КОМПАС-3D

Установка и защита

Требования к аппаратным средствам

Порядок установки

Защита от несанкционированного использования

Новые возможности

Общее

Трехмерное моделирование

Черчение. Оформление чертежей

Работа с текстом

Работа со спецификациями

Печать

Импорт и экспорт

Приложения

Дополнительные сведения

Информация о версии

Информация об установке

Лицензионное соглашение

Справка API КОМПАС-3D

Информация в Интернете

Сайт АСКОН

Сайт КОМПАС-3D

Форум пользователей

Сайт технической поддержки

База знаний (FAQ)


Добро пожаловать!

Компания АСКОН благодарит вас за приобретение системы КОМПАС-3D и надеется, что она будет верным и надежным помощником в вашей повседневной работе и позволит значительно расширить круг задач, решаемых на вашем предприятии при помощи САПР.

Основная задача, решаемая системой КОМПАС-3D — моделирование изделий с целью существенного сокращения периода проектирования и скорейшего их запуска в производство. Эти цели достигаются благодаря возможностям:

– быстрого получения конструкторской и технологической документации, необходимой для выпуска изделий (сборочных чертежей, спецификаций, деталировок и т.д.),

– передачи геометрии изделий в расчетные пакеты,

– передачи геометрии в пакеты разработки управляющих программ для оборудования с ЧПУ,

– создания дополнительных изображений изделий (например, для составления каталогов, создания иллюстраций к технической документации и т.д.).

Основные компоненты КОМПАС-3D:

– Система трехмерного моделирования

Предназначена для создания трехмерных параметрических моделей отдельных деталей и сборочных единиц, содержащих как оригинальные, так и стандартизованные конструктивные элементы. Параметрическая технология позволяет быстро получать модели типовых изделий на основе однажды спроектированного прототипа. Многочисленные сервисные функции облегчают решение вспомогательных задач проектирования и обслуживания производства.

– Чертежно-графический редактор (КОМПАС-График)

Предназначен для автоматизации проектно-конструкторских работ в различных отраслях деятельности. Он может успешно использоваться в машиностроении, архитектуре, строительстве, составлении планов и схем — везде, где необходимо разрабатывать и выпускать графические и текстовые документы.

– Модуль проектирования спецификаций

Используется совместно с Системой трехмерного моделирования и/или Чертежно-графическим редактором. Модуль позволяет выпускать разнообразные спецификации, ведомости и прочие табличные документы.

Документ-спецификация может быть ассоциативно связан со сборочным чертежом (одним или несколькими его листами) и трехмерной моделью сборки.

– Текстовый редактор

Предназначен для разработки различного рода текстовой документации. Возможно как стандартное, так и произвольное оформление документов.

Мы уверены, что вы сделали правильный выбор, начав сотрудничество с компанией АСКОН — одной из лидирующих фирм в области разработки систем автоматизированного проектирования!


Техническая поддержка и сопровождение

При возникновении каких-либо проблем с установкой и эксплуатацией программных продуктов компании АСКОН рекомендуем придерживаться такой последовательности действий.

– Обратитесь к документации по системе и попробуйте найти сведения об устранении возникших неполадок.

– Обратитесь к интерактивной Справочной системе.

– По возможности посетите Сайт Службы технической поддержки компании АСКОН, содержащий ответы на часто возникающие у пользователей вопросы.

Сайт Службы технической поддержки в Интернет:

http://support.ascon.ru

Вы также можете обратиться в Интернет-конференцию пользователей ПО АСКОН. В ней пользователи обмениваются заметками о проблемах, с которыми они столкнулись, а также своими советами и подсказками.

Форум пользователей ПО АСКОН:

http://forum.ascon.ru

– Если указанные источники не содержат рекомендаций по возникшей проблеме, прибегните к услугам технического персонала вашего поставщика программных продуктов компании (дилера АСКОН).

– В том случае, если специалисты вашего поставщика не смогли помочь в разрешении проблемы, свяжитесь непосредственно с офисом АСКОН.

Перед обращением подготовьте, пожалуйста, подробную информацию о возникшей ситуации и ваших действиях, приведших к ней, а также о конфигурации используемого компьютера и периферийного оборудования.

198095, Санкт-Петербург, а/я 7

тел./факс: (812)703-39-34

E-mail: info@ascon.ru

Web-сервер:

http://ascon.ru


Как работать со Справочной системой

Основные разделы Справочной системы перечислены в Содержании. Оно расположено на соответствующей вкладке в левой части окна, появляющегося на экране сразу после вызова справки.

Разделы и входящие в них подразделы представлены в оглавлении в виде пиктограмм («книжек» и «страниц»). Чтобы увидеть содержимое раздела, дважды щелкните мышью на его пиктограмме или выделите его название и нажмите клавишу <Enter>. Повторение этого действия приведет к сворачиванию содержимого раздела в окне содержания. Для просмотра нужного подраздела щелкните мышью на его названии.

Для поиска разделов справочной системы по ключевым словам активизируйте вкладку Указатель. В ней вы можете выбрать из предложенного списка ключевое слово или фразу. Для ускорения поиска можно ввести в соответствующем поле первые буквы искомого ключевого слова. После выбора ключевого слова дважды щелкните на нем мышью или выделите его и нажмите кнопку Показать. На экране появится раздел Справочной системы, который ассоциирован с выбранным ключевым словом. Если таких разделов несколько, на экране появится диалог со списком их названий; выберите в нем нужный раздел и нажмите кнопку Показать.

Если список ключевых слов не содержит нужного слова или выражения, можно произвести полнотекстовый поиск. В этом случае будут найдены разделы, текст которых содержит введенное слово (или фразу). Для полнотекстового поиска активизируйте вкладку Поиск, введите слово (слова) для поиска и нажмите клавишу <Enter> или кнопку Разделы. В списке появится перечень разделов Справочной системы, содержащих заданное слово или слова. Для просмотра нужного раздела дважды щелкните мышью на его названии или нажмите кнопку Показать.

Вы можете изменить ширину области, содержащей вкладки выбора раздела. Для этого «перетащите» мышью границу, отделяющую ее от области просмотра раздела. Чтобы отключить отображение этой области в окне справки, нажмите кнопку Скрыть на инструментальной панели окна справки.

Как правило, разделы содержат ссылки на другие разделы. Для их вызова нужно щелкнуть мышью по выделенному цветом термину или названию раздела.

Признаком возможности вызова другого раздела является появление курсора [image] при прохождении его над текстом ссылки или термина. Для последовательного перебора подсказок и ссылок в разделе пользуйтесь клавишей <Tab>.

Замечания, советы и особенно важные сведения выделены цветным фоном, горизонтальными линейками и отмечены следующими значками:

— Замечание, [image] — Совет, [image] — Внимание!

Отображение рисунков и воспроизведение анимации в Справочных системах формата HTMLHelp (файлах *.chm) подчиняется настройке, сделанной в Windows Internet Explorer. Чтобы рисунки были видны и анимация воспроизводилась, в диалоге Свойства обозревателя на вкладке Дополнительно в разделе Мультимедиа должны быть включены опции Воспроизводить анимацию на веб-страницах и Отображать рисунки. Для вызова диалога служит команда Сервис — Свойства обозревателя...

Смотрите также

Как получить справку при работе

Использование всплывающих подсказок


Новые возможности

– Общее

– Трехмерное моделирование

– Черчение. Оформление чертежей

– Работа с текстом

– Работа со спецификациями

– Печать

– Импорт и экспорт

– Приложения


Общее

Новые возможности

Общее

1. Переработаны обучающие материалы по КОМПАС-3D. Теперь они представлены двумя пособиями:

– Азбука КОМПАС-3D — рассчитана на пользователя, не имеющего или имеющего небольшой опыт работы в КОМПАС-3D;

– Приемы работы в КОМПАС-3D — рассчитаны на достаточно уверенное владение КОМПАС-3D, способность пользователя самостоятельно изучать его.

К каждому уроку прилагаются файлы, необходимые для его выполнения, а также файлы с образцом результата урока. Команды, запускающие пособия, находятся в меню Справка — Азбуки и приемы.

2. Появилась возможность использования кодов документов ЛУ (Лист утверждения) и УЛ (Информационно-удостоверяющий лист). Эти коды находятся в разделе Дополнительные коды диалога Коды и наименования.

Если документ должен иметь два кода, например, СБ-ЛУ, то разделитель и второй код необходимо вводить вручную.


Трехмерное моделирование

Новые возможности

Трехмерное моделирование

1. Появилась возможность вставки в сборку компонентов, зеркально симметричных имеющимся или симметрично расположенных относительно имеющихся.

– Зеркально симметричный компонент может представлять собой:

• зеркальное исполнение исходного, созданное в файле исходного,

• зеркальную модель в отдельном файле,

• зеркально отраженную вставку исходного компонента.

Зеркальное исполнение и зеркальная модель имеют левые системы координат.

– Симметрично расположенный компонент представляет собой новую вставку исходного, расположенную так, чтобы определенная ее точка или плоскость была симметрична соответствующей точке/плоскости в исходном компоненте.
Доступен дополнительный вариант размещения для групп компонентов, которые должны сохранять взаимное положение.

Для создания зеркальных и симметричных компонентов служит команда Зеркальное отражение компонентов. После ее вызова производится указание исходных компонентов и плоскости симметрии, а также настройка параметров отражения/размещения. Зеркальные и симметричные компоненты автоматически связываются с исходными сопряжениями Симметрия и Зависимое положение (для групп компонентов, сохраняющих взаиморасположение).

Зеркальное отражение — один из способов добавления компонентов в модель, поэтому после его выполнения в Дереве модели появляются новые компоненты и сопряжения (а не операция Зеркальное отражение компонентов).

Создание зеркального исполнения модели, преобразование правой системы координат в левую и наложение на компоненты сопряжений Симметрия или Зависимое положение возможно также вручную, т.е. без вызова команды Зеркальное отражение компонентов.

2. Расширен функционал работы с листовыми телами.

– В команде Обечайка появилась возможность сегментации криволинейных участков контура, т.е. замены их аппроксимирующими ломаными. В результате каждый сгиб обечайки заменяется набором сгибов. Сегментация доступна для окружностей и дуг. Возможен выбор способа сегментации:

• По количеству сегментов — задается количество сегментов ломаной,

• По длине сегмента — задается максимальная длина сегмента ломаной,

• По углу сегмента — задается максимальный центральный угол дуги сегмента,

• По линейному отклонению сегмента — задается максимальное расстояние между дугой сегмента и сегментом ломаной.

Настройка сегментации производится на вкладке Панели свойств Сегментация.

Кроме этого, при построении обечайки с уклоном теперь можно указать, какую форму должны иметь автоматически создаваемые в углах контура сгибы — цилиндр или конус. Для этого следует нажать нужный переключатель: С постоянным радиусом или С переменным радиусом в группе переключателей Тип на Панели свойств.

– Добавлена команда Линейчатая обечайка — аналог обычной обечайки, но не по одному, а по двум основаниям. Основания должны быть заданы эскизами произвольной формы, лежащими в разных плоскостях. Дополнительная по сравнению с обычной обечайкой возможность — настройка разбиения поверхности обечайки на грани, т.е. создание/удаление/перемещение ребер как при построении линейчатой поверхности.

Сегментация сгибов линейчатой обечайки не предусмотрена.

– Доработана команда Сгиб:

• Появилась возможность выбора способа построения: На расстояние, До вершины, До поверхности (прежний порядок создания сгиба соответствовал варианту На расстояние).

• Стало возможным задание длины отдельно для каждой из боковых сторон продолжения сгиба. Для перехода к данному варианту построения следует включить на Панели свойств опцию По 2 сторонам.

– Доработана команда Замыкание углов:

• На Панели свойств появилась опция Единые параметры, позволяющая применить текущие параметры замыкания ко всем замыкаемым сгибам (ранее смена параметров замыкания выполнялась для каждого сгиба в отдельности).

• В список Обработка угла добавлен вариант Круговая. Данный способ обработки предусматривает построение круглого отверстия в месте стыка замыкаемых сгибов. Пользователь может задать точное положение отверстия и его диаметр.

– Появилась возможность копирования свойств между однотипными листовыми элементами при их построении/редактировании. Так, например, в создаваемый сгиб можно скопировать значения радиуса и угла из другого, уже существующего, сгиба. Для этого служит кнопка Копировать свойства на Панели специального управления.

– В полях ввода линейных и угловых величин на Панели свойств при построении сгибов и отверстий в листовом теле теперь доступно меню геометрического калькулятора. Оно содержит следующие команды:

• при вводе линейных величин:

- Длина ребра,

- Расстояние между объектами,

- Диаметр,

- Радиус,

• при вводе угловых величин:

- Направление объекта,

- Раствор дуги,

- Между двумя объектами.

Кроме того, в данном меню присутствует команда Копировать свойство, позволяющая присвоить редактируемому параметру такое же значение, как в другом элементе.

3. В настроечном диалоге, появляющемся при сохранении сборки как детали и при удалении истории построения модели, появились опции:

– Учитывать скрытые компоненты — управляет обработкой скрытых компонентов; если опция отключена, то скрытые компоненты считаются отсутствующими.

– Объединить тела и компоненты в одно тело — включает вариант преобразования, при котором все тела и компоненты, имеющие общие поверхности или объемы, сливаются в одно. Если полученное тело имеет полости, то они заполняются материалом. Если тела и компоненты не имеют общих поверхностей, то создается тело из частей.

4. Появилась возможность быстрого выбора компонентов в сборке на основе их расположения относительно габаритов других компонентов. Для выбора компонентов по габариту нужно сначала выделить компоненты, определяющие габарит, а затем вызывать команду Выделить — По габариту — Компоненты внутри габарита либо Выделить — По габариту — Компоненты вне габарита.

5. В сборке изменен состав контекстного меню выделенного примитива — ребра, вершины или грани. Из меню исключены команды, относящиеся к операции (Редактировать эскиз, Редактировать исходный элемент и др.), а включены команды, относящиеся к компоненту (Разместить компонент, Изменить тип загрузки и др.). При этом команды действуют на компонент первого уровня (несмотря на то, что выделенный примитив может принадлежать компоненту более низкого уровня). Таким образом, в окне модели теперь можно выполнять практически те же действия с компонентами первого уровня, что и в Дереве построения. Это делает более удобной работу с большими сборками.

6. Свойства, Обозначение, Наименование, Автор и другие (т.е. свойства, включаемые в отчет) стали доступны для изменения в окне Свойства для модели в целом (корневого элемента Дерева) и компонентов, в том числе вставленных из библиотек.Библиотечные компоненты могут также иметь другие доступные для редактирования в окне Свойства параметры (если это предусмотрено библиотекой).


Черчение. Оформление чертежей

Новые возможности

Черчение. Оформление чертежей

1. Появилась команда Коническая кривая, позволяющая строить конические кривые путем указания конечных точек т1 и т2, касательных в них и точки на кривой либо коэффициента. Касательные могут быть заданы указанием точки их пересечения — в этом случае они строятся как прямые, проходящие через указанную точку и точки т1и т2. Также точки т1 и т2 могут быть указаны на существующих объектах — в этом случае касательной к конической кривой становится касательная к объекту в указанной точке.

2. При создании в чертеже ассоциативного вида модели, являющейся зеркальным исполнением другой, уже спроецированной в этот чертеж модели, к видам добавляются надписи следующего содержания:

– для вида исходного исполнения: «[обозначение исходного исполнения]»,

– для вида зеркального исполнения: «[обозначение зеркального исполнения] –зеркальное отражение. Остальное – см. [обозначение исходного исполнения]».

Наличие таких надписей — требование стандарта. Пользователь может включить/отключить их создание и настроить их содержание на вкладке Надпись диалога, вызываемого командой Сервис — Параметры... — Текущий чертеж — Параметры документа — Вид (для новых документов — Сервис —Параметры... — Новые документы — Графический документ —Параметры документа — Вид).

3. Появилась возможность задания длины продолжения размерных линий размеров: в диалог настройки параметров отрисовки размеров добавлено поле выход размерных линий за выносную.


Работа с текстом

Новые возможности

Работа с текстом

1. Появилась возможность создания зеркально отраженного текста в графических документах и эскизах. Для этого служит опция Зеркальное отражение на вкладке Размещение Панели свойств при создании надписи.

Управление видом текста при выполнении команды Симметрия производится с помощью опции Зеркально отразить тексты. При включенной опции тексты зеркально отражаются, при отключенной — сохраняют вид.

2. Теперь можно настроить количество и расположение характерных точек для перемещения надписи (отображаются при ее выделении) в графическом документе и эскизе. Доступно три варианта, в том числе с расположением точек по углам и в серединах сторон габаритного прямоугольника надписи. Настройка выполняется в диалоге, вызываемом командой Сервис —Параметры — Система — Графический редактор — Характерные точки.


Работа со спецификациями

Новые возможности

Работа со спецификациями

1. Теперь при открытии спецификации не производится ее автоматическая актуализация, а лишь выполняется проверка соответствия между спецификацией и подключенными к ней документами. Если обнаружено рассогласование, то спецификация отображается перечеркнутой пунктирными линиями и выдается запрос на перестроение спецификации. Пользователь может:

– Подтвердить перестроение — связанные со спецификацией чертежи и сборки, которые на данный момент не актуальны, перестраиваются, после чего данные из них передаются в спецификацию.

– Отказаться от перестроения — ни спецификация, ни подключенные к ней документы не изменяются; спецификация остается перечеркнутой, но это не мешает ее редактированию и печати. При необходимости спецификацию можно перестроить позже — с помощью команды Вид — Перестроить.

Запрос на перестроение спецификации может появляться не только при открытии спецификации, но и при работе с ней, если в подключенных документах произошли изменения, требующие передачи в спецификацию.

2. Добавлены настройки, управляющие автоматическим обновлением и сохранением документов, подключенных к спецификации. Данные настройки производятся на вкладке Система общего настроечного диалога, в разделе Редактор спецификаций — Параметры обновления документов. Этот раздел содержит две опции (по умолчанию включены):

– При перестроении спецификации сохранять подключенные документы, открытые в «слепом» режиме — если включена, то подключенные к спецификации документы, которые при ее перестроении были открыты в «слепом» режиме и перестроены, записываются на диск немедленно и безусловно, а если отключена, то эти документы записываются только после сохранения спецификации и не записываются в случае закрытия спецификации без сохранения.

– При сохранении спецификации передавать данные в подключенные документы — если включена, то при сохранении спецификации производится автоматическая передача данных из нее в подключенные документы, если отключена, то передача не производится ни при сохранении спецификации, ни при вызове команды Синхронизация.

3. Появилась возможность сортировки объектов в разделах спецификации более чем по одной колонке. Пользователь может задать список колонок, по которым производится сортировка, и тип сортировки в каждой из них. Сортировка по колонкам выполняется в том порядке, в котором они перечислены в списке. Данная настройка производится на новой вкладке Сортировка диалога редактирования стиля раздела спецификации. Эта вкладка содержит опцию Объекты в разделе сортировать (перенесена с вкладки Настройки) и список колонок с указанием типов сортировки.

4. Появилась возможность управления порядком сортировки объектов спецификации по коду в разделе Документация. Для этого в подпапку \Sys главной папки системы добавлен файл GRAPHIC.KDSP, содержащий перечень кодов документов в том порядке, в котором они должны следовать в разделе Документация согласно стандарту. Формат файла текстовый, т.е., отредактировав данный файл, пользователь может изменить умолчательную сортировку — например, в случае использования нестандартного кода. Ранее сортировка по коду производилась согласно порядку следования кодов в файле GRAPHIC.KDS.


Печать

Новые возможности

Печать

1. Теперь для печати многолистового документа из главного окна (т.е. через диалог Печать документа, без входа в предварительный просмотр) достаточно, чтобы листы имели одинаковый размер. Ранее требовалась также одинаковая ориентация.

2. В режиме предварительного просмотра перед печатью появилась команда Масштаб по выделенным листам. После ее вызова выделенные листы отображаются полностью в максимально возможном масштабе.

3. При автоподгонке листы документов теперь могут автоматически поворачиваться на 90°, если это необходимо для выполнения подгонки, т.е. оптимизации размещения документов на бумаге. Ранее автоподгонка выполнялась лишь за счет изменения масштаба листов.

4. Теперь после выполнения в предварительном просмотре операций, изменяющих количество страниц печати, на экране отображаются не все листы, как раньше, а те же, что были видны на момент запуска операции.


Импорт и экспорт

Новые возможности

Импорт и экспорт

1. В диалог настройки чтения файлов формата DXF или DWG на вкладку Данные добавлена опция Границы видовых экранов по габаритам. Если она включена, то форма видовых экранов импортируемого документа упрощается до габаритных прямоугольников. В результате, если видовые экраны не прямоугольные, в КОМПАС-документе могут оказаться «лишние» объекты, не отображавшиеся в исходном документе из-за того, что находились за пределами видовых экранов. При отключенной опции форма видовых экранов не упрощается, но обработка документа может занимать большее время.

2. Теперь возможен импорт файлов Parasolid до 25-ой версии формата включительно.

3. Исключена возможность записи КОМПАС-документов в формат WMF.


Приложения

Новые возможности

Приложения

1. Доработана библиотека Сервисные инструменты.

– Добавлена команда Символы вдоль кривой. Она позволяет расположить введенные символы (они должны быть разделены пробелами) вдоль указанной кривой. Доступны следующие настройки:

• выбор участка кривой,

• задание смещения — расстояния между кривой и символами,

• выбор направления,

• выбор ориентации — каждый символ под определенным углом к касательной в соответствующей точке кривой или все символы под одним и тем же углом к горизонтали.

– При построении отверстия, связанного с кривой, появилась возможность задания угла наклона оси отверстия к горизонтали (ранее связанное с кривой отверстие располагалось по нормали к ней). Для ввода значения угла на Панель свойств добавлено поле Угол, а для возврата к ориентации отверстия по нормали к кривой — опция По нормали.

2. Доработана библиотека Стандартные изделия.

– Появилась возможность вставлять в чертеж конструктивные элементы с размерами.

– В каталог Крепеж добавлены:

• Пружины ГОСТ 13766-86, ГОСТ 13767-86, ГОСТ 13768-86, ГОСТ 13769-86, ГОСТ 13770-86, ГОСТ 13771-86, ГОСТ 13772-86, ГОСТ 13773-86, ГОСТ 13774-86, ГОСТ 13775-86, ГОСТ 13776-86.

– В каталог Детали, узлы и конструктивные элементы добавлены:

• Фланцы ASME B 16.5,

• Фитинги трубопроводов ASME B 16.9,

• Фитинги ASME B 16.11,

• Фланцы ГОСТ Р 54432–2011,

• Прокладки ГОСТ Р 53561–2009, ГОСТ Р 52376–2005.

3. В приложение Распознавание 3D-моделей добавлены команды, позволяющие перед распознаванием модели удалить некоторые ее элементы (например, фаски, скругления, мелкие отверстия):

– Удаление граней — служит для удаления произвольных граней. Перед вызовом команды необходимо выделить одну или несколько смежных граней.

– Удаление мелких элементов — служит для автоматического поиска и удаления мелких элементов. Мелким считается элемент, размер которого не превышает заданный при настройке приложения (в процентах от диагонали габаритного параллелепипеда модели).

Если удаление части модели, содержащей указанные грани, или найденных мелких элементов без нарушения целостности модели возможно (т.е. прилежащие грани могут быть модифицированы так, чтобы тело оставалось целым), то они удаляются.

Основное назначение команд Удаление граней и Удаление мелких элементов — упрощение геометрии модели для последующего распознавания или анализа с помощью расчетных программ.

4. Доработано приложение Комплектовщик документов КОМПАС-3D: теперь можно управлять добавлением в комплект файлов-источников копий геометрии и компоновочной геометрии. Для этого служат опции Включить в комплект источники копий геометрии и Включить в комплект источники компоновочной геометрии диалога приложения.

5. Доработана APM FEM, система прочностного анализа для КОМПАС-3D.

– Добавлен расчет собственных частот для 10 узловых тетраэдров.

– Добавлен новый объект Закрепление по нормали.

– Добавлен режим построения карты результатов с возможностью вывода результатов выше, ниже или между двумя пользовательскими значениями.

– Добавлен режим построения карты результатов в виде одной изоповерхности.

– Добавлены новые методы расчетов:

• статический расчет: MT_Frontal, IterMinRes;

• расчет устойчивости: Ланцош, FEAST, Поиск корней детерминанта (Sparse);

• расчет собственных колебаний: Итерации подпространств (Sparse), Итерации подпространств (Sparse) без ортогонализации, Ланцош.

6. Дополнена и актуализирована база данных библиотеки Материалы и Сортаменты.

– Общее количество материалов составляет более 10800 наименований. В том числе:

• 1470 отечественных марок сталей и сплавов;

• 2393 зарубежные марки сталей и сплавов;

• 145 марок чугуна;

• 1145 марок цветных металлов и сплавов;

• 263 наименования легирующих сплавов;

• 449 марок масел и смазок;

• 225 марок лаков и красок;

• 602 марки пластмасс;

• 474 марки клеев;

• 1400 наименований сварочных материалов;

• 612 наименований проводов и кабелей;

• 346 наименований строительных материалов;

• 132 вида гальванических покрытий;

• 196 наименований композиционных материалов.

– Произведена замена устаревших документов:

• документ ГОСТ 1050–88 Прокат сортовой калиброванный, со специальной отделкой поверхности из углеродистой качественной конструкционной стали. Общие технические условия заменен документом ГОСТ 1050–2013 Металлопродукция из нелегированных конструкционных качественных и специальных сталей. Общие технические условия;

• документ ГОСТ 19281–89 Прокат из стали повышенной прочности заменен документом ГОСТ 19281–2014 Прокат повышенной прочности (при замене документа добавлено 48 наименований материалов).

– В базу данных добавлены новые документы и материалы, требования к которым регламентируются ими. Это следующие документы:

• ГОСТ 28378–89 Материалы конструкционные порошковые на основе железа. Марки (36 наименований материалов);

• ГОСТ 26802–86 Материалы антифрикционные порошковые на основе железа. Марки (33 наименования материалов);

• ГОСТ 1415–93 Ферросилиций. Технические требования и условия поставки (21 наименование материалов);

• ГОСТ 4756–91 Ферросиликомарганец. Технические требования и условия поставки (18 наименований материалов);

• ГОСТ 4757–91 Феррохром. Технические требования и условия поставки (42 наименования материалов).


1.1. Установка системы

В этом разделе:

1.1.1. Требования к аппаратным средствам

1.1.2. Состав инсталляционного пакета КОМПАС-3D

1.1.3. Установка, запуск и удаление КОМПАС-3D

1.1.3.1. Установка Базового пакета

1.1.3.1.1. Особенности установки Прикладной библиотеки КОМПАС-Макро

1.1.3.1.2. Подготовка к работе с библиотекой Материалы и Сортаменты

1.1.3.2. Установка конфигураций

1.1.3.3. Установка шрифтов

1.1.3.4. Устранение возможных проблем

1.1.3.4.1. Установка системы, обновлений, восстановление установки

1.1.3.4.2. Отображение КОМПАС-документов

1.1.3.5. Установка ключа аппаратной защиты

1.1.3.6. Запуск КОМПАС-3D

1.1.3.7. Удаление КОМПАС-3D


1.1.1. Требования к аппаратным средствам

1.1. Установка системы

1.1.1. Требования к аппаратным средствам

КОМПАС-3D предназначен для использования на персональных компьютерах типа IBM PC, работающих под управлением русскоязычных (локализованных) либо корректно русифицированных операционных систем (табл. 1.1.1).

Табл. 1.1.1. Поддерживаемые операционные системы
ОС | 32-разрядная версия КОМПАС-3D | 64-разрядная версия КОМПАС-3D
MS Windows 8.1 | + | +
MS Windows 8 | + | +
MS Windows 7 SP1 и выше | + | +
MS Windows Vista SP2 и выше | + | +
MS Windows XP SP3 (32-разрядная) | + |

64-разрядная версия КОМПАС-3D может быть установлена только на компьютер с 64-разрядной версией операционной системы.

Обязательным условием работоспособности КОМПАС-3D и конфигураций является поддержка центральным процессором инструкций SSE2. По остальным параметрам минимально возможная конфигурация компьютера для установки и запуска КОМПАС-3D соответствует минимальным системным требованиям для соответствующих операционных систем.

Объем свободного пространства на жестком диске, необходимый для установки, приведен в табл. 1.1.2.

Табл. 1.1.2. Необходимый объем свободного пространства на жестком диске
Устанавливаемая часть инсталляционного пакета | 32-разрядная версия КОМПАС-3D | 64-разрядная версия КОМПАС-3D
Базовый пакет | 2 ГБ | 2,1 ГБ
Машиностроительная конфигурация | 800 МБ | 1 ГБ
Строительная конфигурация | 2,1 ГБ | 2 ГБ
Приборостроительная конфигурация | 200 МБ | 200 МБ

Для установки с дистрибутивного диска требуется привод DVD-ROM.

Для получения бумажных копий документов могут использоваться любые модели принтеров и плоттеров, для которых имеются драйверы, разработанные к установленной на вашем компьютере версии Windows.

При подборе конфигурации следует иметь в виду, что требования к компьютеру возрастают с увеличением сложности задач (насыщенности чертежей, сложности сборок).

Скорость работы КОМПАС-3D на конкретном компьютере зависит также от характеристик отдельных его комплектующих (процессора, оперативной памяти и др.). За информацией об оптимальных вариантах конфигурации компьютера вы можете обратиться к вашему поставщику.


1.1.2. Состав инсталляционного пакета КОМПАС-3D

1.1. Установка системы

1.1.2. Состав инсталляционного пакета КОМПАС-3D

Инсталляционный пакет состоит из следующих частей.

– Базовая часть инсталляционного пакета КОМПАС-3D (далее — Базовый пакет).

– Машиностроительная конфигурация для КОМПАС-3D. Она включает в себя служебные файлы и библиотеки, необходимые для использования КОМПАС-3D в машиностроительном проектировании.

– Строительная конфигурация для КОМПАС-3D. Она включает в себя служебные файлы и библиотеки, необходимые для использования КОМПАС-3D в промышленно-строительном проектировании.

– Приборостроительная конфигурация для КОМПАС-3D. Она включает в себя служебные файлы и библиотеки, необходимые для использования КОМПАС-3D в приборостроительном проектировании.


1.1.3. Установка, запуск и удаление КОМПАС-3D

1.1. Установка системы

1.1.3. Установка, запуск и удаление КОМПАС-3D

Установка системы КОМПАС-3D на компьютер производится в следующем порядке.

1. Установка Базового пакета. На этом же этапе устанавливаются программы ключа защиты.

2. При необходимости — установка одной или нескольких конфигураций.

3. Установка ключа аппаратной защиты в USB-порт компьютера.

На время установки системы КОМПАС-3D рекомендуется выключать антивирусные программы и сетевые экраны, например, Брандмауэр Windows.

Защита КОМПАС-3D от несанкционированного использования описана в Приложении VIII.

В этом разделе:

1.1.3.1. Установка Базового пакета

1.1.3.1.1. Особенности установки Прикладной библиотеки КОМПАС-Макро

1.1.3.1.2. Подготовка к работе с библиотекой Материалы и Сортаменты

1.1.3.2. Установка конфигураций

1.1.3.3. Установка шрифтов

1.1.3.4. Устранение возможных проблем

1.1.3.4.1. Установка системы, обновлений, восстановление установки

1.1.3.4.2. Отображение КОМПАС-документов

1.1.3.5. Установка ключа аппаратной защиты

1.1.3.6. Запуск КОМПАС-3D

1.1.3.7. Удаление КОМПАС-3D


1.1.3.1. Установка Базового пакета

Чтобы установить Базовый пакет на жесткий диск вашего компьютера, выполните следующие действия.

1. Запустите Windows и вставьте в привод DVD диск с инсталляционным пакетом КОМПАС-3D. Автоматически запускается оболочка диска (Disk.exe).

2. Запустите из оболочки установку Базового пакета КОМПАС-3D.

3. Следуйте запросам программы установки.

В окне Тип установки укажите требуемый тип установки — Полная или Выборочная (рис. 1.1.1).

Рис. 1.1.1. Выбор типа установки

Первый вариант означает установку на компьютер всех компонентов системы. Второй вариант означает возможность выбора устанавливаемых компонентов (рис. 1.1.2, 1.1.3).

Рис. 1.1.2. Выбор компонентов КОМПАС-3D

Рис. 1.1.3. Выбор программ ключа защиты

Программа установки будет последовательно копировать файлы системы с компакт-диска в указанную папку на жестком диске компьютера, а затем распаковывать их.

4. Если вам по какой-то причине потребуется прервать установку системы, не дожидаясь ее нормального завершения, нажмите кнопку Отмена.

В этом разделе:

1.1.3.1.1. Особенности установки Прикладной библиотеки КОМПАС-Макро

1.1.3.1.2. Подготовка к работе с библиотекой Материалы и Сортаменты


1.1.3.1.1. Особенности установки Прикладной библиотеки КОМПАС-Макро

Чтобы установить Прикладную библиотеку КОМПАС-Макро, необходимо выбрать этот компонент в окне установки системы КОМПАС (рис. 1.1.4).

Рис. 1.1.4. Выбор компонентов системы

При установке Прикладной библиотеки КОМПАС-Макро автоматически на компьютер устанавливается расширение языка Python Pywin32.


1.1.3.1.2. Подготовка к работе с библиотекой Материалы и Сортаменты

Если на компьютере ранее не использовалась библиотека Материалы и Сортаменты (далее — библиотека) в составе КОМПАС-3D, то не требуется выполнять какие-либо действия для подготовки к работе.

Обновление библиотеки из состава КОМПАС-3D V15 и V10–V14 имеет ряд особенностей, которые описаны ниже в соответствующих разделах.

В библиотеке реализована интеграция с системой Технорма/ИнтраДок версии 3.1.15–3.1.125.

Перед началом совместной работы систем необходимо убедиться в том, что клиентская часть системы Технорма/ИнтраДок, включающая в себя модуль просмотра защищенных документов, установлена на компьютере.

В системе Технорма/ИнтраДок возможны два способа аутентификации пользователей: доменная и автономная.

При доменной аутентификации дополнительная настройка интеграции не требуется.

При автономной аутентификации для предоставления пользователю специальных прав на просмотр, печать или сохранение защищенных документов требуется ввести логин и пароль зарегистрированного пользователя системы. Если логин и пароль не указаны, то вход в систему выполняется от имени пользователя Гость (idoc_guest).

Чтобы указать логин и пароль пользователя системы Технорма/ИнтраДок, запустите библиотеку, вызовите команду Сервис — Настройка и введите необходимые данные на вкладке Технорма/ИнтраДок диалога Настройка.

Особенности обновления библиотеки из состава КОМПАС-3D V15

При установке библиотеки из состава КОМПАС-3D V16 происходит замена файла базы данных (MatSort.mdb), по умолчанию расположенного в папке C:\Users\Public\Documents\ASCON (в Windows Vista, Windows 7, Windows 8) или C:\Documents and Settings\All Users\Documents\ASCON (в Windows XP), файлом, содержащимся в дистрибутиве.

Для обеспечения возможности работы с файлом базы данных библиотеки из состава КОМПАС-3D V15 необходимо выполнить следующее:

1. Перед установкой КОМПАС-3D V16 переместите файл базы данных из указанной выше папки в любую произвольную папку;

2. Выполните установку КОМПАС-3D V16;

3. Замените установленный файл базы данных сохраненным в п.1.

После этого необходимо произвести конвертацию базы данных. Для этого запустите файл Materials.exe, расположенный в папке ..\KOMPAS-3D V16\Libs\Materials. Первый запуск библиотеки займет большее, чем обычно, время, так как при этом выполняется преобразование базы данных. Данное преобразование является однократным и при дальнейшей работе повторяться не будет.

Если конвертация не будет проведена, то при вызове библиотеки из системы КОМПАС-3D будет выдано сообщение об ошибке.

После конвертации базы данных рекомендуется выполнить синхронизацию обозначений экземпляров сортаментов при помощи команды Сервис — Проверка данных для устранения возможных задержек в работе библиотеки.

Особенности обновления библиотеки из состава КОМПАС-3D V10–V14

Если ранее на компьютере использовалась библиотека из состава КОМПАС-3D V10–V14, необходимо произвести конвертацию базы данных. Для этого запустите файл Materials.exe, расположенный в папке ..\KOMPAS-3D V16\Libs\Materials. Первый запуск библиотеки с подключенной базой данных предыдущей версии займет большее, чем обычно, время, так как при этом выполняется преобразование базы данных. Данное преобразование является однократным и при дальнейшей работе повторяться не будет.

Если конвертация не будет проведена, то при вызове библиотеки из системы КОМПАС-3D будет выдано сообщение об ошибке.

После конвертации базы данных рекомендуется выполнить синхронизацию обозначений экземпляров сортаментов при помощи команды Сервис — Проверка данных для устранения возможных задержек в работе библиотеки.

Если нет необходимости использовать «старую» базу данных, необходимо перенастроить библиотеку на использование базы, входящей в состав КОМПАС-3D V16.

Это можно сделать двумя способами:

– Запустить программу настройки библиотеки MaterialsCfg.exe из папки ..\KOMPAS-3D V16\Libs\Materials. В открывшемся окне нужно указать путь к базе данных. По умолчанию база данных библиотеки устанавливается в папку

• C:\Users\Public\Documents\ASCON (в Windows Vista, Windows 7, Windows 8)

или

• C:\Documents and Settings\All Users\Documents\ASCON (в Windows XP)

– Удалить из профиля пользователя конфигурационный файл библиотеки config.xml, расположенный в папке

• C:\Users\%UserName%\AppData\Roaming\ASCON\Materials (в Windows Vista, Windows 7, Windows 8)

или

• C:\Documents and Settings\%UserName%\Application Data\ASCON\Materials (в Windows XP).

Для редактирования данных библиотеки у пользователя должны быть права на изменение папки, в которой находится файл базы данных.


1.1.3.2. Установка конфигураций

После установки Базового пакета можно приступать к установке конфигураций. Вы можете установить одну, несколько или все конфигурации. Порядок установки конфигураций не имеет значения.

Установка конфигураций при отсутствии на компьютере установленного Базового пакета невозможна.

Чтобы установить конфигурацию, выполните следующие действия.

1. Запустите установку нужной конфигурации из оболочки диска с инсталляционным пакетом КОМПАС-3D.

2. Далее следуйте запросам программы установки.

Выбрав тип установки Выборочная, вы сможете указать в диалоговом окне те из входящих в конфигурацию библиотек, которые требуется установить на компьютер.

Чтобы использовать профиль, соответствующий устанавливаемой конфигурации, включите опцию Применить <название конфигурации> настройки. Если опция включена, то после установки конфигурации КОМПАС-3D будет настроен для использования соответствующей системы стандартов. Например, после применения машиностроительных настроек новые чертежи будут оформляться согласно требованиям ЕСКД, а после применения строительных настроек — согласно требованиям СПДС.

Текущий профиль можно сменить во время работы с КОМПАС-3D с помощью команды Сервис — Профили....

3. Если вам по какой-то причине потребуется прервать установку конфигурации, не дожидаясь ее нормального завершения, нажмите кнопку Отмена.

При установке конфигураций файлы автоматически размещаются в папках, созданных при установке Базового пакета.

Не имеет смысла устанавливать не оплаченные вами модули, библиотеки или приложения: так как лицензии для них не предусмотрены, работать они не будут.


1.1.3.3. Установка шрифтов

При установке системы КОМПАС-3D автоматически устанавливаются шрифты, необходимые для оформления КОМПАС-документов (см. табл. 1.1.3):

– шрифты, содержащие символы, начертание которых соответствует ГОСТ 2.304–81 «ЕСКД. Шрифты чертежные»,

– шрифты, содержащие спецсимволы.

Файлы шрифтов копируются в системную папку Fonts.

Табл. 1.1.3. Шрифты КОМПАС-3D
 | TrueType шрифты | Векторные шрифты
 | имя шрифта; имя файла | имя шрифта; имя файла
ГОСТ 2.304–81 «ЕСКД. Шрифты чертежные» | GOST type A; gost_a.ttf | GOST type A (plotter); gost_a.fon
 | GOST type B; gost_b.ttf | GOST type B (plotter); gost_b.fon
 | GOST type AU, Юникод-шрифт; gost_au.ttf) |
 | GOST type BU, Юникод-шрифт; gost_bu.ttf |
Спецсимволы | Symbol type A; symbol_a.ttf | Symbol type A; symbol_a.fon
 | Symbol type B; symbol_b.ttf | Symbol type B; symbol_b.fon


1.1.3.4. Устранение возможных проблем

В этом разделе:

1.1.3.4.1. Установка системы, обновлений, восстановление установки

1.1.3.4.2. Отображение КОМПАС-документов


1.1.3.4.1. Установка системы, обновлений, восстановление установки

1. На время установки рекомендуется отключить все установленные на компьютере защитные средства, такие как антивирус и межсетевой экран (например, Брандмауэр Windows).

2. В процессе установки системы, ее обновления или восстановления установки могут возникнуть проблемы, обусловленные особенностями контроля учетных записей пользователя (UAC). Поэтому, если контроль учетных записей пользователя на компьютере включен, рекомендуется отключить его на время установки, обновления или восстановления, а после выполнения задачи — включить снова.

3. При установке КОМПАС-3D или конфигурации может возникнуть сообщение о прекращении работы Установщика Windows® Installer. Причиной этого может быть устаревшая версия Windows® Installer (ниже 4.5). Для получения дополнительных сведений и загрузки обновления Windows® Installer посетите сайт Microsoft:

http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=8483

После обновления Windows® Installer снова запустите установку КОМПАС-3D или конфигурации.

4. КОМПАС-3D требует наличия на компьютере установленного Microsoft NET Framework версии 4.0 или более поздней. Необходимо, чтобы перед началом установки КОМПАС-3D на компьютер был установлен Microsoft NET Framework и произведена перезагрузка системы.

Установочный комплект Microsoft .NET Framework (файл dotNetFx40_Client_x86_x64.exe) доступен на дистрибутивном диске КОМПАС-3D.

Кроме того, Microsoft NET Framework можно установить с сайта Microsoft:

http://www.microsoft.com/en-us/download/details.aspx?id=24872


1.1.3.4.2. Отображение КОМПАС-документов

В КОМПАС-3D изображение документов на экране формируется с помощью OpenGL. Отрисовка с помощью OpenGL может производиться с использованием аппаратного ускорения или без него.

Если компьютер, на котором планируется работа с КОМПАС-3D, не обеспечивает требуемую программно-аппаратную поддержку OpenGL, то могут возникать дефекты изображения, сбои в работе КОМПАС-3D.

Ниже приведены возможные пути решения этих проблем.

1. Модернизация ПК, которая может заключаться в следующем:

– замена драйвера видеокарты,

– замена видеокарты и установка соответствующего драйвера.

Не гарантируется стабильная работа на встроенных (расположенных на материнской плате компьютера) видеокартах. Рекомендуется использовать видеокарты с графическими процессорами:

• NVIDIA:

• Quadro FX 380, 580, 1800 и более новыми;

• GeForce серии 7ХХХ и более новыми;

• ATI (AMD):

• FirePro V5700, V7750, V8700;

• FireGL V5600, V7600, V7700, V8600;

• Radeon серии HD2XXX и более новыми.

Драйвер для видеокарты можно загрузить с сайтов NVIDIA (http://www.nvidia.com/download/index.aspx?lang=ru) и AMD (http://support.amd.com/us/gpudownload/Pages/index.aspx), указав требуемые сведения.

2. Отключение аппаратного ускорения (может привести к снижению скорости отрисовки).

– Для отключения аппаратного ускорения при отображении графических документов вызовите команду Сервис — Параметры — Система — Графический редактор — Управление изображением, отключите опцию Использовать аппаратное ускорение в правой части появившегося диалога, после чего перезапустите КОМПАС-3D.

– Для отключения аппаратного ускорения при отображении моделей вызовите команду Сервис — Параметры — Система — Редактор моделей — Управление изображением, отключите опцию Использовать аппаратное ускорение в правой части появившегося диалога, после чего перезапустите КОМПАС-3D.

3. Отключение использования OpenGL (возможно только для графических документов).

Для этого в КОМПАС-3D вызовите команду Сервис — Параметры — Система — Графический редактор — Управление изображением, отключите опцию Использовать OpenGL в правой части появившегося диалога, после чего перезапустите КОМПАС-3D.


1.1.3.5. Установка ключа аппаратной защиты

Ключ аппаратной защиты необходимо вставить в свободный разъем USB-порта.

Никаких дополнительных действий выполнять не нужно, так как система КОМПАС-3D автоматически проверяет, установлен ли ключ на компьютере.


1.1.3.6. Запуск КОМПАС-3D

Чтобы начать работу с системой, вызовите команду КОМПАС-3D из программной группы АСКОН — КОМПАС-3D V... Эта программная группа создается автоматически при установке системы на жесткий диск.

После запуска КОМПАС-3D автоматически восстанавливает состояние, имевшееся на момент завершения предыдущего сеанса работы (загруженные документы, размер и расположение окон и т.д.).

Если предыдущий сеанс работы был завершен аварийно (сбой электропитания и т.п.) и было включено автосохранение, при запуске будет выполнено восстановление открытых документов по их временным копиям.

После самого первого запуска КОМПАС-3D вы увидите главное окно системы, в котором пока нет ни одного открытого окна документа. Чтобы на экране появились остальные элементы интерфейса, необходимо открыть какой-либо документ (см. раздел 1.3.4.1).

Существует возможность запуска КОМПАС-3D с одновременным открытием документа, например, двойным щелчком по имени файла документа в Проводнике Windows. В этом случае следует иметь в виду ряд особенностей.

После такого запуска к системе КОМПАС-3D не подключаются библиотеки, подключенные на момент завершения предыдущего сеанса работы, и не загружаются открытые в предыдущем сеансе работы документы. Если во время открытого таким способом сеанса были подключены библиотеки и/или открыты документы, информация об этом не сохраняется после завершения сеанса.


1.1.3.7. Удаление КОМПАС-3D

КОМПАС-3D удаляется с компьютера обычным образом — с помощью Панели управления Windows.

При удалении КОМПАС-3D из подпапок главной папки системы удаляются все системные файлы. Подпапки, ставшие в результате этого пустыми, также удаляются.

Не удаляются (остаются на диске в прежних папках) следующие файлы:

– файлы конфигурации *.ini, *.cfg, *.dsk и *.рrj,

– шрифты КОМПАС-3D,

– драйвер ключа аппаратной защиты,

– файлы, сохраненные в главной папке системы и ее подпапках (файлы шаблонов документов, текстовых шаблонов, различных библиотек и т.п.).

Во время работы с КОМПАС-3D пользователь может вносить изменения в любой из входящих в поставку файл библиотеки стилей линий (*.lcs), стилей штриховок (*.lhs) офоpмлений (*.lyt). Кроме того, возможно редактирование пользователем файла пользовательских меню (Graphic.pmn), справочного файла плотностей (Graphic.dns).

При удалении КОМПАС-3D в числе прочих удаляются все библиотеки, входившие в поставку, а также файлы Graphic.pmn, Graphic.dns, находящиеся в подпапке \SYS главной папки системы, вне зависимости от того, редактировались они пользователем или нет. Если по какой-либо причине эти файлы необходимо сохранить, то перед удалением КОМПАС-3D следует создать их резервные копии.


1.2. Интерфейс системы

В этом разделе:

1.2.1. Окно системы

1.2.2. Панели и окна

1.2.2.1. Инструментальные панели

1.2.2.1.1. Компактные панели

1.2.2.1.2. Расширенные панели команд

1.2.2.2. Окна

1.2.2.3. Управление состоянием панелей и окон

1.2.2.3.1. Совмещение окон

1.2.2.3.2. Объединение окна Свойства и Панели свойств

1.2.2.3.3. Автоматическое сворачивание окон

1.2.2.3.4. Команды управления состоянием окна

1.2.2.3.5. Закрепление положения панелей и окон

1.2.3. Управление окнами документов

1.2.3.1. Закладки документов

1.2.3.2. Рабочая область

1.2.4. Контекстные меню и контекстные панели

1.2.5. Значки режимов в окне документа


1.2.1. Окно системы

1.2. Интерфейс системы

1.2.1. Окно системы

КОМПАС-3D — это стандартное приложение Windows. Поэтому рабочий экран, который вы видите после запуска системы и загрузки документа, практически не отличается по своему внешнему виду от окон других приложений (рис. 1.2.1).

Рис. 1.2.1. Элементы интерфейса КОМПАС-3D

Описание элементов интерфейса КОМПАС-3D представлено в таблице 1.2.1.

Табл. 1.2.1. Элементы интерфейса КОМПАС-3D
Название | Описание
Заголовок | Содержит название, номер версии системы, имя текущего документа1, кнопку системного меню, а также кнопки управления окном системы.
Главное меню | Служит для вызова команд системы. Содержит названия страниц меню. Состав Главного меню зависит от типа текущего документа и режима работы системы.
Инструментальные панели | Содержат кнопки вызова команд системы.
Компактная панель | Содержит несколько инструментальных панелей и кнопки переключения между ними (подробнее — см. раздел 1.2.2.1.1). Состав компактной панели зависит от типа активного документа.
Окно переменных | Служит для работы с переменными и выражениями (подробнее — см. раздел 7.1).
Менеджер библиотек | Служит для работы с КОМПАС-библиотеками. Подробнее о Менеджере библиотек рассказано в разделе 11.3.1.
Панель свойств | Служит для настройки объекта при его создании или редактировании (подробнее — см. раздел 1.2.2.1).
Строка сообщений | Содержит сообщения системы, относящиеся к текущей команде или элементу рабочего окна, на который указывает курсор.
Дерево документа | Отражает порядок создания модели (чертежа) и связи между ее элементами и компонентами. Может располагаться только внутри окна документа (подробнее — см. разделы 2.1.2 и 3.7.1.1).
  1. Чтобы выбрать вариант отображения имени файла — полное или короткое, вызовите команду Сервис — Параметры... — Система — Общие — Отображение имен файлов.

Заголовок и Главное меню системы постоянно присутствуют на экране. Отображением остальных элементов интерфейса управляет пользователь. Команды включения и отключения этих элементов расположены в меню Вид — Панели инструментов.


1.2.2. Панели и окна

1.2. Интерфейс системы

1.2.2. Панели и окна

В этом разделе:

1.2.2.1. Инструментальные панели

1.2.2.1.1. Компактные панели

1.2.2.1.2. Расширенные панели команд

1.2.2.2. Окна

1.2.2.3. Управление состоянием панелей и окон

1.2.2.3.1. Совмещение окон

1.2.2.3.2. Объединение окна Свойства и Панели свойств

1.2.2.3.3. Автоматическое сворачивание окон

1.2.2.3.4. Команды управления состоянием окна

1.2.2.3.5. Закрепление положения панелей и окон


1.2.2.1. Инструментальные панели

Все инструментальные панели, по умолчанию присутствующие в окне КОМПАС-3D, можно разделить на две группы.

– Первую группу составляют панели Стандартная, Вид и Текущее состояние. Эти панели содержат кнопки вызова команд для работы с документом в целом (команды сохранения, изменения масштаба и т.п.). Однако лишь некоторые команды являются универсальными и могут использоваться при работе с документом любого типа. Поэтому в зависимости от типа текущего документа состав панелей первой группы изменяется: кнопки «ненужных» в данный момент команд удаляются, а кнопки «нужных» команд добавляются.

– Вторую группу составляют все остальные инструментальные панели. Они содержат кнопки вызова команд для создания и редактирования объектов, присущих конкретному типу документа. Кнопки на панелях сгруппированы по назначению и образуют расширенные панели команд (см. раздел 1.2.2.1.2).
Панели второй группы для каждого типа документа объединены в системную компактную панель (о компактных панелях см. раздел 1.2.2.1.1).

Типы объектов определяются типом документа (например, чертеж не может содержать тела, а модель не может содержать виды). Поэтому при переходе к документу другого типа состав системной компактной панели, т.е. набор входящих в нее инструментальных панелей, полностью меняется.

Включение и отключение отображения панелей производится командами, которые находятся в подменю команды Вид — Панели инструментов.

После подключения к КОМПАС-3D библиотек становятся доступны их инструментальные панели.

Панель, отображение которой включено, может находиться в «плавающем» или зафиксированном состоянии. «Плавающая» панель может располагаться в любом месте экрана, а зафиксированная — только внутри окна КОМПАС-3D с прикреплением к какой-либо его границе.

Чтобы зафиксировать панель рядом с границей окна, «перетащите» ее за заголовок к этой границе. Чтобы вернуть панель в «плавающее» состояние, выполните обратное действие — «перетащите» ее в направлении центра окна.

Если панель зафиксирована, то роль заголовка играет рельефная линия у левого или верхнего края панели.

Для быстрого переключения между «плавающим» и зафиксированным состоянием панели можно дважды щелкнуть по ее заголовку.

При необходимости вы можете создать пользовательские инструментальные панели и разместить на них кнопки любых команд (см. раздел 9.4.2.2).

В этом разделе:

1.2.2.1.1. Компактные панели

1.2.2.1.2. Расширенные панели команд


1.2.2.1.1. Компактные панели

Рис. 1.2.2. Системная компактная панель при работе с графическим документом

Компактная панель содержит несколько инструментальных панелей, представленных кнопками переключения между ними и кнопками вызова команд активной панели. Активизация той или иной инструментальной панели производится при помощи кнопок переключения.

По умолчанию в окне КОМПАС-3D отображается системная компактная панель, содержащая инструментальные панели для создания и редактирования объектов, присущих документу данного типа.

Вы можете изменять состав системной компактной панели. Рядом с кнопками переключения находятся маркеры перемещения. Чтобы извлечь из системной компактной панели какую-либо инструментальную панель, «перетащите» соответствующий ей маркер мышью за пределы системной компактной панели.

Отпустите кнопку мыши. На экране появится выбранная инструментальная панель. Соответствующая ей кнопка переключения на системной компактной панели исчезнет.

Если инструментальная панель извлечена из компактной, то ее отображение можно включать и отключать с помощью соответствующей команды подменю Вид — Панели инструментов или диалога Панели инструментов (см. раздел 9.1.3.8.2).

Любые инструментальные панели, кроме панелей Стандартная, Вид, Текущее состояние, а также компактных панелей, можно объединить в пользовательскую компактную панель.

Для этого нажмите и удерживайте клавишу <Alt>, а затем «перетащите» мышью за заголовок одну панель на другую. Когда во время наложения панелей рядом с курсором появится знак «+», отпустите кнопку мыши, а затем — клавишу <Alt>. Будет сформирована пользовательская компактная панель. Ей автоматически присваивается название «Компактная панель № N», где N — порядковый номер пользовательской компактной панели.

Чтобы вернуть или добавить инструментальную панель в состав компактной панели, «перетащите» заголовок первой так, чтобы «наложить» ее на последнюю, удерживая клавишу <Alt>. После появления знака «+», отпустите кнопку мыши и клавишу. Инструментальная панель будет включена в компактную.


1.2.2.1.2. Расширенные панели команд

Кнопки вызова команд сгруппированы по назначению и представлены на инструментальной панели кнопкой одной команды из группы. При нажатии кнопки команды и удержании ее в нажатом состоянии рядом с кнопкой появляется расширенная панель, включающая в себя все команды данной группы. Например, расширенная панель, вызываемая кнопкой Дуги панели Геометрия, содержит команды построения дуг различными способами: по трем точкам, касательной к кривой и других.

Кнопки, позволяющие вызвать расширенную панель команд, отмечены маленьким черным треугольником в правом нижнем углу (рис. 1.2.3, а).

Расширенная панель команд может быть преобразована в отдельную панель, имеющую обобщенный заголовок, например, Дуги (рис. 1.2.3, б).

Рис. 1.2.3. Расширенная панель команд: а) в составе инструментальной панели, б) отдельная
а) | б)

Чтобы отделить расширенную панель от инструментальной, выполните следующие действия. Вызовите на кнопке команды расширенную панель и, не отпуская левую кнопку мыши, подведите курсор к маркеру перемещения — рельефной линии у границы панели. После того как курсор примет вид четырехсторонней стрелки, отпустите кнопку мыши — расширенная панель должна оставаться на экране. Нажмите левую кнопку мыши вновь и «перетащите» панель за маркер перемещения в любое место экрана.

Чтобы удалить отделенную расширенную панель с экрана, закройте ее, а чтобы вернуть — создайте вновь.

Отделенные расширенные панели не могут включаться в состав компактных панелей; в расширенных панелях нельзя изменять состав кнопок и порядок их расположения.

Одни и те же команды на отделенных расширенных панелях и инструментальных панелях являются равноправно доступными для вызова. В то же время расширенные панели могут использоваться в отсутствие на экране инструментальной панели, из которой они созданы.


1.2.2.2. Окна

В КОМПАС-3D широко используется элемент управления окно. Это выделенная часть экрана, размеры и расположение которого можно изменять. Основную часть окна составляет поле для ввода и вывода информации. Окно может содержать собственную инструментальную панель. Примеры окон: Окно переменных, Менеджер библиотек, окно Свойства, окно Нумерация, окно Технические требования, окно Дерево документа и Дополнительное окно Дерева. Некоторые окна, например, окно Дерево документа, являются принадлежностью документа, поэтому могут находиться только внутри окна документа, другие окна, например, окно Свойства, являются принадлежностью КОМПАС-3D, поэтому могут находиться в любом месте экрана.

Панель свойств (см. раздел 1.4.2.1) также является окном.


1.2.2.3. Управление состоянием панелей и окон

Панели и окна могут отображаться на экране в одном из двух состояний: «плавающем» или зафиксированном.

При необходимости можно закрепить положение как плавающих, так и зафиксированных панелей и окон (см. раздел 1.2.2.3.5).

Инструментальные панели могут быть зафиксированы рядом с какой-либо границей окна системы. Чтобы зафиксировать панель, «перетащите» ее за заголовок к нужной границе. Чтобы вернуть панель в «плавающее» состояние, выполните обратное действие — «перетащите» ее в направлении центра окна системы.

Окна, которые являются принадлежностью документа — Дерево документа и Технические требования — могут быть зафиксированы рядом с вертикальной границей окна документа. Фиксация таких окон производится так же, как фиксация панелей — путем «перетаскивания» мышью за заголовок.

Остальные окна являются принадлежностью КОМПАС-3D и могут быть зафиксированы рядом с любой границей окна КОМПАС-3D (окна Нумерация и Свойства — только рядом с вертикальными границами). Фиксация таких окон производится следующим образом:

1. Установите указатель мыши на заголовке окна, нажмите левую кнопку и сдвиньте мышь.

В центре окна КОМПАС-3D и у тех его границ, где может быть зафиксировано перемещаемое окно, появляются элементы управления для выбора его положения (рис. 1.2.4).

2. Переместите указатель мыши на нужный элемент управления.

В окне КОМПАС-3D цветом выделяется приграничная область, которую займет перемещаемое окно.

3. Если новое положение окна вас устраивает, отпустите кнопку мыши.

Окно фиксируется рядом с выбранной границей.

Рис. 1.2.4. Фиксация Окна переменных у левой границы окна системы

Для фиксации Панели свойств рядом с нужной границей окна системы можно также воспользоваться командами Размещение — Вверху/Внизу/Слева/Справа из контекстного меню Панели.

Для быстрого переключения между «плавающим» и зафиксированным состоянием панели или окна можно дважды щелкнуть по его заголовку.

В этом разделе:

1.2.2.3.1. Совмещение окон

1.2.2.3.2. Объединение окна Свойства и Панели свойств

1.2.2.3.3. Автоматическое сворачивание окон

1.2.2.3.4. Команды управления состоянием окна

1.2.2.3.5. Закрепление положения панелей и окон


1.2.2.3.1. Совмещение окон

Окна, имеющие одинаковые варианты фиксации (к любой границе окна КОМПАС-3D или только к вертикальным), можно совместить друг с другом. Совмещение окон производится следующим образом:

1. Установите указатель мыши на заголовке одного окна, нажмите левую кнопку и переместите мышь так, чтобы указатель оказался в пределах второго окна.

В центре второго окна появляются элементы управления для выбора положения первого окна (рис. 1.2.5, а).

2. Переместите указатель мыши на нужный элемент управления. Во втором окне цветом выделяется область, которую займет первое (перемещаемое) окно.

• Центральный элемент управления позволяет совместить окна, наложив их друг на друга с образованием вкладок (рис. 1.2.5, б).

• Остальные элементы управления позволяют совместить окна, разделив площадь второго окна по вертикали или горизонтали (рис. 1.2.5, в).

3. Если новое положение окна вас устраивает, отпустите кнопку мыши.

Первое и второе окна совмещаются, образуя одно окно.

Рис. 1.2.5. Совмещение окон: а) выбор варианта совмещения, б) окно со вкладками, в) окно, разделенное по вертикали
а) | б) | в)

Для наложения окон с образованием вкладок можно также «перетащить» первое окно на заголовок второго.


1.2.2.3.2. Объединение окна Свойства и Панели свойств

Назначение окна Свойства и Панели свойств таково, что их одновременное использование исключено: окно Свойства служит для изменения свойств выделенных объектов, а Панель свойств — для задания свойств создаваемого (редактируемого) объекта. В целях экономии экранного места вы можете объединить окно Свойства и Панель свойств в одно окно. Это можно сделать:

– вызвав команду Размещение — Объединить с окном Свойства из контекстного меню Панели свойств,

– либо вызвав команду Объединить с Панелью свойств из контекстного меню заголовка окна Свойства.

Объединенное окно располагается вертикально; может быть зафиксировано рядом с вертикальной границей окна КОМПАС-3D.

В зависимости от действия, выполняемого в данный момент, в объединенном окне отображается:

– Панель свойств — при создании (редактировании) объекта,

– окно Свойства, отображающее свойства объектов — при наличии в окне выделенных объектов,

– пустое окно Свойства — при отсутствии выделенных объектов.

Для отмены объединения:

– если в объединенном окне отображается Панель свойств, вызовите из ее контекстного меню команду Размещение — Объединить с окном Свойства либо отключите и снова включите отображение Панели свойств;

– если в объединенном окне отображается окно Свойства, вызовите из контекстного меню его заголовка команду Объединить с Панелью свойств либо отключите и снова включите отображение окна Свойства.


1.2.2.3.3. Автоматическое сворачивание окон

Окно (в том числе окно, образованное совмещением или объединением других окон), зафиксированное около границы окна системы или документа, может автоматически сворачиваться к этой границе. Это позволяет более эффективно использовать рабочее поле: если работа с окном не ведется, оно автоматически исчезает с экрана, а на границе окна системы или документа остается «корешок» с названием свернутого окна. Чтобы вернуть свернутое окно на экран и продолжить работу с ним, следует поместить курсор в область «корешка».

Для включения/отключения автоматического сворачивания окна служит кнопка Фиксация в его заголовке.


1.2.2.3.4. Команды управления состоянием окна

Для управления состоянием окна служат команды контекстного меню его заголовка (табл. 1.2.2).

Если Панель свойств зафиксирована горизонтально (у верхней или нижней границы окна системы), то роль заголовка играет рельефная вертикальная линия у левого края Панели (см. рис. 1.2.1).

Табл. 1.2.2. Команды управления состоянием окна

Название

Описание

Плавающая

Позволяет перевести зафиксированное окно в «плавающее» состояние. Команда Плавающая недоступна, если включено автоматическое сворачивание окна или положение плавающих окон закреплено.

Зафиксированная

Позволяет перевести «плавающее» окно в зафиксированное состояние. После вызова команды окно фиксируется рядом с той границей, где находилось до того, как стало «плавающим». Команда Зафиксированная недоступна, если включено автоматическое сворачивание окна или положение зафиксированных окон закреплено.

Свернуть

Позволяет включить автоматическое сворачивание зафиксированного окна. Чтобы отключить автоматическое сворачивание, вызовите команду повторно.

Сворачиванием зафиксированного окна можно управлять также с помощью кнопки Фиксация, расположенной в заголовке окна. Изображение на кнопке после нажатия изменяется, что является индикацией режима автоматического сворачивания:

— автоматическое сворачивание окна включено,

— автоматическое сворачивание окна отключено.

Закрыть

Позволяет закрыть окно.

После закрытия окна оно исчезает с экрана. Чтобы вернуть его, необходимо вызвать команду отображения окна на экране.

Если окно Технические требования или Дерево документа находится в «плавающем» состоянии, то оно может отображаться с разными степенями прозрачности. Для настройки степени прозрачности вызовите из контекстного меню заголовка окна команду Прозрачность — N% (рис. 1.2.6). Если щелкнуть по прозрачному окну левой кнопкой мыши, то оно станет непрозрачным.

Рис. 1.2.6. Пример настройки прозрачности окна

На ПК под управлением Microsoft Windows XP команда Прозрачность отсутствует в контекстном меню заголовка «плавающих» окон Технические требования и Дерево документа. Окна Технические требования и Дерево документа отображаются непрозрачными.


1.2.2.3.5. Закрепление положения панелей и окон

Положение панелей и окон можно закрепить. Для этого вызовите команду Вид — Панели инструментов — Закрепить положение. На экране появится подменю, включающее команды: Плавающих панелей, Зафиксированных панелей, Плавающих окон и Зафиксированных окон. Команды также могут быть вызваны из контекстного меню заголовка окна или из меню кнопки со стрелкой в заголовке панели (рис. 1.2.7).

Рис. 1.2.7. Пример вызова команды

В результате закрепления положения:

– для панелей и окон блокируются:

• перемещение,

• изменение размеров,

• переключение между «плавающим» и зафиксированным состоянием двойным щелчком мыши по заголовку;

– для панелей блокируются:

• изменение порядка и состава команд,

• отделение расширенных панелей команд и меню (для зафиксированных панелей);

– для окон становятся недоступны команды контекстного меню:

• Плавающая,

• Зафиксированная.

В тех случаях, когда окно образовано совмещением других окон, закрепление положения блокирует перемещение их границ (внешних — только в случае, если окно зафиксировано).

При настройке интерфейса (см. раздел 9.4.2) закрепление панелей временно отключается. Разрешается изменение порядка, состава команд и управление их отображением.

При попытке перемещения закрепленной панели или окна курсор отображается в виде предупреждающего значка.

Чтобы временно отключить закрепление панелей и окон, нажмите и удерживайте клавишу <Ctrl>.


1.2.3. Управление окнами документов

1.2. Интерфейс системы

1.2.3. Управление окнами документов

КОМПАС-3D позволяет работать одновременно с несколькими различными документами.

Каждый документ, который создается вновь или открывается для редактирования, отображается в отдельном окне.

При необходимости с одним и тем же графическим документом или документом-моделью можно работать в нескольких окнах. Чтобы открыть дополнительное окно документа, вызовите команду Новое окно документа из меню Окно или из контекстного меню закладки документа. В разных окнах могут отображаться разные части документа в разных масштабах.

Каждое окно имеет заголовок, который содержит название отображающегося в нем документа, кнопку системного меню и кнопки управления окном.

Приемы работы с окнами стандартны (перетаскивание окна за его заголовок мышью, изменение границ окна и т.д.) и ничем не отличаются от принятых в других Windows-приложениях. Чтобы разместить на экране окна документов удобным образом, используйте команды Каскад и Мозаика... из меню Окно.

Любое окно документа можно минимизировать до условного значка — пиктограммы. Это может быть удобным в случае, когда документ не нужен только на какое-то время, и желательно не закрывать его совсем. Для рационального размещения пиктограмм документов (они обычно отображаются в нижней части главного окна КОМПАС-3D) используйте команду Окно — Упорядочить значки.

Для последовательного переключения между окнами документов можно использовать комбинацию клавиш <Ctrl>+<F6>, а для произвольного — команды меню Окно. Кроме того, для выбора текущего документа можно пользоваться закладками документов (см. раздел 1.2.3.1).

Управление документами и окнами возможно также в диалоге Окна, вызываемом командой Окно — Все окна.

В окне просмотра диалога перечислены все окна, открытые в текущем сеансе работы.

Выбрав один или несколько документов в этом списке, вы можете, воспользовавшись соответствующими кнопками, выполнить одно из следующих действий:

– активизировать (возможно, если выделен один документ),

– сохранить,

– закрыть,

– расположить каскадом,

– расположить горизонтально,

– расположить вертикально,

– минимизировать.

Кнопки Каскадом, Горизонтально, Вертикально и Минимизировать присутствуют в диалоге Окна, если отключено отображение закладок (см. раздел 1.2.3.1).

В этом разделе:

1.2.3.1. Закладки документов

1.2.3.2. Рабочая область


1.2.3.1. Закладки документов

Основное назначение закладок — быстрое переключение между окнами документов. На закладках документов указаны имена файлов этих документов (рис. 1.2.8).

Включить и отключить закладки можно с помощью команды Окно — Показать закладки. Если рядом с этой командой в меню отображается «галочка», то закладки находятся на экране.

Место расположения и внешнее оформление закладок, вид имен файлов документов (полные или короткие) настраиваются в диалоге настройки закладок документов (см. раздел 9.1.3.7). В диалоге также можно включить и отключить закладки.

Использование закладок возможно только при развернутых (максимизированных) окнах документов. Поэтому при включении отображения закладок все открытые окна автоматически разворачиваются. Системные кнопки Свернуть и Восстановить у окон исчезают, а кнопка Закрыть помещается справа на закладке текущего документа или на строке закладок в зависимости от настройки (см. раздел 9.1.3.7).

Чтобы активизировать окно документа, щелкните мышью по его закладке или укажите нужный документ в списке, вызываемом кнопкой со стрелкой в правой части строки закладок (рис. 1.2.8).

Рис. 1.2.8. Закладки документов

Контекстное меню закладки документа содержит команды:

– Сохранить;

– Сохранить как;

– Закрыть окно;

– Закрыть все другие окна;

– Закрыть все;

– Закрыть другие окна документа;

– Новое окно документа;

– Открыть папку с файлом;

– Копировать полное имя файла;

– Настроить...;

– Все окна...

Чтобы закрыть окно, дважды щелкните левой кнопкой или один раз средней кнопкой (колесом) мыши на закладке документа.

Чтобы создать новый документ, дважды щелкните левой кнопкой мыши на свободном месте строки закладок.

Если включен показ закладок документов и открыто более одного окна, рабочую область главного окна системы можно разделить на несколько частей (см. раздел 1.2.3.2).


1.2.3.2. Рабочая область

Вы можете разделить рабочую область главного окна системы на несколько частей. В каждой из них может находиться одно или несколько окон документов.

Разделение возможно, когда открыто более одного окна (в том числе для одного документа) и включен показ закладок документов.

Чтобы разделить рабочую область по вертикали, «перетащите» мышью любую закладку в окно документа или на правую границу рабочей области. Рабочая область будет разделена на две части. В правой части будет находиться окно документа, закладка которого была перемещена, а в левой — все остальные окна.

Левую часть — при условии, что в ней осталось более одного окна — можно разделить еще на две части таким же образом.

Разделение рабочей области по горизонтали производится аналогично. Для этого «перетащите» мышью любую закладку на нижнюю границу рабочей области.

Вы можете перемещать окна между областями, «перетаскивая» закладки мышью из одной области в другую.

Для изменения ширины областей «перетаскивайте» мышью их границы.

Чтобы вернуться к первоначальному виду рабочей области (т.е. «собрать» все ее части вместе), «перетащите» в любую часть рабочей области закладки всех окон, находящихся вне этой части.


1.2.4. Контекстные меню и контекстные панели

1.2. Интерфейс системы

1.2.4. Контекстные меню и контекстные панели

Контекстное меню появляется на экране при нажатии правой кнопки мыши. Состав меню зависит от объекта, на который указывал курсор во время нажатия кнопки мыши, и от выполняемого действия. При этом в меню собраны команды, наиболее типичные для данного момента работы (рис. 1.2.9).

Рис. 1.2.9. Контекстное меню: а) для нескольких выделенных геометрических объектов, б) для выделенного фрагмента текста
а) | б)

Контекстная инструментальная панель появляется на экране:

– при выделении объектов в окне документа,

– при выделении объектов в Дереве чертежа или в Дереве построения модели,

– при щелчке мышью в свободном месте документа,

– при вызове контекстного меню, кроме случаев вызова контекстного меню во время работы какой-либо команды.

Контекстная панель включает кнопки вызова наиболее часто используемых команд. Состав панели зависит от типа выделенного объекта, от типа документа и от текущего режима работы.

Не предусмотрено появление контекстной панели при выделении следующих объектов:

– обозначения для строительства,

– обозначения для машиностроения, кроме линии-выноски и обозначения позиции,

– радиальный размер с изломом и размер высоты,

– OLE-вставка.

На рисунке рис. 1.2.10 показаны некоторые контекстные панели.

Рис. 1.2.10. Контекстная панель при выделении: а) геометрического объекта в чертеже или фрагменте, б) грани тела в сборке, в) фрагмента текста в текстовом документе, г) геометрического объекта в эскизе трехмерного элемента
а) | б) | в) | г)

Вы можете настроить состав контекстной панели. Для этого служит кнопка Настройка интерфейса в правой части панели (рис. 1.2.11).

Рис. 1.2.11. Настройка состава контекстной панели

Кроме того, вы можете настроить отображение контекстной панели (в том числе отключить ее появление в документах того или иного типа). Для этого вызовите команду Сервис — Параметры... — Система — Общие — Контекстная панель.

При выделении библиотечного макроэлемента появление контекстной панели и ее состав зависят от настройки, выполненной в диалоге Редактирование библиотечных макроэлементов (см. раздел 9.1.10.2).

Контекстная панель, появляющаяся при вызове контекстного меню, не содержит кнопки Настройка интерфейса.

Контекстная панель отображается полупрозрачной, а при наведении на нее курсора становится непрозрачной. Если отвести курсор от выделенного объекта или вызвать какую-либо команду, контекстная панель исчезает.

Удобство работы с контекстными меню и панелями обеспечивается тем, что в них сгруппированы команды, находящиеся в разных разделах Главного меню, но часто использующиеся при работе. Кроме того, вызов команд ускоряется, так как контекстное меню появляется на экране в том месте, где его вызвали щелчком мыши, а контекстная панель — рядом с курсором.

Чтобы закрыть контекстное меню и/или контекстную панель, нажмите клавишу <Esc>.


1.2.5. Значки режимов в окне документа

1.2. Интерфейс системы

1.2.5. Значки режимов в окне документа

Значки режимов служат для информирования пользователя о текущем режиме работы (например, режим контекстного редактирования компонента, подчиненный режим работы с объектами спецификации документа, режим предварительного просмотра перед печатью) и выхода из режима.

Значок, аналогичный пиктограмме кнопки режима на панели, появляется в окне документа при переходе системы в тот или иной режим и исчезает при выходе из него. В окне документа могут одновременно отображаться несколько значков.

Рис. 1.2.12. Отображение значков режимов

Для управления отображением значков на экране служит команда Вид — Показать значки режимов, а для управления их положением в окне документа — команды контекстного меню значка.

Значки отображаются для следующих режимов:

– редактирования графического макроэлемента,

– редактирования технических требований,

– редактирования объектов спецификации,

– эскиза,

– пересчета размеров с учетом допусков,

– контекстного редактирования,

– редактирования таблицы основной надписи,

– подготовки данных для отчета,

– развертки,

– разнесения компонентов,

– сечения модели,

– предварительного просмотра перед печатью.

Чтобы выйти из режима, необходимо щелкнуть мышью по значку.


1.3. Документы КОМПАС-3D

В этом разделе:

1.3.1. Типы документов

1.3.1.1. Трехмерные модели

1.3.1.2. Графические документы

1.3.1.3. Текстовые документы, спецификации

1.3.2. Системы координат и единицы измерения в документах

1.3.2.1. Системы координат

1.3.2.2. Единицы измерения

1.3.3. Создание и сохранение документов

1.3.3.1. Создание документа

1.3.3.2. Сохранение документа

1.3.3.2.1. Сохранение документа в первый раз

1.3.3.2.2. Сохранение документа под другим именем

1.3.3.2.3. Сохранение всех документов

1.3.4. Открытие и закрытие документов

1.3.4.1. Открытие документа

1.3.4.2. Закрытие документа

1.3.5. Информация о документе


1.3.1. Типы документов

1.3. Документы КОМПАС-3D

1.3.1. Типы документов

Тип документа, создаваемого в системе КОМПАС-3D, зависит от рода информации, которую предполагается хранить в этом документе.

Каждому типу документа соответствует расширение имени файла и собственная пиктограмма.

В этом разделе:

1.3.1.1. Трехмерные модели

1.3.1.2. Графические документы

1.3.1.3. Текстовые документы, спецификации


1.3.1.1. Трехмерные модели

Деталь

Деталь — модель изделия, изготавливаемого из однородного материала, без применения сборочных операций.

Файл детали имеет расширение m3d.

Сборка

Сборка — модель изделия, состоящего из нескольких деталей с заданным взаимным положением.

В состав сборки могут также входить другие сборки (подсборки) и стандартные изделия.

Файл сборки имеет расширение a3d.

Технологическая сборка

Технологическая сборка — сборка, содержащая технологические данные, например, результат пересчета размеров модели с учетом допусков, технологические объекты (центровые отверстия, отверстия для крепления и т.п.), технологические модели (люнеты, центры, инструменты и прочая оснастка).

Файл технологической сборки имеет расширение t3d.


1.3.1.2. Графические документы

Чертеж

Основной тип графического документа в КОМПАС-3D — чертеж. Чертеж содержит графическое изображение изделия, основную надпись, рамку, иногда — дополнительные элементы оформления (знак неуказанной шероховатости, технические требования и т.д.). Чертеж КОМПАС-3D может содержать один или несколько листов. Для каждого листа можно задать формат, кратность, ориентацию и др. свойства. В файле чертежа КОМПАС-3D могут содержаться не только чертежи (в понимании ЕСКД), но и схемы, плакаты и прочие графические документы.

Файл чертежа имеет расширение cdw.

Фрагмент

Вспомогательный тип графического документа в КОМПАС-3D — фрагмент. Фрагмент отличается от чертежа отсутствием рамки, основной надписи и других объектов оформления документа. Он используется для хранения изображений, которые не нужно оформлять как отдельный лист (эскизные прорисовки, разработки и т.д.). Кроме того, во фрагментах также хранятся созданные типовые решения для последующего использования в других документах.

Файл фрагмента имеет расширение frw.


1.3.1.3. Текстовые документы, спецификации

Спецификация

Спецификация — документ, содержащий информацию о составе сборки, представленную в виде таблицы. Спецификация оформляется рамкой и основной надписью. Она часто бывает многостраничной.

Файл спецификации имеет расширение spw.

Текстовый документ

Документ, содержащий преимущественно текстовую информацию — текстовый документ. Текстовый документ оформляется рамкой и основной надписью. Он часто бывает многостраничным. В текстовом документе могут быть созданы пояснительные записки, извещения, технические условия и т.п.

Файл текстового документа имеет расширение kdw.


1.3.2. Системы координат и единицы измерения в документах

1.3. Документы КОМПАС-3D

1.3.2. Системы координат и единицы измерения в документах

В этом разделе:

1.3.2.1. Системы координат

1.3.2.2. Единицы измерения


1.3.2.1. Системы координат

При работе в КОМПАС-3D используются стандартные правые декартовы системы координат.

В каждом графическом документе и документе-модели присутствует абсолютная система координат. Ее удаление из документа невозможно.

В трехмерной модели система координат определяет координатные плоскости. Система координат условно показывается на экране в виде трех ортогональных отрезков, а плоскости — в виде прямоугольников, лежащих в этих плоскостях. При необходимости возможно создание локальных систем координат. Подробнее о системах координат в трехмерных моделях рассказано в разделе 2.8.3.

Система координат в графическом документе лежит в плоскости, параллельной экрану, и отображается в виде двух ортогональных стрелок. При необходимости возможно создание локальных систем координат. Подробнее о системах координат в графических документах рассказано в разделе 3.1.4.


1.3.2.2. Единицы измерения

В КОМПАС-3D используется стандартная метрическая система мер.

Умолчательная единица измерения длины — миллиметр.

В этих единицах задаются и отображаются линейные параметры (например, длина отрезка, радиус окружности, величина сдвига) на Панели свойств, значения в размерных надписях линейных размеров, координаты курсора и т.д.

Для графических документов можно установить другую единицу измерения длины — сантиметр или метр (см. раздел 9.2.6.2).

Умолчательная единица измерения угла — градус.

В этих единицах задаются и отображаются угловые параметры (например, угол раствора дуги или угол поворота копии объекта) на Панели свойств. Можно установить другие единицы измерения углов для полей Панели свойств — градусы, минуты и секунды или радианы (см. раздел 9.1.2.2).

Значения в размерных надписях угловых размеров по умолчанию отображаются в градусах. Можно установить другой способ отображения — в градусах и минутах или в градусах, минутах и секундах (см. раздел 9.2.6.10.1).

При вычислении массо-центровочных характеристик можно управлять представлением результатов, выбирая нужные единицы непосредственно в процессе измерения (килограммы или граммы — для массы; миллиметры, сантиметры, дециметры или метры — для длины).

При черчении в КОМПАС-3D пользователь всегда оперирует реальными размерами объектов (в масштабе 1:1), а размещение изображения на чертеже нужного формата выполняется путем выбора подходящего масштаба вида (см. раздел 3.6.4.1).


1.3.3. Создание и сохранение документов

1.3. Документы КОМПАС-3D

1.3.3. Создание и сохранение документов

В этом разделе:

1.3.3.1. Создание документа

1.3.3.2. Сохранение документа

1.3.3.2.1. Сохранение документа в первый раз

1.3.3.2.2. Сохранение документа под другим именем

1.3.3.2.3. Сохранение всех документов


1.3.3.1. Создание документа

Чтобы создать новый документ, вызовите команду Файл — Создать.

На экране появится диалог создания документа (рис. 1.3.1).

Рис. 1.3.1. Диалог создания документа

На вкладке Шаблоны можно выбрать нужный шаблон для нового документа.

Если использование шаблона не требуется, выберите тип документа на вкладке Новые документы.

Нажмите кнопку ОК для создания документа заданного типа или по заданному шаблону.

Другим способом создания нового документа является выбор его из меню кнопки Создать (рис. 1.3.2).

Команды этого меню можно расположить в виде кнопок на отдельной панели и поместить ее в любом удобном месте. Для этого «перетащите» меню кнопки Создать мышью за заголовок в любом направлении. Будет сформирована панель Новый документ (рис. 1.3.3).

Рис. 1.3.2. | Рис. 1.3.3.

Обратите внимание на отличие панели Новый документ от остальных инструментальных панелей: состав и порядок кнопок на ней изменить невозможно.

При создании новых документов используются оформления и формат, установленные по умолчанию. При необходимости вы можете настроить оформление и формат активного документа (см. разделы 3.6.2.1 и 4.1.4.2).


1.3.3.2. Сохранение документа

Чтобы сохранить документ в файл на диске, вызовите команду Файл — Сохранить.

Документ будет автоматически сохранен в той же папке и в том же файле, что и в прошлый раз. Другими словами, файл, созданный при предыдущем сохранении документа, будет заменен новым файлом, содержащим документ в том виде, в котором он был на момент сохранения.

При необходимости вы можете сохранить документ под другим именем или в другой папке (см. раздел 1.3.3.2.2).

В этом разделе:

1.3.3.2.1. Сохранение документа в первый раз

1.3.3.2.2. Сохранение документа под другим именем

1.3.3.2.3. Сохранение всех документов


1.3.3.2.1. Сохранение документа в первый раз

Для сохранения документа вызовите команду Файл — Сохранить.

На экране появится диалог сохранения файла. Укажите в нем папку, в которую требуется записать документ, введите имя файла и нажмите кнопку Сохранить.

По умолчанию предлагается расширение файла, соответствующее типу документа.

Не рекомендуется изменять без крайней необходимости умолчательное расширение у имени файла документа, так как впоследствии это сильно затруднит поиск файла (он не будет отображаться в списке документов данного типа в диалоге открытия файла).

При попытке сохранения документа в уже существующем файле выдается запрос для подтверждения перезаписи (замены старого документа новым). Если существующий документ открыт в данный момент, то его нельзя заменить новым документом — на экране появляется сообщение о невозможности записи.

После закрытия диалога сохранения файла на экране появляется диалог информации о документе (см. раздел 1.3.5).


1.3.3.2.2. Сохранение документа под другим именем

Иногда требуется сохранить документ после его редактирования, оставив неизменной старую редакцию файла. В этом случае применяется сохранение документа под другим именем или в другом месте на диске.

Вызовите команду Файл — Сохранить как...

Дальнейшие действия аналогичны сохранению документа в первый раз (см. раздел 1.3.3.2.1). Отличие в том, что диалог информации о документе не появляется.

Кроме того, команда Сохранить как... позволяет также сохранять КОМПАС-документы в виде шаблонов для новых документов, конвертировать КОМПАС-документы в другие форматы, а при работе с трехмерными моделями — также записывать деталь в файл сборки и сборку в файл детали. Для сохранения документа в виде шаблона, выполнения конвертации или смены типа модели выберите нужную строку из списка Тип файла.


1.3.3.2.3. Сохранение всех документов

Чтобы сохранить сразу все открытые документы, вызовите команду Файл — Сохранить все.

При сохранении документов, которые записываются на диск впервые, на экране будет отображаться диалог, в котором следует задать имя файла и папку для записи. После закрытия этого диалога на экране будет появляться диалог информации о документе.


1.3.4. Открытие и закрытие документов

1.3. Документы КОМПАС-3D

1.3.4. Открытие и закрытие документов

В этом разделе:

1.3.4.1. Открытие документа

1.3.4.2. Закрытие документа


1.3.4.1. Открытие документа

Чтобы открыть существующий документ, вызовите команду Файл — Открыть.

В появившемся на экране диалоге выберите тип документа, укажите имя файла и нажмите кнопку Открыть.

Вы также можете открыть документ КОМПАС-3D с помощью Проводника Windows. Для этого выделите в нем файл, который нужно открыть, и дважды щелкните на нем левой кнопкой мыши или вызовите из контекстного меню команду Открыть.

Если вы попытаетесь открыть уже загруженный для работы документ, КОМПАС-3D не выполнит повторное открытие, а просто активизирует окно этого документа.

Если вы недавно редактировали документ, а затем закрыли его, повторное открытие можно выполнить более быстрым способом. В нижней части меню Файл отображается список нескольких последних документов, с которыми велась работа. Фактически это перечень документов в той последовательности, в которой они закрывались. Чтобы открыть нужный документ, просто выберите его имя в меню.

Количество последних открывавшихся документов, имена которых отображаются в меню Файл, можно настроить. Для этого вызовите команду Сервис — Параметры... — Система — Общие — Отображение имен файлов.


1.3.4.2. Закрытие документа

Чтобы закрыть документ, вызовите команду Файл — Закрыть.

Если документ содержит изменения, которые не были сохранены, на экране появится запрос на выполнение записи закрываемого документа.

Если документ отображался в нескольких различных окнах, закрываются все эти окна.

Чтобы закрыть только одно окно документа и оставить все остальные окна, дважды щелкните мышью на кнопке системного меню закрываемого окна.


1.3.5. Информация о документе

1.3. Документы КОМПАС-3D

1.3.5. Информация о документе

Информацию о документе составляют различные справочные сведения об этом документе, хранящиеся вместе с ним, например, имя автора, дата и время создания, атрибуты и другие. Просмотреть и отредактировать эти сведения можно в диалоге Информация о документе (рис. 1.3.4).

Для вызова этого диалога служит команда Файл — Информация о документе…. Кроме того, он автоматически появляется на экране при первом сохранении документа. Элементы управления диалога информации представлены в таблице 1.3.1.

Рис. 1.3.4. Диалог информации о документе

Табл. 1.3.1. Диалог информации о документе
Элемент | Описание
Вкладка Общие сведения | Содержит общую информацию о документе.
Автор | Имя автора документа.
Организация | Название организации.
Комментарий | Произвольный комментарий к документу. Комментарий может состоять из нескольких строк.
Создан | Дата и время создания документа1.
Последнее изменение | Дата и время последнего сохранения документа1.
Вкладка Внешние ссылки | В окне просмотра этой вкладки перечислены все внешние файлы, на которые ссылается текущий документ, и с которыми он связан: – библиотеки оформлений, – библиотеки фрагментов, – библиотеки стилей, – библиотеки типов атрибутов, – документы-спецификации, подключенные к текущей сборке или чертежу, – сборки или листы сборочного чертежа, подключенные к текущей спецификации, – документы, подключенные к объектам спецификации в текущем документе, – документы, к объектам спецификации в которых подключен текущий документ, – вставленные фрагменты, – файлы деталей, связанных с ассоциативными видами, – файлы деталей и сборок, вставленных в модель, – адреса электронной почты и внешние файлы, на которые сделаны гиперссылки.
Полный путь | Если полный путь и имя файла не помещаются в окне просмотра, происходит сжатие пути. Чтобы получить информацию о полном пути, включите опцию Полный путь.
Записать в файл | Кнопка, позволяющая записать в текстовый файл информацию о внешних связях документа, представленную в окне вкладки.
Вкладка Атрибуты | Вкладка появляется при просмотре сведений о графическом документе или спецификации. Она содержит список типов атрибутов, присвоенных текущему документу.
  1. Поле заполняется автоматически и не может быть изменено пользователем.

По умолчанию сведения об авторе и организации совпадают с указанными при установке системы КОМПАС-3D (в диалоге Сведения о пользователе). Эти сведения, включая комментарий, также могут быть получены из свойств документа (см. раздел 5.1.4.1.1).

При необходимости вы можете изменить умолчательные данные (см. раздел 9.2.3).


1.4. Общие приемы работы

В этом разделе:

1.4.1. Работа в окне документа

1.4.1.1. Графический курсор

1.4.1.2. Масштаб отображения документа

1.4.1.2.1. Увеличение и уменьшение масштаба отображения

1.4.1.2.2. Явное задание масштаба отображения

1.4.1.2.3. Увеличение масштаба произвольного участка изображения

1.4.1.2.4. Масштаб по выделенным объектам

1.4.1.2.5. Плавное изменение масштаба

1.4.1.2.6. Отображение эскиза целиком

1.4.1.2.7. Отображение документа целиком

1.4.1.2.8. Переход к предыдущему или последующему масштабу отображения

1.4.1.2.9. Автоматический подбор масштаба

1.4.1.3. Сдвиг изображения

1.4.1.3.1. Линейки прокрутки

1.4.1.4. Обновление изображения

1.4.1.5. Листание документа

1.4.1.6. Отмена и повтор действий

1.4.1.7. Повтор последних команд

1.4.2. Общие приемы выполнения операций

1.4.2.1. Панель свойств

1.4.2.2. Окно Свойства

1.4.2.2.1. Изменение свойств

1.4.2.3. Запуск и завершение операций

1.4.2.4. Параметры объектов

1.4.2.4.1. Указание точек в окне документа

1.4.2.4.2. Ввод параметров в предопределенном порядке

1.4.2.5. Ввод значений в поля Панели свойств

1.4.2.6. Фиксация параметров

1.4.2.7. Освобождение параметров

1.4.2.8. Активизация параметров

1.4.2.9. Запоминание параметров

1.4.2.10. Автоматическое и ручное создание объектов

1.4.2.11. Повторное указание объектов

1.4.2.12. Копирование свойств объектов

1.4.2.13. Геометрический калькулятор

1.4.2.13.1. Геометрический калькулятор для графических объектов

1.4.2.13.2. Геометрический калькулятор для трехмерных объектов

1.4.2.14. Отображение параметров объектов рядом с курсором

1.4.2.15. Округление значений параметров


1.4.1. Работа в окне документа

1.4. Общие приемы работы

1.4.1. Работа в окне документа

В этом разделе:

1.4.1.1. Графический курсор

1.4.1.2. Масштаб отображения документа

1.4.1.2.1. Увеличение и уменьшение масштаба отображения

1.4.1.2.2. Явное задание масштаба отображения

1.4.1.2.3. Увеличение масштаба произвольного участка изображения

1.4.1.2.4. Масштаб по выделенным объектам

1.4.1.2.5. Плавное изменение масштаба

1.4.1.2.6. Отображение эскиза целиком

1.4.1.2.7. Отображение документа целиком

1.4.1.2.8. Переход к предыдущему или последующему масштабу отображения

1.4.1.2.9. Автоматический подбор масштаба

1.4.1.3. Сдвиг изображения

1.4.1.3.1. Линейки прокрутки

1.4.1.4. Обновление изображения

1.4.1.5. Листание документа

1.4.1.6. Отмена и повтор действий

1.4.1.7. Повтор последних команд


1.4.1.1. Графический курсор

Курсор — это главный инструмент при работе с КОМПАС-3D. С помощью курсора осуществляется вызов команд из меню или с помощью кнопок, создание и редактирование объектов, выполняется множество других действий.

Внешний вид курсора зависит от типа активного документа и выполняемой операции.

Стандартный вид курсора при нахождении в поле графического документа или документа-модели — это квадратная «ловушка». Параметры курсора (размер, цвет и др.) могут настраиваться пользователем. Настройка осуществляется в диалоге, вызываемом командой Сервис — Параметры... — Система — Графический редактор — Курсор.

Возможны следующие способы управления курсором.

– Перемещение мышью — основной способ, доступный в документах всех типов.

– Перемещение при помощи клавиатуры. Вы можете передвигать курсор, используя клавиши со стрелками на основной или расширенной клавиатуре. В этом случае перемещение будет не произвольным, как в случае использования мыши, а дискретным.

В текстовых документах и спецификациях (во время ввода текстовой части объекта) при нажатии на кнопку со стрелкой курсор перемещается на один символ или на одну строку.

В графических документах минимальное перемещение курсора при нажатии на кнопку со стрелкой зависит от установленного шага курсора. Для задания величины шага служит поле Текущий шаг курсора на панели Текущее состояние. Значение шага можно ввести с клавиатуры или выбрать из списка. Для быстрой активизации поля Текущий шаг курсора используйте комбинацию клавиш <Shift> + </> (клавишу </> необходимо нажимать на дополнительной цифровой клавиатуре). Список шагов и умолчательный шаг можно установить в диалоге настройки курсора (см. раздел 9.1.7.1).

– Задание координат курсора. При работе с графическими документами вы можете ввести координаты точки, в которую требуется поместить курсор, в поля Координаты курсора на панели Текущее состояние.

Для быстрой активизации этих полей используйте комбинацию клавиш <Alt> + <X>. После ее нажатия активным становится поле координаты Х. Введите в него нужное значение. Чтобы перейти к полю координаты Y, нажмите клавишу <Tab>. Введите значение.

Подтвердите задание координат курсора, нажав клавишу <Enter>.

Вы можете указывать в полях координат курсора приращения к текущим координатам. Для этого введите символ ^, а затем — значение приращения.

Если панель Текущее состояние расположена вертикально, то для доступа к полю Текущий шаг курсора или Координаты курсора нажмите соответствующую кнопку.

– Фиксация курсора. В графических документах и документах-моделях после установки курсора в нужную точку его требуется зафиксировать — подтвердить, что для создания объекта должна использоваться именно эта точка.

Фиксация производится щелчком левой кнопки мыши или нажатием клавиши <Enter>.

Так, например, для построения отрезка необходимо указать и зафиксировать его начальную и конечную точки, при построении отверстия в модели можно изменить его умолчательное расположение, указав и зафиксировав новое положение точки привязки.


1.4.1.2. Масштаб отображения документа

КОМПАС-3D предоставляет пользователю широкий набор средств для изменения масштаба. Важно понимать, что изменение масштаба отображения не влияет на реальные размеры объектов (габариты деталей, длины отрезков, высоту шрифта и т.п.). Можно провести такую аналогию: лист бумаги c чертежом закреплен на кульмане, а вы перемещаетесь относительно него. Так, приближаясь или удаляясь от чертежа, вы будете видеть изображение крупнее или мельче.

Команды изменения масштаба сгруппированы в меню Вид. Основные из них можно также вызвать с помощью кнопок панели Вид.

Набор доступных команд для изменения масштаба отображения зависит от типа текущего документа.

Увеличение и уменьшение масштаба, а также явное его задание доступны всегда.

Автоматический подбор масштаба возможен при работе с текстовыми документами, спецификацией, при вводе текста технических требований и в некоторых других режимах.

Остальные команды изменения масштаба доступны в графических документах и документах-моделях.

В этом разделе:

1.4.1.2.1. Увеличение и уменьшение масштаба отображения

1.4.1.2.2. Явное задание масштаба отображения

1.4.1.2.3. Увеличение масштаба произвольного участка изображения

1.4.1.2.4. Масштаб по выделенным объектам

1.4.1.2.5. Плавное изменение масштаба

1.4.1.2.6. Отображение эскиза целиком

1.4.1.2.7. Отображение документа целиком

1.4.1.2.8. Переход к предыдущему или последующему масштабу отображения

1.4.1.2.9. Автоматический подбор масштаба


1.4.1.2.1. Увеличение и уменьшение масштаба отображения

Чтобы увеличить или уменьшить масштаб отображения документа, вызовите команду Увеличить масштаб или Уменьшить масштаб.

По умолчанию коэффициент изменения масштаба равен 1,2.

Чтобы изменить данный коэффициент для документов-моделей, вызовите команду Сервис — Параметры... — Система — Редактор моделей — Управление изображением.

Чтобы изменить данный коэффициент для графических документов, вызовите команду Сервис — Параметры... — Система — Графический редактор — Редактирование.

Чтобы изменить данный коэффициент для текстовых документов, отчетов и спецификаций, вызовите команду Сервис — Параметры... — Система — Текстовый редактор — Редактирование.

В правой части появившегося диалога введите или выберите из списка значение коэффициента изменения масштаба.

По умолчанию при работе с графическими документами и моделями кнопки увеличения и уменьшения масштаба отсутствуют на панели Вид. Вы можете добавить эти кнопки на панель (см. раздел 9.4.2.1).


1.4.1.2.2. Явное задание масштаба отображения

Масштаб отображения в активном окне показан в поле Текущий масштаб, расположенном на панели Вид.

Чтобы изменить масштаб, разверните список и выберите нужное значение. Можно также ввести значение с клавиатуры.

При вертикальном расположении панели для вызова этого поля нажмите кнопку Текущий масштаб.

Если требуется установить коэффициент текущего масштаба равным 1,0, удобно использовать команду Масштаб 1,0.


1.4.1.2.3. Увеличение масштаба произвольного участка изображения

Чтобы увеличить произвольный участок изображения, вызовите команду Увеличить масштаб рамкой.

Щелкните мышью в точке первого угла рамки, которая должна охватить увеличиваемую область. Затем перемещайте курсор для достижения нужного размера рамки. При этом на экране будет отображаться фантом рамки.

После фиксации второго угла рамки изображение будет увеличено таким образом, чтобы область документа, ограниченная рамкой, занимала всю площадь окна.


1.4.1.2.4. Масштаб по выделенным объектам

Вы можете установить максимальный масштаб отображения, при котором в окне полностью умещаются все выделенные в документе объекты (подогнать масштаб к габаритам выделенной группы объектов).

Для этого вызовите команду Масштаб по выделенным объектам.

Выделенные вспомогательные прямые и пустые (не содержащие ни одного объекта) виды при выполнении команды не учитываются. Не учитывается также единственная выделенная точка.

Команда Масштаб по выделенным объектам недоступна, если ни один объект не выделен(о способах выделения объектов см. раздел 3.1.2).


1.4.1.2.5. Плавное изменение масштаба

Если требуемый коэффициент изменения масштаба неизвестен, вы можете подобрать его визуально, панорамируя («приближая» или «отдаляя») изображение.

Для этого вызовите команду Приблизить/отдалить.

Внешний вид курсора изменится.

Нажмите левую кнопку мыши и, не отпуская ее, перемещайте курсор в вертикальном направлении. При движении курсора вверх изображение будет плавно увеличиваться, в обратном направлении — уменьшаться. Центром масштабирования является точка, в которой была нажата левая кнопка мыши. Достигнув края экрана, отпустите кнопку мыши, переместите курсор в середину экрана, а затем вновь нажмите левую кнопку и перемещайте мышь.

Чтобы центр панорамирования находился в центре экрана, удерживайте нажатой клавишу <Shift>.

Если вы пользуетесь мышью с колесом, то для панорамирования изображения вращайте колесо мыши. Центром панорамирования является точка, в которой было начато вращение колеса. Возможна настройка направления вращения колеса мыши, см. раздел 9.1.2.10.

Чтобы центр панорамирования находился в центре экрана, удерживайте нажатой клавишу <Shift>.

Колесо мыши можно использовать также для панорамирования изображения в текстовых документах и документах-спецификациях. Для этого вращайте колесо, удерживая нажатой клавишу <Ctrl>.


1.4.1.2.6. Отображение эскиза целиком

Вы можете установить максимальный масштаб отображения текущего эскиза, при котором он полностью умещается в окне модели. Для этого вызовите команду Показать эскиз полностью.

Вспомогательные прямые и вспомогательные проекции, построенные в эскизе, при выполнении команды не учитываются.


1.4.1.2.7. Отображение документа целиком

Чтобы отобразить в окне весь редактируемый документ, вызовите команду Показать все.


1.4.1.2.8. Переход к предыдущему или последующему масштабу отображения

При работе с графическими документами или моделями можно вернуться к одному из предыдущих масштабов отображения в окне.

Чтобы вернуться к предыдущему масштабу, вызовите команду Предыдущий масштаб.

Чтобы вновь перейти к следующему масштабу отображения, вызовите команду Последующий масштаб.


1.4.1.2.9. Автоматический подбор масштаба

Вы можете изменить масштаб отображения текущего текстового документа, технических требований, отчета, таблицы основной надписи или спецификации таким образом, чтобы страница документа полностью умещалась в окне по ширине (горизонтальный размер изображения становится равным ширине окна) или по высоте (вертикальный размер изображения становится равным высоте окна).

Для автоматического подбора масштаба вызовите команду Подогнать масштаб по высоте или Подогнать масштаб по ширине.


1.4.1.3. Сдвиг изображения

Сдвиг (прокрутка) изображения — перемещение изображения документа в окне без изменения масштаба отображения.

Важно понимать, что сдвиг изображения в окне не влияет на реальное местоположение объектов в документе. Можно провести такую аналогию: лист бумаги c чертежом закреплен на кульмане, а вы перемещаетесь относительно него. Так, при сдвиге влево, вправо вверх или вниз в поле зрения будет попадать не все изображение, а только его часть.

Чтобы переместить изображение при работе с графическим документом или моделью, вызовите команду Вид — Сдвинуть или нажмите кнопку Сдвинуть на панели Вид.

Курсор изменит свою форму.

Для обращения к команде сдвига изображения можно также нажать комбинацию клавиш <Shift>+<Ctrl>, а затем левую кнопку мыши.

Перемещайте курсор, удерживая кнопку мыши нажатой (если вы вызывали команду с помощью комбинации клавиш <Shift>+<Ctrl>, то эти клавиши также нужно удерживать нажатыми). Достигнув края экрана, отпустите кнопку мыши, переместите курсор в середину экрана, а затем вновь нажмите левую кнопку и перемещайте мышь.

После того как рабочее поле сдвинуто в нужное положение, отпустите кнопку мыши и клавиши.

Если вы пользуетесь трехкнопочной мышью или мышью с колесом, то для сдвига изображения в графическом, текстовом документе и документе-спецификации можно перемещать мышь с нажатой средней кнопкой (колесом).

Можно сказать, что с помощью описанного способа сдвига изображения мы увеличиваем размер рабочего поля документа. Такой прием удобно использовать в тех случаях, когда не хватает диапазона действия линеек прокрутки.

В этом разделе:

1.4.1.3.1. Линейки прокрутки


1.4.1.3.1. Линейки прокрутки

Линейки прокрутки позволяют перемещать изображение строго по вертикали или горизонтали. Они отображаются в окне документа внизу и справа.

Для прокрутки изображения нажимайте кнопки со стрелками, расположенные по краям линеек. Можно также перемещать «ползунок», имеющийся на линейке.

Если вы пользуетесь мышью с колесом, то для прокрутки изображения при работе с текстовыми документами и документами-спецификациями можно вращать колесо мыши. Для постраничной прокрутки следует дополнительно удерживать нажатой клавишу <Shift>.

Вы можете настроить отображение линеек прокрутки в текущем окне. Для этого вызовите команду Сервис — Параметры... — Текущее окно — Линейки прокрутки.

В правой части появившегося диалога расположена группа Линейки прокрутки, управляющая отображением линеек.


1.4.1.4. Обновление изображения

В процессе выполнения различных команд ввода и редактирования на экране могут появляться вспомогательные линии и символы. В большинстве случаев после завершения команды КОМПАС-3D автоматически удаляет эти временные объекты. Однако иногда возникает необходимость в принудительном удалении с экрана оставшегося «мусора» — обновить изображение.

Чтобы обновить изображение в активном окне, вызовите команду Обновить изображение.

Обновление позволяет также прорисовать заново объекты, изображение которых повреждено. Такое повреждение происходит при удалении (перемещении) одного из наложенных или пересекающихся объектов. Например, при удалении вспомогательных линий с экрана может исчезнуть и сам вычерченный контур. После обновления изображения он появится вновь.


1.4.1.5. Листание документа

При работе с текстовыми документами, со спецификациями, а также при вводе текста технических требований документ можно листать — прокручивать постранично.

Чтобы последовательно переходить от одной страницы к другой, нажимайте клавиши <Page Up> и <Page Down>. Для произвольного перехода к нужной странице введите ее номер в поле Текущая страница на панели Текущее состояние и нажмите клавишу <Enter>. Курсор будет установлен в начало первой строки на странице с заданным номером.

Если панель Текущее состояние расположена вертикально, то для доступа к полю Текущая страница нажмите соответствующую кнопку.


1.4.1.6. Отмена и повтор действий

Для отмены и повтора действий служат команды Отменить и Повторить в меню Редактор. Кнопки вызова этих команд расположены на панели Стандартная.

Команда Отменить восстанавливает то состояние документа, которое было до выполнения последнего действия.

Команда Повторить, наоборот, выполняет отмененное действие вновь. Она доступна только после вызова команды отмены.

Не все команды могут быть отменены и повторены. Это относится, в частности, к командам заполнения основной надписи, удаления всего содержимого документа, записи документа на диск.

Обратите внимание на то, что все операции редактирования параметров компонента (например, изменение типоразмеров), вставленного в сборку из библиотеки, считаются одним действием. Таким образом, отменить одну из операций редактирования библиотечного компонента невозможно: команда Отменить удаляет компонент из сборки, а команда Повторить — возвращает его с теми параметрами, которые он имел перед удалением.

В графическом документе, кроме отмены и повтора команд, возможны отмена и повтор действий внутри текущей команды. При этом отменяются только те действия, которые относятся к данной команде. Например, в документе построено несколько окружностей. Если, не завершая команду Окружность, нажимать кнопку Отменить, то созданные окружности будут поочередно исчезать с экрана, а по нажатию кнопки Повторить — восстанавливаться.

Для графического и текстового документов можно настроить параметры процесса отмены: задать количество шагов назад, а также включить или отключить группировку однотипных операций (см. разделы 9.1.7.11 и 9.1.8.2).


1.4.1.7. Повтор последних команд

Последняя выполненная команда может быть повторно вызвана не через Инструментальную панель, а из контекстного меню или из меню Редактор. Для вызова служит команда Повторить: (команду). Команда может быть вызвана нажатием клавиши <F4>. В контекстном меню, кроме последней выполненной команды, доступны также несколько предыдущих команд (рис. 1.4.1).

Рис. 1.4.1. Пример списка последних команд при работе в чертеже

Списки последних выполненных команд создаются для следующих типов документов КОМПАС-3D:

– деталь,

– сборка,

– чертеж,

– фрагмент,

– спецификация,

а также для следующих режимов работы:

– режим эскиза,

– режим редактирования таблицы.

При работе с текстовым редактором может быть повторена только одна последняя выполненная команда. Команда повтора вызывается из меню Редактор.

Категории добавляемых в списки команд приведены в таблице 1.4.1.

Табл. 1.4.1. Категории повторяемых команд в зависимости от типа документа и режима работы
Название типа документа или режима работы | Категории команд1
Деталь | Редактор, Инструменты, Выделить, Редактирование модели, Элементы листового тела, Пространственные кривые, Поверхности, Вспомогательная геометрия, Элементы оформления, Измерения 3D, Фильтры, Спецификация
Сборка | Редактор, Инструменты, Выделить, Редактирование модели, Сопряжения, Пространственные кривые, Поверхности, Вспомогательная геометрия, Элементы оформления, Измерения 3D, Фильтры, Спецификация
Чертеж | Редактор, Инструменты, Выделить, Измерения 2D, Управление листами
Фрагмент | Редактор, Инструменты, Выделить, Измерения 2D, Управление листами
Спецификация | Все команды редактирования, все команды спецификации, команды библиотек, работающих со спецификацией.
Текстовый документ | Все команды редактирования текста
Режим редактирования таблиц | Редактор, Вставка в текст, Все команды редактирования таблицы
Режим эскиза | Редактор, Инструменты, Выделить, Измерения 2D
  1. Команды, входящие в каждую категорию, перечислены в диалоге Настройка интерфейса — Команды (см. рис. 9.4.1).

Команды включаются в список вне зависимости от того, были они завершены или нет.

Команда не повторяется, если она была вызвана двойным щелчком мыши по объекту.

Если условия выполнения команды отсутствуют, то ее повторный вызов невозможен. Например, для выполнения команды Копирование необходимо, чтобы исходные объекты были выделены. Если в документе нет ни одного выделенного объекта, то в списке последних команд будет недоступна команда Копирование.

Количество запоминаемых команд можно настроить в диалоге, вызываемом командой Сервис — Параметры... — Система — Общие — Повтор команд. В этом же диалоге можно отключить отображение последних команд в контекстном меню.

При завершении сеанса работы КОМПАС-3D списки команд обнуляются.


1.4.2. Общие приемы выполнения операций

1.4. Общие приемы работы

1.4.2. Общие приемы выполнения операций

В этом разделе:

1.4.2.1. Панель свойств

1.4.2.2. Окно Свойства

1.4.2.2.1. Изменение свойств

1.4.2.3. Запуск и завершение операций

1.4.2.4. Параметры объектов

1.4.2.4.1. Указание точек в окне документа

1.4.2.4.2. Ввод параметров в предопределенном порядке

1.4.2.5. Ввод значений в поля Панели свойств

1.4.2.6. Фиксация параметров

1.4.2.7. Освобождение параметров

1.4.2.8. Активизация параметров

1.4.2.9. Запоминание параметров

1.4.2.10. Автоматическое и ручное создание объектов

1.4.2.11. Повторное указание объектов

1.4.2.12. Копирование свойств объектов

1.4.2.13. Геометрический калькулятор

1.4.2.13.1. Геометрический калькулятор для графических объектов

1.4.2.13.2. Геометрический калькулятор для трехмерных объектов

1.4.2.14. Отображение параметров объектов рядом с курсором

1.4.2.15. Округление значений параметров


1.4.2.1. Панель свойств

Панель свойств (рис. 1.4.2) служит для управления процессом выполнения команды.

Включение и отключение Панели свойств производится командой Вид — Панели инструментов — Панель свойств.

Настройка внешнего вида Панели свойств описана в разделе 9.1.3.6.

Рис. 1.4.2. Пример Панели свойств

В верхней или левой части Панели свойств находится Панель специального управления.

На Панели специального управления расположены кнопки, с помощью которых выполняются специальные действия, такие как ввод объекта, прерывание текущей команды, включение автоматического создания объекта и т.д.


1.4.2.2. Окно Свойства

Окно Свойства (рис. 1.4.3) служит для просмотра и изменения свойств объектов, выделенных в модели или графическом документе.

В графических документах окно Свойства можно использовать также при копировании свойств между объектами — для просмотра и выбора копируемых свойств (см. раздел 3.5.1.2).

Рис. 1.4.3. Свойства обозначения клеймения в модели

Чтобы отобразить окно Свойства на экране, вызовите команду Редактор — Свойства или нажмите кнопку Свойства на Стандартной панели.

В графическом документе команду Свойства можно вызывать из контекстного меню выделенных объектов.

В верхней части окна Свойства находится список типов выделенных объектов.

Под списком расположена инструментальная панель окна.

Основную часть окна Свойства занимает таблица свойств объектов.

Таблица состоит из двух колонок. В первой находятся названия свойств объектов, а во второй — значения свойств.

Если на инструментальной панели активизирован переключатель Группировка, то свойства в таблице разбиваются на группы. По умолчанию группы показываются развернутыми, т.е. в таблице видно содержимое групп — входящие в них свойства. Чтобы свернуть группу, оставив в таблице лишь ее название, щелкните мышью на значке минуса слева от названия группы. Повторный щелчок на этом символе (после сворачивания группы он отображается как плюс) приведет к развертыванию группы.

Если на инструментальной панели активизирован переключатель Сортировка, то свойства в таблице сортируются по названиям в алфавитном порядке.

Кнопка Выделить по свойствам служит для вызова команды, позволяющей выделять объекты по набору свойств, исключать объекты из числа выделенных по набору свойств, а также инвертировать выделение (подробнее см. раздел 3.1.2.3). Кнопка доступна в графических документах.

Об особенностях работы в окне Свойства с трехмерными объектами рассказано в разделе 2.14.3.6.1, с графическими объектами — в разделе 3.5.1.2.1.

В этом разделе:

1.4.2.2.1. Изменение свойств


1.4.2.2.1. Изменение свойств

При помощи окна Свойства вы можете изменять свойства отдельного объекта или группы объектов, не прибегая к редактированию каждого из них в отдельности. Если окно не отображается на экране, включите его, нажав кнопку Свойства.

Чтобы изменить свойства объектов, их необходимо выделить любым способом. Во время работы со свойствами можно добавлять объекты к уже выделенным или исключать из числа выделенных также любым способом.

Рис. 1.4.4. Изменение свойств объектов

Список типов объектов в окне Свойства содержит строку Все - N, где N — общее количество выделенных объектов, и строки, сформированные по шаблону Имя типа — n, где «Имя типа» — название типа объектов, а n — количество выделенных объектов данного типа (рис. 1.4.4).

Если выделены объекты только одного типа, то строка Все отсутствует в списке типов объектов.

При выделении дополнительных объектов или исключении объектов из числа выделенных список типов динамически изменяется.

В таблице свойств отображаются:

– названия и значения всех свойств выделенных объектов одного типа — если в списке типов выбран конкретный тип объектов,

– названия и значения свойств, общих для всех выделенных объектов — если в списке типов выбрана строка Все.

Значение свойства, не доступного для редактирования, отображено в ячейке серым цветом.

Чтобы изменить значение какого-либо свойства, выполните следующие действия:

1. Щелкните в ячейке значения свойства, которое требуется изменить.

• Если значение числовое (например, радиус окружности), то ячейка становится доступной для его ввода.

• Если значение нечисловое (например, стиль линии), то в правой части ячейки появляется кнопка с черным треугольником. Она позволяет раскрыть список значений.

• Если значение текстовое (например, параметр шероховатости выносная надпись), то на экране появляется диалог ввода текста.

• Если значение — гиперссылка, то на экране появляется диалог редактирования гиперссылки.

2. Измените значение свойства.

3. Чтобы подтвердить ввод числового значения, нажмите клавишу <Enter> или щелкните мышью вне редактируемой ячейки. Диалог ввода текста или редактирования гиперссылки закройте кнопкой ОК. Для нечисловых значений подтверждение не требуется.

Объекты (объект) автоматически перестраиваются в соответствии с новым значением свойства. При этом объекты остаются выделенными и вы можете продолжать изменять их свойства.

Об особенностях работы в окне Свойства в графических документах рассказано в разделе 3.5.1.2, в моделях — в разделе 2.14.3.6.1.


1.4.2.3. Запуск и завершение операций

Чтобы запустить операцию, следует вызвать соответствующую ей команду. Для этого можно выбрать название команды из меню или нажать на инструментальной панели кнопку, соответствующую команде. Для некоторых команд вызов возможен только из меню или только с инструментальной панели.

После запуска операции на Панели свойств появляются элементы управления параметрами операции и/или параметрами объекта, который будет создан в документе в результате выполнения этой операции.

Для большинства операций необходимо подтверждение выполнения. Чтобы подтвердить выполнение операции, необходимо нажать кнопку Создать объект на Панели специального управления или комбинацию клавиш <Ctrl> + <Enter>. Команда Создать объект доступна также в контекстном меню и в меню Редактор.

В некоторых операциях имеется возможность автоматического создания объектов. По умолчанию автосоздание включено. В этом случае выполнение операции подтверждается автоматически сразу после задания необходимого минимума параметров. Например, окружность автоматически фиксируется в графическом документе, если указаны две точки: центр и точка на окружности. Подробнее об автоматическом и ручном создании объектов рассказано в разделе 1.4.2.10.

Некоторые операции позволяют создать несколько однотипных объектов подряд (или выполнения нескольких однотипных действий). Например, за один запуск операции построения отрезка можно построить несколько отрезков. Для выхода из операции требуется после построения последнего объекта нажать кнопку Прервать команду на Панели специального управления.

Другие операции не предусматривают последовательного создания нескольких объектов (выполнения нескольких действий). Такие операции автоматически завершаются после подтверждения. Например, за один запуск операции очистки области можно очистить только один участок. Нажатие кнопки Прервать команду до подтверждения выполнения операции означает отказ от создания объекта (выполнения действия).

Команда Прервать команду доступна также в контекстном меню.

Для завершения операции можно также выполнить одно из следующих действий:

– нажать клавишу <Esc>,

– отжать кнопку команды,

– вызвать любую другую команду.


1.4.2.4. Параметры объектов

После вызова большинства команд создания объектов необходимо задать различные параметры этих объектов.

Например, после вызова команды построения окружности требуется задание положения ее центра и радиуса, а после вызова команды построения тела выдавливания — направление, глубину выдавливания и величину уклона.

Создать объект — значит определить все его параметры. При разработке моделей и чертежей с помощью КОМПАС-3D все параметры создаваемых объектов отображаются на Панели свойств (см. раздел 1.2.2.1). Каждому параметру соответствует один элемент Панели (рис. 1.4.5).

Параметры можно разделить на числовые (координаты точки, длина, угол, количество вершин и т.п.) и нечисловые (стиль линии, наличие осей симметрии и т.п.).

Рис. 1.4.5. Параметры окружности

Рядом с названием большинства числовых параметров на Панели свойств находится переключатель, на котором отображается значок, соответствующий состоянию параметра (табл. 1.4.2).

Табл. 1.4.2. Значки состояния параметров
Название | Описание
Зафиксированный | На переключателе зафиксированного параметра отображается перекрестие. Значение этого параметра принято системой. Оно остается постоянным при изменении остальных параметров и отображается на фантоме объекта. Зафиксированными могут быть любые числовые параметры.
Активный | На переключателе активного параметра отображается «галочка». Система ожидает, что значение этого параметра будет введено путем указания точки мышью в окне документа. Активными могут быть только параметры, представляющие собой координаты точек.
Вспомогательный | Переключатель вспомогательного параметра пустой. Значение этого параметра либо еще не задано, либо зависит от значений других параметров (в этом случае оно фиксируется автоматически после фиксации параметра, от которого зависит). Вспомогательный параметр можно в любой момент задать и зафиксировать. До фиксации значение вспомогательного параметра удерживается в поле. Вспомогательными параметрами могут быть любые числовые параметры.

Если нечисловые параметры объекта можно задать только одним способом — выбрав нужный вариант на Панели свойств, то для задания числовых параметров доступно несколько способов.

– Первый, наиболее простой и наглядный способ задания параметров — указание нужных точек в окне документа (см. раздел 1.4.2.4.1). Этот способ может применяться в основном для графических объектов, так как среди трехмерных объектов сравнительно мало таких, чьи параметры можно было бы задать, указав лишь точки.

– Второй способ — ввод параметров в предопределенном порядке — позволяет более гибко управлять параметрами объектов (см. раздел 1.4.2.4.2). Этот способ доступен при создании большинства объектов — как графических, так и трехмерных.

– Третий способ — задание значений параметров на Панели свойств — менее нагляден, но универсален и может применяться при создании объектов всех типов (см. раздел 1.4.2.5).

Все эти способы задания параметров объектов можно комбинировать.

После того как все параметры объекта будут заданы, необходимо подтвердить его создание. Это можно сделать одним из следующих способов:

– нажать кнопку Создать объект на Панели специального управления,

– вызвать команду Создать объект из меню Редактор или из контекстного меню,

– нажать комбинацию клавиш <Ctrl> + <Enter>.

В большинстве команд построения графических объектов имеется возможность автоматического создания (см. раздел 1.4.2.10). По умолчанию автосоздание включено.

В дальнейшем при описании команд построения объектов под словом «указание» будет подразумеваться указание некоторого элемента курсором в рабочем поле (т.е. установка курсора на этом объекте и щелчок левой кнопкой мыши), а под словом «задание» — задание параметров любым способом.

В разделах, посвященных созданию объектов, описаны наиболее простые и часто используемые пути. Это касается как способа, так и порядка задания свойств объектов. Например, чтобы построить отрезок, необходимо каким-либо образом указать его длину, направление и положение. При этом можно действовать, например, так: ввести координаты первой точки, затем — угол наклона к оси абсцисс текущей системы координат, и, наконец, указать мышью конечную точку отрезка. Естественно, этот способ такой же правильный, как и все остальные; более того, в некоторых случаях он может оказаться единственно возможным. Однако в описании построения отрезка приведены лишь два основных способа построения: по двум точкам и по точке, длине и углу, так как именно они являются самыми простыми и наиболее употребительными.

В этом разделе:

1.4.2.4.1. Указание точек в окне документа

1.4.2.4.2. Ввод параметров в предопределенном порядке


1.4.2.4.1. Указание точек в окне документа

Указать точку в окне документа — значит установить в нее курсор мыши и зафиксировать.

В графическом документе и в эскизе для точной установки курсора можно использовать привязки (см. раздел 3.1.1) или поля координат курсора на панели Текущее состояние (рис. 1.4.6).

Рис. 1.4.6. Поля координат курсора

Фиксация точки, в которой находится курсор, необходима для того, чтобы координаты этой точки были переданы в поля Панели свойств (т.е. стали параметрами объекта). Точку можно зафиксировать двумя способами:

– щелкнув левой кнопкой мыши (этот способ фиксации удобен, если точка указана мышью — «на глаз» либо с применением привязки),

– нажать клавишу <Пробел> или <Enter> (этот способ удобен, если точка указана с помощью клавиатуры — путем ввода координат курсора или с применением клавиатурной привязки).

Например, для создания отрезка достаточно указать и зафиксировать две точки: начальную и конечную. Обратите внимание на то, что при этом в поля Панели свойств будут занесены не только координаты концов отрезка, но также его длина и угол (они рассчитываются автоматически).

Вы можете изменить умолчательную очередность указания точек, т.е. задавать параметры в последовательности, отличной от предлагаемой системой (см. раздел 1.4.2.8).


1.4.2.4.2. Ввод параметров в предопределенном порядке

Этот способ задания параметров объектов состоит в следующем.

Порядок ввода параметров, не являющихся координатами точек (длина, угол, расстояние, наименование и т.п.), для различных объектов определен заранее и хранится в системе. Поэтому значение (число или текст), введенное с клавиатуры во время создания или редактирования объекта, сразу воспринимается системой как значение предопределенного параметра и заносится в предопределенное поле. Чтобы отказаться от введенного значения, необходимо нажать клавишу <Esc>, а чтобы зафиксировать и перейти к следующему предопределенному полю — <Enter>. При указании точки или объекта в окне документа фиксация введенного значения и переход к следующему параметру происходят автоматически.

Параметры для предопределенного ввода можно задавать в произвольном порядке. Для перемещения между предопределенными полями в прямом направлении служит клавиша <Tab>, в обратном — комбинация клавиш <Shift>+<Tab>. После фиксации значения в выбранном поле производится автоматический переход к следующему полю для предопределенного ввода.

Если текущим предопределенным полем является поле Текст (например, в процессе простановки обозначения шероховатости), то при вводе первых символов надписи на экране появляется соответствующий диалог.

Рассмотрим способ ввода параметров в предопределенном порядке подробнее на примере построения отрезка, для которого известны начальная точка, длина и угол наклона. Очевидно, что строить его указанием начальной и конечной точек по меньшей мере нерационально.

Рис. 1.4.7. Панель свойств при построении отрезка

Предопределенную последовательность ввода параметров отрезка составляют поля Длина и Угол. После вызова команды Отрезок на Панели свойств выделено поле Длина — оно обведено рамкой и имеет отличающийся фон (см. рис. 1.4.7). Наберите значение длины отрезка. Вы увидите, что это значение попало в поле Длина. Обратите внимание на то, что выделение поля исчезло. Это произошло потому, что при вводе значения активизировалась Панель свойств, а режим предопределенного ввода параметров действует только тогда, когда активно окно документа (подробнее о переключении между Панелью свойств и окном документа см. следующий раздел). Укажите начальную точку отрезка мышью в окне. Вы увидите, что в окне документа появился фантом отрезка указанной длины с зафиксированной первой точкой. Поскольку при указании точки активизировалось окно документа, вновь включился режим предопределенного ввода: на Панели свойств выделилось следующее поле последовательности — Угол. Наберите значение угла. Оно будет занесено в поле Угол. Нажмите клавишу <Enter>. Значение угла и сам отрезок будут зафиксированы.

Начальную точку отрезка не обязательно указывать после ввода длины. Это можно сделать как до задания длины, так и после задания угла.

Если по каким-либо причинам необходимо ввести сначала угол наклона отрезка, а затем его длину, нужно действовать следующим образом.

1. Вызвать команду Отрезок. Не выходя из режима предопределенного ввода — т.е. не вводя значение длины, нажать клавишу <Tab>.

Выделение переместится с поля Длина на следующее предопределенное поле — Угол.

Поскольку при вводе значения предопределенного параметра активизируется Панель свойств, нажатие в это время клавиши <Tab> или комбинации <Shift>+<Tab> приводит к активизации следующего или предыдущего элемента управления Панели свойств.

2. Ввести значение угла и нажать клавишу <Enter>.

Угол будет зафиксирован, выделение автоматически перейдет на поле Длина.

3. Ввести значение длины и нажать клавишу <Enter>.

Отрезок будет зафиксирован.

Переключение между Панелью свойств и окном документа

Сразу после вызова команды создания графического или трехмерного объекта активным является окно документа, т.е. система ожидает задания параметров объекта путем указания точек или уже существующих объектов.

В момент перехода к заданию параметров объекта с помощью Панели свойств становится активной Панель свойств. Это происходит при:

– вводе значений в предопределенные поля (см. предыдущий раздел),

– активизации элемента управления Панели свойств с помощью мыши или клавиши-акселератора,

– щелчке мышью на свободном месте вкладки,

– переключении между вкладками с помощью области выбора вкладки.

Обратите внимание на то, что Панель свойств не активизируется при щелчке по ее заголовку, использовании ее контекстного меню, нажатии какой-либо кнопки Панели специального управления, а также при использовании геометрического калькулятора.

Во время, когда активна Панель свойств, переключение на окно документа происходит при:

– нажатии клавиши <Enter> или <Esc>,

– щелчке мышью в окне,

– переходе в окно другого приложения Windows.


1.4.2.5. Ввод значений в поля Панели свойств

Чтобы явно задать значение параметра в поле Панели свойств, щелкните в этом поле левой кнопкой мыши. Оно станет доступно для редактирования. Введите нужное число.

Другим способом доступа к полю параметра является нажатие клавиши <Alt> и клавиши с подчеркнутым в названии параметра символом (например, <Alt>+<У> для ввода угла наклона отрезка).

Значения числовых параметров графических объектов можно «снимать» с уже существующих объектов с помощью геометрического калькулятора (см. раздел 1.4.2.13). Обратите внимание на то, что вызов геометрического калькулятора для поля параметра возможен, если это поле не активизировано.

В поля Панели свойств возможен ввод не только числовых значений параметров, но и выражений для их вычисления. Синтаксис выражений описан в разделе 7.1.3.3.1.

Если выражение начинается с символа <^>, например, ^5+M_PI, то результат вычисления выражения прибавляется к значению, которое содержалось в поле до ввода этого выражения.

После ввода выражения нажмите клавишу <Enter> для его вычисления.

Описанные приемы можно использовать для параметров, находящихся в различных состояниях: зафиксированных, активных, вспомогательных (см. рис. 1.4.5 и табл. 1.4.2).

При переходе к следующему параметру значение текущего параметра автоматически фиксируется.

Числовые значения в полях Панели свойств отображаются с точностью, установленной в диалоге настройки представления чисел (см. раздел 9.1.2.2). Эта точность не влияет на значение параметра, хранящееся внутри системы — оно всегда равно числу, заданному пользователем.

Установка курсора в поле с уже заданным параметром и нажатие клавиши <Enter> означает повторный ввод значения этого параметра. При этом внутри системы сохраняется то значение, которое отображалось в поле в момент нажатия клавиши <Enter>, т.е. число записывается с точностью, установленной для отображения.


1.4.2.6. Фиксация параметров

Фиксация возможна для всех числовых параметров при графических объектах и для координат точек трехмерных объектов.

Значение зафиксированного параметра остается постоянным, а другие параметры остаются доступны для изменения. Признаком того, что параметр зафиксирован, является отображение перекрестия на переключателе рядом с полем параметра (см. рис. 1.4.5 и табл. 1.4.2).

Фиксацию параметра можно рассматривать как ограничение возможных конфигураций создаваемого объекта.

Например, нужно вычертить отрезок, длина которого должна точно равняться 60 миллиметрам. Задайте начальную точку отрезка, затем введите значение 60 в поле длины отрезка и нажмите клавишу <Enter>. Теперь при всех перемещениях курсора будет изменяться только угол наклона отрезка, а длина останется равной 60.

Отметим, что при указании точки в рабочем поле, а также при снятии параметра существующего объекта (см. раздел 1.4.2.13) фиксация этого параметра выполняется автоматически.

Если, перемещая курсор, вы достигли нужного значения какого-либо параметра и хотите его зафиксировать, то, не сдвигая мышь, активизируйте поле параметра с помощью соответствующей комбинации клавиш (например, <Аlt>+<У> для угла наклона отрезка) и затем нажмите клавишу <Enter>.


1.4.2.7. Освобождение параметров

Чтобы отменить фиксацию значения параметра, щелкните левой кнопкой мыши на переключателе рядом с названием этого параметра. Признаком того, что фиксация снята, является отсутствие перекрестия на соответствующем переключателе (см. рис. 1.4.5 и табл. 1.4.2).

Пусть при вычерчивании отрезка была задана первая точка, а затем введено и зафиксировано значение длины, равное 60 миллиметрам. В дальнейшем при всех перемещениях курсора изменялся только угол наклона отрезка. Если теперь освободить длину отрезка, то можно будет вновь изменять как угол наклона, так и длину.

В процессе построения объекта вы можете многократно фиксировать и освобождать его параметры.


1.4.2.8. Активизация параметров

Данный прием доступен в графических документах при построении следующих объектов: произвольных, параллельных и перпендикулярных отрезков; окружностей по двум точкам, по трем точкам, касательных к одной кривой; дуг.

Активизация возможна для параметров, которые задаются путем фиксации курсора в определенной точке поля документа (например, координаты точки, начальный и конечный углы дуги).

Во время задания такого параметра на его переключателе отображается «галочка», означающая, что параметр активный (см. рис. 1.4.5 и табл. 1.4.2), т.е. система ожидает задания именно его значения. После задания значения параметр фиксируется и активным становится следующий параметр.

При создании объектов их параметры активизируются в порядке, установленном в системе по умолчанию. Однако при необходимости пользователь может изменить его.

Чтобы активизировать параметр объекта, щелкните левой кнопкой мыши на его названии (не на переключателе, соответствующем параметру, и не в поле ввода!). Параметр станет активным, и вы сможете задать его значение.

Пусть необходимо построить отрезок заданной длины, параллельный данному и оканчивающийся в заданной точке. Вызовите команду построения параллельного отрезка, укажите данный отрезок, введите значение длины отрезка и зафиксируйте его. По умолчанию точка, которую вы укажете в поле документа, будет восприниматься как начальная точка отрезка, поэтому сейчас «галочкой» отмечен параметр т1. Чтобы можно было указать эту же точку в качестве конечной точки отрезка, активизируйте параметр т2, щелкнув по его названию мышью. «Галочка» на переключателе параметра т1 исчезнет, а на переключателе параметра т2 появится; фантом вводимого отрезка «повернется» на 180°. Теперь укажите положение конца отрезка — например, выполнив привязку к нужной точке.

Вы можете активизировать как вспомогательные, так и уже зафиксированные параметры (например, при редактировании объектов). В этом случае активизация параметра равносильна расфиксированию его значения.


1.4.2.9. Запоминание параметров

Часто требуется создать несколько объектов, имеющих ряд одинаковых параметров. Типичный пример — концентрические окружности (их совпадающими параметрами являются координаты точки центра).

КОМПАС-3D предоставляет возможность сохранить значение параметров и использовать их до завершения текущей команды при построении следующих объектов.

Для использования одинаковых параметров при создании объектов выполните следующие действия.

1. Задайте параметры, которые должны быть запомнены.

2. Нажмите кнопку Запомнить состояние или комбинацию клавиш <Ctrl> + <Shift> + <P>. Кнопка останется в нажатом состоянии, что свидетельствует о запоминании параметров.

3. Выполняйте построения до тех пор, пока нужны запомненные параметры.

4. Отожмите кнопку Запомнить состояние.

Если введенные параметры однозначно определяют объект (например, уже зафиксированы точка центра и радиус окружности), кнопка Запомнить состояние будет недоступна.

Запоминать параметры можно при выполнении различных операций. Ниже приведено несколько примеров использования этой возможности. Ознакомившись с ними, попробуйте самостоятельно построить следующие группы объектов:

– концентрические дуги с одинаковым углом раствора,

– отрезки одинаковой длины с одной и той же начальной точкой,

– отрезки одинаковой длины, параллельные одному и тому же объекту,

а также выполнить следующие действия:

– сделать одинаковыми радиусы нескольких окружностей и дуг,

– измерить длины нескольких участков кривой, начинающихся в одной и той же точке.

Пример1. Концентрические окружности

1. Вызовите команду Инструменты — Геометрия — Окружности — Окружность.

2. Задайте точку центра окружности.

3. Нажмите кнопку Запомнить состояние.

4. Последовательно указывайте точки, лежащие на окружностях.

Если кнопка Автосоздание объекта на Панели специального управления нажата, то окружности будут строиться автоматически. В противном случае создание каждой окружности необходимо подтверждать нажатием кнопки Создать объект.

Подробнее об автоматическом и ручном создании объектов см. раздел 1.4.2.10.

Если расфиксировать координаты центра, а затем указать другую центральную точку, можно построить новое семейство концентрических окружностей.

Пример 2. Расположение нескольких точек на одной вертикали

1. Вызовите команду Инструменты — Параметризация — Точки — Выровнять точки по вертикали.

2. Укажите первую точку для выравнивания.

3. Нажмите кнопку Запомнить состояние.

4. Последовательно указывайте остальные точки для выравнивания.

Пример 3. Измерение расстояния от одной точки до нескольких других

1. Вызовите команду Сервис — Измерить — Расстояние между 2 точками.

2. Задайте точку, от которой требуется измерять расстояние.

3. Нажмите кнопку Запомнить состояние.

4. Последовательно указывайте точки, расстояние до которых нужно определить.

В Информационном окне будут появляться значения измеренных расстояний.


1.4.2.10. Автоматическое и ручное создание объектов

Когда вы изменяете параметры объекта при его построении, иногда бывает не нужно создавать объект сразу после задания всех определяющих его параметров. Удобнее сначала оценить, правильно ли заданы значения параметров, а уже затем подтвердить создание объекта.

После вызова большинства команд ввода объектов на Панели специального управления (см. рис. 1.2.2.1) отображаются две кнопки.

Одна из них, Автосоздание объекта, по умолчанию нажата. Пока она находится в этом состоянии, все объекты создаются (фиксируются) немедленно после ввода параметров, достаточных для построения. Остальные параметры объекта остаются с текущими значениями. Например, для построения окружности достаточно задать положение центра и точки на окружности. Поэтому при включенном автосоздании окружность фиксируется в документе после указания двух точек. Наличие осей зависит от того, какой переключатель был активен в группе Оси. Таким образом, чтобы построить окружность с осями, перед указанием центра или точки на окружности нужно проверить, включена ли отрисовка осей и, если отключена, — включить.

В случае если не требуется, чтобы объекты создавались автоматически, отожмите кнопку Автосоздание. Теперь, чтобы подтвердить создание каждого очередного объекта, нужно будет дополнительно нажать кнопку Создать объект. До тех пор, пока эта кнопка не нажата, объект не считается зафиксированным, поэтому вы можете изменить любой его параметр (см. раздел 1.4.2.8) любое количество раз. Так, в приведенном выше примере включение/отключение отрисовки осей окружности возможно как до указания точек, таки и после. Каждое изменение будет немедленно отражаться на фантоме объекта в окне документа, что позволит контролировать правильность ввода значений.

Вызов команды Автосоздание (и, соответственно, включение/отключение автосоздания объектов) возможен также с помощью клавиатурной комбинации <Ctrl> + <Shift> + <Enter>.

Автосоздание не предусмотрено для некоторых графических объектов (например, эквидистанты). Их необходимо фиксировать вручную.

Для фиксации графического объекта можно просто щелкнуть на нем мышью.

При описании команд построения объектов, для которых предусмотрено автосоздание, предполагается, что оно включено. Случаи необходимости отключения автосоздания специально оговорены.


1.4.2.11. Повторное указание объектов

При выполнении многих команд требуется указывать объект, служащий базовым для построения.

После того как объект указан, можно создать несколько базирующихся на нем объектов.

Чтобы выбрать другой объект в качестве базового и создать новую группу объектов, следует нажать кнопку Указать заново или комбинацию клавиш <Ctrl> + <Shift> + <Z>. Построенные объекты будут зафиксированы, а система вновь будет ожидать указания базового объекта.

Этой кнопкой можно воспользоваться для построения нескольких групп отрезков, параллельных или перпендикулярных указанному объекту, нескольких групп угловых размеров от общей базы и т.п.

Второе назначение кнопки Указать заново — «перевыбор» базового объекта без повторного вызова команды.

Например, если для построения дуги, касательной к кривой, случайно была указана не та кривая, которая нужна, нажмите кнопку Указать заново. Выделение с выбранной кривой будет снято, а система вновь будет ожидать указания базового объекта.


1.4.2.12. Копирование свойств объектов

Иногда необходимо, чтобы новый или редактируемый объект имел ряд таких же свойств, что и ранее созданный объект. При работе с КОМПАС–документами существует возможность копирования некоторых свойств ранее созданного объекта, не выходя из процесса создания или редактирования.

Копирование свойств объектов выполняется с помощью команды Копировать свойства, которая доступна на Панели специального управления после вызова большинства команд.

Команду Копировать свойства можно вызвать также с помощью сочетания клавиш <Сtrl>+<Shift>+<С>.

Чтобы скопировать свойства объекта:

1. Нажмите на Панели специального управления кнопку Копировать свойства или выберите одноименную команду из контекстного меню.

Система переходит в режим указания объекта.

2. Укажите объект — источник свойств. Для этого установите курсор на объекте, свойства которого требуется скопировать. Когда выбранный объект подсветится под курсором, щелкните левой кнопкой мыши или нажмите <Enter>.

Система автоматически возвращается в команду, из которой была вызвана команда Копировать свойства.

Чтобы сменить объект — источник свойств, снова вызовите команду Копировать свойства и выберите другой объект.

3. Задайте параметры нового или редактируемого объекта.

4. Завершите процесс создания или редактирования объекта.

Объект будет иметь свойства объекта-источника.

Команду Копировать свойства можно прервать до возвращения в команду, из которой она была вызвана, одним из следующих способов:

– нажать кнопку Прервать команду на Панели специального управления,

– вызвать команду Прервать команду из контекстного меню,

– нажать клавишу <Esc>.

Копирование свойств имеет особенности, которые зависят от типа документа.

– В графических документах и эскизах команда Копировать свойства доступна на Панели специального управления после вызова большинства команд, размещенных на инструментальных панелях Геометрия, Размеры, Обозначения и Обозначения для строительства.
Копирование свойств производится по следующим правилам:

• свойство Текущий стиль линии копируется между всеми объектами, допускающими изменение стиля линии (например, стиль линии окружности можно скопировать в отрезок, эквидистанту, волнистую линию, фигурную скобку и т.п.);

• свойства Стиль текста, Параметры шрифта и Параметры абзаца копируются между всеми объектами, содержащими текст и допускающими изменение указанных свойств;

• некоторые свойства копируются только между объектами одного и того же типа (например, вид стрелки линии-выноски можно скопировать только в другую линию-выноску, но не в размер).

– В документах–моделях команда Копировать свойства доступна на Панели специального управления после вызова большинства команд, размещенных на инструментальной панели Элементы листового тела.
Свойства копируются только между элементами одного и того же типа (например, свойства подсечки можно скопировать только в подсечку, но не в сгиб).
В качестве источника копируемых свойств может быть указан как элемент листового тела в Дереве построения, так и принадлежащий ему примитив в графической области (вершина, ребро, грань).


1.4.2.13. Геометрический калькулятор

Одним из способов задания числовых параметров графических и трехмерных объектов является снятие значений параметров с уже существующих объектов. Для этого используется так называемый геометрический калькулятор.

Команды геометрического калькулятора доступны в контекстном меню поля ввода числового параметра, если в этом поле не находится текстовый курсор. Набор команд зависит от типа параметра.

После вызова команды Геометрического калькулятора требуется указать объект (объекты), параметры которого необходимо снять: навести курсор на нужный объект и, когда объект подсветится, нажать клавишу <Enter> или левую кнопку мыши.

Во время работы геометрического калькулятора изменяется Панель свойств. Все имевшиеся на ней вкладки заменяются одной, название которой соответствует выбранной команде геометрического калькулятора, а на Панели специального управления остаются кнопки Прервать команду и Справка. Они позволяют отказаться от использования геометрического калькулятора или получить справку о текущей команде геометрического калькулятора соответственно.

После указания объекта система автоматически возвращается к выполнению команды, из которой была вызвана команда геометрического калькулятора. Введенное ранее значение редактируемого параметра заменяется измеренным значением.

Если перед вызовом команды Геометрического калькулятора значение было зафиксировано, то в результате работы калькулятора в поле параметра будет внесено новое значение, при этом фиксация сохранится.

В этом разделе:

1.4.2.13.1. Геометрический калькулятор для графических объектов

1.4.2.13.2. Геометрический калькулятор для трехмерных объектов


1.4.2.13.1. Геометрический калькулятор для графических объектов

При работе в графическом документе или в эскизе команды геометрического калькулятора доступны не только в контекстном меню полей ввода числовых параметров, но и в контекстном меню окна документа.

Команды геометрического калькулятора и их назначение приведены в таблице 1.4.3.

Рассмотрим применение геометрического калькулятора на примере построения эллипса, центр которого находится в точке пересечения продолжений отрезков, ось параллельна одному из отрезков, длина полуоси равна длине дуги (рис. 1.4.8).

Рис. 1.4.8. Объекты, параметры которых будет использовать Геометрический калькулятор

Создайте новый графический документ и постройте в нем объекты, показанные на рис. 1.4.8, соблюдая пропорции «на глаз». Затем выполните следующие действия.

1. Вызовите команду Инструменты — Геометрия — Эллипсы — Эллипс.

На Панели свойств появятся поля для ввода параметров эллипса — координат центра, координат концов полуосей, длин полуосей и угла наклона первой полуоси (рис. 1.4.9).

Рис. 1.4.9. Панель свойств при построении эллипса

2. Вызовите контекстное меню в поле координат центра эллипса. Это меню содержит команды геометрического калькулятора для задания положения точки (рис. 1.4.10).

3. Вызовите из этого меню команду На пересечении продолжений кривых.

Рис. 1.4.10. Меню Геометрического калькулятора при задании точки

Вкладка Эллипс на Панели свойств будет заменена вкладкой На пересечении продолжений кривых.

4. Укажите курсором отрезки, на продолжении которых должен быть построен центр эллипса. Точка пересечения продолжений отрезков строится автоматически.

На Панели свойств вновь появится вкладка Эллипс.

Значение координаты точки будет вычислено, занесено в поле Центр и зафиксировано.

5. Вызовите контекстное меню в поле угла наклона первой оси эллипса. Это меню содержит команды геометрического калькулятора для задания угла (рис. 1.4.11).

Рис. 1.4.11. Меню Геометрического калькулятора при задании угла

6. Вызовите из этого меню команду Направление прямой/отрезка, а затем укажите отрезок, параллельно которому должна пройти первая ось эллипса.

Значение угла наклона этого отрезка к оси ОХ текущей системы координат будет вычислено, занесено в поле Угол и зафиксировано.

7. Вызовите контекстное меню в поле длины первой оси эллипса. Это меню содержит команды геометрического калькулятора для задания длины (рис. 1.4.12).

Рис. 1.4.12. Меню Геометрического калькулятора

8. Вызовите из этого меню команду Длина кривой, а затем укажите дугу, длине которой должна равняться длина полуоси эллипса.

Значение длины будет вычислено, занесено в поле Длина 1 и зафиксировано.

9. Длину второй полуоси задайте произвольно.

На этом построение эллипса с заданными параметрами закончено (рис. 1.4.13).

Рис. 1.4.13. Результат построения эллипса

Табл. 1.4.3. Команды Геометрического калькулятора
Команда | Назначение
При вводе значений координат
На пересечении продолжений кривых | Снятие значений координат точки, расположенной на пересечении продолжений указанных элементов.
На расстоянии от точки | Снятие значений координат точки, смещенной от базовой точки на заданную величину.
На расстояниях от двух кривых | Снятие значений координат точки, расположенной на заданных расстояниях от указанных элементов.
Выровнять по двум точкам | Снятие значений координат точки, выровненной по двум точкам. Точка считается выровненной по двум другим точкам, если они являются ее проекциями на оси текущей СК.
Условное пересечение | Снятие значений координат точки, расположенной на пересечении продолжений указанных элементов, с построением условного пересечения. Об условном пересечении см. раздел 3.3.7.19.
Точка кривой, ближайшая к другой кривой | Привязка и снятие значений координат точки, расположенной на указанном элементе и ближайшей к другому указанному элементу.
При вводе значений линейных величин
Длина кривой | Снятие значения длины (периметра) указанного элемента.
Длина сегмента кривой | Снятие значения длины сегмента ломаной или контура, а также стороны многоугольника.
Между двумя точками | Снятие значения расстояния между двумя указанными точками.
Между двумя точками на кривой | Снятие длины участка кривой, ограниченного двумя указанными точками на этой кривой.
Между двумя кривыми | Снятие значения минимального расстояния между двумя указанными объектами.
От точки до кривой — По нормали | Снятие значения кратчайшего расстояния между указанными точкой и кривой.
От точки до кривой — По Y | Снятие значения расстояния между указанными точкой и объектом в положительном направлении оси Y текущей системы координат.
От точки до кривой — Против Y | Снятие значения расстояния между указанными точкой и объектом в отрицательном направлении оси Y текущей системы координат.
От точки до кривой – По X | Снятие значения расстояния между указанными точкой и объектом в положительном направлении оси X текущей системы координат.
От точки до кривой — Против X | Снятие значения расстояния между указанными точкой и объектом в отрицательном направлении оси X текущей системы координат.
Диаметр | Снятие значения диаметра указанной окружности или дуги.
Радиус | Снятие значения радиуса указанной окружности или дуги.
Полуось эллипса - Большая | Снятие длины большой полуоси указанного эллипса.
Полуось эллипса - Малая | Снятие длины малой полуоси указанного эллипса.
Длина строки текста | Снятие длины указанной текстовой строки.
Габарит объекта – По горизонтали | Снятие значения горизонтального габарита указанного объекта.
Габарит объекта – По вертикали | Снятие значения вертикального габарита указанного объекта.
При вводе значений угловых величин
Направление прямой/отрезка | Снятие значения угла между указанной прямой или отрезком и положительным направлением оси X текущей системы координат.
Наклон касательной | Снятие значения угла между касательной к указанному элементу, проходящей через указанную точку на этом элементе, и положительным направлением оси X текущей системы координат.
Наклон нормали | Позволяет выполнить снятие значения угла между нормалью к элементу, проходящей через точку, в которой он был указан, и положительным направлением оси X текущей системы координат.
Раствор дуги | Снятие значения угла раствора указанной дуги окружности.
Между прямыми/отрезками | Снятие значения угла между двумя указанными прямыми или отрезками.
Наклон оси эллипса | Снятие значения угла между большой осью указанного эллипса и положительным направлением оси X текущей системы координат.
По двум точкам (с осью X) | Снятие значения угла между воображаемой линией, проходящей через две указанные точки, и положительным направлением оси X текущей системы координат.
По трем точкам | Снятие значения угла, образованного тремя указанными точками. Порядок указания: вершина угла, точки, лежащие на его сторонах.
Направление строки текста | Снятие значения угла между указанной текстовой строкой и положительным направлением оси X текущей системы координат.
По точке на окружности/дуге | Снятие значения угла между радиусом, проведенным из центра окружности (дуги) в указанную на ней точку, и положительным направлением оси X текущей системы координат.


1.4.2.13.2. Геометрический калькулятор для трехмерных объектов

Меню геометрического калькулятора доступно после вызова команд Сгиб, Сгиб по эскизу, Сгиб по линии, Подсечка, Отверстие в листовом теле, расположенных на инструментальной панели Элементы листового тела, в полях Длина, Ширина, Отступ, Расстояние, Диаметр, Угол, Радиус сгиба.

Набор команд геометрического калькулятора зависит от того, над полем какого параметра, линейного или углового, находился курсор при вызове контекстного меню. Перечень команд и их назначение приведены в таблице 1.4.4. Кроме команд калькулятора, в контекстном меню присутствует команда Копировать свойство.

Команда Копировать свойство позволяет присвоить параметру редактируемого листового элемента такое же значение, как в другом, уже существующем, элементе. Свойства копируются только между элементами одного типа.

Чтобы задать источник копируемого свойства, следует указать нужный листовой элемент в Дереве построения или принадлежащий ему примитив в графической области (ребро, грань и т.д.). В графической области объект, который может быть указан для копирования свойства, при наведении курсора подсвечивается, а его пиктограмма отображается рядом с курсором.

Табл. 1.4.4. Команды геометрического калькулятора

Команда

Назначение

При вводе значений линейных величин

Длина ребра

Снятие значения длины пространственной кривой, кривой в эскизе или ребра.

Расстояние между 2 объектами

Снятие значения расстояния между двумя указанными объектами.

Диаметр

Снятие значения диаметра указанной окружности, дуги, цилиндра или сферы.

Радиус

Снятие значения радиуса указанной окружности, дуги, цилиндра или сферы.

При вводе значений угловых величин

Направление объекта

– Если указан прямолинейный объект — снятие значения угла между указанным объектом и базовой гранью сгиба. Указанный прямолинейный объект должен быть перпендикулярен линии сгиба.

– Если указан плоский объект — снятие значения угла между базовой гранью сгиба и линией пересечения указанного объекта с плоскостью, перпендикулярной линии сгиба. Указанный плоский объект не должен быть перпендикулярен линии сгиба.

Раствор дуги

Снятие значения раствора указанной дуги окружности.

Между 2 объектами

Снятие значения угла между двумя указанными объектами.


1.4.2.14. Отображение параметров объектов рядом с курсором

При создании и редактировании геометрических объектов их параметры могут отображаться не только в полях Панели свойств, но и рядом с курсором (рис. 1.4.14). Это облегчает контроль правильности построений.

Рис. 1.4.14. Отображение параметров объектов рядом с курсором: а) при построении дуги по трем точкам, б) при построении отрезка, параллельного данному
а) | б)

Управление показом параметров осуществляется опцией Отображать параметры команд в диалоге настройки параметров курсора (см. раздел 9.1.7.1).


1.4.2.15. Округление значений параметров

При работе с КОМПАС-документами вы можете включить округление линейных величин. Эта возможность используется во время выполнения различных команд построения и редактирования графических и трехмерных объектов.

Включение и выключение режима округления в окне (окнах) текущего документа производится кнопкой Округление на панели Текущее состояние или клавишей <F7>.

Умолчательная настройка режима округления (включен или выключен) для окон новых документов производится в диалоге настройки курсора (см. раздел 9.1.7.1).

При включенном режиме значения параметров округляются до ближайшего значения, кратного текущему шагу курсора. Величина округляется в меньшую сторону, если разница между ней и ближайшим кратным значением меньше половины шага курсора, и в большую сторону в противном случае.

Рассмотрим работу в режиме округления подробнее на примере построения прямоугольника. Для этого выполните следующие действия.

1. Убедитесь в том, что режим округления отключен.

2. Установите текущее значение шага курсора 5 мм.

3. Вызовите команду Прямоугольник.

4. Укажите положение первой вершины прямоугольника.

5. Перемещайте курсор и наблюдайте за значениями в полях Высота и Ширина на Панели свойств.

6. Вы увидите, что в этих полях отображаются дробные значения с точностью до 0,0001.

7. Нажмите кнопку Округление.

8. Убедитесь, что в полях Высота и Ширина теперь отображаются целые значения, кратные 5, т.е. размеры прямоугольника изменяются дискретно с шагом, равным шагу курсора.

9. Смените значение шага курсора с 5 на 2.

10. Убедитесь, что размеры сторон прямоугольника стали кратны 2.

Обратите внимание на то, что в момент срабатывания привязки режим округления временно отключается. Например, если при построении отрезка его конечную точку указать с помощью какой-либо привязки, скажем, Ближайшая точка, длина отрезка не округлится. Она будет точно равняться расстоянию от первой точки до точки, к которой осуществлялась привязка.

Кроме того, не производится округление значений зафиксированных параметров. Например, при построении отрезка, параллельного данному, вы можете ввести в поле Расстояние на Панели свойств любое значение и зафиксировать его. При указании начальной и конечной точек отрезка его длина будет округляться, а расстояние от базового — нет.

Округление значений при работе с трехмерными объектами проявляется во время «перетаскивания» их характерных точек. Обратите внимание на то, что в деталях и сборках возможно округление не только линейных, но и угловых величин.


2.1. Общие сведения

В этом разделе:

2.1.1. Основные понятия трехмерного моделирования

2.1.1.1. Модель в КОМПАС-3D

2.1.1.2. Объекты модели

2.1.1.2.1. Геометрические объекты

2.1.1.2.2. Элементы оформления

2.1.1.2.3. Объекты «измерение»

2.1.1.2.4. Компоненты

2.1.1.3. Режимы работы с моделью

2.1.1.4. Базовая точка трехмерного объекта

2.1.2. Дерево модели

2.1.2.1. Отображение последовательности построения модели в Дереве построения

2.1.2.2. Отображение структуры модели в Дереве построения

2.1.2.3. Настройка отображения Дерева построения

2.1.2.4. Дополнительное окно Дерева построения

2.1.2.5. Названия и пиктограммы объектов в Дереве

2.1.2.6. Указатель окончания построения модели

2.1.2.7. Иерархия объектов модели

2.1.2.7.1. Иерархические связи между объектами

2.1.2.7.2. Просмотр отношений объектов

2.1.3. Управление изображением модели

2.1.3.1. Масштабирование, сдвиг, поворот и вращение

2.1.3.1.1. Масштабирование и сдвиг изображения

2.1.3.1.2. Поворот модели

2.1.3.1.3. Вращение модели

2.1.3.2. Ориентация модели

2.1.3.2.1. Сохранение текущей ориентации

2.1.3.3. Управление ориентацией в окне модели

2.1.3.4. Отображение модели

2.1.3.5. Перспектива

2.1.3.5.1. Настройка параметров перспективной проекции

2.1.3.6. Режим упрощенного отображения моделей

2.1.3.6.1. Особенности упрощения подсборок

2.1.4. Общие приемы работы в моделях

2.1.4.1. Выбор объектов

2.1.4.1.1. Выделение и указание объектов

2.1.4.1.2. Выбор объектов в окне

2.1.4.1.3. Фильтры объектов

2.1.4.1.4. Выбор скрытых, совпадающих или близко расположенных объектов

2.1.4.1.5. Выбор в Дереве построения

2.1.4.2. Управление параметрами операции

2.1.4.2.1. Общие сведения

2.1.4.2.2. Характерные точки объектов

2.1.4.2.3. Задание значения размера операции

2.1.4.2.4. Особенности задания числовых параметров операции в полях Панели свойств


2.1.1. Основные понятия трехмерного моделирования

2.1. Общие сведения

2.1.1. Основные понятия трехмерного моделирования

В этом разделе:

2.1.1.1. Модель в КОМПАС-3D

2.1.1.2. Объекты модели

2.1.1.2.1. Геометрические объекты

2.1.1.2.2. Элементы оформления

2.1.1.2.3. Объекты «измерение»

2.1.1.2.4. Компоненты

2.1.1.3. Режимы работы с моделью

2.1.1.4. Базовая точка трехмерного объекта


2.1.1.1. Модель в КОМПАС-3D

В КОМПАС-3D возможно создание двух типов моделей: деталь и сборка.

– Деталь — тип модели, предназначенный для представления изделий, изготавливаемых без применения сборочных операций. Создается и хранится в документе «деталь», расширение файла — m3d.

– Сборка — тип модели, предназначенный для представления изделий, изготавливаемых с применением сборочных операций. Создается и хранится в документе «сборка», расширение файла — a3d. Разновидность сборки — технологическая сборка. Создается и хранится в документе «технологическая сборка», расширение файла — t3d.

Трехмерная модель в КОМПАС-3D состоит из объектов. Объекты подразделяются на:

– геометрические,

– элементы оформления,

– объекты «измерение»,

– компоненты.

К геометрическим объектам относятся: тела, поверхности, кривые, точки, эскизы, объекты вспомогательной геометрии. К элементам оформления относятся размеры, условное обозначение резьбы, линии-выноски, обозначения шероховатости, базы, позиции, допуски формы и расположения.

Компонент — это объект модели, в свою очередь являющийся моделью: деталью или сборкой.

Объекты модели создаются и редактируются путем выполнения операций. При создании и редактировании объекта возможно формирование ассоциативной связи его с другим объектом. Ассоциативная связь — это однонаправленная зависимость расположения или геометрии одного объекта от расположения или геометрии другого объекта. Зависимый объект считается производным, а объект, от которого производный объект зависит — исходным по отношению к производному.

Модели в целом, а также отдельным ее частям (телам, компонентам) можно назначить параметры для расчета МЦХ — материал и плотность материала, а также задать свойства — данные об изделии, которое эта модель (часть модели) представляет.

Состав модели, последовательность ее построения и связи между объектами модели отображаются в Дереве построения.


2.1.1.2. Объекты модели

В этом разделе:

2.1.1.2.1. Геометрические объекты

2.1.1.2.2. Элементы оформления

2.1.1.2.3. Объекты «измерение»

2.1.1.2.4. Компоненты


2.1.1.2.1. Геометрические объекты

Геометрические объекты состоят из примитивов. Примитивами являются:

– вершина,

– ребро,

– грань.

Вершина — примитив, представляющий собой точку либо окончание ребра. Частным случаем вершины является ребро нулевой длины (например, вершина конуса).

Ребро — примитив, представляющий собой участок кривой либо граничной линии грани, ограниченный вершинами и не содержащий внутри себя других вершин. В частных случаях ребро может не ограничиваться вершинами (замкнутые ребра).

Грань — примитив, представляющий собой часть поверхности либо поверхность, ограниченную ребрами и не содержащую внутри себя других ребер. В частных случаях грань может не ограничиваться ребрами (например, сферические и тороидальные грани).

Такие объекты, как плоскости и оси, не имеют примитивов.

Остальные объекты, в зависимости от своего типа, состоят из одного или нескольких примитивов. Например, объект «точка» состоит из одной вершины, ломаные и эскизы — из ребер и вершин, тела — из ребер, вершин и граней.

Тело — объект модели, имеющий некоторый объем и соотнесенный с каким-либо материалом. Тело не имеет самостоятельного файлового представления.

Тело, как правило, представляет собой совокупность граней, ребер и вершин. В частном случае тело может быть представлено одной гранью (например, сферическое и тороидальное тела).

Грани тела образуют замкнутую поверхность. Нарушение замкнутости приводит к нарушению целостности тела.

Построение тел в модели описано в разделе 2.3.

Особый вид тел — листовые тела. Они предназначены для моделирования деталей, полученных из листового материала с помощью операций гибки. Построение листовых тел описано в разделе 2.4.

Поверхность — геометрический объект, представленный связной совокупностью граней или одной гранью. Грани поверхности не могут являться гранями каких-либо других объектов (других поверхностей, тел).

Построение поверхностей описано в разделе 2.6.

Эскиз — объект трехмерного моделирования, созданный на плоскости или плоской грани средствами чертежно-графического редактора.

Эскизы используются в некоторых операциях. Например, эскиз может задавать форму сечения тела, полученного операцией выдавливания, контур ребра жесткости и т.п.

Требования к эскизу определяются операцией, в которой он используется.

Построение эскизов описано в разделе 2.2.

Объектами вспомогательной геометрии являются:

– системы координат,

– координатные и вспомогательные плоскости,

– координатные и вспомогательные оси,

– контрольные точки,

– присоединительные точки.

Построение в модели объектов вспомогательной геометрии описано в разделе 2.8.


2.1.1.2.2. Элементы оформления

Элементами оформления являются:

– условное обозначение резьбы,

– размеры:

• линейный,

• угловой,

• диаметральный,

• радиальный,

– обозначения:

• обозначение шероховатости,

• обозначение базы,

• линия-выноска,

• обозначение позиции,

• обозначение допуска формы и расположения.

Построение в модели элементов оформления описано в разделе 2.9.


2.1.1.2.3. Объекты «измерение»

Объект «измерение» — объект, содержащий результаты работы операции измерения.

Объектами «измерение» являются:

– расстояние и угол,

– длина ребра,

– площадь.

Значение, хранящееся в объекте «измерение», всегда соответствует фактическому значению измеренного параметра модели.

Выполнение измерений в модели описано в разделе 2.15.2.


2.1.1.2.4. Компоненты

Компонент — объект модели, представленный другой, хранящейся в отдельном файле, моделью. Компонентами могут являться детали, сборки, стандартные изделия и библиотечные элементы. Особый тип компонента — локальная деталь. Локальная деталь не имеет самостоятельного файлового представления, а хранится непосредственно в содержащей ее модели. Компоненты, в свою очередь, могут включать в себя другие компоненты и так далее.

Один и тот же компонент может быть вставлен в разные модели. Возможна повторная вставка в модель уже имеющегося в ней компонента.

В модели, содержащей компоненты, можно выполнить операции, имитирующие обработку изделия в сборе, например, создать отверстие, проходящее через несколько компонентов. Результат этих операций не передается в файлы компонентов.

Компоненты могут быть связаны друг с другом сопряжениями. Существует два вида сопряжений:

– позиционирующие сопряжения — определенным образом фиксируют один объект относительно другого,

– сопряжения механической связи — определяют закон движения одного объекта относительно другого.

О добавлении в модель компонентов и наложении на них сопряжений рассказано в разделе 2.11.


2.1.1.3. Режимы работы с моделью

В КОМПАС-3D существуют специальные режимы работы с трехмерной моделью (табл. 2.1.1). Включение и отключение этих режимов производится кнопками, расположенными на панели Режимы. Исключением являются режим эскиза и режим редактирования компонента на месте — кнопки включения этих режимов находятся на панели Текущее состояние, и режим сечения модели — его кнопка находится на панели Вид.

Табл. 2.1.1. Режимы работы с моделью
Название | Назначение | Особенности
Режим эскиза (см. раздел 2.2.1.2) | Создание нового или редактирование существующего эскиза. | Доступны команды создания геометрических объектов и размеров.
Режим отображения модели в перспективной проекции (см. раздел 2.1.3.5) | Отображение модели с учетом перспективы. | Степень вносимого перспективой искажения изображения настраивается.
Режим проверки гладкости поверхности (см. раздел 2.15.4) | Визуальная оценка гладкости соединения граней, а также выявление малозаметных изменений кривизны внутри граней. | Все грани модели представляются зеркально отражающими заданное изображение. Вид изображения настраивается.
Режим сечения модели (см. раздел 2.15.5) | Визуальная оценка взаимного расположения деталей и узлов сборочной модели, конструктивных элементов детали, толщины ее стенок и т.д. | Модель отображается усеченной секущей плоскостью или набором плоскостей. При выполнении операций в этом режиме доступно указание вершин, ребер и граней модели, в том числе усеченных, но недоступно указание вершин, ребер и граней сечения.
Режим представления листового тела в развернутом виде (см. раздел 2.4.7.2) | Отображение выбранных пользователем сгибов в согнутом состоянии, остальных — в разомкнутом. | Возможны только следующие действия: – просмотр и печать модели; – измерение геометрических и массо-центровочных характеристик модели.
Режим разнесения компонентов сборки (см. раздел 2.15.7) | Отображение компонентов сборки в разнесенном виде (это может потребоваться для более наглядного представления сборки). | Возможны только следующие действия: – просмотр и печать модели; – создание отчетов.
Режим редактирования компонента на месте (см. раздел 2.11.7.2.1) | Редактирование указанного компонента в текущем окне модели в окружении других компонентов. | Команды построения и редактирования распространяются только на указанный компонент. Остальные компоненты видны в окне, но недоступны для редактирования, их можно использовать при выполнении команд (указывать грани, ребра, вершины).
Режим пересчета размеров модели с использованием допусков (см. раздел 2.10.3) | Пересчет размеров модели с учетом назначенных допусков. Расчет размеров модели производится согласно текущему пересчету (см. раздел 2.10.3.1). | Возможны только следующие действия: – просмотр и печать модели; – измерение геометрических и массо-центровочных характеристик модели, – создание отчетов.
Режим отображения размеров выбранного элемента (см. раздел 2.9.2.2.2) | – Просмотр размеров объекта (эскиза или операции) вне процесса его редактирования. – Изменение значений размеров объекта. | При выборе объекта на экране отображаются его размеры — размеры эскизов или операций, выраженные в линейных или угловых величинах.


2.1.1.4. Базовая точка трехмерного объекта

Базовая точка трехмерного объекта — это точка, которая используется как начальная для построения геометрии объекта в модели. Положение базовой точки объекта определяется системой автоматически и зависит от типа объекта и способа его построения. Например, базовой точкой компонента является начало его абсолютной системы координат, базовой точкой операции, построенной на эскизе, является центр масс кривых этого эскиза.

Базовая точка показывается на экране в виде трех взаимно перпендикулярных векторов.

Например, базовая точка отображается при выборе копируемого объекта для построения массива (рис. 2.1.1).

Рис. 2.1.1. Примеры отображения базовой точки трехмерного объекта: а) базовая точка компонента; б) базовая точка операции выдавливания, построенной на эскизе
а) | б)


2.1.2. Дерево модели

2.1. Общие сведения

2.1.2. Дерево модели

При работе с любой деталью или сборкой на экране может отображаться окно Дерево модели. Это окно всегда находится внутри окна документа-модели.

Окно содержит три вкладки — Построение, Исполнения и Зоны. На вкладке Построение отображается Дерево построения модели. Оно описано в настоящем разделе. Вкладка Исполнения служит для отображения Дерева исполнений модели. Описание этой вкладки приведено в разделе 2.13.1.2. На вкладке Зоны отображается Дерево зон модели. Описание этой вкладки приведено в разделе 2.15.15.1.

Дерево построения модели (далее — Дерево построения) — это графическое представление набора объектов, составляющих модель. Корневой объект Дерева построения — сама модель, т.е. деталь или сборка. Пиктограммы объектов автоматически появляются в Дереве построения сразу после фиксации этих объектов в модели (см. раздел 2.1.2.5).

Объекты модели могут располагаться в Дереве в порядке создания (см. раздел 2.1.2.1) или объединяться по типам и группам (см. раздел 2.1.2.2).

Компоненты модели — детали и подсборки — являются самостоятельными моделями. Поэтому на соответствующих им ветвях Дерева размещаются, в свою очередь, составляющие их объекты.

В верхней части вкладки Построение находится инструментальная панель, содержащая четыре кнопки (табл. 2.1.2).

Табл. 2.1.2. Кнопки инструментальной панели вкладки Построение
Название | Описание
Отображение структуры модели | Управляет способом представления информации в Дереве построения. Если эта кнопка нажата, то в окне Дерева отображается структура модели (см. раздел 2.1.2.2), а если отжата, то — последовательность построения модели (см. раздел 2.1.2.1).
Состав Дерева модели | Позволяет указать, какие типы объектов следует отображать в Дереве построения, а какие — нет. Для сборок также можно включить группирование компонентов (см. раздел 2.1.2.3). Настройка состава возможна, если нажата кнопка Отображение структуры модели.
Отношения | Управляет отображением специальной области, в которой показывается иерархия отношений объекта, выделенного в Дереве построения (см. раздел 2.1.2.7.2). Область отображается в нижней части окна Дерева.
Дополнительное окно Дерева | Позволяет создать дополнительное окно Дерева построения и отобразить в нем раздел или объект, выделенный в Дереве перед нажатием этой кнопки (см. раздел 2.1.2.4).

Дерево построения служит не только для фиксации объектов, но и для облегчения выделения и указания объектов при выполнении команд (см. раздел 2.1.4.1.5).

Размер пиктограмм в Дереве построения можно настроить, см. раздел 9.1.3.8.7.

Контекстные меню объектов и разделов Дерева построения содержат наиболее часто используемые команды: команды управления отображением объектов, команды включения/исключения объектов из расчетов, команды редактирования, удаления и др.

Дерево может содержать дополнительную информацию о модели, представленную в виде специальных значков, которыми отмечены те или иные объекты. Перечень таких обозначений и их описания приведены в таблице 2 Приложения I.

Действие всех команд контекстного меню разделов, за исключением команды Атрибуты, распространяется на все объекты, входящие в этот раздел.

Вы можете отключить показ окна Дерево модели. Для этого вызовите команду Вид — Дерево модели. Чтобы включить отображение окна, вызовите команду повторно. При включенном состоянии рядом с названием команды в меню отображается «галочка».

Команда Вид — Дерево модели управляет отображением лишь главного окна Дерева. Дополнительные окна Дерева, если они созданы, необходимо закрывать вручную.

Если открыто несколько окон одного документа-модели, показ окна Дерево модели может быть включен или выключен в любом из них. Кроме того, в разных окнах документа-модели может быть различный набор дополнительных окон Дерева.

В этом разделе:

2.1.2.1. Отображение последовательности построения модели в Дереве построения

2.1.2.2. Отображение структуры модели в Дереве построения

2.1.2.3. Настройка отображения Дерева построения

2.1.2.4. Дополнительное окно Дерева построения

2.1.2.5. Названия и пиктограммы объектов в Дереве

2.1.2.6. Указатель окончания построения модели

2.1.2.7. Иерархия объектов модели

2.1.2.7.1. Иерархические связи между объектами

2.1.2.7.2. Просмотр отношений объектов


2.1.2.1. Отображение последовательности построения модели в Дереве построения

2.1.2.1. Отображение последовательности построения модели
в Дереве построения

Последовательность построения модели отображается в Дереве построения, если не нажата кнопка Отображение структуры модели, расположенная на инструментальной панели вкладки Построение в окне Дерево модели. При этом объекты модели располагаются в Дереве построения в том порядке, в котором они были созданы (рис. 2.1.2).

Рис. 2.1.2. Последовательность построения модели

При работе с Деревом, отображающим последовательность построения модели, доступны следующие возможности:

– Изменение последовательности операций (см. раздел 2.14.3.6.3),

– Использование Указателя окончания построения (см. раздел 2.1.2.6).


2.1.2.2. Отображение структуры модели в Дереве построения

Структура модели отображается в Дереве построения при нажатой кнопке Отображение структуры модели, расположенной на инструментальной панели вкладки Построение в окне Дерево модели (рис. 2.1.3).

Структура модели представляет собой набор разделов, в которые по типам объединяются объекты модели. Эти разделы отображаются в Дереве построения. Каждый раздел Дерева имеет название и пиктограмму.

Раздел Дерева построения — именованная часть Дерева, состоящая из однотипных объектов модели, например, Эскизы, Тела и т.п.

Внутри разделов объекты располагаются в порядке создания. Названия разделов, их пиктограммы и типы входящих в них объектов приведены в таблице 1 Приложения I.

Рис. 2.1.3. Структура модели

Такие объекты, как Разбиение поверхности, Удалить грани, Сшивка поверхностей могут располагаться в разделе Поверхность или Тело в зависимости от того, к чему они относятся. Например, операция разбиения поверхности тела помещается в раздел, соответствующий этому телу, а операция разбиения поверхности — в раздел Поверхность.

Объекты, которые относятся к нескольким телам, к телу и поверхности или к телу и компоненту одновременно, размещаются на первом уровне Дерева (например, «Фаска», примененная к телу и поверхности; «Отверстие», примененное к телу и к компоненту).

Кроме того, на первом уровне Дерева построения отображаются некоторые ошибочные операции (например, содержащие ошибку «Не задана область применения операции»).

Объекты могут дублироваться в Дереве построения:

– объекты, входящие в макроэлементы, размещаются на своих местах и в разделе Макро;

– поверхности, сформировавшие тело в результате операции Сшивка поверхностей, размещаются в разделе Поверхности и в разделе, соответствующем телу.

Пользователь может настраивать состав Дерева построения, включая или отключая отображение разделов, а для сборок — также разбиение компонентов на группы в зависимости от типа — Сборочные единицы, Детали, Библиотечные компоненты и т.д. (см. раздел 2.1.2.3).

На рисунке 2.1.2 показано отображение последовательности построения той же детали, структура которой приведена на рисунке 2.1.3. Другими словами, эти рисунки демонстрируют различные представления в Дереве одной и той же модели.

Модель может содержать одинаковые компоненты. Например, несколько одинаковых компонентов можно получить, создав массив. Одинаковые компоненты формируют ветвь в разделе Компоненты или в группе компонентов, объединенных по типу (группы отображаются в Дереве при включенной группировке). Название ветви образуется по шаблону: <Имя компонента> (хN), где N — общее количество одинаковых компонентов. На рис. 2.1.4 показаны ветви одинаковых компонентов, а также группы компонентов, объединенных по типам.

Рис. 2.1.4. Структура сборки с отображением групп

Если имя компонента изменяется, то он исключается из ветви одинаковых компонентов и занимает самостоятельное положение в Дереве построения модели.


2.1.2.3. Настройка отображения Дерева построения

Вы можете включать и выключать отображение разделов или групп компонентов в Дереве построения, а также выбирать умолчательный способ представления информации — структура модели или последовательность построения модели.

Кнопка Состав Дерева модели, расположенная на инструментальной панели вкладки Построение в окне Дерево модели, позволяет настроить умолчательный состав Дерева построения и выбрать сохраняемый вид Дерева.

Эта кнопка доступна, если на инструментальной панели вкладки Построение нажата кнопка Отображение структуры модели.

После нажатия кнопки Состав Дерева модели на экране появляется настроечный диалог, описанный в разделе 9.2.7.4.13.

Щелчок мышью по треугольнику справа от кнопки Состав Дерева модели раскрывает меню этой кнопки, содержащее команды, одноименные разделам (рис. 2.1.5). Чтобы включить или выключить отображение раздела в Дереве построения, вызовите нужную команду.

Рис. 2.1.5. Настройка состава Дерева

Команда Группировать компоненты позволяет разбить компоненты в Дереве построения на группы в зависимости от типа — Сборочные единицы, Детали, Библиотечные компоненты и т.д. (см. рис. 2.1.4).

«Галочка» слева от названия команды означает, что отображение соответствующего раздела или группирование компонентов включено, отсутствие «галочки» — отключено.

Существование в Дереве «пустых» разделов и групп невозможно. Поэтому разделы, отображение которых включено, или группы появляются в Дереве только после создания в модели первого объекта соответствующего типа. Например, если в модели нет ни одного эскиза, то и раздела Эскизы в Дереве не будет.

Объекты, входящие в отключенный раздел, по-прежнему отображаются в окне модели (если только их показ не отключен специально).

Если модель открыта в нескольких окнах, то настройка состава Дерева, произведенная в одном из них, распространяется на все окна этой модели.


2.1.2.4. Дополнительное окно Дерева построения

Дополнительное окно Дерева построения — это специальное окно, в котором отображается часть Дерева (объект, раздел или отношения). Например, на рисунке 2.1.6 показано дополнительное окно Дерева построения, в котором отображается раздел «Эскизы».

Рис. 2.1.6. Пример дополнительного окна Дерева построения

Чтобы создать дополнительное окно Дерева построения, в котором будет показан объект или раздел, выделите в Дереве нужный объект или раздел и нажмите кнопку Дополнительное окно Дерева на инструментальной панели Дерева построения. Описание дополнительного окна Дерева для объекта или раздела приведено в текущем разделе.

Чтобы создать дополнительное окно Дерева построения, в котором будут показаны отношения объекта, выделите в Дереве построения или в окне модели нужный объект и вызовите из его контекстного меню команду Отношения в дополнительном окне. Описание просмотра отношений в окне приведено в разделе 2.1.2.7.2.

Для объекта или раздела в дополнительном окне отображается копия выбранной части Дерева построения. Заголовок дополнительного окна Дерева содержит название объекта или раздела, отображающегося в дополнительном окне.

Изменение способа представления информации в Дереве построения, так же как и изменение состава Дерева, не влияет на содержимое дополнительного окна Дерева. На него влияет только изменение модели, касающееся объекта или раздела, который отображается в дополнительном окне.

Например, когда в Дереве отображалась структура модели, было создано дополнительное окно, содержащее раздел «Эскизы». После этого отображение раздела «Эскизы» в Дереве было отключено. В дополнительном окне по-прежнему отображается раздел «Эскизы» со своим содержимым. Затем в Дереве построения было отключено отображение структуры, т.е. объекты перестали группироваться в разделы и начали показываться в порядке создания. В дополнительном окне по-прежнему отображается раздел «Эскизы» со своим содержимым.

Создание же нового эскиза в модели приведет к появлению нового объекта в дополнительном окне с разделом «Эскизы». Удаление, скрытие и исключение какого-либо эскиза (эскизов) из расчетов тоже будет показано в этом дополнительном окне.

При удалении из модели объекта (или всех объектов раздела), отображаемого в дополнительном окне, это окно закрывается.

В дополнительном окне доступны такие же контекстные меню объектов, как и в Дереве построения. Из этих меню можно быстро вызвать часто используемые команды, например, редактирования или удаления объектов. Выделение объекта в дополнительном окне равносильно выделению его в Дереве построения.

Набор дополнительных окон запоминается системой до закрытия окна модели, в котором они были созданы. При повторном открытии этой модели, а также при открытии ее в новом окне дополнительные окна Дерева построения отсутствуют.

Дополнительные окна Дерева построения удобно применять для организации быстрого доступа к часто используемым объектам модели — эскизам, вспомогательной геометрии и т.п.

Например, вы можете, включив отображение в Дереве структуры модели, создать дополнительные окна с разделами «Эскизы» и «Вспомогательная геометрия». Затем вы можете отключить показ этих разделов в Дереве построения, чтобы сократить его, или включить отображение в Дереве последовательности построения модели, если это более удобно для работы.

Если в окне модели создано несколько дополнительных окон Дерева построения, то можно рекомендовать следующие варианты их расположения, позволяющие более рационально использовать площадь экрана:

– зафиксировать все дополнительные окна Дерева у одной границы окна документа, а затем свернуть их к этой границе,

– зафиксировать все дополнительные окна Дерева у одной границы окна документа так, чтобы они образовывали единую панель.


2.1.2.5. Названия и пиктограммы объектов в Дереве

Название каждого объекта можно ввести при его создании. По умолчанию оно присваивается объектам автоматически в зависимости от их типа (Деталь, Сборка, Сборочная единица, Тело и т.д.) или способа, которым они получены (Ось через ребро, Операция вращения, Фаска, Соосность (Крышка – Прокладка) и т.д).

Названия деталей и подсборок, вставленных в модель, берутся из файлов этих компонентов.

В модели может существовать множество однотипных объектов. Чтобы различать их, к сформированному по умолчанию названию объекта автоматически прибавляется порядковый номер объекта данного типа. Например, Скругление:1 и Скругление:2, Сечение плоскостью:1 и Сечение плоскостью:2.

Наименование объектов можно изменить:

– для корневого объекта модели, компонентов и тел — при помощи команды задания свойств модели, компонента, тела (см. раздел 5.1.4.1.1);

– для остальных объектов — при их редактировании (на вкладке Свойства Панели свойств).

Также вы можете переименовать любой объект непосредственно в Дереве построения. Для этого выполните следующие действия:

1. Выделите название объекта в Дереве построения.

2. Щелкните мышью по выделенному названию или нажмите <F2>.

Название станет доступным для редактирования.

3. Введите новое название объекта.

4. Щелкните мышью вне списка объектов дерева или нажмите <Enter>.

Новое название объекта будет сохранено в Дереве построения.

Для корневого объекта модели и компонентов можно включить отображение имен из двух частей, наименования и обозначения (см. раздел 9.2.7.4.14). Чтобы обозначение отображалось, оно должно быть задано как свойство объекта (см. раздел 5.1.4.1.1). При переименовании объекта в Дереве можно изменить только его наименование, но не обозначение, даже если оно отображается.

Рис. 2.1.7. Переименование объектов в Дереве построения

Слева от названия каждого объекта в Дереве отображается пиктограмма. Она соответствует способу, которым этот объект получен. Пиктограмму, в отличие от названия объекта, изменить невозможно. Благодаря этому при любом переименовании объектов в Дереве построения остается наглядная информация о способе их создания.

Обычно пиктограммы отображаются в Дереве построения синим цветом. Если объект выделен, то его пиктограмма в Дереве зеленая. Если объект указан для выполнения операции, то его пиктограмма в Дереве красная.

В Дереве построения на пиктограммах объектов могут появляться значки, свидетельствующие о состоянии того или иного объекта. Например, к пиктограмме компонента добавляется признак запрета на редактирование, признак ошибки и т.п. После изменения состояния объекта значок исчезает или заменяется другим.

Список дополнительных обозначений приведен в таблице 2 Приложения I.


2.1.2.6. Указатель окончания построения модели

Указатель окончания построения модели — горизонтальная линия, ограничивающая Дерево построения снизу или разбивающая его на две части.

Указатель окончания построения присутствует в Дереве, если в нем включено отображение последовательности построения модели (см. раздел 2.1.2.1).

Положение Указателя в Дереве можно изменить. Чтобы переместить указатель, подведите к нему курсор. Когда курсор примет форму двусторонней стрелки, нажмите левую кнопку мыши. Не отпуская кнопку, переместите Указатель вверх или вниз.

Объекты, оказавшиеся в Дереве построения ниже Указателя, условно удаляются. Такие объекты, а также производные от них не отображаются в окне модели, однако информация о них не удаляется из документа. Пиктограммы условно удаленных объектов отображаются в Дереве построения серым цветом и помечаются пиктограммой-«замком».

Вместо перемещения Указателя мышью можно воспользоваться командой Указатель под выделенный объект. Она находится в контекстном меню объекта, выделенного в Дереве построения.

Несмотря на то что при перемещении Указателя мышью его можно подвести вплотную к верхней границе окна Дерева построения, он может располагаться только среди пиктограмм операций.

После каждого перемещения Указателя в Дереве модель перестраивается.

Для быстрого перемещения Указателя в конец Дерева построения можно воспользоваться командой Указатель в конец Дерева из контекстного меню на Указателе.

После перемещения Указателя вниз условно удаленные объекты модели восстанавливаются.


2.1.2.7. Иерархия объектов модели

Иерархия объектов модели — это порядок их подчинения друг другу.

Для создания любого объекта модели используются уже существующие объекты (например, для создания эскиза нужна плоскость или грань, для создания фаски — ребро и т.д.).

Объект, для создания которого использовались любые части и/или характеристики другого объекта, считается подчиненным этому объекту.

Например, эскиз построен на грани элемента выдавливания — эскиз подчиняется элементу. В эскизе есть проекции ребер приклеенного формообразующего элемента — эскиз подчиняется этому элементу. Вырезанный формообразующий элемент построен путем операции над эскизом — элемент подчиняется эскизу. При приклеивании формообразующего элемента глубина его выдавливания задавалась до вершины элемента вращения — элемент выдавливания подчиняется элементу вращения. Фаска построена на ребре кинематического элемента — фаска подчиняется кинематическому элементу. Вспомогательная ось проведена через вершины формообразующих элементов — ось подчиняется этим элементам. Вспомогательная плоскость проведена через ось перпендикулярно грани формообразующего элемента — плоскость подчиняется оси и формообразующему элементу. И так далее.

В иерархии объектов модели КОМПАС-3D существует два типа отношений между объектами.

– Если объект подчинен другому объекту, он называется производным по отношению к подчиняющему объекту.

– Если объекту подчинен другой объект, то подчиняющий объект называется исходным по отношению к подчиненному.

В некоторых системах трехмерного моделирования исходные объекты называются «родителями» или «предками» («parents»), а производные объекты — «детьми» или «потомками» («children»).

Система координат, существующая в модели сразу после ее создания, всегда является исходным объектом (только опираясь на нее или ее элементы — координатные плоскости — можно построить первый эскиз и другие объекты модели) и никогда не является производными объектом (ее параметры не зависят от других объектов).

Последний объект в Дереве построения никогда не является исходным (т.к. после него не строились объекты, которые могли бы на нем основываться).

Все остальные объекты могут быть как исходными, так и производными. Один и тот же объект может быть производным и исходным для разных объектов. Например, отверстие является производным объектом собственного эскиза и исходным объектом для фаски, построенной на ребре этого отверстия.

Объект всегда является производным от одного или нескольких объектов, находящихся выше него в Дереве построения, и может являться исходным для одного или нескольких объектов, находящихся ниже него в Дереве построения.

Однако это правило не определяет однозначно отношения конкретных объектов. По положению объектов в Дереве невозможно судить о том, какие из них являются исходными и/или производными по отношению к данному объекту.

При необходимости вы можете просмотреть отношения любого объекта модели (см. раздел 2.1.2.7.2).

В этом разделе:

2.1.2.7.1. Иерархические связи между объектами

2.1.2.7.2. Просмотр отношений объектов


2.1.2.7.1. Иерархические связи между объектами

Иерархические связи между объектами модели являются неотъемлемой частью этой модели. Пользователь не может отказаться от формирования этих связей или удалить их.

Связи возникают по мере создания объектов модели и существуют, пока эти объекты не будут удалены или отредактированы. Иерархические связи сохраняются при любом перестроении модели.

Например, при создании эскиза на грани формообразующего элемента между эскизом и гранью возникает связь. В результате этот эскиз при любых изменениях модели будет оставаться на «своей» грани (до тех пор, пока его не удалят или не перенесут на другую грань).

Любой объект участвует в иерархических связях со своими исходными и производными объектами. Связи обладают следующими свойствами:

– при изменении исходного объекта меняется производный,

– производный объект можно изменить путем редактирования как исходного объекта, так и собственных, независимых параметров этого производного объекта.


2.1.2.7.2. Просмотр отношений объектов

Чтобы просмотреть отношения, в которых участвует какой-либо объект, нажмите на инструментальной панели Дерева построения кнопку Отношения. В нижней части Дерева появится область просмотра отношений. Затем выделите нужный объект в Дереве построения или любую его часть (например, грань формообразующего элемента) в окне модели. В области просмотра отношений отобразится информация об иерархии отношений выбранного объекта (рис. 2.1.8).

Рис. 2.1.8. Просмотр иерархии

В первой строке области отношений показано название элемента, отношения которого рассматриваются.

В двух разделах, подчиненных рассматриваемому элементу, в виде структурированных списков отображаются элементы, входящие в иерархию этого элемента. Разделы в этих списках можно раскрывать и закрывать, щелкая мышью на значках «+» и «–» рядом с их названиями. Для просмотра длинных списков можно пользоваться линейкой прокрутки.

В разделе Исходные объекты показан список исходных объектов, в разделе Производные объекты — производных. Названия объектов в окне отношений совпадают с их названиями в Дереве построения (если вы вводили новые имена элементов взамен сформированных по умолчанию, эти имена будут показаны в окне отношений).

На первом уровне списка исходных объектов находятся элементы, непосредственно исходные, т.е. непосредственно подчиняющие данный. Если эти элементы в свою очередь подчиняются другим элементам, то на следующем уровне списка находятся вышестоящие исходные элементы.

На первом уровне списка производных объектов находятся элементы, непосредственно производные, т.е. непосредственно подчиненные данному. Если эти элементы в свою очередь подчиняют другие элементы, то на следующем уровне списка находятся нижестоящие производные элементы.

Таким образом, окно отношений позволяет проследить не только прямые (непосредственные), но и косвенные (опосредованные) отношения подчинения.

Иерархию отношений объектов можно просматривать в отдельном окне Дерева построения (рис. 2.1.9). Для этого следует выделить объект в Дереве построения или в окне модели и вызвать из контекстного меню команду Отношения в дополнительном окне.

Рис. 2.1.9. Просмотр иерархии в дополнительном окне Дерева построения

Иерархию объекта требуется знать, как правило, для того чтобы установить, изменение (редактирование или удаление) каких объектов может прямо или косвенно повлиять на данный объект, и на какие объекты может повлиять изменение данного объекта.

Рассмотрим пример определения иерархических отношений объекта.

На рисунках 2.1.8 и 2.1.9 показана иерархия отношений элемента Прилив.

Прилив, судя по его пиктограмме — это приклеенный элемент выдавливания.

Какие объекты являются исходными для Прилива? Чтобы ответить на этот вопрос, проанализируем структурированный список Исходные объекты.

На уровне списка, следующем сразу за Приливом, находятся Основание корпуса и Эскиз прилива. Эти объекты являются непосредственно исходными для Прилива, т.к. напрямую связаны с ним: эскиз использован для формирования элемента выдавливания, а основание корпуса — для автоматического определения глубины выдавливания (при выполнении операции выдавливания была выбрана опция До вершины и указана вершина элемента-основания).

Основание корпуса, судя по его пиктограмме, представляет собой элемент выдавливания. Этот элемент выдавливания создан на основе Эскиза основания (он расположен на следующем уровне иерархического списка).

Эскиз основания, в свою очередь, был создан на Плоскости XY (она расположена в списке на уровне, следующем за Эскизом основания). Эскиз основания и Плоскость XY связаны с Приливом косвенно.

Эскиз прилива был создан на грани Основания корпуса. Поэтому Основание корпуса расположено в списке на уровне, следующем за Эскизом прилива.

Исходные для Основания корпуса объекты были рассмотрены выше, их список повторяется следом за Основанием корпуса. Если объект является исходным для нескольких других объектов, он (вместе со своими исходными объектами) повторяется в списке (возможно, на различных уровнях) соответствующее количество раз.

Основание корпуса и его исходные объекты связаны с Приливом косвенно.

Чтобы рассмотреть производные объекты Прилива, проанализируем структурированный список Производные объекты.

На следующем за Приливом уровне находится пиктограмма эскиза, который называется Профиль отверстия. Этот эскиз построен на грани Прилива и является непосредственно производным по отношению к Приливу.

Профиль отверстия использован для формирования вырезанного элемента вращения (судя по пиктограмме) — Отверстия (оно находится на следующем за эскизом уровне списка). Профиль отверстия и Отверстие связаны с Приливом косвенно.

Других объектов в иерархии Прилива нет.

Аналогичным образом можно проследить иерархические отношения любого объекта трехмерной модели.

Иногда иерархия отношений объекта показывается не полностью. Это свидетельствует о том, что порядок построения модели был изменен вручную.

Например, в модели имелись два элемента выдавливания, причем эскиз второго элемента базировался на грани первого. Таким образом, второй элемент являлся производным по отношению к первому. В списке исходных объектов второго элемента были перечислены: его эскиз, первый элемент, эскиз первого элемента.

Первый элемент перемещается в Дереве так, что оказывается ниже второго (который при этом отмечается в Дереве как ошибочный), а затем возвращается на место (при этом ошибка исчезает). В результате этих действий в числе исходных объектов второго элемента выдавливания останется только эскиз этого элемента.


2.1.3. Управление изображением модели

2.1. Общие сведения

2.1.3. Управление изображением модели

В этом разделе:

2.1.3.1. Масштабирование, сдвиг, поворот и вращение

2.1.3.1.1. Масштабирование и сдвиг изображения

2.1.3.1.2. Поворот модели

2.1.3.1.3. Вращение модели

2.1.3.2. Ориентация модели

2.1.3.2.1. Сохранение текущей ориентации

2.1.3.3. Управление ориентацией в окне модели

2.1.3.4. Отображение модели

2.1.3.5. Перспектива

2.1.3.5.1. Настройка параметров перспективной проекции

2.1.3.6. Режим упрощенного отображения моделей

2.1.3.6.1. Особенности упрощения подсборок


2.1.3.1. Масштабирование, сдвиг, поворот и вращение

Вы можете управлять масштабом изображения модели на экране, сдвигать, поворачивать и вращать модель.

Если в КОМПАС-3D открыто несколько окон модели, в каждом из них может быть свое положение модели и масштаб изображения.

В некоторых случаях результат изменения масштаба и положения модели зависит от расположения в пространстве ее габаритного параллелепипеда. Например, вращение модели может производиться вокруг центра ее габаритного параллелепипеда; после вызова команды Показать все масштаб отображения модели изменяется так, чтобы проекция ее габаритного параллелепипеда на плоскость экрана вписалась в окно модели.

Габаритный параллелепипед модели — условный параллелепипед, грани которого параллельны координатным плоскостям и проходят через наиболее удаленные друг от друга точки объектов модели.

Вы можете выбрать типы объектов, которые будут учитываться при построении габаритного параллелепипеда. Для этого вызовите команду Сервис — Параметры... — Система — Редактор моделей — Габарит и в появившемся диалоге включите нужные опции.

В этом разделе:

2.1.3.1.1. Масштабирование и сдвиг изображения

2.1.3.1.2. Поворот модели

2.1.3.1.3. Вращение модели


2.1.3.1.1. Масштабирование и сдвиг изображения

Для изменения масштаба изображения модели и его сдвига используются следующие команды:

– Команда Сдвинуть (см. раздел 1.4.1.3),

– Команды масштабирования (раздел 1.4.1.2):

• Показать все,

• Увеличить масштаб рамкой,

• Приблизить/отдалить,

• Увеличить масштаб,

• Уменьшить масштаб,

• Показать эскиз полностью,

• Масштаб по выделенным объектам,

• Предыдущий масштаб,

• Последующий масштаб.

Команда сдвига изображения находится в меню Вид, а команды изменения масштаба — в меню Вид — Масштаб.

Кнопки для вызова команды сдвига и некоторых команд масштабирования находятся на панели Вид.

Для быстрого сдвига изображения (без вызова специальной команды) можно воспользоваться клавиатурными комбинациями <Shift> + <стрелки>. Нажатие на любую из них вызывает перемещение изображения в соответствующую сторону.


2.1.3.1.2. Поворот модели

При моделировании детали или сборки обычно возникает необходимость видеть ее с разных сторон. Для поворота модели можно использовать:

– команду Повернуть,

– клавиатурные комбинации,

– мышь.

Поворот модели при помощи команды Повернуть

Чтобы повернуть модель в окне, вызовите команду Вид — Повернуть. Данная команда позволяет поворачивать модель вокруг центра габаритного параллелепипеда всей модели или любого ее объекта, а также вокруг любого объекта модели. Для этого после вызова команда выполните описанные ниже действия.

– Поворот вокруг центра габаритного параллелепипеда.
Нажмите левую кнопку мыши в окне модели, курсор изменит вид — превратится в «звездочку» с двумя дугообразными стрелками. Не отпуская кнопку, перемещайте курсор.

– Поворот вокруг точки (вершины, центра сферы).
Подведите курсор к нужному объекту в окне модели. Когда объект подсветится, а курсор примет вид, соответствующий выбираемому объекту (см. табл. 2.1.8), щелкните левой кнопкой мыши. Затем нажмите левую кнопку мыши и, не отпуская ее, перемещайте курсор (его вид такой же, как при вращении вокруг центра габаритного параллелепипеда).

Направление вращения вокруг центра габаритного параллелепипеда или вокруг точки зависит от направления перемещения курсора (табл. 2.1.3).

Табл. 2.1.3. Зависимость направления поворота модели от перемещения курсора
Направление перемещения курсора | Направление поворота модели
Вертикально | В вертикальной плоскости, перпендикулярной плоскости экрана.
Горизонтально | В горизонтальной плоскости, перпендикулярной плоскости экрана.
По диагонали | Направление складывается из соответствующих вертикальной и горизонтальной компонент.
Горизонтально при нажатой клавише <Alt> | В плоскости экрана.

– Поворот вокруг прямой (оси, прямолинейного ребра, оси конической или цилиндрической грани, касательной к кривой).
Подведите курсор к нужному элементу в окне модели. Когда элемент подсветится, а курсор примет вид, соответствующий выбираемому объекту, щелкните левой кнопкой мыши. Фантом оси или касательной к кривой отобразится на экране. Нажмите левую кнопку мыши и, не отпуская ее, перемещайте курсор (он имеет вид «оси» с двумя дугообразными стрелками).

– Поворот вокруг перпендикуляра к поверхности (грани, координатной или вспомогательной плоскости).
Подведите курсор к нужной точке поверхности и щелкните левой кнопкой мыши. На экране появится фантом перпендикуляра к поверхности в выбранной точке. Нажмите левую кнопку мыши и, не отпуская ее, перемещайте курсор (он примет вид «плоскости» с двумя дугообразными стрелками).

– Поворот вокруг центра габаритного параллелепипеда объекта (операции, кривой и т.п.)

Выделите объект в Дереве модели, затем переместите курсор в окно модели. Нажмите левую кнопку мыши и, не отпуская ее, перемещайте курсор (он примет вид двух дугообразных стрелок).

Чтобы отменить выбор объектов, нажмите кнопку Указать заново на Панели специального управления.

Чтобы выйти из команды поворота, нажмите кнопку Прервать команду или клавишу <Esc>.

Поворот модели при помощи клавиатуры

Чтобы повернуть модель вокруг центра габаритного параллелепипеда без вызова специальной команды, можно воспользоваться клавиатурными комбинациями (они перечислены в таблице 2.1.4).

Табл. 2.1.4. Комбинации клавиш для поворота модели
Комбинация клавиш | Направление поворота
<Ctrl> + <Shift> + <↑> | Вверх в вертикальной плоскости, перпендикулярной плоскости экрана
<Ctrl> + <Shift> + <↓> | Вниз в вертикальной плоскости, перпендикулярной плоскости экрана
<Ctrl> + <Shift> + <→> | Вправо в горизонтальной плоскости
<Ctrl> + <Shift> + <←> | Влево в горизонтальной плоскости
<Alt> + <→> | Против часовой стрелки в плоскости экрана
<Alt> + <←> | По часовой стрелке в плоскости экрана
<Пробел> + <↑> | На 90° вверх в вертикальной плоскости, перпендикулярной плоскости экрана
<Пробел> + <↓> | На 90° вниз в вертикальной плоскости, перпендикулярной плоскости экрана
<Пробел> + <→> | На 90° вправо в горизонтальной плоскости
<Пробел> + <←> | На 90° влево в горизонтальной плоскости
<Alt> + <↑> | На 90° по часовой стрелке в плоскости экрана
<Alt> + <↓> | На 90° против часовой стрелки в плоскости экрана

Угол поворота модели при однократном нажатии комбинации <Ctrl> + <Shift> + <стрелки> или <Alt> + <стрелки> называется шагом угла поворота модели. Его величину можно настроить (см. раздел 9.1.11.5).

Поворот модели при помощи мыши

Если вы пользуетесь мышью с колесом или трехкнопочной мышью, то для вращения модели можно перемещать мышь с нажатым колесом или средней кнопкой.

При этом, если центр габаритного параллелепипеда модели оказывается за пределами экрана (обычно это происходит при значительном увеличении масштаба отображения), в качестве центра вращения используется ближайшая к курсору точка модели.

Если же центр габаритного параллелепипеда не выходит за экран, то вращение происходит вокруг этого центра. В таком случае для вращения модели вокруг ближайшей к курсору точке нажмите и удерживайте клавишу <Ctrl>.

Чтобы модель поворачивалась в плоскости экрана, во время вращения удерживайте нажатой клавишу <Alt>.


2.1.3.1.3. Вращение модели

При просмотре деталей и сборок вы можете запустить непрерывное вращение модели в заданном направлении с заданной скоростью.

Чтобы запустить вращение, выполните следующие действия.

1. Вызовите команду Вращать модель.

2. Нажмите левую кнопку мыши в окне просмотра, переместите курсор в требуемом направлении вращения и отпустите кнопку мыши. Модель начнет вращаться в заданном направлении вокруг центра габаритного параллелограмма.

2.1. Чтобы модель вращалась вокруг определенной точки (вершины детали, центра сферы, точки), подведите курсор к нужному элементу в окне модели. Элемент подсветится, а курсор примет вид, соответствующий выбираемому объекту (см. табл. 2.1.8). Щелкните левой кнопкой мыши, затем нажмите ее и, не отпуская кнопку, переместите курсор в требуемом направлении, затем отпустите кнопку.

2.2. Чтобы модель вращалась вокруг оси, прямолинейного ребра, оси конической или цилиндрической грани либо вокруг касательной к кривой, подведите курсор к нужному элементу в окне модели. Элемент подсветится, а курсор примет вид, соответствующий выбираемому объекту. Щелкните левой кнопкой мыши. Фантом оси или касательной к кривой отобразятся на экране. Нажмите кнопку и, не отпуская ее, переместите курсор в требуемом направлении, затем отпустите кнопку.

2.3. Чтобы модель вращалась вокруг оси, проходящей через указанную точку грани перпендикулярно этой грани, подведите курсор к нужной точке в окне модели и щелкните мышью. На экране отобразится фантом оси, перпендикулярной к поверхности в точке указания. Нажмите левую кнопку мыши и, не отпуская ее, переместите курсор в требуемом направлении, затем отпустите кнопку.

Чем быстрее перемещался курсор при задании направления вращения, тем выше будет скорость вращения.

Чтобы прервать вращение, щелкните мышью в любом месте окна. Модель остановится. При этом команда Вращать модель не прерывается, и вы можете задать другие направление и скорость вращения.

Команда Вращать модель относится к командам программы просмотра. Чтобы использовать эту команду в КОМПАС-3D, добавьте ее в любое меню или на любую панель (см. раздел 9.4.2.1).


2.1.3.2. Ориентация модели

Положение модели относительно наблюдателя называется ориентацией модели.

Для изменения ориентации модели в КОМПАС-3D можно воспользоваться командой поворота модели.

Часто требуется такая ориентация, при которой одна из плоскостей проекций параллельна плоскости экрана (в этом случае изображение модели соответствует ее изображению на чертеже в стандартной проекции, например, на виде сверху или слева). Такую ориентацию трудно получить, поворачивая модель мышью. В этом случае для изменения ориентации можно пользоваться предусмотренным системой списком названий ориентаций.

На панели Вид расположена кнопка Ориентация. Нажатие на стрелку рядом с этой кнопкой вызывает меню с перечнем стандартных названий ориентаций: Сверху, Снизу, Слева, Справа, Спереди, Сзади, Изометрия XYZ, Изометрия YZX, Изометрия ZXY, Диметрия (каждое из них соответствует направлению взгляда наблюдателя на модель).

Выберите из этого меню команду, соответствующую нужной ориентации (рис. 2.1.10). Модель в окне повернется так, чтобы ее положение соответствовало указанному направлению взгляда.

Команды меню ориентаций можно расположить в виде кнопок на отдельной панели и поместить ее в любом удобном месте. Для этого «перетащите» меню ориентаций мышью за заголовок в любом направлении. Будет сформирована панель Ориентация (рис. 2.1.11).

Обратите внимание на отличие панели Ориентация от остальных инструментальных панелей: состав и порядок кнопок на ней изменить невозможно.

Рис. 2.1.10. Выбор названия ориентации | Рис. 2.1.11. Панель Ориентация

Иногда требуется, чтобы параллельной плоскости экрана оказалась не координатная плоскость, а вспомогательная плоскость или плоская грань модели. Чтобы установить такую ориентацию, выделите нужный плоский объект и выберите из списка названий ориентаций или из контекстного меню строку Нормально к…. Модель повернется так, чтобы направление взгляда было перпендикулярно выбранному объекту. Вектор нормали плоского объекта при этом будет направлен к наблюдателю.

Вы можете не только использовать стандартные названия ориентаций, но и сохранять текущую ориентацию под каким-либо именем (см. раздел 2.1.3.2.1), а затем возвращаться к ней в любой момент, выбрав это имя из списка. В пользовательской ориентации может быть сохранена информация о состояниях слоев на момент ее создания. В этом случае после применения ориентации изменяется не только положение модели, но и состояния слоев.

В этом разделе:

2.1.3.2.1. Сохранение текущей ориентации


2.1.3.2.1. Сохранение текущей ориентации

Чтобы сохранить текущую ориентацию модели, выполните следующие действия.

1. Нажмите кнопку Ориентация на панели Вид.

На экране появится диалог Ориентация вида (рис. 2.1.12).

Рис. 2.1.12. Диалог выбора ориентации вида

В колонке Имя содержится список существующих в модели названий ориентаций. В колонке Состояние слоев показано, хранятся ли в ориентациях сведения о состояниях слоев. О слоях в модели подробно рассказано в разделе 2.15.14.

2. Нажмите на инструментальной панели диалога кнопку Добавить. В списке ориентаций появится новая ориентация. Вы можете изменить название ориентации.

Если в модели, кроме системного слоя, существует еще хотя бы один слой, то по умолчанию опция в столбце Состояние слоев новой ориентации включена. При включенной опции вместе с информацией о положении модели в текущей ориентации сохраняется информация о состоянии слоев.Чтобы отменить сохранение состояния слоев, опцию нужно отключить.

3. Выйдите из диалога. Для этого нажмите кнопку Выход.

В диалоге выбора ориентации можно не только создать новую ориентацию, но и выбрать существующую, а также удалить из списка созданную пользователем ориентацию.

– Чтобы выбрать существующую ориентацию, установите выделение на ее названии в списке и нажмите кнопку Применить диалога. Изображение будет перестроено в соответствии с указанным направлением взгляда.

– Чтобы удалить ориентацию из списка, установите выделение на ее имени и нажмите кнопку Удалить на инструментальной панели диалога. Указанное название исчезнет из списка. Удаление стандартных названий ориентаций (они начинаются с символа «#») не допускается.

Пользовательские ориентации отображаются и в меню ориентаций (рис. 2.1.13). Для установки пользовательской ориентации можно вызвать нужную команду из этого меню.

Рис. 2.1.13. Новая ориентация в меню

Если в КОМПАС-3D открыто несколько окон модели, в каждом из них может быть своя ориентация модели.


2.1.3.3. Управление ориентацией в окне модели

Ориентацию модели можно изменить, поворачивая мышью элемент управления ориентацией, расположенный в левом нижнем углу окна модели. Он состоит из трех объемных стрелок красного, зеленого и синего цветов, показывающих положительные направления осей X, Y, Z абсолютной системы координат (см. раздел 2.8.3.1).

Исходное положение элемента соответствует ориентации Изометрия YZX. Во всех изометрических ориентациях центральная точка элемента обозначается кубиком, а в других — сферой (рис. 2.1.14).

Рис. 2.1.14. Элемент управления ориентацией: а) в изометрии, б) в произвольной ориентации
а) | б)

Элемент управления активизируется и на нем появляются дуги, если курсор находится вблизи элемента. При выборе на элементе стрелки, плоскости или дуги они подсвечиваются, вид курсора изменяется. Щелчок мышью по стрелке, плоскости или дуге (или вращение дуги мышью) поворачивает модель в пространстве, щелчок по сфере — возвращает в исходное положение. Подробно приемы работы описаны в таблице 2.1.5.

Табл. 2.1.5. Приемы смены ориентации в окне модели
Действие | Описание результата
Щелчок по стрелке или перпендикулярной ей плоскости | Ориентация спереди, сзади, сверху, снизу, слева, справа — стрелка направлена на наблюдателя.
<Shift> + щелчок по стрелке или перпендикулярной ей плоскости | Ориентация спереди, сзади, сверху, снизу, слева, справа — стрелка направлена от наблюдателя.
<Ctrl> + щелчок по стрелке | Поворот плоскости, перпендикулярной стрелке, на 180° (вокруг одной из осей этой плоскости): – если указана стрелка X — поворот плоскости YZ вокруг оси Z, – если Y — поворот плоскости ZX вокруг оси X, – если Z — поворот плоскости XY вокруг оси Y.
<Ctrl> + <Shift> + щелчок по стрелке | Поворот плоскости, перпендикулярной стрелке, на 180° (вокруг другой оси плоскости): – если указана стрелка X — поворот плоскости YZ вокруг оси Y, – если Y — поворот плоскости ZX вокруг оси Z, – если Z — поворот плоскости XY вокруг оси X.
<Alt> + щелчок по стрелке | Поворот плоскости, перпендикулярной стрелке, на 90 ° вокруг данной оси.
<Alt> + <Shift> + щелчок по стрелке | Поворот плоскости, перпендикулярной стрелке, на 90 ° вокруг данной оси — в противоположном направлении.
«Поворот мышью» дуги | Поворот плоскости дуги на произвольный угол.
<Ctrl> + щелчок по дуге | Поворот плоскости дуги с шагом 15° (величина по умолчанию). Шаг угла задается в настройках модели (см раздел 9.1.11.5).
<Ctrl> + <Shift> + щелчок по дуге | Поворот плоскости с шагом приращения угла — в противоположном направлении.
Щелчок по сфере | Возврат в положение ориентации Изометрия YZX.
<Alt> + <Ctrl> + <Shift> + прокрутка колеса мыши (при нахождении курсора в области элемента) | Увеличение/уменьшение элемента управления ориентацией.


2.1.3.4. Отображение модели

При работе в КОМПАС-3D доступно несколько типов отображения модели. Чтобы установить тип отображения, выберите его название в меню Вид — Отображение или нажмите соответствующую кнопку на панели Вид (см. табл. 2.1.6).

Табл. 2.1.6. Типы отображения моделей
Тип | Описание | Как выглядит
Каркас | Совокупность всех ребер и линии очерка модели1. |
Без невидимых линий | Совокупность видимых ребер, видимых частей ребер и видимых частей линии очерка модели. |
Невидимые линии тонкие | Невидимые ребра, невидимые части ребер, невидимые части линии очерка отображаются отличающимся от видимых линий цветом1(более светлым). |
Полутоновое отображение | Отображается поверхность модели. Учитываются оптические свойства ее поверхности (цвет, блеск, диффузия и т.д.). |
Полутоновое отображение с каркасом | Объединение полутонового отображения и отображения без невидимых линий. |
  1. Каким бы ни был тип отображения, он не оказывает влияния на свойства модели. Например, при выборе каркасного отображения модель остается сплошной и твердотельной (а не превращается в набор «проволочных» ребер), просто ее поверхность и материал не показываются на экране.

Если в КОМПАС-3D открыто несколько окон, в каждом из них может быть включен свой тип отображения.


2.1.3.5. Перспектива

Любой оптический прибор (например, глаз человека или фотоаппарат) воспринимает изображение предметов, протяженных вдоль его оси, с искажением, иначе говоря, в перспективе. Перспективу иногда требуется учитывать для получения реалистичного изображения трехмерной модели.

В КОМПАС-3D предусмотрено отображение модели в перспективной проекции. Для получения отображения модели с учетом перспективы вызовите команду Вид — Отображение — Перспектива. Кнопка для вызова этой команды расположена на панели Вид.

Чтобы отключить отображение модели в перспективной проекции, отожмите кнопку Перспектива или повторно вызовите команду Вид — Отображение — Перспектива.

С перспективной проекцией можно сочетать все типы отображения, перечисленные в разделе 2.1.3.4.

Рис. 2.1.15. Перспективное полутоновое отображение модели

В этом разделе:

2.1.3.5.1. Настройка параметров перспективной проекции


2.1.3.5.1. Настройка параметров перспективной проекции

Степень вносимого перспективой искажения изображения можно настроить.

Для этого вызовите команду Сервис — Параметры.

На экране появится диалог Параметры.

– Если требуется настроить перспективу только в текущем окне, активизируйте вкладку Текущее окно и выберите пункт Параметры перспективной проекции.

– Если требуется настроить перспективу во всех вновь открываемых окнах, активизируйте вкладку Система и выберите пункт Редактор моделей — Параметры перспективной проекции.

В диалоге находится единственное поле — Расстояние в габаритах модели. Его значение показывает, во сколько раз расстояние от модели до плоскости изображения больше, чем максимальный габарит модели. Другими словами, на экране показывается такое изображение модели, которое получил бы оптический прибор, находящийся на указанном расстоянии от модели. Чем меньше указанное расстояние, тем сильнее заметно искажение изображения.


2.1.3.6. Режим упрощенного отображения моделей

По умолчанию в деталях и сборках включен режим упрощенного отображения.

При этом относительно мелкие компоненты и тела модели заменяются параллелепипедами соответствующих габаритов и цветов в следующих случаях:

– сдвиг и поворот модели мышью или с помощью команд Сдвинуть и Повернуть,

– изменение ориентации и масштаба (если включена плавность, см. раздел 9.1.11.6),

– установка мелкого масштаба отображения,

– сдвиг и поворот отдельных компонентов (при определенных условиях).

После завершения изменения положения или масштаба, а также после увеличения масштаба, отображение модели восстанавливается. Режим упрощения действует при всех типах отображения модели.

Чтобы выключить режим упрощенного отображения модели, вызовите команду Вид — Упрощения — Упрощенное отображение или отожмите кнопку Упрощенное отображение на панели Вид.

Настройка работы режима упрощенного отображения производится в диалоге настройки системы (см. разделы 9.1.11.16.1 и 9.1.11.16.2).

При работе с моделью, содержащей компоненты, обратите внимание на следующую особенность. Если ни один из объектов компонента не учитывается при определении габарита (см. раздел 9.1.11.13), то при упрощенном отображении модели этот компонент не показывается в окне.

В этом разделе:

2.1.3.6.1. Особенности упрощения подсборок


2.1.3.6.1. Особенности упрощения подсборок

Отображение подсборок в упрощенном виде имеет следующие особенности.

– Параллелепипед, которым заменяется подсборка, отображается цветом, заданным для этой подсборки при настройке ее свойств. Цвета, заданные для отдельных деталей, не учитываются.

– Если сборка разнесена, то параллелепипед, заменяющий подсборку, располагается в пространстве в соответствии с параметрами разнесения, заданными для этой подсборки. Параметры разнесения, заданные для отдельных деталей подсборки, игнорируются.


2.1.4. Общие приемы работы в моделях

2.1. Общие сведения

2.1.4. Общие приемы работы в моделях

В этом разделе:

2.1.4.1. Выбор объектов

2.1.4.1.1. Выделение и указание объектов

2.1.4.1.2. Выбор объектов в окне

2.1.4.1.3. Фильтры объектов

2.1.4.1.4. Выбор скрытых, совпадающих или близко расположенных объектов

2.1.4.1.5. Выбор в Дереве построения

2.1.4.2. Управление параметрами операции

2.1.4.2.1. Общие сведения

2.1.4.2.2. Характерные точки объектов

2.1.4.2.3. Задание значения размера операции

2.1.4.2.4. Особенности задания числовых параметров операции в полях Панели свойств


2.1.4.1. Выбор объектов

В этом разделе:

2.1.4.1.1. Выделение и указание объектов

2.1.4.1.2. Выбор объектов в окне

2.1.4.1.3. Фильтры объектов

2.1.4.1.4. Выбор скрытых, совпадающих или близко расположенных объектов

2.1.4.1.5. Выбор в Дереве построения


2.1.4.1.1. Выделение и указание объектов

Для выполнения многих команд построения трехмерных элементов требуется указание или выделение объектов, на которых базируется это построение — эскизов, вершин, ребер и граней, вспомогательных осей и плоскостей, и т.п.

– Выделение объектов происходит, когда не активна ни одна команда трехмерных построений. Объекты выделяют для того, чтобы их просмотреть, или перед вызовом какой-либо команды. Например, элемент можно выделить для того, чтобы вызвать команду редактирования его параметров. Для отмены выделения объекта можно щелкнуть мышью в свободном месте окна модели или нажать клавишу <Esc>.

– Указание объектов происходит в процессе задания параметров текущей команды. Например, после вызова команды создания элемента по сечениям нужно последовательно указывать эскизы-сечения.

Выделение или указание объекта производится щелчком мыши на нем в окне модели.

Часто для выполнения команды требуется выбрать объект, обладающий определенными геометрическими свойствами. Например, для отсечения части модели плоскостью необходимо указать объект, который будет играть роль плоскости отсечения. Таким объектом может являться плоская грань, координатная или вспомогательная плоскость.

По наличию у объекта тех или иных геометрических свойств он относится к одному из типов, приведенных в таблице 2.1.7.

Объекты можно выбирать в окне модели (см. раздел 2.1.4.1.2) или в Дереве построения (см. раздел 2.1.4.1.5). При этом в Дереве построения объект выбирается целиком, а в окне модели можно выбрать отдельные части объекта (если они есть). Например, чтобы в качестве направляющей для кинематической операции использовать всю ломаную, следует указать ее в Дереве построения, а чтобы использовать один или несколько сегментов ломаной, нужно указывать их в окне модели. Еще пример: указав поверхность выдавливания в Дереве построения, можно найти все линии пересечения ее с плоскостью, а указав в окне отдельную грань этой поверхности — линию пересечения грани с плоскостью.

Указание такого объекта, как тело, возможно лишь в Дереве построения. Для этого в Дереве должно быть включено отображение структуры модели (см. раздел 2.1.2.2).

Выделение тела возможно не только в Дереве построения, но и в окне модели. Для этого надо выделить грань, ребро или вершину тела, а затем вызвать из контекстного меню команду Выбрать тело.

Табл. 2.1.7. Типы объектов модели
Тип объектов | Объекты, относящиеся к данному типу
Точечные объекты | – начало координат, – характерная точка геометрического объекта в эскизе, – отдельная точка в эскизе, – отдельная точка в пространстве, – вершина пространственной кривой, – вершина ребра, – точки группы, – точки в составе экземпляров массива точек, – контрольные и присоединительные точки.
Прямолинейные объекты | – отрезок, – отрезок в эскизе, – сегмент ломаной, – координатная или вспомогательная ось, – прямолинейное ребро.
Плоские объекты | – координатная или вспомогательная плоскость, – плоская грань, – плоскость эскиза (для некоторых команд).


2.1.4.1.2. Выбор объектов в окне

Во время прохождения курсора над моделью система автоматически производит динамический поиск объектов.

Динамический поиск — это поиск объекта под курсором. Если объект найден, то он подсвечивается, а его символ (см. табл. 2.1.8) появляется рядом с курсором. При смещении курсора подсвечивание снимается, символ исчезает, и динамический поиск возобновляется.

Динамический поиск при выполнении операции производится с учетом типов объектов. Во время прохождения курсора над моделью подсвечивается объект требуемого в данный момент типа.

Чтобы указать или выделить объект в окне модели, подведите к нему курсор. Когда рядом с курсором появится символ текущего объекта, а сам объект подсветится, щелкните левой кнопкой мыши.

Табл. 2.1.8. Вид курсора при выборе различных типов объектов

Объект

Вершина

Ребро

Грань или поверхность

Ось

Плоскость

Компонент

Тело

Пространственная кривая или ребро

Поверхность

Эскиз

Условное изображение резьбы

Начало абсолютной или локальной системы координат

Точка

Контрольная или присоединительная точка

Линейный размер

Линейный размер от отрезка до точки

Радиальный размер

Диаметральный размер

Угловой размер

Обозначение шероховатости

Обозначение базы

Линия-выноска

Обозначение маркировки

Обозначение клеймения

Обозначение допуска формы и расположения

Обозначение позиции

Щелчок мышью на объекте при нажатой клавише <Shift> позволяет выделить в окне модели компонент, элементом которого является или в состав которого входит указанный объект. Таким образом вы можете, например, выделить всю деталь, указав один из ее элементов — грань, ребро или вершину. Если при нажатой клавише <Shift> выбирается какой-либо вспомогательный элемент, то в окне модели подсвечивается деталь или подсборка, которой принадлежит выбранный вспомогательный элемент.

Иногда для выполнения команды требуется выделение группы объектов.

Чтобы выделить в окне модели несколько объектов (граней, эскизов, вспомогательных элементов и т.п.), следует выбирать их, удерживая нажатой клавишу <Ctrl>.

Чтобы выделить в окне модели несколько деталей, следует выбирать их, удерживая нажатой клавишу <Shift>.

Выбор групп объектов и деталей можно совместить. Это означает, что можно сначала выделить, например, несколько объектов, удерживая клавишу <Ctrl>, затем отпустить ее, нажать клавишу <Shift> (при этом выделение с объектов не снимается) и, удерживая ее, выделить несколько деталей. Таким образом в окне модели будут одновременно выделены группа объектов и группа деталей.


2.1.4.1.3. Фильтры объектов

Иногда в «ловушку» курсора при прохождении курсора над моделью попадает сразу несколько объектов (например, грань и ее ребро), причем подсвечивается не тот объект, который вы хотите указать.

Для облегчения выбора объектов нужного типа используются Фильтры объектов. Чтобы включить их, активизируйте панель Фильтры (см. рис. 2.1.16).

Рис. 2.1.16. Панель Фильтры

По умолчанию на панели нажата кнопка Фильтровать все. Нажатие этой кнопки означает, что подсвечиваются и могут быть указаны (выделены) курсором и вершины, и ребра, и грани, и оси, и плоскости и т.д. — все объекты, приведенные на панели Фильтры.

Если для выполнения задуманного вами действия необходимо указание (выделение) определенных объектов (или примитивов объектов), нажмите соответствующую кнопку на панели Фильтры. Если нажата одна из этих кнопок, то кнопка Фильтровать все выключается.

Если выключаются все кнопки, соответствующие типам примитивов или объектов, то кнопка Фильтровать все автоматически включается (то есть полностью отключить указание всех типов примитивов и объектов невозможно).

Команды фильтрации условно поделены на три группы:

– 1-я группа — фильтрация трехмерных примитивов: граней, ребер, вершин,

– 2-я группа — фильтрация объектов, имеющих примитивы; к таким объектам относятся компоненты, тела, поверхности, эскизы, кривые, точки,

– 3-я группа — фильтрация объектов, не имеющих примитивов; к таким объектам относятся конструктивные оси и плоскости, элементы оформления.

Кнопки вызова команд этих групп разграничены на панели Фильтры разделителями.

Вы можете выбрать несколько типов объектов для фильтрации, нажав нужные кнопки на панели Фильтры. Переключать кнопки фильтров можно в любой момент работы с моделью.

Фильтрация несколькими фильтрами одновременно может быть произведена следующими способами.

– Сочетание фильтров. Если фильтры выбраны только из 1-й, или только из 2-й, или только из 3-й группы, то в результате вы можете отфильтровать или все примитивы, или все объекты, кнопки которых нажаты. Объекты при этом выделяются целиком.

• Пример 1. При нажатых кнопках Фильтровать компоненты и Фильтровать поверхности для выбора доступны все компоненты и поверхности модели.

При выборе объекта курсор принимает вид, соответствующий динамическому поиску компонента или поверхности.

• Пример 2. При нажатых кнопках Фильтровать вершины, Фильтровать ребра для выбора доступны все вершины и ребра модели.

При выборе объекта курсор принимает вид, соответствующий динамическому поиску вершин или ребер.

– Наложение фильтров. Если выбраны фильтры одновременно из 1-ой и из 2-ой группы, то в результате вы можете отфильтровать примитивы, имеющиеся у объектов выбранного типа. При этом выделяются не целые объекты, а их примитивы — ребра, грани или вершины.

• Пример 3. При нажатых кнопках Фильтровать ребра и Фильтровать компоненты для выбора доступны только ребра компонентов.

При выборе объекта курсор принимает вид, соответствующий динамическому поиску ребер.

• Пример 4. При нажатых кнопках Фильтровать грани и Фильтровать точки фильтрация не производится, так как точка не имеет примитива «грань».

Фильтры 3-ей группы в наложении не участвуют, а производят фильтрацию как при сочетании фильтров.


2.1.4.1.4. Выбор скрытых, совпадающих или близко расположенных объектов

Иногда объект, который требуется выбрать в окне модели, расположен близко к другим объектам, или наложен на них, или скрыт под ними. При этом трудно (а иногда и вовсе невозможно) указать его курсором.

Для выбора любого из близко расположенных (в том числе наложенных друг на друга) объектов воспользуйтесь перебором объектов. Перебор возможен, когда система ожидает указания или выделения объекта, а в «ловушку» курсора попадает более одного объекта.

Чтобы выбрать один из скрытых, совпадающих или близко расположенных объектов, выполните следующие действия.

1. Наведите курсор на группу объектов, содержащую нужный объект.

2. Не выбирая ни один из них, вызовите из контекстного меню команду Перебор объектов. Можно также нажать комбинацию клавиш <Ctrl>+<t>.

3. Перебирайте объекты, нажимая клавишу <Пробел> или вызывая команду Следующий объект из контекстного меню. Объекты, на которые указывал курсор в момент вызова команды перебора, будут поочередно подсвечиваться.

4. После подсвечивания нужного объекта выйдите из режима перебора с подтверждением выбора. Для этого вызовите команду Выбрать подсвеченный объект из контекстного меню или нажмите клавишу <Enter>. Можно также щелкнуть мышью на подсвеченном объекте или в любом свободном месте окна документа.

5. Для выхода из режима перебора без указания объекта вызовите из контекстного меню команду Отказ от перебора. Можно также нажать клавишу <Esc>.

Если перебор использовался для указания объекта при выполнении какой-либо команды, система вернется к этой команде.


2.1.4.1.5. Выбор в Дереве построения

Некоторые объекты нужно выделять и указывать не только в окне редактирования модели, но и в Дереве построения.

Чтобы указать или выделить объект в Дереве, щелкните мышью по его названию или пиктограмме.

Таким способом вы можете выделить или указать эскиз, плоскость, ось, формообразующий или конструктивный элемент (например, элемент, приклеенный операцией вращения, или отверстие, или фаску), компонент или сопряжение.

Указание и выделение объектов в Дереве может производиться только в режиме трехмерных построений. Если система находится в режиме эскиза, указание и выделение объектов в Дереве построения невозможно, несмотря на то что Дерево видно на экране.

При указании или выделении в Дереве любого объекта соответствующая ему часть модели подсвечивается или выделяется в окне.

Если в Дереве выделено сопряжение, то в окне модели выделяются объекты, участвующие в этом сопряжении.

Чтобы выделить несколько объектов в Дереве построения, указывайте их, удерживая нажатой клавишу <Ctrl>.

Чтобы выделить в Дереве построения группу объектов, расположенных подряд друг за другом, выделите первый (последний) из этих объектов, нажмите и удерживайте клавишу <Shift>, затем выделите последний (первый) объект. Выделение будет распространено на все объекты группы.

После того как объект выделен любым способом (в том числе в окне модели), соответствующая ему пиктограмма в Дереве построения из синей превращается в зеленую. Например, при указании ребра цвет изменяет пиктограмма операции, образовавшей это ребро, а при указании плоскости цвет изменяет пиктограмма этой плоскости.

После того как объект указан любым способом, соответствующая ему пиктограмма в Дереве модели из синей превращается в красную. Например, при указании грани цвет изменяет пиктограмма операции, образовавшей эту грань, а при указании эскиза цвет изменяет пиктограмма этого эскиза.

Компоненты отображаются в Дереве построения в виде пиктограмм. Слева от пиктограммы расположен знак «+». Он означает, что список объектов, составляющих компонент, свернут. Таким образом, объекты, из которых состоит компонент, могут быть не видны в Дереве даже в том случае, если они выделены в окне модели.

Чтобы увидеть в Дереве объект, выделенный в окне модели, используйте команду Сервис — Показать в дереве. После вызова команды пиктограмма этого объекта выделяется зеленым цветом, а Дерево построения разворачивается так, чтобы она была видна.

Если в окне модели выделен объект, принадлежащий формообразующему элементу (например, грань элемента выдавливания), после вызова команды Показать в дереве в Дереве построения выделяется пиктограмма соответствующего формообразующего элемента.


2.1.4.2. Управление параметрами операции

В этом разделе:

2.1.4.2.1. Общие сведения

2.1.4.2.2. Характерные точки объектов

2.1.4.2.3. Задание значения размера операции

2.1.4.2.4. Особенности задания числовых параметров операции в полях Панели свойств


2.1.4.2.1. Общие сведения

В КОМПАС-3D объекты модели создаются и редактируются путем выполнения операций. Большинство операций имеют определенный набор числовых параметров. Например, числовыми параметрами операции выдавливания являются расстояние выдавливания, угол наклона и толщина стенки, операции масштабирования — коэффициент масштабирования.

Каждому числовому параметру операции соответствует характерная точка трехмерного объекта. Характерные точки отображаются на экране во время выполнения операции в виде черных квадратов.

Если значение параметра операции выражено в линейных или угловых величинах, то этот параметр отображается на экране во время выполнения операции в виде размера соответствующего типа (размера операции).

В приведенных выше примерах расстояние выдавливания, угол наклона и толщина стенки отображаются в виде соответствующего размера и характерной точки; коэффициент масштабирования отображается только в виде характерной точки.

Некоторые операции создаются на основе эскиза. Если в эскизе пользователем проставлены размеры, то при создании операции эти размеры также отображаются на экране.

Размеры эскизов и операций отображаются на экране при создании или редактировании операций, если в диалоге настройки отображения размеров и обозначений включена опция Размеры эскизов и операций (о настройке отображения размеров и обозначений см. раздел 9.1.11.12).

Подробнее о размерах эскизов и операций см. раздел 2.9.2.2.

На рисунке 2.1.17 показан пример построения элемента выдавливания на основе эскиза. На фантоме элемента отображаются:

– характерные точки — в виде черных квадратов,

– размеры операции — расстояние выдавливания (25), угол наклона (10°), толщина стенки (12),

– размеры эскиза — высота (60), ширина (76).

Рис. 2.1.17. Пример построения элемента выдавливания на основе эскиза

Для каждого числового параметра операции автоматически создается переменная. Переменная для размера эскиза создается пользователем (см. раздел 7.2.2.20). Имена переменных отображаются под размерными линиями размеров. Если имена переменных не отображаются, вызовите команду Вид — Имена переменных в размерах.

Значением числового параметра может являться число или константа. Кроме того, значение параметра можно задать математическим выражением.

Для задания числовых параметров операции можно использовать следующие приемы:

– ввод значения параметра или выражения для вычисления значения параметра в соответствующее поле Панели свойств (о вводе значений в поля Панели свойств см. раздел 1.4.2.5, о синтаксисе выражений см. раздел 7.1.3.3.1);

– перемещение характерной точки мышью (см. раздел 2.1.4.2.2);

– задание значения размера эскиза или размера операции (см. раздел 2.1.4.2.3).

Если числовой параметр операции отображается на экране в виде размера, то на значение этого параметра вы можете задать допуск. Назначение допуска на значение параметра операции описано в разделе 2.10.2.2.

Числовые значения параметров операции можно изменить после создания операции. Подробнее редактирование числовых параметров операции описано в разделе 2.14.3.3.


2.1.4.2.2. Характерные точки объектов

Использование характерных точек позволяет во время построения объектов изменять различные их параметры (размеры, положение, форму и др.) без помощи клавиатуры — путем перемещения точек мышью.

Характерные точки трехмерных объектов соответствуют числовым параметрам операции (числовым полям, находящимся на Панели свойств). Характерные точки отображаются на экране в виде черных квадратов.

Некоторые объекты (например, спирали, элементы выдавливания и др.) имеют довольно много числовых параметров. Отображение сразу всех характерных точек этих объектов невозможно, поэтому на экране одновременно показываются только те точки, которые соответствуют числовым полям, находящимся на текущей вкладке Панели свойств. В качестве примера такого объекта рассмотрим коническую спираль. Сразу после вызова команды Спираль коническая на Панели свойств активна вкладка Построение. На ней расположены четыре числовых поля, поэтому фантом спирали имеет четыре характерные точки (рис. 2.1.18, а). При переключении на вкладку Диаметр эти характерные точки исчезают и появляются другие — соответствующие числовым полям вкладки Диаметр (рис. 2.1.18, б).

Рис. 2.1.18. Характерные точки конической спирали: а) активна вкладка Построение Панели свойств; б) активна вкладка Диаметр Панели свойств
а) | б)

Чтобы изменить значение какого-либо параметра, необходимо активизировать соответствующую ему характерную точку и переместить ее.

Для активизации точки подведите к ней курсор мыши. После того как точка будет выделена и рядом с ней появится надпись, содержащая имя и значение параметра (или выражение для вычисления значения параметра), нажмите левую кнопку мыши.

Не отпуская кнопку, перемещайте мышь. Вслед за курсором будет перемещаться выбранная характерная точка, значение соответствующего ей параметра будет изменяться и отображаться в надписи рядом с курсором. Фантом объекта будет динамически перестраиваться. После того как нужное значение будет достигнуто, отпустите кнопку мыши.

Значения некоторых параметров могут откладываться как в одну, так и в другую сторону от нейтрального положения. При перемещении характерной точки, соответствующей такому параметру, на Панели свойств автоматически активизируется нужный переключатель направления. Например, уклон боковых стенок элемента выдавливания может быть направлен внутрь или наружу. При перемещении характерной точки Угол из нулевого положения внутрь тела детали активизируется переключатель Уклон внутрь, а при перемещении наружу — переключатель Уклон наружу.

Контролировать изменение значения параметра при перемещении характерной точки удобнее в режиме округления значений.

Чтобы включить этот режим, нажмите кнопку Округление на панели Текущее состояние. В режиме округления параметр, соответствующий перемещаемой характерной точке, может принимать только такие значения, которые кратны текущему шагу курсора. Значение текущего шага курсора отображается в одноименном поле на панели Текущее состояние. В этом же поле вы можете сменить — ввести с клавиатуры или выбрать из списка — текущий шаг курсора для активного окна. Для быстрой активизации этого поля используйте комбинацию клавиш <Shift> + </> (клавишу </> необходимо нажимать на дополнительной цифровой клавиатуре). Список шагов и умолчательный шаг можно установить в диалоге настройки курсора (см. раздел 9.1.7.1).


2.1.4.2.3. Задание значения размера операции

Одним из способов задания значения числового параметра операции является задание значения размера операции.

Чтобы задать значение размера операции, выполните следующие действия.

1. Вызовите диалог установки значения размера. Для этого дважды щелкните мышью на размерной надписи размера в окне модели.

2. В поле Выражение появившегося диалога введите значение размера: число, константу или выражение для вычисления значения размера. Синтаксис выражений описан в разделе 7.1.3.3.1.

3. Нажмите кнопку Создать объект. Диалог закрывается, модель перестраивается в соответствии с новым значением параметра.

Подробнее диалог установки значения размера и его использование описаны в разделе 2.9.2.2.1.

Значение размера эскиза задается аналогично значению размера операции.

Задание значения размера эскиза возможно только в том случае, если размер ассоциативный.


2.1.4.2.4. Особенности задания числовых параметров операции в полях Панели свойств

При вводе значений числовых параметров операции в поля Панели свойств обратите внимание на следующие особенности.

– Если в поле вводится выражение, то в процессе ввода в поле отображается это выражение, а после подтверждения ввода (нажатия клавиши <Enter>) — результат его вычисления.

– Поле параметра, значение которого задано выражением, имеет желтый цвет. Чтобы получить информацию о параметре, подведите курсор к полю. При этом рядом с курсором появится «ярлычок», содержащий имя параметра, имя соответствующей ему переменной, выражение для вычисления параметра и полученное значение. Если создается новая операция (а не редактируется существующая), то переменной в «ярлычке» нет, так как переменные, соответствующие параметрам операции, возникают в модели только после завершения этой операции.

– Если значение, заданное выражением, изменяется с помощью счетчика или характерной точки, то к выражению добавляется свободный член. Значение свободного члена равно величине изменения. Знак перед свободным членом зависит от того, увеличивается значение параметра или уменьшается.

– Если выражение для вычисления значения содержит переменную, отсутствующую в модели, то после подтверждения ввода эта переменная примет умолчательное значение, а значение параметра операции будет равно результату вычисления выражения с новой переменной. После создания операции новая переменная автоматически появится в модели, а ее имя и умолчательное значение отобразятся в главном разделе Окна переменных (о переменных см. раздел 7.1).

– Если в качестве значения параметра в поле вводится только имя переменной, отсутствующей в модели, то после подтверждении ввода эта переменная примет то значение, которое содержалось в поле до ее ввода. Если в поле содержалось выражение, то значение новой переменной будет равно результату вычисления выражения. После создания операции новая переменная автоматически появится в модели, а ее имя и значение отобразятся в главном разделе Окна переменных.


2.2. Эскизы

В этом разделе:

2.2.1. Работа с эскизом

2.2.1.1. Общие сведения об эскизе

2.2.1.2. Режим эскиза

2.2.1.3. Диагностика состояния эскиза

2.2.1.4. Использование эскиза в операциях

2.2.1.5. Выбор плоскости для построения эскиза

2.2.1.6. Эскиз из библиотеки

2.2.1.7. Ориентация плоскости эскиза и масштаб отображения эскиза

2.2.2. Создание эскиза

2.2.2.1. Порядок создания эскиза

2.2.2.2. Размещение эскиза

2.2.2.3. Использование объектов модели при построении эскиза

2.2.2.3.1. Привязка к объектам модели при работе в эскизе

2.2.2.3.2. Вспомогательная проекция объекта модели

2.2.2.3.3. Проецирование объектов модели в эскиз

2.2.2.4. Особенности использования в эскизе некоторых типов объектов

2.2.2.4.1. Многоугольник, прямоугольник, ломаная

2.2.2.4.2. Текст

2.2.2.4.3. Вставки фрагментов, макроэлементы

2.2.2.4.4. Технологические обозначения, таблицы, штриховки


2.2.1. Работа с эскизом

2.2. Эскизы

2.2.1. Работа с эскизом

В этом разделе:

2.2.1.1. Общие сведения об эскизе

2.2.1.2. Режим эскиза

2.2.1.3. Диагностика состояния эскиза

2.2.1.4. Использование эскиза в операциях

2.2.1.5. Выбор плоскости для построения эскиза

2.2.1.6. Эскиз из библиотеки

2.2.1.7. Ориентация плоскости эскиза и масштаб отображения эскиза


2.2.1.1. Общие сведения об эскизе

Эскиз — объект трехмерного моделирования, созданный средствами чертежно-графического редактора. Эскиз может располагаться на координатной или вспомогательной плоскости, а также на плоской грани.

Эскизы используются для разных целей, например:

– задание формы сечения тела или поверхности,

– задание траектории перемещения сечения,

– задание положения экземпляров массива.

Один и тот же эскиз может использоваться в нескольких различных операциях.

Работа с эскизом ведется в специальном режиме работы с моделью — режиме эскиза.


2.2.1.2. Режим эскиза

Режим эскиза — специальный режим работы с трехмерной моделью КОМПАС-3D. Переход в этот режим производится при создании нового или редактировании существующего эскиза.

Работа в режиме эскиза практически аналогична работе в КОМПАС-фрагменте. Отличием является невозможность создания таких объектов, как технологические обозначения и таблицы, штриховки, заливки, линии обрыва и некоторые другие. Это связано с тем, что они, в отличие от графических объектов, не участвуют в образовании формы трехмерного элемента при перемещении эскиза и, в отличие от размеров, не определяют конфигурацию эскиза.

По умолчанию в новом эскизе включен параметрический режим. Подробно об особенностях работы в нем см. раздел 7.2.1.7; о настройке параметрического режима в эскизе см. раздел 9.2.7.7.1.

Команды трехмерного моделирования в режиме эскиза недоступны. Объекты модели можно использовать в эскизе для проецирования и привязки, см. раздел 2.2.2.3.

После завершения работы с эскизом следует выйти из режима эскиза, чтобы продолжить построение модели. Об использовании эскиза в операциях см. раздел 2.2.1.4.


2.2.1.3. Диагностика состояния эскиза

Если эскиз параметрический, то он может находиться в одном из трех состояний: полностью определенный, не полностью определенный или переопределенный. Эти состояния показываются в Дереве построения значками перед названиями эскизов:

(+) — полностью определенный эскиз, т.е. его объекты не имеют ни одной степени свободы в системе координат эскиза,

(-) — не полностью определенный эскиз,

(!) — переопределенный эскиз.

Рекомендуется, чтобы все эскизы в модели были полностью определены. В этом случае системы уравнений эскизов решаются более устойчиво.

Чтобы просмотреть или изменить состояние эскиза, войдите в режим его редактирования. Включите отображение ограничений (см. раздел 7.2.6.1) и степеней свободы объектов (см. раздел 7.2.6.2), если оно отключено.

– Если эскиз определен полностью, то ни один из его объектов не имеет ни одной степени свободы, т.е. при включенном отображении степеней свободы символы степеней свободы не отображаются.

– Если эскиз определен не полностью, то хотя бы один из его объектов имеет хотя бы одну степень свободы. Для полного определения эскиза следует наложить на его объекты связи и/или ограничения так, чтобы ни один объект не имел ни одной степени свободы.

– Переопределенным считается эскиз, на объекты которого наложены избыточные связи и/или ограничения (при этом степени свободы у объектов могут как присутствовать, так и отсутствовать). Значки избыточных связей и/или ограничений отображаются коричневым цветом. Например, избыточной является связь параллельность, наложенная на отрезки, уже имеющие ограничение горизонтальность.

Если эскиз непараметрический (т.е. его объекты не связаны ни друг с другом, ни с объектами модели и не имеют ограничений), то перед его названием в Дереве построения нет никаких значков.


2.2.1.4. Использование эскиза в операциях

Вне режима работы с эскизом на экране отображаются не все построенные в нем графические объекты, а лишь те, которые лежат на текущем и активных слоях (эскиз может содержать несколько слоев, как и фрагмент, см. раздел 3.6.6) и имеют один из следующих типов и/или стилей:

– точка,

– Осевая линия,

– линия со стилем Основная,

– отрезок со стилем Осевая.

При выполнении операции, использующей эскиз, учитываются именно те его графические объекты, которые видны вне режима эскиза.

Размеры, проставленные в эскизе, доступны при выполнении операции, а также при включении специального режима (см. раздел 2.9.2.2).

Таким образом, если для построения изображения в эскизе (особенно параметрическом) требуются вспомогательные объекты, которые не должны учитываться при выполнении операции, используйте для них стиль линии, отличный от Основной и Осевой.

Размеры, которые не должны быть видны вне режима эскиза, перенесите на погашенный слой.

Эскиз, указанный для использования в той или иной операции, интерпретируется системой как один или несколько контуров, составленных из линий эскиза.

Обратите внимание на то, что линии эскиза всегда входят в контур целиком. Например, если в эскизе построены два отрезка, соединяющиеся в вершине, то они составят один контур, а если отрезки пересекаются, то контуров будет два. Также два контура образуют три отрезка, имеющие общую вершину.

Если линии эскиза формируют несколько контуров, то обычно для корректного выполнения операции требуется, чтобы эти контуры не имели общих точек, не пересекались и не касались. Есть и другие требования, предъявляемые к эскизам. Эти требования зависят от операций, использующих эскизы, и описаны в разделах, посвященных операциям.

В некоторых операциях можно использовать как эскиз целиком (т.е. все его контуры) — для этого следует указать эскиз в Дереве построения, так и отдельные линии эскиза — для этого нужно указывать их в окне модели.


2.2.1.5. Выбор плоскости для построения эскиза

Выбор плоскости для построения эскиза операции не влияет на дальнейший порядок работы с моделью и ее свойства.

Однако, при выборе плоскости для эскиза первого тела или поверхности следует иметь в виду, что от этого выбора будет зависеть положение объекта в стандартной ориентации. Например, если эскиз-сечение тела выдавливания построен в плоскости XY, то проекция тела на виде спереди будет совпадать с формой эскиза (рис. 2.2.1).

Рис. 2.2.1. Положение детали относительно координатных плоскостей


2.2.1.6. Эскиз из библиотеки

Вы можете не создавать изображение в эскизе «с нуля», а вставить в него объекты, уже существующие в библиотеке эскизов (подробнее см. раздел 11.3.4.2).


2.2.1.7. Ориентация плоскости эскиза и масштаб отображения эскиза

Эскиз удобно строить, когда его плоскость совпадает с плоскостью экрана. Если плоскость эскиза перпендикулярна плоскости экрана, построение невозможно.

По умолчанию система настроена так, что при входе в режим эскиза модель автоматически поворачивается в ориентацию Нормально к... по отношению к плоскости эскиза, а при выходе из режима эскиза возвращается в прежнее положение.

Масштаб отображения эскиза определяется следующим образом:

– при создании нового эскиза принимается равным 1 (если эскиз строится на координатной плоскости) или подбирается по габариту объекта (если эскиз строится на вспомогательной плоскости или плоской грани),

– при редактировании существующего эскиза подбирается по габаритам изображения в эскизе, т.е. автоматически выполняется команда Показать эскиз полностью.

Настройку автоматической установки ориентации и масштаба можно изменить в диалоге настройки изменения ориентации (см. раздел. 9.1.11.6).

Если автоматический поворот модели отключен, то плоскость эскиза можно вручную разместить параллельно экрану.

Для этого служит команда Нормально к...

Вы можете установить плоскость эскиза в ориентацию Нормально к... как до перехода в режим эскиза, так и после. В первом случае необходимо выделить плоскость будущего эскиза и вызвать из контекстного меню команду Нормально к... Во втором случае плоскость выделять не нужно — можно просто вызвать команду Нормально к... из контекстного меню (она доступна, если не активна ни одна из команд геометрических построений) или из меню кнопки Ориентация.


2.2.2. Создание эскиза

2.2. Эскизы

2.2.2. Создание эскиза

В этом разделе:

2.2.2.1. Порядок создания эскиза

2.2.2.2. Размещение эскиза

2.2.2.3. Использование объектов модели при построении эскиза

2.2.2.3.1. Привязка к объектам модели при работе в эскизе

2.2.2.3.2. Вспомогательная проекция объекта модели

2.2.2.3.3. Проецирование объектов модели в эскиз

2.2.2.4. Особенности использования в эскизе некоторых типов объектов

2.2.2.4.1. Многоугольник, прямоугольник, ломаная

2.2.2.4.2. Текст

2.2.2.4.3. Вставки фрагментов, макроэлементы

2.2.2.4.4. Технологические обозначения, таблицы, штриховки


2.2.2.1. Порядок создания эскиза

Эскиз размещается на плоском объекте — координатной или вспомогательной плоскости либо плоской грани. Этот объект можно указать как до перехода в режим эскиза, так и после.

1. Вызовите команду Операции — Эскиз или нажмите кнопку Эскиз на панели Текущее состояние.

Кнопка Эскиз остается нажатой — это свидетельствует о том, что система находится в режиме эскиза.

– Если плоский объект был выделен перед вызовом команды, то эскиз создается на этой плоскости; система координат эскиза имеет умолчательное положение.

– Если плоский объект не был выделен, автоматически запускается процесс размещения эскиза (см. раздел 2.2.2.2). Укажите нужный плоский объект.

В Дереве построения появляется пиктограмма эскиза. Она отмечена значком «замок» — признак того, что эскиз в данный момент редактируется.

Меняется состав компактной панели и Главного меню — становятся доступными команды построения и редактирования графических объектов, выделения, измерений, простановки размеров, наложения параметрических связей и ограничений.

На экране отображается система координат эскиза.

2. Постройте в эскизе нужное изображение.

В эскиз можно перенести изображение из ранее созданного чертежа или фрагмента через буфер обмена. Это позволяет при создании трехмерной модели опираться на существующую чертежно-конструкторскую документацию.

3. Для возврата в режим трехмерных построений вновь вызовите команду Операции — Эскиз, или отожмите кнопку Эскиз на панели Текущее состояние, или щелкните мышью по значку режима эскиза в окне документа.

Сразу после выхода из режима эскиза новый эскиз выделяется в графической области.

Команды запуска операций, которые могут быть выполнены на основе созданного эскиза, можно вызвать прямо из режима эскиза. Например, построив в эскизе сечение тела выдавливания, можно сразу вызвать команду Операция выдавливания. Режим редактирования эскиза автоматически завершится, будет запущена команда построения тела выдавливания.

Эскиз относится к объектам, использующим систему координат (о системе координат объекта см. раздел 2.8.3.4.1).


2.2.2.2. Размещение эскиза

Размещение эскиза состоит в выборе плоскости для него и задании положения его системы координат на этой плоскости.

Процесс размещения эскиза запускается после вызова команды Эскиз, если перед ее вызовом не была указана плоскость или плоская грань.

По умолчанию в процессе размещения эскиза включено автосоздание объекта (см. раздел 1.4.2.10). Поэтому после указания плоскости или плоской грани для размещения эскиза система сразу перейдет в режим его построения. Если требуется не только указать плоский объект, но и выполнить другие действия, например, задать положение системы координат эскиза или отключить связь эскиза с плоскостью его размещения, необходимо отключить автосоздание, отжав одноименную кнопку на Панели специального управления.

В процессе размещения эскиза в графической области отображается фантом системы координат эскиза, а Панель свойств имеет вид, показанный на рисунке 2.2.2.

Рис. 2.2.2. Панель свойств в процессе размещения эскиза

Чтобы задать плоскость для размещения эскиза, укажите вспомогательную или координатную плоскость или плоскую грань. Выбранный объект подсветится в окне модели, а его имя появится в поле Базовая плоскость на Панели свойств.

Чтобы сместить и повернуть систему координат эскиза относительно ее исходного положения, введите значения координат и угла в поля Точка привязки и Угол на Панели свойств. Изменение координат и угла отражается на фантоме системы координат эскиза в графической области.

Систему координат эскиза можно также произвольно переместить или повернуть мышью. Для этого следует расфиксировать поле Точка привязки или Угол на Панели свойств, а затем щелчком мыши указать новое положение или угол поворота системы координат эскиза в графической области.

Если требуется, чтобы эскиз не был связан с базовой плоскостью, включите опцию Независимое размещение. Эскиз сохранит свое положение в пространстве, но его связь с базовой плоскостью будет разорвана (подсветка базовой плоскости в окне модели исчезнет, а ее имя удалится из поля Базовая плоскость).

Нажмите кнопку Создать объект на Панели специального управления, чтобы подтвердить размещение эскиза.


2.2.2.3. Использование объектов модели при построении эскиза

Работая в эскизе, вы можете:

– Выполнять привязку к объектам модели при создании геометрических объектов и размеров. При этом в эскизе формируется вспомогательная проекция объекта модели. С проекцией параметрически связывается создаваемый объект. О привязке к объектам модели рассказано в разделе 2.2.2.3.1, о вспомогательной проекции — в разделе 2.2.2.3.2.

– Использовать объекты модели в качестве базовых объектов при создании геометрических объектов и размеров. Для этого нужно просто указывать объекты модели при создании/редактировании изображения в эскизе. В результате в эскизе формируется вспомогательная проекция объекта модели, с которой связывается объект эскиза. Примеры: отрезок, параллельный проекции ребра; угловой размер между проекцией прямолинейного объекта1 и отрезком, связь равенство длин между отрезком и проекцией прямолинейного объекта. О вспомогательной проекции рассказано в разделе 2.2.2.3.2.

– Проецировать объекты модели на плоскость эскиза. При этом в эскизе формируется геометрический объект, связанный непосредственно с объектом модели. О проецировании объектов рассказано в разделе 2.2.2.3.3.

Возможность выбора трехмерных объектов при работе в эскизе зависит от настройки фильтров (см. раздел 2.1.4.1.3). Изменив настройку, вы можете сузить или расширить набор доступных для указания объектов.

  1. Могут также использоваться оси существующих в модели систем координат.

В этом разделе:

2.2.2.3.1. Привязка к объектам модели при работе в эскизе

2.2.2.3.2. Вспомогательная проекция объекта модели

2.2.2.3.3. Проецирование объектов модели в эскиз


2.2.2.3.1. Привязка к объектам модели при работе в эскизе

При создании геометрических объектов в эскизе возможно использование глобальной и локальной привязок не только к геометрическим объектам этого эскиза, но и к объектам модели. О глобальной и локальной привязках к геометрическим объектам подробно рассказано в разделе 3.1.1.2. В данном разделе описаны особенности привязки к объектам модели.

Для привязки можно использовать объекты модели, представляющие собой точки (вершины, начала координат и т.п.) или кривые (ребра, пространственные кривые, оси и т.п.). В результате выполнения привязки в эскизе формируется вспомогательная проекция объекта (см. раздел 2.2.2.3.2), выбранного для привязки, а создаваемый геометрический объект параметрически связывается с проекцией.

Привязка выполняется обычным образом: в процессе построения подведите курсор к нужному объекту модели и щелкните мышью, когда в плоскости эскиза появится вспомогательная проекция выбранного объекта, название привязки и обозначение точки привязки («крестик»).

Например, если требуется построить отрезок, начинающийся в середине проекции ребра, вызовите команду Отрезок, включите глобальную или локальную привязку Середина и подведите курсор к нужному ребру. Когда в плоскости эскиза появится проекция этого ребра, а в ее середине — «крестик» с надписью Середина кривой, щелкните мышью.

При выполнении привязки к объектам модели имейте в виду следующее.

– Если объект прямолинейный и располагается перпендикулярно плоскости эскиза, то привязка возможна только к вершинам этого объекта.

– Невозможно создание двух и более вспомогательных проекций одновременно. Поэтому невозможно выполнение привязки Пересечение без проецирования в эскиз объектов, к точке пересечения которых требуется привязаться.

При необходимости вы можете отключить привязку ко всем объектам модели или только к тем, которые не видны в ее текущем положении. Для этого служат команды Привязка к элементам модели и Только к видимым элементам модели в меню кнопки Привязки (рис. 2.2.3).

Рис. 2.2.3. Команды управления привязкой к объектам модели


2.2.2.3.2. Вспомогательная проекция объекта модели

Вспомогательная проекция объекта модели создается в эскизе автоматически при выполнении привязки к объекту модели, а также при использовании объекта модели в качестве базового для объекта эскиза.

Вспомогательная проекция присутствует в эскизе до тех пор, пока участвует в каких-либо параметрических связях. Если последняя связь, наложенная на вспомогательную проекцию, удалена, то после завершения работы с эскизом эта проекция автоматически удаляется.

Например, при указании положения первой вершины отрезка была выполнена привязка к центру круглого ребра. В результате в эскизе была создана вспомогательная проекция ребра (окружность или эллипс), между ее центром и вершиной отрезка сформирована связь совпадение точек. В дальнейшем первую вершину отрезка потребовалось перенести в другую точку, для чего связь была удалена. Если других связей на вспомогательную проекцию не наложено, при выходе из режима эскиза эта проекция будет удалена.

Если параметрический режим в эскизе отключен, или при его настройке (см. раздел 9.2.7.7.1) отключена параметризация привязок, то связи при выполнении привязки не накладываются и вспомогательные проекции не создаются.

Пользователь может управлять отображением вспомогательных проекций в эскизе. Для этого служит кнопка Вспомогательные проекции на панели Текущее состояние. Если кнопка нажата, то все существующие в эскизе вспомогательные проекции отображаются в эскизе пунктирными линиями.

Эскиз может содержать вспомогательные проекции сразу после создания. Это зависит от того, что используется в качестве плоскости эскиза. Например:

– эскиз на плоской грани содержит вспомогательные проекции ребер этой грани,

– эскиз на координатной плоскости содержит вспомогательную проекцию начала координат,

– эскиз на плоскости, построенной по трем точкам, содержит вспомогательные проекции этих точек,

– эскиз на плоскости, построенной через ребро параллельно другому ребру, содержит вспомогательные проекции этих ребер,

– эскиз на смещенной плоскости не содержит вспомогательных проекций.

Изначально существующие в эскизе вспомогательные проекции не удаляются из него, даже если не участвуют ни в каких параметрических связях.


2.2.2.3.3. Проецирование объектов модели в эскиз

Иногда в эскизе требуется создать линии или точки, представляющие собой проекции трехмерных объектов на плоскость эскиза.

Чтобы создать в эскизе проекцию какого-либо объекта, вызовите команду Операции — Спроецировать объект. Кнопка для вызова этой команды находится на панели Геометрия.

Укажите объект, проекцию которого требуется получить — вершину, грань, ребро, пространственную кривую, ось, точку и т.п.

В эскизе создается проекция указанного объекта.

В зависимости от того, какой объект выбран для проецирования, в эскизе может быть создан один из следующих геометрических объектов:

– точка со стилем Вспомогательная — при проецировании вершины,

– вспомогательная прямая — при проецировании координатной или вспомогательной оси,

– объект типа проекционная кривая со стилем Основная — при проецировании ребра, пространственной кривой или грани (в последнем случае создаются проекционные кривые — проекции ребер, ограничивающих грань).

Если для проецирования выбрано прямолинейное ребро, перпендикулярное плоскости эскиза, то в эскиз проецируется одна из вершин этого ребра.

На созданную проекцию автоматически накладывается параметрическая связь — проекционная связь. Это обеспечивает постоянную связь проекции с исходным трехмерным объектом.

Удаление связи проекционная связь приводит к удалению связи проекции с исходным объектом. Проекция становится обычным геометрическим объектом, который можно перемещать и редактировать. Аналогичный результат дает применение к проекции команды Разрушить.

На проекционную кривую, если она разомкнута, также накладываются связи проекция конечной вершины. Эти связи обеспечивают совпадение крайних вершин проекционной кривой с проекциями крайних вершин исходного объекта.

За один вызов команды Спроецировать объект вы можете построить в эскизе проекции нескольких различных объектов. Для этого указывайте их по очереди.

Чтобы завершить проецирование, нажмите кнопку Прервать команду на Панели специального управления.

В эскизе может существовать только одна проекция каждого объекта модели.

Работа с проекционной кривой

– Изменение формы проекционной кривой невозможно (например, нельзя изменить радиус дуги окружности). Однако эту кривую можно усечь. Проекционная кривая может также использоваться как ограничивающий объект в командах выравнивания или удлинения.

– Если проекционная кривая рассечена на несколько частей, то при выделении одной ее части выделяются все остальные.

– Можно изменять длину проекционной кривой, перемещая характерные точки на ее концах (или концах ее частей). Для перемещения конечной точки кривой необходимо удалить наложенную на нее связь проекция конечной вершины. Перемещение точки возможно только вдоль кривой. Если проекционная кривая представляет собой отрезок или дугу окружности/эллипса, то характерные точки можно перемещать вдоль продолжения кривой (т.е. кривую можно сделать длиннее, чем проекция исходного объекта).

– При копировании проекционной кривой создается обычный геометрический объект (объекты).

– Команды редактирования (сдвиг, поворот и т.д.) можно применить к проекционной кривой, если в них включен режим, при котором исходные объекты при выполнении команды остаются. В результате работы этих команд создается обычный геометрический объект (объекты).

– Для возвращения проекционной кривой исходного состояния (например, после усечения) служит команда контекстного меню Восстановить кривую. Команда доступна в контекстном меню до тех пор, пока кривая сохраняет связь с исходным объектом (т.е. в списке наложенных на нее ограничений присутствует проекционная связь).


2.2.2.4. Особенности использования в эскизе некоторых типов объектов

В этом разделе:

2.2.2.4.1. Многоугольник, прямоугольник, ломаная

2.2.2.4.2. Текст

2.2.2.4.3. Вставки фрагментов, макроэлементы

2.2.2.4.4. Технологические обозначения, таблицы, штриховки


2.2.2.4.1. Многоугольник, прямоугольник, ломаная

Построенные в эскизе многоугольники, прямоугольники, ломаные автоматически разбиваются на отдельные отрезки (а не остаются едиными объектами, как при работе с графическими документами). В параметрическом режиме на эти отрезки накладываются связи и ограничения. Например, на стороны прямоугольника накладываются ограничения горизонтальность и вертикальность, а на их вершины — связи совпадение.

Многоугольники, прямоугольники, ломаные, скопированные в эскиз из графических документов, не разбиваются на отрезки.


2.2.2.4.2. Текст

Эскиз может содержать текст. После выхода из эскиза все содержащиеся в нем тексты автоматически преобразуются в один или несколько контуров, состоящих из сплайновых кривых.

Иногда в результате автоматического преобразования могут получиться контуры, не удовлетворяющие требованиям операции, например, касающиеся. В этих случаях можно попробовать сменить шрифт надписи. Если контур по-прежнему не подходит для операции, можно в эскизе применить к тексту команду Преобразовать в NURBS. Полученные линии уже не будут текстом (т.е. для редактирования надписи ее потребуется ввести и преобразовать в NURBS снова), однако, они будут повторять контуры букв, и вы сможете исправить эскиз так, чтобы он удовлетворял требованиям операции.

Надпись после преобразования в NURBS следует удалить из эскиза или перенести в нем на погашенный слой.


2.2.2.4.3. Вставки фрагментов, макроэлементы

Для выполнения операций не могут использоваться следующие объекты эскиза:

– макроэлементы, вставленные из библиотек или скопированные через буфер обмена из графических документов,

– фрагменты, вставленные из библиотек,

– вставки локальных и внешних фрагментов, выполненные способом Внешней ссылкой или Взять в документ.

Фрагменты и макроэлементы после вставки в эскиз необходимо разбить на отдельные геометрические объекты с помощью команды Редактор — Разрушить.


2.2.2.4.4. Технологические обозначения, таблицы, штриховки

В эскизе невозможно создание технологических обозначений, таблиц, штриховок и некоторых других объектов.

Если в эскиз попали (например, были скопированы из графического документа) какие-либо из объектов, построение которых в эскизе недоступно, это не препятствует дальнейшей работе. Эти объекты не учитываются при образовании объемного элемента. В эскизе они сохраняются. Их можно просмотреть при редактировании эскиза.


2.3. Тела

В этом разделе:

2.3.1. Общие сведения о телах

2.3.1.1. С чего начать построение модели

2.3.2. Операции «Выдавливание» и «Вырезать выдавливанием»

2.3.2.1. Элемент выдавливания

2.3.2.2. Выполнение операции

2.3.2.3. Сечение элемента выдавливания

2.3.2.3.1. Зависимость результата операции выдавливания от сечения

2.3.2.3.2. Указание сечения элемента выдавливания

2.3.2.3.3. Требования к эскизу элемента выдавливания

2.3.2.4. Направление выдавливания

2.3.2.4.1. Направляющий объект

2.3.2.4.2. Выбор направления выдавливания

2.3.2.5. Глубина выдавливания

2.3.2.5.1. Выдавливание на заданное расстояние

2.3.2.5.2. Выдавливание через все

2.3.2.5.3. Выдавливание до вершины

2.3.2.5.4. Выдавливание до поверхности

2.3.2.5.5. Выдавливание до ближайшей поверхности

2.3.2.5.6. Задание расстояния до объекта

2.3.2.6. Угол уклона

2.3.2.7. Тонкая стенка

2.3.2.8. Результат операции

2.3.2.8.1. Результат добавления материала

2.3.2.8.2. Результат удаления материала

2.3.3. Операции «Вращение» и «Вырезать вращением»

2.3.3.1. Элемент вращения

2.3.3.2. Выполнение операции

2.3.3.3. Сечение элемента вращения

2.3.3.3.1. Зависимость результата операции вращения от сечения

2.3.3.3.2. Указание сечения элемента вращения

2.3.3.3.3. Требования к эскизу элемента вращения

2.3.3.4. Ось вращения

2.3.3.5. Тип построения

2.3.3.6. Направление вращения

2.3.3.7. Угол вращения

2.3.3.7.1. Вращение на заданный угол

2.3.3.7.2. Вращение до вершины

2.3.3.7.3. Вращение до поверхности

2.3.4. Операции «Кинематическая» и «Вырезать кинематически»

2.3.4.1. Кинематический элемент

2.3.4.2. Выполнение кинематической операции

2.3.4.3. Сечение кинематического элемента

2.3.4.3.1. Требования к эскизу-сечению

2.3.4.4. Траектория кинематического элемента

2.3.4.4.1. Требования к траектории

2.3.4.5. Тип движения сечения

2.3.5. Операции «По сечениям» и «Вырезать по сечениям»

2.3.5.1. Элемент по сечениям

2.3.5.2. Выполнение операции

2.3.5.3. Сечения элемента по сечениям

2.3.5.3.1. Требования к эскизам-сечениям

2.3.5.4. Осевая линия элемента по сечениям

2.3.5.4.1. Требования к осевой линии

2.3.5.5. Способ построения элемента у крайних сечений

2.3.5.6. Траектория соединения сечений

2.3.5.6.1. Способ генерации траектории

2.3.5.6.2. Замкнутая или разомкнутая траектория

2.3.6. Придание толщины граням тела или поверхности

2.3.7. Булева операция над телами

2.3.7.1. Отображение булевой операции в Дереве построения

2.3.8. Операции редактирования тел

2.3.8.1. Фаска

2.3.8.2. Скругление

2.3.8.2.1. Скругление с постоянным радиусом

2.3.8.2.2. Скругление с переменным радиусом

2.3.8.2.3. Сглаживание и обход углов

2.3.8.2.4. Скругление с сохранением кромки или с сохранением поверхности

2.3.8.2.5. Остановка скругления

2.3.8.3. Преобразование тел в оболочку

2.3.8.4. Ребро жесткости

2.3.8.4.1. Требования к эскизу ребра жесткости

2.3.8.4.2. Формирование ребра жесткости

2.3.8.4.3. Положение ребра

2.3.8.4.4. Уклон граней ребра

2.3.8.5. Уклон граней

2.3.8.6. Отсечение части модели

2.3.8.6.1. Сечение поверхностью

2.3.8.6.2. Сечение по эскизу

2.3.8.7. Масштабирование тел и поверхностей

2.3.8.8. Изменение положения тела или поверхности

2.3.9. Круглое отверстие

2.3.9.1. Круглое отверстие: простое, с зенковкой/цековкой, коническое

2.3.9.1.1. Задание глубины отверстия

2.3.9.1.2. Параметры отверстия с зенковкой и/или цековкой

2.3.9.1.3. Параметры конического отверстия

2.3.9.1.4. Создание резьбового отверстия

2.3.9.1.5. Задание формы торца отверстия

2.3.9.1.6. Размещение отверстия на поверхности

2.3.9.1.7. Создание отверстия по образцу

2.3.9.2. Отверстие из библиотеки

2.3.10. Область применения операции

2.3.10.1. Общие сведения

2.3.10.2. Общий порядок задания области применения операции

2.3.10.3. Область применения «Тела»

2.3.10.3.1. Задание области применения «Тела» для операций добавления материала

2.3.10.3.2. Задание области применения «Тела» для операций удаления материала

2.3.10.3.3. Способы определения области применения «Тела»

2.3.10.4. Область применения «Компоненты»

2.3.10.4.1. Задание области применения «Компоненты»

2.3.10.4.2. Формирование области применения «Компоненты» вручную

2.3.11. Тела, состоящие из отдельных частей

2.3.11.1. Выбор частей, которые следует оставить

2.3.11.1.1. Особенности изменения количества частей тела

2.3.12. Многотельное моделирование

2.3.12.1. Примеры использования многотельного моделирования

2.3.12.2. Отображение многотельной модели в Дереве построения


2.3.1. Общие сведения о телах

2.3. Тела

2.3.1. Общие сведения о телах

Новое тело в модели можно создать с помощью одной из следующих операций:

– Выдавливание. Образует тело путем перемещения сечения вдоль прямолинейной траектории на заданное расстояние (см. раздел 2.3.2).

– Вращение. Образует тело путем поворота сечения вокруг оси на заданный угол (см. раздел 2.3.3).

– По сечениям. Образует тело путем соединения нескольких сечений (см. раздел 2.3.5).

– Кинематическая. Образует тело путем перемещения сечения вдоль произвольной траектории (см. раздел 2.3.4).

– Придание толщины. Образует тело путем добавления слоя материала на указанную поверхность (см. раздел 2.3.6).

– Листовое тело. Образует особый тип тела — листовое тело (см. раздел 2.4).

– Сшивка поверхностей. Образует тело, ограниченное указанными поверхностями (см. раздел 2.6.2.4).

Для создания тела можно также использовать команду Деталь-заготовка (см. раздел 2.11.2.1.3).

После создания нового тела производится «приклеивание» к нему или «вырезание» из него дополнительных объемов, т.е. добавление или удаление материала тела (рис. 2.3.1).

Рис. 2.3.1. Построение тела: а) новое тело — цилиндр; б) «приклеивание» призмы; в) «вырезание» призмы; г) «вырезание» цилиндра
а) | б) | в) | г)

Примерами удаления материала тела могут быть различные отверстия, проточки, канавки, а примерами добавления — бобышки, выступы, ребра (рис. 2.3.2).

Рис. 2.3.2. Бобышка и лапки приклеены к телу, пазы и отверстия — вырезаны из него

Удаление и добавление элементов выдавливания, вращения, по сечениям, кинематической описано в разделах 2.3.2–2.3.4; добавление слоя материала на грани тела — в разделе 2.3.6. Прочие возможности редактирования тел (добавление фасок, скруглений, ребер жесткости, создание оболочки и др.) описаны в разделе 2.3.8.

Модель может содержать несколько тел. Над телами могут производиться булевы операции (см. раздел 2.3.7).

Используя существующие в модели тела, вы можете создавать новые с помощью команд построения массивов, см. раздел 2.7.

В этом разделе:

2.3.1.1. С чего начать построение модели


2.3.1.1. С чего начать построение модели

Перед созданием модели всегда встает вопрос о том, с чего начать построение. Для ответа на него нужно хотя бы приблизительно представлять конструкцию будущей детали.

Мысленно исключите из этой конструкции фаски, скругления, проточки и прочие мелкие конструктивные элементы. Разбейте деталь на составляющие ее элементы (параллелепипеды, призмы, цилиндры, конусы, торы, кинематические элементы и т.д.).

Чаще всего первым строят самый крупный из этих элементов. Если в составе детали есть несколько сопоставимых по размерам элементов, можно начать построение с любого из них.

Возможно, для создания такой детали целесообразно будет построить несколько тел и затем объединить их. Некоторые детали, например, сегментные вкладыши, состоят из нескольких тел, не объединенных между собой. Подробно о многотельном моделировании рассказано в разделе 2.3.12.

Иногда построение начинают с простого элемента (например, параллелепипеда, цилиндра), описанного вокруг проектируемой детали (или ее части).

В некоторых случаях можно выбрать первый элемент (а также наметить дальнейший порядок проектирования детали), представив технологический процесс ее изготовления.

Вообще говоря, дать универсальные рекомендации по созданию трехмерных моделей невозможно. Любой конструктор вырабатывает представления об удобном ему порядке моделирования после самостоятельного построения нескольких моделей.


2.3.2. Операции «Выдавливание» и «Вырезать выдавливанием»

2.3. Тела

2.3.2. Операции «Выдавливание» и «Вырезать выдавливанием»

В этом разделе:

2.3.2.1. Элемент выдавливания

2.3.2.2. Выполнение операции

2.3.2.3. Сечение элемента выдавливания

2.3.2.3.1. Зависимость результата операции выдавливания от сечения

2.3.2.3.2. Указание сечения элемента выдавливания

2.3.2.3.3. Требования к эскизу элемента выдавливания

2.3.2.4. Направление выдавливания

2.3.2.4.1. Направляющий объект

2.3.2.4.2. Выбор направления выдавливания

2.3.2.5. Глубина выдавливания

2.3.2.5.1. Выдавливание на заданное расстояние

2.3.2.5.2. Выдавливание через все

2.3.2.5.3. Выдавливание до вершины

2.3.2.5.4. Выдавливание до поверхности

2.3.2.5.5. Выдавливание до ближайшей поверхности

2.3.2.5.6. Задание расстояния до объекта

2.3.2.6. Угол уклона

2.3.2.7. Тонкая стенка

2.3.2.8. Результат операции

2.3.2.8.1. Результат добавления материала

2.3.2.8.2. Результат удаления материала


2.3.2.1. Элемент выдавливания

Элемент выдавливания образуется путем перемещения сечения по прямолинейной направляющей в одну или в обе стороны на заданное расстояние. Например, элемент, показанный на рисунке 2.3.3, образован выдавливанием эскиза в направлении, перпендикулярном его плоскости.

Рис. 2.3.3. Эскиз и элемент, образованный операцией выдавливания

Элемент выдавливания может быть самостоятельным телом, а может быть приклеен к телу или вырезан из него.

Для создания нового тела выдавливания или приклеивания элемента выдавливания к имеющемуся телу (т.е. для добавления материала) служит операция Выдавливание, а для вырезания элемента выдавливания из тела (т.е. для удаления материала) — операция Вырезать выдавливанием.

В качестве сечения элемента выдавливания может использоваться грань, эскиз, ребро или пространственная кривая (в том числе контур, построенный по линиям эскиза, ребрам грани или произвольный1).

При выдавливании грани, замкнутого эскиза, замкнутого Контура на грани или Контура эскиза возможен выбор между сплошным и тонкостенным элементом (рис. 2.3.4). При разомкнутом сечении возможно построение только тонкостенного элемента.

Рис. 2.3.4. Выдавливание грани: а) сечение (цилиндрическая грань), б) сплошной элемент, в) тонкостенный элемент
а) | б) | в)

Если сечение представляет собой плоскую грань, эскиз, контур, построенный по линиям эскиза или плоской грани, и выдавливается в направлении, перпендикулярном себе, то возможен уклон боковых граней элемента (рис. 2.3.5).

Рис. 2.3.5. Уклон боковых граней элемента выдавливания: а) сплошного, б) тонкостенного
а) | б)

При выдавливании ребра или пространственной кривой (в том числе контура типа Произвольный) возможно построение только тонкостенного элемента. Уклон боковых граней невозможен. Пример выдавливания пространственной кривой приведен на рисунке 2.3.6.

Рис. 2.3.6. Элемент выдавливания с сечением-спиралью

  1. Т.е. имеющий тип Контур на грани, Контур эскиза и Произвольный, см. раздел 2.5.4.24.1.


2.3.2.2. Выполнение операции

1. Запустите операцию. Для этого:

– нажмите нужную кнопку на панели Редактирование детали или Редактирование модели

– или вызовите нужную команду из меню Операции.

Условие доступности команды Вырезать выдавливанием: наличие в модели тела или компонента.

После запуска операции на Панели свойств появляются вкладки с элементами управления параметрами операции.

2. Задайте параметры операции:

– сечение, см. раздел 2.3.2.3;

– направление выдавливания, см. раздел 2.3.2.4;

– глубину выдавливания, см. раздел 2.3.2.5;

– угол уклона, см. раздел 2.3.2.6;

– параметры тонкой стенки, см. раздел 2.3.2.7;

– результат, см. раздел 2.3.2.8.

Все значения параметров при их вводе и редактировании немедленно отображаются на экране в виде фантома элемента. Фантом позволяет визуально проконтролировать правильность задания параметров.

Для задания таких параметров операции, как направление и глубина выдавливания, угол уклона и толщина стенки, можно использовать характерные точки (о характерных точках см. раздел 2.1.4.2.2).

3. Нажмите кнопку Создать объект для завершения операции.

4. Если в результате операции образуется тело из нескольких частей, то после выполнения операции запускается процесс изменения набора частей. Выберите части, которые следует оставить (см. раздел 2.3.11.1).

Результат операции — новое тело, приклеенный или вырезанный элемент — появляется в графической области.

В Дереве построения появляется пиктограмма операции. Она совпадает с пиктограммой на кнопке команды, которая запускает операцию. Исключением является пиктограмма нового тела выдавливания — она отличается от пиктограммы на кнопке.

— пиктограмма нового тела выдавливания


2.3.2.3. Сечение элемента выдавливания

В этом разделе:

2.3.2.3.1. Зависимость результата операции выдавливания от сечения

2.3.2.3.2. Указание сечения элемента выдавливания

2.3.2.3.3. Требования к эскизу элемента выдавливания


2.3.2.3.1. Зависимость результата операции выдавливания от сечения

В таблице 2.3.1 представлены особенности выполнения и результата операции выдавливания, обусловленные выбором сечения.

Табл. 2.3.1. Особенности операции выдавливания, зависящие от объекта, используемого в качестве сечения
Объект | Особенности выполнения и результата операции
эскиз, контур, построенный по линиям эскиза | – возможно создание как тонкостенного, так и сплошного элемента при условии, что сечение замкнуто – возможен уклон боковых граней элемента – эскиз должен подчиняться требованиям, приведенным в разделе 2.3.2.3.3
грань, контур, построенный по ребрам грани | – возможно создание как тонкостенного, так и сплошного элемента (в случае сечения-контура — при условии, что он замкнут) – возможен уклон боковых граней элемента при условии, что грань плоская
ребро, пространственная кривая, произвольный контур | – возможно создание только тонкостенного элемента – невозможен уклон боковых граней элемента


2.3.2.3.2. Указание сечения элемента выдавливания

Вы можете использовать в качестве сечения элемента выдавливания уже существующий в модели объект — ребро, кривую, эскиз или грань, а можете создать новый объект — контур — не прерывая операцию.

Чтобы выбрать в качестве сечения существующий объект, укажите его в Дереве построения или в графической области.

Чтобы построить контур, нажмите кнопку Контур на Панели специального управления. Будет запущена операция создания контура (см. раздел 2.5.4.24). Укажите объекты, входящие в контур, и нажмите кнопку Создать объект. Система вернется в процесс операции выдавливания, созданный контур появится в Дереве построения и будет автоматически выбран в качестве сечения элемента выдавливания.

Название объекта-сечения отображается в поле Сечение на Панели свойств.

Если при перемещении сечения в заданном направлении две или более точек сечения имеют совпадающие траектории, то выполнение операции невозможно. Необходимо сменить сечение или направление.

Сечение элемента выдавливания можно указать перед запуском операции.

Вы можете в любой момент сменить сечение элемента выдавливания. Для этого активизируйте переключатель Сечение, а затем укажите нужный объект или постройте контур.

Эскиз, выбранный в качестве сечения элемента выдавливая, можно отредактировать, не прерывая операцию. Для этого следует нажать кнопку Редактировать эскиз на Панели специального управления. Система перейдет в режим редактирования эскиза. Внесите в эскиз необходимые изменения. Затем нажмите кнопку Эскиз на панели Текущее состояние или щелкните мышью по значку режима эскиза в окне документа для возврата в процесс операции выдавливания.


2.3.2.3.3. Требования к эскизу элемента выдавливания

– Объекты эскиза могут составлять один или несколько контуров.

– Если контуров несколько, они должны быть либо все замкнуты, либо все разомкнуты.

– Если контуры замкнуты, они могут быть вложенными друг в друга. Уровень вложенности не ограничивается.


2.3.2.4. Направление выдавливания

В этом разделе:

2.3.2.4.1. Направляющий объект

2.3.2.4.2. Выбор направления выдавливания


2.3.2.4.1. Направляющий объект

Если сечением элемента является эскиз или плоская грань, то этот объект автоматически выбирается в качестве направляющего. Если сечением является контур, построенный по эскизу или по ребрам плоской грани, то в качестве направляющего объекта автоматически выбирается соответствующий эскиз или грань. При необходимости направляющий объект можно сменить.

Направляющими объектами для выдавливания могут быть:

– Существующий плоский или прямолинейный объект (перечень объектов см. в таблице 2.1.7).

• Прямолинейный объект задает направление, параллельное себе.

• Плоский объект задает направление, перпендикулярное своей плоскости.

– Вектор.

Чтобы выбрать в качестве направляющего существующий объект, активизируйте переключатель Направляющий объект на Панели свойств, а затем укажите нужный объект в Дереве построения или в графической области.

Чтобы построить вектор, нажмите кнопку Построение вектора на Панели специального управления. Подробно построение вектора рассмотрено в разделе 2.8.5.

Название направляющего объекта отображается в поле Направляющий объект.


2.3.2.4.2. Выбор направления выдавливания

Для выбора направления выдавливания служит список Направление (см. табл. 2.3.2) на Панели свойств.

Табл. 2.3.2. Возможные направления выдавливания
Значение опции Направление | В каком направлении производится выдавливание. Особенности задания глубины выдавливания
Прямое | В прямом направлении относительно сечения1. При выборе этого варианта на Панели свойств присутствует список Способ 1 для выбора способа задания глубины выдавливания (см. раздел 2.3.2.5).
Обратное | В обратном направлении относительно сечения1. При выборе этого варианта на Панели свойств присутствует список Способ 2 для выбора способа задания глубины выдавливания (см. раздел 2.3.2.5).
Два направления | В обе стороны относительно сечения. При выборе этого варианта на Панели свойств присутствуют два списка Способ 1 и Способ 2 для выбора способа задания глубины выдавливания в каждом направлении (см. раздел 2.3.2.5).
Средняя плоскость | В обе стороны симметрично относительно сечения. При выборе этого варианта списки Способ 1 и Способ 2 недоступны, т.к. возможен только один способ определения расстояния — точное задание суммарной глубины выдавливания. Введите нужное значение в поле Расстояние 1.
  1. Чтобы различать направления (прямое и обратное), на фантоме в окне детали показана стрелка, соответствующая прямому направлению. Если выбран вариант Прямое направление, выдавливание будет производиться по стрелке. Если вариант Обратное направление — в противоположную стрелке сторону.


2.3.2.5. Глубина выдавливания

После выбора направления требуется задать расстояние, на которое будет производиться выдавливание. Для этого выберите нужный вариант из списка Способ 1 (и/или Способ 2 — в зависимости от выбранного направления) на Панели свойств. Список способов задания глубины выдавливания содержит следующие варианты (они описаны ниже):

– На расстояние,

– Через все,

– До вершины,

– До поверхности,

– До ближайшей поверхности.

В этом разделе:

2.3.2.5.1. Выдавливание на заданное расстояние

2.3.2.5.2. Выдавливание через все

2.3.2.5.3. Выдавливание до вершины

2.3.2.5.4. Выдавливание до поверхности

2.3.2.5.5. Выдавливание до ближайшей поверхности

2.3.2.5.6. Задание расстояния до объекта


2.3.2.5.1. Выдавливание на заданное расстояние

Выдавливание производится точно на расстояние, заданное в поле Расстояние.

Рис. 2.3.7. Выдавливание на расстояние


2.3.2.5.2. Выдавливание через все

Глубина выдавливания определяется автоматически.

Элемент выдавливается на минимальное расстояние, при котором все точки торца оказываются за габаритным параллелепипедом модели (или в плоскости грани параллелепипеда, если выдавливание производится перпендикулярно этой грани).

Рис. 2.3.8. Выдавливание через все

При построении габаритного параллелепипеда учитываются только тела, поэтому, если в модели нет тел, способ определения глубины Через все недоступен.


2.3.2.5.3. Выдавливание до вершины

Глубина выдавливания определяется автоматически по положению указанной пользователем вершины.

Рис. 2.3.9. Выдавливание до вершины

– Если в качестве сечения используется грань, эскиз, контур, построенный по линиям эскиза или ребрам грани, то вычисляется такая глубина выдавливания, при которой поверхность торца элемента (или ее продолжение) проходит через указанную вершину.

– Если в качестве сечения используется ребро, пространственная кривая или произвольный контур, то глубина выдавливания находится как расстояние от указанной вершины до ближайшей к сечению точки, которая лежит на прямой, проходящей через вершину в направлении выдавливания.

Чтобы указать вершину, определяющую глубину выдавливания, активизируйте на Панели свойств переключатель Вершина и укажите нужный точечный объект в графической области (точку можно указать также в Дереве построения). Название указанного объекта появится в поле рядом с переключателем.

Опция Отсекать позволяет отсечь элемент выдавливания плоскостью, проходящей через указанную вершину перпендикулярно направлению выдавливания. В этом случае элемент имеет плоский торец вне зависимости от формы сечения.

При необходимости можно задать расстояние, на котором торец элемента должен находиться от вершины, т.е. увеличить или уменьшить автоматически определенную глубину выдавливания (см. раздел 2.3.2.5.6).

Продление граней сложной формы не всегда возможно. Поэтому, если указанная вершина расположена так, что при заданном направлении выдавливания торец элемента не проходит через нее, то в некоторых случаях построение выполняется только при включенной опции Отсекать.


2.3.2.5.4. Выдавливание до поверхности

Глубина выдавливания определяется автоматически по положению указанной пользователем грани или плоскости.

Рис. 2.3.10. Выдавливание до поверхности

Чтобы указать поверхность, определяющую глубину выдавливания, активизируйте на Панели свойств переключатель Грань и укажите нужный объект в графической области. Название указанного объекта появится в поле рядом с переключателем.

Элемент выдавливается до указанной поверхности. Торец элемента имеет форму поверхности.

При необходимости можно задать расстояние, на котором торец элемента должен находиться от поверхности (см. раздел 2.3.2.5.6).

Рекомендуется выбирать такие сечение, направление и поверхность, чтобы поверхность полностью пересекала элемент выдавливания. В противном случае построение выполняется только в случае, если указанная поверхность может быть продолжена. Продолжение поверхностей сложной формы не всегда возможно.


2.3.2.5.5. Выдавливание до ближайшей поверхности

Глубина выдавливания определяется автоматически. Элемент выдавливается точно до ближайших в направлении выдавливания граней тела, иными словами, до тех пор, пока не встретит на своем пути грань (или грани). Торец элемента имеет форму грани (граней).

Рис. 2.3.11. Выдавливание до ближайшей поверхности

Если в модели нет тел, способ определения глубины До ближайшей поверхности недоступен.

Рекомендуется выбирать такие сечение и направление, чтобы элемент выдавливания пересекался с уже имеющимися в модели телами.

Способ определения глубины До ближайшей поверхности удобно использовать для выдавливания элемента до ступенчатой или криволинейной грани (см. рис. 2.3.12).

Рис. 2.3.12. Выдавливание элемента до ближайшей криволинейной поверхности


2.3.2.5.6. Задание расстояния до объекта

Если был выбран способ построения До вершины или До поверхности, то после указания вершины или поверхности требуется задать расстояние до нее.

Для этого введите в поле Расстояние требуемое расстояние между торцем элемента и объектом.

Если нужно выдавить элемент точно до объекта, введите нулевое расстояние.

Если расстояние до объекта не нулевое, оно может быть отложено как в направлении выдавливания (в этом случае элемент будет выдавлен «за» объект на указанное расстояние), так и против направления выдавливания (в этом случае элемент не достигнет объекта на указанное расстояние). Чтобы задать направление отсчета расстояния до объекта, активизируйте переключатель До объекта или За объект в группе Тип 1.

Рис. 2.3.13. Выдавливание элемента: а) точно до вершины; б) за вершину; в) не доходя до вершины
а) | б) | в)

В случае выдавливания до поверхности на заданном расстоянии от нее строится эквидистантная поверхность, до которой и производится выдавливание.


2.3.2.6. Угол уклона

Уклон боковых граней элемента выдавливания возможен при выполнении следующих условий:

– в качестве сечения элемента используется эскиз, плоская грань или контур, построенный по линиям эскиза либо ребрам плоской грани,

– направление выдавливания перпендикулярно плоскости сечения.

При выдавливании в прямом или обратном направлении (рис. 2.3.14) задайте направление уклона, активизировав переключатель Внутрь или Наружу в группе Уклон. Введите значение угла уклона в поле Угол.

При выдавливании в двух направлениях направление и величину уклона требуется задать дважды — и для прямого, и для обратного направления (рис. 2.3.15).

При выдавливании от средней плоскости направление и величина уклона задаются один раз и считаются одинаковыми в обоих направлениях.

Рис. 2.3.14. Выдавливание в одном направлении: а) без уклона, б) уклон наружу, в) уклон внутрь
а) | б) | в)

Рис. 2.3.15. Выдавливание в двух направлениях с различными параметрами уклона


2.3.2.7. Тонкая стенка

При создании элемента выдавливания, вращения, по сечениям, кинематического, а также некоторых других объектов, можно образовать тонкостенную оболочку.

При формировании оболочки к поверхности элемента (без его «торцев») добавляется слой материала.

Если требуется создать тонкостенную оболочку на основе поверхности сложного тела (а не одного элемента), воспользуйтесь командой Тонкостенная оболочка (см. раздел 2.3.8.3).

Опции управления созданием тонкостенного элемента доступны во время задания параметров элемента. Они находятся на вкладке Панели свойств Тонкая стенка.

Укажите направление добавления слоя материала относительно поверхности. Для этого выберите нужный вариант в списке Тип построения тонкой стенки (табл. 2.3.3).

Табл. 2.3.3. Возможные варианты построения тонкой стенки
Значение опции Тип построения тонкой стенки | В каком направлении добавляется слой материала. Особенности задания толщины стенки
Нет | Тонкая стенка не строится, т.е. образуется сплошной элемент. Этот вариант доступен, если сечение представляет собой замкнутый эскиз (при выполнении операций вращения и выдавливания построение сплошного элемента возможно также при использовании других объектов в качестве сечения, см. разделы 2.3.2.3.1 и 2.3.3.3.1).
Наружу | В прямом направлении относительно поверхности1. Введите толщину в поле Толщина стенки 1. Допускаются только положительные значения.
Внутрь | В обратном направлении относительно поверхности1. Введите толщину в поле Толщина стенки 2. Допускаются только положительные значения.
Два направления | В обе стороны относительно поверхности. Введите в поле Толщина стенки 1 толщину в направлении наружу, а в поле Толщина стенки 2 — толщину в направлении внутрь (рис. 2.3.16, а). Одно из значений может быть отрицательным. Отрицательная толщина отсчитывается в направлении, противоположном положительному и означает удаление материала. Это позволяет построить тонкую стенку, отстоящую от поверхности элемента (рис. 2.3.16, б).
Средняя плоскость | В обе стороны симметрично относительно поверхности. Введите в поле Толщина стенки 1 суммарную толщину. Допускаются только положительные значения.
  1. Используйте фантом для визуального контроля направления добавления материала.

Рис. 2.3.16. Построение тонкой стенки в двух направлениях (на примере элемента выдавливания; сечение показано утолщенной линией): а) толщина стенки 1 и толщина стенки 2 положительные; б) толщина стенки 2 не изменилась, а толщина стенки 1 получила противоположный знак
а) | б)

Рис. 2.3.17. Примеры тонкостенных элементов

Слово «тонкая» в термине «тонкая стенка» в значительной степени условно. Вообще говоря, в некоторых случаях к поверхности, образованной движением контура, можно добавить слой материала такой толщины, которая многократно превысит линейные размеры контура в эскизе. При этом получившийся элемент не будет «тонкостенным» в прямом смысле этого слова. Однако в большинстве случаев толщина создаваемого элемента на один или даже несколько порядков меньше его габаритов, поэтому стенку и называют «тонкой».

Для боковых стенок тонкостенного элемента выдавливания с уклоном заданная толщина соблюдается в плоскости сечения и параллельных ей плоскостях.


2.3.2.8. Результат операции

Результатом операции является:

– При добавлении материала: самостоятельное тело или элемент, прикленный к уже имеющемуся телу (телам). При приклеивании можно задать область применения операции — набор тел, с которыми должен объединяться новый элемент.

– При удалении материала: вычитание элемента из тела (тел) или пересечение элемента с телом (телами). Как при вычитании, так и при пересечении можно задать область применения операции — набор тел и/или компонентов, материал которых будет удален в результате операции.

Выбор результата операции описан ниже; задание области применения операции — в разделе 2.3.10.

В этом разделе:

2.3.2.8.1. Результат добавления материала

2.3.2.8.2. Результат удаления материала


2.3.2.8.1. Результат добавления материала

При выполнении операций выдавливания, вращения, по сечениям, кинематической, а также при создании листового тела и придании толщины можно указать, должен ли элемент быть отдельным телом или его следует объединить с уже имеющимся (т.е. приклеить к нему).

Рис. 2.3.18. Выбор результата операции, добавляющей материал

Чтобы выбрать вариант добавления материала, перейдите на вкладку Панели свойств Результат операции (рис. 2.3.18) и активизируйте нужный переключатель в группе Результат операции.

– Автообъединение — результат операции определяется автоматически: если создаваемый элемент пересекается с другими телами, то он объединяется с ними, в противном случае строится новое тело.

Элемент и тело считаются пересекающимися, если они имеют:

• общий объем,

• или общую поверхность,

• или общее криволинейное ребро (любой формы, кроме окружности, эллипса и их дуг).

– Новое тело — элемент создается как отдельное тело вне зависимости от того, пересекается он с другими телами или нет.

– Объединение — возможен произвольный выбор тел, с которыми будет объединен создаваемый элемент. Для указания тел служит группа переключателей Область применения (см. раздел 2.3.10.3.3). Если элемент объединяется с одним телом, то общее количество тел в модели не меняется, а если с несколькими, то — уменьшается, так как все объединенные тела становятся частями нового тела.

По умолчанию в группе Результат операции активен переключатель Автообъединение. Его особенностью является то, что он работает только в момент выполнения операции. Чтобы убедиться в этом, войдите в режим редактирования элемента, при создании которого был включен переключатель Автоопределение. Вы увидите, что в зависимости от результата операции на Панели свойств активен переключатель Новое тело или Объединение. В последнем случае на Панели свойств появится Список тел, содержащий названия тел, с которыми имеются пересечения.


2.3.2.8.2. Результат удаления материала

При вырезании из тела элемента выдавливания, вращения, по сечениям или кинематического можно удалить материал, находящийся внутри или снаружи поверхности элемента, т.е. вычесть элемент из тела, или получить пересечение элемента и тела (см. схему на рис. 2.3.19).

Рис. 2.3.19. Различные способы вырезания: а) исходные элементы, б) результат вычитания Элемента Б из Элемента А, в) результат пересечения элементов А и Б
а) | б) | в)

Чтобы выбрать вариант вырезания, активизируйте вкладку Панели свойств Вырезание (рис. 2.3.20).

Рис. 2.3.20. Выбор результата операции, удаляющей материал

Активизируйте в группе Результат операции переключатель, соответствующий требуемому способу вырезания — Вычитание элемента или Пересечение элементов.

Рис. 2.3.21. Различные способы вырезания: а) исходные элементы, б) результат вычитания цилиндра из полусферы, в) пересечение цилиндра и полусферы
а) | б) | в)


2.3.3. Операции «Вращение» и «Вырезать вращением»

2.3. Тела

2.3.3. Операции «Вращение» и «Вырезать вращением»

В этом разделе:

2.3.3.1. Элемент вращения

2.3.3.2. Выполнение операции

2.3.3.3. Сечение элемента вращения

2.3.3.3.1. Зависимость результата операции вращения от сечения

2.3.3.3.2. Указание сечения элемента вращения

2.3.3.3.3. Требования к эскизу элемента вращения

2.3.3.4. Ось вращения

2.3.3.5. Тип построения

2.3.3.6. Направление вращения

2.3.3.7. Угол вращения

2.3.3.7.1. Вращение на заданный угол

2.3.3.7.2. Вращение до вершины

2.3.3.7.3. Вращение до поверхности


2.3.3.1. Элемент вращения

Элемент вращения образуется путем поворота сечения вокруг оси в одну или в обе стороны на заданный угол. Например, элемент, показанный на рисунке 2.3.22, образован поворотом эскиза вокруг оси, лежащей в его плоскости, на 270°.

Рис. 2.3.22. Эскиз, ось и элемент, образованный операцией вращения

Элемент вращения может быть самостоятельным телом, а может быть приклеен к телу или вырезан из него.

Для создания нового тела выдавливания или приклеивания элемента вращения к имеющемуся телу (т.е. для добавления материала) служит операция Вращение, а для вырезания элемента вращения из тела (т.е. для удаления материала) — операция Вырезать вращением.

В качестве сечения элемента вращения может использоваться грань, эскиз, ребро или пространственная кривая (в том числе контур, построенный по линиям эскиза, ребрам грани или произвольный1).

При вращении грани, замкнутого эскиза, замкнутого Контура на грани или Контура эскиза возможен выбор между сплошным и тонкостенным элементом (рис. 2.3.23). При разомкнутом сечении возможно построение только тонкостенного элемента.

Рис. 2.3.23. Вращение грани: а) сечение и ось, б) сплошной элемент, в) тонкостенный элемент
а) | б) | в)

Если сечение представляет собой разомкнутый эскиз или разомкнутый контур, построенный по линиям эскиза или ребрам плоской грани, и вращается вокруг оси, лежащей в плоскости сечения, доступен выбор типа построения — тороид или сфероид (рис. 2.3.5). При построении сфероида возможен также выбор между сплошным и тонкостенным элементом. Тороид может быть только тонкостенным.

Рис. 2.3.24. Построение сфероида и тороида (сечение — эскиз — выделено утолщенной линией) а) сфероид сплошной, б) сфероид тонкостенный, в) тороид
а) | б) | в)

При вращении ребра или пространственной кривой (в том числе контура типа Произвольный) возможно построение только тонкостенного элемента. Пример вращения пространственной кривой приведен на рисунке 2.3.6.

Рис. 2.3.25. Элемент вращения с сечением-спиралью

  1. Т.е. имеющий тип Контур на грани, Контур эскиза и Произвольный, см. раздел 2.5.4.24.1.


2.3.3.2. Выполнение операции

1. Запустите операцию. Для этого:

– нажмите нужную кнопку на панели Редактирование детали или Редактирование модели

– или вызовите нужную команду из меню Операции.

Условие доступности команды Вырезать вращением: наличие в модели тела или компонента.

После запуска операции на Панели свойств появляются вкладки с элементами управления параметрами операции.

2. Задайте параметры операции:

– сечение, см. раздел 2.3.3.3;

– ось вращения, см. раздел 2.3.3.4;

– тип построения, см. раздел 2.3.3.5;

– направление вращения, см. раздел 2.3.3.6;

– угол вращения, см. раздел 2.3.3.7;

– параметры тонкой стенки, см. раздел 2.3.2.7;

– результат, см. раздел 2.3.2.8.

Все значения параметров при их вводе и редактировании немедленно отображаются на экране в виде фантома элемента. Фантом позволяет визуально проконтролировать правильность задания параметров.

Для задания угла вращения и толщины стенки можно использовать характерные точки (о характерных точках см. раздел 2.1.4.2.2).

3. Нажмите кнопку Создать объект для завершения операции.

4. Если в результате операции образуется тело из нескольких частей, то после выполнения операции запускается процесс изменения набора частей. Выберите части, которые следует оставить (см. раздел 2.3.11.1).

Результат операции — новое тело, приклеенный или вырезанный элемент — появляется в графической области.

В Дереве построения появляется пиктограмма операции, совпадающая с пиктограммой на кнопке команды, которая запускает операцию. Исключением является пиктограмма нового тела вращения — она отличается от пиктограммы на кнопке.

— пиктограмма нового тела вращения


2.3.3.3. Сечение элемента вращения

В этом разделе:

2.3.3.3.1. Зависимость результата операции вращения от сечения

2.3.3.3.2. Указание сечения элемента вращения

2.3.3.3.3. Требования к эскизу элемента вращения


2.3.3.3.1. Зависимость результата операции вращения от сечения

В таблице 2.3.4 представлены особенности выполнения и результата операции вращения, обусловленные выбором сечения.

Табл. 2.3.4. Особенности операции вращения, зависящие от объекта, используемого в качестве сечения

Объект

Особенности выполнения и результата операции

эскиз, грань, контур, построенный по линиям эскиза или по ребрам грани

– Возможен выбор типа построения — тороид или сфероид (см. раздел 2.3.3.5) при выполнении следующих условий:

– сечение разомкнуто и представляет собой эскиз или контур, построенный по линиям эскиза или ребрам плоской грани,

– ось вращения лежит в плоскости сечения.

– Возможно создание как тонкостенного, так и сплошного элемента при условии, что сечение замкнуто. Если сечение разомкнуто, то выбор между тонкостенным и сплошным элементом возможен при построении сфероида; в остальных случаях при разомкнутом сечении строится тонкостенный элемент.

– Эскиз должен удовлетворять требованиям, приведенным в разделе 2.3.3.3.3.

ребро, пространственная кривая, произвольный контур

– Возможно создание только тонкостенного элемента.

– Невозможен выбор типа построения — тороид или сфероид.


2.3.3.3.2. Указание сечения элемента вращения

Вы можете использовать в качестве сечения элемента вращения уже существующий в модели объект — ребро, кривую, эскиз или грань, а можете создать новый объект — контур — не прерывая операцию.

Чтобы выбрать в качестве сечения существующий объект, укажите его в Дереве построения или в графической области.

Чтобы построить контур, нажмите кнопку Контур на Панели специального управления. Будет запущена операция создания контура (см. раздел 2.5.4.24). Укажите объекты, входящие в контур, и нажмите кнопку Создать объект. Система вернется в процесс операции вращения, созданный контур появится в Дереве построения и будет автоматически выбран в качестве сечения элемента вращения.

Название объекта-сечения отображается в поле Сечение на Панели свойств.

Если при вращении сечения вокруг выбранной оси две или более точек сечения имеют совпадающие траектории, то выполнение операции невозможно. Необходимо сменить сечение или ось.

Сечение элемента вращения можно указать перед запуском операции.

Вы можете в любой момент сменить сечение элемента вращения. Для этого активизируйте переключатель Сечение, а затем укажите нужные объекты или постройте контур.

Эскиз, выбранный в качестве сечения элемента вращения, можно отредактировать, не прерывая операцию. Для этого следует нажать кнопку Редактировать эскиз на Панели специального управления. Система перейдет в режим редактирования эскиза. Внесите в эскиз необходимые изменения. Затем нажмите кнопку Эскиз на панели Текущее состояние или щелкните мышью по значку режима эскиза в окне документа для возврата в процесс операции вращения.


2.3.3.3.3. Требования к эскизу элемента вращения

– Объекты эскиза могут составлять один или несколько контуров.

– Если контуров несколько, они должны быть либо все замкнуты, либо все разомкнуты.

– Если контуры замкнуты, они могут быть вложенными друг в друга. Уровень вложенности не ограничивается.

Кроме сечения, эскиз может содержать также ось вращения. В этом случае к нему предъявляются дополнительные требования:

– ось должна быть изображена в эскизе отрезком со стилем линии Осевая или объектом типа Осевая линия;

– ни один из контуров не должен пересекать ось (или ее продолжение);

– часть точек контуров может лежать на оси (или ее продолжении):

• для замкнутых контуров — любые их точки и/или участки;

• для разомкнутых контуров — только их крайние точки.


2.3.3.4. Ось вращения

Для задания оси вращения вы можете:

– указать существующий объект:

• прямолинейный объект (ребро или ось) — осью будет сам этот объект,

• поверхность вращения, кроме сферы — осью будет ось вращения поверхности,

– построить вспомогательную ось.

Ось вращения может определяться автоматически. Для этого она должна находиться в том же эскизе, что и сечение элемента и являться отрезком со стилем Осевая или объектом Осевая линия. При необходимости вы можете сменить ось.

Чтобы выбрать прямолинейный объект или поверхность вращения, активизируйте переключатель Ось на Панели свойств, а затем укажите нужный объект в Дереве построения или в графической области.

Чтобы построить ось, нажмите кнопку Ось через вершину по объекту на Панели специального управления. Будет запущена операция создания оси (см. раздел 2.8.1.5). Постройте ось и нажмите кнопку Создать объект. Система вернется в процесс операции вращения, созданная ось появится в Дереве построения и будет автоматически выбрана в качестве оси вращения.

Название объекта, задающего ось, отображается в поле Ось.


2.3.3.5. Тип построения

Выбор типа построения — тороид или сфероид — возможен, если:

– сечение разомкнуто и представляет собой эскиз или контур, построенный по линиям эскиза или ребрам плоской грани,

– ось вращения лежит в плоскости сечения.

Чтобы выбрать нужный тип построения, активизируйте соответствующий переключатель в группе Способ (см. табл. 2.3.5).

Табл. 2.3.5. Типы элемента вращения
Значение опции Тип | Особенности формирования элемента | Результат построения
Тороид | При построении тороида вращается только само сечение. К получившейся поверхности добавляется слой материала. В результате получается тонкостенная оболочка — элемент с отверстием вдоль оси вращения. О задании параметров тонкой стенки рассказано в разделе 2.3.2.7. |
Сфероид | При построении сфероида конечные точки сечения проецируются на ось вращения. Построение элемента производится с учетом этих проекций. В результате получается сплошной элемент. |

Если требуется построить элемент вращения с плоскими торцами (рис. 2.3.26), создайте сечение, содержащее профиль этого элемента, а при выполнении операции активизируйте переключатель Сфероид.

Рис. 2.3.26. Построение элемента вращения с плоскими торцами


2.3.3.6. Направление вращения

Направление вращения можно выбрать из списка Направление (см. табл. 2.3.6).

Табл. 2.3.6. Возможные направления выдавливания
Значение опции Направление | В каком направлении производится вращение. Особенности задания угла вращения
Прямое | В прямом направлении относительно сечения1. При выборе этого варианта на Панели свойств присутствует список Способ 1 для выбора способа задания угла поворота (см. раздел 2.3.3.7).
Обратное | В обратном направлении относительно сечения1. При выборе этого варианта на Панели свойств присутствует список Способ 2 для выбора способа задания угла поворота (см. раздел 2.3.3.7).
Два направления | В обе стороны относительно сечения. При выборе этого варианта на Панели свойств присутствуют два списка Способ 1 и Способ 2 для выбора способа задания угла поворота в каждом направлении (см. раздел 2.3.3.7).
Средняя плоскость | В обе стороны симметрично относительно сечения. При выборе этого варианта списки Способ 1 и Способ 2 недоступны, т.к. возможен только один способ определения угла — точное задание суммарного угла поворота. Введите нужное значение в поле Угол 1.
  1. Чтобы различать направления (прямое и обратное), на фантоме в окне детали показана стрелка, соответствующая прямому направлению. Если выбран вариант Прямое направление, вращение будет производиться по стрелке. Если вариант Обратное направление — в противоположную стрелке сторону.


2.3.3.7. Угол вращения

После выбора направления требуется задать угол, на который будет повернуто сечение. Для этого выберите нужный вариант из списка Способ 1 (и/или Способ 2 — в зависимости от выбранного направления вращения) на Панели свойств. Список способов определения угла вращения содержит следующие варианты (они описаны ниже):

– На угол,

– До вершины,

– До поверхности.

В этом разделе:

2.3.3.7.1. Вращение на заданный угол

2.3.3.7.2. Вращение до вершины

2.3.3.7.3. Вращение до поверхности


2.3.3.7.1. Вращение на заданный угол

Поворот сечения производится точно на угол, заданный в поле Угол.

Рис. 2.3.27. Вращение на заданный угол


2.3.3.7.2. Вращение до вершины

Угол поворота сечения определяется автоматически по положению указанной пользователем вершины.

Рис. 2.3.28. Вращение до вершины

• Если в качестве сечения используется грань, эскиз, контур, построенный по линиям эскиза или ребрам грани, то вычисляется такой угол поворота, при котором поверхность торца элемента (или ее продолжение) проходит через указанную вершину.

• Если в качестве сечения используется ребро, пространственная кривая или произвольный контур, то угол поворота определяется следующим образом. В плоскости, перпендикулярной оси, строится окружность с центром на оси и проходящая через указанную вершину. На этой окружности находится точка, ближайшая к сечению. Угол поворота сечения принимается равным углу раствора дуги между найденной точкой и указанной вершиной.

Чтобы указать вершину, определяющую угол поворота, активизируйте на Панели свойств переключатель Вершина и укажите нужный точечный объект в графической области (точку можно указать также в Дереве построения). Название указанного объекта появится в поле рядом с переключателем.

Опция Отсекать позволяет отсечь элемент вращения плоскостью, проходящей через указанную вершину и ось вращения. В этом случае элемент имеет плоский торец вне зависимости от формы сечения.

Продление граней сложной формы не всегда возможно. Поэтому, если указанная вершина расположена так, что при заданной оси вращения торец элемента не проходит через нее, то в некоторых случаях построение выполняется только при включенной опции Отсекать.


2.3.3.7.3. Вращение до поверхности

Угол поворота определяется автоматически по положению указанной пользователем грани или плоскости.

Рис. 2.3.29. Вращение до поверхности

Чтобы задать поверхность, активизируйте переключатель Грань и укажите нужную грань или плоскость в Дереве построения или в графической области.

Элемент вращается до указанной поверхности. Торец элемента имеет форму поверхности.

Рекомендуется выбирать такие сечение, ось и поверхность, чтобы поверхность полностью пересекала элемент вращения. В противном случае построение выполняется только в случае, если указанная поверхность может быть продолжена. Продолжение поверхностей сложной формы не всегда возможно.


2.3.4. Операции «Кинематическая» и «Вырезать кинематически»

2.3. Тела

2.3.4. Операции «Кинематическая» и «Вырезать кинематически»

В этом разделе:

2.3.4.1. Кинематический элемент

2.3.4.2. Выполнение кинематической операции

2.3.4.3. Сечение кинематического элемента

2.3.4.3.1. Требования к эскизу-сечению

2.3.4.4. Траектория кинематического элемента

2.3.4.4.1. Требования к траектории

2.3.4.5. Тип движения сечения


2.3.4.1. Кинематический элемент

Кинематический элемент образуется путем перемещения сечения вдоль траектории, например, как на рисунке 2.3.30.

Рис. 2.3.30. Сечение, направляющая и кинематический элемент

Кинематический элемент может быть самостоятельным телом, а может быть приклеен к телу или вырезан из него.

Для создания нового кинематического тела или приклеивания кинематического элемента к имеющемуся телу (т.е. для добавления материала) служит операция Кинематическая, а для вырезания кинематического элемента из тела (т.е. для удаления материала) — операция Вырезать кинематически.


2.3.4.2. Выполнение кинематической операции

1. Запустите операцию. Для этого:

– нажмите нужную кнопку на панели Редактирование детали или Редактирование модели

– или вызовите нужную команду из меню Операции.

Условие доступности команд Кинематическая операция и Вырезать кинематически: наличие в модели как минимум одного эскиза. Дополнительное условие доступности команды Вырезать кинематически: наличие в модели тела или компонента.

После запуска операции на Панели свойств появляются вкладки с элементами управления параметрами операции.

2. Задайте параметры операции:

– сечение, см. раздел 2.3.4.3;

– траекторию, см. раздел 2.3.4.4;

– тип движения сечения, см. раздел 2.3.4.5;

– параметры тонкой стенки, см. раздел 2.3.2.7;

– результат, см. раздел 2.3.2.8.

Все значения параметров при их вводе и редактировании немедленно отображаются на экране в виде фантома элемента. Фантом позволяет визуально проконтролировать правильность задания параметров.

Для задания толщины стенки можно использовать характерные точки (о характерных точках см. раздел 2.1.4.2.2).

3. При необходимости смените вариант оптимизации построения. Это может изменить внешний вид кинематического элемента в случае, если траектория имеет сложную форму (например, спираль с переменным шагом). Для смены варианта оптимизации активизируйте вкладку Свойства Панели свойств и выберите другую строку из списка Версия оптимизации.

4. Нажмите кнопку Создать объект для завершения операции.

5. Если в результате операции образуется тело из нескольких частей, то после выполнения операции запускается процесс изменения набора частей. Выберите части, которые следует оставить (см. раздел 2.3.11.1).

Результат операции — новое тело, приклеенный или вырезанный элемент — появляется в графической области.

В Дереве построения появляется пиктограмма операции, совпадающая с пиктограммой на кнопке команды, которая запускает операцию. Исключением является пиктограмма нового кинематического тела — она отличается от пиктограммы на кнопке.

— пиктограмма нового кинематического тела


2.3.4.3. Сечение кинематического элемента

В качестве сечения кинематического элемента используется эскиз. Требования к эскизу указаны в разделе 2.3.4.3.1.

Чтобы задать сечение кинематического элемента, активизируйте переключатель Сечение и укажите нужный эскиз в Дереве построения или в графической области.

Название выбранного эскиза отображается в поле Сечение на Панели свойств.

Сечение можно указать перед запуском операции.

В этом разделе:

2.3.4.3.1. Требования к эскизу-сечению


2.3.4.3.1. Требования к эскизу-сечению

– Объекты эскиза-сечения должны составлять один контур.

– Контур может быть разомкнутым или замкнутым.


2.3.4.4. Траектория кинематического элемента

В качестве траектории кинематического элемента может использоваться:

– пространственная кривая (или отдельный сегмент многосегментной кривой),

– линия эскиза,

– ребро,

– цепочка вышеперечисленных объектов в любом сочетании.

Чтобы задать траекторию движения сечения, активизируйте переключатель Траектория. Затем в Дереве построения или в графической области укажите нужные объекты в порядке их соединения.

Название выбранного объекта или количество выбранных объектов отображается в поле Траектория на Панели свойств.

В этом разделе:

2.3.4.4.1. Требования к траектории


2.3.4.4.1. Требования к траектории

– Траектория может быть разомкнутой или замкнутой.

– Если траектория разомкнута, ее начальная или конечная точка должна лежать в плоскости эскиза-сечения.

– Если траектория замкнута, она должна пересекать плоскость эскиза-сечения.

– Касательная к траектории в ее точке, общей с плоскостью эскиза, не должна лежать в этой плоскости.


2.3.4.5. Тип движения сечения

При перемещении эскиза вдоль траектории его ориентация может меняться или оставаться постоянной. Чтобы задать требуемый тип движения сечения, активизируйте соответствующий переключатель в группе Движение сечения (см. табл. 2.3.7).

Табл. 2.3.7. Варианты изменения ориентации сечения при выполнении кинематической операции
Переключатель в группе Движение сечения | Особенности формирования элемента | Схема образования элемента
Сохранять угол наклона1 | Сечение перемещается так, чтобы в любой точке траектории угол между плоскостью сечения и траекторией был постоянным и равным углу между плоскостью эскиза-сечения и траекторией в начальной точке траектории. |
Параллельно самому себе2 | Сечение перемещается так, что в любой точке траектории его плоскость параллельна плоскости эскиза, содержащего сечение. |
Ортогонально траектории1 | Сечение перемещается так, чтобы в любой точке траектории плоскость сечения была перпендикулярна траектории. |
  1. Если плоскость эскиза-сечения перпендикулярна траектории в ее начальной точке, то варианты Сохранять угол наклона и Ортогонально траектории дают одинаковый результат построения.
  2. Нельзя производить движение сечения параллельно самому себе, если траектория имеет точки, в которых касательная к ней параллельна плоскости эскиза-сечения.

На рисунке 2.3.31 показано образование кинематического элемента при различной ориентации сечения относительно траектории (начальное положение эскиза и траектории во всех случаях одинаковое, результаты построения — разные).

Рис. 2.3.31. Кинематический элемент: а) эскизы сечения и траектории, б) перемещение сечения с сохранением угла наклона, в) перемещение сечения параллельно самому себе, г) перемещение сечения ортогонально траектории.
а) | б) | в) | г)


2.3.5. Операции «По сечениям» и «Вырезать по сечениям»

2.3. Тела

2.3.5. Операции «По сечениям» и «Вырезать по сечениям»

В этом разделе:

2.3.5.1. Элемент по сечениям

2.3.5.2. Выполнение операции

2.3.5.3. Сечения элемента по сечениям

2.3.5.3.1. Требования к эскизам-сечениям

2.3.5.4. Осевая линия элемента по сечениям

2.3.5.4.1. Требования к осевой линии

2.3.5.5. Способ построения элемента у крайних сечений

2.3.5.6. Траектория соединения сечений

2.3.5.6.1. Способ генерации траектории

2.3.5.6.2. Замкнутая или разомкнутая траектория


2.3.5.1. Элемент по сечениям

Элемент по сечениям образуется путем соединения нескольких сечений произвольной формы и расположения, например, как на рисунке 2.3.32. Крайнее сечение может быть точкой.

Рис. 2.3.32. Сечения и построенный по ним элемент

В случае необходимости при построении элемента по сечениям можно использовать осевую линию (см. рис. 2.3.33).

Элемент по сечениям может быть самостоятельным телом, а может быть приклеен к телу или вырезан из него.

Для создания нового тела по сечениям или приклеивания элемента по сечениям к имеющемуся телу (т.е. для добавления материала) служит операция По сечениям, а для вырезания элемента по сечениям из тела (т.е. для удаления материала) — операция Вырезать по сечениям.


2.3.5.2. Выполнение операции

1. Запустите операцию. Для этого:

– нажмите нужную кнопку на панели Редактирование детали или Редактирование модели

– или вызовите нужную команду из меню Операции.

Условие доступности команд Операция по сечениям и Вырезать по сечениям: наличие в модели как минимум двух эскизов. Дополнительное условие доступности команды Вырезать по сечениям: наличие в модели тела или компонента.

После запуска операции на Панели свойств появляются вкладки с элементами управления параметрами операции.

2. Задайте параметры операции:

– сечения, см. раздел 2.3.5.3;

– осевую линию, см. раздел 2.3.5.4;

– способ построения элемента у крайних сечений, см. раздел 2.3.5.5;

– траекторию соединения сечений, см. раздел 2.3.5.6;

– параметры тонкой стенки, см. раздел 2.3.2.7;

– результат, см. раздел 2.3.2.8.

Все значения параметров при их вводе и редактировании немедленно отображаются на экране в виде фантома элемента. Фантом позволяет визуально проконтролировать правильность задания параметров.

Построение тонкостенного элемента по сечениям возможно, только если все эскизы-сечения содержат контуры. Использовать эскизы, содержащие точки, для создания такого элемента нельзя.

Для задания толщины стенки можно использовать характерные точки (о характерных точках см. раздел 2.1.4.2.2).

3. Нажмите кнопку Создать объект для завершения операции.

4. Если в результате операции образуется тело из нескольких частей, то после выполнения операции запускается процесс изменения набора частей. Выберите части, которые следует оставить (см. раздел 2.3.11.1).

Результат операции — новое тело, приклеенный или вырезанный элемент — появляется в графической области.

В Дереве построения появляется пиктограмма операции, совпадающая с пиктограммой на кнопке команды, которая запускает операцию. Исключением является пиктограмма нового тела по сечениям — она отличается от пиктограммы на кнопке.

— пиктограмма нового тела по сечениям


2.3.5.3. Сечения элемента по сечениям

В качестве сечений при построении элемента по сечениям используются эскизы. Требования к эскизам указаны в разделе 2.3.5.3.1.

Чтобы задать сечения элемента, активизируйте переключатель Сечения и укажите нужные эскизы в Дереве построения или в графической области.

Перечень эскизов в порядке их указания появляется в окне Список сечений. В этом же порядке сечения будут соединены при построении элемента. Чтобы изменить порядок следования сечений или удалить какие-либо из них, воспользуйтесь кнопками над списком.

При выборе сечений в окне детали указывайте их в точках (вершинах), которые должны последовательно соединяться. В этом случае при автоматической генерации пути (см. табл. 2.3.9) будет построено тело требуемой формы.

Сечения можно указать перед запуском операции.

В этом разделе:

2.3.5.3.1. Требования к эскизам-сечениям


2.3.5.3.1. Требования к эскизам-сечениям

– Эскизы могут быть расположены в произвольно ориентированных плоскостях.

– Объекты каждого эскиза должны составлять один контур.

– Контуры должны быть или все замкнуты, или все разомкнуты.

– В крайних (первом и последнем) эскизах может быть по одной точке (вместо контура).

Использование точек в крайних эскизах возможно, если создается сплошной, а не тонкостенный элемент. Для этого остальные сечения должны быть замкнуты, так как по разомкнутым сечениям можно построить только тонкостенный элемент.


2.3.5.4. Осевая линия элемента по сечениям

В случае необходимости при построении элемента по сечениям можно задать осевую линию. Примеры элементов, построенных по одним и тем же сечениям с применением и без применения осевой линии, приведены на рисунке 2.3.33.

Рис. 2.3.33. Элементы по сечениям: а) без осевой линии; б) с осевой линией
а) | б)

В качестве осевой линии может использоваться:

– пространственная кривая,

– эскиз,

– ребро.

Осевая линия должна удовлетворять требованиям, приведенным в разделе 2.3.5.4.1.

Чтобы задать осевую линию элемента, активизируйте переключатель Осевая линия и укажите нужный объект в Дереве построения или в графической области.

В этом разделе:

2.3.5.4.1. Требования к осевой линии


2.3.5.4.1. Требования к осевой линии

– Осевая линия может быть разомкнутой или замкнутой.

– Если осевая линия разомкнута, ее конечные точки должны лежать в плоскостях первого и последнего эскизов сечений.

– Если контуры сечений разомкнуты, то осевая линия должна пересекать плоскости эскизов сечений в точках, принадлежащих этим контурам. Если контуры сечений замкнуты, допускается пересечение внутри контуров.

– Касательная к осевой линии в ее точке, общей с плоскостью эскиза, не должна лежать в этой плоскости.

– Если осевая линия — многосегментная (например, контур, состоящий из нескольких кривых), то ее сегменты должны быть состыкованы по касательной или гладко.


2.3.5.5. Способ построения элемента у крайних сечений

Вы можете задать направление касательных к элементу, проведенных через точки контуров в его крайних сечениях. Иными словами, вы можете изменить направление «выхода» элемента из первого сечения и направление «входа» элемента в последнее сечение. Для этого выберите требуемый вариант в списке Начальное сечение и Конечное сечение соответственно (см. табл. 2.3.8).

Табл. 2.3.8. Способы построения элемента у начального и конечного сечения

Переключатель в группе Траектория

Особенности формирования элемента

Схема образования элемента

По умолчанию

Указанные вершины сечений соединяются сплайнами третьего порядка.

По нормали

Элемент формируется так, чтобы плоскость, касательная к его поверхности вблизи граничного (начального или конечного) сечения, была перпендикулярна плоскости этого сечения.

По объекту

Элемент формируется так, чтобы плоскость, касательная к его поверхности вблизи граничного эскиза, была параллельна указанному прямолинейному объекту или перпендикулярна указанному плоскому объекту.

Чтобы задать объект, активизируйте переключатель Вектор начального (конечного) сечения и укажите нужный объект в Дереве построения или в графической области.


2.3.5.6. Траектория соединения сечений

Одни и те же сечения можно соединить различными способами. Вы можете выбрать способ генерации траектории, а также сделать ее разомкнутой или замкнутой.

В этом разделе:

2.3.5.6.1. Способ генерации траектории

2.3.5.6.2. Замкнутая или разомкнутая траектория


2.3.5.6.1. Способ генерации траектории

Точки сечений, соединяемые при построении элемента, могут быть указаны вручную или определены автоматически. Для выбора нужного варианта активизируйте соответствующий переключатель в группе Траектория (см. табл. 2.3.9).

Табл. 2.3.9. Варианты генерации траектории
Переключатель в группе Траектория | Особенности формирования элемента
Автоматическая генерация траектории | Точки сечений, соединяемые при построении элемента, определяются автоматически. Этот способ рекомендуется использовать, если топология сечений одинакова (рис. 2.3.34).
Генерация траектории по указанным точкам | Эскизы последовательно соединяются по точкам, ближайшим к точкам их указания (рис. 2.3.35).

Рис. 2.3.34. Автоматическое соединение сечений
а) | б)

Рис. 2.3.35. Элементы, образованные путем соединения разных точек одинаковых сечений (соединенные точки выделены)

Если эскизы указываются в Дереве построения, срабатывает алгоритм автоматической генерации пути.

Если сечения не выпуклые, указывайте путь вручную.

Если топология сечений сильно различается (например, в одном из них — треугольник, а в другом — пятиугольник), результат построения может не соответствовать ожидаемому: может произойти «скручивание» элемента, появление дополнительных ребер (рис. 2.3.36).

Рис. 2.3.36. Автоматическое соединение сечений с разной топологией
а) | б)

Для исправления вышеописанной ошибки отредактируйте сечения следующим образом:

1. Найдите сечение, контур в котором содержит наибольшее количество сегментов — геометрических объектов (отрезков, дуг, сплайнов). Определите это количество.

2. Разбейте геометрические объекты в остальных сечениях так, чтобы выполнялись два условия:

• во всех сечениях должно оказаться одинаковое количество сегментов — геометрических объектов. Оно должно быть равно количеству, определенному в п. 1,

• точки разбиения должны лежать на предполагаемых ребрах элемента по сечениям.

О приемах разбиения геометрических объектов см. раздел 3.5.6.

Результат построения элемента по преобразованным сечениям показан на рисунке 2.3.37.

Рис. 2.3.37. Дуга в верхнем сечении разбита на три части. В результате контур в сечении не изменился, а результат построения стал предсказуемым
а) | б)


2.3.5.6.2. Замкнутая или разомкнутая траектория

Чтобы выбрать вариант формирования траектории, активизируйте переключатель Разомкнутая или Замкнутая в группе Режим.

При создании замкнутой траектории соединяются сечения, которые были указаны первым и последним.

Если осевая линия (см. раздел 2.3.5.4) не используется, то группа Режим доступна при условии, что указано более двух сечений.

Если кроме сечений указана осевая линия, то группа Режим недоступна. При этом в ней активен переключатель, соответствующий конфигурации осевой линии.

Рис. 2.3.38. Разомкнутый и замкнутый элементы, построенные по одним и тем же сечениям

Если элемент замкнут, то способ его построения около всех сечений — По умолчанию (см. раздел 2.3.5.5).


2.3.6. Придание толщины граням тела или поверхности

2.3. Тела

2.3.6. Придание толщины граням тела или поверхности

Вы можете придать толщину граням тела или поверхности, т.е. добавить слой материала на эти грани. Грани, указываемые для придания толщины, могут принадлежать как объектам самой модели, так и объектам ее компонентов.

Для добавления слоя материала вызовите команду Придать толщину.

Команда доступна, если в модели есть хотя бы одна поверхность, тело или компонент.

Рис. 2.3.39. Придание толщины грани поверхности: а) исходная грань, б) добавление слоя материала в одном направлении
а) | б)

В качестве исходных объектов могут использоваться следующие:

– грань тела или поверхности;

– связная совокупность граней одного тела или поверхности.

Если нужно добавить слой материала ко всем граням тела или поверхности, то это тело или поверхность следует указать в Дереве построения.

Укажите исходный объект.

Исходные объекты для добавления материала можно указать и перед вызовом команды.

Повторное указание грани отменяет ее выбор.

Если требуется сменить все объекты, указанные для придания толщины, нажмите кнопку Указать заново на Панели специального управления, а затем повторите выбор объектов.

О выборе объектов подробно рассказано в разделе 2.1.4.1.1.

После указания исходных объектов на экране отображается фантом добавляемого слоя и характерные точки управления толщиной.

Задайте толщину добавляемого слоя. Это делается так же, как при настройке параметров тонкой стенки (см. раздел 2.3.2.7) с единственным отличием: нельзя отказаться от построения тонкой стенки, выбрав вариант Нет.

При необходимости настройте область применения операции с помощью элементов управления вкладки Результат операции Панели свойств (см. раздел 2.3.10.3.1).

Построение невозможно в следующих случаях:

– добавляемый слой материала является телом с нарушенной топологией, то есть с разрывами или участками поверхности, вырожденными в точку или линию;

– поверхность добавляемого слоя самопересекается;

– при указании нескольких граней однозначно не может быть определена линия пересечения их эквидистантных поверхностей.

Нажмите кнопку Создать объект, чтобы зафиксировать добавление материала.

Созданный элемент появляется в окне модели, а соответствующая ему пиктограмма — в Дереве.

В результате операции формируется слой материала, ограниченный исходной поверхностью и эквидистантной к ней или двумя эквидистантными поверхностями.

Придание толщины граням тела из частей невозможно. Необходимо сначала сделать тело целым, отредактировав имеющиеся элементы или создав новые элементы, которые соединят части.


2.3.7. Булева операция над телами

2.3. Тела

2.3.7. Булева операция над телами

Позволяет произвести булеву операцию над двумя телами, имеющимися в текущей модели. Тела, участвующие в операции, могут принадлежать как самой модели, так и ее компонентам. Результатом булевой операции является новое тело, принадлежащее текущей модели. Оно может участвовать в любых последующих операциях, в том числе булевых.

Команда доступна, если в модели имеется более одного тела.

Для вызова команды нажмите кнопку Булева операция на инструментальной панели редактирования модели или выберите ее название в меню Операции.

Рис. 2.3.40. Панель свойств при выполнении булевой операции

Укажите первое и второе тела, участвующие в операции.

Указанные тела подсвечиваются в окне модели. Соответствующие им пиктограммы выделяются цветом в Дереве построения. Названия тел отображаются в Списке объектов на вкладке Параметры Панели свойств (рис. 2.3.40).

Если необходимое отменить указание, нажмите кнопку Указать заново на Панели специального управления. Подсветка всех выбранных тел будет отменена, и вы сможете выбрать новые.

Если неправильно выбрано только второе тело, просто укажите нужное, не отменяя предыдущего выбора.

Задайте тип булевой операции с помощью группы переключателей Результат операции.

Чтобы объединить выбранные тела, активизируйте переключатель Объединение.

Чтобы удалить из первого тела объем, занимаемый вторым телом, активизируйте переключатель Вычитание. Первым считается тело, находящееся на первой позиции списка, а вторым — тело, находящееся на второй позиции.

Для изменения порядка следования тел воспользуйтесь кнопками Переместить вниз и Переместить вверх на панели Список тел.

Чтобы удалить весь объем обоих тел, кроме их общего объема, активизируйте переключатель Пересечение.

Объединение тел возможно, если они пересекаются или имеют общую поверхность, а вычитание и пересечение возможны, только если тела пересекаются.

Наименование объекта (название, которое отображается в Дереве построения) можно задать на вкладке Свойства Панели свойств.

Задав параметры операции, нажмите кнопку Создать объект на Панели специального управления.

В Дереве построения появится пиктограмма булевой операции, а в окне детали — тело, являющееся результатом операции.

В результате булевой операции вычитания или пересечения тел может образоваться тело, состоящее из нескольких частей (см. раздел 2.3.11).

В этом разделе:

2.3.7.1. Отображение булевой операции в Дереве построения


2.3.7.1. Отображение булевой операции в Дереве построения

На рис. 2.3.41 приведены примеры отображения в Дереве построения булевых операций над телами, находящимися на разных уровнях структуры модели.

Рис. 2.3.41. Отображение булевой операции в Дереве модели: а) исходное состояние модели, б) булева операция над телами, непосредственно принадлежащими модели, в) операция над телом, принадлежащим модели (указано первым), и телом, принадлежащим компоненту (указано вторым), г) то же, но порядок указания тел обратный
а) | б)
в) | г)


2.3.8. Операции редактирования тел

2.3. Тела

2.3.8. Операции редактирования тел

В функционале КОМПАС-3D учтены приемы работы, присущие машиностроительному проектированию. Ориентация системы на формирование моделей конкретных деталей, содержащих типичные конструктивные элементы, упрощает выполнение некоторых характерных операций. К ним относятся, например, операции создания фаски, ребра жесткости и т.п.

Для упрощения задания параметров этих элементов их создание выделено в отдельные команды. Так, для построения фаски не нужно рисовать эскиз, перемещать его вдоль ребра и вычитать получившийся объем из основного тела. Достаточно указать ребра для построения фаски и ввести ее параметры — величину катетов или величину катета и угол.

Команды создания конструктивных элементов расположены в меню Операции.

Для задания числовых параметров дополнительных конструктивных элементов можно использовать характерные точки (см. раздел 2.1.4.2.2).

Операции редактирования применимы как к телам, построенным в самой модели, так и к телам, построенным в компонентах.

В этом разделе:

2.3.8.1. Фаска

2.3.8.2. Скругление

2.3.8.2.1. Скругление с постоянным радиусом

2.3.8.2.2. Скругление с переменным радиусом

2.3.8.2.3. Сглаживание и обход углов

2.3.8.2.4. Скругление с сохранением кромки или с сохранением поверхности

2.3.8.2.5. Остановка скругления

2.3.8.3. Преобразование тел в оболочку

2.3.8.4. Ребро жесткости

2.3.8.4.1. Требования к эскизу ребра жесткости

2.3.8.4.2. Формирование ребра жесткости

2.3.8.4.3. Положение ребра

2.3.8.4.4. Уклон граней ребра

2.3.8.5. Уклон граней

2.3.8.6. Отсечение части модели

2.3.8.6.1. Сечение поверхностью

2.3.8.6.2. Сечение по эскизу

2.3.8.7. Масштабирование тел и поверхностей

2.3.8.8. Изменение положения тела или поверхности


2.3.8.1. Фаска

Чтобы создать фаску на ребрах детали, вызовите команду Фаска.

Команда не выполняется для ребер, образованных гладко сопряженными гранями.

Выберите способ построения фаски — По стороне и углу или По двум сторонам, активизировав соответствующий переключатель в группе Способ построения.

– Если фаска строится по стороне и углу, введите в поле Длина 1 длину стороны фаски, а в поле Угол — угол между этой стороной и поверхностью фаски. В справочном поле Длина 2 появится вычисленное значение длины второго катета фаски.

– Если фаска строится по двум сторонам, введите их длины в поля Длина 1 и Длина 2. В справочном поле Угол появится вычисленное значение угла фаски.

Укажите в окне детали ребра, на которых требуется построить фаску. Если требуется построить фаски на всех ребрах какой-либо грани, укажите эту грань.

После указания первого ребра в окне детали возникает фантом — стрелка, направленная вдоль одной из граней. Стрелка указывает направление, в котором будет откладываться сторона фаски с длиной Длина 1. Относительно этого же направления будет откладывается угол фаски.

Если требуется изменить направление, в котором откладывается первая сторона, активизируйте нужный переключатель (Первое направление или Второе направление) в группе Направление первой стороны. При этом направление стрелки-фантома (а значит, и направление первой стороны фаски) изменится.

Если стороны фаски равны, то результат ее построения не будет зависеть от направления первой стороны.

Не стройте фаску для каждого ребра в отдельности. Если это возможно, указывайте при создании фаски как можно большее количество ребер, параметры фаски для которых одинаковы.

Выполнение предыдущего совета может быть затруднено, если фаска неравносторонняя. Если ребра, выбранные для построения такой фаски, относятся не к одной грани, то выбор единого направления фаски для всех ребер может привести к неверному результату построения. В этом случае рекомендуется указывать для построения фаски ребра, относящиеся к одной грани, и создавать отдельную фаску для каждой грани.

Если несколько ребер, на которых строится фаска, гладко соединяются (имеют общую касательную в точке соединения), укажите одно из них и включите опцию По касательным ребрам. В этом случае система автоматически определит другие ребра, на которые требуется продолжить фаску.

После подтверждения выполнения операции на ребрах детали появится фаска, а в Дереве модели — пиктограмма фаски.

Создавайте фаски и скругления по возможности в конце процесса построения детали, а не сразу после возникновения формообразующих элементов, на ребрах которых требуется образовать фаски и скругления. В этом случае расчеты при выполнении формообразующих операций будут производиться быстрее.


2.3.8.2. Скругление

Чтобы скруглить ребро (или несколько ребер), вызовите команду Скругление.

Команда не выполняется для ребер, образованных гладко сопряженными гранями.

Выберите Тип скругления — с постоянным или с переменным радиусом. По умолчанию активен переключатель Постоянный радиус. Если необходимо построить скругление с переменным радиусом, активизируйте переключатель Переменный радиус.

Укажите скругляемые ребра. Если требуется скруглить все ребра, ограничивающие какую-либо грань, укажите эту грань.

Рис. 2.3.42. Скругление: а) для построения скругления указана верхняя грань, б) результат построения скругления
а) | б)

Не выполняйте скругление для каждого ребра в отдельности. Если это возможно, указывайте при создании скругления как можно большее количество ребер, которые требуется скруглить с одинаковым радиусом. В этом случае расчеты при перестроении модели будут производиться быстрее.

Для скругления с постоянным радиусом выберите способ построения и задайте параметры (см. раздел 2.3.8.2.1).

Для скругления с переменным радиусом задайте дополнительные параметры на вкладке Переменный радиус Панели свойств (см. раздел 2.3.8.2.2).

Активизируйте вкладку Параметры Панели свойств и выберите способы сглаживания и обхода углов (см. раздел 2.3.8.2.3).

Если несколько ребер, которые требуется скруглить, гладко соединяются (имеют общую касательную в точке соединения), укажите одно из них и включите опцию Продолжать по касательным ребрам. В этом случае система автоматически определит другие ребра, на которые требуется распространить скругление.

Рис. 2.3.43. Скругление: а) для построения скругления указано одно ребро и включена опция Продолжать по касательной, б) результат построения скругления
а) | б)

Опция Сохранять кромку позволяет построить скругление с сохранением формы ребер соседних граней (см. раздел 2.3.8.2.4). Опция недоступна при построении скругления с переменным радиусом.

Если скругление нужно остановить в определенном месте на ребре, активизируйте вкладку Остановка скругления и задайте параметры точки остановки (см. раздел 2.3.8.2.5).

После подтверждения выполнения операции ребра детали будут скруглены, а в Дереве построения появится пиктограмма скругления.

В этом разделе:

2.3.8.2.1. Скругление с постоянным радиусом

2.3.8.2.2. Скругление с переменным радиусом

2.3.8.2.3. Сглаживание и обход углов

2.3.8.2.4. Скругление с сохранением кромки или с сохранением поверхности

2.3.8.2.5. Остановка скругления


2.3.8.2.1. Скругление с постоянным радиусом

Для скругления с постоянным радиусом доступны четыре способа построения (табл. 2.3.10). Чтобы выбрать нужный способ, активизируйте соответствующий переключатель в группе Способ на Панели свойств.

Табл. 2.3.10. Способы построения скругления с постоянным радиусом
Способ | Результат построения
Дугой окружности Профиль скругления — дуга окружности. Введите нужный радиус скругления в поле Радиус или установите с помощью счетчика. |
Дугой эллипса Профиль скругления — дуга эллипса. Введите нужные значения полуосей эллипса (L1, L2) в поля Полуось 1 и Полуось 2 или установите с помощью счетчика. |
С коэффициентом Профиль скругления — коническая кривая (о конических кривых см. раздел 7 Приложения IX). Введите нужные значения радиуса скругления и коэффициента конической кривой скругления К в поля Радиус и Коэффициент или установите с помощью счетчика. Значение коэффициента К может изменяться в пределах от 0 до 1 (0<К<1). |
Если значение коэффициента К больше 0, но меньше 0,5 (0<К<0,5), то профиль скругления — дуга эллипса. |
Если значение коэффициента К равно 0,5, то профиль скругления — парабола. |
Если значение коэффициента К больше 0,5, но меньше 1 (0,5<К<1), то профиль скругления — гипербола. |
С постоянной хордой Профиль скругления — дуга окружности. Введите нужное значение хорды в поле Хорда или установите с помощью счетчика. |


2.3.8.2.2. Скругление с переменным радиусом

Чтобы построить скругление с переменным радиусом, необходимо задать точки на скругляемых ребрах и радиусы скругления в этих точках.

На вкладке Переменный радиус расположена одноименная панель, содержащая таблицу параметров скругления: номера точек, расстояния до них от начальных точек соответствующих ребер и значения радиусов скругления в этих точках (рис. 2.3.44, б). Пока точки для построения скругления не указаны, таблица параметров пуста.

Рис. 2.3.44. Построение скругления с переменным радиусом: а) указание точек, б) задание параметров скругления, в) результат выполнения команды
а) | б) | в)

Укажите в окне модели нужные точки. Выбранные точки будут отмечены «крестиками» и пронумерованы в порядке указания (рис. 2.3.44, а).

В таблице Переменный радиус задайте значения радиусов скругления в указанных точках.

Если необходимо, уточните значения в колонке % или Длина. Обратите внимание на то, что при изменении значений в этих колонках соответствующая точка смещается в окне модели.

Для изменения какого-либо значения сделайте одинарный или двойной щелчок в нужной ячейке. После одинарного щелчка возможен ввод в ячейку значения с клавиатуры, а после двойного — ввод с клавиатуры или выбор с помощью счетчика.

Вы можете удалить строку таблицы и, следовательно, точку в окне детали. Для этого нажмите кнопку Удалить, расположенную над списком.

Настройка параметров скругления с переменным радиусом имеет следующие особенности.

– По умолчанию радиус скругления в граничных точках ребер равен умолчательному — заданному в поле Радиус на вкладке Скругление Панели свойств. Граничными точками ребра являются его начальная и конечная точки. Им соответствуют 0% и 100% длины ребра. Если радиус скругления в граничной точке должен отличаться от умолчательного, необходимо указать ее явно в окне модели и задать требуемое значение радиуса в таблице параметров скругления.

Если ребро замкнуто, то его начальная и конечная точки совпадают, и при настройке скругления можно указать только одну из них.

Если для построения скругления выбраны два ребра, конечная точка одного из которых совпадает с начальной точкой другого, то при настройке скругления можно указать только одну из них.

– Нулевой радиус скругления может быть задан только в граничных точках. Если граничную точку ребра затруднительно точно указать в окне модели, то можно сначала указать ее примерно, а затем ввести нужное значение — 0% или 100% — в соответствующую ячейку таблицы параметров. Обратите внимание на то, что для точки, не являющейся граничной, невозможно задать нулевое значение радиуса, а для граничной точки с нулевым радиусом невозможно изменить расстояние от вершины (для этого необходимо прежде изменить радиус).

– Для скругления ребер, на которых не указаны точки, используется умолчательное значение. Например, если при создании скругления с переменным радиусом была включена опция Продолжать по касательным ребрам на вкладке Параметры Панели свойств, то эти касательные ребра находятся системой автоматически. Поскольку указать точки на них невозможно, они скругляются с умолчательным радиусом.


2.3.8.2.3. Сглаживание и обход углов

Сглаживание и Обход — это способы стыковки граней скругления.

Выбор способов осуществляется на вкладке Параметры Панели свойств при помощи групп переключателей Сглаживание и Обход. Примеры результатов построения приведены в таблицах 2.3.11 и 2.3.12.

Табл. 2.3.11. Способы сглаживания углов
Способ | Результат построения
Сглаживать углы |
Не сглаживать углы |

Табл. 2.3.12. Способы обхода углов
Способ | Результат построения
Обход без гладкой стыковки |
Обход с гладкой стыковкой |

Группа Обход доступна, если ребро скругляется способом Дугой окружности (см. табл. 2.3.10).


2.3.8.2.4. Скругление с сохранением кромки или с сохранением поверхности

Если поверхность скругления пересекается с соседними гранями, возможны два варианта выполнения операции:

– с сохранением кромки;

– с сохранением поверхности.

Для выбора первого варианта включите опцию Сохранять кромку на вкладке Параметры Панели свойств. В этом случае будет сохранена форма ребер соседних граней (рис. 2.3.45, б).

Если эта опция выключена, то скругление будет построено с сохранением поверхности. Форма ребер соседних граней может измениться (рис. 2.3.45, в).

Рис. 2.3.45. Скругление: а) исходные элементы, б) скругление с сохранением кромки, в) скругление без сохранения кромки
а) | б) | в)

Иногда взаимное расположение скругляемых поверхностей и заданный радиус скругления не позволяют сохранить кромку. Если при этом включена опция Сохранять кромку, то при попытке построить скругление система выдаст сообщение об ошибке.

Чтобы избежать такой ошибки, включите опцию Автоопределение. В этом случае система построит «комбинированное» скругление. Везде, где это возможно, будут сохранены кромки соседних граней. Там, где сохранение кромок невозможно, будут сохранены поверхности соседних граней.

Если включено автоопределение, опция Сохранять кромку недоступна и ее состояние не учитывается при построении скругления.


2.3.8.2.5. Остановка скругления

Остановка скругления возможна, если скругляется одно ребро (или одна цепочка ребер). На разомкнутом ребре (цепочке) может быть указана одна или две точки остановки, на замкнутом ребре обязательно должно быть указано две точки.

Рис. 2.3.46. Остановка скругления

Чтобы остановить скругление в определенном месте на ребре, активизируйте на Панели свойств вкладку Остановка скругления и включите опцию Остановка.

На вкладке находится панель Точки остановки. Панель содержит таблицу для настройки параметров точек остановки: номера точек, расстояния до них от начальной точки скругляемого ребра (или цепочки), информацию об ассоциативной связи с объектом.

Задайте точку (точки) остановки скругления. Для этого можно использовать следующие способы:

– указать произвольную точку на ребре,

– указать вершину, принадлежащую скругляемой цепочке ребер,

– указать объект для ассоциативной связи:

• точечный объект, принадлежащий скругляемому ребру,

• плоский объект, плоскость которого пересекает скругляемое ребро (точка остановки в этом случае находится как точка пересечения ребра с указанным объектом или его продолжением).

Заданная точка остановки отмечается в окне модели цифрой и стрелкой. Стрелка показывает направление усечения: та часть ребра, куда указывает стрелка, останется без изменения, а оставшаяся часть скругляется.

В таблице на Панели свойств точки остановки пронумерованы в порядке указания. Если точка указана произвольно, значения в колонке % или Длина можно отредактировать. При этом соответствующая точка смещается в окне модели.

Если точка остановки ассоциативно связана с объектом, то в колонке Связь с объектом отображается «галочка», изменение значений в колонках % и Длина невозможно. При выделении в таблице строки, которая соответствует точке, связанной с объектом, на Панели свойств появляется переключатель и поле Объект. На переключателе отображается «галочка», а в поле — название объекта, с которым связана точка. Чтобы отменить связь, следует щелкнуть либо в ячейке колонки Связь с объектом, либо на переключателе Объект. Обратите внимание на то, что для восстановления связи необходимо повторное указание объекта.

Направление усечения скругления можно на противоположное, нажав над списком кнопку Сменить направление.

Если плоский объект, с помощью которого определяется точка остановки, пересекает скругляемое ребро в нескольких местах, становятся доступны кнопки Следующее положение и Предыдущее положение. С их помощью выбирается нужная точка.

Вы можете удалить строку таблицы и, следовательно, точку в окне детали. Для этого нажмите кнопку Удалить, расположенную над списком.

По умолчанию скругление усекается в точке остановки плоскостью, проходящей перпендикулярно ребру (рис 2.3.46). Если точка остановки находится как точка пересечения ребра с плоским объектом, скругление можно усечь плоскостью этого объекта. Для этого выделите в таблице строку, которая соответствует данной точке, и включите опцию Усечение по объекту.

Для цепочки ребер остановка скругления возможна, если угол между нормалями к смежным граням во всех точках цепочки постоянный, см. рис 2.3.47.

Рис. 2.3.47. Доступность остановки скругления


2.3.8.3. Преобразование тел в оболочку

На любом этапе работы тело (или несколько тел) можно преобразовать в тонкостенную оболочку.

При создании оболочки все указанное тело исключается из расчетов, а к его граням добавляется слой материала, образующий оболочку.

Для создания оболочки требуется исключить одну или несколько граней тела, к которым не должен добавляться материал. Эти грани превратятся в отверстие (или отверстия) в получившейся оболочке.

При работе с телом, состоящим из нескольких частей, можно исключить грани некоторых из них. Эти части преобразуются в оболочки с отверстием, а остальные — в замкнутые оболочки.

Чтобы создать тонкостенную оболочку, вызовите команду Оболочка.

Укажите направление добавления материала — Наружу или Внутрь относительно поверхности тела. Для этого активизируйте соответствующий переключатель в группе Тип построения тонкой стенки.

Если материал добавляется наружу, введите толщину оболочки в поле Толщина стенки 1, если внутрь — в поле Толщина стенки 2.

Укажите грани тела, которые не должны участвовать в построении оболочки. Количество этих граней показывается в справочном поле Количество удаляемых граней.

Чтобы исключить какую-либо грань из числа выбранных, укажите ее в окне модели повторно. Выделение с этой грани будет снято, и при создании оболочки она удаляться не будет.

Если требуется отменить выбор всех граней, нажмите кнопку Указать заново на Панели специального управления.

Рис. 2.3.48. Создание тонкостенной оболочки: а) исходная деталь, удаляемые грани выделены, б) результат создания тонкостенной оболочки
а) | б)

После подтверждения выполнения операции в окне модели появится изображение тонкостенной оболочки, а в Дереве — соответствующая ей пиктограмма.

Порядок дальнейшей работы с получившейся оболочкой будет прежним — добавление и вычитание объемов, формирование фасок, скруглений и отверстий.


2.3.8.4. Ребро жесткости

Перед построением ребра жесткости в модели требуется создать эскиз, определяющий форму внешнего края ребра. Ребро строится от линии в эскизе к телу. В результате формируется тонкая стенка, ограниченная с одной стороны линией эскиза, а с остальных сторон — гранями тела.

В этом разделе:

2.3.8.4.1. Требования к эскизу ребра жесткости

2.3.8.4.2. Формирование ребра жесткости

2.3.8.4.3. Положение ребра

2.3.8.4.4. Уклон граней ребра


2.3.8.4.1. Требования к эскизу ребра жесткости

– Объекты эскиза должны составлять один контур.

– Контур должен быть разомкнутым.

– Касательные к контуру в его конечных точках должны пересекать тело.

– Контур может не доходить до тела. Система продолжит контур до пересечения с ближайшей гранью. Криволинейные контуры продолжаются по касательным к ним в крайних точках.


2.3.8.4.2. Формирование ребра жесткости

Чтобы построить ребро жесткости, вызовите команду Ребро жесткости.

Команда Ребро жесткости доступна, если выделен один эскиз (эскиз ребра).

Если модель содержит несколько тел, то для построения ребра жесткости необходимо указать то из них, к которому будет приклеено создаваемое ребро. Приклеивание ребер жесткости возможно как к телам, построенным в самой модели, так и к телам, построенным в компонентах. Обратите внимание на то, что грани, ограничивающие ребро, должны принадлежать одному и тому же телу.

Чтобы выбрать тело, укажите в окне модели любую грань, вершину или ребро этого тела, либо выделите в Дереве построения принадлежащий телу объект одного из следующих типов:

– первый формообразующий элемент,

– приклеенный формообразующий элемент,

– приклеенное листовое тело,

– приклеенная зеркальная копия тела,

– булева операция.

Выбранный объект будет подсвечен.

Удобнее всего указывать в окне модели грань (или одну из граней), к которой будет непосредственно примыкать создаваемое ребро жесткости.

Если вы случайно ошиблись при указании тела, нажмите кнопку Указать заново на Панели специального управления. Подсветка с ранее выбранного объекта будет снята, и вы сможете указать другое тело.

С помощью элементов управления Панели свойств настройте параметры ребра:

– положение — на вкладке Параметры (см. раздел 2.3.8.4.3),

– уклон граней — на вкладке Параметры (см. раздел 2.3.8.4.4),

– толщину — на вкладке Толщина; она задается так же, как при настройке параметров тонкой стенки (см. раздел 2.3.2.7) с единственным отличием: нельзя отказаться от построения тонкой стенки, выбрав вариант Нет.

После подтверждения выполнения операции в окне детали появится ребро жесткости, а в Дереве — соответствующая ему пиктограмма.


2.3.8.4.3. Положение ребра

Ребро жесткости может быть перпендикулярно или параллельно плоскости эскиза. Для выбора варианта построения активизируйте соответствующий переключатель в группе Положение (см. табл. 2.3.13).

Табл. 2.3.13. Возможные положения ребра жесткости
Значение опции Положение | Положение и форма ребра | Результат построения
В плоскости эскиза | Ребро жесткости параллельно плоскости эскиза. Эскиз ограничивает ребро по периметру. |
Ортогонально плоскости эскиза | Ребро жесткости перпендикулярно плоскости эскиза ребра. Поверхность ребра образуется выдавливанием эскиза. |

Если тело детали расположено по одну сторону от эскиза, система автоматически распознает направление выдавливания ребра (в сторону детали). Это — Прямое направление. Чтобы изменить направление формирования ребра жесткости, активизируйте переключатель Обратное направление в группе Направление. Направление построения ребра показывается на фантоме в окне модели в виде стрелки.


2.3.8.4.4. Уклон граней ребра

Если требуется, чтобы грани элемента имели уклон, введите его значение в поле Угол уклона. Боковые грани ребра жесткости будут уклонены наружу под заданным углом.

Если эскиз ребра жесткости состоит из нескольких сегментов (например, отрезков), вы можете указать сегмент, задающий направление уклона. Для этого используйте кнопку Следующий. При нажатии на нее подсвечивается один из сегментов эскиза. Нажимайте кнопку, пока не будет подсвечен нужный сегмент. Торцевая грань ребра жесткости, соответствующая этому сегменту, будет принята за основание уклона. Боковые грани ребра будут наклонены по отношению к ней на заданный угол (рис. 2.3.49).

Выбор сегмента, задающего направление уклона, имеет смысл только при построении ребра в плоскости эскиза (когда активен переключатель В плоскости эскиза).

Рис. 2.3.49. Ребро жесткости с уклоном. Эскиз ребра состоит из трех сегментов.
Сегмент, задающий направление уклона, выделен.


2.3.8.5. Уклон граней

Чтобы придать уклон плоским граням, перпендикулярным основанию, или цилиндрическим граням, образующие которых перпендикулярны основанию, вызовите команду Уклон.

Для построения уклона необходимо указать его основание и уклоняемые грани.

Основание уклона — плоская грань детали, форма, размеры и угол наклона которой не изменятся после выполнения команды Уклон.

Уклоняемые грани — грани, угол наклона которых по отношению к основанию изменится в результате выполнения команды Уклон.

Чтобы выбрать основание, активизируйте переключатель Основание и укажите нужную грань в окне детали.

Чтобы выбрать уклоняемые грани, активизируйте переключатель Грани и укажите нужные грани в окне детали.

Основание всегда одно. Уклоняемых граней может быть несколько.

Уклоняемые грани должны быть смежны с основанием. Между собой они могут быть не смежны.

Выберите направление уклона граней — Внутрь или Наружу, активизировав соответствующий переключатель в группе Уклон. При уклонении граней внутрь сечение элемента уменьшается, при уклонении наружу — увеличивается.

Иногда в качестве основания можно указать разные грани. При этом результат выполнения команды будет зависеть от взаимного положения основания и уклоняемой грани (рис. 2.3.50).

Рис. 2.3.50. Уклон: а) исходная деталь и уклоняемая грань, б) и в) результат создания уклона в зависимости от выбора основания
а) | б) | в)

Введите значение угла уклона в поле Угол.

Если применить команду Уклон к грани, уже наклоненной к основанию под каким-либо углом, то этот угол учитываться не будет (то есть результат будет таким, как если бы команда была применена к грани, перпендикулярной основанию).

После подтверждения выполнения операции указанные грани получат уклон, а соответствующая ему пиктограмма появится в Дереве построения.

Не наклоняйте каждую грань в отдельности. Если это возможно, указывайте при выполнении команды Уклон как можно большее количество граней, которые требуется наклонить под одинаковым углом к основанию. В этом случае расчеты при перестроении модели будут производиться быстрее.

Команда не выполняется, если система обнаружит, что грани, перестроенные в соответствии с заданными параметрами уклона, не образуют тело.

Если требуется скруглить одно или несколько ребер, ограничивающих уклоняемую грань, сделайте это после придания грани уклона.

Применение команды Уклон наиболее эффективно на завершающих этапах проектирования литых деталей, когда отдельным граням требуется придать небольшой уклон для облегчения выемки отливок из форм.

Вообще говоря, уклон боковым граням элемента выдавливания можно придать путем редактирования параметров этого элемента. Однако этот способ принципиально отличается от выполнения операции уклона:

– команда Уклон позволяет наклонить отдельные грани, а при выдавливании с уклоном наклоняются все боковые грани элемента,

– при выполнении команды Уклон не меняется положение элементов, подчиненных уклоняемым граням, а при редактировании элемента выдавливания с приданием уклона его граням объекты, подчиненные этим граням, «наклоняются» вместе с ними.


2.3.8.6. Отсечение части модели

На любом этапе построения модели можно удалить часть ее тела (тел). Границей отсечения может служить поверхность произвольной формы или поверхность, образованная выдавливанием произвольного эскиза.

Обратите внимание на то, что плоскость или поверхность, используемая для отсечения, может принадлежать как самой модели, так и любому из ее компонентов, а эскиз должен принадлежать непосредственно модели.

Вообще говоря, такие действия можно произвести и с помощью команды Вырезать выдавливанием. Однако при этом потребуется задание большего количества параметров, а в некоторых случаях построение более сложного эскиза, чем требуется для отсечения части модели.

Для отсечения части модели пересекающей эту модель плоскостью или поверхностью выдавливания предназначены специальные команды. Они расположены в меню Операции — Сечение. Кнопки для их быстрого вызова находятся в одной группе на панели Редактирование детали.

Расположение и форма секущей поверхности могут быть таковы, что в результате отсечения образуется тело, состоящее из нескольких частей (см. раздел 2.3.11).

В этом разделе:

2.3.8.6.1. Сечение поверхностью

2.3.8.6.2. Сечение по эскизу


2.3.8.6.1. Сечение поверхностью

Чтобы удалить часть модели, находящуюся по одну сторону пересекающей эту деталь поверхности, вызовите команду Сечение поверхностью.

В качестве поверхности сечения могут использоваться следующие объекты:

– базовые и вспомогательные плоскости,

– импортированные и построенные в детали поверхности,

– грани.

Плоская поверхность может быть продолжена в любую строну, поэтому она не обязательно должна располагаться так, чтобы пересекать всю деталь. Продолжение неплоской поверхности невозможно, поэтому корректное отсечение части детали такой поверхностью возможно, только если она полностью пересекает тело детали.

Если перед вызовом команды была выделена поверхность, пересекающая деталь, название этой поверхности появится в поле Поверхность сечения на Панели свойств.

Если поверхность сечения не была выделена перед вызовом команды, укажите ее.

Вы можете удалить часть детали по любую сторону от поверхности сечения. Чтобы выбрать направление, активизируйте соответствующий переключатель в группе Направление отсечения — Прямое или Обратное. Направление отсечения показывается на фантоме в окне детали в виде стрелки.

Рис. 2.3.51. Отсечение части детали плоскостью: а) исходное состояние детали (плоскость отсечения обозначена условно), б) результат выполнения операции отсечения
а) | б)

Если вы работаете с многотельной деталью, то кроме настройки параметров отсечения может понадобиться задание области применения операции. Для этого служит вкладка Панели свойств Результат операции. Подробно об области применения операций и способах ее задания рассказано в разделе 2.3.10.3.

После подтверждения выполнения операции модель будет усечена, а в Дереве построения появится соответствующая пиктограмма.


2.3.8.6.2. Сечение по эскизу

Чтобы удалить часть детали, находящуюся по одну сторону пересекающей эту деталь поверхности выдавливания, используйте команду Сечение по эскизу.

Секущая поверхность образуется перемещением эскиза в направлении, перпендикулярном его плоскости.

Перед вызовом команды выделите эскиз, в котором изображен профиль поверхности.

Требования к эскизу поверхности отсечения

– Объекты эскиза должны составлять один контур.

– Контур должен быть разомкнутым.

– Контур должен пересекать проекцию детали на плоскость эскиза.

Выполнение отсечения

Вызовите команду Сечение по эскизу.

Название эскиза, по которому производится отсечение, появится в поле Профиль сечения на Панели свойств.

Вы можете удалить часть детали по любую сторону от поверхности выдавливания. Чтобы выбрать направление, активизируйте соответствующий переключатель в группе Направление отсечения — Прямое или Обратное. Направление отсечения показывается на фантоме в окне детали в виде стрелки.

Рис. 2.3.52. Отсечение части детали по эскизу: а) исходное состояние детали, показан эскиз поверхности отсечения, б) результат выполнения операции отсечения
а) | б)

Если вы работаете с многотельной деталью, то кроме настройки параметров отсечения может понадобиться задание области применения операции. Для этого служит вкладка Панели свойств Результат операции. Подробно об области применения операций и способах ее задания рассказано в разделе 2.3.10.3.

После подтверждения выполнения операции модель будет усечена, а в Дереве построения появится соответствующая пиктограмма.


2.3.8.7. Масштабирование тел и поверхностей

Масштабирование позволяет изменить размеры тела или поверхности в трех направлениях согласно заданному коэффициенту. Получившееся тело или поверхность может участвовать в последующих операциях (в том числе в операции масштабирования) без ограничений.

Команда Масштабирование доступна, если в модели имеется хотя бы одно тело или поверхность. Операция масштабирования применима также к телам и поверхностям компонентов.

Чтобы произвести операцию масштабирования, нажмите кнопку Масштабирование на инструментальной панели редактирования модели или выберите ее название в меню Операции.

Выберите тело или поверхность для масштабирования в Дереве построения или в окне модели.

Пиктограммы и названия тел показываются в Дереве, если в нем включено отображение структуры модели (см. раздел 2.1.2.2).

Если в модели содержится одно тело или одна поверхность, то это тело или поверхность выбирается автоматически.

Выбранный объект подсвечивается в Дереве построения и в окне модели. При этом в окне модели также отображается габаритный параллелепипед, по дальнейшему изменению которого можно визуально оценить масштабирование.

В поле Тело или поверхность на Панели свойств отображается наименование объекта.

За один вызов команды Масштабирование можно изменить размеры одного тела или одной поверхности.

Введите или задайте счетчиком коэффициент масштабирования.

Коэффициент масштабирования можно задать также с помощью характерной точки (см. раздел 2.1.4.2.2).

Укажите в Дереве построения или в окне модели центр масштабирования — вершину или точку в пространстве, выбираемую за неподвижную. После выполнения команды расстояние от этой точки до центра масс масштабируемого объекта изменится пропорционально коэффициенту масштабирования в направлении отрезка, соединяющего эти точки.

По умолчанию центром является начало текущей системы координат модели.

Точка выделяется в модели, а ее наименование отображается в поле Точка-центр.

Чтобы сменить центр масштабирования, укажите новую точку в окне модели.

Вы можете создать точку, нажав кнопку Построение точки на Панели специального управления (подробнее см. раздел 2.5.2.11).

В процессе ввода параметров масштабирования габаритный параллелепипед изменяет размеры и расположение относительно центра масштабирования пропорционально заданному коэффициенту.

Чтобы выбрать другие объекты для выполнения операции, нажмите кнопку Указать заново на Панели специального управления. Текущий выбор объектов отменяется, и вы можете указать новые.

Наименование объекта, цвет и оптические свойства его поверхности можно задать на вкладке Свойства Панели свойств.

Задав параметры операции, нажмите кнопку Создать объект на Панели специального управления.

Промасштабированное тело или поверхность появится в окне модели, а соответствующая ему пиктограмма — в Дереве построения.

Обратите внимание на то, что масштабируются только сами тела или поверхности. Их исходные и производные объекты — эскизы, условные изображения резьбы, обозначения и т.п. — не изменяются.

При дальнейшей работе с моделью, для построения которой использовалась команда Масштабирование, необходимо учитывать следующее.

– Промасштабированное листовое тело теряет свойства, характерные для данного типа тел.

– При построении массивов объектов операции масштабирования, произведенные над объектами ранее, игнорируются. Экземпляры массивов имеют такие размеры и положение в модели, как если бы массивы были построены до выполнения масштабирования.

– Сопряжения, наложенные на объекты, игнорируют последующие изменения размеров и положения объектов, вызванные масштабированием. Чтобы исправить сопряжения, их следует отредактировать, повторно указав сопрягаемые объекты.


2.3.8.8. Изменение положения тела или поверхности

Операция изменения положения позволяет перенести тело или поверхность в произвольную точку модели и повернуть на произвольный угол.

Результатом операции является новый объект — тело или поверхность. Объекты, производные от первоначального («старого») тела или поверхности, остаются связаны с этим телом или поверхностью. Новое тело или поверхность может участвовать в последующих операциях (в том числе в операции изменения положения) без ограничений.

В зависимости от настройки, сделанной при выполнении операции, первоначальный объект удаляется из модели или остается в ней. Если этот объект участвовал в сопряжениях, то в случае его удаления они отмечаются как ошибочные. Для исправления сопряжений их следует отредактировать, повторно указав сопрягаемые объекты.

Изменение положения тела или поверхности производится в заданной пользователем системе координат. Она становится системой координат для операции изменения положения (о системе координат объекта см. раздел 2.8.3.4.1).

Команда изменения положения тела или поверхности доступна, если в модели имеется хотя бы одно тело или поверхность. За один вызов команды можно изменить положение одного тела или одной поверхности. Обратите внимание на то, что операция изменения положения применима только к телам и поверхностям, построенным в самой модели (а не в каком-либо из ее компонентов).

Чтобы изменить положение тела или поверхности, выполните следующие действия.

1. Запустите операцию изменения положения тела или поверхности. Для этого нажмите кнопку Изменить положение на инструментальной панели редактирования модели или вызовите команду Операции — Изменить положение.

2. Укажите объект (тело или поверхность), положение которого требуется изменить, в Дереве построения или в окне модели.

Пиктограммы и названия тел показываются в Дереве, если в нем включено отображение структуры модели (см. раздел 2.1.2.2).

Если в модели содержится одно тело или одна поверхность, то это тело или поверхность выбирается автоматически.

Указанный объект и система координат (по умолчанию — текущая), в которой будет производиться изменение его положения, подсвечиваются в Дереве построения и в окне модели.

В окне модели отображается также специальный элемент управления сдвигом и поворотом объекта — фантом системы координат. Изменение положения объекта производится путем изменения положения этого фантома. Взаимное положение объекта и фантома системы координат не меняется. Первоначально фантом совпадает с выбранной системой координат. Вы можете перемещать фантом вдоль осей системы координат, вдоль собственных осей, а также вращать вокруг собственных осей.

3. Если требуется использовать другую систему координат, укажите ее в Дереве построения.

Если подходящей системы координат в модели нет, постройте новую локальную систему координат. Для этого нажмите кнопку Построение ЛСК на Панели специального управления. Будет запущена операция создания ЛСК (см. раздел 2.8.3.5). Задайте положение ЛСК и нажмите кнопку Создать объект. Система вернется в процесс операции изменения положения объекта, созданная ЛСК появится в Дереве построения и будет автоматически выбрана в качестве системы координат, в которой производится изменение положения.

4. Укажите, требуется ли удалять первоначальное тело или поверхность. Для этого активизируйте нужный переключатель в группе Режим:

– Удалять исходные объекты — количество тел (поверхностей) в модели не изменяется, первоначальное тело (поверхность) не отображается в окне модели, а в Дереве построения отображается как подчиненный объект операции Изменение положения;

– Оставлять исходные объекты — количество тел (поверхностей) в модели увеличивается на единицу, первоначальное тело (поверхность) отображается в окне и в Дереве построения на своем прежнем месте.

5. Активизируйте вкладку Параметры Панели свойств, чтобы задать позицию и ориентацию фантома системы координат. Доступны два способа задания позиции и ориентации, аналогичные используемым при создании локальной системы координат. Для выбора способа раскройте список Способ и укажите в нем нужную строку:

– Относительно СК — относительно указанной системы координат (см. раздел 2.8.3.6.1),

– По объекту — по объекту, свойства которого позволяют однозначно определить позицию и ориентацию фантома системы координат (см. раздел 2.8.3.6.2).

Сдвиг и/или поворот фантома системы координат отображается на фантоме объекта: он занимает положение, соответствующее новому положению системы координат.

Если требуется расположить объект относительно какой-либо системы координат (назовем ее СК1) так же, как он располагается относительно другой системы координат (СК2), укажите СК2 в качестве системы координат, в которой производится изменение положения, а СК1 — в качестве объекта, определяющего позицию и ориентацию фантома системы координат.

6. При необходимости измените наименование и цвет нового тела или поверхности. Для этого служат элементы управления, расположенные на вкладке Свойства Панели свойств.

7. Нажмите кнопку Создать объект на Панели специального управления для подтверждения выполнения операции.

Тело или поверхность изменит свое положение в окне модели, в Дереве построения появится пиктограмма операции изменения положения.


2.3.9. Круглое отверстие

2.3. Тела

2.3.9. Круглое отверстие

К операциям редактирования тел относится и создание круглого отверстия. В КОМПАС-3D имеется возможность построения круглых отверстий следующих типов:

– Простое отверстие,

– Отверстие с зенковкой,

– Отверстие с цековкой,

– Отверстие с зенковкой и цековкой,

– Коническое отверстие.

О построении круглых отверстий рассказано в разделе 2.3.9.1.

Кроме того, вы можете построить круглое отверстие по эскизному профилю, используя библиотеку отверстий, Для этого служит команда Отверстие из библиотеки (см. раздел 2.3.9.2).

Группа команд создания круглых отверстий различных типов и команда Отверстие из библиотеки находятся в меню Операции — Отверстие.

Кнопки для их быстрого вызова расположены на инструментальной панели редактирования модели (рис. 2.3.53).

Рис. 2.3.53. Кнопки вызова команд создания круглого отверстия
и команды Отверстие из библиотеки

В этом разделе:

2.3.9.1. Круглое отверстие: простое, с зенковкой/цековкой, коническое

2.3.9.1.1. Задание глубины отверстия

2.3.9.1.2. Параметры отверстия с зенковкой и/или цековкой

2.3.9.1.3. Параметры конического отверстия

2.3.9.1.4. Создание резьбового отверстия

2.3.9.1.5. Задание формы торца отверстия

2.3.9.1.6. Размещение отверстия на поверхности

2.3.9.1.7. Создание отверстия по образцу

2.3.9.2. Отверстие из библиотеки


2.3.9.1. Круглое отверстие: простое, с зенковкой/цековкой, коническое

2.3.9.1. Круглое отверстие:
простое, с зенковкой/цековкой, коническое

Для создания круглого отверстия определенного типа вызовите соответствующую команду:

Простое отверстие;

Отверстие с зенковкой;

Отверстие с цековкой;

Отверстие с зенковкой и цековкой;

Коническое отверстие.

После вызова команды на Панели свойств появляются элементы управления для задания параметров отверстия (рис. 2.3.54). Часть параметров задается для всех типов отверстий, а остальные параметры зависят от типа отверстия.

В процессе построения можно сменить тип отверстия, выбрав нужную строку из списка Тип отверстия. Выбор типа отверстия из списка равносилен вызову команды создания соответствующего круглого отверстия.

Рис. 2.3.54. Панель свойств при построении простого отверстия

Чтобы построить круглое отверстие, выполните следующие действия.

1. После запуска команды укажите поверхность, на которой будет размещаться отверстие. Фантом отверстия с заданными параметрами отображается в окне модели. Точкой привязки отверстия является точка указания отверстия на выбранной поверхности.

В процессе построения можно выбрать другую поверхность для размещения отверстия.

2. Задайте значение диаметра отверстия в поле Диаметр.

3. Задайте глубину отверстия (см. раздел 2.3.9.1.1).

4. Задайте параметры, зависящие от типа отверстия:

– для отверстия с зенковкой и/или цековкой (см. раздел 2.3.9.1.2),

– для конического отверстия (см. раздел 2.3.9.1.3).

5. При необходимости используйте следующие возможности.

– Создание резьбового отверстия (см. раздел 2.3.9.1.4).

– Задание формы торца отверстия (см. раздел 2.3.9.1.5).

– Создание оси отверстия. Для этого включите опцию Ось.

– Задание параметров размещения отверстия (см. раздел 2.3.9.1.6):

• положение точки привязки отверстия,

• наклон и поворот оси,

• выбор направления построения,

• вырезание части тела над отверстием.

– Создание отверстия по образцу (см. раздел 2.3.9.1.7).

Диаметр, глубину и положение отверстия на поверхности можно изменить с помощью характерных точек.

Если вы работаете с многотельной деталью, то кроме настройки параметров может понадобиться задание области применения операции. Для этого служит вкладка Панели свойств Результат операции. Подробно об области применения операций и способах ее задания рассказано в разделе 2.3.10.3.

6. После задания всех параметров отверстия нажмите кнопку Создать объект на Панели специального управления.

Модель с отверстием на указанной поверхности будет показана в окне, а пиктограмма, соответствующая типу выбранного отверстия, появится в Дереве построения. Если отверстие создавалось с осью и/или с резьбой, то пиктограмма вспомогательной оси и/или условного изображения резьбы отображается в Дереве построения как подчиненный объект отверстия. Рядом с условным изображением резьбы указывается обозначение резьбы (для нестандартной резьбы используется надпись Условное изображение резьбы).

В этом разделе:

2.3.9.1.1. Задание глубины отверстия

2.3.9.1.2. Параметры отверстия с зенковкой и/или цековкой

2.3.9.1.3. Параметры конического отверстия

2.3.9.1.4. Создание резьбового отверстия

2.3.9.1.5. Задание формы торца отверстия

2.3.9.1.6. Размещение отверстия на поверхности

2.3.9.1.7. Создание отверстия по образцу


2.3.9.1.1. Задание глубины отверстия

Для всех типов круглого отверстия глубина задается от точки привязки отверстия до центра торца прямого кругового цилиндра отверстия.

Глубину отверстия можно задать различными способами.

Выберите способ определения глубины отверстия из списка Глубина (см. табл 2.3.14).

Глубина отверстия, имеющего конический или сферический торец, увеличивается на высоту торца. Подробнее о выборе формы торца рассказано в разделе 2.3.9.1.5.

Табл. 2.3.14. Способ определения глубины отверстия

Значение опции Глубина

Правила построения

На расстояние

Глубина отверстия определяется заданным расстоянием. Доступно поле Глубина выреза. Введите в него значение расстояния.

Через все

Глубина отверстия определяется расстоянием от указанной поверхности до точки пересечения оси отверстия с плоскостью, перпендикулярной оси и проходящей через наиболее удаленную от точки привязки точку габаритного параллелепипеда модели.

До вершины

Глубина отверстия определяется абсолютным значением расстояния от точки привязки отверстия до проекции точечного объекта на ось отверстия. Укажите точечный объект в окне модели. Название указанного объекта появится в поле рядом с переключателем Вершина. Чтобы сменить точечный объект, активизируйте переключатель Вершина, а затем укажите нужный объект заново.

До поверхности

Глубина отверстия определяется автоматически по положению указанной пользователем грани или плоскости. Отверстие вырезается до указанной поверхности. Торец отверстия имеет форму поверхности.

Укажите в окне модели поверхность, которой ограничена глубина отверстия. Название указанного объекта появится в поле рядом с переключателем Поверхность.

Чтобы сменить объект, активизируйте переключатель Поверхность, а затем укажите нужный объект заново.


2.3.9.1.2. Параметры отверстия с зенковкой и/или цековкой

Для отверстия с зенковкой и/или цековкой кроме общих для всех типов параметров задаются параметры для настройки зенковки и/или цековки.

Для отверстия с зенковкой выберите способ определения параметров зенковки из списка Способ (см. табл 2.3.15) и задайте их значения.

Табл. 2.3.15. Способ определения параметров зенковки
Значение опции Способ | Правила построения
По диаметру и углу | Поверхность зенковки определяется диаметром зенковки и углом конуса зенковки. Задайте значение диаметра зенковки в поле Диаметр зенковки. Задайте или выберите значение угла конуса зенковки из списка Угол зенковки.
По глубине и углу | Поверхность зенковки определяется глубиной зенковки и углом конуса зенковки. Задайте значение глубины зенковки в поле Глубина зенковки. Задайте или выберите значение угла конуса зенковки из списка Угол зенковки.
По диаметру и глубине | Поверхность зенковки определяется диаметром зенковки и глубиной зенковки. Задайте значение диаметра в поле Диаметр зенковки. Задайте значение глубины зенковки в поле Глубина зенковки.

– Для отверстия с цековкой:

• задайте диаметр цековки в поле Диаметр цековки,

• задайте глубину цековки в поле Глубина цековки.

– Для отверстия с зенковкой и цековкой:

• задайте общий диаметр цековки/зенковки в поле Диаметр цековки/зенковки,

• задайте глубину цековки в поле Глубина цековки,

• задайте угол конуса зенковки в поле Угол зенковки.

Все изменения размеров отображаются на фантоме отверстия.


2.3.9.1.3. Параметры конического отверстия

Для конического отверстия кроме общих для всех типов параметров задаются параметры для настройки конической формы. Доступно два способа задания параметров. В каждом из способов коническая форма отверстия достигается увеличением диаметра верхнего основания конуса, (диаметр, который проходит через точку привязки отверстия). Диаметр нижнего основания конуса всегда равен значению, заданному в поле Диаметр.

После задания диаметра нижнего основания конуса и глубины отверстия выберите способ задания параметров конического отверстия из списка Способ и задайте их значения (см. табл. 2.3.16).

Табл. 2.3.16. Способ определения параметров конического отверстия
Значение опции Способ | Правила построения
По диаметру верхнего основания конуса | Поверхность отверстия определяется диаметром верхнего основания конуса. Задайте диаметр верхнего основания конуса в поле Диаметр основания.
По углу конуса | Поверхность отверстия определяется углом конуса. Задайте угол конуса в поле Угол конуса.


2.3.9.1.4. Создание резьбового отверстия

Круглое отверстие любого типа может быть резьбовым. В этом случае при создании отверстия вместе с ним формируется условное изображение резьбы; диаметр отверстия определяется параметрами резьбы — номинальным диаметром и шагом. Резьба может быть как стандартной, так и нестандартной.

Для создания резьбового отверстия выполните следующие действия.

1. Выберите стандарт резьбы из списка Резьба. В списке содержатся наименования стандартных резьб и строка Нестандартная резьба.

На Панели свойств появляются элементы управления для задания параметров резьбы.

2. Задайте параметры резьбы.

Параметры резьбы можно задать следующими способами.

– Способ 1

• Для нестандартной резьбы введите или выберите из списка значение номинального диаметра резьбы в поле Диаметр резьбы, значение шага — в поле Шаг резьбы.

• Для стандартной резьбы значение шага устанавливается автоматически при выборе диаметра. Если в списке Шаг резьбы находится несколько значений шага, вы можете сменить автоматически установленное значение.

– Способ 2 (для стандартной резьбы).

• Нажмите кнопку Выбор параметров стандартной резьбы. На экране появляется диалог Выбор параметров стандартной резьбы.

В списке Стандарт диалога отображается наименование выбранного стандарта резьбы. При необходимости из этого списка можно выбрать другой стандарт резьбы.

Ниже, в таблице находятся значения номинального диаметра резьбы, шага резьбы и других определяемых стандартом параметров резьбы.

• Выберите из таблицы нужную строку и нажмите кнопку OK. На Панели свойств в поле Диаметр резьбы отобразится значение номинального диаметра резьбы, а в поле Шаг резьбы — значение шага резьбы, находящиеся в выбранной строке.

3. Выберите способ задания длины резьбы в группе переключателей Длина резьбы.

Доступны следующие способы.

– На заданную глубину: длина резьбы определяется заданным расстоянием. Введите значение длины резьбы в поле Длина резьбы.

Объектом, от которого отсчитывается это расстояние, является (рис. 2.3.55):

• для отверстий, имеющих цековку — нижняя граница поверхности цековки,

• для остальных отверстий — поверхность размещения отверстия.

Рис. 2.3.55. Начальная граница резьбы для разных типов отверстий

– На всю глубину: длина резьбы определяется автоматически по глубине отверстия.

При необходимости можно изменить автоматически определенную конечную границу резьбы. Для этого активизируйте переключатель Конечная граница, затем укажите в окне модели или в Дереве построения поверхность, грань или плоскость, до которой нужно построить резьбу.

Условное изображение резьбы отображается на фантоме отверстия.

В коническом отверстии стандартная резьба может быть построена только на заданную глубину. При этом максимальная глубина зависит от размеров отверстия и определяется стандартом.

Таблицы стандартных резьб

Таблицы параметров стандартных резьб располагаются в папке, путь к которой задается системной переменной Thread (см. раздел 9.5.4) системы КОМПАС-3D. По умолчанию это подпапка ...Sys\Thread главной папки системы.

Настройка списка таблиц стандартных резьб и их подключение выполняется в диалоге Параметры резьбы (см. раздел 9.1.6.1). В комплект поставки системы КОМПАС-3D входят таблицы метрических, трубных, упорной и трапецеидальной резьб.

Указанные таблицы содержат параметры стандартных резьб. Используйте их в качестве образца для создания собственных таблиц резьб.

При создании условного изображения резьбы в модели с помощью таблиц резьб связь модели с файлом таблиц резьб не формируется.


2.3.9.1.5. Задание формы торца отверстия

При построении отверстия его дну можно придать определенную форму.

Раскройте список Форма торца и выберите нужный вариант:

– Конический торец,

– Плоский торец,

– Сферический торец.

Для конического торца задайте значение угла конуса в поле Угол конуса торца.


2.3.9.1.6. Размещение отверстия на поверхности

Размещение отверстия на поверхности можно задать рядом параметров. Для этого активизируйте вкладку Размещение. На Панели свойств появляются элементы управления для задания положения отверстия на поверхности, ориентации его оси и направления построения.

Положение на поверхности

При нажатой кнопке Поверхность укажите в окне модели поверхность для размещения отверстия. В поле Поверхность размещения отобразится название выбранного объекта. Размещение точки привязки отверстия на выбранной поверхности аналогично построению точки на поверхности (см. раздел 2.5.2.6).

Направление оси отверстия

По умолчанию ось отверстия перпендикулярна к поверхности размещения. Вы можете изменить направление оси отверстия. Для этого отключите опцию Перпендикулярно поверхности.

Существует несколько способов изменения направления оси отверстия:

– Наклон и поворот оси отверстия относительно умолчательного положения.

Чтобы наклонить ось отверстия, задайте в поле Угол наклона значение угла наклона.

Чтобы повернуть ось отверстия, задайте в поле Угол поворота значение угла поворота.

– Задание направляющего объекта.

Активизируйте переключатель Направление оси и укажите в окне или в Дереве построения направляющий объект. Направляющим объектом может быть существующий прямолинейный, плоский объект или поверхность вращения (кроме сферы). Прямолинейный объект задает направление параллельно себе, плоский объект — перпендикулярно своей плоскости, а поверхность вращения — параллельно своей оси. Список прямолинейных и плоских объектов представлен в таблице 2.1.7.

– Создание направляющего вектора.

Направление оси отверстия будет совпадать с направлением вектора.

Для построения направляющего вектора нажмите кнопку Построение вектора на Панели специального управления. Подробно о построении направляющего вектора рассказано в разделе 2.8.5.

Направление построения

Направление построения отверстия можно задать с помощью группы переключателей Направление построения. По умолчанию отверстие строится внутрь относительно поверхности, на которой оно располагается. Это — Прямое направление. Чтобы изменить направление построения, активизируйте переключатель Обратное направление.

Удаление части тела над отверстием (обработка «навеса»)

В некоторых случаях тело, в котором создается отверстие, образует над ним «навес». «Навес» можно удалить, продлив поверхность отверстия в направлении, противоположном направлению построения отверстия. Для этого служит опция Обрабатывать «навес» рис. 2.3.56.

Рис. 2.3.56. Построение отверстия с зенковкой: а) опция Обрабатывать навес отключена; б) опция Обрабатывать навес включена
а) | б)

Обратите внимание на то, что если в результате построения отверстия не образуется новая грань непосредственно над ним, материал тела не удаляется, так как в этом случае считается, что «навеса» нет (рис. 2.3.57).

Рис. 2.3.57. Положение отверстия в модели: а) «навеса» нет, б) «навес» есть
а) | б)


2.3.9.1.7. Создание отверстия по образцу

Для построения отверстия можно использовать параметры отверстия-образца.

На Панели специального управления нажмите кнопку Отверстие по образцу (на Панели свойств должна быть активна вкладка Параметры). Укажите в модели или в Дереве построения отверстие для копирования параметров. Создаваемое отверстие получает те же параметры, что и отверстие-образец. Отредактируйте параметры, если это необходимо. Если положение отверстия еще не определено, задайте его.


2.3.9.2. Отверстие из библиотеки

Чтобы создать круглое отверстие с использованием библиотеки отверстий, выделите плоский объект, на котором оно должно расположиться (перечень плоских объектов представлен в таблице 2.1.7). Затем вызовите команду Отверстие из библиотеки.

Рис. 2.3.58. Панель свойств отверстия

После вызова команды на Панели свойств появятся элементы управления для выбора профиля отверстия и ввода его геометрических размеров (рис. 2.3.58).

Выберите из списка тип (форму) отверстия. Эскиз профиля выбранного типа отверстия отображается в окне просмотра снизу от списка типов.

Этот эскиз — параметрический. Параметры отверстия управляются значениями соответствующих им размеров в эскизе. Список переменных параметров отверстия отображается ниже окна просмотра.

Чтобы изменить какой-либо параметр отверстия, введите нужное значение в соответствующее поле таблицы параметров.

Не все значения размеров можно менять в произвольном порядке. Например, нельзя сделать диаметр резьбы больше номинального диаметра отверстия. Если требуется увеличить диаметр отверстия, сначала измените номинальный диаметр, а затем — диаметр резьбы.

Введите нужные значения всех параметров отверстия.

Если среди параметров выбранного отверстия в эскизе есть общая глубина H, становятся доступными переключатели группы Способ построения. Они позволяют указать, каким способом определяется глубина отверстия).

Если активизирован переключатель На глубину, то глубина отверстия будет равна заданному в списке параметров значению.

Если активизирован переключатель До вершины или Через все, то параметр H исчезает из списка параметров, а глубина отверстия определяется автоматически. Принцип автоматического определения глубины такой же, как при вырезании элемента выдавливания.

Если активизирован переключатель До вершины, требуется указать эту вершину.

Фантом отверстия с заданными параметрами отображается в окне детали. Точка привязки отверстия (она помечена на эскизе красным цветом) по умолчанию располагается в начале локальной системы координат грани, на которой создается это отверстие.

Чтобы разместить отверстие в нужном месте грани, расфиксируйте поля ввода координат точки привязки. Для этого щелкните мышью по полю т. Перекрестие в этом поле сменится «галочкой». Укажите положение отверстия мышью или введите координаты центра отверстия.

Если вы работаете с многотельной деталью, то кроме настройки параметров может понадобиться задание области применения операции. Для этого служит вкладка Панели свойств Результат операции. Подробно об области применения операций и способах ее задания рассказано в разделе 2.3.10.3.

После задания всех параметров отверстия нажмите кнопку Создать объект на Панели специального управления.

Деталь с отверстием на указанной грани будет показана в окне, а пиктограмма отверстия появится в Дереве построения.

Если отверстие полностью пересекает тело, то результатом построения будет тело, состоящее из нескольких частей (см. раздел 2.3.11).

Вы можете создать собственную библиотеку отверстий или дополнить системную библиотеку отверстий (см. раздел 11.3.4.3).


2.3.10. Область применения операции

2.3. Тела

2.3.10. Область применения операции

В этом разделе:

2.3.10.1. Общие сведения

2.3.10.2. Общий порядок задания области применения операции

2.3.10.3. Область применения «Тела»

2.3.10.3.1. Задание области применения «Тела» для операций добавления материала

2.3.10.3.2. Задание области применения «Тела» для операций удаления материала

2.3.10.3.3. Способы определения области применения «Тела»

2.3.10.4. Область применения «Компоненты»

2.3.10.4.1. Задание области применения «Компоненты»

2.3.10.4.2. Формирование области применения «Компоненты» вручную


2.3.10.1. Общие сведения

Область применения операции — набор объектов, которые модифицируются в результате операции. Область применения операции могут составлять имеющиеся в модели тела, или компоненты, или то и другое.

При добавлении материала модели (например, при приклеивании формообразующих элементов) область применения определяет объекты, с которыми будет объединен создаваемый (редактируемый) элемент, а при удалении (например, при вырезании формообразующих элементов) — объекты, материал которых будет удален в результате операции.

Допустим, в модели имеется три тела. На верхней грани тела 1 создан эскиз для операции выдавливания — окружность (рис. 2.3.59, а). Способ определения глубины выдавливания — Через все. В область применения операции могут входить любые из этих тел в любом сочетании. Допустим, область применения составляют тела 1 и 3.

Рис. 2.3.59. Область применения операции выдавливания: а) исходное состояние детали и эскиз операции, б) результат вырезания, в) результат приклеивания
а) | б) | в)

– Если элемент выдавливания вырезается, то в результате операции отверстие появится только в телах 1 и 3 (рис. 2.3.59, б). Несмотря на то что элемент выдавливания проходит через тело 2, оно остается целым, поскольку не включено в область применения операции.

– Если элемент выдавливания приклеивается, то получится новое тело, состоящее из тел 1 и 3 и элемента выдавливания (рис. 2.3.59, в). Несмотря на то что элемент выдавливания проходит через тело 2, оно остается самостоятельным, поскольку не включено в область применения операции выдавливания.


2.3.10.2. Общий порядок задания области применения операции

Задание области применения операции включает следующие действия.

1. Выбор типа области применения. Для этого служит группа переключателей Область применения. Она появляется на вкладке Параметры Панели свойств при выполнении операций добавления или удаления материала модели (рис. 2.3.60).

• Активизируйте переключатель Область применения «Компоненты и тела», чтобы действие операции распространялось на компоненты, включенные в модель, и на тела, созданные в модели.

• Активизируйте переключатель Область применения «Компоненты», чтобы действие операции распространялось только на компоненты, включенные в модель.

• Активизируйте переключатель Область применения «Тела», чтобы действие операции распространялось только на тела, созданные в модели.

2. Определение области применения выбранного типа — указание объектов, составляющих область применения.

Определение области применения «Тела» описано в разделе 2.3.10.3, определение области применения «Компоненты» — в разделе 2.3.10.4. Если выбрана область применения «Компоненты и тела», то определение области применения выполняется для объектов каждого типа, как описано в указанных выше разделах.

Рис. 2.3.60. Панель свойств при построении круглого отверстия из библиотеки

При работе со сборкой (*.a3d) в операциях удаления материала по умолчанию включено использование области применения «Компоненты и тела», а в операциях добавления материала — «Тела». При работе с деталью (*.m3d) операции обоих типов по умолчанию имеют область применения «Компоненты и тела».

Умолчательный способ определения областей применения «Компоненты» и «Тела» для всех операций удаления материала, кроме отсечения поверхностью и по эскизу, — Автоопределение. Для операций отсечения поверхностью и по эскизу умолчательный способ определения области применения «Компоненты» — Все компоненты, а области применения «Тела» — Автоопределение.


2.3.10.3. Область применения «Тела»

По умолчанию область применения «Тела» определяется автоматически: в нее включаются все видимые (не скрытые и не исключенные из расчета) тела, с которыми пересекается элемент, являющийся результатом операции (до завершения операции он показывается в виде фантома).

Таким образом, если вы работаете с пересекающимися телами, то те из них, которые не должны входить в область применения выполняемых операций, рекомендуется скрыть.

В примерах, приведенных на рисунке 2.3.59, результатом вырезания с автоопределением области применения были бы отверстия во всех трех телах, а результатом приклеивания — одно тело, образованное телами 1, 2, 3 и выдавленным элементом.

При необходимости область применения любой операции можно настроить вручную, включив в нее или все видимые тела, или произвольный набор тел.

Подробно о способах определения области применения операции рассказано в разделе 2.3.10.3.3.

Набор тел, составляющих область применения операции, остается неизменным. Включение отображения тел, которые были скрыты в момент выполнения операции, а также «перетаскивание» тел в Дереве построения не приводят к изменению области применения. Благодаря этому возможно моделирование деталей путем вычитания одного тела из другого.

Например, нужно построить деталь с полостью сложной формы. Для этого можно действовать следующим образом.

1. Создать первое тело — тело, которое будет определять форму детали, и скрыть его.

2. Создать второе тело — тело, которое будет определять форму полости. Выполняя операции, используйте умолчательный способ определения области применения — автоопределение. При этом в область применения всех операций будет входить только второе тело.

3. Включить показ первого тела. При этом область применения второго тела не изменится. Другими словами, все операции, выполненные в п.2, в том числе, например, операции вырезания Через все, будут по-прежнему относиться только ко второму телу.

4. Выполнить булеву операцию вычитания второго тела из первого.

Чтобы включить в область применения операции новые тела или исключить из нее имеющиеся, необходимо войти в режим редактирования этой операции и изменить область ее применения с помощью элементов управления Панели свойств. Эти элементы и приемы работы с ними описаны в следующих разделах.

В этом разделе:

2.3.10.3.1. Задание области применения «Тела» для операций добавления материала

2.3.10.3.2. Задание области применения «Тела» для операций удаления материала

2.3.10.3.3. Способы определения области применения «Тела»


2.3.10.3.1. Задание области применения «Тела» для операций добавления материала

При выполнении в модели операции добавления материала область применения «Тела» задается на вкладке Результат операции Панели свойств (рис. 2.3.61).

Рис. 2.3.61. Задание области применения «Тела»
для приклеиваемого элемента выдавливания

Умолчательный способ определения области применения операции — автоопределение. При этом активен переключатель Автообъединение в группе Результат операции.

Если необходимо, вы можете настроить область применения операции произвольным образом. Для этого активизируйте переключатель Объединение. На Панели свойств станет доступной группа элементов Тела.

Подробно о способах определения области применения операции рассказано в разделе 2.3.10.3.3.


2.3.10.3.2. Задание области применения «Тела» для операций удаления материала

– При вырезании формообразующих элементов область применения «Тела» задается на вкладке Вырезание Панели свойств (рис. 2.3.62).

– При построении круглого отверстия, а также при рассечении модели поверхностью или по эскизу область применения «Тела» задается на вкладке Результат операции Панели свойств (рис. 2.3.63).

Рис. 2.3.62. Задание области применения «Тела» для вырезаемого элемента выдавливания

Рис. 2.3.63. Задание области применения «Тела» для отверстия из библиотеки

Умолчательный способ определения области применения операции — автоопределение. При этом активен переключатель Автоопределение.

Если необходимо, вы можете настроить область применения операции произвольным образом. Для этого отключите переключатель Автоопределение. На Панели свойств станет доступной группа элементов Тела.

Подробно о способах определения области применения операции рассказано в разделе 2.3.10.3.3.


2.3.10.3.3. Способы определения области применения «Тела»

Автоопределение области применения означает, что в нее включаются все тела, кроме скрытых и исключенных из расчетов, с которыми пересекается элемент, являющийся результатом операции.

– При добавлении материала автоопределение области применения производится, если активен переключатель Автообъединение. В случае отсутствия пересечений создаваемого элемента с другими телами данный элемент создается как самостоятельное тело.

При этом на вкладке Результат операции активизируется переключатель Новое тело.

– При удалении материала автоопределение области применения производится, если активен переключатель Автоопределение. В случае отсутствия пересечений создаваемого элемента с другими телами в модели возникает ошибка.

Автоматическое определение области применения операции в некотором роде предпочтительнее других способов задания области применения, так как в последнем случае в нее можно случайно включить тела, не имеющие пересечений с редактируемым элементом. В этом случае элемент нельзя будет создать. Дело в том, что выполнение операции возможно только при условии, что элемент, являющийся результатом операции, действительно пересекается с телами, составляющими ее область применения. Если элемент не пересекается хотя бы с одним из тел, входящих в область применения операции, в модели возникает ошибка «Объекты не пересекаются».

При отключенном автоопределении области применения операции становится доступной группа элементов Тела. Она содержит два переключателя: Все тела и Выбор тел.

– Переключатель Все тела позволяет включить в область применения операции все тела, кроме скрытых и исключенных из расчета, вне зависимости от того, пересекаются они с редактируемым элементом или нет.

– Переключатель Выбор тел позволяет вручную указать тела, которые должны входить в область применения текущей операции. После активизации этого переключателя становится доступной панель Список тел. Она содержит перечень тел, включенных в область применения операции, и две кнопки: Выбрать все и Удалить. Для ручного добавления тел в область применения их следует указать в окне модели или в Дереве построения.

Кнопка Выбрать все позволяет включить в область применения операции все построенные в модели тела, в том числе скрытые тела и тела, непересекающиеся с редактируемым элементом.

Кнопка Удалить позволяет исключить тело из области применения.

Использование переключателей Автообъединение, Автоопределение и Все тела имеет следующую особенность. Если активен один из этих переключателей, то при создании элемента автоматически формируется перечень тел, составляющих область его применения (т.е. тел, с которыми обнаружено пересечение во время выполнения операции). Этот перечень отображается на панели Список тел при редактировании элемента и доступен для изменения.

Результатом выполнения операции отсечения (плоскостью или по эскизу) при активном переключателе Автоопределение является рассечение тел, которые непосредственно пересекаются с поверхностью отсечения.

Если кроме отсекаемых частей тел должны быть удалены тела, целиком расположенные по ту же сторону поверхности отсечения, используйте переключатель Все тела или укажите тела вручную.


2.3.10.4. Область применения «Компоненты»

По умолчанию область применения «Компоненты» определяется автоматически: в нее включаются все компоненты, кроме скрытых и исключенных из расчета, с которыми пересекается элемент, являющийся результатом операции (он показан в окне модели в виде фантома).

При необходимости область применения любой операции можно настроить вручную, включив в нее или все компоненты модели, или все компоненты, кроме библиотечных, или произвольно выбранные компоненты.

Подробно о способах определения области применения «Компоненты» рассказано в разделах 2.3.10.4.1 и 2.3.10.4.2.

В этом разделе:

2.3.10.4.1. Задание области применения «Компоненты»

2.3.10.4.2. Формирование области применения «Компоненты» вручную


2.3.10.4.1. Задание области применения «Компоненты»

Чтобы во время выполнения операции в модели перейти в режим задания области применения «Компоненты», нажмите кнопку Область применения «Компоненты» на Панели специального управления (рис. 2.3.60).

На Панели свойств появятся элементы, позволяющие указать компоненты, к которым будет применена текущая операция (рис. 2.3.64).

Рис. 2.3.64. Элементы управления областью применения «Компоненты»

– Чтобы область применения операции была определена автоматически, активизируйте переключатель Автоопределение. В область применения будут включены все компоненты, кроме скрытых и исключенных из расчета, с которыми пересекается элемент, являющийся результатом операции (он показан в окне модели в виде фантома).

Особенность автоматического определения области применения состоит в том, что при создании элемента автоматически формируется перечень компонентов, с которыми во время выполнения операции обнаружено пересечение. Этот перечень отображается на панели Список тел при редактировании элемента и доступен для изменения.

– Чтобы настроить область применения операции произвольным образом, отключите переключатель Автоопределение. На Панели свойств станет доступной группа элементов Область применения.

• Активизация переключателя Все компоненты означает, что в модели будут найдены и включены в область применения операции компоненты, которые пересекаются с редактируемым элементом. Однако, в отличие от автоопределения области применения, список компонентов не создается. В дальнейшем, при добавлении в модель новых компонентов или перемещении имеющихся, область применения операции будет определена заново, и после перестроения модели форма компонентов, вошедших в область применения операции, изменится.

• Активизация переключателя Все компоненты, кроме библиотечных означает аналогичный вышеописанному порядок определения области применения, но с исключением объектов, вставленных из прикладных библиотек (например, крепежных элементов из Справочника Стандартные Изделия).

• Активизация переключателя Выбор компонентов позволяет вручную указать компоненты, участвующие в операции. Для выбора компонентов служит панель Список компонентов (см. раздел 2.3.10.4.2). Область применения операции, заданная таким способом, не изменяется при добавлении или перемещении компонентов. Чтобы исключить какие-либо компоненты из области применения операции или добавить в нее какие-либо компоненты, необходимо отредактировать эту операцию, изменив ранее созданный список компонентов.

Задав область применения, нажмите кнопку Создать объект на Панели специального управления. Система вернется в режим выполнения операции, для которой производилась настройка области применения «Компоненты».


2.3.10.4.2. Формирование области применения «Компоненты» вручную

Для задания области применения «Компоненты» вручную используется панель Список компонентов (рис. 2.3.65). Эта панель доступна, если активизирован переключатель Выбор компонентов.

Рис. 2.3.65. Панель Список компонентов

Вы можете указывать любые компоненты модели:

– детали,

– подсборки,

– библиотечные компоненты,

– копии компонентов в составе экземпляров массивов.

Компоненты можно выбирать мышью в Дереве построения или в окне модели. Выбранные компоненты подсвечиваются, а их названия добавляются на панель Список компонентов. Повторный выбор компонента исключает его из области применения операции. Если требуется исключить из области применения сразу все включенные в нее компоненты, щелкните мышью в любом свободном месте окна модели.

Выделенная подсборка всегда включается в область применения операции вместе со всеми своими компонентами. Поэтому, если требуется включить в область применения лишь некоторые компоненты подсборки, то следует выбирать только их, следя за тем, чтобы сама подсборка не была выбрана.

Чтобы ускорить выбор компонентов, составляющих область применения операции, можно использовать кнопки, расположенные на панели Список компонентов.

После нажатия кнопки Выбрать все в область применения операции включаются все компоненты модели: детали, подсборки и копии компонентов, входящие в состав экземпляров массивов. Эту кнопку удобно применять, если в операции должно быть задействовано большинство компонентов.

После нажатия кнопки Выбрать все, кроме библиотечных в область применения операции включаются все компоненты модели, кроме вставленных из прикладных библиотек (*.rtw). При необходимости вы можете включить часть библиотечных объектов в область применения. Для этого укажите их мышью в Дереве построения.

Кнопка Удалить позволяет исключить из области применения компоненты, имена которых выделены в списке.

Обратите внимание на то, что объект, выделенный в списке, подсвечивается в окне модели. Это облегчает контроль правильности выбора компонентов.


2.3.11. Тела, состоящие из отдельных частей

2.3. Тела

2.3.11. Тела, состоящие из отдельных частей

Твердые тела в модели КОМПАС-3D могут состоять из нескольких не связанных между собой частей. Например, такое тело можно получить выдавливанием эскиза, содержащего несколько контуров.

Возможно также разделение тел на части в результате операции вырезания или отсечения. Например, вставив в деталь заготовку, можно вырезать из нее материал таким образом, чтобы остались только те части заготовки, которые требуются для построения детали.

В Дереве построения используются специальные значки, символизирующие наличие тел из нескольких частей (рис. 2.3.66):

– восклицательный знак на пиктограмме модели — признак того, что модель содержит тела, состоящие из отдельных частей,

– восклицательный знак на пиктограмме операции — признак того, что при выполнении операции запускался процесс изменения набора частей тела (см. раздел 2.3.11.1),

– разделенная на части пиктограмма тела — признак того, что тело состоит из отдельных частей.

Пиктограммы тел показываются в Дереве, если в нем включено отображение структуры модели (см. раздел 2.1.2.2).

Рис. 2.3.66. Дерево построения детали, содержащей тело из нескольких частей

Контекстное меню, вызванное в Дереве на пиктограмме модели или тела с признаком нескольких частей, а также контекстное меню, вызванное в окне модели с телами из частей, содержит команду Внимание. После вызова этой команды на экране появляется сообщение о наличии тел из нескольких частей.

Тела, состоящие из частей, можно сделать целыми, используя один из двух способов:

1. Изменить эскизы или параметры операций, которые формируют тела из частей, так, чтобы каждое тело содержало одну часть. В этом случае из Дерева построения исчезнут все признаки наличия нескольких частей тел.

2. Создать какие-либо новые элементы, соединяющие части тел. В этом случае из Дерева построения исчезнут только те признаки наличия частей, которые относятся к телам и к модели, а восклицательные знаки на пиктограммах операций останутся.

В листовом теле, состоящем из частей, невозможно создание новых сгибов, изменение состояния существующих, а также замыкание сгибов. Для того чтобы эти операции можно было выполнить, необходимо сделать тело целым.

В этом разделе:

2.3.11.1. Выбор частей, которые следует оставить

2.3.11.1.1. Особенности изменения количества частей тела


2.3.11.1. Выбор частей, которые следует оставить

Выбор частей тела (или тел), которые следует оставить, производится в процессе изменения набора частей. Этот процесс автоматически запускается после выполнения операции, которая приводит к созданию тела из нескольких частей.

Обратите внимание на то, что изменение набора частей возможно для тел, построенных в самой модели и невозможно для тел компонентов. То есть, если операция разделяет на части тела компонентов, то все эти части остаются.

По умолчанию после запуска процесса изменения набора частей на Панели свойств находится одна включенная опция Все. Это означает, что в модели останутся все получившиеся части тела. Части тела показываются в окне модели в виде фантомов.

Если требуется оставить не все, а лишь некоторые части тела, отключите опцию Все. На Панели свойств появится Список частей (рис. 2.3.67). Список представлен в виде таблицы, первая колонка которой содержит номер тела и части, а вторая — опцию Оставить.

Рис. 2.3.67. Выбор частей тела, которые следует оставить

Отключите опции тех частей, которые не будут использоваться, или укажите эти части в окне модели. Повторное указание части включает ее в число оставляемых.

Если нужно оставить или исключить большинство частей, воспользуйтесь кнопками Выбрать все части и Отменить выбор для всех частей, расположенными над списком.

Завершив выбор частей тела, нажмите кнопку Создать объект. Если не оставлено ни одной части, то кнопка недоступна.

Исключенные части тел как бы отсутствуют в модели: они не отображаются на экране, не могут использоваться при построении других объектов, не учитываются при вычислении МЦХ, не передаются в ассоциативные виды модели и в результирующие файлы при экспорте в другие форматы и т.д.

В то же время информация об исключенных частях тел не удаляется из файла модели, благодаря чему впоследствии набор частей можно изменить.

Процесс изменения набора частей запускается также и после редактирования операции, результатом которой является тело из нескольких частей (если только параметры операции не были изменены так, что получилось целое тело).

Пиктограмма операции, после выполнения или редактирования которой запускался процесс выбора частей, отмечается в Дереве восклицательным знаком. В контекстном меню этой операции присутствует команда Изменить набор частей (рис. 2.3.68). Она позволяет повторно запустить процесс выбора частей, получившихся в результате операции.

Рис. 2.3.68. Команда Изменить набор частей

В этом разделе:

2.3.11.1.1. Особенности изменения количества частей тела


2.3.11.1.1. Особенности изменения количества частей тела

1. Если для операции запускался процесс изменения набора частей, а впоследствии количество частей поменялось без запуска этого процесса, на экране появляется сообщение об изменении количества частей. Например, эскиз, содержащий несколько контуров, был выдавлен с уклоном наружу. В процессе изменения набора частей пользователь оставил только некоторые части тела. Затем в Окне переменных значение переменной, соответствующей углу уклона, было увеличено так, что какие-то из частей тела слились. После перестроения в окне модели отображаются все части тела и появляется сообщение об изменении количества частей. При необходимости запустите процесс изменения набора частей тела и выберите нужные части.

2. Операция отмечается восклицательным знаком только после запуска процесса изменения набора частей. В связи с этим может возникнуть следующая ситуация.
Первоначально результатом операции было целое тело. После редактирования какого-либо объекта модели результатом операции стало тело из нескольких частей. Модель и тело получают признак наличия нескольких частей, а операция — нет, так как процесс изменения набора частей не запускался. Для его запуска необходимо войти в режим редактирования операции, а затем подтвердить создание объекта.

Пример 1
В модели было выполнено выдавливание эскиза, содержащего один контур. Затем эскиз был отредактирован: в него добавили еще один контур. Сразу после выхода из режима эскиза элемент выдавливания в окне модели показывается состоящим из двух частей, но пиктограмма элемента выдавливания отображается в Дереве без восклицательного знака.

Пример 2
В модели имелся вырезанный элемент выдавливания, который удалял некоторый объем материала тела, но не разделял его на две части. Затем в Окне переменных значение переменной, которая соответствует глубине выдавливания, было увеличено так, что вырезанный элемент стал полностью пересекать тело. После перестроения тело в окне модели показывается состоящим из двух частей, но пиктограмма вырезанного элемента выдавливания отображается в Дереве без восклицательного знака.


2.3.12. Многотельное моделирование

2.3. Тела

2.3.12. Многотельное моделирование

Многотельное моделирование — процесс создания модели, включающий создание нескольких твердых тел.

Результатом многотельного моделирования может являться как одно тело, так и несколько тел (т.е. многотельная модель).

Каждое тело в процессе многотельного моделирования создается обычным образом. Над телами могут производиться булевы операции (см. раздел 2.3.7).

При выполнении операций в многотельной модели необходимо учитывать их область применения (см. раздел 2.3.10).

Для каждого тела можно задать параметры МЦХ (см. раздел 2.14.6), цвет и свойства поверхности (см. раздел 2.14.2).

Многотельное моделирование расширяет возможности построения модели и снимает ограничения на создание моделей, которые можно получить только объединением, вычитанием или пересечением тел. Например, используя многотельное моделирование, можно построить деталь путем объединения тонкостенных тел с разной толщиной стенки.

При необходимости построенные в модели тела можно сохранить как самостоятельные детали (см. раздел 2.11.2.3).

Обратите внимание на то, что тело не может быть отображено частично. Это означает, что нельзя скрыть или показать, например, отдельный приклеенный к телу элемент. Поэтому после вызова команды Скрыть или Показать для какого-либо элемента скрывается или показывается целиком все тело, в состав которого входит этот элемент.

В этом разделе:

2.3.12.1. Примеры использования многотельного моделирования

2.3.12.2. Отображение многотельной модели в Дереве построения


2.3.12.1. Примеры использования многотельного моделирования

В качестве наиболее типичных примеров использования многотельного моделирования являются проектирование «с нескольких сторон» и создание тел вычитанием.

Проектирование «с нескольких сторон» — способ проектирования, при котором отдельные части детали создаются как самостоятельные тела, а затем объединяются. При этом пересекающиеся тела можно объединить путем выполнения над ними булевой операции, а непересекающиеся — путем построения нового пересекающегося с ними тела.

Создание тел вычитанием — способ проектирования, при котором тело детали формируется путем вычитания одних тел из других. В этом случае нужно создать два пересекающихся тела, первое из которых будет определять форму детали, а второе — форму полости. Затем следует произвести над телами булеву операцию вычитания второго тела из первого. Данный способ проектирования рекомендуется для создания деталей со сложными карманами или другими выборками, проходящими через сложные поверхности и имеющими скругления.

Копирование результата булевой операции с помощью команд построения массивов невозможно. Поэтому, если в модели должно быть несколько одинаковых карманов или выборок, получаемых вычитанием, следует сначала создать копии тел для вычитания, а затем выполнить булеву операцию нужное количество раз.


2.3.12.2. Отображение многотельной модели в Дереве построения

Общее количество тел модели отображается в Дереве построения — в скобках после ее названия (рис. 2.3.69–2.3.71).

В Дереве построения модели отображается количество тел, созданных в этой модели. Количество тел в компонентах не указывается.

Дерево построения может отображаться в одном из двух видов: в виде последовательности построения или в виде структуры модели (см. разделы 2.1.2.1 и 2.1.2.2 соответственно). При работе с многотельной деталью можно рекомендовать отображение Дерева в виде структуры. Этот способ более наглядно представляет состав многотельной модели и порядок ее создания, чем отображение последовательности построения (рис. 2.3.69–2.3.71).

– Элементы, формирующие тела, группируются в разделы, соответствующие телам. Разделы имеют имена «Тело N», где N — порядковый номер тела (рис. 2.3.69, а).

Рис. 2.3.69. Многотельная деталь в Дереве: а) структура, б) последовательность построения
а) | б)

– Если в модели присутствует булева операция над телами, то она размещается в разделе, который соответствует первому из участвующих в ней тел. Второе тело, участвующее в этой булевой операции, отображается как подчиненное ей (рис. 2.3.70, а).

Рис. 2.3.70. Булева операция над телами детали: а) структура, б) последовательность построения
а) | б)

– Если в модели присутствует элемент, объединяющий несколько тел в одно, то он размещается в разделе, который соответствует первому из объединяемых тел. Остальные тела, объединяемые этим элементом, отображаются как подчиненные ему.

Объединяющие элементы обозначаются в Дереве специальными пиктограммами (рис. 2.3.71, а).

Рис. 2.3.71. Приклеенный элемент, объединяющий тела: а) структура, б) последовательность построения
а) | б)


2.4. Листовые тела

В этом разделе:

2.4.1. Общие сведения о листовых телах

2.4.1.1. Приемы работы с листовыми телами

2.4.1.2. Параметры листового тела

2.4.1.3. Переменные листового тела и работа с ними

2.4.1.3.1. Особенности работы с переменными листового тела

2.4.1.4. Длина развертки сгиба

2.4.1.4.1. Определение длины развертки при помощи коэффициента положения нейтрального слоя

2.4.1.4.2. Определение длины развертки способом задания величины сгиба

2.4.1.4.3. Определение длины развертки способом задания уменьшения сгиба

2.4.1.4.4. Таблицы сгибов

2.4.1.5. Фантомы

2.4.2. Листовое тело

2.4.2.1. Требования к эскизу

2.4.2.2. Построение листового тела

2.4.2.2.1. С замкнутым эскизом

2.4.2.2.2. С разомкнутым эскизом

2.4.3. Обечайки

2.4.3.1. Общие приемы построения

2.4.3.1.1. Параметры кромок оснований

2.4.3.1.2. Параметры кромок стыка и зазор

2.4.3.1.3. Смещение зазора

2.4.3.2. Обечайка

2.4.3.2.1. Требования к эскизу обечайки

2.4.3.2.2. Параметры обечайки

2.4.3.2.3. Сегментация

2.4.3.3. Линейчатая обечайка

2.4.3.3.1. Требования к эскизам

2.4.3.3.2. Параметры линейчатой обечайки

2.4.4. Сгибы

2.4.4.1. Термины и определения

2.4.4.2. Отображение сгибов в Дереве построения модели

2.4.4.3. Общие приемы построения сгибов

2.4.4.3.1. Направление отсчета и интерпретация значения угла

2.4.4.3.2. Радиус сгиба

2.4.4.3.3. Освобождение угла

2.4.4.3.4. Состояние сгибов

2.4.4.3.5. Настройка определения длины развертки

2.4.4.3.6. Редактирование параметров сгиба

2.4.4.4. Сгиб

2.4.4.4.1. Размещение сгиба

2.4.4.4.2. Продолжение сгиба

2.4.4.4.3. Смещение сгиба

2.4.4.4.4. Боковые стороны

2.4.4.4.5. Освобождение сгиба

2.4.4.5. Сгиб по линии

2.4.4.5.1. Исходные объекты и результат построения

2.4.4.5.2. Неподвижная сторона сгиба

2.4.4.5.3. Способ формирования сгиба

2.4.4.6. Подсечка

2.4.4.6.1. Исходные объекты и результат построения

2.4.4.6.2. Размер подсечки

2.4.4.6.3. Подсечка с добавлением материала и подсечка без добавления материала

2.4.4.6.4. Плоский участок подсечки

2.4.4.7. Замыкание углов

2.4.4.7.1. Способы замыкания

2.4.4.7.2. Обработка угла

2.4.4.7.3. Зазор

2.4.4.7.4. Продолжение замыкания

2.4.4.7.5. Принцип построения замыкания встык и плотного замыкания

2.4.4.7.6. Принцип построения замыкания с перекрытием

2.4.4.7.7. Выполнение замыкания

2.4.4.8. Сгиб по эскизу

2.4.4.8.1. Требования к эскизу

2.4.4.8.2. Способ построения

2.4.4.8.3. Замыкание углов

2.4.4.8.4. Освобождение

2.4.5. Пластины

2.4.5.1. Требования к эскизу пластины

2.4.5.2. Формирование пластины

2.4.6. Отверстия

2.4.6.1. Отверстие

2.4.6.2. Вырез

2.4.6.2.1. Требования к эскизу

2.4.6.2.2. Формирование выреза

2.4.7. Разгибание и сгибание сгибов. Развертка

2.4.7.1. Разгибание и сгибание

2.4.7.1.1. Неподвижная грань или плоскость

2.4.7.1.2. Выбор сгибов

2.4.7.2. Развертка

2.4.7.2.1. Параметры развертки

2.4.7.2.2. Ориентация Развертка

2.4.7.2.3. Удаление параметров развертки

2.4.7.3. Особенности разгибания и сгибания

2.4.7.4. Чертеж развертки

2.4.8. Штамповочные элементы

2.4.8.1. Общие приемы построения

2.4.8.1.1. Направление построения

2.4.8.1.2. Скругление ребер основания

2.4.8.1.3. Сохранение настроек

2.4.8.2. Штамповка

2.4.8.2.1. Профиль штамповки

2.4.8.2.2. Неподвижная сторона

2.4.8.2.3. Высота

2.4.8.2.4. Боковые стенки

2.4.8.2.5. Скругление боковых ребер

2.4.8.2.6. Скругление ребер дна

2.4.8.3. Буртик

2.4.8.3.1. Требования к эскизу

2.4.8.3.2. Обработка концов

2.4.8.3.3. Просмотр образца

2.4.8.3.4. Способ построения

2.4.8.4. Жалюзи

2.4.8.4.1. Требования к эскизу

2.4.8.4.2. Высота

2.4.8.4.3. Ширина

2.4.8.4.4. Способ построения


2.4.1. Общие сведения о листовых телах

2.4. Листовые тела

2.4.1. Общие сведения о листовых телах

В КОМПАС-3D возможно моделирование деталей, получаемых из листового материала с помощью гибки.

Команды, предназначенные для работы с листовыми телами, расположены в меню Операции, а кнопки для их вызова находятся на панели Элементы листового тела (рис. 2.4.1).

Рис. 2.4.1. Панель Элементы листового тела

Создание листового тела начинается с построения первого листового элемента. Для этого можно использовать команду Листовое тело (см. раздел 2.4.2), Обечайка (см. раздел 2.4.3.2) или Линейчатая обечайка (см. раздел 2.4.3.3).

Затем к полученному телу добавляются другие листовые элементы: сгибы, пластины, отверстия, вырезы и т.д.

Обратите внимание на то, что добавление листовых элементов возможно только к листовому телу, построенному в самой модели, а не в каком-либо из ее компонентов.

В листовом теле возможно создание и «не листовых» элементов. Так, к нему можно приклеивать формообразующие элементы любого типа — выдавливания, вращения, кинематические, по сечениям, и вырезать формообразующие элементы из листового тела. Кроме того, к листовому телу можно добавлять конструктивные элементы (скругления, фаски, ребра, отверстия и т.п.). К листовому телу (первому листовому элементу), пластинам, отверстиям и вырезам можно применять также любые операции копирования.

Рис. 2.4.2. Пример детали из листового материала

Одна модель может содержать одно или несколько листовых тел. Подробно о многотельном моделировании см. раздел 2.3.11. Если листовых тел в модели несколько, они могут быть одинаковой или разной толщины.

В этом разделе:

2.4.1.1. Приемы работы с листовыми телами

2.4.1.2. Параметры листового тела

2.4.1.3. Переменные листового тела и работа с ними

2.4.1.3.1. Особенности работы с переменными листового тела

2.4.1.4. Длина развертки сгиба

2.4.1.4.1. Определение длины развертки при помощи коэффициента положения нейтрального слоя

2.4.1.4.2. Определение длины развертки способом задания величины сгиба

2.4.1.4.3. Определение длины развертки способом задания уменьшения сгиба

2.4.1.4.4. Таблицы сгибов

2.4.1.5. Фантомы


2.4.1.1. Приемы работы с листовыми телами

Любой сгиб, имеющийся в листовом теле, может отображаться как в согнутом, так и в разогнутом состоянии. Пользователь может в любой момент изменить состояние любого сгиба (или группы сгибов).

При работе с листовым телом есть возможность отображения ее развертки. Это специальный режим отображения, в котором выбранные пользователем сгибы показываются согнутыми, а остальные — разогнутыми. Если не выбран ни один сгиб, то в этом режиме отображается полностью развернутая листовое тело. Переход в режим развертки возможен после настройки параметров развертки.

Ассоциативные виды модели, содержащей листовое тело, создаются в чертеже так же, как и ассоциативные виды обычной модели. При этом, если для листового тела настроены параметры развертки, то в чертеже возможно формирование изображения развертки этого тела.

Если в одной модели имеется несколько пересекающихся листовых тел, то для их объединения, вычитания или пересечения используйте команду Булева операция (см. раздел 2.3.7).

Штамповочные элементы, а также элементы, содержащие сгибы, могут быть созданы только на тех участках листового тела, которые имеют постоянную толщину (листовое тело переменной толщины может образоваться, например, в результате объединения двух тел с разной толщиной).

Обратите внимание на то, что выполнение в листовом теле «не листовых» операций может ограничить или сделать невозможным применение функционала для работы с листовыми телами:

– Некоторые формообразующие и дополнительные конструктивные элементы могут воспрепятствовать изменению состояния сгибов (см. раздел 2.4.7.3).

– Операции вырезания и отсечения могут приводить к разделению листового тела на части. В листовом теле, состоящем из частей, невозможно создание новых сгибов, изменение состояния существующих, замыкание сгибов, а также построение вырезов и отверстий способом По толщине. Для того чтобы эти операции можно было выполнить, необходимо сделать тело целым.

– Листовое тело, к которому применена операция масштабирования, перестает быть листовым: добавление к нему каких-либо листовых элементов и изменение состояния сгибов становится невозможным.


2.4.1.2. Параметры листового тела

Листовое тело характеризуется толщиной материала (S), из которого оно изготовлено.

Изогнутые участки (сгибы) тела определяются:

– внутренним радиусом (R),

– углом сгиба (a),

– шириной освобождения (W),

– глубиной освобождения (H).

Рис. 2.4.3. Параметры листового тела

Сгиб может и не иметь освобождений.

Кроме того, каждый сгиб имеет параметр, определяющий длину развертки этого сгиба. Таким параметром — в зависимости от выбранного способа определения длины развертки (см. раздел 2.4.1.4) — является коэффициент нейтрального слоя, или величина сгиба, или уменьшение сгиба. Параметр, определяющий длину развертки сгиба, далее будем называть параметром развертки этого сгиба.

Умолчательные значения параметров для всех новых листовых тел задаются в диалоге настройки свойств листового тела (см. раздел 9.2.7.4.8).

Для задания таких параметров операции, как толщина листа, ширина сгиба, уклон и других, можно использовать характерные точки (о характерных точках см. раздел 2.1.4.2.2).


2.4.1.3. Переменные листового тела и работа с ними

При создании в модели листового тела (см. раздел 2.4.2) в ней автоматически создаются переменные — переменные листового тела. Начальные значения переменных определяются настройкой (см. раздел 9.2.7.4.8).

Переменные листового тела и их текущие значения отображаются в Окне переменных (рис. 2.4.4):

– SM_Thickness — толщина листового материала,

– SМ_Radius — внутренний радиус сгиба,

– SM_Angle — угол сгиба,

– SM_BA — величина сгиба,

– SM_BD — уменьшение сгиба,

– SM_K — коэффициент положения нейтрального слоя,

– SM_H — глубина освобождения сгиба,

– SM_W — ширина освобождения сгиба,

Рис. 2.4.4. Переменные листового тела

По умолчанию при создании элемента Листовое тело и элементов, содержащих сгибы, предлагаются значения параметров, совпадающие со значениями соответствующих переменных. Если эти значения не изменяются вручную, то после создания элемента его параметрам автоматически приравниваются переменные:

– элемент Листовое тело:

• толщина = SM_Thickness;

– элементы, содержащие сгибы:

• внутренний радиус = SМ_Radius,

• угол сгиба = SM_Angle,

• глубина освобождения = SM_H,

• ширина освобождения = SM_W,

• величина сгиба = SM_BA,

• уменьшение сгиба = SM_BD,

• коэффициент нейтрального слоя = SM_K.

Новые значения переменных листового тела в текущей модели можно задать в Окне переменных.

Изменение значения переменной, используемой различными элементами, передается во все эти элементы. Таким образом можно быстро изменить размеры и топологию листового тела, не прибегая к редактированию каждого элемента в отдельности.

Например, параметру «радиус» во всех сгибах тела соответствует переменная SМ_Radius, а параметру «угол» — переменная SM_Angle. Первоначальные значения переменных — 3 и 90 (рис. 2.4.5).

Рис. 2.4.5. Первоначальные значения переменных и исходное состояние тела

В результате изменения значения переменной SМ_Radius на 1,5, а переменной SM_Angle на 70 все сгибы тела перестроились в соответствии с новыми значениями параметров (рис. 2.4.6).

Рис. 2.4.6. Новые значения переменных и перестроенное тело

Автоматически созданные переменные можно использовать в выражениях, определяющих значения других переменных и параметров, а также в эскизах.

Работа с переменными и выражениями подробно рассмотрена в разделе 7.1.

В этом разделе:

2.4.1.3.1. Особенности работы с переменными листового тела


2.4.1.3.1. Особенности работы с переменными листового тела

1. Имена переменных листового тела изменить невозможно.

2. Редактирование сгиба, параметрам которого автоматически приравнены переменные, путем изменения значения какого-либо параметра не влияет на значение соответствующей переменной. В результате такого редактирования параметру сгиба присваивается значение, введенное в соответствующее поле Панели свойств, а равенство значений параметра и переменной автоматически удаляется.

3. Если в результате редактирования сгиба его параметру возвращается значение, соответствующее переменной, то она автоматически приравнивается этому параметру.

4. Вы можете создать в модели листовые переменные (SM_Thickness, SМ_Radius, SM_Angle и т.д.) и присвоить им нужные значения еще до начала построения листового тела. Заданные значения передаются в диалог настройки параметров листового тела для текущей модели и используются при создании листовых элементов.

5. Сгибы, у которых отключено определение параметров по исходному объекту (см. раздел 2.4.4.3.6), отображаются в Окне переменных как самостоятельные элементы, подчиненные своему исходному объекту (рис. 2.4.7). Параметрами этих сгибов являются радиус и параметр развертки. Если значение параметра совпадает со значением соответствующей переменной, то она автоматически приравнивается этому параметру:

– радиусу — SМ_Radius,

– величине сгиба — SM_BA,

– уменьшению сгиба — SM_BD,

– коэффициенту нейтрального слоя — SM_K.

Рис. 2.4.7. Отображение сгибов в Окне переменных

Если длина развертки сгиба определяется по таблице, то параметр развертки этого сгиба отсутствует на панели Переменные.

Если сгиб принадлежит листовому телу с разомкнутым эскизом и соответствует дуге в эскизе листового тела, то параметр Радиус этого сгиба не показывается на панели Переменные. А если длина развертки такого сгиба определяется по таблице, то сгиб не отображается на панели Переменные.


2.4.1.4. Длина развертки сгиба

Длина развертки сгиба может быть определена одним из трех способов:

– задание коэффициента положения нейтрального слоя,

– задание величины сгиба,

– задание уменьшения сгиба.

Кроме того, возможно использование таблиц сгибов, т.е. извлечение параметра, определяющего длину развертки (величины сгиба, уменьшения сгиба или коэффициента нейтрального слоя), из таблицы.

Умолчательный способ определения длины развертки задается в диалоге настройки свойств листового тела для новых моделей. Для каждой конкретной модели умолчательный способ определения длины развертки может быть изменен в диалоге настройки свойств листового тела для текущей модели (о настройке умолчательных параметров листовых тел см. раздел 9.2.7.4.8).

Кроме того, возможен выбор способа определения длины развертки для каждого конкретного сгиба (см. раздел 2.4.4.3.5).

В этом разделе:

2.4.1.4.1. Определение длины развертки при помощи коэффициента положения нейтрального слоя

2.4.1.4.2. Определение длины развертки способом задания величины сгиба

2.4.1.4.3. Определение длины развертки способом задания уменьшения сгиба

2.4.1.4.4. Таблицы сгибов


2.4.1.4.1. Определение длины развертки при помощи коэффициента положения нейтрального слоя

2.4.1.4.1. Определение длины развертки
при помощи коэффициента положения нейтрального слоя

Длина развертки определяется исходя из предположения наличия в сгибе нейтрального слоя.

Нейтральный слой — слой материала тела, длина которого не изменяется при сгибании.

Линия пересечения нейтрального слоя сгиба с плоскостью, перпендикулярной линии сгиба, называется нейтральной линией (рис. 2.4.8).

Рис. 2.4.8. Сечение сгиба плоскостью, перпендикулярной линии сгиба
(нейтральная линия показана штрихами)

Длина развертки цилиндрической части сгиба находится как длина нейтральной линии в ней:

L = p · (R + K · S) ·(a/180) , где

L — длина нейтральной линии;

R — внутренний радиус сгиба;

S — толщина листового материала;

K — коэффициент положения нейтрального слоя;

a — угол сгиба.

Коэффициент К определяет положение нейтрального слоя:

K = t/S, где

t — расстояние от внутренней поверхности сгиба до нейтрального слоя.


2.4.1.4.2. Определение длины развертки способом задания величины сгиба

Длина развертки цилиндрической части сгиба BA (сокращение от Bend Allowance) задается пользователем. Полная длина развертки сгиба L при разгибании (рис. 2.4.9) рассчитывается по формуле:

L = A + BA + B.

Рис. 2.4.9. Разгибание сгиба: а) сгиб согнут, б) сгиб разогнут
а) | б)


2.4.1.4.3. Определение длины развертки способом задания уменьшения сгиба

Длина развертки цилиндрической части сгиба l рассчитывается по формуле:

l = 2 · a - BD, где

BD (сокращение от Bend Deduction) — уменьшение сгиба, задается пользователем;

а — геометрический параметр сгиба, определяется системой автоматически (табл. 2.4.1).

Табл. 2.4.1. Определение параметра а для различных углов сгиба a
a<90° | aі90°
a =(R + S) · tg(a/2) | a =(R + S)

Полная длина развертки L при разгибании (рис. 2.4.10) рассчитывается по формуле:

L = A' + B' - BD.

Рис. 2.4.10. Разгибание сгиба: а) сгиб согнут, б) сгиб разогнут
а) | б)

Для углов сгиба a>90° значение уменьшения сгиба BD может быть отрицательным.


2.4.1.4.4. Таблицы сгибов

При определении длины развертки с использованием способов, рассмотренных выше, значения параметра развертки (K, BA или BD) могут быть заданы — с учетом существующих ограничений — произвольно.

Зависимость параметра развертки от толщины материала, угла и радиуса сгиба может быть определена, например, экспериментальным путем и оформлена в виде таблиц. В системе КОМПАС они носят название таблиц сгибов и могут быть использованы для задания длин разверток.

В соответствии с содержанием таблицы определяется ее тип:

– таблица коэффициентов, определяющих положение нейтрального слоя;

– таблица величин сгиба;

– таблица уменьшений сгиба.

Таблицы сгибов хранятся в файлах с расширением loa.

В комплект поставки системы КОМПАС-3D входят четыре таблицы сгибов:

– две таблицы коэффициентов, определяющих положение нейтрального слоя:

• Sample1_K_factor.loa,

• Sample4_K_factor.loa,

– таблица величин сгибов Sample2_Bend_allowance.loa;

– таблица уменьшений сгибов Sample3_Bend_deduction.loa.

Указанные таблицы содержат условные данные и приведены в качестве примера. Используйте их в качестве образца для создания собственных таблиц сгибов.

Примеры таблиц сгибов находятся в папке, путь к которой задается системной переменной SHEETMETAL системы КОМПАС-3D. По умолчанию это подпапка ...\Sys\SHEETMETAL главной папки системы.

Использование таблиц сгибов

Чтобы использование определенной таблицы сгибов в листовых телах было возможно, необходимо предварительно указать файл этой таблицы в диалоге настройки параметров листового тела (см. раздел 9.2.7.4.8) или с помощью команды Операции — Элементы листового тела — Таблица сгибов — Выбрать.

Чтобы получить из таблицы параметр развертки для сгибов создаваемого или редактируемого листового элемента, выполните следующие действия:

1. На вкладке Параметры Панели свойств разверните список Способ определения длины развертки.

2. Выберите из списка строку Таблица сгибов.

В поле Файл-источник появится имя таблицы сгибов, выбранной при настройке свойств листового тела.

Если при настройке свойств листового тела была включена опция Таблица сгибов, то для определения длин разверток всех новых сгибов по умолчанию будет выбран способ Таблица сгибов. В этом случае производить описанные действия не нужно.

После ввода значений угла и радиуса сгиба из таблицы сгибов будет выбран параметр развертки, соответствующий этим значениям. Он будет использоваться при разгибании построенного листового элемента.

При создании в модели первого листового элемента, использующего таблицу сгибов, все данные из нее записываются в эту модель. Связь модели с файлом таблицы не формируется.

Все сгибы, параметр развертки которых извлекается из таблицы, будут использовать сохраненные внутри документа данные. Исходный файл таблицы может быть отредактирован или удален. Это не приведет к изменению параметров сгибов.

В модели может быть сохранена только одна таблица.

Смена таблицы сгибов

Чтобы использовать для сгибов, построенных с применением таблицы, данные из другого табличного файла, необходимо сменить хранящуюся в модели таблицу сгибов. Для этого выполните одно из следующих действий:

– вызовите команду Операции — Элементы листового тела — Таблица сгибов — Выбрать...,

– нажмите кнопку Обзор в диалоге настройки листового тела для текущей модели (см. раздел 9.2.7.4.8).

Смена таблицы сгибов приведет к изменению свойств всех элементов листового тела, параметр развертки которых извлекался из таблицы: значение этого параметра будет выбрано из новой таблицы. Пиктограммы измененных элементов в Дереве построения будут отмечены красными «галочками», означающими необходимость перестроения.

Таблицу сгибов, хранящуюся в модели, можно записать в файл. Для этого вызовите команду Операции — Элементы листового тела — Таблица сгибов — Сохранить как... В появившемся на экране стандартном диалоге Windows задайте имя файла для записи.

Таблица сгибов может быть удалена из модели. Чтобы удалить таблицу, вызовите команду Операции — Элементы листового тела — Таблица сгибов — Удалить. При этом у листовых элементов, построенных с использованием таблицы, автоматически изменится способ определения длины развертки. Он будет соответствовать типу использовавшейся таблицы сгибов. Значение параметра развертки останется равным табличному значению для текущего радиуса, угла сгиба и толщины материала.

Например, элемент был построен с использованием таблицы величин сгибов. После удаления таблицы для этого элемента будет выбран способ определения длины развертки Величина сгиба. Значение величины сгиба останется равным выбранному ранее из таблицы.

Модель может содержать элементы с автоматически определяемыми углами сгиба. К таким элементам относятся:

– листовое тело с разомкнутым эскизом (углы сгибов определяются параметрами объектов эскиза),

– подсечка, заданный размер которой меньше минимального (углы сгибов рассчитываются по формуле, см. табл. 2.4.10).

Если указанные элементы использовали таблицу сгибов, то при ее удалении обработка этих элементов производится следующим образом.

Способ определения длины развертки автоматически меняется на способ, соответствующий типу использовавшейся таблицы. Параметр развертки принимает умолчательное значение (см. раздел 9.2.7.4.8).

Если вышеперечисленные листовые элементы содержат сгибы, у которых включено определение параметров по исходному объекту (т.е. активна опция По исходному объекту — см. раздел 2.4.4.3.6), то на экране появляется диалог выбора сгибов (рис. 2.4.11).

Рис. 2.4.11. Диалог выбора сгибов

Он содержит перечень сгибов, имеющих описанные свойства, и позволяет настроить обработку этих сгибов при удалении таблицы.

Отметьте в диалоге выбора сгибов те сгибы, для которых требуется сохранить значение параметра развертки, полученное из таблицы. Нажмите кнопку ОК.

У выбранных сгибов будет автоматически отключено определение параметров по исходному объекту. Способ определения длины развертки поменяется на способ, соответствующий типу использовавшейся таблицы. Параметр развертки каждого сгиба примет значение, выбранное из таблицы с учетом величины угла этого сгиба.

У остальных сгибов будет сохранен признак определения параметров по исходному объекту. Поэтому каждый из них получит — вне зависимости от угла сгиба — такие же параметры, как исходный объект.

Формат таблицы сгибов

Таблица сгибов — текстовый файл с расширением loa. Файлы таблиц доступны для просмотра и редактирования при помощи любого текстового редактора, например, Блокнот Windows. Ниже приведен фрагмент таблицы коэффициентов, определяющих положение нейтрального слоя.

# Тип таблицы - таблица коэффициентов К

1

# Интерполяция - использовать линейную интерполяцию

1

<0.5> 1.0 2.0 3.0

0.0 0.375 0.415 0.439

360.0 0.375 0.415 0.439

<1.0> 1.0 2.0 3.0

0.0 0.350 0.375 0.398

360.0 0.350 0.375 0.398

Таблицы сгибов построены в соответствии со следующими правилами.

– Единицы измерения в таблице не указываются. Значения линейных величин измеряются в миллиметрах, угловых — в градусах.

– Строки, начинающиеся с символов «#», являются комментариями.

– Таблица может содержать пустые строки. При обработке таблицы они игнорируются.

– Первое значение таблицы задает ее тип:

1 — таблица коэффициентов К;

2 — таблица величин сгибов BA;

3 — таблица уменьшений сгибов BD.

– Второе значение задает возможность применения интерполяции для определения промежуточных значений параметров:

0 — не применять интерполяцию;

1 — применять линейную интерполяцию.

Если интерполяция применяется, то таблица используется следующим образом.

– Если заданные значения толщины листового тела, радиуса и угла сгиба в точности совпадают с табличными, то значение параметра развертки будет взято из таблицы.

– Если заданное значение толщины, радиуса или угла сгиба не совпадает с табличным, то значение параметра развертки рассчитывается с использованием линейной интерполяции.

Если интерполяция не применяется и заданное значение толщины листового тела, радиуса или угла сгиба не совпадает с табличным, то построение сгиба становится невозможным. Соответствующий листовой элемент отмечается в Дереве построения как ошибочный. Для исправления ошибки необходимо привести параметры сгиба в соответствие с табличными либо выбрать другую таблицу сгибов.

– Таблица сгибов состоит из нескольких блоков данных. Каждый блок содержит значения параметра K, BA или BD для различных толщин, радиусов и углов сгиба. Структура блоков одинакова.

• Толщина листового материала для блока данных является постоянной величиной. Ее значение заключается в угловые скобки. Например, в приведенном выше фрагменте таблицы значение толщины находится в верхнем левом углу блока.

• Первая строка блока содержит значения радиусов сгиба. Они располагаются в порядке возрастания слева направо.

• Левый столбец блока содержит значения углов сгиба. Они располагаются в порядке возрастания сверху вниз.

– Блоки в таблице должны располагаться в порядке увеличения толщины материала.

– Значения в таблице разделяются знаками пробела или табуляции.

При использовании таблицы экстраполяция значений не применяется: если значение толщины, радиуса сгиба или угла выходит за пределы изменения аргументов таблицы, то выдается сообщение об ошибке.


2.4.1.5. Фантомы

При построении таких листовых элементов, как сгибы (см. раздел 2.4.4) и штамповочные элементы (см. раздел 2.4.8) пользователь может включать или отключать показ фантома на экране по своему усмотрению.

Для управления отображением фантома текущего (создаваемого или редактируемого) листового элемента служит кнопка Показать фантом элемента на Панели специального управления.

Фантом листового элемента представляет собой полупрозрачное изображение элемента с текущими параметрами. При изменении параметров фантом динамически изменяется.

Отсутствие фантома на экране (при нажатой кнопке Показать фантом элемента) говорит о том, что создание листового элемента с текущими параметрами невозможно.

Использование фантомов делает создание модели более удобным, так как позволяет визуально контролировать результат построения. Однако иногда (например, при построении буртиков) листовой элемент оказывается довольно сложным, а отрисовка (и перерисовка) его фантома — длительной. В таких случаях для повышения скорости работы показ фантома рекомендуется отключать.


2.4.2. Листовое тело

2.4. Листовые тела

2.4.2. Листовое тело

Листовое тело формируется путем выдавливания эскиза в направлении, перпендикулярном его плоскости.

Перед построением листового тела в модели необходимо создать эскиз, определяющий форму тела.

В этом разделе:

2.4.2.1. Требования к эскизу

2.4.2.2. Построение листового тела

2.4.2.2.1. С замкнутым эскизом

2.4.2.2.2. С разомкнутым эскизом


2.4.2.1. Требования к эскизу

Требования к замкнутому эскизу листового тела:

– объекты эскиза могут составлять один или несколько контуров,

– если контуров несколько, один из них должен быть наружным, а другие — вложенными в него,

– допускается один уровень вложенности контуров.

Требования к разомкнутому эскизу листового тела:

– объекты эскиза должны составлять один контур,

– контур может состоять только из отрезков и дуг окружностей,

– дуги должны располагаться касательно к отрезкам и другим дугам и соединяться с ними в точках касания.


2.4.2.2. Построение листового тела

Чтобы создать в модели листовое тело, вызовите команду Листовое тело.

Команда Листовое тело доступна, если выделен один эскиз.

Задайте параметры листового тела на вкладке Панели свойств Параметры.

Если тел в модели несколько, то кроме настройки параметров может понадобиться задание области применения операции. Для этого служит вкладка Панели свойств Результат операции. Подробно об области применения для операций добавления материала рассказано в разделе 2.3.10.3.1.

Завершив настройку, подтвердите выполнение операции.

В окне модели появится листовое тело с заданными параметрами, а в Дереве построения — пиктограмма листового тела.

После создания листового тела в модели формируется определенный набор переменных (подробнее — см. раздел 2.4.1.3).

В этом разделе:

2.4.2.2.1. С замкнутым эскизом

2.4.2.2.2. С разомкнутым эскизом


2.4.2.2.1. С замкнутым эскизом

Если эскиз замкнут, то для построения листового тела необходимо задать следующие его параметры.

– Направление выдавливания эскиза. Прямое направление показано стрелкой в окне модели. Для изменения направления служит группа переключателей Направление.

– Толщину листового тела. Фактически толщина является расстоянием, на которое выдавливается эскиз.

– Определение длины развертки сгиба (см. раздел 2.4.4.3.5). Если длина развертки берется из таблицы сгибов, вы можете сменить умолчательную таблицу, нажав кнопку Выбрать другую таблицу сгибов.

Рис. 2.4.12. Построение листового тела на основе замкнутого эскиза: а) эскиз, б) листовое тело
а) | б)


2.4.2.2.2. С разомкнутым эскизом

Построение листового тела на основе разомкнутого эскиза имеет следующие особенности:

– отрезки в эскизе формируют плоские участки листового тела,

– дуги в эскизе формируют сгибы соответствующих радиусов,

– углы контура в эскизе формируют сгибы с заданным пользователем внутренним радиусом.

Выберите направление и глубину выдавливания. Это делается так же, как при построении элементов выдавливания (см. разделы 2.3.2.4.2 и 2.3.2.5).

Выберите направление добавления материала — наружу или внутрь по отношению к поверхности, образованной перемещением эскиза в указанном направлении.

Введите толщину слоя добавляемого материала (толщину листового тела) в поле Толщина.

Введите в поле Радиус сгиба значение внутреннего радиуса для сгибов, соответствующих углам контура (рис. 2.4.13).

Ввод нулевого радиуса сгиба невозможен. Минимальное значение — 0,0002 мм.

Рис. 2.4.13. Построение листового тела на основе разомкнутого эскиза: а) эскиз, б) листовое тело
а) | б)

Настройте определение длины развертки сгиба (см. раздел 2.4.4.3.5). Если длина развертки берется из таблицы сгибов, вы можете сменить умолчательную таблицу, нажав кнопку Выбрать другую таблицу сгибов.

Опция Разогнуть управляет состоянием листового тела. Если она выключена, то результатом построения будет согнутое листовое тело. При включенной опции все сгибы листового тела будут разогнуты.

Пиктограмма разогнутого листового тела отмечается в Дереве построения значком «разогнуто». Управление признаком «разогнуто» для листового тела производится также, как для других листовых элементов, содержащих сгибы (см. раздел 2.4.4.3.4).

Сгибы, получившиеся в результате построения листового тела с разомкнутым эскизом, не отличаются от сгибов, полученных с помощью специальных команд. Сгибы листового тела отображаются в Дереве построения так же, как остальные сгибы (см. раздел 2.4.4.2), любой сгиб листового тела можно отредактировать (см. раздел 2.4.4.3.6).


2.4.3. Обечайки

2.4. Листовые тела

2.4.3. Обечайки

Для построения обечаек в КОМПАС-3D служат команды Обечайка и Линейчатая обечайка.

Подробное описание этих команд приведено в разделах 2.4.3.2 и 2.4.3.3. Раздел 2.4.3.1 содержит описание общих приемов построения обечаек.

В этом разделе:

2.4.3.1. Общие приемы построения

2.4.3.1.1. Параметры кромок оснований

2.4.3.1.2. Параметры кромок стыка и зазор

2.4.3.1.3. Смещение зазора

2.4.3.2. Обечайка

2.4.3.2.1. Требования к эскизу обечайки

2.4.3.2.2. Параметры обечайки

2.4.3.2.3. Сегментация

2.4.3.3. Линейчатая обечайка

2.4.3.3.1. Требования к эскизам

2.4.3.3.2. Параметры линейчатой обечайки


2.4.3.1. Общие приемы построения

Форма сечения обечайки определяется ее эскизом. Для построения простой обечайки требуется один эскиз, для линейчатой — два эскиза. Эскизы должны быть созданы до вызова команды.

Эскиз может представлять собой как замкнутый, так и разомкнутый контур. Если контур (или оба контура — при построении линейчатой обечайки) замкнут, то обечайка строится разрезанной по высоте. Расположение и величина зазора может быть задана пользователем. Возможны различные способы обрезки кромок обечайки.

Для задания числовых параметров обечаек можно использовать характерные точки (см. раздел 2.1.4.2.2).

В углах контура обечайки автоматически строятся сгибы заданного радиуса.

Все сгибы обечайки отображаются в Дереве построения так же, как остальные сгибы (см. раздел 2.4.4.2). Любой сгиб обечайки можно отредактировать (см. раздел 2.4.4.3.6).

При создании обечайки в модели формируется такой же набор переменных, как при создании листового тела (подробнее — см. раздел 2.4.1.3).

Над созданной обечайкой могут производиться действия как над листовым телом — разгибание/сгибание, построение вырезов и отверстий, подсечек, буртиков и т.д.

При разгибании обечаек обратите внимание на следующее: сгибами считаются (и, соответственно, разгибаются) все неплоские участки обечайки. При этом только к цилиндрическим и коническим участкам применяются заданные параметры развертки. Результат разгибания остальных участков (они основаны на линейчатых поверхностях) не зависит от параметров развертки.

При работе с обычной обечайкой участки для разгибания/сгибания могут выбираться по отдельности, а при работе с линейчатой — только группами, которые образованы следующими друг за другом неплоскими участками.

В этом разделе:

2.4.3.1.1. Параметры кромок оснований

2.4.3.1.2. Параметры кромок стыка и зазор

2.4.3.1.3. Смещение зазора


2.4.3.1.1. Параметры кромок оснований

Рис. 2.4.14. Кромки оснований обечайки

Параметры кромок оснований обечайки задаются на вкладке Кромки Панели свойств.

Выберите вариант формы кромок оснований обечайки в группе Кромки оснований.

– Перпендикулярно плоскости листа: кромки обрезаются перпендикулярно плоскости развертки обечайки (рис. 2.4.15, а).

– Совпадение с поверхностями оснований: кромки обрезаются поверхностями оснований.
Для линейчатой обечайки — это плоскости первого и второго оснований (рис. 2.4.15, б).
Для простой обечайки — это плоскость эскиза и параллельная ей плоскость (рис. 2.4.15, б). Если выбран способ построения До поверхности, то одна кромка обрезается плоскостью эскиза, а другая — поверхностью (рис. 2.4.15, в).

Рис. 2.4.15. Кромки оснований обечайки: а) перпендикулярно плоскости листа; б) совпадение с поверхностями оснований; в) совпадение с поверхностями оснований, способ До поверхности (для простой обечайки)
а) | б) | в)


2.4.3.1.2. Параметры кромок стыка и зазор

Для обечаек на основе замкнутого контура необходимо задать величину зазора и параметры кромок стыка. Параметры зазора и кромок стыка задаются на вкладке Кромки Панели свойств.

Рис. 2.4.16. Кромки стыка обечайки

В поле Зазор введите или задайте счетчиком величину зазора — расстояние между кромками. Нулевую величину задавать нельзя.

В группе Кромки стыка выберите способ построения кромок стыка.

– Перпендикулярно поверхности листа: поверхность кромки строится таким образом, чтобы она была перпендикулярна поверхности обечайки вдоль всего зазора.
При размещении зазора на плоском участке кромки стыка плоские (рис. 2.4.18, а). На неплоском участке кромки стыка могут быть как плоскими (рис. 2.4.18, б), так и линейчатыми (рис. 2.4.18, в).

– Параллельно друг другу: кромки обрезаются плоскостями, параллельными плоскости, которая, в свою очередь, перпендикулярна контуру обечайки в точке зазора (рис. 2.4.18).

Рис. 2.4.17. Построение кромок стыка способом Перпендикулярно поверхности листа
а) | б) | в)

Рис. 2.4.18. Построение кромок стыка способом Параллельно друг другу

Максимально допустимое значение зазора зависит от его расположения на обечайке — зазор не должен выступать за внутреннюю стенку (см. рис. 2.4.18).

Если контур не замкнут, то кромки всегда обрезаются перпендикулярно поверхности листа.


2.4.3.1.3. Смещение зазора

Смещение характеризует положение точки в центре зазора относительно начальной точки контура в эскизе (для линейчатой обечайки — в эскизе первого основания). Начальная точка контура определяется системой автоматически.

Чтобы задать смещение, активизируйте нужный переключатель в группе Смещение зазора на вкладке Кромки Панели свойств, а затем введите число, характеризующее величину смещения.

– По параметру U — по относительной величине смещения от начальной точки контура до точки в центре зазора. В поле ввода Параметр U, % задается величина в процентах от длины контура в эскизе.

– По длине — по длине контура от его начальной точки до точки в центре зазора. В поле ввода Длина задается абсолютное смещение в единицах измерения длины.

– Угол расположения — по центральному углу дуги от начальной точки контура до точки в центре зазора. В поле ввода Угол задается центральный угол дуги в единицах измерения угла.
При работе с командой Обечайка вариант доступен, если контуром обечайки является окружность.
При работе с командой Линейчатая обечайка вариант доступен, если окружность является контуром первого основания.

Рис. 2.4.19. Смещение зазора: а) по параметру U или по длине; б) по центральному углу
а) | б)

Смещением можно управлять, перемещая характерную точку в центре зазора с помощью мыши. При этом значение параметра смещения, соответствующего выбранному варианту, определяется автоматически и отображается в поле ввода.

В процессе построения можно переключаться между вариантами. При этом величина смещения будет пересчитываться и отображаться в единицах измерения, соответствующих выбранному варианту.

Создание линейчатой обечайки невозможно в следующих случаях:

– зазор располагается на сгибе, автоматически сформированном на стыках граней обечайки,

– внутри или на границе зазора оказывается точка контура, в которой сопрягаются два его участка (например, отрезок и дуга).

В этих случаях необходимо изменить значение параметра смещения зазора.


2.4.3.2. Обечайка

Обечайка формируется путем выдавливания эскиза в направлении, перпендикулярном его плоскости, и добавлением толщины получившейся поверхности (рис. 2.4.20).

Рис. 2.4.20. Построение обечайки на основе замкнутого контура: а) эскиз; б) обечайка
а) | б)

Перед построением обечайки в модели необходимо создать эскиз, определяющий форму обечайки.

Отрезки в эскизе формируют плоские участки обечайки, дуги формируют сгибы соответствующих радиусов, углы контура формируют сгибы с заданным пользователем радиусом.

Чтобы создать в модели обечайку, вызовите команду Обечайка.

Выполните следующие действия.

1. Укажите эскиз.

Эскиз может быть указан до вызова команды.

2. Задайте следующие параметры:

• параметры обечайки, см. раздел 2.4.3.2.2,

• параметры кромок оснований, см. раздел 2.4.3.1.1,

• параметры кромок стыка и зазор (для обечайки с замкнутым эскизом), см. раздел 2.4.3.1.2,

• расположение зазора (для обечайки с замкнутым эскизом), см. раздел 2.4.3.1.3.

При необходимости можно сегментировать криволинейные участки контура обечайки — заменить их ломаными с сегментами равной длины. Настройка сегментации выполняется на вкладке Сегментация Панели свойств (см. раздел 2.4.3.2.3).

Если тел в модели несколько, то кроме настройки параметров может понадобиться задание области применения операции. Для этого служит вкладка Панели свойств Результат операции. Подробно об области применения для операций добавления материала рассказано в разделе 2.3.10.3.1.

Все значения параметров при их вводе и редактировании немедленно отображаются на экране в виде фантома элемента. Фантом позволяет визуально проконтролировать правильность задания параметров.

3. Нажмите кнопку Создать объект для завершения построения.

В модели появляется новый элемент с заданными параметрами, а в Дереве построения — соответствующая пиктограмма.

В этом разделе:

2.4.3.2.1. Требования к эскизу обечайки

2.4.3.2.2. Параметры обечайки

2.4.3.2.3. Сегментация


2.4.3.2.1. Требования к эскизу обечайки

– Объекты эскиза должны составлять один контур. Гладкого сопряжения между объектами контура не требуется.

– Контур может быть разомкнутым или замкнутым.

– Контур не должен иметь самопересечений.


2.4.3.2.2. Параметры обечайки

Для построения обечайки необходимо задать следующие параметры.

– Направление построения.
Прямое направление показано стрелкой в окне модели. Для изменения направления служит группа переключателей Направление.

– Расстояние построения.
Для выбора способа задания расстояния служит список Способ. Доступны следующие способы: На расстояние, До вершины и До поверхности. Параметры задаются так же, как при определении глубины выдавливания (см. разделы 2.3.2.5.1, 2.3.2.5.3 и 2.3.2.5.4).

– Угол уклона.
Для задания направления уклона служит группа переключателей Угол уклона, а для задания угла уклона — поле Угол.

– Толщина обечайки.
Для изменения направления добавления материала служит группа переключателей Направление для толщины, а для задания значения толщины — поле Толщина.

– Тип (актуально для обечаек с уклоном).

• С постоянным радиусом — сгибы в углах контура имеют форму цилиндра.

• С переменным радиусом — сгибы в углах контура имеют форму конуса.

Данный параметр не влияет на сгибы, соответствующие дугам в эскизе. Такие сгибы на обечайке с уклоном всегда имеют форму конуса.

– Радиус сгиба.
Сгибы заданного радиуса строятся в местах соединения участков контура.

В зависимости от выбранного направления толщины строится сгиб, внутренний или наружный радиус которого равен заданному значению. Минимальное допустимое значение внутреннего радиуса 0,0002 мм.

– Параметры развертки (см. раздел 2.4.1.4). Данные параметры актуальны для обечаек, контур в эскизе которых содержит отрезки и/или дуги (если контур включает другие объекты, то на разгибание сгибов, образованных этими объектами, параметры развертки не влияют).


2.4.3.2.3. Сегментация

Сегментация представляет собой замену криволинейных участков контура обечайки аппроксимирующими ломаными, состоящими из сегментов равной длины. В вершинах ломаных создаются сгибы заданного радиуса. Таким образом сгибы обечайки заменяются набором сгибов (рис. 2.4.21).

Рис. 2.4.21. Сегментация обечайки: а) исходное состояние, б) результат сегментации
а) | б)

Сегментация доступна для окружностей и эллипсов, а также их дуг.

Настройка сегментации выполняется на вкладке Сегментация Панели свойств.

Чтобы задать параметры сегментации, включите опцию Сегментация. Опция доступна, если контур обечайки содержит дуги окружностей и/или эллипсов или контуром является окружность/эллипс.

После включения опции на Панели свойств появляются элементы для настройки сегментации.

Укажите способ сегментации, нажав нужный переключатель группы Способ (табл 2.4.2). Затем введите или задайте счетчиком значение параметра.

Табл. 2.4.2. Описание способов сегментации
Наименование | Параметр, определяющий количество сегментов ломаной | Схема образования сегментированного контура
По количеству сегментов | В поле ввода Количество сегментов задается количество сегментов аппроксимирующей ломаной. |
По длине сегмента | В поле ввода Длина сегмента задается значение максимальной длины сегмента аппроксимирующей ломаной. |
По углу сегмента | В поле ввода Угол сегмента задается максимальное значение центрального угла дуги сегмента в единицах измерения угла. |
По линейному отклонению сегмента | В поле ввода Линейное отклонение сегмента задается значение максимального расстояния между дугой сегмента и сегментом аппроксимирующей ломаной. |

Количество сегментов аппроксимирующей ломаной может принимать целые значения в диапазоне 2 — 1000 (если контуром обечайки является окружность или эллипс, то минимальное количество сегментов — 3). Значение параметра сегментации должно обеспечивать количество сегментов в указанных пределах.

В процессе построения можно переключаться между способами сегментации. При этом значение параметра будет пересчитываться и отображаться в единицах измерения, соответствующих выбранному варианту.

Если контур обечайки содержит более одной дуги, то на Панели свойств присутствует опция Единые параметры. Опция позволяет применить выбранный способ сегментации и значение соответствующего параметра ко всем дугам контура обечайки.

По умолчанию опция Единые параметры включена. Если требуется настроить сегментацию какой-либо дуги отдельно, отключите опцию. После этого на Панели свойств появляется панель Кривые, содержащая перечень дуг контура обечайки (рис. 2.4.22). При выделении строки в списке соответствующий ей участок контура подсвечивается в окне модели.

Рис. 2.4.22. Панель Кривые

Выделите в списке строку с номером нужной дуги и задайте параметры сегментации.

Для отмены сегментации дуги отключите опцию рядом с ее номером.

Например, на рис. 2.4.23 показана обечайка, контур которой содержит отрезок и две дуги. Одна из этих дуг сегментирована, вторая — нет.

Рис. 2.4.23. Пример обечайки с сегментированным и несегментированным участками


2.4.3.3. Линейчатая обечайка

Линейчатая обечайка формируется путем соединения двух оснований линейчатой поверхностью и добавления к ней толщины (рис. 2.4.24).

Рис. 2.4.24. Построение линейчатой обечайки на основе замкнутых контуров: а) эскизы оснований; б) линейчатая обечайка
а) | б)

В качестве оснований используются эскизы произвольной формы и расположения; они должны быть созданы перед построением обечайки. Требования к эскизам указаны в разделе 2.4.3.3.1.

В общем случае боковые грани обечайки — линейчатые, но в частных случаях они могут быть плоскими, цилиндрическими или коническими. Это зависит от формы и взаиморасположения эскизов, а также от того, как поверхность разбита на грани. При необходимости умолчательное разбиение можно отредактировать.

Если смежные грани линейчатой поверхности не стыкуются гладко, то на месте стыка автоматически создается сгиб заданного радиуса. При пересечении соседних сгибов так же автоматически формируется освобождение угла (рис. 2.4.25).

Рис. 2.4.25. Пример освобождения угла при пересечении сгибов линейчатой обечайки

Чтобы создать в модели линейчатую обечайку, вызовите команду Линейчатая обечайка.

1. Укажите эскиз первого основания.

Эскиз может быть указан до вызова команды.

2. Укажите эскиз второго основания.

Повторное указание эскиза отменяет его выбор.

Если требуется отменить выбор всех эскизов, нажмите кнопку Указать заново на Панели специального управления. Затем укажите новые эскизы.

3. Задайте следующие параметры:

• параметры линейчатой обечайки, см. раздел 2.4.3.3.2,

• параметры кромок оснований, см. раздел 2.4.3.1.1,

• параметры кромок стыка и зазор (для обечайки с замкнутыми контурами оснований), см. раздел 2.4.3.1.2,

• расположение зазора (для обечайки с замкнутыми контурами оснований), см. раздел 2.4.3.1.3,

4. При необходимости отредактируйте разбиение линейчатой обечайки на грани. Вы можете сдвинуть, добавить или удалить ребра. Для этого служит вкладка Разбиение Панели свойств. Настройка разбиения линейчатой обечайки выполняется так же, как настройка разбиения линейчатой поверхности (см. раздел 2.6.1.9.2) с единственным исключением: при работе с линейчатой обечайкой отсутствует опция По вершинам.

Линейчатая обечайка с текущими параметрами отображается на экране в виде фантома. Фантом позволяет визуально проконтролировать правильность построения.

5. Для завершения построения обечайки нажмите кнопку Создать объект на Панели специального управления.

В модели появляется новый элемент с заданными параметрами, а в Дереве построения — соответствующая пиктограмма.

Создание линейчатой обечайки невозможно, если тело, получаемое в результате построения, имеет самопересечения. О невозможности построения свидетельствует отсутствие фантома.

В этом разделе:

2.4.3.3.1. Требования к эскизам

2.4.3.3.2. Параметры линейчатой обечайки


2.4.3.3.1. Требования к эскизам

– Эскизы могут быть произвольной формы и располагаться в произвольно ориентированных плоскостях.

– Если эскизы располагаются в пересекающихся плоскостях, то объекты контура одного эскиза не должны лежать в плоскости другого эскиза или пересекать ее.

– Объекты каждого эскиза должны составлять один контур.

– Оба контура должны быть или замкнуты, или разомкнуты.

– Контуры не должны иметь самопересечений.


2.4.3.3.2. Параметры линейчатой обечайки

Для построения линейчатой обечайки необходимо задать следующие параметры.

– Толщина обечайки.
Для изменения направления добавления материала служит группа переключателей Направление для толщины, а для задания значения толщины — поле Толщина.

– Радиус сгиба.
Сгибы заданного радиуса строятся в местах соединения участков контура.

В зависимости от выбранного направления толщины строится сгиб, внутренний или наружный радиус которого равен заданному значению.

Минимальное допустимое значение внутреннего радиуса — 0,0002 мм.

– Параметры развертки (см. раздел 2.4.1.4). Данные параметры актуальны для цилиндрических и конических сгибов обечайки; на разгибание сгибов на основе линейчатой поверхности параметры развертки не влияют.


2.4.4. Сгибы

2.4. Листовые тела

2.4.4. Сгибы

Сгиб — неплоский участок листового тела. В подавляющем большинстве случаев сгибы имеют форму цилиндра, т.е. его внешняя и внутренняя поверхности цилиндрические (рис. 2.4.26). Кроме того, эти поверхности могут быть коническими или линейчатыми. При разгибании листового тела его участки, соответствующие сгибам, становятся плоскими, а при сгибании, наоборот, принимают исходную форму. Подробно о сгибании и разгибании см. раздел 2.4.7.1.

Рис. 2.4.26. Пример сгиба в листовом теле

Сгибы цилиндрической формы создаются в модели с помощью следующих команд:

• Сгиб,

• Сгиб по эскизу,

• Сгиб по линии,

• Подсечка.

Данный раздел посвящен перечисленным командам: подраздел 2.4.4.3 содержит описание общих приемов их выполнения, а в подразделах 2.4.4.4, 2.4.4.5, 2.4.4.6 и 2.4.4.8 рассказано о дополнительных приемах. Подраздел 2.4.4.7 описывает замыкание углов — модификацию соседних сгибов с целью уменьшения зазора между ними.

Применение команд создания сгибов, а также команды замыкания углов невозможно, если листовое тело состоит из нескольких частей (например, разделено операцией вырезания). Чтобы создать сгибы, необходимо сначала сделать тело целым, отредактировав имеющиеся элементы или создав новые элементы, которые соединят части.

Обратите внимание на то, что сгибы также появляются в результате построения следующих элементов:

– листовое тело на основе незамкнутого эскиза (см. раздел 2.4.2.2.2) — в этом случае формируются цилиндрические сгибы;

– обечайка, линейчатая обечайка (см. разделы 2.4.3.2 и 2.4.3.3) — в этом случае могут формироваться цилиндрические и конические сгибы, а также сгибы с линейчатой поверхностью.

В этом разделе:

2.4.4.1. Термины и определения

2.4.4.2. Отображение сгибов в Дереве построения модели

2.4.4.3. Общие приемы построения сгибов

2.4.4.3.1. Направление отсчета и интерпретация значения угла

2.4.4.3.2. Радиус сгиба

2.4.4.3.3. Освобождение угла

2.4.4.3.4. Состояние сгибов

2.4.4.3.5. Настройка определения длины развертки

2.4.4.3.6. Редактирование параметров сгиба

2.4.4.4. Сгиб

2.4.4.4.1. Размещение сгиба

2.4.4.4.2. Продолжение сгиба

2.4.4.4.3. Смещение сгиба

2.4.4.4.4. Боковые стороны

2.4.4.4.5. Освобождение сгиба

2.4.4.5. Сгиб по линии

2.4.4.5.1. Исходные объекты и результат построения

2.4.4.5.2. Неподвижная сторона сгиба

2.4.4.5.3. Способ формирования сгиба

2.4.4.6. Подсечка

2.4.4.6.1. Исходные объекты и результат построения

2.4.4.6.2. Размер подсечки

2.4.4.6.3. Подсечка с добавлением материала и подсечка без добавления материала

2.4.4.6.4. Плоский участок подсечки

2.4.4.7. Замыкание углов

2.4.4.7.1. Способы замыкания

2.4.4.7.2. Обработка угла

2.4.4.7.3. Зазор

2.4.4.7.4. Продолжение замыкания

2.4.4.7.5. Принцип построения замыкания встык и плотного замыкания

2.4.4.7.6. Принцип построения замыкания с перекрытием

2.4.4.7.7. Выполнение замыкания

2.4.4.8. Сгиб по эскизу

2.4.4.8.1. Требования к эскизу

2.4.4.8.2. Способ построения

2.4.4.8.3. Замыкание углов

2.4.4.8.4. Освобождение


2.4.4.1. Термины и определения

Для создания сгиба необходимо наличие линии сгиба — прямолинейного объекта, определяющего положение сгиба в листовом теле.

Плоская внешняя или внутренняя грань листового тела, содержащая линию сгиба, называется базовой гранью этого сгиба.

Если тело сгибается в сторону базовой грани, то считается, что сгиб произведен в прямом направлении. При сгибании в противоположную сторону сгиб считается произведенным в обратном направлении.

Рис. 2.4.27. Направление сгиба: а) базовая грань и линия сгиба, б) сгиб в прямом направлении, в) сгиб в обратном направлении
а) | б) | в)


2.4.4.2. Отображение сгибов в Дереве построения модели

Пиктограммы сгибов расположены в Дереве построения модели на ветвях своих исходных объектов — тех листовых элементов, в состав которых они входят (рис. 2.4.28).

Рис. 2.4.28.

Некоторые элементы, например, подсечка, могут содержать несколько сгибов. Чтобы просмотреть список сгибов, разверните ветвь Дерева построения, соответствующую исходному листовому элементу.

Имя каждого сгиба формируется автоматически. Оно содержит порядковый номер сгиба в листовом элементе и название этого элемента.

Контекстное меню сгиба практически не отличается от контекстных меню других листовых элементов.

С его помощью вы можете настроить свойства исходного элемента, просмотреть отношения и атрибуты объекта.

Команда Редактировать элемент запускает процесс редактирования выбранного сгиба (см. раздел 2.4.4.3.6).

Действие команд Исключить из расчета/Включить в расчет распространяется на весь элемент, содержащий выбранный сгиб, а команд Скрыть/Показать — на все листовое тело.


2.4.4.3. Общие приемы построения сгибов

После вызова любой из команд создания сгибов на Панели свойств появляются элементы управления, позволяющие настроить различные параметры сгибов.

Первоначально эти параметры (угол, радиус и т. д.) совпадают с умолчательными для данной модели (см. раздел 2.4.1.3). Если оставить их без изменения, то с параметрами будут связаны умолчательные переменные. В дальнейшем это позволит быстро изменять параметры однотипных сгибов. Подробнее о работе с переменными листового тела рассказано в разделе 2.4.1.3.

Для задания числовых параметров сгибов можно использовать характерные точки (см. раздел 2.1.4.2.2) или геометрический калькулятор (см. раздел 1.4.2.13.2).

Чтобы зафиксировать созданный сгиб, нажмите кнопку Создать объект на Панели специального управления.

К проектируемому листовому телу добавится новый элемент с заданными параметрами, а в Дереве построения появится соответствующая пиктограмма:

– сгиб,

– сгиб по эскизу,

– сгиб по линии,

– подсечка.

Вы можете создать несколько однотипных элементов (сгибов, сгибов по линии или подсечек), не выходя из команды. Для построения очередного элемента укажите его исходный объект (или объекты), при необходимости — измените параметры операции и нажмите кнопку Создать объект.

Если нужно построить подряд несколько элементов с одинаковыми параметрами, поступите следующим образом. Создав первый элемент и убедившись, что параметры указаны верно, нажмите кнопку Автосоздание объекта на Панели специального управления. Затем указывайте исходные объекты для новых элементов. Они будут формироваться автоматически, т.е. не ожидая подтверждения создания.

Чтобы завершить построение элементов, нажмите кнопку Прервать команду на Панели специального управления.

В этом разделе:

2.4.4.3.1. Направление отсчета и интерпретация значения угла

2.4.4.3.2. Радиус сгиба

2.4.4.3.3. Освобождение угла

2.4.4.3.4. Состояние сгибов

2.4.4.3.5. Настройка определения длины развертки

2.4.4.3.6. Редактирование параметров сгиба


2.4.4.3.1. Направление отсчета и интерпретация значения угла

При построении сгиба угол может откладываться как в одну, так и в другую сторону от базовой грани. Прямым направлением отсчета угла считается направление наружу по отношению к листовому телу. Это направление определяется системой автоматически и показывается фантомной стрелкой в окне модели.

Чтобы выбрать направление отсчета угла — Прямое или Обратное — активизируйте соответствующий переключатель в группе Направление.

Значение, введенное в поле Угол, может интерпретироваться как

– угол сгиба или

– дополняющий угол.

Чтобы выбрать интерпретацию значения угла, активизируйте нужный переключатель в группе Интерпретация угла.

Направление сгиба — прямое или обратное (см. рис. 2.4.27, б, в) — зависит как от направления отсчета угла, так и от его интерпретации (см. табл. 2.4.3).

Табл. 2.4.3. Схема построения сгиба в зависимости от направления отсчета и интерпретации угла1
 | Прямое направление отсчета | Обратное направление отсчета
Угол сгиба |  |
Дополняющий угол |  |
  1. На схеме показана проекция детали на плоскость, перпендикулярную линии сгиба. Проекция базовой грани показана в виде утолщенного отрезка.

Построение сгиба с дополняющим углом 180° невозможно, так как это означает отсутствие сгиба: угол сгиба равен 0°.

Если угол интерпретируется как угол сгиба, то направление отсчета угла совпадает с направлением полученного сгиба.

Если же угол интерпретируется как дополняющий, то эти направления совпадают только при значениях угла от 0° до 180°. При значениях дополняющего угла от 180° до 360° направление полученного сгиба оказывается противоположно выбранному направлению отсчета угла.

Например, на рис. 2.4.29 показан сгиб в обратном направлении. Угол этого сгиба равен 250°, интерпретируется как дополняющий и отложен в прямом направлении.

Рис. 2.4.29. Сгиб в обратном направлении


2.4.4.3.2. Радиус сгиба

Чтобы выбрать способ задания радиуса, активизируйте нужный переключатель — Внутренний радиус или Наружный радиус — в группе Способ задания радиуса.

В зависимости от выбранного способа задания радиуса будет построен сгиб, внутренний или наружный радиус которого равен заданному значению.

Минимальное значение внутреннего радиуса — 2 · 10-4 мм. Внутренний и наружный радиусы связаны соотношением:

Rнаружн. = Rвнутр. + S,

где S — толщина материала.

Поэтому минимальное значение наружного радиуса равно сумме (S + 2 · 10-4) мм.


2.4.4.3.3. Освобождение угла

Если создаваемый сгиб располагается по отношению к соседнему сгибу (сгибам), например, так, как показано на рис. 2.4.30, то вы можете применить освобождение угла.

Рис. 2.4.30. Пример расположения сгибов, позволяющего применить
освобождение угла: плоская кольцевая грань создаваемого Сгиба 1
частично совпадает с плоской прямоугольной гранью соседнего с ним Сгиба 2

Доступны три способа освобождения (табл. 2.4.4). Чтобы выбрать нужный способ, активизируйте соответствующий переключатель на вкладке Освобождение Панели свойств.

Табл. 2.4.4. Способы освобождения углов сгибов
Значение опции Освобождение угла | Результат построения1
Только сгиб |
Сгиб и его продолжение |
Все сгибы |
  1. В этой колонке представлены результаты применения различных способов освобождения угла при построении Сгиба 1 (см. рис. 2.4.30).

Использование освобождения угла при работе с командой Сгиб имеет следующие особенности.

1. Освобождение угла возможно, только если линия создаваемого сгиба перпендикулярна линиям соседних сгибов.

2. Для включения освобождения следует активизировать переключатель Освобождение угла на вкладке Освобождение Панели свойств. После этого станут доступны переключатели способа освобождения.


2.4.4.3.4. Состояние сгибов

Листовой элемент может быть построен как в согнутом, так и в разогнутом состоянии. Состоянием листового элемента управляет опция Разогнуть. Если она выключена, то результатом построения будет листовой элемент с согнутыми сгибами (рис. 2.4.31, б). Если опция включена, сгибы листового элемента будут разогнуты (рис. 2.4.31, в).

Рис. 2.4.31. Построение сгиба: а) базовая грань и линия сгиба, б) согнутый сгиб, в) разогнутый сгиб
а) | б) | в)

Пиктограмма разогнутого листового элемента отмечается в Дереве построения значком «разогнуто»:

– разогнутый сгиб,

– разогнутый сгиб по эскизу,

– разогнутый сгиб по линии,

– разогнутая подсечка.

Признаком «разогнуто» можно управлять как с помощью опции Разогнуть (при создании или редактировании листового элемента), так и с помощью команд Разогнуть и Согнуть в контекстном меню листового элемента в Дереве построения. После вызова одной из этих команд для какого-либо элемента в его контекстном меню появляется другая команда. Для нескольких выделенных элементов доступны обе команды (рис. 2.4.32).

Рис. 2.4.32. Команды Согнуть и Разогнуть в контекстном меню сгибов

Существуют также специальные команды редактирования листового тела, позволяющие изменить состояние одного или нескольких сгибов (см. раздел 2.4.7.1).


2.4.4.3.5. Настройка определения длины развертки

Чтобы задать способ определения длины развертки сгиба, раскройте список Развертка и выберите в нем нужную строку:

– Коэффициент,

– Величина сгиба,

– Уменьшение сгиба,

– Таблица сгибов.

Порядок определения длины развертки для каждого из способов подробно рассмотрен в разделе 2.4.1.4.

В зависимости от указанного способа на Панели свойств появится поле для ввода значения параметра развертки (Коэффициент, или Величина, или Уменьшение), или поле, содержащее путь к файлу таблицы сгибов.

По умолчанию используется файл таблицы сгибов, указанный в диалоге настройки листового тела для текущей модели. Выбор другой таблицы сгибов для текущей модели описан в разделе Смена таблицы сгибов.


2.4.4.3.6. Редактирование параметров сгиба

По умолчанию параметры сгибов соответствуют заданным при настройке листового тела. Часть параметров конкретного сгиба могут быть изменены. Для этого следует выделить его в Дереве построения и вызвать команду Редактировать из контекстного меню или из меню Редактор (рис. 2.4.33).

Рис. 2.4.33. Команда Редактировать в контекстном меню сгиба

На Панели свойств появятся элементы, позволяющие настроить сгиб (рис. 2.4.34). По умолчанию опция По исходному объекту включена. Это означает, что параметры сгиба должны быть такими же, как у исходного объекта.

Чтобы задать для сгиба собственные параметры, выключите опцию По исходному объекту. После этого станут доступными остальные элементы управления.

Вы можете изменить следующие параметры сгиба:

– способ задания радиуса,

– значение радиуса сгиба,

– способ определения длины развертки и его параметры.

Остальные свойства сгиба соответствуют свойствам исходного объекта.

Рис. 2.4.34. Элементы управления сгибом

Переключение способа задания радиуса и изменение его значения невозможно, если редактируемый сгиб принадлежит сгибу по эскизу или листовому телу с разомкнутым эскизом и соответствует дуге в эскизе.

Сгибы, у которых отключено определение параметров по исходному объекту, отображаются в Окне переменных как самостоятельные элементы, подчиненные своему исходному объекту (подробнее см. раздел 2.4.1.3.1, пункт 5).


2.4.4.4. Сгиб

Вы можете создать сгиб вдоль ребра листового тела. Ребро должно быть прямолинейным и принадлежать внешней или внутренней плоской грани листового тела.

Указанное ребро будет считаться линией сгиба, а содержащая его грань (внешняя или внутренняя) — базовой гранью сгиба (рис. 2.4.35).

Рис. 2.4.35. Сгиб вдоль ребра: а) базовая грань и линия сгиба, б) результат построения
а) | б)

Чтобы добавить к листовому телу сгиб вдоль ребра, вызовите команду Сгиб.

Укажите ребро, вдоль которого должен располагаться сгиб.

Выберите направление отсчета и интерпретацию угла (см. раздел 2.4.4.3.1).

Укажите величину и способ задания радиуса сгиба (см. раздел 2.4.4.3.2).

Настройте освобождение угла (см. раздел 2.4.4.3.3).

Выберите состояние сгиба (см. раздел 2.4.4.3.4).

Настройте определение длины развертки сгиба (см. раздел 2.4.4.3.5).

Фантомная стрелка (показывающая прямое направление отсчета угла) располагается на левом конце ребра. Сторона сгиба, ближайшая к левому концу ребра, также считается левой, а противоположная сторона сгиба — правой. Левую и правую стороны необходимо различать при настройке размещения сгиба и параметров его боковых сторон.

В этом разделе:

2.4.4.4.1. Размещение сгиба

2.4.4.4.2. Продолжение сгиба

2.4.4.4.3. Смещение сгиба

2.4.4.4.4. Боковые стороны

2.4.4.4.5. Освобождение сгиба


2.4.4.4.1. Размещение сгиба

При создании сгиба возможны различные варианты его размещения на ребре. Чтобы указать размещение сгиба, выберите нужный вариант из списка Размещение (см. табл. 2.4.5). В зависимости от выбранного варианта размещения на Панели свойств появляются поля для ввода ширины сгиба или его отступов от концов ребра.

Табл. 2.4.5. Варианты размещения сгиба
Значение опции Размещение | Правила размещения сгиба и определения его ширины | Результат построения
По всей длине | Ширина сгиба равна длине ребра. |
По центру | Значение ширины сгиба вводится в поле Ширина 1. Сгиб размещается по центру ребра. |
Слева | Значение ширины вводится в поле Ширина 1. Сгиб размещается так, чтобы левый конец ребра лежал в плоскости левой стороны сгиба. |
Справа | Значение ширины вводится в поле Ширина 1. Сгиб размещается так, чтобы правый конец ребра лежал в плоскости правой стороны сгиба. |
Два отступа | Ширина сгиба определяется автоматически как разница между длиной ребра и суммарной величиной отступов2. Значения отступов слева и справа вводятся в поля Отступ 1 и Отступ 2 соответственно. Положение сгиба определяется размерами отступов. |
Отступ слева | Ширина сгиба и величина отступа вводятся в поля Отступ 3 и Ширина 1. Сгиб размещается так, чтобы расстояние от левого конца ребра до левой стороны сгиба равнялось заданному значению отступа. |
Отступ справа | Ширина сгиба и величина отступа вводятся в поля Отступ 3 и Ширина 1. Сгиб размещается так, чтобы расстояние от правого конца ребра до правой стороны сгиба равнялось заданному значению отступа. |
  1. Ширина сгиба может принимать любые положительные значения. Нулевая ширина не допускается.
  2. Значения отступов могут быть как положительными, так и отрицательными. При расчете ширины сгиба учитываются знаки отступов: положительные отступы откладываются внутрь по отношению к листовому телу, а отрицательные — наружу. Значения отступов, при которых ширина сгиба получается отрицательной или равной нулю, а также значения, при которых сгиб оказывается отделенным от листового тела, не допускаются.
  3. Значение отступа может быть как положительными, так и отрицательным. Положительный отступ откладывается внутрь по отношению к листовому телу, а отрицательный — наружу. Значения отступа, при которых сгиб оказывается отделенным от листового тела, не допускаются.


2.4.4.4.2. Продолжение сгиба

Продолжение сгиба — часть листового тела, примыкающая к сгибу со стороны, противоположной ребру, вдоль которого расположен этот сгиб (рис. 2.4.36).

Рис. 2.4.36. Продолжение сгиба вдоль ребра

Для задания длины продолжения сгиба служит список Способ построения 1. В зависимости от выбранного варианта на Панели свойств появляются элементы управления длиной продолжения сгиба.

При необходимости вы можете задать длины сторон продолжения сгиба по отдельности. Для этого служит опция По 2 сторонам. При включенной опции способы построения сторон продолжения сгиба следует выбрать из списков Способ построения 1 и Способ построения 2. Примеры формирования продолжения сгиба приведены на рисунке 2.4.37.

Рис. 2.4.37. Варианты формирования продолжения сгиба: а) опция По 2 сторонам отключена; б) опция По 2 сторонам включена
а) | б)

В списке Способ построения доступны следующие варианты задания длины продолжения сгиба (они описаны ниже):

– На расстояние

– До вершины

– До поверхности

На расстояние

Продолжение сгиба имеет заданную пользователем длину.

При выборе этого способа на Панели свойств присутствует группа переключателей Способ задания длины. Укажите способ задания длины, выбрав нужный переключатель (табл. 2.4.6). Введите значение длины в поле Длина.

Табл. 2.4.6. Схемы задания длины продолжения сгиба1
Значение опции Способ задания длины | Угол сгиба от 0° до 90° | Угол сгиба 90° | Угол сгиба более 90°
Длина |  |  |
Длина по контуру |  |  |
Длина по касанию |  |  |
Длина по контуру внутри |  |  |
Длина по касанию внутри |  |  |
  1. На схеме показана проекция детали на плоскость, перпендикулярную линии сгиба.

До вершины

При использовании этого способа продолжение сгиба имеет такую длину, при которой его торцевая грань (или ребро торцевой грани, прилежащее к стороне продолжения, если включена опция По 2 сторонам) совмещается с плоскостью, проходящей через указанную вершину перпендикулярно направлению построения.

Чтобы задать вершину, активизируйте переключатель Вершина и укажите нужный точечный объект в Дереве построения или в графической области.

До поверхности

Длина продолжения сгиба определяется автоматически по положению указанной пользователем плоской грани или плоскости.

В зависимости от состояния опции По 2 сторонам на фантоме отображаются характерные точки продолжения сгиба:

– при отключенной опции — одна точка посередине ребра торцевой грани;

– при включенной опции — две точки в углах торцевой грани.

При построении способом До поверхности продолжение сгиба имеет такую длину, при которой его характерная точка принадлежит указанной пользователем поверхности или ее продолжению (рис. 2.4.38).

Рис. 2.4.38. Формирование продолжения сгиба способом До поверхности: а) опция По 2 сторонам отключена; б) опция По 2 сторонам включена, для обеих сторон указана одна и та же грань листового тела
а) | б)

Чтобы задать поверхность, активизируйте переключатель Грань и укажите нужную грань или плоскость в графической области.

Задание расстояния до объекта

При выборе способа построения До вершины или До поверхности после указания вершины или поверхности требуется задать расстояние до нее.

Торец продолжения сгиба может совпадать с указанным объектом, «заходить» за объект или «не доходить» до него на заданное расстояние.

Чтобы задать направление отсчета расстояния до объекта, активизируйте переключатель До объекта или За объект в группе Тип, затем введите в поле Расстояние требуемое расстояние между торцем продолжения сгиба и объектом. Если требуется построить продолжение сгиба точно до объекта, введите в поле Расстояние нулевое значение.

Особенности задания параметров продолжения сгиба

– При использовании способа Длина возможен ввод нулевого значения длины. Это означает формирование сгиба без продолжения (рис. 2.4.39).

Рис. 2.4.39. Примеры сгибов без продолжений

– При использовании способов задания длины Длина по контуру, Длина по касанию, Длина по контуру внутри, Длина по касанию внутри значение, вводимое в поле Длина, должно быть больше некоторого минимума (рис. 2.4.40). В общем случае он зависит от толщины материала, угла и радиуса сгиба.

Рис. 2.4.40. Минимальная длина

– Задание Длины по контуру и Длины по контуру внутри доступно для углов от 0° до 180°.

– Построение сгиба возможно не при всех значениях угла и радиуса, если выбран способ построения продолжения сгиба До вершины или До поверхности. О невозможности построения свидетельствует исчезновение фантома сгиба после ввода значения угла и/или радиуса.


2.4.4.4.3. Смещение сгиба

Смещение сгиба — параметр, характеризующий сдвиг сгиба в плоскости базовой грани. Смещение сгиба производится перпендикулярно ребру, вдоль которого он располагается.

Чтобы указать тип смещения сгиба относительно ребра, выберите нужный вариант из списка Тип смещения.

При смещении сгиба внутрь или наружу расстояние смещения задается пользователем произвольно. Для ввода этого расстояния служит поле Смещение. При нулевом смещении сгиб начинается непосредственно от ребра (рис. 2.4.41, а), а при положительном — сдвигается внутрь или наружу (рис. 2.4.41 б, в).

Рис. 2.4.41. Смещение сгиба: а) нулевое, б) внутрь, в) наружу
а) | б) | в)

При других типах смещения расстояние смещения определяется системой автоматически. Это расстояние зависит от угла сгиба, толщины материала и внутреннего радиуса сгиба (табл. 2.4.7).

Табл. 2.4.7. Схема построения и значение смещения1
Угол сгиба a | По внешней линии контура | По внутренней линии контура | По касанию к сгибу
от 0° до 90° |  |  |
 | D = (r + s) · tg(a/2) | D = r · tg(a/2) | D = (r + s) · tg(180 - a/2)
90° |  |  |
 | D = r + s | D = r | D = r + s
от 90° до 180° |  |  |
 | D = (r + s) · tg(180 - a/2) | D = r · tg(180 - a/2) | D = r + s
более 180° |  |  |
 | D = r + s | D = r | D = r + s
  1. На схеме показана проекция модели на плоскость, перпендикулярную ребру, вдоль которого располагается сгиб. Проекция ребра обозначена кружком.


2.4.4.4.4. Боковые стороны

При создании сгиба вдоль ребра возможны два способа управления параметрами боковых сторон сгиба:

– изменение ширины продолжения сгиба (рис. 2.4.42),

Рис. 2.4.42. Изменение ширины продолжения сгиба: а) увеличение, б) уменьшение
а) | б)

– задание угла на сгибе и/или уклона боковых сторон продолжения сгиба (рис. 2.4.43).

Рис. 2.4.43. Управление боковыми сторонами сгиба: а) углы на сгибе, б) уклон боковых сторон продолжения сгиба, в), г) углы на сгибе и уклон боковых сторон продолжения
а) | б)
в) | г)

Чтобы выбрать вариант настройки для левой боковой стороны, активизируйте нужный переключатель — Уклон и угол или Расширение — в группе Слева.

Чтобы выбрать вариант настройки для правой боковой стороны, активизируйте нужный переключатель — Уклон и угол или Расширение — в группе Справа.

Уклон и угол

Правила задания угла уклона боковой стороны сгиба и угла на сгибе:

– углы измеряются на разогнутом сгибе,

– углы отсчитываются от плоскости, перпендикулярной ребру, вдоль которого располагается сгиб,

– углы могут принимать значения от -90° до +90°,

– положительные углы откладываются внутрь по отношению к листовому телу, отрицательные — наружу.

Для ввода угла уклона боковой стороны продолжения сгиба служит поле Уклон.

Для ввода угла на сгибе служит поле Угол на сгибе.

Если угол на сгибе отличен от нуля, то соответствующая боковая грань согнутого сгиба получается не плоская.

Расширение

Расширение продолжения сгиба — изменение ширины продолжения сгиба по сравнению с шириной сгиба.

Значение расширения может быть отрицательным, положительным или нулевым. Отрицательное расширение означает уменьшение ширины продолжения сгиба, положительное — увеличение ширины продолжения сгиба, нулевое — отсутствие изменения ширины.

Для ввода величины расширения продолжения сгиба служит поле Расширение.


2.4.4.4.5. Освобождение сгиба

Освобождение сгиба — пазы в листовом теле, расположенные по бокам сгиба.

Освобождение может иметь прямоугольную или скругленную форму. Размеры освобождения определяются его глубиной и шириной (рис. 2.4.44).

Рис. 2.4.44. Освобождение сгиба: а) прямоугольное, б) скругленное
а) | б)

Чтобы сформировать освобождение сгиба, активизируйте переключатель Освобождение сгиба на вкладке Освобождение Панели свойств.

Чтобы выбрать форму освобождения, активизируйте нужный переключатель — Прямоугольное или Скругленное — в группе Тип.

Введите размеры освобождения в поля Глубина и Ширина. Значения глубины и ширины могут быть нулевыми или положительными.

Опция Включить в ширину сгиба управляет расположением освобождений относительно сгиба. Если ширины освобождений должны включаться в ширину сгиба (фактическая ширина сгиба при этом уменьшается — рис. 2.4.45, б), активизируйте эту опцию. При отключенной опции ширины освобождений не включаются в ширину сгиба (ширина сгиба не изменяется — рис. 2.4.45, в).

Рис. 2.4.45. Расположение освобождений: а) ширина сгиба без освобождений, б) освобождения включены в ширину сгиба, в) освобождения не включены в ширину сгиба
а) | б) | в)

Если угол на сгибе (см. раздел 2.4.4.4.4) отличен от нуля, то освобождение сгиба поворачивается (рис. 2.4.46). Угол поворота освобождения равен углу на сгибе. Глубина освобождения откладывается вдоль боковой грани разогнутого сгиба, а ширина освобождения — перпендикулярно этой грани (рис. 2.4.47).

Рис. 2.4.46. Освобождение сгиба при отличном от нуля угле на сгибе

Рис. 2.4.47. Определение размеров освобождения сгиба при отличном от нуля угле на сгибе


2.4.4.5. Сгиб по линии

Вы можете согнуть листовое тело по прямой линии относительно какой-либо внешней или внутренней плоской грани этого тела. Указанные линия и грань будут считаться линией сгиба и базовой гранью сгиба.

Чтобы согнуть листовое тело по линии, вызовите команду Сгиб по линии.

Укажите базовую грань и линию сгиба (см. раздел 2.4.4.5.1).

Выберите направление отсчета и интерпретацию угла (см. раздел 2.4.4.3.1).

Укажите величину и способ задания радиуса сгиба (см. раздел 2.4.4.3.2).

Настройте освобождение угла (см. раздел 2.4.4.3.3).

Выберите состояние сгиба (см. раздел 2.4.4.3.4).

Настройте определение длины развертки сгиба (см. раздел 2.4.4.3.5).

В этом разделе:

2.4.4.5.1. Исходные объекты и результат построения

2.4.4.5.2. Неподвижная сторона сгиба

2.4.4.5.3. Способ формирования сгиба


2.4.4.5.1. Исходные объекты и результат построения

В качестве линии сгиба может использоваться:

– отрезок эскиза, построенного на внешней или внутренней плоской грани листового тела,

– прямолинейное ребро формообразующего элемента или поверхности,

– сегмент ломаной,

– вспомогательная ось.

Требования к линии сгиба:

– линия сгиба должна располагаться в плоскости базовой грани,

– линия сгиба не должна совпадать с ребром базовой грани,

– линия сгиба должна пересекаться или иметь общую точку хотя бы с одним ребром базовой грани (в последнем случае продолжение линии сгиба должно пересекать контур базовой грани, т.е. общая точка не должна быть точкой касания ребра и линии сгиба),

– линия сгиба может полностью располагаться внутри контура базовой грани (при этом одна или обе конечные точки линии сгиба могут лежать на ребрах грани).

Вспомогательная ось бесконечна. Поэтому при выборе оси в качестве линии сгиба не имеет значения, пересекается отрезок, изображающий эту ось, с контуром базовой грани или нет (см. рис. 2.4.50).

Результат построения сгиба зависит от взаимного расположения базовой грани и линии сгиба. Общее правило: сгибается та часть листового тела, которой принадлежит базовая грань, или участок базовой грани, пересекающийся с линией сгиба или ее продолжением.

Если в качестве линии сгиба используется отрезок, ребро или сегмент ломаной, а сгибаемая грань имеет сложную форму, то для корректного построения сгиба рекомендуется располагать линию сгиба так, чтобы она непосредственно проходила по всем участкам грани, которые должны быть согнуты.

На рисунках 2.4.48–2.4.50 показаны варианты сгибов листового тела, построенные с помощью команды Сгиб по линии. В качестве базовой грани во всех представленных случаях используется верхняя плоская грань; линия сгиба показана утолщенной.

Рис. 2.4.48. Зависимость результата сгиба от положения линии сгиба: а), в) варианты положения линии сгиба, б), г) соответствующие результаты построения
а) | б)
в) | г)

Рис. 2.4.49. Сгиб детали с отверстием: а) положение линии сгиба, б) результат построения
а) | б)
Рис. 2.4.50. Использование вспомогательной оси в качестве линии сгиба: а) расположение оси, б) результат построения
а) | б)


2.4.4.5.2. Неподвижная сторона сгиба

При построении сгиба по линии в окне модели отображается фантомная стрелка (рис. 2.4.51). Она указывает прямое направление отсчета угла сгиба и его неподвижную сторону — ту часть базовой грани, положение которой при сгибе не изменится.

Рис. 2.4.51. Сгиб по линии: а) направление и неподвижная сторона, б) результат операции
а) | б)

Чтобы сделать неподвижной другую сторону, воспользуйтесь группой переключателей Неподвижная сторона.

Изменение неподвижной стороны немедленно отражается на положении стрелки в окне модели.


2.4.4.5.3. Способ формирования сгиба

При построении сгиба по линии вы можете выбрать способ его формирования из списка Способ сгиба (табл. 2.4.8). В таблице показаны схемы построения сгибов для различных величин и направлений отсчета углов.

Табл. 2.4.8. Схема построения сгиба в зависимости от способа формирования1
Значение опции Способ сгиба | Схема построения
По линии сгиба |
Линия сгиба снаружи |
Линия сгиба внутри |
По касанию |
  1. На схеме показана проекция детали на плоскость, перпендикулярную линии сгиба. Проекция базовой грани обозначена утолщенным отрезком, а проекция линии сгиба — кружком.


2.4.4.6. Подсечка

Вы можете создать в листовом теле сразу два сгиба по прямой линии относительно какой-либо грани этого тела. Указанные линия и грань будут считаться линией сгиба и базовой гранью подсечки.

Чтобы построить подсечку, вызовите команду Подсечка.

Укажите базовую грань подсечки и линию сгиба (см. раздел 2.4.4.6.1).

Выберите неподвижную сторону (см. раздел 2.4.4.5.2).

Выберите направление отсчета и интерпретацию угла (см. раздел 2.4.4.3.1).

Значение угла сгиба подсечки должно быть больше 0° и меньше 180°; дополняющего угла — больше 0° и меньше 360°.

Укажите величину и способ задания радиуса сгиба (см. раздел 2.4.4.3.2).

Выберите способ формирования сгиба (см. раздел 2.4.4.5.3).

Настройте освобождение угла (см. раздел 2.4.4.3.3).

Выберите состояние сгиба (см. раздел 2.4.4.3.4).

Настройте определение длины развертки сгиба (см. раздел 2.4.4.3.5).

Выбранные величина и способ задания радиуса, а также способ определения длины развертки по умолчанию используются для обоих сгибов подсечки. В дальнейшем каждому из сгибов можно будет назначить собственные параметры (см. раздел 2.4.4.3.6).

В этом разделе:

2.4.4.6.1. Исходные объекты и результат построения

2.4.4.6.2. Размер подсечки

2.4.4.6.3. Подсечка с добавлением материала и подсечка без добавления материала

2.4.4.6.4. Плоский участок подсечки


2.4.4.6.1. Исходные объекты и результат построения

В качестве линии сгиба для подсечки могут быть использованы следующие прямолинейные объекты:

– отрезок эскиза, построенного на внешней или внутренней плоской грани листового тела,

– сегмент ломаной,

– вспомогательная ось,

– прямолинейное ребро формообразующего элемента или поверхности.

Требования к линии сгиба:

– линия сгиба должна располагаться в плоскости базовой грани,

– линия сгиба должна иметь с базовой гранью хотя бы одну общую точку.

Вспомогательная ось показывается в модели в виде отрезка. Несмотря на это, ось является бесконечной прямой. Поэтому при выборе оси в качестве линии сгиба не важно, имеет ли изображающий ее отрезок общие точки с базовой гранью. Для корректного построения подсечки достаточно, чтобы продолжение оси имело общие точки с базовой гранью.

Результат построения подсечки зависит от взаимного расположения базовой грани и линии сгиба. Общее правило: сгибается та часть листового тела, которой принадлежит базовая грань или участок базовой грани, полностью или частично содержащий линию сгиба.

Если в качестве линии сгиба используется отрезок или сегмент ломаной, а сгибаемая грань имеет сложную форму, то для корректного построения сгиба рекомендуется располагать линию сгиба так, чтобы она непосредственно проходила по всем тем участкам, которые должны быть согнуты.

На рисунках 2.4.52–2.4.55 показаны варианты подсечек. В качестве базовой грани во всех представленных случаях используется верхняя плоская грань листового тела; линия сгиба показана утолщенной.

Рис. 2.4.52. Зависимость результата построения подсечки от положения линии сгиба: а), в) варианты положения линии сгиба, б), г) соответствующие результаты выполнения операции
а) | б)
в) | г)
Рис. 2.4.53. Использование вспомогательной оси в качестве линии сгиба подсечки: а) расположение оси, б) результат построения
а) | б)

Рис. 2.4.54. Использование ребра в качестве линии сгиба подсечки: а) расположение ребра, б) результат построения
а) | б)

Рис. 2.4.55. Подсечка в детали с отверстием: а) положение линии сгиба, б) результат построения
а) | б)


2.4.4.6.2. Размер подсечки

Используя переключатели группы Размер, выберите вариант задания высоты подсечки:

– Наружный размер подсечки,

– Внутренний размер подсечки,

– Полный размер подсечки.

Введите значение размера подсечки в поле Расстояние.


2.4.4.6.3. Подсечка с добавлением материала и подсечка без добавления материала

Опция С добавлением материала позволяет указать, требуется ли построение подсечки с добавлением материала или без добавления материала.

Подсечки с добавлением материала и без добавления материала, построенные с использованием одних и тех же линии сгиба и базовой грани, различаются по следующим признакам:

– форма прямоугольной проекции подсечки на базовую грань,

– форма разогнутой подсечки.

В качестве примера рассмотрим подсечку, исходный элемент которой показан на рисунке 2.4.56.

Рис. 2.4.56. Исходный элемент подсечки: а) изометрическая проекция, б) проекция исходного элемента на базовую грань
а) | б)

Сравнение результатов построения подсечки представлено в таблице 2.4.9.

Табл. 2.4.9. Подсечки с добавлением и без добавления материала1
Различающиеся признаки | Способ построения подсечки
 | С добавлением материала | Без добавления материала
проекция подсечки на базовую грань | ...совпадает с контуром проекции исходного элемента | ...не совпадает с контуром проекции исходного элемента
форма разогнутой подсечки | ...не совпадает с формой исходного элемента | ...совпадает с формой исходного элемента
  1. Линия сгиба показана утолщенной линией, проекция исходного элемента – штриховой.


2.4.4.6.4. Плоский участок подсечки

Между сгибами подсечки может находиться плоский участок. Его наличие зависит от соотношения заданного (Н) и минимального (Hmin) размеров подсечки (см. табл.2.4.10).

Hmin — минимальный внутренний размер подсечки без плоского участка — определяется по формуле:

Hmin = 2 · R - (2 · R + S) · cos a, где

R — внутренний радиус сгибов;

S — толщина листового материала;

a — угол сгиба.

Табл. 2.4.10. Определение наличия в подсечке плоского участка1
Соотношение между заданным и минимальным размерами подсечки
Н>Hmin | Н=Hmin | Н<Hmin
Подсечка с плоским участком. Значения параметров Н, R и a соответствуют заданным. | Подсечка без плоского участка — с перегибом. Значения параметров Н, R и a соответствуют заданным. | Подсечка без плоского участка. Параметры Н и R более приоритетны, поэтому значение, введенное в поле Угол, игнорируется. Величина угла сгиба a вычисляется системой автоматически на основе вышеприведенной формулы.
  1. На рисунках показана проекция подсечки на плоскость, перпендикулярную линии сгиба этой подсечки.


2.4.4.7. Замыкание углов

Замыкание угла — модификация двух смежных сгибов и их продолжений (рис. 2.4.57).

Рис. 2.4.57. Замыкание угла: а) исходное состояние детали, б), в), г) варианты замыкания угла
а) | б) | в) | г)

Смежными считаются сгибы, имеющие общее ребро, расположенное так, как показано на рис. 2.4.58.

Рис. 2.4.58. Смежные сгибы

Таким образом, сгибы, имеющие освобождения, а также сдвинутые друг относительно друга, смежными не являются (рис 2.4.59). Соответствующие им углы не могут быть замкнуты.

Рис. 2.4.59. Примеры несмежных сгибов

Плоские части листового тела, модифицируемые при замыкании угла, называются сторонами угла.

Для корректного построения замыкания углов рекомендуется, чтобы радиусы, углы и длины продолжений смежных сгибов были попарно равны.

Замыкание угла характеризуется следующими параметрами:

– способ (см. раздел 2.4.4.7.1),

– обработка угла (см. раздел 2.4.4.7.2),

– зазор (см. раздел 2.4.4.7.3),

– продолжение (см. раздел 2.4.4.7.4).

От выбранного способа замыкания зависит принцип построения замыкания угла. Принципы построения описаны в разделах 2.4.4.7.5 и 2.4.4.7.6.

В этом разделе:

2.4.4.7.1. Способы замыкания

2.4.4.7.2. Обработка угла

2.4.4.7.3. Зазор

2.4.4.7.4. Продолжение замыкания

2.4.4.7.5. Принцип построения замыкания встык и плотного замыкания

2.4.4.7.6. Принцип построения замыкания с перекрытием

2.4.4.7.7. Выполнение замыкания


2.4.4.7.1. Способы замыкания

Чтобы указать способ замыкания, раскройте список Тип на вкладке Параметры Панели свойств и выберите из него нужную строку (табл. 2.4.11).

Табл. 2.4.11. Способы замыкания угла
Значение опции Способ | Результат построения
Замыкание встык |
Замыкание с перекрытием |
Плотное замыкание |

При выборе варианта Замыкание с перекрытием в окне модели появляется фантомная стрелка. Она располагается на той стороне угла, которая будет перекрывать вторую сторону. Чтобы выбрать другой вариант перекрытия, нажмите кнопку Изменить перекрытие. Положение стрелки в окне модели изменится.


2.4.4.7.2. Обработка угла

Чтобы указать способ обработки угла при замыкании, раскройте список Обработка угла и выберите из него нужную строку. Примеры вариантов обработки угла в сочетании с различными способами замыкания приведены в таблице 2.4.12.

Табл. 2.4.12. Варианты обработки угла при замыкании различными способами
 | Замыкание встык | Замыкание с перекрытием | Плотное замыкание
Без обработки |  |  |
Круговая |  | — |
Стык по кромке |  | — |
Стык по хорде |  |  |

Варианты Круговая, Стык по кромке и Стык по хорде доступны, если смежные сгибы имеют одинаковые углы и одинаковые радиусы. При этом стык по хорде возможен при всех способах замыкания, а стык по кромке и круговая обработка — только для замыкания встык и плотного замыкания.

Если используется Плотное замыкание с обработкой угла Стык по кромке или Круговая, то при нулевом или малом зазоре возможно перекрытие разверток смежных сгибов. Во избежание этого рекомендуется подбирать такую величину зазора, при которой перекрытие исключено.

Круговая обработка угла представляет собой обработку угла способом Стык по кромке с добавлением круглого отверстия. Центр отверстия размещается на прямой, проходящей через точку угла и точку пересечения линий сгибов. Порядок построения замыкания угла с круговой обработкой показан на рис. 2.4.60.

При выборе круговой обработки пользователю требуется задать дополнительные параметры.

Рис. 2.4.60. Построение замыкания угла с круговой обработкой: а) построение замыкания угла с обработкой Стык по кромке; б) размещение отверстия; в) результат построения
а) | б) | в)

Параметры круговой обработки угла

При выборе способа обработки угла Круговая на Панели свойств появляются элементы управления отверстием.

– Размещение отверстия.
Укажите вариант размещения отверстия, выбрав нужный переключатель группы (табл. 2.4.13).

– Диаметр.
Введите значение диаметра отверстия в поле Диаметр.

– Смещение.
Введите в поле Смещение расстояние смещения отверстия вдоль прямой, содержащей его центр. При положительном значении отверстие смещается к точке угла, при отрицательном — к точке пересечения линий сгибов.

Табл. 2.4.13. Варианты размещения отверстия
Значение опции Размещение отверстия | Правила размещения отверстия | Результат построения
Отверстие на пересечении сгибов | Центр отверстия находится в точке пересечения линий сгибов. |
Отверстие в точке угла | Центр отверстия находится в точке угла. |
Отверстие через точку угла | Отверстие проходит через точку угла. |

Замыкание углов с круговой обработкой невозможно, если:

– отверстие с текущим значением диаметра разделяет листовое тело на отдельные части (о телах из частей см. раздел 2.3.11),

– отверстие с текущими параметрами (диаметр и смещение) не имеет пересечений с цилиндрическими гранями сгибов.


2.4.4.7.3. Зазор

Зазор — расстояние, на котором будут расположены друг от друга стороны замыкаемого угла. Зазор измеряется в проекции листового тела на плоскость, перпендикулярную сторонам угла. Такой плоскостью может служить любая плоскость, перпендикулярная линии пересечения внешних или внутренних граней сторон угла (рис. 2.4.61, а). В этой же плоскости измеряется замыкаемый угол (рис. 2.4.61, б).

Рис. 2.4.61. Измерение зазора: а) определение положения плоскости измерения, б) проекция детали на плоскость измерения (вид по стрелке); замыкаемый угол
а) | б)

Для ввода величины зазора служит поле Зазор на вкладке Параметры Панели свойств.


2.4.4.7.4. Продолжение замыкания

Включите опцию Продолжить, если требуется замкнуть парные сгибы, примыкающие к сторонам замыкаемого угла.

Продолжение замыкания возможно при выполнении следующих требований:

– к смежным сгибам:

• попарно равны радиусы и углы (при замыкании с перекрытием — также длины продолжений),

• боковые стороны, обращенные к замыкаемому углу, не имеют расширений,

– к примыкающим сгибам:

• сгибы не имеют смещения и/или освобождения,

• боковые стороны, обращенные к замыкаемому углу, не имеют расширений,

• размещение сгибов на ребрах таково, что каждый сгиб начинается от той вершины ребра, которая обращена к замыкаемому углу,

• при замыкании с перекрытием: радиусы, углы и длины продолжений попарно равны.

Рис. 2.4.62. Замыкание сгиба: а) исходное состояние детали, б) замыкание без продолжения, в) замыкание с продолжением
а) | б) | в)

Продолжение замыкания производится до первой пары примыкающих сгибов, не удовлетворяющих требованиям к ним.


2.4.4.7.5. Принцип построения замыкания встык и плотного замыкания

Рассмотрим принцип построения замыкания встык и плотного замыкания на примере детали, показанной на рис. 2.4.63.

Рис. 2.4.63. Замыкание встык: а) исходное состояние детали, б) результат замыкания угла (зазор отличен от нуля)
а) | б)

Положение сторон угла определяется следующим образом.

1. В плоскости измерения зазора строится биссектриса замыкаемого угла (рис. 2.4.64, а).

2. С каждой стороны от биссектрисы на расстоянии, равном половине величины зазора, проводятся параллельные линии (рис. 2.4.64, а).

3. Стороны угла продолжаются до соприкосновения с полученными линиями (рис. 2.4.64, б). При плотном замыкании стороны угла дополнительно модифицируются: их боковые грани становятся параллельны биссектрисе (рис. 2.4.64, в).

Рис. 2.4.64. Определение положения сторон угла при замыкании встык и плотном замыкании
а) | б) | в)

Минимальное значение зазора — 0, максимальное определяется, как показано на рис. 2.4.65.

Рис. 2.4.65. Максимальный зазор при замыкании встык


2.4.4.7.6. Принцип построения замыкания с перекрытием

Замыкание с перекрытием строится по-разному в зависимости от того, каким оказывается замыкаемый угол — острым или тупым.

Рассмотрим принцип построения замыкания с перекрытием на примере деталей, показанных на рис. 2.4.66.

Рис. 2.4.66. Замыкание с перекрытием (исходное состояние детали и результат операции):
а) замыкаемый угол острый, б) замыкаемый угол тупой

а)

б)

На величину замыкаемого угла влияет взаимное положение сгибов (угол между линиями сгибов), а также углы самих сгибов.

Замыкание с перекрытием строится следующим образом.

1. В плоскости измерения зазора строится прямая — след плоскости внешней грани перекрываемой стороны угла (рис. 2.4.67, а; 2.4.68, а).

2. Перекрывающая сторона продолжается до соприкосновения с этой прямой (рис. 2.4.67, б; 2.4.68, б).

3. Перекрываемая сторона продолжается до тех пор, пока расстояние между ней и перекрывающей стороной не станет равным заданному зазору.

3.1. Если замыкаемый угол острый, то зазор измеряется так, как показано на рис. 2.4.67, в.

3.2. Если замыкаемый угол тупой, то зазор измеряется так, как показано на рис. 2.4.68, в.

Рис. 2.4.67. Построение замыкания с перекрытием для острого угла: а), б) определение положения перекрывающей стороны, в) определение положения перекрываемой стороны
а) | б) | в)

Рис. 2.4.68. Построение замыкания с перекрытием для тупого угла: а), б) определение положения перекрывающей стороны, в) определение положения перекрываемой стороны
а) | б) | в)

Минимальное значение зазора — 0, максимальное определяется, как показано на рис. 2.4.69.

Рис. 2.4.69. Максимальный зазор при замыкании с перекрытием: а) замыкаемый угол острый, б) замыкаемый угол тупой
а) | б)


2.4.4.7.7. Выполнение замыкания

Чтобы замкнуть один или несколько углов листового тела, вызовите команду Замыкание углов.

Выберите пару смежных сгибов одним из способов, представленных на рис. 2.4.70. Для этого укажите:

– общее ребро смежных сгибов (рис. 2.4.70, а),

– боковую грань (или ребро боковой грани) одного из смежных/примыкающих сгибов или его продолжения (рис. 2.4.70, б),

– грани, принадлежащие смежным или примыкающим сгибам (цилиндрические грани сгибов, плоские грани продолжений), или ребра этих граней (рис. 2.4.70, в).

Рис. 2.4.70. Способы указания замыкаемого угла
а) | б) | в)

В окне модели подсветятся боковые грани выбранных смежных сгибов и соответствующие грани их продолжений (стороны замыкаемого угла).

Вы можете указать несколько углов для замыкания. Их список отображается на панели Углы (рис. 2.4.71).

Рис. 2.4.71. Панель Углы

Чтобы удалить угол, повторно укажите его в графической области либо выделите угол в списке и активизируйте переключатель Удалить.

Чтобы очистить весь список, активизируйте переключатель Исключить все.

После указания замыкаемого угла на Панели свойств появляются элементы для настройки параметров замыкания.

Опция Единые параметры позволяет применить одинаковые параметры замыкания ко всем выбранным углам.

По умолчанию опция включена. Если требуется настроить параметры замыкания отдельно для каждого угла, отключите опцию, выделите угол на панели Углы и задайте требуемые параметры.

Выберите способ замыкания (см. раздел 2.4.4.7.1).

Выберите вариант обработки угла (см. раздел 2.4.4.7.2).

Задайте зазор, с которым требуется замкнуть угол (см. раздел 2.4.4.7.3).

При необходимости включите опцию Продолжить (см. раздел 2.4.4.7.4).

Завершив настройку замыкания углов, нажмите кнопку Создать объект на Панели специального управления.

Выбранные углы будут замкнуты, а в Дереве построения появится пиктограмма замыкания углов.

Особенности использования единых параметров замыкания

Замыкание углов с включенной опцией Единые параметры невозможно, если один или несколько выбранных углов не могут быть замкнуты с текущими параметрами. В списке замыкаемых углов такие углы отмечаются надписью Ошибочный параметр (рис. 2.4.72).

Чтобы создать замыкание углов, необходимо выполнить одно из следующих действий:

– изменить параметры замыкания так, чтобы замыкание было возможно для всех углов,

– отключить опцию Единые параметры и отредактировать параметры замыкания ошибочного угла так, чтобы выполнение операции было возможно,

– удалить ошибочный угол из списка замыкаемых углов.

Рис. 2.4.72. Пример списка углов с надписью Ошибочный параметр

Примеры смежных сгибов, замыкание угла между которыми невозможно

В некоторых случаях смежные сгибы имеют такие параметры или располагаются друг относительно друга так, что замыкание угла становится невозможным (рис. 2.4.73).

Рис. 2.4.73. Примеры смежных сгибов, замыкание угла между которыми невозможно


2.4.4.8. Сгиб по эскизу

Вы можете создать в листовом теле сгиб по эскизу — элемент с несколькими сгибами, профиль которого определяется контуром в эскизе (рис. 2.4.74). Сгиб по эскизу располагается вдоль прямолинейного ребра (или нескольких прямолинейных ребер). Это ребро будет считаться линией сгиба, а содержащая его грань (внешняя или внутренняя) — базовой гранью сгиба.

Рис. 2.4.74. Сгиб по эскизу: а) эскиз сгиба, б) сгиб вдоль одного ребра, в) сгиб вдоль нескольких ребер
а) | б) | в)

Чтобы построить сгиб по эскизу, укажите эскиз и вызовите команду Сгиб по эскизу.

Выберите способ построения сгиба и укажите ребро или последовательность ребер, вдоль которых должен располагаться сгиб (см. раздел 2.4.4.8.2).

Укажите величину и способ задания радиуса сгиба (см. раздел 2.4.4.3.2).

Настройте определение длины развертки сгиба (см. раздел 2.4.4.3.5).

Выберите состояние сгиба (см. раздел 2.4.4.3.4).

Выбранные величина и способ задания радиуса, а также способ определения длины развертки по умолчанию используются для всех сгибов создаваемого элемента. В дальнейшем каждому из сгибов можно будет назначить собственные параметры (см. раздел 2.4.4.3.6).

В этом разделе:

2.4.4.8.1. Требования к эскизу

2.4.4.8.2. Способ построения

2.4.4.8.3. Замыкание углов

2.4.4.8.4. Освобождение


2.4.4.8.1. Требования к эскизу

– Эскиз должен располагаться в плоскости, перпендикулярной ребру, вдоль которого будет расположен сгиб.

– Объекты эскиза должны составлять один контур.

– Контур должен быть разомкнут.

– Контур должен начинаться от точки — проекции ребра, вдоль которого будет расположен сгиб.

– Контур может состоять только из отрезков и дуг окружности. Дуги должны соединяться с отрезками и другими дугами в точках касания.

– Если первый объект контура — дуга, она должна быть касательна к проекции базовой грани сгиба.

Как и при создании листового тела по незамкнутому эскизу, углы контура формируют сгибы с заданным пользователем внутренним радиусом, а дуги — сгибы, радиусы которых равны радиусам соответствующих дуг.


2.4.4.8.2. Способ построения

Выберите способ построения сгиба по эскизу, используя группу переключателей Способ. Способ построения сгиба определяет возможности задания ширины сгиба.

– Если выбран способ построения По ребру, то сгиб располагается вдоль одного ребра. Ширина сгиба равна длине ребра (рис. 2.4.75).

Рис. 2.4.75. Сгиб По ребру: а) исходное состояние модели и эскиз сгиба, б) результат построения
а) | б)

– Если выбран способ построения На расстояние, то сгиб также располагается вдоль одного ребра. Ширина сгиба задается пользователем и может откладываться в разные стороны от плоскости эскиза (рис. 2.4.76). Для выбора направления построения служит список Направление на Панели свойств. Этот список содержит варианты Прямое направление, Обратное направление, Два направления, Средняя плоскость. Прямое направление построения показано стрелкой на фантоме сгиба в окне модели. Для ввода значений ширины служат поля Ширина 1 и/или Ширина 2.

Рис. 2.4.76. Сгиб На расстояние: а) в одном направлении от плоскости эскиза, б) в двух направлениях
а) | б)

– Если выбран способ построения Последовательность ребер, то сгиб может располагаться вдоль цепочки прямолинейных ребер. Ребра следует указывать в порядке расположения. Ребра, образующие цепочку, могут соединяться друг с другом вершинами (рис. 2.4.77, а) или сгибами (рис. 2.4.77, б).

Рис. 2.4.77. Сгиб вдоль цепочки ребер: а) соединенных вершиной, б) соединенных сгибом
а) | б)

Для построения сгиба вдоль ребер, соединенных сгибами, необходимо указывать не только прямолинейные ребра, но и сопрягающие их дуговые ребра.


2.4.4.8.3. Замыкание углов

Для настройки замыкания углов при построении сгиба по эскизу служат элементы управления вкладки Замыкание углов на Панели свойств (рис. 2.4.78).

Рис. 2.4.78. Вкладка Замыкание углов

Переключатель Замыкание смежных углов доступен, если сгиб строится вдоль цепочки ребер, соединенных вершинами. Этот переключатель позволяет настроить замыкание углов на стыках ребер цепочки (рис. 2.4.79): выбрать способ замыкания, обработку угла и задать расстояние между сторонами угла. Настройка производится так же, как при выполнении команды Замыкание (см. разделы 2.4.4.7.1–2.4.4.7.3), с единственным отличием: отсутствует способ замыкания С перекрытием.

Рис. 2.4.79. Сгиб вдоль цепочки ребер: а) без замыкания углов, б) с замыканием (один из вариантов)
а) | б)

Переключатели Замыкание в начале и Замыкание в конце доступны, если сгиб строится вдоль одного ребра или разомкнутой цепочки ребер. Эти переключатели позволяют придать начальной и конечной кромкам сгиба по эскизу форму, необходимую для замыкания с предполагаемым смежным сгибом (например, для последующей стыковки с другой деталью). Так как смежные сгибы для начальной и конечной кромок отсутствуют, замыкание производится относительно плоскости a, проходящей через конечную точку сгиба A (рис. 2.4.80, а).

Чтобы задать положение плоскости a, введите в поле Угол1 (или Угол 2) значение угла между нею и плоскостью, перпендикулярной линии сгиба. Значение угла может быть как положительным, так и отрицательным.

При необходимости введите в поле Отступ 1 (или Отступ 2) расстояние, на котором кромка сгиба должна располагаться от плоскости a (рис. 2.4.80, б). Значение отступа может быть только положительным; нулевой отступ означает, что кромка сгиба будет находиться в плоскости a.

Рис. 2.4.80. Сгиб с замыканием в начале и конце: а) точка А и плоскость a, б) вид сверху; отступ и угол
а) | б)

Выбор способа замыкания и обработки угла производится так же, как при выполнении команды Замыкание (см. разделы 2.4.4.7.1 и 2.4.4.7.2), с единственным отличием: отсутствует способ замыкания С перекрытием.

Построение сгиба по эскизу невозможно, если для замыкания в начале или в конце задан отрицательный угол и выбран способ обработки Без обработки.

Обратите внимание на следующую особенность построения сгиба по эскизу с замыканием вдоль цепочки ребер. В случае, когда цепочка включает ребра, образующие внутренний угол грани (рис. 2.4.81), построение возможно с любым способом обработки угла, кроме способа Без обработки. При этом, если внутренний угол меньше 90°, то замыкание создается при условии, что первый элемент в эскизе сгиба — дуга (рис. 2.4.82). Если же первый элемент эскиза — отрезок, то замыкание невозможно.

Рис. 2.4.81. Внутренний и внешний углы грани листового тела | Рис. 2.4.82. Эскиз, начинающийся с дуги


2.4.4.8.4. Освобождение

Для настройки освобождения сгиба и угла при построении сгиба по эскизу служат элементы управления вкладки Освобождение на Панели свойств (рис. 2.4.83).

Рис. 2.4.83. Вкладка Освобождение

Переключатель Освобождение сгиба доступен, если способ построения сгиба — По ребру или На расстояние. Активизируйте этот переключатель, если требуется создать пазы по бокам сгиба. После активизации переключателя становятся доступны элементы управления формой и размерами пазов. Подробно освобождение сгиба описано в разделе 2.4.4.4.5.

Если при создании сгиба по эскизу требуется удалить части соседних сгибов, активизируйте переключатель Освобождение угла и выберите нужный способ освобождения. Подробно освобождение угла описано в разделе 2.4.4.3.3.

Способ освобождения Только сгиб можно использовать для удаления частей сгибов, соединяющих ребра цепочки (рис. 2.4.84).

Рис. 2.4.84. Сгиб вдоль цепочки ребер, соединенных сгибами: а) без освобождения угла, б) с освобождением угла
а) | б)


2.4.5. Пластины

2.4. Листовые тела

2.4.5. Пластины

Пластина — плоский элемент, приклеенный к листовому телу. Пластина формируется путем выдавливания замкнутого эскиза. Глубина выдавливания может быть произвольной или равной толщине материала тела.

Перед добавлением пластины к листовому телу в модели необходимо создать эскиз, определяющий форму пластины.

В этом разделе:

2.4.5.1. Требования к эскизу пластины

2.4.5.2. Формирование пластины


2.4.5.1. Требования к эскизу пластины

– Эскиз должен располагаться на внешней или внутренней плоской грани листового тела или листового элемента.

– Объекты эскиза могут составлять один или несколько контуров.

– Контуры должны быть замкнуты.

– Контуры могут быть вложенными. Уровень вложенности — один.

– Внешний контур должен пересекаться с контуром базовой грани или иметь с ним общие точки.


2.4.5.2. Формирование пластины

Чтобы построить пластину, вызовите команду Пластина.

Команда Пластина доступна, если выделен один эскиз.

В окне модели появится фантомное изображение создаваемой пластины. Стрелкой показано направление выдавливания. Это направление определяется системой автоматически.

Список Объект толщины на вкладке Параметры Панели свойств позволяет указать, будет ли толщина пластины совпадать с текущей толщиной листового тела или будет равна постоянной величине, заданной пользователем.

Раскройте список Объект толщины и выберите из него нужное листовое тело. Толщина выбранного тела отображается в справочном поле Толщина.

Если требуется задать произвольную толщину пластины, выберите в списке Объект толщины строку Без объекта. Поле Толщина станет доступно для редактирования. Введите в него нужное значение.

Чтобы подтвердить формирование пластины в листовом теле, нажмите кнопку Создать объект на Панели специального управления.

В окне модели появится созданная пластина, а в Дереве построения — соответствующая пиктограмма.

Рис. 2.4.85. Создание пластины: а) исходное состояние детали и эскиз пластины, б) результат операции
а) | б)

Если пластина полностью или частично перекрывает сгиб, то его разгибание делается невозможным. Подробнее об этом рассказано в разделе 2.4.7.3.


2.4.6. Отверстия

2.4. Листовые тела

2.4.6. Отверстия

В листовом теле возможно создание круглых отверстий и отверстий произвольного профиля — вырезов.

Для формирования круглых отверстий и вырезов служат команды Отверстие в листовом теле и Вырез в листовом теле соответственно. Подробное описание этих команд приведено в разделах 2.4.6.1 и 2.4.6.2.

Для создания отверстий в листовом теле рекомендуется пользоваться именно командами Отверстие в листовом теле и Вырез в листовом теле, поскольку они учитывают характерные особенности листовых тел.

Отверстия и вырезы могут разделять листовое тело на несколько частей (о телах из частей см. раздел 2.3.11).

В листовом теле, состоящем из частей, невозможно создание новых сгибов, изменение состояния существующих, замыкание сгибов, а также построение вырезов и отверстий способом По толщине. Для того чтобы эти операции можно было выполнить, необходимо сделать тело целым, отредактировав имеющиеся элементы или создав новые элементы, которые соединят части.

В этом разделе:

2.4.6.1. Отверстие

2.4.6.2. Вырез

2.4.6.2.1. Требования к эскизу

2.4.6.2.2. Формирование выреза


2.4.6.1. Отверстие

Чтобы создать в листовом теле круглое отверстие, выделите грань, на которой оно будет расположено, и вызовите команду Отверстие в листовом теле.

В окне модели появится фантом отверстия.

По умолчанию центр отверстия размещается в начале локальной системы координат выбранной грани.

Чтобы расположить отверстие в нужном месте грани, введите значения координат в поле т на вкладке Панели свойств Параметры. Вы можете также указать положение отверстия мышью. Для этого расфиксируйте поле т и укажите нужную точку в окне модели. Координаты выбранной точки будут определены автоматически.

Введите диаметр отверстия в поле Диаметр.

Для задания положения и диаметра отверстия можно использовать характерные точки (см. раздел 2.1.4.2.2) или геометрический калькулятор (см. раздел 1.4.2.13.2).

Все сделанные изменения немедленно отражаются на фантоме отверстия в окне модели.

В группе Тип активизируйте переключатель, соответствующий нужному способу построения (см. табл. 2.4.14).

Табл. 2.4.14. Тип построения отверстия

Значение опции Тип построения

Правила построения

По толщине

Отверстие проходит от указанной грани к противоположной ей в направлении, перпендикулярном этим граням.

Если отверстие захватывает сгиб или сгиб вместе с примыкающими к нему частями листового тела, то оно переходит на этот сгиб и примыкающие части как «обертка».

Построение отверстия данным способом возможно при выполнении следующих условий:

– для построения отверстия должна быть указана внешняя или внутренняя плоская грань листового тела,

– отверстие должно пересекаться с указанной гранью.

Список Объект толщины на вкладке Параметры Панели свойств позволяет указать, будет ли глубина отверстия совпадать с текущей толщиной листового тела или будет равна постоянной величине, заданной пользователем.

Раскройте список Объект толщины и выберите из него нужное листовое тело. Толщина выбранного тела отображается в справочном поле Толщина.

Если требуется задать произвольную толщину, выберите в списке Объект толщины строку Без объекта. Поле Толщина станет доступно для редактирования. Введите в него нужное значение.

На глубину1

Построение отверстия данным способом есть вырезание элемента выдавливания с заданием произвольного расстояния выдавливания. Выдавливание производится перпендикулярно грани, выбранной для построения отверстия. Направление выдавливания — внутрь по отношению к листовому телу.

Чтобы задать расстояние выдавливания, введите его в поле Глубина на вкладке Параметры Панели свойств.

Если отверстие захватывает сгиб, то оно не переходит на него как «обертка».

До грани1

Построение отверстия данным способом есть вырезание элемента выдавливания с указанием объекта для автоматического определения расстояния выдавливания. Выдавливание производится перпендикулярно грани, выбранной для построения отверстия. Направление выдавливания — внутрь по отношению к листовому телу.

Чтобы задать объект, ограничивающий расстояние выдавливания, укажите его в окне модели. В качестве этого объекта может использоваться грань, поверхность, базовая или вспомогательная плоскость.

Если отверстие захватывает сгиб, то оно не переходит на него как «обертка».
  1. Если в файле редактируемой модели присутствует несколько листовых тел, то при построении отверстия данным способом необходимо указать листовое тело, в котором будет создано это отверстие. Чтобы указать тело щелкните по нему мышью в окне модели.
    Для смены листового тела используйте кнопку Указать заново на Панели специального управления.

Чтобы подтвердить формирование отверстия, нажмите кнопку Создать объект на Панели специального управления.

В листовом теле появится круглое отверстие, а в Дереве построения — его пиктограмма.

При создании отверстия в модели автоматически формируется эскиз. Он располагается на грани, указанной для построения отверстия, и содержит вспомогательную точку, находящуюся в центре отверстия.

Если отверстие захватывает сгиб, то при изменении состояния сгиба (см. раздел 2.4.7.1) отверстие перестраивается. Получившаяся в результате форма отверстия зависит от способа его построения и от того, в каком состоянии находился сгиб во время создания отверстия.

Рассмотрим примеры создания и перестроения отверстий, захватывающих сгибы, на примере детали, показанной на рис. 2.4.86.

Рис. 2.4.86. Исходное состояние детали. Центры будущих отверстий (расположенные на невидимых гранях) обозначены «крестиками»

Перестроение отверстий, построенных По толщине, показано на рис. 2.4.87.

Рис. 2.4.87. Отверстия, построенные способом По толщине: а) вид детали сразу после создания отверстий, б) результат изменения состояния сгибов
а) | б)

Перестроение отверстий, построенных На глубину, показано на рис. 2.4.88. Отверстия, построенные До грани, перестраиваются аналогично.

Рис. 2.4.88. Отверстия, построенные способом На глубину: а) вид детали сразу после создания отверстий, б) результат изменения состояния сгибов
а) | б)


2.4.6.2. Вырез

Перед формированием выреза в листовом теле необходимо создать на его грани эскиз, изображающий профиль этого выреза.

В этом разделе:

2.4.6.2.1. Требования к эскизу

2.4.6.2.2. Формирование выреза


2.4.6.2.1. Требования к эскизу

– Объекты эскиза могут составлять один или несколько контуров.

– Контуры должны быть замкнутыми.

– Эскиз должен располагаться только на внешней или внутренней плоской грани листового тела (для построения выреза способом По толщине).


2.4.6.2.2. Формирование выреза

Вызовите команду Вырез в листовом теле.

Команда Вырез доступна, если выделен один эскиз (эскиз выреза).

В окне модели появится фантом выреза.

Выберите тип построения выреза. В группе Тип на вкладке Параметры Панели свойств активизируйте переключатель, соответствующий нужному типу построения. Правила построения для вырезов такие же, как для отверстий (см. табл. 2.4.14).

Укажите, какая часть листового тела должна быть отсечена при вырезании. Для этого активизируйте нужный переключатель в группе Результат операции на вкладке Вырезание.

Если активен переключатель Вычитание элемента, то будет удалена часть тела, находящаяся внутри поверхности, образованной перемещением эскиза выреза (рис. 2.4.89, б).

Если активен переключатель Пересечение элементов, то будет удалена часть тела, находящаяся снаружи этой поверхности (рис. 2.4.89, в).

Рис. 2.4.89. Результат построения выреза в листовом теле: а) исходное состояние детали и эскиз выреза, б) вырез вычитанием, в) вырез пересечением
а) | б) | в)

Чтобы подтвердить формирование выреза, нажмите кнопку Создать объект на Панели специального управления.

В листовом теле появится вырез, а в Дереве построения — его пиктограмма.

Если вырез захватывает сгиб, то при изменении состояния сгиба (см. раздел 2.4.7.1) вырез перестраивается. Получившаяся в результате форма выреза зависит от способа его построения и от того, в каком состоянии находился сгиб во время создания выреза.

Рассмотрим варианты создания и перестроения вырезов, захватывающих сгибы, на примере детали, показанной на рис. 2.4.90.

Рис. 2.4.90. Исходное состояние детали. Эскизы вырезов
(расположенные на невидимых гранях) показаны основной штриховой линией

Перестроение вырезов, построенных По толщине, показано на рис. 2.4.91.

Рис. 2.4.91. Вырезы, построенные способом По толщине: а) вид детали сразу после создания вырезов, б) результат изменения состояния сгибов
а) | б)

Перестроение вырезов, построенных На глубину, показано на рис. 2.4.92. Вырезы, построенные До грани, перестраиваются аналогично.

Рис. 2.4.92. Вырезы, построенные способом На глубину: а) вид детали сразу после создания вырезов, б) результат изменения состояния сгибов
а) | б)


2.4.7. Разгибание и сгибание сгибов. Развертка

2.4. Листовые тела

2.4.7. Разгибание и сгибание сгибов. Развертка

Любой сгиб (полученный как с помощью команд Сгиб, Сгиб по линии, Сгиб по эскизу, Подсечка, так и при создании листового тела на основе разомкнутого эскиза или обечайки) может находиться в согнутом или разогнутом состоянии.

По умолчанию сгибы формируются в согнутом состоянии. При необходимости во время создания (редактирования) сгиба или листового тела ему можно присвоить признак «разогнуто». Этим признаком можно также управлять с помощью команд Разогнуть и Согнуть в контекстном меню элемента (см. раздел 2.4.4.3.4).

Кроме того, существуют специальные команды для изменения состояния одного или сразу нескольких сгибов: Разогнуть и Согнуть.

Команда Разогнуть может быть применена к сгибам, не имеющим признака «разогнуто», а также к сгибам, согнутым с помощью команды Согнуть.

Команда Согнуть может быть применена к сгибам, имеющим признак «разогнуто», а также к сгибам, разогнутым с помощью команды Разогнуть.

Работа с указанными командами подробно рассмотрена в разделе 2.4.7.1.

Присвоение признака «разогнуто» листовому элементу с несколькими сгибами (например, подсечке) означает разгибание всех его сгибов, в то время как команда Разогнуть позволяет разогнуть сгибы выборочно.

Описанные способы управления состоянием сгибов могут применяться в любое время при редактировании листового тела. Однако их действия не равнозначны.

Различие между командами Разогнуть и Согнуть из контекстного меню листового элемента и командами Разогнуть и Согнуть из меню Операции — Элементы листового тела состоит в следующем.

Использование первой пары команд — это редактирование отдельного элемента: изменяются состояния сгибов, входящих в состав этого элемента, в то время как использование второй пары — это редактирование листового тела в целом: в нее добавляется операция Разогнуть или Согнуть.

Как и любое редактирование, редактирование листовых элементов с помощью команд Разогнуть и Согнуть из контекстного меню может приводить к ошибкам в объектах, производных от этих элементов (отверстиях, вырезах и т.п.).

Редактирование листовых элементов с помощью команд Разогнуть и Согнуть из меню Операции — Элементы листового тела к ошибкам, естественно, не приводит. Однако, такое редактирование увеличивает общее количество операций в модели, а следовательно, и время ее обработки (время открытия файла, перестроения модели, создания ассоциативных видов и т.п.).

Таким образом, если листовой элемент не имеет производных объектов (это можно выяснить, например, с помощью команды Отношения), то его состояние можно изменять с помощью команд контекстного меню. В противном случае лучше использовать команды из меню Операции — Элементы листового тела.

Если известно, что для создания каких-либо элементов необходимо, чтобы определенные сгибы были разогнуты, то целесообразным будет следующий порядок работы.

1. Постройте листовые элементы в разогнутом состоянии.

2. Постройте производные от них объекты.

3. Согните сгибы с помощью команды Операции — Элементы листового тела — Согнуть.

Приведенная схема позволяет не вводить дополнительную операцию разгибания.

Кроме вышеописанных приемов изменения состояния сгибов, существует специальный режим отображения листового тела — представление в развернутом виде. В этом режиме выбранные пользователем сгибы показываются в согнутом состоянии, а остальные — в разогнутом.

Состояния сгибов, установленные во время редактирования листового тела, при переходе в режим развернутого отображения игнорируются.

В данном режиме возможен просмотр модели, а также измерение ее геометрических и массо-центровочных характеристик. Редактирование модели в режиме развертки невозможно.

Настройка и включение режима отображения листового тела в развернутом виде рассмотрены в разделе 2.4.7.2.

В этом разделе:

2.4.7.1. Разгибание и сгибание

2.4.7.1.1. Неподвижная грань или плоскость

2.4.7.1.2. Выбор сгибов

2.4.7.2. Развертка

2.4.7.2.1. Параметры развертки

2.4.7.2.2. Ориентация Развертка

2.4.7.2.3. Удаление параметров развертки

2.4.7.3. Особенности разгибания и сгибания

2.4.7.4. Чертеж развертки


2.4.7.1. Разгибание и сгибание

Чтобы разогнуть или согнуть сгиб (несколько сгибов) листового тела, вызовите команду Разогнуть или Согнуть соответственно.

После вызова команды необходимо задать плоскость разгибания/сгибания и сгибы, состояние которых требуется изменить. Для этого используются элементы, появляющиеся на вкладке Параметры Панели свойств.

Подробно назначение элементов и работа с ними описаны в разделах 2.4.7.1.1 и 2.4.7.1.2.

Завершив настройку разгибания или сгибания, нажмите кнопку Создать объект на Панели специального управления.

Листовое тело будет перестроено в соответствии с заданными параметрами разгибания или сгибания, а в Дереве построения появится пиктограмма разгибания или сгибания.

В этом разделе:

2.4.7.1.1. Неподвижная грань или плоскость

2.4.7.1.2. Выбор сгибов


2.4.7.1.1. Неподвижная грань или плоскость

В результате разгибания или сгибания любого сгиба часть листового тела, примыкающая к этому сгибу с одной стороны, поворачивается относительно части, примыкающей к сгибу с другой стороны. Другими словами, одна часть тела остается неподвижной относительно ее системы координат, а другая — перемещается.

При разгибании/сгибании необходимо задать неподвижную грань или плоскость.

Неподвижная грань — любая плоская грань листового тела, принадлежащая той ее части, которая остается неподвижной в результате сгибания или разгибания сгиба (сгибов).

Зависимость результата операции от выбора неподвижной грани показана на рис 2.4.93 на примере разгибания сгиба.

Рис. 2.4.93. Зависимость результата разгибания от выбора плоскости разгибания: а) исходное состояние детали, б) плоскость разгибания — грань А, в) плоскость разгибания — грань Б
а) | б) | в)

Неподвижная плоскость — вспомогательная плоскость, касательная к сгибу, которая в процессе разгибания или сгибания сгиба (сгибов) будет оставаться неподвижной и в которой будет располагаться разогнутый сгиб (сгибы).

Объекты, которые могут быть выбраны для задания неподвижной плоскости:

– Грань сгиба (цилиндрическая, коническая) — указывается внешняя грань сгиба. Вспомогательная плоскость создается автоматически и располагается в одной из вершин грани (рис. 2.4.94).

– Вспомогательная плоскость, касательная к грани сгиба (цилиндрической, конической) листового тела.

Вспомогательная плоскость нужного положения может быть создана пользователем заранее с помощью команды Касательная плоскость или Плоскость, касательная к грани в точке на панели Вспомогательная геометрия.

Рис. 2.4.94. Разгибание листового тела: а) исходное состояние детали, б) результат разгибания сгиба 2 (при указании грани сгиба 1)
а) | б)

Чтобы задать неподвижную грань или плоскость, активизируйте переключатель Плоскость и укажите нужный объект в окне модели.

При разгибании тела после указания грани сгиба в модели появляется вспомогательная плоскость, созданная автоматически.

Если при разгибании была использована вспомогательная плоскость, то для приведения тела в исходное — согнутое — состояние укажите эту плоскость как неподвижную в команде Согнуть.

Выбранная плоскость подсвечивается в окне модели и в Дереве построения. Выбранная грань подсвечивается в окне модели, а в Дереве построения подсвечивается элемент, которому она принадлежит.


2.4.7.1.2. Выбор сгибов

Чтобы перейти к указанию сгибов, состояние которых требуется изменить, активизируйте переключатель Выбор сгибов.

– При работе с командой разгибания необходимо выбирать согнутые сгибы. Для выбора согнутого сгиба укажите в окне модели любую его цилиндрическую грань.

– При работе с командой сгибания необходимо выбирать разогнутые сгибы. Для выбора разогнутого сгиба укажите в окне модели любую его плоскую грань, которая должна стать цилиндрической.

Если модель содержит несколько листовых тел, то для выбора будут доступны только сгибы того тела, которому принадлежит грань или с которым связана вспомогательная плоскость, указанная в качестве неподвижной.

В окне модели будут подсвечены выбранные сгибы, а в Дереве построения — сгибы и листовые элементы, которым они принадлежат.

Список сгибов, указанных для разгибания (сгибания), отображается на панели Сгибы (рис. 2.4.95). Эта панель содержит также кнопки для управления списком сгибов. Описание кнопок представлено в таблице 2.4.15.

Рис. 2.4.95.

Табл. 2.4.15. Управление списком сгибов
Кнопка | Описание
Выбрать все | Позволяет выбрать все сгибы. При работе с командой разгибания в список включаются все согнутые сгибы, а при работе с командой сгибания — все разогнутые. После нажатия кнопки выбранные сгибы подсвечиваются в окне модели и в Дереве построения.
Удалить | Позволяет исключить из списка выделенный сгиб. После нажатия кнопки в окне модели снимается выделение с указанного сгиба. Указание выделенного сгиба в окне модели приводит к исключению его из списка.
Исключить все | Позволяет очистить список сгибов. После нажатия кнопки в окне модели снимается выделение со всех сгибов.


2.4.7.2. Развертка

Перед переключением в режим развернутого отображения листового тела необходимо установить параметры развертки — выбрать неподвижную грань или плоскость и задать состояния сгибов (см. раздел 2.4.7.2.1).

Завершив настройку параметров развертки, сохраните параметры, нажав кнопку Создать объект на Панели специального управления.

Чтобы переключиться в режим развернутого отображения, вызовите команду Развертка. Текущая модель будет показана в соответствии с хранящимися в ней параметрами развертки.

Для удобства просмотра развернутого листового тела можно воспользоваться ориентацией Развертка (см. раздел 2.4.7.2.2).

Чтобы перейти в обычный режим работы с листовым телом, вызовите команду Развертка повторно.

В этом разделе:

2.4.7.2.1. Параметры развертки

2.4.7.2.2. Ориентация Развертка

2.4.7.2.3. Удаление параметров развертки


2.4.7.2.1. Параметры развертки

Чтобы задать параметры развертки, вызовите команду Параметры развертки. На Панели свойств появятся элементы, позволяющие настроить развертку (рис. 2.4.96).

Рис. 2.4.96. Элементы управления параметрами развертки

– Если модель содержит несколько листовых тел, то настройка развертки производится поочередно для каждого тела. Чтобы выполнить настройку параметров развертки тела, следует выбрать его в списке тел, а затем указать его неподвижную грань или плоскость и разгибаемые сгибы.

– Если модель содержит одно листовое тело, то выбирать его не нужно, можно сразу указывать неподвижную грань или плоскость и сгибы.

Выбор тел

Для выбора тела укажите его в списке на панели Тела (рис. 2.4.96). Выбранное тело подсветится в окне модели.

Строки списка отображаются разными цветами:

– строка тела, для которого еще не заданы параметры развертки — красным,

– строка тела, для которого уже заданы параметры развертки — зеленым.

Не обязательно задавать параметры развертки для всех тел, можно настроить одно или некоторые тела.

Выбор неподвижной грани или плоскости

Выбор неподвижной грани или плоскости листового тела производится так же, как при работе с командами сгибания и разгибания (см. раздел 2.4.7.1.1).

Грани, не принадлежащие листовому телу, или плоскости, не связанные с телом, параметры развертки которого задаются в данный момент, недоступны для выбора.

Выбор сгибов

Чтобы задать для сгибов состояния, в которых они будут находиться в режиме развертки, активизируйте переключатель Выбор сгибов.

После этого станет доступна панель (рис. 2.4.96), содержащая список всех сгибов, имеющихся в выбранном листовом теле.

Слева от названий сгибов отображаются опции. Сгибы с включенными опциями будут показаны в режиме развертки разогнутыми, а сгибы с отключенными опциями — согнутыми. Чтобы отметить сгиб, включите опцию рядом с его названием. При выделении сгиба в списке он подсвечивается в окне модели, а при указании в окне модели — выделяется в списке. Это позволяет контролировать правильность настройки.

Сгибы, не принадлежащие листовому телу, параметры развертки которого задаются в данный момент, указать невозможно.

Чтобы ускорить настройку, воспользуйтесь кнопками, расположенными над списком сгибов. Описание кнопок приведено в таблице 2.4.16.

Табл. 2.4.16. Управление состоянием сгибов
Кнопка | Описание
Согнуть все | Позволяет отключить опции сразу у всех сгибов.
Разогнуть все | Позволяет включить опции сразу у всех сгибов списка.
Согнуть выбранные | Позволяет отключить опции у выбранных сгибов1.
Разогнуть выбранные | Позволяет включить опции у сгибов, выделенных в списке1.
  1. Чтобы выделить несколько сгибов в списке, используйте клавиши <Shift> и <Ctrl>.
    Чтобы выделить несколько сгибов в окне модели, просто последовательно указывайте их.

Выбор грани или плоскости для ориентации Развертка

По умолчанию ориентация Развертка (см. раздел 2.4.7.2.2) устанавливается таким образом, чтобы направление взгляда было перпендикулярно грани или плоскости, указанной в качестве неподвижной (если тел несколько, то — неподвижная грань или плоскость первого тела, для которого были настроены параметры развертки).

При необходимости вы можете указать для ориентации Развертка любую другую грань или плоскость. Для этого активизируйте вкладку Вид Панели свойств и укажите нужную грань или плоскость в окне модели. Она будет выделена, а ее наименование появится в поле Плоскость вида.


2.4.7.2.2. Ориентация Развертка

После того, как параметры развертки будут заданы, в список ориентаций (см. раздел 2.1.3.2) текущей модели добавляется ориентация Развертка.

Рис. 2.4.97. Ориентация Развертка в списке ориентаций

В ориентации Развертка модель располагается так, чтобы направление взгляда было перпендикулярно грани или вспомогательной плоскости, указанной в качестве плоскости вида при настройке параметров развертки (см. раздел 2.4.7.2.1).


2.4.7.2.3. Удаление параметров развертки

Чтобы удалить параметры развертки, вызовите команду Операции — Элементы листового тела — Удалить параметры развертки. Из текущей модели будут удалены установленные ранее параметры развертки и ориентация Развертка.

Если параметры развертки листового тела в текущей модели еще не настраивались, то их удаление невозможно. В этом случае команда Операции — Элементы листового тела — Удалить параметры развертки недоступна.


2.4.7.3. Особенности разгибания и сгибания

При разгибании и сгибании сгибов с помощью команд Разогнуть и Согнуть, а также при использовании команды Развертка необходимо учитывать следующие обстоятельства.

– Если сгиб не затронут никакими другими элементами, то его разгибание и сгибание возможно всегда.

– Элементы, затрагивающие сгиб, могут располагаться так, что разгибание или сгибание этого сгиба окажется невозможным (рис. 2.4.98, 2.4.99).

Рис. 2.4.98. Примеры листовых элементов, делающих невозможным разгибание сгиба: а) пластина, б) отверстие, в) вырез
а) | б) | в)

Рис. 2.4.99. Примеры формообразующих и конструктивных элементов, делающих невозможным разгибание сгиба: а) приклеенный и вырезанный элементы, б) ребро жесткости, в) фаска
а) | б) | в)

– Операции, в результате которых ребра и/или грани сгиба полностью перестраиваются, всегда делают его разгибание или сгибание невозможным (рис. 2.4.100).

Рис. 2.4.100. Примеры операций, делающих невозможным разгибание сгиба: а) оболочка, б) уклон
а) | б)

– Если отверстие или вырез с криволинейным контуром захватывает цилиндрическую часть сгиба и примыкающую к нему плоскую часть листового тела, проходя не перпендикулярно этой плоской грани, то разгибание сгиба становится невозможно.

Рис. 2.4.101. Примеры отверстия и выреза, делающих невозможным разгибание сгиба: а) круглое отверстие, построенное способом На глубину, б) вырез, построенный способом До грани (эскиз выреза, расположенный на верхней плоской грани тела, показан штриховой линией)
а) | б)

– Если листовое тело состоит из нескольких частей (например, разделено операцией вырезания), то изменение состояния сгибов невозможно. Чтобы разогнуть или согнуть сгибы, необходимо сначала сделать тело целым, отредактировав имеющиеся элементы или создав новые элементы, которые соединят части.


2.4.7.4. Чертеж развертки

В ассоциативных видах чертежей КОМПАС-3D возможно создание изображений разверток листовых тел в соответствии с параметрами развертки, хранящимися в этих моделях.

Формирование изображения развертки доступно при создании следующих ассоциативных видов:

– Произвольный вид,

– Проекционный вид,

– Вид по стрелке.

Настоящий раздел рассчитан на пользователя, имеющего опыт создания ассоциативных видов. Построение этих видов в данном разделе подробно не рассматривается. Если вы не владеете приемами работы с ассоциативными видами, рекомендуется обратиться к разделу 3.7.

Чтобы сформировать в создаваемом виде изображение развертки, активизируйте переключатель Развертка на вкладке Параметры Панели свойств. Он доступен, если в модели настроены параметры развертки.

Управление отрисовкой линий сгиба производится на вкладке Линии (см. раздел 3.7.1.3.2). Обратите внимание на то, что автоматическая отрисовка линий сгиба на виде возможна, если плоскость проекций этого вида параллельна плоским граням, полученным при разгибании сгибов.

Чтобы правильно выбрать плоскость проекций для вида, содержащего развертку, необходимо знать, как развернутое листовое тело расположено относительно основных плоскостей проекций. Это расположение зависит от того, какая из граней тела или плоскостей, указана в качестве плоскости вида при настройке развертки.

Рассмотрим выбор плоскости проекций для изображения развертки листового тела, показанного на рис. 2.4.102, а.

Рис. 2.4.102. Листовое тело: а) в проекции Изометрия XYZ, б) главный вид
а) | б)

Допустим, что главный вид модели (рис. 2.4.102, б) в чертеже уже построен. Необходимо создать развертку.

В данном случае удобнее всего сформировать в чертеже произвольный вид этой модели.

При создании произвольного вида в списке Ориентация на вкладке Параметры Панели свойств становится доступна строка Развертка (рис. 2.4.103). Выбор ее означает, что плоскость проекций вида будет параллельна грани, указанной в качестве плоскости вида при настройке параметров развертки в модели.

Рис. 2.4.103. Развертка в списке ориентаций модели на произвольном виде

Если в качестве неподвижной грани была задана Грань А (см. рис. 2.4.102 а), то для создания изображения развертки нужно выбрать ориентацию Развертка.

Если в качестве неподвижной грани была задана Грань Б, то для создания изображения развертки нужно выбрать ориентацию Сверху, Снизу или Развертка.

Если в качестве неподвижной была указана задана Грань В, то для создания изображения развертки нужно выбрать ориентацию Сверху или Снизу.

Включите формирование развертки и отрисовку линий сгиба, настройте остальные параметры вида, после чего подтвердите его создание.

Обратите внимание на то, что произвольному виду с изображением развертки автоматически присваивается обозначение, содержащее условное графическое обозначение «развернуто».

Рис. 2.4.104. Развертка листового тела

Использование автоматически сформированной ориентации Развертка не является обязательным. При необходимости вы можете вручную создать в модели нужную ориентацию и использовать ее при построении развертки в чертеже.

При создании вида по стрелке и проекционного вида выбор ориентации из списка невозможен, так как положение плоскостей проекций этих видов зависит от направления взгляда. Выбирая это направление, необходимо учитывать расположение развернутого листового тела.

На разрезах (сечениях) листовое тело всегда отображается в том же состоянии, что и на опорном виде. При изменении состояния листового тела на этом виде (включении или отключении развертки) разрезы (сечения) автоматически перестраиваются.


2.4.8. Штамповочные элементы

2.4. Листовые тела

2.4.8. Штамповочные элементы

При создании листового тела в КОМПАС-3D возможно построение следующих штамповочных элементов:

– открытая и закрытая штамповка (рис. 2.4.105, а и 2.4.105, б),

– буртик (рис. 2.4.105, в),

– жалюзи (рис. 2.4.105, г).

Рис. 2.4.105. Штамповочные элементы
а) | б) | в) | г)

Фактически создание штамповочных элементов относится не к операциям гибки, а к операциям деформирования, когда листовой материал вытягивается и его толщина уменьшается. При построении штамповочных элементов в листовом теле КОМПАС-3D это изменение толщины материала не учитывается.

Разгибание сгибов штамповочных элементов невозможно.

Общие приемы построения штамповочных элементов описаны в разделе 2.4.8.1, а специальные приемы — в разделах 2.4.8.2–2.4.8.4.

Для задания параметров штамповочных элементов можно использовать характерные точки (см. раздел 2.1.4.2.2).

В этом разделе:

2.4.8.1. Общие приемы построения

2.4.8.1.1. Направление построения

2.4.8.1.2. Скругление ребер основания

2.4.8.1.3. Сохранение настроек

2.4.8.2. Штамповка

2.4.8.2.1. Профиль штамповки

2.4.8.2.2. Неподвижная сторона

2.4.8.2.3. Высота

2.4.8.2.4. Боковые стенки

2.4.8.2.5. Скругление боковых ребер

2.4.8.2.6. Скругление ребер дна

2.4.8.3. Буртик

2.4.8.3.1. Требования к эскизу

2.4.8.3.2. Обработка концов

2.4.8.3.3. Просмотр образца

2.4.8.3.4. Способ построения

2.4.8.4. Жалюзи

2.4.8.4.1. Требования к эскизу

2.4.8.4.2. Высота

2.4.8.4.3. Ширина

2.4.8.4.4. Способ построения


2.4.8.1. Общие приемы построения

После вызова команды построения штамповочного элемента на Панели свойств появляются элементы управления, позволяющие настроить различные параметры элемента. Общими для всех штамповочных элементов являются следующие параметры:

– направление построения,

– скругление основания,

– сохранение настроек.

В этом разделе:

2.4.8.1.1. Направление построения

2.4.8.1.2. Скругление ребер основания

2.4.8.1.3. Сохранение настроек


2.4.8.1.1. Направление построения

Грань листового тела, содержащая эскиз штамповочного элемента, считается базовой гранью этого элемента. Вне зависимости от того, на какой из граней — внешней или внутренней — расположен эскиз, базирующийся на нем штамповочный элемент может быть направлен как внутрь листового тела, так и наружу (рис. 2.4.106). Толщина листового материала при этом не учитывается, благодаря чему геометрические параметры элемента не зависят от направления построения.

Рис. 2.4.106. Направление построения штамповочного элемента: а) выбор направления, б) результат построения
а) | б)

Прямым направлением построения считается направление наружу от базовой грани, а обратным — внутрь. Текущее направление построения отображается на экране фантомной стрелкой.

Чтобы указать, по какую сторону базовой грани будет располагаться буртик, активизируйте нужный переключатель в группе Направление построения.


2.4.8.1.2. Скругление ребер основания

Основание штамповочного элемента — часть листового тела, где штамповочный элемент соединяется с прилегающими к нему плоскими участками.

Ребра основания — ребра, образующиеся на стыках граней боковых стенок штамповочного элемента и граней прилегающих к нему плоских участков листового тела. При этом ребра, принадлежащие внутренним боковым граням штамповочного элемента, считаются внутренними ребрами основания, а принадлежащие внешним боковым граням — внешними ребрами основания (рис. 2.4.107).

Рис. 2.4.107. Внутренние и внешние ребра основания

Штамповочные элементы могут создаваться со скруглением ребер основания или без скругления.

Чтобы скруглить ребра основания, включите опцию Скругление основания и введите радиус скругления в поле Радиус скругления основания. Заданное значение радиуса R используется для скругления внешних ребер основания. Радиус скругления внутренних ребер равен сумме (R + S), где S — толщина листового материала. Минимальное значение радиуса скругления ребер основания — 0.


2.4.8.1.3. Сохранение настроек

Вы можете сохранить заданные параметры штамповочного элемента для дальнейшего использования при построении аналогичных элементов до конца сеанса работы. Для этого, завершив настройку параметров элемента, включите опцию По умолчанию.


2.4.8.2. Штамповка

В настоящем разделе описан порядок построения открытой и закрытой штамповок. Они имеют практически одинаковый набор параметров и создаются очень похоже.

Чтобы построить открытую штамповку, вызовите команду Открытая штамповка.

Чтобы построить закрытую штамповку, вызовите команду Закрытая штамповка.

Команды построения штамповок доступны, если выделен один эскиз — профиль штамповки (см. раздел 2.4.8.2.1).

Укажите направление построения (см. раздел 2.4.8.1.1).

Выберите неподвижную сторону штамповки (см. раздел 2.4.8.2.2).

Задайте высоту штамповки (см. раздел 2.4.8.2.3).

Задайте параметры боковых стенок (см. раздел 2.4.8.2.4).

Настройте параметры скругления ребер (см. разделы 2.4.8.1.2, 2.4.8.2.5 и 2.4.8.2.6).

Если штамповка строится со скруглениями ребер дна и/или основания, то при малых (по сравнению с радиусами) высотах штамповки становится невозможным одновременное соблюдение заданных значений угла, радиусов и высоты. Поскольку высота и радиус имеют более высокий приоритет, значение, введенное в поле Угол, игнорируется. Величина угла уклона боковых стенок (фактически, угла наклона касательных к боковым стенкам, так как их плоские участки в этих случаях вырождаются) вычисляется системой автоматически.

Завершив настройку, нажмите кнопку Создать объект на Панели специального управления, чтобы подтвердить создание штамповки.

К проектируемому листовому телу добавится новый элемент с заданными параметрами, а в Дереве построения появится соответствующая пиктограмма:

– открытая штамповка,

– закрытая штамповка.

В этом разделе:

2.4.8.2.1. Профиль штамповки

2.4.8.2.2. Неподвижная сторона

2.4.8.2.3. Высота

2.4.8.2.4. Боковые стенки

2.4.8.2.5. Скругление боковых ребер

2.4.8.2.6. Скругление ребер дна


2.4.8.2.1. Профиль штамповки

Профиль штамповки — это форма ее дна. Профиль определяется эскизом, на котором базируется штамповка. Тонкостенный элемент, получаемый выдавливанием эскиза в направлении построения, образует боковые стенки штамповки.

Требования к эскизу

– Эскиз должен располагаться только на внешней или внутренней плоской грани листового тела.

– Объекты эскиза должны составлять один контур.

– Контур может быть замкнутым или разомкнутым.

– Если контур замкнут, то он может пересекаться с базовой гранью или полностью принадлежать ей.

– Если контур разомкнут, то он должен пересекать базовую грань так, чтобы иметь две общих точки с ребрами, составляющими ее внешний контур. Конечные точки контура могут принадлежать этим ребрам или находиться за пределами базовой грани.

– Общие точки контура и базовой грани не должны совпадать с вершинами ребер, ограничивающих базовую грань.

– Контур не должен пересекаться или иметь общие точки с другими элементами тела.


2.4.8.2.2. Неподвижная сторона

Неподвижная сторона — та часть базовой грани, положение которой при построении штамповки не изменится. Неподвижная часть грани может находиться внутри профиля штамповки или снаружи от него. Именно в этой части грани начинается фантомная стрелка, показывающая направление построения.

Чтобы сменить неподвижную сторону, воспользуйтесь группой переключателей Сторона. При смене неподвижной стороны положение фантомной стрелки в окне модели изменяется.

Зависимость результата построения открытой штамповки от выбора неподвижной стороны представлена в таблице 2.4.17, а закрытой — в таблице 2.4.18. Штриховой линией на рисунках показано исходное состояние детали. Обратите внимание на то, что закрытая штамповка всегда имеет и дно, и основание, а открытая — либо дно, либо основание (в зависимости от выбора неподвижной стороны).

Табл. 2.4.17. Неподвижная сторона открытой штамповки
Значение опции Сторона | Исходное состояние детали | Результат построения штамповки
Сторона 1 |  |
Сторона 2 |  |

Табл. 2.4.18. Неподвижная сторона закрытой штамповки
Значение опции Сторона | Исходное состояние детали | Результат построения штамповки
Сторона 1 |  |
Сторона 2 |  |


2.4.8.2.3. Высота

Чтобы определить высоту штамповки, необходимо выбрать способ задания высоты штамповки и ввести значение высоты.

При построении открытой штамповки доступны два способа задания высоты:

– Полный,

– Снаружи.

При построении закрытой штамповки доступны три способа задания высоты:

– Полный,

– Внутри,

– Снаружи.

Выбрав способ задания высоты, введите нужное значение в поле Высота.

При использовании способа Полный заданное значение высоты штамповки должно быть больше толщины листового тела.


2.4.8.2.4. Боковые стенки

При построении штамповки можно управлять следующими параметрами боковых стенок: направление добавления материала и уклон.

Направление добавления материала

Толщина боковых стенок штамповки может откладываться внутрь или наружу по отношению к поверхности, образованной перемещением профиля в направлении построения.

Чтобы изменить направление добавления материала боковых стенок, воспользуйтесь группой переключателей Боковые стенки:

– для открытой штамповки:

• Внутрь,

• Наружу,

– для закрытой штамповки:

• Внутрь,

• Наружу.

Уклон боковых стенок

Боковые стенки штамповки могут быть уклонены в направлении построения. Чтобы построить штамповку с уклоном боковых стенок, введите значение угла уклона в поле Угол. Нулевое значение в этом поле означает отсутствие уклона.

Уклон боковых стенок штамповки производится в соответствии со следующими правилами.

– Угол уклона отсчитывается от нормали базовой грани.

– Направление отсчета угла выбирается таким, чтобы боковые стенки были уклонены наружу по отношению к дну штамповки.

– Исходные размеры профиля (определяемые эскизом) выдерживаются в области дна штамповки.

Примеры построения открытой и закрытой штамповок с уклоном боковых стенок показаны в таблице 2.4.19 и 2.4.20 соответственно. Направление добавления материала боковых стенок во всех примерах — внутрь; a — угол уклона боковых стенок; штриховой линией показано исходное положение детали, а утолщенной — грань, сохранившая в результате построения форму и размеры профиля.

Табл. 2.4.19. Уклон боковых стенок открытой штамповки
Исходное состояние детали; положение неподвижной стороны | Результат построения | Сечение плоскостью, перпендикулярной базовой грани

Табл. 2.4.20. Уклон боковых стенок закрытой штамповки
Исходное состояние детали; положение неподвижной стороны | Результат построения | Сечение плоскостью, перпендикулярной базовой грани


2.4.8.2.5. Скругление боковых ребер

Боковые ребра — ребра, образующиеся на стыках граней боковых стенок штамповки. При этом ребра, принадлежащие внутренним боковым граням штамповки, считаются внутренними боковыми ребрами, а принадлежащие внешним боковым граням — внешними боковыми ребрами (рис. 2.4.108).

Рис. 2.4.108. Внутренние и внешние боковые ребра штамповки

Штамповка может создаваться со скруглением боковых ребер или без скругления.

Чтобы скруглить боковые ребра, включите опцию Скругление боковых ребер и введите радиус скругления в поле Радиус. Заданное значение радиуса R используется для скругления внутренних боковых ребер. Радиус скругления внешних ребер равен сумме (R + S), где S — толщина листового материала. Минимальное значение радиуса скругления боковых ребер — 0.

Если боковые стенки штамповки уклонены (см. раздел 2.4.8.2.4), то R и (R + S) — минимальные радиусы скругления боковых ребер. Эти значения радиусов выдерживаются в области дна штамповки. Например, на рисунке 2.4.109 показана открытая штамповка с уклоном боковых стенок и скругленными боковыми ребрами.

Рис. 2.4.109. Открытая штамповка с уклоном боковых стенок и скругленными боковыми ребрами: а) радиус скругления равен нулю, б) радиус скругления больше нуля
а) | б)

Боковые ребра штамповки, образованные гладко сопряженными гранями, не скругляются.


2.4.8.2.6. Скругление ребер дна

Ребра дна — ребра, образующиеся на стыках граней дна штамповки и граней ее боковых стенок. При этом ребра, принадлежащие внутренним боковым граням штамповки, считаются внутренними ребрами дна, а принадлежащие внешним боковым граням — внешними ребрами дна (рис. 2.4.110).

Рис. 2.4.110. Внутренние и внешние ребра дна штамповки
(штамповка рассечена плоскостью, перпендикулярной базовой грани)

Штамповка может создаваться со скруглением ребер дна или без скругления.

Чтобы скруглить ребра дна, включите опцию Скругление дна и введите радиус скругления в поле Радиус скругления дна. Заданное значение радиуса R используется для скругления внутренних ребер дна. Радиус скругления внешних ребер равен сумме (R + S), где S — толщина листового материала. Минимальное значение радиуса скругления ребер дна — 0.

Открытая штамповка может иметь либо дно, либо основание в зависимости от выбора неподвижной стороны (см. табл. 2.4.17). Поэтому при ее создании на Панели свойств присутствуют элементы управления скруглением либо дна, либо основания (см. раздел 2.4.8.1.2).


2.4.8.3. Буртик

В листовом теле КОМПАС-3D можно создать буртик с одной из трех форм сечения:

– круглая (рис. 2.4.111, а),

– U-образная (рис. 2.4.111, б),

– V-образная (рис. 2.4.111, в).

Рис. 2.4.112.
а) | б) | в)
Рис. 2.4.111. Формы сечения буртиков

Чтобы построить буртик, вызовите команду Буртик.

Команда доступна, если выделен один эскиз — эскиз буртика. Эскиз определяет конфигурацию и положение буртика. Требования к эскизу перечислены в разделе 2.4.8.3.1.

Построение буртика невозможно, если его эскиз имеет общие точки с ребрами, к которым примыкают сгибы.

Укажите направление построения (см. раздел 2.4.8.1.1).

Выберите форму сечения буртика: круглая, U-образная или V-образная.

Выберите тип обработки концов буртика (см. раздел 2.4.8.3.2).

Для удобства работы на панели Просмотр показан образец буртика (см. раздел 2.4.8.3.3).

Выберите способ построения буртика (см. раздел 2.4.8.3.4).

Введите значения параметров буртика в соответствующие поля на Панели свойств. Набор этих полей зависит от выбранного способа построения.

Настройте параметры скругления ребер основания (см. раздел 2.4.8.1.2). Для U-образного буртика возможно также скругление ребер дна. Это делается так же, как при построении штамповки — см. раздел 2.4.8.2.6.

Если при построении V-образного буртика или U-образного со скруглениями ребер дна и/или основания задана малая (по сравнению с радиусами) высота, то становится невозможным одновременное соблюдение заданных значений угла, радиуса (радиусов) и высоты. Поскольку высота и радиус имеют более высокий приоритет, значение, введенное в поле Угол, игнорируется. Величина угла уклона боковых стенок (фактически, угла наклона касательных к боковым стенкам, так как их плоские участки в этих случаях вырождаются) вычисляется системой автоматически.

Если буртик не умещается полностью в пределах базовой грани, то он обрезается плоскостью (плоскостями) соответствующей торцевой грани (рис. 2.4.113).

Рис. 2.4.113. Буртик, не умещающийся в пределах базовой грани: а) эскиз буртика; б) результат построения
а) | б)

Завершив настройку, нажмите кнопку Создать объект на Панели специального управления, чтобы подтвердить создание буртика.

К проектируемому листовому телу добавится новый элемент с заданными параметрами, а в Дереве построения появится соответствующая пиктограмма.

В этом разделе:

2.4.8.3.1. Требования к эскизу

2.4.8.3.2. Обработка концов

2.4.8.3.3. Просмотр образца

2.4.8.3.4. Способ построения


2.4.8.3.1. Требования к эскизу

– Эскиз должен располагаться только на внешней или внутренней плоской грани листового тела или листового элемента.

– Объекты эскиза могут составлять один или несколько контуров.

– Контуры могут быть замкнутыми или разомкнутыми.

– Если контур состоит из нескольких графических объектов, то они должны гладко сопрягаться.

– Контуры могут пересекаться друг с другом, но самопересечение контуров не допускается.


2.4.8.3.2. Обработка концов

Конец буртика — часть буртика, соответствующая крайней точке контура в эскизе. Доступны следующие варианты обработки концов:

– закрытый (рис. 2.4.114, а),

– открытый (рис. 2.4.114, б),

– рубленый (рис. 2.4.114, в).

Рис. 2.4.114. Типы обработки концов буртика
а) | б) | в)

Выбранный тип применяется ко всем концам текущего буртика.

При выборе типа обработки Рубленый на Панели свойств появляется поле Зазор, в которое следует ввести величину зазора вырубки.


2.4.8.3.3. Просмотр образца

Изображение буртика показано на панели Просмотр. Доступны два варианта изображения:

– поперечный разрез с размерами, соответствующими параметрам сечения,

– образец — наглядное изображение прямолинейного буртика с учетом выбранной формы сечения, типа обработки концов и скругления основания.

Для выбора типа изображения на панели Просмотр служит опция Образец. Если она включена, на панели просмотра отображается образец буртика, если выключена — разрез.


2.4.8.3.4. Способ построения

Для выбора способа построения буртика служит список Способ. Набор способов, доступных в этом списке, зависит от выбранной формы сечения (см. табл. 2.4.21–2.4.23).

Табл. 2.4.21. Способы построения круглого буртика
Способ | Параметры
По высоте и ширине основания |
По высоте и радиусу |
По радиусу и ширине основания |

Табл. 2.4.22. Способы построения U-образного буртика
Способ | Параметры
По высоте, углу и ширине основания |
По ширине основания, высоте и ширине дна |
По ширине основания, углу и ширине дна |
По углу, высоте и ширине дна |

Табл. 2.4.23. Способы построения V-образного буртика
Способ | Параметры
По высоте, углу и ширине основания |
По высоте, углу и радиусу |
По радиусу, углу и ширине основания |
По высоте, радиусу и ширине основания |


2.4.8.4. Жалюзи

Позволяет создать в листовом теле жалюзи по прямой линии. Доступно два типа жалюзи:

– вытянутые (рис. 2.4.115, а),

– подрезанные (рис. 2.4.115, б).

Рис. 2.4.115. Типы жалюзи
а) | б)

Чтобы построить жалюзи, вызовите команду Жалюзи.

Команда доступна, если выделен один эскиз — эскиз жалюзи. Требования к эскизу перечислены в разделе 2.4.8.4.1.

Укажите направление построения (см. раздел 2.4.8.1.1).

Выберите положение жалюзи — справа или слева относительно отрезка в эскизе, активизировав нужный переключатель в группе Положение.

Задайте высоту жалюзи (см. раздел 2.4.8.4.2).

Выберите способ построения жалюзи (см. раздел 2.4.8.4.4).

Задайте ширину жалюзи (см. раздел 2.4.8.4.4).

Настройте параметры скругления ребер основания (см. раздел 2.4.8.1.2).

Завершив настройку, нажмите кнопку Создать объект на Панели специального управления, чтобы подтвердить создание жалюзи.

К проектируемому листовому телу добавится новый элемент (элементы) с заданными параметрами, а в Дереве построения появится соответствующая пиктограмма.

В этом разделе:

2.4.8.4.1. Требования к эскизу

2.4.8.4.2. Высота

2.4.8.4.3. Ширина

2.4.8.4.4. Способ построения


2.4.8.4.1. Требования к эскизу

– Эскиз должен располагаться только на внешней или внутренней плоской грани листового тела или листового элемента.

– Эскиз может содержать один отрезок или несколько отрезков.

– Эскиз должен полностью находиться в пределах базовой грани (т.е. не должен иметь общих точек с ребрами, ограничивающими базовую грань).

– Отрезки в эскизе не могут пересекаться или иметь общие точки.


2.4.8.4.2. Высота

Чтобы определить высоту жалюзи, необходимо выбрать тип размера высоты жалюзи и ввести значение высоты.

Доступно три типа размера высоты:

– Полный,

– От грани,

– Высота прорези.

Выбрав тип размера, введите нужное значение в поле Высота. Пределы допустимых значений высоты жалюзи зависят от толщины листового материала (S) и ширины жалюзи (В). Зависимость различна для разных типов размера высоты (см. таблицу 2.4.24).

Табл. 2.4.24. Пределы допустимых значений высоты жалюзи
Тип размера высоты | Пределы значений высоты
Полный | S < H < B, где Н — полная высота жалюзи
От грани | S < h <B - S, где h — высота жалюзи от грани
Высота прорези | 0.00 < A < B - 2 · S, где A — высота прорези жалюзи

Геометрические параметры жалюзи показаны на рисунке 2.4.116.

Рис. 2.4.116. Геометрические параметры жалюзи: а) вытянутых; б) подрезанных с торцем по направлению подрезки; в) подрезанных с торцем по нормали к толщине
a) | б) | в)


2.4.8.4.3. Ширина

Чтобы задать ширину жалюзи, введите нужное значение в поле Ширина. Значение ширины В (см. рис. 2.4.116) должно удовлетворять следующему условию: B > 2 · S, где S — толщина листового материала. Для вытянутого жалюзи значение ширины должно удовлетворять также условию B < L/2, где L — длина отрезка в эскизе жалюзи.


2.4.8.4.4. Способ построения

Чтобы задать способ построения жалюзи, разверните список Способ и выберите из него нужную строку. Доступны два способа: Вытяжка и Подрезка.

При использовании способа Подрезка можно выбрать форму торца:

– По направлению подрезки или

– По нормали к толщине.


2.5. Точки и кривые

В этом разделе:

2.5.1. Термины и определения

2.5.2. Точки

2.5.2.1. Общий порядок построения точки

2.5.2.1.1. Объекты, используемые при построении

2.5.2.2. Построение точки по координатам XYZ

2.5.2.3. Перенос точки относительно объекта

2.5.2.3.1. Перенос по координатам

2.5.2.3.2. Перенос относительно направляющего объекта

2.5.2.4. Построение точки на пересечении объектов

2.5.2.5. Построение точки на кривой

2.5.2.6. Построение точки на поверхности

2.5.2.6.1. По параметрам U и V

2.5.2.6.2. По смещениям от двух объектов

2.5.2.6.3. По координатам на плоскости

2.5.2.6.4. По координатам на цилиндре и сфере

2.5.2.7. Построение точки в центре объекта

2.5.2.8. Построение проекции точки на объект

2.5.2.9. Построение точки по цилиндрическим (RAZ) и сферическим (RAB) координатам

2.5.2.10. Переменные точки

2.5.2.11. Использование функционала команды Точка при создании других объектов

2.5.2.11.1. Построение точки в процессе создания объекта

2.5.2.11.2. Редактирование точки, построенной в процессе создания объекта

2.5.3. Группы точек

2.5.3.1. Общие приемы создания групп точек

2.5.3.1.1. Разрушение группы точек

2.5.3.2. Группа точек по кривой

2.5.3.2.1. Задание положения точек на рабочем участке

2.5.3.2.2. Задание положения рабочего участка на кривой

2.5.3.3. Группа точек по поверхности

2.5.3.3.1. Задание положения центра сетки при построении группы точек способом По сетке вокруг заданной точки

2.5.3.3.2. Настройка параметров сетки при построении группы точек способом По сетке вокруг заданной точки

2.5.3.4. Группа точек из файла

2.5.3.4.1. Тип координат точки

2.5.3.4.2. Связь группы точек с файлом-источником

2.5.4. Пространственные кривые

2.5.4.1. Параметры отображения кривых

2.5.4.2. Импортированная кривая

2.5.4.3. Отрезок

2.5.4.3.1. Построение по 2 точкам

2.5.4.3.2. Построение по точке, длине и углу наклона

2.5.4.4. Дуга окружности

2.5.4.4.1. Построение по 3 точкам

2.5.4.4.2. Построение по центру и радиусу

2.5.4.4.3. Построение по 2 точкам с направлением

2.5.4.4.4. Построение с касанием к кривой

2.5.4.5. Спирали. Общие приемы построения

2.5.4.6. Цилиндрическая спираль

2.5.4.6.1. Способ построения

2.5.4.6.2. Число витков, шаг, высота

2.5.4.6.3. Направление построения

2.5.4.6.4. Направление навивки

2.5.4.6.5. Начальный угол

2.5.4.6.6. Диаметр спирали

2.5.4.6.7. Положение спирали

2.5.4.7. Коническая спираль

2.5.4.7.1. Начальный и конечный диаметры

2.5.4.7.2. Положение спирали

2.5.4.8. Пространственные сплайны и ломаные. Общие приемы построения

2.5.4.8.1. Таблица параметров вершин

2.5.4.8.2. Приемы работы с таблицей параметров

2.5.4.8.3. Построение по точкам

2.5.4.8.4. Построение по осям

2.5.4.8.5. Построение по объектам

2.5.4.8.6. Формирование ассоциативной связи вершин с точечными объектами. Особенности связанных вершин

2.5.4.8.7. Замкнутая или разомкнутая кривая

2.5.4.8.8. Редактирование параметров вершины

2.5.4.9. Пространственный сплайн

2.5.4.9.1. Тип сплайна

2.5.4.9.2. Сопряжение сплайна с объектами модели

2.5.4.9.3. Особенности сопряжения сплайна По полюсам с другими объектами. Системный полюс

2.5.4.9.4. Управление формой сплайна

2.5.4.9.5. Задание ориентации касательной и величины касательности

2.5.4.9.6. Задание кривизны и ориентации нормали

2.5.4.9.7. Направляющий объект для вектора

2.5.4.9.8. Вращение управляющего фантома

2.5.4.10. Пространственная ломаная

2.5.4.10.1. Встраивание совокупности вершин

2.5.4.10.2. Скругление вершин

2.5.4.11. Сплайн по объектам

2.5.4.12. Кривая по закону

2.5.4.12.1. Задание функции для координаты точки кривой

2.5.4.12.2. Ввод выражения и задание параметра функции

2.5.4.12.3. Задание интервального параметра функции

2.5.4.12.4. Примеры создания кривых по параметрическим уравнениям

2.5.4.13. Скругление кривых

2.5.4.14. Соединение кривых

2.5.4.14.1. Задание натяжения соединительной кривой

2.5.4.14.2. Смена вершины сопряжения исходной кривой

2.5.4.15. Кривая по двум проекциям

2.5.4.15.1. Выбор контуров для построения кривой

2.5.4.16. Усечение кривой

2.5.4.16.1. Усечение кривой двумя объектами

2.5.4.17. Эквидистанта кривой

2.5.4.17.1. Построение смещением по направлению от вершины

2.5.4.17.2. Построение смещением вдоль поверхности

2.5.4.18. Изопараметрическая кривая

2.5.4.19. Группа изопараметрических кривых на поверхности

2.5.4.20. Линия очерка

2.5.4.20.1. Задание направления взгляда при построении линии очерка

2.5.4.21. Сплайн на поверхности

2.5.4.21.1. Таблица параметров вершин сплайна

2.5.4.21.2. Режим редактирования сплайна

2.5.4.21.3. Изменение положения вершины

2.5.4.21.4. Управление касательным вектором сплайна

2.5.4.22. Проекционная кривая

2.5.4.22.1. Объекты, используемые при построении

2.5.4.22.2. Построение проекционной кривой

2.5.4.22.3. Выбор типа проекции базовой кривой

2.5.4.23. Кривая пересечения поверхностей

2.5.4.24. Контур

2.5.4.24.1. Выбор типа контура

2.5.4.24.2. Построение контура со скруглениями

2.5.4.24.3. Построение контура по эквидистанте кривой


2.5.1. Термины и определения

2.5. Точки и кривые

2.5.1. Термины и определения

Связная совокупность граней — множество граней, каждая из которых имеет общее ребро хотя бы еще с одной гранью этого множества, причем одно ребро одновременно принадлежит не более чем двум граням.

Связная совокупность кривых (цепочка кривых) — множество кривых, каждая из которых имеет общую вершину хотя бы еще с одной кривой этого множества, причем одна вершина одновременно принадлежит не более чем двум кривым.

Односегментная кривая — кривая, которая вся состоит из одного участка. Односегментная кривая всегда выделяется и участвует в операциях целиком. Примеры односегментных кривых: дуга, спираль, сплайн.

Многосегментная кривая — кривая, которая состоит (или потенциально может состоять) из нескольких последовательно соединяющихся участков — сегментов. Многосегментная кривая может выделяться и участвовать в операциях как целиком (для этого ее нужно указать в Дереве построения модели), так и отдельными сегментами (для этого их следует указывать в окне модели). Примеры многосегментных кривых: ломаная, контур.


2.5.2. Точки

2.5. Точки и кривые

2.5.2. Точки

Команды создания точек расположены в меню Операции, а кнопки для их вызова находятся на панели Пространственные кривые (рис. 2.5.1).

Рис. 2.5.1. Панель Пространственные кривые

В этом разделе:

2.5.2.1. Общий порядок построения точки

2.5.2.1.1. Объекты, используемые при построении

2.5.2.2. Построение точки по координатам XYZ

2.5.2.3. Перенос точки относительно объекта

2.5.2.3.1. Перенос по координатам

2.5.2.3.2. Перенос относительно направляющего объекта

2.5.2.4. Построение точки на пересечении объектов

2.5.2.5. Построение точки на кривой

2.5.2.6. Построение точки на поверхности

2.5.2.6.1. По параметрам U и V

2.5.2.6.2. По смещениям от двух объектов

2.5.2.6.3. По координатам на плоскости

2.5.2.6.4. По координатам на цилиндре и сфере

2.5.2.7. Построение точки в центре объекта

2.5.2.8. Построение проекции точки на объект

2.5.2.9. Построение точки по цилиндрическим (RAZ) и сферическим (RAB) координатам

2.5.2.10. Переменные точки

2.5.2.11. Использование функционала команды Точка при создании других объектов

2.5.2.11.1. Построение точки в процессе создания объекта

2.5.2.11.2. Редактирование точки, построенной в процессе создания объекта


2.5.2.1. Общий порядок построения точки

Построение точки в пространстве возможно следующими способами:

– По координатам (XYZ),

– Переносом относительно другой точки,

– На пересечении двух объектов,

– На кривой,

– На поверхности,

– В центре объекта,

– Проекцией точки на объект,

– По цилиндру (RAZ),

– По сфере (RAB).

В каждом способе использование определенного объекта обусловливает ассоциативную связь точки с этим объектом — например, принадлежность точки поверхности.

Чтобы создать точку в пространстве, вызовите команду Точка.

Выберите вариант построения точки из списка Способ или при помощи команд контекстного меню. На Панели свойств появятся элементы управления построением (рис. 2.5.2).

Рис. 2.5.2. Панель свойств при построении точки по координатам

Затем задайте параметры и укажите объекты, используемые для построения.

Наряду со вводом числовых значений можно перемещать характерную точку мышью для определения окончательного положения точки, например, при построении на кривой. При этом связь с объектом не нарушается, а параметры будут вычисляться и отображаться в полях Панели свойств.

Подробно о вводе параметров для каждого способа рассказано в разделах 2.5.2.2 — 2.5.2.9.

После задания всех необходимых данных в модели появляется фантом точки. Пока построение не завершено, положение точки можно изменить, активизировав необходимый элемент управления на Панели свойств.

До завершения команды система «запоминает» объекты, указанные в каждом из способов построения, поэтому вы можете переключаться между способами без потери объектов. Исключение составляют способы По координатам (XYZ), По цилиндру (RAZ), По сфере (RAB) — при переключении на любой из них автоматически формируется точка, которая совпадает с точкой, определенной в последнем из выбранных способов. Благодаря этому в любой момент построения точки можно посмотреть ее текущие координаты в декартовой, цилиндрической или сферической системе координат.

Для создания точки без ассоциативной связи с объектами, участвовавшими в построении, переключитесь, например, на способ По координатам (XYZ) и завершите команду.

Чтобы сменить объекты, используемые для построения точки выбранным способом, нажмите кнопку Указать заново на Панели специального управления и повторите выбор объектов.

Название, цвет и стиль отображения точки можно изменить на вкладке Свойства Панели свойств.

Чтобы завершить построение, нажмите кнопку Создать объект на Панели специального управления.

В способах По координатам и В центре доступен режим автосоздания точек, который по умолчанию включен.

В этом разделе:

2.5.2.1.1. Объекты, используемые при построении


2.5.2.1.1. Объекты, используемые при построении

При построении используются два типа объектов — объекты, на которых располагается точка, и объекты, являющиеся вспомогательными — опорные точки и направляющие объекты (в способах Перенос и Проекция).

Точки в модели могут располагаться на пространственных кривых и поверхностях, а также совпадать с точечными объектами.

Точечными объектами являются:

– начала координат,

– вершины линий эскизов,

– отдельные точки в эскизах,

– отдельные точки в пространстве,

– вершины пространственных кривых,

– вершины ребер.

Опорная точка является точкой отсчета смещения в способе Перенос и проецируемым объектом в способе Проекция. Опорной точкой может служить любой точечный объект.

Направляющими объектами, которые задают направление смещения или проецирования точки, могут служить следующие объекты в модели.

– Точечные объекты (перечисленные выше).

Направление, задаваемое точечным объектом — прямая, проходящая через этот точечный объект и указанную опорную точку.

– Прямолинейные объекты:

• отрезки эскизов,

• сегменты ломаных,

• координатные и вспомогательные оси,

• прямолинейные ребра.

Направление, задаваемое прямолинейным объектом — прямая, параллельная объекту.

– Плоские объекты:

• координатные и вспомогательные плоскости,

• плоские грани.

Направление, задаваемое плоским объектом — прямая, перпендикулярная объекту.

Кроме того, направляющим объектом может служить вектор. Этот вектор можно создать при помощи команды Построение вектора (см. раздел 2.8.5).


2.5.2.2. Построение точки по координатам XYZ

По координатам (XYZ) — способ построения точки, позволяющий непосредственно задавать ее декартовы координаты в пространстве или связывать ее с уже имеющимся точечным объектом.

Координаты точки могут быть введены с клавиатуры или определены автоматически при указании ее положения мышью в окне модели. Включение и выключение формирования ассоциативной связи точки с точечным объектом производится с помощью опции Ассоциировать.

– Если все три координаты точки известны, введите их в соответствующие поля Панели свойств и зафиксируйте нажатием клавиши <Enter>.

– При перемещении мыши в окне модели точка определяется как проекция курсора на плоскость, параллельную экрану и проходящую через начало координат. Текущие координаты точки отображаются в полях X, Y, Z Панели свойств. При подведении курсора к точечному объекту (перечень объектов — см. раздел 2.5.2.1.1) рядом с ним появляется условное изображение вершины или точки, а координаты определяются как совпадающие с координатами этого точечного объекта. Чтобы зафиксировать точку с текущими координатами, щелкните левой кнопкой мыши.

Указание точечного объекта при включенной опции Ассоциировать приводит к формированию ассоциативной связи точки с этим объектом.

Признаком наличия связи является отображение «галочки» на кнопке Объект и наименования точечного объекта в поле Объект на Панели свойств. Благодаря этой связи вновь созданная точка будет следовать за объектом при изменении его положения.

Чтобы отменить ассоциативную связь с точечным объектом, следует нажать кнопку Объект. «Галочка» на кнопке исчезнет.

Для восстановления ассоциативной связи точки с точечным объектом необходимо включить опцию Ассоциировать и указать нужный объект заново.

– Если известны две координаты точки, введите их в соответствующие поля Панели свойств и зафиксируйте. Во время движения мыши точка будет перемещаться по прямой, определяемой заданными координатами. Чтобы создать точку, являющуюся проекцией какого-либо точечного объекта на эту прямую, выключите опцию Ассоциировать и укажите нужный точечный объект. Для фиксации точки щелкните левой кнопкой мыши.

– Если известна одна координата точки, введите ее в соответствующее поле Панели свойств и зафиксируйте. Во время движения мыши точка будет перемещаться в плоскости, определяемой заданной координатой. Чтобы создать точку, являющуюся проекцией какого-либо точечного объекта на эту плоскость, выключите опцию Ассоциировать и укажите нужный точечный объект. Для фиксации точки щелкните левой кнопкой мыши.

Координаты точки задаются в ее системе координат (о системе координат объекта — см. раздел 2.8.3.4).


2.5.2.3. Перенос точки относительно объекта

Перенос — способ построения точки заданием координат относительно опорной точки или смещением от нее на заданное расстояние в указанном направлении.

В качестве опорных точек могут быть использованы те же точечные объекты, что и при связывании точек с объектом в способе По координатам.

Для построения точки способом Перенос необходимо выбрать опорную точку — точку, от которой будет производиться отсчет координат или расстояние смещения.

Чтобы выбрать опорную точку, укажите нужный объект при нажатой кнопке Опорная точка. После того как рядом с курсором появится условное изображение вершины или точки, нажмите левую кнопку мыши. В поле Опорная точка отображается ее наименование.

В этом разделе:

2.5.2.3.1. Перенос по координатам

2.5.2.3.2. Перенос относительно направляющего объекта


2.5.2.3.1. Перенос по координатам

Поля ввода координат становятся доступны после указания опорной точки.

Задайте относительные координаты создаваемой точки в полях X, Y, Z Панели свойств и зафиксируйте нажатием клавиши <Enter>.

Относительные координаты задаются в декартовой системе координат, началом которой является опорная точка, а оси сонаправлены осям системы координат создаваемой точки (о системе координат объекта — см. раздел 2.8.3.4).


2.5.2.3.2. Перенос относительно направляющего объекта

После указания опорной точки нажмите кнопку Направляющий объект.

Укажите в модели объект, определяющий направление смещения создаваемой точки от опорной. Перечень направляющих объектов и направления, которые они задают, указаны в разделе 2.5.2.1.1.

Кроме того, направляющим объектом может служить вектор. Этот вектор можно создать при помощи команды Построение вектора (см. раздел 2.8.5).

В поле Направляющий объект отображается наименование указанного объекта. Если направление задано вектором, то в этом поле отображается слово «Вектор».

После указания направляющего объекта или построения вектора становится доступно поле Расстояние.

Задайте расстояние от опорной точки до создаваемой, введя его в этом поле или указав положение точки мышью в окне модели.

Вместо задания расстояния можно указать точечный объект. В этом случае будет построена точка — проекция указанного объекта на направление смещения.


2.5.2.4. Построение точки на пересечении объектов

Пересечение — способ построения точки на пересечении двух объектов. Объектами являются оси, пространственные кривые и их сегменты, ребра, линии эскиза, грани поверхностей и тел. Точка строится автоматически при соблюдении необходимого условия — наличия конечного числа точек пересечения объектов.

Чтобы построить точку, выполните следующие действия.

1. При нажатой кнопке Объект 1 укажите курсором в модели объект — кривую или поверхность. Наименование выбранного объекта отображается в поле Объект 1.

2. При нажатой кнопке Объект 2 укажите курсором в модели второй объект, пересекающийся с первым. Наименование выбранного объекта отображается в поле Объект 2. Если объект не имеет общих точек с первым или число общих точек бесконечно, то определения в поле Объект 2 не произойдет. В этом случае следует вновь указать второй объект или выбрать другую пару объектов.

Указание объектов может производиться в любой последовательности.

После того как оба объекта определены, на экране появится фантом точки.

Чтобы использовать другой объект для выполнения команды, нажмите кнопку Объект 1 или Объект 2. Выделение объекта будет отменено, и вы сможете указать новый.

Если точек пересечения несколько, то они будут поочередно отображаться при нажатии кнопок Следующий объект и Предыдущий объект Панели специального управления. После того как на экране появится нужная точка, завершите создание объекта.


2.5.2.5. Построение точки на кривой

На кривой — способ построения точки, смещенной вдоль кривой на некоторое расстояние от ее вершины. Расстояние может быть задано в относительных или абсолютных величинах.

В качестве кривой может быть выбрана любая пространственная кривая или ее сегмент, линия эскиза или ребро.

Чтобы построить точку на кривой, выполните следующие действия.

1. Укажите курсором в модели кривую. В модели выбранная кривая подсветится. На кривой будут созданы два фантома: точка в месте указания и начальная вершина со стрелкой направления отсчета расстояния. Одновременно в поле Кривая Панели свойств отображается наименование выбранного объекта.

2. Переместите характерную точку мышью вдоль кривой в нужное положение.

Также вы можете задать числовое значение смещения на Панели свойств. Для этого необходимо выбрать вариант его задания из раскрывающегося списка Смещение, содержащего доступные способы.

– В % от длины кривой — по относительной величине смещения от начальной до характерной точки. В поле ввода % от длины кривой задается величина в процентах от 0 до 100 от длины кривой.

– По длине сегмента — по длине кривой от начальной до характерной точки. В поле ввода Длина сегмента задается абсолютное смещение в единицах измерения длины.

– По центральному углу дуги — по центральному углу от начальной до характерной точки. Вариант доступен, если в качестве кривой выбрана дуга окружности или эллипса. В поле ввода Угол задается центральный угол дуги в единицах измерения угла.

После выбора кривой в поле текущего параметра отображается его значение в точке на кривой. При перемещении точки мышью параметры вычисляются и заносятся в эти поля.

Введите или задайте счетчиком величину параметра смещения.

В процессе построения можно переключаться между вариантами. При этом величина смещения будет пересчитываться и отображаться в единицах выбранного варианта.

Построить точку на кривой можно, связав ее с уже имеющимся точечным объектом. Для этого укажите точечный объект (перечень объектов — см. раздел 2.5.2.1.1).

Положение точки определяется кратчайшим расстоянием от точечного объекта до кривой.

Благодаря ассоциативной связи вновь созданная точка будет следовать за объектом при изменении его положения. Признаком наличия связи является отображение «галочки» на кнопке Объект и наименования точечного объекта в поле Объект на Панели свойств. В этом случае поле ввода параметра смещения точки вдоль кривой недоступно для редактирования.

Чтобы отменить ассоциативную связь с точечным объектом, следует нажать кнопку Объект. «Галочка» на кнопке исчезнет. После этого становится доступным поле ввода параметра смещения.

Для восстановления ассоциативной связи точки с точечным объектом необходимо указать нужный объект заново.

При нажатой кнопке От начальной вершины группы переключателей Направление смещение отсчитывается от начальной вершины кривой в направлении вектора смещения. Чтобы изменить направление, нажмите кнопку От конечной вершины.

Пока параметр смещения не задан пользователем, смена направления не вызывает изменения положения точки на кривой.


2.5.2.6. Построение точки на поверхности

На поверхности — способ построения точки, лежащей на поверхности. Поверхностями могут служить:

– грани поверхностей и тел,

– координатные плоскости.

Положение точки можно задать:

– смещением вдоль изопараметрических кривых U и V теоретической поверхности указанной грани,

– смещением (линейным или угловым) точки от двух указанных опорных объектов,

– координатами на поверхностях:

• плоской (доступно два вида координат – прямоугольные и полярные),

• цилиндрической (в цилиндрической системе координат),

• сферической (в сферической системе координат).

Общие сведения о теоретической поверхности и изопараметрических кривых приведены в разделе 2 Приложения IX.

Для построения точки на поверхности необходимо указать поверхность, выбрать вариант указания положения точки и задать параметры, определяющие положение.

Чтобы указать поверхность, при нажатой кнопке Поверхность укажите курсором в модели грань или плоскость. Выбранный объект подсвечивается, его название появляется в поле Поверхность.

Чтобы выбрать вариант задания положения точки, выберите нужную строку из списка Смещение. Варианты подробно описаны в разделах 2.5.2.6.1–2.5.2.6.4.

Опция Учитывать границы позволяет ограничить положение точки контуром грани: при включенной опции точка может находиться только внутри этого контура, а при отключенной — как внутри, так и снаружи (при необходимости теоретическая поверхность грани продлевается). Если точка строится на вспомогательной или координатной плоскости, то опция Учитывать границы недоступна.

В этом разделе:

2.5.2.6.1. По параметрам U и V

2.5.2.6.2. По смещениям от двух объектов

2.5.2.6.3. По координатам на плоскости

2.5.2.6.4. По координатам на цилиндре и сфере


2.5.2.6.1. По параметрам U и V

Данный вариант задания положения точки применяется, если известны относительные величины смещения, либо если нужно просто создать точку, лежащую на теоретической поверхности грани.

Если выбран этот вариант, то на указанной грани отображается фантом ее теоретической поверхности в виде сетки из пересекающихся изопараметрических кривых. На фантоме показаны:

– стрелками — направления влияния параметров U и V в точке начала U=0, V=0;

– пунктирными линиями — фантомы параметров U и V в точке указания.

На Панели свойств присутствуют поля Параметр U, % и Параметр V, %. В них отображаются текущие значения параметров U и V в точке указания грани.

Способы задания положения точки на поверхности

– Перемещение характерной точки мышью в окне модели
При перемещении мышью характерной точки (о характерных точках см. раздел 2.1.4.2.2) текущие значения параметров, определяющие положение точки, отображаются в соответствующих полях.

– Ввод параметров, определяющих положение точки, в соответствующие поля на Панели свойств
Введите значения параметров U и V или задайте их счетчиком и зафиксируйте нажатием клавиши <Enter>.

– Связывание с точечным объектом
Подведите курсор к точечному объекту (перечень объектов — см. раздел 2.5.2.1.1) — рядом с объектом появится условное изображение вершины или точки. Положение создаваемой точки определяется как проекция указанного точечного объекта на поверхность построения. Благодаря установленной ассоциативной связи, вновь созданная точка будет следовать за объектом при изменении его положения.

Признаком наличия связи является отображение «галочки» на кнопке Объект и наименования точечного объекта в поле Объект на Панели свойств. Значения параметров U и V отображаются в соответствующих полях Панели свойств, при этом они недоступны для редактирования.

Чтобы отменить ассоциативную связь с точечным объектом, следует нажать кнопку Объект. «Галочка» на кнопке исчезнет.

Для восстановления ассоциативной связи точки с точечным объектом необходимо указать нужный объект заново.


2.5.2.6.2. По смещениям от двух объектов

Вариант По смещениям от двух объектов применяется, если известно смещение (линейное или угловое) точки от двух опорных объектов.

В общем случае точка располагается на произвольной поверхности, а смещение задается расстояниями до нее от двух плоских объектов. В качестве плоских объектов могут использоваться:

– плоские грани,

– вспомогательные и координатные плоскости,

– ребра в форме плоских кривых,

– эскизы (в Дереве построения).

Плоские объекты должны удовлетворять следующим требованиям:

– быть непараллельны друг другу,

– линия пересечения их плоскостей не должна быть параллельна поверхности (или образующей поверхности), на которой располагается точка.

Кроме того, возможны следующие частные случаи:

– если точка располагается на плоской грани, то в качестве опорного объекта для нее можно использовать прямолинейное ребро; смещение в этом случае отсчитывается от плоскости, проходящей через это ребро перпендикулярно плоской грани;

– если точка располагается на поверхности вращения (кроме сферической), то для нее возможно задание углового смещения от плоскости, проходящей через ось поверхности (смещение от второго объекта при этом — линейное); для задания такой плоскости можно указать совпадающий с ней плоский объект или лежащее в ней прямолинейное ребро.

Если выбран вариант По смещениям от двух объектов, то на Панели свойств появляются поля Объект 1 и Объект 2. В них отображаются названия автоматически определенных системой объектов, от которых отсчитывается смещение точки.

Группы переключателей Тип параметра 1 и Тип параметра 2 позволяют указать тип смещения — линейное или угловое.

Переключение типа параметра возможно, если точка строится на поверхности вращения и в качестве опорного объекта выбрана плоскость, проходящая через ось вращения. В остальных случаях тип параметра определяется системой автоматически и смена его невозможна.

В полях Расстояние 1/Угол 1 и Расстояние 2/Угол 2 отображаются вычисленные смещения точки в ее текущем положении от указанных объектов.

В окне модели отображаются стрелки, указывающие положительное направление отсчета смещения.

Измените значения смещения, при необходимости смените опорные объекты и/или тип смещения. Обратите внимание на то, что ввод смещений возможен, только если оба опорных объекта определены.

В качестве второго опорного объекта можно указать только такой объект, который при выбранной поверхности и первом опорном объекте дает конечное число точек.

Способы задания положения точки на поверхности аналогичны используемым в варианте По параметрам U и V (см. раздел 2.5.2.6.1).

Если заданным условиям удовлетворяют несколько точек на поверхности, на Панели специального управления становятся доступны кнопки Следующий объект и Предыдущий объект. Используя эти кнопки, выберите точку для построения и завершите создание объекта.


2.5.2.6.3. По координатам на плоскости

Вариант По координатам на плоскости применяется, если нужно построить точку на плоскости, задав ее прямоугольные или полярные координаты.

Если используется этот вариант, то на Панели свойств появляется группа переключателей Тип координат, позволяющая выбрать тип координат для построения точки:

– Прямоугольные координаты,

– Полярные координаты.

Если для построения точки выбраны прямоугольные координаты, то на Панели свойств появляются поля X и Y, если выбраны полярные координаты — поля R и A. По умолчанию точка размещается в точке указания плоскости. Текущие координаты точки отображаются в соответствующих полях Панели свойств.

Способы задания положения точки на поверхности аналогичны используемым в варианте По параметрам U и V (см. раздел 2.5.2.6.1).


2.5.2.6.4. По координатам на цилиндре и сфере

Вариант По координатам на цилиндре применяется, если нужно построить точку на цилиндрической поверхности с использованием цилиндрических координат. При выборе данного способа на Панели свойств появляются поля A и Z.

Вариант По координатам на сфере применяется, если нужно построить точку на сферической поверхности с использованием сферических координат. При выборе такого способа на Панели свойств появляются поля A и B.

Подробнее о цилиндрических и сферических координатах рассказано в разделе 2.5.3.4.1.

Для построения точки в цилиндрических координатах необходимо, чтобы центр текущей системы координат лежал на оси цилиндрической поверхности, ось которой совпадает с осью Z текущей системы координат, а для построения точки в сферических координатах необходимо, чтобы центр текущей системы координат совпадал с центром сферы.

Поэтому выбор варианта По координатам на цилиндре (сфере) доступен, если для размещения точки указана цилиндрическая (сферическая) поверхность, удовлетворяющая вышеописанным требованиям. И наоборот, если вариант уже выбран, для указания доступны только такие цилиндрические (сферические) поверхности, которые удовлетворяют требованиям.

По умолчанию точка размещается в точке указания на поверхности. Текущие координаты точки отображаются в соответствующих полях Панели свойств.

Способы задания положение точки на поверхности аналогичны используемым в варианте По параметрам U и V (см. раздел 2.5.2.6.1).


2.5.2.7. Построение точки в центре объекта

В центре — способ создания точки в центре объекта (для тел и граней — в центре масс).

Объектами являются:

– ребра, представляющие собой окружности, эллипсы или их дуги,

– линии эскиза, представляющие собой окружности, эллипсы или их дуги,

– сферические поверхности,

– тела,

– грани.

Чтобы построить точку, укажите объект. Наименование объекта отобразится в поле Объект. В модели точка будет создана автоматически.

Указание тел производится в Дереве построения модели. Пиктограммы и названия тел показываются в Дереве, если в нем включено отображение структуры модели (см. раздел 2.1.2.2).

При расчете центра масс грани учитывается только ее внешний контур.


2.5.2.8. Построение проекции точки на объект

Проекция — способ создания точки как проекции опорной точки на объект.

Опорной точкой может служить любой точечный объект.

Объектами, на которые проецируется опорная точка, являются:

– грани, вспомогательные и координатные плоскости;

– ребра, пространственные кривые, линии эскиза, вспомогательные прямые, координатные оси.

Проекция может быть выполнена ортогонально или в направлении, заданном объектом. Перечень объектов и определяемые ими направления приведены в разделе 2.5.2.1.1.

Кроме того, направляющим объектом может служить вектор. Этот вектор можно создать при помощи команды Построение вектора (см. раздел 2.8.5).

Чтобы построить проекцию, выполните следующие действия.

1. Укажите опорную точку. Наименование точки отображается в поле Опорная точка.

2. При нажатой кнопке Объект укажите объект, на который проецируется опорная точка. Наименование объекта отображается в поле Объект, а в модели появляется фантом ортогональной проекции точки.

3. Завершите создание точки, если требуется построение ортогональной проекции.

Выберите направляющий объект или создайте вектор, если требуется построить проекцию в заданном направлении. Для этого нажмите кнопку Направляющий объект, а затем укажите объект, определяющий направление, или постройте вектор.
Фантом изменит свое положение. Завершите создание точки.

Точка строится только в случаях, если проекция попадает на объект, а не на его продолжение. Исключение составляют плоская поверхность и поверхность вращения — проекция может быть построена на их продолжении.

Вспомогательные и координатные плоскости и оси бесконечны, поэтому проекция создается вне зависимости от ее расположения относительно прямоугольника или отрезка, изображающего плоскость или ось.


2.5.2.9. Построение точки по цилиндрическим (RAZ) и сферическим (RAB) координатам

2.5.2.9. Построение точки по цилиндрическим (RAZ)
и сферическим (RAB) координатам

По цилиндру (RAZ) — способ построения точки, позволяющий задавать ее цилиндрические координаты (R, A, Z) в пространстве или связывать ее с уже имеющимся точечным объектом.

По сфере (RAВ) — способ построения точки, позволяющий задавать ее сферические координаты (R, A, В) в пространстве или связывать ее с уже имеющимся точечным объектом.

О размещении цилиндрической и сферической систем координат относительно системы координат точки рассказано в разделе 2.5.3.4.1.

Радиус сферы или цилиндра можно задать, введя его значение в поле координаты R, или указав объект, определяющий значение радиуса.

Чтобы задать объект, определяющий радиус, активизируйте переключатель Объект радиуса и укажите нужный объект:

– ребро или линию эскиза в форме окружности или дуги окружности,

– кривую — окружность или дугу,

– цилиндрическую или сферическую грань.

Значение радиуса указанного объекта заносится в поле R. Между точкой и объектом формируется ассоциативная связь, поэтому поле R становится недоступным. Чтобы отменить связь, активизируйте переключатель Объект радиуса и повторно укажите объект.

Остальные приемы работы при построении точки По цилиндру (RAZ) и По сфере (RAB) — ввод и фиксация координат точки, связывание ее с уже имеющимся точечным объектом — такие же, как при построении точки По координатам (XYZ) (см. раздел 2.5.2.2).

Если для построения точки указаны два объекта: точечный и определяющий радиус, то точка создается как проекция точечного объекта на цилиндр или сферу соответствующего радиуса.


2.5.2.10. Переменные точки

После создания точки в модели автоматически формируются переменные этой точки.

Среди переменных точки три — информационные. Они соответствуют декартовым координатам точки. Эти переменные создаются всегда.

Наличие и состав остальных переменных определяется способом построения точки (табл. 2.5.1).

Табл. 2.5.1. Переменные точки
Способ построения точки | Переменные
По координатам | – координата X – координата Y – координата Z
Перенос | – относительная координата X – относительная координата Y – относительная координата Z или – расстояние смещения
На кривой | – значение смещения (величина смещения в %, или длина дуги, или центральный угол) – направление смещения
На поверхности | – значение параметра U в % – значение параметра V в % или – смещение от первого плоского объекта – смещение от второго плоского объекта или – координата X (или R) – координата Y (или A)

Если точка создается в локальной, а не в абсолютной системе координат, то при использовании большинства способов построения у такой точки будут только информационные переменные.

На рисунке 2.5.3 показаны переменные точки, построенной способом На поверхности.

Рис. 2.5.3. Переменные точки

Работа с переменными и выражениями подробно рассмотрена в разделе 7.1.


2.5.2.11. Использование функционала команды Точка при создании других объектов

2.5.2.11. Использование функционала команды Точка
при создании других объектов

Построение точки с использованием всех способов, доступных в команде Точка, возможно при выполнении следующих команд:

– Сплайн,

– Ломаная,

– Отрезок,

– Дуга окружности,

– Поверхность по сети точек,

– Поверхность по пласту точек,

– Контрольная точка,

– Присоединительная точка,

– Ось через вершину по объекту,

– Масштабирование,

– Плоскость, касательная к грани в точке,

– Плоскость через вершину перпендикулярно ребру,

– Создать зону,

– Создать/редактировать сечение,

– Добавить из файла,

– Добавить локальную деталь из файла,

– Деталь-заготовка,

– Разместить компонент.

Порядок построения точки при работе с перечисленными командами описан в разделе 2.5.2.11.1.

Особенностью команд Ось через вершину по объекту, Масштабирование и команд построения вспомогательных плоскостей является то, что построенные при их выполнении точки отображаются в Дереве построения как самостоятельные объекты. Изменение параметров этих точек производится путем непосредственного их редактирования.

Точки же, построенные при выполнении остальных команд, хранятся внутри объектов, созданных этими командами, и не отображаются в Дереве построения. Изменение параметров этих точек производится не непосредственно, а при редактировании объектов, для которых они создавались. Порядок и возможности редактирования таких точек описаны в разделе 2.5.2.11.2.

При добавлении компонента в модель или редактировании параметров его размещения, а также при создании/редактировании сечения модели новые точки вообще не создаются. Процесс построения точки используется только для определения положения точки вставки компонента или точек, определяющих положение сечения (плоского или в виде параллелепипеда).

В этом разделе:

2.5.2.11.1. Построение точки в процессе создания объекта

2.5.2.11.2. Редактирование точки, построенной в процессе создания объекта


2.5.2.11.1. Построение точки в процессе создания объекта

Чтобы построить точку, необходимо нажать кнопку Построение точки на Панели специального управления.

Система переходит в процесс создания точки, полностью аналогичный вызываемому командой Точка (см. раздел 2.5.2.1). Выберите способ построения точки, а затем задайте требуемые для этого способа параметры (введите значения или укажите объекты). Создаваемая точка отображается на экране в виде фантома.

Завершив задание параметров точки, нажмите кнопку Создать объект на Панели специального управления.

Система возвращается к выполнению команды, для которой была построена точка.

Название способа построения точки отображается в специальном поле Панели свойств. Если точка была построена способом По координатам (XYZ), то в этом поле отображаются координаты точки.

Рис. 2.5.4. Отображение на Панели свойств параметров точки, построенной в процессе создания дуги

При создании ломаной или сплайна обратите внимание на следующие особенности построения точек.

– В процессе построения точки при нажатии кнопки Создать объект происходит фиксация точки без возвращения в процесс создания ломаной или сплайна. Благодаря этому можно построить несколько вершин кривой подряд. Для завершения процесса построения точки необходимо нажать кнопку Прервать команду.

– В таблице параметров вершин сплайна или ломаной всегда отображаются координаты точек и не отображаются названия способов их построения.


2.5.2.11.2. Редактирование точки, построенной в процессе создания объекта

1. Войдите в режим редактирования объекта.

2. Выделите точку объекта, которую требуется отредактировать, в окне модели или с помощью элементов управления на Панели свойств. При редактировании контрольной или присоединительной точки выделение не требуется.
Обратите внимание на то, что при подведении курсора к точке около него отображается название способа построения точки и ее координаты. Для контрольной или присоединительной точки способ построения точки отображается в информационном поле Точка на Панели свойств.

3. Задайте новое положение точки, выполнив одно из следующих действий.

– Укажите в окне модели точечный объект. Информация о построенной точке удаляется, и редактируемая точка совмещается с указанным объектом. Если на Панели свойств была включена опция Ассоциировать, то точка ассоциируется с объектом.

– Нажмите кнопку Построение точки на Панели специального управления. Система перейдет в процесс редактирования точки, аналогичный процессу ее построения. Измените параметры текущего способа построения точки или выберите другой способ и постройте точку заново. Завершив редактирование, нажмите кнопку Создать объект для выхода из процесса редактирования точки.

– При редактировании дуг, поверхностей, сплайнов и ломаных возможно перемещение точки мышью в соответствии со способом, которым она была построена. Например, точку, находящуюся на кривой, можно сдвинуть вдоль этой кривой. Некоторые способы построения, например, На пересечении, не подразумевают свободного перемещения точки.

– Точка, ассоциированная с точечным объектом, не может быть перемещена произвольно — она следует за точечным объектом. Вы можете удалить связь. Для этого:

• при редактировании дуги следует нажать кнопку Объект на Панели свойств,

• при редактировании сплайна или ломаной следует отключить опцию в колонке Связь с точечным объектом таблицы параметров вершин,

• при редактировании поверхности следует войти в процесс редактирования точки, нажав кнопку Построение точки на Панели специального управления, и нажать кнопку Объект на Панели свойств, а затем — кнопку Создать объект.

После удаления ассоциативной связи точка по-прежнему совпадает с точечным объектом, но уже может быть произвольно перемещена мышью.

Контрольная или присоединительная точка всегда ассоциирована с точечным объектом.

4. Завершив изменение положения точки, нажмите кнопку Создать объект. Отредактированный объект в окне модели будет перестроен.


2.5.3. Группы точек

2.5. Точки и кривые

2.5.3. Группы точек

Группы пространственных точек можно создавать таким образом, чтобы они лежали на существующем объекте — кривой или поверхности. Также группа точек может быть создана по их координатам, сохраненным в файле.

Команды создания групп точек находятся в меню Операции.

Кнопки для их быстрого вызова находятся на панели Пространственные кривые (рис.2.5.5).

Рис. 2.5.5. Команды создания групп точек

В этом разделе:

2.5.3.1. Общие приемы создания групп точек

2.5.3.1.1. Разрушение группы точек

2.5.3.2. Группа точек по кривой

2.5.3.2.1. Задание положения точек на рабочем участке

2.5.3.2.2. Задание положения рабочего участка на кривой

2.5.3.3. Группа точек по поверхности

2.5.3.3.1. Задание положения центра сетки при построении группы точек способом По сетке вокруг заданной точки

2.5.3.3.2. Настройка параметров сетки при построении группы точек способом По сетке вокруг заданной точки

2.5.3.4. Группа точек из файла

2.5.3.4.1. Тип координат точки

2.5.3.4.2. Связь группы точек с файлом-источником


2.5.3.1. Общие приемы создания групп точек

После вызова команды создания группы выберите объект, на котором должны лежать элементы группы. Его название появится в поле на Панели свойств.

Если группа точек создается по данным, считанным из файла, укажите имя файла и путь к нему. На Панели свойств появится его имя.

Задайте параметры группы и свойства точек при помощи полей и переключателей на Панели свойств.

Фантом группы точек отображается на экране. Это позволяет оценить правильность задания параметров и выбора исходных объектов.

При необходимости измените название группы, цвет и стиль отображения точек. Для этого служат элементы управления, расположенные на вкладке Свойства Панели свойств.

Подтвердите создание группы.

Созданная группа точек появится в окне модели, а соответствующая ее типу пиктограмма — в Дереве построения (рис. 2.5.6).

Группа точек состоит из элементов.

Элементы группы точек отображаются в Дереве построения как отдельные объекты, подчиненные группе.

Чтобы развернуть список элементов, щелкните мышью на значке «плюс», расположенном слева от пиктограммы группы в Дереве построения.

Рис. 2.5.6. Группа точек в Дереве построения
а) по поверхности | б) по кривой | в) из файла

Справа от пиктограммы элемента группы в круглых скобках отображается номер этого элемента.

Если группа построена по поверхности, номер элемента группы состоит из двух чисел. Первое — номер элемента по параметру V, второе — номер элемента по параметру U. Нумерация экземпляров начинается с единицы.

Группу точек можно разрушить на отдельные элементы (см. раздел 2.5.3.1.1).

Если при создании группы была включена опция Рассыпать, то после завершении команды положение точек будет соответствовать настройкам. Однако они не будут элементами группы. Состояние построенных точек будет таким же, как если бы к построенной группе была применена команда Разрушить.

В этом разделе:

2.5.3.1.1. Разрушение группы точек


2.5.3.1.1. Разрушение группы точек

Группы точек можно разрушить на отдельные элементы.

Для этого выделите в Дереве построения группы точек, которые требуется разрушить, и вызовите из меню Редактор команду Разрушить.

Для разрушения одной группы точек команду Разрушит можно вызвать из контекстного меню группы точек в Дереве построения.

После вызова команды на экране появляется диалог разрушения. Чтобы подтвердить разрушение, нажмите в этом диалоге кнопку ОК.

Разрушение группы производится по следующим правилам:

– пиктограмма группы и ее объектов удаляется из Дерева построения;

– объекты, составлявшие группу, остаются в том положении, в котором находились в группе.

Типы объектов, которые появляются в результате разрушения, зависят от типов исходных объектов группы (табл. 2.5.2).

Табл. 2.5.2. Результаты разрушения группы объектов
Тип исходного объекта | Тип объектов, полученных в результате разрушения группы
Группа точек по кривой | Точка, построенная способом По кривой.
Группа точек по поверхности | Точка, построенная способом По поверхности.
Группа точек из файла | Точка, построенная способом По координатам (XYZ), По цилиндру (RAZ) или По сфере (RAB) в зависимости от способа интерпретации данных, считанных из файла.
Группа изопараметрических кривых на поверхности | Изопараметрическая кривая.


2.5.3.2. Группа точек по кривой

Чтобы создать группу точек, лежащих на кривой, вызовите команду Группа точек по кривой.

Укажите кривую, на которой должны лежать точки. В качестве кривой может быть выбрана любая пространственная кривая или ее сегмент, линия эскиза или ребро.

Название объекта появится в поле Кривая.

В модели появляется фантом группы. Крайние точки фантома являются ее характерными точками. Вы можете использовать их для задания рабочего участка кривой — части кривой, в пределах которой выполняется построение группы точек.

Управлять количеством точек в группе и их взаимным положением можно, используя элементы управления, которые становятся доступными при выборе одного из вариантов раскрывающегося списка Способ (см. раздел 2.5.3.2.1).

Управлять положением рабочего участка кривой можно следующими способами:

– перемещая характерные точки при помощи мыши,

– используя элементы управления, расположенные на Панели свойств (см. раздел 2.5.3.2.2).

В этом разделе:

2.5.3.2.1. Задание положения точек на рабочем участке

2.5.3.2.2. Задание положения рабочего участка на кривой


2.5.3.2.1. Задание положения точек на рабочем участке

Способы расположения точек группы на рабочем участке кривой можно задать при помощи раскрывающегося списка Способ на вкладке Параметры Панели свойств.

Способ
Равномерно по длине

Построение группы точек с использованием данного способа производится следующим образом.

1. Начальная и конечная точки группы совмещаются с соответствующими границами рабочего участка кривой.

2. Остальные точки размещаются между ними с равным шагом по кривой.

Введите или задайте счетчиком нужное количество точек в группе в поле Количество точек.

Способ
Шаг по кривой

Построение группы точек с использованием данного способа производится следующим образом.

1. Начальная точка группы совмещается с начальной границей рабочего участка кривой.

2. Остальные точки размещаются после нее с заданным шагом по кривой.

Введите или задайте счетчиком нужное расстояние между точками в группе в поле Шаг.

Для этого способа доступна опция По всей кривой. Если она включена, то в пределах всего рабочего участка кривой будет построена группа, количество точек в которой равно результату целочисленного деления длины кривой на указанный шаг плюс одна точка. Этот результат появится в поле Количество точек, доступном только для чтения.

Если опция выключена, поле Количество точек становится доступным для изменения. От начальной точки рабочего участка будет построено столько точек с выбранным шагом, сколько задано в этом поле.

Произведение шага и числа, на единицу меньшего количества точек, не должно превышать длины кривой.

Способ
Равный шаг по параметру кривой

Построение группы точек с использованием данного способа производится следующим образом.

1. Начальная и конечная точки группы совмещаются с соответствующими границами рабочего участка кривой.

2. В параметрической области кривой (см. раздел 2.5.2) находятся точки, соответствующие границам рабочего участка кривой. Часть параметрической области, ограниченная этими точками, разбивается на равные части. Число частей равно n-1, где n — заданное количество точек.

3. Точки разбиения отображаются из параметрической области на кривую. C найденными точками совмещаются остальные точки группы.

В поле Количество точек выберите при помощи счетчика или введите с клавиатуры количество создаваемых точек.

Если кривая, на которой должны лежать точки, многосегментная, то построение группы производится следующим образом.

1. Каждый сегмент кривой имеет свою параметрическую область. Параметрические области сегментов кривой равны между собой и составляют суммарную область, в пределах которой выполняется построение группы точек.

2. Начальная и конечная точки группы совмещаются с соответствующими границами суммарной области.

3. Суммарная область разбивается на равные части (рис. 2.5.7, а). Число частей равно n-1, где n — заданное количество точек.

4. Точки разбиения отображаются из суммарной области на сегменты кривой (рис. 2.5.7, б). C найденными точками совмещаются остальные точки группы.

Рис. 2.5.7. Пример построения группы из 7 точек на ломаной: а) разбиение суммарной параметрической области ломаной на 6 равных участков, б) отображение точек разбиения на сегменты ломаной
а) | б)


2.5.3.2.2. Задание положения рабочего участка на кривой

Для всех способов построения доступны элементы управления, позволяющие задавать параметры расположения рабочего участка на кривой.

Переключатель Сменить направление позволяет выбрать вершину кривой, от которой будет начинаться рабочий участок.

По умолчанию построение группы выполняется от конечных точек кривой. Опция Отступы позволяет задать смещения рабочего участка от вершин кривой. Если опция включена, становятся доступными элементы управления, управляющие формированием отступов. Опция включается автоматически, если положение рабочего участка изменить перемещением характерных точек.

Группа переключателей Граница рабочего участка позволяет выбрать крайнюю точку рабочего участка, для которой выполняется настройка отступов. Используя эти переключатели поочередно, можно задать отступы для начальной и конечной точек.

Также вы можете задать числовые значения каждого из отступов на Панели свойств. Для этого необходимо выбрать вариант его задания из раскрывающегося списка Смещение, содержащего типы параметров.

– В % от длины кривой. В поле ввода % от длины кривой задается величина в процентах от 0 до 100 от длины кривой.

– По длине сегмента. В поле ввода Длина сегмента задается абсолютное смещение в единицах измерения длины.

– По центральному углу дуги. В поле ввода Угол задается центральный угол дуги в единицах измерения угла. Способ доступен, если в качестве кривой указана дуга окружности или эллипса.

При перемещении характерной точки мышью значения параметров вычисляются и заносятся в эти поля.

Введите или задайте счетчиком величину параметра отступа.

В процессе построения можно переключаться между вариантами. При этом величина отступа будет пересчитываться и отображаться в единицах измерения выбранного варианта.

При нажатой кнопке От начальной вершины группы переключателей Направление отступ отсчитывается от начальной вершины кривой в направлении вектора смещения. Чтобы изменить направление, нажмите кнопку От конечной вершины.


2.5.3.3. Группа точек по поверхности

Вы можете создать группу точек, лежащих на поверхности. Поверхностями могут служить грани поверхностей и тел.

В результате выполнения команды создается группа в виде сетки точек. Точки сетки можно представить вершинами многогранника, аппроксимирующего исходную поверхность, по заданным параметрам.

Чтобы создать группу точек, лежащих на поверхности, выполните следующие действия.

1. Вызовите команду Группа точек по поверхности.

2. После вызова команды автоматически на Панели свойств активизируется переключатель Поверхность. Укажите грань, которой должны принадлежать точки.

О выборе объектов подробно рассказано в разделе 2.1.4.1.1.

После выбора объекта его наименование появляется в поле Поверхность Панели свойств.

В модели выбранная грань подсвечивается. На ней появляются:

– фантом ее теоретической поверхности; стрелками показаны направления влияния параметров U и V в точке начала U=0, V=0;

– фантом группы точек; пунктирными линиями показаны фантомы параметров U и V в точке указания.

Общие сведения о теоретической поверхности грани приведены в разделе 7 Приложения IX.

3. Выберите способ расположения точек в группе из раскрывающегося списка Способ на Панели свойств, а затем задайте требуемые для этого способа параметры. Способы построения группы приведены в табл. 2.5.3.

Табл. 2.5.3. Способы построения группы точек по поверхности

Способ

Порядок построения

По количеству точек в направлениях U и V

Количество точек в направлениях U и V задается пользователем.

В полях Количество точек, U и Количество точек, V выберите при помощи счетчика или введите с клавиатуры количество точек в данном направлении.

По линейному отклонению1

Точки строятся таким образом, чтобы отклонение ребер аппроксимирующего многогранника, соединяющих соседние точки в направлениях U и V, от поверхности не превышало заданного пользователем значения.

В поле Линейное отклонение выберите при помощи счетчика или введите с клавиатуры значение максимального отклонения.

По угловому отклонению1

Точки строятся таким образом, чтобы угол между касательной к поверхности в точке и ребром аппроксимирующего многогранника, соединяющим эту точку с соседними в направлениях U и V, не превышал заданного пользователем значения.

В поле Угловое отклонение выберите при помощи счетчика или введите с клавиатуры значение максимального углового отклонения.

По сетке вокруг заданной точки

Точки располагаются на теоретической поверхности указанной грани так, чтобы образовывать сетку вокруг заданной точки, лежащей на этой же теоретической поверхности. Заданная точка является центром сетки. Сетка может быть прямоугольной, концентрической или гексагональной. Примеры групп точек, построенных данным способом, показаны на рисунке 2.5.8; центр сетки отмечен кружком. Задание положения центра сетки описано в разделе 2.5.3.3.1, настройка параметров сетки — в разделе 2.5.3.3.2.
  1. При выборе способов по линейному и угловому отклонению плотность расположения точек по поверхности будет зависеть от ее кривизны. На участках с большей кривизной точки будут расположены чаще, с меньшей кривизной — реже.

Рис. 2.5.8. Группа точек, построенная способом По сетке вокруг заданной точки: а) прямоугольная сетка; б) концентрическая сетка; в) гексагональная сетка
а) | б) | в)

4. Выберите вариант построения группы точек с помощью опции Учитывать границы.

– При включенной опции группа точек строится в пределах контура указанной грани.

– При отключенной опции группа строится на теоретической поверхности грани.

На рисунке показаны варианты построения группы точек на грани с отверстием.

Рис. 2.5.9. Пример построения группы точек по поверхности: а) группа точек при отключенной опции Учитывать границы б) группа точек при включенной опции Учитывать границы
а) | б)

В этом разделе:

2.5.3.3.1. Задание положения центра сетки при построении группы точек способом По сетке вокруг заданной точки

2.5.3.3.2. Настройка параметров сетки при построении группы точек способом По сетке вокруг заданной точки


2.5.3.3.1. Задание положения центра сетки при построении группы точек способом По сетке вокруг заданной точки

2.5.3.3.1. Задание положения центра сетки при построении
группы точек способом По сетке вокруг заданной точки

Положение центра сетки можно задать двумя способами.

Способ 1

Задание параметров U и V центра сетки на теоретической поверхности грани.

Укажите положение центра сетки щелчком мыши на грани или введите в поля Параметр U, % и Параметр V, % нужные значения параметров U и V в процентах.

Общие сведения о теоретической поверхности грани приведены в разделе 7 Приложения IX 2.

Вы можете также задать положение центра сетки перемещением характерной точки «Центр» фантома группы точек (см. рис. 2.5.10).

Способ 2

Указание точечного объекта, лежащего на выбранной грани и находящегося в ее пределах. В качестве точечного объекта может использоваться:

• вершина грани;

• точка в пространстве при условии, что она является непосредственно исходной или непосредственно производной по отношению к указанной грани1.

Укажите в Дереве или окне модели нужный точечный объект.

На кнопке Объект отображается «галочка», а в поле рядом с кнопкой — название объекта. Это свидетельствует о наличии ассоциативной связи центра сетки с выбранным объектом. Благодаря этой связи центр сетки будет следовать за объектом при изменении его положения. При необходимости связь можно отменить, нажав кнопку Объект. «Галочка» на кнопке исчезнет, поле очистится.

Центр сетки может располагаться как в пределах контура указанной грани, так и выходить за его пределы. При необходимости теоретическая поверхность грани будет продлеваться (это зависит от типа грани). На рисунке показаны примеры размещения центра сетки за пределами контура указанной грани при различных состояниях опции Учитывать границы.

Рис. 2.5.10. Примеры размещения центра сетки за пределами контура указанной грани
при построении группы точек по поверхности:
а) опция Учитывать границы включена; б) опция Учитывать границы отключена

а)

б)

Обратите внимание на то, что если центр сетки выходит за пределы теоретической поверхности грани, то он ограничивает сетку в направлении своего перемещения (рис. 2.5.10, б).

  1. Т.е. в иерархии отношений между точкой и указанной гранью, не должно быть других объектов (о просмотре отношений объектов см. раздел 2.1.2.7.2).


2.5.3.3.2. Настройка параметров сетки при построении группы точек способом По сетке вокруг заданной точки

2.5.3.3.2. Настройка параметров сетки при построении
группы точек способом По сетке вокруг заданной точки

Настройка сетки включает в себя выбор типа сетки и задание ее параметров.

Доступны три типа сетки: прямоугольная, концентрическая и гексагональная (рис. 2.5.8).

Выберите нужный тип сетки из списка Тип сетки (рис. 2.5.11).

Рис. 2.5.11. Раскрывающийся список Тип сетки

На Панели свойств появляются элементы управления, позволяющие настроить параметры сетки выбранного типа.

Доступность того или иного типа сетки зависит от типа грани, которой должны принадлежать точки группы.

– Если для построения группы точек используется сферическая грань, то доступны следующие типы сетки: Прямоугольная и Концентрическая.

– Если используется цилиндрическая грань, то доступны следующие типы сетки: Прямоугольная и Гексагональная.

– Если используется коническая, тороидальная или произвольная грань, то доступна только Прямоугольная сетка.

– Если используется плоская грань, то доступны все типы сетки.

Подробно задание параметров прямоугольной, концентрической и гексагональной сеток описано далее в этом разделе.

До завершения команды система «запоминает» данные, введенные для каждого типа сетки, поэтому вы можете переключаться между типами сетки без потери этих данных.

При необходимости вы можете повернуть сетку вокруг нормали грани в центре сетки на произвольный угол. Такая возможность доступна, если для построения группы точек выбрана поверхность с постоянной кривизной (плоская грань или сфера).

Угол поворота сетки отсчитывается от направления U против часовой стрелки (о параметрическом представлении поверхности см. раздел 2 Приложения IX).

Введите в поле Поворот значение угла поворота сетки. Оно может быть как положительным — поворот против часовой стрелки, так и отрицательным — поворот по часовой стрелке.

Прямоугольная сетка

Набор элементов управления для задания параметров прямоугольной сетки зависит от типа грани, которой должны принадлежать точки группы.

– Если используется плоская, сферическая или цилиндрическая грань, то прямоугольная сетка характеризуется шагами вдоль первой оси и вдоль второй оси. На Панели свойств появляются поля: Шаг по оси 1 и Шаг по оси 2.

– Если используется коническая, тороидальная или произвольная грань, то прямоугольная сетка характеризуется шагами по параметрам U и V. На Панели свойств появляются поля: Шаг по U, % и Шаг по V, %.

Введите в поля нужные значения параметров сетки или установите с помощью счетчика.

Концентрическая сетка

Концентрическая сетка характеризуется количеством радиальных лучей и шагом сетки в радиальном направлении. Для задания этих параметров используются поля на Панели свойств: Количество лучей и Шаг радиальный.

Введите в поля нужные значения параметров сетки или установите с помощью счетчика.

Гексагональная сетка

Гексагональная сетка характеризуется равным шагом между соседними узлами сетки.

Введите в поле Шаг значение шага или установите с помощью счетчика.


2.5.3.4. Группа точек из файла

Чтобы создать группу точек по данным, считанным из файла, вызовите команду Группа точек из файла.

В результате выполнения команды создается группа точек, координаты которых были прочитаны из ранее созданного файла данных (о файле данных см. Приложение VI).

Параметры точек могут быть прочитаны из файлов следующих типов:

– текстовый файл,

– файл электронных таблиц Microsoft Excel,

– файл электронных таблиц Open Office.

Чтобы указать имя файла, нажмите кнопку Файл-источник. На экране появится стандартный диалог открытия файлов Windows. Выберите файл и нажмите кнопку Открыть. Имя файла появится в поле.

Значения, считанные из файла, могут интерпретироваться как прямоугольные, цилиндрические или сферические координаты.

Выбор варианта интерпретации осуществляется при помощи группы переключателей группы Тип координат Панели свойств.

Точки группы будут построены в системе координат, соответствующей выбранному варианту интерпретации данных. Размещение этой системы координат относительно системы координат точки описано в разделе 2.5.3.4.1.

В этом разделе:

2.5.3.4.1. Тип координат точки

2.5.3.4.2. Связь группы точек с файлом-источником


2.5.3.4.1. Тип координат точки

Положение точки может быть задано в прямоугольных (X, Y, Z), цилиндрических (R, A, Z) или сферических (R, A, В) координатах. Для построения точки используется система координат, соответствующая типу координат.

Прямоугольная система координат совпадает с системой координат точки.

Цилиндрическая система координат размещается относительно системы координат точки следующим образом:

– начало цилиндрической системы координат совпадает с началом системы координат точки,

– ось Z цилиндрической системы координат совпадает с осью Z системы координат точки.

Значение координаты A определяет угол поворота точки a и отсчитывается в плоскости XY от оси X против часовой стрелки (рис. 2.5.12).

Рис. 2.5.12. Построение точки по цилиндрическим координатам;
XYZ — система координат точки

Начало сферической системы координат совпадает с началом системы координат точки.

Значение координаты A определяет азимутальный угол a и отсчитывается в плоскости XY системы координат точки от оси X против часовой стрелки (рис. 2.5.13). В плоскости XY проводится луч OC под азимутальным углом к оси X.

Значение координаты В определяет зенитный угол b и отсчитывается от оси Z в плоскости, которая проходит через ось Z и луч OC (рис. 2.5.13).

Рис. 2.5.13. Построение точки по сферическим координатам;
XYZ — система координат точки


2.5.3.4.2. Связь группы точек с файлом-источником

Построенная группа точек сохраняет связь с файлом-источником.

Если содержание файла изменится, пиктограмма группы точек в Дереве построения будет отмечена красной «галочкой».

Чтобы устранить рассогласование между построенной группой и содержанием файла, необходимо вызвать команду Вид — Перестроить модель.

После вызова команды точки группы перестраиваются в соответствии с новыми значениями параметров.

Если файл-источник будет удален или переименован, дополнительно к красной «галочке» пиктограмма группы точек будет помечена признаком ошибки в виде восклицательного знака в красном кружке.

Если при построении группы точек была включена опция Рассыпать, связь построенных точек с файлом-источником не сформируется.

Если к построенной группе точек будет применена команда Разрушить, связь построенных точек с файлом-источником исчезнет.


2.5.4. Пространственные кривые

2.5. Точки и кривые

2.5.4. Пространственные кривые

В КОМПАС-3D возможно создание пространственных кривых следующих типов:

– отрезок,

– дуга окружности,

– спираль цилиндрическая,

– спираль коническая,

– ломаная,

– сплайн.

В модель также можно импортировать пространственные кривые, записанные в файле формата STEP AP203/STEP AP214 или IGES.

Кроме этого, можно усечь кривые и построить следующие объекты:

– сплайн, повторяющий форму объекта,

– кривую по двум ее проекциям,

– кривую, заданную в параметрическом виде,

– скругление угла, образованного двумя кривыми,

– соединение двух кривых,

– эквидистантную кривую,

– контур,

– кривые на поверхности:

• изопараметрическую кривую,

• группу изопараметрических кривых на поверхности,

• линию очерка грани.

– сплайн на поверхности,

– проекционную кривую,

– кривую пересечения поверхностей.

Команды создания пространственных кривых расположены в меню Операции, а кнопки для их вызова находятся на панели Пространственные кривые (рис. 2.5.14).

Рис. 2.5.14. Панель Пространственные кривые

Полученные кривые могут использоваться, например, в качестве направляющих при построении кинематических элементов соответствующей формы, для создания поверхностей по сети кривых и др.

Модель может содержать так называемые кривые без истории. Эти объекты появляются в результате разрушения массивов некоторых типов кривых (см. раздел 2.7.1.3.7).

В этом разделе:

2.5.4.1. Параметры отображения кривых

2.5.4.2. Импортированная кривая

2.5.4.3. Отрезок

2.5.4.3.1. Построение по 2 точкам

2.5.4.3.2. Построение по точке, длине и углу наклона

2.5.4.4. Дуга окружности

2.5.4.4.1. Построение по 3 точкам

2.5.4.4.2. Построение по центру и радиусу

2.5.4.4.3. Построение по 2 точкам с направлением

2.5.4.4.4. Построение с касанием к кривой

2.5.4.5. Спирали. Общие приемы построения

2.5.4.6. Цилиндрическая спираль

2.5.4.6.1. Способ построения

2.5.4.6.2. Число витков, шаг, высота

2.5.4.6.3. Направление построения

2.5.4.6.4. Направление навивки

2.5.4.6.5. Начальный угол

2.5.4.6.6. Диаметр спирали

2.5.4.6.7. Положение спирали

2.5.4.7. Коническая спираль

2.5.4.7.1. Начальный и конечный диаметры

2.5.4.7.2. Положение спирали

2.5.4.8. Пространственные сплайны и ломаные. Общие приемы построения

2.5.4.8.1. Таблица параметров вершин

2.5.4.8.2. Приемы работы с таблицей параметров

2.5.4.8.3. Построение по точкам

2.5.4.8.4. Построение по осям

2.5.4.8.5. Построение по объектам

2.5.4.8.6. Формирование ассоциативной связи вершин с точечными объектами. Особенности связанных вершин

2.5.4.8.7. Замкнутая или разомкнутая кривая

2.5.4.8.8. Редактирование параметров вершины

2.5.4.9. Пространственный сплайн

2.5.4.9.1. Тип сплайна

2.5.4.9.2. Сопряжение сплайна с объектами модели

2.5.4.9.3. Особенности сопряжения сплайна По полюсам с другими объектами. Системный полюс

2.5.4.9.4. Управление формой сплайна

2.5.4.9.5. Задание ориентации касательной и величины касательности

2.5.4.9.6. Задание кривизны и ориентации нормали

2.5.4.9.7. Направляющий объект для вектора

2.5.4.9.8. Вращение управляющего фантома

2.5.4.10. Пространственная ломаная

2.5.4.10.1. Встраивание совокупности вершин

2.5.4.10.2. Скругление вершин

2.5.4.11. Сплайн по объектам

2.5.4.12. Кривая по закону

2.5.4.12.1. Задание функции для координаты точки кривой

2.5.4.12.2. Ввод выражения и задание параметра функции

2.5.4.12.3. Задание интервального параметра функции

2.5.4.12.4. Примеры создания кривых по параметрическим уравнениям

2.5.4.13. Скругление кривых

2.5.4.14. Соединение кривых

2.5.4.14.1. Задание натяжения соединительной кривой

2.5.4.14.2. Смена вершины сопряжения исходной кривой

2.5.4.15. Кривая по двум проекциям

2.5.4.15.1. Выбор контуров для построения кривой

2.5.4.16. Усечение кривой

2.5.4.16.1. Усечение кривой двумя объектами

2.5.4.17. Эквидистанта кривой

2.5.4.17.1. Построение смещением по направлению от вершины

2.5.4.17.2. Построение смещением вдоль поверхности

2.5.4.18. Изопараметрическая кривая

2.5.4.19. Группа изопараметрических кривых на поверхности

2.5.4.20. Линия очерка

2.5.4.20.1. Задание направления взгляда при построении линии очерка

2.5.4.21. Сплайн на поверхности

2.5.4.21.1. Таблица параметров вершин сплайна

2.5.4.21.2. Режим редактирования сплайна

2.5.4.21.3. Изменение положения вершины

2.5.4.21.4. Управление касательным вектором сплайна

2.5.4.22. Проекционная кривая

2.5.4.22.1. Объекты, используемые при построении

2.5.4.22.2. Построение проекционной кривой

2.5.4.22.3. Выбор типа проекции базовой кривой

2.5.4.23. Кривая пересечения поверхностей

2.5.4.24. Контур

2.5.4.24.1. Выбор типа контура

2.5.4.24.2. Построение контура со скруглениями

2.5.4.24.3. Построение контура по эквидистанте кривой


2.5.4.1. Параметры отображения кривых

Параметрами отображения кривых являются стиль отображения вершины и стиль линии. Просмотреть и отредактировать эти параметры можно на вкладке Свойства Панели свойств (рис. 2.5.15).

Рис. 2.5.15. Вкладка Свойства

Кнопка Отображение вершин управляет отображением вершин пространственной кривой. Если эта кнопка нажата, то на Панели свойств присутствует список Стиль вершин. Вы можете выбрать стиль отображения вершины из этого списка.

После завершения построения кривой ее вершины будут отображаться выбранным стилем.

Для ломаной со скругленными вершинами отмечаются также концевые точки скруглений (рис. 2.5.16).

Рис. 2.5.16. Отображение концевых точек скруглений ломаной

Кнопка Отображение вершин доступна при редактировании ломаных, созданных в КОМПАС-3D версии 9 и выше.

По умолчанию пространственные кривые отрисовываются линией со стилем Основная. Для изменения текущего стиля воспользуйтесь списком Стиль линий. Список содержит системные стили линий.

Параметры отрисовки текущей кривой, установленные при ее построении, будут использоваться при создании следующих пространственных кривых до конца сеанса работы.

При необходимости вы можете изменить толщину отрисовки линий. Для этого вызовите команду Сервис — Параметры — Система — Редактор моделей — Системные линии. На экране появится диалог, в котором можно установить нужные значения толщины.


2.5.4.2. Импортированная кривая

Для импорта пространственной кривой или пространственных кривых в файл модели КОМПАС-3D могут использоваться следующие файлы:

– файл с расширением igs, step или stp — имеющиеся в этом файле кривые будут вставлены в текущую модель,

– файл данных с расширением xls, ods, txt или csv (о файле данных см. Приложение VI) — по заданным в этом файле координатам в текущей модели будет построена кривая.

Для выполнения импорта используется команда Импортированная кривая.

После вызова команды на экране появляется стандартный диалог Выберите файл для открытия, позволяющий выбрать нужный файл.

Файл с расширением igs, step или stp анализируется на наличие в нем пространственных кривых. Если пространственные кривые в файле не обнаружены, на экране появляется всплывающее сообщение, при этом диалог выбора файла остается активным.

При нажатии в диалоге кнопки Отмена команда завершает свою работу без сохранения изменений.

Если в исходном файле присутствуют кривые, состыкованные по цепочке, во время чтения файла появляется запрос на объединение кривых. При положительном ответе те кривые, объединение которых возможно, будут объединены.

После завершения импорта в Дереве построения появляется пиктограмма импортированной кривой или несколько пиктограмм импортированных кривых. Импортированные кривые являются «кривыми без истории».

Импорт кривых из файлов с расширением igs, step и stp имеет особенности, описанные в разделе 10.1.2.1.1.

Системой координат импортированной кривой или кривых является текущая система координат — абсолютная или локальная (о выборе текущей системы координат — см. раздел 2.8.3.3).

Если системой координат импортированной кривой является не абсолютная, а локальная система координат, то, изменяя положение локальной системы координат относительно абсолютной, можно изменять положение импортированной кривой в модели.

Подробнее о системах координат объектов рассказано в разделе 2.8.3.4.


2.5.4.3. Отрезок

Отрезок в пространстве можно построить двумя способами:

– По 2 точкам,

– По точке, длине и углу наклона.

Для построения отрезка используется команда Отрезок.

После вызова команды на Панели свойств появятся элементы управления построением (рис. 48.4).

Рис. 2.5.17. Панель свойств при построении отрезка

Выберите вариант построения отрезка из списка Способ или при помощи команд контекстного меню.

Затем задайте параметры отрезка и объекты, используемые при построении.

После задания всех необходимых данных на экране появляется фантом отрезка. Пока построение не завершено, вы можете изменить параметры отрезка, активизировав необходимый элемент управления на Панели свойств.

Чтобы сменить объекты, используемые для построения отрезка, нажмите кнопку Указать заново на Панели специального управления и повторите выбор объектов.

Элементы управления, расположенные на вкладке Свойства Панели свойств, позволяют изменить название и цвет отрезка, настроить параметры его отображения (о параметрах отображения см. раздел 2.5.4.1). Также на этой вкладке отображается название системы координат отрезка (о системе координат объекта см. раздел 2.8.3.4.1).

Чтобы завершить построение, нажмите кнопку Создать объект на Панели специального управления.

При всех способах построения отрезка доступен режим автосоздания, который по умолчанию включен. Подробно об автоматическом и ручном создании объектов рассказано в разделе 1.4.2.10.

В этом разделе:

2.5.4.3.1. Построение по 2 точкам

2.5.4.3.2. Построение по точке, длине и углу наклона


2.5.4.3.1. Построение по 2 точкам

Способ По 2 точкам позволяет построить отрезок, последовательно указав начальную и конечную вершину.

Чтобы построить отрезок, выполните следующие действия.

1. Укажите начальную вершину отрезка. Переключатель Начальная вершина активизирован по умолчанию. Доступно несколько способов указания вершины.

– Задание координат вершины в пространстве или связывание ее с уже имеющимся точечным объектом. (Задание координат точки и связывание ее с точечным объектом производится так же, как при создании точки способом По координатам (см. раздел 2.5.2.2)).

– Построение вершины отрезка с использованием способов построения точки команды Точка. Для этого нужно нажать на Панели специального управления кнопку Построение точки. Подробно об построении точки рассказано в разделе 2.5.2.1.

После задания начальной вершины отрезка автоматически активизируется переключатель Конечная вершина.

2. Укажите конечную вершину отрезка. Конечная вершина отрезка указывается аналогично начальной вершине.


2.5.4.3.2. Построение по точке, длине и углу наклона

По точке, длине и углу наклона — способ построения отрезка с указанием плоскости отрезка и заданием параметров: начальной вершины, длины и угла наклона отрезка.

Плоскость отрезка располагается параллельно базовой плоскости. В качестве базовой плоскости может использоваться:

– координатная или вспомогательная плоскость;

– плоская грань;

– плоскость эскиза.

Чтобы построить отрезок, выполните следующие действия.

1. Укажите начальную вершину отрезка. Переключатель Начальная вершина активизирован по умолчанию. Доступно несколько способов указания вершины.

– Задание координат вершины в пространстве или связывание ее с уже имеющимся точечным объектом. (Задание координат точки и связывание ее с точечным объектом производится так же, как при создании точки способом По координатам (см. раздел 2.5.2.2)).

– Построение вершины отрезка с использованием способов построения точки команды Точка. Кнопка Построение точки находится на Панели специального управления. Подробно о построении точки рассказано в разделе 2.5.2.1.

По умолчанию базовая плоскость — одна из координатных плоскостей. Система выбирает ее автоматически в зависимости от расположения модели относительно плоскости экрана. Наименование выбранной координатной плоскости отображается в поле Базовая плоскость.

После указания начальной вершины автоматически определяется положение плоскости отрезка: по заданной точке и базовой плоскости. На экране появляется фантом отрезка.

При необходимости вы можете сменить базовую плоскость. Для этого активизируйте переключатель Базовая плоскость на Панели свойств или вызовите команду из контекстного меню и укажите нужный объект в Дереве построения или в окне модели (эскиз следует указывать в Дереве построения).

Построение отрезка можно начинать с указания базовой плоскости: активизируйте переключатель Базовая плоскость, выберите нужный объект, а затем укажите начальную вершину.

После задания начальной вершины отрезка автоматически активизируется переключатель Конечная вершина.

2. Укажите конечную вершину отрезка. Доступно несколько способов указания конечной вершины:

– задание с помощью мыши в окне модели или связывание ее с точечным объектом (см. раздел 2.5.2.2);

– задание длины и угла наклона отрезка в базовой плоскости.

Задайте длину отрезка.

Длину отрезка можно ввести с клавиатуры или указать положение точки с помощью мыши в окне модели, в этом случае угол наклона отрезка определяется автоматически.

Задайте значение угла наклона отрезка.

Угол наклона отрезка отсчитывается от оси абсцисс системы координат базовой плоскости. Значение угла можно ввести с клавиатуры или указать положение точки с помощью мыши в окне модели.

Если конечная вершина ассоциативно связана с точечным объектом, то значения в полях Длина и Угол недоступны для изменения.


2.5.4.4. Дуга окружности

Дугу окружности в пространстве можно построить следующими способами:

– По 3 точкам,

– По центру и радиусу,

– По 2 точкам с направлением,

– С касанием к кривой.

Чтобы создать дугу окружности в пространстве, вызовите команду Дуга окружности.

Выберите вариант построения дуги из списка Способ или при помощи команд контекстного меню. На Панели свойств появятся элементы управления построением (рис. 2.5.18).

Рис. 2.5.18. Панель свойств при построении дуги окружности по 3 точкам

Затем задайте параметры дуги и объекты, используемые при построении.

После задания одного из параметров дуги переход к следующему параметру происходит автоматически.

Во всех способах объектами построения являются точки. Точку дуги можно указать следующими способами:

– задать координаты в пространстве или указать положение мышью в окне модели;

– связать с уже имеющимся точечным объектом;

– создать, используя способы построения точки команды Точка, не выходя из процесса построения дуги (см. раздел 2.5.2.11).

Указание точечного объекта при включенной опции Ассоциировать приводит к формированию ассоциативной связи точки дуги с этим объектом.

Признаком наличия связи является отображение «галочки» на кнопке Объект и наименования точечного объекта в поле Объект на Панели свойств. При любом изменении положения объекта точка дуги будет следовать за объектом.

Чтобы отменить ассоциативную связь с точечным объектом, следует нажать кнопку Объект. «Галочка» на кнопке исчезнет.

Для восстановления ассоциативной связи точки с точечным объектом необходимо включить опцию Ассоциировать и указать нужный объект заново.

Подробно о вводе параметров и указании объектов для каждого способа рассказано в разделах 2.5.4.4.1–2.5.4.4.4.

Координаты точек задаются в системе координат дуги (о системе координат объекта см. раздел 2.8.3.4).

После задания всех необходимых данных на экране появляется фантом дуги окружности. Пока построение не завершено, вы можете изменить параметры дуги, активизировав необходимый элемент управления на Панели свойств.

При необходимости вы можете построить окружность. Для этого активизируйте переключатель Окружность в группе Дуга. Такая возможность существует во всех способах построения дуги.

До завершения команды система «запоминает» параметры и объекты, указанные в каждом из способов построения, поэтому вы можете переключаться между способами без потери этих данных.

Чтобы сменить объекты, используемые для построения дуги окружности выбранным способом, нажмите кнопку Указать заново на Панели специального управления и повторите выбор объектов.

Элементы управления, расположенные на вкладке Свойства Панели свойств, позволяют изменить название и цвет дуги, настроить параметры ее отображения (о параметрах отображения см. раздел 2.5.4.1). Также на этой вкладке отображается название системы координат дуги (о системе координат объекта см. раздел 2.8.3.4.1).

Чтобы завершить построение, нажмите кнопку Создать объект на Панели специального управления.

При всех способах построения дуги окружности доступен режим автосоздания, который по умолчанию включен. Подробно об автоматическом и ручном создании объектов рассказано в разделе 1.4.2.10.

В этом разделе:

2.5.4.4.1. Построение по 3 точкам

2.5.4.4.2. Построение по центру и радиусу

2.5.4.4.3. Построение по 2 точкам с направлением

2.5.4.4.4. Построение с касанием к кривой


2.5.4.4.1. Построение по 3 точкам

По 3 точкам — способ построения дуги окружности по трем точкам.

Для построения дуги окружности данным способом укажите начальную точку дуги 1, затем конечную точку дуги 2 и промежуточную точку на дуге 3. После указания точки 1 на экране появляется фантом окружности, после указания точки 2 — фантом дуги. Указание промежуточной точки 3 определяет дугу полностью.

– Точку дуги можно указать, задав ее координаты в пространстве или связав ее с уже имеющимся точечным объектом. Задание координат точки и связывание ее с точечным объектом производится так же, как при создании точки способом По координатам (см. раздел 2.5.2.2).

– Точку дуги можно указать, построив ее. При этом используются способы построения точки команды Точка. Подробно об этом рассказано в разделе 2.5.2.1.

По умолчанию дуга окружности проходит от точки 1 к точке 2 через точку 3. При этом активен переключатель Дуга по умолчанию. Чтобы построить дополняющую дугу (не проходящую через точку 3) или окружность, активизируйте нужный переключатель.


2.5.4.4.2. Построение по центру и радиусу

По центру и радиусу — способ построения дуги окружности с указанием плоскости дуги и заданием параметров: центра дуги, начального и конечного углов, радиуса.

Плоскость дуги окружности располагается параллельно базовой плоскости. В качестве базовой плоскости может использоваться:

– координатная или вспомогательная плоскость;

– плоская грань;

– плоскость эскиза.

Чтобы построить дугу, выполните следующие действия.

1. Укажите центральную точку дуги 1.

– Точку дуги можно указать, задав ее координаты в пространстве или связав ее с уже имеющимся точечным объектом. Задание координат точки и связывание ее с точечным объектом производится так же, как при создании точки способом По координатам (см. раздел 2.5.2.2).

– Точку дуги можно указать, построив ее. При этом используются способы построения точки команды Точка. Подробно об этом рассказано в разделе 2.5.2.1.

По умолчанию базовая плоскость — одна из координатных плоскостей. Система выбирает ее автоматически в зависимости от расположения модели относительно плоскости экрана. Наименование выбранной координатной плоскости отображается в поле Базовая плоскость.

При необходимости вы можете сменить базовую плоскость. Для этого активизируйте переключатель Базовая плоскость и укажите нужный объект в Дереве построения или в окне модели (эскиз следует указывать в Дереве построения).

Построение дуги можно начинать с указания базовой плоскости: активизируйте переключатель Базовая плоскость, выберите нужный объект, а затем укажите точку 1.

После указания точки 1 автоматически определяется положение плоскости дуги: по заданной центральной точке и базовой плоскости. На экране появляется фантом окружности дуги с центральной точкой 1.

2. Введите радиус/диаметр дуги. По умолчанию система ожидает ввода радиуса. При этом в группе Параметр активен переключатель Радиус. Чтобы ввести диаметр, активизируйте переключатель Диаметр. На экране появляется фантом окружности заданного размера.

3. Укажите начальную точку дуги 2, задав начальный угол дуги. Начальный угол отсчитывается от оси абсцисс системы координат базовой плоскости. Значение угла можно ввести с клавиатуры или связать начальную точку дуги с уже имеющимся точечным объектом. На экране появляется фантом дуги с заданным начальным углом.

4. Укажите точку дуги 3, задав конечный угол. Конечный угол задается аналогично начальному.

После выполнения вышеописанных действий дуга определена полностью — указаны положение плоскости дуги, точка центра, начальный и конечный углы, радиус.

По умолчанию дуга окружности строится по часовой стрелке от точки 2 к 3. При этом активен переключатель Дуга по умолчанию. Чтобы построить дополняющую дугу или окружность, активизируйте нужный переключатель.

При построении полной дуги окружности после указания точки 1 система сразу переходит к заданию радиуса (точки 4).


2.5.4.4.3. Построение по 2 точкам с направлением

По 2 точкам с направлением — способ построения дуги окружности по двум точкам с указанием в одной из них направления касательного вектора. Направление касательного вектора задается с помощью вектора или направляющих объектов. В качестве направляющих могут использоваться следующие объекты.

– Прямолинейный объект:

• отрезок эскиза,

• сегмент ломаной,

• координатная или вспомогательная ось,

• прямолинейное ребро.

Направление, задаваемое прямолинейным объектом — прямая, параллельная объекту.

– Плоский объект:

• координатная или вспомогательная плоскость,

• плоская грань,

• плоскость эскиза.

Направление, задаваемое плоским объектом — прямая, перпендикулярная объекту.

– Кривая (если начальная или конечная точка дуги лежит на этой кривой).

Направление, задаваемое кривой — касательный вектор в точке касания. Таким образом можно построить дугу, сопряженную с произвольной кривой — пространственным сплайном или ломаной, ребром и др.

Чтобы построить дугу, выполните следующие действия.

1. Задайте начальную точку дуги 1.

– Точку дуги можно указать, задав ее координаты в пространстве или связав ее с уже имеющимся точечным объектом. Задание координат точки и связывание ее с точечным объектом производится так же, как при создании точки способом По координатам (см. раздел 2.5.2.2).

– Точку дуги можно указать, построив ее. При этом используются способы построения точки команды Точка. Подробно об этом рассказано в разделе 2.5.2.1.

2. Задайте конечную точку дуги 2. Точка 2 задается аналогично точке 1. После задания точки 2 система переходит к выбору направления для этой точки — активизируется переключатель Направление в точке, соответствующий точке 2.

3. Задайте направление. Для этого укажите нужный направляющий объект в Дереве построения или в окне модели (эскиз следует указывать в Дереве построения) или постройте вектор (см. раздел 2.8.5).

Для создания вектора нажмите кнопку Построение вектора. Эта кнопка находится на Панели специального управления.

Наименование выбранного объекта отображается в поле Направление в точке. Если направление задано вектором, то в этом поле отображается слово «Вектор».

На экране появляется фантом дуги с точками 1, 2 и касательным вектором в точке 2, указывающим заданное направление.

Для дуги, сопряженной с кривой, необходимо указать точку на этой кривой — начальную, конечную или построенную способом На кривой либо На пересечении (см. раздел 2.5.2.1), а в качестве направляющего объекта в этой точке — саму кривую.

Направление может быть задано только в одной точке дуги — начальной или конечной. Поэтому, если направление в одной из этих точек было задано, то после указания направления в другой точке выбор объекта для первой точки отменяется.

После задания точек 1, 2 и указания направления дуга определена полностью — система строит плоскость дуги и рассчитывает положение центральной точки и радиус.

Плоскость дуги строится по прямолинейному объекту и точке. В качестве прямолинейного объекта используется касательный вектор.

Центральная точка дуги С лежит на пересечении оси с и серединного перпендикуляра m к отрезку, соединяющему точки 1 и 2 (рис. 2.5.19). Ось с перпендикулярна вектору направления в точке.

Радиус определяется как расстояние между центральной точкой С и точкой 1.

Рис. 2.5.19. Определение центральной точки дуги и радиуса

По умолчанию дуга окружности проходит от точки 1 к точке 2 в направлении, совпадающем с направлением касательного вектора. При этом активен переключатель Дуга по умолчанию. Чтобы построить дополняющую дугу или окружность, активизируйте нужный переключатель.


2.5.4.4.4. Построение с касанием к кривой

С касанием к кривой — способ построения дуги окружности с указанием кривой, которой должна касаться окружность дуги, и заданием параметров дуги: центра, начального и конечного углов.

В качестве кривой может использоваться:

– координатная или вспомогательная ось,

– пространственная кривая,

– линии эскиза,

– ребро.

Чтобы построить дугу, выполните следующие действия.

1. Укажите кривую, которой должна касаться окружность дуги. Для этого выберите нужный объект в Дереве построения или в окне модели. Наименование выбранного объекта отображается в поле Кривая. На экране появляется фантом окружности, касательной к заданной кривой.

2. Укажите центральную точку дуги 1.

– Точку дуги можно указать, задав ее координаты в пространстве или связав ее с уже имеющимся точечным объектом. Задание координат точки и связывание ее с точечным объектом производится так же, как при создании точки способом По координатам (см. раздел 2.5.2.2).

– Точку дуги можно указать, построив ее. При этом используются способы построения точки команды Точка. Подробно об этом рассказано в разделе 2.5.2.1.

После указания точки 1 определяется положение плоскости дуги и радиус (точка 4).

Плоскость строится по точке и прямолинейному объекту. В качестве прямолинейного объекта используется касательная прямая, проходящая через точку заданной кривой, ближайшую к центральной точки дуги.

Вычисленное значение радиуса отображается в поле Радиус. При необходимости вы можете ввести нужное значение радиуса в это поле. После этого система рассчитает новое положение центральной точки 1.

Если точка 1 ассоциативно связана с точечным объектом, то значение в поле Радиус недоступно для изменения.

Для построения дуги вы можете использовать диаметр окружности. Для этого активизируйте переключатель Диаметр в группе Параметр.

3. Укажите начальную точку дуги 2, задав начальный угол дуги. Начальный угол отсчитывается от луча, направленного из центра дуги в точку касания. Значение угла можно ввести с клавиатуры или связать начальную точку дуги с уже имеющимся точечным объектом. На экране появляется фантом дуги с заданным начальным углом и точкой 4.

4. Укажите точку дуги 3, задав конечный угол. Конечный угол задается аналогично начальному. На экране появляется фантом дуги, с заданными точками 1, 2, 3, 4.

Если точки 2 и 3 ассоциативно связаны с точечными объектами, поля для ввода значений углов недоступны, в них отображаются вычисленные системой значения углов.

После выполнения вышеописанных действий дуга определена полностью — указаны положение плоскости дуги, точка центра, начальный и конечный углы, радиус.

По умолчанию дуга окружности строится по часовой стрелке от точки 2 к точке 3. При этом активен переключатель Дуга по умолчанию. Чтобы построить дополняющую дугу или окружность, активизируйте нужный переключатель.

При построении полной дуги после указания точки 1 дуга окружности определена полностью — становится доступна кнопка Создать объект на Панели специального управления.


2.5.4.5. Спирали. Общие приемы построения

Команды создания спиралей доступны, если в окне модели выделен какой-либо плоский объект: вспомогательная или проекционная плоскость, плоская грань детали. Этот объект является опорным для спирали.

После вызова любой команды построения спирали требуется задать ее параметры в полях на Панели свойств.

Все значения параметров отображаются на экране в виде фантома спирали.

Элементы управления, расположенные на вкладке Свойства Панели свойств, позволяют изменить название и цвет спирали, настроить параметры ее отображения (о параметрах отображения см. раздел 2.5.4.1).

Чтобы зафиксировать эту спираль в модели, нажмите кнопку Создать объект на Панели специального управления.

В окне модели появляется созданная спираль, а в Дереве построения — ее пиктограмма.


2.5.4.6. Цилиндрическая спираль

Чтобы создать цилиндрическую спираль, вызовите команду Спираль цилиндрическая.

В этом разделе:

2.5.4.6.1. Способ построения

2.5.4.6.2. Число витков, шаг, высота

2.5.4.6.3. Направление построения

2.5.4.6.4. Направление навивки

2.5.4.6.5. Начальный угол

2.5.4.6.6. Диаметр спирали

2.5.4.6.7. Положение спирали


2.5.4.6.1. Способ построения

Укажите способ построения спирали: По числу витков и шагу, По числу витков и высоте или По шагу витков и высоте, выбрав его из списка Способ построения.


2.5.4.6.2. Число витков, шаг, высота

Введите число витков спирали в поле Число витков. Число витков может быть не целым. Если выбран способ построения спирали По шагу витков и высоте, то поле Число витков недоступно для ввода и в нем отображается вычисленное число витков.

Введите шаг витков спирали в поле Шаг. Если выбран способ построения спирали По числу витков и высоте, то поле Шаг недоступно для ввода и в нем отображается вычисленное значение шага.

Если выбран способ построения спирали По шагу витков и высоте или По числу витков и высоте, становится доступной группа переключателей Высота, позволяющая выбрать способы задания высоты спирали.

Способ По размеру

Высота спирали равна значению, заданному в поле Размер.

Активизируйте в группе Высота переключатель По размеру и введите в поле Размер высоту спирали.

Способ По объекту

Высота спирали определяется автоматически по положению указанного пользователем объекта (грани или точки в окне модели).

Активизируйте в группе Высота переключатель По объекту, затем укажите в окне модели вершину, грань, плоскость или поверхность. Название объекта будет показано в справочном поле Объект.

Введите в поле Размер требуемое расстояние между торцем элемента и объектом.

Если нужно построить спираль точно до вершины или поверхности, введите нулевое значение.

Если расстояние до объекта не нулевое, оно может быть отложено как в направлении построения спирали (в этом случае спираль будет выходить «за» объект на указанное расстояние), так и против направления построения (в этом случае спираль не достигнет объекта на указанное расстояние). Чтобы задать направление отсчета расстояния до вершины, активизируйте переключатель До объекта или За объект в группе Тип.

Способ По плоской кривой

Высота спирали определяется автоматически по длине указанной линии эскиза (спираль повторяет форму линии, а ось спирали является копией линии, полученной путем параллельного переноса линии эскиза, при котором ее начальная точка совмещается с точкой привязки спирали). Плоскость используемого эскиза должна быть перпендикулярна плоскости опорной грани спирали.

Активизируйте в группе Высота переключатель По плоской кривой, затем укажите в окне модели нужную линию эскиза.

Название объекта будет показано в справочном поле рядом с переключателем Объект.

Если плоскость эскиза и плоскость оси спирали не параллельны, то спираль автоматически поворачивается так, чтобы эти плоскости стали параллельны.


2.5.4.6.3. Направление построения

По умолчанию спираль строится наружу относительно опорной грани. Это — Прямое направление. Чтобы направить спираль в другую сторону, активизируйте переключатель Обратное направление в группе Направление построения.

Если высота спирали определяется по объекту или по линии эскиза, то изменить направление построения спирали невозможно (переключатель Направление построения недоступен).


2.5.4.6.4. Направление навивки

Выберите направление навивки спирали — Правое или Левое.

Для этого активизируйте соответствующий переключатель в группе Направление навивки.


2.5.4.6.5. Начальный угол

Введите начальный угол спирали в поле Угол — угол поворота спирали вокруг перпендикуляра к опорной грани.

Угол измеряется относительно оси абсцисс системы координат опорной грани.


2.5.4.6.6. Диаметр спирали

Опции управления диаметром спирали расположены на вкладке Панели свойств Диаметр.

Выберите способ определения диаметра спирали. Для этого активизируйте соответствующий переключатель в группе Диаметр (см. табл. 2.5.4).

Табл. 2.5.4. Способы задания диаметра цилиндрической спирали

Значение опции Диаметр

Правила определения диаметра спирали.

Порядок работы

По размеру

Диаметр спирали равен значению, заданному пользователем.

При выборе данного варианта введите диаметр спирали в поле Диаметр 1.

По объекту

Диаметр спирали определяется автоматически по размеру или положению указанного пользователем объекта (см. ниже).

При выборе данного варианта укажите в окне модели объект, определяющий диаметр спирали. Название объекта будет показано в справочном поле Объект 1, а в поле Диаметр 1 появится вычисленное значение диаметра.

Объект, определяющий диаметр спирали

– В качестве объекта может быть указана точка (вершина детали, начало координат, конец отрезка или точка в эскизе и т.п.). В этом случае диаметр спирали принимается равным расстоянию от цента спирали до проекции указанной точки на опорную плоскость спирали.

– В качестве объекта может быть указано ребро детали или изображение в эскизе, имеющее форму окружности или дуги. В этом случае диаметр спирали принимается равным диаметру выбранной окружности или дуги.


2.5.4.6.7. Положение спирали

Фантом цилиндрической спирали с заданными параметрами отображается в окне модели. Точка привязки спирали по умолчанию располагается в начале локальной системы координат грани или плоскости, на которой создается эта спираль.

Чтобы разместить спираль в нужном месте грани или плоскости, расфиксируйте поле т на вкладке Панели свойств Построение. Укажите положение спирали мышью или введите координаты центра спирали в поле т.

После завершения построения спирали в модели, кроме самой спирали, создается также эскиз, содержащий один объект — точку привязки спирали. Этот эскиз располагается на плоскости или плоской грани, выбранной для построения спирали. При необходимости положением уже созданной спирали можно управлять, изменяя положение точки в эскизе (см. раздел 2.14.3.5.1).


2.5.4.7. Коническая спираль

Чтобы создать коническую спираль, вызовите команду Спираль коническая.

Способ построения, число витков, шаг, высота, направление навивки и построения конической спирали задаются точно так же, как и при построении цилиндрической спирали (см. разделы 2.5.4.6.1–2.5.4.6.5).

Коническая спираль отличается от цилиндрической тем, что ее начальный диаметр не равен конечному и недоступно определение высоты спирали по плоской кривой.

Опции управления начальным и конечным диаметром спирали расположены на вкладке Панели свойств Диаметр.

В этом разделе:

2.5.4.7.1. Начальный и конечный диаметры

2.5.4.7.2. Положение спирали


2.5.4.7.1. Начальный и конечный диаметры

Выберите способ определения начального и конечного диаметров спирали. Для этого активизируйте соответствующий переключатель в группе Диаметр начальный и Диаметр конечный (см. табл. 2.5.5).

Табл. 2.5.5. Способы задания начального диаметра конической спирали

Значение опции
Диаметр начальный (Диаметр конечный)

Правила определения диаметра.

Порядок работы

По размеру

Диаметр равен значению, заданному пользователем.

При выборе данного варианта введите начальный (конечный) диаметр спирали в поле Диаметр 1 (Диаметр 2).

По объекту

Диаметр определяется автоматически по размеру или положению указанного пользователем объекта (об объекте, определяющем диаметр спирали — см. с. 473).

При выборе данного варианта укажите нужный объект в окне модели. Название объекта будет показано в справочном поле Объект 1 (Объект 1), а в поле Диаметр 1 (Диаметр 2) появится вычисленное значение диаметра.

По наклону
образующей1

Конечный диаметр вычисляется по заданным значениям начального диаметра и наклона образующей конической спирали.

При выборе данного варианта введите в поле Угол значение угла наклона образующей к оси спирали. Выберите направление наклона образующей, активизировав соответствующий переключатель в группе Наклон образующей (см. табл. 2.5.6).

В поле Диаметр 2 появится вычисленное значение конечного диаметра.
  1. Только для конечного диаметра.

Табл. 2.5.6. Направление наклона образующей конической спирали
Значение опции Наклон образующей | Результат построения
Наружу | Диаметр спирали увеличивается в направлении построения.
Внутрь | Диаметр спирали уменьшается в направлении построения.


2.5.4.7.2. Положение спирали

Фантом конической спирали с заданными параметрами отображается в окне модели. Точка привязки спирали по умолчанию располагается в начале локальной системы координат грани или плоскости, на которой создается эта спираль.

Чтобы разместить спираль в нужном месте грани или плоскости, расфиксируйте поле т на вкладке Панели свойств Построение. Укажите положение спирали мышью или введите координаты центра спирали в поле т.


2.5.4.8. Пространственные сплайны и ломаные. Общие приемы построения

2.5.4.8. Пространственные сплайны и ломаные.
Общие приемы построения

Пространственные ломаная и сплайн являются точечно заданными кривыми. Точки, определяющие эти кривые, называются вершинами.

Пространственная ломаная состоит из отрезков, последовательно соединяющих заданные вершины. Возможно скругление вершин ломаной дугами окружностей.

Пространственный сплайн определяется набором вершин и его порядком. Форма сплайна зависит от расположения заданных вершин в пространстве. В зависимости от типа сплайн может проходить непосредственно через заданные вершины или проходить на расстоянии от них. Расстояние до каждой вершины зависит от ее веса.

Подробно о порядке кривых и весе точек рассказано в разделе 3 Приложения IX.

После вызова команды построения кривой требуется задать параметры ее вершин.

Вершина кривой может быть построена следующими способами:

– По точкам (см.раздел 2.5.4.8.3),

– По осям (см.раздел 2.5.4.8.4),

– По объектам (см. раздел 2.5.4.8.5).

Для задания координат вершины используются следующие приемы:

– ввод значений координат в таблицу параметров вершин кривой (см. раздел 2.5.4.8.1),

– построение специальной точки (см. раздел 2.5.2.11),

– связывание вершины с точечным объектом (см. раздел 2.5.4.8.6).

При построении очередной вершины на экране отображается линия, соединяющая эту вершину с предыдущей — линия построения вершины кривой.

В этом разделе:

2.5.4.8.1. Таблица параметров вершин

2.5.4.8.2. Приемы работы с таблицей параметров

2.5.4.8.3. Построение по точкам

2.5.4.8.4. Построение по осям

2.5.4.8.5. Построение по объектам

2.5.4.8.6. Формирование ассоциативной связи вершин с точечными объектами. Особенности связанных вершин

2.5.4.8.7. Замкнутая или разомкнутая кривая

2.5.4.8.8. Редактирование параметров вершины


2.5.4.8.1. Таблица параметров вершин

Каждая вершина ломаной или сплайна характеризуется набором параметров. Их значения отображаются в таблице параметров вершин (рис. 2.5.20).

Эта таблица называется Координаты вершин и находится на вкладке Панели свойств Параметры.

Каждая вершина кривой описывается строкой таблицы.

Общими для сплайна и ломаной являются следующие параметры:

– номер вершины,

– пространственные координаты вершины,

– значок связи, если вершина ассоциативно связана с точечным объектом,

– значок связи и значок вершины, если вершина была создана с помощью команды Точка (см. раздел 2.5.2.11) любым способом, кроме способа По координатам (XYZ).

Специфическими являются следующие параметры:

– для ломаной — радиус скругления (см. раздел 2.5.4.10.2);

– для сплайна (при построении сплайна по полюсам; см. раздел 2.5.4.9.1):

• вес;

• значок связи и значок системного полюса (о системном полюсе см. раздел 2.5.4.9.3).

Рис. 2.5.20. Таблица параметров вершин: а) сплайна, б) ломаной
а) | б)

Строки таблицы формируются автоматически при построении вершины в окне модели. Вместе с тем, создание или редактирование строки таблицы приводит к созданию новой или изменению параметров существующей вершины кривой.

Координаты вершин кривой задаются в ее системе координат (о системе координат объекта — см. раздел 2.8.3.4.1).

Приемы работы с таблицей параметров вершин описаны в разделе 2.5.4.8.2.


2.5.4.8.2. Приемы работы с таблицей параметров

Элементы управления над таблицей параметров вершин и команды контекстного меню таблицы позволяют выполнять следующие действия:

– заменять содержимое всех ячеек выделенного столбца нулевым значением или значением из первой ячейки;

– заполнять таблицу набором значений из внешнего текстового файла;

– сохранять содержание таблицы параметров в текстовый файл для последующего использования;

– создавать новые вершины;

– изменять значения параметров существующих в таблице вершин;

– удалять вершины кривой;

– удалять связь вершины с точечным объектом;

– отменять сопряжение сплайна с объектом модели.

Замена содержимого всех ячеек выделенного столбца

Чтобы выделить столбец, щелкните мышью по его заголовку. Можно также указать мышью ячейку, принадлежащую столбцу и вызвать из контекстного меню команду Выделить столбец.

Команда Обнулить значение из контекстного меню таблицы позволяет заменить содержимое всех ячеек выделенного столбца значением 0.0.

Команда Копировать значение по первой ячейке позволяет заменить содержимое всех ячеек выделенного столбца значением, введенным в первую ячейку.

Команда Копировать значение по первой ячейке доступна, если кривая не содержит вершин, связанных с точечными объектами.

Чтение файла параметров вершин

При построении сплайна или ломаной вы можете задать параметры вершин, используя данные, сохраненные в файле. Подробнее о файле данных рассказано в Приложении VI.

Чтобы построить кривую по данным из сохраненного на диске файла, нажмите кнопку Читать из файла.

В появившемся на экране стандартном диалоге открытия файлов Windows выберите нужный файл. Таблица параметров будет заполнена значениями из этого файла. В окне модели появится фантом кривой, построенной по табличным данным.

Кнопка Читать из файла доступна только в том случае, когда таблица параметров вершин пуста.

Сохранение параметров вершин в файл

Чтобы сохранить параметры вершин в файл, следует нажать кнопку Сохранить в файл.

На экране появится стандартный диалог сохранения файлов Windows. В этом диалоге следует указать имя файла, папку для сохранения. По умолчанию файлу присваивается расширение txt.

Сохранение координат в файл возможно только в том случае, если в таблице параметров заполнена хотя бы одна строка.

Создание новой вершины в таблице параметров

Чтобы создать вершину перед уже существующей, выделите строку с номером нужной вершины и нажмите кнопку Создать новую вершину или клавишу <Insert>.

В окне модели появится новая вершина. Ее номер будет равным номеру текущей вершины. Номера последующих вершин увеличатся на единицу. Значения параметров созданной вершины будут такими же, как у вершины, перед которой она вставлена. Строка параметров созданной вершины будет активна.

Изменение параметров вершины в таблице параметров

Для изменения параметра вершины кривой активизируйте нужную ячейку таблицы параметров двойным щелчком мыши и введите в нее новое значение. Для перемещения между ячейками можно использовать клавиши со стрелками.

Ввод координат возможен только для вершин кривой, построенных способом По точке и не связанных с точечным объектом.

Удаление вершин из таблицы

Чтобы удалить вершину, выделите строку ее параметров и нажмите кнопку Удалить вершину или клавишу <Delete>.

С помощью комбинации клавиш <Shift>+<стрелка> можно выделить несколько строк и удалить их так же, как одну строку.

Удаление связи вершины с точечным объектом

Чтобы удалить связь вершины с построенной для нее точкой или с точечным объектом, следует выделить в таблице нужную строку и щелкнуть мышью по значку связи этой вершины в колонке Связь или вызвать команду Удалить связь из контекстного меню таблицы. Связь будет удалена, координаты вершины не изменятся.

Будьте внимательны при удалении связи, так как отменить это действие невозможно. Для восстановления связи необходимо отредактировать вершину, заново построив или указав нужную точку.

Отмена сопряжения сплайна с объектом модели

Если вершина сплайна имеет признак системного полюса, то можно удалить сопряжение сплайна, отменив этот признак (о сопряжении сплайна см. раздел 2.5.4.9.2). Чтобы отменить сопряжение сплайна, следует выделить в таблице строку системного полюса, обеспечивающего это сопряжение, и щелкнуть мышью по значку системного полюса в колонке Связь или вызвать команду Удалить связь из контекстного меню таблицы. Сопряжение будет отменено, а для вершины будет снят признак системного полюса. При этом координаты вершины не изменятся.

Будьте внимательны при удалении сопряжения, так как отменить это действие невозможно. Для восстановления сопряжения необходимо его сформировать заново.


2.5.4.8.3. Построение по точкам

Чтобы выполнить построение вершины сплайна или ломаной по точкам, следует выбрать вариант По точкам из раскрывающегося списка Способ построения.

Для задания положения вершины могут использоваться следующие приемы:

– указание курсором положения вершины в окне модели,

– привязка вершины к точечному объекту,

– построение специальной точки,

– ввод данных в ячейки таблицы параметров вершин,

– чтение значений параметров из файла параметров вершин.

Указание вершины курсором и связывание вершины с точечным объектом описаны далее в этом разделе. Использование таблицы параметров вершин и чтение параметров вершин из файла рассмотрены в разделе 2.5.4.8.1, а построение точки — в разделе 2.5.2.11.

Указание курсором положения вершины в окне модели

Положение вершины ломаной или сплайна может быть задано курсором в окне модели. Координаты вершины при этом определяются:

– местоположением курсора в плоскости экрана;

– ориентацией плоскости экрана в пространстве модели;

– ограничениями (фиксацией), которые могут быть наложены на изменение координат.

Чтобы зафиксировать значение координаты, следует использовать переключатель, расположенный рядом с полем этой координаты. По умолчанию координата не фиксирована. При этом на переключателе изображен значок «галочка». Чтобы зафиксировать значение координаты, можно использовать следующие способы:

– щелкнуть мышью по переключателю;

– нажать клавишу <Enter>, когда курсор находится в поле ввода значения координаты.

После фиксации значения координаты значок на переключателе поменяется на «крестик».

Чтобы завершить создание вершины кривой, необходимо щелкнуть мышью в окне модели либо зафиксировать все три координаты вершины.

Новая вершина появится в окне модели. Строка ее параметров будет добавлена в таблицу параметров вершин.

После этого система будет ожидать указания следующей вершины.

Состояние зафиксированности значения координаты сохраняется только при вводе значений координат текущей вершины. После ее создания координата расфиксируется.

При построении ломаной можно построить подряд несколько точек с одним и тем же значением какой-либо координаты (например, при создании вершин, лежащих в одной плоскости). Для этого выполните следующие действия.

1. Задайте и зафиксируйте значение нужной координаты.

2. Нажмите кнопку Запомнить состояние на Панели специального управления.

3. Указывайте положение вершин ломаной. Зафиксированность координаты будет сохраняться.

4. Завершив создание вершин с одним и тем же значением координаты, отожмите кнопку Запомнить состояние.

Привязка вершины к точечному объекту

Чтобы привязать вершину к точечному объекту, следует указать нужный точечный объект курсором.

Для указания точечного объекта подведите к нему курсор. Когда рядом с курсором появится условное изображение вершины, щелкните левой кнопкой мыши.

Новая вершина появляется в окне модели. Строка ее параметров в таблице параметров вершин автоматически заполняется координатами выбранной точки.

Если опция Ассоциировать включена, то формируется ассоциативная связь вершины с указанным точечным объектом (см. раздел 2.5.4.8.6).

Если при построении вершины кривой опция Ассоциировать отключена, то вершина кривой совпадает с указанным точечным объектом, но не связывается с ним, т.е. при перемещении точечного объекта вершина останется на прежнем месте.


2.5.4.8.4. Построение по осям

При построении сплайна или ломаной по осям накладывается ограничение на направление линии построения вершины: линия строится параллельно выбранной оси системы координат кривой (о системе координат объекта — см. раздел 2.8.3.4.1).

Чтобы выбрать координатную ось, которой будет параллельна линия построения вершины, можно воспользоваться следующими способами:

– выбрать нужный вариант из раскрывающегося списка Способ построения,

– вызвать соответствующую команду контекстного меню,

– использовать изображение координатных осей рядом с построенной вершиной в окне модели (рис. 2.5.21).

Рис. 2.5.21. Указание координатной оси в окне модели

В последнем случае из списка Способ построения автоматически выбирается вариант, соответствующий указанному направлению. После того как координатная ось выбрана, при перемещении курсора на экране отображается линия построения вершины, параллельная этой оси.

Для задания положения вершины на линии построения могут использоваться следующие приемы:

– задание смещения создаваемой вершины от предыдущей или от заданной грани,

– указание положения вершины в окне модели,

– привязка вершины к точечному объекту.

После этого система будет ожидать указания следующей вершины. Направление линии построения вершины будет сохранено. Чтобы изменить его, можно использовать следующие способы:

– выбрать способ построения По точкам,

– выбрать другую координатную ось,

– выбрать способ построения По объектам.

Задание смещения вершины

Существует два способа задания смещения создаваемой вершины.

Способ 1

Задается смещение вершины от предыдущей вдоль линии построения (расстояние между вершинами).

Способ 2

Задается смещение вершины от заданной грани. В этом случае необходимо указать опорную грань и задать отступ от нее. В качестве опорной грани можно использовать любую грань или плоскость.

Положение создаваемой вершины в этом случае определяется следующим образом (см. рис. 2.5.22).

1. Строится поверхность, эквидистантная опорной грани и находящаяся от нее на расстоянии отступа.

2. Находится точка пересечения линии построения и эквидистантной поверхности.
При необходимости теоретическая поверхность грани продлевается (о теоретической поверхности грани см. раздел 2 Приложения IX).

3. Создаваемая вершина совмещается с полученной точкой пересечения.

Рис. 2.5.22. Определение положения вершины путем задания ее смещения от опорной грани

– Чтобы задать смещение вершины первым способом, следует в группе Смещение на Панели свойств активизировать переключатель Смещение от предыдущей вершины.
В поле Расстояние следует ввести нужное значение. Знак перед значением расстояния определяет, с какой стороны от предыдущей вершины на линии построения будет располагаться текущая вершина.

– Чтобы задать смещение вершины вторым способом, следует активизировать переключатель Смещение от опорной поверхности. На Панели свойств появляются элементы управления смещением вершины.
Для задания опорной грани следует активизировать переключатель Опорная поверхность и указать в окне модели нужную грань. Указанная грань подсвечивается. Название выбранного объекта отображается в поле рядом с переключателем.
В поле Отступ следует ввести нужное значение. Знак перед значением отступа определяет, с какой стороны от опорной грани будет располагаться вершина.

Положение вершины можно также задать указанием точки в окне модели (см. разделы: Указание курсором положения вершины в окне модели, Привязка вершины к точечному объекту).

После задания параметров смещения необходимо нажать клавишу <Enter>.

Новая вершина появится в окне модели. Строка ее параметров будет добавлена в таблицу параметров вершин.

Указание курсором положения вершины в окне модели

Положение вершины сплайна или ломаной может быть задано курсором в окне модели. При этом координаты этой вершины совпадают с проекцией положения курсора на линию построения вершины.

Чтобы построить вершину, необходимо щелкнуть мышью в окне модели.

Новая вершина появится в окне модели. Строка ее параметров будет добавлена в таблицу параметров вершин.

Привязка вершины к точечному объекту

Вершину сплайна или ломаной при построении по осям можно привязать к точечному объекту. Для этого следует указать нужный точечный объект курсором. Вершина кривой при этом будет совпадать с проекцией указанного точечного объекта на линию построения вершины.

Для указания точечного объекта подведите к нему курсор в окне модели. Когда рядом с курсором появится условное изображение вершины, щелкните левой кнопкой мыши.

Новая вершина появляется в окне модели. Автоматически заполняется строка параметров новой вершины в таблице параметров вершин. Значение координаты по выбранной оси будет равно значению этой координаты указанного точечного объекта.

Если опция Ассоциировать включена, то формируется ассоциативная связь вершины с указанным точечным объектом (см. раздел 2.5.4.8.6).

Если при построении вершины кривой опция Ассоциировать отключена, то вершина совпадает с указанным точечным объектом (или с его проекцией), но не связывается с ним, т.е. при перемещении точечного объекта вершина останется на прежнем месте.


2.5.4.8.5. Построение по объектам

При построении сплайна или ломаной по объектам накладывается ограничение на направление линии построения вершины. Для задания направления этой линии в качестве направляющих можно использовать существующие в окне модели прямолинейные или плоские объекты. Линия построения вершины может быть построена параллельно прямолинейному объекту либо перпендикулярно прямолинейному или плоскому объекту.

Если линия построения вершины строится параллельно объекту, то в качестве объекта, определяющего ее направление, можно использовать вектор.

Вектор можно создать при помощи команды Построение вектора, не выходя из процесса построения кривой (см. раздел 2.8.5).

Для задания положения вершины на линии построения могут использоваться следующие приемы:

– задание смещения создаваемой вершины от предыдущей или от заданной грани (см. раздел Задание смещения вершины),

– указание положения вершины в окне модели (см. раздел Указание курсором положения вершины в окне модели),

– привязка вершины к точечному объекту (см. раздел Привязка вершины к точечному объекту).

Создание линии построения вершины, параллельной объекту

Линия построения вершины кривой может быть построена параллельно существующему прямолинейному объекту (см. табл. 2.1.7). Кроме того, в качестве объекта, определяющего направление линии построения, можно использовать вектор. Этот вектор можно создать при помощи команды Построение вектора, не выходя из процесса построения кривой (см. раздел 2.8.5).

Чтобы создать линию построения вершины, выполните следующие действия.

1. Выберите из раскрывающегося списка Способ построения вариант Параллельно объекту.

2. Укажите направляющий объект в окне или Дереве построения или постройте вектор.

– Чтобы указать направляющий объект в окне модели, подведите к нему курсор. Когда рядом с курсором появится условное изображение этого объекта, щелкните левой кнопкой мыши.

– Чтобы создать вектор, определяющий направление линии построения вершины, нажмите кнопку Построение вектора на Панели специального управления.

Создание линии построения вершины, перпендикулярной объекту

Линия построения вершины кривой может быть построена перпендикулярно существующему прямолинейному или плоскому объекту (см. табл. 2.1.7).

Чтобы создать линию построения вершины, выполните следующие действия.

1. Выберите из раскрывающегося списка Способ построения вариант Перпендикулярно объекту.

2. Укажите направляющий объект в окне или Дереве построения.

Для указания направляющего объекта в окне модели подведите к нему курсор. Когда рядом с курсором появится условное изображение этого объекта, щелкните левой кнопкой мыши.

Линию построения вершины, перпендикулярную прямолинейному объекту, проходящему через предыдущую вершину кривой, построить невозможно, поскольку в данном случае нельзя однозначно определить направление построения.


2.5.4.8.6. Формирование ассоциативной связи вершин с точечными объектами. Особенности связанных вершин

2.5.4.8.6. Формирование ассоциативной связи вершин
с точечными объектами. Особенности связанных вершин

Вершина сплайна или ломаной может быть ассоциативно связана с точечным объектом. Благодаря наличию связи вершина будет следовать за объектом при любых его перемещениях. Ассоциативная связь формируется при включенной опции Ассоциировать во время указания точечного объекта. При этом в таблице параметров вершин в строке текущей вершины появляется значок связи вершины с точечным объектом (см. рис. 2.5.20).

Использование точечного объекта возможно при построении вершины ломаной или сплайна любым способом: По точкам, По осям и По объектам.

– При построении по точкам вершина непосредственно совпадает с указанным точечным объектом.

– При построении по осям или по объектам вершина совпадает с проекцией указанного точечного объекта на линию ее построения.

И в том, и в другом случае связь с точечным объектом сохраняется до тех пор, пока не будет явно удалена. Смена способа построения вершины не приводит к удалению связи.

Например, вершина, связанная с точечным объектом, была построена по точкам, то есть непосредственно совпадала с точечным объектом. При последующем редактировании для этой вершины был выбран способ построения по осям и в качестве направляющей указана ось Х. Поскольку связь с точечным объектом не была удалена, кривая перестроится таким образом, чтобы отредактированная вершина совпадала с проекцией заданного точечного объекта на ось Х.

И наоборот, если до редактирования вершина совпадала с проекцией точечного объекта на линию построения вершины, то в результате смены способа построения на способ по точкам она будет совпадать с самим точечным объектом.

Если при построении вершины кривой опция Ассоциировать отключена, то вершина совпадает с указанным точечным объектом (или с его проекцией), но не связывается с ним, т.е. при перемещении точечного объекта вершина останется на прежнем месте.


2.5.4.8.7. Замкнутая или разомкнутая кривая

Пространственные сплайн и ломаная могут быть разомкнутыми или замкнутыми. Чтобы выбрать вариант построения, активизируйте переключатель Разомкнутая кривая или Замкнутая кривая в группе Замкнутость. При замыкании кривой к ней добавляется участок, соединяющий начальную и конечную вершины, а при размыкании этот участок удаляется.


2.5.4.8.8. Редактирование параметров вершины

Вы можете изменить параметры любой уже созданной вершины сплайна или ломаной, не выходя из команды построения кривой.

Чтобы отредактировать существующую вершину, укажите ее в окне модели или активизируйте соответствующую ей строку в таблице параметров вершин кривой.

Элементы управления Панели свойств позволяют изменить способ, которым была построена выделенная вершина: По точкам, По осям и По объектам.

При выборе способа построения по осям можно изменить ось, параллельно которой строится линия построения вершины кривой.

При выборе способа построения по объектам можно изменить или построить объект, используемый в качестве направляющего.

Параметры вершины, не связанной с точечным объектом, можно изменить следующими способами.

– В ячейках таблицы параметров вершин:

• задать значения координат вершины;

• для сплайна — задать вес вершины;

• для ломаной — ввести радиус скругления.

– Изменить положение вершины в окне модели курсором.

– Используя поля на Панели свойств, изменить значения координат вершины или расстояние, на котором находится редактируемая вершина от предыдущей.

Если вершина связана с точечным объектом, то ее параметры можно изменить следующими способами.

– Удалить связь вершины с точечным объектом и воспользоваться вышеприведенными способами.

– Изменить положение точечного объекта.

– Указать другой точечный объект.

Если вершина была построена способом По точкам с указанием точечного объекта, то ее положение при смене способа построения изменится.

В таблице невозможно сформировать ассоциативную связь вершины с точечным объектом. Эта связь устанавливается при включенной опции Ассоциировать во время указания точечного объекта в окне модели. При этом в строке текущей вершины появляется значок связи вершины с точечным объектом. В таблице связь можно только удалить.

Будьте внимательны при удалении связи, так как отменить это действие невозможно. Для восстановления связи необходимо отредактировать вершину, заново построив или указав нужную точку.

Чтобы перейти от редактирования вершин сплайна или ломаной к продолжению ввода вершин, следует вызвать из контекстного меню команду Продолжить ввод вершин или активизировать последнюю — ненумерованную — строку таблицы параметров вершин.


2.5.4.9. Пространственный сплайн

Чтобы построить пространственный сплайн, вызовите команду Сплайн.

Построение сплайна заключается в последовательном задании вершин его опорной ломаной (далее — «вершин сплайна»).

Вершина сплайна может быть построена следующими способами:

– По точкам (см. раздел 2.5.4.8.3),

– По осям (см. раздел 2.5.4.8.4),

– По объектам (см. раздел 2.5.4.8.5).

Выберите способ построения вершины из раскрывающегося списка Способ построения на Панели свойств.

Первая вершина сплайна может быть построена только способом По точкам.

Типовыми приемами задания координат вершины являются следующие:

– ввод значений координат в таблицу параметров вершин (см. раздел 2.5.4.8.1),

– построение специальной точки (см. раздел 2.5.2.11),

– связывание вершины с точечным объектом в окне модели (см. раздел Привязка вершины к точечному объекту).

Группа переключателей Тип позволяет выбрать тип сплайна: сплайн по точкам или сплайн по полюсам (см. раздел 2.5.4.9.1).

Если начальная и/или конечная вершина сплайна принадлежит существующему объекту модели, вы можете сопрячь сплайн с этим объектом. Для задания условий сопряжения служит вкладка Сопряжения Панели свойств (см. раздел 2.5.4.9.2).

Опция Ассоциировать позволяет сформировать ассоциативную связь между вершинами сплайна и точечными объектами (см. раздел 2.5.4.8.6).

При необходимости вы можете изменить форму сплайна по точкам, управляя касательностью и кривизной в любой его вершине. Для этого выделите в таблице параметров строку с номером нужной вершины и нажмите кнопку Управление формой сплайна в вершинах на Панели специального управления. Система переходит в режим управления формой сплайна в текущей вершине (см. раздел 2.5.4.9.4).

Если начальная или конечная вершина сплайна сопряжена с объектом модели, то управление формой сплайна в этих вершинах невозможно. Удалите заданное сопряжение, чтобы получить возможность управлять формой сплайна в этой вершине (например, с помощью команд контекстного меню Удалить параметры управления — В точке или Удалить параметры управления — Во всех точках).

Элементы управления, расположенные на вкладке Свойства Панели свойств, позволяют изменить название и цвет сплайна, настроить параметры его отображения (о параметрах отображения см. раздел 2.5.4.1). Также на этой вкладке отображается название системы координат сплайна (о системе координат объекта см. раздел 2.8.3.4.1).

Сплайн с текущими параметрами отображается на экране в виде фантома. При изменении параметров фантом изменяется.

Завершив задание параметров вершин, нажмите кнопку Создать объект на Панели специального управления.

В окне модели появляется пространственный сплайн, а в Дереве построения — его пиктограмма. Подчиненными объектами сплайна в Дереве построения являются его вершины.

В этом разделе:

2.5.4.9.1. Тип сплайна

2.5.4.9.2. Сопряжение сплайна с объектами модели

2.5.4.9.3. Особенности сопряжения сплайна По полюсам с другими объектами. Системный полюс

2.5.4.9.4. Управление формой сплайна

2.5.4.9.5. Задание ориентации касательной и величины касательности

2.5.4.9.6. Задание кривизны и ориентации нормали

2.5.4.9.7. Направляющий объект для вектора

2.5.4.9.8. Вращение управляющего фантома


2.5.4.9.1. Тип сплайна

Чтобы выбрать тип сплайна, активизируйте нужный переключатель в группе Тип: Сплайн по точкам или Сплайн по полюсам (табл. 2.5.7).

Табл. 2.5.7. Типы сплайнов
Тип кривой | Результат построения
Сплайн по точкам | Сплайн проходит через все вершины, координаты которых заданы в таблице.
Сплайн по полюсам | Сплайн проходит через конечные вершины касательно к конечным сегментам опорной ломаной и не проходит через промежуточные вершины (они называются «полюсами сплайна»). Расстояние от сплайна до полюса зависит от значения параметра Вес этого полюса.

При построении сплайна по полюсам становятся доступными поля Порядок и Вес.

По умолчанию сплайн имеет порядок 4, а все полюса имеют вес 1. Порядок может принимать значения в диапазоне 2–10, а вес — в диапазоне 0,0001–999.

– Чтобы задать порядок сплайна, введите нужное значение в поле Порядок.

– Чтобы задать вес полюса сплайна, выделите этот полюс и введите нужное значение в поле Вес. Вес полюса можно также задать в колонке Вес таблицы параметров вершин (см. рис.2.5.20, а).

Подробно о порядке кривых и весе точек рассказано в разделе 3 Приложения IX.


2.5.4.9.2. Сопряжение сплайна с объектами модели

Сплайн может сопрягаться с уже существующим в модели объектом (объектом сопряжения) в своей начальной или конечной вершине (вершине сопряжения). Чтобы сопряжение было возможно, вершина сопряжения должна принадлежать объекту сопряжения.

В качестве объектов сопряжения могут использоваться:

– односегментные пространственные кривые (или отдельные сегменты многосегментных),

– вспомогательные и координатные плоскости,

– линии эскиза,

– ребра,

– грани тел и поверхностей.

Возможно использование одного из четырех условий сопряжения: Не задано, По касательной, Гладкое и Перпендикулярно (см. раздел 6 Приложения IX).

Условия сопряжения задаются при создании или редактировании сплайна на вкладке Сопряжения Панели свойств.

Рис. 2.5.23. Вкладка Сопряжения

Доступность того или иного условия сопряжения для начальной или конечной вершины зависит от типа объекта сопряжения.

– Если объект сопряжения — плоскость или грань, то доступны следующие условия сопряжения: Не задано и Перпендикулярно.
Если вершина сопряжения лежит на кривой, принадлежащей плоскости или грани (например, на ребре), то эту кривую можно использовать в качестве граничного объекта, относительно которого задается условие сопряжения. В этом случае доступны все условия сопряжения.

– Если объект сопряжения — пространственная кривая, являющаяся прямолинейным объектом (например, сегментом ломаной), то доступны следующие условия сопряжения: Не задано, По касательной, Гладкое. При сопряжении с пространственными кривыми остальных типов доступны все условия сопряжения (типы пространственных кривых перечислены в таблице 2.1.7).

Вы можете сменить направление сопряжения с помощью группы переключателей Направление. Группа недоступна, если условие сопряжения сплайна — Не задано.

Формирование сопряжения

Чтобы сформировать сопряжение сплайна с объектом сопряжения, выполните следующие действия.

1. Выберите начальную или конечную вершину сплайна для определения параметров сопряжения. Для этого в группе Начальная/конечная вершина активизируйте нужный переключатель. Выбранная вершина будет подсвечена в окне модели.

2. Укажите в окне модели объект сопряжения. Выбранный объект подсветится, а его название появится в поле Объект сопряжения.

3. При необходимости укажите в окне модели граничный объект. Выбранный объект подсветится, а его название появится в поле Граница.

4. Раскройте список Условие и выберите из него условие сопряжения. Условия, которые невозможно применить для выбранной вершины, недоступны.

Фантом создаваемого сплайна в окне модели перестроится согласно выбранному условию сопряжения, около вершины появится обозначение условия сопряжения.

Сопряжение сплайна По полюсам с другими объектами имеет ряд особенностей, см. раздел 2.5.4.9.3.

Удаление сопряжения

Вы можете удалить сопряжение сплайна в начальной или конечной вершине или сразу во всех вершинах.

Для удаления заданного сопряжения в текущей — начальной или конечной — вершине вызовите команду контекстного меню Удалить параметры управления — В точке. Для удаления заданных сопряжений во всех вершинах вызовите команду контекстного меню Удалить параметры управления — Во всех точках.

Вы можете удалить заданное сопряжение в начальной или конечной вершине с помощью команды Указать заново. Для этого активизируйте нужный переключатель в группе Начальная/конечная вершина на Панели свойств, а затем нажмите кнопку Указать заново на Панели специального управления.

Обратите внимание на то, что восстановить удаленное сопряжение невозможно. Для восстановления сопряжения необходимо сформировать его заново.

Если вершина сплайна имеет признак системного полюса, то можно удалить сопряжение сплайна, отменив этот признак. Для этого следует выделить в таблице параметров вершин строку этого системного полюса и щелкнуть мышью по значку системного полюса в колонке Связь или вызвать команду Удалить связь из контекстного меню таблицы. Связь будет удалена. При этом координаты вершины не изменятся.


2.5.4.9.3. Особенности сопряжения сплайна По полюсам с другими объектами. Системный полюс

2.5.4.9.3. Особенности сопряжения сплайна По полюсам
с другими объектами. Системный полюс

Использование условий сопряжения Перпендикулярно, По касательной и Гладко для сплайна По полюсам имеет следующие особенности.

Сопряжение формируется за счет определенных геометрических ограничений в расположении полюсов сплайна, соседних с вершиной сопряжения. Эти ограничения накладываются на полюсы автоматически после выбора условия сопряжения. Если нужно, то полюс сдвигается на минимально необходимое расстояние. Полюсы сплайна с автоматически наложенными ограничениями становятся системными полюсами. В таблице координат вершин системные полюсы отмечаются специальным значком, см. рис. 2.5.20.

Ограничения, накладываемые на системные полюсы, и количество системных полюсов, необходимое для выполнения различных условий сопряжения, приведены в таблице 2.5.8.

Табл. 2.5.8. Количество системных полюсов, необходимое для выполнения условий сопряжения, и геометрические ограничения для этих полюсов
Условие сопряжения | Количество системных полюсов; геометрические ограничения для них | Пример1
Не задано | 0; ограничений нет |
По касательной | 1; ограничение: принадлежность прямой a, касательной к объекту сопряжения в точке сопряжения |
Перпендикулярно | 1; ограничение: принадлежность прямой b, перпендикулярной объекту сопряжения в точке сопряжения |
Гладкое | 2; ограничение для первого полюса: принадлежность прямой a; ограничение для второго полюса: принадлежность прямой c, проходящей параллельно a на расстоянии, которое зависит от кривизны объекта сопряжения в точке сопряжения и от расстояния между этой точкой и первым полюсом |
  1. Цифрами на рисунках обозначены: 1 — вершина сопряжения сплайна с объектом, начальная вершина; 2 и 3 — полюсы сплайна, 4 — конечная вершина сплайна.

Сопряжение сплайна в начальной (конечной) вершине возможно, если она имеет достаточное для данного сопряжения количество соседних полюсов, которые не являются на данный момент системными (т.е. не используются для сопряжения в противоположной вершине).

Для Гладкого сопряжения необходимо также, чтобы порядок сплайна был выше или равен 4.

Если полюсы, соседние с вершиной сопряжения, связаны с точечными объектами или имеют способ построения По осям или По объектам, то после выбора условия сопряжения на экране появляется сообщение об изменении способа построения и перемещении вершин.

Нажмите кнопку ОК, чтобы подтвердить изменение параметров вершины: смену способа построения на способ По точкам, отмену связи с точечным объектом и, при необходимости, изменение координат. Отредактированная вершина получает признак системного полюса — в таблице параметров вершин в строке этой вершины появляется значок системного полюса (см. рис. 2.5.20).

Чтобы отказаться от изменения параметров вершин, нажмите в сообщении кнопку Отмена. В этом случае условие сопряжения остается прежним — Не задано.


2.5.4.9.4. Управление формой сплайна

Если сплайн построен по точкам, то вы можете изменить его форму, управляя касательностью и/или кривизной в текущей вершине.

Изменение формы сплайна производится в режиме управления формой сплайна в текущей вершине. Для перехода в этот режим выделите в окне модели нужную вершину или в таблице параметров вершин строку с номером этой вершины, а затем нажмите кнопку Управление формой сплайна в вершинах на Панели специального управления.

Если начальная или конечная вершина сплайна сопряжена с объектом модели, то управление формой сплайна в этих вершинах невозможно. Чтобы получить возможность управлять формой сплайна в начальной или конечной вершине, удалите заданное сопряжение в этой точке (например, с помощью команд контекстного меню Удалить параметры управления — В точке или Удалить параметры управления — Во всех точках).

После перехода в режим управления вкладка Параметры содержит таблицу параметров вершин и список Управление с вариантами управления формой сплайна в текущей вершине (рис. 2.5.24). Выберите из списка нужный вариант управления.

Рис. 2.5.24. Список Управление

Подробнее варианты управления описаны ниже.

Задайте параметры выбранного варианта с помощью элементов управления Панели свойств или с помощью управляющего фантома в окне модели.

Фантом создаваемого сплайна в окне модели перестраивается, около текущей вершины появляется обозначение варианта управления.

Находясь в режиме управления формой сплайна, вы можете также изменить положение текущей вершины, переместив ее мышью в окне модели или задав нужные значения координат вершины в таблице параметров (см. раздел Изменение параметров вершины в таблице параметров).

Завершив управление формой сплайна в одной из вершин, вы можете:

– перейти к управлению формой сплайна в другой его вершине — для этого выделите в окне модели нужную вершину или в таблице параметров вершин строку с номером этой вершины,

– выйти из режима управления формой сплайна — для этого нажмите кнопку Управление формой в точках на Панели специального управления,

– завершить построение сплайна — для этого нажмите кнопку Создать объект.

Управление касательностью

Данный вариант позволяет управлять формой сплайна в текущей вершине путем задания направления касательной и величины касательности.

Величина касательности показывает, насколько форма сплайна близка к соприкасающейся окружности в окрестности его текущей вершины (о соприкасающейся окружности см. раздел 5 Приложения IX).

Кривизна сплайна в текущей вершине определяется системой автоматически по заданной величине касательности.

Чтобы перейти к этому варианту, выберите в списке Управление на Панели свойств вариант Касательностью.

Используя элементы управления на Панели свойств или характерные точки управляющего фантома, задайте направление касательной в текущей вершине и величину касательности в этой вершине. Подробнее о задании выше перечисленных параметров см. раздел 2.5.4.9.5.

Управление кривизной

Данный вариант позволяет управлять формой сплайна в текущей вершине путем задания кривизны или радиуса кривизны.

– Задание кривизны включает в себя определение направления вектора нормали и задание величины кривизны.

– Задание радиуса кривизны включает в себя определение положения центра кривизны и задание величины радиуса кривизны.

Касательность сплайна в текущей вершине определяется по заданной величине кривизны или величине радиуса кривизны.

Чтобы перейти к этому варианту, выберите в списке Управление на Панели свойств вариант Кривизной.

Используя элементы управления на Панели свойств или характерные точки управляющего фантома, задайте направление кривизну или радиус кривизны в текущей вершине. Подробнее о задании выше перечисленных параметров см. раздел 2.5.4.9.6.

Управление касательностью и кривизной

Данный вариант позволяет изменить форму сплайна, управляя в текущей вершине сразу двумя параметрами — величиной касательности и кривизной.

Чтобы перейти к этому варианту, выберите в списке Управление на Панели свойств вариант Касательностью и кривизной.

Выберите способ управления, используя переключатели группы Способ:

– Активизируйте переключатель Управление ориентацией касательной и величиной касательности, чтобы задать направление касательной и величину касательности в текущей вершине (см. раздел 2.5.4.9.5).

– Активизируйте переключатель Управление ориентацией нормали и кривизны, чтобы изменить форму сплайна, управляя кривизной или радиусом кривизны (см. раздел 2.5.4.9.6).

Кроме активизации переключателей группы Способ для перехода между способами можно щелкать мышью по характерным точкам управляющего фантома «Касательность» и «Кривизна».


2.5.4.9.5. Задание ориентации касательной и величины касательности

Вы можете задать ориентацию касательной и величину касательности с помощью элементов управления на Панели свойств (рис. 2.5.25) или с помощью характерных точек управляющего фантома (рис. 2.5.26).

Рис. 2.5.25. Панель свойств при управлении ориентацией касательной и величиной касательности

Рис. 2.5.26. Управляющий фантом при управлении ориентацией касательной и касательностью

Направление вектора касательной в текущей вершине

Направление вектора касательной в текущей вершине можно задать с помощью направляющего объекта или вращения управляющего фантома.

О задании направляющего объекта для касательного вектора рассказано в разделе 2.5.4.9.7, о вращении управляющего фантома — в разделе 2.5.4.9.8.

При необходимости вы можете сменить полученное направление вектора касательной на противоположное. Для этого нажмите переключатель Сменить направление.

Касательность

Чтобы задать величину касательности сплайна в текущей вершине, введите в поле Касательность нужное значение и нажмите клавишу <Enter>. Фантом сплайна перестраивается.

Вы можете также задать величину касательности с помощью характерной точки управляющего фантома «Касательность» (см. рис.2.5.26).


2.5.4.9.6. Задание кривизны и ориентации нормали

Вы можете задать кривизну или радиус кривизны с помощью элементов управления на Панели свойств (рис. 2.5.27) или с помощью характерных точек управляющего фантома (рис. 2.5.28 и 2.5.30).

Задание кривизны

Чтобы задать кривизну в текущей вершине, в группе Параметр активизируйте переключатель Кривизна. На Панели свойств появляются элементы управления для задания кривизны (см. рис. 2.5.27).

Рис. 2.5.27. Панель свойств при управлении ориентацией нормали и кривизной

На экране появляется управляющий фантом (рис. 2.5.28).

Рис. 2.5.28. Управляющий фантом при задании кривизны

Задание кривизны включает в себя определение направления вектора нормали и задание величины кривизны.

Направление вектора нормали в текущей вершине

Для определения направления вектора нормали используются следующие способы:

– задание направляющего объекта;

– вращение управляющего фантома.

Подробнее о задании направления вектора нормали см. раздел 2.5.4.9.7, о вращении управляющего фантома — в разделе 2.5.4.9.8.

При необходимости вы можете сменить направление вектора нормали на противоположное. Для этого нажмите переключатель Сменить направление.

Кривизна

Для задания величины кривизны в поле Кривизна введите нужное значение и нажмите клавишу <Enter>. Фантом сплайна перестраивается.

Вы можете также задать величину кривизны с помощью характерной точки управляющего фантома «Кривизна» (см. рис.2.5.28).

Задание радиуса кривизны

Чтобы задать радиус кривизны в текущей вершине, в группе Параметр активизируйте переключатель Радиус кривизны.

На Панели свойств появляются элементы управления, показанные на рис. 2.5.29.

Рис. 2.5.29. Панель свойств при управлении расположением центра и величиной радиуса кривизны

На экране появляется управляющий фантом (рис. 2.5.30).

Рис. 2.5.30. Управляющий фантом при задании радиуса кривизны

Задание радиуса кривизны включает в себя определение положения центра кривизны и задание величины радиуса кривизны.

Радиус кривизны можно задать, используя один из следующих приемов:

– Ручное задание центра кривизны

Введите нужные координаты центра кривизны в соответствующие поля на Панели свойств. Управляющий фантом принимает заданное положение. В поле Радиус отображается расстояние от текущей вершины до центра кривизны. При необходимости вы можете изменить полученное значение радиуса кривизны. Для этого введите в поле нужное значение и нажмите клавишу <Enter>.

Управляющий фантом перестраивается — центр кривизны перемещается на заданное расстояние вдоль радиуса. Координаты центра кривизны пересчитываются.

Кроме того, положение центра кривизны можно задать мышью в окне модели. Для этого переместите характерную точку управляющего фантома в нужное положение. Обратите внимание на то, что при этом соприкасающаяся окружность и вектор нормали вращаются вокруг вектора касательной.

– Использование направляющего объекта

Данный прием включает в себя следующие действия:

• указание направляющего объекта для радиуса кривизны в текущей вершине,

• задание величины радиуса кривизны в этой вершине.

В качестве направляющего объекта может использоваться любой точечный, прямолинейный или плоский объект (см. табл. 2.1.7).

Направление, задаваемое точечным объектом — прямая, проходящая через точечный объект и текущую вершину, прямолинейным — прямая, параллельная объекту, плоским — прямая, перпендикулярная объекту. Укажите направляющий объект в Дереве построения или в окне модели.

Кроме того, направляющим объектом может служить вектор. Чтобы создать вектор, нажмите кнопку Построение вектора на Панели специального управления (см. раздел 2.8.5).

Наименование выбранного или построенного объекта отображается в поле Направляющий объект. Управляющий фантом принимает заданное положение, центр кривизны располагается на радиусе, радиус имеет текущее значение.

Задайте величину радиуса кривизны. Для этого введите в поле Радиус нужное значение и нажмите клавишу <Enter>. Фантом сплайна перестраивается.

Обратите внимание на то, что если в качестве направляющего объекта используется точечный объект, то центр кривизны совмещается с этим объектом. В поле Радиус отображается расстояние от текущей вершины до центра кривизны, поля для ввода координат центра кривизны недоступны.

Вы можете также задать величину радиуса с помощью характерной точки управляющего фантома «Радиус» (см. рис.2.5.30).

Полученное направление радиуса кривизны (первым или вторым приемом) вы можете сменить на противоположное. Для этого нажмите на Панели свойств переключатель Сменить направление.


2.5.4.9.7. Направляющий объект для вектора

В качестве направляющего объекта для касательного вектора или вектора нормали может использоваться любой точечный, прямолинейный или плоский объект (см. табл. 2.1.7).

Направление, задаваемое точечным объектом — прямая, проходящая через точечный объект и текущую вершину, прямолинейным — прямая, параллельная объекту, плоским — прямая, перпендикулярная объекту.

Кроме того, направляющим объектом может служить вектор (см. раздел 2.8.5). Чтобы создать вектор, нажмите кнопку Построение вектора на Панели специального управления.

Укажите направляющий объект в Дереве построения или в окне модели или постройте вектор.

Наименование выбранного или построенного объекта отображается в поле Направляющий объект. Управляющий фантом принимает заданное положение, фантом сплайна перестраивается.

Если в качестве направляющего используется прямолинейный объект, то вы можете выбрать направление вектора: параллельно направляющему объекту или перпендикулярно ему. Для этого служит группа переключателей Ориентация.


2.5.4.9.8. Вращение управляющего фантома

Вы можете вращать управляющий фантом вокруг любого из базисных векторов, используя элементы управления на Панели свойств (о базисных векторах см. раздел 4 Приложения IX).

Группа переключателей Вращение на Панели свойств позволяет выбрать вектор, вокруг которого будет вращаться управляющий фантом.

– Активизируйте переключатель Вокруг вектора касательной, чтобы фантом вращался вокруг вектора касательной. Затем в поле Угол введите значение угла вращения.

– Активизируйте переключатель Вокруг вектора нормали, чтобы фантом вращался вокруг вектора нормали. Затем в поле Угол введите значение угла вращения.

– Активизируйте переключатель Вокруг вектора бинормали, чтобы фантом вращался вокруг вектора бинормали. Затем в поле Угол введите значение угла вращения.

Управляющий фантом принимает заданное положение, фантом сплайна перестраивается.

Вы можете также вращать управляющий фантом вокруг базисных векторов с помощью характерных точек «Вокруг вектора касательной», «Вокруг вектора нормали», «Вокруг вектора бинормали» или произвольно — с помощью характерной точки «Вращение» (см. рис. 2.5.26 и 2.5.28).

– Если используется вариант управления Касательностью, то вращение управляющего фантома возможно только вокруг вектора нормали или вектора бинормали. Поэтому фантом не имеет характерную точку «Вокруг вектора касательной», а в группе Вращение недоступен переключатель Вокруг вектора касательной.

– Если используется вариант управления Кривизной, то вращение управляющего фантома возможно только вокруг вектора касательной или вектора бинормали. Поэтому фантом не имеет характерную точку «Вокруг вектора нормали», а в группе Вращение недоступен переключатель Вокруг вектора нормали.

– Если используется вариант управления Касательностью и кривизной, то вращение управляющего фантома возможно вокруг всех базисных векторов. Поэтому фантом содержит все характерные точки, а в группе Вращение доступны все переключатели.

Обратите внимание на то, что если в варианте Касательностью и кривизной касательная или нормаль связана с направляющим объектом, то ее положение в пространстве фиксируется. В этом случае задать направление другой прямой (нормали или касательной) можно следующим образом:

• вращением управляющего фантома вокруг заданной прямой с помощью его характерной точки,

• указанием такого направляющего объекта, который перпендикулярен заданной прямой.


2.5.4.10. Пространственная ломаная

Чтобы построить пространственную ломаную, вызовите команду Ломаная.

Построение ломаной заключается в последовательном задании ее вершин.

Вершина ломаной может быть построена следующими способами:

– По точкам (см.раздел 2.5.4.8.3),

– По осям (см.раздел 2.5.4.8.4),

– По объектам (см. раздел 2.5.4.8.5).

Способ построения можно выбрать из раскрывающегося списка Способ построения.

Типовыми приемами задания координат вершины являются следующие:

– указание курсором положения вершины в окне модели,

– ввод значений координат в таблицу параметров вершин (см. раздел 2.5.4.8.1),

– построение специальной точки (см. раздел 2.5.2.11),

– связывание вершины с точечным объектом в окне модели (см. раздел Привязка вершины к точечному объекту).

При указании положения вершины курсором в окне модели необходимо учитывать положение плоскости экрана в трехмерном пространстве окна модели.

Первая вершина ломаной может быть построена только способом По точкам.

Вторая вершина по умолчанию строится способом По осям. Способ построения для этой вершины может быть изменен.

При создании очередной вершины любым способом на экране отображается линия ее построения, соединяющая эту вершину с предыдущей. Это позволяет оценить правильность ввода параметров и, при необходимости, откорректировать их.

При необходимости вы можете построить несколько вершин ломаной между двумя уже существующими вершинами (см. раздел 2.5.4.10.1). После завершения построения новые вершины в добавляются в таблицу параметров. Вершины ломаной нумеруются заново. Чтобы продолжить создание новых вершин, выделите последнюю — ненумерованную — строку таблицы.

Опция Ассоциировать позволяет сформировать ассоциативную связь между вершинами ломаной и точечными объектами (см. раздел 2.5.4.8.6).

Вершины ломаной могут быть скруглены, см. раздел 2.5.4.10.2.

Элементы управления, расположенные на вкладке Свойства Панели свойств, позволяют изменить название и цвет ломаной, настроить параметры ее отображения (о параметрах отображения см. раздел 2.5.4.1). Также на этой вкладке отображается название системы координат ломаной (о системе координат объекта см. раздел 2.8.3.4.1).

Ломаная с текущими параметрами отображается на экране в виде фантома. При изменении параметров фантом изменяется.

Завершив задание параметров вершин, нажмите кнопку Создать объект на Панели специального управления.

В окне модели появляется пространственная ломаная, а в Дереве построения — ее пиктограмма. Подчиненными объектами ломаной в Дереве построения являются ее вершины.

В этом разделе:

2.5.4.10.1. Встраивание совокупности вершин

2.5.4.10.2. Скругление вершин


2.5.4.10.1. Встраивание совокупности вершин

Чтобы встроить совокупность вершин между двумя уже существующими, следует нажать кнопку Вставить совокупность вершин. Система переходит в процесс создания новых вершин ломаной между двумя уже существующими вершинами.

Укажите курсором граничные вершины ломаной, между которыми будет встраиваться совокупность.

В качестве второй граничной вершины не может быть выбрана вершина, номер которой меньше, чем у первой.

Участок ломаной между граничными вершинами исчезнет.

Создайте новые вершины ломаной. При построении совокупности вершин доступны те же приемы, что и при построении ломаной (см. раздел 2.5.4.10). Параметры вставленных вершин отображаются в таблице параметров вершин.

Чтобы завершить встраивание, нажмите кнопку Создать объект на Панели специального управления.

Вершины встроенной совокупности заменят собой вершины, ранее находившиеся между граничными. Параметры вставленных вершин будут добавлены в таблицу параметров. Вершины ломаной будут перенумерованы.


2.5.4.10.2. Скругление вершин

Чтобы скруглить вершину ломаной, следует выделить нужную вершину в окне модели и ввести значение радиуса скругления в поле Радиус на Панели свойств. Кроме того, можно ввести радиус в соответствующую ячейку таблицы параметров вершин, см. рис. 2.5.20, б).

Если ломаная замкнута, то скруглить можно любую вершину, а если разомкнута, то — любую, кроме начальной и конечной.

Управлять радиусом скругления можно также в окне модели, перемещая характерные точки. Группа переключателей Характерные точки на Панели свойств позволяет указать, какие именно характерные точки ломаной должны отображаться на экране:

– Если активен переключатель Все характерные точки, то в каждой вершине (кроме начальной и конечной вершин разомкнутой ломаной) отображается по две точки: одна для изменения положения вершины, другая для изменения радиуса скругления.

– Если активен переключатель Характерные точки вершин и ненулевых скруглений, то точка для изменения радиуса скругления отображается, только если значение радиуса отлично от нуля. Таким образом, в вершинах с нулевым радиусом (а также в начальной и конечной вершине разомкнутой ломаной) отображается одна точка, а в остальных — две.


2.5.4.11. Сплайн по объектам

Вы можете построить сплайн, повторяющий форму объекта (или объектов) модели. В качестве исходных объектов могут использоваться пространственные кривые, ребра тел и поверхностей, контуры в эскизе.

– Если исходные объекты образуют цепочку и гладко состыкованы, то создается один сплайн.

– Если исходные объекты не гладко состыкованы или не образуют цепочку, то создается несколько отдельных сплайнов.

Сплайн, построенный по исходным объектам, не отличается от сплайна, построенного с помощью команды Сплайн (см. раздел 2.5.4.9). Поэтому для редактирования созданного сплайна могут использоваться типовые приемы редактирования сплайна.

Чтобы построить пространственный сплайн по исходным объектам, вызовите команду Сплайн по объектам.

Укажите объект или объекты для создания сплайна в окне модели. Пространственные кривые можно указать в Дереве построения.

Исходные объекты могут быть выделены и перед вызовом команды.

Повторное указание объекта отменяет его выбор.

Переключатели группы Режим позволяют указать, требуется ли оставлять исходные объекты после выполнения команды или нет.

Элементы управления, расположенные на вкладке Свойства Панели свойств, позволяют изменить название и цвет сплайна, настроить параметры его отображения (о параметрах отображения см. раздел 2.5.4.1). Также на этой вкладке отображается название системы координат сплайна (о системе координат объекта см. раздел 2.8.3.4.1).

Чтобы завершить построение, нажмите кнопку Создать объект на Панели специального управления.

– Если выбран режим построения сплайна без удаления исходных объектов, в окне модели появляется созданный сплайн, а в Дереве построения — пиктограмма сплайна.

– Если выбран режим построения сплайна с удалением исходных объектов, на экране появляется диалог удаления объектов. Диалог позволяет просмотреть удаляемые объекты модели. Вы можете отказаться от удаления или подтвердить его.

• В случае отказа от удаления: в окне модели появляется сплайн, исходные объекты остаются.

• В случае подтверждения удаления: в окне модели появляется сплайн, исходные объекты исчезают.

Обратите внимание на то, связь между сплайном и указанным объектом не формируется, т.е. удаление или редактирование объекта не влияет на созданный сплайн.

Из модели можно удалить только те объекты, которые принадлежат данной модели, но не ее компонентам.

Объекты, принадлежащие компонентам, удалить нельзя. Если для построения сплайна выбираются объекты компонентов, то после нажатия кнопки Создать объект сплайн создается, а на экране появляется сообщение о том, что удаление выбранных объектов не возможно.


2.5.4.12. Кривая по закону

Вы можете построить кривую, задав ее параметрическими уравнениями.

Подробнее о параметрическом представлении кривой см. раздел 2.5.2.

Кривая относится к объектам, использующим систему координат (о системе координат объекта — см. раздел 2.8.3.4.1).

Параметрические уравнения кривой можно задать в прямоугольных, цилиндрических или сферических координатах. По умолчанию кривая строится в прямоугольной системе координат, которая совпадает с системой координат кривой. Цилиндрическая или сферическая система координат размещается относительно системы координат кривой так же, как для точки (см. раздел 2.5.3.4.1).

Чтобы построить кривую по параметрическим уравнениям, выполните следующие действия.

1. Вызовите команду Кривая по закону.

На экране появляется фантом создаваемой кривой в умолчательном виде.

2. Выберите тип координат для построения кривой. Для этого в группе Тип координат на Панели свойств активизируйте нужный переключатель:

– Прямоугольные X,Y,Z,

– Цилиндрические R,A,Z,

– Сферические R,A,B.

3. Задайте функции для координат точек кривой (см. раздел 2.5.4.12.1).

Все изменения отображаются на фантоме создаваемой кривой в окне модели.

4. При необходимости измените наименование и цвет создаваемой кривой, настройте ее отображение. Для этого служат элементы управления, расположенные на вкладке Свойства Панели свойств. Также на этой вкладке отображается название системы координат кривой.
Подробнее о параметрах отображения кривой см. раздел 2.5.4.1.

5. Нажмите кнопку Создать объект на Панели специального управления.

В окне модели появляется кривая, а в Дереве построения — ее пиктограмма.

В этом разделе:

2.5.4.12.1. Задание функции для координаты точки кривой

2.5.4.12.2. Ввод выражения и задание параметра функции

2.5.4.12.3. Задание интервального параметра функции

2.5.4.12.4. Примеры создания кривых по параметрическим уравнениям


2.5.4.12.1. Задание функции для координаты точки кривой

Вы можете задать функцию для каждой координаты точки кривой линейным, кубическим или параметрическим уравнением (о параметрическом представлении кривой см. раздел 2.5.2). Кроме того, вы можете задать для координаты постоянное значение.

Набор координат, для которых задаются функции, зависит от того, какой тип координат выбран для построения кривой (см. п.2 раздела 2.5.4.12). Например, если кривая строится в цилиндрической системе координат, то функции задаются для координат R, A, Z.

Задание функции для координаты включает в себя выбор типа функции, а затем задание ее параметров.

Чтобы выбрать тип функции для координаты, раскройте на Панели свойств список Функция по <имя координаты> и укажите в нем нужную строку (см. рис. 2.5.31).

Рис. 2.5.31. Список Тип функции по X

На Панели свойств появляются элементы управления, позволяющие задать параметры функции выбранного типа. Задание параметров функции каждого типа описано в таблице 2.5.9.

До завершения команды система «запоминает» данные, введенные для каждого типа функции, поэтому вы можете переключаться между типами функции без потери этих данных.

Табл. 2.5.9. Задание параметров функции для координаты точки кривой

Тип функции

Задание параметров функции для координаты точки кривой

Константа

Координата задана постоянным значением.

Введите или задайте счетчиком нужное значение координаты в поле Значение по <имя координаты>.

Линейная

Функция для координаты задана линейным уравнением.

Введите начальное и конечное значение координаты в соответствующие поля на Панели свойств.

Кубическая

Функция для координаты задана кубическим уравнением.

Введите начальное и конечное значение координаты в соответствующие поля на Панели свойств

По выражению

Функция для координаты задана параметрическим уравнением.

Введите в поле Выражение функции по <имя координаты> выражение функции, определяющее координату. Затем в поле Интервальный параметр введите данные о параметре функции: имя и интервал изменения.

Подробнее ввод выражения функции описан в разделе 2.5.4.12.2, а задание интервального параметра функции — 2.5.4.12.3.

Для задания координат точки можно использовать константы (см. табл. 4 Приложения IV). Для функций типа Константа, Линейная, Кубическая после ввода константы и нажатия клавиши <Enter> обозначение константы в поле координаты заменяется ее значением. Для функции типа По выражению значение введенной константы используется при вычислении координаты по заданному выражению функции.

Построение кривой невозможно, если для всех координат точки кривой выбран тип функции Константа. В этом случае на экране появляется предупреждение о том, что функция хотя бы по одной координате не должна быть константой.


2.5.4.12.2. Ввод выражения и задание параметра функции

Для ввода выражения функции, определяющей координату, служит поле Выражение функции по <имя координаты>.

Выражение функции может содержать интервальный параметр (см. раздел 2.5.4.12.3) и неинтервальные параметры. Например, в выражении функции для координаты Z, которое показано на рисунке 2.5.32, параметр t является интервальным, а параметры r и h — неинтервальными.

Обратите внимание на то, что имя интервального параметра не должно совпадать с именами неинтервальных параметров.

Для ввода выражения могут использоваться следующие приемы:

– ввод выражения вручную;

– вставка в выражение переменной модели;

– вставка элементов выражения из коллекции;

– вставка группового закона из коллекции — вставка выражений функций сразу для всех координат.

Приемы ввода выражения описаны ниже.

Если в выражении функции нет интервального параметра, то значением функции является результат вычисления этого выражения, т.е. константа. Для того чтобы построение кривой было возможно, функция хотя бы по одной координате должна содержать интервальный параметр, т.е. не должна быть константой.

В выражение может быть включено любое количество пробелов. При интерпретации выражения они не учитываются.

После ввода выражения нажмите клавишу <Enter>.

Если выражение содержит русские буквы, или неверное сочетание знаков операций, или символы, не являющиеся обозначениями операций/функций, на экране появляется сообщение о наличии синтаксических ошибок.

После ввода выражения функции неинтервальные параметры заносятся в таблицу Значение параметров на Панели свойств.

Таблица состоит из трех колонок. В первой колонке показываются имена параметров выражений, во второй — выражения для их вычисления, в третьей — их значения (см. рис. 2.5.32). Работа с таблицей аналогична работе в Окне переменных (об Окне переменных см. раздел 7.1.1.3).

Рис. 2.5.32. Пример таблицы значений параметров функции по координате Z

Ввод вручную

Вы можете ввести выражение функции в поле Выражение функции по <имя координаты> с клавиатуры.

При вводе выражения вы можете использовать в качестве параметров уже существующие пользовательские переменные модели, в том числе функциональные (см. раздел 7.1.5). Для этого имя параметра должно совпадать с именем переменной. Данные о переменной (для пользовательской переменной — имя и выражение, для функциональной — имя и выражение и аргумент) передаются в таблицу Значение параметров из Окна переменных. Изменение этих данных в таблице недоступно.

Если имя параметра не совпадает ни с одним из имеющихся имен переменных, то этот параметр заносится в таблицу с умолчательным значением. Активизируйте в столбце Выражение ячейку параметра двойным щелчком мыши и введите нужное значение параметра. Затем нажмите клавишу <Enter>. После создания кривой в списке переменных модели появляется переменная с именем заданного параметра.

Функциональную переменную, используемую в выражении функции, рекомендуется создать в Окне переменных до построения кривой по закону.

После создания кривой вы можете отредактировать использованные в ней переменные — ввести новое значение переменной или выражение для ее вычисления в Окне переменных. После перестроения модели форма кривой изменяется.

В выражении можно использовать арифметические операторы, константы, функции и формулы (см. таблицы Приложения III и таблицы 1, 2, 3 и 4 Приложения IV). Операторы, константы, функции и формулы можно копировать в поле Выражение функции по <имя координаты> через буфер обмена.

Вставка переменной модели

В выражение функции можно вставить существующую переменную, выбрав ее из числа переменных модели. Для этого нажмите на Панели специального управления кнопку Вставить имя переменной. На экране появляется диалог Переменные, содержащий список всех переменных модели. Чтобы указать нужную переменную, выделите любую ячейку в строке этой переменной, а затем нажмите кнопку ОК диалога.

Имя переменной добавляется в выражение функции, ее данные передаются в таблицу Значение параметров (см. рис. 2.5.32).

Кнопка Вставить имя переменной доступна, если курсор находится в поле Выражение функции по <имя координаты>.

Вставка элементов выражения из коллекции

В выражение функции можно вставить элементы выражения из коллекции (системные функции, выражения функций кривых и т.п.). Для этого нажмите на Панели специального управления кнопку Вставить функцию из коллекции. На экране появляется диалог вставки математического выражения. Выберите нужный элемент выражения или составьте выражение из нескольких элементов и нажмите кнопку ОК диалога. Подробнее о работе в диалоге см. раздел 7.1.3.4.

Кнопка Вставить функцию из коллекции доступна, если курсор находится в поле Выражение функции по <имя координаты>.

Вставка группового закона из коллекции

Вы можете задать для кривой групповой закон из коллекции. В этом случае каждая координата будет определена своей функцией.

Чтобы задать групповой закон, нажмите на Панели специального управления кнопку Групповой закон. На экране появляется диалог вставки математического выражения. Выберите нужный групповой закон из списка и нажмите кнопку ОК диалога. Подробнее о работе в диалоге см. раздел 7.1.3.4.

После вставки группового закона в полях Выражение функции по <имя координаты> появляются функции для соответствующих координат.

Если групповой закон задает функции только для координат X и Y (например, закон эвольвенты окружности), то выражение функции для координаты Z не изменяется — остается умолчательным. Вы можете отредактировать это выражение при необходимости.


2.5.4.12.3. Задание интервального параметра функции

По умолчанию имя интервального параметра функции — t, интервал его изменения — [0.0;1.0]. Вы можете изменить имя параметра функции и границы его интервала. Для этого введите нужные данные в поле Интервальный параметр, а затем нажмите клавишу <Enter>.

Введенные данные будут добавляться в список и сохраняться в течение сеанса работы КОМПАС-3D.

Обратите внимание на то, что имя интервального параметра функции не должно совпадать с именами неинтервальных параметров функции и именами пользовательских переменных модели.

В качестве граничных значений интервала можно использовать численные значения или константы (см. табл. 4 Приложения IV). После ввода константы и нажатия клавиши <Enter> обозначение константы заменяется ее значением.

Если имя параметра функции для текущей координаты совпадает с именем параметра функции для ранее заданной координаты, интервал изменения параметра функции для текущей координаты определяется автоматически — совпадает с ранее заданным интервалом. В этом случае редактирование интервала изменения параметра для текущей координаты недоступно.

Координаты точки кривой можно определить функциями разных параметров. Каждый параметр может иметь свой интервал изменения.

Для задания интервала изменения параметра функции можно использовать имеющуюся интервальную переменную (см. раздел 7.1.5.1.2). Введите ее имя в квадратных скобках после знака равно в правой части поля Интервальный параметр, а затем нажмите клавишу <Enter>. Значение интервальной переменной (границы интервала изменения) присваивается параметру операции. В этом случае редактирование интервала изменения параметра недоступно.

Вы можете также задать интервал изменения параметра функции, создав новую интервальную переменную с нужным значением. Для этого в поле Интервальный параметр выполните следующие действия.

1. В квадратные скобки введите нужный интервал значений (например, [10;-10]).

2. После знака равно в правой части поля введите имя новой интервальной переменной (в квадратных скобках).

3. Нажмите клавишу <Enter>.

После создания кривой имя и значение новой интервальной переменной появятся в Окне переменных в разделе Интервалы.

В дальнейшем изменение значения интервальной переменной в Окне переменных будет передаваться в кривую — кривая будет перестраиваться согласно новому интервалу изменения параметра функции.

При создании кривой по закону автоматически создаются интервальные переменные, значениями которых являются заданные интервалы изменения параметров функций. Они помещаются в раздел переменных созданной кривой (см. рис. 7.1.10).

Вы можете присвоить интервальной переменной параметра операции значение имеющейся пользовательской интервальной переменной. Для этого в Окне переменных в поле Выражение переменной параметра операции введите имя нужной пользовательской переменной. Значение пользовательской переменной будет присвоено переменной параметра операции и передано в модель, т.е. будут изменены границы интервала изменения параметра функции, определяющей координату точки.

Чтобы кривая изменилась соответственно новым границам интервала, требуется перестроить модель.

В дальнейшем при изменении значения пользовательской переменной значение соответствующей переменной параметра операции будет автоматически изменяться.

Работа с переменными подробно описана в разделе 7.1.


2.5.4.12.4. Примеры создания кривых по параметрическим уравнениям

Пример 1

Требуется построить параболу, заданную законом: y = x 2, в диапазоне от -10 до 10.

Параметрическое представление параболы в прямоугольной системе координат:

x = t,

y = t 2,

z = 0.

Для создания параболы рекомендуется следующий порядок действий.

1. Вызовите команду Кривая по закону.

По умолчанию в группе Тип координат активен переключатель Прямоугольные X,Y,Z. Это означает, что кривая строится в прямоугольных координатах.

2. Задайте функцию для координаты X.

2.1. Выберите в списке Функция по X тип функции По выражению.
На Панели свойств появляются два поля: поле для ввода выражения функции и поле для ввода имени параметра функции и интервала его изменения. Поля содержат умолчательные данные: имя t и умолчательный интервал изменения [0;1].

2.2. Введите в поле Интервальный параметр интервал изменения параметра
t = [10;-10]. Нажмите клавишу <Enter>.

3. Задайте функцию для координаты Y.

3.1. Выберите в списке Функция по Y тип функции По выражению.

3.2. Введите в поле Выражение функции по Y выражение функции t^2.

Интервал изменения параметра t определяется автоматически — совпадает с ранее заданным интервалом для координаты X.

3.3. Нажмите клавишу <Enter>.

4. Задайте функцию для координаты Z.

4.1. Выберите в списке Функция по Z тип функции Константа.

4.2. Введите в поле Значение по Z 0.

5. Нажмите кнопку Создать объект на Панели специального управления.

Пример 2

Для расчета, связанного с провисанием троса или провода, требуется построить цепную линию, заданную законом: y = a·ch (x / a) = a / 2 · (e x / a + e - x / a), в диапазоне от -50 до 50 при a = 80.

Параметрическое представление кривой в прямоугольной системе координат:

x = t,

y = a / 2 · (exp t / a + exp- t / a),

z = 0.

Для создания цепной кривой рекомендуется следующий порядок действий.

1. Вызовите команду Кривая по закону.

По умолчанию в группе Тип координат активен переключатель Прямоугольные X,Y,Z. Это означает, что кривая строится в прямоугольных координатах.

2. Задайте функцию для координаты X.

2.1. Выберите в списке Функция по X тип функции Линейный. На Панели свойств появляются поля для ввода начального и конечного значения координаты X.

2.2. Введите в поле Начальное значение по X -50.

2.3. Введите в поле Конечное значение по X 50.

3. Задайте функцию для координаты Y.

3.1. Выберите в списке Функция по Y тип функции По выражению. На Панели свойств появляются два поля: поле для ввода выражения функции и поле для ввода имени параметра функции и интервала его изменения.

3.2. Введите в поле Выражение функции по Y выражение функции
a / 2 *(exp(t/a)+exp(-t/a)).

3.3. Нажмите клавишу <Enter>. На Панели свойств появляется таблица Значение параметров. Параметр a заносится в нее.

3.4. Задайте значение неинтервального параметра a. Для этого активизируйте ячейку таблицы Выражение двойным щелчком мыши и введите 80. Нажмите клавишу <Enter>.

3.5. Введите в поле Интервальный параметр интервал изменения параметра
t = [-50;50]. Нажмите клавишу <Enter>.

4. Задайте функцию для координаты Z.

4.1. Выберите в списке Функция по Z тип функции Константа.

4.2. Введите в поле Значение по Z 0.

5. Нажмите кнопку Создать объект на Панели специального управления.

Пример 3

При проектировании зубчатой передачи необходимо задать профиль зубчатого колеса. Профиль зуба колеса очерчен по эвольвенте окружности.

Параметры колеса:

– модуль колеса m = 3,

– число зубьев колеса z = 20,

– угол профиля a = 20°.

Параметрическое представление эвольвенты в цилиндрической системе координат:

R = Db / cos(t) / 2 (радиус делительной окружности),

A = tg(t) - t (эвольвентный угол),

Z = 0,

где 0 < t < 0,4 (в радианах).

Для создания эвольвенты рекомендуется следующий порядок действий.

1. Создайте переменные в Окне переменных (см. табл. 2.5.10).

Табл. 2.5.10. Переменные для построения эвольвенты
Имя | Выражение | Комментарий
m | 3 | модуль колеса
z | 20 | число зубьев
a | 20 | угол профиля
D | m*z | диаметр делительной окружности
Db | cosd(a)*D | диаметр основной окружности

2. Вызовите команду Кривая по закону.

3. Выберите тип координат кривой. Для этого в группе Тип координат на Панели свойств активизируйте переключатель Цилиндрические R,A,Z.

4. Задайте функцию для координаты R.

4.1. Выберите в списке Функция по R тип функции По выражению.
На Панели свойств появляются два поля: поле для ввода выражения функции и поле для ввода имени параметра функции и интервала его изменения.

4.2. Введите в поле Выражение функции по R выражение функции Db / cos(t) / 2.

4.3. Нажмите клавишу <Enter>. На Панели свойств появляется таблица Значение параметров. В таблицу передаются выражение и значение переменной Db из Окна переменных.

4.4. Введите в поле Интервальный параметр интервал изменения параметра
t = [0;0,4]. Нажмите клавишу <Enter>.

5. Задайте функцию для координаты A.

5.1. Выберите в списке Функция по A тип функции По выражению.

5.2. Введите в поле Выражение функции по A выражение функции tan(t)-t.

Интервал изменения параметра t определяется автоматически — совпадает с ранее заданным интервалом для координаты R.

5.3. Нажмите клавишу <Enter>.

6. Задайте функцию для координаты Z.

6.1. Выберите в списке Функция по Z тип функции Константа.

6.2. Введите в поле Значение по Z 0.

7. Нажмите кнопку Создать объект на Панели специального управления.

Ввод переменных в Окне переменных в общем случае не обязателен. В данном примере это сделано с целью упрощения выражения для координаты R.


2.5.4.13. Скругление кривых

Вы можете скруглить угол, образованный двумя кривыми. В зависимости от взаимного расположения кривых, скругление выполняется дугой окружности определенного радиуса или сплайном, лежащим на цилиндрической поверхности определенного радиуса. В качестве исходных кривых могут использоваться пространственные кривые, ребра тел и поверхностей, линии эскиза.

Параллельные отрезки, а также концентрические дуги скруглить нельзя.

Чтобы скруглить две кривые, вызовите команду Скругление кривых.

На Панели свойств появятся элементы управления скруглением кривых (рис. 2.5.33).

Рис. 2.5.33. Панель свойств при скруглении двух кривых

Укажите исходные кривые в окне модели. Наименования выбранных объектов отображаются в полях Кривая 1 и Кривая 2.

Исходные кривые следует указывать в точках, близких к предполагаемому месту сопряжения.

После выбора исходных кривых на экране появляется фантом скругления — дуга окружности с характерной точкой или цилиндр с характерной точкой и сплайн.

Кривая скругления строится так, чтобы точки касания ее с исходными кривыми находились вблизи точек указания. Радиус скругления кривых определяется автоматически и его значение отображается в поле Радиус. Вы можете задать нужный радиус скругления следующими способами:

– ввести значение радиуса в поле Радиус или установить с помощью счетчика;

– «перетащить» мышью характерную точку.

Изменение радиуса отображается на фантоме скругления в окне модели.

По умолчанию включено усечение исходных кривых. В этом случае для исходной кривой создается копия. Копия кривой усекается в точке касания ее с кривой скругления. Вы можете отключить усечение. При этом создается только кривая скругления.

Если предложенный системой вариант усечения кривых отличается от ожидаемого, отключите усечение, а для удаления частей кривых воспользуйтесь командой Усечение кривой (см. раздел 2.5.4.16).

Переключатели группы Дуга позволяют выбрать нужное направление скругления.

Если в качестве исходных кривых указаны ребра одной грани, то вы можете расположить их скругление на этой же грани. Для этого включите опцию По поверхности.

Скругление других кривых, лежащих на грани, можно расположить на ней только в том случае, если кривые являются непосредственно производными по отношению к объекту, содержащему грань (о просмотре отношений объектов см. раздел 2.1.2.7.2).

Чтобы сменить исходные кривые, нажмите кнопку Указать заново на Панели специального управления и повторите выбор объектов.

Элементы управления, расположенные на вкладке Свойства Панели свойств, позволяют изменить название и цвет скругления, настроить параметры его отображения (о параметрах отображения см. раздел 2.5.4.1).

Чтобы завершить построение, нажмите кнопку Создать объект на Панели специального управления.

В окне модели появляется кривая сопряжения, а в Дереве построения — ее пиктограмма.

– Если исходные кривые скруглялись с усечением, то ветвь Дерева построения, соответствующая данному скруглению кривых, имеет подчиненные объекты — кривую скругления и усеченные кривые (рис. 2.5.34, а).

– Если исходные кривые скруглялись без усечения, то ветвь Дерева построения, соответствующая данному скруглению кривых, имеет только один подчиненный объект — кривую скругления (рис. 2.5.34, б).

Рис. 2.5.34. Отображение скругления пары кривых в Дереве построения: а) скругление с усечением; б) скругление без усечения
а) | б)

Если после указания исходных кривых на экране не появляется фантом скругления, это означает, что выбранные кривые нельзя скруглить вблизи точек указания. Измените радиус скругления. Если при изменении радиуса фантом скругления не появляется на экране, укажите исходные кривые заново в других точках.


2.5.4.14. Соединение кривых

Вы можете соединить вершины двух кривых или начальную и конечную вершины одной кривой соединительной кривой. В качестве исходных кривых могут использоваться:

– пространственные кривые;

– ребра тел и поверхностей;

– контуры в эскизе.

В точке соединения исходной и соединительной кривых могут быть заданы следующие условия сопряжения: не задано, по касательной, перпендикулярно и гладкое (см. раздел 6 Приложения IX).

Существует возможность изменения формы соединительной кривой с помощью параметра натяжения.

Чтобы соединить две кривые, вызовите команду Соединение кривых.

На Панели свойств появятся элементы управления соединением кривых (рис. 2.5.35).

Рис. 2.5.35. Панель свойств при соединении двух кривых

Укажите исходные кривые в окне модели.

Исходную кривую следует указывать в точке, близкой к той вершине, в которой предполагается соединение с другой кривой.

Если в качестве исходной кривой используется пространственная кривая, то ее можно указать в Дереве построения. В этом случае точкой соединения автоматически выбирается начальная вершина кривой.

Исходные кривые могут быть выделены и перед вызовом команды.

Для соединения концов одной и той же кривой следует указать ее в окне модели дважды — у начальной и конечной вершины.

По умолчанию включено автосоздание объектов (см. раздел 1.4.2.10). В этом случае вершины кривых (или кривой) соединяются сразу после их указания. Соединение выполняется с умолчательными параметрами:

– условие сопряжения исходной и соединительной кривых в обеих точках соединения — по касательной;

– натяжение соединительной кривой равно 50%.

В окне модели появляется соединительная кривая, а в Дереве построения — ее пиктограмма. Обозначения условий сопряжения отображаются около вершин соединительной кривой.

Вы можете управлять параметрами соединительной кривой во время ее создания. Для этого после вызова команды Соединение кривых отключите режим автосоздания объектов (отожмите кнопку Автосоздание объекта на Панели специального управления). Затем укажите исходные кривые. На экране появляется фантом соединительной кривой с умолчательными параметрами.

Выберите нужное условие сопряжения для соединительной и исходной кривых. Для этого раскройте список Условие 1 (или Условие 2) на Панели свойств и укажите в нем нужную строку.

Задайте нужную форму соединительной кривой (см. раздел 2.5.4.14.1).

При необходимости вы можете сменить вершину сопряжения исходной кривой (см. раздел 2.5.4.14.2).

Все изменения отображаются на фантоме соединительной кривой в окне модели.

Чтобы сменить исходные кривые, нажмите кнопку Указать заново на Панели специального управления и повторите выбор объектов.

Элементы управления, расположенные на вкладке Свойства Панели свойств, позволяют изменить название и цвет соединительной кривой, настроить параметры ее отображения (о параметрах отображения см. раздел 2.5.4.1).

Чтобы завершить создание соединительной кривой, нажмите кнопку Создать объект на Панели специального управления.

В этом разделе:

2.5.4.14.1. Задание натяжения соединительной кривой

2.5.4.14.2. Смена вершины сопряжения исходной кривой


2.5.4.14.1. Задание натяжения соединительной кривой

Вы можете изменить форму соединительной кривой с помощью параметра натяжения. Величина данного параметра задается в процентах от 0 до 100.

– Чем меньше параметр натяжения, тем меньше кривизна соединительной кривой в точке соединения — кривая более пологая вблизи точек соединения.

– Чем больше параметр натяжения, тем больше кривизна соединительной кривой в точке соединения — кривая более пологая в ее средней части.

В поле Натяжение% на Панели свойств введите нужное значение натяжения или установите с помощью счетчика.


2.5.4.14.2. Смена вершины сопряжения исходной кривой

При необходимости вы можете сменить вершину сопряжения исходной кривой. Для этого служит группа переключателей Начальная/ конечная вершина 1 (или Начальная/ конечная вершина 2). В группе, соответствующей исходной кривой, активизируйте нужный переключатель.


2.5.4.15. Кривая по двум проекциям

Вы можете построить кривую на основе двух эскизов, расположенных в непараллельных плоскостях. Линии в эскизах считаются ортогональными проекциями создаваемой кривой на плоскости этих эскизов. Поэтому кривая создается как кривая пересечения двух поверхностей, образованных перемещением заданных проекций в направлениях, перпендикулярных их плоскостям (см. рис. 2.5.36).

Рис. 2.5.36. Построение кривой по двум проекциям

Чтобы построить кривую по двум ее проекциям, вызовите команду Кривая по двум проекциям.

Укажите в окне модели первую проекцию — эскиз или отдельные линии в нем.

Эскиз можно указать в Дереве построения или в окне модели. В последнем случае необходимо предварительно включить фильтр эскизов при помощи команды контекстного меню Фильтровать эскизы (о фильтрах объектов см. раздел 2.1.4.1.3). Обратите внимание на то, что этот фильтр действует только в процессе создания кривой по двум проекциям.

Линии первой проекции могут быть выделены и перед вызовом команды.

Название объекта или количество объектов отображается в поле Проекция 1 на Панели свойств.

О выборе объектов подробно рассказано в разделе 2.1.4.1.1.

Укажите вторую проекцию — эскиз или отдельные линии в нем. Название объекта или количество объектов отображается в поле Проекция 2.

На экране появляется фантом создаваемой кривой.

Отсутствие фантома — признак невозможности существования кривой при выбранных исходных объектах.

Повторное указание объекта отменяет его выбор.

Все изменения отображаются на фантоме кривой.

Создаваемая кривая может состоять из одного или нескольких контуров. Выберите нужные контуры для построения (см. раздел 2.5.4.15.1).

Чтобы сменить объекты проекций, нажмите кнопку Указать заново на Панели специального управления и повторите выбор объектов.

Элементы управления, расположенные на вкладке Свойства Панели свойств, позволяют изменить название и цвет кривой, настроить параметры ее отображения (о параметрах отображения см. раздел 2.5.4.1).

Чтобы завершить построение кривой по двум проекциям, нажмите кнопку Создать объект на Панели специального управления.

В окне модели появляется кривая по двум проекциям, а в Дереве построения — пиктограмма пересечения.

В этом разделе:

2.5.4.15.1. Выбор контуров для построения кривой


2.5.4.15.1. Выбор контуров для построения кривой

Создаваемая кривая может состоять из одного или нескольких контуров.

Опция Все контуры на Панели свойств позволяет выбрать нужные контуры для построения. По умолчанию опция включена. Это означает, что будут созданы все полученные контуры.

Если требуется оставить не все, а лишь некоторые контуры, отключите опцию Все контуры. На Панели свойств появится панель Список контуров, содержащая перечень контуров. Слева от названий контуров отображаются опции. По умолчанию все опции включены. При выделении контура в списке он подсвечивается в окне модели. Отключите опции тех контуров, которые не должны быть созданы.

Если нужно оставить или исключить большинство контуров, воспользуйтесь кнопками Включить все и Выключить все, расположенными над списком.


2.5.4.16. Усечение кривой

Вы можете создать усеченную копию кривой.

В качестве исходной кривой может использоваться незамкнутая кривая: пространственная кривая (или ее сегмент), линия эскиза, ребро.

В качестве секущего объекта может использоваться:

– любой точечный объект, лежащий на усекаемой кривой (точка начала координат, точка в пространстве, вершины линий эскизов, отдельные точки в эскизах, вершины пространственных кривых, вершины ребер и т.п.);

– объект, пересекающийся с исходной кривой:

• координатная или вспомогательная плоскость;

• координатная или вспомогательная ось;

• пространственная кривая;

• ребро;

• грань;

• линия эскиза.

Исходная кривая и секущий объект должны иметь общую точку, не совпадающую с вершиной исходной кривой.

Чтобы создать усеченную кривую, вызовите команду Усечение кривой.

На Панели свойств появятся элементы управления усечением кривой (рис. 2.5.37).

Рис. 2.5.37. Панель свойств при усечении кривой

Укажите исходную кривую в окне модели. Пространственную кривую можно выбрать в Дереве построения.

Исходную кривую можно указать и перед вызовом команды.

Укажите секущий объект в окне модели или в Дереве построения.

После выбора исходной кривой и секущего объекта создается копия исходной кривой, которая разбивается точкой пересечения на две части. Та часть копии, которая не содержит точку указания исходной кривой, отображается на экране в виде фантома. Фантом показывает результат усечения исходной кривой. Он ограничен двумя точками: точкой пересечения и концевой точкой исходной кривой (рис. 2.5.38).

Рис. 2.5.38. Фантом усеченной кривой

Точка касания копии исходной кривой и секущего объекта считается точкой пересечения.

Переключатель Сменить направление позволяет выбрать для удаления другую часть кривой — противоположную по отношению к точке пересечения.

Сменить направление усечения можно, указав в окне модели любую из концевых точек исходной кривой.

Если исходная кривая и секущий объект имеют несколько общих точек, на экране появляются фантом усеченной кривой и точки пересечения выбранных объектов. В этом случае фантом усеченной кривой ограничен первой точкой пересечения 1 и концевой точкой исходной кривой 2. Вы можете выбрать другие точки 1 и 2, ограничивающие фантом.

– Чтобы задать новую позицию точки 1, укажите нужную точку пересечения в окне модели (рис. 2.5.39).

Рис. 2.5.39. Изменение положения точки 1: а) выбор точки пересечения; б) результат
а) | б)

– Чтобы задать новую позицию точки 2, укажите нужную точку пересечения, удерживая нажатой клавишу <Ctrl> (рис. 2.5.40).

Рис. 2.5.40. Изменение положения точки 2: а) выбор точки пересечения; б) результат
а) | б)

Чтобы сменить исходную кривую и секущий объект, нажмите кнопку Указать заново на Панели специального управления и повторите выбор объектов.

Элементы управления, расположенные на вкладке Свойства Панели свойств, позволяют изменить название и цвет усеченной кривой, настроить параметры ее отображения (о параметрах отображения см. раздел 2.5.4.1).

Чтобы завершить создание усеченной кривой, нажмите кнопку Создать объект на Панели специального управления.

В окне модели появляется усеченная копия исходной кривой, а в Дереве построения — пиктограмма усечения.

Пространственная кривая после усечения автоматически скрывается.

Существует возможность усечения исходной кривой двумя секущими объектами (см. раздел 2.5.4.16.1).

В этом разделе:

2.5.4.16.1. Усечение кривой двумя объектами


2.5.4.16.1. Усечение кривой двумя объектами

Вы можете создать копию кривой, усеченную двумя объектами. Для этого включите опцию Два секущих объекта. На Панели свойств появляется переключатель Секущий объект 2, переключатель Сменить направление исчезает (рис. 2.5.41).

Рис. 2.5.41. Панель свойств при усечении кривой двумя объектами

Укажите исходную кривую и секущие объекты в окне модели или в Дереве построения. На экране появляется фантом усеченной кривой, который ограничен точками пересечения исходной кривой с секущими объектами 1 и 2 (рис. 2.5.42).

Рис. 2.5.42. Фантом усеченной кривой, ограниченный точками пересечения
исходной кривой с секущими объектами

Если секущие объекты имеют несколько точек пересечения с исходной кривой, то эти точки отображаются различными цветами. Граничные точки фантома усеченной кривой имеют фиолетовый цвет. Все остальные точки пересечения первого объекта отображаются желтым цветом, а второго — серым (рис. 2.5.43, а).

Вы можете изменить позиции точек начала и конца усечения, указав нужные точки пересечения объектов. Чтобы указать точку, принадлежащую первому секущему объекту (точка желтого цвета), щелкните по ней мышью. Точки второго секущего объекта (точки серого цвета) можно указывать, удерживая клавишу <Ctrl>. При нажатой клавише <Ctrl> точки второго объекта меняют цвет на желтый, а первого — на серый (рис. 2.5.43, б).

Рис. 2.5.43. Фантом кривой, усеченной двумя объектами: а) без нажатия клавиши <Ctrl>; б) c нажатием клавиши <Ctrl>
а) | б)

Обратите внимание на то, что фантом усеченной кривой всегда ограничен точками разных секущих объектов.


2.5.4.17. Эквидистанта кривой

Вы можете построить кривую, эквидистантную базовой.

В качестве базовой кривой может использоваться:

– пространственная кривая,

– ребро,

– линия эскиза,

– цепочка вышеперечисленных объектов в любом сочетании.

Для создания эквидистантной кривой вызовите команду Эквидистанта кривой.

Укажите в окне модели базовую кривую.

Базовую кривую можно указать и перед вызовом команды.

На экране появляется фантом эквидистантной кривой с умолчательными параметрами. Начальная вершина базовой кривой отмечена стрелкой.

– Повторное указание кривой отменяет ее выбор.

– Повторное указание одной кривой из совокупности отменяет ее выбор, а также выбор всех следующих за ней кривых в направлении конечной вершины.

О выборе объектов подробно рассказано в разделе 2.1.4.1.1.

Название выбранного объекта или количество выбранных объектов отображается в поле рядом с переключателем Кривая.

Эквидистантную кривую можно построить двумя способами:

– Смещением по направлению от вершины (см. раздел 2.5.4.17.1);

– Смещением вдоль поверхности (см. раздел 2.5.4.17.2).

Выберите способ построения эквидистантной кривой из раскрывающегося списка Способ на Панели свойств.

Затем задайте объекты и параметры для построения эквидистантной кривой.

Все изменения отображаются на фантоме создаваемой кривой в окне модели.

Чтобы сменить объекты, используемые для построения эквидистантной кривой выбранным способом, нажмите кнопку Указать заново на Панели специального управления и повторите выбор объектов.

Элементы управления, расположенные на вкладке Свойства Панели свойств, позволяют изменить название и цвет кривой, настроить параметры ее отображения (о параметрах отображения см. раздел 2.5.4.1).

Чтобы завершить построение, нажмите кнопку Создать объект на Панели специального управления.

В окне модели появляется эквидистантная кривая, а в Дереве построения — ее пиктограмма.

При нулевом смещении эквидистантная кривая представляет собой копию базовой.

Данная копия является единым объектом, даже если в качестве базовой кривой указана совокупность кривых.

В этом разделе:

2.5.4.17.1. Построение смещением по направлению от вершины

2.5.4.17.2. Построение смещением вдоль поверхности


2.5.4.17.1. Построение смещением по направлению от вершины

Данный способ позволяет задать положение эквидистантной кривой смещением ее начальной (конечной) вершины относительно соответствующей вершины базовой кривой. Смещение выполняется в плоскости смещения в направлении вектора смещения.

Рис. 2.5.44. Построение эквидистантной кривой способом
Смещение по направлению от вершины

Плоскость смещения — это плоскость, перпендикулярная базовой кривой в ее начальной или конечной вершине.

Направление вектора смещения задается с помощью направляющих объектов.

Направляющими объектами могут служить следующие объекты в модели.

– Точечные объекты.

Направление, задаваемое точечным объектом — проекция прямой, проходящей через этот точечный объект и начальную или конечную вершину базовой кривой, на плоскость смещения.

– Прямолинейные объекты.

Направление, задаваемое прямолинейным объектом — проекция объекта на плоскость смещения.

– Плоские объекты.

Направление, задаваемое плоским объектом — проекция прямой, перпендикулярной объекту, на плоскость смещения.

Точечные, прямолинейные и плоские объекты перечислены в таблице 2.1.7.

Кроме того, направляющим объектом может служить вектор (см. раздел 2.8.5).

Чтобы построить эквидистанту, выполните следующие действия.

1. Укажите базовую кривую (см. раздел 2.5.4.17).

После этого автоматически определяется направляющий объект — это одна из координатных осей текущей системы координат. Наименование этой оси отображается в поле рядом с переключателем Направление на Панели свойств.

При необходимости вы можете сменить направляющий объект. Для этого активизируйте переключатель Направление, а затем укажите нужный направляющий объект в Дереве построения или в окне модели или постройте вектор.

Наименование выбранного объекта отображается в поле рядом с переключателем Направление. Если направление задано вектором, то в этом поле отображается слово «Вектор».

Полученное направление считается умолчательным — начальным.

В модели появляется фантом эквидистанты, вершина которой удалена от базовой кривой в начальном направлении на умолчательное расстояние.

2. Задайте параметры смещения любым способом.

– Вручную

В поле Угол на Панели свойств введите значение угла поворота вектора смещения в плоскости смещения. Угол отсчитывается от начального направления.

В поле Расстояние введите расстояние в плоскости смещения от базовой кривой до создаваемой.

Величину угла поворота и расстояние можно задать также с помощью характерных точек (см. раздел 2.1.4.2.2).

– Указанием точки

Нажмите кнопку Объект на Панели свойств. Затем укажите точечный объект.

В полях Угол и Расстояние отображаются значения, определяющие положение начальной (конечной) точки эквидистанты. Угол отсчитывается от начального направления.

• Если опция Ассоциировать включена, то указание точечного объекта приводит к формированию ассоциативной связи начальной (конечной) точки эквидистанты с этим объектом.

Признаком наличия связи является отображение «галочки» на кнопке Объект и наименования точечного объекта в поле Объект на Панели свойств. Поля Угол и Расстояние в этом случае недоступны для редактирования.

Благодаря ассоциативной связи вновь созданная эквидистанта будет изменять свою форму при перемещении точки в пространстве.

Чтобы отменить ассоциативную связь с точечным объектом, следует нажать кнопку Объект. «Галочка» на кнопке исчезнет.

• Если опция выключена, то при указании точечного объекта создается эквидистанта без ассоциативной связи с объектом. «Галочка» на кнопке Объект и имя объекта не отображаются, а поля Угол и Расстояние доступны для редактирования.

Для восстановления ассоциативной связи эквидистанты с точечным объектом необходимо включить опцию Ассоциировать, нажать кнопку Объект и указать нужный объект заново.

3. Задайте остальные параметры.

– Группа переключателей Обход углов позволяет выбрать способ стыковки сегментов эквидистантной кривой (рис. 2.5.45).

Рис. 2.5.45. Способы обхода углов: а) обход скруглением; б) обход срезом
а) | б)

– Кнопка Сохранять радиусы управляет построением эквидистанты по участкам базовой кривой, сопряженным дугами окружностей (например, радиусы в вершинах ломаной).

Если кнопка не нажата, то на этих участках строится эквидистанта, радиусы которой будут отличаться от радиусов базовой кривой. Величина их вычисляется автоматически (рис. 2.5.46, а).

Если кнопка нажата, то радиусы эквидистанты будут такими же, как радиусы соответствующих дуговых участков базовой кривой (рис. 2.5.46, б).

Рис. 2.5.46. Скругление сегментов эквидистантной кривой: а) без сохранения радиусов; б) с сохранением радиусов
а) | б)

– Группа переключателей Начальная/Конечная вершина позволяет сменить вершину базовой кривой, через которую проходит плоскость смещения.


2.5.4.17.2. Построение смещением вдоль поверхности

Данный способ позволяет задать положение эквидистантной кривой смещением ее вдоль теоретической поверхности указанной грани на заданное расстояние от базовой кривой (о теоретической поверхности см. раздел 2 Приложения IX). Базовая кривая должна принадлежать выбранной грани.

Рекомендуется в качестве базовой кривой указывать кривую, которая является исходным или производным объектом выбранной поверхности.

Пример использования исходного объекта: кривая, построенная эквидистантно кривой, используемой при построении поверхности по сети кривых (см. раздел 2.6.1.8) или линейчатой поверхности (см. раздел 2.6.1.9).

Пример использования производного объекта: кривая, построенная эквидистантно кривой пересечения поверхностей.

Расстояние между эквидистантной и базовой кривыми измеряется не по теоретической поверхности грани, а по прямой (рис. 2.5.47).

Рис. 2.5.47. Эквидистантная кривая, построенная способом Смещение вдоль поверхности

Укажите грань для построения эквидистантной кривой.

Указанная грань подсвечивается в окне модели, а ее название отображается в поле рядом с переключателем Поверхность.

Задайте расстояние от базовой кривой до создаваемой, введя его в поле Расстояние.

Значение расстояния вы можете задать с помощью характерной точки (см. раздел 2.1.4.2.2).


2.5.4.18. Изопараметрическая кривая

Вы можете построить изопараметрическую кривую теоретической поверхности указанной грани, проходящую через заданную точку этой грани.

Общие сведения о теоретической поверхности грани и изопараметрических кривых приведены в разделе 2 Приложения IX.

Положение точки на грани можно задать двумя способами:

– заданием параметров U и V точки на теоретической поверхности грани,

– указанием точечного объекта, лежащего на указанной грани и находящегося в ее пределах; в качестве точечного объекта может использоваться:

• вершина объекта (или точка в пространстве) при условии, что этот объект (или точка) является непосредственно исходным или непосредственно производным по отношению к объекту, содержащему указанную грань1,

• вершина ребра грани.

Чтобы построить изопараметрическую кривую, выполните следующие действия.

1. Вызовите команду Изопараметрическая кривая.

2. Укажите в окне модели нужную грань.

Базовую грань для построения изопараметрической кривой можно указать и перед вызовом команды.

Указанная грань подсвечивается. На выбранной грани появляются: фантом точки указания грани и фантомы изопараметрических кривых U и V, проходящие через эту точку. В поле Поверхность Панели свойств отображается наименование выбранной грани. В полях ввода Параметр U, % и Параметр V, % отображаются значения параметров U и V в точке указания грани. Направление отсчета значений показано стрелками из точки начала U=0, V=0.

3. Задайте положение точки, через которую должна проходить изопараметрическая кривая. Это можно сделать следующими способами.

Способ 1

Введите в поля Параметр U, % и Параметр V, % нужные значения параметров U и V в процентах (от 0 до 100) или задайте их счетчиком. Изменение значений параметров точки отображается на ее фантоме в окне модели. Также положение точки можно изменить, перемещая мышью ее характерную точку (см. раздел 2.1.4.2.2).

Способ 2

Укажите в Дереве построения или в окне модели нужный точечный объект.

На кнопке Объект отображается «галочка», а в поле рядом с кнопкой — название объекта. Это свидетельствует о наличии ассоциативной связи точки, через которую должна проходить кривая, с выбранным объектом. Благодаря этой связи построенная кривая будет следовать за объектом при изменении его положения. При необходимости связь можно отменить, нажав кнопку Объект. «Галочка» на кнопке исчезнет, поле очистится.

О выборе объектов подробно рассказано в разделе 2.1.4.1.1.

4. Выберите для построения одну из двух кривых.

По умолчанию строится изопараметрическая кривая направления U — ее фантом активный. При этом в группе переключателей Выбор по направлению на Панели свойств активен переключатель Кривая по направлению U.

Чтобы построить изопараметрическую кривую направления V, активизируйте переключатель Кривая по направлению V. Фантом кривой направления V становится активным.

5. При необходимости используйте следующие возможности:

– Отмена сразу всех объектов, заданных для построения кривой. Для этого нажмите кнопку Указать заново на Панели специального управления.

– Изменение наименования и цвета создаваемой кривой. Для этого активизируйте вкладку Свойства Панели свойств. Также на этой вкладке можно настроить параметры отображения кривой (о параметрах отображения см. раздел 2.5.4.1).

6. Нажмите кнопку Создать объект на Панели специального управления.

В окне модели появляется изопараметрическая кривая, а в Дереве построения — ее пиктограмма. После завершения построения первой кривой система ожидает указания объектов для создания следующей кривой.

  1. Т.е. в иерархии отношений между объектом, содержащим вершину (или точку), и объектом, содержащим указанную грань, не должно быть других объектов (о просмотре отношений объектов см. раздел 2.1.2.7.2).


2.5.4.19. Группа изопараметрических кривых на поверхности

Вы можете построить группу изопараметрических кривых на теоретической поверхности указанной грани. Количества кривых каждого направления (U и V) в группе задаются пользователем и могут быть различными.

Общие сведения о теоретической поверхности грани и изопараметрических кривых приведены в разделе 2 Приложения IX.

Для создания группы изопараметрических кривых, вызовите команду Группа изопараметрических кривых на поверхности.

Укажите в окне модели нужную грань.

Базовую грань для построения группы изопараметрических кривых можно указать и перед вызовом команды.

Указанная грань подсвечивается. На ней появляются фантомы изопараметрических кривых направления U и V. Стрелками показаны направления влияния параметров U и V в точке начала U=0, V=0. В поле Поверхность Панели свойств отображается наименование выбранной грани.

Введите нужное количество кривых каждого направления в поля Количество, U и Количество, V на Панели свойств.

В поле Количество, U (Количество, V) вводится количество кривых по направлению параметра поверхности U(V). Это кривые направления V(U), расположенные с равным шагом по параметру U(V).

Группа переключателей Границы управляет построением граничных кривых, соответствующих границам теоретической поверхности грани. По умолчанию в этой группе активен переключатель Оставить границы. Это означает, что группа кривых будет создаваться с граничными кривыми.

Если требуется создать группу без граничных кривых, то активизируйте переключатель Удалить границы.

Опция Рассыпать управляет результатом построения группы кривых.

– Если опция отключена, то после завершения команды кривые будут отображаться в Дереве построения как объекты, подчиненные группе.

– Если опция включена, то после завершения команды кривые не будут объединены в группу — каждая кривая будет отображаться в Дереве построения как самостоятельный объект.

Чтобы сменить грань, используемую для построения группы кривых, нажмите кнопку Указать заново на Панели специального управления и повторите выбор грани.

Название, цвет и параметры отображения кривых группы можно изменить на вкладке Свойства Панели свойств (о параметрах отображения см. раздел 2.5.4.1).

Чтобы завершить построение группы изопараметрических кривых, нажмите кнопку Создать объект на Панели специального управления.

В окне модели появляются изопараметрические кривые, а в Дереве построения — группа изопараметрических кривых или набор отдельных изопараметрических кривых (если была включена опция Рассыпать).

Чтобы развернуть список кривых группы, щелкните мышью на значке «плюс», расположенном слева от пиктограммы группы в Дереве построения.

Сначала в Дереве построения располагаются изопараметрические кривые направления V, разбивающие грань по направлению U, а затем — изопараметрические кривые направления U, разбивающие грань по направлению V.

Обратите внимание на то, что опция Рассыпать присутствует на Панели свойств только при создании группы кривых. Если уже созданную группу кривых требуется преобразовать в набор отдельных кривых, то вы можете разрушить эту группу. Разрушение группы выполняется аналогично разрушению массива объектов (см. раздел 2.7.1.3.7). После разрушения группы каждая кривая отображается в Дереве построения как самостоятельный объект — изопараметрическая кривая.


2.5.4.20. Линия очерка

Вы можете построить линию очерка грани — линию, в точках которой нормаль грани перпендикулярна заданному направлению взгляда.

Ребра грани не включаются в линию очерка.

Построение линии очерка невозможно, если грань плоская или нормаль грани в каждой ее точке перпендикулярна направлению взгляда.

Линию очерка можно построить для набора граней (см. рис 2.5.48).

Рис. 2.5.48. Линия очерка: а) одной грани; б) набора граней
а) | б)

Чтобы построить линию очерка грани, выполните следующие действия.

1. Вызовите команду Линия очерка.

2. После вызова команды автоматически на Панели свойств активизируется переключатель Поверхность. Укажите в окне модели нужную грань или набор граней.

Если требуется построить линию очерка для всех граней тела или поверхности, укажите это тело или поверхность в Дереве построения.

Исходные объекты могут быть выделены и перед вызовом команды.

Указанные объекты подсвечиваются. Название выбранного объекта или количество выбранных объектов отображается в поле Поверхность на Панели свойств.

Повторное указание грани отменяет ее выбор.

О выборе объектов подробно рассказано в разделе 2.1.4.1.1.

На экране появляется фантом линии очерка. По умолчанию линия очерка строится в направлении взгляда, перпендикулярном плоскости экрана.

3. Если требуется зафиксировать линию очерка в той форме, которая соответствует текущему положению модели, включите опцию Фиксировать положение. При отключенной опции линия очерка перестраивается всякий раз после изменения ориентации модели.

4. Выберите направляющий объект или создайте вектор, если требуется задать направление взгляда (см. раздел 2.5.4.20.1).

После задания направления взгляда фантом линии очерка перестраивается.

5. Линия очерка может состоять из одного или нескольких участков — контуров. Выберите нужные контуры для построения линии очерка (см. раздел 2.5.4.15.1).

6. При необходимости используйте следующие возможности:

– Отмена сразу всех объектов, заданных для построения кривой. Для этого нажмите кнопку Указать заново на Панели специального управления.

– Изменение наименования и цвета создаваемой кривой. Для этого активизируйте вкладку Свойства Панели свойств. Также на этой вкладке можно настроить параметры отображения кривой (о параметрах отображения см. раздел 2.5.4.1).

7. Нажмите кнопку Создать объект на Панели специального управления.

В окне модели появляется линия очерка, а в Дереве построения — ее пиктограмма.

В этом разделе:

2.5.4.20.1. Задание направления взгляда при построении линии очерка


2.5.4.20.1. Задание направления взгляда при построении линии очерка

По умолчанию линия очерка строится в направлении взгляда, перпендикулярном плоскости экрана. Вы можете задать направление взгляда с помощью направляющего объекта или вектора.

В качестве направляющего объекта может использоваться любой прямолинейный или плоский объект. Прямолинейные и плоские объекты перечислены в таблице 2.1.7.

Направление, задаваемое прямолинейным объектом — прямая, параллельная объекту.

Направление, задаваемое плоским объектом — прямая, перпендикулярная объекту.

Активизируйте переключатель Направление взгляда, а затем в Дереве построения или в окне модели укажите объект, определяющий направление взгляда.

Повторное указание объекта отменяет его выбор, а направление взгляда становится умолчательным — перпендикулярным плоскости экрана.

Чтобы создать вектор, определяющий направление взгляда, нажмите кнопку Построение вектора на Панели специального управления (см. раздел 2.8.5).

Наименование выбранного объекта отображается в поле Направление взгляда. Если направление задано вектором, то в поле отображается слово «Вектор».


2.5.4.21. Сплайн на поверхности

Вы можете построить сплайн, лежащий на теоретической поверхности указанной грани. При необходимости теоретическая поверхность грани продлевается.

Общие сведения о теоретической поверхности грани приведены в разделе 2 Приложения IX.

Вершина сплайна может быть построена двумя способами:

– заданием параметров U и V;

– указанием точечного объекта, лежащего на указанной грани и находящегося в ее пределах; в качестве точечного объекта может использоваться:

• вершина объекта (или точка в пространстве) при условии, что этот объект (или точка) является непосредственно исходным или непосредственно производным по отношению к объекту, содержащему указанную грань1,

• вершина ребра грани.

Чтобы построить сплайн на поверхности, выполните следующие действия.

1. Вызовите команду Сплайн на поверхности.

2. Укажите в окне модели грань, на которой будет располагаться сплайн.

Базовую грань для построения сплайна можно указать и перед вызовом команды.

Указанная грань подсвечивается. Название выбранного объекта отображается в поле Поверхность на Панели свойств.

О выборе объектов подробно рассказано в разделе 2.1.4.1.1.

3. Задайте вершины сплайна. Это можно сделать следующими способами.

Способ 1

Укажите положение вершины на грани щелчком мыши или введите в поля Параметр U, % и Параметр V, % нужные значения параметров U и V в процентах (от 0 до 100).

Способ 2

Укажите в Дереве построения или в окне модели нужный точечный объект.

На кнопке Объект отображается «галочка», а в поле рядом с кнопкой — название объекта. Это свидетельствует о наличии ассоциативной связи вершины сплайна с выбранным объектом. Благодаря этой связи построенная кривая будет следовать за объектом при изменении его положения. При необходимости связь можно отменить, нажав кнопку Объект. «Галочка» на кнопке исчезнет, поле очистится.

О выборе объектов подробно рассказано в разделе 2.1.4.1.1.

Каждая вершина сплайна характеризуется набором параметров, которые отображаются в таблице параметров вершин. С помощью элементов управления над таблицей и команд контекстного меню таблицы вы можете изменять параметры существующих вершин или создавать новые вершины (см. раздел 2.5.4.21.1).

Сплайн с текущими параметрами отображается на экране в виде фантома.

4. Выберите вариант построения кривой — разомкнутая или замкнутая. Для этого в группе Режим активизируйте нужный переключатель: Разомкнутая кривая или Замкнутая кривая.

5. Выберите тип сплайна. Для этого в группе Тип активизируйте нужный переключатель: Сплайн по точкам или Сплайн по полюсам (подробнее о типах сплайна см. раздел 2.5.4.9.1).

6. При необходимости используйте следующие возможности:

– Изменение положения уже заданных вершин и управление формой сплайна в вершинах. Для этого выделите в таблице параметров строку с номером нужной вершины. Система переходит в режим редактирования сплайна (о редактировании сплайна см. раздел 2.5.4.21.2). В этом режиме можно также удалять вершины сплайна. Чтобы перейти в режим построения сплайна, выделите последнюю (ненумерованную) строку таблицы. Кроме того, вы можете переключаться между режимами построения и редактирования сплайна при помощи команды контекстного меню Завершить/Продолжить ввод вершин.

– Смена грани для построения кривой. Для этого нажмите кнопку Указать заново на Панели специального управления, а затем укажите другую грань и вершины сплайна.

– Изменение наименования и цвета создаваемой кривой. Для этого активизируйте вкладку Свойства Панели свойств. Также на этой вкладке можно настроить параметры отображения кривой (о параметрах отображения см. раздел 2.5.4.1).

7. Нажмите кнопку Создать объект на Панели специального управления.

В окне модели появляется сплайн, а в Дереве построения — его пиктограмма.

  1. Т.е. в иерархии отношений между объектом, содержащим вершину (или точку), и объектом, содержащим указанную грань, не должно быть других объектов (о просмотре отношений объектов см. раздел 2.1.2.7.2).

В этом разделе:

2.5.4.21.1. Таблица параметров вершин сплайна

2.5.4.21.2. Режим редактирования сплайна

2.5.4.21.3. Изменение положения вершины

2.5.4.21.4. Управление касательным вектором сплайна


2.5.4.21.1. Таблица параметров вершин сплайна

Каждая вершина сплайна характеризуется набором параметров. Их значения отображаются в таблице параметров вершин.

Эта таблица называется Координаты вершин (U,V) и находится на Панели свойств.

Каждой вершине сплайна соответствует строка таблицы.

В таблице содержатся следующие параметры:

– номер вершины,

– значения параметров вершины (U,V),

– значок связи, если вершина сплайна ассоциативно связана с точечным объектом,

– вес (при построении сплайна по полюсам);

– значок связи и значок системного полюса (при построении сплайна по полюсам).

Системный полюс сплайна на поверхности аналогичен системному полюсу сплайна, сопряженного По касательной с объектом модели. Подробнее о системном полюсе см. раздел 2.5.4.9.3.

Рис. 2.5.49. Пример таблицы параметров вершин сплайна

Строки таблицы формируются автоматически при построении вершины в окне модели. Вместе с тем, создание или редактирование строки таблицы приводит к созданию новой или изменению параметров существующей вершины кривой. Кроме того, выделение строки существующей вершины позволяет перейти в режим редактирования сплайна (о редактировании см. раздел 2.5.4.21.2). Выделение последней (ненумерованной) строки таблицы позволяет переключиться в режим построения сплайна.

Элементы управления над таблицей и команды контекстного меню таблицы позволяют выполнять следующие действия:

– заменять содержимое всех ячеек выделенного столбца нулевым значением или значением первой ячейки;

– изменять значения параметров существующих в таблице вершин,

– создавать новые вершины,

– удалять вершины кривой,

– удалять связь вершины сплайна с точечным объектом,

– отменять условия касания сплайна с кривой, лежащей на поверхности расположения сплайна (об условии касания сплайна с кривой см. раздел 2.5.4.21.4).

Создание новой вершины сплайна описано ниже, остальные приемы работы описаны в разделе 2.5.4.8.2.

Создание новой вершины

Чтобы добавить новую вершину, выделите в таблице строку с номером вершины, относительно которой будет производиться добавление вершины, и нажмите кнопку над таблицей. Описание кнопок, позволяющих добавить новую вершину, представлено в таблице 2.5.11.

Табл. 2.5.11. Кнопки для добавления вершин сплайна
Кнопка | Описание
Вставить вершину перед текущей | Позволяет добавить вершину между текущей и предыдущей. После нажатия кнопки в окне модели появляется новая вершина, а в таблицу добавляется новая строка, содержащая параметры новой вершины. Новая вершина получает номер текущей вершины, а номера последующих увеличиваются на единицу. Добавить новую вершину можно также, нажав клавишу <Insert>.
Дублировать вершину | Позволяет добавить новую вершину, координаты и вес которой должны быть такими же, как у текущей вершины (вес для сплайна по полюсам). После нажатия кнопки в окне модели появляется новая вершина, а в таблицу добавляется новая строка, содержащая параметры этой вершины. Новая вершина получает номер текущей вершины, а номера последующих увеличиваются на единицу.
Вставить вершину после текущей | Позволяет добавить новую вершину между текущей и следующей. После нажатия кнопки в окне модели появляется новая вершина, а в таблицу добавляется новая строка, содержащая параметры новой вершины. Новая вершина получает номер, следующий по порядку за номером текущей вершины, а номера последующих вершин увеличиваются на единицу.


2.5.4.21.2. Режим редактирования сплайна

В режиме редактирования вы можете:

– изменять положение вершины сплайна;

– управлять формой сплайна в его вершине — изменять направление и длину касательного вектора сплайна.

Чтобы перейти в режим редактирования сплайна, выделите в таблице параметров вершин строку с номером нужной вершины.

При вызове команды редактирования ранее созданного сплайна переход в режим редактирования производится автоматически.

Группа переключателей Управление на Панели свойств позволяет выбрать способ редактирования сплайна в текущей вершине:

– Положение вершины — изменение положения вершины (см. раздел 2.5.4.21.3);

– Касательный вектор в вершине — управление касательным вектором сплайна (см. раздел 2.5.4.21.4).

Для сплайна по полюсам управление касательным вектором возможно только в крайних вершинах. Обратите внимание на следующую особенность перехода в режим редактирования сплайна по полюсам. Выделение строки начальной или конечной вершины позволяет перейти к редактированию положения этой вершины и к управлению ее касательным вектором — на Панели свойств присутствует группа Управление. Выделение строк остальных вершин позволяет перейти к редактированию их положения — на Панели свойств присутствуют поля для ввода значения параметров U и V.

Кроме того, в режиме редактирования вы можете удалять вершины. Для этого выделите нужную вершину в окне модели и нажмите клавишу <Delete>.

Все изменения отображаются на фантоме сплайна в окне модели.

Завершив редактирование сплайна в одной из вершин, вы можете:

– продолжить задание вершин — для этого выделите последнюю (ненумерованную) строку таблицы;

– отредактировать другую вершину — для этого выделите ее строку в таблице или укажите ее о окне модели;

– завершить построение сплайна — для этого нажмите кнопку Создать объект.

Вы можете переключаться между режимами построения и редактирования сплайна при помощи команды контекстного меню Завершить/Продолжить ввод вершин.


2.5.4.21.3. Изменение положения вершины

Чтобы изменить положение текущей вершины сплайна, активизируйте в группе Управление на Панели свойств переключатель Положение вершины.

На Панели свойств появляются элементы управления, показанные на рис. 2.5.50.

Рис. 2.5.50. Панель свойств при изменении положения текущей вершины сплайна

Изменить положение вершины сплайна можно двумя способами:

– задать параметры U и V;

– связать вершину с точечным объектом.

Способы изменения положения вершин сплайна аналогичны способам задания вершины при построении сплайна. Эти способы описаны в п.3 раздела 2.5.4.21.


2.5.4.21.4. Управление касательным вектором сплайна

Вы можете изменить направление и длину касательного вектора сплайна в текущей вершине.

Касательный вектор сплайна в текущей вершине можно направить произвольно или по касательной к кривой, проходящей через эту вершину.

В качестве кривой можно использовать:

– кривую, лежащую на указанной грани, или ребро этой грани;

– изопараметрическую кривую теоретической поверхности указанной грани.

Длину касательного вектора можно изменить произвольно.

Задание условий касания сплайна

Для перехода к управлению касательным вектором сплайна активизируйте в группе Управление на Панели свойств переключатель Касательный вектор в вершине.

На Панели свойств появляются элементы управления, позволяющие задать условия касания сплайна в текущей точке. Выберите из списка Касание нужное условие касания сплайна (рис. 2.5.51).

Рис. 2.5.51. Панель свойств при редактировании касательного вектора в текущей вершине сплайна

Управление касательным вектором описано в табл. 2.5.12.

Табл. 2.5.12. Управление касательным вектором сплайна в текущей вершине
Условие касания | Управление касательным вектором
Не задано | После выбора данного условия форма сплайна в текущей вершине принимает умолчательный вид.
По направлению | Позволяет отредактировать параметры вектора в ручную. После выбора данного условия касания на экране появляется касательный вектор в виде пунктирного отрезка с характерной точкой. Вы можете изменить длину и направление вектора, перемещая мышью его характерную точку.
К изопараметрической кривой U; К изопараметрической кривой V | Позволяет задать направление вектора по касательной к изопараметрической кривой U (или V) указанной грани. После выбора данного условия касания вектор располагается по касательной к изопараметрической кривой. На экране появляется вектор заданного направления. Вы можете отредактировать длину вектора, перемещая мышью его характерную точку.
К кривой на поверхности | Позволяет задать направление вектора по касательной к кривой, лежащей на указанной грани. После выбора данного условия касания на экране появляется вектор с умолчательным направлением. Около текущей вершины появляется обозначение касания. Укажите в окне модели кривую или ребро, определяющее направление вектора. Затем измените длину вектора, перемещая мышью его характерную точку.

Фантом создаваемого сплайна в окне модели перестроится согласно выбранному условию касания, а рядом с вершиной появится значок касания.

Переключатель Сменить направление позволяет направить касательный вектор в противоположную сторону.

Обратите внимание на то, что для сплайна по полюсам управление касательным вектором возможно только в крайних вершинах. После изменения параметров касательного вектора крайней вершины вершина, соседняя с ней, получает признак системного полюса — в таблице параметров вершин в строке этой вершины появляется значок системного полюса (см. рис. 2.5.49). Если вершины, соседние с крайними, связаны с точечными объектами, то после выбора условия касания на экране появляется сообщение об изменении параметров этих вершин.

Подробнее о системном полюсе рассказано в разделе 2.5.4.9.3.

Удаление условий касания сплайна

Вы можете удалить условие касания сплайна в текущей вершине или сразу во всех вершинах.

Чтобы удалить заданное условие касания сплайна в текущей вершине, выберите из списка Касание на Панели свойств вариант Не задано или вызовите команду контекстного меню Удалить параметры управления — В точке.

Чтобы удалить условия касания сплайна во всех вершинах вызовите команду контекстного меню Удалить параметры управления — Во всех точках.

Обратите внимание на то, что восстановить удаленное условие касания невозможно. Для восстановления условия касания необходимо сформировать его заново.

Если вершина сплайна имеет признак системного полюса, то можно удалить условие касания, отменив этот признак. Для этого следует выделить в таблице параметров вершин строку этого системного полюса и щелкнуть мышью по значку системного полюса в колонке Связь или вызвать команду Удалить связь из контекстного меню таблицы. Условие касания будет удалено. При этом координаты вершины не изменятся.


2.5.4.22. Проекционная кривая

Вы можете построить проекционную кривую — проекцию указанной кривой (базовой) на поверхность проецирования.

Рис. 2.5.52. Проекция эскиза на грань тела

В этом разделе:

2.5.4.22.1. Объекты, используемые при построении

2.5.4.22.2. Построение проекционной кривой

2.5.4.22.3. Выбор типа проекции базовой кривой


2.5.4.22.1. Объекты, используемые при построении

Для построения проекционной кривой необходимы поверхность проецирования и базовая кривая.

В качестве поверхности проецирования может использоваться:

– грань тела или поверхности;

– координатная или вспомогательная плоскость;

– набор граней тел и/или поверхностей.

В качестве базовой кривой может использоваться:

– пространственная кривая (в том числе экземпляр массива),

– ребро тела и поверхности,

– линия эскиза,

– набор вышеперечисленных объектов,

– координатная или вспомогательная ось,

– массив кривых,

– группа изопараметрических кривых.

Обратите внимание на следующие особенности построения проекционной кривой:

– Проекцию оси на плоскость построить нельзя.

– Если проекция базовой кривой на поверхность вырождается в точку, то ее построение невозможно.

– Построение проекции оси возможно, если данная проекция располагается в пределах поверхности проецирования.


2.5.4.22.2. Построение проекционной кривой

Чтобы построить проекционную кривую, выполните следующие действия.

1. Вызовите команду Проекционная кривая.

2. После вызова команды автоматически на Панели свойств активизируется переключатель Поверхность. Укажите в окне модели нужную грань или плоскость.
О выборе объектов подробно рассказано в разделе 2.1.4.1.1.

Указанный объект подсвечивается. Название выбранного объекта отображается в поле Поверхность на Панели свойств.

3. После задания поверхности проецирования система переходит к выбору базовой кривой — автоматически активизируется переключатель Кривая. Укажите в окне модели базовую кривую. Название объекта или количество объектов отображается в поле рядом с переключателем.

Обратите внимание на то, что ось, массив кривых и группа изопараметрических кривых не могут входить в набор объектов, составляющих базовую кривую. Поэтому выбор, например, новой оси отменяет выбор всех остальных объектов, входивших в базовую кривую.

На экране появляется фантом проекционной кривой.

Отсутствие фантома — признак невозможности существования проекционной кривой при выбранных исходных объектах и текущих параметрах построения.

4. При необходимости измените поверхность проецирования (например, можно составить набор граней) и/или базовую кривую.

– Чтобы изменить поверхность проецирования, активизируйте переключатель Поверхность, а затем укажите нужные объекты. Плоскость не может входить в набор объектов, составляющих поверхность проецирования. Поэтому выбор новой плоскости отменяет выбор всех остальных объектов, входивших в поверхность проецирования.

Если в набор граней нужно добавить все грани какого-либо тела или поверхности, укажите это тело или поверхность в Дереве построения.

– Чтобы изменить базовую кривую, активизируйте переключатель Кривая, а затем укажите нужные объекты.

Повторное указание объекта отменяет его выбор.

Все изменения отображаются на фантоме кривой.

5. Выберите тип проекции базовой кривой: по нормали к указанной поверхности или в заданном направлении (см. раздел 2.5.4.22.3).

6. По умолчанию проекция базовой кривой строится в пределах контура грани (обрезана по контуру грани) — на Панели свойств включена опция Усечение по границам. Если требуется построить всю проекцию, то отключите опцию. Базовая кривая будет проецироваться на теоретическую поверхность грани. При необходимости теоретическая поверхность грани будет продлеваться.

Если в качестве поверхности проецирования используется набор граней, то по умолчанию проекция базовой кривой обрезана по контуру каждой грани набора.

Обратите внимание на следующие особенности проецирования:

– Проекция базовой кривой на плоскость всегда строится полностью.

– Если в качестве базовой кривой указана ось, то ее проекция всегда строится в пределах контура поверхности проецирования.

В обоих случаях опция Усечение по границам недоступна.

Общие сведения о теоретической поверхности грани приведены в разделе 2 Приложения IX. На рисунке показаны варианты построения проекции линии эскиза (базовой кривой) на грань с отверстием.

Рис. 2.5.53. Результат проецирования линии эскиза на грань с отверстием: а) опция Усечение по границам включена; б) опция Усечение по границам отключена
а) | б)

7. Проекционная кривая может состоять из одного или нескольких участков — контуров. Выберите те контуры, которые должны быть построены (см. раздел 2.5.4.15.1).

8. При необходимости используйте следующие возможности:

– Отмена сразу всех объектов, заданных для построения кривой. Для этого нажмите кнопку Указать заново на Панели специального управления.

– Изменение наименования и цвета создаваемой кривой. Для этого активизируйте вкладку Свойства Панели свойств. Также на этой вкладке можно настроить параметры отображения кривой (о параметрах отображения см. раздел 2.5.4.1).

9. Нажмите кнопку Создать объект на Панели специального управления.

В окне модели появляется проекционная кривая, а в Дереве построения — ее пиктограмма.


2.5.4.22.3. Выбор типа проекции базовой кривой

По умолчанию базовая кривая проецируется по нормали к заданной поверхности проецирования. При этом в группе Тип проекции на Панели свойств активен переключатель По нормали к поверхности.

Вы можете построить проекцию базовой кривой в направлении, заданном объектом или вектором. Для этого в группе Тип проекции активизируйте переключатель По направлению. На Панели свойств появляются элементы, позволяющие задать направляющий объект.

В качестве направляющего объекта может использоваться любой прямолинейный или плоский объект. Прямолинейные и плоские объекты перечислены в таблице 2.1.7.

Направление, задаваемое прямолинейным объектом — прямая, параллельная объекту.

Направление, задаваемое плоским объектом — прямая, перпендикулярная объекту.

Активизируйте переключатель Направление, а затем в Дереве построения или в окне модели укажите объект, определяющий направление проецирования.

Повторное указание объекта отменяет его выбор и фантом создаваемой кривой исчезает.

Чтобы создать вектор, задающий направление проецирования, нажмите кнопку Построение вектора на Панели специального управления (см. раздел 2.8.5).

Наименование выбранного объекта отображается в поле Направление взгляда. Если направление задано вектором, то в поле отображается слово «Вектор».

На рисунке показан пример построения проекции линии эскиза (базовой кривой) на цилиндрическую поверхность.

Рис. 2.5.54. Пример построения проекции линии эскиза на цилиндрическую поверхность: а) проецирование линии эскиза по нормали к поверхности; б) проецирование линии эскиза перпендикулярно плоскости эскиза
а) | б)


2.5.4.23. Кривая пересечения поверхностей

Вы можете построить кривую пересечения двух поверхностей, или двух наборов поверхностей, или поверхности и набора.

Чтобы построить кривую пересечения поверхностей, вызовите команду Кривая пересечения поверхностей.

После вызова команды автоматически активизируется переключатель Набор поверхностей 1 на Панели свойств. Укажите первый объект пересечения — грань или плоскость (о выборе объектов см. раздел 2.1.4.1.1). Название указанного объекта отображается в поле рядом с переключателем Набор поверхностей 1.

После задания первого объекта пересечения система переходит к выбору второго объекта пересечения — автоматически активизируется переключатель Набор поверхностей 2. Укажите второй объект пересечения или несколько объектов. Название объекта или количество объектов отображается в поле рядом с переключателем.

Если требуется изменить первый или второй набор поверхностей, активизируйте соответствующий переключатель и укажите нужные объекты. Повторное указание объекта отменяет его выбор.

Если в текущий набор поверхностей нужно добавить все грани какого-либо тела или поверхности, укажите это тело или поверхность в Дереве построения.

Кривую пересечения координатных плоскостей построить невозможно.

После выбора объектов пересечения на экране появляется фантом кривой пересечения.

Кривая пересечения может состоять из одного или нескольких непрерывных участков — контуров. Выберите нужные контуры для построения (см. раздел 2.5.4.15.1).

Чтобы сменить объекты пересечения, нажмите кнопку Указать заново на Панели специального управления и повторите выбор объектов.

Элементы управления, расположенные на вкладке Свойства Панели свойств, позволяют изменить название и цвет кривой пересечения, настроить параметры ее отображения (о параметрах отображения см. раздел 2.5.4.1).

Чтобы завершить построение кривой пересечения, нажмите кнопку Создать объект на Панели специального управления.

В окне модели появляется кривая пересечения, а в Дереве построения — пиктограмма пересечения.


2.5.4.24. Контур

Вы можете построить контур по уже существующим объектам — пространственным кривым, ребрам или линиям эскиза.

Чтобы построить контур, вызовите команду Контур на панели Пространственные кривые. Команда доступна, если в документе есть хотя бы одна кривая, поверхность, тело или эскиз.

Выберите тип контура при помощи переключателей в группе Тип на Панели свойств или команд контекстного меню.

– Автоопределение типа,

– Произвольный контур,

– Контур на грани,

– Контур эскиза.

Активизация переключателя Автоопределение типа означает, что тип контура будет определен системой автоматически после указания кривых.

Укажите объекты, из которых состоит контур выбранного типа — кривые, линии эскиза, ребра тел или поверхностей, другие ранее построенные контуры.

При указании должно выполняться условие непрерывности создаваемого контура и отсутствия самопересечений.

Подробно о типах контура и указании объектов рассказано в разделе 2.5.4.24.1.

Объекты могут быть выделены до вызова команды.

На экране появляется фантом контура. Начальная вершина контура отмечена стрелкой.

Повторное указание объекта отменяет его выбор, а также выбор всех следующих за ним объектов в направлении конечной вершины контура.

О выборе объектов подробно рассказано в разделе 2.1.4.1.1.

Названия выбранных объектов отображаются в таблице Список объектов на Панели свойств.

Вы можете построить скругления постоянного или переменного радиуса в углах контура (см. раздел 2.5.4.24.2). Также возможно создание контура по эквидистанте кривой (см. раздел 2.5.4.24.3).

Чтобы сменить объекты, используемые для построения контура, нажмите кнопку Указать заново на Панели специального управления и повторите выбор объектов.

Элементы управления, расположенные на вкладке Свойства Панели свойств, позволяют изменить название и цвет контура, настроить параметры его отображения. О параметрах отображения кривых см. раздел 2.5.4.1.

Группа переключателей Начальная/Конечная вершина позволяет сменить начальную вершину контура.

Опция Скрывать исходные кривые управляет видимостью исходных объектов контура после его создания. Если она включена, то после создания контура кривые, по которым он построен, будут автоматически скрыты.

Чтобы завершить построение, нажмите кнопку Создать объект на Панели специального управления.

Созданный контур появится в окне модели, а его пиктограмма — в Дереве построения.

Обратите внимание на то, что контур ассоциативно связан с объектами, по которым он был построен, благодаря чему при изменении формы этих объектов меняется и форма контура.

В этом разделе:

2.5.4.24.1. Выбор типа контура

2.5.4.24.2. Построение контура со скруглениями

2.5.4.24.3. Построение контура по эквидистанте кривой


2.5.4.24.1. Выбор типа контура

Вы можете задать следующие типы контура при помощи переключателей в группе Тип на Панели свойств или команд контекстного меню.

Произвольный контур — контур, состоящий из пространственных кривых, ребер, линий эскизов, других контуров, отдельных сегментов многосегментных кривых.

Чтобы построить произвольный контур, укажите кривые, которые должны в него входить. О выборе объектов см. раздел 2.1.4.1.

Контур на грани — контур, состоящий из ребер одной грани.

Чтобы построить контур на грани, укажите ее ребро, которое должно содержаться в контуре. Одна из граней, которым принадлежит ребро, подсвечивается. Чтобы вместо этой грани выбрать смежную с ней, щелкните на смежной грани мышью.

Укажите все необходимые для контура ребра выбранной грани.

Контур эскиза — контур, состоящий из линий одного эскиза.

Укажите линии эскиза в окне модели или эскиз в Дереве построения. Если эскиз выбран в Дереве, то в контур включаются все его линии, поэтому они должны последовательно соединяться и не образовывать самопересечений.

Автоопределение типа — способ построения контура по умолчанию, при котором не требуется специального выбора типа. При активизированном переключателе Автоопределение типа вы можете указать любые кривые. После создания контура его тип определяется системой автоматически. Чтобы убедиться в этом, войдите в режим редактирования контура, при создании которого был включен переключатель Автоопределение типа. Активизированный переключатель указывает на тип контура.

В процессе выбора вы можете переключаться между типами. В зависимости от того, какие объекты уже указаны для построения контура, может быть недоступен переключатель Контур эскиза, Контур на грани или оба эти переключателя.

После создания контура эскиза или контура на грани вы можете добавить объекты, не принадлежащие данному эскизу или грани. Для этого в режиме редактирования контура нажмите переключатель Произвольный контур и укажите объекты.

Тип контура имеет значение при выполнении некоторых операций. Например, в операции выдавливания выбор того или иного типа контура влияет на результат операции (см. раздел 2.3.2.3.1).


2.5.4.24.2. Построение контура со скруглениями

Для построения скруглений в углах контура активизируйте переключатель Обход скруглением в группе Обход углов вкладки Параметры на Панели свойств. В поле Радиус задайте величину постоянного радиуса скругления.

На фантоме контура в окне модели отображаются скругления одинакового радиуса. На первом скруглении показывается характерная точка для управления величиной радиуса. При перемещении точки мышью все скругления на фантоме изменяются.

Чтобы задать переменный радиус, т.е. в каждой вершине контура свое значение радиуса, при нажатом переключателе Обход скруглением перейдите на вкладку Переменный радиус.

На вкладке расположена одноименная панель, содержащая таблицу параметров: номера точек и значения радиусов в них (рис 2.5.55, а). Если точки не указаны, то таблица пуста.

На фантоме контура в окне модели показываются характерные точки всех радиусов, пронумерованные от начала контура (рис 2.5.55, б).

Рис. 2.5.55. Пример построения контура с переменным радиусом скруглений: а) задание значения радиуса в таблице; б) отображение скруглений на фантоме контура
а) | б)

Укажите курсором те точки, радиус в которых нужно изменить. Выбранные точки отображаются в таблице Переменный радиус.

Задайте значения радиусов скругления в этих точках любым способом — перемещением характерных точек мышью или путем задания значений в таблице.

Чтобы изменить значение радиуса в таблице, сделайте одинарный или двойной щелчок мышью в нужной ячейке. После одинарного щелчка возможен ввод значения с клавиатуры, а после двойного — ввод с клавиатуры или выбор с помощью счетчика.

Скругления отображаются на фантоме контура в окне модели.

Вы можете удалить точку из таблицы при помощи кнопки Удалить, расположенной над списком. Удаление точки из таблицы означает, что в ней будет строиться скругление с постоянным радиусом.


2.5.4.24.3. Построение контура по эквидистанте кривой

Вы можете построить контур по эквидистанте указанной кривой в процессе работы команды Контур.

Чтобы задать параметры эквидистанты, нажмите кнопку Эквидистанта кривой на Панели специального управления.

Система переходит в процесс создания эквидистантной кривой, аналогичный вызываемому командой Эквидистанта кривой (см. раздел 2.5.4.17). Выберите способ построения эквидистанты, а затем задайте требуемые для этого способа параметры (введите значения или укажите объекты). Все изменения отображаются на фантоме создаваемой кривой в окне модели.

Кривые могут быть указаны до перехода в процесс построения эквидистанты.

Завершив задание параметров эквидистанты, нажмите кнопку Создать объект на Панели специального управления.

Система возвращается к выполнению команды Контур.

Название эквидистантной кривой отображается в таблице Список объектов на Панели свойств как объекта для создания контура.

Вы можете строить обход углов скруглением как в эквидистанте, так и в контуре. Построение скруглений в контуре является более удобным, так как предполагает задание произвольных значений радиусов (см. раздел 2.5.4.24.2).

За один вызов команды Контур можно создать один контур по эквидистанте. Чтобы дополнить контур другими кривыми, следует вызвать команду Контур повторно и указать объекты.

Обратите внимание на то, что эквидистанта, построенная в процессе создания контура, не отображается в Дереве построения как самостоятельный объект. Она хранится внутри объекта Контур, для которого была создана.

Чтобы отредактировать параметры эквидистанты в составе контура, войдите в режим редактирования контура и нажмите кнопку Эквидистанта кривой на Панели специального управления. Система перейдет в процесс редактирования эквидистанты, аналогичный процессу ее построения. Измените параметры текущего способа построения эквидистанты или выберите другой способ и постройте кривую заново. Завершив редактирование, нажмите кнопку Создать объект для выхода из процесса редактирования эквидистанты.


2.6. Поверхности

В этом разделе:

2.6.1. Создание поверхностей

2.6.1.1. Импортированная поверхность

2.6.1.2. Поверхность выдавливания

2.6.1.2.1. Построение поверхности выдавливания

2.6.1.2.2. Требования к эскизу поверхности выдавливания

2.6.1.3. Поверхность вращения

2.6.1.3.1. Построение поверхности вращения

2.6.1.3.2. Требования к эскизу поверхности вращения

2.6.1.4. Кинематическая поверхность

2.6.1.5. Поверхность по сечениям

2.6.1.6. Поверхность по сети точек

2.6.1.6.1. Создание поверхности по сети точек

2.6.1.6.2. Задание точек для поверхности по сети точек

2.6.1.6.3. Режим редактирования поверхности по сети точек

2.6.1.6.4. Построение сети точек по существующей поверхности

2.6.1.6.5. Самопересекающаяся поверхность

2.6.1.7. Поверхность по пласту точек

2.6.1.7.1. Создание поверхности по пласту точек

2.6.1.7.2. Задание точек для поверхности по пласту точек

2.6.1.7.3. Распознавание сети точек

2.6.1.7.4. Режим редактирования поверхности по пласту точек

2.6.1.8. Поверхность по сети кривых

2.6.1.8.1. Кривые и точки сети

2.6.1.8.2. Создание поверхности по сети кривых

2.6.1.8.3. Сопряжение поверхности с другими поверхностями

2.6.1.9. Линейчатая поверхность

2.6.1.9.1. Создание линейчатой поверхности

2.6.1.9.2. Управление разбиением поверхности на грани

2.6.1.10. Заплатка

2.6.1.11. Поверхность соединения

2.6.1.12. Эквидистанта поверхности

2.6.2. Редактирование поверхностей

2.6.2.1. Усечение поверхности

2.6.2.1.1. Требования к объектам операции усечения

2.6.2.1.2. Выполнение усечения

2.6.2.2. Разбиение поверхности

2.6.2.2.1. Требования к объектам операции разбиения

2.6.2.2.2. Выполнение разбиения

2.6.2.3. Продление поверхности

2.6.2.3.1. Тип продления

2.6.2.3.2. Способ продления

2.6.2.4. Сшивка поверхностей

2.6.2.5. Удаление граней

2.6.2.6. Тела с нарушенной целостностью

2.6.3. Сплайновая форма. Произвольное редактирование грани

2.6.3.1. Изменение положения полюсов

2.6.3.1.1. Выбор полюсов

2.6.3.1.2. Линейное перемещение полюсов

2.6.3.1.3. Перемещение полюсов со сглаживанием

2.6.3.1.4. Вращение полюсов

2.6.3.1.5. Масштабирование

2.6.3.1.6. Выравнивание полюсов

2.6.3.2. Фиксация полюсов

2.6.3.2.1. Фиксация полюсов, расположенных на границах сетки

2.6.3.2.2. Произвольная фиксация полюсов

2.6.3.2.3. Фиксация полюсов, обеспечивающих неизменность формы и положения ребер грани

2.6.3.3. Изменение параметров сплайновой поверхности

2.6.3.3.1. Порядок поверхности

2.6.3.3.2. Размерность сетки

2.6.3.4. Произвольное перемещение полюсов мышью

2.6.3.4.1. Приемы работы

2.6.3.4.2. Особенности задания направления перемещения полюсов

2.6.3.5. Построение сплайновой формы на эквидистанте грани

2.6.3.6. Особенности редактирования грани и эквидистанты грани


2.6.1. Создание поверхностей

2.6. Поверхности

2.6.1. Создание поверхностей

В файле модели КОМПАС-3D могут быть созданы следующие поверхности:

– выдавливания,

– вращения,

– по сечениям,

– кинематическая,

– «заплатка»,

– линейчатая,

– по сети кривых,

– по сети точек,

– по пласту точек,

– эквидистантная,

– поверхность соединения.

Можно также импортировать в модель поверхности, записанные в файле формата SAT, IGES или STEP AP203.

Доступны следующие операции над поверхностями:

– усечение,

– разбиение,

– продление,

– сшивка.

Кроме того, отдельные грани поверхностей и тел можно модифицировать или удалять.

Команды работы с поверхностями расположены в меню Операции — Поверхность. Кнопки для вызова этих команд находятся на панели Поверхности (рис. 2.6.1).

Рис. 2.6.1. Панель Поверхности

Все вышеназванные возможности создания поверхностей и работы с ними описаны в настоящей части. Помимо этого, возможно выполнение следующих действий с поверхностями:

– масштабирование, см. раздел 2.3.8.7,

– изменение положения, см. раздел 2.3.8.8,

– сохранение в файле новой детали, см. раздел 2.11.2.3.

Поверхности могут использоваться, например, для отсечения части модели или в качестве объекта, до которого производится выдавливание.

При создании поверхность должна быть целой, т.е. не состоящей из частей. Иначе выполнение операции невозможно.

В этом разделе:

2.6.1.1. Импортированная поверхность

2.6.1.2. Поверхность выдавливания

2.6.1.2.1. Построение поверхности выдавливания

2.6.1.2.2. Требования к эскизу поверхности выдавливания

2.6.1.3. Поверхность вращения

2.6.1.3.1. Построение поверхности вращения

2.6.1.3.2. Требования к эскизу поверхности вращения

2.6.1.4. Кинематическая поверхность

2.6.1.5. Поверхность по сечениям

2.6.1.6. Поверхность по сети точек

2.6.1.6.1. Создание поверхности по сети точек

2.6.1.6.2. Задание точек для поверхности по сети точек

2.6.1.6.3. Режим редактирования поверхности по сети точек

2.6.1.6.4. Построение сети точек по существующей поверхности

2.6.1.6.5. Самопересекающаяся поверхность

2.6.1.7. Поверхность по пласту точек

2.6.1.7.1. Создание поверхности по пласту точек

2.6.1.7.2. Задание точек для поверхности по пласту точек

2.6.1.7.3. Распознавание сети точек

2.6.1.7.4. Режим редактирования поверхности по пласту точек

2.6.1.8. Поверхность по сети кривых

2.6.1.8.1. Кривые и точки сети

2.6.1.8.2. Создание поверхности по сети кривых

2.6.1.8.3. Сопряжение поверхности с другими поверхностями

2.6.1.9. Линейчатая поверхность

2.6.1.9.1. Создание линейчатой поверхности

2.6.1.9.2. Управление разбиением поверхности на грани

2.6.1.10. Заплатка

2.6.1.11. Поверхность соединения

2.6.1.12. Эквидистанта поверхности


2.6.1.1. Импортированная поверхность

Для импорта поверхности или поверхностей в файл модели КОМПАС-3D могут использоваться следующие файлы.

– Файл с расширением sat, igs, stp или step — имеющиеся в этом файле свободные поверхности и поверхности тел будут вставлены в текущую модель.

– Файл данных с расширением txt, xls или ods (о файле данных см. Приложение VI) — по заданным в этом файле координатам в текущей модели будет построена многогранная поверхность. Каждая грань поверхности имеет треугольную форму.

Для выполнения импорта используется команда Импортированная поверхность.

После вызова команды на экране появляется стандартный диалог открытия файла, позволяющий выбрать нужный файл.

Во время чтения файла *.igs, записанного без топологии, на экране появляется запрос на сшивку поверхностей. При положительном ответе те импортируемые поверхности, сшивка которых возможна, будут объединены.

После завершения импорта в Дереве построения появится пиктограмма импортированной поверхности или несколько пиктограмм импортированных поверхностей.

Системой координат импортированной поверхности или поверхностей является текущая система координат — абсолютная или локальная (о выборе текущей системы координат — см. раздел 2.8.3.3).

Если системой координат импортированной поверхности является не абсолютная, а локальная система координат, то, изменяя положение локальной системы координат относительно абсолютной, можно изменять положение импортированной поверхности в модели.

Подробнее о системах координат объектов рассказано в разделе 2.8.3.4.

Если в выбранном файле *.sat, *.igs, *.stp или *.step записана сборочная модель, то в результате чтения в текущей модели создаются детали, содержащие импортированные поверхности. При сохранении модели файлы этих деталей записываются на диск. Они помещаются в ту же папку, что и модель.


2.6.1.2. Поверхность выдавливания

Поверхность выдавливания формируется путем перемещения сечения по прямолинейной направляющей в одну или в обе стороны на заданное расстояние.

В качестве сечения поверхности выдавливания может использоваться грань, эскиз, ребро или пространственная кривая (в том числе контур, построенный по линиям эскиза, ребрам грани или произвольный1).

При выдавливании грани, замкнутого эскиза, замкнутого Контура на грани или Контура эскиза возможно построение замкнутой поверхности (рис. 2.6.2). Если сечение разомкнуто, то замыкание поверхности невозможно.

Рис. 2.6.2. Выдавливание грани: а) сечение (цилиндрическая грань), б) замкнутая поверхность, в) незамкнутая поверхность
а) | б) | в)

Если сечение представляет собой плоскую грань, эскиз, контур, построенный по линиям эскиза или плоской грани, и выдавливается в направлении, перпендикулярном себе, то возможен уклон боковых граней поверхности (рис. 2.6.3).

Рис. 2.6.3. Уклон боковых граней поверхности выдавливания: а) замкнутой, б) незамкнутой
а) | б)

Эскиз, используемый в качестве сечения поверхности выдавливания, должен удовлетворять требованиям, представленным в разделе 2.6.1.2.2.

При выдавливании ребра или пространственной кривой (в том числе контура типа Произвольный) замыкание и уклон граней поверхности невозможны. Пример выдавливания пространственной кривой приведен на рисунке 2.6.4.

Рис. 2.6.4. Поверхность выдавливания с сечением-спиралью

  1. Т.е. имеющий тип Контур на грани, Контур эскиза и Произвольный, см. раздел 2.5.4.24.1.

В этом разделе:

2.6.1.2.1. Построение поверхности выдавливания

2.6.1.2.2. Требования к эскизу поверхности выдавливания


2.6.1.2.1. Построение поверхности выдавливания

1. Вызовите команду Поверхность выдавливания.

Запускается операция построения поверхности. На Панели свойств появляются элементы управления параметрами операции.

2. Задайте параметры операции:

– сечение — так же, как при выполнении операции выдавливания, см. раздел 2.3.2.3.2;

– направление выдавливания — так же, как при выполнении операции выдавливания, см. раздел 2.3.2.4;

– глубину выдавливания — так же, как при выполнении операции выдавливания, см. раздел 2.3.2.5;

– угол уклона — так же, как при выполнении операции выдавливания, см. раздел 2.3.2.6.

Для задания таких параметров операции, как угол уклона, направление и глубина выдавливания, можно использовать характерные точки (о характерных точках см. раздел 2.1.4.2.2).

Все значения параметров отображаются на экране в виде фантома поверхности.

3. Если в качестве сечения используется грань, замкнутый эскиз, замкнутый Контур на грани или Контур эскиза, становится доступна опция Замкнутая поверхность. Включите ее, если требуется добавить к поверхности грани, соответствующие начальному и конечному положению сечения (см. рис. 2.6.2, б).

4. нажмите кнопку Создать, чтобы зафиксировать поверхность.

Поверхность появится в окне модели, а соответствующая ей пиктограмма — в Дереве построения.


2.6.1.2.2. Требования к эскизу поверхности выдавливания

– Объекты эскиза могут составлять один или несколько контуров.

– Если контур один, то он может быть разомкнутым или замкнутым.

– Если контуров несколько, то:

• все они должны быть замкнуты.

• один из них должен быть наружным, а другие — вложенными в него; допустимый уровень вложенности — 1.

Если эскиз содержит вложенные контуры, то корректное построение поверхности возможно, только если она замкнута (т.е. при включенной опции Замкнутая поверхность).


2.6.1.3. Поверхность вращения

Поверхность вращения формируется путем вращения сечения вокруг оси в одну или в обе стороны на заданный угол.

В качестве сечения поверхности вращения может использоваться грань, эскиз, ребро или пространственная кривая (в том числе контур, построенный по линиям эскиза, ребрам грани или произвольный1).

При вращении грани, замкнутого эскиза, замкнутого Контура эскиза или Контура грани возможно построение замкнутой поверхности (рис. 2.6.5).

Рис. 2.6.5. Вращение грани: а) сечение (цилиндрическая грань) и ось, б) замкнутая поверхность, в) незамкнутая поверхность
а) | б) | в)

Если сечение разомкнуто, то замыкание поверхности невозможно.

При вращении ребра или пространственной кривой (в том числе контура типа Произвольный) замыкание поверхности также невозможно. Пример вращения пространственной кривой приведен на рисунке 2.6.6.

Рис. 2.6.6. Поверхность вращения с сечением-спиралью

Если сечение представляет собой разомкнутый эскиз или разомкнутый контур, построенный по эскизу или по плоской грани, а ось вращения лежит в плоскости сечения, доступен выбор типа построения — тороид или сфероид (рис. 2.6.7).

Рис. 2.6.7. Построение сфероида и тороида (сечение — эскиз — выделено утолщенной линией): а) сфероид, б) тороид
а) | б)

Эскиз, используемый в качестве сечения поверхности вращения, должен удовлетворять требованиям, перечисленным в разделе 2.6.1.3.2.

  1. Т.е. имеющий тип Контур на грани, Контур эскиза и Произвольный, см. раздел 2.5.4.24.1.

В этом разделе:

2.6.1.3.1. Построение поверхности вращения

2.6.1.3.2. Требования к эскизу поверхности вращения


2.6.1.3.1. Построение поверхности вращения

1. Вызовите команду Поверхность вращения.

Запускается операция построения поверхности. На Панели свойств появляются элементы управления параметрами операции.

2. Задайте параметры операции (так же, как при выполнении операции вращения):

– сечение, см. раздел 2.3.3.3;

– ось вращения, см. раздел 2.3.3.4;

– тип построения, см. раздел 2.3.3.5;

– направление вращения, см. раздел 2.3.3.6;

– угол вращения, см. раздел 2.3.3.7.

Для задания такого параметра операции, как угол вращения, можно использовать характерные точки (о характерных точках см. раздел 2.1.4.2.2).

Все значения параметров отображаются на экране в виде фантома поверхности.

3. При использовании в качестве сечения грани, замкнутого эскиза, замкнутого Контура эскиза или Контура грани доступна опция Замкнутая поверхность. Включите ее, если требуется добавить к поверхности грани, соответствующие начальному и конечному положению сечения (см. рис. 2.6.5, б).

4. Нажмите кнопку Создать объект, чтобы зафиксировать поверхность.

Поверхность появится в окне модели, а соответствующая ей пиктограмма — в Дереве построения.


2.6.1.3.2. Требования к эскизу поверхности вращения

– В эскизе может быть один или несколько контуров.

– Если контур один, он может быть разомкнутым или замкнутым.

– Если контуров несколько, все они должны быть замкнуты.

– Если контуров несколько, один из них должен быть наружным, а другие — вложенными в него.

– Допускается один уровень вложенности контуров.

Если эскиз содержит вложенные контуры, то корректное построение поверхности возможно, только если она замкнута (т.е. при включенной опции Замкнутая поверхность).

Кроме сечения, эскиз может содержать также ось вращения. В этом случае к нему предъявляются дополнительные требования:

– ось должна быть изображена в эскизе отрезком со стилем линии Осевая или объектом типа Осевая линия;

– все контуры должны лежать по одну сторону от оси вращения;

– ни один из контуров не должен пересекать ось (или ее продолжение);

– часть точек контуров может лежать на оси (или ее продолжении):

• для замкнутых контуров — любые их точки и/или участки;

• для разомкнутых контуров — только их крайние точки.


2.6.1.4. Кинематическая поверхность

Кинематическая поверхность образуется путем перемещения сечения вдоль траектории.

Если сечение замкнуто, возможно построение замкнутой поверхности (рис. 2.6.8). Если сечение разомкнуто, то замыкание поверхности невозможно.

Рис. 2.6.8. Кинематическая поверхность: а) сечение и траектория, б) замкнутая поверхность, в) незамкнутая поверхность
а) | б) | в)

Сечение поверхности должно быть изображено в эскизе; в качестве направляющей можно использовать любую кривую или цепочку кривых. Требования к эскизу сечения и к траектории поверхности такие же, как и к эскизу и к траектории кинематического элемента (см. разделы 2.3.4.3.1 и 2.3.4.4.1).

Для создания в модели кинематической поверхности выполните следующие действия.

1. Вызовите команду Кинематическая поверхность. Команда доступна, если в модели есть хотя бы один эскиз.

Запускается операция построения поверхности. На Панели свойств появляются элементы управления параметрами операции.

2. Задайте параметры операции (так же, как при выполнении кинематической операции):

– сечение, см. раздел 2.3.4.3;

– траектория, см. раздел 2.3.4.4;

– тип движения сечения, см. раздел 2.3.4.5.

Все значения параметров отображаются на экране в виде фантома поверхности.

3. При использовании замкнутого сечения доступна опция Замкнутая поверхность. Включите ее, если требуется добавить к поверхности плоские грани, соответствующие начальному и конечному положению сечения (см. рис. 2.6.8, б).

4. При необходимости смените вариант оптимизации построения. Это может изменить внешний вид кинематической поверхности в случае, если траектория имеет сложную форму (например, спираль с переменным шагом). Для смены варианта оптимизации активизируйте вкладку Свойства Панели свойств и выберите другую строку из списка Версия оптимизации.

5. Нажмите кнопку Создать объект, чтобы зафиксировать поверхность.

Поверхность появится в окне модели, а соответствующая ей пиктограмма — в Дереве построения.


2.6.1.5. Поверхность по сечениям

Поверхность по сечениям образуется путем соединения нескольких сечений произвольной формы и расположения. Крайнее сечение может быть точкой.

Если сечения замкнуты, возможно построение замкнутой поверхности (рис. 2.6.9). Если сечения разомкнуты, то замыкание поверхности невозможно.

Рис. 2.6.9. Поверхность по сечениям: а) сечения, б) замкнутая поверхность, в) незамкнутая поверхность
а) | б) | в)

В случае необходимости при построении элемента по сечениям можно использовать осевую линию (рис. 2.6.10).

Рис. 2.6.10. Поверхность по сечениям: а) без осевой линии, б) с осевой линией
а) | б)

Сечения поверхности должны быть изображены в эскизе; в качестве осевой линии можно использовать любую кривую или цепочку кривых. Требования к эскизам сечений и к осевой линии поверхности такие же, как и к эскизам и осевой линии элемента по сечениям (см. разделы 2.3.5.3.1 и 2.3.5.4.1).

Для создания в модели поверхности по сечениям выполните следующие действия.

1. Вызовите команду Поверхность по сечениям. Команда доступна, если в модели есть хотя бы два эскиза.

Запускается операция построения поверхности. На Панели свойств появляются элементы управления параметрами операции.

2. Задайте параметры операции (так же, как при выполнении операции по сечениям):

– сечение, см. раздел 2.3.5.3;

– осевую линию, см. раздел 2.3.5.4;

– способ построения, см. раздел 2.3.5.5.

Все значения параметров отображаются на экране в виде фантома поверхности.

3. При использовании замкнутых сечений доступна опция Замкнутая поверхность. Включите ее, если требуется добавить к поверхности плоские грани, совпадающие по форме с начальным и конечным эскизами-сечениями (см. рис. 2.6.9, б).

4. Нажмите кнопку Создать объект, чтобы зафиксировать поверхность.

Поверхность появится в окне модели, а соответствующая ей пиктограмма — в Дереве построения.


2.6.1.6. Поверхность по сети точек

Поверхность по сети точек — это сплайновая поверхность, построенная по точкам, условно образующим сеть, т.е. расположенным в несколько рядов с одинаковым количеством точек в каждом. Совпадение точек не допускается.

Направление U создаваемой поверхности совпадает с направлением добавления точек. Направление V — это направление добавления рядов. Таким образом, точки сети формируют ряды в направлениях U и V.

Рис. 2.6.11. Поверхность по сети точек

В этом разделе:

2.6.1.6.1. Создание поверхности по сети точек

2.6.1.6.2. Задание точек для поверхности по сети точек

2.6.1.6.3. Режим редактирования поверхности по сети точек

2.6.1.6.4. Построение сети точек по существующей поверхности

2.6.1.6.5. Самопересекающаяся поверхность


2.6.1.6.1. Создание поверхности по сети точек

Чтобы построить поверхность по сети точек, вызовите команду Поверхность по сети точек. На Панели свойств появятся элементы управления, показанные на рис. 2.6.12.

Рис. 2.6.12. Панель свойств при создании поверхности по сети точек

С помощью группы переключателей Тип выберите тип поверхности: По точкам или По полюсам. Поверхность по точкам непосредственно проходит через точки сети. Поверхность по полюсам проходит на некотором расстоянии от точек сети, которое определяется их весом. По умолчанию точкам присваивается единичный вес; в случае необходимости можно изменить веса точек, переключившись в режим редактирования поверхности (см. раздел 2.6.1.6.3).

Задайте точки поверхности (см. раздел 2.6.1.6.2).

На вкладке Свойства Панели свойств вы можете задать наименование и цвет создаваемой поверхности. Также на этой вкладке отображается название системы координат поверхности (о системе координат объекта — см. раздел 2.8.3.4).

Если требуется проверить поверхность на наличие самопересечений, включите опцию Проверка самопересечений.

Завершив задание точек и настроив свойства поверхности, нажмите кнопку Создать объект на Панели специального управления.

Кнопка Создать объект доступна, если введено целое количество рядов точек, начиная с двух.

В окне модели появится построенная поверхность, а в Дереве построения — ее пиктограмма.

Если опция Проверка самопересечений была включена, то в случае обнаружения самопересечений поверхность отмечается в Дереве построения как ошибочная — восклицательным знаком в красном кружке. О самопересечении поверхности см. раздел 2.6.1.6.5.


2.6.1.6.2. Задание точек для поверхности по сети точек

Чтобы задать точки поверхности, укажите в Дереве построения или в окне модели отдельные точечные объекты (перечень точечных объектов см. в табл. 2.1.7), группу точек (о группах точек см. раздел 2.5.3) или массив точек (о массивах см. раздел 2.7).

Указание объектов при включенной опции Ассоциировать приводит к формированию ассоциативной связи точек поверхности с этими объектами.

Вы можете создать точку, нажав кнопку Построение точки на Панели специального управления (подробнее см. раздел 2.5.2.11.1).

Указывать или создавать точки необходимо в порядке их расположения в ряду.

Номер следующей точки и общее количество точек сети отображаются в соответствующих полях Панели свойств.

Задав все точки первого ряда, нажмите кнопку Закончить ряд. После этого кнопка исчезает с Панели свойств. Количество точек во втором и последующих рядах принимается равным количеству точек в первом ряду.

Количество рядов и точек в ряду определяется автоматически, если была указана группа точек по поверхности или массив точек по параллелограммной сетке с отличным от 1 количеством экземпляров по обеим осям.

Укажите или создайте точки остальных рядов.

На экране отображается фантом создаваемой поверхности, фантом сети и стрелки направлений U и V.

Вы можете отменить задание одной или нескольких последних точек, используя кнопку Отменить указание на Панели специального управления. Чтобы отменить сразу все заданные точки, нажмите кнопку Указать заново.

Если задано целое количество рядов, начиная с двух, на Панели специального управления доступна кнопка Редактирование. Она позволяет перейти в режим редактирования поверхности (см. раздел 2.6.1.6.3).

Если ни одна точка сети не задана (т.е. сразу после вызова команды или после нажатия кнопки Указать заново), на Панели специального управления доступны кнопки:

– Читать из файла, позволяющая получить координаты точек, хранящиеся в файле данных (о файле данных см. Приложение VI); числа, записанные в файле, воспринимаются системой как координаты точек в декартовой системе координат, совпадающей с системой координат поверхности (о системе координат объекта — см. раздел 2.8.3.4),

– Сеть точек по поверхности, позволяющая построить поверхность по сети точек, которая аппроксимирует какую-либо из существующих в модели поверхностей (см. раздел 2.6.1.6.4).


2.6.1.6.3. Режим редактирования поверхности по сети точек

Для перехода в режим редактирования поверхности служит кнопка Редактирование на Панели специального управления. В режиме редактирования поверхности Панель свойств содержит элементы управления, показанные на рис. 2.6.13.

Рис. 2.6.13. Панель свойств в режиме редактирования поверхности по сети точек

При вызове команды редактирования ранее созданной поверхности переход в режим редактирования поверхности производится автоматически.

В режиме редактирования поверхности вы можете:

– изменять положение и вес точек, удалять и добавлять ряды,

– изменять порядок поверхности,

– включать и отключать замыкание поверхности.

Эти возможности подробно описаны ниже.

Кроме того, в режиме редактирования поверхности доступны группа переключателей Тип, управляющая типом поверхности, и опция Проверка самопересечений, управляющая проверкой поверхности на самопересечения.

Все изменения параметров поверхности отображаются на ее фантоме в окне модели.

Если после редактирования поверхности требуется продолжить задание точек сети, отожмите кнопку Редактирование. Если же нужно завершить построение поверхности, нажмите кнопку Создать объект.

Редактирование точек и рядов

Используя группу переключателей Выбор точек, выберите объект для редактирования.

– Активизируйте переключатель По одной точке, чтобы выделять точки по отдельности. Выделите точку для редактирования, щелкнув по ней мышью в окне модели.

• Чтобы задать новое положение точки, укажите новый точечный объект, или переместите точку мышью, или измените способ ее построения (подробнее — см. п. 3 раздела 2.5.2.11.2).

• Чтобы изменить вес точки (для поверхности По полюсам), задайте нужное значение в поле Вес.

– Активизируйте переключатель Ряд по направлению U или Ряд по направлению V, чтобы выделять ряды точек. Выделите ряд для редактирования, щелкнув по любой его точке мышью.

• Чтобы добавить еще один ряд по этому же направлению, активизируйте переключатель Вставить перед выбранным рядом или Вставить после выбранного ряда в группе Операции на Панели свойств. В сети точек появится новый ряд. Точки этого ряда считаются созданными способом По координатам (XYZ).

• Чтобы удалить ряд, активизируйте переключатель Удалить выбранный ряд в группе Операции.

• Чтобы изменить вес точек (для поверхности По полюсам), задайте нужное значение в поле Вес. Указанный вес получит каждая точка ряда.

Порядок поверхности в направлениях U и V

Порядок поверхности — один из параметров поверхности, определяющий ее форму. Подробно о порядке сплайновых кривых и поверхностей рассказано в разделе 3 Приложения IX.

Для задания порядка поверхности по параметрам U и V служат поля Порядок, U и Порядок, V.

Замыкание поверхности

Вы можете замкнуть поверхность по направлению U или по направлению V или по обоим направлениям. Для этого служат переключатели Замкнуть по U и Замкнуть по V.

Замыкание по тому или иному направлению возможно, если количество точек в этом направлении — три или больше.


2.6.1.6.4. Построение сети точек по существующей поверхности

Сеть точек может быть автоматически создана на основе существующей в модели поверхности. В качестве поверхности можно использовать:

– грань тела или поверхности,

– вспомогательную или координатную плоскость.

Чтобы построить точки, нажмите кнопку Сеть точек по поверхности на Панели специального управления, а затем укажите в окне модели поверхность.

Выбранная поверхность будет аппроксимирована сплайновой поверхностью по сети точек. Фантом этой поверхности и ее точки отобразятся в окне модели.

– Если в качестве поверхности выбрана вспомогательная или координатная плоскость, то аппроксимирующая поверхность совпадает с прямоугольником, показывающим эту плоскость в пространстве модели.

– Если в качестве поверхности выбрана грань, то аппроксимирующая поверхность совпадает с теоретической поверхностью грани (см. раздел 2 Приложения IX). Поэтому отверстия в выбранной грани игнорируются, а в некоторых случаях границы аппроксимирующей поверхности не совмещаются с контурами выбранной грани: поверхность перекрывает грань. Например, если выбранная грань представляет собой круг, то аппроксимирующая поверхность будет иметь форму квадрата, описанного около этого круга.

Аппроксимирующая поверхность всегда является сплайновой поверхностью, а ее границы, соответственно, — сплайновыми кривыми даже в том случае, если для аппроксимации указана плоскость или заведомо плоская грань с прямолинейными ребрами.


2.6.1.6.5. Самопересекающаяся поверхность

Самопересечение поверхности как математического объекта не является ошибкой. В то же время самопересечение грани детали — это ошибка моделирования, поскольку такую деталь нельзя изготовить.

В связи с этим самопересекающейся поверхности невозможно, например, придать толщину с помощью одноименной команды (см. раздел 2.3.6), так как результат будет заведомо представлять собой ошибочное тело. Однако, можно придать толщину участку поверхности, не имеющему самопересечений, отделив его от остальной поверхности с помощью усечения (см. раздел 2.6.2.1).

Еще пример: выдавливание до поверхности (см. раздел 2.3.2.5.4) невозможно, если сечение элемента проецируется на поверхность в той ее части, где она пересекается сама с собой. Если же сечение проецируется на участок поверхности, свободный от самопересечения, выдавливание выполняется.

В большинстве случаев поверхности создаются для дальнейшего использования в качестве граней тел, поэтому в команде Поверхность по сети точек и некоторых других имеется возможность проверки на самопересечение. Если проверка включена, то при наличии самопересечения поверхность отмечается в Дереве построения как ошибочная. Необходимость исправления данной ошибки, как видно из вышеизложенного, зависит от того, с какой частью поверхности планируется дальнейшая работа.


2.6.1.7. Поверхность по пласту точек

Поверхность по пласту точек — это сплайновая поверхность или многогранная поверхность, построенная по точкам, которые образуют в пространстве пласт, т.е. расположены так, что высота их габаритного параллелепипеда мала по сравнению с его длиной и шириной.

При выполнении команды Поверхность по пласту точек система интерпретирует пласт точек как сеть точек и уже по этой сети создает поверхность. Поэтому в случае построения сплайновой поверхности данную команду можно использовать как не требующий ручного указания точек эквивалент команды Поверхность по сети точек (см. раздел 2.6.1.6). Если же результат автоматического распознавания сети точек окажется неудовлетворителен, воспользуйтесь командой Поверхность по сети точек.

Результат работы команды Поверхность по пласту лучше, если точки пласта образуют регулярную сеть с четырехугольными ячейками.

Рис. 2.6.14. Пласт точек и построенная по нему поверхность

В этом разделе:

2.6.1.7.1. Создание поверхности по пласту точек

2.6.1.7.2. Задание точек для поверхности по пласту точек

2.6.1.7.3. Распознавание сети точек

2.6.1.7.4. Режим редактирования поверхности по пласту точек


2.6.1.7.1. Создание поверхности по пласту точек

Чтобы построить поверхность по пласту точек, вызовите команду Поверхность по пласту точек. На Панели свойств появятся элементы управления, показанные на рис. 2.6.15.

Рис. 2.6.15. Панель свойств при создании поверхности по пласту точек

С помощью группы переключателей Тип выберите тип поверхности:

– По точкам. Сплайновая поверхность, проходящая непосредственно через точки сети.

– По полюсам. Сплайновая поверхность, проходящая на некотором расстоянии от точек. Это расстояние определяется системой и не может быть изменено.

– Многогранная. Поверхность, проходящая непосредственно через точки сети. Каждая грань поверхности имеет треугольную форму.

Задайте точки поверхности (см. раздел 2.6.1.7.2).

Поле Порядок позволяет задать порядок поверхности. Подробно о порядке сплайновых кривых и поверхностей рассказано в разделе 3 Приложения IX.

Переключатели группы Способ служат для выбора способа распознавания сети точек. Способ распознавания сети определяет форму поверхности (см. раздел 2.6.1.7.3).

Если требуется проверить поверхность на наличие самопересечений, включите опцию Проверка самопересечений.

Если тип поверхности — многогранная, то поле Порядок и опция Проверка самопересечений недоступны.

На вкладке Свойства Панели свойств вы можете задать наименование и цвет создаваемой поверхности. Также на этой вкладке отображается название системы координат поверхности (о системе координат объекта — см. раздел 2.8.3.4).

Завершив задание точек и настроив свойства поверхности, нажмите кнопку Создать объект на Панели специального управления.

Кнопка Создать объект доступна, если указано три или более точек.

В окне модели появится построенная поверхность, а в Дереве построения — ее пиктограмма.

Если была включена опция Проверка самопересечений, то в случае обнаружения самопересечений поверхность отмечается в Дереве построения как ошибочная — восклицательным знаком в красном кружке. О самопересечении поверхности см. раздел 2.6.1.6.5


2.6.1.7.2. Задание точек для поверхности по пласту точек

Чтобы задать точки поверхности, укажите в Дереве построения или в окне модели отдельные точечные объекты (перечень точечных объектов см. в табл. 2.1.7), группы точек (о группах точек см. раздел 2.5.3) или массивы точек (о массивах см. раздел 2.7). Совпадение точек не допускается.

Указание точечного объекта или группы точек при включенной опции Ассоциировать приводит к формированию ассоциативной связи точки поверхности с этими объектами.

Вы можете создать точку, нажав кнопку Построение точки на Панели специального управления (подробнее см. раздел 2.5.2.11.1).

После задания третьей точки на экране появляется фантом поверхности. Точки нумеруются в порядке задания.

Кнопка Читать из файла позволяет получить координаты точек, хранящиеся в файле данных (о файле данных см. Приложение VI). Числа, записанные в файле, воспринимаются системой как координаты точек в декартовой системе координат, совпадающей с системой координат поверхности (о системе координат объекта см. раздел 2.8.3.4). Точки из файла добавляются к уже указанным точкам, и фантом перестраивается.

Вы можете отменить задание одной или нескольких последних точек, используя кнопку Отменить указание на Панели специального управления. Чтобы отменить сразу все заданные точки, нажмите кнопку Указать заново.

Если указана хотя бы одна точка поверхности, на Панели специального управления становится доступна кнопка Редактирование. Она позволяет перейти в режим редактирования поверхности (см. раздел 2.6.1.7.4).


2.6.1.7.3. Распознавание сети точек

Доступно три способа распознавания сети точек. Все они предполагают поиск ячеек сети — непосредственно в пространстве или в плоскости. На плоскость проецируются все точки пласта, а затем разыскиваются ячейки, образованные точками-проекциями.

Форма ячеек зависит от типа поверхности: ячейки поверхности По точкам или По полюсам четырехугольные, а ячейки Многогранной поверхности — треугольные.

Если ячейки в плоскости найдены, то на их основе выделяются ячейки в пространстве.

Треугольные ячейки можно найти всегда, а четырехугольные — нет.

Если ни в пространстве, ни в плоскости четырехугольные ячейки не найдены, то сеть строится так, чтобы каждый ряд одного направления проходил через точку пласта; во втором направлении сеть имеет два ряда.

Для выбора способа распознавания сети, образуемой точками пласта, служит группа переключателей Способ.

– При Автоматическом способе распознавания ячейки сети сначала разыскиваются в пространстве. Если ячейки в пространстве не найдены, то они разыскиваются в плоскости, положение которой определяется автоматически на основе взаиморасположения точек пласта.

– При способе В плоскости системы координат ячейки разыскиваются в плоскости XY указанной пользователем системы координат. При активизации данного переключателя на Панели свойств становится доступен список систем координат.

– При способе В плоскости экрана ячейки разыскиваются в плоскости, параллельной экрану, т.е. форма поверхности зависит от того, как расположена модель по отношению к наблюдателю. При активизации данного переключателя на Панели свойств появляется опция Фиксировать положение. Включение этой опции фиксирует поверхность в той форме, которая соответствует текущему положению модели. При отключенной опции поверхность перестраивается всякий раз после изменения ориентации модели. Обратите внимание на то, что форма поверхности (особенно многогранной) может резко измениться при относительно небольшом изменении положения модели.

Рекомендуется следующий порядок распознавания сети точек.

1. Используйте Автоматический способ распознавания.

2. Если результат автоматического распознавания неудовлетворителен, используйте способы В плоскости системы координат и В плоскости экрана, чтобы подобрать подходящую плоскость для проецирования точек.

3. Если с помощью этих способов не удается достичь нужной формы поверхности, отредактируйте пласт точек: постройте дополнительные точки (см. раздел 2.6.1.7.2), исключите или переместите точки (см. раздел 2.6.1.7.4).


2.6.1.7.4. Режим редактирования поверхности по пласту точек

Для перехода в режим редактирования поверхности служит кнопка Редактирование на Панели специального управления.

В режиме редактирования поверхности Панель свойств содержит элементы управления, показанные на рис. 2.6.13.

Рис. 2.6.16. Панель свойств в режиме редактирования поверхности по пласту точек

В режиме редактирования поверхности вы можете изменять положение точек, а также удалять точки. Для указания точки, подлежащей редактированию, щелкните по ней мышью в окне модели.

– Чтобы задать новое положение точки, укажите новый точечный объект, или переместите точку мышью, или измените способ ее построения (подробнее — см. п. 3 раздела 2.5.2.11.2).

– Чтобы удалить точку, нажмите кнопку Удалить точку на Панели специального управления.

Остальные элементы управления, доступные в режиме редактирования поверхности, работают так же, как при создании поверхности (см. раздел 2.6.1.7.1).

Все изменения параметров поверхности отображаются на ее фантоме в окне модели.

Если после редактирования поверхности требуется продолжить задание точек сети, отожмите кнопку Редактирование. Если же нужно завершить построение поверхности, нажмите кнопку Создать объект.


2.6.1.8. Поверхность по сети кривых

Поверхность по сети кривых — это сплайновая поверхность, построенная по двум взаимно пересекающимся семействам кривых. Точки пересечения кривых называются узлами сети.

Все кривые первого семейства считаются кривыми направления U, а все кривые второго семейства — кривыми направления V. Для какого-либо одного направления в качестве одной или обеих крайних кривых могут быть указаны точки.

Рис. 2.6.17. Поверхность по сети кривых.
u1, u2, u3 — кривые направления U; v1, v2, v3 — кривые направления V.
Узлы сети отмечены кружками

В этом разделе:

2.6.1.8.1. Кривые и точки сети

2.6.1.8.2. Создание поверхности по сети кривых

2.6.1.8.3. Сопряжение поверхности с другими поверхностями


2.6.1.8.1. Кривые и точки сети

Требования к взаиморасположению кривых и точек сети:

– Каждая кривая одного направления должна иметь по одной общей точке с каждой кривой другого направления.

– Не допускается касание кривых разных направлений.

– Кривые одного направления должны быть либо все замкнуты, либо все разомкнуты.

– В качестве одной или обеих крайних кривых какого-либо одного направления могут быть указаны точки. В этом случае все кривые другого направления должны проходить через точку (точки), указанную для данного направления.

Кривыми, образующими сеть, могут являться любые односегментные пространственные кривые, ребра и линии эскизов, а точками — любые точечные объекты.


2.6.1.8.2. Создание поверхности по сети кривых

Чтобы создать поверхность по сети кривых, вызовите команду Поверхность по сети кривых. На Панели свойств появятся элементы управления, показанные на рис. 2.6.18.

Рис. 2.6.18. Панель свойств при создании поверхности по сети кривых

Переключатель Направление U активизируется автоматически. Укажите объекты для направления U — кривые или кривые и точки в порядке их следования в сети. Как минимум для этого направления должны быть заданы две кривые, или одна кривая и точка, или одна кривая и две точки. Указанные объекты заносятся в список Кривые направления U на Панели свойств. В окне модели отображается фантом поверхности.

Для направления V можно не указывать ни одной кривой, указать одну кривую или несколько кривых. Если для направления U не были указаны точки, то можно указать точки для направления V.

Если для направления V задана одна кривая, то она должна проходить через крайние (начальные или конечные) точки всех кривых направления U.

Чтобы задать объекты для направления V, активизируйте на Панели свойств переключатель Направление V и укажите нужные объекты в порядке их следования в сети. Они заносятся в список Кривые направления V.

Над списками кривых находятся кнопки управления объектами списка.

– Чтобы изменить положение кривой в списке, выделите ее в списке и нажмите кнопку Переместить вверх или Переместить вниз.

– Чтобы добавить кривую перед или после определенной кривой в списке, выделите эту кривую в списке, нажмите кнопку Вставить перед кривой или Вставить после кривой, а затем укажите добавляемую кривую.

– Чтобы исключить какую-либо кривую из списка, выделите ее в списке и нажмите кнопку Удалить.

Если требуется быстро очистить оба списка кривых, нажмите кнопку Указать заново на Панели специального управления.

Переключатели Замкнуть по U и Замкнуть по V позволяют замкнуть поверхность. Замыкание поверхности по тому или иному направлению возможно, если все кривые данного направления замкнуты.

Если замыкание поверхности по какому-либо направлению возможно, то соответствующий этому направлению переключатель доступен.

Если требуется проверить поверхность на наличие самопересечений, включите опцию Проверка самопересечений.

Если создаваемая поверхность стыкуется с какой-либо существующей поверхностью, то можно задать условие сопряжения создаваемой поверхности с существующей. Для этого служит вкладка Сопряжения Панели свойств (см. раздел 2.6.1.8.3).

Все изменения формы поверхности отображаются на ее фантоме в окне модели.

На вкладке Свойства Панели свойств можно задать наименование и цвет создаваемой поверхности.

Завершив указание кривых и настроив свойства поверхности, нажмите кнопку Создать объект на Панели специального управления.

В окне модели появится построенная поверхность, а в Дереве построения — ее пиктограмма.

Границами построенной поверхности становятся крайние кривые или точки. Если для направления V не указано кривых (или указана одна кривая), то границы (или одна из границ) поверхности в этом направлении определяются автоматически.

Если опция Проверка самопересечений была включена, то в случае обнаружения самопересечений поверхность отмечается в Дереве построения как ошибочная — восклицательным знаком в красном кружке. О самопересечении поверхности см. раздел 2.6.1.6.5.


2.6.1.8.3. Сопряжение поверхности с другими поверхностями

Условия сопряжения поверхности с уже существующими в модели поверхностями задаются при создании или редактировании поверхности на вкладке Сопряжения Панели свойств (рис 2.6.19).

Рис. 2.6.19. Вкладка Сопряжения

Создаваемая поверхность может сопрягаться с существующими поверхностями вдоль своих границ. Чтобы сопряжение вдоль границы было возможно, эта граница должна представлять собой явно указанную кривую (т.е. не быть точкой и не определяться автоматически).

Границы поверхности, вдоль которых возможно сопряжение, называются границами сопряжения, а существующая в модели поверхность, с которой сопрягается создаваемая, — поверхностью сопряжения. Поверхность сопряжения должна полностью содержать границу сопряжения. В качестве поверхностей сопряжения могут использоваться:

– грани тел и поверхностей,

– вспомогательные и координатные плоскости.

Доступно три условия сопряжения: не задано, по касательной и перпендикулярно (см. раздел 6 Приложения IX).

Если сеть не содержит кривых в направлении, противоположном границе сопряжения (т.е. кривых, имеющих общие точки с границей сопряжения), то для этой границы возможен выбор любого из трех условий сопряжений.

Если же кривые противоположного направления есть, то для перпендикулярного сопряжения все они должны быть перпендикулярны поверхности сопряжения, а для сопряжения по касательной — касательны. Если кривые противоположного направления расположены произвольным образом по отношению к поверхности сопряжения, то возможно лишь сопряжение не задано.

В общем случае поверхность по сети кривых имеет 4 границы, поэтому группа Номер границы содержит 4 переключателя (см. рис. 2.6.19). Из них доступны только переключатели, соответствующие границам сопряжения. В окне модели рядом с этими границами отображаются их номера.

Чтобы задать условие сопряжения поверхности вдоль какой-либо из границ сопряжения, выполните следующие действия.

1. В группе Номер границы активизируйте переключатель, соответствующий нужной границе. Граница будет подсвечена в окне модели.

2. Укажите в окне модели поверхность сопряжения. Выбранный объект подсветится, а его название появится в поле Поверхность сопряжения.

3. Раскройте список Условие и выберите из него условие сопряжения. Условия, которые невозможно применить для текущей границы, недоступны.

Фантом создаваемой поверхности в окне модели перестроится согласно выбранному условию сопряжения, около номера границы появится обозначение условия сопряжения.


2.6.1.9. Линейчатая поверхность

Линейчатая поверхность образуется движением прямой линии в пространстве.

В КОМПАС-3D можно построить линейчатую поверхность по двум направляющим, одной из которых может служить точка. Примеры линейчатых поверхностей показаны на рисунке 2.6.20; направляющие-кривые выделены утолщенной линией, а направляющая-точка — кружком.

Рис. 2.6.20. Линейчатые поверхности: а) по направляющим — кривым, б) по направляющим — кривой и точке
а) | б)

В этом разделе:

2.6.1.9.1. Создание линейчатой поверхности

2.6.1.9.2. Управление разбиением поверхности на грани


2.6.1.9.1. Создание линейчатой поверхности

Чтобы создать линейчатую поверхность, вызовите команду Линейчатая поверхность. На Панели свойств появятся элементы управления для задания направляющих поверхности.

Направляющей может являться:

– пространственная кривая,

– линия эскиза,

– ребро,

– цепочка вышеперечисленных объектов в любом сочетании,

– точечный объект.

Объекты, относящиеся к пространственным кривым и точечным объектам, перечислены в таблице 2.1.7.

После вызова команды автоматически активизируется переключатель Кривая 1.

Укажите объект или объекты, которые должны использоваться в качестве первой направляющей. Цепочку пространственных кривых следует указывать в порядке их соединения. Название выбранного объекта или количество объектов (в случае указания цепочки) появятся в поле Кривая 1.

Активизируйте переключатель Кривая 2 и аналогичным образом укажите объект или объекты, которые должны использоваться в качестве второй направляющей.

На экране появится фантом поверхности с пронумерованными ребрами. Направляющие отмечены цифрами 1 и 2 в рамках.

Если требуется сменить какой-либо из объектов, активизируйте нужный переключатель и укажите этот объект заново.

Чтобы указать точку вместо кривой (кривых), необходимо сначала отменить выбор этой кривой (кривых) и наоборот.

Если требуется отменить выбор всех объектов, нажмите кнопку Указать заново на Панели специального управления.

Если требуется проверить поверхность на наличие самопересечений, включите опцию Проверка самопересечений.

Вкладка Разбиение Панели свойств позволяет настроить разбиение линейчатой поверхности на грани (см. раздел 2.6.1.9.2).

Вкладка Свойства позволяет задать наименование и цвет поверхности.

Завершив выбор направляющих и настройку свойств поверхности, нажмите кнопку Создать объект на Панели специального управления.

В окне модели появится построенная поверхность, а в Дереве построения — ее пиктограмма.

Если опция Проверка самопересечений была включена, то в случае обнаружения самопересечений поверхность отмечается в Дереве построения как ошибочная — восклицательным знаком в красном кружке. О самопересечении поверхности см. раздел 2.6.1.6.5.


2.6.1.9.2. Управление разбиением поверхности на грани

По умолчанию линейчатая поверхность разбивается на грани автоматически, т.е. количество «поперечных» ребер и положение их вершин определяется системой.

Если одна из направляющих — точка, а вторая — односегментная пространственная кривая, а также если обе направляющие являются такими кривыми, то поверхность имеет два крайних ребра — начальное и конечное. Если хотя бы одна из направляющих является многосегментной пространственной кривой или цепочкой кривых, поверхность разбивается на грани ребрами, каждое из которых выходит из вершины направляющей.

При необходимости вы можете отредактировать разбиение поверхности на грани. В примере, приведенном на рисунке 2.6.21, одно автоматически созданное ребро было удалено, а вершины двух других — совмещены с вершиной направляющей.

Рис. 2.6.21. Разбиение поверхности на грани: а) автоматическое, б) пользовательское
а) | б)

Настройка разбиения поверхности на грани выполняется на вкладке Разбиение Панели свойств.

Если на этой вкладке включена опция Автоопределение, то разбиение поверхности на грани производится автоматически. Если направляющие имеют одинаковое число вершин, можно включить опцию По вершинам — поверхность будет построена так, чтобы соответствующие вершины направляющих соединялись ребрами. При отключенной опции строится поверхность минимальной кривизны. Если количество вершин направляющих различно, состояние опции не влияет на форму поверхности.

Чтобы отредактировать разбиение, отключите опцию Автоопределение. На вкладке Разбиение появятся элементы управления разбиением (рис. 2.6.22).

Рис. 2.6.22. Вкладка Разбиение

Панель Список ребер содержит пронумерованный перечень ребер поверхности.

При выделении строки в Списке ребер соответствующее ей ребро подсвечивается в окне модели и наоборот — при указании ребра в окне соответствующая ему строка выделяется в списке.

Вы можете удалять и добавлять ребра, а также перемещать вершины ребер вдоль направляющих, при необходимости создавая или отменяя ассоциативную связь с вершинами направляющих. Все изменения отображаются на фантоме поверхности.

Отсутствие фантома — признак невозможности существования поверхности. Типовыми причинами этого являются:

– совпадение или пересечение ребер,

– отсутствие ребер, выходящих из промежуточных вершин направляющих.

Удаление ребра

1. Выделите ребро.

2. Нажмите кнопку Удалить ребро на панели Список ребер.

Выбранное ребро исчезает, а оставшиеся ребра нумеруются заново.

Удаление ребер невозможно, если в списке осталось два ребра.

Добавление ребра

1. Выделите ребро, перед которым или после которого требуется вставить новое ребро.

2. Нажмите кнопку Вставить перед текущим ребром или Вставить после текущего ребра.

Поверхность получает новое ребро со следующим по порядку номером.

Ассоциативная связь вершин ребер с точечными объектами. Перемещение вершин ребер

По умолчанию вершины ребер ассоциативно связываются с вершинами направляющих. При необходимости вы можете отменить эти связи и создать новые. Объектом для связи может являться вершина направляющей или точка, построенная на ней с помощью команды Точка (способы На кривой, Пересечение) или Группа точек по кривой.

Чтобы задать объект, с которым должна быть связана вершина ребра, выполните следующие действия.

1. Выделите ребро.

2. Выберите вершину ребра, активизировав нужный переключатель в группе Начальная/конечная вершина. Если вершина не связана, то при выделении ребра в ней отображается характерная точка. Для выбора такой вершины можно щелкнуть мышью по ее характерной точке.

3. Укажите в окне модели вершину направляющей или точку на ней, с которой должна быть связана выбранная вершина ребра. Вершина совместится с указанным объектом, а его название появится в поле Объект. Признаком связи вершины ребра с объектом является отображение «галочки» на кнопке Объект.

Чтобы отменить связь вершины с объектом, выделите ребро, выберите вершину, а затем нажмите кнопку Объект. «Галочка» на кнопке исчезнет.

Несвязанную вершину можно произвольно перемещать вдоль направляющей, «перетаскивая» мышью ее характерную точку.

Если пространственная кривая, используемая в качестве направляющей, скрыта, то привязка ребра к вершине направляющей невозможна.

Чтобы использовать не всю направляющую, а только ее участок, отмените связь вершины крайнего ребра с вершиной направляющей, а затем переместите вершину ребра вдоль направляющей или свяжите с другим объектом.

Если в качестве одной из направляющих используется точка, то группа переключателей Начальная/конечная вершина отсутствует, а признак наличия или отсутствия связи, отображаемый элементом Объект, относится к той вершине ребра, которая лежит на направляющей.


2.6.1.10. Заплатка

Заплатка — поверхность, ограниченная замкнутым контуром. Сегментами контура могут быть ребра тел и поверхностей, линии эскизов, пространственные кривые.

При указании сегментов следует учитывать следующее.

– Контур не должен иметь самопересечений.

– Если сегменты лежат в одной плоскости или на одной существующей поверхности, то их количество может быть любым, в противном случае — не менее двух и не более четырех.

Чтобы создать заплатку, вызовите команду Заплатка.

Укажите в окне модели сегменты контура в порядке их соединения.

Если контур, ограничивающий заплатку, расположен в одном эскизе, укажите этот эскиз в Дереве построения или в окне модели.

Выбранные объекты будут подсвечены в окне модели и в Дереве построения.

Список объектов, составляющих контур, появится на Панели свойств (рис. 2.6.23). Кнопка Удалить, расположенная над списком, позволяет исключить какой-либо объект из контура. Для исключения объекта можно также повторно указать его. Выделение с исключенного объекта будет снято.

Рис. 2.6.23.

Если требуется проверить поверхность на наличие самопересечений, включите опцию Проверка самопересечений.

Чтобы подтвердить выполнение операции, нажмите кнопку Создать объект на Панели специального управления.

Обратите внимание на то, что кнопка Создать объект доступна, если указанные объекты образуют замкнутую цепочку.

Созданная поверхность появится в окне модели, а соответствующая ей пиктограмма — в Дереве построения.

Если опция Проверка самопересечений была включена, то в случае обнаружения самопересечений поверхность отмечается в Дереве построения как ошибочная — восклицательным знаком в красном кружке. О самопересечении поверхности см. раздел 2.6.1.6.5.


2.6.1.11. Поверхность соединения

Вы можете построить поверхность, соединяющую две грани. Границами поверхности соединения являются указанные ребра или цепочки ребер соединяемых граней. Цепочка ребер должна удовлетворять следующим условиям:

– все ребра принадлежат одной грани,

– ребра имеют общую касательную в точках соединения.

Рис. 2.6.24. Поверхность, соединяющая две плоские грани

Поверхность соединения сопрягается с соединяемыми гранями вдоль границ. Доступно несколько вариантов сопряжения.

Возможно изменение формы соединительной поверхности с помощью параметра натяжения. Кроме того, можно управлять формой боковых ребер поверхности.

Для построения поверхности соединения выполните следующие действия.

1. Запустите операцию построения поверхности. Для этого нажмите кнопку Поверхность соединения на панели Поверхности или вызовите команду Операции — Поверхность —Поверхность соединения.

2. Система ожидает указания первой границы создаваемой поверхности — в группе Выбор границы на Панели свойств активен переключатель Граница 1.

Укажите в окне модели первую границу — ребро или цепочку ребер. Цепочку следует указывать в порядке соединения ребер. Название указанного ребра (или количество ребер в цепочке) появляется в поле Кривая границы 1. Граница подсвечивается в окне модели, около нее отображается номер и значок умолчательного условия сопряжения.

Задайте параметры поверхности соединения вдоль ее первой границы.

Рис. 2.6.25. Элементы управления параметрами поверхности соединения на Панели свойств

2.1. Поверхность сопряжения

В качестве поверхности сопряжения автоматически выбирается грань, которой принадлежат указанные ребра. Грань подсвечивается в окне модели, ее название появляется в поле Поверхность 1. Если ребра принадлежат одновременно двум граням, вы можете сменить грань. Для этого укажите нужную грань в окне модели.

2.2. Условие и направление сопряжения

Выберите условие сопряжения соединяющей поверхности с поверхностью сопряжения из списка Условие. Возможны следующие условия сопряжения: не задано, по касательной, перпендикулярно и гладкое (см. раздел 6 Приложения IX).

Переключатель Сменить направление позволяет сменить направление сопряжения на противоположное. При этом форма поверхности соединения вблизи границы меняется, а условие сопряжения остается прежним.

2.3. Натяжение

Этот параметр влияет на форму поверхности: чем натяжение больше, тем больше кривизна поверхности соединения вблизи границы, и наоборот, чем меньше натяжение, тем кривизна поверхности меньше. Натяжение задается в процентах от 0 до 100.

Задайте величину натяжения в поле Натяжение,%.

2.4. Положение боковых ребер

Боковые ребра поверхности соединения могут представлять собой продолжения боковых ребер соединяемых поверхностей, а могут быть перпендикулярны границе (рис. 2.6.26).

Рис. 2.6.26. Боковые ребра поверхности соединения: а) продолжения боковых ребер соединяемых поверхностей; б) перпендикулярны границам
а) | б)

Чтобы выбрать вариант построения боковых ребер у первой границы поверхности соединения, активизируйте нужный переключатель в группе Боковые ребра.

3. Если для второй границы требуется использовать то же значение натяжения, что для первой, включите опцию Общее натяжение. В этом случае при изменении натяжения на одной из границ автоматически меняется натяжение на другой.

4. Активизируйте в группе Выбор границы переключатель Граница 2. Укажите в окне модели вторую границу и задайте параметры соединения вдоль нее — так же, как первую границу и параметры соединения вдоль нее.

В окне модели появляется фантом поверхности соединения с текущими параметрами. Характерные точки фантома позволяют изменить натяжение поверхности на границах.

Вторая граница может принадлежать той же грани, что и первая — будет построена поверхность, соединяющая разные кромки одной грани.

5. Если требуется проверить поверхность на наличие самопересечений, включите опцию Проверка самопересечений.

6. При необходимости вы можете настроить разбиение поверхности соединения на грани — сдвинуть, добавить или удалить ребра поверхности. Для этого активизируйте вкладку Панели свойств Разбиение. Настройка разбиения поверхности соединения аналогична настройке разбиения линейчатой поверхности (см. раздел 2.6.1.9.2) с единственным исключением: при работе с поверхностью соединения отсутствует опция По вершинам.

7. При необходимости измените наименование и свойства создаваемой поверхности. Для этого активизируйте вкладку Свойства Панели свойств.

8. Подтвердите создание поверхности. Для этого нажмите кнопку Создать объект на Панели специального управления.

В окне модели появится построенная поверхность, а в Дереве построения — ее пиктограмма.

Если опция Проверка самопересечений была включена, то в случае обнаружения самопересечений поверхность отмечается в Дереве построения как ошибочная — восклицательным знаком в красном кружке. О самопересечении поверхности см. раздел 2.6.1.6.5.


2.6.1.12. Эквидистанта поверхности

Вы можете построить поверхность, эквидистантную базовой.

В качестве базовой поверхности могут использоваться следующие объекты:

– грань тела или поверхности;

– связная совокупность граней одного тела или поверхности (см. раздел 2.5.1).

Рис. 2.6.27. Эквидистантная поверхность: а) базовая поверхность — грань поверхности; б) базовая поверхность — совокупность граней
а) | б)

Для создания эквидистантной поверхности вызовите команду Эквидистанта поверхности.

Укажите базовую поверхность в окне модели.

Если в качестве базовой поверхности используются все грани тела или поверхности, то это тело или поверхность можно указать в Дереве построения.

Базовую поверхность можно указать и перед вызовом команды.

Повторное указание базовой поверхности отменяет ее выбор.

О выборе объектов подробно рассказано в разделе 2.1.4.1.1.

Название выбранного объекта или количество выбранных объектов отображается в поле Поверхность.

На экране появится фантом эквидистантной поверхности с характерной точкой для задания расстояния от базовой поверхности до создаваемой (о характерных точках см. раздел 2.1.4.2.2).

Чтобы указать, с какой стороны от базовой поверхности будет построена эквидистантная поверхность, активизируйте переключатель Прямое направление или Обратное направление в группе Направление.

Задайте расстояние от базовой поверхности до создаваемой, введя его в поле Расстояние на Панели свойств.

Все изменения параметров отображаются на фантоме создаваемой поверхности в окне модели.

Чтобы сменить базовую поверхность, нажмите кнопку Указать заново на Панели специального управления и повторите выбор объекта или объектов.

Вкладка Свойства позволяет задать наименование и цвет создаваемой поверхности.

Чтобы завершить построение эквидистантной поверхности, нажмите кнопку Создать объект на Панели специального управления.

В окне модели появится построенная поверхность, а в Дереве построения — ее пиктограмма.

При нулевом смещении эквидистантная поверхность представляет собой копию базовой. Таким способом можно создать необходимое количество копий поверхности, являющейся основой для нескольких тел или деталей.


2.6.2. Редактирование поверхностей

2.6. Поверхности

2.6.2. Редактирование поверхностей

В этом разделе:

2.6.2.1. Усечение поверхности

2.6.2.1.1. Требования к объектам операции усечения

2.6.2.1.2. Выполнение усечения

2.6.2.2. Разбиение поверхности

2.6.2.2.1. Требования к объектам операции разбиения

2.6.2.2.2. Выполнение разбиения

2.6.2.3. Продление поверхности

2.6.2.3.1. Тип продления

2.6.2.3.2. Способ продления

2.6.2.4. Сшивка поверхностей

2.6.2.5. Удаление граней

2.6.2.6. Тела с нарушенной целостностью


2.6.2.1. Усечение поверхности

Вы можете отсечь часть поверхности или сделать в ней вырез по форме объектов, лежащих на этой поверхности или пересекающих ее (рис. 2.6.28). Также вы можете сделать усечение по контуру, спроецированному на выбранную поверхность (см. рис. 2.6.29).

Рис. 2.6.28. Усечение поверхности при помощи другой поверхности: а) поверхности до усечения; б) результат усечения
а) | б)

В этом разделе:

2.6.2.1.1. Требования к объектам операции усечения

2.6.2.1.2. Выполнение усечения


2.6.2.1.1. Требования к объектам операции усечения

В качестве усекаемой поверхности может использоваться связная совокупность граней одного тела или одной поверхности. При указании объекта в Дереве построения усекаемая поверхность формируется изо всех граней этого объекта.

В качестве секущих могут использоваться объекты, представленные в таблице 2.6.1. Секущие объекты должны однозначно определять границу отсечения, т.е. полностью пересекать усекаемую поверхность.

В случае многогранной усекаемой поверхности граница отсечения также считается полностью определенной, если секущий объект пересекает не всю ее, а одну или несколько граней, но так, что крайние точки линии пересечения лежат на ребрах этих граней. В этом случае в границу отсечения входят ребра или части ребер поверхности, см. рис. 2.6.30.

Табл. 2.6.1. Секущие объекты при усечении поверхности

Секущий объект

Особенности использования

Координатная или вспомогательная плоскость

Усечение происходит по линии пересечения плоскости и усекаемой поверхности.

Связная совокупность граней одного тела или одной поверхности

Усечение происходит по линии пересечения секущего объекта и усекаемой поверхности.

При указании объекта в Дереве построения секущий объект формируется изо всех граней указанного.

Кривая, лежащая на усекаемой поверхности:

– пространственная кривая,

– ребро тела или поверхности,

– цепочка кривых или ребер.

Усечение происходит по кривой.

Пространственная кривая может быть секущим объектом только в случае, если она является непосредственно исходной или непосредственно производной 1 по отношению к усекаемой поверхности.

– Пример использования исходной кривой: усечение поверхности, построенной по сети кривых (см. раздел 2.6.1.8), по одной из этих кривых.

– Пример использования производной кривой: усечение поверхности по эквидистанте, построенной смещением вдоль усекаемой поверхности (об эквидистанте кривой см. раздел 2.5.4.17).

Эскиз

Усечение происходит по линии пересечения усекаемой поверхности с поверхностью, получаемой выдавливанием эскиза перпендикулярно его плоскости (см. рис. 2.6.29).

Эскиз должен быть указан в Дереве построения.

Эскиз может содержать один незамкнутый контур или несколько замкнутых контуров. Контуры не должны иметь самопересечений.
  1. Т.е. в иерархии отношений между кривой и усекаемой поверхностью не должно быть других объектов (о просмотре отношений объектов см. раздел 2.1.2.7.2).

О выборе объектов модели подробно рассказано в разделе 2.1.4.1.1.

Рис. 2.6.29. Пример усечения поверхности при помощи контура в эскизе: а) усекаемая поверхность и секущий объект, б) объекты после указания, в) результат усечения
а) | б) | в)

Рис. 2.6.30. Пример усечения трехгранной поверхности: а) усекаемая поверхность и секущий объект, б) результат усечения
а) | б)


2.6.2.1.2. Выполнение усечения

Чтобы усечь поверхность, вызовите команду Усечение поверхности. Команда доступна, если в модели есть хотя бы одна поверхность или одно тело.

На Панели свойств появятся элементы управления усечением (рис. 2.6.31).

Рис. 2.6.31. Панель свойств при усечении поверхности

Переключатель Поверхность активизируется автоматически. Укажите грани, составляющие усекаемую поверхность, в окне модели. Объект-поверхность или тело можно выбрать в Дереве построения.

Усекаемую поверхность можно указать и перед вызовом команды.

Чтобы задать объект, по линии пересечения с которым должна быть усечена поверхность, активизируйте переключатель Секущий объект.

Укажите секущие объекты в окне модели или в Дереве построения.

Если требуется усечь поверхность по изопараметрической кривой, то эту кривую можно построить, не выходя из процесса усечения. Для этого нажмите кнопку Изопараметрическая кривая на Панели специального управления. Будет запущена операция создания изопараметрической кривой на поверхности (см. раздел 2.5.4.18). Если усекаемая поверхность состоит из одной грани, то она выбирается автоматически, а если из нескольких, то следует указать грань, на которой должна располагаться кривая. Затем укажите на грани точку, выберите направление проходящей через нее изопараметрической кривой и нажмите кнопку Создать объект. Система вернется в процесс операции усечения, созданная кривая появится в Дереве построения и будет автоматически выбрана в качестве секущего объекта.

Усекаемая поверхность и секущий объект подсвечиваются, а их названия появляются в полях Поверхность и Секущий объект.

На линии пересечения объектов отображается стрелка, указывающая на ту часть поверхности, которая будет удалена.

Переключатель Сменить направление позволяет выбрать для удаления другую часть усекаемой поверхности.

Чтобы отказаться от использования объекта в качестве усекаемого или секущего, активизируйте переключатель Поверхность или Секущий объект соответственно, и укажите объект в окне модели повторно. Подсветка с объекта будет снята.

Чтобы отменить выбор всех объектов, нажмите кнопку Указать заново на Панели специального управления и повторите выбор объектов.

Наименование операции усечения можно изменить на вкладке Свойства Панели свойств.

Чтобы завершить усечение поверхности, нажмите кнопку Создать объект на Панели специального управления.

Кнопка Создать объект недоступна, если указанные объекты не удовлетворяют предъявляемым к ним требованиям (см. раздел 2.6.2.1.1).

Усеченная поверхность появляется в окне модели, а соответствующая ей пиктограмма — в Дереве построения.

Если в качестве усекаемого объекта было указано тело или его грани, то в результате усечения целостность тела может быть нарушена. Подробно о телах с нарушением целостности рассказано в разделе 2.6.2.6.


2.6.2.2. Разбиение поверхности

Вы можете разбить грани поверхности или тела на несколько новых граней. При этом модель приобретает дополнительные ребра, которые являются границами между вновь образованными гранями (рис. 2.6.32). Разбиение поверхности может производиться:

– по кривым, лежащим на поверхности,

– по линиям пересечения с другими поверхностями или плоскостями,

– по контурам, спроецированным на поверхность.

Рис. 2.6.32. Использование ребра, полученного разбиением грани: а) исходное состояние детали, б) результат построения скругления с сохранением кромки
а) | б)

В этом разделе:

2.6.2.2.1. Требования к объектам операции разбиения

2.6.2.2.2. Выполнение разбиения


2.6.2.2.1. Требования к объектам операции разбиения

В качестве разбиваемой поверхности может использоваться произвольный набор граней тел и/или поверхностей. При указании объекта в Дереве построения разбиваемая поверхность формируется изо всех граней этого объекта.

В качестве секущих могут использоваться объекты, представленные в таблице 2.6.2. Секущие объекты должны однозначно определять линию разбиения, т.е. полностью пересекать разбиваемую поверхность.

В случае многогранной усекаемой поверхности линия разбиения также считается полностью определенной, если секущий объект пересекает не всю ее, а одну или несколько граней, но так, что крайние точки линии пересечения лежат на ребрах этих граней. В этом случае в результате операции будут разбиты только эти грани.

Табл. 2.6.2. Секущие объекты при усечении поверхности

Секущий объект

Особенности использования

Координатная или вспомогательная плоскость; грань

– Усечение происходит по линии пересечения плоскости или грани с разбиваемой поверхностью.

– Возможно использование произвольного набора плоскостей и/или граней.

Кривая, лежащая на разбиваемой поверхности:

– проекционная,

– изопараметрическая,

– линия пересечения,

– линия очерка,

– сплайн на поверхности

– Усечение происходит по кривой.

– Возможно использование произвольного набора кривых.

– Кривые могут пересекаться, но не должны иметь самопересечений.

Эскиз

– Усечение происходит по линии пересечения усекаемой поверхности с поверхностью, получаемой выдавливанием эскиза перпендикулярно его плоскости.

– Возможно использование только одного эскиза.

– Объекты эскиза могут составлять произвольное количество замкнутых и/или разомкнутых контуров. Контуры могут пересекаться, но не должны иметь самопересечений.

О выборе объектов модели подробно рассказано в разделе 2.1.4.1.1.


2.6.2.2.2. Выполнение разбиения

Чтобы разбить грань (грани) тела или поверхности, вызовите команду Разбиение поверхности. Команда доступна, если в модели есть хотя бы одна поверхность или одно тело.

На Панели свойств появятся элементы управления разбиением (рис. 2.6.33).

Рис. 2.6.33. Панель свойств при разбиении поверхности

Переключатель Поверхность активизируется автоматически. Укажите грани, составляющие разбиваемую поверхность, в окне модели. Объект-поверхность или тело можно выбрать в Дереве построения.

Разбиваемую поверхность можно указать и перед вызовом команды.

Чтобы задать объект, по линии пересечения с которым должна быть разбита поверхность, активизируйте переключатель Секущий объект.

Укажите секущие объекты в окне модели или в Дереве построения.

Если требуется разбить поверхность по изопараметрической кривой, то эту кривую можно построить, не выходя из процесса разбиения. Для этого нажмите кнопку Изопараметрическая кривая на Панели специального управления. Будет запущена операция создания изопараметрической кривой на поверхности (см. раздел 2.5.4.18). Если разбиваемая поверхность состоит из одной грани, то она выбирается автоматически, а если из нескольких, то следует указать грань, на которой должна располагаться кривая. Затем укажите на грани точку, выберите направление проходящей через нее изопараметрической кривой и нажмите кнопку Создать объект. Система вернется в процесс операции разбиения, созданная кривая появится в Дереве построения и будет автоматически выбрана в качестве секущего объекта.

Разбиваемая поверхность и секущие объекты подсвечиваются, а их названия появляются в полях Поверхность и Секущий объект. В окне модели отображаются фантомы ребер, которые образуются при разбиении.

Если в качестве секущего объекта указан эскиз, на Панели свойств появляется группа переключателей Направление проецирования, позволяющая задать направление перемещения эскиза для образования секущей поверхности. Активизируйте нужный переключатель: Оба направления, Прямое направление или Обратное направление. Если выбрано перемещение эскиза в прямом или обратном направлении, то это направление показывается стрелкой на фантоме в окне модели.

В операции усечения участвуют все контуры указанного эскиза. Использование отдельных контуров невозможно.

Чтобы отказаться от использования объекта в качестве разбиваемого или секущего, активизируйте переключатель Поверхность или Секущий объект соответственно, и укажите объект в окне модели повторно. Подсветка с объекта будет снята.

Чтобы отменить выбор всех объектов, нажмите кнопку Указать заново на Панели специального управления и повторите выбор объектов.

Наименование операции разбиения можно изменить на вкладке Свойства Панели свойств.

Чтобы завершить разбиение поверхности, нажмите кнопку Создать объект на Панели специального управления.

Выбранные грани разбиваются на несколько граней, а в Дереве построения появляется пиктограмма операции разбиения поверхности.


2.6.2.3. Продление поверхности

Вы можете продлить грань поверхности или грань тела с нарушенной целостностью за пределы указанных кромок этой грани — открытых ребер (об открытых ребрах грани см. раздел 2.6.2.4).

Продление выполняется путем изменения положения указанных кромок или путем создания новых граней, примыкающих к указанным кромкам.

Грань продлевается за пределы указанных кромок на заданную длину или до указанного точечного объекта.

Рис. 2.6.34. Продление грани

Чтобы продлить грань, вызовите команду Продление поверхности.

Укажите в окне модели кромку грани или набор кромок. Если требуется продлить грань за пределы всех кромок, то укажите саму грань.

Кромки грани или саму грань можно указать в окне модели и перед вызовом команды.

На экране появится фантом продления с характерной точкой для задания величины удлинения грани (о характерных точках см. раздел 2.1.4.2.2).

Повторное указание объекта отменяет его выбор.

О выборе объектов подробно рассказано в разделе 2.1.4.1.1.

Название выбранного объекта или количество выбранных объектов отображается в поле рядом с переключателем Кромки на Панели свойств.

Группа переключателей Тип продления позволяет выбрать тип продления грани: той же поверхностью, по касательной или по направлению (см. раздел 2.6.2.3.1).

Раскрывающийся список Способ позволяет выбрать способ продления грани (см. раздел 2.6.2.3.2).

Все изменения отображаются на фантоме продления в окне модели.

Чтобы сменить объекты, используемые для продления грани, нажмите кнопку Указать заново на Панели специального управления и повторите выбор объектов.

Элементы управления, расположенные на вкладке Свойства Панели свойств, позволяют изменить название и цвет объекта.

Чтобы завершить продление грани, нажмите кнопку Создать объект на Панели специального управления.

В окне модели появится продление грани, а в Дереве построения — его пиктограмма.

В этом разделе:

2.6.2.3.1. Тип продления

2.6.2.3.2. Способ продления


2.6.2.3.1. Тип продления

Чтобы выбрать тип продления грани, активизируйте нужный переключатель в группе Тип продления (табл. 2.6.3).

Табл. 2.6.3. Типы продления
Тип продления | Результат построения
Той же поверхностью Данный тип продления грани выбран по умолчанию. В этом случае продление грани выполняется без добавления новых граней — грань удлиняется за пределы открытых ребер по своей теоретической поверхности (о теоретической поверхности см. раздел 2 Приложения IX). Возможен выбор варианта положения боковых ребер продления (см. ниже). |
По касательной Продление выполняется путем создания новых граней, касательных к исходной грани вдоль указанных кромок. Возможен выбор варианта положения боковых ребер продления (см. ниже). |
По направлению Продление выполняется путем создания новых граней, образованных перемещением указанных кромок в заданном направлении. Направление задается направляющим объектом или вектором (см. ниже). |

Положение боковых ребер продления

Если тип продления грани Той же поверхностью или По касательной, вы можете выбрать вариант положения его боковых ребер: продление исходных боковых ребер или продление по нормали к указанным кромкам.

Варианты положения боковых ребер показаны на рисунке 2.6.35. Пунктиром показана кромка, за которую продлена грань.

Рис. 2.6.35. Варианты положения боковых ребер: а) исходный объект, б) продление исходных боковых ребер, в) продление по нормали к указанным кромкам
а) | б) | в)

Для выбора положения боковых ребер продления служит группа переключателей Боковые ребра. Активизируйте нужный переключатель:

– Как продление исходных боковых ребер;

– По нормали к указанным кромкам.

Задание направления продления

Для продления грани по направлению в качестве направляющего объекта может использоваться любой прямолинейный или плоский объект.
Прямолинейные и плоские объекты перечислены в таблице 2.1.7.

Направление, задаваемое прямолинейным объектом — прямая, параллельная объекту.

Направление, задаваемое плоским объектом — прямая, перпендикулярная объекту.

Кроме того, направляющим объектом может служить вектор. Этот вектор можно создать при помощи команды Построение вектора (см. раздел 2.8.5).

Чтобы задать направление перемещения кромок, укажите в окне или Дереве построения направляющий объект или постройте вектор.

Наименование выбранного объекта отобразится в поле рядом с переключателем Направление. Если направление задано вектором, то в этом поле отобразится слово «Вектор».

Чтобы сменить направляющий объект, активизируйте переключатель Направление, а затем укажите нужный направляющий объект или постройте вектор.

Переключатель Сменить направление позволяет направить продление грани в противоположную сторону.


2.6.2.3.2. Способ продления

Доступны два способа продления грани:

– На заданную длину — грань удлиняется за указанные кромки на заданное расстояние;

– До вершины — грань удлиняется за указанные кромки до выбранного точечного объекта.

Для выбора способа продления служит список Способ на Панели свойств.

– Если выбран способ На заданную длину, на Панели свойств появляется поле Длина.
Введите нужное значение удлинения в это поле.

– Если выбран способ До вершины, на Панели свойств появляется элемент управления Вершина.
Укажите нужный точечный объект в окне модели (точечные объекты перечислены в таблице 2.1.7). Наименование выбранного объекта отобразится в поле рядом с переключателем.

Чтобы сменить точечный объект, активизируйте переключатель Вершина, а затем укажите нужный объект в окне модели.


2.6.2.4. Сшивка поверхностей

В КОМПАС-3D возможно соединение открытых ребер одной или нескольких поверхностей (рис. 2.6.36 а, б) с получением целой поверхности, а также присоединение поверхности (поверхностей) к открытым ребрам тела (рис. 2.6.36, в), целостность которого нарушена. Подробно о телах с нарушением целостности рассказано в разделе 2.6.2.6.

Рис. 2.6.36. Примеры открытых ребер (выделены черным цветом): а) поверхность вращения, б) поверхность выдавливания, в) тело с нарушенной целостностью
а) | б) | в)

Для соединения поверхностей вызовите команду Сшивка поверхностей.

Укажите в окне модели сшиваемые объекты. Они будут выделены цветом. Список сшиваемых объектов появится на Панели свойств. С помощью кнопок, расположенных над списком, вы можете менять порядок следования поверхностей и удалять их из списка.

Исключить какую-либо поверхность из числа сшиваемых можно также повторным указанием в окне модели.

В поле Точность на Панели свойств задайте максимальное расстояние между ребрами сшиваемых поверхностей.

Опция Создавать тело позволяет создать твердое тело, ограниченное сшиваемыми поверхностями. Если в списке сшиваемых поверхностей есть тело с нарушенной целостностью, опция Создавать тело включается автоматически, и ее выключение невозможно.

Чтобы подтвердить сшивку поверхностей, нажмите кнопку Создать объект на Панели специального управления. Если список сшиваемых поверхностей содержит всего один объект, то кнопка Создать объект доступна только при включенной опции Создавать тело.

Поверхности, расстояние между ближайшими ребрами которых меньше или равно заданному значению точности, будут объединены в одну. В Дереве построения появится пиктограмма сшивки.

Если было включено создание тела, то проводится проверка созданной поверхности на замкнутость. В случае положительного результата создается твердое тело, ограниченное полученной поверхностью, а в случае отрицательного — тело с нарушенной целостностью.


2.6.2.5. Удаление граней

Чтобы удалить грань (грани) поверхности или тела, вызовите команду Удалить грани.

Укажите в окне модели подлежащие удалению грани. Они будут выделены цветом.

Количество удаляемых граней отображается в одноименном поле на вкладке Параметры Панели свойств.

Чтобы исключить какую-либо грань из числа удаляемых, укажите ее в окне детали повторно. Выделение с этой грани будет снято.

Чтобы подтвердить удаление граней, нажмите кнопку Создать объект на Панели специального управления.

Указанные грани будут удалены из модели.

В Дереве построения появится пиктограмма удаления граней.

При удалении граней тел модель отмечается в Дереве как ошибочная. Причиной этого является нарушение целостности тел (см. раздел 2.6.2.6).


2.6.2.6. Тела с нарушенной целостностью

Целостность тела нарушается, если у него образуются открытые ребра, аналогичные открытым ребрам незамкнутых поверхностей (см. рис. 2.6.36).

К появлению в модели тел с нарушенной целостностью может привести:

– удаление граней тела при помощи команды Удалить грани (см. раздел 2.6.2.5);

– удаление части поверхности тела при помощи команды Усечение поверхности (см. раздел 2.6.2.1);

– сшивка поверхностей при помощи команды Сшивка поверхностей (см. раздел. 2.6.2.4), если при выполнении операции была включена опция Создавать тело, но соединяемые грани не образовали замкнутую поверхность.

Признаком нарушения целостности тела является появление в Дереве построения специальной пиктограммы взамен пиктограммы целого тела. При этом модель в Дереве отмечается как ошибочная.

Тела с нарушенной целостностью можно редактировать при помощи операций с поверхностями — продолжением, усечением и т.п.

Чтобы восстановить целостность, необходимо добавить поверхности, замыкающие тело, и соединить их при помощи команды Сшивка поверхностей.

Обратите внимание на то, что для достижения замкнутости открытое ребро одной поверхности следует стыковать с открытым ребром другой поверхности.

При восстановлении целостности пиктограмма в Дереве построения вновь заменяется на пиктограмму целого тела.

Отметка об ошибке в модели отображается до тех пор, пока целостность всех тел не будет восстановлена.


2.6.3. Сплайновая форма. Произвольное редактирование грани

2.6. Поверхности

2.6.3. Сплайновая форма. Произвольное редактирование грани

Вы можете отредактировать выбранную грань детали, преобразовав ее в сплайновую поверхность. Для этого используется специальный режим редактирования, позволяющий произвольно изменять форму и положение выбранной грани. На рисунке 2.6.37 приведен пример изменения формы грани в специальном режиме редактирования.

Рис. 2.6.37. Произвольное редактирование грани: а) исходное состояние грани, б) результат редактирования
а) | б)

Чтобы войти в режим редактирования грани, вызовите команду Сплайновая форма.

Вид компактной панели изменится. Она будет содержать кнопки переключения между двумя инструментальными панелями: Сплайновая форма (активна по умолчанию) и Фильтры. На инструментальной панели Сплайновая форма нажата кнопка Сплайновая форма, а на Панели свойств присутствуют кнопки Панели специального управления.

Укажите грань детали, которую требуется отредактировать.

Грань можно указать и перед вызовом команды Сплайновая форма.

Указанная грань преобразуется в сплайновую поверхность1 и подсвечивается (подробно о сплайновой поверхности см. раздел 3 Приложения IX). На экране появляется фантом сетки, построенной по параметрической области поверхности (см. раздел 2 Приложения IX). Сетка образована рядами точек — полюсов. Ряды сетки располагаются в двух направлениях — U и V. При изменении положения полюсов форма и/или положение грани могут изменяться.

При необходимости вы можете отредактировать не саму выбранную грань, а эквидистантную ей поверхность (см. раздел 2.6.3.5).

Обратите внимание на то, что при редактировании имеющейся грани могут изменяться формы границ соседних с ней граней, а эквидистантная поверхность является отдельным объектом, поэтому ее редактирование не изменяет границы граней детали.

В режиме редактирования грани вы можете выполнить следующие действия:

– изменить форму и положение грани, переместив полюсы с помощью команд инструментальной панели (см. раздел 2.6.3.1) или мышью (см. раздел 2.6.3.4),

– зафиксировать полюсы сетки и границы редактируемой грани (см. раздел 2.6.3.2),

– изменить параметры сплайновой поверхности (см. раздел 2.6.3.3).

Вы можете отменить выполненное действие или повторить последнее отмененное действие (см. раздел 1.4.1.6).

Кроме того, можно переопределить редактируемый объект — выбрать другую грань для редактирования, используя кнопку Указать заново Панели специального управления. Обратите внимание на то, что все изменения грани и ее эквидистанты, произведенные до перевыбора объекта, будут утеряны.

Чтобы завершить редактирование грани, нажмите кнопку Создать объект. Работа в режиме редактирования грани закончится, все изменения сохранятся. В Дереве построения появится пиктограмма операции Сплайновая форма.

Кнопка Прервать команду позволяет выйти из режима редактирования без сохранения изменений.

  1. В результате преобразования грань теряет исходные свойства. Например, после преобразования конической грани в сплайновую поверхность построение ее оси с помощью команды Ось конической поверхности становится невозможным.

В этом разделе:

2.6.3.1. Изменение положения полюсов

2.6.3.1.1. Выбор полюсов

2.6.3.1.2. Линейное перемещение полюсов

2.6.3.1.3. Перемещение полюсов со сглаживанием

2.6.3.1.4. Вращение полюсов

2.6.3.1.5. Масштабирование

2.6.3.1.6. Выравнивание полюсов

2.6.3.2. Фиксация полюсов

2.6.3.2.1. Фиксация полюсов, расположенных на границах сетки

2.6.3.2.2. Произвольная фиксация полюсов

2.6.3.2.3. Фиксация полюсов, обеспечивающих неизменность формы и положения ребер грани

2.6.3.3. Изменение параметров сплайновой поверхности

2.6.3.3.1. Порядок поверхности

2.6.3.3.2. Размерность сетки

2.6.3.4. Произвольное перемещение полюсов мышью

2.6.3.4.1. Приемы работы

2.6.3.4.2. Особенности задания направления перемещения полюсов

2.6.3.5. Построение сплайновой формы на эквидистанте грани

2.6.3.6. Особенности редактирования грани и эквидистанты грани


2.6.3.1. Изменение положения полюсов

Для изменения положения полюсов сетки используются следующие команды инструментальной панели Сплайновая форма:

– Линейное перемещение,

– Перемещение со сглаживанием,

– Вращение,

– Масштабирование,

– Выравнивание.

С помощью этих команд вы можете сместить отдельно взятые полюсы или все полюсы выбранного ряда. Подробная информация о выборе полюсов приведена в разделе 2.6.3.1.1.

При смещении полюсов форма и/или положение грани изменяются. Если новое положение полюсов не обеспечивает корректное изменение формы и положения грани, то грань остается в первоначальном состоянии (подробнее см. раздел 2.6.3.6).

В зависимости от используемой команды смещение полюсов определяется различными параметрами: величиной смещения, углом вращения, коэффициентом масштабирования и т.п. Однако для любой из указанных выше команд необходимо задать направление смещения. Типовые варианты направления смещения описаны в таблице 2.6.4. Специальные варианты, используемые в конкретных командах, приведены в разделах, описывающих работу с этими командами.

Табл. 2.6.4. Варианты направления смещения полюсов

Вариант

Описание

По оси X
По оси Y
По оси Z

Направление задается осью Х, Y или Z текущей системы координат (см. раздел 2.8.3.3).

Параллельно объекту

Направление задается указанием произвольного объекта одного из следующих типов: прямолинейный объект (см. табл. 2.1.7), цилиндр, конус, тор.

При выборе прямолинейного объекта направление совпадает с ним.

При выборе цилиндра, конуса или тора направление совпадает с его осью.

Укажите нужный объект в Дереве построения или в окне модели. Название объекта отображается в поле Направляющий объект.

При смещении полюсов вращением, масштабированием или выравниванием на Панели свойств присутствует переключатель Направляющий объект. Он позволяет при необходимости сменить направляющий объект.

Перпендикулярно объекту

Направление задается указанием произвольного плоского объекта (см. табл. 2.1.7) и совпадает с перпендикуляром к этому объекту. После выбора этого варианта укажите нужный объект в Дереве построения или в окне модели. Название объекта отображается в поле Направляющий объект.

При смещении полюсов вращением, масштабированием или выравниванием на Панели свойств присутствует переключатель Направляющий объект. Он позволяет при необходимости сменить направляющий объект.

По нормали

Направление задается нормалью к редактируемой грани, проходящей через смещаемый полюс.

В этом разделе:

2.6.3.1.1. Выбор полюсов

2.6.3.1.2. Линейное перемещение полюсов

2.6.3.1.3. Перемещение полюсов со сглаживанием

2.6.3.1.4. Вращение полюсов

2.6.3.1.5. Масштабирование

2.6.3.1.6. Выравнивание полюсов


2.6.3.1.1. Выбор полюсов

В зависимости от того, с помощью какой команды выполняется смещение или фиксация полюсов, смещаемые полюсы выбираются следующими способами.

– Чтобы выбрать полюсы для смещения командой Вращение, Масштабирование, Выравнивание, а также фиксации командой Фиксировать полюсы, выполните следующие действия.

Подведите курсор к нужному полюсу. Когда рядом с курсором появится символ вершины, щелкните мышью. Выбранный полюс подсветится. Выберите последовательно все нужные полюсы. Если требуется отменить выбор какого-либо полюса, повторно щелкните по нему мышью.

Вы можете выбирать как отдельные полюсы, так и ряды полюсов. Выбор ряда означает, что все полюсы этого ряда добавляются в набор выбранных полюсов.

Чтобы выбрать ряд полюсов, подведите курсор к сегменту этого ряда. Когда рядом с курсором появится символ пространственной кривой, щелкните мышью. Все сегменты выбранного ряда подсветятся. Повторный щелчок мышью по сегменту ряда отменяет выбор полюсов.

– Чтобы выбрать полюсы для смещения командой Линейное перемещение или Перемещение со сглаживанием, необходимо указывать полюсы или сегменты рядов полюсов, щелкая по ним мышью при нажатой клавише <Ctrl>. Повторный щелчок мышью при нажатой клавише <Ctrl> отменяет выбор полюса (ряда полюсов).

Полюсы выбранного ряда могут быть также выбраны по отдельности (до или после выбора ряда). Эти полюсы остаются выбранными после отмены выбора ряда.

Вы можете выбрать произвольное количество полюсов, указывая отдельные полюсы или ряды сетки.

Для выбора полюсов можно также использовать команды Выбрать все полюсы, Отменить выбор полюсов и Инвертировать выбор полюсов контекстного меню.


2.6.3.1.2. Линейное перемещение полюсов

Изменение положения полюсов сетки редактируемой грани может выполняться с помощью линейного перемещения (рис. 2.6.38).

Рис. 2.6.38. Перемещение полюсов: а) исходное состояние грани, б) перемещение отдельных полюсов по оси Z, в) перемещение рядов полюсов по оси Z, г) перемещение рядов полюсов в плоскости экрана
а) | б)
в) | г)

Выбранные полюсы перемещаются в заданном направлении в соответствии с определенными условиями перемещения.

Чтобы переместить полюсы, выполните следующие действия.

1. Вызовите команду Линейное перемещение. На Панели свойств появятся элементы управления, позволяющие задать параметры перемещения (рис. 2.6.39).

Рис. 2.6.39. Панель свойств при перемещении полюсов

2. Укажите полюсы, которые нужно переместить (см. раздел 2.6.3.1.1).

Линейное перемещение полюсов может выполняться вручную или автоматически.

Если требуется переместить вручную один полюс (один ряд полюсов), указание полюса (ряда полюсов) не требуется. Перемещение выполняется, как описано в п. 5 текущего раздела.

3. Выберите нужный вариант направления перемещения полюсов с помощью раскрывающегося списка Направление. Доступны следующие варианты:

• По оси Х,

• По оси Y,

• По оси Z,

• Параллельно объекту,

• Перпендикулярно объекту,

• По нормали,

• Вдоль многоугольника,

• В плоскости экрана.

Описание типовых вариантов направления перемещения (По оси Х, По оси Y, По оси Z, Параллельно объекту, Перпендикулярно объекту, По нормали) приведено в таблице 2.6.4.

При выборе варианта Вдоль многоугольника перемещение выполняется по направлению U или V сетки.

Вариант В плоскости экрана позволяет переместить полюсы в плоскости экрана.

После выбора варианта направления перемещения на Панели свойств появятся дополнительные элементы управления. Набор этих элементов и дальнейшие действия зависят от выбранного варианта.

4. Выполните дополнительные действия по настройке перемещения в соответствии с выбранным вариантом.

– По оси X/По оси Y/По оси Z — дополнительные действия не требуются.

– Параллельно объекту/Перпендикулярно объекту — укажите направляющий объект в Дереве построения или в окне модели. Наименование объекта отображается в поле Направляющий объект.

– По нормали — включите/отключите опцию От исходной.

Если опция включена, положение нормали рассчитывается относительно исходной формы редактируемой грани, если опция отключена — относительно текущей формы этой грани. Исходной формой грани считается та форма, которую имела грань на момент вызова команды Сплайновая форма.

– Вдоль многоугольника — выберите тип направления, активизировав переключатель По U или По V группы переключателей Тип. Возможны два варианта перемещения по каждому из направлений:

• К последующему,

• К предыдущему.

При выборе первого варианта полюс перемещается вдоль сегмента сетки, соединяющего этот полюс с полюсом, следующим за ним по направлению U/V, а при выборе второго — против направления U/V.

Активизируйте переключатель, соответствующий нужному варианту.

– В плоскости экрана — дополнительные действия не требуются.

5. Переместите выбранные полюсы вручную или автоматически.

Для ручного перемещения подведите курсор к одному из выбранных полюсов. Когда рядом с курсором появится символ вершины, нажмите левую кнопку мыши и, не отпуская кнопку, переместите мышь в нужное место. Затем отпустите кнопку.

Если в числе выбранных полюсов есть полюсы, которые выбирались указанием ряда, то вы можете подвести курсор к сегменту этого ряда. Когда рядом с курсором появится символ пространственной кривой, нажмите левую кнопку мыши и, не отпуская кнопку, переместите мышь в нужное место. Затем отпустите кнопку.

Если задано направление перемещения По нормали, перемещение полюсов за сегмент ряда невозможно.

Чтобы переместить полюсы автоматически, в поле Смещение введите расстояние, на которое переместятся полюсы. Оно может быть как положительным, так и отрицательным. После перемещения полюсов поле Смещение обнуляется.

Для направления перемещения В плоскости экрана доступно только ручное перемещение полюсов.

6. При ручном перемещении выбранных полюсов вы можете задать дополнительное условие перемещения, позволяющее переместить также некоторое количество соседних с выбранными полюсов сетки. Для этого используется список Условия. Задание условия подробно описано ниже.

7. Для завершения команды нажмите кнопку Создать объект.

Дополнительное условие перемещения полюсов

При ручном перемещении полюсов вы можете переместить не только выбранные полюсы, но и некоторое количество невыбранных полюсов, расположенных в тех же рядах, что и выбранные. Ряды могут располагаться по направлению U или V сетки, а также по обоим направлениям (см. рис. 2.6.40).

Рис. 2.6.40. Пропорциональное перемещение полюсов: а) в ряду по направлению U, б) в рядах по направлениям U и V
а) | б)

Полюсы перемещаются пропорционально в том же направлении, что и выбранные полюсы.

Расстояние, на которое перемещается каждый полюс, рассчитывается следующим образом.

Пусть P0 — выбранный полюс, перемещаемый вручную. Его перемещение L0 определяется пользователем.

Pi — полюс, пропорционально перемещаемый вместе с выбранным,

где i — порядковый номер полюса в ряду. Началом отсчета полюсов является выбранный полюс. Полюс, расположенный ближе всех к выбранному, имеет порядковый номер 1, следующий — 2 и т.д.

Количество полюсов, пропорционально перемещаемых вместе с выбранным, задается пользователем и равно n, то есть первый по порядку перемещаемый полюс — P1, а последний — Pn.

Перемещение Li полюса Pi определяется автоматически. Расчет производится по формуле:

Li = L0 · (n + 1 - i) / (n + 1)

Так, например, при пропорциональном перемещении 3 полюсов (рис. 2.6.41) перемещение каждого из них составит:

L1 = L0 · (3 + 1 - 1) / (3 + 1) = L0 · 3 / 4,

L2 = L0 · (3 + 1 - 2) / (3 + 1) = L0 · 1 / 2,

L3 = L0 · (3 + 1 - 3) / (3 + 1) = L0 · 1 / 4.

Рис. 2.6.41. Пропорциональное перемещение полюсов

Заданное количество n перемещаемых полюсов может превышать количество полюсов в ряду. В этом случае перемещаются только имеющиеся полюсы, но в расчете перемещения для каждого из них используется заданное количество n.

Чтобы настроить пропорциональное перемещение полюсов, выполните следующие действия.

1. Выберите из раскрывающегося списка Условия вариант Пропорционально. На Панели свойств появятся дополнительные элементы управления (рис. 2.6.42).

Рис. 2.6.42. Элементы настройки параметров пропорционального перемещения полюсов

2. Задайте направление отсчета пропорционально перемещаемых полюсов.

Количество пропорционально перемещаемых полюсов отсчитывается от выбранного полюса в ту или иную сторону. Направление отсчета в ряду задается отдельно для каждого направления сетки (U и V) с помощью раскрывающихся списков U и V. Доступны следующие варианты:

– Перед и после — количество перемещаемых полюсов отсчитывается в каждую сторону от выбранного полюса,

– Перед — количество перемещаемых полюсов отсчитывается от выбранного полюса против направления U/V,

– После — количество перемещаемых полюсов отсчитывается от выбранного полюса по направлению U/V,

– Не перемещать — перемещается только выбранный полюс, положение остальных полюсов ряда не изменяется.

Выберите нужный вариант из каждого раскрывающегося списка.

3. Введите количество перемещаемых полюсов в полях Перед и После отдельно для каждого направления сетки (U и V). Отображение полей зависит от выбранного варианта отсчета полюсов.

Если выбрано несколько полюсов, то заданное количество отсчитывается в ряду каждого из них.

4. Переместите вручную выбранные полюсы. При этом будет автоматически выполнено пропорциональное перемещение заданного количества полюсов.


2.6.3.1.3. Перемещение полюсов со сглаживанием

Изменение положения полюсов сетки редактируемой грани может выполняться с помощью перемещения со сглаживанием (рис. 2.6.43).

Рис. 2.6.43. Примеры перемещения полюсов со сглаживанием

Доступны следующие виды сглаживания (рис. 2.6.44):

– Плавный переход,

– Выпуклый,

– Вогнутый.

Рис. 2.6.44. Перемещение полюсов одного ряда со сглаживанием: а) исходное состояние грани, б) сглаживание вида Плавный переход, в) сглаживание вида Выпуклый, г) сглаживание вида Вогнутый
а) | б)
в) | г)

Выбранные полюсы перемещаются в определенном направлении, заданном пользователем. Для перемещения полюсов необходимо переместить мышью один из них. Перемещение остальных полюсов выполняется автоматически в том же направлении.

Расстояние, на которое перемещается каждый полюс, рассчитывается следующим образом.

Пусть P0 — полюс, перемещаемый мышью. Его перемещение L0 определяется пользователем.

Pi — произвольный полюс из числа выбранных,

где i — номер полюса.

Расчет перемещения Li полюса Pi производится автоматически по формуле:

Li = ki · L0,

где ki — коэффициент сглаживания для полюса Pi.

Для расчета коэффициента сглаживания используются следующие формулы:

ki = 1 - 3 · хi 2 + 2 · хi 3 — сплайновая функция, сглаживание вида Плавный переход,

ki = 1 - хi n — степенная функция, сглаживание вида Выпуклый,

ki = (1 - хi) n — степенная функция, сглаживание вида Вогнутый,

где n — натуральное число; диапазон значений аргумента хi [0;1].

Следовательно, формула расчета перемещения Li полюса Pi в зависимости от выбранного вида сглаживания будет иметь вид:

Li = (1 - 3 · хi 2 + 2 · хi 3) · L0, или

Li = (1 - хi n) · L0, или

Li = (1 - хi) n · L0.

В качестве аргумента хi используется расстояние от полюса, для которого выполняется расчет, до прямой, проходящей в направлении перемещения через полюс P0.

Так как диапазон значений аргумента хi [0;1], то расстояние до наиболее удаленного полюса Pmax принимается за единичный отрезок — хmax = 1. При этом расстояния до всех остальных полюсов (менее удаленных) принимают значения от 0 до 1.

При выполнении расчета для наиболее удаленного полюса Pmax получаем перемещение, равное нулю, т.е. этот полюс не перемещается. Перемещения всех остальных полюсов имеют значения, отличные от нуля.

Если среди выбранных полюсов есть несколько полюсов, расположенных на одинаковом расстоянии от прямой, проходящей в направлении перемещения через полюс P0, и данное расстояние является наибольшим, то ни один из этих полюсов не перемещается.

Пример перемещения со сглаживанием вида Плавный переход для 6 выбранных полюсов приведен на рис. 2.6.45.

Рис. 2.6.45. Перемещение полюсов со сглаживанием вида Плавный переход.
Первый из выбранных полюсов P0 перемещается мышью. Последний из выбранных полюсов P5 наиболее удален от прямой, проходящей в направлении перемещения через полюс P0. Перемещение полюса P5 равно нулю.

Выполнение перемещения со сглаживанием

1. Вызовите команду Перемещение со сглаживанием. На Панели свойств появятся элементы управления, позволяющие задать параметры перемещения (рис. 2.6.46).

Рис. 2.6.46. Панель свойств при перемещении полюсов со сглаживанием

2. Укажите полюсы, которые нужно переместить (см. раздел 2.6.3.1.1).

Если требуется переместить один полюс (один ряд полюсов), указание полюса (ряда полюсов) не требуется. Перемещение выполняется, как описано в п. 7 текущего раздела.

3. Выберите нужный вариант направления перемещения полюсов с помощью раскрывающегося списка Направление. Доступны следующие варианты:

• По оси Х,

• По оси Y,

• По оси Z,

• Параллельно объекту,

• Перпендикулярно объекту,

• По нормали.

Описание вариантов приведено в таблице 2.6.4.

После выбора нужного варианта на Панели свойств появляются дополнительные элементы управления. Набор этих элементов и дальнейшие действия зависят от выбранного варианта.

4. Выполните дополнительные действия по настройке перемещения в соответствии с выбранным вариантом.

– По оси X/По оси Y/По оси Z — дополнительные действия не требуются.

– Параллельно объекту/Перпендикулярно объекту — укажите направляющий объект в окне модели. Наименование объекта отображается в поле Направляющий объект.

– По нормали — включите/отключите опцию От исходной.

Если опция включена, положение нормали рассчитывается относительно исходной формы редактируемой грани, если опция отключена — относительно текущей формы этой грани. Исходной формой грани считается та форма, которую имела грань на момент вызова команды Сплайновая форма.

5. Выберите вид сглаживания, активизировав один из следующих переключателей группы Вид:

– Плавный переход,

– Выпуклый,

– Вогнутый.

6. Для варианта Выпуклый или Вогнутый введите значение степени n функции в поле Степень. Поле появляется на Панели свойств после выбора варианта.

7. Переместите выбранные полюсы. Для этого подведите курсор к одному из них. Когда рядом с курсором появится символ вершины, нажмите левую кнопку мыши и, не отпуская кнопку, переместите мышь в нужное место. Затем отпустите кнопку. Все выбранные полюсы (кроме полюса, наиболее удаленного от перемещаемого мышью) переместятся в соответствии с заданным видом сглаживания.

8. Для завершения команды нажмите кнопку Создать объект.


2.6.3.1.4. Вращение полюсов

Изменение положения полюсов сетки редактируемой грани может выполняться с помощью вращения (рис. 2.6.47).

Рис. 2.6.47. Вращение полюсов: а) исходное состояние грани, б) результат вращения
а) | б)

Вращение полюсов сетки выполняется вокруг оси, проходящей через центр вращения в заданном направлении. Плоскость вращения перпендикулярна оси вращения и проходит через вращаемый полюс.

На рис. 2.6.48 приведен пример перемещения полюса вращением. Направление оси вращения совпадает с осью Х текущей системы координат; Рнач. и Ркон. — начальное и конечное положения перемещаемого полюса.

Рис. 2.6.48. Вращение полюса

Чтобы переместить полюсы вращением, выполните следующие действия.

1. Вызовите команду Вращение. На экране отобразятся круговые стрелки. На Панели свойств появятся элементы управления, позволяющие задать параметры вращения (рис. 2.6.49).

Рис. 2.6.49. Панель свойств при вращении полюсов

2. Укажите полюсы, которые нужно повернуть (см. раздел 2.6.3.1.1).

3. Задайте направление оси вращения, выбрав из раскрывающегося списка Направление один из следующих вариантов:

– По оси Х,

– По оси Y,

– По оси Z,

– Параллельно объекту,

– Перпендикулярно объекту.

Описание вариантов приведено в таблице 2.6.4.

4. Укажите центр вращения. Для этого из раскрывающегося списка Центр выберите один из следующих вариантов:

– Нет,

– ЛСК,

– Центр объекта,

– Центр выбранных,

– Точка.

Описание вариантов приведено в таблице 2.6.5.

Табл. 2.6.5. Варианты задания центра вращения полюсов

Вариант

Описание

Нет

Центр не задается. Ось вращения совпадает с направляющим объектом либо с нормалью к этому объекту (для направления Перпендикулярно объекту).

ЛСК

Центр совпадает с началом текущей системы координат (см. раздел 2.8.3.3).

Центр объекта

Центр совпадает с центром масс редактируемой грани. Координаты центра масс рассчитываются для той формы грани, которую она имеет на момент редактирования.

Центр выбранных

Центр совпадает с центром масс выбранных полюсов. Для расчета центра масс полюсы представляются материальными точками одинакового веса.

Точка

При выборе этого варианта на Панели свойств присутствует переключатель Объект центра (активен по умолчанию), позволяющий указать произвольный точечный объект, в том числе один из полюсов сетки.

После указания объекта его название отображается в поле рядом с переключателем. Центр совпадает с указанным объектом.

5. В поле Угол введите значение угла вращения. Оно может быть как положительным — вращение в направлении, указанном стрелками, так и отрицательным — вращение в противоположном направлении.

Выбранные полюсы сетки переместятся в соответствии с заданными параметрами вращения.

6. При необходимости вы можете указать заново один из выбранных вручную объектов — полюс сетки или объект, определяющий параметры вращения. Для этого активизируйте нужный переключатель (например, для указания полюса должен быть активным переключатель Выбор полюсов) и укажите объект. Чтобы переопределить все выбранные вручную объекты, нажмите кнопку Указать заново Панели специального управления и повторите выбор, активизируя нужные переключатели.

7. Для завершения команды нажмите кнопку Создать объект.


2.6.3.1.5. Масштабирование

Изменение положения полюсов сетки редактируемой грани может выполняться с помощью масштабирования.

Для перемещения полюса масштабированием используются следующие способы (рис. 2.6.50):

– равномерное масштабирование,

– масштабирование по направлению,

– масштабирование в плоскости.

Рис. 2.6.50. Масштабирование полюсов: а) исходное состояние грани, б) равномерное масштабирование, в) масштабирование в плоскости, г) масштабирование по оси
а) | б)
в) | г)

Масштабирование выполняется следующим образом.

Равномерное масштабирование — полюс перемещается по прямой, соединяющей центр масштабирования с этим полюсом, пока расстояние между ним и центром масштабирования не увеличится в k раз, где k — коэффициент масштабирования.

На рис. 2.6.51 приведен пример перемещения полюса равномерным масштабированием.

Центр масштабирования выбран произвольно.

Рнач. и Ркон. — начальное и конечное положения перемещаемого полюса.

Lнач. и Lкон. — расстояния от полюса в его начальном и конечном положениях до центра масштабирования.

Рис. 2.6.51. Перемещение полюса при равномерном масштабировании

Масштабирование по направлению — полюс перемещается параллельно прямой, проходящей через центр масштабирования в заданном направлении, пока расстояние между его проекцией на эту прямую и центром масштабирования не увеличится в k раз, где k — коэффициент масштабирования.

На рис. 2.6.52 приведен пример перемещения полюса масштабированием по направлению.

Направление перемещения совпадает с осью Х текущей системы координат, т.е. полюс перемещается параллельно прямой, которая проходит через центр масштабирования параллельно оси Х. Центр масштабирования выбран произвольно.

Рнач. и Ркон. — начальное и конечное положения перемещаемого полюса.

Р ’нач. и Р ’кон. — проекции начального и конечного положений перемещаемого полюса на прямую, параллельно которой перемещается полюс.

Lнач. и Lкон. — расстояния от проекций полюса в его начальном и конечном положениях до центра масштабирования.

Рис. 2.6.52. Перемещение полюса при масштабировании по направлению,
направляющим объектом является ось Х

Масштабирование в плоскости — полюс перемещается параллельно прямой, соединяющей центр масштабирования и проекцию полюса на плоскость, проходящую через центр масштабирования параллельно заданному плоскому объекту. Перемещение выполняется до тех пор, пока расстояние между проекцией полюса и центром масштабирования не увеличится в k раз, где k — коэффициент масштабирования.

На рис. 2.6.53 приведен пример перемещения полюса масштабированием в плоскости.

Плоскость масштабирования параллельна плоскости XY текущей системы координат и проходит через центр масштабирования. Центр масштабирования выбран произвольно.

Рнач. и Ркон. — начальное и конечное положения перемещаемого полюса.

Р ’нач. и Р ’кон. — проекции начального и конечного положений перемещаемого полюса на плоскость масштабирования. Прямая, параллельно которой перемещается полюс, проходит через центр масштабирования и проекцию начального положения полюса Р ’нач..

Lнач. и Lкон. — расстояния от проекций полюса в его начальном и конечном положениях до центра масштабирования.

Рис. 2.6.53. Перемещение полюса при масштабировании в плоскости,
плоскостью масштабирования является плоскость XY

Чтобы переместить полюсы масштабированием, выполните следующие действия.

1. Вызовите команду Масштабирование. На Панели свойств появятся элементы управления, позволяющие задать параметры масштабирования (рис. 2.6.54).

Рис. 2.6.54. Панель свойств при перемещении полюсов масштабированием

2. Укажите полюсы, которые нужно переместить (см. раздел 2.6.3.1.1).

3. В поле Коэффициент введите коэффициент масштабирования. Выбранные полюсы переместятся в соответствии с заданным коэффициентом в направлении, которое определяется способом и центром масштабирования, заданными по умолчанию.

4. Выберите нужный способ масштабирования из раскрывающегося списка Способ. Доступны следующие варианты.

– Для равномерного масштабирования — вариант Равномерное (выбран по умолчанию).

– Для масштабирования по направлению:

• По оси Х,

• По оси Y,

• По оси Z,

• Параллельно объекту,

• Перпендикулярно объекту.

Описание вариантов приведено в таблице 2.6.4.

– Для масштабирования в плоскости:

• В плоскости ХY,

• В плоскости ZХ,

• В плоскости ZY,

• В выбранной плоскости.

При выборе одного из первых трех вариантов автоматически выбирается соответствующая ему координатная плоскость текущей системы координат (см. раздел 2.8.3.3).

Вариант В выбранной плоскости позволяет указать произвольный плоский объект (см. табл. 2.1.7) в Дереве построения или в окне модели. При этом на Панели свойств находится переключатель Направляющий объект (активен по умолчанию). Укажите нужный объект. Его название отображается в поле рядом с переключателем.

5. Укажите центр масштабирования. Для этого из раскрывающегося списка Центр выберите один из следующих вариантов:

– ЛСК,

– Центр объекта,

– Центр выбранных,

– Точка.

Описание вариантов приведено в таблице 2.6.5.

После задания всех параметров масштабирования выбранные полюсы займут требуемое положение.

6. При необходимости вы можете указать заново выбранные вручную объекты — полюсы сетки или объекты, определяющие параметры масштабирования. Для указания нужного объекта активизируйте соответствующий ему переключатель (например, для указания полюсов должен быть активным переключатель Выбор полюсов). Если требуется переопределить все выбранные вручную объекты, нажмите кнопку Указать заново Панели специального управления и повторите выбор объектов, активизируя нужные переключатели.

7. Для завершения масштабирования нажмите кнопку Создать объект.


2.6.3.1.6. Выравнивание полюсов

Изменение положения полюсов сетки редактируемой грани может выполняться с помощью выравнивания.

Доступны два способа выравнивания полюсов сетки — По направлению (рис. 2.6.55) и По плоскому объекту (рис. 2.6.56).

В первом случае выбранный полюс перемещается на прямую, проходящую через центр выравнивания в заданном направлении. Перемещение производится перпендикулярно прямой.

Во втором случае выбранный полюс перемещается на плоскость, параллельную заданной плоскости и проходящую через центр выравнивания. Перемещение производится перпендикулярно плоскости.

Рис. 2.6.55. Выравнивание полюсов по направлению: а) исходное состояние грани, б) результат выравнивания
а) | б)

Рис. 2.6.56. Выравнивание полюсов по плоскому объекту: а) исходное состояние грани, б) результат выравнивания
а) | б)

Чтобы переместить полюс (ряд полюсов) выравниванием, выполните следующие действия.

1. Вызовите команду Выравнивание. На Панели свойств появятся элементы управления, позволяющие задать параметры выравнивания (рис. 2.6.57).

Рис. 2.6.57. Панель свойств при перемещении полюсов выравниванием

2. Укажите полюсы, которые нужно переместить (см. раздел 2.6.3.1.1). Выбранные полюсы переместятся в соответствии с умолчательными параметрами выравнивания.

3. Выберите способ выравнивания из раскрывающегося списка Способ.

4. Задайте направление или плоскость выравнивания.

– Для выравнивания по направлению задайте направление с помощью одноименного раскрывающегося списка. Доступны следующие варианты:

• По оси Х,

• По оси Y,

• По оси Z,

• Параллельно объекту,

• Перпендикулярно объекту.

Описание вариантов приведено в таблице 2.6.4.

– Для выравнивания по плоскому объекту выберите плоскость с помощью одноименного раскрывающегося списка. Доступны следующие варианты:

• Плоскость ХY,

• Плоскость ZХ,

• Плоскость ZY,

• Выбранная плоскость.

При выборе одного из первых трех вариантов автоматически выбирается соответствующая ему координатная плоскость текущей системы координат (см. раздел 2.8.3.3).

Вариант Выбранная плоскость позволяет указать произвольный плоский объект (см. табл. 2.1.7) в Дереве построения или в окне модели. При этом на Панели свойств находится переключатель Плоский объект (активен по умолчанию). Укажите нужный объект. Его название отображается в поле рядом с переключателем.

5. Укажите центр выравнивания. Для этого из раскрывающегося списка Центр выберите один из следующих вариантов:

– Нет,

– ЛСК,

– Центр объекта,

– Центр выбранных,

– Точка.

При выборе варианта Нет центр выравнивания не задается. Прямая (плоскость), на которую перемещаются полюсы при выравнивании, совпадает с выбранным прямолинейным (плоским) объектом или нормалью к этому объекту (для варианта Перпендикулярно объекту).

Описание остальных вариантов указания центра выравнивания приведено в таблице 2.6.5.

После задания всех параметров выравнивания выбранные полюсы займут требуемое положение.

6. При необходимости вы можете указать заново выбранные вручную объекты — полюсы сетки или объекты, определяющие параметры выравнивания. Для указания нужного объекта активизируйте соответствующий ему переключатель (например, для указания полюсов должен быть активным переключатель Выбор полюсов). Если требуется переопределить все выбранные вручную объекты, нажмите кнопку Указать заново Панели специального управления и повторите выбор объектов, активизируя нужные переключатели.

7. Для завершения выравнивания нажмите кнопку Создать объект.


2.6.3.2. Фиксация полюсов

При редактировании грани может потребоваться, чтобы некоторые полюсы сетки были неподвижны — зафиксированы.

Для фиксации полюсов вызовите команду Фиксировать полюсы инструментальной панели Сплайновая форма. На Панели свойств появятся элементы управления, позволяющие выполнить фиксацию (рис. 2.6.58).

Рис. 2.6.58. Панель свойств при фиксации полюсов

Доступны следующие способы фиксации:

– фиксация полюсов, расположенных на границах сетки (в ее крайних рядах),

– произвольная фиксация полюсов,

– фиксация полюсов, обеспечивающих неизменность формы и положения ребер грани.

Вы можете фиксировать полюсы одним или несколькими способами одновременно. Порядок фиксации полюсов описан ниже.

Для завершения фиксации полюсов нажмите кнопку Создать объект.

Зафиксированные полюсы отображаются на экране кружками увеличенного диаметра.

В этом разделе:

2.6.3.2.1. Фиксация полюсов, расположенных на границах сетки

2.6.3.2.2. Произвольная фиксация полюсов

2.6.3.2.3. Фиксация полюсов, обеспечивающих неизменность формы и положения ребер грани


2.6.3.2.1. Фиксация полюсов, расположенных на границах сетки

Полюсы, расположенные на границах сетки, фиксируются с помощью групп переключателей Границы вдоль U (для границ сетки, расположенных вдоль направления U) и Границы вдоль V (для границ сетки, расположенных вдоль направления V), показанных на рисунке 2.6.58.

По умолчанию ни одна из границ сетки не зафиксирована, поэтому в группах активны переключатели Нет фиксации. Чтобы зафиксировать полюсы нужных границ, используйте следующие переключатели:

– Обе границы сетки,

– Первая граница сетки,

– Вторая граница сетки.

В режиме редактирования грани вы можете включить или отключить фиксацию всех границ сетки, не вызывая команду Фиксировать полюсы. Для этого используется команда Зафиксировать границы сетки/Расфиксировать границы сетки контекстного меню. Вызов команды автоматически активизирует переключатели фиксации границ в команде Фиксировать полюсы:

– команда Зафиксировать границы сетки — переключатели Обе границы сетки,

– команда Расфиксировать границы сетки — переключатели Нет фиксации.


2.6.3.2.2. Произвольная фиксация полюсов

Если требуется зафиксировать полюсы сетки, расположенные произвольно, включите опцию Выбор полюсов и укажите нужные полюсы или ряды полюсов, щелкая по ним мышью (подробнее выбор полюсов описан в разделе 2.6.3.1.1). Полюсы могут располагаться в любом ряду сетки, в том числе и на ее границе.

Отмена фиксации отдельно взятого полюса (ряда полюсов) выполняется повторным щелчком мыши по этому полюсу (ряду полюсов). Чтобы отменить фиксацию всех полюсов, зафиксированных данным способом, отключите опцию Выбор полюсов.

В режиме редактирования грани вы можете включить или отключить выбор полюсов для фиксации, не вызывая команду Фиксировать полюсы. Для этого используется команда Фиксировать полюсы с Shift контекстного меню. Вызов этой команды позволяет выбирать фиксируемые полюсы при нажатой клавише <Shift>; повторный вызов — отменяет фиксацию. При этом автоматически изменяется состояние опции Выбор полюсов в команде Фиксировать полюсы.


2.6.3.2.3. Фиксация полюсов, обеспечивающих неизменность формы и положения ребер грани

2.6.3.2.3. Фиксация полюсов, обеспечивающих неизменность формы
и положения ребер грани

При редактировании грани может потребоваться сохранение формы и положения некоторых или всех ее ребер в неизменном виде. Это обеспечивается фиксацией полюсов сетки, влияющих на форму и положение этих ребер.

Чтобы выполнить фиксацию, включите опцию Выбор ребер грани и последовательно укажите все нужные ребра, щелкая по ним мышью.

Выбранные ребра подсвечиваются, все полюсы сетки, влияющие на форму и положение этих ребер, автоматически фиксируются.

Для отмены фиксации полюсов, обеспечивающих неизменность формы и положения одного из выбранных ребер, повторно щелкните мышью по этому ребру. Если требуется отменить фиксацию полюсов для всех выбранных ребер, отключите опцию Выбор ребер грани.


2.6.3.3. Изменение параметров сплайновой поверхности

Для изменения формы грани, преобразованной в сплайновую поверхность (см. раздел 3 Приложения IX), используется сетка, которая образована рядами контрольных точек (полюсов). Полюсы сетки расположены в двух направлениях: U и V.

По умолчанию сетка имеет размерность 6х6 (т.е. количество полюсов сетки по каждому из направлений равно 6) и порядок поверхности, равный 4.

Если редактируемая грань изначально является сплайновой поверхностью, то размерность сетки и порядок поверхности равны соответственно размерности и порядку грани.

Вы можете изменять порядок поверхности и количество ее полюсов, используя следующие команды инструментальной панели Сплайновая форма:

– Порядок,

– Сетка.

Работа с командами подробно описана ниже.

В этом разделе:

2.6.3.3.1. Порядок поверхности

2.6.3.3.2. Размерность сетки


2.6.3.3.1. Порядок поверхности

Чтобы изменить порядок поверхности, вызовите команду Порядок.

На Панели свойств появятся поля Порядок по U и Порядок по V, позволяющие задать нужное значение порядка по каждому из направлений сетки (рис. 2.6.59).

Рис. 2.6.59. Панель свойств при изменении порядка сетки

Введите значения в эти поля или задайте их с помощью счетчика. Значение в поле не может быть меньше 3.

Кроме того, вы можете изменить количество полюсов сетки. Для этого включите опцию Новая сетка. На Панели свойств появятся дополнительные элементы управления (рис. 2.6.60).

Рис. 2.6.60. Задание количества полюсов сетки

Введите нужные значения в поля Количество точек по U и Количество точек по V и нажмите кнопку Разбить заново. Сетка, отображаемая на экране, перестроится. Количество ее полюсов будет соответствовать заданным значениям.

Аналогичным образом можно изменить количество полюсов сетки при работе с командой Сетка.

Обратите внимание на то, что количество полюсов сетки по выбранному направлению не может быть меньше порядка поверхности, заданного по этому направлению. Поэтому при увеличении порядка количество полюсов автоматически увеличивается. Уменьшение порядка не изменяет количество полюсов.

Для завершения команды нажмите кнопку Создать объект.

Кнопка Прервать команду позволяет отказаться от произведенных изменений.


2.6.3.3.2. Размерность сетки

Чтобы сгустить или разредить сетку — изменить ее размерность, вызовите команду Сетка. На Панели свойств появятся элементы настройки сетки (рис. 2.6.61).

Рис. 2.6.61. Панель свойств при изменении размерности сетки

Вы можете изменить размерность сетки двумя способами: добавив или удалив ее ряды; задав нужное количество полюсов сетки.

Чтобы добавить новый ряд, укажите один из рядов сетки. Для этого щелкните мышью по сегменту сетки между двумя полюсами нужного ряда. В группе Операции нажмите кнопку Вставить перед выбранным рядом или Вставить после выбранного ряда. Новый ряд будет расположен в том же направлении, что и выбранный.

Чтобы удалить ряд, выберите его и нажмите кнопку Удалить выбранный ряд группы Операции.

Кроме того, вы можете изменить количество полюсов сетки, используя опцию Новая сетка. После включения опции на Панели свойств появятся дополнительные элементы управления.

Введите нужные значения в поля Количество точек по U и Количество точек по V и нажмите кнопку Разбить заново. Сетка, отображаемая на экране, перестроится. Количество ее полюсов будет соответствовать заданным значениям.

Аналогичным образом можно изменить количество полюсов сетки при работе с командой Порядок.

При необходимости вы можете записать координаты полюсов сетки в файл данных. Для этого нажмите кнопку Сохранить в файл на Панели специального управления и укажите имя файла и папку для сохранения в появившемся диалоге. По умолчанию файлу присваивается расширение txt. Подробная информация о файле данных приведена в Приложении VI.

Для завершения настройки сетки нажмите кнопку Создать объект.

Кнопка Прервать команду позволяет отказаться от произведенных изменений.


2.6.3.4. Произвольное перемещение полюсов мышью

В режиме редактирования грани вы можете перемещать один или несколько полюсов сетки мышью, а также фиксировать полюсы, которые перемещать не требуется.

Способы перемещения и фиксации полюсов описаны ниже.

При необходимости можно отменять произведенные действия и повторять действия, которые были отменены (см. раздел 1.4.1.6).

В этом разделе:

2.6.3.4.1. Приемы работы

2.6.3.4.2. Особенности задания направления перемещения полюсов


2.6.3.4.1. Приемы работы

Для перемещения полюсов мышью используются следующие способы.

– Чтобы переместить один полюс, подведите к нему курсор. Когда рядом с курсором появится символ вершины, нажмите левую кнопку мыши и, не отпуская кнопку, переместите мышь в нужное место. Затем отпустите кнопку.

– Чтобы переместить все полюсы одного из рядов сетки, подведите курсор к сегменту этого ряда. Когда рядом с курсором появится символ пространственной кривой, нажмите левую кнопку мыши и, не отпуская кнопку, переместите мышь в нужное место. Затем отпустите кнопку.

– Чтобы переместить несколько полюсов, предварительно выделите их мышью при нажатой клавише <Ctrl>. Аналогичное выделение сегмента сетки добавляет в набор выделенных полюсов все полюсы ряда, содержащего этот сегмент. Повторный щелчок мышью при нажатой клавише <Ctrl> по выделенному полюсу (ряду полюсов) отменяет выделение.

– Чтобы переместить все полюсы сетки, выделите их с помощью команды контекстного меню Выбрать все полюсы или сочетания клавиш <Ctrl>+<А>. Команда Отменить выбор полюсов контекстного меню отменяет выделение всех полюсов сетки. Если требуется отменить выделение только некоторых из них, щелкните мышью при нажатой клавише <Ctrl> по нужным полюсам (рядам полюсов).

При необходимости вы можете инвертировать выделение полюсов сетки, вызвав из контекстного меню команду Инвертировать выбор полюсов. При этом с выделенных полюсов выделение снимается, выделяются все остальные полюсы.

При перемещении полюсов форма и/или положение грани изменяются. Если новое положение полюсов не обеспечивает корректное изменение формы и положения грани, то грань остается в первоначальном состоянии (подробнее см. раздел 2.6.3.6).

Обратите внимание на то, что перемещать можно только незафиксированные полюсы сетки. Зафиксированные полюсы, даже если они выделены, не перемещаются.

Для фиксации полюсов сетки используются следующие команды контекстного меню.

– Фиксировать границы — позволяет зафиксировать все полюсы, расположенные на границах сетки. Для снятия фиксации используется команда Расфиксировать границы.

– Режим фиксации полюсов — позволяет зафиксировать произвольные полюсы сетки. После вызова команды полюсы выделяются щелчком мыши при нажатой клавише <Shift>. Аналогичное выделение сегмента сетки добавляет в набор зафиксированных полюсов все полюсы ряда, содержащего этот сегмент. Если требуется отменить фиксацию какого-либо полюса (ряда полюсов), повторно щелкните по нему мышью при нажатой клавише <Shift>. Чтобы отменить фиксацию всех полюсов сетки, повторно вызовите команду Режим фиксации полюсов.

Зафиксировать полюсы или снять фиксацию можно также с помощью команды Фиксировать полюсы инструментальной панели (см. раздел 2.6.3.2).

По умолчанию перемещение выбранных полюсов выполняется в плоскости экрана. Вы можете задать другое направление перемещения с помощью группы команд Направление смещения контекстного меню. Все возможные варианты перемещения приведены в таблице 2.6.6.

Табл. 2.6.6. Команды контекстного меню
Команда | Описание
По оси X По оси Y По оси Z | Команды позволяют переместить выбранные полюсы соответственно вдоль оси Х, оси Y и оси Z текущей системы координат (см. раздел 2.8.3.3).
Параллельно объекту | Команда позволяет переместить выбранные полюсы параллельно прямолинейному объекту (см. табл. 2.1.7) или оси цилиндра, конуса, тора. После вызова команды следует указать нужный объект.
Перпендикулярно объекту | Команда позволяет переместить выбранные полюсы перпендикулярно плоскому объекту (см. табл. 2.1.7). После вызова команды следует указать нужный объект.
По нормали | Команда позволяет переместить выбранные полюсы вдоль нормали к редактируемой грани. При выборе этого варианта перемещение ряда полюсов за сегмент ряда невозможно.
Вдоль многоугольника | Команда позволяет переместить выбранные полюсы по направлению U или V сетки. Возможны два варианта перемещения по каждому из направлений: К последующему, К предыдущему. В первом случае полюс перемещается вдоль сегмента сетки, соединяющего этот полюс с полюсом, следующим за ним по выбранному направлению (U или V); во втором случае — против выбранного направления.
В плоскости экрана | Команда позволяет переместить выбранные полюсы в плоскости экрана.


2.6.3.4.2. Особенности задания направления перемещения полюсов

При произвольном перемещении полюсов мышью направление перемещения задается с помощью команд контекстного меню. Эти команды связаны с элементами управления Панели свойств, которые используются для задания направления при работе с командами Линейное перемещение и Перемещение со сглаживанием.

Например, в режиме произвольного перемещения полюсов для задания направления была вызвана команда контекстного меню Направление смещения — Вдоль многоугольника — По U — К предыдущему. В дальнейшем потребовалось переместить полюсы с помощью команды Линейное перемещение инструментальной панели. После вызова этой команды заданное направление сохранилось, а на Панели свойств активизировались соответствующие ему элементы управления:

– в списке Направление — вариант Вдоль многоугольника,

– в группе Тип — переключатель По U,

– в группе Способ — переключатель К предыдущему.

Если в процессе работы с командой Линейное перемещение или Перемещение со сглаживанием направление смещения будет изменено, то это изменение сохранится после завершения команды.

Например, при работе с командой Перемещение со сглаживанием в списке Направление был выбран вариант Параллельно объекту и в окне модели указан направляющий объект. После завершения работы с командой заданное направление сохранилось, а в контекстном меню автоматически активизировалась команда Направление смещения — Параллельно объекту (появилась «галочка» рядом с названием команды). Кроме того, сохранился выбор направляющего объекта.


2.6.3.5. Построение сплайновой формы на эквидистанте грани

Сплайновая форма может быть построена на поверхности, эквидистантной редактируемой грани, т.е. полученная сплайновая форма будет являться отдельной поверхностью.

Использование эквидистантной поверхности позволяет сохранить исходную грань и соседние с ней грани в неизменном виде.

Чтобы построить сплайновую форму на эквидистантной поверхности, после выбора редактируемой грани нажмите кнопку Эквидистанта грани на Панели специального управления. Будет создана сплайновая поверхность, эквидистантная редактируемой грани (подробно о сплайновой поверхности см. раздел 3 Приложения IX). Она совпадает с этой гранью, т.е. расстояние между гранью и ее эквидистантой равно нулю.

Обратите внимание на то, что грань, выбранная для редактирования, автоматически преобразуется в сплайновую поверхность. После создания эквидистанты грань возвращается в исходное состояние.

Кнопку Эквидистанта грани можно нажать и перед выбором грани. В этом случае эквидистантная поверхность будет создана после выбора грани.

Редактирование эквидистантной поверхности выполняется теми же способами, что и редактирование грани. При нажатой кнопке Эквидистанта грани все действия в режиме редактирования грани применяются к ее эквидистанте, форма и положение исходной грани остаются без изменения (рис. 2.6.62).

Рис. 2.6.62. Построение сплайновой формы на эквидистантной поверхности: а) редактируемая грань, б) эквидистантная поверхность и редактируемая грань
а) | б)

Если грань была отредактирована до создания эквидистантной поверхности, то эквидистантная поверхность принимает форму и положение редактируемой грани на текущий момент, а сама редактируемая грань возвращается в исходные форму и положение.

Вы можете отказаться от создания сплайновой формы на эквидистанте редактируемой грани. Для этого отожмите кнопку Эквидистанта грани. Эквидистантная поверхность исчезнет, а редактируемая грань снова преобразуется в сплайновую поверхность. Все действия, произведенные в режиме редактирования, будут применены к редактируемой грани. Грань примет форму и положение эквидистанты на текущий момент редактирования.

После редактирования эквидистанты ее границы могут не совпадать с границами исходной грани и располагаться таким образом, что при данном положении границ невозможно стыкование с соседними гранями детали. В этом случае при возврате к редактированию грани ее форма и положение не будут соответствовать форме и положению эквидистанты на текущий момент редактирования. Грань останется в первоначальном виде, а фантом сетки сохранит текущее состояние.

Подробное описание особенностей редактирования грани и эквидистанты грани приведено в разделе 2.6.3.6.


2.6.3.6. Особенности редактирования грани и эквидистанты грани

– При редактировании грани обратите внимание на следующие особенности.

• Если редактируемая грань плоская, то при перемещении полюсов сетки в плоскости этой грани, ее форма не изменяется.

• При редактировании грани могут измениться форма и положение ее границы. При этом могут также измениться форма и положение границы грани, соседней с ней. Данные изменения возможны при условии, что тип соседней грани остается неизменным.

Например, редактируемая грань и грань, соседняя с ней, — плоские. Чтобы изменить форму ребра, расположенного между этими гранями, нужно переместить находящиеся на нем полюсы сетки. Вы можете перемещать полюсы в разных направлениях. Однако, при этом форма ребра будет изменяться в плоскости грани, соседней с редактируемой. Если положение полюсов не позволяет построить ребро в этой плоскости, форма редактируемой грани возвращается в исходное состояние. При этом полюсы сетки сохраняют текущее положение.

– Для редактирования как грани, так и ее эквидистанты характерны следующие особенности.

• Если исходная грань содержит более 1000 ребер, то работа команды Сплайновая форма несколько замедляется.

• Если в процессе редактирования полюсы сетки изменили свое положение таким образом, что форма грани/эквидистанты грани не может быть построена корректно, то грань/эквидистанта грани принимает свою первоначальную форму. При этом полюсы сетки сохраняют текущее положение.

• При редактировании грани/эквидистанты грани допускается самопересечение.

• При переходе от редактирования грани к редактированию ее эквидистанты текущие форма и положение грани передаются эквидистанте. Аналогично при обратном переходе (от эквидистанты к грани), кроме тех случаев, когда границы эквидистанты занимают такое положение, при котором невозможно стыкование с соседними гранями детали. В такой ситуации грань будет иметь исходные форму и положение.

Описанные выше особенности редактирования грани/эквидистанты грани характерны не только для первоначального создания сплайновой формы, но и для ее последующего редактирования.


2.7. Массивы

В этом разделе:

2.7.1. Общие сведения

2.7.1.1. Информация о массивах

2.7.1.1.1. Базовая точка экземпляра массива

2.7.1.1.2. Отображение экземпляров массива в Дереве построения модели

2.7.1.1.3. Переменные массивов

2.7.1.2. Область применения экземпляра массива операции

2.7.1.3. Общие приемы работы с массивами

2.7.1.3.1. Выбор копируемых объектов

2.7.1.3.2. Особенности копирования некоторых операций

2.7.1.3.3. Варианты расположения базовой точки копируемого объекта для тел вращения и поверхностей вращения

2.7.1.3.4. Включение и отключение отображения фантома массива

2.7.1.3.5. Геометрический массив

2.7.1.3.6. Удаление и восстановление отдельных экземпляров

2.7.1.3.7. Разрушение массивов

2.7.1.3.8. Особенности редактирования массивов

2.7.2. Управление переменными экземпляров

2.7.2.1. Общие сведения

2.7.2.2. Таблица изменяемых переменных

2.7.2.2.1. Общие сведения

2.7.2.2.2. Создание, редактирование и удаление таблицы изменяемых переменных

2.7.2.2.3. Приемы работы с таблицей изменяемых переменных

2.7.2.2.4. Задание нового значения переменной экземпляра

2.7.2.2.5. Индивидуальные допуски в таблице изменяемых переменных

2.7.2.3. Отчет по массиву с таблицей изменяемых переменных

2.7.2.3.1. Создание отчета по массиву с таблицей изменяемых переменных

2.7.2.3.2. Настройка параметров таблицы отчета по массиву

2.7.2.3.3. Настройка отображения столбцов таблицы отчета по массиву

2.7.2.3.4. Компоновка таблицы отчета по массиву

2.7.2.4. Размеры экземпляров массива

2.7.3. Массив по сетке

2.7.3.1. Схема образования параллелограммной сетки

2.7.3.2. Порядок построения массива по сетке

2.7.3.3. Параметры сетки по первой оси

2.7.3.3.1. Направление первой оси

2.7.3.3.2. Шаг сетки вдоль первой оси

2.7.3.4. Параметры сетки по второй оси

2.7.3.4.1. Направление второй оси

2.7.3.4.2. Шаг сетки вдоль второй оси

2.7.3.5. Изменение положения экземпляров в массиве относительно базового

2.7.3.6. Размещение копий внутри сетки

2.7.4. Массив по концентрической сетке

2.7.4.1. Схема построения массива

2.7.4.2. Порядок построения массива по концентрической сетке

2.7.4.3. Параметры сетки в кольцевом направлении

2.7.4.4. Параметры сетки в радиальном направлении

2.7.4.5. Ориентация экземпляров массива

2.7.4.6. Сдвиг экземпляров вдоль оси массива

2.7.4.7. Изменение положения экземпляров в массиве относительно базового

2.7.4.8. Размещение копий внутри концентрической сетки

2.7.4.9. Задание положения базовой точки базового экземпляра

2.7.5. Массив вдоль кривой

2.7.5.1. Схема построения массива

2.7.5.2. Порядок построения массива вдоль кривой

2.7.5.3. Начальная точка кривой

2.7.5.4. Шаг копирования

2.7.5.5. Направление копирования вдоль траектории

2.7.5.6. Ориентация экземпляров массива

2.7.5.7. Задание положения базовой точки базового экземпляра

2.7.6. Массив по точкам

2.7.6.1. Порядок построения массива по точкам

2.7.6.2. Управление расположением экземпляров массива относительно плоскости эскиза

2.7.6.3. Ориентация экземпляров массива

2.7.6.3.1. Построение экземпляров с сохранением исходной ориентации

2.7.6.3.2. Построение экземпляров с ориентацией по объекту, связанному с точками

2.7.6.3.3. Построение экземпляров с ориентацией по указанному объекту

2.7.7. Массив по таблице

2.7.7.1. Порядок построения массива по таблице

2.7.7.2. Задание позиций экземпляров

2.7.7.2.1. Чтение данных из файла

2.7.7.2.2. Ручной ввод данных в таблицу

2.7.7.3. Особенности использования таблицы изменяемых переменных

2.7.7.4. Ориентация экземпляров массива

2.7.7.4.1. Построение экземпляров с доворотом по радиальному направлению

2.7.8. Зеркальный массив

2.7.8.1. Порядок построения зеркального массива операций, кривых, точек, вспомогательных плоскостей и осей

2.7.8.2. Порядок построения зеркальной копии тела или поверхности

2.7.8.2.1. Результат зеркального копирования тела

2.7.9. Массив по образцу

2.7.9.1. Порядок построения массива компонентов по образцу

2.7.9.2. Размещение экземпляров массива

2.7.10. Массив произвольных объектов

2.7.10.1. Основные принципы выбора объектов

2.7.10.1.1. Копируемые объекты и их исходные объекты

2.7.10.1.2. Системы координат исходных объектов

2.7.10.1.3. Изолирование копируемых объектов

2.7.10.2. Область применения массива произвольных объектов


2.7.1. Общие сведения

2.7. Массивы

2.7.1. Общие сведения

В этом разделе:

2.7.1.1. Информация о массивах

2.7.1.1.1. Базовая точка экземпляра массива

2.7.1.1.2. Отображение экземпляров массива в Дереве построения модели

2.7.1.1.3. Переменные массивов

2.7.1.2. Область применения экземпляра массива операции

2.7.1.3. Общие приемы работы с массивами

2.7.1.3.1. Выбор копируемых объектов

2.7.1.3.2. Особенности копирования некоторых операций

2.7.1.3.3. Варианты расположения базовой точки копируемого объекта для тел вращения и поверхностей вращения

2.7.1.3.4. Включение и отключение отображения фантома массива

2.7.1.3.5. Геометрический массив

2.7.1.3.6. Удаление и восстановление отдельных экземпляров

2.7.1.3.7. Разрушение массивов

2.7.1.3.8. Особенности редактирования массивов


2.7.1.1. Информация о массивах

При работе с моделью может потребоваться создание копий объектов (например, операций или компонентов), которые были бы определенным образом упорядочены — образовывали прямоугольную сетку с заданными параметрами или были симметричны относительно плоскости и т.п.

Для создания в модели упорядоченных групп одинаковых объектов можно воспользоваться командами построения массивов. В КОМПАС-3D имеется возможность построения массивов следующих типов:

– по сетке (см. раздел 2.7.3),

– по концентрической сетке (см. раздел 2.7.4),

– вдоль кривой (см. раздел 2.7.5),

– по точкам (см. раздел 2.7.6),

– по таблице (см. раздел 2.7.7),

– зеркальный массив (см. раздел 2.7.8),

– по образцу (разновидность массива компонентов; см. раздел 2.7.9).

Команды построения массивов расположены в меню Операции — Массив, а кнопки для их вызова находятся на панели Массивы (рис. 2.7.1).

Рис. 2.7.1. Команды копирования объектов

Вы можете создавать массивы следующих объектов:

– операций, добавляющих или удаляющих материал тела,

– тел,

– поверхностей,

– кривых,

– точек,

– вспомогательных плоскостей,

– вспомогательных осей,

– компонентов.

Кроме того, возможно копирование ранее созданных групп точек, групп изопараметрических кривых и массивов (за исключением массивов тел и поверхностей и массивов с таблицей изменяемых переменных).

Массив объектов состоит из экземпляров. По умолчанию первый экземпляр массива является базовым экземпляром. Он соответствует копируемому объекту или — если копируемых объектов несколько — группе объектов. Остальные экземпляры массива являются копиями базового экземпляра. Вы можете изменить положение экземпляров массива относительно базового, задав ему нужный номер в массиве.

При необходимости вы можете изменить форму и размеры экземпляров путем изменения значений их переменных (при условии, что копируемый объект имеет переменные). Такая возможность доступна для всех массивов, кроме зеркального массива и массива по образцу. Управление переменными экземпляров подробно описано в разделе 2.7.2.

Если в результате создания массива операций образуются тела, состоящие из частей, то пиктограмма массива имеет признак наличия нескольких частей — восклицательный знак. Подробно о телах из нескольких частей рассказано в разделе 2.3.11.

Из всех массивов, кроме массива по образцу, можно исключить экземпляры (см. раздел 2.7.1.3.6).

Все массивы, кроме массива операций, можно разрушить на отдельные экземпляры (см. раздел 2.7.1.3.7).

Построение массива по образцу имеет ряд особенностей. Подробно об этом рассказано в разделе 2.7.9. Остальные массивы имеют общие приемы работы. Эти приемы описаны в разделе 2.7.1.3. О построении этих массивов рассказано в разделах 2.7.3–2.7.8.

В этом разделе:

2.7.1.1.1. Базовая точка экземпляра массива

2.7.1.1.2. Отображение экземпляров массива в Дереве построения модели

2.7.1.1.3. Переменные массивов


2.7.1.1.1. Базовая точка экземпляра массива

Понятие базовой точки экземпляра используется в следующих массивах:

– по концентрической сетке,

– по точкам,

– по таблице,

– вдоль кривой.

Относительно базовой точки экземпляра определяется положение экземпляра в пространстве. В свою очередь, положение базовых точек экземпляров определяется типом и параметрами массива. Так, в массиве по концентрической сетке базовые точки экземпляров совпадают с узлами сетки, в массиве по точкам или по таблице — с указанными или полученными из файла точками, а в массиве вдоль кривой базовые точки экземпляров размещаются на кривой.

Базовой точкой базового экземпляра массива по умолчанию является базовая точка копируемого объекта (см. раздел 2.1.1.4). Также имеется возможность выбора произвольной точки в качестве базовой точки базового экземпляра. В результате, поскольку все экземпляры массива являются копиями базового, их положение относительно базовых точек изменится аналогично.

Подробно о построении вышеперечисленных массивов рассказано в разделах 2.7.4–2.7.7.

Если копируется операция вращения, тело, созданное операцией вращения, или поверхность вращения, то вместо базовой точки копируемого объекта можно использовать ее проекцию на ось вращения копируемого объекта (см. раздел 2.7.1.3.3).


2.7.1.1.2. Отображение экземпляров массива в Дереве построения модели

Экземпляры массива отображаются в Дереве построения модели как отдельные объекты, подчиненные массиву.

Чтобы развернуть список экземпляров, щелкните мышью на значке «плюс», расположенном слева от пиктограммы массива в Дереве построения.

Рис. 2.7.2. Массив по концентрической сетке в Дереве построения

Справа от пиктограммы экземпляра массива в круглых скобках отображается номер этого экземпляра.

– Если сетка параллелограммная, номер экземпляра массива состоит из двух чисел. Первое — номер экземпляра вдоль первой оси сетки, второе — номер экземпляра вдоль второй оси (нумерация экземпляров начинается с единицы).

– Если сетка концентрическая, номер экземпляра массива состоит из двух чисел. Первое — номер экземпляра в радиальном направлении, второе — номер экземпляра в кольцевом направлении (нумерация экземпляров начинается с единицы).

– Если копии расположены вдоль кривой, номер экземпляра массива отсчитывается по порядку расположения экземпляров, начиная от исходного.

– Если копии расположены по точкам, номер экземпляра равен номеру точки, задающей его позицию. Точки нумеруются в порядке их указания.

– Если копии расположены по координатам (заданным в файле или в таблице), номер экземпляра равен порядковому номеру строки файла или таблицы.


2.7.1.1.3. Переменные массивов

При создании массива в Окне переменных модели автоматически создается раздел, который содержит переменные этого массива.

Для переменных каждого экземпляра массива создается отдельный подраздел, подчиненный разделу переменных массива. Например, раздел переменных Массив по таблице:1 может содержать подразделы Экземпляр (1), Экземпляр (2) и т.п.

Набор переменных экземпляра массива включает переменные размеров эскизов и операций. Эти переменные автоматически создаются для всех массивов, кроме зеркального массива и массива по образцу.

Для массива по таблице набор переменных экземпляра также содержит переменные размеров позиций экземпляров. Эти переменные создаются автоматически при задании позиций экземпляров массива. Они соответствуют координатам точек, которые считаны из файла данных или заданы в таблице изменяемых переменных массива (см. раздел 2.7.7.2).


2.7.1.2. Область применения экземпляра массива операции

Каждый экземпляр массива наследует область применения операции, копией которой он является. Так, каждая копия ребра жесткости приклеивается к тому же телу, к которому было приклеено исходное ребро; каждая копия круглого отверстия вырезается из того же тела или компонента, из которого было вырезано исходное отверстие и т.п.

Для всех массивов, кроме массива произвольных объектов, изменение областей применения экземпляров массива операций невозможно ни при создании, ни при редактировании массива. Задание области применения массива произвольных объектов описано в разделе 2.7.10.2.

При необходимости можно создать массив операций удаления материала (например, отверстий), каждая копия которого будет применена к копии компонента. Для этого действуйте следующим образом:

– создайте массив компонентов,

– постройте проходящее через исходный компонент отверстие и включите в его область применения те копии компонента, через которые должны пройти копии отверстия,

– создайте массив отверстий.


2.7.1.3. Общие приемы работы с массивами

В этом разделе:

2.7.1.3.1. Выбор копируемых объектов

2.7.1.3.2. Особенности копирования некоторых операций

2.7.1.3.3. Варианты расположения базовой точки копируемого объекта для тел вращения и поверхностей вращения

2.7.1.3.4. Включение и отключение отображения фантома массива

2.7.1.3.5. Геометрический массив

2.7.1.3.6. Удаление и восстановление отдельных экземпляров

2.7.1.3.7. Разрушение массивов

2.7.1.3.8. Особенности редактирования массивов


2.7.1.3.1. Выбор копируемых объектов

Для выбора объектов служит вкладка Выбор объектов на Панели свойств (рис. 2.7.3).

Рис. 2.7.3. Вкладка Выбор объектов

Переключатели группы Тип позволяют выбрать тип копируемых объектов.

Переключатель Автоопределение по указанию активен по умолчанию. Это означает, что тип объекта будет определен системой автоматически после указания первого объекта — в группе активизируется переключатель, соответствующий типу указанного объекта. Указанный объект выделяется цветом, а на панели Список объектов появляется его название. Повторное указание объекта отменяет его выбор. Далее вы можете указать в качестве копируемых другие объекты данного типа.

При создании зеркальной копии тела или поверхности панель Список объектов отсутствует на Панели свойств.

При указании объектов обратите внимание на следующие особенности.

– Кривые, точки, вспомогательные плоскости и оси могут быть указаны для копирования вместе (т.е. могут быть объектами одного и того же массива), а тела и поверхности — нет (т.е. массив может состоять либо из тел, либо из поверхностей).

– При указании в окне модели ребра, грани или вершины тела в группе Тип активизируется переключатель Операции, а при указании ребра, грани или вершины объекта из состава компонента — переключатель Компоненты. Если для копирования требуется выбрать тело, то перед его указанием активизируйте переключатель Тела или поверхности.

Объекты для копирования можно выбрать и перед вызовом команды создания массива.

Чтобы выбрать для копирования объекты определенного типа, в группе Тип активизируйте переключатель этого типа:

– Операции,

– Тела или поверхности,

– Кривые, точки, вспомогательная геометрия,

– Произвольный — данный переключатель присутствует в группе Тип при создании всех массивов, кроме зеркального и массива по образцу; специфика построения массива в случае использования этого переключателя описана в разделе 2.7.10,

– Компоненты.

После активизации переключателя укажите в Дереве построения или в окне модели объект (объекты) выбранного типа.

Особенности выбора объектов различных типов

– Компоненты
Копироваться могут только компоненты первого уровня, т.е. вставленные непосредственно в текущую модель. Поэтому, если в Дереве построения или в окне модели указать объект, входящий в компонент, то для копирования будет выбран сам компонент — на панели Список объектов появится его название.

– Массивы
Тип объектов копируемого массива должен совпадать с выбранным типом объектов. Массив копируется в текущем состоянии. Для копирования массива укажите его в Дереве построения или укажите любой его экземпляр в окне модели. На панели Список объектов появляется название указанного массива.

Невозможно копирование массивов тел или поверхностей. Поэтому эти массивы нельзя указать в качестве исходных объектов для массива.

– Группа точек или изопараметрических кривых
Группу можно скопировать как целиком, так и частично. Для копирования всей группы укажите ее в Дереве построения. На панели Список объектов появляются названия всех объектов группы. Для копирования отдельных точек или кривых группы укажите нужные точки или кривые в Дереве построения или в окне модели.

О выборе объектов в Дереве построения или в окне модели подробно рассказано в разделе 2.1.4.1.

Чтобы отменить выбор всех объектов заданного типа, нажмите кнопку Указать заново на Панели специального управления.

До завершения команды система запоминает все объекты разных типов, указанные для копирования, поэтому вы можете переключаться между типами без потери этих данных.

Выбор типа копируемого объекта возможен только при создании массива. При редактировании массива сменить тип копируемого объекта нельзя.


2.7.1.3.2. Особенности копирования некоторых операций

– Операции Фаска и Скругление

Операции Фаска и Скругление могут копироваться только вместе с объектом, к которому они применены. Для копирования фаски или скругления укажите в Дереве построения операцию создания объекта, на ребрах которого была построена фаска или скругление, а затем — саму фаску или скругление. Можно также указать в окне модели ребра, грани или вершины, принадлежащие копируемым объектам.

– Ребро жесткости

Массив ребра жесткости создается корректно в том случае, если каждая копия ребра примыкает к грани того же тела, что и копируемое ребро.

– Операции Оболочка, Уклон, Сечение поверхностью, Сечение по эскизу

Эти операции невозможно скопировать с помощью команд построения массивов.

– Операция Придать толщину

Если с помощью операции Придать толщину создается новое тело, вы можете создать копию этой операции.

Если операция Придать толщину применена к уже существующему телу, то скопировать ее невозможно. Поэтому следует сначала создать копии нужного тела, а затем к каждой копии применить операцию Придать толщину.

– Условное обозначение резьбы

Если при копировании условного обозначения резьбы копируется также объект, грань которого ограничивает эту резьбу, то границей резьбы-копии будет грань-копия. В противном случае резьба-копия будет ограничена той же гранью, что исходная резьба.


2.7.1.3.3. Варианты расположения базовой точки копируемого объекта для тел вращения и поверхностей вращения

2.7.1.3.3. Варианты расположения базовой точки копируемого объекта
для тел вращения и поверхностей вращения

Вы можете вместо базовой точки копируемого объекта (см. раздел 2.1.1.4) использовать ее проекцию на ось вращения копируемого объекта.

Данная возможность доступна в массивах, использующих базовую точку базового экземпляра (см. раздел 2.7.1.1.1), при копировании следующих объектов:

– операция вращения,

– тело, созданное операцией вращения,

– поверхность вращения.

Включение/отключение использования проекции базовой точки производится на вкладке Параметры Панели свойств с помощью опции На оси вращения.

По умолчанию для построения массива используется именно проекция базовой точки, т.е. опция На оси вращения включена.

Изменение состояния опции отображается на фантоме массива в окне модели.


2.7.1.3.4. Включение и отключение отображения фантома массива

При построении массива вы можете включать или отключать отображение его фантома на экране по своему усмотрению. Такая возможность доступна для всех массивов, кроме зеркального массива и массива по образцу.

Для управления отображением фантома текущего (создаваемого или редактируемого) массива служит кнопка Показать фантом на Панели специального управления.

При изменении параметров массива его фантом динамически изменяется.

Использование фантомов делает создание массива более удобным, так как позволяет визуально контролировать результат построения.


2.7.1.3.5. Геометрический массив

При формировании массива операций можно ускорить его создание и перестроение. Для этого на вкладке Параметры включите опцию Геометрический массив. Эта опция присутствует на вкладке только при создании массива операций. Если выбран любой другой тип объектов, опция отсутствует.

При формировании геометрического массива копируются только грани и ребра, которые являются результатом копируемой операции. Копирование операций и их параметров не производится.

Для корректного построения геометрического массива необходимо, чтобы все его исходные объекты были построены либо путем добавления материала, либо его вырезания. Смешение копируемых объектов разного рода недопустимо.

Такое расположение скопированных поверхностей относительно имеющихся, при котором не образуется тело, или такое расположение экземпляров массива, при котором их грани пересекаются друг с другом, приводит к ошибке при построении. В таких случаях опция Геометрический массив должна быть отключена.

Обратите внимание на особенности копирования объекта, выдавленного До поверхности.

– При копировании объекта с отключенной опцией Геометрический массив каждый экземпляр массива выдавливается до той же поверхности, что и копируемый объект. В результате экземпляры могут отличаться друг от друга высотой и формой «торца».

– При копировании объекта с включенной опцией Геометрический массив каждый экземпляр является точной копией исходного объекта.

Если в массиве имеется таблица изменяемых переменных (о таблице см. раздел 2.7.2.2), то при включении опции Геометрический массив на экране появляется сообщение о том, что из таблицы будут удалены все переменные. После нажатия в сообщении кнопки ОК все переменные удаляются.

Для массива по таблице удаляются все переменные, кроме переменных координат базовых точек экземпляров.


2.7.1.3.6. Удаление и восстановление отдельных экземпляров

Иногда требуется отменить построение некоторых экземпляров, или наоборот, восстановить удаленные экземпляры. Для этого во время создания или редактирования массива выполните следующие действия.

1. Активизируйте вкладку Экземпляры на Панели свойств.

Эта вкладка содержит панель Список удаленных, а для типа копируемых объектов Операции или Кривые, точки, вспомогательная геометрия также группу переключателей Режим.

Если при создании массива операций включена опция Геометрический массив, то вкладка содержит только панель Список удаленных.

После активизации вкладки в окне модели появляются характерные точки и номера экземпляров массива.

2. Если на вкладке присутствует группа переключателей Режим, активизируйте переключатель Удалить/восстановить. Если этой группы нет, перейдите к выполнению следующего пункта.

3. В окне модели установите курсор на характерной точке того экземпляра массива, который требуется удалить или восстановить. Когда рядом с курсором появится надпись «Удалить/восстановить экземпляр», щелкните левой кнопкой мыши.

– Если производится удаление экземпляра, то его фантом исчезает, а номер появляется в Списке удаленных на Панели свойств.

– Если производится восстановление экземпляра, то его фантом появляется, а номер исчезает из Списка удаленных.

Восстановить удаленный экземпляр можно другим способом.

1. Выделите в Списке удаленных нужный экземпляр.

2. Нажмите кнопку Восстановить над списком.

Экземпляр можно удалить из массива только целиком. Удаление отдельных копий исходных объектов из состава экземпляра невозможно.

Существует другой способ удаления экземпляров массива. Он, в отличие от вышеописанного, доступен только после того, как массив создан. Для выполнения такого изменения массива выполните следующие действия.

1. Выделите подлежащие исключению экземпляры в Дереве построения, а затем нажмите клавишу <Delete> или вызовите из контекстного меню команду Удалить.

На экране появляется диалог, в котором требуется указать, следует ли удалить все экземпляры (т.е. отменить операцию создания массива в целом) или выбранные экземпляры (рис. 2.7.4).

2. Включите опцию Экземпляры.

Рис. 2.7.4. Удаление экземпляров массива

В окне диалога отображается список номеров исключаемых экземпляров массива (о номерах экземпляров массива рассказано в разделе 2.7.1.1.2).

3. Выберите экземпляр и нажмите кнопку OK диалога.

Массив перестраивается и отображается в окне модели без указанных экземпляров.

Удаление экземпляров массива по образцу невозможно.


2.7.1.3.7. Разрушение массивов

Все массивы, кроме массива операций, можно разрушить на отдельные экземпляры.

Для этого выделите в Дереве построения массивы, которые требуется разрушить, и вызовите из меню Редактор команду Разрушить.

Для разрушения одного массива команду Разрушить можно вызвать из контекстного меню массива в Дереве построения.

После вызова команды на экране появляется диалог разрушения. Чтобы подтвердить разрушение, нажмите в этом диалоге кнопку ОК.

Разрушение массива производится по следующим правилам:

– пиктограммы разрушенного массива и его экземпляров удаляются из Дерева построения;

– объекты, составлявшие массив, отображаются в Дереве как самостоятельные объекты модели;

– объекты, составлявшие массив, остаются в том положении и с теми параметрами, которые они имели в массиве;

– объекты, соответствующие удаленным экземплярам разрушенного массива, в модель не добавляются;

– если разрушается массив, являвшийся исходным для другого (производного) массива, то этот производный массив также разрушается; если же разрушается производный массив, то исходный массив не изменяется;

– компоненты, составлявшие массив компонентов, фиксируются в том положении, в котором находились в массиве.

Типы объектов, которые появляются в результате разрушения, зависят от типов исходных объектов массива (табл. 2.7.1).

Результат разрушения массива произвольных объектов (см. раздел 2.7.7.1) не подчиняется представленным в таблице 2.7.1 соответствиям. Все объекты, составлявшие данный массив, преобразуются в объекты, полностью аналогичные исходным.

Табл. 2.7.1. Результаты разрушения массивов объектов
Тип исходного объекта | Тип объектов, полученных в результате разрушения массива
Тело | Тело без истории. Тело без истории редактировать невозможно.
Поверхность | Поверхность без истории. Поверхность без истории редактировать невозможно.
Точки и группы точек | Точка, построенная способом По координатам (XYZ).
Пространственные кривые: |
Отрезок | Отрезок по двум точкам.
Дуга окружности | Дуга окружности по трем точкам.
Ломаная | Ломаная.
Сплайн по точкам | Сплайн по точкам.
Сплайн по полюсам, Соединение кривых | Сплайн по полюсам.
Остальные кривые | Кривая без истории. Кривые без истории редактировать невозможно.
Вспомогательная плоскость | Перпендикулярная плоскость (положение точки, через которую проходит плоскость, и направление вектора, которому она перпендикулярна, определяются автоматически).
Вспомогательная ось | Ось через вершину по объекту (положение точки, через которую проходит ось, и направление вектора, которому она параллельна, определяются автоматически).

Обратите внимание на следующую особенность разрушения массива компонентов. После разрушения массива компоненты, составлявшие массив, размещаются в Дереве так, как если бы были добавлены в модель вместо создания массива. Это можно увидеть, если включить отображение в Дереве последовательности построения модели (о способах отображения объектов в Дереве — см. разделы 2.1.2.1 и 2.1.2.2).

Например, в модели имелись добавленные друг за другом компоненты: Корпус, Прокладка, Крышка (рис. 2.7.5, а). После этого был создан массив Прокладок и добавлен компонент Пробка (рис. 2.7.5, б). Затем массив был разрушен. Порядок следования компонентов в Дереве после разрушения массива будет следующим: Корпус, Прокладка (1), Крышка, Прокладка (2), Прокладка (3), Пробка (рис. 2.7.5, в).

Рис. 2.7.5. Создание и разрушение массива компонентов
а) | б) | в)

Если значения переменных экземпляров массива изменены (см. раздел 2.7.2), то после разрушения такого массива экземпляры сохраняют форму и размеры, соответствующие измененным значениям переменных.


2.7.1.3.8. Особенности редактирования массивов

При редактировании массива невозможно сменить тип копируемого объекта — на вкладке Выбор объектов отсутствует группа переключателей Тип. На данной вкладке отображается пиктограмма типа объекта, выбранного для копирования при создании массива (рис. 2.7.6).

Рис. 2.7.6. Вкладка Выбор объектов при редактировании массива кривых или точек


2.7.2. Управление переменными экземпляров

2.7. Массивы

2.7.2. Управление переменными экземпляров

В этом разделе:

2.7.2.1. Общие сведения

2.7.2.2. Таблица изменяемых переменных

2.7.2.2.1. Общие сведения

2.7.2.2.2. Создание, редактирование и удаление таблицы изменяемых переменных

2.7.2.2.3. Приемы работы с таблицей изменяемых переменных

2.7.2.2.4. Задание нового значения переменной экземпляра

2.7.2.2.5. Индивидуальные допуски в таблице изменяемых переменных

2.7.2.3. Отчет по массиву с таблицей изменяемых переменных

2.7.2.3.1. Создание отчета по массиву с таблицей изменяемых переменных

2.7.2.3.2. Настройка параметров таблицы отчета по массиву

2.7.2.3.3. Настройка отображения столбцов таблицы отчета по массиву

2.7.2.3.4. Компоновка таблицы отчета по массиву

2.7.2.4. Размеры экземпляров массива


2.7.2.1. Общие сведения

Вы можете изменить форму и размеры экземпляров путем изменения значений их переменных. Данная возможность доступна при условии, что копируемый объект имеет переменные, влияющие на его форму и размеры.

Экземпляры имеют те же переменные, что и копируемый объект. Например, переменными операции выдавливания являются: расстояние, угол уклона и, если элемент тонкостенный, толщина стенки. Эти же переменные имеют и экземпляры массива операции выдавливания.

По умолчанию значения переменных копируемого объекта и экземпляров совпадают. Вы можете задать новые значения переменных для всех экземпляров массива, кроме базового.

На рисунке 2.7.7 приведен пример изменения размеров экземпляров массива по кривой. Копируемым объектом является операция выдавливания. Для каждого экземпляра задано новое значение расстояния выдавливания.

Рис. 2.7.7. Пример изменения размеров экземпляров массива операции выдавливания:
для каждого экземпляра задано новое значение расстояния выдавливания

Кроме переменных копируемого объекта для изменения доступны переменные следующих объектов, участвующих в его построении:

– эскизы (если в них созданы размеры с переменными),

– вспомогательные плоскости,

– кривые (кроме сплайнов и ломаных),

– точки.

Например, копируется элемент выдавливания, эскиз которого построен на плоскости, параллельной плоскости XY, а глубина выдавливания определяется положением точки в пространстве. Для экземпляров массива можно будет задать новые значения переменных, определяющих размеры эскиза, расстояние от его плоскости до плоскости XY и координаты точки, до которой производится выдавливание.

Далее под переменными копируемого объекта будут подразумеваться как сами эти переменные, так и переменные объектов, участвующих в построении копируемого объекта. Под переменными экземпляра будет подразумеваться набор переменных, аналогичных переменным копируемого объекта.

Управление переменными экземпляров выполняется двумя способами:

– с помощью таблицы изменяемых переменных (см. раздел 2.7.2.2),

– редактированием значений размеров экземпляров (см. раздел 2.7.2.4).

Значения переменных экземпляров можно изменить и после создания массива. Для этого можно использовать Окно переменных (см. раздел 7.1.1.3) или производные размеры (см. раздел 2.9.2.8).

Управление переменными экземпляров недоступно:

– в зеркальном массиве и массиве по образцу,

– в других массивах:

• если копируются тела или поверхности (т.е. в группе Тип объекта активен переключатель Тела и поверхности),

• если копируются операции при включенной опции Геометрический массив.

В остальных случаях управление переменными экземпляров доступно. Однако, изменение переменных некоторых объектов невозможно. К таким объектам относятся: операция придания толщины, массив, группа кривых или точек и некоторые другие. Копии этих объектов в массиве не могут отличаться от оригинала.


2.7.2.2. Таблица изменяемых переменных

В этом разделе:

2.7.2.2.1. Общие сведения

2.7.2.2.2. Создание, редактирование и удаление таблицы изменяемых переменных

2.7.2.2.3. Приемы работы с таблицей изменяемых переменных

2.7.2.2.4. Задание нового значения переменной экземпляра

2.7.2.2.5. Индивидуальные допуски в таблице изменяемых переменных


2.7.2.2.1. Общие сведения

Таблица изменяемых переменных — это таблица, хранящаяся в модели и содержащая переменные экземпляров массива.

Таблица изменяемых переменных позволяет задавать новые значения переменных для экземпляров, изменяя тем самым их форму и размеры.

Таблица формируется пользователем во время создания или редактирования массива. Впоследствии таблица может быть отредактирована или удалена из файла.

Чтобы изменить форму и размеры экземпляров, сформируйте таблицу изменяемых переменных, включив в нее нужные переменные экземпляров. Затем задайте этим переменным новые значения.

Новые значения переменных можно задать двумя способами:

– вводом нового значения в нужную ячейку таблицы;

– заданием шага изменения переменных.

Экземпляры массива перестраиваются согласно новым значениям переменных.

Создание таблицы изменяемых переменных описано в разделе 2.7.2.2.2, способы задания новых значений переменных — в разделе 2.7.2.2.4.

Таблица изменяемых переменных, хранящаяся в модели, может быть записана в файл данных (о файле данных см. Приложение VI). Возможно также чтение таблицы из файла данных.

При построении массива по таблице вы можете использовать таблицу изменяемых переменных для задания позиций экземпляров. Подробнее о массиве по таблице см. раздел 2.7.7.


2.7.2.2.2. Создание, редактирование и удаление таблицы изменяемых переменных

Создание таблицы изменяемых переменных

Чтобы создать таблицу изменяемых переменных массива, выполните следующие действия.

При копировании операций:

1. Во время работы с массивом нажмите кнопку Таблица изменяемых переменных на Панели специального управления.

На экране появляются:

– окно Таблица изменяемых переменных с таблицей, содержащей столбец с номерами экземпляров;

– размеры, соответствующие переменным копируемого объекта (рис. 2.7.8).

Рис. 2.7.8. Пример отображения размеров, соответствующих переменным операции выдавливания

Если имена переменных не показываются на размерных линиях размеров, вы можете включить их отображение в окне модели (см. раздел 2.9.2.2.3).

Для массива по таблице таблица изменяемых переменных может содержат координаты точек, задающих позиции экземпляров (см. раздел 2.7.7.2). Вы можете включить/отключить отображение координат в таблице нажатием кнопки Задать координаты базовой точки, расположенной на инструментальной панели окна Таблица изменяемых переменных.

2. Сформируйте набор переменных копируемого объекта, значения которых для экземпляров следует изменить.

Переменные некоторых операций (Отверстие из библиотеки, Придать толщину, Кинематическая операция и некоторые другие) добавить в набор невозможно.

Для формирования набора переменных укажите в окне модели нужные размеры копируемого объекта. Они выделяются цветом.

В таблице появляются столбцы, соответствующие выбранным переменным копируемого объекта. Первая строка содержит имена переменных (заголовки столбцов). Во второй строке отображаются значения переменных базового экземпляра. Каждая строка таблицы, начиная с третьей, содержит номер экземпляра и пустые ячейки.

Пустая ячейка таблицы изменяемых переменных означает, что переменная в этой ячейке имеет значение, совпадающее со значением соответствующей переменной базового экземпляра. Поэтому сразу после того, как переменная добавлена в таблицу, третья и последующие ячейки ее столбца пусты.

Повторное указание размера в окне модели отменяет его выбор (из таблицы удаляется столбец, соответствующий выбранной переменной).

3. Задайте новые значения переменных. Это можно сделать двумя способами:

– вводом нового значения переменной в нужную ячейку таблицы;

– заданием шага изменения переменных.

Обратите внимание на то, что значения переменных базового экземпляра изменить нельзя (строка со значениями базового экземпляра имеет серый цвет).

О задании новых значений переменных рассказано в разделе 2.7.2.2.4.

4. Закройте окно Таблица изменяемых переменных кнопкой ОК.

Созданная таблица добавляется в файл текущей модели. Экземпляры массива перестраиваются согласно новым значениям переменных.

Приемы работы с таблицей изменяемых переменных описаны в разделе 2.7.2.2.3.

При копировании компонентов:

Для создания таблицы изменяемых переменных необходимо, чтобы копируемый компонент имел внешние переменные (о внешних переменных см. раздел 7.1.5.3).

1. Во время работы с массивом нажмите кнопку Таблица изменяемых переменных на Панели специального управления.

На экране появляется окно Таблица изменяемых переменных с таблицей, содержащей столбец с номерами экземпляров.

2. Сформируйте набор переменных копируемого компонента, значения которых для экземпляров следует изменить. Для этого используйте кнопку Читать переменные или Вставить переменную окна Таблица изменяемых переменных. Описание кнопок представлено в разделе 2.7.2.2.3.

3. Выполните пп. 3 и 4 описанной выше последовательности создания таблицы изменяемых переменных при копировании операций.

Таблица изменяемых переменных создается автоматически при редактировании размеров экземпляров массива в окне модели (см. раздел 2.7.2.4) или при редактировании соответствующих этим размерам переменных в Окне переменных. Столбцы с измененными переменными добавляются в таблицу.

Редактирование таблицы изменяемых переменных

Редактирование таблицы изменяемых переменных аналогично ее созданию.

Чтобы начать редактирование таблицы, нажмите кнопку Таблица изменяемых переменных на Панели специального управления.

Удаление таблицы изменяемых переменных

Если наличие таблицы изменяемых переменных в файле больше не требуется, ее можно удалить. Для этого нажмите кнопку Удалить таблицу на Панели специального управления. В результате:

– измененные значения переменных для экземпляров удаляются из файла;

– переменные экземпляров принимают значения, совпадающие со значениями соответствующих переменных базового экземпляра;

– экземпляры перестраиваются и становятся точными копиями исходного объекта массива.


2.7.2.2.3. Приемы работы с таблицей изменяемых переменных

Доступны следующие возможности работы с таблицей.

Чтение данных из ранее созданного файла

Нажмите кнопку Читать из файла. В появившемся диалоге открытия файлов укажите нужный файл и нажмите кнопку Открыть. Таблица будет заполнена данными из этого файла (о файле данных см. Приложение VI).

Сохранение таблицы в файл

Нажмите кнопку Сохранить в файл. На экране появляется диалог записи файлов. Задайте местоположение и имя файла (по умолчанию файлу присваивается расширение txt) и нажмите кнопку Сохранить.

– Если сохранение таблицы производится при вводе значений переменных, то в файл данных записываются только числовые значения переменных. Для массива по таблице в файл данных также могут записываться координаты точек, задающих позиции экземпляров (подробнее о записи координат точек см. раздел Запись таблицы в файл данных).

– Если сохранение таблицы производится при задании шага изменения переменных, то в файл данных записываются только шаги изменения.

При работе с массивами по сетке, по концентрической сетке, вдоль кривой и по точкам кнопки Читать из файла и Сохранить в файл недоступны в том случае, если таблица изменяемых переменных пустая (не содержит столбцы с переменными экземпляров).

При работе с массивом по таблице данные кнопки доступны всегда.

Добавление переменных копируемого объекта в таблицу

Нажмите кнопку Читать переменные. Переменные копируемого объекта, которых еще нет в таблице, будут добавлены в нее. Обратите внимание на то, что информационные переменные в таблицу не добавляются (об информационной переменной см. раздел 7.1.1.2.1).

Добавление в таблицу определенной переменной копируемого объекта

Нажмите кнопку Вставить переменную. На экране появляется диалог Переменные со списком переменных копируемого объекта. Укажите нужную переменную и нажмите кнопку ОК. Выбранная переменная будет добавлена в таблицу.

Удаление выделенного столбца

Выделите нужный столбец или любую из его ячеек и нажмите кнопку Удалить столбец.

Изменение порядка следования столбцов

«Перетащите» заголовок столбца мышью в нужное место, см. рис. 2.7.9.

Рис. 2.7.9. Изменение порядка следования столбцов в таблице изменяемых переменных

Изменение количества строк таблицы
(для массива по таблице)

Нажмите нужную кнопку:

• Добавить строку выше,

• Добавить строку ниже,

• Удалить строки (доступна после выделения строки или ячейки).

Смена способа задания значений переменных для экземпляров

– Чтобы перейти к способу, позволяющему ввести в ячейки таблицы произвольные значения, нажмите кнопку Значения переменных.

– Чтобы перейти к способу, позволяющему задать шаг изменения, нажмите кнопку Шаг значений.

Подробнее способы задания новых значений переменных для экземпляров описаны в разделе 2.7.2.2.4.

Если столбец содержит значения, не образующие арифметическую прогрессию (т.е. шаг изменения значения определить невозможно), то переход к заданию шага возможен только с удалением данных этого столбца. После нажатия кнопки Шаг значений на экране появляется запрос на приведение значений к базовым.

• Нажмите кнопку Да, чтобы удалить значения в столбце и перейти к заданию шага.

• Нажмите кнопку Нет, чтобы сохранить значения в столбце. В этом случае переход к заданию шага не происходит.

Включение/отключение отображения координат в таблице
(для массива по таблице)

Нажмите кнопку Задать координаты базовой точки.

Если создается массив произвольных объектов (а не объектов какого-либо определенного типа), то кнопа Задать координаты базовой точки отсутствует на инструментальной панели.

Отмена изменений в таблице

Отмена изменений в таблице заключается в удалении из ее ячеек новых значений. Пустая ячейка таблицы означает, что значение в этой ячейке совпадает с базовым.

– Отмена изменения в ячейке

Щелчком мыши выделите нужную ячейку таблицы и вызовите из контекстного меню команду Значение по базовому.

– Отмена изменений в столбце

Выделите нужный столбец, щелкнув мышью по его заголовку, и вызовите из контекстного меню команду Значение по базовому.

– Отмена всех изменений в таблице

Вызовите из контекстного меню окна Таблица изменяемых переменных команду Все значения по базовому.

Включение/отключение отображения индивидуальных допусков в таблице

Нажмите кнопку Отображать индивидуальные допуски. Подробнее об индивидуальных допусках в таблице рассказано в разделе 2.7.2.2.5.


2.7.2.2.4. Задание нового значения переменной экземпляра

Новое значение переменной экземпляра можно задать двумя способами.

Способ 1

Ввод значения переменной в ячейку таблицы изменяемых переменных.

Чтобы перейти к данному способу, в окне Таблица изменяемых переменных нажмите кнопку Значения переменных.

В окне появляется таблица, организованная следующим образом (рис. 2.7.10):

– Первый столбец содержит номера экземпляров массива.

– Первая строка содержит имена переменных копируемого объекта (заголовки столбцов таблицы).

– Вторая строка содержит значения переменных базового экземпляра. Значения в строке недоступны для редактирования (строка имеет серый цвет).

– Каждая строка таблицы, начиная с третьей, содержит номер экземпляра и набор измененных пользователем переменных. Пустая ячейка в строке означает, что переменная в этой ячейке остается без изменения, т.е. ее значение совпадает со значением соответствующей переменной базового экземпляра.

Рис. 2.7.10. Пример таблицы изменяемых переменных
для ввода нового значения переменной в ячейку таблицы (массив по сетке)

В качестве значения переменной в ячейку таблицы может быть введено число или выражение для вычисления значения. Порядок ввода выражений аналогичен описанному в разделе 7.1.3.3.

Чтобы задать значение, активизируйте нужную ячейку двойным щелчком мыши, введите в нее новое числовое значение или выражение и нажмите клавишу <Enter>. Для перемещения между ячейками можно использовать клавиши со стрелками.

На размеры эскиза или операции копируемого объекта могут быть назначены индивидуальные допуски (см. раздел 2.10.2). Если таблица содержит переменные таких размеров, то вы можете включить отображение допусков в таблице. Для этого служит кнопка Отображать индивидуальные допуски (см. рис. 2.7.10). Работая в таблице, вы можете изменить допуски на размеры эскиза или операции (см. раздел 2.7.2.2.5).

Способ 2

Задание шага изменения переменных.

Чтобы перейти к данному способу, в окне Таблица изменяемых переменных нажмите кнопку Шаг значений.

В окне появляется таблица, организованная следующим образом (рис. 2.7.11):

– Первая строка содержит имена переменных базового экземпляра (заголовки столбцов таблицы).

– Вторая строка содержит значения переменных базового экземпляра. Значения в строке недоступны для редактирования.

– Третья строка служит для задания шага изменения переменных.

Рис. 2.7.11. Пример таблицы изменяемых переменных
для задания шага изменения переменных

В третьей строке таблицы активизируйте нужную ячейку двойным щелчком мыши, введите в нее шаг изменения переменной и нажмите клавишу <Enter>. Значение шага может быть как положительным, так и отрицательным. Для перемещения между ячейками можно использовать клавиши со стрелками.

При необходимости вы можете просмотреть новые значения переменных. Для этого в окне Таблица изменяемых переменных нажмите кнопку Значения переменных. В окне отобразится таблица со значениями переменных. Столбец переменной, для которой был задан шаг изменения, будет содержать ее новые значения.

Обратите внимание на то, что значение переменной, которое получит конкретный экземпляр, зависит от его номера и типа массива.

– В массивах по параллелограммной и по концентрической сетке значения переменных для экземпляров изменяются согласно схемам, показанным на рисунках 2.7.12 и 2.7.13.

Рис. 2.7.12. Схема изменения значений переменных с заданным шагом
для экземпляров массива по параллелограммной сетке

Рис. 2.7.13. Схема изменения значений переменных с заданным шагом
для экземпляров массива по концентрической сетке

a)

– В массивах по кривой, по точкам и по таблице значения переменных для экземпляров изменяются с заданным шагом в порядке увеличения номеров экземпляров (рис. 2.7.14).

Рис. 2.7.14. Схема изменения значений переменных с заданным шагом
по порядку нумерации экземпляров (построение массива по кривой)

Таким образом, в первом случае некоторые из экземпляров имеют одинаковые значения переменной (рис. 2.7.12 и рис. 2.7.13), а во втором случае все значения переменной разные (рис. 2.7.14).


2.7.2.2.5. Индивидуальные допуски в таблице изменяемых переменных

На значения параметров экземпляров (управляющие размеры эскиза и параметры операции) могут быть назначены допуски — общие или индивидуальные (о допусках см. раздел 2.10.2). Если назначены индивидуальные допуски, то вы можете включить их отображение в таблице. Для этого служит кнопка Отображать индивидуальные допуски (см. рис. 2.7.15).

Возможность просмотра индивидуальных допусков в таблице изменяемых переменных доступна, если новые значения параметров экземпляров задаются способом, позволяющим вручную вводить в ячейки таблицы произвольные значения (способ 1, см. раздел 2.7.2.2.4).

При нажатой кнопке Отображать индивидуальные допуски в ячейках таблицы показываются следующие данные:

– В ячейках второй строки таблицы отображаются данные базового экземпляра:

• значения параметров базового экземпляра,

• заданный допуск — квалитет и предельные отклонения или предельные значения параметров базового экземпляра.

– В остальных строках таблицы, начиная с третьей, отображаются:

• набор измененных значений параметров экземпляров,

• допуски на значения параметров экземпляров.

Рис. 2.7.15. Отображение индивидуальных допусков в таблице изменяемых переменных

Обратите внимание на следующие особенности отображения данных в ячейках таблицы:

– пустая ячейка таблицы — значение и допуск параметра экземпляра в этой ячейке совпадают со значением и допуском соответствующего параметра базового экземпляра,

– ячейка содержит только значение параметра — на значение параметра экземпляра в этой ячейке назначен общий допуск или параметр не имеет допуска,

– ячейка содержит значение параметра и заданный допуск — значение и/или допуск параметра экземпляра в этой ячейке отличаются от значения и/или допуска соответствующего параметра базового экземпляра.

При нажатой кнопке Отображать индивидуальные допуски ячейки таблицы изменяемых переменных недоступны для ручного ввода.

В таблице изменяемых переменных вы можете назначить или изменить допуски на значения параметров экземпляров. Для этого служит диалог Значение и допуск.

Рис. 2.7.16. Диалог Значение и допуск: а) на линейную величину, б) на угловую величину
а) | б)

Диалог вызывается следующими способами:

– командой Назначить допуск контекстного меню ячейки таблицы.

– при нажатой кнопке Отображать индивидуальные допуски нажатием кнопки с многоточием в правой части ячейки или двойным щелчком мышью по ячейке.

Элементы управления группы Допуск описаны в таблице 3.3.5. Действия по назначению допуска аналогичны описанным в разделе 2.10.2.2.

Диалог также позволяет задать новое значение параметра экземпляра. Для этого служит поле Значение и одноименная кнопка (кнопка присутствует в диалоге для параметров экземпляров, значения которых выражены в линейных величинах). Вы можете ввести новое значение с клавиатуры. Для параметра экземпляра, выраженного в линейных величинах, значение можно также выбрать из пользовательского меню. Для этого нажмите кнопку Значение. На экране появится пользовательское меню. По умолчанию оно содержит нормальные линейные размеры по ГОСТ 6636-69.

После выполнения всех необходимых действий в диалоге закройте его, нажав кнопку ОК.

Если значение переменной параметра задано выражением, то изменить значение параметра в диалоге назначения допуска нельзя. Поле Значение и одноименная кнопка не отображаются в диалоге.

Данные базового экземпляра изменить нельзя (строка таблицы со значениями базового экземпляра имеет серый цвет).


2.7.2.3. Отчет по массиву с таблицей изменяемых переменных

Если массив содержит таблицу изменяемых переменных (см. раздел 2.7.2), вы можете создать отчет по этому массиву. Данный отчет представляет собой таблицу с размещенными в ней сведениями из таблицы изменяемых переменных (набор переменных и их значения, координаты точек). Таблицу отчета по массиву можно разместить в графическом или текстовом документе. Вы можете редактировать данные, содержащиеся в этой таблице, изменять ее заголовок, расположение и т.п.

Отчет по массиву может быть ассоциативно связан с источником данных (моделью) или не связан. Ассоциативная связь формируется при создании отчета. Порядок создания отчета по массиву приведен в разделе 2.7.2.3.1.

Если отчет по массиву ассоциативно связан с источником данных, вы можете обновлять данные в отчете, открывать документ-источник и использовать команды редактирования, доступные для ассоциативных отчетов (см. раздел 5.2.3.8). Для отчета по массиву, не связанного с источником данных, эти действия не доступны.

Приемы работы с таблицей отчета по массиву такие же, как при работе с таблицей исполнений (см. раздел 2.13.5.3).

Компоновка и настройка параметров таблицы отчета по массиву выполняется при ее создании или редактировании (см. разделы 2.7.2.3.2 и 2.7.2.3.4). Отображение текста таблицы, расположенной в графическом или текстовом документе, подчиняется настройке параметров текста таблицы отчета, выполненной для этого документа (см. разделы 9.2.4.7 и 9.2.6.24).

В этом разделе:

2.7.2.3.1. Создание отчета по массиву с таблицей изменяемых переменных

2.7.2.3.2. Настройка параметров таблицы отчета по массиву

2.7.2.3.3. Настройка отображения столбцов таблицы отчета по массиву

2.7.2.3.4. Компоновка таблицы отчета по массиву


2.7.2.3.1. Создание отчета по массиву с таблицей изменяемых переменных

Чтобы создать отчет по массиву с таблицей изменяемых переменных, выполните следующие действия.

1. Откройте модель, содержащую массив с таблицей изменяемых переменных (о таблице см. раздел 2.7.2.2).

2. Вызовите команду Создать отчет по массиву с таблицей изменяемых переменных из меню Сервис — Отчеты или с помощью одноименной кнопки на панели Отчеты.

На Панели свойств появляются элементы создания отчета (рис. 2.7.17).

Рис. 2.7.17. Панель свойств при создании отчета по массиву

3. Укажите в Дереве построения или в окне модели нужный массив.

Выбор массива без таблицы изменяемых переменных невозможен.

Указанный массив подсвечивается. Название выбранного массива отображается в поле рядом с переключателем Массив.

После выбора массива на экране появляется диалог настройки параметров таблицы отчета по массиву (см. рис. 2.7.18).

Чтобы перевыбрать массив для создания отчета, закройте диалог настройки параметров таблицы отчета и укажите нужный массив. После указания массива на экране снова появится диалог настройки параметров таблицы отчета.

Массив для создания отчета можно указать и перед вызовом команды. В этом случае для вызова диалога настройки параметров таблицы отчета следует нажать кнопку Настроить... на Панели свойств.

4. Настройте параметры таблицы отчета по массиву (см. раздел 2.7.2.3.2).

5. С помощью опции Ассоциативный отчет включите/отключите создание ассоциативной связи создаваемого отчета с документом-источником (моделью).

– Если опция включена, то созданный отчет ассоциативно связывается с документом-источником. Изменения в документе-источнике (в таблице изменяемых переменных) будут передаваться в отчет.

– Если опция отключена, то создается отчет без ассоциативной связи с документом-источником. В этом случае изменения в документе-источнике в созданный отчет не будут передаваться.

Опция Ассоциативный отчет присутствует на Панели свойств во время создания отчета по массиву при условии, что документ-источник сохранен в файл на диске. Во время редактирования отчета опция отсутствует на Панели свойств.

Ассоциативный отчет по массиву следует размещать в графическом документе. При размещении в текстовом документе ассоциативная связь отчета с документом-источником не создается.

6. Вы можете включить автоматическое присвоение номеров таблицам отчета. Для этого выберите из списка Нумерация наименование группы нумерации (о нумерации см. раздел 3.10.1).

7. Настройте компоновку таблицы отчета по массиву (см. раздел 2.7.2.3.4).

8. Для завершения создания отчета нажмите кнопку Создать объект.

На экране появляется диалог выбора документа или стандартный диалог открытия файлов. Откройте нужный графический или текстовый файл.

– В графическом документе разместите фантом таблицы отчета. Для этого укажите место расположения точки привязки таблицы курсором или путем ввода координат на Панели свойств и щелкните левой кнопкой мыши для фиксации таблицы. При необходимости вы можете задать название таблицы, см. раздел 3.4.2.4.

– В текстовом документе таблица отчета размещается автоматически.


2.7.2.3.2. Настройка параметров таблицы отчета по массиву

Настройка параметров таблицы отчета по массиву выполняется в диалоге Параметры таблицы отчета по массиву (рис. 2.7.18).

Рис. 2.7.18. Диалог настройки параметров таблицы отчета по массиву

Диалог вызывается при создании или редактировании таблицы отчета по массиву:

– автоматически после выбора массива,

– или нажатием кнопки Настроить... на вкладке Отчет по массиву Панели свойств.

По умолчанию в диалоге отображаются столбцы, соответствующие столбцам таблицы изменяемых переменных в выбранном массиве, и столбец с номерами экземпляров. Вы можете удалить из отчета какие-либо столбцы или добавить их снова.

Обратите внимание на следующую особенность таблицы изменяемых переменных в массиве по таблице. В этом массиве таблица изменяемых переменных всегда содержит столбцы с координатами экземпляров массива, но отображение этих столбцов может быть включено или отключено. Доступность аналогичных столбцов в таблице отчета зависит от того, включены ли они в массиве на момент работы с таблицей отчета.

В диалоге Параметры таблицы отчета по массиву доступны следующие действия.

– Выбор варианта отображения таблицы — с заголовком или без. Для этого используется опция С заголовком.

– Добавление, удаление и перемещение столбцов таблицы — элементы управления аналогичны используемым для настройки стиля таблицы отчета (см. таблицу 5.2.2).

– Настройка параметров отображения столбцов таблицы и данных содержащихся в них (см. раздел 2.7.2.3.3).

– Задание высоты строк таблицы. Для этого используется поле Высота строк, мм. Значение в поле вводится вручную.

– Настройка «шапки» таблицы. Данная настройка аналогична настройке «шапки» таблицы отчетов (см. раздел 5.2.2.2.4).

Чтобы завершить настройку свойств таблицы, нажмите кнопку ОК. Для выхода из диалога без изменения настроек нажмите кнопку Отмена.

Набор столбцов таблицы отчета по массиву зависит только от ее настройки. Чтобы изменить набор столбцов таблицы, следует изменить настройку. Изменение набора столбцов таблицы изменяемых переменных (в документе-источнике) в ассоциативный отчет по массиву не передается.


2.7.2.3.3. Настройка отображения столбцов таблицы отчета по массиву

Для столбцов таблицы отчета по массиву доступна настройка следующих параметров:

– Имя столбца, Знаков после запятой, Ширина столбца, мм, Выравнивание, Переносить по словам — настройка аналогична настройке параметров стиля отчета, описанной в таблице 5.2.3,

– Параметр, Формат значения, Объединять ячейки — настройка описана в таблице 2.7.2.

Табл. 2.7.2. Параметры настройки отображения столбцов таблицы отчета по массиву
Элемент | Описание
Параметр | Поле1, содержащее имя параметра экземпляров массива (например, координаты точек, задающих позиции экземпляров, имена переменных). Выберите имя параметра из списка. Перечень параметров экземпляров соответствует столбцам таблицы изменяемых переменных в выбранном массиве.
Формат значения | Поле1, позволяющее выбрать вариант отображения значения параметра экземпляра в таблице: – Значение, – Значение + допуск, – Допуск.
Объединять ячейки | Опция, позволяющая объединять соседние ячейки столбца таблицы в том случае, если содержимое этих ячеек одинаково, т.е. если отображаемое значение одно и то же для соседних ячеек.
  1. Элемент управления позволяет выбрать вариант из раскрывающегося списка. После щелчка мышью по ячейке в ее правом углу появляется кнопка с треугольником. При нажатии на кнопку на экране появляется список, из которого можно выбрать вариант параметра.


2.7.2.3.4. Компоновка таблицы отчета по массиву

Сведения о параметрах экземпляров массива можно показать не одной таблицей, а в виде нескольких таблиц. Настройка, позволяющая выбрать способ расположения таблиц на листе, производится на вкладке Компоновка Панели свойств (рис. 2.7.19).

Рис. 2.7.19. Вкладка Компоновка Панели свойств

Чтобы создать несколько таблиц и настроить их расположение на листе, выполните следующие действия.

1. Для получения нескольких таблиц включите опцию Разбить таблицу.

2. В поле Строк в таблице задайте максимальное количество строк, входящих в каждую таблицу. Параметры отображения всех таблиц одинаковы.

3. Чтобы задать порядок размещения таблиц на листе, выберите нужное направление размещения из раскрывающегося списка Компоновка.

– Вариант Вправо, затем вниз позволяет располагать таблицы горизонтальными рядами. Количество таблиц в ряду задается в поле Вправо не более.

– Вариант Вниз, затем вправо позволяет располагать таблицы вертикальными рядами. Количество таблиц в ряду задается в поле Вниз не более.

4. Введите в поле Зазор, мм расстояние между таблицами. Вы можете ввести значение расстояния вручную или выбрать его из раскрывающегося списка.


2.7.2.4. Размеры экземпляров массива

При работе со всеми массивами, кроме зеркального массива и массива по образцу, вы можете управлять формой и размерами экземпляров, изменяя значения размеров эскизов и операций этих экземпляров.

Размеры эскизов и операций экземпляра соответствуют аналогичным размерам копируемого объекта.

Чтобы для нужного экземпляра в окне модели отобразились размеры эскизов и операций, выполните следующие действия.

1. В процессе создания или редактирования массива раскройте вкладку Экземпляры Панели свойств.

2. В группе Режим активизируйте переключатель Редактировать размеры.

Группа Режим присутствует на вкладке, если в группе Тип активен переключатель Кривые, точки, вспомогательная геометрия или Операции (при отключенной опции Геометрический массив).

3. Выберите нужный экземпляр на панели Список экземпляров.

4. На панели Список объектов выберите объект (эскиз или операцию), размеры которого требуется отобразить. В окне модели появятся размеры данного объекта.

Для базового экземпляра размеры эскизов и операций не отображаются.

Вы можете изменить значения нужных размеров. При этом геометрия экземпляра массива изменяется. Отображение и особенности работы с размерами эскизов и операций экземпляра массива аналогичны описанным в разделе 2.9.2.2.

При изменении размера его переменная добавляется в таблицу изменяемых переменных массива (если данная таблица отсутствует, то она будет автоматически создана).

Для массива по таблице возможно также управление положением экземпляров путем изменения значений размеров позиции экземпляра.

Данные размеры создаются при задании координат точек, определяющих позиции экземпляров массива, и соответствуют этим координатам. Переменные размеров позиций добавляются в Окно переменных.

По умолчанию размеры позиций экземпляров не отображаются в Окне модели. Чтобы отобразить размеры позиции нужного экземпляра, выберите его на панели Список экземпляров (см. п.3 описанного выше порядка действий).

Для изменения позиции экземпляра отредактируйте значения размеров. Работа с размерами позиций аналогична работе с размерами эскизов и операций.

Если координаты точек, определяющих позиции экземпляров массива, получены из файла, то значения размеров позиций недоступны для редактирования. В этом случае размеры позиций не отображаются на экране.

Допуски размеров эскизов и операций экземпляров массива совпадают с допусками соответствующих размеров копируемого объекта. Размерам позиций экземпляров по умолчанию назначаются общие допуски.

При редактировании значения размера вы можете назначить ему другой допуск или удалить допуск.

При необходимости вы можете управлять геометрией и позициями экземпляров массива с помощью производных размеров 2.9.2.8. Эти размеры могут быть созданы для массива в целом, экземпляра массива, объектов, входящих в экземпляр массива.

Создание размеров выполняется после создания массива.


2.7.3. Массив по сетке

2.7. Массивы

2.7.3. Массив по сетке

Вы можете создать массив объектов, расположив их в узлах параллелограммной сетки, например, как показано на рис. 2.7.20.

Рис. 2.7.20. Пример массива по сетке

Схема образования сетки описана в разделе 2.7.3.1, порядок построения массива — в разделе 2.7.3.2.

В этом разделе:

2.7.3.1. Схема образования параллелограммной сетки

2.7.3.2. Порядок построения массива по сетке

2.7.3.3. Параметры сетки по первой оси

2.7.3.3.1. Направление первой оси

2.7.3.3.2. Шаг сетки вдоль первой оси

2.7.3.4. Параметры сетки по второй оси

2.7.3.4.1. Направление второй оси

2.7.3.4.2. Шаг сетки вдоль второй оси

2.7.3.5. Изменение положения экземпляров в массиве относительно базового

2.7.3.6. Размещение копий внутри сетки


2.7.3.1. Схема образования параллелограммной сетки

Параллелограммная сетка характеризуется направлением образующих ее векторов и углом между ними (рис. 2.7.21). Началом координат сетки можно считать любую точку копируемых объектов.

Рис. 2.7.21. Схема образования параллелограммной сетки

Экземпляры массива отображаются на экране в виде фантома и располагаются в пространстве в соответствии с заданными параметрами сетки. Фантом позволяет визуально проконтролировать правильность задания параметров.


2.7.3.2. Порядок построения массива по сетке

Чтобы построить массив по сетке, выполните следующие действия.

1. Вызовите команду Массив по сетке.

После вызова команды Панель свойств содержит вкладку Выбор объектов (см. рис. 2.7.3).

2. Укажите копируемые объекты (см. раздел 2.7.1.3.1).

Названия выбранных объектов отображаются на панели Список объектов, на экране появляется фантом массива.

Объекты для копирования можно выбрать и перед вызовом команды создания массива.

После выбора копируемых объектов на Панели свойств появляются вкладки Параметры, Экземпляры, Свойства.

3. Перейдите на вкладку Параметры.

3.1. С помощью элементов управления вкладки задайте параметры сетки по первой оси (см. раздел 2.7.3.3), а затем по второй (см. раздел 2.7.3.4.1).

Для задания параметров сетки массива можно использовать характерные точки (о характерных точках объектов см. раздел 2.1.4.2.2).

Управлять параметрами сетки массива с помощью характерных точек можно без перехода на вкладку Параметры.

Все сделанные изменения отображаются на фантоме массива.

4. При необходимости используйте следующие возможности:

– Изменение положения экземпляров массива относительно базового экземпляра — экземпляра, соответствующего копируемому объекту (см. раздел 2.7.3.5).

– Выбор варианта размещения копий внутри сетки (см. раздел 2.7.3.6).

– Построение геометрического массива, если копируются операции (см. раздел 2.7.1.3.5).

– Удаление или восстановление экземпляров массива. Для этого активизируйте вкладку Экземпляры Панели свойств. Подробнее об удалении или восстановлении экземпляров см. раздел 2.7.1.3.6.

– Управление формой и размерами экземпляров путем изменения значений их переменных (см. раздел 2.7.2).

– Изменение наименования массива и свойств поверхности экземпляров. Для этого активизируйте вкладку Свойства Панели свойств.

5. Подтвердите создание массива.

Созданный массив появляется в окне модели, а соответствующая его типу пиктограмма — в Дереве построения.


2.7.3.3. Параметры сетки по первой оси

В этом разделе:

2.7.3.3.1. Направление первой оси

2.7.3.3.2. Шаг сетки вдоль первой оси


2.7.3.3.1. Направление первой оси

При копировании операции направление первой оси сетки по умолчанию совпадает с осью Х эскиза этой операции.

Если копируются операции выдавливания и вращения, использующие в качестве сечения не эскиз, а другие объекты (например, грань), то направление первой оси сетки по умолчанию совпадает с осью Х абсолютной системы координат.

Если для копирования выбрано несколько операций, то направление первой оси сетки задается осью Х эскиза или осью Х абсолютной системы координат первой указанной операции.

При копировании объектов остальных типов направление первой оси сетки по умолчанию совпадает с осью X текущей системы координат (о выборе текущей системы координат см. раздел 2.8.3.3).

Название объекта, задающего направление первой оси, отображается в поле Ось 1 на Панели свойств.

Вы можете изменить направление первой оси следующими способами:

1. Задать угол между первой осью и осью X текущей системы координат в плоскости XY или осью Х в плоскости эскиза операции. Для этого следует ввести в поле Наклон значение угла наклона первой оси сетки.

2. Указать в Дереве построения или в окне модели направляющий объект. В качестве направляющего объекта может использоваться любой прямолинейный или плоский объект, а также цилиндрическая или коническая поверхность. Прямолинейные и плоские объекты перечислены в таблице 2.1.7.

Направление, задаваемое прямолинейным объектом — прямая, параллельная объекту.

Направление, задаваемое плоским объектом — прямая, перпендикулярная объекту.

Направление, задаваемое цилиндрической или конической поверхностью — прямая, параллельная оси вращения.

Наименование указанного объекта отображается в поле Ось 1.

3. Построить вектор, задающий направление оси. В этом случае в поле Ось 1 будет отображаться слово «Вектор». Для создания вектора нажмите кнопку Построение вектора на Панели специального управления. Подробнее о построении вектора см. раздел 2.8.5.

Полученное направление оси — это Прямое направление. Чтобы направить ось в противоположную сторону, активизируйте переключатель Обратное направление в группе Направление.


2.7.3.3.2. Шаг сетки вдоль первой оси

Чтобы задать шаг сетки вдоль первой оси, выполните следующие действия.

1. Введите в поле N 1 количество копий в направлении первой оси.

2. Введите в поле Шаг 1 значение шага между копиями.

3. В группе Режим 1 активизируйте переключатель, соответствующий введенному значению шага (см. табл. 2.7.3).

Табл. 2.7.3. Режим задания шага сетки

Значение опции Режим

Способ задания шага

Шаг между
соседними
экземплярами

Значение шага воспринимается системой как расстояние между соответствующими точками соседних копий в направлении оси1.

Этот вариант удобно использовать, если требуется разместить определенное количество копий на известном расстоянии друг от друга.

Шаг между
крайними
экземплярами

Значение шага воспринимается системой как расстояние между соответствующими точками первой и последней копий в направлении оси1.

Этот вариант удобно использовать, если требуется разместить на участке известной длины определенное количество копий.
  1. Если количество копий в направлении оси равно двум, то результат построения одинаков при любом состоянии переключателя Режим.

Одинаковых результатов формирования массива можно добиться при разных состояниях переключателя Режим. Для этого нужно учитывать следующее соотношение:

L = (N – 1) · l, где

L — шаг между крайними экземплярами,

N — количество копий,

l — шаг между соседними экземплярами.


2.7.3.4. Параметры сетки по второй оси

В этом разделе:

2.7.3.4.1. Направление второй оси

2.7.3.4.2. Шаг сетки вдоль второй оси


2.7.3.4.1. Направление второй оси

Чтобы задать направление второй оси сетки, активизируйте на Панели свойств переключатель Ось 2.

На Панели свойств появляются элементы управления направлением второй оси.

Вы можете задать направление второй оси следующими способами.

1. Ввести нужное значение угла между осями сетки в поле Угол раствора.

2. Указать в Дереве построения или в окне модели направляющий объект (о направляющем объекте см. п. 2 раздела 2.7.3.3.1). Название указанного объекта появляется в поле Ось 2.

3. Построить вектор, задающий направление оси (см. п. 3 раздела 2.7.3.3.1). В этом случае в поле Ось 2 будет отображаться слово «Вектор».

Полученное направление оси — это Прямое направление. Чтобы направить ось в противоположную сторону, активизируйте переключатель Обратное направление в группе Направление.


2.7.3.4.2. Шаг сетки вдоль второй оси

Параметры шага сетки вдоль второй оси аналогичны параметрам шага вдоль первой оси (см. раздел 2.7.3.3.2). Для их задания используйте поля и переключатели N 2, Шаг 2 и Режим 2.


2.7.3.5. Изменение положения экземпляров в массиве относительно базового

2.7.3.5. Изменение положения экземпляров в массиве
относительно базового

По умолчанию номер базового экземпляра (экземпляра, соответствующего копируемому объекту) — 1,1 (см. рис. 2.7.22, а). О номерах экземпляров массива рассказано в разделе 2.7.1.1.2.

Вы можете изменить положение экземпляров массива относительно базового, задав ему нужный номер в массиве (см. рис. 2.7.22, б).

Рис. 2.7.22. Изменение положения экземпляров в массиве относительно базового (базовый экземпляр показан белым цветом): а) базовый экземпляр с номером (1,1); б) базовый экземпляр с номером (2,2)
а) | б)

– Чтобы изменить номер базового экземпляра в массиве, включите на Панели свойств опцию Базовый экземпляр. На Панели свойств появляются поля Номер 1 и Номер 2. Введите в эти поля нужные номера базового экземпляра по осям сетки или задайте их счетчиком. Фантом массива перестраивается — экземпляры массива располагаются так, чтобы номер базового экземпляра в массиве соответствовал заданному.

– Чтобы вернуть базовому экземпляру умолчательный номер — 1,1, отключите опцию. Фантом массива перестраивается — экземпляры располагаются так, чтобы номер базового экземпляра стал умолчательным.


2.7.3.6. Размещение копий внутри сетки

Размещения экземпляров массива и их количество внутри первоначально заданной сетки можно изменить, например, расположить экземпляры только по периметру сетки или в шахматном порядке. Для задания требуемого варианта размещения выберите строку из списка Схема (табл. 2.7.4).

Табл. 2.7.4. Управление копиями внутри сетки
Схема размещения | Правила формирования массива | Результат построения
Стандартная схема | Экземпляры массива располагаются во всех узлах сетки. |
Удалять копии внутри сетки 1 | Экземпляры массива располагаются по периметру сетки. |
Копировать только вдоль осей 2 | Экземпляры массива располагаются только вдоль осей сетки. |
Шахматный порядок — сдвиг вдоль первой оси 2 | Экземпляры сдвигаются относительно узлов заданной сетки на полшага вдоль первой оси. Сдвиг выполняется в каждом четном ряду в текущем направлении оси. Первым рядом считается ряд, содержащий экземпляр с номером (1, 1). |
Шахматный порядок — сдвиг вдоль второй оси 2 | Экземпляры сдвигаются относительно узлов заданной сетки на полшага вдоль второй оси. Сдвиг выполняется в каждом четном ряду в текущем направлении оси. Первым рядом считается ряд, содержащий экземпляр с номером (1, 1). |
  1. Схема имеет смысл в случае, если количество экземпляров по обоим направлениям три и более.
  2. Схема имеет смысл в случае, если количество экземпляров по обоим направлениям два и более.

Положение базового экземпляра при размещении экземпляров в шахматном порядке не меняется.


2.7.4. Массив по концентрической сетке

2.7. Массивы

2.7.4. Массив по концентрической сетке

Вы можете создать массив объектов, расположив их в узлах концентрической сетки, например, как показано на рис. 2.7.23.

Рис. 2.7.23. Пример массива по концентрической сетке

Схема образования сетки описана в разделе 2.7.4.1, порядок построения массива — в разделе 2.7.4.2.

В этом разделе:

2.7.4.1. Схема построения массива

2.7.4.2. Порядок построения массива по концентрической сетке

2.7.4.3. Параметры сетки в кольцевом направлении

2.7.4.4. Параметры сетки в радиальном направлении

2.7.4.5. Ориентация экземпляров массива

2.7.4.6. Сдвиг экземпляров вдоль оси массива

2.7.4.7. Изменение положения экземпляров в массиве относительно базового

2.7.4.8. Размещение копий внутри концентрической сетки

2.7.4.9. Задание положения базовой точки базового экземпляра


2.7.4.1. Схема построения массива

Концентрическая сетка характеризуется положением ее плоскости и центра, радиусами окружностей и углом между пересекающими их радиальными лучами (рис. 2.7.24).

Рис. 2.7.24. Концентрическая сетка массива

Положение плоскости сетки и ее центра определяется осью массива и базовой точкой базового экземпляра.

Положение базовой точки базового экземпляра может быть определено автоматически или задано вручную.

Построение массива объекта по концентрической сетке описано в табл. 2.7.5.

Копирование группы объектов имеет особенности, которые описаны ниже.

Табл. 2.7.5. Построение массива объекта по концентрической сетке

Шаг построения

Результат1

1. Строится плоскость сетки, проходящая через базовую точку базового экземпляра перпендикулярно оси массива.

2. В плоскости сетки строятся первый луч и первая окружность сетки, проходящие через базовую точку. Таким образом, базовая точка базового экземпляра является первым узлом сетки.

3. Согласно параметрам сетки строятся остальные лучи и окружности сетки и находятся остальные узлы сетки.

4. Базовые точки остальных экземпляров массива совмещаются с узлами сетки. Экземпляры располагаются относительно своих базовых точек так же, как базовый располагается относительно своей.

5. Если включен доворот копий до радиального направления, то каждый экземпляр поворачивается в плоскости сетки относительно своей базовой точки так, чтобы располагаться относительно своего луча так же, как базовый располагается относительно своего.

  1. Результат построения показан в проекции на плоскость, перпендикулярную оси массива.

Если копируется группа объектов, то для всех объектов, кроме операций, массив строится следующим образом.

– Если базовая точка задана вручную, то группа объектов копируется как одно целое: строится одна сетка для группы копируемых объектов; если включен доворот, то каждый экземпляр (группа копий) поворачивается вокруг своей базовой точки (рис. 2.7.25, а).

– Если базовая точка автоопределена, то объекты группы копируются по отдельности: для каждого объекта строится собственная сетка; если включен доворот, то копия каждого объекта поворачивается вокруг своей базовой точки (рис. 2.7.25, б).

Группа операций копируется всегда как одно целое.

Рис. 2.7.25. Массив группы объектов по концентрической сетке c доворотом: а) в качестве базовой указана точка 1, б) базовая точка не указана
а) | б)


2.7.4.2. Порядок построения массива по концентрической сетке

Чтобы построить массив по концентрической сетке, выполните следующие действия.

1. Вызовите команду Массив по концентрической сетке.

После вызова команды Панель свойств содержит вкладку Выбор объектов (см. рис. 2.7.3).

2. Укажите копируемые объекты (см. раздел 2.7.1.3.1).

Названия выбранных объектов появляются на панели Список объектов.

На экране появляется фантом базовой точки копируемого объекта в виде трех взаимно перпендикулярных векторов (см. раздел 2.1.1.4).

На Панели свойств появляются вкладки Параметры, Экземпляры, Свойства.

Объекты для копирования можно выбрать и перед вызовом команды создания массива.

3. Перейдите на вкладку Параметры.

3.1. Задайте ось массива. В качестве оси массива можно использовать любой прямолинейный объект или поверхность вращения (кроме сферы). Прямолинейные объекты перечислены в таблице 2.1.7.
Активизируйте переключатель Ось на Панели свойств и укажите нужный объект в окне модели. Конструктивные оси можно также указывать в Дереве построения.

Название объекта-оси появляется в поле Ось.

После выбора оси массива на экране появляются фантом массива и стрелки, показывающие направление добавления экземпляров относительно копируемых элементов. Cетка строится с умолчательными параметрами. С помощью характерных точек фантома вы можете изменить умолчательные параметры сетки массива.

3.2. Активизируйте в группе Выбор направления переключатель В кольцевом направлении. Задайте параметры сетки в кольцевом направлении (см. раздел 2.7.4.3).

3.3. Активизируйте в группе Выбор направления переключатель В радиальном направлении. Задайте параметры сетки в радиальном направлении (см. раздел 2.7.4.4).

3.4. Выберите ориентацию экземпляров массива (см. раздел 2.7.4.5).

Все заданные изменения отображаются на фантоме массива.

4. При необходимости используйте следующие возможности:

– Сдвиг экземпляров вдоль оси массива (см. раздел 2.7.4.6).

– Изменение положения экземпляров массива относительно базового экземпляра — экземпляра, соответствующего копируемому объекту (см. раздел 2.7.4.7).

– Смена положения базовой точки базового экземпляра (см. раздел 2.7.4.9).

– Отключение использования проекции базовой точки копируемого объекта — доступно, если копируются тела/поверхности вращения (см. раздел 2.7.1.3.3).

– Построение геометрического массива — доступно, если копируются операции (см. раздел 2.7.1.3.5).

– Удаление или восстановление экземпляров массива. Для этого активизируйте вкладку Экземпляры Панели свойств. Об удалении и восстановлении экземпляров массива рассказано в разделе 2.7.1.3.6.

– Управление формой и размерами экземпляров путем изменения значений их переменных (см. раздел 2.7.2).

– Изменение наименования массива и свойств поверхности экземпляров. Для этого активизируйте вкладку Свойства Панели свойств.

5. Подтвердите создание массива.

Созданный массив появится в окне модели, а соответствующая его типу пиктограмма — в Дереве построения.

Если базовая точка базового экземпляра лежит на оси массива, то невозможно определить направление первой оси (и, следовательно, остальных осей) сетки. Количество экземпляров в радиальном направлении такого массива всегда равно 1. Изменение этого количества, а также других параметров сетки в радиальном направлении невозможно (переключатель В радиальном направлении недоступен). Такой массив не является ошибочным и, если он вас устраивает, не меняйте его исходные объекты.

В случае если необходимо изменить параметры сетки в радиальном направлении, следует выбрать другую ось массива либо другую базовую точку.


2.7.4.3. Параметры сетки в кольцевом направлении

Чтобы задать параметры сетки в кольцевом направлении, активизируйте переключатель В кольцевом направлении группы Выбор направления. После этого на Панели свойств появляются элементы управления расположением экземпляров массива в кольцевом направлении.

Введите в поле N 2 количество лучей концентрической сетки. Иными словами, в этом поле нужно указать, сколько копий должно получиться на каждой окружности сетки.

Если это количество больше единицы, становятся доступными элементы управления для задания шага сетки в радиальном направлении.

Введите в поле Шаг 2 угол между лучами сетки. Иными словами, в этом поле нужно указать угловой шаг между копиями в кольцевом направлении. Значение этого параметра не может быть больше 360°.

В группе Режим 2 активизируйте переключатель, соответствующий введенному значению шага (см. табл. 2.7.6).

Табл. 2.7.6. Режим задания шага сетки
Значение опции Режим | Способ задания шага
Шаг между соседними экземплярами | Значение шага воспринимается системой как угол между соседними лучами сетки1. Этот вариант удобно использовать, если требуется разместить определенное количество копий под известным углом друг к другу.
Шаг между крайними экземплярами | Значение шага воспринимается системой как угол между первым и последним лучами сетки1. Этот вариант удобно использовать, если требуется разместить определенное количество копий равномерно по окружности или дуге.
  1. Если количество копий в кольцевом направлении равно двум, то результат построения одинаков при любом состоянии переключателя Режим.

Одинаковых результатов формирования массива можно добиться при разных состояниях переключателя Режим. Для этого нужно учитывать следующее соотношение:

A = (N – 1) · a, где

A — угловой шаг между крайними экземплярами, причем A < 360°,

N — количество копий,

a — угловой шаг между соседними экземплярами.

Если A = 360°, то производится копирование вдоль полной окружности, и

A = N · a

Выберите направление добавления экземпляров относительно копируемых элементов — Прямое или Обратное. Для этого активизируйте соответствующий переключатель в группе Направление. Направление, соответствующее активному в данный момент переключателю, показано на экране стрелками.


2.7.4.4. Параметры сетки в радиальном направлении

Чтобы задать параметры сетки в радиальном направлении, активизируйте переключатель В радиальном направлении группы Выбор направления. После этого на Панели свойств появляются элементы управления расположением экземпляров массива в радиальном направлении.

Введите в поле N 1 количество окружностей концентрической сетки. Иными словами, в этом поле нужно указать, сколько копий должно получиться на каждом луче сетки.

Если это количество больше единицы, становятся доступными элементы управления для задания шага сетки в радиальном направлении.

Введите в поле Шаг 1 расстояние между окружностями сетки. Иными словами, в этом поле нужно указать шаг между копиями в радиальном направлении.

В группе Режим 1 активизируйте переключатель, соответствующий введенному значению шага (см. табл. 2.7.7).

Табл. 2.7.7. Режим задания шага сетки
Значение опции Режим | Способ задания шага
Шаг между соседними экземплярами | Значение шага воспринимается системой как расстояние между соседними окружностями сетки1. Этот вариант удобно использовать, если требуется разместить определенное количество копий на известном расстоянии друг от друга.
Шаг между крайними экземплярами | Значение шага воспринимается системой как расстояние между крайними окружностями сетки1. Этот вариант удобно использовать, если требуется разместить на участке известной длины определенное количество копий.
  1. Если количество копий в радиальном направлении равно двум, то результат построения одинаков при любом состоянии переключателя Режим.

Одинаковых результатов формирования массива можно добиться при разных состояниях переключателя Режим. Для этого нужно учитывать следующее соотношение:

L = (N – 1) · l, где

L — шаг между крайними экземплярами,

N — количество копий,

l — шаг между соседними экземплярами.

По умолчанию экземпляры добавляются относительно копируемых объектов в направлении от центра сетки. Это — Прямое направление. Чтобы добавлять экземпляры в направлении к центру, активизируйте переключатель Обратное направление в группе Направление.


2.7.4.5. Ориентация экземпляров массива

Экземпляры в массиве могут сохранять исходную ориентацию или поворачиваться с учетом углового шага сетки. Чтобы выбрать вариант построения, активизируйте нужный переключатель в группе Ориентация (см. табл. 2.7.8).

Табл. 2.7.8. Ориентация элементов концентрического массива
Значение опции Ориентация | Правила поворота экземпляров | Результат построения
Доворачивать до радиального направления | Каждый экземпляр поворачивается в плоскости сетки вокруг своей базовой точки так, чтобы располагаться относительно своего луча так же, как базовый располагается относительно своего. |
Сохранять исходную ориентацию | Поворот экземпляров не производится. |


2.7.4.6. Сдвиг экземпляров вдоль оси массива

Cуществует возможность сдвигать экземпляры вдоль оси массива, например, как показано на рис. 54.4.

Рис. 2.7.26. Пример массива по концентрической сетке со сдвигом экземпляров вдоль оси

Чтобы сдвинуть экземпляры вдоль оси массива, требуется задать числовое значение в поле Шаг по оси. Значение шага может быть как положительным, так и отрицательным.

На фантоме массива положительное направление оси указано прямой стрелкой.

При нулевом шаге все экземпляры находятся в одной плоскости (рис. 2.7.27, a).

При отличном от нуля шаге экземпляры смещаются вдоль оси массива (рис. 2.7.27, б).

Рис. 2.7.27. Изменение положения экземпляров массива при задании шага по оси a) нулевой шаг; б) шаг по оси отличается от нуля
а) | б)

Значение смещения T определяется по формуле:

T = t · (N – 1), где:

N — номер копии в кольцевом направлении,

t — шаг вдоль оси массива.


2.7.4.7. Изменение положения экземпляров в массиве относительно базового

2.7.4.7. Изменение положения экземпляров в массиве
относительно базового

По умолчанию номер базового экземпляра (экземпляра, соответствующего копируемому объекту) — 1,1 (см. рис. 2.7.28, а). О номерах экземпляров массива рассказано в разделе 2.7.1.1.2.

Вы можете изменить положение экземпляров массива относительно базового, задав ему нужный номер в массиве (см. рис. 2.7.28, б).

Рис. 2.7.28. Изменение положения экземпляров в массиве относительно базового экземпляра (базовый экземпляр показан белым цветом): а) базовый экземпляр с номером (1,1); б) базовый экземпляр с номером (1,2)
а) | б)

– Чтобы изменить номер базового экземпляра в массиве, включите на Панели свойств опцию Базовый экземпляр. На Панели свойств появляются поля Номер 1 и Номер 2. Введите в эти поля нужные номера базового экземпляра в кольцевом и радиальном направлении или задайте их счетчиком. Фантом массива перестраивается — экземпляры массива располагаются так, чтобы номер базового экземпляра в массиве соответствовал заданному.

– Чтобы вернуть базовому экземпляру умолчательный номер — 1,1, отключите опцию. Фантом массива перестраивается — экземпляры располагаются так, чтобы номер базового экземпляра стал умолчательным.


2.7.4.8. Размещение копий внутри концентрической сетки

Экземпляры массива можно сдвигать на полшага в кольцевом или радиальном направлении. Чтобы указать нужный вариант размещения копий, выберите строку в списке Схема (табл. 2.7.9).

Табл. 2.7.9. Управление копиями внутри концентрической сетки
Схема размещения | Правила формирования массива | Результат построения
Стандартная схема | Экземпляры массива располагаются без сдвига относительно узлов заданной сетки. |
Шахматный порядок — сдвиг в кольцевом направлении | Экземпляры кольцевых рядов сдвигаются относительно узлов заданной концентрической сетки вдоль кольцевого направления. Величина сдвига равна половине длины дуги между соседними узлами сетки. Сдвиг происходит в каждом четном ряду в направлении построения экземпляров. Первым рядом считается ряд, содержащий экземпляр с номером (1, 1). |
Шахматный порядок — сдвиг в радиальном направлении | Экземпляры радиальных рядов сдвигаются относительно узлов заданной концентрической сетки вдоль луча на полшага. Сдвиг происходит в каждом четном ряду в направлении построения экземпляров. Первым рядом считается ряд, содержащий экземпляр с номером (1, 1). |

Положение базового экземпляра при расположении экземпляров в шахматном порядке не меняется.

Варианты расположения экземпляров в шахматном порядке имеют смысл только в тех случаях, когда количество экземпляров по обоим направлениям два или более.


2.7.4.9. Задание положения базовой точки базового экземпляра

Положение базовой точки базового экземпляра может быть определено автоматически или задано вручную.

Автоопределенной базовой точкой базового экземпляра является базовая точка копируемого объекта (см. раздел 2.1.1.4).

Выбор способа задания базовой точки производится на вкладке Параметры Панели свойств с помощью группы переключателей Базовая точка.

По умолчанию в качестве базовой точки базового экземпляра используется базовая точка копируемого объекта. При этом в группе Базовая точка активен переключатель Автоопределение.

Чтобы задать положение базовой точки вручную, активизируйте переключатель Ручное указание. На Панели свойств появляются переключатель Базовая точка базового экземпляра (автоматически активизируется) и справочное поле Объект. Укажите в Дереве или окне модели нужный точечный объект (точечные объекты перечислены в таблице 2.1.7). Наименование выбранного объекта отображается в поле рядом с переключателем.

При копировании группы объектов по концентрической сетке имеются особенности, зависящие от того, автоопределена базовая точка или задана вручную (см. раздел 2.7.4.1).


2.7.5. Массив вдоль кривой

2.7. Массивы

2.7.5. Массив вдоль кривой

Вы можете создать массив объектов, расположив их вдоль указанной кривой, например, как показано на рис. 2.7.29.

Рис. 2.7.29. Пример массива вдоль кривой

Схема построения массива описана в разделе 2.7.5.1, порядок построения массива — в разделе 2.7.5.2.

В этом разделе:

2.7.5.1. Схема построения массива

2.7.5.2. Порядок построения массива вдоль кривой

2.7.5.3. Начальная точка кривой

2.7.5.4. Шаг копирования

2.7.5.5. Направление копирования вдоль траектории

2.7.5.6. Ориентация экземпляров массива

2.7.5.7. Задание положения базовой точки базового экземпляра


2.7.5.1. Схема построения массива

Массив вдоль кривой строится по-разному в зависимости от того, задана базовая точка базового экземпляра или нет.

Если базовая точка задана, то массив строится следующим образом.

1. Находится траектория копирования.

1.1. Строится копия указанной кривой: кривая параллельным переносом перемещается так, чтобы ее начальная точка совпала с базовой точкой базового экземпляра (B).

1.2. Строится отрезок, соединяющий базовую точку базового экземпляра (B) с базовой точкой копируемого объекта (А).

1.3. Строится кинематическая поверхность путем перемещения отрезка АВ вдоль копии кривой. Ребро поверхности, противоположное копии кривой, является траекторией копирования.

2. Экземпляр массива рассматривается как отдельный объект, имеющий свою базовую точку — базовую точку копии. Базовые точки копий размещаются на траектории копирования согласно заданному шагу копирования.

3. Если включен доворот, то каждая копия поворачивается вокруг своей базовой точки (см. раздел 2.7.5.6).

Схема построения массива описанным образом приведена на рис. 2.7.30, а.

Если базовая точка не задана, то массив строится следующим образом.

1. Находится траектория копирования. Для этого строится копия указанной кривой: кривая параллельным переносом перемещается так, чтобы ее начальная точка совпала с базовой точкой копируемого объекта (A). Полученная копия кривой является траекторией копирования.

2. Базовые точки копий (см. выше) размещаются на траектории копирования согласно заданному шагу копирования.

3. Если включен доворот, то каждая копия поворачивается вокруг своей базовой точки (см. раздел 2.7.5.6).

Схема построения массива описанным образом приведена на рис. 2.7.30, б.

Рис. 2.7.30. Схема копирования операции выдавливания вдоль всей направляющей с сохранением ориентации (траектория и копируемый объект выделены): а) в качестве базовой точки базового экземпляра выбрана точка B, б) положение базовой точки базового экземпляра не задано
а) | б)


2.7.5.2. Порядок построения массива вдоль кривой

Чтобы построить массив вдоль указанной кривой, выполните следующие действия.

1. Вызовите команду Массив вдоль кривой.

После вызова команды Панель свойств содержит вкладку Выбор объектов (см. рис. 2.7.3).

2. Укажите копируемые объекты (см. раздел 2.7.1.3.1).

Названия выбранных объектов появляются на панели Список объектов.

На экране появляется фантом базовой точки копируемого объекта в виде трех взаимно перпендикулярных векторов (см. раздел 2.1.1.4).

На Панели свойств появляются вкладки Параметры, Экземпляры, Свойства.

Объекты для копирования можно выбрать и перед вызовом команды создания массива.

3. Перейдите на вкладку Параметры.

3.1. Задайте кривую для создания массива.

В качестве этой кривой можно использовать:

• пространственную кривую,

• ребро,

• линию эскиза,

• цепочку вышеперечисленных объектов в любом сочетании.

Активизируйте переключатель Кривая и укажите нужный объект или объекты в Дереве построения или в окне модели. Название выбранного объекта или количество выбранных объектов отображается в поле Кривая. Повторное указание объекта отменяет его выбор.

На экране появляется фантом создаваемого массива. В качестве базовой точки базового экземпляра используется начальная точка указанной кривой (крайняя точка кривой, ближайшая к копируемому объекту) или базовая точка копируемого объекта. Это зависит от взаимного расположения копируемого объекта и начальной точки кривой (см. раздел 2.7.5.7).

3.2. При необходимости задайте начальную точку кривой вручную, если траектория копирования замкнута (см. раздел 2.7.5.3).

3.3. Введите в поле Количество количество копий.

3.4. Задайте шаг копирования (см. раздел 2.7.5.4).

3.5. При необходимости с помощью переключателей группы Направление смените направление копирования, предложенное системой (см. раздел 2.7.5.5).

3.6. Выберите ориентацию экземпляров (см. раздел 2.7.5.6).

Все изменения отображаются на фантоме массива.

4. При необходимости используйте следующие возможности:

– Смена положения базовой точки базового экземпляра (см. раздел 2.7.5.7).

– Отключение использования проекции базовой точки копируемого объекта — доступно, если копируются тела/поверхности вращения (см. раздел 2.7.1.3.3).

– Построение геометрического массива — доступно, если копируются операции (см. раздел 2.7.1.3.5).

– Удаление или восстановление экземпляров массива. Для этого активизируйте вкладку Экземпляры Панели свойств. Об удалении и восстановлении экземпляров массива рассказано в разделе 2.7.1.3.6.

– Управление формой и размерами экземпляров путем изменения значений их переменных (см. раздел 2.7.2).

– Изменение наименования массива и свойств поверхности экземпляров. Для этого активизируйте вкладку Свойства Панели свойств.

5. Подтвердите создание массива.

Созданный массив появится в окне модели, а соответствующая его типу пиктограмма — в Дереве построения.


2.7.5.3. Начальная точка кривой

Начальной точкой разомкнутой траектории считается ее крайняя точка, ближайшая к копируемому объекту.

Начальной точкой замкнутой траектории считается ее первая вершина (для цепочки объектов — вершина, ближайшая к копируемому объекту).

При необходимости вы можете задать начальную точку замкнутой траектории вручную. В качестве начальной точки можно указать любую точку на траектории.

Активизируйте переключатель Начальная точка на вкладке Параметры Панели свойств и укажите нужную точку в окне модели. Название выбранного объекта отображается в поле рядом с переключателем. Повторное указание объекта отменяет его выбор.

Зависимость расположения экземпляров массива от выбора начальной точки показана на рис. 2.7.31.

Рис. 2.7.31. Зависимость между расположением копий и положением начальной точки кривой
(траектория копирования и копируемый объект выделены,
начальной точка обозначена кружком)


2.7.5.4. Шаг копирования

Копии можно расположить равномерно вдоль всей направляющей или на заданном расстоянии друг от друга. Чтобы выбрать вариант построения, в группе Способ активизируйте соответствующий переключатель (см. табл. 2.7.10).

Табл. 2.7.10. Способы задания шага копирования
Значение опции Способ | Принцип определения шага копирования
По шагу | Можно задать значение шага и выбрать режим определения шага1: – между соседними копиями или – между крайними копиями. Введите в поле Шаг значение шага между копиями, измеренное вдоль траектории копирования. В группе Режим активизируйте переключатель, соответствующий введенному значению шага (см. табл. 2.7.11).
Вдоль всей направляющей | Полный шаг определяется автоматически как длина траектории копирования. Первый и последний экземпляры массива лежат в начальной и конечной точках направляющей кривой. Экземпляры массива расположены равномерно вдоль траектории. Поле Шаг и группа Режим отсутствуют на Панели свойств.
  1. Если задать значение полного шага, равное длине траектории, то результат построения будет таким же, как при способе построения Вдоль всей направляющей.

Табл. 2.7.11. Режим задания шага вдоль траектории

Значение опции Режим

Способ определения шага

Шаг между
соседними
экземплярами

Значение шага воспринимается системой как расстояние между соответствующими точками вставки соседних копий в направлении траектории копирования1.

Этот вариант удобно использовать, если требуется разместить определенное количество копий на известном расстоянии друг от друга.

Шаг между
крайними
экземплярами

Значение шага воспринимается системой как расстояние между соответствующими точками вставки первой и последней копий в направлении траектории копирования1.

Этот вариант удобно использовать, если требуется разместить на участке известной длины определенное количество копий.
  1. Если количество копий равно двум, то результат построения одинаков при любом состоянии переключателя Режим.

Одинаковых результатов можно добиться при разных состояниях переключателя Режим. Для этого нужно учитывать следующее соотношение:

L = (N – 1) · l, где

L — шаг между крайними экземплярами, измеренный вдоль траектории,

N — количество копий,

l — шаг между соседними экземплярами, измеренный вдоль траектории.


2.7.5.5. Направление копирования вдоль траектории

При создании массива вдоль кривой вы можете управлять направлением копирования с помощью переключателей группы Направление.

Смена направления по-разному влияет на массивы с замкнутой и разомкнутой траекториями.

Если траектория замкнута, то Прямое направление копирования означает расположение экземпляров вдоль траектории по одну сторону от копируемого объекта, а Обратное направление — по другую сторону (рис. 2.7.32). На фантоме массива текущее направление копирования показано стрелкой.

Рис. 2.7.32. Смена направления для массива с замкнутой траекторией: а) копируемый объект и траектория (выделена утолщенной линией), б) массив в прямом направлении, в) массив в обратном направлении
а) | б) | в)

Если траектория копирования замкнута и экземпляры располагаются вдоль всей направляющей (см. табл. 2.7.7), то результат операции не зависит от направления копирования.

Если траектория разомкнута, то Прямое направление копирования означает, что начало траектории определяется умолчательным образом — начальной точкой считается ближайший к копируемому объекту конец траектории. При выборе Обратного направления началом траектории будет считаться другой ее конец (рис. 2.7.33).

Рис. 2.7.33. Смена направления для массива с разомкнутой траекторией: а) копируемый объект и траектория, б) массив в прямом направлении, в) массив в обратном направлении
а) | б) | в)


2.7.5.6. Ориентация экземпляров массива

Копии в массиве могут сохранять исходную ориентацию или доворачиваться с учетом кривизны траектории. Чтобы выбрать вариант построения, активизируйте нужный переключатель в группе Ориентация (см. табл. 2.7.12).

Табл. 2.7.12. Ориентация копий вдоль кривой
Значение опции Ориентация | Правила поворота копий | Результат построения
Сохранять исходную ориентацию | Поворот копий не производится. |
Доворачивать до нормали | Каждая копия поворачивается так, чтобы ориентироваться по отношению к касательному вектору траектории в своей базовой точке так же, как копируемый объект ориентируется по отношению к касательному вектору траектории в его базовой точке. |


2.7.5.7. Задание положения базовой точки базового экземпляра

Положение базовой точки базового экземпляра может быть определено автоматически или задано вручную.

Автоопределенной базовой точкой базового экземпляра является базовая точка копируемого объекта (см. раздел 2.1.1.4).

Результат построения массива зависит от способа задания базовой точки (см. раздел 2.7.5.1).

Выбор способа задания базовой точки производится на вкладке Параметры Панели свойств с помощью группы переключателей Базовая точка.

Если базовая точка копируемого объекта совпадает с начальной точкой кривой или лежит на касательной к кривой в этой точке, то по умолчанию активен переключатель Автоопределение.

В остальных случаях по умолчанию активен переключатель Ручное указание. При этом в качестве базовой точки базового экземпляра предлагается начальная точка указанной кривой (крайняя точка кривой, ближайшая к копируемому объекту). Наименование базовой точки отображается в поле Объект.

Если требуется сменить базовую точку, активизируйте в группе Базовая точка переключатель Базовая точка базового экземпляра и укажите в Дереве построения или в окне модели нужный точечный объект (точечные объекты перечислены в таблице 2.1.7).

При необходимости вы можете сменить способ задания базовой точки. Для этого активизируйте нужный переключатель: Автоопределение или Ручное указание.

Для получения предсказуемого результата копирования рекомендуется:

– при использовании ручного указания базовой точки базового экземпляра выбирать в качестве базовой начальную точку траектории,

– при использовании автоопределения базовой точки базового экземпляра строить траекторию так, чтобы она заведомо начиналась в базовой точке копируемого объекта.


2.7.6. Массив по точкам

2.7. Массивы

2.7.6. Массив по точкам

Вы можете создать массив объектов, позиции экземпляров которого заданы точечными объектами (рис. 2.7.34). Точечные объекты перечислены в таблице 2.1.7.

Рис. 2.7.34. Пример массива по точкам

В этом разделе:

2.7.6.1. Порядок построения массива по точкам

2.7.6.2. Управление расположением экземпляров массива относительно плоскости эскиза

2.7.6.3. Ориентация экземпляров массива

2.7.6.3.1. Построение экземпляров с сохранением исходной ориентации

2.7.6.3.2. Построение экземпляров с ориентацией по объекту, связанному с точками

2.7.6.3.3. Построение экземпляров с ориентацией по указанному объекту


2.7.6.1. Порядок построения массива по точкам

Чтобы построить массив по точкам, выполните следующие действия.

1. Вызовите команду Массив по точкам.

После вызова команды Панель свойств содержит вкладку Выбор объектов (см. рис. 2.7.3).

2. Укажите копируемые объекты (см. раздел 2.7.1.3.1).

Названия указанных объектов появляются на панели Список объектов.

На экране появляется фантом базовой точки копируемого объекта в виде трех взаимно перпендикулярных векторов (см. раздел 2.1.1.4).

На Панели свойств появляются вкладки Параметры, Экземпляры, Свойства.

Объекты для копирования можно выбрать и перед вызовом команды создания массива.

3. Перейдите на вкладку Параметры.

3.1. Задайте позиции экземпляров массива. Для этого активизируйте переключатель Точки и укажите нужные точечные объекты в Дереве построения или в окне модели (точечные объекты перечислены в таблице 2.1.7). Указанные точечные объекты выделяются цветом.

Название выбранного объекта или количество выбранных объектов отображается в поле Точки. Повторное указание объекта отменяет его выбор.

На экране появляется фантом создаваемого массива: базовой точкой базового экземпляра считается базовая точка копируемого объекта; базовые точки остальных экземпляров массива совмещаются с указанными точками.

Если позиции экземпляров массива задаются точками группы или точками эскиза (эскизов), то вы можете указать нужные точки в Дереве построения или в окне модели. Для выбора сразу всех точек группы или эскиза укажите эту группу или эскиз в Дереве построения.

В случае задания позиций экземпляров точками эскиза вы можете управлять положением экземпляров относительно плоскости эскиза (см. раздел 2.7.6.2).

3.2. Выберите способ ориентации экземпляров (см. раздел 2.7.6.3).

Все сделанные изменения отображаются на фантоме массива.

4. При необходимости используйте следующие возможности:

– Смена положения базовой точки базового экземпляра (см. раздел 2.7.4.9).

– Отключение использования проекции базовой точки копируемого объекта — доступно, если копируются тела/поверхности вращения (см. раздел 2.7.1.3.3).

– Построение геометрического массива — доступно, если копируются операции (см. раздел 2.7.1.3.5).

– Удаление или восстановление экземпляров массива. Для этого активизируйте вкладку Экземпляры Панели свойств. Об удалении и восстановлении экземпляров массива рассказано в разделе 2.7.1.3.6.

– Управление формой и размерами экземпляров путем изменения значений их переменных (см. раздел 2.7.2).

– Изменение наименования массива и свойств поверхности экземпляров. Для этого активизируйте вкладку Свойства Панели свойств.

5. Подтвердите создание массива.

Созданный массив появится в окне модели, а соответствующая его типу пиктограмма — в Дереве построения.

Число копий исходного объекта равно числу точек, задающих позиции экземпляров массива (n).

Если в результате одна из копий совпадает с исходным объектом, то эта копия не создается. Число копий объекта равно n-1.


2.7.6.2. Управление расположением экземпляров массива относительно плоскости эскиза

2.7.6.2. Управление расположением экземпляров массива
относительно плоскости эскиза

В случае, когда положение экземпляров массива задано точками эскиза, вы можете настроить размещение экземпляров относительно плоскости этого эскиза. Для этого служит опция Проецировать на Панели свойств.

Если опция включена, то перед размещением экземпляра массива, положение которого задано точкой эскиза, корректируется положение базовой точки C базового экземпляра: за новую базовую точку C' принимается проекция текущей базовой точки на плоскость эскиза (рис. 2.7.35, а). Таким образом, если позиции экземпляров заданы точками разных эскизов, то эти экземпляры будут по-разному расположены относительно своих базовых точек.

При отключенной опции копирование производится обычным образом, т.е. для всех экземпляров используется одна и та же — автоопределенная или заданная пользователем — базовая точка базового экземпляра C (рис. 2.7.35, б).

Рис. 2.7.35. Задание позиций экземпляров массива: а) при включенной опции Проецировать; б) при отключенной опции Проецировать
а) | б)

На положение экземпляров, позиции которых заданы не точками эскизов, а другими точечными объектами, состояние опции Проецировать не влияет.


2.7.6.3. Ориентация экземпляров массива

Экземпляры массива могут сохранять исходную ориентацию или поворачиваться.

Чтобы выбрать вариант построения экземпляров, активизируйте нужный переключатель в группе Ориентация на Панели свойств:

– Сохранять исходную ориентацию (см. раздел 2.7.6.3.1),

– Ориентировать по объекту, связанному с точкой (см. раздел 2.7.6.3.2),

– Ориентировать по указанному объекту (см. раздел 2.7.6.3.3).

В этом разделе:

2.7.6.3.1. Построение экземпляров с сохранением исходной ориентации

2.7.6.3.2. Построение экземпляров с ориентацией по объекту, связанному с точками

2.7.6.3.3. Построение экземпляров с ориентацией по указанному объекту


2.7.6.3.1. Построение экземпляров с сохранением исходной ориентации

Вы можете построить экземпляры массива с сохранением исходной ориентации — ориентация каждого экземпляра массива в его базовой точке будет совпадать с ориентацией копируемого объекта в его базовой точке (рис. 2.7.36).

Рис. 2.7.36. Расположение экземпляров массива с сохранением исходной ориентации

Чтобы расположить экземпляры с сохранением исходной ориентации, активизируйте переключатель Сохранять исходную ориентацию в группе Ориентация на Панели свойств. После активации переключателя все экземпляры будут ориентированы в пространстве так же, как копируемый объект.


2.7.6.3.2. Построение экземпляров с ориентацией по объекту, связанному с точками

Позиции экземпляров массива могут быть заданы точками, лежащими на кривой или на поверхности. К таким точкам относятся:

– точки, построенные с помощью команды Группа точек по кривой или Группа точек по поверхности (см. разделы 2.5.3.2 и 2.5.3.3);

– точки, построенные с помощью команды Точка способом По кривой или По поверхности (см. разделы 2.5.2.5 и 2.5.2.6).

Если позиции экземпляров заданы вышеперечисленными точками, то можно ориентировать экземпляры относительно объекта (объектов), на котором лежат точки. Для этого служит переключатель Ориентировать по объекту, связанному с точкой группы Ориентация на Панели свойств.

После активизации переключателя экземпляры ориентируются следующим образом:

– Точки лежат на кривой

Каждый экземпляр поворачивается вокруг своей базовой точки так, чтобы ориентироваться по отношению к касательному вектору кривой в этой точке так же, как копируемый объект ориентируется по отношению к касательному вектору кривой в точке этой кривой, ближайшей к базовой точке копируемого объекта (рис. 2.7.37, а).

– Точки лежат на поверхности

Каждый экземпляр поворачивается вокруг своей базовой точки так, чтобы ориентироваться по отношению к нормали поверхности в этой точке так же, как копируемый объект ориентируется по отношению к нормали поверхности в точке этой поверхности, ближайшей к базовой точке копируемого объекта (рис. 2.7.37, б).

Рис. 2.7.37. Пример расположения экземпляров массива: а) с ориентацией по кривой; б) с ориентацией по поверхности
а) | б)

В набор точек, задающих позиции экземпляров, могут входить точки, не лежащие на кривой или поверхности. В этом случае после активизации переключателя Ориентировать по объекту, связанному с точкой экземпляры, позиции которых заданы этими точками, будут ориентироваться в пространстве так же, как копируемый объект.

Переключатель Ориентировать по объекту, связанному с точкой недоступен, если

– все точки, задающие позиции экземпляров, не лежат на поверхности или кривой;

– все точки, задающие позиции экземпляров, лежат на плоской поверхности или на линейной кривой;

– базовая точка копируемого объекта не проецируется на поверхность или кривую, которой принадлежат точки.


2.7.6.3.3. Построение экземпляров с ориентацией по указанному объекту

Экземпляры массива можно ориентировать по нормали к указанному объекту. В качестве объекта может использоваться:

– ребро, пространственная кривая или линия эскиза (кроме прямолинейных);

– грань (кроме плоской).

На рисунке 2.7.38 показан пример расположения экземпляров массива с ориентацией по сферической грани.

Рис. 2.7.38. Пример расположения экземпляров массива (базовый экземпляр выделен цветом): а) с сохранением исходной ориентации; б) с ориентацией по сферической грани
а) | б)

Чтобы изменить ориентацию экземпляров в пространстве относительно объекта, нажмите переключатель Ориентировать по указанному объекту. На Панели свойств рядом с переключателем появляется поле Объект.

Укажите нужный объект. Указанный объект выделяется цветом, а его наименование отображается в поле Объект.

Ориентация экземпляра определяется следующим образом:

1. Строится ближайшая проекция точки, задающей позицию экземпляра, на указанный объект (точка А).

2. Строится ближайшая проекция базовой точки базового экземпляра на указанный объект (точка В).

3. Экземпляр поворачивается вокруг своей базовой точки так, чтобы ориентироваться относительно нормали к указанному объекту в точке А так же, как копируемый объект ориентируется относительно нормали к указанному объекту в точке В.

Если точки, задающие позицию экземпляра, не проецируются на указанный объект, то экземпляры, соответствующие этим точкам, ориентируются в пространстве так же, как копируемый объект.


2.7.7. Массив по таблице

2.7. Массивы

2.7.7. Массив по таблице

Вы можете создать массив объектов, позиции экземпляров которого заданы точками. Позиции точек, в свою очередь, можно задать двумя способами:

• чтение координат, которые хранятся в виде таблицы в файле данных (о файле данных см. Приложение VI);

• ввод координат в таблицу изменяемых переменных, которая хранится в модели.

Значения, считанные из файла данных или заданные в таблице изменяемых переменных, могут интерпретироваться как прямоугольные, цилиндрические или сферические координаты точек (подробнее о типах координат точки см. раздел 2.5.3.4.1).

Если позиции экземпляров заданы с помощью файла данных, то созданный массив сохраняет связь с этим файлом.

Массив по таблице относится к объектам, использующим систему координат (о системе координат объекта см. раздел 2.8.3.4.1).

В этом разделе:

2.7.7.1. Порядок построения массива по таблице

2.7.7.2. Задание позиций экземпляров

2.7.7.2.1. Чтение данных из файла

2.7.7.2.2. Ручной ввод данных в таблицу

2.7.7.3. Особенности использования таблицы изменяемых переменных

2.7.7.4. Ориентация экземпляров массива

2.7.7.4.1. Построение экземпляров с доворотом по радиальному направлению


2.7.7.1. Порядок построения массива по таблице

Чтобы построить массив по таблице, выполните следующие действия.

1. Вызовите команду Массив по таблице.

После вызова команды Панель свойств содержит вкладку Выбор объектов (см. рис. 2.7.3).

2. Укажите копируемые объекты (см. раздел 2.7.1.3.1).

Названия выбранных объектов появляются на панели Список объектов.

На экране появляется фантом базовой точки копируемого объекта в виде трех взаимно перпендикулярных векторов (см. раздел 2.1.1.4).

На Панели свойств появляются вкладки Параметры, Экземпляры, Свойства.

Объекты для копирования можно выбрать и перед вызовом команды создания массива.

3. Перейдите на вкладку Параметры.

3.1. Задайте позиции экземпляров (см. раздел 2.7.7.2).

3.2. Выберите тип координат для интерпретации данных (из таблицы изменяемых переменных или из файла данных; подробнее о типах координат точки см. раздел 2.5.3.4.1). Для этого в группе Тип координат на Панели свойств активизируйте нужный переключатель:

• Прямоугольные X,Y,Z,

• Цилиндрические R,A,Z,

• Сферические R,A,B.

Точки для задания позиций экземпляров будут построены в системе координат, соответствующей выбранному типу.

Обратите внимание на то, что при смене типа координат их значения сохраняются — присваиваются координатам выбранного типа.

Если смена типа координат производится во время работы с таблицей изменяемых переменных (при открытом окне Таблица изменяемых переменных), то вы можете:

– сохранить значения координат — текущие значения координат присвоить координатам выбранного типа,

– пересчитать значения координат — текущие значения координат изменить согласно выбранному типу координат.

На экране появляется диалог, в котором можно выбрать нужное действие. Нажмите кнопку Да, чтобы сохранить значения координат или кнопку Нет, чтобы пересчитать значения координат.

3.3. Выберите способ ориентации экземпляров массива (см. раздел 2.7.7.4).

Все сделанные изменения отображается на фантоме массива.

4. При необходимости используйте следующие возможности:

– Смена положения базовой точки базового экземпляра (см. раздел 2.7.4.9).

– Отключение использования проекции базовой точки копируемого объекта — доступно, если копируются тела/поверхности вращения (см. раздел 2.7.1.3.3).

– Построение геометрического массива — доступно, если копируются операции (см. раздел 2.7.1.3.5).

– Удаление или восстановление экземпляров массива. Для этого активизируйте вкладку Экземпляры Панели свойств. Об удалении и восстановлении экземпляров массива см. раздел 2.7.1.3.6.

– Управление формой и размерами экземпляров, а также их позициями, путем изменения значений переменных (см. раздел 2.7.2).

– Изменение наименования массива и свойств поверхности экземпляров. Для этого активизируйте вкладку Свойства Панели свойств.

5. Подтвердите создание массива.

Созданный массив появится в окне модели, а соответствующая его типу пиктограмма — в Дереве построения.


2.7.7.2. Задание позиций экземпляров

Положение точек, которые определяют позиции экземпляров, можно задать двумя способами:

– чтением координат, которые хранятся в файле данных (о файле данных см. Приложение VI),

– ручным вводом координат в таблицу изменяемых переменных, которая хранится в модели (о таблице изменяемых переменных см.раздел 2.7.2.2).

Группа переключателей Источник данных на вкладке Параметры позволяет выбрать способ задания позиций экземпляров:

– Файл-источник — чтение данных из файла (см. раздел 2.7.7.2.1),

– Ввод вручную — ручной ввод данных в таблицу изменяемых переменных (см. раздел 2.7.7.2.2).

Особенности использования таблицы изменяемых переменных рассмотрены в разделе 2.7.7.3.

В этом разделе:

2.7.7.2.1. Чтение данных из файла

2.7.7.2.2. Ручной ввод данных в таблицу


2.7.7.2.1. Чтение данных из файла

Данный способ позволяет задать позиции экземпляров точками, координаты которых получены из ранее созданного файла (о файле данных см. Приложение VI).

Чтобы задать позиции экземпляров, выполните следующие действия.

1. Перейдите на вкладку Параметры Панели свойств и в группе Источник данных нажмите кнопку Файл-источник.

2. На экране появляется стандартный диалог открытия файлов Windows. Укажите имя нужного файла и нажмите кнопку Открыть. Имя файла отображается в поле Файл-источник.

На экране появляется фантом массива: базовой точкой базового экземпляра считается базовая точка копируемого объекта; базовые точки остальных экземпляров массива совмещаются с точками, координаты которых получены из файла данных. Эти точки выделены цветом.

О базовой точке копируемого объекта рассказано в разделе 2.1.1.4, о базовой точке экземпляра массива — в разделе 2.7.1.1.1.

Вы можете просмотреть данные, считанные из файла, в окне Таблица изменяемых переменных. Для этого выполните следующие действия.

1. Нажмите кнопку Таблица изменяемых переменных на Панели специального управления. На экране появляется окно Таблица изменяемых переменных.

2. Если координаты не отображаются в таблице, включите их показ, нажав кнопку Задать координаты базовой точки на инструментальной панели окна.

В таблице изменяемых переменных показываются колонки с координатами базовых точек экземпляров (рис. 2.7.39). Во второй строке отображаются значения координат базовой точки копируемого объекта. Каждая строка таблицы, начиная с третьей, содержит номер экземпляра и координаты точки, задающей его позицию.

Обратите внимание на то, что колонки с координатами имеют серый цвет. Это означает, что значения координат не доступны для редактирования.

Рис. 2.7.39. Пример таблицы изменяемых переменных с координатами, полученными из файла

Построенный массив сохраняет связь с файлом данных. Эта связь в целом аналогична связи группы точек с файлом-источником (см. раздел 2.5.3.4.2). Отличие состоит в управлении связью: отказаться от ее формирования при создании массива невозможно (на Панели свойств отсутствует опция Рассыпать).


2.7.7.2.2. Ручной ввод данных в таблицу

Данный способ позволяет задать позиции экземпляров путем ручного ввода координат базовых точек экземпляров в таблицу изменяемых переменных (о таблице изменяемых переменных см.раздел 2.7.2.2).

Чтобы задать позиции экземпляров, выполните следующие действия.

1. Перейдите на вкладку Параметры Панели свойств и в группе Источник данных нажмите кнопку Ввод вручную. Автоматически запускается команда Таблица изменяемых переменных (кнопка ее вызова находится на Панели специального управления).
На экране появляется окно Таблица изменяемых переменных с таблицей, организованной следующим образом (первоначальный вид таблицы; рис. 2.7.40):

– Первая строка таблицы содержит наименования координат (заголовки столбцов).

– Вторая строка содержит значения координат базовой точки копируемого объекта.

– Остальные строки таблицы содержат номера экземпляров и пустые ячейки (по умолчанию в таблице создается три строки).

Пустая ячейка таблицы изменяемых переменных означает, что координата в этой ячейке имеет значение, совпадающее со значением соответствующей координаты базовой точки копируемого объекта.

Рис. 2.7.40. Пример таблицы изменяемых переменных для ввода координат
(первоначальный вид таблицы)

Обратите внимание на то, что координаты отображаются в таблице, если на инструментальной панели окна Таблица изменяемых переменных нажата кнопка Задать координаты базовой точки.

2. Задайте нужное количество экземпляров (строк в таблице) и ведите в таблицу новые координаты базовых точек экземпляров. Новые координаты можно ввести двумя способами:

– вводом координат в ячейки таблицы (способ 1),

– заданием шага изменения координат (способ 2).

Способы заполнения таблицы подробно описаны далее в этом разделе.

3. Закройте окно Таблица изменяемых переменных кнопкой ОК.

Таблица с координатами базовых точек экземпляров добавляется в текущий файл.

На экране появляется фантом массива: базовой точкой базового экземпляра считается базовая точка копируемого объекта; базовые точки остальных экземпляров массива совмещаются с точками, координаты которых заданы в таблице изменяемых переменных.

Если в ячейку таблицы введено значение, выходящее за границы диапазона, то после нажатия кнопки ОК таблица не закрывается, на экране появляется сообщение о выходе значения за границы диапазона, а границы ячейки выделяются. Диапазон допустимых значений переменной зависит от параметра, которому она соответствует. Например, к появлению такого сообщения приводит ввод отрицательного значения в ячейку координаты В сферической системы координат, поскольку диапазон допустимых значений этой координаты составляет 0°...180°.

Приемы работы с таблицей изменяемых переменных описаны в разделе 2.7.2.2.3

Редактирование координат в таблице изменяемых переменных аналогично их вводу. Чтобы начать редактирование таблицы, нажмите кнопку Таблица изменяемых переменных на Панели специального управления.

Способы заполнения таблицы изменяемых переменных координатами точек, задающих позиции экземпляров

Способ 1

Ввод координат точек, задающих позиции экземпляров, в таблицу изменяемых переменных.

1. Чтобы перейти к данному способу, в окне Таблица изменяемых переменных нажмите кнопку Значение переменных. В окне появляется таблица изменяемых переменных, имеющая первоначальный вид (рис. 2.7.40).

2. Задайте нужное количество экземпляров. Для этого измените количество строк таблицы с помощью кнопок:

• Добавить строку выше,

• Добавить строку ниже,

• Удалить строки.

Обратите внимание на то, что сразу после добавления в таблицу строки ее ячейки пусты. Пустая ячейка означает, что координата в этой ячейке имеет значение, совпадающее со значением соответствующей координаты базовой точки копируемого объекта.

3. Введите в таблицу новые координаты базовых точек экземпляров. Для этого активизируйте нужную ячейку двойным щелчком мыши, введите новое значение координаты и нажмите клавишу <Enter>.

Способ 2

Задание шага изменения координат базовых точек экземпляров.

1. Чтобы перейти к данному способу, в окне Таблица изменяемых переменных нажмите кнопку Шаг значений.

В окне появляется таблица, организованная следующим образом (рис. 2.7.41):

– Первая строка, начиная с третьей ячейки, содержит наименования координат (заголовки столбцов).

– Второй столбец служит для задания количества экземпляров.

– Вторая строка, начиная с третьей ячейки, содержит координаты базовой точки копируемого объекта.

– Третья строка служит для задания шага изменения координат.

Рис. 2.7.41. Пример таблицы изменяемых переменных для задания шага изменения координат

2. Задайте нужное количество экземпляров.

2.1. Во втором столбце активизируйте нужную ячейку двойным щелчком мыши и введите в нее требуемое количество экземпляров массива.

2.2. Нажмите клавишу <Enter>.

3. Задайте шаг изменения координат.

3.1. В третьей строке таблицы активизируйте нужную ячейку двойным щелчком мыши и введите в нее шаг изменения координат (значение шага может быть как положительным, так и отрицательным).

3.2. Нажмите клавишу <Enter>.

При необходимости вы можете просмотреть новые координаты точек. Для этого в окне Таблица изменяемых переменных нажмите кнопку Значения переменных. В окне отобразится таблица с координатами. Столбец координаты, для которой был задан шаг изменения, будет содержать ее новые значения.


2.7.7.3. Особенности использования таблицы изменяемых переменных

Задание позиций экземпляров

Одним из способов задания позиций экземпляров массива по таблице является чтение координат точек из файла данных, см. Приложение VI.Таблица изменяемых переменных позволяет просмотреть координаты, полученные из файла.

Если отображение координат в таблице отключено, нажмите на инструментальной панели окна Таблица изменяемых переменных кнопку Задать координаты базовой точки. В таблице появляются колонки с координатами (рис. 2.7.42). Обратите внимание на то, что колонки с координатами имеют серый цвет. Это означает, что значения координат не доступны для редактирования.

Рис. 2.7.42. Пример таблицы изменяемых переменных с координатами,
полученными из файла

Другим способом задания позиций экземпляров является ручной ввод координат базовых точек экземпляров в таблицу изменяемых переменных, см. раздел 2.7.7.2.2. Ячейки таблицы для ввода значений координат имеют белый цвет (рис. 2.7.43). Это означает, что значения в этих ячейках можно изменить. Исключение составляет строка с координатами базовой точки копируемого объекта (строка имеет серый цвет) — эти координаты изменить нельзя.

Рис. 2.7.43. Пример таблицы изменяемых переменных с координатами, заданными вручную

Задание нового значения переменной экземпляра

Новые значения переменных для экземпляров массива по таблице можно получить из файла данных, см. Приложение VI. Для этого служит кнопка Читать из файла. Таблица изменяемых переменных заполняется данными из файла следующим образом: значения заносятся только в те ячейки, которые отображаются в таблице на момент чтения данных и доступны для редактирования (имеют белый цвет).

В качестве примера рассмотрим таблицу изменяемых переменных, показанную на рисунке 2.7.44. Таблица содержит столбцы с координатами базовых точек экземпляров и столбцы со значениями переменных для экземпляров.

На рисунке 2.7.44, а) ячейки с координатами недоступны для редактирования, ячейки со значениями переменных доступны. Значения из файла данных будут заноситься только в те ячейки, которые доступны для редактирования (в столбцы переменных).

На рисунке 2.7.44,б) доступны для редактирования и ячейки со значениями координат, и ячейки со значениями переменных. Значения из файла данных будут заменять содержимое всех ячеек, доступных для редактирования.

Чтобы значения координат базовых точек оставить без изменения, отключите их отображение в таблице. Это можно сделать с помощью кнопки Задать координаты базовой точки. Тогда значения из файла данных будут заноситься только в оставшиеся ячейки таблицы (в столбцы переменных).

Рис. 2.7.44. Пример таблицы изменяемых переменных:
а) координаты базовых точек экземпляров не доступны для редактирования;
б) координаты базовых точек экземпляров доступны для редактирования

а)

б)

Если при чтении файла данных обнаруживается, что он содержит больше строк, чем таблица, то:

– Для таблицы, в которой доступны для редактирования ячейки со значениями координат, рис.2.7.44, б), на экране появляется запрос на добавление дополнительных строк.

Нажмите кнопку Да, чтобы добавить дополнительные строки. Чтобы отказаться от добавления дополнительных строк, нажмите кнопку Нет.

– Для таблицы, в которой ячейки со значениями координат недоступны для редактирования, рис.2.7.44, а), запрос на добавление дополнительных строк не выдается. Данные из файла данных заносятся только в те строки, которые присутствуют в таблице.

Запись таблицы в файл данных

В файл данных записываются только те значения, которые расположены в ячейках, доступных для редактирования. Если отображение ячеек в таблице выключено, запись значений из этих ячеек не выполняется.

Рассмотрим запись в файл таблицы, приведенной на рис. 2.7.44.

На рисунке 2.7.44, а) показана таблица, у которой ячейки с координатами не доступны для редактирования, а ячейки со значениями переменных доступны. В файл данных будут записываться только значения переменных.

На рисунке 2.7.44, б) показана таблица, у которой доступны для редактирования и ячейки со значениями координат, и ячейки со значениями переменных. В файл данных будут записываться значения координат и значения переменных.


2.7.7.4. Ориентация экземпляров массива

Экземпляры массива могут сохранять исходную ориентацию или поворачиваться.

Чтобы выбрать вариант построения экземпляров, активизируйте нужный переключатель в группе Ориентация на Панели свойств:

– Сохранять исходную ориентацию (см. раздел 2.7.6.3.1),

– Доворачивать по радиальному направлению (см. раздел 2.7.7.4.1),

– Ориентировать по объекту (см. раздел 2.7.6.3.3).

В этом разделе:

2.7.7.4.1. Построение экземпляров с доворотом по радиальному направлению


2.7.7.4.1. Построение экземпляров с доворотом по радиальному направлению

Если позиции экземпляров заданы в цилиндрических или сферических координатах, можно ориентировать экземпляры по радиальному направлению. Для этого служит переключатель Доворачивать по радиальному направлению группы Ориентация на Панели свойств.

После активизации переключателя экземпляры ориентируются следующим образом:

– Позиции экземпляров заданы в цилиндрических координатах

Каждый экземпляр поворачивается вокруг своей базовой точки так, чтобы ориентироваться по отношению к перпендикуляру, опущенному из этой точки на ось Z, так же, как базовый экземпляр ориентируется по отношению к перпендикуляру, опущенному из его базовой точки на ось Z (см. рис. 2.7.45, а).

– Позиции экземпляров заданы в сферических координатах

Каждый экземпляр поворачивается вокруг своей базовой точки так, чтобы ориентироваться по отношению к лучу, проведенному из центра сферы в его базовую точку, так же, как базовый экземпляр ориентируется по отношению к своему лучу, проведенному из центра сферы в его базовую точку (см. рис. 2.7.45, б).

Рис. 2.7.45. Пример ориентации экземпляров массива по радиальному направлению: а) позиции заданы в цилиндрических координатах; б) позиции заданы в сферических координатах
а) | б)


2.7.8. Зеркальный массив

2.7. Массивы

2.7.8. Зеркальный массив

Вы можете создать копию объектов, которая является его зеркальным отражением относительно указанного плоского объекта.

Создание зеркальной копии компонентов модели невозможно.

Рис. 2.7.46. Зеркальное копирование объектов: а) исходная деталь (плоскость симметрии для копирования показана условно), б) результат копирования основания и лапки относительно средней плоскости прямоугольного выступа
а) | б)

– Результат зеркального копирования операции, поверхности, кривой, точки, вспомогательной плоскости или поверхности — новый объект того же типа, что и копируемый, зеркально симметричный ему.

– Результат зеркального копирования тела — тело, обладающее плоскостью симметрии или новое тело, зеркально симметричное имеющемуся.

Зеркальный массив для различных типов объектов строится по-разному. Поэтому набор элементов управления для создания зеркальной копии объекта зависит от типа этого объекта — для тела и поверхности используется один набор элементов управления, для операций, кривых, точек, вспомогательных плоскостей и осей — другой.

Порядок построения зеркального массива операций, кривых, точек, вспомогательных плоскостей и осей описан в разделе 2.7.8.1, порядок построения зеркальной копии тела или поверхности — в разделе 2.7.8.2.

Обратите внимание на то, что за один вызов команды вы можете скопировать:

– либо одну или несколько операций,

– либо один или несколько объектов следующих типов: кривая, точка, вспомогательная плоскость или ось,

– либо одно тело,

– либо одну поверхность.

В этом разделе:

2.7.8.1. Порядок построения зеркального массива операций, кривых, точек, вспомогательных плоскостей и осей

2.7.8.2. Порядок построения зеркальной копии тела или поверхности

2.7.8.2.1. Результат зеркального копирования тела


2.7.8.1. Порядок построения зеркального массива операций, кривых, точек, вспомогательных плоскостей и осей

2.7.8.1. Порядок построения зеркального массива операций,
кривых, точек, вспомогательных плоскостей и осей

Чтобы построить зеркальный массив операций или кривых, точек, вспомогательных плоскостей и осей, выполните следующие действия.

1. Вызовите команду Зеркальный массив.

После вызова команды Панель свойств содержит вкладку Выбор объектов (см. рис. 2.7.3).

2. Укажите копируемые объекты: операции или кривые, точки, вспомогательные плоскости и оси.

Подробнее о выборе копируемых объектов см. раздел 2.7.1.3.1.

Названия выбранных объектов появляются на панели Список объектов.

На Панели свойств появляются вкладки Параметры и Свойства.

Объекты для копирования можно выбрать и перед вызовом команды создания массива.

3. Активизируйте переключатель Плоскость и укажите плоскость симметрии в Дереве построения или в окне модели. Название выбранного объекта отображается в поле рядом с переключателем.

4. При необходимости используйте следующие возможности:

– Построение геометрического массива, если копируются операции (см. раздел 2.7.1.3.5).

– Изменение наименования массива и свойств поверхности экземпляров. Для этого активизируйте вкладку Свойства Панели свойств.

5. Подтвердите создание массива.

Созданный массив появится в окне модели, а соответствующая его типу пиктограмма — в Дереве построения.


2.7.8.2. Порядок построения зеркальной копии тела или поверхности

Чтобы построить зеркальную копию тела или поверхности, выполните следующие действия.

1. Вызовите команду Зеркальный массив.

После вызова команды Панель свойств содержит вкладку Выбор объектов (см. рис. 2.7.3).

2. Активизируйте в группе Тип переключатель Тела или поверхности.

3. Укажите копируемый объект: тело или поверхность. Указанный объект выделяется цветом.

Подробнее о выборе копируемых объектов см. раздел 2.7.1.3.1.

На Панели свойств появляются вкладки Результат операции и Свойства.

Объект для копирования можно выбрать и перед вызовом команды создания массива.

4. Укажите плоский объект, который будет служить плоскостью симметрии при копировании. Таким объектом может являться любая плоская грань, проекционная или вспомогательная плоскость.

После указания тела (поверхности) и плоскости симметрии на экране появится фантом зеркальной копии тела (поверхности).

5. Выберите нужный результат копирования в случае, когда копируется тело. Для этого используйте на вкладке Результат операции одноименную группу переключателей (см. раздел 2.7.8.2.1).

6. С помощью переключателей группы Режим укажите, требуется ли оставлять копируемый объект после выполнения команды или нет.

7. При необходимости используйте следующие возможности:

– Отмена выбора всех объектов на текущей вкладке Панели свойств.
Для этого нажмите кнопку Указать заново на Панели специального управления. Подсветка с ранее выбранного объекта (объектов) будет снята, и вы сможете указать другой объект.

– Изменение наименования массива и свойств поверхности экземпляров. Для этого активизируйте вкладку Свойства Панели свойств.

8. Подтвердите создание массива.

В окне модели появится зеркальная копия выбранного тела или поверхности, а в Дереве построения — пиктограмма Зеркальное отражение.

В этом разделе:

2.7.8.2.1. Результат зеркального копирования тела


2.7.8.2.1. Результат зеркального копирования тела

– Активизируйте переключатель Автоопределение, чтобы результат операции был определен автоматически. При этом построение выполняется следующим образом:

• если зеркальная копия тела не пересекается и не имеет общих поверхностей с исходным телом, то копия строится как отдельное тело,

• если зеркальная копия тела пересекается или имеет общую поверхность с исходным телом, то происходит объединение тел в одно.

Переключатель работает только при создании зеркального массива. При редактировании массива в первом случае на Панели свойств активен переключатель Новое тело, во втором — переключатель Объединение.

– Активизируйте переключатель Новое тело, чтобы зеркальная копия представляла собой отдельное тело вне зависимости от того, пересекается она с исходным телом или нет.

– Активизируйте переключатель Объединение, чтобы объединить исходное тело и его зеркальную копию.

При построении новой зеркальной копии результат операции определяется автоматически (т.е. по умолчанию в группе Результат операции активен переключатель Автоопределение).

Если был активизирован — вручную или автоматически — переключатель Объединение, то построение зеркальной копии тела возможно только при условии, что она пересекается или имеет общую поверхность с исходным телом. Если условие не выполняется, то операция копирования отмечается как ошибочная.


2.7.9. Массив по образцу

2.7. Массивы

2.7.9. Массив по образцу

Вы можете создать массив компонентов текущей модели, расположив их так же, как расположены экземпляры другого — уже существующего массива — массива-образца.

В качестве массива-образца можно использовать массив любого типа, кроме массива по образцу.

Если массивом-образцом является зеркальный массив, то экземпляр созданного массива имеет левостороннюю СК (см. раздел 2.8.3.1.1).

Изменение параметров массива-образца передается в массив по образцу — он перестраивается.

В этом разделе:

2.7.9.1. Порядок построения массива компонентов по образцу

2.7.9.2. Размещение экземпляров массива


2.7.9.1. Порядок построения массива компонентов по образцу

Чтобы построить массив компонентов по образцу, выполните следующие действия.

1. Вызовите команду Массив по образцу.

После вызова команды на Панели свойств активна вкладка Выбор объектов.

Рис. 2.7.47. Вкладка Выбор объектов

2. Укажите копируемые компоненты для создания массива. Названия указанных компонентов появляются на панели Список объектов.

3. Активизируйте вкладку Параметры.

3.1. Выберите массив-образец. Для этого активизируйте переключатель Массив-образец и укажите в Дереве построения или в окне модели нужный массив объектов.

Выбранный массив-образец выделяется цветом, его название появляется в поле рядом с переключателем.

На экране появляется фантом создаваемого массива.

3.1. Выберите способ размещения экземпляров массива относительно массива-образца (см. раздел 2.7.9.2).

3.2. Если массив-образец имеет вложенность (т.е. его исходным объектом является другой массив), вы можете управлять количеством экземпляров создаваемого массива с помощью опции Учитывать вложенность.

Если опция включена, то количество экземпляров создаваемого массива будет равно произведению количества экземпляров массива-образца на количество экземпляров вложенного массива, а если отключена — просто равно количеству экземпляров массива-образца.

3.3. Если в массиве-образце имеются удаленные экземпляры, то вы можете управлять количеством экземпляров создаваемого массива с помощью опции Учитывать удаленные (об удалении экземпляров см. раздел 2.7.1.3.6).

Если опция включена, создаваемый массив не будет содержать экземпляры, соответствующие удаленным экземплярам массива-образца, а если отключена — будет содержать.

Все изменения отображаются на фантоме массива.

4. При необходимости измените наименование массива. Для этого используйте элементы управления вкладки Свойства Панели свойств.

5. Подтвердите создание массива.

Созданный массив появится в окне модели, а соответствующая его типу пиктограмма — в Дереве построения.


2.7.9.2. Размещение экземпляров массива

Существует два способа размещения экземпляров массива по образцу.

Способ 1

Экземпляры создаваемого массива размещаются в пространстве согласно параметрам массива-образца.

В этом случае из массива-образца извлекаются данные о его типе и параметрах, а затем используются для построения массива по образцу. Например, если в качестве массива-образца используется массив по сетке, то извлекаются данные об объектах, служащих осями массива и о значении шага экземпляров по каждой оси сетки. Результат построения массива будет таким же, как при построении массива компонентов того же типа, что массив-образец, и с такими же параметрами.

На рисунке 2.7.48 приведен пример построения массива по образцу по параметрам массива-образца. В качестве массива-образца используется массив по сетке — его экземпляры показаны серым цветом. Копируемый компонент каждого из массивов расположен в его нижнем левом углу (выделен утолщенной линией).

Рис. 2.7.48. Размещение экземпляров массива по образцу согласно параметрам массива-образца

Чтобы построить массив по образцу данным способом, активизируйте переключатель По параметрам массива-образца в группе Способ на Панели свойств.

Способ 2

Экземпляры создаваемого массива размещаются относительно соответствующих им экземпляров массива-образца так же, как копируемый объект размещается относительно соответствующего ему экземпляра массива-образца (базового экземпляра). По умолчанию в качестве базового экземпляра в массиве-образце выбирается экземпляр, ближайший к копируемому компоненту. Если копируется несколько компонентов, то в качестве базового экземпляра в массиве-образце выбирается экземпляр, ближайший к тому компоненту, который был указан первым. При необходимости вы можете сменить базовый экземпляр.

Чтобы построить массив по образцу данным способом, выполните следующие действия.

1. В группе Способ на Панели свойств активизируйте переключатель Сохранять положение относительно экземпляра массива-образца.

Базовый экземпляр массива-образца, выбранный по умолчанию, выделяется цветом. Фантом массива перестраивается — экземпляры массива размещаются относительно соответствующих им экземпляров массива-образца так же, как копируемый компонент размещается относительно базового экземпляра массива-образца. На Панели свойств появляется элемент управления Экземпляр.

2. Если требуется сменить базовый экземпляр, активизируйте переключатель Экземпляр и укажите нужный экземпляр массива-образца в Дереве построения или в окне модели. Наименование указанного экземпляра отображается в поле рядом с переключателем. Фантом массива перестраивается.

Пример построения массива по образцу данным способом показан на рисунке 2.7.49. В качестве массива-образца используется массив по сетке — его экземпляры показаны светло-серым цветом. Копируемый компонент создаваемого массива показан темно-серым цветом. Базовый экземпляр массива-образца выделен утолщенной линией.

Рис. 2.7.49. Размещение экземпляров массива по образцу с сохранением взаимного расположения копируемого компонента и базового экземпляра массива-образца: а) базовый экземпляр массива-образца выбран по умолчанию; б) базовый экземпляр массива-образца указан пользователем
а) | б)


2.7.10. Массив произвольных объектов

2.7. Массивы

2.7.10. Массив произвольных объектов

Во всех массивах, кроме зеркального и массива по образцу, есть возможность копирования произвольного набора объектов. Это позволяет создать массив объектов различных типов за одну операцию.

Чтобы создать массив произвольных объектов, после вызова команды построения массива нужного типа (например, массива по сетке) необходимо в группе Тип активизировать переключатель Произвольный. На Панели свойств появятся вкладки Параметры, Экземпляры, Результат операции и Свойства.

Все действия по созданию массива произвольных объектов аналогичны действиям по созданию массива объектов выбранного типа (например, операций). Исключение составляют следующие:

– выбор объектов для копирования (см. раздел 2.7.10.1),

– задание области применения массива (см. раздел 2.7.10.2).

При создании массива по концентрической сетке, по точкам, по таблице, вдоль кривой обратите внимание на следующую особенность.

Если положение базовой точки базового экземпляра (см. раздел 2.7.1.1.1) определяется автоматически, то данная точка совпадает с базовой точкой того объекта, который занимает первую строку в списке копируемых объектов (объекты располагаются в списке в том же порядке, что и в Дереве построения модели). Так, например, если для копирования выбраны операция и ее эскиз, то базовая точка базового экземпляра совпадает с началом системы координат эскиза.

При разрушении массива произвольных объектов обратите внимание на следующие особенности. В результате разрушения массива все объекты, составлявшие данный массив, преобразуются в объекты, полностью аналогичные исходным. Исключение составляют эскизы, которые копировались без своих базовых плоскостей. Такие эскизы после разрушения массива теряют связи с базовыми плоскостями и размещаются в модели способом Независимое размещение (подробнее о независимом размещении эскиза см. раздел 2.2.2.2).

В этом разделе:

2.7.10.1. Основные принципы выбора объектов

2.7.10.1.1. Копируемые объекты и их исходные объекты

2.7.10.1.2. Системы координат исходных объектов

2.7.10.1.3. Изолирование копируемых объектов

2.7.10.2. Область применения массива произвольных объектов


2.7.10.1. Основные принципы выбора объектов

При создании массива произвольных объектов в качестве копируемых могут быть указаны объекты различных типов — операции, поверхности, кривые, точки, вспомогательные плоскости, оси, эскизы, системы координат и т.п.

Невозможно указать в качестве копируемых объектов тела, компоненты, ранее созданные массивы и некоторые операции, такие как ребро жесткости, оболочка, листовое тело, придать толщину и т.п.

Копируемые объекты указываются в Дереве построения. Названия выбранных объектов появляются на панели Список объектов.

При включенной опции Выбирать промежуточные элементы в набор включаются не только указанные объекты, но и объекты, находящиеся между ними в Дереве построения. Включение промежуточных объектов в набор не зависит то того, какой вид Дерева включен — последовательность построения или структура модели. Первый, последний и промежуточные объекты определяются на основе последовательности построения модели. Объекты, которые невозможно скопировать, в набор не включаются.

Для корректного построения массива используются следующие приемы:

– выбор копируемых объектов вместе с их исходными объектами:

• указание всех исходных объектов, в том числе эскизов и тех объектов, которые использовались для построения исходных (см. раздел 2.7.10.1.1),

• указание систем координат исходных объектов (см. раздел 2.7.10.1.2),

– изолирование копируемых объектов (см. раздел 2.7.10.1.3).

Выбор нужного приема определяется порядком и способами построения копируемых объектов.

В этом разделе:

2.7.10.1.1. Копируемые объекты и их исходные объекты

2.7.10.1.2. Системы координат исходных объектов

2.7.10.1.3. Изолирование копируемых объектов


2.7.10.1.1. Копируемые объекты и их исходные объекты

При создании массива произвольных объектов для каждого экземпляра выполняются те же построения, что и для копируемого объекта. Поэтому требуется указать не только сами копируемые объекты, но и объекты, необходимые для их построения (в том числе эскизы).

Примеры

– Для построения операции выдавливания использовался эскиз. При выборе объектов для копирования необходимо указать и операцию выдавливания, и ее эскиз. Каждый экземпляр массива будет включать копию эскиза и копию операции выдавливания. В противном случае все экземпляры массива будут построены на одном эскизе — эскизе исходной операции выдавливания — и совпадут с ней.

– В модели построены точки. Эти точки использованы для построения сплайна. Копируемая поверхность получена вращением сплайна вокруг отрезка, созданного в пространстве модели.
Для корректного построения массива необходимо указать следующие объекты: поверхность вращения, отрезок, сплайн и точки, использованные для построения сплайна. Каждый экземпляр массива будет включать копии всех этих объектов.

• Если указаны все объекты, кроме отрезка (оси вращения), то все экземпляры будут иметь одну и ту же ось — ось вращения копируемой поверхности.

• Если указаны все объекты, кроме точек, использованных для построения сплайна, то копии сплайна в экземплярах не могут быть созданы. Все экземпляры поверхности будут построены вращением одного и того же — исходного — сплайна вокруг осей этих экземпляров.


2.7.10.1.2. Системы координат исходных объектов

Исходный объект копируемого объекта может быть связан с началом СК (например, объект в эскизе связывается с началом СК с помощью управляющего размера или привязки). Для корректного построения массива в данном случае необходимо указать и объект, и СК. Указание СК может также понадобиться, если при создании массива или дальнейшей работе с ним требуется задавать координаты объектов в экземплярах.

Если СК указана, то для каждого экземпляра создается копия СК, относительно которой определяются координаты объектов, входящих в экземпляр. Значения координат остаются неизменными. В противном случае копии СК не создаются. Координаты объектов, входящих в экземпляры, определяются относительно исходной СК и имеют различные значения.

Примеры

– Для построения операции выдавливания использовался эскиз. Он представляет собой окружность, центр которой связан управляющим размером с началом абсолютной СК. При выборе объектов для копирования необходимо указать операцию выдавливания, ее эскиз и абсолютную СК. Каждый экземпляр массива будет включать копии всех этих объектов: операцию выдавливания, эскиз с размером и СК. Размер проставляется между центром окружности в эскизе экземпляра и началом соответствующей этому экземпляру копии СК. Если при создании массива СК не указана, то ее копии в экземплярах не создаются. Окружности в эскизах экземпляров остаются связанными с исходной СК. Поэтому копии окружности совпадают с исходной окружностью, а копии операции выдавливания — с исходной операций.

– Координаты концов отрезка заданы в абсолютной СК. Если при выборе объектов для копирования указаны отрезок и абсолютная СК, то каждый экземпляр массива включает копию отрезка и копию СК. Координаты концов отрезка в экземпляре определяются относительно СК этого экземпляра, поэтому значения координат остаются неизменными. Если при создании массива указан только отрезок, то копии СК в экземплярах не создаются. Координаты концов отрезка в экземплярах определяются относительно исходной СК и имеют различные значения.


2.7.10.1.3. Изолирование копируемых объектов

В некоторых случаях при построении массива нельзя указать исходные объекты копируемого объекта или их указание затруднительно (см. Примеры). Чтобы экземпляры массива были построены корректно, необходимо предварительно разорвать связи копируемого объекта с его исходными объектами. Для этого используется изолирование объектов (порядок изолирования приведен ниже). После выполнения изолирования создается объект Копирование, который должен быть указан вместе с копируемым при создании массива.

Примеры

– Отверстие построено на грани, полученной выдавливанием эскиза. Ребра этой грани определяют положение отверстия. Чтобы построить массив отверстий, необходимо указать копируемое отверстие и исходную для него операцию выдавливания. При этом каждый экземпляр массива будет содержать и отверстие, и операцию выдавливания, что приведет к изменению параметров тела. Чтобы этого не произошло, нужно указать не всю операцию выдавливания, а только те ее объекты, без которых невозможно построение отверстия, т.е. плоскую грань, на которой расположено отверстие, и ребра, определяющие его положение. Для этого применим к отверстию команду Изолировать объекты. В результате создается копия, включающая только необходимые для построения объекты. Связь отверстия с операцией выдавливания заменяется связью с полученной копией. Теперь при создании массива необходимо указать копируемое отверстие и копию его исходных объектов.

– Поверхность построена по сети точек. Для корректного построения экземпляров этой поверхности в массиве необходимо указать и саму поверхность, и все ее точки. Это может занять длительное время. Если к поверхности применить команду Изолировать объекты, то при построении массива потребуется указать только копируемую поверхность и объект Копирование, полученный при ее изолировании.

Порядок изолирования объектов

Чтобы изолировать объект от исходных объектов, выделите его в Дереве построения и вызовите команду Редактор — Изолировать объекты (при указании тела или поверхности команда недоступна).

Рекомендуется указывать изолируемые объекты при отображении в Дереве последовательности построения модели.

После вызова команды в модели появляется копия исходных объектов изолируемого объекта. Данная копия представляет собой объект модели, содержащий геометрические объекты без истории. Эти объекты являются копиями исходных геометрических объектов изолируемого объекта и ассоциативно связаны с ними.

Копия создается в абсолютной системе координат и отображается в Дереве построения модели в виде объекта Копирование, который располагается в Дереве перед изолируемым объектом (при включенном отображении последовательности построения модели). Объекты, входящие в копию, отображаются в окне модели. При необходимости вы можете скрыть отображение объектов копии.

В результате выполнения команды связи изолированного объекта с его исходными объектами заменяются связями с объектами полученной копии.

В копию включаются плоскости, грани, вершины и ребра (в зависимости от набора исходных объектов).

Например, поверхность получена вращением дуги окружности вокруг ребра элемента выдавливания. При изолировании поверхности вращения создается копия, в которую входят дуга окружности (сечение вращения) и ребро (ось вращения). Операция выдавливания, которой принадлежит это ребро, в копию не включается.

Если исходным объектом является эскиз, то в копию включаются только те объекты эскиза, которые выполняют функции оси, траектории, направляющего объекта. Остальные объекты и сам эскиз в состав копии не включаются. Изолируемый объект сохраняет связь с эскизом. Поэтому независимо от использования команды изолирования объектов для корректного построения массива необходимо указывать эскизы копируемых объектов.

Изолирование объекта не может быть выполнено, если его исходными объектами являются только:

– эскиз,

– система координат,

– объекты, которые не содержатся в Дереве построения модели (например, если для построения поверхности использованы координаты точек из файла).

В этих случаях после вызова команды на экране появляется сообщение о том, что объект не имеет заменяемых связей.

Если эскиз содержит объект, являющийся осью, траекторией или задающий направление построения, то изолирование выполняется.

Вы можете изолировать сразу несколько объектов, если они расположены друг за другом в Дереве (при включенном отображении последовательности построения модели). Для этого перед вызовом команды выделите нужные объекты с помощью клавиши <Shift> или <Ctrl>.

Изолирование не предусмотрено для массивов, элементов оформления и некоторых операций, таких как фаска, скругление, уклон, оболочка, булева операция, изменить положение, вычесть компоненты, копирование, масштабирование, операций листового тела.


2.7.10.2. Область применения массива произвольных объектов

При создании массива произвольных объектов вы можете задать область применения операции. Общие сведения об области применения операции приведены в разделе 2.3.10.1.

Для задания области применения массива используется вкладка Результат операции Панели свойств (рис. 2.7.50).

Рис. 2.7.50. Задание области применения массива

На этой вкладке содержится группа переключателей Область применения, которая позволяет выбрать тип области применения операции:

– «Компоненты и тела» — действие операции распространяется на компоненты, включенные в модель, и на тела, созданные в модели,

– «Компоненты» — действие операции распространяется только на компоненты, включенные в модель,

– «Тела» — действие операции распространяется только на тела, созданные в модели.

После выбора типа области применения укажите объекты, составляющие эту область. Для указания тел используются элементы, расположенные на вкладке Результат операции. Если в область применения должны быть включены компоненты, нажмите кнопку Область применения «Компоненты» на Панели специального управления. После этого на вкладке Параметры появляются нужные элементы управления (см. раздел 2.3.10.4.1).

По умолчанию область применения определяется автоматически. При этом и для тел, и для компонентов активизирован переключатель Автоопределение.

Автоопределение означает, что в область применения включаются все объекты (тела, компоненты или и то и другое), с которыми пересекаются экземпляры массива, кроме скрытых и исключенных из расчета объектов.

Если экземпляр массива содержит операцию, добавляющую материал, то он объединяется с телом (в случае пересечения с компонентом экземпляр объединяется с телом компонента). При отсутствии пересечений экземпляр создается как самостоятельное тело.

Если экземпляр массива содержит операцию, удаляющую материал, то при отсутствии пересечений в модели возникает ошибка.

Особенностью автоопределения при работе с массивом является то, что при этом не формируется список объектов, составляющих область применения. Если состав модели изменяется, то автоматически изменяется и область применения массива.

Автоматическое определение области применения массива предпочтительнее ручного указания объектов. При этом система сама определяет, с какими телами и компонентами пересекается каждый экземпляр массива, и включает эти объекты в область применения.

При ручном указании тел обратите внимание на то, что каждое указанное тело должно пересекаться со всеми экземплярами массива. В противном случае в модели появляется ошибка.

В некоторых случаях требуется вручную выбрать объекты, составляющие область применения. Например, грани двух тел соприкасаются. В одном из тел построено отверстие, глубина которого определяется способом Через все. Если при создании массива область применения будет определяться автоматически, то полученные экземпляры отверстий пройдут через оба тела. Чтобы этого не произошло, необходимо вручную указать нужное тело.

Ручное указание тел описано в текущем разделе, а компонентов — в разделе 2.3.10.4.2.

Чтобы указать нужные тела, отключите переключатель Автоопределение. На Панели свойств появится группа Тела, содержащая следующие переключатели:

– Все тела — позволяет включить в область применения массива все тела, кроме скрытых и исключенных из расчета, вне зависимости от того, пересекаются они с редактируемым элементом или нет.

– Выбор тел — позволяет вручную указать тела, которые должны входить в область применения текущей операции.

После активизации переключателя Выбор тел становится доступной панель Список тел. Она содержит перечень тел, включенных в область применения операции, и две кнопки: Выбрать все и Удалить.

Чтобы добавить тело в область применения, укажите его в окне модели или в Дереве построения.

Кнопка Выбрать все позволяет включить в область применения операции все построенные в модели тела, в том числе скрытые тела и тела, непересекающиеся с редактируемым элементом.

Кнопка Удалить позволяет исключить тело из области применения.

При построении массива отверстий с фаской или скруглением обратите внимание на следующую особенность.

Если все экземпляры массива пересекаются с телом (компонентом), которое содержит копируемые объекты, то массив строится корректно.

Если какой-либо экземпляр массива пересекается с другим телом (компонентом), то фаска (скругление) на этом экземпляре не строится. В модели появляется ошибка.


2.8. Вспомогательные объекты

В этом разделе:

2.8.1. Вспомогательные оси

2.8.1.1. Ось через две вершины

2.8.1.2. Ось на пересечении плоскостей

2.8.1.3. Ось через ребро

2.8.1.4. Ось конической поверхности

2.8.1.5. Ось через вершину по объекту

2.8.1.5.1. Объекты, используемые при построении

2.8.1.5.2. Построение оси

2.8.2. Вспомогательные плоскости

2.8.2.1. Смещенная плоскость

2.8.2.2. Плоскость через три вершины

2.8.2.3. Плоскость под углом к другой плоскости

2.8.2.4. Плоскость через ребро и вершину

2.8.2.5. Плоскость через плоскую кривую

2.8.2.6. Плоскость через вершину параллельно другой плоскости

2.8.2.7. Плоскость через вершину перпендикулярно ребру

2.8.2.8. Нормальная плоскость

2.8.2.9. Касательная плоскость

2.8.2.10. Плоскость, касательная к грани в точке

2.8.2.11. Плоскость через ребро параллельно/перпендикулярно другому ребру

2.8.2.12. Плоскость через ребро параллельно/перпендикулярно грани

2.8.2.13. Средняя плоскость

2.8.3. Системы координат

2.8.3.1. Абсолютная система координат

2.8.3.1.1. Правосторонняя и левосторонняя системы координат

2.8.3.1.2. Преобразование правосторонней системы координат в левостороннюю

2.8.3.2. Локальные системы координат

2.8.3.3. Текущая система координат. Выбор текущей системы координат

2.8.3.4. Использование ЛСК

2.8.3.4.1. Система координат объекта

2.8.3.4.2. Замена системы координат объекта

2.8.3.5. Создание ЛСК. Общие сведения

2.8.3.6. Основной способ создания ЛСК

2.8.3.6.1. Создание ЛСК относительно системы координат

2.8.3.6.2. Создание ЛСК по объекту

2.8.3.7. Дополнительные способы создания ЛСК

2.8.3.7.1. Позиция ЛСК

2.8.3.7.2. Ориентация ЛСК

2.8.3.7.3. Файл координат единичных векторов

2.8.3.8. Переменные ЛСК

2.8.3.9. Удаление ЛСК

2.8.3.10. Настройка систем координат

2.8.4. Контрольные и присоединительные точки

2.8.5. Вектор

2.8.5.1. Построение по двум вершинам

2.8.5.2. Построение по углу в плоскости СК

2.8.5.3. Построение по оси СК

2.8.5.4. Построение по коэффициентам

2.8.5.5. Построение по двум углам

2.8.5.6. Построение по прямолинейному ребру, оси или перпендикулярно плоскости кривой

2.8.5.7. Построение по оси цилиндра или перпендикулярно плоской грани, плоскости

2.8.5.8. Построение перпендикулярно грани в указанной точке

2.8.5.9. Построение по базисному вектору в точке кривой

2.8.5.10. Построение перпендикулярно плоскости экрана

2.8.6. Компоновочная геометрия

2.8.6.1. Добавление компоновочной геометрии в модель

2.8.6.1.1. Добавление компоновочной геометрии из файла

2.8.6.1.2. Создание компоновочной геометрии «на месте»

2.8.6.1.3. Преобразование компонента в компоновочную геометрию

2.8.6.2. Редактирование компоновочной геометрии

2.8.6.2.1. Редактирование объектов компоновочной геометрии

2.8.6.2.2. Изменение положения и параметров компоновочной геометрии

2.8.7. Копии геометрических объектов

2.8.7.1. Создание копии геометрических объектов

2.8.7.1.1. Окно модели-источника

2.8.7.2. Редактирование копии геометрических объектов

2.8.7.3. Разрушение копии геометрических объектов

2.8.7.4. Коллекции


2.8.1. Вспомогательные оси

2.8. Вспомогательные объекты

2.8.1. Вспомогательные оси

Если существующих в модели ребер недостаточно для выполнения построений, вы можете создать вспомогательные оси.

Команды построения вспомогательных осей расположены в меню Операции, а кнопки для их вызова находятся в одной группе на панели Вспомогательная геометрия.

После вызова любой команды построения вспомогательной оси требуется указать объекты для ее построения. Для построения в основном используются точечные, прямолинейные и плоские объекты модели (они перечислены в табл. 2.1.7).

Если перед вызовом команды были выделены какие-либо объекты, то они будут восприняты в качестве объектов для построения оси.

Созданная ось будет показана в окне модели в виде отрезка. В Дереве построения появится специальная пиктограмма.

Отрезок, изображающий ось, немного выступает за пределы объектов, указанных при построении этой оси. Иногда для понимания расположения оси требуется, чтобы символизирующий ее отрезок был больше (меньше) или был расположен в другом месте оси (прямой линии). Вы можете изменить размер и положение этого отрезка, перетаскивая мышью его характерные точки (они появляются, когда ось выделена).

В этом разделе:

2.8.1.1. Ось через две вершины

2.8.1.2. Ось на пересечении плоскостей

2.8.1.3. Ось через ребро

2.8.1.4. Ось конической поверхности

2.8.1.5. Ось через вершину по объекту

2.8.1.5.1. Объекты, используемые при построении

2.8.1.5.2. Построение оси


2.8.1.1. Ось через две вершины

Чтобы создать вспомогательную ось, проходящую через указанные точечные объекты, вызовите команду Ось через две вершины.

Укажите пару точечных объектов, через которые должна проходить создаваемая ось.


2.8.1.2. Ось на пересечении плоскостей

Чтобы создать вспомогательную ось, которая является линией пересечения двух плоских объектов, вызовите команду Ось на пересечении плоскостей.

Укажите пару плоских объектов, на пересечении которых требуется построить ось.


2.8.1.3. Ось через ребро

Чтобы создать вспомогательную ось, которая проходит через прямолинейный объект, вызовите команду Ось через ребро.

Укажите прямолинейный объект, через который должна пройти создаваемая ось.


2.8.1.4. Ось конической поверхности

Чтобы создать вспомогательную ось, которая является осью поверхности вращения, вызовите команду Ось конической поверхности.

Укажите поверхность вращения, ось которой требуется построить.


2.8.1.5. Ось через вершину по объекту

Вы можете создать вспомогательную ось, проходящую через точечный объект в направлении, задаваемом другим объектом или вектором.

В этом разделе:

2.8.1.5.1. Объекты, используемые при построении

2.8.1.5.2. Построение оси


2.8.1.5.1. Объекты, используемые при построении

Для построения оси необходимы точечный объект и направляющий объект.

В качестве направляющего объекта может использоваться любой из объектов, перечисленных в таблице 2.8.1, или вектор, созданный в процессе построения оси.

Табл. 2.8.1. Направляющие объекты
Объект | Направление, задаваемое объектом
Прямолинейный объект | Прямая, параллельная или перпендикулярная объекту1.
Плоский объект | Прямая, перпендикулярная объекту.
Плоская кривая: – дуга, – окружность, – линия эскиза. | Прямая, перпендикулярная плоскости кривой.
Пространственная кривая2 | Прямая, направленная вдоль касательного вектора или вектора главной нормали3.
Поверхности вращения3 | Прямая, параллельная или перпендикулярная оси вращения3.
Поверхности произвольной формы1 | Прямая, перпендикулярная объекту в указанной точке.
  1. Для выбора нужного направления создаваемой оси служит группа переключателей Ориентация (см. раздел 2.8.1.5.2).
  2. Точечный объект должен принадлежать направляющему объекту.
  3. Сферу можно использовать в качестве направляющего объекта в том случае, если точечный объект принадлежит ей. Направление, задаваемое сферой — перпендикуляр в точке указания.


2.8.1.5.2. Построение оси

Чтобы создать вспомогательную ось, проходящую через вершину в направлении выбранного объекта, вызовите команду Ось через вершину по объекту.

Если объекты уже существуют в модели, укажите их.

При указании точки, построенной способом На кривой (см. раздел 2.5.2.5) или На поверхности (см. раздел 2.5.2.6), автоматически выбирается направляющий объект для оси — кривая или поверхность, на которой построена точка. При необходимости вы можете сменить направляющий объект. Для этого укажите нужный объект в окне модели.

Объекты для построения оси можно выделить и перед вызовом команды.

Если нужных объектов в модели нет, то вы можете построить их, не выходя из команды.

– Чтобы создать точку, нажмите кнопку Построение точки на Панели специального управления (см. раздел 2.5.2.11).

– Чтобы создать вектор, определяющий направление оси, нажмите кнопку Построение вектора на Панели специального управления (см. раздел 2.8.5).

После завершения создания объекта система вернется в процесс построения оси.

Обратите внимание на то, что созданная точка отображается как самостоятельный объект в Дереве построения. Изменение параметров точки производится непосредственно путем редактирования этого объекта, а не в процессе редактирования оси.

После выбора объектов на экране появляется фантом создаваемой оси.

В ряде случаев (см. табл. 2.8.1) можно выбрать направление создаваемой оси: вдоль направляющего объекта или перпендикулярно ему. Для этого служит группа переключателей Ориентация.

– Параллельно объекту,

– Перпендикулярно объекту.

Изменение ориентации оси отображается на фантоме в окне модели.

Чтобы сменить объекты, используемые для построения оси, нажмите кнопку Указать заново на Панели специального управления и повторите выбор объектов.

Вы можете задать название и цвет оси на вкладке Свойства Панели свойств.

Чтобы завершить построение, нажмите кнопку Создать объект на Панели специального управления.


2.8.2. Вспомогательные плоскости

2.8. Вспомогательные объекты

2.8.2. Вспомогательные плоскости

Если существующих в модели координатных плоскостей и плоских граней недостаточно для выполнения построений, вы можете создать вспомогательные плоскости.

Команды построения вспомогательных конструктивных плоскостей расположены в меню Операции, а кнопки для их вызова находятся в одной группе на панели Вспомогательная геометрия.

После вызова любой команды построения вспомогательной плоскости требуется указать объекты для построения этой плоскости и задать ее параметры в полях на Панели свойств. Для построения в основном используются точечные, прямолинейные и плоские объекты модели (они перечислены в табл. 2.1.7).

Если перед вызовом команды были выделены какие-либо объекты, то они будут восприняты в качестве объектов для построения плоскости.

Плоскость с заданными параметрами отображается на экране в виде фантома.

Чтобы зафиксировать эту плоскость в модели, нажмите кнопку Создать объект на Панели специального управления.

Во всех командах построения вспомогательной плоскости, кроме команды Плоскость, касательная к грани в точке, доступен режим автосоздания, который по умолчанию включен. Подробно об автоматическом и ручном создании объектов рассказано в разделе 1.4.2.10.

Созданная плоскость будет показана в окне модели в виде прямоугольника. В Дереве построения появится специальная пиктограмма.

Прямоугольник, изображающий плоскость, немного выступает за пределы объектов, указанных при построении этой плоскости. Иногда для понимания расположения плоскости требуется, чтобы символизирующий ее прямоугольник был больше (меньше) или был расположен в другом месте плоскости. Вы можете изменить размер и положение этого прямоугольника, перетаскивая мышью его характерные точки (они появляются, когда плоскость выделена).

В этом разделе:

2.8.2.1. Смещенная плоскость

2.8.2.2. Плоскость через три вершины

2.8.2.3. Плоскость под углом к другой плоскости

2.8.2.4. Плоскость через ребро и вершину

2.8.2.5. Плоскость через плоскую кривую

2.8.2.6. Плоскость через вершину параллельно другой плоскости

2.8.2.7. Плоскость через вершину перпендикулярно ребру

2.8.2.8. Нормальная плоскость

2.8.2.9. Касательная плоскость

2.8.2.10. Плоскость, касательная к грани в точке

2.8.2.11. Плоскость через ребро параллельно/перпендикулярно другому ребру

2.8.2.12. Плоскость через ребро параллельно/перпендикулярно грани

2.8.2.13. Средняя плоскость


2.8.2.1. Смещенная плоскость

Чтобы создать вспомогательную плоскость, расположенную на заданном расстоянии от указанного плоского объекта, вызовите команду Смещенная плоскость.

Введите в поле Расстояние значение расстояния от плоского объекта до создаваемой плоскости.

Укажите плоский объект, относительно которого задается смещение новой плоскости.

Чтобы указать, по какую сторону от существующей должна быть построена новая плоскость, активизируйте переключатель Прямое направление или Обратное направление в группе Направление смещения.

Расстояние и направление смещения можно задать с помощью характерной точки (см. раздел 2.1.4.2.2).


2.8.2.2. Плоскость через три вершины

Чтобы создать вспомогательную плоскость, проходящую через три точечных объекта, вызовите команду Плоскость через три вершины.

Укажите тройку точек, через которые должна пройти создаваемая плоскость.


2.8.2.3. Плоскость под углом к другой плоскости

Чтобы создать вспомогательную плоскость, проходящую через прямолинейный объект под заданным углом к плоскому объекту, вызовите команду Плоскость под углом к другой плоскости.

Прямолинейный объект должен быть параллелен плоскому объекту или принадлежать ему.

Укажите плоский объект, под углом к которому должна пройти новая плоскость.

Укажите прямолинейный объект, через который должна пройти новая плоскость.

Введите в поле Угол значение угла между плоским объектом и создаваемой плоскостью или выберите его из раскрывающегося списка.

Чтобы указать, в какую сторону от плоского объекта должен быть отложен указанный угол, активизируйте переключатель Прямое направление или Обратное направление в группе Направление угла.

Величину и направление угла можно задать с помощью характерной точки (см. раздел 2.1.4.2.2).


2.8.2.4. Плоскость через ребро и вершину

Чтобы создать вспомогательную плоскость, проходящую через прямолинейный и точечный объекты, вызовите команду Плоскость через ребро и вершину.

Укажите объекты для построения плоскости.


2.8.2.5. Плоскость через плоскую кривую

Чтобы создать вспомогательную плоскость, проходящую через указанную плоскую кривую, вызовите команду Плоскость через плоскую кривую.

В качестве кривой может использоваться:

– линия эскиза,

– сплайн (или ломаная) с тремя вершинами,

– дуга,

– другие плоские кривые: ребро, имеющее форму окружности, и т.п.

Укажите кривую, через которую должна пройти новая плоскость.


2.8.2.6. Плоскость через вершину параллельно другой плоскости

Чтобы создать вспомогательную плоскость, проходящую через точечный объект параллельно плоскому объекту, вызовите команду Плоскость через вершину параллельно другой плоскости.

Укажите точечный и плоский объекты.


2.8.2.7. Плоскость через вершину перпендикулярно ребру

Чтобы создать вспомогательную плоскость, проходящую через точечный объект перпендикулярно кривой (ребру, линии эскиза, сплайну и т.п.), вызовите команду Плоскость через вершину перпендикулярно ребру.

Точечный объект необязательно должен принадлежать кривой.

Если точечный объект и кривая уже существуют в модели, укажите их.

Если нужных объектов в модели нет, то вы можете построить их, не выходя из команды.

– Чтобы создать точку, нажмите кнопку Построение точки на Панели специального управления (см. раздел 2.5.2.11).

– Чтобы создать вектор, нажмите кнопку Построение вектора на Панели специального управления (см. раздел 2.8.5).

После завершения создания объекта система вернется в процесс построения плоскости.

Обратите внимание на то, что созданная точка отображается как самостоятельный объект в Дереве построения. Изменение параметров точки производится непосредственно путем редактирования этого объекта, а не в процессе редактирования плоскости.


2.8.2.8. Нормальная плоскость

Чтобы создать вспомогательную плоскость, нормальную к поверхности вращения (кроме сферы), вызовите команду Нормальная плоскость.

Выберите способ создания новой плоскости, используя переключатели группы Способ на Панели свойств:

– Автопостроение — будет построена нормальная плоскость, проходящая через ось поверхности вращения и точку этой поверхности с нулевыми значениями параметров U и V (о параметрическом представлении грани см. раздел 2 Приложения IX);

– Параллельно объекту — будет построена нормальная плоскость, проходящая через ось поверхности вращения параллельно указанной координатной плоскости или плоской грани.

Укажите объекты для построения.

– Если выбран способ Автопостроение, укажите поверхность вращения.

– Если выбран способ Параллельно объекту, укажите поверхность вращения, а затем координатную плоскость или плоскую грань, относительно которой будет задано положение новой плоскости.

По умолчанию включено автосоздание объектов (см. раздел 1.4.2.10). В этом режиме новая плоскость создается автоматически (т.е. подтверждение создания не требуется) в умолчательном положении.

Если необходимо задать угол поворота новой плоскости вокруг оси поверхности вращения, отключите режим автосоздания объектов (отожмите кнопку Автосоздание объекта на Панели специального управления).

Угол отсчитывается от умолчательного положения новой плоскости.

Введите нужное значение угла поворота в поле Угол.

Чтобы указать, в какую сторону от умолчательного положения должен быть отложен заданный угол, активизируйте переключатель Прямое направление или Обратное направление в группе Направление угла.

Величину и направление отсчета угла можно задать также с помощью характерной точки (см. раздел 2.1.4.2.2).

Если требуется сменить объекты, используемые для построения плоскости, нажмите кнопку Указать заново на Панели специального управления, а затем повторите выбор объектов.

Подтвердите создание плоскости, нажав кнопку Создать объект на Панели специального управления.


2.8.2.9. Касательная плоскость

Чтобы создать вспомогательную плоскость, касательную к цилиндрической или конической грани модели, вызовите команду Касательная плоскость.

Первоначальное положение касательной плоскости определяется линией касания. Линия касания, в свою очередь, определяется как линия пересечения указанной цилиндрической или конической грани и проходящего через ее ось плоского объекта. Плоский объект должен быть создан заранее. При необходимости касательную плоскость можно повернуть вокруг оси цилиндрической или конической поверхности относительно первоначального положения.

Укажите цилиндрическую или коническую грань, которой должна касаться новая плоскость, а затем — проходящий через ось этой грани плоский объект.

На экране появляется фантом касательной плоскости.

Введите в поле Угол на вкладке Параметры Панели свойств значение угла поворота касательной плоскости относительно ее первоначального положения. По умолчанию угол равен нулю и новая плоскость оказывается перпендикулярна указанному плоскому объекту.

Величину угла можно задать также с помощью характерной точки (о характерных точках см. раздел 2.1.4.2.2).

Чтобы указать, по какую сторону от цилиндрической (конической) грани должна быть построена новая плоскость, активизируйте переключатель Положение 1 или Положение 2 в группе Положение плоскости.


2.8.2.10. Плоскость, касательная к грани в точке

Чтобы создать вспомогательную плоскость, касающуюся указанной грани в заданной точке, вызовите команду Плоскость, касательная к грани в точке.

Укажите грань, касательно к которой должна пройти новая плоскость.

На выбранной грани появляются фантом ее теоретической поверхности в виде сетки изопараметрических кривых U и V и фантом создаваемой плоскости в виде прямоугольника (о теоретической поверхности см. раздел 2 Приложения IX). По умолчанию новая плоскость проходит через точку указания грани.

Задайте положение новой плоскости. Это можно сделать следующими способами.

– Задайте нужное положение точки, через которую будет проходить плоскость. Положение точки определяется смещением вдоль изопараметрических кривых U и V.
Для задания смещения точки введите нужные значения в поля Параметр U, % и Параметр V, %.

– Свяжите точку, через которую будет проходить плоскость, с существующим точечным объектом (см. табл. 2.1.7). Для этого укажите нужный объект в Дереве построения или в окне модели. На кнопке Точка отображается «галочка», а в поле рядом с кнопкой — название объекта. Это свидетельствует о наличии ассоциативной связи плоскости с выбранным объектом. Благодаря этой связи построенная плоскость будет следовать за объектом при изменении его положения.

При необходимости связь можно отменить, нажав кнопку Точка. «Галочка» на кнопке исчезнет, поле очистится.

Для задания положения плоскости могут быть указаны точечные объекты как принадлежащие выбранной грани, так и не принадлежащие, но проецирующиеся на эту грань. Положение создаваемой плоскости в этом случае определяет проекция.

Если точечного объекта, нужного для построения плоскости, в модели нет, то вы можете построить точку, не выходя из команды. Для этого нажмите кнопку Построение точки на Панели специального управления (см. раздел 2.5.2.11).

После завершения создания точки система вернется в процесс построения плоскости.

Обратите внимание на то, что созданная точка отображается как самостоятельный объект в Дереве построения. Изменение параметров точки производится непосредственно путем редактирования этого объекта, а не в процессе редактирования плоскости.


2.8.2.11. Плоскость через ребро параллельно/перпендикулярно другому ребру

2.8.2.11. Плоскость через ребро
параллельно/перпендикулярно другому ребру

Чтобы создать вспомогательную плоскость, проходящую через указанные прямолинейные объекты параллельно или перпендикулярно другим прямолинейным объектам, вызовите команду Плоскость через ребро параллельно/перпендикулярно другому ребру.

Укажите прямолинейный объект, через который должна пройти плоскость.

Чтобы выбрать вариант построения — Параллельно или Перпендикулярно другому прямолинейному объекту, активизируйте соответствующий переключатель в группе Положение плоскости.

Укажите прямолинейный объект, параллельно (или перпендикулярно) которому должна пройти плоскость.


2.8.2.12. Плоскость через ребро параллельно/перпендикулярно грани

2.8.2.12. Плоскость через ребро
параллельно/перпендикулярно грани

Чтобы создать вспомогательную плоскость, проходящую через указанные прямолинейные объекты параллельно или перпендикулярно плоским объектам, вызовите команду Плоскость через ребро параллельно/перпендикулярно грани.

Укажите прямолинейный объект, через который должна пройти плоскость.

Чтобы выбрать вариант построения — Параллельно или Перпендикулярно другому объекту, активизируйте соответствующий переключатель в группе Положение плоскости.

Укажите объект, параллельно (или перпендикулярно) которому должна пройти плоскость.


2.8.2.13. Средняя плоскость

Чтобы построить биссекторную плоскость двугранного угла, вызовите команду Средняя плоскость.

Двугранный угол — часть пространства, ограниченная двумя полуплоскостями, границей каждой из которых служит их общая прямая. Эти полуплоскости называются гранями двугранного угла, а прямая — ребром двугранного угла. Угол между линями пресечения граней двугранного угла с плоскостью, перпендикулярной ребру двугранного угла, называется линейным углом двугранного угла.

Биссекторная плоскость двугранного угла — плоскость, проходящая через биссектрису линейного угла и ребро этого двугранного угла.

Рис. 2.8.1. Двугранный угол и его биссекторная плоскость

Двугранный угол для построения средней плоскости может быть задан:

– гранями — для этого необходимо указать два плоских объекта,

– линейным углом — для этого необходимо указать два прямолинейных объекта,

– гранью и стороной линейного угла — для этого необходимо указать плоский и прямолинейный объекты.

Чтобы задать положение средней плоскости относительно указанных объектов, активизируйте нужный переключатель положения вкладке Параметры Панели свойств:

– Положение 1 — строится биссекторная плоскость,

– Положение 2 — строится плоскость, перпендикулярная биссекторной и проходящая через ребро двугранного угла.

В частном случае, если указанные объекты параллельны, построение выполняется следующим образом (вне зависимости от того, какой переключатель положения активен).

– Если объекты прямолинейные, то средняя плоскость строится перпендикулярно проходящей через них плоскости на равном расстоянии от них.

– Если объекты плоские, а также, если один плоский, а второй — прямолинейный, то средняя плоскость строится параллельно им на равном расстоянии от них.


2.8.3. Системы координат

2.8. Вспомогательные объекты

2.8.3. Системы координат

В этом разделе:

2.8.3.1. Абсолютная система координат

2.8.3.1.1. Правосторонняя и левосторонняя системы координат

2.8.3.1.2. Преобразование правосторонней системы координат в левостороннюю

2.8.3.2. Локальные системы координат

2.8.3.3. Текущая система координат. Выбор текущей системы координат

2.8.3.4. Использование ЛСК

2.8.3.4.1. Система координат объекта

2.8.3.4.2. Замена системы координат объекта

2.8.3.5. Создание ЛСК. Общие сведения

2.8.3.6. Основной способ создания ЛСК

2.8.3.6.1. Создание ЛСК относительно системы координат

2.8.3.6.2. Создание ЛСК по объекту

2.8.3.7. Дополнительные способы создания ЛСК

2.8.3.7.1. Позиция ЛСК

2.8.3.7.2. Ориентация ЛСК

2.8.3.7.3. Файл координат единичных векторов

2.8.3.8. Переменные ЛСК

2.8.3.9. Удаление ЛСК

2.8.3.10. Настройка систем координат


2.8.3.1. Абсолютная система координат

В каждой модели существует абсолютная система координат и определяемые ею плоскости и оси. Названия координатных осей и плоскостей появляются в Дереве построения сразу после создания нового файла модели.

Изображение абсолютной системы координат модели показывается посередине окна в виде трех ортогональных отрезков красного, синего и зеленого цветов. Общее начало отрезков — это начало абсолютной системы координат модели, точка с координатами 0, 0, 0.

Плоскости показываются на экране условно — в виде прямоугольников красного, синего и зеленого цветов, лежащих в этих плоскостях. По умолчанию прямоугольники расположены так, что их центры совмещены с началом координат — такое отображение позволяет пользователю увидеть размещение плоскостей в пространстве. Иногда для понимания расположения плоскости требуется, чтобы символизирующий ее прямоугольник был больше (меньше) или находился в другом месте плоскости. Вы можете изменить размер и положение этого прямоугольника, перетаскивая мышью его характерные точки (они появляются, когда плоскость выделена).

Координатные оси и плоскости абсолютной системы координат невозможно удалить из файла модели. Их можно переименовать (см. раздел 2.1.2.5), а также включить/выключить их показ в окне модели (см. раздел 2.14.1.1).

В левом нижнем углу окна документа отображается элемент управления ориентацией модели. Он состоит из трех объемных стрелок красного, зеленого и синего цветов, показывающих положительные направления осей X, Y, Z абсолютной системы координат. Данный элемент управления позволяет сменить ориентацию модели, например, щелчком мыши по стрелке или поворотом в пространстве. Подробно приемы работы с ним описаны в разделе 2.1.3.3.

При повороте модели другими способами элемент поворачивается — так же, как и значок, расположенный в начале абсолютной системы координат, но, в отличие от последнего, не сдвигается при перемещении модели и не может быть отключен.

При необходимости вы можете создать в модели локальные системы координат. Подробно о создании и использовании локальных систем координат рассказано далее.

В этом разделе:

2.8.3.1.1. Правосторонняя и левосторонняя системы координат

2.8.3.1.2. Преобразование правосторонней системы координат в левостороннюю


2.8.3.1.1. Правосторонняя и левосторонняя системы координат

Абсолютная система координат может быть правосторонней и левосторонней.

Большинство моделей содержит правостороннюю систему координат. Эта система характеризуется тем, что при взгляде с конца вектора Z на плоскость XY ось Х совмещается с осью Y поворотом против часовой стрелки.

Правосторонняя система координат обозначается в Дереве построения пиктограммой.

В левосторонней системе координат ось Z инвертирована. При взгляде с конца вектора Z на плоскость XY ось Х совмещается с осью Y поворотом по часовой стрелке.

Модели с левосторонней системой координат появляются в следующих случаях:

– при создании компонентов зеркальным отражением, если в результате отражения создается новая модель (см. раздел 2.11.3.4.1),

– при создании зеркальных исполнений (см. раздел 2.13.4.1),

– при ручном инвертировании оси Z (см. раздел 2.8.3.1.2).

Левосторонняя система координат обозначается соответствующей пиктограммой в Дереве построения самих моделей и вставок этих моделей в другие документы.

Кроме того, левосторонняя система координат может быть создана в компоненте и сохранена только в модели, содержащей этот компонент (без передачи в модель — источник компонента, т.е. в источнике остается правосторонняя СК). Это происходит в следующих случаях:

– при создании компонентов зеркальным отражением, если созданные компоненты являются зеркальными вставками исходных (см. раздел 2.11.3.4.1),

– при создании массива по образцу, использующего в качестве образца зеркальный массив (см. разделы 2.7.8 и 2.7.9) — в данном случае компонент является экземпляром массива.

Системы координат таких компонентов обозначаются в Дереве построения содержащей их модели пиктограммой правосторонней СК, так как обозначения в Дереве отражают состояние объектов в моделях — источниках компонентов.

Все построения выполняются одинаково в правосторонней и левосторонней системах координат.


2.8.3.1.2. Преобразование правосторонней системы координат в левостороннюю

При необходимости вы можете преобразовать правостороннюю систему координат в левостороннюю и наоборот. Для этого выполните следующие действия.

Из контекстного меню системы координат вызовите команду Свойства. На Панели свойств появятся элементы управления.

Опция Инвертировать ось Z определяет, какой будет система координат — правосторонней (опция отключена) или левосторонней (опция включена). Для преобразования системы координат включите/отключите опцию.

Преобразование системы координат модели имеет следующие особенности.

– Если модель содержит вставки и/или локальные системы координат, то преобразование выполняется для всех систем координат вставок, а также локальных систем координат. При этом пиктограммы данных систем координат в Дереве построения модели не изменяются.

– При инвертировании оси Z компонента модели преобразование выполняется в его модели-источнике.


2.8.3.2. Локальные системы координат

Иногда для описания участков детали абсолютная система координат не подходит или ее использование возможно, но требует дополнительных расчетов. Обычно это бывает при построении участков детали, повернутых относительно абсолютной системы координат.

В таких случаях для упрощения работы можно сначала построить локальную систему координат (ЛСК), расположив ее начало и оси требуемым образом, а потом уже в ней создавать объекты. Например, если требуется получить ломаную, сегменты которой располагаются перпендикулярно друг другу, но под углом к осям абсолютной системы координат, можно предварительно создать ЛСК, оси которой параллельны сегментам будущей ломаной, а начало совпадает с ее первой вершиной.

ЛСК могут использоваться также для позиционирования деталей-заготовок, импортированных поверхностей, компонентов.

Создание ЛСК описано в разделах 2.8.3.5–2.8.3.7, а ее использование для создания объектов — в разделе 2.8.3.4.

В модели можно построить несколько ЛСК и переключаться между ними, делая нужную в данный момент ЛСК текущей (см. раздел 2.8.3.3). Система координат, которая была текущей во время создания объекта, становится системой координат этого объекта.

Объекты постоянно сохраняют связь со своими системами координат. Благодаря этому можно быстро изменить положение участка детали, изменив положение его системы координат.

Имеется возможность переноса объектов из одной системы координат в другую (см. раздел 2.8.3.4.2).

Все имеющиеся в модели ЛСК показываются в Дереве построения, как и остальные объекты. Если в Дереве включено отображение структуры модели (см. раздел 2.1.2.2), то ЛСК находятся в разделе Системы координат.

Вы можете отключать отображение в окне модели отдельных ЛСК или всех систем координат сразу, а также исключать ЛСК из расчета, используя те же приемы, что и при работе с другими объектами (см. разделы 2.14.1.1 и 2.14.1.2).

При исключении ЛСК из расчета все построенные в ней объекты также исключаются, а при удалении — удаляются.

Стандартные чертежные виды модели определяются на основе ее абсолютной системы координат.


2.8.3.3. Текущая система координат. Выбор текущей системы координат

Только одна система координат модели может быть текущей в данный момент времени.

Перед названием текущей системы координат в Дереве построения отображается буква «т» в круглых скобках (см. рис. 2.8.2).

Текущая ЛСК отображается в окне модели цветами, заданными для ее элементов, а остальные ЛСК — серым цветом. Абсолютная система координат модели отображается цветной вне зависимости от того, является она текущей или нет.

Чтобы присвоить статус «текущая» локальной или абсолютной системе координат, выполните следующие действия.

1. Вызовите команду Редактор — Выбрать текущую СК. Система координат, которая является текущей в данный момент, подсветится в окне модели.

2. Укажите в Дереве построения систему координат, которая должна быть текущей. Можно также указать начало этой системы координат в окне модели.

Для присвоения и отмены статуса «текущая» можно использовать команду Текущая СК в контекстном меню системы координат в Дереве построения:

– если команда отмечена «галочкой», значит, система координат уже является текущей; после вызова команды она перестанет быть ею, и текущей станет абсолютная система координат,

– если команда не отмечена «галочкой», значит, система координат не текущая; после вызова команды она станет текущей.

Если при настройке ЛСК (см. раздел 9.1.11.9) включена опция При создании ЛСК назначать ее текущей СК, то каждая новая ЛСК автоматически получает статус «текущая».


2.8.3.4. Использование ЛСК

– ЛСК может использоваться в качестве системы координат объекта (см. раздел 2.8.3.4.1) для тех объектов, положение и/или ориентация которых задается относительно координатной системы (а не относительно других объектов модели). Если системой координат объекта является ЛСК, то этот объект можно перемещать и поворачивать в абсолютной системе координат модели путем изменения положения ЛСК. Чтобы отменить зависимость объекта от ЛСК, его следует перенести в абсолютную систему координат модели (см. раздел 2.8.3.4.2).

– Элементы ЛСК — точку начала, координатные плоскости и оси — можно использовать при построении модели так же, как другие точечные, плоские и прямолинейные объекты.

– Сопряжение Совпадение, наложенное на две ЛСК, делает их (и, следовательно, содержащие их компоненты) неподвижными друг относительно друга.

В этом разделе:

2.8.3.4.1. Система координат объекта

2.8.3.4.2. Замена системы координат объекта


2.8.3.4.1. Система координат объекта

Система координат объекта — система координат, относительно которой задано положение и/или ориентация объекта.

Список объектов, использующих систему координат, представлен в таблице 2.8.2.

Табл. 2.8.2. Объекты, использующие систему координат
Объект | Параметры объекта, зависящие от системы координат
Точка | – Координаты точки при использовании способов По координатам (XYZ), По цилиндру (RAZ), По сфере (RAB). – Ориентация осей для задания координат точки относительно опорной при использовании способа Перенос.
Ломаная, сплайн | – Координаты вершин при использовании способа По точкам. – Ориентация осей при использовании способов По оси X, По оси Y, По оси Z.
ЛСК1 | – Координаты точки начала (при создании ЛСК основным способом). – Углы Эйлера (при создании ЛСК дополнительными способами).
Дуга окружности, отрезок | Координаты точек.
Эскиз | – Положение начала координат2. – Ориентация осей2.
Импортированная поверхность | Позиция и ориентация.
Группа точек по кривой, по поверхности | Координаты точек (доступны после разрушения группы).
Группа точек из файла | Положение точек. Точки строятся в текущей системе координат согласно координатам, записанным в файле.
Поверхность по сети точек, по пласту точек | Координаты точек (созданных с помощью команды Построение точки) или положение точек (полученных из файла).
Кривая по закону | Положение кривой. Кривая строится в текущей системе координат согласно заданным функциям.
Операция изменения положения тела или поверхности | Положение тела или поверхности. Тело или поверхность связывается с условной системой координат, начальное положение которой совпадает с текущей системой координат; для задания положения тела или поверхности задается необходимое положение условной системы координат.
Массив по таблице | Положение экземпляров массива. Массив строится в текущей системе координат по точкам, координаты которых записаны в файле.
Зона | Координаты противоположных вершин параллелепипеда зоны и его ориентация.
  1. Параметры ЛСК могут задаваться в другой ЛСК, если при настройке системы (см. раздел 9.1.11.9) отключена опция Создавать ЛСК только в абсолютной СК.
  2. После создания эскиза положение и ориентацию его системы координат можно изменить при помощи команды Разместить эскиз (см. раздел 2.14.3.1.2).

Спирали и круглые отверстия связываются с системой координат опосредованно: систему координат использует эскиз, который автоматически создается при построении спирали или отверстия.

Первоначально системой координат объекта является та, которая была текущей во время его создания. О том, как сделать систему координат текущей, рассказано в разделе 2.8.3.3.

При необходимости объект можно перенести из его системы координат в другую (см. раздел 2.8.3.4.2).

Использование оси, плоскости или начала координат ЛСК при создании объекта (например, создание точки с привязкой к началу локальной системы координат) не делает ее системой координат этого объекта.

Эскиз имеет следующие особенности:

– если эскиз создается на плоскости системы координат, то она становится системой координат этого эскиза, даже если не была текущей в момент его создания;

– если эскиз создается на вспомогательной плоскости, то его системой координат становится система координат этой плоскости вне зависимости от того, какая система координат была текущей в момент создания эскиза.

Если объект построен не в абсолютной, а в локальной системе координат, то пиктограмма этого объекта отмечается в Дереве построения значком «ЛСК» в виде уменьшенной пиктограммы ЛСК (рис. 2.8.2).

Рис. 2.8.2. Отображение в Дереве построения объектов, построенных в ЛСК

Название системы координат объекта отображается на вкладке Свойства Панели свойств при создании или редактировании этого объекта.

Поле СК также отображается на Панели свойств при просмотре свойств объекта (рис. 2.8.3). Для просмотра свойств следует вызвать команду Свойства из контекстного меню пиктограммы объекта в Дереве построения.

Рис. 2.8.3. Поле СК на Панели свойств


2.8.3.4.2. Замена системы координат объекта

Любой из объектов, перечисленных в таблице 2.8.2, можно перенести из его системы координат в другую систему координат.

Для переноса объекта могут использоваться только те системы координат, которые расположены выше объекта в Дереве построения.

Чтобы заменить систему координат объекта, вызовите команду Редактор — Перенести в СК.

После вызова команды на Панели свойств появляются элементы управления переносом объектов в другую систему координат.

Укажите в Дереве построения объекты, систему координат которых требуется заменить.

Названия выбранных объектов заносятся на панель Список объектов (рис. 2.8.4). В скобках после названия объекта указывается название его системы координат.

Рис. 2.8.4. Элементы управления переносом объектов в другую систему координат

Объекты для переноса в другую систему координат можно выделить и до вызова команды.

Чтобы удалить какой-либо объект из списка, выделите его и нажмите кнопку Удалить, расположенную над списком.

Выберите систему координат, в которую требуется перенести объекты, указав ее название в списке СК.

Опция Сохранять положение позволяет указать, требуется ли сохранение положения объекта в абсолютной системе координат модели после переноса в другую систему координат.

– Если опция включена, то выполняется пересчет параметров объекта для новой системы координат, чтобы положение объекта в модели не изменилось.

– Если опция выключена, то значения параметров объекта сохранятся, а его положение в модели изменится.

Завершив настройку, нажмите кнопку Создать объект на Панели специального управления для выполнения переноса объектов в выбранную систему координат.

Особенности переноса объектов из одной системы координат в другую

– Пересчет параметров некоторых объектов (ломаной, детали-заготовки и др.) не производится, т.е. они изменяют свое положение вне зависимости от состояния опции Сохранять положение. Такие объекты отмечаются в списке значком с изображением замка.

– Элементы объекта могут иметь ассоциативную связь с другими объектами. В результате замены системы координат объекта положение связанных элементов не изменяется вне зависимости от состояния опции Сохранять положение. Например, имеется дуга окружности, построенная по трем точкам, две из которых заданы своими координатами, а третья совпадает с вершиной. В результате переноса этой дуги в другую систему координат при отключенной опции Сохранять положение точки, заданные координатами, переместятся, а точка, связанная с вершиной, останется на своем месте.

– ЛСК могут переноситься из одной системы координат в другую, только если при настройке ЛСК (см. раздел 9.1.11.9) отключена опция Создавать ЛСК только в абсолютной СК.


2.8.3.5. Создание ЛСК. Общие сведения

Основными параметрами ЛСК, задающими ее положение в пространстве, являются позиция и ориентация.

– Позиция — параметр, задающий положение центра ЛСК.

– Ориентация — параметр, задающий направление осей ЛСК.

Параметры ЛСК задаются относительно ее собственной системы координат. Собственной системой координат для ЛСК является абсолютная система координат модели или текущая система координат (это зависит от настройки ЛСК, см. раздел 9.1.11.9).

Чтобы приступить к созданию ЛСК, вызовите команду ЛСК. Кнопка для вызова этой команды расположена на панели Вспомогательная геометрия.

После вызова команды запускается процесс создания ЛСК основным способом. Этот процесс подробно описан в разделе 2.8.3.6.

Существуют также дополнительные способы создания ЛСК. Чтобы перейти к ним, нажмите кнопку Дополнительные способы на Панели специального управления. Запустится процесс создания ЛСК дополнительными способами. Этот процесс подробно описан в разделе 2.8.3.7.

Используя основной или дополнительные способы, задайте позицию и ориентацию создаваемой ЛСК. Все изменения параметров отображаются на фантоме ЛСК в окне модели.

Название ЛСК можно изменить на вкладке Свойства Панели свойств. Там же отображается название собственной системы координат для создаваемой ЛСК.

Получив требуемое расположение ЛСК, зафиксируйте ее, нажав кнопку Создать объект на Панели специального управления.

Созданная ЛСК появится в окне модели, а ее пиктограмма — в Дереве построения.

Если при настройке ЛСК (см. раздел 9.1.11.9) включена опция При создании ЛСК назначать ее текущей СК, то созданная ЛСК станет текущей.


2.8.3.6. Основной способ создания ЛСК

Этот способ создания ЛСК доступен непосредственно после вызова команды ЛСК. Панель свойств содержит элементы управления, показанные на рисунке 2.8.5.

Рис. 2.8.5. Панель свойств при создании ЛСК основным способом

На экране отображается фантом создаваемой ЛСК. По умолчанию новая ЛСК совпадает с собственной системой координат.

Позицию и ориентацию создаваемой ЛСК можно задать:

– относительно системы координат (см. раздел 2.8.3.6.1),

– по объекту, свойства которого позволяют однозначно определить параметры ЛСК (см. раздел 2.8.3.6.2).

Чтобы выбрать способ задания позиции и ориентации ЛСК, раскройте список Способ и укажите в нем нужную строку (рис. 2.8.5).

В этом разделе:

2.8.3.6.1. Создание ЛСК относительно системы координат

2.8.3.6.2. Создание ЛСК по объекту


2.8.3.6.1. Создание ЛСК относительно системы координат

При создании ЛСК относительно системы координат на экране отображается фантом, показанный на рисунке 2.8.6.

Рис. 2.8.6. Фантом ЛСК

Позиция ЛСК

Чтобы задать позицию ЛСК, введите координаты точки ее начала в поля X, Y, Z или укажите в окне модели точечный объект. При создании ЛСК используются те же точечные объекты, что и при построении точки (см. раздел 2.5.2.1.1). Фантом ЛСК переместится так, чтобы ее начало совпало с указанной точкой.

Чтобы сменить выбранный точечный объект, нажмите кнопку Указать заново на Панели специального управления и укажите нужный объект в окне модели.

Если для задания позиции ЛСК указан точечный объект, то начало ЛСК ассоциативно связывается с ним. При этом:

– поля X, Y, Z содержат координаты объекта и недоступны для редактирования,

– на кнопке Объект отображается «галочка», а в поле Объект — название объекта.

Благодаря ассоциативной связи начало ЛСК будет следовать за объектом при изменении его положения.

Чтобы отменить ассоциативную связь с точечным объектом, следует нажать кнопку Объект. «Галочка» на кнопке исчезнет.

Для восстановления ассоциативной связи точки с точечным объектом необходимо указать нужный объект заново.

Вы можете перемещать ЛСК в окне модели мышью, используя характерные точки фантома. Для задания позиции ЛСК служат точки, которые отображаются в виде квадратов.

– Точку начала ЛСК можно перемещать произвольно. Фантом ЛСК перемещается вслед за характерной точкой. При этом текущие координаты точки отображаются в полях X, Y, Z; если одна или две координаты зафиксированы, то перемещение происходит в плоскости или по оси.

– Точки на концах осей можно перемещать в направлении этих осей. Фантом ЛСК перемещается в этом же направлении. Текущие координаты начала ЛСК отображаются в полях X, Y, Z.

Ориентация ЛСК

Чтобы задать ориентацию ЛСК, в группе Направление осей активизируйте переключатель, соответствующий оси, направление которой требуется задать:

– Ось X,

– Ось Y,

– Ось Z.

Выбранная ось будет выделена на фантоме в окне модели.

Ось, направление которой требуется изменить, можно указать мышью в окне модели. Для этого подведите курсор к нужной оси и щелкните левой кнопкой мыши, когда рядом с курсором появится строка Направляющий объект оси.

Укажите направляющий объект. При создании ЛСК используются те же прямолинейные и плоские направляющие объекты, что и при построении точки (см. раздел 2.5.2.1.1).

Кроме того, направляющим объектом может служить вектор. В этом случае направление выбранной оси будет совпадать с направлением вектора. Этот вектор можно создать при помощи команды Построение вектора (см. раздел 2.8.5).

Название выбранного объекта отображается в поле Направляющий объект оси. Ось ЛСК ассоциативно связывается с этим объектом. Если направление оси задано вектором, то в этом поле отображается слово «Вектор».

Направление можно задать только для двух осей системы координат. Третья ось автоматически располагается так, чтобы образовывать с двумя другими правую тройку векторов.

После того как для первой оси выбран направляющий объект или построен вектор, ЛСК поворачивается так, чтобы эта ось совпала с направлением, которое задает объект или вектор.

Направляющий объект для второй оси может иметь направление, не перпендикулярное первой оси. В этом случае направление второй оси определяется как проекция направления, которое задает объект, на плоскость, перпендикулярную первой оси.

Объект не может использоваться в качестве направляющего для второй оси, если он параллелен первой оси или лежит на одной прямой с ней.

Вектор не может использоваться в качестве направляющего объекта для второй оси, если он коллинеарен первой оси. При обнаружении ошибки выдается сообщение об этом.

При необходимости вы можете направить любую из осей ЛСК в противоположную сторону. Для этого в группе Направление осей активизируйте переключатель, соответствующий оси, а затем — переключатель Перевернуть ось.

Оси ЛСК можно переворачивать с помощью мыши. Для этого, удерживая нажатой клавишу <Ctrl>, щелкните левой кнопкой мыши по характерной точке на конце нужной оси.

Вы можете произвольно вращать ЛСК в окне модели мышью, перемещая характерные точки фантома. Для задания ориентации ЛСК служат точки, которые отображаются в виде кружков. Каждая точка соответствует одной из плоскостей ЛСК и позволяет вращать ЛСК вокруг оси, перпендикулярной этой плоскости.

Ось, вокруг которой поворачивается ЛСК, остается неподвижной, а две другие — перемещаются. Если какая-либо из них была ассоциативно связана с объектом, то эта связь удаляется.


2.8.3.6.2. Создание ЛСК по объекту

При создании по объекту фантом ЛСК первоначально отсутствует в окне модели. Он появляется только после указания объекта, определяющего положение ЛСК. Объект, по которому создается ЛСК, однозначно задает ее позицию и ориентацию (табл. 2.8.3).

Табл. 2.8.3. Объекты для создания ЛСК
Объект | Параметры ЛСК, определяемые объектом
 | Позиция | Ориентация
Эскиз | Начало системы координат эскиза | X: совпадает с осью X системы координат эскиза, Y: совпадает с осью Y системы координат эскиза, Z: автоопределение
Промежуточная вершина ломаной | Вершина ломаной | X: параллельна предыдущему сегменту ломаной, Y: параллельна проекции следующего сегмента ломаной на плоскость, перпендикулярную оси Х, Z: автоопределение
Точка, созданная способом На кривой 1 | Точка | X: параллельна касательной к кривой в точке, Y: параллельна главной нормали к кривой в точке, Z: автоопределение
Точка, созданная способом На поверхности или Проекция | Точка | X: параллельна касательной по направлению U2, Y: параллельна касательной по направлению V2, Z: автоопределение
Дуга окружности или эллипса (кривая, контур в эскизе или ребро) | Центр дуги | X: направлена к начальной вершине дуги, Y: автоопределение, Z: перпендикулярна плоскости дуги
Система координат | Начало СК | X: совпадает с осью X системы координат, Y: совпадает с осью Y системы координат, Z: совпадает с осью Z системы координат
Тело3 | Центр масс | X: совпадает с осью инерции Ox, Y: совпадает с осью инерции Oy, Z: совпадает с осью инерции Oz
Плоская грань | Центр масс грани4 | X: совпадает с осью X системы координат грани, Y: совпадает с осью Y системы координат грани, Z: автоопределение
  1. Для создания ЛСК невозможно использовать точку, построенную на линейной кривой.
  2. Направления U и V видны на экране, например, во время построения точки способом На поверхности.
  3. Тела, у которых нет осей инерции (например, шар), не могут использоваться. Если у выбранного тела одна ось инерции (например, цилиндр), то с ней совпадает ось Z ЛСК.
  4. Возможен выбор варианта расположения центра масс грани. Для этого служит опция Только внешний контур на Панели свойств (см. ниже).

Чтобы задать объект для создания ЛСК, укажите его в Дереве построения или в окне модели. Название выбранного объекта отображается в поле Объект. ЛСК ассоциативно связывается с этим объектом.

Опция Только внешний контур управляет положением центра масс плоской грани, который определяет позицию ЛСК. Если опция включена, то при расчете центра масс грани учитывается только внешний контур грани. При отлюченной опции расчет центра масс грани производится с учетом внутренних контуров грани.

На рисунке показаны варианты расположения центра масс плоской грани; центр масс отмечен кружком.

Рис. 2.8.7. Варианты расположения центра масс плоской грани: а) при включенной опции Только внешний контур, б) при отключенной опции Только внешний контур
а) | б)


2.8.3.7. Дополнительные способы создания ЛСК

Чтобы перейти к дополнительным способам создания ЛСК, необходимо после вызова команды ЛСК нажать кнопку Дополнительные способы на Панели специального управления.

После этого вкладка Параметры на Панели свойств заменяется двумя вкладками: Позиция и Ориентация. Они служат для задания позиции и ориентации ЛСК различными способами. Работа с этими вкладками подробно описана в разделах 2.8.3.7.1 и 2.8.3.7.2.

В этом разделе:

2.8.3.7.1. Позиция ЛСК

2.8.3.7.2. Ориентация ЛСК

2.8.3.7.3. Файл координат единичных векторов


2.8.3.7.1. Позиция ЛСК

Для задания позиции ЛСК используется вкладка Позиция Панели свойств (рис. 2.8.8).

Рис. 2.8.8. Вкладка Позиция

Элементы управления вкладки Позиция позволяют задать положение точки начала ЛСК с использованием способов, доступных в команде Точка (см. раздел 2.5.2.1).

Единственным отличием процесса позиционирования ЛСК от процесса создания точки является наличие дополнительных элементов управления в способе По координатам. Этими элементами являются группа переключателей Смещение и поле Расстояние. Они позволяют сдвигать ЛСК вдоль собственных осей.

Чтобы выбрать ось, вдоль которой требуется сдвинуть ЛСК, активизируйте нужный переключатель в группе Смещение, а затем введите расстояние смещения в поле Расстояние. Положительная величина означает смещение в направлении оси, отрицательная – в противоположном направлении.

Поле Расстояние обнуляется после каждого ввода, и новое смещение ЛСК отсчитывается от ее текущего положения.

При любых изменениях позиции ЛСК ее ориентация сохраняется постоянной.


2.8.3.7.2. Ориентация ЛСК

Для задания ориентации ЛСК используется вкладка Ориентация Панели свойств (рис. 2.8.9).

Рис. 2.8.9. Вкладка Ориентация

Доступно три способа ориентирования ЛСК:

– задание направляющих объектов или построение векторов для осей и при необходимости — поворот ЛСК вокруг собственных осей,

– поворот ЛСК относительно собственной системы координат путем задания углов Эйлера,

– по объекту, свойства которого позволяют однозначно определить ориентацию ЛСК.

Чтобы выбрать способ ориентирования ЛСК, раскройте список Способ и укажите в нем нужную строку (рис. 2.8.9). Подробно способы ориентирования описаны ниже.

При любых изменениях ориентации ЛСК ее позиция сохраняется постоянной.

Во время задания ориентации ЛСК способами Направление осей и Система углов Эйлера на Панели свойств присутствует панель Направление осей. Она содержит таблицу координат единичных векторов, которые сонаправлены осям ЛСК. Эти координаты определяются в собственной системе координат ЛСК. При изменении ориентации ЛСК значения в таблице изменяются. Редактирование координат единичных векторов вручную невозможно. Панель Направление осей содержит три кнопки:

– Исходная ориентация. Позволяет отменить все изменения ориентации ЛСК. После нажатия этой кнопки оси ЛСК становятся сонаправлены соответствующим осям ее собственной СК.

– Читать из файла. Позволяет ориентировать ЛСК по тройке единичных векторов, координаты которых записаны в файле. После нажатия этой кнопки на экране появляется диалог, в котором нужно указать файл, содержащий координаты векторов и нажать кнопку Открыть. Значения в таблице изменятся, а фантом ЛСК в окне модели повернется. Все сделанные ранее настройки ориентации ЛСК (выбор объектов или ввод значений углов) будут отменены.
Связь ЛСК с файлом координат единичных векторов не формируется.

– Сохранить в файл. Позволяет записать текущие координаты единичных векторов в файл. После нажатия этой кнопки на экране появляется диалог, в котором нужно задать папку для размещения файла и его имя.

Файлы координат единичных векторов — текстовые. Вы можете просмотреть, отредактировать или создать такой файл с помощью любого текстового редактора. Подробно о файле координат единичных векторов рассказано в разделе 2.8.3.7.3.

Направление осей

Чтобы выбрать ось ЛСК, направление которой требуется задать, активизируйте нужный переключатель (см. рис. 2.8.9):

– Направляющий объект оси Х,

– Направляющий объект оси Y,

– Направляющий объект оси Z.

Укажите направляющий объект в окне модели или постройте вектор, определяющий направление выбранной оси (о векторе см. раздел 2.8.5).

Название указанного объекта отображается в поле рядом с выбранным переключателем. Если направление оси задано вектором, то в этом поле отображается слово «Вектор».

Справа от поля с наименованием направляющего объекта оси находится кнопка, позволяющая направить ось в противоположную сторону.

Чтобы повернуть ЛСК вокруг какой-либо из собственных осей, активизируйте нужный переключатель в группе Вращение, а затем введите угол поворота вокруг выбранной оси в поле Угол.

Поле Угол обнуляется после каждого ввода, и новый угол поворота ЛСК отсчитывается от ее текущего положения.

По своей сути ориентирование ЛСК способом Направление осей не отличается от ориентирования ЛСК способом Относительно СК. Этот процесс описан в разделе Ориентация ЛСК. Вы можете обратиться к данному разделу для получения более подробной информации об ориентировании ЛСК заданием направляющих объектов и поворотом вокруг собственных осей.

Система углов Эйлера

Чтобы задать Эйлеровы углы, определяющие положение ЛСК относительно собственной СК, введите нужные значения в поля Угол нутации, Угол прецессии и Угол вращения (рис. 2.8.10).

Рис. 2.8.10. Панель свойств при вводе углов Эйлера

При ориентировании ЛСК способом Система углов Эйлера вы можете направить любую из осей в противоположную сторону. Для этого, удерживая нажатой клавишу <Ctrl>, в окне модели щелкните левой кнопкой мыши по характерной точке на конце нужной оси. Положение фантома ЛСК на экране изменится, а в полях углов отобразятся значения, соответствующие новому положению.

По объекту

Для ориентирования ЛСК по объекту необходимо указать объект, свойства которого позволяют однозначно определить ориентацию ЛСК.

Перечень объектов, которые могут быть указаны, приведен в таблице 2.8.3. Направления осей ЛСК, задаваемые этими объектами, приведены в колонке Ориентация той же таблицы.

Укажите объект для ориентирования ЛСК в Дереве построения или в окне модели. Положение фантома ЛСК в окне модели изменяется, название выбранного объекта отображается в поле Объект. ЛСК ассоциативно связывается с этим объектом.


2.8.3.7.3. Файл координат единичных векторов

Файл координат единичных векторов используется для задания ориентации ЛСК. Формат файла — текстовый (*. txt).

Файл координат единичных векторов должен содержать три строки координат. При интерпретации файла координат единичных векторов считается, что:

– первая строка содержит координаты вектора X, вторая — вектора Y, третья — вектора Z,

– первое число в строке — координата вектора по оси X, второе — по оси Y, третье — по оси Z.

Все строки, расположенные ниже строк координат, считаются комментариями и не учитываются.

Файл может содержать координаты взаимно перпендикулярных, но не единичных векторов. В этом случае ЛСК ориентируется по заданным векторам, а в таблице отображаются значения соответствующих единичных векторов.

Требования к строкам координат:

– одна строка содержит координаты одного вектора,

– разделители координат в строке — пробелы,

– строки координат находятся в начале файла и идут подряд,

– в начале строки (перед первой координатой) могут находиться пробелы, в конце строки (после последней координаты) — произвольный комментарий.

Если содержимое файла, указанного для чтения координат векторов, не удовлетворяет перечисленным требованиям или если описанные в нем векторы не являются взаимно перпендикулярными, то на экране появляется сообщение о невозможности получения данных. Текущая ориентация ЛСК при этом не меняется.


2.8.3.8. Переменные ЛСК

После создания ЛСК в модели автоматически формируются переменные этой ЛСК.

Работа с переменными и выражениями подробно рассмотрена в разделе 7.1.

Среди переменных ЛСК двенадцать — информационные. Они соответствуют координатам начальной точки ЛСК и координатам единичных векторов. Эти переменные создаются всегда.

Наличие и состав остальных переменных определяется способом создания ЛСК:

– для ЛСК, созданной основным способом, формируются переменные координат точки начала,

– для ЛСК, созданной дополнительными способами:

• если позиция ЛСК была задана с использованием способа построения точки По координатам, Перенос, На кривой или На поверхности, то для ЛСК создаются переменные, соответствующие параметрам, характерным для этих способов (см. табл. 2.5.1),

• если ориентация ЛСК была задана с использованием углов Эйлера, то для ЛСК создаются переменные, соответствующие углам нутации, прецессии и вращения.

Если собственной системой координат ЛСК является локальная, а не абсолютная система координат, то для ЛСК создаются только информационные переменные координат начальной точки и единичных векторов.

Значения всех переменных ЛСК определяются в абсолютной системе координат.

На рисунке 2.8.11 показаны переменные ЛСК, построенной дополнительными способами; позиция ЛСК задана построением точки На кривой, а ориентация — вводом углов Эйлера.

Рис. 2.8.11. Переменные ЛСК


2.8.3.9. Удаление ЛСК

Удаление ЛСК выполняется обычным образом — с помощью команды Удалить или клавиши <Delete> (см. раздел 2.14.3.8).

Обратите внимание на то, что при удалении ЛСК удаляются также объекты, которые были в ней построены. Эти объекты являются производными по отношению к удаляемой ЛСК. Они перечислены в диалоге-предупреждении, появляющемся при удалении, вместе с остальными производными объектами удаляемой ЛСК.

Если удалена текущая ЛСК, то текущей становится абсолютная система координат.


2.8.3.10. Настройка систем координат

Вы можете выполнить следующие настройки систем координат модели:

– для абсолютной системы координат — задать наименования и цвет изображения координатных плоскостей, осей и обозначения начала координат (см. раздел 9.2.7.5.5),

– для локальных систем координат — задать наименования и цвет изображения координатных плоскостей, осей и обозначения начала координат (см. раздел 9.2.7.5.6), а также выбрать умолчательные способы работы с локальными системами координат (см. раздел 9.1.11.9).


2.8.4. Контрольные и присоединительные точки

2.8. Вспомогательные объекты

2.8.4. Контрольные и присоединительные точки

Контрольные и присоединительные точки — особые объекты, использующиеся при создании моделей трубопроводов, кабелей, жгутов и т.п. Для построения этих систем служат специализированные приложения КОМПАС-3D.

Контрольные и присоединительные точки включаются в детали и сборочные единицы, которые создаются для последующего размещения средствами приложений в трубопроводах, кабелях, жгутах и т.п. Контрольные точки обеспечивают расстановку деталей и сборочных единиц по траектории системы, а присоединительные — правильную стыковку их друг с другом и с элементами трассы. Расстановка и стыковка моделей производится с помощью сопряжений.

Для создания контрольных и присоединительных точек служат команды Контрольная точка и Присоединительная точка соответственно.

Рис. 2.8.12. Контрольная и присоединительные точки

Несмотря на то что контрольные и присоединительные точки — это специальные объекты, используемые приложением, вы можете применять их, например, для разметки и обозначения направлений внутри моделей. Контрольные и присоединительные точки, а также ось (оси) присоединительной точки могут участвовать в сопряжениях как обычные точечные и прямолинейные объекты.


2.8.5. Вектор

2.8. Вспомогательные объекты

2.8.5. Вектор

Иногда в процессе построения какого-либо объекта необходимо создать вектор в пространстве. Для этого служит команда Построение вектора. Чтобы вызвать данную команду, нажмите кнопку Построение вектора на Панели специального управления. Система перейдет в процесс создания вектора.

Вектор в пространстве можно построить следующими способами:

– По двум вершинам,

– Угол в плоскости СК,

– По оси СК,

– По коэффициентам,

– По двум углам,

– По прямолинейному ребру, оси или перпендикулярно плоскости кривой,

– По оси цилиндра или перпендикулярно плоской грани, плоскости,

– Перпендикулярно грани в указанной точке,

– По базисному вектору в точке кривой,

– Перпендикулярно плоскости экрана.

Выберите вариант построения вектора из списка Способ или при помощи команд контекстного меню. На Панели свойств появятся элементы управления построением (рис. 2.8.13).

Рис. 2.8.13. Панель свойств при создании вектора способом По двум вершинам

Задайте параметры и укажите объекты, используемые для построения. Подробно о вводе параметров и указании объектов для каждого способа рассказано в разделах 2.8.5.1 — 2.8.5.10.

После задания всех необходимых данных в модели появляется фантом вектора заданного направления. Длина фантома не зависит от масштаба отображения модели.

Чтобы сменить объекты, используемые для построения вектора, нажмите кнопку Указать заново на Панели специального управления и повторите выбор объектов.

Чтобы завершить построение, нажмите кнопку Создать объект на Панели специального управления.

Система вернется в процесс построения объекта.

В этом разделе:

2.8.5.1. Построение по двум вершинам

2.8.5.2. Построение по углу в плоскости СК

2.8.5.3. Построение по оси СК

2.8.5.4. Построение по коэффициентам

2.8.5.5. Построение по двум углам

2.8.5.6. Построение по прямолинейному ребру, оси или перпендикулярно плоскости кривой

2.8.5.7. Построение по оси цилиндра или перпендикулярно плоской грани, плоскости

2.8.5.8. Построение перпендикулярно грани в указанной точке

2.8.5.9. Построение по базисному вектору в точке кривой

2.8.5.10. Построение перпендикулярно плоскости экрана


2.8.5.1. Построение по двум вершинам

По двум вершинам — способ построения вектора по двум точечным объектам.

По умолчанию система ожидает указания начальной точки вектора — активен переключатель Вершина 1. Укажите в окне модели или Дереве построения начальную точку вектора. После указания начальной точки вектора система ожидает указание точки, в которую будет направлен вектор, — активизируется переключатель Вершина 2. Укажите в окне модели или Дереве построения точку, определяющую направление вектора.

Наименование выбранных точечных объектов отображаются в полях Вершина 1 и Вершина 2.

На экране появляется фантом вектора, направленный из первой указанной точки во вторую. Это — Прямое направление. Чтобы изменить направление вектора, активизируйте переключатель Обратное направление в группе Направление.


2.8.5.2. Построение по углу в плоскости СК

Угол в плоскости СК — способ построения вектора путем указания системы координат, одной из ее осей и угла наклона вектора относительно этой оси. Плоскость вектора определяется по выбранной оси:

– если указана ось X, то угол вектора отсчитывается в плоскости XY,

– если указана ось Y, то угол вектора отсчитывается в плоскости YZ,

– если указана ось Z, то угол вектора отсчитывается в плоскости ZX.

Начальная точка вектора совпадает с началом выбранной системы координат.

После выбора данного способа построения на экране появляется фантом вектора с умолчательными настройками.

С помощью списка СК выберите систему координат для построения вектора.

Если модель не содержит ЛСК, то список СК не доступен. В этом случае вектор будет строиться в абсолютной системе координат модели.

Выберите ось системы координат для отсчета угла вектора. Для этого в группе Ось СК активизируйте нужный переключатель:

– Ось X,

– Ось Y,

– Ось Z.

Введите в поле Угол значение угла наклона вектора или выберите его из раскрывающегося списка.

Все изменения параметров отображаются на фантоме вектора в окне модели.


2.8.5.3. Построение по оси СК

По оси СК — способ построения вектора путем выбора системы координат и указанием оси этой системы координат, вдоль которой будет направлен вектор.

После выбора данного способа построения на экране появляется фантом вектора с умолчательными настройками.

С помощью списка СК выберите систему координат для построения вектора.

Если модель не содержит ЛСК, то список СК не доступен. В этом случае вектор будет строиться в абсолютной системе координат модели.

Начальная точка вектора совпадает с началом выбранной системы координат.

Выберите ось СК для задания направления вектора. Для этого в группе Ось СК активизируйте нужный переключатель:

– Ось X,

– Ось Y,

– Ось Z.

По умолчанию направление вектора совпадает с направлением выбранной оси. Это — Прямое направление. Чтобы направить вектор в противоположную сторону, активизируйте переключатель Обратное направление в группе Направление.

Все изменения параметров отображаются на фантоме вектора в окне модели.


2.8.5.4. Построение по коэффициентам

По коэффициентам — способ построения вектора путем выбора системы координат и указания коэффициентов разложения вектора по ее координатным осям X, Y, Z. Коэффициенты разложения вектора определяют направление вектора в пространстве.

После выбора данного способа построения на экране появляется фантом вектора с умолчательными настройками.

С помощью списка СК выберите систему координат для построения вектора.

Если модель не содержит ЛСК, то список СК не доступен. В этом случае вектор будет строиться в абсолютной системе координат модели.

Начальная точка вектора совпадает с началом выбранной системы координат.

Введите коэффициенты разложения вектора по координатным осям выбранной системы координат в поля X, Y, Z на Панели свойств.

Полученное направление — это Прямое направление. Чтобы направить вектор в противоположную сторону, активизируйте переключатель Обратное направление в группе Направление.


2.8.5.5. Построение по двум углам

По двум углам — способ построения вектора путем выбора системы координат и указания азимутального и зенитного углов, задающих направление вектора.

После выбора данного способа построения на экране появляется фантом вектора с умолчательными настройками.

С помощью списка СК выберите систему координат для построения вектора.

Если модель не содержит ЛСК, то список СК не доступен. В этом случае вектор будет строиться в абсолютной системе координат модели.

Начальная точка вектора совпадает с началом выбранной системы координат.

Направление вектора определяется двумя углами А и В. Угол А соответствует азимутальному углу a сферической системы координат, а угол В — зенитному углу b.

Начало сферической системы координат совпадает с началом системы координат вектора.

Aзимутальный угол a отсчитывается в плоскости XY системы координат вектора от оси X против часовой стрелки (рис. 2.8.14). В плоскости XY проводится луч OC под азимутальным углом к оси X.

В плоскости, проходящей через ось Z и луч OC, проводится луч OD под зенитным углом к оси Z. Этот луч определяет направление строящегося вектора.

Рис. 2.8.14. Определение направления вектора по азимутальному и зенитному углам

Введите или задайте счетчиком значения азимутального и зенитного углов в поля A и B на Панели свойств.

Все изменения параметров отображаются на фантоме вектора в окне модели.


2.8.5.6. Построение по прямолинейному ребру, оси или перпендикулярно плоскости кривой

2.8.5.6. Построение по прямолинейному ребру, оси
или перпендикулярно плоскости кривой

По прямолинейному ребру, оси или перпендикулярно плоскости кривой — способ построения вектора путем указания направляющего объекта.

В качестве направляющего объекта в данном способе может использоваться любой прямолинейный объект (см. табл. 2.1.7) или плоская кривая: линия эскиза, дуга, окружность, ребро в виде дуги, окружности или эллипса.

Укажите направляющий объект в окне модели или в Дереве построения.

На экране появляется фантом вектора.

– Если в качестве направляющего объекта выбрано прямолинейное ребро или ось, то вектор направлен вдоль выбранного объекта.

– Если в качестве направляющего объекта выбрана плоская кривая, то вектор направлен перпендикулярно плоскости кривой.

Вы можете изменить направление создаваемой оси с помощью группы переключателей Направление.


2.8.5.7. Построение по оси цилиндра или перпендикулярно плоской грани, плоскости

2.8.5.7. Построение по оси цилиндра
или перпендикулярно плоской грани, плоскости

По оси цилиндра или перпендикулярно плоской грани, плоскости — способ построения вектора путем указания направляющего объекта.

В качестве направляющего объекта в данном способе может использоваться любой плоский объект (см. табл. 2.1.7) или любая поверхность вращения, кроме сферической.

Укажите направляющий объект в окне модели или в Дереве построения.

На экране появляется фантом вектора.

– Если в качестве направляющего объекта выбран плоский объект, то вектор направлен перпендикулярно выбранному объекту.

– Если в качестве направляющего объекта выбрана поверхность вращения, то вектор направлен вдоль оси вращения.

Вы можете изменить направление создаваемого вектора с помощью группы переключателей Направление.


2.8.5.8. Построение перпендикулярно грани в указанной точке

Перпендикулярно грани в указанной точке — способ построения вектора перпендикулярного указанной грани в заданной точке. Положение точки задается смещением вдоль изопараметрических кривых U и V теоретической поверхности указанной грани (о теоретической поверхности см. раздел 2 Приложения IX).

Укажите курсором в модели нужную грань.

На выбранной грани появляются: фантом ее теоретической поверхности и фантом вектора. Фантом теоретической поверхности грани отображается в виде сетки изопараметрических кривых U и V. Вектор начинается в точке указания грани и перпендикулярен ей в этой точке.

В поле Грань Панели свойств отображается наименование выбранной грани. В полях ввода Параметр U, % и Параметр V, % отображаются значения параметров U и V в точке указания грани.

Задайте положение начальной точки вектора. Для этого введите в полях Параметр U, % и Параметр V, % нужные значения параметров U и V в процентах (от 0 до 100) или задайте их счетчиком. Изменение смещения начальной точки вектора отображается на его фантоме в окне модели.

По умолчанию направление вектора совпадает с направлением нормали грани в указанной точке. Это — Прямое направление. Чтобы направить вектор в противоположную сторону, активизируйте переключатель Обратное направление в группе Направление.


2.8.5.9. Построение по базисному вектору в точке кривой

По базисному вектору в точке кривой — способ построения вектора путем задания положения его начальной точки на кривой и выбора базисного вектора кривой в этой точке. Выбранный базисный вектор определяет направление создаваемого вектора в пространстве.

Общие сведения о базисных векторах приведены в разделе 4 Приложения IX.

В качестве кривой может быть выбрана пространственная кривая, линия эскиза, ребро или сегмент ломаной.

Положение начальной точки вектора задается смещением вдоль кривой на некоторое расстояние от ее вершины.

Чтобы построить вектор, выполните следующие действия.

1. Укажите кривую для построения вектора в окне модели. Пространственную кривую можно выбрать в Дереве построения.

В поле Кривая Панели свойств отображается наименование выбранного объекта.

На кривой будут созданы два фантома: касательный вектор и начальная вершина кривой со стрелкой направления отсчета смещения. Касательный вектор начинается в точке указания.

2. Задайте смещение начальной точки вектора вдоль кривой.

Смещение точки задается в процентах от 0 до 100 от длины кривой. В начальной вершине величина смещения равна 0.

После выбора кривой в поле % от длины кривой отображается значение смещения в точке указания. Введите или задайте счетчиком нужную величину смещения точки.

3. Выберите направление вектора. Для этого активизируйте нужный переключатель в группе Вектор:

– Касательный вектор,

– Вектор главной нормали,

– Вектор бинормали.

Полученное направление — это Прямое направление. Чтобы направить вектор в противоположную сторону, активизируйте переключатель Обратное направление в группе Направление.


2.8.5.10. Построение перпендикулярно плоскости экрана

Перпендикулярно плоскости экрана — способ построения вектора, перпендикулярного плоскости экрана.

После выбора данного способа построения в центре экрана появляется фантом вектора, направленный к наблюдателю. Это — Прямое направление. Чтобы направить вектор в противоположную сторону, активизируйте переключатель Обратное направление в группе Направление.

Для фиксации текущего положения вектора в пространстве служит опция Фиксировать положение.

– Если опция включена, то при изменении ориентации модели вектор поворачивается вместе с моделью.

– Если опция отключена, то при любом изменении положения модели вектор располагается в центре экрана и направлен перпендикулярно плоскости экрана.


2.8.6. Компоновочная геометрия

2.8. Вспомогательные объекты

2.8.6. Компоновочная геометрия

Компоновочная геометрия — часть модели, которая представляет собой набор объектов, определяющих основные геометрические параметры модели. Например, она может определять:

– области пространства сборки, ограничивающие ее компоненты,

– места крепежа,

– конечные положения подвижных частей сборки (при их наличии),

– ограничения габаритных размеров,

– размещение отдельных составных частей изделия и т.п.

Использование компоновочной геометрии является одним из приемов проектирования сборочной модели (см. Приложение VII, Методика «Сверху вниз с предварительной компоновкой» и Методика «Снизу вверх с предварительной компоновкой»).

Компонентами компоновочной геометрии могут быть детали, сборки и локальные детали.

Детали и сборки, вставленные в модель в качестве компоновочной геометрии, хранятся в отдельных файлах. Фактически модель содержит только ссылки на файлы этих деталей и сборок. При передаче такой модели на другое рабочее место вместе с ней необходимо передавать и файлы всех деталей и сборок, являющихся источниками ее компоновочной геометрии.

Локальная деталь, построенная в модели в качестве компоновочной геометрии, хранится непосредственно в файле этой модели.

Компоновочная геометрия добавляется в модель из файла другой модели (см. раздел 2.8.6.1.1) или создается в контексте текущей модели (см. раздел 2.8.6.1.2).

В дальнейшем вы можете редактировать компоновочную геометрию в контексте текущей модели. Если компоновочная геометрия хранится в другом файле (деталь, сборка), то можно также открыть ее для редактирования в отдельном окне. Особенности редактирования описаны в разделе 2.8.6.2.1.

Одна и та же модель может быть вставлена в качестве компоновочной геометрии в несколько других моделей, и наоборот, модель может содержать несколько вставок одной и той же компоновочной геометрии.

Элементы компоновочной геометрии (грани, ребра, тела и т.п.) могут использоваться в операциях построения различных объектов модели. При этом сама компоновочная геометрия не изменяется.

Компоновочная геометрия не является составной частью изделия, поэтому она не учитывается при создании отчетов и спецификации по модели.

Компоновочная геометрия не участвует в определении МЦХ модели.

По умолчанию компоновочная геометрия располагается на специальном слое Компоновочная геометрия, а если слоев с таким именем несколько (данные слои могут добавляться и удаляться пользователем) — на одном из них, имеющем наименьший номер. Если при создании компоновочной геометрии слой с именем Компоновочная геометрия отсутствует в модели, то он создается автоматически. По умолчанию автоматически созданный слой не проецируется в ассоциативный чертеж. При необходимости вы можете включить проецирование или перенести компоновочную геометрию на другой слой. Работа со слоями описана в разделе 2.15.14.

Построение компоновочной геометрии в целом аналогично построению компонентов.

При дальнейшей работе с компоновочной геометрией, в отличие от работы с компонентами, недоступны следующие действия:

– включение/отключение фиксации,

– объединение в подсборку и разрушение подсборки,

– преобразование в локальную деталь командой Взять в документ.

Объединение в макроэлемент доступно только для объектов, входящих в компоненты компоновочной геометрии. Сами эти компоненты объединить в макроэлемент нельзя.

Кроме того, на объекты компоновочной геометрии не распространяется действие команд меню Вид — Скрыть в компонентах. Вы можете управлять отображением всей компоновочной геометрии в модели и/или в ее компонентах с помощью команды Компоновочная геометрия (об управлении отображением объектов см. раздел 2.14.1.1.2).

В этом разделе:

2.8.6.1. Добавление компоновочной геометрии в модель

2.8.6.1.1. Добавление компоновочной геометрии из файла

2.8.6.1.2. Создание компоновочной геометрии «на месте»

2.8.6.1.3. Преобразование компонента в компоновочную геометрию

2.8.6.2. Редактирование компоновочной геометрии

2.8.6.2.1. Редактирование объектов компоновочной геометрии

2.8.6.2.2. Изменение положения и параметров компоновочной геометрии


2.8.6.1. Добавление компоновочной геометрии в модель

Компоновочная геометрия может быть создана непосредственно в текущей модели («на месте», см. раздел 2.8.6.1.2) или добавлена из другой модели, сохраненной в файле на диске (см. раздел 2.8.6.1.1).

При работе со сборкой вы можете вызвать команды создания/добавления компоновочной геометрии из меню Операции или нажатием соответствующих кнопок на панели Редактирование сборки. Кнопка добавления компоновочной геометрии из файла присутствует также на панели Редактирование модели.

При работе с деталью вы можете добавить компоновочную геометрию, нажав кнопку на панели Редактирование детали. Чтобы иметь возможность создать компоновочную геометрию «на месте», включите отображение панели Редактирование сборки с помощью команды Вид — Панели инструментов — Редактирование сборки или добавьте команду создания компоновочной геометрии на одну из инструментальных панелей.

Кроме указанных выше способов, компоновочная геометрия может быть получена преобразованием в нее компонента (см. раздел 2.8.6.1.3), а также при преобразовании объектов модели в деталь (см. раздел 2.11.2.3.1) и локальную деталь (см. раздел 2.11.2.3.2).

В этом разделе:

2.8.6.1.1. Добавление компоновочной геометрии из файла

2.8.6.1.2. Создание компоновочной геометрии «на месте»

2.8.6.1.3. Преобразование компонента в компоновочную геометрию


2.8.6.1.1. Добавление компоновочной геометрии из файла

Чтобы в качестве компоновочной геометрии в модель была добавлена деталь или сборка, существующая в файле на диске, выполните следующие действия.

1. Вызовите команду Операции — Добавить из файла — Компоновочную геометрию... или нажмите кнопку Добавить компоновочную геометрию на панели Редактирование модели/детали или Редактирование сборки.

2. В появившемся на экране диалоге открытия файлов выберите файл, содержащий нужную модель.

Если вставляемая модель содержит исполнения, то набор объектов и свойства компоновочной геометрии будут соответствовать одному из этих исполнений. Перечень всех исполнений, имеющихся в модели, содержится в списке Исполнение диалога выбора файла. Укажите нужное исполнение в списке.

Если в выбранной модели созданы дополнительные номера исполнений, то диалог также содержит список Дополнительный номер. По умолчанию в списке активизирован вариант, при котором ни один дополнительный номер не выбран (пустая строка списка). При необходимости выберите строку с нужным номером.

3. Для завершения выбора файла нажмите кнопку Открыть.

После этого диалог закрывается, а в текущей модели создается компоновочная геометрия, содержащая модель из выбранного файла. Абсолютная система координат модели из файла совпадает с абсолютной системой координат текущей модели.

Если модель из файла и/или текущая модель содержат локальные системы координат, то в дальнейшем вы можете изменить положение компоновочной геометрии. Для этого войдите в режим ее редактирования и сделайте текущими нужные системы координат моделей (подробнее см. раздел 2.8.6.2.2).

В Дереве построения модели в разделе Компоновочная геометрия появляется пиктограмма, соответствующая типу компоновочной геометрии (деталь или сборка). Рядом с пиктограммой отображается наименование компоновочной геометрии, взятое из ее файла.

После добавления компоновочной геометрии требуется перестроение модели (подробнее о перестроении см. раздел 2.14.3.7).

Если компоновочная геометрия является исполнением модели, вы можете заменить ее другим исполнением данной модели. Для этого из контекстного меню компоновочной геометрии в Дереве построения вызовите команду Текущее исполнение и укажите нужное исполнение в появившемся списке исполнений модели. Рядом с обозначением выбранного исполнения в списке появится «галочка». Это означает, что данное исполнение вставлено в модель. После выбора исполнения перестройте модель (подробнее о перестроении см. раздел 2.14.3.7).


2.8.6.1.2. Создание компоновочной геометрии «на месте»

Чтобы создать компоновочную геометрию выполните следующие действия.

1. Вызовите команду Операции — Создать — Компоновочную геометрию... или нажмите кнопку Создать компоновочную геометрию на панели Редактирование сборки. На экране появится диалог Создать компоновочную геометрию (рис. 2.8.15).

Рис. 2.8.15. Диалог Создать компоновочную геометрию

2. Задайте тип создаваемой компоновочной геометрии. Для этого в группе элементов Тип создаваемого компонента выберите один из следующих вариантов:

– Деталь — для создания детали, содержащейся в отдельном файле,

– Сборка — для создания сборки, содержащейся в отдельном файле,

– Локальная деталь — для создания детали, содержащейся в файле текущей модели.

3. В поле Имя компонента введите имя компоновочной геометрии и нажмите кнопку ОК.

В случае создания детали или сборки на экране появится диалог сохранения файлов. Укажите папку и имя файла для записи новой детали/сборки и нажмите кнопку Сохранить. После этого в Дереве построения модели в разделе Компоновочная геометрия появится пиктограмма, обозначающая новую деталь/сборку, а система перейдет в режим контекстного редактирования этой детали/сборки. О том, что новый объект находится в режиме контекстного редактирования, говорит желтый цвет его пиктограммы.

В случае создания локальной детали ввод имени файла детали не требуется, так как локальная деталь хранится в той же модели, где создается. Система сразу переходит в режим контекстного редактирования локальной детали, а в разделе Компоновочная геометрия Дерева построения появляется соответствующая ей пиктограмма.

Абсолютная система координат создаваемой детали, сборки или локальной детали совпадает с текущей системой координат модели.

4. Выполните все необходимые действия по созданию детали, сборки или локальной детали в режиме контекстного редактирования. Работа в данном режиме описана в разделе 2.11.7.2.1. Для выхода из режима отожмите кнопку Редактировать на месте на панели Текущее состояние, или вызовите из контекстного меню детали/сборки команду Редактировать на месте, или щелкните мышью по значку режима контекстного редактирования в окне модели. Система вернется в режим работы с текущей моделью, пиктограмма нового объекта из желтой превратится в синюю.

После завершения контекстного редактирования детали, сборки или локальной детали требуется перестроение модели (подробнее о перестроении см. раздел 2.14.3.7).

Работа с локальной деталью имеет особенности (см. раздел 2.11.7.5).

Если текущая модель и/или созданная в ней компоновочная геометрия (в виде детали, сборки, локальной детали) содержат локальные системы координат, то в дальнейшем вы можете изменить положение компоновочной геометрии. Для этого войдите в режим ее редактирования и сделайте текущими нужные системы координат (подробнее см. раздел 2.8.6.2.2).


2.8.6.1.3. Преобразование компонента в компоновочную геометрию

Чтобы преобразовать компонент модели (кроме библиотечного компонента) в компоновочную геометрию, укажите в Дереве построения нужный компонент и вызовите команду Редактор — Перенести в компоновочную геометрию. Если в Дереве построения уже имеется раздел Компоновочная геометрия, то вы можете просто «перетащить» компонент мышью на пиктограмму данного раздела.

При этом пиктограмма выбранного компонента в Дереве построения переносится в раздел Компоновочная геометрия. Компонент приобретает свойства компоновочной геометрии и располагается на слое Компоновочная геометрия.

Положение объектов компонента в окне модели не изменится. Однако, если абсолютная система координат компонента не совпадает ни с одной из систем координат модели, то в модели будет создана совпадающая с ней локальная система координат.

Если требуется преобразовать в компоновочную геометрию несколько компонентов модели, выделите их в Дереве и вызовите команду Редактор — Перенести в компоновочную геометрию.

При необходимости вы можете выполнить обратное преобразование — компоновочной геометрии в компонент. Это возможно в том случае, если в Дереве построения имеется раздел Компоненты. Для выполнения преобразования «перетащите» мышью нужную компоновочную геометрию на пиктограмму данного раздела.

После преобразования компонента в компоновочную геометрию и наоборот требуется перестроение модели (подробнее о перестроении см. раздел 2.14.3.7).


2.8.6.2. Редактирование компоновочной геометрии

В рамках редактирования компоновочной геометрии вы можете:

– отредактировать объекты компоновочной геометрии (см. раздел 2.8.6.2.1),

– изменить параметры компоновочной геометрии (см. раздел 2.8.6.2.2):

• изменить положение компоновочной геометрии в модели,

• изменить свойства компоновочной геометрии,

• выбрать другой файл-источник компоновочной геометрии,

• пересчитать размеры компоновочной геометрии с учетом назначенных допусков.

В этом разделе:

2.8.6.2.1. Редактирование объектов компоновочной геометрии

2.8.6.2.2. Изменение положения и параметров компоновочной геометрии


2.8.6.2.1. Редактирование объектов компоновочной геометрии

Чтобы отредактировать объекты компоновочной геометрии, нужно либо открыть ее в отдельном окне, либо перейти в режим контекстного редактирования компоновочной геометрии. После этого можно использовать любые приемы редактирования, описанные в разделе 2.14.3.

Обратите внимание на то, что редактирование в отдельном окне доступно только в том случае, если в качестве компоновочной геометрии в модель вставлена деталь или сборка. Компоновочную геометрию, являющуюся локальной деталью, можно редактировать только в контексте текущей модели.

Чтобы отредактировать компоновочную геометрию в отдельном окне выделите ее в Дереве построения и вызовите из контекстного меню команду Редактировать в окне. Откроется файл — источник компоновочной геометрии. Этот файл можно также открыть обычным способом с помощью команды Файл — Открыть.

После внесения всех необходимых изменений сохраните файл — источник компоновочной геометрии и закройте его или вернитесь в окно модели, содержащей компоновочную геометрию.

При необходимости вы можете сохранить редактируемую компоновочную геометрию в файле с другим именем или в другом месте на диске. Особенности сохранения описаны в разделе 2.11.7.1.1.

Чтобы отредактировать компоновочную геометрию в контексте текущей модели выделите компоновочную геометрию в Дереве построения и вызовите из контекстного меню команду Редактировать на месте. Система перейдет в режим редактирования компоновочной геометрии. Работа в данном режиме описана в разделе 2.11.7.2.1.

Чтобы завершить редактирование компонента «на месте», повторно вызовите команду Редактировать на месте, или отожмите кнопку Редактировать на месте, или щелкните мышью по значку режима контекстного редактирования в окне модели. Система вернется в режим работы с основной моделью.

При редактировании «на месте» обратите внимание на следующую особенность.

Если компоновочной геометрией является деталь или сборка, то изменения вносятся непосредственно в файл этой детали/сборки. После завершения редактирования на экране появляется запрос на сохранение файла.

Если компоновочной геометрией является локальная деталь, запрос на сохранение не выдается, так как локальная деталь хранится не во внешнем файле, а в файле содержащей ее модели.

После внесения изменений в объекты компоновочной геометрии требуется перестроение модели (подробнее о перестроении см. раздел 2.14.3.7).


2.8.6.2.2. Изменение положения и параметров компоновочной геометрии

Чтобы изменить положение компоновочной геометрии в модели, выделите ее в Дереве построения и вызовите команду Разместить компонент контекстного меню или команду Редактировать меню Редактор. На Панели свойств появятся элементы управления.

Элементы изменения положения находятся на вкладке Размещение (рис. 2.8.16).

Рис. 2.8.16. Вкладка Размещение

Эта вкладка позволяет изменить положение компоновочной геометрии в модели. Она содержит раскрывающиеся списки систем координат компоновочной геометрии и текущей модели. Списки доступны, если в компоновочной геометрии и текущей модели имеются локальные системы координат.

Чтобы изменить положение компоновочной геометрии, выберите из списков системы координат для совмещения.

Рядом с каждым из списков находится кнопка, позволяющая указать нужную систему координат не в списке, а в Дереве построения или окне модели. Система координат компоновочной геометрии выбирается после нажатия кнопки СК компонента, а система координат модели — после нажатия кнопки СК текущего документа.

Выбранные системы координат совмещаются друг с другом и положение компоновочной геометрии в модели изменяется.

При необходимости вы можете настроить другие параметры компоновочной геометрии, не выходя из процесса ее размещения.

Вкладка Свойства позволяет задать цвет и оптические свойства отображения компоновочной геометрии. Используемые для этого элементы управления описаны в разделе 2.14.2.

На этой вкладке вы также можете включить компоновочную геометрию в расчет или исключить ее из расчета. Для этого используются переключатели группы Состояние.

Кроме того, вы можете выбрать новые значения внешних переменных модели, являющейся источником компоновочной геометрии, если она содержит таблицу переменных. Для этого требуется нажать кнопку Таблица переменных и выбрать нужную строку в появившейся на экране таблице.

Для настройки параметров компоновочной геометрии без изменения ее положения можно использовать команду Свойства компонента контекстного меню.

Выполнив все необходимые действия, нажмите кнопку Создать объект на Панели специального управления.


2.8.7. Копии геометрических объектов

2.8. Вспомогательные объекты

2.8.7. Копии геометрических объектов

Копия геометрических объектов — это объект модели, содержащий геометрические объекты без истории, которые являются копиями геометрических объектов этой или другой модели.

Использование копий геометрических объектов — один из приемов проектирования сборочной модели (см. Приложение VII, Методика «Сверху вниз с предварительной компоновкой» и Методика «Снизу вверх с предварительной компоновкой»).

Источники геометрических объектов, входящих в одну и ту же копию, должны содержаться в одном документе.

Между объектом, входящим в копию, и его исходным объектом имеется ассоциативная связь. Изменения исходного объекта передаются в его копию. Если исходный объект содержится в том же документе, то это происходит автоматически. Если копия и исходный объект находятся в разных документах, то для передачи изменений необходимо перестроить модель, содержащую копию (подробнее о перестроении см. раздел 2.14.3.7).

Копия геометрических объектов может содержать следующие объекты модели:

– тела,

– поверхности,

– грани,

– ребра,

– вершины,

– пространственные кривые и точки,

– вспомогательные оси и плоскости,

– системы координат,

– эскизы.

В копию могут включаться объекты самой модели, ее компонентов и содержащейся в ней компоновочной геометрии.

Объекты, входящие в копию, могут изменяться последующими операциями, а также использоваться в операциях построения различных объектов модели.

Для создания копии используется специальная команда.

Копия геометрических объектов также создается в модели в результате изолирования объектов. Особенности изолирования объектов и полученной копии описаны в разделе 2.7.10.1.3.

В этом разделе:

2.8.7.1. Создание копии геометрических объектов

2.8.7.1.1. Окно модели-источника

2.8.7.2. Редактирование копии геометрических объектов

2.8.7.3. Разрушение копии геометрических объектов

2.8.7.4. Коллекции


2.8.7.1. Создание копии геометрических объектов

Создание ассоциативной копии геометрических объектов выполняется с помощью команды Копировать объекты, которая вызывается из меню Операции — Дополнительные элементы или нажатием кнопки Копировать объекты на панели Редактирование модели.

Если копия должна содержать объекты текущей модели, то нужные объекты можно выбрать как до, так и после вызова команды.

Если требуется создать копию из объектов другой модели, то выбор объектов возможен только после вызова команды.

Перечень объектов, которые могут быть включены в копию, приведен в разделе 2.8.7.

После вызова команды на Панели свойств появляются две вкладки Параметры и Свойства.

Рис. 2.8.17. Вкладка Параметры

На вкладке Параметры (рис. 2.8.17) выполните следующие действия.

1. С помощью группы переключателей Способ копирования выберите источник копируемых объектов.

По умолчанию в группе активизирован переключатель Контекстное. В этом случае выбор объектов для копирования выполняется в текущей модели.

Чтобы создать копию из объектов другой модели, активизируйте переключатель Из файла. На экране появится диалог выбора файла. Укажите файл, который будет являться источником для выбора объектов, и нажмите кнопку Открыть.

На Панели свойств появится поле с полным именем выбранного файла и кнопка Файл-источник, позволяющая перевыбрать файл. В окне модели появится Окно модели-источника (см. раздел 2.8.7.1.1).

2. С помощью группы переключателей Выбор объектов задайте способ формирования набора объектов, входящих в копию. Доступны два варианта: произвольное указание объектов и выбор коллекции объектов (см. раздел 2.8.7.4).

По умолчанию в группе активизирован переключатель Ручное указание, что соответствует произвольному указанию объектов. Набор объектов отображается на панели Список объектов.

Чтобы добавить объект в список, укажите его в Дереве построения или в окне той модели, которая выбрана в качестве источника копирования (в случае контекстного копирования — это текущая модель, в случае копирования из файла — модель, показанная в Окне модели-источника). Указанный объект подсветится. Его фантом появится в окне текущей модели.

Повторное указание объекта удаляет его из списка копируемых. Можно также удалить объект, выделив его в списке и нажав кнопку Удалить из списка. Кнопка Указать заново полностью очищает список.

Тело или поверхность можно указать только в Дереве построения.

Если в Дереве построения указана операция построения тела или поверхности, например, операция выдавливания, то копируются все грани этого тела (поверхности).

Чтобы выбрать коллекцию объектов, активизируйте переключатель Коллекции. На Панели свойств появится раскрывающийся список коллекций, имеющихся в текущей модели (при контекстном копировании) или в модели из файла (при копировании из файла). Выберите нужную коллекцию из списка.

Список коллекций отображается на Панели свойств, если выбранный для копирования документ содержит хотя бы одну коллекцию.

После выбора объектов любым из описанных выше способов в окне текущей модели появляются фантомы выбранных объектов.

3. Определите положение копии в модели. Для этого выполните следующие действия.

• Если объекты копируются из текущей модели, копия по умолчанию размещается в текущей системе координат модели. Чтобы задать другое положение копии, сделайте текущей другую систему координат. Для этого выберите ее из списка СК текущего документа или нажмите одноименную кнопку и укажите нужную систему координат в Дереве построения или в окне модели.

• Если объекты копируются из другой модели, по умолчанию абсолютная система координат модели-источника совпадает с текущей системой координат модели, в которой создается копия. Чтобы задать другое положение копии, укажите другие системы координат для совмещения. Для этого выберите их из списков СК источника и СК текущего документа. Для выбора систем координат можно также использовать одноименные кнопки Панели свойств. После нажатия кнопки доступно указание в Дереве построения или в окне текущей модели (для системы координат текущего документа) и в Дереве построения или в окне модели-источника (для системы координат модели-источника).

Элементы выбора систем координат доступны, если текущая модель и/или модель — источник копирования содержат локальные системы координат.

4. Если требуется, чтобы объекты копии были зеркальным отражением исходных, включите опцию Зеркально. Выбранные объекты будут отражены зеркально относительно плоскости XY системы координат, в которой размещается копия.

При копировании объектов модели с левосторонней системой координат в модель с правосторонней и наоборот копируемая геометрия автоматически отражается относительно плоскости XY системы координат, в которой размещается копия. При включении опции Зеркально происходит повторное отражение геометрии.

Системы координат, входящие в копию, всегда имеют то же направление, что и система координат модели, содержащей эту копию, т.е. левосторонняя система координат становится правосторонней, а правосторонняя — левосторонней. Действие опции Зеркально не распространяется на копируемые системы координат.

5. На вкладке Свойства введите наименование создаваемой копии объектов.

6. Для завершения создания копии нажмите кнопку Создать объект на Панели специального управления.

В Дереве построения модели в разделе Копии появится пиктограмма и наименование созданной копии объектов, а в окне текущей модели — объекты, входящие в данную копию.

В этом разделе:

2.8.7.1.1. Окно модели-источника


2.8.7.1.1. Окно модели-источника

Окно модели-источника отображается в окне текущей модели, если в качестве источника объектов для создания копии выбран файл другой модели.

Это окно содержит изображение модели-источника и Дерево построения данной модели (рис 2.8.18).

Рис. 2.8.18. Окно модели-источника

В Дереве построения модели-источника отображаются следующие объекты:

– системы координат,

– вспомогательная геометрия,

– элементы оформления (недоступны для копирования),

– кривые и точки,

– эскизы,

– тела, построенные непосредственно в модели-источнике,

– объекты «измерение» (недоступны для копирования).

Указание объектов в Окне модели-источника выполняется обычным образом — объекты указываются мышью в Дереве или в самом окне.

Вы можете переместить Окно модели-источника, «перетащив» его мышью за заголовок. Можно также изменить размер окна, «перетаскивая» мышью его границы. Перемещение и изменение размера окна возможны только в пределах окна текущей модели.

Тип отображения объектов в окне (каркасное, полутоновое и т.п.) соответствует выбранному в окне текущей модели.

При необходимости вы можете изменить масштаб отображения объектов в окне с помощью команд Показать все и Текущий масштаб, а также вращением колеса мыши.

Можно также управлять отображением объектов в окне с помощью команды Вид — Скрыть.

Кроме того, вы можете повернуть модель, отображающуюся в окне, при помощи клавиатуры (см. раздел Поворот модели при помощи клавиатуры) и при помощи мыши (см. раздел Поворот модели при помощи мыши).


2.8.7.2. Редактирование копии геометрических объектов

Чтобы отредактировать копию геометрических объектов, выделите ее в Дереве построения модели и вызовите команду Редактировать из меню Редактор или контекстного меню. На Панели свойств появятся те же элементы управления, что и при создании копии.

Вы можете выбрать другой способ копирования и/или выбора объектов, отредактировать набор объектов, изменить положение копии, указав другие системы координат. Все эти действия выполняются так же, как при создании копии (см. раздел 2.8.7.1).


2.8.7.3. Разрушение копии геометрических объектов

Копия геометрических объектов содержит объекты без истории, ассоциативно связанные с исходными объектами. Вы можете разрушить имеющуюся копию на отдельные объекты. В результате разрушения связь между объектами копии и их исходными объектами теряется. В модели получается набор объектов без истории.

Чтобы разрушить копию, выделите ее в Дереве построения и вызовите команду Разрушить из меню Редактор или контекстного меню.

Если требуется разрушить несколько копий, выделите их в Дереве построения и вызовите команду из меню Редактор.

После вызова команды на экране появляется диалог разрушения. Чтобы подтвердить разрушение, нажмите кнопку ОК. Кнопка Отмена позволяет закрыть диалог, отказавшись от разрушения.

После разрушения пиктограмма разрушенной копии удаляется из модели. Объекты копии отображаются в Дереве построения как самостоятельные объекты и сохраняют свое положение в модели.


2.8.7.4. Коллекции

Коллекция представляет собой произвольный набор объектов. В коллекцию, как правило, объединяются объекты, необходимые для выполнения определенных построений. Например, коллекция может содержать грани стыковочных поверхностей и/или прочие грани окружающих деталей, определяющие положение и конфигурацию вновь создаваемого компонента.

Коллекции используются для выбора объектов при создании копий геометрических объектов (см. раздел 2.8.7). Они позволяют быстро выбрать необходимые объекты, не указывая их в Дереве построения или в окне модели.

Коллекция может содержать следующие объекты модели:

– тела,

– поверхности,

– грани,

– ребра,

– вершины,

– пространственные кривые и точки,

– вспомогательные оси и плоскости,

– системы координат,

– эскизы.

В коллекцию могут включаться объекты текущей модели, ее компонентов и содержащейся в ней компоновочной геометрии.

Чтобы создать коллекцию вызовите команду Операции — Дополнительные элементы — Коллекция или нажмите кнопку Коллекция на панели Редактирование модели.

На Панели свойств появятся вкладки Параметры и Свойства.

Вкладка Параметры содержит панель Список объектов, которая позволяет сформировать набор объектов, входящих в коллекцию. Нужные объекты могут быть указаны как до вызова команды, так и после.

Чтобы добавить объект в список, укажите его мышью в Дереве построения или в окне модели.

Тело или поверхность можно указать только в Дереве построения.

Повторное указание объекта удаляет его из списка. Можно также удалить объект, выделив его в списке и нажав кнопку Удалить из списка. Кнопка Указать заново полностью очищает список.

На вкладке Свойства задайте наименование создаваемой коллекции.

Для завершения создания коллекции нажмите кнопку Создать объект на Панели специального управления.

В Дереве построения появится пиктограмма коллекции и ее наименование. При выделении коллекции в Дереве входящие в нее объекты подсвечиваются в окне модели.

При создании коллекции в модели не создаются копии выбранных объектов. В коллекцию включаются сами эти объекты.

В дальнейшем вы можете изменить набор объектов коллекции и ее наименование. Для этого выделите коллекцию в Дереве построения и вызовите команду Редактировать из меню Редактор или контекстного меню. На Панели свойств появятся те же элементы управления, что и при создании коллекции. Действия по редактированию коллекции аналогичны действиям по ее созданию.


2.9. Размеры, обозначения, резьба (условное изображение)

2.9. Размеры, обозначения,
резьба (условное изображение)

В этом разделе:

2.9.1. Общие сведения

2.9.2. Размеры

2.9.2.1. Общие сведения о размерах

2.9.2.2. Размеры эскизов и операций

2.9.2.2.1. Задание значения размера

2.9.2.2.2. Отображение размеров эскизов и операций в окне модели

2.9.2.2.3. Отображение имен переменных в размерах эскизов и операций

2.9.2.2.4. Особенности работы с размерами операций

2.9.2.3. Порядок простановки размеров вручную

2.9.2.4. Линейный размер

2.9.2.4.1. Размещение размерной надписи на полке

2.9.2.4.2. Зависимость значения размера от выбора базовой плоскости

2.9.2.5. Линейный размер от отрезка до точки

2.9.2.6. Угловой размер

2.9.2.7. Радиальный и диаметральный размеры

2.9.2.7.1. Выбор объектов для простановки размеров

2.9.2.7.2. Радиальный размер

2.9.2.7.3. Диаметральный размер

2.9.2.7.4. Особенности простановки размера

2.9.2.8. Производные размеры

2.9.2.8.1. Особенности работы с производными размерами

2.9.2.9. Редактирование производных размеров

2.9.2.9.1. Редактирование отображения производного размера

2.9.2.9.2. Размещение производных размеров

2.9.2.9.3. Условия размещения производного размера в базовой плоскости

2.9.2.9.4. Порядок размещения производных размеров

2.9.3. Обозначения

2.9.3.1. Общие приемы создания обозначений

2.9.3.1.1. Задание положения плоскости обозначения

2.9.3.1.2. Добавление и удаление ответвлений

2.9.3.2. Шероховатость

2.9.3.3. База

2.9.3.4. Линия-выноска

2.9.3.5. Обозначение клеймения

2.9.3.6. Обозначение маркировки

2.9.3.7. Обозначение позиции

2.9.3.8. Допуск формы

2.9.4. Условное изображение резьбы

2.9.4.1. Использование подгонки


2.9.1. Общие сведения

2.9. Размеры, обозначения, резьба (условное изображение)

2.9.1. Общие сведения

КОМПАС-3D позволяет создать различные варианты размеров и обозначений в трехмерных моделях.

Команды простановки размеров и обозначений сгруппированы в меню Операции — Элементы оформления, а кнопки для вызова команд — на панели Элементы оформления (рис. 2.9.1).

Рис. 2.9.1. Панель Элементы оформления

Созданные размеры и обозначения можно передать в чертеж при создании в нем ассоциативных видов модели (см. раздел 3.7.1.2).

Переданные в чертеж размеры и обозначения являются проекционными обозначениями. Работа с проекционными обозначениями описана в разделе 3.7.3.5.


2.9.2. Размеры

2.9. Размеры, обозначения, резьба (условное изображение)

2.9.2. Размеры

В этом разделе:

2.9.2.1. Общие сведения о размерах

2.9.2.2. Размеры эскизов и операций

2.9.2.2.1. Задание значения размера

2.9.2.2.2. Отображение размеров эскизов и операций в окне модели

2.9.2.2.3. Отображение имен переменных в размерах эскизов и операций

2.9.2.2.4. Особенности работы с размерами операций

2.9.2.3. Порядок простановки размеров вручную

2.9.2.4. Линейный размер

2.9.2.4.1. Размещение размерной надписи на полке

2.9.2.4.2. Зависимость значения размера от выбора базовой плоскости

2.9.2.5. Линейный размер от отрезка до точки

2.9.2.6. Угловой размер

2.9.2.7. Радиальный и диаметральный размеры

2.9.2.7.1. Выбор объектов для простановки размеров

2.9.2.7.2. Радиальный размер

2.9.2.7.3. Диаметральный размер

2.9.2.7.4. Особенности простановки размера

2.9.2.8. Производные размеры

2.9.2.8.1. Особенности работы с производными размерами

2.9.2.9. Редактирование производных размеров

2.9.2.9.1. Редактирование отображения производного размера

2.9.2.9.2. Размещение производных размеров

2.9.2.9.3. Условия размещения производного размера в базовой плоскости

2.9.2.9.4. Порядок размещения производных размеров


2.9.2.1. Общие сведения о размерах

Размеры в модели могут быть двух типов: управляющие и информационные. От типа размера зависит, влияет размер на объект модели или, наоборот, объект влияет на размер.

Управляющий размер — это размер, который управляет геометрией объекта модели. Значение управляющего размера может быть изменено пользователем. После этого объект, имеющий данный размер, перестраивается так, чтобы удовлетворять новому значению размера. Признаком управляющего размера является прямоугольная рамка вокруг его значения. Эта рамка на печать не выводится.

Информационный размер — это размер, которым управляет объект модели. Изменение значения информационного размера невозможно. Если объект, к которому проставлен информационный размер, был перестроен, то происходит перестроение размера и пересчет его значения.

При работе с моделью можно использовать размеры эскизов и операций. Кроме того, возможно создание размеров — элементов оформления.

– Размеры эскизов и операций: в Дереве построения не отображаются, видны на экране только при создании операции и в специальном режиме; могут быть как управляющими, так и информационными; в чертеж не передаются; подробнее о размерах эскизов и операций см. раздел 2.9.2.2.

– Размеры — элементы оформления:

• производные размеры — это размеры эскизов и операций, представленные в виде элементов оформления; наследуют тип соответствующих размеров; в Дереве построения отображаются как подчиненные объекты эскизов или операций; могут быть переданы в чертеж; подробнее о производных размерах см. раздел 2.9.2.8;

• размеры, проставленные к модели вручную; всегда информационные; в Дереве построения отображаются как самостоятельные объекты модели; могут быть переданы в чертеж; подробнее о размерах, проставленных вручную, см. раздел 2.9.2.3.

Внешний вид производных размеров и размеров, проставленных вручную, одинаковый (например, длина и угол стрелки, шрифт и положение размерной надписи и т.п.), так как он подчиняется настройке размеров модели (см. раздел 9.2.7.2). Отличаются производные размеры от размеров, проставленных вручную, только цветом отображения (по умолчанию цвет производных размеров — фиолетовый, цвет размеров, проставленных вручную — коричневый). Настройка цвета отображения объектов модели описана в раздел 9.2.7.4.7.


2.9.2.2. Размеры эскизов и операций

В КОМПАС-3D большинство операций имеют определенный набор числовых параметров. Если значение параметра операции выражено в линейных или угловых величинах, то этот параметр может показываться на экране в виде размера соответствующего типа — размера операции. Например, числовыми параметрами операции выдавливания являются: расстояние выдавливания, угол наклона и толщина стенки.

Размеры операции отображаются на экране в следующих случаях:

– при выполнении операции;

– в специальном режиме отображения размеров выбранного элемента (см. раздел 2.9.2.2.2.).

Для каждого числового параметра операции автоматически создается переменная. Имя переменной отображается в скобках под размерной линией размера, соответствующего параметру операции (рис. 2.9.2).

Рис. 2.9.2. Пример построения элемента выдавливания

Размеры эскиза, имеющие переменные, можно также просмотреть в режиме отображения размеров. Кроме того, размеры эскиза отображаются при выполнении операции, если эскиз участвует в ее создании.

При выполнении операции размеры эскизов и операций отображаются на экране, если в диалоге настройки отображения размеров и обозначений (см. раздел 9.1.11.12) включена опция Размеры эскизов и операций.

При работе с массивом можно включить отображение размеров эскизов и операций для каждого экземпляра массива (см. раздел 2.7.2.4).

Размеры эскизов и операции могут быть как управляющими, так и информационными (см. раздел 2.9.2.1).

В Дереве построения размеры эскизов и операций не отображаются.

Возможно включение или отключение отображения имен переменных и признака «управляющий» на размерах эскизов и операций (см. раздел 2.9.2.2.3).

При необходимости вы можете изменить значение размера эскиза или размера операции. Изменение значения размера возможно как во время выполнения операции (см. раздел 2.1.4.2.3), так и после — в режиме отображения размеров выбранного элементам (см. раздел 2.9.2.2.1).

При необходимости вы можете отобразить размеры эскизов и операций в виде элементов оформления (см. раздел 2.9.2.8). В результате в окне модели появляются производные размеры, соответствующие размерам эскизов и операций. В Дереве построения производные размеры отображаются подчиненными эскизам и операциям (см. рис. 2.9.18).

В этом разделе:

2.9.2.2.1. Задание значения размера

2.9.2.2.2. Отображение размеров эскизов и операций в окне модели

2.9.2.2.3. Отображение имен переменных в размерах эскизов и операций

2.9.2.2.4. Особенности работы с размерами операций


2.9.2.2.1. Задание значения размера

Вы можете отредактировать значения следующих размеров:

– ассоциативные размеры эскиза и размеры операции при выполнении операции или в режиме отображения размеров выбранного элемента (о режиме см. раздел 2.9.2.2.2);

– размеры, проставленные вручную (см. раздел 2.9.2.3),

– размеры эскиза и операции, представленные в виде элементов оформления (производные размеры, см. раздел 2.9.2.8).

При выполнении операции размеры эскиза и операции отображаются на экране, если в диалоге настройки отображения размеров и обозначений (см. раздел 9.1.11.12) включена опция Размеры эскизов и операций.

Ввод значения размера производится в диалоге установки значения размера (рис. 2.9.3).

Рис. 2.9.3. Диалог установки значения размера: а) операции, б) эскиза
а) | б)

Диалог появляется на экране после:

– двойного щелчка мышью на размерной надписи размера;

– вызова команды Установить значение размера из контекстного меню производного размера, выделенного в Дереве построения или в окне модели.

В этом диалоге вы можете выполнить следующие действия.

– Отредактировать имя переменной (только для размера эскиза и размера, проставленного вручную).

– Ввести нужное значение размера1: число, константу или выражение для вычисления значения размера (синтаксис выражений описан в разделе 7.1.3.3.1).

– Назначить индивидуальный допуск, используя кнопку Назначить допуск:

• на значение параметра операции,

• на размер эскиза,

• на размер, проставленный вручную.

Назначение допуска описано в разделе 2.10.2.2.

– Ввести комментарий к переменной.

– Сделать управляющий размер информационным или наоборот, используя кнопку Информационный размер (только для размера эскиза).

– Включить автоматическое перестроение модели после завершения задания значения размера (закрытия диалога), используя кнопку Перестроить.

Завершив редактирование размера, в диалоге нажмите кнопку Создать размер.

– Если в диалоге включено автоматическое перестроение модели, то изображение на экране перестроится в соответствии с новым значением размера.

– Если автоматическое перестроение модели отключено, то изображение на экране остается без изменения. Для перестроения модели нажмите кнопку Перестроить на панели Вид или клавишу <F5>. Изображение на экране перестроится в соответствии с новым значением размера.

Обратите внимание на следующую особенность редактирования значения размера эскиза или операции при выполнении операции. После изменения значения размера в диалоге Установить значение размера фантом создаваемого объекта перестраивается независимо от состояния кнопки Перестроить (см. выше).

  1. Для размера эскиза ввод значения возможен, если этот размер управляющий. В противном случае поле для ввода значения размера недоступно.


2.9.2.2.2. Отображение размеров эскизов и операций в окне модели

При работе с моделью вы можете просматривать:

– управляющие размеры операции, создающей объект, не входя в процесс ее редактирования;

– управляющие размеры эскиза, имеющие переменные, вне режима редактирования эскиза.

Для этого используется специальный режим отображения размеров выбранного элемента.

Кроме того, в этом режиме возможно изменение значений размеров эскизов и операций.

Выберите нужный объект, выделив его в Дереве построения или указав в окне модели любой его примитив: грань, ребро или вершину. Затем включите режим отображения размеров выбранного элемента. Для этого нажмите кнопку Размеры выбранного элемента на панели Режимы либо выберите ее название из меню Вид или из контекстного меню выделенного объекта. Кнопка Размеры выбранного элемента доступна, если не активна ни одна команда трехмерных построений.

На экране отображаются размеры выбранного объекта (рис. 2.9.4).

Рис. 2.9.4. Пример отображения размеров выделенного объекта: а) эскиза, б) элемента выдавливания
а) | б)

Если при выборе объекта его размеры не отображаются в окне модели, это означает, что:

– операция не имеет числовых параметров, выраженных в линейных или угловых величинах;

– эскиз не содержит управляющих размеров или управляющий размер эскиза не имеет переменной.

Чтобы изменить значение размера, выполните двойной щелчок мышью по его размерной надписи. На экране появляется диалог установки значения размера. Используя этот диалог, задайте нужное значение размера (см. раздел 2.9.2.2.1).

Чтобы перейти к просмотру или редактированию размеров другого объекта, выделите его примитив в окне модели.

Особенности отображения размеров выбранного объекта

1. Просмотр и изменение возможны для размеров только тех объектов, которые построены непосредственно в модели (а не в каком-либо из ее компонентов). Чтобы работать с компонентом, необходимо перейти в режим его редактирования в окне или на месте.

2. Если размер объекта уже представлен в виде производного размера (см. рис. 2.9.18), то изображение этого размера (дублирующее производный) не формируется в режиме отображения размеров.

3. Соединительные линии размеров (например, линии условно показывающие образмеренные объекты, см. рис. 2.9.4, б) отображаются на экране, если в диалоге настройки отображения размеров и обозначений (см. раздел 9.1.11.12) включена опция Соединительные линии.


2.9.2.2.3. Отображение имен переменных в размерах эскизов и операций

По умолчанию в модели включен режим отображения имен переменных и признака «управляющий» в размерах эскизов и операций (подробнее об управляющих размерах см. раздел 2.9.2.1).

В этом режиме размеры эскизов и операций отображаются следующим образом:

– значения размеров заключены в рамки (см. рис. 2.9.4),

– имена переменных, соответствующие размерам, отображаются под их размерными линиями.

Если значение числового параметра операции или размера эскиза задается константой, выражением или отрицательным числом, то под размерной линией размера отображаются: имя переменной и ее значение.

Чтобы выключить режим отображения имен переменных в размерах эскизов и операций, вызовите команду Вид — Имена переменных в размерах или нажмите клавишу <F11>.


2.9.2.2.4. Особенности работы с размерами операций

При редактировании операции какой-либо ее числовой параметр может стать зависимым от объекта модели. В этом случае размер операции, представляющий этот параметр, становится информационным и перестает отображаться на экране. Если этот размер операции был представлен как элемент оформления (производный размер), то после редактирования операции производный размер удаляется.

Например, при редактировании операции выдавливания способ построения На расстояние был изменен на способ До вершины. Расстояние выдавливания становится зависимым от положения заданной вершины. Размер операции, соответствующий расстоянию выдавливания, делается информационным и перестает отображаться на экране. Производный размер, представляющий этот размер операции, удаляется.


2.9.2.3. Порядок простановки размеров вручную

Система позволяет проставить вручную линейные, угловые, радиальные и диаметральные размеры к объектам различного типа. Объект, к которому проставляется размер, называется базовым.

Все размеры, проставляемые вручную в трехмерных моделях, являются информационными размерами (см. раздел 2.9.2.1).

Для создания размера вызовите команду простановки размера нужного типа.

Если требуется автоматическое создание размера, нажмите кнопку Автосоздание объекта на Панели специального управления. Подробнее об автоматическом и ручном создании объектов см. раздел 1.4.2.10.

При необходимости за один вызов команды можно проставить несколько размеров одного типа. Для этого, не выходя из команды, последовательно указывайте объекты, размеры к которым требуется проставить. Объекты могут быть указаны в Дереве построения или в окне модели.

В окне модели появляются созданные размеры, а в Дереве построения — их пиктограммы.

Чтобы завершить текущую команду, нажмите кнопку Прервать команду на Панели специального управления.

Кнопка Указать заново позволяет осуществить повторный выбор объектов.

Элементы управления, расположенные на вкладке Свойства, позволяют задать наименование размера в Дереве построения и цвет отрисовки размерных линий.

При простановке размера с умолчательными настройками размерная надпись может оказаться внутри тела. Для удобства дальнейшей работы с размером переместите мышью характерную точку, определяющую положение размерной надписи, таким образом, чтобы размерная надпись находилась снаружи тела.

Каждому размеру при его создании автоматически присваивается имя переменной. Чтобы изменить умолчательное имя переменной, дважды щелкните мышью на размерной надписи нужного размера. На экране появится диалог Установить значение размера. Введите новое имя переменной и нажмите кнопку Создать размер. Подробнее о диалоге установки значения размера см. раздел 2.9.2.2.1.

Режим работы с трехмерной моделью не поддерживает векторные шрифты, в том числе поставляемые с КОМПАС-3D шрифты GOST type A (plotter), GOST type B (plotter), Symbol type A (plotter), Symbol type B (plotter), поэтому не следует использовать их для размерных надписей.

Проставленные размеры могут иногда мешать просмотру изображения модели. Чтобы сделать размер невидимым, выделите его и вызовите из контекстного меню команду Скрыть. Размер также становится скрытым, если скрыт один из его объектов, к которым он проставлен.

Скрытые размеры не передаются в чертеж при создании в нем ассоциативных видов модели.

Чтобы сделать скрытый размер видимым, выделите его в Дереве построения и вызовите из контекстного меню команду Показать.

В КОМПАС-3D установлены такие умолчательные значения параметров размеров, которые наиболее часто используются в конструкторской документации. При необходимости вы можете изменить эти значения. Настройка параметров размеров для модели описана в разделе 9.2.7.2.


2.9.2.4. Линейный размер

Для простановки линейного размера используются точечные, прямолинейные и плоские объекты.

Точечные объекты:

– точка в эскизе,

– пространственная точка,

– вершина пространственной кривой,

– вершина тела или поверхности.

Прямолинейные объекты:

– отрезок в эскизе,

– сегмент ломаной,

– ребро тела или поверхности.

Плоские объекты:

– координатная плоскость,

– вспомогательная плоскость,

– грань тела или поверхности.

Чтобы проставить линейный размер, вызовите команду Линейный размер.

Укажите курсором объекты для простановки размера.

– Для простановки размера к прямолинейному объекту укажите курсором этот объект.

– Для простановки размера между двумя точечными объектами, двумя плоскими объектами или точечным и плоским объектами укажите курсором эти объекты.

Простановка линейного размера между двумя плоскими объектами возможна только в том случае, если эти объекты параллельны.

Укажите базовую плоскость — плоский объект, параллельно которому будет расположена плоскость простановки размера.

При простановке размера к ребру или отрезку в эскизе базовая плоскость выбирается системой автоматически. В первом случае в качестве базовой плоскости используется одна из пары граней, разделяемых ребром, а во втором — плоскость эскиза.

Вы можете сменить базовую плоскость (в том числе автоматически выбранную), не выходя из команды. Для этого активизируйте переключатель Плоскость на Панели свойств и укажите нужный плоский объект.

После указания объектов и базовой плоскости на экране появляется фантом размера. Штрихпунктирной линией с двумя точками отображается измеряемый отрезок. Его концы являются точками привязки размера (точками выхода выносных линий). Штриховой линией отображается линия проекции одного из объектов на плоскость простановки размера (необходимость проецирования определяется взаимным положением объектов и плоскости простановки размера).

Измеряемый отрезок и линия проекции отображаются, если при настройке параметров отображения размеров включена опция Показывать соединительные линии (см. раздел 9.1.11.12).

Задайте положение размерной линии. Для этого введите значение длины выносных линий в поле Длина на вкладке Размер Панели свойств (значение может быть как положительным, так и отрицательным) или переместите мышью характерные точки на ее концах.

При необходимости отредактируйте размерную надпись (см. раздел 3.3.1.3) и задайте параметры отрисовки размера (см. раздел 3.3.1.2), используя вкладки Панели свойств.

Если нужно разместить размерную надпись на полке, выполните действия, описанные в разделе 2.9.2.4.1.

По умолчанию линейный размер располагается в плоскости простановки размера слева от измеряемого отрезка. Левая сторона от измеряемого отрезка находится следующим образом. Строится вектор, направленный из первой точки привязки размера во вторую (или ее проекцию). Левой стороной считается часть плоскости простановки размера, лежащая слева по направлению этого вектора.

При простановке нескольких линейных размеров за один вызов команды выбор базовой плоскости сохраняется. Чтобы выбрать другую базовую плоскость, нажмите кнопку Указать заново на Панели свойств.

Пример простановки линейного размера между двумя точечными объектами показан на рис. 2.9.5.

Рис. 2.9.5. Пример простановки линейного размера

В этом разделе:

2.9.2.4.1. Размещение размерной надписи на полке

2.9.2.4.2. Зависимость значения размера от выбора базовой плоскости


2.9.2.4.1. Размещение размерной надписи на полке

При необходимости вы можете разместить размерную надпись на полке. Для этого во время создания или редактирования размера выполните следующие действия.

1. Активизируйте вкладку Параметры Панели свойств.

2. Из раскрывающегося списка Размещение текста выберите один из следующих вариантов: На полке, влево, На полке, вправо, На полке, вверх или На полке, вниз.

Линия-выноска появится на экране (рис. 2.9.6).

Рис. 2.9.6. Линейный размер на полке

3. Перемещая мышью точки т3 и т4, задайте положение начала линии-выноски и начала полки.


2.9.2.4.2. Зависимость значения размера от выбора базовой плоскости

Во всех случаях простановки линейного размера, кроме размера между плоским и точечным объектами, базовая плоскость определяет не только пространственное положение размера, но и его значение.

В качестве примера рассмотрим простановку размеров между точечными объектами в модели, показанной на рис. 2.9.7.

Рис. 2.9.7. Точечные объекты и возможные базовые грани для простановки размера

Для построения размера указаны точки 1 и 2, принадлежащие грани А и расположенные в центрах круглых ребер.

Рис. 2.9.8. Зависимость положения и значения размера от выбора базовой плоскости: а) базовая плоскость — грань А; б) базовая плоскость — грань Б; в) базовая плоскость — грань В
а) | б) | в)

– На рисунке 2.9.8, а) показан размер, базовой плоскостью которого является грань А. Поскольку эта грань содержит обе точки 1 и 2, она же является и плоскостью простановки размера. Значение размера равно фактическому расстоянию между точками 1 и 2.

– На рисунке 2.9.8 б) показан размер, базовой плоскостью которого является грань Б. Плоскость простановки размера параллельна этой грани и проходит через точку 1. Точка 2 спроецирована на плоскость простановки размера. Значение размера равно расстоянию от точки 1 до проекции точки 2, т.е. длине проекции фактического расстояния между точками 1 и 2 на базовую плоскость.

– На рисунке 2.9.8 в) показан размер, базовой плоскостью которого является грань В. Порядок его построения такой же, как у предыдущего.


2.9.2.5. Линейный размер от отрезка до точки

Линейный размер от отрезка до точки проставляется между прямолинейным и точечным объектами. Могут использоваться следующие объекты.

Прямолинейные:

– отрезок в эскизе,

– сегмент ломаной,

– координатная ось,

– вспомогательная ось,

– ребро тела или поверхности.

Точечные:

– точка в эскизе,

– пространственная точка,

– начало координат,

– вершина пространственной кривой,

– вершина тела или поверхности.

Чтобы проставить линейный размер от отрезка до точки, вызовите команду Линейный от отрезка до точки.

Укажите курсором прямолинейный объект, а затем — точечный.

Размер проставляется в плоскости, проходящей через объекты (рис. 2.9.9).

Рис. 2.9.9. Пример простановки линейного размера от отрезка до точки

Задайте положение размерной линии. Для этого введите значение длины выносных линий в поле Длина на вкладке Размер Панели свойств (значение может быть как положительным, так и отрицательным) или переместите мышью характерные точки на ее концах.

При необходимости отредактируйте размерную надпись (см. раздел 3.3.1.3) и задайте параметры отрисовки размера (см. раздел 3.3.1.2), используя вкладки Панели свойств.

Если нужно разместить размерную надпись на полке, выполните действия, описанные в разделе 2.9.2.4.1.


2.9.2.6. Угловой размер

Для простановки углового размера используются прямолинейные и плоские объекты, которые являются сторонами угла.

Прямолинейные объекты:

– отрезок в эскизе,

– сегмент ломаной,

– вспомогательная ось,

– ребро тела или поверхности.

Плоские объекты:

– координатная плоскость,

– вспомогательная плоскость,

– грань тела или поверхности.

Чтобы проставить угловой размер, вызовите команду Угловой размер.

Укажите курсором объекты: два прямолинейных, два плоских или прямолинейный и плоский.

При простановке размера между двумя прямолинейными объектами размер проставляется в плоскости, проходящей через эти объекты (рис. 2.9.10, а). Если выбранные объекты не лежат в одной плоскости, размер не проставляется.

При простановке размера между двумя плоскими объектами размер проставляется в плоскости, перпендикулярной линии пересечения этих объектов (рис. 2.9.10, б). Проекции плоскости простановки размера на выбранные плоские объекты отображаются в виде штриховых линий.

Размер, проставленный между двумя плоскими объектами, можно перемещать вдоль линии пересечения этих объектов. Для этого во время создания или редактирования размера переместите мышью характерную точку на его вершине на нужное расстояние.

При простановке размера между прямолинейным и плоским объектами размер проставляется в плоскости, проходящей через выбранный прямолинейный объект и его проекцию на выбранный плоский объект (рис. 2.9.10, в).

Линии проекций отображаются, если при настройке параметров отображения размеров включена опция Показывать соединительные линии (см. раздел 9.1.11.12).

Рис. 2.9.10. Примеры простановки углового размера: а) между двумя ребрами, б) между двумя гранями, в) между ребром и гранью
а) | б) | в)

Тип вновь созданного углового размера определяется системой автоматически. При необходимости с помощью переключателей группы Тип на вкладке Размер Панели свойств вы можете изменить предложенный системой способ простановки размера, в том числе включить простановку угла больше 180° (автоматический выбор этого варианта невозможен).

Задайте положение размерной линии. Для этого введите значение длины выносных линий в поле Длина (значение может быть как положительным, так и отрицательным) или переместите мышью характерные точки на ее концах.

Чтобы направить размерные линии в противоположную сторону, сохранив их длину, нажмите кнопку Сменить положение.

Если нужно разместить размерную надпись на полке, выполните действия, описанные в разделе 2.9.2.4.1.

При необходимости отредактируйте размерную надпись (см. раздел 3.3.1.3) и задайте параметры отрисовки размера (см. раздел 3.3.1.2), используя вкладки Панели свойств.


2.9.2.7. Радиальный и диаметральный размеры

Система позволяет проставлять радиальный и диаметральный размеры различными способами. Большинство параметров этих размеров одинаковы. Различие состоит в выборе типа размера (см. разделы 2.9.2.7.2 и 2.9.2.7.3).

В этом разделе:

2.9.2.7.1. Выбор объектов для простановки размеров

2.9.2.7.2. Радиальный размер

2.9.2.7.3. Диаметральный размер

2.9.2.7.4. Особенности простановки размера


2.9.2.7.1. Выбор объектов для простановки размеров

При простановке радиального и диаметрального размеров используются следующие объекты:

– окружность (дуга окружности) в эскизе,

– ребро тела или поверхности, имеющее форму окружности (дуги окружности),

– грань тела или поверхности, имеющая цилиндрическую, коническую, сферическую или тороидальную форму.

При выборе окружности в эскизе размер проставляется в плоскости эскиза.

При выборе ребра размер проставляется в плоскости этого ребра (рис. 2.9.11, а, б).

Рис. 2.9.11. Примеры простановки размеров к ребру детали: а) радиального, б) диаметрального
а) | б)

При выборе грани размер проставляется в плоскости, перпендикулярной оси выбранной грани (рис. 2.9.12, а, б).

Рис. 2.9.12. Примеры простановки размеров к грани детали: а) радиального, б) диаметрального
а) | б)

Окружность, к которой проставляется размер, отображается штрихпунктирной линией с двумя точками. Выносные линии — штриховыми.

Окружность, к которой проставляется размер, и выносные линии отображаются, если при настройке параметров отображения размеров включена опция Показывать соединительные линии (см. раздел 9.1.11.12).

Положение размера можно задавать произвольно или фиксировать.

Для произвольного задания положения размера переместите мышью характерную точку в центре окружности, к которой проставляется размер, вдоль оси грани.

Для фиксации положения размера включите опцию Положение на вкладке Размер Панели свойств и укажите курсором объект фиксации — точечный объект или плоский объект, параллельный плоскости простановки размера. Размер будет проставлен в плоскости, проходящей через объект фиксации. Повторное указание курсором этого объекта отменит фиксацию положения размера.

Между размером и объектом фиксации формируется ассоциативная связь. Благодаря этой связи размер следует за объектом фиксации при изменении положения последнего.


2.9.2.7.2. Радиальный размер

Чтобы проставить радиальный размер, вызовите команду Радиальный размер.

Укажите объект для простановки размера (см. раздел 2.9.2.7.1).

Радиальный размер может быть проставлен от центра или не от центра окружности. В обоих случаях размерная линия принадлежит прямой, проходящей через центр образмериваемой окружности. Отличие состоит в следующем. Если размер проставлен от центра, то длина его размерной линии не может быть меньше радиуса. Если размер проставлен не от центра, то длина размерной линии может быть любой.

Для выбора нужного варианта простановки размера воспользуйтесь группой переключателей Тип на вкладке Размер Панели свойств.

Задайте положение размерной линии, перемещая мышью характерную точку т1 (рис. 2.9.13).

Рис. 2.9.13. Радиальный размер с ручным размещением размерной линии

При необходимости отредактируйте размерную надпись (см. раздел 3.3.1.3) и задайте параметры отрисовки размера (см. раздел 3.3.1.2), используя вкладки Панели свойств.

Если нужно разместить размерную надпись на полке, выполните действия, описанные в разделе 2.9.2.4.1.


2.9.2.7.3. Диаметральный размер

Чтобы проставить диаметральный размер, вызовите команду Диаметральный размер.

Укажите объект для простановки размера (см. раздел 2.9.2.7.1).

Размерная линия может быть полная или с обрывом. Для выбора нужного варианта воспользуйтесь группой переключателей Тип на вкладке Размер Панели свойств.

Размерная линия с обрывом выходит за центр окружности на расстояние, равное 1/5 ее радиуса, но не менее, чем на расстояние, установленное в данном документе для выхода размерной линии за текст. Эта величина задается при настройке параметров размеров в текущей модели (см. 9.2.7.2.2).

Задайте положение размерной линии, перемещая мышью характерную точку т1 (рис. 2.9.14).

Рис. 2.9.14. Диаметральный размер с ручным размещением размерной линии

При необходимости отредактируйте размерную надпись (см. раздел 3.3.1.3) и задайте параметры отрисовки размера (см. раздел 3.3.1.2), используя вкладки Панели свойств.

Если нужно разместить размерную надпись на полке, выполните действия, описанные в разделе 2.9.2.4.1.


2.9.2.7.4. Особенности простановки размера

Простановка размера к грани конической, сферической или тороидальной формы имеет следующие особенности.

Грань конической формы

Размер к грани конической формы проставляется в плоскости, перпендикулярной оси грани (оси конуса) и проходящей через точку, в которой была указана грань (рис. 2.9.15).

Рис. 2.9.15. Пример простановки диаметрального размера к грани конической формы

Значение размера соответствует значению радиуса (диаметра) сечения конуса плоскостью простановки размера. При перемещении размера вдоль оси конуса его значение изменяется соответственно изменению значения радиуса (диаметра) сечения конуса.

Если положение размера зафиксировано (см. раздел 2.9.2.7.1), то значение размера будет соответствовать значению радиуса (диаметра) сечения конуса плоскостью, проходящей через объект фиксации. В качестве объекта фиксации может быть выбран точечный объект или плоский объект, перпендикулярный оси конуса.

Грань сферической формы

Размер к грани сферической формы проставляется в плоскости, проходящей через центр сферы и точку, в которой была указана грань (рис. 2.9.16). Первоначальное положение плоскости выбирается системой. При необходимости вы можете изменить положение плоскости простановки размера, перемещая мышью характерную точку т1.

Рис. 2.9.16. Пример простановки диаметрального размера к грани сферической формы

При фиксации положения размера (см. раздел 2.9.2.7.1) возможны следующие варианты его простановки:

– относительно точечного объекта — в плоскости, проходящей через центр сферы и выбранный точечный объект; положение плоскости определяется системой,

– относительно плоского объекта — в плоскости, проходящей через центр сферы параллельно выбранному плоскому объекту.

Грань тороидальной формы

Размер к грани тороидальной формы проставляется в плоскости, перпендикулярной оси грани (круговой оси тора) и проходящей через точку, в которой была указана грань (рис. 2.9.17).

Рис. 2.9.17. Пример простановки диаметрального размера к грани тороидальной формы

В качестве объекта фиксации (см. раздел 2.9.2.7.1) может быть выбран точечный объект или плоский объект, перпендикулярный круговой оси тора.


2.9.2.8. Производные размеры

Размеры эскизов и размеры операций можно представить в виде элементов оформления. В результате в окне модели появляются производные размеры, соответствующие размерам эскизов и операций. В Дереве построения производные размеры отображаются подчиненными эскизам и операциям (рис. 2.9.18).

Рис. 2.9.18. Производные размеры: а) в Дереве построения, б) в окне модели
а) | б)

Чтобы размеры эскизов или операций представить в виде элементов оформления, выполните следующие действия.

1. Вызовите команду Операции — Элементы оформления — Производные размеры. Кнопка для вызова этой команды находится на панели Элементы оформления.

2. Выделите в Дереве построения объекты, размеры которых требуется отобразить в виде элементов оформления, или укажите в окне модели любой примитив объектов: грань, ребро или вершину.

Объекты могут быть выделены и перед вызовом команды.

Указанные объекты выделяются цветом, а на панели Список объектов появляются их наименования. Повторное указание объекта отменяет его выбор.

3. Включите опцию Размеры с нулевым значением, чтобы создавать производные размеры для размеров с нулевым значением.

4. Чтобы сменить объекты, размеры которых требуется отобразить в виде элементов оформления, нажмите кнопку Указать заново на Панели специального управления и повторите выбор объектов.

5. Завершив выбор объектов, нажмите кнопку Создать объект на Панели специального управления.

Размеры эскиза, для которых не созданы переменные, нельзя представить в виде элементов оформления.

Производные размеры выбранных объектов появляются в окне модели и в Дереве построения. Цвет отображения размеров в окне по умолчанию фиолетовый.

Производные размеры для размеров с нулевым значением отображаются только в Дереве построения. В окне модели эти производные размеры не отображаются.

Управляющие размеры эскизов и операций, представленные как элементы оформления, сохраняют свой тип, т.е. остаются управляющими. При изменении значения такого размера модель перестраивается. Изменение значения производного размера производится в диалоге установки значения размера (см. раздел 2.9.2.2.1).

Производные размеры можно передать в чертеж при создании в нем ассоциативных видов модели (см. раздел 3.7.1.2). Переданные в чертеж размеры являются проекционными обозначениями. Работа с проекционными обозначениями описана в разделе 3.7.3.5.

В этом разделе:

2.9.2.8.1. Особенности работы с производными размерами


2.9.2.8.1. Особенности работы с производными размерами

Если фаска построена по стороне и углу, равному 45°, то создается один линейный производный размер (согласно стандарту). Текст размерной надписи этого размера содержит значения стороны и угла фаски, например, 5х45°. При необходимости для этой фаски можно создать два производных размера — линейный и угловой. Для этого выполните следующие действия.

1. Выделите производный размер фаски в Дереве построения или в окне модели и вызовите команду Редактировать из контекстного меню.

2. Вызовите диалог ввода размерной надписи размера. Для этого щелкните мышью в поле Текст на вкладке Размер Панели свойств.

3. Очистите поле Текст после и закройте диалог кнопкой OK.

4. Чтобы закончить редактирование размера, нажмите кнопку Создать объект на Панели специального управления. Текст размерной надписи отредактированного размера содержит только значение стороны фаски.

5. Вызовите команду Производные размеры.

6. Выделите в Дереве построения или в окне модели фаску.

7. Нажмите кнопку Создать объект. В Дереве построения и в окне модели к линейному производному размеры фаски добавляется угловой производный размер.


2.9.2.9. Редактирование производных размеров

Для производного размера вы можете отредактировать его отображение: задать новые параметры отрисовки и отредактировать размерную надпись.

Кроме того, вы можете отредактировать размещение указанных производных размеров — задать нужную плоскость (или плоскую грань), в которой будут размещаться эти размеры.

Редактирование отображения производного размера описано в разделе 2.9.2.9.1, размещение производных размеров — в разделе 2.9.2.9.2.

В этом разделе:

2.9.2.9.1. Редактирование отображения производного размера

2.9.2.9.2. Размещение производных размеров

2.9.2.9.3. Условия размещения производного размера в базовой плоскости

2.9.2.9.4. Порядок размещения производных размеров


2.9.2.9.1. Редактирование отображения производного размера

При редактировании отображения производного размера можно изменить его размерную надпись и задать новые параметры отрисовки.

Чтобы изменить отображение производного размера, нужно выделить этот размер в Дереве построения или в окне модели и вызвать из контекстного меню команду Редактировать.

На Панели свойств появляются вкладки Размер, Параметры, Свойства.

Элементы управления вкладки Размер описаны в таблице 2.9.1, вкладки Параметры — в таблице 3.3.3.

Элементы управления, расположенные на вкладке Свойства, позволяют задать наименование размера в Дереве построения и цвет отрисовки размерных линий.

Табл. 2.9.1. Элементы управления вкладки Размер

Элемент

Описание

Объект

В этом поле отображается название объекта (эскиза или операции), размеры которого представлены в виде элементов оформления (производных размеров).

Параметр

В этом поле отображается название размера эскиза или параметра операции, представленного в виде элемента оформления (производного размера).

Длина1

Поле, позволяющее задать длину выносных линий производного размера.

По умолчанию поле содержит значение длины выносных линий размера.

Чтобы изменить умолчательное значение, введите нужное значение длины с клавиатуры или задайте его при помощи счетчика (значение может быть как положительным, так и отрицательным).

Длину выносных линий можно также изменить с помощью характерных точек на концах размерной линии.

При перемещении мышью одной из характерных точек значение длины определяется автоматически и заносится в это поле.

Текст2

Поле для вызова диалога ввода размерной надписи, в котором вы можете задать нужное значение размера и настроить его оформление (см. раздел 3.3.1.3).

Тип3

Группа переключателей, позволяющая указать тип размерной линии диаметрального или радиального размера:

– полная или с обрывом — для диаметрального размера;

– от центра или не от центра — радиального размера.
  1. Присутствует на Панели свойств при редактировании линейного или углового размера.
  2. Присутствует на Панели свойств при редактировании линейного, диаметрального или радиального размера.
  3. Присутствует на Панели свойств при редактировании диаметрального или радиального размера.

Чтобы завершить редактирование производного размера, нажмите кнопку Создать объект на Панели специального управления.

Для отказа от редактирования размера нажмите клавишу <Esc> или кнопку Прервать команду.


2.9.2.9.2. Размещение производных размеров

Сразу после создания производные размеры размещаются следующим образом:

– производный размер, соответствующий размеру эскиза, размещается в плоскости этого эскиза,

– производный размер, соответствующий размеру операции, располагается в плоскости, автоматически определенной системой в зависимости от типа размера и объекта, создаваемого операцией.

Плоскость, в которой производный размер находится сразу после создания, называется исходной плоскостью.

Вы можете разместить один или несколько производных размеров в другой плоскости, задав базовую плоскость. В качестве базовой плоскости может использоваться:

– координатная или вспомогательная плоскость;

– плоская грань.

Производный размер изменяет свое положение (размещается в базовой плоскости), если выполняются условия размещения (см. раздел 2.9.2.9.3). Если условия не выполняются, производный размер не меняет своего положения, а на экране появляется сообщение об этом.

При необходимости после размещения размера в базовой плоскости можно отменить сделанные изменения — размер разместится в исходной плоскости.

Порядок размещения производных размеров описан в разделе 2.9.2.9.4.


2.9.2.9.3. Условия размещения производного размера в базовой плоскости

Любой производный размер может быть размещен в базовой плоскости, которая параллельна его исходной плоскости.

Кроме того, в зависимости от типа размера и операции, к которой он относится, возможны следующие варианты размещения:

– Линейный размер размещается в базовой плоскости, если эта плоскость пересекает его исходную плоскость по линии, параллельной размерной линии.

– Производный размер, соответствующий параметру операции выдавливания Угол уклона, размещается в базовой плоскости, если эта плоскость пересекает сечение и перпендикулярна ему в точке пересечения.

– Производный диаметральный размер можно разместить в базовой плоскости, если эта плоскость перпендикулярна исходной плоскости. При таком размещении диаметральный размер преобразуется в линейный.

При условии указания траектории любой производный размер можно разместить в произвольно расположенной базовой плоскости. Траектория — линия, вдоль которой размер перемещается в эту плоскость. Траектория должна пересекать исходную и базовую плоскости размера, причем угол между базовой плоскостью и траекторией должен быть равен углу между исходной плоскостью и траекторией.

Этот способ предназначен в основном для размещения размеров эскиза-сечения операции выдавливания, вращения или кинематической (построенной с сохранением угла наклона сечения) в плоскости, совпадающей с любым из положений сечения на траектории, по которой оно двигалось при образовании операции. Для получения предсказуемого положения размеров рекомендуется в качестве траектории выбирать ребро, образованное в результате операции и совпадающее с направлением движения сечения (для операций вращения или выдавливания), либо собственно траекторию (для кинематической операции). Если в качестве траектории указана произвольная кривая, положение размеров в базовой плоскости может отличаться от ожидаемого.


2.9.2.9.4. Порядок размещения производных размеров

Чтобы изменить плоскость расположения производных размеров или отменить сделанные изменения и разместить размеры в их исходных плоскостях, выполните следующие действия.

1. Вызовите команду Редактор — Разместить производные размеры. Кнопка для вызова этой команды находится на панели Элементы оформления.

2. Сформируйте набор производных размеров, расположение которых требуется изменить. Для этого выделите в Дереве построения или в окне модели нужные производные размеры.

Производные размеры могут быть выделены и перед вызовом команды.

Указанные размеры выделяется цветом, а на панели Список размеров появляются их наименования. Повторное указание размера отменяет его выбор.

– Чтобы выбрать сразу все производные размеры модели, нажмите кнопку Выделить все размеры на панели Список размеров.

– Чтобы сменить размеры, нажмите кнопку Указать заново на Панели специального управления и повторите выбор размеров.

– Чтобы удалить размер из набора, выделите его название в списке размеров на панели Список размеров и нажмите кнопку Удалить.

3. Задайте способ определения базовой плоскости расположения для размеров набора с помощью группы переключателей Базовая плоскость.

– Чтобы разместить размеры набора в их исходных плоскостях, активизируйте переключатель Автоопределение.

– Чтобы разместить размеры набора в новой плоскости, активизируйте переключатель Ручное указание.

После активизации переключателя Ручное указание становится доступен переключатель Базовая плоскость. Активизируйте этот переключатель и укажите в окне модели нужную плоскость или плоскую грань. Указанный объект выделяется цветом, а его имя отображается в поле Плоскость на Панели свойств.

4. Если необходимо задать траекторию для перемещения производных размеров в базовую плоскость, активизируйте переключатель Траектория. Укажите в окне модели нужное ребро или кривую. Указанный объект выделяется цветом, а его имя отображается в поле Траектория на Панели свойств.

В некоторых случаях при изменении плоскости одного производного размера существует несколько вариантов размещения. Примером является размещение производного размера операции Фаска, когда новая плоскость пересекает ребро, на котором построена фаска, и перпендикулярна ему.

Если существует несколько вариантов размещения, становятся доступны кнопки Следующий объект и Предыдущий объект Панели специального управления. С их помощью выбирается нужный вариант.

5. Завершив настройку размещения размеров, нажмите кнопку Создать объект на Панели специального управления.

Указанные размеры размещаются в соответствии с выполненной настройкой:

– Если выбрано автоопределение плоскости расположения размеров, то каждый размер набора размещается в своей исходной плоскости, наименования всех размеров набора удаляются из панели Список размеров.

– Если задана базовая плоскость, то размеры набора размещаются в заданной плоскости; линии проекций размеров и линии, условно показывающие образмеренные объекты, показываются на экране соединительными линиями. Наименования размеров удаляются из панели Список размеров.
Если после нажатия кнопки Создать объект на панели Список размеров остаются наименования размеров, это означает, что эти размеры невозможно разместить в указанной плоскости. На экране появляется сообщение об этом, а размеры остаются в своих текущих базовых плоскостях (или исходных плоскостях). Выделение таких размеров не отменяется. Вы можете задать для них другую базовую плоскость.

За один вызов команды Разместить производные размеры можно сменить плоскость расположения произвольному количеству размеров.

Для отказа от размещения размеров нажмите клавишу <Esc> или кнопку Прервать команду.

Обратите внимание на то, что соединительные линии размеров отображаются на экране, если в диалоге настройки отображения размеров и обозначений (см. раздел 9.1.11.12) включена опция Соединительные линии. Особенность размеров, перемещенных по траектории: для них отображаются только линии, показывающие образмеренные объекты, а линии проекций не отображаются.


2.9.3. Обозначения

2.9. Размеры, обозначения, резьба (условное изображение)

2.9.3. Обозначения

Система позволяет создать следующие условные обозначения:

– обозначение шероховатости,

– обозначение базовой поверхности,

– произвольную линию-выноску,

– линию-выноску для обозначения клеймения,

– линию-выноску для обозначения маркировки,

– линию-выноску для обозначения позиции (только в сборочных моделях),

– обозначение допуска формы.

Условные обозначения в модели обладают следующими свойствами.

– Обозначения ассоциативно связываются с указанными при их создании объектами. Благодаря этой связи каждое обозначение всегда относится к определенному объекту в модели.

– Каждое обозначение располагается в плоскости, называемой плоскостью обозначения. Обозначения всегда остаются в своих плоскостях, т.е. поворачиваются при повороте модели. Если модель повернута так, что плоскость обозначения оказывается перпендикулярна плоскости экрана, то это обозначение не отображается.

– Если плоскость обозначения не перпендикулярна экрану, то обозначение всегда отображается таким образом, чтобы текст в нем можно было читать слева направо.

Для простановки обозначения вызовите команду создания обозначения нужного типа, укажите в окне модели обозначаемый объект (объекты) и настройте параметры обозначения.

Общие приемы создания обозначений в модели описаны в разделе 2.9.3.1, а специальные приемы создания конкретных обозначений — в разделах 2.9.3.2–2.9.3.8.

При простановке обозначения шероховатости и базы доступно автосоздание. По умолчанию оно включено, о чем свидетельствует нажатая кнопка Автосоздание объекта на Панели специального управления.

При простановке остальных обозначений требуется подтверждать создание объекта вручную, нажимая кнопку Создать объект.

Подробнее об автоматическом и ручном создании объектов см. раздел 1.4.2.10.

При необходимости за один вызов команды можно проставить несколько обозначений одного типа. Для этого, не выходя из команды, последовательно указывайте в окне модели новые обозначаемые объекты.

В окне модели появляются созданные обозначения, а в Дереве построения — их пиктограммы.

Чтобы завершить текущую команду, нажмите кнопку Прервать команду на Панели специального управления.

Вы можете, не прерывая команду простановки обозначения, развернуть модель так, чтобы плоскость создаваемого обозначения была параллельна плоскости экрана. Для этого вызовите команду Нормально к... из меню кнопки Ориентация (см. раздел 2.1.3.2).

Режим работы с трехмерной моделью не поддерживает векторные шрифты, в том числе поставляемые с КОМПАС-3D шрифты GOST type A (plotter), GOST type B (plotter), Symbol type A (plotter), Symbol type B (plotter), поэтому не следует использовать их для надписей в составе обозначений.

Созданные обозначения могут иногда мешать просмотру изображения модели. Чтобы сделать обозначение невидимым, выделите его и вызовите из контекстного меню команду Скрыть.

Скрытые обозначения не передаются в чертеж при создании в нем ассоциативных видов модели.

Чтобы сделать скрытое обозначение видимым, выделите его в Дереве построения или в окне модели и вызовите из контекстного меню команду Показать.

Вы можете скрыть сразу все обозначения, вызвав команду Вид — Скрыть — Условные обозначения. После этого в модели перестают отображаться как имеющиеся, так и вновь добавляемые обозначения. Чтобы сделать обозначения видимыми, вызовите команду повторно. Те обозначения, которые не были скрыты по отдельности, отобразятся на экране.

Если в результате редактирования модели в ней исчезает элемент, использовавшийся для обозначения (например, скругляется ребро, к которому была проставлена линия-выноска), это обозначение остается на своем прежнем месте. Поэтому, чтобы избежать появления в модели таких «висящих в пространстве» обозначений, рекомендуется создавать обозначения после того, как форма модели полностью определена.

В КОМПАС-3D установлены такие умолчательные значения параметров обозначений, которые наиболее часто используются в конструкторской документации. При необходимости вы можете изменить эти значения. Настройка параметров обозначений описана в разделе 9.2.7.3.

В этом разделе:

2.9.3.1. Общие приемы создания обозначений

2.9.3.1.1. Задание положения плоскости обозначения

2.9.3.1.2. Добавление и удаление ответвлений

2.9.3.2. Шероховатость

2.9.3.3. База

2.9.3.4. Линия-выноска

2.9.3.5. Обозначение клеймения

2.9.3.6. Обозначение маркировки

2.9.3.7. Обозначение позиции

2.9.3.8. Допуск формы


2.9.3.1. Общие приемы создания обозначений

В этом разделе:

2.9.3.1.1. Задание положения плоскости обозначения

2.9.3.1.2. Добавление и удаление ответвлений


2.9.3.1.1. Задание положения плоскости обозначения

Плоскость обозначения располагается параллельно базовой. В качестве базовой плоскости используется одна из координатных плоскостей.

Первоначально базовая плоскость выбирается системой автоматически в зависимости от расположения модели относительно плоскости экрана. При необходимости вы можете выбрать другую базовую плоскость, а также сместить плоскость обозначения параллельно самой себе.

Чтобы сменить базовую плоскость, выберите название нужной плоскости из раскрывающегося списка Базовая плоскость на вкладке Знак Панели свойств (рис. 2.9.19). Можно также воспользоваться командами Выбрать базовой плоскость XY / ZX / ZY контекстного меню.

Рис. 2.9.19. Панель свойств при построении линии-выноски

По умолчанию плоскость обозначения проходит через точку, в которой был указан обозначаемый объект (или через сам объект, если он — точечный). Если необходимо, вы можете сместить плоскость обозначения относительно умолчательного положения.

При создании обозначения шероховатости и базы эта возможность доступна при отключенном автосоздании объекта и только после того, как обозначение сформировано (для обозначения шероховатости — указана точка простановки знака (или начала полки), для обозначения базы — точка, определяющая положение рамки с надписью, и начальная точка одного ответвления).

Чтобы сместить плоскость обозначения, нажмите кнопку Положение на вкладке Знак Панели свойств. На экране отображается фантом плоскости обозначения.

Смещение плоскости обозначения можно задать произвольно или зафиксировать ее совпадение с имеющимся в модели объектом.

– Для произвольного задания положения плоскости обозначения переместите мышью характерную точку фантома плоскости. Фантом будет двигаться так, чтобы плоскость обозначения оставалась параллельной базовой, а все начальные точки ответвлений — на обозначаемом объекте (объектах).

Если перемещение плоскости обозначения невозможно, например, когда обозначаемый объект — точка или ребро, параллельное базовой плоскости, фантом остается на месте.

– Для фиксации положения плоскости обозначения укажите курсором объект фиксации. Плоскость обозначения будет проходить через этот объект. Объектом фиксации может служить любой точечный, прямолинейный или плоский объект модели, расположенный так, чтобы через него можно было провести плоскость, параллельную базовой плоскости и пересекающую обозначаемый объект. Повторное указание курсором объекта фиксации отменит фиксацию положения плоскости обозначения.

Между плоскостью обозначения и объектом фиксации формируется ассоциативная связь. Благодаря этой связи плоскость следует за объектом фиксации при изменении положения последнего.

Если плоскость обозначения зафиксирована, то смена базовой плоскости невозможна (список выбора базовой плоскости недоступен). Чтобы выбрать другую базовую плоскость, необходимо сначала отменить фиксацию плоскости обозначения.


2.9.3.1.2. Добавление и удаление ответвлений

Линия-выноска, обозначения маркировки и клеймения, обозначение позиции, а также допуск формы могут иметь более одного ответвления.

Все ответвления одного обозначения должны лежать в плоскости этого обозначения, т.е. в качестве второй и последующих начальных точек ответвления должны быть указаны точки, принадлежащие плоскости обозначения.

Во время указания начальных точек дополнительных ответвлений, когда курсор проходит над телом (или поверхностью), пересекающимся с плоскостью обозначения, на экране пунктиром отображается линия пересечения тела (поверхности) с плоскостью обозначения. Грани тел и поверхностей могут быть указаны только в точках, лежащих на этой линии. Когда над ней проходит курсор, рядом с ним отображается название привязки Точка на кривой и значок грани.

Чтобы добавить к обозначению ответвление, следует подвести курсор к нужной точке начала этого ответвления (на линии пересечения грани и плоскости обозначения) и щелкнуть мышью, когда рядом с ним появится название привязки Точка на кривой.

Для линий-выносок и допусков формы и обозначения началом ответвления могут служить также находящиеся в плоскости обозначения пространственные точки и точки, принадлежащие не грани, а, например, пространственной кривой, вспомогательной оси и т.п. Признаком того, что такая точка может быть началом ответвления, является отображение около курсора при прохождении его над этой точкой названия привязки Ближайшая точка и значка объекта, которому эта точка принадлежит.

Объекты, которым принадлежат начальные точки ответвлений обозначения, считаются объектами, к которым относится это обозначение. Их перечень отображается на панели Список объектов вкладки Знак на Панели свойств (см. рис. 2.9.19).

При выделении названия объекта в списке соответствующее ему ответвление подсвечивается в окне модели.

Чтобы удалить ответвление, укажите его в списке и нажмите клавишу <Delete> или кнопку Удалить на панели Список объектов.


2.9.3.2. Шероховатость

Обозначение шероховатости может проставляться на следующих объектах:

– грань тела или поверхности,

– ребро тела или поверхности,

– сегмент пространственной ломаной,

– размер,

– обозначение.

Чтобы создать обозначение, вызовите команду Шероховатость.

Укажите объект для простановки обозначения шероховатости.

Если требуется сменить выбранный объект, нажмите кнопку Указать заново на Панели специального управления и укажите новый объект.

После указания объекта на экране появляется фантом обозначения. Он располагается в плоскости обозначения. При необходимости вы можете изменить положение плоскости обозначения (см. раздел 2.9.3.1.1).

Если в качестве обозначаемого объекта указан размер или обозначение, то обозначение шероховатости располагается в плоскости этого объекта. Изменение положения плоскости невозможно.

По умолчанию формируется обозначение шероховатости поверхности, способ обработки которой не устанавливается. При этом в группе Тип активен переключатель Без указания вида обработки. Для создания обозначения шероховатости поверхности, образованной с удалением или без удаления слоя материала, активизируйте соответствующий переключатель в указанной группе.

Введите текст и настройте отрисовку обозначения (см. раздел 3.3.7.3.1 и раздел 3.3.7.3.2).

По умолчанию создается обозначение шероховатости на полке.

Укажите точку начала полки.

Рис. 2.9.20. Пример простановки обозначения шероховатости

Структура обозначения шероховатости определяется ГОСТ 2.309–73 (см. рис. 3.3.52).

Выбор структуры, используемой в текущей модели, производится при настройке обозначения шероховатости в текущей модели (см. раздел 9.2.7.3.12). По умолчанию в новых моделях создаются обозначения шероховатости в соответствии с изменением в ГОСТ 2.309–73.

Не выходя из команды, вы можете создать несколько обозначений шероховатости. При этом выбранный тип знака и сформированная надпись сохраняются.


2.9.3.3. База

Для простановки обозначения базы могут быть указаны следующие объекты:

– грани поверхностей и тел,

– ребра поверхностей и тел,

– размеры,

– вспомогательные оси и плоскости,

– пространственные кривые.

Чтобы создать обозначение базовой поверхности, вызовите команду База.

Укажите объект для простановки обозначения базы.

Если требуется сменить выбранный объект, нажмите кнопку Указать заново на Панели специального управления и укажите новый объект.

После указания объекта на экране появится фантом обозначения. Середина основания треугольника, обозначающего базу, совпадает с точкой, в которой был указан объект. Фантом располагается в плоскости обозначения. При необходимости вы можете изменить положение плоскости обозначения (см. раздел 2.9.3.1.1).

Если в качестве обозначаемого объекта указан размер или обозначение, то обозначение базы проставляется в плоскости этого объекта. Изменение положения плоскости невозможно.

По умолчанию формируется обозначение базы, перпендикулярное указанному объекту. При этом в группе Тип на Панели свойств активен переключатель Перпендикулярно к опорному элементу. Если требуется создать наклонное обозначение, активизируйте переключатель Произвольное расположение.

В поле Текст отображается предлагаемая системой буква для обозначения выносного элемента.

По умолчанию включена опция Автосортировка — при этом обозначениям баз в порядке их создания автоматически присваиваются буквы алфавита, что исключает совпадение букв. При включенной опции Автосортировка поле Текст недоступно. Если необходимо ввести букву для обозначения базы вручную, отключите опцию Автосортировка. Поле Текст станет доступно, но контроль совпадения букв будет отключен.

При последующем включении опции Автосортировка введенные вручную буквы заменяются автоматически определенными.

Укажите точку, определяющую положение рамки с надписью.

Рис. 2.9.21. Пример простановки обозначения базы


2.9.3.4. Линия-выноска

Линия-выноска может быть проставлена к следующим объектам:

– грань тела или поверхности,

– координатная плоскость,

– вспомогательная плоскость,

– точка в эскизе,

– пространственная точка,

– вершина пространственной кривой,

– линия эскиза,

– сегмент пространственной ломаной,

– пространственная кривая,

– ребро тела или поверхности,

– координатная ось,

– вспомогательная ось,

– размер,

– обозначение.

Чтобы создать произвольную линию-выноску, вызовите команду Линия-выноска.

Укажите объект, на который указывает первое ответвление линии-выноски. Начальной точкой первого ответвления будет точка, в которой был указан объект.

Задайте точку начала полки.

На экране появляется фантом обозначения. Он располагается в плоскости обозначения. При необходимости вы можете изменить положение плоскости обозначения (см. раздел 2.9.3.1.1).

Если в качестве обозначаемого объекта выбран размер или условное обозначение, то линия-выноска проставляется в плоскости этого объекта. Изменение положения плоскости обозначения невозможно.

Чтобы задать начальные точки дополнительных ответвлений, укажите точки, лежащие в плоскости обозначения. Подробно о добавлении и удалении ответвлений рассказано в разделе 2.9.3.1.2.

Введите надпись и настройте отрисовку линии-выноски (см. раздел 3.3.7.4.1 и раздел 3.3.7.4.2).

Кнопка Редактировать точки на Панели специального управления позволяет изменить конфигурацию линии-выноски (см. раздел 3.3.7.4.3).

Чтобы зафиксировать обозначение, нажмите кнопку Создать объект.

Рис. 2.9.22. Пример простановки линии-выноски


2.9.3.5. Обозначение клеймения

Для простановки обозначения клеймения могут использоваться грани тел или поверхностей.

Чтобы создать линию-выноску для обозначения клеймения, вызовите команду Знак клеймения.

Укажите объект, на который будет указывать первое ответвление линии-выноски. Начальной точкой первого ответвления будет точка, в которой был указан объект.

Задайте точку, определяющую положение знака клеймения.

На экране появляется фантом обозначения. Он располагается в плоскости обозначения. При необходимости вы можете изменить положение плоскости обозначения (см. раздел 2.9.3.1.1).

Чтобы задать начальные точки дополнительных ответвлений, укажите точки, лежащие в плоскости обозначения. Подробно о добавлении и удалении ответвлений рассказано в разделе 2.9.3.1.2.

В поле Текст на Панели свойств отображается предлагаемый системой текст обозначения клеймения. При необходимости вы можете изменить как содержание, так и начертание надписи (см. раздел 3.3.7.5.1).

Настройте отрисовку обозначения клеймения (см. раздел 3.3.7.5.2).

Кнопка Редактировать точки на Панели специального управления позволяет изменить конфигурацию линии-выноски (см. раздел 3.3.7.4.3).

Чтобы зафиксировать обозначение, нажмите кнопку Создать объект.

Рис. 2.9.23. Пример простановки обозначения клеймения


2.9.3.6. Обозначение маркировки

Для обозначения маркировки могут использоваться грани тел или поверхностей.

Чтобы создать линию-выноску для обозначения маркировки, вызовите команду Знак маркировки.

Укажите объект, на который будет указывать первое ответвление линии-выноски. Начальной точкой первого ответвления будет точка, в которой был указан объект.

Задайте точку, определяющую положение знака маркировки.

На экране появляется фантом обозначения. Он располагается в плоскости обозначения. При необходимости вы можете изменить положение плоскости обозначения (см. раздел 2.9.3.1.1).

Чтобы задать начальные точки дополнительных ответвлений, укажите точки, лежащие в плоскости обозначения. Подробно о добавлении и удалении ответвлений рассказано в разделе 2.9.3.1.2.

В поле Текст на Панели свойств отображается предлагаемый системой текст обозначения маркировки. При необходимости вы можете изменить как содержание, так и начертание надписи. Это делается так же, как при создании обозначения клеймения в графическом документе (см. раздел 3.3.7.5.1).

С помощью списка Стрелка на вкладке Параметры можно выбрать тип стрелки линии-выноски. Если этот тип стрелки необходимо использовать в обозначениях маркировки до конца текущего сеанса работы, включите опцию По умолчанию.

Кнопка Редактировать точки на Панели специального управления позволяет изменить конфигурацию линии-выноски (см. раздел 3.3.7.4.3).

Чтобы зафиксировать обозначение, нажмите кнопку Создать объект.

Рис. 2.9.24. Пример простановки обозначения маркировки


2.9.3.7. Обозначение позиции

Для обозначения позиции могут использоваться следующие объекты:

– грань тела или поверхности,

– ребро тела или поверхности.

Чтобы создать линию-выноску для обозначения позиции, вызовите команду Обозначение позиции.

Укажите объект, на который будет указывать первое ответвление линии-выноски. Начальной точкой первого ответвления будет точка, в которой был указан объект.

Задайте точку начала полки.

На экране появляется фантом обозначения. Он располагается в плоскости обозначения. При необходимости вы можете изменить положение плоскости обозначения (см. раздел 2.9.3.1.1).

В поле Текст на вкладке Знак Панели свойств отображается предлагаемая системой надпись — номер позиции. Если необходимо, вы можете изменить номер и его начертание, а также создать дополнительные полки с номерами позиций. Это делается так же, как при создании обозначения позиции в графическом документе (см. раздел 3.3.7.7.1).

Чтобы задать начальные точки дополнительных ответвлений, укажите точки, лежащие в плоскости обозначения. Подробно о добавлении и удалении ответвлений рассказано в разделе 2.9.3.1.2.

Кнопка Редактировать точки на Панели специального управления позволяет изменить конфигурацию линии-выноски (см. раздел 3.3.7.4.3).

Чтобы зафиксировать обозначение, нажмите кнопку Создать объект.

Пример простановки обозначения позиции


2.9.3.8. Допуск формы

Обозначение допуска формы и расположения может быть проставлено к следующим объектам:

– грань тела или поверхности,

– координатная плоскость,

– вспомогательная плоскость,

– ребро тела или поверхности,

– сегмент пространственной ломаной,

– вспомогательная ось,

– размер,

– обозначение.

Чтобы создать обозначение допуска формы и расположения поверхности, вызовите команду Допуск формы.

Укажите обозначаемый объект.

Укажите точку, определяющую положение рамки. По умолчанию в выбранную точку помещается левый нижний угол рамки. При этом в списке Базовая точка на Панели свойств выбран вариант Слева внизу. Чтобы изменить положение рамки относительно точки вставки, разверните указанный список и выберите нужную строку.

Чтобы рамка была расположена вертикально, включите опцию Вертикально на Панели свойств.

На экране отображается фантом рамки. Он располагается в плоскости обозначения. При необходимости вы можете изменить положение плоскости обозначения (см. раздел 2.9.3.1.1).

Если в качестве обозначаемого объекта выбран размер или условное обозначение, то обозначение допуска проставляется в плоскости этого объекта. Изменение положения плоскости обозначения невозможно.

Сформируйте таблицу допуска (см. раздел 3.3.7.13.1).

Чтобы создать ответвление со стрелкой или треугольником, нажмите соответствующую кнопку на Панели специального управления и укажите начальную точку ответвления в плоскости обозначения. Конечной точкой всех ответвлений является базовая точка (точка рамки, выбранная в списке Базовая точка).

Чтобы завершить формирование ответвления, отожмите соответствующую кнопку на Панели специального управления.

Подробно о добавлении и удалении ответвлений рассказано в разделе 2.9.3.1.2.

Для создания следующего ответвления снова нажмите нужную кнопку.

Кнопка Редактировать точки на Панели специального управления позволяет изменить конфигурацию ответвлений. После ее нажатия эти точки отображаются в виде черных квадратиков и кружков. Подведите курсор к любой характерной точке. Форма курсора изменится — он превратится в четырехстороннюю стрелку. Измените положение характерных точек, «перетаскивая» их мышью.

Для выхода из режима редактирования точек отожмите кнопку Редактировать точки.

Чтобы зафиксировать обозначение, нажмите кнопку Создать объект.

Рис. 2.9.25. Пример простановки допуска формы и расположения поверхности


2.9.4. Условное изображение резьбы

2.9. Размеры, обозначения, резьба (условное изображение)

2.9.4. Условное изображение резьбы

В моделях КОМПАС-3D резьба создается не как винтовая поверхность, а как условное изображение — каркасный цилиндр или конус. Чтобы построить в модели изображение резьбы, выполните следующие действия.

1. Вызовите команду Условное изображение резьбы.

На Панели свойств появляются элементы управления для задания параметров резьбы.

2. Укажите базовый объект резьбы — цилиндрическую или коническую грань.

По умолчанию создается метрическая резьба с крупным шагом. В окне модели появляется фантом условного изображения резьбы.

Начальная граница резьбы определяется автоматически при указании базового объекта. Если требуется сменить начальную границу, активизируйте переключатель Начальная граница, а затем укажите в окне модели или в Дереве построения поверхность, грань, ребро или плоский объект, от которого нужно построить резьбу.

3. Если необходимо, выберите другой стандарт резьбы, ее диаметр и шаг. Это делается так же, как при построении резьбового отверстия (см. п.п. 1 и 2 раздела 2.3.9.1.4).

Для нестандартной резьбы доступна опция Автоопределение диаметра резьбы. Включите опцию для автоматического определения диаметра по размерам объекта, указанного для построения резьбы. Автоматически рассчитанное значения диаметра отображается в поле Диаметр резьбы. Задайте значение шага резьбы.

4. Задайте длину резьбы. Для этого служит группа переключателей Длина резьбы. Доступны следующие способы:

– На заданную длину: длина резьбы определяется заданным расстоянием. Введите значение длины резьбы в поле Длина резьбы.

– До конечной границы: длина резьбы определяется автоматически по конечной границе резьбы.

Если требуется сменить автоматически определенную конечную границу резьбы, активизируйте переключатель Конечная граница и укажите нужную поверхность или ребро.

В качестве начальной/конечной границы резьбы должно быть указано ребро грани базового объекта резьбы или ребро соосной с ней конической (поверхность зенковки, фаски) или тороидальной (поверхность скругления) грани. Ребро, использование которого возможно, подсвечивается при наведении на него указателя мыши.

Включите опцию Подгонка, если нужно изменить геометрию базового объекта резьбы (см. раздел .2.9.4.1).

Опция Подгонка отсутствует на Панели свойств, если модель создана в КОМПАС-3D версии 14 SP1 или более ранней.

5. При необходимости используйте следующие дополнительные возможности.

– Копирование параметров существующей резьбы. Для этого вызовите команду Резьба по образцу нажатием соответствующей кнопки на Панели специального управления или из контекстного меню. Укажите в окне модели или в Дереве построения резьбу для копирования параметров. Создаваемое условное изображение резьбы получает те же параметры, что и резьба-образец. Отредактируйте параметры, если это требуется.

– Отмена выбора всех объектов. Для этого нажмите кнопку Указать заново на Панели специального управления.

6. Завершив настройку, нажмите кнопку Создать объект для фиксации условного изображения резьбы в модели.

В окне модели появится каркасный цилиндр или конус (рис. 2.9.26), изображающий резьбу, а в Дереве — пиктограмма резьбы. Рядом с условным изображением резьбы в Дереве указывается обозначение резьбы и надпись Условное изображение (для нестандартной резьбы используется надпись Условное изображение резьбы).

Если при построении условного изображения резьбы использовалась «подгонка», то ее пиктограмма отображается в Дереве модели как подчиненный объект условного изображения резьбы. Включить/отключить «подгонку» можно без входа в процесс редактирования резьбы — с помощью команды Подгонка в контекстном меню резьбы в Дереве модели.

Команда Подгонка недоступна в контекстном меню резьбы в Дереве модели, если:

– диаметр базового объекта резьбы соответствует номинальному диаметру резьбы,

– документ-модель создан в КОМПАС-3D версии 14 SP1 или более ранней.

Построение условного изображения стандартной конической резьбы имеет следующие особенности:

– Создание объекта возможно только при условии использования подгонки.

– Резьба может быть построена только на заданную глубину. При этом максимальная глубина зависит от выбранного номинального диаметра резьбы и определяется стандартом.

Рис. 2.9.26. Условное изображение резьбы в детали Ниппель

Обратите внимание на то, что условное изображение резьбы всегда показывается в модели полностью. Например, в результате выполнения команды Сечение поверхностью элемент, на котором построена резьба, оказался отсечен (или рассечен). При этом условное изображение резьбы отображается в модели целиком, несмотря на то что поверхность (или часть поверхности), на которой построена резьба, не видна.

При создании в чертежах ассоциативных видов моделей, содержащих условные изображения резьбы, эти изображения могут быть также построены в видах (см. раздел 3.7.1.3.3).

В этом разделе:

2.9.4.1. Использование подгонки


2.9.4.1. Использование подгонки

Подгонка используется в тех случаях, когда нужно изменить геометрию базового объекта резьбы согласно выбранному номинальному диаметру резьбы. При этом для цилиндрической поверхности под параметры резьбы «подгоняется» диаметр (рис. 2.9.27), а для конической поверхности «подгоняются» диаметр объекта в основной плоскости и угол конуса.

Включение и отключение подгонки производится опцией Подгонка на Панели свойств при создании или редактировании условного изображения резьбы.

Подгонка модифицирует только ту грань, которая была указана в качестве базовой для резьбы. Поэтому, если требуется создать резьбу с подгонкой на нескольких соосных поверхностях (например, отверстие в двух деталях), операцию следует выполнить для каждой поверхности отдельно.

Рис. 2.9.27. Пример построения резьбы в простом отверстии: а) без подгонки, б) с подгонкой
а) | б)

При подгонке отверстия с зенковкой (или фаской, или скруглением) меняется глубина зенковки. Чтобы «подогнать» глубину зенковки, активизируйте переключатель дополнительной подгонки Смещение 1. Это позволяет сместить начальную границу участка, на котором образуется резьба, в исходное положение и сохранить первоначальную глубину зенковки (рис. 2.9.28).

Рис. 2.9.28. Пример построения резьбы в отверстии с зенковкой: а) без подгонки, б) с подгонкой, Смещение 1 отключено (штриховой линией обозначена глубина зенковки до подгонки), в) с подгонкой, Смещение 1 включено
а) | б) | в)

При подгонке отверстия с неплоским торцем меняется длина участка поверхности, на котором создана резьба. Чтобы «подогнать» эту длину, активизируйте переключатель дополнительной подгонки Смещение 2. Это позволяет сместить конечную границу резьбы и сохранить ее первоначальную длину, см. рис. 2.9.29.

Рис. 2.9.29. Пример построения резьбы в отверстии с неплоским торцем: а) без подгонки, б) с подгонкой, Смещение 2 выключено (штриховой линией обозначена граница резьбы до подгонки), в) с подгонкой, Смещение 2 включено
а) | б) | в)

Для стержня с наружной резьбой, имеющего фаску или скругление у начальной/конечной границы резьбы, дополнительная подгонка выполняется аналогично отверстию.


2.10. Допуски. Пересчет модели с учетом допусков

В этом разделе:

2.10.1. Общие сведения

2.10.2. Допуски

2.10.2.1. Общие допуски

2.10.2.1.1. Файл отклонений

2.10.2.2. Назначение допуска

2.10.2.2.1. Вызов диалога назначения допуска

2.10.2.2.2. Особенности работы с размерами, значение которых задано вручную

2.10.3. Режим пересчета размеров модели

2.10.3.1. Системные и пользовательские пересчеты размеров

2.10.3.2. Управление пересчетом

2.10.3.2.1. Создание, редактирование и удаление пользовательского пересчета

2.10.3.2.2. Приемы работы с режимами пересчета в Менеджере документа

2.10.3.3. Включение режима пересчета размеров и работа в нем

2.10.3.3.1. Выбор текущего пересчета размеров

2.10.3.3.2. Создание копии пересчитанной модели


2.10.1. Общие сведения

2.10. Допуски. Пересчет модели с учетом допусков

2.10.1. Общие сведения

Все объекты модели создаются путем выполнения операций. Если числовые параметры операции выражаются в линейных или угловых величинах, то на значения этих параметров можно назначить допуски. Кроме того, допуски можно назначить на размеры эскизов. Подробнее о размерах эскизов и операций рассказано в разделе 2.9.2.2, о допусках и их назначении — в разделе 2.10.2.

При работе с моделью вы можете использовать режим пересчета размеров модели. Этот режим служит для пересчета размеров модели с учетом назначенных допусков. Расчет размеров модели производится согласно текущему пересчету.

КОМПАС-3D предоставляет три системных пересчета размеров: в середину поля допуска, по верхнему пределу и по нижнему пределу. Возможно также создание пользовательских пересчетов.

Подробнее о режиме пересчета размеров модели и работе в нем см. раздел 2.10.3.


2.10.2. Допуски

2.10. Допуски. Пересчет модели с учетом допусков

2.10.2. Допуски

КОМПАС-3D позволяет назначить допуски на размеры эскиза, а также на значения числовых параметров операции, для которых выполняются следующие условия:

– параметр выражен в линейных или угловых величинах;

– переменная параметра не является информационной (об информационных переменных см. раздел 7.1.1.2.1).

Возможно назначение общих и индивидуальных допусков.

Назначение допуска производится автоматически согласно настройке (см. раздел 9.2.7.2.10). Эта настройка определяет:

– объекты, размеры и параметры которых должны иметь допуск;

– значение индивидуального допуска для размеров разных типов: линейных, угловых, диаметральных, радиальных; размеры, для которых не задано значение индивидуального допуска, имеют общий допуск.

Условия использования в модели общего допуска и его настройка описаны в разделе 2.10.2.1.

При необходимости во время создания или редактирования объекта пользователь может вручную включить/отключить наличие допуска у размера (параметра), изменить значение индивидуального допуска, поменять общий допуск на индивидуальный и наоборот (см. раздел 2.10.2.2).

Индивидуальный допуск отображается в Окне переменных, а также в размерной надписи размера эскиза и размера, соответствующего параметру операции (о размерах эскизов и операций см. раздел 2.9.2.2; о допусках в Окне переменных см. раздел 7.1.4.2). Общие допуски отображаются только в Окне переменных.

Если модель требует перестроения, то в Окне переменных могут отображаться неверные предельные значения параметров или размеров, определяемые по общим допускам. Для правильного отображения этих значений перестройте модель.

На рисунке 2.10.1 приведен пример отображения индивидуальных допусков на размер эскиза и на размеры операции при создании элемента выдавливания.

Рис. 2.10.1. Отображение индивидуальных допусков при создании элемента выдавливания

Назначение допусков возможно только для параметров тех операций, которые созданы непосредственно в текущей модели (например, для значений параметров вырезанного элемента выдавливания, сопряжения и т.п.). Допуски на значения параметров операций, выполненных в компоненте, следует назначать при работе с ним.

Общие и индивидуальные допуски используются в режиме пересчета размеров модели. Подробнее о режиме см. раздел 2.10.3.

Индивидуальный допуск можно назначить на управляющие и информационные размеры эскиза (с переменной и без). Однако в режиме пересчета размеров модели используются только управляющие размеры эскиза, имеющие переменную.

В этом разделе:

2.10.2.1. Общие допуски

2.10.2.1.1. Файл отклонений

2.10.2.2. Назначение допуска

2.10.2.2.1. Вызов диалога назначения допуска

2.10.2.2.2. Особенности работы с размерами, значение которых задано вручную


2.10.2.1. Общие допуски

Общие допуски в КОМПАС-3D установлены по четырем классам точности согласно ГОСТ 30893.1-2002 (ИСО 2768-1-89).

Включение использования общих допусков и выбор нужного класса точности производится в диалоге настройки общих допусков (см. раздел 9.2.7.4.9). По умолчанию назначение общих допусков включено.

Общий допуск назначается автоматически на все размеры и параметры, которые могут иметь допуск, кроме следующих:

– размер или параметр с индивидуальным допуском либо признаком Номинальный (в рамке) (подробнее см. раздел 2.10.2.2),

– угловой параметр пространственной кривой, точки или вспомогательной плоскости,

– линейный размер или линейный параметр, абсолютное значение которого находится в диапазоне [0...0,5),

– угловой параметр, значение которого равно 0,

– угловой параметр операции вращения, значение которого равно 360.

Определение предельных отклонений значений параметров и размеров по общим допускам производится с помощью данных, содержащихся в файле отклонений (см. раздел 2.10.2.1.1).

Согласно стандарту, предельные отклонения параметров притупленных кромок отличаются от отклонений других линейных параметров при одинаковом диапазоне значений и классе точности. В КОМПАС-3D общие допуски для всех линейных параметров назначаются по одной таблице стандарта. Вы можете назначить на параметры притупленных кромок нужные индивидуальные допуски.

В этом разделе:

2.10.2.1.1. Файл отклонений


2.10.2.1.1. Файл отклонений

Предельные отклонения размеров и значений параметров по общим допускам извлекаются из файла отклонений. Имя и расположение этого файла определяется переменной GENERALTOLERANCE среды КОМПАС-3D (см. раздел 9.5.4). По умолчанию файл отклонений называется Gen_tol.ttl и находится в подпапке \Sys главной папки КОМПАС-3D. Если требуется, чтобы имя и/или расположение файла отклонений отличалось от умолчательного, используйте файл Kompas.ini (см. раздел 9.5.3).

Если файл отклонений отсутствует по пути, определенному переменной GENERALTOLERANCE или Kompas.ini, общие допуски на размеры эскизов и на значения параметров операций не назначаются.


2.10.2.2. Назначение допуска

Назначение или изменение допуска на размер эскиза или на значение параметра операции производится в диалоге Назначить допуск (рис. 2.10.2).

Рис. 2.10.2. Диалог назначения допуска: а) на линейную величину, б) на угловую величину
а) | б)

Элементы управления диалога описаны в таблице 3.3.5.

Для новых размеров и параметров операций:

– состояние опции Допуск (включена/отключена) и умолчательное значение допуска определяются настройкой допусков по умолчанию (см. раздел 9.2.7.2.10),

– состояние элементов управления Отклонения, Пределы, Отобразить определяется настройкой параметров допусков и предельных значений (см. раздел 9.2.7.2.9).

Диалог можно вызвать как в процессе выполнения операции, так и вне процесса. Подробнее о вызове диалога рассказано в разделе 2.10.2.2.1.

Основные действия, выполняемые в диалоге, приведены в таблице 2.10.1.

Табл. 2.10.1. Основные действия, выполняемые в диалоге Назначить допуск
Действие | Выполнение
Назначение индивидуального допуска | Заполните нужные поля диалога и нажмите кнопку ОК.
Назначение общего допуска | Очистите все поля диалога и нажмите кнопку ОК. Общий допуск назначается, если в диалоге настройки общих допусков включена опция Использовать общие допуски по ГОСТ 30893.1 (ISO2768-1) (см. раздел 9.2.7.4.9).
Отключение возможности назначения допуска (общего или индивидуального) | Отключите опцию Допуск и нажмите кнопку ОК.

Обратите внимание на следующие особенности работы в диалоге:

– Если для размера эскиза или параметра операции созданы переменные предельных отклонений (см. раздел 7.1.5.2) и ячейка Выражение Окна переменных заполнена хотя бы для одной из них, в диалоге недоступны следующие элементы управления: кнопка Квалитет, поле значения квалитета, опция, управляющая отображением квалитета, а также поля предельных отклонений/предельных значений размера.

– В диалоге можно изменить отображение размерной надписи размера операции, например, включить показ предельных значений размера вместо отклонений. При этом, если размер операции представлен в виде элемента оформления (т.е. создан соответствующий производный размер, см. раздел 2.9.2.8), то сделанные изменения передаются в производный размер и будут видны при последующем редактировании операции. В противном случае, т.е. если производного размера нет, измененное отображение размерной надписи сохраняется лишь до завершения операции. При последующем редактировании операции ее размер отображается согласно настройке параметров допусков и предельных значений (см. раздел 9.2.7.2.9).

В этом разделе:

2.10.2.2.1. Вызов диалога назначения допуска

2.10.2.2.2. Особенности работы с размерами, значение которых задано вручную


2.10.2.2.1. Вызов диалога назначения допуска

Диалог Назначить допуск (см. рис. 2.10.2) можно вызвать как в процессе выполнения операции, так и вне процесса.

В процессе выполнения операции диалог появляется на экране после нажатия кнопки Назначить допуск. Эта кнопка расположена на Панели свойств рядом с полем числового параметра операции.

Кнопка Назначить допуск присутствует на Панели свойств, если в диалоге настройки параметров отображения Панели свойств (см. раздел 9.1.3.6) включена опция Кнопки управления допусками.

Вне процесса выполнения операции диалог Назначить допуск можно вызвать из Окна переменных (см. раздел 7.1.4.2).

Также диалог назначения допуска можно вызвать при редактировании размеров эскизов и размеров, соответствующих параметрам операции, нажатием кнопки Назначить допуск в диалоге установки значения размера. Подробнее о задании значения размера см. раздел 2.9.2.2.1.


2.10.2.2.2. Особенности работы с размерами, значение которых задано вручную

В КОМПАС-3D возможно отключение автоматического определения значения размера и ввод произвольного числа в размерную надпись. Включением и отключением автоопределения значения размера управляет опция Авто в диалоге задания размерной надписи (см. рис. 3.3.4). Этот диалог можно вызвать при редактировании производного размера, соответствующего размеру эскиза или операции (см. раздел 2.9.2.9.1), а при работе в эскизе — непосредственно во время создания или редактирования размера.

Число, введенное вручную в размерную надпись, не становится значением переменной, соответствующей данному размеру. Переменная всегда имеет значение, равное автоопределенной или вычисленной (если для переменной задано выражение) величине. В связи с этим работа с размерами, чьи значения введены вручную, имеет следующие особенности.

В размерной надписи размера отображается значение, введенное вручную. Если допуск размера задан путем указания квалитета, то в размерной надписи отображаются отклонения или пределы, определенные по этому квалитету для введенного вручную номинала. Например, на рисунке 2.10.3 введенное вручную значение размера — 20, отклонения — ±0,26. В то же время в диалоге установки значения размера отображается «истинное» значение размера — значение его переменной, а в вызванном из этого диалога (кнопкой Назначить допуск) диалоге назначения допуска — «истинный» допуск. Так, «истинные» значение и отклонения размера 20 на рисунке 2.10.3 — 10 и ±0,18. Именно этот допуск будет использован при пересчетах данного размера. «Истинные» значение и допуск размера отображаются также в Окне переменных.

Рис. 2.10.3. Размер операции, значение которого введено вручную

Все вышесказанное относится к управляющему размеру. Если же размер информационный и, следовательно, не участвует в пересчете, то в диалоге установки значения, вызванном для этого размера, кнопка Назначить допуск запускает диалог задания размерной надписи (см. рис. 3.3.4), в котором можно отредактировать как значение размера, так и допуск.

Если в качестве значения размера введен текст, то автоматическое определение допуска по квалитету невозможно. При необходимости задайте отклонения вручную.


2.10.3. Режим пересчета размеров модели

2.10. Допуски. Пересчет модели с учетом допусков

2.10.3. Режим пересчета размеров модели

Режим пересчета размеров модели — специальный режим работы с трехмерной моделью КОМПАС-3D. Этот режим служит для пересчета размеров объектов и компонентов модели с учетом назначенных допусков (общих и индивидуальных, см. раздел 2.10.2). Расчет размеров модели производится согласно текущему пересчету.

КОМПАС-3D предоставляет три системных пересчета размеров: в середину поля допуска, по верхнему пределу и по нижнему пределу. Возможно также создание пользовательских пересчетов размеров. Подробнее о пересчетах размеров рассказано в разделе 2.10.3.1.

При включении режима пересчета происходит следующее:

– значения переменных, соответствующих размерам модели, на которые назначены допуски, изменяются согласно параметрам выбранного пересчета;

– пересчитанные значения переменных отображаются в Окне переменных в столбце Пересчитанное значение;

– в заголовок окна документа добавляется надпись «(Пересчет — <наименование выбранного пересчета>)»;

– модель перестраивается с новыми значениями переменных.

Например, для преобразования модели используется системный пересчет размеров по верхнему пределу. При включении режима все размеры, участвующие в пересчете, принимают наибольшие предельные значения. Модель перестраивается с учетом новых размеров.

Так как пересчет размеров модели с использованием допусков фактически является перестроением модели с новыми значениями переменных, следует иметь в виду, что:

– размеры, не влияющие на модель (информационные или не имеющие переменной), не изменяются, даже если у них есть допуск;

– для правильного перестроения модель должна быть корректно параметризована (например, эскиз должен быть полностью определен и т.п.).

В режиме пересчета на компоненты модели распространяются настройки общего допуска, выполненные и сохраненные в файлах компонентов. Если в каком-либо компоненте использование общего допуска отключено, то в режиме пересчета общие допуски к размерам такого компонента не применяются.

Управление пересчетом производится в Менеджере документа (см. раздел 2.10.3.2).

Для включения режима пересчета размеров модели нажмите кнопку Пересчитать размеры с учетом допусков на панели Режимы или вызовите одноименную команду из меню Сервис — Пересчет размеров.

Кнопка Пересчитать размеры с учетом допусков недоступна при редактировании компонента «на месте».

Меню кнопки Пересчитать размеры с учетом допусков содержит: перечень всех пересчетов размеров модели, команды Управление пересчетом... и Создать копию. При включенном режиме пересчета недоступны команды создания новых объектов и команды редактирования уже имеющихся объектов. Подробнее о работе в режиме рассказано в разделе 2.10.3.3.

С помощью команды Сохранить как... пересчитанную модель можно сохранить в другой формат.

Если модель, находящаяся в режиме пересчета, закрыта с сохранением, то при последующем открытии этой модели ее состояние будет таким же, как при закрытии — включен режим пересчета, размеры модели соответствуют текущему пересчету.

После выхода из режима пересчета модель возвращается в то состояние, в котором она была в момент включения режима.

В этом разделе:

2.10.3.1. Системные и пользовательские пересчеты размеров

2.10.3.2. Управление пересчетом

2.10.3.2.1. Создание, редактирование и удаление пользовательского пересчета

2.10.3.2.2. Приемы работы с режимами пересчета в Менеджере документа

2.10.3.3. Включение режима пересчета размеров и работа в нем

2.10.3.3.1. Выбор текущего пересчета размеров

2.10.3.3.2. Создание копии пересчитанной модели


2.10.3.1. Системные и пользовательские пересчеты размеров

Пересчет размеров — это совокупность следующих параметров:

– набор переменных, соответствующих размерам эскизов и операций (о размерах см. раздел 2.9.2.2);

– способ пересчета значения каждой переменной набора (см. табл. 2.10.2).

Системные пересчеты размеров модели:

– в середину поля допуска (используется по умолчанию),

– по верхнему пределу,

– по нижнему пределу.

Набор переменных для системного пересчета формируется автоматически. В него входят все переменные модели (включая переменные компонентов), соответствующие размерам эскизов и операций. Значения переменных этого набора пересчитываются одним способом.

Например, для перестроения модели используется пересчет размеров в середину поля допуска. При включении режима пересчета значения переменных, участвующих в пересчете, принимают значения, соответствующие середине поля допуска. Модель перестраивается с учетом новых значений переменных.

Пользователь может создавать собственные пересчеты размеров — пользовательские. Набор переменных пользовательского пересчета формируется вручную. Для каждой переменной этого набора назначается один из способов пересчета ее значения:

– в середину поля допуска,

– по верхнему пределу,

– по нижнему пределу,

– с коэффициентом.

О создании пользовательского пересчета, его редактировании и удалении рассказано в разделе 2.10.3.2.1.

Способы пересчета размеров модели и соответствующие способам формулы пересчета приведены в таблице 2.10.2. Буквами в формулах обозначены:

A — пересчитанное значение размера (эскиза или операции),

N — номинальное значение размера,

ES — верхнее отклонение,

EI — нижнее отклонение.

Табл. 2.10.2. Способы пересчета размеров модели
Способ пересчета размера | Формула пересчета размера, соответствующая способу пересчета
в середину поля допуска1 | A=N+(ES+EI)*0,5
по верхнему пределу | A=N+ES
по нижнему пределу | A=N+EI
с коэффициентом2 | A=N+EI+(ES-EI)*K, где 0<K<1
  1. В пользовательском пересчете используется по умолчанию.
  2. Используется только для переменных в пользовательских пересчетах. Для компонентов недоступен.

Если размер эскиза или операции является информационным, то значение переменной размера не пересчитывается (остается без изменения).


2.10.3.2. Управление пересчетом

Управление пересчетом размеров модели производится в Менеджере документа. Он позволяет выполнять следующие действия:

– создание, редактирование или удаление пользовательских пересчетов;

– выбор пересчета, согласно которому будет производиться расчет размеров модели (т.е. назначение того или иного пересчета текущим).

Создание, редактирование и удаление пользовательских пересчетов описаны в разделе 2.10.3.2.1, приемы работы с пересчетами — в разделе 2.10.3.2.2.

Чтобы перейти к управлению пересчетом размеров, вызовите команду Управление пересчетом.... Эта команда находится в меню кнопки Пересчитать размеры с учетом допусков на панели Режимы (см. рис. 2.10.6), а также в меню Сервис — Пересчет размеров. Команда доступна вне режима пересчета.

После вызова команды на экране появляется диалог Менеджер документа (рис. 2.10.4). В левой части диалога, в Дереве документа, выбран элемент Пересчет размеров и развернут список пересчетов. Список пересчетов содержит имена всех пересчетов размеров модели — системных и пользовательских (если они созданы). Перед названием системного пересчета отображается буква «с» в круглых скобках. Текущий пересчет отмечен красной «галочкой».

Рис. 2.10.4. Управление режимом пересчета в Менеджере документа

Правая часть диалога предназначена для работы с пересчетами. Ее содержимое зависит от того, какое действие выполняется в данный момент — управление пересчетами или настройка пользовательского пересчета.

– Для управления пересчетами выберите в Дереве документа элемент Пересчет размеров. В правой части диалога отображаются (рис. 2.10.4):

• панель, содержащая кнопки вызова команд для управления пересчетами,

• список пересчетов в виде таблицы из двух колонок: Статус и Имя.

– Для настройки пользовательского пересчета выберите его название в Дереве документа. В правой части диалога отображаются (рис. 2.10.5):

• панель, содержащая кнопки вызова команд для задания параметров пересчета,

• список пересчитываемых переменных в виде таблицы из четырех колонок:

- колонка Имя содержит имена переменных и/или компонентов,

- колонка Параметр содержит имена параметров операций, размеры которых требуется пересчитать (для компонентов — пуста),

- колонка Способ пересчета предназначена для выбора способа пересчета значения переменной; каждая ячейка колонки содержит раскрывающийся список способов пересчета: в середину поля допуска, по верхнему пределу, по нижнему пределу, с коэффициентом (см. таблицу 2.10.2); для компонента в списке присутствуют пользовательские пересчеты, если они созданы в файле компонента; пересчет с коэффициентом для компонентов не используется,

- колонка Коэффициент служит для задания коэффициента; значение коэффициента может изменяться в пределах от 0 до 1 (0<К<1).

Параметры системного пересчета не отображаются в диалоге Менеджер документа.

Рис. 2.10.5. Отображение параметров пользовательского пересчета:
а) набор включает в себя только переменные размеров эскизов и операций;
б) набор включает в себя только компоненты
в) набор включает в себя переменные размеров эскизов и операций и компоненты

а)

б)

в)

Переменные, компоненты и способы пересчета в компонентах, входящие в пользовательский пересчет, при дальнейшем редактировании модели или компонентов могут быть удалены. В этом случае ячейки, соответствующие перечисленным объектам, в колонке Имя выделяются красным цветом, в колонке Параметр — очищаются.

В этом разделе:

2.10.3.2.1. Создание, редактирование и удаление пользовательского пересчета

2.10.3.2.2. Приемы работы с режимами пересчета в Менеджере документа


2.10.3.2.1. Создание, редактирование и удаление пользовательского пересчета

Для создания, редактирования или удаления пользовательского пересчета вызовите команду Управление пересчетом... из меню кнопки Пересчитать размеры с учетом допусков на панели Режимы. На экране появляется диалог Менеджер документа (см. рис. 2.10.4).

В появившемся диалоге выполните необходимые действия (см. ниже).

Чтобы закрыть диалог Менеджер документа, нажмите кнопку ОК.

Подтверждение каждого изменения в диалоге Менеджер документа не требуется, т.к. изменение сохраняется в модели сразу после выполнения.

Создание пользовательского пересчета

Чтобы создать пользовательский пересчет размеров модели, выполните следующие действия.

1. Выделите в левой части диалога Менеджер документа элемент Пересчет размеров.

2. Нажмите кнопку Создать на инструментальной панели диалога Менеджер документа.
В список пересчетов добавляется новый пересчет с умолчательным именем. При необходимости вы можете изменить имя пересчета.

3. Укажите созданный пересчет в списке пересчетов в левой части диалога.

4. Сформируйте набор переменных и/или компонентов нового пересчета.

– Для добавления переменных используйте один из следующих способов.

• Укажите в Дереве построения или окне модели производные размеры, соответствующие нужным размерам эскизов и операций (производные размеры должны быть созданы заранее, см. раздел 2.9.2.8).

• Добавьте в набор нужные переменные модели с помощью кнопок Читать переменные или Вставить переменную, расположенных на инструментальной панели диалога Менеджер документа (подробнее см. раздел 2.10.3.2.2).

– Для добавления компонента укажите его в Дереве построения или в окне модели. Обратите внимание на то, что в пересчете размеров участвуют компоненты первого уровня, причем целиком, т.е. выборочное указание объектов или переменных компонента невозможно.

В списке переменных нового пересчета появляются строки, соответствующие переменным и/или компонентам набора.

5. Задайте способ пересчета для каждой переменной и компонента. Для этого в каждой ячейке колонки Способ из раскрывающегося списка выберите нужный способ пересчета: в середину поля допуска, по верхнему пределу, по нижнему пределу, с коэффициентом (о способах пересчета размеров см. таблицу 2.10.2). При использовании способа с коэффициентом введите значение коэффициента от 0 до 1 в соответствующую ячейку колонки Коэффициент.

Обратите внимание на особенности настройки пересчета компонентов:

– способ пересчета с коэффициентом недоступен,

– при выборе способа в середину поля допуска, по верхнему пределу или по нижнему пределу все переменные компонента пересчитываются согласно этому способу,

– для выбора доступны пользовательские пересчеты, созданные в файле компонента.

Для перемещения между ячейками можно использовать клавиши со стрелками.

Вы можете создать новый пользовательский пересчет с параметрами уже существующего системного или пользовательского пересчета-образца. Для создания пользовательского пересчета, аналогичного существующему, служит кнопка По образцу на инструментальной панели диалога Менеджер документа (подробнее см. раздел 2.10.3.2.2).

Редактирование пользовательского пересчета

Редактирование пользовательского пересчета практически аналогично его созданию. Чтобы начать редактирование, откройте диалог Менеджер документа, выполнив действия описанные выше.

Удаление пользовательского пересчета

Если наличие пользовательского пересчета в модели больше не требуется, его можно удалить. Для этого выполните следующие действия.

1. Откройте диалог Менеджер документа, выполнив действия описанные выше.

2. В списке пересчетов выберите нужный пересчет.

3. На инструментальной панели диалога нажмите кнопку Удалить пересчет или вызовите команду из контекстного меню пересчета.

Выделенный пересчет удаляется из списка пересчетов.


2.10.3.2.2. Приемы работы с режимами пересчета в Менеджере документа

При описании приемов работы с режимами пересчета предполагается, что диалог Менеджер документа открыт и в его левой части, в Дереве документа, выбран элемент Пересчет размеров.

Создание пользовательского пересчета

Нажмите кнопку Создать на инструментальной панели диалога Менеджер документа или вызовите команду из контекстного меню любого пересчета. В список пересчетов добавляется новый пересчет.

Создание пользовательского пересчета с параметрами уже существующего пересчета

Выделите пересчет-образец в списке и нажмите кнопку По образцу или вызовите команду из контекстного меню. В список добавляется новый пересчет, имеющий параметры пересчета-образца.

Если в качестве пересчета-образца выбран один из системных пересчетов, то в пользовательский пересчет будут входить все переменные текущей модели, соответствующие размерам эскизов и операций. Способ пересчета значения каждой переменной в данном пересчете будет соответствовать выбранному системному пересчету.

При необходимости вы можете изменить параметры пересчета, созданного по образцу.

Выбор текущего пересчета

Выделите нужный пересчет в списке и нажмите кнопку Назначить текущим или вызовите команду из контекстного меню. В списке пересчетов на пиктограмме появляется «галочка». Это означает, что данный пересчет является текущим (т.е. согласно этому пересчету будет производиться расчет размеров модели).

Сделать пересчет текущим можно другим способом. В списке пересчетов активизируйте нужную строку двойным щелчком мыши.

Переименование пользовательского пересчета

В правой части диалога щелчком мыши активизируйте нужную ячейку колонки Имя и введите в нее новое имя пересчета. Для перемещения между ячейками можно использовать клавиши со стрелками.

Пересчет можно переименовать и в Дереве документа. Для этого одним щелчком мыши выделите название пересчета, вторым щелчком сделайте его доступным для редактирования, затем введите новое имя.

Системные пересчеты переименовать нельзя.

Удаление пользовательского пересчета

Выделите в списке нужный пользовательский пересчет и нажмите кнопку Удалить или вызовите команду из контекстного меню.

Обратите внимание на то, что системные пересчеты удалить нельзя.

Добавление переменных модели, соответствующих размерам эскизов и операций, в пользовательский пересчет

Выделите в Дереве документа нужный пользовательский пересчет и нажмите кнопку Читать переменные. Все переменные размеров и параметров операций модели, участвующие в пересчете ее размеров, добавятся в список переменных справа.

Обратите внимание на то, что переменные размеров и параметров операций, имеющие статус «информационные», в список переменных не добавляются (об информационных переменных см. раздел 7.1.1.2.1).

Добавление определенной переменной модели в пользовательский пересчет

Выделите в Дереве документа нужный пользовательский пересчет и нажмите кнопку Вставить переменную. На экране появляется диалог Переменные, позволяющий выбрать переменную из списка переменных текущего документа. Укажите нужную переменную и нажмите кнопку ОК. Выбранная переменная добавится в выделенный пересчет.

Добавление компонентов в пользовательский пересчет

Выделите в Дереве документа нужный пользовательский пересчет. Укажите добавляемый компонент щелчком мыши в Дереве построения или в окне модели. Строка с именем компонента добавится в выделенный пересчет.

Удаление переменных и компонентов из пользовательского пересчета

Выделите в Дереве документа нужный пользовательский пересчет. Затем в правой части диалога выделите нужные строки или любые ячейки этих строк и нажмите кнопку Удалить строки.

Удаление строки означает исключение переменной или компонента, соответствующего этой строке, из пользовательского пересчета. Переменная или компонент в модели остается без изменений.

Выбор способа пересчета значения переменной

Выделите в Дереве документа нужный пользовательский пересчет. Затем в правой части диалога в колонке Способ пересчета активизируйте ячейку переменной, для которой требуется назначить способ пересчета. Из раскрывающегося списка этой ячейки выберите нужный способ пересчета (о способах пересчета размеров см. таблицу 2.10.2) или нажмите на инструментальной панели кнопку, соответствующую нужному способу пересчета:

– В середину поля допуска,

– По верхнему пределу,

– По нижнему пределу,

– С коэффициентом.


2.10.3.3. Включение режима пересчета размеров и работа в нем

Для включения режима пересчета размеров модели нажмите кнопку Пересчитать размеры с учетом допусков на панели Режимы или вызовите одноименную команду из меню Сервис — Пересчет размеров.

Кнопка Пересчитать размеры с учетом допусков недоступна при редактировании компонента «на месте».

Меню кнопки Пересчитать размеры с учетом допусков содержит перечень всех пересчетов размеров модели и команды Управление пересчетом... и Создать копию.

Данное меню вызывается щелчком мыши по треугольнику, расположенному рядом с кнопкой.

Рис. 2.10.6. Меню кнопки Пересчитать размеры с учетом допусков

Все команды меню кнопки Пересчитать размеры с учетом допусков, кроме пользовательских пересчетов, можно также вызвать из меню Сервис — Пересчет размеров.

При включенном режиме пересчета недоступны команды создания новых объектов и команды редактирования уже имеющихся объектов. Возможны только следующие действия:

– просмотр и печать модели (о печати см. раздел 8.1);

– измерение геометрических (без создания объектов «изменения») и массо-центровочных характеристик модели (см. раздел 2.15.2);

– создание отчетов (см. раздел 5.2).

Кроме того, в режиме пересчета вы можете:

– сменить текущий пересчет (см. раздел 2.10.3.3.1);

– создать копию пересчитанной модели (см. раздел 2.10.3.3.2).

Чтобы выйти из режима пересчета размеров, отожмите кнопку Пересчитать размеры с учетом допусков или щелкните мышью по значку режима пересчета в окне документа.

В этом разделе:

2.10.3.3.1. Выбор текущего пересчета размеров

2.10.3.3.2. Создание копии пересчитанной модели


2.10.3.3.1. Выбор текущего пересчета размеров

2.10. Допуски. Пересчет модели с учетом допусков > 2.10.3. Режим пересчета размеров модели > 2.10.3.3. Включение режима пересчета размеров и работа в нем

2.10.3.3.1. Выбор текущего пересчета размеров

Текущий пересчет — пересчет, согласно которому производится расчет размеров модели в режиме пересчета.

Текущий пересчет отмечен «галочкой» в меню кнопки Пересчитать размеры с учетом допусков на панели Режимы (рис. 2.10.6).

Чтобы выбрать текущий пересчет размеров, выполните следующие действия.

1. Раскройте список пересчетов. Для этого щелкните мышью по треугольнику справа от кнопки Пересчитать размеры с учетом допусков.

2. Выберите из списка нужный пересчет.

Рядом с именем выбранного пересчета появляется «галочка».

Выбор текущего пересчета из меню кнопки Пересчитать размеры с учетом допусков доступен как в режиме пересчета размеров, так и вне его. Вне режима пересчета текущий пересчет можно выбрать также Менеджере документа (см. раздел 2.10.3.2.2).


2.10.3.3.2. Создание копии пересчитанной модели

2.10. Допуски. Пересчет модели с учетом допусков > 2.10.3. Режим пересчета размеров модели > 2.10.3.3. Включение режима пересчета размеров и работа в нем

2.10.3.3.2. Создание копии пересчитанной модели

Работая в режиме пересчета размеров модели, вы можете сохранить вариант текущей модели, номинальными размерами которой являются размеры, пересчитанные согласно текущему пересчету. Меняя пересчет, можно создать несколько вариантов модели с разными размерами — от наименьших до наибольших предельных размеров.

Для сохранения модели с пересчитанными значениями размеров служит команда Создать копию. Она находится в меню кнопки Пересчитать размеры с учетом допусков на панели Режимы (рис. 2.10.6), а также в меню Сервис — Пересчет размеров.

Команда Создать копию доступна только в режиме пересчета размеров.

После вызова команды Создать копию на экране появляется диалог сохранения файла. Укажите в нем имя файла и папку для сохранения, а затем нажмите кнопку Сохранить.

При создании копии происходит следующее:

– объекты, созданные непосредственно в модели, принимают пересчитанные значения размеров,

– для компонентов модели изменяется способ пересчета, с которым они вставлены (см. раздел 2.16.2.1); файлы компонентов на диске не изменяются.

Копия пересчитанной модели ничем не отличается от модели, построенной «с нуля», т.е. в дальнейшем вы можете работать с ней обычным образом.

Команда Файл — Сохранить как, в отличие от команды Создать копию, сохраняет модель без изменения номинальных размеров.


2.11. Компоненты

В этом разделе:

2.11.1. Общие сведения о компонентах

2.11.2. Добавление компонентов. Основные способы

2.11.2.1. Добавление компонента из файла

2.11.2.1.1. Добавление детали/подсборки из файла

2.11.2.1.2. Добавление локальной детали из файла

2.11.2.1.3. Добавление детали-заготовки

2.11.2.2. Создание компонента «на месте»

2.11.2.2.1. Создание детали «на месте»

2.11.2.2.2. Создание подсборки «на месте»

2.11.2.2.3. Создание локальной детали «на месте»

2.11.2.3. Преобразование объектов

2.11.2.3.1. Преобразование объектов в деталь

2.11.2.3.2. Преобразование объектов в локальную деталь

2.11.2.4. Добавление стандартного изделия

2.11.2.5. Параметры положения и вставки компонента

2.11.2.5.1. Выбор файла компонента

2.11.2.5.2. Задание параметров положения компонента

2.11.2.5.3. Элемент базирования компонента

2.11.3. Добавление зеркальных и симметричных компонентов

2.11.3.1. Базовые принципы

2.11.3.2. Отображение компонента в Дереве построения

2.11.3.3. Порядок создания компонента отражением

2.11.3.4. Параметры отражения

2.11.3.4.1. Выбор результата зеркального отражения компонента

2.11.3.4.2. Настройка положения компонента при симметричном размещении

2.11.3.5. Автоматическое наложение сопряжений

2.11.4. Перемещения и повороты компонентов

2.11.4.1. Сдвиг компонента

2.11.4.2. Поворот компонента

2.11.4.3. Дополнительные возможности перемещения компонента

2.11.4.3.1. Автоматическое наложение сопряжений в процессе перемещения

2.11.4.3.2. Контроль соударений

2.11.4.4. Фиксация компонентов

2.11.5. Сопряжение компонентов

2.11.5.1. Общие сведения о сопряжениях

2.11.5.1.1. Принципы наложения сопряжений

2.11.5.1.2. Взаимодействие сопряжений

2.11.5.1.3. Отображение сопряжений в Дереве построения модели

2.11.5.2. Позиционирующие сопряжения

2.11.5.2.1. Общие приемы создания позиционирующих сопряжений

2.11.5.2.2. Совпадение

2.11.5.2.3. Соосность

2.11.5.2.4. Параллельность

2.11.5.2.5. Перпендикулярность

2.11.5.2.6. Расположение объектов на заданном расстоянии

2.11.5.2.7. Расположение объектов под углом друг к другу

2.11.5.2.8. Касание

2.11.5.2.9. Симметрия

2.11.5.2.10. Зависимое положение

2.11.5.3. Сопряжения механической связи

2.11.5.3.1. Обеспечение корректной работы сопряжений механической связи

2.11.5.3.2. Общие приемы создания сопряжений механической связи

2.11.5.3.3. Сопряжение Вращение – вращение

2.11.5.3.4. Сопряжение Вращение – перемещение

2.11.5.3.5. Сопряжение Кулачок – толкатель

2.11.5.3.6. Просмотр работы сопряжений

2.11.6. Булевы операции над деталями

2.11.6.1. Вычитание

2.11.6.2. Объединение

2.11.7. Редактирование компонентов

2.11.7.1. Редактирование геометрии компонента в окне

2.11.7.1.1. Сохранение компонента под другим именем

2.11.7.2. Редактирование геометрии компонента «на месте»

2.11.7.2.1. Работа в режиме контекстного редактирования

2.11.7.3. Изменение положения компонента

2.11.7.4. Изменение свойств компонента

2.11.7.4.1. Изменение источника компонента

2.11.7.5. Особенности работы с локальной деталью и деталью-заготовкой без истории


2.11.1. Общие сведения о компонентах

2.11. Компоненты

2.11.1. Общие сведения о компонентах

Компонент — часть модели, представленная другой моделью. Компонентами модели могут быть детали, сборки, детали-заготовки и локальные детали, а в сборках также стандартные изделия и модели, вставленные из приложений.

Модель компонента может храниться в отдельном файле или в файле текущей модели.

В отдельных файлах хранятся следующие компоненты:

– детали,

– сборки,

– детали-заготовки с историей,

– стандартные изделия,

– модели, вставленные из приложений.

В данном случае в текущей модели фактически содержатся не сами компоненты, а ссылки на их файлы. Поэтому для передачи такой модели на другое рабочее место вместе с ней необходимо передавать и файлы компонентов.

В файле текущей модели хранятся следующие компоненты:

– локальные детали,

– детали-заготовки без истории.

Эти компоненты не имеют самостоятельного файлового представления. Они хранятся непосредственно в содержащей их модели. Использование локальных деталей и деталей-заготовок, вставленных без истории, позволяет создать файл сборочной модели, все детали которой хранятся внутри этого же файла.

Для добавления компонентов в модель используются следующие способы:

– вставка компонента из файла (см. раздел 2.11.2.1),

– построение компонента в контексте текущей модели (см. раздел 2.11.2.2),

– добавление компонента зеркальным отражением или симметричной вставкой (см. раздел 2.11.3),

– преобразование объектов текущей модели в деталь/локальную деталь (см. раздел 2.11.2.3).

Компоненты могут быть связаны сопряжениями друг с другом или с другими объектами модели. Доступно два вида сопряжений: позиционирующие и механические. Позиционирующие сопряжения ограничивают взаиморасположение объектов (например, устанавливают соосность стержня и отверстия), а сопряжения механической связи задают закон перемещения объектов друг относительно друга (например, поступательное перемещение гайки при вращении винта). Создание сопряжений описано в разделе 2.11.5.

Одна и та же модель может быть вставлена в качестве компонента в несколько других моделей, и наоборот, модель может содержать несколько вставок одного и того же компонента.

В модели, содержащей компоненты, можно выполнить операции, имитирующие обработку изделия в сборе. Обычно это операции удаления материала, например, можно построить отверстие, проходящее через несколько компонентов. Обратите внимание на то, что результат такой операции не передается в файлы компонентов, а хранится в содержащей их модели. Если открыть файлы компонентов, то будет видно, что отверстий в них нет. Благодаря этому один и тот же компонент можно вставлять в разные модели и выполнять в них разные операции — это не приведет к изменению файла компонента на диске.

Если требуется, чтобы изменения компонента отразились во всех содержащих его моделях, необходимо открыть и отредактировать файл этого компонента. Редактирование компонента возможно как «на месте», т.е. в окне содержащей его модели (см. раздел 2.11.7.2), так и в отдельном окне (см. раздел 2.11.7.1). Для компонентов, хранящихся в текущей модели, доступно только редактирование «на месте».

При необходимости вы можете изменить положение компонента в модели и параметры его вставки (см. раздел 2.11.7.3).

Если компоненты являются деталями, то над ними можно производить булевы операции вычитания и объединения (см. раздел 2.11.6).

По умолчанию вставленные в модель компоненты сохраняют собственные, т.е. записанные в их файлах, массо-центровочные характеристики и свойства (обозначение, наименование и т.п.). При необходимости вы можете задать для компонента отличные от его собственных МЦХ (см. раздел 2.14.6.3) и свойства (см. раздел 5.1.4.1.2). Эти данные не передаются в файл компонента, а хранятся в содержащей его модели.


2.11.2. Добавление компонентов. Основные способы

2.11. Компоненты

2.11.2. Добавление компонентов. Основные способы

Команды добавления компонентов расположены в меню Операции, а кнопки для их вызова — на панели Редактирование сборки.

Если модель должна содержать несколько одинаковых компонентов, то после вставки первого из них его можно скопировать нужное количество раз (см. раздел 2.14.4.6). Если нужно, чтобы копии компонента располагались определенным образом (например, вдоль некоторой кривой или образовывали сетку с заданными параметрами), целесообразнее воспользоваться командами создания массивов (см. раздел 2.7). Кроме того, вы можете создать компонент, являющийся зеркальным отражением исходного или его симметричной вставкой (см. раздел 2.11.3).

В этом разделе:

2.11.2.1. Добавление компонента из файла

2.11.2.1.1. Добавление детали/подсборки из файла

2.11.2.1.2. Добавление локальной детали из файла

2.11.2.1.3. Добавление детали-заготовки

2.11.2.2. Создание компонента «на месте»

2.11.2.2.1. Создание детали «на месте»

2.11.2.2.2. Создание подсборки «на месте»

2.11.2.2.3. Создание локальной детали «на месте»

2.11.2.3. Преобразование объектов

2.11.2.3.1. Преобразование объектов в деталь

2.11.2.3.2. Преобразование объектов в локальную деталь

2.11.2.4. Добавление стандартного изделия

2.11.2.5. Параметры положения и вставки компонента

2.11.2.5.1. Выбор файла компонента

2.11.2.5.2. Задание параметров положения компонента

2.11.2.5.3. Элемент базирования компонента


2.11.2.1. Добавление компонента из файла

В модель в качестве компонента может быть вставлена другая модель (деталь или сборка), существующая в файле на диске.

Модель из файла может быть источником следующих компонентов:

– деталь,

– подсборка,

– локальная деталь,

– деталь-заготовка.

Положение компонента в модели указывается при его вставке. Для этого используются следующие способы:

– По координатам,

– По сопряжениям.

При размещении компонента способом По координатам может быть включено автосоздание (см. раздел 1.4.2.10). В этом случае операция вставки компонента автоматически завершается после задания положения его точки вставки.

Если положение компонента задано способом По координатам, и этот компонент — первый в текущей модели, то он автоматически фиксируется. Подробнее о фиксации см. раздел 2.11.4.4.

Если вставленный компонент является исполнением модели, вы можете заменить его другим исполнением данной модели. Для этого из контекстного меню компонента в Дереве построения вызовите команду Текущее исполнение и укажите нужное исполнение в появившемся списке исполнений модели. Выбрать другое исполнение компонента можно также в окне Свойства, см. раздел 2.14.3.6.1.

После замены компонента перестройте модель (подробнее о перестроении см. раздел 2.14.3.7).

При дальнейшей работе вы можете изменить положение вставленного компонента в модели, отредактировать его параметры (см. раздел 2.11.7.3).

В этом разделе:

2.11.2.1.1. Добавление детали/подсборки из файла

2.11.2.1.2. Добавление локальной детали из файла

2.11.2.1.3. Добавление детали-заготовки


2.11.2.1.1. Добавление детали/подсборки из файла

Чтобы добавить в качестве компонента деталь или подсборку, существующую в файле на диске, выполните следующие действия.

1. Вызовите команду Операции — Добавить из файла — Компонент... или нажмите кнопку Добавить из файла на панели Редактирование сборки.

2. В появившемся на экране диалоге открытия файлов выберите файл, содержащий нужную модель (см. раздел 2.11.2.5.1).

В окне текущей модели появится фантом выбранной модели, а на Панели свойств — вкладки Размещение и Свойства.

3. На вкладке Размещение задайте параметры расположения компонента в модели (см. раздел 2.11.2.5.2).

4. На вкладке Свойства настройте цвет и оптические свойства компонента (используемые для этого элементы управления описаны в разделе 2.14.2, включите/отключите создание объекта спецификации.

На этой вкладке вы также можете выбрать новые значения внешних переменных модели, если вставляемый компонент содержит таблицу переменных. Для этого требуется нажать кнопку Таблица переменных и выбрать нужную строку в появившейся на экране таблице.

5. Для завершения вставки компонента нажмите кнопку Создать объект на Панели специального управления.

В Дереве построения модели появится пиктограмма, соответствующая типу компонента (деталь или сборка), а рядом с пиктограммой — наименование компонента, взятое из его файла.


2.11.2.1.2. Добавление локальной детали из файла

В качестве локальной детали может быть вставлена деталь или сборка, существующая в файле на диске.

Выбранная для вставки модель может сама содержать локальные детали. В этом случае обратите внимание на следующие особенности.

• Если выбранная модель является сборкой, то в виде локальной детали может быть вставлена как вся сборка, так и одна из ее локальных деталей.

• Если выбранная модель является деталью, то в виде локальной детали может быть вставлена только вся эта деталь. Выбор содержащихся в ней локальных деталей невозможен.

Чтобы добавить в модель локальную деталь, выполните следующие действия.

1. Вызовите команду Операции — Добавить из файла — Локальную деталь... или нажмите кнопку Добавить локальную деталь из файла на панели Редактирование сборки.

2. В появившемся на экране диалоге открытия файлов выберите файл, содержащий нужную модель (см. раздел 2.11.2.5.1).

Если выбранная модель является сборкой, которая в свою очередь содержит локальные детали, то на экране появится диалог Выберите локальную деталь.

Чтобы в виде локальной детали была вставлена одна из локальных деталей, имеющихся в сборке, укажите ее в данном диалоге и нажмите кнопку ОК.

Чтобы в виде локальной детали была вставлена вся сборка, в данном диалоге нажмите кнопку Отмена.

После выбора модели — источника вставки в окне текущей модели появится фантом локальной детали, а на Панели свойств — вкладки Размещение и Свойства.

3. На вкладке Размещение задайте параметры расположения локальной детали в модели (см. раздел 2.11.2.5.2).

4. На вкладке Свойства настройте цвет и оптические свойства компонента (используемые для этого элементы управления описаны в разделе 2.14.2), включите/отключите создание объекта спецификации.

На этой вкладке вы также можете выбрать новые значения внешних переменных локальной детали, если модель — источник вставки содержит таблицу переменных. Для этого требуется нажать кнопку Таблица переменных и выбрать нужную строку в появившейся на экране таблице.

5. Для завершения вставки локальной детали нажмите кнопку Создать объект на Панели специального управления.

Локальная деталь будет вставлена в текущую модель.

В Дереве построения модели появится пиктограмма локальной детали, а рядом с пиктограммой — наименование локальной детали, взятое из файла-источника.

Локальная деталь хранится в файле той модели, в которую она вставлена.


2.11.2.1.3. Добавление детали-заготовки

Удобный прием моделирования изделий, которые отличаются лишь некоторыми конструктивными элементами, — использование ранее созданной модели (детали или сборки) в качестве заготовки.

Модель, которую планируется использовать, должна быть записана на диск в файл с любым именем.

Чтобы вставить в качестве заготовки готовую модель, выполните следующие действия.

1. Вызовите команду Операции — Деталь-заготовка… или нажмите кнопку Деталь-заготовка на панели Редактирование модели.

2. В появившемся на экране диалоге открытия файлов выберите файл, содержащий нужную модель (см. раздел 2.11.2.5.1).

В окне текущей модели появится фантом выбранной модели, а на Панели свойств — вкладки Размещение и Свойства.

3. На вкладке Размещение выполните следующие действия.

• Задайте параметры расположения заготовки в модели (см. раздел 2.11.2.5.2).

• Выберите способ вставки заготовки. Для этого активизируйте соответствующий переключатель в группе Способ вставки.
При активном переключателе Вставка внешней ссылкой сохраняется связь заготовки с файлом-источником. Заготовка не копируется в модель, а существует в ней в виде ссылки на свой файл. Если в дальнейшем файл-источник будет отредактирован, изменения автоматически передадутся в модель, использующую данную заготовку (для передачи изменений требуется перестроение модели, см. раздел 2.14.3.7).
Если активным является переключатель Вставка без истории, то связь заготовки с файлом-источником не сохраняется. Редактирование файла-источника не влияет на деталь-заготовку, вставленную данным способом.

4. На вкладке Свойства настройте цвет и оптические свойства заготовки. Используемые для этого элементы управления описаны в разделе 2.14.2.

На этой вкладке вы также можете выбрать новые значения внешних переменных заготовки, если модель — источник вставки содержит таблицу переменных. Для этого требуется нажать кнопку Таблица переменных и выбрать нужную строку в появившейся на экране таблице.

5. Для завершения вставки заготовки нажмите кнопку Создать объект.

Деталь-заготовка будет вставлена в текущую модель. В Дереве построения модели появится пиктограмма, соответствующая способу вставки заготовки:

– заготовка, вставленная внешней ссылкой,

– заготовка без истории.

Рядом с пиктограммой появится наименование заготовки, взятое из файла-источника.

Если положение детали-заготовки задано способом По координатам, она автоматически фиксируется.


2.11.2.2. Создание компонента «на месте»

При формировании сборочной модели в КОМПАС-3D вы можете не только добавлять в нее готовые компоненты с диска, но и создавать их, не выходя из текущего файла, т.е. строить детали и подсборки в контексте текущей модели. При этом в окне будут видны все остальные компоненты. Они недоступны для редактирования, но их элементы (грани, ребра, вершины, эскизы и др.) могут использоваться в операциях создания новых компонентов.

Компонент (деталь, подсборка, локальная деталь), созданный в контексте текущей модели, связывается с этой моделью сопряжением Совпадение (см. раздел 2.11.5.2.2). Сопряжение накладывается на абсолютную систему координат компонента и текущую систему координат модели. Пиктограмма сопряжения появляется в группе сопряжений Дерева построения. При необходимости вы можете отредактировать или удалить автоматически созданное сопряжение.

При дальнейшей работе вы также можете изменить положение созданного компонента в модели, отредактировать его параметры (см. раздел 2.11.7.3).

При создании в модели компонента требуется задать имя файла этого компонента и выбрать папку для его сохранения. Если файл с таким именем уже существует в выбранной папке и этот файл открыт, то перезапись файла невозможна. Необходимо изменить имя файла или выбрать другую папку для его сохранения. Если, кроме того, модель из данного файла является компонентом одной из открытых моделей, то при попытке перезаписи процесс создания компонента прерывается.

В этом разделе:

2.11.2.2.1. Создание детали «на месте»

2.11.2.2.2. Создание подсборки «на месте»

2.11.2.2.3. Создание локальной детали «на месте»


2.11.2.2.1. Создание детали «на месте»

Чтобы начать построение детали непосредственно в текущей модели, вызовите команду Операции — Создать — Деталь или нажмите кнопку Создать деталь на панели Редактирование сборки.

В появившемся на экране диалоге сохранения файлов укажите папку и имя файла для записи новой детали и нажмите кнопку Сохранить.

В Дереве построения модели появится пиктограмма, обозначающая новую деталь. Система автоматически перейдет в режим контекстного редактирования этой детали — об этом говорит желтый цвет пиктограммы. Работа в данном режиме описана в разделе 2.11.7.2.1.

Закончив построение детали, отожмите кнопку Редактировать на месте на панели Текущее состояние, или вызовите из контекстного меню команду Редактировать на месте, или щелкните мышью по значку режима контекстного редактирования в окне модели. Система вернется в режим работы с основной моделью, пиктограмма детали в Дереве построения станет синей.

Если первый элемент создаваемой детали планируется строить на основе эскиза, и плоский объект для его размещения уже есть в модели, укажите этот объект перед вызовом команды создания детали. В этом случае после сохранения файла детали и включения режима контекстного редактирования происходит автоматический переход в режим редактирования эскиза, располагающегося в указанной плоскости. Выполните необходимые построения и выйдите из режима эскиза.


2.11.2.2.2. Создание подсборки «на месте»

Чтобы начать построение подсборки непосредственно в текущей модели, вызовите команду Операции — Создать — Сборку или нажмите кнопку Создать сборку на панели Редактирование сборки.

В появившемся на экране диалоге сохранения файлов укажите папку и имя файла для записи новой сборки и нажмите кнопку Сохранить.

В Дереве построения модели появится пиктограмма, обозначающая новую подсборку. Система автоматически перейдет в режим построения подсборки в контексте содержащей ее модели — об этом говорит желтый цвет пиктограммы. Работа в данном режиме описана в разделе 2.11.7.2.1.

Завершив создание подсборки, отожмите кнопку Редактировать на месте на панели Текущее состояние, или вызовите из контекстного меню команду Редактировать на месте, или щелкните мышью по значку режима контекстного редактирования в окне модели. Система вернется в режим работы с основной моделью, пиктограмма подсборки станет синей.


2.11.2.2.3. Создание локальной детали «на месте»

Чтобы начать построение локальной детали непосредственно в текущей модели, вызовите команду Операции — Создать — Локальную деталь или нажмите кнопку Создать локальную деталь на панели Редактирование сборки.

Создание локальной детали «на месте» выполняется аналогично созданию детали «на месте» (см. раздел 2.11.2.2.1) с единственным отличием: ввод имени файла детали не требуется, так как локальная деталь хранится в той же модели, где создается.


2.11.2.3. Преобразование объектов

Объекты, имеющиеся в модели, могут быть преобразованы в деталь. При работе со сборкой можно также преобразовать объекты в локальную деталь.

Преобразование возможно только для объектов, построенных непосредственно в текущей модели и относящихся к следующим типам:

– тела,

– поверхности,

– пространственные кривые и точки,

– локальные системы координат,

– вспомогательные плоскости,

– вспомогательные оси.

При необходимости вы можете преобразовать объекты, построенные в компоненте, в деталь. Для этого необходимо войти в режим редактирования этого компонента.

Подробно преобразование объектов в деталь и локальную деталь описано в разделах 2.11.2.3.1 и 2.11.2.3.2.

Преобразование объектов в деталь или локальную деталь нельзя отменить. Также после преобразования становится невозможной отмена операций, выполненных в модели до преобразования.

В этом разделе:

2.11.2.3.1. Преобразование объектов в деталь

2.11.2.3.2. Преобразование объектов в локальную деталь


2.11.2.3.1. Преобразование объектов в деталь

Преобразование объектов в деталь — это сохранение объектов, построенных в модели (детали или сборке), в файл новой детали (*.m3d). Если преобразование выполняется в сборке, полученная деталь вставляется в нее в виде компонента.

При работе с деталью объекты, выбранные для преобразования, передаются в новую деталь и сохраняются в исходной в неизменном виде.

При работе со сборкой объекты, выбранные для преобразования, могут быть удалены из сборки в процессе преобразования.

Преобразование объектов в деталь выполняется с помощью команды Редактор — Создать деталь.

Вы можете выбрать нужные объекты как до, так и после вызова команды. Объекты для преобразования указываются в Дереве построения или в окне модели (для указания тела или поверхности в окне модели вы можете выделить любую его грань, ребро или вершину).

Если вы выбрали объект в Дереве построения, то команду Создать деталь можно вызвать из контекстного меню.

После вызова команды на Панели свойств появляются элементы управления преобразованием. Для задания параметров преобразования выполните следующие действия.

1. Задайте обозначение создаваемой детали. Для этого щелкните мышью в поле Обозначение и выполните необходимые действия в появившемся диалоге. Порядок работы в диалоге описан в разделе 2.13.2.1.1.

2. В поле Наименование введите наименование создаваемой детали.

3. Сформируйте набор преобразуемых объектов с помощью панели Список объектов. Объекты, выбранные до вызова команды, уже содержатся в списке. Чтобы добавить объект в список, укажите его в Дереве построения или в Окне модели. Повторное указание объекта удалит его из списка. Можно также удалить объект, выделив его в списке и нажав кнопку Удалить из списка.

В список могут быть добавлены только объекты, типы которых перечислены в разделе 2.11.2.3.

4. С помощью группы переключателей Способ выберите способ записи объектов в файл детали. По умолчанию в этой группе активен переключатель Сохранение с историей. Это означает, что в новую деталь будут переданы сами объекты, эскизы, использованные при их построении, и данные об остальных исходных объектах. Тип данных зависит от типа текущей модели:

– если преобразование выполняется в детали, то в новой детали создаются копии геометрии исходных объектов (о копии геометрических объектов см. раздел 2.8.7),

– если преобразование выполняется в сборке, то в новой детали формируются ссылки на файл сборки, аналогичные тем, которые формируются в файле компонента во время его редактирования «на месте», если при этом используются объекты других компонентов сборки.

Булева операция над телами корректно передается в деталь только в том случае, если оба тела, участвующие в этой операции, принадлежат текущей модели, а не ее компонентам.

Деталь, которая получена из тела, образованного операцией Придать толщину, содержит ошибку «Невозможно выполнить операцию». Если эта операция не образует, а модифицирует тело, то результат преобразования корректен.

Кроме исходных объектов при сохранении с историей в деталь передаются все выражения, заданные для вычисления параметров элементов преобразуемых объектов, а также все переменные главного раздела.

Положение объектов при передаче в деталь сохраняется, т.е. переданные объекты будут расположены в системе координат детали так же, как они расположены в системе координат исходной модели.

Если в деталь нужно передать только сами объекты, без исходных объектов и переменных, активизируйте переключатель Сохранение без истории в группе Способ. При этом становится доступной опция Зеркально. Включите эту опцию, если требуется, чтобы переданные в новую деталь объекты были расположены симметрично своему исходному положению относительно одной из координатных плоскостей. Нужная плоскость выбирается из списка Плоскость симметрии, который становится доступным после включения опции.

5. При работе со сборкой вы можете выполнить дополнительные действия.

– Включите опцию Компоновочная геометрия, если требуется, чтобы новая деталь была добавлена в сборку не в виде компонента, а в виде компоновочной геометрии.

– Включите опцию Удалять оригинал, если после преобразования объекты должны быть удалены из сборки. Обратите внимание на то, что удаляются только объекты, выбранные для преобразования. Их исходные объекты остаются без изменения.

Если объект, преобразованный в деталь, участвовал в сопряжениях, то в случае удаления оригинала в этих сопряжениях участвует новая деталь, а в случае сохранения оригинала сопряжения не изменяются.

6. Задав все параметры преобразования, нажмите кнопку Создать объект на Панели специального управления. На экране появится стандартный диалог сохранения файла. Укажите в нем папку и имя файла детали для записи, а затем нажмите кнопку Сохранить. Выбранные объекты будут записаны в указанный файл.


2.11.2.3.2. Преобразование объектов в локальную деталь

Преобразование объектов в локальную деталь возможно только при работе со сборкой.

Объекты, построенные в текущей сборке, преобразуются в локальную деталь этой же сборки. Созданная локальная деталь автоматически добавляется в список компонентов текущей сборки.

Преобразование объектов в локальную деталь выполняется с помощью команды Редактор — Создать локальную деталь.

Преобразование объектов в локальную деталь аналогично преобразованию объектов в деталь (см. раздел 2.11.2.3.1). Отличие состоит в том, что в результате преобразования объектов в локальную деталь не создается отдельный файл детали (*.m3d). Локальная деталь хранится в файле той сборки, в которой создается.


2.11.2.4. Добавление стандартного изделия

Если в изделии используются стандартные изделия (болты, гайки, винты и т.д.), вам не требуется моделировать их как уникальные детали. Модели стандартных изделий могут быть вставлены из Справочника Стандартные Изделия.

Если Справочник Стандартные Изделия установлен на вашем рабочем месте, то в меню Библиотеки присутствует пункт Стандартные изделия. Он содержит подменю команд доступа к функциям справочника.

Чтобы вставить в модель стандартное изделие, вызовите команду Библиотеки — Стандартные изделия — Вставка — Вставить элемент. В появившемся диалоге двойным щелчком мыши выберите нужное стандартное изделие, задайте его параметры и нажмите кнопку Применить. Укажите в окне модели точку вставки изделия или объекты для сопряжения, после чего нажмите на Панели специального управления кнопку Создать объект.

Вставленное изделие появится в окне модели, а его пиктограмма — в Дереве построения.

Для получения более подробной информации о возможностях Справочника Стандартные Изделия обратитесь к его документации.

Основные приемы работы со стандартным изделием — сдвиг и поворот, наложение сопряжений, задание свойств, управление доступом и другие — такие же, как при работе с уникальным компонентом (деталью, подсборкой).


2.11.2.5. Параметры положения и вставки компонента

В этом разделе:

2.11.2.5.1. Выбор файла компонента

2.11.2.5.2. Задание параметров положения компонента

2.11.2.5.3. Элемент базирования компонента


2.11.2.5.1. Выбор файла компонента

После вызова одной из команд вставки компонента в модель на экране появляется диалог выбора файла — источника вставки.

Укажите в диалоге файл нужной модели.

Если эта модель содержит исполнения, то геометрия и свойства компонента будут соответствовать одному из этих исполнений. Перечень всех исполнений, имеющихся в модели, содержится в списке Исполнение диалога выбора файла. Укажите нужное исполнение в списке.

Если в выбранной модели созданы дополнительные номера исполнений, то диалог также содержит список Дополнительный номер. По умолчанию в списке активизирован вариант, при котором ни один дополнительный номер не выбран (пустая строка списка). При необходимости выберите строку с нужным номером.

Для завершения выбора модели нажмите кнопку Открыть.


2.11.2.5.2. Задание параметров положения компонента

Параметры, определяющие положение компонента, задаются на вкладке Размещение Панели свойств.

Порядок настройки параметров зависит от способа размещения компонента По координатам или По сопряжениям. Нужный способ выбирается с помощью группы переключателей Способ размещения.

Набор элементов и порядок задания положения компонента для каждого способа приведены ниже.

Способ размещения По координатам

Элементы управления, отображаемые на вкладке Размещение при выборе способа По координатам, показаны на рис. 2.11.1.

Рис. 2.11.1. Способ По координатам

Для настройки положения компонента данным способом выполните следующие действия.

1. Задайте положение точки вставки компонента — точки, с которой совпадает начало текущей системы координат компонента.

Доступны следующие варианты задания положения.

– Ручное указание в окне модели. Точку вставки компонента можно указать произвольно или используя привязку (например, к началу координат или к вершине). Для выполнения привязки подведите курсор к нужному объекту и, когда рядом с ним появится значок этого объекта, щелкните левой кнопкой мыши.

Привязку к началу текущей системы координат можно выполнить с помощью клавиатуры. Для этого нажмите комбинацию клавиш <Ctrl>+<0>, а затем — клавишу <Enter>.

– Ввод координат в поле Опорная точка.

– Построение точки. Для этого нажмите кнопку Построение точки на Панели специального управления. Запустится процесс построения точки (см. раздел 2.5.2.11.1). Выберите способ построения и задайте необходимые параметры. Эти параметры будут определять положение точки вставки компонента. Обратите внимание на то, что в данном случае процесс построения точки используется только для определения положения точки вставки. Новая точка при этом не создается.

Положение точки вставки фиксируется с помощью опции, расположенной рядом с полем Опорная точка. Включенному состоянию опции (т.е. зафиксированному положению точки вставки) соответствует значок «крестик», а отключенному — значок «галочка».

Опция включается автоматически в следующих случаях:

– после ручного указания точки вставки в окне модели описанными выше способами,

– после ввода всех трех координат в поле Опорная точка,

– после завершения процесса создания точки.

При необходимости вы можете включить/отключить опцию вручную.

Редактирование координат в поле Опорная точка и создание точки командой Построение точки доступны при любом состоянии опции.

Ручное указание точки вставки доступно при отключенной опции. Если опция включена, вы можете только переместить компонент мышью за начало его системы координат.

2. Задайте ориентацию осей системы координат компонента с помощью направляющих объектов или углов Эйлера.

Чтобы выбрать ось, направление которой требуется задать, в группе Направление осей активизируйте нужный переключатель:

– Направляющий объект оси Х,

– Направляющий объект оси Y,

– Направляющий объект оси Z.

На Панели свойств появится поле отображения направляющего объекта и кнопка, позволяющая сменить направление выбранной оси на противоположное. Кнопка соответствует выбранной оси:

– Перевернуть ось Х,

– Перевернуть ось Y,

– Перевернуть ось Z.

Укажите направляющий объект в окне модели. Название этого объекта появляется в поле Направляющий объект оси. Ось ассоциативно связывается с этим объектом.

При необходимости измените направление оси с помощью одной из описанных выше кнопок.

Направление можно задать только для двух осей системы координат. Третья ось автоматически располагается так, чтобы образовывать с двумя другими правую тройку векторов.

После того как для первой оси выбран направляющий объект, система координат компонента поворачивается так, чтобы эта ось совпала с направлением, которое задает объект.

Направляющий объект для второй оси может иметь направление, не перпендикулярное первой оси. В этом случае направление второй оси определяется как проекция направления, которое задает объект, на плоскость, перпендикулярную первой оси.

Объект не может использоваться в качестве направляющего для второй оси, если он параллелен первой оси или лежит на одной прямой с ней.

Для задания ориентации осей можно использовать поле Углы Эйлера. В это поле вводятся углы нутации, прецессии и вращения. В случае выбора направляющих объектов углы рассчитываются автоматически, их значения появляются в поле. Вы можете изменить значения углов. При этом произведенный ранее выбор направляющих объектов отменяется.

Положением компонента в модели можно управлять с помощью элемента базирования (см. раздел 2.11.2.5.3).

3. Положением компонента в модели можно управлять с помощью систем координат.

Первоначально компонент размещается в модели следующим образом:

– начало текущей системы координат компонента совпадает с точкой вставки,

– оси текущей системы координат компонента сонаправлены осям текущей системы координат модели,

– координаты точки вставки компонента и углы Эйлера определяются относительно текущей системы координат модели.

Вы можете изменить положение компонента в модели, указав другую систему координат компонента или текущей модели. Для этого используются соответствующие списки. Доступность списков определяется наличием локальных систем координат в компоненте/текущей модели.

Система координат компонента выбирается из списка СК компонента. Она совмещается с точкой вставки, при этом компонент изменяет свое положение.

Для выбора системы координат текущей модели используется список СК текущего документа. Если СК выбирается при отключенной опции Сохранять положение, то координаты точки вставки остаются неизменными, но откладываются в выбранной системе координат. В результате изменяется положение компонента в модели. Если опция Сохранять положение включена, то выбор СК модели не изменяет положение компонента в ней. Изменяются координаты точки вставки компонента и углы Эйлера (их значения определяются относительно выбранной системы координат).

При необходимости в процессе размещения компонента можно изменить положение его системы координат. Для этого нажмите кнопку Изменить положение СК компонента на Панели специального управления. Запустится процесс создания ЛСК (см. разделы 2.8.3.6 и 2.8.3.7). Задайте параметры ЛСК и нажмите кнопку Создать объект. Система вернется в процесс размещения компонента. В списке СК компонента появится строка Измененная. Обратите внимание на то, что в данном случае процесс создания ЛСК используется только для определения положения СК компонента. Новая ЛСК при этом не создается.

При задании нового положения СК обратите внимание на следующую особенность. Если при настройке системы в диалоге ЛСК (см. раздел 9.1.11.9) включена опция Создавать ЛСК только в абсолютной СК, то положение СК определяется относительно абсолютной СК компонента, в противном случае — относительно текущей.

Изменение положения СК и выбор другой СК используются только в текущем процессе размещения компонента. Эти данные не сохраняются в системе.

Способ размещения По сопряжениям

Элементы управления, отображаемые на вкладке Размещение при выборе способа По сопряжениям, показаны на рис. 2.11.2.

Рис. 2.11.2. Способ По сопряжениям

Кроме того, при выборе данного способа в окне модели отображается Окно модели-источника. Это окно такое же, как при копировании объектов из внешнего файла (см. раздел 2.8.7.1.1).

При вставке модели из приложения окно модели-источника не отображается.

Для настройки положения компонента способом По сопряжениям выполните следующие действия.

1. Укажите сопрягаемые объекты текущей модели и компонента в Дереве построения или в окне модели (объект компонента может быть указан в Окне модели-источника). Наименования объектов появятся в полях Объект сборки и Объект компонента соответственно.

Если требуется отменить выбор объекта, укажите его повторно. Кнопка Указать заново позволяет отменить выбор всех объектов.

2. Выберите тип позиционирующего сопряжения, активизировав соответствующий переключатель в группе Выбор сопряжения (доступность переключателей зависит от того, какие объекты выбраны для сопряжения). Запустится процесс создания сопряжения данного типа. Приемы создания позиционирующих сопряжений различных типов приведены в разделе 2.11.5.2.

Вы можете указать сопрягаемые объекты, находясь в процессе создания сопряжения.

После завершения создания сопряжения система вернется в исходный процесс. Созданное сопряжение отобразится на панели Сопряжения. Данная панель содержит список сопряжений и элементы управления списком.

Аналогично создайте все нужные сопряжения.

Вы можете включать сопряжения в расчет и исключать их из расчета, включая и отключая опции, соответствующие им в списке.

Чтобы изменить параметры сопряжения, выделите его в списке и нажмите кнопку Редактировать. Запустится процесс редактирования сопряжения. Внесите необходимые изменения и нажмите кнопку Создать объект на Панели специального управления.

Чтобы удалить сопряжение, выделите его в списке и нажмите кнопку Удалить.


2.11.2.5.3. Элемент базирования компонента

Положение компонента в модели можно изменить, используя специальный инструмент — элемент базирования.

Элемент базирования совпадает с текущей системой координат компонента. Элемент состоит из трех объемных стрелок красного, зеленого и синего цветов, показывающих положительные направления осей X, Y, Z этой системы координат. В плоскостях, перпендикулярных стрелкам, отображаются дуги соответствующего цвета. Например, стрелка элемента, совпадающая с осью Х, имеет красный цвет. Дуга, лежащая в плоскости, перпендикулярной этой стрелке, также красного цвета. Центральная точка элемента обозначается сферой. Вид элемента базирования приведен на рис. 2.11.3.

Рис. 2.11.3. Элемент базирования

Для активизации элемента базирования выберите его стрелку или дугу. Выбор стрелки возможен, когда рядом с курсором отображается значок, обозначающий ось. Значок поворота рядом с курсором показывает, что возможен выбор дуги.

Размер элемента базирования можно изменить. Для этого наведите на него курсор, нажмите комбинацию клавиш <Alt> + <Ctrl> + <Shift> и, не отпуская ее, вращайте колесо мыши. Полученный размер элемента базирования сохраняется в системе.

Изменение положения компонента в модели производится путем перемещения и/или поворота элемента базирования.

– Перемещение элемента базирования

• Вдоль оси на произвольное расстояние.
Подведите курсор к стрелке, совпадающей с нужной осью, нажмите левую кнопку мыши и, не отпуская ее, перемещайте мышь вдоль выбранной оси в нужном направлении. Когда элемент базирования займет требуемое положение, отпустите кнопку.

• Вдоль оси на заданное расстояние.
Щелкните мышью по стрелке, совпадающей с нужной осью. На экране появится поле для ввода расстояния. Введите нужное значение и нажмите клавишу <Enter>. Элемент базирования переместится на заданное расстояние вдоль выбранной оси.

• В произвольном направлении.
Подведите курсор к сфере в центре элемента, нажмите левую кнопку мыши и, не отпуская ее, перемещайте мышь в нужном направлении. Когда элемент базирования займет требуемое положение, отпустите кнопку.

– Поворот элемента базирования

• Вокруг оси на произвольный угол.
Подведите курсор к дуге, лежащей в плоскости, перпендикулярной нужной оси. Нажмите левую кнопку и, не отпуская ее, поворачивайте систему координат вокруг выбранной оси в нужном направлении. Когда элемент базирования займет требуемое положение, отпустите кнопку.

• Вокруг оси на заданный угол.
Щелкните мышью по дуге, лежащей в плоскости, перпендикулярной нужной оси. На экране появится поле для ввода значения угла поворота. Введите нужное значение и нажмите клавишу <Enter>. Элемент базирования повернется на заданный угол вокруг выбранной оси.

• Вокруг оси с заданным шагом.
Нажмите клавишу <Ctrl> и, не отпуская ее, щелкните мышью по дуге, лежащей в плоскости, перпендикулярной нужной оси. Элемент базирования повернется на величину заданного шага.
Если требуется повернуть элемент базирования на заданный шаг в противоположную сторону, щелкните по дуге, удерживая комбинацию клавиш <Ctrl> + <Shift>.

Шаг угла задается при настройке параметров (см. раздел 9.1.11.5). По умолчанию он равен 15°.

• Поворот оси на 180°.
Щелкните мышью по стрелке, совпадающей с нужной осью, удерживая нажатой клавишу <Ctrl> или комбинацию клавиш <Ctrl> + <Shift>. Ось повернется на 180° вокруг одной из двух других осей элемента базирования.

При нажатой клавише <Ctrl>:

- ось Х вокруг оси Z,

- ось Y вокруг оси Х,

- ось Z вокруг оси Y.

При нажатой комбинации клавиш <Ctrl> + <Shift>:

- ось Х вокруг оси Y,

- ось Y вокруг оси Z,

- ось Z вокруг оси Х.


2.11.3. Добавление зеркальных и симметричных компонентов

2.11. Компоненты

2.11.3. Добавление зеркальных и симметричных компонентов

В ходе проектирования изделия с симметричными элементами может потребоваться создать объекты, которые являются зеркальным отражением или симметричной вставкой уже смоделированной части изделия. КОМПАС-3D позволяет получать такие объекты отражением имеющихся.

Рис. 2.11.4. Модель, содержащая зеркально отраженный компонент

Симметрия представляет собой свойство геометрического объекта, которое заключается в том, что при некоторых преобразованиях одна часть геометрического объекта совпадает с другой его частью.

Геометрический объект симметричен относительно плоскости, если для каждой точки геометрического объекта существует симметричная относительно плоскости другая точка этого объекта. Геометрический объект может обладать и несколькими плоскостями симметрии.

Если геометрический объект совмещается сам с собой при повороте на любой угол вокруг некоторой оси, то такой объект называется осесимметричным. Простейшей пространственной фигурой, обладающей осью симметрии, является цилиндр.

Геометрический объект обладает центром симметрии, если любая прямая, проходящая через некоторую точку этого объекта, является осью симметрии. Иными словами, геометрический объект можно повернуть на любой угол относительно любой прямой, проходящей через центр симметрии. Такой симметрией обладает сфера.

Для создания зеркальных и симметричных компонентов используется команда Зеркальное отражение компонентов. Она позволяет создать компоненты, зеркальные и/или симметричные исходным. При этом не учитываются операции над компонентами, произведенные в содержащей их сборочной модели, т.е. полученные компоненты являются отражением моделей, имеющихся в файлах-источниках исходных компонентов.

Смоделированная часть изделия может содержать компоненты, обладающие и не обладающие симметрией, а также компоненты, симметрия которых частично нарушается наличием выступов, впадин, фасок и т.п. В зависимости от наличия симметрии компоненты разделяют на:

– симметричные,

– несимметричные,

– условно симметричные.

При выборе способов получения компонентов симметричной части изделия учитывается наличие симметрии у исходных компонентов, а также требования по оптимизации состава изделия.

Базовые принципы добавления компонентов различными способами подробно описаны в разделе 2.11.3.1.

Для сохранения положения добавляемого компонента относительно исходного и указанной плоскости симметрии в процессе отражения выполняется автоматическое наложение сопряжений (см. раздел 2.11.3.5).

В этом разделе:

2.11.3.1. Базовые принципы

2.11.3.2. Отображение компонента в Дереве построения

2.11.3.3. Порядок создания компонента отражением

2.11.3.4. Параметры отражения

2.11.3.4.1. Выбор результата зеркального отражения компонента

2.11.3.4.2. Настройка положения компонента при симметричном размещении

2.11.3.5. Автоматическое наложение сопряжений


2.11.3.1. Базовые принципы

В процессе проектирования изделия, симметричного относительно некоторой плоскости, целесообразно создать компоненты, расположенные с одной стороны от плоскости симметрии, а компоненты, расположенные с другой стороны, получить их отражением. В КОМПАС-3D вы можете создать:

– зеркально отраженные компоненты, которые являются новыми моделями (исполнениями моделей),

– дополнительные вставки исходных компонентов, расположенные зеркально или симметрично.

Принципы зеркального и симметричного расположения компонентов подробно описаны ниже.

В качестве исходного компонента для отражения может быть выбран любой компонент модели. При выборе подсборки отраженные компоненты создаются для всех компонентов, входящих в нее.

Добавленный компонент может быть таким же, как исходный (только отраженный зеркально), или иметь отличия по сравнению с ним. Например, вам может потребоваться добавить в полученный компонент ряд конструктивных элементов (бобышки, фаски, отверстия и т.п.) или изменить свойства компонента (материал, покрытие и т.п.).

В зависимости от задач проектирования, а также от наличия у исходного компонента симметрии, вы можете использовать различные способы добавления компонента в модель. Для компонентов, не обладающих симметрией, как правило, применяется создание зеркально отраженных компонентов, для компонентов с внутренней симметрией целесообразно использовать вставку исходного компонента в зеркальном виде, а для условно симметричных компонентов — симметричную вставку исходного компонента, размещенную с учетом плоскости/центра симметрии компонента. Описание данных способов приведено ниже.

Несимметричный компонент

Если исходный компонент не обладает симметрией, как правило, выполняется зеркальное отражение исходного компонента относительно указанной плоскости симметрии (рис. 2.11.5). Исключение составляют случаи, когда несимметричный компонент можно считать условно симметричным, т.е. несимметричность формы компонента не влияет на его размещение и работу в требуемом положении.

В результате отражения создается компонент, зеркальный исходному. Он имеет левостороннюю СК (см. раздел 2.8.3.1.1).

Рис. 2.11.5. Зеркальное отражение несимметричного компонента

Полученный компонент может быть новой отдельной моделью или зеркальным исполнением модели. Выбор одного из этих вариантов зависит от особенностей исходных компонентов и проектируемого изделия.

– Зеркальный компонент, созданный как зеркальное исполнение модели, сохраняет ассоциативную связь с исходным. Работа с таким компонентом аналогична работе с зависимым исполнением модели. Особенности зеркальных исполнений описаны в разделе 2.13.4.
Этот вариант предпочтителен для компонента, который должен иметь ассоциативную связь с исходным, но может в той или иной степени отличаться от него, т.е. допускает внесение изменений.

– Зеркальный компонент, созданный как отдельная модель, не имеет ассоциативной связи с исходным. В дальнейшем вы можете работать с этим компонентом так же, как с любым другим компонентом, вставленным в модель из файла. При выполнении построений в данном компоненте необходимо учитывать особенности левосторонней СК.
Данный вариант используется, если компонент должен значительно отличаться от исходного, а также в том случае, если файл исходного компонента недоступен.

Симметричный компонент

Если исходный компонент обладает симметрией, то в модель, как правило, добавляется зеркально отраженная вставка этого компонента относительно указанной плоскости симметрии (рис. 2.11.6). Полученный зеркальный компонент, по сути, является тем же самым исходным компонентом, только отображаемым в зеркально отраженном виде. Все изменения, произведенные в файле-источнике модели исходного компонента, применяются к зеркально отраженным вставкам так же, как и к обычным вставкам этого компонента.

Данный вариант позволяет размещать отраженные вставки компонентов без дополнительных настроек размещения. Например, вы можете использовать этот вариант для добавления в модель симметрично расположенных вставок большинства стандартных изделий.

Рис. 2.11.6. Зеркальная вставка компонента, обладающего симметрией

Условно симметричный компонент

Симметрия компонента может быть принята условно. Если исходный компонент является условно симметричным, то в модель, как правило, добавляется симметричная вставка этого компонента относительно указанной плоскости симметрии (рис. 2.11.7). Положение вставки рассчитывается с учетом плоскости/центра условной симметрии исходного компонента, т.е. плоского или точечного объекта, относительно которого условно симметричны части компонента.

Рис. 2.11.7. Симметричная вставка компонента,
обладающего условной симметрией

Выбор плоскости/центра условной симметрии может выполняться автоматически или вручную. Вы можете выбрать один из вариантов, автоматически предлагаемых системой. Если данные варианты не удовлетворяют условиям проектирования, или требуется дополнительное уточнение положения компонента, используйте ручной способ указания плоскости/центра условной симметрии компонента.

В некоторых случаях может возникнуть необходимость выполнить симметричную вставку нескольких компонентов одного уровня, представляющих собой симметричную или условно симметричную конструкцию, но не объединенных в сборочную единицу. Например, необходимо добавить симметричную вставку детали с устанавливаемыми при сборке стандартными компонентами типа болтов, масленок и т.п. В этом случае настройка положения выполняется для самой детали, а положение остальных компонентов определяется относительно данной детали, которая выбирается в качестве базового компонента. Сам базовый компонент и все компоненты, для которых он является базовым, перемещаются и поворачиваются относительно исходных компонентов как одно целое.

При симметричном размещении (независимо от варианта задания положения) добавленный компонент является вставкой исходного. Новая модель при этом не создается. СК вставки повернута или смещена относительно СК исходного компонента.


2.11.3.2. Отображение компонента в Дереве построения

Компоненты, добавленные в модель зеркальным отражением или симметричной вставкой, отображаются в Дереве построения в разделе Компоненты.

Они имеют пиктограммы, аналогичные пиктограммам компонентов того же типа (деталь, сборка и др.). Если компонент является зеркальным исполнением исходного, то его пиктограмма отображается в зеркальном виде (рис. 2.11.8).

На пиктограммах компонентов могут появляться значки аналогично другим объектам в Дереве.

Рис. 2.11.8. Отображение зеркально отраженных компонентов в Дереве построения

Названия компонентов формируются автоматически в соответствии с настройкой (см. раздел 9.1.11.11). При необходимости название компонента в Дереве можно изменить обычными способами.

Иерархическое расположение в Дереве построения компонентов, полученных зеркальным отражением или симметричной вставкой, аналогично расположению компонентов, полученных другими способами.

Если добавленный компонент является зеркальным исполнением или зеркальной/симметричной вставкой исходного компонента, то в Дереве построения в разделе Компоненты (или в группе, если включена группировка) формируется отдельная ветвь, которая включает исходный компонент и компонент, полученный в результате отражения. Аналогичные ветви получаются при копировании компонентов или создании массива компонентов, см. рис. 2.1.4).

Подробнее об отображении объектов в Дереве построения рассказано в разделе 2.1.2.5.

Компоненты, полученные зеркальным отражением, имеют левостороннюю СК. Особенности отображения СК в Дереве построения модели приведены в разделе 2.8.3.1.1.

Так как отражение компонентов является одним из способов добавления компонентов в модель, в Дереве построения появляются только сами добавленные компоненты, операция отражения в Дереве не создается.


2.11.3.3. Порядок создания компонента отражением

Чтобы добавить зеркально отраженный компонент или симметричную вставку компонента, выполните следующие действия.

1. Вызовите команду Операции — Зеркальное отражение компонентов или нажмите кнопку Зеркальное отражение компонентов на панели Редактирование сборки. На Панели свойств появятся элементы управления (рис. 2.11.9).

Рис. 2.11.9. Панель свойств при зеркальном отражении компонентов

2. Выберите плоскость симметрии, указав плоский объект — плоскую грань, координатную или вспомогательную плоскость. Плоская грань может быть указана только в окне модели, а остальные объекты — как в окне модели, так и в Дереве построения. Выбранная плоскость симметрии подсвечивается.

3. Выберите исходные компоненты. Для этого укажите компоненты или принадлежащие им объекты в Дереве построения или в окне модели. Выбранные компоненты выделяются цветом, их перечень отображается на панели Список объектов. В окне модели появляются фантомы добавляемых компонентов.

Если исходный компонент в свою очередь содержит компоненты, то построение выполняется для всех этих компонентов, однако на панели Список объектов отображается только сам исходный компонент.

Исходные компоненты можно выбрать и перед вызовом команды зеркального отражения, указав компоненты (принадлежащие им объекты) в Дереве построения или в окне модели.

Если среди указанных объектов есть вспомогательные плоскости, то первая из них становится плоскостью симметрии операции.

При необходимости вы можете удалить компонент из списка исходных, выделив его на панели Список объектов и нажав кнопку Удалить на этой панели. Исключение компонента из списка происходит и в том случае, если вы повторно укажете его в Дереве построения или в окне модели.

4. С помощью переключателей группы Режим укажите, требуется ли оставлять исходные компоненты после выполнения команды или нет.

5. Для перехода к настройке параметров вставки компонентов нажмите кнопку Продолжить зеркальное отражение на Панели специального управления. На экране появится диалог Параметры зеркального отражения компонентов (см. рис. 2.11.10), а элементы выбора объектов на Панели свойств перестанут отображаться.

6. Задайте параметры вставки, как описано в разделе 2.11.3.4.

7. При необходимости вы можете вернуться к выбору объектов. Для этого в диалоге Параметры зеркального отражения компонентов нажмите кнопку Выбор объектов.... Диалог закроется, на Панели свойств появятся элементы управления.

Измените набор выбранных компонентов и нажмите кнопку Продолжить зеркальное отражение. Диалог настройки параметров отражения вновь появится на экране.

8. Для завершения добавления компонентов нажмите кнопку Создать объект на Панели специального управления или закройте диалог, нажав кнопку ОК. В Дереве построения модели появятся добавленные компоненты.

Кнопки Прервать команду на Панели специального управления и Отмена в диалоге позволяют завершить операцию без создания компонентов.


2.11.3.4. Параметры отражения

Параметры зеркального отражения и симметричной вставки компонентов задаются в диалоге Параметры зеркального отражения компонентов (рис. 2.11.10).

Рис. 2.11.10. Диалог Параметры зеркального отражения компонентов

Диалог содержит перечень компонентов модели, выбранных в качестве исходных для выполнения операции, и инструментальную панель. Порядок расположения компонентов в диалоге соответствует порядку их отображения в Дереве построения.

Если исходный компонент в свою очередь содержит компоненты, то в диалоге показываются и сам исходный компонент, и компоненты, входящие в него.

По умолчанию в диалоге отображаются все выбранные компоненты. При этом из раскрывающегося списка Фильтр:, расположенного на инструментальной панели диалога, выбран вариант Все компоненты.

Вы можете отключить отображение в диалоге библиотечных компонентов или, наоборот, включить отображение только библиотечных компонентов, выбрав соответственно один из следующих вариантов:

– Все компоненты, кроме библиотечных,

– Все библиотечные компоненты.

Перечень компонентов отображается в виде таблицы. Ячейки таблицы содержат информацию о заданных настройках и позволяют изменить их. Чтобы изменить настройку для выбранного компонента, щелкните мышью в соответствующей ячейке и выберите из появившегося списка нужный вариант.

Настройка параметров операции выполняется также с помощью элементов управления инструментальной панели диалога. Вы можете настраивать параметры отдельно для каждого компонента или для нескольких компонентов одновременно, выделив их в таблице диалога.

Группа кнопок Способ: позволяет выбрать способ добавления компонентов. По умолчанию все компоненты добавляются способом Зеркальное отражение компонента (на инструментальной панели нажата соответствующая кнопка).

Чтобы некоторые компоненты добавлялись другим способом, укажите их и нажмите кнопку Симметричное расположение компонента.

Пиктограмма выбранного способа отображается в соответствующей компоненту ячейке столбца Способ вставки.

Если компонент вставляется в модель способом Зеркальное отражение компонента, требуется определить, каким будет результат операции (см. раздел 2.11.3.4.1). Если способ добавления компонента — Симметричное расположение компонента, необходимо настроить положение компонента (см. раздел 2.11.3.4.2).

Базовые принципы добавления компонентов различными способами подробно описаны в разделе 2.11.3.1.

В некоторых случаях при настройке параметров отражения компонента все компоненты, входящие в него, перестают отображаться в диалоге. Это означает, что для них недоступно изменение настроек, т.к. они должны иметь те же параметры отражения, что и содержащий их компонент.

Изменение настройки параметров отражения показывается на фантомах добавляемых компонентов в окне модели. Фантомы компонентов могут перекрывать друг друга, что затрудняет просмотр. Вы можете управлять видимостью фантомов, не закрывая диалог настройки. Для этого используйте столбец Видимость фантома.

По умолчанию фантомы всех компонентов являются видимыми. Чтобы скрыть фантом компонента, щелкните мышью в соответствующей ему ячейке столбца Видимость фантома. Пиктограмма в ячейке изменится. Фантом компонента перестанет отображаться в окне модели. Повторный щелчок снова включит отображение фантома.

Если требуется скрыть/показать фантомы нескольких компонентов, выделите их в таблице и вызовите команду контекстного меню Скрыть фантом/Показать фантом.

Компонент, добавленный зеркальным отражением или симметричной вставкой, отображается в Дереве построения модели как обычный компонент. Чтобы настроить порядок формирования наименований компонентов, добавляемых данными способами, нажмите кнопку Настройка общих параметров зеркального отражения. На экране появится диалог настройки параметров. В этом диалоге вы также можете выбрать папку, в которую будут сохраняться модели, созданные в процессе зеркального отражения. Работа в диалоге описана в разделе 9.1.11.11.

В этом разделе:

2.11.3.4.1. Выбор результата зеркального отражения компонента

2.11.3.4.2. Настройка положения компонента при симметричном размещении


2.11.3.4.1. Выбор результата зеркального отражения компонента

При выборе способа Зеркальное отражение компонента (см. раздел 2.11.3.4) становится доступной группа кнопок Результат:, позволяющая выбрать один из вариантов зеркального компонента, получаемого в результате выполнения операции. Пиктограмма выбранного варианта отображается в соответствующей компоненту ячейке столбца Результат создания зеркальной модели.

Доступны следующие варианты.

Создать зеркальное исполнение

Данный вариант является умолчательным для всех компонентов, кроме стандартных изделий.

При выборе этого варианта зеркально отраженный компонент сохраняется в файле-источнике исходного компонента в виде зеркального исполнения модели, т.е. добавленный компонент является зеркальным исполнением модели исходного.

Особенности:

– Если документ содержит несколько вставок одной и той же модели с компонентами, т.е. одна и та же модель с компонентами является источником нескольких компонентов, то при зеркальном отражении этих компонентов с результатом Создать зеркальное исполнение полный состав модели показывается только для первого из них, а компоненты, входящие в остальные, не отображаются.

– Если зеркальное исполнение исходного компонента уже есть в его файле, то при создании зеркального компонента используется это исполнение. Новое зеркальное исполнение не создается. В этом случае строка компонента в диалоге настройки параметров имеет бирюзовый цвет, а компоненты, входящие в него, не отображаются.

– Если файл модели исходного компонента недоступен для записи, то для этого компонента по умолчанию выбран вариант Сохранить зеркальный компонент в файле (см. ниже). Это связано с тем, что в данный файл невозможно будет сохранить полученное зеркальное исполнение компонента. Если зеркальное исполнение компонента уже имеется в файле, умолчательным будет вариант Создать зеркальное исполнение.

Выбор варианта Создать зеркальное исполнение недоступен для стандартных изделий.

Сохранить зеркальный компонент в файле

При выборе этого варианта зеркально отраженный компонент сохраняется в отдельном файле, т.е. добавленный компонент является самостоятельной моделью. Полное имя файла, в который добавляется компонент, отображается в диалоге в соответствующей ячейке столбца Файл. Папка для сохранения моделей компонентов выбирается при настройке (см. раздел 9.1.11.11).

Особенности:

– Если в отдельный файл сохраняется стандартное изделие, оно также становится самостоятельной моделью. Его пиктограмма в Дереве построения заменяется пиктограммой детали/сборки. Внешним переменным полученной модели присваиваются значения, заданные для стандартного изделия при его вставке в сборку.
Если данный вариант выбран для стандартного изделия-сборки, то в диалоге настройки параметров показываются все его компоненты. Вы можете выбрать результат зеркального отражения каждого из них:

• Отображать компонент в зеркальном виде (активен по умолчанию) — добавленный компонент будет еще одной вставкой того же компонента, т.е. его источником останется библиотечная модель,

• Сохранить зеркальный компонент в файле — компонент стандартного изделия сохранится в отдельном файле, т.е. источником добавленного компонента будет новая модель.

– Если сохранение файла невозможно (например, папка, выбранная для сохранения, недоступна для записи), то после нажатия кнопки ОК в диалоге настройки параметров отражения на экране появляется диалог Ошибка сохранения файла. В этом диалоге вы можете выбрать другую папку для сохранения файла (кнопка Изменить) или отказаться от создания новой модели для данного компонента (кнопка Пропустить). В последнем случае новая модель не создается. Добавляемый компонент будет еще одной вставкой исходного компонента, отраженной зеркально.

Сохранение может быть недоступно для нескольких компонентов. В этом случае диалог Ошибка сохранения файла появляется по очереди для каждого из них.

Вы можете применить выбранное в диалоге действие ко всем последующим компонентам. Для этого перед выбором действия включите опцию Применить для всех последующих. Если в диалоге выбрана другая папка для сохранения (кнопка Изменить), то все последующие компоненты будут сохранены в эту папку. Если выбрано действие Пропустить, то все последующие компоненты будут зеркальными вставками исходных компонентов (без создания новых моделей).

Кнопка Прервать позволяет отменить операцию по созданию компонентов зеркальным отражением. При этом зеркальные компоненты в модели не создаются, а заданные для них параметры отражения теряются.

Отображать компонент в зеркальном виде

Данный вариант является умолчательным для стандартных изделий.

При выборе этого варианта добавленный компонент является еще одной вставкой исходного компонента, только в зеркально отраженном виде. Фактически это та же самая модель, вставленная зеркально.

Особенности:

– Если данный вариант выбран для стандартного изделия, не обладающего симметрией, строка этого изделия в диалоге настройки параметров имеет розовый цвет.

– Если исходный компонент, в свою очередь, содержит компоненты, то при выборе данного варианта все компоненты, входящие в исходный, перестают отображаться в диалоге.


2.11.3.4.2. Настройка положения компонента при симметричном размещении

При выборе способа Симметричное расположение компонента (см. раздел 2.11.3.4) становится доступной группа элементов Положение:.

Для задания положения компонента используются следующие способы.

– Указание плоского или точечного объекта, который является плоскостью/центром симметрии исходного компонента. Данный способ используется для отдельных компонентов.

– Выбор базового компонента. Данный способ используется для добавления произвольного набора компонентов с сохранением их взаимного положения.

После выбора нужного объекта (компонента) фантом добавляемого компонента (нескольких компонентов) изменяет свое положение. Описание выбранного варианта показывается в диалоге в ячейке столбца Положение компонента. Вы можете просмотреть весь список вариантов, щелкнув мышью в ячейке.

Далее в разделе подробно описаны различные способы задания положения компонента, а также список вариантов объектов и работа с ним.

Если для компонента выбран способ Симметричное расположение компонента, то все компоненты, входящие в него, также размещаются данным способом. Эти компоненты перестают отображаться в диалоге.

Использование плоскости/центра симметрии

При указании плоскости/центра симметрии исходного компонента положение добавляемого компонента определяется следующим образом.

Пусть плоскость симметрии, относительно которой размещается компонент, — Р, а плоскость симметрии компонента — S. Находится прямая пересечения плоскостей Р и S и угол j между этими плоскостями.

Если плоскости не параллельны, положение добавляемого компонента определяется поворотом исходного вокруг прямой пересечения плоскостей на угол 2j (рис 2.11.11, а).

Если плоскости параллельны, положение определяется перемещением исходного компонента в направлении плоскости Р на удвоенное расстояние между плоскостями 2h (рис 2.11.11, б).

Перемещение также выполняется, если выбрана не плоскость, а центр симметрии компонента. В данном случае компонент перемещается на удвоенное расстояние между плоскостью Р и центром симметрии.

Рис. 2.11.11. Размещение компонента с использованием его плоскости симметрии: а) плоскость симметрии компонента не параллельна плоскости симметрии операции; б) плоскость симметрии компонента параллельна плоскости симметрии операции
а) | б)

Доступны автоматический и ручной способы указания плоскости/центра симметрии компонента.

Для автоматического выбора объекта используются кнопки Предыдущее положение и Следующее положение. При каждом нажатии одной из этих кнопок системой предлагается объект исходного компонента (с указанием положения объекта), входящий в предопределенный список (описание списка приведено в разделе Просмотр и изменение настройки). Варианты перебираются циклически.

Чтобы указать объект вручную, нажмите кнопку Указать плоскость или точку в компоненте. Запустится процесс указания объекта. Диалог настройки параметров отражения перестанет отображаться. На экране появится Окно модели — источника исходного компонента, позволяющее выбрать нужный объект. Вид окна и работа в нем аналогичны описанным в разделе 2.8.7.1.1.

Укажите нужный объект. Положение фантома компонента в окне модели изменится. Наименование выбранного объекта появится в поле Объект Панели свойств. При необходимости вы можете выбрать другой объект, указав его в Окне модели-источника. Для завершения выбора нажмите кнопку Применить на Панели специального управления. Диалог настройки параметров отражения вновь появится на экране. Выбранный объект будет использоваться для расчета положения компонента. В список вариантов объектов для этого компонента добавится новый вариант.

Ручное указание плоскости и точечного объекта доступно для компонентов сборки первого уровня. Для компонентов всех остальных уровней доступен только выбор плоскости.

Если исходный компонент обладает симметрией, предпочтительным является автоматический способ указания объекта.

Если исходный компонент является несимметричным, эффективнее указать объект вручную.

Использование базового компонента

В данном разделе под базовым компонентом понимается компонент, относительно которого сохраняется положение всех выбранных компонентов.

Выбор базового компонента используется, если в модель требуется добавить несколько компонентов как одно целое, т.е. с сохранением взаимного расположения. Один из компонентов модели используется в качестве базового. Компоненты, взаимное расположение которых требуется сохранить, выбираются единой группой (базовый компонент в эту группу не включается) и размещаются способом Симметричное расположение компонента относительно базового компонента, который выбирается из оставшихся компонентов модели.

Фактически расчет симметричного положения выполняется только для одного компонента — базового, а размещаемые относительно него компоненты перемещаются таким образом, чтобы их положение относительно базового осталось таким же, как у исходных компонентов.

Компонент может использоваться как базовый, если он удовлетворяет следующим условиям:

– размещается способом Симметричное расположение компонента,

– входит в тот же исходный компонент и расположен на том же уровне, что и компоненты, выбранные для размещения по базовому, но не выбран вместе с ними.

Порядок действий.

1. Укажите компоненты, которые требуется разместить симметрично с сохранением взаимного положения. Указанные компоненты должны находиться на одном уровне Дерева построения. Компонент, который предполагается использовать как базовый, не должен быть выбран.

2. Нажмите кнопку Указать базовый компонент на инструментальной панели диалога. На экране появится диалог Выбор базового компонента (рис. 2.11.12). Диалог содержит список компонентов, каждый из которых может быть базовым для указанных компонентов.

Рис. 2.11.12. Диалог Выбор базового компонента

3. Выберите базовый компонент.

По умолчанию базовым является компонент, который находится на верхней строке списка. Рядом с его именем отображается «галочка». Чтобы сделать базовым другой компонент, дважды щелкните по строке списка, содержащей этот компонент, или выделите его в списке и нажмите кнопку Выбор базового компонента.

4. Для завершения работы в диалоге нажмите кнопку ОК.

Диалог закроется. Положение указанных компонентов будет определяться относительно базового. В списки вариантов объектов для этих компонентов добавится новый вариант, содержащий имя базового компонента.

Просмотр и изменение настройки

Для расчета положения добавляемого компонента (нескольких компонентов) используется выбранный объект. Таким объектом может быть плоскость/центр симметрии исходного компонента или базовый компонент.

Сведения о выбранном объекте отображаются в диалоге следующим образом.

– В поле Вариант положения содержится номер выбранного варианта в списке вариантов объектов, используемых для расчета положения компонента. Поле недоступно для ручного ввода.

– В ячейке столбца Положение компонента содержится описание выбранного варианта. Вы можете просмотреть весь список вариантов, щелкнув мышью в ячейке.

Список формируется отдельно для каждого компонента.

Первые восемь строк списка содержат варианты выбора плоскости/центра симметрии исходного компонента, автоматически предлагаемые системой. Эти варианты присутствуют в списках всех компонентов, размещаемых способом Симметричное расположение компонента.

Строки списка формируются по следующему шаблону: <Номер варианта><Тип объекта><Положение объекта>.

Например, если в списке активизирована строка 1 Вариант - Плоскость (Центр габарита, <X,Y>), это означает, что в исходном компоненте выбрана плоскость симметрии, проходящая через центр его габарита параллельно плоскости XY абсолютной системы координат.

Строка 4 Вариант - Плоскость (Центр масс, <J1,J2>) означает, что выбранная плоскость симметрии проходит через центр масс и главные оси инерции J1 и J2 исходного компонента.

Девятая строка присутствует в списках тех компонентов, для которых вручную указана плоскость/центр симметрии или выбран базовый компонент. Данная строка формируется по следующему шаблону: <Номер варианта><Имя объекта>.

Девятый вариант сохраняется в списке до завершения работы команды. Он изменяется в случае перевыбора объекта.

При необходимости вы можете использовать список для выбора другого объекта или для перехода к ручному его указанию (вариант Указать объект...).

Для перевыбора объекта (как в ручном, так и в автоматическом режиме) также используются кнопки инструментальной панели диалога.

Выбор другого базового компонента выполняется только с помощью кнопки инструментальной панели.


2.11.3.5. Автоматическое наложение сопряжений

При создании компонента отражением автоматически создается сопряжение Симметрия или Зависимое положение.

Сопряжение Симметрия создается при любом варианте отражения, кроме отражения способом Симметричное расположение компонента с размещением по базовому компоненту. В этом случае создается сопряжение Зависимое положение.

При одновременном отражении нескольких компонентов одно из указанных сопряжений создается для каждого из них.

Сопряжения Симметрия и Зависимое положение накладываются на исходные компоненты и компоненты, полученные в результате отражения.

Особенности создания сопряжений в автоматическом режиме:

– Сопряжение Симметрия, автоматически наложенное на компоненты модели, имеет направление, при котором исходный компонент (ведущий компонент сопряжения) влияет на положение отраженного компонента (ведомый компонент сопряжения), ограничивая его степени свободы. Подробно о направлении сопряжения см. раздел Направление сопряжения.

– При автоматическом создании сопряжения Зависимое положение взаимное расположение компонентов сопряжения определяется по образцу. В этом случае исходные компоненты (компонент, выбранный для размещения, и базовый компонент) задают образец положения для отраженных компонентов, т.е. исходные компоненты являются компонентами-образцами, а отраженные — компонентами сопряжения.

В процессе дальнейшей работы вы можете отредактировать сопряжения или удалить их. При редактировании сопряжений используются такие же элементы управления, как при ручном создании аналогичных сопряжений (см. разделы 2.11.5.2.9 и 2.11.5.2.10). Общие приемы работы с сопряжениями описаны в разделе 2.11.5.


2.11.4. Перемещения и повороты компонентов

2.11. Компоненты

2.11.4. Перемещения и повороты компонентов

В процессе вставки компонента или после нее вы можете использовать специальные команды для задания положения и ориентации компонента в модели, а также определения его положения относительно других компонентов.

В КОМПАС-3D предусмотрено несколько способов перемещения компонентов в системе координат содержащей их модели. Вы можете повернуть компонент вокруг центра его габаритного параллелепипеда, вокруг оси или вокруг точки, а также сдвинуть компонент в любом направлении. Для выполнения всех видов поворота компонента используется команда Повернуть компонент, а для его сдвига — Переместить компонент. Команды расположены в меню Сервис, а кнопки для их вызова — на панели Редактирование сборки.

При перемещении компонента обратите внимание на следующие особенности.

– Зафиксированный компонент (см. раздел 2.11.4.4) невозможно переместить в системе координат содержащей его модели. В Дереве построения зафиксированный компонент отмечается буквой ф в круглых скобках.

– Перемещение компонента может быть ограничено или запрещено наложенными на этот компонент сопряжениями (о сопряжениях — см. раздел 2.11.5).

• Если компонент может перемещаться (например, компоненты, расположенные соосно, могут перемещаться вдоль их общей оси и вращаться вокруг нее), то он отмечается в Дереве построения знаком «-» в круглых скобках.

• Если компонент не может перемещаться (например, компонент, координатные плоскости которого совпадают с координатными плоскостями модели, нельзя ни сдвинуть, ни повернуть), то он отмечается в Дереве построения знаком «+» в круглых скобках.

После любого перемещения компонента его пиктограмма в Дереве построения отмечается красной «галочкой». Это свидетельствует о необходимости перестроения модели. Чтобы перестроить модель, вызовите команду Вид — Перестроить. Подробнее о перестроении модели см. раздел 2.14.3.7.

Следует различать команды перемещения компонентов в системе координат модели и команды перемещения всей модели в окне (см. раздел 2.1.3).

В этом разделе:

2.11.4.1. Сдвиг компонента

2.11.4.2. Поворот компонента

2.11.4.3. Дополнительные возможности перемещения компонента

2.11.4.3.1. Автоматическое наложение сопряжений в процессе перемещения

2.11.4.3.2. Контроль соударений

2.11.4.4. Фиксация компонентов


2.11.4.1. Сдвиг компонента

Чтобы сдвинуть компонент, вызовите команду Переместить компонент.

Форма курсора изменится.

Установите курсор на сдвигаемом компоненте, нажмите левую кнопку мыши и, не отпуская ее, перемещайте курсор. Компонент будет сдвигаться в том же направлении. Когда нужное положение компонента будет достигнуто, отпустите кнопку мыши.

Группа переключателей Режимы позволяет выполнить:

– Простое перемещение — перемещение без дополнительных действий,

– Автосопряжения — перемещение с автоматическим наложением сопряжений (см. раздел 2.11.4.3.1),

– Контроль соударений — перемещение с контролем соударений компонентов (см. раздел 2.11.4.3.2).

Для выхода из команды сдвига компонента нажмите клавишу <Esc> или кнопку Прервать команду на Панели специального управления.


2.11.4.2. Поворот компонента

Чтобы повернуть компонент, вызовите команду Повернуть компонент.

Форма курсора изменится.

Вы можете повернуть компонент следующими способами:

– вокруг центра габаритного параллелепипеда данного компонента,

– вокруг точки — вершины, начала системы координат или точки в эскизе,

– вокруг прямолинейного объекта — вспомогательной оси, ребра или отрезка в эскизе.

По умолчанию выполняется вращение компонента вокруг центра габаритного параллелепипеда.

Чтобы повернуть компонент вокруг точки или прямолинейного объекта, активизируйте переключатель Центр/ось вращения и укажите нужный объект в Дереве построения или в окне модели.

Установите курсор на компоненте, который необходимо повернуть, нажмите левую кнопку мыши в окне модели и, не отпуская ее, перемещайте курсор. Компонент будет поворачиваться вокруг выбранного элемента.

Группа переключателей Режимы позволяет выполнить:

– Простое вращение — вращение без дополнительных действий,

– Автосопряжения — вращение с автоматическим наложением сопряжений (см. раздел 2.11.4.3.1),

– Контроль соударений — вращение с контролем соударений компонентов (см. раздел 2.11.4.3.2).

Для выхода из команды поворота компонента нажмите клавишу <Esc> или кнопку Прервать команду на Панели специального управления.


2.11.4.3. Дополнительные возможности перемещения компонента

При любом способе перемещения (сдвиге или повороте) компонента доступны следующие действия:

– автоматическое наложение сопряжений на элементы компонентов,

– контроль соударений компонентов.

Эти действия выполняются только для тел компонентов, полностью загруженных в модель, т.е. имеющих тип загрузки Полный (см. раздел 2.12.2.1).

В этом разделе:

2.11.4.3.1. Автоматическое наложение сопряжений в процессе перемещения

2.11.4.3.2. Контроль соударений


2.11.4.3.1. Автоматическое наложение сопряжений в процессе перемещения

Во время сдвига или поворота компонента вы можете использовать режим автоматического наложения сопряжений. Этот режим позволяет при перемещении компонентов распознавать приближающиеся друг к другу элементы (грани, вершины, ребра) и автоматически добавлять сопряжения, соответствующие их форме и типу.

Режим автосопряжений включается после вызова команды перемещения компонента.

Чтобы включить режим автоматического наложения сопряжений, в группе Режимы Панели свойств активизируйте переключатель Автосопряжения.

Перемещайте компонент. Когда он приблизится к другому компоненту, будут подсвечены их грани, на которые можно автоматически наложить сопряжение. Если отпустить кнопку мыши, когда грани подсвечены, на них будет наложено сопряжение.

Например, при приближении друг к другу плоских граней система «на лету» накладывает на них сопряжение Совпадение, а при приближении друг к другу цилиндрических граней — сопряжение Соосность.


2.11.4.3.2. Контроль соударений

Во время сдвига или поворота компонента вы можете использовать режим контроля соударений. В этом режиме перемещение компонентов ограничено их формой и размерами: движение возможно только до «соприкосновения» с другим компонентом.

Режим контроля соударений включается и настраивается после вызова команды перемещения компонента.

Чтобы включить режим контроля соударений, в группе Режимы Панели свойств активизируйте переключатель Контроль соударений. На Панели свойств появятся переключатели для настройки режима.

Выбор перемещаемых компонентов для контроля столкновений

При перемещении компонента обычно происходит перемещение сопряженных с ним компонентов.

Чтобы контроль столкновений осуществлялся только для перемещаемого компонента, активизируйте переключатель Только передвигаемый компонент в группе Контролировать столкновения.

Чтобы контроль столкновений осуществлялся для любого из одновременно перемещаемых компонентов, активизируйте переключатель Все компоненты.

Если перемещаемый компонент не участвует в сопряжениях, то состояние переключателей в группе Контролировать столкновения не имеет значения.

Подсветка граней при столкновении

Чтобы при столкновении перемещаемого компонента с другим компонентом их соприкоснувшиеся грани подсвечивались в окне модели, активизируйте переключатель Подсветка граней при столкновении включена.

Чтобы отключить подсвечивание соприкоснувшихся граней, активизируйте переключатель Подсветка граней при столкновении выключена.

Звуковой сигнал при столкновении

Чтобы при столкновении перемещаемого компонента с другим компонентом раздавался звуковой сигнал, активизируйте переключатель Звуковой сигнал при столкновении включен.

Чтобы отключить звуковой сигнал, активизируйте переключатель Звуковой сигнал при столкновении выключен.

Остановка при столкновении

Чтобы после столкновения перемещаемого компонента с другим компонентом его невозможно было далее перемещать в этом направлении, активизируйте переключатель Останавливать при столкновении. Другими словами, эта опция позволяет предотвратить возможное проникновение перемещаемого компонента внутрь других компонентов.

Чтобы компонент можно было перемещать после столкновения, активизируйте переключатель Не останавливать при столкновении.

Выбор неподвижных компонентов для контроля столкновений

По умолчанию осуществляется контроль столкновений перемещаемых компонентов со всеми остальными компонентами модели.

Вы можете выбрать конкретные компоненты, столкновения с которыми требуется контролировать. Для этого активизируйте переключатель Компоненты и укажите нужные компоненты. Их названия появятся в справочной таблице Список компонентов.

Чтобы исключить компонент из списка, укажите его повторно или выделите его в списке и нажмите кнопку Удалить или клавишу <Delete>.


2.11.4.4. Фиксация компонентов

Фиксация компонента делает невозможным любое перемещение этого компонента в системе координат содержащей его модели. Рекомендуется фиксировать хотя бы один компонент модели для того, чтобы при наложении сопряжений перемещение компонентов было предсказуемым.

Первый компонент, вставленный в новую модель из файла и размещенный способом По координатам (см. раздел 2.11.2.5.2), фиксируется автоматически.

Чтобы зафиксировать компонент (компоненты) в текущем положении:

1. Выделите компонент в Дереве построения или любой его примитив в окне модели. При необходимости можно выделить сразу несколько компонентов.

Подробнее о выборе объектов см. раздел 2.1.4.1.

2. Нажмите кнопку Включить фиксацию на панели Редактирование сборки или вызовите команду из контекстного меню.

Справа от пиктограмм зафиксированных компонентов в Дереве построения отображается буква ф в круглых скобках.

Если фиксируется пара компонентов, участвующих в сопряжении, то это сопряжение автоматически исключается из расчета. При наложении сопряжения на пару фиксированных компонентов оно создается сразу исключенным из расчета.

Если зафиксирован только один из сопрягаемых компонентов, сопряжение из расчета не исключается.

Сопряжение, автоматически исключенное из расчета, нельзя включить в расчет вручную.

При отключении фиксации компонента (компонентов), участвующего в сопряжении, автоматически исключенное из расчета сопряжение вновь включается в расчет. Сопряжение компонентов, исключенное из расчета вручную, автоматически в расчет не включаются.

Чтобы отключить фиксацию компонента (компонентов):

1. Выделите компонент (компоненты) в Дереве построения или в окне модели.

Нажмите кнопку Отключить фиксацию на панели Редактирование сборки или вызовите команду из контекстного меню.

Команды Включить фиксацию и Отключить фиксацию недоступны для компонентов, являющихся экземплярами массива.

Поскольку признак фиксации является одним из свойств компонента, для фиксации отдельного компонента можно воспользоваться следующим способом.

1. Выделите компонент в Дереве построения.

2. Вызовите из контекстного меню команду Свойства компонента.

В группе Фиксация на Панели свойств будет активен переключатель Не фиксировать компонент.

3. Активизируйте другой переключатель из этой группы — Фиксировать компонент.

4. Подтвердите изменение свойств компонента, нажав кнопку Создать объект.

Чтобы отключить фиксацию отдельного компонента, можно также воспользоваться переключателем Не фиксировать компонент на Панели свойств.

Обратите внимание на то, что включение и отключение фиксации возможно только для компонентов, расположенных на первом уровне редактируемой модели. Таким образом, при работе, например, со сборкой можно установить или отменить фиксацию компонента, входящего непосредственно в эту сборку, но не в какую-либо из ее подсборок. Аналогично, при редактировании подсборки «на месте» установить или отменить фиксацию можно для компонента, входящего в эту подсборку, а для компонента, входящего в другую подсборку или в саму сборку — нельзя.


2.11.5. Сопряжение компонентов

2.11. Компоненты

2.11.5. Сопряжение компонентов

После того как в модели будут созданы все необходимые объекты, можно приступать к созданию сопряжений.

Сопряжение — это связь между компонентами и другими объектами.

Например, после наложения сопряжения Параллельность на две грани разных компонентов сами эти компоненты оказываются сопряженными. Положение компонентов изменяется таким образом, что выбранные грани становятся параллельными. В дальнейшем при любом перемещении одного из сопряженных компонентов второй автоматически перемещается так, чтобы параллельность граней сохранялась.

В сопряжениях могут участвовать различные объекты, принадлежащие как компонентам, так и содержащей их модели: координатные плоскости и оси, начала координат, грани, ребра, вершины тел и поверхностей, точки, вершины кривых, сегменты ломаных, дуги, графические объекты в эскизах, а также вспомогательные оси и плоскости, локальные системы координат.

Одни и те же объекты могут участвовать в различных сопряжениях; возможно наложение различных сопряжений на одну и ту же пару объектов.

В этом разделе:

2.11.5.1. Общие сведения о сопряжениях

2.11.5.1.1. Принципы наложения сопряжений

2.11.5.1.2. Взаимодействие сопряжений

2.11.5.1.3. Отображение сопряжений в Дереве построения модели

2.11.5.2. Позиционирующие сопряжения

2.11.5.2.1. Общие приемы создания позиционирующих сопряжений

2.11.5.2.2. Совпадение

2.11.5.2.3. Соосность

2.11.5.2.4. Параллельность

2.11.5.2.5. Перпендикулярность

2.11.5.2.6. Расположение объектов на заданном расстоянии

2.11.5.2.7. Расположение объектов под углом друг к другу

2.11.5.2.8. Касание

2.11.5.2.9. Симметрия

2.11.5.2.10. Зависимое положение

2.11.5.3. Сопряжения механической связи

2.11.5.3.1. Обеспечение корректной работы сопряжений механической связи

2.11.5.3.2. Общие приемы создания сопряжений механической связи

2.11.5.3.3. Сопряжение Вращение – вращение

2.11.5.3.4. Сопряжение Вращение – перемещение

2.11.5.3.5. Сопряжение Кулачок – толкатель

2.11.5.3.6. Просмотр работы сопряжений


2.11.5.1. Общие сведения о сопряжениях

В КОМПАС-3D можно задать сопряжения следующих типов.

– Позиционирующее сопряжение (определенным образом фиксирующее один объект относительно другого):

• Совпадение,

• Касание,

• Соосность,

• Параллельность,

• Перпендикулярность,

• Расположение элементов на заданном расстоянии,

• Расположение элементов под заданным углом,

• Симметрия,

• Зависимое положение.

Позиционирующие сопряжения обычно применяются в процессе компоновки изделия. О создании позиционирующих сопряжений рассказано в разделах 2.11.5.2.1 – 2.11.5.2.10.

Позиционирующие сопряжения могут накладываться автоматически при перемещении компонентов. Об автосопряжениях рассказано в разделе 2.11.4.3.1.

– Сопряжение механической связи (определяющее закон движения одного объекта относительно другого при движении любого из них):

• Вращение – вращение,

• Вращение – перемещение,

• Кулачок – толкатель.

Сопряжения механической связи являются вспомогательными и применяются для предварительной оценки и визуализации работы механизмов. О создании сопряжений механической связи рассказано в разделах 2.11.5.3.2 – 2.11.5.3.5.

Команды наложения позиционирующих сопряжений расположены в меню Операции — Сопряжения компонентов, механических связей — в меню Операции — Механические сопряжения компонентов. Кнопки для вызова этих команд находятся на панели Сопряжения (рис. 2.11.13).

Рис. 2.11.13. Панель Сопряжения

Сопряжения обоих типов могут накладываться, редактироваться или удаляться независимо друг от друга. Возможность просмотра сопряжений механической связи может быть ограничена наличием некоторых позиционирующих сопряжений. Поэтому сопряжения механической связи рекомендуется создавать после позиционирующих.

Создание сопряжений описано в разделах 2.11.5.2 и 2.11.5.3, редактирование — в разделе 2.14.3.5.3.

При создании сопряжений в модели автоматически создаются переменные, соответствующие параметрам этих сопряжений. Подробно о создании и использовании переменных см. раздел 7.1.

В этом разделе:

2.11.5.1.1. Принципы наложения сопряжений

2.11.5.1.2. Взаимодействие сопряжений

2.11.5.1.3. Отображение сопряжений в Дереве построения модели


2.11.5.1.1. Принципы наложения сопряжений

Первоначально — сразу после вставки в модель — компонент может произвольно перемещаться в ее системе координат.

В результате наложения позиционирующего сопряжения компонент теряет часть степеней свободы. Например, если установить совпадение грани детали с плоскостью, то у детали останется три степени свободы: две степени свободы перемещения и одна степень свободы вращения.

Первый компонент, вставленный в модель из файла, автоматически фиксируется. При необходимости вы можете зафиксировать любые другие компоненты, а также отменить фиксацию любых компонентов (см. раздел 2.11.4.4).

Рекомендуется, чтобы после наложения всех позиционирующих сопряжений компоненты стали неподвижны в системе координат содержащей их модели.

Если в дальнейшем планируется наложение сопряжений механической связи, то позиционирующие сопряжения нужно накладывать так, чтобы у объектов оставались необходимые степени свободы.

В Дереве построения используются следующие обозначения, показывающие, может ли компонент перемещаться в системе координат модели:

(ф) — зафиксированный компонент,

(+) — компонент, полностью определенный позиционирующими сопряжениями, т.е. не имеющий ни одной степени свободы в системе координат модели,

(-) — не полностью определенный компонент.

Обозначение добавляется перед названием компонента.

Корневой объект в Дереве, раздел Компоненты, его группа или ветвь одинаковых объектов имеют знак (+) перед названием, если все входящие в них объекты зафиксированы или полностью определены. В остальных случаях они имеют знак (-).

Кроме зафиксированных и полностью определенных компонентов, неподвижными в системе координат модели являются следующие объекты:

– объект, принадлежащий модели в целом, а не какому-либо из компонентов (эти объекты находятся на первом уровне в Дереве построения)

– экземпляр массива.

Экземпляры массива, являющегося, в свою очередь, экземпляром другого массива, не могут участвовать в сопряжениях.

Если из двух сопрягаемых компонентов один неподвижен, то подвижность второго компонента (а следовательно, и возможность его последующего сопряжения с другими объектами) ограничивается больше, чем если бы он сопрягался со «свободным» компонентом.

Два неподвижных объекта сопрячь невозможно (в некоторых случаях сопряжение создается и сразу отмечается как ошибочное). Например, нельзя установить совпадение двух осей, являющихся объектами сборки, даже если они проходят через ребра или вершины разных деталей. Невозможно также сопрячь объекты, принадлежащие одному и тому же компоненту: это потребует независимого перемещения объектов внутри компонента, в то время как он перемещается в системе координат модели как одно целое.


2.11.5.1.2. Взаимодействие сопряжений

После наложения позиционирующего сопряжения объекты автоматически перемещаются так, чтобы выполнялось условие сопряжения (если оно не выполнялось до наложения сопряжения).

После наложения сопряжения механической связи объекты остаются на своих местах (исключение — сопряжение Кулачок – толкатель, в котором объекты, если они не соприкасались, автоматически приводятся в соприкосновение).

Сопряжения механической связи работают в «границах», которые определены позиционирующими сопряжениями. Действие сопряжений можно проверить, перемещая компонент мышью в различных направлениях. Подробно о просмотре работы сопряжений механической связи рассказано в разделе 2.11.5.3.6.

В процессе редактирования модели могут возникнуть противоречия в сопряжениях. Например, может оказаться, что два позиционирующих сопряжения требуют различных положений одного и того же компонента. В таких случаях сопряжение отмечается в Дереве построения как ошибочное.

Позиционирующие сопряжения могут препятствовать перемещению компонента в направлении, которое определено сопряжением механической связи. В этом случае сопряжение механической связи не действует. Значок ошибки в Дереве построения не возникает.


2.11.5.1.3. Отображение сопряжений в Дереве построения модели

После создания сопряжения в Дереве построения появляется его пиктограмма.

Рис. 2.11.14. Группа сопряжений между Корпусом и Переходником

Если в Дереве включено отображение структуры модели (см. раздел 2.1.2.2), то два или более сопряжений, наложенных на одну и ту же пару компонентов, формируют группу в разделе «Сопряжения» (рис. 2.11.14). Название группы образуется из имен сопряженных компонентов.


2.11.5.2. Позиционирующие сопряжения

Позиционирующие сопряжения, как правило, существуют в любой сборочной модели, так как другими способами (например, перемещением компонентов мышью, использованием привязок при вставке и др.) трудно расположить компоненты требуемым образом, а при редактировании несопряженных компонентов их взаимное положение легко нарушается.

Например, два компонента были каким-либо образом установлены так, чтобы две их грани совпадали. После изменения глубины выдавливания элемента, принадлежащего одному из компонентов, грань, с которой совпадала грань другого компонента, была перемещена. Если совпадение граней было установлено «вручную», их взаимное положение будет нарушено. Компонент, который не редактировался, останется на своем месте. Его вновь придется устанавливать в нужное положение. Если же совпадение граней было достигнуто путем наложения на компоненты сопряжения Совпадение, то после редактирования одного из сопряженных компонентов и перестроения модели произойдет такое перемещение второго компонента, чтобы условие сопряжения не нарушалось, т. е. чтобы грани, участвующие в сопряжении Совпадение, по-прежнему располагались в одной плоскости.

В этом разделе:

2.11.5.2.1. Общие приемы создания позиционирующих сопряжений

2.11.5.2.2. Совпадение

2.11.5.2.3. Соосность

2.11.5.2.4. Параллельность

2.11.5.2.5. Перпендикулярность

2.11.5.2.6. Расположение объектов на заданном расстоянии

2.11.5.2.7. Расположение объектов под углом друг к другу

2.11.5.2.8. Касание

2.11.5.2.9. Симметрия

2.11.5.2.10. Зависимое положение


2.11.5.2.1. Общие приемы создания позиционирующих сопряжений

Для создания сопряжения вызовите команду, соответствующую нужному типу сопряжения.

Укажите в окне модели сопрягаемые объекты, а для сопряжения Симметрия сопрягаемые объекты и плоскость симметрии.

Если перед вызовом команды в окне модели были выделены какие-либо объекты, сопряжение будет наложено на них.

Сопряжение может быть создано в ручном или автоматическом режиме. Это зависит от состояния кнопки Автосоздание объекта на Панели специального управления.

При включенном автосоздании сопряжение создается автоматически сразу после выбора объектов. Если требуется выполнить дополнительные настройки сопряжения, отключите автосоздание. В этом случае для завершения создания сопряжения необходимо нажать кнопку Создать объект.

Для сопряжений На расстоянии и Под углом автосоздание не предусмотрено, т.к. для создания сопряжения необходимо не только указать объекты, но и задать соответственно расстояние или угол между сопрягаемыми объектами.

Ориентация компонентов

По умолчанию сопрягаемые компоненты перемещаются так, чтобы соблюдалось условие сопряжения, а величина перемещения компонентов относительно их начального положения была минимальной. Иногда положение компонентов при этом отличается от требуемого. Например, после наложения сопряжения Совпадение на плоские грани деталей эти детали оказываются по одну сторону от плоскости указанных граней, а требуется, чтобы они располагались по разные стороны от плоскости.

Вы можете управлять положением сопрягаемых компонентов при наложении сопряжений всех типов, кроме сопряжения Симметрия. Для этого выполните следующие действия.

Отключите режим автоматического подтверждения выполнения команды (отожмите кнопку Автосоздание объекта на Панели специального управления).

Затем активизируйте один из переключателей в группе Ориентация — Прямая Ориентация или Обратная ориентация. Положение сопрягаемых компонентов можно оценить по фантому в окне модели.

Добившись требуемой ориентации компонентов, подтвердите создание сопряжения.

Дополнительные приемы

– Можно наложить несколько однотипных сопряжений, не выходя из команды.

Например, вызвав команду На расстоянии, вы можете расположить на заданном расстоянии две грани, затем, изменив, если нужно, расстояние, указать для сопряжения вершину и ребро и так далее.

– При наложении сопряжений вы можете использовать команду Запомнить состояние, позволяющую использовать заданные параметры сопряжения для последующего создания сопряжений того же типа. Например, необходимо расположить несколько компонентов так, чтобы они касались какой-либо поверхности. После вызова команды Касание укажите эту поверхность, нажмите кнопку Запомнить состояние на Панели специального управления и указывайте нужные компоненты.

– Сопряжения могут быть наложены автоматически в процессе сдвига или поворота компонента (см. раздел 2.11.4.3.1). Кроме того, при создании компонента зеркальным отражением (см. раздел 2.11.3.3) на него автоматически накладывается сопряжение Симметрия или Зависимое положение (см. раздел 2.11.3.5).


2.11.5.2.2. Совпадение

Чтобы установить совпадение объектов, вызовите команду Совпадение.

Укажите первый и второй объекты (грани, ребра, вершины и т.д. в любой комбинации), совпадение которых вы хотите установить.

Совпадение систем координат двух компонентов означает совпадение одноименных осей и плоскостей этих систем координат. Поэтому после наложения на компоненты такого сопряжения они становятся неподвижны друг относительно друга. Указание систем координат производится в Дереве построения.


2.11.5.2.3. Соосность

Чтобы установить соосность объектов, вызовите команду Соосность.

Укажите первый и второй объекты (оси, конические грани), соосность которых вы хотите установить.


2.11.5.2.4. Параллельность

Чтобы установить параллельность объектов, вызовите команду Параллельность.

Укажите первый и второй объекты (грани, ребра и т. д.), параллельность которых вы хотите установить.


2.11.5.2.5. Перпендикулярность

Чтобы установить выбранные объекты перпендикулярно друг другу, вызовите команду Перпендикулярность.

Укажите первый и второй объекты (грани, ребра и т. д.), перпендикулярность которых вы хотите установить.


2.11.5.2.6. Расположение объектов на заданном расстоянии

Чтобы расположить объекты на заданном расстоянии друг от друга, вызовите команду На расстоянии.

Укажите первый и второй объекты (грани, ребра, вершины и т. д.), которые необходимо расположить на указанном расстоянии.

Ближайшее решение

По умолчанию на Панели параметров включена опция Ближайшее решение. При этом автоматически определяется расстояние между указанными объектами. Сопряжение создается с использованием этого расстояния.

В результате положение компонентов после наложения сопряжения не меняется или меняется минимально.

Например, если для наложения сопряжения На расстоянии указаны вершина и плоскость, их положение не изменится.

Если для наложения сопряжения На расстоянии указаны две плоскости, то одна из них изменит свое положение так, чтобы стать параллельной другой плоскости. При этом система выберет наиболее близкую к исходной ориентацию перемещаемого компонента. Сформируется сопряжение с использованием того расстояния, на котором будут располагаться плоскости.

Расстояние, определенное автоматически, может быть изменено пользователем.

Задание произвольного расстояния

Вы можете задать расстояние между сопрягаемыми компонентами до указания объектов. Для этого отключите опцию Ближайшее решение и введите нужное значение в поле Расстояние.

Чтобы указать, в какую сторону относительно первого объекта откладывается расстояние, активизируйте переключатель Прямое направление или Обратное направление в группе Направление.


2.11.5.2.7. Расположение объектов под углом друг к другу

Чтобы расположить объекты под заданным углом, вызовите команду Под углом.

Для создания сопряжения данного вида могут использоваться различные объекты. В зависимости от их сочетания углом сопряжения является:

– для прямолинейных объектов — угол между скрещивающимися или пересекающимися прямыми, содержащими эти объекты,

– для прямолинейного и плоского объектов — угол между прямолинейным объектом и его проекцией на плоский объект,

– для двух плоских объектов — угол между плоскостями объектов,

– для прямолинейного объекта и поверхности вращения — угол между объектом и осью поверхности вращения,

– для плоского объекта и поверхности вращения — угол между осью поверхности вращения и ее проекцией на плоский объект,

– для двух поверхностей вращения — угол между осями вращения.

Перечень прямолинейных и плоских объектов приведен в таблице 2.1.7. К поверхностям вращения, которые могут использоваться для создания сопряжения данного вида, относятся цилиндрические, конические и тороидальные.

Угол сопряжения может быть двух типов — Пространственный и Плоский.

Чтобы выбрать нужный тип угла сопряжения, в группе элементов Тип угла необходимо активизировать соответствующий переключатель — Пространственный (3D) угол или Плоский (2D) угол.

При выборе типа угла сопряжения следует учитывать, что после наложения сопряжения изменение положения сопряженных компонентов будет ограничено:

– если тип угла Пространственный — значением этого угла,

– если тип угла Плоский — значением этого угла и положением плоскости его измерения.

Тип угла Пространственный

Если выбран тип угла Пространственный, укажите сопрягаемые объекты. После этого становится доступным поле Угол, позволяющее ввести значение угла сопряжения.

Если на Панели свойств включена опция Ближайшее решение, значение угла сопряжения (угла между указанными объектами) определяется автоматически и заносится в поле Угол. Вы можете использовать это значение для создания сопряжения или задать другое. В первом случае положение компонентов после наложения сопряжения не меняется. Во втором случае положение одного из компонентов изменяется в соответствии с заданным значением.

При необходимости можно задать значение угла сопряжения до указания сопрягаемых объектов. Для этого следует отключить опцию Ближайшее решение.

Тип угла Плоский

Если выбран тип угла Плоский, укажите сопрягаемые объекты и ось, определяющую направление измерения угла сопряжения в плоскости. Плоскостью измерения угла сопряжения (сокращенно — плоскостью угла) является условная плоскость, перпендикулярная заданной оси.

– Ось должна удовлетворять следующим требованиям:

• Объект, определяющий ось, должен принадлежать одному из сопрягаемых компонентов.

• Если сопрягаемым объектом компонента является его грань, ось должна быть параллельна этой грани или принадлежать ей; если сопрягаемым объектом является ребро, ось должна быть перпендикулярна этому ребру.

– Для определения оси может быть указан:

• прямолинейный объект — за ось принимается указанный объект,

• плоский объект — за ось принимается нормаль к указанному плоскому объекту,

• плоская кривая (дуга, окружность, линия эскиза) — за ось принимается нормаль к плоскости кривой,

• поверхность вращения (цилиндрическая, коническая, тороидальная) — за ось принимается ось поверхности вращения.

Например, сопрягаемым объектом компонента является его грань. В качестве объекта, определяющего ось, может быть выбрано ребро этой грани.

После того как ось задана, один из сопрягаемых компонентов изменяет свое положение таким образом, чтобы стороны угла сопряжения были параллельны плоскости измерения этого угла.

После указания сопрягаемых объектов и оси становится доступным поле Угол, позволяющее ввести значение угла сопряжения. При необходимости можно задать значение угла сопряжения до указания сопрягаемых объектов и оси. Для этого следует отключить опцию Ближайшее решение на Панели свойств.

Если опция Ближайшее решение включена, то значение угла сопряжения (угла между указанными объектами) определяется автоматически и заносится в поле Угол. Использование этого значения позволяет создать сопряжение, при котором взаимное расположение компонентов совпадает с исходным или минимально отличается от него.

Вы можете отредактировать определенное автоматически значение угла сопряжения в поле Угол.


2.11.5.2.8. Касание

Чтобы установить касание объектов, вызовите команду Касание.

Если сопряжение создается для объектов, имеющих единственный вариант сопряжения Касание, например, для прямолинейного ребра и цилиндрической поверхности, то укажите эти объекты (ребро и поверхность).

В режиме автосоздания объектов (при нажатой кнопке Автосоздание на Панели специального управления) автоматически создается вариант сопряжения, наиболее близкий к исходному положению объектов.

Если в сопряжении участвуют конические, сферические, тороидальные грани или другие элементы, для которых возможны несколько вариантов касания, то отожмите кнопку Автосоздание.

Укажите первый и второй объекты (грань, ребро, поверхность), касание которых требуется установить.

Возможны следующие виды касания:

– по окружности — в случаях сопряжения с тором, круглым ребром и др.,

– по образующей — в случаях сопряжения с цилиндрической, конической поверхностями,

– в точке — в случаях сопряжения со сферической поверхностью и касания двух цилиндрических поверхностей.

После указания второго объекта автоматически определяется вид касания объектов и включается соответствующая опция — По окружности или По образующей. Обе выключенные опции означают касание в точке. Изменение состояния опций невозможно.

Исключение составляют следующие пары объектов:

– цилиндр – цилиндр (в точке, по образующей);

– конус – сфера (в точке, по окружности).

Чтобы задать вид касания для объектов этих пар, включите или выключите соответствующую опцию.

После указания объектов на экране компоненты располагаются следующим образом. В случае касания по окружности в общей плоскости оказываются совпадающие окружности. В случае касания по образующей образующие располагаются на одной прямой. В случае касания в точке объекты имеют общую точку.

В паре сфера – тор возможен особый вид касания — в точках внешней и внутренней экваториальных окружностей тора. Этот вид касания считается касанием по окружности.

Для плоской, цилиндрической, конической, незамкнутых тороидальной или сферической грани линия или точка касания может находиться на продолжении грани.

Если возможны два варианта сопряжения, то доступны переключатели группы Ориентация. Для смены ориентации нажмите переключатель Прямая ориентация или Обратная ориентация. Если существует более двух вариантов сопряжений, то вместо переключателя ориентации доступна кнопка Следующий. При нажатии кнопки отображается следующий вариант.

Чтобы отображались варианты другого вида касания для пар объектов цилиндр – цилиндр и конус – сфера, включите нужную опцию и возобновите просмотр.

После выбора варианта сопряжения подтвердите его создание.


2.11.5.2.9. Симметрия

Чтобы расположить объекты симметрично относительно плоскости, вызовите команду Симметрия.

Укажите плоскость симметрии — плоскую грань, вспомогательную или координатную плоскость.

Укажите первый и второй сопрягаемые объекты.

Для создания сопряжения данного вида могут использоваться точечные объекты, плоские объекты, прямолинейные объекты, системы координат, компоненты.

Вы также можете наложить сопряжение Симметрия на пары цилиндрических, конических, сферических, тороидальных граней, если параметры их теоретических поверхностей совпадают, а также на ребра в форме дуг или окружностей, имеющие одинаковые радиусы.

Сопряжение может быть создано, если выбраны объекты одного типа, например, два точечных объекта, два плоских объекта и т.п. Поэтому при выборе второго объекта доступны только объекты того же типа, что и первый.

Компоненты и системы координат можно выбрать только в Дереве построения модели.

Если в команде включено автосоздание, то после указания плоскости симметрии и сопрягаемых объектов автоматически создается сопряжение. Если автосоздание отключено, вы можете задать параметры сопряжения (см. ниже), а затем подтвердить создание сопряжения кнопкой Создать объект.

Сопряжение Симметрия создается автоматически при добавлении компонента зеркальным отражением (см. раздел 2.11.3.3). Оно накладывается на исходный и отраженный компоненты. Обратите внимание на то, что данное сопряжение создается во всех случаях, кроме отражения компонента способом Симметричное расположение компонента с размещением по базовому компоненту. В данном случае создается сопряжение Зависимое положение (см. раздел 2.11.5.2.10).

Направление сопряжения

Сопряжение имеет направление, если один из сопрягаемых компонентов (ведущий) влияет на положение другого (ведомого), ограничивая его степени свободы.

По умолчанию создаваемое вручную сопряжение не имеет направления. Вы можете задать направление сопряжения, если в качестве сопрягаемых объектов выбраны компоненты модели.

Чтобы задать направление сопряжения (т.е. выбрать ведущий компонент), активизируйте один из переключателей группы Направление сопряжения:

– Объект 1 ограничивает объект 2,

– Объект 2 ограничивает объект 1.

Параметры размещения компонента

После указания плоскости симметрии и сопрягаемых объектов указанные объекты изменяют свое положение так, чтобы быть зеркально симметричными относительно плоскости симметрии. Указанные объекты входят в компоненты, на которые накладывается сопряжение.

В качестве сопрягаемых объектов могут быть указаны сами компоненты. В этом случае вы можете изменить взаимное положение компонентов, выбрав для них другой способ размещения.

Изменение способа взаимного размещения компонентов возможно, если системы координат обоих компонентов либо правосторонние, либо левосторонние (см. раздел 2.8.3.1.1). В этом случае на Панели свойств находится кнопка Настроить....

Чтобы выполнить настройку, нажмите эту кнопку. Запустится процесс настройки параметров размещения компонентов.

Умолчательным способом размещения является Зеркальное отражение. Вы можете выбрать другой способ — Симметричное расположение и настроить его параметры.

Параметры взаимного расположения компонентов сопряжения настраиваются так же, как параметры компонента зеркального исполнения относительно компонента исходного исполнения (см. раздел 2.13.4.3.1). Доступны все варианты задания положения, кроме варианта Положение по базовому компоненту.

При изменении параметров размещения один из компонентов сопряжения изменяет свое положение в окне модели. Это может быть как первый, так и второй компонент сопряжения, в зависимости от дополнительных ограничений, наложенных на компоненты.

Чтобы завершить настройку, нажмите кнопку Применить на Панели специального управления. Система вернется в процесс создания сопряжения.


2.11.5.2.10. Зависимое положение

Сопряжение Зависимое положение представляет собой фиксацию положения одного компонента относительно другого. Компонент, который фиксируется, называется зависимым, а компонент, относительно которого выполняется фиксация, — базовым.

Если на пару компонентов наложено сопряжение Зависимое положение, то при перемещении любого из них другой перемещается таким образом, чтобы взаимное положение компонентов сохранилось.

Чтобы зафиксировать один компонент относительно другого, вызовите команду Зависимое положение.

Выберите зависимый компонент, указав принадлежащий ему объект в Дереве построения или в окне модели. Наименование выбранного компонента появится в поле Зависимый компонент.

Аналогично выберите базовый компонент. Его наименование появится в поле Базовый компонент.

Если в команде включено автосоздание, то после выбора сопрягаемых компонентов автоматически создается сопряжение. Если автосоздание отключено, то необходимо подтвердить создание сопряжения кнопкой Создать объект.

Базовый компонент может быть полностью определен или зафиксирован в модели. В этом случае после наложения сопряжения зависимый компонент становится полностью определенным.

Вам может потребоваться, чтобы компоненты сопряжения были расположены друг относительно друга так же, как два других компонента модели. Для этого используется опция По образцу.

Если в команде включено автосоздание, необходимо включить опцию По образцу до выбора компонентов сопряжения.

После включения опции на Панели свойств появляются элементы выбора зависимого и базового компонентов-образцов, взаимное расположение которых будет образцом для сопрягаемых компонентов. Положение зависимого компонента-образца рассчитывается относительно системы координат базового компонента-образца, т.е. системы координат базового и зависимого компонентов сопряжения будут располагаться друг относительно друга так же, как системы координат образцов.

Укажите зависимый и базовый компоненты-образцы. Их наименования появятся в соответствующих полях. При этом зависимый компонент сопряжения переместится таким образом, чтобы занять положение в соответствии с образцом. Данное положение фиксируется относительно базового компонента сопряжения и сохраняется в случае перемещения одного из сопряженных компонентов. Если перемещается один из компонентов-образцов, то зависимый компонент сопряжения перемещается в соответствии с новым образцом положения.

При включенном автосоздании после выбора компонентов-образцов сопряжение создается автоматически. Если автосоздание отключено, требуется подтвердить создание сопряжения.

Сопряжение Зависимое положение создается автоматически при добавлении компонента зеркальным отражением, если способ отражения — Симметричное расположение компонента с размещением по базовому компоненту (см. раздел 2.11.3.4.2). При этом компонентами сопряжения являются компоненты, полученные зеркальным отражением, а их исходные компоненты используются в качестве компонентов-образцов.


2.11.5.3. Сопряжения механической связи

Сопряжение механической связи обеспечивает связь перемещений компонентов в моделях механических передач, редукторов, кулачковых механизмов и других. Использование сопряжений механической связи позволяет переводить проектируемый механизм в различные положения путем перемещения одного из компонентов. Перемещение этого компонента приводит в движение связанные с ним другие компоненты (с учетом ограничений, накладываемых позиционирующими сопряжениями).

Рис. 2.11.15. Пример связи перемещений между деталями

При создании сопряжений необходимо учитывать следующее.

– Сопряжения механической связи, как и позиционирующие, накладываются на пары объектов. Возможны следующие виды сопряжений механической связи и соответствующие им виды перемещений:

• Вращение – вращение. Оба объекта вращаются.

• Вращение – перемещение. Один объект вращается, другой — перемещается по прямолинейной траектории.

• Кулачок – толкатель. Один объект (кулачок) вращается, другой (толкатель) — перемещается вдоль прямолинейной траектории с сохранением контакта кулачка и толкателя.

– В модели может быть создано несколько сопряжений механической связи. Один и тот же компонент может быть связан сопряжениями механической связи с несколькими компонентами.

В примере, показанном на рисунке 2.11.15, при перемещении колеса 3 вдоль рейки 5 вращаются колеса 1 и 2. Это обеспечивается сопряжениями Вращение – перемещение, наложенными на колесо 3 – рейку 5, колесо 2 – рейку 5 и сопряжением Вращение – вращение, наложенным на колеса 1 и 2.

Для просмотра работы сложного механизма, если не стоит задача показать движение всех его звеньев, достаточно задать сопряжения между начальным и конечным подвижными элементами. В примере, показанном на рисунке 2.11.15, это могло бы быть сопряжение Вращение – перемещение, наложенное на колесо 1 и деталь 5. При движении детали 5 вращается колесо 1, а колеса 2 и 3 не вращаются.

Для создания сопряжений Вращение – вращение, Вращение – перемещение и просмотра их работы не требуется контакта деталей между собой.

– При демонстрации механических передач позиционирующие сопряжения, использованные при компоновке модели, ограничивают перемещение компонентов в пространстве. Позиционирующие сопряжения следует накладывать так, чтобы у компонентов оставались степени свободы, необходимые для последующего наложения сопряжений механической связи и их работы (см. раздел 2.11.5.3.1).

В этом разделе:

2.11.5.3.1. Обеспечение корректной работы сопряжений механической связи

2.11.5.3.2. Общие приемы создания сопряжений механической связи

2.11.5.3.3. Сопряжение Вращение – вращение

2.11.5.3.4. Сопряжение Вращение – перемещение

2.11.5.3.5. Сопряжение Кулачок – толкатель

2.11.5.3.6. Просмотр работы сопряжений


2.11.5.3.1. Обеспечение корректной работы сопряжений механической связи

Для обеспечения ожидаемого взаимного перемещения компонентов, связанных сопряжением механической связи, рекомендуется, чтобы эти компоненты имели минимум степеней свободы, необходимый для совершения движений в рамках сопряжений механической связи. Уменьшить количество степеней свободы компонента можно с помощью позиционирующих сопряжений его с другими объектами, а также с помощью фиксации.

Обычно, если позиционирующие сопряжения в модели изделия наложены так, что компоненты имеют столько же степеней свободы, сколько детали и узлы в реальной конструкции, то для работы сопряжений механической связи не требуется введения дополнительных ограничений.

Поясним сказанное на примерах.

1. Вращение – вращение

Рассмотрим сопряжение между двумя зубчатыми колесами, в котором колеса должны вращаться вокруг неподвижных осей (например, колеса 1 и 2 на рис. 2.11.16).

Перед наложением сопряжения механической связи следует обеспечить:

• неподвижность осей в системе координат модели,

• соосность колес и соответствующих им осей.

Обычно колеса не имеют возможности перемещаться вдоль осей вращения — этого можно достичь, связав плоские торцевые грани колес с каким-либо неподвижным плоским объектом сопряжением Совпадение или На расстоянии.

Таким образом, каждое колесо будет иметь по одной степени свободы вращения вокруг оси.

После наложения сопряжения Вращение – вращение вращение любого из колес будет приводить к вращению другого колеса.

Обратите внимание на то, что неподвижность осей вращения колес необходима именно для данного примера. В других случаях оси могут иметь возможность перемещения, например, оси колес-сателлитов в планетарных передачах.

2. Вращение – перемещение

Пример 1. Рассмотрим сопряжение между колесом и рейкой, в котором колесо, вращаясь, должно перемещать рейку (например, как на рис. 2.11.17).

Перед наложением сопряжения механической связи следует обеспечить:

• неподвижность оси колеса в системе координат модели,

• соосность колеса и оси,

• постоянство ориентации рейки по отношению к оси колеса (это можно сделать разными способами, например, связав прямолинейное ребро рейки с одной неподвижной плоскостью сопряжением На расстоянии, а с другой — сопряжением Совпадение),

Как и в предыдущем примере, можно наложить сопряжение, препятствующее смещению колеса вдоль оси.

Таким образом, колесо будет иметь одну степень свободы вращения вокруг своей оси, и рейка будет иметь одну степень свободы поступательного движения.

После наложения сопряжения Вращение – перемещение вращение колеса будет приводить к перемещению рейки и наоборот, при перемещении рейки будет вращаться колесо.

Пример 2. Рассмотрим сопряжение между винтом и гайкой, в котором винт, вращаясь, должен перемещать гайку.

Перед наложением сопряжения механической связи следует обеспечить:

• невозможность сдвига винта вдоль оси вращения,

• соосность винта и гайки.

Таким образом, винт будет иметь одну степень свободы вращения вокруг оси, а гайка — две степени свободы: вращения вокруг оси и перемещения вдоль нее.

После наложения сопряжения Вращение – перемещение вращение винта будет приводить к перемещению гайки и наоборот, при перемещении гайки будет вращаться винт.

Винт в данном сопряжении может быть и неподвижным. Тогда гайка при перемещении будет вращаться.

Если же и винт, и гайка будут иметь по две степени свободы (вращения и перемещения), то корректная работа сопряжения станет невозможна.

3. Кулачок – толкатель

Рассмотрим сопряжение, в котором кулачок, вращаясь, должен перемещать толкатель вдоль прямолинейной траектории (например, как на рис. 2.11.18).

Перед наложением сопряжения механической связи следует обеспечить:

• неподвижность оси вращения кулачка в системе координат модели,

• постоянство ориентации толкателя по отношению к траектории его перемещения (это можно сделать разными способами, например, если толкатель имеет круглое сечение, установив соосность его с неподвижной осью).

Рабочие поверхности кулачка и толкателя автоматически приводятся в соприкосновение после наложения сопряжения Кулачок – толкатель путем перемещения толкателя вдоль его траектории. Нужно проследить, чтобы форма и взаиморасположение кулачка и толкателя, а также наложенные на них сопряжения не препятствовали этому. Накладывать на кулачок и толкатель сопряжение Касание не нужно.

Рекомендуется наложить на кулачок сопряжения, препятствующие его смещению вдоль оси вращения — для сохранения контакта кулачка с толкателем.

Таким образом, кулачок будет иметь одну степень свободы вращения вокруг оси, а толкатель — одну степень свободы поступательного движения; наличие у толкателя степени свободы вращения вокруг траектории не имеет значения.

После наложения сопряжения Кулачок –толкатель вращение кулачка будет приводить к перемещению толкателя. Передача движения в обратном направлении — от толкателя к кулачку — в сопряжении Кулачок –толкатель не предусмотрена.


2.11.5.3.2. Общие приемы создания сопряжений механической связи

Для создания сопряжения вызовите команду, соответствующую нужному типу сопряжения.

Укажите в Дереве построения или в окне модели первый из сопрягаемых объектов. Затем укажите ось, вокруг которой происходит вращение этого объекта, или траекторию, задающую направление перемещения объекта.

Произведите аналогичные указания для второго объекта.

Для сопряжения Кулачок – толкатель имеются некоторые особенности в выборе объектов. Они описаны в разделе 2.11.5.3.5.

После указания объекты подсвечиваются, а их наименования появляются в соответствующих полях Панели свойств.

Указание объектов, осей или траекторий производится при нажатом переключателе, который находится рядом с полем объекта на Панели свойств.

Нажатие кнопки Указать заново на Панели специального управления позволяет отменить текущее указание объекта.

При необходимости измените относительное направление перемещения объектов. Подробно о выборе направлений рассказано ниже.

Задайте соотношение перемещений в поле Соотношение в зависимости от типа передачи. Значение вводится с клавиатуры или выбирается из раскрывающегося списка соотношений, ранее использованных в текущем сеансе работы КОМПАС-3D.

После задания параметров подтвердите создание сопряжения.

Выбор объектов

Пары объектов обычно составляются из компонентов, причем один из них может быть зафиксирован. Кроме того, возможно сопряжение компонента с другим объектом модели.

Для указания осей вращения и траекторий перемещения могут быть выбраны следующие объекты.

– Прямолинейные (сегменты ломаных, координатные и вспомогательные оси, прямолинейные ребра).

Осью или траекторией является прямая, совпадающая с объектом.

– Плоские кривые (дуги, ребра в виде окружностей).

Осью или траекторией является прямая, проходящая через центр указанного объекта перпендикулярно его плоскости.

– Грани поверхностей вращения (цилиндрические, конические, тороидальные).

Осью или траекторией является ось вращения.

При указании некоторых элементов, наряду с объектом, которому они принадлежат, по умолчанию выбирается ось или траектория движения. Ее наименование появляется в соответствующем поле (Ось, Ось 1, Ось 2, Траектория) на Панели свойств.

Например, для выбора участвующей в сопряжении детали было указано ее ребро. В поле Компонент появляется наименование детали, а в поле Траектория — наименование указанного ребра.

Величина перемещения вдоль траектории не ограничивается длиной указанного объекта.

Направление перемещения

При указании оси или траектории система автоматически задает направление движения объектов в передаче. В окне модели направление вращения обозначается круговыми стрелками, а направление перемещения — прямой.

Направления, заданные автоматически, можно изменить при помощи переключателей групп Направление 1 — для первого объекта и Направление 2 — для второго.

Имеет значение только относительное направление движения сопрягаемых объектов — при просмотре работы передачи объект можно перемещать мышью как в прямом, так и в обратном направлении. При этом направления движения объектов или совпадают с заданными при создании, или оба им противоположны.

Например, чтобы колеса в зубчатой передаче вращались навстречу друг другу, объектам следует задать противоположные направления (у одного объекта должен быть нажат переключатель Прямое направление, у другого — Обратное направление).


2.11.5.3.3. Сопряжение Вращение – вращение

Сопряжение служит для визуализации движения в моделях зубчатых, ременных, цепных, фрикционных передач и других. Чтобы создать это сопряжение, вызовите команду Вращение – вращение.

Рис. 2.11.16. Пример применения сопряжений вращения

Укажите первый объект и ось, вокруг которой будет происходить вращение, а затем — второй объект и его ось вращения.

Сопрягаемые объекты можно указать, выделив их перед вызовом команды.

Задайте направление и соотношение перемещений.

Соотношение перемещений определяет отношение числа оборотов первого объекта к числу оборотов второго объекта. Соотношение определяется по аналогии с передаточным числом зубчатой передачи. Соотношение 1:2 означает, что за один оборот первого объекта второй объект совершает 2 оборота.

Если один объект неподвижен, то расчет соотношения производится аналогично. Например, из двух сопряженных колес одно неподвижно. В этом случае подвижное колесо совершает сложное вращательное движение — вращение вокруг своей оси с одновременным вращением вокруг неподвижного колеса. Соотношение равно отношению числа оборотов подвижной оси вокруг неподвижной к числу оборотов подвижного колеса вокруг своей оси.

При указании поверхности вращения в поле Соотношение по умолчанию заносится величина ее радиуса.

Для двух поверхностей вращения выбор всех параметров можно сделать, щелкнув мышью по этим поверхностям.

В примере, показанном на рисунке 2.11.16, можно наложить два сопряжения вращения — между колесами 1 и 2 и между колесами 3 и 4.

Сопряжение невозможно наложить на пару объектов, находящихся на одной оси вращения. На рисунке 2.11.16 такими объектами являются колеса 2 и 3.


2.11.5.3.4. Сопряжение Вращение – перемещение

Сопряжение служит для визуализации движения в моделях зубчато-реечных передач, передач винт-гайка и других. Чтобы создать это сопряжение, вызовите команду Вращение – перемещение.

Рис. 2.11.17. Пример применения сопряжения Вращение – перемещение

Укажите первый объект и ось, вокруг которой будет происходить вращение, а затем — второй объект и траекторию, задающую направление его перемещения.

Сопрягаемые объекты можно указать, выделив их перед вызовом команды.

Задайте направление и соотношение перемещений.

Соотношение перемещений определяет отношение длины окружности единичного радиуса, равной 2p (мм), к линейному перемещению второго объекта.

Соотношение 1:2 означает, что за один оборот первого объекта второй объект перемещается на 2 · 2p (мм), то есть около 13 мм.

Если один объект неподвижен, то расчет соотношения производится аналогично. Например, рейка неподвижна, а колесо радиуса R (мм) катится по ней без скольжения. За один оборот колеса рейка перемещается относительно центра колеса на 2pR. Соотношение перемещений равно 1:R.

Вы можете рассчитать требуемое соотношение, используя формулу 1:(L/2p).

Здесь L — расстояние в миллиметрах, на которое должен переместиться второй объект за один оборот первого объекта.


2.11.5.3.5. Сопряжение Кулачок – толкатель

Сопряжение служит для визуализации движения в кулачковом механизме. Чтобы создать это сопряжение, вызовите команду Кулачок – толкатель. Кулачок совершает вращательное движение, а толкатель — возвратно-поступательное. При этом рабочая поверхность толкателя остается в контакте с рабочей поверхностью кулачка.

Рис. 2.11.18. Пример применения сопряжения Кулачок – толкатель

Объекты сопряжения

Объекты для сопряжения выбираются таким образом, что один из них служит кулачком, вращающимся вокруг оси, другой — толкателем, перемещающимся вдоль прямолинейной траектории. Конструкция механизма должна обеспечивать контакт кулачка и толкателя в пределах их рабочих поверхностей.

Модель кулачка должна являться однотельной деталью.

Рабочая поверхность кулачка может состоять из одной или нескольких граней — плоских, цилиндрических, конических, тороидальных. Кроме того, рабочая поверхность кулачка может представлять собой линейчатую поверхность, эскиз которой состоит из отрезков, дуг, дуг эллипсов, сплайнов.

Для указания оси вращения кулачка могут быть выбраны следующие объекты.

– Прямолинейные (сегменты ломаных, координатные и вспомогательные оси, прямолинейные ребра).

Осью является прямая, совпадающая с объектом.

– Плоские кривые (дуги, ребра в виде окружностей).

Осью является прямая, проходящая через центр указанного объекта по нормали к его плоскости.

– Грани поверхностей вращения (цилиндрические, конические, тороидальные).

Осью является ось вращения.

Рабочая поверхность толкателя — плоская или сферическая грань. В сопряжении участвует поверхность, полученная продолжением указанной грани — плоскость или полная сфера.

Объектом, являющимся рабочей поверхностью, также может служить вершина в детали толкателя.

Если рабочая поверхность толкателя — плоская, то рабочей поверхностью кулачка может служить только цилиндрическая, коническая или линейчатая поверхности. При этом кулачок и толкатель должны быть так ориентированы друг относительно друга, чтобы их касание происходило по прямой линии.

В качестве траектории толкателя могут быть указаны прямолинейные объекты (сегменты ломаных, координатные и вспомогательные оси, прямолинейные ребра). Перемещение толкателя происходит вдоль выбранной траектории.

Создание сопряжения

При нажатой кнопке Грани кулачка укажите последовательно те грани рабочей поверхности кулачка, которые будут использованы в сопряжении. Количество граней появляется в поле Грани кулачка.

Нажмите кнопку Ось и укажите ось, вокруг которой вращается кулачок. Наименование появляется в поле оси.

Если грани рабочей поверхности кулачка гладко сопрягаются друг с другом, то при включенной опции По касательной указание одной из граней объекта влечет за собой автоматическое указание смежных с ней граней. Выбираются только те грани, которые стыкуются по отрезкам прямых, параллельных оси кулачка.

Нажмите кнопку Грань толкателя и укажите рабочую грань или вершину толкателя.

Нажмите кнопку Траектория и укажите траекторию, в направлении которой перемещается толкатель. Наименование появляется в поле траектории.

После указания оси или траектории система автоматически определяет направление вращения или перемещения вдоль траектории. В окне модели направление вращения обозначается круговыми стрелками, а направление перемещения — прямой. Рабочие поверхности кулачка и толкателя приходят в контакт.


2.11.5.3.6. Просмотр работы сопряжений

Чтобы проверить или продемонстрировать работу сопряжения, следует привести в движение один из компонентов, участвующих в сопряжении. Это движение должно выполняться в соответствии с теми параметрами, которые были заданы при создании сопряжения. Другими словами, для вращения необходимо выбирать ось, а для перемещения — направление, заданные при создании сопряжения. Это движение будет инициировать перемещение сопряженного объекта — ответное перемещение. Ответное перемещение объектов, в свою очередь, может инициировать перемещения других сопряженных с ними объектов и т.д.

Чтобы привести компонент в движение, используйте следующие команды:

– Переместить компонент (см. раздел 2.11.4.1),

– Повернуть компонент (см. раздел 2.11.4.2).

Инициирующее движение может являться составляющей сложного движения компонента. Например, для просмотра сопряжения Вращение – перемещение можно использовать вращение вокруг оси с помощью команды Повернуть компонент. При перемещении рейки мышью (см. рис. 2.11.17) инициирующим перемещением будет являться линейная составляющая вращения рейки. Воспринимается та линейная составляющая, которая сонаправлена с траекторией, заданной в сопряжении.

Если движение объекта не является инициирующим и не имеет ни одной инициирующей составляющей, то ответное движение сопряженных объектов не происходит.

В текущей модели возможен просмотр только тех сопряжений, которые наложены на компоненты и объекты этой модели.

При просмотре сопряжений необходимо учитывать следующие обстоятельства.

– Позиционирующие сопряжения могут препятствовать изменению положения объектов.

– Чтобы вращательное движение было инициирующим, необходимо, чтобы выбранная для выполнения команды поворота ось совпадала с заданной в сопряжении механической связи. Если в сопряжении ось была выбрана автоматически при указании элемента объекта, то ее следует построить, например, как вспомогательный объект.

– Направление инициирующего движения может как совпадать с заданным в команде, так и быть ему противоположным. Все звенья механических передач будут перемещаться в соответствии с относительными направлениями, заданными при создании сопряжений.

– Вращение компонента или его перемещение вдоль траектории не ограничено. Чтобы предотвратить «внедрение» одного компонента в другой, просмотр можно производить в режиме контроля соударений.

О режиме контроля соударений рассказано в разделе 2.11.4.3.2.

– Если задающий направление перемещения объект, например, ребро, принадлежит подвижному компоненту, то и траектория будет изменять свое положение в пространстве согласно условиям сопряжения.

– Может быть создано сопряжение подвижного объекта с неподвижным. В этом случае подвижный объект — если его движению не препятствуют позиционирующие сопряжения — будет совершать сложное вращательное или вращательно-поступательное движение относительно неподвижного.

– Для просмотра работы передачи Вращение – перемещение важно, чтобы при создании сопряжения было задано соотношение, отображающее реальное перемещение объектов. Способ расчета соотношения приведен в разделе 2.11.5.3.4.

– Просмотр работы передачи Кулачок – толкатель возможен только при приведении в движение кулачка. Связанное движение происходит только в пределах граней, указанных в качестве его рабочей поверхности. Грани поверхности кулачка, не указанные в данном сопряжении, могут терять контакт с толкателем.

– При просмотре работы передачи Кулачок – толкатель видимого контакта может не наблюдаться, так как рабочей поверхностью толкателя является вся сферическая поверхность либо плоскость грани.


2.11.6. Булевы операции над деталями

2.11. Компоненты

2.11.6. Булевы операции над деталями

Детали (в том числе локальные детали), являющиеся компонентами одной и той же сборки (*.a3d), можно «вычитать» друг из друга, а также «склеивать».

Булевы операции над деталями производятся во время редактирования их в контексте сборки.

Результат булевой операции вычитания — модификация тела детали путем удаления из него областей пересечения с телами или компонентами других деталей. Компоненты детали не модифицируются булевой операцией вычитания, даже они пересекаются с вычитаемыми деталями. Результат вычитания хранится в той детали, из которой вычитались другие детали.

Результат булевой операции объединения — тело, объединяющее тела других деталей или их компонентов. Этот результат записывается в новый файл детали или в новую локальную деталь.

Тело может участвовать в булевой операции только при условии, что в содержащей его детали нет других тел.

Результат булевой операции сохраняет связь с деталями, участвовавшими в этой операции. Так, например, изменение формы вычитаемой детали приводит к изменению формы полости, получившейся в результате вычитания. Удаление из сборки детали, задействованной в булевой операции, влечет за собой удаление и этой операции.

В этом разделе:

2.11.6.1. Вычитание

2.11.6.2. Объединение


2.11.6.1. Вычитание

Вычитание позволяет образовать в детали полость, имеющую форму другой детали. Чтобы вычесть одну или несколько деталей из другой детали, войдите в режим контекстного редактирования детали, в которой требуется сделать полость. Для этого выделите деталь в Дереве построения и вызовите из контекстного меню команду Редактировать на месте.

Вызовите команду Операции — Вычесть компоненты. Кнопка для вызова этой команды находится на панели Редактирование детали.

Укажите детали, которые необходимо вычесть из редактируемой.

Выбранные детали подсвечиваются в окне модели. Соответствующие им пиктограммы выделяются цветом в Дереве построения. Названия этих деталей отображаются в таблице Список компонентов на Панели свойств.

Если требуется, чтобы размеры создаваемой полости отличались от размеров вычитаемой детали, введите в поле Коэффициент коэффициент линейного расширения полости в процентах. Для увеличения размеров полости значение коэффициента должно быть положительным, для уменьшения — отрицательным.

Полость увеличится по сравнению с вычитаемой деталью в (1 + k/100) раз, где k — заданный коэффициент. По умолчанию центром масштабирования полости является центр габаритного параллелепипеда вычитаемой детали. При необходимости вы можете задать центр масштабирования явно. Для этого укажите нужную точку в окне модели мышью. Чтобы отказаться от использования этой точки в качестве центра масштабирования, укажите ее заново.

Подтвердите выполнение операции. В текущей детали будет образована полость, имеющая заданные форму и размеры.

Расположение и форма вычитаемой детали могут быть таковы, что в результате вычитания образуется тело, состоящее из нескольких частей (см. раздел 2.3.11).

На ветви Дерева построения, соответствующей текущей детали, появится пиктограмма операции вычитания компонентов.

Завершив создание или редактирование детали, выйдите из режима контекстного редактирования.

При необходимости вы можете скрыть или исключить из расчета детали, использовавшиеся для образования полости.


2.11.6.2. Объединение

Работая со сборкой, вы можете «склеить» несколько имеющихся деталей, получив из них одну. Например, это может потребоваться для объединения спроектированных деталей в единую литую раму, исходя из возникших в процессе проектирования новых технологических требований.

Чтобы объединить несколько имеющихся в сборке деталей, создайте в сборке новую деталь. Для этого из меню Операции — Создать вызовите команду Деталь или Локальную деталь.

Система перейдет в режим редактирования детали.

Вызовите команду Операции — Объединить компоненты. Кнопка для вызова этой команды находится на панели Редактирование детали.

Укажите детали, которые необходимо объединить. Для выполнения операции необходимо, чтобы эти детали пересекались друг с другом или имели совпадающие грани.

Выбранные детали подсвечиваются в окне модели. Соответствующие им пиктограммы выделяются цветом в Дереве построения. Названия этих деталей отображаются в таблице Список компонентов на Панели свойств.

Подтвердите выполнение операции. В окне модели появится тело новой детали, являющееся объединением указанных деталей сборки, а в Дереве построения — соответствующая пиктограмма.

Приемы работы с полученным телом не отличаются от приемов работы с любой другой деталью. Вы можете приклеивать и вырезать формообразующие элементы, создавать скругления, уклоны и т.д.

Завершив создание детали, выйдите из режима контекстного редактирования.

При необходимости вы можете скрыть или исключить из расчета детали, объединением которых является новая деталь.


2.11.7. Редактирование компонентов

2.11. Компоненты

2.11.7. Редактирование компонентов

Компоненты являются самостоятельными моделями, вставленными в текущую модель.

Чтобы изменить геометрию компонента, нужно либо открыть его в отдельном окне (см. раздел 2.11.7.1), либо перейти в режим контекстного редактирования этого компонента (см. раздел 2.11.7.2). После этого можно использовать любые приемы редактирования, описанные в разделе 2.14.3.

Обратите внимание на то, что редактирование в отдельном окне доступно для компонента, являющегося деталью, подсборкой или заготовкой, вставленной с историей. Локальную деталь и заготовку без истории можно редактировать только в контексте текущей модели.

Завершив редактирование компонента, закройте его окно либо выйдите из режима контекстного редактирования. Отредактированные компоненты обычно отмечаются в Дереве модели красной «галочкой». Это свидетельствует о необходимости перестроения модели. Чтобы перестроить модель, вызовите команду Вид — Перестроить. Подробнее о перестроении модели см. раздел 2.14.3.7.

При необходимости вы можете отредактировать свойства компонента (см. раздел 2.11.7.4). При этом доступны следующие действия:

– изменение свойств компонента, в том числе цвета и оптических свойств,

– управление фиксацией и состоянием компонента (включением компонента в расчет),

– задание параметров расчета МЦХ компонента и выполнение расчета,

– выбор другого файла — источника компонента,

– пересчет размеров компонента с учетом назначенных допусков.

Кроме того, вы можете изменить положение компонента в модели (см. раздел 2.11.7.3). В рамках этого процесса доступны следующие действия:

– задание положения компонента различными способами,

– управление фиксацией и состоянием компонента (включением компонента в расчет),

– изменение цвета и оптических свойств компонента,

– управление созданием объекта спецификации,

– выбор значений внешних переменных компонента.

В этом разделе:

2.11.7.1. Редактирование геометрии компонента в окне

2.11.7.1.1. Сохранение компонента под другим именем

2.11.7.2. Редактирование геометрии компонента «на месте»

2.11.7.2.1. Работа в режиме контекстного редактирования

2.11.7.3. Изменение положения компонента

2.11.7.4. Изменение свойств компонента

2.11.7.4.1. Изменение источника компонента

2.11.7.5. Особенности работы с локальной деталью и деталью-заготовкой без истории


2.11.7.1. Редактирование геометрии компонента в окне

Чтобы начать редактирование компонента в отдельном окне, содержащем только этот компонент (без остальных компонентов), выделите нужный компонент в Дереве построения и вызовите из контекстного меню команду Редактировать в окне. Предварительно рекомендуется сохранить текущую модель.

Перейти к редактированию компонента в окне можно, открыв содержащий его файл обычным способом: вызвать команду Файл — Открыть и выбрать нужный файл. При использовании команды Редактировать в окне не требуется искать нужный файл в папках на диске — система находит его автоматически.

После вызова команды Редактировать в окне откроется файл — источник этого компонента. Внесите в модель необходимые изменения и сохраните ее. Затем закройте окно компонента или перейдите в окно содержащей его модели.

Во время редактирования компонента «в окне» на экране отображаются все объекты, принадлежащие этому компоненту, и все они доступны для редактирования (вы можете изменять параметры объектов, их опорные объекты и т.д.). Однако редактирование некоторых объектов ограничено. К ним относятся те объекты компонента, которые были созданы в контексте содержащей его модели с использованием других компонентов этой модели (т.е. с использованием объектов, непосредственно не принадлежащих редактируемому компоненту), например, вспомогательная плоскость компонента, проходящая через ребра и/или вершины других деталей и т.п.

В файле компонента, содержащего объекты, определенные в контексте содержащей его модели, формируются ссылки на файл этой модели (так как он является внешним по отношению к файлу компонента, эти ссылки называются внешними). При редактировании такого компонента в отдельном окне существует лишь возможность переопределить внешние ссылки на внутренние. Другими словами, вы можете указать для построения объекта, ссылающегося на объекты из внешнего файла, другие объекты — находящиеся в текущем файле. Отредактированный таким образом объект теряет связь с внешним файлом.

Если же требуется, чтобы объект компонента, определенный в контексте содержащей компонент модели, не терял связи с ней, его необходимо редактировать в контексте этой модели («на месте»).

В этом разделе:

2.11.7.1.1. Сохранение компонента под другим именем


2.11.7.1.1. Сохранение компонента под другим именем

Если одновременно открыты файл модели, в которую вставлен компонент, и файл — источник компонента, то при попытке сохранить файл компонента под другим именем или в другой папке система выдает запрос об изменении ссылки на компонент.

– Если требуется, чтобы модель ссылалась на файл компонента с новым именем, нажмите кнопку Изменить ссылки. Это может понадобиться, например, для включения в модель отредактированного компонента и сохранения его первоначального варианта.

– Если требуется, чтобы модель ссылалась на файл компонента с прежним именем, нажмите кнопку Сохранить ссылки. Это может понадобиться, например, для сохранения отредактированного компонента без передачи его изменения в содержащую его модель. Обратите внимание на то, что в этом случае после окончания редактирования компонента модель, в которую он входит, следует закрыть без сохранения.

Ссылки изменяются лишь в открытых на данный момент моделях. В моделях, имеющих ссылки на этот же файл компонента, но закрытых в момент его сохранения под другим именем, ссылки не изменяются.


2.11.7.2. Редактирование геометрии компонента «на месте»

Редактирование «на месте» (в контексте) — это редактирование компонента в окне модели, которой он принадлежит. При этом в окне видны все остальные компоненты («окружение» или «обстановка»), доступны команды сдвига и поворота всей модели, изменения ее масштаба, ориентации и типа отображения.

«На месте» особенно удобно редактировать те объекты компонента, при построении которых использовалось «окружение» (например, элемент, выдавленный до грани соседней детали или вспомогательную ось, проходящую через начало координат другого компонента). Другими словами, объекты компонента, которые создавались в контексте модели, содержащей компонент, рекомендуется редактировать в контексте этой же модели.

При редактировании «на месте» изменения вносятся непосредственно в файл компонента (детали или подсборки) — так же, как если бы этот файл был открыт в отдельном окне. После завершения редактирования на экране появляется запрос на сохранение файла компонента.

При редактировании локальной детали или заготовки без истории запрос не выдается, так как она хранится не во внешнем файле, а в файле содержащей ее модели.

В этом разделе:

2.11.7.2.1. Работа в режиме контекстного редактирования


2.11.7.2.1. Работа в режиме контекстного редактирования

Чтобы начать редактирование компонента в окне текущей модели, выделите нужный компонент в Дереве построения и вызовите из контекстного меню команду Редактировать на месте. Кнопка для вызова этой команды находится на панели Текущее состояние.

Система перейдет в режим редактирования компонента.

Пиктограмма редактируемого компонента в Дереве построения из синей превратится в желтую, а пиктограмма содержащей его модели, наоборот, из желтой в синюю. Это говорит о том, что текущим документом стал компонент.

Признаком того, что режим контекстного редактирования включен, является отображение нажатой кнопки Редактировать на месте, а также значка режима контекстного редактирования в окне модели.

Все команды построения и редактирования в этом режиме распространяются только на указанный компонент. Остальные компоненты модели недоступны для редактирования (служат «обстановкой»), но их можно использовать при выполнении команд (указывать грани, ребра, вершины).

Вы можете изменить цвет, который используется для отображения компонентов, составляющих «обстановку», или отключить изменение цвета этих компонентов (см. раздел 9.1.11.8).

Приемы создания/редактирования модели «на месте», в контексте содержащей ее модели, практически не отличаются от приемов создания/редактирования модели в отдельном окне. При работе с моделью вы можете, например, выполнять формообразующие операции, строить вспомогательные элементы, добавлять компоненты из файлов, создавать компоненты «на месте» и т.п. Дополнительной возможностью является использование при построении элементов «обстановки». Например, можно выдавить формообразующий элемент до грани другого компонента, провести ось через его вершины, создать эскиз на грани соседней детали (при работе со сборкой).

Чтобы завершить редактирование компонента «на месте», повторно вызовите команду Редактировать на месте, или отожмите кнопку Редактировать на месте, или щелкните мышью по значку режима контекстного редактирования в окне модели.

Система вернется в режим работы с основной моделью.


2.11.7.3. Изменение положения компонента

Чтобы изменить положение компонента в модели, выделите его в Дереве построения и вызовите команду Разместить компонент контекстного меню или Редактировать меню Редактор. На Панели свойств появятся вкладки Размещение и Свойства. На этих вкладках вы можете выполнить следующие действия.

– Вкладка Размещение

• Изменение положения компонента в модели (см. раздел 2.11.2.5.2). Набор элементов управления положением компонента зависит от выбранного способа размещения — По координатам или По сопряжениям. Элементы доступны, если фиксация компонента отключена.

Если компонент, положение которого требуется изменить, размещен в модели способом По сопряжениям, обратите внимание на следующую особенность.

В случае перехода на другой способ размещения (По координатам) созданные ранее сопряжения не удаляются из модели, а исключаются из расчета.

При необходимости вы можете включить эти сопряжения в расчет. При этом положение компонента изменится соответственно заданным сопряжениям.

• Включение/отключение фиксации компонента с помощью переключателей Фиксировать компонент и Не фиксировать компонент группы Фиксация.

– Вкладка Свойства

• Изменение цвета и оптических свойства компонента. Используемые для этого элементы управления описаны в разделе 2.14.2.

• Включение/отключение создания объекта спецификации с помощью соответствующей опции (для всех компонентов, кроме детали-заготовки).

• Включение компонента в расчет и исключение его из расчета. Для этого используются переключатели группы Состояние.

• Выбор новых значений внешних переменных модели, являющейся источником компонента, если она содержит таблицу переменных. Для этого требуется нажать кнопку Таблица переменных и выбрать нужную строку в появившейся на экране таблице.

Чтобы завершить изменение положения компонента, нажмите кнопку Создать объект на Панели специального управления.


2.11.7.4. Изменение свойств компонента

Чтобы изменить свойства компонента, выделите его в Дереве построения и вызовите из контекстного меню команду Свойства компонента. На Панели свойств появятся вкладки Свойства, Параметры МЦХ и Файл-источник. На этих вкладках вы можете выполнить следующие действия.

– Вкладка Свойства

• Изменение значений свойств компонента с помощью панели Список свойств (см. раздел 5.1.4.1.1).

• Изменение цвета и оптических свойства компонента. Используемые для этого элементы управления описаны в разделе 2.14.2.

• Включение/отключение фиксации компонента с помощью переключателей Фиксировать компонент и Не фиксировать компонент группы Фиксация.

• Включение компонента в расчет и исключение его из расчета. Для этого используются переключатели группы Состояние.

• Преобразование правосторонней системы координат компонента в левостороннюю и наоборот. Для выполнения преобразования включите опцию Инвертировать ось Z СК. Данное преобразование сохраняется только в модели, содержащей компонент, в модели — источнике компонента система координат остается без изменения.
Опция включается автоматически при вставке компонента в модель с левосторонней системой координат.

– Вкладка Параметры МЦХ

• Выбор способа определения МЦХ и задание свойств материала компонента с помощью панели Материал (см. раздел 2.14.6.3).

• Пересчет МЦХ. Выполняется нажатием кнопки Пересчитать МЦХ, после которого производится расчет массо-центровочных характеристик компонента при текущем значении параметров. По окончании расчета на экране появляется Информационное окно с результатами расчета.

– Вкладка Файл-источник

• Выбор для вставки другой модели, исполнения модели и/или дополнительного номера (см. раздел 2.11.7.4.1).

• Пересчет размеров компонента с учетом допусков. Для этого требуется нажать кнопку Пересчитать размеры и выбрать из раскрывающегося списка пересчетов нужный пересчет (о пересчетах см. раздел 2.10.3.1).

Чтобы завершить изменение свойств компонента, нажмите кнопку Создать объект на Панели специального управления. Изображение модели будет перерисовано и/или модель перестроится в соответствии с новыми свойствами компонента.

Обратите внимание на то, что модель необходимо перестроить, если:

– изменен файл-источник компонента, выбрано другое его исполнение или дополнительный номер,

– изменены размеры компонента с учетом полей допусков.

В этом разделе:

2.11.7.4.1. Изменение источника компонента


2.11.7.4.1. Изменение источника компонента

Если требуется выбрать другую модель в качестве источника компонента, на вкладке Файл-источник выполните следующие действия.

Нажмите кнопку Файл-источник.

В появившемся на экране диалоге открытия файлов выберите файл, содержащий нужную модель.

Если выбранная модель содержит исполнения и дополнительные номера, вы можете выбрать нужное исполнение и дополнительный номер с помощью соответствующих списков. Списки отображаются в диалоге при наличии в модели исполнений и дополнительных номеров.

Для завершения выбора модели нажмите кнопку Открыть. Полное имя модели появится в поле Файл-источник.

Если в дальнейшем потребуется перевыбрать исполнение и/или дополнительный номер модели, используйте списки Исполнение и Дополнительный номер, расположенные на вкладке Файл-источник. Списки отображаются на вкладке при наличии в модели исполнений и дополнительных номеров.

Для локальной детали и детали-заготовки, вставленной без истории, выбор другой модели невозможен, а выбор исполнения модели и дополнительного номера возможен только в том случае, если источником вставки была модель, содержащая исполнения и дополнительные номера.


2.11.7.5. Особенности работы с локальной деталью и деталью-заготовкой без истории

2.11.7.5. Особенности работы с локальной деталью
и деталью-заготовкой без истории

Можно выделить следующие особенности работы с локальной деталью и деталью-заготовкой, вставленной без истории, отличающие их от других компонентов.

– Пользователь может управлять отображением в Дереве построения объектов, из которых состоит локальная деталь или деталь-заготовка без истории. Для этого служат команды Показать состав и Скрыть состав в ее контекстном меню. По умолчанию показ состава вновь созданной локальной детали включен, а детали-заготовки без истории — отключен. Управление показом состава локальной детали или детали-заготовки без истории аналогично управлению показом состава макроэлемента (см. раздел 2.15.8.2).

– Локальная деталь и деталь-заготовка без истории не связаны с файлами *.m3d, а хранятся в текущей модели. Поэтому их можно редактировать только в контексте основной модели. В контекстных меню данных компонентов есть только команда Редактировать на месте, а команды Редактировать в окне нет. Редактирование «на месте» выполняется для локальной детали и детали-заготовки также, как для других компонентов (см. раздел 2.11.7.2), с единственным отличием: при выходе из режима редактирования не появляется запрос на сохранение файла.

– Локальная деталь и деталь-заготовка без истории всегда загружены полностью. Смена типа загрузки для них невозможна.

Остальные приемы работы — сдвиг и поворот, наложение сопряжений, задание свойств, управление доступом и другие — доступны в том же объеме, что и при работе с другими компонентами.


2.12. Сборка

В этом разделе:

2.12.1. Общие сведения

2.12.1.1. Настройки трехмерного редактора для работы с большой сборкой

2.12.1.2. Настройки для ассоциативных чертежей большой сборки

2.12.2. Частичная загрузка сборки

2.12.2.1. Типы загрузки компонентов

2.12.2.1.1. Полный

2.12.2.1.2. Упрощенный

2.12.2.1.3. Пустой

2.12.2.1.4. Габарит

2.12.2.1.5. Особенности компонентов с неполной загрузкой

2.12.2.1.6. Выбор типа загрузки компонента

2.12.2.2. Типы загрузки сборки

2.12.2.2.1. Системные типы загрузки

2.12.2.2.2. Пользовательские типы загрузки. Создание и удаление

2.12.2.2.3. Выбор типа загрузки сборки

2.12.2.2.4. Редактирование типов загрузки

2.12.2.3. Пароли типов загрузки

2.12.2.3.1. Установка, редактирование и удаление пароля типа загрузки

2.12.2.3.2. Иерархия защищенных типов загрузки

2.12.2.3.3. Редактирование и удаление пароля типа загрузки

2.12.3. Запрет на редактирование компонента

2.12.3.1. Сохранение запрета редактирования компонентов в типе загрузки сборки

2.12.3.2. Особенности работы с компонентами, имеющими запрет на редактирование

2.12.3.2.1. Особенности общего характера

2.12.3.2.2. Работа в Дереве построения модели

2.12.3.2.3. Выполнение операций и построение объектов

2.12.3.2.4. Массивы компонентов и вставки из одного источника

2.12.3.2.5. Сопряжения

2.12.3.2.6. Переменные

2.12.3.2.7. Объекты спецификации

2.12.3.2.8. Перестроение

2.12.3.2.9. Исполнения модели


2.12.1. Общие сведения

2.12. Сборка

2.12.1. Общие сведения

Сборка в КОМПАС-3D — трехмерная модель, объединяющая модели деталей, подсборок и стандартных изделий, и содержащая информацию о взаимном положении этих компонентов и зависимостях между параметрами их элементов.

Пользователь определяет состав сборки, внося в нее новые компоненты или удаляя существующие. Подробно о компонентах рассказано в разделе 2.11.

Выделяют два подхода к проектированию сборки, соответствующие двум способам добавления компонентов в сборку:

– Снизу вверх — в сборку вставляются уже готовые модели компонентов, разработанные независимо друг от друга;

– Сверху вниз — компоненты создаются в контексте сборки, при этом построение следующих может базироваться на предыдущих.

На практике чаще всего встречается смешанный способ проектирования, т.е. сочетание приемов двух названных способов. Дополнительно может применяться компоновочная геометрия — представленные в графическом виде исходные данные, используемые в качестве основы для создания геометрии компонентов, или своего рода «разметка» сборки, используемая для размещения компонентов. Если стоит задача смоделировать перемещение компонентов сборки, т.е. показать работу механизма, компоновочная геометрия может выступать в роли подвижного каркаса, приводящего в движение связанные с ним компоненты.

Подробнее о подходах к проектированию рассказано в Приложении VII. Там же приведены методики проектирования, реализуемые в рамках того или иного подхода. О работе с компоновочной геометрией см. раздел 2.8.6.

Если сборка достаточно велика, т.е. насчитывает более 1000 компонентов, ее проектирование обычно осуществляется несколькими разработчиками. Кроме того, компоненты большой сборки часто имеют довольно сложную геометрию.

В связи с этим при работе с большими сборками должно быть обеспечено следующее:

– оптимизация использования ресурсов компьютера,

– разграничение доступа к различным частям сборки при работе над ней нескольких разработчиков,

– защита результатов работы одного разработчика сборки от изменений другими разработчиками.

Удовлетворение вышеперечисленных требований возможно за счет:

– специальных настроек КОМПАС-3D, снижающих затраты ресурсов компьютера (см. раздел 2.12.1.1),

– наложения запрета на редактирование тех или иных компонентов сборки (см. раздел 2.12.3),

– создания типов загрузки сборки (см. раздел 2.12.2.2.2) и защиты их паролями (см. раздел 2.12.2.3).

Рекомендации по организации работы над сборкой нескольких разработчиков приведены в Приложении VII.

В 10 и последующих версиях КОМПАС-3D внутренняя структура файла модели была значительно доработана. Поэтому, если модель сборки создана в КОМПАС-3D версии 9 или более ранних, настоятельно рекомендуется сохранить сборку и ее компоненты в текущей версии.

В этом разделе:

2.12.1.1. Настройки трехмерного редактора для работы с большой сборкой

2.12.1.2. Настройки для ассоциативных чертежей большой сборки


2.12.1.1. Настройки трехмерного редактора для работы с большой сборкой

1. При работе с большими сборками используйте режим упрощенного отображения — это ускорит сдвиг и поворот модели. Настройте режим упрощенного отображения следующим образом.

– В диалоге настройки упрощения компонентов уменьшите уровень детализации и включите применение дополнительного режима для стандартных компонентов. Если стандартных компонентов в модели много, рекомендуется отключить их показ с помощью опции Скрыть.

– В диалоге прочих настроек режима упрощенного отображения включите все опции.

Подробно режим упрощенного отображения моделей описан в разделе 2.1.3.6.

По умолчанию режим упрощенного отображения модели включен; также включены все опции в диалоге прочих настроек режима упрощенного отображения.

2. Выключите все опции в диалоге настройки изменения ориентации (см. раздел 9.1.11.6). Это позволяет исключить дополнительные повороты и масштабирование модели.

3. Убедитесь, что опция Отображать у компонентов доступ Только чтение в диалоге настройки прав доступа отключена (см. раздел 9.1.4.2). При включенной опции увеличивается время открытия файла модели в связи с выполнением проверки на наличие у компонентов атрибута «только чтение».

4. Чтобы сократить время перерисовки модели после сдвига или поворота, выполните следующую настройку.

– С помощью команд меню Вид — Скрыть отключите отображение вспомогательных объектов сборки, которые не нужны для работы. Отображение в сборке большинства вспомогательных объектов компонентов отключено по умолчанию. При необходимости вы можете отключить отображение остальных объектов с помощью команд меню Вид — Скрыть в компонентах.

– Отключите полутоновое отображение с каркасом.

5. Чтобы быстро восстанавливать часто используемые положения модели, сохраните их как пользовательские ориентации (см. раздел 2.1.3.2.1).


2.12.1.2. Настройки для ассоциативных чертежей большой сборки

Чтобы ускорить построение в чертеже ассоциативных видов сборки, перед их созданием выполните следующую настройку в диалоге параметров нового вида для текущего чертежа (диалог вызывается командой Сервис — Параметры... — Текущий чертеж — Параметры документа — Вид):

– на вкладке Параметры отключите опции Скрытые и Библиотечные,

– на вкладках Линии и Элементы оформления отключите все опции.

Описанная настройка позволит получить в чертеже только линии видимого контура модели.

Изображения обозначений резьбы, а также скрытых и библиотечных компонентов можно включить на завершающей стадии работы с чертежом. Включение обозначений резьбы производится на вкладке Элементы оформления Панели свойств при редактировании вида; включение изображений компонентов — с помощью команды Показать из контекстного меню этих компонентов в Дереве чертежа.

Отображение невидимых линий, линий переходов и линий сгиба можно включить на вкладке Линии Панели свойств во время редактирования вида. Однако, при работе со сборками, содержащими более 1000 деталей, не рекомендуется включать передачу в вид невидимых линий — это приведет к значительному увеличению времени создания и перестроения видов.

В 10 и последующих версиях КОМПАС-3D внутренняя структура файла модели была значительно доработана. Поэтому, если модель сборки создана в КОМПАС-3D версии 9 или более ранних, настоятельно рекомендуется сохранить ее в текущей версии. Это ускорит построение видов и передачу значения массы из файла модели в основную надпись чертежа.


2.12.2. Частичная загрузка сборки

2.12. Сборка

2.12.2. Частичная загрузка сборки

Частичная загрузка сборки предполагает временное представление выбранных компонентов в упрощенном, выгруженном виде или в виде габаритных параллелепипедов.

Пользователь назначает типы загрузки компонентам (см. раздел 2.12.2.1.6), создавая тем самым тип загрузки сборки. Типы загрузки сборки — различные комбинации типов загрузки компонентов, сохраненные в этой сборке (см. раздел 2.12.2.2).

Тела, построенные в сборке, и имеющиеся в ней локальные детали не имеют типов загрузки. Они всегда полностью представлены в сборке.

Любое изменение типа загрузки сборки считается редактированием сборки, поэтому при ее закрытии выдается запрос на сохранение документа. Нажмите кнопку Да, чтобы сохранить файлы сборки и всех ее компонентов, или кнопку Нет, если сохранение документов не требуется.

В этом разделе:

2.12.2.1. Типы загрузки компонентов

2.12.2.1.1. Полный

2.12.2.1.2. Упрощенный

2.12.2.1.3. Пустой

2.12.2.1.4. Габарит

2.12.2.1.5. Особенности компонентов с неполной загрузкой

2.12.2.1.6. Выбор типа загрузки компонента

2.12.2.2. Типы загрузки сборки

2.12.2.2.1. Системные типы загрузки

2.12.2.2.2. Пользовательские типы загрузки. Создание и удаление

2.12.2.2.3. Выбор типа загрузки сборки

2.12.2.2.4. Редактирование типов загрузки

2.12.2.3. Пароли типов загрузки

2.12.2.3.1. Установка, редактирование и удаление пароля типа загрузки

2.12.2.3.2. Иерархия защищенных типов загрузки

2.12.2.3.3. Редактирование и удаление пароля типа загрузки


2.12.2.1. Типы загрузки компонентов

Типы загрузки компонента — способы загрузки компонента, различающиеся объемом данных, помещаемых в память компьютера — Полный, Упрощенный, Пустой, Габарит.

В этом разделе:

2.12.2.1.1. Полный

2.12.2.1.2. Упрощенный

2.12.2.1.3. Пустой

2.12.2.1.4. Габарит

2.12.2.1.5. Особенности компонентов с неполной загрузкой

2.12.2.1.6. Выбор типа загрузки компонента


2.12.2.1.1. Полный

При типе загрузки Полный компонент загружается обычным образом, т.е. виден в Дереве и в окне модели. Тип загрузки Полный не обозначается в Дереве специальным значком.

По умолчанию все создаваемые компоненты имеют тип загрузки Полный.


2.12.2.1.2. Упрощенный

При типе загрузки Упрощенный компонент загружается так, что он виден в Дереве построения и в окне модели, но в окне отображается без линий каркаса и с пониженной точностью (т.е. менее «гладким»).

Пиктограмма упрощенного компонента отмечается значком «облако».

Особенности компонентов с неполной загрузкой см. в разделе 2.12.2.1.5.


2.12.2.1.3. Пустой

При типе загрузки Пустой компонент не загружается. Он виден только в Дереве построения.

На пиктограмму выгруженного компонента накладывается полупрозрачный серый квадрат.

Особенности компонентов с неполной загрузкой см. в разделе 2.12.2.1.5.


2.12.2.1.4. Габарит

При типе загрузки Габарит компонент загружается так, что он виден в Дереве построения, а в окне модели отображаются только его габаритный параллелепипед. О настройке отображения габарита моделей см. раздел 9.1.11.13.

Пиктограмма компонента с типом загрузки Габарит отмечается значком «параллелепипед».

Особенности компонентов с неполной загрузкой см. в разделе 2.12.2.1.5.


2.12.2.1.5. Особенности компонентов с неполной загрузкой

Компоненты с неполной загрузкой (типы Упрощенный, Пустой, Габарит) имеют следующие отличия от полностью загруженных (тип Полный):

– просмотр состава компонента невозможен (отсутствует значок «+» слева от названия компонента),

– просмотр переменных компонента невозможен (отсутствует список переменных компонента в Окне переменных),

– внутренний объект спецификации, соответствующий компоненту, недоступен для редактирования в сборке.

Особенностью выгруженных компонентов (тип Пустой) является также то, что если хотя бы один такой компонент участвует в сопряжении, то это сопряжение блокируется. Редактирование и удаление заблокированного сопряжения невозможно. В Дереве построения заблокированное сопряжение отмечается пиктограммой-«замком». Для разблокирования сопряжения необходимо полностью загрузить участвующие в нем компоненты.

Компонент с неполной загрузкой автоматически загружается полностью при выполнении следующих действий:

– применение к компоненту любой операции (создание круглого отверстия на грани компонента, скругление ребер компонента и т.п.), а также редактирование этой операции;

– указание компонента для построения другого объекта (указание грани компонента для построения эскиза или придания толщины и т.п.), а также редактирование этого объекта;

– наложение на компонент сопряжения, а также редактирование этого сопряжения;

– указание компонента в качестве исходного объекта для массива компонентов, а также редактирование этого массива;

– перемещение компонента в структуре сборки;

– сдвиг или поворот компонента;

– вызов команды редактирования компонента в окне или на месте;

– смена файла-источника компонента.

В дальнейшем автоматически загруженный компонент можно выгрузить, упростить или задать габарит. Однако, следует иметь в виду, что полная загрузка компонента может быть автоматически восстановлена при перестроении сборки. Это происходит в следующих случаях:

– компонент является исходным объектом или экземпляром массива компонентов;

– к компоненту применена операция, результатом которой является создание или удаление граней и ребер (Фаска, Отверстие, Разбиение поверхности, Удалить грани и т.п.);

– компонент-подсборка загружается полностью при выполнения команд разнесения модели, за исключением типа загрузки компонента Упрощенный, при котором после разнесения или его отмены компоненты остаются упрощенными.


2.12.2.1.6. Выбор типа загрузки компонента

Выбор типа загрузки возможен для компонента, находящегося на любом уровне сборки.

Чтобы изменить тип загрузки выбранного компонента (детали или подсборки), вызовите команду Типы загрузки — Полный/Пустой/Упрощенный/Габарит (рис. 2.12.1) из контекстного меню или с панели Редактирование сборки.

Для компонента-подсборки вы можете выбрать тип загрузки, созданный в файле-источнике подсборки. Для этого выделите компонент-подсборку и вызовите команду Типы загрузки — Выбрать... из контекстного меню или нажмите кнопку Примененный тип загрузки на панели Текущее состояние. Подробно о типах загрузки сборки см. раздел 2.12.2.2.3.

Тип загрузки может быть изменен сразу у нескольких однотипных компонентов, всех объектов раздела Компоненты, всех компонентов подсборки, а также группы или ветви компонентов. Для этого выделите компоненты, раздел, группу и т.п. и вызовите команду, как описано выше.

Рис. 2.12.1. Выбор типа загрузки компонента

Изменение типа загрузки одного экземпляра массива распространяется на остальные экземпляры и исходный компонент.

Изменение типа загрузки одной вставки компонента (в том числе стандартного изделия) распространяется на все остальные вставки этого компонента в текущей сборке.

При изменении типа загрузки обратите внимание на следующее.

– Типы загрузки в порядке уменьшения детализации — Полный, Упрощенный, Габарит, Пустой.

Для компонентов возможна смена типа загрузки или на тип Полный, или на менее детальный по отношению к примененному.

Например, компоненты с типом загрузки Пустой или Габарит не могут быть загружены с типом Упрощенный. Для выполнения такой загрузки следует сначала компоненты загрузить полностью, а затем уже упрощенно.

– К компоненту, файл которого открыт в отдельном окне, нельзя применить тип загрузки, менее детальный, чем примененный в этом файле. Например, компонент-деталь невозможно выгрузить, если открыт его файл-источник.

– К компоненту-подсборке может быть применен любой из типов загрузки, ранее созданных в ее файле-источнике. Если для выполнения команды выбрано несколько компонентов-подсборок, то необходимо учитывать следующее:

• на Панели свойств доступны типы загрузки компонента-подсборки, указанного первым;

• тип загрузки применяется ко всем выбранным компонентам-подсборкам, имеющим в своих файлах тип загрузки с данным именем — при этом для каждой подсборки осуществляется индивидуальная загрузка, которая была выполнена при создании этого типа.

Компоненты-подсборки представляют собой ссылки на соответствующие файлы.

Поэтому при открытых файлах моделей любые изменения в типах загрузки (например, создание, редактирование или применение) в файле подсборки, передаются в содержащую ее сборку. И наоборот, если в сборке подсборка получает другой тип загрузки, то он будет автоматически применен и в файле подсборки.


2.12.2.2. Типы загрузки сборки

Тип загрузки сборки — это комбинация типов загрузки компонентов сборки (см. раздел 2.12.2.1).

Типы загрузки сборки подразделяются на системные и пользовательские.

В каждой сборке доступны системные типы загрузки: Полный, Пустой, Упрощенный, Габарит. При выборе одного из них все компоненты сборки получают одноименный тип загрузки (рис. 2.12.2, а).

Пользовательские типы загрузки создаются для сборки пользователем и хранятся в файле этой сборки. Пользовательские типы используются для того, чтобы загружать разные компоненты по-разному и/или запрещать их редактирование (рис. 2.12.2, б). О применении типов загрузки см. раздел 2.12.2.2.3.

Рис. 2.12.2. Примеры типов загрузки сборки: а) системного упрощенного, б) пользовательского
а) | б)

Один из имеющихся в сборке типов загрузки является примененным. По умолчанию это системный тип загрузки сборки — полный.

Примененный тип загрузки сборки отображается на панели Текущее состояние. Звездочка перед именем типа загрузки (рис.2.12.3) означает, что тип загрузки одного или нескольких компонентов отличается от примененного (т.е. был изменен пользователем, см. раздел 2.12.2.1.6, или произошла автоматическая смена неполной загрузки на полную, см. раздел 2.12.2.1.5).

Рис. 2.12.3. Отображение примененного типа загрузки

Использование неполной загрузки позволяет освободить ресурсы компьютера и ускорить тем самым работу с моделями больших сборок. Так, можно выбрать тип загрузки Полный лишь для той подсборки, с которой ведется работа в данный момент, и Пустой — для всех остальных компонентов. Если требуется видеть расположение этих компонентов в сборке, то можно применить для них тип загрузки Упрощенный или Габарит.

Применение неполной загрузки компонентов предпочтительнее, чем исключение компонентов из расчетов, так как не приводит к нарушению иерархических и ассоциативных связей между объектами модели.

Кроме того, компоненты с типом загрузки Упрощенный, Пустой и Габарит, в отличие от исключенных из расчета, передаются в ассоциативный чертеж модели так же, как и с типом загрузки Полный.

Любой тип загрузки сборки можно защитить паролем (см. раздел 2.12.2.3).

В этом разделе:

2.12.2.2.1. Системные типы загрузки

2.12.2.2.2. Пользовательские типы загрузки. Создание и удаление

2.12.2.2.3. Выбор типа загрузки сборки

2.12.2.2.4. Редактирование типов загрузки


2.12.2.2.1. Системные типы загрузки

Системные тип загрузки сборки — Полный, Пустой, Упрощенный или Габарит. Применение одного из них означает, что все компоненты сборки получают одинаковый тип загрузки. Например, тип загрузки сборки Упрощенный означает, что все компоненты в ней загружены упрощенно. О типах загрузки компонентов см. раздел 2.12.2.1.

По умолчанию к сборке применяется тип загрузки Полный.

Системные типы нельзя удалить из модели.


2.12.2.2.2. Пользовательские типы загрузки. Создание и удаление

Пользовательский тип загрузки сборки — это определенная комбинация типов загрузки ее компонентов. Кроме того, в пользовательском типе загрузки сохраняется информация о наличии у компонентов запрета на редактирование.

Можно создать несколько пользовательских типов загрузки для одной сборки. Все пользовательские типы загрузки хранятся в файле сборки.

Защита типов загрузки сборки паролями при условии, что разные пользовательские типы запрещают доступ к одним компонентам и разрешают доступ к другим, позволяет разграничить доступ к узлам большой сборки при организации коллективной работы над этой сборкой (см. Приложение VII).

Для перехода к управлению типами загрузки можно вызвать любую из команд:

– команду Типы загрузки из контекстного меню сборки;

– команду Примененный к сборке тип загрузки нажатием одноименной кнопки на панели Текущее состояние.

После вызова команды на Панели свойств появляются элементы управления, позволяющие создавать, редактировать, удалять типы загрузки (рис. 2.12.4).

Рис. 2.12.4. Панель свойств при работе с типами загрузки

В списке Тип загрузки отображаются типы загрузки сборки. Примененный тип загрузки отмечен маркером-«кружком» или звездочкой. Появление звездочки (*) вместо маркера в списке или в поле Примененный тип загрузки на панели Текущее состояние означает, что текущий набор типов загрузки компонентов отличается от примененного.

Создание типа загрузки

Чтобы создать пользовательский тип загрузки текущей сборки, выполните следующие действия.

1. Установите нужные типы загрузки для компонентов сборки (см. раздел 2.12.2.1.6).

2. При необходимости наложите запрет на редактирование тех или иных компонентов (см. раздел 2.14.2.1).

3. Вызовите команду работы с типами загрузки.

Загрузка или выгрузка компонентов, наложение или снятие запрета редактирования могут быть выполнены после вызова команды.

4. Нажмите кнопку Создать над списком Тип загрузки Панели свойств.

Рис. 2.12.5. Создание типа загрузки для текущей сборки

5. Введите название типа загрузки в поле Наименование диалога Создание типа загрузки. Название не должно совпадать с другим названием типа загрузки в текущей сборке.

Названия типов загрузки, созданных в файлах компонентов-подсборок, могут совпадать. Присвоение одинаковых имен используется для того, чтобы в сборке можно было одновременно загрузить компоненты-подсборки с необходимой для каждого из них загрузкой, определяемой настройками пользовательского типа загрузки с этим именем.

6. Если создаваемый тип загрузки требуется защитить паролем, введите пароль в поле Пароль и подтвердите его в появившемся диалоге.

Подробнее о защите типов загрузки паролем см. раздел 2.12.2.3.

7. Чтобы применить создаваемый тип загрузки к модели, включите опцию Применить к модели. Если опция выключена, то примененным типом загрузки остается тот же, что и до создания.

8. Закройте диалог кнопкой ОК.

9. Чтобы применить другой тип загрузки, выберите его и нажмите кнопку Применить на Панели специального управления.

10. Для выхода из команды нажмите кнопку Прервать команду.

Удаление типа загрузки

Чтобы удалить пользовательский тип загрузки текущей сборки, выполните следующие действия.

1. Вызовите команду работы с типами загрузки.

2. Выделите подлежащий удалению тип загрузки в списке Тип загрузки на Панели свойств.

3. Нажмите кнопку Удалить объект, расположенную над списком.

Выбранный тип загрузки исчезнет из списка.

При удалении примененного типа загрузки применяется предыдущий по списку тип загрузки.

4. Для выхода из команды нажмите кнопку Прервать команду на Панели специального управления.

Тип загрузки может быть защищен паролем, а несколько защищенных типов загрузки могут образовывать иерархические «цепочки» (см. раздел 2.12.2.3). Удаление защищенных типов загрузки имеет следующие особенности:

– удаление типа загрузки, не являющегося примененным или подчиненным ему, требует ввода пароля (соответствующий диалог появляется после нажатия кнопки Удалить объект),

– удаление примененного типа загрузки, входящего в «цепочку», но не являющегося первым в ней, невозможно (кнопка Удалить объект недоступна).


2.12.2.2.3. Выбор типа загрузки сборки

Тип загрузки сборки можно выбрать:

– перед открытием ее файла;

– во время работы со сборкой.

Для указания типа загрузки сборки перед ее открытием служит список Тип загрузки. Этот список появляется в диалоге открытия файлов при выборе файла сборки (*.a3d).

Список Тип загрузки содержит строки Полный, Пустой, Упрощенный, Габарит, а также названия пользовательских типов загрузки, если они имеются в выбранной для открытия сборке (рис. 2.12.6).

Рис. 2.12.6. Выбор типа загрузки при открытии сборки

Укажите нужный тип загрузки, а затем нажмите кнопку Открыть диалога открытия файла. Сборка будет открыта. Выбранный при открытии тип загрузки применяется к сборке. Это означает, что всем компонентам сборки будет назначен тип загрузки Полный, Пустой, Упрощенный, Габарит, а в случае выбора пользовательского типа загрузки сборки каждому компоненту будет назначен заданный для него тип загрузки.

Чтобы применить другой тип загрузки сборки во время работы с ней, выберите его из списка Примененный тип загрузки на панели Текущее состояние (рис. 2.12.7).

Рис. 2.12.7. Выбор типа загрузки для текущей сборки на панели Текущее состояние

Как и при открытии сборки, список содержит названия системных и пользовательских типов загрузки. Если нужный тип отсутствует в сборке, его можно создать и применить (см. раздел 2.12.2.2.2).

При выборе типа загрузки, защищенного паролем (см. раздел 2.12.2.3), на экране появится диалог ввода пароля, кроме случаев:

– когда один системный тип загрузки меняется на другой,

– когда выбираемый тип загрузки отмечен как примененный маркером-«кружком» или звездочкой,

– когда выбираемый тип загрузки является подчиненным по отношению к примененному.

Обратите внимание на то, что при загрузке файла сборки путем указания его имени в меню Файл выбор типа загрузки невозможен. Сборка открывается с тем типом загрузки, который был применен на момент ее сохранения. То же самое происходит при открытии подсборки текущей сборки с помощью команды Редактировать в окне.

Чтобы сменить тип загрузки компонента-подсборки на тип, созданный в его файле-источнике, выделите компонент в Дереве построения и нажмите кнопку Примененный к сборке тип загрузки на панели Текущее состояние. Укажите в списке Тип загрузки на Панели свойств и нажмите кнопку Применить на Панели специального управления.


2.12.2.2.4. Редактирование типов загрузки

При редактировании типа загрузки можно изменить:

– в системном типе — пароль и комментарий,

– в пользовательском типе — типы загрузки одного или нескольких компонентов, наименование типа загрузки, его пароль и комментарий, а также снять или наложить запрет на редактирование.

Чтобы отредактировать тип загрузки текущей сборки, выполните следующие действия.

1. Если редактируется состояние модели, измените загрузку компонентов (см. раздел 2.12.2.1.6). При необходимости наложите или снимите запрет на редактирование тех или иных компонентов (см. раздел 2.14.2.1).

2. Вызовите команду работы с типами загрузки, как при их создании (см. раздел 2.12.2.2.2).

Загрузка/выгрузка компонентов, наложение/снятие запрета редактирования могут быть выполнены после вызова команды.

3. Укажите в списке Тип загрузки редактируемый тип загрузки.

4. Нажмите кнопку Редактировать над списком Тип загрузки Панели свойств.

5. Введите пароль редактируемого типа загрузки, если он защищен паролем.

6. Измените параметры типа загрузки в диалоге Редактирование типа загрузки, как при создании. О редактировании пароля см. раздел 2.12.2.3.3.

7. Чтобы применить редактируемый тип загрузки к модели, включите опцию Применить к модели. Если опция выключена, то примененным типом загрузки остается тот же, что и до редактирования. О применении типа загрузки см. раздел 2.12.2.2.3.

8. Чтобы в редактируемый тип перешла информация о текущем состоянии модели — загрузке и запрете на редактирование компонентов модели, включите опцию Обновить по текущему состоянию модели. Если опция выключена, то информация не передается.

9. Закройте диалог кнопкой ОК.

10. Для выхода из команды нажмите кнопку Прервать команду на Панели специального управления.


2.12.2.3. Пароли типов загрузки

Вы можете установить пароли на системные и пользовательские типы загрузки сборки.

Тип загрузки, имеющий пароль, называется защищенным типом загрузки.

Запрос пароля производится при попытке выполнения следующих действий:

1. открытие защищенной сборки, открытие входящей в нее подсборки с защищенным типом загрузки с помощью команды Редактировать в окне или Редактировать на месте,

2. применение защищенного типа загрузки,

3. удаление или редактирование защищенного типа загрузки, не являющегося примененным,

4. снятие запрета на редактирование компонента, который был наложен в результате применения защищенного типа загрузки (запрет обозначен в Дереве значком «щит» серого цвета).

При вводе неверного пароля выполнение перечисленных действий блокируется.

Пароль системных типов загрузки может использоваться вместо пароля любого пользовательского типа загрузки.

Диалог запроса пароля представлен на рис. 2.12.8.

Рис. 2.12.8. Диалог запроса пароля типа загрузки

Поля Тип загрузки и Доступ доступны только в случае открытия сборки.

Из списка Тип загрузки можно выбрать другой тип загрузки. Если выбран незащищенный паролем тип загрузки, то поле Пароль становится недоступно.

Из списка Доступ можно выбрать вариант открытия файла: для редактирования или только для чтения.

Установка пароля на тип загрузки производится при его создании или редактировании.

Пароль редактируемого или применяемого типа загрузки не запрашивается, если ранее был введен пароль системных типов загрузки для снятия запрета на редактирование компонента (см. раздел 2.12.3.1).

В этом разделе:

2.12.2.3.1. Установка, редактирование и удаление пароля типа загрузки

2.12.2.3.2. Иерархия защищенных типов загрузки

2.12.2.3.3. Редактирование и удаление пароля типа загрузки


2.12.2.3.1. Установка, редактирование и удаление пароля типа загрузки

Условием задания пароля пользовательскому типу загрузки является наличие пароля у системных типов загрузки. Чтобы установить, отредактировать, удалить пароль, выполните следующие действия.

1. Вызовите команду работы с типами загрузки, как при их создании (см. раздел 2.12.2.2.2).

2. Выделите тип загрузки, который необходимо защитить паролем, в списке Тип загрузки на Панели свойств.

3. Нажмите кнопку Редактировать, расположенную над списком.

4. Чтобы установить пароль, введите его в появившемся диалоге в поле Пароль.

Пароль может содержать от 1 до 38 любых символов, в том числе пробелы.

Подтвердите пароль.

Чтобы сменить пароль, замените символы (*) в поле Пароль новой комбинацией символов.

Чтобы удалить пароль, удалите из поля Пароль все символы (*).

5. Закройте диалог ввода пароля кнопкой ОК.

Защищенный тип загрузки отмечается в списке значком «ключ».

При установке пароля на один из системных типов загрузки этот же пароль автоматически устанавливается на остальные системные типы загрузки.

6. Если необходимо, установите пароль на другие типы загрузки, повторив для них действия 2–5.

7. Для выхода из команды нажмите кнопку Прервать команду на Панели специального управления.

8. Сохраните файл сборки.

Если системные типы загрузки защищены, то ввод пароля для пользовательского типа загрузки возможен непосредственно при его создании (см. раздел 2.12.2.2.2) — для этого введите пароль в поле Пароль.

Защита паролем всех типов загрузки сборки при условии, что разные пользовательские типы запрещают доступ к одним компонентам и разрешают доступ к другим, позволяет разграничить доступ к узлам большой сборки при организации коллективной работы над этой сборкой (см. раздел см. Приложение VII).

В результате установки пароля на пользовательский тип загрузки могут формироваться иерархические «цепочки» (см. раздел 2.12.2.3.2).


2.12.2.3.2. Иерархия защищенных типов загрузки

Защищенные типы загрузки могут формировать иерархические «цепочки».

«Цепочка» образуется, если на момент создания нового защищенного типа загрузки (или на момент защиты пользовательского типа загрузки паролем) был применен другой защищенный тип загрузки. В этом случае создаваемый (или защищаемый) тип загрузки становится подчиненным по отношению к примененному, а он, в свою очередь, становится исходным по отношению к создаваемому (или защищаемому).

В списке типов загрузки (при работе с командой Типы загрузки) наименование подчиненного типа загрузки смещено вправо относительно наименования исходного (рис. 2.12.9).

Рис. 2.12.9. Иерархические «цепочки» защищенных типов загрузки

Удаление подчиненного типа загрузки или его пароля доступно только в случае, если применен исходный тип загрузки. Наименования типов загрузки, для которых невозможно удаление или отмена пароля при примененном типе загрузки, отображаются в списке типов загрузки на сером фоне (рис. 2.12.9).

Если пользовательский тип загрузки подчинен системному типу, то для его удаления достаточно, чтобы текущим был любой системный тип загрузки.

Если исходный тип загрузки «B» с подчиненным типом загрузки «С», в свою очередь, является подчиненным по отношению к типу загрузки «A», то тип загрузки «А» считается исходным по отношению к «B» и «C», а «B» и «C» — подчиненными по отношению к «А».


2.12.2.3.3. Редактирование и удаление пароля типа загрузки

Для удаления пароля выполните те же действия, что и для установки пароля на имеющийся в модели тип загрузки (см. раздел 2.12.2.3.1), но вместо ввода удалите все символы из поля Пароль в диалоге Редактирование типа загрузки.

Чтобы отредактировать пароль, введите в поле Пароль новые символы и подтвердите новый пароль.

Редактирование и удаление пароля примененного типа загрузки сборки и любого из подчиненных ему типов загрузки производится без запроса пароля.

При удалении пароля системных типов загрузки на экране появляется запрос на удаление паролей пользовательских типов загрузки. Вы можете подтвердить удаление или отказаться от него.


2.12.3. Запрет на редактирование компонента

2.12. Сборка

2.12.3. Запрет на редактирование компонента

По умолчанию все компоненты сборки доступны для редактирования, но если требуется, то редактирование какого-либо компонента можно запретить.

Запрет на редактирование означает, что набор действий с таким компонентом ограничен. Например, компонент нельзя редактировать, перемещать, разрушать, изменять тип загрузки и т.п. (об особенностях таких компонентов см. раздел 2.12.3.2).

Запрет на редактирование может быть наложен:

– «вручную» на каждый компонент в отдельности при помощи специальных команд (см. раздел 2.14.2.1);

– в результате применения пользовательского типа загрузки, содержащего информацию о запрете редактирования (о выборе типа загрузки см. раздел 2.12.2.2.3).

В процессе работы над сборкой запрет на редактирование можно неограниченно накладывать и снимать с компонентов.

Состояние модели, учитывающее разграничение доступа к редактированию компонентов, можно сохранить в пользовательском типе загрузки при его создании или обновлении (см. раздел 2.12.2.2.4).

Компоненты, добавленные в сборку после применения защищенного паролем типа загрузки, в других пользовательских типах загрузки автоматически получают запрет на редактирование.

В этом разделе:

2.12.3.1. Сохранение запрета редактирования компонентов в типе загрузки сборки

2.12.3.2. Особенности работы с компонентами, имеющими запрет на редактирование

2.12.3.2.1. Особенности общего характера

2.12.3.2.2. Работа в Дереве построения модели

2.12.3.2.3. Выполнение операций и построение объектов

2.12.3.2.4. Массивы компонентов и вставки из одного источника

2.12.3.2.5. Сопряжения

2.12.3.2.6. Переменные

2.12.3.2.7. Объекты спецификации

2.12.3.2.8. Перестроение

2.12.3.2.9. Исполнения модели


2.12.3.1. Сохранение запрета редактирования компонентов в типе загрузки сборки

2.12.3.1. Сохранение запрета редактирования компонентов
в типе загрузки сборки

Запрет редактирования компонента сохраняется в файле сборки, т.е. при открытии сборки те ее компоненты, которые были недоступны для редактирования во время последнего сохранения, остаются недоступными.

При необходимости информация о том, что редактирование определенного компонента (или компонентов) запрещено, может быть записана в пользовательский тип загрузки сборки. В результате применения к сборке такого типа загрузки меняются не только типы загрузки ее компонентов, но и доступ к их редактированию. Запись производится в момент создания либо обновления существующего типа загрузки. О создании типа загрузки см. раздел 2.12.2.2.2, о редактировании — 2.12.2.2.4.

После применения типа загрузки с информацией о запрете на редактирование компонентов в Дереве построения появляются обозначения:

– значки «щит» синего цвета — если применен не защищенный паролем тип загрузки;

– значки «щит» серого цвета — если применен защищенный тип загрузки (об установке пароля см. раздел 2.12.2.3).

Пользователь может снять запрет на редактирование выбранного компонента, например, при помощи команды Редактирование — Разрешено (см. раздел 2.14.2.1). Если компонент отмечен значком «щит» серого цвета, то для снятия запрета необходимо ввести пароль системного типа загрузки.

Удаление пароля типа загрузки не снимает запрет на редактирование с компонентов автоматически — значок «щит» остается серым.
Чтобы разрешить редактирование такого компонента, после удаления пароля вызовите команду Редактирование — Разрешено.

Чтобы записать запрет на редактирование в ранее созданный тип загрузки, выполните следующие действия.

1. Примените тип загрузки, в который требуется внести запрет редактирования. Например, выберите его из списка Примененный тип загрузки на панели Текущее состояние (см. раздел 2.12.2.2.3).

2. В модели наложите запрет редактирования компонентов.

3. Вызовите команду работы с типами загрузки (см. раздел 2.12.2.2.2).

Наложение/снятие запрета редактирования могут быть выполнены после вызова команды.

4. Вызовите команду Редактировать нажатием кнопки над списком. В диалоге включите опцию Обновить по текущему состоянию модели. Закройте диалог кнопкой ОК.

5. Сохраните сборку.

Разные пользовательские типы загрузки могут запрещать редактирование разных компонентов. Таким образом, используя защищенные пользовательские типы загрузки, можно разграничить доступ разных пользователей к разным компонентам сборки при коллективной работе.

Запись запрета редактирования компонентов в системный тип загрузки невозможна.

Поэтому после смены пользовательского типа загрузки системным доступ к редактированию компонентов не изменяется (т.е. те компоненты, которые были недоступны для редактирования, остаются недоступными).

Точно так же при открытии сборки с системным типом загрузки доступ к редактированию компонентов остается таким же, каким был при сохранении сборки (например, редактирование некоторых компонентов могло быть запрещено вручную или в результате применения пользовательского типа загрузки).


2.12.3.2. Особенности работы с компонентами, имеющими запрет на редактирование

2.12.3.2. Особенности работы с компонентами,
имеющими запрет на редактирование

В данном разделе перечислены ограничения, накладываемые на работу с компонентами сборки, имеющими запрет на редактирование.

В этом разделе:

2.12.3.2.1. Особенности общего характера

2.12.3.2.2. Работа в Дереве построения модели

2.12.3.2.3. Выполнение операций и построение объектов

2.12.3.2.4. Массивы компонентов и вставки из одного источника

2.12.3.2.5. Сопряжения

2.12.3.2.6. Переменные

2.12.3.2.7. Объекты спецификации

2.12.3.2.8. Перестроение

2.12.3.2.9. Исполнения модели


2.12.3.2.1. Особенности общего характера

Если редактирование компонента запрещено, то при работе с ним невозможно выполнение следующих действий:

• удаление из сборки каким бы то ни было способом,

• редактирование в окне и в контексте сборки,

• управление включением в расчет,

• редактирование свойств,

• разрушение (если компонент — подсборка),

• сдвиг и поворот,

• изменение типа загрузки,

• смена исполнения.


2.12.3.2.2. Работа в Дереве построения модели

Если редактирование компонента запрещено, то при работе с ним в Дереве построения действуют следующие ограничения.

– Недоступны команды контекстного меню, выполнение которых невозможно.

После вызова команды Свойства на Панели свойств присутствуют только вкладки Параметры МЦХ и Файл источник. Элементы управления вкладок недоступны.

– Компонент не включается в новую подсборку, получаемую объединением выделенных компонентов.

– Невозможен просмотр состава компонента.

– Невозможно редактирование наименования компонента.

– В подсборку, редактирование которой запрещено, невозможны копирование и перенос других компонентов.


2.12.3.2.3. Выполнение операций и построение объектов

– Если редактирование компонента запрещено, то к нему невозможно применение операций, результатом которых является создание или удаление граней и ребер (Фаска, Отверстие, Массив, Разбиение поверхности, Удалить грани и т.п.).

Если запрет на редактирование компонент получил после применения к нему операции, то эта операция блокируется. Для заблокированной операции невозможно:

• редактирование,

• непосредственное изменение значений переменных (возможно лишь получение переменными значений по ссылке или в результате вычисления выражений),

• удаление,

• управление включением в расчет,

• использование в качестве исходного элемента массива.

Заблокированные операции отмечаются в Дереве построения пиктограммой «замок» (рис. 2.12.10). Действие заблокированных операций на компонент, имеющий запрет на редактирование, сохраняется.

После снятия у компонента запрета на редактирование примененная к нему операция разблокируется.

Рис. 2.12.10. Объекты модели, заблокированные в результате
наложения запрета редактирования на один из компонентов

– Команды, которые не предполагают изменения граней и ребер, могут использовать компоненты, имеющие запрет на редактирование. Например, грань детали может служить основанием уклона в команде Уклон или исходной поверхностью в команде Придать толщину.

Кроме того, объекты, принадлежащие компоненту, редактирование которых запрещено, могут являться исходными для новых объектов. Например, грань детали можно использовать для создания эскиза или для простановки обозначения; точки, созданные в компоненте, можно использовать для построения вспомогательных осей и плоскостей и т.п.

Использование компонента, имеющего запрет на редактирование, для построения других объектов возможно при условии, что этот компонент имеет тип загрузки Полный.


2.12.3.2.4. Массивы компонентов и вставки из одного источника

– Создание массива компонентов, имеющих запрет на редактирование, невозможно.

– Если после создания массива хотя бы один из его исходных компонентов получил запрет на редактирование, то этот массив и его экземпляры блокируются (аналогично операции, примененной к компоненту, который получил запрет на редактирование, см. выше).

– Копии компонента, полученные как путем создания массива, так и путем повторной вставки, образуют группу в Дереве построения. В первом случае все компоненты группы автоматически получают или теряют запрет редактирования после назначения или отмены его для одного из компонентов группы. Во втором случае запрет редактирования необходимо накладывать или снимать для каждого компонента группы в отдельности.

Смена типа загрузки для одного компонента распространяется на все его вставки вне зависимости от того, имеют они запрет на редактирование или нет.


2.12.3.2.5. Сопряжения

– Компонент, имеющий запрет на редактирование, не может участвовать в сопряжениях.

– Если после создания сопряжения хотя бы один из участвующих в нем компонентов получил запрет редактирования, то это сопряжение блокируется (аналогично операции, примененной к компоненту, который получил запрет редактирования, см. выше).

Заблокированное сопряжение не работает.

– При удалении из сборки компонента, с которым сопряжен компонент с запретом редактирования, заблокированное сопряжение удаляется. После снятия этого запрета или после повторного открытия сборки местоположение компонента рассчитывается заново согласно оставшимся сопряжениям.

При удалении объекта, использованного для сопряжения (например, ребра), заблокированное сопряжение не удаляется, а отмечается как ошибочное.


2.12.3.2.6. Переменные

– Непосредственное изменение значений переменных компонента, имеющего запрет редактирования, невозможно.

– Переменные компонента, имеющего запрет редактирования, могут получать значения по ссылке или в результате вычисления выражений, в которых они участвуют.


2.12.3.2.7. Объекты спецификации

– Невозможно редактирование объекта спецификации компонента, имеющего запрет редактирования.

– Изменения в объекте спецификации компонента, имеющего запрет редактирования, передаются в сборку после снятия этого запрета у компонента или после повторного открытия сборки.


2.12.3.2.8. Перестроение

– Если отредактирован файл-источник компонента, имеющего запрет редактирования, то при открытии сборки его перестроение производится автоматически, без выдачи запроса на перестроение.

– Перестроение компонента, имеющего запрет редактирования, после изменения его исходных объектов или значений переменных производится обычным образом — по нажатию кнопки Перестроить.


2.12.3.2.9. Исполнения модели

Запрет на редактирование компонента передается из исходного исполнения содержащей компонент сборки в зависимые: если запрещено редактирование компонента, входящего в исходное исполнение, то редактирование соответствующего компонента в зависимом исполнении также запрещается. При этом значок «замок» рядом с обозначением компонента в Дереве построения зависимого исполнения заменяется значком «щит».

Отменить связь такого компонента с компонентом исходного исполнения сборки нельзя — команда Отменить связь контекстного меню компонента в Дереве исполнений недоступна.


2.13. Исполнения модели

В этом разделе:

2.13.1. Общие сведения об исполнениях

2.13.1.1. Основные понятия

2.13.1.2. Дерево исполнений

2.13.1.3. Исполнения в Менеджере документа

2.13.1.4. Общий порядок работы с исполнениями

2.13.1.5. Настройка исполнений

2.13.2. Создание исполнений

2.13.2.1. Обозначение и наименование исполнения

2.13.2.1.1. Диалог задания обозначения исполнения

2.13.2.2. Способы создания исполнения

2.13.2.2.1. Создание исполнения в Дереве исполнений

2.13.2.2.2. Создание исполнения в Менеджере документа

2.13.2.2.3. Использование списка исполнений другой модели

2.13.2.3. Изменение положения исполнения в списке исполнений

2.13.2.4. Удаление исполнения

2.13.3. Работа с исполнениями

2.13.3.1. Выбор текущего исполнения

2.13.3.2. Создание, редактирование и удаление объектов исполнения

2.13.3.3. Передача объектов в исполнения

2.13.3.4. Редактирование свойств исполнения

2.13.3.4.1. Особенности передачи изменений свойств между исполнениями

2.13.3.5. Использование переменных в исполнении

2.13.3.5.1. Пользовательская переменная в исполнении

2.13.3.5.2. Задание значений пользовательских переменных

2.13.3.5.3. Дополнительные возможности работы с переменными

2.13.3.5.4. Просмотр и назначение допусков при работе с переменными

2.13.3.6. Дополнительные номера исполнений

2.13.3.7. Сохранение модели с исполнениями

2.13.4. Зеркальные исполнения модели

2.13.4.1. Способы создания зеркальных исполнений

2.13.4.2. Особенности работы с зеркальными исполнениями

2.13.4.3. Изменение положения компонента в зеркальном исполнении

2.13.4.3.1. Изменение параметров отражения компонента

2.13.4.4. Замена компонента его зеркальным исполнением

2.13.5. Таблица исполнений

2.13.5.1. Создание таблицы

2.13.5.1.1. Связь основной надписи чертежа с ассоциативной таблицей исполнений

2.13.5.2. Настройка параметров таблицы

2.13.5.2.1. Настройка параметров отображения столбцов таблицы

2.13.5.3. Работа с таблицей

2.13.6. Спецификация по сборке с исполнениями

2.13.6.1. Создание спецификации по сборке с исполнениями

2.13.6.2. Компоненты с одинаковыми номерами позиций

2.13.6.2.1. Окно Группы компонентов

2.13.6.2.2. Формирование в сборке группы компонентов с одной позицией


2.13.1. Общие сведения об исполнениях

2.13. Исполнения модели

2.13.1. Общие сведения об исполнениях

В этом разделе:

2.13.1.1. Основные понятия

2.13.1.2. Дерево исполнений

2.13.1.3. Исполнения в Менеджере документа

2.13.1.4. Общий порядок работы с исполнениями

2.13.1.5. Настройка исполнений


2.13.1.1. Основные понятия

Документ-модель может содержать данные о нескольких вариантах построения модели, обладающих общими конструктивными признаками при некоторых различиях между собой. Эти варианты называются исполнениями модели (далее — исполнения).

Все исполнения модели содержатся в одном групповом документе в виде отдельных моделей.

Основное исполнение создается по умолчанию при создании модели. Это исполнение является исходным вариантом модели и используется для создания других исполнений этой модели.

Вы можете создать исполнение непосредственно из основного исполнения или использовать для создания другое исполнение, ранее созданное из основного. Исполнение, используемое для получения других исполнений, называется исходным.

В системе предусмотрена возможность создания зависимых и независимых исполнений. Зависимое исполнение имеет связь с исходным исполнением, независимое исполнение не имеет такой связи. Наличие связи определяется при создании исполнения и в дальнейшем не может быть изменено, т.е. нельзя сделать зависимое исполнение независимым и наоборот.

Объекты независимого исполнения доступны для самостоятельного редактирования и удаления. На них не влияют изменения соответствующих объектов исходного исполнения.

Объекты зависимого исполнения связаны с соответствующими объектами исходного исполнения. Изменение или удаление объектов исходного исполнения передается в зависимое.

При необходимости вы можете создать зависимые зеркальные исполнения (см. раздел 2.13.4).

Набор исполнений документа имеет графическое представление в виде Дерева исполнений, которое отображается на отдельной вкладке в окне Дерево модели. Вы можете работать с любым исполнением модели, сделав его текущим. При этом в окне модели и в Дереве построения модели будут отображаться объекты текущего исполнения.

Исполнение модели содержит постоянные и переменные данные. Постоянными являются данные, одинаковые для всех исполнений модели, содержащихся в одном документе. Переменные данные различны для разных исполнений.


2.13.1.2. Дерево исполнений

Дерево исполнений модели отображается на вкладке Исполнения в окне Дерево модели (рис. 2.13.1).

Рис. 2.13.1. Дерево исполнений модели

На первой позиции в дереве находится основное исполнение модели, на следующих позициях — остальные исполнения, зависимые и независимые. Все независимые исполнения расположены на первом уровне иерархии дерева. Зависимые исполнения подчинены тому исполнению, которое для них является исходным.

При необходимости вы можете скрыть зависимые исполнения, дважды щелкнув мышью по пиктограмме их исходного исполнения. Повторный двойной щелчок отобразит скрытые исполнения.

Каждое исполнение в Дереве исполнений имеет название и пиктограмму.

Название состоит из обозначения и наименования исполнения. Обозначение формируется при создании исполнения (см. раздел 2.13.2.2). Наименование по умолчанию совпадает с наименованием основного исполнения. И обозначение, и наименование исполнения можно изменить (см. раздел 2.13.3.4).

Обратите внимание на то, что в зависимости от настройки (см. раздел 9.2.7.4.14) в названии исполнения могут отображаться обозначение и наименование или только наименование. В последнем случае обозначение исполнения сохраняется в системе, но не отображается в Дереве исполнений.

Пиктограммы исполнений отображаются в Дереве исполнений синим цветом. Если исполнение является текущим, то его пиктограмма имеет желтый цвет.

Если исполнение является зависимым, то его объекты связаны с соответствующими объектами исходного исполнения. Связанный объект в Дереве построения отмечается значком «замок». Это означает, что объект нельзя самостоятельно отредактировать или удалить.

При необходимости вы можете создать дополнительное окно Дерева построения для любого исполнения. Для этого в Дереве исполнений выберите нужное исполнение и вызовите из его контекстного меню команду Исполнение в дополнительном окне.

В дополнительном окне отображается копия Дерева построения выбранного исполнения. Заголовок дополнительного окна Дерева содержит название этого исполнения. Работа с дополнительным окном Дерева построения аналогична описанной в разделе 2.1.2.4.


2.13.1.3. Исполнения в Менеджере документа

Для формирования набора исполнений модели можно использовать Менеджер документа (рис. 2.13.2). Он позволяет выполнять следующие действия:

– создавать и удалять исполнения модели, изменять их положение в списке исполнений,

– просматривать свойства исполнений и изменять их значения,

– задавать различные значения переменных для разных исполнений,

– сохранять данные по исполнениям в файлы различных форматов и использовать сохраненные данные для создания набора исполнений в других моделях.

Рис. 2.13.2. Менеджер документа

Диалог Менеджер документа появляется на экране после вызова команды Управление исполнениями... одним из следующих способов:

– из меню Редактор,

– нажатием одноименной кнопки на панели Текущее состояние,

– из контекстного меню исполнения в Дереве исполнений,

– из подменю Текущее исполнение контекстного меню корневого объекта в Дереве построения.

В левой части диалога отображается Дерево элементов документа. Если диалог вызван указанными выше командами, в Дереве активен элемент Исполнения. При этом в правой части диалога отображается перечень исполнений модели, созданных в документе, и инструментальная панель, позволяющая выполнять различные действия с исполнениями.

Перечень исполнений отображается в диалоге в виде таблицы. Каждый столбец таблицы соответствует определенному свойству модели.

Вы можете сформировать нужный набор и порядок расположения свойств в таблице. Для этого нажмите кнопку Настройка столбцов на инструментальной панели диалога. На экране появится диалог Настройка столбцов (работа в диалоге описана в разделе 5.1.4.2.2).

Настройка столбцов, содержащих переменные, имеет особенности, описанные в разделе 2.13.3.5.2.

При необходимости вы можете отключить отображение любого столбца, кроме столбца Наименование, не вызывая диалог настройки. Для этого активизируйте ячейку нужного столбца и нажмите кнопку Удалить столбец.

В Менеджере вы можете добавлять и удалять исполнения модели, изменять их положение в наборе исполнений документа, задавать различные значения свойств для разных исполнений, сохранять информацию об исполнениях и использовать эту информацию для создания набора исполнений в других документах.

Диалог Менеджер документа позволяет работать не только с исполнениями модели, но и с дополнительными номерами исполнений.

Для выполнения различных действий с дополнительными номерами активизируйте элемент Дополнительные номера в дереве диалога. В правой части диалога будет отображен перечень дополнительных номеров, созданных для модели с исполнениями, и инструментальная панель, позволяющая выполнять различные действия с дополнительными номерами.

Перечень дополнительных номеров отображается в диалоге в виде таблицы. Настройка столбцов таблицы аналогична настройке, выполняемой для исполнений (см. выше).

В Менеджере вы можете добавлять и удалять дополнительные номера, изменять их положение в списке, изменять дополнительные номера и заданные для них комментарии, сохранять информацию о дополнительных номерах и использовать эту информацию для создания дополнительных номеров в других документах. Работа с дополнительными номерами описана в разделе 2.13.3.6.

После выполнения всех необходимых действий закройте диалог, нажав кнопку ОК. Все произведенные изменения будут сохранены. Кнопка Отмена позволяет закрыть диалог без сохранения изменений.

Если требуется сохранить изменения, не закрывая диалог, нажмите кнопку Применить.

Добавление, перемещение и удаление исполнений сохраняется автоматически и не может быть отменено в Менеджере.


2.13.1.4. Общий порядок работы с исполнениями

Рекомендуется следующий порядок работы с исполнениями.

1. Создайте новую модель. Эта модель является основным исполнением.

2. Задайте базовое обозначение и наименование основного исполнения (см. раздел 2.13.2.1). Каждому исполнению, созданному в модели, будет присвоено это обозначение и наименование.

Номера исполнений, создаваемых в модели, формируются автоматически в соответствии с настройкой. Если параметры формирования номеров, заданные по умолчанию, не соответствуют требованиям на вашем предприятии, измените их до создания исполнений. Настройка формирования номеров исполнений описана в разделе 9.2.7.4.3.

3. Создайте в основном исполнении все объекты и переменные, которые должны быть переданы в другие исполнения модели.

4. Создайте нужные исполнения модели (см. раздел 2.13.2.2).

При необходимости вы можете изменить свойства созданного исполнения (см. раздел 2.13.3.4) или его положение в списке исполнений (см. раздел 2.13.2.3).

5. Отредактируйте объекты исполнений, которые должны отличаться от объектов основного исполнения. При необходимости вы можете создать в исполнениях новые объекты, удалить имеющиеся. Работа с объектами зависимых и независимых исполнений имеет различия (см. раздел 2.13.3.2).

Обратите внимание на то, что в окне модели и в Дереве построения модели отображаются объекты того исполнения, которое на данный момент является текущим. Чтобы отредактировать нужное исполнение, необходимо назначить его текущим (см. раздел 2.13.3.1).

Передача изменений, произведенных в исходном исполнении, в зависимые исполнения имеет особенности, описанные в разделе 2.13.3.3.

6. Используйте переменные для изменения геометрии зависимых исполнений (см. раздел 2.13.3.5).

7. Отредактируйте значения свойств исполнений, которые должны отличаться от значений свойств основного исполнения (см. раздел 2.13.3.4).

Вы можете вставить нужное исполнение модели в другой документ (например, в сборку в качестве компонента); сформировать в чертеже ассоциативный вид, содержащий проекцию конкретного исполнения модели; создать спецификацию по модели с исполнениями; создать таблицу исполнений модели в графическом или текстовом документе.

Последовательность создания исполнений и порядок их следования в Дереве исполнений могут быть произвольными. Это не оказывает влияния на порядок их следования в спецификации и в таблице исполнений.


2.13.1.5. Настройка исполнений

В КОМПАС-3D доступны следующие настройки, касающиеся исполнений модели:

– настройка создания объектов и переменных в зависимых исполнениях (см. раздел 9.1.11.10),

– настройка параметров формирования номеров новых исполнений в новом или текущем документе (см. раздел 9.2.7.4.3),

– настройка спецификации по сборке с исполнениями в новом документе (см. раздел 9.2.5.2).


2.13.2. Создание исполнений

2.13. Исполнения модели

2.13.2. Создание исполнений

В этом разделе:

2.13.2.1. Обозначение и наименование исполнения

2.13.2.1.1. Диалог задания обозначения исполнения

2.13.2.2. Способы создания исполнения

2.13.2.2.1. Создание исполнения в Дереве исполнений

2.13.2.2.2. Создание исполнения в Менеджере документа

2.13.2.2.3. Использование списка исполнений другой модели

2.13.2.3. Изменение положения исполнения в списке исполнений

2.13.2.4. Удаление исполнения


2.13.2.1. Обозначение и наименование исполнения

Каждое исполнение модели имеет обозначение и наименование.

Обозначение исполнения состоит из базового обозначения, номера исполнения и кода документа.

Базовое обозначение и код являются общими для всех исполнений модели. Номер исполнения формируется индивидуально для каждого исполнения и должен быть уникальным в пределах документа.

Код, заданный в модели, передается в спецификацию, созданную по данной модели, и не передается в ассоциативный чертеж модели.

Примеры кода модели:

– МД — Электронная модель детали,

– МС — Электронная модель сборочной единицы.

Базовое обозначение и код задаются вручную. Номера исполнений формируются автоматически, но, при необходимости, могут также задаваться вручную.

Вариант задания номеров (автоматически или вручную), а также параметры номеров, формируемых автоматически, задаются при настройке (см. раздел 9.2.7.4.3). Данная настройка учитывается только при создании новых исполнений и не влияет на обозначения исполнений, уже имеющихся в модели.

Обозначение исполнения может быть задано:

– при работе со списком свойств исполнения на Панели свойств (см. раздел 5.1.4.1.1), данный список вызывается командой Свойства исполнения контекстного меню исполнения в Дереве исполнений или Свойства модели контекстного меню корневого объекта в Дереве построения,

– при создании нового исполнения в Дереве исполнений (см. раздел 2.13.2.2.1),

– при работе в Менеджере документа (см. раздел 2.13.1.3) или Редакторе свойств (см. раздел 5.1.4.2).

Для задания обозначения используется специальный диалог. В этом диалоге вы можете задать базовое обозначение, номер исполнения и код. Работа в диалоге описана в разделе 2.13.2.1.1.

Наименование исполнения можно задать при работе со списком свойств исполнения на Панели свойств, в Редакторе свойств или в Менеджере документа. Текст наименования вводится в поле соответствующего свойства.

Наименование зеркального исполнения формируется добавлением предопределенного суффикса к наименованию исходного. Суффикс указывается при настройке (см. раздел 9.1.11.11).

При дальнейшей работе вы можете редактировать обозначения и наименования исполнений, используя способы, описанные выше.

Способы редактирования свойств исполнений приведены в разделе 2.13.3.4; особенности передачи обозначения и наименования исполнения в другие исполнения — в разделе 2.13.3.4.1.

В этом разделе:

2.13.2.1.1. Диалог задания обозначения исполнения


2.13.2.1.1. Диалог задания обозначения исполнения

Обозначение исполнения задается в диалоге Обозначение (рис. 2.13.3).

Рис. 2.13.3. Диалог Обозначение

Поле Базовое обозначение позволяет задать базовое обозначение исполнения. Изменения, произведенные в этом поле, передаются в обозначения других исполнений модели (об особенностях передачи изменений см. раздел 2.13.3.4.1).

Для задания номера исполнения служит поле Номер исполнения. Изменение номера влияет только на текущее обозначение.

Базовое обозначение и номер вводятся с клавиатуры.

Код документа задается в поле Код. Вы можете ввести код с клавиатуры или выбрать его из списка кодов диалога Коды и наименования (см. рис. 3.6.7). Чтобы данный диалог появился на экране, из контекстного меню поля Код вызовите команду Вставить код и наименование... или дважды щелкните мышью в этом поле. Заданный код передается в обозначения других исполнений модели.

Особенности передачи изменений в исполнения модели описаны в разделе 2.13.3.4.1.

Между частями обозначения имеются разделители. По умолчанию первым разделителем является тире (указывается при настройке, см. раздел 9.2.7.4.3), а вторым — пробел. При необходимости вы можете изменить разделители, заданные по умолчанию.

Чтобы изменить первый разделитель, введите в соответствующее поле один произвольный символ. Данный символ используется только в текущем обозначении. Обратите внимание на то, что первый разделитель обязательно должен присутствовать в обозначении. Если разделитель удаляется (поле оставляется пустым), то после закрытия диалога в обозначении восстанавливается удаленный разделитель.

Чтобы изменить второй разделитель, введите один произвольный символ в соответствующее поле диалога Обозначение. Этот символ будет использоваться в качестве разделителя при создании исполнений из данного исполнения. По умолчанию разделителем перед полем Код является пробел. Если требуется создать обозначение без второго разделителя, удалите пробел.

Разделители, заданные по умолчанию, не включаются в готовое обозначение, если соответствующая часть обозначения (номер исполнения или код документа) не задана.

Если в качестве разделителей введены другие символы, то они безусловно включаются в обозначение.

Для завершения работы в диалоге нажмите кнопку ОК. Кнопка Отмена позволяет закрыть диалог без сохранения изменений.


2.13.2.2. Способы создания исполнения

Вы можете создавать зависимые, зависимые зеркальные (см. раздел 2.13.4) и независимые исполнения модели, используя Дерево исполнений или Менеджер документа.

Дерево исполнений предпочтительно использовать для создания единичных исполнений. Формирование набора из нескольких исполнений рекомендуется выполнять в Менеджере документа.

Состав и порядок расположения исполнений в Менеджере полностью повторяет Дерево исполнений. При добавлении исполнения в Менеджере оно автоматически добавляется в соответствующее место Дерева исполнений.

По умолчанию документ-модель содержит одно исполнение — основное. Оно является исходным для первого создаваемого исполнения. В дальнейшем вы можете использовать для создания исполнений не только основное исполнение, но и исполнения, созданные пользователем.

При создании исполнения его наименование и базовое обозначение наследуются из исходного исполнения.

Задайте базовое обозначение и наименование основного исполнения до создания всех остальных исполнений модели (см. раздел 2.13.2.1).

Номер исполнения формируется автоматически в соответствии с настройкой (см. раздел 9.2.7.4.3) и добавляется в обозначение исполнения.

Если в процессе выполнения настройки вы отключили автоматическое формирование номеров исполнений, обратите внимание на следующие особенности.

При создании зависимого исполнения его умолчательный номер совпадает с номером исходного исполнения. При создании независимого исполнения умолчательный номер не создается.

Чтобы номер исполнения был уникальным в пределах документа, в первом случае измените умолчательный номер, а во втором — задайте нужный номер исполнения.

Из любого исполнения модели, кроме зеркального, можно создать как зависимое, так и независимое исполнение.

Созданное исполнение, как зависимое, так и независимое, наследует геометрию, элементы оформления, набор переменных и значения свойств (в том числе цвет и оптические свойства) из исходного исполнения.

Объекты, исключенные из расчета, наследуются с сохранением признака Исключен из расчета.

Порядок создания исполнения при работе с Деревом исполнений приведен в разделе 2.13.2.2.1, при работе с Менеджером документа — в разделе 2.13.2.2.2.

В этом разделе:

2.13.2.2.1. Создание исполнения в Дереве исполнений

2.13.2.2.2. Создание исполнения в Менеджере документа

2.13.2.2.3. Использование списка исполнений другой модели


2.13.2.2.1. Создание исполнения в Дереве исполнений

1. Откройте Дерево исполнений модели.

2. Укажите исполнение, которое должно быть исходным для создаваемого исполнения, и вызовите команду Создать исполнение из его контекстного меню. Команда доступна для всех исполнений, кроме зеркальных. После вызова команды на Панели свойств появляются элементы управления (рис. 2.13.4).

Рис. 2.13.4. Элементы создания исполнения

3. В поле Обозначение отображается умолчательное обозначение исполнения, состоящее из базового обозначения, номера исполнения и кода.

Вы можете изменить любую часть обозначения создаваемого исполнения с помощью специального диалога (см. раздел 2.13.2.1.1). Для вызова диалога щелкните мышью в поле Обозначение.

При редактировании обозначения обратите внимание на следующие особенности:

– изменение базового обозначения передается в другие исполнения модели (см. раздел 2.13.3.4),

– номер исполнения должен быть уникальным в пределах документа; в случае совпадения номеров создаваемого исполнения и исполнения, уже имеющегося в документе, новое исполнение не будет создано.

Вы можете выбрать обозначение исполнения из внешнего справочника (Классификатор ЕСКД). Для этого нажмите кнопку Выбор из справочника. Справочник должен быть подключен к КОМПАС-3D.

4. Проверьте состояние опции Зависимое исполнение. Для создания зависимого исполнения опция должна быть включена, для создания независимого — выключена.

5. При необходимости вы можете создать зеркальное исполнение модели. Для этого включите опцию Зеркальное исполнение. Опция присутствует на Панели свойств, если исходное исполнение еще не имеет зависимых зеркальных исполнений. Опция доступна при включенной опции Зависимое исполнение.

6. При необходимости введите пояснения к создаваемому исполнению в поле Комментарий.

7. На вкладке Свойства вы можете задать цвет и оптические свойства создаваемого исполнения.

8. Завершите создание исполнения одним из следующих способов.

– При создании обычного исполнения модели, а также зеркального исполнения модели, не содержащей компоненты, нажмите кнопку Создать объект на Панели специального управления.

– При создании зеркального исполнения модели, содержащей компоненты, вместо кнопки Создать объект на Панели специального управления отображается кнопка Продолжить создание исполнения. Нажмите эту кнопку. На экране появится диалог Параметры зеркального отражения компонентов. Он содержит перечень всех компонентов, входящих в модель, и позволяет настроить параметры их отражения. Диалог аналогичен описанному в разделе 2.11.3.4 с единственным отличием — нет кнопки Выбор объектов.... Выполните необходимые действия в диалоге и завершите создание зеркального исполнения, нажав кнопку ОК в диалоге или кнопку Создать объект на Панели специального управления.

После завершения команды в Дереве исполнений появляется новое исполнение. Оно автоматически становится текущим.

9. Аналогично создайте все нужные исполнения модели.

Вы также можете создать исполнение, работая с Деревом построения текущего исполнения модели. Для этого из контекстного меню корневого элемента Дерева вызовите команду Создать исполнение. При работе с исполнением сборки данная команда также присутствует в контекстном меню компонента при его редактировании «на месте».

Дальнейшие действия аналогичны описанным выше.


2.13.2.2.2. Создание исполнения в Менеджере документа

1. Откройте Менеджер документа (см. раздел 2.13.1.3). В дереве Менеджера активизирован элемент Исполнения.

2. Из списка исполнений, расположенного в правой части окна Менеджера, выберите исполнение, которое должно быть исходным для создаваемого исполнения.

3. Создайте исполнение нужного типа, вызвав из меню кнопки Создать зависимое исполнение одну из следующих команд:

– Создать зависимое исполнение,

– Создать зеркальное исполнение,

– Создать независимое исполнение.

Команды создания зависимого и независимого исполнений доступны для всех исполнений, кроме зеркальных. Команда создания зеркального исполнения доступна для исполнений, которые не являются зеркальными и не имеют зависимых зеркальных исполнений.

После вызова любой из указанных команд (кроме команды создания зеркального исполнения, вызываемой для модели с компонентами) в списке исполнений Менеджера и в Дереве исполнений появляется новое исполнение. Свойства исполнения, в том числе его наименование и обозначение, отображаются в Менеджере документа.

При создании зеркального исполнения модели, содержащей компоненты, после вызова команды Создать зеркальное исполнение на экране появляется диалог настройки параметров отражения компонентов. Диалог аналогичен описанному в разделе 2.11.3.4 с единственным отличием — нет кнопки Выбор объектов.... Выполните необходимые настройки и завершите создание зеркального исполнения, нажав кнопку ОК в диалоге или кнопку Создать объект на Панели специального управления. После этого новое исполнение появляется в списке исполнений Менеджера и в Дереве исполнений.

При необходимости вы можете изменить обозначение, наименование или какое-либо другое свойство исполнения (см. раздел 2.13.3.4). Вы также можете изменить положение исполнения в списке исполнений (см. раздел 2.13.2.3).

4. Аналогично создайте все нужные исполнения модели.

Для создания списка исполнений можно использовать список исполнений другой модели (см. раздел 2.13.2.2.3).

5. Для завершения работы в Менеджере документа нажмите кнопку ОК.


2.13.2.2.3. Использование списка исполнений другой модели

Набор исполнений имеющейся модели можно использовать для создания аналогичного набора исполнений в другой модели. Для этого выполните следующие действия.

1. В имеющейся модели с исполнениями откройте Менеджер документа (см. раздел 2.13.1.3).

2. Нажмите кнопку Сохранить как... на инструментальной панели Менеджера.

3. В появившемся на экране диалоге сохранения файла укажите папку для сохранения, выберите тип файла Электронные таблицы ODF (*.ods) или Электронные таблицы Microsoft Excel (*.xls) и нажмите кнопку Сохранить.

Информация об исполнениях модели будет сохранена в файле указанного типа.

4. Откройте модель, в которой нужно создать исполнения.

5. Откройте Менеджер документа.

6. Нажмите кнопку Читать из файла на инструментальной панели Менеджера.

7. В появившемся на экране диалоге открытия файла выберите файл формата ods или xls и нажмите кнопку Открыть. Список исполнений из файла будет передан в модель.

Переданные исполнения добавляются к исполнениям, имеющимся в модели, и размещаются после них в списке Менеджера документа и в Дереве исполнений.

Вы можете добавить в модель исполнения из нескольких файлов.

Дальнейшая работа с добавленными исполнениями аналогична работе с исполнениями, созданными в модели.

При создании набора исполнений описанным выше способом обратите внимание на следующие особенности.

– Базовое обозначение и код исполнений, добавленных из файла, не передаются в исполнения, уже имеющиеся в модели.

– Все исполнения, содержащиеся в выбранном файле, добавляются в модель независимо от того, имеются ли в ней исполнения с такими же номерами. Номера добавленных исполнений не изменяются.

– В модель передаются значения только тех свойств исполнений, которые не связаны с геометрией модели. Геометрию и связанные с ней свойства, такие как масса, свойства, созданные из переменных параметров операций, и т.п. данным способом передать нельзя.


2.13.2.3. Изменение положения исполнения в списке исполнений

При работе в Менеджере документа вы можете изменить положение исполнения в списке исполнений модели.

Для этого выберите исполнение, которое требуется переместить, и нажмите кнопку Переместить строку вверх или Переместить строку вниз. Исполнение переместится соответственно на одну позицию вверх или вниз в списке исполнений Менеджера и в Дереве исполнений.

Доступность кнопок определяется возможностью перемещения исполнения на ту или иную позицию.

Перемещение исполнения возможно в пределах одного уровня списка.

Изменение положения исполнения в списке не изменяет номер исполнения.


2.13.2.4. Удаление исполнения

Удаление исполнения выполняется следующими способами:

– в Дереве исполнений — командой Удалить, вызываемой из меню Редактор или контекстного меню исполнения,

– в Менеджере документа — нажатием кнопки Удалить строки на инструментальной панели Менеджера.

Вы можете удалить любое исполнение, кроме основного.

Если удаляемое исполнение имеет зависимые исполнения, то эти исполнения также удаляются.

При удалении зависимого исполнения, которое является текущим, статус текущего назначается его исходному исполнению. Если текущим является независимое исполнение, то после его удаления текущим становится основное исполнение модели.

При необходимости вы можете удалить одновременно несколько исполнений, выделив их с помощью клавиши <Shift> или <Ctrl>.


2.13.3. Работа с исполнениями

2.13. Исполнения модели

2.13.3. Работа с исполнениями

Для редактирования объектов в модели с исполнениями используются те же способы, что и в модели без исполнений.

Изменения вносятся в текущее исполнение модели. Если это исполнение имеет зависимые исполнения, то произведенные изменения передаются в эти исполнения. Если само исполнение является зависимым, то его объекты связаны с объектами исходного исполнения и недоступны для редактирования. При необходимости вы можете отменить связь объектов и внести необходимые изменения. Подробнее редактирование исполнений описано в разделе 2.13.3.2.

Параметры объектов исполнений можно изменять с помощью переменных. Особенности работы с переменными в исполнениях описаны в разделе 2.13.3.5.

Исполнение, созданное в модели, можно использовать в других документах, например, можно вставить его в сборку в качестве компонента или использовать для создания ассоциативного вида в чертеже. Нужное исполнение выбирается при выполнении операции. Например, при вставке компонента в сборку исполнение выбирается из раскрывающегося списка в диалоге открытия файла.

В этом разделе:

2.13.3.1. Выбор текущего исполнения

2.13.3.2. Создание, редактирование и удаление объектов исполнения

2.13.3.3. Передача объектов в исполнения

2.13.3.4. Редактирование свойств исполнения

2.13.3.4.1. Особенности передачи изменений свойств между исполнениями

2.13.3.5. Использование переменных в исполнении

2.13.3.5.1. Пользовательская переменная в исполнении

2.13.3.5.2. Задание значений пользовательских переменных

2.13.3.5.3. Дополнительные возможности работы с переменными

2.13.3.5.4. Просмотр и назначение допусков при работе с переменными

2.13.3.6. Дополнительные номера исполнений

2.13.3.7. Сохранение модели с исполнениями


2.13.3.1. Выбор текущего исполнения

Сразу после создания исполнения в Дереве исполнений оно автоматически становится текущим. Чтобы вручную сделать исполнение текущим, используйте один из следующих способов:

– в Дереве исполнений — из контекстного меню исполнения вызовите команду Текущее или щелкните мышью по названию исполнения,

– в Дереве построения — из контекстного меню корневого элемента Дерева вызовите команду Текущее исполнение и укажите нужное исполнение в появившемся списке,

– в Менеджере документа — нажмите кнопку Сделать текущим на инструментальной панели Менеджера или из контекстного меню исполнения вызовите команду Текущее,

– на панели Текущее состояние (при горизонтальном расположении панели) — выберите нужное исполнение из списка поля Управление исполнениями или введите обозначение исполнения в это поле.

– в окне Свойства — выделите корневой элемент в Дереве и выберите нужное исполнение из списка Исполнение.

При открытии модели с исполнениями вы можете указать исполнение, которое будет текущим. Для этого в диалоге открытия файла из раскрывающегося списка Исполнение выберите нужное исполнение модели.

Объекты текущего исполнения отображаются в окне модели и в Дереве построения модели.

Обозначение текущего исполнения отображается в заголовке главного окна КОМПАС-3D.


2.13.3.2. Создание, редактирование и удаление объектов исполнения

Исполнение, созданное в модели, наследует геометрию из исходного исполнения. В дальнейшем вы можете изменять геометрию исполнения, добавляя, редактируя и удаляя его объекты.

Чтобы объекты исполнения отображались в окне модели и в Дереве построения модели, сделайте это исполнение текущим, как описано в разделе 2.13.3.1.

Для удобства работы с исполнением вы можете создать для него дополнительное окно Дерева построения. Для этого в Дереве исполнений выберите нужное исполнение и вызовите из его контекстного меню команду Исполнение в дополнительном окне.

Независимое исполнение является полностью автономным. На него не влияет редактирование других исполнений модели.

В зависимое исполнение передаются изменения, производимые в его исходном исполнении. Особенности создания, изменения и удаления объектов описаны ниже.

Создание объектов

Создание объектов доступно в любом исполнении, как зависимом, так и независимом.

Если исполнение, в котором создается объект, имеет зависимые исполнения, то идентичный объект может быть создан в этих исполнениях. Объект создается в том случае, если в диалоге настройки исполнений включена опция Создавать объект в зависимых исполнениях (см. раздел 9.1.11.10). Данная опция также управляет добавлением в зависимые исполнения компонентов, идентичных добавленным в исходное исполнение.

Если при добавлении компонентов в исходное исполнение на них накладываются сопряжения, то эти сопряжения передаются во все зависимые исполнения, кроме зеркального.

Редактирование и удаление объектов

Редактирование и удаление объектов исходного исполнения передается в зависимые исполнения, если соответствующие объекты зависимых исполнений сохраняют связь с объектами исходного исполнения.

Для передачи изменений объектов необходимо перестроить модель с исполнениями, вызвав команду Вид — Перестроить. После вызова команды перестраиваются все исполнения, для которых требуется перестроение (исполнения, отмеченные красной «галочкой» в Дереве исполнений). Удаление объектов передается автоматически.

В зависимом исполнении самостоятельное редактирование или удаление объектов недоступно (в Дереве построения такие объекты отмечены значком «замок»).

Если требуется изменить или удалить какой-либо объект зависимого исполнения, отмените его связь с объектом исходного исполнения. Для этого из контекстного меню объекта вызовите команду Отменить связь. Объект станет доступным для редактирования и удаления, а в контекстном меню появится команда Восстановить связь. Эта команда позволяет восстановить связь между объектами.

После восстановления связи и перестроения модели объект зависимого исполнения становится идентичным соответствующему объекту исходного исполнения. Изменения, произведенные с объектом зависимого исполнения до восстановления связи, не сохраняются.

В независимом исполнении объекты доступны для изменения и удаления.

При необходимости вы можете изменять объекты исполнений модели с помощью переменных. Эти действия описаны в разделе 2.13.3.5.

Особенности работы с локальными моделями и стандартными изделиями

Работа с компонентом, являющимся локальной моделью или стандартным изделием, имеет следующие особенности.

– Локальная модель, которая является компонентом зависимого исполнения, имеет связь с соответствующим компонентом исходного исполнения (пиктограмма локальной модели в зависимом исполнении отмечена в Дереве построения значком «замок»), однако эта связь — частичная: передаются только перемещение и удаление компонента.

– Компонент исходного исполнения модели может быть преобразован в локальную модель с помощью команды Редактор — Взять в документ. Это действие не передается в зависимое исполнение, т.е. в зависимом исполнении данный компонент остается прежним. При этом между компонентами сохраняется частичная связь, описанная в предыдущем пункте.

– Если в исходное исполнение добавляется компонент, являющийся локальной моделью или стандартным изделием, то в зависимом исполнении идентичный компонент не создается. Для его создания воспользуйтесь командой Передать в исполнения, см. раздел 2.13.3.3.

– Замена стандартного изделия, входящего в исходное исполнение модели, другим стандартным изделием не передается в зависимое исполнение модели. В этом случае соответствующее стандартное изделие, входящее в зависимое исполнение модели, удаляется.


2.13.3.3. Передача объектов в исполнения

Объекты, имеющиеся в текущем исполнении модели, могут быть переданы в другие исполнения, как зависимые, так и независимые. Для передачи объектов выполните следующие действия.

1. Назначьте текущим исполнение, объекты которого нужно передать (см. раздел 2.13.3.1).

2. Вызовите команду Редактор — Передать в исполнения. На Панели свойств появятся элементы управления, показанные на рис. 2.13.5.

Рис. 2.13.5. Элементы Панели свойств

3. Сформируйте список объектов текущего исполнения, которые требуется передать.

Чтобы добавить нужные объекты в список, укажите их мышью в Дереве построения или в окне модели. Наименования выбранных объектов будут отображены на панели Список объектов.

При необходимости вы можете удалить объект из списка передаваемых, выделив его на панели Список объектов и нажав кнопку Удалить из списка.

4. Настройте список исполнений, в которые должны быть переданы выбранные объекты. Для этого используется панель Исполнения.

По умолчанию на этой панели отображаются все исполнения, имеющиеся в модели. Если требуется, чтобы список содержал только зависимые исполнения текущего исполнения (исполнения, подчиненные текущему в Дереве исполнений), нажмите кнопку Только зависимые исполнения.

Слева от обозначения каждого исполнения в списке находится включенная опция. Это означает, что выбранные объекты будут переданы во все исполнения, содержащиеся в списке. Если в какое-то из исполнений передавать объекты не требуется, отключите соответствующую ему опцию.

Для включения и отключения всех опций в списке можно использовать кнопки Включить все и Выключить все.

5. Чтобы передать объекты, нажмите кнопку Создать объект.

Особенности передачи объектов в исполнения:

– если передаваемый объект имеет исходные объекты, например, эскизы, то эти объекты также передаются в выбранные исполнения,

– если передаваемый объект уже содержится в выбранных исполнениях, то в эти исполнения данный объект не передается,

– если на передаваемые компоненты модели наложены сопряжения, то эти сопряжения не передаются в зеркальное исполнение модели.


2.13.3.4. Редактирование свойств исполнения

Набор свойств модели является единым для всех содержащихся в ней исполнений. Работа с набором свойств выполняется одинаково в модели с исполнениями и без (см. раздел 5.1).

Особенностью модели с исполнениями является то, что общий набор свойств модели может редактироваться при работе с любым из ее исполнений.

Значения свойств могут быть различными для разных исполнений модели.

При создании нового исполнения ему передаются все значения свойств исходного исполнения. Исключение составляет свойство Обозначение. В новое исполнение передается только часть обозначения исполнения — базовое обозначение и код. Номер исполнения формируется системой или задается пользователем.

Значения свойств исполнения можно отредактировать при работе со списком свойств этого исполнения на Панели свойств.

В Дереве исполнений список свойств вызывается для любого из исполнений модели командой Свойства исполнения контекстного меню.

В Дереве построения список свойств вызывается для текущего исполнения модели. Для этого из контекстного меню корневого объекта Дерева нужно вызвать команду Свойства модели.

Изменение значений свойств выполняется для исполнения так же, как для модели. Общий порядок работы со списком свойств приведен в разделе 5.1.4.1.

Кроме того, редактирование значений свойств текущего исполнения можно выполнить в Редакторе свойств (см. раздел 5.1.4.2 и 5.1.4.4).

Если требуется изменить значения свойств нескольких исполнений, используйте Менеджер документа (см. раздел 2.13.1.3). Вы можете настроить отображение столбцов со всеми нужными свойствами и задать значения свойств для разных исполнений.

Значения свойств в Менеджере документа изменяются непосредственно в ячейках этих свойств. Исключение составляют следующие свойства:

– Материал, Плотность, Масса — редактирование выполняется в диалоге Массо-центровочные характеристики (см. раздел 5.1.4.4.2),

– Позиция, Раздел спецификации — редактирование выполняется в диалоге Выберите раздел (см. раздел 6.2.2.3.1),

– Обозначение — редактирование выполняется в диалоге Обозначение (см. раздел 2.13.2.1.1),

– Заменитель материала и Покрытие — значения свойств выбираются из внешнего справочника (справочник должен быть подключен к системе КОМПАС-3D).

Диалоги редактирования свойств вызываются двойным щелчком мыши в ячейке соответствующего свойства или нажатием кнопки с многоточием в правой части этой ячейки.

Изменения свойств, выполненные для одного из исполнений, передаются в другие исполнения. Этот процесс имеет особенности, описанные в разделе 2.13.3.4.1.

Менеджер документа может содержать свойства, созданные из переменных. Особенности редактирования этих свойств описаны в разделах 2.13.3.5.2 и 2.13.3.5.3.

Наименование исполнения можно изменить не только указанными выше способами, но и в Дереве исполнений (см. раздел 2.1.2.5).

В этом разделе:

2.13.3.4.1. Особенности передачи изменений свойств между исполнениями


2.13.3.4.1. Особенности передачи изменений свойств между исполнениями

При редактировании свойств исполнений обратите внимание на следующие особенности передачи изменений в другие исполнения.

– Порядок передачи изменений базового обозначения зависит от того, для какого исполнения выполнены данные изменения. Возможны следующие варианты:

• для основного исполнения — изменения передаются во все исполнения модели, которые имеют такие же базовые обозначения, как и основное исполнение,

• для зависимого исполнения — изменения передаются в его исходное исполнение и зависимые исполнения, если они есть (т.е. во все исполнения, расположенные на той же ветви Дерева исполнений, что и изменяемое исполнение),

• для независимого исполнения — изменения передаются в его зависимые исполнения, если они есть.

– Изменение кода, содержащегося в обозначении исполнения, передается во все его зависимые исполнения, которые имеют такое же значение кода.

– Изменение номера, содержащегося в обозначении исполнения, учитывается при автоматическом формировании номеров — номер вновь созданного исполнения будет следующим за самым большим номером, имеющимся в списке исполнений.

– Для свойств Наименование, Материал, Плотность, Масса (в случае ручного ввода значения массы), Заменитель материала, Покрытие, Разработал, Проверил, Утвердил, Т. контр., Н. контр. и свойств, созданных из переменных, — изменения свойств исполнения передаются во все его зависимые исполнения, которые имеют такие же значения соответствующих свойств.

– Для свойств Автор и Организация — изменения свойств исполнения передаются во все исполнения модели.

– Изменения остальных свойств исполнений в другие исполнения не передаются.


2.13.3.5. Использование переменных в исполнении

В некоторых случаях требуется изменять объекты зависимых исполнений, сохраняя их связи с объектами исходных исполнений. Для этого используются переменные.

Каждый геометрический объект модели имеет набор переменных. К ним относятся переменные параметров операций и переменные размеров эскизов. Эти переменные используются для управления геометрией модели.

Здесь и далее имеется в виду, что переменные размеров эскизов, используемые для управления геометрией, соответствуют управляющим размерам (об управляющих размерах см. разделы 2.9.2.1 и 7.2.1.10).

При сохранении связи объектов зависимого исполнения с объектами исходного самостоятельно отредактировать объекты зависимого исполнения нельзя. Соответственно в зависимом исполнении нельзя изменить значения переменных, созданных для этих объектов.

Чтобы управлять геометрией зависимых исполнений с помощью переменных, необходимо создать пользовательские переменные (см. раздел 7.1.2.1) и сопоставить их нужным переменным параметров операций и размеров.

Набор пользовательских переменных исходного исполнения передается в созданные из него исполнения. Особенности создания пользовательских переменных в исполнениях описаны в разделе 2.13.3.5.1.

Сопоставление переменных выполняется в Окне переменных (см. раздел 7.1.1.3). Оно заключается в том, что пользовательская переменная задается в качестве значения переменной параметра операции или переменной размера, т.е. имя пользовательской переменной вводится в ячейку Выражение переменной параметра операции или переменной размера.

В дальнейшем вы можете задавать значения пользовательских переменных. Эти значения будут переданы сопоставленным переменным параметров операций и переменным размеров эскизов. В результате геометрия исполнения изменится.

Для корректной работы выполните создание и сопоставление пользовательских переменных в основном исполнении модели до создания остальных исполнений. В этом случае каждое исполнение модели будет иметь один и тот же набор переменных.

Чтобы задать различные значения переменной для разных исполнений, используйте Менеджер документа. Порядок работы с переменными в Менеджере описан в разделе 2.13.3.5.2.

В этом разделе:

2.13.3.5.1. Пользовательская переменная в исполнении

2.13.3.5.2. Задание значений пользовательских переменных

2.13.3.5.3. Дополнительные возможности работы с переменными

2.13.3.5.4. Просмотр и назначение допусков при работе с переменными


2.13.3.5.1. Пользовательская переменная в исполнении

При создании исполнения в него передаются все переменные исходного исполнения (в том числе пользовательские), т.е. создается набор переменных, идентичный набору переменных исходного исполнения.

Обратите внимание на следующие особенности передачи пользовательских переменных в исполнения:

– зависимое исполнение — значением пользовательской переменной становится ссылка на соответствующую переменную исходного исполнения; данная ссылка заменяет содержимое соответствующей ячейки Выражение Окна переменных (если из пользовательской переменной создано свойство, то содержимое ячейки передается без изменений — ссылка не создается);

– независимое исполнение — переданная пользовательская переменная полностью идентична соответствующей переменной исходного исполнения; содержимое ячейки Выражение Окна переменных передается без изменений.

В дальнейшем вы можете добавить пользовательскую переменную в любое исполнение, созданное в модели.

Если исполнение, в которое добавляется переменная, имеет зависимые исполнения, то новая переменная будет передана во все эти исполнения, так как в диалоге настройки исполнений по умолчанию включена опция Создавать переменную в зависимых исполнениях (см. раздел 9.1.11.10). Если передавать переменные не требуется, отключите опцию.

Для передачи пользовательской переменной в зависимые исполнения можно использовать команду Применить в зависимых исполнениях. Команда присутствует в контекстном меню пользовательской переменной в исполнении, имеющем зависимые исполнения.

В Окне переменных модели вы можете редактировать пользовательские переменные исполнений, как зависимых, так и независимых. Обратите внимание на то, что в Окне переменных отображается набор переменных того исполнения, которое является текущим (см. раздел 2.13.3.1).

Вы можете изменить содержимое ячейки Выражение нужной переменной, при этом значение переменной изменится. Это изменение будет передано в зависимые исполнения.

Если переменная зависимого исполнения должна иметь другое значение (отличное от значения переменной исходного исполнения), замените ссылку, содержащуюся в ячейке Выражение этой переменной нужным значением. Связь между переменными зависимого и исходного исполнений будет утеряна. При необходимости вы можете восстановить связь, создав ссылку на переменную нужного исполнения (см. раздел 7.1.3.5).

Значения пользовательских переменных для различных исполнений можно изменить при работе с Менеджером документа (см. раздел 2.13.3.5.2).


2.13.3.5.2. Задание значений пользовательских переменных

Значения пользовательских переменных задаются с помощью Окна переменных (см. раздел 7.1.1.3) или Менеджера документа (см. раздел 2.13.1.3).

Окно переменных используется для задания значений пользовательских переменных текущего исполнения (особенности задания значений описаны в разделе 2.13.3.5.1).

Если модель содержит свойства, созданные из пользовательских переменных, то вы можете использовать Редактор свойств (см. раздел 5.1.4.2) для задания значений переменных текущего исполнения.

Чтобы задать значения пользовательских переменных для различных исполнений, откройте Менеджер документа и выполните следующие действия.

1. Выберите пользовательскую переменную, значения которой нужно задать.

Для этого нажмите кнопку Вставить переменную на инструментальной панели Менеджера. На экране появится диалог Переменные, содержащий список переменных текущего исполнения (см. рис. 7.1.8).

Если нужная пользовательская переменная содержится в списке переменных другого исполнения модели, выберите обозначение этого исполнения из раскрывающегося списка Исполнение.

Укажите нужную пользовательскую переменную в списке переменных и нажмите кнопку ОК. Диалог Переменные закроется. В таблице Менеджера документа появится столбец, наименование которого содержит имя выбранной переменной. При этом в документе автоматически создается свойство из выбранной переменной (см. раздел 5.1.3.2.1).

Созданное из переменной свойство включается в набор свойств документа и может редактироваться на Панели свойств (см. раздел 5.1.4.1) или в Редакторе свойств (см. раздел 5.1.4.2).

Если свойство из нужной переменной уже создано в документе, то диалог выбора переменной использовать не требуется. Настройте отображение столбца со значениями этого свойства, как описано в разделе 2.13.1.3.

2. Ячейки полученного столбца доступны как для независимых, так и для зависимых исполнений модели. Введите требуемые значения в ячейки.

Обратите внимание на то, что изменение значения переменной, выполненное для исполнения, передается в те его зависимые исполнения, которые имеют такое же значение данной переменной.

3. Чтобы произведенные изменения были применены и переданы в модель до завершения работы в Менеджере, нажмите кнопку Применить.

4. Для завершения работы в Менеджере документа нажмите кнопку ОК.


2.13.3.5.3. Дополнительные возможности работы с переменными

В некоторых случаях при работе с исполнениями может потребоваться задать значение переменной параметра операции или переменной управляющего размера эскиза. Вы можете задать значения этих переменных для независимого исполнения или для объектов зависимого исполнения, не имеющих связи с объектами исходного исполнения (например, связь отменена или объект создан в зависимом исполнении).

Если значение переменной должно быть задано только для одного исполнения, назначьте это исполнение текущим (см. раздел 2.13.3.1) и задайте значение нужной переменной в Окне переменных. Значения переменных задаются для исполнения так же, как для модели (см. раздел 7.1.3).

Вы также можете создать свойство из нужной переменной текущего исполнения (см. раздел 5.1.3.2.1) и задать его значение с помощью списка свойств на Панели свойств (см. раздел 5.1.4.1) или в Редакторе свойств (см. раздел 5.1.4.2).

При необходимости вы можете создавать свойства из любых переменных, кроме функциональных и интервальных. Особенности задания значений свойств, созданных из переменных, описаны в разделе 5.1.4.4.5).

Если требуется задать значения переменной параметра операции или переменной управляющего размера эскиза для нескольких исполнений, откройте Менеджер документа, добавьте нужную переменную (см. раздел 2.13.3.5.2) и задайте ее значения для исполнений.

Изменение значения переменной параметра операции (переменной размера) исполнения передается в его зависимое исполнение в том случае, если связь между соответствующими параметрами (размерами) этих исполнений сохранена.

Для переменной управляющего размера эскиза или переменной параметра операции, выраженного в линейных или угловых величинах, можно задать не только значение, но и назначить допуск на значение соответствующего параметра или допуск на размер. Назначение допусков описано в разделе 2.13.3.5.4.


2.13.3.5.4. Просмотр и назначение допусков при работе с переменными

При работе с переменными в Менеджере документа (см. раздел 2.13.1.3) вы можете просмотреть индивидуальные допуски, назначенные переменным управляющих размеров эскизов и переменным параметров операций, значения которых выражены в линейных или угловых величинах (подробнее об индивидуальных допусках см. раздел 2.10.2).

Если в Менеджере не отображается столбец со значениями нужной переменной, добавьте его с помощью кнопки Вставить переменную (см. раздел 2.13.3.5.2) или настройте отображение столбца (см. раздел 2.13.1.3) в том случае, если в документе создано свойство из этой переменной.

По умолчанию назначенные допуски не отображаются в ячейках таблицы Менеджера документа. Чтобы включить отображение индивидуальных допусков, нажмите кнопку Отображать индивидуальные допуски. При нажатой кнопке в ячейках показываются значения параметров (размеров), выбранные квалитеты и предельные отклонения параметров (размеров). Чтобы отключить отображение допусков, отожмите кнопку.

При нажатой кнопке Отображать индивидуальные допуски ячейки переменных управляющих размеров эскизов и переменных параметров операций, значения которых выражены в линейных и угловых величинах, недоступны для ручного ввода.

Менеджер документа позволяет назначать допуски на указанные выше размеры и значения параметров.

Допуск может назначаться для объектов независимого исполнения модели или объектов зависимого исполнения, не имеющих связи с объектами исходного исполнения.

Чтобы назначить допуск, выполните следующие действия.

1. В столбце переменной выберите ячейку, соответствующую нужному исполнению.

2. Вызовите диалог назначения допуска одним из следующих способов:

– если в Менеджере включен режим отображения индивидуальных допусков, нажмите кнопку с многоточием в правой части выбранной ячейки или дважды щелкните по ней мышью,

– если режим отображения индивидуальных допусков отключен, вызовите команду Назначить допуск из контекстного меню выбранной ячейки.

После вызова команды на экране появляется диалог Значение и допуск (рис. 2.13.6).

Рис. 2.13.6. Диалог Значение и допуск

3. В появившемся диалоге выполните необходимые действия по назначению допуска. Эти действия аналогичны описанным в разделе 2.10.2.2.

Диалог также позволяет задать значение параметра или размера, которому соответствует переменная. Он содержит поле Значение и одноименную кнопку (кнопка присутствует в диалоге для линейных размеров и параметров, значения которых выражены в линейных величинах).

Введите значение в поле или выберите его из пользовательского меню, которое появляется на экране после нажатия кнопки Значение. По умолчанию меню содержит нормальные линейные размеры по ГОСТ 6636-69.

Если значение переменной параметра или размера задано выражением, то изменить значение в диалоге назначения допуска нельзя. Поле Значение и одноименная кнопка не отображаются в диалоге.

4. Для завершения работы в диалоге нажмите кнопку ОК.

Диалог закроется. Заданное значение будет отображено в Менеджере документа. При нажатой кнопке Отображать индивидуальные допуски в Менеджере также отобразится назначенный допуск.

Значения и допуски, заданные для исполнения, передаются во все его зависимые исполнения после нажатия в Менеджере документа кнопки Применить или ОК.

Если на значение параметра или на размер какого-либо зависимого исполнения требуется назначить другой допуск, отмените связь соответствующего объекта этого исполнения с объектом исходного исполнения.

В Менеджере документа назначенный допуск хранится в виде предельных отклонений параметра (размера).


2.13.3.6. Дополнительные номера исполнений

Если исполнения модели кроме конструктивных отличий имеют такие переменные характеристики, которые могут быть присущи нескольким исполнениям (вид покрытия, дополнительная комплектация изделия составными частями и т.п.), в модели создаются дополнительные номера.

Каждому дополнительному номеру соответствует определенный набор переменных данных. Эти данные задаются в качестве значений свойств дополнительных номеров.

Чтобы создать список дополнительных номеров, выполните следующие действия.

1. Откройте Менеджер документа (см. раздел 2.13.1.3).

2. В дереве Менеджера активизируйте элемент Дополнительные номера.

3. На инструментальной панели Менеджера нажмите кнопку Создать дополнительный номер исполнения.

Новый дополнительный номер появится в Менеджере. Он будет сформирован в соответствии с настройкой (см. раздел 9.2.7.4.3). При необходимости вы можете изменить параметры настройки. Эти изменения учитываются только при создании новых дополнительных номеров.

4. Задайте значения свойств дополнительного номера. Для этого предварительно настройте отображение столбцов с нужными свойствами, используя кнопки Настройка столбцов и Удалить столбец (см. раздел 2.13.1.3). Значения свойств вводятся в ячейки таблицы Менеджера.

При необходимости вы можете добавить столбцы с внешними переменными и задать значения этих переменных. Действия по добавлению внешних переменных и заданию их значений аналогичны описанным в разделе 2.13.3.5.2.

5. Аналогично создайте все нужные дополнительные номера и задайте значения их свойств.

Список дополнительных номеров отображается в Менеджере в виде таблицы. Ячейки таблицы доступны для ручного ввода. При необходимости вы можете изменить созданные дополнительные номера.

Кроме того, можно изменить порядок расположения дополнительных номеров в списке. Действия по изменению положения дополнительного номера аналогичны описанным в разделе 2.13.2.3.

Для создания дополнительных номеров в модели можно использовать список дополнительных номеров другой модели, сохраненный в файл формата ods или xls. При этом номера и значения их свойств добавляются из файла в текущую модель.

Если в модели имеется номер, идентичный номеру, содержащемуся в файле (совпадают не только номера, но и значения их свойств), то номер из файла не добавляется в модель.

Действия по созданию дополнительных номеров данным способом аналогичны описанным в разделе 2.13.2.2.3.

6. Для завершения работы в Менеджере документа нажмите кнопку ОК.

Переменные данные, соответствующие дополнительным номерам, приводятся в графическом или текстовом документе в виде таблицы дополнительных номеров. Для создания данной таблицы можно использовать модель или ассоциативный вид с модели, созданный в чертеже.

Таблица дополнительных номеров создается командой Создать таблицу исполнений. Для создания обеих таблиц (исполнений и дополнительных номеров) используется один и тот же набор элементов управления. Чтобы в результате выполнения команды в графическом или текстовом документе была создана таблица дополнительных номеров, в диалоге настройки параметров таблицы (см. раздел 2.13.5.2) выберите тип таблицы Таблица дополнительных номеров.

Все действия по созданию таблицы дополнительных номеров аналогичны действиям, выполняемым при создании таблицы исполнений (см. раздел 2.13.5.1).

Работа с созданной таблицей дополнительных номеров аналогична работе с таблицей исполнений (см. раздел 2.13.5.3).


2.13.3.7. Сохранение модели с исполнениями

Сохранение модели, содержащей исполнения, выполняется так же, как сохранение модели без исполнений.

При записи модели с исполнениями в форматы КОМПАС-3D сохраняются данные обо всех содержащихся в ней исполнениях.

При записи модели с исполнениями в другие форматы сохраняются данные только о текущем исполнении модели.

Кроме того, вы можете сохранить любое из исполнений в отдельный файл. Для этого выполните следующие действия.

1. В Дереве исполнений из контекстного меню нужного исполнения вызовите команду Создать копию. На экране появится диалог Информация о документе.

2. Введите в диалоге необходимую справочную информацию и нажмите кнопку ОК. На экране появится стандартный диалог сохранения файла.

3. Укажите нужное имя и место расположения файла на диске и нажмите кнопку Сохранить.

В файл будет сохранено только выбранное исполнение. В полученном файле оно будет основным.


2.13.4. Зеркальные исполнения модели

2.13. Исполнения модели

2.13.4. Зеркальные исполнения модели

В процессе проектирования может потребоваться создать зеркальные исполнения модели (детали, сборки) и/или компонентов модели.

Зеркальное исполнение представляет собой вариант модели, полученный ее зеркальным отражением относительно плоскости XY системы координат исходного исполнения.

Если исходное исполнение модели содержит компоненты, параметры их зеркального отражения настраиваются. Данная настройка аналогична выполняемой для компонентов модели, которые создаются зеркальным отражением (см. раздел 2.11.3.4).

Зеркальное исполнение модели имеет левостороннюю СК (см. раздел 2.8.3.1.1).

Зеркальное исполнение создается зависимым (см. раздел 2.13.1.1).

Для каждого исполнения модели можно создать только одно зеркальное исполнение.

Зеркальное исполнение не может быть исходным для создания исполнений.

Отображение зеркальных исполнений в Дереве исполнений и в Менеджере документа имеет следующие особенности.

– Пиктограммы зеркальных исполнений модели аналогичны пиктограммам обычных исполнений, но повернуты в противоположную сторону.

– Наименование зеркального исполнения формируется добавлением предопределенного суффикса к наименованию исходного исполнения. Суффикс указывается при настройке (см. раздел 9.1.11.11).

В остальном отображение зеркальных исполнений в Дереве исполнений и в Менеджере документа не отличается от обычных исполнений (см. разделы 2.13.1.2 и 2.13.1.3).

Работа с зеркальными исполнениями в целом аналогична работе с обычными зависимыми исполнениями (см. раздел 2.13.3). Особенности приведены в разделе 2.13.4.2.

Дополнительные возможности работы с зеркальными исполнениями описаны в разделах 2.13.4.3 и 2.13.4.4.

В этом разделе:

2.13.4.1. Способы создания зеркальных исполнений

2.13.4.2. Особенности работы с зеркальными исполнениями

2.13.4.3. Изменение положения компонента в зеркальном исполнении

2.13.4.3.1. Изменение параметров отражения компонента

2.13.4.4. Замена компонента его зеркальным исполнением


2.13.4.1. Способы создания зеркальных исполнений

Зеркальные исполнения модели создаются следующими способами.

– В Дереве построения модели или в Дереве исполнений командой Создать исполнение, если при выполнении данной команды включена опция Зеркальное исполнение. Работа команды описана в разделе 2.13.2.2.1.

– В Менеджере документа командой Создать зеркальное исполнение. Создание исполнений в менеджере документа описано в разделе 2.13.2.2.2.

– Автоматически, если модель является компонентом другой модели, и для этого компонента выполняется зеркальное отражение с результатом операции Создать зеркальное исполнение.

Отражение компонента выполняется в содержащей его модели командой Зеркальное отражение компонентов (см. раздел 2.11.3.3). Если при настройке параметров операции для этого компонента выбран способ Зеркальное отражение компонента и результат операции Создать зеркальное исполнение, то в модели-источнике компонента автоматически создается зеркальное исполнение. Настройка параметров отражения подробно описана в разделе 2.11.3.4.


2.13.4.2. Особенности работы с зеркальными исполнениями

– Сопряжения, наложенные на компоненты модели, не передаются в ее зеркальное исполнение.

– Все компоненты зеркального исполнения модели считаются зафиксированными. Их положение определяется положением компонентов в исходном исполнении.

– Если при создании зеркального исполнения модели, содержащей компоненты, для некоторых из них выбран способ отражения Зеркальное отражение компонента с результатом операции Сохранить зеркальный компонент в файле (см. разделы 2.11.3.4 и 2.11.3.4.1), обратите внимание на следующую особенность.

Источниками этих компонентов становятся отдельные модели из файлов. Поэтому к таким компонентам не применяются изменения их исходных компонентов, содержащихся в исходном исполнении. Исключение составляют следующие действия:

• перемещение исходного компонента — положение компонента в зеркальном исполнении изменяется,

• удаление исходного компонента — компонент удаляется из зеркального исполнения.

При необходимости вы можете отменить передачу результата этих действий. Для этого из контекстного меню компонента в зеркальном исполнении модели вызовите команду Отменить связь. Кроме того, после вызова команды этот компонент становится доступным для изменения и удаления. Для восстановления связи используйте соответствующую команду меню, которая появляется после отмены связи.

– Если в исходное исполнение модели добавляется новый компонент, то в зависимое зеркальное исполнение этой модели добавляется зеркальное исполнение компонента, при наличии такого исполнения в файле-источнике компонента. Если такого исполнения нет, то в зеркальное исполнение модели передается основное исполнение компонента, размещенное зеркально, т.е. зеркально отраженная вставка исходного исполнения. Данный компонент размещается способом Зеркальное отражение компонента с результатом операции Отображать компонент в зеркальном виде. На экране появляется сообщение Зеркальное исполнение компонента отсутствует. В зеркальное исполнение изделия добавлен компонент в зеркальном виде.

– Если в зеркальном исполнении модели создан новый компонент, и этот компонент передается в другие исполнения (см. раздел 2.13.3.3), то в этих исполнениях создается его зеркально отраженная вставка. Если требуется, чтобы компонент отображался в обычном (не зеркальном) виде, вызовите из его контекстного меню команду Свойства компонента и включите опцию Инвертировать ось Z СК на Панели свойств.


2.13.4.3. Изменение положения компонента в зеркальном исполнении

Для изменения положения компонента в зеркальном исполнении используется команда Разместить компонент контекстного меню. Работа команды имеет следующие особенности.

– Для компонентов зеркального исполнения, связь которых с компонентами исходного исполнения отключена, а также для компонентов, добавленных в зеркальное исполнение после его создания, команда запускает процесс размещения компонентов модели (см. раздел 2.11.7.3).

– Для компонентов зеркального исполнения, сохраняющих связь с компонентами исходного, команда запускает процесс изменения параметров отражения компонента (см. раздел 2.13.4.3.1). Обратите внимание на то, что при сохранении связи между компонентами изменение параметров доступно только для зеркальных и симметричных вставок компонентов (см. разделы 2.11.3.4, 2.11.3.4.1 и 2.11.3.4.2). Для всех остальных компонентов (т.е. компонентов, полученных зеркальным отражением с результатом в виде зеркального исполнения или модели, сохраненной в файл) команда недоступна.

Если компонент является локальной деталью, то команда Разместить компонент доступна только в том случае, если связь этого компонента с компонентом исходного исполнения отключена.

В этом разделе:

2.13.4.3.1. Изменение параметров отражения компонента


2.13.4.3.1. Изменение параметров отражения компонента

После вызова команды Разместить компонент для компонента зеркального исполнения, связанного с компонентом исходного, на Панели свойств появляются элементы настройки параметров отражения выбранного компонента (рис. 2.13.7). Набор элементов панели зависит от заданных параметров отражения.

Рис. 2.13.7. Панель свойств при изменении положения компонента

Группа переключателей Способ позволяет выбрать способ отражения компонента:

– Зеркальное отражение,

– Симметричное расположение.

В обоих случаях компонент представляет собой еще одну вставку исходного компонента: в первом — зеркальную, во втором — симметричную.

При выборе способа Симметричное расположение на Панели свойств появляются элементы настройки положения компонента.

Положение компонента определяется относительно плоскости/центра симметрии исходного компонента или «базового» компонента.

Выберите вариант задания положения, активизировав один из следующих переключателей.

– Типовое положение

На Панели свойств появляется предопределенный список объектов исходного компонента, которые могут использоваться для определения положения компонента в зеркальном исполнении. Строки списка формируются по следующему шаблону: <Номер варианта><Тип объекта><Положение объекта>.

– Положение при ручном указании объекта

В окне модели появляется Окно модели-источника исходного компонента. Данное окно позволяет вручную указать объект, который будет использоваться для расчета положения компонента в зеркальном исполнении. Вид окна и работа в нем аналогичны описанным в разделе 2.8.7.1.1. Наименование выбранного объекта отображается в поле Объект внутренней симметрии Панели свойств.

– Положение по базовому компоненту

На Панели свойств появляется поле Положение по базовому компоненту. «Базовый» компонент выбирается в Дереве построения или в окне модели.

Под «базовым» компонентом понимается компонент, относительно которого сохраняется положение размещаемого компонента. В качестве «базового» может быть выбран компонент зеркального исполнения, который расположен на одном уровне с размещаемым компонентом и получен способом Симметричное расположение компонента. Наименование выбранного компонента появляется в соответствующем поле.

При изменении параметров размещения компонента положение его фантома в окне модели изменяется.

Чтобы завершить изменение параметров, нажмите кнопку Применить на Панели специального управления.

Процесс изменения положения компонента также запускается командой Редактировать меню Редактор.


2.13.4.4. Замена компонента его зеркальным исполнением

Чтобы зеркальное исполнение модели с компонентами содержало зеркальное исполнение компонента, в процессе создания исполнения выполните следующие настройки — выберите для компонента способ Зеркальное отражение компонента с результатом операции Создать зеркальное исполнение (данные настройки являются умолчательными для всех компонентов, кроме стандартных изделий, см. разделы 2.11.3.4 и 2.11.3.4.1). В этом случае в контекстном меню полученного компонента активизируется команда Заменить зеркальным исполнением (рядом с командой появляется «галочка»). Если требуется отказаться от применения зеркального исполнения компонента, вызовите эту команду. «Галочка» исчезнет, зеркальное исполнение компонента будет заменено его исходным исполнением, отраженным зеркально.

Если зеркальное исполнение модели с компонентами содержит исходное исполнение компонента, вы можете заменить его зеркальным исполнением. Для этого вызовите из контекстного меню компонента команду Заменить зеркальным исполнением. Команда присутствует в меню компонентов, полученных способом Симметричное расположение компонента или Зеркальное отражение компонента с результатом операции Отображать компонент в зеркальном виде. После вызова команды исходное исполнение компонента заменяется зеркальным, а команда отмечается «галочкой».

Если исходное исполнение компонента расположено симметрично, то после вызова команды Заменить зеркальным исполнением способ размещения компонента автоматически изменяется.

Если зеркальное исполнение компонента отсутствует в документе, то после вызова команды замены исходного исполнения зеркальным в Дереве построения появляется признак ошибки. Чтобы исправить ошибку, создайте зеркальное исполнение компонента в его файле-источнике или вернитесь к использованию исходного исполнения компонента.

При возврате к использованию в модели исходного исполнения компонента восстанавливаются все настройки отражения, выполненные для этого компонента в процессе создания зеркального исполнения модели.


2.13.5. Таблица исполнений

2.13. Исполнения модели

2.13.5. Таблица исполнений

Сведения о переменных данных исполнений приводятся в таблице исполнений. Для создания таблицы исполнений можно использовать модель или ассоциативный вид с модели, созданный в чертеже. Порядок создания таблицы приведен в разделе 2.13.5.1.

Таблица исполнений может быть размещена в графическом или текстовом документе. Вы можете редактировать данные, содержащиеся в таблице, изменять ее заголовок, расположение и т.п.

Если таблица исполнений ассоциативно связана с источником данных (моделью или ассоциативным видом с модели), то вы можете получать данные из документа-источника, открывать его, использовать команды редактирования, доступные для ассоциативных отчетов (см. раздел 5.2.3.8). Для таблицы, не связанной с источником данных, эти действия недоступны.

Работа с таблицей исполнений описана в разделе 2.13.5.3.

Настройка параметров таблицы исполнений выполняется при ее создании или редактировании (см. раздел 2.13.5.2). Отображение текста таблицы исполнений, расположенной в графическом или текстовом документе, подчиняется настройке параметров текста таблицы отчета, выполненной для этого документа (см. разделы 9.2.4.7 и 9.2.6.24).

В этом разделе:

2.13.5.1. Создание таблицы

2.13.5.1.1. Связь основной надписи чертежа с ассоциативной таблицей исполнений

2.13.5.2. Настройка параметров таблицы

2.13.5.2.1. Настройка параметров отображения столбцов таблицы

2.13.5.3. Работа с таблицей


2.13.5.1. Создание таблицы

Для создания таблицы исполнений выполните следующие действия.

1. Откройте модель или чертеж, содержащий ассоциативный вид с модели.

2. Если создание таблицы выполняется в чертеже, укажите нужный ассоциативный вид с модели. Если нужный вид не выбран пользователем, то для создания таблицы автоматически выбирается текущий ассоциативный вид.

3. Вызовите команду Создать таблицу исполнений из меню Сервис — Отчеты или с помощью одноименной кнопки на панели Отчеты.

На Панели свойств появятся элементы создания таблицы. Они расположены на двух вкладках — Таблица исполнений и Компоновка.

Кроме этого, автоматически откроется диалог Параметры таблицы исполнений, позволяющий настроить внешний вид таблицы (см. раздел 2.13.5.2).

4. Выполните необходимые настройки в диалоге Параметры таблицы исполнений и закройте его, нажав кнопку ОК. В дальнейшем вы можете вызвать этот диалог с помощью кнопки Настроить... Панели свойств.

5. После вызова команды создания таблицы на Панели свойств активна вкладка Таблица исполнений (рис. 2.13.8). На этой вкладке с помощью переключателей Обозначение задайте порядок отображения обозначений исполнений в таблице.

Рис. 2.13.8. Панель свойств при создании таблицы исполнений;
Вкладка Таблица исполнений

Если активным является переключатель Только номера исполнений, то для первого исполнения в таблице отображается полное обозначение, а для остальных исполнений — только номера.

Чтобы обозначение каждого исполнения отображалось полностью, активизируйте переключатель Полные обозначения.

6. Проверьте состояние опции Ассоциативная таблица.

Если опция включена, то таблица исполнений будет ассоциативно связана с документом — источником данных. Если в дальнейшем значения свойств исполнений в документе-источнике изменятся, эти изменения можно будет передать в таблицу исполнений (см. раздел 2.13.5.3).

При отключенной опции создается неассоциативная таблица исполнений. В этом случае данные, измененные в документе-источнике, в таблицу не передаются.

Если таблица исполнений создается для модели, то опция Ассоциативная таблица присутствует на Панели свойств только в том случае, если эта модель сохранена в файл на диске.

Ассоциативная таблица может быть размещена только в графическом документе. При размещении в текстовом документе таблица становится неассоциативной вне зависимости от состояния опции.

7. Вы можете включить автоматическое присвоение номеров таблицам исполнений. Для этого выберите из списка Нумерация наименование группы нумерации (об автоматической нумерации объектов см. раздел 3.10.1).

8. При создании ассоциативной таблицы исполнений для ассоциативного вида с модели в чертеже вы можете связать эту таблицу с основной надписью чертежа (см. раздел 2.13.5.1.1).

9. Если требуется, чтобы перечень исполнений модели был показан не одной таблицей, а в виде нескольких таблиц, перейдите на вкладку Компоновка (рис. 2.13.9).

Рис. 2.13.9. Вкладка Компоновка

10. Для получения нескольких таблиц включите опцию Разбить таблицу.

11. В поле Строк в таблице задайте максимальное количество строк, входящих в каждую таблицу. Соответственно этому значению общий список исполнений будет разделен на несколько списков, каждый из которых помещается в отдельную таблицу. Параметры отображения всех таблиц одинаковы.

12. Чтобы задать порядок размещения таблиц на листе, выберите нужное направление размещения из раскрывающегося списка Компоновка.

Вариант Вправо, затем вниз позволяет располагать таблицы горизонтальными рядами. Количество таблиц в ряду задается в поле Вправо не более.

Вариант Вниз, затем вправо позволяет располагать таблицы вертикальными рядами. Количество таблиц в ряду задается в поле Вниз не более.

13. Поле Зазор, мм позволяет задать расстояние между таблицами. Вы можете ввести значение расстояния вручную или выбрать его из раскрывающегося списка.

14. Для завершения создания таблицы исполнений нажмите кнопку Создать объект.

Если создание таблицы выполняется для ассоциативного вида с модели в чертеже, то в поле чертежа появится фантом таблицы. Укажите место расположения точки привязки таблицы курсором или путем ввода координат на Панели свойств и щелкните левой кнопкой мыши для фиксации таблицы. Таблица помещается в тот ассоциативный вид, который выбран для ее создания.

Если создание таблицы выполняется в модели, то на экране появится диалог открытия файла. Откройте нужный графический или текстовый документ. В графическом документе разместите фантом таблицы, как описано выше. В текстовом документе таблица размещается автоматически.

При создании таблицы исполнений в чертеже вы можете перевыбрать ассоциативный вид, для которого создается таблица, до завершения работы команды. Для этого нужно просто щелкнуть мышью на нужном виде в Дереве или в окне чертежа.

Для таблицы, размещенной в чертеже, можно задать название, см. раздел 3.4.2.4.

В этом разделе:

2.13.5.1.1. Связь основной надписи чертежа с ассоциативной таблицей исполнений


2.13.5.1.1. Связь основной надписи чертежа с ассоциативной таблицей исполнений

Если в чертеже имеется таблица исполнений, содержащая столбцы со свойствами Материал и Масса, то в соответствующих этим свойствам ячейках основной надписи чертежа вместо значений свойств должен быть текст, указывающий, что нужные сведения содержатся в таблице (например, текст вида См. табл.). Этот текст формируется автоматически:

– при создании таблицы исполнений для ассоциативного вида с модели (см. раздел 2.13.5.1),

– при редактировании таблицы исполнений, размещенной в чертеже, командой Редактировать таблицу.

Текст ссылки на таблицу исполнений может быть сформирован только в том случае, если эта таблица является ассоциативной (при создании таблицы включена опция Ассоциативная таблица).

Для формирования текста ссылки используются элементы вкладки Таблица исполнений Панели свойств, показанные на рис. 2.13.10.

Рис. 2.13.10. Элементы формирования ссылки

Ссылки создаются при включенной опции Ссылки в основной надписи. В поле, расположенном справа от этой опции, содержится умолчательный текст ссылки. При необходимости вы можете изменить этот текст.

Если таблица исполнений имеет автоматически сформированный номер (т.е. в списке Нумерация выбран вариант, отличный от Не использовать), то этот номер может быть добавлен к тексту ссылки. Для этого включите опцию Добавить номер таблицы.

К тексту ссылки добавляется только сам номер; текст до и после номера, заданный при настройке параметров нумерации (см. раздел 9.2.6.23), не добавляется.

Чтобы для текста ссылки был автоматически подобран такой шрифт, при котором ссылка полностью уместится в отведенной для нее ячейки основной надписи, включите опцию Подобрать параметры шрифта. Если опция выключена, то тексты ссылок могут выйти за пределы своих ячеек.

После завершения создания или редактирования таблицы исполнений содержимое ячеек Материал и Масса основной надписи чертежа заменяется текстом ссылки на эту таблицу. Это происходит в том случае, если таблица исполнений содержит столбцы соответствующих свойств. Если столбец какого-либо свойства отсутствует в таблице, то в «его» ячейке основной надписи отображается не ссылка, а значение свойства, соответствующее тому исполнению модели, которое связано с основной надписью. Например, если столбец Масса исключить из таблицы исполнений, а столбец Материал оставить, то ссылка появится только в ячейке Материал, а в ячейке Масса будет показано значение массы модели исполнения, связанного с основной надписью. О выборе модели для связи с основной надписью чертежа см. раздел 3.7.3.8


2.13.5.2. Настройка параметров таблицы

Настройка параметров таблицы исполнений выполняется в диалоге, показанном на рис. 2.13.11.

Рис. 2.13.11. Диалог настройки параметров таблицы исполнений

Диалог вызывается при создании или редактировании таблицы исполнений нажатием кнопки Настроить... на вкладке Таблица исполнений Панели свойств.

Кроме того, диалог появляется автоматически после вызова команды Создать таблицу исполнений.

Диалог содержит окно настройки таблицы и инструментальную панель.

Он используется для настройки параметров не только таблицы исполнений, но и таблицы дополнительных номеров (о дополнительных номерах см. раздел 2.13.3.6). Тип таблицы, для которой будет выполняться настройка, выбирается из раскрывающегося списка Тип таблицы, расположенного на инструментальной панели диалога. Набор элементов управления диалога зависит от выбранного типа.

В рамках настройки таблицы исполнений доступны следующие действия.

– Добавление, перемещение и удаление столбцов таблицы — элементы управления аналогичны используемым для настройки таблицы отчета (см. таблицу 5.2.2).

– Настройка параметров отображения столбцов таблицы и данных содержащихся в них (см. раздел 2.13.5.2.1).

– Задание высоты строк таблицы. Для этого используется поле Высота строк, мм. Значение в поле вводится вручную.

– Настройка «шапки» таблицы (см. раздел 5.2.2.2.4).

Чтобы завершить настройку параметров таблицы, в диалоге Параметры таблицы исполнений нажмите кнопку ОК.

Если перечень исполнений представлен в виде нескольких таблиц, каждая из них будет отображена в соответствии с выполненной настройкой. Сформированный заголовок будет содержаться в каждой из этих таблиц.

В этом разделе:

2.13.5.2.1. Настройка параметров отображения столбцов таблицы


2.13.5.2.1. Настройка параметров отображения столбцов таблицы

Для столбцов таблицы исполнений доступна настройка следующих параметров:

• Свойство, Имя столбца, Единица измерения, Знаков после запятой, Ширина столбца, мм, Выравнивание, Переносить по словам — настройка аналогична настройке параметров стиля отчета, описанной в таблице 5.2.3,

• Формат значения, Объединять ячейки — настройка описана в таблице 2.13.1.

Табл. 2.13.1. Дополнительные параметры настройки таблицы исполнений

Элемент

Описание

Формат значения

Поле1, позволяющее выбрать вариант отображения значения свойства в таблице исполнений. Например, для свойства Обозначение возможны следующие варианты отображения:

– Полные обозначения,

– Только номера исполнений.

Выбор нужного варианта для данного свойства равнозначен использованию переключателя Обозначение Панели свойств.

Объединять ячейки

Опция, позволяющая объединять соседние ячейки столбца таблицы исполнений в том случае, если содержимое этих ячеек одинаково, т.е. если отображаемое свойство имеет одно и то же значение для соседних исполнений.
  1. Элемент управления позволяет выбрать вариант из раскрывающегося списка. После щелчка мышью по ячейке в ее правом углу появляется кнопка с треугольником. При нажатии на кнопку на экране появляется список, из которого можно выбрать вариант параметра.


2.13.5.3. Работа с таблицей

Таблица исполнений может быть ассоциативно связана или не связана с источником данных. Ассоциативность таблицы определяется при ее создании (см. раздел 2.13.5.1). При необходимости вы можете отменить ассоциативность созданной таблицы, как описано в разделе 5.2.3.8.3, но нельзя сделать неассоциативную таблицу ассоциативной.

Работа с неассоциативной таблицей выполняется с помощью типовых команд.

Для ассоциативных таблиц доступны как типовые команды, например, вырезание, копирование, изменение стиля, так и специальные команды, аналогичные командам работы с ассоциативным отчетом.

Ассоциативная таблица исполнений имеет связь с моделью или ассоциативным видом с модели, который использовался для ее создания. Она отображается аналогично ассоциативному отчету в дополнительной внешней рамке, показанной пунктиром (см. рис. 5.2.14).

Если ассоциативная таблица исполнений разделена на несколько таблиц, то все эти таблицы являются единым объектом и отображаются в общей рамке.

Вы можете обновлять данные в ассоциативной таблице, открывать документ-источник для редактирования объектов, изменять точку привязки таблицы. Эти действия аналогичны описанным в разделах 5.2.3.8.1 и 5.2.3.8.2.

Для редактирования ассоциативной таблицы используется команда Редактировать таблицу контекстного меню (меню вызывается для выделенной таблицы). Команда также может быть вызвана двойным щелчком мыши по внешней рамке таблицы. После вызова команды на Панели свойств появляются элементы изменения параметров таблицы. При редактировании таблицы доступны все те же действия, что и при ее создании (см. раздел 2.13.5.1), кроме включения/выключения ассоциативности.

Для завершения редактирования таблицы исполнений нажмите кнопку Создать объект на Панели свойств.

Кроме указанных выше действий, вы можете задать название ассоциативной таблицы или таблиц, на которые она разделена. Для этого выделите ассоциативную таблицу и вызовите из контекстного меню команду Название.... На экране появится диалог ввода названий таблиц. Описание работы в диалоге приведено в разделе 3.4.2.4.

Данные, содержащиеся в таблице, как ассоциативной, так и неассоциативной, можно отредактировать в поле документа. Для перехода в режим редактирования дважды щелкните мышью по таблице (для ассоциативной таблицы — в любом месте, кроме пунктирной рамки). В этом режиме доступны все приемы работы с таблицами (см. раздел 4.2.2).

Во время редактирования с помощью команды Редактировать таблицу можно изменить параметры таблицы (например, набор колонок), нажав кнопку Настроить... на Панели свойств. В этом случае после завершения редактирования таблица создается заново, в результате чего теряются все ее изменения, выполненные в поле документа.


2.13.6. Спецификация по сборке с исполнениями

2.13. Исполнения модели

2.13.6. Спецификация по сборке с исполнениями

В этом разделе:

2.13.6.1. Создание спецификации по сборке с исполнениями

2.13.6.2. Компоненты с одинаковыми номерами позиций

2.13.6.2.1. Окно Группы компонентов

2.13.6.2.2. Формирование в сборке группы компонентов с одной позицией


2.13.6.1. Создание спецификации по сборке с исполнениями

Для создания спецификации по сборке с исполнениями можно использовать любую из следующих команд:

– Создать спецификацию по сборке (см. раздел 6.2.3.8)
Эта команда формирует в сборке внутренние объекты спецификации и создает документ-спецификацию, подключенную к сборке. Стиль спецификации определяется настройкой для новых спецификаций по сборке, см. раздел 9.2.5.2.1. По умолчанию для сборок с количеством исполнений не более 3 используется групповая спецификация по варианту А (ГОСТ 2.113–75), а для сборок с большим количеством исполнений — по варианту Б (ГОСТ 2.113–75 Ф.1, 1в). При необходимости вы можете изменить умолчательную настройку.

– Создать объекты спецификации (см. раздел 6.2.3.7.1)
Эта команда формирует объекты спецификации в компонентах сборки, опционально создает и сохраняет документ-спецификацию, подключенную к сборке. Стиль спецификации определяется общей настройкой для новых спецификаций, см. раздел 9.2.5.1.1. По умолчанию для новых спецификаций используется стиль Простая спецификация (ГОСТ 2.106–96), поэтому перед тем, как применять команду Создать объекты спецификации к сборке с исполнениями, настройку следует изменить, выбрав в качестве умолчательного стиля один из стилей для групповых спецификаций.


2.13.6.2. Компоненты с одинаковыми номерами позиций

Иногда требуется, чтобы в спецификациях на разные исполнения сборки определенные компоненты имели один и тот же номер позиции. Обычно это нужно для компонентов, которые выполняют одну и ту же функцию, но в разных исполнениях сборки представлены разными моделями (или разными исполнениями моделей).

Чтобы некоторые компоненты сборки КОМПАС-3D имели один и тот же номер позиции, их следует объединить в группу компонентов с одинаковой позицией. В одной сборке может быть несколько таких групп. Один компонент может входить только в одну группу. Информация о группах компонентов хранится в файле сборки.

Все компоненты, включенные в одну группу, будут иметь в спецификации один и тот же номер позиции.

Работа с группами производится в окне Группы компонентов. Для его включения/отключения служит одноименная кнопка на панели Спецификация. Интерфейс окна Группы компонентов и приемы работы в нем описаны в разделе 2.13.6.2.1.

Порядок формирования группы компонентов описан в разделе 2.13.6.2.2.

Если сборка содержит несколько одинаковых компонентов, то не обязательно включать всех их в одну группу. Например, из десяти болтов в группу могут быть включены лишь четыре. В результате эти четыре болта будут иметь один номер позиции, а остальные — другой, определяемый сортировкой объектов в спецификации.

В этом разделе:

2.13.6.2.1. Окно Группы компонентов

2.13.6.2.2. Формирование в сборке группы компонентов с одной позицией


2.13.6.2.1. Окно Группы компонентов

Окно Группы компонентов (рис. 2.13.12) служит для работы с группами компонентов, которые должны иметь один и тот же номер позиции в спецификации. Включение и отключение отображения на экране этого окна производится кнопкой Группы компонентов на панели Спецификация.

Рис. 2.13.12. Окно Группы компонентов

Основную площадь окна Группы компонентов занимает список компонентов, входящих в текущую группу. Список представлен в виде таблицы: в первой колонке отображаются обозначения исполнений сборки, а во второй — обозначения входящих в эти исполнения компонентов, позиции которых должны быть одинаковы. При выделении компонента в списке он подсвечивается в окне модели.

Над списком компонентов находится инструментальная панель окна Группы компонентов. Ее кнопки доступны только при работе со сборкой.

Над инструментальной панелью находится поле со списком для выбора текущей группы. Группы в списке отсортированы по алфавиту.

Ниже описаны приемы работы с группами компонентов.

Чтобы записать в файл модели результаты работы с группами компонентов, файл необходимо сохранить. Отмена действий при работе с группами не предусмотрена, поэтому, чтобы отказаться от создания/удаления/изменения групп, следует закрыть файл сборки без сохранения.

Создание группы компонентов

Чтобы создать новую группу компонентов, нажмите кнопку Создать группу на инструментальной панели окна Группы компонентов. На экране появляется диалог для ввода имени новой группы. Введите имя группы и нажмите кнопку ОК диалога. Диалог закрывается, созданная группа добавляется в список групп и автоматически становится текущей. Новая группа не содержит компонентов, поэтому их список пуст.

Переименование групп компонентов невозможно.

Удаление группы компонентов

Чтобы удалить группу (группы) компонентов, нажмите кнопку Удалить группу на инструментальной панели окна Группы компонентов. На экране появляется диалог Удалить группы (рис. 2.13.13). Выполните в нем одно из следующих действий:

– чтобы удалить все группы, выберите вариант Все,

– чтобы удалить одну или несколько групп, выберите вариант Группы и укажите удаляемые группы в списке диалога.

После этого нажмите в диалоге кнопку ОК. По умолчанию в диалоге включена опция Группы и выделена та группа, которая была текущей при вызове диалога.

Рис. 2.13.13. Диалог Удалить группы

Удаление из сборки группы компонентов означает лишь удаление из файла информации об этой группе. Компоненты, входившие в группу, остаются в сборке на своих местах.

Добавление компонентов в группу

Чтобы добавить компоненты в текущую группу, выделите их в Дереве построения и нажмите кнопку Добавить в группу на инструментальной панели окна Группы компонентов. Обозначения исполнения сборки и выбранных компонентов появляются в списке окна Группы компонентов.

Если добавляемые компоненты входят в другую группу, то они автоматически удаляются из этой группы.

Обычно в группу включают компоненты из разных исполнений сборки, но при необходимости можно формировать группы из компонентов одного исполнения, а также создавать группы компонентов в сборках без исполнений.

Удаление компонента из группы

Чтобы удалить компонент из группы, выделите его в списке окна Группы компонентов и нажмите кнопку Удалить на инструментальной панели этого окна.

Обозначение компонента исчезает из списка.


2.13.6.2.2. Формирование в сборке группы компонентов с одной позицией

Формирование в сборке группы компонентов состоит в создании новой (или выборе существующей) группы и включении в нее нужных компонентов из разных исполнений.

Для создания в сборке групп компонентов с одной и той же позицией выполните следующие действия.

1. Включите отображение окна Группы компонентов.

2. Создайте группу компонентов. Для этого:

2.1. Нажмите кнопку Создать группу на инструментальной панели окна Группы компонентов.

2.2. В появившемся диалоге введите имя новой группы и закройте его кнопкой ОК.

3. Добавьте в группу компоненты. Для этого:

3.1. Сделайте текущим одно из исполнений сборки, содержащее компоненты, которые должны иметь одинаковые номера позиций с компонентами в другом исполнении.

3.2. Выделите эти компоненты в Дереве построения и нажмите кнопку Добавить в группу на инструментальной панели окна Группы компонентов.

Выбранные компоненты появляются в таблице: в столбце Исполнение отображается обозначение исполнения сборки, а в столбце Объект — обозначения компонентов (см. рис. 2.13.12).

3.3. Проделайте действия, описанные в п.п. 3.1 и 3.2 для остальных компонентов, которые должны иметь тот же номер позиции, что и компоненты, уже добавленные в текущую группу.

4. Вызовите команду Файл — Сохранить, чтобы информация о группах компонентов была записана в файл модели.

Если группа, в которую требуется добавить компоненты, уже существует, то вместо создания новой группы сделайте нужную группу текущей. Для этого выберите ее имя из списка групп.


2.14. Редактирование и настройки модели

В этом разделе:

2.14.1. Управление состоянием объектов

2.14.1.1. Включение и отключение видимости объектов

2.14.1.1.1. Управление видимостью отдельных объектов

2.14.1.1.2. Управление видимостью вспомогательных объектов

2.14.1.1.3. Управление видимостью объектов, находящихся на одном слое

2.14.1.2. Исключение объектов из расчета

2.14.2. Управление цветом и оптическими свойствами объектов

2.14.2.1. Запрет редактирования объектов модели

2.14.3. Редактирование объектов модели

2.14.3.1. Редактирование эскиза

2.14.3.1.1. Редактирование изображения в эскизе модели

2.14.3.1.2. Размещение эскиза на плоскости

2.14.3.2. Редактирование операции

2.14.3.3. Редактирование числовых параметров операции

2.14.3.3.1. Редактирование значения переменной

2.14.3.3.2. Редактирование размера операции

2.14.3.4. Редактирование моделей, вставленных из библиотеки

2.14.3.5. Особенности редактирования отдельных объектов

2.14.3.5.1. Отверстие из библиотеки; спираль; отверстие в листовом теле

2.14.3.5.2. Размеры и обозначения

2.14.3.5.3. Редактирование сопряжений

2.14.3.6. Другие приемы редактирования

2.14.3.6.1. Редактирование модели с помощью Окна Свойства

2.14.3.6.2. Редактирование модели с помощью Указателя окончания построения

2.14.3.6.3. Изменение последовательности операций

2.14.3.7. Перестроение модели

2.14.3.8. Удаление объекта

2.14.4. Изменение структуры модели

2.14.4.1. Преобразование деталь - подсборка и подсборка - деталь

2.14.4.2. Объединение компонентов в подсборку

2.14.4.3. Преобразование локальной детали

2.14.4.4. Запись источника одинаковых компонентов в новый файл

2.14.4.5. Разрушение подсборки

2.14.4.6. Перенос и копирование компонентов

2.14.5. Сохранение сборки как детали и детали как сборки

2.14.5.1. Настройка параметров записи сборки в файл детали

2.14.5.2. Отличительные особенности детали и сборки

2.14.6. МЦХ и параметры штриховки модели

2.14.6.1. Общие приемы задания параметров МЦХ

2.14.6.1.1. Материал и плотность материала

2.14.6.1.2. Масса и координаты центра масс

2.14.6.2. Параметры расчета МЦХ тел

2.14.6.3. Параметры расчета МЦХ компонентов

2.14.6.4. Параметры расчета МЦХ детали, сборки

2.14.6.5. Настройка МЦХ

2.14.6.6. Параметры штриховки модели


2.14.1. Управление состоянием объектов

2.14. Редактирование и настройки модели

2.14.1. Управление состоянием объектов

В этом разделе:

2.14.1.1. Включение и отключение видимости объектов

2.14.1.1.1. Управление видимостью отдельных объектов

2.14.1.1.2. Управление видимостью вспомогательных объектов

2.14.1.1.3. Управление видимостью объектов, находящихся на одном слое

2.14.1.2. Исключение объектов из расчета


2.14.1.1. Включение и отключение видимости объектов

Вспомогательные оси, плоскости (особенно когда их много в модели), не задействованные в выполнении операций эскизы, отдельные компоненты и другие объекты иногда мешают просмотру изображения модели. Для удобства работы с моделью вы можете сделать невидимым любой из этих объектов. При этом он по-прежнему будет учитываться в иерархии, и его производные объекты будут отображаться корректно.

Включать и отключать видимость можно:

– для отдельного объекта (см. раздел 2.14.1.1.1),

– для всех вспомогательных объектов или групп однотипных вспомогательных объектов (см. раздел 2.14.1.1.2),

– для всех объектов, находящихся на одном слое (см. раздел 2.14.1.1.3).

В этом разделе:

2.14.1.1.1. Управление видимостью отдельных объектов

2.14.1.1.2. Управление видимостью вспомогательных объектов

2.14.1.1.3. Управление видимостью объектов, находящихся на одном слое


2.14.1.1.1. Управление видимостью отдельных объектов

Чтобы скрыть объект или несколько объектов, выделите их в Дереве построения или в окне модели и вызовите из контекстного меню команду Скрыть. Объекты станут невидимыми. Соответствующие им пиктограммы останутся на своих местах в Дереве построения, но будут отображаться серым цветом.

Чтобы сделать скрытый объект или несколько объектов видимыми, выделите их в Дереве модели и вызовите из контекстного меню команду Показать. Объекты станут видимыми.

Обратите внимание на то, что тело всегда показывается и скрывается целиком, даже если при вызове команды Показать или Скрыть была выделена отдельная формообразующая операция. Например, в результате включения отображения приклеенного элемента выдавливания на экране появится все тело, содержащее этот элемент, а в результате скрытия элемента все тело перестанет отображаться.

То же самое относится к поверхностям. Например, в результате показа или скрытия поверхности, участвующей в операции Сшивка, в окне модели возникнут или исчезнут все остальные поверхности, участвующие в этой же операции.

После вызова команды Показать или Скрыть для прочих объектов (вспомогательных осей, кривых, точек и т.п.) в окне модели появляются или скрываются только эти объекты.

Команда Скрыть (Показать) недоступна, если все выделенные объекты уже скрыты (показаны).

Применение к объекту команды Скрыть или Показать изменяет значение имеющегося у этого объекта свойства Видимость: оно принимает значение Скрытый или Видимый соответственно. Значение свойства можно изменять вручную, без вызова команды. Для этого служит Окно Свойства, см. раздел 1.4.2.2.


2.14.1.1.2. Управление видимостью вспомогательных объектов

Чтобы скрыть все вспомогательные объекты в модели, нажмите кнопку Скрыть все объекты на панели Вид. Чтобы скрыть вспомогательные объекты определенного типа, вызовите из меню этой кнопки нужную команду (рис. 2.14.1). После вызова любой из команд скрываются все объекты соответствующего типа — как уже существующие в модели, так и вновь создаваемые. Пиктограммы этих объектов отображаются в Дереве построения серым цветом. Кнопка, расположенная рядом с названием вызванной команды в меню, переходит в нажатое состояние, свидетельствующее о том, что объекты скрыты.

Если модель содержит компоненты, то видимостью вспомогательных объектов в них можно управлять отдельно. Для этого служит кнопка Скрыть все объекты в компонентах на панели Вид. Кнопка имеет такое же меню, как и кнопка Скрыть все объекты. Разница в том, что действие команд Скрыть все объекты в компонентах распространяется только на компоненты модели, а команд Скрыть все объекты — и на модель, и на ее компоненты.

Рис. 2.14.1. Указание типа объекта для скрытия

Чтобы сделать вспомогательные объекты видимыми, необходимо повторно вызвать команду скрытия.

Объекты, скрытые описанными выше командами, невозможно сделать видимыми с помощью команды Показать — она отсутствует в контекстном меню этих объектов.

Изменение значения свойства Видимость в окне Свойства для этих объектов недоступно.

Из меню кнопок Скрыть все объекты и Скрыть все объекты в компонентах можно сформировать отдельные инструментальные панели (пример см. на рис. 2.14.2) и использовать их вместо меню. Для этого следует «перетащить» меню мышью за заголовок в нужном направлении.

Рис. 2.14.2. Панель Скрыть

Обратите внимание на отличие панелей Скрыть и Скрыть в компонентах от остальных инструментальных панелей: состав и порядок кнопок на них изменить невозможно.

Если модель и/или ее компоненты содержат компоновочную геометрию (см. раздел 2.8.6), имейте в виду следующее.

Команда Компоновочная геометрия управляет отображением всей компоновочной геометрии, содержащейся в модели и/или ее компонентах.

Остальные команды не влияют на отображение объектов компоновочной геометрии.


2.14.1.1.3. Управление видимостью объектов, находящихся на одном слое

Управление видимостью объектов возможно с помощью слоев (о слоях см. раздел 2.15.14).

Все объекты, находящиеся на одном слое, могут быть одновременно скрыты или показаны путем изменения значения свойства Видимость для этого слоя.

Обратите внимание на то, что у объекта свойство Видимость должно иметь значение По слою — только в этом случае изменение значения свойства слоя изменит значение свойства объекта.

Значение По слою — умолчательное значение свойства Видимость для всех объектов.

Если значение свойства Видимость у объекта изменено по отношению к умолчательному, т.е. имеет значение Скрытый (или Видимый), то объект скрыт (или показан) вне зависимости от состояния слоя, на котором он находится.

Для просмотра и изменения значений свойств объектов служит Окно Свойства, см. раздел 1.4.2.2.


2.14.1.2. Исключение объектов из расчета

Вы можете исключать из расчета любые элементы и компоненты модели первого уровня. При исключении объекта из расчета модель перестраивается так, как будто указанный объект удален, однако информация о нем сохраняется в документе.

Чтобы исключить один или несколько объектов из расчета, выделите их в Дереве построения или в окне модели и вызовите из контекстного меню команду Исключить из расчета.

Для компонента команда исключения из расчета может быть вызвана:

– в Дереве построения — из контекстного меню компонента,

– в окне модели — из контекстного меню элемента этого компонента или элемента любого из его компонентов.

После вызова команды модель будет перестроена без учета исключенных объектов и производных от них операций и объектов. Пиктограммы объектов, исключенных из расчета, в Дереве построения отобразятся серым цветом и будут помечены пиктограммой-«крестиком».

Чтобы вновь включить в расчет один или несколько объектов, выделите их в Дереве построения и вызовите из контекстного меню команду Включить в расчет.

Исключенные из расчета объекты временно удаляются из модели. Поэтому базировавшиеся на них объекты иногда могут отмечаться как ошибочные. Ошибки исчезают после включения объектов в расчет.

Исключение объектов из расчета позволяет сократить время расчета при построении дополнительных элементов или перестроении модели, а также увидеть, как выглядела модель до построения определенных элементов.

Например, после построения последовательности производных элементов требуется перейти к построению других элементов, не связанных и не пересекающихся с существующими. Вы можете исключить существующую последовательность из расчетов, после этого время перестроения модели при создании новых элементов существенно сократится (система не будет выполнять проверку взаимного пересечения всех элементов и рассчитывать линии пересечения). Когда нужные элементы будут построены, включите все элементы в расчет. Контроль их взаимного положения будет произведен однократно.

Вы можете исключать из расчетов фаски, скругления, отверстия и прочие мелкие элементы, если из-за большого их количества построение новых формообразующих элементов происходит слишком медленно.

С помощью команды Исключить из расчета можно исключать объекты из расчета выборочно, т.е. вне зависимости от того, какое положение они занимают в иерархии элементов модели и, следовательно, в Дереве построения.

Можно привести пример не только временного исключения элементов из расчета, но и временного включения элемента в расчет.

Иногда при формировании плоского изображения модели (например, ее изометрической проекции на чертеже или полутонового изображения в каталоге) требуется показать вырез модели (например, вырез 1/4 модели). После создания модели выполните операцию отсечения по эскизу. Сохраните файл модели. Создайте нужное изображение модели. Для дальнейшей работы с моделью (например, расчета ее массо-центровочных характеристик или передачи модели в приложение, формирующее управляющую программу для технологического оборудования) исключите из расчета операцию отсечения.


2.14.2. Управление цветом и оптическими свойствами объектов

2.14. Редактирование и настройки модели

2.14.2. Управление цветом и оптическими свойствами объектов

Вы можете задать цвет и оптические свойства (степень блеска, прозрачности и т.п.) как для модели в целом, так и для отдельных ее частей: компонентов, тел, поверхностей, операций, граней и др. Если объект не имеет поверхности, например, кривая или точка, то для него возможна лишь настройка цвета.

Чтобы задать цвет и оптические свойства объекта, выделите его в Дереве построения или в окне модели и вызовите из контекстного меню команду Свойства (для модели — Свойства модели, для компонента — Свойства компонента).

Для задания цвета и оптических свойств грани служит команда Свойства грани в контекстном меню грани, выделенной в окне модели.

Если в окне модели выделена составляющая объекта, например, ребро операции или сегмент ломаной, то в контекстном меню присутствует команда Свойства исходного элемента. Она позволяет перейти к настройке свойств объекта, в состав которого входит выделенный.

После вызова команды настройки свойств на Панели свойств появляются элементы управления свойствами объекта, в том числе группа переключателей Назначить цвет и панель Оптические свойства с «ползунками» для управления значениями параметров, характеризующих оптические свойства поверхности (рис. 2.14.3).

Рис. 2.14.3. Элементы управления цветом и свойствами поверхности компонента

Состав группы Назначить цвет зависит от настраиваемого объекта. Описание переключателей группы представлено в таблице 2.14.1.

Табл. 2.14.1. Переключатели группы Назначить цвет
Название переключателя; для каких объектов доступен | Результат использования переключателя
По исходному объекту доступен для всех объектов | – Грань отображается цветом, заданным для операции, в результате которой образовалась эта грань. – Операции (в том числе массивы), тела, поверхности, кривые, оси и другие объекты модели отображаются цветом, заданным для модели (или исполнения, если оно есть).
По источнику доступен для операций, в том числе массивов, и компонентов | – Операция отображается цветом, заданным для тела (или поверхности), которое она формирует. – Массив отображается цветом, заданным для копируемого объекта. – Компонент отображается так же, как он выглядит в своем файле.
По слою доступен для объектов, которые могут размещаться на слоях1 (все объекты, кроме операций и граней) | Объекты имеют цвета и оптические свойства, заданные для слоев, содержащих эти объекты.
Вручную доступен для всех объектов | Объект имеет цвет, произвольно выбранный пользователем.
  1. О слоях см. раздел 2.15.14.

Задание цвета и оптических свойств имеет следующие особенности:

– Для модели цвет и оптические свойства всегда задаются вручную. Поэтому при настройке свойств модели группа Назначить цвет отсутствует на Панели свойств, присутствуют лишь поле Цвет и панель Оптические свойства. При настройке всех остальных объектов:

• Поле Цвет присутствует, если активен переключатель Вручную.

• Панель Оптические свойства присутствует, если активен переключатель По исходному объекту, По слою (в этих случаях значения свойств недоступны для изменения и отображаются как справочные) или Вручную (в этом случае значения свойств можно изменить).

– Изменение цвета и оптических свойств возможно только для компонентов первого уровня. При настройке компонентов других уровней элементы управления цветом и оптическими свойствами отсутствуют на Панели свойств.

Настроив цвет и оптические свойства, подтвердите сделанные изменения.

После этого изображение модели в окне будет перерисовано в соответствии с установленными параметрами.

Цвет и оптические свойства объектов можно также изменить в Окне Свойства (см. раздел 2.14.3.6.1), задав требуемые значения свойствам Назначение цвета, Цвет и Оптические свойства.

Окно Свойства позволяет настроить сразу несколько объектов. Например, можно выделить несколько граней детали или компонентов сборки и задать для них цвет.

Иногда параллельные грани тела сливаются на полутоновом изображении. Чтобы облегчить восприятие такого изображения, свойства параллельных граней можно сделать разными (часто достаточно изменения блеска или диффузии без изменения цвета).

В этом разделе:

2.14.2.1. Запрет редактирования объектов модели


2.14.2.1. Запрет редактирования объектов модели

Вы можете запретить или разрешить редактирование одного или нескольких объектов модели. Для этого выделите нужные объекты в Дереве модели и вызовите команду:

– Редактирование — Запрещено или Редактирование — Разрешено из их контекстного меню (рис. 2.14.4, а);

– Запрет редактирования выбранных объектов или Разрешение редактирования выбранных объектов нажатием одноименной кнопки на панели Редактирование детали или Редактирование сборки.

Обратите внимание на то, что запретить/разрешить редактирование можно только для объектов первого уровня, кроме компонентов. Управление доступом к редактированию компонентов возможно вне зависимости от уровня вложенности.

Объект, редактирование которого запрещено, отмечается в Дереве построения значком «щит» (рис. 2.14.4, б). Если в его состав входят другие объекты, то они отмечаются значком «замок». Объект, запрещенный для редактирования, нельзя также удалить, перенести на другой слой, включить в расчет/исключить из расчета. Если запрет наложен на тело, то к нему становится невозможно применить операции редактирования тела, например, сделать фаску, вырезать отверстие и т.п. Аналогично становится невозможно изменить поверхность (усечь, продлить и т.п.), если ее редактирование запрещено.

Объекты, редактирование которых запрещено, могут изменяться в результате изменения их исходных объектов. Кроме того, они могут быть удалены с помощью Указателя окончания построения (см. раздел 2.14.3.6.2).

Рис. 2.14.4. Запрет редактирования объекта: а) установка, б) отображение в Дереве построения
а) | б)

Запрет редактирования компонентов сборки может использоваться для разграничения доступа к ее частям. Этот запрет сохраняется в пользовательских типах загрузки. Подробнее о сохранении запрета и особенностях работы с компонентами, на редактирование которых наложен запрет, см. раздел 2.12.3.

Управление возможностью редактирования объектов возможно с помощью слоев (о слоях см. раздел 2.15.14).

Редактирование всех объектов, находящихся на одном слое, может быть одновременно запрещено или разрешено путем изменения значения свойства Редактируемость для этого слоя.

Обратите внимание на то, что у объекта свойство Редактирование должно иметь значение По слою — только в этом случае изменение значения свойства слоя изменит значение свойства объекта.

Значение По слою — умолчательное значение свойства Редактирование для всех объектов.

Если значение свойства Редактирование у объекта изменено по отношению к умолчательному, т.е. имеет значение Запрещено (или Разрешено), то редактирование объекта запрещено (или разрешено) вне зависимости от состояния слоя, на котором он находится. Чтобы вернуть свойству Редактирование объекта значение По слою, вызовите для этого объекта команду По слою (рис. 2.14.4, а).

Для просмотра и изменения значений свойств объектов можно также использовать Окно Свойства, см. раздел 1.4.2.2.


2.14.3. Редактирование объектов модели

2.14. Редактирование и настройки модели

2.14.3. Редактирование объектов модели

При редактировании модели можно изменить любые параметры составляющих ее объектов. В данном разделе описаны все доступные приемы редактирования объектов.

Обратите внимание на то, что в текущей модели возможно редактирование только тех объектов, которые непосредственно находятся в ней. Поэтому прямое редактирование объектов, принадлежащих компонентам модели, невозможно. Для редактирования объектов компонента нужно либо открыть его в отдельном окне (см. раздел 2.11.7.1), либо включить режим контекстного редактирования компонента (см. раздел 2.11.7.2). После этого можно использовать любые приемы редактирования объектов.

При любом редактировании объектов модели иерархические связи между ними сохраняются, т.е. после изменения какого-либо объекта не требуется заново задавать последовательность построения подчиненных ему объектов и их параметры.

В одних случаях перестроение модели происходит автоматически. Например, после изменения в эскизе формы контура сразу изменяется форма базирующегося на нем элемента выдавливания. В других случаях, например, при изменении значений переменных, для перестроения модели требуется вызвать специальную команду, см. раздел 2.14.3.7.

Изменения, внесенные в модель при редактировании, передаются во все модели, содержащие ее в качестве компонента.

В этом разделе:

2.14.3.1. Редактирование эскиза

2.14.3.1.1. Редактирование изображения в эскизе модели

2.14.3.1.2. Размещение эскиза на плоскости

2.14.3.2. Редактирование операции

2.14.3.3. Редактирование числовых параметров операции

2.14.3.3.1. Редактирование значения переменной

2.14.3.3.2. Редактирование размера операции

2.14.3.4. Редактирование моделей, вставленных из библиотеки

2.14.3.5. Особенности редактирования отдельных объектов

2.14.3.5.1. Отверстие из библиотеки; спираль; отверстие в листовом теле

2.14.3.5.2. Размеры и обозначения

2.14.3.5.3. Редактирование сопряжений

2.14.3.6. Другие приемы редактирования

2.14.3.6.1. Редактирование модели с помощью Окна Свойства

2.14.3.6.2. Редактирование модели с помощью Указателя окончания построения

2.14.3.6.3. Изменение последовательности операций

2.14.3.7. Перестроение модели

2.14.3.8. Удаление объекта


2.14.3.1. Редактирование эскиза

В этом разделе:

2.14.3.1.1. Редактирование изображения в эскизе модели

2.14.3.1.2. Размещение эскиза на плоскости


2.14.3.1.1. Редактирование изображения в эскизе модели

Вы можете отредактировать изображение в любом эскизе модели.

Перед вызовом команды редактирования эскиза требуется указать эскиз. Это можно сделать одним из следующих способов:

– выделите эскиз в Дереве построения,

– выделите в Дереве построения операцию, созданную на основе эскиза,

– выделите в окне модели любую грань объекта, созданного на основе эскиза.

Затем вызовите из контекстного меню команду Редактировать эскиз.

Система перейдет в режим редактирования эскиза.

При этом в окне модели останутся только те объекты, которые находятся в Дереве построения перед редактируемым эскизом. Иначе говоря, модель временно вернется в то состояние, в котором она была в момент создания редактируемого эскиза.

Внося изменения в эскиз, вы можете проецировать в него существующие объекты (ребра, грани и т.д.), привязываться к объектам модели, накладывать и удалять параметрические связи и ограничения, выполнять любые построения, редактировать графические объекты.

Если эскиз параметрический, и положение объектов в нем определяется ассоциативными размерами, вы можете ввести новые значения этих размеров.

Помните, что эскиз для выполнения операции должен отвечать определенным требованиям. Они должны соблюдаться не только при создании эскиза, но и при его редактировании. Конкретные требования к эскизам приведены в разделах, посвященных операциям.

После внесения в эскиз нужных изменений выйдите из режима редактирования эскиза. Объект, сформированный на основе эскиза, и его производные объекты перестроятся в соответствии изменением контура в эскизе.

Не рекомендуется производить такое редактирование эскиза, после которого заведомо не смогут быть перестроены производные объекты.


2.14.3.1.2. Размещение эскиза на плоскости

В некоторых случаях требуется изменить положение эскиза на плоскости (плоской грани) или выбрать для размещения эскиза другую плоскость (плоскую грань). Для этого выделите эскиз в Дереве построения и вызовите из контекстного меню команду Разместить эскиз. На Панели свойств появятся элементы размещения эскиза (см. рис. 2.2.2).

Если графические объекты в эскизе параметрически связаны со вспомогательными проекциями объектов модели (см. раздел 2.2.2.3.1), то после вызова команды на экране появляется сообщение о возможном нарушении этих связей при смене плоскости эскиза. Вы можете продолжить размещение эскиза или отказаться от него.

Чтобы выбрать другую плоскость (плоскую грань) для размещения эскиза, укажите ее в окне модели. Положение эскиза изменится, а имя выбранного объекта появится в поле Базовая плоскость на Панели свойств.

Для изменения положения эскиза на плоскости используются поля т и Угол. Задайте в них новое положение системы координат выделенного эскиза и угол поворота нового положения системы координат относительно текущего положения. Новое положение системы координат или угол ее поворота можно указать курсором в окне. Для этого необходимо сначала расфиксировать соответствующее поле — т или Угол. После расфиксации любого из полей на экране появляется фантом системы координат.

Положение графических объектов эскиза в его системе координат не изменяется. Поэтому при перемещении системы координат перемещается и изображение эскиза. Это перемещение отображается на экране в виде фантома.

Если требуется, чтобы эскиз не был связан с базовой плоскостью, включите опцию Независимое размещение. Эскиз сохранит свое положение в пространстве, но его связь с базовой плоскостью будет разорвана (подсветка базовой плоскости в окне модели исчезнет, а ее имя удалится из поля Базовая плоскость). При включенной опции элементы задания положения эскиза недоступны.

Отключение опции Независимое размещение восстанавливает связь эскиза с базовой плоскостью.

После выполнения всех необходимых действий нажмите кнопку Создать объект. Объект, сформированный на основе эскиза, и его производные объекты перестроятся в соответствии с новым положением эскиза.

Команда Разместить эскиз недоступна, если графические объекты в выделенном эскизе параметрически связаны с ранее созданными объектами (например, характерные точки отрезков в эскизе совпадают с вершинами грани, на которой этот эскиз построен или эскиз содержит проекции существующих ребер) или параметрические связи других типов делают невозможным перемещение графических объектов в плоскости эскиза.


2.14.3.2. Редактирование операции

Объект модели создается путем выполнения операции. Вы можете отредактировать созданный объект, изменив параметры операции.

Чтобы изменить параметры операции, перейдите в режим редактирования объекта. Для этого выполните одно из действий:

– выделите объект в Дереве построения или в окне модели и вызовите из контекстного меню команду Редактировать;

– выделите объект в Дереве построения или в окне модели и вызовите из команду Редактировать элемент из меню Редактор;

– выделить любую грань, ребро или вершину объекта в окне модели и вызовите из контекстного меню команду Редактировать исходный элемент.

Система перейдет в режим выполнения команды, использовавшейся для построения выбранного объекта.

При этом в окне модели останутся только те объекты, которые находятся в Дереве построения перед редактируемым. Иначе говоря, модель временно вернется в то состояние, в котором она была в момент создания редактируемого объекта.

На Панели свойств появятся те же поля и переключатели для задания параметров операции, что и при построении объекта. Если для построения объекта использовались опорные или исходные объекты, то они будут подсвечены в окне модели и в Дереве построения.

Отредактируйте нужные параметры операции (задайте новые числовые значения параметров, измените набор опорных или исходных объектов и т.п.).

Если в диалоге настройки отображения размеров и обозначений (см. раздел 9.1.11.12) включена опция Размеры эскизов и операций, то при редактировании элементов на экране отображаются и доступны для изменения размеры эскиза. Чтобы изменить значение размера, следует дважды щелкнуть мышью по размерной надписи.

Подтвердите сделанные изменения, нажав кнопку Создать объект.

Объект будет перестроен в соответствии с новыми параметрами операции.


2.14.3.3. Редактирование числовых параметров операции

Вы можете отредактировать числовые параметры операции без перехода в режим ее редактирования. Для этого можно использовать переменные, соответствующие параметрам операции, и размеры операции (см. раздел 2.9.2.2).

Подробнее редактирование переменных, соответствующих параметрам операции, описано в разделе 2.14.3.3.1, редактирование размеров операций — в разделе 2.14.3.3.2.

В этом разделе:

2.14.3.3.1. Редактирование значения переменной

2.14.3.3.2. Редактирование размера операции


2.14.3.3.1. Редактирование значения переменной

Одним из способов редактирования числового параметра операции является изменение значения его переменной в Окне переменных.

Чтобы изменить значение переменной, выполните следующие действия.

1. Включите показ Окна переменных. Для этого нажмите кнопку Переменные на Стандартной панели.

2. Найдите в таблице Окна переменных раздел, соответствующий нужному объекту, и раскройте его.

3. Найдите строку редактируемой переменной.

4. Щелкните мышью в ячейке Выражение этой строки и введите новое значение переменной.

5. Нажмите клавишу <Enter>.

Чтобы перестроить модель в соответствии с новым значением параметра, нажмите кнопку Перестроить на панели Вид или выберите ее название из меню Вид.

Подробно о редактировании переменных см. раздел 7.1.4.


2.14.3.3.2. Редактирование размера операции

Одним из способов редактирования числового параметра операции является изменение значения соответствующего размера операции.

Редактирование размера операции возможно в специальном режиме (см. раздел 2.9.2.2.2).

Чтобы изменить значение размера операции, выполните следующие действия.

1. Включите режим отображения размеров выбранного элемента. Для этого нажмите кнопку Размеры выбранного элемента на панели Вид или выберите ее название из меню Вид.

2. Выделите нужный объект в Дереве построения или укажите в окне модели любой примитив этого объекта: грань, ребро или вершину.

На экране отображаются размеры выделенного объекта.

3. Найдите нужный размер и выполните двойной щелчок мышью по его размерной надписи. На экране появляется диалог установки значения размера.

4. В поле Выражение появившегося диалога введите значение размера: число, константу или выражение для вычисления значения размера. Синтаксис выражений описан в разделе 7.1.3.3.1.

5. Нажмите кнопку Перестроить, чтобы включить автоматическое перестроение модели после закрытия диалога.

6. Завершите редактирование размера, нажав кнопку Создать объект.

Диалог закрывается, модель перестраивается в соответствии с новым значением параметра.

Подробнее диалог установки значения размера и его использование описаны в разделе 2.9.2.2.1.

Значение размера эскиза можно изменить вне режима эскиза. Изменение значения размера эскиза аналогично изменению значения размера операции.

Если размер операции представлен в виде элемента управления (т.е. создан производный размер, см. раздел 2.9.2.8), вы можете отредактировать параметр операции, изменив значение соответствующего производного размера. Порядок редактирования значения производного размера аналогичен порядку редактирования, описанному выше.


2.14.3.4. Редактирование моделей, вставленных из библиотеки

После того как компонент из библиотеки вставлен в модель, может возникнуть необходимость его редактирования.

– Если вставленный компонент не имеет внешних переменных, для его изменения необходимо отредактировать модель-источник в библиотеке (см. раздел 11.3.5).

Обновление вставок (как из библиотек, так и моделей с диска) происходит автоматически при открытии главного документа.

– Если во вставленном из библиотеки компоненте существуют внешние переменные, для изменения его размеров и топологии следует отредактировать значения этих переменных (см. раздел 7.1.5.3.2).

Если кроме внешних переменных в библиотечном компоненте присутствует таблица переменных, можно выбрать новый набор значений переменных из таблицы. Для открытия таблицы переменных служит команда Таблица переменных в контекстном меню библиотечного компонента в Дереве.

Иногда после редактирования переменных модели она отмечается в Дереве построения как ошибочная. Это означает, что введены такие значения внешних переменных, при которых система уравнений, связывающих переменные модели, не может быть решена. Для исправления ошибки отредактируйте значения переменных еще раз.

– Кроме того, существует возможность заменить компонент из библиотеки компонентом с диска (изменить источник вставки модели).

Чтобы изменить источник вставки компонента, выделите ее в Дереве построения и вызовите из контекстного меню команду Свойства компонента. На Панели свойств активизируйте вкладку Файл-источник и нажмите кнопку Файл-источник. В появившемся стандартном диалоге открытия файлов выберите нужный документ-модель.

Библиотечный компонент-деталь можно заменить только деталью, компонент-сборку – только сборкой.

Выбранная модель будет вставлена в текущую модель вместо библиотечного компонента с сохранением положения точки вставки. Пиктограмма компонента из библиотеки в Дереве построения исчезнет, на ее месте появится пиктограмма детали или подсборки.

Если в модели имеются производные от библиотечного компонента объекты, (например, через одну из ее вершин была проведена вспомогательная ось или на одной из граней библиотечной модели была построена деталь в контексте сборки), то при замене источника вставки модели все связи, возникшие при создании производных объектов, будут разрушены, и в модели возникнут ошибки. Поэтому прежде чем изменить источник вставки модели, просмотрите отношения этой модели, чтобы определить, какие производные элементы она имеет.


2.14.3.5. Особенности редактирования отдельных объектов

Приемы редактирования большинства элементов (удаление, изменение параметров, задание других опорных объектов и т.д.) одинаковы. О них рассказано в предыдущих разделах.

Однако некоторые объекты обладают специфическими свойствами, из-за которых для редактирования этих объектов применяются дополнительные приемы. Они рассмотрены в настоящем разделе.

В этом разделе:

2.14.3.5.1. Отверстие из библиотеки; спираль; отверстие в листовом теле

2.14.3.5.2. Размеры и обозначения

2.14.3.5.3. Редактирование сопряжений


2.14.3.5.1. Отверстие из библиотеки; спираль; отверстие в листовом теле

Особенностью таких объектов как отверстие из библиотеки, спираль и отверстие в листовом теле является то, что при их создании в модели автоматически формируется эскиз. Он содержит вспомогательную точку, находящуюся на пересечении оси объекта и грани (или плоскости), на которой он располагается. Далее будем называть эту точку центральной точкой объекта.

Если в Дереве отображается последовательность построения модели (см. раздел 2.1.2.1), то объекты располагаются в нем в порядке создания, и эскиз с центральной точкой будет находиться непосредственно перед отверстием (спиралью).

Если в Дереве отображается структура модели (см. раздел 2.1.2.2), то эскиз будет находиться в разделе «Эскизы», а отверстие — в разделе «Тело» (спираль — в разделе «Кривые и точки»). В этом случае для быстрого поиска эскиза с центральной точкой можно просмотреть отношения объекта Отверстие или Спираль (см. раздел 2.1.2.7.2). Нужный эскиз будет первым в списке исходных объектов Отверстия или Спирали.

Используя этот эскиз, вы можете:

– Изменить положение объекта на грани. Для этого выделите эскиз с центральной точкой в Дереве построения (или саму точку в окне модели), а затем вызовите из контекстного меню команду Редактировать. Система перейдет в режим редактирования эскиза. Любым способом переместите находящуюся в эскизе точку в нужное место. Вы можете использовать привязки, наложить на точку параметрические ограничения, или проставить параметрические размеры, определяющие положение точки.

Например, если требуется, чтобы отверстие было расположено точно посередине прямоугольной грани, постройте вспомогательный отрезок, соединяющий диагональные точки грани, и привяжите точку к его середине. После этого при любом изменении размеров грани центр отверстия будет оставаться точно в центре грани.

После внесения в эскиз нужных изменений выйдите из режима редактирования эскиза. Объект перестроится в соответствии с новым положением центра.

– Перенести объект на другую грань или плоскость. Для этого выделите эскиз с центральной точкой в Дереве построения и вызовите команду Разместить эскиз (см. раздел 2.2.2.2).


2.14.3.5.2. Размеры и обозначения

Размеры и обозначения, в отличие от других объектов модели, можно редактировать без вызова команды редактирования, с помощью мыши.

Выделите размер или обозначение щелчком мыши в окне модели или в Дереве построения. В окне модели отобразятся характерные точки выделенного объекта. Вы можете перемещать их мышью в плоскости размера или обозначения. Например, таким образом можно передвинуть размерную линию или размерную надпись, повернуть полку линии-выноски, сменить место, на которое указывает ответвление линии-выноски и т.п.

При выделении обозначения на экране также показывается плоскость этого обозначения — в виде прямоугольника, отрисованного штриховой линией. Если при создании обозначения его плоскость не была зафиксирована (т.е. не был указан объект фиксации), то в одном из углов прямоугольника находится характерная точка, позволяющая перемещать плоскость обозначения параллельно самой себе. При «перетаскивании» этой точки мышью все обозначение перемещается. Перемещение возможно до тех пор, пока выполняется условие принадлежности начальных точек всех ответвлений объекту, к которому было проставлено обозначение.

Если перемещение плоскости невозможно (например, обозначение проставлено к точечному объекту), то обозначение остается на месте.

Если требуется отредактировать надпись в составе объекта (размерную надпись или надпись в обозначении), выделите объект, переместите курсор так, чтобы он не находился над этим объектом, и нажмите комбинацию клавиш <Shift> +<Enter>. Сделайте необходимые изменения в появившемся диалоге и закройте его кнопкой ОК.

Для размера можно вызвать диалог установки значения, дважды щелкнув мышью по размерной надписи. В зависимости от типа размера в этом диалоге можно изменить имя переменной, значение размера и другие параметры (см. раздел 2.9.2.2.1).


2.14.3.5.3. Редактирование сопряжений

Чтобы отредактировать сопряжение, выделите его в Дереве построения и вызовите из контекстного меню команду Редактировать.

При редактировании сопряжения, в отличие от редактирования операции, модель не приводится в состояние, соответствующее моменту создания сопряжения.

При необходимости укажите другие объекты для наложения сопряжения. При помощи элементов управления на Панели свойств измените параметры сопряжения (например, ориентацию объектов или расстояние между ними).

Если форма указанных элементов и уже имеющиеся связи и ограничения не препятствуют сопряжению, модель перестроится так, чтобы выполнялось условие сопряжения. Если выполнение условия сопряжения невозможно, оно сразу после редактирования отмечается как ошибочное. В некоторых случаях условие сопряжения выполняется за счет нарушения условий других сопряжений — тогда ошибка появляется в них.

Редактируя сопряжение, нельзя изменить его тип, то есть нельзя превратить, например, сопряжение На расстоянии в сопряжение Параллельно.


2.14.3.6. Другие приемы редактирования

В этом разделе:

2.14.3.6.1. Редактирование модели с помощью Окна Свойства

2.14.3.6.2. Редактирование модели с помощью Указателя окончания построения

2.14.3.6.3. Изменение последовательности операций


2.14.3.6.1. Редактирование модели с помощью Окна Свойства

Вы можете просматривать и изменять следующие свойства выделенных объектов (не прибегая к редактированию каждого из них в отдельности):

– параметры отображения — цвет, стиль линии, стиль вершины и т.д.,

– свойства — слой объекта, обозначение, наименование, исполнение,

– состояние — управление фиксацией, видимостью, включением в расчет, редактированием, проецированием объектов в ассоциативный чертеж,

– параметры, заданные при создании объекта (для размеров, обозначений и т.д.),

– текст, входящий в состав объекта,

– стиль текста, параметры шрифта и параметры абзаца,

– признак языка для проверки правописания.

Для изменения свойств объектов, а также для просмотра свойств служит окно Свойства. Оно отображается на экране после вызова команды Редактор — Свойства или нажатием кнопки Свойства на Стандартной панели.

Элементы управления окна Свойства и порядок изменения свойств описаны в разделе 1.4.2.2.

Работа со свойствами в документах-моделях имеет следующие особенности.

– Могут быть указаны объекты первого уровня — оси и системы координат, элементы оформления, кривые и точки, эскизы, объекты вспомогательной геометрии, компоненты первого уровня, тела, построенные в модели, грани этих тел и т.д.

– Список свойств в окне зависит от типа выделенного объекта. Например, при щелчке мышью по выносной линии размера отображаются его свойства как элемента оформления, а при щелчке по тексту размера — свойства текста размерной надписи.

– Свойство Исполнение доступно для редактирования, если у выделенного объекта имеются исполнения. Объектами могут быть текущая деталь, текущая сборка, компонент или несколько одинаковых компонентов.
Свойство Исполнение недоступно для редактирования, если в выделенной группе одинаковых компонентов есть запрещенные для редактирования.

– Для свойства объекта может быть установлено значение По слою. В этом случае значение свойства определяется значением, заданным для слоя, на котором располагается объект. К свойствам объектов, управляемым через слои, относятся:

• видимость,

• возможность редактирования,

• цвет,

• оптические свойства,

• возможность проецирования в ассоциативный чертеж.

– Значения свойств в окне Свойства доступны для редактирования, если это не входит в противоречие с другими свойствами. Например, для компонента изменение свойств Цвет и Оптические свойства недоступно, если цвет назначается По исходному объекту, По источнику или По слою.

– Свойство Видимость для объекта недоступно, если все объекты данного типа скрыты при помощи команды Скрыть все вспомогательные объекты (см. раздел 2.14.1.1.2).

– Для обозначения базы изменение свойства Обозначение базы недоступно, если при ее создании или редактировании была включена автосортировка для букв в обозначении (см. раздел 2.9.3.3).

– Свойство Язык доступно, если выделено обозначение линии-выноски.

– Свойства, по которым составляется отчет1 (Обозначение, Наименование, Масса и некоторые другие), доступны для самой модели, ее компонентов и тел.

Объекты, вставленные из библиотек, могут иметь специальные свойства, если это предусмотрено библиотекой. Например, конструкции, созданные с помощью библиотеки Оборудование: Металлоконструкции, обладают такими свойствами, как Длина/Ширина/Высота профиля, Длина/Ширина/Толщина пластины. Отображение специальных свойств библиотечных компонентов в окне Свойства зависит от настройки списка свойств (см. раздел 5.1.2.2). Свойства макроэлементов, вставленных из библиотеки, отображаются в окне Свойства в зависимости от настройки (см. раздел 9.1.10.2).

  1. Об отчетах см. раздел 5.2.


2.14.3.6.2. Редактирование модели с помощью Указателя окончания построения

2.14.3.6.2. Редактирование модели
с помощью Указателя окончания построения

С помощью Указателя окончания построения модели (см. раздел 2.1.2.6) вы можете условно удалять объекты из модели. Указатель можно также использовать для изменения порядка построения модели.

Редактирование с помощью Указателя возможно, если в Дереве отображается последовательность построения модели (см. раздел 2.1.2.1).

Переместите Указатель так, чтобы он разбивал Дерево построения на две части.

Вы увидите, что объекты, оказавшиеся ниже Указателя, отображаются серым цветом и помечаются пиктограммой-«замком». Это — условно удаленные объекты. Информация о них не удаляется из документа, однако, эти объекты, а также производные от них не отображаются в окне модели.

Для быстрого возвращения Указателя в конец Дереве построения можно воспользоваться командой Указатель в конец Дерева из контекстного меню на Указателе. После вызова этой команды все условно удаленные объекты модели восстанавливаются. Модель перестраивается с учетом восстановленных объектов.

Особенностью массива является то, что при его условном удалении теряется изменение свойств (например, цвета) граней экземпляров. Т.е. при восстановлении массив как бы строится заново с умолчательными свойствами граней.

Во время работы над моделью вы можете неограниченное число раз перемещать Указатель окончания построения. Пиктограммы вновь созданных объектов будут располагаться в Дереве построения перед Указателем.

Это свойство Указателя окончания построения, а также то, что условно удаленные объекты не отображаются на экране и не могут использоваться при построениях, удобно использовать для изменения последовательности построения модели.

Например, для редактирования детали, полученной с помощью операции зеркального копирования, следует вносить изменения в ту ее половину, которая являлась оригиналом, располагая их до операции копирования. Однако, во-первых, обе половины детали выглядят совершенно одинаково. Во-вторых, при редактировании вы можете случайно использовать объекты той половины детали, которая получена копированием, что неизбежно приведет к ошибке. В таких случаях целесообразно переместить Указатель окончания построения так, чтобы операция зеркального копирования и все последующие были условно удалены из модели. На экране остается только оригинальная половина детали. Вы можете отредактировать ее по своему усмотрению. После восстановления операции копирования вторая половина детали также будет содержать внесенные изменения.

Если объекты модели, расположенные под Указателем окончания построения, не требуются для дальнейших построений и не должны присутствовать в модели, вы можете одновременно удалить все эти объекты. Воспользуйтесь для этого командой Удалить элементы под Указателем из контекстного меню на Указателе.

После вызова команды на экране появляется диалог-предупреждение. В нем перечислены удаляемые объекты модели. Вы можете отказаться от удаления или подтвердить его.


2.14.3.6.3. Изменение последовательности операций

Удобный (правда, нечасто используемый) прием редактирования — «перетаскивание» операций мышью прямо в Дереве построения. С его помощью можно быстро изменить порядок построения.

«Перетаскивать» объекты удобнее и нагляднее, если в Дереве включено отображение последовательности построения модели (см. раздел 2.1.2.1).

Чтобы переместить операцию в Дереве построения, подведите курсор к нужной пиктограмме, нажмите левую кнопку мыши и, не отпуская ее, перемещайте курсор в место предполагаемого размещения операции в Дереве построения.

Когда нужное положение операции будет достигнуто, отпустите кнопку мыши. Пиктограмма операции разместится в Дереве построения на указанном месте и будет отмечена красной «галочкой». Это означает, что изменения в порядке построения еще не переданы в модель — изображение в окне осталось прежним.

Чтобы перестроить модель, вызовите команду Вид — Перестроить.

При перемещении операций учитывается их иерархия. Операцию невозможно переместить выше исходного или ниже производного объекта в Дереве построения. О невозможности размещения операции в выбранном месте говорит отображение запрещающего значка вместо курсора.


2.14.3.7. Перестроение модели

Перестроение модели можно определить как актуализацию модели. При перестроении форма и положение объектов модели рассчитываются заново, в результате чего изображение модели на экране может измениться.

Если при настройке системы включен пересчет МЦХ в процессе перестроения (см. раздел 9.1.11.15), то во время перестроения обновляются хранящиеся в файле модели значения ее массы и координат центра масс.

Перестроение требуется, если в модели есть противоречия, т.е. геометрия модели не соответствует исходным данным — истории построения, значениям параметров операций, сопряжениям и т.п. Объекты, являющиеся источниками противоречий, отмечаются в Дереве модели красной «галочкой». При наличии хотя бы одного объекта, требующего перестроения, красной «галочкой» в Дереве отмечается и сама модель, благодаря чему признак необходимости перестроения заметен, даже если Дерево полностью свернуто.

Для перестроения модели следует вызвать команду Вид — Перестроить или нажать клавишу <F5>. Кнопка этой команды находится на панели Вид.

Противоречия в модели и, следовательно, необходимость ее перестроения возникают в результате редактирования, например:

– В Окне переменных изменено значение переменной, соответствующей параметру операции. Объект, являющийся результатом этой операции, в окне модели остается прежним, но в Дереве построения отмечается красной «галочкой». После перестроения объект в окне модели приходит в соответствие с новым значением параметра, а красная «галочка» в Дереве исчезает.

– В Дереве построения изменен порядок следования операций путем «перетаскивания» их мышью. Все перемещенные операции отмечаются в Дереве красной «галочкой», а модель в окне не меняется. После перестроения «галочки» исчезают, изображение же модели может измениться или остаться прежним — это зависит от набора операций в каждом конкретном случае. Например, если операцию отсечения тела плоскостью, находившуюся между операциями, формирующими тело, переместить так, чтобы она оказалась после них, то будет рассечено все тело, а не какая-то его часть, как ранее. Если же поменять местами в Дереве две не зависящие друг от друга операции, то модель, скорее всего, не изменится.

– Два компонента сопряжены так, чтобы грань одного из них касалась цилиндрической поверхности другого. Затем произведено редактирование второго компонента, в результате чего его цилиндрическая грань, участвующая в сопряжении, превратилась в коническую. Изменение формы компонента отображается в окне модели, но положение первого компонента остается прежним. Пиктограмма отредактированного компонента отмечается красной «галочкой» в Дереве построения. После перестроения модели «галочка» исчезает, а первый компонент занимает такое положение, при котором существующее сопряжение (касание поверхностей) не нарушается.

– В модели построена вспомогательная ось, проходящая через вершины двух компонентов. Затем положение одного из компонентов изменилось, например, из-за наложения на него сопряжения. Пиктограмма компонента отмечается в Дереве построения красной «галочкой», а вспомогательная ось остается на прежнем месте. После перестроения «галочка» исчезает, положение оси меняется так, чтобы она проходила через заданные вершины.

В некоторых случаях система, определив, что модель нуждается в перестроении, выдает запрос на перестроение. Например, этот запрос появляется на экране при загрузке модели, если какой-либо из ее компонентов не соответствует данным о нем, которые хранятся в модели. Причиной такого рассогласования может быть как изменение геометрии компонента, так и его свойств — обозначения, наименования, материала и т.п.

В окне запроса перечислены компоненты, являющиеся источниками противоречий.

Если вы хотите перестроить модель, нажмите кнопку Да диалога.

В том случае, если модель состоит из большого числа компонентов, ее перестроение может занять значительное время. Поэтому, если необходимо отредактировать несколько компонентов сложной модели, целесообразно перестраивать ее один раз — после внесения всех изменений (а не каждый раз после редактирования отдельного компонента).

Чтобы отложить перестроение модели, нажмите кнопку Нет диалога. Запрос на перестроение модели исчезнет, а пиктограммы объектов, требующих перестроения, будут отмечены в Дереве построения красной «галочкой».

Вы можете в любой момент перестроить модель, вызвав команду Вид — Перестроить.

Иногда после перестроения в модели появляются признаки ошибки — восклицательные знаки в красных кружках, свидетельствующие об ошибках построения объектов. Например, вырезанный из модели элемент был выдавлен до грани какой-либо детали. Затем эта деталь перемещается так, что указанная грань уже не может ограничивать элемент выдавливания (т.е. эскиз элемента либо не полностью проецируется на эту грань, либо вовсе не может быть спроецирован на нее). Вырезание элемента становится невозможным, и после перестроения модели эта операция помечается в Дереве построения как ошибочная.


2.14.3.8. Удаление объекта

Любые объекты (формообразующий элемент, эскиз, вспомогательную ось или плоскость, компонент модели, сопряжение и т.д.) можно удалить из модели. Для этого достаточно выделить их в Дереве построения и вызвать из контекстного меню команду Удалить или нажать клавишу <Delete>.

Если команда Удалить недоступна, это значит, что удаление объектов невозможно. Например, нельзя удалить объекты, которые входят в макроэлемент, автоматически созданный библиотекой.

После вызова команды на экране появляется диалог-предупреждение (рис. 2.14.5). В нем отображается иерархический список, в котором:

– на первом уровне — пиктограмма модели или исполнения, объекты которого удаляются;

– на втором уровне — удаляемые объекты;

– на третьем и последующих уровнях — объекты модели, связанные с удаляемыми объектами (связанными объектами являются также сопряжения, в которых участвуют удаляемые объекты); связанные объекты удаляются вместе со своими исходными объектами.

Вы можете отказаться от удаления или подтвердить его.

Рис. 2.14.5. Диалог удаления объектов


2.14.4. Изменение структуры модели

2.14. Редактирование и настройки модели

2.14.4. Изменение структуры модели

Редактирование структуры модели — это изменение иерархии компонентов. В большинстве случаев в результате редактирования структуры модели изменяется набор составляющих ее файлов.

Доступны следующие возможности редактирования структуры модели:

– преобразование деталь – подсборка и подсборка – деталь (см. раздел 2.14.4.1),

– объединение компонентов в подсборку и разрушение подсборки (см. разделы 2.14.4.2 и 2.14.4.5),

– копирование и перенос компонентов (см. раздел 2.14.4.6),

– выделение объектов модели в отдельные детали (см. раздел 2.11.2.3).

В результате выполнения операции редактирования структуры из модели могут быть удалены некоторые сопряжения, наложенные на компоненты, которые участвовали в этой операции. Поэтому рекомендуется накладывать сопряжения после того, как структура модели будет окончательно определена.

В этом разделе:

2.14.4.1. Преобразование деталь - подсборка и подсборка - деталь

2.14.4.2. Объединение компонентов в подсборку

2.14.4.3. Преобразование локальной детали

2.14.4.4. Запись источника одинаковых компонентов в новый файл

2.14.4.5. Разрушение подсборки

2.14.4.6. Перенос и копирование компонентов


2.14.4.1. Преобразование деталь - подсборка и подсборка - деталь

– Преобразование детали в подсборку — это сохранение детали, вставленной в текущую модель, в файле новой сборки (*.a3d).

– Преобразование подсборки в деталь — это сохранение подсборки, вставленной в текущую модель, в файле новой детали (*.m3d).

Преобразования деталь – подсборка и подсборка – деталь могут потребоваться при проектировании сборки «сверху вниз». Например, на начальных этапах проектирования редуктора было запланировано, что его крышка будет сварной. Соответственно, Крышка была вставлена в модель редуктора как подсборка. Позже оказалось, что целесообразнее сделать литую крышку, т.е. компонент должен быть деталью, а не подсборкой. Для быстрого редактирования модели редуктора можно воспользоваться преобразованием подсборки в деталь.

Обратите внимание на то, что работа с деталью имеет ограничения по сравнению со сборкой (см. раздел 2.14.5.2).

Преобразование возможно только для компонентов, находящихся на первом уровне структуры модели, т.е. вставленных непосредственно в текущую модель. Если требуется преобразовать компоненты, входящие в какую-либо подсборку, необходимо перейти в режим редактирования этой подсборки.

Чтобы выполнить преобразование, выделите нужный компонент — деталь или подсборку — в Дереве построения и вызовите команду Сохранить как... из контекстного меню или из меню Редактор — Редактировать компонент. На экране появится стандартный диалог сохранения файла.

Дальнейшие действия по преобразованию модели аналогичны описанным в разделе 2.14.5.

После завершения преобразования сохраненный компонент вставляется в текущую модель вместо прежнего. Прежний компонент удаляется из модели, но его файл на диске не изменяется.

Чтобы сохранить изменения в текущей модели, вызовите команду Файл — Сохранить.

Команду Сохранить как... можно использовать для сохранения компонента под другим именем и автоматической вставки в текущую модель переименованного компонента вместо прежнего.


2.14.4.2. Объединение компонентов в подсборку

Вы можете объединить несколько компонентов текущей модели в подсборку.

Объединение возможно только для компонентов первого уровня, т.е. вставленных непосредственно в текущую модель, а не в какую-либо из ее подсборок.

В результате объединения создается новый файл сборки (*.a3d), содержащий компоненты текущей модели, указанные для объединения. Новая сборка вставляется в текущую модель в качестве подсборки, а компоненты, из которых она составлена, удаляются из модели. Файлы этих компонентов на диске не изменяются.

Абсолютная система координат новой подсборки совпадает с абсолютной системой координат текущей модели.

Чтобы объединить компоненты в подсборку, выделите их в Дереве построения и вызовите из контекстного меню команду Объединить в подсборку. В появившемся на экране стандартном диалоге сохранения файла укажите папку и имя файла сборки для записи, а затем нажмите кнопку Сохранить. Диалог закроется.

Чтобы сохранить изменения в текущей модели, вызовите команду Файл — Сохранить.

Объединение в подсборку недоступно для следующих компонентов:

– деталей-заготовок,

– компонентов, являющихся экземплярами или исходными объектами массива.

Объединение в подсборку нельзя отменить.


2.14.4.3. Преобразование локальной детали

Вы можете преобразовать локальную деталь в обычный компонент (деталь или сборку), сохраненный в отдельном файле. Для этого выделите нужную локальную деталь в Дереве построения и вызовите из контекстного меню команду Сохранить как.... На экране появится диалог сохранения файла. Умолчательный тип файла — a3d или m3d — соответствует исходному типу модели — деталь или сборка. При необходимости вы можете поменять тип файла. Задайте имя файла, укажите папку для его сохранения и нажмите кнопку Сохранить.

Диалог сохранения файла закрывается, а локальная деталь становится обычным компонентом модели — деталью или подсборкой.

Вы также можете преобразовать обычный компонент в локальную деталь Для этого выделите его в Дереве построения и вызовите команду Взять в документ.

При работе со сборкой команда вызывается из меню Редактор или контекстного меню, а при работе с деталью — только из контекстного меню.

После вызова команды выделенный компонент становится локальной деталью текущей модели.


2.14.4.4. Запись источника одинаковых компонентов в новый файл

Если модель содержит компоненты, которые являются вставками одной и той же модели (такие компоненты образуют отдельные ветви в Дереве построения, см. Приложение I), то вы можете сохранить модель-источник этих компонентов в новый файл. Для этого в Дереве построения выделите нужную ветвь компонентов — деталей, сборок, локальных деталей — и вызовите из контекстного меню команду Сохранить как.... На экране появится диалог сохранения файла.

Укажите папку и имя файла для сохранения и нажмите кнопку Сохранить. При этом модель-источник компонентов записывается в новый файл, а в текущую модель вместо прежних компонентов автоматически вставляются компоненты, источником которых является полученный файл модели. Прежние компоненты удаляются из модели, но их файл на диске не изменяется.

Обратите внимание на то, что при таком варианте сохранения тип документа нельзя изменить, т.е. сборку можно сохранить только как сборку, деталь — как деталь, а локальную деталь — либо как сборку, либо как деталь, в зависимости от того, какой моделью (деталью или сборкой) она является.

После группового сохранения локальных деталей их пиктограммы в Дереве построения текущей модели изменяются.

Если выбранная ветвь содержит компоненты, запрещенные для редактирования, то команда Сохранить как... недоступна.


2.14.4.5. Разрушение подсборки

Вы можете разбить подсборку текущей модели на отдельные компоненты.

В результате разрушения подсборки все ее компоненты передаются в текущую модель. Их положение в окне модели не изменяется. Остальные объекты, которые имелись в подсборке — поверхности, кривые и т.п., а также выполненные в подсборке операции (фаски, отверстия и др.) — не передаются в текущую модель.

Разрушенная подсборка удаляется из модели. Файл подсборки на диске не изменяется.

Чтобы разрушить подсборку, выделите ее в Дереве построения и вызовите команду Разрушить из контекстного меню или из меню Редактор — Редактировать компонент.

Особенности применения команды разрушения.

– Разрушение возможно только для подсборок первого уровня, т.е. вставленных непосредственно в текущую модель, а не в какую-либо из ее подсборок.

– Подсборки, находившиеся внутри разрушенной подсборки, не разрушаются. При необходимости вы можете применить к ним команду разрушения.

– Разрушение подсборки, являющейся исходным объектом массива, невозможно.

– Разрушение подсборки нельзя отменить.

Если компонентом модели является локальная деталь, полученная из подсборки, то к этой локальной детали можно применить команду разрушения.

Также можно разрушить деталь-заготовку, источником которой является сборка. В результате разрушения детали-заготовки пиктограммы ее компонентов, переданных в текущую модель, заменяются пиктограммами деталей-заготовок.


2.14.4.6. Перенос и копирование компонентов

Вы можете перемещать и копировать компоненты:

– из одной подсборки текущей модели в другую,

– из текущей модели в любую ее подсборку и наоборот.

Перенос производится в Дереве построения путем «перетаскивания» компонента мышью на пиктограмму подсборки или модели (либо на пиктограмму раздела Компоненты внутри подсборки или модели).

Копирование компонента производится аналогично, но с нажатой клавишей <Ctrl>; рядом с курсором при этом отображается значок «+».

При «перетаскивании» компонента на пиктограмму объекта, куда он не может быть перенесен или скопирован, вместо курсора отображается предупреждающий значок.

После переноса компонента его положение в модели не изменяется.

В результате копирования получаются наложенные друг на друга компоненты. Для изменения положения исходного компонента или компонента-копии используйте команды сдвига и поворота (см. разделы 2.11.4.1 и 2.11.4.2).

Копирование и перенос компонентов возможны не только в Дереве построения, но и в окне модели. В этом случае можно произвольно задавать положение компонента в системе координат модели. Однако, расположение компонента в структуре модели ограничено первым уровнем, т.е. перенесенный или скопированный компонент вставляется непосредственно в текущую модель.

Чтобы перенести компонент в окне модели, выполните следующие действия.

1. Выделите компонент в Дереве построения или в окне модели.

2. В окне модели установите курсор на компоненте.

3. Нажмите левую кнопку мыши и клавишу <Alt>.

4. Перемещайте мышь. Вслед за курсором в окне модели будет перемещаться фантом компонента.

5. Когда фантом достигнет нужного положения, отпустите кнопку мыши, а затем — клавишу <Alt>.

Копирование компонента производится аналогично, но с нажатием клавиши <Ctrl>; рядом с курсором при этом отображается значок «+». Кроме того, для копирования можно выделять не один, а несколько компонентов.

Вы можете копировать компоненты, используя их пиктограммы в Дереве построения. Для этого выполните следующие действия.

1. Выделите компонент в Дереве построения.

2. Нажмите клавишу <Ctrl> и «перетащите» компонент мышью из Дерева построения в окно модели. Отпустите кнопку мыши.

3. Перемещайте мышь в окне модели. Вслед за курсором будет перемещаться фантом компонента.

4. Когда фантом достигнет нужного положения, щелкните левой кнопкой мыши и отпустите клавишу <Ctrl>.

Результатом переноса или копирования компонента вне зависимости от способа является создание или удаление в файле модели ссылки на файл компонента:

– при переносе компонента ссылка на него удаляется из одного файла (например, подсборки) и добавляется в другой (например, в сборку),

– при копировании компонента ссылка на него добавляется в файл модели или подсборки.

Перенос компонента, являющегося исходным объектом или экземпляром массива, невозможен.


2.14.5. Сохранение сборки как детали и детали как сборки

2.14. Редактирование и настройки модели

2.14.5. Сохранение сборки как детали и детали как сборки

Вы можете сохранить текущую деталь (*.m3d) в файле новой сборки (*.a3d), т.е. преобразовать деталь в сборку и наоборот, сохранить текущую сборку (*.a3d) в файле новой детали (*.m3d), т.е. преобразовать сборку в деталь.

Чтобы выполнить преобразование, вызовите команду Файл — Сохранить как....

На экране появится стандартный диалог сохранения файла. В этом диалоге выполните следующие действия.

– Для преобразования детали в сборку — в списке Тип файла выберите строку КОМПАС-сборки (*.a3d), укажите папку и имя файла для записи и нажмите кнопку Сохранить.

– Для преобразования сборки в деталь — в списке Тип файла выберите строку КОМПАС-детали (*.m3d) и укажите папку и имя файла для записи.

• Если требуется изменение параметров модели и/или ее структуры, вызовите команду Сохранить с параметрами... из меню кнопки Сохранить и настройте параметры преобразования в появившемся на экране диалоге (см. раздел 2.14.5.1).

• Если настройка параметров не требуется, нажмите кнопку Сохранить. В этом случае полученная деталь будет отличаться от исходной сборки только расширением файла и рядом особенностей, описанных в разделе 2.14.5.2.

Преобразование сборки в деталь имеет следующие особенности.

– В процессе преобразования сборки в деталь данные, связанные со спецификацией (описания спецификации, объекты спецификации и т.п.), удаляются. Полученная деталь не имеет связи со спецификацией. Сама спецификация не изменяется.

– Если сборка содержит исполнения, то при сохранении с настройкой параметров (команда Сохранить с параметрами...) в деталь передается только текущее исполнение модели. Если настройка параметров не выполняется, то полученная деталь содержит все исполнения исходной сборки.

После завершения преобразования на экране по-прежнему отображается исходная деталь или сборка. Чтобы загрузить модель — результат преобразования, воспользуйтесь командой Файл — Открыть.

Если требуется преобразовать модель, являющуюся компонентом другой модели, для последующей вставки результата преобразования в эту же модель вместо исходного компонента, воспользуйтесь специальной командой Сохранить как... (см. раздел 2.14.4.1).

При преобразовании сборки в деталь обратите внимание на то, что работа с деталью имеет ограничения по сравнению со сборкой (см. раздел 2.14.5.2).

В этом разделе:

2.14.5.1. Настройка параметров записи сборки в файл детали

2.14.5.2. Отличительные особенности детали и сборки


2.14.5.1. Настройка параметров записи сборки в файл детали

Чтобы настроить параметры преобразования сборки в деталь, выполните следующие действия.

В диалоге сохранения файла вызовите из меню кнопки Сохранить команду Сохранить с параметрами.... На экране появится диалог Параметры сохранения в деталь (рис. 2.14.6).

Рис. 2.14.6. Диалог Параметры сохранения в деталь

Диалог позволяет задать параметры изменения структуры модели, а также ее массы и центра масс. Обратите внимание на то, что исключенные из расчета компоненты не учитываются в процессе преобразования. Они считаются отсутствующими.

Элементы настройки параметров преобразования приведены в таблице 2.14.2.

Табл. 2.14.2. Диалог настройки параметров преобразования

Элемент

Описание

Общие настройки

Группа опций для задания общих параметров преобразования.

Сохранять массу

Включите эту опцию, чтобы преобразованная модель имела ту же массу, что исходная. При отключенной опции масса преобразованной модели рассчитывается заново.

Сохранять центр масс

Включите эту опцию, чтобы центр масс преобразованной модели находился в той же точке, что и центр масс исходной модели. При отключенной опции координаты центра масс преобразованной модели вычисляются заново.

Учитывать скрытые компоненты

Если опция включена, то преобразуются как видимые, так и скрытые компоненты. В результате преобразования в тела они становятся видимыми, а в детали-заготовки — остаются скрытыми. При отключенной опции скрытые компоненты считаются отсутствующими.

Преобразования

Группа элементов для выбора нужного способа изменения структуры модели и настройки параметров в рамках выбранного способа. Если требуется сохранить модель без изменений, выберите вариант Специальное преобразование и отключите опции Удалить историю построения и Преобразовать компоненты (см. ниже).

Объединить тела и компоненты в одно тело

Выберите этот вариант, чтобы все тела и компоненты модели были объединены в одно тело.

Полученному телу назначается материал исходной сборки. Тело является сплошным, без внутренних полостей (эти полости заполняются материалом).

Если компоненты сборки не имеют ни одной общей поверхности, то в результате объединения получается тело из частей.

Специальное преобразование

Выберите этот вариант, чтобы настроить параметры преобразования структуры модели.

Удалить историю построения

Включите эту опцию для удаления из файла модели информации о способах создания объектов модели и связях между ними. В результате удаления истории построения:

– тела/поверхности/кривые превращаются в операции/поверхности/кривые без истории;

– массив превращается в набор объектов, расположенных согласно параметрам массива;

– локальные системы координат, контрольные и присоединительные точки заменяются обычными точками,

– эскизы, вспомогательные оси и плоскости, элементы оформления и сопряжения удаляются;

– компоненты фиксируются;

– если компонент был изменен операцией в содержащей его модели, то его тела и поверхности в отредактированном виде переносятся в модель, а сам компонент из нее удаляется.

Обратите внимание на то, что данная опция удаляет историю построения только тех объектов, которые принадлежат непосредственно преобразуемой модели, т.е. история построения компонентов сохраняется.

Преобразовать компоненты

Включите эту опцию, чтобы выполнить преобразование компонентов. При отключенной опции компоненты остаются без изменений.

Если удаление истории построения включено, то компоненты, затронутые операцией в содержащей их модели, преобразуются согласно вышеописанному вне зависимости от состояния опции Преобразовать компоненты.

В тела

Выбор этого варианта означает, что тела и поверхности компонентов всех уровней преобразуются в тела и поверхности без истории. Имена тел и поверхностей совпадают с именами соответствующих компонентов. Другие объекты компонентов в результирующую модель не передаются.

Если модель содержит операции над компонентами (например, массив компонентов), то после преобразования компонентов в тела эти операции удаляются, т.к. теряют источник построения. Удаление выполняется независимо от состояния опции Удалить историю построения.

В детали-заготовки

Выбор этого варианта означает, что компоненты первого уровня преобразуются в детали-заготовки. Если требуется, чтобы заготовки были внедрены в модель (а не вставлены ссылкой на внешние файлы), включите опцию Без истории.

Компоненты остальных уровней остаются без изменений.

Стандартные изделия и библиотечные компоненты не преобразуются в детали-заготовки.

После завершения настройки параметров нажмите кнопку ОК. Сборка будет преобразована и записана в файл детали в соответствии с настройкой.

Если требуется отказаться от записи файла, нажмите кнопку Отмена.


2.14.5.2. Отличительные особенности детали и сборки

Работа с деталью имеет ряд отличий по сравнению со сборкой.

– Для детали невозможно создать спецификацию (недоступны команды Создать объекты спецификации... и Создать спецификацию по сборке).

– В детали не предполагается использование компонентов, поэтому инструментальные панели Редактирование сборки и Сопряжения по умолчанию скрыты. При необходимости вы можете работать с компонентами в детали. Для этого включите отображение данных панелей с помощью соответствующих команд меню Вид — Панели инструментов.

– Недоступны разнесение компонентов и булевы операции над компонентами.

– Невозможно скопировать в деталь свойства из компонентов.

– Для детали недоступно применение системных типов загрузки. Типы загрузки, назначенные компонентам, нельзя сохранить как тип загрузки детали.


2.14.6. МЦХ и параметры штриховки модели

2.14. Редактирование и настройки модели

2.14.6. МЦХ и параметры штриховки модели

Массо-центровочные характеристики модели могут получаться расчетным путем или задаваться вручную.

– В первом случае МЦХ модели вычисляется по МЦХ составляющих ее частей: тел и компонентов.

– Во втором случае вычисляются только координаты центра масс (масса модели вводится пользователем) или ничего не вычисляется (и масса, и координаты центра масс модели вводятся пользователем).

Рассчитанные или заданные вручную масса и координаты центра масс модели сохраняются в ее файле. При вставке модели в другую модель в качестве компонента эти параметры передаются в модель и используются уже при расчете ее массо-центровочных характеристик.

В случае необходимости можно задать массо-центровочные характеристики для компонентов, отличающиеся от их собственных. Эти параметры будут храниться и использоваться в содержащей компоненты модели.

Для ускорения расчета МЦХ модели рекомендуется сохранить файлы всех ее компонентов в КОМПАС-3D версии 10 или более поздней.

Общие приемы задания параметров МЦХ описаны в разделе 2.14.6.1, а порядок действий при настройке параметров МЦХ тел, компонентов и моделей — в разделах 2.14.6.2–2.14.6.4. Раздел 2.14.6.5 посвящен настройкам системы и документов, связанных с МЦХ моделей, раздел 2.14.6.6 — заданию параметров штриховки модели.

В этом разделе:

2.14.6.1. Общие приемы задания параметров МЦХ

2.14.6.1.1. Материал и плотность материала

2.14.6.1.2. Масса и координаты центра масс

2.14.6.2. Параметры расчета МЦХ тел

2.14.6.3. Параметры расчета МЦХ компонентов

2.14.6.4. Параметры расчета МЦХ детали, сборки

2.14.6.5. Настройка МЦХ

2.14.6.6. Параметры штриховки модели


2.14.6.1. Общие приемы задания параметров МЦХ

Управление массо-центровочными характеристиками объекта (тела, компонента или модели) производится с помощью элементов, находящихся на вкладке Параметры МЦХ Панели свойств после вызова команды настройки свойств объекта.

Объем тел всегда рассчитывается системой автоматически. С помощью элементов управления вкладки Параметры МЦХ можно задать:

– материал и плотность материала (см. раздел 2.14.6.1.1) для расчета массы и координат центра масс,

– произвольные значения массы и координат центра масс (см. раздел 2.14.6.1.2).

На вкладке Параметры МЦХ присутствует также кнопка Пересчитать МЦХ (рис. 2.14.7). После ее нажатия производится расчет массо-центровочных характеристик объекта при текущем значении параметров. По окончании расчета на экране появляется Информационное окно с результатами расчета.

В Информационном окне отображаются краткие результаты расчета (масса, объем, площадь поверхности, координаты центра масс тела или модели). Чтобы получить инерционные характеристики модели (моменты инерции и направление главных осей инерции), воспользуйтесь командой МЦХ модели (см. раздел 2.15.2.4).

В этом разделе:

2.14.6.1.1. Материал и плотность материала

2.14.6.1.2. Масса и координаты центра масс


2.14.6.1.1. Материал и плотность материала

Для выбора параметров материала служит панель Материал (рис. 2.14.7).

Рис. 2.14.7. Расчет МЦХ по плотности; панель Материал

В таблице отображаются свойства материала модели — наименование текущего материала, плотность и параметры штриховки, с которыми он отображается на разрезе/сечении в чертеже.

Кнопка Выбрать материал из списка позволяет выбрать материал из справочного файла плотностей (файл ...\ASCON\KOMPAS-3D V...\Sys\Grарhic.dns; значения параметров материалов, содержащиеся в нем, могут редактироваться пользователем), а кнопка Выбрать материал из справочника — из Справочника Материалы и Сортаменты.

После выбора материала ячейки Обозначение материала и Плотность заполняются автоматически.

Чтобы задать плотность, активизируйте переключатель Расчет по плотности в группе Способ определения МЦХ на Панели свойств (рис. 2.14.7). Для расчета может использоваться справочное значение плотности, т.е. соответствующее выбранному материалу, или произвольно заданное.

– При активизированном переключателе Выбор из справочника (вариант по умолчанию) в расчете используется справочное значение плотности. Оно берется из справочного файла плотностей или Справочника Материалы и Сортаменты и отображается в поле Плотность.

– Чтобы задать произвольное значение плотности, активизируйте переключатель Ручной ввод и введите нужное значение в поле Плотность.

О настройке параметров штриховки модели см. раздел 2.14.6.6.


2.14.6.1.2. Масса и координаты центра масс

Чтобы задать массу модели, активизируйте переключатель Расчет по массе на Панели свойств (рис. 2.14.8). Введите значение массы в поле Масса.

При необходимости вы можете задать и координаты центра масс. Для этого включите опцию ЦМ и введите значения координат в таблицу на панели Центр масс.

Рис. 2.14.8. Расчет МЦХ по массе; панель Центр масс


2.14.6.2. Параметры расчета МЦХ тел

Чтобы настроить параметры расчета МЦХ тела, выделите его в Дереве построения и вызовите из контекстного меню команду Свойства тела (рис. 2.14.9).

Рис. 2.14.9. Вызов команды Свойства тела

Пиктограммы и названия тел показываются в Дереве, если в нем включено отображение структуры модели (см. раздел 2.1.2.2).

Активизируйте вкладку Параметры МЦХ на Панели свойств (рис. 2.14.10).

Рис. 2.14.10. Настройка параметров МЦХ для тела

Для тел доступны следующие возможности настройки параметров МЦХ.

– Использование параметров МЦХ, заданных в свойствах модели-источника — детали или сборки, в которой построено настраиваемое тело. Чтобы включить использование параметров МЦХ источника, активизируйте переключатель Из источника в группе Способ определения МЦХ. После этого элементы управления Материал и Масса станут недоступны.

– Задание материала и плотности материала тела (см. раздел 2.14.6.1.1).

Завершив настройку параметров МЦХ, нажмите кнопку Создать объект на Панели специального управления.


2.14.6.3. Параметры расчета МЦХ компонентов

Настройка параметров МЦХ возможна для любого компонента модели — детали (в том числе локальной), подсборки или библиотечного компонента. Файл компонента при этом остается без изменений. Возможна также настройка параметров МЦХ для компонентов, входящих в состав экземпляров массива.

Чтобы задать параметры МЦХ компонента, выделите этот компонент в Дереве построения и вызовите из контекстного меню команду Свойства компонента. Активизируйте вкладку Параметры МЦХ Панели свойств.

Для компонентов доступны следующие возможности настройки параметров МЦХ.

– Использование параметров МЦХ, хранящихся в файле-источнике компонента. Чтобы включить использование параметров МЦХ источника, активизируйте переключатель Из источника в группе Способ определения МЦХ. После этого элементы управления Материал и Масса станут недоступны.

– Ввод массы компонента, а при необходимости — и координат центра масс (см. раздел 2.14.6.1.2) (рис. 2.14.11). Обратите внимание на то, что координаты центра масс компонента необходимо задавать в его системе координат.

Если координаты центра масс компонента не заданы пользователем, то они рассчитываются по плотностям и объемам входящих в компонент тел и компонентов.

Рис. 2.14.11. Задание массы и центра масс компонента

– Задание материала и плотности материала тел компонента (см. раздел 2.14.6.1.1) (рис. 2.14.12). Указанная плотность будет использована для всех тел, построенных непосредственно в компоненте, которым не задана собственная плотность.

Рис. 2.14.12. Задание плотности компонента-детали

Завершив настройку параметров компонента для расчета МЦХ, нажмите кнопку Создать объект.

В Редакторе свойств можно просмотреть свойства материалов всех тел и компонентов. Также вы можете изменить их значения у компонентов первого уровня и пересчитать массу модели (см. раздел 5.1.4.2).

Пример задания МЦХ компонента вручную

Пусть в сборку вставлена условная, т.е. без проработки отдельных деталей и элементов, модель электродвигателя, масса и значения координат центра масс которой отличаются от стандартных. Однако, для получения правильных массо-центровочных характеристик сборки необходимо, чтобы в расчете участвовали стандартные параметры МЦХ электродвигателя.

Это можно обеспечить двумя способами.

Способ 1. Ввод и хранение стандартных параметров МЦХ в модели электродвигателя. Для этого выполните следующие действия.

1. Откройте модель электродвигателя, выделите первый элемент Дерева построения и вызовите из контекстного меню команду Свойства модели.

2. Перейдите на вкладку Параметры МЦХ Панели свойств и активизируйте переключатель Расчет по массе в группе Способ определения МЦХ.

3. Введите значение стандартной массы электродвигателя в поле Масса.

4. Активизируйте опцию ЦМ и введите стандартные координаты центра масс электродвигателя в таблицу на панели Центр масс.

5. Нажмите кнопку Создать объект.

6. Сохраните модель.

Заданные параметры МЦХ сохранятся в модели и будут переданы в сборку. Редактирование модели — добавление или удаление материала — не влияет на введенные вручную массу и координаты центра масс.

Способ 2. Ввод и хранение стандартных параметров МЦХ электродвигателя в сборке. Для этого выполните следующие действия.

1. Откройте сборку, содержащую модель электродвигателя в качестве компонента.

2. Выделите компонент Электродвигатель в Дереве построения сборки и вызовите из контекстного меню команду Свойства компонента.

3. Перейдите на вкладку Параметры МЦХ Панели свойств и активизируйте переключатель Расчет по массе в группе Способ определения МЦХ.

4. Введите значение стандартной массы электродвигателя в поле Масса.

5. Активизируйте опцию ЦМ и введите стандартные координаты центра масс электродвигателя в таблицу на панели Центр масс. Значения координат следует задавать в системе координат компонента (а не сборки).

6. Нажмите кнопку Создать объект.

7. Сохраните сборку.

Заданные параметры МЦХ компонента сохранятся в сборке и будут использоваться при расчете ее массо-центровочных характеристик. В модели электродвигателя никаких изменений не произойдет — в ней будут по-прежнему храниться расчетные значения массы и координат центра масс.

Особенности расчета МЦХ модели после редактирования

– Масса, вручную заданная для компонента (в файле-источнике или в содержащей его модели), считается постоянной, пока компонент или какая-либо его часть присутствует в модели. Если же модель отредактирована так, что тело компонента исчезло полностью, его масса считается нулевой. Например, после создания в модели отверстия, проходящего через компонент, масса этого компонента не меняется, а после удаления компонента в результате отсечения плоскостью масса этого компонента становится нулевой.

– Если в модели выполнена булева операция над телами двух компонентов, то массы этих тел перестают учитываться при расчете МЦХ модели. Вместо этого учитывается масса тела, получившегося в результате выполнения булевой операции. При необходимости параметры расчета МЦХ этого тела можно изменить, см. раздел 2.14.6.2.


2.14.6.4. Параметры расчета МЦХ детали, сборки

Чтобы настроить параметры расчета МЦХ модели (детали или сборки), выделите ее в Дереве модели и вызовите из контекстного меню команду Свойства модели (рис. 2.14.13).

Рис. 2.14.13. Вызов команды Свойства модели

Активизируйте вкладку Параметры МЦХ на Панели свойств.

Для моделей доступны следующие возможности настройки параметров МЦХ:

– Задание материала и плотности (см. раздел 2.14.6.1.1) (рис. 2.14.14). Указанная плотность будет использована для всех тел, построенных непосредственно в модели, которым не задана собственная плотность. Масса модели определяется как суммарная масса ее тел и компонентов.

Рис. 2.14.14. Задание плотности модели

– Задание общей массы модели, а при необходимости — и координат центра масс (см. раздел 2.14.6.1.2) (рис. 2.14.15). Если координаты центра масс модели не заданы пользователем, то они рассчитываются по параметрам входящих в нее тел и компонентов. При этом для тех тел, которым не задана собственная плотность, используется справочное значение плотности материала модели.

Рис. 2.14.15. Задание массы и центра масс модели

Завершив настройку параметров МЦХ, нажмите кнопку Создать объект на Панели специального управления.

Рассчитанные или заданные вручную масса и координаты центра масс модели будут записаны в ее файл.

В Редакторе свойств можно просмотреть свойства материалов всех тел и компонентов модели. Также вы можете изменить их значения (изменение свойств компонента возможно, только если он находится на первом уровне иерархии модели) и пересчитать массу модели (см. раздел 5.1.4.2).


2.14.6.5. Настройка МЦХ

В КОМПАС-3D доступны следующие настройки, касающиеся массо-центровочных характеристик моделей:

– настройка автоматического расчета МЦХ (см. раздел 9.1.11.15),

– задание точности вычисления МЦХ (см. раздел 9.2.7.4.11),

– выбор единиц измерения МЦХ (см. раздел 9.2.7.4.16),

– настройка материала, плотности материала и параметров штриховки детали, используемых по умолчанию в новом документе (см. раздел 9.2.7.4.1).


2.14.6.6. Параметры штриховки модели

Управление параметрами штриховки модели осуществляется в команде Свойства модели, Свойства тела или Свойства компонента.

На панели Материал вкладки Параметры МЦХ можно задать параметры штриховки материала модели — стиль, цвет и угол штриховки. Эти параметры сохраняются в модели и используются при ее отображении на разрезе/сечении в ассоциативном виде чертежа.

Настройка параметров штриховки возможна, если расчет параметров МЦХ производится по плотности или по массе. Если же параметры МЦХ определяются по источнику (доступно для компонентов и тел), то параметры штриховки также определяются по источнику.

Чтобы задать стиль штриховки, щелкните мышью по ячейке значения Стиль штриховки. Становится доступен список, из которого можно выбрать стиль штриховки, в том числе и созданный пользователем (рис. 2.14.16).

Рис. 2.14.16. Выбор стиля штриховки

О создании пользовательских стилей штриховок и сохранении их в библиотеку см. раздел 11.1.1.2.2.

Стиль штриховки задается модели автоматически, если материал выбирается из файла плотностей нажатием кнопки Выбрать материал из списка (см. раздел 2.14.6.1.1). Это обусловлено тем, что в файле плотностей содержится информация о соответствии стиля штриховки тому или иному материалу. О подготовке справочного файла плотностей см. раздел 9.5.5.2.

Чтобы сменить цвет штриховки или задать ей наклон, щелкните мышью по ячейке Цвет штриховки или Угол штриховки. На экране появляется стандартный диалог выбора цвета или список значений углов. При необходимости введите значение угла вручную.

Заданный угол наклона будет применен к штриховке на чертеже, если выбранный стиль допускает изменение угла.

Изменить параметры штриховки можно при задании свойств материала компонентам и телам в Редакторе свойств (см. раздел 5.1.4.2).

Завершив настройку параметров штриховки, нажмите кнопку Создать объект на Панели специального управления.


2.15. Сервисные функции

В этом разделе:

2.15.1. Диагностика модели

2.15.1.1. Предупреждения об ошибках

2.15.1.2. Предупреждения о необходимости перестроения модели

2.15.2. Измерения

2.15.2.1. Расстояние и угол

2.15.2.1.1. Объект «измерение»

2.15.2.2. Длина ребра

2.15.2.3. Площадь

2.15.2.4. МЦХ модели

2.15.2.5. Отклонение поверхностей

2.15.2.5.1. Измерение по нормали к первой поверхности

2.15.2.5.2. Измерение с использованием направляющего объекта

2.15.3. Проверка пересечений

2.15.4. Проверка гладкости поверхностей модели

2.15.4.1. Включение режима проверки гладкости модели

2.15.4.2. Настройка параметров отображения

2.15.4.2.1. Способ отображения Зебра

2.15.4.2.2. Способ отображения Отражение среды

2.15.5. Сечение модели

2.15.5.1. Управление сечениями

2.15.5.2. Создание сечения

2.15.5.2.1. Свободное размещение плоскости сечения

2.15.5.2.2. Смещенная плоскость сечения

2.15.5.2.3. Повернутая плоскость сечения

2.15.5.2.4. Сечение в виде параллелепипеда

2.15.5.2.5. Сечение по зоне

2.15.5.3. Редактирование параметров сечения

2.15.6. Получение информации о модели и ее объектах

2.15.6.1. Основные сведения

2.15.6.2. Дополнительные сведения

2.15.7. Разнесение компонентов сборки

2.15.8. Трехмерный макроэлемент

2.15.8.1. Создание трехмерного макроэлемента

2.15.8.2. Управление показом состава макроэлемента

2.15.8.3. Изменение состава макроэлемента

2.15.8.4. Разрушение макроэлемента

2.15.8.5. Удаление макроэлемента

2.15.9. Удаление истории построения модели

2.15.10. Создание чертежа текущей модели

2.15.11. Технические требования

2.15.11.1. Ввод и удаление технических требований в модели

2.15.11.2. Окно Технические требования

2.15.11.3. Печать технических требований из модели

2.15.12. Неуказанная шероховатость

2.15.12.1. Редактирование и удаление знака неуказанной шероховатости

2.15.13. Пароль на доступ к модели

2.15.14. Слои в модели

2.15.14.1. Состояние слоев

2.15.14.2. Слои в Менеджере документа-модели

2.15.14.3. Создание слоя в модели

2.15.14.4. Переключение между слоями

2.15.14.5. Выделение слоя в модели

2.15.14.6. Перенос объектов модели между слоями

2.15.14.7. Удаление слоя из модели

2.15.14.8. Группы и фильтры слоев в модели

2.15.15. Зоны в модели

2.15.15.1. Дерево зон

2.15.15.2. Создание зоны в модели

2.15.15.2.1. Создание зоны по координатам

2.15.15.2.2. Создание зоны по габаритам объектов

2.15.15.3. Разбиение на зоны

2.15.15.3.1. Разбиение зоны равномерно по осям

2.15.15.3.2. Разбиение зоны по набору плоскостей

2.15.15.4. Выделение объектов с помощью зон


2.15.1. Диагностика модели

2.15. Сервисные функции

2.15.1. Диагностика модели

В этом разделе:

2.15.1.1. Предупреждения об ошибках

2.15.1.2. Предупреждения о необходимости перестроения модели


2.15.1.1. Предупреждения об ошибках

Если произведено такое редактирование модели, которое делает невозможным существование каких-либо ее объектов с учетом иерархии и/или параметрических связей, КОМПАС-3D выдает соответствующее диагностическое сообщение. В нем указана конкретная причина конфликта или потери связи между компонентами модели (например, «Операция потеряла опорный объект», «Опорная поверхность видоизменилась», «Пустой эскиз», «Самопересечение контура» и т.д.).

При этом модель не перестраивается, а остается в том состоянии, в котором была перед вызовом команды редактирования. Рядом с пиктограммами объектов, существование которых стало невозможным после произведенного редактирования, в Дереве построения появляется признак ошибки.

Если ошибка есть хотя бы в одном из объектов модели (элементе, компоненте, сопряжении и т.п.), признак ошибки появляется не только рядом с пиктограммой этого объекта, но и рядом с пиктограммой модели (детали или сборки). Благодаря этому наличие ошибки в модели заметно даже тогда, когда Дерево построения полностью свернуто.

Чтобы узнать, в чем заключается возникшая ошибка, выделите в Дереве построения ошибочный объект и вызовите из контекстного меню команду Что неверно?.

На экране появится диалог, в котором перечислены ошибки, возникшие при перестроении этого объекта.

Ошибки отображаются в диалоге в виде структурированного списка. Описание каждой ошибки находится на уровне, следующем за названием ошибочного объекта.

Если вы просматриваете все ошибки в модели, то ее ошибочные компоненты (формообразующие элементы, вспомогательные оси и плоскости, копии, фаски, оболочки, компоненты, сопряжения и т.д.) в списке находятся на уровне, следующем за названием модели.

Справочная система содержит рекомендации по возможным путям устранения ошибки.

Чтобы получить разъяснение конкретной ошибки и общие рекомендации по ее устранению, выделите описание ошибки в диалоге и нажмите кнопку Справка. Прочитайте появившуюся страницу Справочной системы, подумайте, какой из рассмотренных в ней случаев наиболее похож на ошибку в вашей модели, запомните рекомендации по ее устранению.

Чтобы исправить ошибку, отредактируйте в соответствии с рекомендациями Справочной системы элемент, эскиз или сопряжение, в котором она возникла, или исходные элементы. Часто для исправления ошибки достаточно повторить редактирование модели, повлекшее за собой эту ошибку, установив при этом прежние значения параметров объектов.

Если в модели несколько ошибок, производите их исправление в порядке следования ошибочных элементов в Дереве построения.

Некоторые ошибки делают невозможным существование элементов, дальнейшие построения и редактирование детали. Например, после редактирования контура в эскизе исчезли опорные вершины для построения вспомогательных осей и плоскостей, а производный элемент не может быть перестроен (модель «рассыпалась», без устранения ошибки с ней работать нельзя).

Другие ошибки не являются столь критическими и не мешают дальнейшей работе с моделью. Например, при переносе эскиза на другую грань параметрические связи графических объектов эскиза были потеряны. В этом случае графические объекты в эскизе не перестраиваются, образуемый ими контур остается прежним, и построенный на его основе элемент не разрушается, благодаря чему остается возможным существование производных элементов.

В любом случае рекомендуется устранять ошибку сразу после ее возникновения.


2.15.1.2. Предупреждения о необходимости перестроения модели

После редактирования модели (перемещения компонентов, изменения значений переменных и т.п.) связи между объектами модели могут нарушиться. Например, вспомогательные элементы после перемещения их опорных объектов остаются на прежних местах. Объекты модели, редактирование которых вызвало конфликты такого рода, отмечаются красной «галочкой» в Дереве построения.

Чтобы устранить возникшие противоречия, необходимо изменить геометрию объектов и/или переместить их так, чтобы их форма, параметры и положение соответствовали положению опорных объектов и не противоречили наложенным на них сопряжениям. Для этого используется команда Вид — Перестроить модель. Подробнее о перестроении см. раздел 2.14.3.7.

Иногда после перестроения модели в ней могут появляться предупреждения об ошибках (восклицательный знак в красном кружке).


2.15.2. Измерения

2.15. Сервисные функции

2.15.2. Измерения

При работе в документах-моделях может возникнуть необходимость узнать расстояние или угол между вершинами, ребрами или гранями, длину кривой, площадь грани.

В КОМПАС-3D возможно измерение различных геометрических параметров, а также расчет массо-центровочных характеристик модели (объема, массы, координат центра масс, осевых и центробежных моментов инерции).

Результаты измерения геометрических параметров могут быть сохранены в модели как значения переменных.

Команды измерений сгруппированы в меню Сервис, а кнопки для вызова команд — на панели Измерения и диагностика (3D) (рис. 2.15.1).

Рис. 2.15.1. Панель Измерения и диагностика (3D)

На Панели свойств после вызова любой из команд измерения появляется вкладка Измерение. На ней расположены элементы, позволяющие настроить параметры процесса измерения. Эти элементы представлены в таблице 2.15.1.

Табл. 2.15.1. Элементы управления параметрами измерений
Элемент | Описание
Количество знаков после запятой | Список, управляющий точностью представления результатов вычисления. Минимальное количество знаков после запятой — 0, максимальное — 10.
Единицы измерения длины | Список, позволяющий выбрать единицы измерения длины: миллиметры, сантиметры, дециметры, метры.
Единицы измерения угла | Список, позволяющий выбрать единицы измерения углов: градусы, радианы. Только для команды Расстояние и угол.
Единицы измерения массы | Список, позволяющий выбрать единицы измерения массы: граммы, килограммы. Только для команды МЦХ модели.
Кратко | Опция, позволяющая получать результаты измерений в сокращенном или в полном объеме. Только для команд Расстояние и угол, МЦХ модели, Отклонение поверхностей.

На панели Измерения и диагностика (3D) находятся также кнопки вызова команд Проверка пересечений и Информация об объекте. О работе с ними рассказано в разделах 2.15.3 и 2.15.6 соответственно.

Вы можете настроить точность вычисления МЦХ и площадей граней в модели. Данная настройка описана в разделе 9.2.7.4.11.

В этом разделе:

2.15.2.1. Расстояние и угол

2.15.2.1.1. Объект «измерение»

2.15.2.2. Длина ребра

2.15.2.3. Площадь

2.15.2.4. МЦХ модели

2.15.2.5. Отклонение поверхностей

2.15.2.5.1. Измерение по нормали к первой поверхности

2.15.2.5.2. Измерение с использованием направляющего объекта


2.15.2.1. Расстояние и угол

Вы можете определить расстояние и, если возможно, угол между двумя указанными объектами. Такими объектами могут являться координатные и вспомогательные оси и плоскости, грани, ребра, вершины, пространственные кривые и точки. Их можно указывать в любой комбинации (например, плоскость и вершина, ребро и ось, две грани).

Для определения расстояния и угла между двумя объектами вызовите команду Расстояние и угол.

Щелкните мышью по первому объекту в окне модели. Указанный объект подсвечивается.

Подведите курсор ко второму объекту.

Система определяет значение расстояния между объектами (если оно не нулевое) и значение угла между ними (если объекты не параллельны и не перпендикулярны). Результаты измерения появляются рядом с курсором.

Если объекты пересекаются, параллельны или перпендикулярны, рядом с курсором появляется соответствующее сообщение.

Отображаемый результат измерений зависит от типов указанных объектов и их взаимного расположения.

Описание результатов приведено в таблице 2.15.2.

Если результаты измерений необходимо внести в Информационное окно, то щелкните по второму объекту левой кнопкой мыши.

Управление Информационным окном, а также команды его меню описаны в разделе 3.9.1.2.

Объекты могут быть выделены до вызова команды. После вызова команды объекты подсвечиваются, на экране появляются: Информационное окно с результатами измерений, фантомы измеряемых расстояний и, если указана поверхность вращения, оси вращения.

Табл. 2.15.2. Результаты измерений

Обозначение величины

Описание результатов измерений

L

Расстояние между объектами.

Измеряется в случаях, когда можно однозначно определить расстояние между объектами, например, между двумя вершинами.

Также расстояние L измеряется, если один из объектов является конечным (гранью, ребром, кривой), а второй — бесконечным (вспомогательной, координатной осью или плоскостью). В этом случае результатом измерения L является кратчайшее расстояние между объектами.

L (min), L (max)1

Минимальное и максимальное расстояния между объектами. Измеряются между точками двух объектов, расположенными наиболее близко L (min) и наиболее далеко L (max) друг от друга. Если объекты пересекаются, то значение L (min) на экран не выводится.

Измерение L (min) и L (max) производится для случаев, когда оба объекта конечны. Один из объектов может быть точечным.

L (norm)

Расстояние между параллельными плоскостями.

Измеряется в случаях, когда указанные объекты находятся в параллельных плоскостях.

А

Угол, зависящий от типа указанных объектов:

– для прямолинейных объектов — угол между скрещивающимися или пересекающимися прямыми, содержащими эти объекты;

– для прямолинейного и плоского объектов — угол между прямолинейным объектом и его проекцией на плоский объект;

– для двух плоских объектов — угол между плоскостями объектов;

– для прямолинейного объекта и поверхности вращения — угол между объектом и осью поверхности вращения;

– для плоского объекта и поверхности вращения — угол между плоскостью объекта и осью поверхности вращения;

– для двух поверхностей вращения — угол между осями вращения.

Дополняющий угол1

Угол, дополняющий измеренный угол А до 180° или 360°.

Расстояние до оси

Расстояние от точки до оси поверхности вращения. Измеряется, если один из указанных объектов является поверхностью вращения.

Межосевое расстояние

Расстояние между осями поверхностей вращения. Измеряется, если оба указанных объекта являются поверхностями вращения.

В проекциях на оси абсолютной системы координат1

dx, dy, dz — проекции расстояния (L, L(min), L(max), L(norm), Расстояние до оси или Межосевое расстояние) в миллиметрах на оси абсолютной системы координат X, Y, Z.

  1. Данный параметр вычисляется, если на Панели свойств выключена опция Кратко.

Чтобы получить дополнительные результаты измерений, выключите опцию Кратко на Панели свойств и повторите указание объектов.

Кнопка Запомнить состояние на Панели специального управления позволяет запомнить первый указанный объект. Например, если требуется измерить расстояние и угол между одним объектом и несколькими другими, то после указания первого объекта нажмите кнопку Запомнить состояние, а затем укажите остальные объекты.

В этом разделе:

2.15.2.1.1. Объект «измерение»


2.15.2.1.1. Объект «измерение»

При использовании команд измерения расстояния, угла, площади грани или длины ребра можно создать объект «измерение». При этом в модели автоматически формируются связанные с этим объектом информационные переменные, значения которых равны результатам измерения. Об информационной переменной см. раздел 7.1.1.2.1.

Чтобы создать объект «измерение», укажите объект (объекты) щелчком мыши в окне модели, а затем нажмите кнопку Создать измерение на Панели свойств.

Объект «измерение», соответствующий последнему выполненному измерению, появляется в Дереве построения и в Окне переменных.

При выделении измерения в Дереве построения объект (объекты) этого измерения выделяются в окне модели.

При использовании команды Измерить расстояние и угол в зависимости от состояния опции Кратко может быть получен объект «измерение» с сокращенным или полным набором переменных.

Объект «измерение» не подлежит редактированию — его можно только удалить из модели или исключить из расчета.

Измерение постоянно сохраняет связь со своими объектами, т.е. после редактирования модели, которое влияет на результат измерения, изменяется значение соответствующей этому измерению переменной. Если объект «измерение» был исключен из расчета, то новое значение переменной вычисляется после включения объекта в расчет.

Иногда редактирование модели может приводить к вырождению объекта «измерение». Например, две точки, между которыми измерялось расстояние, совпали. В этом случае объект «измерение» отмечается в Дереве построения и в Окне переменных как ошибочный.

При удалении объекта, участвующего в измерении, объект «измерение» удаляется.


2.15.2.2. Длина ребра

Чтобы определить длину пространственной кривой или периметр грани детали, вызовите команду Длина ребра.

Подведите курсор к объекту, длину которого вы хотите измерить. Результат измерения появляется рядом с курсором.

Если полученный результат необходимо внести в Информационное окно, то щелкните по выбранному объекту левой кнопкой мыши.

На экране появляется Информационное окно с результатом измерения. Указанный объект подсвечивается.

Управление Информационным окном, а также команды его меню описаны в разделе 3.9.1.2.

Вы можете просмотреть значения длин других объектов, подведя к ним курсор. Для внесения результатов измерений в Информационное окно последовательно щелкайте по этим объектам мышью.

Указанные объекты подсвечиваются. В Информационное окно добавляется список измеренных длин. В конце списка указана сумма всех измеренных значений.

Чтобы измерить полную длину многосегментной кривой, укажите ее в Дереве построения.

Если требуется измерить периметр грани, укажите эту грань сразу после вызова команды. В этом случае сумма измеренных значений будет соответствовать ее периметру.

Чтобы исключить какой-либо объект из списка, укажите его повторно. Выделение с этого объекта будет снято, запись о его длине будет удалена из окна, а сумма длин — вычислена заново.

Объекты могут быть выделены до вызова команды. После вызова команды на экране появляется Информационное окно с результатами измерений.

По результатам измерений вы можете создавать объекты «измерение» (см. раздел 2.15.2.1.1).


2.15.2.3. Площадь

Чтобы измерить площадь граней детали, вызовите команду Площадь.

Подведите курсор к грани, площадь которой вы хотите измерить. Результат измерения появляется рядом с курсором.

Если полученный результат необходимо внести в Информационное окно, то щелкните по выбранной грани левой кнопкой мыши.

На экране появляется Информационное окно с результатом измерения. Указанная грань подсвечивается.

Управление Информационным окном, а также команды его меню описаны в разделе 3.9.1.2.

Вы можете просмотреть значения площадей других граней, подведя к ним курсор. Для внесения результатов измерений в Информационное окно последовательно щелкайте по этим граням мышью.

Выбранные грани подсвечиваются. В Информационное окно добавляется список измеренных площадей. В конце списка указана сумма всех измеренных значений.

Чтобы исключить какую-либо грань из списка, укажите ее повторно. Выделение с этой грани будет снято, запись о ее площади будет удалена из окна, а сумма площадей — вычислена заново.

Объекты могут быть выделены до вызова команды. После вызова команды на экране появляется Информационное окно с результатами измерений.

По результатам измерений вы можете создавать объекты «измерение» (см. раздел 2.15.2.1.1).


2.15.2.4. МЦХ модели

Чтобы выполнить расчет массо-центровочных характеристик текущей модели, вызовите команду МЦХ модели.

По умолчанию в Информационном окне отобразится краткая информация о модели. Это следующие данные:

– площадь поверхности модели,

– объем модели,

– масса модели,

– координаты центра масс в абсолютной системе координат модели.

Чтобы получить дополнительные сведения, выключите опцию Кратко на Панели свойств. В Информационное окно добавятся следующие данные:

– осевые моменты инерции (в абсолютной, центральной и главной центральной системах координат),

– центробежные моменты инерции (в абсолютной и центральной системах координат),

– направление главных осей инерции.

Кнопка Центр масс на Панели свойств управляет отображением центра масс модели. При нажатой кнопке на экране отображается фантом главной центральной системы координат. Оси этой системы координат обозначены J1, J2 и J3 в порядке убывания момента инерции относительно оси.

Чтобы создать точку в центре масс, включите опцию Точка, а затем нажмите кнопку Центр масс. В модели будет создана точка с названием «Точка в ЦМ».

При последующем редактировании модели положение ранее созданной Точки в ЦМ не меняется. Чтобы создать новую точку, соответствующую фактическому центру масс, вызовите команду Вычислить МЦХ модели повторно.


2.15.2.5. Отклонение поверхностей

Вы можете измерить расстояния между двумя объектами. Такими объектами могут являться координатные и вспомогательные плоскости, грани, объекты-поверхности.

Далее для обозначения объектов измерений будет применяться термин поверхность.

Чтобы измерить расстояния между поверхностями, вызовите команду Отклонение поверхностей. Затем поочередно укажите поверхности в окне модели. Поверхности также могут быть указаны до вызова команды.

Расстояния измеряются между точками первой поверхности и их проекциями на вторую поверхность в заданном направлении.

Количество точек определяется пользователем, их расположение на поверхности задается автоматически. Направление измерения зависит от выбранного способа измерения:

– нормально к первой поверхности,

– параллельно выбранному направляющему объекту.

Способ измерения можно выбрать, используя переключатели группы Способ.

Переключатели группы Направление позволяют выбрать направление измерения — прямое, обратное или в обоих направлениях. Направление измерения в окне модели показано фантомом. Оно должно совпадать с направлением на вторую поверхность, иначе измерение не будет выполнено.

Выбор варианта направления измерения зависит от формы и взаимного расположения поверхностей. Например, пусть сечение поверхностей плоскостью имеет вид, представленный на рис. 2.15.2. Измерение выполняется с использованием направляющего объекта. Если ограничиться измерениями только в прямом направлении, то часть расстояний не будет измерена — на рисунке линии этих измерений показаны прерывистыми стрелками. Чтобы измерить все расстояния между поверхностями, следует выбрать вариант Два направления.

Рис. 2.15.2. Сечение поверхностей

Решение о необходимости измерений в обоих направлениях принимает пользователь.

Поля со счетчиком Точек по U и Точек по V позволяют задать количество точек измерения по параметрам U и V. По умолчанию значения полей составляют 20. Общее количество измерений равно произведению значений полей.

Поля со счетчиком Минимумов и Максимумов позволяют задать количество первых искомых минимумов и максимумов, параметры которых отображаются в Информационном окне. По умолчанию значения полей равны 1.

Опция Кратко позволяет выбрать количество измерений, параметры которых будут показаны в Информационном окне в результате выполнения команды. Если опция включена, будут показаны только первые искомые максимумы и минимумы. Если опция выключена, будут показаны все результаты измерений.

Результаты измерений отображаются в Информационном окне.

Управление окном, а также команды его меню описаны в разделе 3.9.1.2.

В Информационном окне содержатся следующие параметры:

– Количество измерений,

Количество измерений может не совпадать с заданным количеством точек. Например, измерение не выполняется, если линия измерения не пересекает вторую поверхность.

– Минимальное расстояние между поверхностями в точках измерений,

– Максимальное расстояние между поверхностями в точках измерений,

– Среднее арифметическое расстояний в точках измерений,

– Абсолютный минимум расстояния между поверхностями,

Точка измерения абсолютного минимума может не совпадать с точками заданного набора.

– Заданное количество результатов измерения, наиболее близких к минимальному расстоянию (первые искомые минимумы),

– Заданное количество результатов измерения, наиболее близких к максимальному расстоянию (первые искомые максимумы).

Для каждого измерения из первых искомых минимумов и максимумов отображается следующий набор данных (рис. 2.15.3):

– измеренное расстояние,

– координаты точки измерения на первой и второй поверхностях,

– среднее арифметическое значение расстояния.

Если измерение расстояния выполняется в обоих направлениях, то в начале каждой строки, содержащей результаты измерения, отображается стрелка, показывающая направление измерения. Прямое направление отмечается стрелкой влево, обратное направление — стрелкой вправо.

Рис. 2.15.3. Результаты измерения первых минимумов и максимумов в Информационном окне

Если при выполнении команды выбрано отображение полного набора результатов измерений, координаты точек измерений и измеренное расстояние будут показаны для всех измерений.

Если в текущем сеансе выполнения команды будет выполнено повторное измерение, результаты предыдущего измерения в Информационном окне будут заменены новыми и не сохранятся. Чтобы не потерять результаты измерений, необходимо сохранить их в файл на диске, используя команды меню Информационного окна.

В этом разделе:

2.15.2.5.1. Измерение по нормали к первой поверхности

2.15.2.5.2. Измерение с использованием направляющего объекта


2.15.2.5.1. Измерение по нормали к первой поверхности

Чтобы выполнить измерение, следует нажать переключатель По нормали к ‘Поверхности 1‘.

Укажите в окне документа-модели поверхность, от которой будут измеряться расстояния. Наименование объекта появится в поле Поверхность 1.

Укажите вторую поверхность. Наименование объекта появится в поле Поверхность 2.

Координатная или вспомогательная плоскость может быть выбрана только в качестве второй поверхности.

Выберите направление измерения таким образом, чтобы фантом стрелки был направлен от первой поверхности ко второй. Если направление измерения будет выбрано неправильно, при попытке выполнения команды в Информационном окне появится сообщение Некорректно заданы параметры для расчета.

Задайте количество измерений по параметрам U и V и количество отображаемых минимумов и максимумов измеряемых значений.

Используя опцию Кратко, задайте объем результатов измерений, отображаемых в Информационном окне.

Чтобы выполнить измерения, нажмите кнопку Создать объект на Панели свойств.

Результаты измерений появятся в Информационном окне. В окне модели будут показаны линии измерений, соединяющие точки измерений первых искомых минимумов и максимумов. Линии измерений первых искомых минимумов показаны сплошными линиями, первых искомых максимумов — пунктирными.

Система будет ожидать изменения параметров команды для последующих измерений.

Кнопка Прервать команду позволяет завершить работу команды.


2.15.2.5.2. Измерение с использованием направляющего объекта

Чтобы выполнить измерение, следует нажать переключатель По направляющему объекту.

Укажите в окне документа-модели поверхность, от которой будут измеряться расстояния. Наименование объекта появится в поле Поверхность 1.

Укажите вторую поверхность. Наименование объекта появится в поле Поверхность 2.

Координатная или вспомогательная плоскость может быть выбрана только в качестве второй поверхности.

Укажите направляющий объект. В качестве направляющих могут быть указаны следующие объекты:

– Прямолинейные: ось, отрезок, прямое ребро, сегмент ломаной линии. При выборе прямолинейного объекта измерения будут выполняться параллельно ему.

– Плоские: плоская грань, координатная или вспомогательная плоскость. При выборе плоского объекта измерения будут выполняться перпендикулярно ему.

Если нужного направляющего объекта в модели нет, то вы можете построить вектор, задающий направление измерения (о векторе см. раздел 2.8.5).

Выберите направление измерения таким образом, чтобы фантом стрелки был направлен от первой поверхности ко второй. Если направление измерения будет выбрано неправильно, при попытке выполнения команды в Информационном окне появится сообщение Некорректно заданы параметры для расчета.

Задайте количество измерений по параметрам U и V и количество отображаемых минимумов и максимумов измеряемых значений.

Используя опцию Кратко, задайте объем результатов измерений, отображаемых в Информационном окне.

Чтобы выполнить измерения, нажмите кнопку Создать объект на Панели свойств.

Результаты измерений появятся в Информационном окне. В окне модели будут показаны линии измерений, соединяющие точки измерений первых искомых минимумов и максимумов. Линии измерений первых искомых минимумов показаны сплошными линиями, первых искомых максимумов — пунктирными.

Система будет ожидать изменения параметров команды для последующих измерений.

Кнопка Прервать команду позволяет завершить работу команды.


2.15.3. Проверка пересечений

2.15. Сервисные функции

2.15.3. Проверка пересечений

Иногда одной из целей моделирования изделия является обнаружение мест нежелательных пересечений и касаний компонентов или тел («натыков» в конструкции).

Для выявления таких мест нажмите кнопку Проверка пересечений на панели Измерения и диагностика (3D) или выберите ее название из меню Сервис.

После вызова команды последовательно указывайте компоненты или тела, которые требуется проверить на пересечение. Выбранные объекты будут показаны в Списке объектов на Панели свойств.

– Если для проверки выбраны компоненты, то будут найдены пересечения между телами, принадлежащими этим компонентам (но не между телами, принадлежащими одному компоненту). Указание компонентов производится в Дереве построения.

– Если для проверки выбраны тела, то будут найдены пересечения между ними. Указание тел возможно как в Дереве, так и в окне модели.

Если требуется обнаружить касание компонентов или тел, включите опцию Считать касания пересечениями.

После указания объектов нажмите кнопку Проверить пересечения на Панели специального управления.

В списке Обнаруженные пересечения на Панели свойств появятся порядковый номер пересечения и названия пересекающихся (касающихся) объектов. В окне модели будет показан каркас области их пересечения и/или линия касания.

Для выхода из команды проверки пересечений нажмите клавишу <Esc> или кнопку Прервать команду.


2.15.4. Проверка гладкости поверхностей модели

2.15. Сервисные функции

2.15.4. Проверка гладкости поверхностей модели

При моделировании деталей (например, корпусных) может возникнуть необходимость тщательной проверки гладкости поверхностей. Для визуальной оценки гладкости поверхностей модели используется специальный режим ее отображения.

В этом режиме все грани модели представляются зеркально отражающими окружающую среду, например, цветные полосы, нанесенные на сферическую поверхность. Вы можете визуально оценить гладкость соединения граней поверхности (см. табл. 2.15.3), а также выявить малозаметные изменения кривизны внутри граней (см. рис. 2.15.4).

Включение режима проверки гладкости модели описано в разделе 2.15.4.1, настройка параметров отображения — в разделе 2.15.4.2.

Табл. 2.15.3. Оценка гладкости стыков граней с использованием «зебры»
Условие сопряжения граней | Форма и расположение полос «зебры», соответствующие условию сопряжения
Не задано | Полосы на гранях не стыкуются:
По касательной | Полосы на гранях стыкуются с изломом:
Гладкое | Полосы на гранях стыкуются гладко:

Рис. 2.15.4. Проверка гладкости поверхности (поверхность имеет небольшую выпуклость): а) полутоновое с каркасом отображение модели — выпуклость практически не видна; б) режим проверки гладкости модели (способ Зебра) — выпуклость хорошо видна
а) | б)

В этом разделе:

2.15.4.1. Включение режима проверки гладкости модели

2.15.4.2. Настройка параметров отображения

2.15.4.2.1. Способ отображения Зебра

2.15.4.2.2. Способ отображения Отражение среды


2.15.4.1. Включение режима проверки гладкости модели

Для включения режима проверки гладкости модели вызовите команду Режим проверки гладкости на панели Режимы или выберите ее название из меню Сервис — Проверка гладкости. После ее вызова внешний вид модели изменяется. По умолчанию для отображения используется способ Зебра.

В процессе работы с документом параметры отображения модели могут быть настроены (например, изменена ширина полос «зебры» или выбран другой способ отображения — Отражение среды). В этом случае внешний вид модели соответствует произведенным настройкам.

Способы отображения модели и настройка соответствующих им параметров описана в разделе 2.15.4.2.

Использование режима проверки гладкости модели приводит к дополнительному расходу памяти и ресурсов операционной системы, что в конечном счете несколько замедляет работу КОМПАС-3D.


2.15.4.2. Настройка параметров отображения

Параметры режима проверки гладкости модели могут быть настроены. Настройка доступна, если в модели есть хотя бы одна поверхность.

Для выполнения настройки вызовите команду Параметры проверки гладкости одним из следующих способов:

– выбрав из меню кнопки Режим проверки гладкости на панели Режимы,

– выбрав из меню Сервис — Проверка гладкости.

Внешний вид модели изменится (если в документе не включен режим проверки гладкости модели). На Панели свойств появятся элементы управления параметрами отображения.

Возможны два способа отображения модели:

– Зебра — в гранях модели отражается сфера с нанесенными на нее полосами (данный способ является умолчательным),

– Отражение среды — в гранях модели отражается сфера с нанесенным на нее растровым изображением из файла.

При этом модель находится внутри воображаемой сферы.

Способ отображения модели выбирается из одноименного раскрывающегося списка.

Для способа Зебра задайте цвет и параметры отображения полос (см. раздел 2.15.4.2.1).

Для способа Отражение среды выберите файл, в котором содержится нужное изображение, и задайте параметры его отображения (см. раздел 2.15.4.2.2).

При изменении параметров отображения модели ее внешний вид в окне автоматически изменяется.

Если границы отражаемых полос или участков выбранного изображения имеют неровности, включите опцию Повышенная точность отрисовки. Границы станут более ровными.

Для завершения работы в команде нажмите кнопку Прервать команду на Панели специального управления. Если в документе не включен режим проверки гладкости, то модель примет прежний вид. Если этот режим включен, отображение модели будет соответствовать настроенным параметрам.

Настройка параметров отображения модели сохраняется до конца текущего сеанса работы с документом.

В этом разделе:

2.15.4.2.1. Способ отображения Зебра

2.15.4.2.2. Способ отображения Отражение среды


2.15.4.2.1. Способ отображения Зебра

По умолчанию для отображения модели данным способом используются черные полосы на белом фоне. С помощью элементов управления Панели свойств (рис. 2.15.5) вы можете настроить параметры полос и изменить их цвет. Цвет фона изменить нельзя.

Рис. 2.15.5. Элементы настройки цвета и параметров полос

Для изменения цвета полос служит поле Цвет полос. Чтобы выбрать нужный цвет, необходимо щелкнуть мышью по треугольнику в правой части поля и указать цвет в появившейся на экране палитре цветов.

Для настройки параметров полос служит панель Параметры “зебры”. Панель содержит область предварительного просмотра и поля, соответствующие следующим параметрам:

– частота полос,

– ширина полос,

– размытие границ,

– поворот,

– прозрачность.

«Ползунок» в каждом поле позволяет управлять значением соответствующего параметра. Область предварительного просмотра служит для визуальной оценки произведенных изменений — в ней изображена сфера с нанесенными на нее полосами. При изменении цвета или значений параметров изображение в области предварительного просмотра автоматически изменяется.


2.15.4.2.2. Способ отображения Отражение среды

Для отображения модели данным способом используется изображение, содержащееся в растровом файле формата BMP, GIF, JPEG, PNG, TIFF или TGA. С помощью элементов управления Панели свойств (рис. 2.15.6) вы можете выбрать нужный файл и настроить параметры нанесения изображения на отражаемую сферу.

Рис. 2.15.6. Элементы выбора изображения и настройки параметров его нанесения
на поверхность сферы

Для выбора файла необходимо нажать кнопку Файл изображения и указать нужный файл в стандартном диалоге выбора файлов. Полное имя файла появится в поле Файл-источник. Станет доступной панель Параметры отражения, позволяющая настроить параметры нанесения выбранного изображения на поверхность отражаемой сферы.

Панель содержит область предварительного просмотра и поля, соответствующие следующим параметрам:

– смещение по горизонтали,

– масштаб по горизонтали,

– смещение по вертикали,

– масштаб по вертикали,

– поворот,

– прозрачность.

«Ползунок» в каждом поле позволяет управлять значением соответствующего параметра. Область предварительного просмотра служит для визуальной оценки произведенных изменений — в ней изображена сфера с нанесенным на нее изображением. При выборе другого файла изображения или значений параметров изображение в области предварительного просмотра автоматически изменяется.

Путь к папке с изображениями (т.е. к папке, которая открывается после нажатия на кнопку Файл изображения) определяется переменой PICTURES среды КОМПАС-3D (см. раздел 9.5.4). По умолчанию открывается подпапка Samples\Surfaces\Maps главной папки системы. Если требуется, чтобы путь к папке с изображениями отличался от умолчательного, используйте файл Kompas.ini (см. раздел 9.5.3).


2.15.5. Сечение модели

2.15. Сервисные функции

2.15.5. Сечение модели

В процессе моделирования бывает трудно оценить корректность взаимного расположения деталей и узлов сборочной модели, конструктивных элементов детали, толщину ее стенок и т.д. Для визуального контроля в подобных случаях используется режим сечения модели.

При включенном режиме модель отображается усеченной плоскостью или набором плоскостей (рис. 2.15.7). Положение секущей плоскости (плоскостей) задается при создании сечения модели (см. раздел 2.15.5.2).

Рис. 2.15.7. Режим сечения модели: а) модель при отключенном режиме сечения; б) модель в режиме сечения с отображением фантомных граней; в) модель в режиме сечения без отображения фантомных граней
а) | б) | в)

Вы можете создать в модели несколько различных сечений. Одно из них — текущее.

Чтобы включить режим сечения модели, вызовите команду Вид — Сечение модели — Отобразить сечение или нажмите кнопку Сечение модели на панели Вид.

Если в модели еще не создано ни одного сечения, то после вызова команды запустится процесс создания сечения. Если сечения в модели есть, то вид модели изменится. Она будет отображаться усеченной текущим сечением, а в правом верхнем углу окна модели появится значок режима сечения модели.

Вы можете сделать текущим другое сечение. Для этого выберите его имя из меню кнопки Сечение модели. Вид модели в окне автоматически изменится.

Если выбранное сечение содержит ошибочные параметры, то модель отображается без усечения. На экране появляется сообщение с описанием ошибки.

Включение режима сечения происходит также после завершения создания сечения. Созданное сечение становится текущим.

В режиме сечения модели вы можете выполнять любые операции построения объектов, измерения, включать другие режимы (например, режим контекстного редактирования, режим эскиза и др.).

При выполнении операций доступно указание вершин, ребер и граней модели, в том числе усеченных, но недоступно указание вершин, ребер и граней сечения.

Чтобы завершить работу в режиме, повторно вызовите команду Вид — Сечение модели — Отобразить сечение, или нажмите кнопку Сечение модели на панели Вид, или щелкните мышью по значку режима в окне модели.

Для формирования набора сечений в модели используется диалог Сечения модели, описанный в разделе 2.15.5.1. Этот диалог позволяет не только создавать, но и удалять сечения, изменять их параметры.

В этом разделе:

2.15.5.1. Управление сечениями

2.15.5.2. Создание сечения

2.15.5.2.1. Свободное размещение плоскости сечения

2.15.5.2.2. Смещенная плоскость сечения

2.15.5.2.3. Повернутая плоскость сечения

2.15.5.2.4. Сечение в виде параллелепипеда

2.15.5.2.5. Сечение по зоне

2.15.5.3. Редактирование параметров сечения


2.15.5.1. Управление сечениями

Для формирования набора сечений используется диалог Сечения модели (рис. 2.15.8). Он появляется на экране после вызова команды Управление сечениями... из меню Вид — Сечение модели или меню кнопки Сечение модели на панели Вид.

Рис. 2.15.8. Диалог Сечения модели

Диалог содержит список сечений, созданных в модели, и элементы управления сечениями.

Список сечений имеет вид таблицы. Он позволяет изменить имя сечения и его статус.

Чтобы изменить имя сечения, дважды щелкните мышью в соответствующей ячейке таблицы и введите нужный текст.

Если требуется сделать сечение текущим, активизируйте строку данного сечения и нажмите кнопку Текущее сечение на инструментальной панели диалога или дважды щелкните мышью в ячейке Статус, соответствующей данному сечению. При включенном режиме сечения модели вид модели в окне автоматически изменится.

Если режим сечения модели отключен, вы можете включить его, не закрывая диалог. Для этого нажмите кнопку Режим сечения модели. Повторное нажатие кнопки отключит режим. При включении/отключении режима диалог остается на экране.

Чтобы создать новое сечение, нажмите кнопку Создать сечение и выполните действия, описанные в разделе 2.15.5.2.

Кнопка Редактировать сечение позволяет изменить параметры сечения (см. раздел 2.15.5.3).

После нажатия кнопки создания или редактирования сечения диалог Сечения модели закрывается.

Чтобы удалить сечение, выберите его в списке и нажмите кнопку Удалить сечение. Если данное сечение является текущим, то после его удаления текущим становится сечение, следующее за ним в списке.

После выполнения всех необходимых действий закройте диалог.

Действия, выполненные в диалоге, не могут быть отменены.


2.15.5.2. Создание сечения

Сечение модели может включать несколько шагов отсечения. Для каждого шага настраиваются свои параметры. По умолчанию сечение содержит один шаг. Вы можете добавить нужное количество шагов при создании или редактировании сечения.

На каждом шаге выполняется отсечение части модели одной или несколькими плоскостями. Количество плоскостей зависит от способа, выбранного для настройки параметров шага.

Вы можете создать произвольное количество шагов отсечения, однако, сечение модели может содержать не более 6 секущих плоскостей.

Процесс создания сечения запускается в следующих случаях:

– после вызова команды Вид — Сечение модели — Отобразить сечение или нажатия кнопки Сечение модели на панели Вид, если в модели не создано ни одно сечение,

– после нажатия кнопки Создать сечение в диалоге Сечения модели.

В окне модели появляется фантом плоскости сечения, а на Панели свойств — вкладки Параметры (рис. 2.15.9) и Свойства.

Рис. 2.15.9. Создание сечения модели, вкладка Параметры

Положение фантома соответствует первому шагу отсечения. Задайте параметры первого шага и добавьте нужное количество шагов.

Список шагов отсечения отображается на панели Шаг отсечения вкладки Параметры. По умолчанию он содержит один шаг.

Если заданных параметров недостаточно для создания шага отсечения или параметры заданы неверно, справа от имени шага в списке отображаются символы (!).

Задайте нужные параметры для первого шага отсечения. Набор параметров зависит от способа размещения секущей плоскости, который выбирается из раскрывающегося списка Способ. Доступны следующие варианты:

– Свободное размещение (см. раздел 2.15.5.2.1),

– Смещенная плоскость (см. раздел 2.15.5.2.2),

– Повернутая плоскость (см. раздел 2.15.5.2.3),

– Параллелепипед (см. раздел 2.15.5.2.4),

– Зона (см. раздел 2.15.5.2.5).

В некоторых случаях при настройке параметров шага отсечения используются объекты, имеющиеся в модели. Например, при размещении плоскости сечения способом Повернутая плоскость положение базовой плоскости и оси вращения определяются выбранными объектами. Если требуется перевыбрать объекты, нажмите кнопку Указать заново на Панели специального управления.

При размещении плоскости сечения способом Свободное размещение, Смещенная плоскость или Повернутая плоскость вы можете управлять направлением отсечения. При свободном размещении плоскости направление отсечения показывает ось Z элемента задания положения, а при смещении или повороте плоскости — синяя стрелка. Чтобы сменить направление отсечения на противоположное, нажмите кнопку Сменить направление.

При использовании этих способов размещения вы также можете включить ориентацию модели, при которой плоскость сечения параллельна плоскости экрана. Для этого нажмите кнопку Вид по нормали к плоскости сечения на Панели специального управления.

Для способов Смещенная плоскость и Повернутая плоскость кнопки Сменить направление и Вид по нормали к плоскости сечения становятся доступными после выбора базовых объектов.

Если сечение должно включать несколько шагов отсечения, создайте новый шаг, нажав кнопку Добавить шаг отсечения на панели Шаг отсечения. В списке появится имя нового шага. Выберите способ построения и задайте параметры размещения плоскости сечения, как описано выше.

Если требуется удалить шаг отсечения, укажите его в списке и нажмите кнопку Удалить.

Чтобы в месте сечения модели созданной плоскостью отображалась фантомная грань (или грани), включите опцию Закрашивать сечение. Цвет и оптические свойства этой грани задаются на вкладке Свойства (см. ниже). Фантомная грань не является объектом и отображается только при включенном режиме сечения модели (см. рис. 2.15.7, б).

Чтобы фантомная грань (грани) не отображалась в модели (см. рис. 2.15.7, в), отключите опцию. Это может понадобиться, например, для визуальной оценки корректности взаимного расположения компонентов сборочной модели (проверки на наличие пересечений компонентов и т.п.).

Включение/отключение опции Закрашивать сечение выполняется для всего создаваемого сечения, а не для отдельных его шагов, т.е. фантомные грани отображаются (либо не отображаются) для всех шагов отсечения.

Фантомные грани, а также их ребра и вершины не могут использоваться при выполнении каких-либо операций в модели. Они недоступны для указания.

Чтобы задать имя создаваемого сечения, раскройте вкладку Свойства и введите нужный текст в поле Наименование.

Также на этой вкладке настраиваются цвет и оптические свойства фантомной грани. Для этого используется группа элементов Назначить цвет. Доступны следующие варианты задания цвета:

– По исходному объекту,

– Вручную.

При ручном выборе цвета доступна настройка оптических свойств. Подробное описание элементов задания цвета и оптических свойств приведено в разделе 2.14.2.

Для завершения создания сечения нажмите кнопку Создать объект. Кнопка доступна, если сечение содержит хотя бы один шаг, параметры которого заданы полностью и без ошибок.

Вновь созданное сечение становится текущим. Вид модели изменяется. Она отображается усеченной плоскостями данного сечения, т.е. включается режим сечения модели.

Если созданное сечение содержит шаги, параметры которых не заданы или заданы с ошибками, то после создания сечения на экране появляется сообщение со списком всех имеющихся в сечении ошибок.

В этом разделе:

2.15.5.2.1. Свободное размещение плоскости сечения

2.15.5.2.2. Смещенная плоскость сечения

2.15.5.2.3. Повернутая плоскость сечения

2.15.5.2.4. Сечение в виде параллелепипеда

2.15.5.2.5. Сечение по зоне


2.15.5.2.1. Свободное размещение плоскости сечения

Для свободного размещения плоскости сечения можно использовать элементы Панели свойств (см. рис. 2.15.9) или элемент базирования.

Размещение плоскости включает в себя указание положения опорной точки, определяющей положение плоскости в модели, и задание ориентации плоскости.

В окне модели отображается элемент базирования, который совпадает с опорной точкой. Он представляет собой аналог системы координат и состоит из трех объемных стрелок красного, зеленого и синего цветов, показывающих положение осей X, Y, Z элемента. В плоскостях, перпендикулярных стрелкам, отображаются дуги соответствующего цвета. Центральная точка элемента обозначается сферой или кубиком (кубик отображается в том случае, если опорная точка ассоциативно связана с объектом модели). Плоскость XY элемента совпадает с создаваемой плоскостью сечения. Положительное направление оси Z показывает направление отсечения.

Чтобы изменить положение опорной точки плоскости сечения, переместите данный элемент. Поворот элемента изменяет ориентацию плоскости в модели. Приемы перемещения, поворота и изменения размера элемента описаны в разделе 2.11.2.5.3.

Если опорная точка плоскости сечения имеет ассоциативную связь с объектом (центральная точка элемента обозначена кубиком), то произвольное перемещение элемента недоступно. Однако, вы можете отменить ассоциативную связь, переместив элемент вдоль оси.

Для задания положения опорной точки можно также использовать один из следующих способов.

– Указание точечного объекта в Дереве построения или в окне модели. При этом опорная точка ассоциативно связывается с данным объектом.

– Задание смещения по осям координат. Чтобы переместить плоскость вдоль нужной оси, в группе Смещение активизируйте переключатель, соответствующий этой оси.

• Смещение по оси Х,

• Смещение по оси Y,

• Смещение по оси Z.

На Панели свойств появится поле Смещение. Введите в это поле расстояние, на которое требуется сместить плоскость.

– Построение точки. При этом создается ассоциативная связь. Для выполнения построения нажмите кнопку Построение точки на Панели специального управления. Запустится процесс построения точки (см. раздел 2.5.2.11.1). Выберите способ построения и задайте необходимые параметры. Эти параметры будут определять положение опорной точки. Обратите внимание на то, что в данном случае процесс построения точки используется только для определения положения опорной точки. Новая точка при этом не создается. После завершения процесса построения точки система вернется в процесс создания сечения.

Панель свойств содержит поле Опорная точка. Это поле является информационным (недоступно для ввода). В зависимости от способа задания положения опорной точки в поле отображаются либо координаты опорной точки, либо имя объекта, с которым она ассоциативно связана. При изменении положения опорной точки содержимое поля автоматически изменяется.

Для задания ориентации плоскости используются следующие способы.

– Указание объекта, определяющего направление нормали плоскости сечения (нормаль совпадает с осью Z элемента базирования). Объект указывается в Дереве построения или в окне модели. Доступны объекты следующих типов:

• прямолинейный объект — нормаль параллельна объекту,

• плоский объект (в том числе эскиз и плоская кривая) — нормаль перпендикулярна плоскости объекта,

• поверхность вращения — нормаль параллельна оси вращения.

Сферу можно выбрать только в том случае, если опорная точка плоскости сечения принадлежит ей. В этом случае нормаль совпадает с перпендикуляром к сфере в опорной точке.

– Задание угла поворота плоскости сечения вокруг оси элемента базирования.

В группе Вращение активизируйте переключатель, соответствующий нужной оси:

• Вокруг оси Х,

• Вокруг оси Y,

• Вокруг оси Z.

На Панели свойств появится поле Угол. Введите в это поле нужное значение угла. Фантом плоскости сечения повернется вокруг выбранной оси на заданный угол.

– Построение вектора.

Нажмите кнопку Построение вектора на Панели специального управления. Запустится процесс построения вектора (см. раздел 2.8.5). Выберите способ построения и задайте необходимые параметры. В модели появится фантом вектора заданного направления. Завершите построение вектора. Система вернется в процесс создания сечения. Нормаль плоскости сечения будет параллельна вектору и сонаправлена ему.

Панель свойств содержит поле Направление нормали. Это поле является информационным (недоступно для ввода). В зависимости от способа задания направления нормали плоскости сечения в поле отображаются либо имя направляющего объекта, либо координаты вектора нормали. Если нормаль задана построением вектора, то в поле также отображается слово Вектор.

При изменении ориентации плоскости содержимое поля автоматически изменяется.


2.15.5.2.2. Смещенная плоскость сечения

При выборе способа размещения плоскости сечения Смещенная плоскость на Панели свойств появляются элементы, показанные на рис. 2.15.10.

Рис. 2.15.10. Способ Смещенная плоскость

Чтобы задать параметры размещения для данного способа, выполните следующие действия.

1. Выберите способ задания базовой плоскости. Для этого активизируйте один из следующих переключателей:

– Плоскость модели — в качестве базовой плоскости выбирается плоскость или плоская грань, имеющаяся в модели,

– Плоскость сечения предыдущего шага — в качестве базовой плоскости выбирается плоскость сечения, заданная на предыдущем шаге отсечения; вариант доступен, если текущий шаг не является первым шагом отсечения, и предыдущие шаги могут использоваться для задания базовой плоскости.

2. Выберите объект, который будет использоваться в качестве базовой плоскости:

– для варианта Плоскость модели — укажите плоский объект в Дереве построения или в окне модели; данный объект подсвечивается в окне модели, а его имя появляется в поле Базовая плоскость;

– для варианта Плоскость сечения предыдущего шага — выберите нужный шаг отсечения из раскрывающегося списка Выбор шага.

Список Выбор шага содержит все предыдущие шаги отсечения, созданные в текущем сечении модели, кроме:

– шагов, параметры которых заданы способом Параллелепипед (см. раздел 2.15.5.2.4) или Зона (см. раздел 2.15.5.2.5),

– шагов, в названии которых имеются символы (!).

После выбора объекта в окне модели появляется фантом плоскости сечения, совпадающий с базовой плоскостью. Выбранный плоский объект подсвечивается. Направление отсечения показывается синей стрелкой.

3. Задайте смещение плоскости сечения относительно базовой.

Для этого в поле Расстояние введите нужное значение смещения. Плоскость сместится на заданное расстояние.

Вы также можете сместить плоскость вручную. Для этого используется синяя стрелка, показывающая направление отсечения. Доступны следующие варианты смещения:

– на произвольное расстояние — «перетащите» стрелку мышью,

– на заданное расстояние — щелкните мышью по стрелке и введите значение смещения в появившемся поле.

При ручном смещении плоскости значение в поле Расстояние автоматически изменяется.


2.15.5.2.3. Повернутая плоскость сечения

При выборе способа размещения плоскости сечения Повернутая плоскость на Панели свойств появляются элементы, показанные на рис. 2.15.11.

Рис. 2.15.11. Способ Повернутая плоскость

Чтобы задать параметры размещения для данного способа, выполните следующие действия.

1. Выберите способ задания базовой плоскости и объект, который будет использоваться в качестве этой плоскости. Для этого выполните действия, описанные в п.п. 1 и 2 раздела 2.15.5.2.2.

2. Задайте ось, относительно которой требуется повернуть плоскость сечения. Для этого в Дереве построения или в окне модели укажите линейный объект (ребро или ось), лежащий в базовой плоскости или плоскости, параллельной ей.

В поле Ось появляется имя указанного объекта, а в окне модели — фантом плоскости сечения. Он проходит через выбранную ось параллельно базовой плоскости (или совпадает с ней). Направление отсечения показывается синей стрелкой, а плоскость вращения — дугой.

3. Задайте угол поворота плоскости вокруг выбранной оси.

Для этого введите значение угла поворота в поле Угол.

Вы также можете повернуть плоскость вручную. Для этого используется дуга, показывающая плоскость вращения. Доступны следующие варианты поворота:

– на произвольный угол — «перетащите» дугу мышью,

– на заданный угол — щелкните мышью по дуге и введите значение угла поворота в появившемся поле.

При ручном повороте плоскости сечения значение в поле Угол автоматически изменяется.


2.15.5.2.4. Сечение в виде параллелепипеда

Сечение модели может представлять собой параллелепипед. Отсекается та часть модели, которая находится за пределами параллелепипеда.

Для создания такого сечения используется способ Параллелепипед. При выборе этого способа на Панели свойств появляются элементы, показанные на рис. 2.15.12.

Рис. 2.15.12. Способ Параллелепипед

Чтобы задать параметры параллелепипеда, выполните следующие действия.

1. Выберите вариант задания параллелепипеда. Для этого в группе Вариант активизируйте один из следующих переключателей:

– По двум вершинам,

– По центру и вершине.

2. Задайте положение точек параллелепипеда.

Положение первой точки указывается при активном переключателе Точка 1, а положение второй — при активном переключателе Точка 2.

Координаты точки могут быть введены с клавиатуры или определены автоматически при указании положения точки мышью в окне модели или выборе точечного объекта. Эти действия аналогичны описанным в разделе 2.5.2.2.

Кроме того, для задания координат можно использовать процесс построения точки, который запускается после нажатия кнопки Построение точки на Панели специального управления (см. раздел 2.5.2.11.1). Параметры, заданные в данном процессе, определяют положение точки параллелепипеда. Новая точка при этом не создается.

После задания координат одной из точек параллелепипеда его фантом появляется в окне модели.


2.15.5.2.5. Сечение по зоне

Если в модели созданы зоны (см. раздел 2.15.15), то вы можете выбрать одну из них при задании параметров шага отсечения. Для этого используется способ Зона. При выборе зоны отсекается та часть модели, которая находится за ее пределами.

Нужная зона выбирается на вкладке Зоны Дерева модели. Фантом зоны отображается в окне модели, а ее имя — в поле Зона Панели свойств. Повторное указание зоны отменяет ее выбор.


2.15.5.3. Редактирование параметров сечения

Если требуется отредактировать параметры сечения модели, укажите это сечение в диалоге Сечения модели и нажмите кнопку Редактировать сечение (см. раздел 2.15.5.1).

В окне модели появится фантом плоскости сечения, а на Панели свойств — вкладки Параметры и Свойства. Набор элементов на вкладках такой же, как при создании сечения.

Вы можете отредактировать параметры нужного шага отсечения. Для этого укажите его на панели Шаг отсечения и выполните действия, описанные в разделе 2.15.5.2. Вы также можете добавить или удалить шаги отсечения.

При удалении и редактировании шагов отсечения, используемых для задания базовых плоскостей других шагов (см. разделы 2.15.5.2.2 и 2.15.5.2.3), имейте в виду следующее.

– При удалении шага, плоскость которого является базовой для другого шага, в качестве базовой будет использоваться плоскость шага, следующего за удаленным. Если такого шага нет, то автоматический перевыбор базовой плоскости невозможен. Шаг, базовая плоскость которого потеряна, становится ошибочным. В его названии появляются символы (!), а в списке Выбор шага — строка Ошибка. Если этот список содержит другие шаги, то он остается доступным для выбора шага. В противном случае список становится недоступным.

– Если плоскость Шага 1 используется в качестве базовой плоскости для Шага 2, построенного способом Повернутая плоскость, то при редактировании Шага 1 положение его плоскости должно оставаться параллельным оси поворота Шага 2. В противном случае Шаг 2 становится ошибочным. К его имени добавляются символы (!).

Символы (!) появляются в имени шага и в том случае, если его базовой плоскостью является плоскость модели, которая в результате редактирования стала непараллельной оси поворота.


2.15.6. Получение информации о модели и ее объектах

2.15. Сервисные функции

2.15.6. Получение информации о модели и ее объектах

При работе с моделью вы можете получить справочные сведения о ней самой, а также о любом ее объекте: ребре, грани, элементе, поверхности, компоненте и др. Для этого нажмите кнопку Информация об объекте на панели Измерения и диагностика (3D) или выберите ее название из меню Сервис.

Чтобы быстро получить информацию об объекте, подведите к нему курсор в окне модели. Рядом с курсором появляются символ объекта и базовые сведения об объекте (рис. 2.15.13).

Рис. 2.15.13. Быстрый просмотр информации о ребре

Щелкните по выбранному объекту левой кнопкой мыши.

На экране появляется Информационное окно.

Управление окном и команды его меню описаны в разделе 3.9.1.2.

По умолчанию в Информационном окне выдается краткая информация об объекте, т.е. только основные сведения (см. раздел 2.15.6.1). При необходимости вы можете получить также дополнительные сведения об объекте (см. раздел 2.15.6.2). Для этого отключите опцию Кратко на Панели свойств и укажите объект еще раз.

Объект или объекты, информацию о которых нужно получить, можно выбрать и до вызова команды.

Одни объекты можно указать только в Дереве, например, сборки, детали, элементы, эскизы, ломаные, другие — только в окне, например, ребра, грани, вершины, сегменты контура в эскизе, сегменты ломаной, третьи — и в Дереве, и в окне, например, начала координат, вспомогательные и конструктивные плоскости, точки, сплайны.

Если перед вызовом команды Информация об объекте в Дереве или в окне модели были выделены объекты, то Информационное окно появляется на экране сразу после вызова команды и содержит сведения об этих объектах.

В Информационном окне выдается краткая информация об объекте — основные сведения (см. раздел 2.15.6.1).

Компоненты модели следует указывать в Дереве построения.

Для просмотра информации о другом объекте подведите к нему курсор. При щелчке мышью на объекте сведения о нем будут добавлены в Информационное окно.

На Панели свойств можно задать точность вычислений, единицы измерения длины и угла. Изменение этих параметров немедленно отражается в Информационном окне.

Для завершения команды получения информации нажмите кнопку Прервать команду на Панели специального управления или закройте Информационное окно.

В этом разделе:

2.15.6.1. Основные сведения

2.15.6.2. Дополнительные сведения


2.15.6.1. Основные сведения

Основные сведения об объекте:

– Номер измерения.

– Название объекта.

– Тип объекта. Сведения о типе объекта берутся из математического описания объекта. Например:

• ребро может иметь тип прямая, дуга окружности, сплайн и др.;

• грань или поверхность может иметь тип плоская, тороидальная, линейчатая поверхность, сплайновая поверхность и др.

Некоторые объекты, например, точка или элемент, не имеют типа.

– Числовые параметры объекта. Набор параметров зависит от объекта:

• для объектов, представляющих собой разновидность кривой (ребро, пространственная кривая, линия эскиза и др.), определяется длина,

• для цилиндрических, сферических и круглых объектов (поверхность скругления, ребра и контуры в виде окружностей/дуг окружностей и др.) определяется радиус и диаметр,

• для точек выводятся координаты,

• для плоских граней выводятся координаты нормального вектора и т.д.

В числе параметров объекта отображаются также имена и значения переменных этого объекта.

Для деталей и сборок указываются значения некоторых системных свойств (имя файла, дата создания и др.; о системных свойствах см. раздел 5.1.3.1), для сборок также указываются общие данные о количестве компонентов первого уровня, сопряжений и элементов.

Компоненты первого уровня — детали и подсборки, непосредственно входящие в текущую модель. Компоненты, входящие в подсборки (а также в подсборки подсборок и так далее), не являются компонентами первого уровня для текущей модели.

– Если в Дереве отображается последовательность построения модели, то компоненты первого уровня размещаются на первом уровне Дерева.

– Если в Дереве отображается структура модели, то компоненты первого уровня размещаются на первом уровне раздела «Компоненты».


2.15.6.2. Дополнительные сведения

Дополнительные сведения об объекте:

– Цвет и оптические свойства объекта.

– Отношения в виде перечней исходных и производных объектов.

– Для граней: параметры ограничивающих их ребер, для ребер: параметры конечных вершин.

– Для исполнения (т.е. объекта Дерева исполнений): номера исходных и производных исполнений.

– Для сборок: количество компонентов всех уровней, т.е. сумма компонентов первого уровня и остальных компонентов.


2.15.7. Разнесение компонентов сборки

2.15. Сервисные функции

2.15.7. Разнесение компонентов сборки

Иногда сборку требуется увидеть в «разобранном» виде (так, чтобы были видны все ее компоненты).

Перед разнесением компонентов требуется установить параметры разнесения: выбрать компоненты, а также направление и величину их перемещения.

Чтобы задать параметры разнесения, вызовите команду Сервис —Разнести компоненты — Параметры.

Один и тот же компонент может участвовать в нескольких шагах разнесения.

В одном шаге разнесения могут участвовать несколько компонентов.

Компонент, входящий в подсборку (на любом уровне вложенности), может участвовать в шаге разнесения независимо от других компонентов этой подсборки.

Рис. 2.15.14. Задание параметров разнесения компонентов

На Панели свойств (рис. 2.15.14) отображается список шагов разнесения компонентов.

Если настройка параметров разнесения текущей сборки еще не производилась, то список пуст.

Чтобы добавить шаг разнесения, нажмите кнопку Добавить.

Затем укажите компоненты, участвующие в шаге разнесения, и параметры этого шага:

1. Чтобы выбрать компоненты, активизируйте переключатель Компоненты и укажите нужные объекты.

2. Чтобы указать направление разнесения компонентов, активизируйте переключатель Объект. Компоненты могут разноситься в направлении, совпадающем с ребром модели (для этого укажите в окне сборки нужное ребро) или в направлении, перпендикулярном грани (для этого укажите нужную грань).

3. Введите в соответствующее поле Расстояние, на которое должен переместиться компонент относительно своего прежнего положения.

4. Выберите направление перемещения компонентов — Прямое или Обратное, активизировав соответствующий переключатель в группе Направление.

После задания параметров шага разнесения компонентов нажмите кнопку Применить. Выбранные компоненты будут разнесены в соответствии с установленными параметрами.

Если полученное разнесение компонентов отличается от ожидаемого, отредактируйте параметры разнесения.

Аналогичным образом задайте требуемое количество шагов разнесения и настройте их параметры.

Чтобы удалить шаг или компонент из списка, нажмите кнопку Удалить в верхней части этого списка.

Закончив настройку шагов разнесения, нажмите кнопку Прервать команду на Панели специального управления.

После выхода из команды настройки шагов сборка в окне оказывается в разнесенном виде.

Чтобы включить режим обычного отображения сборки, вызовите команду Сервис — Разнести компоненты — Разнести. Кнопка для вызова команды находится на панели Режимы. Эта команда служит переключателем режима разнесения и обычного отображения сборки. Когда компоненты разнесены, кнопка нажата, а к имени документа в заголовке окна добавляются слова «Разнесенный вид» в круглых скобках. В окне документа появляется значок режима, свидетельствующий о том, что сборка отображается в разнесенном виде. Щелчок мышью по значку позволяет выйти из режима разнесения.

Когда компоненты сборки разнесены, недоступны все команды редактирования сборки (в том числе команда Редактировать в окне), команды создания пространственных кривых, поверхностей, вспомогательных объектов, элементов оформления, команды наложения сопряжений и команды работы со спецификацией.

Подсборка не может быть отображена в окне сборки в разнесенном виде.


2.15.8. Трехмерный макроэлемент

2.15. Сервисные функции

2.15.8. Трехмерный макроэлемент

Трехмерный макроэлемент — группа объектов модели. Логическое группирование объектов путем объединения их в макроэлементы позволяет представить Дерево построения в более компактном виде. Это упрощает ориентацию в Дереве, особенно при работе со сложными моделями, содержащими много объектов.

В макроэлементы целесообразно объединять объекты, имеющие общее функциональное или конструктивное назначение.

Объекты, включенные в макроэлемент, отображаются в Дереве построения как подчиненные объекты этого макроэлемента и отмечаются пиктограммами-папками. Порядок работы с ними такой же, как с объектами, не входящими в макроэлементы: их можно редактировать, исключать из расчета, удалять и т.д. Кроме того, объекты, входящие в макроэлемент, могут участвовать в операциях (например, копирования).

Трехмерные макроэлементы могут быть вложенными друг в друга. Количество уровней вложенности не ограничено. Другими словами, вы можете включать в макроэлемент:

– несколько уже существующих макроэлементов,

– объекты, принадлежащие любому из существующих макроэлементов.

На рисунке 2.15.15 в качестве примера показан макроэлемент Проушина. Он содержит следующие объекты: проушину с внешней и внутренней бобышками и отверстием и отверстия под винты. Бобышки и отверстия под винты, в свою очередь, объединены в одноименные макроэлементы, подчиненные макроэлементу Проушина.

Рис. 2.15.15. Макроэлемент Проушина: а) отображение в Дереве построения, б) объекты модели, входящие в макроэлемент (выделены)
а) | б)

При выделении в Дереве построения пиктограммы макроэлемента в окне модели подсвечиваются все объекты, входящие в этот макроэлемент.

В этом разделе:

2.15.8.1. Создание трехмерного макроэлемента

2.15.8.2. Управление показом состава макроэлемента

2.15.8.3. Изменение состава макроэлемента

2.15.8.4. Разрушение макроэлемента

2.15.8.5. Удаление макроэлемента


2.15.8.1. Создание трехмерного макроэлемента

Чтобы создать в модели новый макроэлемент, вызовите команду Сервис — Создать макроэлемент.

Внизу Дереве построения появится макроэлемент, не содержащий ни одного объекта. Вы можете добавить в него объекты модели (см. раздел 2.15.8.3).

Чтобы объединить в макроэлемент несколько существующих объектов, выделите их в Дереве построения и вызовите команду Объединить в макроэлемент из контекстного меню или из меню Сервис.

Макроэлемент, содержащий указанные объекты, появится на месте самого нижнего из включенных в этот макроэлемент объектов. Пиктограммы объектов разместятся на уровне, следующем за уровнем макроэлемента. Порядок расположения объектов в макроэлементе совпадает с порядком их расположения в Дереве перед созданием макроэлемента.

Если в Дереве отображается последовательность построения модели (см. раздел 2.1.2.1), то все макроэлементы находятся в разделе Макро.

Обратите внимание на то, что объединить в макроэлемент можно только такие объекты, которые входят в состав одного и того же «родительского» объекта и располагаются на одном и том же уровне, за исключением:

– сгибов в составе листового элемента (например, сгибов, составляющих подсечку),

– экземпляров массива.

Таким образом, невозможно объединить в макроэлемент объекты, принадлежащие:

– разным компонентам модели,

– макроэлементу и всей модели,

– компоненту модели и всей модели и т.п.


2.15.8.2. Управление показом состава макроэлемента

Доступны два способа отображения макроэлемента в Дереве построения:

– с показом состава,

– без показа состава.

Если показ состава включен, то рядом с пиктограммой макроэлемента в Дереве отображается значок «+». Щелчок мышью на этом значке (после которого он отображается как «-») разворачивает список объектов, входящих в состав макроэлемента.

Рис. 2.15.16.

Если показ состава выключен, то значок «+» у пиктограммы макроэлемента отсутствует. Просмотр состава такого макроэлемента в Дереве построения невозможен.

Рис. 2.15.17.

Способ отображения макроэлемента в Дереве никак не влияет на отображение составляющих его объектов в окне модели.

По умолчанию показ состава вновь созданного макроэлемента включен.

Чтобы выключить показ состава макроэлемента, выделите его в Дереве построения и вызовите из контекстного меню команду Скрыть состав. Чтобы вернуть отображение состава, следует вызвать из контекстного меню макроэлемента команду Показать состав. Если выделены несколько макроэлементов с различной настройкой отображения, то в контекстном меню доступны обе команды.


2.15.8.3. Изменение состава макроэлемента

После того как макроэлемент создан, его состав можно изменить, «перетаскивая» объекты мышью в Дереве построения.

– Чтобы добавить объект в макроэлемент, «перетащите» пиктограмму объекта на пиктограмму макроэлемента.

Когда форма курсора изменится, «отпустите» объект. Он будет добавлен в состав выбранного макроэлемента. Если объект размещался в Дереве построения выше макроэлемента, то положение макроэлемента после добавления этого объекта не изменяется. В противном случае макроэлемент перемещается в Дереве построения на место добавленного объекта.

– Чтобы исключить объект из макроэлемента, разверните его состав (для этого необходимо, чтобы показ состава макроэлемента был включен, см. раздел 2.15.8.2). «Перетащите» пиктограмму объекта в Дереве за пределы макроэлемента.

Когда форма курсора изменится, «отпустите» объект. Он будет исключен из макроэлемента и появится в том месте Дереве построения, где находился до включения в макроэлемент.

– Чтобы переместить объект из макроэлемента в конкретное место Дереве построения, «перетащите» объект к этому месту. Когда курсор примет вид стрелки, «отпустите» объект. Если курсор не превращается в стрелку, это означает, что перемещаемый объект не может занимать указанное положение в иерархии объектов модели.

Начало координат невозможно включить в макроэлемент или исключить из него при помощи мыши. Для этого необходимо пользоваться командами Объединить в макроэлемент и Разрушить макроэлемент соответственно.

С помощью мыши возможно также перемещение объектов между макроэлементами.


2.15.8.4. Разрушение макроэлемента

Разрушение макроэлемента — операция, обратная его созданию.

После разрушения макроэлемента его пиктограмма удаляется из Дереве построения, а составлявшие его элементы возвращаются на свои места.

Макроэлементы, входящие в состав разрушаемого, сохраняются.

Чтобы разрушить макроэлемент (макроэлементы), выделите его и вызовите команду Разрушить макроэлемент из контекстного меню или из меню Сервис.


2.15.8.5. Удаление макроэлемента

Удаление макроэлемента означает удаление его самого и объектов, входящих в его состав.

Чтобы удалить макроэлемент (макроэлементы), выделите его и вызовите команду Удалить из контекстного меню или из меню Редактор.

После этого на экране появится диалог удаления объектов. В нем перечислены все объекты, входящие в удаляемый макроэлемент. Вы можете подтвердить удаление или отказаться от него.


2.15.9. Удаление истории построения модели

2.15. Сервисные функции

2.15.9. Удаление истории построения модели

При необходимости вы можете удалить из файла модели информацию о способах создания объектов и связях между ними. В результате внешний вид модели и ее массо-центровочные характеристики не меняются, но становится невозможным проследить, как была создана модель, и отредактировать параметры ее объектов.

Историю построения можно удалить, когда она больше не требуется, например, если проектирование модели завершено. После удаления истории построения модель перестраивается быстрее, размер файла модели уменьшается.

Команда Удалить историю построения находится в меню Редактор. После вызова команды на экране появляется диалог Параметры удаления истории построения, позволяющий задать параметры преобразования модели при удалении истории ее построения. Работа в диалоге аналогична описанной в разделе 2.14.5.1.

После удаления истории модель можно редактировать обычным образом: удалять и редактировать (доступными способами) существующие объекты и создавать новые. При необходимости удаление истории построения можно выполнить повторно.

До закрытия файла модели вы можете отменить удаление истории построения. Отменяются все преобразования, кроме изменения МЦХ и преобразования компонентов в детали-заготовки.

Чтобы восстановить исходное состояние модели, закройте ее без сохранения.

В моделях с исполнениями удаление истории построения недоступно. При необходимости вы можете сохранить исполнения как отдельные модели (см. раздел 2.13.3.7) и удалить их истории построения.


2.15.10. Создание чертежа текущей модели

2.15. Сервисные функции

2.15.10. Создание чертежа текущей модели

Вы можете создать чертеж с ассоциативным видом модели (детали или сборки) непосредственно при работе с этой моделью.

Документ-модель должен быть сохранен в файл на диске.

Чтобы перейти к созданию чертежа, вызовите команду Операции — Создать новый чертеж из модели.

После этого автоматически создается новый чертеж, а в нем — Произвольный ассоциативный вид. При этом в качестве модели, изображаемой в виде, уже выбрана текущая трехмерная модель. Остальные параметры вида — умолчательные (ориентация — спереди, цвет — черный, масштаб — 1:1 и т.д.). Если необходимо, измените параметры.

Затем укажите положение базовой точки вида.

В чертеже будет создан произвольный вид, изображающий текущую модель.

Дальнейшая работа с чертежом — создание других ассоциативных видов, оформление и т.п. ведется так же, как и с чертежом, созданным обычным способом.


2.15.11. Технические требования

2.15. Сервисные функции

2.15.11. Технические требования

Технические требования представляют собой текст, являющийся частью конструкторского документа. Они дополняют графическую информацию и позволяют изготовить изделие в точном соответствии с замыслом конструктора.

В документе-модели технические требования задаются и отображаются в специальном окне (см. раздел 2.15.11.2). Вы можете передать их в ассоциативный чертеж по модели или сохранить в отдельный документ, а также вывести на печать.

После передачи в чертеж технические требования становятся его частью и могут в нем произвольно редактироваться и перемещаться (см. раздел 3.6.7). Одновременно с этим между техническими требованиями в модели и чертеже поддерживается связь: по желанию пользователя изменения технических требований в модели могут быть переданы в чертеж (см. раздел 3.7.3.9).

В этом разделе:

2.15.11.1. Ввод и удаление технических требований в модели

2.15.11.2. Окно Технические требования

2.15.11.3. Печать технических требований из модели


2.15.11.1. Ввод и удаление технических требований в модели

Чтобы ввести технические требования, вызовите команду Технические требования из меню Вид или из контекстного меню в окне модели. На экране появляется окно Технические требования. Введите текст в окне (см. раздел 2.15.11.2).

Чтобы удалить технические требования из модели, удалите их текст в окне Технические требования.

Технические требования компонентов не отображаются в содержащей их модели. Просмотреть или изменить технические требования компонента можно в режиме его редактирования в окне или на месте.


2.15.11.2. Окно Технические требования

Работа с техническими требования в модели производится в окне Технические требования.

Для включения и отключения окна служит команда Вид —Технические требования.

В окне отображаются технические требования, если они заданы в модели. В верхней части окна находится меню команд для работы с ними.

Рис. 2.15.18. Окно Технические требования

В окне Технические требования вы можете выполнять следующие действия:

– вводить и редактировать текст,

– вставлять специальные объекты и форматировать текст — при помощи команд из меню Вставка и Формат,

– форматировать текст — при помощи команд из меню Формат,

– сохранять текст в отдельный текстовый файл (*.txt) или текстовый документ КОМПАС-3D (*.kdw) — при помощи команды Сохранить в документ из меню Файл,

– выводить текст на печать — при помощи команды Печать из меню Файл.

Также вы можете редактировать текст в окне режима работы с техническими требованиями. Для этого вызовите команду Редактор — Редактировать в окне из меню окна Технические требования. На экране появляется окно, в котором отображаются технические требования модели в режиме редактирования в этом окне.

В данном режиме доступны такие же элементы управления, как при работе с техническими требованиями, вводимыми в чертеже (см. раздел 3.6.7.1.1). Вы можете редактировать текст, вставлять блоки готового текста, проверять орфографию на разных языках и т.п.

В режиме работы с техническими требованиями текст показан в том виде, какой он будет иметь при выводе на печать. Длина строки соответствует ширине листа бумаги при печати. О печати технических требований см. раздел 2.15.11.3.

Настройка умолчательных параметров текста выполняется для новых документов (см раздел 9.2.7.9). В текущем документе настройка производится непосредственно при работе с техническими требованиями. В чертеж параметры текста, заданные в модели, не передаются.

Для выхода из режима работы с техническими требованиями служат специальные команды сохранения и закрытия, находящиеся в меню Файл (см. табл. 3.6.11).

Чтобы закрыть окно режима и вернуться в окно модели, можно также нажать системную кнопку Закрыть в правом верхнем углу окна или щелкнуть мышью по значку режима редактирования технических требований.


2.15.11.3. Печать технических требований из модели

Технические требования из модели печатаются на листах без оформления. Их можно вывести на печать следующими способами.

– Для печати технических требований вместе с изображением модели служит команда Предварительный просмотр. Она позволяет настроить параметры в режиме предварительного просмотра и напечатать документ (см. раздел 8.3.1). Технические требования представлены в предварительном просмотре отдельными листами. Вы можете настроить их масштаб и другие параметры печати.

– Для печати технических требований без модели можно использовать команду Печать, вызываемую из окна Технические требования или окна режима работы с техническими требованиями (см. раздел 2.15.11.2).


2.15.12. Неуказанная шероховатость

2.15. Сервисные функции

2.15.12. Неуказанная шероховатость

Модель может содержать обозначение неуказанной шероховатости. Обозначение включает в себя знак, параметр шероховатости и его значение, при необходимости — знак в скобках. Знак и параметр являются системными свойствами документа-модели (о свойствах см. раздел 5.1.3.1).

Для управления отображением неуказанной шероховатости в окне модели служит команда Вид — Неуказанная шероховатость. Если параметры неуказанной шероховатости не заданы, она отображается с умолчательными параметрами. Умолчательное местоположение знака — в правом верхнем углу окна модели.

О редактировании параметров неуказанной шероховатости см. раздел 2.15.12.1.

Неуказанная шероховатость передается в исполнения модели. В независимом исполнении ее можно редактировать. В зависимом исполнении параметры неуказанной шероховатости не редактируются — они изменяются только при изменении параметров шероховатости в основном исполнении. Эту связь можно разрушить, вызвав команду Разрушить связь из контекстного меню знака неуказанной шероховатости.

Неуказанная шероховатость передается в ассоциативный чертеж. После передачи в чертеж она становится его частью и может в нем произвольно редактироваться и перемещаться. Возможна синхронизация данных неуказанной шероховатости в модели и чертеже (см. раздел 3.7.3.10).

Настройка параметров текста неуказанной шероховатости для текущей модели выполняется в диалоге, вызываемом командой Сервис — Параметры — Текущая модель — Неуказанная шероховатость.

В этом разделе:

2.15.12.1. Редактирование и удаление знака неуказанной шероховатости


2.15.12.1. Редактирование и удаление знака неуказанной шероховатости

Чтобы отредактировать параметры знака неуказанной шероховатости, вызовите из контекстного меню знака команду Редактировать неуказанную шероховатость. На Панели свойств появятся вкладки Знак и Свойства. Элементы управления вкладки Знак позволяют настроить параметры неуказанной шероховатости (см. табл. 2.15.4). На вкладке Свойства можно изменить цвет знака.

Табл. 2.15.4. Элементы управления для редактирования знака неуказанной шероховатости
Элемент | Описание
Тип | Группа опций, позволяющая выбрать тип знака шероховатости: без указания вида обработки, с удалением слоя материала или без удаления слоя материала.
Текст | Текст надписи. Он может быть введен с клавиатуры или выбран из пользовательского меню. Вызов пользовательского меню осуществляется двойным щелчком в заполняемом поле.
Добавить знак в скобках | Опция, управляющая отрисовкой знака в скобках.

Чтобы завершить настройку, нажмите кнопку Создать объект.

Параметры неуказанной шероховатости можно задать в окне Свойства, см. раздел 2.14.3.6.1.

Чтобы изменить положение неуказанной шероховатости в окне документа, вызовите нужную команду из подменю команды Размещение контекстного меню знака.

Чтобы удалить неуказанную шероховатость, вызовите из контекстного меню знака команду Удалить неуказанную шероховатость или команду Редактор — Удалить — Неуказанную шероховатость.


2.15.13. Пароль на доступ к модели

2.15. Сервисные функции

2.15.13. Пароль на доступ к модели

Доступ к модели можно защитить паролем. После этого загрузка модели для просмотра или редактирования будет возможна только при условии ввода правильного пароля.

Защита модели сборки (*.a3d) осуществляется путем ввода пароля на тип (типы) загрузки сборки. О типах загрузки сборки см. раздел 2.12.2.2, о паролях типов загрузки — раздел 2.12.2.3.

Защита модели детали (*.m3d) осуществляется путем ввода пароля непосредственно на доступ к модели. Для этого выполните следующие действия:

1. Выделите корневой элемент (т.е. саму деталь) в Дереве построения.

2. Вызовите из контекстного меню команду Доступ.

3. В появившемся диалоге Доступ к модели введите пароль и, если нужно, комментарий. Закройте диалог кнопкой ОК.

4. В следующем диалоге введите пароль еще раз и закройте этот диалог кнопкой ОК.

5. Сохраните файл модели.

Пароль на доступ к детали, если он установлен, запрашивается в следующих случаях:

– открытие файла детали;

– вставка детали в другую модель в качестве компонента;

– попытка перейти к редактированию:

• детали — компонента модели (с помощью команд Редактировать в окне и Редактировать на месте);

• детали-заготовки (с помощью команды Редактировать источник);

• детали — источника изображения в ассоциативном виде (с помощью команды Редактировать в окне).

Во всех перечисленных случаях на экране появляется диалог, показанный на рисунке 2.15.19. Для загрузки модели необходимо ввести пароль в одноименном поле. При необходимости можно выбрать вариант доступа: редактирование или только чтение.

Рис. 2.15.19. Диалог запроса пароля на доступ к модели детали

Смена и удаление пароля осуществляется аналогично назначению пароля: для смены пароля в диалоге Доступ к модели нужно ввести новый пароль, а для удаления пароля — удалить все символы пароля. После смены или удаления пароля файл модели следует сохранить.


2.15.14. Слои в модели

2.15. Сервисные функции

2.15.14. Слои в модели

Слой — логическая группа объектов документа. Разбиение на слои упрощает изменение свойств группы объектов. Так, для всех объектов, лежащих на одном слое, можно одновременно изменить цвет, включить/отключить показ на экране, передачу в ассоциативный вид и т.п.

В модели всегда есть системный слой и, если пользователь не создавал других слоев, все объекты размещаются на системном слое.

Всего в модели может быть создано до 2 147 483 647 слоев. Выбор объектов для размещения на том или ином слое осуществляется пользователем. Например, на отдельные слои можно поместить вспомогательные объекты, размеры, крепеж и т.п. Слой может содержать объекты любого типа, в том числе объекты из различных исполнений, но один и тот же объект не может принадлежать разным слоям.

Чтобы узнать, на каком слое находится тот или иной объект, выделите его в Дереве построения или в окне модели и вызовите из контекстного меню команду Слой объекта. Слой выбранного объекта будет отмечен «галочкой» в списке слоев (см. рис. 2.15.23).

Компоненты модели размещаются на слоях целиком, т.е. вместе со всеми входящими в них объектами. При этом распределение по слоям доступно только для компонентов первого уровня.

В этом разделе:

2.15.14.1. Состояние слоев

2.15.14.2. Слои в Менеджере документа-модели

2.15.14.3. Создание слоя в модели

2.15.14.4. Переключение между слоями

2.15.14.5. Выделение слоя в модели

2.15.14.6. Перенос объектов модели между слоями

2.15.14.7. Удаление слоя из модели

2.15.14.8. Группы и фильтры слоев в модели


2.15.14.1. Состояние слоев

Состояние слоя определяется значениями следующих свойств:

– Видимость — свойство управляет отображением объектов слоя на экране и имеет два значения: видимый и погашенный. Если слой видимый, то его объекты отображаются на экране.

– Цвет — свойство управляет цветом отображения объектов слоя на экране. Цвет слоя назначается в стандартном диалоге выбора цвета.

– Оптические свойства — свойство управляет оптическими свойствами объектов слоя. Оптические свойства слоя задаются в диалоге Оптические свойства.

– Редактируемость — свойство управляет возможностью редактирования объектов слоя и имеет два значения: разрешено или запрещено.

– Проецируемость в чертеж — свойство управляет возможностью проецирования слоя и его объектов в ассоциативный чертежи имеет два значения: разрешено или запрещено.

Чтобы значение свойства слоя передавалось свойству объекта, свойство объекта должно иметь значение По слою. Например, объект лежит на Слое 1. Чтобы объект был скрыт, когда Слой 1 погашен, и отображался, когда Слой 1 видимый, требуется, чтобы свойство Видимость объекта имело значение По слою. Управление свойствами объектов производится в Окне Свойства (см. раздел 2.14.3.6.1).

Среди всех слоев в модели только один имеет статус текущий. Именно в текущий слой записываются все новые объекты.

Текущим можно сделать любой слой. При этом он автоматически становится видимым. Пока слой является текущим, погасить его невозможно.

Для редактирования объектов состояние и статус слоя не имеют значения. Если слой объекта погашен, то этот объект можно выделить для редактирования в Дереве построения. После редактирования объекта состояние и статус слоя остаются без изменения.

При необходимости объекты модели можно перенести с их слоев на любой другой слой (см. раздел 2.15.14.6).

Доступность и результат работы команды Скрыть/Показать для объекта не зависит от состояния слоя, на котором этот объект находится. Однако, следует иметь в виду, что если свойство Видимость объекта имело значение По слою, то после вызова команды Скрыть оно получает значение Скрытый (соответственно, после вызова команды Показать — значение Видимый).


2.15.14.2. Слои в Менеджере документа-модели

Работа со слоями в модели производится в Менеджере документа. Он позволяет выполнять следующие действия:

– создание и удаление слоев,

– выбор текущего слоя,

– изменение значений свойств слоев.

Чтобы открыть Менеджер документа, выполните одно из следующих действий:

– вызовите команду Сервис — Менеджер документа...,

– нажмите кнопку Менеджер документа на панели Стандартная,

– нажмите кнопку Управление слоями на панели Текущее состояние.

На экране появляется диалог Менеджер документа для работы со слоями (рис. 2.15.20).

Рис. 2.15.20. Управление слоями в Менеджере документа-модели

В левой части диалога отображается Дерево элементов документа. Если диалог вызван указанными выше командами, в Дереве активен элемент Слои. При этом в правой части диалога отображается перечень созданных в документе слоев и инструментальная панель, позволяющая выполнять различные действия с ними.

Список слоев содержит имена слоев, созданных в текущей модели.

В колонках Списка слоев в виде пиктограмм отображаются значения свойств:

– статус;

– видимость:

• видимый слой,

• погашенный слой,

– цвет;

– оптические свойства;

– редактируемость:

• разрешить редактирование,

• запретить редактирование,

– проецируемость в ассоциативный чертеж:

• проецировать в чертеж,

• не проецировать в чертеж.

Текущий слой дополнительно отмечается красной «галочкой» в колонке Статус.

Пиктограмма пустого слоя отличается от пиктограммы слоя с объектами цветом контура: в первом случае он серый, во втором синий.

Щелчок мыши по значению свойства в полях Статус, Видимость, Редактирование и Проецирование в чертеж изменяет его на противоположное. Щелчок в поле Имя позволяет изменить значение этого поля. Изменить наименование объекта можно также, вызвав команду Переименовать из его контекстного меню. Щелчок в поле Цвет позволяет назначить слою цвет в стандартном диалоге выбора цвета. Оптические свойства слоя можно изменить, щелкнув мышью в поле Оптические свойства.

Вы можете одинаковым образом изменить состояния сразу нескольких слоев. Для этого выделите их, затем нажмите нужную кнопку на инструментальной панели Менеджера документа или вызовите команду контекстного меню.

Для текущего слоя нельзя изменить значения свойств видимость и редактируемость.

Объекты, расположенные в Списке, могут быть отсортированы по любому из столбцов. Чтобы выбрать столбец для сортировки, щелкните по его названию. Рядом с названием появится треугольник. Он показывает направление сортировки. Если вершина треугольника направлена вниз, то сортировка списка производится по убыванию значений в этом столбце, а если вверх — то по возрастанию.

Инструментальная панель расположена в верхней части диалога Менеджер документа. Назначение ее кнопок описано в таблице 2.15.5.

Табл. 2.15.5. Инструментальная панель Менеджера документа
Кнопка | Позволяет
Создать слой | Создать новый слой.
Создать группу | Создать группу слоев.
Создать фильтр | Создать фильтр слоев.
Удалить | Удалить выделенные слои. Удаление слоя означает удаление всех расположенных на нем объектов. Поэтому при попытке удалить непустой слой на экране появляется диалог удаления объектов. Вы можете подтвердить удаление слоя вместе со всеми его объектами или отказаться от удаления.
Сделать текущим | Сделать выделенный слой текущим.
Видимый | Сделать выделенные слои видимыми.
Погашенный | Сделать выделенные слои погашенными, т.е. невидимыми.
Цвет | Изменить цвет выделенных слоев. Цвет слоя назначается в стандартном диалоге выбора цвета.
Оптические свойства слоя | Изменить оптические свойства выделенных слоев. Оптические свойства назначаются в диалоге Оптические свойства.
Разрешить редактирование | Сделать выделенные слои редактируемыми.
Запретить редактирование | Сделать выделенные слои нередактируемыми.
Проецировать в чертеж | Сделать выделенные слои проецируемыми в ассоциативный чертеж.
Не проецировать в чертеж | Сделать выделенные слои непроецируемыми в ассоциативный чертеж.

Поле Область поиска находится ниже Дерева элементов. Это поле позволяет выполнить поиск слоя по имени или номеру.

Чтобы начать поиск, следует ввести в поле строку текста. При этом можно использовать маски. В масках знак «*» заменяет любое количество любых символов. Знак «?» заменяет один любой символ. В Списке слоев будут показаны слои, имена или номера которых совпадают с заданной строкой. Содержание области поиска не сохраняется в документе.


2.15.14.3. Создание слоя в модели

Чтобы создать новый слой в модели, выполните следующие действия.

1. Откройте Менеджер документа любым способом (см. раздел 2.15.14.2). Например, нажмите кнопку Управление слоями на панели Текущее состояние.

2. Нажмите кнопку Создать слой на инструментальной панели диалога Менеджер документа.

В Списке слоев появится новый слой. В поле имени слоя будет находиться текстовый курсор. Вы можете изменить умолчательное имя, а также ввести комментарий к слою.

По умолчанию новому слою присваивается первый свободный номер.

3. Задайте состояние слоя:

– видимость,

– цвет,

– оптические свойства,

– редактируемость,

– проецируемость в ассоциативный чертеж.

Обратите внимание на то, что после создания нового слоя текущим остается тот же слой, что и до создания. Если требуется, чтобы текущим был новый слой, нажмите кнопку Сделать текущим или щелкните мышью в ячейке Статус. На пиктограмме слоя появится красная «галочка», показывающая, что слой является текущим.

4. После ввода всех параметров нового слоя нажмите кнопку ОК Менеджера документа.


2.15.14.4. Переключение между слоями

Имя текущего слоя отображается в поле Управление слоями на панели Текущее состояние.

Поле Управление слоями присутствует на Панели, если она расположена горизонтально.

Вы можете сделать любой слой текущим, а также включить/выключить видимость и изменить другие свойства слоев при помощи Менеджера документа (см. раздел 2.15.14.2).

Однако наиболее удобным является следующий способ. Выберите или введите с клавиатуры имя нужного слоя в поле Управление слоями на панели Текущее состояние и он станет текущим (рис. 2.15.21).

Рис. 2.15.21. Переключение между слоями на панели Текущее состояние

Объекты слоя, выделенного в списке, подсвечиваются в Дереве построения и в окне модели. Значки перед именами слоев в списке показывают значения свойств: редактируемость, видимость, цвет и проецируемость в ассоциативный чертеж. Щелчок мыши по значкам этих свойств меняет их значение на противоположное. Исключение составляет свойство цвет, значение которого изменить нельзя. При этом следует помнить, что для текущего слоя можно изменить только значение свойства проецируемость в ассоциативный чертеж.


2.15.14.5. Выделение слоя в модели

Для выделения в модели объектов, принадлежащих какому-либо определенному слою или слоям, вызовите команду Выделить — По слою. На экране появляется подменю с командами Указанием и Выбором.... Эти команды аналогичны одноименным командам в графическом документе, см. таблицу 3.6.10.


2.15.14.6. Перенос объектов модели между слоями

Для переноса объектов на тот или иной слой служит команда Сервис — Изменить слой. Команда также может быть вызвана из контекстного меню.

После вызова команды на Панели свойств появляются элементы управления, позволяющие задать параметры изменения слоя.

Укажите объекты, которые требуется перенести на другой слой. Могут быть указаны компоненты, тела, поверхности, кривые, точки, размеры, обозначения, эскизы, локальные системы координат и другие. Исключение составляют оси и плоскости абсолютной системы координат — они могут находиться только на системном слое.

Операции не являются объектами, которые могут переноситься на слои отдельно от содержащих их тел.

Указанные объекты подсвечиваются в модели. Имена объектов и их слоев отображаются на панели Список объектов (рис. 2.15.22).

Чтобы удалить объект из списка, выделите строку и нажмите кнопку Удалить над списком. Повторное указание объекта в модели также отменяет его выбор.

Объекты могут быть выделены до вызова команды.

Рис. 2.15.22. Перенос объектов на другой слой

На панели Слой укажите слой, на который требуется поместить выбранные объекты. Для этого щелкните мышью по строке c именем слоя.

Чтобы создать новый слой, нажмите кнопку Создать новый слой над списком.

После того как объекты указаны, нажмите кнопку Создать объект для переноса их на выбранный слой.

Также вы можете изменить слой одного объекта следующим способом. Вызовите из его контекстного меню команду Слой объекта. Меню команды содержит названия имеющихся в модели слоев, «галочкой» отмечен слой текущего объекта. Чтобы его сменить, укажите в меню нужный слой (рис. 2.15.23).

Рис. 2.15.23. Выбор слоя из меню команды Слой объекта

Значение свойства объекта, находящегося на слое, будет совпадать со значением свойства слоя, если свойству объекта задано значение По слою в Окне Свойства (см. раздел 1.4.2.2).


2.15.14.7. Удаление слоя из модели

Вы можете удалить слой из документа. Объекты, расположенные на слое, также будут удалены.

Для удаления слоя выполните следующие действия.

1. Откройте Менеджер документа любым способом (см. раздел 2.15.14.2). Например, нажмите кнопку Управление слоями на панели Текущее состояние.

2. Выделите в Списке слоев те слои, которые требуется удалить.

Если имя слоя известно, для выбора слоя можно воспользоваться Областью поиска, расположенной в левом нижнем углу Менеджера документа.

3. Нажмите кнопку Удалить на инструментальной панели Менеджера документа.

Удаление текущего и системного слоев невозможно.

Если удаляемый слой содержит объекты, на экране появляется диалог, который позволяет просмотреть их список и подтвердить удаление либо отказаться от него.

4. Подтвердите удаление.

5. Закройте Менеджер документа, нажав кнопку ОК.

При удалении в модели слоя, спроецированного в ассоциативный чертеж, слой также удаляется из чертежа. Если на удаляемом слое в чертеже находятся объекты, не являющиеся проекционными, они автоматически переносятся на системный слой чертежа.


2.15.14.8. Группы и фильтры слоев в модели

Назначение групп слоев и фильтров слоев и приемы работы с ними в модели в целом такие же, как в графическом документе. В данном разделе кратко описано создание и удаление групп и фильтров слоев в модели. Подробные сведения можно получить в разделе 3.6.6.9, посвященном наборам слоев в графическом документе (в графическом документе наборами слоев являются: группы слоев, группы свойств слоев и фильтры слоев; в модели группы свойств слоев не предусмотрены).

Чтобы создать группу слоев в модели, нажмите кнопку Создать группу на Инструментальной панели Менеджера документа (см. рис 2.15.20). Пиктограмма новой группы появится в Дереве документа.

«Перетащите» нужные слои на значок созданной группы.

Чтобы создать фильтр слоев документа, нажмите кнопку Создать фильтр на Инструментальной панели. После этого на экране появляется диалог Фильтр слоев (рис. 2.15.24). В таблице Условия данного диалога задайте одно или несколько условий фильтрации слоев. Контролируйте результат фильтрации в таблице Просмотр.

Рис. 2.15.24. Диалог создания фильтра слоев в документе-модели

Чтобы завершить настройку фильтра и закрыть диалог, нажмите кнопку ОК. Значок фильтра появится в Дереве Менеджера документа.

Чтобы удалить группу слоев или фильтр, следует выделить их в Дереве Менеджера документа и нажать кнопку Удалить или вызвать команду из контекстного меню.

Фильтры слоев можно преобразовывать в группы, см. раздел Преобразование фильтра в группу.


2.15.15. Зоны в модели

2.15. Сервисные функции

2.15.15. Зоны в модели

В модели можно создавать зоны. Зона — это выделенный в пространстве модели объем.

Зоны удобно использовать в моделях, содержащих большое количество компонентов, расположенных компактными группами. Применение зон позволяет ускорить выбор групп объектов в такой модели. О выделении объектов с помощью зон см. раздел 2.15.15.4.

Зону можно разбить на несколько новых зон. Образовавшиеся в результате разбиения зоны, в свою очередь, могут быть разбиты.

Включение/отключение отображения зон в окне модели выполняется с помощью команды Вид — Отображение — Показать зоны или нажатием кнопки Отображение зон на инструментальной Панели Вид.

Все имеющиеся в модели зоны перечислены в Дереве модели на вкладке Зоны (см. раздел 2.15.15.1). Если эта вкладка активна, то зоны отображаются в окне модели вне зависимости от того, включен или отключен их показ.

Зоны показываются в окне модели в виде полупрозрачных многогранников. Настройка параметров отображения зон для текущего окна выполняется в специальном диалоге (см. раздел 9.3.4).

При создании в модели исполнений зоны передаются в них так же, как и другие объекты (см. раздел 2.13.3.2).

В этом разделе:

2.15.15.1. Дерево зон

2.15.15.2. Создание зоны в модели

2.15.15.2.1. Создание зоны по координатам

2.15.15.2.2. Создание зоны по габаритам объектов

2.15.15.3. Разбиение на зоны

2.15.15.3.1. Разбиение зоны равномерно по осям

2.15.15.3.2. Разбиение зоны по набору плоскостей

2.15.15.4. Выделение объектов с помощью зон


2.15.15.1. Дерево зон

Дерево зон модели отображается на вкладке Зоны Дерева модели (рис. 2.15.25). В нем располагаются зоны и разбиения в порядке их создания.

Рис. 2.15.25. Дерево зон модели

Зоны и разбиения располагаются на первом уровне иерархии Дерева.

Зоны, получаемые в результате разбиений, располагаются на втором уровне.

При создании зонам и разбиениям автоматически присваиваются наименования и номера.

Перед названием текущей зоны отображается буква «т» в круглых скобках. Чтобы сделать другую зону текущей, вызовите из ее контекстного меню в Дереве зон команду Текущая зона. При вызове команды рядом с ее названием в меню появляется «галочка».

Чтобы скрыть или показать зону, выделите ее в Дереве зон и вызовите из контекстного меню команду Скрыть или Показать.

Чтобы удалить зону или разбиение, выделите нужный объект в Дереве зон и вызовите из контекстного меню команду Удалить.


2.15.15.2. Создание зоны в модели

Зоны относятся к объектам, использующим систему координат (о системе координат объекта см. раздел 2.8.3.4.1).

Габариты зоны в модели можно задать следующими способами:

– По координатам;

– По габаритам объектов.

Для удобства работы включите отображение зон в окне модели или активизируйте в Дереве модели вкладку Зоны.

Вызовите команду Создать зону одним из способов:

– из меню Редактор — Зоны,

– нажатием соответствующей кнопки на инструментальной панели Вспомогательная геометрия,

– из контекстного меню детали или сборки на вкладке Зоны.

После вызова команды на Панели свойств на вкладке Параметры появляются элементы управления для задания параметров зоны, см. рис. 2.15.26.

Рис. 2.15.26. Панель свойств при создании зоны

Выберите из списка Способ способ задания габаритов зоны и введите необходимые параметры. Подробно о вводе параметров для каждого из способов рассказано в разделах 2.15.15.2.1 и 2.15.15.2.2.

Объекты для определения габаритов зоны можно указать в Дереве построения или в окне модели до вызова команды. В этом случае на Панели свойств по умолчанию отображаются элементы управления для способа По габаритам объектов.

На вкладке Свойства Панели свойств можно изменить умолчательное наименование зоны. Также на этой вкладке отображается название системы координат зоны.

После задания параметров в окне модели отображается фантом создаваемой зоны.

Чтобы, не выходя из команды, задать другие параметры создаваемой зоны, нажмите кнопку Указать заново на Панели специального управления.

Чтобы завершить построение, нажмите кнопку Создать объект.

Созданная зона появляется в окне модели, а ее пиктограмма и наименование — в Дереве зон модели.

В этом разделе:

2.15.15.2.1. Создание зоны по координатам

2.15.15.2.2. Создание зоны по габаритам объектов


2.15.15.2.1. Создание зоны по координатам

Чтобы задать габариты зоны способом По координатам, выполните следующие действия:

1. Выберите вариант задания параллелепипеда. Для этого в группе Вариант активизируйте один из следующих переключателей:

– По двум вершинам,

– По центру и вершине.

2. Задайте положение точек параллелепипеда.

Положение первой точки указывается при активном переключателе Точка 1, а положение второй — при активном переключателе Точка 2.

Координаты точки могут быть введены с клавиатуры или определены автоматически при указании положения точки мышью в окне модели или выборе точечного объекта. Эти действия аналогичны описанным в разделе 2.5.2.2.

Кроме того, для задания координат можно использовать процесс построения точки, который запускается после нажатия кнопки Построение точки на Панели специального управления (см. раздел 2.5.2.11.1). Параметры, заданные в данном процессе, определяют положение точки параллелепипеда. Новая точка при этом не создается.


2.15.15.2.2. Создание зоны по габаритам объектов

Чтобы задать габариты зоны способом По габаритам объектов, укажите объекты, определяющие габариты зоны.

Объекты могут быть указаны как в окне модели, так и в Дереве построения. При указании объекты подсвечиваются, а их наименования отображаются на панели Список объектов.

Вспомогательные плоскости и оси не участвуют в определении габарита зоны.

Чтобы удалить какой-либо объект из списка, выделите его и нажмите кнопку Удалить, расположенную над списком.

Повторное указание объектов также отменяет их выбор.

Зона имеет форму параллелепипеда, охватывающего все указанные объекты.

При выборе объектов в Дереве построения можно указать всю модель или ее компонент. В этом случае габариты зоны по умолчанию определяются телами и поверхностями, входящими в состав модели или компонента. Список типов объектов, определяющих габариты зоны, можно изменить при настройке (см. раздел 9.2.7.4.15).

Списки типов объектов для модели и ее компонента могут отличаться. В этом случае габариты зоны для модели определяются только теми объектами, которые совпадают в списках. Если при указании компонента в габарите зоны не учитываются отдельные типы его объектов, это означает, что они исключены из списка при настройке этого компонента. При необходимости вы можете указать нужные объекты вручную.

Нажатая кнопка Указание деталей на Панели специального управления позволяет указывать отдельные детали на любом уровне сборки. Если кнопка отжата, то при указании детали выбирается весь компонент первого уровня, к которому эта деталь относится.


2.15.15.3. Разбиение на зоны

Зону в модели можно разбить на зоны следующими способами:

– Равномерно по осям;

– По набору плоскостей.

Для удобства работы включите отображение зон в окне модели или активизируйте в Дереве модели вкладку Зоны.

Чтобы разбить зону, вызовите команду Редактор — Зоны — Разбить зону или нажмите соответствующую кнопку на инструментальной панели Вспомогательная геометрия.

После вызова команды на Панели свойств появятся элементы управления для задания параметров разбиения зоны, см. рис. 2.15.27.

Рис. 2.15.27. Панель свойств при разбиении зоны

Укажите в Дереве или в окне модели зону для разбиения.

На Панели свойств выберите в группе переключателей Способ разбиения способ разбиения зоны и введите необходимые параметры.

Подробно о вводе параметров и указании объектов для каждого из способов разбиения рассказано в разделах 2.15.15.3.1 и 2.15.15.3.2.

Зону, полученную в результате разбиения способом По набору плоскостей, можно разбить на зоны только таким же способом.

После указания параметров в окне модели в разбиваемой зоне отображаются фантомы новых зон.

На вкладке Свойства можно изменить умолчательное наименование разбиения.

Чтобы изменить параметры разбиения, не выходя из команды, нажмите кнопку Указать заново на Панели специального управления.

Вы можете, не выходя из команды, создать в модели новую зону. Для этого нажмите кнопку Создать зону на Панели специального управления.

Чтобы завершить построение, нажмите кнопку Создать объект.

Новые зоны отображаются внутри разбиваемой зоны.

Наименования разбиения и новых зон отображаются в Дереве зон модели.

В одной зоне может быть создано несколько разбиений.

В этом разделе:

2.15.15.3.1. Разбиение зоны равномерно по осям

2.15.15.3.2. Разбиение зоны по набору плоскостей


2.15.15.3.1. Разбиение зоны равномерно по осям

Для разбиения зоны способом Равномерно по осям задайте в полях Количество зон по оси Х, Количество зон по оси У и Количество зон по оси Z нужные значения.

Количество зон хотя бы по одной из осей должно быть больше 1.


2.15.15.3.2. Разбиение зоны по набору плоскостей

Для разбиения зоны способом По набору плоскостей укажите плоскости, разбивающие зону. Плоскости должны пересекаться с разбиваемой зоной. В качестве плоскостей можно использовать:

– координатные и вспомогательные плоскости,

– плоские грани.

Плоскости могут быть указаны как в окне модели, так и в Дереве построения. После указания объекты подсвечиваются, а их наименования отображаются на панели Список объектов.

Чтобы удалить какой-либо объект из списка, выделите его и нажмите кнопку Удалить, расположенную над списком.

Повторное указание объектов также отменяет их выбор.


2.15.15.4. Выделение объектов с помощью зон

С помощью зон могут быть выделены:

– Объекты, построенные непосредственно в модели (тела, поверхности, кривые и т.п.). На принадлежность зоне или на пересечение с зоной проверяются сами объекты.

– Компоненты. На принадлежность зоне или на пересечение с зоной проверяются не объекты компонентов, а габаритный параллелепипед компонента. Таким образом, зоной можно выделить целый компонент, но не отдельный его объект. Габаритный параллелепипед строится в абсолютной системе координат компонента по объектам, включенным в список объектов, определяющих габарит зоны (см. раздел 9.2.7.4.15). Если списки объектов для модели и компонента отличаются, габариты компонента определяются теми объектами, которые совпадают в списках.

Выделение компонентов по зоне может происходить:

– Только на первом уровне текущего документа: может быть выделен только компонент первого уровня целиком, т.е. вместе со всеми входящими в него объектами; выделение компонентов второго уровня и далее (т.е. компонентов, входящих в компоненты и т.д.) по отдельности невозможно.

– На всех уровнях текущего документа: может быть выделен компонент любого уровня.

Способ выделения объектов зоной — на первом уровне документа или на всех уровнях — зависит от настройки системы, см. раздел 9.1.11.14.

Чтобы выделить объекты и компоненты (далее — «объекты») с помощью зоны, выполните следующие действия.

1. Включите отображение зон в окне модели или активизируйте в Дереве модели вкладку Зоны.

2. Выберите нужную зону в Дереве зон или в окне модели.

3. Вызовите из меню Выделить — По зоне или из контекстного меню нужную команду:

– Выбрать внутри зоны — выделяются объекты, которые лежат внутри зоны, включая объекты, касающиеся границ зоны.

– Выбрать вне зоны — выделяются все объекты, которые лежат вне зоны, включая объекты, касающиеся границ зоны.

– Выбрать секущей зоной — выделяются объекты, которые лежат внутри зоны, а также объекты, пересекающие границу зоны.

Если перед вызовом команды не была выбрана ни одна зона, команда применяется к текущей зоне.

При выделении по зоне учитываются фильтры объектов (см. раздел 2.1.4.1.3).

Выделение групп объектов с помощью зон можно использовать для последующего применения к ним каких-либо команд, например, команд изменения типа загрузки (о типах загрузки см. раздел 2.12.2.1.6).

В результате выполнения любой из команд выделения в нижней части Дерева зон отображается список выделенных объектов. Команда, вызванная из контекстного меню любого объекта списка, применяется ко всем объектам. Так, если вызвать команду Типы загрузки и указать определенный тип загрузки, то он будет применен ко всей группе объектов.


2.16. Технологическая подготовка модели

В этом разделе:

2.16.1. Технологическая сборка

2.16.2. Учет допусков при управлении размерами компонента

2.16.2.1. Пересчет размеров компонента в сборке

2.16.2.2. Возврат компоненту номинальных размеров


2.16.1. Технологическая сборка

2.16. Технологическая подготовка модели

2.16.1. Технологическая сборка

КОМПАС-3D предоставляет пользователю возможность подготовки модели (детали или сборки) к разработке технологического процесса ее изготовления (или сборки). Для этого используется технологическая сборка.

Технологическая сборка — это трехмерная модель, содержащая технологические данные, например, результат пересчета размеров модели с учетом допусков, технологические объекты (центровые отверстия, отверстия для крепления и т.п.), технологические модели (люнеты, центры, инструменты и прочая оснастка). Технологическая сборка создается и хранится в документе «технологическая сборка», расширение файла — t3d.

Примеры использования технологической сборки:

Пример 1
Конструктором создана деталь. Для разработки технологического процесса изготовления этой детали технолог создает технологическую сборку, включает в нее деталь и добавляет необходимые технологические данные.

Пример 2
Конструктором создана общая сборка редуктора. Два корпуса редуктора необходимо обрабатывать совместно. Модели этих корпусов находятся в разных подсборках общей сборки редуктора. Технолог создает технологическую сборку и включает в нее корпуса редуктора. Затем добавляет в эту сборку нужные технологические данные для совместной обработки корпусов.

Технологическая сборка может состоять из любых объектов, входящих в обычную сборку КОМПАС-3D (см. раздел 2.1.1.1).

Работа с технологической сборкой — добавление компонентов, создание и редактирование тел и поверхностей, создание сопряжений и т.п. — аналогична работе с обычной сборкой.

Некоторые инструментальные панели в технологической сборке по умолчанию отключены (например, панель Массивы).

Рекомендуется следующий порядок создания технологической сборки.

1. Создайте новый документ «технологическая сборка».

2. Добавьте нужные компоненты (созданные ранее конструктором детали и/или сборки).

3. При необходимости:

– отредактируйте модель путем выполнения операций в технологической сборке;

– пересчитайте размеры модели с учетом допусков;

– добавьте:

• технологические модели и стандартные изделия в виде компонентов;

• технологические данные.

Если при работе с технологической сборкой предполагается изменение состава сборки, то рекомендуется зафиксировать ее компоненты. Для этого можно выделить раздел Компоненты в Дереве построения и нажать кнопку Включить фиксацию на панели Редактирование сборки.

Изменения компонента, выполненные операциями в технологической сборке, не передаются в файл этого компонента. Эти изменения хранятся в технологической сборке. В то же время изменения модели, которые выполнены при редактировании файла этой модели, передаются в технологическую сборку.

Если технологическая сборка создается из обычной сборки с помощью команды Сохранить как..., то все последующие изменения исходной сборки не будут передаваться в технологическую сборку.

По умолчанию компоненты добавляются в технологическую сборку с номинальными размерами. В сборке можно изменить размеры каждого компонента с учетом допусков, назначенных конструктором на размеры компонента (размеры эскизов и размеры, соответствующие параметрам операций; см. раздел 2.9.2.2). Подробнее об управлении размерами компонента в сборке рассказано в разделе 2.16.2.


2.16.2. Учет допусков при управлении размерами компонента

2.16. Технологическая подготовка модели

2.16.2. Учет допусков при управлении размерами компонента

По умолчанию компоненты добавляются в модель с номинальными размерами. При необходимости можно пересчитать размеры компонента с учетом назначенных допусков (о допусках см. раздел 2.10.2). Расчет размеров компонента производится согласно текущему пересчету.

КОМПАС-3D предоставляет три системных пересчета размеров: в середину поля допуска, по верхнему пределу и по нижнему пределу. Компонент также может иметь пользовательские пересчеты, созданные при его редактировании. Подробнее о пересчетах размеров рассказано в разделе 2.10.3.1.

Управление размерами компонента с учетом допусков возможно после того, как компонент вставлен.

Настройка пересчета размеров доступна только для компонента первого уровня (т.е. для компонента, вставленного непосредственно в текущую модель). Заданные настройки пересчета размеров компонента распространяются на размеры всех объектов, входящих в него.

В этом разделе:

2.16.2.1. Пересчет размеров компонента в сборке

2.16.2.2. Возврат компоненту номинальных размеров


2.16.2.1. Пересчет размеров компонента в сборке

Пересчет размеров компонента, вставленного в модель, осуществляется с помощью команды Свойства компонента. Команда находится в контекстном меню компонента, выделенного в окне модели или Дереве построения.

После вызова команды на Панели свойств появятся вкладки, содержащие элементы управления для настройки свойств компонента.

Чтобы изменить размеры компонента согласно требуемому пересчету, на вкладке Файл-источник нажмите кнопку Пересчитать размеры. Становится доступен список пересчетов (о пересчетах см. раздел 2.10.3.1). Выберите из списка нужный пересчет — системный или пользовательский (рис. 2.16.1).

Рис. 2.16.1. Выбор пересчета размеров компонента

Обратите внимание на то, что для локальной детали доступны только системные пересчеты.

После выбора пересчета нажмите кнопку Создать объект на Панели специального управления.

Пиктограмма отредактированного компонента в Дереве построения будет отмечена красной «галочкой», означающей, что сборку необходимо перестроить.

Для того, чтобы увидеть, как будет выглядеть модель с учетом изменившихся размеров компонента, нажмите кнопку Перестроить на панели Вид или вызовите команду Вид — Перестроить.

В Дереве построения пересчитанный компонент отмечается буквой «п» в круглых скобках.


2.16.2.2. Возврат компоненту номинальных размеров

Чтобы вернуть компоненту, вставленному в модель, номинальные размеры, выполните следующие действия.

1. Вызовите из контекстного меню компонента команду Свойства компонента.

2. На вкладке Файл-источник отожмите кнопку Пересчитать размеры. Список пересчетов становится недоступным.

3. На Панели специального управления нажмите кнопку Создать объект.

4. Перестройте модель. Для этого нажмите кнопку Перестроить на панели Вид или вызовите команду Вид — Перестроить.


3.1. Общие приемы работы в графических документах

3.1. Общие приемы работы
в графических документах

В этом разделе:

3.1.1. Привязки

3.1.1.1. Общие сведения о привязках

3.1.1.2. Глобальная и локальная привязка

3.1.1.2.1. Использование глобальных привязок

3.1.1.2.2. Использование локальных привязок

3.1.1.3. Клавиатурные привязки

3.1.2. Выделение объектов. Использование буфера обмена

3.1.2.1. Выделение объектов мышью

3.1.2.2. Выделение объектов с помощью команд

3.1.2.3. Выделение объектов по свойствам

3.1.2.4. Перебор объектов

3.1.2.5. Использование буфера обмена

3.1.2.5.1. Помещение объектов в буфер

3.1.2.5.2. Вставка из буфера

3.1.3. Сетка. Ортогональное черчение

3.1.3.1. Использование сетки

3.1.3.2. Привязка по сетке

3.1.3.3. Изображение сетки при мелких масштабах

3.1.3.4. Ортогональное черчение

3.1.4. Системы координат в графическом документе

3.1.4.1. Абсолютная система координат

3.1.4.2. Локальные системы координат

3.1.4.2.1. Создание локальной системы координат

3.1.4.2.2. Управление локальными системами координат

3.1.5. Управление порядком отрисовки объектов

3.1.6. Создание объекта по образцу


3.1.1. Привязки

3.1. Общие приемы работы в графических документах

3.1.1. Привязки

В этом разделе:

3.1.1.1. Общие сведения о привязках

3.1.1.2. Глобальная и локальная привязка

3.1.1.2.1. Использование глобальных привязок

3.1.1.2.2. Использование локальных привязок

3.1.1.3. Клавиатурные привязки


3.1.1.1. Общие сведения о привязках

В процессе работы с графическим документом постоянно возникает необходимость точно установить курсор в некоторую точку (начало координат, центр окружности, конец отрезка и т.п.), иными словами, выполнить привязку к уже существующим точкам или объектам. Без такой привязки невозможно создать точный чертеж.

КОМПАС-3D предоставляет возможности привязок к характерным точкам (пересечение, граничные точки, центр и т.д.) и объектам (по нормали, по направлениям осей координат).

Выполнить привязку можно с помощью клавиатуры (клавиатурная привязка) или с помощью специальных команд. Клавиатурная привязка возможна в любое время, привязка с помощью команд — только во время создания или редактирования графических объектов.

Привязка с помощью команд может действовать глобально (глобальная привязка) или локально (локальная привязка).

Глобальная привязка (если она включена) постоянно действует при вводе и редактировании объектов. Например, если включена глобальная привязка к пересечениям, то при создании каждой точки система автоматически будет выполнять поиск ближайшего пересечения в пределах ловушки курсора.

Локальная привязка действует однократно. Например, если при создании точки включена локальная привязка к пересечениям, то после завершения построения этой точки привязка перестанет действовать. Для выполнения такой же привязки при создании следующей точки необходимо включить ее повторно. Использование локальной привязки неудобно в том случае, если требуется выполнить несколько однотипных привязок подряд.

Локальная привязка является более приоритетной, чем глобальная, то есть во время действия локальной привязки установленные в окне глобальные привязки не действуют.

Перечень комбинаций клавиш для выполнения клавиатурной привязки приведен в разделе 3.1.1.3, перечень команд глобальной и локальной привязки — в разделе 3.1.1.2.


3.1.1.2. Глобальная и локальная привязка

Перечень команд глобальной и локальной привязок, используемых в КОМПАС-3D, приведен в таблице 3.1.1.

Табл. 3.1.1. Команды глобальной и локальной привязки
Наименование | Описание
Ближайшая точка | Привязка к характерной точке объекта (например, к начальной точке отрезка) или началу текущей системы координат.
Середина | Привязка к середине объекта.
Пересечение | Привязка к пересечению объектов.
Касание | При выборе данного способа привязка будет выполняться таким образом, чтобы создаваемый объект (отрезок, дуга и т.п.) касался указанного объекта в точке, ближайшей к текущему положению курсора.
Нормаль | При выборе данного способа привязка будет выполняться таким образом, чтобы создаваемый объект (например, отрезок) располагался перпендикулярно указанному объекту.
По сетке | Привязка к точке вспомогательной сетки (см. раздел 3.1.3.1) в текущем окне (при этом сетка может быть включена или выключена).
Выравнивание | При выборе данного способа привязки будет выполняться выравнивание вводимой точки объекта по вертикали и по горизонтали относительно характерных точек существующих объектов, а также относительно последней зафиксированной точки. Выравнивание выполняется без учета угла наклона локальной системы координат.
Угловая привязка | При выборе данного способа привязки курсор будет перемещаться относительно последней зафиксированной точки под углами, кратными указанному при настройке привязок (см. рис. 3.1.3) значению. Отсчет углов ведется в текущей системе координат. По умолчанию шаг угловой привязки равен 45°.
Центр | Привязка к центральной точке окружности, эллипса, дуги окружности или эллипса, прямоугольника, правильного многоугольника.
Точка на кривой | Привязка к ближайшей точке указанной кривой. Ближайшая точка будет определяться как пересечение кривой с нормалью к ней, проведенной из указанной точки.

Привязка выполняется следующим образом.

В процессе создания или редактирования графического объекта установите курсор так, чтобы его «ловушка» захватывала объект (или точку), к которому требуется привязаться (рис. 3.1.1). Например, для использования привязки Ближайшая точка требуется захватить характерную точку какого-либо объекта (некоторые примеры характерных точек показаны на рис. 3.5.2); для использования привязки Центр — дугу, многоугольник или другой объект, имеющий центральную точку.

В точке, соответствующей привязке, появится «крестик», который свидетельствует о срабатывании привязки (рис. 3.1.1).

При использовании глобальных привязок срабатывает более приоритетная из них (см. раздел 3.1.1.2.1).

Для завершения привязки нажмите клавишу <Enter> или левую кнопку мыши. Точка, отмеченная «крестиком», будет зафиксирована.

Рис. 3.1.1. Использование привязки Центр для указания центра отверстия

Вы можете изменить размер «ловушки» курсора, вызвав команду Сервис — Параметры... — Система — Графический редактор — Курсор (см. раздел 9.1.7.1).

В этом разделе:

3.1.1.2.1. Использование глобальных привязок

3.1.1.2.2. Использование локальных привязок


3.1.1.2.1. Использование глобальных привязок

Для управления глобальными привязками используется меню кнопки Привязки, расположенной на панели Текущее состояние. Чтобы включить нужную привязку в текущем окне, вызовите соответствующую ей команду меню.

Для включения привязок можно также использовать кнопки панели Глобальные привязки. Пока кнопка находится в нажатом состоянии, привязка будет действовать. Для отключения привязки отожмите кнопку.

Рис. 3.1.2. Панель глобальных привязок

Можно включать несколько различных глобальных привязок к объектам, и все они будут работать одновременно. При этом расчет точки выполняется «на лету», а на экране отображается фантом, соответствующий этой точке.

Если при текущем положении курсора возможно выполнение сразу нескольких привязок, то срабатывает более приоритетная из них. Список приоритетов совпадает с порядком перечисления привязок в диалоге их настройки (рис. 3.1.3).

Допустим, включены привязки Ближайшая точка и Пересечение, расположенные в списке друг за другом. Если при текущем положении курсора (например, при указании точки для выравнивания) его «ловушка» захватывает характерную точку объекта и точку пересечения объектов, то сработает более приоритетная привязка Ближайшая точка.

Вы можете отключить действие всех глобальных привязок, а затем включить их вновь в прежнем составе, воспользовавшись кнопкой Привязки. Эта кнопка также служит индикатором действия глобальных привязок: нажатая кнопка означает, что глобальные привязки включены, отжатая — отключены. Для переключения кнопки при помощи клавиатуры воспользуйтесь комбинацией клавиш <Ctrl>+<D>. Для временного отключения глобальных привязок нажмите и удерживайте клавишу <Alt>; после того как вы отпустите клавишу, привязки включатся.

Включение и отключение глобальных привязок, а также ряд дополнительных настроек доступны в диалоге установки глобальных привязок (рис. 3.1.3). Для его вызова служит кнопка Установка глобальных привязок на Панели текущего состояния.

Элементы управления диалога описаны в разделе 9.1.7.16.

Рис. 3.1.3. Диалог установки глобальных привязок

Обратите внимание на то, что включение и отключение глобальных привязок описанными выше способами действует только для текущего окна до конца сеанса работы.

Если документ открыт в нескольких окнах, то настройка привязок, сделанная в одном из них, распространяется на все окна этого документа.

Умолчательная настройка глобальных привязок — настройка, которая будет использоваться для окон вновь созданных или открытых документов — останется прежней. Чтобы изменить ее, вызовите команду Сервис — Параметры... — Система — Графический редактор — Привязки. На экране появится диалог с элементами управления, аналогичными представленным на рис. 3.1.3 (единственное исключение — отсутствие опции Запретить привязки), в котором вы можете произвести необходимую настройку.


3.1.1.2.2. Использование локальных привязок

Включение локальной привязки возможно во время создания и редактирования графических объектов. Команды включения локальных привязок сгруппированы в меню. Существует два способа доступа к этому меню.

1. С помощью контекстного меню (рис. 3.1.4).

Рис. 3.1.4. Команды включения локальных привязок в контекстном меню

2. С помощью кнопки Локальные привязки. Это вынесенная на панель Глобальные привязки кнопка последней использовавшейся локальной привязки (рис. 3.1.5).

Рис. 3.1.5. Меню кнопки Локальные привязки

Команды меню кнопки Локальные привязки можно расположить в виде кнопок на отдельной панели и поместить данную панель в любом удобном месте. Для этого «перетащите» меню кнопки Локальные привязки за заголовок в любом направлении.

Будет сформирована панель Локальные привязки. Обратите внимание на ее отличие от остальных инструментальных панелей: состав и порядок кнопок на ней изменить невозможно.

Для включения нужной локальной привязки вызовите соответствующую команду меню или нажмите кнопку на панели Локальные привязки.

Курсор изменит свою форму, что свидетельствует о том, что привязка активна. Действие всех глобальных привязок будет приостановлено до завершения текущей операции.

Кнопка Локальные привязки на панели Глобальные привязки доступна после вызова команды создания или редактирования объекта.


3.1.1.3. Клавиатурные привязки

Некоторые варианты привязки можно выполнять с помощью клавиатуры, нажимая для этого соответствующие комбинации клавиш. Эти комбинации представлены в таблице 3.1.2.

Клавиши <0>–<9> и <.> следует нажимать на дополнительной клавиатуре. При этом должен быть включен цифровой режим ее работы (должен гореть индикатор NumLock).

Табл. 3.1.2. Комбинации клавиш для выполнения привязок
Комбинация | Описание
<Ctrl>+<0> | Пеpеместить куpсоp в точку (0,0) текущей системы координат
<Ctrl>+<5> | Установить куpсоp в ближaйшую к нему хapaктеpную точку элементa без учета фоновых видов и слоев1
<Ctrl>+<Shift>+<5> | Установить куpсоp в ближaйшую к нему хapaктеpную точку элементa с учетом фоновых видов и слоев
<Ctrl>+<.> | Устaновить куpсоp по нормали в ближaйшую точку ближaйшего элемента
<Alt>+<5> | Установить куpсоp в ближайшую к нему точку пеpесечения двух пpимитивов
<Shift>+<5> | Устaновить куpсоp в ближайшую к нему сеpедину пpимитивa
<Ctrl>+<1> | Пpивязкa к ближaйшему элементу по диагонали между отрицательным направлением оси ОХ и отрицательным направлением оси ОY текущей системы координат
<Ctrl>+<2>,<Ctrl>+<↓> | Пpивязкa к ближaйшему элементу против направления оси OY текущей системы координат
<Ctrl>+<3> | Пpивязкa к ближaйшему элементу по диагонали между положительным направлением оси ОХ и отрицательным направлением оси ОY текущей системы координат
<Ctrl>+<4>,<Ctrl>+<←> | Пpивязкa к ближaйшему элементу против направления оси OХ текущей системы координат
<Ctrl>+<6>,<Ctrl>+<→> | Пpивязкa к ближaйшему элементу по направлению оси OХ текущей системы координат
<Ctrl>+<7> | Пpивязкa к ближaйшему элементу по диагонали между отрицательным направлением оси ОХ и положительным направлением оси ОY текущей системы координат
<Ctrl>+<8>,<Ctrl>+<↑> | Пpивязкa к ближaйшему элементу по направлению оси OY текущей системы координат
<Ctrl>+<9> | Пpивязкa к ближaйшему элементу по диагонали между положительным направлением оси ОХ и положительным направлением оси ОY текущей системы координат
  1. Данная комбинация клавиш работает также при отключенном режиме NumLоck. В этом случае она позволяет установить куpсоp в ближaйшую хapaктеpную точку ближайшего элементa с учетом фоновых видов и слоев.


3.1.2. Выделение объектов. Использование буфера обмена

3.1. Общие приемы работы в графических документах

3.1.2. Выделение объектов. Использование буфера обмена

В этом разделе:

3.1.2.1. Выделение объектов мышью

3.1.2.2. Выделение объектов с помощью команд

3.1.2.3. Выделение объектов по свойствам

3.1.2.4. Перебор объектов

3.1.2.5. Использование буфера обмена

3.1.2.5.1. Помещение объектов в буфер

3.1.2.5.2. Вставка из буфера


3.1.2.1. Выделение объектов мышью

Для выделения объектов мышью выполните следующие действия.

1. Подведите курсор к нужному объекту так, чтобы «ловушка» курсора захватывала объект.

2. Щелкните левой кнопкой мыши. Цвет объекта изменится — он будет отрисован цветом, установленным для выделенных объектов (см. раздел 9.1.7.11).

Чтобы отменить выделение объекта, щелкните левой кнопкой мыши в любом месте вне этого объекта или нажмите клавишу <Esc>. Выделение будет снято — объект отрисуется своим обычным цветом.

Если необходимо выделить несколько объектов, нажмите клавишу <Shift> или <Ctrl> и удерживайте ее нажатой, щелкая левой кнопкой мыши на нужных объектах. После окончания выделения отпустите клавишу <Shift> (<Ctrl>).

Можно выделить несколько объектов другим способом — с помощью охватывающей или секущей рамки. Установите курсор на свободное место (так, чтобы он не захватывал никаких объектов), нажмите левую кнопку мыши и перемещайте курсор, удерживая кнопку нажатой. На экране будет отображаться рамка, следующая за курсором.

– При перемещении курсора слева направо формируется охватывающая рамка. Она отображается сплошной линией. После того как вы отпустите кнопку мыши, будут выделены те объекты, которые попали внутрь рамки целиком.

– При перемещении курсора справа налево формируется секущая рамка. Она отображается пунктиром. После того как вы отпустите кнопку мыши, будут выделены те объекты, которые попали внутрь рамки целиком или частично (т.е. пересеклись с рамкой).

Для снятия выделения с отдельных объектов щелкайте на них левой кнопкой мыши, удерживая нажатой клавишу <Shift> или <Ctrl>. Можно снять выделение с нескольких объектов при помощи прямоугольной рамки. Это делается аналогично выделению, но с нажатой клавишей <Shift>.

При снятии выделения рамкой следите за тем, чтобы в рамку попадали только выделенные объекты. В противном случае выделение не снимается, а накладывается — на невыделенные объекты.

Иногда объекты, которые требуется выделить, расположены близко друг к другу или даже наложены друг на друга. При этом трудно (а иногда и вовсе невозможно) точно указать один из них курсором.

Для выделения указанием любого из близко расположенных (в том числе наложенных друг на друга) объектов служит команда Перебор объектов (см. раздел 3.1.2.4).


3.1.2.2. Выделение объектов с помощью команд

Команды выделения графических объектов сгруппированы в меню Выделить, а команды снятия выделения — в меню Выделить — Исключить.

Кнопки для вызова команд находятся на панели Выделение (рис. 3.1.6).

Рис. 3.1.6. Панель Выделение

Описание общих команд выделения представлено в таблице 3.1.3, о специальных командах выделения см. следующие разделы:

Выделить — Группу — раздел 3.10.2.4,

Выделить — Слой — раздел 3.6.6.7,

Выделить — Вид — раздел 3.6.5.4,

Выделить — По стилю кривой — раздел 3.2.1.1.1,

Выделить — По атрибутам — раздел 11.5.3.5.

Указание объектов, с которых требуется снять выделение, производится аналогично указанию объектов для выделения. Команды снятия выделения доступны, если в документе есть выделенные объекты.

Табл. 3.1.3. Общие команды выделения графических объектов

Команда

Описание

Выделить все

Позволяет выделить все объекты, содержащиеся в текущем виде чертежа (об изменении состояния вида см. раздел 3.6.5.2) или во фрагменте.

Выделить объект

Позволяет выделить отдельный объект.

После вызова команды укажите курсором объект, который нужно выделить.

За один вызов команды можно указать произвольное количество объектов.

Выделить рамкой

Позволяет выделить объекты с помощью прямоугольной рамки.

После вызова команды укажите курсором первую и вторую вершины прямоугольной рамки. Элементы, целиком попавшие в заданную рамку, будут выделены.

За один вызов команды можно задать произвольное количество рамок.

Выделить
вне рамки

Позволяет выделить объекты, не попавшие в заданную прямоугольную рамку.

После вызова команды укажите курсором первую и вторую вершины прямоугольной рамки. Элементы, целиком оставшиеся снаружи заданной рамки, будут выделены.

За один вызов команды можно задать произвольное количество рамок.

Выделить секущей рамкой

Позволяет выделить объекты активного документа, частично или полностью попавшие в заданную прямоугольную рамку.

После вызова команды укажите курсором первую и вторую вершины прямоугольной рамки. Элементы, которые целиком или частично попали внутрь заданной рамки, будут выделены.

За один вызов команды можно задать произвольное количество секущих рамок.

Выделить секущей ломаной

Позволяет выделить объекты активного документа, пересекая их произвольной ломаной линией.

После вызова команды указывайте курсором вершины ломаной. Объекты, пересекающиеся со звеньями ломаной, будут выделены.

Выделить прежний список

Позволяет выделить объекты, которые выделялись предыдущий раз (элементы прежнего списка).

Выделить по типу

Позволяет выделить объекты активного документа в соответствии с их типом.

После вызова команды на экране появляется диалог, в котором требуется указать типы объектов, подлежащих выделению.

Выделить по свойствам

Позволяет выделить геометрические объекты активного документа по набору параметров, исключить объекты из числа выделенных по набору параметров, а также инвертировать выделение. Команда Выделить по свойствами подробно рассмотрена в разделе 3.1.2.3.


3.1.2.3. Выделение объектов по свойствам

Команда Выделить по свойствам позволяет выполнять операции выделения с объектами (геометрическими, размерами, обозначениями), соответствующими заданным условиям.

Доступными операциями выделения являются следующие:

– добавление объектов в группу выделенных,

– отмена выделения для группы объектов,

– инвертирование выделения группы объектов.

Под инвертированием следует понимать выделение всех объектов документа (или отмена выделения для всех объектов документа), за исключением удовлетворяющих заданным условиям.

Условием включения объекта в группу является соответствие значений его свойств заданным величинам. Свойствами, по которым выбираются объекты, являются параметры, которые задаются на Панели свойств при создании того или иного объекта. Принадлежность видам и слоям является общим свойством всех объектов.

Для вызова команды нажмите кнопку Выделить по свойствам на инструментальной панели Выделение или выберите ее название в меню Выделить.

На экране появится диалог выбора объектов по свойствам (рис. 3.1.7). Элементы управления этого диалога позволяют выбрать типы объектов и условия для выполнения над ними операций выделения.

Рис. 3.1.7. Диалог выделения объектов по свойствам

Кнопки инструментальной панели диалога позволяют управлять результатом операции выделения объектов и изменять масштаб отображения документа.

Дерево объектов содержит наименования типов объектов, которые присутствуют в текущем документе. Этот набор формируется автоматически. Опция рядом с наименованием позволяет управлять включением объектов данного типа в группу выделяемых объектов.

Библиотечные макроэлементы образуют отдельный раздел Дерева объектов с подразделами, соответствующими библиотеками. Например, если в документе есть отверстия, вставленные из библиотеки Сервисные инструменты, то в Дереве объектов есть раздел Библиотечные макроэлементы — Сервисные инструменты — Отверстия. Параметры для выделения библиотечных отверстий следует задавать в этом разделе.

Отображение раздела Библиотечные макроэлементы зависит от настройки (см. раздел 9.1.10.2).

Таблица условий выделения содержит список свойств выделенного в дереве объекта и позволяет задавать условия включения объекта в группу выделенных, т.е. формировать фильтр для выбора.

Чтобы сформировать фильтр для выбора объектов определенного типа, выполните следующие действия.

1. Включите в дереве опцию, соответствующую типу объекта.

2. Выберите в таблице свойство.

3. Выберите из раскрывающегося списка Условие нужный вариант (рис. 3.1.8). Набор доступных условий зависит от типа свойства.

4. Задайте значение условия в поле Значение. Способ задания также зависит от типа свойства. Значения числовых свойств, например, Длина, Угол, координаты характерных точек следует вводить с клавиатуры. Значения других свойств, например, Вид, Стиль, Размещение стрелок выбираются из раскрывающегося списка.

Рис. 3.1.8. Список условий

Чтобы быстро задать свойства, общие для всех объектов группы, включите опцию корневого раздела, например, Геометрия. Выберите общие условия и значения параметров. Затем в дереве выключите опции типов объектов, не подлежащих внесению в группу. Далее задайте остальные параметры для каждого типа объектов группы.

При задании условий следует учитывать следующие особенности.

– Если в столбце Свойство выбран Вид и в столбце Значение указан его номер, то при выборе слоя в раскрывающемся списке будут присутствовать только те слои, которые принадлежат данному виду. Если вид не выбран, то для выбора будут доступны все слои.

– Если в таблице не указано значение ни одного свойства, то в группу попадают все объекты данного типа.

– Если значения свойств заданы, а опция типа объекта выключена, то объекты в группу не включаются.

– Если вариант в столбце Условие не выбран, а значение задано, то в качестве условия используется вариант =.

– Если вариант в столбце Условие выбран, а значение не задано, то считается, что свойства не указаны, т.е. в группу попадают все объекты данного типа.

– Если условие для свойства не задано, то по этому свойству ограничения для выполнения над объектом операций выделения накладываться не будут.

– В группу объектов для выполнения операций выделения включаются только те объекты выбранного типа, которые удовлетворяют одновременно всем заданным условиям.

Кнопки Применить ко всем объектам и Применить к выделенным объектам позволяют указать задать область применения фильтра — все объекты документа или только выделенные объекты. Кнопка Применить к выделенным объектам доступна, если в документе есть выделенные объекты; она нажимается автоматически, если на момент вызова диалога в документе были выделены объекты. Когда эта кнопка нажата, в дереве присутствуют только те типы объектов, которые есть среди выделенных.

Кнопка Добавлять в группу позволяет добавлять в группу выделенных те объекты, которые удовлетворяют заданным условиям.

Кнопка Исключать из группы позволяет исключить из группы ранее выделенных объекты, которые удовлетворяют заданным условиям. Кнопка доступна, если в документе есть выделенные объекты.

Кнопка Инвертировать выделение позволяет изменить состояние выделенности объектов документа.

Результат инвертирования зависит от состояния кнопок Добавлять в группу и Исключать из группы. Если в дереве выбора объектов выбраны какие-либо объекты, то при нажатой кнопке Добавлять в группу указанные объекты добавляются к выделенным, результат инвертируется. При нажатой кнопке Исключать из группы выделение с указанных объектов снимается, результат инвертируется.

За один вызов команды можно произвести несколько действий по добавлению и исключению объектов нескольких типов, а также инвертированию выделения. Чтобы выполнить действие без выхода из диалога, используйте кнопку Применить.

Не прерывая работы команды, можно изменять масштаб отображения документа следующими способами.

Кнопка Показать все позволяет изменить масштаб отображения в активном окне таким образом, чтобы в нем был виден полностью весь документ.

Кнопка Масштаб по выделенным объектам позволяет автоматически изменить масштаб отображения в активном окне таким образом, чтобы в нем полностью помещались все выделенные объекты в максимально возможном масштабе. Если ни один объект не выделен, команда недоступна.

Выделенные вспомогательные прямые и пустые (не содержащие ни одного объекта) виды при масштабировании по выделенным объектам не учитываются. Не учитывается также единственная выделенная точка.

Чтобы завершить операции выделения, нажмите кнопку ОК диалога.

Выделив несколько объектов с помощью какой-либо команды выделения, вы можете вызвать другую команду выделения и продолжить указание объектов — выделение с отмеченных ранее объектов не снимается.


3.1.2.4. Перебор объектов

Иногда объект, который требуется указать, расположен близко к другим объектам или наложен на другие объекты. При этом трудно (а иногда и вовсе невозможно) точно указать его курсором.

Для выбора любого из близко расположенных (в том числе наложенных друг на друга) объектов служит режим перебора объектов. Перебор возможен, когда система ожидает выделения или указания объекта, а в ловушку курсора попадает сразу несколько объектов.

Выделение объектов часто требуется перед выполнением какой-либо команды. Например, для получения копии объекта необходимо выделить исходный объект.

Указание объектов требуется во время выполнения некоторых команд. Например, для построения параллельного отрезка необходимо указать объект, которому должен быть параллелен создаваемый отрезок.

Перебор при выделении графических объектов

1. Наведите курсор на группу объектов, содержащую нужный, и выделите любой из них.

2. Вызовите из контекстного меню команду Перебор объектов или нажмите комбинацию клавиш <Ctrl>+<t>.

3. Перебирайте объекты, нажимая клавишу <Пробел> или вызывая команду Следующий объект из контекстного меню. Объекты, попавшие в ловушку курсора в момент выделения первого объекта, будут поочередно подсвечиваться.

4. После подсвечивания нужного объекта вызовите команду Закончить перебор объектов. Можно также нажать клавишу <Enter> либо щелкнуть мышью на выделенном объекте. Перебор закончится на текущем объекте.

Заканчивать перебор не обязательно. Вы можете вызвать команду, для выполнения которой выделяется объект, сразу после того, как он подсветится.

Перебор при указании графических объектов

1. Наведите курсор на группу объектов, содержащую нужный объект.

2. Не указывая ни один из них, вызовите из контекстного меню команду Перебор объектов. Можно также нажать комбинацию клавиш <Ctrl>+<t>.

3. Перебирайте объекты, нажимая клавишу <Пробел> или вызывая команду Следующий объект из контекстного меню. Объекты, на которые указывал курсор в момент вызова команды перебора, будут поочередно подсвечиваться.

4. После подсвечивания нужного объекта выйдите из режима перебора с подтверждением выбора. Для этого вызовите команду Выбрать подсвеченный объект из контекстного меню или нажмите клавишу <Enter>. Можно также щелкнуть мышью на подсвеченном объекте или в любом свободном месте окна документа.

5. Для выхода из режима перебора без указания объекта вызовите из контекстного меню команду Отказ от перебора. Можно также нажать клавишу <Esc>.

Система вернется в режим выполнения команды, для которой указывался объект.


3.1.2.5. Использование буфера обмена

При работе с графическими документами нередко возникает необходимость в копировании или переносе некоторой части изображения в пределах одного документа или в другие документы.

Для этих целей в КОМПАС-3D используется собственный буфер обмена, а не стандартный буфер Windows.

Иногда (обычно при переносе фрагментов текста) использование буфера обмена Windows возможно. Указания на это даны в описаниях соответствующих операций.

Объем информации, который можно поместить в буфер обмена, не ограничен. Содержимое буфера сохраняется на диске в специальном системном файле. При новом копировании или вырезании в буфер его предыдущее содержимое уничтожается.

Буфер обмена позволяет быстро и удобно копировать или переносить чертежные объекты. Однако в тех случаях, когда требуется выполнить точный сдвиг или сложное копирование (например, по прямоугольной или концентрической сетке), используйте специальные команды редактирования (см. разделы 3.5.2 и 3.5.3).

Копирование и перенос информации через буфер возможен только между документами, открытыми в одном и том же приложении КОМПАС-3D.

В этом разделе:

3.1.2.5.1. Помещение объектов в буфер

3.1.2.5.2. Вставка из буфера


3.1.2.5.1. Помещение объектов в буфер

Помещение объектов в буфер может выполняться с одновременным удалением их из документа или без удаления.

В первом случае производится так называемое вырезание в буфер. Процесс, включающий в себя вырезание в буфер и вставку из буфера, называется переносом через буфер.

Во втором случае производится копирование в буфер. Процесс, включающий в себя копирование в буфер и вставку из буфера, называется копированием через буфер.

При копировании или вырезании в буфер его предыдущее содержимое удаляется.

Чтобы поместить объекты в буфер, выполните следующие действия.

1. Выделите все объекты (о способах выделения см. раздел 3.1.2), которые требуется поместить в буфер обмена.

2. Вызовите команду Редактор — Вырезать (для вырезания в буфер) или Редактор — Копировать (для копирования в буфер).

Вид курсора изменится.

3. Задайте точку, которая будет базовой для выделенного набора объектов.

Задание базовой точки не требуется, если выделены:

– объекты, принадлежащие разным видам чертежа,

– вид или несколько видов целиком.

За базовую точку в этих случаях автоматически принимается начало абсолютной системы координат (левый нижний угол листа чертежа).

Кроме того, указание базовой точки не нужно, если в буфер помещается фрагмент текста.


3.1.2.5.2. Вставка из буфера

Чтобы вставить объекты, содержащиеся в буфере обмена, в активный документ, вызовите команду Редактор — Вставить.

Если в буфере находятся объекты, принадлежавшие разным видам чертежа и/или виды целиком, то они будут немедленно вставлены в чертеж. Вставленные объекты размещаются в видах с теми же параметрами, что и исходные объекты.

Так как фрагмент не может содержать видов, в него невозможна вставка видов или объектов, принадлежавших разным видам.

Если в буфере находятся объекты, принадлежавшие фрагменту или одному виду чертежа, на экране отображается фантом вставляемых объектов, а на Панели свойств — элементы управления вставкой. Эти элементы представлены в таблице 3.1.4.

Табл. 3.1.4. Элементы управления вставкой из буфера

Элемент

Описание

Базовая точка

Координаты базовой точки вставляемых объектов.

Угол поворота

Угол поворота объектов вокруг базовой точки.

Масштаб

Коэффициент масштабирования объектов.

Режим

Группа переключателей, управляющая размещением объектов многослойной вставки. Доступна, если в буфере содержатся объекты, принадлежавшие разным слоям (о слоях см. раздел 3.6.6).

Активизация переключателя На текущий слой означает, что все изображение будет расположено на одном (текущем) слое активного документа.

Активизация переключателя На слои-источники означает, что в активном документе будут созданы недостающие слои для размещения объектов.

Выносные линии

Группа переключателей, управляющая масштабированием выносных линий и линий-выносок размеров (см. раздел 3.5.4.2.1)1.
  1. При копировании через буфер объекта, являющегося вставкой фрагмента (см. раздел 3.8.2), линии-выноски и выносные линии масштабируются, если при вставке этого фрагмента была включена опция Масштабировать выносные линии, и не масштабируются, если эта опция не была включена, т.е. в этом случае состояние кнопки Масштабирование выносных линий значения не имеет.

После фиксации базовой точки содержимое буфера обмена вставляется в документ.

Вы можете продолжать вставки объектов, размещая их в нужных местах документа и задавая нужный масштаб и угол поворота. Количество вставок из буфера, которое можно выполнить за один вызов команды, не ограничено.


3.1.3. Сетка. Ортогональное черчение

3.1. Общие приемы работы в графических документах

3.1.3. Сетка. Ортогональное черчение

В этом разделе:

3.1.3.1. Использование сетки

3.1.3.2. Привязка по сетке

3.1.3.3. Изображение сетки при мелких масштабах

3.1.3.4. Ортогональное черчение


3.1.3.1. Использование сетки

При работе с графическим документом или эскизом операции очень часто бывает удобным включить изображение сетки на экране и установить привязку к ее узлам. При этом курсор, перемещаемый мышью, начнет двигаться не плавно, а дискретно по узлам сетки. Такой режим работы можно сравнить с вычерчиванием изображения на листе миллиметровой бумаги.

Сетка не является частью документа и не выводится на бумагу.

Сетка может по-разному выглядеть в разных окнах, даже если это окна одного и того же документа. Возможна установка различных шагов сетки по ее осям, отрисовка сетки с узлами, а также назначение повернутой относительно текущей системы координат и непрямоугольной (искаженной) сетки.

Управление отображением сетки в активном окне осуществляется кнопкой Сетка на панели Текущее состояние.

Эта кнопка также служит индикатором отображения сетки в окне: нажатая кнопка означает, что сетка включена, отжатая — выключена.

Для управления сеткой служит специальное меню, вызываемое нажатием на кнопку со стрелкой, расположенную рядом с кнопкой Сетка.

Описание команд этого меню представлено в таблице 3.1.5.

Табл. 3.1.5. Команды управления сеткой
Команда | Описание
Настроить параметры | Позволяет настроить параметры сетки в активном окне. После вызова команды на экране появляется диалог настройки сетки (см. раздел 9.1.7.2).
Отображать параметры | Управляет отображением основных параметров сетки — расстояний между ее видимыми узлами1 по осям Х и Y текущей системы координат — на панели Текущее состояние (рис. 3.1.9)2. После вызова команды параметры сетки будут отображаться вне зависимости от того, включено или выключено изображение сетки.
Отображать параметры, если сетка активна | Управляет отображением основных параметров сетки на панели Текущее состояние 2. После вызова команды параметры сетки будут отображаться на панели, только если сетка включена.
  1. При мелком масштабе отображения не все точки сетки видны на экране (производится разрежение сетки), поэтому расстояние между соседними видимыми точками отличается от расстояния между точками, установленного в диалоге настройки параметров сетки.
    Если отображение сетки выключено, параметры сетки при любом масштабе совпадают с шагами сетки по осям Х и Y, установленными при настройке (см. раздел 9.1.7.2).
  2. Параметры сетки отображаются на панели, если она расположена горизонтально.

Рис. 3.1.9. Отображение параметров сетки на панели Текущее состояние


3.1.3.2. Привязка по сетке

Присутствие сетки на экране еще не говорит о том, что привязка курсора к ее точкам выполняется. Включение нужного варианта привязки выполняется отдельно (см. рис. 3.1.3).

Справедливо и обратное замечание: изображение сетки в окне может быть выключено, однако это не мешает выполнению привязки по сетке.

Глобальная привязка по сетке (как и любая другая глобальная привязка) действует только в том окне, в котором она была установлена.

Если постоянная привязка по сетке не нужна, отключите глобальную привязку по сетке.

В этом случае вы можете привязать курсор к узлу сетки, включив локальную привязку (см. раздел 3.1.1.2.2).


3.1.3.3. Изображение сетки при мелких масштабах

Если изображение сетки в окне включено, то каждый раз при изменении масштаба отображения (см. раздел 1.4.1.2) система будет учитывать это изменение при перерисовке сетки. Когда масштаб становится настолько мелким, что сетку с заданным шагом невозможно корректно отрисовать из-за ее плотности, на экран выводится разреженная сетка.

Предел плотности сетки определяется значением, заданным в качестве Минимального расстояния между точками (см. раздел 9.1.7.2). До тех пор, пока количество пикселов между точками больше минимального, разрежение сетки не происходит. При дальнейшем уменьшении масштаба сетка разреживается.

Разреживание сетки производится с учетом шага разреживания, установленного при ее настройке.

Если была установлена кратность Из ряда (см. там же), то шаг точек сетки будет кратен числам из ряда 2, 5, 10, 20, 50, 100, 200, 500, 1000, 2000, 5000, 10000, 20000, 50000, 100000, 500000. Это означает, что при установке такого масштаба отображения, который не позволяет корректно отображать каждую точку, на экране будет показываться каждая вторая точка сетки; при дальнейшем уменьшении масштаба — каждая пятая, затем десятая и так далее.

Если же был установлен Кратный шаг разреживания (см. там же), то шаг точек сетки будет постоянно кратен заданному числу. Например, задание шага разреживания, кратного 2, означает, что при уменьшении масштаба изображения на экране сначала показывается каждая вторая точка сетки, затем — каждая четвертая, затем — шестая и т.д.


3.1.3.4. Ортогональное черчение

Режим ортогонального черчения служит для быстрого создания объектов или их частей, ортогональных осям текущей системы координат.

Включение и отключение этого режима производится кнопкой Ортогональное черчение, расположенной на панели Текущее состояние. Другой способ управления ортогональным режимом — нажатие клавиши <F8>.

Указанная кнопка служит также индикатором режима ортогонального черчения: нажатая кнопка означает, что ортогональное черчение включено, отжатая — выключено.

Если в процессе построения объекта требуется временно отключить (или включить) этот режим, нажмите и удерживайте клавишу <Shift>.

Ортогональный режим используется при вычерчивании горизонтальных и вертикальных отрезков, обозначений ступенчатых разрезов, перпендикулярных друг другу участков ответвлений допуска формы и в других случаях.

Чтобы познакомиться с работой в режиме ортогонального черчения, выполните следующие действия.

1. Создайте новый графический документ (лист или фрагмент). Убедитесь, что режим ортогонального черчения отключен. При необходимости выключите его.

2. Вызовите команду Инструменты — Геометрия — Отрезки — Отрезок и укажите курсором первую точку отрезка.

3. Перемещайте курсор по полю документа и наблюдайте за фантомом отрезка.

Конечная точка отрезка совпадает с курсором, ее можно зафиксировать в любом месте чертежа, нажав левую клавишу мыши.

4. Включите режим ортогонального черчения.

5. Перемещайте курсор.

Теперь фантом отрезка строго горизонтален или вертикален в зависимости от направления, ближе к которому находится курсор.

6. Зафиксируйте конечную точку отрезка.

7. Задайте начальную точку другого отрезка.

8. Перемещайте курсор по полю чертежа. Убедитесь, что фантом отрезка строится ортогонально осям текущей системе координат.

9. Нажмите и удерживайте клавишу <Shift> и продолжайте перемещать курсор.

Ортогональный режим отключился, и отрезок строится в обычном режиме, следуя за перемещением курсора.

10. Отпустите клавишу <Shift>. Убедитесь, что система вновь перешла в ортогональный режим.

11. Создайте наклонную локальную систему координат (см. раздел 3.1.4.2.1).

12. Введите несколько отрезков, указывая курсором их начальные и конечные точки. Убедитесь, что отрезки создаются ортогонально осям координат текущей ЛСК.


3.1.4. Системы координат в графическом документе

3.1. Общие приемы работы в графических документах

3.1.4. Системы координат в графическом документе

В этом разделе:

3.1.4.1. Абсолютная система координат

3.1.4.2. Локальные системы координат

3.1.4.2.1. Создание локальной системы координат

3.1.4.2.2. Управление локальными системами координат


3.1.4.1. Абсолютная система координат

Каждый чертеж имеет абсолютную систему координат. Ее начало всегда находится в левом нижнем углу формата (внешней рамки). Для фрагмента понятие абсолютной системы координат не имеет смысла (нет явных габаритов, как в случае чертежа), поэтому начало системы координат при создании нового фрагмента отображается в центре окна.


3.1.4.2. Локальные системы координат

Использование одной только абсолютной системы координат не всегда удобно. При проектировании часто возникают ситуации, когда нужно отмерять расстояния или углы не от левого нижнего угла листа, а от какой-либо другой точки.

Для реализации такого способа задания параметров объектов в КОМПАС-3D используются локальные системы координат (ЛСК). Назначив ЛСК в нужных точках проектируемой детали или узла, вы можете выбрать любую из них в качестве текущей. При этом все координаты будут рассчитываться и отображаться именно в этой текущей системе. После того как ЛСК перестанет быть нужной, вы можете удалить ее из документа.

В этом разделе:

3.1.4.2.1. Создание локальной системы координат

3.1.4.2.2. Управление локальными системами координат


3.1.4.2.1. Создание локальной системы координат

Чтобы создать в документе локальную систему координат, вызовите команду Вставка — Локальная СК или нажмите кнопку Локальная СК на панели Текущее состояние.

На Панели свойств появятся элементы для работы с локальными системами координат. Эти элементы представлены в таблице 3.1.6.

Табл. 3.1.6. Элементы Панели свойств для работы с ЛСК
Элемент | Описание
Выбор ЛСК | Панель, содержащая список ЛСК, имеющихся в текущем документе.
Имя ЛСК | Имя выделенной в списке ЛСК. Вы можете ввести в это поле любое название для любой ЛСК.
Начало отсчета локальной СК | Поля координат точки начала выделенной ЛСК. Координаты этой точки задаются в текущей системе координат.
Угол наклона оси Х локальной СК | Поле угла поворота оси Х выделенной ЛСК. Этот угол отсчитывается от оси Х текущей системы координат.
Настройка... | Кнопка, позволяющая настроить отрисовку ЛСК. После нажатия этой кнопки на экране появляется диалог настройки ЛСК (см. раздел 9.1.7.10).


3.1.4.2.2. Управление локальными системами координат

Чтобы настроить имеющиеся в документе ЛСК, сделать какую-либо из них текущей или удалить, вызовите команду Вставка — Локальная СК или нажмите кнопку Локальная СК на панели Текущее состояние.

На Панели свойств появятся элементы, представленные в таблице 3.1.6.

– Чтобы установить какую-либо ЛСК в качестве текущей, выделите ее в списке (при этом она отрисовывается на экране) и нажмите кнопку Текущая локальная СК, расположенную в окне Выбор ЛСК. Текущая ЛСК отмечается в списке «галочкой».
Если ни одна из ЛСК не выбрана в качестве текущей, то текущей является абсолютная система координат.

– Чтобы удалить выделенную ЛСК, нажмите кнопку Удалить локальную СК.

– Чтобы создать новую ЛСК, нажмите кнопку Новая локальная СК.

Кроме того, выделив в списке любую ЛСК, вы можете ввести для нее новое имя, координаты точки-начала отсчета и угол поворота.

Вы можете отменить любое из вышеперечисленных действий, воспользовавшись кнопкой Отменить на панели Стандартная.


3.1.5. Управление порядком отрисовки объектов

3.1. Общие приемы работы в графических документах

3.1.5. Управление порядком отрисовки объектов

При отображении и печати графических документов учитывается порядок отрисовки объектов. Умолчательный порядок отрисовки определяется системой автоматически в зависимости от типа объекта: вначале отрисовываются штриховки и заливки, поверх них — вспомогательные прямые, затем отрезки, окружности, эллипсы и так далее. В результате получается, что объекты перекрывают друг друга в порядке отрисовки.

Эффект перекрытия особенно заметен при работе с разноцветными заливками и штриховками, а также с разноцветными линиями большой толщины.

Например, в документе созданы прямоугольник, штриховка, линейный размер. По умолчанию они располагаются так: штриховка, прямоугольник, размер, т.е. штриховка перекрывается прямоугольником и размером, а прямоугольник — только размером.

В любой момент работы с документом вы можете изменить умолчательное расположение объектов друг относительно друга. Для этого выделите объект, размещение которого требуется изменить, и вызовите нужную команду из меню Редактор — Порядок. Описание этих команд представлено в таблице 3.1.7.

Табл. 3.1.7. Команды управления видимостью объектов
Команда | Описание
Впереди всех | Помещает выделенный объект перед всеми объектами. В результате перемещенный объект будет перекрывать все остальные.
Позади всех | Помещает выделенный объект за всеми объектами. В результате перемещенный объект будет перекрываться всеми остальными.
Перед объектом | Помещает выделенный объект перед указанным. После вызова команды необходимо указать объект, перед которым требуется разместить выделенный. В результате он будет перекрывать указанный объект и все предыдущие объекты.
За объектом | Помещает выделенный объект за указанным. После вызова команды необходимо указать объект, за которым требуется разместить выделенный. В результате он будет перекрываться указанным объектом и всеми последующими объектами.
На уровень вперед | Меняет местами выделенный объект и объект, находящийся перед ним.
На уровень назад | Меняет местами выделенный объект и объект, находящийся за ним.

Команды управления видимостью доступны также в контекстном меню выделенного объекта.

Команды изменения видимости можно применять сразу к нескольким выделенным объектам. При этом смежные объекты (лежащие на соседних уровнях) перемещаются как единый объект.

При попытке выделить мышью (см. раздел 3.1.2.1) один из наложенных друг на друга объектов подсвечивается самый ближний из них. Для выделения объектов, расположенных под этим объектом, воспользуйтесь командой перебора (см. раздел 3.1.2.4).

При настройке видимости объектов графических документов необходимо иметь в виду следующие особенности.

– Изменение видимости доступно для объектов, принадлежащих текущему и активным слоям (подробнее о слоях см. раздел 3.6.6) фрагмента или текущего вида (подробнее о видах см. раздел 3.6.4) чертежа.

– Видимость объектов, принадлежащих разным видам, определяется системой автоматически: виды, созданные позже, считаются расположенными впереди видов, созданных раньше. Таким образом, например, объекты самого первого — системного — вида чертежа перекрываются объектами всех остальных видов. Изменение относительного расположения видов невозможно.

– Всегда находятся впереди всех остальных следующие объекты чертежа:

• внешняя и внутренняя рамки,

• основная надпись,

• технические требования,

• неуказанная шероховатость,

• спецификация на листе.

– Объекты, образующие вставленный фрагмент (см. раздел 3.8.2.1), располагаются друг относительно друга так, как во фрагменте-источнике. Вставка фрагмента занимает в главном документе один уровень видимости. Поэтому при работе с главным документом изменить порядок объектов, составляющих вставку, невозможно. Для этого необходимо редактирование самого вставленного фрагмента.

– Макроэлемент (см. раздел 3.8.5), как и вставка фрагмента, занимает один уровень видимости. При этом сразу после создания макроэлемент располагается впереди всех остальных объектов. Объекты внутри макроэлемента располагаются друг относительно друга так же, как и до объединения


3.1.6. Создание объекта по образцу

3.1. Общие приемы работы в графических документах

3.1.6. Создание объекта по образцу

Одним из способов создания нового графического объекта является создание объекта со свойствами уже существующего объекта — образца. Для создания объекта, аналогичного существующему, служит команда Объект по образцу.

При выполнении команды Объект по образцу в новый объект копируются свойства объекта-образца. Образцами могут быть геометрические объекты (кроме контуров и дуг эллипсов), обозначения и размеры. Набор копируемых свойств зависит от типа объекта-образца.

Пример: в документе существует заливка внутри круга. Команда Объект по образцу позволяет создать внутри другого контура заливку с такими же свойствами (тип, цвет, прозрачность и т.д.), что и существующая.

Чтобы создать объект по образцу:

1. Нажмите кнопку Объект по образцу на инструментальной панели Геометрия (см. рис. 3.2.1) или выберите ее название из меню Инструменты.

Курсор изменит вид.

2. Укажите объект — образец для копирования свойств. Для этого установите курсор на объекте. Когда выбранный объект подсветится, щелкните левой кнопкой мыши.

После указания объекта автоматически запускается команда, соответствующая типу указанного объекта-образца. Например, если в качестве образца был указан отрезок, то запускается команда Отрезок.

3. Задайте параметры нового объекта. Так, для отрезка требуется задать вершины. Стиль линии отрезка будет таким же, как у отрезка-образца.

4. Завершите процесс создания объекта.

Команду Объект по образцу можно прервать до запуска команды, соответствующей типу указанного объекта-образца, одним из следующих способов:

– нажать кнопку Прервать команду на Панели специального управления,

– вызвать команду Прервать команду из контекстного меню,

– нажать клавишу <Esc>.

Если перед вызовом команды Объект по образцу объект-образец уже был выделен, то после вызова команды сразу запускается команда, соответствующая типу объекта-образца.


3.2. Геометрические объекты

В этом разделе:

3.2.1. Общие сведения о геометрических объектах

3.2.1.1. Стили геометрических объектов

3.2.1.1.1. Выделение кривых по стилю

3.2.1.1.2. Изменение стиля объектов

3.2.1.2. Список стилей линий

3.2.1.2.1. Менеджер стилей линий

3.2.2. Точки

3.2.2.1. Произвольная точка

3.2.2.2. Точки по кривой

3.2.2.3. Точки пересечений двух кривых

3.2.2.4. Все точки пересечений кривой

3.2.2.5. Точка на заданном расстоянии

3.2.3. Вспомогательные прямые

3.2.3.1. Произвольная прямая

3.2.3.1.1. Простановка точек пересечений

3.2.3.2. Горизонтальная прямая

3.2.3.3. Вертикальная прямая

3.2.3.4. Параллельная прямая

3.2.3.5. Перпендикулярная прямая

3.2.3.6. Касательная прямая через внешнюю точку

3.2.3.7. Касательная прямая через точку кривой

3.2.3.8. Прямая, касательная к двум кривым

3.2.3.9. Биссектриса

3.2.4. Отрезки

3.2.4.1. Отрезок

3.2.4.2. Параллельный отрезок

3.2.4.3. Перпендикулярный отрезок

3.2.4.4. Касательный отрезок из внешней точки

3.2.4.5. Касательный отрезок через точку кривой

3.2.4.6. Отрезок, касательный к двум кривым

3.2.5. Окружности

3.2.5.1. Окружность

3.2.5.1.1. Окружность с осями

3.2.5.2. Окружность по трем точкам

3.2.5.3. Окружность с центром на объекте

3.2.5.4. Окружность, касательная к кривой

3.2.5.5. Окружность, касательная к двум кривым

3.2.5.6. Окружность, касательная к трем кривым

3.2.5.7. Окружность по двум точкам

3.2.6. Эллипсы

3.2.6.1. Эллипс

3.2.6.2. Эллипс по диагонали габаритного прямоугольника

3.2.6.3. Эллипс по центру и вершине габаритного прямоугольника

3.2.6.4. Эллипс по центру, середине стороны и вершине описанного параллелограмма

3.2.6.5. Эллипс по трем вершинам описанного параллелограмма

3.2.6.6. Эллипс по центру и трем точкам

3.2.6.7. Эллипс, касательный к двум кривым

3.2.7. Дуги

3.2.7.1. Дуга

3.2.7.1.1. Выбор направления дуги

3.2.7.2. Дуга по трем точкам

3.2.7.3. Дуга, касательная к кривой

3.2.7.4. Дуга по двум точкам

3.2.7.5. Дуга по двум точкам и углу раствора

3.2.7.6. Дуги эллипсов

3.2.8. Прямоугольники и многоугольники

3.2.8.1. Прямоугольник

3.2.8.2. Прямоугольник по трем точкам

3.2.8.3. Многоугольник

3.2.9. Ломаная, сплайны, конические кривые

3.2.9.1. Ломаная

3.2.9.1.1. Таблица Координаты вершин

3.2.9.1.2. Редактирование характерных точек (при создании или редактировании объекта)

3.2.9.2. Сплайн по полюсам

3.2.9.3. Сплайн по точкам

3.2.9.3.1. Управление формой сплайна

3.2.9.3.2. Способы формирования параметров точек сплайна

3.2.9.4. Коническая кривая

3.2.10. Непрерывный ввод объектов

3.2.10.1. Создание объектов последовательности

3.2.10.2. Завершение ввода объектов

3.2.10.3. Стиль линии при непрерывном вводе объектов

3.2.11. Линия

3.2.11.1. Общий порядок построения объектов линии

3.2.11.2. Способы построения первого отрезка

3.2.11.2.1. Параллельно или перпендикулярно объекту

3.2.11.2.2. Касательно к объекту

3.2.11.2.3. Касательно к одному объекту и параллельно другому

3.2.11.2.4. Посередине между двумя параллельными прямыми

3.2.11.2.5. Касательно к двум объектам

3.2.11.2.6. На биссектрисе угла

3.2.11.3. Способы построения последующих отрезков

3.2.11.3.1. Параллельно или перпендикулярно объекту

3.2.11.3.2. Касательно к объекту

3.2.11.4. Способы построения первой дуги

3.2.11.4.1. Касательно к объекту

3.2.11.4.2. Произвольная

3.2.11.5. Способы построения последующих дуг

3.2.11.5.1. Касательно к объекту

3.2.11.5.2. По нормали к предыдущему сегменту

3.2.11.5.3. Произвольная

3.2.12. Мультилиния

3.2.12.1. Общие сведения

3.2.12.2. Термины и определения

3.2.12.3. Создание мультилинии

3.2.12.4. Линии мультилинии

3.2.12.5. Шаблон мультилинии

3.2.12.6. Базовая линия

3.2.12.6.1. Прямолинейный и дуговой сегменты

3.2.12.6.2. Сегмент по объекту

3.2.12.6.3. Модификация базовой линии

3.2.12.7. Способы обхода угла в вершине

3.2.12.7.1. Обход срезом

3.2.12.7.2. Обход скруглением

3.2.12.7.3. Обход скруглением с одинаковым радиусом

3.2.12.8. Ограничители мультилинии

3.2.12.8.1. Выбор вида ограничителя мультилинии

3.2.12.8.2. Задание параметров ограничителя

3.2.12.9. Режимы работы с мультилинией

3.2.12.10. Редактирование вершины

3.2.12.10.1. Операция редактирования вершины

3.2.12.10.2. Операция вставки вершины

3.2.12.11. Удаление и восстановление участков линий мультилиний

3.2.12.12. Особенности редактирования мультилинии

3.2.13. Штриховка и заливка

3.2.13.1. Задание границ

3.2.13.1.1. Ручное рисование границ

3.2.13.1.2. Обход границы по стрелке

3.2.13.2. Штриховка

3.2.13.2.1. Построение штриховки

3.2.13.2.2. Параметры штриховки

3.2.13.3. Заливка

3.2.13.3.1. Типы заливки

3.2.13.3.2. Построение заливки

3.2.13.3.3. Параметры заливки

3.2.13.3.4. Дополнительные переходы цвета и уровни прозрачности заливки

3.2.13.3.5. Редактирование заливки

3.2.14. Составные объекты

3.2.14.1. Контур

3.2.14.2. Эквидистанта кривой

3.2.14.2.1. Параметры эквидистанты

3.2.14.3. Эквидистанта по стрелке

3.2.15. Фаски и скругления

3.2.15.1. Фаска

3.2.15.1.1. Управление усечением объектов

3.2.15.1.2. Создание условного пересечения усекаемых объектов

3.2.15.2. Фаска на углах объекта

3.2.15.3. Скругление

3.2.15.4. Скругление на углах объекта


3.2.1. Общие сведения о геометрических объектах

3.2. Геометрические объекты

3.2.1. Общие сведения о геометрических объектах

В системе КОМПАС-3D возможно построение геометрических объектов следующих типов:

– точки,

– прямые,

– отрезки,

– окружности,

– эллипсы,

– дуги окружностей и эллипсов,

– прямоугольники,

– правильные многоугольники,

– ломаные,

– сплайны (NURBS, кривые Безье),

– конические кривые,

– мультилинии,

– штриховки и заливки,

– эквидистанты,

– контуры.

Команды создания этих объектов сгруппированы в меню Инструменты — Геометрия, а кнопки для вызова команд — на панели Геометрия (рис. 3.2.1).

Рис. 3.2.1. Панель Геометрия

Если какие-либо действия выполняются одинаково в однородных командах, то описание этих действий приведено только один раз при первом знакомстве с ними.

В этом разделе:

3.2.1.1. Стили геометрических объектов

3.2.1.1.1. Выделение кривых по стилю

3.2.1.1.2. Изменение стиля объектов

3.2.1.2. Список стилей линий

3.2.1.2.1. Менеджер стилей линий


3.2.1.1. Стили геометрических объектов

Внешний вид геометрического объекта определяется его стилем.

Вместе с КОМПАС-3D поставляются системные стили точек, линий и штриховок. Системные стили линий и штриховок соответствуют стандартным. Возможно создание пользовательских стилей линий и штриховок.

Одним из системных стилей точек и кривых является Вспомогательный стиль. Он предназначен для объектов, выполняющих вспомогательные функции — точек и линий, создаваемых при разметке, во время предварительных построений и т.п. После того как такие объекты станут не нужны, их удаляют.

Если вспомогательные объекты имеют одноименный стиль, то всех их можно быстро удалить, воспользовавшись командой Редактор — Удалить — Вспомогательные кривые и точки (см. раздел 3.5.8.1). Поэтому, если объект относится к вспомогательным, то при его построении рекомендуется использовать соответствующий стиль. Если же создаваемый объект не должен удаляться заодно со вспомогательными, то для него следует выбрать другой стиль.

При создании геометрического объекта текущий стиль отображается в одноименном поле на Панели свойств. Чтобы изменить стиль, разверните список Стиль и выберите в нем нужную строку (рис. 3.2.2).

Рис. 3.2.2. Выбор стиля кривой

Перечень и порядок следования стилей линий в списке Стиль, а также умолчательный стиль определяются настройкой списка стилей линий (см. раздел 9.2.6.6).

При создании прямых (см. раздел 3.2.3) им автоматически присваивается стиль Вспомогательная. Выбор другого стиля невозможен.

Внешний вид точек и линий, имеющих системные стили, зависит от настройки системы. При необходимости вы можете ее изменить (см. разделы 9.1.7.4 и 9.1.7.5).

В этом разделе:

3.2.1.1.1. Выделение кривых по стилю

3.2.1.1.2. Изменение стиля объектов


3.2.1.1.1. Выделение кривых по стилю

Чтобы выделить в документе все кривые, имеющие один стиль, выполните следующие действия.

1. Вызовите команду Выделить — По стилю кривой.... На экране появится диалог с перечнем использованных в текущем документе стилей линий.

2. Выберите в диалоге нужный стиль (стили).

Объекты, имеющие указанный стиль (стили), будут выделены.


3.2.1.1.2. Изменение стиля объектов

Чтобы изменить стиль существующего геометрического объекта (объектов), выполните следующие действия.

1. Выделите объект (объекты), стили которых требуется изменить (о способах выделения см. раздел 3.1.2).

2. Вызовите команду Сервис — Изменить стиль. На экране появится диалог замены стиля (рис. 3.2.3). Количество вкладок диалога зависит от того, какие типы объектов (кривые, точки, штриховки, тексты) выделены.

3. Настройте параметры и подтвердите замену стилей.

Об изменении стиля штриховок в ассоциативных видах чертежа см. раздел 3.7.2.7.1.

Рис. 3.2.3. Диалог замены стилей


3.2.1.2. Список стилей линий

В каждом графическом документе хранится список стилей линий — информация о том, какие стили могут быть использованы в этом документе.

По умолчанию список содержит только системные стили линий. При необходимости пользователь может добавить в список стили из библиотек или наборов стилей.

К списку стилей линий можно применить фильтр стилей, чтобы ограничить набор стилей, отображающийся в списке Стиль на Панели свойств (см. рис. 3.2.2) при создании геометрических объектов. Рекомендуется включить отображение только для нескольких наиболее часто применяемых стилей. При необходимости, используя строку Другой стиль... списка Стиль, можно выбрать для отрисовки объекта любой другой стиль или создать новый. Настройка фильтра стилей линий описана в разделе 9.2.6.6.1.

В этом разделе:

3.2.1.2.1. Менеджер стилей линий


3.2.1.2.1. Менеджер стилей линий

Менеджер стилей линий (рис. 3.2.4) служит для управления списком стилей линий текущего или новых документов.

Рис. 3.2.4. Менеджер стилей линий при настройке списка стилей линий текущего документа

По умолчанию Менеджер стилей линий открывается в свернутом виде, т.е. отображается

только его левая часть. Она содержит список стилей линий. Стили отмечаются значками:

– системный стиль,

– внедренный в документ стиль,

– библиотечный стиль.

В списке стилей линий текущего документа к значкам может добавляться «галочка», показывающая, что стиль задействован в документе, т.е. является используемым. Например, на рисунке 3.2.4 используемыми являются стили Основная и Вспомогательная.

Правая часть Менеджера стилей линий появляется после нажатия кнопки Добавить стили. Эта часть служит для выбора библиотеки (или набора) стилей и включения стилей из нее в список стилей документа.

Элементы управления Менеджера стилей линий представлены в таблице 3.2.1.

Табл. 3.2.1. Элементы управления Менеджера стилей линий

Элемент

Описание

Создать

Кнопка, позволяющая создать стиль. Новый стиль добавляется в список стилей документов как внедренный стиль.

После нажатия этой кнопки на экране появляется диалог создания или редактирования стиля кривой.

Редактировать

Кнопка, позволяющая отредактировать выбранный стиль.

Доступна, если в списке стилей документа выбран внедренный стиль.

После нажатия этой кнопки на экране появляется диалог создания или редактирования стиля кривой.

Удалить

Кнопка, позволяющая удалить выбранные стили.

Доступна, если в списке стилей документа выбраны не используемые стили — внедренные и/или библиотечные.

После нажатия этой кнопки на экране появляется диалог, в котором вы можете подтвердить удаление или отказаться от него.

Фильтр

Список фильтров для списка стилей документа:

– Показать все,

– Системные стили,

– Внедренные стили,

– Библиотечные стили,

– Используемые стили,

– Не используемые стили.

Чтобы применить фильтр, выберите его из списка Фильтр. В списке стилей останутся только те стили, которые соответствуют фильтру.

Добавить стили

Кнопка, позволяющая добавить в список стилей документа стили из библиотеки или набора. После ее нажатия в Менеджере стилей линий появляется дополнительная область с элементами управления.

Для закрытия этой области следует нажать кнопку Добавить стили повторно.

Показать библиотеку

Кнопка для выбора библиотеки стилей линий. После ее нажатия на экране появляется диалог, в котором следует указать файл библиотеки стилей линий (*.lcs) и нажать кнопку Открыть.

Перечень библиотечных стилей линий появится в окне просмотра.

Показать набор

Кнопка для выбора набора стилей линий. После ее нажатия на экране появляется диалог, в котором следует указать имя набора и нажать кнопку Выбрать.

Перечень стилей линий набора появится в окне просмотра.

Добавить библиотечный стиль

Позволяет добавить в список стилей документа один или несколько библиотечных стилей.

Доступна, если в списке библиотечных стилей имеются выделенные стили. После нажатия этой кнопки выбранные стили включаются в список документа как библиотечные.

Библиотечные стили сохраняют связь с файлами библиотек, откуда они были добавлены в документ.

Внедрить стиль в документ

Позволяет внедрить в документ один или несколько библиотечных стилей или стилей из набора.

Доступна, если в списке библиотечных стилей или стилей из набора имеются выделенные стили. После нажатия этой кнопки выбранные стили включаются в список документа как внедренные.

Стили, внедренные в документ из библиотек, не сохраняют связей с файлами этих библиотек.

Библиотечные стили с разорванной связью

Разрыв связей библиотечных стилей документа с библиотекой происходит в следующих случаях:

– перемещение в другую папку файла библиотеки, из которой стили были добавлены в документ;

– удаление соответствующих стилей из библиотеки.

При открытии документа, в списке стилей которого присутствуют стили с разорванной связью, на экране появляется сообщение о том, что стили или библиотеки стилей не найдены.

Библиотечные стили с разорванной связью отмечаются в Менеджере стилей линий восклицательным знаком в красном кружке.

Восстановление связей возможно одним из следующих способов:

– разместите файл библиотеки по прежнему пути, после чего закройте и откройте документ — библиотека и стили в ней будут найдены;

– не перемещая библиотеку, откройте ее в Менеджере стилей линий и повторно добавьте стили из нее в список стилей документа — прежний путь к файлу библиотеки будет заменен текущим.

Если в списке несколько библиотечных стилей с разорванной связью, то для удобства работы можно воспользоваться фильтром Библиотечные, с разорванной связью.

Если восстановление библиотеки или стилей в ней невозможно, отредактируйте объекты, использующие стили с разорванной связью, назначив им другие стили, а затем удалите из списка стилей документа стили с разорванной связью. Можно действовать, например, следующим образом.

1. Откройте Менеджер стилей линий, запомните название стиля, потерявшего связь с библиотекой, и закройте Менеджер стилей линий.

2. Выделите в документе объекты, использующие этот стиль, с помощью команды Выделить — По стилю кривой...

3. Замените стиль выделенных объектов другим (см. раздел 3.2.1.1.2).

4. Откройте Менеджер стилей линий, удалите стиль, потерявший связь с библиотекой, и закройте Менеджер стилей линий.

Линии, использующие стиль с разорванной связью, сохраняют свое начертание, поэтому можно и не менять их стиль (например, если стилей для замены нет). Однако, в этом случае стиль с разорванной связью будет невозможно удалить, и при открытии документа будет выдаваться предупреждение.


3.2.2. Точки

3.2. Геометрические объекты

3.2.2. Точки

Система КОМПАС-3D предоставляет разнообразные способы простановки точек, а также несколько стилей для их оформления. Это позволяет использовать точки не только в качестве вспомогательных элементов, но и в качестве самостоятельных геометрических объектов.

В этом разделе:

3.2.2.1. Произвольная точка

3.2.2.2. Точки по кривой

3.2.2.3. Точки пересечений двух кривых

3.2.2.4. Все точки пересечений кривой

3.2.2.5. Точка на заданном расстоянии


3.2.2.1. Произвольная точка

Чтобы построить произвольно расположенную точку, вызовите команду Точка.

Задайте положение точки.


3.2.2.2. Точки по кривой

Чтобы построить несколько точек, разбивающих какую-либо кривую на равные участки, вызовите команду Точки по кривой.

Введите количество участков, на которые требуется разбить кривую, в соответствующее поле на Панели свойств.

Укажите кривую для простановки точек.

Если кривая не замкнута, точки будут построены сразу после ее указания. Первая точка будет совпадать с начальной точкой кривой, последняя — с конечной.

Если кривая замкнута, то после ее указания требуется задать положение первой точки на ней (определить точку т).

Рис. 3.2.5. Пример деления кривых (замкнутой и незамкнутой) на равные части

Если указанная точка не принадлежит выбранной кривой, то положение первой точки будет определяться проекцией указанной точки на кривую. Для точного позиционирования курсора воспользуйтесь привязками (см. раздел 3.1.1).

Если требуется «разрезать» кривую на несколько равных частей без простановки точек, воспользуйтесь командой Разбить кривую на N частей (см. раздел 3.5.6.2).


3.2.2.3. Точки пересечений двух кривых

Чтобы построить точки в местах пересечений кривых, вызовите команду Точки пересечений двух кривых.

Укажите первую кривую для поиска пересечений.

Кнопка Указать заново позволяет сменить первую кривую.

Затем укажите вторую кривую.

В местах пересечений заданных кривых автоматически создаются точки.

Рис. 3.2.6. Пример простановки точек пересечений эллипса и окружности


3.2.2.4. Все точки пересечений кривой

Чтобы построить точки в местах всех пересечений указанной кривой с другими кривыми вызовите команду Все точки пересечений кривой.

Укажите кривую для поиска пересечений.

После этого автоматически будут созданы точки в местах ее пересечения с другими кривыми, расположенными в текущих и активных видах (о видах чертежа см. раздел 3.6.5.2) и слоях (о слоях см. раздел 3.6.6).

Рис. 3.2.7. Пример простановки всех точек пересечений эллипса с двумя кривыми

Все точки пересечений вспомогательной прямой можно проставить сразу при ее создании, используя переключатель Режим (см. раздел 3.2.3.1.1).


3.2.2.5. Точка на заданном расстоянии

Чтобы построить точки на кривой, находящиеся на заданном расстоянии от выбранной точки на этой кривой (базовой точки) и друг от друга, вызовите команду Точка на заданном расстоянии.

Введите количество точек, которое требуется создать, в соответствующее поле на Панели свойств.

Укажите кривую для простановки точек.

Кнопка Указать заново позволяет выбрать другую кривую для простановки точек.

Укажите базовую точку на кривой — точку т.

Если указанная точка не принадлежит выбранной кривой, то положение базовой точки будет определяться проекцией указанной точки на кривую. Для точного позиционирования курсора воспользуйтесь привязками (см. раздел 3.1.1).

В поле Расстояние на Панели свойств введите расстояние между базовой точкой и первой создаваемой точкой. Если создается несколько точек, то указанное значение будет определять также расстояние между ними.

При перемещении курсора в разные стороны от базовой точки на экране отображаются фантомы точки (точек), которые могут быть построены. Зафиксируйте нужный фантом.

Рис. 3.2.8. Пример простановки трех точек вдоль дуги на расстоянии 5 мм от базовой точки


3.2.3. Вспомогательные прямые

3.2. Геометрические объекты

3.2.3. Вспомогательные прямые

Прямые являются аналогом тонких линий, которые конструктор использует при черчении на кульмане. Они нужны для предварительных построений, по которым затем формируется окончательный контур детали, а иногда — для задания проекционной связи между видами.

Прямые имеют стиль Вспомогательная, его изменение невозможно.

Вспомогательные прямые (а также другие кривые со стилем линии Вспомогательная) не выводятся на бумагу при печати документов.

В этом разделе:

3.2.3.1. Произвольная прямая

3.2.3.1.1. Простановка точек пересечений

3.2.3.2. Горизонтальная прямая

3.2.3.3. Вертикальная прямая

3.2.3.4. Параллельная прямая

3.2.3.5. Перпендикулярная прямая

3.2.3.6. Касательная прямая через внешнюю точку

3.2.3.7. Касательная прямая через точку кривой

3.2.3.8. Прямая, касательная к двум кривым

3.2.3.9. Биссектриса


3.2.3.1. Произвольная прямая

Чтобы построить произвольно расположенную прямую, вызовите команду Вспомогательная прямая.

Задайте первую точку, через которую должна проходить прямая — т1.

– Если известно положение второй точки, принадлежащей прямой (т2), задайте ее. Угол наклона прямой (угол между прямой и осью абсцисс текущей системы координат) будет определен автоматически.

Рис. 3.2.9. Построение прямой по двум точкам

– Если известен угол наклона создаваемой прямой, введите его в соответствующее поле на Панели свойств.

В этом разделе:

3.2.3.1.1. Простановка точек пересечений


3.2.3.1.1. Простановка точек пересечений

Во время вспомогательных построений бывает нужно отметить точки пересечения прямых друг с другом и с остальными объектами.

По умолчанию простановка этих точек отключена и в группе Режим активен переключатель Не ставить точки пересечения. Чтобы включить формирование точек, активизируйте переключатель Ставить точки пересечения.

Если режим простановки точек пересечений включен, то при создании новой вспомогательной прямой система будет автоматически проставлять точки пересечения этой прямой со всеми графическими объектами, лежащими в активных слоях текущего вида (см. раздел 3.6.5.1).

Рис. 3.2.10. Построение вспомогательных прямых а) с простановкой, б) без простановки вспомогательных точек
а) | б)

Стиль автоматически проставленных точек — Вспомогательная.

При необходимости их можно удалить одной командой вместе с другими вспомогательными элементами (см. раздел 3.5.8.1).

Если требуется отметить не все точки пересечения прямой, а только точки ее пересечения с некоторыми объектами, воспользуйтесь командой Точки пересечений двух кривых (см. раздел 3.2.2.3).


3.2.3.2. Горизонтальная прямая

Чтобы построить горизонтальную прямую, вызовите команду Горизонтальная прямая.

Задайте точку, через которую должна пройти прямая.

Горизонтальной считается прямая, параллельная оси абсцисс текущей системы координат. Поэтому, если вы построите горизонтальную прямую в виде, система координат которого повернута относительно абсолютной системы координат, эта прямая не будет параллельна горизонтальным сторонам листа.


3.2.3.3. Вертикальная прямая

Чтобы построить вертикальную прямую, вызовите команду Вертикальная прямая.

Задайте точку, через которую должна пройти прямая.

Вертикальной считается прямая, параллельная оси ординат текущей системы координат. Поэтому, если вы построите вертикальную прямую в виде, система координат которого повернута относительно абсолютной системы координат, эта прямая не будет параллельна вертикальным сторонам листа.


3.2.3.4. Параллельная прямая

Чтобы построить прямую, параллельную прямолинейному объекту, вызовите команду Параллельная прямая.

К прямолинейным объектам относятся:

– вспомогательные прямые,

– отрезки (в том числе в составе ломаных, многоугольников, контуров),

– размерная и выносные линии размеров,

– линии таблиц.

Укажите прямолинейный объект, параллельно которому должна пройти прямая.

Задайте расстояние от прямолинейного объекта до параллельной прямой. Это можно сделать двумя способами:

– введите значение расстояния в соответствующее поле на Панели свойств,

– задайте точку, через которую должна пройти создаваемая прямая.

По умолчанию система предлагает фантомы прямых, расположенных на заданном расстоянии по обе стороны от прямолинейного объекта. При этом в группе Количество прямых активен переключатель Две прямые.

Чтобы включить создание одной прямой, параллельной объекту, активизируйте переключатель Одна прямая.

Зафиксируйте фантом прямой (или двух прямых).

Рис. 3.2.11. Прямые, параллельные отрезку

Чтобы перейти к построению прямых, параллельных другому объекту, нажмите кнопку Указать заново, а затем укажите курсором нужный прямолинейный объект.


3.2.3.5. Перпендикулярная прямая

Чтобы построить прямую, перпендикулярную другому объекту, вызовите команду Перпендикулярная прямая.

Укажите объект, перпендикулярно которому должна пройти прямая. Затем задайте точку, принадлежащую прямой.

На экране появятся фантомы всех вариантов прямых, перпендикулярных выбранному объекту и проходящих через указанную точку.

Активизируйте подходящий фантом и зафиксируйте его.

Рис. 3.2.12. Прямые, перпендикулярные сплайну

Чтобы перейти к построению прямых, перпендикулярных другому объекту, нажмите кнопку Указать заново, а затем укажите новый объект.


3.2.3.6. Касательная прямая через внешнюю точку

Чтобы построить прямую, касательную к объекту и проходящую через точку, заданную вне этого объекта, вызовите команду Касательная прямая через внешнюю точку.

Укажите объект, касательно к которому должна пройти прямая. Затем задайте точку, принадлежащую прямой.

На экране появятся фантомы всех вариантов прямых, касательных к объекту и проходящих через заданную точку.

Активизируйте подходящий фантом и зафиксируйте его.

Рис. 3.2.13. Прямые, касательные к эллипсу

Чтобы перейти к построению прямых, касательных к другому объекту, нажмите кнопку Указать заново, а затем укажите новый объект.


3.2.3.7. Касательная прямая через точку кривой

Чтобы построить прямую, касающуюся объекта в точке, заданной на нем, вызовите команду Касательная прямая через точку кривой.

Укажите объект, касательно к которому должна пройти прямая. На экране появится фантом касательной.

– Если известно положение точки касания, задайте ее.

Если указанная точка не принадлежит выбранной кривой, то положение точки касания будет определяться проекцией указанной точки на кривую. Для точного позиционирования курсора воспользуйтесь привязками (см. раздел 3.1.1).

– Если известен угол наклона касательной (угол между прямой и осью абсцисс текущей системы координат), введите его в соответствующее поле на Панели свойств.

Зафиксируйте фантом (фантомы).

Рис. 3.2.14. Касательная к сплайну: а) проходящая через точку сплайна, б) имеющая заданный угол наклона
а) | б)

Чтобы перейти к построению прямых, касательных к другому объекту, нажмите кнопку Указать заново, а затем укажите новый объект.


3.2.3.8. Прямая, касательная к двум кривым

Чтобы построить прямую, касательную к двум объектам, вызовите команду Прямая, касательная к двум кривым.

Укажите первый и второй объекты, касательно к которым должна пройти прямая.

На экране появятся фантомы всех возможных вариантов касательных.

Активизируйте подходящий фантом и зафиксируйте его.

Рис. 3.2.15. Прямые, касательные к эллипсу и окружности

Чтобы перейти к построению прямых, касательных к другим объектам, нажмите кнопку Указать заново, а затем укажите два объекта.


3.2.3.9. Биссектриса

Чтобы построить биссектрису угла, образованного двумя указанными прямолинейными объектами, вызовите команду Биссектриса.

Последовательно укажите два любых прямолинейных объекта.

На экране появятся фантомы биссектрис углов, образованных выбранными объектами.

Активизируйте подходящий фантом и зафиксируйте его.

Если указаны два параллельных объекта, будет построена прямая, равноудаленная от этих объектов.

Чтобы выбрать другие объекты для построения биссектрисы, нажмите кнопку Указать заново, а затем последовательно укажите два прямолинейных объекта.

Рис. 3.2.16. Биссектрисы углов, образованных отрезком и стороной многоугольника


3.2.4. Отрезки

3.2. Геометрические объекты

3.2.4. Отрезки

В этом разделе:

3.2.4.1. Отрезок

3.2.4.2. Параллельный отрезок

3.2.4.3. Перпендикулярный отрезок

3.2.4.4. Касательный отрезок из внешней точки

3.2.4.5. Касательный отрезок через точку кривой

3.2.4.6. Отрезок, касательный к двум кривым


3.2.4.1. Отрезок

Чтобы построить произвольный отрезок, вызовите команду Отрезок.

Задайте начальную точку отрезка т1.

– Если известно положение конечной точки отрезка т2, задайте ее. Длина и угол наклона отрезка будут определены автоматически.

– Если известны длина и угол наклона отрезка, введите их в соответствующие поля на Панели свойств. Положение конечной точки отрезка будет определено автоматически.


3.2.4.2. Параллельный отрезок

Чтобы построить отрезок, параллельный прямолинейному объекту, вызовите команду Параллельный отрезок.

Укажите объект, параллельно которому должен пройти отрезок.

Задайте начальную точку отрезка т1. Расстояние от объекта до параллельного отрезка будет определено автоматически.

Это расстояние можно ввести в соответствующее поле на Панели свойств перед заданием положения начальной точки отрезка.

– Если известно положение конечной точки отрезка т2, задайте ее.

– Если известна длина отрезка, введите ее значение в соответствующее поле на Панели свойств.

Рис. 3.2.17. Построение отрезка, параллельного стороне многоугольника

Чтобы перейти к построению отрезков, параллельных другому объекту, нажмите кнопку Указать заново, а затем укажите нужный объект.


3.2.4.3. Перпендикулярный отрезок

Чтобы построить отрезок, перпендикулярный прямолинейному объекту, вызовите команду Перпендикулярный отрезок.

Укажите объект, перпендикулярно которому должен пройти отрезок.

Задайте начальную точку отрезка т1.

– Если положение конечной точки отрезка т2, задайте ее.

– Если известна длина отрезка, введите ее значение в соответствующее поле на Панели свойств.

Рис. 3.2.18. Построение отрезка, перпендикулярного стороне многоугольника

Чтобы перейти к построению отрезков, перпендикулярных другому прямолинейному объекту, нажмите кнопку Указать заново, а затем укажите курсором нужный объект.


3.2.4.4. Касательный отрезок из внешней точки

Чтобы построить отрезок, касательный к объекту, вызовите команду Касательный отрезок из внешней точки.

Укажите кривую, касательно к которой должен пройти отрезок.

Затем укажите начальную точку отрезка т1 вне кривой.

По умолчанию конечной точкой отрезка является точка касания. Если необходимо, вы можете изменить длину отрезка, введя нужное значение в соответствующее поле Панели свойств.

На экране появятся фантомы всех вариантов отрезков, касательных к выбранному объекту и проходящих через точку т1.

Активизируйте подходящий фантом и зафиксируйте его.

Рис. 3.2.19. Построение отрезков, касательных к дуге

Чтобы перейти к построению отрезков, касательных к другому объекту, нажмите кнопку Указать заново, а затем укажите курсором нужный объект.


3.2.4.5. Касательный отрезок через точку кривой

Чтобы построить отрезок, касательный к объекту и проходящий через указанную точку этого объекта, вызовите команду Касательный отрезок через точку кривой.

Укажите объект, касательно к которому должен пройти отрезок. На экране появится фантом касательной.

– Если известно положение точки касания, задайте ее.

При этом значение угла наклона и координаты точки т2 касательного отрезка определятся автоматически.

– Если известен угол наклона касательного отрезка (угол между ним и осью абсцисс текущей системы координат), введите его в поле Угол на Панели свойств.

После ввода значения угла отображаются фантомы всех вариантов касательных, расположенных под заданным углом. Выберите подходящий вариант касательной. Для этого подведите курсор к нужному фантому. После того, как соответствующая ему точка касания появится на экране, зафиксируйте ее щелчком мыши.

Рис. 3.2.20. Выбор точки касания

Укажите точку т1, определяющую длину отрезка. Если известна длина касательного отрезка, то введите ее значение в поле Длина на Панели свойств.

Для точного позиционирования курсора воспользуйтесь клавиатурными привязками (см. раздел 3.1.1.3) или геометрическим калькулятором (см. раздел 1.4.2.13.1).

Рис. 3.2.21. Построение касательного отрезка: а) заданием точки касания, б) заданием угла наклона
а) | б)


3.2.4.6. Отрезок, касательный к двум кривым

Чтобы построить отрезок, касательный к двум кривым, вызовите команду Отрезок, касательный к двум кривым.

Укажите первую и вторую кривые, касательно к которым должен пройти отрезок.

По умолчанию система предлагает построение отрезков с концами в точках касания. При необходимости вы можете ввести значение длины отрезка в соответствующее поле Панели свойств.

На экране будут показаны фантомы всех вариантов отрезков, касательных к указанным кривым.

Активизируйте подходящий фантом и зафиксируйте его.

Рис. 3.2.22. Отрезки, касательные к окружности и эллипсу

Чтобы перейти к построению отрезков, касательных к другим объектам, нажмите кнопку Указать заново, а затем последовательно укажите курсором две кривые.


3.2.5. Окружности

3.2. Геометрические объекты

3.2.5. Окружности

В этом разделе:

3.2.5.1. Окружность

3.2.5.1.1. Окружность с осями

3.2.5.2. Окружность по трем точкам

3.2.5.3. Окружность с центром на объекте

3.2.5.4. Окружность, касательная к кривой

3.2.5.5. Окружность, касательная к двум кривым

3.2.5.6. Окружность, касательная к трем кривым

3.2.5.7. Окружность по двум точкам


3.2.5.1. Окружность

Чтобы построить произвольную окружность, вызовите команду Окружность.

Укажите центр окружности.

– Если известно положение точки т, через которую проходит окружность, задайте эту точку.

Рис. 3.2.23. Построение окружности по центру и точке

– Если известно значение радиуса или диаметра окружности, введите его в поле ввода параметра на Панели свойств. По умолчанию система ожидает ввода диаметра. При этом в группе Параметр активен переключатель Диаметр.

Чтобы ввести радиус окружности, активизируйте переключатель Радиус.

В этом разделе:

3.2.5.1.1. Окружность с осями


3.2.5.1.1. Окружность с осями

По умолчанию окружности строятся без осевых линий. При этом в группе Оси на Панели свойств активен переключатель Без осей.

Чтобы создаваемая окружность имела осевые линии, активизируйте переключатель С осями. На фантоме окружности появятся оси, отрисованные по направлениям текущей системы координат.

При построении окружностей остальных типов создание осей выполняется аналогично.

Если вы начертили окружность без осей, а затем обнаружили, что нужно построить и ее оси, нет необходимости удалять окружность и создавать новую с осями. Войдите в режим редактирования окружности, дважды щелкнув по ней мышью. Включите отрисовку осей и нажмите кнопку Создать объект на Панели специального управления.

Оси можно построить также с помощью команды Обозначение центра (см. раздел 3.3.7.14).

Осевые линии представляют собой системный макроэлемент — обозначение центра. Обозначение центра по умолчанию не связано с окружностью и при ее дальнейшем редактировании (изменении радиуса или положения) не перестраивается.


3.2.5.2. Окружность по трем точкам

Чтобы построить окружность, проходящую через три заданные точки, вызовите команду Окружность по трем точкам.

Задайте точки т1, т2 и т3, через которые должна пройти окружность. Координаты центра окружности и ее радиус будут определены автоматически.

Рис. 3.2.24. Окружность по трем точкам


3.2.5.3. Окружность с центром на объекте

Чтобы построить окружность с центром на указанной кривой, вызовите команду Окружность с центром на объекте.

Укажите объект, на котором должен лежать центр окружности.

Задайте первую точку т1, через которую проходит создаваемая окружность.

– Если известно положение второй точки т2, лежащей на окружности, задайте ее.

– Если известно значение радиуса или диаметра окружности, введите его в поле ввода параметра на Панели свойств. По умолчанию система ожидает ввода диаметра. При этом в группе Параметр активен переключатель Диаметр.

Чтобы ввести радиус окружности, активизируйте переключатель Радиус.

На экране появятся фантомы всех вариантов окружностей, удовлетворяющих заданным параметрам.

Активизируйте подходящий фантом и зафиксируйте его.

Рис. 3.2.25. Окружности с центрами, лежащими на сплайне: а) проходящие через точки т1 и т2, б) с равными радиусами и проходящие через точку т1
а) | б)

Чтобы перейти к построению окружностей с центром на другом объекте, нажмите кнопку Указать заново, а затем укажите курсором новый объект.


3.2.5.4. Окружность, касательная к кривой

Чтобы построить окружность, касательную к заданной кривой, вызовите команду Окружность, касательная к кривой.

Укажите объект, которого должна касаться окружность.

– Если известно положение точек т1 и т2, принадлежащих создаваемой окружности, задайте их (рис. 3.2.26, а).

Вы можете ввести радиус или диаметр окружности в соответствующее поле Панели свойств перед заданием второй точки окружности. Однако построение касательной окружности возможно не при всех комбинациях положения точки на окружности (т1) и значения радиуса. О невозможности построения свидетельствует исчезновение фантома окружности после ввода значения радиуса.

– Если известна точка центра окружности, задайте ее (рис. 3.2.26, б).

На экране появятся фантомы всех окружностей, имеющих заданные параметры и касательных к указанной кривой.

Рис. 3.2.26. Окружности, касательные к эллипсу: а) проходящие через точки т1 и т2, б) концентрические
а) | б)

Активизируйте подходящий фантом и зафиксируйте его.

Чтобы перейти к построению окружностей, касательных к другому объекту, нажмите кнопку Указать заново, а затем укажите курсором новый объект.


3.2.5.5. Окружность, касательная к двум кривым

Чтобы построить окружность, касательную к двум указанным кривым, вызовите команду Окружность, касательная к двум кривым.

Укажите объекты, которых должна касаться окружность.

– Если известна точка т, принадлежащая создаваемой окружности, задайте ее.

– Если известно значение радиуса или диаметра окружности, введите его в поле ввода параметра на Панели свойств. По умолчанию система ожидает ввода диаметра. При этом в группе Параметр активен переключатель Диаметр.

Чтобы ввести радиус окружности, активизируйте переключатель Радиус.

На экране появятся фантомы всех окружностей, имеющих заданные параметры и касательных к указанным кривым.

Выберите нужный фантом и зафиксируйте его.

Рис. 3.2.27. Окружности, касательные к дуге и сплайну: а) проходящие через точку т, б) равных радиусов
а) | б)

Чтобы перейти к построению окружностей, касательных к другим объектам, нажмите кнопку Указать заново, а затем последовательно укажите курсором два объекта.


3.2.5.6. Окружность, касательная к трем кривым

Чтобы построить окружность, касательную к трем указанным кривым, вызовите команду Окружность, касательная к трем кривым.

Укажите первый, второй и третий объекты, касательно к которым должна пройти окружность.

Если среди указанных объектов есть эллипс или сплайн, система запросит указания примерного местоположения окружности.

На экране появятся фантомы всех вариантов окружностей, касательных к указанным объектам.

Активизируйте подходящий фантом и зафиксируйте его.

Рис. 3.2.28. Окружность, касательная к двум эллипсам и отрезку

Чтобы перейти к построению окружностей, касательных к другим объектам, нажмите кнопку Указать заново, а затем последовательно укажите курсором три объекта.


3.2.5.7. Окружность по двум точкам

Чтобы построить окружность, проходящую через две заданные точки, вызовите команду Окружность по двум точкам.

Задайте первую точку т1, через которую должна пройти окружность.

Введите диаметр или радиус в поле ввода параметра на Панели свойств при активном переключателе Диаметр или Радиус.

Задайте вторую точку т2, через которую должна пройти окружность.

Если точки т1 и т2 диаметрально противоположны, вводить радиус или диаметр не обязательно — он определяется автоматически.

Рис. 3.2.29. Построение окружности по двум точкам


3.2.6. Эллипсы

3.2. Геометрические объекты

3.2.6. Эллипсы

При построении эллипсов с помощью всех нижеописанных команд управление отрисовкой осевых линий производится так же, как при создании окружностей (см. раз-дел 3.2.5.1.1).

В этом разделе:

3.2.6.1. Эллипс

3.2.6.2. Эллипс по диагонали габаритного прямоугольника

3.2.6.3. Эллипс по центру и вершине габаритного прямоугольника

3.2.6.4. Эллипс по центру, середине стороны и вершине описанного параллелограмма

3.2.6.5. Эллипс по трем вершинам описанного параллелограмма

3.2.6.6. Эллипс по центру и трем точкам

3.2.6.7. Эллипс, касательный к двум кривым


3.2.6.1. Эллипс

Чтобы построить произвольный эллипс, вызовите команду Эллипс.

Укажите центральную точку эллипса.

Задайте величину первой полуоси эллипса. Это можно сделать двумя способами.

– задайте конечную точку полуоси т1,

– введите длину полуоси в соответствующем поле на Панели свойств.

Угол наклона первой полуоси к оси абсцисс текущей системы координат определяется автоматически.

Если необходимо, перед указанием величины первой полуоси вы можете задать точное значение угла ее наклона в соответствующем поле Панели свойств.

Задайте величину второй полуоси эллипса. Это тоже можно сделать двумя способами.

– задайте конечную точку полуоси т2,

– введите длину полуоси в соответствующем поле на Панели свойств.

Рис. 3.2.30. Эллипс по центру и размерам полуосей


3.2.6.2. Эллипс по диагонали габаритного прямоугольника

Чтобы построить эллипс, вписанный в прямоугольник с заданной диагональю, вызовите команду Эллипс по диагонали прямоугольника.

Введите в соответствующее поле на Панели свойств величину угла наклона первой полуоси эллипса к оси абсцисс текущей системы координат (по умолчанию она равна 0°).

Затем задайте начальную (т1) и конечную (т2) точки диагонали прямоугольника, описанного вокруг создаваемого эллипса. Длины полуосей эллипса будут рассчитаны автоматически.

Рис. 3.2.31. Эллипс по диагонали габаритного прямоугольника


3.2.6.3. Эллипс по центру и вершине габаритного прямоугольника

Чтобы построить эллипс, вписанный в прямоугольник с заданными центром и вершиной, вызовите команду Эллипс по центру и вершине прямоугольника.

Введите в соответствующее поле на Панели свойств величину угла наклона первой полуоси эллипса к оси абсцисс текущей системы координат (по умолчанию она равна 0°).

Затем задайте центральную точку и вершину прямоугольника, описанного вокруг создаваемого эллипса. Длины полуосей эллипса будут рассчитаны автоматически.

Рис. 3.2.32. Эллипс по центру и вершине габаритного прямоугольника


3.2.6.4. Эллипс по центру, середине стороны и вершине описанного параллелограмма

3.2.6.4. Эллипс по центру, середине стороны
и вершине описанного параллелограмма

Чтобы построить эллипс, вписанный в параллелограмм с заданными центром, серединой стороны и вершиной, вызовите команду Эллипс по центру, середине стороны и вершине параллелограмма.

Задайте точку точки центра, затем середину стороны (т1) и вершину (т2) параллелограмма, описанного вокруг создаваемого эллипса.

Длины полуосей эллипса и угол наклона его первой полуоси к оси абсцисс текущей системы координат будут рассчитаны автоматически.

Рис. 3.2.33. Эллипс по центру, середине стороны и вершине параллелограмма


3.2.6.5. Эллипс по трем вершинам описанного параллелограмма

Чтобы построить эллипс, вписанный в параллелограмм с тремя заданными вершинами, вызовите команду Эллипс по 3 вершинам параллелограмма.

Задайте положения вершин т1, т2 и т3 параллелограмма, описанного вокруг создаваемого эллипса.

Длины полуосей эллипса и угол наклона его первой полуоси к оси абсцисс текущей системы координат будут рассчитаны автоматически.

Рис. 3.2.34. Эллипс по трем вершинам габаритного параллелограмма


3.2.6.6. Эллипс по центру и трем точкам

Чтобы построить эллипс с определенным центром и проходящий через три заданные точки, вызовите команду Эллипс по центру и 3 точкам.

Укажите положение центральной точки создаваемого эллипса, а затем точки т1, т2 и т3, принадлежащие ему.

Рис. 3.2.35. Эллипс по центру и трем точкам


3.2.6.7. Эллипс, касательный к двум кривым

Чтобы построить эллипс, касательный к двум заданным объектам, вызовите команду Эллипс, касательный к 2 кривым.

Укажите первый и второй объекты в точках т1 и т2 их касания с эллипсом.

Для точного позиционирования курсора воспользуйтесь клавиатурными привязками (см. раздел 3.1.1.3).

Задайте точку т3, через которую должен проходить создаваемый эллипс.

Рис. 3.2.36. Эллипс, касательный к отрезку и окружности


3.2.7. Дуги

3.2. Геометрические объекты

3.2.7. Дуги

В данном разделе рассматривается построение дуг окружности. В дальнейшем слово «окружности» в сочетании «дуга окружности» для краткости будет опускаться. Понятие «дуга» будет использоваться для обозначения именно дуги окружности. В тех случаях, где речь пойдет о других дугах, например, эллипсов, это будет специально оговорено.

В этом разделе:

3.2.7.1. Дуга

3.2.7.1.1. Выбор направления дуги

3.2.7.2. Дуга по трем точкам

3.2.7.3. Дуга, касательная к кривой

3.2.7.4. Дуга по двум точкам

3.2.7.5. Дуга по двум точкам и углу раствора

3.2.7.6. Дуги эллипсов


3.2.7.1. Дуга

Чтобы построить произвольную дугу, вызовите команду Дуга.

Задайте центральную точку дуги.

Задайте начальную точку дуги. Это можно сделать двумя способами:

– указать точку мышью,

– ввести значения угла и радиуса (или диаметра) в соответствующие поля Панели свойств.

По умолчанию при вводе параметра окружности система ожидает ввода радиуса. При этом в группе Параметр активен переключатель Радиус.

Чтобы ввести диаметр, активизируйте переключатель Диаметр.

Задайте конечную точку дуги. Это тоже можно сделать двумя способами:

– указать точку мышью,

– ввести значение конечного угла дуги в соответствующее поле Панели свойств.

Рис. 3.2.37. Построение дуги по центру и двум точкам

В этом разделе:

3.2.7.1.1. Выбор направления дуги


3.2.7.1.1. Выбор направления дуги

По умолчанию дуга строится против часовой стрелки. При этом в группе Направление на Панели свойств активен переключатель Построение против часовой стрелки.

Чтобы изменить направление построения на противоположное, активизируйте переключатель Построение по часовой стрелке.

При построении дуг остальных типов направление задается аналогично1.

  1. При построении дуги по трем точкам ее направление определяется порядком указания точек, поэтому на Панели свойств нет переключателя направления.


3.2.7.2. Дуга по трем точкам

Чтобы построить дугу с заданными конечными точками и точкой, лежащей на дуге, вызовите команду Дуга по трем точкам.

Укажите начало дуги (т1), точку, через которую должна пройти дуга (т2), и конец дуги (т3). Координаты центра и радиус дуги будут рассчитаны автоматически.

Рис. 3.2.38. Построение дуги по трем точкам


3.2.7.3. Дуга, касательная к кривой

Чтобы построить дугу, касательную к заданному объекту, вызовите команду Дуга, касательная к кривой.

Укажите объект, которого должна касаться дуга.

Задайте точку т1, через которую должна пройти дуга.

Задайте конечную точку дуги т2.

Координаты центра дуги и ее радиус будут рассчитаны автоматически. Начальная точка дуги — точка касания.

Вы можете ввести радиус или диаметр дуги в соответствующее поле Панели свойств перед заданием точки т2. Однако построение касательной дуги возможно не при всех комбинациях положения точки на дуге (т1) и значения радиуса. О невозможности построения свидетельствует исчезновение фантома дуги после ввода значения радиуса.

На экране появятся фантомы всех вариантов дуг, удовлетворяющих заданным параметрам.

Активизируйте подходящий фантом и зафиксируйте его.

Рис. 3.2.39. Дуга, касательная к отрезку

Чтобы перейти к построению дуг, касательных к другой кривой, нажмите кнопку Указать заново, а затем укажите курсором новую базовую кривую.


3.2.7.4. Дуга по двум точкам

Чтобы построить дугу с заданными конечными точками, вызовите команду Дуга по 2 точкам.

Введите значение радиуса или диаметра создаваемой дуги в соответствующее поле на Панели свойств.

По умолчанию при вводе параметра окружности система ожидает ввода радиуса. При этом в группе Параметр активен переключатель Радиус.

Чтобы ввести диаметр, активизируйте переключатель Диаметр.

Задайте начальную точку дуги т1.

Задайте конечную точку дуги т2.

Для построения дуги по диаметрально противоположным точкам ввод радиуса или диаметра не обязателен — он определяется автоматически после указания точек.

Рис. 3.2.40. Дуга по двум точкам


3.2.7.5. Дуга по двум точкам и углу раствора

Чтобы построить дугу, начинающуюся и заканчивающуюся в заданных точках и имеющую определенный угол раствора, вызовите команду Дуга по 2 точкам и углу раствора.

Введите в соответствующее поле на Панели свойств величину угла раствора дуги (по умолчанию она равна 90°).

Задайте начальную точку дуги т1.

Задайте конечную точку дуги т2.

Координаты центральной точки дуги и ее радиус будут рассчитаны автоматически.

Рис. 3.2.41. Дуга по двум точкам и углу раствора 60°


3.2.7.6. Дуги эллипсов

В КОМПАС-3D не существует специальной команды для построения дуг эллипсов. Однако дуги эллипсов можно получить, применяя команды усечения (см. раздел 3.5.7) к целым эллипсам. С помощью привязок (см. раздел 1.4.2.13.1) и вспомогательных построений (см. раздел 3.2.3) можно создавать дуги эллипсов с заданными параметрами.

Рис. 3.2.42. Пример дуги эллипса, полученной усечением целого эллипса по точкам т1 и т2

Редактирование дуг эллипсов осуществляется с помощью характерных точек (см. раздел 3.5.1.1.3).


3.2.8. Прямоугольники и многоугольники

3.2. Геометрические объекты

3.2.8. Прямоугольники и многоугольники

При построении прямоугольников и многоугольников с четным количеством углов возможна автоматическая отрисовка осевых линий. Управление отрисовкой осевых линий производится так же, как при создании окружностей (см. раздел 3.2.5.1.1).

Прямоугольники и многоугольники в КОМПАС-3D являются едиными объектами, а не наборами отрезков. Они выделяются и редактируются целиком.

В этом разделе:

3.2.8.1. Прямоугольник

3.2.8.2. Прямоугольник по трем точкам

3.2.8.3. Многоугольник


3.2.8.1. Прямоугольник

Чтобы построить произвольный прямоугольник, вызовите команду Прямоугольник.

Доступно два способа построения прямоугольника:

– По двум противоположным вершинам.
Активизируйте переключатель По двум вершинам в группе Способ на Панели свойств. Задайте противоположные вершины прямоугольника т1 и т2. При необходимости введите угол наклона прямоугольника в поле Угол. Высота и ширина прямоугольника определяются автоматически.

Рис. 3.2.43. Построение прямоугольника по противоположным вершинам

– По центру и вершине.
Активизируйте переключатель По центру и вершине в группе Способ на Панели свойств. Задайте центр прямоугольника и одну из его вершин т1. При необходимости введите угол наклона прямоугольника в поле Угол. Высота и ширина прямоугольника определяются автоматически.

Рис. 3.2.44. Построение прямоугольника по центру и вершине

Угол наклона прямоугольника отсчитывается от оси абсцисс текущей системы координат. По умолчанию угол равен нулю.

Чтобы построить квадрат, указывайте вторую точку при нажатой клавише <Shift>.


3.2.8.2. Прямоугольник по трем точкам

Чтобы построить прямоугольник по трем точкам, вызовите команду Прямоугольник по трем точкам.

Доступно два способа построения прямоугольника:

– По трем вершинам.
Активизируйте переключатель По трем точкам в группе Способ на Панели свойств. Задайте вершины прямоугольника т1, т2 и т3. Высота, ширина и угол наклона прямоугольника определяются автоматически.

Рис. 3.2.45. Построение прямоугольника по трем вершинам

– По центру, середине стороны и вершине.
Активизируйте переключатель По центру и двум точкам в группе Способ на Панели свойств. Задайте центр прямоугольника, середину одной из сторон т1 и вершину т2. Высота, ширина и угол наклона прямоугольника определяются автоматически.

Рис. 3.2.46. Построение прямоугольника по центру, середине стороны и вершине


3.2.8.3. Многоугольник

Чтобы построить правильный многоугольник, вызовите команду Многоугольник.

По умолчанию многоугольник строится по вписанной окружности. При этом в группе Способ построения активен соответствующий переключатель. Чтобы включить построение по описанной окружности, активизируйте переключатель По описанной окружности.

Введите число вершин многоугольника в соответствующее поле на Панели свойств.

Задайте точку центра многоугольника.

– Если известно положение точки т — одной из вершин (при построении по описанной окружности) или середины одной из сторон (при построении по вписанной окружности) создаваемого многоугольника, задайте эту точку.

– Если известны радиус или диаметр, а также угол наклона1 многоугольника, введите их в соответствующие поля на Панели свойств.

По умолчанию при вводе параметра окружности система ожидает ввода диаметра. При этом в группе Параметр активен переключатель Диаметр.

Чтобы ввести радиус, активизируйте переключатель Радиус.

Рис. 3.2.47. Шестиугольник: а) по описанной окружности, б) по вписанной окружности
а) | б)

  1. Угол наклона многоугольника определяется углом между осью абсцисс текущей системы координат и радиус-вектором, проведенным из центра многоугольника в его первую вершину (при построении по описанной окружности) или в середину первой стороны (при построении по вписанной окружности).


3.2.9. Ломаная, сплайны, конические кривые

3.2. Геометрические объекты

3.2.9. Ломаная, сплайны, конические кривые

В этом разделе:

3.2.9.1. Ломаная

3.2.9.1.1. Таблица Координаты вершин

3.2.9.1.2. Редактирование характерных точек (при создании или редактировании объекта)

3.2.9.2. Сплайн по полюсам

3.2.9.3. Сплайн по точкам

3.2.9.3.1. Управление формой сплайна

3.2.9.3.2. Способы формирования параметров точек сплайна

3.2.9.4. Коническая кривая


3.2.9.1. Ломаная

Чтобы построить ломаную линию, состоящую из отрезков прямых, вызовите команду Ломаная.

Задайте вершины ломаной.

Каждая вершина ломаной имеет набор параметров, отображающийся в таблице Координаты вершин (см. раздел 3.2.9.1.1).

Рис. 3.2.48. Ломаная: а) разомкнутая, б) замкнутая
а) | б)

Выберите вариант построения ломаной — разомкнутая или замкнутая. Для этого в группе Режим активизируйте нужный переключатель: Разомкнутый объект или Замкнутый объект.

Вы можете изменить конфигурацию ломаной, не выходя из команды. Для этого нажмите кнопку Редактировать точки на Панели специального управления. Система перейдет в режим редактирования характерных точек объекта. Внесите необходимые изменения (см раздел 3.2.9.1.2).

Построенная ломаная является единым объектом чертежа, она будет выделяться, редактироваться и удаляться целиком.

Зафиксируйте созданную ломаную, нажав кнопку Создать объект.

В этом разделе:

3.2.9.1.1. Таблица Координаты вершин

3.2.9.1.2. Редактирование характерных точек (при создании или редактировании объекта)


3.2.9.1.1. Таблица Координаты вершин

Каждая вершина ломаной или сплайна характеризуется набором параметров. Их значения отображаются в таблице Координаты вершин, которая располагается на Панели свойств.

Одной вершине кривой соответствует одна строка таблицы.

Общими параметрами для ломаной и сплайна являются следующие:

– номер вершины;

– координаты вершины по оси Х и по оси Y.

При построении сплайна по точкам в таблице отображаются как общие параметры, так и параметры, зависящие от выбранного типа кривой:

– NURBS-кривая по точкам:

• длина вектора производной;

• угол наклона вектора производной;

• величина кривизны.

– Кривая Безье:

• длина 1, 2 — длины первого и второго векторов производной;

• угол 1, 2 — углы наклона первого и второго векторов производной.

Рис. 3.2.49. Таблица Координаты вершин: а) ломаной и сплайна по полюсам, б) сплайна по точкам
а) | б)

Строки таблицы формируются автоматически при построении вершины в окне документа. Редактирование строки таблицы приводит к изменению параметров соответствующей вершины.

Для изменения параметра вершины активизируйте нужную ячейку таблицы параметров двойным щелчком мыши и введите в нее новое значение. Для перемещения между ячейками можно использовать клавиши со стрелками.

Над таблицей Координаты вершин находятся следующие кнопки для работы с параметрами.

– Читать из файла — позволяет внести в таблицу данные, сохраненные во внешнем файле. Кнопка доступна, если таблица параметров вершин пуста, т.е. сразу после вызова команды создания ломаной/сплайна. После нажатия кнопки на экране появляется стандартный диалог открытия файлов Windows, в котором необходимо выбрать нужный файл. Таблица параметров будет заполнена значениями из этого файла. В окне документа появится фантом сплайна, построенного по табличным данным.

– Сохранить в файл — позволяет сохранить параметры вершин в файл для дальнейшего использования. После нажатия кнопки на экране появляется стандартный диалог сохранения файлов Windows. В этом диалоге следует указать имя файла, папку для сохранения. По умолчанию файлу присваивается расширение txt, но при необходимости оно может быть изменено. Сохранение координат в файл возможно, если в таблице параметров заполнена хотя бы одна строка.

– Создать новую вершину — позволяет создать вершину после уже существующей. Для этого выделите строку с номером нужной вершины и нажмите кнопку Создать новую вершину или клавишу <Insert>. В окне документа появится новая вершина. Ее номер будет следующим за номером текущей вершины. Номера последующих вершин увеличатся на единицу. Строка параметров созданной вершины будет активна.

– Удалить вершину — позволяет удалить вершину. Для этого выделите строку ее параметров и нажмите кнопку Удалить вершину или клавишу <Delete>. Последнюю строку удалить невозможно.

Для выполнения действий над параметрами вершин также могут использоваться команды контекстного меню таблицы Координаты вершин.


3.2.9.1.2. Редактирование характерных точек (при создании или редактировании объекта)

Вы можете изменять положение, добавлять или удалять характерные точки объекта в процессе построения — после нажатия кнопки Редактировать точки на Панели специального управления.

В этом режиме характерные точки отображаются в виде маленьких черных квадратов в вершинах, а объект — в виде фантома.

Подведите курсор к характерной точке, которую требуется отредактировать. Форма курсора изменится — он превратится в четырехстороннюю стрелку. Нажмите клавишу <Enter> или щелкните левой кнопкой мыши — точка будет выделена.

Редактировать точки объекта можно следующими способами.

– «Перетаскивание» точки мышью.

– Перемещение точки при помощи клавиатуры.
Для этого точка должна быть выделена нажатием клавиши <Enter>.
Переместите курсор при помощи клавиш со стрелками.

– Задание координат характерной точки.
Задайте новые координаты выделенной точки на Панели свойств.

– Добавление или удаление характерной точки.

• Чтобы добавить точку, щелкните мышью на нужном звене объекта. Оно будет разбито на две части новой точкой, расположенной в указанном месте. Вы можете переместить ее в любое место.

• Чтобы удалить выделенную точку, нажмите клавишу <Delete>. После этого характерная точка исчезнет, и объект перестроится в соответствии с положением оставшихся характерных точек.

При определении положения точки вы можете использовать привязки (см. раздел 3.1.1) и геометрический калькулятор (см. раздел 1.4.2.13.1).

Чтобы выйти из режима редактирования точек и продолжить построение линии, отожмите кнопку Редактировать точки.


3.2.9.2. Сплайн по полюсам

Сплайн по полюсам — сплайн, проходящий через конечные вершины касательно к конечным сегментам опорной ломаной и не проходящий через промежуточные вершины (они называются «полюсами сплайна»).

Чтобы построить сплайн по полюсам, вызовите команду Сплайн по полюсам.

Задайте вершины сплайна. Для этого укажите вершины опорной ломаной.

Каждая вершина сплайна имеет набор параметров, отображающийся в таблице Координаты вершин (см. раздел 3.2.9.1.1).

Задайте характеристики сплайна — порядок сплайна и вес каждой точки. Для этого введите нужные значения в поля Порядок и Вес на Панели свойств. Порядок может принимать значения в диапазоне 2 — 10, а вес — в диапазоне 0,0001 — 999.

Подробно о порядке сплайна и весе точек рассказано в разделе 3 Приложения IX.

Рис. 3.2.50. Сплайн по полюсам: а) разомкнутый, б) замкнутый
а) | б)

Выберите вариант построения сплайна — разомкнутый или замкнутый. Для этого в группе Режим активизируйте нужный переключатель: Разомкнутый объект или Замкнутый объект.

Вы можете изменить конфигурацию сплайна, не выходя из команды. Для этого нажмите кнопку Редактировать точки на Панели специального управления. Система перейдет в режим редактирования характерных точек объекта. Внесите необходимые изменения (см. раздел 3.2.9.1.2).

Зафиксируйте созданный сплайн, нажав кнопку Создать объект.


3.2.9.3. Сплайн по точкам

Чтобы построить сплайн, проходящий через заданные вершины, вызовите команду Сплайн по точкам.

Сплайн по точкам может представлять собой кривую одного из следующих типов:

– Кривая Безье

– NURBS-кривая по точкам

Выберите нужный тип кривой из списка Тип кривой на Панели свойств.

При построении NURBS-кривой по точкам выберите из списка Способ на Панели свойств нужный способ формирования параметров точек сплайна (см. раздел 3.2.9.3.2).

Задайте вершины сплайна. Для этого укажите точки, через которые должен пройти сплайн.

Каждая вершина сплайна имеет набор параметров, отображающийся в таблице Координаты вершин (см. раздел 3.2.9.1.1).

Рис. 3.2.51. Кривая Безье: а) разомкнутая, б) замкнутая
а) | б)

Выберите вариант построения сплайна — разомкнутый или замкнутый. Для этого в группе Режим активизируйте нужный переключатель: Разомкнутый объект или Замкнутый объект.

Чтобы изменить конфигурацию сплайна, нажмите кнопку Редактировать точки на Панели специального управления. Система перейдет в режим редактирования характерных точек объекта. В этом режиме вы можете:

– изменить положение и количество вершин, см раздел 3.2.9.1.2;

– изменить форму сплайна в вершине:

• для кривой Безье — управляя длиной и направлением вектора производной,

• для NURBS-кривой по точкам — управляя касательностью и кривизной, см. раздел 3.2.9.3.1.

Зафиксируйте созданный сплайн, нажав кнопку Создать объект.

Все объекты на иллюстрациях раздела Ломаная и сплайны имеют одинаковый набор опорных точек. Обратите внимание на отличия форм объектов, имеющих одинаковые опорные точки, в зависимости от типа объекта и от того, замкнутый он или разомкнутый.

В этом разделе:

3.2.9.3.1. Управление формой сплайна

3.2.9.3.2. Способы формирования параметров точек сплайна


3.2.9.3.1. Управление формой сплайна

При построении сплайна, являющегося NURBS-кривой по точкам, вы можете изменять его форму, управляя касательностью и/или кривизной в любой вершине.

Величина касательности показывает, насколько форма сплайна близка к соприкасающейся окружности в окрестности его текущей вершины; кривизна характеризует радиус этой окружности (о кривизне и соприкасающейся окружности см. раздел 5 Приложения IX).

Изменение формы сплайна производится в режиме редактирования характерных точек объекта в текущей вершине. Для перехода в этот режим нажмите кнопку Редактировать точки на Панели специального управления.

После перехода в режим редактирования на Панели свойств появляется список Управление с вариантами управления сплайном в текущей вершине.

В окне документа или в таблице Координаты вершин укажите вершину сплайна, в которой требуется изменить его форму.

Выберите из списка Управление нужный вариант:

– Касательностью — позволяет задать длину и угол наклона вектора производной в выбранной вершине,

– Касательностью и кривизной — позволяет задать, кроме длины и угла наклона вектора производной, величину кривизны.

После выбора одного из вариантов управления около текущей вершины появляется обозначение этого варианта и управляющий фантом — одна или две пунктирные стрелки.

Задайте параметры выбранного варианта с помощью элементов управления Панели свойств или с помощью управляющего фантома в окне документа. Обратите внимание на то, что длину вектора производной можно задать только на Панели свойств.

Находясь в режиме управления формой сплайна, вы можете также изменить положение текущей вершины, переместив ее мышью в окне документа (см. раздел 3.2.9.1.2) или задав нужные значения координат вершины в таблице параметров (см. раздел 3.2.9.1.1).

Завершив управление формой сплайна в одной из вершин, вы можете:

– перейти к управлению формой сплайна в другой его вершине — для этого выделите в окне документа нужную вершину или в таблице параметров вершин строку с номером этой вершины,

– выйти из режима управления формой сплайна — для этого нажмите кнопку Редактировать точки на Панели специального управления,

– завершить построение сплайна — для этого нажмите кнопку Создать объект.


3.2.9.3.2. Способы формирования параметров точек сплайна

При построении сплайна, являющегося NURBS-кривой по точкам, вы можете задавать способ параметризации кривой.

NURBS-кривая по точкам имеет параметрическое представление (см. раздел 2.5.2). Точки, по которым строится сплайн, соответствуют некоторым значениям параметра t. Форма сплайна, проходящего через одни и те же точки, может быть различной (см. рис 3.2.52). Это зависит от способа формирования параметров точек сплайна:

– Линейный — значения параметра, соответствующие точкам, которые указаны пользователем, считаются равномерно расположенными на параметрической области кривой.

– По длине хорды — расположение значений параметра, соответствующих точкам, которые указаны пользователем, на параметрической области кривой зависит от расстояния между соседними точками.

– Центростремительный — расположение значений параметра, соответствующих точкам, которые указаны пользователем, на параметрической области кривой зависит от квадратного корня из расстояния между соседними точками.

Рис. 3.2.52. Сплайны с разными способами формирования параметров точек:
I — Линейный, II — Центростремительный, III — По длине хорды

Чтобы задать способ формирования параметров точек сплайна, выберите нужный вариант из списка Способ на Панели свойств.


3.2.9.4. Коническая кривая

Для построения конической кривой необходимо задать ее начальную и конечную точки, касательные к ней в этих точках и промежуточную точку кривой. Подробнее о конических кривых см. раздел 7 Приложения IX.

Чтобы построить коническую кривую, вызовите команду Коническая кривая.

1. Задайте начальную точку кривой т1. Это можно сделать следующими способами.

– Укажите точку в окне документа или введите ее координаты с клавиатуры.

– Выберите объект, которого коническая кривая должна касаться в своей начальной точке, затем укажите на нем точку т1. Объектом может быть любая существующая в документе кривая (отрезок, дуга, сплайн и пр.).
Если указанный объект прямолинейный, то он является касательным к конической кривой в ее начальной точке т1. Если объект криволинейный, то касательная к нему в указанной точке т1 является касательной к конической кривой в этой точке.

• Чтобы выбрать объект, подведите к нему курсор. Когда курсор примет вид квадратной «ловушки», а объект под ним подсветится, нажмите левую кнопку мыши (рис. 3.2.53, а).

Если выбрать объект не удается, временно отключите глобальные привязки, нажав и удерживая <Alt>.

Если требуется выбрать другой объект, нажмите кнопку Указать заново на Панели специального управления. Выделение с выбранного объекта снимается, и вы можете указать новый объект. Указать новый объект можно только до фиксации на нем точки конической кривой. Если точка уже указана на выбранном объекте, расфиксируйте ее на Панели свойств, выберите нужный объект и укажите на нем точку.

• Укажите начальную точку конической кривой т1 на выбранном объекте.
Если выбран криволинейный объект, на экране появляется фантом касательной (рис. 3.2.53, б). Фантом касается объекта в той точке, в которой объект был указан. Перемещая курсор по полю документа, вы увидите, как вслед за курсором перемещается фантом касательной. При фиксации точки т1 угол наклона касательной к конической кривой в этой точке определяется автоматически.
Если выбран прямолинейный объект, то по его углу наклона автоматически определяется угол наклона касательной к конической кривой в начальной точке т1, указанной на объекте.
Если точка указана вне объекта, то ее положение на объекте определяется как проекция указанной точки на объект.

Рис. 3.2.53. Построение конической кривой касательно к объекту: а) указание объекта, б) указание точки на криволинейном объекте
а | б

2. Задайте конечную точку конической кривой т2. Это также можно сделать двумя способами.

– Укажите точку в окне документа или введите ее координаты с клавиатуры.

– Выберите объект и укажите на нем точку т2.

3. Укажите положение точки пересечения касательных к конической кривой.

На экране отображаются: фантом конической кривой и фантомы касательных к ней в точках т1 и т2, пересекающиеся в точке т3.

Если касательные к конической кривой в точках т1 и т2 определены (перед указанием точек т1 и т2 были выбраны объекты и точки указаны на них), то точка т3 определяется и фиксируется автоматически.

Если касательные к конической кривой не заданы, точка их пересечения т3 не зафиксирована. Положение точки т3 можно указать следующими способами.

– Укажите точку в окне документа или введите ее координаты с клавиатуры. Углы наклона касательных в начальной и конечной точках конической кривой определяются автоматически.

– Введите значения углов наклонов касательных в поля Угол1 и Угол2 на Панели свойств. Положение точки т3 определяется автоматически.

4. Форма конической кривой определяется положением точки на кривой т4. Задайте точку т4 одним из следующих способов.

– Укажите точку в окне документа или введите ее координаты с клавиатуры.

По умолчанию активен переключатель коэффициент. В этом случае, если точка т4 указана внутри треугольника с вершинами в точках т1, т2, т3, то коническая кривая проходит непосредственно через указанную точку. Если точка указана за пределами треугольника, то кривая проходит через точку пересечения медианы из вершины т3 с прямой, проведенной через указанную точку параллельно отрезку т1т2 (рис. 3.2.54).

Рис. 3.2.54. Определение положения точки т4: а) точка указана внутри треугольника при активном переключателе коэффициент; б) построение точки на медиане
а) | б)

При активном переключателе высота кривая проходит через точку пересечения медианы из вершины т3 с прямой, проведенной через указанную точку параллельно отрезку т1т2, независимо от того, где указана точка.

– Введите значение параметра коэффициент/высота в поле на Панели свойств, активизировав соответствующий переключатель. Ввод значения параметра коэффициент/высота определяет положение точки т4 на медиане треугольника.

Значение параметра коэффициент должно лежать в пределах 0,0001–0,9999.

Значение связанного с ним параметра высота должно обеспечивать значение параметра коэффициент в указанных пределах.

После ввода всех параметров зафиксируйте созданную коническую кривую, нажав кнопку Создать объект.


3.2.10. Непрерывный ввод объектов

3.2. Геометрические объекты

3.2.10. Непрерывный ввод объектов

Чтобы построить последовательности отрезков, дуг и сплайнов, вызовите команду Непрерывный ввод объектов.

При вводе последовательности конечная точка созданного объекта автоматически становится начальной точкой следующего объекта. Использовать эту команду удобно, например, при построении контура детали, состоящего из объектов различного типа.

Рис. 3.2.55. Пример последовательности объектов,
полученной с помощью команды непрерывного ввода

Построенная последовательность не является единым объектом. Сегменты линии будут выделяться, редактироваться и удаляться по отдельности.

В этом разделе:

3.2.10.1. Создание объектов последовательности

3.2.10.2. Завершение ввода объектов

3.2.10.3. Стиль линии при непрерывном вводе объектов


3.2.10.1. Создание объектов последовательности

После вызова команды на Панели свойств, кроме собственно полей ввода параметров, отображается группа Тип. Она содержит переключатели, позволяющие указать тип создаваемого сегмента. Для выбора типа активизируйте соответствующий переключатель (см. табл. 3.2.2).

Табл. 3.2.2. Переключатели типа сегмента
Тип сегмента | Способ построения сегмента
Отрезок | Произвольный
 | Параллельный объекту
 | Перпендикулярный объекту
 | Касательный к объекту
Дуга | По трем точкам
 | Сопряженная
Сплайн | Кривая Безье
 | NURBS

По умолчанию при первом обращении к команде текущий тип объекта — Отрезок. Это означает, что при указании точек будет построена ломаная, состоящая из отрезков, соединяющих эти точки.

В любой момент ввода последовательности вы можете изменить текущий тип объекта. Для этого активизируйте нужный переключатель в группе Тип.

Способы построения различных объектов при непрерывном вводе, а также приемы управления их параметрами аналогичны способам и приемам, приведенным выше, в описании команд построения отдельных объектов.


3.2.10.2. Завершение ввода объектов

Для завершения ввода объектов служат переключатели Замкнуть и Новый ввод на Панели свойств.

После активизации переключателя Замкнуть автоматически создается точка, совпадающая с первой точкой последовательности объектов, и построение последовательности завершается. Автоматически введенная точка принадлежит тому типу объекта, построение которого было включено в момент замыкания. Если количество уже введенных точек объекта недостаточно для автоматического построения объекта, замыкающего последовательность, то переключатель Замкнуть недоступен. После замыкания введенной последовательности система ожидает ввода новой непрерывной последовательности объектов.

После активизации переключателя Новый ввод построение последовательности завершается без замыкания, и система ожидает ввода новой последовательности.


3.2.10.3. Стиль линии при непрерывном вводе объектов

Текущий стиль распространяется только на формируемый в данный момент объект, а не на все объекты последовательности. Поэтому вы можете чертить объекты различного стиля, не прерывая ввод последовательности.


3.2.11. Линия

3.2. Геометрические объекты

3.2.11. Линия

Чтобы построить линию, состоящую из отрезков и/или дуг окружностей, положение которых может либо автоматически определяться системой в зависимости от указанных объектов чертежа, либо задаваться пользователем, вызовите команду Линия.

При вводе линии конечная точка созданного объекта автоматически становится начальной точкой следующего объекта.

Построенная последовательность не является единым объектом. Дуги и отрезки будут выделяться, редактироваться и удаляться по отдельности.

Доступно два типа объектов, составляющих линию: отрезок и дуга. В любой момент построения линии вы можете изменить текущий тип объекта.

Способ создания отрезка или дуги определяется системой автоматически в зависимости от того, какие объекты указаны пользователем. Например, если во время построения отрезка указан прямолинейный объект, то отрезок может быть параллелен или перпендикулярен ему. Это определяется направлением движения курсора.

При создании первого объекта последовательности доступны дополнительные способы построения, поскольку у этого объекта, в отличие от последующих, не зафиксирована ни одна точка.

Способы создания первых объектов линии описаны в разделах 3.2.11.2 и 3.2.11.4, а способы создания последующих объектов — в разделах 3.2.11.3 и 3.2.11.5.

Переключатель Новый ввод, расположенный на Панели свойств, позволяет прервать создание текущей линии и начать новую.

Переключатель Непрерывный ввод объектов позволяет указать, будут ли создаваться отдельные объекты или их последовательность. По умолчанию при первом вызове команды Линия этот переключатель активен и начальная точка каждого следующего объекта совпадает с конечной точкой предыдущего. Чтобы задавать начальные точки объектов произвольно, отключите переключатель Непрерывный ввод объектов. Чтобы вернуться к созданию последовательности, активизируйте переключатель вновь.

В этом разделе:

3.2.11.1. Общий порядок построения объектов линии

3.2.11.2. Способы построения первого отрезка

3.2.11.2.1. Параллельно или перпендикулярно объекту

3.2.11.2.2. Касательно к объекту

3.2.11.2.3. Касательно к одному объекту и параллельно другому

3.2.11.2.4. Посередине между двумя параллельными прямыми

3.2.11.2.5. Касательно к двум объектам

3.2.11.2.6. На биссектрисе угла

3.2.11.3. Способы построения последующих отрезков

3.2.11.3.1. Параллельно или перпендикулярно объекту

3.2.11.3.2. Касательно к объекту

3.2.11.4. Способы построения первой дуги

3.2.11.4.1. Касательно к объекту

3.2.11.4.2. Произвольная

3.2.11.5. Способы построения последующих дуг

3.2.11.5.1. Касательно к объекту

3.2.11.5.2. По нормали к предыдущему сегменту

3.2.11.5.3. Произвольная


3.2.11.1. Общий порядок построения объектов линии

1. Укажите тип сегмента, активизировав нужный переключатель в группе Тип на Панели свойств:

– Отрезок,

– Дуга.

Текущий тип сегмента линии можно менять без обращения к Панели свойств — с помощью комбинации клавиш <Ctrl> + <Tab>.

2. Укажите объект (объекты) для построения сегмента. Например, отрезок или дуга может касаться окружности, отрезок может быть параллелен или перпендикулярен прямой, может лежать на биссектрисе угла и т.п.

Чтобы указать объект, подведите к нему курсор. Когда объект подсветится, нажмите левую кнопку мыши.

Если указать объект не удается, проверьте, выключена ли привязка Точка на кривой. Если привязка включена, выключите ее.

Невозможность указания объекта при включенной привязке объясняется тем, что она более приоритетна, чем выбор объекта.

Если требуется сменить объект, нажмите кнопку Указать заново на Панели специального управления. Выделение с ранее выбранного объекта снимется, и вы сможете указать новый объект.

После выбора объекта (объектов) на экране появится фантом — прямая или дуга, содержащая сегмент.

3. Укажите начальную и (или) конечную точки объекта. Если начальная (конечная) точка указана вне фантома сегмента, то положение начала (конца) объекта определяется как проекция указанной точки на фантом.

Во время построения сегментов линии на Панели свойств отображаются поля параметров этих объектов: координаты начальной и конечной точек, радиус или диаметр (для дуг), длина и угол (для отрезков). Эти поля используются так же, как при создании отрезков и дуг с помощью специальных команд.

Подробно способы построения объектов линии описаны в разделах 3.2.11.2–3.2.11.5. В некоторых случаях последовательность действий может отличаться от вышеприведенного общего порядка.

После создания объекта система ожидает построения следующего объекта того же типа.

Обратите внимание на следующую особенность построения сегментов линии. В тех случаях, когда возможно несколько вариантов построения сегмента, выбирается вариант, ближайший к точке указания объекта. Этим создание сегментов линии отличается от создания аналогичных объектов с помощью специальных команд. Такой подход позволяет ускорить построение, но требует наличия определенного навыка.

Например, известно, что из одной точки может быть построено две касательных к окружности.

Если при построении отрезка, касательного к окружности, с помощью команды Касательный отрезок через внешнюю точку можно выбрать, на какой из касательных он будет лежать, то при построении касательного отрезка в составе линии выбор невозможен. Отрезок будет лежать на той прямой, которая касается окружности в точке, ближайшей к точке, в которой была указана окружность.


3.2.11.2. Способы построения первого отрезка

В этом разделе:

3.2.11.2.1. Параллельно или перпендикулярно объекту

3.2.11.2.2. Касательно к объекту

3.2.11.2.3. Касательно к одному объекту и параллельно другому

3.2.11.2.4. Посередине между двумя параллельными прямыми

3.2.11.2.5. Касательно к двум объектам

3.2.11.2.6. На биссектрисе угла


3.2.11.2.1. Параллельно или перпендикулярно объекту

Чтобы построить первый отрезок линии параллельно или перпендикулярно другому объекту, выполните следующие действия.

1. Укажите прямолинейный объект, которому должен быть перпендикулярен или параллелен создаваемый отрезок.

2. Укажите начальную точку отрезка.

Последовательность указания прямолинейного объекта и начальной точки отрезка значения не имеет.

3. Перемещайте курсор по полю документа. На экране появится фантом отрезка. В зависимости от положения курсора относительно начальной точки фантом может быть параллельным или перпендикулярным объекту. Если курсор находится в области 1 (рис. 3.2.56, а), то фантом отрезка строится параллельно объекту (рис. 3.2.56, б), а если в области 2, то — перпендикулярно (рис. 3.2.56, в).

Рис. 3.2.56. Построение отрезка параллельно/перпендикулярно прямолинейному объекту
а) | б) | в)

4. Перемещая курсор, выберите нужное направление отрезка и укажите его конечную точку.


3.2.11.2.2. Касательно к объекту

Чтобы построить первый отрезок линии касательно к объекту, выполните следующие действия.

1. Укажите криволинейный объект, которого должен касаться создаваемый отрезок.

2. Перемещайте курсор по полю документа. Вы увидите, как вслед за курсором перемещается фантомом касательной.

Чтобы сменить направление касательной к окружности (эллипсу), проведите курсор так, чтобы он пересек окружность (эллипс).

3. Укажите начальную и конечную точки отрезка.

Рис. 3.2.57. Построение первого отрезка линии касательно к другому объекту: а) указание объекта, б) указание начальной точки отрезка, в) указание конечной точки отрезка
а) | б) | в)

Чтобы начать (закончить) отрезок точно в точке касания, воспользуйтесь привязкой Касание (пример см. на рис. 3.2.61).


3.2.11.2.3. Касательно к одному объекту и параллельно другому

Чтобы построить первый отрезок линии касательно к одному объекту и параллельно другому, выполните следующие действия.

1. Укажите криволинейный объект, которого должен касаться создаваемый отрезок.

Аналогичным образом укажите прямолинейный объект, которому должен быть параллелен отрезок.

Последовательность указания объектов значения не имеет.

2. Перемещайте курсор по полю документа. Вы увидите, как вслед за курсором перемещается фантомом касательной.

3. Укажите начальную и конечную точки отрезка.

Рис. 3.2.58. Построение первого отрезка линии касательно к одному объекту и параллельно другому: а) указание объектов, б) указание начальной точки отрезка, в) указание конечной точки отрезка
а) | б) | в)

Чтобы начать (закончить) отрезок точно в точке касания, воспользуйтесь привязкой Касание (пример см. на рис. 3.2.61).


3.2.11.2.4. Посередине между двумя параллельными прямыми

Чтобы построить первый отрезок линии так, чтобы он лежал на прямой, проходящей посередине между двумя прямолинейными объектами, параллельными друг другу, выполните следующие действия.

1. Укажите первый и второй прямолинейные объекты.

2. Укажите начальную точку отрезка.

3. Перемещайте курсор по полю документа. На экране появится фантом отрезка, лежащий на прямой, расположенной посередине между двумя выбранными прямолинейными объектами.

4. Укажите конечную точку отрезка.

Рис. 3.2.59. Построение первого отрезка линии на прямой, расположенной посередине между двумя параллельными прямыми: а) указание объектов, б) указание начальной точки отрезка, в) указание конечной точки отрезка
а) | б) | в)


3.2.11.2.5. Касательно к двум объектам

Чтобы построить первый отрезок линии касательно к двум объектам, выполните следующие действия.

1. Укажите первый и второй криволинейные объекты, которых должен касаться создаваемый отрезок.

После указания второго объекта на экране появится фантом отрезка, лежащего на прямой, касающейся указанных объектов в точках, ближайших к тем, в которых эти объекты были указаны.

2. Укажите начальную и конечную точки отрезка.

Рис. 3.2.60. Построение первого отрезка линии касательно к двум объектам: а) указание объектов, б) указание начальной точки отрезка, в) указание конечной точки отрезка
а) | б) | в)

Чтобы начать (закончить) отрезок точно в точке касания, воспользуйтесь привязкой Касание (рис. 3.2.61).

Рис. 3.2.61. Пример построения первого отрезка линии


3.2.11.2.6. На биссектрисе угла

Чтобы построить первый отрезок линии, лежащий на биссектрисе угла, образованного двумя прямолинейными объектами, выполните следующие действия.

1. Укажите два непараллельных прямолинейных объекта.

2. Укажите начальную точку отрезка.

Перемещайте курсор по полю документа. На экране появится фантом отрезка, лежащий на биссектрисе выбранного угла.

3. Укажите конечную точку отрезка.

Рис. 3.2.62. Построение первого отрезка линии, расположенного на биссектрисе угла: а) указание объектов, б) указание начальной точки отрезка, в) указание конечной точки отрезка
а) | б) | в)


3.2.11.3. Способы построения последующих отрезков

В этом разделе:

3.2.11.3.1. Параллельно или перпендикулярно объекту

3.2.11.3.2. Касательно к объекту


3.2.11.3.1. Параллельно или перпендикулярно объекту

Чтобы построить последующий отрезок линии параллельно или перпендикулярно другому объекту, выполните следующие действия.

1. Укажите прямолинейный объект, которому должен быть перпендикулярен или параллелен создаваемый отрезок.

2. Перемещайте курсор по полю документа. На экране появится фантом отрезка. В зависимости от положения курсора относительно начальной точки фантом может быть параллельным или перпендикулярным объекту (см. рис. 3.2.56).

3. Перемещая курсор, выберите нужное направление отрезка и укажите его конечную точку.

Рис. 3.2.63. Построение последующего отрезка линии перпендикулярно/параллельно другому объекту: а) указание объекта, б) создание перпендикулярного отрезка, в) создание параллельного отрезка
а) | б) | в)


3.2.11.3.2. Касательно к объекту

Чтобы построить последующий отрезок линии касательно к объекту, выполните следующие действия.

1. Укажите криволинейный объект, которого должен касаться создаваемый отрезок.

2. Перемещайте курсор по полю документа. Вы увидите, как вслед за курсором перемещается фантом касательной. Он лежит на прямой, касающейся выбранного объекта в точке, ближайшей к той, в которой этот объект был указан.

3. Укажите конечную точку отрезка.

Рис. 3.2.64. Построение последующего отрезка линии касательно к другому объекту: а) указание объекта, б) указание конечной точки отрезка
а) | б)

Чтобы закончить отрезок точно в точке касания, воспользуйтесь привязкой Касание (рис. 3.2.65).

Рис. 3.2.65. Пример построения последующего отрезка линии


3.2.11.4. Способы построения первой дуги

В этом разделе:

3.2.11.4.1. Касательно к объекту

3.2.11.4.2. Произвольная


3.2.11.4.1. Касательно к объекту

Чтобы построить первую дугу линии касательно к объекту, выполните следующие действия.

1. Укажите начальную точку дуги.

2. Укажите объект, которого должна касаться дуга.

3. Перемещайте курсор по полю документа. Вы увидите, как вслед за ним перемещается фантом дуги. Если необходимо сменить направление дуги, проведите курсор через ее начальную точку.

Фантом касается выбранного объекта в той точке, в которой этот объект был указан. Радиус дуги определяется автоматически и фиксируется.

– Чтобы изменить радиус, введите нужное значение в поле Радиус или Диаметр на Панели свойств.

– Чтобы задать радиус указанием конечной точки, расфиксируйте поле Радиус или Диаметр и не вводите значение.

4. Укажите конечную точку дуги.

Рис. 3.2.66. Построение первой дуги линии касательно к объекту: а) указание начальной точки, б) указание объекта, в) указание конечной точки
а) | б) | в)

Если положение начальной и конечной точек дуги задано жестко, то они однозначно определяют радиус дуги. В этом случае вы можете сначала указать начальную и конечную точки дуги, а затем объект, которого она должна касаться (рис. 3.2.67). Дуга будет зафиксирована с автоматически определенным радиусом.

Рис. 3.2.67. Построение первой дуги линии касательно к объекту: а) указание начальной и конечной точек, б) указание объекта
а) | б)


3.2.11.4.2. Произвольная

Чтобы построить первую дугу произвольным образом, выполните следующие действия.

1. Укажите начальную и конечную точки дуги. На экране появится фантом дуги.

2. Введите с клавиатуры радиус или диаметр дуги или укажите мышью точку, через которую должна пройти дуга.


3.2.11.5. Способы построения последующих дуг

В этом разделе:

3.2.11.5.1. Касательно к объекту

3.2.11.5.2. По нормали к предыдущему сегменту

3.2.11.5.3. Произвольная


3.2.11.5.1. Касательно к объекту

Последующая дуга линии может быть построена касательно к:

– предыдущему сегменту линии,

– предыдущему сегменту и произвольному объекту,

– произвольному объекту.

По умолчанию последующая дуга линии строится касательно к предыдущему сегменту. Этот сегмент подсвечивается в окне документа.

Чтобы построить дугу касательно к предыдущему сегменту, выполните следующие действия.

1. Если радиус или диаметр дуги известен, введите нужное значение в поле Радиус или Диаметр на Панели свойств и зафиксируйте.

2. Перемещайте курсор по полю документа. Вы увидите, как вслед за ним перемещается фантом дуги.

Если необходимо сменить направление дуги, проведите курсор через ее начальную точку.

3. Укажите конечную точку дуги.

Рис. 3.2.68. Построение последующей дуги касательно к предыдущему сегменту линии

Чтобы построить дугу касательно к предыдущему сегменту и к произвольному объекту, выполните следующие действия.

1. Укажите второй объект, которого должна касаться дуга. Он будет подсвечен в окне документа.

2. Перемещайте курсор по полю документа. Вы увидите, как вслед за ним перемещается фантом дуги. Радиус дуги изменить нельзя — он жестко определен двумя объектами, которых касается дуга.

Если необходимо сменить направление дуги, проведите курсор через ее начальную точку.

3. Укажите конечную точку дуги.

Рис. 3.2.69. Построение последующей дуги касательно к предыдущему сегменту и к произвольному объекту: а) выбор объекта, б) указание конечной точки
а) | б)

Чтобы построить дугу касательно к произвольному объекту, выполните следующие действия.

1. Нажмите кнопку Указать заново на Панели специального управления. Подсветка с предыдущего сегмента снимется.

2. Укажите объект, которого должна касаться дуга.

3. Перемещайте курсор по полю документа. Вы увидите, как вслед за ним перемещается фантом дуги. Он касается выбранного объекта в той точке, в которой этот объект был указан. Радиус дуги определяется автоматически и фиксируется. Чтобы изменить радиус или диаметр, введите нужное значение в поле Радиус или Диаметр на Панели свойств. Фантом перестроится.

Если необходимо сменить направление дуги, проведите курсор через ее начальную точку.

4. Укажите конечную точку дуги.

Рис. 3.2.70. Построение последующей дуги линии касательно к произвольному объекту: а) выбор объекта, б) указание конечной точки дуги
а) | б)


3.2.11.5.2. По нормали к предыдущему сегменту

Последующая дуга линии может быть построена касательно к нормали, проведенной к предыдущему сегменту линии в его конечной точке. Точкой касания является начальная точка дуги. Построение дуги по нормали к предыдущему сегменту приведено на рис. 3.2.71. Основной линией показан предыдущий сегмент, штриховой — нормаль к нему в его конечной точке, тонкой — дуга по нормали.

Рис. 3.2.71. Дуга по нормали: а) к дуге, б) к отрезку
а) | б)

Чтобы перейти к построению дуги по нормали, нажмите клавишу <Ctrl>, сдвиньте мышь и отпустите клавишу. Вы увидите, что фантом дуги перестроится так, чтобы в начальной точке касаться нормали к предыдущему сегменту, проведенной в его конечной точке.

Дуга по нормали может касаться объекта или быть произвольной.

Чтобы построить дугу по нормали касательно к объекту, выполните следующие действия.

1. Укажите объект, которого должна касаться дуга. Для этого подведите курсор к нужному объекту. Когда объект подсветится, нажмите левую кнопку мыши.

2. Перемещайте курсор по полю документа. Вы увидите, как вслед за ним перемещается фантом дуги. Радиус дуги изменить нельзя — он жестко определен двумя объектами, которых касается дуга.

Если необходимо сменить направление дуги, проведите курсор через ее начальную точку.

Если требуется сменить объект, которого касается дуга, нажмите кнопку Указать заново на Панели специального управления. Выделение с ранее выбранного объекта снимется, и вы сможете указать новый объект.

3. Укажите конечную точку дуги.

Рис. 3.2.72. Дуга по нормали, касательная к объекту: а) выбор объекта, б) указание конечной точки дуги
а) | б)

Чтобы построить произвольную дугу по нормали, выполните следующие действия.

1. Если радиус или диаметр дуги известен, введите нужное значение в поле Радиус или Диаметр на Панели свойств и зафиксируйте.

2. Перемещайте курсор по полю документа. Вы увидите, как вслед за ним перемещается фантом дуги.

Если необходимо сменить направление дуги, проведите курсор через ее начальную точку.

3. Укажите конечную точку дуги.

Рис. 3.2.73. Построение произвольной дуги по нормали

Следующая дуга линии тоже будет строиться по нормали. Чтобы вернуться к построению касательных дуг, нажмите клавишу <Ctrl>, сдвиньте мышь и отпустите клавишу. Фантом дуги перестроится.


3.2.11.5.3. Произвольная

По умолчанию последующая дуга линии строится касательно предыдущему сегменту. Этот сегмент подсвечивается в окне документа.

Чтобы отказаться от построения касательной дуги, нажмите кнопку Указать заново на Панели специального управления. Подсветка с предыдущего сегмента снимется. Затем выполните следующие действия.

1. Укажите конечную точку дуги. На экране появится фантом дуги.

2. Введите с клавиатуры радиус или диаметр дуги в поле Радиус или Диаметр или укажите мышью точку, через которую должна пройти дуга.


3.2.12. Мультилиния

3.2. Геометрические объекты

3.2.12. Мультилиния

В этом разделе:

3.2.12.1. Общие сведения

3.2.12.2. Термины и определения

3.2.12.3. Создание мультилинии

3.2.12.4. Линии мультилинии

3.2.12.5. Шаблон мультилинии

3.2.12.6. Базовая линия

3.2.12.6.1. Прямолинейный и дуговой сегменты

3.2.12.6.2. Сегмент по объекту

3.2.12.6.3. Модификация базовой линии

3.2.12.7. Способы обхода угла в вершине

3.2.12.7.1. Обход срезом

3.2.12.7.2. Обход скруглением

3.2.12.7.3. Обход скруглением с одинаковым радиусом

3.2.12.8. Ограничители мультилинии

3.2.12.8.1. Выбор вида ограничителя мультилинии

3.2.12.8.2. Задание параметров ограничителя

3.2.12.9. Режимы работы с мультилинией

3.2.12.10. Редактирование вершины

3.2.12.10.1. Операция редактирования вершины

3.2.12.10.2. Операция вставки вершины

3.2.12.11. Удаление и восстановление участков линий мультилиний

3.2.12.12. Особенности редактирования мультилинии


3.2.12.1. Общие сведения

Мультилиния — геометрический объект, состоящий из одной или нескольких линий, построенных эквидистантно к базовой линии. Мультилинию можно использовать для изображения трубопроводов, стен, перегородок, ограждений и других протяженных объектов с контуром из нескольких линий (рис. 3.2.74).

Рис. 3.2.74. Пример использования мультилиний

Не рекомендуется изображать одной мультилинией несколько объектов (например, группу параллельных трубопроводов).

Линии в мультилинии могут иметь различные стили.

Максимальное количество линий в мультилинии — 64.

Все линии мультилинии располагаются в одном слое.

Возможно изменение конфигурации базовой линии.

Вы можете настроить умолчательные параметры мультилинии в настроечном диалоге (см. раздел 9.2.6.9), а также задать пользовательские параметры при создании мультилинии.

Пользовательские параметры мультилинии можно сохранить для последующего использования, записав в файл шаблона мультилинии. Используя эти шаблоны, вы можете создать однотипные мультилинии.

Мультилиния может входить в состав макроэлемента и группы.


3.2.12.2. Термины и определения

Рис. 3.2.75. Мультилиния (базовая линия показана пунктиром)

Базовая линия мультилинии — невидимая линия мультилинии, вершины которой задаются при создании мультилинии и от которой эквидистантно строятся все остальные линии мультилинии.

Сегмент базовой линии мультилинии — часть базовой линии между соседними вершинами.

Линия мультилинии — составной геометрический объект, состоящий из последовательно соединенных линейных, сплайновых сегментов, дуг окружностей и эллипсов.

Сегмент мультилинии — часть мультилинии, построенная по одному сегменту базовой линии.

Ограничитель мультилинии — линия, соединяющая определенным образом конечные точки крайних линий конечного сегмента мультилинии.

Разделитель сегментов мультилинии — линия, соединяющая определенным образом крайние линии мультилинии на стыке сегментов.

Ширина мультилинии — расстояние между крайними линиями мультилинии, причем базовая линия не считается крайней линией. Ширина мультилинии, состоящей из одной линии, равна 0.

Тип мультилинии — совокупность следующих параметров мультилинии:

– количество линий и их параметры — смещение от базовой линии и стиль;

– вид ограничителей мультилинии и их параметры — высота и стиль линии.

Однотипные мультилинии — это мультилинии, имеющие один тип. Однако расположение вершин базовой линии, их количество и разделители сегментов в однотипных линиях могут быть различными.


3.2.12.3. Создание мультилинии

Чтобы создать мультилинию, вызовите команду Мультилиния. На Панели свойств появятся элементы управления построением мультилинии (рис. 3.2.76).

Рис. 3.2.76. Панель свойств при построении мультилинии

По умолчанию включен режим добавления сегментов в мультилинию — нажата кнопка Добавить сегменты.

Задайте параметры мультилинии: количество, смещение и стили линий. Это можно сделать следующими способами:

– задать параметры на Панели свойств (см. раздел 3.2.12.4),

– получить параметры из шаблона мультилинии (см. раздел 3.2.12.5),

– скопировать параметры ранее построенной мультилинии (см. раздел 3.2.12.6).

Добавьте сегменты базовой линии (см. раздел 3.2.12.6) и выберите способы обхода угла в вершинах — варианты соединения линий мультилинии на стыках сегментов (см. раздел 3.2.12.7).

В окне документа отображается фантом создаваемой мультилинии. Вы можете непосредственно в процессе построения мультилинии отредактировать конфигурацию базовой линии (см. раздел 3.2.12.10) — изменить положение вершины и способ обхода угла в ней, а также добавить или удалить вершину. Все сделанные изменения немедленно отражаются на фантоме мультилинии.

Группа переключателей Режим построения позволяет указать, требуется замыкать мультилинию или нет. Мультилиния замыкается прямолинейным сегментом.

Мультилинию, состоящую из одного прямолинейного или сплайнового сегмента, замкнуть нельзя.

Для незамкнутой мультилинии вы можете задать вид ограничителей (см. раздел 3.2.12.8.1) и их параметры: высоту и стиль линий отрисовки (см. раздел 3.2.12.8.2).

Чтобы завершить построение мультилинии, нажмите кнопку Создать объект на Панели специального управления.


3.2.12.4. Линии мультилинии

Список линий мультилинии показывается на панели Линии вкладки Параметры (рис. 3.2.77).

Рис. 3.2.77. Панель Линии

В списке отображаются стили линий и их смещение относительно базовой линии. Линии в списке располагаются в порядке возрастания их смещений. Пределы смещения: от -50000000 до 50000000. Умолчательный набор линий задается при настройке параметров мультилинии для новых или текущего чертежей (см. раздел 9.2.6.9).

Панель Линии содержит также кнопки для управления линиями. Описание кнопок панели представлено в таблице 3.2.3.

Табл. 3.2.3. Управление линиями мультилинии

Кнопка

Описание

Создать новую линию

Позволяет добавить новую линию в мультилинию.

После нажатия кнопки к мультилинии добавляется новая линия, а в список — новая строка, содержащая параметры новой линии. По умолчанию эта линия имеет стиль Основная и отрицательное смещение. Добавление производится с шагом 10.

Добавить новую линию можно также, нажав клавишу <Ins>.

Чтобы изменить смещение, введите нужное значение в первое поле строки, а чтобы изменить стиль — выберите нужный вариант из списка во втором поле.

Создать симметричную линию

Позволяет добавить в мультилинию линию, симметричную выделенной в списке.

После нажатия кнопки к мультилинии добавляется новая линия, а в список — новая строка, содержащая параметры новой линии. Добавленная линия имеет стиль выделенной линии и ее смещение с противоположным знаком. Новая строка занимает в списке позицию, соответствующую своему смещению.

Кнопка не доступна, если в списке выделена линия, уже имеющая симметричную, или если смещение выделенной линии равно 0.

Удалить линию

Позволяет удалить из мультилинии линию, выделенную в списке.

После нажатия кнопки выделенная линия удаляется из мультилинии и из списка.

Удалить линию можно также, нажав комбинацию клавиш <Ctrl>+<Delete>.

Кнопка не доступна, если в списке всего одна линия или если выделены все линии.

Вырожденные линии мультилинии не показываются в документе. При появлении в мультилинии таких линий на экране появляется сообщение о невозможности их отображения.

Вырожденные линии не удаляются из мультилинии — они видны в списке линий мультилиний на панели Линии вкладки Параметры. При изменении формы базовой линии и/или значений смещений этих линий они становятся видимыми.

Если при построении или редактировании мультилинии все ее линии вырождаются, то на экране отображается только фантом базовой линии, а кнопка Создать объект становится недоступна.


3.2.12.5. Шаблон мультилинии

Параметры мультилинии можно сохранить для последующего использования, записав в файл шаблона мультилинии. Файл шаблона имеет расширение mlt.

Шаблоны мультилиний хранятся в папке, путь к которой задается переменной MULTILINETEMPLATES среды КОМПАС-3D. По умолчанию это подпапка \Templates главной папки системы. Чтобы задать другую папку для размещения шаблонов мультилиний, создайте и отредактируйте файл KOMPAS.ini (о переменных среды КОМПАС-3D см. раздел 9.5.4, о файле KOMPAS.ini см. раздел 9.5.3).

Шаблон мультилинии содержит параметры мультилинии:

– количество линий и их параметры — стиль и смещение от базовой линии;

– виды ограничителей на концах мультилинии и их параметры — высоту ограничителей и стиль линий.

Чтобы сохранить параметры текущей мультилинии, нажмите кнопку Сохранить шаблон на вкладке Параметры Панели свойств. На экране появится стандартный диалог сохранения файла. Введите имя файла шаблона и нажмите кнопку Сохранить.

Чтобы использовать шаблон при создании или редактировании мультилинии, нажмите кнопку Загрузить шаблон на вкладке Параметры на Панели свойств. На экране появится стандартный диалог открытия файла. Выберите имя нужного файла и нажмите кнопку Открыть. Мультилиния получит параметры из шаблона. Фантом мультилинии изменится соответственно полученным параметрам.

При необходимости вы можете отредактировать полученные из шаблона параметры мультилинии (см. раздел 3.2.12.4 и раздел 3.2.12.8).

Если при загрузке шаблона на экране появляется сообщение Невозможно открыть файл, это означает, что выбранный файл не является шаблоном или файл шаблона некорректен.


3.2.12.6. Базовая линия

Базовая линия мультилинии состоит из сегментов.

Группа переключателей Тип (рис. 3.2.78) позволяет выбрать тип сегмента для добавления в базовую линию:

Прямолинейный сегмент или Дуговой сегмент (см. раздел 3.2.12.6.1);

Сегмент по объекту (см. раздел 3.2.12.6.2).

Рис. 3.2.78. Группа переключателей Тип

Добавление сегментов в базовую линию возможно при создании и редактировании мультилинии.

В этом разделе:

3.2.12.6.1. Прямолинейный и дуговой сегменты

3.2.12.6.2. Сегмент по объекту

3.2.12.6.3. Модификация базовой линии


3.2.12.6.1. Прямолинейный и дуговой сегменты

Прямолинейные и дуговые сегменты можно добавить в базовую линию, непосредственно построив их при создании (или редактировании) мультилинии.

Чтобы добавить в базовую линию прямолинейный или дуговой сегмент, активизируйте нужный переключатель в группе Тип: Прямолинейный сегмент или Дуговой сегмент. Постройте сегмент базовой линии. Порядок построения прямолинейного и дугового сегментов аналогичен порядку построения объектов линии (см. раздел 3.2.11.1).

Обратите внимание на следующие особенности построения сегментов базовой линии.

– По умолчанию дуговой сегмент строится по касательной к предыдущему сегменту любого типа.

– По умолчанию прямолинейный сегмент строится по касательной к предыдущему дуговому сегменту.

Чтобы отказаться от построения сегмента по касательной к предыдущему сегменту, нажмите кнопку Указать заново на Панели специального управления. Далее можно построить произвольно ориентированный сегмент базовой линии.

Добавление сегмента отображается на фантоме мультилинии.

После добавления сегмента система ожидает добавления следующего сегмента того же типа. Конечная вершина созданного сегмента автоматически становится начальной вершиной следующего сегмента.


3.2.12.6.2. Сегмент по объекту

Вы можете добавить в базовую линию незамкнутый геометрический объект, ранее созданный в графическом документе:

– отрезок;

– дугу окружности или эллипса;

– NURBS, кривую Безье или ломаную;

– контур;

– мультилинию.

Чтобы добавить базовую линию незамкнутый геометрический объект, активизируйте в группе Тип переключатель Сегмент по объекту.

Укажите объект для добавления в базовую линию. Для этого подведите к нему курсор. Когда объект подсветится, нажмите левую кнопку мыши.

Если в мультилинии уже есть сегменты, то добавление объекта возможно при условии, что конечная вершина последнего сегмента совпадает с начальной или конечной точкой добавляемого объекта.

В базовую линию можно добавить несколько последовательно соединенных объектов. Указывать эти объекты следует по порядку расположения.

Кривая Безье, NURBS и ломаная добавляются в базовую линию целиком. При этом кривая Безье или NURBS добавляется одним сегментом, а ломаная — в виде нескольких сегментов, количество которых равно количеству сегментов ломаной.

Вы можете указать в качестве объекта другую мультилинию. В этом случае в базовую линию добавятся все сегменты указанной мультилинии с заданными для нее способами обхода угла в вершине базовой линии (см. раздел 3.2.12.7).

Чтобы отменить выбор объекта, нажмите кнопку Отменить на панели Стандартная.

Переключатели группы Режим управления позволяют указать, требуется ли оставлять исходные объекты после их добавления в базовую линию или нет.


3.2.12.6.3. Модификация базовой линии

После того как мультилиния построена, к ее базовой линии можно добавить прямолинейные или дуговые сегменты, используя команды Фаска на углах объекта (см. раздел 3.2.15.2) и Скругление на углах объекта (см. раздел 3.2.15.4). Вершины новых сегментов будут иметь умолчательные параметры — обход угла срезом без разделителя сегментов (о способах обхода угла см. раздел 3.2.12.7).

Кроме того, вы можете добавить сегмент в начало и/или середину базовой линии мультилинии путем разбиения данной мультилинии на части и создания новой мультилинии из нового сегмента (сегментов) и частей первоначальной мультилинии.

Например, в документе построена мультилиния с вершинами А, В, С, D (рис. 3.2.79, а). Необходимо в начало и середину (между вершинами В и С) этой мультилинии добавить кривые (рис 3.2.79, б).

Рис. 3.2.79. Добавление сегментов в мультилинию: а) первоначальная мультилиния; б) результат добавления
а) | б)

Для этого выполните следующие действия.

1. Разбейте мультилинию на три участка в вершинах В и С. Для этого воспользуйтесь командой Разбить кривую.

2. Удалите участок ВС.

3. Постройте кривую нужной формы.

Конечная точка кривой должна совпадать с начальной вершиной мультилинии А.

4. Постройте вторую кривую.

Начальная и конечная точки кривой должны совпадать с вершинами В и С.

5. Вызовите команду Мультилиния.

6. Скопируйте в новую мультилинию свойства первоначальной мультилинии.

6.1. Нажмите кнопку Копировать свойства на Панели специального управления.

6.2. Укажите в окне документа источник свойств — любую из частей первоначальной мультилинии.

7. Добавьте в базовую линию новой мультилинии построенные объекты и части первоначальной мультилинии.

7.1. Активизируйте в группе Тип переключатель Сегмент по объекту.

7.2. Укажите объекты для добавления в базовую линию: построенные объекты и части первоначальной мультилинии. Указывать эти объекты следует по порядку расположения.

Чтобы при построении новой мультилинии удалить исходные объекты, активизируйте переключатель Удалять исходные объекты в группе Режим построения вкладки Параметры.


3.2.12.7. Способы обхода угла в вершине

Способ обхода угла в вершине базовой линии — это способ соединения линий мультилинии на стыке сегментов. Возможны три способа обхода угла (рис. 3.2.80): обход срезом (см. раздел 3.2.12.7.1), обход скруглением (см. раздел 3.2.12.7.2), обход скруглением с одинаковым радиусом (см. раздел 3.2.12.7.3).

Рис. 3.2.80. Способы обхода угла в вершине базовой линии: а) обход срезом, б) обход скруглением, в) обход скруглением с одинаковым радиусом
а) | б) | в)

– При построении мультилинии способ обхода угла задается для начальной вершины добавляемого сегмента. Заданный способ по умолчанию используется для последующих вершин.

– При редактировании мультилинии вы можете задать нужный способ обхода угла для любой ее вершины, кроме конечных.

Для выбора способа обхода угла служит группа переключателей Обход угла на вкладке Мультилиния Панели свойств.

Чтобы задать требуемый способ обхода угла активизируйте нужный переключатель: Обход срезом, Обход скруглением, Обход скруглением с одинаковым радиусом.

В этом разделе:

3.2.12.7.1. Обход срезом

3.2.12.7.2. Обход скруглением

3.2.12.7.3. Обход скруглением с одинаковым радиусом


3.2.12.7.1. Обход срезом

Способ Обход срезом позволяет вставить разделитель на стыке сегментов мультилинии.

Чтобы выбрать нужный разделитель, раскройте список Разделитель на вкладке Мультилиния Панели свойств и укажите в нем нужную строку (табл. 3.2.4).

Табл. 3.2.4. Разделители сегментов мультилинии
Разделитель | Изображение
Без разделителя |
Дуговой |
Угловой |
Перекрытие |

Для разделителей Дуговой и Перекрытие можно задать направление, т.е. выбрать, для какого из двух стыкующихся сегментов будет создан разделитель.

Для выбора направления разделителя сегментов служит группа переключателей Направление.

Чтобы задать требуемое направление разделителя активизируйте нужный переключатель: Направление 1 или Направление 2.

По умолчанию линия отрисовки разделителя имеет стиль Основная. Для изменения стиля линии воспользуйтесь списком Стиль на Панели свойств. Список недоступен, если на стыке сегментов мультилинии нет разделителя.

Обратите внимание на то, что если стиль отрисовки дугового разделителя отличается от стиля крайних линий мультилинии, то стык сегментов выглядит так, как показано на рис. 3.2.81.

Рис. 3.2.81. Стык сегментов с дуговым разделителем


3.2.12.7.2. Обход скруглением

Способ Обход скруглением позволяет соединить линии мультилинии в стыках сегментов, скруглив их радиусом эквидистанты.


3.2.12.7.3. Обход скруглением с одинаковым радиусом

Способ Обход скруглением с одинаковым радиусом позволяет соединить линии мультилинии в стыках сегментов скруглением. Радиус скругления для всех линий одинаковый. По умолчанию радиус скругления равен 10.

Введите нужный радиус скругления в поле Радиус или установите с помощью счетчика.


3.2.12.8. Ограничители мультилинии

Умолчательный вид и параметры ограничителей задаются при настройке мультилинии (см. раздел 9.2.6.9). Вы можете изменить вид ограничителя конечного сегмента мультилинии (см. раздел 3.2.12.8.1) и его параметры: высоту и стиль линии отрисовки (см. раздел 3.2.12.8.2).

После редактирования мультилинии ограничители могут перестать отображаться в документе. Это происходит в следующих случаях:

– в мультилинии осталась одна линия;

– в мультилинии не отображается ни одна крайняя линия мультилинии.

Информация об ограничителях, которые не отображаются, сохраняется в мультилинии.

В этом разделе:

3.2.12.8.1. Выбор вида ограничителя мультилинии

3.2.12.8.2. Задание параметров ограничителя


3.2.12.8.1. Выбор вида ограничителя мультилинии

Чтобы задать вид ограничителя, укажите нужную строку в списке Ограничитель 1 (или Ограничитель 2) на вкладке Параметры Панели свойств (табл. 3.2.5).

Табл. 3.2.5. Ограничители мультилинии
Ограничители | Изображение
Без ограничителя |
Прямолинейный |
Дуговой |
Ломаный |


3.2.12.8.2. Задание параметров ограничителя

Чтобы задать высоту ограничителя, ведите ее значение в поле Высота 1, % (или Высота 2, %) вкладки Параметры Панели свойств. Величина данного параметра задается в процентах от 0 до 100 от ширины мультилинии.

Чтобы сменить стиль линии, воспользуйтесь списком Стиль 1 (или Стиль 2) на Панели свойств.

Обратите внимание на то, что если стиль отрисовки прямолинейного ограничителя отличается от стиля крайних линий мультилинии, то в зависимости от значения высоты ограничитель выглядит так, как показано на рис. 3.2.82.

Рис. 3.2.82. Прямолинейный ограничитель: а) с нулевой высотой; б) с высотой больше нуля
а) | б)


3.2.12.9. Режимы работы с мультилинией

По умолчанию при создании мультилинии включен режим добавления сегментов — нажата кнопка Добавить сегменты на Панели специального управления. В этом режиме создается базовая линия, задаются параметры мультилинии и выбираются способы обхода угла в вершине мультилинии (см. раздел 3.2.12.3).

Второй режим работы с мультилинией — режим редактирования элементов. В этом режиме вы можете изменять положение вершин базовой линии (см. раздел 3.2.12.10.1) и вставлять в нее новые вершины (см. раздел 3.2.12.10.2). Также в этом режиме вы можете изменять параметры мультилинии (см. разделы 3.2.12.4, 3.2.12.7 и 3.2.12.8). Для перехода в режим редактирования нажмите кнопку Редактировать элементы на Панели специального управления. На фантоме мультилинии появляются вершины базовой линии в виде маленьких черных квадратов.

Кнопка Редактировать элементы доступна, если мультилиния имеет хотя бы один сегмент.

Между режимами добавления сегментов и редактирования элементов можно произвольно переключаться при помощи кнопок Панели специального управления или команд в контекстном меню.

По умолчанию при редактировании уже созданной мультилинии режим редактирования элементов включается автоматически.


3.2.12.10. Редактирование вершины

При необходимости вы можете изменять конфигурацию базовой линии мультилинии, редактируя ее вершины.

Редактирование вершин базовой линии производится в режиме редактирования элементов мультилинии (на Панели специального управления нажата кнопка Редактировать элементы). Подробнее о режимах работы с мультилинией рассказано в разделе 3.2.12.9.

Группа переключателей Операция (рис. 3.2.83) позволяет выбрать операцию редактирования вершины базовой линии:

– Редактирование вершины — изменение положения, параметров или удаление вершины (см. раздел 3.2.12.10.1);

– Вставка вершины (см. раздел 3.2.12.10.2).

Рис. 3.2.83. Группа переключателей Операция

В этом разделе:

3.2.12.10.1. Операция редактирования вершины

3.2.12.10.2. Операция вставки вершины


3.2.12.10.1. Операция редактирования вершины

Операция редактирования вершины позволяет:

– изменить положение вершины;

– удалить вершину;

– задать способ обхода угла в вершине, если данная вершина не является конечной (см. раздел 3.2.12.7).

Чтобы отредактировать вершину, активизируйте переключатель Редактирование вершин в группе Операция.

Указание вершины

Подведите курсор к нужной вершине. Форма курсора изменится — он превратится в четырехстороннюю стрелку. Нажмите левую кнопку мыши. Вершина будет активизирована — ее цвет изменится с черного на установленный для выделенных объектов (см. раздел 9.1.7.11).

Чтобы снять выделение с вершины, щелкните мышью вне фантома мультилинии.

Перемещение вершины

Укажите вершину. Измените ее положение, перемещая мышь или задав новые координаты (см. ниже). Кроме того, для этой вершины можно задать нужный способ обхода угла (см. раздел 3.2.12.7).

Задание координат вершины

Укажите вершину. На Панели свойств рядом с группой Операция находятся поля с координатами этой вершины. Введите в поля координат новые значения и зафиксируйте их, нажав клавишу <Enter>. После этого выделенная вершина займет новое положение.

Удаление вершины

Укажите вершину и нажмите клавишу <Delete>. Вершина удаляется, мультилиния перестраивается.

– При удалении конечной вершины мультилинии удаляется соответствующий ей сегмент.

– При удалении любой другой вершины мультилинии удаляются прилегающие к ней сегменты. Вместо них в мультилинию вставляется прямолинейный сегмент.

После удаления вершины односегментной мультилинии система переходит в режим добавления сегментов.


3.2.12.10.2. Операция вставки вершины

Операция вставки вершины в базовую линию позволяет добавить новую вершину в базовую линию.

Чтобы добавить в базовую линию новую вершину, активизируйте переключатель Вставка вершины в группе Операция.

Вставьте новую вершину в базовую линию.

Вы можете указать точку вставки новой вершины курсором на фантоме мультилинии. Если указанная точка не принадлежит мультилинии, то положение новой вершины будет определяться проекцией точки на базовую линию.

Для создания новой вершины можно ввести ее координаты в поля, расположенные на Панели свойств. Введенные координаты необходимо зафиксировать, нажав клавишу <Enter>.

Для новой вершины будет использован текущий способ обхода угла (см. раздел 3.2.12.7).


3.2.12.11. Удаление и восстановление участков линий мультилиний

После построения мультилинии к ее линиям могут быть применены команды Усечь кривую и Усечь кривую двумя точками (см. разделы 3.5.7.1 и 3.5.7.2). В результате применения этих команд участки линий мультилинии удаляются.

При необходимости вы можете восстановить удаленные участки линий мультилинии двумя способами.

1. Для восстановления одного или нескольких удаленных участков вызовите команду Восстановить удаленный участок линии мультилинии из меню Редактор или нажмите одноименную кнопку на панели Редактирование.

Наведите курсор на одну из крайних точек участка, подлежащего восстановлению. Указанный участок подсветится. После щелчка мышью данный участок будет восстановлен. Вы можете восстановить произвольное количество участков, последовательно указывая их курсором.

Если требуется восстановить несколько удаленных участков линий мультилинии или нескольких мультилиний, удобно использовать указание рамкой. Для указания участка данным способом достаточно, чтобы одна из его крайних точек находилась внутри рамки. Все участки, указанные рамкой, подсвечиваются и восстанавливаются после формирования рамки.

2. Для восстановления всех удаленных участков линии мультилинии вызовите команду Восстановить целостность линии мультилинии из меню Редактор или нажмите одноименную кнопку на панели Редактирование.

Наведите курсор на линию мультилинии, целостность которой требуется восстановить. Указанная линия подсветится. После щелчка мышью все удаленные участки данной линии будут восстановлены. Вы можете восстановить целостность произвольного количества линий мультилиний, последовательно указывая их курсором.

Если требуется восстановить целостность всех линий мультилинии или нескольких мультилиний, удобно использовать указание секущим отрезком (см. раздел Указание группы объектов секущим отрезком на с. 357). Указанные линии подсвечиваются. После формирования секущего отрезка удаленные участки всех указанных линий восстанавливаются.

Мультилинии, содержащие удаленные участки, могут быть выделены в окне документа до вызова команды восстановления целостности линии мультилинии. В этом случае после вызова команды на экране появляется запрос на восстановление всех удаленных участков данных мультилиний. Чтобы восстановить удаленные участки, нажмите кнопку ОК. Кнопка Отмена позволяет отказаться от восстановления.

Дальнейшая работа в команде выполняется, как описано выше.


3.2.12.12. Особенности редактирования мультилинии

Для работы с мультилинией можно использовать все команды редактирования, кроме команд Выровнять по границе, Удлинить до ближайшего объекта, Очистить область, Преобразовать в NURBS. Команды редактирования подробно описаны в разделе 3.5.

Мультилиния может использоваться как ограничивающий объект в командах Выровнять по границе и Удлинить до ближайшего объекта.

Кроме того, вы можете разбить мультилинию на отдельные объекты. Для этого воспользуйтесь командой Редактор — Разрушить.

Команда Удалить фаску или скругление (см. раздел 3.5.7.5) позволяет удалить дуговой или прямолинейный сегмент мультилинии при условии, что оставшиеся сегменты можно продолжить до точки пересечения.


3.2.13. Штриховка и заливка

3.2. Геометрические объекты

3.2.13. Штриховка и заливка

Штрихование и заливка цветом областей графического документа в системе КОМПАС-3D сходны по способу их построения.

Для создания штриховки или заливки требуется задать ее границы и параметры. Способы задания границ — общие для штриховки и заливки — изложены в разделе 3.2.13.1, приемы построения штриховки — в разделе 3.2.13.2, приемы построения заливки — в разделе 3.2.13.3.

В этом разделе:

3.2.13.1. Задание границ

3.2.13.1.1. Ручное рисование границ

3.2.13.1.2. Обход границы по стрелке

3.2.13.2. Штриховка

3.2.13.2.1. Построение штриховки

3.2.13.2.2. Параметры штриховки

3.2.13.3. Заливка

3.2.13.3.1. Типы заливки

3.2.13.3.2. Построение заливки

3.2.13.3.3. Параметры заливки

3.2.13.3.4. Дополнительные переходы цвета и уровни прозрачности заливки

3.2.13.3.5. Редактирование заливки


3.2.13.1. Задание границ

Количество и вложенность областей, задаваемых одновременно, не ограничены.

Объекты, ограничивающие штриховку (заливку), могут быть выделены перед вызовом команды. В этом случае после вызова команды на экране появится запрос на использование выделенных объектов в качестве границы штриховки (заливки). Для подтверждения следует нажать кнопку Да, и система сразу же построит штриховку (заливку), если это возможно.

Если объекты не были выделены или вы отказались от их использования, укажите точку внутри области, которую нужно заштриховать (залить). Система определит ближайшие границы, внутри которых указана точка, и построит фантом штриховки (или заполнит заливкой).

Границами штриховки или заливки могут служить системные линии стилей Основная и Для линии обрыва или линии пользовательских стилей, при настройке которых указано, что они могут использоваться в качестве границы штриховки.

Рис. 3.2.84. Построение штриховки: а) точки внутри областей, указанные для построения, б) полученная штриховка
а) | б)

Указание точки внутри области является умолчательным способом задания границы штриховки (заливки). Возможно также формирование границ вручную и по стрелке. Эти способы подробно описаны ниже.

При вводе ассоциативной штриховки и заливки (об ассоциативных объектах см. раздел 7.2.1.4) режимы ручного рисования границ и обхода границ по стрелке недоступны.

Кроме того, возможно указание в качестве границ штриховки (заливки) существующих геометрических объектов. Для этого служат команды Добавить границу и Исключить границу в контекстном меню. Каждая из них вызывает подменю с перечнем способов указания объектов.

Если штриховка (заливка) в нескольких несоединяющихся областях документа должна иметь одинаковые параметры, ее следует создавать как единый объект.

Например, границы всех областей штриховки сечения детали (рис. 3.2.85), следует указать как границы одной штриховки. Это обеспечит одинаковость параметров штриховки внутри них и облегчит ее последующее редактирование.

Рис. 3.2.85. Штриховка, состоящая из нескольких областей

В этом разделе:

3.2.13.1.1. Ручное рисование границ

3.2.13.1.2. Обход границы по стрелке


3.2.13.1.1. Ручное рисование границ

Ручное рисование границ — задание вручную границы области для выполнения операции. Нарисованные таким образом границы отображаются на экране только до завершения команды.

Для перехода в режим ручного рисования границ нажмите кнопку Ручное рисование границ.

Набор элементов управления на Панели свойств изменится — она примет вид, показанный на рис. 3.2.86.

Рис. 3.2.86. Панель свойств в режиме ручного рисования границ

Последовательно указывайте вершины ломаной, которая ограничивает область.

Переключатели группы Режим позволяют управлять замыканием ломаной.

Вы можете изменять положение вершин ломаной непосредственно в процессе построения. Для этого нажмите кнопку Редактировать точки.

Подведите курсор к любой характерной точке (они отображаются в виде черных квадратиков). Форма курсора изменится — он превратится в четырехстороннюю стрелку.

Измените положение характерных точек или удалите ненужные точки, аналогично редактированию ломаной (см. раздел 3.2.9.1.2).

Возможно также добавление характерных точек. Для этого щелкните мышью на нужном звене. Оно будет разбито на две части новой вершиной, расположенной в указанной точке. Вы можете «перетащить» ее в любое место.

Для выхода из режима редактирования точек отожмите кнопку Редактировать точки.

Закончив рисование границы, нажмите кнопку Создать объект.

Для отказа от ручного рисования границы нажмите клавишу <Esc> или кнопку Прервать команду.


3.2.13.1.2. Обход границы по стрелке

Обход границы по стрелке — задание границы области для выполнения какой-либо операции последовательным обходом пересекающиеся между собой геометрических объектов.

Для перехода в режим обхода границы по стрелке нажмите кнопку Обход границы по стрелке.

Набор элементов управления на Панели свойств изменится — она примет вид, показанный на рис. 3.2.87.

Рис. 3.2.87. Панель свойств в режиме обхода границы по стрелке

Укажите точку вблизи геометрического объекта, с которого требуется начать обход контура.

На экране появится фантомное изображение первого участка контура (поверх базового элемента) и стрелка, показывающая предложенное системой направление дальнейшего движения.

Для указания нужного направления щелкните мышью на соответствующем объекте.

Направление движения по сегментам контура можно также выбрать с помощью следующих кнопок, расположенных на Панели специального управления:

• Предыдущее направление,

• Следующее направление,

• Шаг вперед,

• Шаг назад.

Кроме того, для выбора направления движения можно использовать клавиатурные комбинации, приведенные в таблице 3.2.6.

Табл. 3.2.6. Клавиатурные комбинации для выбора направления обхода
Клавиша | Описание действия
<Пробел> | Перебор возможных направлений обхода от текущего узла против часовой стрелки.
<Shift>+<Пробел> | Перебор возможных направлений обхода от текущего узла по часовой стрелке.
<Enter> | Подтверждение выбора направления, отмеченного стрелкой.
<Shift>+<Enter> | Возврат на один шаг назад.

Группа переключателей Способ прохода узлов позволяет указать, каким образом следует проходить неветвящиеся узлы контура — узлы, в которых направление дальнейшего движения всего одно (то есть в узле нет разветвлений). По умолчанию используется автоматическая обработка таких узлов (без запроса на выбор дальнейшего направления).

Чтобы отказаться от продолжения обхода и начать формирование контура заново, нажмите кнопку Повторный выбор объекта, а затем укажите нужный объект, с которого требуется начать обход.

При указании участка, замыкающего контур (т.е. участка, конечная точка которого совпадает с начальной точкой первого участка), происходит автоматическая фиксация объекта.

Чтобы зафиксировать разомкнутый контур, нажмите кнопку Создать объект.

Существующий в графическом документе разомкнутый контур может быть выбран в качестве границы штриховки только способом обхода по стрелке.


3.2.13.2. Штриховка

В этом разделе:

3.2.13.2.1. Построение штриховки

3.2.13.2.2. Параметры штриховки


3.2.13.2.1. Построение штриховки

Чтобы заштриховать одну или несколько областей, вызовите команду Штриховка.

Укажите границы и параметры штриховки.

На экране появляется фантом штриховки, что позволяет контролировать правильность задания областей и параметров штриховки.

Когда все нужные области будут заштрихованы, нажмите кнопку Создать объект. Штриховка будет зафиксирована в документе, и система будет ожидать указания границ для следующей штриховки.


3.2.13.2.2. Параметры штриховки

Для настройки параметров штриховки служат элементы управления, расположенные на вкладке Штриховка Панели свойств. Они представлены в таблице 3.2.7.

Табл. 3.2.7. Элементы управления штриховкой
Элемент | Описание
Стиль | Список стилей штриховки. Чтобы изменить текущий стиль штриховки, разверните список и укажите нужный вариант.
Цвет | Список, позволяющий выбрать цвет линий штриховки (или заливки). Щелчок на строке Другие цвета выводит на экран расширенный диалог выбора цвета.
Базовая точка | Условная точка, от которой «начинается» штриховка. При изменении ее координат линии штриховки смещаются по вертикали и/или по горизонтали.
Шаг | Шаг линий штриховки.
Угол | Угол поворота штриховки вокруг ее базовой точки.
Тип |
 | Заполнение штриховкой всей области внутри границ.
 | Построение штриховки полосой вдоль границы.
Ширина1 | Значение ширины полосы штриховки.
Расположение1 |
 | Расположение полосы штриховки слева от границы.
 | Расположение полосы штриховки справа от границы.
  1. Элемент управления доступен, если активен переключатель Полоса в группе Тип.


3.2.13.3. Заливка

В этом разделе:

3.2.13.3.1. Типы заливки

3.2.13.3.2. Построение заливки

3.2.13.3.3. Параметры заливки

3.2.13.3.4. Дополнительные переходы цвета и уровни прозрачности заливки

3.2.13.3.5. Редактирование заливки


3.2.13.3.1. Типы заливки

В системе КОМПАС-3D могут быть построены заливки следующих видов.

– Одноцветная заливка, представляющая собой однородное окрашивание выбранной области.

– Градиентная заливка с плавным или пошаговым изменением цвета, представленная несколькими типами (линейной, цилиндрической, угловой, конической, радиальной и квадратной) и придающая эффект объема изображениям графического документа (см. рис. 3.2.88).

– Область заливки может состоять из одного или нескольких замкнутых контуров, в том числе и несвязанных друг с другом.

Рис. 3.2.88. Примеры использования заливок

При построении градиентных заливок необходимо учитывать следующие особенности.

После указания одной или нескольких заливаемых областей вокруг контуров автоматически строится габаритный прямоугольник, внутри которого будет происходить распределение цвета. При изменении параметров заливки, например, угла наклона заливки, габаритный прямоугольник изменяется (см. рис. 3.2.89). Габаритный прямоугольник является условным и на экране не отображается.

Рис. 3.2.89. Параметры заливки при построении: а) при отсутствии сдвига и угла наклона, б) после задания сдвига и угла наклона
а) | б)

Начальной точкой заливки является точка, в которой устанавливается начальный цвет. По умолчанию начальная точка находится в центре габаритного прямоугольника.

Начальная линия заливки — линия, проходящая через начальную точку. От начальной линии или начального луча начинается переход цвета для некоторых типов заливок.

Конечной линией заливки является линия или конечный луч, в которых устанавливается конечный цвет.

В таблице 3.2.8 представлено описание типов градиентных заливок. Для наглядности представлены примеры с пошаговым изменением цвета, нулевыми сдвигом начальной точки и углом заливки.

Табл. 3.2.8. Описание типов градиентных заливок
Пример заливки (с пошаговым изменением цвета) | Описание типа заливки
 | Линейная — переход цвета от начальной линии до конечной. Начальная и конечная линии находятся на параллельных сторонах габаритного прямоугольника. Для линейной заливки начальная точка отсутствует.
 | Цилиндрическая — переход цвета от начальной линии до конечных. Конечные линии они являются сторонами габаритного прямоугольника, параллельными начальной линии.
 | Для угловой и конической заливок начальной и конечной линиями служат лучи, проведенные из начальной точки. Угловая — переход цвета от начального луча до конечного в круговом направлении. Начальный луч отстоит от конечного на угол в 360 градусов.
 | Коническая — переход цвета от начального луча до конечного в круговом направлении. Начальный луч отстоит от конечного на угол в 180 градусов.
 | Радиальная — переход цвета в радиальном направлении от начальной точки до точки, наиболее от нее удаленной на стороне габаритного прямоугольнике.
 | Квадратная — переход цвета в направлениях, перпендикулярных сторонам габаритного прямоугольника. Начальный цвет — в начальной точке, конечный — на наиболее удаленной стороне габаритного прямоугольника.

Угол заливки определяет поворот заливки относительно начальной точки внутри области. При изменении угла заливки габаритный прямоугольник также повернется на заданный угол. Для линейной заливки угол определяет изменение направления перехода цвета.

Положение начальной точки заливки можно изменять на величину сдвига относительно центра габаритного прямоугольника. Если сдвига нет, то начальная точка лежит в центре габаритного прямоугольника.

При необходимости можно увеличить прозрачность каждого цвета заливки. 100%-ная прозрачность означает, что цвет заливки будет невидим. По умолчанию значения параметров «Прозрачность» («Начальная прозрачность», «Конечная прозрачность») равны 0%, то есть заливки создаются непрозрачными.

Дополнительно в заливке можно задать несколько промежуточных цветов и уровней прозрачности.


3.2.13.3.2. Построение заливки

Чтобы залить цветом одну или несколько областей, вызовите команду Заливка.

Укажите границы и параметры заливки.

Чтобы скопировать параметры заливки, ранее созданной в документе, нажмите кнопку Копировать свойства на Панели специального управления.

Курсор изменит вид.

Подведите курсор к контуру, ограничивающему заливку, параметры которой необходимо скопировать. После того как контур подсветится, нажмите левую кнопку мыши. Для переноса параметров укажите область заливки. Заливка со скопированными параметрами отобразится в указанной области. При необходимости параметры можно отредактировать.

На экране появляется заполненные цветом одна или несколько областей, что позволяет контролировать правильность задания областей и параметров заливки.

Когда все нужные области будут залиты, нажмите кнопку Создать объект. Заливка будет зафиксирована в документе, и система будет ожидать указания границ для следующей заливки.


3.2.13.3.3. Параметры заливки

Для настройки параметров заливки служат элементы управления, расположенные на вкладке Заливка Панели свойств.

Набор элементов управления зависит от типа заливки, выбранного в группе Тип.

Они представлены в таблице 3.2.9.

Табл. 3.2.9. Элементы управления заливкой

Элемент

Описание

Тип

Список типов заливки. Чтобы изменить текущий тип заливки, разверните список и укажите нужный вариант.

Если выбран тип заливки — одноцветная, то доступны следующие элементы управления.

Цвет

Список, позволяющий выбрать цвет заливки. Щелчок на строке Другие цвета выводит на экран расширенный диалог выбора цвета.

Прозрачность

Элемент управления, позволяющий задавать прозрачность1 выбранному цвету.

– Если установлена Прозрачность — 0%, то заливка полностью непрозрачна. Чтобы увеличить прозрачность, следует передвинуть мышью «ползунок» вправо.

– «Ползунок» в правом крайнем положении задает Прозрачность — 100%. Заливка является полностью прозрачной.

Если выбраны другие типы заливки в списке Тип (градиентные — линейная, цилиндрическая и т.д.), то доступны следующие элементы управления.

Цвет 1

Цвет 2

Списки, позволяющие выбрать начальный и конечный цвета заливки. Щелчок на строке Другие цвета выводит на экран расширенный диалог выбора цвета.

Угол

Элемент управления для задания угла поворота заливки относительно начальной точки внутри области.

Введите или выберите значение из списка ранее введенных, а также часто используемых углов.

Поле недоступно для радиальной заливки.

Сдвиг X

Сдвиг Y

Поля для ввода или задания счетчиком относительного смещения начальной точки заливки от центра до сторон габаритного прямоугольника. Значения могут изменяться от –100 до 100 %.

– Если установлены значения 0 %, то смещения нет — начальная точка заливки совпадает с центром габаритного прямоугольника.

– Значение 100% Сдвига X или Сдвига Y означает, что начальная точка заливки лежит на стороне (контуре) габаритного прямоугольника.

При перемещении точки мышью, а также при повороте заливки величина сдвига вычисляется и заносится в эти поля.

Для цилиндрической заливки доступно поле Сдвиг для ввода смещения начальной точки в направлении к начальной или конечной линии заливки.

Поля недоступны для линейной заливки.

Прозрачность

Элементы управления, позволяющие задавать прозрачность1 выбранному Цвету 1 и Цвету 2.

– Если установлена Начальная прозрачность (Конечная прозрачность) — 0%, то заливка, установленная в полях Цвет 1 (Цвет 2), полностью непрозрачна. Чтобы увеличить прозрачность того или иного цвета заливки, следует передвинуть мышью соответствующий «ползунок» вправо.

– «Ползунок» в правом крайнем положении задает Начальную прозрачность (Конечную прозрачность) — 100%. Заливка считается полностью прозрачной.

Дополнительно

При нажатии кнопки на экране появляется диалог расширенного управления заливкой. В диалоге задаются промежуточные цвета и уровни прозрачности, а также их расположение в заливке (см. раздел 3.2.13.3.4).

Переходы цвета

Группа переключателей, позволяющая выбрать способ изменения цвета заливки от Цвета 1 до Цвета 2.

– Если активен переключатель Плавное изменение цвета, то переход цвета выполняется плавно.

– Если активен переключатель Заданное количество шагов, то переходы цвета выполняются в заданное количество шагов. Становится доступно поле для ввода или задания счетчиком количества шагов — от 1 до 255.
  1. Некоторые устройства вывода не поддерживают печать прозрачной заливки. В этих случаях при настройке печати рекомендуется включать альтернативный способ вывода (см. разделы 8.2.2 и 8.3.5.2).


3.2.13.3.4. Дополнительные переходы цвета и уровни прозрачности заливки

При построении или редактировании градиентной заливки можно создать дополнительные промежуточные цвета и/или изменить уровень прозрачности некоторой ее области (см. рис. 3.2.90).

Для этого нажмите кнопку Дополнительно на Панели свойств или вызовите одноименную команду контекстного меню.

Рис. 3.2.90. Радиальная заливка до и после добавления нескольких цветов и уровней прозрачности
а) | б)

На экране появится диалог расширенного управления заливкой (см. рис. 3.2.91).

В окне диалога находится прямоугольник-образец с установленными на Панели свойств переходом цвета от Цвета 1 до Цвета 2 и уровнями прозрачности — Начальной и Конечной. Если на Панели свойств была установлена ненулевая прозрачность, то в верхней половине прямоугольника отображаются черно-белые клетки, по яркости которых можно визуально оценить уровень прозрачности.

Рис. 3.2.91. Диалог расширенного управления заливкой

Чтобы задать дополнительные цвета и/или уровни прозрачности, выполните следующие действия.

1. Создайте новую позицию. Для этого в окне диалога дважды щелкните мышью в месте расположения нового цвета или уровня прозрачности между Цветом 1 и Цветом 2. Внизу окна появится указатель позиции в виде треугольника.

Вы можете создать несколько позиций.

Указатель текущей позиции отображается в рамке (см. рис. 3.2.91). Текущую позицию можно менять щелчком мыши по нужному указателю или с помощью комбинации клавиш <Ctrl> + <→>, <Ctrl> + <←>.

2. Передвиньте указатель позиции в нужное положение мышью или клавишами <→>, <←>, или посредством ввода или задания счетчиком целого числа от 1 до 99 в поле Позиция. При перемещении мышью курсор принимает вид двухсторонней стрелки.

В поле Позиция отображается значение в процентах, характеризующее положение текущей позиции относительно начальной точки заливки. Позиции 0 соответствует начальный цвет, позиции 100% — конечный цвет заливки.

Поле Позиция доступно, если текущим является указатель дополнительной позиции.

3. Задайте цвет в текущей позиции в диалоге выбора цвета, дважды щелкнув по указателю позиции или используя элемент управления Цвет. По умолчанию в созданной позиции цвет является промежуточным между цветами в ближайших позициях.

– Чтобы создать в заливке участок с постоянным цветом, переместите мышью указатель позиции при нажатой клавише <Ctrl> на нужное расстояние.

– Чтобы удалить промежуточный цвет, «перетащите» мышью данный указатель за пределы окна. После того как курсор изменит свою форму, отпустите указатель. Удалить промежуточный цвет также можно нажатием клавиши <Delete>, предварительно сделав соответствующую позицию текущей.

Если необходимо ввести дополнительные цвета без изменения прозрачности, опция Интерполирование группы Прозрачность должна находиться во включенном состоянии.

4. Задайте дополнительные уровни прозрачности в заливке. Для этого сделайте текущим указатель на границе области, где будет изменена прозрачность.

Опция Интерполирование в группе элементов Прозрачность служит для управления заданием прозрачности, а шкала изменения с «ползунком» — для задания и отображения уровня прозрачности в текущей позиции. Значение прозрачности в процентах отображается справа от шкалы.

– По умолчанию опция Интерполирование включена. Это означает, что прозрачность в созданной позиции является величиной, интерполированной между значениями прозрачности в ближайших позициях, например, начальной и конечной.

При включенной опции произвольное изменение прозрачности в текущей позиции невозможно — шкала изменения недоступна.

– Если опция Интерполирование выключена, то становится доступной шкала изменения прозрачности. Чтобы задать новую величину, следует передвинуть «ползунок» в нужное положение мышью или клавишами <→> и <←>.

Если значение прозрачности равно 0%, то в этой позиции заливка считается полностью непрозрачной, а если 100% — то полностью прозрачной. Цвет при этом соответствует отображенному в поле элемента управления Цвет,

Чтобы отменить дополнительный уровень прозрачности без удаления позиции, сделайте позицию текущей и включите опцию Интерполирование.

После задания промежуточных цветов и уровней прозрачности нажмите кнопку ОК.

Начальный и конечный цвет, а также начальную и конечную прозрачность заливки можно изменить, сделав позиции 0% и 100% текущими. После внесения изменений значения автоматически отображаются на Панели свойств.


3.2.13.3.5. Редактирование заливки

Характерными точками заливки являются начальная точка и характерные точки контуров заливки.

При редактировании заливки необходимо учитывать следующее.

– В режиме редактирования характерных точек для всех типов заливки, кроме одноцветной и линейной, можно изменять положение начальной точки.

– Чтобы цвет заливки не изменялся при выделении, следует включить опцию Всегда показывать заливку установленным цветом в диалоге, появляющемся на экране после вызова команды Сервис — Параметры — Система — Графический редактор — Редактирование. Тогда при выделении заливки будет подсвечиваться только ее контур.


3.2.14. Составные объекты

3.2. Геометрические объекты

3.2.14. Составные объекты

К составным геометрическим объектам в системе КОМПАС-3D относятся:

– эквидистанты,

– контуры.

Общим свойством этих объектов является то, что они выделяются и редактируются целиком. Работа с отдельными объектами, входящими в состав такого объекта, возможна только после его разрушения. Для разрушения объектов служит команда Редактор — Разрушить.

В этом разделе:

3.2.14.1. Контур

3.2.14.2. Эквидистанта кривой

3.2.14.2.1. Параметры эквидистанты

3.2.14.3. Эквидистанта по стрелке


3.2.14.1. Контур

Чтобы создать контур, состоящий из частей пересекающихся геометрических объектов, вызовите команду Собрать контур.

Дальнейший порядок действий аналогичен описанному в разделе 3.2.13.1.2.

Управление исходными объектами описано в разделе 3.5.2.1.1.

Рис. 3.2.92. Пример контура, построенного обходом по стрелке


3.2.14.2. Эквидистанта кривой

Чтобы построить эквидистанту какого-либо геометрического объекта, вызовите команду Эквидистанта кривой.

Укажите объект, эквидистанту которого требуется построить. На экране появится фантом эквидистанты.

Настройте параметры эквидистанты (см. раздел 3.2.14.2.1). Все вносимые изменения отображаются на фантоме.

Закончив настройку, нажмите кнопку Создать объект. Эквидистанта будет зафиксирована в документе, и система будет ожидать указания объекта для следующей эквидистанты.

В этом разделе:

3.2.14.2.1. Параметры эквидистанты


3.2.14.2.1. Параметры эквидистанты

Настройка параметров эквидистанты производится с помощью элементов, расположенных на вкладке Эквидистанта Панели свойств. Они представлены в таблице 3.2.10.

Табл. 3.2.10. Элементы управления эквидистантой
Элемент | Описание
Радиус 1 | Расстояние от объекта до эквидистанты слева.
Радиус 2 | Расстояние от объекта до эквидистанты справа.
Обход углов |
 | Способ обхода углов срезом (рис. 3.2.93, а).
 | Способ обхода углов скруглением (рис. 3.2.93, б).
Тип |
 | Построение эквидистанты с левой стороны от объекта.
 | Построение эквидистанты с правой стороны от объекта.
 | Построение эквидистанты с двух сторон от объекта (рис. 3.2.94, б).
Режим |
 | Удалять вырожденные участки эквидистанты (рис. 3.2.95, а).
 | Оставлять вырожденные участки эквидистанты (рис. 3.2.95, б).

Если активен переключатель Оставлять вырожденные участки, то углы обходятся только срезом. Группа переключателей Обход углов недоступна.

Рис. 3.2.93. Обход углов: а) срезом, б) скруглением
а) | б)

Рис. 3.2.94. Эквидистанта: а) с одной стороны от объекта, б) с двух сторон
а) | б)

Рис. 3.2.95. Эквидистанта: а) без вырожденных участков, б) с вырожденными участками
а) | б)


3.2.14.3. Эквидистанта по стрелке

Чтобы построить эквидистанту контура, образованного обходом по стрелке, вызовите команду Эквидистанта по стрелке.

Порядок действий при формировании контура обходом по стрелке описан в разделе 3.2.13.1.2.

Параметры эквидистанты по стрелке такие же, как в случае эквидистанты объекта (см. раздел 3.2.14.2.1).


3.2.15. Фаски и скругления

3.2. Геометрические объекты

3.2.15. Фаски и скругления

По умолчанию для произвольной фаски и скругления используется тот стиль линии, который имеет первый из указанных объектов. Фаска или скругление на углах объекта имеют тот же стиль, что и объект.

В этом разделе:

3.2.15.1. Фаска

3.2.15.1.1. Управление усечением объектов

3.2.15.1.2. Создание условного пересечения усекаемых объектов

3.2.15.2. Фаска на углах объекта

3.2.15.3. Скругление

3.2.15.4. Скругление на углах объекта


3.2.15.1. Фаска

Чтобы построить отрезок, соединяющий две пересекающиеся кривые, вызовите команду Фаска.

С помощью группы переключателей Тип на Панели свойств укажите способ построения фаски: по двум длинам или по длине и углу.

Введите параметры фаски в соответствующие поля на Панели свойств.

Укажите первый и второй объекты, между которыми нужно построить фаску.

Рис. 3.2.96. Построение фаски: а) исходное изображение, б) результат выполнения команды
а) | б)

В этом разделе:

3.2.15.1.1. Управление усечением объектов

3.2.15.1.2. Создание условного пересечения усекаемых объектов


3.2.15.1.1. Управление усечением объектов

Возможно два способа построения фаски /скругления:

– с усечением объектов,

– без усечения объектов.

При использовании первого способа части первого/второго объектов, оставшиеся после создания фаски/скругления, автоматически удаляются, при использовании второго — нет.

Вы можете выбрать способ построения фаски для обоих ее элементов индивидуально. Для этого в группах Элемент 1 и Элемент 2 на Панели свойств активизируйте переключатель Усекать элемент или Не усекать элемент. По умолчанию в каждой из этих групп активен переключатель Усекать элемент.

Рис. 3.2.97. Построение фаски/скругления: а) с усечением элементов, б) без усечения элементов
а) | б)


3.2.15.1.2. Создание условного пересечения усекаемых объектов

На усекаемых объектах может быть построено условное пересечение. Это означает, что при построении фаски/скругления объекты будут продолжены тонкими линиями до точки их пересечения. Условное пересечение также может быть построено отдельно, при помощи команды Условное пересечение, см. раздел 3.3.7.19.

Чтобы включить или выключить создание пересечения при построении фаски/скругления, активизируйте нужный переключатель в группе Условное пересечение на Панели свойств.

Рис. 3.2.98. Построение фаски/скругления: а) при включенном построении условного пересечения, б) при выключенном
а) | б)

Условное пересечение создается, если построение фаски/скругления происходит с усечением хотя бы одного из указанных объектов (см. раздел 3.2.15.1.1).

Для построения используются умолчательные значения параметров, задаваемые в разделе Условное пересечение диалога настройки документа (см. раздел 9.2.6.12).

По умолчанию созданное условное пересечение никак не связано с объектами, указанными в ходе выполнения команды, и может редактироваться отдельно.


3.2.15.2. Фаска на углах объекта

Чтобы построить фаски на углах объектов следующих типов: контур, ломаная или многоугольник, вызовите команду Фаска на углах объекта.

С помощью группы переключателей Тип на Панели свойств укажите способ построения фаски: по двум длинам или по длине и углу.

Введите параметры фаски в соответствующие поля на Панели свойств.

Укажите курсором угол контура, многоугольника или ломаной, на котором необходимо построить фаску. Первым объектом для построения фаски будет считаться ближайшее к указанной точке звено.

По умолчанию фаска строится только на указанном угле контура. При этом в группе Режим на Панели свойств активен переключатель На указанном угле. Чтобы фаски с заданными параметрами одновременно создавались на всех углах выбранного контура, активизируйте переключатель На всех углах контура.

Рис. 3.2.99. Построение фасок на всех углах прямоугольника


3.2.15.3. Скругление

Чтобы построить скругление дугой окружности между двумя пересекающимися объектами, вызовите команду Скругление.

Введите радиус скругления в соответствующее поле на Панели свойств.

Укажите два объекта, между которыми нужно построить скругление.

Рис. 3.2.100. Построение скругления: а) исходное изображение, б) результат построения
а) | б)


3.2.15.4. Скругление на углах объекта

Чтобы построить скругления дугами окружности на углах объектов следующих типов: контур, ломаная или многоугольник, вызовите команду Скругление на углах объекта.

Введите радиус скругления в соответствующее поле на Панели свойств.

Укажите угол контура, многоугольника или ломаной, на котором необходимо построить скругление.

По умолчанию скругляется только указанный угол контура. При этом в группе Режим на Панели свойств активен переключатель На указанном угле. Чтобы скругления с заданными параметрами одновременно создавались на всех углах выбранного контура, активизируйте переключатель На всех углах контура.

Рис. 3.2.101. Построение скруглений на всех углах многоугольника


3.3. Размеры и обозначения

В этом разделе:

3.3.1. Общие приемы работы с размерами

3.3.1.1. Настройка свойств

3.3.1.2. Настройка параметров

3.3.1.3. Ввод размерной надписи

3.3.1.4. Выбор квалитета

3.3.1.5. Управление размерной линией и надписью

3.3.1.5.1. Особенности автоматического размещения текста

3.3.1.6. Настройка размеров в текущем и новых документах

3.3.1.7. Выравнивание размерных линий

3.3.1.8. Формирование зазора между выносной линией и точкой привязки

3.3.2. Линейные размеры

3.3.2.1. Простой линейный размер

3.3.2.1.1. Указание объектов для простановки размера

3.3.2.1.2. Управление ориентацией размера

3.3.2.1.3. Размер с наклонными выносными линиями

3.3.2.2. Линейный размер с обрывом

3.3.2.3. Линейный размер от отрезка до точки

3.3.2.4. Линейный размер от общей базы

3.3.2.5. Цепной линейный размер

3.3.2.6. Линейный размер с общей размерной линией

3.3.2.7. Размер дуги

3.3.3. Диаметральные и радиальные размеры

3.3.3.1. Диаметральный размер

3.3.3.2. Простой радиальный размер

3.3.3.2.1. Радиальный размер на полке с несколькими ответвлениями

3.3.3.2.2. Редактирование радиального размера

3.3.3.3. Радиальный размер с изломом

3.3.3.3.1. Редактирование размерной линии с изломом при помощи мыши

3.3.4. Угловые размеры

3.3.4.1. Общие приемы работы с угловыми размерами

3.3.4.1.1. Указание сторон углов

3.3.4.1.2. Управление ориентацией размера

3.3.4.1.3. Вид выносных линий

3.3.4.2. Простой угловой размер

3.3.4.3. Угловой размер от общей базы

3.3.4.4. Угловой цепной размер

3.3.4.5. Угловой размер с общей размерной линией

3.3.4.6. Угловой размер с обрывом

3.3.4.7. Особенности редактирования углового размера с помощью мыши

3.3.5. Авторазмеры

3.3.5.1. Линейный авторазмер

3.3.5.2. Линейный авторазмер от отрезка до точки

3.3.5.3. Линейный авторазмер с обрывом

3.3.5.4. Угловой авторазмер

3.3.5.5. Угловой авторазмер с обрывом

3.3.5.6. Радиальный авторазмер

3.3.5.7. Диаметральный авторазмер

3.3.6. Размер высоты

3.3.6.1. Для вида спереди или разреза

3.3.6.2. Для вида сверху с линией-выноской и для вида сверху непосредственно на изображении

3.3.7. Обозначения для машиностроения

3.3.7.1. Общие сведения

3.3.7.2. Настройка обозначений для машиностроения в текущем и новых документах

3.3.7.3. Шероховатость

3.3.7.3.1. Ввод надписи обозначения шероховатости

3.3.7.3.2. Настройка отрисовки знака шероховатости

3.3.7.3.3. Управление расположением знака шероховатости

3.3.7.4. Линия-выноска

3.3.7.4.1. Ввод надписи на линии-выноске

3.3.7.4.2. Настройка отрисовки линии-выноски

3.3.7.4.3. Изменение конфигурации линии-выноски

3.3.7.4.4. Изменение положения значка

3.3.7.5. Обозначение клеймения

3.3.7.5.1. Ввод надписи обозначения клеймения

3.3.7.5.2. Настройка отрисовки обозначения клеймения

3.3.7.6. Обозначение маркировки

3.3.7.7. Обозначение позиции

3.3.7.7.1. Ввод надписи обозначения позиции

3.3.7.7.2. Настройка отрисовки обозначения позиции

3.3.7.7.3. Выравнивание позиций

3.3.7.8. Обозначение изменения

3.3.7.8.1. Ввод надписи обозначения изменения

3.3.7.8.2. Настройка отрисовки обозначения изменения

3.3.7.9. Стрелка направления взгляда

3.3.7.9.1. Формирование текста обозначения

3.3.7.10. Линия разреза/сечения

3.3.7.10.1. Построение линии сложного разреза

3.3.7.11. Выносной элемент

3.3.7.11.1. Настройка отрисовки обозначения выносного элемента

3.3.7.12. База

3.3.7.12.1. Ввод надписи обозначения базы

3.3.7.13. Допуск формы

3.3.7.13.1. Формирование таблицы допуска

3.3.7.13.2. Создание ответвлений

3.3.7.14. Обозначение центра

3.3.7.14.1. Настройка отрисовки обозначения центра

3.3.7.15. Осевая линия

3.3.7.16. Автоосевая

3.3.7.16.1. Автоосевая по двум точкам

3.3.7.16.2. Построение автоосевой способом По объектам

3.3.7.16.3. Построение автоосевой способом C указанием границы

3.3.7.16.4. Автоосевая-обозначение центра

3.3.7.16.5. Пример использования автоосевой

3.3.7.17. Волнистая линия

3.3.7.17.1. Настройка параметров волнистой линии

3.3.7.17.2. Способы построения волнистой линии

3.3.7.17.3. Особенности редактирования волнистой линии

3.3.7.18. Линия с изломами

3.3.7.18.1. Настройка параметров линии с изломами

3.3.7.18.2. Смещение изломов

3.3.7.19. Условное пересечение

3.3.7.19.1. Настройка параметров условного пересечения

3.3.8. Обозначения для строительства

3.3.8.1. Общие сведения

3.3.8.2. Настройка обозначений для строительства в текущем и новых документах

3.3.8.3. Марка/позиционное обозначение без линии-выноски

3.3.8.3.1. Ввод текста марки/позиционного обозначения

3.3.8.3.2. Автонумерация марки/позиционного обозначения

3.3.8.3.3. Параметры марки/позиционного обозначения без линии-выноски

3.3.8.4. Марка/позиционное обозначение с линией-выноской

3.3.8.4.1. Параметры марок/позиционных обозначений с линией-выноской

3.3.8.5. Марка/позиционное обозначение на линии

3.3.8.6. Линия разреза

3.3.8.6.1. Формирование текста обозначения линии разреза

3.3.8.7. Обозначение узла

3.3.8.7.1. Ввод текста обозначения узла и узла в сечении

3.3.8.7.2. Параметры обозначения узла

3.3.8.8. Обозначение узла в сечении

3.3.8.8.1. Параметры обозначения узла в сечении

3.3.8.9. Номер узла

3.3.8.9.1. Ввод текста обозначения номера узла

3.3.8.10. Фигурная скобка

3.3.8.10.1. Ввод текста обозначения фигурной скобки

3.3.8.10.2. Параметры фигурной скобки

3.3.8.10.3. Особенности редактирования фигурной скобки с помощью мыши

3.3.8.11. Выносная надпись

3.3.8.11.1. Ввод текста выносной надписи

3.3.8.11.2. Параметры выносной надписи

3.3.8.12. Прямая координационная ось

3.3.8.12.1. Автопродолжение

3.3.8.12.2. Формирование обозначения

3.3.8.12.3. Параметры отрисовки

3.3.8.12.4. Выступы

3.3.8.12.5. Дополнительные обозначения

3.3.8.12.6. Параметры отрисовки дополнительных обозначений

3.3.8.12.7. Ввод текста дополнительных обозначений

3.3.8.13. Дуговая координационная ось

3.3.8.14. Круговая координационная ось

3.3.8.14.1. Параметры отрисовки

3.3.8.15. Использование команды «Запомнить состояние» для построения осей

3.3.8.15.1. Прямые оси

3.3.8.15.2. Дуговые оси

3.3.8.15.3. Круговые оси

3.3.9. Автоматическое создание видов и гиперссылок

3.3.9.1. Автоматическое создание вида

3.3.9.1.1. Автоматически сформированное изображение выносного элемента и узла

3.3.9.2. Автоматическое создание гиперссылки


3.3.1. Общие приемы работы с размерами

3.3. Размеры и обозначения

3.3.1. Общие приемы работы с размерами

КОМПАС-3D позволяет создать в графическом документе любой из предусмотренных стандартом вариантов размеров. Возможна простановка нескольких типов линейных, угловых, радиальных размеров, диаметрального размера, размеров высоты и дуги. Кроме того, доступен специальный способ простановки размеров, при котором тип размера автоматически определяется системой.

Команды простановки размеров сгруппированы в меню Инструменты — Размеры, а кнопки для вызова команд — на панели Размеры (рис. 3.3.1).

Рис. 3.3.1. Панель Размеры

Общая последовательность действий при простановке большинства размеров следующая:

1. Вызов команды простановки размера нужного типа или команды автоматической простановки размеров.

2. Указание объектов (объекта), к которым требуется проставить размер.

3. Настройка начертания размера с помощью вкладок Панели свойств (см. разделы 3.3.1.1 и 3.3.1.2).

4. Редактирование (при необходимости) размерной надписи (см. раздел 3.3.1.3) и задание ее положения.

В этом разделе:

3.3.1.1. Настройка свойств

3.3.1.2. Настройка параметров

3.3.1.3. Ввод размерной надписи

3.3.1.4. Выбор квалитета

3.3.1.5. Управление размерной линией и надписью

3.3.1.5.1. Особенности автоматического размещения текста

3.3.1.6. Настройка размеров в текущем и новых документах

3.3.1.7. Выравнивание размерных линий

3.3.1.8. Формирование зазора между выносной линией и точкой привязки


3.3.1.1. Настройка свойств

Рис. 3.3.2. Вкладка Размер Панели свойств при простановке линейного размера

Элементы управления создаваемым размером, содержащиеся на вкладке Размер, представлены в таблице 3.3.1.

Табл. 3.3.1. Элементы управления вкладки Размер

Элемент

Описание

т1, т2, т3, т4

Поля координат характерных точек размера. На рис. 3.3.12 показаны четыре точки, определяющее положение линейного размера на полке.

Если выбрано автоматическое, фиксированное или ручное размещение текста (см. табл. 3.3.3), то поле т3 задает также положение надписи, а если выбрано размещение на полке — точку начала линии-выноски.

Поле т4 присутствует в том случае, если выбран один из вариантов размещения размерной надписи на полке (см. там же).

Тип

Элемент, определяющий направление выносных линий размера. В зависимости от типа создаваемого размера этот элемент может иметь различные вид и состав (см. табл. 3.3.2).

Текст

Поле, содержащее текст размерной надписи. Чтобы отредактировать текст, предлагаемый по умолчанию, или ввести новый, щелкните в поле мышью.

Подробно формирование размерной надписи описано в разделе 3.3.1.3.

Ввод символов непосредственно в поле Текст невозможен.

Размещение текста

Список позволяет выбрать способ размещения текста размерной надписи: Автоматическое, Фиксированное, Ручное, На полке, влево, На полке, вправо, На полке, вверх, На полке, вниз. Для всех размеров, кроме линейного размера с общей размерной линией, углового размера с общей размерной линией и размера высоты.

Подробнее об управлении размещением текста размерной надписи см. раздел 3.3.1.5.

Табл. 3.3.2. Элемент Тип
Тип размера | Состав элемента Тип
Линейный размер | Горизонтальный
 | Вертикальный
 | Параллельно объекту1
Размер дуги | Параллельные выносные линии
 | Выносные линии от центра
Размер высоты | Для вида спереди или разреза
 | Для вида сверху с линией-выноской
 | Для вида сверху непосредственно на изображении
Диаметральный размер | Полная выносная линия
 | Выносная линия с обрывом
Радиальный размер | Радиальный размер не от центра окружности
 | Радиальный размер от центра окружности
Угловой размер | На минимальный (острый) угол
 | На максимальный (тупой) угол
 | На угол более 180°
  1. Только для простого линейного размера.


3.3.1.2. Настройка параметров

Рис. 3.3.3. Вкладка Параметры Панели свойств при простановке линейного размера

Элементы управления создаваемым размером, содержащиеся на вкладке Параметры, представлены в таблице 3.3.3.

Табл. 3.3.3. Элементы управления вкладки Параметры

Элемент

Описание

Выносная линия

Переключатель определяет, будет ли отрисована выносная линия размера. Только для размеров, имеющих выносные линии.

Для радиальных размеров и линейного размера с обрывом вкладка Параметры содержит один такой переключатель. Для всех остальных линейных размеров и диаметрального размера таких переключателей два.

Стрелка

Список позволяет выбрать вид стрелки. Перечень стрелок, доступных для выбора, а также порядок следования стрелок в списке определяется настройкой фильтра стрелок для текущего документа (см. раздел 9.2.6.10.5).

Положение надписи

Список позволяет выбрать вариант расположения размерной надписи относительно размерной линии: Параллельно, над линией, Параллельно, в разрыве линии, Горизонтально, в разрыве линии. Для всех размеров, кроме линейного размера с общей размерной линией.

Размещение стрелок

Группа переключателей позволяет выбрать вариант размещения стрелок относительно выносных линий размера.

– Если требуется, чтобы стрелки располагались внутри промежутка между выносными линиями, активизируйте переключатель Внутри.

– Если требуется, чтобы стрелки располагались снаружи промежутка между выносными линиями, активизируйте переключатель Снаружи.

– Если требуется, чтобы вариант размещения стрелок выбирался системой автоматически, активизируйте переключатель Авто.

Ответвления

Группа переключателей позволяет выбрать способ построения ответвлений: От начала полки, От конца полки. Только для простого радиального размера.

Переключатели доступны, если из списка Размещение текста выбран один из вариантов размещения текста размерной надписи на полке.

Зазор/длина

Группа элементов позволяет создавать размерные линии с зазором или фиксированной длины (см. раздел 3.3.1.8). Для линейных размеров (кроме размера с обрывом), диаметрального и радиальных размеров.

Элементы доступны при включенной отрисовке выносных линий.

Параметры выноски

Группа полей позволяет задать параметры линии выноски. Для всех размеров, кроме линейного размера с общей размерной линией.

При создании размера с надписью, расположенной на полке, в поле Длина отображается длина линии-выноски, а в поле Угол — угол ее наклона к оси абсцисс текущей системы координат. Ввод значений с клавиатуры в эти поля возможен при отключенном автосоздании объектов (см. раздел 1.4.2.10) и только после того, как линия-выноска сформирована (указана точка начала полки), т.е. фактически с помощью этих полей производится редактирование созданной линии-выноски.

Угол излома

Поле для ввода угла излома размерной линии. Только для радиального размера с изломом.

Указатель
от текста к дуге

Опция управляет отрисовкой указателя от размерной надписи к образмериваемой дуге. Только для размера дуги.

По умолчанию

Если опция включена, то все текущие настройки вкладки Параметры будут использоваться при создании следующих размеров данного типа до конца сеанса работы.

Если опция отключена, то настройка распространяется только на текущий (создаваемый) размер.


3.3.1.3. Ввод размерной надписи

Ввод (редактирование) текста размерной надписи производится в диалоге (рис. 3.3.4), который вызывается щелчком мыши в поле Текст на вкладке Размер.

Элементы управления этого диалога представлены в таблице 3.3.4.

При вводе и редактировании текста размерной надписи необходимо иметь в виду следующие особенности:

– если пределы включены в размерную надпись, а квалитет — нет, то номинальное значение в размерной надписи не отображается;

– если отображение предельных значений размера включено, а квалитет не задан, то изменение геометрии размера (например, при перестроении ассоциативного размера) не приводит к пересчету предельных значений.

Рис. 3.3.4. Диалог задания размерной надписи линейного размера

Табл. 3.3.4. Диалог задания размерной надписи

Элемент

Описание

Текст до1

Поле для ввода префикса — текста, предшествующего значению размера.

Список символов

Раскрывающийся список позволяет выбрать нужный символ для простановки перед размерным числом. Вы можете выбрать символ диаметра, квадрата, радиуса, обозначения метрической резьбы или вариант Нет символа. Если требуется ввести какой-либо другой символ, вставьте его в поле Текст до с помощью команд меню Вставить.

Значение

Поле для отображения значения размера.

Вы можете ввести значение с клавиатуры.

При простановке всех размеров, кроме угловых, можно также выбрать значение из пользовательского меню. Для этого нажмите кнопку Значение. На экране появится пользовательское меню. По умолчанию оно содержит нормальные линейные размеры по ГОСТ 6636-69.

Авто

Опция управляет способом определения значения размера.

Если опция включена, значение размера определяется автоматически.

После ручного ввода значения (в том числе из пользовательского меню) опция автоматически отключается. Чтобы восстановить автоматически определенное значение, вновь включите опцию Авто.

Точность отображения автоматически вычисленного значения можно задать при настройке текущего документа (см. раздел 9.2.6.10.12). Если значение размера введено вручную, то настройка точности на него не влияет.

Формат отображения

Раскрывающийся список позволяет выбрать формат отображения номинального значения угла в размерной надписи текущего размера. Присутствует в диалоге только при простановке угловых размеров.

Вариант Градусы, минуты, секунды позволяет отобразить значение угла в формате ХХ°ХХ'ХХ", а вариант Десятичная система — в формате ХХ,ХХХ°.

Единица измерения1

Поле для ввода обозначения единиц измерения проставляемого размера.

Заданный текст располагается в размерной надписи сразу после предельных отклонений.

При простановке угловых размеров поле Единица измерения отсутствует.

Текст после1

Поле для ввода суффикса — текста, следующего сразу за значением размера.

х45°

Кнопка позволяет добавить в текст, следующий за значением размера, строку х45°.

Текст под1

Поле для ввода текста, который будет располагаться под размерной надписью.

Поле просмотра

Поле содержит размерную надпись в том виде, в каком она будет отображена в документе (за исключением текста под размерной надписью). Недоступно для ручного ввода.

Использовать по умолчанию

Если опция включена, то текущие настройки сохраняются и используются при создании следующих размеров данного типа до конца сеанса работы. Если опция отключена, то текущие настройки распространяются только на текущий (создаваемый или редактируемый) размер, а новые размеры соответствуют умолчательной настройке (см. разделы 9.2.6.10.10 и 9.2.6.10.11).

Допуск

Группа элементов позволяет назначить допуск на проставляемый размер (см. табл. 3.3.5).

Оформление

Группа элементов позволяет настроить дополнительные параметры оформления размерной надписи (см. табл. 3.3.6).
  1. При заполнении полей Текст до, Единица измерения, Текст после, Текст под текст можно выбирать из пользовательских меню. Вызов пользовательских меню осуществляется двойным щелчком в заполняемом поле. Умолчательный состав пользовательских меню в указанных полях показан на рисунке 3.3.5.

Табл. 3.3.5. Элементы назначения допуска на размер

Элемент

Описание

Допуск

Опция позволяет управлять назначением допуска на размер. Если опция включена, текущий размер может иметь допуск. При этом в диалоге доступны элементы назначения допуска. При отключенной опции эти элементы недоступны.

Обратите внимание на то, что при отключении опции Допуск выбранные для размера квалитет и отклонения (пределы) удаляются. Кроме того, отключаются опции Отобразить и Номинальный (в рамке) (описание опций приведено ниже). Последующее включение опции Допуск не восстанавливает удаленные данные и состояние указанных опций.

Квалитет

Поле для отображения квалитета, назначенного проставляемому размеру. Для выбора нужного квалитета нажмите кнопку Квалитет. О подборе квалитета рассказано в разделе 3.3.1.4.

Опция Отобразить 1 справа от поля Квалитет управляет отображением квалитета в размерной надписи. При включенной опции квалитет отображается в размерной надписи, при отключенной — нет.

При простановке угловых размеров элементы выбора квалитета отсутствуют.

Отклонения,
Пределы

Группа элементов позволяет добавить в размерную надпись предельные отклонения размера или его предельные значения.

Предельные отклонения добавляются, если выбран вариант Отклонения, а предельные значения размера, — если выбран вариант Пределы.

Для углового размера возможен только ручной ввод отклонений и предельных значений.

Для линейного, радиального и диаметрального размеров отклонения и предельные значения могут быть заданы вручную или получены автоматически, если для размера выбран квалитет. Обратите внимание на то, что после ручного ввода отклонений или предельных значений выбор квалитета для размера отменяется (поле Квалитет становится пустым).

При вводе отклонений доступна кнопка ±. Она позволяет сделать отклонения равными. После ее нажатия значение из текущего поля ввода отклонения (текущим считается то поле, в котором находится курсор) передается в поле второго отклонения. В верхнем поле перед значением ставится знак «+», а в нижнем поле — знак «-».

Опция Отобразить справа от кнопки ± управляет отображением отклонений или предельных значений в размерной надписи. Опция присутствует в диалоге для всех размеров, кроме угловых. При включенной опции отклонения (предельные значения) отображаются в размерной надписи, при отключенной — нет.

Номинальный (в рамке)

Опция позволяет отрисовать рамку вокруг той части размерной надписи, которая включает символ, значение размера, квалитет и отклонения (пределы). При включении этой опции автоматически отключается отображение квалитета и отклонений (пределов). При необходимости их можно тут же включить вновь.
  1. Если данная опция недоступна, это означает, что выбран такой номер квалитета, для которого отключена вставка в размерную надпись. Номер, начиная с которого квалитет не вносится в надпись, задается при настройке текущего документа (см. раздел 9.2.6.10.12).

Если для размера созданы переменные предельных отклонений (см. раздел 7.1.5.2) и ячейка Выражение Окна переменных (см. раздел 7.1.1.3) заполнена хотя бы для одной из них, то в диалоге ввода размерной надписи недоступны следующие элементы назначения допуска: кнопка Квалитет, поле значения квалитета, опция, управляющая отображением квалитета, а также поля предельных отклонений/предельных значений размера.

Табл. 3.3.6. Элементы настройки оформления
Элемент | Описание
Подчеркнуть | Опция позволяет включить подчеркнутое отображение той части размерной надписи, которая содержит символ, значение размера, квалитет и отклонения (пределы).
Пределы в одну строку | Опция позволяет отобразить предельные значения размера не одно под другим, а друг за другом через дефис. Опция доступна при включенной опции Пределы.
Размер в скобках | Группа опций позволяет отобразить в скобках ту часть размерной надписи, которая содержит символ, значение размера, квалитет и отклонение. Включите опцию, соответствующую нужной форме скобок (круглые или квадратные). Указанные элементы заключаются в скобки вместе с рамкой и подчеркиванием, если они есть.
Выравнивание текста | Раскрывающийся список позволяет выбрать способ расположения отклонений или предельных значений размера относительно его номинального значения. Выберите нужный вариант расположения из списка.

Рис. 3.3.5. Пользовательское меню в полях: а) Текст до, б) Единица измерения, в) Текст после, г) Текст под
а) | б) | в) | г)

При заполнении полей Текст до, Единица измерения, Текст после, Текст под доступно главное меню диалога. Оно содержит команды редактирования и форматирования текста. Эти команды используются так же, как и при работе в текстовом редакторе (см. раздел 4.1.2).

После выполнения всех необходимых действий в диалоге закройте его, нажав кнопку ОК. Внешний вид размерной надписи в поле Текст на вкладке Размер Панели свойств изменится в соответствии с произведенными настройками.

Вы можете вводить компоненты размерной надписи, используя поле Текст. Для этого вызовите контекстное меню в этом поле (см. рис. 3.3.6) и выберите нужную команду.

Рис. 3.3.6. Выбор команды из контекстного меню в поле Текст

На экране появится диалог ввода указанной части размерной надписи.

На рис. 3.3.7 показан пример такого диалога. В нем также можно вызвать пользовательское меню.

Рис. 3.3.7. Диалог ввода текста после размерной надписи


3.3.1.4. Выбор квалитета

После нажатия кнопки Квалитет в диалоге задания размерной надписи на экране появляется диалог выбора квалитета (рис. 3.3.8).

В нем можно назначить нужный квалитет или подобрать его по предельным отклонениям. Элементы управления этого диалога рассмотрены в таблице 3.3.7.

Рис. 3.3.8. Диалог выбора квалитета

Табл. 3.3.7. Элементы управления диалога выбора квалитета
Элемент | Описание
Предпочтительные Основные1 Дополнительные1 | Поля, содержащие списки предпочтительных, основных и дополнительных квалитетов, соответствующих выбранной системе (вала или отверстия). Чтобы выбрать квалитет, щелкните на нем мышью.
Значение | Справочное поле, содержащее номинальное значение размера.
Отклонения | Группа справочных полей, содержащих значения текущих отклонений размера. Эти отклонения автоматически вычисляются по квалитету или задаются пользователем вручную.
Показать квалитеты для | Группа опций, позволяющая указать, в какой системе будет выполняться назначение допуска (в системе отверстия или в системе вала).
Подбор квалитета | Группа элементов, позволяющая подобрать квалитет по заданным предельным отклонениям размера. Введите нужные значения предельных отклонений размера в поля Верхнее и Нижнее и нажмите кнопку Подобрать. В списках для выбора останутся наименования только тех квалитетов, которым соответствует указанный диапазон отклонений.
  1. Присутствие в данном диалоге основных и дополнительных квалитетов зависит от настройки параметров новых размеров. Чтобы отключить отображение одного или обоих списков, вызовите команду Сервис — Параметры... — Текущий чертеж/фрагмент — Размеры — Допуски и предельные значения — Параметры. В правой части появившегося диалога отключите требуемые опции группы Квалитеты.


3.3.1.5. Управление размерной линией и надписью

В этом разделе описываются способы, доступные при управлении размерной линией и надписью всех размеров, кроме линейного размера с общей размерной линией, углового размера с общей размерной линией и размера высоты.

Способы размещения размерной надписи содержатся в списке Размещение текста на вкладке Размер Панели свойств (см. рис. 3.3.2). Описание способов представлено в таблице 3.3.8.

Табл. 3.3.8. Способы размещения текста

Наименование

Описание

Автоматическое

Способ размещения текста определяется автоматически по указанному пользователем положению размерной надписи (см. раздел 3.3.1.5.1).

Автоматическое размещение присутствует в списке Размещение текста всех размеров, кроме линейного цепного, линейного с обрывом, радиального с изломом и углового с обрывом.

Фиксированное

Размерная надпись имеет три предопределенных положения: посередине между выносными линиями или снаружи от них.

Перемещая курсор, выберите положение размерной надписи и зафиксируйте его нажатием левой кнопки мыши или клавиши <Enter>.

Ручное

Положение размерной надписи определяется пользователем.

Перемещая курсор, задайте нужное положение размерной надписи и зафиксируйте его нажатием левой кнопки мыши или клавиши <Enter>.

На полке, влево

При выборе одного из этих способов для размещения надписи формируется линия-выноска с полкой выбранного направления. Начальной точкой линии-выноски является заданная пользователем точка, определяющая положение размерной линии.

Направление полки можно изменять следующими способами.

– Для изменения направления полки на противоположное перемещайте курсор вправо/влево (для горизонтальной полки) или вверх/вниз (для вертикальной полки).

– Для поворота полки вращайте колесо мыши при нажатой клавише <Ctrl>.

При изменении направления полки выполняется переключение между способами размещения текста на полке.

После выбора направления полки укажите точку начала полки.

На полке, вправо

На полке, вверх

На полке, вниз

Включение/отключение размещения текста на полке доступно с помощью команды Размер на полке контекстного меню.

В этом разделе:

3.3.1.5.1. Особенности автоматического размещения текста


3.3.1.5.1. Особенности автоматического размещения текста

Автоматическое размещение присутствует в списке Размещение текста всех размеров, кроме линейного цепного, линейного с обрывом, радиального с изломом и углового с обрывом.

При использовании автоматического размещения положение размерной надписи указывается пользователем. По указанному положению надписи система автоматически определяет размещение текста — фиксированное, ручное или на полке. Текущий способ в списке Размещение текста при этом не меняется.

Автоматическое размещение присутствует в списке способов размещения текста только при простановке размера. При редактировании размера в списке отображается способ размещения, который система автоматически определила при простановке размера.

Для простановки размера с автоматическим размещением надписи действуйте следующим образом.

1. Перемещайте курсор вдоль размерной линии.

При приближении курсора к одной из предопределенных точек — посередине размерной линии или снаружи выносных линий — размерная надпись автоматически устанавливается в эту точку.

2. Когда надпись достигнет нужного положения, щелкните левой кнопкой мыши.

Если надпись зафиксирована в одном из предопределенных положений, определяется фиксированное размещение, а если в произвольном положении — ручное.

При перемещении вдоль размерной линии размерная надпись размещается так, чтобы не пересекаться с выносными линиями и не оказываться над стрелками. Если требуется расположить размерную надпись абсолютно произвольно, перемещайте курсор при нажатой клавише <Alt>.

Чтобы разместить размерную надпись на полке, выполните следующие действия.

1. Укажите положение размерной линии, и, не фиксируя его, нажмите и удерживайте клавишу <Ctrl>.

2. Сдвиньте курсор, затем отпустите клавишу <Ctrl>. Положение размера зафиксируется, у него появится линия-выноска и горизонтальная полка. Обратите внимание на то, что точкой начала линии-выноски в данном случае является середина размерной линии.

При простановке радиальных размеров нажатие и удержание клавиши <Ctrl> не фиксирует положение размерной линии.

3. Перемещая курсор, задайте начало полки и ее направление.

Чтобы повернуть полку, вращайте колесо мыши при нажатой клавише <Ctrl>.

Зафиксируйте точку начала полки.


3.3.1.6. Настройка размеров в текущем и новых документах

Оформление чертежа заметно ускоряется, если основной набор параметров размеров используется как умолчательный: при создании очередного размера требуется лишь небольшая его корректировка.

В КОМПАС-3D установлены такие умолчательные значения параметров размеров, которые наиболее часто используются в конструкторской документации. При необходимости вы можете изменить умолчательные параметры размеров. Возможности настройки размеров описаны в разделе 9.2.6.10. Произведенная настройка сохраняется в текущем документе и не изменяется при передаче его на другое рабочее место.

Если изменение настройки размеров в текущем документе по каким-либо причинам нежелательно, вы можете установить комбинацию параметров, которая будет использоваться как умолчательная при создании размеров до конца сеанса работы.

Для этого при простановке первого размера каждого типа (линейный, угловой и т.д.) настройте его необходимым образом и включите опцию По умолчанию на вкладке Параметры Панели свойств и в диалоге ввода размерной надписи.


3.3.1.7. Выравнивание размерных линий

После простановки линейных и угловых размеров на чертеже возможно автоматическое выравнивание их размерных линий по размерной линии образца. В качестве образца выбирается один из размеров в чертеже.

После выравнивания длина выносных линий изменяется таким образом, что размерные линии линейных размеров становятся расположены на одной прямой, а размерные линии угловых размеров — на одной окружности (или на окружностях с равными радиусами).

Выравниваемые размеры можно указывать как после вызова команды (способ 1), так и до вызова (способ 2).

Чтобы произвести выравнивание, выполните следующие действия.

Способ 1.

1. Вызовите команду Выровнять размерные линии из меню Инструменты. Команда доступна, если в графическом документе имеется хотя бы один линейный или угловой размер.

2. Подведите курсор к размеру-образцу, по размерной линии которого требуется произвести выравнивание, и щелкните по нему левой кнопкой мыши. После указания образец подсветится.

3. Укажите курсором один или несколько размеров подряд для выравнивания. При подведении курсора, если размер может быть выровнен, он подсвечивается, а после указания его выносные и размерные линии перестраиваются.

Размер может быть выровнен, если он соответствует типу размера-образца, а для линейных размеров необходимо также, что бы их размерные линии были параллельны размерной линии размера-образца.

Рис. 3.3.9. Пример выравнивания линейных размеров: а) указание образца, б) результат выравнивания
а) | б)

Обозначение размера-образца остается подсвеченным до конца работы команды.

Чтобы перейти к выравниванию другой группы обозначений, нажмите кнопку Указать заново на Панели специального управления. Затем укажите образец и обозначения для выравнивания.

Способ 2.

1. Выделите на чертеже размеры, которые нужно выровнять. Если в выделение попадут другие объекты, не являющиеся размерами, они не помешают работе команды, а будут проигнорированы.

2. Вызовите команду Выровнять размерные линии и укажите размер-образец. Те из выделенных размеров, которые могут быть выровнены по данному образцу, выровняются, остальные размеры проигнорируются.

Чтобы выровнять сразу несколько групп размеров, например, вертикальные и горизонтальные размеры, нужно выделить все выравниваемые размеры (применяя способ 1 или способ 2) и последовательно указать для них нужные образцы, используя кнопку Указать заново.


3.3.1.8. Формирование зазора между выносной линией и точкой привязки

3.3.1.8. Формирование зазора между выносной линией
и точкой привязки

Иногда при простановке размера требуется, чтобы выносная линия была отрисована на некотором расстоянии от точки привязки. Это возможно при простановке линейных размеров всех типов (кроме размера с обрывом), диаметрального и радиальных размеров.

Для реализации такого способа построения используется группа элементов управления Зазор/длина на вкладке Параметры Панели свойств. Элементы группы доступны при включенной отрисовке выносных линий (см. таблицу 3.3.3).

Вы можете зафиксировать как длину выносных линий, так и зазор между базовой точкой и началом выносной линии. Для этого введите нужное значение в поле Зазор/длина.

Если требуется, чтобы заданное число определяло зазор между началом выносной линии и точкой привязки размера, активизируйте переключатель Зазор выносных линий. В этом случае при задании положения размерной линии длина выносной линии будет изменяться, а зазор — оставаться постоянным и равным заданному значению.

Если же введенное значение должно определять длину выносной линии, активизируйте переключатель Длина выносных линий. В этом случае при задании положения размерной линии зазор будет изменяться, а длина выносной линии — оставаться постоянной и равной заданному значению.

Если значение в поле Зазор/длина равно нулю, то выносные линии начинаются в точках привязки размера и могут иметь любую длину.

Рис. 3.3.10. Пример простановки линейного и диаметрального размеров с зазором


3.3.2. Линейные размеры

3.3. Размеры и обозначения

3.3.2. Линейные размеры

Система позволяет проставлять линейные размеры различными способами. Большинство параметров при разных способах простановки одинаковы. Различие состоит в порядке указания характерных точек и образмериваемых объектов.

В этом разделе:

3.3.2.1. Простой линейный размер

3.3.2.1.1. Указание объектов для простановки размера

3.3.2.1.2. Управление ориентацией размера

3.3.2.1.3. Размер с наклонными выносными линиями

3.3.2.2. Линейный размер с обрывом

3.3.2.3. Линейный размер от отрезка до точки

3.3.2.4. Линейный размер от общей базы

3.3.2.5. Цепной линейный размер

3.3.2.6. Линейный размер с общей размерной линией

3.3.2.7. Размер дуги


3.3.2.1. Простой линейный размер

Чтобы проставить линейный размер, вызовите команду Линейный размер.

Задайте точки привязки размера — т1 и т2 (точки выхода выносных линий). Для этого укажите нужные точки и/или объекты в документе (см. раздел 3.3.2.1.1).

При необходимости отредактируйте размерную надпись (см. раздел 3.3.1.3), выберите способ размещения размерной надписи (см. раздел 3.3.1.5) и настройте параметры отрисовки размера (см. раздел 3.3.1.2).

Затем задайте точку т3, определяющую положение размерной линии. Точка т3 определяет также положение размерной надписи, если выбрано автоматическое, фиксированное или ручное размещение текста (рис. 3.3.11).

Рис. 3.3.11. Линейный размер с ручным размещением размерной надписи

Если выбрано размещение размерной надписи на полке, то точка т3 определяет не только положение размерной линии, но и начало линии-выноски. В этом случае для задания положения текста необходимо задать точку начала полки т4 (рис. 3.3.12).

Рис. 3.3.12. Линейный размер на полке

В этом разделе:

3.3.2.1.1. Указание объектов для простановки размера

3.3.2.1.2. Управление ориентацией размера

3.3.2.1.3. Размер с наклонными выносными линиями


3.3.2.1.1. Указание объектов для простановки размера

Для простановки размеров могут быть указаны следующие объекты:

– точки привязки размера,

– базовый объект (или объекты).

Режим указания объектов определяется состоянием кнопки Выбор базового объекта, расположенной на Панели специального управления Панели свойств. При отжатой кнопке выполняется указание точек привязки, а при нажатой — выбор базовых объектов.

Указание точек привязки размера

Данный режим предназначен для указания точек привязки размера — точек выхода выносных линий. Чтобы указать нужные точки, отожмите кнопку Выбор базового объекта.

Вы можете указывать как характерные точки объектов, так и отдельные точки. При наведении на объект указателя мыши срабатывает одна из привязок, включенных в документе. Если ни одна из привязок не сработала, объект выбирается целиком, и точками привязки размера становятся его крайние точки.

Обратите внимание на то, что выбор объекта возможен, когда в документе отключена привязка Точка на кривой. Если эта привязка включена, то при наведении указателя мыши на объект выбирается одна из его точек (в случае умолчательного распределения приоритетов привязок). Это происходит потому, что в данном режиме выбор точек привязки имеет приоритет перед выбором объектов.

При необходимости вы можете выбрать объект, удерживая клавишу <Alt> (временное отключение всех привязок).

Чтобы проставить размер, укажите две нужные точки. Пример полученного размера приведен на рис. 3.3.13.

Рис. 3.3.13. Пример простановки линейного размера по двум точкам

Указание базового объекта для простановки размера

Для простановки размера можно использовать один или два базовых объекта.

Чтобы указать базовые объекты, нажмите кнопку Выбор базового объекта. Привязки перестанут работать, система перейдет в режим указания объектов.

Укажите базовый объект. После этого привязки снова начинают работать, однако возможность выбора базового объекта сохраняется. В данном режиме (в отличие от режима указания точек привязки) выбор объекта имеет приоритет перед выбором точек привязки.

Укажите еще один базовый объект или перейдите к размещению размерной надписи.

Все доступные варианты базовых объектов представлены в таблице 3.3.9.

Табл. 3.3.9. Выбор базовых объектов для простановки линейного размера
Базовые объекты | Полученный размер | Комментарий
Отрезок, сплайн, дуга (окружности, эллипса) |  | Размер проставляется к крайним точкам указанного объекта. Эти точки становятся точками привязки размера.
Окружность |  | К размерной надписи автоматически добавляется знак диаметра. Положение размера — горизонтальный или вертикальный — определяется перемещением курсора.
Эллипс |  | Создается размер одной из полуосей. Нужная полуось выбирается перемещением курсора.
Осевая линия (или отрезок со стилем осевая) и точка |  | Значение размера равно удвоенному расстоянию от осевой до точки (может быть указана как отдельная точка, так и характерная точка объекта). Точками привязки размера становятся указанная точка и точка, симметричная ей относительно осевой. Перед размерным числом автоматически проставляется знак диаметра.
Окружность и эллипс1 |  | Создается размер между центрами окружности и эллипса.
Две окружности1 |  | В зависимости от точек, в которых были указаны окружности, создается размер между их центрами или размер, выносные линии которого расположены касательно к окружностям.
  1. Могут также использоваться дуги.


3.3.2.1.2. Управление ориентацией размера

По умолчанию размерная линия параллельна линии, проходящей через точки привязки размера. При этом на вкладке Размер Панели свойств активен переключатель Параллельно объекту.

Чтобы построить горизонтальный или вертикальный размер, активизируйте соответствующий переключатель.

Рис. 3.3.14. Ориентация линейного размера: а) параллельный объекту, б) горизонтальный, в) вертикальный
а) | б) | в)


3.3.2.1.3. Размер с наклонными выносными линиями

Иногда бывает необходимо наклонить выносные линии линейного размера, например, как на рис. 3.3.15.

Рис. 3.3.15. Пример простановки размера с наклонными выносными линиями

Размер такого вида формируется в процессе построения простого линейного размера с помощью кнопки Наклонить размер, расположенной на Панели специального управления.

Эта кнопка доступна, если выполняются следующие условия:

– выключено автоматическое создание объекта (см. раздел 1.4.2.8),

– заданы все характерные точки (то есть размер полностью определен),

– размер проставляется параллельно объекту (см. раздел 3.3.2.1.2).

После нажатия указанной кнопки все опции вкладки Размер заменяются одним полем Угол. Введите в него значение угла наклона выносных линий размера. Можно также «наклонить» размер мышью, перетаскивая одну из появившихся экране характерных точек.

После установки нужного положения выносных линий отожмите кнопку Наклонить размер. На вкладке Размер вновь появятся обычные элементы управления.


3.3.2.2. Линейный размер с обрывом

Чтобы проставить линейный размер с обрывом, вызовите команду Линейный размер с обрывом.

Укажите отрезок, от которого требуется проставить размер с обрывом.

– Если на изображении есть ось симметрии образмериваемого элемента, укажите ее (осевая линия должна быть параллельна отрезку, от которого проставляется размер). Значение размера вычисляется как удвоенное расстояние между отрезком и осью, перед размерным числом автоматически проставляется знак диаметра. При необходимости можно отредактировать размерную надпись (см. раздел 3.3.1.3).

– Если оси образмериваемого элемента нет, то введите текст размерной надписи вручную (см. раздел 3.3.1.3).

При необходимости выберите способ размещения размерной надписи (см. раздел 3.3.1.5) и настройте параметры отрисовки размера (см. раздел 3.3.1.2).

Затем задайте точку т3, определяющую положение размерной линии и ее длину.

Если выбрано размещение размерной надписи на полке, задайте точку начала полки т4. Точка начала линии-выноски находится в середине размерной линии, изменить ее положение нельзя.

Рис. 3.3.16. Пример простановки размеров с обрывом


3.3.2.3. Линейный размер от отрезка до точки

Чтобы построить линейный размер между двумя геометрическими элементами — отрезком и произвольной точкой (в том числе характерной точкой другого графического объекта), вызовите команду Линейный размер от отрезка до точки.

Укажите отрезок, от которого проставляется размер.

Выносные линии размера будут параллельны этому отрезку, а один из его концов будет первой точкой привязки размера.

Задайте вторую точку привязки размера т2. Для этого укажите один из следующих объектов:

– произвольную точку;

– отрезок, параллельный отрезку, от которого проставляется размер — точкой т2 станет один из концов указанного отрезка;

– окружность (дугу окружности) — точкой т2 станет точка касания окружности и прямой параллельной отрезку, от которого проставляется размер.

При необходимости отредактируйте размерную надпись (см. раздел 3.3.1.3), выберите способ размещения размерной надписи (см. раздел 3.3.1.5) и настройте параметры отрисовки размера (см. раздел 3.3.1.2).

Затем задайте точку т3, определяющую положение размерной линии. Если выбрано автоматическое, фиксированное или ручное размещение размерной надписи, то ее положение также определяет точка т3.

Если выбрано размещение размерной надписи на полке, задайте точку начала полки т4. В этом случае точка т3 является начальной точкой линии-выноски.

Тот конец отрезка, ближе к которому окажется размерная линия, будет принят за первую точку привязки размера т1.

Рис. 3.3.17. Пример простановки размера между отрезком и точкой


3.3.2.4. Линейный размер от общей базы

Чтобы построить группу линейных размеров с общей базой, вызовите команду Линейный от общей базы.

Задайте первую точку привязки т1. Она будет общей для группы создаваемых размеров.

Задайте вторую точку привязки т2 для первого размера группы.

При необходимости отредактируйте размерную надпись (см. раздел 3.3.1.3), выберите способ размещения текста (см. раздел 3.3.1.5) и настройте параметры отрисовки размера (см. раздел 3.3.1.2).

Задайте точку т3, определяющую положение размерной линии. Точка т3 определяет также положение размерной надписи, если выбрано автоматическое, фиксированное или ручное размещение текста.

Если выбрано размещение размерной надписи на полке, задайте точку начала полки т4. В этом случае точка т3 определяет начало линии-выноски.

Последовательно задайте точки т2, т3 (и т4) для остальных размеров группы.

На вкладке Размер Панели свойств находится группа переключателей Тип, с помощью которой можно установить ориентацию каждого из создаваемых размеров (вертикальный или горизонтальный).

Группа размеров, построенная с помощью команды Линейный от общей базы, не является единым объектом — это несколько простых линейных размеров, первые точки привязки которых совпадают. Поэтому, если у всех размеров группы должны быть одинаковые параметры (например, стрелки определенного типа), необходимо после настройки первого размера включить опцию По умолчанию.

Рис. 3.3.18. Простановка линейных размеров от общей базы

Чтобы перейти к простановке группы размеров от другой базы, расфиксируйте первую базовую точку (поле т1 на вкладке Размер Панели свойств) и задайте ее новое положение.


3.3.2.5. Цепной линейный размер

Чтобы построить цепь линейных размеров, вызовите команду Цепной линейный размер.

Задайте первую точку привязки размера т1.

Задайте вторую точку привязки размера т2.

На вкладке Размер Панели свойств находится группа переключателей Тип, с помощью которой можно установить ориентацию всех размеров цепи (вертикальный или горизонтальный).

Выбор ориентации возможен только до фиксации первого размера цепи.

При необходимости отредактируйте размерную надпись (см. раздел 3.3.1.3), выберите способ размещения текста (см. раздел 3.3.1.5) и настройте параметры отрисовки размера (см. раздел 3.3.1.2).

Задайте точку, определяющую положение размерной линии т3. Это положение будет одинаковым для всех размеров цепи. Если выбрано фиксированное или ручное размещение текста, то точка т3 определяет также положение размерной надписи.

Если выбрано размещение размерной надписи на полке, задайте точку начала полки т4.

Последовательно задайте точки т2, т3 (и т4) для остальных размеров цепи.

Группа размеров, построенная с помощью команды Линейный цепной размер, не является единым объектом — это цепь простых линейных размеров, составленная по определенным правилам (первая точка привязки каждого последующего размера совпадает со второй точкой привязки предыдущего; размерные линии расположены на одной прямой). Поэтому, если у всех размеров цепи должны быть одинаковые параметры (например, стрелки определенного типа), необходимо после настройки первого размера включить опцию По умолчанию.

Рис. 3.3.19. Простановка цепи линейных размеров

Чтобы перейти к простановке следующего цепного размера, расфиксируйте первую точку привязки цепи (поле т1 на вкладке Размер Панели свойств) и задайте ее новое положение.


3.3.2.6. Линейный размер с общей размерной линией

Чтобы построить группу линейных размеров с общей размерной линией, вызовите команду Линейные размеры с общей размерной линией.

Задайте первую точку привязки т1 для группового размера.

Затем задайте вторую точку привязки т2.

На вкладке Размер Панели свойств находится группа переключателей Тип, с помощью которой можно установить ориентацию группового размера (вертикальный или горизонтальный).

Выбор ориентации возможен только до формирования первого размера группы.

При необходимости отредактируйте размерную надпись (см. раздел 3.3.1.3) и настройте параметры отрисовки размера (см. раздел 3.3.1.2).

Задайте точку, определяющую положение размерной линии т3. Это положение будет одинаковым для всех размеров группы.

Затем задайте точки т2 для остальных размеров группы.

Группа размеров, построенная с помощью команды Линейный с общей размерной линией, не является единым объектом — это цепь линейных размеров с совпадающими первыми точками привязки и специальным образом расположенными размерными надписями. Поэтому, если у всех размеров группы должны быть одинаковые параметры (например, стрелки определенного типа), необходимо после настройки первого размера включить опцию По умолчанию.

Рис. 3.3.20. Простановка линейных размеров с общей размерной линией

Чтобы перейти к построению следующей группы размеров с общей размерной линией, расфиксируйте первую точку привязки группы (поле т1 на вкладке Размер Панели свойств) и задайте ее новое положение.


3.3.2.7. Размер дуги

Чтобы построить размер, характеризующий длину дуги окружности, вызовите команду Размер дуги окружности.

Укажите дугу, которую требуется образмерить.

На вкладке Размер Панели свойств находится группа переключателей Тип, с помощью которой можно задать направление выносных линий — от центра или параллельно радиусу, проведенному в середину дуги. Если угол раствора дуги больше 180°, возможно создание размера только с выносными линиями от центра.

Рис. 3.3.21. Размер дуги: а) с параллельными выносными линиями, б) с выносными линиями от центра
а) | б)

При необходимости отредактируйте размерную надпись (см. раздел 3.3.1.3), выберите способ размещения размерной надписи (см. раздел 3.3.1.5) и настройте параметры отрисовки размера (см. раздел 3.3.1.2). Символ дуги проставляется над номиналом размера автоматически.

Затем задайте точку, определяющую положение размерной линии т3. Точка т3 определяет также положение размерной надписи, если выбрано автоматическое, фиксированное или ручное размещение текста.

Если выбрано размещение размерной надписи на полке, задайте точку начала полки т4. Точка т3 в этом случае является начальной точкой линии-выноски.

На вкладке Параметры Панели свойств находится опция Указатель от текста к дуге. Включите ее, если требуется соединить указателем дугу и текст относящегося к ней размера. Это может потребоваться, например, при простановке размеров концентрических дуг с одинаковым раствором и начальным углом.

Рис. 3.3.22. Пример простановки размера дуги с указателем от текста к дуге


3.3.3. Диаметральные и радиальные размеры

3.3. Размеры и обозначения

3.3.3. Диаметральные и радиальные размеры

В этом разделе:

3.3.3.1. Диаметральный размер

3.3.3.2. Простой радиальный размер

3.3.3.2.1. Радиальный размер на полке с несколькими ответвлениями

3.3.3.2.2. Редактирование радиального размера

3.3.3.3. Радиальный размер с изломом

3.3.3.3.1. Редактирование размерной линии с изломом при помощи мыши


3.3.3.1. Диаметральный размер

Чтобы построить диаметральный размер, вызовите команду Диаметральный размер.

Укажите окружность, которую требуется образмерить.

Размерная линия может быть полная или с обрывом. Для выбора нужного варианта воспользуйтесь группой переключателей Тип на вкладке Размер Панели свойств.

При необходимости отредактируйте размерную надпись (см. раздел 3.3.1.3), выберите способ размещения размерной надписи (см. раздел 3.3.1.5) и настройте параметры отрисовки размера (см. раздел 3.3.1.2).

Если выбрано автоматическое, фиксированное или ручное размещение размерной надписи, задайте точку т1, определяющую положение размерной линии и надписи (рис. 3.3.23).

Рис. 3.3.23. Диаметральные размеры с автоматически размещенной надписью

Если выбрано размещение размерной надписи на полке, надпись может быть расположена, как показано на рис. 3.3.24.

Рис. 3.3.24. Диаметральные размеры с надписью, размещенной на полке: а) линия-выноска не совпадает с размерной линией, б) линия-выноска совпадает с размерной линией
а) | б)

– Чтобы расположить размерную надпись, как показано на рис. 3.3.24, а, задайте точку т1, определяющую начало линии-выноски, и точку т2 начала полки. Точка т1 должна лежать внутри окружности.

– Чтобы расположить размерную надпись, как показано на рис. 3.3.24, б, задайте только точку т2 начала полки. Заданная точка должна лежать вне окружности.

Размерная линия с обрывом выходит за центр окружности на расстояние, равное 1/5 ее радиуса, но не менее, чем на расстояние, установленное в данном документе для выхода размерной линии за текст. Эта величина задается при настройке текущего документа (см. раздел 9.2.6.10.2).


3.3.3.2. Простой радиальный размер

Чтобы построить радиальный размер, вызовите команду Радиальный размер.

Укажите окружность или дугу окружности, которую требуется образмерить.

При необходимости отредактируйте размерную надпись (см. раздел 3.3.1.3), выберите способ размещения размерной надписи (см. раздел 3.3.1.5) и настройте параметры отрисовки размера (см. раздел 3.3.1.2).

Если выбрано автоматическое, фиксированное или ручное размещение размерной надписи, задайте точку т1, определяющую положение размерной линии и текста (рис. 3.3.25).

Рис. 3.3.25. Радиальный размер с автоматически размещенной надписью

Если выбрано размещение размерной надписи на полке, задайте точку начала полки т2 (рис. 3.3.26). Для простановки размеров одинаковых радиусов на общей полке используются полки с несколькими ответвлениями (см. раздел 3.3.3.2.1).

Рис. 3.3.26. Радиальный размер на полке

Радиальный размер может быть проставлен от центра или не от центра окружности (дуги). В обоих случаях размерная линия принадлежит прямой, проходящей через центр образмериваемой окружности. Отличие состоит в следующем. Если размер проставлен от центра, то длина его размерной линии не может быть меньше радиуса (рис. 3.3.25, 3.3.26). Если размер проставлен не от центра, то длина размерной линии может быть любой (рис. 3.3.27).

Рис. 3.3.27. Радиальный размер не от центра

Для выбора нужного варианта воспользуйтесь группой переключателей Тип на вкладке Размер Панели свойств.

В этом разделе:

3.3.3.2.1. Радиальный размер на полке с несколькими ответвлениями

3.3.3.2.2. Редактирование радиального размера


3.3.3.2.1. Радиальный размер на полке с несколькими ответвлениями

В соответствии с ГОСТ размеры одинаковых радиусов допускается указывать на общей полке. Для такого варианта простановки размеров используются полки с несколькими ответвлениями (рис. 3.3.28).

Рис. 3.3.28. Радиальный размер на полке с ответвлением: а) от начала полки, б) от конца полки.
а) | б)

Простановка размера на общей полке возможна только для неконцентрических окружностей (дуг окружностей) с одинаковыми радиусами.

Чтобы проставить размер для двух или более окружностей (дуг окружностей), выполните следующие действия.

1. Вызовите команду Радиальный размер.

2. Укажите первую окружность (дугу окружности), которую требуется образмерить. На экране появится фантом размера.

3. Ответвления размера (размерные линии к остальным окружностям или дугам окружностей) могут быть построены от начала полки или от ее конца.

• Чтобы следующее ответвление размера начиналось от начала полки (рис. 3.3.28, а), укажите вторую окружность (дугу окружности). При этом полка будет создана автоматически. Фантом размера изменится — он будет состоять из двух размерных линий и полки.

• Чтобы следующее ответвление размера начиналось от конца полки (рис. 3.3.28, б), она должна быть предварительно создана.

Для создания полки переместите курсор при нажатой клавише <Ctrl> или выберите один из вариантов размещения текста размерной надписи на полке из списка Размещение текста на вкладке Размер Панели свойств. Фантом размера изменится — он будет состоять из размерной линии и полки.

Станет доступной группа переключателей Ответвления на вкладке Параметры Панели свойств, позволяющая выбрать способ построения ответвления — От начала полки или От конца полки. Активизируйте переключатель От конца полки. К фантому размера добавится ответвление, начинающееся от конца полки.

4. Укажите остальные окружности (дуги окружностей), которые требуется образмерить.

Вы можете создать любое количество ответвлений, указывая окружности и дуги одного и того же радиуса. Вариант построения каждого ответвления (от начала полки или от ее конца) зависит от того, какой из переключателей группы Ответвления активизирован.

5. После указания всех необходимых окружностей (дуг окружностей), завершите простановку размера, задав точку т2 начала полки (см. рис. 3.3.28).

В дальнейшем вы можете изменять параметры созданного размера, редактировать его характерные точки, добавлять ответвления (см. раздел 3.3.3.2.2). Если требуется вносить изменения в процессе создания размера, отключите автосоздание объектов.


3.3.3.2.2. Редактирование радиального размера

Радиальный размер можно редактировать, изменяя его параметры на Панели свойств (см. раздел 3.3.1.2).

Если для редактирования выбран радиальный размер на полке или при изменении параметров размера задано размещение его размерной надписи на полке, возможно добавление ответвлений размера. Чтобы перейти в режим добавления ответвлений, нажмите кнопку Добавить ответвления на Панели специального управления. Добавление ответвления выполняется автоматически при указании окружности (дуги окружности) того же радиуса, что и окружность, к которой проставлен редактируемый размер.

Удаление ответвлений и изменение положения полки выполняется в режиме редактирования характерных точек. Этот режим доступен, если размер имеет ответвления. Для перехода в этот режим нажмите кнопку Редактировать точки на Панели специального управления.

В режиме редактирования характерных точек вы можете выполнить следующие действия.

– Переместить полку, изменив координаты точки т2 (см. рис. 3.3.28) или «перетащив» ее мышью в нужное место. При определении положения точки т2 вы можете использовать привязки (см. раздел 3.1.1) и геометрический калькулятор (см. раздел 1.4.2.13.1).

– Повернуть полку, вращая точку на конце полки вокруг точки т2 с шагом 90°.

– Удалить ответвление, выделив характерную точку на его конце и нажав клавишу <Delete>.

Обратите внимание на то, что режимы добавления ответвлений и редактирования характерных точек не могут быть одновременно включены. При включении одного из режимов другой автоматически отключается.


3.3.3.3. Радиальный размер с изломом

Радиальный размер с изломом используется, когда требуется образмерить дугу очень малой кривизны, например, как на рис. 3.3.29.

Рис. 3.3.29. Радиальные размеры с изломом

В этом случае размерная линия представляет собой ломаную, причем то ее звено, которое оканчивается размерной стрелкой, совпадает с истинным радиусом, проведенным в выбранную точку дуги.

Чтобы построить радиальный размер с изломом, вызовите команду Радиальный размер с изломом.

Укажите окружность или дугу окружности, которую требуется образмерить.

При необходимости отредактируйте размерную надпись (см. раздел 3.3.1.3), выберите способ размещения размерной надписи (см. раздел 3.3.1.5) и настройте параметры отрисовки размера (см. раздел 3.3.1.2).

Если выбрано фиксированное или ручное размещение текста, задайте точку т1, определяющую положение размерной линии и надписи (рис. 3.3.30).

Рис. 3.3.30. Радиальные размеры с изломом с автоматически размещенной надписью

Если выбрано размещение размерной надписи на полке, задайте точку начала полки т2 (рис. 3.3.31).

Рис. 3.3.31. Радиальный размер с надписью, размещенной на полке

Задайте положение фиктивного центра (на рисунках он обозначен точкой C’) окружности, расположенного ближе к дуге, чем фактический центр.

Размеры с изломом, проставляемые друг за другом к концентрическим дугам или окружностям, автоматически создаются с одним и тем же фиктивным центром — точкой, которая была указана для первого из них (см. рис. 3.3.29).

В этом разделе:

3.3.3.3.1. Редактирование размерной линии с изломом при помощи мыши


3.3.3.3.1. Редактирование размерной линии с изломом при помощи мыши

Редактировать размерную линию с изломом можно, изменяя положение ее характерных точек мышью в окне документа.

Подробно о редактировании при помощи характерных точек рассказано в разделе 3.5.1.1.3.

Размерная линия с изломом имеет следующие характерные точки:

1 — точку для изменения положения фиктивного центра,

2 — точку для смещения излома вдоль размерной линии,

3 — точку для изменения угла наклона размерной линии; для размерной линии, надпись на которой размещена ручным способом или на полке (см. табл. 3.3.1), точка 3 также позволяет перемещать надпись или полку,

4 — точку для смены направления полки.

Количество и расположение характерных точек зависит от способа размещения надписи (рис. 3.3.32).

Рис. 3.3.32. Характерные точки размера с надписью, размещенной: а) вручную, б) на полке
а) | б)

При перемещении точки излома следует учесть, что длина линии от центра до излома ограничена размером обозначения фиктивного центра, то есть a>b (см. рис. 3.3.32, а).

Чтобы изменить умолчательный размер обозначения центра в текущем документе, вызовите команду Сервис — Параметры... — Текущий чертеж (фрагмент) — Линии — Осевая линия.


3.3.4. Угловые размеры

3.3. Размеры и обозначения

3.3.4. Угловые размеры

В этом разделе:

3.3.4.1. Общие приемы работы с угловыми размерами

3.3.4.1.1. Указание сторон углов

3.3.4.1.2. Управление ориентацией размера

3.3.4.1.3. Вид выносных линий

3.3.4.2. Простой угловой размер

3.3.4.3. Угловой размер от общей базы

3.3.4.4. Угловой цепной размер

3.3.4.5. Угловой размер с общей размерной линией

3.3.4.6. Угловой размер с обрывом

3.3.4.7. Особенности редактирования углового размера с помощью мыши


3.3.4.1. Общие приемы работы с угловыми размерами

В этом разделе:

3.3.4.1.1. Указание сторон углов

3.3.4.1.2. Управление ориентацией размера

3.3.4.1.3. Вид выносных линий


3.3.4.1.1. Указание сторон углов

Для простановки угловых размеров всех типов могут быть указаны прямолинейные объекты или точки, при соединении которых образуются стороны угла.

Режим указания объектов определяется состоянием кнопки Выбор базового объекта, расположенной на Панели специального управления Панели свойств. При нажатой кнопке выполняется указание прямолинейных объектов, а при отжатой — указание точек.

В качестве прямолинейного объекта (далее «отрезка») может использоваться:

– отрезок, звено ломаной, сторона многоугольника,

– объект типа осевая линия,

– вспомогательная прямая,

– ось абсолютной системы координат или системы координат вида.

Различные варианты простановки углового размера описаны ниже. Примеры приведены на рисунках. Последовательность указания объектов показана на рисунках цифрами в скобках.

Указание отрезков для простановки размера

Чтобы указать отрезки, нажмите кнопку Выбор базового объекта. В документе перестанут работать привязки, система перейдет в режим указания объектов.

Последовательно укажите отрезки — стороны угла. Одна из конечных точек первого отрезка принимается за точку привязки размера т1, второго — за точку привязки т2. Положение вершины угла вычисляется автоматически.

Если в качестве стороны угла указана вспомогательная прямая или ось системы координат, то соответствующая этой стороне точка привязки размера совпадает с вершиной угла.

После указания отрезков привязки снова начинают работать. Они позволяют задать положение размерной надписи.

Рис. 3.3.33. Пример простановки углового размера по двум отрезкам

При необходимости вы можете проставить угловой размер, задав одну из его сторон отрезком, а вторую двумя точками. Для этого укажите отрезок, затем отожмите кнопку Выбор базового объекта и укажите две точки.

За первую точку привязки размера принимается одна из конечных точек отрезка, а за вторую — одна из указанных точек. Отрезок и прямая, проходящая через указанные точки, образуют угол. Положение вершины угла вычисляется автоматически.

Рис. 3.3.34. Пример простановки углового размера по отрезку и двум точкам

Указание точек для простановки размера

Если требуется проставить угловой размер по точкам, отожмите кнопку Выбор базового объекта.

Укажите точку, которая будет являться вершиной угла, а затем точки т1 и т2 на его сторонах — точки привязки размера.

Точки могут быть указаны в документе, заданы вводом координат на Панели свойств или с помощью геометрического калькулятора (см. раздел 1.4.2.13.1).

Рис. 3.3.35. Пример простановки углового размера по трем точкам

Если необходимо, то в режиме указания точек можно выбрать и отрезок, т.е. проставить размер, указав стороны угла отрезками или отрезком и двумя точками. Указание отрезков доступно при отключенной привязке Точка на кривой. Если эта привязка включена, указывайте отрезки, удерживая клавишу <Alt> (что временно отключает привязки).


3.3.4.1.2. Управление ориентацией размера

Ориентация вновь созданного углового размера определяется системой автоматически.

Если этот угол острый, в группе Тип на вкладке Размеры становится активным переключатель На острый угол, если тупой — переключатель На тупой угол. На рис. 3.3.36 показаны возможные места указания сторон угла и соответствующие им автоматически определенные углы.

Рис. 3.3.36. Автоопределение типа углового размера

При необходимости с помощью указанных переключателей вы можете изменить предложенный системой способ простановки, в том числе включить простановку угла больше 180° (автоматический выбор этого варианта невозможен).

Обратите внимание на то, что между двумя сторонами существуют два угла больше 180°:

– угол, дополняющий до 360° острый угол между сторонами,

– угол, дополняющий до 360° тупой угол между сторонами.

Выбор нужного варианта осуществляется указанием точки т3 (рис. 3.3.37).

Рис. 3.3.37. Простановка размера на угол больше 180° между отрезками

Изменение ориентации угловых размеров с общей размерной линией возможно только при отключенном автосоздании (см. раздел 1.4.2.10).


3.3.4.1.3. Вид выносных линий

Выносные линии могут быть отрисованы от центра или не от центра, а от точек привязки т1 и т2 (см.рис. 3.3.38).

Для выбора нужного варианта воспользуйтесь группой переключателей Выносные линии или вызовите команду Выносные линии от центра из контекстного меню.

Рис. 3.3.38. Вид выносных линий: а) не от центра, б) от центра
а) | б)


3.3.4.2. Простой угловой размер

Чтобы проставить простой угловой размер, вызовите команду Угловой размер.

Укажите первую и вторую стороны угла (см. раздел 3.3.4.1.1).

На Панели свойств отображаются координаты вершины угла, точек привязки т1 и т2.

При необходимости отредактируйте размерную надпись (см. раздел 3.3.1.3), выберите способ размещения размерной надписи (см. раздел 3.3.1.5) и настройте параметры отрисовки размера (см. раздел 3.3.1.2).

Задайте точку т3, определяющую положение размерной линии и надписи. Те концы отрезков, ближе к которым окажется размерная линия, будут приняты за точки привязки размера.

Если выбрано автоматическое, фиксированное или ручное размещение размерной надписи, то ее положение также определяется точкой т3 (рис. 3.3.39).

Рис. 3.3.39. Угловые размеры с ручным размещением размерной надписи;
способ задания сторон угла — по двум отрезкам

Если выбрано размещение размерной надписи на полке, то точка т3 определяет не только положение размерной линии, но и начало линии-выноски. В этом случае для задания положения текста необходимо задать точку начала полки т4 (рис. 3.3.40).

Рис. 3.3.40. Угловой размер на полке;
способ задания сторон угла — по трем точкам


3.3.4.3. Угловой размер от общей базы

Чтобы построить группу угловых размеров с общей базой, вызовите команду Угловой размер от общей базы.

Укажите первую сторону угла, общую для группы создаваемых размеров, а затем вторую сторону угла для первого размера группы (см. раздел 3.3.4.1.1).

На Панели свойств отображаются координаты вершины угла, точек привязки т1 и т2.

При необходимости отредактируйте размерную надпись (см. раздел 3.3.1.3), выберите способ размещения размерной надписи (см. раздел 3.3.1.5) и настройте параметры отрисовки размера (см. раздел 3.3.1.2).

Задайте точку, определяющую положение размерной линии т3. Точка т3 определяет также положение размерной надписи, если выбрано автоматическое, фиксированное или ручное размещение текста.

Если выбрано размещение размерной надписи на полке, задайте точку начала полки т4.

Последовательно укажите вторые стороны углов, точку т3 (и т4) для остальных размеров группы.

Группа размеров, построенная с помощью команды Угловой от общей базы, не является единым объектом — это несколько простых угловых размеров, первые стороны которых совпадают. Поэтому, если у всех размеров группы должны быть одинаковые параметры (например, стрелки определенного типа), необходимо после настройки первого размера включить опцию По умолчанию.

Рис. 3.3.41. Простановка угловых размеров от общей базы;
способ задания сторон угла — по двум отрезкам

Чтобы перейти к простановке группы размеров от другой базы, нажмите кнопку Указать заново и укажите новую сторону угла.


3.3.4.4. Угловой цепной размер

Чтобы построить цепь угловых размеров, вызовите команду Угловой цепной размер.

Укажите первую и вторую стороны угла (см. раздел 3.3.4.1.1).

На Панели свойств отображаются координаты вершины угла, точек привязки т1 и т2.

При необходимости отредактируйте размерную надпись (см. раздел 3.3.1.3), выберите способ размещения размерной надписи (см. раздел 3.3.1.5) и настройте параметры отрисовки размера (см. раздел 3.3.1.2).

Задайте точку, определяющую положение размерной линии т3. Это положение будет одинаковым для всех размеров цепи.

Точка т3 определяет также положение размерной надписи, если выбрано автоматическое, фиксированное или ручное размещение текста.

Если выбрано размещение размерной надписи на полке, задайте точку начала полки т4. Точка т3 в этом случае определяет начало линии-выноски.

Последовательно укажите вторые стороны углов — отрезки, точку т3 (и т4) для остальных размеров цепи.

Все отрезки, указываемые для построения цепного углового размера, должны проходить через одну точку — центр окружности, содержащей размерные линии.

Группа размеров, построенная с помощью команды Угловой цепной размер, не является единым объектом — это цепь простых угловых размеров, составленная по определенным правилам (первая сторона угла каждого последующего размера совпадает со второй стороной угла предыдущего; размерные линии расположены на одной окружности). Поэтому, если у всех размеров цепи должны быть одинаковые параметры (например, или стрелки определенного типа), необходимо после настройки первого размера включить опцию По умолчанию.

Рис. 3.3.42. Простановка цепи угловых размеров;
способ задания сторон угла — по двум отрезкам

Чтобы перейти к простановке следующего цепного размера, нажмите кнопку Указать заново и укажите новую сторону угла.


3.3.4.5. Угловой размер с общей размерной линией

Чтобы построить группу угловых размеров с общей размерной линией, вызовите команду Угловой размер с общей размерной линией.

Укажите первую и вторую стороны угла (см. раздел 3.3.4.1.1).

На Панели свойств отображаются координаты вершины угла, точек привязки т1 и т2.

При необходимости отредактируйте размерную надпись (см. раздел 3.3.1.3) и настройте параметры отрисовки размера (см. раздел 3.3.1.2).

Задайте точку т3, определяющую положение размерной линии. Это положение будет одинаковым для всех размеров группы.

Последовательно укажите вторые стороны углов для остальных размеров группы.

Все отрезки, указываемые для построения углового размера с общей размерной линией, должны проходить через одну точку — центр окружности, содержащей размерные линии.

Группа размеров, построенная с помощью команды Угловой с общей размерной линией, не является единым объектом — это цепь угловых размеров с совпадающими первыми сторонами углов и специальным образом расположенными размерными надписями. Поэтому, если у всех размеров группы должны быть одинаковые параметры (например, стрелки определенного типа), необходимо после настройки первого размера включить опцию По умолчанию.

Рис. 3.3.43. Простановка угловых размеров с общей размерной линией;
способ задания сторон угла — по трем точкам

Чтобы перейти к простановке следующей группы размеров с общей размерной линией, нажмите кнопку Указать заново и укажите новую сторону угла.


3.3.4.6. Угловой размер с обрывом

Чтобы проставить угловой размер с обрывом, вызовите команду Угловой размер с обрывом.

Укажите объект, от которого требуется проставить размер (первую сторону угла), и ось симметрии размера (она указывается так же, как вторая сторона угла). Об указании сторон угла см. раздел 3.3.4.1.1.

В качестве оси может быть указана вспомогательная прямая.

На Панели свойств отображаются координаты вершины угла, точек т1 и т2.

При необходимости отредактируйте размерную надпись (см. раздел 3.3.1.3), выберите способ размещения размерной надписи (см. раздел 3.3.1.5) и настройте параметры отрисовки размера (см. раздел 3.3.1.2).

Задайте точку т3, определяющую положение размерной линии и ее длину.

Если выбрано размещение размерной надписи на полке, задайте точку начала полки т4. Линия-выноска будет начинаться от середины размерной линии.

Рис. 3.3.44. Простановка углового размера с обрывом;
способ задания сторон угла — по двум отрезкам


3.3.4.7. Особенности редактирования углового размера с помощью мыши

3.3.4.7. Особенности редактирования углового размера
с помощью мыши

Редактировать угловой размер можно, изменяя положение его характерных точек мышью в окне документа.

Рис. 3.3.45. Редактирование углового размера с помощью мыши
а) | б) | в) | г)

Подробно о редактировании при помощи характерных точек рассказано в разделе 3.5.1.1.3.

Угловой размер имеет несколько характерных точек. Количество и расположение характерных точек зависит от способа размещения надписи (см. рис. 3.3.45).

1 — точка для изменения положения вершины угла;

2, 3 — точки для изменения положения сторон угла и точек привязки выносных линий, (рис. а);

4, 5 — точки для смещения размерной линии, (рис. б);

6 — точка для перемещения надписи при ручном способе размещения; точка для перемещения выноски при способе размещения надписи на полке (см. табл. 3.3.1), (рис. в);

7 — точка для перемещения полки, (рис. г);

8 — точка для смены направления полки.


3.3.5. Авторазмеры

3.3. Размеры и обозначения

3.3.5. Авторазмеры

Размеры часто применяемых типов (простые линейные, угловые, радиальные и некоторые другие) удобно создавать с помощью команды автоматической простановки размеров.

Для вызова команды служит кнопка Авторазмер на инструментальной панели Размеры.

После вызова команды необходимо указать объекты для простановки размера: кривые или точки. В зависимости от того, какие объекты указаны, система автоматически определит тип создаваемого размера. Таким образом, для получения размеров каждого типа не нужно вызывать специальную команду — достаточно указать необходимые объекты.

Правила указания объектов при работе с командой Авторазмер:

– если при указании объекта в «ловушку» курсора попала характерная точка этого объекта, то считается, что указана точка, а не объект,

– если при указании объекта в «ловушку» курсора не попала ни одна характерная точка этого объекта, то считается, что указан объект, т.е. кривая,

– если в «ловушку» попали несколько объектов, то указанным считается объект (точка или кривая), ближайший к центру ловушки,

– при использовании привязок Ближайшая точка, Середина или Пересечение указанной считается точка, а не кривая, которой она принадлежит.

Чтобы настроить размер «ловушки» курсора, воспользуйтесь командой Сервис — Параметры... — Система — Графический редактор — Курсор.

Таким образом, для простановки линейного размера нужно указать отрезок или две точки, между которыми требуется проставить размер, для простановки углового размера — два непараллельных отрезка и так далее. Подробнее указание объектов для простановки размера того или иного типа описано в следующих разделах.

При необходимости отредактируйте размерную надпись (см. раздел 3.3.1.3) и настройте параметры отрисовки размера (см. раздел 3.3.1.2).

Способы управления размерной линией и размещением надписи авторазмера такие же, как у размеров, создаваемых при помощи специальных команд (см. раздел 3.3.1.5).

Дополнительной возможностью авторазмеров является фиксация положения размерной линии при нажатой клавише <Shift> (кроме линейного авторазмера с обрывом, углового авторазмера с обрывом и радиального авторазмера).

Процесс редактирования авторазмера запускается обычным образом — двойным щелчком мыши по его изображению.

Редактирование размеров, полученных с помощью команды Авторазмер, ничем не отличается от редактирования размеров, полученных с помощью специальных команд.

В этом разделе:

3.3.5.1. Линейный авторазмер

3.3.5.2. Линейный авторазмер от отрезка до точки

3.3.5.3. Линейный авторазмер с обрывом

3.3.5.4. Угловой авторазмер

3.3.5.5. Угловой авторазмер с обрывом

3.3.5.6. Радиальный авторазмер

3.3.5.7. Диаметральный авторазмер


3.3.5.1. Линейный авторазмер

Для создания линейного авторазмера укажите точки и/или объекты в документе. Подробнее об указании объектов для простановки размеров рассказано в разделе 3.3.2.1.1.

На экране появится фантом линейного размера.

Перемещая курсор, выберите ориентацию размера — горизонтальный, вертикальный или параллельный объекту.

В списке Размещение текста отображается текущее размещение размерной надписи. При необходимости смените способ размещения (см. раздел 3.3.1.5).

Укажите точку, определяющую положение размерной линии и надписи.

Линейный авторазмер предлагается системой по умолчанию после вызова команды Авторазмер и указания отрезка. Если требуется проставить не простой линейный размер, а, например, линейный размер от отрезка до точки или угловой размер, то продолжайте указание объектов. Система перейдет в режим построения размера, соответствующего указанным объектам.


3.3.5.2. Линейный авторазмер от отрезка до точки

Для создания линейного авторазмера от отрезка до точки укажите отрезок и точку, или два параллельных отрезка, или отрезок и окружность (дугу окружности).

Если один из указанных отрезков имеет системный стиль Осевая или является системным объектом осевая линия (см. раздел 3.3.7.15), то тип размера автоматически определяется как Простой линейный с обрывом. Таким образом, если требуется проставить линейный авторазмер от отрезка до точки, необходимо обращать внимание на стиль линии выбираемых отрезков и тип выбираемых объектов.

На экране появится фантом линейного размера.

Укажите точку, определяющую положение размерной линии и надписи.

Способы управления размерной линией и размещением размерной надписи описаны в разделе 3.3.1.5.


3.3.5.3. Линейный авторазмер с обрывом

Для создания линейного авторазмера с обрывом укажите в любой последовательности два параллельных отрезка, один из которых имеет системный стиль линии Осевая или является объектом осевая линия (см. раздел 3.3.7.15).

На экране появится фантом линейного размера с обрывом.

Укажите точку, определяющую положение размерной линии и надписи.

Способы управления размерной линией и размещением размерной надписи описаны в разделе 3.3.1.5.


3.3.5.4. Угловой авторазмер

Для создания углового авторазмера укажите два непараллельных прямолинейных объекта. Можно использовать следующие объекты:

– отрезок (в том числе звено ломаной или сторона многоугольника),

– объект типа осевая линия,

– вспомогательная прямая,

– ось абсолютной системы координат или системы координат вида.

Если один из указанных объектов является отрезком с системным стилем Осевая или объектом типа осевая линия (см. раздел 3.3.7.15), то тип размера автоматически определяется как Угловой с обрывом. Таким образом, если требуется проставить простой угловой размер, необходимо обращать внимание на стиль линии выбираемых отрезков и тип выбираемых объектов.

На экране появится фантом углового размера.

Перемещая курсор, выберите тип размера — на острый угол, на тупой угол или на угол больше 180°.

Укажите точку, определяющую положение размерной линии и надписи.

Способы управления размерной линией и размещением размерной надписи описаны в разделе 3.3.1.5.


3.3.5.5. Угловой авторазмер с обрывом

Для создания углового авторазмера с обрывом укажите в любой последовательности два непараллельных прямолинейных объекта. Можно использовать следующие объекты:

– отрезок (в том числе звено ломаной или сторона многоугольника),

– объект типа осевая линия,

– вспомогательная прямая,

– ось абсолютной системы координат или системы координат вида.

Один из указанных объектов должен быть отрезком с системным стилем линии Осевая или объектом типа осевая линия (см. раздел 3.3.7.15).

На экране появится фантом углового размера с обрывом.

Укажите точку, определяющую положение размерной линии и надписи.

Способы управления размерной линией и размещением размерной надписи описаны в разделе 3.3.1.5.


3.3.5.6. Радиальный авторазмер

Для создания радиального авторазмера укажите дугу окружности.

На экране появится фантом радиального размера.

Группа переключателей Тип на вкладке Размер позволяет указать, требуется ли проставить радиальный размер от центра или не от центра окружности.

Группа переключателей Размер позволяет указать, требуется ли проставить диаметральный или радиальный размер. При выборе диаметрального размера система переключается в режим создания этого размера (см. следующий раздел).

Укажите точку, определяющую положение размерной линии и надписи.

Способы управления размерной линией и размещением размерной надписи описаны в разделе 3.3.1.5.


3.3.5.7. Диаметральный авторазмер

Для создания диаметрального авторазмера укажите окружность.

На экране появится фантом диаметрального размера.

Размерная линия может быть полная или с обрывом. Для выбора нужного варианта воспользуйтесь группой переключателей Тип на вкладке Размер.

Группа переключателей Размер позволяет указать, требуется ли проставить диаметральный или радиальный размер. При выборе радиального размера система переключается в режим создания этого размера (см. предыдущий раздел).

При создании диаметрального авторазмера может быть построен линейный размер со знаком «диаметр» (рис. 3.3.46, а) или собственно диаметральный размер (рис. 3.3.46, б). Для простановки линейного размера необходимо перемещать курсор в направлениях осей системы координат текущего вида чертежа (для фрагмента — в направлениях осей абсолютной системы координат, т.е. вертикально или горизонтально), а для простановки диаметрального размера — под углом к этим осям.

Рис. 3.3.46. Размер окружности: а) линейный, б) диаметральный
а) | б)

При простановке диаметрального размера дуги создание линейного размера невозможно.

Укажите точку, определяющую положение размерной линии и надписи.

Способы управления размерной линией и размещением размерной надписи описаны в разделе 3.3.1.5.


3.3.6. Размер высоты

3.3. Размеры и обозначения

3.3.6. Размер высоты

Чтобы построить размер высоты, вызовите команду Размер высоты.

На Панели свойств находится раскрывающийся список Тип, с помощью которого можно выбрать размер нужного назначения. Возможные типы размеров представлены на рис. 3.3.47.

Рис. 3.3.47. Размер высоты: а) для вида спереди или разреза, б) для вида сверху с линией-выноской, в) для вида сверху непосредственно на изображении
а) | б) | в)

В этом разделе:

3.3.6.1. Для вида спереди или разреза

3.3.6.2. Для вида сверху с линией-выноской и для вида сверху непосредственно на изображении


3.3.6.1. Для вида спереди или разреза

Задайте точку т0, от которой нужно отсчитывать значения высот (точку нулевого уровня).

Задайте точку привязки т1, определяющую положение образмериваемого уровня.

Система автоматически рассчитывает значение высоты указанной точки относительно точки т0 (расчет производится в метрах с точностью до одной десятой).

Вы можете отредактировать автоматически установленное значение, а также настроить параметры надписи. Для этого щелкните мышью в поле Текст на Панели свойств. На экране появится диалог задания надписи (рис. 3.3.48).

Элементы управления этого диалога представлены в таблице 3.3.10.

Рис. 3.3.48. Диалог задания надписи для размера высоты

Табл. 3.3.10. Диалог задания надписи для размера высоты
Элемент | Описание
Значение | В этом поле отображается автоматически вычисленное системой значение размера. При необходимости вы можете ввести другое значение вручную. Для выбора значения из пользовательского меню нажмите кнопку Значение.
Авто | Эта опция управляет способом определения значения размера. Если опция включена, значение размера определяется автоматически. Если значение было введено вручную, опция автоматически выключается. Чтобы восстановить автоматически определенное значение, вновь включите опцию Авто.
Размер в рамке | Опция, позволяющая отрисовать рамку вокруг значения размера.
Подчеркнуть | Опция, позволяющая подчеркнуть значение размера.
Использовать по умолчанию | Если эта опция включена, то все текущие настройки будут использоваться при создании следующих размеров данного типа до конца сеанса работы. Если опция выключена, то настройка распространяется только на текущий (создаваемый) размер.

В процессе формирования и настройки параметров размерной надписи ее текущий внешний вид отображается в диалоге в специальном поле просмотра.

Затем задайте точку т2, определяющую положение надписи.

Задайте точки т1 и т2 для других уровней, высота которых должна быть проставлена от этой же нулевой точки.

Чтобы перейти к созданию группы размеров высоты от другого нулевого уровня, расфиксируйте точку, от которой производился отсчет (поле т0 на Панели свойств), и задайте ее новое положение.


3.3.6.2. Для вида сверху с линией-выноской и для вида сверху непосредственно на изображении

3.3.6.2. Для вида сверху с линией-выноской
и для вида сверху непосредственно на изображении

При простановке размера высоты на виде сверху возможен только ручной ввод текста. Вызов диалога задания надписи и работа с ним описаны в предыдущем разделе.

Для формирования размера высоты с линией-выноской задайте точку т1, определяющую образмериваемый уровень (в ней будет начинаться линия-выноска), а затем точку, определяющую положение размерной надписи т2.

Для формирования размера высоты непосредственно на изображении задайте точку, определяющую положение размерной надписи т2.


3.3.7. Обозначения для машиностроения

3.3. Размеры и обозначения

3.3.7. Обозначения для машиностроения

В этом разделе:

3.3.7.1. Общие сведения

3.3.7.2. Настройка обозначений для машиностроения в текущем и новых документах

3.3.7.3. Шероховатость

3.3.7.3.1. Ввод надписи обозначения шероховатости

3.3.7.3.2. Настройка отрисовки знака шероховатости

3.3.7.3.3. Управление расположением знака шероховатости

3.3.7.4. Линия-выноска

3.3.7.4.1. Ввод надписи на линии-выноске

3.3.7.4.2. Настройка отрисовки линии-выноски

3.3.7.4.3. Изменение конфигурации линии-выноски

3.3.7.4.4. Изменение положения значка

3.3.7.5. Обозначение клеймения

3.3.7.5.1. Ввод надписи обозначения клеймения

3.3.7.5.2. Настройка отрисовки обозначения клеймения

3.3.7.6. Обозначение маркировки

3.3.7.7. Обозначение позиции

3.3.7.7.1. Ввод надписи обозначения позиции

3.3.7.7.2. Настройка отрисовки обозначения позиции

3.3.7.7.3. Выравнивание позиций

3.3.7.8. Обозначение изменения

3.3.7.8.1. Ввод надписи обозначения изменения

3.3.7.8.2. Настройка отрисовки обозначения изменения

3.3.7.9. Стрелка направления взгляда

3.3.7.9.1. Формирование текста обозначения

3.3.7.10. Линия разреза/сечения

3.3.7.10.1. Построение линии сложного разреза

3.3.7.11. Выносной элемент

3.3.7.11.1. Настройка отрисовки обозначения выносного элемента

3.3.7.12. База

3.3.7.12.1. Ввод надписи обозначения базы

3.3.7.13. Допуск формы

3.3.7.13.1. Формирование таблицы допуска

3.3.7.13.2. Создание ответвлений

3.3.7.14. Обозначение центра

3.3.7.14.1. Настройка отрисовки обозначения центра

3.3.7.15. Осевая линия

3.3.7.16. Автоосевая

3.3.7.16.1. Автоосевая по двум точкам

3.3.7.16.2. Построение автоосевой способом По объектам

3.3.7.16.3. Построение автоосевой способом C указанием границы

3.3.7.16.4. Автоосевая-обозначение центра

3.3.7.16.5. Пример использования автоосевой

3.3.7.17. Волнистая линия

3.3.7.17.1. Настройка параметров волнистой линии

3.3.7.17.2. Способы построения волнистой линии

3.3.7.17.3. Особенности редактирования волнистой линии

3.3.7.18. Линия с изломами

3.3.7.18.1. Настройка параметров линии с изломами

3.3.7.18.2. Смещение изломов

3.3.7.19. Условное пересечение

3.3.7.19.1. Настройка параметров условного пересечения


3.3.7.1. Общие сведения

Команды простановки обозначений для документов, оформляемых в соответствии с машиностроительными стандартами, сгруппированы в меню Инструменты — Обозначения, а кнопки для вызова команд — на панели Обозначения (рис. 3.3.49).

Рис. 3.3.49. Панель Обозначения


3.3.7.2. Настройка обозначений для машиностроения в текущем и новых документах

3.3.7.2. Настройка обозначений для машиностроения
в текущем и новых документах

Оформление чертежа заметно ускоряется, если основной набор параметров обозначений используется как умолчательный: при создании очередного обозначения требуется лишь небольшая его корректировка.

В КОМПАС-3D установлены такие умолчательные значения параметров обозначений, которые наиболее часто используются в конструкторской документации.

Чтобы изменить умолчательные параметры обозначений в текущем документе, вызовите команду Сервис — Параметры... — Текущий чертеж (фрагмент).

Настройка обозначений производится в следующих разделах и подразделах, находящихся в левой части диалога:

– Линии

• Осевая линия,

– Линии обрыва,

– Линия-выноска,

– Условное пересечение,

– Обозначения для машиностроения:

• Обозначение позиции,

• Шероховатость,

• Отклонения формы и база,

• Линия разреза/сечения,

• Стрелка взгляда,

• Автосортировка,

• Обозначение изменения,

– Перекрывающиеся объекты.

Эти разделы содержат элементы управления, позволяющие установить параметры обозначений текущего документа; в некоторых разделах элементы управления сгруппированы в подразделы.

Произведенная настройка сохраняется в текущем документе и не изменяется при передаче его на другое рабочее место.

Все настройки раздела Линия-выноска, кроме настройки фильтра стрелок, распространяются также на обозначения клеймения и маркировки. Фильтр стрелок действует только для линии-выноски.

Длина и зачернение стрелок в составе допуска формы и расположения подчиняются настройке, сделанной для размеров (в разделе Размеры диалога настройки, см. раздел 9.2.6.10.4).

При настройке высоты шрифта и размеров знаков (диаметра окружности, стороны квадрата и знака обозначения изменения) следите за их соразмерностью.

Если в большинстве документов используются одинаковые параметры обозначений, то можно сделать так, чтобы каждый новый документ по умолчанию создавался с необходимыми настройками.

Для этого вызовите команду Сервис — Параметры... — Новые документы — Графический документ. В левой части появившегося диалога находятся те же разделы с теми же наборами настраиваемых параметров обозначений для новых документов, что и для текущего документа.


3.3.7.3. Шероховатость

Чтобы создать обозначение шероховатости поверхности, вызовите команду Шероховатость.

Укажите объект для нанесения обозначения шероховатости (контур детали, выносную линию размера и т.п.).

По умолчанию формируется обозначение шероховатости поверхности, способ обработки которой не устанавливается. При этом в группе Тип на вкладке Знак Панели свойств активен переключатель Без указания вида обработки. Для создания обозначения шероховатости поверхности, образованной с удалением или без удаления слоя материала, активизируйте соответствующий переключатель в указанной группе.

Введите текст обозначения и настройте его отрисовку.

Задайте точку т, определяющую положение знака.

Если точка т указана вне объекта, то положение знака будет определяться проекцией заданной точки на объект или его продолжение. В последнем случае объект автоматически будет продолжен на нужное расстояние тонкой линией (рис. 3.3.50).

Рис. 3.3.50. Простановка обозначения шероховатости на продолжении объекта

Продление NURBS и кривых Безье невозможно.

Для точного позиционирования курсора воспользуйтесь привязками (см. раздел 3.1.1).

Если выбрано размещение обозначения шероховатости на полке (см. табл. 3.3.11), то точка т определяет начало линии-выноски. В этом случае для определения положения знака необходимо задать точку начала полки т1 (рис. 3.3.51, б).

Рис. 3.3.51. Простановка обозначения шероховатости: а) без полки, б) на полке
а) | б)

Структура обозначения шероховатости определяется ГОСТ 2.309–73 (рис. 3.3.52).

Рис. 3.3.52. Структура обозначения шероховатости: а) соответствующая предыдущей редакции ГОСТ 2.309–73, б) соответствующая изменению №3, 2003 в ГОСТ 2.309–73
а) | б)

Выбор структуры, используемой в текущем документе, производится в разделе Шероховатость диалога настройки текущего документа (см. раздел 3.3.7.2). По умолчанию в новых документах создаются обозначения шероховатости в соответствии с изменением в ГОСТ 2.309–73.

Не выходя из команды, вы можете создать несколько обозначений шероховатости. При этом выбранный тип знака и сформированная надпись сохраняются.

К созданному обозначению шероховатости можно добавить текстовую метку, см. раздел 3.4.1.2.

В этом разделе:

3.3.7.3.1. Ввод надписи обозначения шероховатости

3.3.7.3.2. Настройка отрисовки знака шероховатости

3.3.7.3.3. Управление расположением знака шероховатости


3.3.7.3.1. Ввод надписи обозначения шероховатости

Если в обозначении шероховатости требуется указать только высотный параметр шероховатости (Rа, Rz или Rmаx), вызовите контекстное меню в поле Текст на вкладке Знак (рис. 3.3.53).

Выберите нужный параметр и его значение.

Рис. 3.3.53. Пример выбора обозначения шероховатости из контекстного меню

Если в обозначении шероховатости должны содержаться дополнительные сведения, вызовите диалог ввода надписи обозначения (рис. 3.3.54). Для этого щелкните в поле Текст левой кнопкой мыши. Можно также просто начать ввод текста — диалог автоматически появится на экране.

Рис. 3.3.54. Ввод надписи обозначения шероховатости

В диалоге показано обозначение шероховатости и структура надписи.

Введите нужный текст.

Для ускорения ввода различных частей надписи можно применять пользовательские меню.

Двойной щелчок мышью в любом поле ввода текста в диалоге вызывает соответствующее пользовательское меню.

В первом поле пользовательское меню содержит параметры шероховатости Rа, Rz, Rmаx, Sm, S и их значения, параметр относительной опорной длины tp и уровни сечения профиля, а также значения базовых длин. Во втором поле — названия способов обработки поверхности. В третьем — наименования направлений неровностей. При выборе любого из наименований («Произвольное», «Радиальное» и т.д.) в обозначении шероховатости размещается соответствующее условное обозначение.

При необходимости измените умолчательные параметры текста (размер, цвет символов и т.п.) с помощью элементов управления на вкладках Панели свойств.

Если параметры текста у всех обозначений шероховатости в документе отличаются от текущих умолчательных параметров, то рекомендуется не настраивать каждую надпись в отдельности, а установить требуемые параметры в качестве умолчательных. Для этого служит раздел Шероховатость диалога настройки текущего документа.

Завершив ввод и форматирование текстов в полях, нажмите кнопку OK диалога.


3.3.7.3.2. Настройка отрисовки знака шероховатости

Чтобы изменить отрисовку обозначения шероховатости поверхности, активизируйте вкладку Параметры Панели свойств. Расположенные на ней элементы управления рассмотрены в таблице 3.3.11.

Табл. 3.3.11. Элементы управления отрисовкой знака шероховатости
Элемент | Описание
По контуру | Переключатель, позволяющий нанести обозначение шероховатости поверхности, образующей контур.
Полка | Список, управляющий расположением знака. Доступны варианты: Без полки, Влево, Вправо, Вверх, Вниз.
Параметры выноски | При создании обозначения шероховатости, расположенного на полке, в поле Длина отображается длина линии-выноски, а в поле Угол — угол ее наклона к оси абсцисс текущей системы координат. Ввод значений с клавиатуры в эти поля возможен при отключенном автосоздании объектов (см. раздел 1.4.2.10) и только после того, как обозначение сформировано (указана точка начала полки), т.е. фактически с помощью этих полей производится редактирование созданной линии-выноски.
Стрелка | Список, позволяющий выбрать вид стрелки линии-выноски. Список доступен, если обозначение шероховатости размещается на полке.


3.3.7.3.3. Управление расположением знака шероховатости

Знак шероховатости может быть расположен непосредственно на размерной линии или на полке. Варианты размещения знака содержатся в списке Полка на вкладке Параметры Панели свойств. Выберите нужный вариант из этого списка. При этом первоначальное положение знака шероховатости будет соответствовать выбранному варианту.

При создании обозначения шероховатости вы можете изменять положение знака одним из следующих способов.

– Выбор из списка другого варианта размещения знака шероховатости.

– Перемещение курсора вправо, влево, вверх или вниз после определения точки начала линии-выноски. Данный способ используется в случае выбора одного из вариантов размещения знака шероховатости на полке. Он позволяет изменить направление полки на противоположное. Для горизонтального расположения полки используется перемещение курсора вправо/влево, для вертикального — вверх/вниз.

– Использование клавиши <Ctrl> и колеса мыши.

Если выбран вариант размещения знака шероховатости на размерной линии (без полки), при нажатии и удержании клавиши <Ctrl> появляется линия-выноска и горизонтальная полка. Перемещая курсор, вы можете задать начало полки и ее направление — вправо или влево.

Чтобы повернуть полку, при нажатой клавише <Ctrl> вращайте колесо мыши «к себе» или «от себя». В первом случае полка поворачивается по часовой стрелке, во втором — против часовой стрелки.

– Включение/отключение создания знака шероховатости на полке с помощью команды Знак на полке контекстного меню.


3.3.7.4. Линия-выноска

Чтобы создать произвольную линию-выноску, вызовите команду Линия-выноска.

Задайте начальную точку первого ответвления линии-выноски.

Задайте точку начала полки т1.

Затем задайте начальные точки остальных ответвлений. Их количество не ограничено.

Введите надпись на линии-выноске и настройте ее отрисовку.

На экране отображается фантом создаваемой линии-выноски. Вы можете отредактировать или удалить любое из ответвлений создаваемой линии-выноски, не выходя из команды (см. раздел 3.3.7.4.3).

Чтобы зафиксировать изображение, нажмите кнопку Создать объект.

Рис. 3.3.55. Пример простановки линий-выносок

В этом разделе:

3.3.7.4.1. Ввод надписи на линии-выноске

3.3.7.4.2. Настройка отрисовки линии-выноски

3.3.7.4.3. Изменение конфигурации линии-выноски

3.3.7.4.4. Изменение положения значка


3.3.7.4.1. Ввод надписи на линии-выноске

Иногда надпись состоит только из прописной буквы русского алфавита, расположенной на полке линии-выноски. В этом случае вызовите контекстное меню в поле Текст на вкладке Знак Панели свойств и выберите из него нужный символ.

Если требуется ввести более сложную надпись, вызовите диалог ввода текста (рис. 3.3.56). Для этого щелкните левой кнопкой мыши в поле Текст на вкладке Знак Панели свойств. Можно также просто начать ввод текста — диалог автоматически появится на экране.

Рис. 3.3.56. Диалог ввода текста на линии-выноске

В диалоге показана структура надписи на линии-выноске.

Введите нужный текст.

Двойной щелчок мышью в первом поле ввода текста в диалоге вызывает пользовательское меню, содержащее прописные буквы русского алфавита.

Двойной щелчок в остальных полях позволяет перейти к вставке текстового шаблона (см. раздел 4.1.2.11.6).

При необходимости измените умолчательные параметры текста (размер, цвет символов и т.п.) с помощью элементов управления на вкладках Панели свойств.

Если параметры текста на всех линиях-выносках в документе отличаются от текущих умолчательных параметров, то рекомендуется не настраивать каждую надпись в отдельности, а установить требуемые параметры в качестве умолчательных. Для этого служат подразделы Текст над/под/за полкой и Наклонный текст в разделе Линия-выноска диалога настройки текущего документа.

Завершив ввод и форматирование текстов в полях, нажмите кнопку OK диалога.


3.3.7.4.2. Настройка отрисовки линии-выноски

Чтобы изменить отрисовку линии-выноски, активизируйте вкладку Параметры Панели свойств. Расположенные на ней элементы управления рассмотрены в таблице 3.3.12.

Табл. 3.3.12. Элементы управления отрисовкой линии-выноски
Элемент | Описание
Стрелка | Список, позволяющий выбрать вид стрелки линии-выноски. Перечень стрелок, доступных для выбора, а также порядок следования стрелок в списке определяется настройкой фильтра, сделанной в разделе Линия-выноска — Фильтр стрелок диалога настройки текущего документа (см. раздел 3.3.7.2).
Тип | Список, позволяющий выбрать значок для обозначения соединения.
Полка | Элемент управления, позволяющий выбрать расположение полки обозначения. Элемент управления Полка принимает различный вид в зависимости от того, какой переключатель активизирован в группе Ответвления.
 | Если активен переключатель От начала полки или От конца полки, то элемент управления Полка представляет собой раскрывающийся список, позволяющий выбрать направление полки от точки ее начала. Выберите из списка нужное направление отрисовки полки — Влево, Вправо, Вверх или Вниз (рис. 3.3.57).
 | Если активен переключатель Параллельные, то элемент управления Полка представляет собой группу переключателей, позволяющую выбрать положение полки — Горизонтальное или Вертикальное (рис. 3.3.58)1.
Ответвления | Группа переключателей, позволяющая выбрать способ построения ответвлений (рис. 3.3.59). Активизируйте нужный переключатель:
 | От начала полки,
 | От конца полки,
 | Параллельные.
По контуру | Переключатель, позволяющий сформировать обозначение обработки по контуру.
Сохранять текст | Если эта опция включена, то текст, сформированный для текущей линии-выноски, будет использоваться для остальных линий-выносок, созданных за этот вызов команды. Если опция выключена, то каждая следующая линия-выноска формируется без текста.
По умолчанию | Если эта опция включена, то все текущие настройки вкладки Параметры будут использоваться при создании следующих линий-выносок до конца сеанса работы. Если опция выключена, то настройка распространяется только на текущую (создаваемую) линию-выноску.
  1. Поскольку вид элемента управления Полка зависит от того, какой переключатель активен в группе Ответвления, рекомендуется настраивать полку после того, как будет выбран вариант добавления ответвлений.

Рис. 3.3.57. Список направлений полки

Рис. 3.3.58. Переключатели положения полки

Рис. 3.3.59. Ответвления линии-выноски: а) от начала и от конца полки, б) параллельные
а) | б)

Чтобы создать линию-выноску с ответвлениями от начала и от конца полки (рис. 3.3.59, а), выполните следующие действия. Построив необходимое количество ответвлений от начала полки, активизируйте переключатель От конца полки и укажите начальные точки ответвлений.

К ответвлениям, построенным при помощи переключателя Параллельные, невозможно добавить ответвления От начала полки/От конца полки и наоборот.


3.3.7.4.3. Изменение конфигурации линии-выноски

По умолчанию при создании линии-выноски включен режим добавления ответвлений. Об этом свидетельствует нажатая кнопка Добавить ответвления на Панели специального управления. В этом режиме каждая вновь указанная точка воспринимается системой как начальная точка очередного ответвления. Курсор имеет вид перекрестия.

При нажатии кнопки Редактировать точки система переходит в режим редактирования характерных точек объекта. В этом режиме можно внести изменения в конфигурацию обозначения и удалить ответвления, но добавить ответвления нельзя. Характерные точки отображаются в виде черных квадратиков, а объект — в виде фантома. Точки в серединах ответвлений служат для создания изломов (см. рис. 3.3.60).

Подведите курсор к характерной точке объекта. Форма курсора изменится — он превратится в четырехстороннюю стрелку. Нажмите клавишу <Enter> или щелкните левой кнопкой мыши — точка будет выделена.

Редактировать точки объекта можно следующими способами.

– «Перетаскивание» точки мышью.

– Перемещение точки при помощи клавиатуры.
Для этого точка должна быть выделена нажатием клавиши <Enter>.
Переместите курсор при помощи клавиш со стрелками.

– Задание координат характерной точки.
Задайте новые координаты выделенной точки на Панели свойств.

– Удаление характерной точки.

Выделите точку и нажмите клавишу <Delete>. После этого характерная точка исчезнет и объект перестроится в соответствии с положением оставшихся характерных точек.

При удалении начальной точки ответвления удаляется ответвление целиком.

При определении положения точки вы можете использовать привязки (см раздел 3.1.1) и геометрический калькулятор (см раздел 1.4.2.13.1).

Точку на конце полки линии-выноски можно только поворачивать вокруг точки начала полки с шагом 90°.

Рис. 3.3.60. Формирование излома выноски а) и б) перемещение точки в процессе редактирования, в) излом после редактирования
а) | б) | в)

Между режимами добавления ответвлений и редактирования точек можно произвольно переключаться при помощи кнопок Панели специального управления или команд в контекстном меню. При выходе из одного режима автоматически включается другой.


3.3.7.4.4. Изменение положения значка

Изменить положение значка на линии-выноске можно только после ее создания.

Рис. 3.3.61. Изменение положения значка на линии-выноске: а) положение значка по умолчанию, б) значок перемещен вверх по линии-выноске
а) | б)

Чтобы переместить значок, выделите созданную линию-выноску щелчком мыши. Система перейдет в режим редактирования характерных точек. Перемещая характерную точку значка, установите его в нужное положение на линии-выноске.


3.3.7.5. Обозначение клеймения

Чтобы создать линию-выноску для обозначения клеймения, вызовите команду Знак клеймения.

Задайте начальную точку первого ответвления (точку нанесения первого клейма).

Задайте точку т1, определяющую положение знака клеймения.

Затем задайте начальные точки остальных ответвлений.

В поле Текст на Панели свойств отображается предлагаемый системой текст обозначения клеймения. При необходимости вы можете изменить как содержание, так и начертание надписи (см. раздел 3.3.7.5.1).

Кнопка Ссылка позволяет включить в текст обозначения ссылку, например, на пункт технических требований. После ее нажатия на экране появляется диалог создания ссылки (см. рис. 3.4.3 и табл. 3.4.6).

Настройте отрисовку обозначения клеймения.

На экране отображается фантом создаваемого обозначения. Вы можете изменить его конфигурацию, не выходя из команды — так же, как при создании линии-выноски (см. раздел 3.3.7.4.3).

Чтобы зафиксировать изображение, нажмите кнопку Создать объект.

Рис. 3.3.62. Простановка обозначения клеймения

В этом разделе:

3.3.7.5.1. Ввод надписи обозначения клеймения

3.3.7.5.2. Настройка отрисовки обозначения клеймения


3.3.7.5.1. Ввод надписи обозначения клеймения

Ввод надписи производится в специальном диалоге (рис. 3.3.63). Для его вызова щелкните левой кнопкой мыши в поле Текст на вкладке Знак Панели свойств. Можно также просто начать ввод текста — диалог автоматически появится на экране.

Рис. 3.3.63. Диалог ввода текста в обозначении клеймения

В диалоге показана структура надписи обозначения клеймения.

Кнопки со стрелками справа от первого поля ввода текста позволяют «листать» список номеров пунктов техтребований в любом направлении.

Кнопка Ссылка позволяет включить в текст обозначения ссылку, например, на пункт технических требований. После ее нажатия на экране появляется диалог создания ссылки (см. рис. 3.4.3 и табл. 3.4.6).

Двойной щелчок мышью во втором и третьем полях вызывает специальный диалог, в котором можно выбрать содержание клейма и способ его нанесения (в соответствии с рекомендуемым приложением к ГОСТ 2.314–68).

При необходимости измените умолчательные параметры текста (размер, цвет символов и т.п.) с помощью элементов управления на вкладках Панели свойств.

Если параметры текста у всех обозначений клеймения в документе отличаются от текущих умолчательных параметров, то рекомендуется не настраивать каждую надпись в отдельности, а установить требуемые параметры в качестве умолчательных. Для этого служат подразделы Текст над/под/за полкой и Наклонный текст в разделе Линия-выноска диалога настройки текущего документа.

Завершив ввод и форматирование текстов в полях, нажмите кнопку OK диалога.


3.3.7.5.2. Настройка отрисовки обозначения клеймения

Чтобы изменить отрисовку обозначения клеймения, активизируйте вкладку Параметры Панели свойств. Расположенные на ней элементы управления рассмотрены в таблице 3.3.13.

Табл. 3.3.13. Элементы управления отрисовкой обозначения клеймения
Элемент | Описание
Стрелка | Список, позволяющий выбрать вид стрелки обозначения клеймения.
Направление | Группа переключателей, позволяющая выбрать направление отрисовки знака.
По умолчанию | Если эта опция включена, то все текущие настройки вкладки Параметры будут использоваться при создании следующих обозначений клеймения до конца сеанса работы. Если опция выключена, то настройка распространяется только на текущее (создаваемое) обозначение.


3.3.7.6. Обозначение маркировки

Чтобы создать линию-выноску для обозначения маркировки, вызовите команду Знак маркировки.

Задайте начальную точку первого ответвления (первую точку нанесения маркировки).

Задайте точку т1, определяющую положение знака маркировки.

Затем задайте начальные точки остальных ответвлений.

С помощью списка Стрелка на вкладке Параметры можно выбрать тип стрелки линии-выноски. Если этот тип стрелки необходимо использовать в обозначениях маркировки до конца текущего сеанса работы, включите опцию По умолчанию.

В поле Текст на вкладке Знак отображается предлагаемый системой текст обозначения маркировки. Если необходимо, вы можете изменить как содержание, так и начертание надписи. Это делается так же, как и при создании обозначения клеймения (см. раздел 3.3.7.5.1).

Кнопка Ссылка позволяет включить в текст обозначения ссылку, например, на пункт технических требований. После ее нажатия на экране появляется диалог создания ссылки (см. рис. 3.4.3 и табл. 3.4.6).

На экране отображается фантом создаваемого обозначения. Вы можете изменить его конфигурацию, не выходя из команды — так же, как при создании линии-выноски (см. раздел 3.3.7.4.3).

Чтобы зафиксировать изображение, нажмите кнопку Создать объект.

Рис. 3.3.64. Простановка обозначения маркировки


3.3.7.7. Обозначение позиции

Чтобы создать линию-выноску для простановки обозначения позиции, вызовите команду Обозначение позиции.

Задайте начальную точку первого ответвления (первую точку, на которую указывает позиционная линия-выноска).

Задайте точку начала полки т1.

Если создается обозначение позиции без полки (на вкладке Панели свойств Параметры отключена опция Полка), то точка т1 определяет положение конечной точки ответвлений.

Затем задайте начальные точки остальных ответвлений.

В поле Текст на вкладке Знак Панели свойств отображается предлагаемая системой надпись — номер позиции. Если необходимо, вы можете изменить номер и его начертание, а также создать дополнительные полки с номерами позиций (см. раздел 3.3.7.7.1).

Настройте отрисовку позиционной линии-выноски.

На экране отображается фантом создаваемого обозначения. Вы можете изменить его конфигурацию, не выходя из команды — так же, как при создании линии-выноски (см. раздел 3.3.7.4.3).

Чтобы зафиксировать изображение, нажмите кнопку Создать объект.

Рис. 3.3.65. Простановка позиционных линий-выносок

В этом разделе:

3.3.7.7.1. Ввод надписи обозначения позиции

3.3.7.7.2. Настройка отрисовки обозначения позиции

3.3.7.7.3. Выравнивание позиций


3.3.7.7.1. Ввод надписи обозначения позиции

Для вызова диалога ввода текста (рис. 3.3.66) щелкните левой кнопкой мыши в поле Текст на вкладке Знак Панели свойств. Можно также просто начать ввод текста — диалог автоматически появится на экране.

Рис. 3.3.66. Диалог ввода текста в обозначении позиции

В диалоге показана структура надписи обозначения позиции.

Кнопки со стрелками справа от поля ввода текста позволяют «листать» список номеров позиций в любом направлении.

Дополнительные полки на позиционной линии-выноске строятся автоматически при вводе каждой новой строки текста. Чтобы создать новую строку, нажмите клавишу <Enter>.

При необходимости измените умолчательные параметры текста (размер, цвет символов и т.п.) с помощью элементов управления на вкладках Панели свойств.

Если параметры текста у всех обозначений позиций в документе отличаются от текущих умолчательных параметров, то рекомендуется не настраивать каждую надпись в отдельности, а установить требуемые параметры в качестве умолчательных. Для этого служит раздел Обозначение позиции — Текст обозн. позиций диалога настройки текущего документа.

Завершив ввод и форматирование текста, нажмите кнопку OK диалога.


3.3.7.7.2. Настройка отрисовки обозначения позиции

Чтобы изменить отрисовку позиционной линии-выноски, активизируйте вкладку Параметры Панели свойств. Расположенные на ней элементы управления рассмотрены в таблице 3.3.14.

Табл. 3.3.14. Элементы управления отрисовкой линии-выноски

Элемент

Описание

Стрелка

Список, позволяющий выбрать вид стрелки позиционной линии-выноски. Перечень стрелок, доступных для выбора, а также порядок следования стрелок в списке определяется настройкой фильтра, сделанной в разделе Обозначение позиции — Фильтр стрелок диалога настройки текущего документа (см. раздел 3.3.7.2).

Направление
полки

Группа переключателей, позволяющая выбрать направление отрисовки полки линии-выноски.

Изменение направления полки имеет смысл, если ее отрисовка включена (активна опция Полка). Исключение — обозначение позиции с типом формы Простой текст: для него смена направления полки при отключенной опции Полка означает изменение положения текста относительно линии-выноски (слева или справа).

Текст вверх/вниз

Группа переключателей, позволяющая выбрать направление добавления номеров позиций.

Изменение направления добавления номеров позиций имеет смысл, если они размещаются вертикально (отключена опция Горизонтально).

Форма позиции

Список, позволяющий выбрать тип формы для обозначения позиции.

Горизонтально

Опция, управляющая расположением обозначения, содержащего несколько номеров позиций. Если опция отключена, то номера располагаются в колонку, а если включена — в строку.

Полка

Опция, управляющая отрисовкой полки позиционной линии-выноски.

Для позиций с типом формы Простой текст полка представляет собой обычную полку линии-выноски, над которой располагается текст. Для остальных типов формы полка — это отрезок, соединяющий текст с линией-выноской (рис. 3.3.67).

По умолчанию

Если эта опция включена, то все текущие настройки вкладки Параметры будут использоваться при создании следующих позиционных линий-выносок до конца сеанса работы.

Если опция выключена, то настройка распространяется только на текущее (создаваемое) обозначение позиции.

Рис. 3.3.67. Обозначения позиций различных форм: а) с полкой, б) без полки
а) | б)


3.3.7.7.3. Выравнивание позиций

Чтобы расположить на одной линии — горизонтальной или вертикальной — начальные точки полок нескольких позиционных линий-выносок, выделите их в документе.

Вызовите нужную команду — Выровнять позиции по горизонтали или Выровнять позиции по вертикали — из меню Инструменты или нажмите нужную кнопку на инструментальной панели Обозначения.

После этого задайте точку, по координате которой — X или Y — требуется выровнять начала полок выбранных линий-выносок. Точку можно указать мышью или ввести ее координаты в поля Базовая точка на Панели свойств.


3.3.7.8. Обозначение изменения

Чтобы создать линию-выноску для обозначения изменения, вызовите команду Знак изменения.

Задайте начальную точку первого ответвления (первую точку, на которую указывает линия-выноска).

Задайте точку т1, определяющую положение знака обозначения изменения.

Затем задайте начальные точки остальных ответвлений.

Нумерация изменений может выполняться различными способами.

По умолчанию предлагаемый системой номер изменения является простым текстом. При этом в списке Нумерация, расположенном на вкладке Знак Панели свойств, выбран вариант Не использовать.

Вы можете задать номер изменения, поместив создаваемое обозначение в одну из групп нумерации. Для этого следует выбрать из списка Нумерация название нужной группы. Данный способ позволяет нумеровать изменения автоматически. Номер каждого изменения является ссылкой на номер обозначения этого изменения в группе нумерации. Автоматическая нумерация объектов подробно описана в разделе 3.10.1

Заданный номер изменения отображается в поле Текст вкладки Знак. При необходимости вы можете добавить текст, расположенный до или после номера, изменить начертание символов, изменить значение номера, если он является простым текстом. Редактирование надписи обозначения изменения описано в разделе 3.3.7.8.1.

Настройте отрисовку обозначения изменения.

На экране отображается фантом создаваемого обозначения. Вы можете изменить его конфигурацию, не выходя из команды — так же, как при создании линии-выноски (см. раздел 3.3.7.4.3).

Чтобы зафиксировать изображение, нажмите кнопку Создать объект.

Рис. 3.3.68. Простановка обозначения изменения

В этом разделе:

3.3.7.8.1. Ввод надписи обозначения изменения

3.3.7.8.2. Настройка отрисовки обозначения изменения


3.3.7.8.1. Ввод надписи обозначения изменения

Для вызова диалога ввода текста (рис. 3.3.69) щелкните левой кнопкой мыши в поле Текст на вкладке Знак Панели свойств. Можно также просто начать ввод текста — диалог автоматически появится на экране.

Рис. 3.3.69. Диалог ввода текста обозначения изменения

Номер изменения может быть задан вручную или автоматически.

Заданный вручную номер является простым текстом и может быть изменен с клавиатуры или с помощью счетчика, расположенного справа от поля ввода текста.

Номер, заданный автоматически, является ссылкой на номер обозначения в группе нумерации. Он недоступен для изменения. Если требуется, вы можете удалить номер-ссылку. При этом обозначение изменения будет удалено из группы нумерации.

Об автоматической нумерации объектов см. раздел 3.10.1.

Кроме номера обозначения изменения надпись может содержать произвольный текст. Вы можете ввести текст с клавиатуры или вставить текстовый шаблон (см. раздел 4.1.2.11.6). Для вставки шаблона следует дважды щелкнуть мышью в поле ввода текста.

При необходимости измените умолчательные параметры текста (размер, цвет символов и т.п.) с помощью элементов управления на вкладках Панели свойств.

Если параметры текста во всех обозначениях изменений в документе отличаются от текущих умолчательных параметров, то рекомендуется не настраивать каждую надпись в отдельности, а установить требуемые параметры в качестве умолчательных. Для этого служит раздел Обозначение изменения — Текст надписи диалога настройки текущего документа.

Завершив ввод и форматирование текста в поле, нажмите кнопку OK диалога.


3.3.7.8.2. Настройка отрисовки обозначения изменения

Чтобы изменить отрисовку обозначения изменения, активизируйте вкладку Параметры Панели свойств. Расположенные на ней элементы управления рассмотрены в таблице 3.3.15.

Табл. 3.3.15. Элементы управления отрисовкой обозначения изменения

Элемент

Описание

Тип

Список, позволяющий выбрать вид знака обозначения изменения.

Высота знака

Поле для ввода или выбора размера знака: стороны квадрата или диаметра окружности1.

Тип выноски

Список, позволяющий выбрать тип выноски.

Если линии-выноски создаваемого обозначения изменения должны быть произвольной длины, выберите вариант Выноска полной длины.

Если необходимо создать обозначение изменения с равными линиями-выносками, выберите вариант Ограниченный отрезок и введите в поле Длина необходимое значение.
  1. Если знак обозначения изменения имеет вид скобок, то поле Высота знака недоступно, так как высота скобок определяется высотой шрифта текста обозначения изменения.


3.3.7.9. Стрелка направления взгляда

Чтобы построить стрелку, указывающую направление взгляда, вызовите команду Стрелка взгляда.

Задайте начальную точку стрелки т1.

Стрелку, расположенную строго вертикально или горизонтально, удобно создавать в режиме ортогонального черчения. Для его включения и выключения служит кнопка Ортогональное черчение на панели Текущее состояние, а также клавиша <F8>. Чтобы временно перейти в режим ортогонального черчения, нажмите и удерживайте клавишу <Shift>.

Рис. 3.3.70. Простановка стрелки направления взгляда

В поле Текст на Панели свойств отображается автоматически сформированный текст обозначения стрелки взгляда. Если необходимо, вы можете изменить как содержание, так и начертание надписи (см. раздел 3.3.7.9.1).

Из списка Стрелка вы можете выбрать вид стрелки. Перечень стрелок, доступных для выбора, а также порядок следования стрелок в списке определяется настройкой фильтра стрелок для текущего документа (см. раздел 9.2.6.10.5).Настройка отрисовки стрелок описана в разделе 9.2.6.13.3.

Задайте точку т2, определяющую направление стрелки.

Стрелка взгляда будет зафиксирована в документе.

Сразу после создания стрелки взгляда автоматически запускается команда создания нового вида (см. раздел 3.3.9.1). После выполнения этой команды в чертеже появится вид, обозначение которого будет ассоциативно связано с созданной стрелкой.

Вы можете отказаться от создания нового вида, нажав кнопку Прервать команду. Однако делать это не рекомендуется, поскольку ручное создание вида и формирование связи между его обозначением и обозначением стрелки займет дополнительное время. Кроме того, размещение вида по стрелке в отдельном виде позволяет быстро изменять масштаб изображения и делает более удобной компоновку чертежа.

При простановке стрелки взгляда может автоматически создаваться гиперссылка, связывающая обозначение с вновь созданным видом (см. раздел 3.3.9.2).

В этом разделе:

3.3.7.9.1. Формирование текста обозначения


3.3.7.9.1. Формирование текста обозначения

Буква для обозначения стрелки может быть введена вручную или задана системой автоматически.

Автоматическое задание буквы выполняется при включенной опции Автосортировка. При этом произвольное изменение буквы невозможно. Чтобы ввести любой символ для обозначения стрелки, отключите опцию Автосортировка. Отключение опции исключает из автосортировки только текущий объект. Если в дальнейшем опция Автосортировка снова включается, то пользовательское обозначение заменяется автоматически созданным. Автосортировка буквенных обозначений описана в разделе 3.10.1.5.

Если в обозначение объекта необходимо включить номер листа или обозначение зоны, где будет располагаться вид с соответствующим изображением, включите опцию Лист или Зона.

Номер листа или обозначение зоны автоматически включаются в обозначение стрелки после создания вида и формирования ассоциативной связи между надписью этого вида и обозначением стрелки (см. раздел 3.3.9.1).

Во фрагментах создание листов и видов невозможно, поэтому опции Лист и Зона недоступны.

Обозначение объекта оформления можно сформировать также в диалоге ввода надписи обозначения (рис. 3.3.71). Для его вызова щелкните левой кнопкой мыши в поле Текст. Можно также просто начать ввод текста — диалог автоматически появится на экране.

Рис. 3.3.71. Диалог ввода надписи обозначения

Первое поле ввода диалога предназначено для буквенного обозначения. Во втором поле можно ввести дополнительные сведения, например, обозначение зоны.

При необходимости измените параметры текста (размер, цвет символов и т.п.) с помощью элементов управления на вкладках Панели свойств.

Завершив ввод и форматирование текстов в полях, нажмите кнопку OK диалога.

Если параметры текста у всех стрелок взгляда в документе отличаются от текущих умолчательных параметров, то рекомендуется не настраивать каждую надпись в отдельности, а установить требуемые параметры в качестве умолчательных. Для этого служит раздел Стрелка взгляда диалога настройки текущего документа.

Если на Панели свойств включена опция Автосортировка, то в диалоге ввода надписи недоступно первое поле, а если включена опция Лист или Зона, то — второе поле. Если включены опции Автосортировка и Лист (или Зона), то недоступно само поле Текст на Панели свойств и вызов диалога ввода надписи невозможен.


3.3.7.10. Линия разреза/сечения

Чтобы создать линию разреза или сечения, вызовите команду Линия разреза/сечения.

Укажите первую и вторую точки линии разреза. При необходимости вы можете задать направление линии разреза. Для этого перед указанием второй точки выберите любой линейный объект (кроме объектов, входящих в состав сложных объектов). В зависимости от направления движения курсора при указании второй точки линия разреза будет параллельна или перпендикулярна выбранному объекту.

Первая и вторая указанные точки считаются начальными — расположенными ближе к контуру детали — точками штрихов, обозначающих линию разреза или сечения. После указания второй точки на экране появляется фантом обозначения линии разреза/сечения.

Если требуется построить линию ступенчатого или ломаного разреза, нажмите кнопку Сложный разрез на Панели специального управления. Построение линии сложного разреза описано в разделе 3.3.7.10.1.

В поле Текст на Панели свойств отображается автоматически сформированный текст обозначения линии разреза. Если необходимо, вы можете изменить как содержание, так и начертание надписи. Это делается так же, как при создании стрелки взгляда (см. раздел 3.3.7.9.1).

Чтобы указать, рядом с какой из стрелок — первой или последней — должен располагаться дополнительный текст, активизируйте соответствующий переключатель в группе Размещение. Если дополнительный текст не используется, состояние переключателей этой группы не имеет значения.

Из списка Стрелка вы можете выбрать вид стрелки. Перечень стрелок, доступных для выбора, а также порядок следования стрелок в списке определяется настройкой фильтра стрелок для текущего документа (см. раздел 9.2.6.10.5). Настройка отрисовки стрелок описана в разделе 9.2.6.13.3.

Вы можете изменить конфигурацию линии разреза/сечения, не выходя из команды. Для этого нажмите кнопку Редактировать точки на Панели специального управления.

Подведите курсор к любой характерной точке (эти точки отображаются в виде черных квадратиков). Форма курсора изменится — он превратится в четырехстороннюю стрелку.

Измените положение характерных точек или удалите ненужные точки, аналогично редактированию ломаной (см. раздел 3.2.9.1.2).

Чтобы выбрать, с какой стороны от линии разреза/сечения должны располагаться стрелки, перемещайте курсор. Когда он пересечет прямую, содержащую линию разреза/сечения, фантом перестроится: стрелки расположатся по другую сторону от линии.

Щелкните левой кнопкой мыши с той стороны от линии, где должны располагаться стрелки.

Линия разреза/сечения будет зафиксирована в документе.

Рис. 3.3.72. Простановка линии разреза

Сразу после создания линии разреза/сечения автоматически запускается команда создания нового вида (см. раздел 3.3.9.1). После выполнения этой команды в чертеже появится вид, обозначение которого будет ассоциативно связано с созданной линией разреза/сечения.

Вы можете отказаться от создания нового вида, нажав кнопку Прервать команду. Однако делать это не рекомендуется, поскольку ручное создание вида и формирование связи между его обозначением и обозначением линии разреза/сечения займет дополнительное время. Кроме того, размещение разреза/сечения в отдельном виде позволяет быстро изменять масштаб изображения и делает более удобной компоновку чертежа.

При простановке линии разреза/сечения может автоматически создаваться гиперссылка, связывающая обозначение с вновь созданным видом (см. раздел 3.3.9.2).

В этом разделе:

3.3.7.10.1. Построение линии сложного разреза


3.3.7.10.1. Построение линии сложного разреза

Для перехода в режим построения линии ступенчатого или ломаного разреза служит кнопка Сложный разрез на Панели специального управления.

Она доступна после указания первой точки линии разреза.

После нажатия этой кнопки каждая последующая указанная точка считается точкой излома линии разреза. Для точного указания пользуйтесь привязками или меню геометрического калькулятора в полях Текущая точка на вкладке Знак Панели свойств. Можно также вводить в эти поля значения с клавиатуры.

Если требуется задать направление сегмента линии разреза, перед указанием конечной точки этого сегмента выберите любой линейный объект (кроме объектов, входящих в состав сложных объектов). В зависимости от направления движения курсора сегмент линии разреза будет расположен параллельно или перпендикулярно выбранному объекту.

После указания очередной точки фантом линии разреза перестраивается (рис. 3.3.73).

Рис. 3.3.73. Создание линии ступенчатого разреза: а) переход в режим построения линии сложного разреза и указание третьей точки (первая и вторая указаны до перехода в этот режим), б), в) указание четвертой точки
а) | б) | в)

Линию разреза, сегменты которой перпендикулярны друг другу (например, при оформлении ступенчатого разреза), удобно создавать в режиме ортогонального черчения. Для его включения и выключения служит кнопка Ортогональное черчение на панели Текущее состояние, а также клавиша <F8>. Чтобы временно перейти в режим ортогонального черчения, нажмите и удерживайте клавишу <Shift>.

Если режим ортогонального черчения отключен, возможно создание линии сечения, сегменты которой наклонены друг к другу под произвольными углами (например, при оформлении ломаного разреза).

Указав последнюю точку линии разреза, отожмите кнопку Сложный разрез. Система вернется в режим построения простого разреза.


3.3.7.11. Выносной элемент

Чтобы создать обозначение выносного элемента, вызовите команду Выносной элемент.

Задайте точку центра контура, ограничивающего выносной элемент.

Задайте размеры контура: для окружности — диаметр или радиус, для прямоугольников — ширину, высоту и радиус скругления.

Настройте отрисовку обозначения выносного элемента.

В поле Текст на Панели свойств отображается автоматически сформированный текст обозначения выносного элемента. Если необходимо, вы можете изменить как содержание, так и начертание надписи. Это делается так же, как при создании стрелки взгляда (см. раздел 3.3.7.9.1).

Задайте точку начала полки т2.

Рис. 3.3.74. Обозначение положения выносного элемента

Сразу после создания выносного элемента автоматически запускается команда создания нового вида (см. раздел 3.3.9.1). После выполнения этой команды в чертеже появится вид, обозначение которого будет ассоциативно связано с созданным обозначением выносного элемента.

Вы можете отказаться от создания нового вида, нажав кнопку Прервать команду. Однако делать это не рекомендуется, поскольку ручное создание вида и формирование связи между его обозначением и обозначением выносного элемента займет дополнительное время. Кроме того, размещение изображения выносного элемента в отдельном виде позволяет быстро изменять масштаб изображения и делает более удобной компоновку чертежа.

При простановке выносного элемента может автоматически создаваться гиперссылка, связывающая обозначение с вновь созданным видом (см. раздел 3.3.9.2).

В этом разделе:

3.3.7.11.1. Настройка отрисовки обозначения выносного элемента


3.3.7.11.1. Настройка отрисовки обозначения выносного элемента

Чтобы изменить отрисовку обозначения выносного элемента, активизируйте вкладку Параметры Панели свойств. Расположенные на ней элементы управления рассмотрены в таблице.

Табл. 3.3.16. Элементы управления отрисовкой выносного элемента
Элемент | Описание
Форма | Список, позволяющий выбрать форму контура, ограничивающего выносной элемент.
Полка | Группа переключателей, позволяющая выбрать направление отрисовки полки линии-выноски.
По умолчанию | Если эта опция включена, то все текущие настройки вкладки Параметры будут использоваться при создании следующих обозначений выносного элемента до конца сеанса работы. Если опция выключена, то настройка распространяется только на текущее (создаваемое) обозначение.


3.3.7.12. База

Чтобы создать обозначение базовой поверхности, вызовите команду База.

Укажите объект, изображающий базовый элемент (контур детали, осевую линию и т.п.).

Задайте точку т1 основания треугольника, обозначающего базу.

Если указанная точка не принадлежат выбранному объекту, то положение знака будет определяться проекцией указанной точки на объект или его продолжение. В последнем случае объект автоматически будет продолжен на нужное расстояние тонкой линией. Для точного позиционирования курсора воспользуйтесь привязками. Например, если базой является ось симметрии, удобно применить привязку Ближайшая точка, чтобы совместить основание треугольника с концом размерной линии. Подробнее о привязках см. раздел 3.1.1.

По умолчанию формируется обозначение базы, перпендикулярное указанному объекту. При этом в группе Тип на Панели свойств активен переключатель Перпендикулярно опорному элементу. Если требуется создать наклонное обозначение, активизируйте переключатель Произвольное расположение.

В поле Текст отображается предлагаемая системой буква для обозначения базы. Если необходимо, вы можете изменить как сам символ, так и его начертание (см. раздел 3.3.7.12.1).

Укажите точку т2, определяющую положение рамки с надписью.

Рис. 3.3.75. Пример простановки обозначения базы

Линия, соединяющая обозначение базы и рамку, начинается в середине стороны рамки, если объект, указанный в качестве базового, отклоняется от вертикали или горизонтали не более чем на 2°. Если уклон больше, то линия начинается в ближайшей вершине рамки.

К созданному обозначению базовой поверхности можно добавить текстовую метку, см. раздел 3.4.1.2.

В этом разделе:

3.3.7.12.1. Ввод надписи обозначения базы


3.3.7.12.1. Ввод надписи обозначения базы

Буква для обозначения базы может быть введена вручную или задана системой автоматически.

Автоматическое задание буквы выполняется при включенной опции Автосортировка. При этом произвольное изменение буквы невозможно. Чтобы ввести любой символ для обозначения базы, отключите опцию Автосортировка. Отключение опции исключает из автосортировки только текущий объект. Если в дальнейшем опция Автосортировка снова включается, то пользовательское обозначение заменяется автоматически созданным. Автосортировка буквенных обозначений описана в разделе 3.10.1.5.

Обозначение базы можно ввести также в диалоге ввода надписи обозначения (рис. 3.3.76). Для его вызова щелкните левой кнопкой мыши в поле Текст. Можно также просто начать ввод текста — диалог автоматически появится на экране.

Рис. 3.3.76. Диалог ввода надписи обозначения базы

При необходимости измените параметры текста (размер, цвет символов и т.п.) с помощью элементов управления на вкладках Панели свойств.

Завершив ввод и форматирование текста, нажмите кнопку OK диалога.

Если параметры текста у всех обозначений баз в документе отличаются от текущих умолчательных параметров, то рекомендуется не настраивать каждую надпись в отдельности, а установить требуемые параметры в качестве умолчательных. Для этого служит раздел Отклонения формы и база диалога настройки текущего документа.

Если на Панели свойств включена опция Автосортировка, то поле Текст на Панели свойств недоступно. Вызов контекстного меню и диалога ввода надписи невозможны.


3.3.7.13. Допуск формы

Чтобы создать обозначение допуска формы и расположения поверхности, вызовите команду Допуск формы.

Задайте точку вставки рамки допуска. По умолчанию в выбранную точку помещается левый нижний угол рамки. При этом в списке Базовая точка на Панели свойств выбран вариант Слева внизу. Чтобы изменить положение рамки относительно точки вставки, разверните указанный список и выберите нужную строку.

Чтобы рамка была расположена вертикально, включите опцию Вертикально на Панели свойств.

Сформируйте таблицу допуска. Способы и порядок ее создания рассмотрены ниже.

Создайте необходимое количество ответвлений со стрелками или треугольниками.

На экране отображается фантом создаваемого обозначения. Вы можете изменить его конфигурацию, не выходя из команды — так же, как при создании линии-выноски (см. раздел 3.3.7.4.3).

Чтобы зафиксировать изображение, нажмите кнопку Создать объект.

Рис. 3.3.77. Простановка допуска расположения поверхностей

К созданному обозначению допуска формы можно добавить текстовую метку, см. раздел 3.4.1.2.

В этом разделе:

3.3.7.13.1. Формирование таблицы допуска

3.3.7.13.2. Создание ответвлений


3.3.7.13.1. Формирование таблицы допуска

Существует два способа формирования таблицы допуска формы и расположения поверхности:

– полуавтоматический,

– ручной.

Чтобы создать таблицу допуска в полуавтоматическом режиме, активизируйте переключатель Таблица на Панели свойств.

На экране появится диалог ввода надписи и выбора параметров обозначения допуска.

Разверните список Знак и выберите обозначение допуска нужного типа.

Введите числовое значение допуска, обозначение первой и второй баз. Для ускорения ввода можно применять пользовательские меню. Двойной щелчок мышью в любом поле ввода текста в диалоге вызывает соответствующее пользовательское меню (рис. 3.3.78).

Рис. 3.3.78. Пользовательское меню при вводе обозначения допуска

Кнопка Ссылка позволяет вставить ссылку на существующее в документе обозначение базы. После нажатия этой кнопки на экране появляется диалог, в котором необходимо настроить параметры ссылки (см. рис. 3.4.3 и табл. 3.4.6).

Завершив формирование таблицы обозначения допуска формы, нажмите кнопку ОК диалога Обозначение допуска.

Система автоматически создаст таблицу для обозначения допуска и заполнит ее выбранными символами и значениями.

Чтобы сформировать таблицу допуска в ручном режиме, щелкните мышью в поле Текст на Панели свойств.

На экране появится диалог ввода текста обозначения допуска формы и расположения.

Он содержит пока только одну ячейку. Чтобы сформировать таблицу нужной структуры, воспользуйтесь элементами управления на вкладке Таблица Панели свойств.

Контекстное меню ячейки содержит команды-аналоги почти всех элементов вкладки Таблица. Используя эти команды, вы можете сформировать и заполнить таблицу, не обращаясь к Панели свойств.

Создайте таблицу нужной структуры.

Введите текст в ячейки созданной таблицы. При этом удобно выбирать значения и символы из пользовательских меню, вызываемых двойным щелчком мыши в ячейке (рис. 3.3.79).

Рис. 3.3.79. Ввод надписи в таблице допуска

Так, пользовательское меню первой ячейки содержит наименования видов допуска. При выборе любого из них («Допуск соосности», «Допуск прямолинейности» и т.д.) в обозначении размещается соответствующее условное обозначение. Пользовательское меню второй ячейки содержит числовые значения допусков, третьей и последующих — прописные буквы русского алфавита для обозначения баз.

При необходимости измените параметры текста в ячейках (размер, цвет символов и т.п.) с помощью элементов управления на вкладках Панели свойств.

Если параметры текста у всех допусков формы и расположения в документе отличаются от текущих умолчательных параметров, то рекомендуется не настраивать каждую надпись в отдельности, а установить требуемые параметры в качестве умолчательных. Для этого служит раздел Отклонения формы и база диалога настройки текущего документа.

Во время формирования таблицы допуска формы в ручном режиме ссылку на имеющееся в документе обозначение базы можно создать с помощью команды Вставка — Ссылка.

Завершив формирование и форматирование таблицы допуска, нажмите кнопку ОК диалога.

Таблица, созданная в полуавтоматическом режиме, может быть в любое время отредактирована в ручном режиме. Например, возможно сочетание полуавтоматического ввода и ручного форматирования текстов в ячейках.


3.3.7.13.2. Создание ответвлений

Чтобы создать ответвление со стрелкой или треугольником, нажмите соответствующую кнопку на Панели специального управления.

На фантоме рамки появятся восемь точек, показывающие возможные места выхода ответвлений.

Щелкните мышью вблизи точки, в которой должно начинаться создаваемое ответвление.

Ответвления, сегменты которых перпендикулярны друг другу, удобно создавать в режиме ортогонального черчения. Для его включения и выключения служит кнопка Ортогональное черчение на панели Текущее состояние, а также клавиша <F8>. Чтобы временно перейти в режим ортогонального черчения, нажмите и удерживайте клавишу <Shift>. Если режим ортогонального черчения отключен, возможно создание ответвлений, сегменты которых наклонены друг к другу под произвольными углами.

Задавайте точки излома ответвления. Для точного указания пользуйтесь привязками.

Чтобы завершить формирование ответвления, отожмите соответствующую кнопку на Панели специального управления.

Для создания следующего ответвления снова нажмите нужную кнопку.


3.3.7.14. Обозначение центра

Чтобы создать обозначение центра, вызовите команду Обозначение центра.

По умолчанию обозначение центра формируется в виде двух пересекающихся осей. При этом в группе Тип на вкладке Обозначение центра Панели свойств активен переключатель Две оси. Чтобы создать условное обозначение центра или одну ось, активизируйте соответствующий переключатель.

Если требуется сформировать обозначение центра осесимметричного объекта (окружности, дуги окружности, эллипса, дуги эллипса, прямоугольника, правильного многоугольника), укажите этот объект.

Если указан эллипс, дуга эллипса, прямоугольник или правильный многоугольник, обозначение центра немедленно фиксируется. Угол наклона обозначения при этом определяется автоматически.

Если указана окружность или ее дуга, то для фиксации обозначения центра необходимо также указать угол его наклона.

Если необходимо построить осевые линии, не принадлежащие ни одному осесимметричному объекту, активизируйте поле Центр или Угол на Панели свойств (для этого следует щелкнуть левой кнопкой мыши по названию поля). Затем задайте положение центральной точки обозначения и угол его наклона.

В результате выполнения команды создается специальный системный макроэлемент — обозначение центра. Оси обозначения центра пересекаются в центре базовой кривой всегда штрихами.

По умолчанию обозначение центра никак не связано с объектом, указанным при его построении, и может редактироваться отдельно.

Создание ассоциативных (связанных с базовой кривой) объектов оформления возможно при использовании параметрического режима. Подробнее об этом режиме и его настройке см. раздел 7.2.1.7.

В этом разделе:

3.3.7.14.1. Настройка отрисовки обозначения центра


3.3.7.14.1. Настройка отрисовки обозначения центра

Чтобы изменить отрисовку обозначения центра, активизируйте вкладку Параметры Панели свойств. Расположенные на ней элементы управления рассмотрены в таблице 3.3.17.

Табл. 3.3.17. Элементы управления отрисовкой обозначения центра

Элемент

Описание

Выступ

Поле для ввода или выбора величины выступов осевых линий за контур.

Пунктир1

Поле для ввода или выбора длины пунктира.

Промежуток1

Поле для ввода или выбора величины расстояния между пунктиром и штрихом.

Автоопределение

Согласно ГОСТ осевые линии должны начинаться и заканчиваться штрихами. Чтобы выполнить это требование, при отрисовке линий производится пропорциональное изменение длин штрихов.

Включите опцию Автоопределение, если при расчете длины штриха полученное значение должно попадать в диапазон, заданный стандартом (5…30 мм).

Штрих

Поле для ввода или выбора максимальной длины штрихов осевых линий. Если значение задано, то требования стандарта не учитываются. Длина штрихов рассчитывается так, чтобы полученная величина не превышала указанного значения.

Поле Штрих доступно при выключенной опции Автоопределение.

“Точка“

Поле для ввода длины штрихов, образующих перекрестие в центре объекта. Данная настройка действует при создании обозначения центра в виде «крестика». Во всех остальных случаях длина центральных штрихов определяется системой автоматически.
  1. Согласно ГОСТ 2.303, общая длина пунктира и двух промежутков должна составлять 3…5 мм.

Длины элементов линий обозначения центра не зависят от масштаба вида, т.е задаются «для бумаги».


3.3.7.15. Осевая линия

Чтобы построить осевую линию, указав две ее точки, вызовите команду Осевая линия по двум точкам.

Укажите первую и вторую точки осевой линии (например, точки пересечения ее с контуром осесимметричной детали, рис. 3.3.80, а). В документе будет создана осевая линия, выступающая за указанные точки (рис. 3.3.80, б).

Обратите внимание на то, что в результате выполнения команды Осевая линия по двум точкам получается объект осевая линия, а не отрезок со стилем Осевая. Работа с объектами этого типа не отличается от работы с объектами остальных типов. Например, с помощью команды Выделить — По типу вы можете выделить в документе все осевые линии.

Рис. 3.3.80. Построение осевой линии по двум точкам: а) указание точек с использованием привязки, б) результат построения
а) | б)

Настройка отрисовки осевой линии производится на вкладке Параметры Панели свойств. Элементы управления вкладки аналогичны элементам одноименной вкладки при построении обозначения центра (см. табл. 3.3.17).


3.3.7.16. Автоосевая

Команда Автоосевая позволяет построить осевую линию, положение и длина которой могут либо автоматически определяться системой в зависимости от указанных объектов чертежа, либо задаваться пользователем.

Для вызова команды нажмите кнопку Автоосевая на инструментальной панели Обозначения.

Укажите объекты для построения автоосевой. Ими могут являться:

– отрезки,

– точки,

– осесимметричные объекты.

Для управления построением автоосевой служат переключатели группы Способ. Переключатель По объектам позволяет построить осевую линию с автоматически определенными длиной и положением, а переключатель С указанием границы — осевую произвольной длины.

Варианты создания автоосевой зависят от типа указанных объектов и от выбранного способа построения.

Параметры автоосевой (длины выступов, пунктиров и промежутков) для всех вариантов настраиваются так же, как при выполнении команды Обозначение центра — на вкладке Параметры Панели свойств (см. табл. 3.3.17). Исключение составляет простановка осевых линий для эллипса (дуги эллипса). В этом случае настроить параметры осевых линий при их создании невозможно — они подчиняются настройке осевых линий для текущего графического документа.

После завершения построения автоосевой система ожидает указания объектов для создания следующей автоосевой.

Процесс редактирования автоосевой запускается обычным образом — двойным щелчком мыши по ее изображению.

Редактирование осевых линий и обозначений центра, полученных с помощью команды Автоосевая, ничем не отличается от работы с такими объектами, полученными при помощи команд Осевая линия по двум точкам и Обозначение центра.

В этом разделе:

3.3.7.16.1. Автоосевая по двум точкам

3.3.7.16.2. Построение автоосевой способом По объектам

3.3.7.16.3. Построение автоосевой способом C указанием границы

3.3.7.16.4. Автоосевая-обозначение центра

3.3.7.16.5. Пример использования автоосевой


3.3.7.16.1. Автоосевая по двум точкам

Построение автоосевой по двум точкам очень похоже на выполнение команды Осевая линия по двум точкам.

Чтобы создать автоосевую по двум точкам, укажите курсором две произвольные точки на чертеже. В документе будет создана осевая линия, выступающая за указанные точки.

При необходимости для указания точек можно использовать привязки или вспомогательные построения.

Состояние переключателей группы Способ при построении автоосевой по двум точкам не имеет значения.


3.3.7.16.2. Построение автоосевой способом По объектам

Чтобы построить осевую линию с автоматически определяемыми длиной и положением, активизируйте переключатель По объектам в группе Способ.

Построение автоосевой относительно отрезка

В любой последовательности укажите объекты для создания автоосевой:

Рис. 3.3.81. Пример построения автоосевой; способ По объектам

а)

б)

– отрезок, затем точку (рис. 3.3.81, а) или

– точку, затем отрезок (рис. 3.3.81, б).

Осевая линия будет зафиксирована. Ее длина автоматически вычисляется как сумма длины отрезка и двух выступов. Положение автоосевой также определяется автоматически. Она располагается на прямой, параллельной указанному отрезку и содержащей указанную точку, симметрично относительно проекции середины отрезка на эту прямую.

Построение автоосевой относительно двух отрезков

Если в качестве объектов для построения автоосевой будут выбраны два отрезка, то построенная линия будет лежать на биссектрисе угла, образованного ими.

Укажите первый отрезок. На экране появится фантом осевой, параллельный этому отрезку. Укажите второй отрезок. Осевая линия будет построена автоматически. Ее положение определяется следующим образом.

1. Местонахождение начальной точки зависит от взаимного расположения выбранных отрезков:

– если отрезки пересекаются, то автоосевая начинается в точке их пересечения (рис. 3.3.82, а),

– если один отрезок пересекается с воображаемым продолжением второго отрезка, то автоосевая начинается в точке пересечения этих линий (рис. 3.3.82, б),

– если отрезки не пересекаются, то автоосевая начинается в точке пересечения биссектрисы угла с воображаемой прямой, проходящей через начала отрезков (рис. 3.3.82, в).

2. Конечная точка — точка пересечения биссектрисы угла с воображаемой прямой, проходящей через концы отрезков.

Рис. 3.3.82. Примеры построения автоосевой
а) | б) | в)

Если отрезки параллельны, то автоосевая будет равноудалена от отрезков. Ее начальная и конечная точки будут находиться на линиях, которые соединяют концы этих отрезков (рис. 3.3.83.)

Рис. 3.3.83. Построение автоосевой относительно параллельных отрезков
а) указание отрезков | б) построенная автоосевая


3.3.7.16.3. Построение автоосевой способом C указанием границы

Чтобы построить автоосевую с произвольной длиной, активизируйте переключатель С указанием границы.

Построение автоосевой относительно отрезка

В этом случае осевая линия может располагаться как параллельно, так и перпендикулярно отрезку.

Укажите отрезок. Укажите первую точку, через которую должна пройти автоосевая. Система будет ожидать указания второй точки, принадлежащей осевой линии. Положение этой точки определит, каким образом осевая будет расположена относительно отрезка — параллельно или перпендикулярно. Перемещайте курсор. На экране будут появляться фантомы осевой линии, параллельные (рис. 3.3.84, а) или перпендикулярные (рис. 3.3.84, в) выбранному отрезку.

Рис. 3.3.84. Пример построения автоосевой; способ С указанием границы
а) | б) | в) | г)

Добившись нужного положения и длины фантома, щелкните мышью. Осевая линия будет зафиксирована (рис. 3.3.84, б, г).

Если при указании второй точки курсор не находится точно на фантоме осевой линии, границей осевой является проекция положения курсора на эту линию.

Для задания второй точки осевой линии можно указать кривую или вспомогательную прямую на чертеже (рис. 3.3.85, а). В этом случае автоосевая будет заканчиваться в точке своего пересечения с выбранной линией (рис. 3.3.85, б).

Рис. 3.3.85. Указание кривой для задания второй точки автоосевой
а) | б)

Построение автоосевой относительно двух отрезков

Чтобы построить автоосевую, произвольно расположенную на прямой, содержащей биссектрису угла, образованного двумя отрезками, выполните следующие действия.

1. Укажите первый и второй отрезки.

2. Укажите начальную и конечную точки автоосевой (рис. 3.3.86, а).

Для задания границ автоосевой можно указывать кривые или вспомогательные прямые на чертеже. Границами осевой будут точки пересечения этих линий с прямой, содержащей биссектрису угла (рис. 3.3.86, б, в).

Рис. 3.3.86. Примеры построения автоосевой
а) | б) | в)

Если при указании точек курсор не находится точно на продолжении биссектрисы, границами осевой являются проекции положений курсора на эту линию.


3.3.7.16.4. Автоосевая-обозначение центра

Чтобы построить обозначение центра, образованное двумя перпендикулярными осевыми линиями, укажите один из осесимметричных объектов:

– окружность,

– эллипс,

– дуга окружности или эллипса.

Состояние переключателей группы Способ при построении обозначения центра не имеет значения.

Правильные многоугольники при построении автоосевой рассматриваются как совокупности отрезков. Поэтому многоугольник невозможно выбрать в качестве объекта для построения обозначения центра.

Если в качестве объекта выбрана окружность или дуга окружности, то на экране появится фантом обозначения центра. При перемещении курсора будет изменяться его угол поворота вокруг центра окружности или дуги. Чтобы зафиксировать обозначение, щелкните мышью. Для точного позиционирования изображения используйте привязки (рис. 3.3.87 а, б).

Если в качестве объекта выбран эллипс или дуга эллипса, то обозначение центра фиксируется автоматически (рис. 3.3.87 в, г). Угол поворота обозначения изменить нельзя, так как осевые линии совпадают с осями эллипса.

Рис. 3.3.87. Построение автоосевой осесимметричных объектов
а) | б) | в) | г)

При работе с командой Автоосевая, в отличие от команды Обозначение центра, тип обозначения изменить невозможно.


3.3.7.16.5. Пример использования автоосевой

Используя команду Автоосевая, вы можете строить изображения осевой линии на чертежах, выполняя минимальное количество действий.

Пример №1: построение осевой на чертеже четырьмя щелчками мыши (рис. 3.3.88). Щелчки 1 и 2 — указание отрезков для построения автоосевой; щелчки 3 и 4 — указание отрезков, которые служат границами автоосевой.

Рис. 3.3.88. Построение автоосевой на чертеже способом С указанием границы:
а) указание объектов для построения автоосевой, б) построенная автоосевая

а)

б)

Пример №2: построение обозначения центра с использованием команды Автоосевая (рис. 3.3.89).

Рис. 3.3.89. Построение обозначения центра на чертеже: а) указание объекта, б) задание положения обозначения центра, в) построенное обозначение
а) | б) | в)


3.3.7.17. Волнистая линия

Чтобы построить волнистую линию обрыва (рис. 3.3.90), вызовите команду Волнистая линия.

Рис. 3.3.90. Пример использования волнистой линии

Волнистая линия представляет собой синусоиду, имеющую целое количество полуволн. Начальная т1 и конечная т2 точки волнистой линии лежат на средней линии синусоиды.

Специфическими параметрами волнистой линии являются следующие (рис. 3.3.91):

– координаты начальной и конечной точек,

– амплитуда,

– длина волны,

– длина средней линии,

– угол между осью Х текущей системы координат и средней линией,

– направление отрисовки.

Рис. 3.3.91. Параметры волнистой линии

Чтобы построить волнистую линию, можно использовать следующие способы.

– Указать положение начальной т1 и конечной т2 точек отрезка средней линии; длина и угол наклона отрезка будут определены автоматически.

– Указать положение начальной точки отрезка средней линии, его длину и угол наклона. Например, вы можете указать курсором положение точки т1, ввести длину в поле на Панели свойств и задать курсором угол наклона отрезка. Положение конечной точки отрезка будет определено автоматически.

После указания точек т1 и т2 в документе создается волнистая линия с умолчательными параметрами.

Во время построения волнистой линии вы можете изменить направление отрисовки волнистой линии с помощью группы переключателей Направление на вкладке Волнистая линия Панели свойств. На вкладке Параметры можно настроить параметры волнистой линии (см. раздел 3.3.7.17.1).

Чтобы быстро построить несколько волнистых линий с одинаковыми параметрами, например, для обозначения разрыва изображения, следует выполнить следующие действия.

1. Задайте значения параметров волнистой линии на вкладке Параметры.

2. Задайте и зафиксируйте значения в полях Угол и Длина, а затем нажмите кнопку Запомнить состояние.

3. Указывайте последовательно начальные точки т1 новых волнистых линий.

Вы можете создать несколько обозначений за один вызов команды Волнистая линия.

Чтобы завершить построение волнистых линий, нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

В этом разделе:

3.3.7.17.1. Настройка параметров волнистой линии

3.3.7.17.2. Способы построения волнистой линии

3.3.7.17.3. Особенности редактирования волнистой линии


3.3.7.17.1. Настройка параметров волнистой линии

Для настройки текущих параметров волнистой линии служат элементы управления вкладки Параметры Панели свойств. Эти элементы представлены в таблице 3.3.18.

Табл. 3.3.18. Элементы управления параметрами волнистой линии

Элемент

Описание

Количество
полуволн,

Длина волны

Переключатели, позволяющие выбрать способ построения волнистой линии.

Чтобы построить линию по количеству полуволн, активизируйте переключатель Количество полуволн и введите количество полуволн в одноименное поле.

Чтобы построить линию по длине волны, активизируйте переключатель Длина волны и введите длину волны в одноименное поле.

Подробнее способы построения волнистой линии рассмотрены в разделе 3.3.7.17.2.

Амплитуда

Поле для ввода или выбора значения амплитуды волны. Амплитуда может задаваться в относительных или абсолютных единицах.

Значение
амплитуды в %

Если активен этот переключатель, то значение, введенное в поле Амплитуда, показывает соотношение между амплитудой и длиной волны1. Если в процессе построения или редактирования изменяются координаты концов волнистой линии, амплитуда изменяется пропорционально длине волны.

Значение
амплитуды в мм

Если активен этот переключатель, то значение, введенное в поле Амплитуда, показывает абсолютное значение расстояния между средней линией и максимально удаленной от нее точкой волны. Если в процессе построения или редактирования изменяются координаты концов волнистой линии, амплитуда не изменяется.

При смене единиц задания амплитуды значение в поле Амплитуда пересчитывается.

Стиль

В этом поле отображается текущий стиль отрисовки волнистой линии. Чтобы изменить стиль, раскройте список и выберите нужную строку. Перечень стилей, доступных для выбора, а также порядок их следования определяются настройкой фильтра линий, сделанной в разделе Линии обрыва — Фильтр линий диалога настройки текущего документа (см. раздел 3.3.7.2).

По умолчанию

Если эта опция включена, то все текущие настройки вкладки Параметры будут использоваться при создании следующих волнистых линий до конца сеанса работы.

Если опция выключена, то настройка распространяется только на текущую (создаваемую) линию. При следующем вызове команды будут использоваться умолчательные настройки.
  1. Текущей либо фактической — в зависимости от способа построения, см. раздел 3.3.7.17.2.

Умолчательные параметры волнистой линии для текущего документа устанавливаются в подразделе Линии обрыва — Волнистая линия диалога настройки текущего документа (см. раздел 3.3.7.2).


3.3.7.17.2. Способы построения волнистой линии

Волнистая линия может быть построена по количеству полуволн и по длине волны. Для выбора способа построения служат переключатели Количество полуволн и Длина волны на вкладке Параметры Панели свойств. Активизация одного из этих переключателей автоматически отменяет активизацию другого.

– При активизации переключателя Количество полуволн становится доступным поле Количество полуволн.

Это поле позволяет ввести или задать при помощи счетчика требуемое количество полуволн волнистой линии. В поле Длина волны будет показано значение текущей длины волны в миллиметрах. Текущая длина волны рассчитывается как частное от деления текущей длины средней линии (расстояния между точками т1 и т2) на количество волн (половину заданного количества полуволн). При изменении положения курсора, соответствующего положению точки т2 (т.е. при изменении текущей длины средней линии) текущая длина волны динамически изменяется, а количество полуволн остается постоянным и равным заданному значению.

– При активизации переключателя Длина волны становится доступным поле Длина волны. Это поле позволяет ввести номинальную длину волны и отображает фактическую длину волны.

Фактическая длина волны — наиболее близкая к номинальной длине волны величина, при которой на текущей длине средней линии размещается целое количество полуволн. Фактическая длина волны определяется следующим образом.

1. Текущая длина средней линии делится на номинальную длину волны — значение, первоначально введенное в поле Длина волны.

2. Частное удваивается — получается количество полуволн.

3. Количество полуволн округляется до целого числа. Полученное значение отображается в поле Количество полуволн.

4. Текущая длина средней линии делится на округленное количество полуволн — получается фактическая длина волны.

При изменении положения курсора, соответствующего положению точки т2 (т.е. при изменении текущей длины средней линии) динамически изменяется как количество полуволн, так и фактическая длина волны. При этом количество полуволн всегда целое, а фактическая длина волны колеблется вблизи номинальной длины волны.

Если в поле Длина волны вводится значение, превышающее удвоенное расстояние между начальной и конечной точками волнистой линии, то длина волны принимается равной удвоенному расстоянию между концами волнистой линии, а количество полуволн принимается равным единице.

До указания точки т1 в полях Количество полуволн и Длина волны отображаются умолчательные значения.


3.3.7.17.3. Особенности редактирования волнистой линии

Редактировать волнистую линию можно, используя элементы управления на Панели свойств, или изменяя положение ее характерных точек мышью в окне документа. Волнистая линия имеет три характерные точки: точка амплитуды, расположенная на первой полуволне, и две точки, расположенные на концах линии (рис. 3.3.92).

Рис. 3.3.92. Характерные точки волнистой линии

При изменении амплитуды волнистой линии путем перемещения точки амплитуды количество полуволн и длина волнистой линии остаются прежними.

При изменении длины волнистой линии путем перемещения мышью характерных точек 1 и 2 могут изменяться следующие параметры:

– отношение амплитуды к длине волны,

– значение амплитуды в миллиметрах,

– количество полуволн.

Изменение параметров зависит от состояния переключателей на Панели свойств.

Отношение амплитуды к длине волны изменяется, если активны переключатели Количество полуволн и Значение амплитуды в мм (рис. 3.3.93).

Рис. 3.3.93. Перемещение характерной точки т2
при активных переключателях Количество полуволн и Значение амплитуды в мм

Значение амплитуды изменяется, если активны переключатели Количество полуволн и Значение амплитуды в % (рис. 3.3.94).

Рис. 3.3.94. Перемещение характерной точки т2
при активных переключателях Количество полуволн и Значение амплитуды в %

Количество полуволн изменяется, если активен переключатель Длина волны. При этом, если активен переключатель Значение амплитуды в %, то сохраняется отношение амплитуды к фактической длине волны (рис. 3.3.95), а если активен переключатель Значение амплитуды в мм, — то абсолютное значение амплитуды.

Рис. 3.3.95. Перемещение характерной точки т2
при активных переключателях Длина волны и Значение амплитуды в %

Если при активном переключателе Длина волны характерные точки 1 и 2 сближаются на расстояние, меньшее половины номинальной длины волны, строится одна полуволна фактической длины (рис. 3.3.96). При этом значение номинальной длины волны сохраняется.

Рис. 3.3.96. Сближение характерных точек на расстояние,
меньшее половины номинальной длины волны

При выполнении операции Масштабирование волнистая линия будет претерпевать те же изменения, что и в процессе редактирования, если соответствующие переключатели находятся в активном состоянии (см. рис. 3.3.93–3.3.96).

Чтобы отредактировать волнистую линию при помощи команд, применяемых для геометрических объектов — Усечь кривую, Разбить кривую и т.п., необходимо преобразовать линию в сплайновую кривую — NURBS (см. раздел 3.5.4.4).


3.3.7.18. Линия с изломами

Чтобы построить линию обрыва с изломами (рис. 3.3.97), вызовите команду Линия с изломами.

Рис. 3.3.97. Пример использования линии с изломами

Линия с изломами представляет собой отрезок с равномерно расположенными изломами.

Изломом называется фрагмент обозначения, имеющий две (Тип 1) или три (Тип 2) вершины.

Амплитудой называется расстояния между линией и максимально удаленной от нее точкой излома.

Рис. 3.3.98. Параметры линии с изломами

Специфическими параметрами линии с изломами являются следующие (рис. 3.3.98):

– координаты начальной (т1) и конечной (т2) точек,

– амплитуда излома,

– длина ломаной,

– выступ,

– промежуток между изломами,

– угол между осью Х текущей системы координат и линией с изломами,

– тип изломов,

– количество изломов,

– смещение изломов от симметричного положения на линии.

Чтобы построить линию с изломами, можно использовать следующие способы.

– Указать положение начальной т1 и конечной т2 точек; длина и угол наклона линии будут определены автоматически.

– Указать положение начальной точки линии с изломами, ее длину и угол наклона. Например, вы можете указать курсором положение точки т1, ввести длину в поле на Панели свойств и задать курсором угол наклона отрезка. Положение конечной точки будет определено автоматически.

В документе будет создана линия с изломами, выходящая за точки т1 и т2 на величину выступа.

Если заданное количество изломов с текущими параметрами не умещается между конечными точками линии, то строится максимально возможное целое число изломов.

Во время построения линии с изломами можно настроить параметры линии с изломами на вкладке Параметры Панели свойств (см. раздел 3.3.7.18.1).

Чтобы быстро построить несколько одинаковых линий с изломами, например, для обозначения разрыва изображения, выполните следующие действия.

1. Не указывая точек т1 и т2, выполните настройки на вкладке Параметры.

2. Задайте и зафиксируйте значения в полях Угол и Длина.

3. Нажмите кнопку Запомнить состояние.

4. Укажите последовательно начальные точки т1 новых линий разрыва.

Вы можете создать несколько обозначений за один вызов команды Линия с изломами.

Чтобы завершить команду, нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

При использовании привязки к линии с изломами в процессе построения других объектов необходимо иметь в виду следующее: привязка Середина позволяет привязаться к середине промежутка, привязка Центр — к середине всей линии.

В этом разделе:

3.3.7.18.1. Настройка параметров линии с изломами

3.3.7.18.2. Смещение изломов


3.3.7.18.1. Настройка параметров линии с изломами

Для настройки параметров линии с изломами служат элементы управления вкладки Параметры Панели свойств. Эти элементы представлены в таблице 3.3.19.

Табл. 3.3.19. Элементы управления параметрами линии с изломами

Элемент

Описание

Выступ

Поле, позволяющее ввести или задать при помощи счетчика значение выступа линии за начальную и конечную точки.

Количество
изломов

Поле, позволяющее ввести или задать при помощи счетчика количество изломов линии. Минимальное количество изломов равно 1.

Амплитуда

Поле, позволяющее ввести или задать при помощи счетчика амплитуду излома. При изменении амплитуды прямо пропорционально изменяется ширина излома.

Смещение

Поле, позволяющее ввести или задать при помощи счетчика смещение изломов (см. раздел 3.3.7.18.2).

Тип излома

Группа переключателей, позволяющая выбрать вариант отрисовки излома: с двумя или тремя вершинами. При изменении типа величина промежутков между изломами не меняется.

Стиль

В этом поле отображается текущий стиль отрисовки линии с изломами. Чтобы изменить стиль, раскройте список и выберите нужную строку. Перечень стилей, доступных для выбора, а также порядок их следования определяются настройкой фильтра линий, сделанной в разделе Линии обрыва — Фильтр линий диалога настройки текущего документа (см. раздел 3.3.7.2).

По умолчанию

Если эта опция включена, то все текущие настройки вкладки Параметры будут использоваться при создании следующих линий с изломами до конца сеанса работы.

Если опция выключена, то настройка распространяется только на текущую (создаваемую) линию. При следующем вызове команды будут использоваться умолчательные настройки.

Умолчательные параметры линии с изломами для текущего документа устанавливаются в подразделе Линии обрыва — Линия с изломами диалога настройки текущего документа (см. раздел 3.3.7.2).


3.3.7.18.2. Смещение изломов

Смещение изломов c равно выраженному в процентах отношению расстояния b, на которое смещены изломы, к величине промежутка между изломами a:

с = (b/a) · 100

– Если расстояние b равно нулю (и, следовательно, смещение с равно нулю), изломы находятся на равном расстоянии друг от друга и от концов линии (рис. 3.3.99, а).

– Если расстояние b не равно нулю (и, следовательно, смещение с не равно нулю), изломы смещены от симметричного положения. Направление смещения зависит от его знака:

• c > 0 — изломы смещаются в направлении конечной точки т2 (рис. 3.3.99, б),

• c < 0 — изломы смещаются в направлении начальной точки т1.

– Если расстояние b равно промежутку между изломами, то есть смещение равно 100% или –100%, граница излома совпадает с конечной (рис. 3.3.99, в) или начальной (рис. 3.3.99, г) точкой.

Рис. 3.3.99. Смещение изломов

а)

б)

в)

г)

Величина выступов линии за начальную и конечную точки (т1 и т2) при смещении изломов не изменяется.


3.3.7.19. Условное пересечение

Условное пересечение — обозначение, представляющее собой пересечение продолжения объекта с другим объектом или его продолжением. Продолжения объектов строятся выносными линиями. На пересечении выносной линии с объектом или другой выносной линией создается точка (рис. 3.3.100).

Вы можете построить условное пересечение следующих объектов (в том числе входящих в макроэлементы и вставки): отрезков, дуг окружностей и эллипсов, а также эквидистант отрезков и дуг окружностей.

Рис. 3.3.100. Условное пересечение: a) для продолжений двух объектов; б) для объекта и продолжения другого объекта
а) | б)

Чтобы построить условное пересечение, вызовите команду Условное пересечение.

Укажите курсором первый, а затем второй объект ближе к той его конечной точке, от которой следует построить его продолжение. Фиксация курсора выполняется нажатием левой кнопки мыши или клавиши <Enter>.

Точки пересечения самих объектов (а не их продолжений) не строятся. Для выполнения команды необходимо, чтобы был продолжен хотя бы один объект из указанной пары.

После указания первого объекта он подсвечивается. При попадании второго объекта в «ловушку» курсора на экране появляется фантом условного пересечения. Это происходит, если для данной пары объектов существует хотя бы один вариант построения.

Если точек пересечения несколько, то для отображения другого варианта фантома подведите курсор, не фиксируя его, ближе к другой конечной точке объекта. После появления фантома в нужной точке зафиксируйте курсор.

Размер «ловушки» курсора можно изменить в диалоге настройки курсора (см. раздел 9.1.7.1).

Условное пересечение усекаемых объектов может быть построено в процессе создания фаски или скругления (см. раздел 3.2.15). Вы также можете использовать команду Условное пересечение при построении объектов, вызывая ее из меню геометрического калькулятора (см. раздел 1.4.2.13.1).

По умолчанию созданное условное пересечение никак не связано с объектами, указанными в ходе выполнения команды, и может редактироваться отдельно.

Создание ассоциативных (связанных с базовыми кривыми) объектов оформления возможно при использовании параметрического режима. Подробнее об этом режиме и его настройке см. раздел 7.2.1.7.

В этом разделе:

3.3.7.19.1. Настройка параметров условного пересечения


3.3.7.19.1. Настройка параметров условного пересечения

Для настройки параметров условного пересечения служат элементы управления Панели свойств.

Чтобы включить или отключить отрисовку выносных линий объекта, используйте переключатели Выносная линия 1 и Выносная линия 2.

Выносная линия может начинаться на некотором расстоянии от конечной точки объекта.

Вы можете зафиксировать как длину выносных линий, так и зазор между объектом и началом выносной линии. Для этого введите или задайте счетчиком нужное значение в поле Зазор или длина, мм. Допускаются только целые значения длины (зазора). При нулевом значении (или значении, превышающем расстояние от объекта до точки т1) выносные линии строятся от конечных точек объектов до точки пересечения (рис. 3.3.100).

Рис. 3.3.101. Отрисовка выносных линий при задании ненулевого значения: a) зазора; б) длины
а) | б)

Если требуется, чтобы заданное число определяло зазор между конечной точкой объекта и началом выносной линии, активизируйте переключатель Зазор (рис. 3.3.101, а).

Если же введенное значение должно определять длину выносной линии, активизируйте переключатель Длина (рис. 3.3.101, б).

Включите опцию Точка, чтобы на пересечении выносных линий создавалась точка. Выберите из раскрывающегося списка стиль ее отрисовки. Если опция выключена, то точка не создается.

Включенная опция По умолчанию означает, что все текущие настройки будут использоваться при создании следующих условных пересечений до конца сеанса работы. При выключенной опции настройка распространяется только на текущее (создаваемое) пересечение.

Умолчательные значения параметров условного пересечения для текущего документа, в том числе величина выхода выносных линий за точку пересечения, устанавливаются в разделе Условное пересечение диалога настройки текущего документа (см. раздел 9.2.6.12).

В режиме редактирования условного пересечения на Панели свойств отображаются координаты точки пересечения выносных линий т1. Изменение координат доступно, если условное пересечение не имеет ассоциативной связи с объектами.


3.3.8. Обозначения для строительства

3.3. Размеры и обозначения

3.3.8. Обозначения для строительства

В этом разделе:

3.3.8.1. Общие сведения

3.3.8.2. Настройка обозначений для строительства в текущем и новых документах

3.3.8.3. Марка/позиционное обозначение без линии-выноски

3.3.8.3.1. Ввод текста марки/позиционного обозначения

3.3.8.3.2. Автонумерация марки/позиционного обозначения

3.3.8.3.3. Параметры марки/позиционного обозначения без линии-выноски

3.3.8.4. Марка/позиционное обозначение с линией-выноской

3.3.8.4.1. Параметры марок/позиционных обозначений с линией-выноской

3.3.8.5. Марка/позиционное обозначение на линии

3.3.8.6. Линия разреза

3.3.8.6.1. Формирование текста обозначения линии разреза

3.3.8.7. Обозначение узла

3.3.8.7.1. Ввод текста обозначения узла и узла в сечении

3.3.8.7.2. Параметры обозначения узла

3.3.8.8. Обозначение узла в сечении

3.3.8.8.1. Параметры обозначения узла в сечении

3.3.8.9. Номер узла

3.3.8.9.1. Ввод текста обозначения номера узла

3.3.8.10. Фигурная скобка

3.3.8.10.1. Ввод текста обозначения фигурной скобки

3.3.8.10.2. Параметры фигурной скобки

3.3.8.10.3. Особенности редактирования фигурной скобки с помощью мыши

3.3.8.11. Выносная надпись

3.3.8.11.1. Ввод текста выносной надписи

3.3.8.11.2. Параметры выносной надписи

3.3.8.12. Прямая координационная ось

3.3.8.12.1. Автопродолжение

3.3.8.12.2. Формирование обозначения

3.3.8.12.3. Параметры отрисовки

3.3.8.12.4. Выступы

3.3.8.12.5. Дополнительные обозначения

3.3.8.12.6. Параметры отрисовки дополнительных обозначений

3.3.8.12.7. Ввод текста дополнительных обозначений

3.3.8.13. Дуговая координационная ось

3.3.8.14. Круговая координационная ось

3.3.8.14.1. Параметры отрисовки

3.3.8.15. Использование команды «Запомнить состояние» для построения осей

3.3.8.15.1. Прямые оси

3.3.8.15.2. Дуговые оси

3.3.8.15.3. Круговые оси


3.3.8.1. Общие сведения

КОМПАС-3D позволяет создавать следующие обозначения, используемые в промышленном строительном проектировании:

– марки/позиционные обозначения (без линии-выноски, с линией-выноской, на линии),

– обозначения линий разреза,

– обозначения узла и узла в сечении,

– номера узлов,

– выносные надписи для многослойных конструкций,

– фигурные скобки для обозначения фрагментов,

– координационные оси (прямые, дуговые, круговые).

Команды простановки обозначений для документов, оформляемых в соответствии со строительными стандартами, сгруппированы в меню Вид — Панели инструментов — Обозначения для строительства, а кнопки для вызова команд — сгруппированы на панели Обозначения для строительства (рис. 3.3.102).

Рис. 3.3.102. Панель Обозначения для строительства


3.3.8.2. Настройка обозначений для строительства в текущем и новых документах

3.3.8.2. Настройка обозначений для строительства
в текущем и новых документах

Оформление чертежа заметно ускоряется, если основной набор параметров обозначений используется как умолчательный: при создании очередного обозначения требуется лишь небольшая его корректировка.

В КОМПАС-3D установлены такие умолчательные значения параметров обозначений, которые наиболее часто используются в конструкторской документации.

Чтобы изменить умолчательные параметры того или иного строительного обозначения в текущем документе, вызовите команду Сервис — Параметры... — Текущий чертеж/фрагмент.

Раскройте раздел Обозначения для строительства в левой части появившегося диалога. Он содержит подразделы, названия которых совпадают с названиями обозначений:

– Марка/позиционное обозначение,

– Линия разреза,

– Обозначение узла и узла в сечении,

– Номер узла,

– Выносная надпись,

– Фигурная скобка,

– Координационные оси.

Каждый подраздел включает группы настроек, позволяющих установить параметры обозначения в текущем документе.

Произведенная настройка сохраняется в текущем документе и не изменяется при передаче его на другое рабочее место.

Если изменение настройки обозначений в текущем документе по каким-либо причинам нежелательно, вы можете установить комбинацию параметров, которая будет использоваться как умолчательная при создании обозначений до конца сеанса работы.

Для этого при создании обозначения каждого типа (кроме марок/позиционных обозначений на линии и номеров узлов) настройте его необходимым образом и включите опцию По умолчанию на вкладке Параметры Панели свойств.

Если в большинстве документов используются одинаковые параметры обозначений, то можно сделать так, чтобы каждый новый документ по умолчанию создавался с необходимыми настройками.

Для этого вызовите команду Сервис — Параметры... — Новые документы — Графический документ. Раскройте раздел Обозначения для строительства в левой части появившегося диалога. Список подразделов и набор настраиваемых параметров размеров для новых документов такой же, как для текущего документа.


3.3.8.3. Марка/позиционное обозначение без линии-выноски

Чтобы создать марку/позиционное обозначение без линии-выноски, вызовите команду Марка/позиционное обозначение без линии-выноски.

После вызова команды на экране появляется фантом обозначения. Точка привязки (т) располагается в центре габаритного прямоугольника.

Введите координаты марки/позиционного обозначения на Панели свойств или укажите точку, определяющую его положение в окне документа.

Чтобы построить повернутое обозначение, введите нужное значение угла поворота текста в поле Угол.

Введите текст надписи обозначения (см. раздел 3.3.8.3.1).

Чтобы при вводе текста производилось автоматическое присвоение свободных номеров элементам, активизируйте переключатель Автонумерация. Подробнее об автонумерации см. раздел 3.3.8.3.2.

Контекстное меню поля Текст содержит все марки, созданные в документе. Чтобы создать марку с уже существующим текстовым обозначением, вы можете выбрать его из этого меню (рис. 3.3.103). В режиме автонумерации ей будет присвоен очередной номер.

Рис. 3.3.103. Контекстное меню поля Текст марки/позиционного обозначения

Если текст, сформированный для текущей (создаваемой) марки/позиционного обозначения, нужно использовать для остальных обозначений, созданных за этот вызов команды, включите опцию Сохранять текст. При выключенной опции каждое следующее обозначение формируется без текста.

Рис. 3.3.104. Марка/позиционное обозначение без линии-выноски а) пример использования, б) типы формы обозначения
а) | б)

Настройте параметры марки/позиционного обозначения на вкладке Параметры Панели свойств (см. раздел 3.3.8.3.3).

Текст надписи может служить источником ссылки другого текстового объекта, находящегося в этом документе. Подробнее о ссылках см. раздел 3.4.1.4.

Кнопка Копировать свойства на Панели специального управления позволяет копировать текст в текущее обозначение из уже существующей марки/позиционного обозначения (этого же или другого типа). При копировании свойств передается также тип формы обозначений.

Чтобы зафиксировать изображение, нажмите кнопку Создать объект на Панели специального управления.

Вы можете создать несколько обозначений за один вызов команды Марка/позиционное обозначение без линии-выноски. Для этого после нажатия кнопки Создать объект укажите новую точку привязки (т).

Фон под обозначением всегда очищается независимо от настроек, сделанных в диалоге параметров отображения перекрывающихся объектов.

В этом разделе:

3.3.8.3.1. Ввод текста марки/позиционного обозначения

3.3.8.3.2. Автонумерация марки/позиционного обозначения

3.3.8.3.3. Параметры марки/позиционного обозначения без линии-выноски


3.3.8.3.1. Ввод текста марки/позиционного обозначения

Для ввода текста во время создания и редактирования следующих объектов:

– марка/позиционное обозначение без линии-выноски,

– марка/позиционное обозначение с линией-выноской,

– марка/позиционное обозначение на линии.

служит диалог, приведенный на рис. 3.3.105. Диалог вызывается щелчком мыши в поле Текст на вкладке Знак Панели свойств или при помощи команды Текст надписи... из контекстного меню поля чертежа.

Элементы управления этого диалога представлены в таблице 3.3.20.

Рис. 3.3.105. Диалог ввода текста марки/позиционного обозначения

Табл. 3.3.20. Диалог ввода текста марки/позиционного обозначения

Элемент

Описание

Текст до

Поле для ввода текста, предшествующего обозначению марки/позиционного обозначения.

Марка

Поля для ввода обозначения марки.

В левое поле вводится текстовое обозначение марки, а в правое — номер марки. Если в чертеже уже были созданы марки/позиционные обозначения, марку можно выбрать из списка, раскрывающегося при нажатии кнопки со стрелкой в левом поле. После выбора марки, в том числе и не содержащей символов, становится доступен список номеров данной марки в правом поле. Номер марки можно указать из списка или ввести новый.

Если включена Автонумерация марок (см. раздел 3.3.8.3.2), то для выбранной марки предлагается следующий по порядку номер.

Текст после

Поле для ввода текста, следующего за обозначением марки.

Текст под

Поле для ввода текста, который отобразится под полкой обозначения.

Комментарий

Поле для ввода вспомогательной информации, например, об элементе, для которого создается марка/позиционное обозначение. Комментарий не отображается на чертеже.

В процессе формирования обозначения его текущий внешний вид (за исключением текста под полкой) отображается в специальном поле в нижней части диалога.

Между маркой и номером элемента может находиться разделитель — один, два или три символа, которые также отображаются в этом поле (на рис. 3.3.105 разделитель — дефис). Разделитель вставляется автоматически. Если один из элементов обозначения — название марки или ее номер — отсутствует, то разделитель не отображается. Разделитель не является текстом и не редактируется в диалоге ввода текста.

Ввод символа (символов) разделителя производится в пункте Марка/позиционное обозначение — Общие настройки диалога настройки текущего документа (см. раздел 3.3.8.2).

В меню диалога ввода текста находятся команды редактирования, вставки и форматирования текста. Эти команды используются так же, как и при работе в текстовом редакторе (см. раздел 4.1.2). Некоторые из команд можно вызвать из контекстного меню поля ввода диалога.

Для обозначения марок рекомендуется использовать символы, ввод которых возможен непосредственно с клавиатуры цифры и буквы русского и латинского алфавитов и т.п. Если обозначение марки содержит символы, введенные при помощи команд Вставить — Символ... и Вставить — Спецзнак, то это обозначение будет создано, но в раскрывающийся список левого поля попадает только часть обозначения, находящаяся перед первым таким символом.

После ввода текста марки/позиционного обозначения нажмите кнопку ОК диалога.

Если параметры текста (шрифт, высота, цвет и т.п.) у марок/позиционных обозначений (всех или какого-либо типа) в документе отличаются от текущих умолчательных параметров, то рекомендуется не настраивать каждую надпись в отдельности, а установить требуемые параметры в качестве умолчательных. Для этого служат подпункты Марка/позиционное обозначение — С линией-выноской/ На линии/ Без линии-выноски — Текст диалога настройки текущего документа (см. раздел 3.3.8.2).


3.3.8.3.2. Автонумерация марки/позиционного обозначения

Переключатель Автонумерация позволяет автоматически присваивать номер создаваемой марке. Переключатель доступен при создании марки/позиционного обозначения и недоступен при редактировании.

В режиме автонумерации происходит автоматическое заполнение той части строки, которая содержит номер (после текста марки). Автонумерация работает для марок с одинаковым текстовым обозначением. Тип марки — с линией-выноской, на линии или без линии-выноски — значения не имеет. Также не имеет значения способ задания номеров предыдущих марок — вручную или автоматически.

Для создания марки с автоматически присвоенным номером выполните следующие действия.

1. Активизируйте переключатель Автонумерация на Панели свойств. По умолчанию поле Текст пусто. Если включена опция Сохранять текст на вкладке Знак Панели свойств, то в поле Текст отображается текст, размещенный над полкой последнего созданного обозначения.

2. Щелкните правой кнопкой мыши в поле Текст. Появится контекстное меню, содержащее список марок в алфавитном порядке, использовавшихся в документе.

Марка, обозначаемая в списке символами < >, не содержит текстового обозначения, а состоит только из номера.

3. Выберите из контекстного меню нужную марку. В поле Текст отобразится обозначение марки с присвоенным ей следующим свободным номером.

В диалоге ввода текста (рис. 3.3.105) можно отредактировать обозначение, ввести дополнительный текст над полкой и под полкой, ввести комментарий.

Если марка/позиционное обозначение с автоматически присвоенным номером удаляется из документа, номера оставшихся объектов не изменяются.

Вы можете настроить систему так, чтобы режим автонумерации для марок всех типов был включен по умолчанию. Для этого включите опцию Автонумерация в пункте Марка/позиционное обозначение — Общие настройки диалога настройки текущего документа (см. раздел 3.3.8.2).

Изменение состояния переключателя Автонумерация на Панели свойств равносильно изменению состояния опции Автонумерация в диалоге общих настроек.

Если режим автонумерации выключен, поле Текст пусто. В этом случае номер марке/позиционному обозначению присваивается вручную в диалоге ввода текста.


3.3.8.3.3. Параметры марки/позиционного обозначения без линии-выноски

Чтобы настроить отрисовку марки/позиционного обозначения без линии-выноски, активизируйте вкладку Параметры Панели свойств. Расположенные на ней элементы управления рассмотрены в таблице 3.3.21.

Табл. 3.3.21. Элементы управления отрисовкой марки/позиционного обозначения без линии-выноски
Элемент | Описание
Форма | Список для выбора типа формы обозначения. Если поле пусто, то выбран тип Без формы — обозначение строится без формы. Чтобы изменить форму, раскройте список и выберите нужную строку. Перечень форм, доступных для выбора, а также порядок следования форм в списке определяются настройкой фильтра, сделанной в подпункте Марка/позиционное обозначение — Без линии-выноски —Фильтр форм диалога настройки текущего документа (см. раздел 3.3.8.2).
 | Если выбран тип Без формы, то настройка не требуется. Если выбрана какая-либо форма обозначения, то на Панели свойств появляются поля для ввода размеров формы1: Ширина, Высота или Габарит (см. таблицу 3.3.22).
Ширина | Поле для ввода или задания счетчиком ширины габаритного прямоугольника текущей формы.
Высота | Поле для ввода или задания счетчиком высоты габаритного прямоугольника текущей формы.
Габарит | Поле для ввода или задания счетчиком габарита текущей формы. Габарит формы — размер геометрической фигуры, ограничивающей снаружи форму обозначения. Габаритом формы является сторона квадрата или диаметр окружности — в зависимости от типа формы.
Стиль линии | Поле, в котором отображается текущий стиль линии отрисовки формы. Чтобы изменить стиль, раскройте список Стиль линии и выберите нужную строку. Перечень стилей, доступных для выбора, а также порядок следования стилей в списке определяются настройкой фильтра, сделанной в подпункте Марка/позиционное обозначение — Без линии-выноски —Фильтр линий диалога настройки текущего документа (см. раздел 3.3.8.2).
По умолчанию | Если эта опция включена, то все текущие настройки вкладки Параметры Панели свойств будут использоваться при создании следующих марок/позиционных обозначений до конца сеанса работы. Если опция выключена, настройка распространяется только на текущее (создаваемое) обозначение.
  1. Размер формы не зависит от длины строки вводимого текста. Если строка окажется длиннее поля текста в форме, произойдет автоматическое сужение надписи.

В таблице 3.3.22 представлены поля для ввода размеров форм, появляющиеся на Панели свойств после выбора формы. В скобках указаны виды задаваемых размеров формы.

Табл. 3.3.22. Виды размеров форм марки/позиционного обозначения без линии-выноски
Форма | Название полей ввода и виды задаваемых размеров
Без формы | Задание размеров не требуется
Окружность | Габарит (диаметр)
Прямоугольник | Ширина (ширина), Высота (высота)
Квадрат | Габарит (длина стороны квадрата)
Ромб 1 | Ширина (ширина описанного прямоугольника), Высота (высота описанного прямоугольника)
Ромб 2 | Габарит (длина стороны описанного квадрата)
Шестиугольник | Габарит (диаметр описанной окружности)
Треугольник 1 | Габарит (диаметр описанной окружности)
Треугольник 2 | Габарит (диаметр описанной окружности)
Скругленный прямоугольник | Ширина (расстояние между центрами полуокружностей), Высота (высота)
Окружность с вертикальным разделителем | Габарит (диаметр)
Двойная окружность | Габарит (диаметр внутренней окружности)

Умолчательные размеры форм и расстояния от разделителя формы до текста задаются в подпункте Марка/позиционное обозначение — Без линии-выноски — Параметры диалога настройки текущего документа (см. раздел 3.3.8.2).


3.3.8.4. Марка/позиционное обозначение с линией-выноской

Чтобы создать марку/позиционное обозначение с линией-выноской, вызовите команду Марка/позиционное обозначение с линией-выноской.

Укажите начальную точку первого ответвления обозначения (т).

Укажите точку начала полки т1.

Затем укажите начальные точки остальных ответвлений. Их количество не ограничено.

Введите текст надписи обозначения (см. раздел 3.3.8.3.1).

Чтобы при вводе текста производилось автоматическое присвоение свободных номеров элементам активизируйте переключатель Автонумерация. Подробнее об автонумерации см. раздел 3.3.8.3.2.

Контекстное меню поля Текст содержит все марки, созданные в документе. Чтобы создать марку с уже существующим текстовым обозначением, вы можете выбрать его из этого меню (см. рис. 3.3.103). В режиме автонумерации ей будет присвоен очередной номер.

Если текст, сформированный для текущей (создаваемой) марки/позиционного обозначения, нужно использовать для остальных подобных обозначений, созданных за этот вызов команды, включите опцию Сохранять текст. При выключенной опции каждое следующее обозначение формируется без текста.

Текст надписи может служить источником ссылки другого текстового объекта, находящегося в этом документе.

Настройте параметры марки/позиционного обозначения на вкладке Параметры Панели свойств (см. раздел 3.3.8.4.1).

Рис. 3.3.106. Примеры марки/позиционного обозначения с линией-выноской

По умолчанию при создании марки/позиционного обозначения включен режим добавления ответвлений. Об этом свидетельствует нажатая кнопка Добавить ответвления на Панели специального управления. В этом режиме каждая вновь указанная точка воспринимается системой как начальная точка очередного ответвления.

В режиме редактирования характерных точек объекта можно внести изменения в конфигурацию обозначения. Добавление ответвлений в этом режиме невозможно. Для перехода в режим редактирования нажмите кнопку Редактировать точки на Панели специального управления.

Подведите курсор к любой характерной точке (эти точки отображаются в виде черных квадратиков). Форма курсора изменится.

Измените положение характерных точек или удалите ненужные точки, аналогично редактированию линии-выноски (см. раздел 3.3.7.4.3).

Между режимами можно произвольно переключаться при помощи кнопок Панели специального управления или команд в контекстном меню. При выходе из одного режима автоматически включается другой.

Кнопка Копировать свойства на Панели специального управления позволяет копировать текст в текущее обозначение из уже существующей марки/позиционного обозначения (этого же или другого типа).

Чтобы зафиксировать изображение, нажмите кнопку Создать объект на Панели специального управления.

Вы можете создать несколько обозначений за один вызов команды Марка/позиционное обозначение с линией-выноской. Для этого после нажатия кнопки Создать объект укажите новые точки т и т1.

В этом разделе:

3.3.8.4.1. Параметры марок/позиционных обозначений с линией-выноской


3.3.8.4.1. Параметры марок/позиционных обозначений с линией-выноской

Чтобы настроить отрисовку марки/позиционного обозначения с линией-выноской, активизируйте вкладку Параметры Панели свойств. Расположенные на ней элементы управления рассмотрены в таблице 3.3.23.

Табл. 3.3.23. Элементы управления отрисовкой марки/позиционного обозначения с линией-выноской
Элемент | Описание
Стрелка | Список, позволяющий выбрать вид стрелки марки/позиционного обозначения. Перечень стрелок, доступных для выбора, а также порядок следования стрелок в списке определяются настройкой фильтра, сделанной в подпункте Марка/позиционное обозначение — С линией выноской — Фильтр стрелок диалога настройки текущего документа (см. раздел 3.3.8.2).
Полка | Элемент управления, позволяющий выбрать расположение полки обозначения. Элемент управления Полка принимает различный вид в зависимости от того, какой переключатель активизирован в группе Ответвления.
 | Если активен переключатель От начала полки или От конца полки, то элемент управления Полка представляет собой раскрывающийся список, позволяющий выбрать направление полки от точки ее начала. Выберите из списка нужное направление отрисовки полки — Влево, Вправо, Вверх или Вниз (рис. 3.3.107).
 | Если активен переключатель Параллельные, то элемент управления Полка представляет собой группу переключателей, позволяющую выбрать положение полки — Горизонтальное или Вертикальное (рис. 3.3.108)1.
Ответвления | Группа переключателей, позволяющая выбрать способ построения ответвлений. Активизируйте нужный переключатель:
 | От начала полки,
 | От конца полки,
 | Параллельные.
По умолчанию | Если эта опция включена, то все текущие настройки вкладки Параметры Панели свойств будут использоваться при создании следующих марок/позиционных обозначений до конца сеанса работы. Если опция выключена, настройка распространяется только на текущее (создаваемое) обозначение.
  1. Поскольку вид переключателей Полка зависит от того, какой переключатель активен в группе Ответвления, рекомендуется настраивать полку после того, как будет выбран вариант добавления ответвлений.

Рис. 3.3.107. Элемент управления Полка в виде раскрывающегося списка

Рис. 3.3.108. Элемент управления Полка в виде группы переключателей

Расстояния от текста до полки и размеры стрелок задаются в подпункте Марка/позиционное обозначение — С линией-выноской — Параметры, а вид стрелок и засечек — в подпункте Марка/позиционное обозначение — С линией-выноской — Стрелки и засечки диалога настройки текущего документа (см. раздел 3.3.8.2).


3.3.8.5. Марка/позиционное обозначение на линии

Чтобы создать марку/позиционное обозначение на линии, вызовите команду Марка/позиционное обозначение на линии.

Укажите курсором линию для размещения обозначения. После того как объект подсветится, щелкните левой кнопкой мыши.

Чтобы сменить объект, нажмите кнопку Указать заново на Панели специального управления и выберите новую линию.

На экране появится фантом габаритного прямоугольника марки/позиционного обозначения.

Группа переключателей Размещение текста позволяет выбрать расположение обозначения: Над линией, На линии или Под линией. В процессе построения при помощи мыши автоматически активизируется переключатель, соответствующий текущему положению фантома.

Введите текст надписи обозначения (см. раздел 3.3.8.3.1).

Чтобы при вводе текста производилось автоматическое присвоение свободных номеров элементам активизируйте переключатель Автонумерация. Подробнее об автонумерации см. раздел 3.3.8.3.2.

Контекстное меню поля Текст содержит все марки, созданные в документе. Чтобы создать марку с уже существующим текстовым обозначением, вы можете выбрать его из этого меню (см. рис. 3.3.103). В режиме автонумерации ей будет присвоен очередной номер.

Если текст, сформированный для текущей (создаваемой) марки/позиционного обозначения, нужно использовать для остальных подобных обозначений, созданных за этот вызов команды, включите опцию Сохранять текст. При выключенной опции каждое следующее обозначение формируется без текста.

Текст надписи может служить источником ссылки другого текстового объекта, находящегося в этом документе. Подробнее о ссылках см. раздел 3.4.1.4.

Перемещая курсор, выберите размещение текста — над линией, на линии или под линией и щелкните левой кнопкой мыши.

Если указанная точка не принадлежит выбранной линии, то положение обозначения будет определяться проекцией указанной точки на линию или ее продолжение. В последнем случае линия автоматически будет продолжена на нужное расстояние выносной линией со стилем тонкая.

Продление дуг эллипсов, NURBS и кривых Безье невозможно.

Для точного позиционирования курсора воспользуйтесь привязками или меню геометрического калькулятора в поле Положение марки на вкладке Знак Панели свойств.

Расстояния от текста до линии задаются в подпункте Марка/позиционное обозначение — На линии — Параметры диалога настройки текущего документа (см. раздел 3.3.8.2).

Рис. 3.3.109. Марка/позиционное обозначение на линии: а) пример использования, б) варианты размещения текста
а) | б)

Фон под обозначением всегда очищается независимо от настроек, сделанных в диалоге параметров отображения перекрывающихся объектов.

Кнопка Копировать свойства на Панели специального управления позволяет копировать текст в текущее обозначение из уже существующей марки/позиционного обозначения (этого же или другого типа).

Вы можете создать несколько обозначений за один вызов команды Марка/позиционное обозначение на линии.


3.3.8.6. Линия разреза

Чтобы создать линию разреза, вызовите команду Линия разреза.

Создание линии разреза для строительства в целом аналогично созданию линии разреза для машиностроения (см. раздел 3.3.7.10).

Отличия следующие:

– Вместо букв в обозначении используются цифры (см. раздел 3.3.8.6.1);

– Формированием нового вида после создания линии разреза управляет опция Создавать вид.
Если опция включена, то после создания линии разреза автоматически запускается команда создания нового вида (см. раздел 3.3.9.1). После выполнения этой команды в чертеже появится вид, надпись которого будет ассоциативно связана с созданной линией разреза.

В этом разделе:

3.3.8.6.1. Формирование текста обозначения линии разреза


3.3.8.6.1. Формирование текста обозначения линии разреза

Для ввода текста обозначения линии разреза служит поле Текст на Панели свойств. В этом поле отображается автоматически сформированный текст обозначения — номер разреза. Вы можете выбрать нужный номер разреза из контекстного меню этого поля (рис. 3.3.110).

Рис. 3.3.110. Меню выбора символа

Если в обозначение линии разреза необходимо включить номер листа или обозначение зоны, где будет располагаться вид с соответствующим изображением, включите опцию Лист или Зона на Панели свойств.

Номер листа или обозначение зоны автоматически включаются в обозначение линии разреза после создания вида и формирования ассоциативной связи между надписью этого вида и обозначением линии разреза (см. раздел 3.3.9.1).

Во фрагментах создание листов и видов невозможно, поэтому опции Лист и Зона недоступны.

Текст обозначения линии разреза можно сформировать также в диалоге ввода текста обозначения. Для вызова этого диалога щелкните мышью в поле Текст или вызовите команду Текст надписи... из контекстного меню. Можно также просто начать ввод текста — диалог автоматически появится на экране.

Рис. 3.3.111. Диалог ввода текста обозначения линии разреза

Первое поле ввода диалога предназначено для цифрового обозначения разреза. Двойной щелчок мышью в этом поле вызывает меню выбора символа (рис. 3.3.111). Кнопки со стрелками справа от поля ввода текста позволяют «листать» список номеров разреза в любом направлении.

Во втором поле можно ввести дополнительные сведения, например, обозначение зоны.

Если на Панели свойств включена опция Лист или Зона, то в диалоге ввода текста обозначения второе поле недоступно.

При необходимости измените параметры текста (размер, цвет символов и т.п.) с помощью элементов управления на вкладках Панели свойств.

Завершив ввод и форматирование текстов в полях, нажмите кнопку OK диалога.

Если параметры текста (шрифт, высота, цвет и т.п.) у всех обозначений линии разреза в документе отличаются от текущих умолчательных параметров, то рекомендуется не настраивать каждую надпись в отдельности, а установить требуемые параметры в качестве умолчательных. Для этого служит подраздел Обозначения для строительства — Линия разреза диалога настройки текущего документа (см. раздел 3.3.8.2).


3.3.8.7. Обозначение узла

Чтобы создать обозначение узла, вызовите команду Обозначение узла.

Точка привязки обозначения узла находится в центре контура, ограничивающего узел.

Введите координаты центра узла на Панели свойств или укажите точку, определяющую его положение, в окне документа.

Введите текст надписи обозначения (см. раздел 3.3.8.7.1).

Текст обозначения узла может содержать ссылку на другой объект (например, номер узла) и может являться источником ссылки. Подробнее о ссылках см. раздел 3.4.1.4.

Задайте размеры контура: для окружности — диаметр или радиус, для прямоугольников — ширину, высоту и радиус скругления.

Настройте параметры отрисовки обозначения узла на вкладке Параметры Панели свойств (см. раздел 3.3.8.7.2).

Опция Создавать вид позволяет сформировать новый вид сразу после создания узла.

Если опция включена, то после создания узла автоматически запускается команда создания нового вида (см. раздел 3.3.9.1). После выполнения этой команды в чертеже появится вид, обозначение которого будет ассоциативно связано с созданным узлом.

Вы можете отказаться от создания нового вида, нажав кнопку Прервать команду. Однако делать это не рекомендуется, поскольку ручное создание вида и формирование связи между его обозначением и обозначением узла займет дополнительное время. Кроме того, размещение изображения узла в отдельном виде позволяет быстро изменять масштаб изображения и делает более удобной компоновку чертежа.

При простановке узла может автоматически создаваться гиперссылка, связывающая обозначение с вновь созданным видом (см. раздел 3.3.9.2).

Укажите точку начала полки т2.

Рис. 3.3.112. Примеры обозначений узлов

В этом разделе:

3.3.8.7.1. Ввод текста обозначения узла и узла в сечении

3.3.8.7.2. Параметры обозначения узла


3.3.8.7.1. Ввод текста обозначения узла и узла в сечении

Для ввода текста при создании и редактировании обозначения узла и узла в сечении служит диалог, приведенный на рис. 3.3.113.

Диалог вызывается щелчком мыши в поле Текст на вкладке Знак Панели свойств или при помощи команды Текст надписи... из контекстного меню поля чертежа. Можно также просто начать ввод текста — диалог автоматически появится на экране.

Рис. 3.3.113. Диалог ввода текста обозначения узла и узла в сечении

По умолчанию надпись представляет собой номер, определяемый автоматически. Это первый свободный номер среди обозначений узлов и узлов в сечении, имеющихся в текущем документе. Кнопки со стрелками справа от поля 1 позволяют «листать» список номеров обозначения в любом направлении.

Введите текст в поля ввода.

Чтобы перейти к вводу текста другого поля, нажмите клавишу <Tab> или комбинацию клавиш <Shift> + <Tab>.

Чтобы вставить табуляцию при вводе текста, нажмите комбинацию клавиш <Ctrl> + <Tab>.

При вводе текста обозначения узла можно использовать текстовые шаблоны. Для вызова Библиотекаря текстовых шаблонов дважды щелкните мышью в поле ввода. Подробнее о текстовых шаблонах — см. раздел 4.1.2.11.6.

Пока диалог ввода текста находится на экране, на Панели свойств доступны элементы, а в Главном меню — команды, позволяющие работать с текстом. Некоторые из них можно вызвать из контекстного меню поля ввода диалога.

Если параметры текста (шрифт, высота, цвет и т.п.) у всех обозначений узла и узла в сечении в документе отличаются от текущих умолчательных параметров, то рекомендуется не настраивать каждую надпись в отдельности, а установить требуемые параметры в качестве умолчательных. Для этого служит пункт Обозначение узла и узла в сечении — Текст диалога настройки текущего документа (см. раздел 3.3.8.2).


3.3.8.7.2. Параметры обозначения узла

Чтобы настроить отрисовку обозначения узла, активизируйте вкладку Параметры Панели свойств. Расположенные на ней элементы управления рассмотрены в таблице 3.3.24.

Табл. 3.3.24. Элементы управления отрисовкой обозначения узла
Элемент | Описание
Форма | Список для выбора формы контура, ограничивающей узел. Укажите в раскрывающемся списке форму обозначения:
 | Окружность,
 | Прямоугольник,
 | Скругленный прямоугольник.
Полка | Список для выбора расположения полки обозначения. Укажите в раскрывающемся списке нужное направление полки линии-выноски:
 | Влево,
 | Вправо,
 | Вверх,
 | Вниз.
Сохранять текст | Если опция включена, то текст под полкой, введенный для текущего обозначения узла, будет предлагаться по умолчанию для следующих обозначений узла до конца сеанса работы. При выключенной опции каждое следующее обозначение будет содержать только текст над полкой.
По умолчанию | Если эта опция включена, то все текущие настройки вкладки Параметры Панели свойств будут использоваться при создании следующих обозначений узла до конца сеанса работы. Если опция выключена, настройка распространяется только на текущее (создаваемое) обозначение узла.

Расстояния от текста до полки задаются в пункте Обозначение узла и узла в сечении — Параметры диалога настройки текущего документа (см. раздел 3.3.8.2).


3.3.8.8. Обозначение узла в сечении

Чтобы создать обозначение узла в сечении, вызовите команду Обозначение узла в сечении.

Введите координаты точки привязки (т) штриха на Панели свойств или укажите положение точки привязки штриха в окне документа. Точкой привязки штриха является его средняя точка.

На экране появится фантом обозначения с умолчательными настройками.

Введите длину штриха в поле Штрих. Укажите точку начала полки т1. Угол наклона штриха вычисляется автоматически и заносится в поле Угол. Угол наклона отсчитывается от оси ОХ текущей системы координат. Если необходимо установить определенный угол наклона штриха, введите эту величину с клавиатуры в поле Угол и зафиксируйте ее.

Чтобы начать построение от точки начала полки, активизируйте поле ввода координат точки т1 на Панели свойств и укажите точки (т1) и (т).

Настройте параметры обозначения узла в сечении на вкладке Параметры Панели свойств (см. раздел 3.3.8.8.1).

Рис. 3.3.114. Примеры обозначений узлов в сечении

Введите текст надписи обозначения (см. раздел 3.3.8.7.1).

Текст обозначения узла в сечении может содержать ссылку на другой объект, например, номер узла. Подробнее о ссылках см. раздел 3.4.1.4.

По умолчанию при создании обозначения номера узла в сечении включен режим добавления штрихов. Об этом свидетельствует нажатая кнопка Добавить штрихи на Панели специального управления. В этом режиме каждая вновь указанная точка воспринимается системой как точка середины очередного штриха. Вы можете создать несколько штрихов подряд на линии-выноске, указывая их точки привязки. Если штрихи должны иметь разную длину, вводите в поле Штрих размер каждого следующего штриха.

В режиме редактирования характерных точек объекта можно изменить угол наклона штрихов, расположение штрихов и полки, а также удалить штрихи. Для перехода в режим редактирования нажмите кнопку Редактировать точки на Панели специального управления.

Подведите курсор к любой характерной точке (эти точки отображаются в виде черных квадратиков). Форма курсора изменится.

Измените положение характерных точек или удалите ненужные точки, аналогично редактированию линии-выноски (см. раздел 3.3.7.4.3).

Чтобы изменить угол наклона штрихов в режиме редактирования характерных точек, расфиксируйте поле Угол.

Между режимами можно произвольно переключаться при помощи кнопок Панели специального управления или команд в контекстном меню. При выходе из одного режима автоматически включается другой.

Опция Создавать вид позволяет сформировать новый вид сразу после создания узла в сечении. Этот вид является текущим, и вы можете приступать к вычерчиванию изображения в нем.

Чтобы зафиксировать изображение, нажмите кнопку Создать объект на Панели специального управления.

Вы можете создать несколько обозначений за один вызов команды Обозначение узла в сечении. Для этого после нажатия кнопки Создать объект укажите новые точки т и т1.

В этом разделе:

3.3.8.8.1. Параметры обозначения узла в сечении


3.3.8.8.1. Параметры обозначения узла в сечении

Чтобы настроить отрисовку обозначения узла в сечении, активизируйте вкладку Параметры Панели свойств. Расположенные на ней элементы управления рассмотрены в таблице 3.3.25.

Табл. 3.3.25. Элементы управления отрисовкой обозначения узла
Элемент | Описание
Полка | Список для выбора направления полки относительно точки ее начала (т1). Укажите в раскрывающемся списке направление:
 | Влево,
 | Вправо,
 | Вверх,
 | Вниз.
Сохранять текст | Если опция включена, то текстовое обозначение текущего узла будет предлагаться по умолчанию для остальных подобных обозначений, созданных за этот вызов команды. При выключенной опции каждое следующее обозначение формируется без текста под полкой.
По умолчанию | Если эта опция включена, то все текущие настройки вкладки Параметры Панели свойств будут использоваться при создании следующих обозначений узла до конца сеанса работы. Если опция выключена, настройка распространяется только на текущее обозначение.

Стили линии штриха и линии между штрихами, а также включение опции отрисовки линии между штрихами определяются настройками в пункте Обозначение узла и узла в сечении — Общие настройки, а умолчательная длина штриха и зазор между штрихом и линией-выноской — в пункте Обозначение узла и узла в сечении — Параметры диалога настройки текущего документа (см. раздел 3.3.8.2).


3.3.8.9. Номер узла

Чтобы создать обозначение номера узла, вызовите команду Номер узла.

После вызова команды на экране появляется фантом номера узла. Точка привязки располагается в центре окружности.

Введите координаты точки привязки номера узла на Панели свойств или укажите точку, определяющую положение номера узла в окне документа.

Введите текст надписи обозначения (см. раздел 3.3.8.9.1).

Рис. 3.3.115. Примеры обозначений номеров узлов

Чтобы зафиксировать изображение, нажмите кнопку Создать объект на Панели специального управления.

Тип формы и размеры обозначения задаются в пункте Номер узла — Параметры диалога настройки текущего документа (см. раздел 3.3.8.2).

Вы можете создать несколько обозначений за один вызов команды Номер узла. Для этого после нажатия кнопки Создать объект укажите новую точку расположения номера узла.

По сравнению с изображением номера узла, полученным посредством геометрических построений, обозначение, созданное при помощи команды Номер узла, имеет следующие преимущества:

– сохраняет размеры и взаимное расположение частей при масштабировании, повороте или преобразовании симметрии;

– может содержать ссылку на другой объект (например, обозначение узла) и может являться источником ссылки.

В этом разделе:

3.3.8.9.1. Ввод текста обозначения номера узла


3.3.8.9.1. Ввод текста обозначения номера узла

Для ввода текста в обозначение при создании и редактировании номера узла служит диалог, приведенный на рис. 3.3.116.

Диалог вызывается щелчком мыши в поле Текст на Панели свойств или при помощи команды Текст надписи... из контекстного меню поля чертежа. Можно также просто начать ввод текста — диалог автоматически появится на экране.

Рис. 3.3.116. Диалог ввода текста номера узла

Введите текст номера узла в поле ввода. Если введен двухстрочный текст, то в обозначении автоматически создается разделитель — горизонтальная черта посередине формы. Первая строка текста будет расположена над разделителем, а вторая — под разделителем. Для формирования новой строки или разбиения одной строки на две нажмите клавишу <Enter>.

Кнопки со стрелками справа от поля ввода позволяют «листать» список номеров обозначений в любом направлении.

Если длина строки введенного текста окажется больше диаметра окружности обозначения, произойдет автоматическое сужение надписи.

Пока диалог ввода текста находится на экране, на Панели свойств доступны элементы, а в Главном меню — команды, позволяющие работать с текстом. Некоторые из них можно вызвать из контекстного меню поля ввода диалога.

Если параметры текста (шрифт, высота, цвет и т.п.) у всех обозначений номера узла в документе отличаются от текущих умолчательных параметров, то рекомендуется не настраивать каждую надпись в отдельности, а установить требуемые параметры в качестве умолчательных. Для этого служит пункт Номер узла — Текст диалога настройки текущего документа (см. раздел 3.3.8.2).

Чтобы сделать в номере узла ссылку на обозначение узла, предварительно создайте это обозначение при помощи команды Обозначение узла или Обозначение узла в сечении. Команду вставки ссылки можно вызвать из контекстного меню поля ввода диалога или из меню Вставка. Ссылка возможна только на обозначения, находящиеся в том же документе, что и номер узла. Подробнее о ссылках см. раздел 3.4.1.4.


3.3.8.10. Фигурная скобка

Чтобы создать изображение фигурной скобки, используемое для обозначения фрагментов, вызовите команду Фигурная скобка.

Если известны первая (т1) и вторая (т2) точки привязки скобки, укажите их. При этом длина и угол наклона скобки будут определены автоматически.

Рис. 3.3.117. Примеры фигурных скобок

Если известны первая точка привязки скобки, ее длина и угол наклона, задайте их любым способом и в любом порядке. Обратите внимание на то, что минимальная длина фигурной скобки зависит от величины радиуса закругления (см. раздел 3.3.8.10.2).

На экране появится фантом изображения фигурной скобки.

В случае если текст фигурной скобки размещается на полке линии-выноски, то следует указать точку начала полки (т3).

Группа переключателей Тип позволяет выбрать ориентацию фигурной скобки: горизонтально, вертикально или произвольно.

Группа переключателей Направление позволяет выбрать направление фигурной скобки.

Направление скобки по умолчанию задается в пункте Фигурная скобка — Общие настройки диалога настройки текущего документа (см. раздел 3.3.8.2).

Введите текст надписи обозначения (см. раздел 3.3.8.10.1).

Текст фигурной скобки может содержать ссылку на другой объект и может являться источником ссылки. Подробнее о ссылках см. раздел 3.4.1.4.

Настройте параметры фигурной скобки на вкладке Параметры Панели свойств (см. раздел 3.3.8.10.2).

Кнопка Редактировать точки на Панели специального управления служит для перехода в режим редактирования характерных точек линии-выноски. В этом режиме можно создавать изломы линии-выноски и перемещать мышью ее характерные точки (см. раздел 3.3.7.4.3). Кнопка Редактировать точки доступна, если выбран один из вариантов размещения текста на полке и указана точка начала полки т3.

Некоторые особенности редактирования фигурной скобки описаны в разделе 3.3.8.10.3.

Чтобы зафиксировать изображение, нажмите кнопку Создать объект на Панели специального управления.

Вы можете создать несколько обозначений за один вызов команды Фигурная скобка. Для этого после нажатия кнопки Создать объект укажите новые точки привязки.

В этом разделе:

3.3.8.10.1. Ввод текста обозначения фигурной скобки

3.3.8.10.2. Параметры фигурной скобки

3.3.8.10.3. Особенности редактирования фигурной скобки с помощью мыши


3.3.8.10.1. Ввод текста обозначения фигурной скобки

Для ввода текста при создании и редактировании обозначения фигурной скобки служит диалог, приведенный на рис. 3.3.118.

Диалог вызывается щелчком мыши в поле Текст на Панели свойств или при помощи команды Текст надписи... из контекстного меню поля чертежа. Можно также просто начать ввод текста — диалог автоматически появится на экране.

Рис. 3.3.118. Диалог ввода текста фигурной скобки

Введите текст обозначения в поле ввода.

Чтобы ввести несколько строк, пользуйтесь клавишей <Enter> для разделения текста на строки.

Чтобы вставить табуляцию при вводе текста, нажмите комбинацию клавиш <Ctrl> + <Tab>.

Двойной щелчок в поле ввода позволяет перейти к вставке текстового шаблона (см. раздел 4.1.2.11.6).

Пока диалог ввода текста находится на экране, на Панели свойств доступны элементы, а в Главном меню — команды, позволяющие работать с текстом. Некоторые из них можно вызвать из контекстного меню поля ввода диалога.

Если параметры текста (шрифт, высота, цвет и т.п.) у всех обозначений фрагментов (фигурной скобки) в документе отличаются от текущих умолчательных параметров, то рекомендуется не настраивать каждую надпись в отдельности, а установить требуемые параметры в качестве умолчательных. Для этого служит пункт Фигурная скобка — Текст диалога настройки текущего документа (см. раздел 3.3.8.2).


3.3.8.10.2. Параметры фигурной скобки

Чтобы настроить отрисовку фигурной скобки, активизируйте вкладку Параметры Панели свойств. Расположенные на ней элементы управления рассмотрены в таблице 3.3.26.

Табл. 3.3.26. Элементы управления отрисовкой фигурной скобки
Элемент | Описание
Размещение текста | Список для выбора способа размещения надписи фигурной скобки. Укажите в раскрывающемся списке необходимый вариант.
 | При выборе одного из способов для размещения надписи:
 | На полке, вправо,
 | На полке, влево,
 | На полке, вверх,
 | На полке, вниз формируется линия-выноска с полкой указанного направления. В этом случае требуется указать точку начала полки (т3).
 | При выборе способа Автоматическое текст располагается с внешней стороны фигурной скобки без линии-выноски. Строки текста параллельны скобке. Текст автоматически центрируется относительно середины скобки.
Радиус закругления | Поле выбора радиуса закругления фигурной скобки. Возможен ввод значений радиуса с клавиатуры. Если задается такой радиус закругления, при котором текущее значение длины скобки оказывается меньше минимального (см. ниже), то длина скобки автоматически принимает это минимальное значение.
Стиль линии | Поле для отображения текущего стиля линии фигурной скобки. Чтобы изменить стиль, раскройте список Стиль линии и выберите нужную строку. Перечень стилей, доступных для выбора, а также порядок их следования определяются настройкой фильтра линий, сделанной в пункте Фигурная скобка — Фильтр линий диалога настройки текущего документа (см. раздел 3.3.8.2).
Сохранять текст | Если опция включена, то текущее текстовое обозначение скобки будет предлагаться по умолчанию для следующих фигурных скобок до конца сеанса работы.
По умолчанию | Если эта опция включена, то все текущие настройки будут использоваться при создании следующих фигурных скобок до конца сеанса работы. Если опция выключена, настройка распространяется только на текущую (создаваемую) фигурную скобку.

Минимальная длина фигурной скобки рассчитывается по формуле

L=4 · R/M, где

R — радиус закругления фигурной скобки,
M — масштаб вида, в котором располагается скобка.

Если фигурная скобка создается в виде с масштабом 1:1 или во фрагменте, то L=4 · R.

Умолчательный способ расположения текста — автоматического или на полке — определяется настройкой, сделанной в пункте Фигурная скобка — Общие настройки, а умолчательный радиус закругления и расстояния от текста до скобки — в пункте Фигурная скобка — Параметры диалога настройки текущего документа (см. раздел 3.3.8.2).


3.3.8.10.3. Особенности редактирования фигурной скобки с помощью мыши

Фигурная скобка имеет четыре или пять (в зависимости от выбранного варианта размещения текста) характерных точек.

Редактирование скобки путем перемещения характерных точек мышью имеет следующие особенности.

– Смена направления фигурной скобки достигается перемещением точки в центре скобки — т3 (рис. 3.3.119).

Рис. 3.3.119. Смена направления фигурной скобки: а) исходное состояние и направление перемещения точки т3, б) результат редактирования
а) | б)

– При перемещении одной из точек привязки — т1 или т2 — происходит изменение длины скобки и ее поворот вокруг другой точки привязки. При этом текст, расположенный рядом со скобкой, поворачивается вместе с ней, а текст, расположенный на полке, не меняет своего положения. Перемещая точки привязки, следует учитывать, что их невозможно сблизить на расстояние, меньшее, чем минимальная длина фигурной скобки (см. раздел 3.3.8.10.2). Минимальная длина зависит от величины радиуса закругления (см. таблицу 3.3.26).

– Смена варианта размещения текста осуществляется перемещением точки т4 (рис. 3.3.120).

Рис. 3.3.120. Преобразование текста на полке в надпись: а) исходное состояние и направление перемещения точки т4, б) результат редактирования
а) | б)

– При перемещении характерных точек сохраняется горизонтальная или вертикальная ориентация скобки, заданная с помощью переключателей группы Тип.


3.3.8.11. Выносная надпись

Чтобы создать выносную надпись для обозначения многослойных конструкций, вызовите команду Выносная надпись.

Укажите начальную точку первого ответвления выносной надписи (т).

Укажите точку начала полки т1.

Затем укажите начальные точки остальных ответвлений. Их количество не ограничено.

Введите текст выносной надписи (см. раздел 3.3.8.11.1).

Рис. 3.3.121. Примеры выносной надписи

Настройте параметры выносной надписи на вкладке Параметры Панели свойств (см. раздел 3.3.8.11.2).

По умолчанию при создании выносной надписи включен режим добавления ответвлений. Об этом свидетельствует нажатая кнопка Добавить ответвления на Панели специального управления. В этом режиме каждая вновь указанная точка воспринимается системой как начальная точка очередного ответвления.

В режиме редактирования характерных точек объекта можно внести изменения в конфигурацию обозначения. Добавление ответвлений в этом режиме невозможно. Для перехода в режим редактирования нажмите кнопку Редактировать точки на Панели специального управления.

Подведите курсор к любой характерной точке (эти точки отображаются в виде черных квадратиков). Форма курсора изменится.

Измените положение характерных точек или удалите ненужные точки, аналогично редактированию линии-выноски (см. раздел 3.3.7.4.3).

Между режимами можно произвольно переключаться при помощи кнопок Панели специального управления или команд в контекстном меню. При выходе из одного режима автоматически включается другой.

Чтобы зафиксировать изображение, нажмите кнопку Создать объект на Панели специального управления.

Вы можете создать несколько обозначений за один вызов команды Выносная надпись. Для этого после нажатия кнопки Создать объект укажите новые точки т и т1.

В этом разделе:

3.3.8.11.1. Ввод текста выносной надписи

3.3.8.11.2. Параметры выносной надписи


3.3.8.11.1. Ввод текста выносной надписи

Для ввода текста в обозначение при создании и редактировании выносной надписи служит диалог, приведенный на рис. 3.3.122.

Диалог вызывается щелчком мыши в поле Текст на Панели свойств или при помощи команды Текст надписи... из контекстного меню поля чертежа. Можно также просто начать ввод текста — диалог автоматически появится на экране.

Рис. 3.3.122. Диалог ввода текста выносной надписи

В окне диалога отображается таблица, состоящая из двух колонок. В левой колонке находятся порядковые номера полок. В правой колонке находится поле ввода текста.

Введите текст в поле ввода.

Чтобы перейти к вводу текста следующей полки, нажмите комбинацию клавиш <Shift> + <Enter> или клавишу <Tab>. В окне диалога появится новая строка с номером следующей полки.

Чтобы ввести несколько строк на одной полке, пользуйтесь клавишей <Enter> для разделения текста на строки.

Чтобы вставить табуляцию при вводе текста, нажмите комбинацию клавиш <Ctrl> + <Tab>.

При вводе текста выносной надписи можно использовать текстовые шаблоны. Для вызова Библиотекаря текстовых шаблонов дважды щелкните мышью в поле ввода. Подробнее о текстовых шаблонах — см. раздел 4.1.2.11.6.

Вы можете вставлять в выносную надпись несколько текстовых шаблонов одновременно. При этом в диалоге будет сформировано столько дополнительных строк (и, соответственно, полок в выносной надписи), сколько шаблонов было отмечено в окне Библиотекаря.

Пока диалог ввода текста находится на экране, на Панели свойств доступны элементы, а в Главном меню — команды, позволяющие работать с текстом и таблицей. Некоторые из них можно вызвать из контекстного меню поля ввода диалога.

Если параметры текста (шрифт, высота, цвет и т.п.) у всех обозначений выносной надписи отличаются от текущих умолчательных параметров, то рекомендуется не настраивать каждую надпись в отдельности, а установить требуемые параметры в качестве умолчательных. Для этого служит пункт Выносная надпись — Текст диалога настройки текущего документа (см. раздел 3.3.8.2).

Вы можете сделать ссылку на другой текстовый объект, находящийся в этом же документе. Команду вставки ссылки можно вызвать из контекстного меню поля ввода или из меню Вставка. Подробнее о ссылках см. раздел 3.4.1.4.

После завершения ввода текста нажмите кнопку ОК диалога.


3.3.8.11.2. Параметры выносной надписи

Чтобы настроить отрисовку выносной надписи, активизируйте вкладку Параметры Панели свойств. Расположенные на ней элементы управления рассмотрены в таблице 3.3.27.

Табл. 3.3.27. Элементы управления отрисовкой выносной надписи

Элемент

Описание

Стрелка

Список для выбора вида стрелки выносной надписи.

Перечень стрелок, доступных для выбора, а также порядок следования стрелок в списке определяются настройкой фильтра, сделанной в пункте Выносная надпись — Фильтр стрелок диалога настройки текущего документа (см. раздел 3.3.8.2).

Направление
полки

Группа переключателей, позволяющая выбрать направление полок выносной надписи: Полки вправо или Полки влево.

Текст
вверх/вниз

Группа переключателей, позволяющая выбрать расположение полок с текстом относительно точки т1.

Если активен переключатель Текст вниз, то с точкой т1 совмещается начало верхней полки, а если — Текст вверх, то с точкой т1 совмещается начало нижней полки.

При переключении расположения полок порядок их следования не изменяется.

Тип формы

Группа переключателей, позволяющая выбрать форму верхней полки выносной надписи.

Если активен переключатель Тип 1, то верхняя полка отображается с дополнительным вертикальным сегментом.

Если активен переключатель Тип 2, то верхняя полка отображается без дополнительного сегмента.

Выравнивание

Группа переключателей, позволяющая выбрать способ определения длины полок выносной надписи.

Если активен переключатель Полки одинаковой длины, то все полки имеют одинаковую длину, равную длине наиболее протяженной полки. Ее длина складывается из длины строки текста на ней и величин отступов.

Если активен переключатель Полки по длине текста, полки могут иметь различную длину. Длина каждой полки складывается из длины строки текста на ней и величин отступов.

Сохранять текст

Если опция включена, то текущий текст будет предлагаться по умолчанию для следующих выносных надписей до конца сеанса работы.

При выключенной опции каждая следующая выносная надпись формируется без текста.

По умолчанию

Если эта опция включена, то все текущие настройки будут использоваться при создании следующих выносных надписей до конца сеанса работы.

Если опция выключена, настройка распространяется только на текущую (создаваемую) выносную надпись.

Умолчательные тип формы и способ выравнивания полок задаются в пункте Выносная надпись — Общие настройки, расстояния от текста до полки и размеры стрелок — в пункте Выносная надпись — Параметры, а вид стрелок и засечек — в пункте Выносная надпись — Стрелки и засечки диалога настройки текущего документа (см. раздел 3.3.8.2).


3.3.8.12. Прямая координационная ось

Чтобы создать обозначение прямой координационной оси, вызовите команду Прямая координационная ось.

Укажите начальную точку оси (т1). На экране появится фантом обозначения с умолчательными параметрами.

Рис. 3.3.123. Прямая координационная ось: а) пример использования, б) параметры оси
а) | б)

Введите текст надписи обозначения.

Чтобы при вводе текста производилось автоматическое присвоение номера марке, активизируйте переключатель Автопродолжение (см. раздел 3.3.8.12.1).

Подробнее о формировании обозначения координационной оси см. раздел 3.3.8.12.2.

Укажите конечную точку оси (т2).

В документе будет создана прямая координационная ось, выходящая за точки т1 и т2 на величины выступов. При этом длина отрезка между точками т1, т2 и угол оси будут определены автоматически и занесены в поля Длина и Угол.

Во время построения оси можно задать ее параметры на вкладках Параметры, Выступ 1, Выступ 2 Панели свойств (см. раздел 3.3.8.12.3 и раздел 3.3.8.12.4).

За один вызов команды Прямая координационная ось можно создать несколько координационных осей.

При построении осей с одинаковыми (частично или полностью) параметрами удобно воспользоваться командой Запомнить состояние. Пример создания координационных осей приведен в разделе 3.3.8.15.

Координационная ось может иметь дополнительные обозначения (рис. 3.3.124). Порядок их создания подробно описан в разделе 3.3.8.12.5.

Рис. 3.3.124. Элементы дополнительных обозначений: а) указатель ориентации, б) марка, в) текст
а) | б) | в)

В этом разделе:

3.3.8.12.1. Автопродолжение

3.3.8.12.2. Формирование обозначения

3.3.8.12.3. Параметры отрисовки

3.3.8.12.4. Выступы

3.3.8.12.5. Дополнительные обозначения

3.3.8.12.6. Параметры отрисовки дополнительных обозначений

3.3.8.12.7. Ввод текста дополнительных обозначений


3.3.8.12.1. Автопродолжение

Переключатель Автопродолжение позволяет автоматически присваивать номер или букву создаваемой координационной оси. Переключатель доступен при создании марки/позиционного обозначения и скрыт при редактировании.

Автопродолжение действует для обозначения оси — букв или чисел, введенных в первое поле ввода диалога ввода текста (см. рис. 3.3.126) или выбранных из контекстного меню поля Текст Панели свойств (см. рис. 3.3.125).

– Если предыдущая ось имеет цифровое обозначение (номер), то следующей оси присваивается следующий номер в порядке возрастания.

– Если предыдущая ось имеет буквенное обозначение, то следующей оси присваивается следующая по порядку буква. Порядок следования букв определяются перечнем, заданным в пункте Координационные оси — Общие настройки диалога настройки текущего документа (см. раздел 9.2.6.14.1). Буквы, не указанные в этом пункте, при автопродолжении игнорируются.

– Если предыдущая ось имеет буквенное и цифровое обозначение, то автопродолжение действует для первого символа. Например, после оси с обозначением А1 будет создана ось Б1.

Если координационная ось с автоматически присвоенным номером или буквой удаляется из документа, номера и буквы оставшихся осей не изменяются.

Автопродолжение действует только для основных марок — марок, присоединенных к координационным осям. Автопродолжение для марок дополнительных обозначений не производится.

Автопродолжение действует только в течение одного вызова команды построения осей. Чтобы автопродолжение действовало до конца сеанса работы КОМПАС-3D, следует дополнительно включить опцию Сохранять текст на вкладке Параметры Панели свойств.

Если режим автопродолжения выключен, то обозначение координационной оси выбирается вручную из контекстного меню поля Текст или задается в диалоге ввода текста.


3.3.8.12.2. Формирование обозначения

В поле Текст на Панели свойств отображается предлагаемое системой обозначение координационной оси.

Если поле Текст пусто, то обозначение координационной оси отсутствует. Текст обозначения может быть введен двумя способами.

– Способ 1

Если обозначение содержит только номер или букву, его удобнее сформировать с помощью контекстного меню поля Текст. В меню находятся следующие команды: Цифра, Буква и Добавить индекс ‘с’ (рис. 3.3.125).

Рис. 3.3.125. Контекстное меню поля Текст координационной оси

Чтобы создать обозначение марки, укажите нужный номер или букву в подменю команды Цифра или Буква.

Чтобы к обозначению добавить индекс, вызовите команду Добавить индекс «с».

В поле Текст отобразится выбранное обозначение.

Список букв, доступных в подменю Буква, а также порядок следования букв в списке определяются перечнем, заданным в пункте Координационные оси — Общие настройки диалога настройки текущего документа (см. раздел 3.3.8.2). Сдвоенные буквы в список не вводятся — они формируются автоматически после того, как использована последняя буква списка.

– Способ 2

Если необходимо ввести букву и номер или отредактировать текущее обозначение, следует вызвать диалог ввода текста (рис. 3.3.126), щелкнув левой кнопкой мыши в поле Текст или при помощи команды Текст надписи... из контекстного меню поля чертежа.

В диалоге показана структура надписи обозначения оси.

Обозначение (буква или номер), если оно было выбрано из подменю, находится в первом поле диалога, а индекс «с» — в третьем.

Введите или отредактируйте текст, учитывая следующее.

В первое поле вводится та часть обозначения, которая предполагает автопродолжение (см. раздел 3.3.8.12.1). Можно выбрать цифру или букву, дважды щелкнув в первом поле левой кнопкой мыши. На экране появится меню, которое содержит команды Цифра и Буква.

Рис. 3.3.126. Диалог ввода текста координационной оси

Кнопки со стрелками справа от поля ввода позволяют «листать» список обозначений в любом направлении. После одиночных предлагаются сдвоенные буквы.

Если в первую строку диалога ввода текста вводятся буква и номер, то при автопродолжении в обозначении изменится та его часть, которая стоит на первом месте. В случае если были введены сдвоенная буква и номер, то предлагаются следующая по порядку сдвоенная буква и прежний номер.

Во второе и третье поля вводится текст, который при автопродолжении не изменяется. Двойной щелчок в этих полях позволяет перейти к вставке текстового шаблона (см. раздел 4.1.2.11.6).

Пока диалог ввода текста находится на экране, на Панели свойств доступны элементы, а в Главном меню — команды, позволяющие работать с текстом. Некоторые из них можно вызвать из контекстного меню поля ввода диалога.

Если параметры текста (шрифт, высота, цвет и т.п.) у всех обозначений координационной оси отличаются от текущих умолчательных параметров, то рекомендуется не настраивать каждую надпись в отдельности, а установить требуемые параметры в качестве умолчательных. Для этого служит пункт Координационные оси — Текст диалога настройки текущего документа (см. раздел 3.3.8.2).


3.3.8.12.3. Параметры отрисовки

Чтобы настроить отрисовку координационной оси, активизируйте вкладку Параметры Панели свойств. Расположенные на ней элементы управления рассмотрены в таблице 3.3.28.

Табл. 3.3.28. Элементы управления отрисовкой координационной оси
Элемент | Описание
Тип марки | Группа переключателей, позволяющая выбрать вариант отрисовки марки. Активизируйте переключатель Окружность или Двойная окружность. Для прямых и дуговых осей марка заданного типа отрисовывается с обоих концов координационной оси.
Размер | Поле для выбора диаметра окружности обозначения марки координационных осей. Возможен также ввод значений диаметра с клавиатуры. Введенные значения будут добавляться в список и сохраняться в течение сеанса работы КОМПАС-3D. В случае отрисовки двойной окружности заданный размер определяет диаметр внешней окружности.
Пунктир | Поле для ввода или задания счетчиком длины пунктира.
Промежуток | Поле для ввода или задания счетчиком длины промежутков между пунктиром и штрихом.
Автоопределение | Опция, позволяющая выбрать способ отрисовки штрихпунктирной линии координационной оси. Если опция Автоопределение включена, то длина штриха вычисляется автоматически с соблюдением следующих условий: – длина штриха находится в диапазоне 5...30 мм; – координационные оси начинаются и заканчиваются штрихами; – начальная и конечная точки оси (т1 и т2) располагаются на штрихах.
 | Если опция Автоопределение выключена, то строится ось с длиной штриха, не превышающей значения, заданного в поле Штрих. При построении будет соблюдено условие, что оси начинаются и заканчиваются штрихами.
Штрих | Поле для ввода или задания счетчиком максимальной длины штрихов координационной оси. Поле доступно при выключенной опции Автоопределение.
Сохранять текст | Если опция Сохранять текст включена, то обозначение, текст до и текст после, заданные для текущей оси, будут предлагаться по умолчанию для остальных координационных осей этого же типа до конца сеанса работы.
По умолчанию | Если эта опция включена, то все текущие настройки вкладки Параметры Панели свойств будут использоваться при создании следующих координационных осей этого же типа до конца сеанса работы. Если опция выключена, настройка распространяется только на текущую координационную ось.

Умолчательные значения диаметра и ширины кольца устанавливаются в пункте Координационные оси — Общие настройки, а выбор способа построения штрихов оси и задание умолчательных параметров штрихпунктирной линии производятся в пункте Координационные оси — Параметры диалога настройки текущего документа (см. раздел 3.3.8.2).


3.3.8.12.4. Выступы

Настройка выступов координационной оси производится на вкладках Выступ 1 и Выступ 2 Панели свойств.

Рис. 3.3.127. Параметры выступа координационной оси: а) смещение, б) направление, в) смещение излома
а) | б) | в)

В таблице 3.3.29 описаны элементы управления вкладки Выступ 1, позволяющие настроить выступ за начальную точку. Настройка выступа за конечную точку производится таким же способом на вкладке Выступ 2.

Табл. 3.3.29. Элементы управления отрисовкой выступов координационной оси

Элемент

Описание

Выступ

Поле для задания величины выступа за начальную точку координационной оси.

Введите нужное значение или задайте его счетчиком.

Ввод нулевого значения означает отсутствие выступа.

Марка

Переключатель, позволяющий включать или выключать отрисовку марки в начале координационной оси.

Активизируйте переключатель, чтобы ось отрисовывалась с маркой на конце выступа1.

Если переключатель не активен, координационная ось строится без марки на конце выступа.

Смещение

Поле для задания величины смещения марки от координационной оси (см. рис. 3.3.127 а).

Введите или задайте счетчиком расстояние, на которое марка отстоит от координационной оси.

Введите ноль, если марка расположена на координационной оси.

Поле доступно, если активизирован переключатель Марка.

Направление

Группа переключателей, позволяющая выбрать, в какую сторону от координационной оси смещена марка (см. рис. 3.3.127 б).

Чтобы изменить направление смещения марки, активизируйте переключатель Направление 1 или Направление 2.

Переключатели доступны, если активизирован переключатель Марка.

Смещение
излома, %

Поле для задания величины, характеризующей положение точки излома относительно начальной точки оси (см. рис. 3.3.127 в).

Введите или задайте счетчиком отношение расстояния от точки т1 или т2 до точки излома ко всей величине выступа. Отношение задается в процентах:

C=(a/b) · 100, где

a, мм — расстояния от точки т1 или т2 до точки излома;

b, мм — величина выступа;

C, % — смещение излома.

Поле доступно, если активизирован переключатель Марка.

По умолчанию

Если эта опция включена, то все текущие настройки вкладки Выступ 1 Панели свойств будут использоваться при создании выступа за начальную точку следующих обозначений оси этого же типа до конца сеанса работы.

Если опция выключена, настройка распространяется только на текущую координационную ось.
  1. Чтобы построить цепочки марок, перейдите на вкладку Дополнительные обозначения (см. раздел 3.3.8.12.6).

Умолчательные значения величин выступа и смещения излома задаются в пункте Координационные оси — Параметры диалога настройки текущего документа (см. раздел 3.3.8.2).


3.3.8.12.5. Дополнительные обозначения

Элементами дополнительных обозначений координационной оси являются:

– указатели ориентации оси,

– цепочки марок,

– текстовые обозначения.

Дополнительные обозначения присоединяются к основной марке. Основная марка — марка, расположенная на оси. Если ось не имеет основных марок, создание дополнительных обозначений невозможно.

Рис. 3.3.128. Элементы дополнительных обозначений оси и точки их присоединения

Дополнительные обозначения могут быть созданы как в процессе построения, так и в режиме редактирования оси.

Чтобы создать дополнительные обозначения в процессе построения оси, выполните следующие действия.

1. Отключите режим автоматического создания объектов, отжав кнопку Автосоздание объекта на Панели специального управления.

2. Постройте обозначение координационной оси с основной маркой и введите текст обозначения.

3. Перейдите на вкладку Панели свойств Дополнительные обозначения (см. раздел 3.3.8.12.6). В группе Элементы активизируйте один из переключателей.

• Переключатель Добавить указатель ориентации оси позволяет добавить указатель ориентации оси. Указатель оси добавляется вместе с маркой.

• Переключатель Добавить марку позволяет добавить марку.

• Переключатель Добавить текст позволяет добавить текстовое обозначение в виде надписи.

После активизации переключателя на экране появляется фантом элемента, а в местах возможного присоединения дополнительных обозначений — черные точки (см. рис. 3.3.128).

Элемент Указатель ориентации оси строится по нормали к координационной оси со стрелкой, направленной от основной марки.

4. Настройте параметры Тип марки и Длина.

5. Введите текст создаваемого обозначения (см. раздел 3.3.8.12.7).

6. Укажите точку присоединения элемента мышью. Когда точка подсветится, щелкните левой кнопкой мыши.

7. Чтобы присоединить следующий элемент, активизируйте нужный переключатель в группе Элементы.

8. Для завершения построения нажмите кнопку Создать объект на Панели специального управления.

Чтобы добавить дополнительные обозначения к уже существующей оси, войдите в режим ее редактирования. Для этого дважды щелкните мышью по обозначению оси. Обозначение изменит цвет. Далее выполните действия, описанные выше в п.п. 3 — 8.

Чтобы отредактировать или удалить дополнительные обозначения, войдите в режим редактирования координационной оси и перейдите на вкладку Дополнительные обозначения Панели свойств. Щелкните по дополнительному обозначению мышью. Элемент изменит цвет. Введите новые параметры или удалите дополнительное обозначение.


3.3.8.12.6. Параметры отрисовки дополнительных обозначений

Чтобы настроить параметры отрисовки дополнительных обозначений координационных осей (прямых, дуговых, круговых), перейдите на вкладку Дополнительные обозначения Панели свойств.

– При создании оси элементы вкладки Дополнительные обозначения доступны, если режим автосоздания объектов отключен и указаны точки:

• т1 и т2 — для прямой оси,

• тС, т1 и т2 или тС, угол 1, угол 2 и радиус — для дуговой оси,

• тС и т — для круговой оси.

– В процессе редактирования элементы вкладки Дополнительные обозначения доступны всегда.

Расположенные на вкладке элементы управления рассмотрены в таблице 3.3.30.

Табл. 3.3.30. Элементы управления отрисовкой элементов дополнительных обозначений
Элемент | Описание
Элементы | Группа переключателей, позволяющая выбрать вид добавляемых элементов.
 | – Чтобы добавить указатель ориентации оси вместе с маркой, активизируйте переключатель Добавить указатель ориентации оси.
 | – Чтобы добавить марку, активизируйте переключатель Добавить марку.
 | – Чтобы добавить текстовое обозначение в виде надписи, активизируйте переключатель Добавить текст.
 | Чтобы добавить следующий элемент, необходимо вновь активизировать переключатель группы Элементы.
Тип марки | Группа переключателей, позволяющая выбрать вариант отрисовки добавляемой марки. Активизируйте переключатель Окружность или Двойная окружность. Переключатель Тип марки доступен, если активен переключатель Добавить указатель ориентации оси или Добавить марку.
Длина указателя | Поле для задания длины указателя ориентации оси. Введите ее или задайте счетчиком. Поле доступно, если активизирован переключатель Добавить указатель ориентации оси.
Текст | Поле, в котором отображается текст текущего дополнительного обозначения. Ввод текста описан в разделе 3.3.8.12.7.

Параметры стрелки и умолчательная длина указателя определяются значениями, заданными в пункте Координационные оси — Указатель ориентации диалога настройки текущего документа (см. раздел 3.3.8.2).


3.3.8.12.7. Ввод текста дополнительных обозначений

Для ввода надписи во время создания и редактирования дополнительных обозначений:

– указатель ориентации оси,

– марка,

– текст

служит диалог ввода текста, приведенный на рис. 3.3.129.

Рис. 3.3.129. Диалог ввода текста дополнительного обозначения координационной оси

При добавлении элементов Указатель ориентации оси и Марка для вызова диалога требуется щелкнуть мышью в поле Текст.

При добавлении элемента Текст диалог появляется автоматически после того, как указана точка присоединения обозначения.

Введите текст обозначения в поле ввода.

Если длина строки введенного текста окажется больше диаметра окружности марки, произойдет автоматическое сужение надписи.

В меню диалога находятся команды редактирования, вставки и форматирования текста. Некоторые из них можно вызвать из контекстного меню поля ввода диалога.

После завершения ввода текста нажмите кнопку ОК диалога.


3.3.8.13. Дуговая координационная ось

Чтобы создать обозначение дуговой координационной оси, вызовите команду Дуговая координационная ось.

Укажите точку центра дуги оси (тС). На экране появится фантом обозначения с умолчательными параметрами.

Введите текст надписи обозначения.

Чтобы при вводе текста производилось автоматическое присвоение номера марке, активизируйте переключатель Автопродолжение (см. раздел 3.3.8.12.1).

Подробнее о формировании обозначения координационной оси см. раздел 3.3.8.12.2.

Рис. 3.3.130. Дуговая координационная ось: а) пример использования, б) параметры оси
а) | б)

Укажите начальную (т1) и конечную (т2) точки оси или введите полярные координаты этих точек в поля Угол 1, Угол 2 и Радиус (или Диаметр).

По умолчанию при вводе параметра окружности система ожидает ввода радиуса. При этом в группе Параметр активен переключатель Радиус.

Чтобы ввести диаметр, активизируйте переключатель Диаметр.

Значения углов отсчитываются от оси ОХ текущей системы координат.

В случае построения оси при помощи мыши углы и радиус дуги будут определены автоматически и занесены в поля Угол 1, Угол 2 и поле текущего параметра — Радиус или Диаметр.

Группа переключателей Направление на Панели свойств управляет направлением построения дуги координационной оси — против часовой стрелки и по часовой стрелке.

При построении мышью после указания центра (тС) и начальной точки (т1) переключатель, соответствующий текущему положению фантома, активизируется автоматически.

Чтобы изменить направление, следует провести курсор вдоль оси через начальную точку (т1) или активизировать переключатель противоположного направления.

Если координаты начальной и конечной точек оси вводятся с клавиатуры, то группа переключателей Направление становится доступна после ввода значений в любые три поля Центр, Угол 1, Угол 2 или Радиус (или Диаметр).

В документе будет создана дуговая координационная ось, состоящая из дуги, ограниченной точками т1 и т2, и прямолинейных выступов. Выступы расположены по касательным к дуге оси.

Настройте параметры дуговой координационной оси на вкладках Параметры, Выступ 1, Выступ 2 Панели свойств. Дуговая и прямая оси имеют одинаковые параметры, настройка которых описана в разделе 3.3.8.12.3 и разделе 3.3.8.12.4.

Вы можете создать несколько обозначений за один вызов команды Дуговая координационная ось.

За один вызов команды Прямая координационная ось можно создать несколько координационных осей.

При построении осей с одинаковыми (частично или полностью) параметрами удобно воспользоваться командой Запомнить состояние. Пример создания координационных осей приведен в разделе 3.3.8.15.

Координационная ось может иметь дополнительные обозначения (см. рис. 3.3.124). Порядок их создания подробно описан в разделе 3.3.8.12.5.


3.3.8.14. Круговая координационная ось

Чтобы создать обозначение круговой координационной оси, вызовите команду Круговая координационная ось.

Укажите точку центра окружности оси (тС). На экране появится фантом обозначения с умолчательными параметрами.

Рис. 3.3.131. Круговая координационная ось: а) пример использования, б) параметры оси
а) | б)

Введите текст надписи обозначения.

Чтобы при вводе текста производилось автоматическое присвоение номера марке, активизируйте переключатель Автопродолжение (см. раздел 3.3.8.12.1).

Подробнее о формировании обозначения координационной оси см. раздел 3.3.8.12.2.

Укажите точку размещения марки (т). Точка т определяет величину радиуса окружности. В документе будет создана круговая координационная ось с радиусом, равным расстоянию от центра (тС) до точки размещения марки (т). При построении мышью радиус вычисляется автоматически и соответствующая величина заносится в поле текущего параметра — Радиус или Диаметр.

Настройте параметры круговой оси на вкладке Параметры Панели свойств (см. раздел 3.3.8.14.1).

За один вызов команды Круговая координационная ось можно создать несколько обозначений.

При построении осей с одинаковыми (частично или полностью) параметрами удобно воспользоваться командой Запомнить состояние. Пример создания координационных осей приведен в разделе 3.3.8.15.

Координационная ось может иметь дополнительные обозначения (рис. 3.3.132). Порядок их создания подробно описан в разделе 3.3.8.12.5.

Рис. 3.3.132. Элементы дополнительных обозначений круговой оси: а) указатель ориентации, б) марка, в) текст
а) | б) | в)

В этом разделе:

3.3.8.14.1. Параметры отрисовки


3.3.8.14.1. Параметры отрисовки

Чтобы настроить отрисовку круговой координационной оси, активизируйте вкладку Параметры Панели свойств.

Чтобы выключить отрисовку марки на координационной оси, активизируйте переключатель Марка.

Настройка умолчательного состояния переключателя Марка производится в пункте Координационные оси — Общие настройки диалога настройки текущего документа (см. раздел 3.3.8.2).

Остальные элементы управления настраиваются аналогично элементам управления прямых осей. Они рассмотрены в таблице 3.3.28.


3.3.8.15. Использование команды «Запомнить состояние» для построения осей

3.3.8.15. Использование команды «Запомнить состояние»
для построения осей

Чтобы построить несколько одинаковых координационных осей, можно воспользоваться командой Запомнить состояние, расположенной на Панели специального управления.

Автоматическое создание объектов должно быть включено, т.е. кнопка Автосоздание объектов на Панели специального управления должна быть нажата.

В этом разделе:

3.3.8.15.1. Прямые оси

3.3.8.15.2. Дуговые оси

3.3.8.15.3. Круговые оси


3.3.8.15.1. Прямые оси

Для создания прямых осей, например, продольных или поперечных, выполните следующие действия.

1. Вызовите команду Прямая координационная ось. Не указывая точек т1 и т2, сделайте настройки на вкладках Параметры, Выступ 1, Выступ 2 Панели свойств.

2. Задайте и зафиксируйте значения в полях Угол и Длина на вкладке Координационная ось.

3. Нажмите кнопку Запомнить состояние.

4. Введите обозначение оси и активизируйте переключатель Автопродолжение.

5. Укажите последовательно начальные точки (т1) новых координационных осей.

Чтобы создать сетку прямых координационных осей (например, c шагом 25 мм по оси OX и 37 мм по оси OY), выполните следующие действия.

1. Выполните п.п. 1–4 предыдущей последовательности действий, задав значение 0 в поле Угол.

2. Укажите начальную точку первой горизонтальной оси мышью или введя координаты в поле т1.

3. Не сдвигая мышь, активизируйте поле т1 и увеличьте текущее значение координаты Y на 37. Для этого последовательно нажмите следующие клавиши (комбинации клавиш):

<Alt>+<1>, <Tab>, <End>, <+>, <3>, <7>, <Enter>.

Будет построена новая ось, смещенная на 37 мм вверх относительно первой оси. Чтобы построить очередную ось, нажмите (не сдвигая мышь) указанные клавиши еще раз и т.д.

4. Задайте значение 90 в поле Угол, зафиксируйте его и введите номер оси.

5. Укажите начальную точку первой вертикальной оси мышью или введя координаты в поле т1.

6. Не сдвигая мышь, нажмите последовательно клавиши (комбинации клавиш):

<Alt>+<1>, <End>, <+>, <2>, <5>, <Enter>.

Чтобы построить очередную ось, нажмите (не сдвигая мышь) указанные клавиши еще раз и т.д.


3.3.8.15.2. Дуговые оси

Для создания дуговых осей, например, в виде дуг концентрических окружностей, выполните следующие действия.

1. Вызовите команду Дуговая координационная ось. Не указывая точек тС, т1 и т2, сделайте настройки на вкладках Параметры, Выступ 1, Выступ 2 Панели свойств.

2. Задайте и зафиксируйте значения в полях Угол 1 и Угол 2 на вкладке Координационная ось. Укажите точку центра.

3. Нажмите кнопку Запомнить состояние.

4. Введите обозначение оси и активизируйте переключатель Автопродолжение.

5. Укажите последовательно мышью точки концов радиусов новых координационных осей или последовательно задайте значения в поле Радиус.

Чтобы построить две группы концентрических дуговых осей, симметричные относительно прямой (например, оси OY), выполните следующие действия.

1. Постройте первую группу осей, выполнив п.п. 1–5 предыдущей последовательности действий.

2. Отредактируйте значение в поле Угол 1, преобразовав его в разность между 180 и текущим значением. Для этого активизируйте поле и, не меняя текущего значения, введите перед ним символы 180- и нажмите клавишу <Enter>.

3. Таким же образом отредактируйте значение в поле Угол 2.

4. Смените направление построения оси.

5. Активизируйте поле Центр щелчком по его названию и укажите центр новой группы осей.

6. Укажите последовательно мышью точки концов радиусов осей или последовательно задайте значения в поле Радиус.

Чтобы вторая группа осей располагалась симметрично первой относительно оси OX, при выполнении п. 2 достаточно поменять знаки чисел в полях Угол 1 и Угол 2 на противоположные.


3.3.8.15.3. Круговые оси

Для создания круговых осей, например, в виде концентрических окружностей, выполните следующие действия.

1. Вызовите команду Круговая координационная ось. Не указывая точек тС и т, сделайте настройки на вкладке Параметры Панели свойств.

2. Укажите мышью точку тС или задайте и зафиксируйте координаты центра в полях ввода Центр.

3. Нажмите кнопку Запомнить состояние.

4. Введите обозначение оси и активизируйте переключатель Автопродолжение.

5. Укажите последовательно точки расположения марок (т) новых координационных осей. Для точного позиционирования курсора воспользуйтесь привязками.


3.3.9. Автоматическое создание видов и гиперссылок

3.3. Размеры и обозначения

3.3.9. Автоматическое создание видов и гиперссылок

В этом разделе:

3.3.9.1. Автоматическое создание вида

3.3.9.1.1. Автоматически сформированное изображение выносного элемента и узла

3.3.9.2. Автоматическое создание гиперссылки


3.3.9.1. Автоматическое создание вида

После создания некоторых обозначений сразу запускается команда создания вида1— на Панели свойств появляются элементы управления параметрами вида. При необходимости измените параметры вида, а затем укажите точку привязки вида. В документе появится вид, надпись которого будет ассоциативно связана с только что созданным обозначением объекта оформления (подробнее см. раздел 3.6.4.6.2).

Данная возможность доступна при создании следующих обозначений:

– стрелка взгляда,

– линия разреза/сечения,

– выносной элемент,

– узел в сечении,

– узел.

Если обозначение создавалось в неассоциативном виде, то и новый вид неассоциативный. После создания обозначения выносного элемента или узла в виде автоматически формируется изображение выносного элемента или узла. В остальных случаях новый неассоциативный вид пуст.

Если обозначение создавалось в ассоциативном вида, то и новый вид ассоциативный:

– для стрелки взгляда — Вид по стрелке,

– для выносного элемента — Выносной элемент,

– для линии разреза/сечения — Разрез/сечение,

– для узла — Выносной элемент.

Получившийся ассоциативный вид содержит автоматически сформированное изображение модели, которое соответствует обозначению, т.е. вид по стрелке, разрез/сечение или выносной элемент.

После создания обозначения узла в сечении формируется неассоциативный вид.

Подробнее о видах см. раздел 3.6.1.2 (неассоциативные виды) и 3.7 (ассоциативные виды).

Автоматически сформированное изображение выносного элемента или узла имеет ряд особенностей, см. раздел 3.3.9.1.1.

  1. После создания машиностроительных обозначений вид формируется безусловно, а после создания строительных — только если при их настройке была включена опция Создать вид на Панели свойств.

В этом разделе:

3.3.9.1.1. Автоматически сформированное изображение выносного элемента и узла


3.3.9.1.1. Автоматически сформированное изображение выносного элемента и узла

Автоматически сформированное изображение выносного элемента или узла содержит копии объектов, попавших внутрь контура обозначения. Копируются следующие объекты:

– геометрические объекты,

– вставки рисунков, фрагментов и изображений из видов других чертежей,

– обозначения:

• обозначение центра,

• волнистая линия,

• линия с изломами,

• условное пересечение,

• автоосевая,

• осевая линия по двум точкам.

Остальные обозначения и размеры не копируются. Скопированные объекты нельзя отредактировать или удалить, но можно перенести их на другой слой и изменить их стиль.

Если вид, который является источником изображения для выносного элемента или узла, изменился, то выносной элемент или узел отмечается красной «галочкой» в Дереве чертежа, а в окне документа отображается перечеркнутым.

Чтобы обновить изображение, вызовите команду Вид — Перестроить. Если чертеж неассоциативный, для обновления выносного элемента можно также использовать команду Перестроить вид из его контекстного меню в Дереве чертежа.

Отображение границы выносного элемента зависит от того, какие объекты попали внутрь его:

– только линии, полученные проецированием модели (выносной элемент в ассоциативном чертеже) — отображаются лишь те участки контура, которые ограничивают проекцию; эти линии нельзя удалить или отредактировать, но можно изменить их стиль;

– объекты, созданные с помощью команд (выносной элемент в неассоциативном чертеже) — контур всегда отображается целиком; можно не только изменить стиль линии контура, но и отредактировать его (например, усечь) или удалить;

– как линии проекции модели, так и объекты, построенные с помощью команд (выносной элемент в ассоциативном чертеже с добавленными вручную объектами, например, осями) — отображается целый контур и наложенные на него участки контура, ограничивающие проекцию.

Если требуется восстановить контур (после изменения стиля, редактирования или удаления), вызовите команду Восстановить границу из контекстного меню выносного элемента, выделенного в Дереве чертежа или в окне документа.

Если контур выносного элемента был отредактирован или удален, то после изменения вида-источника и перестроения изображения контур автоматически восстанавливается.


3.3.9.2. Автоматическое создание гиперссылки

При создании нового обозначения

– стрелки взгляда,

– выносного элемента,

– линии разреза/сечения,

– узла,

– узла в сечении

может автоматически создаваться гиперссылка, связывающая обозначение с автоматически созданным видом.

Для автоматического создания гиперссылки необходимо выполнение следующих условий:

– при простановке обозначения был автоматически создан связанный с ним вид (см. раздел 3.3.9.1),

– в диалоге настройки гиперссылок была включена опция Автоматически создавать гиперссылки (см. раздел 9.1.2.7).

Если хотя бы одно из условий не выполнено, гиперссылка автоматически не создается. При необходимости можно создать гиперссылку, выделив объект и вызвав команду Гиперссылка... из меню Вставка или из контекстного меню (см. раздел 10.2.2.1).


3.4. Текст и таблицы

В этом разделе:

3.4.1. Текст в графическом документе

3.4.1.1. Надписи

3.4.1.1.1. Создание надписи

3.4.1.1.2. Редактирование надписи

3.4.1.1.3. Формат надписей на чертеже

3.4.1.2. Текстовая метка

3.4.1.2.1. Создание, редактирование и удаление текстовой метки

3.4.1.3. Тексты, входящие в состав сложных объектов

3.4.1.4. Ссылки

3.4.1.4.1. Создание ссылки

3.4.1.4.2. Особенности ссылок на объекты некоторых типов

3.4.1.4.3. Обновление ссылки

3.4.1.4.4. Редактирование ссылки

3.4.1.4.5. Разрушение ссылки

3.4.2. Таблицы в графическом документе

3.4.2.1. Создание таблицы

3.4.2.2. Вставка таблицы из файла

3.4.2.3. Редактирование таблицы

3.4.2.4. Названия и нумерация таблиц


3.4.1. Текст в графическом документе

3.4. Текст и таблицы

3.4.1. Текст в графическом документе

Текстовыми объектами графического документа являются:

– надписи,

– тексты в составе сложных объектов (размеров и обозначений).

Общие принципы работы с текстом в КОМПАС-документах изложены в разделе 4.1.

Вы можете задать умолчательные параметры текста на чертеже. Для этого вызовите команду Сервис — Параметры... — Текущий чертеж (фрагмент).

Выберите пункт Шрифт по умолчанию в левой части появившегося диалога. Из списка в правой части диалога выберите шрифт, который будет по умолчанию использоваться для всех текстовых объектов текущего документа — как для надписей, так и для текстов в составе сложных объектов.

Чтобы выполнить отдельную настройку для текста надписей, выберите пункт Текст на чертеже в левой части диалога. Элементы управления, появившиеся в его правой части, позволяют настроить параметры шрифта, абзаца и табуляции (см. раздел 9.2.6.15).

Если вы используете одни и те же параметры текста в большинстве графических документов, то выполнение соответствующей настройки в каждом документе нерационально. В этом случае можно сделать так, чтобы все новые документы сразу создавались с требуемыми параметрами текста.

Для этого вызовите команду Сервис — Параметры... — Новые документы — Графический документ.

Выбирая в левой части диалога пункты Шрифт по умолчанию и Текст на чертеже, вы можете настроить эти параметры для всех новых графических документов так же, как для текущего документа.

В этом разделе:

3.4.1.1. Надписи

3.4.1.1.1. Создание надписи

3.4.1.1.2. Редактирование надписи

3.4.1.1.3. Формат надписей на чертеже

3.4.1.2. Текстовая метка

3.4.1.2.1. Создание, редактирование и удаление текстовой метки

3.4.1.3. Тексты, входящие в состав сложных объектов

3.4.1.4. Ссылки

3.4.1.4.1. Создание ссылки

3.4.1.4.2. Особенности ссылок на объекты некоторых типов

3.4.1.4.3. Обновление ссылки

3.4.1.4.4. Редактирование ссылки

3.4.1.4.5. Разрушение ссылки


3.4.1.1. Надписи

В этом разделе:

3.4.1.1.1. Создание надписи

3.4.1.1.2. Редактирование надписи

3.4.1.1.3. Формат надписей на чертеже


3.4.1.1.1. Создание надписи

Чтобы создать произвольный фрагмент текста на чертеже или во фрагменте, вызовите команду Инструменты — Ввод текста.

Состав Главного меню изменится, а на Панели свойств появятся элементы, позволяющие настроить размещение надписи. Эти элементы представлены в таблице 3.4.1.

Табл. 3.4.1. Элементы управления размещением надписи на чертеже
Элемент | Описание
Точка привязки | Поля координат точки привязки текста.
Угол наклона | Угол наклона строк текста к горизонтали.
Размещение | Группа переключателей, позволяющая выбрать способ размещения текста относительно точки привязки (табл. 3.4.2).
Зеркальное отражение | Опция позволяет зеркально отразить текст внутри габаритного прямоугольника. При этом положение точки привязки надписи не изменяется.

Табл. 3.4.2. Способы размещения текста относительно точки привязки
Способ | Описание
Справа | Текст располагается с правой стороны от точки привязки. С этой точкой совпадает крайняя левая точка первой текстовой строки.
По центру | Текст располагается симметрично относительно точки привязки. С этой точкой совпадает центральная точка первой текстовой строки.
Слева | Текст располагается с левой стороны от точки привязки. С этой точкой совпадает крайняя правая точка первой текстовой строки.

После того как точка привязки текста указана, система переходит в режим ввода текста: на экране появляется рамка ввода, а на Панели свойств — вкладки Формат и Вставка.

Введите текст надписи, заканчивая набор каждой строки нажатием клавиши <Enter>. По умолчанию размер рамки ввода не фиксирован, и по мере набора она увеличивается так, чтобы вмещать текст полностью. При необходимости вы можете зафиксировать либо ширину, либо ширину и высоту рамки и установить правила размещения текста внутри нее (см. раздел 3.4.1.1.3).

При вводе текста на чертеже вы можете использовать все приемы, описанные в разделе 4.1.2, за исключением вставки вертикально текста и иллюстраций.

Чтобы зафиксировать надпись, нажмите кнопку Создать объект.

За один вызов команды Ввод текста вы можете создать несколько надписей с одинаковыми параметрами размещения. Закончив ввод первой надписи, переместите курсор за пределы рамки ввода и нажмите левую кнопку мыши. Предыдущая надпись автоматически зафиксируется, а в указанном вами месте откроется новая рамка ввода.


3.4.1.1.2. Редактирование надписи

Задание положения надписи с помощью характерных точек

Текстовая надпись имеет характерные точки двух типов.

– Точки перемещения надписи — позволяют переместить надпись в произвольном направлении.
Количество точек перемещения настраивается. Возможные варианты показаны на рис. 3.4.1. Подробнее о данной настройке см. раздел 9.1.7.12.

– Точки поворота надписи — позволяют повернуть надпись вокруг точки привязки, положение которой определяется выбранным способом размещения текста (см. табл. 3.4.2).
Количество точек поворота также зависит от способа размещения: надпись, размещенная способом Справа или Слева, имеет одну точку поворота, а способом По центру — две. Точки поворота отображаются вне габаритного прямоугольника текста на уровне первой строки. Например, на рис. 3.4.1, а) точка поворота — крайняя справа.

Рис. 3.4.1. Характерные точки текстовой надписи: а) вариант настройки 1, способ размещения Справа, б) вариант настройки 2, способ размещения Слева, в) вариант настройки 3, способ размещения По центру
а) | б) | в)

Активизация и перемещение характерных точек выполняются обычным образом (см. раздел 3.5.1.1.3).

Изменение текста и положения надписи

Чтобы изменить текст и параметры размещения надписи, выполните следующие действия.

1. Дважды щелкните мышью по нужной надписи. На Панели свойств появятся вкладки Формат и Вставка, а текст надписи станет доступным для редактирования.

2. Отредактируйте текст и/или измените его параметры. Для этого используются все приемы, описанные в разделе 4.1.2, за исключением вставки вертикального текста и иллюстраций.

3. Чтобы изменить параметры размещения надписи, вызовите из ее контекстного меню команду Редактировать размещение. В окне документа появится габаритный прямоугольник надписи, а на Панели свойств — вкладка Размещение.

4. Измените необходимые параметры размещения надписи: угол наклона строк текста, способ размещения надписи, вид отображения текста — обычный или зеркальный.

На последнем этапе укажите в окне документа положение точки привязки или задайте ее координаты. Система вернется в режим ввода текста.

5. Подтвердите произведенные изменения, нажав кнопку Создать объект или щелкнув мышью вне рамки редактирования текста.

Применение команд редактирования к надписи

К надписям можно применять следующие команды редактирования:

– Сдвиг (см. раздел 3.5.2),

– Поворот (см. раздел 3.5.4.1),

– Симметрия (см. раздел 3.5.4.3),

– Копирование (см. раздел 3.5.3).


3.4.1.1.3. Формат надписей на чертеже

Чтобы задать параметры размещения и стиль надписи на чертеже или во фрагменте, в режиме ввода текста вызовите команду Параметры форматирования, нажав соответствующую кнопку на вкладке Формат Панели свойств.

На экране появится диалог форматирования текста (рис. 3.4.2). Элементы управления этого диалога приведены в табл. 3.4.3.

Рис. 3.4.2. Диалог форматирования текста

Табл. 3.4.3. Диалог форматирования текста

Элемент

Описание

Стиль всего текста по умолчанию

Поле, содержащее название стиля текста, применяемого по умолчанию для надписей на чертеже.

Изменить

Кнопка, позволяющая выбрать стиль для текущей надписи. После ее нажатия на экране появится диалог выбора стиля текста (табл. 4.1.7).

При назначении другого стиля весь текст текущей надписи будет переформатирован в соответствии с новым стилем. Остальные надписи на чертеже не изменятся.

Если требуется использовать разные стили для разных частей надписи, используйте команду Стиль (см. раздел 4.1.2.7.1). Отформатировать отдельные части надписи можно также с помощью команд Абзац и Шрифт (см. разделы 4.1.2.5.1 и 4.1.2.1).

Высота,
Ширина

Поля для ввода габаритов прямоугольной области, ограничивающей текст (рамки ввода).

Доступны при активизации переключателей Изменение сужения текста (или Форматирование строк) и Изменение шага строк в группах Отслеживание размеров по горизонтали и Отслеживание размеров по вертикали соответственно.

Отслеживание размеров
по горизонтали/ вертикали

Группы переключателей, позволяющие установить способ расположения текста внутри рамки ввода. Эти способы подробно описаны в таблицах 3.4.4 и 3.4.5.

Табл. 3.4.4. Отслеживание размеров по горизонтали
Способ | Описание
Перенос правой границы | Правая граница рамки ввода перемещается, отслеживая длину вводимых строк. Переход к новой строке возможен только по нажатию клавиши <Enter>.
Изменение сужения текста | Правая граница рамки ввода жестко фиксируется. Подгонка длины строки к ширине рамки выполняется путем изменения сужения символов. Переход к новой строке возможен только по нажатию клавиши <Enter>.
Форматирование строк | Правая граница рамки ввода жестко фиксируется. Перенос текста со строки на строку выполняется автоматически.

Табл. 3.4.5. Отслеживание размеров по вертикали
Способ | Описание
Перенос нижней границы | Нижняя граница рамки ввода перемещается, отслеживая вертикальный размер текстового фрагмента.
Изменение шага строк | Нижняя граница рамки ввода жестко фиксируется. Подгонка общей высоты текста к высоте рамки выполняется путем уменьшения шага строк.


3.4.1.2. Текстовая метка

Объекты на чертеже или во фрагменте можно отметить с помощью текстовой метки. Такая необходимость возникает, например, при указании обозначения шероховатости поверхности после покрытия: к знаку шероховатости добавляется звездочка «*», а в технических требованиях чертежа делается запись * Размеры и шероховатость поверхности после покрытия.

Текстовую метку можно добавить к следующим объектам:

– обозначению допуска формы,

– знаку шероховатости,

– обозначению базовой поверхности.

Объект с текстовой меткой воспринимается системой (выделяется, перемещается, копируется, удаляется) как единое целое. При этом текстовая метка может редактироваться отдельно от своего объекта.

Параметры метки (в том числе умолчательный текст) можно настроить см. раздел 9.2.6.16.

В этом разделе:

3.4.1.2.1. Создание, редактирование и удаление текстовой метки


3.4.1.2.1. Создание, редактирование и удаление текстовой метки

Чтобы добавить текстовую метку, выделите объект и вызовите из контекстного меню команду Добавить текстовую метку. К объекту будет добавлена метка с умолчательным текстом.

Вы можете изменить текст и/или положение текстовой метки в процессе ее редактирования. Кроме того, для изменения положения метки можно использовать характерные точки. Эти действия выполняются для текстовой метки также, как для надписи в графическом документе, см. раздел 3.4.1.1.2.

Отредактировать текстовую метку также можно в соответствующем поле окна Свойства. Работа с этим окном описана в разделе 3.5.1.2.1.

Если текстовая метка или ее часть закрыта объектом, к которому она добавлена, «перетащите» метку в нужное положение с помощью характерной точки.

Чтобы удалить текстовую метку, вызовите из контекстного меню выделенного объекта команду Удалить текстовую метку.


3.4.1.3. Тексты, входящие в состав сложных объектов

При вводе надписей, входящих в состав размеров и обозначений, доступны основные возможности форматирования текста и вставки объектов.

Сами команды форматирования и вставки выполняются обычным образом (см. раздел 4.1.2). Различия имеются только в способах доступа к ним.

При вводе надписей, входящих в состав обозначений, команды вставки и форматирования можно вызвать теми же способами, что и при вводе надписей — с помощью Главного меню, Инструментальных панелей и переключателей Панели свойств.

При вводе размерных надписей доступ к командам вставки и форматирования осуществляется с помощью разделов Вставка и Формат в меню диалога ввода надписи (см. рис. 3.3.4).


3.4.1.4. Ссылки

Ссылка — это текст, ассоциативно связанный с каким-либо другим объектом, содержащим текст. Объект, с которым связана ссылка, называется источником ссылки.

При использовании одного и того же источника содержимое ссылки может быть различным: текст источника, номер листа, на котором он расположен и др.

Благодаря наличию ассоциативной связи между ссылкой и источником содержимое ссылки автоматически изменяется при изменении источника.

Например, знак маркировки может содержать ссылку на номер пункта технических требований, указывающего способ и шрифт маркировки. При смене номера пункта (в результате удаления или добавления пунктов перед ним) ссылка обновляется. Благодаря этому обозначение всегда будет содержать правильный номер пункта техтребований.

В КОМПАС-3D возможно формирование ссылок между текстовыми объектами, находящимися в одном и том же графическом документе.

Ссылки можно включать в следующие текстовые объекты:

– технические требования,

– текст на чертеже,

– ячейки таблицы на чертеже,

– надписи в обозначениях,

– ячейки основной надписи.

Источниками могут служить следующие объекты:

– объекты оформления (обозначение базы, стрелка взгляда, обозначение позиции и т.п.),

– текст на чертеже,

– вид,

– пункт технических требований,

– переменная,

– свойства документа или объекта (см. раздел 5.1.3.1),

– номер объекта в группе нумерации (см. раздел 3.10.1.1),

– ассоциативный отчет (в том числе отчет по массиву с таблицей изменяемых переменных), ассоциативная таблица исполнений.

Ссылки выделяются на чертеже цветом, заданным при настройке текстовых элементов (см. раздел 9.1.3.5). По умолчанию рабочие ссылки отображаются синим цветом.

Пока связь между ссылкой и ее источником сохраняется, редактирование содержимого ссылки невозможно: оно всегда соответствует тексту источника или зоне его расположения. При удалении источника ссылки связь между ним и ссылкой разрывается. Ссылки с разорванной связью («нерабочие ссылки») по умолчанию отображаются красным цветом. Автоматическое восстановление ссылки возможно только путем отмены удаления объекта-источника с помощью команды Редактор — Отменить. Если отменить удаление уже нельзя, то потребуется создать объект-источник заново и отредактировать (см. раздел 3.4.1.4.4) ссылку.

При необходимости вы можете принудительно удалить связь между ссылкой и ее источником (см. раздел 3.4.1.4.5).

Ссылка остается рабочей, если ее источник не отображается на экране. Например, источником ссылки может являться скрытое проекционное обозначение либо объект, находящийся в погашенном виде или слое.

Цвета, заданные при настройке текстовых элементов, применяются только для отображения ссылок, расположенных в текущем слое фрагмента или в текущем слое текущего вида чертежа. Ссылки, находящиеся в других видимых видах и слоях, не выделяются. Они отображаются теми же цветами, что и остальные объекты этих видов и слоев. Для печати надписей, содержащих ссылки, используются цвета, заданные при настройке параметров вывода.

В результате создания в чертеже объектов оформления (стрелок взгляда, линий разреза, обозначений выносных элементов, узлов и узлов в сечении) в нем автоматически формируются виды, надписи которых содержат ссылки на соответствующие объекты оформления.

В свою очередь, при создании и редактировании указанных объектов оформления можно включить автоматическое добавление в обозначение этих объектов ссылок на номер листа и/или обозначение зоны, где расположен соответствующий вид.

Подробно об ассоциативной связи между надписью вида и обозначением объекта оформления рассказано в разделе 3.6.4.6.2.

В этом разделе:

3.4.1.4.1. Создание ссылки

3.4.1.4.2. Особенности ссылок на объекты некоторых типов

3.4.1.4.3. Обновление ссылки

3.4.1.4.4. Редактирование ссылки

3.4.1.4.5. Разрушение ссылки


3.4.1.4.1. Создание ссылки

Чтобы вставить в текст ссылку, вызовите команду Вставка — Ссылка.

На экране появится диалог, показанный на рис. 3.4.3. Настройте параметры ссылки, используя элементы управления этого диалога (табл. 3.4.6) и нажмите кнопку ОК для вставки ссылки в текст.

Рис. 3.4.3. Диалог настройки ссылки

Табл. 3.4.6. Диалог настройки ссылки

Элемент

Описание

Тип источника

Список, позволяющий выбрать тип объекта-источника ссылки.

Ссылка на

Список, позволяющий указать, что будет являться содержимым ссылки.

Набор вариантов содержимого ссылки зависит от типа источника. Для большинства источников возможна ссылка на текст, обозначение зоны и номер листа.

Если тип источника — Вид, то создание ссылок имеет определенные особенности (см. табл. 3.4.7).

Если источник размещается в нескольких зонах, то при создании ссылки на обозначение зоны местоположением источника считается только одна из зон (см. табл. 3.4.8).

В скобках

Опция, позволяющая заключить содержимое ссылки в скобки.

Количество знаков после запятой

Список появляется в диалоге, если источником ссылки является Переменная, и заменяет собой опцию В скобках.

Список становится доступен, если в списке Ссылка на: выбран вариант Значение или Имя = значение.

Список позволяет указать количество знаков после запятой, отображающихся в числовом значении ссылки на переменную.

Значение переменной округляется до указанного знака.

Если выбран 0, то в ссылке отображается округленное целое число.

По умолчанию количество знаков после запятой равно заданному в диалоге настройки представления чисел (см. раздел 9.1.3.5). Максимальное количество знаков — 6.

Угловые величины в ссылках на переменную представляются в десятичной системе счисления.

Список
источников

Список, в котором отображаются тексты всех имеющихся в документе источников выбранного типа.

Источники приведены в списке подряд. Источник, содержащий несколько строк текста или несколько полок, на которые возможно сделать ссылки, отображается в списке следующим образом: первая строка — без отступа, подобно источнику с одной строкой, а вторая и последующие строки будут иметь отступ слева. Например, если одно обозначение позиции содержит несколько полок с номерами, то при ссылке на номер позиции в списке отобразятся все номера этого обозначения — первый номер без отступа, а остальные с отступом.

Чтобы указать нужный источник, выделите его текст в списке. Выбранный источник выделяется также в окне графического документа (кроме пунктов технических требований).

Просмотр

В этом поле отображается создаваемая ссылка в том виде, в каком она будет вставлена в текст.

Если формирование ссылки с заданными параметрами невозможно (например, при попытке создать ссылку на текст под полкой линии-выноски, которая содержит только текст над полкой), то поле Просмотр пусто, а кнопка ОК недоступна.


3.4.1.4.2. Особенности ссылок на объекты некоторых типов

Вид чертежа

Особенности создания ссылки на вид чертежа обусловлены типом вида — ассоциативный или неассоциативный. Об ассоциативных видах рассказано в части 3.7. Варианты ссылки на вид чертежа представлены в табл. 3.4.7.

Табл. 3.4.7. Варианты содержимого ссылки на вид чертежа
Вариант содержимого ссылки | Описание
Масштаб | Содержимое ссылки — текущий масштаб вида.
Развернуто | Содержимое ссылки — знак «развернуто». Создание ссылки возможно: – если вид неассоциативный, то всегда, – если вид ассоциативный, то при следующих условиях: – для разреза/сечения и выносного элемента: если в опорном виде изображена развертка листовой детали; – для вида по стрелке: если в нем изображена развертка листовой детали.
Повернуто | Содержимое ссылки — знак «повернуто». Создание ссылки возможно: – если вид неассоциативный, то всегда, – если вид ассоциативный, то при условии, что угол поворота, заданный на вкладке Параметры, отличен от нуля1.
Повернуто на угол | Содержимое ссылки — знак «повернуто» и текущий угол поворота вида. Условия, при которых возможно создание ссылки — такие же, как для предыдущего варианта.
  1. Если поворот вида обусловлен наличием проекционной связи его с опорным видом (на вкладке Параметры активен переключатель Проекционная связь), то создание ссылки, содержащей угол поворота, невозможно.

Зона чертежа

Создание ссылки на зону чертежа, в которой находится выбранный источник ссылки, возможно, если разбиение на зоны в текущем чертеже включено (см. раздел 3.6.8). Во фрагменте разбиение на зоны невозможно, поэтому в нем невозможно и создание ссылки на зону.

Порядок определения содержимого ссылки для случаев, когда источник ссылки располагается в нескольких зонах чертежа, приведен в табл. 3.4.8.

Табл. 3.4.8. Определение зоны, в которой расположен источник ссылки
Тип источника | Зоной размещения считается
Обозначение базы | Зона, в которой расположена точка соединения рамки и линии-выноски.
Линия разреза | Зона, в которой расположена точка привязки буквы, обозначающей первую стрелку направления взгляда.
Стрелка взгляда | Зона, в которой расположена точка привязки буквы, обозначающей стрелку.
Фигурная скобка | Точка привязки текста; если текст на полке, то точка начала полки.
Текст, Таблица исполнений, Таблица отчета по массиву, Таблица отчета | Зона, в которой расположена точка привязки текста или таблицы.
Марка координационной оси | Зона, в которой расположена марка. Если включено отображение обеих марок оси, то — зона, в которой расположена первая марка.
Выносной элемент, Обозначение позиции, Линия-выноска, Обозначение узла, Выносная надпись, Обозначение узла в сечении, Марка/позиционное обозначение с линией-выноской | Зона, в которой расположена точка начала полки.

Технические требования

Если источником ссылки являются технические требования, то содержимым ссылки может быть только номер пункта технических требований. Поэтому для того, чтобы создание ссылки было возможно, необходимо выполнение следующих условий:

– каждый пункт технических требований является отдельным абзацем,

– для абзацев технических требований должна быть установлена нумерация.

Чтобы пронумеровать абзацы технических требований, войдите в режим их редактирования, выделите весь текст и вызовите команду Установить нумерацию. Подробнее о нумерованных списках рассказано в разделе 4.1.2.12.

Абзацы технических требований, пронумерованные вручную (т.е. номера введены с клавиатуры, а не созданы автоматически), фактически являются ненумерованными, поэтому создание ссылок на пункты технических требований в этом случае невозможно.

По умолчанию система настроена так, чтобы абзацы технических требований создавались нумерованными (см. раздел 9.2.6.19.6).


3.4.1.4.3. Обновление ссылки

Обновление ссылки — повторное формирование содержимого существующей ссылки.

Обновление ссылок производится автоматически после выполнения пользователем любых действий, приводящих к изменению текста объекта-источника (для ссылок, содержащих текст) или положения объекта-источника (для ссылок, содержащих обозначения зон). Кроме того, все ссылки безусловно обновляются при открытии и закрытии документа, а также при переходе в режим предварительного просмотра.


3.4.1.4.4. Редактирование ссылки

Редактирование ссылки — это изменение ее параметров. Чтобы отредактировать ссылку, выполните следующие действия.

1. Войдите в режим редактирования текста, содержащего ссылку.

2. Установите курсор мыши на ссылку и вызовите из контекстного меню команду Редактировать ссылку....

На экране появится тот же диалог, что и при создании ссылки (см. рис. 3.4.3 и табл. 3.4.6).

3. Внесите необходимые изменения и закройте диалог, нажав кнопку ОК.

4. Подтвердите редактирование текста.


3.4.1.4.5. Разрушение ссылки

Разрушение ссылки — удаление связи между ссылкой и ее источником. В результате разрушения содержимое ссылки становится обычным текстом, который можно редактировать вручную. Обновление разрушенной ссылки становится невозможным.

Чтобы разрушить ссылку, выполните следующие действия.

1. Войдите в режим редактирования текста, содержащего ссылку.

2. Установите курсор мыши на ссылку и вызовите из контекстного меню команду Разрушить ссылку.

3. Подтвердите редактирование текста.


3.4.2. Таблицы в графическом документе

3.4. Текст и таблицы

3.4.2. Таблицы в графическом документе

При работе с графическим документом вы можете создавать таблицы, а также вставлять таблицы из внешних файлов. Общие принципы работы с таблицами в КОМПАС-документах приведены в разделе 4.2.

В этом разделе:

3.4.2.1. Создание таблицы

3.4.2.2. Вставка таблицы из файла

3.4.2.3. Редактирование таблицы

3.4.2.4. Названия и нумерация таблиц


3.4.2.1. Создание таблицы

Чтобы создать таблицу в чертеже или фрагменте, вызовите команду Инструменты — Ввод таблицы.

На Панели свойств появятся элементы управления размещением таблицы. Эти элементы представлены в таблице 3.4.9.

Табл. 3.4.9. Элементы управления размещением таблицы
Элемент | Описание
Точка привязки | Поля координат точки привязки таблицы.
Угол наклона | Поле угла наклона строк таблицы к горизонтали.

После задания точки привязки таблицы на экране появится диалог создания новой таблицы (рис. 3.4.4).

Элементы управления этого диалога представлены в таблице 3.4.10.

Рис. 3.4.4. Диалог создания новой таблицы

Табл. 3.4.10. Диалог создания новой таблицы
Элемент | Описание
Число столбцов, Число строк | Поля для ввода количества столбцов и строк новой таблицы.
Ширина столбца, Высота строки | Поля для ввода размеров ячеек новой таблицы.
Располагать заголовок | Группа переключателей, управляющая созданием и расположением «шапки» (заголовка) таблицы. Самый распространенный пример — таблица с наименованиями параметров в заголовке и значениями самих параметров в ячейках.
Из файла | Кнопка, позволяющая вставить в документ готовую таблицу из внешнего файла (см. раздел. 3.4.2.2). После ее нажатия на экране появляется меню, в котором требуется указать тип файла, в котором хранится таблица. При вставке таблицы из файла настройка структуры таблицы, сделанная в данном диалоге, игнорируется.

Вновь созданная таблица, а также таблица, сформированная из фрагмента (см. раздел 3.4.2.2), размещается в документе так, чтобы ее верхний левый угол совпал с точкой привязки.

При редактировании таблицы положение ее верхнего левого угла может быть изменено, однако положение точки привязки таблицы остается постоянным.

Таблица, прочитанная из файла *.tbl (см. там же), размещается в документе так, чтобы ее точка привязки имела указанные координаты.

Курсор автоматически устанавливается в верхнюю левую ячейку новой таблицы. Вы можете вводить, редактировать и форматировать текст в ячейках, а также изменять структуру таблицы. Для этого используются приемы работы, описанные в разделе 4.2.2.

Чтобы зафиксировать таблицу, нажмите кнопку Создать объект.


3.4.2.2. Вставка таблицы из файла

Возможность вставки таблиц из внешних файлов позволяет многократно использовать однажды созданные типовые таблицы.

Вставка таблицы из файла в документ производится путем внедрения. Благодаря этому при передаче этого документа на другие рабочие места не нужно заботиться о передаче файла, из которого была вставлена таблица.

Табл. 3.4.11. Команды вставки таблицы из внешнего файла

Команда

Описание

Загрузить
из файла таблиц

Загрузка таблицы, сохраненной в файле *.tbl (файл таблицы КОМПАС-3D)1. После вызова команды на экране появляется диалог, в котором требуется указать нужный файл *.tbl.

Создать
из графического фрагмента

Создание таблицы из файла *.frw (файл фрагмента КОМПАС-3D). После вызова команды на экране появляется диалог, в котором требуется указать файл *.frw, содержащий изображение таблицы. После выбора и открытия фрагмента на экране появится диалог параметров создания таблицы (см. рис. 3.4.5), в котором можно настроить некоторые параметры генерируемой таблицы.

При автоматической генерации таблицы из графического фрагмента учитываются все существующие в нем тексты, горизонтальные и вертикальные отрезки. Другие объекты в формировании таблицы не участвуют. Стили текстов и отрезков сохраняются в получившейся таблице (в виде стилей текстов ячеек и стилей линий границ ячеек).
  1. О сохранении таблицы в файл *.tbl см. раздел 4.2.2.9.

Рис. 3.4.5. Диалог параметров создания таблицы

Табл. 3.4.12. Диалог параметров создания таблицы

Элемент

Описание

Использовать привязку к сетке

Опция, включение которой означает, что габариты ячеек будут дискретными (кратными какому-либо числу). При этом размеры ячеек таблицы, находящейся во фрагменте, будут округлены до ближайшего значения, кратного указанному шагу сетки.

При выключенной опции габариты ячеек получившейся таблицы будут совпадать с габаритами ячеек таблицы во фрагменте.

Шаг сетки для привязки
габаритов ячеек

Группа полей для ввода значений шага по горизонтали и по вертикали. Эта группа доступна, если привязка габаритов ячеек к сетке включена.

Стиль текста для незаполненных ячеек таблицы

Имя стиля текста, который будет использоваться по умолчанию при вводе текста в незаполненные во фрагменте ячейки таблицы1.

Изменить...

Кнопка, позволяющая назначить другой стиль для незаполненных ячеек. После ее нажатия на экране появляется диалог выбора стиля текста (см. табл. 4.1.7).
  1. Стиль текста заполненных ячеек сохраняется.


3.4.2.3. Редактирование таблицы

Вы можете изменить положение таблицы, ее структуру, а также текст, содержащийся в ней.

Положение таблицы изменяется с помощью характерной точки. Для этого установите на нее курсор, нажмите левую кнопку мыши и, не отпуская кнопку, перемещайте мышь. Характерная точка будет перемещаться вслед за курсором. Когда нужное положение таблицы будет достигнуто, отпустите кнопку мыши.

Если требуется изменить текст и/или структуру таблицы, задать точные параметры ее положения, выполните следующие действия.

1. Войдите в режим редактирования таблицы. Для этого дважды щелкните по ней мышью. На Панели свойств появятся вкладки Формат, Вставка и Таблица, а текст в ячейках таблицы станет доступным для редактирования.

2. Отредактируйте текст и/или измените структуру таблицы. Для этого используются приемы работы, описанные в разделе 4.2.2.

3. Чтобы изменить параметры размещения таблицы, вызовите из ее контекстного меню команду Редактировать размещение. В окне документа появится фантом таблицы, а на Панели свойств — вкладка Размещение.

4. Измените угол наклона таблицы. Задайте координаты точки привязки таблицы или укажите ее положение в окне документа. Система вернется в режим ввода текста.

5. Подтвердите произведенные изменения, нажав кнопку Создать объект или щелкнув мышью вне таблицы.

Кроме того, к таблицам можно применять следующие команды редактирования:

– Сдвиг (см. раздел 3.5.2),

– Поворот (см. раздел 3.5.4.1),

– Симметрия (см. раздел 3.5.4.3),

– Копирование (см. раздел 3.5.3).

Возможно также копирование и перенос таблиц через буфер обмена (см. раздел 3.1.2.5).


3.4.2.4. Названия и нумерация таблиц

В графическом документе таблица может иметь название, вводимое вручную, и/или номер, задаваемый автоматически. Название и номер вводятся независимо друг от друга. Ввод названия таблицы описан в настоящем разделе; об автоматической нумерации объектов см. раздел 3.10.1.

Чтобы задать таблице название, вызовите команду Название... из контекстного меню таблицы.

После вызова команды на экране появляется диалог ввода названия таблицы. Если таблица, например, ассоциативный отчет, разбита на несколько частей, то в диалоге содержатся поля ввода текста, количество которых равно числу таблиц (рис. 3.4.6).

Рис. 3.4.6. Диалог ввода названий ассоциативной таблицы

Введите в поля диалога названия для каждой таблицы по порядку.

Длина строки может превышать ширину таблицы. В этом случае автоматического сужения символов или переносов текста на новую строку не происходит. Для разбиения названия на строки используйте клавишу <Enter>, для перехода к названию другой таблицы — клавиши <↑>/<↓>.

На Панели свойств доступны элементы, а в Главном меню — команды, позволяющие работать с текстом. Некоторые команды можно вызвать из контекстного меню поля ввода диалога. Например, вы можете вставить спецзнак, символ, изменить параметры форматирования текста: шрифт, высоту, выравнивание и отступы абзацев и т.п.

Завершив ввод или редактирование названий, нажмите кнопку ОК диалога. Диалог закроется, а над таблицами появятся вновь заданные или измененные названия.

Чтобы отказаться от ввода или редактирования названий, нажмите кнопку Отмена.

Параметры текста названия в текущем документе можно настроить:

– для простых таблиц — в диалоге, вызываемом командой Сервис — Параметры — Текущий чертеж/фрагмент — Параметры таблицы — Название таблицы.

– для ассоциативных таблиц — в диалоге, вызываемом командой Сервис — Параметры — Текущий чертеж/фрагмент — Параметры таблицы отчета — Название таблицы.

Если для текущей таблицы применялась автоматическая нумерация, то номер (он может включать также текст перед номером), отображается в диалоге. Такой номер является ссылкой на номер таблицы в группе нумерации и недоступен для изменения. Если требуется, номер-ссылку можно удалить. При этом автоматическая нумерация текущей таблицы будет отменена.


3.5. Редактирование

В этом разделе:

3.5.1. Общие приемы редактирования

3.5.1.1. Редактирование объектов с помощью мыши

3.5.1.1.1. Перемещение объектов с помощью мыши

3.5.1.1.2. Копирование объектов с помощью мыши

3.5.1.1.3. Редактирование характерных точек

3.5.1.2. Изменение и копирование свойств объектов

3.5.1.2.1. Окно Свойства в графических документах

3.5.1.2.2. Копирование свойств

3.5.2. Сдвиг

3.5.2.1. Произвольный сдвиг

3.5.2.1.1. Управление исходными объектами

3.5.2.2. Сдвиг по углу и расстоянию

3.5.3. Копирование

3.5.3.1. Произвольная копия

3.5.3.1.1. Масштаб и поворот копий

3.5.3.2. Копия по кривой

3.5.3.2.1. Интерпретация шага

3.5.3.2.2. Расположение копий

3.5.3.2.3. Направление копирования

3.5.3.3. Копия по параллелограммной сетке

3.5.3.4. Копия по концентрической сетке

3.5.3.4.1. Расположение копий

3.5.3.5. Копия по окружности

3.5.4. Преобразования объектов

3.5.4.1. Поворот

3.5.4.2. Масштабирование

3.5.4.2.1. Управление масштабированием выносных линий

3.5.4.3. Симметрия

3.5.4.3.1. Указание существующей оси симметрии

3.5.4.4. Преобразование в NURBS

3.5.5. Деформация

3.5.5.1. Выбор объектов для деформации

3.5.5.2. Деформация сдвигом

3.5.5.3. Деформация поворотом

3.5.5.4. Деформация масштабированием

3.5.6. Разбиение объектов на части

3.5.6.1. Разбить кривую на две части

3.5.6.2. Разбить кривую на несколько равных частей

3.5.7. Удаление частей объектов. Продление объектов

3.5.7.1. Усечение кривых

3.5.7.2. Усечение кривых по указанным точкам

3.5.7.3. Выравнивание по границе

3.5.7.4. Удлинение до ближайшего объекта

3.5.7.5. Удаление фасок и скруглений

3.5.7.6. Очистка области

3.5.7.7. Удаление частей объектов оформления и библиотечных макроэлементов

3.5.7.8. Очистка фона

3.5.8. Удаление объектов

3.5.8.1. Удаление вспомогательных объектов

3.5.8.2. Удаление всех объектов документа

3.5.8.3. Удаление объектов оформления


3.5.1. Общие приемы редактирования

3.5. Редактирование

3.5.1. Общие приемы редактирования

КОМПАС-3D предоставляет пользователю разнообразные возможности редактирования объектов.

– Наиболее простые и часто используемые приемы редактирования — перемещение и копирование объектов, сдвиг характерных точек — можно выполнять с помощью мыши. Приемы редактирования описаны в разделе 3.5.1.1.

– Изменение и копирование свойств объектов осуществляются при помощи окна Свойства. Приемы работы со свойствами объектов описаны в разделе 3.5.1.2.

– Действия с объектами, такие как удаление части объекта, преобразование объектов, копирование по сетке и т.д., выполняются при помощи специальных команд.

Команды редактирования геометрических объектов сгруппированы в меню Редактор, а кнопки для вызова команд — на панели Редактирование (рис. 3.5.1).

Рис. 3.5.1. Панель Редактирование

Перед вызовом команд сдвига, поворота, масштабирования, преобразования симметрии и копирования требуется выделить объекты, участвующие в операции (о выделении объектов см. раздел 3.1.2). Работа команд редактирования описана в разделах 3.5.2 – 3.5.8.

Кроме того, можно отредактировать параметры объекта — для этого следует дважды щелкнуть мышью по объекту либо, выделив его, нажать клавишу <Enter> или <Пробел> (курсор не должен находиться над объектом). На Панели свойств появляется тот же набор управляющих элементов, что и при создании объекта. Вы можете отредактировать параметры объекта: изменить любые его свойства и характеристики.

Иногда бывает нужно отредактировать только текст, входящий в состав объекта — размерную надпись, текст фигурной скобки, текст обозначения шероховатости и т.п. В таких случаях удобно сразу вызвать диалог ввода надписи, без запуска процесса редактирования объекта. Это можно сделать следующими способами:

– дважды щелкнуть мышью на надписи (именно на ней, а не на линиях или точках, составляющих объект);

– выделить объект, переместить курсор так, чтобы он не находился над этим объектом, и нажать комбинацию клавиш <Shift> + <Enter> или <Shift> + <Пробел>.

На панели Редактирование находятся кнопки вызова команд Удалить разрыв линии мультилинии и Удалить все разрывы указанной линии мультилинии. О работе с ними рассказано в разделе 3.2.12.11.

Объекты могут копироваться как вместе с атрибутами и свойствами, так и без них. Подробно копирование объектов с атрибутами описано в разделе 11.5.3.3, копирование объектов с заданными пользователем свойствами — в разделе 5.1.4.3.

Такие свойства объектов, как слой, стиль линии, стиль текста и т.п., можно копировать между объектами, т.е. переносить с одного объекта на другой (см. раздел 3.5.1.2.2).

В этом разделе:

3.5.1.1. Редактирование объектов с помощью мыши

3.5.1.1.1. Перемещение объектов с помощью мыши

3.5.1.1.2. Копирование объектов с помощью мыши

3.5.1.1.3. Редактирование характерных точек

3.5.1.2. Изменение и копирование свойств объектов

3.5.1.2.1. Окно Свойства в графических документах

3.5.1.2.2. Копирование свойств


3.5.1.1. Редактирование объектов с помощью мыши

В этом разделе:

3.5.1.1.1. Перемещение объектов с помощью мыши

3.5.1.1.2. Копирование объектов с помощью мыши

3.5.1.1.3. Редактирование характерных точек


3.5.1.1.1. Перемещение объектов с помощью мыши

Чтобы переместить объекты мышью, выполните следующие действия.

1. Выделите объекты, которые нужно сдвинуть. О выделении геометрических объектов см. раздел 3.1.2, видов — раздел 3.6.5.4.

2. Установите курсор на одном из выделенных объектов (но не на характерной точке), и нажмите левую кнопку мыши.

3. Удерживая кнопку мыши нажатой, «перетаскивайте» объекты. На экране отображается их фантом, следующий за курсором.

4. После того как нужное положение объектов достигнуто, отпустите кнопку мыши.

Объекты будут удалены с прежних мест и помещены в новые.


3.5.1.1.2. Копирование объектов с помощью мыши

Чтобы скопировать объекты мышью, выполните следующие действия.

1. Выделите объекты, которые нужно скопировать.

2. Нажмите клавишу <Ctrl>.

3. Не отпуская клавишу <Ctrl>, установите курсор на одном из выделенных объектов (но не на характерной точке), нажмите левую кнопку мыши и переместите мышь.

4. Отпустите клавишу <Ctrl> и кнопку мыши.

На экране отображается фантом перемещаемых объектов, следующий за курсором.

5. Перемещайте мышь, пока не будет достигнуто нужное положение объектов, затем щелкните левой кнопкой.

Объекты будут скопированы в указанное место, а оригиналы останутся в прежнем положении.

Вы можете продолжать копирование, фиксируя положение очередной копии.

6. Чтобы завершить копирование, нажмите клавишу <Esc>.


3.5.1.1.3. Редактирование характерных точек

Конфигурацию и положение объекта можно изменить, перемещая ту или иную его характерную точку.

Для перехода в режим редактирования объекта следует щелкнуть по нему мышью.

В этом режиме характерные точки отображаются в виде маленьких черных квадратов, а объект выделяется.

Рис. 3.5.2. Характерные точки: а) отрезка, б) окружности, в) сплайна, г) допуска формы, д) текста
а) | б) | в) | г) | д)

Характерные точки дуги дополнены черными треугольными значками, при перемещении которых изменяется только радиус дуги.

Рис. 3.5.3. Характерные точки дуги

При подведении к характерной точке курсор принимает следующую форму:

— если характерную точку можно перемещать произвольно,

— если перемещение характерной точки ограничено или если она может иметь лишь несколько определенных положений,

— если перемещение характерной точки приводит к повороту объекта или его части.

Если при выделении нескольких объектов их характерные точки совпадают, то они отображаются в виде общей характерной точки. При перемещении общей характерной точки перемещаются соответствующие характерные точки каждого объекта. Настройка отображения общих характерных точек и количества выделенных объектов описаны в разделе 9.1.7.12.

Для перемещения точки могут использоваться следующие способы:

– «Перетаскивание» мышью точки выделенного объекта,

– Активизация точки и указание ее нового положения.

Способы перемещения характерных точек описаны ниже.

Чтобы снять выделение с объекта после перемещения характерных точек, щелкните мышью вне изображения этого объекта. Когда выделение c объекта снимается, исчезают и его характерные точки.

«Перетаскивание» мышью точки выделенного объекта

Для «перетаскивания» характерной точки установите на нее курсор, нажмите левую кнопку мыши и, не отпуская кнопку, перемещайте мышь. Характерная точка будет перемещаться вслед за курсором. Когда нужное положение точки будет достигнуто, отпустите кнопку мыши.

Если включено округление (см. раздел 1.4.2.15), то при перемещении характерной точки объекта изменение его линейных и угловых параметров происходит дискретно — с шагом, равным шагу курсора. Текущие значения параметров отображаются рядом с курсором. Фон надписей рядом с курсором можно настроить (см. раздел 9.1.3.3).

Если, установив курсор на характерной точке и нажав кнопку мыши, не сдвигать мышь в течение секунды, то на экране появляются вспомогательные траектории. При перемещении характерной точки вдоль вспомогательной траектории изменяется только один параметр объекта (рис.3.5.4).

Рис. 3.5.4. Вспомогательные траектории: а) начальное положение характерной точки, б) «перетаскивание» характерной точки вдоль траектории
а) | б)

Если при «перетаскивании» характерной точки курсор удаляется от вспомогательной траектории, то ее изображение исчезает с экрана.

Чтобы при «перетаскивании» характерных точек вспомогательные траектории постоянно отображались, нажмите и удерживайте клавишу <Сtrl>.

Чтобы отключить отображение вспомогательных траекторий при «перетаскивании» характерных точек, нажмите и удерживайте клавишу <Alt>.

Вспомогательные траектории отображаются при редактировании:

– отрезка,

– мультилинии,

– дуги,

– эллипса, дуги эллипса,

– прямоугольника.

Активизация точки и указание ее нового положения

Активизация точки осуществляется мышью — щелчком левой кнопки или при помощи клавиатуры — нажатием клавиши <Enter>.

После активизации запускается процесс сдвига точки. Активизированная точка подсвечивается, а рядом с курсором появляется нулевое значение параметров сдвига. Система ожидает указания положения точки, которая стала «связана» с курсором. При движении курсора рядом с ним отображаются изменения координат, расстояния и угла относительно исходного положения точки.

Укажите новое положение точки одним из способов:

– щелкните мышью в нужном месте документа,

– задайте значения параметров сдвига на Панели свойств,

– переместите точку при помощи клавиш со стрелками и зафиксируйте точку,

– введите координаты курсора на панели Текущее состояние (см. раздел 1.4.1.1) и зафиксируйте точку.

Фиксация точки производится щелчком мыши или нажатием клавиши <Enter>.

Вы можете ограничивать перемещение точки, фиксируя необходимый параметр на Панели свойств. Например, чтобы сдвинуть точку в направлении оси X, задайте нулевое значение в поле координаты Y и зафиксируйте его. На экране отобразится фантом прямой, вдоль которой возможно перемещение точки.

При указании положения точки вы можете использовать привязки (см. раздел 3.1.1) и геометрический калькулятор (см. раздел 1.4.2.13.1).

После фиксации точки процесс сдвига завершается автоматически.

Чтобы прекратить процесс без сдвига, нажмите кнопку Прервать команду на Панели специального управления или нажмите клавишу <Esc>.


3.5.1.2. Изменение и копирование свойств объектов

Вы можете просматривать и изменять свойства выделенных объектов, не прибегая к редактированию каждого из них в отдельности, а также копировать свойства между объектами.

Изменять и копировать можно следующие свойства объектов:

– слой, на котором расположен объект,

– некоторые параметры, которые задаются на Панели свойств во время создания или редактирования этого объекта,

– текст, входящий в состав объекта,

– стиль текста, параметры шрифта и параметры абзаца,

– признак языка для проверки правописания,

– гиперссылки.

Для изменения свойств выделенных объектов, а также для просмотра свойств источника и выбора копируемых свойств служит окно Свойства. Приемы работы в нем во время изменения и копирования свойств различаются.

Окно Свойства и общий порядок изменения свойств описаны в разделе 1.4.2.2. Особенности работы в окне Свойства для графических документов рассмотрены в разделе 3.5.1.2.1, копирование свойств между объектами — в разделе 3.5.1.2.2.

В этом разделе:

3.5.1.2.1. Окно Свойства в графических документах

3.5.1.2.2. Копирование свойств


3.5.1.2.1. Окно Свойства в графических документах

Рис. 3.5.5. Свойства дуги

Окно Свойства отображается на экране после вызова команды Редактор — Свойства или нажатия кнопки Свойства на Стандартной панели.

Команду Свойства удобно вызывать из контекстного меню выделенных объектов.

Элементы управления окна Свойства и порядок изменения свойств описаны в разделе 1.4.2.2.

Работа в графических документах имеет следующие особенности.

– Для указания объектов можно использовать кнопку Выделить по свойствам на инструментальной панели окна Свойства. Она служит для вызова команды, позволяющей выделять объекты по набору свойств, исключать объекты из числа выделенных по набору свойств, а также инвертировать выделение (подробнее см. раздел 3.1.2.3).

– В чертеже объекты можно указывать в Дереве чертежа:

• графические макроэлементы, вставки фрагментов и изображений из видов других чертежей;

• модели, по которым создан чертеж.

– При изменении свойств необходимо учитывать их специфику и тип выделенных объектов.

• Свойства, являющиеся значениями длин (длина отрезка, радиус окружности и т.п.) и координат точек, отображаются с учетом текущих единиц измерения длин.

• Свойства, изменение которых в данный момент не имеет смысла, недоступны. Например, выделена штриховка с типом заполнения Область. Свойства Ширина полосы и Расположение штриховки относительно контура отображаются в таблице свойств, но изменение их значений невозможно. Эти свойства становятся доступны после смены значения свойства Тип заполнения с Область на Полоса.

• Изменение свойства Обозначение недоступно для стрелок взгляда, выносных элементов, линий разреза/сечения и баз, если при их создании или редактировании была включена автосортировка букв (см. раздел 3.10.1.5).

• Свойство Слой объекта, а также свойства, являющиеся значениями координат и углов, доступны, если выделенные объекты принадлежат одному виду.

• Значения координат и углов измеряются в системе координат вида, содержащего выделенные объекты, или в его текущей локальной системе координат (если она есть) — даже в случае, если вид, которому принадлежат выделенные объекты, не является текущим в данный момент.

• Свойство Язык доступно, если выделен текст или таблица.

• Свойство Гиперссылка доступно, если выделен один объект, или если все выделенные объекты содержат одинаковые гиперссылки, или если ни один из выделенных объектов не содержит гиперссылку.

• Свойства, по которым составляется отчет1 (Обозначение, Наименование, Масса и некоторые другие), доступны для макроэлементов, вставок фрагментов и видов из других чертежей.

– Возможно копирование свойств между объектами, в том числе и объектами модели в чертеже. Правила копирования описаны в разделе 3.5.1.2.2.

Библиотечные макроэлементы могут иметь специальные свойства, если это предусмотрено библиотекой. Например, изображение отверстия, созданное с помощью библиотеки Сервисные инструменты, обладает такими свойствами, как Вид (сбоку/сверху), Ось (есть/нет), Резьба (стандартная/нестандартная/нет), Диаметр и др.

Отображение специальных свойств макроэлемента в окне Свойства зависит от настройки (см. раздел 9.1.10.2).

  1. Об отчетах см. раздел 5.2.


3.5.1.2.2. Копирование свойств

Вы можете скопировать свойства указанного объекта (источника свойств) в другие объекты, т.е. сделать свойства других объектов совпадающими со свойствами указанного объекта.

Рис. 3.5.6. Выбор свойств для копирования в окне Свойства

Копирование свойств производится по следующим правилам:

– свойство Слой объекта, а также свойства, являющиеся значениями координат и углов, в чертеже копируются между объектами, принадлежащими одному виду,

– свойство Стиль, стиль линии, копируется между всеми объектами, допускающими изменение стиля линии (например, стиль линии окружности можно скопировать в отрезок, эквидистанту, волнистую линию, фигурную скобку и т.п.),

– свойства из групп Текст (или свойство Стиль текста), Параметры шрифта и Параметры абзаца копируются между всеми объектами, содержащими текст и допускающими изменение указанных свойств,

– свойство Язык копируется между текстами и таблицами,

– свойство Гиперссылка копируется между всеми объектами, в которые может быть вставлена гиперссылка,

– остальные свойства копируются только между объектами одного и того же типа (например, вид стрелки линии-выноски можно скопировать только в другую линию-выноску, но не в размер).

По умолчанию копирование некоторых свойств объектов отключено. К ним относятся свойство Слой объекта, значения координат характерных точек и другие свойства, копирование которых обычно не требуется. Включение (и отключение) копирования свойств производится в окне Свойства. Если оно не отображается на экране, включите его, нажав кнопку Свойства.

Чтобы скопировать свойства, выполните следующие действия.

1. Вызовите команду Редактор — Копировать свойства или нажмите кнопку Копировать свойства на Стандартной панели.

2. Укажите объект-источник свойств. Для этого выделите его в окне документа. Указание объекта-источника возможно как до вызова команды Копировать свойства, так и после.

В окне Свойства отображаются название объекта-источника и текущие значения его свойств. Слева от названий свойств находятся опции для управления копированием свойств. Включение опции означает, что соответствующее ей свойство будет скопировано из объекта-источника в указанный объект (объекты), а отключение — что свойство скопировано не будет (рис. 3.5.6).

3. Укажите объект или объекты, в которые требуется скопировать свойства источника. Для этого щелкайте по ним мышью или выделите рамкой.

Свойства объектов изменяются.

Во время копирования свойств объект-источник остается выделенным.

Чтобы сменить источник свойств, нажмите кнопку Указать заново на Панели специального управления или на инструментальной панели окна Свойства, а затем укажите новый объект-источник.

4. Чтобы завершить копирование свойств, нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Возможно копирование свойств объектов между разными графическими документами, открытыми в одном окне КОМПАС-3D. Оно производится так же, как копирование свойств между объектами одного документа. Единственное условие выполнения этой операции: в документе, куда копируются свойства, не должна быть запущена ни одна другая команда.


3.5.2. Сдвиг

3.5. Редактирование

3.5.2. Сдвиг

В этом разделе:

3.5.2.1. Произвольный сдвиг

3.5.2.1.1. Управление исходными объектами

3.5.2.2. Сдвиг по углу и расстоянию


3.5.2.1. Произвольный сдвиг

Чтобы сдвинуть выделенные объекты, вызовите команду Сдвиг.

– Если известно положение, которое должна занять после сдвига какая-либо точка изображения, задайте ее в качестве базовой (т1). Затем задайте новое положение этой точки — т2.

– Если известны смещения объектов в направлении осей текущей системы координат, введите их в соответствующие поля на Панели свойств.

Рис. 3.5.7. Произвольный сдвиг: а) исходное изображение, б) результат операции
а) | б)

Иногда удобнее выполнять простое перетаскивание выделенных объектов мышью, не прибегая к команде сдвига. Об этой возможности подробно рассказано в разделе 3.5.1.1.1.

Иногда требуется сдвинуть только часть геометрических объектов, составляющих изображение, а остальные — соответствующим образом перестроить. Такое редактирование осуществляется с помощью команды Деформация сдвигом (см. раздел 3.5.5.2).

В этом разделе:

3.5.2.1.1. Управление исходными объектами


3.5.2.1.1. Управление исходными объектами

После выполнения операции ее исходные объекты могут быть оставлены в документе или удалены.

Управление исходными объектами производится с помощью группы переключателей Режим на Панели свойств.

Чтобы исходные объекты автоматически удалялись по завершении операции, активизируйте переключатель Удалять исходные объекты. Активизация переключателя Оставлять исходные объекты означает, что они будут сохранены.


3.5.2.2. Сдвиг по углу и расстоянию

Чтобы переместить выделенные объекты на определенное расстояние в заданном направлении, вызовите команду Сдвиг по углу и расстоянию.

Введите в соответствующие поля на Панели свойств расстояние сдвига и угол между радиус-вектором, определяющим направление сдвига, и осью абсцисс текущей системы координат.

На экране появится фантом смещенных объектов.

Значения смещений вдоль осей текущей системы координат будут рассчитаны автоматически и показаны в справочных полях на Панели свойств.

Управление исходными объектами производится так же, как и в случае произвольного сдвига.

Чтобы зафиксировать фантом, нажмите кнопку Создать объект.

Рис. 3.5.8. Сдвиг по углу и расстоянию: а) исходное изображение, б) сдвиг отверстия на 22 мм под углом 10° к оси Х
а) | б)


3.5.3. Копирование

3.5. Редактирование

3.5.3. Копирование

В этом разделе:

3.5.3.1. Произвольная копия

3.5.3.1.1. Масштаб и поворот копий

3.5.3.2. Копия по кривой

3.5.3.2.1. Интерпретация шага

3.5.3.2.2. Расположение копий

3.5.3.2.3. Направление копирования

3.5.3.3. Копия по параллелограммной сетке

3.5.3.4. Копия по концентрической сетке

3.5.3.4.1. Расположение копий

3.5.3.5. Копия по окружности


3.5.3.1. Произвольная копия

Чтобы скопировать выделенные объекты, вызовите команду Копия указанием.

Задайте базовую точку для копирования т1.

Задайте точку т2, определяющую новое положение базовой точки.

Значения смещений по осям текущей системы координат будут рассчитаны автоматически и показаны в полях Сдвиг по оси Х и Сдвиг по оси Y.

Управление исходными объектами описано в разделе 3.5.2.1.1.

После фиксации нового положения базовой точки система копирует выделенные элементы в заданное место и ожидает указания следующего места для копирования.

Рис. 3.5.9. Произвольное копирование: а) исходное изображение, б) результат операции
а) | б)

Иногда удобнее выполнять простое копирование выделенных объектов мышью, не прибегая к вызову специальной команды. Об этой возможности подробно рассказано в разделе 3.5.1.1.2.

В этом разделе:

3.5.3.1.1. Масштаб и поворот копий


3.5.3.1.1. Масштаб и поворот копий

По умолчанию объекты-копии имеют такой же размер и такую же ориентацию, как и объект-оригинал (рис. 3.5.10, а).

При необходимости вы можете промасштабировать и/или повернуть копии относительно исходных объектов (рис. 3.5.10, б). Для этого введите нужные значения в поля Угол и Масштаб на вкладке Копия Панели свойств.

При копировании с изменением масштаба вы можете указать, нужно ли масштабировать выносные линии и линии-выноски размеров (если они есть среди копируемых объектов). Управление масштабированием выносных линий рассмотрено в разделе 3.5.4.2.1.

Масштаб и поворот копий при копировании по кривой, по параллелограммной и концентрической сеткам производятся аналогично.

Рис. 3.5.10. Копирование объектов: а) с сохранением угла поворота и масштаба, б) с изменением угла поворота и масштаба
а) | б)


3.5.3.2. Копия по кривой

Чтобы создать массив копий выделенных объектов, разместив их вдоль указанной кривой, вызовите команду Копия по кривой.

Управление исходными объектами описано в разделе 3.5.2.1.1.

Укажите базовую точку для копирования т1.

Укажите кривую, вдоль которой должны копироваться объекты.

Введите количество копий и их шаг в соответствующие поля на Панели свойств.

Шаг измеряется вдоль кривой, по которой производится копирование.

Установите нужную интерпретацию шага, расположение копий относительно нормали к кривой и направление копирования. Эти параметры подробно рассмотрены в следующих разделах.

Укажите на кривой начальную точку копирования — с ней будет совмещена базовая точка первого экземпляра массива.

На экране появится фантом массива копий. Для его фиксации нажмите кнопку Создать объект.

Рис. 3.5.11. Пример копирования по кривой

В этом разделе:

3.5.3.2.1. Интерпретация шага

3.5.3.2.2. Расположение копий

3.5.3.2.3. Направление копирования


3.5.3.2.1. Интерпретация шага

По умолчанию значение, введенное в поле Шаг, воспринимается как расстояние между соответствующими точками соседних экземпляров массива. При этом в группе Режим активен переключатель Расстояние между соседними копиями. Второй переключатель в этой группе — Расстояние между крайними копиями. Активизируйте его, если на участке кривой, длина которого задана в поле Шаг, требуется равномерно разместить количество копий, заданное в поле Количество.

Рис. 3.5.12. Копирование окружностей вдоль дуги: а) активен переключатель Расстояние между соседними копиями, б) активен переключатель Расстояние между крайними копиями
а) | б)


3.5.3.2.2. Расположение копий

По умолчанию производится доворот копий до нормали к кривой: каждая копия поворачивается так, чтобы ее положение относительно нормали к кривой, проведенной в точку вставки, совпадало с положением исходного объекта относительно оси Y абсолютной системы координат. При этом в группе Нормаль активен переключатель Доворачивать до нормали. Если требуется, чтобы все копии располагались так же, как исходный объект, активизируйте переключатель Не доворачивать до нормали.

Рис. 3.5.13. Копирование эллипса вдоль сплайна: а) без доворота копий до нормали, б) c доворотом копий до нормали
а) | б)

Экземпляры массива располагаются описанным образом, если поле Угол содержит нулевое значение (см. раздел 3.5.3.1.1). В противном случае каждая копия дополнительно поворачивается на заданный угол.


3.5.3.2.3. Направление копирования

По умолчанию копирование объектов вдоль кривой направлено против часовой стрелки от начальной точки. При этом в группе Направление активен переключатель Отрицательное направление. Если массив должен располагаться по другую сторону от начальной точки, активизируйте переключатель Положительное направление.

Очевидно, что выбор направления создания массива имеет смысл только в тех случаях, когда в качестве начальной точки указана не крайняя точка кривой.


3.5.3.3. Копия по параллелограммной сетке

Чтобы создать массив копий выделенных объектов, разместив их в узлах сетки с заданными параметрами, вызовите команду Копия по сетке.

Управление исходными объектами описано в разделе 3.5.2.1.1.

Укажите базовую точку копируемых объектов т1. При формировании массива копии будут размещены так, чтобы их базовые точки совпадали с узлами сетки (см. рис. 3.5.14, 3.5.15).

На экране появится фантом массива. Чтобы настроить сетку требуемым образом, активизируйте вкладку Параметры Панели свойств. Расположенные на ней элементы управления представлены в таблице 3.5.1. Параметры сетки, которыми управляют перечисленные элементы, показаны на рис. 3.5.14.

Табл. 3.5.1. Элементы управления параллелограммной сеткой
Элемент | Описание
Наклон | Угол наклона первой оси сетки к оси абсцисс текущей системы координат.
N1 N2 | Количества экземпляров массива вдоль первой и второй осей сетки.
Угол раствора | Угол между осями сетки.
Шаг1 Шаг2 | Шаг копий вдоль первой и второй осей сетки.
Режим 1 Режим 2 | Переключатели, управляющие интерпретацией шага вдоль осей. Управление интерпретацией рассмотрено в разделе 3.5.3.2.1.
Копии в углах сетки | Переключатели, управляющие способом размещения копий. Они доступны, если количество копий вдоль каждой из осей больше или равно трем.
Копии внутри сетки | Переключатели, управляющие способом размещения копий. Они доступны, если количество копий вдоль каждой из осей больше или равно трем.

Рис. 3.5.14. Схема образования параллелограммной сетки

Каждое изменение того или иного параметра массива или сетки немедленно отражается на его фантоме.

Чтобы зафиксировать фантом, укажите точку вставки массива т2.

Рис. 3.5.15. Пример копирования по сетке


3.5.3.4. Копия по концентрической сетке

Чтобы создать массив выделенных объектов, разместив их в узлах концентрической сетки, вызовите команду Копия по концентрической сетке.

Управление исходными объектами описано в разделе 3.5.2.1.1.

Укажите базовую точку копируемых объектов т1. При формировании массива копии будут размещены так, чтобы их базовые точки совпадали с узлами сетки (см. рис 3.5.17, 3.5.18).

На экране появится фантом массива. Чтобы настроить сетку требуемым образом, активизируйте вкладку Параметры Панели свойств. Расположенные на ней элементы управления представлены в таблице 3.5.2. Параметры сетки, которыми управляют перечисленные элементы, показаны на рис. 3.5.16.

Табл. 3.5.2. Элементы управления концентрической сеткой
Элемент | Описание
Радиус | Значение радиуса начальной окружности сетки.
Шаг 1 Шаг 2 | Шаг копий в радиальном и кольцевом направлениях.
Режим 1 Режим 2 | Переключатели, управляющие интерпретацией шага в радиальном и кольцевом направлениях. Управление интерпретацией рассмотрено в разделе 3.5.3.2.1.
N1 N2 | Количества копий в радиальном и кольцевом направлениях.
Начальный угол | Угол между осью абсцисс текущей системы координат и первой радиальной линией сетки.
Копия в центре | Группа переключателей, управляющая отрисовкой копии в центральной точке сетки. Если активен переключатель Оставлять копию в центре, то в массив будет добавлен еще один экземпляр так, чтобы его базовая точка совпала с центром сетки. По умолчанию формирование центральной копии отключено.
Ориентация копий | Группа переключателей, управляющая расположением копий. Ее действие подробно рассмотрено ниже.

Рис. 3.5.16. Схема образования концентрической сетки

Каждое изменение того или иного параметра массива или сетки немедленно отражается на его фантоме.

Чтобы зафиксировать фантом, укажите точку вставки массива т2.

Рис. 3.5.17. Пример копирования по концентрической сетке

В этом разделе:

3.5.3.4.1. Расположение копий


3.5.3.4.1. Расположение копий

По умолчанию в группе Ориентация копий активен переключатель Доворачивать копии до радиального направления. При этом каждая копия поворачивается вокруг своей базовой точки так, чтобы ее положение относительно той радиальной линии, на которой она расположена, совпадало с положением исходного объекта относительно оси X абсолютной системы координат. Если требуется, чтобы все копии располагались так же, как исходный объект, активизируйте переключатель Не доворачивать копии до радиального направления.

Рис. 3.5.18. Копирование по концентрической сетке: а) без доворота до радиального направления, б) с доворотом до радиального направления
а) | б)

Экземпляры массива располагаются описанным образом, если поле Угол содержит нулевое значение (см. раздел 3.5.3.1.1). В противном случае каждая копия дополнительно поворачивается на заданный угол.


3.5.3.5. Копия по окружности

Чтобы создать массив копий выделенных объектов, разместив их по окружности с указанным центром, вызовите команду Копия по окружности.

Задайте центр копирования.

На экране появится фантом массива с умолчательными параметрами.

Введите общее количество экземпляров массива в соответствующее поле на Панели свойств.

При копировании по окружности исходный объект входит в состав массива, поэтому количество созданных копий будет на единицу меньше введенного значения.

Группа переключателей Режим позволяет выбрать способ размещения экземпляров массива (рис. 3.5.19).

Рис. 3.5.19. Режим копирования: а) вдоль всей окружности, б) с угловым шагом 45°
а) | б)

Если вы выбрали размещение копий с заданным угловым шагом, введите его значение в поле Шаг, и установите нужное направление копирования с помощью группы переключателей Направление.

Каждое изменение того или иного параметра массива немедленно отражается на его фантоме.

Чтобы зафиксировать массив, нажмите кнопку Создать объект.


3.5.4. Преобразования объектов

3.5. Редактирование

3.5.4. Преобразования объектов

В этом разделе:

3.5.4.1. Поворот

3.5.4.2. Масштабирование

3.5.4.2.1. Управление масштабированием выносных линий

3.5.4.3. Симметрия

3.5.4.3.1. Указание существующей оси симметрии

3.5.4.4. Преобразование в NURBS


3.5.4.1. Поворот

Чтобы повернуть выделенные объекты, вызовите команду Поворот.

Задайте точку центра поворота.

– Если известно положение, которое должна занять после поворота какая-либо точка изображения, задайте ее в качестве базовой (т1). Затем задайте новое положение этой точки — т2.

– Если известен угол поворота объектов, введите его в соответствующее поле на Панели свойств.

Управление исходными объектами описано в разделе 3.5.2.1.1.

Рис. 3.5.20. Выполнение поворота: а) исходное изображение, б) изображение после поворота отверстия (центр поворота отмечен «крестиком»)
а) | б)

Иногда требуется повернуть только часть геометрических объектов, составляющих изображение, а остальные — соответствующим образом перестроить. Такое редактирование осуществляется с помощью команды Деформация поворотом (см. раздел 3.5.5.3).


3.5.4.2. Масштабирование

Чтобы выполнить масштабирование выделенных объектов, вызовите команду Масштабирование.

Введите в соответствующие поля на Панели значения коэффициентов масштабирования в направлении осей координат (вы можете ввести разные значения коэффициента масштабирования по осям).

Ввод масштаба по оси Y невозможен, если среди выделенных объектов есть окружности или дуги окружностей или виды целиком. В этом случае выполнение операции производится со значением масштаба по оси Y, равным масштабу по оси X.

Управление исходными объектами описано в разделе 3.5.2.1.1.

Группа переключателей Выносные линии управляет масштабированием выносных линий. Подробно об этом рассказано в следующем разделе.

Задайте точку центра масштабирования.

Рис. 3.5.21. Выполнение масштабирования: а) исходное изображение, б) изображение после масштабирования проушины
а) | б)

Иногда требуется промасштабировать только часть геометрических объектов, составляющих изображение, а остальные — соответствующим образом перестроить. Такое редактирование осуществляется с помощью команды Деформация масштабированием (см. раздел 3.5.5.4).

В этом разделе:

3.5.4.2.1. Управление масштабированием выносных линий


3.5.4.2.1. Управление масштабированием выносных линий

Выносные линии и линии-выноски размеров (если они есть среди объектов, участвующих в операции) по умолчанию не масштабируются, т.е. их длина остается такой же, как в оригинальном изображении. При этом в группе Выносные линии активен переключатель Не масштабировать.

Если необходимо изменить длину выносных линий и линий-выносок в соответствии с заданными коэффициентами масштабирования, активизируйте опцию Масштабировать.

Рис. 3.5.22. Уменьшение масштаба копий объекта в два раза: а) исходный объект, б) копирование без масштабирования выносных линий, в) копирование с масштабированием выносных линий
а) | б) | в)

Рекомендуется включать масштабирование выносных линий при значительном изменении масштаба объектов, среди которых имеется много размеров.


3.5.4.3. Симметрия

Чтобы выполнить преобразование симметрии относительно прямой для выделенных объектов, вызовите команду Симметрия.

Задайте первую точку, принадлежащую оси симметрии (т1).

– Если положение второй точки на оси (т2) известно, задайте ее.

– Если известен угол наклона оси (угол между ней и осью абсцисс текущей системы координат), введите его в соответствующее поле на Панели свойств.

Выбранный для преобразования объект может содержать текст. Опция Зеркально отразить тексты позволяет определить, как будет выглядеть текст после преобразования симметрии. При включенной опции текст будет отражен зеркально, при отключенной — останется в исходном виде.

Действие опции не распространяется на текст обозначений, выбранных для преобразования симметрии.

Управление исходными объектами описано в разделе 3.5.2.1.1.

Рис. 3.5.23. Преобразование симметрии: а) исходное изображение, б) результат выполнения команды
а) | б)

В этом разделе:

3.5.4.3.1. Указание существующей оси симметрии


3.5.4.3.1. Указание существующей оси симметрии

Если в документе уже есть прямолинейный объект, являющийся осью симметрии выполняемого преобразования, вы можете указать сам этот объект, а не точки, принадлежащие ему. Для этого нажмите кнопку Выбор базового объекта и укажите курсором нужный объект.


3.5.4.4. Преобразование в NURBS

Преобразование в NURBS (неоднородный рациональный В-сплайн) возможно для любого геометрического объекта или текста. Такое преобразование может потребоваться для последующего гибкого редактирования объекта перемещением его характерных точек.

Чтобы преобразовать геометрический объект или текст в NURBS, вызовите команду Преобразовать в NURBS.

Исходные объекты можно преобразовывать в кривые следующих типов:

– Сплайн по полюсам

– NURBS-кривая по точкам

Выберите нужный тип кривой из списка Тип кривой на Панели свойств.

Преобразование объекта в NURBS-кривую по точкам выполняется путем его аппроксимации. Аппроксимация выполняется следующими способами:

– Аппроксимация по стрелке прогиба;

– Аппроксимация по углу касательной.

Выберите нужный способ аппроксимации из списка Аппроксимация кривой на Панели свойств.

Задайте точность аппроксимации в поле Шаг аппроксимации на Панели свойств.

Укажите объект для преобразования.

Управление исходными объектами описано в разделе 3.5.2.1.1.

Результат преобразования текстов в кривые зависит от типа используемого шрифта. Так, при обработке TrueType-шрифтов создаются контуры букв, а при обработке векторных шрифтов — наборы отрезков, составляющие буквы (рис. 3.5.24).

Рис. 3.5.24. Преобразование текстов в NURBS: а) исходные объекты — тексты,
набранные TrueType-шрифтом и векторным шрифтом, б) результаты преобразования

а)

б)

Некоторые объекты невозможно преобразовать в один NURBS без кратных точек. Результатом преобразования таких объектов является контур, состоящий из нескольких NURBS без кратных точек.

Преобразование невозможно в том случае, когда исходный объект и кривая, в которую он преобразуется, являются кривой одного и того же типа.


3.5.5. Деформация

3.5. Редактирование

3.5.5. Деформация

Команды деформации используются в случаях, когда необходимо сдвинуть, повернуть или промасштабировать часть изображения таким образом, чтобы объекты, положение характерных точек которых изменилось, не потеряли связь с неподвижными объектами. То есть команды деформации позволяют редактировать элементы, не «разрывая» изображение.

После вызова команды деформации система ожидает указания объектов, подлежащих преобразованию (т.е. выделять объекты заранее, например, как для копирования, не нужно). После того как объекты выбраны, включается режим выполнения команды деформации. При этом изменяется набор элементов управления на Панели свойств.

Порядок указания объектов одинаков для всех трех команд. Он рассмотрен в разделе 3.5.5.1. В остальных разделах описана последовательность действий при выполнении деформации конкретного типа.

В этом разделе:

3.5.5.1. Выбор объектов для деформации

3.5.5.2. Деформация сдвигом

3.5.5.3. Деформация поворотом

3.5.5.4. Деформация масштабированием


3.5.5.1. Выбор объектов для деформации

Указание объектов для деформации производится с помощью прямоугольной рамки.

Укажите противоположные вершины рамки т1 и т2. «Захваченные» объекты будут выделены. Система перейдет в режим выполнения деформации.

Набор выделенных объектов можно изменить при помощи кнопок на Панели специального управления.

Кнопка Выделить новой рамкой позволяет сформировать рамку заново. После ее нажатия прежнее выделение отменяется и система вновь ожидает выделения объектов: на Панели свойств появляются поля т1 и т2. Вы можете указать вершины рамки заново.

Кнопка Исключить/добавить объект позволяет снять выделение с объектов, попавших в рамку. Для исключения объекта укажите его курсором. Повторное указание объекта снова включает его в выделенную группу.

Объект, изначально находившийся вне рамки, невозможно добавить к выделенным.

Пока кнопка Исключить/добавить объект нажата, поля Панели свойств недоступны. Закончив исключение или добавление объектов, отожмите кнопку, чтобы перейти к выполнению деформации.


3.5.5.2. Деформация сдвигом

Чтобы выполнить деформацию объектов сдвигом, вызовите команду Деформация сдвигом.

Укажите объекты для деформации.

– Если известно положение, которое должна занять после сдвига какая-либо точка изображения, задайте ее в качестве базовой (т1). Затем задайте новое положение этой точки — т2.

– Если известны смещения объектов в направлении осей текущей системы координат, введите их в соответствующие поля на Панели свойств.

Деформация объектов сдвигом происходит по следующему правилу.

– Элементы, полностью попавшие в рамку выделения, будут просто сдвинуты на заданное расстояние.

– Элементы, частично попавшие в рамку выделения, будут отредактированы таким образом, чтобы их характерные точки, попавшие в рамку выделения, переместились на заданное расстояние, а характерные точки, не попавшие в рамку выделения, остались на прежнем месте.

– Элементы, не попавшие в рамку выделения, не редактируются.

Рис. 3.5.25. Выполнение деформации сдвигом: а) выбор объектов, б) результат операции
а) | б)


3.5.5.3. Деформация поворотом

Чтобы выполнить деформацию объектов поворотом, вызовите команду Деформация поворотом.

Укажите объекты для деформации.

Задайте точку центра поворота.

– Если известно положение, которое должна занять после поворота какая-либо точка изображения, задайте ее в качестве базовой (т1). Затем задайте новое положение этой точки — т2.

– Если известен угол поворота объектов, введите его в соответствующее поле на Панели свойств.

Деформация объектов поворотом происходит по следующему правилу.

– Элементы, полностью попавшие в рамку выделения, будут просто повернуты на заданный угол относительно центра поворота.

– Элементы, частично попавшие в рамку выделения, будут отредактированы таким образом, чтобы их характерные точки, попавшие в рамку выделения, повернулись на заданный угол относительно центра поворота, а характерные точки, не попавшие в рамку выделения, остались на прежнем месте.

– Элементы, не попавшие в рамку выделения, не редактируются.

Рис. 3.5.26. Выполнение деформации поворотом: а) выбор объектов, б) результат операции
а) | б)


3.5.5.4. Деформация масштабированием

Чтобы выполнить деформацию объектов масштабированием, вызовите команду Деформация масштабированием.

Укажите объекты для деформации.

Введите в соответствующие поля на Панели значения коэффициентов масштабирования в направлении осей координат (вы можете ввести разные значения коэффициента масштабирования по осям).

Ввод масштаба по оси Y невозможен, если среди выделенных объектов есть окружности или дуги окружностей. В этом случае выполнение операции производится со значением масштаба по оси Y, равным масштабу по оси X.

Задайте точку центра масштабирования.

После этого будет выполнено перестроение объектов.

Деформация объектов масштабированием происходит по следующему правилу.

– Элементы, полностью попавшие в рамку выделения, будут просто промасштабированы с заданным коэффициентом относительно центра масштабирования.

– Элементы, частично попавшие в рамку выделения, будут отредактированы таким образом, чтобы координаты их характерных точек, попавших в рамку выделения, изменились относительно центра масштабирования в соответствии с заданными коэффициентами, а характерные точки, не попавшие в рамку выделения, остались на прежнем месте.

– Элементы, не попавшие в рамку выделения, не редактируются.

Рис. 3.5.27. Выполнение деформации масштабированием: а) выбор объектов, б) результат операции
а) | б)


3.5.6. Разбиение объектов на части

3.5. Редактирование

3.5.6. Разбиение объектов на части

Команды разбиения могут быть применены к любым кривым, кроме эквидистант и вспомогательных прямых.

Если точки, указанные при выполнении команд, не принадлежат выбранным кривым, то положение точек разбиения будет определяться проекциями указанных точек на кривую. Для точного позиционирования курсора воспользуйтесь привязками (см. раздел 3.1.1).

В этом разделе:

3.5.6.1. Разбить кривую на две части

3.5.6.2. Разбить кривую на несколько равных частей


3.5.6.1. Разбить кривую на две части

Чтобы разбить объект в какой-либо точке на две части, вызовите команду Разбить кривую.

Укажите кривую.

Если кривая не замкнута, то для разбиения ее на две части требуется задание одной точки т1.

Если кривая замкнута, то для ее разбиения необходимо задать точки т1 и т2.


3.5.6.2. Разбить кривую на несколько равных частей

Чтобы разбить объект на несколько равных частей, вызовите команду Разбить кривую на N частей.

Введите количество участков, на которые нужно разбить кривую, в соответствующее поле на Панели свойств. Затем укажите кривую для разбиения.

Если кривая замкнута, необходимо задать начальную точку для разбиения.


3.5.7. Удаление частей объектов. Продление объектов

3.5. Редактирование

3.5.7. Удаление частей объектов. Продление объектов

Иногда при редактировании чертежа требуется удалить не весь элемент, а только какую-либо его часть или, наоборот, достроить недостающую часть элемента. В этих случаях удобно применять специальные команды усечения объектов, а также команды удаления области, фаски/скругления, команды выравнивания по границе и удлинения объектов.

В этом разделе:

3.5.7.1. Усечение кривых

3.5.7.2. Усечение кривых по указанным точкам

3.5.7.3. Выравнивание по границе

3.5.7.4. Удлинение до ближайшего объекта

3.5.7.5. Удаление фасок и скруглений

3.5.7.6. Очистка области

3.5.7.7. Удаление частей объектов оформления и библиотечных макроэлементов

3.5.7.8. Очистка фона


3.5.7.1. Усечение кривых

Чтобы удалить часть объекта, ограниченную точками пересечения его с другими объектами (усечь объект), вызовите из меню команду Усечь кривую.

Усекать можно любые геометрические объекты за исключением эквидистант и вспомогательных прямых.

По умолчанию удаляется тот участок кривой, который указан курсором. При этом в группе Режим на Панели свойств активен переключатель Удалять указанный участок. Если же требуется удалить внешние по отношению к указанному участки кривой, активизируйте переключатель Оставлять указанный участок. Так, на рис. 3.5.28, б для усечения обеих прямых были указаны те их участки, которые лежали внутри окружности. Однако верхняя прямая была выбрана в режиме оставления указанного участка, а нижняя — в режиме удаления.

Установив требуемый режим, укажите нужный участок кривой.

Рис. 3.5.28. Усечение отрезков: а) исходное изображение, б) результат выполнения команды
а) | б)

Для усечения можно указывать группу объектов, используя секущий отрезок.

Указание группы объектов секущим отрезком

Чтобы указать группу объектов секущим отрезком, выполните следующие действия.

1. Установите курсор в первую точку секущего отрезка.

2. Нажмите левую кнопку мыши и перемещайте курсор ко второй точке отрезка, удерживая кнопку нажатой. При перемещении курсора формируется секущий отрезок. Он отображается пунктиром. Объекты, которые пересекает отрезок, подсвечиваются.

3. Отпустите кнопку, когда отрезок пересечет все нужные объекты.

На рисунке 3.5.29 приведен пример указания группы объектов для выравнивания по указанной границе.

Рис. 3.5.29. Указание группы объектов секущим отрезком для выравнивания по указанной границе: а) исходное изображение, б) указание объектов с помощью секущего отрезка, в) результат выравнивания
а) | б) | в)


3.5.7.2. Усечение кривых по указанным точкам

Чтобы удалить часть объекта, ограниченную двумя произвольно заданными точками, вызовите команду Усечь кривую двумя точками.

Усекать по точкам можно любые геометрические объекты за исключением эквидистант и вспомогательных прямых.

По умолчанию удаляется участок кривой, заключенный между указанными точками (если объект не замкнут) или участок, указанный курсором (если объект замкнут). При этом в группе Режим на Панели свойств активен переключатель Удалять указанный участок. Если же требуется удалить внешние по отношению к указанному участки кривой, активизируйте переключатель Оставлять указанный участок.

Установив нужный режим, укажите курсором усекаемый геометрический объект.

Затем укажите две точки (т1 и т2), ограничивающие участок кривой, который следует удалить.

Если указанная точка не принадлежит выбранной кривой, то положение границ участка будет определяться проекциями указанных точек на кривую. Для точного позиционирования курсора воспользуйтесь привязками (см. раздел 3.1.1).

Если кривая замкнута, необходимо указать точку внутри удаляемого участка.

Рис. 3.5.30. Усечение объектов по двум точкам


3.5.7.3. Выравнивание по границе

Выравнивание объектов по границе — продление объектов до границы выравнивания или усечение по ней.

Выравнивание может потребоваться при построении изображений тел вращения, например, как на рис. 3.5.31, а также во многих других случаях.

Рис. 3.5.31. Выполнение выравнивания: а) исходное изображение, б) результат операции
а) | б)

Использовать в качестве границы можно любые геометрические объекты, а выравнивать по границе — любые, кроме вспомогательных прямых.

Кривые Безье и NURBS могут быть только усечены по границе, продление их с помощью команды выравнивания невозможно.

Чтобы выровнять объекты, вызовите команду Выровнять по границе.

Укажите границу выравнивания.

Укажите объекты, которые должны быть выровнены.

Объекты для выравнивания можно указывать по одному или группой. Для указания группы объектов используется секущий отрезок (см. раздел Указание группы объектов секущим отрезком).

Если объект пересекается с границей выравнивания несколько раз, то учитываются все пересечения (как показано на рис. 3.5.32).

Рис. 3.5.32. Выполнение выравнивания: а) исходное изображение, б) результат операции
а) | б)

Чтобы перейти к выравниванию по другой границе, нажмите кнопку Указать заново и выберите новую границу.


3.5.7.4. Удлинение до ближайшего объекта

Чтобы продлить объект до ближайшей точки его пересечения (или касания) с другим объектом, вызовите команду Удлинить до ближайшего объекта.

Укажите объект для удлинения — отрезок, дугу окружности или эллипса.

Удлинение объекта происходит от той его конечной точки, ближе к которой находился курсор при выборе объекта, до ближайшей точки пересечения с другим объектом (в том числе в составе макроэлементов и вставок).

При удлинении объектов учитываются их пересечения с геометрическими объектами, осями и линиями обрыва. Если ни один из этих объектов не пересекается с продолжением объекта, выбранного для удлинения, то удлинение не происходит.

Рис. 3.5.33. Исходное изображение и изображение после удлинения отрезков

Объекты для удлинения можно указывать по одному или группой. Для указания группы объектов используется секущий отрезок (см. раздел Указание группы объектов секущим отрезком).

За один вызов команды вы можете продолжить несколько объектов или несколько раз продолжить один и тот же объект.

Если имеется несколько объектов, часть из которых нужно продолжить до пересечения с объектом, а часть — усечь в точках пересечения с тем же объектом, воспользуйтесь командой Выровнять по границе.

Имейте в виду, что продолжение объекта с помощью этой команды возможно как до явных точек пересечения с границей, так и до точек пересечения с ее продолжением, в то время как команда Удлинить до ближайшего объекта продолжает объект только до явных точек пересечения с другими объектами.


3.5.7.5. Удаление фасок и скруглений

Чтобы удалить отрезок или дугу, соединяющие концы двух других объектов, и продолжить эти объекты до точки их пересечения, вызовите команду Удалить фаску/скругление.

Укажите фаску или скругление, подлежащие удалению. Если объекты, которые соединяет указанный отрезок или дуга, можно перестроить, продолжив их до точки пересечения, то фаска или скругление будут удалены.


3.5.7.6. Очистка области

При разработке чертежной документации (особенно сборочных чертежей) изображения деталей зачастую накладываются друг на друга. Естественно, что невидимые линии контуров деталей не должны изображаться в документе. Однако удаление их поодиночке — долгая и утомительная работа, автоматизировать и заметно ускорить которую можно с использованием команды Очистить область.

Итак, чтобы удалить все объекты, находящиеся внутри или снаружи от некоторой границы, вызовите команду Очистить область.

Система ожидает указания границ областей для очистки.

Если в документе имеются замкнутые геометрические объекты (окружности, многоугольники, контуры и т.п.), все изображение внутри которых необходимо удалить, укажите их (рис. 3.5.34).

Рис. 3.5.34. Использование замкнутого геометрического объекта в качестве границы для очистки области: а) выбор объекта (выделен цветом), б) результат операции
а) | б)

Если граница очищаемой области состоит из участков нескольких пересекающихся кривых (рис. 3.5.35), укажите ее путем обхода по стрелке. Для этого нажмите кнопку Обход границы по стрелке. Дальнейший порядок действий описан в разделе 3.2.13.1.2.

Рис. 3.5.35. Граница для очистки области, состоящая из участков нескольких объектов: а) выбор объектов (выделены цветом), б) результат операции
а) | б)

Если границей очищаемой области является ломаная, не совпадающая полностью ни с одним из имеющихся контуров (рис. 3.5.36), сформируйте ее вручную. Для этого нажмите кнопку Ручное рисование границ. Дальнейший порядок действий описан в разделе 3.2.13.1.1.

Рис. 3.5.36. Использование временной ломаной линии в качестве границы области очистки: а) формирование ломаной, б) результат операции
а) | б)

Вы можете указать для очистки сразу несколько расположенных в разных местах областей с границами, заданными различными способами.

По умолчанию удаляются геометрические объекты, расположенные внутри указанной границы. При этом в группе Режим на Панели свойств активен переключатель Удалять объекты внутри границ. Если же эти объекты требуется оставить, а все остальные удалить, активизируйте переключатель Удалять объекты снаружи от границ.

После того как границы областей указаны, нажмите для их очистки кнопку Создать объект.

Применяя команду очистки области, необходимо иметь в виду следующие особенности ее работы.

– При выполнении команды удаляются (усекаются) объекты, расположенные в текущем виде на текущем и активных слоях. О видах и слоях см. разделы 3.6.4–3.6.6.

– Сложные объекты (например, вставка фрагмента или изображения из вида другого чертежа, растровый объект, таблица, текст, эквидистанта) удаляются только в том случае, если их габаритные прямоугольники полностью попали в область для очистки.

– Размеры и объекты оформления (линии-выноски, обозначения баз, допусков формы и т.п.) удаляются, если они полностью попали в область для очистки. Благодаря этому можно получать изображения, показанные на рис. 3.5.36.

– Вспомогательные прямые, пересекающие область очистки, удаляются.


3.5.7.7. Удаление частей объектов оформления и библиотечных макроэлементов

3.5.7.7. Удаление частей объектов оформления
и библиотечных макроэлементов

Команды усечения кривых, выравнивания по границе и очистки области можно применять к размерам и обозначениям, а также к изображениям, вставленным из библиотек. На рис. 3.5.37 приведены примеры редактирования некоторых из перечисленных объектов.

Рис. 3.5.37. Удаление части изображения: а) выносной линии размера, б) крепежного элемента (шпильки)
а) | б)

Однако следует иметь в виду, что удаленные таким образом геометрические объекты (или их части) на самом деле лишь становятся временно невидимыми. После первого же перестроения объект оформления или библиотечный макроэлемент вновь будет отображен полностью.


3.5.7.8. Очистка фона

Согласно стандарту, при недостатке места для стрелок и надписей допускается прерывать контурные, выносные, центровые и осевые линии, а также штриховку.

Как было показано выше, это можно сделать, используя команды Усечь по двум точкам (рис. 3.5.30, 3.5.37, а) и Очистить область (рис. 3.5.35).

Однако гораздо более удобно применять очистку фона — автоматическое прерывание штриховок и линий при пересечении их со следующими объектами:

– текст на чертеже,

– стрелки, надписи и знаки в составе объектов оформления (размеров, линий-выносок, допусков формы и т.п.).

Включение и настройка очистки фона в текущем документе производится в диалоге настройки отрисовки перекрывающихся объектов (см. раздел 9.2.6.18).

Настройка, сделанная в данном диалоге, будет применена ко всем существующим и вновь создаваемым в текущем документе текстам, размерам и обозначениям.

При необходимости для любого из них можно выключить очистку фона, вызвав команду Очистить фон из контекстного меню (рис. 3.5.38) или из меню Сервис.

Если очистка в текущем документе отключена, эта команда позволяет включить очистку фона вокруг нужных объектов.

Рис. 3.5.38. Команда Очистить фон

Объект, очистка фона которого включалась или выключалась индивидуально (командой Очистка фона), уже не подчиняется включению и выключению очистки в диалоге настройки отображения перекрывающихся объектов.

При очистке фона прерываются линии и штриховки, расположенные в одном виде с объектом, для которого выполняется очистка. О видах см. раздел 3.6.4.


3.5.8. Удаление объектов

3.5. Редактирование

3.5.8. Удаление объектов

Помимо команд ввода и редактирования объектов, КОМПАС-3D имеет широкий набор средств удаления.

Проще всего удалить объект, выделив его и нажав клавишу <Delete>. О способах выделения геометрических объектов см. раздел 3.1.2, видов — раздел 3.6.5.4.

Удалить только что созданный объект можно, вызвав команду Отменить сразу после его создания.

Будьте внимательны при выделении и последующем удалении макроэлементов, групп, вставок фрагментов и других сложных объектов. На экране могут не отображаться некоторые из входящих в них объектов (например, расположенные на выключенных слоях — см. раздел 3.6.6.1), поэтому возможно случайное удаление нужных элементов.

Если при удалении допущена ошибка, воспользуйтесь командой отмены.

В этом разделе:

3.5.8.1. Удаление вспомогательных объектов

3.5.8.2. Удаление всех объектов документа

3.5.8.3. Удаление объектов оформления


3.5.8.1. Удаление вспомогательных объектов

В процессе работы над чертежом конструктор часто использует различные вспомогательные построения (аналог построений в тонких линиях на кульмане).

В КОМПАС-3D предусмотрены различные варианты построения бесконечных прямых. Стиль линии, используемый для них, — Вспомогательная, изменение его невозможно. Этот стиль можно назначить также любому геометрическому объекту при создании или редактировании. Кроме того, стиль Вспомогательная могут иметь точки (именно он используется для точек по умолчанию).

При работе с фрагментом, чтобы очистить его от ставших ненужными вспомогательных построений, вызовите команду Редактор — Удалить — Вспомогательные кривые и точки. Все кривые и точки, имеющие стиль Вспомогательная, будут удалены из фрагмента.

При работе с чертежом после вызова команды Редактор — Удалить — Вспомогательные кривые и точки на экране появляется подменю, включающее команды В текущем виде и Во всех видах. Таким образом вы можете удалить объекты вспомогательного стиля только из текущего вида или сразу изо всех видов чертежа.


3.5.8.2. Удаление всех объектов документа

Чтобы удалить сразу все содержимое документа, вызовите команду Редактор — Удалить — Все.

После этого на экране появится предупреждение о невозможности отмены операции. Чтобы подтвердить удаление, нажмите кнопку Да.

Если удаление всех объектов документа все-таки было ошибочным, то единственным способом восстановить содержимое документа, имевшееся после предыдущей записи на диск, будет его закрытие без сохранения на диске и повторное открытие.


3.5.8.3. Удаление объектов оформления

Для удаления таких объектов оформления чертежа, как основная надпись, технические требования и знак обозначения шероховатости неуказанных поверхностей, служат следующие команды из меню Редактор — Удалить: Содержимое основной надписи, Технические требования, Неуказанную шероховатость.

Восстановить содержимое основной надписи (данные, введенные вручную в ячейки основной надписи), невозможно. Поэтому после вызова соответствующей команды на экране появляется диалог-предупреждение, в котором можно подтвердить удаление или отказаться от него.


3.6. Создание чертежей

В этом разделе:

3.6.1. Из чего состоит чертеж

3.6.1.1. Листы

3.6.1.2. Виды

3.6.1.3. Знак неуказанной шероховатости

3.6.1.3.1. Простановка знака

3.6.1.3.2. Редактирование и удаление знака

3.6.1.4. Технические требования

3.6.2. Управление листами

3.6.2.1. Оформление и формат листа

3.6.2.2. Добавление листа

3.6.2.3. Удаление листа

3.6.2.4. Переключение между листами

3.6.3. Основная надпись чертежа

3.6.3.1. Заполнение основной надписи

3.6.3.1.1. Обозначение документа

3.6.3.1.2. Пользовательское меню

3.6.3.1.3. Дата

3.6.3.1.4. Текстовые шаблоны

3.6.3.1.5. Коды и наименования

3.6.3.2. Удаление содержимого основной надписи

3.6.4. Сведения о видах

3.6.4.1. Получение изображений в различных масштабах

3.6.4.2. Состояния видов

3.6.4.3. Создание простого вида

3.6.4.4. Настройка параметров видов

3.6.4.5. Дерево чертежа

3.6.4.6. Надпись вида

3.6.4.6.1. Объект оформления, связанный с видом

3.6.4.6.2. Ассоциативная связь между надписью вида и обозначением объекта оформления

3.6.4.6.3. Редактирование надписи вида как части вида

3.6.4.6.4. Редактирование надписи вида как текстового объекта

3.6.5. Приемы работы с видами

3.6.5.1. Переключение между видами

3.6.5.2. Изменение состояния вида

3.6.5.3. Изменение параметров вида

3.6.5.4. Выделение вида

3.6.5.5. Копирование и перенос видов через буфер

3.6.5.6. Удаление вида

3.6.5.7. Компоновка видов на листе

3.6.5.8. Разрыв вида

3.6.5.8.1. Создание разрыва

3.6.5.8.2. Направление сдвига при разрыве

3.6.5.8.3. Амплитуда

3.6.5.8.4. Особенности работы с разрывами изображений

3.6.6. Слои

3.6.6.1. Состояния слоев

3.6.6.2. Менеджер документа

3.6.6.2.1. Инструментальная панель Менеджера документа

3.6.6.2.2. Дерево листов, видов и слоев

3.6.6.2.3. Список листов, видов и слоев

3.6.6.2.4. Область поиска

3.6.6.3. Создание нового слоя

3.6.6.4. Переключение между слоями

3.6.6.5. Изменение состояния и параметров слоя

3.6.6.6. Копирование слоев между видами

3.6.6.7. Выделение слоя

3.6.6.8. Удаление слоя

3.6.6.9. Управление слоями в графическом документе

3.6.6.9.1. Наборы слоев

3.6.6.9.2. Операции с наборами слоев

3.6.6.9.3. Использование наборов для задания свойств слоев

3.6.7. Технические требования в чертеже

3.6.7.1. Ввод технических требований в чертеже

3.6.7.1.1. Режим работы с техническими требованиями

3.6.7.2. Размещение технических требований на чертеже

3.6.7.3. Разбивка технических требований на страницы

3.6.7.4. Редактирование и удаление технических требований

3.6.8. Разбиение чертежа на зоны


3.6.1. Из чего состоит чертеж

3.6. Создание чертежей

3.6.1. Из чего состоит чертеж

Помимо графического изображения, чертеж содержит рамку, основную надпись, знак неуказанной шероховатости и технические требования. Геометрическая характеристика листа — формат. Она включает в себя собственно формат (А1, А2 и т.д), а также кратность и ориентацию.

Если чертеж включает несколько листов, то для каждого из них можно задать собственный формат, а также выбрать нужный тип основной надписи.

В этом разделе:

3.6.1.1. Листы

3.6.1.2. Виды

3.6.1.3. Знак неуказанной шероховатости

3.6.1.3.1. Простановка знака

3.6.1.3.2. Редактирование и удаление знака

3.6.1.4. Технические требования


3.6.1.1. Листы

Каждый лист отображается в чертеже в виде внешней и внутренней рамок формата с основной надписью. Все листы одного чертежа показываются на экране одновременно. Они располагаются вплотную друг к другу слева направо в порядке создания.

Листы никак не связаны с изображением, хранящимся в чертеже. Условно можно считать их лежащими в специальном слое, который расположен поверх всех графических объектов. Поэтому при удалении листа изображение, находившееся «под ним», остается на своем прежнем месте, а рамка вокруг него и соответствующая основная надпись исчезают.

При создании нового чертежа в нем автоматически создается первый лист. При необходимости вы можете добавить листы. Это можно сделать в любой момент работы над чертежом. Также в любое время можно изменить параметры любого листа. Подробнее об управлении листами документа рассказано в разделе 3.6.2.

Вы можете включить режим разбиения чертежа на зоны, задать размеры этих зон и их обозначения. Включение и настройка разбиения чертежа на зоны описана в разделе 9.2.6.19.4.


3.6.1.2. Виды

Вид является составной частью чертежа, служащей «контейнером» для изображения. Внутри вида графические объекты могут располагаться на одном или нескольких слоях (подробнее о слоях см. раздел 3.6.6). Существование изображения вне слоя и вида невозможно.

Это не относится к техническим требованиям и знаку неуказанной шероховатости — они не принадлежат ни одному виду и ни одному слою.

Основными характеристиками вида являются масштаб и положение. Изменение масштаба и положения вида приводит к масштабированию и перемещению всех объектов, расположенных в этом виде.

Чертежи, создаваемые в КОМПАС-3D, могут включать до 2 147 483 647 видов.

Вид чертежа не обязательно должен содержать какую-либо проекцию детали в строго геометрическом толковании. Это может быть любое изолированное изображение.

Не обязательно также и само разбиение чертежа на виды. Все изображение на чертеже, если это удобно при работе, может располагаться в одном виде.

При создании нового чертежа система автоматически формирует в нем специальный системный вид с нулевым номером, а в виде — системный слой с нулевым номером.

Если пользователь не создавал никаких других видов и/или слоев, то все создаваемые объекты в чертеже будут помещаться в системный вид на системный слой.

Таким образом, сразу же после создания нового чертежа вы можете приступать к вычерчиванию изображения, не заботясь о создании вида.

В этом случае черчение будет вестись «в натуральную величину». О черчении в масштабе см. раздел 3.6.4.1.

Внутри фрагмента разбиение на виды невозможно, так как по сути фрагмент сам аналогичен системному виду чертежа.

Работа с видами описана в разделе 3.6.4.


3.6.1.3. Знак неуказанной шероховатости

Знак неуказанной шероховатости практически всегда присутствует на чертежах машиностроительных деталей. При работе в КОМПАС-3D возможно автоматическое формирование и размещение знака.

Задание параметров текста знака неуказанной шероховатости при его создании невозможно. Эти параметры определяются настройкой документа, описанной в разделе 9.2.6.19.7.

В этом разделе:

3.6.1.3.1. Простановка знака

3.6.1.3.2. Редактирование и удаление знака


3.6.1.3.1. Простановка знака

Для простановки знака неуказанной шероховатости на чертеже вызовите команду Вставка — Неуказанная шероховатость — Ввод….

На экране появится диалог ввода и редактирования знака (рис. 3.6.1). Его элементы управления представлены в табл. 3.6.1.

Рис. 3.6.1. Диалог ввода и редактирования знака

Табл. 3.6.1. Диалог ввода и редактирования знака неуказанной шероховатости
Элемент | Описание
Тип знака | Группа опций, позволяющая выбрать тип знака шероховатости: без указания вида обработки, с удалением слоя материала или без удаления слоя материала.
Добавить знак в скобках | Опция, управляющая отрисовкой знака в скобках.
Текст | Текст надписи. Он может быть введен с клавиатуры или выбран из пользовательского меню (рис 3.6.1). Вызов пользовательского меню осуществляется двойным щелчком в заполняемом поле.
Расстояние до знака1 | Поле для ввода вертикального расстояния от текста надписи до знака шероховатости.
Удалить | Кнопка, позволяющая удалить знак. Доступна после создания знака.
  1. Данное поле присутствует в диалоге, если при настройке обозначений шероховатости в текущем документе было выбрано соответствие предыдущей редакции ГОСТ2.309–73. Эта настройка производится в разделе Шероховатость диалога настройки текущего документа (см. раздел 3.3.7.2).

После закрытия диалога кнопкой ОК знак появляется в правом верхнем углу первого листа чертежа.


3.6.1.3.2. Редактирование и удаление знака

Вы можете изменить знак неуказанной шероховатости в диалоге его редактирования (рис. 3.6.1). Для вызова диалога существует три способа:

– двойной щелчок левой кнопкой мыши по знаку,

– вызов из его контекстного меню команды Редактировать неуказанную шероховатость,

– вызов команды Вставка — Неуказанная шероховатость — Ввод….

Чтобы изменить расположение знака на чертеже, перейдите в режим размещения знака. Для этого существует два способа:

– вызов команды Ручное размещение из контекстного меню знака,

– вызов команды Вставка — Неуказанная шероховатость — Размещение.

На экране появляется габаритная рамка знака и подсвечивается точка его привязки. Знак можно «перетащить» мышью за характерную точку в любое место чертежа.

Чтобы восстановить умолчательное положение знака1, вызовите из его контекстного меню команду Авторазмещение.

Для удаления знака неуказанной шероховатости существует три способа:

– нажатие кнопки Удалить в диалоге редактирования знака (табл. 3.6.1),

– вызов команды Удалить неуказанную шероховатость из контекстного меню знака,

– вызов команды Редактор — Удалить — Неуказанную шероховатость.

  1. По умолчанию знак неуказанной шероховатости размещается в правом верхнем углу первого листа чертежа на расстоянии 7 мм от верхней линии рамки и 8 мм от правой линии рамки.


3.6.1.4. Технические требования

Технические требования являются частью чертежа. Они дополняют графическую информацию, содержащуюся в документе.

Технические требования представляют собой текст на поле чертежа, не принадлежащий ни видам, ни слоям. Они могут содержать ссылки на текстовые объекты текущего чертежа и также являться источниками ссылок.

Работа с техническими требованиями в чертеже — создание, редактирование, форматирование и другие действия — выполняется в окне режима работы с техническими требованиями (см. раздел 3.6.7.1.1)

Размещение технических требований на чертеже, разбивка их на страницы, редактирование и удаление описаны в разделе 3.6.7.

Вы можете настроить параметры технических требований документа, которые будут использоваться по умолчанию. Настройка параметров технических требований описана в разделах 9.2.6.19.5 и 9.2.6.19.6.


3.6.2. Управление листами

3.6. Создание чертежей

3.6.2. Управление листами

Основной инструмент, предназначенный для управления листами чертежа, — Менеджер документа.

Для вызова Менеджера документа можно выполнить любое из следующих действий:

– вызвать команду Менеджер документа из меню Сервис или контекстного меню на свободном месте документа,

– нажать кнопку Управление видами или Управление слоями на панели Текущее состояние,

– вызвать команду Вставка — Слой...

Подробно интерфейс Менеджера документа и работа с ним описаны в разделе 3.6.6.2. В настоящем разделе рассматриваются лишь предоставляемые Менеджером документа возможности работы с листами чертежа.

Работа с дополнительными листами спецификации выполняется в Менеджере документа аналогично работе с листами чертежа (см. разделы 3.6.2.1–3.6.2.3).

В этом разделе:

3.6.2.1. Оформление и формат листа

3.6.2.2. Добавление листа

3.6.2.3. Удаление листа

3.6.2.4. Переключение между листами


3.6.2.1. Оформление и формат листа

В оформление листа входят основная надпись (см. раздел 3.6.3), внешняя и внутренняя рамки. Оформления, поставляемые с КОМПАС-3D, хранятся в библиотеках — файлах *.lyt, расположенных в подпапке \Sys главной папки системы. Основная библиотека оформлений, использующаяся при создании документов, — graphic.lyt. Возможно также формирование пользовательских библиотек оформлений.

Благодаря тому, что каждому листу присвоено оформление, вам не нужно вычерчивать рамки и таблицы основной надписи.

Заполнение основной надписи подробно описано в разделе 3.6.3.1.

По умолчанию первый лист чертежа, созданного без шаблона (о шаблонах — см. раздел 11.2.1.8), имеет оформление Чертеж конструкторский. Первый лист. ГОСТ 2.104-2006, а новые (добавляемые) листы — Чертеж конструкторский. Последующие листы. ГОСТ 2.104-2006. Умолчательный формат листов — А4.

Если чертеж создан по шаблону, то количество листов в нем и их оформления соответствуют шаблону.

Вне зависимости от способа создания чертежа вы можете изменить оформление и формат любого его листа.

Рис. 3.6.2. Менеджер документа; работа с листами чертежа

Для этого выполните следующие действия.

1. Вызовите Менеджер документа.

2. Активизируйте объект Листы в Дереве листов, видов и слоев Менеджера документа.

В Списке листов, видов и слоев перечислены листы чертежа в порядке создания и показаны свойства листов (рис. 3.6.2).

3. Щелкните мышью по строке, соответствующей листу, параметры которого требуется изменить.

4. В графе Ориентация отображается значок, показывающий текущую ориентацию листа. Чтобы изменить ее, следует щелкнуть по этому значку. Значок также изменится.

5. В графе Формат отображается обозначение текущего формата листа. Чтобы сменить формат, разверните список в данной графе и выберите нужное обозначение формата.

Вы можете установить размеры листа, отличные от предусмотренных стандартом. Для этого вызовите команду Формат из контекстного меню строки или нажмите кнопку Формат на инструментальной панели Менеджера документа. В появившемся на экране диалоге включите опцию Пользовательский, введите размеры листа и закройте диалог. В графе Формат отобразятся заданные значения сторон листа.

6. В графе Кратность отображается текущая кратность формата листа. Чтобы сменить кратность, разверните список в данной графе и выберите нужное значение.

Если лист имеет нестандартные размеры, его кратность задать невозможно.

7. В графе Оформление отображается наименование присвоенного листу оформления из текущей библиотеки оформлений. Имя файла этой библиотеки отображается в графе Библиотека оформлений.

7.1. Чтобы выбрать другое оформление из текущей библиотеки, щелкните по наименованию в графе Оформление. В появившемся на экране диалоге укажите нужное оформление.

7.2. Чтобы выбрать оформление из другой библиотеки, щелкните по наименованию в графе Библиотека оформлений или нажмите кнопку Оформление на инструментальной панели Менеджера документа. В появившемся на экране диалоге укажите нужную библиотеку и оформление из нее.

8. Вы можете просмотреть сделанные изменения на экране, не закрывая диалога. Для этого нажмите кнопку Применить. Чтобы закрыть Менеджер документа с сохранением изменений и продолжить работу с чертежом, нажмите кнопку ОК.

Свойства первого листа чертежа можно настроить другим способом. Вызовите команду Сервис — Параметры или команду Параметры текущего чертежа... из контекстного меню окна документа. Раскройте вкладку Текущий чертеж появившегося на экране диалога и выполните необходимые настройки, используя элементы управления раздела Параметры первого листа.

Если вы используете одни и те же оформление и формат для листов большинства чертежей, то выполнение соответствующей настройки в каждом документе нерационально. В этом случае можно сделать так, чтобы все новые документы сразу создавались с требуемыми параметрами.

Для этого вызовите команду Сервис — Параметры... — Новые документы — Графический документ — Параметры первого листа/Параметры новых листов.

Выбирая в левой части диалога пункты Формат и Оформление, вы можете настроить эти свойства для листов всех будущих чертежей.

Подробно о работе с оформлениями чертежей рассказано в разделе 11.2.1.

В Менеджере документа вы можете задать оформление и другие параметры листов спецификаций.

Чтобы настроить дополнительные листы спецификации, выполните действия, описанные в пунктах 1–8. При выполнении пункта 2 следует активизировать объект Дополнительные листы в начале/конце документа в Списке листов, видов и слоев.

Чтобы настроить стиль спецификации активизируйте объект Листы документа и выполните действия, описанные в пунктах 7–8.


3.6.2.2. Добавление листа

Доступно два способа добавления в чертеж нового листа.

– С помощью Главного меню. Вызовите команду Вставка — Лист. Справа от имеющихся в чертеже листов появится новый лист. Его оформление и формат будут определяться настройкой, сделанной для новых листов чертежей. При необходимости эти свойства можно изменить (см. раздел 3.6.2.1).

– С помощью Менеджера документа. Для этого выполните следующие действия.

1. Вызовите Менеджер документа.

2. Выделите в Дереве листов, видов и слоев объект Листы.

3. Нажмите на инструментальной панели Менеджера документа кнопку Создать лист. В конец Списка листов, видов и слоев будет добавлена строка, соответствующая созданному листу. При необходимости измените свойства листа.

Если требуется, чтобы лист добавился в определенное место, то перед нажатием кнопки Создать лист укажите в Списке листов, видов и слоев лист, за которым должен следовать вставляемый лист.

4. Нажмите кнопку ОК диалога Менеджер документа. Он будет закрыт, а добавленный лист появится на экране справа от имеющихся листов.

В Менеджере документа вы можете добавить дополнительные листы в начале или конце документа-спецификации.


3.6.2.3. Удаление листа

Для удаления листа из чертежа выполните следующие действия.

1. Вызовите Менеджер документа.

2. Выделите в Дереве листов, видов и слоев объект Листы.

3. В Списке листов, видов и слоев выделите строку, соответствующую удаляемому листу, и нажмите кнопку Удалить.

4. Нажмите кнопку ОК диалога Менеджер документа. Он будет закрыт, а удаленный лист исчезнет с экрана.

Существование чертежа без листов невозможно. Поэтому единственный оставшийся в чертеже лист удалить нельзя.

В Менеджере документа вы можете удалить дополнительные листы в начале или конце документа-спецификации.


3.6.2.4. Переключение между листами

Все листы многолистового чертежа отображаются на экране одновременно. Однако, при вычерчивании объектов обычно устанавливается такой масштаб отображения, при котором виден только один лист или часть листа. Все остальное при этом оказывается за пределами экрана.

Лист, который расположен так, что захватывает центр окна документа (без учета области, занимаемой Деревом чертежа), считается текущим. Его номер отображается в списке листов на панели Управление листами (рис. 3.6.3).

Рис. 3.6.3. Панель Управление листами

Чтобы сделать текущим другой лист, можно воспользоваться линейками прокрутки, командой Сдвинуть, или специальной панелью Управление листами. Описание элементов управления этой панели представлено в таблице 3.6.2.

Табл. 3.6.2. Панель Управление листами
Элемент | Позволяет
Менеджер документа | Вызвать диалог Менеджер документа.
Первый лист | Сделать текущим первый лист документа. Масштаб отображения не изменяется. Кнопка недоступна, если первый лист является текущим.
Предыдущий лист | Сделать текущим лист, предшествующий листу, который является текущим в данный момент. Масштаб отображения не изменяется. Кнопка недоступна, если первый лист является текущим.
Показать лист | Показать текущий лист полностью. При этом масштаб отображения изменится так, чтобы текущий лист полностью умещался в окне чертежа, а положение текущего листа изменяется так, чтобы его центр совпадал с центром окна чертежа.
Список листов | Выбрать текущий лист. Разверните список и укажите в нем номер нужного листа. Лист с выбранным номером будет показан на экране без изменения масштаба.
Последующий лист | Сделать текущим лист, следующий за листом, который является текущим в данный момент. Масштаб отображения не изменяется. Кнопка недоступна, если последний лист является текущим.
Последний лист | Сделать текущим последний лист документа. Масштаб отображения не изменяется. Кнопка недоступна, если последний лист является текущим.


3.6.3. Основная надпись чертежа

3.6. Создание чертежей

3.6.3. Основная надпись чертежа

Основная надпись появляется и размещается на листах чертежа автоматически — пользователю требуется лишь заполнить ее ячейки. В некоторые из них возможен полуавтоматический ввод текста.

Так как основная надпись является частью оформления, изменение ее размеров или структуры непосредственно в документе невозможно.

Чтобы задать для листа другую основную надпись, нужно присвоить ему оформление, содержащее эту основную надпись.

Если листу необходимо задать нестандартную основную надпись, вам придется сначала описать ее, включить в оформление, а затем присвоить это оформление документу.

Подробнее об оформлении листа см. раздел 3.6.2.1.

В этом разделе:

3.6.3.1. Заполнение основной надписи

3.6.3.1.1. Обозначение документа

3.6.3.1.2. Пользовательское меню

3.6.3.1.3. Дата

3.6.3.1.4. Текстовые шаблоны

3.6.3.1.5. Коды и наименования

3.6.3.2. Удаление содержимого основной надписи


3.6.3.1. Заполнение основной надписи

Заполнение граф основной надписи в целом аналогично вводу текста в ячейки обычной таблицы.

Графы, текст в которых является стандартным (Разработал, Проверил и др.), недоступны для ввода и редактирования.

Существует три способа перехода в режим заполнения основной надписи:

– двойной щелчок левой кнопкой мыши по основной надписи,

– вызов команды Заполнить основную надпись из ее контекстного меню,

– вызов команды Вставка — Основная надпись.

В режиме заполнения основной надписи ее внешний вид изменяется — границы ячеек отображаются с учетом заданных отступов текста.

Введите или отредактируйте текст в графах основной надписи.

Система предоставляет возможность полуавтоматического заполнения граф основной надписи. После двойного щелчка мышью в какой-либо графе штампа на экране появляется: диалог для ввода обозначения, или меню, из которого можно выбрать нужную строку, или календарь, из которого можно выбрать дату, или окно выбора текстового шаблона. Кроме того, возможен выбор кода и наименования документа из специального диалога.

Перечисленные возможности подробно рассмотрены в следующих разделах.

В графу Масштаб можно вставить ссылку на масштаб любого из имеющихся в чертеже видов (о создании ссылок см. раздел 3.4.1.4.1). Тогда при изменении масштаба этого вида новое значение будет передаваться в графу Масштаб.

Систему можно настроить так, чтобы в основной надписи автоматически формировалась ссылка на первый созданный пользователем вид. Для этого включите опцию Создавать ссылку на масштаб вида в основной надписи в диалоге настройки нового вида (см. раздел 9.2.6.19.1).

Заполнив все графы основной надписи, нажмите кнопку Создать объект или нажмите комбинацию клавиш <Ctrl>+<Enter> для сохранения сделанных изменений и выхода из режима работы с основной надписью.

Сведения, введенные в ячейки типа Общий для документа, автоматически передаются в другие ячейки этого же типа (в том числе на других листах). Типы ячеек задаются при настройке основных надписей, входящих в оформления листов. Например, в оформлениях, поставляемых вместе с системой, основные надписи настроены так, что обозначение изделия, введенное на одном из листов, передается в Графы 26 и ячейки Обозначение основных надписей на всех остальных листах.

Различающуюся информацию необходимо ввести на каждом листе.

Графы Количество листов и Номер листа заполняются автоматически и недоступны для редактирования. При необходимости вы можете задать предопределенное количество листов, а также отключить автоопределение номера листа (см. раздел 9.2.6.19.3).

В этом разделе:

3.6.3.1.1. Обозначение документа

3.6.3.1.2. Пользовательское меню

3.6.3.1.3. Дата

3.6.3.1.4. Текстовые шаблоны

3.6.3.1.5. Коды и наименования


3.6.3.1.1. Обозначение документа

Обозначение документа может быть простым или составным. Обозначение считается простым, если оно включает в себя только базовое обозначение. В составное обозначение помимо базовой части входит номер исполнения, и/или дополнительный номер исполнения, и/или код документа.

Простое обозначение можно вводить или редактировать непосредственно в ячейке основной надписи, а работа с составным обозначением производится в специальном диалоге (рис. 3.6.4), где для каждой части обозначения предусмотрено отдельное поле.

Рис. 3.6.4. Диалог ввода обозначения

Для вызова диалога работы с составным обозначением служит команда контекстного меню Редактировать обозначение....

Введите или отредактируйте в диалоге требуемые элементы обозначения. В поле разделителя возможен ввод только одного символа, в любое другое поле — одной строки.

Контекстное меню диалога содержит основные команды для работы с текстом. Эти же и другие команды доступны в главном меню и на вкладках Панели свойств.

Задание кода документа возможно как путем непосредственного ввода, так и путем выбора из диалога Коды и наименования (см. раздел 3.6.3.1.5).

Завершив ввод или редактирование обозначения, закройте диалог кнопкой ОК. В основной надписи появляется обозначение, составленное из фрагментов, заданных в полях диалога ввода обозначения. Если в диалоге был задан код документа, то в графу Наименование добавляется соответствующее коду наименование.

Если был задан произвольный код документа, отсутствующий в файле кодов и наименований (см. раздел 9.5.5.3), то соответствующее ему наименование вводится вручную.

Системные разделители (первый — тире, второй — точка, третий — пробел) не включаются в готовое обозначение, если соответствующая часть обозначения (номер исполнения, дополнительный номер исполнения, код документа) не задана.

Если вместо системных разделителей введены другие символы, то они безусловно включаются в обозначение.

Если обозначение составное, то при попытке его редактирования диалог Обозначение появляется автоматически. Кроме того, для вызова диалога можно дважды щелкнуть на обозначении.

Составное обозначение «превращается» в простое, если очистить в диалоге поля с номером исполнения, дополнительным номером и кодом (разделители должны быть системными или отсутствовать).


3.6.3.1.2. Пользовательское меню

Пользовательское меню появляется при двойном щелчке на любой графе, в которую нужно вводить фамилию. Оно включает команды Разработчики, Технологи и Нормоконтроль, каждая из которых содержит подменю — список фамилий (рис. 3.6.5). Выбранная в этом списке фамилия автоматически размещается в графе основной надписи. Если фамилия длинная, произойдет автоподбор ширины букв, и текст будет занимать только отведенное ему место.

Рис. 3.6.5. Пример выбора фамилии сотрудника отдела нормоконтроля при заполнении штампа

Структура меню, показанного на рис. 3.6.5, и содержание его строк хранятся в специальном файле пользовательского меню Grарhic.рmn. Этот файл поставляется вместе с системой и при ее установке размещается в подпапке \Sys главной папки КОМПАС-3D. Вы можете модифицировать этот файл, внеся в него какие-либо строки или разделы меню или добавив в существующие разделы фамилии сотрудников вашего предприятия. После этого при вызове пользовательского меню в его строках будут отражены внесенные вами изменения.

По двойному щелчку мыши в графах Масштаб и Литеры появляются соответствующие пользовательские меню. Состав этих меню также хранится в файле Grарhic.рmn и может быть изменен пользователем.


3.6.3.1.3. Дата

По двойному щелчку в любой графе, в которую нужно вводить дату, на экране появляется диалог Ввод даты (рис. 3.6.6). По умолчанию в нем активна текущая дата. Вы можете выбрать другую дату, воспользовавшись списками годов, месяцев и чисел. После нажатия клавиши <Enter> указанная дата будет автоматически размещена в соответствующей графе штампа. Формат даты подчиняется настройкам Windows для краткого формата вывода даты.

Рис. 3.6.6. Выбор даты при заполнении штампа


3.6.3.1.4. Текстовые шаблоны

По двойному щелчку мыши в остальных графах основной надписи на экране появляется окно Библиотекаря текстовых шаблонов1. Выберите из него нужный шаблон и нажмите кнопку Вставить в документ. Текст будет автоматически размещен в соответствующей графе штампа. Подробно о работе с текстовыми шаблонами рассказано в разделе 4.1.2.11.6.

Если текст, который необходимо ввести в графу надписи, отсутствует среди текстовых шаблонов, его нужно набрать вручную. Если есть вероятность, что такой текст придется вводить еще несколько раз, включите режим, позволяющий автоматически сохранить введенный в графу основной надписи текст в файле текстовых шаблонов. Для этого выполните следующие действия.

1. Вызовите команду Сервис — Параметры... — Система — Текстовый редактор — Текстовые шаблоны.

2. В правой части появившегося диалога включите опцию Сохранять введенный текст в файле.

При необходимости укажите файл текстовых шаблонов для сохранения вводимых текстов (по умолчанию система предлагает файл Grарhic.tdр).

3. Нажмите кнопку OK, после чего настройка вступит в силу.

  1. Если на вашем рабочем месте установлен Справочник Материалы и Сортаменты, то по двойному щелчку в графе, содержащей сведения о материале детали, будет запускаться этот Справочник.


3.6.3.1.5. Коды и наименования

Номенклатура конструкторских документов установлена ГОСТ 2.102–68. Согласно этому стандарту каждому типу документа соответствуют определенные код и наименование. При заполнении основных надписей КОМПАС-документов ввод этих кодов и наименований может быть автоматизирован.

Для вставки кода и наименования служит команда Вставить код и наименование.... Она доступна в режиме заполнения основной надписи документа, а также при работе в диалоге ввода обозначения (см. раздел 3.6.3.1.1). Команда находится в меню Вставка и в контекстном меню.

После вызова команды Вставить код и наименование... на экране появляется диалог Коды и наименования (рис. 3.6.7).

Рис. 3.6.7. Диалог Коды и наименования

В этом диалоге перечислены коды и наименования документов.

Код, вставленный в обозначение, может быть отделен пробелом или любым другим символом. Нужный символ задается в диалоге ввода обозначения. По умолчанию разделителем перед полем Код является пробел. Чтобы изменить разделитель, введите произвольный символ в соответствующее поле диалога Обозначение. Если требуется создать обозначение без разделителя, удалите пробел из поля.

Слева от названия раздела в диалоге кодов и наименований находится значок «+». Чтобы раскрыть раздел, следует щелкнуть по этому значку. Он сменится на «-». В перечне появятся документы раздела.

Выберите нужный код и нажмите кнопку ОК. Можно также дважды щелкнуть в ячейке Код. Диалог закроется. Выбранный код будет вставлен в графу Обозначение, а соответствующее ему наименование — в графу Наименование. Порядок вставки зависит от содержимого этих граф и определяется следующими правилами.

– Если графы пусты, в них вставляются код и наименование документа.

– Если в графах содержится произвольный текст, то код документа и его наименование вставляются после этого текста.

– Если последние знаки в графе Обозначение составляют один из стандартных кодов, то эти знаки удаляются. Вместо них вставляется выбранный код.

– Если последние знаки в графе Наименование составляют одно из стандартных наименований документов, то эти знаки удаляются. Вместо них вставляется выбранное наименование документа.

– После текста, составляющего стандартный код или наименование, в графе может находиться любое количество знаков «точка» или «пробел». При вставке выбранных кода и наименования эти знаки удаляются.

Автоматическая вставка кода и наименования производится в ячейки типа Наименование изделия и Обозначение документа.

Содержимое диалога Коды и наименования определяется файлом кодов и наименований — graphic.kds. По умолчанию он находится в подпапке \Sys главной папки системы. Формат файла — текстовый, поэтому при необходимости файл graphic.kds может быть открыт и отредактирован в любом текстовом редакторе, см. раздел 9.5.5.3.

Вставка кода из диалога превращает простое обозначение в составное (см. раздел 3.6.3.1.1).


3.6.3.2. Удаление содержимого основной надписи

Подобная операция может потребоваться, например, если готовый чертеж был взят как заготовка для разработки нового документа.

Существует два способа удаления содержимого основной надписи чертежа:

– вызов команды Редактор — Удалить — Содержимое основной надписи,

– вызов команды Удалить содержимое из контекстного меню основной надписи.

Будьте особенно внимательны при удалении всего содержимого основной надписи, так как эту операцию невозможно отменить.


3.6.4. Сведения о видах

3.6. Создание чертежей

3.6.4. Сведения о видах

С точки зрения проектировщика вид — это изображение обращенной к наблюдателю видимой части поверхности предмета.

Вид как часть КОМПАС-чертежа — это «контейнер» для объектов, а также сами объекты, находящиеся в этом «контейнере».

Объекты, содержащиеся в одном виде КОМПАС-3D, могут формировать как одно изображение (вид, разрез, сечение или выносной элемент), так и сразу несколько. В принципе, чертеж может состоять из одного-единственного вида, который будет содержать все необходимые изображения.

Однако при работе в КОМПАС-3D настоятельно рекомендуется разбивать всю графическую информацию в чертеже на виды, размещая каждое изображение в отдельном виде. Такой подход дает следующие преимущества.

– Получение изображения в различных масштабах без ручного пересчета размеров — он производится автоматически (см. раздел 3.6.4.1).

– Удобство компоновки изображений на листе чертежа: каждый вид можно масштабировать, перемещать и поворачивать целиком, как один объект (см. раздел 3.6.5.7).

– Возможность формирования ассоциативной связи между обозначениями стрелок взгляда, линий разреза/сечения, выносных элементов и обозначениями соответствующих изображений. Благодаря этой связи такие данные, как буква, номер листа и т.п. автоматически передаются между обозначениями.

Эти возможности заметно ускоряют создание сборочных чертежей, чертежей крупных объектов, насыщенных чертежей.

Кроме того, в любой момент работы над чертежом вы можете разрешить/запретить редактирование любых видов (делая их активными или фоновыми), а также включить/отключить отображение видов (делая их видимыми или погашенными). Подробнее о возможных состояниях вида см. раздел 3.6.4.2. Выбор нужного свойства для конкретного вида производится при настройке состояния видов (см. раздел 3.6.5.2).

В любом, кроме системного, виде чертежа можно создать один или несколько разрывов изображения (см. раздел 3.6.5.8).

Особый тип видов — ассоциативные виды. Они содержат автоматически сформированные проекции трехмерных моделей. Подробнее об ассоциативных видах рассказано в разделе 3.7.

В этом разделе:

3.6.4.1. Получение изображений в различных масштабах

3.6.4.2. Состояния видов

3.6.4.3. Создание простого вида

3.6.4.4. Настройка параметров видов

3.6.4.5. Дерево чертежа

3.6.4.6. Надпись вида

3.6.4.6.1. Объект оформления, связанный с видом

3.6.4.6.2. Ассоциативная связь между надписью вида и обозначением объекта оформления

3.6.4.6.3. Редактирование надписи вида как части вида

3.6.4.6.4. Редактирование надписи вида как текстового объекта


3.6.4.1. Получение изображений в различных масштабах

Создавая чертеж в КОМПАС-3D, пользователь может задавать натуральные размеры геометрических объектов (отрезков, дуг и т.п.), формирующих контуры изделий, а для масштабирования изображения изделия использовать виды.

Например, для размещения чертежа конструкции с общей длиной 1500 мм на листе формата А1 требуется начертить ее в масштабе 1:2,5. При традиционном черчении для получения такого уменьшенного изображения пришлось бы вручную делить параметры каждого геометрического элемента на 2,5, а при простановке размеров — также вручную вписывать действительные значения в размерные надписи.

В КОМПАС-3D можно сразу (т.е. до начала формирования изображения) создать в чертеже вид с масштабом 1:2,5 и чертить в нем, вводя натуральные геометрические размеры. Масштабирование изображения (уменьшение в 2,5 раза) будет производиться системой автоматически. При простановке размеров их действительные значения также будут определяться автоматически.

Если впоследствии окажется, что масштаб необходимо изменить, изображение не нужно будет вычерчивать заново, пересчитывая размеры. Потребуется лишь изменение масштаба вида, в котором это изображение расположено.

При создании нового чертежа в нем автоматически формируется системный вид с масштабом 1:1.

Параметры системного вида изменить невозможно. Поэтому, если в чертеже требуется создать изображение в масштабе, отличном от 1, необходимо сначала создать новый вид с нужным масштабом.

Если вы используете один и тот же масштаб для большинства чертежей, то создание соответствующего вида в каждом чертеже нерационально. В этом случае можно сделать так, чтобы в каждом новом чертеже сразу создавался вид с требуемым масштабом. Для этого вызовите команду Сервис — Параметры... — Новые документы — Графический документ — Параметры документа — Вид.

В правой части появившегося диалога включите опцию Создавать новый вид и задайте масштаб вида. При этом возможен как ввод произвольных чисел в поля, так и выбор стандартного значения из меню, вызываемого кнопкой, расположенной между полями ввода масштаба.

Масштаб, заданный при настройке, будет автоматически передаваться в соответствующую графу основной надписи новых чертежей.

Вне зависимости от состояния опции Создавать новый вид при создании нового чертежа в нем автоматически формируется системный вид.


3.6.4.2. Состояния видов

Состояние вида определяется значениями следующих свойств:

– активность — управляет доступностью вида и объектов в нем для редактирования и имеет два значения:

• активный — объекты вида доступны для редактирования и удаления; возможно изменение параметров вида, в том числе его положения в чертеже;

• фоновый — объекты вида недоступны для редактирования и удаления; если включена привязка к объектам фоновых слоев (см. раздел 3.1.1.2), то к объектам фоновых видов можно осуществить привязку; изменение параметров вида и его перемещение невозможно.

– видимость — управляет отображением объектов вида на экране и имеет два значения:

• видимый — объекты вида отображаются на экране, при этом активные виды показываются выбранными для них цветами, а фоновые — установленным стилем;

• погашенный — объекты вида не отображаются на экране вне зависимости от того, активный он или фоновый (видна лишь габаритная рамка вида); таким образом, погашенный вид полностью недоступен для любых операций.

Стиль (тип линии, ее толщина и цвет), которым отображаются объекты фоновых видов и рамки видов, можно задать в диалоге настройки отрисовки видов (см. раздел 9.1.7.8). В этом же диалоге можно отключить показ рамок видов. Цвет, которым отображаются активные виды, можно задать в Менеджере документа (см. раздел 3.6.5.2) или на Панели свойств при создании/редактировании вида (см. раздел 3.6.4.4).

Среди всех видов один — и только один — имеет статус текущий.

Именно в текущий вид (на его текущий слой) записываются вновь создаваемые объекты.

Текущим можно сделать любой вид. При этом он автоматически становится видимым и активным. Пока вид является текущим, эти значения изменить нельзя (т.е. текущий вид невозможно ни погасить, ни сделать фоновым). Объекты текущего вида отрисовываются на экране реальными стилями линий, точек и штриховок, которые назначены в диалогах настройки системы.

После того как статус текущий присваивается другому виду, состояние вида, который был текущим ранее, восстанавливается. Например, в какой-то момент работы над чертежом Вид 1 был текущим. Вид 2 в это время был фоновым и видимым. Затем Вид 2 сделали текущим, в результате чего он стал активным. После завершения редактирования Вида 2 текущим вновь был сделан Вид 1. Вид 2 при этом снова стал фоновым.

В зависимости от настройки системы (см. раздел 9.1.5.2) погашенные виды могут выводиться или не выводиться на бумагу.

Управление состоянием видов рассмотрено в разделе 3.6.5.2.


3.6.4.3. Создание простого вида

Чтобы создать в чертеже простой (пользовательский) вид, вызовите команду Вставка — Вид или нажмите кнопку Создать новый вид на панели Виды.

Форма курсора изменится — он превратится в изображение координатных осей.

Настройте параметры нового вида (см. раздел 3.6.4.4) и задайте его точку привязки.


3.6.4.4. Настройка параметров видов

Настройка параметров вида производится с помощью элементов на вкладке Настройка Панели свойств. Эти элементы представлены в таблице 3.6.3.

Табл. 3.6.3. Элементы управления параметрами вида чертежа
Элемент | Описание
Номер1 | Поле, содержащее порядковый номер вида. По умолчанию виду присваивается первый свободный номер. Вы можете ввести в данное поле любое число, отличное от номеров уже имеющихся видов.
Имя1 | Поле, содержащее имя вида — его название, отображающееся в Дереве чертежа (см. раздел 3.7.1.1) и в поле Текущий вид на панели Текущее состояние. Вы можете ввести в данное поле любой набор символов.
Цвет | Список, позволяющий выбрать цвет вида в активном состоянии (о состояниях видов — см. раздел 3.6.4.2).
Масштаб | Список, позволяющий выбрать масштаб вида. Вы можете также ввести числа, определяющие масштаб, с клавиатуры.
Выносные линии | Группа переключателей, позволяющая указать, нужно ли масштабировать выносные линии и линии-выноски размеров в виде (если они есть в виде) при изменении его масштаба. Подробнее о масштабировании выносных линий размеров см. раздел 3.5.4.2.1.
Точка вида | Группа переключателей, позволяющая выбрать положение базовой точки вида.
Точка привязки | Поля координат точки привязки вида (точки, с которой должна совпадать базовая точка этого вида) в абсолютной системе координат (начало абсолютной системы координат чертежа совпадает с левым нижним углом его габаритной рамки).
Угол | Поле угла поворота вида вокруг его базовой точки. Чтобы повернуть вид вокруг другой точки, воспользуйтесь командой Поворот (см. раздел 3.5.4.1).
  1. Поле отсутствует на Панели свойств при создании Стандартных ассоциативных видов (см. раздел 3.7.2.1).


3.6.4.5. Дерево чертежа

Дерево чертежа — представленная в графическом виде последовательность создания видов в текущем чертеже (рис. 3.6.8).

Рис. 3.6.8. Дерево чертежа

Управление отображением окна Дерева чертежа производится командой Вид — Дерево чертежа. Когда показ Дерева включен, рядом с названием команды в меню отображается «галочка».

Если открыто несколько окон одного чертежа, показ Дерева может быть включен или выключен в любом из них.

Дерево чертежа располагается в отдельном окне, которое всегда находится внутри окна чертежа. Вы можете изменить размер окна Дерева, перетаскивая мышью его углы или границы.

В Дереве чертежа отображаются виды в порядке их создания.

Слева от названия вида в Дереве может отображаться пиктограмма со значком «+». Щелчок мышью на этом значке позволяет просмотреть подчиненные виду объекты — макроэлементы, вставки видов и фрагментов, а для ассоциативного вида также модель, изображение которой содержится в виде, и местные разрезы (если они есть в виде). Подробно об ассоциативных видах в Дереве чертежа рассказано в разделе 3.7.1.

Каждый вид автоматически возникает в Дереве сразу после того, как он создан в чертеже. Название присваивается видам также автоматически. Оно содержит имя вида и его масштаб. Например, «Системный вид (1:1)», «Вид 1 (2:1)» и т.д.

Состояние вида (текущий, фоновый или погашенный; подробнее см. раздел 3.6.4.2) показывается в Дереве чертежа справа от пиктограммы вида буквой «т», «ф» или «п» в круглых скобках (рис. 3.6.8).

В Дереве чертежа отображаются также имеющиеся в чертеже макроэлементы, вставки видов и фрагментов. Подробно об этом рассказано в разделе 3.8.

Размер пиктограмм в Дереве чертежа можно настроить, см. раздел 9.1.3.8.7.

Управление показом тех или иных типов объектов в Дереве производится кнопкой Состав Дерева чертежа, расположенной в верхней части окна.

При выделении элементов Дерева чертежа (моделей и видов) в окне чертежа подсвечиваются соответствующие объекты.

Используя контекстное меню элементов Дерева чертежа, можно управлять состоянием и некоторыми параметрами изображения. Например, команды контекстного меню вида (рис. 3.6.9, а) позволяют разрушать или удалять вид, команды контекстного меню вставки фрагмента (рис. 3.6.9, б) — редактировать вставку.

Рис. 3.6.9. Контекстное меню элементов Дерева чертежа: а) вида (ассоциативного), б) вставки фрагмента
а) | б)


3.6.4.6. Надпись вида

Надпись — текстовый объект, входящий в состав вида.

Надпись вида используется для автоматического формирования и обновления текста, сопровождающего:

– разрез,

– сечение,

– выносной элемент,

– вид по стрелке,

– обозначение узла,

– обозначение узла в сечении.

Надпись вида состоит из элементов (обозначение, знак «развернуто», масштаб, и др.), любой из которых пользователь может по своему усмотрению включить в надпись вида или исключить из нее. Для этого служат элементы управления вкладки Надпись вида, появляющейся на Панели свойств во время создания или редактирования вида (см. раздел 3.6.4.6.3).

Каждый элемент надписи вида ассоциативно связан с объектом оформления или параметром самого вида (см. разделы 3.6.4.6.1, 3.6.4.6.2).

Наличие в чертеже обозначений линий разреза, выносных элементов, стрелок взгляда и обозначений узлов предполагает наличие в нем соответствующих изображений. Поэтому, чтобы ускорить работу, по окончании создания любого из перечисленных обозначений автоматически запускается команда создания вида. Надпись этого вида ассоциативно связывается с только что созданным объектом оформления. Пользователю остается настроить, если нужно, другие параметры вида (в том числе его надписи) и указать положение вида в чертеже. После этого можно приступать к вычерчиванию изображения в виде.

Надпись вида можно редактировать:

– как часть вида — при создании или редактировании самого вида, см. раздел 3.6.4.6.3 (для неассоциативных видов) и 3.7.1.3.4 (для ассоциативных видов),

– как текстовый объект (см. раздел 3.6.4.6.4).

Чертеж может содержать ассоциативные виды исполнений модели, одно из которых является зеркальным. В надписи этих видов автоматически включаются ссылки на обозначения исполнений. Подробнее см. раздел 3.7.3.12.

В этом разделе:

3.6.4.6.1. Объект оформления, связанный с видом

3.6.4.6.2. Ассоциативная связь между надписью вида и обозначением объекта оформления

3.6.4.6.3. Редактирование надписи вида как части вида

3.6.4.6.4. Редактирование надписи вида как текстового объекта


3.6.4.6.1. Объект оформления, связанный с видом

Объект оформления, связанный с видом — обозначение выносного элемента, линии разреза, стрелки взгляда, узла или узла в сечении, которое является источником буквенного или цифрового обозначения в надписи вида.

Связь между видом и объектом оформления может формироваться двумя способами.

– Автоматически. Вид, который автоматически создается после выполнения команды простановки объекта оформления (Линия разреза, Выносной элемент, Стрелка взгляда, Обозначение узла, Обозначение узла в сечении), связывается с объектом, созданным этой командой. Ассоциативные виды1 Разрез/сечение, Выносной элемент, Вид по стрелке связываются с указанными для их построения объектами оформления.

– Вручную. В надписи вида вручную создается ссылка на нужный объект оформления. Ссылку можно создать с помощью кнопки Ссылка на вкладке Надпись вида Панели свойств во время создания (редактирования) вида или во время редактирования надписи вида как текстового объекта. Этот способ доступен только для неассоциативных видов.

Благодаря наличию связи обозначения объектов оформления и надписи видов всегда соответствуют друг другу.

  1. Об ассоциативных видах рассказано в разделе 3.7.


3.6.4.6.2. Ассоциативная связь между надписью вида и обозначением объекта оформления

3.6.4.6.2. Ассоциативная связь между надписью вида
и обозначением объекта оформления

Надпись вида состоит из следующих элементов:

– буквенное или цифровое обозначение,

– знак «развернуто»,

– масштаб вида,

– знак «повернуто»,

– угол поворота,

– номер листа,

– обозначение зоны.

Надпись вида, в котором изображен узел или узел в сечении, может содержать только цифровое обозначение и номер листа.

Обозначение объекта оформления состоит из следующих элементов:

– буква или цифра,

– номер листа,

– номер зоны.

Все элементы в надписи вида и обозначении объекта оформления (кроме буквы или цифры в составе последнего1) являются ссылками. Для надписи вида источниками ссылки являются объект оформления, связанный с видом, и параметры самого вида. Для обозначения объекта оформления источником ссылки является вид, с которым связано это обозначение. Ссылки формируют ассоциативные связи между надписью вида и обозначением связанного с ним объекта оформления. Благодаря этим связям надпись вида и обозначение объекта оформления всегда соответствуют друг другу. Пользователь может в любой момент включить или исключить любой элемент, а следовательно, включить или отключить любую связь.

Все возможные связи и их направление схематично показаны стрелками на рис. 3.6.10. Стрелки направлены от источника к ссылке.

Рис. 3.6.10. Схема связей между надписью вида
и обозначением линии разреза (для машиностроения), связанного с этим видом

Рассмотрим пример использования связей между надписью вида и обозначением объекта оформления.

Допустим, в чертеже создан вид, изображающий выносной элемент. Обозначение выносного элемента: Б (1А), надпись вида: Б (2:1) (2В).

Впоследствии в чертеж были внесены следующие изменения:

– добавлены еще несколько изображений, в результате чего обозначение выносного элемента сменилось на Г,

– изменен масштаб вида, содержащего выносной элемент: принят масштаб 2,5:1,

– вид перенесен в зону 2А.

После этих изменений обозначение выносного элемента автоматически принимает вид Г (2А), а надпись вида, содержащего выносной элемент — Г (2,5:1) (2В).

  1. Буква или цифра в обозначении объекта оформления определяется системой автоматически или вводится пользователем вручную.


3.6.4.6.3. Редактирование надписи вида как части вида

Настройка надписи вида производится с помощью элементов управления вкладки Надпись вида Панели свойств (рис. 3.6.11).

Описание этих элементов представлено в таблице 3.6.4.

Рис. 3.6.11. Вкладка Надпись вида

Табл. 3.6.4. Элементы управления надписью вида
Элемент | Описание
Окно просмотра надписи вида | Справочное поле, содержащее текущую надпись вида.
Вставить ссылку | Кнопка, позволяющая создать или изменить в надписи вида ссылку на объект оформления. После нажатия кнопки на экране появится диалог создания ссылки (см. рис. 3.4.3). Выберите нужный тип источника, задайте остальные параметры ссылки и нажмите кнопку ОК. После того как ссылка будет создана, между видом и объектом оформления, выбранным в качестве источника ссылки, сформируется связь. Текст ссылки появится в Окне просмотра надписи вида на Панели свойств. Станут доступны опции Обозначение, Лист и Зона.
Обозначение | Выключение этой опции разрывает связь вида с объектом оформления, поэтому последующее включение опции становится невозможным. Чтобы сформировать связь заново, следует нажать кнопку Вставить ссылку.
Развернуто | Если опция отключена, то значок «развернуто» не включается в надпись вида, а если включена, то включается.
Масштаб | Опция, управляющая включением в надпись вида его текущего масштаба.
Повернуто | Если опция отключена, то значок «повернуто» не включается в надпись вида, а если включена, то включается.
Угол | Опция, управляющая включением в надпись вида значения угла поворота. Опция Угол доступна, если включена опция Повернуто.
Лист | Опция, управляющая включением в надпись вида ссылки на номер листа чертежа, где располагается связанный с видом объект оформления. Опция Лист доступна, если включена опция Обозначение.
Зона | Опция, управляющая включением в надпись вида ссылки на обозначение зоны чертежа, где располагается связанный с видом объект оформления. Если опция включена, то обозначение зоны — при условии, что в чертеже включено разбиение на зоны — добавляется в надпись. Если опция отключена, то обозначение зоны не добавляется в надпись вида. Опция Зона доступна, если включена опция Обозначение.


3.6.4.6.4. Редактирование надписи вида как текстового объекта

Поскольку надпись вида является текстовым объектом, для редактирования надписи можно использовать приемы, характерные для этих объектов.

Чтобы изменить положение надписи вида, выделите ее, а затем переместите и/или поверните с помощью мыши. Можно также воспользоваться командой Редактировать размещение. Она доступна, если в надписи вида есть обычный (не являющийся ссылкой) текст.

Обратите внимание на то, что при повороте вида угол поворота надписи вида изменяется так, чтобы она оставалось параллельна оси Х абсолютной системы координат.

Чтобы изменить содержимое и/или оформление надписи, дважды щелкните по ней мышью или вызовите из контекстного меню вида команду Надпись вида.... На Панели свойств появятся вкладки с элементами управления для настройки надписи вида:

– вкладка Надпись вида позволяет изменить состав надписи; описание элементов управления вкладки см. табл. 3.6.4 (единственное отличие — при редактировании надписи вида как текстового объекта на вкладке отсутствует окно просмотра),

– вкладка Формат позволяет изменить форматирование текста надписи, например, выбрать шрифт, настроить параметры абзаца и т.п.,

– вкладка Вставка позволяет вставить в надпись различные объекты, например, текстовые шаблоны, спецзнаки, символы, и т.п.

В режиме редактирования можно также выполнить следующие действия:

– ввести произвольный текст в любое место надписи,

– изменить параметры ссылок, входящих в состав надписи, с помощью команды Редактировать ссылку из контекстного меню (рис. 3.6.12),

– превратить ссылки в обычный текст с помощью команды Разрушить ссылку из контекстного меню (рис. 3.6.12).

Рис. 3.6.12. Редактирование и разрушение ссылок в надписи вида

Изменение ссылок на объект оформления в надписи ассоциативного вида невозможно. Это означало бы разрыв связи между видом и объектом оформления и сделало бы невозможным существование ассоциативного вида.

Вы можете копировать и переносить надписи видов через буфер. После вставки надписи вида из буфера она преобразуется в текст на чертеже, т.е. перестает быть свойством определенного вида. При этом, если надпись вставляется в тот же документ, откуда была скопирована, то ссылки, имеющиеся в надписи, сохраняют связи со своими источниками. Если же надпись вида вставляется в другой документ, то связи ссылок с источниками разрываются — ссылки отображаются красным цветом.


3.6.5. Приемы работы с видами

3.6. Создание чертежей

3.6.5. Приемы работы с видами

Чтобы использование видов была максимально удобным, КОМПАС-3D предоставляет пользователю разнообразные приемы работы с видами. Практически для каждого приема предусмотрено несколько способов выполнения.

В частности, одним из них является вызов команд из контекстных меню видов в Дереве чертежа. Включение отображения Дерева чертежа и управление им подробно описаны в разделе 3.6.4.5.

Удобные возможности управления состоянием видов чертежа предоставляет Менеджер документа. Для отображения его на экране выполните одно из следующих действий:

– вызовите команду Менеджер документа из меню Сервис или контекстного меню на свободном месте документа,

– нажмите кнопку Управление видами или Управление слоями на панели Текущее состояние,

– вызовите команду Вставка — Слой...

Подробно интерфейс Менеджера документа и работа с ним описаны в разделе 3.6.6.2. В настоящем разделе рассматриваются лишь предоставляемые Менеджером документа возможности работы с видами.

В этом разделе:

3.6.5.1. Переключение между видами

3.6.5.2. Изменение состояния вида

3.6.5.3. Изменение параметров вида

3.6.5.4. Выделение вида

3.6.5.5. Копирование и перенос видов через буфер

3.6.5.6. Удаление вида

3.6.5.7. Компоновка видов на листе

3.6.5.8. Разрыв вида

3.6.5.8.1. Создание разрыва

3.6.5.8.2. Направление сдвига при разрыве

3.6.5.8.3. Амплитуда

3.6.5.8.4. Особенности работы с разрывами изображений


3.6.5.1. Переключение между видами

Вы можете сделать нужный вид текущим, а также настроить состояние других видов с помощью Менеджера документа (см. раздел 3.6.5.2).

Однако существуют более быстрые способы смены текущего вида.

– Выберите или введите с клавиатуры номер или название (это зависит от настройки, см. раздел 9.1.7.8) нужного вида в поле Текущий вид на панели Текущее состояние (рис. 3.6.13), и он станет текущим. Вид, выделенный в списке, подсвечивается в окне документа. Значки перед номером или названием вида показывают его текущее состояние и цвет.

Рис. 3.6.13. Выбор текущего вида

– Выделите нужный вид в Дереве чертежа и вызовите из контекстного меню команду Текущий.

– Если нужный вид включен, т.е. является активным и видимым, дважды щелкните мышью на каком-либо объекте этого вида. Запустится процесс редактирования объекта, а вид, в котором объект находится, станет текущим.

Вид, который был текущим ранее, вернется в свое прежнее состояние.


3.6.5.2. Изменение состояния вида

Чтобы изменить состояние вида, выполните следующие действия.

1. Вызовите Менеджер документа.

2. Выделите в Дереве листов, видов и слоев Менеджера корневой объект — текущий чертеж.

В Списке листов, видов и слоев будут показаны все присутствующие в чертеже виды их свойства.

3. Выделите в Списке вид, состояние которого требуется изменить.

4. Задайте свойства вида с помощью кнопок инструментальной панели Менеджера документа:

• Сделать текущим

• Активный

• Фоновый

• Видимый

• Погашенный

Вы можете одинаковым образом изменить состояния сразу нескольких видов. Для этого выделите их и нажмите нужную кнопку на инструментальной панели Менеджера документа.

Чтобы сделать активными и видимыми все виды чертежа или все слои вида (фрагмента), нажмите кнопку Включить все на инструментальной панели Менеджера документа.

Значения свойств видов можно изменять также, щелкая на пиктограммах в полях Списка листов, видов и слоев.

5. При необходимости вы можете поменять и другие параметры видов: номер, имя, цвет.

6. Закройте Менеджер документа, нажав кнопку ОК.

Иногда бывает удобно изменять состояние видов другими способами:

– с помощью команд Текущий, Фоновый, Погасить из контекстного меню вида в Дереве чертежа,

– с помощью значков, отображающих свойства Активность и Видимость в списке видов на панели Текущее состояние (рис. 3.6.13); щелчок на значке изменяет значение свойства вида на противоположное.

Не забывайте, что состояние текущего вида изменить невозможно.


3.6.5.3. Изменение параметров вида

Чтобы изменить параметры текущего вида, нажмите кнопку Параметры текущего вида на инструментальной панели Виды или вызовите команду из меню Сервис.

Если Дерево чертежа находится на экране, то вы можете настроить параметры не только текущего, но и любого активного вида чертежа. Для этого вызовите из его контекстного меню команду Параметры вида.

На Панели свойств появятся элементы, представленные в таблице 3.6.3.

Настройте параметры вида требуемым образом и нажмите кнопку Создать объект.

Если нужно изменить только масштаб вида, воспользуйтесь командой Масштаб из контекстного меню этого вида в Дереве чертежа.

Если масштаб вида, содержащего выносные линии и линии-выноски размеров, был изменен, на экране появляется запрос на масштабирование этих объектов. Вы можете подтвердить масштабирование или отказаться от него (подробнее см. раздел 3.5.4.2.1).

Вы можете изменить параметры любого вида чертежа, кроме Системного. Параметры этого вида следующие:

– Имя Системный вид

– Номер 0

– Цвет Черный

– Масштаб 1:1

– Точка привязки 0,0

– Угол поворота 0°


3.6.5.4. Выделение вида

Выделение вида (видов) требуется для последующего выполнения с ним операций редактирования, помещения в буфер обмена, удаления и т.д. Выделять можно только текущий и активные виды.

Вокруг выделенных видов отображается подсвеченная прямоугольная габаритная рамка. Она является признаком того, что выделены не просто отдельные объекты данного вида, а весь вид целиком (как часть чертежа).

Если вид пустой, то при его выделении на экране отображается подсвеченный квадрат с центром в точке начала координат вида.

Чтобы выделить вид, вызовите команду Выделить — Вид. На экране появится подменю, команды которого описаны в таблице 3.6.5.

Табл. 3.6.5. Команды выделения видов
Команда | Описание
Указанием | Позволяет выделить вид (или несколько видов), указав принадлежащий ему объект.
Выбором | Позволяет выделить вид, указав его название. После вызова команды на экране появляется диалог с перечнем видов, имеющихся в текущем чертеже. Укажите в списке нужные виды и нажмите кнопку ОК.

Кроме того, можно выделить вид, выделив его пиктограмму в Дереве чертежа.


3.6.5.5. Копирование и перенос видов через буфер

Вы можете скопировать или перенести существующий вид со всеми расположенными в нем объектами в другой чертеж. Для этой цели используется буфер обмена КОМПАС-3D.

Чтобы скопировать или перенести вид, выделите его и поместите в буфер обмена. Затем вставьте вид из буфера в другой чертеж. Подробнее о работе с буфером см. раздел 3.1.2.5.

Если вид с таким номером уже есть в чертеже, система проверяет, нельзя ли вставить в него содержимое вида из буфера обмена (объединить виды). Для объединения видов должно выполняться условие полного совпадения:

– номеров,

– координат базовых точек,

– углов поворота,

– масштабов1.

Если объединение видов невозможно, создается новый вид, которому присваивается первый свободный номер.

Если необходимо скопировать вид в тот же самый чертеж, удобнее использовать копирование при помощи мыши (подробнее см. раздел 3.5.1.1.2). При копировании система создает новый вид, присваивая ему первый незанятый номер.

При необходимости вы можете вставить в чертеж изображение из вида другого чертежа, создав особый объект — вставку вида (см. раздел 3.8.3).

  1. Этим условиям всегда удовлетворяют системные виды.


3.6.5.6. Удаление вида

Если содержимое какого-либо вида больше не потребуется для работы, вы можете удалить этот вид из чертежа.

Для удаления вида выделите его, а затем вызовите команду Редактор — Удалить — Выделенные объекты или нажмите клавишу <Delete>.

Можно также вызвать команду Удалить из контекстного меню вида в Дереве чертежа.

На экране появится диалог удаления видов. В нем перечислены названия удаляемых видов. Вы можете подтвердить удаление, нажав кнопку ОК или отказаться от него, нажав кнопку Отмена.

Системный вид удалить нельзя. Вы можете удалить лишь объекты, содержащиеся в нем (см. раздел 3.5.8), а сам вид всегда остается в чертеже.

Кроме того, можно удалять виды с помощью Менеджера документа. Для этого выполните следующие действия.

1. Вызовите Менеджер документа.

2. Выделите в Дереве листов, видов и слоев Менеджера корневой объект — текущий чертеж.

В Списке листов, видов и слоев будут показаны все присутствующие в чертеже виды их свойства.

3. Выделите в Списке вид (виды), которые требуется удалить.

4. Нажмите кнопку Удалить на инструментальной панели Менеджера документа.

В Менеджере документа невозможно удаление текущего и системного видов.

При попытке удалить вид на экране появляется диалог, в котором перечислены удаляемые виды, а также виды, которые затрагивает операция удаления (при удалении вида чертежа удаляются базирующиеся на нем виды по стрелке, выносные элементы, разрезы и сечения).

5. Подтвердите удаление.

6. Закройте Менеджер документа, нажав кнопку ОК.


3.6.5.7. Компоновка видов на листе

Компоновка видов — изменение их масштаба и/или положения на листе чертежа.

Компоновка значительно упрощается, если каждое изображение находится в отдельном виде. В этом случае масштаб, расположение и угол поворота любого изображения может быть быстро изменен.

Выполнять действия по компоновке можно только с текущим и активными видами чертежа.

Чтобы изменить масштаб вида, вызовите его контекстное меню в Дереве чертежа и выберите из него нужный масштаб (рис. 3.6.14).

Рис. 3.6.14. Смена масштаба вида

После этого геометрические объекты (отрезки, дуги и т.п.), содержащиеся в виде, перестроятся — увеличатся или уменьшатся в соответствии с заданным масштабом. В то же время толщина линий, длина стрелок, высота шрифта в надписях, размеры знаков и т.п. не изменятся. Значения размеров также останутся прежними. Например, на рисунке 3.6.15, а масштаб вида, содержащего изображение втулки — 2:1. Чтобы уместить на листе технические требования, изображение нужно уменьшить. Для этого необходимо сменить масштаб вида на 1:1 (рис. 3.6.15, б).

Рис. 3.6.15. Изменение масштаба вида
а) | б)

Чтобы изменить положение вида, выделите его (см. раздел 3.6.5.4), а затем переместите с помощью мыши в нужное место. Для этого установите курсор внутрь габаритной рамки вида, нажмите левую кнопку мыши и, не отпуская кнопку, перемещайте мышь. Вид будет перемещаться вслед за курсором. Когда нужное положение вида будет достигнуто, отпустите кнопку мыши.

Чтобы изменить угол поворота вида, вызовите из его контекстного меню в Дереве чертежа команду Параметры вида... На Панели свойств появятся элементы управления, которые позволяют задать параметры выбранного вида. Введите значение угла поворота в поле Угол на вкладке Параметры Панели свойств. При необходимости на этой же вкладке можно задать масштаб вида и координаты точки привязки вида.

Параметры системного вида недоступны для редактирования.

Некоторые ассоциативные виды имеют связь со своим опорным видом. В этом случае для поворота или перемещения вида необходимо сначала отключить связь.

К видам можно применять следующие команды редактирования:

– Сдвиг (см. раздел 3.5.2),

– Поворот (см. раздел 3.5.4.1),

– Масштабирование (см. раздел 3.5.4.2),

– Симметрия (см. раздел 3.5.4.3).

Результатом выполнения команды Масштабирование является не простое масштабирование объектов, а изменение масштаба вида; результатом выполнения команды Симметрия является создание в чертеже нового вида, симметричного указанному.


3.6.5.8. Разрыв вида

Согласно стандарту длинные предметы или их элементы с постоянным или закономерно изменяющимся сечением допускается изображать с разрывами, т.е. условно удалять среднюю часть. На изображении может быть один или несколько разрывов.

В КОМПАС-3D для подобной трансформации изображения служит команда Разрыв вида. Она позволяет условно удалять указанную часть (части) изображения, а оставшиеся части придвигать друг к другу. Команда может быть применена как к ассоциативным, так и к неассоциативным видам чертежа.

Доступно несколько типов линии разрыва — С изломом, Прямая и т.п. Умолчательная настройка линии разрыва — выбор типа линии разрыва и задание ее параметров — описаны в разделе 9.2.6.7.

Разрыв изображения в системном виде невозможен.

Если в виде нужно создать разрывы, то рекомендуется следующий порядок работы в нем.

1. Создание в виде всех геометрических объектов.

2. Построение в виде требуемого количества разрывов.

3. При работе с ассоциативными видами — создание видов, использующих вид с разрывом в качестве опорного.

4. Добавление в вид объектов оформления: размеров, обозначений, надписей и т.п.

В этом разделе:

3.6.5.8.1. Создание разрыва

3.6.5.8.2. Направление сдвига при разрыве

3.6.5.8.3. Амплитуда

3.6.5.8.4. Особенности работы с разрывами изображений


3.6.5.8.1. Создание разрыва

Чтобы создать разрыв изображения в текущем виде, вызовите команду Разрыв вида.

На экране появятся две параллельные линии — границы разрыва (см. рис. 3.6.17), а на Панели свойств — элементы управления, позволяющие настроить параметры разрыва. Эти элементы управления представлены в таблице 3.6.6.

Перемещая мышью характерные точки границ разрыва, ограничьте часть изображения, которую нужно удалить.

Табл. 3.6.6. Элементы управления параметрами разрыва

Элемент

Описание

Разрывы

Панель, содержащая список разрывов, имеющихся в текущем виде. Выделенный в списке разрыв считается текущим.

Кнопка Добавить позволяет создать в виде новый разрыв. После ее нажатия на экране появляется новая пара границ разрыва.

Кнопка Удалить позволяет удалить из вида текущий разрыв.

Угол

Поле для ввода или выбора угла между осью Х системы координат текущего вида и направлением сдвига (см. раздел 3.6.5.8.2) текущего разрыва.

Зазор1

Поле для ввода или выбора расстояния между линиями разрыва — расстояния, на котором будут располагаться друг от друга видимые части изображения после создания разрыва.

Тип линии

Список для выбора типа линии разрыва.

Амплитуда,%
Амплитуда, max

Поля для настройки амплитуды волнистой линии или линии с изломом. Подробно назначение этих полей рассмотрено в разделе 3.6.5.8.3.

Показать разрывы

Опция, включение которой означает, что текущий вид будет отображаться с разрывами. При отключенной опции изображение в виде показывается полностью (разрывы при этом сохраняются).

Вид может отображаться либо полностью — без всех разрывов, либо со всеми разрывами, которые в нем созданы. Отключить какой-либо один из разрывов невозможно.
  1. При использовании линий разрыва с изломом минимальный зазор должен составлять не менее двух амплитуд. Минимальный зазор при использовании линий других типов — 1 мм.

При установке границ следует учитывать, что расстояние между границами разрыва (см. рис. 3.6.17) не может быть меньше удвоенного значения амплитуды.

Чтобы подтвердить создание разрыва изображения, нажмите кнопку Создать объект.

Разрыв будет создан (рис. 3.6.16). Все геометрические объекты текущего вида, находившиеся между границами разрыва, перестанут отображаться на экране. Видимые части изображения будут ограничены линиями обрыва выбранного типа и придвинуты друг к другу так, чтобы расстояние между ними равнялось значению, заданному в поле Зазор. Длина линий обрыва определяется системой автоматически по габаритам изображения в виде.

Рис. 3.6.16. Пример разрыва изображения

В контекстом меню вида с разрывом в Дереве чертежа становятся доступны команды, позволяющие управлять разрывом: Параметры разрыва... и Показать разрывы. Они представлены в таблице 3.6.7.

Табл. 3.6.7. Команды управления разрывом
Название команды | Описание
Параметры разрыва... | Позволяет настроить разрыв (разрывы) изображения в виде. После вызова команды на Панели свойств появляются те же элементы управления, что и при создании разрыва. Вы можете изменить параметры любого из разрывов вида или удалить любой разрыв.
Показать разрывы | Позволяет управлять изображением в виде: включать и выключать отображение разрывов1. Вид может отображаться либо полностью — без всех разрывов, либо со всеми разрывами, которые в нем созданы. Отключить какой-либо один из разрывов невозможно.
  1. Вызов этой команды равносилен включению (или выключению) опции Показать разрывы на Панели свойств при создании или редактировании разрывов.


3.6.5.8.2. Направление сдвига при разрыве

Направление сдвига — линия, вдоль которой сдвигаются друг к другу видимые части изображения при создании разрыва вида. На рисунке 3.6.17 показаны система координат вида, границы разрыва и направление сдвига. В данном случае угол между осью Х и направлением сдвига равен нулю.

Рис. 3.6.17. Направление сдвига

Обратите внимание на то, что направления сдвига одного и того же вида могут быть только параллельны или перпендикулярны друг другу. Например, в виде создан разрыв, направление сдвига которого расположено под углом 30° к оси Х. Впоследствии в этом виде можно будет создать разрывы, направления сдвига которых располагаются либо под таким же углом, либо под углом 120° к оси Х.


3.6.5.8.3. Амплитуда

Амплитуда — отклонение линии с изломом или волнистой от средней линии (рис. 3.6.18).

Рис. 3.6.18. Амплитуда: а) линии с изломом, б) волнистой линии (на рисунке также показана средняя линия)
а) | б)

Значение амплитуды для линии с изломом равно значению, заданному поле Амплитуда, max.

Значение амплитуды для волнистой линии задается в поле Амплитуда,% в процентах от длины разрыва.

Длина разрыва — расстояние между максимально удаленными друг от друга крайними видимыми точками, измеренное перпендикулярно направлению сдвига (рис. 3.6.19).

Рис. 3.6.19. Длина разрыва

Значение, введенное в поле Амплитуда, max, для волнистой линии задает наибольшую допустимую амплитуду. Если расчетное значение амплитуды, выраженное в миллиметрах, превысит максимальное, то для отрисовки линии будет использоваться уже не расчетная, а установленная максимальная величина.


3.6.5.8.4. Особенности работы с разрывами изображений

1. Если в окне чертежа включено отображение сетки, то она не отображается между границами разрыва. Привязка по сетке между границами разрыва невозможна.

2. Все размеры, обозначения, надписи и таблицы, имеющиеся в виде с разрывом, остаются видны, даже если они находились (полностью или частично) между границами разрыва при его настройке.

3. Осевые линии и обозначения центра, полученные с помощью команд Осевая линия по двум точкам, Автоосевая (см. раздел 3.3.7.15 и 3.3.7.16) и Обозначение центра (см. раздел 3.3.7.14), не прерываются. Если же указанные объекты создавались в документе с помощью команды Отрезок (см. раздел 3.2.4.1), то они будут разорваны так же, как и остальные геометрические объекты.

4. При добавлении новых объектов в вид с разрывом линии разрыва не перестраиваются автоматически. Для их перерисовки с учетом новых габаритов изображения следует вызвать команду Обновить изображение.

5. Разрыв изображения является принадлежностью вида чертежа. В виде хранится информация о положении линий разрыва относительно системы координат этого вида, но не относительно находящихся в виде объектов. Поэтому при любом перемещении объектов внутри вида линии разрыва остаются на прежних местах. При необходимости вы можете отредактировать разрыв с помощью команды Параметры разрыва... (см. табл. 3.6.7). Если требуется изменить положение объектов вместе с разрывом, измените положение вида (см. раздел 3.6.5.7).


3.6.6. Слои

3.6. Создание чертежей

3.6.6. Слои

Если вам приходилось создавать на кульмане чертежи или схемы с большим количеством элементов (линий, размеров, обозначений и т.д.), то вы наверняка знакомы с применением калек для компоновки подобных конструкторских документов. В этом случае конструктор размещает различные блоки графической информации как бы на разных логических (в смысле выделения этого блока как отдельной единицы) и физических (в смысле размещения блока на отдельном бумажном носителе) уровнях.

При использовании такого разбиения заметно упрощается решение компоновочных задач, редактирование отдельных элементов изображения. На каждом этапе разработки документа (чертежа) используются только те блоки информации, которые необходимы в данный момент.

Реализация такого способа работы в КОМПАС-3D возможна при использовании слоев. В каждом виде чертежа (см. раздел 3.6.4), а также во фрагменте возможно создание до 2 147 483 647 слоев.

Явное разбиение фрагмента или вида чертежа на слои не является обязательным для пользователя. При создании нового фрагмента или вида чертежа в нем автоматически формируется слой с номером 0, в котором можно сразу начинать работу.

Создание новых слоев и управление слоями производятся в Менеджере документа. Он подробно описан в разделе 3.6.6.2.

В этом разделе:

3.6.6.1. Состояния слоев

3.6.6.2. Менеджер документа

3.6.6.2.1. Инструментальная панель Менеджера документа

3.6.6.2.2. Дерево листов, видов и слоев

3.6.6.2.3. Список листов, видов и слоев

3.6.6.2.4. Область поиска

3.6.6.3. Создание нового слоя

3.6.6.4. Переключение между слоями

3.6.6.5. Изменение состояния и параметров слоя

3.6.6.6. Копирование слоев между видами

3.6.6.7. Выделение слоя

3.6.6.8. Удаление слоя

3.6.6.9. Управление слоями в графическом документе

3.6.6.9.1. Наборы слоев

3.6.6.9.2. Операции с наборами слоев

3.6.6.9.3. Использование наборов для задания свойств слоев


3.6.6.1. Состояния слоев

Состояние слоя определяется значениями следующих свойств:

– активность — управляет доступностью объектов слоя для редактирования и имеет два значения:

• активный — все объекты слоя доступны для выполнения операций редактирования и удаления; активные слои можно сравнить с кальками, в которые не вносится ничего нового, а производятся лишь исправления ранее созданных объектов и перемещения самих калек на кульмане;

• фоновый — объекты слоя недоступны для редактирования и удаления; если включена привязка к объектам фоновых слоев (см. раздел 3.1.1.2), то к объектам фоновых слоев можно осуществить привязку; фоновые слои подобны калькам, закрепленным для базирования по ним новых элементов чертежа или схемы;

– видимость — управляет отображением объектов слоя на экране и имеет два значения:

• видимый — объекты слоя отображаются на экране, при этом активные слои показываются выбранными для них цветами, а фоновые — установленным стилем;

• погашенный — объекты слоя не отображаются на экране вне зависимости от того, активный он или фоновый; таким образом, погашенный слой полностью недоступен для любых операций; Образно говоря, вы можете снять ненужные сейчас кальки с кульмана;

– печать — управляет возможностью вывода объектов слоя на печать и имеет значения:

• разрешить печать;

• запретить печать.

Стиль (тип линии, ее толщина и цвет), которым отображаются объекты фоновых слоев, можно задать в диалоге настройки отрисовки слоев (см. раздел 9.1.7.9). Цвет, которым отображаются объекты активного слоя, устанавливается для каждого слоя в Менеджере документа (см. раздел 3.6.6.5).

Среди всех слоев вида или фрагмента один — и только один — имеет статус текущий.

Именно в текущий слой текущего вида записываются вновь создаваемые объекты.

Текущим можно сделать любой слой. При этом он автоматически становится видимым и активным. Пока слой является текущим, эти значения изменить нельзя (т.е. текущий слой невозможно ни погасить, ни сделать фоновым). В то же время печать текущего слоя может быть запрещена. Значение свойства печать не меняется при присвоении или снятии статуса текущего слоя.

Объекты текущего слоя отрисовываются на экране реальными стилями линий, точек и штриховок, которые назначены в диалогах настройки системы. Можно сказать, что текущий слой — это та калька, которая находится поверх всех остальных и на которой в данный момент вычерчиваются объекты.

После того как статус текущий присваивается другому слою, состояние слоя, который был текущим ранее, восстанавливается. Например, в какой-то момент работы над чертежом Слой 1 был текущим. Слой 2 в это время был фоновым и видимым. Затем Слой 2 сделали текущим, в результате чего он стал активным. После завершения редактирования Слоя 2 текущим вновь был сделан Слой 1. Слой 2 при этом снова стал фоновым.

В зависимости от настройки системы (см. раздел 9.1.5.2) погашенные слои могут выводиться на бумагу или не выводиться.


3.6.6.2. Менеджер документа

Менеджер документа предназначен для работы с объектами, составляющими структуру документа: листами, видами и слоями. Основные действия, выполняемые с помощью Менеджера документа:

– изменение свойств листов, видов и слоев,

– создание листов и слоев,

– удаление листов, видов и слоев,

– выбор текущего вида и слоя,

– группирование слоев,

– копирование слоев между видами.

Менеджер документа может быть вызван в текстовом документе и спецификации. В нем можно просмотреть и сменить используемые в документе оформления основных и дополнительных листов (для спецификаций — стиль основных листов спецификации). Для дополнительных листов возможно также выполнение следующих действий: добавление, удаление, изменение формата, кратности и ориентации.

Чтобы открыть Менеджер документа, выполните одно из следующих действий:

– вызовите команду Менеджер документа... из меню Сервис или контекстного меню на свободном месте документа,

– вызовите команду Вставка — Слой...,

– нажмите кнопку Менеджер документа на панели Стандартная,

– нажмите кнопку Управление слоями на панели Текущее состояние,

– нажмите кнопку Управление видами на панели Текущее состояние.

На экране появляется диалог Менеджер документа (рис. 3.6.20).

Рис. 3.6.20. Менеджер документа

Диалог Менеджер документа содержит области:

– Инструментальная панель (см. раздел 3.6.6.2.1),

– Дерево листов, видов и слоев (см. раздел 3.6.6.2.2),

– Список листов, видов и слоев (см. раздел 3.6.6.2.3),

– Область поиска — только для графических документов (см. раздел 3.6.6.2.4).

В этом разделе:

3.6.6.2.1. Инструментальная панель Менеджера документа

3.6.6.2.2. Дерево листов, видов и слоев

3.6.6.2.3. Список листов, видов и слоев

3.6.6.2.4. Область поиска


3.6.6.2.1. Инструментальная панель Менеджера документа

Инструментальная панель расположена в верхней части диалога Менеджер документа. Набор кнопок инструментальной панели определяется типом документа. Для графического документа набор кнопок зависит также от текущего элемента, выделенного в Дереве листов, видов и слоев. Элементы управления при работе с видами и слоями в графическом документе описаны в таблице 3.6.8.

Табл. 3.6.8. Инструментальная панель Менеджера документа при работе с видами и слоями

Кнопка

Позволяет

Создать слой

Создать новый слой. Команда недоступна в следующих случаях:

– выделено несколько объектов;

– текущим объектом является Документ, фильтр или группа, расположенная на первом уровне;

– текущим является объект Списка листов, видов и слоев.

Создать группу

Создать группу слоев. Доступна, если в документе действует режим группирования слоев1.

Создать группу свойств

Создать группу свойств. Доступна, если в документе действует режим группирования свойств слоев1.

Создать фильтр

Создать новый фильтр слоев. Доступна, если в документе действует режим группирования слоев1.

Удалить

Удалить объект или выделенные объекты.

При попытке удалить вид на экране появляется диалог, в котором перечислены удаляемые виды, а также виды, которые затрагивает операция удаления.

При попытке удалить непустой слой выдается предупреждающее сообщение о том, что слой содержит объекты.

Вы можете подтвердить удаление вида (слоя) или отказаться от удаления.

Сделать текущим

Сделать выделенный слой или вид текущим.

Активный

Сделать слой или вид, выделенные слои или все слои группы активными, то есть доступными для изменения.

Фоновый

Сделать слой или вид, выделенные слои или все слои группы фоновыми, то есть недоступными для изменения.

Видимый

Сделать слой или вид, выделенные слои или все слои группы видимыми.

Погашенный

Сделать слой или вид, выделенные слои или все слои группы невидимыми.

Цвет

Задать цвет для отображения слоя или группы. После задания цвета на кнопке появится горизонтальная полоска текущего цвета.

Разрешить печать

Разрешить вывод выделенных слоев на печать. Команда недоступна, если для всех выделенных объектов печать слоев уже разрешена.

Запретить печать

Запретить вывод выделенных слоев на печать. Команда недоступна, если для всех выделенных объектов печать слоев уже запрещена.

Включить все

Сделать все погашенные и фоновые слои вида, выделенного в Дереве листов, видов и слоев, (или все виды текущего чертежа) активными и видимыми. Команда недоступна, если среди выделенных объектов нет фоновых или погашенных.

Настройка видов

Вызвать диалог настройки параметров отображения видов текущего документа.

Настройка слоев

Вызвать диалог настройки параметров отображения слоев текущего документа.
  1. Режим группирования слоев выбирается при настройке группирования, см. раздел 9.2.6.3.

Элементы управления при работе с листами графического документа, спецификацией и текстовым документом описаны в таблице 3.6.9.

Табл. 3.6.9. Инструментальная панель Менеджера документа

Кнопка

Позволяет

Создать лист

– В чертеже — создать новый лист. Доступна, если текущим объектом является Листы.

– В спецификации — создать новый дополнительный лист. Доступна, если текущим объектом является Дополнительные листы в начале/конце документа.

Создать раздел

Создать новый раздел в текстовом документе. Доступна в текстовом документе.

Формат

Задать формат текущего листа или раздела. Доступна, если текущим является лист или раздел, а для спецификации — дополнительный лист.

После нажатия кнопки на экране появляется диалог Формат листа. Описание элементов диалога приведено в разделе 9.1.12.3.1.

Оформление

Задать библиотеку оформлений и стиль оформления из этой библиотеки. Доступна, если текущим объектом является лист (лист документа, дополнительный лист) или раздел.

После нажатия кнопки на экране появляется диалог Оформление. Описание элементов диалога приведено в разделе 9.2.4.2.2.

Переместить вверх/вниз

Изменить порядок следования дополнительных листов в начале или в конце спецификации. Порядок следования дополнительных листов определяется порядком расположения их оформлений в списках диалога.

При нажатии кнопки дополнительный лист перемещается на одну позицию вверх или вниз. Кнопка доступна, если лист не является первым или последним среди листов в разделе Дерева Дополнительные листы в начале/конце документа.

Удалить

Удалить лист графического документа, раздел в текстовом документе или дополнительный лист спецификации. При работе со спецификацией кнопка недоступна, если текущим является лист, входящий в раздел Дерева Листы документа. Во всех остальных случаях кнопка доступна.

При указании объекта из него удаляются все листы.

Настройка спецификации

Вызвать диалог настройки текущей спецификации.

Параметры...

Вызвать диалог выбора стиля текущей спецификации.


3.6.6.2.2. Дерево листов, видов и слоев

Дерево листов, видов и слоев находится в левой части диалога Менеджер документа.

Корневым объектом Дерева является Документ:

– фрагмент или чертеж,

– текстовый документ,

– спецификация.

Название корневого объекта совпадает с именем файла. Подчиненными Документу объектами первого уровня могут являться:

– листы (для чертежа), дополнительные листы и листы документа (для текстового документа и спецификации),

– виды (для чертежа может быть несколько, для фрагмента — только один):

• пустой вид,

• вид, содержащий объекты,

– группы слоев (для чертежа и фрагмента),

– группы свойств слоев (для чертежа и фрагмента),

– фильтры (для чертежа и фрагмента).

Для видов подчиненными объектами в Дереве могут являться:

– группы слоев,

– группы свойств слоев,

– фильтры,

– вставки видов.

Для групп подчиненными объектами в Дереве могут являться группы следующих уровней. Количество уровней не ограничено.

Листы, фильтры и вставки видов не имеют подчиненных объектов.

Объект, который выделен в Дереве листов, видов и слоев, считается текущим.

Положение фильтров и групп в Дереве может быть изменено. Для этого используется механизм Drag&Drop. При перемещении группы на новое место она удаляется с прежнего места. Чтобы поместить группу в новое место, не удаляя ее с прежнего (т.е. скопировать группу), перед началом перемещения нажмите и удерживайте нажатой клавишу <Ctrl>. При копировании групп копируются также входящие в них слои (подробнее см. раздел 3.6.6.6).

При попытке поместить объект в недопустимое место вместо курсора отображается предупреждающий значок.


3.6.6.2.3. Список листов, видов и слоев

Список листов, видов и слоев находится в правой части диалога Менеджер документа. Он содержит имена объектов, входящих в состав текущего элемента Дерева. Если в состав группы входят и слои, и группы, то в Списке листов, видов и слоев показываются слои только этой группы. Слои, включенные в подчиненные группы, не отображаются. Чтобы отобразить их, следует сделать текущей нужную группу.

В полях Списка листов, видов и слоев в виде пиктограмм отображаются значения свойств:

– Статус:

• пустой вид,

• вид, содержащий объекты,

– Активность:

• активный слой или вид,

• фоновый слой или вид,

– Видимость:

• видимый слой или вид,

• погашенный слой или вид.

– Печать:

• печать слоя разрешена,

• печать слоя запрещена.

Текущий слой или вид дополнительно отмечается красной «галочкой» в поле Статус.

Пиктограмма пустого слоя отличается от пиктограммы слоя, содержащего объекты, цветом контура: в первом случае он серый, во втором синий.

Список листов, видов и слоев позволяет не только просматривать свойства объектов, но и изменять их. Щелчок мыши по значению свойства в полях Статус, Активность, Видимость, Печать изменяет его на противоположное. Щелчок в поле Номер или Имя позволяет изменить значение этого поля. Изменить наименование объекта можно также, вызвав команду Переименовать из его контекстного меню. Щелчок в поле Цвет вызывает панель, в которой можно выбрать цвет для слоя или вида.

Нельзя переименовать слой, переданный из модели. Имена таких слоев начинаются с префикса «с». Подробнее о передаче слоев из модели рассказано в разделе 3.7.3.11.

Невозможно задать свойство Фоновый или Погашенный для слоя или вида, имеющего статус Текущий.

Объекты, расположенные в Списке, могут быть отсортированы по любому из столбцов. Чтобы выбрать столбец для сортировки, щелкните по его названию. Рядом с названием появится треугольник. Он показывает направление сортировки. Если вершина треугольника направлена вниз, то сортировка списка производится по убыванию значений в этом столбце, а если вверх — то по возрастанию.

В Списке листов, видов и слоев отображаются также виды, которые вставлены в текущий чертеж из других чертежей, и слои этих видов. Особенности работы с этими объектами описаны в разделе 3.8.1.7.2.


3.6.6.2.4. Область поиска

Поле Область поиска находится ниже Дерева листов, видов и слоев в Менеджере графического документа. Это поле позволяет выполнить упрощенную фильтрацию слоев по полям Номер и Имя.

Фильтр применяется к элементам объекта, который является текущим в Дереве листов, видов и слоев — документа, вида, группы. Чтобы начать поиск, следует ввести в поле строку текста. При этом можно использовать маски. В масках знак «*» заменяет любое количество любых символов. Знак «?» заменяет один любой символ. В Списке листов, видов и слоев будут показаны объекты, у которых номера и имена слоев совпадают с заданной строкой. Содержание области поиска не сохраняется в документе.


3.6.6.3. Создание нового слоя

Чтобы создать новый слой в текущем виде чертежа или во фрагменте, выполните следующие действия.

1. Вызовите команду Вставка — Слой или нажмите кнопку Управление слоями на панели Текущее состояние. На экране появится диалог Менеджер документа.

2. В Дереве листов, видов и слоев выделите объект (вид, группу свойств или группу слоев) для добавления нового слоя и нажмите кнопку Создать слой на инструментальной панели Менеджера документа.

В Списке листов, видов и слоев появится новый слой. В поле имени слоя будет находиться текстовый курсор. Вы можете изменить умолчательное имя. Ввод имени не является обязательным, однако понятные имена слоев, особенно если их достаточно много, значительно облегчают работу с документом. Для удобства работы полезно также ввести комментарий к слою.

По умолчанию новому слою присваивается первый свободный номер. При необходимости можно изменить его.

3. Чтобы установить цвет отрисовки слоя в активном состоянии, нажмите кнопку Цвет на инструментальной панели Менеджера документа. Цвет слоя можно также выбрать из раскрывающегося списка в колонке Цвет.

Обратите внимание на то, что после создания нового слоя текущим остается тот же слой, что и перед этим. Если требуется, чтобы текущим был новый слой, нажмите кнопку Сделать текущим или щелкните мышью в ячейке Статус. На пиктограмме слоя появится красная «галочка», показывающая, что слой является текущим.

4. После ввода всех параметров нового слоя нажмите кнопку ОК Менеджера документа.


3.6.6.4. Переключение между слоями

Вы можете сделать нужный слой текущим, а также настроить состояние других слоев с помощью Менеджера документа (см. раздел 3.6.6.2).

Однако существуют более быстрые способы выбора нового текущего слоя.

– Выберите или введите с клавиатуры номер или название (это зависит от настройки, см. раздел 9.1.7.9) нужного слоя в поле Текущий слой на панели Текущее состояние (рис. 3.6.21), и он станет текущим. Слой, выделенный в списке, подсвечивается в окне документа. Значки перед номером или названием слоя показывают его текущее состояние и цвет.

Рис. 3.6.21. Выбор текущего слоя

Поле Текущий слой присутствует на Панели, если она расположена горизонтально.

– Если нужный слой включен, т.е. является активным и видимым, можно переключиться на него следующим образом.

1. Выделите любой объект, лежащий на нужном слое.

2. Вызовите контекстное меню и выберите из него команду Переключиться на слой объекта. Слой, в котором находится выделенный объект, станет текущим.

Слой, который был текущим ранее, вернется в свое прежнее состояние.

Команда Переключиться на слой объекта недоступна, если выделен «многослойный» объект (макроэлемент, группа, вставка вида или фрагмента) или если выделенный объект уже находится в текущем слое.


3.6.6.5. Изменение состояния и параметров слоя

Чтобы изменить параметры и/или состояние существующего слоя, выполните следующие действия.

1. Вызовите команду Вставка — Слой или нажмите кнопку Управление слоями на панели Текущее состояние. На экране появится диалог Менеджер документа.

2. Выделите в Дереве листов, видов и слоев объект (вид, группу свойств или группу слоев), содержащий слой, параметры которого требуется изменить. В Списке листов, видов и слоев появятся все слои выделенного объекта.

3. Выберите среди них нужный слой.

Если имя или номер слоя известны, для выбора слоя можно воспользоваться Областью поиска, расположенной в левом нижнем углу Менеджера документа.

4. Задайте состояние выделенного слоя с помощью кнопок инструментальной панели Менеджера документа:

• Сделать текущим,

• Активный,

• Фоновый,

• Видимый,

• Погашенный,

• Печать разрешена,

• Печать запрещена.

Вы можете одинаковым образом изменить состояния сразу нескольких слоев. Для этого выделите их, затем нажмите нужную кнопку на инструментальной панели Менеджера документа или вызовите команду контекстного меню.

Чтобы сделать активными и видимыми все слои вида (фрагмента), нажмите кнопку Включить все на инструментальной панели Менеджера документа.

Состояния слоев можно изменять также, щелкая на пиктограммах в полях Списка листов, видов и слоев.

5. При необходимости вы можете изменить параметры слоя: номер, имя слоя, цвет в активном состоянии, комментарий.

Нельзя переименовать слой, переданный из модели. Имена таких слоев начинаются с префикса «с». Подробнее о передаче слоев из модели рассказано в разделе 3.7.3.11.

6. После завершения редактирования состояния и параметров слоя нажмите кнопку ОК Менеджера документа.

Для быстрого изменения состояния сразу нескольких или всех слоев удобно использовать наборы слоев (см. раздел 3.6.6.9.1).

Иногда бывает удобно изменять состояние слоев с помощью значков, отображающих свойства Активность, Видимость и Печать в списке слоев на панели Текущее состояние (рис. 3.6.21).

Щелчок на значке изменяет значение свойства слоя на противоположное.

Не забывайте, что активность и видимость текущего слоя изменить невозможно.


3.6.6.6. Копирование слоев между видами

Вы можете копировать слои между видами чертежа. При копировании содержимое исходных слоев игнорируется, т.е. в результате копирования новые слои получаются пустыми.

Чтобы скопировать слои, выполните следующие действия.

1. Вызовите команду Вставка — Слой или нажмите кнопку Управление слоями на панели Текущее состояние. На экране появится диалог Менеджер документа.

2. Выделите в Дереве листов, видов и слоев объект (вид, группу свойств или группу слоев), содержащий исходные слои, т.е. слои, которые нужно скопировать. В Списке листов, видов и слоев появятся все слои выделенного объекта.

3. Выделите слои, которые нужно скопировать, и «перетащите» их мышью на пиктограмму вида, в котором должны находиться слои-копии. Если слои-копии требуется добавить также в группу, принадлежащую виду, «перетаскивайте» исходные слои сразу на пиктограмму группы.

Вы можете также копировать между видами группы слоев и группы свойств слоев вместе с содержащимися в них слоями. Для этого «перетаскивайте» группы в Дереве листов, видов и слоев мышью, удерживая нажатой кнопку <Ctrl>.

4. Для сохранения изменений закройте Менеджер документа, нажав кнопку ОК.

Если копирование слоя или группы в указанное место возможно, то при «перетаскивании» рядом с курсором показывается значок «плюса», а если нет — то вместо курсора отображается предупреждающий значок. Например, группу нельзя скопировать саму в себя или в родительскую группу, а слой — в содержащий его вид.

При копировании производится контроль номеров слоев. Если в виде, куда копируются слои, есть слои с такими же номерами, как у копируемых, на экране появляется диалог-предупреждение о совпадении номеров слоев (рис. 3.6.22). Для продолжения работы необходимо выбрать один из вариантов действий.

Рис. 3.6.22. Предупреждение о совпадении номеров слоев

Наличие в виде двух и более системных слоев (слоев с нулевыми номерами) не допускается. Поэтому при копировании системного слоя из одного вида в другой варианты Добавить и Добавить — для всех недоступны.


3.6.6.7. Выделение слоя

Чтобы выделить слой вызовите команду Выделить — Слой. На экране появится подменю, команды которого описаны в таблице 3.6.10.

Табл. 3.6.10. Команды выделения слоев
Команда | Описание
Указанием | Позволяет выделить слой (или несколько слоев), указав лежащий на нем объект.
Выбором | Позволяет выделить слой, указав его название. После вызова команды на экране появляется диалог с перечнем слоев, имеющихся в текущем фрагменте или виде чертежа. Укажите в списке нужные слои и нажмите кнопку ОК.


3.6.6.8. Удаление слоя

Вы можете удалить слой из документа. Для этого выполните следующие действия.

1. Вызовите команду Вставка — Слой или нажмите кнопку Управление слоями на панели Текущее состояние. На экране появится диалог Менеджер документа.

2. Выделите в Дереве листов, видов и слоев объект (вид, группу свойств или группу слоев), содержащий слой, который требуется удалить.

3. В Списке листов, видов и слоев появятся все слои выделенного объекта. Выберите среди них нужный слой.

Если имя или номер слоя известны, для выбора слоя можно воспользоваться Областью поиска, расположенной в левом нижнем углу Менеджера документа.

4. Нажмите кнопку Удалить на инструментальной панели Менеджера документа.

Удаление текущего и системного слоев невозможно.

Если удаляемый слой содержит объекты, на экране появляется сообщение об этом.

5. Подтвердите удаление.

6. Закройте Менеджер документа, нажав кнопку ОК.


3.6.6.9. Управление слоями в графическом документе

Если документ содержит большое количество слоев, то ручная настройка каждого из них для работы с той или иной группой объектов неэффективна. Гораздо более рационально и удобно в этих случаях использовать наборы слоев. С их помощью возможно оперативное изменение видимости, активности, возможности печати и цвета одновременно у нескольких (или всех) слоев документа.

Создание наборов слоев и операции с ними производятся в Менеджере документа.

В этом разделе:

3.6.6.9.1. Наборы слоев

3.6.6.9.2. Операции с наборами слоев

3.6.6.9.3. Использование наборов для задания свойств слоев


3.6.6.9.1. Наборы слоев

Существуют статические наборы слоев — Группы слоев и Группы свойств слоев и динамические — Фильтры. Использование в документе того или иного набора слоев зависит от настройки (см. раздел 9.2.6.3).

Группа слоев

Использование групп слоев позволяет одновременно изменять свойства нескольких слоев одинаковым образом. Например, можно сделать все слои группы погашенными.

В группу могут входить слои фрагмента, слои одного или нескольких видов чертежа. Один слой может входить в состав нескольких групп. При изменении активности, видимости, возможности печати или цвета группы это свойство аналогичным образом изменяется у всех слоев, которые входят в нее. При включении слоя в группу в ней показываются фактические свойства этого слоя. Свойства слоя, который включен в группу, могут быть изменены как в составе группы, так и индивидуально. Если свойства изменены вне данной группы, то эти изменения будут показаны при просмотре состава группы.

Добавление слоя в документ не приводит к автоматическому добавлению этого слоя в какую-либо группу. Создание слоя в группе добавляет слой в документ. В другие группы созданный слой автоматически не добавляется.

При удалении слоя из группы он не удаляется из документа. При удалении слоя из документа он автоматически удаляется из группы (групп).

Группы слоев являются именованными объектами. По умолчанию при создании группы ей присваивается имя, состоящее из слова «Группа» и порядкового номера. Это имя может быть изменено.

Группы слоев сохраняются в документе.

Группа свойств слоев

Группа свойств слоев представляет собой заранее подготовленный набор настроек для включенных в нее слоев.

Один слой может быть включен в несколько групп. Значения одного и того же свойства у одного и того же слоя в разных группах могут быть различными. Значения одного и того же свойства у разных слоев в одной группе также могут быть различными.

В результате применения группы свойства включенных в нее слоев принимают значения, заданные в этой группе.

Рассмотрим пример использования групп свойств слоев. Пусть для Вида 1 поэтажного чертежа созданы следующие группы свойств слоев.

Офисное здание (Вид 1)

– План на отм. 0,000 (Группа 1)

• Архитектурные решения (Группа 1-1)

• Технологическое оборудование (Группа 1-2)

• Вентиляция и аспирация (Группа 1-3)

– План на отм. 3.300 (Группа 2)

• Архитектурные решения (Группа 2-1)

• Технологическое оборудование (Группа 2-2)

• Вентиляция и аспирация (Группа 2-3)

Каждая из групп содержит все слои Вида 1.

Группа 1-2 Технологическое оборудование, предназначенная для работы с изображениями технологического оборудования, расположенного на отметке 0.000, настроена следующим образом:

– слои, содержащие архитектурные конструкции, — фоновые,

– слои, содержащие изображение элементов системы вентиляции и аспирации, — погашенные,

– слои, содержащие технологическое оборудование, — активные, один из них — текущий,

– слои, содержащие объекты на отметке 3.300, — погашенные.

После применения Группы 1-2 свойства слоев Вида 1 изменятся в соответствии с настройками этой группы:

– слои с элементами системы вентиляции и аспирации, а также все слои с объектами на отметке 3.300 погаснут, т.е. не будут видны,

– слои с изображениями архитектурных конструкций станут фоновыми, т.е. будут видимыми, но недоступными для редактирования,

– слои с изображениями технологического оборудования станут активными, т.е. доступными для редактирования,

– один из слоев с технологическим оборудованием станет текущим — в него будут добавляться вновь создаваемые объекты.

Группа 1-1 настроена так, чтобы слои, содержащие изображения архитектурных конструкций, были активными, а остальные слои — погашенными, если они не требуются при работе с этими конструкциями, или фоновыми, если они должны быть видны.

Аналогичным образом настроены остальные группы свойств слоев.

Таким образом, использование групп свойств позволяет оперативно изменять отображение и возможность редактирования объектов графического документа для выполнения текущих задач, применяя заранее созданные наборы настроек.

Свойства слоев станут соответствовать настройкам только после того, как группа свойств будет сделана текущей (см. раздел Группа свойств слоев).

Поскольку группа свойств слоев является набором настроек, фактическое состояние слоев, которые включены в нее, в группе не отображается.

Добавление слоя в документ не приводит к автоматическому добавлению этого слоя в группу. Создание слоя в группе добавляет слой в документ. В другие группы созданный слой автоматически не добавляется.

Удаление слоя из группы не приводит к удалению слоя из документа. При удалении слоя из документа он автоматически удаляется из группы (групп).

По умолчанию при создании группы ей присваивается имя, состоящее из слов «Группа свойств» и порядкового номера. Это имя может быть изменено.

Группы свойств слоев сохраняются в документе.

Фильтр слоев

С помощью фильтров можно создавать динамические группы слоев, свойства которых соответствуют условиям фильтрации. Например, можно выбрать только те слои, которым присвоен фиолетовый цвет, или слои, названия которых начинаются с буквы «с». Состав динамической группы изменяется при изменении свойств слоев графического документа. Например, при создании нового слоя, свойства которого соответствуют условиям фильтрации, этот слой автоматически будет показан в составе фильтра. Фильтры могут быть преобразованы в группы слоев (см. раздел Преобразование фильтра в группу).

Фильтры являются именованными объектами. По умолчанию при создании фильтра ему присваивается имя, состоящее из слова «Фильтр» и порядкового номера. Это имя может быть изменено.

Фильтры сохраняются в документе.


3.6.6.9.2. Операции с наборами слоев

Создание групп

Чтобы создать группу, следует выбрать ее родительский объект в Дереве листов, видов и слоев и нажать кнопку Создать группу или Создать группу свойств. Доступность этих элементов управления определяется настройкой группирования слоев в документе (см. раздел 9.2.6.3).

Пиктограмма новой группы появится в составе своего родительского объекта. В поле названия группы будет находиться текстовый курсор. Вы можете изменить умолчательное имя группы. После нажатия клавиши <Enter> или щелчка мышью вне названия группы она будет зафиксирована.

– Если наследование состава родительского объекта включено (см. раздел 9.2.6.3), то в новой группе будут присутствовать слои. В противном случае создается пустая группа.

– Если в родительском объекте были выделены какие-либо слои, новая группа будет содержать эти слои. При этом не имеет значения, включено или выключено наследование состава.

Чтобы поместить или добавить в группу слои, выделите в Дереве листов, видов и слоев вид, фильтр или ранее созданную группу.

В Списке листов, видов и слоев будут показаны слои, составляющие выделенный объект.

Вы можете ограничить перечень слоев выбранного объекта, используя Область поиска (см. раздел 3.6.6.2.4).

«Перетащите» нужные слои на значок созданной группы, воспользовавшись стандартным механизмом Drag&Drop Windows. При этом слои с прежнего места не удаляются.

При попытке поместить объект в недопустимое место рядом с курсором появится предупреждающий значок.

Вы можете переместить сразу несколько выделенных объектов. Чтобы выделить последовательно расположенные объекты, выделите первый из них, нажмите <Shift> и, не отпуская эту клавишу, выделите последний объект. Все слои между первым и последним будут выделены. Чтобы выделить произвольно расположенные объекты, нажмите <Ctrl>. Удерживая эту клавишу, щелкайте по названиям слоев. Описанные способы выделения можно комбинировать.

Если создана группа свойств слоев, задайте для каждого слоя свойства, которые будут назначены ему после применения группы. Используйте для этого кнопки инструментальной панели (см. табл. 3.6.8) и поля Списка листов, видов и слоев.

Чтобы изменить название существующей группы, можно использовать стандартные способы Windows:

– щелкнуть по названию группы,

– выделить название и нажать функциональную клавишу <F2>,

– вызвать из контекстного меню команду Переименовать.

В поле названия появится текстовый курсор, позволяющий редактировать его.

Чтобы удалить группу, следует выделить ее в Дереве листов, видов и слоев и нажать кнопку Удалить.

Создание фильтров

Чтобы создать фильтр слоев документа или его вида, следует выбрать его родительский объект в Дереве листов, видов и слоев и нажать кнопку Создать фильтр. Эта кнопка доступна, если в текущем документе действует режим группирования слоев (см. раздел 9.2.6.3).

Выбор родительского объекта для фильтра определяет состав фильтруемых объектов. Если фильтр создается на уровне видов (второй уровень), фильтрация будет применена к слоям всего документа. Если фильтр расположить внутри вида (третий уровень), то он будет применен только к слоям этого вида.

Создание фильтра в группе невозможно.

После нажатия кнопки Создать фильтр на экране появится диалог Фильтр слоев (рис. 3.6.23). Элементы управления этого диалога позволяют настраивать фильтр. В поле Название фильтра находится текстовый курсор. Вы можете изменить умолчательное имя фильтра. По умолчанию создаваемому фильтру присваивается имя, состоящее из слова «Фильтр» и порядкового номера.

Рис. 3.6.23. Диалог создания фильтра слоев

Каждая строка таблицы Условия является условием фильтрации слоев. Поля Статус, Активность, Видимость, Цвет содержат раскрывающиеся списки. Конкретные условия фильтрации следует выбирать из этих списков. В полях Номер, Имя и Комментарий условия необходимо вводить с клавиатуры. При этом можно использовать маски. В масках знак «*» заменяет любое количество любых символов. Знак «?» заменяет один любой символ. Чтобы завершить ввод в поле, следует нажать <Enter> или щелкнуть мышью вне этого поля.

При задании условий вы можете использовать команды контекстного меню. Команда Очистить ячейку позволяет удалить значение в текущем поле условия. Команда Удалить строку позволяет удалить условие целиком. Команда Копировать строку позволяет создать копию текущей строки.

Условий фильтрации может быть несколько. После формирования условия автоматически создается строка для создания следующего условия. Если фильтр состоит из нескольких условий, то они складываются. Например, если поле Статус одного условия содержит значение «непустой слой», а другого — «пустой», то в фильтре будут показаны и пустые слои, и слои, содержащие объекты.

Таблица Просмотр содержит список слоев, свойства которых удовлетворяют условиям фильтрации. Пока не сформировано ни одного условия, в списке отображаются все слои родительского объекта фильтра. Список динамически изменяется при изменении условий фильтра.

Чтобы завершить настройку фильтра, следует нажать кнопку ОК. Диалог будет закрыт. Значок фильтра появится в Дереве листов, видов и слоев. Чтобы закрыть диалог создания фильтра, отказавшись от сделанных изменений, нажмите кнопку Отмена.

Название фильтра может быть изменено аналогично названию группы (см. с. 1290).

Чтобы удалить фильтр, следует выделить его в Дереве листов, видов и слоев и нажать кнопку Удалить.

Преобразование фильтра в группу

Если в документе действует режим группирования слоев, то в группы слоев могут быть преобразованы произвольно выбранные фильтры.

Чтобы превратить какой-либо фильтр в группу, активизируйте этот фильтр и вызовите из его контекстного меню команду Преобразовать фильтр в группу. Значок и название объекта изменятся: названием станет слово «Группа», к нему добавится порядковый номер в списке групп.

При смене режима группирования слоев на режим группирования свойств слоев все фильтры автоматически преобразуются в группы свойств слоев. Имена получившихся объектов при этом не изменятся, то есть будут состоять из слова «Фильтр» с прежним порядковым номером.

Обратное преобразование, т.е. превращение группы в фильтр, невозможно никакими способами.


3.6.6.9.3. Использование наборов для задания свойств слоев

Группа слоев

Использование группы слоев позволяет одновременно задать активность, видимость, возможность печати или цвет слоев, которые входят в эту группу, одинаковым образом. При активизации группы в Дереве листов, видов и слоев ее состав показывается в Списке листов, видов и слоев. Содержание полей Списка будет отображать фактическое текущее состояние слоев, входящих в группу. Свойства слоев могут быть различными. Используя кнопки инструментальной панели, задайте состояние видимости, активности, возможности печати и цвет для группы.

Обратите внимание на то, что изменить активность и видимость текущего слоя невозможно.

В группе слоев может не быть ни одного текущего слоя. Максимальное число текущих слоев равно числу видов, которым принадлежат слои, входящие в группу. Например, если группа содержит слои из Вида 1 и из Вида 2, то в ней может быть два текущих слоя. Таким образом, группа слоев, подчиненная виду, а также любая группа слоев фрагмента может содержать только один текущий слой.

Чтобы сделанные настройки группы вступили в силу, нажмите кнопку Применить. При этом Менеджер документа останется на экране. Если нажать кнопку ОК, то настройки будут применены к слоям группы, а Менеджер документа закроется. Чтобы закрыть этот диалог, не применяя выполненные настройки, следует нажать кнопку Отмена.

Фильтр

Использование фильтров сходно с использованием группы слоев. При выделении фильтра в Дереве слои, свойства которых соответствуют настройкам фильтрации, появятся в Списке листов, видов и слоев. Используя кнопки инструментальной панели, вы можете задать активность, видимость, возможность печати, цвет одновременно всем отфильтрованным элементам. Используя элементы управления в полях Списка листов, видов и слоев, вы можете изменить свойства слоя индивидуально.

Если свойства одного или нескольких отфильтрованных слоев будут изменены таким образом, что слои перестанут соответствовать условиям фильтрации, то они удалятся из фильтра.

Группа свойств слоев

Использование группы свойств слоев позволяет задать каждому слою, входящему в группу, индивидуальный набор свойств. Сразу после создания группы свойств слоев значения в полях Списка листов, видов и слоев отображают фактическое состояние слоев. Используя кнопки инструментальной панели или изменяя значения свойств слоя непосредственно в полях Списка листов, видов и слоев, задайте состояние видимости, активности, возможность печати и цвет для каждого слоя группы. Чтобы задать одинаковый набор свойств нескольким слоям, следует выделить их в Списке и воспользоваться кнопками инструментальной панели.

Обратите внимание на то, что изменить свойства текущего слоя невозможно.

В группе свойств слоев может быть либо один текущий слой, либо ни одного.

В последующем при выделении группы в Дереве набор свойств, назначенных слоям этой группы, будет показан в Списке листов, видов и слоев. Фактическое состояние слоев, включенных в группу, не отображается.

Чтобы сделанные настройки элементов группы вступили в силу, выделите группу свойств и слоев и нажмите кнопку Сделать текущим. На пиктограмме группы появится «галочка». Затем нажмите кнопку Применить. При этом Менеджер документа останется на экране. Если нажать кнопку ОК, то настройки будут применены к слоям группы, а Менеджер документа закроется. Чтобы закрыть этот диалог, не применяя выполненные настройки, следует нажать кнопку Отмена.


3.6.7. Технические требования в чертеже

3.6. Создание чертежей

3.6.7. Технические требования в чертеже

В этом разделе:

3.6.7.1. Ввод технических требований в чертеже

3.6.7.1.1. Режим работы с техническими требованиями

3.6.7.2. Размещение технических требований на чертеже

3.6.7.3. Разбивка технических требований на страницы

3.6.7.4. Редактирование и удаление технических требований


3.6.7.1. Ввод технических требований в чертеже

Чтобы перейти к вводу текста технических требований, вызовите в чертеже команду Вставка — Технические требования — Ввод. На экране появляется окно режима работы с техническими требованиями. Приемы работы в нем описаны в разделе 3.6.7.1.1.

Выполните необходимые действия и выйдите из режима. По умолчанию технические требования отображаются над основной надписью чертежа.

О редактировании и удалении технических требований см. раздел 3.6.7.4.

В этом разделе:

3.6.7.1.1. Режим работы с техническими требованиями


3.6.7.1.1. Режим работы с техническими требованиями

Окно режима работы с техническими требованиями служит для ввода, редактирования и форматирования их текста. Окно появляется на экране после вызова команды Вставка — Технические требования — Ввод.

Окно имеет заголовок «Имя файла —> Технические требования».

В окне отображаются технические требования, если они заданы в документе. Также показана пунктирная рамка, обозначающая границы страницы технических требований на листе. По умолчанию в чертеже границы установлены по ширине основной надписи. Об изменении границ см. раздел 3.6.7.2.

В данном режиме доступны все возможности ввода, редактирования и форматирования текста (см. раздел 4.1.2).

Использование команды Вставить текстовый шаблон на вкладке Вставка Панели свойств (см. раздел 4.1.2.11.6) позволяет ускорить создание технических требований, исключив повторный ввод часто применяющихся пунктов.

При помощи команд Сохранить блок и Загрузить блок на вкладке Вставка Панели свойств можно сохранять или вставлять в текст типовые технические требования — блоки текста из текстовых файлов (*.txt) или текстовых документов КОМПАС-3D (*.kdw). Об использовании блоков текста см. раздел 4.1.2.10.

При помощи команды Правописание на вкладке Формат Панели свойств можно выполнять проверку текста на разных языках.

Введенные технические требования передаются в документ после сохранения изменений, сделанных в окне.

Меню Файл содержит специальные команды сохранения и закрытия, представленные в таблице 3.6.11.

Табл. 3.6.11. Специальные команды меню Файл в окне режима работы с техническими требованиями

Команда

Описание

Закрыть — Документ

Позволяет закрыть документ, которому принадлежат редактируемые технические требования. Окно технических требований также закрывается.

Закрыть —
Технические
требования

Позволяет закрыть окно редактируемых технических требований. Окно документа, которому они принадлежат, остается открытым.

Сохранить —
В документ

Позволяет записать технические требования в содержащий их документ. Запись документа на диск не производится.

Сохранить —
С документом
в файл

Позволяет записать технические требования в содержащий их документ, а сам документ — на диск. После выполнения команды активным остается окно технических требований.

Сохранить как —
Текстовый
документ

Позволяет записать текст технических требований в отдельном файле текстового документа КОМПАС-3D (*.kdw).

После вызова команды на экране появляется диалог, в котором требуется задать имя файла для записи.

Сохранить как —
С документом
в файл

Позволяет записать документ, содержащий редактируемые технические требования, под другим именем или в другую папку.

После выполнения команды активным становится окно технических требований вновь записанного документа.

Чтобы закрыть окно работы с техническими требованиями, можно также щелкнуть мышью по значку режима редактирования в окне документа.


3.6.7.2. Размещение технических требований на чертеже

Войти в режим ручного размещения технических требований на чертежа можно двумя способами:

– вызвав команду Вставка — Технические требования — Размещение,

– вызвав команду Ручное размещение тех. требований из их контекстного меню.

Указанные команды доступны только в том случае, если создан текст технических требований (см. раздел 3.6.1.4).

В режиме ручного размещения вокруг текста технических требований отображается рамка с точками в углах (см. рис. 3.6.24).

Чтобы переместить технические требования в другое место, поместите курсор внутрь рамки (он изменит свою форму на четырехстороннюю стрелку), нажмите левую кнопку мыши и передвигайте мышь, удерживая кнопку нажатой. Технические требования будут перемещаться вслед за курсором. После того как нужное положение будет достигнуто, отпустите кнопку мыши.

Рис. 3.6.24. Режим размещения технических требований

«Перетаскивая» мышью характерные точки, расположенные на сторонах и в углах рамки, вы можете изменить размер страницы технических требований.

Возможно также точное задание размещения и размеров страницы технических требований. Для этого, находясь в режиме ручного размещения технических требований, вызовите из контекстного меню команду Позиционировать....

На экране появится диалог позиционирования текущей страницы технических требований. В нем можно задать расстояния от левой и нижней сторон формата (внешней рамки чертежа) до сторон рамки технических требований.


3.6.7.3. Разбивка технических требований на страницы

Текст технических требований автоматически размещается над основной надписью первого или последнего (в зависимости от настройки, см. раздел 9.2.6.19.6) листа. Если там не умещается весь текст, то выполняется автоматическая разбивка технических требований на страницы и размещение их со сдвигом влево.

В том случае, если текст технических требований выходит за пределы формата, следует установить больший формат чертежа (см. раздел 3.6.2.1). Если же технические требования достаточно объемные (например, для больших сборочных единиц) и состоят из десятка и более страниц, целесообразно оформить их на отдельном листе в виде текстового документа (о создании текстовых документов см. раздел 4.1.4).

При необходимости вы можете принудительно разбить технические требования на страницы и по отдельности разместить их на поле чертежа.

Для этого войдите в режим ручного размещения технических требований и уменьшите вертикальный размер рамки технических требований (см. раздел 3.6.7.2). Вокруг той части технических требований, которая не уместилась в рамке (на первой странице), будет создана новая рамка (вторая страница).

Вторая и последующие страницы технических требований автоматически размещаются на свободном месте листа в соответствии со стандартными правилами.

Пример разбиения технических требований на две страницы показан на рис. 3.6.25.

Рис. 3.6.25. Разбиение технических требований на страницы

Можно выполнить и обратную операцию. Если растянуть исходную рамку до нужных размеров, то весь текст вновь разместится в ней, а дополнительные рамки удалятся.

Чтобы восстановить умолчательные размеры и положение страниц технических требований, вызовите из их контекстного меню команду Авторазмещение технических требований. Если чертеж многолистовой, то умолчательное расположение технических требований зависит от настройки их параметров (см. раздел 9.2.6.19.6).


3.6.7.4. Редактирование и удаление технических требований

Войти в режим редактирования текста технических требований можно тремя способами:

– дважды щелкнув левой кнопкой мыши на технических требованиях,

– вызвав команду Редактировать тех. требования из их контекстного меню,

– вызвав команду Вставка — Технические требования — Ввод.

Для удаления технических требований из чертежа также существует три способа:

– вызов команды Редактор — Удалить — Технические требования,

– вызов команды Удалить тех. требования из их контекстного меню,

– удаление текста технических требований в режиме их редактирования.


3.6.8. Разбиение чертежа на зоны

3.6. Создание чертежей

3.6.8. Разбиение чертежа на зоны

Включение и настройка разбиения текущего чертежа на зоны производится в диалоге, вызываемом командой Сервис — Параметры... — Текущий чертеж — Параметры документа — Разбиение на зоны (см. раздел 9.2.6.19.4).

Настройка параметров разбиения на зоны хранится в самом чертеже и не изменяется при его передаче на другое рабочее место.

Если вы используете одни и те же параметры разбиения на зоны во всех чертежах, то выполнение соответствующей настройки в каждом чертеже нерационально. В этом случае можно сделать так, чтобы все новые чертежи сразу создавались с требуемой настройкой разбиения на зоны.

Для этого используется диалог, вызываемый командой Сервис — Параметры... — Новые документы — Графический документ — Параметры документа — Разбиение на зоны.

Эта настройка распространяется только на документы, созданные после ее выполнения. Чертежи, существовавшие до выполнения настройки, не изменяются.


3.7. Ассоциативные виды

В этом разделе:

3.7.1. Общие сведения об ассоциативных видах

3.7.1.1. Ассоциативные виды в Дереве чертежа

3.7.1.2. Типовая последовательность действий при создании ассоциативного чертежа модели

3.7.1.3. Настройка ассоциативных видов

3.7.1.3.1. Параметры

3.7.1.3.2. Линии

3.7.1.3.3. Объекты и элементы оформления

3.7.1.3.4. Надпись

3.7.2. Построение видов

3.7.2.1. Стандартные виды

3.7.2.2. Произвольный вид

3.7.2.3. Проекционный вид

3.7.2.4. Вид по стрелке

3.7.2.5. Местный вид

3.7.2.6. Выносной элемент

3.7.2.7. Разрез/сечение

3.7.2.7.1. Особенности использования штриховки, заданной в модели

3.7.2.8. Местный разрез

3.7.3. Приемы работы с ассоциативными видами

3.7.3.1. Назначение «неразрезаемых» компонентов

3.7.3.2. Отключение изображения компонента на виде

3.7.3.3. Отключение проекционной связи между видами

3.7.3.4. Управление стилями линий, точек и штриховок

3.7.3.5. Работа с проекционными обозначениями

3.7.3.5.1. Условия формирования проекционных обозначений в видах

3.7.3.5.2. Управление отображением проекционных обозначений

3.7.3.5.3. Свойства проекционных обозначений

3.7.3.5.4. Редактирование проекционных обозначений

3.7.3.6. Переход к редактированию модели

3.7.3.7. Предупреждения о необходимости перестроения чертежа и об ошибках

3.7.3.8. Заполнение основной надписи ассоциативного чертежа

3.7.3.8.1. Синхронизация основной надписи и модели

3.7.3.9. Передача технических требований из модели в чертеж. Синхронизация

3.7.3.10. Передача неуказанной шероховатости из модели в чертеж. Синхронизация

3.7.3.11. Передача слоев из модели в чертеж

3.7.3.12. Надпись вида зеркального исполнения

3.7.3.13. Разрушение ассоциативных связей


3.7.1. Общие сведения об ассоциативных видах

3.7. Ассоциативные виды

3.7.1. Общие сведения об ассоциативных видах

Ассоциативные виды формируются в обычном чертеже КОМПАС-3D. Чертеж, содержащий ассоциативные виды, называется ассоциативным чертежом.

Доступно создание следующих видов:

– стандартный вид (спереди, сзади, сверху, снизу, справа, слева),

– произвольный вид (вид произвольной модели в произвольной ориентации),

– проекционный вид (вид по направлению, указанному относительно другого вида),

– вид по стрелке,

– разрез/сечение (простой, ступенчатый, ломаный),

– выносной элемент,

– местный вид,

– местный разрез.

Команды создания ассоциативных видов сгруппированы в меню Вставка — Вид с модели и Вставка — Вспомогательный вид, а кнопки для вызова команд — на панели Виды (рис. 3.7.1).

Рис. 3.7.1. Панель Виды

Стандартные и проекционные виды автоматически строятся в проекционной связи.

Все виды связаны с моделью: изменения в модели приводят к изменению изображения в ассоциативном виде. Пока ассоциативный вид сохраняет связь с моделью, редактирование геометрических объектов, составляющих проекцию модели, невозможно. При необходимости связь между видом и моделью может быть разрушена.

Для любого вида можно указать, какие объекты модели не требуется отображать в нем. Это могут быть тела, поверхности, кривые, точки, а также созданные в модели элементы оформления (условные изображения резьбы, размеры, обозначения). Кроме того, возможно отключение отображения в виде выбранного компонента (т.е. всех его объектов).

Для разреза/сечения имеется возможность назначить «неразрезаемые» компоненты изделия (детали или подсборки).

Имеется возможность синхронизировать данные в основной надписи чертежа (обозначение, наименование, массу и др.) с данными из файла модели, технические требования в чертеже — с техническими требованиями в файле модели.

Один чертеж может содержать несколько ассоциативных видов, в том числе видов, изображающих разные модели.

Если модель содержит исполнения, то при создании ассоциативного вида вы можете выбрать нужное исполнение. Сведения о переменных данных исполнений приводятся в таблице исполнений (см. раздел 2.13.5.1).

Если в чертеж добавляется ассоциативный вид зеркального исполнения, то могут быть автоматически созданы надписи этого вида и вида исходного исполнения. О создании надписей подробно рассказано в разделе 3.7.3.12.

Если модель содержит слои, группы слоев и фильтры, то при создании ассоциативного вида их можно передать в чертеж (см. раздел 3.7.3.11).

Для удобства управления видами рекомендуется использовать Дерево чертежа (см. раздел 3.7.1.1).

В любом ассоциативном виде можно создать один или несколько разрывов изображения (см. раздел 3.6.5.8).

Команды создания вида по стрелке, разреза/сечения и выносного элемента запускаются автоматически после создания в чертеже соответствующих объектов оформления: стрелки взгляда, линии разреза/сечения, выносного элемента. Возможен также запуск этих команд вручную.

Надписи видов по стрелке, разреза/сечения и выносного элемента автоматически связываются со «своими» объектами оформления, благодаря чему они всегда соответствуют друг другу (см. раздел 3.6.4.6).

Чертежу, содержащему ассоциативные виды трехмерной модели, автоматически присваивается атрибут, в котором содержатся сведения о массе модели (рис. 3.7.2).

Рис. 3.7.2. Просмотр сведений о модели, изображенной в чертеже

Если чертеж содержит изображения нескольких моделей, то в атрибут заносятся сведения о той модели, данные о которой отображаются в основной надписи этого чертежа.

Ассоциативные виды модели с компонентами или многотельной детали могут отображаться некорректно, если компоненты или тела пересекаются. Некорректность проявляется в отсутствии видимых или присутствии невидимых линий. Чтобы исправить указанные ошибки, рекомендуется отредактировать модель, устранив пересечение компонентов или тел. Это можно сделать одним из трех способов:

– модифицировать компоненты или тела, удалив «лишний» материал,

– изменить положение компонентов или тел так, чтобы они не пересекались,

– объединить пересекающиеся компоненты или тела.

Ошибки в ассоциативных видах могут возникать также из-за самопересечений тел детали. Для исправления изображения необходимо отредактировать деталь так, чтобы самопересечений тел не было.

В этом разделе:

3.7.1.1. Ассоциативные виды в Дереве чертежа

3.7.1.2. Типовая последовательность действий при создании ассоциативного чертежа модели

3.7.1.3. Настройка ассоциативных видов

3.7.1.3.1. Параметры

3.7.1.3.2. Линии

3.7.1.3.3. Объекты и элементы оформления

3.7.1.3.4. Надпись


3.7.1.1. Ассоциативные виды в Дереве чертежа

Ассоциативный вид автоматически появляется в Дереве чертежа сразу после того, как он создан в чертеже. Название присваивается видам также автоматически. Оно содержит имя вида и его масштаб. Например, «Системный вид(1:1)», «Проекционный вид 4(2:1)», «Разрез Б-Б(1:1)» и т.д.

О работе с Деревом чертежа подробно рассказано в разделе 3.6.4.5.

Подчиненными объектами ассоциативного вида являются модель, изображение которой содержится в этом виде, и местные разрезы, если они есть в виде (рис. 3.7.3, а).

Объекты, составляющие модель, сгруппированы в разделы: Тела, Поверхности, Кривые и точки, Компоненты (рис. 3.7.3).

Объекты модели, которые не участвуют в формировании ее изображения в чертеже —эскизы, вспомогательные оси и плоскости, ЛСК и т.п. — не отображаются в Дереве чертежа.

Рис. 3.7.3. Дерево чертежа с ассоциативными видами: а) детали, б) сборки
а) | б)

Контекстное меню объектов Дерева чертежа (рис. 3.7.4) позволяет просматривать отношения видов, а также назначать «неразрезаемые» компоненты и переходить к редактированию трехмерных моделей, изображенных на ассоциативных видах.

Рис. 3.7.4. Контекстные меню элементов Дерева чертежа: а) контекстное меню вида, б) контекстное меню компонента
а) | б)

Обратите внимание на следующие особенности отображения объектов модели в Дереве чертежа.

– В разделе Поверхности отображаются фактически присутствующие в модели поверхности. Тип поверхности не указывается. В результате содержимое раздела Поверхности в Дереве чертежа может отличаться от содержимого аналогичного раздела в Дереве построения модели. Например, в модели имеются Поверхность вращения:1, Линейчатая поверхность:1 и операция Сшивка, объединяющая их в одну поверхность. В Дереве чертежа этой модели будет присутствовать только одна поверхность с именем Поверхность:1. Если же при сшивке поверхностей было образовано тело, то Дерево чертежа вовсе не будет содержать раздел Поверхности (несмотря на то, что в Дереве построения модели он есть).

– Некоторые объекты — тела, поверхности, кривые или точки — могут быть скрыты при редактировании модели. По умолчанию такие объекты не отображаются в ассоциативных видах. В Дереве чертежа они видны, но их пиктограммы не отличаются от пиктограмм видимых объектов (в отличие от Дерева построения модели, где пиктограммы скрытых объектов имеют серый цвет). При необходимости вы можете включить отображение в видах скрытых объектов (см. раздел 3.7.1.3.3).


3.7.1.2. Типовая последовательность действий при создании ассоциативного чертежа модели

3.7.1.2. Типовая последовательность действий
при создании ассоциативного чертежа модели

1. Подготовительные действия (выполняются при необходимости).

1.1. Создайте или откройте модель, ассоциативный чертеж которой вы собираетесь создать.

1.2. Если какие-либо объекты — компоненты, тела, поверхности, кривые, точки — не должны показываться в чертеже, отключите их отображение в модели, используя команду Скрыть.

1.3. Если в чертеж планируется передача размеров и обозначений из модели, проставьте их.

1.4. Если в модели созданы слои, укажите те из них, которые будут переданы в чертеж (о слоях в модели см. раздел 2.15.14.2).

1.5. Решите, какая ориентация модели наиболее подходит для главного вида. Если выбранное положение модели невозможно установить, используя стандартные ориентации, добавьте пользовательскую ориентацию (см. раздел 2.1.3.2), соответствующую нужному положению.

2. Создайте чертеж КОМПАС-3D.

Если модель не очень сложная, для создания ее чертежа можно использовать команду построения стандартных видов (см. раздел 3.7.2.1). Она позволяет сразу получить весь необходимый набор проекций, в том числе изометрическую.

При создании сборочных чертежей, а также чертежей сложных деталей рекомендуется использовать команду построения произвольного вида (см. раздел 3.7.2.2).

Для автоматического создания чертежа и произвольного вида текущей модели в нем воспользуйтесь командой Создать новый чертеж из модели в меню Операции при работе с моделью.

Если в модели имеются несохраненные изменения, то при создании ее ассоциативного вида на экране появляется запрос на сохранение модели. Нажмите кнопку Да, чтобы немедленно сохранить файл модели или кнопку Нет, чтобы отказаться от сохранения. В любом случае в ассоциативном виде создается изображение модели в ее текущем виде.

3. Создав в чертеже стандартные или произвольные виды, приступайте к построению на их основе проекционных видов, разрезов, сечений, выносных элементов, местных видов и местных разрезов (см. разделы 3.7.2.3 — 3.7.2.8).

4. Если необходимо, отредактируйте изображение в ассоциативных видах:

• настройте отображение в видах объектов — тел, поверхностей, кривых, точек, а также элементов оформления — изображений резьбы, размеров и обозначений, имеющихся в модели (см. раздел 3.7.1.3.3).

• назначьте «неразрезаемые» компоненты (см. раздел 3.7.3.1),

• отключите отображение компонентов, которые не должны показываться на чертеже (см. раздел 3.7.3.2).

5. Добавьте в чертеж необходимые объекты оформления: размеры, технологические обозначения, надписи и другие элементы (осевые линии, обозначения центра и т.п.) (см. раздел 3.3). Перед тем как приступить к их созданию, рекомендуется включить ассоциативность и параметризацию при вводе всех объектов (см. раздел 7.2.1.7). Благодаря этому размеры, технологические обозначения, осевые линии и другие объекты, введенные вручную, будут связаны с изображением модели и смогут «отслеживать» его изменения. Например, после изменения диаметра отверстия в детали в ассоциативном виде изменится диаметр окружности, изображающей это отверстие, а также значение размера, ассоциативно связанного с ней. Кроме того, при работе в параметрическом режиме автоматически накладываются связи и ограничения на такие объекты, как линия разреза/сечения, стрелка взгляда, обозначение выносного элемента. Благодаря этому, например, горизонтальная линия разреза, выровненная по центру окружности, изображающей отверстие, будет сохранять свою горизонтальность и следовать за окружностью при перемещении отверстия в модели.

Кроме того, для удобства дальнейшей работы с чертежом рекомендуется создавать новые слои (о слоях в графическом документе см. раздел 3.6.6) для расположения объектов разных типов.

6. Скомпонуйте виды на листе чертежа (см. раздел 3.6.5.7). Если необходимо, отключите проекционные связи между видами (например, это может потребоваться для расположения вида по стрелке в произвольном месте листа).


3.7.1.3. Настройка ассоциативных видов

Существуют четыре группы настроек ассоциативных видов:

– параметры (см. раздел 3.7.1.3.1),

– линии (см. раздел 3.7.1.3.2),

– объекты и элементы оформления (см. раздел 3.7.1.3.3),

– надпись (см. раздел 3.7.1.3.4).

Настройки доступны для всех ассоциативных видов, кроме Местного вида и Местного разреза. Для вида Выносной элемент недоступна настройка объектов и элементов оформления. Настройки этих видов совпадают с соответствующими настройками их опорных видов.

Для линий, объектов и элементов оформления возможна умолчательная настройка (см. раздел 9.2.6.19.1).

В этом разделе:

3.7.1.3.1. Параметры

3.7.1.3.2. Линии

3.7.1.3.3. Объекты и элементы оформления

3.7.1.3.4. Надпись


3.7.1.3.1. Параметры

После вызова команды построения ассоциативного вида на вкладке Параметры Панели свойств появляются элементы, позволяющие настроить вид. Те элементы, которые являются общими для простых и ассоциативных видов, представлены в таблице 3.6.3. Специальные элементы вкладки Параметры — характерные для ассоциативных видов — представлены в таблице 3.7.1.

Табл. 3.7.1. Элементы управления параметрами ассоциативных видов

Элемент

Описание

Файл-источник

Поле содержит полное имя файла — источника модели, выбранной для изображения в чертеже. Чтобы указать другой файл-источник, введите его имя в данное поле или воспользуйтесь кнопкой Выбрать другую модель справа от поля. После нажатия кнопки на экране появляется диалог открытия файла. Укажите в диалоге нужную модель.

Если данная модель содержит исполнения и дополнительные номера, то в диалоге отображаются списки, позволяющие выбрать нужное исполнение и дополнительный номер.

После завершения выбора файла-источника его полное имя появляется в поле Файл-источник.

Только для Стандартных и Произвольного видов.

Исполнение

Список позволяет выбрать исполнение модели, для которой создается ассоциативный вид. Геометрия вида будет соответствовать выбранному исполнению.

Список присутствует на Панели свойств, если выбранная для создания вида модель содержит исполнения. Обозначения исполнений, как зависимых, так и независимых, располагаются на одном уровне иерархии списка.

Только для Стандартных и Произвольного видов.

Ориентация
модели

Список позволяет выбрать ориентацию модели на главном (при построении стандартных видов) или произвольном виде. Список содержит названия всех ориентаций, имеющихся в файле — источнике модели (о создании пользовательских ориентаций — см. раздел 2.1.3.2).

Только для Стандартных и Произвольного видов.

Схема

Переключатель, позволяющий настроить схему стандартных видов модели.

Только для Стандартных видов.

Подобрать

Кнопка, позволяющая автоматически подобрать такой стандартный масштаб, при котором все виды полностью умещаются на чертеже.

Только для Стандартных видов.

Проекционная связь

Переключатель, управляющий проекционной связью между видами.

Только для видов По стрелке, Проекционного и Разреза/сечения.

Разнести

Переключатель, управляющий разнесением сборки. Он доступен, если файлом-источником является сборка с заданными параметрами разнесения компонентов (см. раздел 2.15.7).

Только для видов По стрелке, Произвольного, Проекционного и Разреза/сечения.

Развертка

Переключатель, управляющий отображением листового тела в развернутом виде. Он доступен, если файлом-источником является деталь, содержащая листовое тело и параметры развертки (см. раздел 2.4.7.2). Об изображении развертки в чертеже см. также раздел 2.4.7.4.

Только для видов По стрелке, Произвольного, и Проекционного.

Слои

Переключатель, управляющий передачей в чертеж слоев, групп слоев и фильтров, находящихся в модели. В чертеж передаются только слои со свойством Проецировать в чертеж, подробнее см. раздел 3.7.3.11.

Только для Стандартных видов, Произвольного, Проекционного, По стрелке, Разреза/сечения.

Разрез/сечение

Группа переключателей, позволяющая выбрать тип изображения.

Только для видов Разрез/сечение и Местный разрез.


3.7.1.3.2. Линии

После вызова команды построения ассоциативного вида на вкладке Линии Панели свойств появляются элементы управления, позволяющие настроить отрисовку вида (рис. 3.7.5). Эти элементы представлены в таблице 3.7.2.

Рис. 3.7.5. Вкладка Линии

Табл. 3.7.2. Элементы управления отрисовкой ассоциативных видов

Элемент

Описание

Видимые линии

Список, позволяющий выбрать стиль1 для отрисовки видимых линий проекции модели.

Невидимые
линии

Опция, управляющая передачей в вид линий невидимого контура.

Если эта опция выключена, то переключатель отрисовки невидимых линий недоступен. При включении опции система обращается к модели и формирует линии невидимого контура. Переключатель показа невидимых линий становится доступным, и вы можете включить отрисовку невидимых линий.

Если во время настройки параметров вида было изменено состояние опции Невидимые линии, то после завершения настройки этот вид отображается перечеркнутым, т.е. требующим перестроения. В результате перестроения линии невидимого контура добавляются в вид (если опция Невидимые линии была включена) или удаляются из него (если опция была выключена).

Рекомендуется отключать опцию Невидимые линии при построении ассоциативных видов сборок, содержащих более 1000 компонентов.

Переключатель отрисовки
невидимых линий

Переключатель, управляющий отрисовкой невидимых линий проекции модели. При включенной отрисовке доступен список стилей линии. По умолчанию используется штриховая линия.

Переключатель отрисовки невидимых линий доступен, если включена опция Невидимые линии.

Переключатель отрисовки линий переходов

Переключатель, управляющий отрисовкой линий переходов. При включенной отрисовке доступен список стилей линии. По умолчанию используется сплошная тонкая линия.

Переключатель отрисовки линий сгиба

Переключатель, управляющий отрисовкой линий сгиба. При включенной отрисовке доступен список стилей линии. По умолчанию используется пунктир 2.

Для видов По стрелке, Проекционного и Произвольного переключатель Линии сгиба доступен, если при настройке параметров этого вида включена отрисовка развертки (см. табл. 3.7.1).

Для Разреза/сечения, Местного разреза и Выносного вида переключатель Линии сгиба доступен, если при настройке параметров опорного вида включена отрисовка развертки.
  1. Подробнее о стилях линии см. раздел 3.2.1.1.

Невидимые линии хранятся в виде вне зависимости от того, включена их отрисовка или нет. Если отрисовка этих линий не потребуется, отключите опцию Невидимые линии — это уменьшит размер файла чертежа.


3.7.1.3.3. Объекты и элементы оформления

После вызова команды построения ассоциативного вида на вкладке Объекты Панели свойств появляются элементы управления, позволяющие указать, какие объекты и элементы оформления, имеющиеся в модели, требуется отображать в этом виде (рис. 3.7.6).

Рис. 3.7.6. Вкладка Объекты

– В списке Объекты включите опции, соответствующие тем типам объектов, которые должны передаваться в вид.

Чтобы получить изображения не только видимых, но и скрытых объектов, включите также опцию Отображать скрытые объекты. При отключенной опции объекты, показ которых отключен в модели, не отображаются в ассоциативном виде.

Действие опций распространяется на все объекты модели, включая объекты в компонентах.

Присоединительные и контрольные точки не передаются в чертеж.

– В списке Элементы оформления включите опции, соответствующие тем типам элементов оформления, которые должны передаваться в вид.

Обратите внимание на то, что изображение резьбы в ассоциативном виде чертежа строится, если плоскость проекций этого вида строго параллельна или строго перпендикулярна оси поверхности, на которой построена резьба.

Резьба, находящаяся на невидимом участке модели, отображается в ассоциативном виде, если в нем включен показ линий невидимого контура (см. табл. 3.7.2). Стиль, установленный для этих линий, используется также и для отрисовки изображения резьбы.

Условия передачи в ассоциативные виды размеров и обозначений описаны в разделе 3.7.3.5.1.

Объекты и элементы оформления, входящие в скрытые компоненты (см. раздел 3.7.3.2), не отображаются вне зависимости от настройки, сделанной на вкладке Объекты.

Объекты модели, у которых свойство Проецировать в чертеж имеет значение Запрещено, отсутствуют в чертеже вне зависимости от настройки, сделанной на вкладке Объекты.

Настройка отображения объектов и элементов оформления недоступна для вида Выносной элемент. Объекты в нем показываются те же, что и в его опорном виде, а размеры и обозначения — те, для которых выполняются условия передачи.


3.7.1.3.4. Надпись

После вызова команды построения ассоциативного вида на вкладке Надпись вида Панели свойств появляются элементы управления, позволяющие настроить надпись вида.

Надпись вида — это текстовый объект, входящий в состав вида. Надпись содержит ссылки на объект оформления, связанный с видом, и ссылки на параметры самого вида. Подробнее о надписи вида — см. раздел 3.6.4.6.

Вкладка Панели свойств Надпись вида приведена на рис. 3.7.7, а описание элементов управления вкладки — в таблице 3.7.3.

Рис. 3.7.7. Вкладка Надпись вида

Табл. 3.7.3. Элементы управления надписью вида

Элемент

Описание

Окно просмотра надписи вида

Справочное поле, содержащее текущую надпись вида.

Обозначение

Отключение этой опции исключает из надписи вида обозначение объекта оформления (например, Б-Б). Для последующего включения этого текста необходимо включить опцию Обозначение.

Развернуто

Если опция отключена, то значок «развернуто» не включается в надпись вида. Если опция включена, то значок включается:

– в надпись произвольного вида, проекционного вида или вида по стрелке, если в нем изображена развертка листового тела (т.е. на вкладке Параметры Панели свойств активен переключатель Развертка),

– в надпись вида, содержащего разрез/сечение или выносной элемент, если в его опорном виде изображена развертка листового тела.

Масштаб

Опция, управляющая включением в надпись вида его текущего масштаба.

Повернуто

Если опция отключена, то значок «повернуто» не включается в надпись вида.

Если она включена, то значок включается в надпись вида, если угол поворота, заданный на вкладке Параметры Панели свойств, отличен от нуля1.

Угол

Опция, управляющая включением в надпись вида значения угла поворота. Опция Угол доступна, если включена опция Повернуто.

Лист

Опция, управляющая включением в надпись вида ссылки на номер листа чертежа, где располагается связанный с видом объект оформления.

Опция Лист доступна, если включена опция Обозначение.

Зона

Опция, управляющая включением в надпись вида ссылки на обозначение зоны чертежа, где располагается связанный с видом объект оформления. Если опция включена, то обозначение зоны — при условии, что в чертеже включено разбиение на зоны — добавляется в надпись. Если опция отключена, то обозначение зоны не добавляется в надпись вида.

Опция Зона доступна, если включена опция Обозначение.
  1. Если поворот вида обусловлен наличием проекционной связи с его опорным видом (на вкладке Параметры активен переключатель Проекционная связь), то значок «повернуто» не включается в надпись вида.

Если в чертеже имеются ассоциативные виды исполнений модели, одно из которых является зеркальным, то надписи этих видов содержат, кроме описанных выше элементов, ссылки на обозначения исполнений. Эти ссылки включаются в надписи автоматически. Подробнее см. раздел 3.7.3.12.


3.7.2. Построение видов

3.7. Ассоциативные виды

3.7.2. Построение видов

Создание Стандартных и Произвольного видов доступно вне зависимости от того, есть уже в чертеже какие-либо ассоциативные виды или нет.

Создание всех остальных видов возможно только на основе уже существующих видов.

Виды, используемые при создании других видов, называются опорными. Так, например, для проекционного вида опорным является вид, относительно которого указано направление при построении этого проекционного вида, для разреза или сечения — вид, содержащий изображение линии разреза, и т.д.

По умолчанию вид имеет такую же настройку отрисовки (см. раздел 3.7.1.3.2) и отображения объектов (см. раздел 3.7.1.3.3), что и опорный вид.

Если вид имеет разрыв, то в созданном на его основе проекционном виде, виде по стрелке или разрезе/сечении может автоматически создаваться разрыв с такими же параметрами. Для этого необходимо, чтобы направление проецирования было перпендикулярно направлению сдвига изображения в опорном виде (см. раздел 3.6.5.8.2).

С разрывами, полученными автоматически, можно выполнять действия, предусмотренные для разрывов, созданных при помощи команды Разрыв вида — управлять отображением в документе, редактировать, удалять и т.д. Работа с разрывами подробно описана в разделе 3.6.5.8.

В этом разделе:

3.7.2.1. Стандартные виды

3.7.2.2. Произвольный вид

3.7.2.3. Проекционный вид

3.7.2.4. Вид по стрелке

3.7.2.5. Местный вид

3.7.2.6. Выносной элемент

3.7.2.7. Разрез/сечение

3.7.2.7.1. Особенности использования штриховки, заданной в модели

3.7.2.8. Местный разрез


3.7.2.1. Стандартные виды

Чтобы построить стандартные виды модели, вызовите команду Стандартные виды.

В появившемся диалоге выберите файл-источник модели.

Если выбранная модель содержит исполнения, то в диалоге можно указать обозначение нужного исполнения. Геометрия вида будет соответствовать выбранному исполнению модели.

После выбора файла-источника в окне чертежа появится фантом габаритных прямоугольников видов.

По умолчанию система предлагает создание трех видов: главного вида, вида спереди и вида слева. Чтобы изменить набор стандартных видов выбранной модели, активизируйте переключатель Схема видов на вкладке Параметры Панели свойств.

На экране появится диалог выбора схемы видов (рис. 3.7.8). Взаимное расположение видов на схеме зависит от проекционного метода. Выбор проекционного метода выполняется при настройке параметров нового вида, см. раздел 9.2.6.19.1.

Элементы управления диалога выбора схемы видов представлены в таблице 3.7.4.

Рис. 3.7.8. Диалог выбора схемы видов: а) проекционный метод — Проекция по первому углу, б) проекционный метод — Проекция по третьему углу
а) | б)

Табл. 3.7.4. Диалог выбора схемы видов
Элемент | Описание
Схема видов | Схема стандартного расположения видов чертежа. Чтобы включить или отключить построение вида, щелкните по нему мышью. Отключение главного вида невозможно.
Зазор по горизонтали1 | Горизонтальное расстояние между габаритными прямоугольниками видов (в миллиметрах). На этом расстоянии будут располагаться, например, главный вид и вид слева.
Зазор по вертикали1 | Вертикальное расстояние между габаритными прямоугольниками видов (в миллиметрах). На этом расстоянии будут располагаться, например, главный вид и вид сверху.
  1. Зазоры измеряются «по бумаге», без учета масштаба видов.

Завершив настройку, нажмите кнопку ОК диалога.

Настройте параметры (см. табл. 3.6.3 и табл. 3.7.1) и отрисовку видов (см. раздел 3.7.1.3.2).

Чтобы зафиксировать фантом, задайте точку привязки главного вида.

Если в модели имеются несохраненные изменения, то при создании ее ассоциативного вида на экране появляется запрос на сохранение модели. Нажмите кнопку Да, чтобы немедленно сохранить файл модели или кнопку Нет, чтобы отказаться от сохранения. В любом случае в ассоциативном виде создается изображение модели в ее текущем виде.


3.7.2.2. Произвольный вид

Чтобы построить произвольный вид с модели, вызовите команду Произвольный вид.

В появившемся диалоге выберите файл-источник модели.

Если выбранная модель содержит исполнения, то в диалоге можно указать обозначение нужного исполнения. Геометрия вида будет соответствовать выбранному исполнению модели.

После выбора файла-источника на экране появится фантом габаритного прямоугольника вида.

Настройте параметры вида (см. табл. 3.6.3 и табл. 3.7.1), отрисовку вида (см. раздел 3.7.1.3.2) и набор передаваемых объектов (см. раздел 3.7.1.3.3). При необходимости настройте надпись вида (см. раздел 3.7.1.3.4).

Чтобы зафиксировать фантом, задайте точку привязки вида.

Если в модели имеются несохраненные изменения, то при создании ее ассоциативного вида на экране появляется запрос на сохранение модели. Нажмите кнопку Да, чтобы немедленно сохранить файл модели или кнопку Нет, чтобы отказаться от сохранения. В любом случае в ассоциативном виде создается изображение модели в ее текущем виде.


3.7.2.3. Проекционный вид

Чтобы построить вид модели, указав одно из ортогональных направлений относительно имеющегося вида, вызовите команду Проекционный вид.

Укажите опорный вид для создания проекционного вида. Затем перемещайте курсор в направлении, соответствующем виду, который требуется создать. На экране будет отображаться фантом габаритного прямоугольника вида.

Настройте параметры вида (табл. 3.6.3 и табл. 3.7.1), отрисовку вида (см. раздел 3.7.1.3.2) и набор передаваемых объектов (см. раздел 3.7.1.3.3). При необходимости настройте надпись вида (см. раздел 3.7.1.3.4).

Чтобы зафиксировать фантом, задайте точку привязки вида.

Изображение модели в полученном проекционном виде зависит от выбранного проекционного метода, см. раздел 9.2.6.19.1. Например, если выбран метод По первому углу, то для формирования вида слева курсор необходимо перемещать вправо относительно опорного вида, а если По третьему углу, то — влево.

При необходимости поверните вид другой стороной, для этого измените метод проецирования (см. раздел 9.2.6.19.1).


3.7.2.4. Вид по стрелке

Для построения вида по стрелке требуется наличие в его опорном виде стрелки, показывающей направление взгляда. Если стрелки нет, создайте ее (см. раздел 3.3.7.9).

Необходимым условием корректного построения вида по стрелке является расположение стрелки именно в его опорном виде. Поэтому при создании стрелки взгляда проследите, чтобы текущим был соответствующий вид (об управлении состоянием видов см. раздел 3.6.5.2).

Команда Вид по стрелке запускается автоматически после простановки в ассоциативном виде стрелки взгляда.

Если вы прервали выполнение автоматически запущенной команды, то, чтобы построить вид по стрелке, вызовите команду Вид по стрелке вручную и укажите стрелку взгляда.

На экране появится фантом габаритного прямоугольника вида по стрелке.

Настройте параметры вида (табл. 3.6.3 и табл. 3.7.1), его отрисовку (см. раздел 3.7.1.3.2), набор передаваемых объектов (см. раздел 3.7.1.3.3) и надпись вида (см. раздел 3.7.1.3.4).

Чтобы зафиксировать фантом, задайте точку привязки вида.


3.7.2.5. Местный вид

Местный вид — изображение отдельного, ограниченного места поверхности модели. В КОМПАС-3D построение местного вида осуществляется путем усечения изображения в существующем — опорном — виде. Границей усечения может являться любой замкнутый контур (окружность, эллипс, замкнутая кривая Безье и т.п.).

Если в опорном виде нет замкнутого контура, создайте его (см. разделы 3.2.5, 3.2.6, 3.2.8, 3.2.9).

Необходимым условием корректного построения местного вида является расположение ограничивающего его контура именно в опорном виде. Поэтому при создании контура проследите, чтобы текущим был соответствующий вид (об управлении состоянием видов см. раздел 3.6.5.2).

Чтобы построить местный вид, вызовите команду Местный вид.

Укажите контур, ограничивающий местный вид. Содержимое опорного вида, находящееся вне пределов контура, перестанет отображаться на экране.

Переключение между полным и усеченным отображением вида осуществляется командой Местный вид, расположенной в контекстном меню вида в Дереве чертежа.


3.7.2.6. Выносной элемент

Для построения этого вида требуется наличие в его опорном виде обозначения выносного элемента. Если обозначения нет, создайте его (см. раздел 3.3.7.11).

Необходимым условием корректного построения вида-выносного элемента является расположение обозначения выносного элемента именно в его опорном виде. Поэтому при создании обозначения проследите, чтобы текущим был соответствующий вид (об управлении состоянием видов см. раздел 3.6.5.2).

Команда Выносной элемент запускается автоматически после простановки в ассоциативном виде обозначения выносного элемента.

Если вы прервали выполнение автоматически запущенной команды, то, чтобы построить вид-выносной элемент, вызовите команду Выносной элемент вручную и укажите обозначение выносного элемента.

На экране появится фантом габаритного прямоугольника вида, содержащего выносной элемент.

Настройте параметры вида (табл. 3.6.3 и табл. 3.7.1), его отрисовку (см. раздел 3.7.1.3.2) и надпись (см. раздел 3.7.1.3.4).

Чтобы зафиксировать фантом, задайте точку привязки вида.


3.7.2.7. Разрез/сечение

Для построения этого вида требуется наличие в его опорном виде обозначения линии разреза. Если обозначения нет, создайте его (см. раздел 3.3.7.10).

Необходимым условием корректного построения разреза/сечения является расположение обозначения линии разреза именно в его опорном виде. Поэтому при создании обозначения проследите, чтобы текущим был соответствующий вид (об управлении состоянием видов см. раздел 3.6.5.2).

Команда Разрез/сечение запускается автоматически после создания в ассоциативном виде линии разреза/сечения.

Если вы прервали выполнение автоматически запущенной команды, то, чтобы построить разрез или сечение, вызовите команду Разрез/сечение вручную и укажите линию разреза/сечения.

На экране появится фантом габаритного прямоугольника вида, содержащего разрез/сечение.

Настройте параметры вида (табл. 3.6.3 и табл. 3.7.1), его отрисовку (см. раздел 3.7.1.3.2), набор передаваемых объектов (см. раздел 3.7.1.3.3) и надпись вида (см. раздел 3.7.1.3.4).

Чтобы настроить штриховку, активизируйте вкладку Штриховка Панели свойств.

При включенной опции Параметры из модели параметры штриховок автоматически берутся из тел и компонентов модели, по которой создан вид (вариант по умолчанию). В этом случае каждый компонент или тело может иметь собственные параметры штриховки. О задании параметров штриховок в модели см. раздел 2.14.6.6.

Если опция выключена, то становятся доступны элементы управления, которые позволяют настроить параметры штриховки вручную. После ввода параметров штриховка всех компонентов и тел становится одинаковой.

Об особенностях использования штриховки, заданной в модели, см. раздел 3.7.2.7.1.

Группа переключателей Штриховка сборки позволяет выбрать способ штриховки соседних деталей — в одну сторону или с поворотом на 90°.

Об остальных элементах управления вкладки Штриховка см. табл. 3.2.7.

Чтобы зафиксировать фантом, задайте точку привязки вида.

В этом разделе:

3.7.2.7.1. Особенности использования штриховки, заданной в модели


3.7.2.7.1. Особенности использования штриховки, заданной в модели

При создании ассоциативных видов, содержащих заданную в модели штриховку, необходимо учитывать следующее.

– Настройка использования параметров штриховки модели производится в командах Разрез/сечение или Местный разрез на вкладке Штриховка Панели свойств.

– Параметры штриховок компонентов и тел передаются из модели в чертеж однократно — при создании первого ассоциативного вида (вне зависимости от настроек вкладки Штриховка). Параметры сохраняются в чертеже и в дальнейшем могут использоваться для создания новых ассоциативных видов по данной модели. Это означает, что параметры штриховки для одного и того же компонента или тела будут одинаковыми на всех ассоциативных видах.

– При создании последующих ассоциативных видов по одной и той же модели в чертеж передаются параметры штриховок только для вновь созданных в ней компонентов и тел, у которых данные параметры в чертеже еще отсутствуют.

– Изменение параметров штриховки в модели не приводит к их автоматическому обновлению в видах при перестроении чертежа.

Для синхронизации параметров модели и чертежа служит команда Восстановить стили (см. раздел 3.7.3.4).

– Параметры штриховки можно изменить вручную в одном или нескольких ассоциативных видах. Для этого следует выделить штриховку (штриховки) и вызвать команду Изменить стиль... из контекстного меню или из меню Сервис.

После вызова команды на экране появляется диалог изменения стилей штриховок (рис. 3.7.9).

Рис. 3.7.9. Диалог замены стилей штриховок

На вкладке Штриховки выберите из списка Что заменять стили штриховки, которые требуется заменить, а из списка Чем заменять — имеющийся в документе стиль для замены. Чтобы для замены выбрать стиль из библиотеки, нажмите кнопку (>>).

Задайте цвет, шаг и угол штриховки, а также другие параметры, если необходимо.

В группе Применить к следует выбрать параметр применения нового стиля. По умолчанию выбран вариант Выделенным объектам, который означает, что стиль поменяется только у выделенных штриховок.

Вариант Телам доступен, если выделена хотя бы одна штриховка, параметры которой получены из модели. При выборе варианта Телам поменяются стили выделенных штриховок. Одновременно меняются стили невыделенных штриховок во всех ассоциативных видах для тех тел, стили которых попали в группу выделения.


3.7.2.8. Местный разрез

Для построения этого вида требуется наличие в его опорном виде замкнутого контура (окружности, эллипса, замкнутой кривой Безье и т.п.).

Если в опорном виде нет замкнутого контура, создайте его (см. разделы 3.2.5, 3.2.6, 3.2.8, 3.2.9).

Необходимым условием корректного построения местного разреза является расположение контура именно в его опорном виде. Поэтому при создании обозначения проследите, чтобы текущим был соответствующий вид (об управлении состоянием видов см. раздел 3.6.5.2).

Контур не должен иметь самопересечений.

Создание местных разрезов на выносных элементах невозможно.

Чтобы построить местный разрез, вызовите команду Местный разрез.

Укажите в опорном виде замкнутый контур, ограничивающий местный разрез (рис. 3.7.10, а).

При необходимости введите номер и имя местного разреза в одноименные поля на Панели свойств. Кнопка Секущая плоскость доступна при отключенном автосоздании объектов (см. раздел 1.4.2.10), а также при редактировании ранее созданного местного разреза. Она позволяет заново указать положение секущей плоскости.

Переключатели группы Разрез/сечение позволяют выбрать тип изображения: разрез или сечение.

Группа Разрез/сечение доступна, если опорный вид создаваемого местного разреза не является разрезом (сечением). В противном случае тип изображения совпадает с типом изображения в опорном виде, и переключение невозможно.

Чтобы настроить штриховку, активизируйте вкладку Штриховка Панели свойств.

При включенной опции Параметры из модели параметры штриховок автоматически берутся из тел и компонентов модели, по которой создан вид (вариант по умолчанию). В этом случае каждый компонент или тело может иметь собственные параметры штриховки. О задании параметров штриховок в модели см. раздел 2.14.6.6.

Если опция выключена, то становятся доступны элементы управления, которые позволяют настроить параметры штриховки вручную. После ввода параметров штриховка всех компонентов и тел становится одинаковой.

Об особенностях использования штриховки, заданной в модели, см. раздел 3.7.2.7.1.

Группа переключателей Штриховка сборки позволяет выбрать способ штриховки соседних деталей. Об остальных элементах управления вкладки Штриховка см. табл. 3.2.7.

После указания контура, ограничивающего местный разрез, на экране появится фантом прямой линии — след секущей плоскости. Обратите внимание на то, что этот фантом виден, только когда курсор проходит над видом, плоскость проекций которого перпендикулярна плоскости проекций создаваемого местного разреза.

Укажите положение секущей плоскости (рис. 3.7.10, б).

Рис. 3.7.10. Построение местного разреза: а) указание контура, ограничивающего разрез, б) указание положения секущей плоскости, в) результат выполнения команды
а) | б) | в)

Местный разрез будет построен (рис. 3.7.10, в). Его пиктограмма появится на ветви Дерева чертежа, соответствующей его опорному виду (рис. 3.7.11).

Рис. 3.7.11. Пиктограмма местного разреза

Контекстное меню местного разреза в Дереве чертежа содержит команды управления этим местным разрезом. Они представлены в таблице 3.7.5.

Табл. 3.7.5. Команды управления местным разрезом
Название команды | Описание
Местный разрез | Управляет отображением местного разреза на его опорном виде. При отключении показа местного разреза ограничивающий его контур по-прежнему отображается на экране. Если граница не должна быть видна, ее можно перенести ее на другой слой, который затем погасить.
Параметры разреза... | Позволяет настроить параметры местного разреза. После вызова команды на Панели свойств появляются те же элементы, что и при создании разреза.
Удалить разрез | Позволяет удалить местный разрез. После вызова команды на экране появляется диалог, в котором вы можете подтвердить удаление вида или отказаться от него. При удалении местного разреза ограничивающий его контур по-прежнему остается в чертеже. Его нужно удалять отдельно.


3.7.3. Приемы работы с ассоциативными видами

3.7. Ассоциативные виды

3.7.3. Приемы работы с ассоциативными видами

При работе с ассоциативными видами вы можете использовать общие приемы (см. раздел 3.6.5), а также ряд специальных приемов.

В этом разделе:

3.7.3.1. Назначение «неразрезаемых» компонентов

3.7.3.2. Отключение изображения компонента на виде

3.7.3.3. Отключение проекционной связи между видами

3.7.3.4. Управление стилями линий, точек и штриховок

3.7.3.5. Работа с проекционными обозначениями

3.7.3.5.1. Условия формирования проекционных обозначений в видах

3.7.3.5.2. Управление отображением проекционных обозначений

3.7.3.5.3. Свойства проекционных обозначений

3.7.3.5.4. Редактирование проекционных обозначений

3.7.3.6. Переход к редактированию модели

3.7.3.7. Предупреждения о необходимости перестроения чертежа и об ошибках

3.7.3.8. Заполнение основной надписи ассоциативного чертежа

3.7.3.8.1. Синхронизация основной надписи и модели

3.7.3.9. Передача технических требований из модели в чертеж. Синхронизация

3.7.3.10. Передача неуказанной шероховатости из модели в чертеж. Синхронизация

3.7.3.11. Передача слоев из модели в чертеж

3.7.3.12. Надпись вида зеркального исполнения

3.7.3.13. Разрушение ассоциативных связей


3.7.3.1. Назначение «неразрезаемых» компонентов

Сразу после создания разреза или сечения модели, содержащей компоненты (в том числе местного разреза или сечения), все попавшие в секущую плоскость детали изображаются разрезанными. Однако существуют детали, которые не должны показываться в разрезе, несмотря на то что через них проходит секущая плоскость. К ним относятся валы, крепежные элементы и др.

Чтобы указать деталь или подсборку, которая не должна разрезаться, выполните следующие действия.

1. Разверните ветвь Дерева чертежа, соответствующую виду (разрезу или сечению), на котором компонент должен быть показан неразрезанным. Разверните список компонентов и найдите нужный компонент.

2. Из контекстного меню этого компонента вызовите команду Не разрезать.

3. Вид, содержащий изображение этого компонента, будет отмечен в Дереве чертежа красной «галочкой», означающей, что чертеж необходимо перестроить.

4. Нажмите клавишу <F5> или кнопку Перестроить на панели Вид.

Изображение в чертеже будет перестроено с учетом сделанных изменений.

Чтобы вновь включить изображение компонента в разрезе, вызовите из контекстного меню на нем в Дереве чертежа команду Разрезать, после чего перестройте чертеж.

Изображение компонента в неразрезанном виде на одном разрезе (сечении) никак не влияет на изображение его на других разрезах (сечениях). Иными словами, компонент, изображенный на нескольких разрезах (сечениях), на одних может быть показан разрезанным, а на других — целым.


3.7.3.2. Отключение изображения компонента на виде

Чтобы дать представление о внутреннем устройстве изделия, на некоторых видах чертежа его изображают, не показывая какие-либо детали.

Для получения изображения изделия без каких-либо деталей совершенно необязательно прибегать к редактированию трехмерной модели.

После создания в чертеже нужных видов (по умолчанию они содержат изображения всех видимых компонентов), можно отключить показ «лишних» компонентов на некоторых из них.

Для этого выполните следующие действия.

1. Разверните ветвь Дерева чертежа, соответствующую виду, на котором должно быть отключено изображение какого-либо компонента. Разверните список компонентов и найдите нужный компонент.

2. Из контекстного меню этого компонента вызовите команду Скрыть.

3. Вид, содержащий изображение этого компонента, будет помечен в Дереве чертежа красной «галочкой», означающей, что чертеж необходимо перестроить.

4. Нажмите клавишу <F5> или кнопку Перестроить на панели Вид.

Изображение в чертеже будет перерисовано с учетом внесенных изменений.

Пиктограммы скрытых компонентов отображаются в Дереве чертежа серым цветом.

Отключение изображения компонента на одном из видов никак не влияет на показ этого компонента в других видах чертежа.

Чтобы вновь включить показ компонента, вызовите из контекстного меню на нем в Дереве чертежа команду Показать, после чего перестройте чертеж.

Если показ компонента включен, то его объекты и элементы оформления отображаются в виде согласно настройке, сделанной на вкладке Объекты Панели свойств (см. раздел 3.7.1.3.3).


3.7.3.3. Отключение проекционной связи между видами

Проекционные виды чертежа, созданные с помощью команды Стандартные виды, находятся в проекционной связи со своим главным видом; виды, созданные с помощью команд Проекционный вид, Вид по стрелке и Разрез/сечение, — с опорными видами.

Наличие проекционных связей между видами ограничивает их взаимное перемещение. Например, вид по стрелке может перемещаться в поле чертежа только в направлении, указанном стрелкой взгляда.

Если возникает необходимость произвольного расположения какого-либо из видов, вызовите из контекстного меню этого вида в Дереве чертежа команду Проекционная связь. Эта команда доступна также в контекстном меню вида, выделенного в окне чертежа. По умолчанию проекционная связь включена — кнопка команды Проекционная связь нажата. Для отключения проекционной связи вызовите команду. После этого вы можете перемещать вид в окне чертежа при помощи мыши.

Другой способ управления проекционной связью состоит в следующем. Вызовите из контекстного меню проекционного вида в Дереве чертежа команду Параметры вида. На Панели свойств появятся элементы управления, которые позволяют задать параметры вида. Активизируйте переключатель Проекционная связь. После этого вы сможете ввести координаты точки привязки вида в полях на Панели свойств.

Чтобы включить проекционную связь, вызовите из контекстного меню на этом виде в Дереве чертежа команду Проекционная связь. Проекционная связь будет включена.


3.7.3.4. Управление стилями линий, точек и штриховок

По умолчанию в ассоциативном виде объекты имеют следующие стили:

– линии проекций тел и поверхностей — стили, заданные при настройке вида (см. раздел 3.7.1.3.2);

– проекции точек и кривых — стили соответствующих объектов в модели (см. раздел 2.5.4.1);

– штриховки на разрезах/сечениях — стили, заданные в модели для компонентов и тел (см. раздел 2.14.6.6).

При необходимости вы можете назначать линиям, точкам и штриховкам любые другие стили (см. раздел 3.2.1.1.2).

Впоследствии, чтобы вернуть линиям, точкам и штриховкам умолчательные стили, вызовите команду Восстановить стили из контекстного меню вида, выделенного в Дереве чертежа или в чертеже. Команда может быть применена к нескольким выделенным видам одновременно.


3.7.3.5. Работа с проекционными обозначениями

Трехмерная модель изделия может содержать размеры и обозначения (о создании этих объектов см. разделы 2.9.2 и 2.9.3). Размеры и обозначения могут передаваться в чертеж, содержащий ассоциативные виды модели. Объекты, появившиеся в чертеже в результате передачи, называются проекционными обозначениями.

В этом разделе:

3.7.3.5.1. Условия формирования проекционных обозначений в видах

3.7.3.5.2. Управление отображением проекционных обозначений

3.7.3.5.3. Свойства проекционных обозначений

3.7.3.5.4. Редактирование проекционных обозначений


3.7.3.5.1. Условия формирования проекционных обозначений в видах

Если при настройке параметров вида включена передача размеров и обозначений (см. раздел 3.7.1.3.3), то соответствующие им проекционные обозначения формируются в виде при выполнении следующих условий.

– Плоскость проекций вида параллельна плоскости простановки размера или обозначения.

– В виде отображаются объекты (компоненты, тела, поверхности, линии), к которым проставлены размеры или обозначения. Например, обозначения позиций будут показаны в виде, если в нем видны грани или участки граней, от которых отходят позиционные линии-выноски.

Для формирования проекционных обозначений в сечениях, разрезах, местных видах и выносных элементах требуется выполнение дополнительных условий.

– В сечение передаются только те размеры и обозначения, плоскость простановки которых совпадает с плоскостью сечения.

– Передача размера или обозначения в разрез и выносной элемент зависит от положения точек, считающихся точками привязки (см. табл. 3.7.6).

• Размеры и обозначения передаются в разрез, если ни одна из их точек привязки не отсечена линией разреза.

• Размеры и обозначения передаются в выносной элемент или местный вид, если проекции всех их точек привязки находятся внутри контура, ограничивающего вид.

Табл. 3.7.6. Точки привязки размеров и обозначений
Объект | Точки привязки
линейный, линейный от отрезка до точки, угловой размеры | начальные точки выносных линий
радиальный, диаметральный размеры | центр образмериваемой окружности или дуги
линия-выноска, обозначения позиции, маркировки, клеймения, шероховатости на полке, базы, допуск формы и расположения | конечные точки ответвлений
обозначение шероховатости без полки | точка простановки знака

Обратите внимание на то, что проекционные обозначения, соответствующие линейным и угловым размерам, формируются в ассоциативном виде и в том случае, если проекции их точек привязки закрыты линиями видимого контура, например, как показано на рисунке 3.7.12.

Рис. 3.7.12. Линейный размер в модели (а) и соответствующий ему проекционный размер в ассоциативном виде (б)
а) | б)

Проекционные обозначения, имеющиеся в видах чертежа, могут быть видимыми или скрытыми (см. раздел 3.7.3.5.2).

Размеры и обозначения, исключенные из расчета в модели, не передаются в чертеж.


3.7.3.5.2. Управление отображением проекционных обозначений

Вы можете включать или отключать показ проекционных обозначений в чертеже.

Чтобы скрыть видимые проекционные обозначения, выделите их и вызовите из контекстного меню команду Скрыть. Выбранные проекционные обозначения перестанут отображаться.

Чтобы сделать скрытые проекционные обозначения видимыми, выполните следующие действия.

1. Вызовите команду Вид — Показать скрытые обозначения.

Все скрытые проекционные обозначения отобразятся на экране светло-серым цветом. Форма курсора изменится.

2. Последовательно щелкайте мышью на обозначениях, которые нужно сделать видимыми.

Во время работы команды Показать скрытые обозначения можно также скрывать видимые обозначения, щелкая на них мышью.

3. Завершите работу команды, нажав кнопку Прервать команду на Панели специального управления.

Включение/отключение показа проекционного обозначения в виде не влияет на отображение соответствующего объекта в модели. И наоборот, включение/отключение показа размера или обозначения в модели не влияет на отображение соответствующего проекционного обозначения в ассоциативном виде этой модели.

В чертеж передаются все размеры и обозначения, удовлетворяющие условиям, указанным в разделе 3.7.3.5.1, однако часть их может быть автоматически скрыта. Поэтому, если вы не видите нужных проекционных обозначений на чертеже, проверьте, не скрыты ли они. При необходимости включите показ обозначений, как описано выше. Далее приведены наиболее часто встречающиеся случаи, в которых проекционные обозначения автоматически скрываются.

– Если размер или обозначение скрыто в модели, то соответствующее проекционное обозначение скрывается и в ассоциативном виде.

– Если новое проекционное обозначение является дубликатом уже имеющегося, то оно скрывается. Например, при построении выносного элемента проекционные обозначения в нем создаются, но не показываются — из-за того, что уже показаны в ранее созданном опорном виде.

– Проекционное обозначение, точки привязки которого принадлежат линиям невидимого контура, отображается в виде, если в нем включен показ этих линий. Если же показ невидимых линий отключен, то проекционное обозначение отображается только при условии, что его точки привязки проецируются точно на линии видимого контура. О настройке отображения в виде линий невидимого контура см. раздел 3.7.1.3.2.


3.7.3.5.3. Свойства проекционных обозначений

При работе с проекционными обозначениями необходимо иметь в виду следующие их особенности.

– Проекционные обозначения имеют ассоциативную связь с соответствующими размерами и обозначениями в модели. Благодаря этой связи из модели в чертеж передается текст надписи проекционного обозначения и некоторые другие параметры (тип углового размера, тип знака шероховатости и т.п.). Обновление чертежа происходит при его открытии, а также по команде Вид — Перестроить.

– Признаком существования ассоциативной связи между моделью и проекционным обозначением является наличие у последнего ограничения Проекционный. При необходимости вы можете удалить это ограничение (см. раздел 7.2.3.1), и проекционное обозначение превратится в обычный размер или обозначение.

– Проекционные размеры связаны не только с размерами в модели, но и с геометрическими объектами ассоциативного вида (т.е. с проекциями объектов, к которым они проставлены). Благодаря этому при обновлении чертежа размеры перестраиваются в соответствии с изменением изображения модели.

– Буква в проекционном обозначении базы передается из модели в чертеж только в том случае, если в чертеже отключена автосортировка для баз (см. раздел 9.2.6.13.14); при смене буквы в модели синхронизация не производится. Если автосортировка баз включена, то проекционному обозначению базы присваивается первая свободная буква в соответствии с порядком сортировки. При отключении в чертеже автосортировки в проекционных обозначениях баз остаются те буквы, которые были на момент отключения.

– Если обозначения допуска формы и расположения в модели содержат ссылки на обозначения баз, то аналогичные ссылки создаются и в чертеже.


3.7.3.5.4. Редактирование проекционных обозначений

Возможности редактирования проекционных обозначений ограничены наличием связи с моделью.

Редактирование параметров

Чтобы отредактировать параметры проекционного обозначения, дважды щелкните по нему мышью.

На Панели свойств появятся такие же элементы управления параметрами объекта, как и при создании в чертеже обычных объектов соответствующего типа.

Особенность редактирования проекционного обозначения состоит в следующем: те параметры, значения которых передаются в чертеж из модели, недоступны для редактирования. Остальные параметры доступны, и вы можете менять их произвольным образом. Сделанные изменения сохраняются в чертеже и не изменяются во время его перестроения.

Например, при редактировании линейного размера доступны для изменения все параметры, кроме координат точек привязки и типа ориентации; при редактировании размерной надписи можно только подчеркнуть размер, заключить его в рамку и/или в скобки, отключить отображение допуска, выбрать способ расположения отклонений или предельных значений. Кроме того, можно отключить автоопределение значения размера и ввести в качестве значения любые символы.

Редактирование характерных точек

При выделении проекционного обозначения щелчком мыши на экране отображаются характерные точки обозначения. Перемещая это точки мышью, вы можете редактировать конфигурацию проекционного обозначения.

Например, с помощью характерных точек вы можете изменить положение размерной линии проекционного размера или положение точки начала полки проекционной линии-выноски.

При редактировании характерных точек проекционных обозначений базы, шероховатости, допуска формы, маркировки, клеймения, позиции и линии-выноски вы можете перемещать и проекции их точек вставки (см. табл. 3.7.6). Если положение проекции точки вставки обозначения было отредактировано в чертеже вручную, то последующие изменения положения точки вставки обозначения, сделанные в модели, в чертеж не передаются.


3.7.3.6. Переход к редактированию модели

Если на вашем рабочем месте установлен основной компонент КОМПАС-3D — система трехмерного моделирования, и на ключе электронной защиты имеется лицензия для его использования, то во время работы с чертежом можно быстро открыть документ, содержащий изображенную в этом чертеже трехмерную модель. Если вы работаете со сборочным чертежом, то из него можно непосредственно перейти к моделям деталей.

Для этого разверните ветвь Дерева чертежа, соответствующую любому виду, на котором имеется изображение компонента (детали или подсборки), подлежащего редактированию, и вызовите из контекстного меню этого компонента команду Редактировать в окне.

КОМПАС-3D откроет окно, содержащее выбранную трехмерную модель. Внесите в нее необходимые изменения, сохраните и закройте окно.

При возврате в окно чертежа, содержащего изображение отредактированной модели, система выдаст запрос на перестроение чертежа. Положительный ответ на этот запрос означает перестроение изображения в чертеже с учетом изменений, внесенных в модель.

Перестроение чертежа модели, состоящей из большого количества деталей и подсборок, может занять значительное время. Поэтому, если необходимо отредактировать несколько компонентов такой модели, рекомендуется перестраивать ее чертеж один раз — после внесения последнего изменения (а не каждый раз после редактирования отдельного компонента).

Вообще говоря, перейти к редактированию компонента в окне можно, открыв содержащий его файл обычным способом: нажать кнопку Открыть документ или вызвать команду Файл — Открыть и выбрать нужный файл. При использовании команды Редактировать в окне не требуется разыскивать нужный файл в папках на диске — система находит его автоматически.


3.7.3.7. Предупреждения о необходимости перестроения чертежа и об ошибках

3.7.3.7. Предупреждения
о необходимости перестроения чертежа и об ошибках

Наличие связей между моделью и ее изображением позволяет постоянно следить за их соответствием друг другу.

Всякий раз при открытии и активизации чертежей, содержащих ассоциативные виды, система проверяет соответствие между изображением и моделью. В случае обнаружения расхождений выдается запрос на перестроение геометрических объектов чертежа.

Положительный ответ на этот запрос запускает немедленное перестроение изображения в чертеже. Отрицательный ответ откладывает перестроение. При этом пиктограммы видов, изображения в которых не соответствуют моделям, в Дереве чертежа помечаются красной «галочкой», означающей необходимость перестроения чертежа; в окне чертежа такие виды отображаются перечеркнутыми.

Вы можете в любое время перестроить чертеж, воспользовавшись клавишей <F5> или кнопкой Перестроить на панели Вид.

Если в модели имеются несохраненные изменения, то при перестроении ее ассоциативного вида на экране появляется запрос на сохранение модели. Нажмите кнопку Да, чтобы немедленно сохранить файл модели или кнопку Нет, чтобы отказаться от сохранения. В любом случае изображение модели и содержимое основной надписи в ассоциативном виде будут соответствовать ее текущему виду.

Перестроение чертежа требуется также после отключения/включения отображения компонентов, назначения «неразрезаемых» компонентов и в некоторых других случаях.

Кроме команды Перестроить для обновления изображения модели можно использовать команду Перепроецировать. Эта команда заново формирует все имеющиеся в чертеже ассоциативные виды — вне зависимости от того, перечеркнуты они или нет. Вызов команды Перепроецировать осуществляется комбинацией клавиш <Ctrl> + <Alt> + <F5>.

Если «галочкой» в Дереве чертежа помечена пиктограмма модели, то это означает, что перестроения требует не чертеж, а модель, изображение которой содержится в виде. Чтобы перестроить модель, откройте ее (см. раздел 3.7.3.6) и нажмите клавишу <F5> или кнопку Перестроить. Затем сохраните модель и закройте ее окно.

Иногда после перестроения чертежа на месте «галочки» появляется признак ошибки (восклицательный знаки в красном кружке), свидетельствующий об ошибке построения вида. Например, в результате редактирования линии разреза/сечения произошло ее самопересечение. Разрез, соответствующий такой линии разреза/сечения, не может быть построен, поэтому его пиктограмма в Дереве чертежа получает признак ошибки.

Чтобы узнать, в чем заключается возникшая ошибка, выделите в Дереве чертежа ошибочный объект и вызовите из контекстного меню команду Что неверно?.

На экране появится диалог, в котором перечислены ошибки, возникшие при перестроении этого объекта.

Справочная система содержит рекомендации по возможным путям устранения ошибки.

Чтобы получить разъяснение конкретной ошибки и общие рекомендации по ее устранению, выделите описание ошибки в диалоге и нажмите кнопку Справка.

Если вид содержит изображение ошибочной модели, то признак ошибки в Дереве чертежа получает как пиктограмма модели, так и пиктограммы вида и листа чертежа. Благодаря этому наличие ошибки в модели, изображенной в чертеже, заметно даже тогда, когда Дерево чертежа полностью свернуто.

Чтобы исправить ошибку в модели, откройте ее и отредактируйте, используя рекомендации Справочной системы.


3.7.3.8. Заполнение основной надписи ассоциативного чертежа

При создании Стандартных или Произвольного видов в основную надпись чертежа передаются следующие сведения из документа-модели:

– обозначение (простое — полностью, составное — все части, кроме кода документа),

– наименование,

– масса,

– материал (только для чертежей деталей).

Эти сведения вводятся во время работы с документом-моделью (*.m3d, *.a3d) при настройке свойств детали или сборки.

Масса детали рассчитывается автоматически в соответствии с плотностью материала детали и ее формой. Масса сборочной модели определяется как суммарная масса ее компонентов.

Если чертеж содержит ассоциативные изображения нескольких моделей (это могут быть разные документы-модели или разные исполнения одной и той же модели), то вы можете указать, из какой модели следует брать сведения для заполнения основной надписи.

Для этого, дважды щелкнув мышью по основной надписи чертежа, перейдите в режим ее редактирования.

Активизируйте вкладку Модели Панели свойств. На ней перечислены названия документов-моделей, ассоциативные виды которых имеются в активном чертеже.

Слева от названия модели, сведения о которой переданы в основную надпись чертежа, находится пиктограмма, изображающая лист чертежа. Чтобы указать для связи с основной надписью другую модель, выделите ее в списке и нажмите кнопку Связать (можно также дважды щелкнуть мышью на нужной строке).

Текст в графах основной надписи изменится. Чтобы подтвердить выбор модели, нажмите кнопку Создать объект. Система перейдет в обычный режим работы, а основная надпись будет содержать сведения об указанной модели.

Заполнение остальных граф основной надписи ничем не отличается от заполнения граф основной надписи обычного чертежа (см. раздел 3.6.3.1).

Сведения в графы Разработал, Проверил, Утвердил, Технологический контроль, Нормоконтроль также передаются из документа-модели, если в ней заданы значения одноименных системных свойств. Подробнее см. раздел Свойства модели в ассоциативном чертеже.

В этом разделе:

3.7.3.8.1. Синхронизация основной надписи и модели


3.7.3.8.1. Синхронизация основной надписи и модели

Благодаря наличию связи между моделью и основной надписью чертежа, содержащего ее ассоциативные виды, возможна синхронизация основной надписи и модели.

Синхронизация основной надписи и модели — это передача данных между свойствами модели и основной надписью чертежа.

Например, после создания в чертеже ассоциативных видов детали потребовалось сменить материал, из которого она изготовлена. Чтобы в основную надпись чертежа попали новое обозначение материала и новое значение массы, необходима синхронизация основной надписи и модели.

Из модели в чертеж могут передаваться те же сведения, что и при создании ассоциативных видов:

– обозначение (простое — полностью, составное — все части, кроме кода документа),

– наименование,

– масса,

– материал.

Настройка передачи данных из модели в чертеж и управление этой передачей производятся на вкладке Параметры Панели свойств в режиме редактирования основной надписи чертежа. Элементы управления, расположенные на этой вкладке, представлены в таблице 3.7.7.

Работая с чертежом, вы можете в любой момент синхронизировать данные в основной надписи чертежа и в свойствах модели.

Так, чтобы получить данные из модели (обозначение, наименование, материал, массу), вызовите из контекстного меню основной надписи чертежа в режиме заполнения команду Синхронизировать данные.

Если ассоциативный вид модели скопирован в новый чертеж через буфер обмена, то для передачи данных из этой модели в основную надпись чертежа его необходимо перестроить.

В обратном направлении — из чертежа в модель — могут быть переданы только обозначение и наименование изделия. Эта передача не требует настройки и производится автоматически при сохранении чертежа. Стандартные код и наименование документа (если они присутствуют в основной надписи чертежа) в модель не попадают.

Перечень стандартных кодов и наименований документов задается в файле кодов и наименований — graphic.kds. По умолчанию он находится в подпапке \Sys главной папки системы. Формат файла — текстовый, поэтому при необходимости файл graphic.kds может быть открыт и отредактирован в любом текстовом редакторе.

Табл. 3.7.7. Элементы управления синхронизацией основной надписи

Элемент

Описание

Синхронизация
данных

Переключатель, позволяющий включить или выключить синхронизацию основной надписи и модели.

Если он активен, то возможна передача данных как из модели в чертеж, так и из чертежа в модель. В противном случае данные не передаются ни в одном направлении.

Синхронизировать

Кнопка, позволяющая получить данные из модели (обозначение, наименование, материал, массу).

Режим
синхронизации

Группа переключателей, позволяющая выбрать режим синхронизации.

Если активен переключатель Автоматическая синхронизация, то при открытии и активизации ассоциативного чертежа, а также при перестроении изображения в его основную надпись передаются данные из модели.

Если активен переключатель Синхронизация по запросу, то возможна только ручная синхронизация1.

Синхронизация массы

Переключатель, управляющей синхронизацией массы модели. Если он активен, то всякий раз при синхронизации значение массы модели будет рассчитано заново и занесено в графу Масса.

Если переключатель не активен, то расчет массы не производится, и ее значение в основной надписи не изменяется.

Точность
представления

Поле для ввода или выбора количества знаков после запятой в значении массы.

Масса

Список, позволяющий установить единицы измерения для отображения значения массы модели в основной надписи: килограммы, граммы или тонны.

Сокращение

Поле обозначения единиц измерения массы. Символы, введенные в это поле, передаются в графу Масса.

  1. Для этого следует нажать кнопку Синхронизировать на Панели свойств или вызвать команду Синхронизировать данные из контекстного меню основной надписи. Если в модели имеются несохраненные изменения, то на экране появляется запрос на сохранение модели. Нажмите кнопку Да, чтобы немедленно сохранить файл модели или кнопку Нет, чтобы отказаться от сохранения.

Если обозначение материала в ассоциативном чертеже отредактировано путем добавления пробелов, переноса строк или табуляции, то в результате автоматической синхронизации обозначение материала в чертеже не меняется при условии, что материал модели не менялся. Во всех остальных случаях обозначение материала в чертеже синхронизируется с обозначением материала модели.

Синхронизацию основной надписи чертежа и модели можно настроить также в диалоге вызываемом командой Сервис — Параметры... — Текущий чертеж — Параметры документа — Основная надпись (см. раздел 9.2.6.19.2).

Элементы управления этого диалога выполняют те же функции, что и элементы вкладки Параметры, приведенные в таблице 3.7.7. Единственным различием является отсутствие в диалоге кнопки Синхронизировать, так как она не участвует в процессе настройки.


3.7.3.9. Передача технических требований из модели в чертеж. Синхронизация

3.7.3.9. Передача технических требований из модели в чертеж.
Синхронизация

В ассоциативный чертеж могут передаваться технические требования из модели, по которой создан чертеж. В полученных требованиях ссылки на объекты модели будут представлять собой ссылки на соответствующие объекты в чертеже. Впоследствии, если технические требования в модели будут отредактированы, то изменения могут быть переданы в чертеж путем их синхронизации. Передача технических требований из чертежа в модель не предусмотрена.

О вводе технических требований в модели см. раздел 2.15.11.1.

Передача требований в чертеж происходит автоматически при создании ассоциативного вида, если одновременно выполняются следующие условия.

1. Включена опция Синхронизировать технические требования в диалоге параметров технических требований (см. раздел 9.2.6.19.6).

2. Создаваемый ассоциативный вид — первый ассоциативный вид в чертеже.

3. В чертеже отсутствуют технические требования.

4. В модели, по которой создается вид, введены технические требования.

С полученными требованиями могут выполняться действия, предусмотренные для технических требований чертежа — позиционирование, редактирование, разбивка на страницы, удаление, описанные в разделе 3.6.7.

Чтобы синхронизировать технические требования, вызовите в чертеже одну из команд

– Вставка — Технические требования — Синхронизировать,

– Синхронизировать технические требования из контекстного меню технических требований.

Если при создании ассоциативного вида технические требования не были переданы в чертеж из-за несоблюдения одного или нескольких вышеперечисленных условий, то их можно передать позже, вызвав команду синхронизации.

При передаче или синхронизации технических требований необходимо учитывать следующие особенности:

– формат текста, заданный для технических требований в модели, в чертеж не передается;

– передача технических требований осуществляется из модели, с которой связана основная надпись;

– ранее переданные технические требования, отредактированные или введенные вручную, полностью заменяются новыми.

Вы можете отменить выполненную передачу или синхронизацию технических требований при помощи команды Отменить, вызываемую на Стандартной панели или из меню Редактор.

Следует иметь в виду, что передаваемые технические требования могут содержать созданные в модели ссылки на различные объекты, например, элементы оформления — линии-выноски, обозначения базы, позиции и другие.

Ссылки будут рабочими в полученных технических требованиях, если в чертеже присутствуют объекты ссылок в видимом или скрытом состоянии. О передаче в чертеж объектов из модели см. раздел 3.7.3.5.1.


3.7.3.10. Передача неуказанной шероховатости из модели в чертеж. Синхронизация

3.7.3.10. Передача неуказанной шероховатости
из модели в чертеж. Синхронизация

Неуказанная шероховатость, если она задана в модели (см. раздел 2.15.12), передается в ассоциативный чертеж этой модели. Полученная из модели неуказанная шероховатость может редактироваться и перемещаться в чертеже.

Существует возможность синхронизации неуказанной шероховатости в модели и в чертеже. При этом изменения параметров неуказанной шероховатости в модели передаются в чертеж. Передача неуказанной шероховатости из чертежа в модель не предусмотрена.

Синхронизация неуказанной шероховатости может выполняться автоматически или вручную — это зависит от настройки. Настройка синхронизации неуказанной шероховатости в модели и в чертеже выполняется в диалоге Синхронизация неуказанной шероховатости (см. раздел 9.2.6.19.8).

Автоматическая синхронизация производится при открытии и активизации документа, а также при перестроении изображения в чертеже.

В ручном режиме синхронизация выполняется с помощью команды Синхронизировать, вызываемой из контекстного меню знака неуказанной шероховатости в чертеже.

При передаче или синхронизации неуказанной шероховатости необходимо учитывать следующие особенности:

– передача неуказанной шероховатости осуществляется из модели, с которой связана основная надпись;

– если на момент создания ассоциативного вида в чертеже присутствовала неуказанная шероховатость, она изменяет свое значение;

– если неуказанная шероховатость в модели не задана или удалена, значения параметров шероховатости, заданной в чертеже, не меняются.

Неуказанная шероховатость передается из модели в чертеж вне зависимости от того, включено или отключено ее отображение в модели.


3.7.3.11. Передача слоев из модели в чертеж

Слои, имеющиеся в модели, могут быть переданы в ассоциативный вид этой модели. При этом на каждом слое размещаются проекции тех объектов, которые находятся на соответствующем слое модели. Кроме слоев передаются группы слоев и фильтры слоев, если они созданы в модели. Подробно о слоях в модели см. раздел 2.15.14.

Чтобы слой были передан из модели в ассоциативный чертеж, необходимо:

1. Разрешить проецирование слоя модели в чертеж. Для этого свойство слоя Проецировать в чертеж должно иметь значение Разрешено. Это умолчательное значение для всех слоев, создаваемых в модели вручную. Для просмотра и изменения состояний слоев в модели служит Менеджер документа (см. раздел 2.15.14.2).

2. Активизировать переключатель Слои на Панели свойств при создании стандартного или произвольного вида (см. разделы 3.7.2.1 и 3.7.2.2).

Переключатель Слои доступен также при создании видов По стрелке, Разреза/Сечения и Проекционного. Его умолчательное состояние в этих командах соответствует состоянию при создании опорного вида. При необходимости вы можете изменить состояние переключателя Слои.

Если для какого-либо слоя модели отключено проецирование (свойство Проецировать в чертеж имеет значение Запрещено), то вне зависимости от состояния переключателя Слои проекции объектов этого слоя отсутствуют в чертеже.

Имена слоев, образовавшихся в чертеже в результате проецирования модели, начинаются с префикса «(с)».

На проекционном слое можно строить новые объекты. Объекты-проекции можно переносить с исходного слоя на любой другой слой в чертеже.

При работе со слоями, полученными из модели, необходимо учитывать следующие особенности:

– свойства слоев передаются в чертеж из модели следующим образом:

• свойства Видимость и Цвет слоев модели полностью соответствуют аналогичным свойствам слоев в чертеже,

• свойству Редактирование (разрешено/запрещено) слоя в модели соответствует свойство Активность (активный/фоновый) слоя в чертеже,

– значения свойств слоев, переданных из модели, можно менять в чертеже,

– изменение свойств существующих слоев не передается из модели в чертеж,

– слои, переданные из модели, нельзя удалить из чертежа или переименовать,

– новый слой передается из модели в чертеж при условии, что этот слой в модели не пуст,

– удаление слоя из модели приводит к автоматическому удалению соответствующего слоя из ассоциативного вида; при этом:

• проекции объектов модели, лежавших на удаленном слое, удаляются вне зависимости от того, на каком слое они находились в чертеже,

• если на удаляемом проекционном слое лежит объект, принадлежащий в модели другому слою, то он автоматически переносится на «свой» слой,

• если на проекционном слое находятся объекты, не являющиеся проекционными, то они автоматически переносятся на системный слой вида чертежа.


3.7.3.12. Надпись вида зеркального исполнения

При создании ассоциативного чертежа модели, содержащей зеркальное исполнение, вы можете добавить ассоциативный вид этого исполнения в чертеж. При этом в чертеже автоматически создаются надписи видов зеркального исполнения и исполнения, которое является исходным для него (рис. 3.7.13).

Рис. 3.7.13. Ассоциативные виды исходного и зеркального исполнений модели

Условия создания надписей:

– чертеж содержит ассоциативные виды исходного и зеркального исполнений (надписи создаются при добавлении одного из этих видов, если другой уже имеется в чертеже),

– чертеж не содержит ассоциативных видов других моделей и других исполнений этой же модели,

– при настройке параметров вида чертежа на вкладке Надпись диалога Вид включена опция Создавать надписи при вставке ассоциативного вида зеркального исполнения (см. раздел 9.2.6.19.1).

Если ассоциативный вид одного из исполнений (исходного или зеркального) уже содержит надпись вида, то при добавлении ассоциативного вида другого исполнения имеющаяся надпись будет дополнена.

Надпись ассоциативного вида зеркального исполнения формируется в соответствии с шаблоном. Данный шаблон определяется настройкой и при необходимости может быть изменен (см. раздел 9.2.6.19.1).

Надпись ассоциативного вида исходного исполнения не настраивается. Она содержит ссылку на обозначение исполнения модели — источника вида. Код документа, входящий в обозначение, в ссылку не включается.

Обе надписи могут содержать другие элементы, например, знак «повернуто», масштаб вида, угол поворота и т.п. Это зависит от настройки параметров надписи (см. раздел 3.7.1.3.4).

В дальнейшем вы можете отредактировать или удалить надпись вида, созданную автоматически, как обычную надпись вида.

При удалении надписи одного из видов или самого вида вместе с надписью надпись второго вида не удаляется.

Обратите внимание на то, что описанные выше надписи видов могут быть добавлены в чертеж только автоматически. Создать их вручную нельзя.

Если надпись одного из видов была отредактирована или удалена, то для восстановления надписи необходимо заново создать вид.


3.7.3.13. Разрушение ассоциативных связей

Ассоциативные виды постоянно сохраняют связь с моделями, изображения которых в них содержатся. Благодаря этому любое изменение модели передается в ее вид (виды). По этой же причине ручное редактирование геометрии в ассоциативных видах невозможно.

При необходимости ассоциативная связь вида с моделью может быть разрушена. Для этого служит команда Разрушить вид из контекстного меню на виде в Дереве чертежа. Можно также воспользоваться командой Разрушить из меню Редактор.

После разрушения ассоциативный вид превращается в набор геометрических объектов (отрезков, дуг и т.п.) и становится обычным пользовательским видом чертежа КОМПАС-3D.

Редактирование изображения в разрушенном виде возможно любыми доступными в системе способами: масштабирование, деформация, редактирование с помощью «характерных точек» и др. О способах редактирования геометрических объектов см. раздел 3.5.

При разрушении вида, являющегося опорным для построения проекционных видов, эти виды превращаются в произвольные. Другими словами, связь проекционных видов с опорным разрушается, а с моделью — сохраняется.

При разрушении вида, являющегося опорным для вида по стрелке и видов, содержащих выносные элементы или разрезы (сечения), эти виды разрушаются. Они разрушаются и при разрушении соответствующих им обозначений.

Разрушение ассоциативных видов может быть применено на этапе оформления чертежей или по окончании работы над ними, когда связь с моделью уже несущественна. Чертеж с разрушенными ассоциативными связями требует меньше машинных ресурсов, он быстрее загружается, перестраивается и т.п.

Если разрушение ассоциативного вида произошло по ошибке, то для восстановления предыдущего состояния документа следует нажать кнопку Отменить на панели Стандартная.


3.8. Вставки видов и фрагментов. Макроэлементы

В этом разделе:

3.8.1. Общие сведения о вставках

3.8.1.1. Термины и определения

3.8.1.2. Фрагменты КОМПАС-3D

3.8.1.3. Способы вставки

3.8.1.4. Параметры вставки

3.8.1.5. Управление вставками

3.8.1.5.1. Команды редактирования объектов, применимые к вставкам

3.8.1.5.2. Работа со слоями вставки

3.8.1.6. Менеджер вставок видов и фрагментов

3.8.1.7. Приемы работы со вставками в чертеже

3.8.1.7.1. Вставки видов и фрагментов в Дереве чертежа

3.8.1.7.2. Вставки видов в Менеджере документа

3.8.2. Вставка фрагментов

3.8.2.1. Вставка внешнего фрагмента

3.8.2.1.1. Вставка параметрического фрагмента

3.8.2.2. Создание и вставка локального фрагмента

3.8.3. Вставка видов

3.8.3.1. Порядок выполнения вставки

3.8.3.2. Свойства вставок видов

3.8.4. Редактирование вставок

3.8.4.1. Редактирование содержимого вставки

3.8.4.2. Редактирование параметров вставки

3.8.4.3. Замена источника

3.8.4.4. Обновление вставок

3.8.4.5. Удаление вставок

3.8.5. Макроэлементы

3.8.5.1. Создание макроэлемента

3.8.5.2. Действия с макроэлементами

3.8.5.3. Линия-выноска объекта

3.8.5.3.1. Создание линии-выноски

3.8.5.3.2. Редактирование объектов и удаление линии-выноски

3.8.5.4. Режим редактирования макроэлемента

3.8.5.5. Добавление объектов в макроэлемент

3.8.5.6. Задание характерных точек

3.8.5.6.1. Изменение положения характерной точки относительно макроэлемента

3.8.5.6.2. Использование характерной точки макроэлемента

3.8.5.7. Отображение макроэлементов в Дереве чертежа

3.8.5.8. Разрушение макроэлемента


3.8.1. Общие сведения о вставках

3.8. Вставки видов и фрагментов. Макроэлементы

3.8.1. Общие сведения о вставках

При работе с графическими документами КОМПАС-3D вы можете вставлять в них изображения, созданные ранее. Доступно несколько различных способов вставки (см. раздел 3.8.1.3).

– Во фрагменты можно вставлять изображения, находящиеся в других фрагментах.

– В чертежи можно вставлять изображения, находящиеся во фрагментах или в видах других чертежей (о видах чертежа см. раздел 3.6.1.2).

Фрагменты и чертежи можно также вставлять в текстовые документы КОМПАС-3D. Об этом рассказано в разделе 4.1.2.11.8.

Команды вставки изображений сгруппированы в меню Вставка, а кнопки вызова команд — на панели Вставки и макроэлементы (рис. 3.8.1).

Рис. 3.8.1. Панель Вставки и макроэлементы

Вставленный объект может быть дополнен линиями-выносками, которые становятся его частью. Такой объект воспринимается системой (выделяется, перемещается, удаляется) как единое целое.

Кнопка вызова команды Линия-выноска объекта находится на панели Вставки и макроэлементы. О добавлении линии-выноски к объектам рассказано в разделе 3.8.5.3.

В этом разделе:

3.8.1.1. Термины и определения

3.8.1.2. Фрагменты КОМПАС-3D

3.8.1.3. Способы вставки

3.8.1.4. Параметры вставки

3.8.1.5. Управление вставками

3.8.1.5.1. Команды редактирования объектов, применимые к вставкам

3.8.1.5.2. Работа со слоями вставки

3.8.1.6. Менеджер вставок видов и фрагментов

3.8.1.7. Приемы работы со вставками в чертеже

3.8.1.7.1. Вставки видов и фрагментов в Дереве чертежа

3.8.1.7.2. Вставки видов в Менеджере документа


3.8.1.1. Термины и определения

Вставка — тип объекта графического документа, предназначенный для отображения в этом документе изображения из другого графического документа или локального фрагмента.

Локальный фрагмент — фрагмент, созданный и хранящийся внутри другого графического документа.

Документ-владелец — документ, содержащий вставку.

Источник вставки — документ, в котором было создано и хранится изображение, используемое для вставки.

Вид-владелец — вид чертежа-владельца, содержащий вставку вида из другого чертежа.

Вид-источник — вид чертежа-источника, изображение из которого вставлено в вид-владелец.

Экземпляр вставки — вставка, содержащая изображение из конкретного источника. Документ может содержать несколько экземпляров одной и той же вставки, т.е. изображений, вставленных из одного и того же вида или фрагмента. Экземпляры могут отличаться друг от друга параметрами вставки.

Вложенная вставка — вставка, имеющаяся в источнике данной вставки.


3.8.1.2. Фрагменты КОМПАС-3D

За время своей профессиональной деятельности каждый конструктор накапливает множество типовых решений, которые не оформляются в виде законченного и официально утверждаемого чертежа. Это могут быть различные проработки, эскизы, черновики и так далее. Для их хранения в КОМПАС-3D предусмотрен специальный тип графического документа — фрагмент. Файлы фрагментов имеют расширение frw.

Главным отличием фрагмента от чертежа является отсутствие формата, основной надписи, обозначения шероховатости неуказанных поверхностей и технических требований. Кроме того, во фрагменте невозможно создать несколько различных видов. Можно сказать, что фрагмент аналогичен системному (нулевому) виду чертежа.

Если вставка фрагментов в графические документы производится часто, то для удобства хранения и поиска фрагментов можно использовать библиотеки фрагментов (см. раздел 11.3.2).

При работе с любым графическим документом возможно создание локальных фрагментов. Эти фрагменты хранятся внутри графического документа и могут многократно в нем использоваться (см. раздел 3.8.2.2).


3.8.1.3. Способы вставки

КОМПАС-3D обеспечивает три способа вставки видов и фрагментов в другой документ. Эти способы представлены в таблице 3.8.1.

Табл. 3.8.1. Способы вставки фрагментов и видов

Способ вставки

Описание

Взять в документ

Содержимое фрагмента или вида копируется в документ и хранится там как единое целое. Связь с файлом-источником не сохраняется, за исключением информации о его имени и полном пути к файлу.

Изображение, взятое в документ, можно обновить, т.е. получить заново из файла-источника. Для этого необходимо, чтобы файл-источник размещался по пути, записанном в документе-владельце.

При передаче документа, содержащего взятые вставки, на другое рабочее место передача файлов-источников вставок не требуется.

Взятые в документ фрагменты (но не виды) можно редактировать внутри этого документа. Изменения будут переданы во все вставки этого фрагмента внутри документа-владельца, но не во фрагмент-источник.

Внешняя ссылка

В документе-владельце формируется ссылка на файл-источник без вставки содержащихся в нем объектов. Поэтому при редактировании файла-источника будут обновляться и все сделанные вставки этого источника. Данный способ вставки удобно использовать, когда хранящееся в источнике изображение детали или узла используется сразу в нескольких различных документах, и модификация изображения должна приводить к автоматическому изменению этих документов (обновление документа-владельца происходит при его активизации или открытии). Благодаря этому отпадает необходимость в редактировании каждого документа при изменении общей для них детали или узла.

При передаче документа, содержащего внешние ссылки, на другое рабочее место необходима передача файлов-источников вставок.

Россыпью

Объекты, находящиеся во фрагменте или виде, копируются в документ, а всякая связь между этими объектами и файлом-источником теряется.

Если источники вставок, сделанных внешней ссылкой, находятся на других рабочих местах, убедитесь, что в диалоге установки прав доступа к файлам включен контроль за изменением файлов. Диалог вызывается командой Сервис — Параметры... — Система — Файлы — Установка прав доступа.


3.8.1.4. Параметры вставки

После вызова команды вставки фрагмента или вида на Панели свойств появляются элементы управления вставкой. Эти элементы представлены в таблице 3.8.2.

Табл. 3.8.2. Элементы управления вставкой фрагмента

Элемент

Описание

Файл-источник

Полное имя файла-источника вставки.

Выбрать другой источник вставки

Кнопка, позволяющая указать другой файл в качестве источника вставки. После ее нажатия на экране появляется диалог выбора файла.

Библиотека

Только для вставки фрагмента из библиотеки. Панель, позволяющая выбрать фрагмент из библиотеки фрагментов. Содержит название библиотеки и список ее разделов. Изображение, содержащееся в выбранном фрагменте, отображается в окне панели и на фантоме в окне документа.

Вид

Только для вставки вида.

Список, позволяющий выбрать вид-источник. Содержит имена и номера видов чертежа-источника.

Изображение, содержащееся в выбранном виде-источнике, показывается на фантоме в окне документа.

Способ вставки

Группа переключателей, позволяющая указать способ вставки фрагмента или вида (о способах вставки см. раздел 3.8.1.3).

Имя вставки

Поле для ввода имени вставки. Это имя отображается в Менеджере вставок видов и фрагментов, а при работе с чертежом — также в Дереве чертежа и в Менеджере документа.

По умолчанию в качестве имени вставки предлагается полный путь к файлу-источнику.

Все экземпляры одной и той же вставки имеют одинаковые имена. Если изменить имя какого-либо одного экземпляра вставки, то оно будет присвоено всем остальным экземплярам.

Режим 1

Только для вставки фрагмента.

Группа переключателей, управляющая размещением объектов многослойного фрагмента.

– Если активен переключатель На текущий слой, то все изображение будет расположено на одном (текущем) слое фрагмента или вида чертежа.

– Если активен переключатель На слои-источники, то объекты вставляемого фрагмента будут расположены во фрагменте или в виде на слоях с теми же номерами, как во вставляемом фрагменте. Если в документе уже есть нужные слои, то вставляемые объекты размещаются на них; состояния слоев не изменяются (даже если они отличаются от состояний слоев во вставляемом фрагменте). Недостающие слои создаются, причем в том же состоянии, что и соответствующие слои во вставляемом фрагменте.

Работа со слоями подробно рассмотрена разделе 3.6.6.

Выносные линии

Группа переключателей, позволяющая указать, требуется ли масштабировать имеющиеся во вставке выносные линии и линии-выноски размеров.

– Если активен переключатель Не масштабировать, то длины выносных линий и линий-выносок остаются такими же, как в файле-источнике.

– Если активен переключатель Масштабировать, то длины выносных линий и линий-выносок изменяются в соответствии с текущим масштабом вида-владельца и/или с масштабом, заданным для вставки фрагмента.

Сделанная настройка сохраняется во вставке и в дальнейшем учитывается при изменении масштаба вида-владельца или масштаба вставки (включение/отключение масштабирования выносных линий при выполнении этих операций игнорируется).

Базовая точка

Поля координат базовой точки вставки.

Угол поворота

Поле угла поворота вставки.

Масштаб

Только для вставки фрагмента.

Поле масштаба вставки фрагмента.

В тонких линиях

Только для вставки вида.

Опция, позволяющая отображать вместо основных и утолщенных линий вставки соответствующие тонкие линии. Если она включена, то линии вставки отображаются следующим образом:

– основные и утолщенные — тонкими;

– штриховые основные — штриховыми;

– осевые основные — осевыми.

Указанная замена производится только для системных стилей линий. Линии пользовательских стилей сохраняют свой вид вне зависимости от состояния опции В тонких линиях.

Как в документе

Только для вставки вида.

Опция, позволяющая отображать объекты вставки с умолчательными параметрами, т.е. параметрами, заданными при настройке документа-владельца.

Если эта опция включена, то отображение объектов изменяется следующим образом:

– параметры, которые нельзя изменить при создании объекта (например, длина стрелок размеров), приводятся к умолчательным,

– параметры, которые можно изменить при создании объекта (например, высота шрифта размерной надписи), приводятся к умолчательным только в том случае, если они не редактировались.


3.8.1.5. Управление вставками

Такие приемы работы со вставками, как редактирование содержимого, редактирование параметров, смена источника, удаление, можно выполнять с помощью команд контекстного меню вставки, выделенной в окне документа (см. разделы 3.8.4.1–3.8.4.5). В чертеже эти команды доступны также в контекстном меню вставки, выделенной в Дереве чертежа (см. раздел 3.8.1.7.1).

Все вышеназванные приемы (кроме редактирования параметров вставки), а также дополнительные возможности работы со вставками — переименование, изменение способа создания, повторная вставка, создание и вставка локальных фрагментов доступны в Менеджере вставок видов и фрагментов. Он описан в разделе 3.8.1.6, а порядок работы при создании и вставке локального фрагмента — в разделе 3.8.2.2.

В Менеджере вставок видов и фрагментов вставки группируются по типам и способам вставки; операции, выполненные над вставкой, применяются сразу ко всем имеющимся в документе экземплярам этой вставки.

Вставки различных видов, источником которых является один и тот же чертеж, отображаются в Менеджере вставок видов и фрагментов как одна и та же вставка.

В окне документа можно выделить отдельный экземпляр вставки и работать именно с этим экземпляром.

Таким образом, Менеджер вставок видов и фрагментов целесообразнее использовать в случаях, когда нужно изменить все экземпляры отдельной вставки или группы вставок, а контекстное меню вставки — когда нужно изменить конкретный экземпляр.

В документе можно также выделить несколько экземпляров одной и той же или различных вставок и работать сразу со всеми выделенными объектами.

В этом разделе:

3.8.1.5.1. Команды редактирования объектов, применимые к вставкам

3.8.1.5.2. Работа со слоями вставки


3.8.1.5.1. Команды редактирования объектов, применимые к вставкам

К вставкам можно применять следующие команды редактирования:

– Сдвиг (см. раздел 3.5.2),

– Поворот (см. раздел 3.5.4.1),

– Масштабирование (см. раздел 3.5.4.2),

– Симметрия (см. раздел 3.5.4.3),

– Копирование (см. раздел 3.5.3).

Обратите внимание на то, что результатом выполнения двух последних команд является создание в документе новых экземпляров вставки.

Сдвиг и копирование вставки возможны также с помощью мыши (см. раздел 3.5.1.1).

При необходимости вставку можно преобразовать в набор отдельных объектов, не связанных между собой и с файлом-источником. Для этого выделите вставку и вызовите команду Редактор — Разрушить.


3.8.1.5.2. Работа со слоями вставки

В документе-владельце присутствуют все объекты документа-источника — как находящиеся на видимых слоях в источнике, так и находящиеся на погашенных. Отображение объектов в документе-владельце зависит от состояния слоев в этом документе и не зависит от состояния слоев в документе-источнике.

– Управление отображением слоев вставки вида описано в разделе 3.8.1.7.2.

– Управление отображением слоев вставки фрагмента производится обычным образом — путем изменения значения свойства видимость у соответствующего слоя в документе-владельце (см. раздел 3.6.6.5). Вставка фрагмента должна быть выполнена на слои-источники (см. табл. 3.8.2).

Чтобы изменение видимости слоя с объектами вставки фрагмента не влияло на остальное изображение документа, нужно, чтобы на этом слое не размещалось никаких других объектов, кроме объектов вставки. Этого проще всего достичь следующим образом. До выполнения вставки следует присвоить слоям в документе-источнике номера, не совпадающие с номерами слоев фрагмента или вида, в который будет произведена вставка. В этом случае в результате вставки в документе-владельце будут созданы новые слои для размещения объектов вставки, причем состояние этих слоев будет таким же, как в документе-источнике.


3.8.1.6. Менеджер вставок видов и фрагментов

Для отображения Менеджера вставок видов и фрагментов на экране (рис. 3.8.2) нажмите кнопку Менеджер вставок видов и фрагментов на панели Вставки и макроэлементы либо выберите его название из меню Редактор или контекстного меню на любом свободном месте документа.

Рис. 3.8.2. Менеджер вставок видов и фрагментов

Менеджер вставок видов и фрагментов служит для выполнения различных операций над вставками. Сделанные изменения применяются ко всем экземплярам вставки, над которой выполнена операция.

Менеджер вставок видов и фрагментов содержит:

– список типов вставок,

– список вставок выбранного типа,

– список свойств выбранной вставки,

– инструментальную панель для управления вставками.

Описание перечисленных элементов представлено в таблице 3.8.3.

Табл. 3.8.3. Элементы управления Менеджера вставок видов и фрагментов

Элемент

Описание

Список типов вставок

Служит для отображения типов вставок, имеющихся в документе. В зависимости от типа документа и наличия вставок может содержать следующие разделы и подразделы:

– Вставки фрагментов

– Локальные

– Взятые в документ

– Внешней ссылкой

– Вставки видов

– Взятые в документ

– Внешней ссылкой

Список вставок

Служит для отображения вставок того типа, который выделен в Списке типов вставок.

Представляет собой таблицу из двух колонок. В колонке Имя отображаются имена вставок, а в колонке Количество — количества экземпляров каждой вставки. Для сортировки вставок по имени или по количеству щелкните мышью по заголовку соответствующего столбца.

Для изменения имени вставки дважды щелкните в нужной ячейке.

При выделении строки или нескольких строк в списке все соответствующие экземпляры вставок выделяются в окне документа.

Список свойств

Служит для отображения свойств вставки, выделенной в Списке вставок.

Представляет собой таблицу из двух колонок. В колонке Свойство перечислены названия свойств, а в колонке Значение — их значения.

Перечитать документ-источник

Служит для принудительного обновления изображения во вставках, взятых в документ. Вставки, подлежащие обновлению, необходимо выделить в Списке вставок.

После нажатия этой кнопки имеющиеся во вставках изображения заменяются полученными из файлов-источников.

Обновление изображения возможно, если файл-источник вставки размещается по пути, записанному во вставке (этот путь отображается как значение свойства Файл-источник).

Взять в документ

Служит для преобразования вставок, сделанных внешней ссылкой, во вставки, взятые в документ. Вставки, подлежащие преобразованию, необходимо выделить в Списке вставок.

Преобразовать во внешнюю ссылку

Служит для преобразования вставок, взятых в документ, во вставки, сделанные внешней ссылкой. Вставки, подлежащие преобразованию, необходимо выделить в Списке вставок.

Рассыпать

Служит для разрушения вставок любого типа. Вставки, подлежащие преобразованию, необходимо выделить в Списке вставок.

После нажатия этой кнопки связь вставки с ее файлом-источником удаляется, а изображение превращается набор объектов, каждый из которых можно редактировать по отдельности.

Удалить

Служит для удаления вставок. Вставки, подлежащие удалению, необходимо выделить в Списке вставок.

После нажатия кнопки все экземпляры выделенных вставок удаляются из документа.

Локальные фрагменты и вставки, взятые в документ, удаляются из документа-владельца физически (то есть уничтожается их содержимое).

При удалении вставок, сделанных внешней ссылкой, удаляются только ссылки, а сами файлы-источники на диске остаются неизменными.

Вставить

Служит для создания новых экземпляров уже имеющейся вставки.

Вставку, дополнительные экземпляры которой требуется создать, необходимо выделить в Списке вставок.

После нажатия этой кнопки Менеджер вставок видов и фрагментов закрывается. Запускается процесс, аналогичный созданию вставки1.

Создать фрагмент

Служит для создания в текущем графическом документе нового локального фрагмента (см. раздел 3.8.2.2).

Изменить источник

Служит для смены файла-источника вставки.

Вставки, источник которых требуется сменить, необходимо выделить в Списке вставок.

После нажатия этой кнопки Менеджер вставок видов и фрагментов закрывается и на экране появляется стандартный диалог выбора файла, в котором требуется указать новый источник для выделенных вставок.

Редактировать источник

Служит для редактирования содержимого вставки.

Вставку, подлежащую редактированию, необходимо выделить в Списке вставок.

После нажатия этой кнопки Менеджер вставок видов и фрагментов закрывается. Запускается такой же процесс редактирования, как и после вызова команды Редактировать источник (см. раздел 3.8.4.1).

Редактирование источника доступно для вставок видов, сделанных внешней ссылкой, и для всех вставок фрагментов.
  1. В процессе создания вставки, запущенном из Менеджера вставок видов и фрагментов, невозможно изменение файла-источника и способа вставки.


3.8.1.7. Приемы работы со вставками в чертеже

При работе с чертежами доступны такие средства навигации в структуре документа, как Дерево чертежа и Менеджер документа. Эти средства предоставляют дополнительные возможности работы со вставками.

В этом разделе:

3.8.1.7.1. Вставки видов и фрагментов в Дереве чертежа

3.8.1.7.2. Вставки видов в Менеджере документа


3.8.1.7.1. Вставки видов и фрагментов в Дереве чертежа

В Дереве чертежа (см. раздел 3.7.1.1) вставки видов и фрагментов объединяются в группы Вставки видов (хN) и Вставки фрагментов (хN1), которые подчиняются виду, содержащему вставки (рис. 3.8.3). N и N1 в названиях групп — числа, обозначающие количества вставок видов и фрагментов соответственно.

Рис. 3.8.3. Отображение вставок видов и фрагментов в Дереве чертежа

Названия вставок в Дереве чертежа формируются по следующему шаблону:

(Х) + имя + (N), где

– Х — буква, обозначающая способ вставки:

• «л» — вставка локального фрагмента,

• «с» — вставка, сделанная внешней ссылкой,

• отсутствие буквы — вставка, взятая в документ,

– имя — имя вставки;

– N — номер экземпляра вставки; экземпляры нумеруются в пределах вида-владельца; если экземпляр один, то номер не отображается.

При выделении вставки в Дереве она выделяется в окне документа.

Контекстное меню выделенной вставки содержит команды управления вставкой.


3.8.1.7.2. Вставки видов в Менеджере документа

В Менеджере документа (см. раздел 3.6.6.2) показываются только вставки видов. В Дереве листов, видов и слоев они отображаются как подчиненные объекты вида-владельца (рис. 3.8.4). В Списке листов, видов и слоев вставки отображаются после слоев вида-владельца.

Рис. 3.8.4. Отображение вставок видов в Менеджере документа

Вставка вида всегда активна, видима и доступна для печати. Изменение состояния вставки невозможно.

Вставку вида нельзя сделать текущей.

Вы можете изменять имя вставки и комментарий к ней в соответствующих колонках Списка листов, видов и слоев.

При выделении в Дереве листов, видов и слоев вставки вида в Списке листов, видов и слоев отображаются слои, составляющие вставку (рис. 3.8.5).

Рис. 3.8.5. Отображение слоев вставки в Менеджере документа

Все слои вставки всегда активны, их невозможно сделать фоновыми.

Ни один из слоев вставки нельзя сделать текущим.

Слои вставки невозможно копировать в другие виды, добавлять в группы, фильтровать.

Вы можете изменять видимость, имя, цвет слоев вставки и комментарии к ним, а также включать/отключать для этих слоев возможность печати. Эти изменения не передаются в вид-источник вставки.

Таким образом, частичное или полное отключение показа/печати объектов вставки в чертеже-владельце возможно только путем погашения слоев вставки. Поэтому при создании вида-источника вставки следует тщательно следить за правильным распределением ее объектов по слоям.

Слои вложенных вставок, т.е. вставок, содержащихся в виде-источнике данной вставки, не отображаются в Менеджере документа при работе с чертежом-владельцем.


3.8.2. Вставка фрагментов

3.8. Вставки видов и фрагментов. Макроэлементы

3.8.2. Вставка фрагментов

Существует два способа вставки фрагментов в графический документ:

– вставка готовых фрагментов из внешних файлов (в том числе из библиотек фрагментов — см. раздел 11.3.2),

– создание и вставка локальных фрагментов.

Эти способы не исключают друг друга, их можно сочетать.

В этом разделе:

3.8.2.1. Вставка внешнего фрагмента

3.8.2.1.1. Вставка параметрического фрагмента

3.8.2.2. Создание и вставка локального фрагмента


3.8.2.1. Вставка внешнего фрагмента

Чтобы вставить в документ изображение, хранящееся во внешнем файле фрагмента или библиотеки фрагментов, вызовите команду Вставить фрагмент. Для вызова команды нажмите кнопку Вставить фрагмент на панели Вставки и макроэлементы или выберите ее название из меню Вставка.

На экране появится диалог, в котором требуется выбрать тип файла (*.frw или *.lfr), задать путь и имя фрагмента или библиотеки фрагментов.

– При выборе фрагмента в поле Файл-источник на вкладке Параметры Панели свойств отображается полное имя выбранного фрагмента. На экране появится фантом изображения, содержащегося в выбранном фрагменте.

– При выборе библиотеки фрагментов на вкладке Параметры присутствует панель Библиотека. Выберите в списке раздел библиотеки, в окне ниже укажите нужный фрагмент в списке фрагментов раздела. Содержащееся во фрагменте изображение отобразится в окне просмотра панели, а его фантом появится на экране.

Настройте параметры вставки требуемым образом (см. табл. 3.8.2).

При вставке параметрического фрагмента можно управлять значениями внешних переменных вставляемого фрагмента. Подробно вставка параметрического фрагмента рассмотрена в разделе 3.8.2.1.1.

– Если автосоздание объектов включено, то изображение фиксируется в документе после задания положения базовой точки.

– Если автосоздание отключено, то для фиксации изображения требуется подтвердить создание объекта.

За один вызов команды вы можете создать несколько вставок фрагмента с различными параметрами.

Вы можете перейти к вставке другого фрагмента, не выходя из команды. Для этого воспользуйтесь кнопкой Выбрать другой источник вставки на Панели свойств.

В этом разделе:

3.8.2.1.1. Вставка параметрического фрагмента


3.8.2.1.1. Вставка параметрического фрагмента

Параметрический фрагмент — фрагмент, содержащий внешние переменные. Подробно о внешних переменных рассказано в разделе 7.1.1.2.2. Напомним, что внешние переменные служат для управления параметрами вставляемого фрагмента без его редактирования «изнутри».

Изменение значений внешних переменных при вставке параметрического фрагмента производится на вкладке Переменные Панели свойств.

Рис. 3.8.6. Пример вкладки Переменные

Эта вкладка содержит перечень внешних переменных вставляемого фрагмента (рис. 3.8.6). Переменные имеют такие значения, какими они были в момент последнего сохранения фрагмента на диске.

Чтобы изменить значение переменной, дважды щелкните мышью в ячейке, где оно отображается. Задайте новое значение и нажмите клавишу <Enter>.

Если значение переменной изменено, в колонке Изменен напротив ее имени отображается «галочка».

Чтобы вернуть какой-либо переменной значение, хранящееся в файле-источнике, щелкните мышью на этой «галочке».

Кнопка Таблица переменных позволяет открыть таблицу переменных вставляемого фрагмента и выбрать новые значения внешних переменных.

После нажатия этой кнопки на экране появляется окно Таблица переменных. Укажите в таблице нужную строку и закройте окно кнопкой ОК. Внешние переменные фрагмента получат значения, записанные в ячейках выбранной строки.

Кнопка Таблица переменных доступна, если таблица переменных, хранящаяся во вставляемом фрагменте, содержит более одной строки. Таблица переменных формируется в файле при его создании или редактировании и хранится в нем. Подробно о таблице переменных рассказано в разделе 7.1.5.4.

Изменения значений переменных немедленно отражаются на фантоме фрагмента в окне документа.

Если параметрический фрагмент вставляется из библиотеки, перечень его внешних переменных находится на вкладке Параметры Панели свойств (в панели Библиотека). На этой же вкладке находится кнопка Таблица переменных для доступа к таблице переменных библиотечного фрагмента.

После того как фрагмент вставлен с определенными значениями переменных, система ожидает выполнения новой вставки. Для нее можно задать новые значения внешних переменных.

Если параметрический фрагмент взят в документ или вставлен ссылкой, то внешние переменные и уравнения, связывающие их с другими переменными, хранятся в самой вставке. Именно благодаря этому в одном документе может быть несколько вставок фрагментов с разными значениями одной и той же переменной — переменные не будут вступать в конфликт, «мешать» друг другу, т.к. каждая из них управляет своим участком изображения.

Если параметрический фрагмент вставлен россыпью, то сразу после вставки его параметры соответствуют указанным значениям внешних переменных. Однако сами переменные и связывающие их уравнения в документ-владелец не передаются.


3.8.2.2. Создание и вставка локального фрагмента

Чтобы создать внутри документа локальный фрагмент, выполните следующие действия.

1. Вызовите команду Создать локальный фрагмент. Для вызова команды нажмите кнопку Создать локальный фрагмент на панели Вставки и макроэлементы.

2. Откроется окно локального фрагмента.

3. Постройте изображение, которое будет храниться в локальном фрагменте.

4. Вызовите команду Файл — Сохранить — В документ-владелец. Локальный фрагмент будет сохранен в своем документе-владельце.

5. В появившемся на экране диалоге введите имя созданного локального фрагмента.

6. Закройте окно локального фрагмента.

Второй способ создания в документе локального фрагмента — использование кнопки Создать фрагмент в Менеджере вставок видов и фрагментов.

Чтобы вставить локальный фрагмент в документ, выполните следующие действия.

1. Вызовите команду Менеджер вставок видов и фрагментов. Для вызова команды нажмите кнопку Менеджер вставок видов и фрагментов на панели Вставки и макроэлементы либо выберите ее название из меню Редактор или контекстного меню на любом свободном месте документа.

2. В Списке типов вставок раскройте раздел Вставки фрагментов — Локальные.

3. В Списке вставок выделите имя локального фрагмента, который требуется вставить в документ.

4. Нажмите кнопку Вставить.

Дальнейшие действия аналогичны действиям, выполняемым при вставке внешнего фрагмента: необходимо задать параметры вставки на Панели свойств (см. табл. 3.8.2) и указать положение базовой точки.

При вставке локального фрагмента невозможно изменить источник и указать способ вставки.


3.8.3. Вставка видов

3.8. Вставки видов и фрагментов. Макроэлементы

3.8.3. Вставка видов

В этом разделе:

3.8.3.1. Порядок выполнения вставки

3.8.3.2. Свойства вставок видов


3.8.3.1. Порядок выполнения вставки

Чтобы вставить в чертеж изображение, находящееся в виде другого чертежа, вызовите команду Вставить изображение из вида другого чертежа. Для вызова команды нажмите кнопку Вставить изображение из вида другого чертежа на панели Вставки и макроэлементы или выберите ее название из меню Вставка.

На экране появится диалог, в котором требуется задать путь и имя чертежа-источника вставки.

После выбора чертежа на экране появляется фантом изображения, находящегося в виде-источнике — виде, который выбран в списке Вид на Панели свойств.

В фантоме показываются все слои вида-источника, в том числе погашенные. После создания вставки погашенные слои перестанут быть видны.

При необходимости смените вид-источник и настройте остальные параметры вставки, используя элементы управления на Панели свойств (см. табл. 3.8.2).

– Если автосоздание объектов включено, то изображение фиксируется в документе после задания положения базовой точки.

– Если автосоздание отключено, то для фиксации изображения требуется подтвердить создание объекта.

За один вызов команды вы можете создать несколько вставок одного и того же или различных видов из чертежа-источника.

Вы можете перейти к вставке вида из другого чертежа, не выходя из команды. Для этого воспользуйтесь кнопкой Выбрать другой источник вставки на Панели свойств.

Вставка вида располагается в том виде чертежа, который был текущим во время ее создания. Этот вид становится видом-владельцем вставки.


3.8.3.2. Свойства вставок видов

При работе со вставками видов необходимо иметь в виду следующие их особенности.

– Вставка вида не лежит ни на одном из слоев вида-владельца. Ее нельзя погасить отдельно от вида-владельца.

– В документе-владельце доступно управление слоями вставки. Для этого используется Менеджер документа (см. раздел 3.8.1.7.2).

– Свойства объектов вставки:

• могут использоваться при построении других объектов (для привязки, в качестве границ и т.п.);

• не доступны для редактирования;

• не могут служить источником ссылок;

• не могут участвовать в формировании параметрических и ассоциативных связей.

– Сразу после создания вставки ее масштаб совпадает с масштабом вида-владельца. Он может отличаться от масштаба вида-источника и автоматически изменяется при изменении масштаба вида-владельца.

– Если вид-источник — ассоциативный, то его вставка не имеет непосредственной связи с моделью. Поэтому, если необходимо передать в вид-владелец изменения изображения, вызванные редактированием модели, необходимо сначала перестроить вид-источник, а затем обновить вид-владелец.

– Объекты спецификации, с которыми связаны объекты вида-источника, не добавляются к объектам спецификации чертежа-владельца.

– Вставка вида может входить в состав группы.

– Вставка вида не может входить в состав макроэлемента.


3.8.4. Редактирование вставок

3.8. Вставки видов и фрагментов. Макроэлементы

3.8.4. Редактирование вставок

Если вставка выполнялась россыпью, то вставленные объекты не являются единым целым (т.е. вставка как объект отсутствует). Эти объекты могут редактироваться по отдельности с помощью любых способов, приемов и команд, рассмотренных в разделе 3.5.

В настоящем разделе рассмотрены возможности редактирования вставок, сделанных внешней ссылкой, взятых в документ, а также локальных фрагментов.

В этом разделе:

3.8.4.1. Редактирование содержимого вставки

3.8.4.2. Редактирование параметров вставки

3.8.4.3. Замена источника

3.8.4.4. Обновление вставок

3.8.4.5. Удаление вставок


3.8.4.1. Редактирование содержимого вставки

Редактирование содержимого вставки (составляющих ее геометрических объектов) возможно для всех типов вставок фрагментов и для вставок видов, сделанных внешней ссылкой.

Чтобы отредактировать содержимое вставки, выделите его и вызовите из контекстного меню команду Редактировать источник.

В КОМПАС-3D откроется новое окно, в которое будет загружен для редактирования внешний файл-источник — чертеж или фрагмент (если была сделана вставка внешней ссылкой), либо набор объектов вставки (если фрагмент был взят в документ), либо хранящийся в документе локальный фрагмент (если фрагмент создавался непосредственно в документе).

Отредактируйте изображение во фрагменте или в виде-источнике вставки и сохраните документ.

Если редактируется локальный или взятый в документ фрагмент, команда Файл — Сохранить содержит подменю, команды которого представлены в таблице 3.8.4.

Табл. 3.8.4. Специальные команды сохранения фрагментов
Команда | Описание
Сохранить — В документ- владелец | Позволяет сохранить только редактируемый фрагмент с автоматическим обновлением (но без сохранения) документа-владельца.
Сохранить — С владельцем в файл | Позволяет одновременно сохранить редактируемый фрагмент и документ-владелец. В том случае, если документ-владелец сохраняется впервые, на экране появится диалог для ввода его имени.

После сохранения фрагмента закройте его окно и вернитесь в документ-владелец. Внесенные во фрагмент изменения сразу же будут отражены во всех его вставках, имеющихся в документе-владельце.

Доступ к содержимому вставки, сделанной внешней ссылкой, возможен и без обращения к документу-владельцу. Файл-источник такой вставки можно открыть обычным способом и отредактировать. В этом случае обновление документа-владельца будет выполнено автоматически при его открытии, а если он уже был открыт, то при его активизации. Таким образом, файл-источник и документ-владелец могут открываться и редактироваться не одновременно, однако соответствие между ними всегда будет контролироваться.


3.8.4.2. Редактирование параметров вставки

Параметры вставки — параметры, заданные на Панели свойств во время создания вставки (см. табл. 3.8.2). Некоторые из них можно изменить после создания вставки.

Для этого следует дважды щелкнуть мышью по вставке или, выделив ее, вызвать команду Редактировать из контекстного меню либо из меню Редактор. На Панели свойств появятся те же вкладки, что и при создании данной вставки.

Вы можете изменить любые параметры вставки, кроме пути к файлу-источнику и способа вставки. Для вставки параметрического фрагмента возможно также задание новых значений переменных.

Для изменения пути к файлу-источнику (фактически — для смены источника) воспользуйтесь командой Изменить источник (см. раздел 3.8.4.3).

Для изменения способа вставки воспользуйтесь Менеджером вставок видов и фрагментов (см. раздел 3.8.1.6).

Каждое внесенное изменение отражается на фантоме вставки в окне документа. Завершив редактирование, нажмите кнопку Создать объект.


3.8.4.3. Замена источника

Чтобы заменить источник вставки, выделите ее и выберите из контекстного меню команду Изменить источник…

После вызова команды на экране появится стандартный диалог выбора файлов, в котором нужно указать документ, который будет источником вставки.

После этого запустится процесс создания вставки. Параметры (масштаб, угол поворота и др.) вставки, источник которой изменился, остаются прежними. Эти параметры отображаются в полях Панели свойств. При необходимости вы можете изменить их. Завершив настройку, нажмите кнопку Создать объект на Панели специального управления.

Аналогичным образом вы можете изменить источник для нескольких вставок, т.е. заменить все выделенные вставки фрагментов или видов (даже если файлы-источники вставок различны) каким-либо одним фрагментом или видом. Для этого выделите в документе вставки, источник которых требуется изменить, и выберите из контекстного меню команду Изменить источник… — Для вставок видов/Для вставок фрагментов.

После указания нового файла-источника он будет вставлен в документ вместо каждой из выделенных вставок с сохранением параметров вставок. Чтобы подтвердить смену источника вставок, нажмите кнопку Создать объект.


3.8.4.4. Обновление вставок

Обновление вставки — передача изменений из источника вставки в документ-владелец.

Для обновления вставок необходимо, чтобы изменения в источнике вставки были сохранены.

– Если вставка выполнена внешней ссылкой, то ее обновление производится автоматически при открытии или активизации документа-владельца.

– Если вставка взята в документ, то для ее обновления необходимо перечитать источник. Для этого служит кнопка Перечитать в Менеджере вставок видов и фрагментов (см. табл. 3.8.3).


3.8.4.5. Удаление вставок

Если какие-либо из вставок больше не нужны, вы можете удалить их из документа. Для этого выделите вставки в окне документа и нажмите клавишу <Delete>.

Так как локальный фрагмент хранится внутри документа, то он остается там даже при удалении всех его вставок. В дальнейшем локальный фрагмент можно вставить снова (см. раздел 3.8.2.2).

Если необходимо удалить из документа не вставку локального фрагмента, а сам локальный фрагмент, используйте Менеджер вставок видов и фрагментов (см. раздел 3.8.1.6). С его помощью можно удалить также любую другую вставку, в том числе не отображающуюся в документе — например, вставку вида, все слои которой погашены, или сделанную внешней ссылкой вставку, источник которой не найден.


3.8.5. Макроэлементы

3.8. Вставки видов и фрагментов. Макроэлементы

3.8.5. Макроэлементы

При проектировании изделий конструктор использует большое количество стандартных деталей или узлов. Это различные крепежные детали (болты, гайки, винты, шайбы), подшипники, выключатели, разъемы и так далее.

Во время редактирования чертежа существует необходимость в выделении, перемещении, повороте таких деталей сразу целиком, поскольку действия с каждым объектом в отдельности будут длительными и неудобными. Кроме того, некоторые элементы изображения стандартной детали не должны быть доступны для редактирования.

Для этого при работе в КОМПАС-3D различные объекты изображения — геометрические объекты, размеры, штриховки, обозначения и другие — можно объединять в макроэлементы.

Объекты, объединяемые в макроэлемент, должны находиться в одном виде чертежа (о видах см. раздел 3.6.4).

Невозможно включить в макроэлемент объекты ассоциативных видов, сохраняющих связь с моделями.

Объекты в составе макроэлемента нельзя по отдельности выделять, удалять или редактировать (за исключением изменения стиля или созданной в нем линии-выноски). Таким образом, макроэлемент обрабатывается системой как единое целое.

Получить доступ к отдельным объектам, входящим в макроэлемент, можно после его разрушения или при редактировании. При разрушении никакой связи между входившими ранее в макроэлемент объектами не сохраняется. При редактировании макроэлемента можно выполнять с его составляющими различные действия, не прерывая связи, и дополнять макроэлемент новыми объектами.

Изображения стандартных изделий, вставленные из библиотек КОМПАС-3D, являются макроэлементами. Вы можете создать свои собственные прикладные библиотеки макроэлементов. Также вы можете задать макроэлементам свойства (массу, мощность, стоимость погонного метра и т.п.). По свойствам макроэлементов, вставленных в чертеж, могут автоматически формироваться отчеты КОМПАС-3D. Задание свойств описано в разделе 5.1, создание отчетов — в разделе 5.2.

Рис. 3.8.7. Примеры макроэлементов из библиотеки

Кнопки вызова команд для работы с макроэлементами сгруппированы на панели Вставки и макроэлементы (см. рис. 3.8.8). О создании макроэлементов и работе с ними рассказано в разделах 3.8.5.1–3.8.5.8.

Рис. 3.8.8. Панель Вставки и макроэлементы

На панели Вставки и макроэлементы находятся кнопки вызова команд вставки видов и фрагментов. О вставках рассказано в разделах 3.8.1 –3.8.3.

В этом разделе:

3.8.5.1. Создание макроэлемента

3.8.5.2. Действия с макроэлементами

3.8.5.3. Линия-выноска объекта

3.8.5.3.1. Создание линии-выноски

3.8.5.3.2. Редактирование объектов и удаление линии-выноски

3.8.5.4. Режим редактирования макроэлемента

3.8.5.5. Добавление объектов в макроэлемент

3.8.5.6. Задание характерных точек

3.8.5.6.1. Изменение положения характерной точки относительно макроэлемента

3.8.5.6.2. Использование характерной точки макроэлемента

3.8.5.7. Отображение макроэлементов в Дереве чертежа

3.8.5.8. Разрушение макроэлемента


3.8.5.1. Создание макроэлемента

Чтобы объединить объекты в макроэлемент, выполните следующие действия.

1. Выделите все объекты, которые нужно включить в макроэлемент (о выделении объектов см. раздел 3.1.2).

2. Вызовите команду Создать макроэлемент. Для вызова команды нажмите кнопку Создать макроэлемент на панели Вставки и макроэлементы или выберите ее название из меню Сервис.

Если выделены объекты из разных видов, команда будет недоступна.

Если выделенные для включения в макроэлемент объекты находятся на разных слоях, на экране появится диалог, в котором требуется указать тип макроэлемента: многослойный или однослойный.

Пиктограмма макроэлемента появляется в Дереве чертежа (см. рис. 3.8.12).


3.8.5.2. Действия с макроэлементами

С макроэлементами, как и с отдельными объектами, могут выполняться различные действия — копирование в буфер обмена, удаление, сдвиг, поворот, масштабирование и т.д. Макроэлемент воспринимается системой как единое целое.

Перед началом операции необходимо выделить нужный макроэлемент. Для этого следует щелкнуть по нему мышью или выбрать в Дереве чертежа. В окне документа вы можете выделить сразу несколько макроэлементов.

Чтобы выделить сразу все макроэлементы в текущем виде чертежа или во фрагменте, вызовите команду Выделить — По типу, а затем в списке имеющихся объектов укажите Макроэлементы.

После выделения макроэлемента вызовите нужную команду, например, из меню Редактор, и выполните действия, предусмотренные в команде.


3.8.5.3. Линия-выноска объекта

Вы можете создать и добавить к объекту одну или несколько линий-выносок, которые становятся его частью (см. рис. 3.8.9).

Создание и добавление линии-выноски производится командой Линия-выноска объекта.

Объектами, к которым может быть добавлена линия-выноска, являются:

– макроэлементы (в том числе библиотечные),

– вставки фрагментов,

– вставки изображений из видов других чертежей.

Объект с подобной линией-выноской воспринимается системой (выделяется, перемещается, удаляется) как единое целое. При этом линии-выноски могут редактироваться отдельно от своего объекта.

Рис. 3.8.9. Примеры объектов с линиями-выносками

В этом разделе:

3.8.5.3.1. Создание линии-выноски

3.8.5.3.2. Редактирование объектов и удаление линии-выноски


3.8.5.3.1. Создание линии-выноски

Чтобы создать и добавить к объекту линию-выноску, выполните следующие действия.

1. Выделите один объект — макроэлемент или вставку, к которому должна быть добавлена линия-выноска.

2. Вызовите команду Линия-выноска объекта.

Команда может быть вызвана:

– нажатием кнопки Линия-выноска объекта на панели Вставки и макроэлементы;

– из меню Инструменты;

– из контекстного меню объекта в окне документа или в Дереве чертежа.

Для макроэлемента команда также доступна в режиме его редактирования (о режиме редактирования см. раздел 3.8.5.4).

3. Задайте начальную точку первого ответвления.

Задайте точку присоединения линии-выноски к объекту т1.

Точка т1 связывается с объектом: в дальнейшем, при его редактировании она отображается как одна из характерных точек, перемещение которой перемещает весь объект. В некоторых случаях может оказаться удобным совмещение точки присоединения линии-выноски с точкой перемещения объекта (см. рис. 3.8.10). В то же время некоторые библиотечные макроэлементы могут иметь характерные точки для управления размерами. Присоединение линии-выноски к одной из таких точек нежелательно, так как в этом случае она потеряет свою функцию.

Затем задайте начальные точки остальных ответвлений. Их количество не ограничено.

4. Настройте отрисовку ответвлений. Задавайте параметры так же, как для обычной линии-выноски (см. раздел 3.3.7.4.2). Следует учитывать, что при добавлении линии-выноски к объекту на Панели свойств отсутствуют элементы управления для полки и надписи.

На экране отображается фантом создаваемой линии-выноски. Вы можете отредактировать или удалить любое из ее ответвлений, не выходя из команды (см. раздел 3.3.7.4.3).

Чтобы зафиксировать изображение, нажмите кнопку Создать объект.

Чтобы добавить к объекту следующую линию-выноску, вызовите команду Линия-выноска объекта повторно.


3.8.5.3.2. Редактирование объектов и удаление линии-выноски

Редактирование объектов с линией-выноской

При выделении объекта с линией-выноской на нем отображаются характерные точки объекта и линии-выноски (рис. 3.8.10). Вы можете редактировать объект с помощью точек перемещения и поворота, при этом точка присоединения линии-выноски остается связанной с объектом. Сама линия-выноска «ведет себя» так же, как обычная линия-выноска при перемещении точки начала полки: удлиняется, укорачивается или поворачивается.

Рис. 3.8.10. Пример редактирования объекта с линией-выноской
(точка присоединения линии-выноски к объекту совпадает с его точкой перемещения)

Редактирование точек линии-выноски производится следующими способами.

– Чтобы изменить положение ответвлений, выделите объект и переместите характерные точки (см. раздел 3.5.1.1.3).

– Чтобы изменить конфигурацию линии-выноски, дважды щелкните по ней мышью и выполните действия по добавлению и удалению точек или ответвлений (см. раздел 3.3.7.4.3).

При разрушении макроэлемента содержащаяся в нем линия-выноска преобразуется в обычную линию-выноску.

Удаление линий-выносок

Чтобы удалить линию-выноску объекта, выделите его в окне документа или в Дереве документа. Затем вызовите команду контекстного меню Удалить линии-выноски. Команда появляется в меню, если выделен один объект с обозначением, построенным командой Линия-выноска объекта.

В результате работы команды у объекта удаляются все линии-выноски.

Удалить одну линию-выноску из нескольких можно только у макроэлемента. Для этого войдите в режим его редактирования, выделите удаляемую линию-выноску и нажмите клавишу <Delete>.


3.8.5.4. Режим редактирования макроэлемента

Редактирование макроэлемента производится в режиме его редактирования.

В этом режиме можно выполнять следующие действия:

– редактировать отдельные объекты макроэлемента,

– строить новые или добавлять существующие объекты в макроэлемент,

– создавать и удалять характерную точку макроэлемента,

– добавлять и удалять линии-выноски макроэлемента (см. раздел 3.8.5.3).

Чтобы перейти в режим редактирования макроэлемента, следует дважды щелкнуть мышью по макроэлементу или, выделив его, вызвать команду Редактировать макроэлемент. Для вызова команды нажмите кнопку Редактировать макроэлемент на панели Вставки и макроэлементы или панели Режимы, либо выберите ее название из меню Редактор.

Пока система находится в режиме редактирования макроэлемента, кнопка Редактировать макроэлемент остается нажатой. В окне документа появляется значок режима. Редактируемый макроэлемент отмечается в Дереве чертежа пиктограммой — «замком» (рис. 3.8.12, б).

Отредактируйте объекты макроэлемента. Все остальные объекты недоступны — они отображаются на экране стилем отрисовки фоновых видов.

Постройте новые объекты (в том числе многослойные) или удалите существующие. Все объекты, построенные в режиме редактирования макроэлемента, автоматически включаются в его состав.

Чтобы добавить в макроэлемент объект из числа имеющихся в документе, воспользуйтесь командой Добавить геометрию. О работе команды рассказано в разделе 3.8.5.5.

Чтобы создать или удалить характерную точку макроэлемента, воспользуйтесь командой Задать характерную точку. О работе команды рассказано в разделе 3.8.5.6, о редактировании положения точки в макроэлементе — в разделе 3.8.5.6.1.

Чтобы создать линию-выноску в макроэлементе, воспользуйтесь командой Линия-выноска объекта. О работе команды рассказано в разделе 3.8.5.3.1.

Чтобы выйти из режима редактирования, отожмите кнопку Редактировать макроэлемент, или выберите одноименную команду из меню Редактор повторно, или щелкните мышью по значку режима редактирования в окне документа.


3.8.5.5. Добавление объектов в макроэлемент

Команда Добавить геометрию позволяет добавлять в макроэлемент существующие в документе объекты.

Чтобы добавить в макроэлемент объекты, выполните следующие действия.

1. Выделите один макроэлемент, в который необходимо добавить объекты, или войдите в режим его редактирования.

2. Вызовите команду Добавить геометрию. Для вызова команды нажмите кнопку Добавить геометрию на панели Вставки и макроэлементы или выберите ее название из меню Инструменты — Макроэлементы.

3. Укажите объекты для добавления, щелкая на них мышью.

При попадании объекта в «ловушку» курсора объект подсвечивается.

Объекты, находящиеся в другом виде, недоступны для указания.

Чтобы исходные объекты автоматически удалялись, активизируйте переключатель Удалять исходные объекты. Активизация переключателя Оставлять исходные объекты означает, что исходные объекты будут сохранены.

Чтобы завершить выполнение команды, нажмите кнопку Прервать команду.


3.8.5.6. Задание характерных точек

Команда Задать характерную точку позволяет создать в макроэлементе характерную точку или удалить ранее созданную. Характерная точка, если она есть в макроэлементе, может использоваться для его перемещения и поворота при редактировании изображения.

Чтобы задать характерную точку, выполните следующие действия.

1. Выделите один макроэлемент, в котором необходимо создать характерную точку, или войдите в режим его редактирования.

2. Вызовите команду Задать характерную точку. Для вызова команды нажмите кнопку Задать характерную точку на панели Вставки и макроэлементы или выберите ее название из меню Инструменты — Макроэлементы.

3. Укажите мышью положение базовой точки или введите ее координаты на Панели свойств. Для этого вы можете воспользоваться привязками или геометрическим калькулятором.

После указания на экране появляется условное изображение точки.

Чтобы удалить ранее построенную характерную точку, после вызова команды нажмите кнопку Удалить характерную точку на Панели специального управления. Кнопка доступна, если данная точка была построена в макроэлементе.

Чтобы завершить выполнение команды, нажмите кнопку Прервать команду.

В этом разделе:

3.8.5.6.1. Изменение положения характерной точки относительно макроэлемента

3.8.5.6.2. Использование характерной точки макроэлемента


3.8.5.6.1. Изменение положения характерной точки относительно макроэлемента

После создания характерной точки вы можете сместить ее относительно макроэлемента, задав ей новое положение.

Для этого выделите макроэлемент, в котором находится точка, или войдите в режим его редактирования. Вызовите команду Задать характерную точку. Затем расфиксируйте координаты на Панели свойств и укажите новое положение точки.


3.8.5.6.2. Использование характерной точки макроэлемента

Характерная точка служит для размещения макроэлемента в документе при помощи привязок.

Характерная точка является точкой перемещения и центром поворота макроэлемента. Рядом с ней отображается вторая точка, которая служит для изменения угла наклона макроэлемента (см. рис. 3.8.11). Вы можете мышью «поворачивать» макроэлемент, перемещая вторую точку. Для точного поворота можно с помощью привязки совместить эту точку с другим объектом.

Рис. 3.8.11. Отображение характерной точки: а) в режиме редактирования макроэлемента, б) при редактировании документа
а) | б)


3.8.5.7. Отображение макроэлементов в Дереве чертежа

В Дереве чертежа (см. раздел 3.7.1.1) макроэлементы объединяются в группы Макро (хN), которые подчиняются виду, содержащему макроэлементы (рис. 3.8.12, а).

N в названиях групп — числа, обозначающие количество макроэлементов в каждой из них.

При создании или вставке макроэлементу присваиваются умолчательное имя и номер, которые можно отредактировать в Дереве чертежа.

Рис. 3.8.12. Отображение макроэлементов в Дереве чертежа:
а) в режиме построения; б) в режиме редактирования объекта

При выделении в Дереве чертежа макроэлемент выделяется в окне документа.

Контекстное меню выделенного макроэлемента содержит команды управления макроэлементом (рис. 3.8.13).

Рис. 3.8.13. Контекстное меню макроэлемента в Дереве чертежа

При редактировании макроэлемента, включающего другие макроэлементы, его структура показывается в Дереве чертежа. В этом случае слева от названия макроэлемента в Дереве отображается пиктограмма со значком «+». Щелчок мышью на значке позволяет просмотреть состав макроэлемента (рис. 3.8.12, б).


3.8.5.8. Разрушение макроэлемента

Вы можете разрушить макроэлемент (в том числе вставленный из библиотеки) на отдельные составляющие его объекты.

Чтобы разрушить макроэлемент, выполните следующие действия.

1. Выделите макроэлемент (макроэлементы), который нужно разрушить.

2. Вызовите команду Разрушить из меню Редактор.

После разрушения макроэлемент автоматически удаляется из Дерева чертежа.


3.9. Измерения в графических документах

В этом разделе:

3.9.1. Общие сведения

3.9.1.1. Быстрый просмотр результатов измерения

3.9.1.2. Информационное окно

3.9.2. Измерения на плоскости

3.9.2.1. Координаты точки

3.9.2.2. Расстояние между двумя точками

3.9.2.3. Расстояние между точками на кривой

3.9.2.4. Расстояние от кривой до точки

3.9.2.5. Расстояние между двумя кривыми

3.9.2.6. Угол между двумя прямыми/отрезками

3.9.2.7. Угол, образованный тремя точками

3.9.2.8. Длина кривой

3.9.2.9. Площадь

3.9.3. Массо-центровочные характеристики

3.9.3.1. Задание границ объектов

3.9.3.2. МЦХ плоских фигур

3.9.3.3. МЦХ тел вращения

3.9.3.4. МЦХ тел выдавливания


3.9.1. Общие сведения

3.9. Измерения в графических документах

3.9.1. Общие сведения

При работе в графических документах может возникнуть необходимость узнать расстояние или угол между точками, кривыми, найти площадь фигуры и т.п. В КОМПАС-3D возможно измерение различных геометрических характеристик, а также расчет массо-центровочных характеристик тела вращения или выдавливания (объема, массы, координат центра масс, осевых и центробежных моментов инерции).

Команды измерений сгруппированы в меню Сервис, а кнопки для вызова команд — на панели Измерения (2D) (рис. 3.9.1).

Рис. 3.9.1. Панель Измерения(2D)

В этом разделе:

3.9.1.1. Быстрый просмотр результатов измерения

3.9.1.2. Информационное окно


3.9.1.1. Быстрый просмотр результатов измерения

Вы можете быстро просмотреть результаты измерения, а можете внести их в Информационное окно.

Для просмотра результатов измерения после вызова команды достаточно подвести курсор к объекту измерения (например, к кривой, длину которой требуется определить). Результаты измерения отобразятся рядом с курсором (рис. 3.9.2, а).

Если в измерении участвуют несколько объектов, то последовательно укажите щелчком мыши все объекты, участвующие в измерении, кроме последнего объекта. К этому объекту подведите курсор. Результаты измерения отобразятся рядом с курсором. Например, требуется измерить расстояния между двумя точками на кривой. Щелкните мышью по кривой, вдоль которой будет измеряться расстояние. Затем щелкните мышью по первой точке кривой, а ко второй подведите курсор. Рядом с курсором появляется результат измерения (рис. 3.9.2, б).

Рис. 3.9.2. Просмотр результатов измерения: а) длина кривой; б) расстояние между двумя точками на кривой
а) | б)

Для внесения результатов измерения в Информационное окно следует щелкнуть мышью по объекту измерения (или по всем объектам измерения, если их несколько). На экране появляется Информационное окно. В окне отображаются результаты измерения и некоторые справочные параметры. Управление окном, а также команды его меню описаны в разделе 3.9.1.2.


3.9.1.2. Информационное окно

Информационное окно появляется на экране после щелчка мышью по объектам измерения.

Например, на рис. 3.9.3 показано Информационное окно при измерении расстояния от кривой до точки.

Рис. 3.9.3. Пример Информационного окна

В нем отображаются:

– текущая дата,

– полное имя активного документа,

– название текущей команды,

– результаты измерений.

Вы можете перемещать курсор по тексту в окне, вводить в него произвольный текст, выделять фрагменты текста клавишами или мышью. Если длина списка результатов превышает размеры окна, для просмотра значений пользуйтесь линейками прокрутки.

Информационное окно имеет собственное меню, состоящее из двух пунктов: Файл и Редактор. Команды меню описаны в таблицах 3.9.1 и 3.9.2 соответственно.

Табл. 3.9.1. Команды меню Файл
Команда | Позволяет
Сохранить | Сохранить содержимое Информационного окна в текстовом файле1 (*.txt). После вызова команды на экране появляется диалог. Укажите в нем имя файла для записи2.
Печать... | Напечатать содержимое Информационного окна. После вызова команды на экране появляется диалог настройки параметров печати.
Выход | Завершить текущую команду измерения без сохранения результатов.
  1. Файл записывается в формате текста Windows и может в дальнейшем использоваться в любых Windows-приложениях.
  2. Если выбрать существующий текстовый файл, на экране появится запрос «Добавить текст в конец файла?». В случае положительного ответа имеющийся в файле текст будет дополнен результатами измерений, отрицательного — заменен.

Табл. 3.9.2. Команды меню Редактор
Команда | Позволяет
Вырезать | Вырезать выделенный фрагмент текста в буфер обмена Windows.
Копировать | Скопировать выделенный фрагмент текста в буфер обмена Windows.
Вставить | Вставить текст из буфера обмена Windows.
Удалить | Удалить выделенный фрагмент текста.
Выделить все | Выделить весь текст в Информационном окне.
Шрифт... | Выбрать шрифт текста в Информационном окне. После вызова команды появляется диалог настройки шрифта.
Найти... | Найти заданный фрагмент текста. После вызова команды на экране появляется диалог, в котором можно ввести текст и настроить параметры поиска.

Сведения в Информационном окне обновляются после указания очередного объекта измерения. Поэтому редактирование текста в окне целесообразно только после завершения измерений.

Кнопка Фиксация в заголовке Информационного окна включает режим его автоматического сворачивания.

Кнопка Закрыть позволяет завершить текущую команду измерения.


3.9.2. Измерения на плоскости

3.9. Измерения в графических документах

3.9.2. Измерения на плоскости

После вызова любой из команд измерений на плоскости (см. рис. 3.9.1) на Панели свойств появляется вкладка Измерение. На ней расположены элементы, позволяющие настроить параметры процесса измерения. Эти элементы представлены в таблице 3.9.3.

Табл. 3.9.3. Элементы управления параметрами измерений

Элемент

Описание

Центр, т1, т2, т

Поля координат точек, задаваемых для выполнения измерения.

Расстояние

Справочное поле, в котором отображается измеряемое расстояние.

dX, dY

Справочные поля, в которых отображаются расстояния между указанными точками по осям текущей системы координат. Только для команды Расстояние между двумя точками.

Угол

Справочное поле, в котором отображается измеряемый угол (для команд Угол между двумя прямыми и Угол по трем точкам) или угол наклона радиус-вектора указанной точки к оси ОХ текущей системы координат (для команды Координаты точки).

Количество знаков после запятой

Список, управляющий отображением результатов измерения. Минимальное количество знаков после запятой — 0, максимальное — 10.

Единицы измерения длины

Список, позволяющий выбрать единицы измерения длины: миллиметры, сантиметры, дециметры, метры.

Единицы измерения угла

Список, позволяющий выбрать единицы измерения углов: градусы, радианы.

Режим

Переключатель, позволяющий выбрать режим измерения длин и площадей. Он появляется на Панели свойств, если масштаб текущего вида отличен от единицы.

Активизация переключателя Без учета масштаба вида позволяет получить результат «в натуральную величину». Активизация переключателя По бумаге позволяет получить результат в масштабе вида1.

Точка/Точки2

Группа переключателей, управляющая отрисовкой вспомогательных точек, формируемых в процессе измерения. Набор переключателей в этой группе зависит от выбранной команды измерения (см. табл. 3.9.4).

Центр масс1

Группа переключателей, управляющая отрисовкой точки в центре масс фигуры. Только для команды Площадь.

Стиль1

Список, позволяющий выбрать стиль точки.

Биссектриса1

Группа переключателей, управляющая отрисовкой биссектрисы измеряемого угла. Набор переключателей в этой группе зависит от выбранной команды измерения (см. табл. 3.9.5).
  1. Значения линейных величин, измеренные «по бумаге», получаются из значений «в натуральную величину» умножением на масштаб вида, а значения площадей — умножением на квадрат масштаба.
  2. Действие элементов управления Точки, Центр масс, Стиль и Биссектриса распространяется на следующее измерение.

Табл. 3.9.4. Состав группы переключателей Точка/Точки в зависимости от активной команды
Команда | Состав группы Точка/Точки
Координаты точки |
 | Не отрисовывать измеряемую точку
 | Отрисовывать измеряемую точку
Расстояние между двумя точками |
 | Не отрисовывать среднюю точку
 | Отрисовывать среднюю точку
Расстояние между точками на кривой |
 | Не отрисовывать измеряемые точки
 | Отрисовывать измеряемые точки
Расстояние от кривой до точки |
 | Не отрисовывать измеряемые точки
 | Отрисовывать измеряемую точку
Расстояние между двумя кривыми |
 | Не отрисовывать ближайшие точки
 | Отрисовывать ближайшие точки

Табл. 3.9.5. Состав группы переключателей Биссектриса в зависимости от активной команды
Команда | Состав группы Точка/Точки
Угол между двумя прямыми/отрезками |
 | Не отрисовывать биссектрису
 | Отрисовывать биссектрису
Угол по трем точкам |
 | Не отрисовывать биссектрису
 | Отрисовывать биссектрису

В этом разделе:

3.9.2.1. Координаты точки

3.9.2.2. Расстояние между двумя точками

3.9.2.3. Расстояние между точками на кривой

3.9.2.4. Расстояние от кривой до точки

3.9.2.5. Расстояние между двумя кривыми

3.9.2.6. Угол между двумя прямыми/отрезками

3.9.2.7. Угол, образованный тремя точками

3.9.2.8. Длина кривой

3.9.2.9. Площадь


3.9.2.1. Координаты точки

Чтобы определить положение произвольной точки графического документа, вызовите команду Координаты точки.

Последовательно задавайте точки, координаты которых требуется узнать.

Вы можете быстро просмотреть результаты измерения, подведя курсор к точке, или ввести результаты измерения в Информационное окно, щелкнув мышью по точке (о быстром просмотре см. раздел 3.9.1.1).

При быстром просмотре рядом с курсором отображаются координаты точки в текущей системе координат.

В Информационном окне отображаются следующие измеренные значения:

– координаты точки в текущей системе координат,

– расстояние от начала координат до точки,

– угол между радиус-вектором точки и осью Х.

Расстояние и угол представляют собой полярные координаты точки в системе, ось которой совпадает с осью Х текущей декартовой системы координат.


3.9.2.2. Расстояние между двумя точками

Чтобы определить расстояние между двумя произвольными точками графического документа, вызовите команду Расстояние между двумя точками.

Задавайте пары точек, расстояние между которыми требуется измерить.

Система определяет кратчайшее расстояние между указанными точками (длину соединяющего их отрезка прямой).

Вы можете быстро просмотреть результаты измерения или ввести результаты измерения в Информационное окно (см. раздел 3.9.1.1).

При быстром просмотре результатов измерения рядом с курсором отображается значение расстояния между указанными точками. В Информационном окне к значению расстояния между точками добавляются: значение расстояния между точками вдоль осей текущей системы координат и некоторые справочные параметры.


3.9.2.3. Расстояние между точками на кривой

Чтобы измерить длину участка кривой, ограниченного двумя точками, вызовите команду Расстояние между двумя точками на кривой.

Укажите кривую для измерения расстояния между точками на ней.

Затем задайте две точки, ограничивающие измеряемый участок.

Вы можете быстро просмотреть результаты измерения или ввести результаты измерения в Информационное окно (см. раздел 3.9.1.1).

При быстром просмотре результатов измерения рядом с курсором отображается значение длины участка кривой, ограниченного указанными точками. В Информационном окне к длине участка кривой добавляются некоторые справочные параметры.

Если указанные точки не принадлежит выбранной кривой, то положение границ участка будет определяться проекциями указанных точек на кривую. Для точного позиционирования курсора воспользуйтесь привязками (см. раздел 3.1.1).

Если выбрана замкнутая кривая, требуется указать также измеряемый участок.


3.9.2.4. Расстояние от кривой до точки

Чтобы измерить расстояние между выбранной кривой и произвольной точкой, вызовите команду Расстояние от кривой до точки.

Укажите кривую, а затем задайте точку, расстояние до которой нужно измерить.

Система определяет длину кратчайшего перпендикуляра, опущенного из точки на кривую.

Вы можете быстро просмотреть результаты измерения или ввести результаты измерения в Информационное окно (см. раздел 3.9.1.1).

При быстром просмотре результатов измерения рядом с курсором отображается значение расстояния от кривой до указанной точки. В Информационном окне к значению расстояния добавляются некоторые справочные параметры.


3.9.2.5. Расстояние между двумя кривыми

Чтобы определить расстояние между двумя кривыми, вызовите команду Расстояние между двумя кривыми.

Укажите курсором две кривые.

Система определяет кратчайшее расстояние между ними.

Возможно измерение только ненулевых расстояний. Поэтому после выбора первой кривой можно указать только непересекающуюся с ней кривую.

Вы можете быстро просмотреть результаты измерения или ввести результаты измерения в Информационное окно (см. раздел 3.9.1.1).

При быстром просмотре результатов измерения рядом с курсором отображается значение расстояния между указанными кривыми. В Информационном окне к значению расстояния добавляются некоторые справочные параметры.

Команду Измерить расстояние между кривыми можно использовать с целью нахождения ближайших точек двух элементов.


3.9.2.6. Угол между двумя прямыми/отрезками

Чтобы определить угол между прямолинейными объектами, вызовите команду Угол между двумя прямыми/отрезками.

Указывайте объекты, углы между которыми требуется измерить. Такими объектами могут являться прямые, отрезки, звенья ломаных линий и стороны многоугольников в различных комбинациях.

Система определяет величину угла, образованного точкой на первом объекте, ближайшей к месту указания этого объекта, точкой пересечения объектов (или их продолжений) и точкой на втором объекте, ближайшей к месту указания этого объекта.

Если выбраны параллельные объекты, то значение угла будет нулевым.

Вы можете быстро просмотреть результаты измерения или ввести результаты измерения в Информационное окно (см. раздел 3.9.1.1).

При быстром просмотре результатов измерения рядом с курсором отображается значение угла между указанными прямолинейными объектами. В Информационном окне к значению угла добавляется разница между измеренным углом и углами, равными 180° и 360°.


3.9.2.7. Угол, образованный тремя точками

Чтобы измерить угол, образованный тремя произвольными точками, вызовите команду Угол по трем точкам.

Задайте вершину угла, а затем две точки, лежащие на его сторонах.

Вы можете быстро просмотреть результаты измерения или ввести результаты измерения в Информационное окно (см. раздел 3.9.1.1).

При быстром просмотре результатов измерения рядом с курсором отображается значение угла между указанными точками. В Информационном окне к значению угла добавляется разница между измеренным углом и углами, равными 180° и 360°.


3.9.2.8. Длина кривой

Чтобы измерить полную длину кривой (длину незамкнутой кривой от начальной до конечной точки или периметр замкнутой кривой), вызовите команду Длина кривой.

Укажите кривую, длину которой требуется измерить.

Для измерения длин можно указывать только те кривые, которые расположены в текущем виде (об изменении состояния видов рассказано в разделе 3.6.5.2).

Вы можете быстро просмотреть результаты измерения или ввести результаты измерения в Информационное окно (см. раздел 3.9.1.1).

При быстром просмотре результатов измерения рядом с курсором отображается значение длины указанной кривой. Это же значение отображается в Информационном окне.

Вы можете просмотреть значения длин других кривых, подведя к ним курсор. Для внесения результатов измерений в Информационное окно последовательно щелкайте по этим кривым мышью.

Указанные объекты подсвечиваются. В Информационное окно добавится список измеренных длин. В конце списка указана сумма всех измеренных значений.

Чтобы исключить какую-либо кривую из списка, укажите ее повторно. Выделение с этой кривой будет снято, запись о ее длине будет удалена из окна, а сумма длин — вычислена заново.

Если кривая состоит из участков нескольких пересекающихся кривых, укажите ее путем обхода по стрелке. Для этого нажмите кнопку Обход границы по стрелке. Дальнейший порядок действий описан в разделе 3.2.13.1.2. После формирования контура результат измерения появляется в Информационном окне.

Если требуется измерить длину ломаной, не совпадающей полностью ни с одним из имеющихся контуров, сформируйте ее вручную. Для этого нажмите кнопку Ручное рисование границ. Дальнейший порядок действий описан в разделе 3.2.13.1.1. После формирования контура результат измерения появляется в Информационном окне.


3.9.2.9. Площадь

Чтобы определить площадь произвольной фигуры, вызовите команду Площадь.

Укажите точку внутри замкнутой области, ограниченной пересекающимися геометрическими объектами. Границы фигуры, образованной этими объектами, будут определены автоматически. Измеряемая площадь выделится цветом.

Для вычисления площади могут использоваться только те объекты, которые расположены в текущем виде (об изменении состояния видов рассказано в разделе 3.6.5.2).

Вы можете быстро просмотреть результаты измерения или ввести результаты измерения в Информационное окно (см. раздел 3.9.1.1).

При быстром просмотре результатов измерения рядом с курсором отображается значение площади указанной фигуры. Это же значение отображается в Информационном окне.

Вы можете просмотреть значения площадей других фигур, подведя к ним курсор. Для внесения результатов измерений в Информационное окно последовательно щелкайте внутри этих фигур мышью.

В Информационное окно добавится список измеренных площадей. В конце списка указана сумма всех измеренных значений.

Если повторно указать измеренную фигуру, щелкнув по ней мышью, ее площадь удаляется из списка измеренных площадей в Информационном окне. Список перенумеровывается, сумма всех измеренных площадей пересчитывается, а выделение цветом отменяется.

Используя кнопки Панели специального управления, вы можете вычислить площадь:

– Фигуры, ограниченной замкнутым контуром (окружностью, эллипсом, многоугольником и т.п.). Для этого нажмите кнопку Указать замкнутую кривую и укажите нужный контур.

– Фигуры, образованной набором геометрических объектов. Для этого нажмите кнопку Обход границы по стрелке. Дальнейший порядок действий описан в разделе 3.2.13.1.2. После формирования контура результат измерения появляется в Информационном окне.

– Фигуры, границы которой не существуют в чертеже. Для этого нажмите кнопку Ручное рисование границ. Дальнейший порядок действий описан в разделе 3.2.13.1.1. Сформируется временная ломаная линия. После формирования контура результат измерения появляется в Информационном окне.

Для измерения площади и вычисления координат геометрического центра сложной фигуры, состоящей из нескольких частей и имеющей отверстия, пользуйтесь командой Вычислить массо-центровочные характеристики плоского тела (см. раздел 3.9.3.2).


3.9.3. Массо-центровочные характеристики

3.9. Измерения в графических документах

3.9.3. Массо-центровочные характеристики

Команды вычисления МЦХ собраны в одну группу на панели Измерения (2D) (см. рис. 3.9.1).

После вызова любой из команд вычисления МЦХ на Панели свойств появляется вкладка Измерение. На ней расположены элементы, позволяющие настроить параметры процесса вычисления. Эти элементы представлены в таблице 3.9.6.

Табл. 3.9.6. Элементы управления параметрами вычисления МЦХ
Элемент | Описание
т | Поля координат точки начала системы координат, относительно которой должен производиться расчет МЦХ тела. Координаты этой точки задаются в текущей системе координат.
Угол | Поля угла поворота системы координат, относительно которой должен производиться расчет МЦХ тела. Этот угол отсчитывается от оси ОХ текущей системы координат.
Количество знаков после запятой | Количество знаков в десятичной части числа. Минимальное количество знаков — 1, максимальное — 10.
Единицы измерения длины | Список, позволяющий выбрать единицы измерения длины: миллиметры, сантиметры, дециметры, метры.
Единицы измерения массы | Список, позволяющий выбрать единицы измерения массы: граммы, килограммы.
Центр масс | Нажатие на эту кнопку позволяет отрисовать точку в центре масс (для плоских фигур) или точку, являющуюся проекцией центра масс тела на плоскость чертежа (для тел вращения или выдавливания).
Стиль | Список, позволяющий выбрать стиль точки.

В этом разделе:

3.9.3.1. Задание границ объектов

3.9.3.2. МЦХ плоских фигур

3.9.3.3. МЦХ тел вращения

3.9.3.4. МЦХ тел выдавливания


3.9.3.1. Задание границ объектов

Для вычисления МЦХ плоской фигуры требуется задание ее границ, а для вычисления МЦХ тела вращения или выдавливания — границ сечения тела. Существует несколько способов указания границ.

– Если в документе есть замкнутые контуры (эллипсы, окружности, сплайны и т.п.), ограничивающие фигуру или сечение тела, укажите их. Этот способ является умолчательным, т.е. после вызова команды вычисления МЦХ система ожидает указания контура. Границу, заданную указанием, можно исключить из группы расчета. Для этого просто укажите ее повторно.

– Если в качестве границы требуется указать контур, образованный набором геометрических объектов, нажмите кнопку Обход границы по стрелке. Дальнейший порядок действий описан в разделе 3.2.13.1.2. Если, обходя границу по стрелке, вы создали разомкнутый контур, то замыкающий отрезок будет построен автоматически.

– Если границы фигуры или сечения тела не существуют в чертеже, вы можете сформировать временную ломаную линию. Для этого нажмите кнопку Ручное рисование границ. Дальнейший порядок действий описан в разделе 3.2.13.1.1.

После указания каждого контура на экране появляется диалог Свойства объекта. В нем требуется указать, что ограничивает заданный контур — тело или отверстие.

До тех пор, пока не закончится выполнение команды вычисления МЦХ, каждый новый контур добавляется к уже выбранным, и расчет производится для сложной фигуры (сложного тела). Для начала нового расчета завершите выполнение команды и вызовите ее вновь.


3.9.3.2. МЦХ плоских фигур

Чтобы рассчитать площадь, координаты центра масс, осевые моменты инерции и центробежный момент инерции плоской фигуры, вызовите команду Расчет МЦХ плоских фигур.

Задайте границы фигуры и отверстий в ней.

Расчет МЦХ начинается сразу после указания первой границы. При указании каждой следующей границы (отверстия или тела) характеристики вычисляются заново.


3.9.3.3. МЦХ тел вращения

Чтобы вычислить МЦХ тела вращения (или его сектора) с заданным образующим сечением, вызовите команду МЦХ тел вращения.

Тело вращения для расчета МЦХ строится по следующим правилам.

– Образующее сечение тела вращения лежит в плоскости XOY (в плоскости чертежа) с одной стороны от оси OX.

– Вращение сечения происходит вокруг оси X.

– Для тела вращения угол дуги вращения равен 360°. Для сегментов тел вращения угол раствора дуги вращения меньше 360°.

Задайте границы сечения тела плоскостью XOY.

После указания каждого контура на экране появляется диалог свойств объекта (рис. 3.9.4). Элементы управления этого диалога представлены в таблице 3.9.7.

Рис. 3.9.4. Диалог Свойства объекта

Табл. 3.9.7. Элементы управления параметрами тела/отверстия
Элемент | Описание
Тело, Отверстие | Укажите, границей чего является указанный контур — тела или отверстия.
Выбрать из справочника | Кнопка, позволяющая выбрать материал из Справочника материалов (если он установлен на вашем рабочем месте). Значение плотности указанного материала появится в поле Плотность.
Плотность | Кнопка, позволяющая выбрать значение плотности из справочного файла плотностей1. Выбранное значение появится в поле Плотность. Вы можете также ввести нужное значение с клавиатуры.
Угол раствора | Угол сектора тела вращения.
  1. Файл ...\ASCON\KOMPAS-3D V...\Sys\Grарhic.dns. Значения плотностей материалов, содержащиеся в нем, могут редактироваться пользователем.

Расчет МЦХ начинается сразу после указания первой границы. Система определяет следующие значения:

– массу тела,

– объем тела,

– координаты центра масс,

– плоскостные моменты инерции,

– осевые моменты инерции,

– центробежные моменты инерции.

При указании каждой следующей границы (отверстия или тела) характеристики вычисляются заново.

Для корректного вычисления МЦХ тел с отверстиями необходимо при указании отверстия задавать плотность материала, из которого изготовлено тело с этим отверстием.


3.9.3.4. МЦХ тел выдавливания

Чтобы вычислить МЦХ тела выдавливания с заданным сечением, вызовите команду МЦХ тел выдавливания.

Тело выдавливания для расчета МЦХ строится по следующим правилам.

– Сечение тела выдавливания лежит в плоскости XOY (в плоскости графического документа).

– Выдавливание производится в направлении оси Z.

Задайте границы сечения тела плоскостью XOY.

После указания каждого контура на экране появляется диалог свойств объекта (рис. 3.9.5).

Поле Толщина предназначено для ввода толщины тела в направлении выдавливания. Остальные элементы управления диалога представлены в таблице 3.9.7.

Рис. 3.9.5. Диалог Свойства объекта

Расчет МЦХ начинается сразу после указания первой границы. Система определяет следующие значения:

– массу тела,

– объем тела,

– координаты центра масс,

– плоскостные моменты инерции,

– осевые моменты инерции,

– центробежные моменты инерции.

При указании каждой следующей границы (отверстия или тела) характеристики вычисляются заново.


3.10. Сервисные функции

В этом разделе:

3.10.1. Автонумерация и автосортировка объектов

3.10.1.1. Общие сведения

3.10.1.2. Порядок добавления номера в обозначение объекта

3.10.1.3. Окно Нумерация

3.10.1.4. Приемы нумерации

3.10.1.4.1. Добавление объекта в группу нумерации

3.10.1.4.2. Исключение объекта из группы нумерации

3.10.1.4.3. Свободные номера и автоперестроение нумерации

3.10.1.4.4. Изменение номера

3.10.1.5. Автосортировка буквенных обозначений объектов

3.10.2. Именованные группы

3.10.2.1. Создание новой группы

3.10.2.2. Добавление объектов в группу

3.10.2.3. Исключение объектов из группы

3.10.2.4. Выделение группы

3.10.2.5. Разрушение группы

3.10.3. Использование растровых изображений

3.10.3.1. Вставка

3.10.3.2. Редактирование

3.10.3.3. Обрезка

3.10.3.3.1. Выполнение обрезки рисунка

3.10.3.3.2. Выбор режима отображения рисунка


3.10.1. Автонумерация и автосортировка объектов

3.10. Сервисные функции

3.10.1. Автонумерация и автосортировка объектов

В этом разделе:

3.10.1.1. Общие сведения

3.10.1.2. Порядок добавления номера в обозначение объекта

3.10.1.3. Окно Нумерация

3.10.1.4. Приемы нумерации

3.10.1.4.1. Добавление объекта в группу нумерации

3.10.1.4.2. Исключение объекта из группы нумерации

3.10.1.4.3. Свободные номера и автоперестроение нумерации

3.10.1.4.4. Изменение номера

3.10.1.5. Автосортировка буквенных обозначений объектов


3.10.1.1. Общие сведения

В графических документах КОМПАС-3D предусмотрена автоматическая нумерация следующих объектов:

– таблицы, в том числе таблицы исполнений,

– отчеты, в том числе отчеты по массиву с таблицей изменяемых переменных,

– обозначения изменений,

– стрелки взгляда,

– выносные элементы,

– линии разреза/сечения (для машиностроения),

– базы,

– линии-выноски,

– размеры (кроме размера высоты).

При автоматической нумерации объекты указанных типов помещаются в группы нумерации (количество объектов в каждой группе не более 2 147 483 647). Для работы с группами нумерации используется окно Нумерация (см. раздел 3.10.1.3).

Каждый объект может входить только в одну группу нумерации. Номер объекта является ссылкой на его номер в группе.

Группа нумерации объединяет объекты, имеющие общие параметры нумерации, определяемые настройкой группы. Номера объектов группы не могут повторяться.

В одном документе возможно использование нескольких групп автоматической нумерации объектов — системных и пользовательских.

Системные группы созданы в документе по умолчанию. Имя системной группы начинается с символа #. Нельзя добавить или удалить системную группу, изменить ее наименование.

Пользовательские группы добавляются и удаляются пользователем в процессе работы с документом. Имя группы задается произвольно и доступно для редактирования.

По умолчанию в документе имеется три системные группы: #Автосортировка, #Нумерация обозначений изменений, #Нумерация таблиц.

Группы #Нумерация обозначений изменений, #Нумерация таблиц, а также пользовательские группы используются для автоматического присвоения номеров объектам. Номера объектов этих групп могут быть представлены числами от 1 до 2 147 483 647 или произвольно заданными символами.

Группа #Автосортировка предназначена для автосортировки буквенных обозначений объектов. В качестве номеров объектов этой группы используются только буквы. Порядок и особенности автосортировки описаны в разделе 3.10.1.5.

Параметры нумерации объектов в каждой группе (как системной, так и пользовательской) можно настроить.

Параметры системной группы #Автосортировка настраиваются в диалоге Автосортировка буквенных обозначений (см. раздел 9.2.6.13.14).

Настройка параметров всех остальных системных групп выполняется в диалоге Параметры системных групп нумерации. Для создания/удаления пользовательских групп, а также настройки их параметров используется диалог Параметры пользовательских групп нумерации. Работа в этих диалогах описана в разделе 9.2.6.23.

Объекты могут добавляться в группы нумерации вручную или автоматически в процессе создания/редактирования этих объектов. Добавление объектов в группы нумерации описано в разделе 3.10.1.4.1.


3.10.1.2. Порядок добавления номера в обозначение объекта

При автоматической нумерации в обозначении объекта создается ссылка на номер этого объекта в списке той группы нумерации, в которую он помещен. В группе #Автосортировка в качестве номеров используются буквы.

Особенности добавления номера-ссылки в обозначение объекта:

– таблица, отчет — номер-ссылка добавляется к тексту названия таблицы (таблицы отчета),

Если ассоциативная таблица разбита на несколько частей, то нумеруются все части. При необходимости нумерацию некоторых таблиц можно отменить (см. раздел 3.10.1.4.2).

– обозначение изменения — номер-ссылка добавляется к тексту обозначения,

– линия-выноска — номер-ссылка добавляется к тексту обозначения, расположенному над полкой,

– стрелка взгляда, выносной элемент, линия разреза/сечения — номер-ссылка заменяет содержимое поля, предназначенного для ввода буквенного обозначения (см. раздел 3.3.7.9.1),

– база — номер-ссылка заменяет весь текст обозначения,

– размеры — номер-ссылка добавляется к содержимому поля Текст до размерной надписи.


3.10.1.3. Окно Нумерация

Для работы с группами нумерации служит окно Нумерация, которое появляется на экране после вызова команды Вид — Нумерация. Окно содержит раскрывающийся список групп нумерации, список объектов текущей группы и инструментальную панель. В списке текущей группы для каждого объекта указан тип объекта и номер.

Элементы окна доступны, если не запущена ни одна команда.

Кнопки инструментальной панели позволяют настраивать отображение объектов в окне нумерации и параметры групп, а также управлять составом объектов каждой группы.

По умолчанию список объектов группы отображается в окне нумерации в порядке возрастания их номеров. При этом на инструментальной панели этого окна нажата кнопка Сортировка. Вы можете включить отображение списка в порядке убывания номеров объектов. Для этого отожмите кнопку.

Кнопка Масштаб по выделенным объектам позволяет изменить масштаб отображения документа таким образом, чтобы в нем в максимально возможном масштабе отображался объект, выделенный в окне нумерации. Если ни один объект не выделен, кнопка недоступна.

Для настройки параметров групп нумерации используется кнопка Параметры групп нумерации. Она вызывает диалог настройки, соответствующий текущей группе.

Для изменения набора объектов группы и порядка их следования в ней используются кнопки добавления, перемещения и удаления объектов. Эти действия описаны в разделе 3.10.1.4.


3.10.1.4. Приемы нумерации

В этом разделе:

3.10.1.4.1. Добавление объекта в группу нумерации

3.10.1.4.2. Исключение объекта из группы нумерации

3.10.1.4.3. Свободные номера и автоперестроение нумерации

3.10.1.4.4. Изменение номера


3.10.1.4.1. Добавление объекта в группу нумерации

Добавление объекта в группу нумерации (т.е. включение автонумерации объекта) может выполняться вручную или автоматически.

Ручное добавление доступно для объектов всех типов. При этом объект может быть помещен в любую группу нумерации.

Чтобы добавить объект или несколько объектов вручную, выполните следующие действия.

1. Из списка групп нумерации выберите нужную группу.

2. В окне документа выделите объекты, которые требуется добавить в выбранную группу.

3. Нажмите кнопку Добавить выделенные объекты на инструментальной панели окна Нумерация.

Автоматическое добавление объектов в группы имеет следующие особенности:

– таблица, отчет или обозначение изменения добавляется в любую группу, кроме группы #Автосортировка,

– стрелка взгляда, выносной элемент, линия разреза/сечения, база или линия-выноска добавляется только в группу #Автосортировка,

– для размера любого типа автоматическое добавление в группы нумерации недоступно.

Автоматическое добавление объекта в группу выполняется при его создании или редактировании. Для этого используются элементы управления Панели свойств. В зависимости от типа объекта доступны следующие способы:

– для таблицы, отчета, обозначения изменения — выберите группу нумерации, в которую требуется добавить объект, из списка Нумерация, (список расположен для таблиц — на вкладке Таблица, для обозначения изменения — на вкладке Знак),

– для стрелки взгляда, выносного элемента, линии разреза/сечения, базы, линии-выноски — включите опцию Автосортировка.

Если опция Автосортировка включена при создании объекта, то все новые объекты того же типа будут автоматически добавляться в группу #Автосортировка (в диалоге настройки включается автосортировка объектов данного типа, см. раздел 9.2.6.13.14). Включение опции при редактировании объекта не влияет на вновь создаваемые объекты.

При добавлении объекта в любую группу, кроме группы #Автосортировка, он помещается в конец списка объектов группы и получает последний номер в списке. Положение объектов в списке группы #Автосортировка зависит от типа объектов и определяется настройкой. Поэтому добавленный объект располагается последним среди объектов того же типа.

Чтобы сменить номер объекта, переместите его в списке (см. раздел 3.10.1.4.4). Если в группе имеется свободный номер (для всех групп, кроме группы #Автосортировка), то он может быть присвоен добавленному объекту. О свободных номерах см. раздел 3.10.1.4.3.

Один и тот же объект не может входить одновременно в несколько групп нумерации. Поэтому, если в группу добавляется объект, уже включенный в другую группу, он переносится из исходной группы в группу, указанную для добавления.


3.10.1.4.2. Исключение объекта из группы нумерации

Чтобы исключить объект из группы нумерации (т.е. отключить автонумерацию этого объекта), выделите его в списке объектов группы и нажмите кнопку Исключить из группы на инструментальной панели окна Нумерация. Данный способ доступен для объектов всех типов.

Кроме того, вы можете отключить автонумерацию объекта при его редактировании. В зависимости от типа объекта используются следующие способы.

– для таблицы, отчета, обозначения изменения — из списка Нумерация, расположенного на Панели свойств, выберите вариант Не использовать или удалите номер ссылку из названия таблицы/обозначения изменения,

– для размера — при редактировании размерной надписи удалите номер-ссылку из поля Текст до,

– для стрелки взгляда, выносного элемента, линии разреза/сечения, базы, линии-выноски — на Панели свойств отключите опцию Автосортировка; для линии-выноски также доступно удаление номера-ссылки.

Отключение опции Автосортировка исключает из автонумерации только текущий объект.

После исключения из группы нумерации таблицы, отчета, обозначения изменения, размера или линии-выноски из обозначения исключенного объекта (названия таблицы) удаляется номер-ссылка.

Кроме номера-ссылки, надпись объекта может содержать произвольный текст, введенный вручную. Данный текст не удаляется при удалении номера-ссылки.

В свою очередь номер-ссылка может содержать строку текста, заданную при настройке параметров нумерации. Эта строка является частью номера и удаляется вместе с ним.

Если из группы нумерации исключается стрелка взгляда, выносной элемент, линия разреза/сечения или база, то номер-ссылка в обозначении объекта преобразуется в простой текст.

При умолчательной настройке нумерация в документе автоматически перестраивается. Если автоперестроение отключено, номера остальных объектов не изменяются. В списке группы нумерации остаются свободные номера (см. раздел 3.10.1.4.3). Отключение автоперестроения доступно для всех групп, кроме группы #Автосортировка.


3.10.1.4.3. Свободные номера и автоперестроение нумерации

При исключении объекта из группы нумерации присвоенный ему номер может быть удален из списка объектов группы или оставлен в качестве свободного номера. Это зависит от значения параметра Автоперестроение нумерации, которое задается при настройке параметров нумерации (см. раздел 9.2.6.23).

Если выбрано значение Да (автоперестроение включено), то при исключении объекта из группы выполняется автоматическое перестроение номеров объектов этой группы, находящихся в списке после исключаемого. Свободных номеров не остается. Если выбрано значение Нет (автоперестроение отключено), номера объектов группы не изменяются, в списке остаются строки, содержащие свободные номера.

При исключении объекта, занимающего последнюю строку списка, его номер в списке удаляется независимо от значения параметра Автоперестроение нумерации, т.е. строки, содержащей свободный номер, не будет.

Для группы #Автосортировка нельзя отключить автоперестроение нумерации, поэтому данная группа не может содержать свободные номера.

В дальнейшем строки списка, содержащие свободные номера, можно удалить вручную (их удаление аналогично исключению объектов из группы) или автоматически, включив автоперестроение нумерации.

Вы можете создать в списке произвольное количество строк, содержащих свободные номера. Для этого отключите автоперестроение нумерации и переместите последний объект в списке на нужное количество позиций вниз.


3.10.1.4.4. Изменение номера

Чтобы изменить номер объекта, измените его положение в списке объектов группы нумерации с помощью кнопок Передвинуть вниз и Передвинуть вверх. Одно нажатие кнопки перемещает выбранный объект на одну позицию вниз/вверх. При этом он занимает соседнюю строку списка и получает номер объекта, содержащегося в этой строке, т.е. объекты меняются местами и номерами друг с другом. Аналогичные действия выполняются, если рядом с перемещаемым объектом находится не другой объект, а строка, содержащая свободный номер.

Перемещать можно как строки, содержащие объекты, так и строки со свободными номерами. При перемещении строки со свободным номером на последнюю позицию в списке она автоматически удаляется.

При перемещении объекта обратите внимание на следующие особенности.

– Для объекта, расположенного первым в списке, доступно только перемещение вниз.

– Для объекта, расположенного последним в списке, доступность перемещения вниз зависит от значения параметра Автоперестроение нумерации (см. раздел 9.2.6.23). Если выбрано значение Да, перемещение вниз недоступно. Если выбрано значение Нет, объект можно переместить вниз. При этом объект переносится на следующую позицию списка и получает соответствующий номер, строка, на которой первоначально находился объект, остается пустой, а исходный номер объекта становится свободным номером.

– В группе #Автосортировка можно менять местами только объекты одного и того же типа; перемещение последнего объекта вниз недоступно.


3.10.1.5. Автосортировка буквенных обозначений объектов

Автосортировка позволяет автоматически упорядочивать буквы, использующиеся в следующих обозначениях:

– стрелки взгляда,

– выносные элементы,

– линии разреза/сечения (для машиностроения),

– базы,

– линии-выноски,

– размеры (кроме размера высоты).

В автосортировке участвуют только буквы обозначений, включенных в системную группу нумерации #Автосортировка. Для этих обозначений произвольный ввод буквы невозможен. Нужная буква выбирается системой автоматически в соответствии с настройкой (см. раздел 9.2.6.13.14). Созданный объект добавляется в группу нумерации #Автосортировка. Его обозначение в окне документа содержит ссылку на номер этого объекта в группе (в данном случае номера представлены не числами, а буквами). Работа с группами нумерации выполняется в окне Нумерация (см. раздел 3.10.1.3).

Положение объекта в группе #Автосортировка определяется его типом. Объекты одного и того же типа объединяются в подгруппы, которые следуют одна за другой в списке группы. Порядок следования подгрупп объектов в зависимости от типа также указывается при настройке.

Основные действия с автосортируемыми объектами:

– Включение автосортировки объекта

• Автоматическое включение автосортировки доступно для всех объектов, кроме размеров. Для этого включите опцию Автосортировка при создании или редактировании объекта. Если требуется, чтобы автосортировка автоматически включалась для всех вновь создаваемых объектов определенного типа, включите соответствующую опцию в диалоге настройки автосортировки.

• Ручное включение автосортировки доступно для всех объектов. Для этого добавьте объект в группу #Автосортировка. При необходимости вы можете добавить объект в любую группу нумерации.

Особенности добавления объектов в группы нумерации описаны в разделе 3.10.1.4.1.

– Смена буквы в обозначении объекта

Чтобы изменить букву объекта, измените его положение в списке группы с помощью кнопок Передвинуть вниз и Передвинуть вверх. Переместить объект можно только внутри подгруппы объектов того же типа. Подробнее об изменении положения объекта в группе нумерации см. раздел 3.10.1.4.4.

– Отключение автосортировки объекта

Чтобы отключить автосортировку объекта, удалите его из группы нумерации или при редактировании объекта (кроме размера) на Панели свойств отключите опцию Автосортировка. Эти и другие способы исключения объектов из автосортировки подробно описаны в разделе 3.10.1.4.2.

При исключении объекта из автосортировки обозначения оставшихся объектов формируются заново с учетом «освободившихся» букв.

Если автосортировка отключается для стрелки взгляда, выносного элемента, линии разреза/сечения или базы, то ссылка на букву становится простым текстом. Вы можете ввести другую букву и/или любой другой символ, в том числе используемый в другом обозначении.

Если автосортировка отключается для линии-выноски или размера, то ссылка на букву удаляется из обозначения объекта.

При необходимости вы можете создать объекты с одинаковыми буквами, управляемыми автосортировкой. Для этого добавьте один из них в группу #Автосортировка, а в обозначения остальных добавьте ссылку на букву этого объекта. Добавление ссылок описано в разделе 3.4.1.4.1. Для объектов, в которые добавляются ссылки, автосортировка должна быть отключена.


3.10.2. Именованные группы

3.10. Сервисные функции

3.10.2. Именованные группы

При работе с чертежом довольно часто возникает потребность на какое-то время объединить отдельные элементы изображения, логически связанные между собой, для удобства их поиска и редактирования. Например, если разрабатывается конструкция емкости с крышкой, то будет удобно выделять и перемещать изображение крышки и всех расположенных на ней конструктивных элементов одновременно в том случае, если изменяется высота емкости.

При работе в КОМПАС-3D возможно объединение произвольного количества объектов в группы. Существенным является тот факт, что включение объекта в группу не накладывает никаких ограничений на его самостоятельность. Объект по-прежнему можно редактировать отдельно, вплоть до его полного удаления.

Каждый объект графического документа может быть включен в несколько различных групп, созданных в этом документе.

Для удобства работы при создании каждой группы обязательно задается ее имя, которое в дальнейшем отображается в списке для выбора группы во время различных операций.

В группу могут входить объекты, расположенные на разных слоях (см. раздел 3.6.6) и в разных видах (см. раздел 3.6.4) чертежа.

К группе могут быть применены следующие команды редактирования:

– Сдвиг (см. раздел 3.5.2),

– Поворот (см. раздел 3.5.4.1),

– Масштабирование (см. раздел 3.5.4.2),

– Симметрия (см. раздел 3.5.4.3),

– Копирование (см. раздел 3.5.3).

При выполнении команд Симметрия и Копирование в документе не формируются новые группы. Создаются только копии объектов, входящих в исходную группу.

Группы также можно копировать и переносить через буфер обмена (см. раздел 3.1.2).

Группа может быть в любой момент разрушена, что не окажет никакого влияния на входившие в нее объекты.

Управление группами объектов производится в диалоге (рис. 3.10.1), вызываемом командой Сервис — Группы....

Рис. 3.10.1. Диалог работы с группами

В этом разделе:

3.10.2.1. Создание новой группы

3.10.2.2. Добавление объектов в группу

3.10.2.3. Исключение объектов из группы

3.10.2.4. Выделение группы

3.10.2.5. Разрушение группы


3.10.2.1. Создание новой группы

Для создания новой именованной группы выполните следующие действия.

1. Выделите объекты, которые нужно включить в группу (о способах выделения объектов см. раздел 3.1.2).

2. Вызовите диалог работы с группами.

3. Введите имя для создаваемой группы и нажмите кнопку Создать новую группу.


3.10.2.2. Добавление объектов в группу

Чтобы включить дополнительные объекты в имеющуюся именованную группу, выполните следующие действия.

1. Выделите объекты, которые требуется добавить в группу.

2. Вызовите диалог работы с группами.

3. Выберите в списке имя группы, в которую требуется добавить выделенные объекты, и нажмите кнопку Добавить в группу.


3.10.2.3. Исключение объектов из группы

Чтобы исключить из именованной группы часть входящих в нее объектов, выполните следующие действия.

1. Выделите объекты, которые требуется исключить из группы.

2. Вызовите диалог работы с группами.

3. Выберите в списке имя группы, которой принадлежат выделенные объекты, и нажмите кнопку Исключить из группы.


3.10.2.4. Выделение группы

Выделение группы требуется перед вызовом команд редактирования. Чтобы выделить в документе именованную группу, выполните следующие действия.

1. Вызовите команду Выделить — Группу. На экране появится диалог указания группы.

2. Выберите в списке имя группы (групп), которую требуется выделить.

Все объекты, составляющие указанную группу (группы), будут выделены.


3.10.2.5. Разрушение группы

Если именованная группа больше не требуется для работы, можно разрушить ее. Разрушение группы не оказывает никакого влияния на те объекты, которые входят в эту группу.

Для разрушения группы выполните следующие действия.

1. Вызовите диалог работы с группами.

2. Выберите в списке имя группы (групп), которую требуется разрушить, и нажмите кнопку Разрушить группы. Имя выбранной группы (групп) будет удалено из списка.


3.10.3. Использование растровых изображений

3.10. Сервисные функции

3.10.3. Использование растровых изображений

Вы можете вставлять в графические документы изображения из внешних растровых файлов следующих форматов:

• BMP,

• GIF,

• JPEG,

• PNG,

• TIFF,

• TGA.

Вставка растровых объектов рассмотрена в разделе 3.10.3.1.

Растровое изображение, вставленное в КОМПАС-документ, можно сохранить в файле. Для этого выделите вставку и вызовите из контекстного меню команду Сохранить растровый объект как... В появившемся на экране диалоге выберите тип файла, задайте его имя и расположение.

Доступны также возможности редактирования вставленного изображения (см. раздел 3.10.3.2) и его обрезки по произвольному контуру (см. раздел 3.10.3.3).

При необходимости возможна настройка редактирования вставленных в документ растровых изображений, см. раздел 9.1.7.13.

В этом разделе:

3.10.3.1. Вставка

3.10.3.2. Редактирование

3.10.3.3. Обрезка

3.10.3.3.1. Выполнение обрезки рисунка

3.10.3.3.2. Выбор режима отображения рисунка


3.10.3.1. Вставка

Чтобы вставить растровое изображение, вызовите команду Вставка — Рисунок.

В появившемся на экране диалоге укажите нужный файл-источник вставки.

В текущем документе появится габаритная рамка вставляемого изображения, а на Панели свойств — элементы управления вставкой. Эти элементы представлены в таблице 3.10.1.

Табл. 3.10.1. Элементы управления вставкой растрового изображения
Элемент | Описание
Файл-источник | Полное имя файла-источника рисунка.
Сменить источник | Кнопка, позволяющая выбрать другой файл в качестве источника рисунка.
Способ вставки | Группа переключателей, позволяющая указать способ вставки (см. табл. 4.1.12).
Разрешение | Поле для указания разрешения вставляемого изображения. Оно присутствует на Панели свойств, если в файле-источнике нет информации о разрешении изображения.
Базовая точка | Поля координат базовой точки рисунка.
Угол | Поле угла поворота рисунка в текущей системе координат.
Масштаб | Поле коэффициента масштабирования рисунка.
Информация | Панель, содержащая сведения о вставляемом растровом объекте. При изменении значений в полях Разрешение и Масштаб значения в строках Ширина, мм и Высота, мм данной панели пересчитываются.
Режим | Группа переключателей для выбора режима отображения растрового объекта: частично или полностью. Эта группа становится доступна после указания границы обрезки рисунка (см. раздел 3.10.3.3).

После задания базовой точки фантом вставки фиксируется. Вы можете вставить выбранное изображение несколько раз, при необходимости изменяя его масштаб и угол поворота.

Вы можете вставить растровое изображение через буфер обмена. В этом случае на Панели свойств присутствуют элементы управления вставкой, перечисленные в таблице 3.10.1, за исключением следующих: Файл-источник, Сменить источник и Способ вставки.


3.10.3.2. Редактирование

Редактирование растровых изображений средствами КОМПАС-3D невозможно. Чтобы отредактировать рисунок, необходимо открыть его в приложении, работающем с растровой графикой.

Для этого выделите вставленный растровый объект и вызовите из контекстного меню команду Редактировать источник. Эта команда работает по-разному в зависимости от способа вставки (см. табл. 4.1.12) выбранного растрового объекта.

– Если объект был вставлен внешней ссылкой, то после вызова команды Редактировать источник он открывается приложением, сопоставленным в Windows типу файла, который имеет этот растровый объект.

– Если объект был взят в документ, то после вызова команды Редактировать источник он открывается в том формате в том приложении, которые установлены при настройке графического (см. раздел 9.1.7.13).

После того как рисунок будет открыт, внесите в него необходимые изменения. Затем сохраните и закройте файл рисунка. Сделанные изменения будут переданы в КОМПАС-документ.

При редактировании источника растрового объекта, взятого в документ, создается файл, тип которого указан при настройке графического редактора, а имя совпадает с именем файла-источника вставки. Созданный файл размещается в папке, предназначенной для хранения временных файлов. Если закрытие рисунка производится до завершения сеанса работы КОМПАС-3D, то изменения рисунка передаются в КОМПАС-документ, а временный файл удаляется. В противном случае изображение в КОМПАС-документе не изменятся, а файл рисунка остается в папке для временных файлов.

Если объект был вставлен внешней ссылкой, то в его контекстном меню доступна команда Редактировать с помощью... После ее вызова на экране появляется диалог для указания программы. Выберите программу, поддерживающую тип файла, который имеет вставленный рисунок, и нажмите кнопку ОК. Рисунок будет открыт указанной программой.

Положение в документе и масштаб рисунка можно изменить, перемещая мышью его характерные точки. Кроме того, к рисункам можно применять следующие команды редактирования объектов:

– Сдвиг (см. раздел 3.5.2),

– Поворот (см. раздел 3.5.4.1),

– Масштабирование (см. раздел 3.5.4.2),

– Симметрия (см. раздел 3.5.4.3),

– Копирование (см. раздел 3.5.3).

Обратите внимание на то, что результатом выполнения двух последних команд является вставка в документ дополнительных рисунков.

Копирование рисунка возможно также с помощью мыши (см. раздел 3.5.1.1.2) и через буфер обмена (см. раздел 3.1.2).


3.10.3.3. Обрезка

В случаях, когда в чертеже или фрагменте требуется отображать не весь вставленный рисунок, а только его часть, можно скрыть участки изображения с помощью команды Обрезать. Обрезка рисунка производится по замкнутой линии — границе обрезки. Граница обрезки может быть создана непосредственно в процессе выполнения команды или предварительно построена в документе.

Предварительно созданная граница может включать различные геометрические объекты, в то время как в процессе выполнения команды можно построить только ломаную.

После того как для рисунка указана граница обрезки, можно выбрать режим отображения рисунка — полностью или частично (см. раздел 3.10.3.3.2).

Граница обрезки хранится внутри вставки рисунка. Благодаря этому она перемещается, поворачивается и копируется вместе с рисунком. При изменении размеров вставки (с помощью команды Масштабирование, в результате изменения разрешения растра и др.) граница масштабируется.

Для того чтобы обрезать рисунок по другой границе, необходимо выполнить обрезку повторно, указав или создав новый контур. Так как граница для обрезки может быть только одна, новый контур заменит прежний.

При смене источника вставки граница обрезки удаляется. Для обрезки нового рисунка необходимо вызвать для него команду Обрезать.

Если в качестве нового источника вставки указан прежний файл (например, находящийся в другой папке), то граница обрезки сохраняется.

При выделении рисунка, отображающегося частично, габаритная рамка формируется по размерам той части рисунка, которая видна на экране. Характерные точки контура — границы обрезки не показываются.

К характерным точкам, а также к линиям границы обрезки рисунка возможна привязка во время построения других объектов.

В этом разделе:

3.10.3.3.1. Выполнение обрезки рисунка

3.10.3.3.2. Выбор режима отображения рисунка


3.10.3.3.1. Выполнение обрезки рисунка

Требования к границе обрезки:

– граница должна представлять собой окружность, эллипс, прямоугольник, многоугольник, замкнутую ломаную или замкнутый контур (контур не должен содержать кривые Безье или NURBS),

– граница должна пересекаться с рисунком,

– граница, имеющая самопересечения, должна полностью находиться в пределах рисунка.

При необходимости создайте границу обрезки — геометрический объект или контур, удовлетворяющий вышеприведенным требованиям.

Чтобы обрезать рисунок, выполните следующие действия.

1. Вызовите команду Редактор — Обрезать.

2. Укажите рисунок для обрезки, щелкнув по нему мышью (при прохождении курсора над вставленными в документ рисунками они выделяются габаритной рамкой).

Рисунок для обрезки можно указать и перед вызовом команды, выделив его.

В этом случае команду Обрезать удобно вызывать из контекстного меню.

3. Задайте границу обрезки.

– Чтобы указать заранее созданную границу, щелкните по ней мышью (при прохождении курсора над объектами, которые могут использоваться в качестве границы, они подсвечиваются).

Группа переключателей Режим позволяет указать, требуется ли удалять указанный объект после создания границы или нет.

Связь между рисунком и указанным объектом не формируется, т.е. удаление или редактирование объекта не влияет на границу обрезки.

– Чтобы создать границу обрезки, нажмите кнопку Ручное рисование границ на Панели специального управления.

Система перейдет в режим ручного рисования границ (см. раздел 3.2.13.1.1). Постройте границу обрезки, удовлетворяющую требованиям, перечисленным выше.

Нажмите кнопку Создать объект на Панели специального управления, чтобы вернуться к выполнению команды Обрезать.

4. Если требуется сменить границу, нажмите кнопку Повторный выбор контура на Панели специального управления и выберите другой объект либо нажмите кнопку Ручное рисование границ, и постройте другую границу. При необходимости включите режим полного отображения рисунка с помощью появившейся на Панели свойств группы переключателей Режим.

5. Нажмите кнопку Создать объект для подтверждения обрезки рисунка.

После обрезки одного рисунка система ожидает указания следующего. Чтобы завершить выполнение команды, нажмите кнопку Прервать команду.


3.10.3.3.2. Выбор режима отображения рисунка

Режим отображения рисунка — полностью или частично — можно выбрать, используя один из двух способов.

Способ 1

1. Выделите рисунок, для которого была выполнена обрезка, и вызовите из контекстного меню команду Обрезать или команду Редактировать.

2. Выберите режим отображения с помощью группы переключателей Режим на Панели свойств.

3. Нажмите кнопку Создать объект.

Способ 2

1. Включите отображение окна Свойства, если оно отключено. Например, для этого можно вызвать команду Редактор — Свойства.

2. Выделите рисунок, для которого была выполнена обрезка.

3. В окне Свойства найдите свойство Режим отрисовки. Щелкните в ячейке значения свойства, раскройте список значений и выберите из него нужную строку.

Этот способ позволяет изменить режим отображения сразу нескольких выделенных рисунков.

Подробно окно Свойства и изменение свойств объектов описаны в разделе 3.5.1.2.

Если граница оказывается за пределами рисунка (это может произойти в результате изменения площади рисунка при редактировании его в графическом редакторе), она не удаляется из вставки, но режим отображения рисунка автоматически меняется на полный. Чтобы снова обрезать такой рисунок, необходимо вызвать для него команду Обрезать и создать или указать новый контур.


4.1. Текстовый редактор

В этом разделе:

4.1.1. Общие сведения

4.1.1.1. Текстовый курсор и управление им

4.1.2. Приемы работы

4.1.2.1. Выбор шрифта и установка его параметров

4.1.2.2. Редактирование текста, режимы вставки и замены

4.1.2.3. Выделение фрагментов текста

4.1.2.4. Копирование и перенос текста через буфер

4.1.2.5. Форматирование текста

4.1.2.5.1. Изменение параметров абзаца

4.1.2.5.2. Смена регистра символов

4.1.2.6. Язык текста

4.1.2.6.1. Выбор языка

4.1.2.6.2. Смена символов на латинские или кириллические

4.1.2.7. Стили текста

4.1.2.7.1. Выбор текущего стиля текста

4.1.2.8. Символы форматирования

4.1.2.9. Поиск и замена текста

4.1.2.10. Использование блоков текста

4.1.2.11. Специальные вставки

4.1.2.11.1. Дроби

4.1.2.11.2. Индексы

4.1.2.11.3. Надстроки и подстроки

4.1.2.11.4. Специальные знаки и обозначения

4.1.2.11.5. Символы

4.1.2.11.6. Текстовые шаблоны

4.1.2.11.7. Вертикальный текст

4.1.2.11.8. Иллюстрации

4.1.2.11.9. Вставка отчета в текст

4.1.2.12. Списки

4.1.2.12.1. Создание списков и управление ими

4.1.2.12.2. Настройка параметров списков

4.1.3. Проверка правописания

4.1.3.1. Проверка текста на различных языках

4.1.3.2. Автоматическая проверка текста

4.1.3.3. Проверка правописания по вызову команды

4.1.3.4. Настройка параметров проверки правописания

4.1.3.5. Выполнение проверки

4.1.3.5.1. Графический документ

4.1.3.5.2. Текстовый документ

4.1.3.5.3. Спецификация

4.1.3.6. Словари

4.1.3.6.1. Редактирование вспомогательного словаря

4.1.3.6.2. Создание нового вспомогательного словаря

4.1.3.6.3. Подключение существующего вспомогательного словаря

4.1.3.6.4. Добавление слов во вспомогательный словарь при проверке орфографии

4.1.4. Создание текстового документа

4.1.4.1. Режим отображения

4.1.4.2. Оформление и формат

4.1.4.3. Основная надпись

4.1.4.4. Разделы

4.1.4.4.1. Добавление и удаление раздела

4.1.4.4.2. Переключение между разделами

4.1.4.4.3. Изменение порядка следования разделов

4.1.4.5. Нумерация листов

4.1.4.6. Пример создания документа с несколькими разделами


4.1.1. Общие сведения

4.1. Текстовый редактор

4.1.1. Общие сведения

Текстовый редактор является составной частью системы КОМПАС-3D. Основная область его применения — разработка различного рода текстово-графической документации. Документы могут оформляться в соответствии со стандартами или иметь произвольную форму.

При создании документов возможно использование любых доступных в Windows шрифтов — как векторных, так и TrueTyрe.

В поставку системы КОМПАС-3D включены шрифты TrueType, начертание которых соответствует ГОСТ 2.304-81 ЕСКД. Шрифты чертежные:

– GOST type A (имя файла шрифта — gost_a.ttf),

– GOST type B (имя файла шрифта — gost_b.ttf),

– GOST type AU (Юникод-шрифт, имя файла шрифта — gost_au.ttf),

– GOST type BU (Юникод-шрифт, имя файла шрифта — gost_bu.ttf),

Кроме того, дистрибутив включает шрифты True Type, содержащие спецсимволы:

– Symbol type A (имя файла шрифта — symbol_a.ttf),

– Symbol type B (имя файла шрифта — symbol_b.ttf).

В комплект поставки входят также векторные шрифты (содержащие те же символы, что и шрифты True Type):

– GOST type A (potter) (имя файла шрифта — gost_a.fon),

– GOST type B (potter) (имя файла шрифта — gost_b.fon),

– Symbol type A (имя файла шрифта — symbol_a.fon),

– Symbol type B (имя файла шрифта — symbol_b.fon).

Основные возможности текстового редактора:

– настройка параметров шрифта и абзацев,

– работа со стилями текста (использование готовых и разработка собственных),

– автоматизированный ввод часто встречающихся фрагментов текста (текстовых шаблонов),

– вставка специальных обозначений и символов (допусков форм, предельных отклонений, обозначений сварных соединений и т.п.) из системной библиотеки,

– вставка формул, дробей, надстрочных и подстрочных индексов,

– создание списков различной степени вложенности,

– создание произвольных таблиц,

– вывод созданных документов на плоттер и принтер,

– проверка правописания текстов на разных языках.

Пользователи, имеющие некоторый опыт работы в популярном текстовом редакторе MS Word для Windows (или другом текстовом процессоре для этой операционной системы), найдут в КОМПАС-3D много знакомых возможностей по обработке текста и смогут без труда освоить систему.

Текстовый процессор используется для ввода и обработки текстово-графической информации в следующих режимах:

– создание технических требований, заполнение основной надписи на чертежах,

– создание различных надписей и таблиц (в том числе в составе размеров и обозначений) в чертежах и фрагментах,

– создание отдельных текстовых и текстово-графических документов,

– создание таблиц основных надписей чертежей, спецификаций и текстовых документов.

Каждый из этих из режимов имеет некоторые отличия в интерфейсе и наборе доступных команд. В целом приемы работы и принципы задания параметров во всех режимах одинаковы.

В дальнейшем при описании той или иной возможности текстового процессора будут оговариваться отличия (если они имеются) при ее использовании в различных режимах работы.

Вызов команд текстового процессора возможен с помощью Главного меню, Инструментальных панелей и вкладок Панели свойств. Для большинства команд доступны все три способа вызова.

В этом разделе:

4.1.1.1. Текстовый курсор и управление им


4.1.1.1. Текстовый курсор и управление им

Текстовый курсор представляет собой вертикальный мигающий штрих. Он показывает, куда в следующий момент будет вводиться текст либо вставляться иллюстрация или таблица. Высота курсора равна текущей высоте шрифта, если включено курсивное начертание, курсор отображается наклонным, а если нет — прямым.

Текстовый курсор отображается в рабочем поле текстового документа сразу после его создания или загрузки. Абзац, в котором находится курсор, считается текущим.

На поле чертежа или фрагмента текстовый курсор появляется в специальной рамке после вызова команды создания надписи (см. раздел 3.4.1.1.1) или таблицы (4.2.4.1).

Положение текстового курсора в текущем окне документа сохраняется неизменным при переходе в другие окна. При загрузке документа курсор автоматически устанавливается в позицию начала текста.

Перемещать текстовый курсор можно как с помощью мыши, так и с помощью клавиатуры. Для управления курсором используются клавиши, представленные в таблице 4.1.1.

Табл. 4.1.1. Клавиши управления текстовым курсором
Клавиша/Клавиши | Назначение
<←> | На одну позицию влево
<→> | На одну позицию вправо
<↓> | На одну строку вниз
<↑> | На одну строку вверх
<Page Up> | В верхнюю строку текущего окна
<Page Down> | В нижнюю строку текущего окна
<Home> | В начало строки
<End> | В конец строки
<Ctrl>+<←> | К началу предыдущего слова
<Ctrl>+<→> | К началу следующего слова
<Ctrl>+<↑> | В начало текущего абзаца; если курсор находился в начале абзаца, то — в начало предыдущего абзаца.
<Ctrl>+<↓> | В начало следующего абзаца. Из начальной позиции последнего абзаца курсор перемещается в конец этого абзаца.
<Ctrl>+<Home> | В начало первого абзаца
<Ctrl>+<End> | В конец последнего абзаца
<Tab> | Перемещение вправо на заданную величину табуляции
<Enter> | Начать следующий абзац
<Ctrl>+<Enter> | Начать следующий абзац на новой странице (т.е. вставить принудительный разрыв страницы)
<Shift>+<Enter> | Начать новую строку в текущем абзаце (т.е. вставить принудительный разрыв строки)

При использовании клавиш <Page Up> и <Page Down> курсор позиционируется в текущую позицию первой или последней строки окна соответственно. При переходе на нужную страницу с помощью поля Текущая страница (см. раздел 1.4.1.5) курсор позиционируется в текущую позицию первой строки указанной страницы.

При прокрутке текста с помощью мыши положение курсора в тексте остается неизменным.

В режиме ввода текста на чертеже действие клавиш распространяется только на текущий фрагмент текста (он ограничен тонкой габаритной рамкой). Для перехода в этот режим следует дважды щелкнуть мышью на нужной надписи. Курсор остается в той позиции, где он находился в момент двойного щелчка мышью.


4.1.2. Приемы работы

4.1. Текстовый редактор

4.1.2. Приемы работы

Данный раздел посвящен приемам работы, которые используются при вводе и редактировании большинства надписей в документах КОМПАС-3D.

В этом разделе:

4.1.2.1. Выбор шрифта и установка его параметров

4.1.2.2. Редактирование текста, режимы вставки и замены

4.1.2.3. Выделение фрагментов текста

4.1.2.4. Копирование и перенос текста через буфер

4.1.2.5. Форматирование текста

4.1.2.5.1. Изменение параметров абзаца

4.1.2.5.2. Смена регистра символов

4.1.2.6. Язык текста

4.1.2.6.1. Выбор языка

4.1.2.6.2. Смена символов на латинские или кириллические

4.1.2.7. Стили текста

4.1.2.7.1. Выбор текущего стиля текста

4.1.2.8. Символы форматирования

4.1.2.9. Поиск и замена текста

4.1.2.10. Использование блоков текста

4.1.2.11. Специальные вставки

4.1.2.11.1. Дроби

4.1.2.11.2. Индексы

4.1.2.11.3. Надстроки и подстроки

4.1.2.11.4. Специальные знаки и обозначения

4.1.2.11.5. Символы

4.1.2.11.6. Текстовые шаблоны

4.1.2.11.7. Вертикальный текст

4.1.2.11.8. Иллюстрации

4.1.2.11.9. Вставка отчета в текст

4.1.2.12. Списки

4.1.2.12.1. Создание списков и управление ими

4.1.2.12.2. Настройка параметров списков


4.1.2.1. Выбор шрифта и установка его параметров

При создании различного рода конструкторско-технологической документации, оформляемой в соответствии с требованиями ЕСКД, применяются стандартные чертежные шрифты (именно они используются в поставляемых вместе с системой стилях текста). А для художественного оформления плакатов, проспектов и других аналогичных материалов можно подобрать шрифты самых разных начертаний.

Чтобы подключить новые шрифты к Windows, используйте системную утилиту Панель управления — Шрифты.

Поскольку КОМПАС-3D ориентирован в основном на выпуск технической документации, установка параметров текста несколько отличается от принятой в универсальных текстовых процессорах.

Основным отличием является назначение высоты символов, интервалов и межстрочного расстояния не в пунктах (points), а в миллиметрах, как это принято на чертежах.

В режиме работы с текстом название текущего шрифта и пример его начертания отображаются в соответствующих полях Панели свойств.

Чтобы задать параметры текущего шрифта, вызовите команду Шрифт.

На экране появится диалог, позволяющий установить параметры текущего шрифта (рис. 4.1.1).

Рис. 4.1.1. Диалог настройки параметров шрифта

Эти же параметры шрифта можно настроить по отдельности, пользуясь элементами инструментальной панели Форматирование (рис. 4.1.2) или вкладки Форматирование Панели свойств (рис. 4.1.3).

Установленные вами параметры шрифта будут использоваться при вводе текста до тех пор, пока вы их не измените.

Рис. 4.1.2. Панель Форматирование

Рис. 4.1.3. Вкладка Форматирование


4.1.2.2. Редактирование текста, режимы вставки и замены

При редактировании введенного текста используются клавиши, представленные в таблице 4.1.2.

Табл. 4.1.2. Клавиши, используемые для редактирования текста
Клавиша | Назначение
<Backspace> | Удаление одного символа слева от курсора1. При удалении самого левого в строке символа курсор переходит в последнюю позицию предыдущей строки.
<Ctrl>+<Backspace> | Удаление одного слова слева от курсора1.
<Delete> | Удаление одного символа справа от курсора1. Если курсор находится перед маркером конца абзаца (см. раздел 4.1.2.8), то нажатие клавиши <Delete> приведет к слиянию двух абзацев.
<Ctrl>+<Delete> | Удаление одного слова справа от курсора1.
<Insert> | Переключение между режимами вставки и замены. В режиме вставки символ вставляется в позицию курсора, раздвигая остальные символы. В режиме замены вводимые символы заменяют символы справа от курсора. Когда включен режим замены, курсор отображается утолщенным для индикации этого режима.
  1. Правая часть строки при этом сдвигается влево.

Для вставки в текст нового абзаца нужно поместить курсор в конец того абзаца, после которого требуется вставить новый, и нажать клавишу <Enter>. Если курсор находится не в конце абзаца, нажатие этой клавиши приведет к разбиению текущего абзаца на два отдельных абзаца.

Чтобы удалить несколько слов или строк подряд, выделите их и нажмите клавишу <Delete> или вызовите команду Редактор — Удалить.


4.1.2.3. Выделение фрагментов текста

Чтобы распространить действие какой-либо команды на некоторую часть текста (например, при задании высоты символов), нужно предварительно выделить эту часть.

Чтобы выделить произвольный фрагмент текста, установите указатель мыши в начало этого фрагмента, нажмите левую кнопку мыши и перемещайте выделение в нужном направлении, не отпуская кнопки. Символы выделенного текста отображаются инверсным цветом.

Выделить одно слово можно двойным щелчком мыши на нем, а выделить предложение — щелчком на нем с нажатой клавишей <Ctrl>.

Чтобы выделить одну или несколько строк текста, поместите курсор мыши слева от границы поля ввода (см. рис. 4.1.5) напротив первой строки, которую требуется выделить. Когда вид курсора изменится, нажмите левую кнопку мыши и перемещайте мышь вниз до тех пор, пока не будет выделено нужное количество строк.

Можно также выделять текст с помощью клавиатуры. Установите курсор в то место, откуда вы хотите начать выделение, нажмите клавишу <Shift> и, не отпуская ее, нажимайте клавиши со стрелками для выделения в нужном направлении либо щелкните мышью в конечной позиции выделения.

Для выделения текста по словам используйте комбинации клавиш <Ctrl>+<Shift>+<←> и <Ctrl>+<Shift>+<→>.

Для изменения границ выделения щелкните мышью в новой конечной позиции с нажатой клавишей <Shift>.

Для выделения всего текста вызовите команду Редактор — Выделить все или нажмите комбинацию клавиш <Ctrl>+<A>.

Чтобы отменить выделение, щелкните левой кнопкой мыши в любом месте текущего окна, или нажмите одну из клавиш управления курсором, или нажмите клавишу <Esc>.


4.1.2.4. Копирование и перенос текста через буфер

Копирование и перенос текста через буфер возможно как в одном и том же документе, так и между разными документами КОМПАС-3D.

Чтобы скопировать или перенести фрагмент текста, выделите его и поместите в буфер обмена. Затем установите курсор в то место, куда требуется вставить этот фрагмент, и выполните вставку из буфера. Подробнее о работе с буфером обмена см. раздел 3.1.2.5.

Вставленный из буфера фрагмент текста появится на экране, начиная с текущей позиции курсора. При вставке строки будут раздвинуты, а курсор сместится за последний вставленный из буфера символ.

Если вам нужно поместить в текст несколько копий текста из буфера, повторите команду вставки нужное количество раз. При этом, разумеется, нужно устанавливать курсор в новое место для вставки следующей копии.

При копировании и переносе фрагментов текста используется буфер обмена Windows. Поэтому с помощью буфера возможен перенос текста между документами КОМПАС-3D и документами других приложений Windows. Так, например, чтобы перенести текст из документа MS Word, нужно выделить в этом документе нужный фрагмент текста, скопировать его в буфер, затем переключиться в КОМПАС-3D и вставить текст из буфера в свой документ.

Стиль и некоторые параметры форматирования, примененные к тексту, не передаются при копировании этого текста через буфер обмена. Вы можете отформатировать вставленный текст средствами текстового процессора КОМПАС-3D.


4.1.2.5. Форматирование текста

Текстовые абзацы имеют ряд параметров, обуславливающих их внешний вид. К параметрам абзаца относятся:

– шаг строк,

– левый и правый отступы,

– интервалы перед абзацем и после абзаца,

– способ выравнивания текста:

• по левой границе,

• по центру,

• по правой границе,

• по всей ширине в границах текста,

– параметры табуляции.

Эти параметры присущи каждому абзацу и в любое время могут быть изменены.

Кроме того, всему абзацу или некоторым его фрагментам можно назначить определенные параметры шрифта (см. раздел 4.1.2.1).

Перечисленные параметры абзаца вместе с параметрами шрифта могут быть объединены в стиль текста. Стиль может быть настроен один раз и сохранен, а затем многократно использован для быстрого форматирования документов (см. раздел 4.1.2.7).

Возможно, при оформлении документов вам достаточно часто приходится использовать различные параметры шрифтов и абзацев. Чтобы во время ввода текста не отвлекаться на их настройку, рекомендуется набрать весь документ основным шрифтом в едином стиле. Затем, выделяя нужные абзацы или другие фрагменты текста, можно задать для них необходимые параметры шрифта и абзаца или назначить им определенные стили текста.

В этом разделе:

4.1.2.5.1. Изменение параметров абзаца

4.1.2.5.2. Смена регистра символов


4.1.2.5.1. Изменение параметров абзаца

Грамотная настройка параметров абзацев позволяет придать текстовому документу выразительность и сделать его более удобным для восприятия.

Чтобы изменить текущие параметры абзаца, вызовите команду Параметры абзаца.

На экране появится диалог, позволяющий установить параметры текущего абзаца (рис. 4.1.4). Элементы управления этого диалога представлены в таблице 4.1.3.

Рис. 4.1.4. Диалог настройки параметров абзаца

Табл. 4.1.3. Диалог настройки параметров абзаца
Элемент | Описание
Шаг строк | Расстояние между строками в абзаце. Изменение шага строк позволяет сохранять пропорциональность расстояний между строками, набранными шрифтом с различной высотой символов (например, при включении в текст каких-либо сносок, комментариев или примечаний, набранных более мелким по сравнению с основным текстом шрифтом).
Красная строка | Отступ первой строки абзаца. Это расстояние измеряется от границы текста (см. рис. 4.1.5). При создании нового абзаца курсор автоматически устанавливается в позицию с заданным отступом.
Отступы | Расстояния между левой и правой границами поля ввода и соответствующими границами текста (см. рис. 4.1.5).
Интервал | Расстояние между двумя соседними абзацами. Оно складывается из двух величин — интервала после первого абзаца и интервала перед вторым абзацем. Установка интервалов позволяет выделить абзацы в текстовом документе для их наилучшего восприятия при чтении, а также для привлечения внимания к особо важной информации.
Выравнивание | Группа переключателей, позволяющая установить способ выравнивания абзацев (см. табл. 4.1.4).
Располагать с новой страницы | Опция, включение которой позволяет принудительно расположить абзац на новой странице.
Табуляция... | Кнопка для вызова диалога настройки параметров табуляции. Его элементы управления описаны в таблице 4.1.5.

Рис. 4.1.5. Расположение текста на странице

Табл. 4.1.4. Способы выравнивания абзацев
Способ | Описание
Влево | Все строки абзаца начинаются строго у левой границы текста1. Концы строк при этом не выравниваются.
Вправо | Все строки абзаца заканчиваются строго у правой границы текста. Начала строк при этом не выравниваются. Типичный пример выравнивания текста вправо — адрес и дата в письмах.
По центру | Текст абзаца располагается симметрично относительно границ текста. Этот способ выравнивания обычно применяется к заголовкам.
По всей ширине | Строки абзаца начинаются у левой границы текста1, а заканчиваются у правой границы. Растяжение строк происходит за счет автоматического увеличения ширины пробелов. Этот способ выравнивания наиболее часто применяется к основному тексту документа.
  1. Положение начала первой строки абзаца задается значением красной строки (см. рис. 4.1.5).

Табл. 4.1.5. Элементы управления диалога настройки табуляции
Элемент | Описание
Позиция | Положение отступа табуляции в миллиметрах.
Заполнение | Список, позволяющий выбрать способ заполнения табуляции.
Выравнивание | Группа переключателей, управляющая способом выравнивания текста относительно позиции табуляции (табл. 4.1.6). Выравнивание текста с помощью табуляций может использоваться, например, при формировании оглавлений.
Установить | Кнопка, позволяющая добавить настраиваемую табуляцию в список.
Удалить | Кнопка, позволяющая удалить выделенную табуляцию.
Удалить все | Кнопка, позволяющая очистить сразу весь список табуляций.

Табл. 4.1.6. Способы выравнивания текста относительно позиции табуляции
Способ | Описание
Влево | Часть строки, введенная после табуляции, располагается справа от ее позиции.
По центру | Часть строки, введенная после табуляции, располагается симметрично относительно ее позиции.
Вправо | Часть строки, введенная после табуляции, располагается слева от ее позиции.
По десятичной точке | В позиции табуляции располагается точка, введенная в любом месте строки после табуляции.

После установки параметров абзаца закройте диалог. Текущий и вводимые после него абзацы будут оформлены и выровнены в соответствии со сделанной настройкой.

Если перед вызовом команды имелись выделенные абзацы текста, то действие настроек форматирования распространяется только на эти абзацы.

Некоторые параметры абзаца можно настроить по отдельности, пользуясь элементами инструментальной панели Форматирование или вкладки Форматирование Панели свойств (рис. 4.1.2, 4.1.3).

Чтобы перенести следующий за курсором текст в начало новой страницы (т.е. вставить в позицию курсора разрыв страницы), нажмите комбинацию клавиш <Ctrl> + <Enter>.


4.1.2.5.2. Смена регистра символов

Если вы забыли своевременно переключить регистр (т.е. ввели несколько букв заглавными вместо строчных или наоборот), выделите ошибочно набранный фрагмент и вызовите команду или нажмите комбинацию клавиш:

Перевести в верхний регистр — комбинация клавиш <Ctrl> + <Shift> + <U>,

Перевести в нижний регистр — комбинация клавиш <Ctrl> + <Shift> + <D>.

По умолчанию команды Перевести в верхний регистр и Перевести в нижний регистр не присутствуют ни в одном меню и ни на одной панели. При необходимости вы можете добавить эти команды в меню или на любую панель (см. раздел 9.4.2.1).


4.1.2.6. Язык текста

Документ или объект может содержать тексты на разных языках. Язык является одним из свойств текста. Признак языка может быть присвоен тексту при вводе или редактировании. Для написания отдельных терминов, например, сокращений из латинских букв, выбор того или иного языка в качестве признака не является принципиальным — важно, чтобы необходимые символы имелись в используемом шрифте. Но для проверки правописания слов, пояснений, текстов присвоение признака языка дает возможность использования словаря этого языка.

Подробно о проверке текстов на различных языках рассказано в разделе 4.1.3.1.

В этом разделе:

4.1.2.6.1. Выбор языка

4.1.2.6.2. Смена символов на латинские или кириллические


4.1.2.6.1. Выбор языка

По умолчанию вводимый с клавиатуры текст имеет признак текущего языка операционной системы Windows (проще говоря, языка раскладки клавиатуры).

Чтобы ввести текст на другом языке, следует переключить раскладку клавиатуры и начать ввод.

Признак языка отображается в поле Язык на вкладке Форматирование Панели свойств (см. рис. 4.1.3). Если в документе находится текст на другом языке, например, вставленный откуда-либо через буфер обмена, то он по умолчанию имеет признак Без проверки. Вы можете присвоить тексту признак языка, выделив этот текст и выбрав нужный вариант из списка Язык.

Раскрывающийся список Язык служит только для выбора языка словаря, который будет использоваться при проверке правописания. Язык текста при помощи этого списка изменить нельзя.


4.1.2.6.2. Смена символов на латинские или кириллические

При вводе смешанного текста, в котором встречаются слова как на русском, так и на других языках (набираемые латинскими буквами), можно легко ошибиться — набрать несколько слов не теми символами. В текстовом процессоре КОМПАС-3D предусмотрены команды для смены символов кириллицы на символы латинского алфавита и наоборот.

Для такого перевода следует выделить нужный фрагмент текста и вызвать команду или нажать комбинацию клавиш:

Перевести в русский регистр — комбинация клавиш <Ctrl> + <Shift> + <R>,

Перевести в латинский регистр — комбинация клавиш <Ctrl> + <Shift> + <L>.

Преобразование будет выполнено в соответствии с клавиатурной раскладкой символов, поддерживаемой установленным на вашем компьютере драйвером клавиатуры. Тексту, преобразованному в символы русского регистра, автоматически присваивается признак русского языка, а тексту, преобразованному в символы латинского регистра — признак английского языка.

По умолчанию команды Перевести в русский регистр и Перевести в латинский регистр не присутствуют ни в одном меню и ни на одной панели. При необходимости вы можете добавить эти команды в меню или на любую панель (см. раздел 9.4.2.1).


4.1.2.7. Стили текста

Как уже говорилось выше, стиль текста — это совокупность параметров абзацев и шрифта. Стиль текста полностью определяет его внешний вид.

Конечно, можно форматировать каждый абзац текста по отдельности, изменяя различные параметры. Но вряд ли это целесообразно при создании больших многостраничных текстовых документов с заранее известными требованиями к оформлению. Для таких документов удобнее всего использовать готовый набор стилей, включающий стили обычного текста документа, ячейки таблицы, заголовка раздела, и т.п.

Для чертежей могут использоваться свои специфические текстовые стили (такие как текст на чертеже, текст в размерных надписях, на полках линий-выносок, текст в технических требованиях и т.п.).

В состав дистрибутива КОМПАС-3D входят готовые (системные) стили для создания текстового документа и для ввода текста и специальных обозначений на чертеже. Кроме того, вы можете создавать собственные стили, при необходимости используя системные стили в качестве прототипа.

Стили текстов могут храниться:

– непосредственно в текстовых документах (внедренные стили),

– в библиотеках стилей (библиотечные стили),

– в наборах стилей.

Каждая библиотека стилей хранится в отдельном файле с расширением lts. Использование стилей из библиотек возможно, если во время работы есть доступ к файлам этих библиотек (в том числе и по локальной сети).

Библиотечные стили, использованные при создании текстового документа, не сохраняются в этом документе. Поэтому при передаче документа на другое рабочее место или на другое предприятие необходимо передать вместе с ним и нужные библиотеки стилей.

Наборы стилей хранятся в конфигурационном файле *.cfg. После применения стиля из набора он копируется в документ, т.е. становится внедренным стилем.

Использование стилей при создании и оформлении текстовых документов и чертежей имеет ряд несомненных преимуществ перед раздельным форматированием, поскольку обеспечивает:

– Единство оформления всей документации в строгом соответствии с требованиями ЕСКД или другими требованиями (стандарты предприятия, отрасли и т.п.).

– Сокращение времени на оформление документации.

– Сокращение времени на корректировку оформления каких-либо элементов документации. Например, для изменения шрифта во всех заголовках достаточно отредактировать стиль, применявшийся для создания этих заголовков, а не форматировать каждый заголовок отдельно.

Возможно задание так называемого расширенного стиля текста, в котором дополнительно определяются параметры текста (высота шрифта, коэффициент сужения и шаг строк) для первых трех строк в ячейке таблицы.

Расширенный стиль текста используется в основном для описания различных случаев ввода текста в графы основных надписей документа (в ячейки таблицы с фиксированными габаритами). При этом можно указывать, какими будут параметры текста при вводе в графу одной, двух или трех строк. При вводе в графу большего, чем три, количества строк используются настройки обычного (не расширенного) стиля текста.

В этом разделе:

4.1.2.7.1. Выбор текущего стиля текста


4.1.2.7.1. Выбор текущего стиля текста

Название текущего стиля текста отображается в поле Стиль текста (рис. 4.1.6).

Если выделено несколько абзацев, оформленных различными стилями, то поле пусто.

Если параметры абзаца или шрифта у выделенного текста (или какой-либо его части) отличаются от установленных в стиле, то перед названием стиля в поле Стиль текста отображается «звездочка». Чтобы устранить несоответствия, т.е. привести параметры текста к стилевым, следует нажать комбинацию клавиш <Ctrl> + <Пробел> или повторно применить к абзацу (абзацам) прежний стиль.

Рис. 4.1.6. Поле Стиль текста на Панели свойств

Чтобы выбрать стиль для текущего или выделенных абзацев, выполните следующие действия.

1. Раскройте список стилей, нажав кнопку со стрелкой в правой части поля Стиль текста.

В списке отображаются названия системных стилей текста, доступных в активном документе.

2. Выберите из списка нужный стиль.

Текущий или выделенные абзацы будут переформатированы в соответствии с выбранным стилем.

Если к тексту требуется применить не системный стиль, а стиль из внешней библиотеки или создать и использовать новый стиль, выберите в списке стилей строку Другой стиль... или вызовите команду Стиль текста.

На экране появится диалог выбора стиля текста (рис. 4.1.7). На вкладках диалога отображаются списки стилей. Стили в списках могут быть отсортированы по именам или по номерам. Чтобы изменить сортировку, щелкните мышью по заголовку нужного столбца.

Элементы управления диалога выбора стиля текста представлены в таблице 4.1.7.

Рис. 4.1.7. Диалог выбора стиля текста

Табл. 4.1.7. Диалог выбора стиля текста
Элемент | Описание
Системные | В поле этой вкладки отображается список системных стилей. Они доступны в любом документе КОМПАС-3D.
Внедренные | В поле этой вкладки отображается список стилей, хранящихся внутри текущего документа. Они могут быть созданы непосредственно в документе или взяты из набора.
Библиотечные | В поле этой вкладки отображается список стилей текста, взятых из внешних библиотек стилей.
Показать | Группа кнопок, служащая для просмотра списков стилей (см. табл. 4.1.8).
Новый | Эта кнопка доступна, если активна вкладка Внедренные, т.е. при просмотре стилей, находящихся в текущем документе или наборе. Она позволяет создать новый стиль текста, который будет храниться внутри текущего документа или в наборе.
Выбрать | Позволяет назначить абзацу стиль, выделенный в списке. Чтобы выбрать стиль, можно также дважды щелкнуть мышью на его названии. Диалог выбора стиля закроется.

Табл. 4.1.8. Кнопки для просмотра групп стилей
Кнопка | Описание
Набор | Нажмите эту кнопку для просмотра стилей, хранящихся в созданном ранее наборе. Содержимое выбранного набора отображается на вкладке Внедренные.
Библиотеки | Нажмите эту кнопку для открытия внешней библиотеки и просмотра стилей, хранящихся в ней. Содержимое выбранной библиотеки отображается на вкладке Библиотечные.
Документ | Нажмите эту кнопку для просмотра системных стилей. Они отображаются на вкладке Системные.


4.1.2.8. Символы форматирования

Специальные символы форматирования — символы табуляции, пробела и маркера конца абзаца. Они не выводятся на печать и служат для управления текстом.

Символ табуляции вставляется в текст при нажатии клавиши <Tab>.

Символ пробела — точка в середине высоты строки, появляющаяся при нажатии на клавишу пробела.

Маркер конца абзаца — специальный символ, несколько похожий на изображение нотного знака. Он вставляется в текст при нажатии клавиши <Enter> и обозначает конец введенного абзаца. Дальнейший ввод текста будет производиться в новом абзаце.

Управление отображением описанных служебных символов производится командой Символы форматирования.


4.1.2.9. Поиск и замена текста

Текстовый процессор КОМПАС-3D предоставляет возможность автоматизированного поиска и замены фрагментов текста. Искать и заменять можно отдельные символы, слова или произвольную часть строки (подстроку).Автоматизированная замена текста позволяет быстро исправить многократно встречающееся в документе слово или выражение (например, обозначение детали).

Чтобы найти подстроку, вызовите команду Редактор — Найти.... На экране появится диалог (рис. 4.1.8, а), в котором следует ввести искомый текст и задать критерии поиска.

Чтобы найти подстроку и заменить ее другой, вызовите команду Редактор — Заменить.... На экране появится диалог настройки параметров поиска и замены (рис. 4.1.8, б).

Элементы управления диалога поиска и диалога поиска и замены текста представлены в таблице 4.1.9.

Рис. 4.1.8. Диалог задания параметров: а) поиска текста, б) поиска и замены текста
а) | б)

Табл. 4.1.9. Элементы управления диалогов поиска и замены текста
Элемент | Описание
Найти: | Поле для ввода подстроки, которую требуется найти в тексте.
Заменить на: | Поле для ввода подстроки, которую требуется вставить в текст вместо найденной. Присутствует только в диалоге поиска и замены текста.
Различать регистр | Опция, позволяющая учитывать регистр символов. Если она включена, то при поиске будут различаться строчные и прописные символы. Так, например, подстроки «ГОСТ» и «Гост» будут восприниматься как разные.
Только полное слово | Включите эту опцию для поиска набора символов, составляющего отдельное слово (не являющееся частью другого). Это поможет избежать ненужных повторов в случае, если введенное слово может являться частью других слов.
Запрос на замену | Включите эту опцию, чтобы система запрашивала подтверждение на замену каждой найденной подстроки. Присутствует только в диалоге поиска и замены текста.
Направление | Группа переключателей, управляющая направлением поиска. Если активен переключатель Вперед, то поиск ведется по ходу документа, а если активен переключатель Назад, то в обратном направлении.
Начало поиска | Группа переключателей, позволяющая задать начало поиска. Если активен переключатель От курсора, то поиск начнется с текущего положения курсора. Если активен переключатель Граница текста, поиск начнется от одной из границ текста в зависимости от выбранного направления (от верхней границы, если активен переключатель Вперед и от нижней, если активен переключатель Назад).
Замена... | Кнопка вызова диалога поиска и замены текста. Присутствует только в диалоге поиска текста.
Заменить все | Кнопка, позволяющая заменить сразу все вхождения указанной подстроки. Присутствует только в диалоге поиска и замены текста.

Чтобы начать поиск или поиск и замену, нажмите кнопку OK. После этого производится однократный поиск или замена. Найденная или уже замененная подстрока выделяется в тексте.

Чтобы повторить поиск или поиск и замену с теми же параметрами, вызовите команду Редактор — Продолжить (или нажмите клавишу <F3>). Если поиск и замена выполняются при нажатой кнопке Заменить все, вызов этой команды не требуется.

Если искомая подстрока не найдена, на экране появится сообщение об этом.

Подстроки, введенные для поиска и замены, хранятся в памяти до конца сеанса работы. Поэтому при необходимости их можно выбирать из списка, а не вводить заново.

Команду замены текста можно использовать для быстрого удаления из текста заданной подстроки. Для этого введите искомую подстроку в поле Найти:, а поле Заменить на: оставьте пустым.

Поиск и замена текста в таблице производится в пределах текущей ячейки.


4.1.2.10. Использование блоков текста

Текстовый процессор КОМПАС-3D предоставляет возможность сохранять и загружать текст блоками.

Чтобы записать какой-либо непрерывный блок текста в отдельный файл на диске, выполните следующие действия.

1. Выделите нужный фрагмент текста.

2. Вызовите команду Сохранить блок.

3. В появившемся на экране диалоге задайте папку и имя файла для записи.

По умолчанию блок сохраняется в текстовом документе КОМПАС-3D — файле с расширением kdw. При необходимости вы можете выбрать для записи формат txt.

Чтобы загрузить в документ текст из файла *.kdw, *.txt или *.rtf, выполните следующие действия.

1. Установите курсор в то место, куда следует вставить блок текста.

2. Вызовите команду Загрузить блок.

3. В появившемся диалоге укажите папку и имя файла. Текст, содержащийся в выбранном файле, будет вставлен в активный документ.


4.1.2.11. Специальные вставки

Поскольку текстовый процессор КОМПАС-3D создан специально для разработки технической документации, он содержит команды, позволяющие вставлять различные объекты в текстово-графические документы и в надписи на чертежах.

Команды, позволяющие реализовать специальные вставки, сгруппированы в меню Вставка, а кнопки для их вызова — на панели Вставка в текст (рис. 4.1.9).

Рис. 4.1.9. Панель Вставка в текст

Кроме того, вызов команд возможен с помощью элементов управления, расположенных на вкладке Вставка Панели свойств (рис. 4.1.10).

Рис. 4.1.10. Вкладка Вставка

В этом разделе:

4.1.2.11.1. Дроби

4.1.2.11.2. Индексы

4.1.2.11.3. Надстроки и подстроки

4.1.2.11.4. Специальные знаки и обозначения

4.1.2.11.5. Символы

4.1.2.11.6. Текстовые шаблоны

4.1.2.11.7. Вертикальный текст

4.1.2.11.8. Иллюстрации

4.1.2.11.9. Вставка отчета в текст


4.1.2.11.1. Дроби

Вы можете вставлять в текст дроби различной высоты — полной, средней и малой. Они отличаются друг от друга высотой символов числителя и знаменателя (табл. 4.1.10).

Табл. 4.1.10. Размер символов в дробях и индексах различной высоты
Высота объекта | Высота символов от высоты символов текущего шрифта, %
Полная | 100
Средняя | »67
Малая | »45

После вызова команды вставки дроби в текущей позиции курсора появляется разделительная черта дроби, а сам курсор переходит в позицию для ввода числителя. Переход к вводу знаменателя осуществляется щелчком мыши под чертой дроби или нажатием клавиши <→> при нахождении текстового курсора на последней позиции в числителе.

При вводе дроби центрирование числителя и знаменателя выполняется автоматически. Размер разделительной черты всегда соответствует выражению наибольшей длины (в числителе или в знаменателе).

При перемещении курсора с помощью клавиш <→> и <←> по строке, содержащей дробь, действуют следующие правила.

– При движении слева направо курсор проходит сначала через числитель, а затем через знаменатель.

– При движении справа налево курсор проходит сначала через знаменатель, а затем через числитель.

Возможна вставка дробей в числитель и знаменатель существующей дроби — создание вложенных («многоэтажных») дробей.

Если перед вызовом команды вставки дроби был выделен фрагмент строки, он преобразуется в числитель дроби. Знаменатель следует ввести обычным образом.

Рис. 4.1.11. Пример использования дроби полной высоты


4.1.2.11.2. Индексы

Вы можете вставлять в текст надстрочные и подстрочные индексы различной высоты — полной, средней и малой. Они отличаются друг от друга высотой символов (табл. 4.1.10).

После вызова команды вставки индекса курсор переходит в позицию для ввода верхнего индекса. Переход к вводу нижнего индекса осуществляется щелчком мыши в позиции нижнего индекса или нажатием клавиши <→> при нахождении текстового курсора на последней позиции в верхнем индексе.

При перемещении курсора с помощью клавиш <→> и <←> по строке, содержащей индексы, действуют следующие правила.

– При движении слева направо курсор проходит сначала через верхний индекс, а затем через нижний.

– При движении справа налево курсор проходит сначала через нижний индекс, а затем через верхний.

При вставке индекса резервируется место сразу для двух индексов — верхнего и нижнего. На практике же часто требуется ввод только одного индекса. В этом случае позицию другого индекса следует просто оставить пустой. В дальнейшем вы можете заполнить ее, не вызывая заново команду вставки, а просто поместив курсор в позицию нужного индекса.

Индексы автоматически выравниваются по левой границе, за которую принимается положение курсора перед началом вставки индексов.

Возможна вставка индексов в позиции существующих индексов — создание вложенных индексов.

Если перед вызовом команды вставки индекса был выделен фрагмент строки, он преобразуется в верхний индекс. Нижний индекс можно ввести обычным образом.

Рис. 4.1.12. Пример использования индексов


4.1.2.11.3. Надстроки и подстроки

Вставка над- и подстрок является разновидностью вставки индексов. Отличие заключается в том, что строка-основание может иметь различную высоту, а верхние и нижние индексы центрируются относительно строки-основания.

Вы можете вставить подстроку с нормальным основанием, высота символов которого равна высоте символов текущего шрифта, и с увеличенным основанием, высота символов которого составляет »150 % от высоты символов текущего шрифта. Высота индексов постоянна и составляет »45 % от высоты символов текущего шрифта.

Область применения команд вставки над- и подстрок — написание различных обозначений, математических формул и т.д.

После вызова команды вставки над/подстроки, курсор остается на месте — можно начинать ввод строки-основания. Переход от ввода основания к вводу надстроки выполняется клавишей <→> при нахождении текстового курсора в последней позиции основания, переход из надстроки в подстроку — также клавишей <→> при нахождении текстового курсора в последней позиции надстроки.

При перемещении курсора с помощью клавиш <→> и <←> по строке, содержащей над/подстроки, действуют следующие правила.

– При движении слева направо курсор проходит сначала строку-основание, потом надстроку, а затем подстроку.

– При движении справа налево курсор проходит сначала подстроку, потом надстроку, а затем строку-основание.

Если перед вызовом команды вставки над/подстроки был выделен фрагмент строки, он преобразуется в строку-основание. Над- и подстроки можно ввести обычным образом.

Рис. 4.1.13. Пример выражения с применением вставки над- и подстроки

Вставки дробей, индексов, над- и подстрок могут применяться при формировании различных выражений как по отдельности, так и в различных сочетаниях.

Рис. 4.1.14. Пример формулы, введенной с помощью нескольких команд вставки


4.1.2.11.4. Специальные знаки и обозначения

Чтобы вставить в текст спецзнак (например, конструкторско-технологическое обозначение), вызовите команду Спецзнак.

На экране появится диалог выбора спецзнака (рис. 4.1.15). Спецзнаки сгруппированы в разделы. Чтобы просмотреть содержимое раздела, разверните его. Знак или обозначение, название которого выделено в списке, отображается в окне просмотра.

Рис. 4.1.15. Диалог выбора специального знака

Чтобы вставить выделенный спецзнак, нажмите кнопку ОК. Можно также дважды щелкнуть мышью на его названии. Диалог будет закрыт, а выбранный знак — вставлен в текущую позицию курсора.

По умолчанию используются знаки и обозначения, хранящиеся в файле graphic.sss (текстовый файл, содержащий описания спецзнаков). Он поставляется вместе с системой и располагается в подпапке \Sys главной папки КОМПАС-3D.

Чтобы подключить другой файл *.sss, нажмите кнопку Другой набор в диалоге выбора спецзнака.


4.1.2.11.5. Символы

Чтобы вставить в текст специальный символ, вызовите команду Символ.

На экране появится диалог, содержащий таблицу символов (рис. 4.1.16).

Рис. 4.1.16. Пример таблицы символов

Выберите шрифт и набор символов из соответствующих списков. Для ускорения выбора можно нажать на клавиатуре клавишу с первой буквой названия шрифта или набора символов.

Ячейка текущего символа в таблице отображается с черным фоном. Перемещаться по таблице символов можно как с помощью клавиш со стрелками, так и с помощью мыши.

Чтобы вставить выбранный символ в текущую позицию курсора, нажмите кнопку ОК. Можно также дважды щелкнуть левой кнопкой мыши на нужной ячейке таблицы.

Диалог будет закрыт, а выбранный символ — вставлен в текст.

В составе КОМПАС-3D поставляются шесть шрифтов TrueTyрe и четыре векторных шрифта, специально разработанных для написания текстов в соответствии с ЕСКД. Шрифтам присвоены названия GOST tyрe А,GOST tyрe АU, GOST tyрe B, GOST tyрe BU, Symbol tyрe А, Symbol tyрe B. В таблицах этих шрифтов содержатся различные конструкторские и технологические знаки, латинские цифры, буквы греческого и других алфавитов.


4.1.2.11.6. Текстовые шаблоны

Текстовые шаблоны — это фрагменты текстов, хранящиеся во внешних файлах *.tdр. Они содержат различные типовые тексты и служат для автоматизации ввода часто встречающихся строк или обозначений.

Чтобы вставить шаблон в документ, вызовите команду Текстовый шаблон.

На экране появится окно Библиотекаря текстовых шаблонов (рис. 4.1.17).

Рис. 4.1.17. Окно Библиотекаря текстовых шаблонов

Каждая вкладка Библиотекаря соответствует одному файлу шаблонов (*.tdp).

Текстовые шаблоны сгруппированы в разделы, список которых отображается в левой части вкладки. В правой ее части отображается список шаблонов выделенного раздела (вверху) и полный текст выделенного шаблона (внизу).

Вы можете найти нужный шаблон, просматривая разделы. Кроме того, можно воспользоваться поиском. Для этого вызовите команду Редактор — Найти... из меню Библиотекаря. В появившемся на экране диалоге введите искомый фрагмент текста, настройте критерии поиска и нажмите кнопку Найти.

Чтобы вставить нужный шаблон в документ, отметьте его — щелкните мышью по пиктограмме этого шаблона в списке. Шаблон будет отмечен красной «галочкой».

Затем нажмите кнопку Вставить в документ на инструментальной панели Библиотекаря текстовых шаблонов. При необходимости вы можете отметить и вставить несколько шаблонов (в том числе принадлежащих разным разделам и подразделам).

Другой способ вставки шаблона — двойной щелчок мышью по его названию. В этом случае не требуется заранее отмечать нужный шаблон, однако можно вставить только один шаблон.

Вставленный шаблон можно редактировать как обыкновенный текст (см. раздел 4.1.2.2). Информация о том, из какого файла шаблон был вставлен, не сохраняется. Благодаря этому при передаче документов на другие рабочие места не нужно заботиться о передаче файлов текстовых шаблонов.

По умолчанию в окне Библиотекаря текстовых шаблонов открывается файл grарhic.tdр. Этот файл поставляется вместе с КОМПАС-3D и располагается в подпапке \Sys главной папки системы.

Вы можете отредактировать данный файл текстовых шаблонов или создать собственный. Чтобы создать новый файл *.tdр, выполните следующие действия.

1. Вызовите команду Файл — Создать Библиотекаря текстовых шаблонов.

2. Сформируйте структуру (разделы и подразделы) файла с помощью команды Вставка — Раздел.

3. Создайте в разделах шаблоны с помощью команды Вставка — Шаблон.

4. Введите тексты шаблонов. При этом возможно копирование текстов через буфер обмена Windows. Для специальных вставок служат кнопки инструментальной панели Библиотекаря.

5. Закончив создание файла текстовых шаблонов, сохраните его с помощью команды Файл — Сохранить.

В дальнейшем, чтобы получить доступ к пользовательскому файлу текстовых шаблонов, необходимо вызвать команду Библиотекаря Файл — Открыть.


4.1.2.11.7. Вертикальный текст

Чтобы вставить в документ текст, строки которого расположены вертикально, вызовите команду Вертикальный текст.

На экране появится тонкая рамка, ограничивающая фрагмент вертикального текста.

Для удобства работы текст вводится горизонтально.

Автоматический перевод строки не производится, поэтому для переноса текста на новую строку необходимо нажимать клавишу <Enter>.

Остальные приемы ввода, а также приемы редактирования и форматирования при создании вертикального текста такие же, как и при работе с обычным горизонтальным текстом.

После того как нужный текст набран, выйдите из режима ввода вертикального текста, нажав кнопку Создать объект или комбинацию клавиш <Ctrl>+<Enter>.

Введенный текст автоматически размещается вертикально. Он не может быть окружен горизонтальным текстом.

Вертикальное размещение текста чаще всего требуется при заполнении некоторых граф в основных надписях документов.

Для редактирования вертикального текста дважды щелкните по нему мышью.

Текст отобразится горизонтально в контурной рамке и станет доступным для изменения.

При вводе технических требований, текста на чертеже и заполнении основной надписи вставка вертикального текста невозможна.


4.1.2.11.8. Иллюстрации

В текст можно вставить иллюстрацию — КОМПАС-чертеж (*.cdw), КОМПАС-фрагмент (*.frw) или изображение, хранящееся в растровом файле (*.bmp, *.gif, *.jpg, *.png, *.tif, *.tga).

Документ, содержащий вставляемое изображение, называется источником вставки.

– Чтобы вставить чертеж или фрагмент, вызовите команду Фрагмент.

– Чтобы вставить изображение из растрового файла, вызовите команду Рисунок.

В появившемся на экране диалоге открытия файла укажите файл для вставки.

После того как файл будет выбран, в диалоге станет доступна кнопка Параметры. После ее нажатия на экране появится диалог настройки параметров вставки иллюстрации в документ (см. ниже).

Если необходимо, настройте параметры вставки, а затем нажмите кнопку Открыть для выполнения вставки.

Иллюстрация вставляется в отдельный абзац.

Вы можете вставить в текст графический объект из КОМПАС-документа или растровое изображение через буфер обмена.

Вставленную иллюстрацию можно переносить или копировать через буфер, как отдельный символ, а также удалять. Обтекание иллюстрации текстом невозможно.

Вы можете изменить выравнивание иллюстрации относительно границ поля ввода — так же, как и для абзаца (см. раздел 4.1.2.5.1).

При вводе технических требований, текста на чертеже и заполнении основной надписи вставка иллюстраций невозможна.

При вводе таблиц на чертеже возможна вставка фрагментов и растровых изображений.

Настройка параметров вставки

Настройка параметров вставки в текст графического документа или растрового изображения производится в диалоге Параметры вставки (рис. 4.1.18).

Элементы управления этого диалога представлены в таблице 4.1.11.

Рис. 4.1.18. Диалог параметров вставки иллюстрации в текст

Табл. 4.1.11. Диалог параметров вставки графического документа в текст

Элемент

Описание

Имя файла1

В этом поле отображается имя файла, выбранного для вставки.

Справа от поля находится кнопка для выбора другого файла. Она доступна во время редактирования и только для иллюстраций, вставленных внешней ссылкой.

Способ вставки

Группа переключателей, позволяющая выбрать способ вставки файла (см. табл. 4.1.12).

Габариты источника1

В этих полях отображается высота и ширина изображения, выбранного для вставки.

Габариты вставки

В этих полях отображается текущая высота и ширина изображения с учетом масштаба, заданного в поле Масштаб. Для растровых изображений учитывается также разрешение, заданное в поле Разрешение.

Вы можете ввести нужное значение высоты (ширины) вставки с клавиатуры. Соответствующий заданному значению масштаб будет определен автоматически, ширина (высота) вставки будет умножена на полученное значение2.

Масштаб

Поле, позволяющее ввести или выбрать из списка масштаб вставки. В списке доступны также варианты по ширине и по высоте, позволяющие подогнать размеры вставки под ширину или высоту страницы.

После изменения масштаба габариты вставки пересчитываются.

Угол поворота

Список, позволяющий выбрать угол поворота вставки. Доступны углы, кратные 90°.

Разрешение

Только для растровых изображений.

Поле, в котором отображается текущее разрешение изображения. Разрешение доступно для изменения, если в файле-источнике вставки нет информации о разрешении.

После изменения разрешения габариты вставки пересчитываются.

Цветовая палитра1

Только для растровых изображений.

Поле, в котором отображается цветовое разрешение графического файла.
  1. Поле является справочным и недоступно для редактирования.
  2. Расчет выполняется с точностью до 0,01. Получившееся значение масштаба округляется в меньшую сторону. В результате этого конечное значение высоты (ширины) может отличаться от изначально введенного.

Табл. 4.1.12. Способы вставки изображения
Способ | Описание
Взять в документ | Содержимое файла копируется в документ. Связь с источником не сохраняется. Изменения, сделанные в файле-источнике, не отображаются в документе, содержащем вставку. При передаче этого документа на другое рабочее место передача источника вставки не требуется.
Внешняя ссылка | В документе формируется ссылка на файл-источник вставки. Изменения, сделанные в файле-источнике, отображаются во всех документах, содержащих вставки. При передаче этих документов на другое рабочее место требуется также передача источника вставки.

Редактирование вставленных иллюстраций

Вы можете изменить параметры вставки иллюстрации. Для этого дважды щелкните на вставленной в текст иллюстрации или вызовите из ее контекстного меню команду Параметры вставки.... На экране появится диалог Параметры вставки (см выше).

Вы можете отредактировать любые параметры вставки, в том числе сменить файл-источник.

Обратите внимание на то, что изменение способа вставки возможно только для иллюстраций, вставленных внешней ссылкой — их можно взять в документ. Обратное преобразование не доступно.

В контекстном меню вставки растрового изображения присутствуют команды Редактировать с помощью... и Редактировать источник. Их использование подробно рассмотрено в разделе 3.10.3.2.


4.1.2.11.9. Вставка отчета в текст

В текст может быть вставлен отчет по модели или графическому документу.

Для этого вызовите команду Вставить отчет.

После вызова команды на экране появляется диалог открытия файлов. Выберите документ-модель или графический документ, объекты которого будут включены в отчет.

Выбранный документ открывается, одновременно в нем запускается процесс создания отчета.

Выполните действия, предусмотренные в команде Создать отчет. Подробно о создании отчетов рассказано в разделе 5.2.3.

После размещения отчета в документе, из которого вызвана команда Вставить отчет, создание и вставка отчета завершается автоматически.

Отчет вставляется в отдельный абзац. Вставленную таблицу отчета можно редактировать, переносить или копировать через буфер, а также удалять.


4.1.2.12. Списки

При разработке различной технической документации (технических требований, перечней параметров и т.д.) часто бывает необходимо пронумеровать абзацы, т.е. создать списки (рис. 4.1.19). Текстовый процессор КОМПАС-3D содержит специальные средства для создания различного рода списков и перечислений и управления ими.

Рис. 4.1.19. Списки: а) без вложенности, б) вложенный, в), г) вложенные с разными типами номеров
а) | б) | в) | г)

Пронумеровать и выровнять абзацы так, как показано на рисунках, можно вручную. Однако, использование автоматической нумерации гораздо эффективнее как при создании, так и при редактировании списков.

В этом разделе:

4.1.2.12.1. Создание списков и управление ими

4.1.2.12.2. Настройка параметров списков


4.1.2.12.1. Создание списков и управление ими

Существует два способа формирования списков:

– нумерация существующих абзацев;

– нумерация абзацев при вводе.

Первый способ более нагляден, поэтому сначала рассмотрим формирование списка из уже имеющегося текста. Нумерация не меняет ни границ абзацев, ни способа их выравнивания, ни других параметров. Поэтому для улучшения восприятия списка документ можно предварительно отформатировать (см. разделы 4.1.2.1, 4.1.2.5.1, 4.1.2.7).

Чтобы преобразовать несколько абзацев в список, выполните следующие действия.

1. Выделите абзацы, которые требуется пронумеровать.

2. Вызовите команду Установить нумерацию. В начале абзаца появится его порядковый номер, т.е каждый абзац превратится в пункт списка.

Полученный таким образом список не имеет вложенности, т.е. все его пункты находятся на одном — первом — уровне (рис. 4.1.19, а).

При необходимости вы можете перевести некоторые абзацы на следующий уровень, т.е. увеличить вложенность нескольких пунктов списка на единицу (рис. 4.1.19, б). Для этого выделите нужные абзацы и вызовите команду Увеличить вложенность. Нумерация списка соответствующим образом изменится.

Чтобы выполнить обратную операцию — уменьшить существующий уровень нумерации абзацев, выделите их и вызовите команду Уменьшить вложенность.

Формирование списка вторым способом производится в следующем порядке.

1. Введите абзац, являющийся первым пунктом списка.

2. Вызовите команду Установить нумерацию. В начале абзаца появится цифра 1.

3. Установите курсор в последнюю позицию пронумерованного абзаца и нажмите клавишу <Enter>. Будет создан новый абзац со следующим номером — 2.

4. Чтобы увеличить или уменьшить уровень нумерации текущего абзаца, вызовите соответственно команду Увеличить вложенность или Уменьшить вложенность.

5. Введите необходимое количество пунктов списка, располагая их на нужных уровнях.

Чтобы отменить нумерацию текущего абзаца (например, для завершения ввода списка) или выделенных абзацев (например, для преобразования списка в обычный текст), следует повторно вызвать команду Установить нумерацию.

Кнопка Установить нумерацию на панели Форматирование и одноименный переключатель на вкладке Форматирование Панели свойств являются индикаторами наличия у абзаца признака нумерации.

Нередко в одном документе (или надписи на чертеже) необходимо создать несколько независимых списков. Чтобы начать нумерацию заново — с первого уровня и с первого номера, выполните следующие действия.

1. Установите курсор в абзац, являющийся первым пунктом нового списка.

2. Вызовите команду Новый список.

Действие этой команды распространяется только на текущий абзац, поэтому она доступна, если нет выделенных абзацев.

В принципе, ненумерованные абзацы можно считать находящимися на самом верхнем («нулевом») уровне. Поэтому для установки и отмены нумерации абзацев возможно использование команд Увеличить вложенность и Уменьшить вложенность.


4.1.2.12.2. Настройка параметров списков

Параметры списков одинаковы для всего текста. Это обеспечивает единство оформления всех списков, имеющихся в тексте.

Чтобы настроить параметры списков, вызовите команду Параметры списка.

Команда Параметры списка доступна, если курсор находится в списке.

На экране появится диалог с текущими настройками параметров списков (рис. 4.1.20). Элементы управления этого диалога представлены в таблице 4.1.13.

Рис. 4.1.20. Диалог настройки параметров списков

Табл. 4.1.13. Диалог настройки параметров списков
Элемент | Описание
Использовать для | Список, позволяющий указать уровень вложенности списка, на который будет распространяться настройка форматирования. Если номера уровней нужно оформить по-разному (рис. 4.1.20 в, г), следует поочередно выбирать уровни в списке и настраивать оформление для каждого из них отдельно. Максимальное количество уровней — 10.
Текст перед Текст после | Если эти поля заполнены, их содержимое автоматически добавляется к номерам списка. Такая возможность полезна, например, при создании нумерованного списка рисунков (рис. 4.1.21). Чтобы текст из этих полей не дублировался при увеличении вложенности списка, его следует задавать только для тех уровней, где он нужен.
Применить для всех уровней | Если требуется, чтобы номера всех уровней были оформлены одинаково, нажмите эту кнопку.
Начинать нумерацию с позиции | Поле, в котором можно ввести или выбрать из списка номер, с которого требуется начать нумерацию.
Добавлять к номеру верхнего уровня | Опция, управляющая формированием вложенных списков. Если она включена, то номера пунктов данного уровня включают в себя номер последнего пункта предыдущего уровня, например, 2.2.1, 2.2.2. Если опция выключена, то все пункты данного уровня имеют только свои порядковые номера.
Отступ | Величина отступа в миллиметрах и его тип (табл. 4.1.14).
Шрифт | Кнопка, позволяющая настроить параметры шрифта, используемого для номеров пунктов списка. После ее нажатия на экране появится диалог настройки шрифта.
Сбросить | Кнопка, позволяющая вернуться к умолчательным параметрам списков всех уровней.

Табл. 4.1.14. Типы отступов в списках
Тип отступа | Описание
Фиксированный отступ от номера до текста | Расстояние от последнего символа в номере до первого символа первой строки каждого пункта списка постоянно и равно значению, заданному в поле Величина отступа. Расстояние от границы текста до первого символа строки зависит от количества символов в номере.
Фиксированный отступ до начала текста | Расстояние от границы текста до первого символа первой строки каждого пункта списка постоянно и равно значению, заданному в поле Величина отступа. Расстояние от последнего символа в номере до первого символа строки зависит от количества символов в номере.

Рис. 4.1.21. Текст перед номерами первого уровня

При настройке списков для текста на чертеже настройка действует только на этот текстовый объект. Если в чертеже присутствуют другие текстовые объекты такого типа, списки в них не меняются.


4.1.3. Проверка правописания

4.1. Текстовый редактор

4.1.3. Проверка правописания

Программа проверки правописания системы КОМПАС-3D позволяет выполнять проверку правописания текстовых объектов КОМПАС-документов:

– текст текстового документа,

– текст объекта спецификации и таблицы изменений,

– текст основной надписи,

– текст технических требований,

– текст надписей в составе линии-выноски, выносной надписи, фигурной скобки,

– текст на чертеже,

– текст в таблице.

Проверка правописания может быть выполнена:

– во всем документе,

– в текстовом объекте, редактируемом в данный момент.

Доступно два способа проверки:

– автоматическая (см. раздел 4.1.3.2),

– по вызову команды (см. раздел 4.1.3.3).

Проверка по вызову команды может применяться как для всего документа, так и для текстового объекта, редактируемого в данный момент.

Такие текстовые объекты, как текст на чертеже, линия-выноска, выносная надпись, фигурная скобка и таблица, можно выделить перед вызовом команды — тогда проверка будет выполнена только в них. Если ни один объект не выделен, то проверяются все имеющиеся в документе текстовые объекты.

При редактировании отдельного текстового объекта можно выделить его фрагмент перед вызовом команды — тогда будет проверен только этот фрагмент. Если выделенных фрагментов нет, проверяется весь текстовый объект целиком.

Автоматическая проверка доступна только для редактируемого текстового объекта.

Проверка правописания в различных КОМПАС-документах подробно описана в разделе 4.1.3.5.

При проверке правописания необходимо учитывать, что программа может находить не все ошибки, а только наиболее типичные. Поэтому окончательное решение о наличии или отсутствии ошибок должен принимать пользователь.

В этом разделе:

4.1.3.1. Проверка текста на различных языках

4.1.3.2. Автоматическая проверка текста

4.1.3.3. Проверка правописания по вызову команды

4.1.3.4. Настройка параметров проверки правописания

4.1.3.5. Выполнение проверки

4.1.3.5.1. Графический документ

4.1.3.5.2. Текстовый документ

4.1.3.5.3. Спецификация

4.1.3.6. Словари

4.1.3.6.1. Редактирование вспомогательного словаря

4.1.3.6.2. Создание нового вспомогательного словаря

4.1.3.6.3. Подключение существующего вспомогательного словаря

4.1.3.6.4. Добавление слов во вспомогательный словарь при проверке орфографии


4.1.3.1. Проверка текста на различных языках

Документ или объект может содержать тексты на разных языках. Проверка осуществляется по нормам и правилам того языка, признак которого был присвоен тексту при вводе или редактировании.

О вводе текста на разных языках рассказано в разделе 4.1.2.6.

Чтобы проверка на каком-либо языке была возможна, необходимо, чтобы файл словаря для этого языка (*.lex) находился в подпапке \Sys главной папки системы КОМПАС-3D.

Перечень языковых словарей, доступных для использования, отображается в раскрывающемся списке Язык на вкладке Форматирование Панели свойств (см. рис. 4.1.3).

Чтобы узнать, на каком языке будет проверяться текст документа, текст следует выделить. Признак языка отображается в поле Язык.

Пустое поле языка означает, что в выделенном тексте содержатся фрагменты с различными признаками языка. Слова Без проверки означают, что текст не имеет признака языка и останется непроверенным.

Признак языка можно изменить. Например, текст, вставленный из буфера обмена, может не иметь признака языка. Чтобы текст проверялся, признак языка следует присвоить — выделить текст и выбрать язык в раскрывающемся списке.


4.1.3.2. Автоматическая проверка текста

Автоматическая проверка выполняется при редактировании текстового объекта без дополнительных действий со стороны пользователя. Программа проверки производит анализ текста, выявляя слова, в которых предполагается наличие ошибок, а также предложения или их фрагменты, предположительно содержащие ошибки.

Слова, предположительно содержащие орфографические ошибки, по умолчанию подчеркиваются красной волнистой линией, а фрагменты текста, предположительно содержащие грамматические ошибки — зеленой. Текст с признаком «без проверки» подчеркивается серой волнистой линией (цвет подчеркивания можно настроить, см. раздел 9.1.3.5).

Выполнение автоматической проверки можно включить или выключить при настройке программы проверки правописания (см. раздел 4.1.3.4).

Чтобы просмотреть список действий, которые программа проверки правописания предлагает применить к выделенному слову или предложению, вызовите контекстное меню подчеркнутого элемента.

В случае орфографической ошибки с помощью этого меню можно:

– заменить слово,

– добавить проверяемое слово в словарь,

– продолжить проверку, отказавшись от замены,

– выбрать другой язык проверки или признак «без проверки».

В случае грамматической ошибки с помощью этого меню можно:

– получить описание ошибки

• если описание является указанием, например, «Не хватает запятой после слова "но".», то возможно автоматическое исправление согласно описанию,

• если описание является рекомендацией, например, «Предложение перегружено глаголами. Попробуйте...», то автоматическое исправление невозможно;

– продолжить проверку, отказавшись от исправления.


4.1.3.3. Проверка правописания по вызову команды

Для выполнения проверки правописания следует вызвать команду Сервис — Правописание....

После этого для каждого предложения будут последовательно выполнены следующие действия.

1. Орфографическая проверка слов.

2. Грамматическая проверка, если она включена (только для русского языка).

Рис. 4.1.22. Диалог проверки правописания

Если обнаружено отсутствующее в словаре слово, а также если анализ предложения позволяет сделать вывод о наличии грамматических ошибок в нем, на экране появляется диалог Правописание (рис. 4.1.22). Набор элементов управления диалога Правописание представлен в таблице 4.1.15.

Табл. 4.1.15. Элементы управления проверкой правописания

Элемент

Описание

Орфографическая ошибка,

Грамматическая ошибка

Поле, содержащее проверяемое предложение. При орфографической проверке слово, предположительно содержащее орфографическую ошибку, выделено красным цветом. При грамматической проверке часть предложения, предположительно содержащая грамматическую ошибку, выделена зеленым цветом.

Ошибка может быть исправлена непосредственно в данном поле. Для внесения исправлений в исходный текст при орфографической проверке нажмите кнопку Заменить, а при грамматической — кнопку Изменить.

При смене варианта в поле Язык словаря содержимое поля орфографической ошибки изменяется.

Варианты

При орфографической проверке это поле содержит список слов, сходных по написанию с проверяемым, из словарей программы проверки орфографии.

Состав списка определяется только написанием слов, поэтому в него могут быть включены слова, не подходящие по контексту.

Чтобы заменить проверяемое слово вариантом из списка, его следует выделить и нажать кнопку Заменить.

При грамматической проверке это поле содержит краткие описания возможных ошибок. Для внесения исправлений в исходный текст необходимо выбрать вариант и нажать кнопку Изменить.

Замена или исправление выполняется также после двойного щелчка по элементу списка. Если начать редактирование проверяемого слова в поле Орфографическая/Грамматическая ошибка, поле Варианты станет недоступным.

Пропустить

Кнопка, позволяющая пропустить проверяемое слово (при орфографической проверке) или предложение (при грамматической проверке). Оно считается проверенным и не содержащим ошибки. Если начать редактирование проверяемого слова/предложения в поле Орфографическая /Грамматическая ошибка, кнопка Пропустить заменяется кнопкой Отменить правку.

Отменить правку

Кнопка, позволяющая отменить редактирование, выполненное в поле Орфографическая/Грамматическая ошибка. После нажатия кнопки становится доступным поле Варианты.

Пропустить все

Кнопка, позволяющая пропустить проверяемое слово (при орфографической проверке) или предложение (при грамматической проверке). Оно считается проверенным и не содержащим ошибки. Слова такого же написания или предложения с такими же грамматическими ошибками в остальном тексте также полагаются правильными и пропускаются при проверке (даже если выполнялась проверка выделенного фрагмента).

При орфографической проверке кнопка становится недоступна, если производится редактирование в поле Орфографическая ошибка.

Добавить

Кнопка присутствует в диалоге во время орфографической проверки. Она позволяет добавить проверяемое слово во вспомогательный словарь, который назначен умолчательным. При последующих проверках это слово будет предлагаться для замены в списке Варианты. Кнопка недоступна, если производится редактирование в поле Орфографическая ошибка.

Заменить

Кнопка присутствует в диалоге во время орфографической проверки. Она позволяет заменить проверяемое слово в тексте вариантом из списка или словом, отредактированным в поле Орфографическая ошибка. После нажатия кнопки проверка продолжается.

Изменить

Кнопка присутствует в диалоге во время грамматической проверки. Она позволяет отредактировать проверяемое предложение в тексте в соответствии с выбранным вариантом ошибки или заменить исправленным в поле Грамматическая ошибка. После нажатия кнопки проверка продолжается.

Заменить все

Кнопка присутствует в диалоге во время орфографической проверки. Она позволяет заменить проверяемое слово и слова аналогичного написания по всему тексту вариантом из списка или словом, отредактированным в поле Орфографическая ошибка. Уже проверенные слова, например, обработанные командами Пропустить, Заменить, не заменяются. После нажатия кнопки проверка продолжается.

Грамматика

Опция, позволяющая управлять проверкой грамматики. По умолчанию опция включена.

Язык словаря

Элемент управления служит для изменения языка проверяемого слова.

В поле Язык словаря отображается признак языка того слова, которое выделено красным цветом в поле Орфографическая ошибка. В поле Вариант содержится список слов для замены, взятых из языковых и вспомогательных словарей.

Если необходимо, выберите из раскрывающегося списка Язык словаря нужный вариант.

– Если выбран другой язык словаря, то набор слов в поле Вариант изменится. Выберите слово для замены.

– Если выбран вариант Без проверки, то данное слово останется без проверки.

После завершения проверки проверяемые слова будут иметь признаки языков, установленных в диалоге. Слова, для которых была отменена проверка, не будут иметь признака языка.

Параметры...

Кнопка, позволяющая настроить параметры проверки правописания. После вызова команды на экране появится диалог Параметры правописания (см. раздел 4.1.3.4).

Вернуть

Кнопка, позволяющая отменить предыдущее действие по редактированию текста в диалоге Правописание. После отмены последнего редактирования кнопка становится недоступной. Также кнопка недоступна до первой правки текста.

Отмена

Кнопка, позволяющая завершить проверку правописания. После вызова команды диалог Правописание будет закрыт, а внесенные исправления зафиксируются в тексте.


4.1.3.4. Настройка параметров проверки правописания

Настройка параметров проверки правописания выполняется в диалоге Параметры правописания (рис. 4.1.23). Открыть этот диалог можно одним из двух способов:

– Вызвать команду Сервис — Параметры — Система — Текстовый редактор — Параметры правописания.

– Нажать кнопку Параметры в диалоге Правописание.

Элементы управления диалога настройки параметров правописания представлены в таблице 4.1.16.

Рис. 4.1.23. Диалог настройки параметров правописания

Табл. 4.1.16. Диалог настройки проверки правописания
Элемент | Описание
Орфография | Группа элементов управления для настройки орфографической проверки.
Автоматически проверять орфографию | Опция позволяет включить автоматическую проверку орфографии. Слова, предположительно содержащие орфографические ошибки, по умолчанию подчеркиваются красной1 волнистой линией.
Предлагать только из основного словаря | Опция позволяет использовать вспомогательные словари при проверке правописания.
Пропускать слова из прописных букв | Опция позволяет пропускать при проверке орфографии слова, состоящие из заглавных букв.
Пропускать слова с цифрами | Опция позволяет пропускать при проверке орфографии слова, состоящие из букв и цифр.
Пропускать дроби, индексы и надстроки | Опция позволяет пропускать при проверке орфографии дроби, индексы, надстрочный и подстрочный текст.
Пропускать адреса Интернета и имена файлов | Опция позволяет пропускать при проверке орфографии адреса Интернета, электронной почты и имена файлов.
Словари... | Команда позволяет выполнять различные действия со вспомогательными словарями. После вызова команды на экране появится диалог Вспомогательные словари (см. рис. 4.1.25).
Грамматика | Группа элементов управления для настройки грамматической проверки.
Автоматически проверять грамматику | Опция позволяет включить автоматическую проверку грамматики. Предложения или их части, предположительно содержащие орфографические ошибки, по умолчанию подчеркиваются зеленой1 волнистой линией.
Настройка... | Кнопка позволяет настроить параметры грамматической проверки. После вызова команды на экране появится диалог Настройка грамматической проверки (см. рис. 4.1.24 и табл. 4.1.17).
  1. Цвет подчеркивания можно настроить, см. раздел 9.1.3.5.

Рис. 4.1.24. Диалог настройки грамматической проверки

Табл. 4.1.17. Диалог настройки грамматической проверки

Элемент

Описание

Используемый набор правил:

Список, позволяющий выбрать или сформировать стиль (см. табл. 4.1.18), в соответствии с которым будет проверяться текст, или сформировать пользовательский стиль. Каждый из стилей проверки имеет определенный набор используемых грамматических и стилистических правил.

Грамматика

Стиль

В списке названий правил могут одновременно отображаться правила либо для грамматической проверки, либо для стилистической. Для указания типа правил выберите нужный вариант: Грамматика или Стиль.

Чтобы то или иное правило использовалось во время проверки текста, включите опцию слева от названия правила, чтобы отказаться от использования правила — выключите.

Вы можете получить подробную информацию о каждом правиле. Для этого выделите его в списке и нажмите кнопку Пояснения.

Проверять

Группа элементов управления, позволяющая настроить использование некоторых правил литературной правки текста (см. табл. 4.1.19). Для всех трех правил можно задать числовой критерий «строгости» проверки, а для количества слов в предложении — ввести максимальное значение.

Начальная установка

Кнопка, позволяющая вернуть выбранному стилю проверки используемый по умолчанию набор правил. После ее нажатия все изменения стиля, сделанные пользователем, отменяются.

Пояснения

Кнопка, позволяющая просмотреть пояснения к выделенному в списке правилу. После ее нажатия на экране появляется окно с подробным описанием выбранного правила.

Табл. 4.1.18. Стили проверки текста
Стиль | Описание
Строго (все правила) | Полный набор грамматических и стилистических правил.
Для деловой переписки | Набор правил для проверки деловой прозы: корреспонденции, текстов контрактов, научных статей и пр.
Для обычной переписки | Набор правил для проверки неформальных текстов: писем, внутрифирменных докладных записок и пр.
Пользовательский стиль | Набор правил, формируемый пользователем. Чтобы создать произвольный набор правил, выберите один из пользовательских стилей, включите или выключите использование правил по своему усмотрению и закройте диалог, нажав кнопку OK.

Табл. 4.1.19. Правила литературной правки
Правило | Описание
Нанизывание предложно-именных групп | Задает максимально допустимое число идущих подряд сочетаний предлога и существительного.
Нанизывание родительных падежей | Задает максимально допустимое число идущих подряд существительных в родительном падеже.
Согласование относительных местоимений | Задает максимально допустимое число слов между относительным местоимением (который, какой, каковой) и существительным, к которому оно относится.


4.1.3.5. Выполнение проверки

Проверка правописания в КОМПАС-документах различных типов имеет определенные особенности. О них рассказано в разделах 4.1.3.5.1 — 4.1.3.5.2.

В этом разделе:

4.1.3.5.1. Графический документ

4.1.3.5.2. Текстовый документ

4.1.3.5.3. Спецификация


4.1.3.5.1. Графический документ

Проверка правописания в графических документах производится для всех текстовых объектов.

Проверка начинается после вызова команды Сервис — Правописание. Если в каком-либо текстовом объекте обнаружена ошибка, то на экране появляется диалог Правописание (см. рис. 4.1.15 и табл. 4.1.15). Масштаб отображения изменяется: к документу автоматически применяется команда Показать все.

Название текстового объекта, проверяемого в данный момент, добавляется к названию в заголовке диалога. Например, во время проверки текста в таблице заголовок диалога имеет вид Правописание — Таблица, а во время проверки технических требований — Правописание — Технические требования.

Такие текстовые объекты, как текст на чертеже, таблица, линия-выноска, фигурная скобка и выносная надпись во время проверки выделяются в документе.

После закрытия диалога Правописание масштаб отображения документа восстанавливается.


4.1.3.5.2. Текстовый документ

В текстовых документах проверяются:

– текст,

– таблицы,

– основная надпись.

Надписи, имеющиеся во вставленных фрагментах, не проверяются.

Тексты в таблице основной надписи проверяются, если они видны на экране, т.е. если документ отображается в режиме разметки страниц (см. раздел 4.1.4.1). Если показ элементов оформления отключен, т.е. при отображении документа в нормальном режиме, проверяются только текст и таблицы документа.

Проверка начинается после вызова команды Сервис — Правописание. При обнаружении ошибки соответствующий фрагмент текста выделяется, а на экране появляется диалог Правописание (см. рис. 4.1.15 и табл. 4.1.15).

Если перед вызовом команды проверки в документе был выделен фрагмент — часть текста или таблица, то проверка производится только в этом фрагменте. По ее окончании на экране появляется запрос на продолжение проверки в оставшейся части документа.

Если перед вызовом команды ничего не было выделено, то проверка производится от текущего положения курсора до конца документа. Затем проверяется начало документа до того места, где находился курсор в момент вызова команды проверки. Если документ отображается в режиме разметки страниц, то после проверки его содержимого (текста и таблиц) проверяются тексты в таблицах основной надписи.

При необходимости документ прокручивается так, чтобы текст, проверяемый в данный момент, был виден на экране.

Чтобы проверить основную надпись отдельно от содержимого документа, войдите в режим редактирования основной надписи и воспользуйтесь автоматической проверкой (см. раздел 4.1.3.2) или проверкой по вызову команды (см. раздел 4.1.3.3).


4.1.3.5.3. Спецификация

В спецификациях проверяются:

– текст базовых и вспомогательных объектов, в том числе текст объектов, не отображающихся в таблице (объектов с одинаковой текстовой частью, объектов, показ которых отключен вручную, объектов-двойников),

– основная надпись.

Заголовки разделов и текст в дополнительных колонках не проверяются.

Чтобы начать проверку, вызовите команды Сервис — Правописание. При обнаружении ошибки соответствующий фрагмент текста выделяется, а на экране появляется диалог Правописание (см. рис. 4.1.15 и табл. 4.1.15).

Если спецификация отображается в нормальном режиме, то проверяется текст объектов спецификации. При этом:

– если ни один из объектов не редактируется, то проверяются все объекты,

– если редактируется какой-либо объект спецификации, то проверка производится только в нем, при этом:

• если перед вызовом команды проверки был выделен фрагмент текста, то проверяется только этот фрагмент; по окончании проверки на экране появляется запрос на ее продолжение в оставшейся части объекта спецификации,

• если выделенных фрагментов не было, то проверяется весь текст редактируемого объекта спецификации.

Если спецификация отображается в режиме разметки страниц, то сначала проверяется текст объектов спецификации, а затем — текст основной надписи.

Чтобы проверить основную надпись отдельно от содержимого документа, войдите в режим редактирования основной надписи и воспользуйтесь автоматической проверкой (см. раздел 4.1.3.2) или проверкой по вызову команды (см. раздел 4.1.3.3).


4.1.3.6. Словари

Словари используются при орфографической проверке. Они содержат слова заведомо правильного написания. При проверке слова текста сравниваются со словами из словарей.

В комплект поставки входят языковые словари (*.lex), а также пустой вспомогательный словарь (*.dic).

Содержание языковых словарей является предопределенным и не может быть изменено средствами КОМПАС-3D.

Вспомогательный словарь предназначен для добавления узкоупотребительных технических и прочих специальных терминов, имен собственных, сокращений, и т.п., которые не включены в языковый словарь.

Программа проверки правописания позволяет создавать дополнительные вспомогательные словари. Вспомогательный словарь может включать термины на разных языках.

При проверке близкого по написанию слова подходящий термин автоматически отыскивается системой во всех словарях по признаку языка и предлагается для замены. Если одно слово имеет признаки нескольких языков, например, разные части термина, то для замены предлагается слова на языке первого символа.

Вся работа со вспомогательными словарями ведется в диалоге Вспомогательные словари (рис. 4.1.25). Для его вызова служит кнопка Словари... в диалоге настройки правописания (см. раздел 4.1.3.4).

Рис. 4.1.25. Диалог работы со вспомогательными словарями

В этом разделе:

4.1.3.6.1. Редактирование вспомогательного словаря

4.1.3.6.2. Создание нового вспомогательного словаря

4.1.3.6.3. Подключение существующего вспомогательного словаря

4.1.3.6.4. Добавление слов во вспомогательный словарь при проверке орфографии


4.1.3.6.1. Редактирование вспомогательного словаря

Чтобы отредактировать вспомогательный словарь, выполните следующие действия.

1. Вызовите диалог работы со вспомогательными словарями.

2. Выделите в списке словарь, подлежащий редактированию, и нажмите кнопку Изменить.

3. В появившемся на экране диалоге редактирования словаря (рис. 4.1.26) выполните одно из следующих действий:

– чтобы добавить слово, введите его в поле Слово:, а затем нажмите кнопку Добавить,

– чтобы удалить слово, выделите его в поле Словарь:, а затем нажмите кнопку Удалить,

– чтобы изменить слово, удалите его, а затем добавьте, изменив его написание.

Язык слова, помещаемого в словарь, соответствует языку раскладки клавиатуры.

4. Нажмите кнопку Выход.

Рис. 4.1.26. Диалог редактирования вспомогательного словаря


4.1.3.6.2. Создание нового вспомогательного словаря

Чтобы создать вспомогательный словарь, выполните следующие действия.

1. Вызовите диалог работы со вспомогательными словарями.

2. Нажмите кнопку Создать.

3. В появившемся на экране диалоге задайте имя и месторасположение файла словаря. Файлам словарей автоматически присваиваются расширения dic.

4. Нажмите кнопку Сохранить.

Диалог записи файла закроется, а имя созданного словаря появится в списке диалога Вспомогательные словари. Опция рядом с именем словаря показывает, используется ли он при проверке правописания. По умолчанию она включена.

Созданный словарь представляет собой пустой файл. Слова будут добавляться в него при орфографической проверке (см. раздел 4.1.3.6.4).

Если слова добавляются при орфографической проверке, они автоматически вставляются в определенный словарь — словарь по умолчанию.

5. Чтобы назначить словарь умолчательным, выделите его имя в списке и нажмите кнопку По умолчанию.

6. Нажмите кнопку ОК в диалоге Вспомогательные словари.

Чтобы программа проверки правописания обращалась к вспомогательным словарям, необходимо выключить опцию Предлагать только из основного словаря в диалоге настройки параметров правописания (см. табл. 4.1.16).


4.1.3.6.3. Подключение существующего вспомогательного словаря

Вы можете подключить к системе проверки правописания вспомогательные словари, например, предоставленные сторонними разработчиками. Чтобы подключить вспомогательный словарь, выполните следующие действия.

1. Вызовите диалог работы со вспомогательными словарями.

2. Нажмите кнопку Добавить.

3. В появившемся диалоге выберите файл словаря и нажмите кнопку Открыть.

По умолчанию добавленный словарь подключен к системе проверки правописания, то есть опция слева от его имени в списке диалога Вспомогательные словари включена.

4. Чтобы назначить словарь умолчательным, выделите его имя в списке и нажмите кнопку По умолчанию.

5. Нажмите кнопку ОК в диалоге Вспомогательные словари.


4.1.3.6.4. Добавление слов во вспомогательный словарь при проверке орфографии

Чтобы добавить проверяемое слово во вспомогательный словарь во время орфографической проверки, нажмите кнопку Добавить в диалоге Правописание.

Добавляемые слова включаются в определенный вспомогательный словарь — словарь по умолчанию.

Чтобы проверить, какой из вспомогательных словарей является умолчательным или назначить умолчательным другой словарь, выполните следующие действия.

1. Нажмите кнопку Параметры в диалоге Правописание (см. раздел 4.1.3.4).

2. В появившемся на экране диалоге Параметры правописания нажмите кнопку Словари....

На экране появится диалог Вспомогательные словари.

Имя умолчательного словаря в списке дополнено строкой «(по умолчанию)».

3. Чтобы назначить умолчательным другой словарь, выделите его имя и нажмите кнопку По умолчанию. Закройте диалог, нажав кнопку OK.

4. Закройте диалог Параметры правописания.


4.1.4. Создание текстового документа

4.1. Текстовый редактор

4.1.4. Создание текстового документа

Файл текстового документа КОМПАС-3D имеет расширение kdw.

Текстовый документ может состоять из одного или нескольких разделов (см. раздел 4.1.4.4).

Помимо собственно текста, каждый лист текстового документа содержит основную надпись. Вы можете выбрать тип основной надписи для первого листа, четного и нечетного листов. Неотъемлемой характеристикой текстового документа является его формат.

Все эти параметры можно задать для раздела (см. раздел 4.1.4.2).

О нумерации листов в текстовом документе и в разделах рассказано в разделе 4.1.4.5.

Основная надпись текстового документа показывается или не показывается на экране в зависимости от режима отображения документа.

В этом разделе:

4.1.4.1. Режим отображения

4.1.4.2. Оформление и формат

4.1.4.3. Основная надпись

4.1.4.4. Разделы

4.1.4.4.1. Добавление и удаление раздела

4.1.4.4.2. Переключение между разделами

4.1.4.4.3. Изменение порядка следования разделов

4.1.4.5. Нумерация листов

4.1.4.6. Пример создания документа с несколькими разделами


4.1.4.1. Режим отображения

Существует два режима отображения текстового документа:

– обычный,

– режим разметки страниц.

Переключение между обычным режимом и режимом разметки страниц производится с помощью одноименных команд, расположенных в меню Сервис. Можно также воспользоваться кнопками на панели Режимы.

Сразу после создания текстовый документ отображается в обычном режиме: вы видите в окне документа белое поле с изображенной на нем пунктирной прямоугольной рамкой — границей области ввода текста (рис. 4.1.27, а).

В режиме разметки страниц на экране отображается также рамка и основная надпись каждого листа (рис. 4.1.27, б). Иначе говоря, в режиме разметки документ показывается в том виде, в каком он будет напечатан на бумаге.

Рис. 4.1.27. Отображение одной и той же страницы документа: а) в нормальном режиме, б) в режиме разметки страниц
а) | б)

Текст документа можно вводить как в обычном режиме, так и в режиме разметки страниц.


4.1.4.2. Оформление и формат

В оформление текстового документа входят основная надпись (см. раздел 4.1.4.3), внешняя и внутренняя рамки. Кроме того, в оформлении хранятся размеры полей текста — расстояния от внутренней рамки до границ текста. Оформления листов отображаются на экране только в режиме разметки (см. раздел 4.1.4.1).

Оформления, поставляемые с КОМПАС-3D, хранятся в библиотеках — файлах *.lyt, расположенных в подпапке \Sys главной папки системы. Основная библиотека оформлений, использующаяся при создании документов, — graphic.lyt. Возможно также формирование пользовательских библиотек оформлений. Подробно о работе с оформлениями документов рассказано в разделе 11.2.1.

Благодаря тому, что каждому листу документа присвоено оформление, вам не нужно вычерчивать рамку и таблицу основной надписи.

По умолчанию первый лист текстового документа, созданного без шаблона (см. раздел 11.2.1.8), имеет оформление Текстовый конструкторский документ. Первый лист. ГОСТ 2.104-2006. Четный и нечетный листы имеют оформление Текстовый конструкторский документ. Последующий лист. ГОСТ 2.104-2006. Формат текстового документа по умолчанию — А4.

Текстовый документ, созданный по шаблону, имеет оформления и формат листов, соответствующие шаблону.

Вне зависимости от способа создания документа вы в любой момент можете изменить оформления его листов и формат.

Для этого выполните следующие действия.

1. На панели Стандартная нажмите кнопку Менеджер документа. На экране появляется диалог Менеджер документа (рис. 4.1.28).

В Дереве документа перечислены разделы в порядке их создания. Справа в соответствующих строках показаны свойства листов, входящих в разделы.

Рис. 4.1.28. Менеджер документа; работа с текстовым документом

2. Щелкните мышью по строке, соответствующей разделу, параметры которого требуется изменить.

3. В графе Ориентация отображается значок, показывающий текущую ориентацию листов раздела. Чтобы изменить ее, следует щелкнуть по этому значку. Значок также изменится.

4. В графе Формат отображается обозначение текущего формата листов раздела. Чтобы сменить формат, разверните список в данной графе и выберите нужное обозначение формата.

Вы можете установить размеры листа, отличные от предусмотренных стандартом. Для этого нажмите кнопку Формат на инструментальной панели Менеджера документа. В появившемся на экране диалоге включите опцию Пользовательский, введите размеры листа и закройте диалог. В графе Формат отобразятся заданные значения сторон листа.

5. В графе Кратность отображается текущая кратность формата листа. Чтобы сменить кратность, разверните список в данной графе и выберите нужное значение.

Если лист имеет нестандартные размеры, его кратность задать невозможно.

6. В графе Оформление отображается наименование присвоенного листам раздела оформления из текущей библиотеки оформлений. Имя файла этой библиотеки отображается в графе Библиотека оформлений.

6.1. Чтобы выбрать другое оформление из текущей библиотеки, щелкните по наименованию в графе Оформление. В появившемся на экране диалоге укажите нужное оформление.

6.2. Чтобы выбрать оформление из другой библиотеки, щелкните по наименованию в графе Библиотека оформлений или нажмите кнопку Оформление на инструментальной панели Менеджера документа. В появившемся на экране диалоге укажите нужную библиотеку и оформление из нее.

Если листы внутри одного раздела имеют различное оформление, в графах Оформление и Библиотека оформлений отображаются «звездочки».

7. Вы можете просмотреть сделанные изменения на экране, не закрывая диалога. Для этого нажмите кнопку Применить. Чтобы закрыть Менеджер документа с сохранением изменений, нажмите кнопку ОК.

Изменить оформление и формат листов любого из разделов можно также, вызвав команду Сервис — Параметры... — Текущий текстовый документ — Параметры листа.

Выбирая в левой части диалога пункты Формат и Оформление, вы можете настроить эти свойства для листов указанного раздела, см. разделы 9.2.4.2.1 и 9.2.4.2.2.

Оформление применяется к листам раздела. Первый, четный и нечетный лист раздела определяется на основе фактического порядка листов. Он не зависит от номеров листов, отображаемых в основной надписи.


4.1.4.3. Основная надпись

Основная надпись является одним из элементов оформления текстового документа (см. раздел 4.1.4.2).

Чтобы заполнить основную надпись текстового документа, переключите его в режим разметки и дважды щелкните мышью по таблице основной надписи. Система перейдет в режим заполнения основной надписи документа. Приемы работы в этом режиме описаны в разделах 3.6.3.1.1–3.6.3.1.5.

Заполнив все графы основной надписи, нажмите кнопку Создать объект на Панели свойств или нажмите комбинацию клавиш <Ctrl>+<Enter> для сохранения сделанных изменений и выхода из режима работы с основной надписью.

Чтобы выйти из режима заполнения основной надписи в текстовом документе, можно щелкнуть мышью в любом месте за пределами таблицы основной надписи.

Сведения, введенные в ячейки типа Общий для документа, автоматически передаются в другие ячейки этого типа (в том числе на других листах). Типы ячеек задаются при настройке основных надписей, входящих в оформления листов. Например, в оформлениях, поставляемых вместе с системой, основные надписи настроены так, что обозначение изделия, введенное одном из листов, передается в ячейки Обозначение основных надписей на всех остальных листах.

Различающуюся информацию необходимо ввести на каждом листе.

Графы Количество листов и Номер листа заполняются автоматически и недоступны для редактирования. Вы можете задать предопределенное количество листов, а также отключить автоопределение номера листа (см. раздел 9.2.4.6).


4.1.4.4. Разделы

Раздел — это непрерывная часть текстового документа, имеющая определенные параметры — формат, ориентацию и оформление листов. Эти параметры настраиваются отдельно для каждого раздела.

Вы можете задать одно оформление для всех листов раздела или разные для первого, четных и нечетных листов. Формат и ориентация одни и те же для всех листов раздела.

Выбор формата и ориентации для раздела выполняется в диалоге Формат (см. раздел 9.2.4.2.1), оформления — в диалоге Оформление (см. раздел 9.2.4.2.2). Кроме того, параметры разделов можно задавать в Менеджере документа (см. раздел 4.1.4.2).

По умолчанию текстовый документ содержит один раздел. Вы можете добавлять и удалять разделы, изменять порядок их следования в документе.

В этом разделе:

4.1.4.4.1. Добавление и удаление раздела

4.1.4.4.2. Переключение между разделами

4.1.4.4.3. Изменение порядка следования разделов


4.1.4.4.1. Добавление и удаление раздела

Добавлять и удалять разделы можно во время редактирования текста документа или в диалоге Менеджер документа (см. рис. 4.1.28).

Добавление раздела

– Во время редактирования текста документа

Вызовите команду Вставка — Разрыв раздела или нажмите соответствующую кнопку на инструментальной панели Вставка в текст. В текущей позиции курсора со следующей страницы начнется новый раздел. Он отделяется от предыдущего надписью Разрыв раздела.

Новый раздел имеет формат и оформление предыдущего или последующего раздела (если новый раздел создается в начале документа).

– В Менеджере документа

1. Вызовите Менеджер документа, нажав кнопку Менеджер документа на панели Стандартная.

2. Определите расположение нового раздела относительно существующих.

– Чтобы новый раздел находился перед первым разделом, выберите корневой объект Дерева документа в левой части диалога (данный объект выбран по умолчанию). Новый раздел будет иметь такие же параметры, как первый раздел.

– Чтобы расположить новый раздел после какого-либо из существующих, выберите этот раздел (для выбора раздела можно использовать как левую, так и правую части диалога). Новый раздел будет иметь такие же параметры, как выбранный.

3. На инструментальной панели Менеджера документа нажмите кнопку Создать раздел. Новый раздел появится в Дереве документа и в списке разделов Менеджера.

4. При необходимости измените имя раздела; настройте формат и оформление его листов (см. раздел 4.1.4.2).

5. Чтобы применить изменения, не закрывая Менеджер, нажмите в диалоге кнопку Применить. В текстовом документе появится новый пустой раздел, а диалог останется на экране. Чтобы завершить работу в диалоге с сохранением изменений, нажмите кнопку ОК.

Удаление раздела

– Во время редактирования текста документа

Установите курсор в первую или последнюю позицию текущего раздела и нажмите клавишу <Backspase> или <Delete> соответственно. Разрыв раздела удаляется, а содержимое текущего раздела объединяется с предыдущим или последующим разделом.

Получившийся раздел имеет формат и оформление первого из двух объединенных разделов.

– В Менеджере документа

1. Вызовите Менеджер документа.

2. Выделите удаляемый раздел в Дереве или в списке разделов Менеджера и нажмите на инструментальной панели кнопку Удалить.

3. Подтвердите удаление, нажав в диалоге кнопку Применить или ОК. В последнем случае работа в Менеджере документа завершается.

Если удаление раздела выполняется в Менеджере документа, то раздел удаляется вместе со всем его содержимым.

Существование текстового документа без разделов невозможно. Поэтому единственный оставшийся в документе раздел удалить нельзя.


4.1.4.4.2. Переключение между разделами

В поле Текущий раздел на панели Текущее состояние отображаются имя и номер (в скобках) текущего раздела документа. Чтобы переключиться на другой раздел, разверните список справа от поля Текущий раздел и укажите в списке нужную строку. На экране отобразится первая страница нужного раздела.


4.1.4.4.3. Изменение порядка следования разделов

Вы можете поменять порядок, в котором разделы располагаются в текстовом документе. Например, можно перенести первый раздел документа в конец, т.е. сделать последним. При этом текст раздела, формат и ориентация его листов сохраняется; все листы документа перенумеровываются согласно новому порядку разделов.

Изменение порядка следования разделов текстового документа производится в Менеджере документа (см. рис. 4.1.28). Вызовите Менеджер документа, нажмите одноименную кнопку на панели Стандартная, и выполните следующие действия.

1. В Дереве документа (оно находится в левой части Менеджера) установите курсор на перемещаемом разделе и нажмите левую кнопку мыши. Название раздела подсветится.

2. Не отпуская кнопку, перемещайте курсор мыши к названию того раздела, после которого должен разместиться выбранный раздел.

3. Когда название второго раздела подсветится, отпустите кнопку мыши. Выбранный раздел переместится в указанное место.

Названия разделов в Менеджере документа (по умолчанию они имеют вид Раздел №) после перестановки не изменяются. При необходимости вы можете отредактировать их вручную.


4.1.4.5. Нумерация листов

В текстовом документе предусмотрена автоматическая нумерация листов. Если она включена, то количество листов и их номера, отображаемые в графах Количество листов и Номер листа основной надписи, определяются автоматически и зависят от настройки.

– Количество в графе Количество листов:

• может быть предопределенным (задается пользователем при настройке),

• может определяться автоматически как сумма1 листов всех разделов.

– Номер в графе Номер листа.

• Номер первого листа раздела:

- может быть предопределенным (задается пользователем при настройке),

- может определяться нумерацией предыдущего раздела; в этом случае номер рассчитывается по формуле S + 1, где S — суммарное1 количество листов предыдущих разделов (вариант недоступен для первого раздела документа).

• Номера второго и последующих листов рассчитываются по формуле N + 1, где N — номер предыдущего листа.

Если автоматическая нумерация включена для всех разделов и начинается с номера 1,то номер каждого листа соответствует фактическому номеру листа документа.

Из нумерации можно исключить отдельные разделы. В графах Номер листа и Количество листов листы этих разделов учитываться не будут.

При отключении автоматической нумерации доступен ручной ввод номеров и количества листов в графы Номер листа и Количество листов.

Настройка параметров нумерации для текущего документа выполняется в диалоге, вызываемом командой Сервис — Параметры... — Текущий текстовый документ — Нумерация листов. (см. раздел 9.2.4.6).

  1. в сумму включается:
    — заданное количество листов раздела, если это количество предопределено;
    — фактическое количество листов раздела, если оно определяется автоматически.


4.1.4.6. Пример создания документа с несколькими разделами

Допустим, требуется создать текстовый документ, состоящий из нескольких разделов: титульный лист, основной текст, иллюстрация, лист регистрации изменений. Иллюстрация должна быть выполнена на листе формата А3, остальные разделы — на листах формата А4. Порядок действий при этом может быть следующий.

1. Проверьте настройку параметров листа для новых текстовых документов.

1.1. Вызовите команду Сервис — Параметры... — Новые документы — Текстовый документ — Параметры листа.

1.2. Выберите пункт Формат. Убедитесь, что для листов документа выбран формат А4 с вертикальной ориентацией.

1.3. Выберите пункт Оформление. Убедитесь, что первый лист документа имеет оформление Текстовый конструкторский документ. Первый лист. ГОСТ 2.104-2006 из библиотеки graphic.lyt, остальные листы — оформление Текстовый конструкторский документ. Последующие листы. ГОСТ 2.104-2006 из той же библиотеки.

Если параметры нового документа отличаются от описанных, отредактируйте их.

2. Создайте новый текстовый документ КОМПАС-3D.

Документ отображается на экране в нормальном режиме, т.е. без рамки и основной надписи.

Новый документ содержит один раздел. По мере ввода текста в этот раздел добавляются новые листы.

3. Заполните текстом 2–3 страницы документа.

4. Вызовите команду Вид — Разметка страниц, либо нажмите одноименную кнопку на панели Режимы.

Отображение документа изменится: на экране появится изображение рамки и основной надписи. Обратите внимание на то, что основная надпись первого листа отличается от основной надписи последующих листов — это соответствует умолчательной настройке оформления документа.

5. Добавьте в начало и конец документа новые разделы.

5.1. Чтобы вставить новый раздел перед первым разделом, установите курсор в начало документа, т.е. в первую позицию первой строки, и вызовите команду Вставка — Разрыв раздела.

5.2. Чтобы добавить новый раздел в конце документа, установите курсор в конец последнего раздела, т.е. в последнюю позицию последней строки, и вызовите команду Вставка — Разрыв раздела.

Новые разделы содержат по одному листу и имеют те же параметры, что и первый раздел.

6. Присвойте первому разделу оформление Титульный лист. ГОСТ 2.105-95.

6.1. Вызовите Менеджер документа.

6.2. В правой части окна Менеджера выделите первую строку и щелкните мышью в столбце Оформление.

6.3. В появившемся диалоге выбора оформления включите опцию Единое оформление. В окне диалога останется одна группа выбора оформления, состоящая из полей Библиотека и Название.

6.4. Нажмите кнопку Выбор справа от поля Название.

6.5. В открывшемся диалоге со списком оформлений выберите строку Титульный лист. ГОСТ 2.105-95 и нажмите кнопку ОК.

В оформлениях Титульный лист и Лист регистрации изменений таблицы занимают все рабочее пространство листа. Применить такое оформление можно только к пустому разделу, т.е. к разделу, в котором еще нет ни одной строки.

6.6. Закройте диалог настройки оформления раздела кнопкой ОК. На экране останется диалог Менеджер документа. В столбце Оформление для первого раздела появится название выбранного вами оформления.

7. Аналогичным образом присвойте последнему разделу документа оформление Лист регистрации изменений (вертик.) Посл.листы. ГОСТ 2.503-90 ФЗ.

8. Присвойте разделам документа имена Титульный лист, Основной текст и Лист изменений в графе Имя.

9. Не закрывая диалог Менеджер документа, добавьте в документ раздел для иллюстраций и отредактируйте его параметры.

9.1. Выделите строку раздела Основной текст и нажмите кнопку Создать раздел на инструментальной панели Менеджера. Новый раздел появится после выделенного раздела.

9.2. В строке нового раздела разверните список форматов и укажите А3.

9.3. Установите горизонтальную ориентацию в графе Ориентация.

9.4. Примените к разделу единое оформление Текстовый конструкторский документ. Последующие листы. ГОСТ 2.104-2006.

9.5. Присвойте разделу имя Иллюстрация.

9.6. Закройте диалог Менеджера документа кнопкой ОК.

10. Заполните произвольными данными титульный лист и лист регистрации изменений.

Ввод текста на листах, в которых основная надпись занимает весь лист, возможен только в режиме разметки страниц и производится в режиме заполнения основной надписи. Чтобы войти в режим заполнения основной надписи, дважды щелкните мышью по нужной таблице. Для выхода из режима заполнения основной надписи с сохранением сделанных изменений нажмите комбинацию клавиш <Ctrl>+<Enter> либо щелкните мышью вне редактируемой таблицы.

Если требуется создать новый лист в разделе с таким оформлением, вызовите команду Вставка — Разрыв страницы или нажмите комбинацию клавиш <Ctrl>+<Enter>.

11. В раздел Иллюстрация добавьте фрагмент.

11.1. Установите курсор в первую строку на листе формата А3 и вызовите команду Вставка — Фрагмент....

11.2. Выберите любой КОМПАС-фрагмент, например, файл SAMPLE.frw в подпапке \Samples\Drawings главной папки системы, и нажмите кнопку Открыть. Подробнее о вставке иллюстраций см. раздел 4.1.2.11.8.

12. На этом создание документа завершено.

13. Убедитесь в том, что все листы учитываются при автоматической нумерации листов и автоматическом определении общего числа листов, т.е. первым листом документа является первый лист первого раздела, а последним — последний лист последнего раздела.


4.2. Таблицы

В этом разделе:

4.2.1. Общие сведения

4.2.2. Приемы работы

4.2.2.1. Ввод текста в ячейку таблицы

4.2.2.2. Выделение ячеек, строк и столбцов таблицы

4.2.2.3. Объединение ячеек

4.2.2.4. Разделение ячеек

4.2.2.5. Добавление и удаление строк и столбцов

4.2.2.6. Копирование и перенос ячеек, строк и столбцов

4.2.2.7. Изменение размеров ячеек таблицы

4.2.2.8. Границы ячеек

4.2.2.9. Сохранение таблиц

4.2.2.10. Блокировка размеров таблицы

4.2.2.11. Форматирование ячеек

4.2.3. Настройка параметров текста в таблице

4.2.4. Использование таблиц

4.2.4.1. Таблицы в текстовом документе


4.2.1. Общие сведения

4.2. Таблицы

4.2.1. Общие сведения

Текстовый редактор КОМПАС-3D предоставляет разнообразные возможности создания и редактирования различных таблиц как в графических, так и в текстовых документах.

В целом приемы работы с таблицами одинаковы. Основные команды работы с таблицами сгруппированы в меню Таблица, а кнопки для их вызова — на панели Таблицы и границы (рис. 4.2.1).

Кроме того, вызов команд возможен с помощью переключателей, расположенных на вкладке Таблица Панели свойств (рис. 4.2.2).

Рис. 4.2.1. Панель Таблицы и границы

Рис. 4.2.2. Вкладка Таблица

При вводе текста в ячейки таблицы вы можете применять все приемы форматирования, описанные в разделе 4.1.2. Параметры форматирования можно также задать для пустой ячейки.

Существующую таблицу можно трансформировать: добавлять либо удалять столбцы и строки, разделять или объединять ячейки, изменять размеры и стиль линий границ ячеек.

Созданную типовую таблицу (например, таблицу параметров зубчатого зацепления) можно сохранить в отдельном файле, а затем вставлять в новые документы.


4.2.2. Приемы работы

4.2. Таблицы

4.2.2. Приемы работы

Все описанные ниже приемы работы доступны в режиме редактирования таблицы.

После создания новой таблицы система переходит в этот режим автоматически.

Чтобы перейти в режим редактирования уже существующей таблицы, следует дважды щелкнуть по ней мышью.

Рис. 4.2.3. Таблица в режиме редактирования

В режиме редактирования таблица заключается в тонкую рамку, а внутри ячеек таблицы штриховыми линиями показываются границы поля ввода текста (рис. 4.2.3). Курсор остается в той ячейке и в той позиции, где он находился в момент двойного щелчка мышью.

В этом разделе:

4.2.2.1. Ввод текста в ячейку таблицы

4.2.2.2. Выделение ячеек, строк и столбцов таблицы

4.2.2.3. Объединение ячеек

4.2.2.4. Разделение ячеек

4.2.2.5. Добавление и удаление строк и столбцов

4.2.2.6. Копирование и перенос ячеек, строк и столбцов

4.2.2.7. Изменение размеров ячеек таблицы

4.2.2.8. Границы ячеек

4.2.2.9. Сохранение таблиц

4.2.2.10. Блокировка размеров таблицы

4.2.2.11. Форматирование ячеек


4.2.2.1. Ввод текста в ячейку таблицы

Ввод текста в ячейку таблицы ничем не отличается от ввода обычного текста.

Для перехода в нужную ячейку щелкните в ней левой кнопкой мыши. Кроме того, перемещение по ячейкам возможно с помощью клавиши <Tаb>.

Ячейка, в которой находится курсор, считается текущей. Столбец и строка, которым принадлежит эта ячейка, также считаются текущими.


4.2.2.2. Выделение ячеек, строк и столбцов таблицы

Выделение ячеек, строк или столбцов таблицы может понадобиться, например, для форматирования текста внутри этих строк или столбцов.

Доступно два способа выделения диапазона смежных ячеек.

– Перемещайте курсор по таблице, удерживая нажатой левую кнопку мыши.

– Установите курсор в угловую ячейку диапазона, нажмите клавишу <Shift> и, не отпуская ее, щелкните мышью в противоположной угловой ячейке.

Рис. 4.2.4. Пример выделения диапазона ячеек

Доступно два способа выделения строки (столбца) таблицы.

– С помощью команд меню. Установите курсор в любую ячейку этой строки (столбца) и вызовите команду Выделить строку (Выделить столбец).

– С помощью мыши. Подведите указатель к границе таблицы напротив нужной строки или столбца. Когда указатель примет форму стрелки, направленной в сторону таблицы, нажмите левую кнопку мыши. Строка (столбец), на которую указывает стрелка, будет выделена.

Доступно два способа выделения диапазонов строк (столбцов) таблицы.

– Подведите указатель к границе таблицы напротив первой строки (столбца) диапазона. Когда указатель примет форму стрелки, направленной в сторону таблицы, нажмите левую кнопку мыши и перемещайте указатель в направлении последней строки (столбца) диапазона, удерживая нажатой левую кнопку мыши. Выделение будет распространяться на строки (столбцы), границы которых пересечет указатель. Когда все нужные строки или столбцы таблицы будут выделены, отпустите левую кнопку мыши.

– Выделите первую строку (столбец) диапазона, нажмите клавишу <Shift> и, не отпуская ее, щелкните мышью в любой ячейке последней строки (столбца) диапазона.

Чтобы выделить ячейку, подведите указатель к ее левой границе. Когда указатель примет форму стрелки, направленной в сторону ячейки, нажмите левую кнопку мыши. Ячейка, на которую указывает стрелка, будет выделена.


4.2.2.3. Объединение ячеек

Чтобы объединить несколько ячеек таблицы в одну, выделите их и вызовите команду Объединить ячейки.

Команда доступна, если выделенные ячейки образуют прямоугольный блок.

Стили границ объединяемых ячеек могут быть различными. Стиль границ объединенной ячейки выбирается согласно следующим правилам:

– стиль верхней горизонтальной границы соответствует стилю верхней границы левой верхней ячейки в выделенном блоке;

– стиль нижней горизонтальной границы соответствует стилю нижней границы левой нижней ячейки в выделенном блоке;

– стиль левой вертикальной границы соответствует стилю левой границы левой верхней ячейки в выделенном блоке;

– стиль правой вертикальной границы соответствует стилю правой границы правой верхней ячейки в выделенном блоке.

Правила формирования текста в объединенной ячейке:

– тексты объединяемых ячеек добавляются к тексту верхней левой ячейки в порядке расположения ячеек слева направо и сверху вниз;

– тексты объединяемых ячеек сохраняют следующие параметры абзаца: Шаг строк, Красная строка, Отступы, Табуляция, Интервалы, Выравнивание;

– тексты объединяемых ячеек сохраняют следующие параметры шрифта: Шрифт, Высота, Сужение, Курсив, Жирный, Подчеркнутый, Цвет;

– текст каждой объединяемой ячейки в объединенной ячейке начинается с нового абзаца;

– ячейки, не содержащие текста, не создают пустого абзаца;

– значения параметров Отступы, Отслеживание размера по горизонтали, Отслеживание размера по вертикали объединенной ячейки равны значениям аналогичных параметров верхней левой ячейки.


4.2.2.4. Разделение ячеек

Чтобы разбить текущую ячейку или диапазон выделенных ячеек таблицы на несколько ячеек, вызовите команду Разбить ячейки...

На экране появится диалог Разбиение ячеек (рис. 4.2.5). В нем требуется задать количество строк и столбцов, на которые нужно разбить ячейку (ячейки).

Рис. 4.2.5. Диалог разбиения ячеек

Если команда применяется к диапазону выделенных ячеек, то ее результат зависит от состояния опции Объединить ячейки перед разбиением.

– Если опция включена, то выделенные ячейки объединяются и полученная таким образом ячейка разбивается на заданное количество строк и столбцов.

– Если опция выключена, то на заданное количество строк и столбцов разбивается каждая из выделенных ячеек.

Если выделенные ячейки образуют непрямоугольный блок, то их объединение невозможно, поэтому опция Объединить ячейки перед разбиением недоступна.

Эта опция недоступна также при разбиении единственной ячейки.

Свойства ячейки и параметры форматирования текста новых ячеек наследуются от исходной ячейки. Если ячейки были объединены перед разбиением, то свойства и параметры форматирования наследуются от левой верхней ячейки диапазона.


4.2.2.5. Добавление и удаление строк и столбцов

Для выполнения операций вставки вызовите нужную команду:

– Вставить столбец слева,

– Вставить столбец справа,

– Вставить строку сверху,

– Вставить строку снизу.

Столбец (строка), который был текущим перед вызовом команды, считается исходным для нового столбца (строки).

Чтобы добавить строку внизу таблицы, установите курсор в крайнюю позицию нижней правой ячейки и нажмите клавишу <Tab>.

Вставка производится по следующим правилам.

– За один вызов команды вставляется один столбец (строка).

– Ячейки нового столбца (строки) имеют те же размеры, параметры форматирования текста и стиль линий границ, что и исходный столбец (строка).

– Тексты, содержащиеся в ячейках исходного столбца (строки), не копируются в ячейки нового столбца (строки).

Для удаления столбцов или строк служат команды Удалить столбец или Удалить строку.

Чтобы удалить сразу несколько строк или столбцов, выделите их перед вызовом команды.

Нажатие клавиши <Delete> удаляет содержимое ячеек выделенных столбцов (строк). Сами столбцы (строки) остаются в таблице.

Вставлять и удалять столбцы (строки) можно только в том случае, если количество столбцов (строк) не зафиксировано (см. раздел 4.2.2.10).


4.2.2.6. Копирование и перенос ячеек, строк и столбцов

Копирование и перенос ячеек, строк и столбцов между таблицами возможны как в одном и том же документе, так и в разных документах, открытых в одном приложении КОМПАС-3D (в том числе в документах различных типов).

Копирование и перенос ячеек, строк и столбцов, в отличие от копирования и переноса текста, осуществляется через собственный буфер обмена КОМПАС-3D.

Ячейки, строки и столбцы копируются и переносятся с сохранением параметров шрифта, параметров абзаца и стиля текста.

Чтобы скопировать или перенести ячейки, строки или столбцы из одной таблицы в другую, выполните следующие действия.

1. Войдите в режим редактирования таблицы, ячейки, строки или столбцы которой требуется скопировать или перенести.

2. Выделите нужный диапазон ячеек, строк или столбцов.

3. Для копирования диапазона в буфер вызовите из контекстного меню команду Копировать, а для вырезания — команду Вырезать.

4. Войдите в режим редактирования таблицы, в которую требуется вставить ячейки, строки или столбцы.

5. Установите курсор в место копирования:

• при копировании ячеек — в ячейку, где должно разместиться содержимое верхней левой ячейки находящегося в буфере диапазона ячеек,

• при копировании строк — в строку, над которой должны разместиться строки, находящиеся в буфере,

• при копировании столбцов — в столбец, слева от которого должны разместиться столбцы, находящиеся в буфере.

6. Вызовите из контекстного меню команду Вставить.

Содержащиеся в буфере ячейки будут вставлены в таблицу в направлении вправо и вниз от текущей. Содержимое вставляемых ячеек заменяет собой содержимое уже имеющихся ячеек. При необходимости в таблицу добавляются строки и/или столбцы.

Для корректной вставки строк необходимо, чтобы обе таблицы имели одинаковое число столбцов, а для корректной вставки столбцов — одинаковое число строк. В противном случае возможна неполная вставка или появление объединенных ячеек.

Если размеры таблицы заблокированы (см. раздел 4.2.2.10) либо в ячейках имеется запрет на изменение текста или ввод многострочного текста (см. раздел 4.2.2.11), то после вызова команды вставки на экране может появиться диалог с запросом на снятие ограничений. Для продолжения вставки нажмите кнопку Да, а для отказа от вставки — кнопку Нет.


4.2.2.7. Изменение размеров ячеек таблицы

Чтобы изменить габариты ячейки, выполните следующие действия.

1. Поместите указатель мыши на границу ячейки. Он примет вид двунаправленной стрелки.

2. Нажмите левую кнопку мыши и, не отпуская ее, «перетаскивайте» границу ячейки в нужном направлении.

3. После того как нужное положение границы достигнуто, отпустите кнопку мыши.

Если поместить указатель на пересечение границ ячейки (на ее угол), можно «перетаскивать» сразу обе границы ячейки. Указатель мыши в этом случае принимает вид четырехсторонней стрелки.

При «перетаскивании» границ ячейки размеры ячеек и таблицы в целом изменяются следующим образом.

– Размеры всех ячеек текущего столбца или строки таблицы изменяются в соответствии с положением курсора мыши.

– Размеры таблицы остаются неизменными.

– Размеры столбца справа от текущего и/или строки ниже текущей изменяются в соответствии с положением курсора мыши.

Если при «перетаскивании» границ ячейки удерживать нажатой клавишу <Ctrl>, изменения размеров будут следующими.

– Размеры всех ячеек текущего столбца или строки таблицы изменяются в соответствии с положением курсора мыши.

– Размеры соседних столбцов и строк остаются неизменными.

– Размеры таблицы изменяются в соответствии с изменением размеров ячейки.

Во время перемещения границ рядом с курсором отображаются текущие размеры ячеек (рис. 4.2.6).

Рис. 4.2.6. Перемещение границ ячеек таблицы

– При перемещении горизонтальной или вертикальной границы отображается высота или ширина ячейки. Перемещаемая граница и параллельная ей граница отсчета размера подсвечиваются.

– При перемещении угла ячейки отображаются ее высота и ширина одновременно. Перемещаемые границы и параллельные им границы отсчета размеров подсвечиваются.

Следует обратить внимание на то, что отображаемые рядом с курсором параметры относятся к ячейке, расположенной слева или сверху по отношению к перемещаемой границе. Исключением является перемещение верхней или правой границы таблицы. В этом случае рядом с курсором отображаются размеры ячейки, примыкающей к данной границе снизу или справа.

Чтобы узнать размеры ячейки, установите курсор в ее правый нижний угол. После того как курсор превратится в четырехстороннюю стрелку, нажмите левую кнопку мыши. Рядом с курсором появятся значения размеров ячейки.

Размеры ячеек изменяются мышью и отображаются рядом с курсором с точностью 1 мм. Чтобы переместить границу с большей точностью, следует ввести необходимый размер в диалоге настройки формата ячейки (см. раздел 4.2.2.11).

Изменение границ строк и столбцов возможно только в том случае, если габариты ячеек не зафиксированы (см. раздел 4.2.2.10).


4.2.2.8. Границы ячеек

Ячейки вновь созданной таблицы имеют умолчательное обрамление: внешние рамки и линии, разделяющие строки таблицы, имеют стиль Основная, а линии, разделяющие столбцы, имеют стиль Тонкая.

Управление отображением и стилем линии границ ячеек производится в диалоге настройки границ (рис. 4.2.7). Для его вызова служит команда Границы.

Рис. 4.2.7. Диалог настройки границ

В списке Стиль линий границ перечислены системные стили линий, которые могут быть использованы для границ ячеек.

В поле Образец схематично отображается выделенный диапазон ячеек. Слева от поля и под ним расположены кнопки, соответствующие границам. Если отображение границы включено, то кнопка нажата, а если выключено — отжата. Включенные границы показываются на образце установленным для них стилем линии, а выключенные — серыми линиями. Если граница выделенного диапазона состоит из линий разного стиля, то она показывается на образце в виде толстой серой линии.

Чтобы выключить отображение границ текущей ячейки (или выделенного диапазона ячеек), отожмите кнопки, соответствующие этим границам, в диалоге настройки границ.

Для удобства редактирования таблицы с выключенными границами вы можете включить их отображение на экране, активизировав переключатель Отображать сетку. Выключенные границы будут показаны в виде тонких серых линий. Эти линии отображаются на экране только в режиме редактирования таблицы и не выводятся на печать.

Чтобы изменить стиль линии границы текущей ячейки (или выделенного диапазона ячеек), выполните следующие действия.

1. Вызовите диалог настройки границ (рис. 4.2.7).

2. Выберите нужный стиль из списка Стиль линий границ.

3. Если граница, стиль которой требуется изменить, выключена, нажмите соответствующую ей кнопку. Если граница, стиль которой требуется изменить, включена, отожмите соответствующую ей кнопку, а затем вновь нажмите ее.

Управление границами возможно также с помощью элементов инструментальной панели Таблицы и границы.

Чтобы изменить стиль линии границы текущей ячейки (или выделенного диапазона ячеек), выберите нужный стиль из списка, а затем нажмите кнопку, соответствующую границе (рис. 4.2.8).

Рис. 4.2.8. Выбор стиля линии границы ячейки

Кнопки, соответствующие границам, можно расположить на отдельной панели и разместить ее в любом удобном месте. Для этого «перетащите» меню кнопок мышью за заголовок в любом направлении. Будет сформирована панель Границы.

Если панель Таблицы и границы расположена вертикально, то вместо списка стилей на ней отображается кнопка Стиль линии. Для изменения текущего стиля линии границы следует нажать эту кнопку. На экране появится диалог, в котором можно выбрать нужный стиль.


4.2.2.9. Сохранение таблиц

Создав таблицу один раз, вы можете сохранить ее в файле для дальнейшего использования. Файлы таблиц в КОМПАС-3D имеют расширение tbl.

Чтобы сохранить текущую таблицу во внешнем файле, выполните следующие действия.

1. Вызовите команду Сохранить таблицу в файл.

2. В появившемся диалоге задайте папку и имя файла для сохранения таблицы.

Впоследствии сохраненную таблицу можно будет загружать с диска. Для этого в диалоге создания таблиц следует нажать кнопку Из файла (см. табл. 3.4.10).


4.2.2.10. Блокировка размеров таблицы

При создании типовых таблиц вы можете запретить изменение их структуры и габаритов ячеек. Для этого вызовите команду Блокировка размеров таблицы.

На экране появится диалог настройки блокировки (рис. 4.2.9). Опции этого диалога представлены в таблице 4.2.1.

Рис. 4.2.9. Диалог блокировки размеров таблицы

Табл. 4.2.1. Диалог блокировки размеров таблицы
Опция | Описание
Зафиксировать габариты ячеек | Запрещает изменение размеров ячеек таблицы.
Запретить изменять число строк | Делает недоступной команды вставки и удаления строк.
Запретить изменять число столбцов | Делает недоступной команды вставки и удаления столбцов.


4.2.2.11. Форматирование ячеек

Чтобы отформатировать текущую или выделенные ячейки таблицы, вызовите команду Формат ячейки.

На экране появится диалог форматирования ячейки (рис. 4.2.10). Элементы управления этого диалога представлены в таблице 4.2.2.

Рис. 4.2.10. Диалог форматирования ячейки

Табл. 4.2.2. Диалог форматирования ячейки

Элемент

Описание

Стиль текста по умолчанию

Поле, содержащее название стиля текста, применяемого по умолчанию для надписи в ячейке.

Изменить

Кнопка, позволяющая выбрать стиль текста для указанной ячейки (ячеек). После ее нажатия на экране появится диалог выбора стиля текста (табл. 4.1.7).

При назначении другого стиля весь текст в ячейке (ячейках) будет переформатирован в соответствии с новым стилем. Остальные ячейки не изменятся.

Запретить
изменение текста в ячейке

Опция, позволяющая блокировать любое редактирование содержимого указанной ячейки (ячеек).

Такой запрет необходим, например, при создании типовых таблиц, где имеются ячейки, текст которых не подлежит изменению.

Однострочный текст

Опция, включение которой запрещает ввод более чем одной строки текста в ячейке. Данная опция, как и предыдущая, используется при создании типовых таблиц.

Отступы

Группа опций, определяющая расположение текста в ячейке. Значения отступов отсчитываются от границ ячейки.

Не рекомендуется устанавливать отступы, равные нулю, так как при этом символы текста будут «прикасаться» к линиям, ограничивающим ячейку.

Ширина столбца, Высота строки

Поля для ввода размеров текущей ячейки.

Доступны при активизации переключателей Изменение сужения текста (или Форматирование строк) и Изменение шага строк в группах Отслеживание размеров по горизонтали и Отслеживание размеров по вертикали соответственно.

Отслеживание размеров
по горизонтали/ вертикали

Группы переключателей, позволяющие установить способ расположения текста внутри ячейки (ячеек). Эти способы подробно описаны в таблицах 4.2.3 и 4.2.4.

Табл. 4.2.3. Отслеживание размеров по горизонтали
Способ | Описание
Перенос правой границы | Длина строк в ячейке динамически отслеживается: при вводе строки, длина которой превышает ширину ячейки, правая граница ячейки (а вместе с ней и всего столбца) сдвигается вправо. Все столбцы, расположенные справа от текущего, будут смещены вправо. Переход к новой строке возможен только по нажатию клавиши <Enter>.
Изменение сужения текста | Ширина ячейки (и всего столбца) остается постоянной при вводе текста1. Подгонка длины строки к ширине ячейки выполняется путем изменения сужения символов. Переход к новой строке возможен только по нажатию клавиши <Enter>.
Форматирование строк | Ширина ячейки (и всего столбца) остается постоянной при вводе текста1. Подгонка длины строки к ширине ячейки выполняется путем автоматического переноса текста со строки на строку.
  1. Возможность ручного изменения габаритов ячейки (см. раздел 4.2.2.7) сохраняется.

Табл. 4.2.4. Отслеживание размеров по вертикали
Способ | Описание
Перенос нижней границы | Вертикальный размер текстового фрагмента в ячейке динамически отслеживается: если текст не умещается в ячейке, ее нижняя граница (и граница всей строки) смещается вниз.
Изменение шага строк | Высота ячейки (и всего столбца) остается постоянной при вводе текста. Подгонка общей высоты текста к высоте ячейки выполняется путем уменьшения шага строк.

Если габариты ячейки были зафиксированы (см. раздел 4.2.2.10), то поля ввода отступов, а также переключатели Перенос правой границы и Перенос нижней границы становятся недоступными.


4.2.3. Настройка параметров текста в таблице

4.2. Таблицы

4.2.3. Настройка параметров текста в таблице

Обычно текст в ячейках «шапки» таблицы отличается от текста в остальных ячейках высотой символов, способом выравнивания и другими параметрами.

При создании новой таблицы пользователь указывает, в какой строке будет располагаться заголовок (см. табл. 3.4.10).

К ячейкам заголовка будет применен системный стиль текста Заголовок таблицы, а ко всем остальным ячейкам — стиль Ячейка таблицы.

При необходимости вы можете изменить параметры указанных системных стилей в текущем графическом или текстовом документе. Для этого вызовите команду Сервис — Параметры.... — Текущий документ.

В списке объектов настройки (он находится в левой части появившегося диалога) есть пункты Заголовок таблицы и Ячейка таблицы. При их выборе в правой части диалога появляются элементы управления (см. табл. 9.2.3), позволяющие настроить соответствующие системные стили текста в текущем документе.

После закрытия диалога тексты, имеющие системный стиль Заголовок таблицы и Ячейка таблицы, будут переформатированы.

Сделанная настройка будет сохранена в текущем документе и не изменится при передаче его на другое рабочее место.

Если в большинстве документов используются стили Заголовок таблицы и Ячейка таблицы с одинаковыми параметрами, то выполнение соответствующей настройки в каждом документе нерационально. В этом случае можно сделать так, чтобы все новые документы сразу создавались с требуемыми настройками. Для этого вызовите команду Сервис — Параметры... — Новые документы.

В левой части появившегося диалога раскройте раздел, соответствующий типу настраиваемого документа — Текстовый документ или Графический документ. Затем настройте стили Заголовок таблицы и Ячейка таблицы, выбрав одноименные пункты.

Команда Сервис — Параметры... недоступна, когда система находится в режиме редактирования таблицы. Поэтому, чтобы приступить к настройке, необходимо выйти из этого режима — щелкнуть мышью за пределами редактируемой таблицы.


4.2.4. Использование таблиц

4.2. Таблицы

4.2.4. Использование таблиц

Создание таблиц возможно при работе с графическими и текстовыми документами.

В дальнейшем вы можете отредактировать вставленную таблицу или удалить ее.

Работа с таблицами в графическом документе описана в разделе 3.4.2, а в текстовом — в разделе 4.2.4.1.

В этом разделе:

4.2.4.1. Таблицы в текстовом документе


4.2.4.1. Таблицы в текстовом документе

Чтобы вставить таблицу в текстовый документ, вызовите команду Вставка — Таблица....

На экране появится диалог создания новой таблицы (см. рис. 3.4.4).

Таблица вставляется в текст как один абзац.

Если в строке перед курсором был набран текст, для размещения таблицы автоматически формируется новый пустой абзац.

Курсор автоматически устанавливается в верхнюю левую ячейку новой таблицы. Вы можете вводить, редактировать и форматировать текст в ячейках, а также изменять структуру таблицы.

Чтобы зафиксировать таблицу, нажмите кнопку Создать объект.

Чтобы изменить размещение таблицы относительно границ поля ввода и расстояния между ней и соседними абзацами, следует настроить содержащий ее абзац (см. раздел 4.1.2.5.1).

Выравнивание по всей ширине для таблицы будет эквивалентно выравниванию влево.

Копирование и перенос таблиц через буфер обмена не отличается от копирования и переноса фрагментов текста (см. раздел 4.1.2.4).


5.1. Свойства

В этом разделе:

5.1.1. Общие сведения

5.1.2. Управление свойствами

5.1.2.1. Настройка списка свойств для новых документов

5.1.2.2. Настройка списка свойств текущего документа

5.1.2.3. Управление свойствами

5.1.2.4. Создание библиотеки свойств

5.1.2.5. Формирование списка свойств документа

5.1.2.5.1. Создание свойства

5.1.2.5.2. Изменение свойства

5.1.2.5.3. Удаление свойства

5.1.2.5.4. Добавление свойства из библиотеки свойств в документ

5.1.2.5.5. Копирование свойств компонента (или вставки) в документ-сборку (или чертеж/фрагмент)

5.1.2.5.6. Подключение свойства к документу

5.1.3. Типы и значения свойств

5.1.3.1. Системные свойства

5.1.3.2. Дополнительные свойства

5.1.3.2.1. Свойства, созданные из переменных

5.1.4. Работа со свойствами

5.1.4.1. Задание значений свойств на Панели свойств

5.1.4.1.1. Общие приемы работы

5.1.4.1.2. Работа в документе-модели

5.1.4.1.3. Работа в чертеже

5.1.4.1.4. Работа во фрагменте

5.1.4.2. Редактор свойств

5.1.4.2.1. Отображение объектов

5.1.4.2.2. Настройка столбцов

5.1.4.2.3. Выделение ячеек и строк

5.1.4.2.4. Редактирование значений

5.1.4.2.5. Сохранение таблицы в файл и вывод на печать

5.1.4.3. Копирование свойств

5.1.4.4. Особенности задания свойств

5.1.4.4.1. Ссылка в значении свойства

5.1.4.4.2. Задание материала в документе-модели. Пересчет МЦХ

5.1.4.4.3. Задание материала в графическом документе

5.1.4.4.4. Задание обозначения

5.1.4.4.5. Задание значений свойств, созданных из переменных

5.1.4.4.6. Задание раздела спецификации


5.1.1. Общие сведения

5.1. Свойства

5.1.1. Общие сведения

Свойство — информация, соотнесенная с графическим изображением или моделью и отражающая какую-либо из его характеристик, например, обозначение, наименование, массу и т.д.

Список свойств документа создается и хранится в чертеже, фрагменте или документе-модели. Он является единым для документа и входящих в него объектов, а значения свойств объектов могут различаться.

Свойства могут быть заданы:

– в графических документах — чертежу или фрагменту в целом, макроэлементам, вставкам видов и фрагментов;

– в документе-модели — модели в целом, телам и компонентам.

В ассоциативном виде чертежа могут быть доступны для просмотра свойства модели, по которой чертеж создан.

Свойства делятся на системные и дополнительные. По умолчанию в списке свойств находятся только системные свойства. Вы можете добавить в список дополнительные свойства.

В процессе работы набор дополнительных свойств в списке можно редактировать: создавать и добавлять новые свойства, изменять и удалять существующие, добавлять свойства из библиотек свойств. Указанные действия описаны в разделе 5.1.2.5.

Вы можете заранее настроить список свойств для новых документов, включив в него все необходимые свойства. Для этого используются библиотеки свойств. Подключение библиотек описано в разделе 5.1.2.1. В комплект поставки системы КОМПАС-3D входит библиотека свойств properties.lpt.

Вы можете создать собственные библиотеки свойств (см. раздел 5.1.2.4).

Для задания значения свойства необходимо, чтобы свойство из списка отображалось в свойствах документа. Включение отображения свойств может быть выполнено как для новых документов (см. раздел 5.1.2.1), так и для текущего (см. раздел 5.1.2.2).

Значения свойств задаются во время работы с документом. Задание значений свойств описано в разделе 5.1.4.

Свойства документа и входящих в него объектов могут использоваться для представления в виде отчетов. Подробно об отчетах рассказано в разделе 5.2.


5.1.2. Управление свойствами

5.1. Свойства

5.1.2. Управление свойствами

Настройка списка свойств выполняется для новых документов или для текущего документа.

При настройке новых документов вы можете подключить нужные библиотеки свойств и включить отображение свойств в документах, при настройке текущего документа — только включить отображение в нем свойств.

В этом разделе:

5.1.2.1. Настройка списка свойств для новых документов

5.1.2.2. Настройка списка свойств текущего документа

5.1.2.3. Управление свойствами

5.1.2.4. Создание библиотеки свойств

5.1.2.5. Формирование списка свойств документа

5.1.2.5.1. Создание свойства

5.1.2.5.2. Изменение свойства

5.1.2.5.3. Удаление свойства

5.1.2.5.4. Добавление свойства из библиотеки свойств в документ

5.1.2.5.5. Копирование свойств компонента (или вставки) в документ-сборку (или чертеж/фрагмент)

5.1.2.5.6. Подключение свойства к документу


5.1.2.1. Настройка списка свойств для новых документов

Чтобы настроить список свойств для новых графических документов, вызовите команду Сервис — Параметры... — Новые документы — Графический документ — Настройка списка свойств, а для новых документов-моделей — команду Сервис — Параметры... — Новые документы — Модель — Деталь/Сборка — Настройка списка свойств.

На экране появится диалог, показанный на рис. 5.1.1.

Рис. 5.1.1. Настройка списка свойств новых документов,
подключение библиотеки свойств

Диалог содержит две вкладки: Библиотеки свойств и Свойства.

Вкладка Библиотеки свойств позволяет подключить библиотеки, свойства из которых могут использоваться в новых документах.

Чтобы подключить библиотеку, выполните следующие действия.

1. Добавьте библиотеку свойств в список библиотек. Для этого нажмите кнопку Добавить и укажите нужную библиотеку (файл с расширением lpt) в стандартном диалоге Windows открытия файлов. В список библиотек добавится строка, содержащая имя файла библиотеки и путь к нему.

2. Включите опцию слева от имени файла библиотеки в списке. Свойства из библиотеки будут добавлены в список свойств новых документов.

Вы можете редактировать список библиотек, перемещая или удаляя элементы списка. Для этого используются кнопки Переместить вверх/вниз и Удалить.

Список свойств новых документов содержится на вкладке Свойства. Чтобы настроить отображение свойств в новых документах, активизируйте эту вкладку (рис. 5.1.2).

Рис. 5.1.2. Настройка списка свойств новых документов,
настройка отображения свойств

В список входят системные свойства и свойства из подключенных библиотек. Опция слева от наименования свойства позволяет включить или отключить отображение этого свойства в новых документах.

Опция Все позволяет включить/отключить отображение всех свойств.

Чтобы просмотреть параметры свойства, выделенного в списке, нажмите кнопку Просмотр. На экране появится диалог Параметры свойства (рис. 5.1.3). В режиме просмотра данные, содержащиеся в диалоге, недоступны для редактирования.

Рис. 5.1.3. Просмотр параметров свойства


5.1.2.2. Настройка списка свойств текущего документа

Чтобы настроить список свойств текущего документа (чертежа, фрагмента, детали или сборки), вызовите команду Сервис — Параметры... — Текущий документ — Настройка списка свойств. На экране появится диалог, показанный на рис. 5.1.4.

Рис. 5.1.4. Настройка списка свойств текущего документа

В диалоге содержится одна вкладка Свойства. На этой вкладке расположен список свойств текущего документа. Кроме системных свойств список может содержать свойства, заданные пользователем, и свойства, добавленные из подключенных библиотек или файлов входящих в документ объектов, например, компонентов или вставок видов и фрагментов при работе с чертежом (см. раздел 5.1.2.3).

Настройте отображение свойств в текущем документе, включив или отключив опции слева от названий свойств.


5.1.2.3. Управление свойствами

Работа со свойствами документа и библиотеками свойств выполняется в диалоге Управление свойствами (рис. 5.1.5), который вызывается командой Сервис — Библиотеки стилей, типов, оформлений и основных надписей — Свойства объектов.... Диалог может быть также вызван с Панели свойств в процессе задания свойств документа или входящего в него объекта, а также в Редакторе свойств. О задании свойств и о работе в Редакторе рассказано в разделе 5.1.4.

В данном диалоге вы можете не только создать, но и включить отображение свойства в текущем документе.

Рис. 5.1.5. Диалог управления свойствами в сборке

Диалог содержит два окна просмотра. Чтобы выполнять действия в одном из окон, активизируйте его щелчком мыши. При этом кнопки, расположенные между окнами, становятся доступными для работы в активном окне.

Активным может быть только одно окно — оно выделено рамкой. Например, на рис. 5.1.5 активным является правое окно.

Каждое окно просмотра позволяет отобразить список свойств текущего документа или выбранной библиотеки свойств.

Для отображения свойств документа используется кнопка Показать документ, для отображения библиотеки свойств — кнопка Показать библиотеку.

На рис. 5.1.5 показан вариант, когда в левом окне просмотра отображается список Локальные свойства документа (свойства текущего документа), а в правом — список свойств из библиотеки properties.lpt.

Вид окна просмотра зависит от типа документа, выбранного для показа свойств.

– Для детали окно просмотра содержит вкладку Документ, на которой отображается список свойств текущего документа.

– Для сборки, чертежа или фрагмента окно просмотра содержит две вкладки. На вкладке Документ отображается список свойств текущего документа. Для сборки на вкладке Компоненты отображается список свойств компонентов данной сборки первого уровня, для чертежа или фрагмента на вкладке Вставки — список свойств вставок видов/фрагментов. На вкладке Компоненты или Вставки находятся только свойства, отличные от свойств документа.

В чертеже на вкладке Вставки находятся также свойства модели, по которой создан ассоциативный вид.

Список свойств на вкладке Документ имеет вид таблицы. В таблице отображаются источник и комментарий для каждого свойства, а также опция для подключения его к документу. Источником здесь может являться система (System), библиотека свойств или документ, из которого добавлено свойство.

Включенная опция означает, что данное свойство отображается в документе.

– Для библиотеки свойств окно просмотра не содержит вкладок. Список свойств библиотеки отображается в поле окна. В библиотеке возможно создание групп свойств на разных уровнях. Список свойств в окне может быть представлен в виде дерева, содержащего разделы и подразделы.

Каждому свойству в списке соответствует наименование и пиктограмма. Символы на пиктограмме показывают тип значения свойства:

– символ Т соответствует типу значения Строка,

– символ Л — типу значения Логический,

– символы 1,2 — типу значения Целый или Вещественный.

Пиктограмма системного свойства имеет серый цвет, пиктограмма дополнительного свойства — желтый.

Чтобы просмотреть информацию о свойстве, выделите его в списке и нажмите кнопку Просмотреть. На экране появится диалог Параметры свойства (см. рис. 5.1.3). В режиме просмотра данные, содержащиеся в диалоге, недоступны для редактирования.

Вы можете создавать новые библиотеки свойств (см. раздел 5.1.2.4), добавлять свойства в список свойств текущего документа или библиотеки, изменять или удалять существующие свойства (см. раздел 5.1.2.5).


5.1.2.4. Создание библиотеки свойств

Создание библиотеки свойств выполняется в диалоге Управление свойствами (см. рис. 5.1.5).

Для создания библиотеки выполните следующие действия.

1. Нажмите кнопку Показать библиотеку.

2. В появившемся диалоге укажите или создайте папку, в которой должна размещаться новая библиотека.

3. Введите имя новой (несуществующей) библиотеки и нажмите кнопку Открыть.

4. Ответьте Да на запрос системы о создании нового файла (рис. 5.1.6).

Активное окно просмотра диалога управления свойствами очистится, так как вновь созданная библиотека пуста.

Рис. 5.1.6. Запрос на создание файла новой библиотеки

5. Чтобы создать в библиотеке новый раздел, нажмите кнопку Создать раздел и введите имя раздела в появившемся на экране диалоге. Аналогично создайте все нужные разделы и подразделы.

6. Создайте нужные свойства, используя кнопку Создать свойство. Действия по созданию свойств подробно описаны в разделе 5.1.2.5.1.

При необходимости вы можете редактировать и удалять разделы библиотеки и свойства (см. разделы 5.1.2.5.2 и 5.1.2.5.3).

Кнопка Копировать вправо/влево позволяет копировать в библиотеку уже существующие свойства.

Кнопка Перенести вправо/влево позволяет переносить их.

Для выполнения этих действий в соседнем окне просмотра необходимо открыть нужный источник свойств для копирования (переноса) и выделить свойство.

Источником может быть текущий документ или библиотека свойств.

– При выборе документа вы можете не только копировать (переносить) свойства этого документа, но и копировать свойства входящих в него вставок.

– При выборе библиотеки вы можете копировать (переносить) как свойства, так и разделы этой библиотеки.

Системные свойства документов копировать и переносить нельзя.


5.1.2.5. Формирование списка свойств документа

По умолчанию список свойств документа содержит системные свойства и свойства из библиотек, подключенных при настройке (см. раздел 5.1.2.1). Вы можете редактировать список, создавая новые свойства, изменяя или удаляя существующие. Редактирование списка выполняется в диалоге Управление свойствами (см. рис. 5.1.5).

В этом разделе:

5.1.2.5.1. Создание свойства

5.1.2.5.2. Изменение свойства

5.1.2.5.3. Удаление свойства

5.1.2.5.4. Добавление свойства из библиотеки свойств в документ

5.1.2.5.5. Копирование свойств компонента (или вставки) в документ-сборку (или чертеж/фрагмент)

5.1.2.5.6. Подключение свойства к документу


5.1.2.5.1. Создание свойства

Включите отображение списка свойств текущего документа, нажав кнопку Показать документ. В окне просмотра будет раскрыта вкладка Документ, содержащая этот список.

Чтобы добавить новое свойство в список, нажмите кнопку Создать свойство. На экране появится диалог Параметры свойства (рис. 5.1.7). Элементы этого диалога описаны в таблице 5.1.1.

Рис. 5.1.7. Диалог создания свойства

Табл. 5.1.1. Диалог создания свойства

Элемент

Описание

Наименование

Поле позволяет ввести наименование свойства. Если свойство с таким наименованием уже существует в списке, то к наименованию вновь созданного свойства добавляется порядковый номер.

Тип данных

Раскрывающийся список позволяет выбрать тип значения свойства — Целый, Вещественный, Строка или Логический. От выбранного типа значения зависит доступность элементов управления диалога.

Заполнение из списка

Опция позволяет использовать список предопределенных значений при задании значения свойства. Чтобы сформировать список, включите эту опцию и нажмите кнопку Правило для значений.

Опция доступна для всех типов значения свойства, кроме логического.

Величина

Раскрывающийся список позволяет выбрать измеряемую сущность, с которой будет связано свойство. После выбора измеряемой сущности ее базовая единица измерения становится единицей измерения свойства.

Список доступен для значения свойства типа Вещественный или Строка.

Единица измерения

Раскрывающийся список позволяет выбрать единицу измерения свойства. Он содержит единицы измерения текущей измеряемой сущности.

Список доступен для значения свойства типа Вещественный или Строка.

Правило для значений

Значения свойства могут задаваться в рамках конкретного диапазона значений или выбираться из предопределенного списка (при включенной опции Заполнение из списка). Первый вариант доступен для значений типа Целый или Вещественный, второй вариант — для значений типа Целый, Вещественный или Строка.

При задании диапазона значений после нажатия кнопки на экране появляется диалог Правило для ввода значений (рис. 5.1.8). Он содержит поля ввода минимального и максимального значений свойства.

При задании списка значений после нажатия кнопки на экране появляется диалог Список значений (рис. 5.1.9). Описание элементов управления этого диалога приведено в таблице 5.1.2.

Поле значений

Поле служит для отображения правила, заданного для ввода значений свойства. Недоступно для редактирования.

Комментарий

Поле позволяет ввести дополнительные сведения о свойстве. Доступно для значений всех типов.

Идентификатор

Поле служит для отображения идентификатора свойства. Идентификатор назначается автоматически и не может быть изменен пользователем. Поле недоступно для редактирования.

Рис. 5.1.8. Диалог задания диапазона значений свойства

Рис. 5.1.9. Диалог создания списка значений свойства

Табл. 5.1.2. Диалог создания списка значений свойства
Наименование | Описание
Поле ввода значения | Поле служит для ввода текста нового значения. Чтобы данное значение было добавлено в список, нажмите кнопку Добавить значение или клавишу <Enter>.
Поле отображения списка | Поле служит для отображения сформированного списка значений.
Добавить значение | Кнопка позволяет добавить значение, заданное в поле ввода, в список значений.
Удалить значение | Кнопка позволяет удалить значение, указанное в списке.
Переместить значение в списке вверх/вниз | Кнопка позволяет переместить значение, указанное в списке, на одну позицию вверх или вниз.

Вновь созданное свойство добавляется в список свойств текущего документа. Его отображение включается автоматически.


5.1.2.5.2. Изменение свойства

В диалоге Управление свойствами (см. рис. 5.1.5) включите отображение списка свойств текущего документа, нажав кнопку Показать документ. В окне просмотра будет раскрыта вкладка Документ, содержащая этот список.

Чтобы изменить свойство текущего документа, выберите это свойство в списке свойств и нажмите кнопку Редактировать. На экране появится диалог Параметры свойства (см. рис. 5.1.7). Описание элементов управления диалога приведено в таблице 5.1.1.

При редактировании свойства вы можете изменить наименование свойства и дополнительные сведения о нем, выбрать единицу измерения из списка единиц измерения текущей измеряемой сущности, изменить граничные значения заданного диапазона значений или отредактировать сформированный список значений свойства.

Тип значения свойства, измеряемая сущность и правило ввода значений задаются при создании свойства и не могут быть изменены.

Изменения параметров системного свойства сохраняются в течение текущего сеанса работы КОМПАС-3D.


5.1.2.5.3. Удаление свойства

В диалоге Управление свойствами (см. рис. 5.1.5) включите отображение списка свойств текущего документа, нажав кнопку Показать документ. В окне просмотра будет раскрыта вкладка Документ, содержащая этот список.

Чтобы удалить свойство, выделите его в списке свойств и нажмите кнопку Удалить. На экране появится запрос на подтверждение удаления. Если удаляемое свойство имеет значение, заданное в текущем документе, то запрос на удаление будет содержать информацию об этом. Нажмите кнопку Да, чтобы подтвердить удаление, или кнопку Нет, чтобы отказаться от него.

Обратите внимание на то, что удалить можно только дополнительное свойство документа. Системные свойства недоступны для удаления.

Отменить удаление свойства невозможно.


5.1.2.5.4. Добавление свойства из библиотеки свойств в документ

Чтобы добавить свойство из библиотеки в документ, выполните следующие действия.

1. В одном из окон просмотра диалога Управление свойствами (см. рис. 5.1.5) включите отображение списка свойств текущего документа. Для этого нажмите кнопку Показать документ. В окне будет раскрыта вкладка Документ, содержащая список свойств.

2. В другом окне диалога включите отображение списка свойств библиотеки. Для этого нажмите кнопку Показать библиотеку и выберите файл нужной библиотеки в стандартном диалоге Windows открытия файлов.

3. Скопируйте или перенесите свойство из библиотеки в документ.

Чтобы скопировать свойство, выделите его в списке свойств библиотеки и нажмите кнопку Копировать вправо/влево.

Чтобы перенести выделенное свойство, нажмите кнопку Перенести вправо/влево. При этом свойство будет удалено из библиотеки свойств и добавлено в список свойств документа.

После того как свойство будет помещено из библиотеки в список локальных свойств, это свойство сохраняется в документе даже после удаления библиотеки.

Вы можете воспользоваться готовой библиотекой properties.lpt, входящей в комплект поставки системы КОМПАС-3D.


5.1.2.5.5. Копирование свойств компонента (или вставки) в документ-сборку (или чертеж/фрагмент)

5.1.2.5.5. Копирование свойств компонента (или вставки)
в документ-сборку (или чертеж/фрагмент)

Свойства компонентов сборки (или вставок чертежа/фрагмента) могут быть скопированы в список свойств данного документа. Для этого выполните следующие действия.

1. В одном из окон просмотра диалога Управление свойствами (см. рис. 5.1.5) включите отображение списка свойств текущего документа. Для этого нажмите кнопку Показать документ. В окне будет раскрыта вкладка Документ, содержащая список свойств.

2. В другом окне диалога включите отображение списка свойств компонентов текущей сборки (или вставок чертежа/фрагмента). Для этого нажмите кнопку Показать документ и раскройте вкладку Компоненты (или Вставки).

На вкладке Компоненты (или Вставки) содержатся те свойства компонентов (или вставок), которые отличаются от свойств текущего документа. Эти свойства доступны только для просмотра и копирования.

3. Выделите нужное свойство в списке свойств компонентов (или вставок) и нажмите кнопку Копировать вправо/влево. Свойство компонента будет скопировано в список свойств текущего документа.


5.1.2.5.6. Подключение свойства к документу

Подключение свойства к документу необходимо для того, чтобы можно было задать значение этого свойства.

Чтобы подключить свойство, в диалоге Управление свойствами включите опцию рядом со свойством на вкладке Документ окна Локальные свойства документа.

Подключенные свойства отображаются в списке при задании значений свойств (см. разделе 5.1.4).


5.1.3. Типы и значения свойств

5.1. Свойства

5.1.3. Типы и значения свойств

В этом разделе:

5.1.3.1. Системные свойства

5.1.3.2. Дополнительные свойства

5.1.3.2.1. Свойства, созданные из переменных


5.1.3.1. Системные свойства

Системные свойства — свойства, которые всегда находятся в документе и доступны для использования в нем, например, Обозначение, Наименование, Масса и т.д. Значения некоторых системных свойств определяются автоматически — исходя из данных, получаемых системой при работе с тем или иным объектом. Остальные значения задаются пользователем вручную — на Панели свойств, в Редакторе свойств и другими способами.

– Обозначение*, Наименование*

Значения задаются вручную или по ссылке на другой объект в документе (см. раздел 5.1.4.4.1). В чертеже значения могут быть заданы в основной надписи.

Вы можете выбрать обозначение документа или входящих в него объектов из внешнего Справочника (Классификатор ЕСКД). Для этого используется кнопка Выбрать обозначение из справочника. Справочник должен быть подключен к системе КОМПАС-3D.

Звездочкой (*) отмечены свойства, значения которых могут быть заданы в Редакторе свойств (см. раздел 5.1.4.2).

– Количество

Значение этого свойства устанавливается равным единице, так как в текущий момент времени возможна работа со свойствами только одного документа или объекта.

– Масса*

В графических документах значение задается вручную. В чертеже значение может быть задано в основной надписи. В свойствах ассоциативного чертежа по умолчанию отображается масса, заданная в модели, по которой создан вид.

Значение массы модели или ее части вычисляется при расчете массо-центровочных характеристик или задается вручную на вкладке Параметры МЦХ Панели свойств (см. раздел 2.14.6). Оно автоматически передается в список свойств документа.

– Материал*, Заменитель материала*, Покрытие*, Плотность*

В графическом документе значения задаются на вкладке Свойства Панели свойств. Возможен ручной ввод или выбор из справочников. В чертеже материал также может быть задан в основной надписи.

В модели материал выбирается из справочника, а плотность, заменители материала и покрытия могут выбираться из справочника или вводиться вручную. Материал модели или ее части можно задать на вкладке Свойства или на вкладке Параметры МЦХ Панели свойств. При выборе материала в список свойств документа передаются его обозначение, плотность и стиль штриховки.

Для выбора материала, заменителя материала и покрытия можно использовать:

• кнопку Выбрать материал из списка — материал выбирается из справочного файла плотностей (файл ...\ASCON\KOMPAS-3D V...\Sys\Grарhic.dns; содержимое файла может редактироваться пользователем),

• кнопку Выбрать материал из справочника — материал выбирается из внешнего справочника (справочник должен быть подключен к системе КОМПАС-3D).

В системе КОМПАС-3D имеется десять свойств Заменитель материала и десять свойств Покрытие. Это означает, что в одном и том же документе может быть выбрано десять различных заменителей материала и назначено до десяти видов покрытий.

– Знак неуказанной шероховатости*, Параметр неуказанной шероховатости*

В графическом документе эти параметры можно задать на вкладке Свойства Панели свойств вручную. Возможен ввод параметров с помощью команды Вставка — Неуказанная шероховатость — Ввод.

В модели параметры неуказанной шероховатости можно задать на вкладке Свойства Панели свойств. Если отображение знака включено, возможно задание параметров с помощью команды Редактировать неуказанную шероховатость.

– Автор*, Организация*, Комментарий*

Значения свойств связаны со сведениями, отображенными в диалоге Информация о документе (см. раздел 1.3.5) в текущем документе. Они могут задаваться вручную и редактироваться в документе.

– Тип объекта

Тип, к которому относится документ или объект — Чертеж, Вставка вида, Вставка фрагмента, Фрагмент, Макроэлемент, Сборочная единица, Деталь, Стандартное изделие, Компонент из библиотеки или Тело, определяется системой автоматически.

– Позиция

К компонентам и телам в модели могут быть проставлены позиции. Номера этих позиций используются в качестве значений свойства Позиция для компонентов и тел.

В графическом документе связь номера позиции с объектом осуществляется через объект спецификации. Подробнее об объектах спецификации в документах см. раздел 6.1.3.

– Имя файла, Полное имя файла

Свойства отображают имя файла и полный путь к файлу документа или объекта. Для объектов, не имеющих файла (например, для тел, графических макроэлементов), в значение свойства заносится путь к текущему документу.

– Создан, Последнее изменение

Даты создания и последнего изменения файла заполняются автоматически.

– Раздел спецификации*

Свойство, отражающее название раздела спецификации для входящего в документ объекта. Значение заполняется автоматически после создания объекта спецификации.

– Разработал*, Проверил*, Утвердил*, Технологический контроль*, Нормоконтроль*

Значения задаются вручную. В чертеже значения могут быть заданы в основной надписи.

Значения, заданные в документе-модели, передаются в свойства чертежа, созданного по этой модели (см. раздел Свойства модели в ассоциативном чертеже).

– Класс точности

Значение отражает класс точности, выбранный при создании модели (см. раздел 9.2.7.4.9).

В графическом документе значение задается вручную.


5.1.3.2. Дополнительные свойства

Дополнительное свойство — свойство из внешней библиотеки свойств. Дополнительные свойства создаются и назначаются документу пользователем.

Значения дополнительных свойств также задаются пользователем. Способ задания значения зависит от его типа.

– Значение типа Целый или Вещественный вводится в поле в числовом виде (вручную или при помощи счетчика) или выбирается из списка значений.

– Значение типа Строка вводится в поле в виде текста или выбирается из списка значений.

– Для задания значения типа Логический используется опция, расположенная в ячейке Значение свойства данного типа. Если опция включена, свойство имеет значение Да, если опция отключена — значение Нет.

Тип значения свойства и данные, необходимые для задания значения (диапазон значений, список значений), задаются при создании свойства (см. раздел 5.1.2.5.1).

Значения дополнительных свойств могут получать значения по ссылке на другой объект в документе. О ссылках в свойствах подробно рассказано в разделе 5.1.4.4.1.

В этом разделе:

5.1.3.2.1. Свойства, созданные из переменных


5.1.3.2.1. Свойства, созданные из переменных

В модели свойство может быть создано из переменной. Значение такого свойства изменяется автоматически при изменении значения переменной. И наоборот, если отредактировать значение свойства, то изменяется и значение переменной, что приводит к соответствующему перестроению модели.

Вы можете создавать свойства из всех переменных, кроме функциональных и интервальных (см. раздел 7.1.5.1).

Чтобы создать и добавить свойство из переменной в документ, в Окне переменных выделите нужную переменную и вызовите из контекстного меню команду Добавить в список свойств. Рядом с названием команды появится «галочка». Это означает, что свойство из данной переменной создано в документе. Повторный вызов команды удалит это свойство.

Созданное свойство и его значение появляется в списке свойств документа. Тип значения свойства определяется автоматически. Возможны следующие типы:

– Вещественный — для свойства, созданного из любой переменной, кроме переменной параметра Исключить из расчета,

– Логический — для свойства, созданного из переменной параметра Исключить из расчета.

Вы можете просмотреть перечень свойств, созданных из переменных, в диалоге Управление свойствами на вкладке Документ (рис. 5.1.10). Для этих свойств в списке свойств диалога автоматически создается раздел Переменные. Все свойства, созданные из переменных, помещаются в этот раздел. Наименования свойств и комментарии к ним соответствуют именам переменных и комментариям к ним в Окне переменных.

Свойства, входящие в раздел Переменные диалога Управление свойствами, доступны только для удаления. Редактировать, копировать и перемещать эти свойства нельзя.

При удалении свойства переменная, из которого создано свойство, не удаляется.

При удалении переменной удаляется только значение свойства, созданного из этой переменной. Само свойство остается в списке свойств документа. Удалять свойства необходимо вручную в диалоге Управление свойствами или с помощью команды Добавить в список свойств (см. выше).

Рис. 5.1.10. Свойства из переменных в диалоге Управление свойствами

Для изменения значений свойств, созданных из переменных, используются те же способы, что и для изменения значений других свойств документа (подробнее см. раздел 5.1.4.4.5).


5.1.4. Работа со свойствами

5.1. Свойства

5.1.4. Работа со свойствами

Вы можете задавать и просматривать свойства и их значения документу или входящим в него объектам следующими способами:

– используя элементы управления Панели свойств — при данном способе возможна работа со свойствами отдельного объекта или документа (см. раздел 5.1.4.1);

– в Редакторе свойств — при данном способе можно работать со свойствами всех объектов документа, а также самого документа (см. раздел 5.1.4.2).

Свойства объектов хранятся только в текущем документе и не передаются в файлы самих объектов. По умолчанию компоненты в модели и вставки в графическом документе отображаются со свойствами источника, которые при необходимости можно изменить. Измененные значения не передаются в файлы-источники.

Если объект используется в нескольких документах, то целесообразно задать свойства в файле-источнике. В этом случае все изменения, сделанные в файле объекта, передаются в документы.

При работе со свойствами рекомендуется использовать библиотеки свойств.

В этом разделе:

5.1.4.1. Задание значений свойств на Панели свойств

5.1.4.1.1. Общие приемы работы

5.1.4.1.2. Работа в документе-модели

5.1.4.1.3. Работа в чертеже

5.1.4.1.4. Работа во фрагменте

5.1.4.2. Редактор свойств

5.1.4.2.1. Отображение объектов

5.1.4.2.2. Настройка столбцов

5.1.4.2.3. Выделение ячеек и строк

5.1.4.2.4. Редактирование значений

5.1.4.2.5. Сохранение таблицы в файл и вывод на печать

5.1.4.3. Копирование свойств

5.1.4.4. Особенности задания свойств

5.1.4.4.1. Ссылка в значении свойства

5.1.4.4.2. Задание материала в документе-модели. Пересчет МЦХ

5.1.4.4.3. Задание материала в графическом документе

5.1.4.4.4. Задание обозначения

5.1.4.4.5. Задание значений свойств, созданных из переменных

5.1.4.4.6. Задание раздела спецификации


5.1.4.1. Задание значений свойств на Панели свойств

В этом разделе:

5.1.4.1.1. Общие приемы работы

5.1.4.1.2. Работа в документе-модели

5.1.4.1.3. Работа в чертеже

5.1.4.1.4. Работа во фрагменте


5.1.4.1.1. Общие приемы работы

После вызова команды Свойства модели (Свойства чертежа, Свойства вставки вида и т.д.) на Панели свойств появляются элементы управления свойствами, в том числе панель Список свойств (панель расположена на вкладке Свойства).

Панель содержит список свойств текущего документа, отображение которых включено (см. раздел 5.1.2.5.6), и элементы управления списком (рис. 5.1.11).

Рис. 5.1.11. Просмотр свойств сборки

Список свойств документа отображается в виде таблицы, в которой содержатся наименования свойств, их значения и единицы измерения.

Ячейки свойств, недоступные для редактирования на панели Список свойств, имеют серый фон.

При просмотре свойств объекта, входящего в документ, в ячейках столбца Источник некоторых свойств отображаются опции (рис. 5.1.12). Наличие опции показывает возможность получения значения свойства из источника — файла объекта. Возможны следующие варианты отображения опции.

– Опция включена. Значение свойства получено из источника и может быть заменено значением, заданным в текущем документе. После замены значения опция автоматически отключается.

– Опция отключена. Значение свойства задано в текущем документе на панели Список свойств. Чтобы получить значение свойства из источника, включите опцию.

– Опция включена и недоступна. Значение свойства получено из источника. Изменение значения свойства на панели Список свойств невозможно.

– Опция отключена и недоступна. Значение свойства задано в текущем документе (например, в модели значение массы компонента задано на вкладке Параметры МЦХ Панели свойств). Изменение значения свойства на панели Список свойств невозможно.

При необходимости вы можете просмотреть все свойства источника, нажав кнопку Свойства источника. После этого на экране появляется информационное окно, содержащее текущую дату, полное имя файла и список его свойств.

Рис. 5.1.12. Просмотр свойств компонента модели

В список свойств входят как системные, так и дополнительные свойства документа.

Задание значений системных свойств описано в разделе 5.1.3.1, задание значений дополнительных свойств — в разделе 5.1.3.2.

При задании значений свойств объектов, имеющих источник, обратите внимание на следующие особенности:

– умолчательным значением свойства является значение, переданное из источника — файла компонента, чертежа или фрагмента;

– значения свойств, заданные в документе входящим в него объектам, не передаются в файлы-источники.

Значения свойств текущего документа, заданные пользователем на панели Список свойств, могут быть удалены. Для удаления значения выделите его в списке свойств и нажмите кнопку Удалить значение.

Если значение свойства может быть получено из источника, то после выполнения удаления поле значения свойства автоматически заполняется значением из источника.

Чтобы создать ссылку в значении свойства на объект в документе, выделите свойство в списке и нажмите кнопку Вставить ссылку. Подробно работе со ссылками в свойствах рассказано в разделе 5.1.4.4.1.

Вы можете редактировать список свойств текущего документа и настраивать отображение свойств в списке, не прерывая работу в команде Свойства (документа).

– Редактирование списка свойств выполняется в диалоге Управление свойствами (см. раздел 5.1.2.3). Вы можете вызвать этот диалог, нажав одноименную кнопку.

– Настройка отображения свойств может выполняться в диалоге Настройка списка свойств (см. раздел 5.1.2.2). Вы можете вызвать этот диалог, нажав одноименную кнопку.

Чтобы просмотреть все значения свойств объектов документа, воспользуйтесь Редактором свойств (см. раздел 5.1.4.2).


5.1.4.1.2. Работа в документе-модели

При работе с документом-моделью значения свойств могут быть заданы как для самой модели, так и для ее тел и компонентов.

Для задания свойств документу-модели служит команда Свойства модели. Команда может быть вызвана из меню Файл или из контекстного меню корневого объекта Дерева модели.

Для задания свойств объектам модели служит команда Свойства компонента или Свойства тела. Команда может быть вызвана из контекстного меню объекта, выделенного в окне модели или Дереве модели.

После вызова команды на Панели свойств появляются элементы управления, позволяющие задать значения свойств или документа-модели, или входящего в него объекта.

Чтобы перенести свойства компонентов в документ-сборку, скопируйте их свойства в диалоге Управление свойствами на вкладке Компоненты (см. раздел 5.1.2.5.5).

Для задания свойств исполнениям служит команда Свойства исполнения. Команда вызывается в Дереве исполнений из контекстного меню исполнения. Работа в команде Свойства исполнения аналогична работе в команде Свойства модели.

О редактировании свойств исполнений см. раздел 2.13.3.4.

Общие приемы задания свойств описаны в разделе 5.1.4.1.1.


5.1.4.1.3. Работа в чертеже

В чертеже можно задать свойства документу и входящим в него вставкам видов, вставкам фрагментов и макроэлементам.

Команда Свойства чертежа позволяет просматривать и изменять свойства документа-чертежа. Команда может быть вызвана из меню Файл или из контекстного меню корневого объекта Дерева чертежа.

При помощи команд Свойства макроэлемента, Свойства вставки вида, Свойства вставки фрагмента можно задать свойства входящим в документ объектам. Команды вызываются из контекстного меню объекта, выделенного в окне или Дереве чертежа.

Чтобы перенести свойства вставок видов и фрагментов в документ-чертеж, скопируйте их свойства в диалоге Управление свойствами на вкладке Вставки (см. раздел 5.1.2.5.5).

Значения системных свойств определяются автоматически. Свойства Позиция и Раздел спецификации заполняются, если создан объект спецификации, связанный с макроэлементом или вставкой.

Значения таких системных свойств, как Обозначение, Наименование, Материал, Масса, Разработал, Проверил, Утвердил, Технологический контроль, Нормоконтроль, также могут быть заданы в основной надписи. После ее заполнения значения этих свойств отображаются в списке свойств документа. После редактирования значений при помощи команды Свойства чертежа или в Редакторе свойств все изменения передаются в соответствующие ячейки основной надписи.

Общие приемы задания свойств описаны в разделе 5.1.4.1.1.

Свойства модели в ассоциативном чертеже

В ассоциативный чертеж из документа-модели передаются следующие свойства, которые условно можно разбить на группы, отличающиеся по принципу работы с ними.

– Свойства Обозначение, Наименование.

Значения свойств, заданные в документе-модели, передаются в чертеж по модели, в том числе ячейки основной надписи, и наоборот, значения из документа-чертежа или его основной надписи — в свойства модели.

Значения могут быть отредактированы в любом месте: в чертеже при помощи команд Свойства чертежа или Основная надпись, в модели — Свойства модели.

О заполнении основной надписи ассоциативного чертежа см. раздел 3.7.3.8.

Если обозначение является составным, то из модели в чертеж и наоборот передаются все части обозначения, кроме кода. Особенности простых и составных обозначений описаны в разделе 5.1.4.4.4.

– Свойства Масса, Материал, Плотность.

Значения свойств задаются в документе-модели на вкладке Параметры МЦХ, передаются в чертеж по модели, в том числе в ячейки основной надписи.

Значения могут быть отредактированы: в чертеже при помощи команд Свойства чертежа или Основная надпись, в модели — Свойства модели.

В чертеж одновременно со свойством Материал передаются также параметры его штриховки — стиль, цвет и угол штриховки, заданные в модели для каждого материала (см. раздел .3.7.2.7.1).

Из чертежа в модель значения свойств не передаются.

– Свойства Разработал, Проверил, Утвердил, Технологический контроль, Нормоконтроль.

Значения свойств, заданные в документе-модели, передаются однократно в процессе создания чертежа в его свойства и основную надпись (при условии, что они ранее в чертеж не вводились). При дальнейшем редактировании передача значений свойств из чертежа в модель (или из модели в чертеж) не происходит. Значения следует редактировать вручную, например, для чертежа при помощи команды Свойства чертежа.

– Свойства компонентов и тел модели, по которой создан чертеж.

Доступны только для чтения. Для просмотра списка свойств служат команды Свойства компонента и Свойства тела. Они могут быть вызваны из контекстного меню модели.

В списке перечислены свойства, включенные для отображения в документе-чертеже. Для изменения списка отображаемых свойств служит команда Управление свойствами (см. раздел .5.1.2.3).

Свойства графических макроэлементов

Графическим макроэлементам могут быть заданы свойства в документе или библиотеке фрагментов.

Для этого служит команда Свойства макроэлемента. Команда может быть вызвана из контекстного меню макроэлемента.

Заданные макроэлементу свойства переносятся при его копировании и вставке.


5.1.4.1.4. Работа во фрагменте

Во фрагменте можно задать свойства документу и входящим в него вставкам фрагментов и макроэлементам.

Команда Свойства фрагмента позволяет просматривать и изменять свойства документа-фрагмента. Команда может быть вызвана из меню Файл.

При помощи команд Свойства вставки фрагмента и Свойства макроэлемента можно задать свойства входящим в документ объектам. Команды вызываются из контекстного меню объекта, выделенного в окне документа.

Чтобы перенести свойства вставок фрагментов в документ-фрагмент, скопируйте их свойства в диалоге Управление свойствами на вкладке Вставки (см. раздел 5.1.2.5.5).

Общие приемы задания свойств описаны в разделе 5.1.4.1.1.


5.1.4.2. Редактор свойств

Редактор свойств позволяет:

– просматривать и редактировать свойства объектов в текущем документе;

– создавать и добавлять новые свойства;

– сохранять значения свойств в отдельный файл или выводить на печать.

Редактор свойств появляется на экране после вызова команды Редактор свойств, которая может быть вызвана при работе с документами-моделями или графическими документами нажатием кнопки на панели Отчеты или выбором названия из меню Сервис — Отчеты.

После вызова команды на экране появляется диалог Редактор свойств (рис. 5.1.13).

В диалоге находится окно, в котором в виде таблицы отображаются объекты и их свойства. Элементы управления диалога позволяют управлять отображением свойств в Редакторе и выполнять различные действия с ними.

Рис. 5.1.13. Диалог Редактор свойств в модели

В этом разделе:

5.1.4.2.1. Отображение объектов

5.1.4.2.2. Настройка столбцов

5.1.4.2.3. Выделение ячеек и строк

5.1.4.2.4. Редактирование значений

5.1.4.2.5. Сохранение таблицы в файл и вывод на печать


5.1.4.2.1. Отображение объектов

В столбце Наименование находится перечень объектов, имеющий структуру Дерева.

Если кнопка Группировка нажата, то объекты отображаются сгруппированными. Это означает, что расположенные на одном уровне объекты с совпадающими свойствами представлены одной строкой. Количество объектов группы суммируется и отображается в свойстве Количество. В качестве значений остальных свойств отображаются значения одного объекта группы. Строки, не имеющие совпадающего с другими свойства, остаются без изменения. Пиктограммы для сгруппированных объектов приведены в таблице 5.1.3.

Если кнопка отжата, то отображается полный перечень объектов.

В чертеже при включенной группировке объектов может выполняться также группировка объектов по видам. Для этого щелкните мышью по треугольнику справа от кнопки группировки и в появившемся меню вызовите команду Группировать по видам. После вызова команды объекты отображаются сгруппированными по своим видам. Наименования видов доступны для редактирования.

Если в чертеже присутствуют несколько видов с одной модели, то модель отображается в нескольких видах документа. При этом в свойстве Количество для такой модели всегда указана единица.

Рис. 5.1.14. Вызов команды группировки по видам в чертеже

Для управления сортировкой объектов служит кнопка Сортировка. Объекты в диалоге отсортированы по типам, независимо от того, нажата кнопка или нет.

Если кнопка Сортировка нажата, то объекты каждого типа сортируются по алфавиту. Если кнопка отжата, то объекты отображаются в порядке их создания.

Чтобы включить или выключить отображение объектов того или иного типа в Редакторе, нажмите кнопку Состав Дерева построения.

На экране появляется меню, содержащее перечень типов объектов. «Галочка» слева от названия означает, что отображение объектов соответствующего типа включено, отсутствие «галочки» — отключено.

Включенный вариант Показать все, находящийся в меню, означает показ всех типов.

Чтобы задать уровень, до которого включительно отображаются объекты из состава сборочных единиц модели, нажмите кнопку Уровень. Становится доступным список, из которого можно выбрать номер уровня.

По умолчанию кнопка не нажата. Это означает, что для редактирования доступны объекты всех уровней модели.

Элемент Уровень присутствует в Редакторе при работе в чертеже или сборке.

Табл. 5.1.3. Пиктограммы сгруппированных объектов в Редакторе свойств
Пиктограмма | Типы сгруппированных объектов
 | Детали
 | Подсборки
 | Библиотечные компоненты
 | Стандартные изделия
 | Локальные детали
 | Вставки видов в чертеже
 | Вставки фрагментов в чертеже
 | Макроэлементы в чертеже


5.1.4.2.2. Настройка столбцов

По умолчанию в Редакторе свойств находятся столбцы со свойствами, подключенными к документу. Каждый столбец в Редакторе соответствует одному свойству.

Чтобы изменить набор свойств, отображаемых в Редакторе, нажмите кнопку Настройка столбцов. На экране появится диалог, в котором вы можете сформировать набор отображаемых свойств и настроить их взаимное расположение (рис. 5.1.15).

Рис. 5.1.15. Диалог настройки столбцов в Редакторе свойств

В диалоге перечислены локальные свойства документа. Из них в окне Доступные свойства находятся свойства документа, доступные для выбора, а в окне Отображаемые свойства — свойства, выбранные для отображения в Редакторе.

Чтобы добавить свойство в список отображаемых свойств, выделите его в окне Доступные свойства и нажмите кнопку Перенести вправо. Свойство будет перенесено в окно Отображаемые свойства.

Чтобы удалить свойство из списка отображаемых, выделите его в окне Отображаемые свойства и нажмите кнопку Перенести влево. Свойство будет удалено из этого окна, оно появится в окне Доступные свойства.

При необходимости вы можете изменить список доступных свойств. Для этого нажмите кнопку Управление свойствами. На экране появится диалог Управление свойствами, позволяющий добавить свойство в документ, создать новое свойство, подключить новое или ранее созданное свойство. Подключенное свойство автоматически появляется в окне Отображаемые свойства. О работе в диалоге Управление свойствами рассказано в разделе 5.1.2.3.

Вы можете изменить порядок следования свойств в Редакторе свойств, перемещая их в окне Отображаемые свойства. Для этого выделите свойство, положение которого требуется изменить, и нажмите кнопку Переместить вверх/вниз. Кнопка доступна, если свойство можно переместить на указанную позицию.

Свойство Наименование переместить или удалить из списка отображаемых нельзя.

После завершения настройки столбцов нажмите кнопку ОК.


5.1.4.2.3. Выделение ячеек и строк

Выделение ячеек может потребоваться для задания значений свойств, в том числе при вставке ссылок, копировании, удалении и других действиях с содержимым ячеек. Содержимое выделенных ячеек или строк через буфер обмена могут быть вставлены в документы других приложений Windows.

Чтобы выделить ячейку, щелкните по ней мышью. Чтобы выделить строку, щелкните мышью на поле в начале строки (см. рис. 5.1.13).

Чтобы выделить несколько ячеек или строк, щелкайте по ним мышью при нажатой клавише <Ctrl>. Чтобы выделить несколько ячеек или строк подряд, щелкните по первой, а затем по последней выделяемой ячейке или строке при нажатой клавише <Shift>.

Выделение ячейки в таблице сопровождается выделением соответствующего объекта в документе.

Чтобы отменить выделение, щелкните мышью по свободному от таблицы месту окна.


5.1.4.2.4. Редактирование значений

В Редакторе свойств вы можете отредактировать значения свойств документа и входящих в него объектов. Ячейки, недоступные для редактирования, имеют серый фон1. Значения свойств, заданные в файле-источнике, отображены синим цветом, а заданные в текущем документе — черным.

– Чтобы изменить значение свойства, щелкните мышью по выделенной ячейке и отредактируйте в ней текст.

При редактировании свойств сгруппированных объектов изменения передаются во все объекты группы.

– Чтобы вернуть значение свойства из источника, выделите ячейку и вызовите команду Источник из контекстного меню.

– Чтобы копировать, вставить, вырезать, удалить содержимое выделенных строк или ячеек, используйте команды контекстного меню. Чтобы вставить предварительно скопированное содержимое ячеек, выделите такой же диапазон ячеек и вызовите команду вставки.

– Вы можете вставлять содержимое отдельных ячеек или строк через буфер обмена в документы других приложений Windows.

– Вместо значения свойства вы можете вставить ссылку на объект документа. Подробно о вставке и редактировании ссылок см. раздел 5.1.4.4.1.

Вы можете изменять материал и его плотность, а также массу объектов. Подробно о редактировании МЦХ в Редакторе свойств см. раздел 5.1.4.4.2.

Вы можете отредактировать системные свойства документа — Автор, Организация, Комментарий.

Чтобы отменить редактирование ячейки, выделите ячейку и нажмите кнопку Исходный текст в диалоге. После нажатия кнопки ячейка приобретает тот вид, который имела после открытия диалога.

Отмена редактирования невозможна, если была разрушена ссылка или значения в ячейках свойств заданы в диалогах, вызываемых из Редактора, например, Обозначение, Материал, Масса и другие.

Для передачи изменений в документ или обновления ссылок нажмите кнопку Применить диалога. В этом случае отказаться от изменений невозможно.

  1. Исключение составляют свойства модели Масса, Материал, Плотность, Заменитель материала, Покрытие, Раздел спецификации — их ячейки имеют серый фон, но значения можно редактировать.


5.1.4.2.5. Сохранение таблицы в файл и вывод на печать

Чтобы сохранить таблицу в файл, нажмите кнопку Сохранить как... диалога и выберите тип файла.

– КОМПАС-Чертежи (файл *.cdw),

– КОМПАС-Фрагменты (файл *.frw),

– КОМПАС-Текстовые документы (файл *.kdw),

– КОМПАС-Таблицы (файл *.tbl),

– Текстовые файлы (файл *.txt),

– Электронные таблицы ODF (файл *.ods),

– Электронные таблицы Microsoft Excel (файл *.xls).

При сохранении в графический или текстовый КОМПАС-документ используются параметры текста, заданные при настройке таблицы отчета для документов соответствующего типа. Например, чтобы настроить параметры текста при сохранении таблицы в графическом документе, вызовите команду Сервис — Параметры — Новые документы — Графический документ — Параметры таблицы отчета — Заголовок/Ячейка. Об элементах управления диалога см. раздел 9.2.4.3.

Чтобы напечатать содержимое окна Редактора, нажмите кнопку Печать. В появившемся диалоге задайте параметры печати, затем нажмите кнопку ОК.


5.1.4.3. Копирование свойств

При копировании объектов у объектов-копий автоматически создаются свойства, повторяющие свойства исходного объекта.

Для графических объектов

– при «перетаскивании» объекта мышью при нажатой клавише <Ctrl> — свойства копируются всегда;

– при вставке графического объекта из буфера обмена или в процессе работы команд симметрии, масштабирования, сдвига, поворота, а также операций копирования указанием, по кривой, по сетке и т.п. — копированием свойств можно управлять.

Копированию подлежат системные свойства, значения которых задаются пользователем, и все дополнительные свойства. Подробно о задании значений свойств рассказано в разделе 5.1.3.

Для управления копированием служит группа переключателей Копирование свойств на вкладке Атрибуты Панели свойств команды.

При активном переключателе Не копировать объект копируется без свойств.

Если требуется создать копию с такими же свойствами, как у оригинала, активизируйте переключатель Копировать.

Если в команде предусмотрена возможность удаления или оставления исходного объекта, то свойства копируются при выбранном варианте Оставлять исходные объекты в группе Режим на Панели свойств.

Если ни один из объектов, выбранных для копирования, не имеет свойств, заданных пользователем, переключатели Копирование свойств недоступны.

Для моделей копирование свойств происходит при копировании объектов, например, при «перетаскивании» с нажатой клавишей <Ctrl> пиктограммы компонента из Дерева в окно модели.

Также при создании массивов свойства исходного объекта (компонента или тела) копируются в каждый экземпляр массива.


5.1.4.4. Особенности задания свойств

В этом разделе:

5.1.4.4.1. Ссылка в значении свойства

5.1.4.4.2. Задание материала в документе-модели. Пересчет МЦХ

5.1.4.4.3. Задание материала в графическом документе

5.1.4.4.4. Задание обозначения

5.1.4.4.5. Задание значений свойств, созданных из переменных

5.1.4.4.6. Задание раздела спецификации


5.1.4.4.1. Ссылка в значении свойства

Вы можете вместо значения свойства вставить ссылку на объект, который находится в текущем документе и содержит текстовую или числовую информацию. Вставленную ссылку можно отредактировать или разрушить.

Работа со ссылками может производиться:

– на Панели свойств при задании значений свойств документа или объекта (о задании значений на Панели свойств см. раздел 5.1.4.1);

– в Редакторе свойств (о Редакторе свойств см. раздел 5.1.4.2).

Чтобы вставить ссылку, выделите одну ячейку со значением свойства и вызовите команду Вставить ссылку. Команда может быть вызвана нажатием кнопки, расположенной над списком, а в Редакторе свойств также и из контекстного меню выделенной ячейки.

После вызова команды на экране появляется диалог, в котором следует настроить параметры ссылки. Действия по настройке аналогичны действиям, производимым при вставке ссылки в текст (см. раздел 3.4.1.4).

После вставки значение свойства заменяется значением, полученным из источника ссылки. Значение свойства со ссылкой отображено синим цветом.

Значения по ссылке могут получать свойства с любым типом данных, кроме логического.

Рекомендуется вставлять ссылки на данные, тип которых соответствует типу данных значения свойства. Например, если значение свойства имеет тип данных целый, то в эту ячейку следует вставлять ссылку на целое значение в источнике.

Чтобы отредактировать ссылку, выделите ячейку со ссылкой и вызовите из контекстного меню команду Редактировать ссылку. На экране появится тот же диалог, что и при создании ссылки. Внесите изменения и закройте диалог.

Чтобы удалить связь между ссылкой и ее источником, выделите ячейку со ссылкой и вызовите из контекстного меню команду Разрушить ссылку. В результате разрушения содержимое ссылки становится значением свойства, которое можно редактировать вручную.

Отмена разрушения ссылки невозможна.


5.1.4.4.2. Задание материала в документе-модели. Пересчет МЦХ

Вы можете редактировать значения системных свойств Материал, Плотность, Масса, а также производить пересчет МЦХ1 модели.

Это можно выполнять:

– при помощи команды Свойства модели на вкладке Параметры МЦХ на Панели свойств при задании значений свойств;

– в Редакторе свойств (о Редакторе свойств см. раздел 5.1.4.2).

В Редакторе свойств используются те же приемы, что в команде Свойства модели (см. разделы 2.14.6.1–2.14.6.4).

Чтобы в Редакторе свойств изменить материал, плотность или массу объекта, выполните следующие действия.

1. Вызовите диалог редактирования свойства объекта. Для этого:

– выделите ячейку со значением свойства Материал, Плотность или Масса и нажмите кнопку Параметры МЦХ на инструментальной панели Редактора, или

– дважды щелкните по ячейке мышью, или

– нажмите кнопку с многоточием в правой части выделенной ячейки (рис. 5.1.16).

Рис. 5.1.16. Вызов диалога редактирования материала в модели

На экране появляется диалог, в котором можно внести изменения в значения свойств.

Рис. 5.1.17. Диалог изменения значений свойств для МЦХ

В диалоге находятся такие же элементы управления, как при задании значений свойств на Панели свойств (в команде Свойства модели на вкладке Параметры МЦХ).

2. Выберите способ пересчета МЦХ объекта.

– Из источника — активизация переключателя означает, что значения свойств для компонента берутся из файла-источника, для тела — из текущего документа.

– Расчет по плотности — активизируйте этот переключатель, чтобы задать материал и/или плотность материала для расчета массы модели или тела.

– Расчет по массе — активизируйте этот переключатель, чтобы задать значение массы вручную. Он доступен в диалоге при настройке детали, сборки или компонента сборки.

При открытии диалога активизированный переключатель обозначает способ, примененный в расчете МЦХ текущего объекта.

3. Задайте новые параметры: материал, плотность или массу, а также параметры штриховки, если требуется.

Чтобы обновить значение массы объекта, нажмите кнопку Пересчитать МЦХ в диалоге.

После нажатия кнопки происходит расчет МЦХ объекта (детали, компонента или тела), с учетом изменений МЦХ, сделанных ранее для содержащихся в объекте тел и компонентов. Результат пересчета массы отображается в строке Масса диалога.

Нажмите кнопку ОК диалога.

4. Примените новые свойства к модели. Для этого нажмите кнопку Применить в Редакторе свойств. Измененные свойства отображаются в Редакторе.

5. Отредактируйте МЦХ всех необходимых объектов, как описано в п.п.1–4.

Чтобы в Редакторе свойств пересчитать МЦХ всей модели, вызовите диалог для ее корневого объекта и нажмите в нем кнопку Пересчитать МЦХ.

При задании значений свойств необходимо учитывать следующее.

– Если настраивается тело, то выбранный материал считается собственным материалом этого тела.

– Если настраивается деталь, то выбранный материал применяется к тем ее телам, которым не задан собственный материал.

– Если настраивается сборка, то выбранный материал применяется только к телам, созданным в этой сборке (не к компонентам!), причем к тем из них, которым не задан собственный материал.

– Если настраивается компонент сборки, то выбор материала имеет смысл, только если этот компонент — деталь. Заданное значение плотности применяется к тем ее телам, которым не задан собственный материал.

Свойства материала — плотность и параметры штриховки, в том числе и заданные вручную — сохраняются вместе с материалом в модели и применяются к телам деталей, компонентов, сборок по приведенным выше правилам.

Чтобы отменить редактирование и установить значения свойств объекта из источника, вызовите для этого объекта диалог и активизируйте переключатель Из источника. Затем примените данное изменение к модели нажатием кнопки Применить в Редакторе свойств.

При необходимости вы можете назначить материал с помощью кнопки Выбрать материал из списка или Выбрать материал из справочника на инструментальной панели Редактора свойств. В первом случае материал выбирается из справочного файла плотностей, а во втором — из внешнего Справочника, подключенного к системе КОМПАС-3D.

  1. Пересчет МЦХ заключается в определении массы модели с учетом изменений текущей плотности, а также массы входящих в модель компонентов и тел.


5.1.4.4.3. Задание материала в графическом документе

Вы можете задавать свойства Материал и Плотность для графических объектов, выбирая значения из справочного файла плотностей или внешнего Справочника, подключенного к системе КОМПАС-3D.

Справочный файл плотностей Grарhic.dns поставляется вместе с системой и располагается в подпапке \Sys главной папки КОМПАС-3D. Пользователь может добавлять и редактировать значения в файле.

Это можно выполнять:

– при помощи команды Свойства чертежа (Свойства фрагмента, Свойства макроэлемента и т.д.) на Панели свойств (о задании значений свойств на Панели свойств см. раздел 5.1.4.1);

– в Редакторе свойств (о Редакторе свойств см. раздел 5.1.4.2).

Чтобы задать свойство, выделите ячейку со значением свойства Материал и нажмите кнопку Выбрать материал из списка или Выбрать материал из справочника на панели инструментов.

В Редакторе свойств выбрать материал из справочника можно также нажатием кнопки с многоточием в правой части выделенной ячейки Материал или Плотность или двойным щелчком мыши по ячейке.

Рис. 5.1.18. Вызов диалога редактирования материала в графическом документе


5.1.4.4.4. Задание обозначения

Обозначение документа (объекта) может быть простым или составным. Обозначение считается простым, если оно включает в себя только базовое обозначение. В составное обозначение помимо базовой части входит номер исполнения (при работе с графическими документами и компонентами сборки — также дополнительный номер исполнения) и код.

Код, заданный в модели, передается в спецификацию, созданную по данной модели, и не передается в ассоциативный чертеж модели.

Примеры кода модели:

– МД — Электронная модель детали,

– МС — Электронная модель сборочной единицы.

Простое обозначение можно вводить или редактировать непосредственно в отведенной для него ячейке. Составное обозначение задается в специальном диалоге Обозначение, где для каждой части обозначения предусмотрено отдельное поле. Работа в диалоге описана в разделе 2.13.2.1.1.

Вы можете задавать обозначение документа или выбранного объекта:

– На Панели свойств при задании значений свойств документа или объекта (о задании значений на Панели свойств см. раздел 5.1.4.1). Простое обозначение вводится непосредственно в ячейку обозначения. Для вызова диалога Обозначение выделите ячейку и вызовите команду Редактировать обозначение из контекстного меню.

– В Редакторе свойств (о Редакторе свойств см. раздел 5.1.4.2). Простое обозначение вводится непосредственно в ячейку обозначения. Для вызова диалога Обозначение выделите ячейку и нажмите кнопку с многоточием в ее правой части.

Если ячейка уже содержит составное обозначение, для вызова диалога Обозначение можно дважды щелкнуть мышью в этой ячейке.

Составное обозначение «превращается» в простое, если очистить в диалоге поля с номером исполнения, дополнительным номером и кодом (разделители должны быть системными или отсутствовать).


5.1.4.4.5. Задание значений свойств, созданных из переменных

Свойство модели, созданное из переменной, получает значение этой переменной. О создании свойств из переменных см. раздел 5.1.3.2.1.

Вы можете изменить значение свойства способами, предусмотренными для свойств документа. Для этого используются элементы управления Панели свойств (см. раздел 5.1.4.1) или Редактор свойств (см. раздел 5.1.4.2).

Обратите внимание на то, что значение свойства можно изменять только в том случае, если значение переменной, из которой создано свойство, задано числом. Если значение задано константой, выражением или ссылкой на переменную внешнего файла, то оно недоступно для изменения. Также недоступны для изменения значения свойств, созданных из информационных переменных или переменных, на которые наложено ограничение Только чтение.

Значение свойства, созданного из переменной параметра Исключить из расчета, изменяется с помощью включения/отключения опции (о переменных исключения объектов из расчета см. раздел 7.1.4.1.1).

Если для создания свойства используется переменная параметра операции, значение которого выражено в линейных или угловых величинах, или переменная управляющего размера эскиза, то при работе с этим свойством на Панели свойств или в Редакторе свойств можно назначить/изменить допуск на соответствующее значение параметра или допуск на размер.

Для назначения/изменения допуска используется диалог Значение и допуск. Диалог вызывается командой Назначить допуск из контекстного меню ячейки со значением свойства, расположенной на Панели свойств или в Редакторе свойств.

Диалог Значение и допуск показан на рис. 2.13.6. Элементы назначения допуска описаны в таблице 3.3.5, поле Значение — в разделе 2.13.3.5.4.

После редактирования значения свойства автоматически изменяется значение соответствующей переменной, что приводит к перестроению модели.


5.1.4.4.6. Задание раздела спецификации

Свойство Раздел спецификации предназначено главным образом для формирования в сборке набора соответствующих компонентам объектов спецификации для последующей передачи их в документ-спецификацию.

– Если в файле компонента нет объекта спецификации, то значение свойства Раздел спецификации определяется типом файла компонента: детали (*.m3d) считаются входящими в раздел Детали, а сборки (*.a3d) — в раздел Сборочные единицы. Пользователь может произвольно менять значение свойства, т.е. перевыбирать раздел, в котором должен находиться соответствующий компоненту объект спецификации.

– Если в файле компонента есть объект спецификации, то значением свойства Раздел спецификации для этого компонента является название раздела, которому принадлежит объект спецификации. Чтобы иметь возможность менять значение свойства Раздел спецификации для такого компонента, нужно отключить синхронизацию соответствующего ему внутреннего объекта спецификации сборки с документом-владельцем (см. раздел 6.2.3.5.3).

Тела в модели также могут иметь свойство Раздел спецификации. По умолчанию значение этого свойства для тел не задано.

Кроме того, свойство Раздел спецификации можно задать и модели в целом. Если в ней не было объекта спецификации, то он будет создан в указанном разделе (в сборке формируется внешний объект спецификации), а если был, то будет перенесен в указанный раздел.

Свойство Раздел спецификации для модели или ее объекта можно задать следующими способами:

– на Панели свойств (см. раздел 5.1.4.1.1) — при помощи команды Назначить раздел, вызываемой из контекстного меню ячейки Раздел спецификации или двойным щелчком мыши по ячейке;

– в Редакторе свойств (см. раздел 5.1.4.2) — нажатием кнопки с многоточием в правой части выделенной ячейки Раздел спецификации или двойным щелчком мыши по ячейке.

После вызова команды на экране появляется такой же диалог, как при добавлении базового объекта в спецификацию (см. раздел 6.2.2.3.1).

Рис. 5.1.19. Вызов диалога для выбора раздела спецификации объекта

В диалоге следует выбрать раздел и нажать кнопку Создать, а затем подтвердить задание значения свойства нажатием кнопки Создать объект (на Панели свойств) или ОК (в Редакторе свойств).

Список доступных для выбора разделов определяется стилем спецификации, входящим в текущее описание спецификации (см. раздел 6.1.3.4).

Опции Текстовая часть в виде строки, Синхронизировать наименование с материалом и кнопка Выбрать шаблон доступны, если свойство Раздел спецификации назначается модели впервые. При изменении значения уже имеющегося у модели свойства доступен лишь список разделов и подразделов. Чтобы указанные элементы управления стали доступны, необходимо удалить объект спецификации, связанный с настраиваемой моделью.

Шаблон заполнения текстовой части объекта спецификации

Для разделов Стандартные изделия и Материалы возможно заполнение текстовой части в виде строки (вариант по умолчанию) или по шаблону.

Выбрать шаблон можно в диалоге выбора раздела (рис. 5.1.19). Для этого следует отключить опцию Текстовая часть в виде строки и нажать ставшую доступной кнопку Выбрать шаблон.

Выбранный шаблон можно отредактировать с помощью команды Шаблон заполнения текстовой части контекстного меню ячейки Раздел спецификации на Панели свойств.

После вызова команды появляется диалог редактирования шаблона. В диалоге отображается таблица, в ячейках которой можно вводить или изменять значения, предложенные по умолчанию.

Рис. 5.1.20. Диалог для заполнения текстовой части по шаблону

Задайте значения в полях таблицы, после чего нажмите кнопку ОК диалога.

Заданный текст автоматически попадает в объект спецификации.

Связь между объектом спецификации и материалом компонента

Если модели, ее компоненту или телу (далее — «модели») назначается раздел спецификации Материалы, то доступно три способа автоматического формирования объекта спецификации:

– Связь объекта спецификации со свойством Материал настраиваемой модели. Для этого в диалоге выбора раздела должна быть включена опция Синхронизация наименование с материалом (она доступна, если включена опция Текстовая часть в виде строки).
В колонку Наименование объекта спецификации передается наименование материала модели. Если материал был выбран из Справочника Материалы и Сортаменты, то в объекте спецификации заполняются также дополнительные колонки ID материала и Обозначение материала.
Наименование материала модели становится также наименованием самой модели (т.е. свойство Наименование автоматически получает такое же значение, как свойство Материал).
В дальнейшем при изменении материала модели изменяется ее наименование и соответствующий объект спецификации, а при изменении материла в спецификации изменяется наименование и материал модели.

– Связь объекта спецификации со свойством Наименование настраиваемой модели. Для этого в диалоге выбора раздела опция Текстовая часть в виде строки должна быть включена, а опция Синхронизировать наименование с материалом — отключена.
В колонку Наименование объекта спецификации передается наименование модели.
В дальнейшем изменение наименования модели приводит к изменению объекта спецификации и наоборот.
Изменение материала модели не влияет ни на ее наименование, ни на объект спецификации.

– Заполнение текстовой части объекта спецификации по шаблону. Для этого обе опции — Текстовая часть в виде строки и Синхронизировать наименование с материалом — должны быть отключены.
Выбор шаблона и его редактирование описаны выше.


5.2. Отчеты

В этом разделе:

5.2.1. Общие сведения

5.2.2. Подготовка к созданию отчета

5.2.2.1. Свойства в отчете

5.2.2.2. Стили отчета

5.2.2.2.1. Общие сведения

5.2.2.2.2. Работа с библиотеками стилей

5.2.2.2.3. Настройка стиля

5.2.2.2.4. Настройка «шапки» таблицы

5.2.2.2.5. Способы группировки данных

5.2.2.2.6. Сортировка данных

5.2.2.2.7. Настройка оформления

5.2.2.2.8. Подключение стилей отчетов

5.2.2.3. Настройка

5.2.2.3.1. Настройка формата и полей листа

5.2.2.3.2. Настройка параметров текста

5.2.3. Создание отчетов и работа с ними

5.2.3.1. Объекты, помещаемые в отчет

5.2.3.2. Команды создания и вставки отчета

5.2.3.3. Порядок создания отчета

5.2.3.3.1. Способы указания объектов

5.2.3.3.2. Выбор типов объектов

5.2.3.3.3. Компоновка отчета

5.2.3.3.4. Настройка условий фильтрации объектов по свойствам

5.2.3.4. Окно подготовки данных

5.2.3.4.1. Общие сведения

5.2.3.4.2. Режимы работы в Окне подготовки данных

5.2.3.5. Приемы работы в Окне подготовки данных

5.2.3.5.1. Настройка текущих параметров в Окне подготовки данных

5.2.3.5.2. Фильтрация строк

5.2.3.5.3. Выделение строк

5.2.3.5.4. Скрытие строк

5.2.3.5.5. Вставка строк

5.2.3.5.6. Копирование строк

5.2.3.5.7. Удаление строк

5.2.3.5.8. Перемещение строк вверх и вниз

5.2.3.5.9. Перемещение строк в начало страницы

5.2.3.5.10. Редактирование текста в отчете

5.2.3.5.11. Объединение ячеек в строке

5.2.3.5.12. Поиск текста в отчете

5.2.3.5.13. Сохранение в отдельный файл

5.2.3.5.14. Просмотр перед печатью и печать

5.2.3.5.15. Размещение отчета в документе

5.2.3.6. Названия и нумерация таблиц отчета

5.2.3.7. Данные в виде ссылок

5.2.3.8. Ассоциативные отчеты

5.2.3.8.1. Редактирование

5.2.3.8.2. Обновление таблиц

5.2.3.8.3. Разрушение ассоциативности отчета

5.2.3.9. Примеры создания отчетов

5.2.3.9.1. Простой отчет

5.2.3.9.2. Ассоциативный отчет


5.2.1. Общие сведения

5.2. Отчеты

5.2.1. Общие сведения

В КОМПАС-3D возможно создание отчетов, представляющих собой таблицы с размещенными в них данными об объектах. Данные об объектах, помещаемые в отчет, задаются при создании этих объектов как значения свойств.

Отчеты могут использоваться для выпуска различных табличных документов без жесткой привязки к требованиям стандартов какой-либо одной системы или отрасли. При редактировании данных, собранных в отчете, свойства объектов не изменяются.

В таблицу отчета заносятся сведения из документа-модели или графического документа. Например, в отчете могут быть перечислены свойства деталей — наименование, обозначение, масса, количество, позиция, изготовитель, цена и т.д. Список деталей и набор свойств, помещаемых в отчет, определяется пользователем.

Объектами, по которым формируется отчет, служат компоненты любого уровня (в том числе стандартные и библиотечные изделия), тела, а также графические макроэлементы, вставки видов и фрагментов.

Свойствами, которые передаются в отчет, являются системные и дополнительные свойства объекта. О задании свойств подробно рассказано в разделе 5.1.

Внешний вид отчета определяется стилем отчета, параметры которого задаются пользователем.

При создании отчетов в системе КОМПАС-3D предусмотрены следующие возможности:

– выбор объектов в соответствии с заданными критериями, такими как тип или свойство объекта, а также ограничение определенным уровнем структуры модели (для ассоциативных чертежей — уровнем чтения модели);

– получение сведений о свойствах тех или иных объектов с возможностью подсчета суммы их значений, а также редактирование свойств;

– использование предварительно подготовленных стилей отчетов, которые при необходимости могут быть отредактированы в процессе формирования отчета;

– вывод отчетов на печать;

– размещение полученных отчетов в существующих или во вновь созданных графических или текстовых документах системы КОМПАС-3D, а также сохранение отчетов в самостоятельные файлы КОМПАС-Чертежи (файл *.cdw), КОМПАС-Фрагменты (файл *.frw), КОМПАС-Текстовые документы (файл *.kdw), КОМПАС-Таблицы (файл *.tbl), Текстовые файлы (файл *.txt), Электронные таблицы ODF (файл *.ods), Электронные таблицы Microsoft Excel (файл *.xls);

– создание ассоциативного отчета — таблицы, связанной с документом, по объектам которого он был получен.

Кнопки вызова команд для работы с отчетами расположены на инструментальной панели Отчеты.

Рис. 5.2.1. Инструментальная панель Отчеты


5.2.2. Подготовка к созданию отчета

5.2. Отчеты

5.2.2. Подготовка к созданию отчета

Подготовка к созданию отчета включает в себя подготовку графических объектов и моделей, по которым создается отчет, создание стиля отчета или библиотеки стилей, общие настройки системы КОМПАС-3D.

– Подготовка объектов заключается в том, чтобы заранее задать им необходимые свойства. О свойствах в отчетах рассказано в разделе 5.2.2.1.

– Настройка стиля отчета включает в себя задание параметров, определяющих внешний вид отчета. Стили отчета могут быть предварительно созданы и сохранены в библиотеку. О работе со стилями отчета рассказано в разделе 5.2.2.2.

– Настройки системы КОМПАС-3D заключаются в задании параметров, необходимых при размещении отчета в документах. О настройке системы рассказано в разделе 5.2.2.3.

Для ознакомительной работы подготовка к созданию отчета необязательна. Вы можете использовать настройки системы КОМПАС-3D по умолчанию.

В этом разделе:

5.2.2.1. Свойства в отчете

5.2.2.2. Стили отчета

5.2.2.2.1. Общие сведения

5.2.2.2.2. Работа с библиотеками стилей

5.2.2.2.3. Настройка стиля

5.2.2.2.4. Настройка «шапки» таблицы

5.2.2.2.5. Способы группировки данных

5.2.2.2.6. Сортировка данных

5.2.2.2.7. Настройка оформления

5.2.2.2.8. Подключение стилей отчетов

5.2.2.3. Настройка

5.2.2.3.1. Настройка формата и полей листа

5.2.2.3.2. Настройка параметров текста


5.2.2.1. Свойства в отчете

Свойствами, по которым создается отчет, являются локальные свойства документа. По умолчанию это системные свойства — наименование, обозначение, материал, масса, количество, плотность, тип объекта, имя файла, раздел спецификации, дата создания и другие.

Пользователь может включить в список локальных свойств дополнительные свойства из библиотек.

По умолчанию используется библиотека свойств Properties.lpt. Библиотека содержит дополнительные свойства — марку, мощность, стандарт, цену и другие свойства. Вы можете создать несколько библиотек свойств (файлов *.lpt) для формирования отчетов различного назначения и добавлять из них свойства в документ.

Значения свойств попадают в отчет, если они заданы до начала его создания. Если значение не задано, то ячейка данного свойства в отчете будет незаполненной.

В отчетах, имеющих связь со свойствами объектов (ассоциативный отчет, отчет с данными в виде ссылок), значения свойств можно задавать и после создания отчета — они попадут в него автоматически.

О создании свойств, настройке списка и задании значений свойств подробно рассказано в разделе 5.1.

Кнопка Управление свойствами на панели Отчеты служит для вызова диалога, в котором можно отредактировать список свойств документа. Диалог также может быть вызван командой Сервис — Библиотеки стилей, типов, оформлений и основных надписей — Свойства объектов....


5.2.2.2. Стили отчета

В этом разделе:

5.2.2.2.1. Общие сведения

5.2.2.2.2. Работа с библиотеками стилей

5.2.2.2.3. Настройка стиля

5.2.2.2.4. Настройка «шапки» таблицы

5.2.2.2.5. Способы группировки данных

5.2.2.2.6. Сортировка данных

5.2.2.2.7. Настройка оформления

5.2.2.2.8. Подключение стилей отчетов


5.2.2.2.1. Общие сведения

Стиль отчета определяет внешний вид отчета. Настройки стиля отчета влияют на отображение тех или иных свойств в столбцах, именование столбцов, порядок их следования в отчете, способы сортировки и группировки, габариты ячеек и способ выравнивания текста в них, разбиение таблиц на страницы и другие параметры.

Вы можете создавать стили следующими способами.

– Стиль может быть создан или отредактирован в составе библиотеки стилей до формирования отчета. О создании и настройке стилей рассказано в разделах 5.2.2.2.2–5.2.2.2.7.

– Текущий стиль отчета может быть настроен непосредственно в процессе создания отчета. Данный стиль доступен для использования только до конца сеанса работы с документом.

Для многократного использования стиль следует сохранить в библиотеку.

Библиотеки стилей отчетов — внешние по отношению к документам файлы (*.lrt). Библиотеки могут быть переданы на другие рабочие места. Стили, хранящиеся в библиотеках, доступны при создании отчетов в разных документах.

Для использования стилей из библиотеки ее необходимо подключить к системе (см. раздел 5.2.2.2.8).

В системе КОМПАС-3D находятся системные стили отчета — По умолчанию и По всем свойствам. Эти стили доступны в процессе создания отчета (см. раздел 5.2.3.3). На их основе можно создать новый стиль, но нельзя отключить или удалить из системы, а также перенести в какую-либо библиотеку стилей отчетов.


5.2.2.2.2. Работа с библиотеками стилей

Команда Стили отчетов позволяет работать с библиотеками стилей отчетов. Для вызова команды нажмите кнопку на панели Отчеты или выберите ее название из меню Сервис — Библиотеки стилей, типов, оформлений и основных надписей.

После вызова команды на экране появляется диалог Стили отчетов, в котором вы можете создавать, просматривать, редактировать стили, хранящиеся в библиотеке, а также редактировать структуру библиотек, копировать и перемещать стили из одной библиотеки в другую.

На рис. 5.2.2 показан диалог работы с библиотеками стилей отчетов.

Элементы управления диалога представлены в таблице 5.2.1.

Рис. 5.2.2. Диалог работы с библиотеками стилей отчетов

Табл. 5.2.1. Диалог работы с библиотеками стилей отчетов

Элемент

Описание

Окно просмотра

Служит для отображения списка стилей библиотеки.

Диалог имеет два окна просмотра, поэтому в нем одновременно могут отображаться списки стилей двух разных библиотек. Активным может быть только одно окно — оно выделено рамкой. Например, на рис. 5.2.2 активным является левое окно. Активизация производится щелчком мыши в окне.

Списки стилей имеют структуру дерева — разделы, подразделы и т.д., содержащие стили. Уровень вложенности разделов не ограничен. Все объекты дерева автоматически сортируются по именам внутри каждого раздела.

Показать
библиотеку

Позволяет отобразить в активном окне список стилей, хранящихся в библиотеке, а также создать новую библиотеку.

После нажатия кнопки на экране появляется диалог, в котором необходимо задать имя файла.

Новый раздел

Позволяет создать новый подраздел в текущем разделе. После нажатия кнопки на экране появляется диалог, в котором нужно ввести имя нового раздела (подраздела).

Создать стиль

Позволяет создать новый стиль в текущем разделе библиотеки. После нажатия кнопки на экране появляется диалог, в котором необходимо выполнить действия по созданию нового стиля (см. раздел 5.2.2.2.3).

Просмотреть

Позволяет просмотреть выделенный стиль. После нажатия кнопки (или двойного щелчка мышью по стилю) на экране появляется диалог настройки параметров стиля в режиме просмотра.

Редактировать

Позволяет отредактировать выделенный объект — наименование раздела (подраздела) или стиль. После нажатия кнопки на экране появляется:

– если был выделен раздел — диалог создания и редактирования его имени;

– если был выделен стиль — диалог создания и редактирования стиля.

Удалить

Позволяет удалить выделенный стиль или раздел. Раздел удаляется вместе со всеми стилями в нем.

Внимание! Восстановление удаленного стиля или раздела библиотеки невозможно.

Копировать1

влево/вправо

Позволяет производить обмен стилями или разделами между библиотеками. После нажатия кнопки выделенный стиль или раздел копируется в соседнее окно в раздел, который является в нем текущим.

Перенести1

влево/вправо

Позволяет переносить стили или разделы из одной библиотеки в другую. После нажатия кнопки выделенный стиль или раздел переносится в текущий раздел соседнего окна.
  1. Кнопки доступны, если в неактивном окне просмотра открыта библиотека.

Чтобы создать новую библиотеку, выполните следующие действия.

1. Нажмите кнопку Показать библиотеку в диалоге работы с библиотеками (рис. 5.2.2). В появившемся диалоге выбора файлов введите несуществующее имя, нажмите кнопку Открыть и подтвердите создание файла. Активное окно диалога работы с библиотеками стилей очистится, так как вновь созданная библиотека пуста.

Если вы планируете хранить в библиотеке большое количество стилей, то рекомендуется разбить их на тематические группы — разделы; впоследствии это облегчит поиск нужного стиля.

2. Чтобы создать раздел, нажмите кнопку Новый раздел и введите в появившемся диалоге имя раздела. Сформируйте структуру библиотеки, добавляя в нее разделы.

3. Чтобы создать стиль, выделите в окне раздел, в котором должен содержаться создаваемый стиль. Нажмите кнопку Создать стиль. В появившемся диалоге выполните действия по настройке параметров нового стиля (см. раздел 5.2.2.2.3).

Для завершения работы со стилями служит кнопка Выход. После ее нажатия все добавления, удаления или изменения стилей будут автоматически сохранены.


5.2.2.2.3. Настройка стиля

Настройка стиля отчета осуществляется в диалоге Параметры стиля отчета. В диалоге вы можете настроить и сохранить стиль текущего отчета в библиотеку стилей.

Диалог появляется на экране:

– после нажатия кнопки Создать стиль (Просмотреть, Редактировать) в диалоге работы с библиотеками стиля (см. раздел 5.2.2.2.2);

– после нажатия кнопки Настроить... на Панели свойств команды Создать отчет, в том числе и в Окне подготовки данных.

На рис. 5.2.3 показан диалог настройки параметров стиля отчета.

Рис. 5.2.3. Диалог настройки параметров стиля отчета

Элементы управления диалога представлены в таблице 5.2.2.

Табл. 5.2.2. Диалог настройки параметров стиля отчета

Элемент

Описание

Имя стиля

Поле, в котором отображается имя стиля.

Введите имя стиля, под которым его требуется сохранить в библиотеку.

Идентификатор

Справочное поле, содержащее уникальный номер, который система автоматически присваивает создаваемому стилю. Данный номер будет отображаться в диалоге при последующем просмотре или редактировании сформированного стиля.

Заголовок...

Кнопка для вызова диалога, в котором можно настроить «шапку» таблицы. О настройке см. раздел 5.2.2.2.4.

Окно настройки

Окно, в котором отображаются настройки стиля в виде таблицы. Таблица содержит

– столбцы по количеству свойств объекта — название свойства находится в первой строке таблицы;

– строки, в ячейках которых расположены элементы управления для настройки каждого свойства — название настройки находится слева от окна, а результат настройки отображается в ячейке.

Для стиля По умолчанию в столбцах заданы свойства Обозначение, Наименование, Количество, Масса, для стиля По всем свойствам — все локальные свойства документа.

При создании нового стиля окно пусто. Чтобы заполнить окно, нажмите кнопку Добавить столбец слева/справа нужное количество раз и отредактируйте настройки для каждого столбца. Описание элементов управления окна представлено в таблице 5.2.3.

Добавить столбец
слева/справа

Кнопка, после нажатия которой столбец с умолчательными настройками добавляется слева/справа от текущего.

Если окно пусто, то в нем появляется столбец со свойством Обозначение.

Удалить столбец

Кнопка, после нажатия которой текущий столбец удаляется.

Переместить столбец
влево/вправо

Кнопка, после нажатия которой текущий столбец перемещается влево/вправо, меняясь местами с рядом стоящим столбцом. Кнопка доступна, если слева/справа от текущего в таблице имеется хотя бы один столбец.

Сохранить в библиотеку как...

Кнопка для вызова диалога сохранения стиля в библиотеку стилей. В появившемся диалоге укажите файл существующей библиотеки или введите имя новой библиотеки. Стиль будет сохранен под именем, заданным в поле Имя стиля.

Табл. 5.2.3. Элементы управления окна настройки параметров

Элемент

Описание

Свойство

Поле1 свойства объекта. Выберите вариант свойства из списка, в котором доступны все локальные свойства документа.

Если нужное свойство в списке отсутствует, щелкните мышью по строке Настроить.... На экране появляется диалог, позволяющий настроить список и выбрать свойство из библиотеки свойств.

Выполните следующие действия.

– Чтобы добавить в список свойство из библиотеки, подключите библиотеку на вкладке Библиотеки свойств. Работа в диалоге аналогична настройке списка свойств для новых документов (см раздел 9.2.6.5).

– Чтобы настроить список, включите опции рядом с нужными свойствами на вкладке Свойства. Выделенное при этом свойство автоматически становится выбранным вариантом свойства в столбце отчета.

Имя столбца

Строка заголовков столбцов в отчете. Например, свойство Масса может иметь в отчете заголовок Масса, кг.

По умолчанию имя столбца совпадает со свойством.

Введите имя столбца.

Отображать

Опция, позволяющая включать/отключать показ столбца в отчете. Если опция включена, то столбец отображается в отчете. Если опция выключена, то столбец не отображается.

Единица измерения

Поле1 единицы измерения свойства. Выберите единицу измерения из списка.

Знаков после запятой

Поле, в котором можно задать количество знаков после запятой для вещественных значений.

Сортировка

Поле, в котором отображаются параметры сортировки.

– Если поле пусто, то сортировка по данному свойству не производится.

– Если в поле находится текст, то данное свойство участвует в сортировке. Например, текст Приоритет 1 “А-Я” означает, что свойство имеет первый приоритет и его ячейки отсортированы в алфавитном порядке.

Щелчком мыши на поле вызывается диалог, в котором можно настроить сортировку данных. О настройке сортировки см. раздел 5.2.2.2.6.

Группировка

Поле1 параметра, по которому производится группировка объектов в отчете.

В поле отображается умолчательный способ группирования. Например, способ Совпадение для наименований означает, что все объекты с совпадающими наименованиями представлены одной строкой. Выберите способ.

Подробно о способах группировки рассказано в разделе 5.2.2.2.5.

Ширина столбца, мм

Поле ширины столбца отчета в миллиметрах. Введите целое число.

Выравнивание

Поле1 параметра выравнивания в ячейках столбца, кроме ячейки заголовка.

Выберите способ выравнивания. Параметры способа стилевое задаются в диалоге настройки параметров текста документа, в котором размещается отчет (см. раздел 5.2.2.3.2).

Переносить по словам

Опция, позволяющая настроить отображение в ячейках текста, длина которого превышает ширину столбца.

Если опция включена, то фрагменты текста, отделенные пробелом, могут быть перенесены на новую строку. Если опция выключена, то содержимое ячейки отображается одной строкой с сужением символов.

Оформление

Кнопка для вызова диалога, в котором можно настроить параметры оформления отчета. О настройке оформления см. раздел 5.2.2.2.7.
  1. Элемент управления позволяет выбрать вариант из раскрывающегося списка. После щелчка мышью по ячейке в ее правом углу появляется кнопка с треугольником. При нажатии на кнопку на экране появляется список, из которого можно выбрать вариант параметра.

Настройки текущего стиля сохраняются до конца сеанса работы КОМПАС-3D.


5.2.2.2.4. Настройка «шапки» таблицы

Для настройки «шапки» таблицы используется диалог Заголовок таблицы (рис. 5.2.4), который вызывается нажатием кнопки Заголовок....

Рис. 5.2.4. Диалог Заголовок таблицы

Диалог содержит поле настройки «шапки» таблицы и инструментальную панель.

По умолчанию в поле диалога отображаются только заголовки столбцов, заданные в диалоге Параметры стиля отчета.

Чтобы добавить новую строку, нажмите кнопку Вставить строку сверху. В окне диалога появится пустая строка. В дальнейшем вы можете использовать для добавления строк как эту команду, так и команду Вставить строку снизу. Добавление выполняется относительно той строки, в которой находится курсор.

Добавьте нужное количество строк.

Если требуется удалить одну из добавленных строк, установите в нее курсор и нажмите кнопку Удалить строку.

Количество ячеек в строке совпадает с количеством столбцов таблицы. Вы можете объединять и разбивать ячейки.

Чтобы объединить ячейки, необходимо их выделить. Ячейки выделяются мышью, как описано в разделе 4.2.2.2.

Для объединения выделенных ячеек используется кнопка Объединить ячейки. Подробнее об объединении ячеек см. раздел 4.2.2.3.

Чтобы разделить ячейку на несколько ячеек, установите в ней курсор и нажмите кнопку Разбить ячейки. На экране появится диалог, позволяющий задать параметры разделения ячейки. Работа в диалоге описана в разделе 4.2.2.4.

Объединение и разбиение ячеек доступно только для добавленных строк.

Вы можете изменять размеры ячеек, «перетаскивая» их границы курсором (см. раздел 4.2.2.7). Стиль линий границ выделенных ячеек настраивается в диалоге Границы, который появляется на экране после вызова команды Границы... контекстного меню. Работа в диалоге описана в разделе 4.2.2.8.

Текст в ячейки «шапки» таблицы вводится обычным образом (см. раздел 4.2.2.1). Вы можете не только вводить текст в ячейки добавленных строк, но и редактировать текст заголовков столбцов, заданный в диалоге Параметры стиля отчета.

После выполнения всех необходимых действий по настройке «шапки» таблицы закройте диалог Заголовок таблицы, нажав кнопку ОК.


5.2.2.2.5. Способы группировки данных

Группирование — это объединение объектов, имеющих определенные значения свойств, для отображения их в отчете в компактном виде. При группировке происходит автоматическая замена нескольких строк свойства одной строкой (далее — результирующей).

Доступны следующие способы группирования.

Совпадение — группируются только строки с одинаковыми значениями выбранного столбца. При этом значение свойства отображается в результирующей ячейке/ячейках каждой группы. Строки, не имеющие совпадающего с другими свойства, остаются без изменения.

Сумма — группируются все строки данного столбца. При этом в результирующую ячейку/ячейки группы помещается суммарное значение свойства.

Диапазон — группируются все строки данного столбца. При этом в результирующую ячейку/ячейки группы помещаются разделенные многоточием минимальное и максимальное значения свойства.

Способы Сумма и Диапазон доступны только для числовых свойств, например, Количество или Длина.

Перечисление — группируются все строки данного столбца. При этом в результирующую ячейку/ячейки группы помещаются разделенные точкой с запятой все значения свойства подряд.

Обратите внимание на то, что группировка позволяет объединять объекты по нескольким свойствам одновременно.

Если к какому-либо свойству применяется способ Совпадение, то способы Сумма, Диапазон, Перечисление автоматически работают внутри каждой группы, полученной в результате объединения совпадающих обозначений.

Например, установлена группировка Совпадение для обозначений и наименований, Сумма — для количества, Перечисление — для изготовителя. Отчет будет содержать строки, представляющие собой группы деталей, имеющих совпадающие обозначения и наименования одновременно. В каждой группе в столбце Количество число деталей будет просуммировано, а в столбце Изготовитель перечислены заводы.


5.2.2.2.6. Сортировка данных

Сортировка данных служит для отображения объектов в отчете по группам, образованным из объектов с одинаковыми свойствами. При этом внутри каждой группы объекты могут располагаться в алфавитном порядке (прямом или обратном), или в порядке возрастания или убывания численных значений, или по списку значений.

Настройка сортировки данных в отчете производится в диалоге, который появляется на экране после щелчка на поле Сортировка в диалоге Параметры стиля отчета.

Предусмотрено три уровня сортировки:

– Приоритет 1 (Уровень 1) — сортировка всех объектов;

– Приоритет 2 (Уровень 2) — сортировка в получившихся группах;

– Приоритет 3 (Уровень 3) — сортировка в получившихся подгруппах.

Стиль По умолчанию предусматривает сортировку на первом уровне по обозначению, на втором — по наименованию в алфавитном порядке.

Чтобы изменить настройку сортировки, выполните следующие действия.

1. Настройте первый уровень. Для этого раскройте список Уровень 1. Список содержит свойства объекта, находящиеся в окне диалога Параметры стиля отчета и строку с вариантом Нет, означающую отказ от сортировки.

Выберите свойство или отказ от сортировки.

2. Выберите вариант расположения объектов внутри группы.

А-Я — в алфавитном порядке или по возрастанию чисел,

Я-А — в обратном алфавитном порядке или по убыванию чисел.

По списку — в порядке, отображенном в списке значений свойства. Опция доступна, если в списке Уровень 1 выбрано свойство, при создании которого в диалоге Параметры свойства установлен список значений. Подробно о создании свойств рассказано в разделе 5.1.2.5.1.

3. Аналогично первому настройте второй и третий уровни сортировки при помощи элементов Уровень 2 и Уровень 3.

Результат настройки сортировки отображается в строке Сортировка диалога Параметры стиля отчета в ячейках свойств, участвующих в сортировке.

В отчете к одному и тому же свойству может быть применена группировка и сортировка одновременно. При этом должен быть выбран способ группировки Совпадение.


5.2.2.2.7. Настройка оформления

Настройка оформления в стиле отчета производится в диалоге, который появляется на экране после нажатия кнопки Оформление в диалоге Настройка стиля отчета.

Элементы управления диалога представлены в таблице 5.2.4.

Табл. 5.2.4. Диалог настройки параметров оформления

Элемент

Описание

Строить снизу вверх

Опция, позволяющая управлять порядком расположения строк в отчете. Если опция выключена, то заголовок и строки следуют сверху вниз.

Если опция включена, то заголовок помещается на нижней строке и строки следуют снизу вверх.

Отображать заголовок

Группа элементов, позволяющая управлять размещением в отчете заголовков столбцов.

Если опция Отображать заголовок включена, то на каждой странице таблицы помещается строка с заголовками, заданными в поле Имя столбца диалога Параметры стиля отчета. Высоту строки можно задать в поле Высота строки заголовка таблицы, мм.

Если опция выключена, то строка отсутствует.

Высота строки заголовка таблицы, мм1

Поле для ввода или задания счетчиком высоты строки заголовка.

Высота строки ячейки таблицы, мм

Поле для ввода или задания счетчиком высоты строк.

Нумерация столбцов

Группа элементов, позволяющая управлять нумерацией столбцов. Если опция Нумерация столбцов выключена, то строка с номерами отсутствует.

Если опция включена, то в таблице после заголовка автоматически помещается строка с номерами столбцов. Для настройки параметров нумерации служат поля Формат номера и Начинать с.

Формат номера1

Список, из которого можно выбрать формат номера — буквы или цифры.

Начинать с1

Поле для ввода или задания счетчиком начального номера в нумерации столбцов.

Нумерация строк

Группа элементов, позволяющая управлять нумерацией строк. Если опция Нумерация строк выключена, то столбец с номерами отсутствует.

Если опция включена, то в таблицу автоматически добавляется первый столбец с заголовком «N» и номерами строк.Выполняется одноуровневая или многоуровневая нумерация, в зависимости от выбранного варианта.

Одноуровневая1

Вариант нумерации, при выборе которого все строки в отчете нумеруются подряд в порядке возрастания.

Многоуровневая1

Вариант нумерации, при выборе которого строки нумеруются внутри каждого уровня отдельно. Выполняется для моделей, содержащих компоненты. Например, в сборке компоненты первого уровня будут иметь номера 1, 2, 3, ..., а входящие в них компоненты — номера 1.1, 1.2, 1.3, ..., 2.1, 2.2, 2.3, ..., 3.1, 3.2, 3.3, ... и т.д.

Разбивать на страницы

Группа элементов, позволяющая управлять разбиением таблицы.

Если опция Разбивать на страницы включена, то таблица автоматически разбивается на несколько страниц с равным количеством строк в каждой. Количество строк можно задать в поле Строк на страницу. Также можно управлять наличием пустых строк на последней странице.

Если опция выключена, то отчет представляет собой одну таблицу.

Строк на страницу1

Поле для ввода или задания счетчиком количества строк таблицы на одной странице.

Оставлять пустые строки1

Опция, позволяющая задавать вид последней станицы. Если опция включена, то на последней странице могут отображаться строки после последнего объекта, оставшиеся пустыми.
  1. Элемент управления доступен, если включена опция в данной группе.


5.2.2.2.8. Подключение стилей отчетов

Чтобы подключить стили, находящиеся в библиотеке стилей, вызовите команду Сервис — Параметры... — Система — Отчеты — Настройка списка стилей отчетов.

Элементы управления диалога описаны в разделе 9.1.12.1.

Общий порядок подключения стиля следующий.

1. На вкладке Библиотеки стилей добавьте нужный файл библиотеки стилей отчета. Для этого нажмите кнопку Добавить.

2. Включите опцию рядом с названием добавленной библиотеки. Стили из этой библиотеки появятся на вкладке Стили.

3. На вкладке Стили включите опцию рядом с названием нужного стиля.

Для завершения настройки нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.

Вы можете использовать одновременно несколько библиотек стилей отчетов и подключать из них стили по мере необходимости.

Подключение стилей из библиотек возможно также в процессе создания отчета. Подробно о создании отчета см. раздел 5.2.3.3.


5.2.2.3. Настройка

В этом разделе:

5.2.2.3.1. Настройка формата и полей листа

5.2.2.3.2. Настройка параметров текста


5.2.2.3.1. Настройка формата и полей листа

Вы можете задать формат листа и отступы от его границ, которые будут использоваться при выводе текущего отчета на печать из Окна подготовки данных.

Чтобы настроить формат листа отчета, вызовите команду Сервис — Параметры... — Система — Отчеты — Размещение таблицы — Формат листа. В появившемся на экране диалоге выберите формат листа документа из стандартного ряда или задайте произвольные размеры листа.

Чтобы задать поля на листе отчета, вызовите команду Сервис — Параметры... — Система — Отчеты — Размещение таблицы — Поля листа. В появившемся на экране диалоге введите или задайте счетчиком величины полей.

Просмотреть отчет с текущими настройками формата и полей листа можно в Окне подготовки данных в режиме разметки страниц. Для включения этого режима служит кнопка Разметка страниц на панели Вид Окна подготовки данных.

Элементы управления диалога описаны в разделе 9.1.12.3.


5.2.2.3.2. Настройка параметров текста

Настройка параметров текста заголовков и ячеек таблицы отчета возможна:

– для текстовых документов (см. раздел 9.2.4.7) — настройка используется при размещении отчета в текстовом документе;

– для графических документов (см. раздел 9.2.6.24) — настройка используется:

• при размещении отчета в графическом документе;

– при отображении отчета по графическому документу в Окне подготовки данных;для документов-моделей (см. раздел 9.2.7.8) — настройка используется при отображении отчета по модели в Окне подготовки данных.

Элементы управления диалога описаны в разделе 9.2.4.3.

Исключение составляет параметр Выравнивание, который задается в настройках стиля для ячеек каждого столбца отдельно (о настройках стиля см. раздел 5.2.2.2.3).

В настроечных диалогах, описанных в разделе 9.2.4.3, вы можете задать только параметры способа — стилевое выравнивание. Для этого выберите способ выравнивания (справа, слева или по центру) с ненулевым отступом.

Отчет может создаваться по объектам одного документа, а размещаться в другом. Если настройка текста в этих документах различна, то вид отчета в Окне подготовки данных может отличаться от вида этого же отчета, вставленного в документ.

По умолчанию для текстовых, графических документов и документов-моделей установлены одинаковые параметры текста отчета.

Настройка параметров текста названия таблицы выполняется:

– для неассоциативных отчетов — в диалоге настройки параметров текста таблиц (см. раздел 9.2.6.17.3),

– для ассоциативных отчетов — в диалоге настройки параметров текста отчетов (см. раздел 9.2.6.24.3).


5.2.3. Создание отчетов и работа с ними

5.2. Отчеты

5.2.3. Создание отчетов и работа с ними

В этом разделе:

5.2.3.1. Объекты, помещаемые в отчет

5.2.3.2. Команды создания и вставки отчета

5.2.3.3. Порядок создания отчета

5.2.3.3.1. Способы указания объектов

5.2.3.3.2. Выбор типов объектов

5.2.3.3.3. Компоновка отчета

5.2.3.3.4. Настройка условий фильтрации объектов по свойствам

5.2.3.4. Окно подготовки данных

5.2.3.4.1. Общие сведения

5.2.3.4.2. Режимы работы в Окне подготовки данных

5.2.3.5. Приемы работы в Окне подготовки данных

5.2.3.5.1. Настройка текущих параметров в Окне подготовки данных

5.2.3.5.2. Фильтрация строк

5.2.3.5.3. Выделение строк

5.2.3.5.4. Скрытие строк

5.2.3.5.5. Вставка строк

5.2.3.5.6. Копирование строк

5.2.3.5.7. Удаление строк

5.2.3.5.8. Перемещение строк вверх и вниз

5.2.3.5.9. Перемещение строк в начало страницы

5.2.3.5.10. Редактирование текста в отчете

5.2.3.5.11. Объединение ячеек в строке

5.2.3.5.12. Поиск текста в отчете

5.2.3.5.13. Сохранение в отдельный файл

5.2.3.5.14. Просмотр перед печатью и печать

5.2.3.5.15. Размещение отчета в документе

5.2.3.6. Названия и нумерация таблиц отчета

5.2.3.7. Данные в виде ссылок

5.2.3.8. Ассоциативные отчеты

5.2.3.8.1. Редактирование

5.2.3.8.2. Обновление таблиц

5.2.3.8.3. Разрушение ассоциативности отчета

5.2.3.9. Примеры создания отчетов

5.2.3.9.1. Простой отчет

5.2.3.9.2. Ассоциативный отчет


5.2.3.1. Объекты, помещаемые в отчет

Объекты, которые могут быть выбраны для помещения в отчет:

– в модели

• тела;

• компоненты:

- подсборки;

- детали и локальные детали;

- стандартные изделия;

- компоненты из библиотек моделей;

– в чертеже

• вставки изображений из видов других чертежей;

• вставки фрагментов;

• графические макроэлементы (пользовательские, созданные командой Создать макроэлемент, и библиотечные, например, вставленные из Библиотеки Стандартные Изделия);

• модели ассоциативного вида — помещаются в отчет при указании вида по модели или одного из объектов модели в Дереве чертежа;

• виды — помещаются в отчет все содержащиеся в нем объекты (см. выше);

– во фрагменте

• вставки фрагментов;

• макроэлементы.


5.2.3.2. Команды создания и вставки отчета

Отчет создается командой Создать отчет. Команда доступна в документах:

– модель (*.a3d) — отчет создается по текущей модели, а размещается в выбранном в команде графическом или текстовом документе (новом или существующем);

– чертеж (*.cdw), фрагмент (*.frw) — отчет создается по объектам текущего документе и размещается в этом же документе.

О работе команды см. раздел 5.2.3.3.

Для вставки отчета в документ служит команда Вставить отчет.

Команда доступна в графических (*.cdw, *.frw) и текстовых (*.kdw) документах.

После вызова команды в диалоге открытия файлов необходимо выбрать документ-модель или графический документ, объекты которого будут включены в отчет. Выбранный документ открывается, в нем запускается процесс создания отчета, как после вызова команды Создать отчет (см. раздел 5.2.3.3). После размещения отчета в документе команда завершается автоматически.


5.2.3.3. Порядок создания отчета

Чтобы создать отчет по свойствам объектов в графическом документе или модели, вызовите команду Создать отчет.

После вызова команды выполните следующие действия.

1. Укажите объекты, данные о которых должны быть переданы в отчет, при помощи переключателей группы Способ.

По умолчанию активен переключатель

– в документе-модели — По всем объектам до указанного уровня, при этом варианте в отчет попадут все компоненты первого уровня;

– в чертеже — По текущему виду, при этом варианте в отчет попадут все объекты текущего вида.

Подробно о выборе объектов для отчета рассказано в разделе 5.2.3.3.1.

Чтобы в отчет по модели автоматически попали объекты с определенными свойствами, задайте условия фильтрации (см.раздел 5.2.3.3.4).

2. Выберите стиль отчета из раскрывающегося списка Стиль, в котором перечислены все подключенные стили.

Если нужный стиль в списке отсутствует, щелкните мышью по строке Другой.... На экране появляется диалог, позволяющий выбрать стиль из библиотеки стилей и подключить его. Порядок работы в диалоге описан в разделе 5.2.2.2.8. Выделенный в диалоге стиль автоматически становится выбранным.

Чтобы просмотреть или отредактировать выбранный стиль, нажмите кнопку Настроить.... О настройке стиля подробно рассказано в разделе 5.2.2.2.3.

3. Вы можете включить автоматическое присвоение номеров таблицам отчета. Для этого выберите из списка Нумерация наименование группы нумерации (см. раздел 3.10.1).

4. Выберите вариант продолжения работы команды.

По умолчанию активен переключатель Окно подготовки данных. Это означает, что при нажатии кнопки Создать отчет произойдет переход в Окно подготовки данных. В этом окне можно просмотреть и отредактировать отчет, сделать дополнительные настройки внешнего вида, а также сохранить отчет в самостоятельный файл (*.cdw, *.frw, *.kdw, *.tbl, *.txt, *.ods, *.xls) или вывести на печать. Из Окна подготовки данных вы можете перейти к размещению таблиц в документе.

Если переключатель Окно подготовки данных не активен, то при нажатии кнопки Создать отчет произойдет переход к размещению таблиц в документе.

При включенной опции Ассоциативный отчет создается таблица отчета, ассоциативно связанная с документом, по объектам которого он был получен. При выключенной опции создается отчет без ассоциативной связи. Подробнее см. раздел 5.2.3.8.

При включенной опции Данные в виде ссылок в отчете автоматически формируются ссылки на значения свойств объектов. Если опция выключена, то содержимое отчета представляет собой обычный текст. Подробнее см. раздел 5.2.3.7.

Настройки ассоциативности и отображения данных в виде ссылок имеют значение только при размещении отчета в графическом документе.

Если отчет создается для модели, то опции Ассоциативная таблица и Данные в виде ссылок присутствуют на Панели свойств только в том случае, если эта модель сохранена в файл на диске.

В документе-модели при включенной опции В новый документ отчет размещается в новом документе. Тип нового документа выбирается из списка Новый документ Панели свойств. Если опция выключена, то отчет размещается в ранее созданном документе.

Параметры расположения таблиц отчета задаются на вкладке Компоновка (см. раздел 5.2.3.3.3).

5. Нажмите кнопку Создать отчет на Панели специального управления.

При активном переключателе Окно подготовки данных на экране появляется Окно подготовки данных, содержащее отчет. Выполните действия по настройке отчета. Подробно о работе в Окне подготовки данных рассказано в разделе 5.2.3.4.

При неактивном переключателе на экране появляется диалог выбора документа или стандартный диалог открытия файлов. Выберите документ. В открывшемся на экране документе укажите место расположения отчета. Для таблиц, размещаемых в графических файлах, можно задать название, см. раздел 3.4.2.4.

После размещения отчета командой Создать отчет или закрытия Окна подготовки данных происходит автоматический возврат в процесс создания отчета. После вставки отчета командой Вставить отчет процесс завершается. О командах создания и вставки отчета см. раздел 5.2.3.2.

За один вызов команды вы можете создать несколько отчетов и каждый из них разместить в нескольких документах или вывести на печать.

Чтобы сменить все объекты, нажмите кнопку Указать заново на Панели специального управления и повторите выбор объектов.

После завершения работы с отчетами нажмите кнопку Прервать команду на Панели специального управления.

В этом разделе:

5.2.3.3.1. Способы указания объектов

5.2.3.3.2. Выбор типов объектов

5.2.3.3.3. Компоновка отчета

5.2.3.3.4. Настройка условий фильтрации объектов по свойствам


5.2.3.3.1. Способы указания объектов

Чтобы выбрать способ указания объектов, активизируйте переключатель в группе Способ на Панели свойств. Затем в зависимости от способа выполните необходимые действия.

В документе-модели

Если активен переключатель По всем объектам до указанного уровня, то в отчет по сборке автоматически включаются компоненты до заданного уровня и тела, полученные операциями в сборке.

По умолчанию выбираются объекты первого уровня.

В поле Уровень задайте номер уровня, до которого включительно производится автовыбор объектов.

Если активен переключатель По всем уровням, то в отчет по сборке автоматически включаются компоненты всех уровней и тела, полученные операциями в сборке.

Если активен переключатель По указанным объектам, то объекты следует выбирать вручную, щелкая по ним мышью. Укажите объекты. Если требуется, вы можете указать и саму модель. Выбранные объекты подсвечиваются. Чтобы отменить выбор объекта, щелкните по нему повторно.

Чтобы выбрать тела, построенные операциями в детали, или компоненты, включенные в деталь, необходимо использовать способ По указанным объектам.

В чертеже

Если активен переключатель По текущему виду, то в отчет включаются все объекты текущего вида.

Если активен переключатель По всем видам, то в отчет автоматически включаются объекты из всех видов чертежа.

Если в документе присутствуют несколько видов с одной модели, то информация не дублируется — в отчете отображается информация только главного вида. Главным считается вид, с которого были получены все остальные виды, либо вид, который был создан первым.

Если активен переключатель По указанным объектам, то объекты следует выбирать вручную, щелкая по ним мышью. Укажите объекты.

Опция Уровень чтения моделей служит для ввода или выбора из списка уровня, до которого включительно производится выбор объектов из сборок в ассоциативных видах чертежа. При включенной опции доступен список для выбора уровня.

В ассоциативных чертежах при использовании способов По текущему виду и По всем видам в отчет попадают тела, полученные операциями в сборке, и компоненты сборки. Чтобы выбрать тела, построенные операциями в детали, или компоненты, включенные в деталь, необходимо использовать способ По указанным объектам.

Объекты могут быть выделены до вызова команды.
В этом случае активен переключатель По указанным объектам, а объекты считаются выбранными вручную. Вид в ассоциативном чертеже выбирается, если он был выделен целиком. Для этого можно, например, щелкнуть по его габаритной рамке.

Выбранные объекты подсвечиваются. Чтобы отменить выбор объекта, щелкните по нему повторно.

При настройке отчета по фрагменту группа Способ отсутствует на Панели свойств. В отчет автоматически включаются все объекты.

Тип объектов задается на вкладке Объекты Панели свойств (см. раздел 5.2.3.3.2). Если тип отключен, то объекты данного типа становятся недоступны для выбора способом По указанным объектам, а с уже выбранных объектов данного типа выбор снимается.


5.2.3.3.2. Выбор типов объектов

Настройка, позволяющая указать тип объектов для помещения в отчет, производится на вкладке Объекты Панели свойств (рис. 5.2.5).

Рис. 5.2.5. Вкладка Объекты Панели свойств в чертеже

На вкладке находятся панели Объекты вида и/или Объекты модели, которые содержат список типов объектов.

Для того чтобы данный тип объектов участвовал в формировании отчета, необходимо включить опцию, расположенную слева от его названия.

Если опция какого-либо типа отключена, то эти объекты будут исключены из числа выбранных, независимо от результата выбора объектов при помощи группы Способ (см. раздел 5.2.3.3.1).


5.2.3.3.3. Компоновка отчета

Настройка, позволяющая выбрать способ расположения таблиц на листе, производится на вкладке Компоновка Панели свойств (рис. 5.2.6).

Рис. 5.2.6. Вкладка Компоновка Панели свойств

Выберите способ в списке Компоновка.

– При выборе способа Вправо, затем вниз таблицы располагаются горизонтальными рядами. В поле Вправо не более задайте максимальное количество таблиц в горизонтальном ряду.

– При выборе способа Вниз, затем вправо таблицы располагаются вертикальными рядами. В поле Вниз не более задайте максимальное количество таблиц в вертикальном ряду.

Поле Зазор, мм служит для ввода или выбора из раскрывающегося списка расстояния между границами таблиц в рядах.

Задайте в поле Зазор, мм или выберите из раскрывающегося списка расстояние между таблицами.

Настройка параметров расположения отчета сохраняется до конца сеанса работы с документом.


5.2.3.3.4. Настройка условий фильтрации объектов по свойствам

Фильтрация объектов по свойствам позволяет автоматически выбирать и помещать в отчет объекты, свойства которых удовлетворяют заданным условиям. Фильтрация применяется к объектам, выбранным при помощи группы Способ или вкладки Тип Панели свойств (см. разделы 5.2.3.3.1–5.2.3.3.2).

Фильтрация объектов по свойствам доступна в документе-модели. В Окне подготовки данных вы можете производить фильтрацию строк для отчетов по графическим объектам и моделям (см. раздел 5.2.3.5.2).

Управление режимом фильтрации производится при помощи кнопки Фильтровать объекты по свойствам на Панели специального управления. Нажатая кнопка означает, что режим фильтрации включен, а отжатая — выключен. Кнопка доступна, если заданы условия фильтрации.

Чтобы задать или просмотреть условия фильтрации, нажмите кнопку Настроить фильтр объектов по свойствам. После нажатия кнопки на Панели свойств появляется вкладка Условия фильтрации.

Рис. 5.2.7. Вкладка Условия фильтрации при выборе объектов в документе-модели

Условия фильтрации отображаются в окне панели Условия фильтрации. Каждое условие состоит из трех частей: <Свойство> <Условие> <Значение>. Если окно пусто, то условия не заданы.

Описание элементов управления вкладки приведено в таблице 5.2.5.

Табл. 5.2.5. Элементы управления окна настройки параметров
Элемент | Описание
Условия фильтрации | Панель, позволяющая формировать условия фильтрации. Окно служит для отображения списка условий фильтрации.
Добавить условие | Кнопка, позволяющая добавить условие в список. После нажатия кнопки в окне появляется первая часть условия фильтрации — свойство Обозначение по умолчанию. Условие и значение этого свойства не заданы.
Удалить условие | Кнопка, позволяющая удалить выделенное условие или свойство.
Свойство1 | Раскрывающийся список, из которого можно выбрать свойство фильтрации. В списке доступны свойства, подключенные к документу.
Условие1 | Раскрывающийся список, из которого можно выбрать условие для текущего свойства фильтрации. Выбранное условие отображается на панели Условия фильтрации.
Значение1 | Поле, в которое следует ввести значение свойства. Значение также можно выбрать из раскрывающегося списка, в котором находятся ранее использованные значения.
Учитывать регистр | Опция, позволяющая учитывать регистр — заглавные или строчные буквы в тексте значения, введенного в поле Значение. Если опция включена, то регистр учитывается. Если опция выключена, то регистр не учитывается.
  1. Элемент управления доступен, если в окне условий фильтрации находится хотя бы одно свойство.

Чтобы задать условия фильтрации, выполните следующие действия.

1. Нажмите кнопку Добавить условие, расположенную на панели Условия фильтрации. В поле появляется умолчательный вариант свойства фильтрации.

2. Раскройте список Свойство и выберите свойство фильтрации. При помощи элементов управления Условие и Значение задайте параметры фильтрации.

Полное условие появляется на панели Условия фильтрации. Например, условие Наименование содержит Фланец означает, что в отчет попадут строки, в наименовании которых есть слово «фланец».

3. Чтобы задать следующее условие, повторите действия, описанные в пунктах 1 и 2.

Если на панели Условия фильтрации задано несколько условий, то в отчет помещаются объекты, удовлетворяющие хотя бы одному из этих условий.

Чтобы отредактировать условие фильтрации, выделите его на панели Условия фильтрации и измените нужный параметр.

Подтвердите создание фильтра нажатием кнопки Создать фильтр на Панели специального управления вкладки.

Условия фильтрации сохраняются до конца работы сеанса системы КОМПАС-3D.


5.2.3.4. Окно подготовки данных

В этом разделе:

5.2.3.4.1. Общие сведения

5.2.3.4.2. Режимы работы в Окне подготовки данных


5.2.3.4.1. Общие сведения

Окно подготовки данных служит для просмотра отчета, редактирования и дополнительной настройки внешнего вида отчета. Из Окна настроенный отчет может быть выведен на печать, размещен в документе или сохранен в отдельный файл.

Окно подготовки данных появляется на экране в следующих случаях:

– при создании отчета — после нажатия кнопки Создать отчет на Панели специального управления команды Создать отчет (при нажатом переключателе Окно подготовки данных на Панели свойств);

– при редактировании ассоциативного отчета — после вызова команды Редактировать в окне подготовки данных из контекстного меню выделенного в документе отчета (или после двойного щелчка мышью по его внешней рамке).

В Окне находится заполненная таблица отчета в том виде, который был задан на Панели свойств команды Создать отчет и вкладке Объекты при включенном или выключенном режиме фильтрации объектов (для моделей), заданном на Панели специального управления. При редактировании ассоциативного отчета в Окне подготовки данных также отображаются изменения, внесенные в таблицу в поле документа.

Таблица отчета содержит в строках выбранные объекты, а в столбцах набор свойств этих объектов. Внешний вид отчета соответствует стилю отчета.

По умолчанию в строках отчета отображаются данные в виде ссылок на свойства объектов (см. раздел 5.2.3.7).

Строка отчета может состоять из нескольких строк таблицы. Это обусловлено тем, что длина текста в ячейке может превышать ширину столбца, задаваемую в стиле отчета.

По умолчанию отчет отображается в сгруппированном виде (см. раздел 5.2.2.2.5).

Параметры текста заголовка и ячеек таблицы в Окне соответствуют параметрам, настроенным для текущего документа по умолчанию.

О настройках параметров текста рассказано в разделе 5.2.2.3.2.

Окно подготовки данных содержит следующие панели.

– Панель свойств (рис. 5.2.8).

Рис. 5.2.8. Панель свойств Окна подготовки данных при создании отчета

Элементы управления панели служат для настройки текущих параметров отчета.

– Компактную панель, имеющую в своем составе несколько инструментальных панелей.

Рис. 5.2.9. Компактная панель в Окне подготовки данных.
Активна инструментальная панель Таблица отчета

• На панели Таблица отчета расположены кнопки вызова команд для придания отчету окончательного вида — группирования, фильтрации, выделения строк для их помещения в отчет и т.д., а также команд для размещения отчета в документе или сохранения в отдельный файл (рис. 5.2.9).

• Панель Форматирование служит для вызова команд форматирования текста в ячейках таблицы отчета (см. раздел 4.1.2.5).

• Панель Вставка в текст служит для вызова команд вставки в текст отчета различных объектов (см. раздел 4.1.2.11).

Из Окна подготовки данных вы можете

– сохранить отчет в отдельные файлы (см. раздел 5.2.3.5.13);

– вывести отчет на печать (см. раздел 5.2.3.5.14);

– разместить отчет в документе (см. раздел 5.2.3.5.15);

– при редактировании ассоциативного отчета — вернуться в документ, где он размещен.

Для завершения работы в Окне подготовки данных следует нажать кнопку Прервать команду на Панели специального управления. Можно также закрыть Окно кнопкой Закрыть в правом верхнем углу либо щелчком мыши по значку режима.

В Окне подготовки данных отображается «шапка» таблицы из одной строки. Дополнительные строки заголовка, если они заданы при настройке (см. раздел 5.2.2.2.4), не отображаются в Окне подготовки данных. Дополнительные строки присутствуют в заголовке отчета, сохраненного в документ типа cdw, frw или kdw (см. раздел 5.2.3.5.13).


5.2.3.4.2. Режимы работы в Окне подготовки данных

Возможны три режима отображения — нормальный, режим разметки страниц и режим отображения отчета без рамки документа и пустых строк.

Рис. 5.2.10. Панель Режимы в Окне подготовки данных

Вы можете свободно переключаться между режимами, используя кнопки панели Режимы или команды меню Вид. Нажатая кнопка является индикатором текущего режима.

После открытия Окна подготовки данных на экране показана таблица отчета в нормальном режиме. В данном режиме в таблице перечислены все объекты подряд без разбиения на страницы, на экране не показывается рамка документа. В нормальном режиме доступны все настройки отчета.

Чтобы на экране отображался отчет с разбиением на страницы и отображением полей, нужно перейти в режим разметки страниц. Для перехода в этот режим нажмите кнопку Разметка страниц на панели Режимы.

В этом режиме вы можете изменять стиль и параметры размещения отчета, расположенные на вкладке Параметры Панели свойств Окна. В этом режиме также можно отменить фильтрацию строк и управлять группированием. Применение других приемов редактирования таблицы невозможно.

В режиме Разметка страниц возможно отображение отчета без рамки документа и пустых строк. Для этого нажмите кнопку Без рамки и пустых строк.

Для навигации по отчету служит панель Текущее состояние (рис. 5.2.11). В ее полях отображается справочная информация о номерах текущей страницы, строки и количестве строк отчета.

Чтобы переместиться на другую страницу или строку, наберите ее номер в поле Текущая страница или Текущая строка и нажмите клавишу <Enter>.

Рис. 5.2.11. Панель Текущее состояние в Окне подготовки данных

Если панель Текущее состояние расположена вертикально, то для доступа к полю нажмите соответствующую кнопку.


5.2.3.5. Приемы работы в Окне подготовки данных

В этом разделе:

5.2.3.5.1. Настройка текущих параметров в Окне подготовки данных

5.2.3.5.2. Фильтрация строк

5.2.3.5.3. Выделение строк

5.2.3.5.4. Скрытие строк

5.2.3.5.5. Вставка строк

5.2.3.5.6. Копирование строк

5.2.3.5.7. Удаление строк

5.2.3.5.8. Перемещение строк вверх и вниз

5.2.3.5.9. Перемещение строк в начало страницы

5.2.3.5.10. Редактирование текста в отчете

5.2.3.5.11. Объединение ячеек в строке

5.2.3.5.12. Поиск текста в отчете

5.2.3.5.13. Сохранение в отдельный файл

5.2.3.5.14. Просмотр перед печатью и печать

5.2.3.5.15. Размещение отчета в документе


5.2.3.5.1. Настройка текущих параметров в Окне подготовки данных

Вы можете создать отчет в сгруппированном или разгруппированном виде.

По умолчанию отчет сгруппирован. Это означает, что объекты, имеющие одинаковые свойства в отчете, представлены одной результирующей строкой.

Признаком того, что отчет сгруппирован, является нажатая кнопка Группировать на инструментальной панели Таблица отчета или в меню Таблица.

Настройка параметров группирования содержится в стиле отчета.

Чтобы просмотреть или изменить параметры группирования, нажмите кнопку Настроить... на Панели свойств Окна подготовки данных. Для настройки группировки используются ячейки строки Группировка. Подробнее см. разделы 5.2.2.2.3–5.2.2.2.5).

После внесения изменений в стиль вызовите команду Перестроить таблицу.

Отчет с измененными параметрами группировки отображается в Окне подготовки данных.

Чтобы получить в отчете полный список объектов, отожмите кнопку Группировать.

При отмене группирования происходит также отмена фильтрации строк. О фильтрации строк рассказано в разделе 5.2.3.5.2.


5.2.3.5.2. Фильтрация строк

Вы можете применить фильтрацию строк к отображенной в Окне таблице — оставить в отчете только те строки, значения в колонках которых удовлетворяют заданным условиям или содержат определенный набор символов.

Для фильтрации строк отчета служит команда Применить фильтр. Чтобы вызвать команду или просмотреть условия фильтрации, нажмите кнопку на панели Таблица отчета или выберите название из меню Таблица. На Панели свойств появляется вкладка Условия фильтрации (рис. 5.2.12).

В окне панели Условия фильтрации отображаются условия фильтрации. Каждое условие состоит из трех частей: <Имя колонки> <Условие> <Значение>. Если окно пусто, то условия не заданы.

Рис. 5.2.12. Вкладка Условия фильтрации при фильтрации строк

Используя элементы управления вкладки, задайте условия фильтрации. Для этого выполните следующие действия.

1. Нажмите кнопку Добавить условие, расположенную на панели Условия фильтрации. После нажатия кнопки в окне появляется первая часть условия фильтрации — колонка Обозначение по умолчанию. Условие и значение свойства, отображенного в этой колонке, не заданы.

2. Раскройте список Колонка и выберите свойство фильтрации. В списке Колонка доступны имена колонок текущего стиля отчета.

При помощи элементов управления Условие и Значение задайте параметры фильтрации.

Полное условие появляется на панели Условия фильтрации. Например, условие

Длина, м < 1.2 означает, что в отчет попадут строки, имеющие в колонке Длина, м значения, меньшие 1.2.

3. Включите опцию Учитывать регистр, чтобы учитывался регистр — заглавные или строчные буквы в тексте значения, введенного в поле Значение.

4. Чтобы задать следующее условие, повторите действия, описанные в пунктах 1–3.

Если на панели Условия фильтрации задано несколько условий, то в отчет помещаются объекты, удовлетворяющие хотя бы одному из этих условий.

Если требуется сохранить настройки параметров фильтрации до конца сеанса работы с документом, вызовите команду Запомнить условия фильтрации на Панели специального управления.

Чтобы выполнить фильтрацию, нажмите кнопку Создать объект на Панели специального управления.

На экране появляется отфильтрованная таблица.

Чтобы отредактировать условие фильтрации, выделите его на панели Условия фильтрации и измените нужный параметр.

К уже отфильтрованной таблице можно применить новые фильтры. Для этого повторно вызовите команду Применить фильтр. В этом случае на Панели свойств доступна опция Удалить предыдущие. Если опция включена, то предыдущие условия не учитываются — фильтрация будет произведена исключительно с новыми условиями. Если опция выключена, то новые условия будут применены дополнительно к предыдущим. Для выполнения фильтрации, нажмите кнопку Создать объект повторно.

Чтобы отменить фильтрацию строк, выполненную в Окне подготовки данных, вызовите команду Удалить фильтры. Для этого нажмите кнопку на панели Таблица отчета или выберите название из меню Таблица. Команда доступна, если была выполнена команда Применить фильтр.


5.2.3.5.3. Выделение строк

Выделение строк отчета может потребоваться как при редактировании (удалении, копировании, вставке, перемещении строк по таблице), так и при создании отчета из отдельных строк.

Выделять строки можно следующими способами.

– Чтобы выделить строку, щелкните по ней мышью.

– Чтобы выделить несколько строк, щелкните по ним мышью при нажатой клавише <Ctrl>.

Повторный щелчок мышью по выделенной строке отменяет ее выделение.

– Чтобы выделить диапазон строк, нажмите клавишу <Shift> и, не отпуская ее, щелкните мышью по начальной и конечной строке диапазона. Если диапазон начинается от первой строки, то при нажатой клавише <Shift> щелкните мышью только по конечной строке.

Также для выделения диапазона в нужном направлении вы можете использовать комбинацию клавиш <Shift> + <↑>/<↓>.

Для изменения границ выделения диапазона строк щелкните мышью в новой конечной строке при нажатой клавише <Shift>.

Чтобы отменить выделение всех строк, щелкните мышью по пустой строке.

Количество выделенных строк отчета отображается на панели Текущее состояние в поле Выделено строк.

Выделение строк возможно в нормальном режиме отображения отчета (см. раздел 5.2.3.4.2).


5.2.3.5.4. Скрытие строк

Вы можете скрыть некоторые строки, чтобы не помещать их в отчет. Для этого выделите строки, которые должны быть показаны в отчете.

Чтобы просмотреть отчет, составленный из выделенных строк, вызовите команду Скрыть все строки, кроме выделенных. Для вызова команды нажмите кнопку на панели Таблица отчета или выберите название из меню Таблица.

После нажатия кнопки все строки, кроме выделенных, в таблице не показываются.

В режиме скрытия строк редактирование отчета невозможно.

Чтобы привести отчет в состояние, когда все строки показаны, отожмите кнопку Скрыть все строки, кроме выделенных на панели Таблица отчета или повторно вызовите команду из меню Таблица.


5.2.3.5.5. Вставка строк

Вы можете вставить строку в любое место таблицы.

Для выполнения операции выделите строку, ниже которой требуется вставить строку.

Вызовите команду Вставить строку снизу. Для этого нажмите кнопку на панели Таблица отчета или выберите название из контекстного меню или из меню Таблица. Вы также можете использовать клавишу <Insert>.

После вызова команды вставляется строка. Одновременно запускается режим редактирования текста, в котором вы можете ввести текст. О режиме редактирования текста отчета см. раздел 5.2.3.5.10.

Чтобы оставить строку незаполненной, после вставки щелкните мышью по любой строке, нажмите комбинацию клавиш <Ctrl> + <Enter> или клавишу <Esc>.


5.2.3.5.6. Копирование строк

Вы можете вставить в отчет копию выделенной строки.

Для выполнения операции выделите строку, которую требуется скопировать.

Вызовите команду Копировать строку из контекстного меню или из меню Таблица.

После вызова команды копия добавляется снизу от скопированной строки.


5.2.3.5.7. Удаление строк

Вы можете удалить выделенные строки.

Для этого после выделения строк вызовите команду Удалить строку нажатием кнопки на панели Таблица отчета, выбором названия из контекстного меню или из меню Таблица. Вы также можете использовать клавишу <Delete>.


5.2.3.5.8. Перемещение строк вверх и вниз

Вы можете переместить выделенную строку вверх или вниз.

Чтобы переместить строку, вызовите команду Сдвинуть строку вверх/вниз.

Команды вызываются нажатием кнопки на панели Таблица отчета, выбором названия из контекстного меню или из меню Таблица. Вы также можете использовать комбинацию клавиш <Ctrl> + <↑>/<↓>.

Таким же образом вы можете переместить диапазон выделенных строк.


5.2.3.5.9. Перемещение строк в начало страницы

Вы можете переместить строки, начиная с выделенной, в начало следующей страницы.

Для этого выделите строку, с которой должна начинаться новая страница, и вызовите команду С новой страницы нажатием кнопки на панели Таблица отчета, выбором названия из контекстного меню или из меню Таблица.

Чтобы вернуть перемещенные строки на исходную страницу, выделите строку, к которой была применена команда С новой страницы. При этом кнопка вызова команды будет находиться в нажатом состоянии. Затем отожмите кнопку С новой страницы.


5.2.3.5.10. Редактирование текста в отчете

Вы можете внести изменения в текст строки отчета или объединить ячейки строки.

Чтобы войти в режим редактирования текста, выполните одно из действий:

– дважды щелкнуть мышью по строке,

– выделить строку и вызвать команду Редактировать строку из контекстного меню или из меню Таблица,

– нажать клавишу <Enter>.

После вызова команды на экране появляется Панель свойств редактирования строки отчета в текстовом режиме.

В режиме редактирования текста доступны элементы управления панелей Форматирование и Вставка в текст.

Выполните действия по редактированию текста.

Чтобы выйти из режима редактирования и подтвердить изменения, выполните одно из действий:

– нажмите кнопку Создать объект на Панели специального управления,

– щелкните мышью в любом месте таблицы вне редактируемой строки,

– нажмите комбинацию клавиш <Ctrl>+<Enter>.

Чтобы выйти из режима редактирования без подтверждения изменений, нажмите клавишу <Esc>.

Чтобы отменить редактирование текста, выделите отредактированную строку и вызовите команду Привести текстовую часть к исходному виду из контекстного меню.

Если на Панели свойств включена опция Данные в виде ссылок, то в строках отображаются ссылки на свойства объектов. Они недоступны для редактирования. Вы можете ввести текст до или после ссылки в ячейке или удалить ссылку целиком, если требуется.

Чтобы данные в виде ссылок преобразовать в обычный текст, выключите опцию Данные в виде ссылок и вызовите команду Перестроить таблицу. Опция доступна только при создании отчета.

О работе с данными в виде ссылок см. раздел 5.2.3.7.


5.2.3.5.11. Объединение ячеек в строке

Вы можете объединить соседние ячейки в строке.

Для этого войдите в режим редактирования текста.

Выделите ячейки, которые требуется объединить, и нажмите кнопку Объединить ячейки на Панели свойств или вызовите одноименную команду из меню Таблица.

Подтвердите редактирование.

Вход в режим редактирования текста и выход из него описаны в разделе 5.2.3.5.10.

Чтобы отменить объединение ячеек, выделите отредактированную строку и вызовите команду Привести текстовую часть к исходному виду из контекстного меню.


5.2.3.5.12. Поиск текста в отчете

Вы можете найти строку, содержащую заданный текст.

Чтобы осуществить поиск, вызовите команду Найти... из меню Редактор.

После вызова команды на Панели свойств появляется вкладка Найти. Используя элементы управления вкладки Найти, настройте параметры поиска.

Для этого задайте искомый текст в поле Текст. Его также можно выбрать из списка, в котором находятся ранее использованные фрагменты текста.

Если требуется найти текст, содержащийся в значениях какого-либо одного свойства, то включите опцию В колонке и выберите данное свойство из списка Колонка.

Если требуется найти ячейки, которые содержат исключительно заданный текст, включите опцию Ячейка целиком.

Если требуется учитывать регистр символов, включите опцию Учитывать регистр. В этом случае при поиске будут различаться строчные и прописные символы. Так, например, слова «ГОСТ» и «Гост» будут восприниматься как разные.

Выберите направление поиска при помощи переключателей группы Направление.

– если активен переключатель К концу документа, то поиск ведется по ходу документа;

– если активен переключатель К началу документа, то поиск ведется в обратном направлении;

– если активен переключатель Найти все, то в отчете будут сразу найдены все строки с искомым текстом.

Чтобы начать поиск, нажмите кнопку Выполнить на Панели специального управления.

При активном переключателе К концу документа или К началу документа строка с искомым текстом выделяется. Повторите поиск, нажав кнопку Выполнить. При каждом нажатии кнопки выделяется одна строка, найденная в заданном направлении.

При активном переключателе Найти все выделяются все найденные строки.

Если искомый текст не найден, то на экране появляется сообщение об этом.

Команда Найти... также может быть вызвана в режиме редактирования текста из меню Редактор или нажатием комбинации клавиш <Ctrl> + <F>. В этом случае поиск текста в таблице производится в пределах текущей ячейки.

О настройках параметров поиска в ячейке подробно рассказано в разделе 4.1.2.9.


5.2.3.5.13. Сохранение в отдельный файл

Данные отчета могут быть сохранены в отдельные файлы.

Чтобы сохранить отчет, вызовите команду Файл — Сохранить как... или нажмите кнопку Сохранить текущий отчет как... на панели Таблица отчета.

После нажатия кнопки на экране появляется стандартный диалог сохранения файлов.

Отчет может быть сохранен в виде документа одного из следующих типов.

– КОМПАС-Чертежи (файл *.cdw),

– КОМПАС-Фрагменты (файл *.frw),

– КОМПАС-Текстовые документы (файл *.kdw),

– КОМПАС-Таблицы (файл *.tbl),

– Текстовые файлы (файл *.txt),

– Электронные таблицы ODF (файл *.ods),

– Электронные таблицы Microsoft Excel (файл *.xls).

Дополнительные строки заголовка отчета, если они заданы при настройке (см. раздел 5.2.2.2.4), присутствуют в отчете, сохраненном в документ типа cdw, frw или kdw. Заголовок отчета, сохраненного в документ другого типа, всегда состоит из одной строки, как в Окне подготовки данных.


5.2.3.5.14. Просмотр перед печатью и печать

Отчет в текущем виде может быть выведен на печать.

О настройках формата и полей листа рассказано в разделе 5.2.2.3.1.

Вы можете просмотреть размещение отчета на листах в Окне подготовки данных в режиме Разметка страниц (см. раздел 5.2.3.4.2).

Также вы можете использовать окно предварительного просмотра перед печатью КОМПАС-документов. Нажмите кнопку Предварительный просмотр на панели Стандартная. На экране появится окно, в котором вы можете настроить различные параметры вывода на печать (см. раздел 8.3.1.2).

Чтобы напечатать отчет, нажмите кнопку Печать на панели Стандартная или вызовите команду Файл — Печать. Вы также можете использовать комбинацию клавиш <Ctrl> + <P>.

На экране появится диалог, аналогичный диалогу настройки печати текстовых документов. Задайте параметры печати.

Подробно о печати документов рассказано в разделе 8.1.


5.2.3.5.15. Размещение отчета в документе

Вы можете разместить в документе все строки отчета или только выделенные.

Чтобы передать в документ все отображающиеся в Окне строки, вызовите команду Файл — Передать в документ — Отчет или нажмите кнопку Передать отчет в документ на панели Таблица отчета. Вы также можете вызвать команду Создать отчет на Панели специального управления Окна подготовки данных.

Чтобы передать в документ выделенные строки, вызовите команду Файл — Передать в документ — Выделенное или нажмите кнопку Передать в документ выделенное на панели Таблица отчета. Команда доступна, если в отчете выделены строки.

Если кнопка Скрыть все строки, кроме выделенных нажата, это означает, что отчет находится в режиме просмотра выделенных строк. Подробно о просмотре отчета из выделенных строк рассказано в разделе 5.2.3.5.4.

После вызова команды на экране появляется диалог выбора документа или стандартный диалог открытия файлов.

Выбранный документ открывается, система автоматически переходит к размещению в нем таблиц. В документе-модели при включенной опции В новый документ на Панели свойств размещение происходит в новом документе.

Укажите положение точки привязки таблиц курсором или путем ввода координат на Панели свойств.


5.2.3.6. Названия и нумерация таблиц отчета

Для таблиц отчета, размещаемых в графическом документе, можно ввести названия (см. раздел 3.4.2.4) и включить автоматическую нумерацию.

Автоматическая нумерация заключается в присвоении таблице номера-ссылки на номер в группе нумерации. Для этого необходимо добавить таблицу в группу любым из способов:

– в процессе создания или редактирования отчета — путем выбора группы из списка Нумерация, расположенного на Панели свойств;

– после размещения отчета в документе — путем добавления в окно Нумерация, вызываемое командой Вид — Нумерация.

Подробно приемы автоматической нумерации объектов описаны в разделе 3.10.1.


5.2.3.7. Данные в виде ссылок

В отчетах, размещаемых в графических документах, предусмотрена возможность отображения содержимого строк отчета в виде ссылок на значения свойств в документе-источнике. Такие ссылки создаются автоматически, если включена опция Данные в виде ссылок на Панели свойств в команде Создать отчет (см. раздел 5.2.3.3). Они отображаются в отчете цветом, установленным для текстовых ссылок (см. раздел 9.1.3.5).

Вы можете ввести в ячейку обычный текст до или после такой ссылки: дополнительную надпись, обозначение, спецзнак и т.д.

Это возможно в следующих режимах:

– в документе — в режиме редактирования таблиц (см. раздел 4.2.2);

– в Окне подготовки данных — в режиме редактирования текста (см. раздел 5.2.3.5.10).

Рис. 5.2.13. Отображение в отчете данных в виде ссылок

Данные в виде ссылок нельзя отредактировать вручную или разрушить. После изменения значений свойств в документе-источнике данные можно обновить в отчете при помощи команды Перестроить, а в ассоциативном отчете — также при помощи команды Обновить таблицу (см. раздел 5.2.3.8.2).

Данные в виде ссылок в отчете — в Окне подготовки данных или в документе — могут изменить цвет. Это означает, что требуется обновление ссылок, либо ссылки стали нерабочими, т.е. потеряна их связь с документом-источником или объектом.

Чтобы обновить ссылки, перестройте отчет. Для восстановления связи устраните причину ее разрыва.


5.2.3.8. Ассоциативные отчеты

Вы можете создавать отчеты, в которых поддерживается ассоциативная связь с документом, по объектам которого он создан.

Ассоциативная связь формируется, если при создании отчета на Панели свойств была включена опция Ассоциативный отчет.

Ассоциативный отчет следует размещать в графическом документе. При размещении в текстовом документе ассоциативная связь отчета с документом-источником не создается.

Ассоциативный отчет имеет следующие отличия от простого отчета (созданного при выключенной опции Ассоциативный отчет).

– В ассоциативном отчете поддерживается постоянная связь с документом-источником — документом, по объектам которого был создан отчет. Все изменения, происходящие с объектами в документе-источнике и касающиеся отчета, передаются в отчет. Например, он автоматически пополняется при добавлении объектов в документ-источник с учетом использованного способа указания объектов.

Актуальность отчета достигается за счет обновления данных (см. раздел 5.2.3.8.2). По желанию пользователя ассоциативность можно разрушить на определенном этапе работы с отчетом (см. раздел 5.2.3.8.3).

– Ассоциативный отчет представляет собой единый объект, который может состоять из нескольких таблиц. Он отображается в документе в дополнительной внешней рамке, показанной пунктиром (рис. 5.2.14). Готовый отчет можно редактировать как в Окне подготовки данных, так и в документе, в котором он размещен (см. раздел 5.2.3.8.1).

Рис. 5.2.14. Ассоциативный отчет

Контекстное меню ассоциативного отчета содержит как типовые команды работы с объектом, например, вырезание, копирование, создание гиперссылок и др., так и команды редактирования отчета в Окне подготовки данных, открытия документа-источника, ввода названий, обновления (рис. 5.2.15).

Рис. 5.2.15. Контекстное меню ассоциативного отчета

Следует обратить внимание на особенности копирования ассоциативного отчета, созданного по объектам текущего графического документа. Чтобы копия отчета сохранила ассоциативность, рекомендуется использовать способ копирования с помощью мыши (см. раздел 3.5.1.1.2).

В этом разделе:

5.2.3.8.1. Редактирование

5.2.3.8.2. Обновление таблиц

5.2.3.8.3. Разрушение ассоциативности отчета


5.2.3.8.1. Редактирование

Возможны следующие способы редактирования ассоциативного отчета.

– Редактирование объектов в документе-источнике.

Вызовите команду Открыть документ-источник из контекстного меню выделенного в документе отчета. После вызова команды на экране появляется документ, по которому получен отчет. Измените объекты в документе-источнике, если требуется. Внесенные изменения попадают во все ассоциативные отчеты, которые были по нему созданы.

Обновите эти отчеты в документах (см. раздел 5.2.3.8.2).

– Редактирование отчета в Окне подготовки данных.

Вызовите команду Редактировать в окне подготовки данных из контекстного меню выделенного в документе отчета. Команда может быть также вызвана двойным щелчком мыши по внешней рамке отчета.

После вызова команды отчет отображается в режиме Окна подготовки данных. В нем доступны элементы управления для изменения стиля отчета, компоновки, содержимого ячеек и т.д.

Выполните действия, как при создании отчета (см. раздел 5.2.3.5).

Чтобы подтвердить изменения, нажмите кнопку Создать отчет на Панели специального управления.

При редактировании отчета невозможно управлять способом отображения данных в виде ссылок, отменить ассоциативность отчета, изменить параметры размещения.

– Смена точки привязки отчета.

Вызовите команду Изменить точку привязки из контекстного меню выделенного в документе отчета. После вызова команды запускается процесс, в котором можно выбрать другую точку привязки.

Чтобы подтвердить изменения, нажмите кнопку Создать объект на Панели специального управления.

– Редактирование таблицы отчета непосредственно в документе, где он размещен.

Двойной щелчок мышью по отчету (за исключением пунктирной рамки) позволяет войти в режим редактирования таблицы. В этом режиме доступны все приемы работы с таблицами (см. раздел 4.2.2).

Редактирование отчета, выполненное в поле документа, отменяется последующим перестроением отчета в Окне подготовки данных, например, при смене стиля. Это обусловлено тем, что перестроение фактически является повторным созданием отчета.

Поэтому при редактировании отчета рекомендуется в первую очередь выполнять действия, связанные с его перестроением или обновлением, а затем вносить изменения в текст — в Окне подготовки данных или в документе.


5.2.3.8.2. Обновление таблиц

Обновление содержимого таблиц требуется для ассоциативных отчетов, если изменились данные в документе-источнике. Признаком неактуальности ассоциативного отчета является перечеркивание таблицы в документе (рис. 5.2.16).

Рис. 5.2.16. Отчет, данные которого изменились в документе-источнике

Чтобы привести данные отчета в актуальное состояние, вызовите команду Обновить таблицу из контекстного меню отчета, выделенного в документе.

После вызова команды данные в отчете заменяются данными из документа-источника, а перечеркивание таблицы исчезает.

Данные, отредактированные вручную при работе с отчетом, не обновляются.

При обновлении учитывается способ выбора объектов, установленный в процессе создания отчета.

Обновление таблиц происходит также при перестроении графического документа, где размещен отчет, вызовом команды Перестроить.

Обновление отчета отменяет настройки, выполненные в Окне подготовки данных — вставку строк, фильтрацию, группирование, перемещение строк и т.д.


5.2.3.8.3. Разрушение ассоциативности отчета

Команда Разрушить позволяет отменить ассоциативность отчета, то есть разрушить связь с документом-источником. Команда может быть вызвана из контекстного меню выделенного в документе отчета или из меню Редактор.

После вызова команды ассоциативный отчет преобразуется в простой, для которого доступны приемы редактирования таблиц (см. раздел 4.2.2). Отчет отображается без характерной рамки и названия, если оно было задано.

Если отчет состоит из нескольких таблиц, то каждая таблица становится отдельным объектом.

После вызова команды ссылки на значения свойств остаются в отчете.


5.2.3.9. Примеры создания отчетов

В этом разделе:

5.2.3.9.1. Простой отчет

5.2.3.9.2. Ассоциативный отчет


5.2.3.9.1. Простой отчет

Для создания отчета по составу изделия рекомендуется следующий порядок действий.

1. Откройте файл — сборку или чертеж — по которому необходимо создать отчет. Если чертеж неассоциативный, то включаемые в отчет объекты (узлы, детали и т.п.) должны представлять собой графические макроэлементы и вставки фрагментов.

Вызовите команду Создать отчет.

2. В группе Способ выберите:

– для сборки — вариант По всем уровням; это позволит получить отчет, в котором будут перечислены все детали, входящие в состав сборочных единиц.

– для чертежа — вариант По всем видам; это позволит получить отчет, в котором будут перечислены объекты из всех видов чертежа.

3. Нажмите кнопку Настроить....

В открывшемся диалоге Параметры стиля отчета настройте стиль отчета.

3.1. Добавьте два столбца (в стиль По умолчанию), выберите для них обозначения — Позиция и Тип объекта.

3.2. Настройте параметры сортировки, щелкнув мышью по полю Сортировка.

В диалоге сортировки данных задайте первый уровень — По списку для свойства Тип объекта, второй и третий уровень — А-Я для свойств Обозначение и Наименование соответственно.

Рис. 5.2.17. Пример настройки сортировки

Обратите внимание на то, что свойство Тип объекта добавлено в стиль отчета исключительно для настройки сортировки. Отключите его отображение в стиле при помощи опции Отображать.

3.3. Настройте остальные параметры стиля — ширину столбцов, выравнивание и другие, приведенные в диалоге (рис 5.2.18).

Введите имя в поле Имя стиля.

Сохраните созданный стиль в библиотеку стилей, нажав кнопку Сохранить в библиотеку как...

Рис. 5.2.18. Пример настройки стиля

3.4. Перейдите в Окно подготовки данных. Для этого при нажатом переключателе Окно подготовки данных нажмите кнопку Создать отчет на Панели специального управления.

3.5. Создайте отчет без ассоциативной связи с документом и без ссылок. Для этого выключите опции Ассоциативный отчет и Данные в виде ссылок на Панели свойств в Окне подготовки данных.

3.6. Обновите отчет. Для этого нажмите кнопку Перестроить таблицу на панели Вид в Окне подготовки данных.

Рис. 5.2.19. Пример отчета в Окне подготовки данных

4. Отредактируйте отчет при помощи команд Окна подготовки данных — вставьте пустые строки, если требуется, введите текст, переместите или удалите строки и т.д. (рис. 5.2.19).

5. Сохраните отчет как отдельный документ при помощи команды Сохранить текущий отчет как... либо разместите отчет в уже существующем документе или в текущем чертеже при помощи команды Создать отчет (рис. 5.2.20).

Рис. 5.2.20. Пример размещения отчета в чертеже


5.2.3.9.2. Ассоциативный отчет

В качестве примера рассматривается создание ассоциативного отчета с отображением в нем ссылок в виде свойств, размещение отчета в новом фрагменте, проверка работы ссылок и ассоциативности отчета, а также редактирование отчета, вставка названий таблиц, разрушение ассоциативности.

Рекомендуется следующий порядок действий.

Создание отчета

1. Откройте файл сборки, по которой необходимо создать отчет.

Вызовите команду Создать отчет.

2. Выберите вариант По всем уровням в группе Способ.

3. Включите опции Ассоциативный отчет и Данные в виде ссылок на Панели свойств, если они были выключены.

4. Включите опцию В новый документ и выберите в списке Новый документ вариант КОМПАС-Фрагмент на Панели свойств.

5. Настройте параметры стиля, как для обычного отчета (см. раздел 5.2.3.9.1).

6. Перейдите к размещению отчета в документе. Для этого отожмите переключатель Окно подготовки данных и нажмите кнопку Создать отчет на Панели специального управления.

7. Укажите мышью расположение точки привязки отчета во фрагменте.

8. Система автоматически возвращается в документ-источник. Чтобы просмотреть созданный отчет, перейдите во фрагмент, где он размещен.

Рис. 5.2.21. Ассоциативный отчет с данными в виде ссылок

Ассоциативные изменения отчета

9. Чтобы проверить ассоциативность отчета, перейдите в документ-источник при помощи команды Открыть документ-источник, вызванной во фрагменте из контекстного меню отчета.

10. Добавьте новый компонент в сборку любым способом и задайте значения его свойствам.

В примере добавлены два компонента Насос.

Рис. 5.2.22. Добавление компонента в документ-источник

11. Перейдите в документ, где размещен отчет. Отчет в нем теперь отображается перечеркнутым, так как изменился состав модели в документе-источнике.

12. Обновите отчет. Для этого вызовите команду Обновить таблицу. После обновления в отчете появляется новый объект — компоненты Насос с заданными свойствами.

Рис. 5.2.23. Результат обновления отчета

Данные в виде ссылок

13. Проверьте, как отображаются ссылки в отчете при изменении значений свойств объектов. Для этого перейдите в документ-источник при помощи команды Открыть документ-источник, вызванной из контекстного меню отчета в документе.

14. Измените значение свойства компонента. Например, в Дереве построения модели отредактируйте наименование компонента, затем перестройте модель нажатием кнопки Перестроить (модель) на панели Вид.

В примере компоненты Емкость переименованы в Резервуар вертикальный.

Рис. 5.2.24. Изменение значений свойств в документе-источнике

15. Перейдите в документ, где расположен отчет. Цвет текста значений свойств сменился на цвет ссылок, требующих обновления. Одновременно с этим отчет отображается перечеркнутым, что означает изменения в документе-источнике.

Рис. 5.2.25. Ассоциативный отчет после изменения значений свойств в документе-источнике

16. Обновите отчет. Для этого вызовите команду Обновить таблицу из контекстного меню отчета. После обновления новое наименование отображается в отчете с учетом правила сортировки. Цвет текста изменяется на цвет, установленный для ссылок.

В примере объект Емкость после переименования в Резервуар вертикальный занял другое положение.

Рис. 5.2.26. Результат обновления отчета

17. Проверьте, как отображаются ссылки при потере связи с документом-источником. Для этого закройте документ-источник и временно переименуйте его.

18. Перейдите в документ, где расположен отчет. В нем значения свойств отображаются цветом, означающий потерю источника ссылки. Отчет отображается перечеркнутым (рис. 5.2.27).

Рис. 5.2.27. Ассоциативный отчет при потере связи с документом-источником

19. Для восстановления ассоциативной связи задайте документу-источнику прежнее имя. Цвет текста изменяется на цвет, установленный для ссылок.

Редактирование отчета

20. Отредактируйте отчет: вставьте текст и разделите отчет на две таблицы, расположенные горизонтально. Для этого перейдите в Окно подготовки данных, дважды щелкнув мышью по рамке выделенного отчета или вызвав команду Редактировать в Окне подготовки данных из его контекстного меню.

В первую очередь выполняйте редактирование, связанное с перестроением (обновлением) таблиц по модели, например, настройку стиля. Затем вносите изменения в текст, вставляйте и перемещайте строки, выполняйте фильтрацию строк и другие действия.

21. Настройте стиль. Например, задайте количество строк на странице, равное 10. Для этого нажмите кнопку Настроить на Панели свойств. В диалоге Параметры стиля отчета нажмите кнопку Оформление и введите значение.

22. Обновите отчет в Окне подготовки данных нажатием кнопки Перестроить таблицу на панели Вид.

23. Задайте надпись раздела Оборудование (рис. 5.2.28). Для этого вставьте три пустые строки в любом месте таблицы при помощи команды Вставить строку снизу на панели Таблица отчета.

24. Выделите вставленные строки и переместите их вверх таблицы при помощи команды Сдвинуть строку вверх.

25. Войдите в режим редактирования текста двойным щелчком мыши по пустой строке и введите простой текст Оборудование. Примените к нему подчеркивание.

26. Аналогично задайте надпись раздела Трубы и арматура.

27. Отредактируйте строку Насос, добавив простой текст после ссылки.

Рис. 5.2.28. Редактирование отчета в Окне подготовки данных

28. Разбейте таблицу на две части. Для этого выделите строку, с которой должна начинаться вторая таблица. Затем нажмите кнопку С новой страницы на панели Таблица отчета.

29. Чтобы таблицы располагались горизонтально, выберите вариант Вниз, затем вправо в группе Компоновка на Панели свойств.

30. Подтвердите редактирование, нажав кнопку Создать отчет на Панели специального управления.

Рис. 5.2.29. Отредактированный отчет в документе

Текст отчета можно редактировать не только в Окне подготовки данных, но и непосредственно в поле фрагмента. Для этого дважды щелкните мышью по строке отчета. Затем внесите изменения в текст нужной ячейки.

Вставка названий

31. Вставьте названия для каждой таблицы. Для этого вызовите команду Название... из контекстного меню отчета в документе.

32. Введите в поля диалога тексты.

В примере заданы: в первом поле — Испытательный участок, во втором — Продолжение табл.

Рис. 5.2.30. Отчет с названиями таблиц

Разрушение связи

33. Освободите отчет от ассоциативной связи с документом-источником, если она не требуется в дальнейшей работе. Для этого вызовите команду Разрушить из контекстного меню отчета. Рамка, являющаяся признаком ассоциативности, не отображается.

34. Проверьте работу ссылок, как приведено выше (п.п.13–15).

35. Чтобы перестроить ссылки, нажмите кнопку Перестроить на панели Вид. Для работы с отчетами во фрагментах ее следует добавить на панель Вид, так как по умолчанию она отсутствует.


6.1. Общие сведения о спецификации

В этом разделе:

6.1.1. Объект спецификации

6.1.1.1. Объект спецификации и его свойства

6.1.1.1.1. Базовый объект

6.1.1.1.2. Вспомогательный объект

6.1.1.2. Состав объекта спецификации

6.1.1.2.1. Текстовая часть объекта спецификации

6.1.1.2.2. Геометрия объекта спецификации

6.1.1.2.3. Дополнительные параметры объекта спецификации

6.1.2. Структура спецификации

6.1.2.1. Разделы

6.1.2.1.1. Блоки разделов

6.1.2.1.2. Заголовки разделов и блоков разделов

6.1.2.2. Подразделы

6.1.2.3. Пустые строки

6.1.2.4. Резервные строки

6.1.2.5. Блоки исполнений

6.1.2.6. Сортировка объектов

6.1.2.6.1. Сортировка по возрастанию и по убыванию

6.1.2.6.2. Составная сортировка по возрастанию и по убыванию

6.1.2.6.3. Особые случаи составной сортировки

6.1.2.6.4. Сортировка для раздела документации

6.1.2.7. Простановка позиций

6.1.3. Взаимодействие спецификации с другими документами

6.1.3.1. Объекты спецификации в чертежах

6.1.3.2. Объекты спецификации в моделях

6.1.3.2.1. Деталь

6.1.3.2.2. Сборка

6.1.3.3. Подчиненный режим

6.1.3.4. Описание спецификации

6.1.3.5. Связь документов со спецификацией

6.1.3.5.1. Связь сборочного чертежа со спецификацией

6.1.3.5.2. Связь сборки со спецификацией

6.1.3.5.3. Связь документов с основной надписью спецификации

6.1.3.6. Синхронизация данных

6.1.3.6.1. Передача объектов из чертежа или сборки в спецификацию

6.1.3.6.2. Передача объектов из спецификации в чертеж и сборку

6.1.3.6.3. Передача данных между основной надписью спецификации и подключенными документами

6.1.3.6.4. Синхронизация данных при открытии спецификации. Перестроение спецификации

6.1.4. Интеграция с приложениями


6.1.1. Объект спецификации

6.1. Общие сведения о спецификации

6.1.1. Объект спецификации

Объект спецификации — строка или несколько следующих друг за другом строк спецификации КОМПАС-3D, относящихся к одному материальному объекту.

В этом разделе:

6.1.1.1. Объект спецификации и его свойства

6.1.1.1.1. Базовый объект

6.1.1.1.2. Вспомогательный объект

6.1.1.2. Состав объекта спецификации

6.1.1.2.1. Текстовая часть объекта спецификации

6.1.1.2.2. Геометрия объекта спецификации

6.1.1.2.3. Дополнительные параметры объекта спецификации


6.1.1.1. Объект спецификации и его свойства

Объект спецификации имеет информационную природу. Он представляет собой комплекс разнородных сведений о каком-либо материальном объекте (например, детали, сборочной единице или документе), включаемом в спецификацию.

Если применить эту терминологию к «бумажной» спецификации, можно сказать, что ее объект — это строка (или несколько строк) с данными об одном предмете (рис. 6.1.1).

Рис. 6.1.1. Объекты спецификации

Если сравнивать спецификацию с базой данных, то объект спецификации подобен записи в базе.

Объекты спецификации бывают базовые и вспомогательные.

В этом разделе:

6.1.1.1.1. Базовый объект

6.1.1.1.2. Вспомогательный объект


6.1.1.1.1. Базовый объект

Для базовых объектов предусмотрена возможность автоматического заполнения колонок, сортировки, подключения графических объектов из сборочного чертежа, подключения деталей из сборки и т.д.

При заполнении спецификации рекомендуется по возможности создавать базовые объекты.


6.1.1.1.2. Вспомогательный объект

В отличие от базового для вспомогательного объекта не предусмотрены сервисные функции, выполнение которых обеспечивает спецификация. Вспомогательные объекты не сортируются автоматически и т.д.

Вспомогательные объекты рекомендуется использовать для выполнения таких приемов оформления спецификации, которые не могут быть обеспечены вводом базовых объектов (рис.6.1.2). Например, при помощи вспомогательного объекта спецификации можно ввести произвольный текст (комментарий) в таблицу спецификации или создать пустую строку в середине раздела (подробнее см. раздел 6.2.2.3.1 и упражнение 13).

Рис. 6.1.2. Базовые и вспомогательные объекты спецификации


6.1.1.2. Состав объекта спецификации

Внешнее проявление объекта спецификации — его текстовая часть, размещаемая в строках бланка спецификации. Именно она соответствует строке «бумажной» спецификации.

Но в отличие от такой строки объект электронной спецификации содержит гораздо большее количество информации.

Как правило, базовый объект спецификации состоит из

– текстовой части,

– геометрии (графических объектов и трехмерных моделей),

– набора дополнительных параметров.

Вспомогательный объект спецификации не содержит геометрии и имеет меньше дополнительных параметров, чем базовый.

В этом разделе:

6.1.1.2.1. Текстовая часть объекта спецификации

6.1.1.2.2. Геометрия объекта спецификации

6.1.1.2.3. Дополнительные параметры объекта спецификации


6.1.1.2.1. Текстовая часть объекта спецификации

Текстовая часть объекта спецификации — это сведения, которые вносят в строку таблицы спецификации. Например, объекты, представленные на рис. 6.1.1, имеют текстовые части «А2 АЕКТ 620840.200СБ Сборочный чертеж», «А4 АЕКТ 620840.200ПС Паспорт», «А3 1 АЕКТ 620840.210 Указатель уровня 1», «А4 2 АЕКТ 620840.220 Насос 1», «А2 4 АЕКТ 620840.201 Корпус 1» и т.д.

Приемы ввода и редактирования текстовой части практически не отличаются от приемов работы с текстами на чертеже. Пользователю доступны команды форматирования шрифта и абзаца, вставки дробей, индексов, над- и подстрок, спецзнаков, символов и предопределенного текста.

Кроме того, при создании некоторых объектов, текстовая часть которых формируется по стандартным правилам, используются шаблоны заполнения текстовой части. Шаблоны заполнения — специфический механизм, используемый только при работе с объектами спецификации.

Подробнее о приемах ввода и редактировании текстовой части объекта спецификации рассказано в разделе 6.2.2.4.


6.1.1.2.2. Геометрия объекта спецификации

Объект спецификации может содержать информацию о

– графических объектах сборочного чертежа, составляющих его изображение,

и (или)

– соответствующем компоненте трехмерной сборки.

Эта информация называется геометрией объекта спецификации.

Например, при создании объекта спецификации «Вал» в качестве его геометрического состава были указаны отрезки, штриховки и другие элементы, изображающие вал в сборочном чертеже, а также деталь Вал из трехмерной сборки.

Подробно включение геометрии в состав объекта спецификации описано в разделе 6.2.2.5.

В состав объекта спецификации можно включить геометрию не из любого документа (чертежа или сборки), а только из подключенного к этой спецификации (см. разделы 6.1.3.5 и 6.2.4.1).

В спецификации можно включить режим показа геометрии объектов спецификации (см. раздел 6.2.2.5.3). В этом режиме система автоматически выделяет в чертеже или сборке геометрию, относящуюся к выделенному объекту спецификации (при условии, что чертеж или сборка открыты). При перемещении по спецификации (например, при помощи клавиш со стрелками) в окне чертежа или сборки подсвечиваются изображения, соответствующие объектам спецификации.

Такой режим чрезвычайно удобен при работе со сборками, содержащими не один десяток компонентов. Он позволяет быстро отыскать на сборочном чертеже или в модели изображение любого объекта спецификации (сборочной единицы, детали, стандартного изделия и т.д.).

Включение в состав геометрии объекта спецификации всех графических объектов, составляющих его изображение, не является строго обязательным. Однако настоятельно рекомендуется включать в геометрию объекта позиционную линию-выноску.

Благодаря включению позиционной линии-выноски в графический состав объекта спецификации осуществляются некоторые функции ассоциативной связи спецификации со сборочным чертежом, а именно — соответствие номера позиции на чертеже номеру позиции в спецификации и автоматический расчет зон.

– После того как вы изменили в спецификации какие-либо номера позиций, достаточно передать эти изменения в чертеж (см. разделы 6.1.3.6.2 и 6.2.4.2.2), и на полках линий-выносок в нем автоматически появятся новые номера позиций.

– Если в спецификации включен расчет зон (см. раздел 6.4.2.1), то после изменения положения позиционных линий-выносок в чертеже (например, в результате изменения масштаба изображения или формата чертежа) в спецификацию можно автоматически передать новые обозначения зон, в которых находится каждая позиция (см. разделы 6.1.3.6.1 и 6.2.4.2.1).

Спецификацию можно настроить таким образом, чтобы при удалении ее объекта происходило и автоматическое удаление соответствующей геометрии, а при удалении геометрии — автоматическое удаление объекта (см. раздел 6.4.2.1). Например, если удалить объект «Прокладка» из спецификации, то пропадет и изображение прокладки в чертеже и наоборот.

Этой возможностью спецификации следует пользоваться очень аккуратно, т.к. восстановление ошибочно удаленной геометрии не всегда возможно.


6.1.1.2.3. Дополнительные параметры объекта спецификации

Объект спецификации может содержать большое количество разнородной информации. Она дополняет текстовую часть объекта, видимую в строке спецификации.

Эта информация никогда не видна в бланке спецификации. Однако ее можно в любой момент просмотреть и отредактировать.

Все виды этой информации называются дополнительными параметрами объекта спецификации.

К дополнительным параметрам объекта спецификации относятся

– настройки этого объекта,

– подключенные к объекту документы,

– данные в дополнительных колонках объекта.

Настройки объекта

Настройки объекта влияют на его положение и отображение в спецификации, а также на его «поведение» при автоматической простановке позиций и сортировке объектов (см. раздел 6.2.2.6.1).

Подключенные документы

К объекту спецификации можно подключить документы системы КОМПАС-3D (см. раздел 6.2.2.6.3). Связь между ними является двусторонней и ассоциативной. Она позволяет

– автоматически передавать данные между текстовой частью объекта и подключенными к нему документами (см. раздел 6.2.4.2.2),

– автоматически создавать заготовку чертежа детали на основе ее изображения в сборочном чертеже (см. раздел 6.2.6.4), а также облегчает доступ к документам.

Дополнительные колонки

Объект спецификации может содержать сведения, дополняющие информацию, включаемую в стандартный бланк. Эти сведения хранятся в так называемых «дополнительных колонках» объекта спецификации (см. раздел 6.2.2.6.2). Их можно просмотреть или отредактировать в любой момент. Однако в бланке спецификации они не видны и на печать не выводятся.

Пример информации в дополнительных колонках — масса и стоимость объекта. В дополнительные колонки вводят и любую другую информацию об объекте (код ОКП, материал, текстовый комментарий и т.д.). Количество и состав дополнительных колонок определяются потребностями пользователя.

Данные в дополнительных колонках можно просуммировать автоматически (см. раздел 6.2.6.2). Обычно эта возможность используется для расчета стоимости компонентов изделия и его массы (в отсутствие трехмерной модели).


6.1.2. Структура спецификации

6.1. Общие сведения о спецификации

6.1.2. Структура спецификации

Основной структурной единицей спецификации является объект спецификации.

Подобно тому, как чертеж состоит из геометрических объектов и макроэлементов, а текстовый документ состоит из слов и предложений, спецификация состоит из объектов спецификации, сгруппированных по разделам.

Объекты в таблице спецификации чередуются с заголовками разделов, заголовками блоков, пустыми строками и резервными строками.

В этом разделе:

6.1.2.1. Разделы

6.1.2.1.1. Блоки разделов

6.1.2.1.2. Заголовки разделов и блоков разделов

6.1.2.2. Подразделы

6.1.2.3. Пустые строки

6.1.2.4. Резервные строки

6.1.2.5. Блоки исполнений

6.1.2.6. Сортировка объектов

6.1.2.6.1. Сортировка по возрастанию и по убыванию

6.1.2.6.2. Составная сортировка по возрастанию и по убыванию

6.1.2.6.3. Особые случаи составной сортировки

6.1.2.6.4. Сортировка для раздела документации

6.1.2.7. Простановка позиций


6.1.2.1. Разделы

Порядок следования объектов в спецификации определяется стандартом. Стандарт предусматривает также объединение объектов в разделы и задает очередность разделов.

Разделы являются одним из компонентов стиля спецификации (см. раздел 6.4.1). Их количество, названия и порядок формируются при настройке стиля. Выбрав стиль текущей спецификации, вы тем самым, помимо прочих настроек и параметров, выбираете список возможных разделов спецификации.

Перед добавлением объекта можно выбрать или создать раздел для его размещения.

Перемещение объекта из одного раздела в другой невозможно.

В спецификации не могут существовать разделы без объектов. Поэтому при создании нового раздела в нем сразу возникает первый объект, а при удалении последнего объекта из раздела удаляется и сам раздел.

Удалить раздел можно только путем последовательного удаления всех объектов в нем.

Раздел, один из объектов которого выделен или редактируется, считается текущим.

Особенностью спецификации системы КОМПАС-3D является возможность создавать и заполнять разделы в произвольной последовательности. Вы можете сначала ввести стандартные изделия, затем создать и заполнить раздел Документация, перейти к вводу деталей, а потом — сборочных единиц.

Система автоматически расположит получившиеся разделы в стандартной последовательности (в общем случае — в последовательности, заданной при настройке стиля спецификации). Каждый новый раздел будет размещаться в строго определенном по отношению к существующим разделам месте, при необходимости «раздвигая» уже заполненные строки.

В этом разделе:

6.1.2.1.1. Блоки разделов

6.1.2.1.2. Заголовки разделов и блоков разделов


6.1.2.1.1. Блоки разделов

Спецификация может содержать вложенные и дополнительные разделы.

Вложенные разделы располагаются внутри раздела, после всех объектов этого раздела.

Дополнительные разделы располагаются в конце спецификации, после всех ее разделов. Обычно дополнительные разделы размещают, начиная с нового листа.

Группы вложенных и дополнительных разделов называются соответственно блоками вложенных разделов и блоками дополнительных разделов.

Например, в раздел Комплекты простой спецификации по ГОСТ 2.106–96 могут входить следующие блоки вложенных разделов:

– Комплект монтажных частей,

– Комплект сменных частей,

– Комплект запасных частей,

– Комплект инструмента и принадлежностей,

– Комплект укладочных средств.

Примером спецификации с дополнительными разделами может служить спецификация, выполненная по ГОСТ 2.413–72 «Правила выполнения конструкторской документации изделий, изготовляемых с применением электрического монтажа». Такая спецификация может содержать один из следующих блоков дополнительных разделов:

– Устанавливают по ХХХХ.ХХХХХХ.ХХХМЭ,

– Устанавливают по ХХХХ.ХХХХХХ.ХХХТБ,

– Устанавливают при электромонтаже.

При использовании в спецификации блоков Устанавливают по... возможно указание документа (обычно электромонтажного чертежа или таблицы соединений). Обозначение указанного документа автоматически подставляется в заголовок блока разделов (см. раздел 6.4.2.4).

Дополнительными и вложенными разделами в спецификации КОМПАС-3D могут быть только разделы, аналогичные основным — не вложенным и не дополнительным — разделам. При этом настройки дополнительных и вложенных разделов совпадают с настройками соответствующих основных разделов. Обычно в качестве дополнительных и вложенных разделов используются следующие:

– Сборочные единицы,

– Детали,

– Стандартные изделия,

– Прочие изделия,

– Материалы.

Блоки дополнительных и вложенных разделов и перечни разделов, входящих в них — компоненты стиля спецификации.

Нумерация объектов в спецификации с вложенными или дополнительными блоками сквозная.

О создании спецификаций с блоками дополнительных и вложенных разделов рассказано в разделе 6.2.7.2.


6.1.2.1.2. Заголовки разделов и блоков разделов

Как правило, название каждого раздела или блока разделов спецификации размещается в отдельной строке (или нескольких строках) в начале раздела или блока. Эти строки называются соответственно заголовками разделов и заголовками блоков. Например, на рис. 6.1.3 показаны заголовки разделов.

Спецификацию можно настроить так, чтобы заголовки разделов (в том числе дополнительных и вложенных) не отображались в ее бланке (см. раздел 6.4.2.2). Аналогичная настройка возможна для заголовков блоков (см. разделы 6.4.2.2.3 и 6.4.2.4).


6.1.2.2. Подразделы

Зачастую стандарт предписывает группировать объекты в разделе по категориям, а внутри получившихся групп сортировать по наименованию или обозначению. Этот механизм также поддерживается спецификацией системы КОМПАС-3D.

Группы объектов внутри разделов называются подразделами.

Подразделы, как и разделы, являются компонентом стиля спецификации. Их количество, названия и порядок внутри каждого раздела формируются при настройке стиля.

Выбрав стиль текущей спецификации, вы тем самым, помимо прочих настроек и параметров, выбираете списки возможных подразделов в каждом разделе спецификации.

Примером применения подразделов может служить Ведомость ссылочных документов, в каждом разделе которой документы требуется группировать по видам в следующей последовательности:

– Стандарты,

– ТУ на покупные изделия и материалы,

– Руководящие технические материалы,

– Инструкции.

Если деление на подразделы не запрещено в стиле текущей спецификации, то при ее настройке можно изменить список подразделов в каждом ее разделе (см. раздел 6.4.2.2).

При создании нового объекта можно выбрать не только раздел, но и подраздел для его размещения.

Можно вводить объекты в произвольном порядке, выбирая подразделы, к которым они относятся. Спецификация разместит объекты в каждом разделе с учетом порядка подразделов.

Возможно перемещение объекта из одного подраздела в другой.

Названия подразделов не отображаются в бланке спецификации. Они служат лишь для удобства выбора подраздела.


6.1.2.3. Пустые строки

Пустая строка — строка в бланке спецификации, расположенная непосредственно над или под заголовком раздела или блока разделов. Она отделяет заголовок от объектов спецификации (рис. 6.1.3).

В пустую строку невозможно ввести текст. Ее наличие в спецификации продиктовано стандартом.

Отображение пустых строк вокруг заголовков разделов можно выключить при настройке разделов (см. раздел 6.4.2.2), а вокруг заголовков блоков — при настройке блоков (см. разделы 6.4.2.2.3 и 6.4.2.4).


6.1.2.4. Резервные строки

Резервная строка — строка спецификации, предназначенная для внесения последующих изменений в выпущенную (напечатанную на бумаге) спецификацию (рис. 6.1.3).

Наличие резервных строк в спецификации продиктовано стандартом.

В каждом разделе система автоматически создает несколько резервных строк (их количество определяется пользователем).

Эти строки всегда расположены в конце раздела (в каком бы порядке вы ни вводили в него объекты спецификации), в них никогда нельзя ввести данные.

При простановке позиций в каждом разделе учитывается количество резервных строк в предыдущем разделе (см. разделы 6.1.2.7 и 6.2.2.8).

Рис. 6.1.3. Заголовки разделов, пустые и резервные строки


6.1.2.5. Блоки исполнений

Стандартом предусмотрено несколько форм (бланков) для групповых спецификаций. Максимальное число колонок для ввода количества на исполнение в этих формах — 10.

Один из способов заполнения спецификации на изделие, имеющее более десяти исполнений — разбиение исполнений на группы по десять и внесение в одну спецификацию сначала данных об исполнениях с основного по девятое, затем — с десятого по девятнадцатое и так далее. Такие группы называются блоками исполнений.

Если начало блока исполнений приходится на начало листа спецификации, то номера исполнений размещаются в «шапке» спецификации. Если начало блока исполнений приходится на середину листа, то блоки отделяются друг от друга строкой «Обозн. исполн.» (обозначения исполнений), содержащей в колонках Количество на исполнение обозначения исполнений последующего блока. Эта строка (рис. 6.1.4) называется началом блока. Она, как и заголовок раздела, сверху и снизу обрамлена пустыми строками.

Рис. 6.1.4. Блоки исполнений

Отображение строк, содержащих начала блоков, и пустых строк вокруг них можно отключить при настройке блоков исполнений (см. раздел 6.4.2.3).


6.1.2.6. Сортировка объектов

В спецификации может производиться автоматическая сортировка объектов внутри раздела.

Правила сортировки являются компонентом стиля спецификации (см. раздел 6.4.1).

Правила сортировки объектов (колонки для сортировки и тип сортировки в каждой из них) устанавливаются для каждого раздела. Объекты сортируются последовательно по выбранным колонкам (в разных разделах колонки для сортировки могут быть разными).

При настройке текущей спецификации можно включать и отключать автоматическую сортировку объектов в каждом разделе (см. разделы 6.2.2.7 и 6.4.2.2), но нельзя менять правила сортировки. Для изменения правил сортировки в текущей спецификации нужно сменить стиль этой спецификации на стиль, содержащий нужные правила сортировки.

Пользователь может отказаться от автоматической сортировки объектов в любом разделе. Все объекты раздела, в котором отключена автоматическая сортировка, можно располагать в произвольной последовательности.

Если в разделе включена автоматическая сортировка, то она выполняется каждый раз после создания в разделе нового объекта и после редактирования текстовой части существующего объекта.

Если раздел содержит подразделы, то автоматическая сортировка происходит внутри подразделов. При этом порядок следования подразделов не нарушается и объекты между подразделами не перемещаются.

Предусмотрено пять типов сортировки объектов:

– по возрастанию,

– по убыванию,

– составная по возрастанию,

– составная по убыванию,

– для раздела документации.

В этом разделе:

6.1.2.6.1. Сортировка по возрастанию и по убыванию

6.1.2.6.2. Составная сортировка по возрастанию и по убыванию

6.1.2.6.3. Особые случаи составной сортировки

6.1.2.6.4. Сортировка для раздела документации


6.1.2.6.1. Сортировка по возрастанию и по убыванию

Сортировка по возрастанию происходит по-разному в зависимости от типа данных в колонке.

В колонках с числовым типом данных сортировка объектов производится путем сравнения их значений. В результате сортировки числа располагаются в порядке возрастания.

Пример списка числовых значений, отсортированного по возрастанию:

25

125

250

В колонках с типом данных «строка» сортировка объектов по возрастанию производится путем сравнивания символов в соответствующих позициях строк (начиная с первой позиции). В результате сортировки первой окажется cтрока, первый отличающийся символ которой расположен в алфавите ближе к началу. Цифры располагаются перед буквами, а латинские буквы — перед кириллическими. Примером сортировки по возрастанию является расположение статей в большинстве словарей и энциклопедий.

Пример списка обозначений, отсортированного по возрастанию:

А125ГП

А25МП

Д250МП

Д25ГП

В данном случае вначале сравнивались первые символы строк. Строки, начинающиеся с А, оказались перед строками, начинающимися с Д. Внутри первой группы строк (А25МП и А125ГП) было произведено сравнивание вторых символов — 1 и 2. Первой оказалась строка, содержащая на второй позиции единицу. При дальнейшем сравнении строк, начинающихся с Д, их вторые и третьи символы оказались одинаковыми. В результате сравнения четвертых символов (цифры 0 и буквы Г) строка, содержащая букву, оказалась последней.

Сортировка по убыванию также происходит по-разному в зависимости от типа данных в колонке. Правила сортировки по убыванию противоположны правилам сортировки по возрастанию.

Списки, отсортированные в предыдущем примере по возрастанию, после сортировки по убыванию будут выглядеть так:

250

125

25

и

Д25ГП

Д250МП

А25МП

А125ГП


6.1.2.6.2. Составная сортировка по возрастанию и по убыванию

Правила составной сортировки сочетают в себе правила сортировки для колонок с разными типами значений. В этом случае строки разбиваются на буквы и числа, составленные из стоящих рядом цифр. Затем производится последовательное сравнивание букв и чисел. Главное отличие составной сортировки от сортировки по убыванию или по возрастанию — учет значений чисел, находящихся в любом месте строки. В то время как при обычной сортировке сравниваются цифры с цифрами и цифры с буквами, при составной сортировке сравниваются числа с числами.

Строки из предыдущих примеров после составной сортировки по возрастанию располагаются в следующем порядке:

А25МП

А125ГП

Д25ГП

Д250МП

Вначале сравнивались первые символы, и в результате первыми в списке оказались строки, начинающиеся с буквы А. При дальнейшей сортировке строк А25МП и А125ГП сравнивались не цифры 2 и 1, а числа 25 и 125. В результате строка, содержащая меньшее число 25, оказалась первой. В строках Д25ГП и Д250МП сравнивались не символы 2 и 2, 5 и 5, Г и 0, а числа 25 и 250. В результате строка, содержащая большее число 250, оказалась последней.

Этот же список после составной сортировки по убыванию (правила которой противоположены правилам составной сортировки по возрастанию) будет выглядеть так:

Д250МП

Д25ГП

А125ГП

А25МП


6.1.2.6.3. Особые случаи составной сортировки

Более сложное проявление составной сортировки — сортировка текстов, созданных по шаблонам заполнения (обычно это наименования стандартных изделий и материалов, подробнее см. раздел 6.2.2.4.5). Тексты, созданные по шаблону, состоят из нескольких полей. Эти тексты часто требуется сортировать не в последовательности символов и чисел, из которых они состоят, а в определенной последовательности полей по значениям в этих полях. Например, стандартные изделия вначале сортируются по наименованию, затем — по обозначению стандарта, затем — в порядке возрастания основных параметров и размеров. Пример составной сортировки наименований стандартных изделий:

Шпонка 2–10х8х40 ГОСТ 23360–78

Шпонка 2–14х9х50 ГОСТ 23360–78

Штифт 10х45 ГОСТ 3128–70

Штифт 12х50 ГОСТ 3128–70

Информация о том, по каким полям и в какой очередности сортировать объекты данного вида, хранится в шаблоне заполнения. Подробно о шаблонах заполнения рассказано в разделе 6.4.5.

Иногда для правильного расположения текстов, сформированных по шаблону, не подходит ни сортировка по возрастанию, ни сортировка по убыванию. В этих случаях при настройке шаблона порядок сортировки значений в полях задается явно — путем перечисления возможных значений и расположения их в нужной последовательности.

Например, обозначения электротехнических элементов в пределах одного и того же наименования необходимо сначала сортировать в порядке увеличения единиц измерения, а затем — номинального значения:

Резистор МЛТ-0,25-210 Ом ТУ 11–85

Резистор МЛТ-0,5-240 Ом ТУ 11–85

Резистор МЛТ-0,25 24 кОм ТУ 11–85

Резистор МЛТ-0,25-27 кОм ТУ 11–85

Для правильной сортировки по полю, содержащему единицы измерения, используется возможность явного задания порядка сортировки значений соответствующего поля (см. раздел 6.5.1.9).

Колонки спецификации, текст в которых формируется и сортируется с использованием шаблонов, имеют тип значений «запись».


6.1.2.6.4. Сортировка для раздела документации

Сортировка для раздела документации, как правило, включается только при настройке раздела Документация. При таком типе сортировки учитываются последние символы обозначения, т.е. код документа. Вначале производится составная сортировка строк по возрастанию без кода. Внутри получившихся групп с одинаковым началом строк производится сортировка по коду: объекты записываются в последовательности, в которой коды перечислены в файле graphic.kdsp.

Порядок следования кодов в файле graphic.kdsp соответствует ГОСТ 2.102–2013. Формат файла — текстовый, поэтому при необходимости вы можете открыть и отредактировать его в любом текстовом редакторе, см. раздел 9.5.5.4. По умолчанию файл graphic.kdsp находится в подпапке \Sys главной папки системы.

Документы, имеющие двойной код, например, СБ-ЛУ (лист утверждения) или СБ-УЛ (информационно-удостоверяющий лист), записываются после документа, к которому они разработаны.

Документы с произвольным (отсутствующим в файле graphic.kdsp) кодом, сортируются в алфавитном порядке кодов и записываются после документов со стандартным кодом.

В отсутствие файла graphic.kdsp объекты спецификации сортируются в алфавитном порядке кодов.

Пример сортировки обозначений документов в разделе Документация:

318.606100.00 СБ

318.606100.00 СБ-ЛУ

318.606100.00 К3

318.606100.00 ПЗ

318.606100.00 РР

Перечисленные документы расположены в следующем порядке: сборочный чертеж, лист утверждения к сборочному чертежу, схема кинематическая принципиальная, пояснительная записка, расчеты.


6.1.2.7. Простановка позиций

Для конструктора главным связующим звеном между сборочным чертежом и спецификацией являются номера позиций. Только благодаря этим числам на полках линий-выносок и в колонке Позиция можно установить соответствие между изображенным на чертеже предметом (деталью, узлом) и строкой спецификации.

Такое соответствие может поддерживаться спецификацией системы КОМПАС-3D автоматически. При этом номер позиции объекта спецификации передается на полку линии-выноски в чертеже.

Номера позиций объектам спецификации также могут присваиваться автоматически. При создании базовых объектов спецификации в их колонках Позиция появляются номера, отражающие порядок возникновения объектов.

Пользователь может запретить простановку позиций в любом разделе (см. раздел 6.2.2.8).

Любой базовый объект можно настроить так, чтобы номер его позиции не отображался в таблице спецификации, даже если этот объект находится в разделе, где разрешена простановка позиций (см. раздел 6.2.2.6.1).

В результате сортировки или создания объектов не в порядке следования разделов последовательность нумерации объектов может не совпадать с последовательностью их расположения в таблице (рис. 6.1.5, а). Для устранения этого несоответствия служит команда Сервис — Расставить позиции, выполняющая расчет и автоматическую простановку номеров позиций объектов спецификации (рис. 6.1.5, б).

Рис. 6.1.5. Номера в колонке Позиция: а) возникшие при вводе объектов; б) упорядоченные в результате действия команды Расставить позиции
а) | б)

При простановке позиций учитывается порядок следования объектов в спецификации, количество резервных строк в каждом разделе, отключение простановки позиций в отдельных разделах и настройки объектов. Каждый базовый объект получает номер позиции, соответствующий его индивидуальным настройкам и его положению в спецификации. Это не относится к объектам в разделах, где выключена простановка позиций.

Если в разделе отключена простановка позиций, то числа в его колонке Позиция не возникают ни при вводе объектов, ни при автоматической простановке позиций. Объектам следующего раздела (если в нем включена простановка позиций) присваиваются номера, следующие за номерами позиций предыдущих пронумерованных объектов.

Простановка позиций в разделе (если она включена) производится даже в том случае, когда отключен показ номеров позиций у всех или у некоторых объектов раздела. При этом может оказаться, что номера позиций в разделе не видны, но учитываются при нумерации объектов в следующих разделах.

В некоторых случаях несколько следующих друг за другом объектов спецификации могут иметь одинаковые номера позиций (см. раздел 6.2.2.6.1). При этом показ повторяющихся номеров может быть отключен. Пример объектов, имеющих одинаковые номера позиций — исполнения одной и той же детали в групповой спецификации.

Передача номеров позиций из спецификации на полки позиционных линий-выносок в чертеже возможна только для тех объектов спецификации, в состав геометрии которых входит позиционная линия-выноска (см. раздел 6.2.2.5). Эта передача происходит при синхронизации данных (см. раздел 6.2.4.2.2).


6.1.3. Взаимодействие спецификации с другими документами

6.1. Общие сведения о спецификации

6.1.3. Взаимодействие спецификации с другими документами

В чертежах, фрагментах, деталях и сборках могут существовать точно такие же объекты спецификации, как и в документе-спецификации.

По умолчанию эти объекты не видны в графических документах и моделях в режиме построений и не выводятся на печать1. Однако их можно в любой момент просмотреть и отредактировать.

Для просмотра и редактирования объектов спецификации, существующих в чертежах, фрагментах, деталях и сборках, предназначен специальный («подчиненный») режим (см. разделы 6.1.3.3 и 6.2.3.5).

  1. В чертеже можно включить такой режим, в котором таблица спецификации с расположенными в ней объектами разместится над основной надписью и будет напечатана вместе с чертежом (см. раздел 6.2.6.12).

В этом разделе:

6.1.3.1. Объекты спецификации в чертежах

6.1.3.2. Объекты спецификации в моделях

6.1.3.2.1. Деталь

6.1.3.2.2. Сборка

6.1.3.3. Подчиненный режим

6.1.3.4. Описание спецификации

6.1.3.5. Связь документов со спецификацией

6.1.3.5.1. Связь сборочного чертежа со спецификацией

6.1.3.5.2. Связь сборки со спецификацией

6.1.3.5.3. Связь документов с основной надписью спецификации

6.1.3.6. Синхронизация данных

6.1.3.6.1. Передача объектов из чертежа или сборки в спецификацию

6.1.3.6.2. Передача объектов из спецификации в чертеж и сборку

6.1.3.6.3. Передача данных между основной надписью спецификации и подключенными документами

6.1.3.6.4. Синхронизация данных при открытии спецификации. Перестроение спецификации


6.1.3.1. Объекты спецификации в чертежах

Обычно при вычерчивании сборочного чертежа изображения деталей и узлов, позиционные линии-выноски и прочие сведения вводятся до создания отдельного документа-спецификации.

При традиционном («бумажном») способе формирования спецификации конструктор помнит всю эту информацию или записывает ее в черновик до начала заполнения спецификации. При работе в системе КОМПАС-3D сведения, которые потребуются при создании спецификации на основе текущего чертежа, можно сохранять прямо в этом чертеже.

Создавайте объекты спецификации в чертеже по мере построения их изображений (см. раздел 6.2.3.1). После подключения к чертежу спецификации (см. раздел 6.2.4.1.1) эти объекты можно будет передать в нее в любой момент (см. раздел 6.2.4.2.1). При этом объекты не исчезают из чертежа, а лишь копируются в спецификацию (вместе со всеми своими дополнительными параметрами и сведениями о подключенной к ним геометрии).

Объект спецификации можно редактировать и в документе-спецификации, и в чертеже (в подчиненном режиме). После того как объект спецификации отредактирован в одном из связанных документов (спецификации или чертеже), изменения можно передать в другой документ — произвести синхронизацию (см. раздел 6.2.4.2).

Так как передача объектов спецификации из чертежа в спецификацию требует вызова только одной команды и занимает мало времени (обычно — несколько секунд), она может быть использована для быстрого восстановления утраченной или испорченной спецификации. Если вы будете создавать объекты сразу в отдельном документе-спецификации и впоследствии не передадите их в чертеж, то такое восстановление будет невозможно.

Еще одно преимущество создания объектов спецификации в чертеже — возможность получения объектом данных непосредственно с чертежа. Если создать в чертеже объект спецификации, содержащий в своем геометрическом составе позиционную линию-выноску, то в колонке Зона будет автоматически появляться обозначение зоны чертежа, в которой находится подключенная геометрия, а после каждого изменения номера позиции объекта спецификации (например, в результате сортировки) новый номер будет появляться на полке соответствующей линии-выноски в чертеже.


6.1.3.2. Объекты спецификации в моделях

Объекты спецификации можно создавать не только в «плоском» сборочном чертеже, но и в трехмерной модели (детали или сборке). Формирование объектов спецификации в модели возможно на любом этапе ее построения (см. разделы 6.2.3.3 и 6.2.3.4).

Объект спецификации можно редактировать и в документе-спецификации, и в модели (см. раздел 6.2.3.5). После того как объект спецификации отредактирован в одном из связанных документов (спецификации или модели), изменения можно передать в другой документ — произвести синхронизацию (см. раздел 6.2.4.2).

В этом разделе:

6.1.3.2.1. Деталь

6.1.3.2.2. Сборка


6.1.3.2.1. Деталь

Деталь может иметь неограниченное количество объектов спецификации, принадлежащих любым разделам спецификации. Однако в большинстве случаев в детали создают единственный объект спецификации, содержащий ее наименование и обозначение и принадлежащий разделу Детали.

При вставке в сборку детали ее объекты спецификации детали попадают в эту сборку, а из нее — в подключенную спецификацию. Принадлежность объектов разделам спецификации сохраняется.


6.1.3.2.2. Сборка

Объекты спецификации в сборке бывают двух типов: внешние и внутренние.

Внешние объекты спецификации

Внешние объекты спецификации в сборке — объекты спецификации, предназначенные для передачи в те сборки, в которые данная сборка войдет в качестве подсборки.

Внешние объекты спецификации формируются пользователем (см. раздел 6.2.3.4.1). Они могут принадлежать любым разделам спецификации. Однако в большинстве случаев в сборке создают единственный объект спецификации, содержащий ее наименование и обозначение и принадлежащий разделу Сборочные единицы.

При вставке сборки в другую сборку ее внешние объекты спецификации попадают в главную сборку, а из нее — в подключенную спецификацию. Принадлежность объектов разделам спецификации сохраняется.

Внутренние объекты спецификации

Внутренние объекты спецификации в сборке — объекты, которые не передаются в другую сборку при вставке в нее данной сборки в качестве подсборки.

Они могут быть сформированы пользователем, а могут «прийти» в сборку из других моделей — при вставке в сборку компонентов (деталей и подсборок) происходит автоматическое формирование ее внутренних объектов спецификации. В сборку передаются внешние объекты спецификации, принадлежащие подсборкам и объекты спецификации, принадлежащие деталям.

Внутренние объекты передаются в подключенный к сборке документ-спецификацию (см. раздел 6.2.4.2.1). При этом объекты не исчезают из сборки, а лишь копируются в спецификацию (вместе со всеми своими дополнительными параметрами и сведениями о подключенной к ним геометрии).

Внутренние объекты спецификации передаются и в чертежи при создании в них ассоциативных видов, содержащих изображения моделей. Благодаря этому при формировании полного комплекта ассоциативных документов (моделей, чертежей и спецификаций) каждый объект спецификации достаточно создать один раз — в модели. Из нее объект попадет в модели более высокого уровня, чертежи и спецификации.

Пользователь может дополнить набор внутренних объектов спецификации, создавая новые объекты, не связанные с внешними файлами (см. раздел 6.2.3.4.2). Эти внутренние объекты при необходимости можно связать с одним или несколькими телами, построенными в сборке (см. раздел 6.2.2.5.1).

Также пользователь может отредактировать внутренние объекты, автоматически сформированные системой.

При необходимости пользователь может исключить из сборки или чертежа любой объект спецификации, принадлежащий детали (подсборке).


6.1.3.3. Подчиненный режим

Подчиненный режим — режим просмотра и редактирования объектов спецификации непосредственно в графическом документе или модели.

Этот режим доступен, если в документе есть описание спецификации. Для перехода в подчиненный режим служит команда Спецификация — Редактировать объекты.

Для работы с объектами спецификации в графическом документе или модели открывается специальное окно с колонками и разделами, идентичными колонкам и разделам спецификации. Это окно практически не отличается от окна редактирования документа-спецификации. Только в его заголовке показывается не имя документа-спецификации, а имя документа, в котором находятся объекты спецификации, и ремарка «→ Объекты спецификации».

В подчиненном режиме доступны все приемы работы с объектами спецификации. Единственным исключением является невозможность вызова команды простановки позиций.

Созданные и отредактированные в подчиненном режиме объекты постоянно хранятся в графическом документе или модели. Их можно в любой момент передать в спецификацию, связанную с документом.

Признаком того, что спецификация находится в починенном режиме, служит появление значка режима в окне документа. Чтобы выйти из этого режима, можно щелкнуть по значку мышью.


6.1.3.4. Описание спецификации

Описание спецификации включает в себя имя файла спецификации, подключенной к документу, стиль этой спецификации и настройку отображения значений массы.

Работа с описаниями спецификаций, имеющимися в документе, производится в диалоге, вызываемом командой Спецификация — Управление описаниями спецификаций. В нем можно создать описание, отредактировать его, сделать текущим или удалить.

Возможно и автоматическое создание описания спецификации в документе.

Так, в момент создания в документе (модели или чертеже) первого объекта спецификации этот документ получает описание спецификации. Объект создается в соответствии со стилем, выбранным в системе для новых документов-спецификаций. Поэтому возникшее описание содержит стиль спецификации, указанный в настройке новых документов. Настройка отображения значений массы также соответствует умолчательной для новых спецификаций.

Сборка получает описание спецификации также при вставке в нее компонента, содержащего объекты спецификации.

До тех пор пока к модели или чертежу не подключен документ-спецификация, описание не содержит имени файла спецификации.

Если при работе со спецификацией к ней подключили модель или чертеж (см. раздел 6.2.4.1), в подключенном документе появляется описание. Оно содержит стиль и имя файла спецификации. После подключения объекты в чертеже или модели создаются в соответствии со стилем подключенной спецификации. Это делается для того, чтобы объекты в чертеже (модели) и подключенной спецификации имели одинаковую структуру (колонки, правила сортировки) и при передаче объектов между документами их внешний вид не изменялся.

Для фрагмента описание спецификации содержит только стиль спецификации и настройку отображения значений массы. Это связано с тем, что фрагмент непосредственно к спецификации не подключается, но в нем можно создавать объекты спецификации для передачи в чертежи (см. раздел 6.2.3.1.2).

Обычно модель или чертеж содержит одно описание спецификации, позволяющее создавать в нем объекты для передачи в единственную спецификацию. Однако допустимо создание нескольких описаний спецификаций в одном документе. Об этом подробно рассказано в разделе 6.2.6.14.

Если модель или чертеж имеет несколько описаний спецификации, то только одно из них является текущим в данный момент времени. Объекты спецификации создаются в соответствии со стилем, входящим в текущее описание спецификации. Пользователь может в любое время сделать текущим другое описание спецификации.


6.1.3.5. Связь документов со спецификацией

Как правило, внутри комплекта документов на изделие, создаваемых в КОМПАС-3D, существуют ассоциативные связи. Благодаря им обеспечивается обмен данными между документами.

В этом разделе:

6.1.3.5.1. Связь сборочного чертежа со спецификацией

6.1.3.5.2. Связь сборки со спецификацией

6.1.3.5.3. Связь документов с основной надписью спецификации


6.1.3.5.1. Связь сборочного чертежа со спецификацией

В конструкторской практике спецификация, составляемая на изделие, всегда соответствует сборочному чертежу этого изделия.

Спецификация КОМПАС-3D также может быть связана со сборочным чертежом (одним или несколькими чертежами КОМПАС-3D). Эта связь является двунаправленной и ассоциативной.

Пользователь может указать сборочный чертеж, которому соответствует текущая спецификация (см. раздел 6.2.4.1.2). В результате чертеж получает и сохраняет информацию о том, какая спецификация к нему подключена. Такую связь можно установить и из текущего сборочного чертежа, указав разрабатываемую для него спецификацию (см. раздел 6.2.4.1.1). При этом информация о подключении чертежа будет передана в спецификацию.

Таким образом, после установления связи между спецификацией и сборочным чертежом информация об этой связи хранится в обоих документах, а способ их подключения друг к другу (из чертежа или из спецификации) определяется исключительно выбором пользователя.

Находясь в окне спецификации, можно быстро открыть подключенные к ней чертежи. И наоборот, при работе с чертежом можно быстро вызвать подключенную к нему спецификацию. Благодаря однажды установленной связи спецификации и сборочного чертежа система «помнит» местонахождение связанных документов и по команде открытия находит их самостоятельно.

Другое проявление двунаправленной связи — возможность передачи данных из чертежа в спецификацию или из спецификации в чертеж, причем передача ассоциативна (см. раздел 6.2.4.2).

Из чертежа в спецификацию могут передаваться обозначения зон, в которых находятся изображения объектов спецификации, наименования и обозначения этих объектов. Из спецификации в чертеж могут передаваться номера позиций, наименования и обозначения объектов.

Например, в результате изменения масштаба чертежа или положения изображения некоторые позиции попали в другие зоны чертежа. Для ликвидации последствий этой ситуации «вручную» придется просмотреть все позиционные линии-выноски, проверить, в какой зоне они находятся и при необходимости исправить обозначения зон в спецификации. Спецификация КОМПАС-3D выполняет все эти действия автоматически (по команде пользователя). Обозначения зон, в которых находятся позиции на данный момент, передаются в спецификацию и размещаются в ее колонке Зона, в строке с соответствующей позицией. Если в результате сортировки объектов в спецификации изменились номера позиций, меняются номера на полках соответствующих позиционных линий-выносок в чертеже.

Таким образом, сделанные в одном документе изменения передаются в однозначно определенное, соответствующее им место другого документа.


6.1.3.5.2. Связь сборки со спецификацией

Кроме сборочного чертежа спецификация КОМПАС-3D может быть связана с трехмерной моделью сборки. Эта связь также является двунаправленной и ассоциативной.

Пользователь может указать модель, которой соответствует текущая спецификация (см. раздел 6.2.4.1.2). В результате модель получает и сохраняет информацию о том, какая спецификация к ней подключена. Такую связь можно установить и из текущей сборки, указав разрабатываемую для нее спецификацию (см. раздел 6.2.4.1.1). При этом информация о подключении модели будет передана в спецификацию.

Таким образом, после установления связи между спецификацией и сборкой информация об этой связи хранится в обоих документах, а способ их подключения друг к другу (из сборки или из спецификации) определяется исключительно выбором пользователя.

Находясь в окне спецификации, можно быстро открыть подключенную к ней сборку. И наоборот, при работе с моделью можно быстро вызвать подключенную к ней спецификацию. Благодаря однажды установленной связи спецификации и сборки система «помнит» местонахождение связанных документов и по команде открытия находит их самостоятельно.

Другое проявление двунаправленной связи — возможность передачи данных из модели в спецификацию или из спецификации в модель, причем передача ассоциативна (см. раздел 6.2.4.2).

Из модели в спецификацию могут передаваться обозначения, наименования и массы компонентов. Из спецификации в модель могут передаваться обозначения и наименования компонентов.

Например, в результате изменения размеров деталей изменилась их масса. Спецификация КОМПАС-3D автоматически (по команде пользователя) получит обновленные значения массы компонентов сборки.

Если модель сборки содержит больше одного исполнения, ее следует связывать с групповой спецификацией. Групповая спецификация получает из сборки не только данные о компонентах, но и данные об исполнениях: их общее число, номера, состав. При изменении сборки спецификация автоматически обновляется.


6.1.3.5.3. Связь документов с основной надписью спецификации

При подключении документа — сборки или сборочного чертежа — к спецификации (см. раздел 6.2.4.1.2) пользователь может указать:

– документ, из которого в основную надпись текущей спецификации будут передаваться обозначение и наименование изделия,

– документы, которые будут получать обозначение и наименование изделия из текущей спецификации.


6.1.3.6. Синхронизация данных

Благодаря подключению сборочного чертежа или модели сборки к спецификации возможна синхронизация данных в этих документах.

Синхронизация — процесс передачи данных из чертежа или сборки в подключенную спецификацию или из спецификации в подключенные к ней документы.

В этом разделе:

6.1.3.6.1. Передача объектов из чертежа или сборки в спецификацию

6.1.3.6.2. Передача объектов из спецификации в чертеж и сборку

6.1.3.6.3. Передача данных между основной надписью спецификации и подключенными документами

6.1.3.6.4. Синхронизация данных при открытии спецификации. Перестроение спецификации


6.1.3.6.1. Передача объектов из чертежа или сборки в спецификацию

Созданные в чертеже или модели объекты спецификации не видны на самом чертеже или в модели (если не считать случая размещения спецификации на чертеже). Их можно увидеть только в окне подчиненного режима и нельзя вывести на печать.

Чтобы объекты спецификации появились в отдельном документе-спецификации (который можно вывести на печать), их нужно передать из чертежа или модели в подключенную спецификацию. Сразу после подключения все объекты автоматически попадают в документ-спецификацию. Передача последующих изменений обеспечивается синхронизацией. Для ее запуска служит специальная команда, см. раздел 6.2.4.2.1.

Синхронизация также автоматически (без вызова специальной команды) производится при сохранении документа, подключенного к спецификации.

После вызова команды синхронизации происходит следующее:

– Изменения, внесенные в объекты спецификации, попадают из документа в подключенную к нему спецификацию. При этом происходит не безусловное копирование всех объектов из одного документа в другой, а только передача отличающихся данных.

• Если какого-либо объекта нет в спецификации, этот объект копируется в нее.

• Если различаются текстовая часть или дополнительные параметры какого-либо объекта в модели/чертеже и в спецификации, то текстовая часть или дополнительные параметры копируются из объекта спецификации в модели/чертеже в соответствующий объект в спецификации.

• Если какого-либо объекта, существующего в спецификации, нет в модели/чертеже, то в результате синхронизации объект не пропадает из спецификации. Благодаря этому в спецификацию можно передать объекты из нескольких подключенных документов — эти объекты не уничтожат, а дополнят друг друга. Причем спецификация будет «помнить», из какого документа «пришел» каждый ее объект.

– Изменения обозначения и/или наименования документа передаются в основную надпись спецификации.

– Если в спецификации изменены объекты, «пришедшие» из текущего документа, то эти изменения передаются в документ.

– В спецификации производится сортировка объектов, новые номера позиций передаются в подключенный документ. Это обеспечивается умолчательной настройкой стиля спецификации; при необходимости расчет позиций можно отключить (опции Связь с расчетом позиций и Рассчитывать позиции, см. раздел 6.4.2.1).

– Файл спецификации, в которую передаются изменения, сохраняется, на экране появляется сообщение о том, какая спецификация была изменена. Обратите внимание на то, что спецификация может быть не загружена в момент синхронизации (в этом случае она будет открыта, изменена, сохранена и закрыта в «слепом» режиме, без отображения на экране).

Если передача данных из модели/чертежа в спецификацию временно отключена пользователем при настройке спецификации (см. раздел 6.4.2.1), то синхронизация не производится ни по команде пользователя, ни автоматически.

Передача данных из подключенных документов в спецификацию производится также во время перестроения спецификации, см. раздел 6.1.3.6.4.


6.1.3.6.2. Передача объектов из спецификации в чертеж и сборку

Иногда требуется передать в сборочный чертеж или модель сборки изменения, сделанные в подключенной спецификации. Например, в результате сортировки объектов в спецификации эти объекты получили новые номера позиций. Чтобы соответствующие номера появились на полках линий-выносок, объекты с этими номерами требуется передать в чертеж/сборку. Для этого служит специальная команда, см. раздел 6.2.4.2.2.

Синхронизация также автоматически (без вызова специальной команды) производится при сохранении спецификации.

После вызова команды синхронизации происходит следующее:

– Изменения, внесенные в объекты спецификации, попадают из спецификации в подключенные к ней модели/чертежи. При синхронизации происходит не безусловное копирование всех объектов из одного документа в другой, а только передача отличающихся данных.

• Если различаются текстовая часть или дополнительные параметры какого-либо объекта в модели/чертеже и в спецификации, то текстовая часть или дополнительные параметры копируются из объекта спецификации в документе-спецификации в соответствующий объект в модели/чертеже.

• Если какого-либо объекта, существующего в спецификации, нет в модели/чертеже, то в результате синхронизации этот объект будет передан в модель/чертеж только при условии, что этот объект имеет в своем составе геометрию из этого документа. Объекты, не имеющие геометрии и существующие только в спецификации, никогда не передаются в модели и чертежи. Если объект, не имеющий геометрии, «пришел» в спецификацию из модели/чертежа, он будет передаваться в тот же документ.

– Изменения обозначения и/или наименования передаются из основной надписи спецификации в подключенные документы (если эта передача была включена при их подключении — опция Передавать изменения в документ, см. раздел 6.2.4.1.2).

– Если в подключенном документе изменены объекты спецификации, то эти изменения передаются в спецификацию.

– В спецификации производится сортировка объектов, и новые номера позиций передаются в подключенный документ. Это обеспечивается умолчательной настройкой стиля спецификации; при необходимости расчет позиций можно отключить (опции Связь с расчетом позиций и Рассчитывать позиции, см. раздел 6.4.2.1).

– Документы, в которые передаются изменения, сохраняются, на экране появляется сообщение о том, какие документы были изменены. Обратите внимание на то, что документы могут быть не загружены в момент синхронизации (в этом случае они будут открыты, изменены, сохранены и закрыты в «слепом» режиме, без отображения на экране).

При синхронизации изменения передаются также между спецификацией и документами, подключенными к объектам спецификации. Например, при подключении к объекту чертежа детали (см. раздел 6.2.2.6.3) была включена опция Передавать изменения в документ, впоследствии у чертежа изменился формат, а в спецификации — обозначение детали. При синхронизации новое обозначение формата попадет в спецификацию, а новое обозначение детали — соответствующую графу основной надписи чертежа детали.

При необходимости можно изменить настройку системы так, чтобы изменения спецификаций не влияли на подключенные к ним документы, см. раздел 9.1.9.2.


6.1.3.6.3. Передача данных между основной надписью спецификации и подключенными документами

6.1.3.6.3. Передача данных между основной надписью спецификации
и подключенными документами

Для передачи обозначения и наименования изделия между основной надписью спецификации и подключенными документами пользователю не требуется вызывать специальную команду. Эта передача производится автоматически при сохранении документов.

При синхронизации изменения передаются также в другие связанные документы (если это необходимо). Например, при подключении к спецификации сборочного чертежа и пояснительной записки передача данных была настроена следующим образом: спецификация получает обозначение и наименование изделия из чертежа, а пояснительная записка — из спецификации. Впоследствии обозначение изделия в чертеже было изменено. При синхронизации новое обозначение попадет из чертежа в спецификацию, а из спецификации — в пояснительную записку.

Документ, в который передаются изменения, может быть не загружен в момент синхронизации (в этом случае он будет открыт, изменен, сохранен и закрыт в «слепом» режиме, без отображения на экране).

После выполнения синхронизации система выдает сообщение о том, какие документы были изменены.


6.1.3.6.4. Синхронизация данных при открытии спецификации. Перестроение спецификации

6.1.3.6.4. Синхронизация данных при открытии спецификации.
Перестроение спецификации

При открытии документа-спецификации происходит проверка соответствия:

– объектов спецификации в самой спецификации и объектов спецификации в подключенных к ней документах,

– обозначения и наименования изделия в самой спецификации и в подключенных к ней документах.

Если в результате проверки обнаруживаются рассогласования, то на экране появляется запрос на перестроение спецификации.

– Положительный ответ запускает перестроение. При этом выполняются следующие действия:

• перестраиваются связанные со спецификацией документы, которые требуют перестроения: ассоциативные чертежи — если изменены изображенные в них модели, сборки — если изменены их компоненты первого уровня,

• из этих документов извлекаются данные для спецификации.

В зависимости от настройки (см. раздел 9.1.9.2) перестроенные документы могут сохраняться сразу по окончании перестроения или только после сохранения спецификации.

– Отрицательный ответ означает отказ от перестроения. При этом спецификация открывается в том виде, в котором была в последний раз сохранена, но отображается перечеркнутой пунктирными линиями — признак необходимости перестроения. Это не препятствует работе со спецификацией (например, вы можете редактировать объекты); пунктирные линии на печать не выводятся.

В дальнейшем перестроение можно запустить в любое время с помощью команды Вид — Перестроить.

Следует иметь в виду, что такое состояние спецификации — не перестроена, но отредактирована — временное, т.е. может быть изменено при последующем перестроении или сохранении подключенного документа.

Запрос на перестроение спецификации может возникнуть не только при открытии спецификации, но и в процессе работы с ней — если в каком-либо из подключенных к спецификации документов были произведены изменения, требующие отражения в спецификации.

Отменить перестроение спецификации нельзя, но можно закрыть ее без сохранения — она останется в первоначальном виде.


6.1.4. Интеграция с приложениями

6.1. Общие сведения о спецификации

6.1.4. Интеграция с приложениями

Некоторые приложения системы КОМПАС-3D полностью интегрированы с Модулем проектирования спецификаций.

Это проявляется в том, что при вставке изображения или модели из приложения в чертеж или сборку в этом чертеже или сборке появляется соответствующий объект спецификации.

Примером такого приложения является Справочник Стандартные Изделия (далее Справочник). При его использовании необходимо учитывать следующее.

– Объект спецификации появляется в документе автоматически при вставке объекта из Справочника, если в нем сделана специальная настройка (вариант по умолчанию). Настройку можно включать или отключать в процессе вставки объекта. Управление настройками подробно описано в справочной системе Справочника.

– Справочник по умолчанию настроен таким образом, что обозначения изделий и материалов формируются в полном соответствии со стандартами на них, а объекты спецификации, возникшие в результате работы со Справочником, размещаются в нужных разделах стандартных спецификаций.

После вставки вы можете отредактировать текст или изменить значения в полях шаблона заполнения. Вы также можете настроить сортировку по тому или иному параметру (см. раздел 6.1.2.6).

– При вставке объекта из Справочника в чертеж можно создать новую или указать существующую позиционную линию-выноску для изображения вставленного изделия (материала). Эта линия-выноска, как и изображение, вставленное из Справочника, автоматически попадет в геометрию соответствующего объекта спецификации (со всеми вытекающими отсюда последствиями — возможностью расчета зон, передачей номера позиции из спецификации на линию-выноску и т.д.).

– Если в документ вставить несколько одинаковых объектов из Справочника с одинаковыми параметрами, возникнут дублирующие друг друга объекты спецификации (объекты-«двойники»). Подробнее о них рассказано в разделе 6.2.6.15.

– Содержащаяся в Справочнике информация об объектах спецификации может передаваться в документ-спецификацию напрямую (а не только из подключаемых документов). Очевидно, что объекты спецификации, полученные таким образом, не могут иметь в своем составе геометрию. В остальном они не отличаются от аналогичных объектов, полученных из чертежей: их текст так же формируется по шаблону, они размещаются в тех же разделах спецификации и так же сортируются.

Подробно порядок вставки объектов из Справочника в спецификацию рассмотрен в разделе 6.2.2.4.3.

Передача в документы информации об объектах спецификации, а также прямая вставка объектов в спецификацию возможна из любой пользовательского приложения — при условии, что оно запрограммировано необходимым образом.

Кроме Справочника Стандартные Изделия, со спецификацией КОМПАС интегрирован Справочник Материалы и Сортаменты. Эта интеграция проявляется в возможности вставки в спецификацию обозначений материалов из данного справочника и просмотра свойств материалов (физико-механические, технологические, химический состав и др.). Порядок вставки обозначений материалов из Справочника, а также его настройка для работы со спецификацией подробно рассмотрены в справочной системе этого приложения.


6.2. Приемы работы со спецификацией

В этом разделе:

6.2.1. Интерфейс

6.2.1.1. Панель свойств

6.2.1.2. Панель Текущее состояние

6.2.1.3. Кнопки вызова команд

6.2.2. Работа с документом-спецификацией

6.2.2.1. Создание документа-спецификации

6.2.2.2. Выбор стиля спецификации

6.2.2.2.1. Текущая спецификация

6.2.2.2.2. Вновь создаваемые спецификации

6.2.2.3. Заполнение спецификации

6.2.2.3.1. Добавление нового объекта

6.2.2.3.2. Копирование объекта спецификации

6.2.2.3.3. Создание исполнений объектов спецификации

6.2.2.3.4. Удаление объекта спецификации

6.2.2.4. Ввод и редактирование текстовой части объекта спецификации

6.2.2.4.1. Ввод данных вручную

6.2.2.4.2. Вставка кодов и наименований документов

6.2.2.4.3. Вставка объектов из Справочника Стандартные Изделия

6.2.2.4.4. Редактирование текстовой части объекта спецификации

6.2.2.4.5. Использование шаблонов заполнения

6.2.2.4.6. Шаблонная текстовая часть в виде строки

6.2.2.4.7. Редактирование текстовой части, заполненной по шаблону

6.2.2.4.8. Использование предопределенных текстов

6.2.2.4.9. Полуавтоматический ввод данных в графы спецификации

6.2.2.5. Подключение и редактирование состава геометрии объекта спецификации

6.2.2.5.1. Включение геометрии в состав объекта спецификации

6.2.2.5.2. Изменение состава геометрии объекта спецификации

6.2.2.5.3. Просмотр геометрии объектов спецификации

6.2.2.6. Ввод и редактирование дополнительных параметров объекта спецификации

6.2.2.6.1. Настройки объекта спецификации

6.2.2.6.2. Дополнительные колонки

6.2.2.6.3. Подключение документа к объекту спецификации

6.2.2.7. Сортировка объектов

6.2.2.8. Простановка позиций

6.2.2.9. Режимы работы с документом-спецификацией

6.2.2.10. Отображение объектов, содержащих код и наименование документа

6.2.3. Работа с объектами спецификации в чертежах и моделях

6.2.3.1. Создание объектов спецификации в чертеже

6.2.3.1.1. Объекты спецификации из Справочника Стандартные Изделия

6.2.3.1.2. Объекты спецификации из вставленных фрагментов

6.2.3.2. Создание объектов спецификации в модели. Общие сведения

6.2.3.3. Создание объектов спецификации в детали

6.2.3.4. Создание объектов спецификации в сборке

6.2.3.4.1. Внешние объекты

6.2.3.4.2. Внутренние объекты

6.2.3.4.3. Особенности создания объектов спецификации раздела «Материалы»

6.2.3.4.4. Объекты спецификации из Справочника Стандартные Изделия

6.2.3.4.5. Объекты спецификации из библиотек моделей

6.2.3.5. Редактирование объектов спецификации в документе

6.2.3.5.1. Редактирование состава геометрии объекта спецификации

6.2.3.5.2. Просмотр геометрии объектов спецификации

6.2.3.5.3. Синхронизация объекта спецификации сборки с документом-владельцем и со свойствами компонента

6.2.3.6. Удаление объекта спецификации из документа

6.2.3.7. Автоматическое создание и удаление объектов спецификации сборки

6.2.3.7.1. Создание объектов спецификации

6.2.3.7.2. Удаление объектов спецификации

6.2.3.8. Создание спецификации по сборке

6.2.4. Связь спецификации с чертежами и моделями

6.2.4.1. Взаимное подключение документов

6.2.4.1.1. Подключение спецификации к текущей сборке или чертежу

6.2.4.1.2. Подключение сборки или чертежа к текущей спецификации

6.2.4.2. Синхронизация данных

6.2.4.2.1. Передача объектов из чертежа или сборки в спецификацию

6.2.4.2.2. Передача объектов из спецификации в чертеж или сборку

6.2.4.2.3. Передача данных между основной надписью спецификации и подключенными документами

6.2.5. Типовые процедуры создания спецификации

6.2.5.1. Спецификация, связанная со сборочным чертежом

6.2.5.2. Спецификация, связанная с моделью сборки

6.2.5.3. Полный комплект ассоциативных документов

6.2.5.4. Спецификация, не связанная с другими документами

6.2.6. Дополнительные возможности

6.2.6.1. Операции с объектами, содержащими геометрию

6.2.6.1.1. Удаление геометрии при удалении объекта спецификации

6.2.6.1.2. Удаление объекта спецификации при удалении геометрии

6.2.6.1.3. Копирование объекта спецификации при копировании геометрии

6.2.6.2. Подсчет суммы значений в колонках спецификации

6.2.6.3. Обработка числовых колонок спецификации

6.2.6.4. Создание заготовки чертежа на основе геометрии объекта спецификации

6.2.6.5. Разбиение спецификации на листы

6.2.6.6. Создание резервных строк в середине раздела спецификации

6.2.6.7. Включение и отключение показа объекта в таблице спецификации

6.2.6.8. Сохранение спецификации в других форматах

6.2.6.8.1. Экспорт во фрагмент

6.2.6.8.2. Экспорт в форматы DXF, DWG и IGES

6.2.6.8.3. Экспорт в форматы баз данных

6.2.6.9. Дополнительные листы

6.2.6.10. Нумерация листов

6.2.6.11. Настройка отображения значений массы

6.2.6.12. Спецификация на чертеже

6.2.6.12.1. Размещение на чертеже спецификации текущего стиля

6.2.6.12.2. Размещение на чертеже спецификаций разных стилей

6.2.6.12.3. Название спецификации на чертеже

6.2.6.13. Таблица изменений

6.2.6.14. Объекты разных спецификаций в одном чертеже

6.2.6.15. Объекты-«двойники»

6.2.6.16. Использование марок/позиционных обозначений

6.2.6.17. Обозначения позиций в модели сборки

6.2.6.18. Объединение вариантов описаний спецификаций в документе

6.2.7. Частные приемы формирования спецификаций

6.2.7.1. Групповые спецификации

6.2.7.1.1. Групповая спецификация по варианту Б

6.2.7.1.2. Групповая спецификация по варианту А

6.2.7.1.3. Редактирование номеров исполнений

6.2.7.2. Спецификации с вложенными и дополнительными разделами

6.2.8. Хранение в документах информации об используемом стиле спецификации

6.2.8.1. Перечитывание стиля


6.2.1. Интерфейс

6.2. Приемы работы со спецификацией

6.2.1. Интерфейс

Модуль проектирования спецификаций функционирует в среде КОМПАС-3D. Поэтому элементы его интерфейса (меню, панели и т.д.) и приемы работы с ними — такие же, как в КОМПАС-3D.

В этом разделе:

6.2.1.1. Панель свойств

6.2.1.2. Панель Текущее состояние

6.2.1.3. Кнопки вызова команд


6.2.1.1. Панель свойств

Если в таблице спецификации выделен какой-либо объект, его параметры отображаются на Панели свойств (рис. 6.2.1).

Каждому параметру соответствует поле или переключатель (подробнее см. раздел 6.2.2.6). Изменяя состояние переключателей и значения в полях, можно отредактировать параметры объекта спецификации.

Рис. 6.2.1. Панель свойств объекта спецификации


6.2.1.2. Панель Текущее состояние

В режиме работы в таблице спецификации на панели Текущее состояние (рис. 6.2.2) появляются поля и переключатели, позволяющие управлять параметрами текущего раздела спецификации (см. табл. 6.2.1).

Рис. 6.2.2. Панель Текущее состояние

Табл. 6.2.1. Элементы управления, расположенные на панели Текущее состояние при работе со спецификацией
Элемент управления | Описание
Текущая страница | В этом поле показан номер текущей страницы спецификации. Чтобы перейти на нужную страницу, введите в поле ее номер.
Проставлять позиции | Этот переключатель позволяет разрешить или запретить простановку номеров позиций в текущем разделе (подробнее см. раздел 6.2.2.8).
Подключать геометрию | Этот переключатель позволяет разрешить или запретить подключение геометрии к объектам спецификации в текущем разделе (подробнее см. раздел 6.2.2.5).
Автоматическая сортировка | Этот переключатель позволяет разрешить или запретить автоматическую сортировку объектов спецификации в текущем разделе (подробнее см. раздел 6.2.2.7).
Количество резервных строк | В этом поле показано количество резервных строк в текущем разделе (см. раздел 6.1.2.4). Вы можете изменить это количество.


6.2.1.3. Кнопки вызова команд

Кнопки вызова команд Модуля проектирования спецификаций расположены на инструментальной панели Спецификация (рис. 6.2.3). Если она входит в состав Компактной панели, используйте кнопку-переключатель Спецификация для ее активизации.

Рис. 6.2.3. Инструментальная панель Спецификация

В следующих разделах этой книги кнопки изображены на полях абзацев, в которых упоминаются соответствующие команды. Название инструментальной панели Спецификация при этом не указывается.

Если кнопка находится на другой панели, название этой панели оговаривается особо.


6.2.2. Работа с документом-спецификацией

6.2. Приемы работы со спецификацией

6.2.2. Работа с документом-спецификацией

В этом разделе:

6.2.2.1. Создание документа-спецификации

6.2.2.2. Выбор стиля спецификации

6.2.2.2.1. Текущая спецификация

6.2.2.2.2. Вновь создаваемые спецификации

6.2.2.3. Заполнение спецификации

6.2.2.3.1. Добавление нового объекта

6.2.2.3.2. Копирование объекта спецификации

6.2.2.3.3. Создание исполнений объектов спецификации

6.2.2.3.4. Удаление объекта спецификации

6.2.2.4. Ввод и редактирование текстовой части объекта спецификации

6.2.2.4.1. Ввод данных вручную

6.2.2.4.2. Вставка кодов и наименований документов

6.2.2.4.3. Вставка объектов из Справочника Стандартные Изделия

6.2.2.4.4. Редактирование текстовой части объекта спецификации

6.2.2.4.5. Использование шаблонов заполнения

6.2.2.4.6. Шаблонная текстовая часть в виде строки

6.2.2.4.7. Редактирование текстовой части, заполненной по шаблону

6.2.2.4.8. Использование предопределенных текстов

6.2.2.4.9. Полуавтоматический ввод данных в графы спецификации

6.2.2.5. Подключение и редактирование состава геометрии объекта спецификации

6.2.2.5.1. Включение геометрии в состав объекта спецификации

6.2.2.5.2. Изменение состава геометрии объекта спецификации

6.2.2.5.3. Просмотр геометрии объектов спецификации

6.2.2.6. Ввод и редактирование дополнительных параметров объекта спецификации

6.2.2.6.1. Настройки объекта спецификации

6.2.2.6.2. Дополнительные колонки

6.2.2.6.3. Подключение документа к объекту спецификации

6.2.2.7. Сортировка объектов

6.2.2.8. Простановка позиций

6.2.2.9. Режимы работы с документом-спецификацией

6.2.2.10. Отображение объектов, содержащих код и наименование документа


6.2.2.1. Создание документа-спецификации

Чтобы создать спецификацию, вызовите команду Файл — Создать. В появившемся диалоге создания нового документа выберите тип нового документа — Спецификация.

На экране появится таблица новой спецификации. В ней можно создавать объекты спецификации (см. раздел 6.2.2.3).

Эта таблица и правила ее заполнения (колонки, разделы, наличие автоматической сортировки, количество резервных строк и т.д.) будут соответствовать стилю, который установлен по умолчанию для новой спецификации.

Стиль спецификации можно изменить.

Вы можете создать новую спецификацию на основе шаблона. Для этого активизируйте вкладку Шаблоны диалога создания нового документа и укажите нужный шаблон.

Шаблоны спецификаций, поставляемые с КОМПАС-3D, содержат стиль спецификации. Вы можете отредактировать имеющиеся шаблоны (например, заполнив в них основные надписи) или создать новые.


6.2.2.2. Выбор стиля спецификации

Стиль спецификации — совокупность параметров и настроек, присущих спецификации и влияющих на ее заполнение и отображение. Подробнее о нем рассказано в разделе 6.4.1.

Стили спецификаций, поставляемые в составе дистрибутива КОМПАС-3D, хранятся в файлах Graphic.lyt и Vector.lyt, расположенных в папке ...\Sys.

В этом разделе:

6.2.2.2.1. Текущая спецификация

6.2.2.2.2. Вновь создаваемые спецификации


6.2.2.2.1. Текущая спецификация

Чтобы изменить стиль текущей спецификации, выполните следующие действия.

1. Вызовите команду Сервис — Параметры....

Появившийся на экране диалог будет по умолчанию раскрыт на разделе Текущая спецификация — Стиль.

2. Нажмите кнопку Показать библиотеку выберите файл *.lyt, в котором находится нужный стиль. Если в справочном поле диалога уже указана требуемая библиотека, ее можно не выбирать заново.

3. Выберите из списка стиль, который должна иметь текущая спецификация.

Обычно изменяют стиль только что созданной спецификации, которая еще не содержит объектов.

Сменить стиль текущей спецификации можно также в Менеджере документа.


6.2.2.2.2. Вновь создаваемые спецификации

Чтобы установить стиль, с которым по умолчанию должны создаваться новые спецификации, выполните следующие действия.

1. Вызовите команду Сервис — Параметры.

2. В появившемся диалоге разверните раздел Новые документы — Спецификация — Умолчательные настройки — Стиль.

3. Укажите библиотеку стилей (файл *.lyt) и выберите стиль, который должны иметь вновь создаваемые спецификации.


6.2.2.3. Заполнение спецификации

Спецификация заполняется путем создания в ней новых объектов (как базовых, так и вспомогательных).

Объекты спецификации можно также создать в подключенных к ней трехмерных сборках или сборочных чертежах, а затем передать их в отдельный документ-спецификацию.

Кроме того, возможна вставка объектов из Справочника Стандартные Изделия (см. раздел 6.2.2.4.3) или Справочника Материалы и Сортаменты.

В этом разделе:

6.2.2.3.1. Добавление нового объекта

6.2.2.3.2. Копирование объекта спецификации

6.2.2.3.3. Создание исполнений объектов спецификации

6.2.2.3.4. Удаление объекта спецификации


6.2.2.3.1. Добавление нового объекта

Чтобы создать базовый объект в текущей спецификации, вызовите команду Вставка — Базовый объект или нажмите клавишу <Insert>.

Чтобы создать вспомогательный объект, вызовите команду Вставка — Вспомогательный объект.

Если создаваемый объект — первый в спецификации...

На экране появится диалог выбора раздела (и подраздела) для размещения этого объекта (рис. 6.2.4).

Рис. 6.2.4. Диалог выбора раздела спецификации

Выберите в нем нужный раздел.

Заголовок выбранного раздела появится в бланке спецификации. Заголовок будет подчеркнут и в соответствии со стандартом обрамлен сверху и снизу пустыми строками.

Если требуется создать объект в текущем разделе...

Для создания объекта в уже существующем разделе перед вызовом команды Вставка — Базовый объект установите курсор в любом месте этого раздела.

Если требуется создать объект в новом разделе...

Для создания объекта в новом разделе требуется вначале создать этот раздел при помощи команды Вставка — Раздел.

Так как спецификация не может содержать пустой раздел (раздел без объектов), сразу после создания нового раздела в нем возникнет первый объект.

Вне зависимости от способа создания объекта спецификации после вызова команды в таблице спецификации станет доступной строка для ввода его текстовой части (см. раздел 6.2.2.4).

При создании нового объекта в некоторых разделах (например, Стандартные изделия, Материалы) необходимо указать способ формирования его текстовой части: использование шаблона заполнения (см. раздел 6.2.2.4.5) или ввод текстовой части с клавиатуры (см. раздел 6.2.2.4.6).

После ввода текстовой части (а при необходимости — и дополнительных параметров объекта, см. раздел 6.2.2.6) подтвердите его создание. Для этого нажмите комбинацию клавиш <Ctrl>+<Enter> или щелкните мышью вне строки, содержащей объект.


6.2.2.3.2. Копирование объекта спецификации

Объект спецификации можно также создать путем копирования существующего объекта и последующего редактирования копии.

Чтобы скопировать объект, выделите его (не входя в режим редактирования его текстовой части) и вызовите команду Редактор — Копировать объект.

Система создаст новый объект с текстовой частью, повторяющей текстовую часть выделенного объекта, и перейдет в режим редактирования этой текстовой части (см. раздел 6.2.2.4). После изменения данных в колонках нового объекта следует подтвердить его создание.

Объект, созданный путем копирования другого объекта, по своим свойствам и параметрам ничем не отличается от объектов, созданных при помощи команды Вставка — Объект.

Обычно путем копирования создают объект, текстовая часть которого незначительно отличается от текстовой части существующего объекта.

Скопированный объект размещается в том же разделе спецификации, что и его прототип. Размещение копии объекта в другом разделе невозможно.

При копировании следует учитывать, что данные из дополнительных колонок выбранного объекта (см. раздел 6.2.2.6.2) передаются в дополнительные колонки копии.


6.2.2.3.3. Создание исполнений объектов спецификации

Еще один способ ввода объектов спецификации — создание исполнений текущего объекта. Для создания объекта-исполнения выполните следующие действия.

1. Выделите базовый объект спецификации и вызовите команду Вставка — Исполнение.

2. В появившемся на экране диалоге введите номера исполнений объекта (рис. 6.2.5).

Номера должны разделяться запятыми и дефисами. Нумерация исполнений может быть не сплошной.

Рис. 6.2.5. Диалог ввода номеров исполнений

В результате в спецификации возникнут новые объекты, отличающиеся от своего прототипа только суффиксами в обозначении (будем называть их объектами-исполнениями).

Например, если ввести номера исполнений «2–5,8,12», то в спецификации появится 6 новых объектов, а их обозначение будет отличаться от обозначения объекта, для которого создаются исполнения, суффиксами –02, –03, –04, –05, –08 и –12.

Отображение обозначений и позиций исполнений зависит от настройки текущей спецификации. Для просмотра и/или изменения этой настройки вызовите команду Формат — Настройка спецификации и в появившемся диалоге настройки спецификации активизируйте вкладку Блоки исполнений (рис. 6.2.6).

Рис. 6.2.6. Настройка создания исполнений объектов

Отображением обозначений и позиций исполнений управляет группа элементов Формировать обозначения исполнений объектов.

– Если включен вариант Показывать полностью, то обозначения новых объектов состоят из обозначения исходного объекта с добавлением суффикса — номера исполнения (рис. 6.2.7).

Рис. 6.2.7. Объекты-исполнения. Обозначение показано полностью

– Если включен вариант Показывать только номер, то обозначения новых объектов так же состоят из обозначения исходного объекта с добавлением номера исполнения, однако постоянная часть обозначения в таблице спецификации не отображается — в ней виден только номер исполнения (рис. 6.2.8).

Рис. 6.2.8. Объекты-исполнения. В обозначении показан только номер исполнения

Автоматическая сортировка объектов происходит с учетом полного обозначения. Благодаря этому объекты-исполнения располагаются по порядку номеров за своим исходным объектом даже в том случае, если в колонке Обозначение показываются только их номера.

Объекты-исполнения создаются только в тех разделах спецификации, которые сортируются по обозначению.

– Если опция Позиции возрастают отключена, то в настройках объектов спецификации, созданных путем добавления исполнений, автоматически отключаются опции Позиция объекта возрастает и Показывать позицию. Опция Объект является исполнением в настройках объектов-исполнений всегда автоматически включается. О настройках объектов спецификации см. раздел 6.2.2.6.1.


6.2.2.3.4. Удаление объекта спецификации

Для удаления объекта спецификации установите выделение на этом объекте (при помощи одного щелчка мышью или клавишами со стрелками). Затем вызовите команду Редактор — Удалить объект. На экране появится запрос на подтверждение удаления объекта (рис. 6.2.9). В нем будет указано обозначение и наименование объекта.

Рис. 6.2.9. Запрос на удаление объекта

Нажмите кнопку Да, если вы уверены в необходимости удаления объекта, или кнопку Нет, если объект удалять не нужно.

Отменить удаление объекта спецификации невозможно.

Если при настройке текущей спецификации включена опция Удалять геометрию при удалении объекта спецификации (см. раздел 6.2.6.1.1), будьте особенно внимательны при удалении объекта спецификации, т.к. оно повлечет за собой удаление из сборочного чертежа и модели сборки всех объектов, входящих в состав удаляемого объекта спецификации.


6.2.2.4. Ввод и редактирование текстовой части объекта спецификации

Текстовая часть объекта спецификации может быть заполнена различными способами.

В этом разделе:

6.2.2.4.1. Ввод данных вручную

6.2.2.4.2. Вставка кодов и наименований документов

6.2.2.4.3. Вставка объектов из Справочника Стандартные Изделия

6.2.2.4.4. Редактирование текстовой части объекта спецификации

6.2.2.4.5. Использование шаблонов заполнения

6.2.2.4.6. Шаблонная текстовая часть в виде строки

6.2.2.4.7. Редактирование текстовой части, заполненной по шаблону

6.2.2.4.8. Использование предопределенных текстов

6.2.2.4.9. Полуавтоматический ввод данных в графы спецификации


6.2.2.4.1. Ввод данных вручную

6.2. Приемы работы со спецификацией > 6.2.2. Работа с документом-спецификацией > 6.2.2.4. Ввод и редактирование текстовой части объекта спецификации

6.2.2.4.1. Ввод данных вручную

Режим ввода и редактирования текстовой части действует после вызова команды вставки нового объекта спецификации (см. раздел 6.2.2.3.1) до тех пор, пока не подтверждено создание объекта.

Режим ввода и редактирования текстовой части практически не отличается от текстового режима КОМПАС-3D. В этом режиме в таблице спецификации открывается для редактирования строка, в которой будет расположена текстовая часть объекта спецификации. Становятся доступными команды форматирования шрифта и абзаца, а также команды вставки дроби, индекса, над- и подстроки, спецзнака, символа и предопределенного текста.

Символы, введенные в колонку, автоматически сужаются так, чтобы все они уместились в одной ячейке. Если сужение слишком большое, вы можете перенести часть символов на следующую строку. Для этого установите курсор в место переноса и нажмите клавишу <Enter>. Таким образом, текстовая часть объекта спецификации может занимать несколько строк в бланке спецификации.

Перемещение текстового курсора внутри колонки производится при помощи клавиш <→> и <←>. Клавиша <↑> перемещает текстовый курсор в позицию перед первым символом в колонке, а клавиша <↓> — в позицию после последнего символа.

Перемещение между колонками производится при помощи клавиши <Tab> (в направлении слева направо) или комбинации клавиш <Shift>+<Tab> (в направлении справа налево). В нужную колонку объекта спецификации можно также попасть, щелкнув по ней мышью.

Для подтверждения изменения текстовой части объекта спецификации и выхода из режима ее редактирования нужно нажать комбинацию клавиш <Ctrl>+<Enter> или щелкнуть мышью в любом месте окна вне строк, в которых размещена отредактированная текстовая часть.

Редактирование составных обозначений (т.е. обозначений, содержащих кроме базовой части номер исполнения, и/или дополнительный номер, и/или код документа) производится специальном диалоге. Этот диалог автоматически появляется на экране при попытке ввода/редактирования обозначения в разделе Документация (т.к. обозначения в этом разделе обычно включают код документа), а также при попытке редактирования обозначения объекта-исполнения. Работа в нем и результат ввода обозначения — такие же, как при заполнении основной надписи, см. раздел 3.6.3.1.1.


6.2.2.4.2. Вставка кодов и наименований документов

6.2. Приемы работы со спецификацией > 6.2.2. Работа с документом-спецификацией > 6.2.2.4. Ввод и редактирование текстовой части объекта спецификации

6.2.2.4.2. Вставка кодов и наименований документов

При создании объектов в разделе Документация часто требуется задавать коды и наименования документов, например, код «СБ» и наименование «Сборочный чертеж».

Для вставки кодов и наименований служит специальный диалог. Он вызывается командой Вставить код и наименование... в контекстном меню колонок Обозначение и Наименование создаваемого объекта. После вызова команды на экране появится диалог выбора кода и наименования документа. Работа в этом диалоге и результат вставки кода и наименования — такие же как при заполнении основной надписи, см. раздел 3.6.3.1.5.

При создании объектов в разделе Документация может потребоваться добавить дополнительный код в обозначение документа — «ЛУ» (Лист утверждения) или «УЛ» (Информационно-удостоверяющий лист). Автоматическая вставка двойного кода в системе КОМПАС-3D не предусмотрена. Если в обозначении документа должны быть два кода, например, СБ-ЛУ, то разделитель1 и второй код — ЛУ или УЛ — необходимо ввести вручную в поле Код диалога Обозначение. В графу Наименование автоматически добавляется соответствующий коду текст.

Команда Вставить код и наименование... доступна для раздела спецификации, если:

– при настройке этой спецификации (см. раздел 6.4.2.2.1) в данном разделе включен показ кода документа,

– при настройке стиля спецификации в данном разделе создана колонка типа Обозначение с типом данных Строка, связанная с ячейкой штампа Обозначение документа — в эту колонку вставляется код, а наименование добавляется к тексту в колонке типа Наименование.

Стили спецификаций, поставляемые в составе дистрибутива КОМПАС-3D, настроены так, что вставка кода и наименования возможна во все разделы, кроме Стандартные изделия, Прочие изделия и Материалы, а показ кода документа включен лишь в разделе Документация. Таким образом, команда Вставить код и наименование... фактически доступна только в разделе Документация.

  1. Разделителем между кодами может быть, например, пробел или дефис. Допускается также отсутствие разделителя.


6.2.2.4.3. Вставка объектов из Справочника Стандартные Изделия

6.2. Приемы работы со спецификацией > 6.2.2. Работа с документом-спецификацией > 6.2.2.4. Ввод и редактирование текстовой части объекта спецификации

6.2.2.4.3. Вставка объектов из Справочника Стандартные Изделия

Чтобы вставить в спецификацию объект из Справочника Стандартные Изделия (далее Справочника), выполните следующие действия.

1. Вызовите в спецификации команду Библиотеки — Стандартные изделия — Вставить элемент. Опция создания объекта спецификации в настройках Справочника должна быть включена (вариант по умолчанию).

Выберите в Справочнике нужный объект (болт, винт, гайку, подшипник, узел, соединение и т.п.). Подробно выбор объектов описан в документации Справочника.

Объект спецификации расположится в спецификации в определенном Справочником разделе. Например, крепежное изделие добавится в раздел Стандартные изделия. Если такого раздела еще нет, то при вставке объекта он создастся автоматически.

Текстовая часть объекта сформируется по шаблону заполнения с учетом выбранных параметров объекта из Справочника. В дальнейшем текстовую часть можно будет отредактировать (см. раздел 6.2.2.4.7).

2. После вставки первого объекта на экране остается окно Справочника для вставки следующего. Вставьте следующий объект, если требуется.

Вы можете вставить несколько одинаковых объектов. В этом случае будет создан объект-«двойник», см. раздел 6.2.6.15.

Чтобы прекратить вставку, закройте окно Справочника.

Если наличие отдельного объекта спецификации для каждого вставленного из Справочника объекта не требуется, можно обойтись и без объектов-«двойников». Для этого вставьте из Справочника только один объект, а затем введите нужное значение в колонке Количество.

Вы можете вставить объекты в спецификацию из другого приложения, в том числе пользовательского, при условии, что оно запрограммированы необходимым образом. Вставка производится способом, предусмотренным каждым приложением.


6.2.2.4.4. Редактирование текстовой части объекта спецификации

6.2. Приемы работы со спецификацией > 6.2.2. Работа с документом-спецификацией > 6.2.2.4. Ввод и редактирование текстовой части объекта спецификации

6.2.2.4.4. Редактирование текстовой части объекта спецификации

Для входа в режим редактирования текстовой части существующего объекта спецификации нужно дважды щелкнуть мышью по строкам, в которых размещается этот объект, либо установить выделение на объекте и вызвать команду Редактор — Редактировать объект или нажать клавишу <Enter>.

Выход из режима редактирования текста производится точно так же, как выход из режима ввода объекта — щелчком мышью в любом месте спецификации вне редактируемого объекта или при помощи комбинации клавиш <Ctrl>+<Enter>.


6.2.2.4.5. Использование шаблонов заполнения

6.2. Приемы работы со спецификацией > 6.2.2. Работа с документом-спецификацией > 6.2.2.4. Ввод и редактирование текстовой части объекта спецификации

6.2.2.4.5. Использование шаблонов заполнения

Текстовая часть некоторых объектов может формироваться по шаблонам заполнения. Обычно по шаблону заполняют обозначения и наименования стандартных изделий и материалов. В общем случае шаблоны служат для автоматизации ввода и сортировки текстов, формируемых по стандартным правилам.

Шаблон заполнения представляет собой «заготовку» с полями для ввода значений свойств объектов. Из данных в полях шаблона автоматически формируется текст в какой-либо колонке объекта спецификации. В шаблоне также хранится информация о том, по каким полям и в каком порядке сортировать объекты данного вида.

Поставляемые в составе системы стили спецификаций настроены таким образом, что объекты в их разделах Стандартные изделия и Материалы создаются по соответствующим шаблонам заполнения. Рассмотрим заполнение текстовой части по шаблону на примере объекта — стандартного изделия.

1. При создании объекта укажите раздел для его размещения — Стандартные изделия (рис. 6.2.10).

Рис. 6.2.10. Выбор раздела Стандартные изделия

2. В том же диалоге нажмите кнопку Выбрать шаблон.

На экране появится диалог выбора шаблона заполнения текстовой части (рис. 6.2.11).

3. Выберите в нем нужный шаблон.

Для выбора доступны шаблоны только тех объектов, которые могут быть созданы в данном разделе. Например, в разделе Стандартные изделия нельзя указать шаблон какого-либо материала, но можно выбрать шаблон заполнения наименования крепежного изделия.

Рис. 6.2.11. Выбор шаблона заполнения текстовой части

После подтверждения выбора шаблона будет создан базовый объект спецификации. В его колонку Наименование будет автоматически передано наименование объекта, сформированное по шаблону (в соответствии со стандартом для выбранного вида изделия). Значения параметров объекта (например, диаметр и длина болта) используются умолчательные.

4. Введите вручную нужные данные в оставшиеся колонки объекта (например, количество болтов) и при необходимости отредактируйте сформированное по шаблону наименование (например, измените номинальные размеры изделия). Подробнее о редактировании текстовой части, заполненной по шаблону, рассказано в разделе 6.2.2.4.7.

5. Для подтверждения создания объекта нажмите комбинацию клавиш <Ctrl>+<Enter>.

Если объект спецификации создается путем вставки в графический документ объекта из Справочника Стандартные Изделия или Справочника Материалы и Сортаменты, то выбирать шаблон не требуется. Текстовая часть объекта спецификации автоматически заполняется по предусмотренному для объекта шаблону (см. раздел 6.1.4).

Текстовая часть объектов может заполняться по шаблону не только в разделах Стандартные изделия и Материалы стандартных спецификаций, но и в других разделах спецификаций любых (в том числе пользовательских) стилей. При этом могут использоваться не только поставляемые в составе КОМПАС-3D шаблоны заполнения наименований изделий и материалов, но и созданные пользователем шаблоны любого типа (например, шаблон шифров изделий или шаблон кодов предприятий). О создании пользовательских шаблонов и стилей спецификации рассказано в 6.4 части, а упражнения для практического освоения формирования шаблонов и настройки стиля спецификации приведены в 6.5 части.


6.2.2.4.6. Шаблонная текстовая часть в виде строки

6.2. Приемы работы со спецификацией > 6.2.2. Работа с документом-спецификацией > 6.2.2.4. Ввод и редактирование текстовой части объекта спецификации

6.2.2.4.6. Шаблонная текстовая часть в виде строки

При создании объекта в разделах Стандартные изделия и Материалы требуется назначить шаблон заполнения текстовой части (см. раздел 6.2.2.4.5).

Иногда в раздел спецификации, текстовые части объектов которого формируются с использованием шаблона, необходимо внести объект, для которого не существует готового шаблона.

Если такие объекты приходится вводить часто, то целесообразно создать для них специальный шаблон и сохранить его в библиотеке Spc.lat (см. раздел 6.4.5).

Если же такие объекты вводятся редко, можно обойтись и без специального шаблона. В этом случае при создании объекта в диалоге выбора раздела и типа объекта (рис. 6.2.10) включите опцию Текстовая часть в виде строки.

Введите текстовую часть объекта спецификации и подтвердите его создание. Введенная текстовая часть автоматически разбивается на поля и сортируется по этим полям. Порядок сортировки можно изменить, отредактировав вручную ключи этих полей (см. раздел 6.4.5.1).


6.2.2.4.7. Редактирование текстовой части, заполненной по шаблону

6.2. Приемы работы со спецификацией > 6.2.2. Работа с документом-спецификацией > 6.2.2.4. Ввод и редактирование текстовой части объекта спецификации

6.2.2.4.7. Редактирование текстовой части, заполненной по шаблону

Если текст в какой-либо колонке объекта спецификации сформирован по шаблону заполнения, то двойной щелчок мышью по этой колонке в режиме редактирования текстовой части вызывает диалог, в котором можно изменить значения и тексты в полях шаблона (рис. 6.2.12).

Рис. 6.2.12. Диалог редактирования значений в полях шаблона

После подтверждения изменения данных в шаблоне текст в колонке формируется вновь с учетом новых значений в полях.

Текстовую часть объекта спецификации всегда можно отредактировать, не изменяя значений в полях его шаблона. Для этого нужно вводить и удалять данные в режиме редактирования текстовой части, не вызывая диалог редактирования значений в полях шаблона.

В любом случае при сортировке объектов, имеющих шаблон заполнения, учитываются данные в полях шаблона, а не видимая в таблице спецификации текстовая часть.


6.2.2.4.8. Использование предопределенных текстов

6.2. Приемы работы со спецификацией > 6.2.2. Работа с документом-спецификацией > 6.2.2.4. Ввод и редактирование текстовой части объекта спецификации

6.2.2.4.8. Использование предопределенных текстов

При вводе текстовой части объекта спецификации возможно использование текстовых шаблонов. Работа с ними в спецификации практически не отличается от работы с текстовыми шаблонами в текстовых и графических документах.

Следует различать текстовые шаблоны и шаблоны заполнения.

Предопределенные тексты для вставки в спецификацию могут храниться в отдельном файле шаблонов *.tdp (а не обязательно в том же файле текстовых шаблонов, который используется графическими и текстовыми документами). Имя файла текстовых шаблонов, из которого они вставляются в текущую спецификацию, можно указать в диалоге настройки спецификации (см. раздел 6.4.2.1). По умолчанию используется файл предопределенных текстов, указанный в стиле текущей спецификации.

Для вставки предопределенного текста в колонку объекта спецификации в режиме редактирования текстовой части дважды щелкните мышью по этой колонке или, установив в нее курсор, вызовите из контекстного меню команду Вставить текст.

В появившемся окне Библиотекаря текстовых шаблонов выберите нужный текст и дважды щелкните по нему мышью.

Если при настройке системы в разделе Текстовый редактор — Текстовые шаблоны включена опция Сохранять введенный текст в файле, то введенные вручную в колонки объектов тексты автоматически сохраняются в файле текстовых шаблонов. В разделе Спецификация этого файла формируется структура, учитывающая разделы и колонки спецификации (рис. 6.2.13).

Рис. 6.2.13. Текстовые шаблоны


6.2.2.4.9. Полуавтоматический ввод данных в графы спецификации

6.2. Приемы работы со спецификацией > 6.2.2. Работа с документом-спецификацией > 6.2.2.4. Ввод и редактирование текстовой части объекта спецификации

6.2.2.4.9. Полуавтоматический ввод данных в графы спецификации

Если к объекту спецификации подключен документ КОМПАС-3D (см. раздел 6.2.2.6.3), данные из этого документа будут передаваться в текстовую часть объекта спецификации. При этом отпадает необходимость в ручном вводе данных в некоторые колонки объекта и тем самым уменьшается вероятность опечаток. Например, данные из основной надписи чертежа, подключенного к объекту, могут быть автоматически переданы в колонки спецификации Формат, Обозначение и Наименование и дополнительную колонку Масса.

После редактирования и сохранения этих данных в подключенном документе они вновь будут переданы в объект спецификации. Таким образом, благодаря связи между объектом спецификации и документом происходит ввод текстовой части объекта и автоматически поддерживается соответствие между информацией в основной надписи подключенного документа (например, чертежа детали) и текстовой частью объекта спецификации.

Передача данных из подключенного документа в объект спецификации производится, если выполняются следующие условия:

– при настройке стиля раздела спецификации разрешено заполнение колонок путем чтения данных из основной надписи,

– для подключенного документа включена опция Передавать изменения в документ.

Если объект спецификации содержит позиционную линию-выноску (см. раздел 6.2.2.5), в колонку Зона будет автоматически передаваться обозначение зоны, в которой находится номер позиции (при условии, что расчет зон включен при настройке стиля спецификации).

Если в результате редактирования сборочного чертежа изменилось положение позиционных линий-выносок, входящих в состав геометрии объектов спецификации, то в момент расчета позиций в колонку Зона будут переданы новые обозначения зон, в которых теперь находится геометрия объектов спецификации.

В некоторые колонки (например, Количество и Примечание) данные в любом случае придется вводить вручную — сформировать их автоматически система не может.

Рекомендуется как можно шире использовать полуавтоматический ввод данных в текстовую часть объектов спецификации. Это позволит избежать множества ошибок при формировании спецификации.


6.2.2.5. Подключение и редактирование состава геометрии объекта спецификации

6.2.2.5. Подключение и редактирование
состава геометрии объекта спецификации

Включение в состав объекта спецификации позиционной линии-выноски является необходимым условием для передачи информации об объектах спецификации между чертежом (или сборкой) и спецификацией.

Включение в состав объекта спецификации соответствующих ему объектов чертежа или модели позволяет быстро отыскать изображение этого объекта спецификации (например, детали или сборочной единицы) в сборочном чертеже или в модели сборки.

Поэтому рекомендуется обязательно включать в состав объекта спецификации позиционную линию-выноску и по возможности — его изображение или модель.

Линия-выноска может быть единственным графическим объектом в составе геометрии объекта спецификации.

Геометрию можно включать в состав только базовых объектов спецификации.

Сразу после включения позиционной линии-выноски в состав объекта спецификации номер позиции на полке линии-выноски заменяется номером позиции объекта спецификации.

Позиционная линия-выноска может быть включена в состав нескольких объектов спецификации. В этом случае к ней автоматически добавляются полки для размещения номеров позиции, полученных из объектов. Номера размещаются на полках по возрастанию. Объекты-«двойники» (см. раздел 6.2.6.15) имеют один номер позиции, поэтому при подключении линии-выноски к таким объектам дополнительные полки не формируются.

Возможна и обратная ситуация — включение нескольких позиционных линий-выносок в состав геометрии одного объекта спецификации. В этом случае номер позиции объекта спецификации будет передаваться на полки всех подключенных линий-выносок (т.е. они будут иметь одинаковые номера позиций).

Если линия-выноска входит в состав геометрии объекта спецификации, то добавление к ней полок с произвольными номерами позиции становится невозможно. Можно создавать лишь полки с текстом или вводить текст на имеющихся полках.

Вы можете включить выделение цветом текста тех линий-выносок в документе, которые включены в состав геометрии объекта спецификации (см. раздел 9.1.3.5).

В этом разделе:

6.2.2.5.1. Включение геометрии в состав объекта спецификации

6.2.2.5.2. Изменение состава геометрии объекта спецификации

6.2.2.5.3. Просмотр геометрии объектов спецификации


6.2.2.5.1. Включение геометрии в состав объекта спецификации

6.2. Приемы работы со спецификацией > 6.2.2. Работа с документом-спецификацией > 6.2.2.5. Подключение и редактирование состава геометрии объекта спецификации

6.2.2.5.1. Включение геометрии в состав объекта спецификации

Геометрия с чертежа

Самый быстрый и удобный способ включения геометрии в состав объекта спецификации — создание в чертеже объекта спецификации, содержащего геометрию, и передача этого объекта в связанную с чертежом спецификацию. Создание объекта спецификации, содержащего геометрию, описано в разделе 6.2.3.1. Передача объектов спецификации из чертежа в связанную с ним спецификацию производится автоматически — во время подключения одного документа к другому (см. раздел 6.2.4.1), а также при сохранении подключенного к спецификации чертежа или вручную — с помощью команды синхронизации (см. раздел 6.2.4.2.1).

Если объект спецификации создан без геометрии, ее можно ввести в состав объекта следующим образом.

1. Выделите в чертеже графические объекты, которые должны войти в состав объекта спецификации (не забудьте о позиционной линии-выноске!).

2. В подключенной к чертежу спецификации установите выделение на объекте, в состав которого нужно ввести выделенную геометрию.

3. Вызовите команду Редактор — Редактировать состав объекта.

4. В появившемся на экране запросе подтвердите добавление графических объектов в состав объекта спецификации (рис. 6.2.14).

После этого в составе объекта появится указанная геометрия.

Рис. 6.2.14. Подтверждение изменения состава геометрии объекта спецификации

Геометрия из модели

Один объект спецификации может включать геометрию одного компонента либо одного или нескольких тел.

Геометрия компонента включается в объект спецификации при создании этого объекта (см. разделы 6.2.3.3 и 6.2.3.4).

Тела, построенные в сборке, могут включаться в состав геометрии объекта спецификации как при его создании (см. раздел 6.2.3.4.2, описание способа № 4), так и после. Добавление тела в состав геометрии объекта спецификации аналогично добавлению графического объекта в состав геометрии объекта спецификации (см. выше). Однако, в отличие от графических объектов, одно и то же тело может входить в состав лишь одного объекта спецификации. Другими словами, в состав объекта спецификации можно включить только то тело, которое не входит в состав другого объекта.

Позиционные линии-выноски, имеющиеся в модели, включаются в состав объектов спецификации так же, как и позиционные линии-выноски чертежа.


6.2.2.5.2. Изменение состава геометрии объекта спецификации

6.2. Приемы работы со спецификацией > 6.2.2. Работа с документом-спецификацией > 6.2.2.5. Подключение и редактирование состава геометрии объекта спецификации

6.2.2.5.2. Изменение состава геометрии объекта спецификации

...В сборочном чертеже

Часто возникает ситуация, когда требуется изменить набор графических объектов, входящих в состав объекта спецификации — например, добавить графические объекты к геометрии объекта спецификации или заменить геометрию объекта спецификации другой геометрией или удалить геометрию из состава объекта спецификации.

Последовательность выполнения этих действий примерно одинакова.

1. Выделите графические объекты, которые должны войти в состав объекта спецификации. Если требуется удалить геометрию из состава объекта спецификации, ни один графический объект не должен быть выделен.

2. В режиме редактирования подключенной к чертежу спецификации выделите объект, состав геометрии которого требуется изменить.

3. Вызовите команду Редактор — Редактировать состав объекта.

4. В появившемся на экране запросе (рис. 6.2.14) выберите вариант изменения графического состава объекта спецификации (добавить или заменить геометрию) или подтвердите удаление геометрии из состава объекта спецификации.

Будьте внимательны при изменении геометрического состава объекта спецификации, т.к. отменить эту операцию невозможно.

...В модели-сборке

Если в состав объекта спецификации включен компонент сборки, то геометрией объекта являются все тела этого компонента. Редактирование состава геометрии такого объекта спецификации «вручную» невозможно.

Если в состав объекта спецификации включено одно или несколько тел сборки, то геометрию объекта спецификации можно удалить, дополнить или заменить аналогично тому, как это делается в сборочном чертеже (см. выше). Тела могут быть добавлены в состав объекта спецификации только в том случае, если они не входят в состав других объектов спецификации.

Позиционные линии-выноски, имеющиеся в модели, добавляются в состав объектов спецификации и исключаются из него так же, как и позиционные линии-выноски чертежа.


6.2.2.5.3. Просмотр геометрии объектов спецификации

6.2. Приемы работы со спецификацией > 6.2.2. Работа с документом-спецификацией > 6.2.2.5. Подключение и редактирование состава геометрии объекта спецификации

6.2.2.5.3. Просмотр геометрии объектов спецификации

Чтобы просмотреть геометрию объекта спецификации, выполните следующие действия.

1. Откройте спецификацию и подключенный к ней сборочный чертеж или сборку.

2. Расположите мозаикой окна этих документов.

Вызовите в окне чертежа или модели команду Показать все.

3. Активизируйте окно спецификации и выделите в нем любой объект спецификации.

4. Вызовите команду Сервис — Показать состав объекта.

Система перейдет в режим показа геометрии объектов спецификации. В окне чертежа или сборки будут выделены графические объекты или трехмерные компоненты, входящие в состав выделенного объекта спецификации.

5. Для просмотра геометрии других объектов текущей спецификации выделяйте эти объекты любым способом (при помощи мыши или клавиатуры).

Режим показа геометрии объекта спецификации действует до тех пор, пока нажата кнопка Показать состав объекта и рядом с названием команды Показать состав объекта в меню отображается «галочка».

6. Для выхода из режима показа геометрии отожмите кнопку Показать состав объекта или повторно вызовите команду Показать состав объекта.


6.2.2.6. Ввод и редактирование дополнительных параметров объекта спецификации

6.2.2.6. Ввод и редактирование
дополнительных параметров объекта спецификации

Для работы со всеми видами дополнительных параметров текущего объекта спецификации предназначены элементы управления, расположенные на вкладках Панели свойств Параметры и Документы.

После выделения любого объекта спецификации на этих вкладках активизируются переключатели и поля, позволяющие задавать дополнительные параметры этого объекта. Чтобы изменить какие-либо параметры, активизируйте или отключите соответствующий переключатель либо введите в поле нужные данные.

Некоторые поля на Панели свойств — справочные. Изменить данные в них невозможно.

В этом разделе:

6.2.2.6.1. Настройки объекта спецификации

6.2.2.6.2. Дополнительные колонки

6.2.2.6.3. Подключение документа к объекту спецификации


6.2.2.6.1. Настройки объекта спецификации

6.2. Приемы работы со спецификацией > 6.2.2. Работа с документом-спецификацией > 6.2.2.6. Ввод и редактирование дополнительных параметров объекта спецификации

6.2.2.6.1. Настройки объекта спецификации

Настройки объекта влияют на его положение и отображение в спецификации и устанавливают правила обработки объекта при выполнении некоторых команд. Для управления настройками служат элементы, представленные в таблице 6.2.2.

Табл. 6.2.2. Элементы управления настройками объекта спецификации

Элемент

Описание

Тип

В этом справочном поле отображается тип строки, выделенной в таблице спецификации:

– Базовый объект (см. раздел 6.1.1.1.1),

– Вспомогательный объект (см. раздел 6.1.1.1.2),

– Заголовок раздела (см. раздел 6.1.2.1.2),

– Пустая строка (см. раздел 6.1.2.3),

– Резервная строка (см. раздел 6.1.2.4),

– Заголовок блока исполнений
(см. раздел 6.1.2.5).

Раздел

В этом справочном поле отображается название текущего раздела спецификации.

Имя подраздела

Номер
подраздела

Эти поля используются, чтобы переместить объект в другой подраздел внутри раздела, которому он принадлежит. Значения в них взаимосвязаны: при выборе из списка имени подраздела в соседнем поле появляется номер этого подраздела и наоборот, после указания номера можно увидеть имя соответствующего подраздела.

В результате выбора другого подраздела положение объекта в разделе может измениться.

Если текущий раздел не имеет подразделов, то списки имен и номеров подразделов пусты.

Позиция объекта возрастает1

Этот переключатель позволяет указать, должен ли номер позиции данного объекта быть на единицу больше, чем номер позиции предыдущего объекта.

Показывать
объект в таблице1

Этот переключатель влияет на показ объекта в таблице спецификации (делает объект видимым или невидимым). Отключение показа объекта не удаляет этот объект, а лишь на время (до включения показа) делает его невидимым в таблице спецификации2.

Показывать
позицию1

Этот переключатель включает и отключает показ в таблице номера позиции объекта спецификации.

Объект является исполнением1

Этот переключатель автоматически активизируется у объектов, образованных по команде Добавить исполнения объекта (см. раздел 6.2.2.3.3).

Действие этого переключателя имеет принципиальное значение только при составлении групповой спецификации с количеством исполнений больше десяти (см. раздел 6.2.7.1.1). Активизированный переключатель означает, что при представлении информации в спецификации по объектам данный объект не должен отделяться от своего исходного объекта. Исходным считается первый предыдущий объект с аналогичным обозначением, у которого не включен признак Объект является исполнением.

Кроме того, для объектов, у которых включен этот признак, недоступна команда Добавить исполнения (то есть невозможно создать исполнение объекта-исполнения).

Синхронизировать с документом-владельцем

Этот переключатель автоматически активизируется у объекта, с которыми связан компонент сборки. Этот компонент является документом-владельцем объекта спецификации. Пока переключатель активен, между сборкой (или спецификацией, к которой она подключена) и документом-владельцем производится передача изменений, сделанных в объекте спецификации. Неактивный переключатель означает, что передача изменений не происходит. Например, отключение передачи данных может потребоваться для редактирования объекта спецификации, документ-владелец которого недоступен для записи

Сброс

Эта кнопка доступна, если пользователь изменял состояния переключателей, автоматически установленные при создании объекта спецификации. Она позволяет вернуть автоматически установленные настройки.

Размещать
на новом листе

Этот переключатель позволяет разместить выделенный объект или заголовок раздела на новом листе спецификации.

Переключатель недоступен, если спецификация размещена на листе чертежа.

Привести
текстовую часть
к исходному виду

Это переключатель доступен, если объект спецификации возник при вставке в документ фрагмента или библиотечной модели (см. разделы 6.2.3.1.2 и 6.2.3.4.5), а текстовая часть объекта редактировалась вручную. Переключатель позволяет вернуть текстовую часть объекта, «пришедшую» вместе со вставкой, т.е. отменить ручное редактирование текстовой части.
  1. Сочетание переключателей Позиция объекта возрастает, Показывать объект в таблице, Показывать позицию и Объект является исполнением управляет «поведением» объекта при автоматической простановке позиций и сортировке объектов.
  2. При работе со спецификацией можно включить режим, в котором видны (и выводятся на печать) все объекты спецификации (как видимые, так и скрытые при помощи переключателя Показывать объект в таблице). Для этого вызовите команду Показать все объекты (см. раздел 6.2.6.7).

Состояние переключателей Позиция возрастает, Показывать объект в таблице, Показывать позицию и Объект является исполнением устанавливаются для каждого объекта в момент его формирования. Оно зависит от способа создания объекта и его характеристик.

Благодаря этому при сортировке, простановке позиций, разбиении спецификации с большим количеством исполнений на блоки все объекты ведут себя соответствующим своим характеристикам образом.

Рассмотрим несколько примеров автоматически сформированной комбинации настроек базового объекта. В этих примерах подразумевается, что простановка позиций в разделах спецификации разрешена (включена).

– Объект создан при помощи команды Вставка — Базовый объект (см. раздел 6.2.2.3.1). Его текстовая часть в колонке, по которой производится сортировка, отличается от текстов в этой колонке других объектов раздела.

Например, в разделе Детали создан объект, обозначение которого не совпадает с обозначениями других (уже существующих в спецификации) деталей.

В момент подтверждения создания объекта система производит автоматическую сортировку в текущем разделе: сравнивает все тексты в колонке Обозначения, по которой производится сортировка. «Убедившись», что обозначение нового объекта уникально (т.е. такой детали в спецификации еще нет), система активизирует для него переключатель Позиция объекта возрастает. Это значит, что объект будет иметь свой собственный, отличный от других, номер позиции. Активизируются также переключатели Показывать объект в таблице и Показывать позицию (у системы нет причин автоматически скрывать уникальный объект спецификации или номер его позиции).

Таким образом, новый объект будет показан в таблице спецификации, и каждый раз при простановке позиций он будет получать номер позиции, отличающийся от номера позиции предыдущего пронумерованного объекта.

– Объект создан путем копирования другого объекта (см. раздел 6.2.2.3.2). Его текстовая часть в колонке, по которой производится сортировка, не отличается от текстов в этой колонке исходного объекта. Или объект создан при помощи команды Вставка — Базовый объект и его текстовая часть в колонке, по которой производится сортировка, не отличается от текста в этой колонке другого объекта раздела.

Например, в разделе Детали создан объект с текстовой частью, повторяющей текстовую часть уже существующего объекта-детали1. В момент подтверждения создания объекта система производит автоматическую сортировку в текущем разделе. Обнаружив, что деталь с таким обозначением уже есть в спецификации, система располагает новый объект-деталь под существующим объектом с аналогичным обозначением. Система «понимает», что номер позиции нового объекта должен быть таким же, как у предыдущего объекта (т.к. они описывают одну и ту же деталь) и поэтому выключает для нового объекта признак Позиция объекта возрастает. Одна и та же деталь не должна упоминаться в спецификации дважды, поэтому автоматически выключается и признак Показывать объект в таблице. Признак Показывать позицию не отключается. Благодаря этому в режиме показа всех объектов (см. раздел 6.2.6.15) будет виден номер позиции скрытого объекта.

Таким образом, новый объект не будет показан в таблице спецификации, и каждый раз при простановке позиций он будет получать тот же номер позиции, что и предыдущий объект.

– Объект создан при помощи команды Вставка — Исполнение (см. раздел 6.2.2.3.3).

Вне зависимости от того, включен ли показ только номера исполнения или обозначения полностью, внутри объекта хранится его полное обозначение. Сразу после создания объекта производится сортировка, и в соответствии с этим обозначением объект располагается сразу после исходного объекта, имеющего такое же, но без суффикса, обозначение. У объекта активизируются переключатели Объект является исполнением (благодаря этому объект «помнит» свое полное обозначение) и Показывать объект в таблице (спецификация «понимает», что судя по новому обозначению, такого объекта в разделе еще нет).

Вообще говоря, необходимость присвоения объекту-исполнению нового номера позиции и показ этой позиции в таблице зависят от конкретного случая применения объекта-исполнения. Например, если в одной сборочной единице применяются разные исполнения одной детали, то в колонке Позиция соответствующих им объектов спецификации должны быть показаны отличающиеся номера.

Если же разные исполнения детали используются в разных исполнениях сборочной единицы, то в групповой спецификации они должны иметь один и тот же номер позиции, который показывается только для основного исполнения.

Спецификация может реализовать оба способа нумерации объектов-исполнений.

• Если при настройке спецификации (Формат — Настройка спецификации — Блоки исполнений) опция Позиции возрастают выключена (см. рис. 6.2.6), то при создании объектов-исполнений переключатели Позиция объекта возрастает и Показывать позицию неактивны. В результате объекты-исполнения оказываются не пронумерованными, а следующий за ними объект имеет номер позиции на единицу больше номера позиции исходного объекта, для которого были сформированы исполнения.

• Если при настройке спецификации опция Позиции возрастают включена, то при создании объектов-исполнений у них активизируются переключатели Позиция объекта возрастает и Показывать позицию. В результате объекты-исполнения оказываются пронумерованными по возрастанию.

Если объект-исполнение — первый объект раздела, т.е. выше него нет базового объекта или другого исполнения с тем же обозначением, то позиция такого объекта показывается в таблице вне зависимости от состояния переключателя Показывать позицию.

Действие кнопки Проставлять позиции на панели Текущее состояние распространяется только на вновь создаваемые объекты спецификации. Если объект-исполнение был создан при нажатой кнопке Проставлять позиции, то ее отключение не приведет к исчезновению или изменению номера его позиции. Номер позиции можно будет скрыть (или сделать невозрастающим) только при помощи переключателей на Панели свойств. Однако все объекты, создаваемые после выключения опции Проставлять позиции, не будут пронумерованы.

  1. Это может потребоваться для подключения геометрии из разных листов сборочного чертежа к одной и той же детали в спецификации.


6.2.2.6.2. Дополнительные колонки

6.2. Приемы работы со спецификацией > 6.2.2. Работа с документом-спецификацией > 6.2.2.6. Ввод и редактирование дополнительных параметров объекта спецификации

6.2.2.6.2. Дополнительные колонки

Объект спецификации может содержать сведения, дополняющие информацию, включаемую в стандартный бланк. Эти сведения хранятся в так называемых «дополнительных колонках» объекта спецификации. Они могут быть просмотрены или отредактированы в любой момент, однако в бланке спецификации они не видны и на печать не выводятся.

Примером информации в дополнительных колонках могут служить масса и стоимость объекта.

В дополнительные колонки вводят и любую другую информацию об объекте (код ОКП, материал, текстовый комментарий и т.д.). Их количество и состав определяются потребностями пользователя и хранятся в стиле спецификации (см. раздел 6.4.1).

Данные в дополнительных колонках объекта спецификации можно просмотреть и отредактировать на разворачивающейся панели Дополнительные колонки, расположенной на вкладке Параметры (рис. 6.2.15).

Рис. 6.2.15. Дополнительные колонки

Панель содержит список возможных для данной спецификации типов дополнительных колонок и их значений, относящихся к текущему объекту спецификации.

Для ввода или редактирования значения в дополнительной колонке щелкните мышью в соответствующем поле списка и введите нужные данные.

Сервисные команды позволяют сложить числовые значения дополнительных параметров, при этом может учитываться количество одинаковых объектов в сборке и даже количество объектов в ее различных исполнениях. О порядке вычисления суммы значений в дополнительных колонках можно прочитать в разделе 6.2.6.2.


6.2.2.6.3. Подключение документа к объекту спецификации

6.2. Приемы работы со спецификацией > 6.2.2. Работа с документом-спецификацией > 6.2.2.6. Ввод и редактирование дополнительных параметров объекта спецификации

6.2.2.6.3. Подключение документа к объекту спецификации

Объект спецификации можно связать с документом КОМПАС-3D. Эта связь является двусторонней и ассоциативной и позволяет передавать данные об объекте спецификации в подключенный документ, или наоборот, данные из документа в соответствующий ему объект спецификации.

Документ подключается к объекту спецификации на вкладке Панели свойств Документы. Она содержит разворачивающуюся панель Документы (рис. 6.2.16).

Рис. 6.2.16. Документ, подключенный к объекту спецификации

Панель содержит название подключенного к объекту спецификации документа и его уменьшенное изображение (при условии, что не включена опция Выключить просмотр).

Для подключения документа к объекту спецификации нажмите на панели Документы кнопку Добавить документ. В появившемся диалоге укажите путь к файлу документа и его имя, после чего нажмите кнопку Открыть.

Если объект спецификации — документ, подключите к нему собственно этот документ (например, сборочный чертеж, пояснительную записку, схему и т.д.).

Если объект спецификации — сборочная единица, подключите к нему соответствующую спецификацию.

Если объект спецификации — деталь, подключите к нему рабочий чертеж этой детали.

Трехмерная модель детали или сборки обычно подключается к объекту автоматически (см. раздел 6.2.3.4.2). Ее можно подключить и вручную (тем же способом, что и документы других типов).

При подключении документа к объекту спецификации на экране появляется запрос на использование данных из основной надписи подключаемого документа.

В случае положительного ответа в соответствующие колонки объекта спецификации автоматически передаются наименование и обозначение из модели или основной надписи чертежа, а также обозначение формата, на котором выполнен подключенный чертеж.

Информация из подключенного документа может передаваться не только в колонки бланка спецификации, но и в дополнительные колонки. Например, в дополнительную колонку объекта может быть автоматически передана масса детали из модели или из соответствующей графы основной надписи. При этом, если используемые в спецификации единицы измерения массы (см. раздел 9.2.5.1.4) отличаются от единиц, используемых в чертеже или модели, производится пересчет значения массы.

Вообще говоря, передача данных из подключенного к объекту документа является частью стиля спецификации. При формировании стиля можно отключить передачу данных или настроить ее параметры (например, изменить ячейку штампа, данные из которой должны передаваться в конкретную колонку объекта спецификации).

В обратном направлении — из объекта спецификации в подключенный документ — могут передаваться изменения обозначения и наименования.

Включение/отключение передачи данных (в обоих направлениях: из объекта спецификации в подключенный документ и обратно) производится опцией Передавать изменения в документ рядом с названием документа на панели Документы.

Если эта опция включена, то:

– изменения в подключенном к объекту документе (обозначение, наименование, масса, формат листа) при его сохранении передаются в спецификацию,

– изменения обозначения и наименования в объекте спецификации при ее сохранении передаются в подключенный к объекту документ.

Для отключения документа от объекта спецификации выделите в списке его название и нажмите кнопку Отключить документ.

Если требуется открыть подключенный к объекту документ, выделите в списке его название и нажмите кнопку Редактировать документ.

При необходимости к объекту спецификации может быть подключено несколько документов. В этом случае в объект передаются данные из первого подключенного документа. Вы можете изменить порядок подключенных к объекту документов, перемещая их по списку при помощи кнопок Переместить документ в списке вверх и Переместить документ в списке вниз.


6.2.2.7. Сортировка объектов

Автоматическая сортировка базовых объектов производится только в тех разделах спецификации, при настройке которых включена сортировка (см. раздел 6.4.2.2) и указаны ее правила — колонки, по которым должна производиться сортировка, и тип сортировки в каждой из них.

Чтобы быстро включить или отключить автоматическую сортировку в текущем разделе, пользуйтесь кнопкой Автоматическая сортировка на панели Текущее состояние. Нажатая кнопка означает, что автоматическая сортировка в текущем разделе включена, отжатая — выключена.

Отключение автоматической сортировки распространяется на вновь создаваемые в разделе объекты и не нарушает порядок уже отсортированных объектов.

Если автоматическая сортировка в разделе отключена, вы можете располагать его объекты в произвольной последовательности, перемещая их вверх и вниз.

Для перемещения объекта в разделе выделите его и вызовите команду Редактор — Сдвинуть объект вверх или — Сдвинуть объект вниз. Для быстрого вызова этих команд можно воспользоваться комбинациями клавиш <Shift>+<↑> и <Shift>+<↓> соответственно.

Автоматическая сортировка вспомогательных объектов спецификации не производится. Их можно вручную перемещать вверх и вниз даже в тех разделах, где включена автоматическая сортировка базовых объектов.

Если вспомогательный объект оказывается под базовым (сразу после создания или в результате применения команды сдвига), то между этими объектами возникает связь. Благодаря ей при перемещении базового объекта (например, после сортировки) вспомогательный последует за ним.

Связь между базовым и вспомогательным объектами не препятствует сдвигу вспомогательного. Если в результате сдвига вспомогательный объект оказывается под другим базовым, то связывается с ним; вспомогательные объекты, находящиеся в начале раздела, ни с чем не связаны.

При необходимости вы можете сортировать вспомогательные объекты, используя подразделы. Для этого переместите вспомогательные объекты, которые требуется отсортировать, в начало раздела — так, чтобы перед ними не было ни одного базового объекта. Затем отредактируйте каждый из этих объектов, присваивая ему нужный номер подраздела.

Объекты будут сортироваться в порядке возрастания номера подраздела. При этом будут учитываться как вспомогательные, так и базовые объекты.

Если настроенный вышеописанным способом вспомогательный объект переместить с помощью команд Сдвинуть объект вверх и Сдвинуть объект вниз так, что он окажется ниже базового объекта, то между ними снова возникнет связь. Чтобы отключить ее, необходимо опять переместить вспомогательный объект в начало раздела и задать для него нужный номер подраздела.

В разделе Документация объекты сортируются с учетом кода документа, см. раздел 6.1.2.6.4. Коды и наименования документов извлекаются из файла graphic.kds. Порядок следования кодов определяется файлом graphic.kdsp. По умолчанию оба файла находятся в подпапке \Sys главной папки системы КОМПАС-3D. Формат файлов — текстовый, поэтому при необходимости вы можете открыть и отредактировать файлы graphic.kds и graphic.kdsp в любом текстовом редакторе, см. раздел 9.5.5.3 и раздел 9.5.5.4.

Например, если необходимо использовать в спецификации коды переменного содержания И... (Инструкции) и Д... (Прочие документы), добавьте их в файлы graphic.kds и graphic.kdsp.


6.2.2.8. Простановка позиций

Числа, автоматически возникающие в колонке Позиция новых объектов, не являются номерами позиций. Они представляют собой порядковые номера объектов и отражают последовательность их создания.

Для присвоения объектам номеров позиций, соответствующих их положению в спецификации, вызовите команду Сервис — Расставить позиции.

В результате действия команды в колонке Позиция появятся номера позиций объектов.

Чтобы быстро включить или выключить простановку номеров позиций в текущем разделе, пользуйтесь кнопкой Проставлять позиции на панели Текущее состояние.

Нажатая кнопка означает, что простановка позиций в текущем разделе включена, отжатая — выключена.

При простановке позиций в каждом разделе учитывается количество резервных строк в предыдущем разделе.

Например, раздел Детали заканчивается позицией 46 и содержит три резервные строки. Тогда следующий за ним раздел Стандартные изделия будет начинаться с позиции 50, т.к. номера позиций 47, 48 и 49 зарезервированы для последующих изменений.

Даже после ввода в раздел Детали новых или удаления существующих объектов количество резервных строк в нем останется неизменным, а команда автоматической простановки позиций обеспечит «соблюдение дистанции» между номерами позиций в соседних разделах.

Для быстрого изменения количества резервных строк в текущем разделе служит поле Количество резервных строк на панели Текущее состояние.


6.2.2.9. Режимы работы с документом-спецификацией

При создании и заполнении текстовой части объектов документа-спецификации на экране вы видите стандартную таблицу спецификации и вводите данные в ее графы. Такой режим работы называется нормальным режимом заполнения спецификации. Он аналогичен нормальному режиму заполнения текстового документа.

В этом режиме также редактируются дополнительные параметры объектов спецификации, к объектам подключается геометрия, производится сортировка объектов, простановка позиций и другие операции с объектами.

Основная надпись документа-спецификации в нормальном режиме не видна и не доступна для редактирования.

Для заполнения основной надписи спецификации, просмотра дополнительных листов и ввода на них текста требуется перейти в режим разметки страницы. Этот режим при работе со спецификацией похож на режим разметки страницы текстового документа.

Для перехода в режим разметки страницы вызовите команду Вид — Разметка страниц или нажмите кнопку Разметка страниц на панели Режимы.

В этом режиме страницы спецификации показываются так, как они будут выводиться на печать. Видны и доступны для редактирования таблицы основной надписи документа-спецификации и текста дополнительных листов.

Объекты спецификации в режиме разметки страницы недоступны для редактирования.

Для редактирования объектов требуется вернуться в нормальный режим.

Для перехода из режима разметки страницы в нормальный режим вызовите команду Вид — Нормальный режим или нажмите кнопку Нормальный режим на панели Режимы.

По умолчанию система находится в нормальном режиме работы со спецификацией.


6.2.2.10. Отображение объектов, содержащих код и наименование документа

6.2.2.10. Отображение объектов, содержащих
код и наименование документа

Показ наименования изделия в текстовой части объекта спецификации, содержащего код и наименование документа, может быть автоматически отключен.

Отключение происходит, если содержимое ячеек Обозначение (без учета стандартного кода) и Наименование (без учета стандартного наименования документа) объекта спецификации полностью совпадает с содержимым соответствующих ячеек основной надписи этой спецификации. Полный текст в ячейке Наименование объекта спецификации виден только в режиме редактирования текстовой части этого объекта.

Перечень стандартных кодов и наименований документов определяется файлом кодов и наименований — graphic.kds. По умолчанию он находится в подпапке \Sys главной папки системы. Формат файла — текстовый, поэтому при необходимости файл graphic.kds может быть открыт и отредактирован в любом текстовом редакторе.

Если используются нестандартный код и/или наименование, содержимое ячейки Наименование отображается полностью даже при условии совпадения обозначения и наименования изделия.

Рассмотрим механизм отключения показа наименования изделия на примере объекта раздела Документация. Предположим, этот объект соответствует сборочному чертежу изделия. Целесообразно подключить к нему сборочный чертеж и взять данные из его основной надписи (рис. 6.2.17).

Рис. 6.2.17. Основная надпись сборочного чертежа, подключаемого к объекту спецификации

В ячейки Обозначение и Наименование объекта спецификации будут переданы строки «КСКВ.12.020СБ» и «Кронштейн Сборочный чертеж» соответственно (рис. 6.2.18, а).

Пусть графы Обозначение и Наименование основной надписи спецификации содержат строки «КСКВ.12.020» и «Кронштейн» соответственно.

В этом случае содержимое ячейки Наименование данного объекта спецификации зависит от режима работы. Наименование изделия — «Кронштейн» — показывается только в режиме редактирования этого объекта (рис. 6.2.18, а). После выхода из этого режима, а также в режиме разметки страниц отображение наименования изделия отключается и в ячейке Наименование остается только наименование документа (рис. 6.2.18, б).

Рис. 6.2.18.

а) Режим редактирования

б) Режим разметки страниц

Пусть теперь графа Обозначение основной надписи спецификации содержит строку «КСКВ.12.021» (рис. 6.2.19, а). В этом случае в ячейке Наименование данного объекта спецификации отображается полное наименование документа в любом режиме работы (рис. 6.2.19, б).

Рис. 6.2.19.

а) Основная надпись спецификации

б) Объект спецификации; режим разметки страниц


6.2.3. Работа с объектами спецификации в чертежах и моделях

6.2. Приемы работы со спецификацией

6.2.3. Работа с объектами спецификации в чертежах и моделях

Объекты спецификации можно создавать не только в документах-спецификациях, но и в чертежах, и в моделях.

Приемы создания и редактирования объектов спецификации в различных типах документов практически одинаковы. Например, копирование и редактирование базовых и вспомогательных объектов спецификации, создание исполнений объектов, редактирование дополнительных параметров объектов и подключение к ним документов производятся точно так же, как при работе с объектами в документе-спецификации (см. раздел 6.2.2).

Кнопки вызова команд работы с объектами спецификации в режимах работы с графическими документами и моделями по умолчанию находятся на инструментальной панели Спецификация (рис. 6.2.3).

В этом разделе:

6.2.3.1. Создание объектов спецификации в чертеже

6.2.3.1.1. Объекты спецификации из Справочника Стандартные Изделия

6.2.3.1.2. Объекты спецификации из вставленных фрагментов

6.2.3.2. Создание объектов спецификации в модели. Общие сведения

6.2.3.3. Создание объектов спецификации в детали

6.2.3.4. Создание объектов спецификации в сборке

6.2.3.4.1. Внешние объекты

6.2.3.4.2. Внутренние объекты

6.2.3.4.3. Особенности создания объектов спецификации раздела «Материалы»

6.2.3.4.4. Объекты спецификации из Справочника Стандартные Изделия

6.2.3.4.5. Объекты спецификации из библиотек моделей

6.2.3.5. Редактирование объектов спецификации в документе

6.2.3.5.1. Редактирование состава геометрии объекта спецификации

6.2.3.5.2. Просмотр геометрии объектов спецификации

6.2.3.5.3. Синхронизация объекта спецификации сборки с документом-владельцем и со свойствами компонента

6.2.3.6. Удаление объекта спецификации из документа

6.2.3.7. Автоматическое создание и удаление объектов спецификации сборки

6.2.3.7.1. Создание объектов спецификации

6.2.3.7.2. Удаление объектов спецификации

6.2.3.8. Создание спецификации по сборке


6.2.3.1. Создание объектов спецификации в чертеже

В сборочном чертеже нужно создавать те объекты спецификации, изображения которых содержатся в этом чертеже. Как правило, это объекты из разделов Сборочные единицы, Детали, Стандартные изделия.

Для создания объекта спецификации выполните следующие действия.

1. Находясь в режиме редактирования чертежа, выделите графические объекты, составляющие изображение детали или подсборки, в том числе позиционную линию-выноску. Выделенные объекты будут составлять геометрию объекта спецификации.

Включение позиционной линии-выноски в состав геометрии объекта спецификации обеспечит автоматическое заполнение колонки спецификации Зона и передачу номера позиции из спецификации на полку линии-выноски.

2. Вызовите команду Спецификация — Добавить объект…

3. В появившемся на экране диалоге выберите раздел для размещения объекта, а при необходимости — шаблон заполнения его текстовой части.

4. В появившемся на экране окне введите текстовую часть объекта спецификации (см. раздел 6.2.2.4).

5. При необходимости на вкладках Панели свойств Параметры и Документы задайте дополнительные параметры объекта (см. разделы 6.2.2.6.1 и 6.2.2.6.2) и подключите к нему документы (см. раздел 6.2.2.6.3).

6. Подтвердите создание объекта спецификации, нажав в окне ввода текстовой части кнопку OK или комбинацию клавиш <Ctrl>+<Enter>.

В чертеже будет создан объект спецификации, в состав которого входит выделенная геометрия. Если в диалоге настройки цвета текстовых элементов включена опция Номера позиций с объектами спецификаций, цвет шрифта номера позиции изменится в соответствии с настройками. Это позволяет отличать обозначения позиций, включенные в состав объектов спецификации, от не включенных. Для вызова диалога настройки текстовых элементов служит команда Сервис — Параметры... — Система — Экран — Цвет текстовых элементов.

Если при создании объекта в его состав не были включены графические объекты (в том числе позиционная линия-выноска), их можно ввести в состав объекта спецификации на любом этапе работы с ним. Это делается так же, как при включении геометрии в объект документа-спецификации (см. раздел 6.2.2.5.1). Разница состоит лишь в том, что выделять объект, в состав которого вводится геометрия, надо в подчиненном режиме.

В этом разделе:

6.2.3.1.1. Объекты спецификации из Справочника Стандартные Изделия

6.2.3.1.2. Объекты спецификации из вставленных фрагментов


6.2.3.1.1. Объекты спецификации из Справочника Стандартные Изделия

6.2. Приемы работы со спецификацией > 6.2.3. Работа с объектами спецификации в чертежах и моделях > 6.2.3.1. Создание объектов спецификации в чертеже

6.2.3.1.1. Объекты спецификации из Справочника Стандартные Изделия

При вставке в чертеж изображения из Справочника Стандартные Изделия (далее Справочника) по умолчанию создается объект спецификации с позиционной линией-выноской.

После выбора объекта из Справочника и указания его положения на экране появляется окно для ввода текстовой части объекта спецификации (такое же, как при создании объекта спецификации в чертеже).

После подтверждения создания объекта требуется создать новую позиционную линию-выноску (вариант по умолчанию), указывающую на объект. Эта линия-выноска и графические объекты библиотечного изображения будут включены в состав объекта спецификации.

Объект спецификации расположится в определенном Справочником разделе, например, крепежное изделие — в разделе Стандартные изделия.

Вы можете отказаться от создания объекта спецификации при вставке изображения из Справочника, а также создать объект спецификации после его вставки в чертеж или фрагмент. Вставка объектов, управление созданием объекта спецификации, настройка простановки позиции и описаны в документации Справочника.

Вы можете вставлять объекты спецификаций из другого приложения способом, предусмотренным этим приложением.


6.2.3.1.2. Объекты спецификации из вставленных фрагментов

6.2. Приемы работы со спецификацией > 6.2.3. Работа с объектами спецификации в чертежах и моделях > 6.2.3.1. Создание объектов спецификации в чертеже

6.2.3.1.2. Объекты спецификации из вставленных фрагментов

Во фрагменте можно создать такие же объекты спецификации, как в чертеже. Они создаются и редактируются по тем же правилам, что и объекты спецификации в чертеже.

Фрагмент не подключается к спецификации. Поэтому напрямую передать объекты из него в спецификацию невозможно.

Однако фрагмент можно вставить в чертеж. При этом объекты спецификации, так же как и графические объекты, попадут из фрагмента в чертеж (с сохранением всех их свойств). Такая передача объектов происходит при любом способе вставки — ссылкой, телом или россыпью.

Порядок работы с объектами, полученными таким способом, не отличается от порядка работы с объектами спецификации, созданными непосредственно в чертеже.

Если в состав объектов спецификации во фрагменте входят позиционные линии-выноски, то при вставке фрагмента в чертеж после сортировки всех объектов спецификации в этом чертеже на линиях-выносках появятся новые номера позиций, соответствующие месту появившихся из фрагмента объектов среди объектов спецификации чертежа.

Проще говоря, если во фрагменте номера позиций 1, 2 и 3, то после вставки этого фрагмента в чертеж и пересчета позиций в нем позиции во фрагменте могут получить, например, номера 10, 28 и 46 (при условии, что позиционные линии-выноски входят в состав объекта спецификации, включены расчет позиций и их простановка).

Если фрагмент содержит несколько описаний спецификаций (см. раздел 6.2.6.14) и объекты, созданные для каждого описания, то при вставке в чертеж этого фрагмента в чертеже появятся все описания спецификаций, содержащиеся во фрагменте, и все объекты спецификации из фрагмента.

Если при выпуске различных сборочных чертежей (схем, чертежей общего вида и т.д.) вы используете типовые решения, создайте соответствующие фрагменты с объектами спецификации и любым способом вставляйте их в чертежи.

1. Начертите типовую деталь (или узел) во фрагменте.

2. Создайте в этом фрагменте объект спецификации, соответствующий детали (или объекты спецификации, соответствующие деталям узла).

3. Сохраните фрагмент.

4. Вставляйте фрагмент в сборочные чертежи.

Вместе с изображением в них будут «приходить» объекты спецификации.

Вы также можете создать библиотеки фрагментов, содержащих объекты спецификации, и вставлять фрагменты в чертежи из них. При работе в библиотеке фрагменты, содержащие объекты спецификации, ничем не отличаются от других фрагментов.


6.2.3.2. Создание объектов спецификации в модели. Общие сведения

Существует два различных способа работы с объектами спецификации в моделях.

1. Ручное создание объектов спецификации в моделях компонентов (см. разделы 6.2.3.3 и 6.2.3.4.1). При вставке компонентов в сборку их объекты спецификации передаются в сборку (см. раздел 6.2.3.4.2, способ 1).

2. Автоматическое создание в сборке объектов спецификации, соответствующих компонентам первого уровня (см. раздел 6.2.3.4.2, способ 2) на основе свойств этих компонентов.

Как первый, так и второй способ формирует в сборке набор объектов спецификации, отражающий ее состав. В случае необходимости можно создать в сборке объекты спецификации, не связанные с компонентами (см. раздел 6.2.3.4.2, способ 4).

После подключения сборки к документу-спецификации (см. раздел 6.2.4.1) в нее передаются все объекты спецификации из сборки.

Для корректного формирования объектов спецификации в модели рекомендуется предварительно сохранить ее на диске.


6.2.3.3. Создание объектов спецификации в детали

Как правило, в детали создают единственный объект спецификации, содержащий ее наименование и обозначение и принадлежащий разделу Детали.

Как и при работе с графическими документами, для создания в детали объектов спецификации требуется вызвать команду Спецификация — Добавить объект.... Выделять какие-либо формообразующие и конструктивные элементы перед вызовом команды не требуется.

Дальнейшие действия (выбор раздела для размещения объекта, ввод текстовой части и задание дополнительных параметров) выполняются так же, как при создании объекта спецификации в чертеже (см. раздел 6.2.3.1).

Если перед вызовом команды создания объекта спецификации в Дереве построения была выделена текущая деталь (корневой элемент Дерева), то колонки Обозначение, Наименование и дополнительная колонка Масса заполняются автоматически, а текущий документ-деталь подключается к создаваемому объекту спецификации.

Автоматическое заполнение текстовой части объекта спецификации предпочтительнее, чем ручной ввод данных, так как позволяет избежать случайных ошибок.


6.2.3.4. Создание объектов спецификации в сборке

В сборке можно создать внутренние и внешние объекты (см. раздел 6.1.3.2.2).

В этом разделе:

6.2.3.4.1. Внешние объекты

6.2.3.4.2. Внутренние объекты

6.2.3.4.3. Особенности создания объектов спецификации раздела «Материалы»

6.2.3.4.4. Объекты спецификации из Справочника Стандартные Изделия

6.2.3.4.5. Объекты спецификации из библиотек моделей


6.2.3.4.1. Внешние объекты

6.2. Приемы работы со спецификацией > 6.2.3. Работа с объектами спецификации в чертежах и моделях > 6.2.3.4. Создание объектов спецификации в сборке

6.2.3.4.1. Внешние объекты

Как правило, в сборке создают единственный внешний объект спецификации, содержащий ее наименование и обозначение и принадлежащий разделу Сборочные единицы. Этот объект автоматически передается в сборку, в которую текущая входит в качестве подсборки (сборочной единицы).

Чтобы создать в сборке внешний объект спецификации, вызовите команду Спецификация — Добавить объект — Внешний....

Дальнейшие действия (выбор раздела для размещения объекта, ввод текстовой части и задание дополнительных параметров) выполняются так же, как при создании объекта спецификации в чертеже (см. раздел 6.2.3.1).

Если перед вызовом команды создания внешнего объекта спецификации в Дереве построения была выделена текущая сборка (корневой элемент Дерева), то колонки Обозначение, Наименование и дополнительная колонка Масса заполняются автоматически, а текущий документ-сборка подключается к создаваемому объекту спецификации.


6.2.3.4.2. Внутренние объекты

6.2. Приемы работы со спецификацией > 6.2.3. Работа с объектами спецификации в чертежах и моделях > 6.2.3.4. Создание объектов спецификации в сборке

6.2.3.4.2. Внутренние объекты

Можно выделить четыре способа создания в сборке внутренних объектов спецификации. Вы можете комбинировать их по своему усмотрению.

1. Формирование объектов спецификации при создании компонентов

Внутренние объекты спецификации возникают в сборке при вставке в нее деталей, содержащих объекты спецификации, и подсборок, содержащих внешние объекты спецификации. Иными словами, при вставке в сборку компонентов объекты спецификации деталей и внешние объекты спецификации подсборок становятся внутренними объектами главной сборки.

Если документы-модели не были подключены к «своим» объектам спецификации, то это можно сделать при редактировании внутренних объектов спецификации сборки (о подключении документов к объектам спецификации см. раздел 6.2.2.6.3). Все изменения внутренних объектов спецификации, «пришедших» в сборку из компонентов, передаются в файлы этих компонентов.

Таким образом, если вы создавали объекты спецификации во всех деталях и подсборках текущей сборки, то в ней оказываются все объекты, необходимые для внесения в спецификацию на эту сборку. Их можно передать в спецификацию, подключенную к сборке.

Данный способ является предпочтительным для создания в сборке объектов спецификации, соответствующих компонентам, так как формирование объектов спецификации непосредственно при работе с компонентами снижает вероятность ошибок.

2. Автоматическое формирование объектов спецификации
для компонентов первого уровня сборки

Если в файле компонента нет объекта спецификации, то соответствующий ему внутренний объект спецификации формируется в сборке на основе свойств (обозначение, наименование, масса) этого компонента. Формирование объекта происходит автоматически после вставки компонента в сборку при условии, что в сборке есть описание спецификации (см. раздел 6.1.3.4). Автоматически созданный объект не передается в файл компонента, он существует только в сборке.

Стиль автоматически созданного объекта спецификации соответствует текущему стилю спецификации. Таким образом, после появления в сборке нового описания спецификации и назначения его текущим в этой сборке создаются внутренние объекты спецификации со стилем, входящим в новое описание. При этом не имеет значения, было ли описание создано вручную или появилось в сборке автоматически (например, в результате вставки компонента с объектом спецификации).

Обратите внимание на то, что в свойствах автоматически созданного объекта спецификации отключен переключатель Синхронизировать с документом — владельцем объекта (см. раздел 6.2.2.6.1), благодаря чему объект и не передается из сборки в компонент. При редактировании объекта спецификации можно включить этот переключатель, после чего объект спецификации появится в файле компонента.

Данный способ позволяет не заботиться о создании объектов спецификации в файлах компонентов. Кроме того, в автоматически созданных объектах спецификации используются обозначения и наименования, заданные для компонентов в сборке (см. раздел 5.1.4.1.2). В общем случае они могут отличаться от обозначений и наименований в файлах компонентов. Таким образом, при необходимости компонент можно быстро переименовать в сборке, не изменяя его файл.

Данный способ формирования внутренних объектов спецификации используется при автоматическом создании спецификации по сборке (см. раздел 6.2.3.8).

3. Автоматическое формирование объектов спецификации,
соответствующих компонентам

Автоматическое создание объектов спецификации в компонентах текущей сборки производится с помощью команды Спецификация — Создать объекты спецификации....

При этом создаются объекты спецификации во всех компонентах, где их не было. В деталях создаются обычные объекты спецификации, в сборках — внешние объекты спецификации. Обозначение и наименование берутся из свойств компонентов, заполняется дополнительная колонка Масса; документы-модели подключаются к созданным внутри них объектам спецификации.

Подробно команда автоматического создания объектов спецификации описана в разделе 6.2.3.7.1.

Для использования данного способа создания объектов спецификации необходимо, чтобы в файлах всех компонентов сборки были заданы их обозначения и наименования.

4. Формирование объектов спецификации в сборке
и связывание их с компонентами и телами

Чтобы создать в текущей сборке внутренний объект спецификации, связанный с каким-либо компонентом или построенным в этой сборке телом, выделите нужный объект в Дереве построения, а затем вызовите команду Спецификация — Добавить объект — Внутренний....

Дальнейшие действия (выбор раздела для размещения объекта, ввод текстовой части и задание дополнительных параметров) выполняются так же, как при создании объекта спецификации в чертеже (см. раздел 6.2.3.1).

Обратите внимание на то, что колонки Обозначение и Наименование объекта спецификации автоматически заполняются данными, введенными при настройке свойств компонента (тела), а его текущая масса заносится в дополнительную колонку Масса. Если был выделен компонент, то его файл автоматически подключается к создаваемому объекту спецификации, а после создания объект спецификации передается в соответствующий файл модели (для подсборки созданный объект становится внешним объектом спецификации).

В некоторых случаях в сборке требуется создать внутренний объект, которому не может соответствовать компонент или тело. Например, при сборке изделия используется какой-либо материал. Данные о нем должны попасть в спецификацию (т.е. в сборке должен быть соответствующий внутренний объект). Однако построить модель этого материала невозможно. В таком случае в сборке нужно создать объект, не связанный ни с внешним файлом, ни с каким-либо телом. Для этого вызовите команду Добавить объект — Внутренний..., не выделяя никаких объектов сборки.

Данный способ — единственный, который позволяет создать в сборке внутренние объекты, связанные с телами или не связанные ни с телами, ни с компонентами. Будьте внимательны при его использовании: этот способ повышает вероятность случайного создания одинаковых объектов спецификации, в том числе для компонентов. В сборке невозможно удаление объектов спецификации, связанных с компонентами. Поэтому для удаления «лишних» объектов потребуется редактирование файлов компонентов.

Формированием в сборке внутренних объектов спецификации, соответствующих компонентам, управляет опция Создавать объекты спецификации. По умолчанию она включена.

Если ее отключить, то объект спецификации не будет создаваться для компонента (при использовании способа 2) и не будет передаваться из файла компонента во внутренние объекты спецификации сборки (при использовании остальных способов).

Поэтому, если в сборке отсутствует объект спецификации для какого-либо компонента, проверьте, включено ли создание этого объекта. Для этого выделите компонент в Дереве построения и вызовите из контекстного меню команду Свойства компонента. Проверьте состояние опции Создавать объекты спецификации на Панели свойств.

Опция Создавать объекты спецификации есть также в свойствах библиотечных компонентов.


6.2.3.4.3. Особенности создания объектов спецификации раздела «Материалы»

6.2. Приемы работы со спецификацией > 6.2.3. Работа с объектами спецификации в чертежах и моделях > 6.2.3.4. Создание объектов спецификации в сборке

6.2.3.4.3. Особенности создания объектов спецификации раздела «Материалы»

Если в сборке есть объекты (компоненты или тела), относящиеся к разделу спецификации Материалы, то для создания соответствующих им объектов спецификации действуйте следующим образом.

1. Вызовите в сборке Редактор свойств (см. раздел 5.1.4.2).

2. Включите в Редакторе свойств отображение столбцов Материал и Раздел спецификации (см. раздел 5.1.4.2.2).

3. Проверьте материал компонентов и тел, которые должны быть отнесены к разделу спецификации Материалы.

• Материал компонента обычно задается в файле компонента. При необходимости вы можете поменять материал компонента непосредственно в Редакторе свойств (см. раздел 5.1.4.4.2) — это изменение сохранится в сборке и не будет передано в файл компонента.

• Материал тела по умолчанию совпадает с материалом сборки. Если тело должно иметь другой материал, поменяйте его в Редакторе свойств.

4. Задайте свойству Раздел спецификации у каждого объекта, который относится к материалам, значение Материалы (см. раздел 5.1.4.4.6).

5. Закройте Редактор свойств кнопкой ОК.

В сборке будут созданы связанные с указанными компонентами и телами внутренние объекты спецификации в разделе Материалы.


6.2.3.4.4. Объекты спецификации из Справочника Стандартные Изделия

6.2. Приемы работы со спецификацией > 6.2.3. Работа с объектами спецификации в чертежах и моделях > 6.2.3.4. Создание объектов спецификации в сборке

6.2.3.4.4. Объекты спецификации из Справочника Стандартные Изделия

При вставке в сборку модели из Справочника Стандартные Изделия по умолчанию создается объект спецификации.

После выбора объекта из Справочника и указания его положения на экране появляется окно для ввода текстовой части объекта спецификации (такое же, как при создании объекта спецификации в модели).

После подтверждения создания объекта в сборке возникнет внутренний объект спецификации. Он расположится в определенном Справочником разделе, например, крепежное изделие — в разделе Стандартные изделия.

Вы можете отказаться от создания объекта спецификации при вставке модели из Справочника. Вставка объектов и управление созданием объекта спецификации описаны в документации Справочника.

Вы можете вставлять объекты спецификаций из другого приложения способом, предусмотренным этим приложением.


6.2.3.4.5. Объекты спецификации из библиотек моделей

6.2. Приемы работы со спецификацией > 6.2.3. Работа с объектами спецификации в чертежах и моделях > 6.2.3.4. Создание объектов спецификации в сборке

6.2.3.4.5. Объекты спецификации из библиотек моделей

Модель, хранящаяся в библиотеке моделей (файле *.l3d), может содержать такие же объекты спецификации, как модель, хранящаяся в отдельном файле на диске.

Если библиотечный компонент, содержащий внутренние объекты спецификации, вставить в сборку, то в сборке появятся соответствующие внутренние объекты спецификации. Порядок работы с ними не отличается от порядка работы с объектами спецификации, «пришедшими» в сборку при вставке компонентов из отдельных файлов.

Эту возможность удобно использовать, если в ваших изделиях используются типовые детали и узлы.

1. Создайте трехмерную модель типовой детали (узла).

2. Создайте в этой модели внешний объект спецификации, соответствующий детали (или узлу).

3. Включите модель в состав библиотеки моделей.

4. Вставляйте модель из библиотеки в сборки.

Вместе с телом библиотечного компонента в сборки будут передаваться объекты спецификации.


6.2.3.5. Редактирование объектов спецификации в документе

Редактирование объектов спецификации в чертежах и моделях производится в подчиненном режиме (см. раздел 6.1.3.3). Этот режим доступен при наличии в документе описания спецификации. Для его вызова служит команда Спецификация — Редактировать объекты….

К редактированию объекта спецификации в чертеже можно перейти, используя подключенную к нему геометрию. Для этого выделите нужные графические объекты и вызовите из контекстного меню команду Редактировать объект спецификации.

После редактирования объектов спецификации в сборочном чертеже изменения могут быть переданы в подключенную к нему спецификацию в результате синхронизации (см. раздел 6.2.4.2.1).

Обозначение и наименование чертежа влияет на отображение объектов спецификации, содержащих код и наименование документа. Это влияние аналогично влиянию обозначения и наименования спецификации на объекты в ней (см. раздел 6.2.2.10).

В этом разделе:

6.2.3.5.1. Редактирование состава геометрии объекта спецификации

6.2.3.5.2. Просмотр геометрии объектов спецификации

6.2.3.5.3. Синхронизация объекта спецификации сборки с документом-владельцем и со свойствами компонента


6.2.3.5.1. Редактирование состава геометрии объекта спецификации

6.2. Приемы работы со спецификацией > 6.2.3. Работа с объектами спецификации в чертежах и моделях > 6.2.3.5. Редактирование объектов спецификации в документе

6.2.3.5.1. Редактирование состава геометрии объекта спецификации

Способы редактирования состава геометрии объекта спецификации в чертеже или сборке (добавление, замена и удаление геометрии) практически аналогичны способам редактирования состава геометрии в документе-спецификации (см. раздел 6.2.2.5.2). Разница состоит лишь в том, что выделять объект, состав которого редактируется, надо в подчиненном режиме (т.е. непосредственно внутри чертежа или сборки, а не в отдельном документе-спецификации).


6.2.3.5.2. Просмотр геометрии объектов спецификации

6.2. Приемы работы со спецификацией > 6.2.3. Работа с объектами спецификации в чертежах и моделях > 6.2.3.5. Редактирование объектов спецификации в документе

6.2.3.5.2. Просмотр геометрии объектов спецификации

Порядок просмотра геометрии объектов спецификации, созданных в чертеже или сборке, практически аналогичен порядку просмотра геометрии объектов в документе-спецификации (см. раздел 6.2.2.5.3). Разница состоит лишь в том, что выделять объекты спецификации, состав которых просматривается, надо в подчиненном режиме.

При просмотре геометрии расположите мозаикой окно чертежа (или сборки) и окно подчиненного режима редактирования объектов спецификации.


6.2.3.5.3. Синхронизация объекта спецификации сборки с документом-владельцем и со свойствами компонента

6.2. Приемы работы со спецификацией > 6.2.3. Работа с объектами спецификации в чертежах и моделях > 6.2.3.5. Редактирование объектов спецификации в документе

6.2.3.5.3. Синхронизация объекта спецификации сборки
с документом-владельцем и со свойствами компонента

Документ-владелец объекта спецификации — компонент сборки, с которым связан имеющийся в ней внутренний объект спецификации.

По умолчанию сразу после вставки компонента в сборку в свойствах этого компонента включено получение обозначения и наименования из источника (соответствующие опции в колонке Источник включены, см. рис. 5.1.12). При этом:

– Если в файле компонента был объект спецификации,
то этот объект передается во внутренние объекты спецификации сборки. Для этого объекта включается синхронизация с документом-владельцем, т.е. активизируется переключатель Синхронизировать с документом-владельцем объекта в группе Настройки на Панели свойств. При такой настройке изменения объекта спецификации передаются:

• из сборки в компонент — безусловно, передача производится сразу после подтверждения создания объекта спецификации,

• из компонента в сборку — при условии, что получение обозначения и наименования из источника включено; передача производится при сохранении файла компонента.

Отключение переключателя Синхронизировать с документом-владельцем объекта означает запрет передачи изменений как в одну, так и в другую сторону.

– Если в файле компонента не было объекта спецификации,
то этот объект автоматически создается в сборке на основе свойств компонента. Переключатель Синхронизировать с документом-владельцем объекта в группе Настройки на Панели свойств для такого объекта не активизируется, поскольку в документе-владельце нет объекта спецификации.

Если требуется передать автоматически созданный объект спецификации в документ-владелец, включите переключатель Синхронизировать с документом-владельцем объекта.

Синхронизация объекта спецификации с документом-владельцем отключается автоматически, если в этом объекте было отредактировано обозначение или наименование.

Вы можете или оставить синхронизацию отключенной, или:

– передать изменения в документ-владелец — для этого активизируйте переключатель Синхронизировать с документом-владельцем объекта,

– взять данные из документа-владельца — для этого активизируйте переключатель Исходный текст.

Кроме синхронизации объекта спецификации с документом-владельцем, пользователь может управлять связью объекта спецификации, соответствующего компоненту сборки, со свойствами этого компонента. Для этого служит переключатель Синхронизировать со свойствами компонента.

– Активный переключатель означает, что изменения обозначения или наименования компонента будут передаваться из объекта спецификации в свойства компонента и наоборот. В результате обозначение (наименование) в свойствах компонента всегда будет совпадать с обозначением (наименованием) в соответствующем объекте спецификации.

– Неактивный переключатель означает, что передача данных не производится. В результате обозначение (наименование) компонента в свойствах и в объекте спецификации могут быть различными.

В документе-спецификации, к которой подключена сборка, синхронизация объектов с документами-владельцами и свойствами компонентов производится аналогично вышеописанному.


6.2.3.6. Удаление объекта спецификации из документа

Чтобы удалить объект спецификации из чертежа, перейдите в подчиненный режим (Спецификация — Редактировать объекты…), выделите подлежащий удалению объект и нажмите клавишу <Delete> или вызовите команду Редактор — Удалить объект.

Если при настройке спецификации была включена опция Удалять геометрию при удалении объекта спецификации, то в результате удаления объекта спецификации из чертежа исчезнут также соответствующие графические объекты (изображение компонента сборки). Подробнее об этом рассказано в разделе 6.2.6.1.1.

Чтобы удалить объект спецификации из детали, перейдите в подчиненный режим, выделите подлежащий удалению объект и нажмите клавишу <Delete> или вызовите команду Редактор — Удалить объект.

Таким же образом удаляются внешние объекты спецификации в сборке и те ее внутренние объекты, которые связаны с телами или не связаны ни с телами, ни с компонентами.

Внутренние объекты спецификации сборки, которые связаны с документами-моделями, нельзя удалить описанным способом. Вы можете исключить из набора внутренних объектов спецификации в сборке объект спецификации, принадлежащий конкретному компоненту. Для этого выполните следующие действия.

1. Выделите нужный компонент в Дереве построения.

2. Вызовите из контекстного меню команду Свойства компонента.

3. На Панели свойств выключите опцию Создавать объекты спецификации.

Объект спецификации, принадлежащий выбранному компоненту, будет исключен из числа внутренних объектов спецификации в сборке. При этом объект, естественно, не удаляется из самого компонента. Он лишь перестает присутствовать во внутренних объектах спецификации в текущей сборке.

Исключение объекта спецификации, принадлежащего какому-либо компоненту, из внутренних объектов спецификации в одной сборке никак не влияет на его присутствие во внутренних объектах спецификации в остальных сборках, компонентом которых он является.


6.2.3.7. Автоматическое создание и удаление объектов спецификации сборки

6.2.3.7. Автоматическое создание и удаление
объектов спецификации сборки

Если во время создания компонентов сборки были введены их обозначения и наименования, то при работе со сборкой возможно автоматическое создание объектов спецификации в ее деталях и подсборках.

Обозначение и наименование модели вводятся при задании ее свойств.

Возможна и обратная операция — автоматическое удаление всех объектов спецификации, имеющихся в сборке и ее компонентах.

При настройке автоматического создания или удаления объектов спецификации можно включить создание или удаление документов-спецификаций, связанных со сборкой и ее подсборками. О связи сборки со спецификацией — см. раздел 6.1.3.5.2.

Команды автоматического создания и удаления объектов спецификации в сборке подробно описаны ниже.

Обратите внимание на то, что время, требующееся для автоматического создания или удаления объектов спецификации, может быть значительным, поскольку производится открытие, редактирование и сохранение моделей. В общем случае время выполнения команды зависит от:

– насыщенности сборки и сложности ее компонентов,

– производительности компьютера,

– размещения файлов сборки и компонентов: на диске того же компьютера, где запущен КОМПАС-3D и вызвана команда создания или удаления объектов спецификации (в этом случае команда выполняется быстрее всего), или на сетевых дисках.

В целях экономии времени рекомендуется использовать указанные команды не всякий раз после добавления очередного компонента, а на завершающем этапе работы со сборкой — после того, как в нее будут включены все необходимые компоненты.

В этом разделе:

6.2.3.7.1. Создание объектов спецификации

6.2.3.7.2. Удаление объектов спецификации


6.2.3.7.1. Создание объектов спецификации

6.2. Приемы работы со спецификацией > 6.2.3. Работа с объектами спецификации в чертежах и моделях > 6.2.3.7. Автоматическое создание и удаление объектов спецификации сборки

6.2.3.7.1. Создание объектов спецификации

Чтобы создать объекты спецификации в деталях и подсборках текущей сборки, вызовите команду Спецификация — Создать объекты спецификации...

Команда недоступна в следующих случаях:

– сборка не сохранена в файле на диске,

– в сборке уже есть внутренние объекты спецификации, соответствующие всем компонентам первого уровня.

После вызова команды на экране появится диалог, приведенный на рисунке 6.2.20. Элементы управления диалога представлены в таблице 6.2.3.

Рис. 6.2.20. Диалог создания объектов спецификации

Табл. 6.2.3. Диалог создания объектов спецификации
Элемент | Описание
Обработать файлы компонентов | Группа элементов, позволяющая задать область действия команды.
Всех уровней | Включение этой опции означает, что: – в деталях текущей сборки и в деталях подсборок будут созданы объекты спецификации, – во всех подсборках будут созданы внешние объекты спецификации.
Первого уровня | Включение этой опции означает, что: – в деталях текущей сборки будут созданы объекты спецификации, – в подсборках текущей сборки будут созданы внешние объекты спецификации.
Раздел спецификации | Группа элементов, позволяющая указать, каким разделам должны принадлежать объекты спецификации. В списках КОМПАС-Сборки (*.a3d) и КОМПАС-Детали (*.m3d) содержатся названия разделов спецификации текущего стиля. Если текущий стиль спецификации не определен (т.е. если отсутствует описание спецификации), то используется стиль, установленный для новых спецификаций. Выберите разделы, в которые будут помещаться объекты спецификации в файлах деталей и внешние объекты спецификации в файлах сборок. Если не нужно создавать объекты спецификации в файлах деталей или сборок, то выберите пустую строку в списке КОМПАС-Сборки (*.a3d) или КОМПАС-Детали (*.m3d).
Создавать документ спецификации | Включите эту опцию, чтобы автоматически создать и подключить к текущей сборке документ-спецификацию (*.spw). Если в группе Обработать файлы компонентов включена опция Всех уровней, автоматически создаются и подключаются к подсборкам всех уровней документы-спецификации, соответствующие этим подсборками. Документы-спецификации именуются так же, как сборки, к которым они подключаются, и размещаются там же, где сборки.
Сохранять изменения | Включите эту опцию, чтобы после создания объектов спецификации текущая сборка была сохранена1.
  1. Файлы компонентов сохраняются вне зависимости от состояния данной опции.

Завершив настройку создания объектов спецификации, нажмите кнопку ОК диалога.

В тех компонентах, которые не содержали объекты спецификации, будут созданы объекты, соответствующие этим компонентам. При этом:

– в колонки Обозначение и Наименование помещаются данные, введенные при настройке свойств компонента,

– в дополнительную колонку Масса заносится текущая масса компонента,

– файл компонента подключается к создаваемому объекту спецификации.

Команда Спецификация — Создать объекты спецификации... не обрабатывает тела, построенные в сборке, и библиотечные компоненты.

К объектам, вставленным из Справочника Стандартные Изделия, при вызове данной команды автоматически применяется аналогичная команда Справочника.


6.2.3.7.2. Удаление объектов спецификации

6.2. Приемы работы со спецификацией > 6.2.3. Работа с объектами спецификации в чертежах и моделях > 6.2.3.7. Автоматическое создание и удаление объектов спецификации сборки

6.2.3.7.2. Удаление объектов спецификации

Чтобы удалить объекты спецификации из текущей сборки, ее деталей и подсборок, вызовите команду Спецификация — Удалить объекты спецификации...

Команда доступна, если текущая сборка сохранена в файле на диске и содержит объекты спецификации.

После вызова команды на экране появится диалог, приведенный на рисунке 6.2.21. Элементы управления диалога представлены в таблице 6.2.4.

Рис. 6.2.21. Диалог удаления объектов спецификации

Табл. 6.2.4. Диалог удаления объектов спецификации
Элемент | Описание
Обработать файлы компонентов | Группа элементов, позволяющая задать область действия команды.
Всех уровней | Включение этой опции означает, что из текущей сборки и всех ее компонентов будут удалены все объекты спецификации.
Первого уровня | Включение этой опции означает, что: – из деталей текущей сборки будут удалены все объекты спецификации, – из подсборок будут удалены все внешние объекты спецификации, – из текущей сборки будут удалены внешние объекты спецификации и внутренние объекты спецификации, не связанные с компонентами (например, в разделе Материалы).
Удалить документ спецификации | Включите эту опцию, чтобы удалить подключенный к текущей сборке документ-спецификацию (*.spw). Если в группе Обработать файлы компонентов включена опция Всех уровней, автоматически удаляются документы-спецификации, подключенные к подсборкам.
Сохранять изменения | Включите эту опцию, чтобы после удаления объектов спецификации текущая сборка и все ее компоненты были сохранены.

Завершив настройку удаления объектов спецификации, нажмите кнопку OK диалога.


6.2.3.8. Создание спецификации по сборке

Возможно автоматическое создание спецификации, которая содержит объекты, соответствующие входящим в сборку компонентам первого уровня.

Для этого следует открыть нужную сборку и вызвать команду Спецификация — Создать спецификацию по сборке. Команда недоступна, если сборка не сохранена в файле на диске или редактируется в контексте другой сборки.

После вызова команды на экране появляется заполненная спецификация.

Если какие-либо из компонентов сборки не имели объектов спецификации, они создаются автоматически на основе свойств этих компонентов.

Новый документ-спецификация не сохраняется в файл автоматически. Команду сохранения следует вызвать вручную. Только после этого спецификация будет синхронизироваться со сборкой — например, спецификация будет изменяться после редактирования свойств компонентов в сборке или добавлении/удалении компонентов. Синхронизация производится автоматически при сохранении сборки.

Созданная спецификация имеет стиль, заданный при настройке новых документов. Если сборка не имеет исполнений, то стиль спецификации определяется умолчательной настройкой, см. раздел 9.2.5.1.1; стиль спецификации по сборке с исполнениями зависит от количества исполнений, см. раздел 9.2.5.2.1.

Сборка не может быть одновременно подключена к нескольким спецификациям одного стиля. Поэтому в результате выполнения команды Создать спецификацию по сборке новая спецификация создается, если сборка еще не связана со спецификацией такого же стиля. В противном случае загружается (или активизируется, если уже загружена) спецификация, к которой подключена сборка.

Если файл спецификации не найден, например, переименован или перемещен в другую папку, на экране появляется предупреждающее сообщение. Вы можете создать новую спецификацию по сборке, нажав кнопку Да, или отказаться от создания спецификации, нажав кнопку Нет.

Во время работы команды создания спецификации по сборке автоматически производятся следующие действия:

– Создание в сборке внутренних объектов спецификации для компонентов, в файлах которых отсутствовали эти объекты (о внутренних объектах спецификации см. раздел 6.1.3.2.2 и 6.2.3.4.2, п. 2). Вы можете просмотреть или отредактировать внутренние объекты спецификации сборки в подчиненном режиме (см. раздел 6.1.3.3).

– Создание документа-спецификации и подключение ее к сборке (о связи сборки и спецификации см. раздел 6.1.3.5.2).

При использовании команды создания спецификации по сборке имейте в виду следующее:

– Команда не создает объекты спецификации для тел, а также для компонентов, вставленных из прикладных библиотек.

– Если опция Создавать объекты спецификации в свойствах компонента отключена, внутренний объект спецификации, соответствующий компоненту, в сборке не создается.


6.2.4. Связь спецификации с чертежами и моделями

6.2. Приемы работы со спецификацией

6.2.4. Связь спецификации с чертежами и моделями

В этом разделе:

6.2.4.1. Взаимное подключение документов

6.2.4.1.1. Подключение спецификации к текущей сборке или чертежу

6.2.4.1.2. Подключение сборки или чертежа к текущей спецификации

6.2.4.2. Синхронизация данных

6.2.4.2.1. Передача объектов из чертежа или сборки в спецификацию

6.2.4.2.2. Передача объектов из спецификации в чертеж или сборку

6.2.4.2.3. Передача данных между основной надписью спецификации и подключенными документами


6.2.4.1. Взаимное подключение документов

Связь между спецификацией и сборочным чертежом или между спецификацией и моделью-сборкой может быть установлена двумя способами:

– подключением спецификации к чертежу или сборке (см. раздел 6.2.4.1.1),

– подключением чертежа или сборки к спецификации (см. раздел 6.2.4.1.2).

Свойства связи между сборкой или чертежом и спецификацией не зависят от порядка подключения документов друг к другу. Иными словами, имея связанные друг с другом спецификацию и сборку (или спецификацию и чертеж), невозможно установить, подключалась ли сборка (чертеж) к спецификации или спецификация к сборке (чертежу).

В этом разделе:

6.2.4.1.1. Подключение спецификации к текущей сборке или чертежу

6.2.4.1.2. Подключение сборки или чертежа к текущей спецификации


6.2.4.1.1. Подключение спецификации к текущей сборке или чертежу

Подключение спецификации к сборке или чертежу может производиться на любом этапе работы с этим документом. Единственным условием подключения является наличие поименованного файла текущей сборки или чертежа на диске. То есть спецификацию нельзя подключить к документу, который ни разу не сохранялся с момента создания и поэтому не имеет имени.

Возможно подключение к сборке или чертежу существующей спецификации (в том числе содержащей объекты) или создание новой спецификации в процессе подключения.

1. Чтобы подключить спецификацию к текущему документу, вызовите команду Спецификация — Управление описаниями спецификаций....

На экране появится диалог управления описаниями спецификаций (рис. 6.2.22 или 6.2.24). Подробнее об описаниях рассказано в разделе 6.1.3.4.

При автоматическом создании объектов спецификации в сборке (см. раздел 6.2.3.7.1) возможно автоматическое создание документа-спецификации и подключение его к текущей сборке.

Если в текущем документе есть объекты спецификации...

Сборка или чертеж уже имеет описание спецификации. Это описание не содержит имени файла спецификации. В нем указан только стиль спецификации (рис. 6.2.22).

Рис. 6.2.22. Описание спецификации при наличии
в документе объектов спецификации

2. В диалоге управления описаниями спецификаций выделите существующее описание и нажмите кнопку Редактировать описание.

3. В появившемся диалоге описания спецификации (рис. 6.2.23) задайте имя файла подключаемой спецификации. Для этого нажмите кнопку Выбрать в группе опций Имя файла спецификации и в появившемся диалоге открытия файлов укажите имя файла спецификации.

Рис. 6.2.23. Редактирование описания

Диалог описания спецификации закроется. К названию стиля спецификации в диалоге управления описаниями спецификаций добавится полное имя подключенной к документу спецификации.

Указанная спецификация должна иметь тот же стиль, что и объекты спецификации, существующие в сборке или чертеже.

Если в диалоге открытия файлов набрать имя несуществующей спецификации, спецификация с указанным именем будет создана системой. Стиль этой спецификации будет соответствовать объектам спецификации в чертеже.

Указанный в диалоге стиль спецификации изменять нельзя, т.к. в документе уже существуют объекты спецификации, созданные в соответствии с этим стилем.

Если в текущем документе нет объектов спецификации...

Перечень описаний спецификаций в диалоге управления описаниями спецификаций пуст (рис. 6.2.24).

Рис. 6.2.24. Описание спецификации при отсутствии
в документе объектов спецификации

4. Чтобы добавить к нему описание, нажмите в диалоге кнопку Добавить описание.

На экране появится диалог описания спецификации (рис. 6.2.23).

5. Укажите в нем имя файла спецификации и ее стиль.

Имя файла спецификации однозначно определяет ее стиль.

• Если спецификация, которую требуется подключить, уже существует, просто выберите ее: нажмите кнопку Выбрать и в появившемся диалоге укажите файл спецификации. После этого в соответствующих полях автоматически появятся имя библиотеки стилей и название стиля выбранной спецификации.

• Если спецификация, которую требуется подключить, не существует, укажите стиль, который она должна иметь: выберите вначале библиотеку стилей, а затем — название стиля из нее. После этого нажмите кнопку Выбрать в группе Имя файла спецификации и в появившемся диалоге открытия файлов введите имя несуществующей спецификации. Спецификация с указанным именем и выбранным стилем будет создана системой.

В результате выполнения пунктов 1, 2 и 31 в диалоге управления описаниями появится описание, содержащее имя документа-спецификации (рис. 6.2.25).

Рис. 6.2.25. Редактирование описания

6. Выделите в диалоге управления описаниями имя спецификации, которую требуется подключить к сборке или чертежу, и нажмите кнопку OK.

Спецификация будет подключена к документу.

Если в диалоге описания спецификации включить опцию Загрузить документ спецификации, то после выхода из диалога по кнопке OK подключенная спецификация будет открыта в КОМПАС-3D.

7. Чтобы выйти из диалога управления описаниями, нажмите кнопку Выход.

  1. Пункты 2 и 3 выполняются один раз, вариант выполнения выбирается в зависимости от наличия в текущем документе объектов спецификации.


6.2.4.1.2. Подключение сборки или чертежа к текущей спецификации

К спецификации можно подключить любое количество сборок и чертежей. Обычно к спецификации подключают трехмерную модель сборки или (и) листы сборочного чертежа.

1. Чтобы подключить к текущей спецификации сборку или чертеж, вызовите команду Сервис — Управление сборкой.

На экране появится диалог управления сборкой (рис. 6.2.26). В нем показаны названия документов, подключенных к текущей спецификации.

Рис. 6.2.26. Диалог управления сборкой

2. Для подключения сборки или чертежа к спецификации нажмите в диалоге кнопку Подключить документ.

3. В появившемся диалоге выбора файлов укажите файл документа.

4. Чтобы включить передачу обозначения и наименования из первого подключенного документа в основную надпись спецификации, нажмите кнопку Заполнить основную надпись.

5. Чтобы отметить документы, в которые должны передаваться обозначение и наименование из основной надписи спецификации, включите опции в соответствующих ячейках колонки Передавать изменения в документ.

Вы можете быстро открыть любой из подключенных документов. Для этого выделите его в списке и нажмите кнопку Редактировать документ.

6. Для закрытия диалога управления сборкой нажмите кнопку Выход.

Таким образом, кнопка Заполнить основную надпись управляет передачей данных из подключенного документа в спецификацию. Пока она остается в нажатом состоянии, связь между спецификацией и первым подключенным документом сохраняется. Если на первом месте в списке подключенных окажется другой документ, то в спецификацию будут передаваться обозначение и наименование из этого документа. Порядок следования документов в диалоге управления сборкой можно менять с помощью кнопок Переместить документ вверх и Переместить документ вниз.

Порядок следования документов в списке учитывается также при расчете зон.

После отжатия кнопки Заполнить основную надпись передача данных в основную надпись спецификации прекратится. Текущие обозначение и наименование изделия ни в документе, ни в спецификации не изменятся.

Колонка Передавать изменения в документ управляет передачей обозначения и наименования изделия из спецификации в подключенные документы. При отключении опции в этой колонке у какого-либо документа передача в него обозначения и наименования изделия из спецификации прекратится. Текущие обозначение и наименование изделия ни в документе, ни в спецификации не изменятся.

Следовательно, чтобы установить двустороннюю связь между спецификацией и подключенным документом, необходимо нажать в диалоге управления сборкой кнопку Заполнить основную надпись, поместить нужный документ на первое место в списке подключенных и установить для него отметку в колонке Передавать изменения в документ (как это сделано, например, для документа Конвейер.cdw на рисунке 6.2.26).


6.2.4.2. Синхронизация данных

Обычно объекты спецификации создают и редактируют в одном из подключенных друг к другу документов — либо в сборочном чертеже (или модели), либо в спецификации. В результате получается, что объекты в подключенных друг к другу документах различаются.

Для корректной обработки взаимно подключенных документов необходимо, чтобы объекты спецификации в них были одинаковы. Чтобы добиться этого, следует произвести синхронизацию — передать актуальные объекты в подключенный документ (см. также раздел 6.1.3.6).

При необходимости передачу данных между взаимно подключенными документами можно отключить. Для этого служит опция Связь сборки или чертежа со спецификацией в диалоге настройки текущей спецификации (см. раздел 6.4.2.1). Кроме того, можно отключить передачу изменений из спецификации в подключенные документы — для этого нужно изменить настройку системы, см. раздел 9.1.9.2.

Проявлением синхронизации являются также передача обозначения и наименования изделия между:

– объектами спецификации и подключенными к ним документами,

– спецификацией и подключенным к ней чертежом или сборкой.

В этом разделе:

6.2.4.2.1. Передача объектов из чертежа или сборки в спецификацию

6.2.4.2.2. Передача объектов из спецификации в чертеж или сборку

6.2.4.2.3. Передача данных между основной надписью спецификации и подключенными документами


6.2.4.2.1. Передача объектов из чертежа или сборки в спецификацию

Для передачи объектов спецификации из текущего чертежа или сборки в подключенную к этому документу спецификацию вызовите команду Спецификация — Синхронизировать данные.

Подключенная спецификация необязательно должна быть открыта в момент вызова команды.

В результате действия команды в спецификацию будут переданы объекты из чертежа или внутренние объекты из сборки. Система выдаст сообщение об изменении спецификации.

При сохранении чертежа или сборки синхронизация со спецификацией производится автоматически.

Подробнее о передаче объектов из чертежа или сборки в спецификацию см. раздел 6.1.3.6.1.


6.2.4.2.2. Передача объектов из спецификации в чертеж или сборку

Для передачи объектов из текущей спецификации в подключенные к ней документы вызовите из контекстного меню команду Синхронизировать данные.

Подключенный документ необязательно должен быть открыт в момент вызова команды.

В результате действия команды в чертеж или сборку будут переданы объекты из спецификации. Система выдаст сообщение об изменении подключенных документов.

Если при подключении к объектам спецификации документов была включена опция Передавать изменения в документ, то данные из колонок объектов будут переданы в подключенные к объектам документы (например, в соответствующие ячейки основных надписей чертежей деталей).

В чертеж передаются не все объекты из спецификации, а только те, которые были созданы в этом чертеже (и затем переданы в спецификацию) или имеют в своем составе геометрию из этого чертежа. Это правило продиктовано тем, что спецификация может быть подключена к нескольким листам сборочного чертежа, и передача всех объектов спецификации в каждый подключенный чертеж приведет к появлению большого количества одинаковых объектов. Во избежание такой неоднозначной ситуации объект спецификации передается только в тот чертеж, в котором находится соответствующее ему изображение.

Передача объектов из спецификации в подключенные чертежи производится также каждый раз при сохранении спецификации. В этом случае синхронизация происходит автоматически и вызывать соответствующую команду не требуется.

Подробнее о передаче объектов из чертежа или сборки в спецификацию см. раздел 6.1.3.6.2.


6.2.4.2.3. Передача данных между основной надписью спецификации и подключенными документами

6.2.4.2.3. Передача данных между основной надписью спецификации
и подключенными документами

Синхронизация обозначения и наименования изделия производится автоматически при сохранении любого из связанных документов. Вызов специальной команды синхронизации не требуется. Настройка синхронизации производится в диалоге управления сборкой, см. раздел 6.2.4.1.2.

Передача данных между основной надписью спецификации и подключенным документом производится в следующем порядке.

Из документа берется полное содержимое граф основной надписи Обозначение и Наименование (если документ — спецификация или чертеж) или полей Обозначение и Наименование (если документ — модель сборки).

Если последние знаки полученного обозначения составляют один из стандартных кодов, то оно передается в связанный документ без этих знаков. В противном случае обозначение передается «как есть». Наименование изделия обрабатывается аналогичным образом.

Например, на рисунке 6.2.27 показаны основные надписи чертежей, подключаемых к спецификациям, а на рисунке 6.2.28 — основные надписи спецификаций, заполненные данными, полученными из этих чертежей. Поскольку чертеж на рисунке 6.2.27, а) имеет стандартные код и наименование, основная надпись спецификации на рисунке 6.2.28, а) заполнена правильно. Чертеж же на рисунке 6.2.27, б) имеет нестандартный код, поэтому обозначение спецификации на рисунке 6.2.28, б) неверно.

Перечень стандартных кодов и наименований определяется файлом кодов и наименований — graphic.kds. По умолчанию он находится в подпапке \Sys главной папки системы. Формат файла — текстовый, поэтому при необходимости файл graphic.kds может быть открыт и отредактирован в любом текстовом редакторе.

Рис. 6.2.27. Основные надписи чертежей

а)

б)

Рис. 6.2.28. Основные надписи спецификаций

а)

б)

Если обозначение и/или наименование спецификации отредактировано, то при ее сохранении новые данные автоматически передаются в подключенные документы. На экране появляется сообщение о том, какие документы изменены.


6.2.5. Типовые процедуры создания спецификации

6.2. Приемы работы со спецификацией

6.2.5. Типовые процедуры создания спецификации

Приемы, представленные в разделах 6.2.2–6.2.4, позволяют создавать спецификации различными способами. Все эти приемы можно произвольно комбинировать для получения спецификаций требуемого вида.

Однако среди всевозможных комбинаций приемов и способов работы можно выделить несколько типовых процедур создания спецификаций. Они представлены в этом разделе. Эти процедуры оптимальны с точки зрения скорости создания спецификаций и получения корректного комплекта конструкторских документов на изделие.

В этом разделе:

6.2.5.1. Спецификация, связанная со сборочным чертежом

6.2.5.2. Спецификация, связанная с моделью сборки

6.2.5.3. Полный комплект ассоциативных документов

6.2.5.4. Спецификация, не связанная с другими документами


6.2.5.1. Спецификация, связанная со сборочным чертежом

1. Создайте в чертеже объекты спецификации (см. раздел 6.2.3.1). Желательно, чтобы они имели в своем составе геометрию (как минимум, позиционные линии-выноски).

2. Перейдите в подчиненный режим работы с объектами спецификации чертежа (см. раздел 6.2.3.5). Убедитесь, что в таблице спецификации имеются все созданные вами объекты.

3. Подключите к чертежу документ-спецификацию (см. раздел 6.2.4.1.1).

4. Передайте в спецификацию объекты из чертежа (см. раздел 6.2.4.2.1).

5. Сохраните спецификацию.

Если при создании объектов спецификации подключать к ним чертежи, можно получить в этих чертежах копию геометрии («заготовку» изображения) из сборочного чертежа (см. раздел 6.2.6.4).


6.2.5.2. Спецификация, связанная с моделью сборки

1. Создайте и сохраните файлы компонентов будущей сборки (деталей и подсборок).

2. В каждом файле детали формируйте соответствующий ей объект спецификации (см. раздел 6.2.3.3), располагая его в разделе Детали.

3. В каждом файле подсборки формируйте соответствующий ей внешний объект спецификации (см. раздел 6.2.3.4.1), располагая его в разделе Сборочные единицы.

4. Создайте документ-сборку и добавьте в нее все требующиеся компоненты.

5. Если необходимо, добавьте в сборку объекты из Справочника Стандартные Изделия (см. раздел 6.2.3.4.4).

6. Если какие-либо компоненты сборки могут быть построены только в ее контексте, создайте эти компоненты. Находясь в режиме контекстного редактирования компонента, создайте объекты спецификации: для детали — обычный объект, а для подсборки — внешний.

7. Перейдите в подчиненный режим работы с внутренними объектами спецификации сборки (см. раздел 6.2.3.5). Убедитесь, что раздел Сборочные единицы содержит внешние объекты спецификации, принадлежащие подсборкам, раздел Детали — объекты спецификации, принадлежащие деталям, раздел Стандартные изделия — объекты спецификации, принадлежащие библиотечным элементам, а значения в графе Количество соответствуют числу вставок компонента в сборку.

8. Если необходимо, создайте в сборке внутренние объекты спецификации (см. раздел 6.2.3.4.2) — например, в разделе Материалы.

9. Сохраните созданный файл сборки.

10. Подключите к сборке документ-спецификацию (см. раздел 6.2.4.1.1).

11. Передайте в спецификацию объекты из сборки (см. раздел 6.2.4.2.1).

12. Сохраните спецификацию.

13. При необходимости проставьте в сборке позиционные линии-выноски (см. раздел 6.2.6.17).

Альтернатива вышеописанной процедуре — автоматическое создание спецификации с помощью команды Создать объекты спецификации... (см. раздел 6.2.3.7.1) или Создать спецификацию по сборке (см. раздел 6.2.3.8).


6.2.5.3. Полный комплект ассоциативных документов

1. Сформируйте в сборке внутренние объекты спецификации (см. раздел 6.2.3.4.2).

2. Создайте ассоциативный чертеж сборки. В него автоматически будут переданы внутренние объекты спецификации из сборки.

3. Проставьте в чертеже позиционные линии-выноски. Включите их в состав соответствующих объектов спецификации.

4. Подключите документ-спецификацию к сборке и (или) ассоциативному сборочному чертежу (см. раздел 6.2.4.1.1).

5. Передайте в спецификацию объекты из сборки или чертежа (см. раздел 6.2.4.2.1).


6.2.5.4. Спецификация, не связанная с другими документами

1. Создайте документ-спецификацию (см. раздел 6.2.2.1).

2. Создайте в ней объекты спецификации и заполните их текстовую часть (см. разделы 6.2.2.3, 6.2.2.4).

Используйте этот способ только для быстрого перевода в электронный вид уже выпущенной «бумажной» спецификации при условии, что другие документы на изделие (сборочный чертеж, деталировка, модели) отсутствуют в электронном виде.


6.2.6. Дополнительные возможности

6.2. Приемы работы со спецификацией

6.2.6. Дополнительные возможности

Модуль проектирования спецификаций обладает сервисными возможностями, использование которых не является строго обязательным при формировании спецификации. Они служат для выполнения некоторых вспомогательных действий.

Возможно, некоторые дополнительные приемы работы со спецификациями и возможности настройки, описанные в этом разделе, окажутся полезными для вас. Разумеется, советы по их применению являются не прямым указанием к действию, а лишь примером их использования.

В этом разделе:

6.2.6.1. Операции с объектами, содержащими геометрию

6.2.6.1.1. Удаление геометрии при удалении объекта спецификации

6.2.6.1.2. Удаление объекта спецификации при удалении геометрии

6.2.6.1.3. Копирование объекта спецификации при копировании геометрии

6.2.6.2. Подсчет суммы значений в колонках спецификации

6.2.6.3. Обработка числовых колонок спецификации

6.2.6.4. Создание заготовки чертежа на основе геометрии объекта спецификации

6.2.6.5. Разбиение спецификации на листы

6.2.6.6. Создание резервных строк в середине раздела спецификации

6.2.6.7. Включение и отключение показа объекта в таблице спецификации

6.2.6.8. Сохранение спецификации в других форматах

6.2.6.8.1. Экспорт во фрагмент

6.2.6.8.2. Экспорт в форматы DXF, DWG и IGES

6.2.6.8.3. Экспорт в форматы баз данных

6.2.6.9. Дополнительные листы

6.2.6.10. Нумерация листов

6.2.6.11. Настройка отображения значений массы

6.2.6.12. Спецификация на чертеже

6.2.6.12.1. Размещение на чертеже спецификации текущего стиля

6.2.6.12.2. Размещение на чертеже спецификаций разных стилей

6.2.6.12.3. Название спецификации на чертеже

6.2.6.13. Таблица изменений

6.2.6.14. Объекты разных спецификаций в одном чертеже

6.2.6.15. Объекты-«двойники»

6.2.6.16. Использование марок/позиционных обозначений

6.2.6.17. Обозначения позиций в модели сборки

6.2.6.18. Объединение вариантов описаний спецификаций в документе


6.2.6.1. Операции с объектами, содержащими геометрию

Если объекты спецификации имеют в своем составе графические объекты, то становится возможным автоматическое выполнение следующих действий:

– удаление геометрии при удалении объекта спецификации (см. раздел 6.2.6.1.1),

– удаление объекта спецификации при удалении геометрии (см. раздел 6.2.6.1.2),

– копирование объекта спецификации при копировании геометрии (см. раздел 6.2.6.1.3).

Включение и отключение этих сервисных возможностей производится на вкладке Настройки диалога настройки спецификации (рис. 6.2.29). Для вызова этого диалога служит команда Формат — Настройка спецификации...

Рис. 6.2.29. Диалог настройки спецификации

Если вы работаете в подчиненном режиме редактирования объектов спецификации, а к текущему чертежу не подключен документ-спецификация, настройка спецификации не производится и команда настройки недоступна.

Использование перечисленных возможностей возможно как при работе в документе-спецификации, так и в чертеже, в подчиненном режиме.

В этом разделе:

6.2.6.1.1. Удаление геометрии при удалении объекта спецификации

6.2.6.1.2. Удаление объекта спецификации при удалении геометрии

6.2.6.1.3. Копирование объекта спецификации при копировании геометрии


6.2.6.1.1. Удаление геометрии при удалении объекта спецификации

Опция Удалять геометрию при удалении объекта спецификации (см. рис. 6.2.29) управляет автоматическим удалением из чертежа геометрии удаляемого объекта спецификации.

Если опция включена, то при удалении объектов спецификации из чертежа будут удаляться входящие в их состав графические объекты (даже если этот чертеж закрыт в момент удаления объекта спецификации).

Опцией удаления геометрии при удалении объекта спецификации нужно пользоваться крайне осторожно, так как восстановить удаленные таким способом объекты не всегда возможно.


6.2.6.1.2. Удаление объекта спецификации при удалении геометрии

Опция Удалять объекты спецификации при удалении геометрии (см. рис. 6.2.29) управляет автоматическим удалением объектов спецификации при удалении из чертежа графических объектов, входящих в состав этих объектов спецификации.

Если эта опция включена, то при удалении из чертежа геометрических объектов и линий-выносок, входящих в состав объектов спецификации, на экране появляется диалог, показанный на рисунке 6.2.30.

Рис. 6.2.30. Диалог выбора объекта спецификации

В окне диалога перечислены обозначения и наименования всех объектов спецификации, состав которых полностью удаляется при удалении выбранных геометрических объектов. Вы можете:

– удалить все объекты, которые содержат удаляемую геометрию, нажав кнопку Удалить все,

– удалить только некоторые объекты, выделив их и нажав кнопку Удалить,

– отказаться от удаления объектов, нажав кнопку Не удалять.


6.2.6.1.3. Копирование объекта спецификации при копировании геометрии

Опция Копировать объекты спецификации при копировании геометрии (см. рис. 6.2.29) управляет автоматическим копированием объектов спецификации при копировании в чертеже графических объектов, входящих в состав этих объектов спецификации.

Если эта опция включена, то копия объекта спецификации автоматически создается при копировании в чертеже:

– всех геометрических объектов и линий-выносок, входящих в состав этого объекта,

– всех геометрических объектов, входящих в состав этого объекта,

– хотя бы одной линии-выноски, входящей в состав этого объекта.

Если геометрия объекта спецификации расположена в разных видах чертежа, то этот объект спецификации копируется также при копировании части геометрии, целиком находящейся в одном виде.

Способ копирования геометрии — с помощью мыши или команд редактирования — для копирования объекта спецификации не имеет значения.


6.2.6.2. Подсчет суммы значений в колонках спецификации

При настройке некоторых колонок бланка спецификации и дополнительных колонок, содержащих числовые данные, может быть предусмотрено сложение значений в этих колонках.

Для сложения числовых значений в колонках вызовите команду Сервис — Сложить значения в колонках.

В появившемся на экране диалоге (рис. 6.2.31) вы увидите результаты суммирования. Оно будет произведено в соответствии с настройками стиля текущей спецификации. Сложены будут значения в тех колонках, для которых включена опция сложения. Если спецификация групповая, то результат сложения будет выдан для каждого исполнения.

Рис. 6.2.31. Диалог с результатами суммирования

Таким способом можно подсчитать массу или стоимость специфицируемого изделия (конечно, при условии, что вы ввели массу или стоимость всех объектов спецификации).

Вы можете записать результаты суммирования в отдельный текстовый файл. Для этого нажмите в диалоге с результатами кнопку Записать... и введите имя файла.


6.2.6.3. Обработка числовых колонок спецификации

Иногда при работе со спецификацией требуется произвести некоторые арифметические действия над значениями в колонках спецификации (например, для автоматического заполнения колонки Стоимость, если известны цена и количество изделий).

Для выполнения таких действий служит библиотека Сервисные инструменты (файл komlib.rtw). Она входит в стандартный комплект поставки КОМПАС-3D и не требует отдельной лицензии.

Для подсчета значений в колонках подключите библиотеку Сервисные инструменты и в ее разделе Операции со спецификацией выберите команду Обработка числовых колонок.

На экране появится диалог обработки числовых колонок (рис. 6.2.32, табл. 6.2.5).

Рис. 6.2.32. Диалог обработки числовых колонок

Табл. 6.2.5. Элементы управления диалога обработки числовых колонок

Опция

Описание

Числовые
колонки

В этом столбце перечислены числовые колонки активной спецификации (колонки, имеющие тип данных «Целый» или «Вещественный»). В список включены как основные, так и дополнительные колонки. Колонки сгруппированы в секции, которые соответствуют разделам спецификации.

Набор секций и состав колонок в них зависит от настройки стиля текущей спецификации. Секция Для всех разделов является общей и отображается для спецификации любого стиля, но состав ее колонок также зависит от стиля.

Переменные

В этом столбце требуется ввести или отредактировать

– имена переменных, которые будут присвоены значениям соответствующих колонок, и

– уравнения для расчета данных в других колонках.

После ввода переменных и уравнений нажмите кнопку ОК диалога. В колонки спецификации будут подставлены рассчитанные значения.

Для пересчета значений в колонках (например, после изменения исходных данных) требуется повторно вызвать команду Обработка числовых колонок спецификации.


6.2.6.4. Создание заготовки чертежа на основе геометрии объекта спецификации

6.2.6.4. Создание заготовки чертежа
на основе геометрии объекта спецификации

К моменту создания спецификации рабочие чертежи деталей и узлов могут быть еще не готовы. Модуль проектирования спецификаций позволяет создать «заготовки» рабочих чертежей деталей и сборочных чертежей сборочных единиц и комплексов.

Создание заготовки возможно, если чертеж, предназначенный для изображения объекта спецификации (например, детали), еще не существует.

При подключении к объекту спецификации документа (см. раздел 6.2.2.6.3) в стандартном диалоге выбора файла введите несуществующее имя файла чертежа. Система создаст чертеж с указанным вами именем и разместит в нем все графические элементы, входящие в состав объекта спецификации (за исключением позиционной линии-выноски). Вы получите заготовку рабочего чертежа детали или чертежа сборочной единицы.

Проставить в нем размеры и дополнить геометрию придется вручную, а вот некоторые графы основной надписи (например, Обозначение и Наименование) будут заполнены автоматически (данные в них передаются из спецификации). В дальнейшем при редактировании текстов в этих графах изменения будут передаваться в спецификацию.

Этой возможностью нужно пользоваться только в том случае, если у вас нет трехмерной модели компонента сборки. Если модель имеется, создавайте ее ассоциативный чертеж, а не чертеж на основе геометрии из сборочного чертежа.


6.2.6.5. Разбиение спецификации на листы

Если разделы спецификации не умещаются на одном листе, происходит автоматическая разбивка спецификации на листы. В нормальном режиме отображения спецификации верхняя и нижняя граница листа показаны горизонтальными пунктирными линиями.

Иногда при автоматической разбивке спецификации на листы получается, что заголовок раздела оказывается на одном листе, а объекты этого раздела — на другом или многострочный объект спецификации располагается на разных листах. В таких случаях вы можете вручную разбить спецификацию на листы так, чтобы заголовок раздела или объект спецификации размещался на новом листе.

Чтобы разместить заголовок раздела или объект спецификации в начале новой страницы, выделите этот заголовок или объект и активизируйте переключатель Размещать на новом листе, расположенный на Панели свойств.


6.2.6.6. Создание резервных строк в середине раздела спецификации

Обычно резервные строки располагаются в конце разделов. Если резервная строка должна быть расположена в середине раздела, поступите следующим образом.

1. С помощью вспомогательного объекта спецификации создайте пустую строку в том месте раздела, где должна находиться резервная строка.

2. Установите выделение на созданной строке и активизируйте переключатель Позиция объекта возрастает, расположенный на Панели свойств.

Активизация этого переключателя означает, что номер позиции объекта должен быть на единицу больше номера позиции предшествующего ему объекта. Если опция отключена, то номер позиции совпадает с номером позиции предыдущего объекта.


6.2.6.7. Включение и отключение показа объекта в таблице спецификации

6.2.6.7. Включение и отключение показа объекта
в таблице спецификации

При создании некоторых объектов спецификации в их настройках автоматически отключается опция Показывать объект в таблице (подробно об этом рассказано в разделе 6.2.2.6.1).

Чтобы скрытые объекты стали видны в таблице спецификации, выполните следующие действия.

1. Временно включите режим показа всех скрытых объектов спецификации. Для этого служит команда Вид — Показать все объекты. После вызова команды соответствующая кнопка остается нажатой (таким образом, она является индикатором режима показа всех объектов).

После того как в результате действия этой команды стали видны все объекты спецификации, вы можете включить опцию показа в таблице для каждого конкретного объекта.

2. Выделите объект в таблице спецификации и активизируйте переключатель Показывать объект в таблице, расположенный на Панели свойств.

Настроенный таким образом объект будет показываться в таблице спецификации в любом режиме.

3. Для отключения режима показа всех объектов вызовите команду Показать все объекты еще раз. При этом соответствующая кнопка окажется отжатой.

Для отключения показа объекта в таблице необязательно входить в режим показа всех объектов. Просто выключите для этого объекта переключатель Показывать объект в таблице.


6.2.6.8. Сохранение спецификации в других форматах

Иногда спецификацию требуется передать на другие рабочие места или на другие предприятия. При этом может оказаться, что целевое рабочее место не оснащено системой КОМПАС-3D и поэтому на нем нельзя работать со спецификацией КОМПАС-3D.

Чтобы сделать доступными просмотр и распечатку спецификации на таких рабочих местах, спецификацию (файл *.spw) можно экспортировать в файлы других форматов.

В этом разделе:

6.2.6.8.1. Экспорт во фрагмент

6.2.6.8.2. Экспорт в форматы DXF, DWG и IGES

6.2.6.8.3. Экспорт в форматы баз данных


6.2.6.8.1. Экспорт во фрагмент

Вы можете экспортировать текущую спецификацию в файл фрагмента КОМПАС-3D (*.frw). Для этого выполните следующие действия.

1. Подключите библиотеку Сервисные инструменты (файл komlib.rtw).

2. Из ее раздела Операции со спецификацией вызовите команду Преобразовать спецификацию во фрагмент.

Если в момент вызова команды в КОМПАС-3D была активна спецификация, будет экспортироваться эта (текущая) спецификация.

Если в момент вызова команды текущим документом была не спецификация, система выдаст стандартный диалог выбора файла для открытия. Укажите в нем нужную спецификацию.

Если в экспортируемой спецификации больше одной страницы, на экране появится диалог компоновки (рис. 6.2.33).

3. Укажите в нем, каким образом размещать страницы спецификации на поле фрагмента (табл. 6.2.6).

Рис. 6.2.33. Диалог компоновки листов спецификации

Табл. 6.2.6. Элементы управления диалога компоновки

Элемент управления

Описание

Спецификация

Справочное поле, в котором указано полное имя файла сохраняемой спецификации.

Количество
листов

Справочное поле, в котором указано количество листов сохраняемой спецификации.

Размер
каждого листа

Справочное поле, в котором указан размер листов сохраняемой спецификации (в миллиметрах).

Количество
листов
спецификации
в ряду

В это поле можно ввести количество листов спецификации, которое должно быть размещено в горизонтальном ряду.

При постоянном общем количестве листов указанное количество одновременно однозначно определяет количество рядов, в котором разместятся все листы спецификации.

Интервал
между листами

В это поле можно ввести расстояние (в миллиметрах), которое нужно оставить между внешними рамками соседних листов спецификации.

Общий габарит

В этом справочном поле указан общий габарит, который будет иметь изображение экспортированной спецификации при выбранной компоновке.

Для изменения общего габарита (например, чтобы разместить спецификацию на листе бумаги заданного формата) измените величину зазора между листами и их расположение в рядах.

Каждый лист
спецификации записывать
макроэлементом

Если эта опция включена, то отрезки и тексты, составляющие каждый лист спецификации, в результирующем файле образуют макроэлемент.

4. После задания всех параметров компоновки нажмите кнопку OK для начала экспорта.

Система создаст новый фрагмент и разместит в нем изображение листов спецификации. Это изображение будет состоять из графических объектов КОМПАС-3D — отрезков и текстов. В случае включения соответствующей опции они будут собраны в макроэлементы.

Вся информация, касающаяся исходной спецификации (объекты, настройки и т.д.), во фрагменте будет утрачена. В нем останутся только текстовые части объектов (в виде отдельных текстов в ячейках), таблица спецификации (в виде отрезков) и основная надпись (в виде отрезков и отдельных текстов в ячейках).

В получившемся фрагменте доступны все средства редактирования графических документов системы КОМПАС-3D.

Никакой связи между новым фрагментом и исходной спецификацией не возникает. Поэтому не следует ожидать, что вносимые в спецификацию изменения будут отражаться в полученном из нее фрагменте.


6.2.6.8.2. Экспорт в форматы DXF, DWG и IGES

Вы можете экспортировать спецификацию в форматы DXF, DWG и IGES. Для этого выполните следующие действия.

1. Откройте спецификацию, которую требуется экспортировать.

2. Вызовите команду Файл — Сохранить как и в поле Тип файла появившегося диалога выберите нужное расширение файла (dxf, dwg или igs).

3. Нажмите кнопку Сохранить.

При выборе в списке Тип файла строки DXF или DWG в диалоге появляется кнопка Параметры. Она вызывает диалог настройки записи документа в выбранный формат. В нем можно указать номер версии формата, настроить экспорт текста и спецзнаков. Для многостраничной спецификации можно задать параметры размещения страниц на поле результирующего документа (количество листов в ряду и интервал между листами). Завершив настройку, закройте диалог кнопкой ОК, а затем нажмите кнопку Сохранить диалога сохранения файлов.

Для формата IGES настройка экспорта невозможна.

Система создаст файл требуемого формата и разместит в нем изображение листов спецификации. Изображение (как и при экспорте во фрагмент) будет состоять из отрезков и текстов.

Хотя полученные в результате экспорта файлы утрачивают свойства спецификации КОМПАС-3D (порядок заполнения документа, связь со сборочным чертежом, возможность автосортировки и простановки позиций и т.д.) и не могут в дальнейшем редактироваться средствами Модуля проектирования спецификаций, они незаменимы при необходимости просмотра и печати спецификаций на тех рабочих местах, где отсутствует возможность работы с файлами спецификаций КОМПАС-3D.


6.2.6.8.3. Экспорт в форматы баз данных

Для передачи данных в автоматизированные системы управления производством может понадобиться преобразование спецификации в файл формата dBase III DOS, dBase III Windows или Excel.

Чтобы экспортировать спецификацию в таблицу базы данных, выполните следующие действия.

1. Подключите библиотеку Сервисные инструменты (файл komlib.rtw).

2. Из ее раздела Операции со спецификацией вызовите команду Экспорт спецификации.

После вызова команды на экране появляется диалог настройки параметров экспорта спецификации (рис. 6.2.34 – 6.2.37).

3. Задайте в нем параметры экспорта (табл. 6.2.7 – 6.2.10).

4. После настройки параметров экспорта спецификации нажмите кнопку Начать запись.

Более быстрый способ записи текущей спецификации в файл формата Excel — вызов команды Файл — Сохранить как... В появившемся диалоге следует ввести имя файла, из списка Тип файла выбрать строку Файлы Excel (*.xls) и нажать кнопку Сохранить.

Спецификация будет сохранена в умолчательной конфигурации в файл формата Excel.

Рис. 6.2.34. Диалог настройки параметров экспорта спецификации.
Вкладка Файл

Табл. 6.2.7. Диалог настройки параметров экспорта спецификации. Вкладка Файл
Элемент управления | Описание
Текущий | Включенная опция означает, что будет экспортироваться текущий документ.
Выбрать документ | Эта кнопка позволяет выбрать спецификацию для экспорта.
Документ | В этом поле отображается имя экспортируемой спецификации.
Записать в файл | В этом поле отображается имя создаваемого файла.
Выбрать файл | Эта кнопка позволяет указать путь к создаваемому файлу.
Формат | Список служит для выбора типа создаваемого файла.

Рис. 6.2.35. Диалог настройки параметров экспорта спецификации.
Вкладка Объекты

Табл. 6.2.8. Диалог настройки параметров экспорта спецификации. Вкладка Объекты
Элемент управления | Описание
Включить объекты | В этом окне отображаются типы строк, существующих в активной спецификации: – Базовые объекты, – Вспомогательные объекты1, – Заголовки разделов1, – Резервные строки1, – Пустые строки1, – Заголовки блоков исполнений1. Те из них, которые будут передаваться в таблицу базы данных, помечены «галочкой» в колонке Включить. Чтобы исключить строки определенного типа из состава экспортируемых, щелкните на «галочке» левой кнопкой мыши.
  1. При экспорте в таблицу БД резервных и пустых строк создаются записи с пустыми полями, а при экспорте заголовков разделов и блоков исполнений (а иногда и вспомогательных объектов) создаются малоинформативные записи (например, с текстом «Детали» в поле Наименование). Как правило, такие записи бесполезны при обработке базы данных системами управления производством (или иными экспертными и аналитическими программами). Поэтому обычно экспорт соответствующих строк отключается. Чтобы записи, образованные из базовых объектов спецификации, не потеряли информацию о том, какому разделу они принадлежат, в эти записи включают специальные поля (см. табл. 6.2.9).

Рис. 6.2.36. Диалог настройки параметров экспорта спецификации.
Вкладка Поля

Табл. 6.2.9. Диалог настройки параметров экспорта спецификации. Вкладка Поля

Элемент управления

Описание

Включить
колонки

В этом окне в виде таблицы перечислены колонки активной спецификации и соответствующие им поля с текущими настройками.

Поля, которые будут передаваться в таблицу базы данных, помечены «галочкой» в колонке Включить. Чтобы изменить параметры (имя, длину и т.п.) какого-либо поля спецификации в новом документе или исключить поле из состава экспортируемых, дважды щелкните мышью на соответствующей строке таблицы.

Дополнительные колонки

Эта опция управляет экспортом всех дополнительных колонок. При ее включении дополнительные колонки помечаются «галочкой». Если требуется экспортировать одни доп. колонки и не экспортировать другие, дважды щелкайте мышью по соответствующим строкам и в появившемся диалоге включайте/выключайте опцию Включить поле.

Специальные
колонки

Эта опция управляет экспортом всех специальных колонок1. При ее включении специальные колонки помечаются «галочкой». Если требуется экспортировать одни специальные колонки и не экспортировать другие, дважды щелкайте мышью по соответствующим строкам и в появившемся диалоге включайте/выключайте опцию Включить поле.
  1. При экспорте в базу данных для каждого объекта спецификации создается отдельная запись. Ее поля соответствуют колонкам бланка спецификации и дополнительным колонкам. Однако в этом случае теряется информация о типе объекта и о том, какому разделу он принадлежит. Чтобы сохранить эту информацию, к записи можно добавить специальные поля — Номер раздела, Тип объекта и т.п. Именно для управления созданием этих полей служит опция Специальные колонки.

Рис. 6.2.37. Диалог настройки параметров экспорта спецификации.
Вкладка Разделы

Табл. 6.2.10. Диалог настройки параметров экспорта спецификации. Вкладка Разделы

Элемент управления

Описание

Включить
разделы

В этом окне отображаются разделы, существующие в текущей спецификации. Те из них, объекты которых будут экспортироваться, помечены «галочкой». Чтобы исключить раздел из состава экспортируемых (или включить ранее выключенный раздел), щелкните на нем левой кнопкой мыши.

Конфигурация

Чтобы сохранить созданную конфигурацию спецификации для экспорта (формат, экспортируемые и не экспортируемые разделы, объекты, поля и т.п.), введите имя новой конфигурации в поле ввода и нажмите кнопку Сохранить.

Сохраненную конфигурацию можно использовать при последующих вызовах команды экспорта спецификации в формат БД.

Чтобы удалить существующую конфигурацию, выберите ее имя из списка и нажмите кнопку Удалить.


6.2.6.9. Дополнительные листы

Спецификация КОМПАС-3D может иметь дополнительные листы в начале и в конце. Эта возможность позволяет, например, создавать и хранить вместе с самой спецификацией лист регистрации изменений. Дополнительные листы учитываются при автоматической нумерации листов.

Управление дополнительными листами, включающее в себя их создание, удаление, задание и редактирование свойств листов, производится следующими способами:

– в Менеджере документа, вызываемом нажатием одноименной кнопки на панели Стандартная (диалог подробно описан в разделе 3.6.6.2, изменение параметров листов, добавление и удаление — в разделах 3.6.2.1–3.6.2.3);

– в диалоге настройки параметров текущей спецификации, вызываемом командой Сервис — Параметры... — Текущая спецификация — Дополнительные листы (см. раздел 9.2.5.1.3).

Чтобы дополнительные листы отображались на экране, следует переключиться в режим Разметка страниц (см. раздел 6.2.2.9). В этом же режиме производится ввод текста в таблицы на дополнительных листах.

Если вы используете один и тот же набор дополнительных листов в большинстве спецификаций, то выполнение соответствующей настройки в каждом документе нерационально. В этом случае можно сделать так, чтобы все новые спецификации сразу создавались с требуемыми дополнительными листами.

Для этого вызовите команду Сервис — Параметры... — Новые документы — Спецификация — Дополнительные листы.


6.2.6.10. Нумерация листов

Настройка нумерации листов текущей спецификации выполняется в диалоге Нумерация листов, вызываемом командой Сервис — Параметры... — Текущая спецификация — Нумерация листов. Работа в диалоге описана в разделе 9.2.4.6.


6.2.6.11. Настройка отображения значений массы

Вы можете задать единицы измерения массы и точность отображения ее значения для использования в соответствующих колонках спецификации, например, в колонке Масса плазовой спецификации или в дополнительной колонке Масса.

Чтобы настроить отображение массы для нового документа-спецификации, вызовите команду Сервис — Параметры... — Новые документы — Спецификация — Отображение величин. В появившемся диалоге выберите единицу измерения массы и задайте количество знаков после запятой в значении массы.

Если требуется изменить настройку отображения массы для существующего документа-спецификации, вызовите команду Сервис — Параметры... — Текущая спецификация — Отображение величин.

Настройка отображения массы для объектов спецификации графического документа или модели хранится в описании спецификации, используемом этими объектами. Чтобы изменить настройку, вызовите команду Спецификация — Управление описаниями спецификаций..., в появившемся диалоге выберите описание и нажмите кнопку Редактировать описание. В появившемся диалоге настройки описания текущей спецификации выберите единицу измерения массы и задайте количество знаков после запятой в значении массы (см. рис. 6.2.23). Если документ уже подключен к спецификации, то изменение настройки невозможно — она совпадает с настройкой спецификации (см. рис. 6.2.25).

После изменения единицы измерения массы значения в соответствующих ячейках документа-спецификации или объекта спецификации пересчитываются. Также значение массы пересчитывается:

– при передаче объектов спецификации между документами, если в них используются разные настройки отображения значения массы,

– при передаче значения массы между объектом спецификации и подключенным к нему документом (чертежом или моделью), если в спецификации и документе используются различные единицы измерения массы.

Заданное количество знаков после запятой применяется только для отображения значения массы. То есть в ячейке постоянно хранится значение массы с той точностью, с которой оно было введено пользователем или получено из подключенного документа (чертежа или модели), а отображается в ячейке значение, округленное до указанного знака.


6.2.6.12. Спецификация на чертеже

Объекты спецификации, имеющиеся в чертеже, можно разместить в таблице спецификации на этом же чертеже. Необходимым условием для этого является следующее: к чертежу не должна быть подключена спецификация того же стиля, что и объекты спецификации, которые требуется разместить на чертеже.

Соответственно, чертеж, на котором размещена таблица спецификации определенного стиля, невозможно подключить к спецификации этого же стиля. Чтобы подключение было возможно, необходимо отменить размещение спецификации на листе.

Стили объектов спецификации в чертеже определяются описаниями спецификаций (см. раздел 6.1.3.4), имеющимися в этом чертеже.

Обычно чертеж имеет одно описание спецификации. Это описание является текущим.

В этом разделе:

6.2.6.12.1. Размещение на чертеже спецификации текущего стиля

6.2.6.12.2. Размещение на чертеже спецификаций разных стилей

6.2.6.12.3. Название спецификации на чертеже


6.2.6.12.1. Размещение на чертеже спецификации текущего стиля

Чтобы разместить спецификацию на чертеже, вызовите команду Спецификация — Спецификация на листе — Показать. Команда доступна, если к чертежу не подключена спецификация текущего стиля.

После вызова этой команды над основной надписью чертежа появляется таблица. Она содержит объекты спецификации, имеющиеся в чертеже.

Все параметры этой таблицы (количество и формат колонок, заголовок, расположение объектов на страницах и т.п.) соответствуют параметрам таблицы, входящей в основную надпись текущего стиля спецификации как Таблица для спецификации.

На эту таблицу распространяются все настройки текущего стиля спецификации (количество резервных строк, сортировка и т.п.). Короче говоря, эта таблица с объектами — спецификация текущего стиля без рамок и собственного штампа.

Обозначение и наименование чертежа влияет на отображение объектов спецификации, содержащих код и наименование документа. Это влияние аналогично влиянию обозначения и наименования спецификации на объекты в ней (см. раздел 6.2.2.10).

При создании новых объектов спецификации в чертеже они автоматически попадают в таблицу спецификации на листе.

Двойной щелчок мышью по таблице запускает подчиненный режим редактирования объектов спецификации. Все сделанные в нем изменения после закрытия окна этого режима передаются в спецификацию на листе.

Для перемещения таблицы по листу служит команда Спецификация — Спецификация на листе — Размещение (или команда Ручное размещение из контекстного меню).

Вы можете создать пользовательский стиль, например, для таблицы соединений или перечня элементов, а затем разместить таблицу соединений на листе с электрической схемой или перечень элементов на листе с кинематической схемой. Если при работе над схемой будут созданы соответствующие объекты, содержащие геометрию, впоследствии это облегчит поиск изображения проводника или элемента схемы.

Чтобы отключить отображение спецификации на листе, вызовите команду Спецификация — Спецификация на листе — Показать повторно.


6.2.6.12.2. Размещение на чертеже спецификаций разных стилей

Команда Спецификация — Спецификация на листе — Показать позволяет разместить на листе только одну спецификацию — спецификацию текущего стиля.

Чтобы включить размещение на листе спецификаций других стилей (если чертеж содержит несколько описаний спецификаций), вызовите диалог управления описаниями спецификаций (рис. 6.2.38). Для этого служит команда Спецификация — Управление описаниями спецификаций...

Рис. 6.2.38. Диалог управления описаниями спецификаций

Выберите в списке описание, содержащее нужный стиль, и нажмите кнопку Включить отображение на листе. Эта кнопка доступна только для тех описаний, которые не содержат имени файла спецификации.

Если спецификация размещена на листе, то напротив соответствующего описания спецификации отображается «галочка» в колонке На листе.

Закройте диалог управления описаниями спецификаций кнопкой Выход. Таблица спецификации, содержащая объекты спецификации выбранного стиля, появится на листе чертежа.

Кнопка Выключить отображение на листе диалога управления описаниями спецификации позволяет отменить размещение спецификации на листе.


6.2.6.12.3. Название спецификации на чертеже

Название спецификации — текст над таблицей спецификации, расположенной на листе. Название спецификации может состоять из нескольких строк. Текст названия вводится пользователем. При этом можно задать различные названия для первого и последующих листов спецификации.

Название можно ввести только для спецификации, размещенной на чертеже (см. разделы 6.2.6.12.1 и 6.2.6.12.2). Для задания названия спецификации выполните следующие действия.

1. Вызовите команду Название... из меню Спецификация — Спецификация на листе или из контекстного меню спецификации на листе.

2. В появившемся на экране диалоге введите названия для первого и последующих листов спецификации. Если длина введенной строки превышает ширину таблицы спецификации, происходит автоматическое сужение символов. Для перехода на новую строку нажмите клавишу <Enter>. При необходимости вы можете изменить любые параметры форматирования текста: шрифт, высоту, выравнивание и отступы абзацев и т.п.

3. Закройте диалог кнопкой ОК. Над таблицей (таблицами) спецификации появится название (названия).

Разбиение таблицы спецификации на листы производится в подчиненном режиме работы со спецификацией при помощи переключателя Размещать на новом листе (см. раздел 6.2.6.5).

В дальнейшем, чтобы отредактировать имеющееся название спецификации, вызовите команду Название... повторно. Можно также дважды щелкнуть на названии спецификации.

Название спецификации задается для конкретного стиля спецификации и сохраняется в чертеже.

Если при настройке системы в разделе Текстовый редактор — Текстовые шаблоны включена опция Сохранять введенный текст в файле, то введенные вручную названия для листов спецификации на чертеже автоматически сохраняются в файле текстовых шаблонов. Они располагаются в разделе Спецификация — Название спецификации на листе чертежа этого файла (см. рис. 6.2.13).

В дальнейшем для вызова Библиотекаря текстовых шаблонов и использования сохраненных названий следует дважды щелкнуть мышью в поле ввода текста диалога задания названия спецификации.

Команда Спецификация — Спецификация на листе — Название... позволяет работать с названием спецификации текущего стиля. Если на листе чертежа отображаются таблицы спецификаций разных стилей, то для ввода или редактирования их названий пользуйтесь командой Название... из контекстных меню этих таблиц.

Расстояние от спецификации до названия одинаково для всех таблиц спецификации, отображающихся на листе. Оно задается в диалоге настройки параметров названия спецификации на листе. Умолчательное расстояние — 5 мм. В диалоге настройки параметров названия спецификации на листе можно настроить также умолчательные параметры текста названия. Для вызова этого диалога служит команда Сервис — Параметры... — Текущий чертеж — Параметры документа — Название спецификации на листе.


6.2.6.13. Таблица изменений

Чтобы внести в текущий чертеж информацию об изменениях, выполните следующие действия.

1. Назначьте чертежу одно из оформлений — Чертеж констр. с ТИ. Первый лист. ГОСТ 2.104-2006 или Чертеж констр. с ТИЗ. Первый лист. ГОСТ 2.104-2006 (ТИЗ —таблица изменений с зонами). Можно также выбрать аналогичные оформления для последующих листов чертежа.

2. Вызовите команду Спецификация — Добавить объект таблицы изменений.

3. В появившемся окне ввода текстовой части заполните ячейки и нажмите кнопку OK.

Заполненная вами строка появится в главной таблице основной надписи чертежа.

Чтобы отредактировать строки таблицы изменений, вызовите команду Спецификация — Редактировать объекты таблицы изменений.

Система перейдет в подчиненный режим редактирования текстовой части объектов.

Приемы работы в нем — такие же, как при редактировании объектов спецификации в чертеже.

Таблица изменений заполняется снизу вверх. Строки в ней сортируются по возрастанию номера.

К объекту таблицы изменений можно подключить геометрию из чертежа.


6.2.6.14. Объекты разных спецификаций в одном чертеже

При создании в чертеже первого объекта спецификации этот объект создается в соответствии со стилем, установленным в системе для новых спецификаций. При этом чертеж автоматически получает описание спецификации (см. раздел 6.1.3.4). Следующие объекты создаются с этим же стилем.

В диалоге управления описаниями спецификаций в чертеже вы можете создать более одного описания спецификации (см. раздел 6.2.4.1.1). К одному документу могут быть подключены спецификации только разных стилей.

Описание, отмеченное «галочкой» в колонке Текущий диалога управления описаниями, считается текущим. Входящий в него стиль считается текущим стилем спецификации.

Объекты спецификации в чертеже создаются в соответствии со стилем, входящим в текущее описание, и передаются в документ-спецификацию, входящую в текущее описание (если вообще существует подключенная спецификация).

Если, находясь в чертеже, вы вызываете команду создания объекта спецификации, то на экране появляется окно ввода текстовой части нового объекта, содержащее колонки и «шапку», соответствующие бланку текущего стиля спецификации.

В подчиненном режиме редактирования объектов можно увидеть только объекты, созданные в соответствии с текущим стилем спецификации. После того как вы сделаете текущим другое описание (для этого выделите его в диалоге управления описаниями и нажмите кнопку Сделать текущим), создаваться будут объекты, соответствующие текущему стилю, а в подчиненном режиме станут видны объекты спецификации текущего стиля (при этом объекты спецификации других стилей не удалятся из чертежа, а будут просто не видны).

Команды синхронизации работают со спецификацией, входящей в текущее описание.

По умолчанию на чертеже размещается спецификация текущего стиля. Если необходимо показать на чертеже спецификации других стилей, вызовите диалог управления описаниями и включите в нем отображение на листе для нужных описаний спецификаций (см. раздел 6.2.6.12.2).

Создание в чертеже объектов для спецификаций разных стилей и передача их в разные документы-спецификации принципиально отличается от смены стиля спецификации. При смене стиля одни и те же объекты одной спецификации могут отображаться в другом бланке, попадать в разделы с другими заголовками, иметь другой состав колонок (подробнее о смене стиля спецификации — см. раздел 6.4.3). А при работе с разными описаниями создаются автономные группы объектов, каждая из которых передается в отдельный документ-спецификацию.

Вообще говоря, работа с несколькими описаниями спецификаций в одном чертеже — нетипичный прием создания спецификаций. Его нужно применять только когда создание нескольких спецификаций на базе одного сборочного чертежа четко обосновано.

Создайте в сборочном чертеже два описания спецификаций — собственно спецификацию и ведомость покупных изделий. После того как вы внесете в них объекты, эти объекты можно будет передать в два разных документа — в спецификацию и в ведомость покупных изделий.


6.2.6.15. Объекты-«двойники»

Объекты-«двойники» — объекты одного раздела, содержащие одинаковые данные в колонке, по которой производится сортировка. Они могут возникнуть в результате копирования объектов, вставки в чертеж или спецификацию одинаковых изделий из Справочника Стандартные Изделия, ввода одинаковой текстовой части объектов и т.д.

При автоматической сортировке этим объектам присваиваются одинаковые номера позиций и у всех них, кроме одного (созданного первым), выключается показ объекта в таблице. Поэтому в обычном режиме такие объекты видны как один объект спецификации.

Вы можете в любой момент включать и отключать режим показа всех объектов спецификации (см. раздел 6.2.6.7). В этом режиме в таблице спецификации видны все объекты, в том числе и те, у которых любым способом (автоматически или вручную) отключен показ.

Если вывод спецификации на печать начать из этого режима, будут напечатаны все объекты.

Если изображение объекта спецификации (например, детали) находится в разных листах сборочного чертежа, создайте несколько объектов с одинаковой текстовой частью и подключите к каждому из них соответствующие графические объекты одного из листов сборки (в том числе позиционную линию-выноску).

В этом случае можно будет легко найти геометрию детали в любом листе сборки (для этого нужно включить показ всех объектов и показ геометрии объектов).

А при пересчете номеров позиций (например, в результате создания новых объектов) номер на линии-выноске детали будет изменяться во всех листах.

Если в сборочном чертеже существует несколько групп одинаковых стандартных изделий, создайте объект спецификации, содержащий позиционную линию-выноску, для каждой из них. Например, две разные крышки крепятся одинаковыми винтами.

Создайте объект с позиционной линией-выноской для винтов одной крышки и объект с позиционной линией-выноской для винтов другой крышки. Они автоматически получат одинаковый номер (и на линиях-выносках также будут одинаковые номера позиций). В режиме просмотра всех объектов и показа геометрии объектов спецификации будет легко найти каждую группу винтов.

А если вы измените, например, диаметр винтов, крепящих одну из крышек, то объекты спецификации станут отличаться, автоматически получат разные номера (соответствующие новому порядку их сортировки), будут видны в спецификации в обычном режиме, и на их линиях-выносках появятся отличающиеся номера позиций. Вам нужно будет только изменить числа в колонке Количество.


6.2.6.16. Использование марок/позиционных обозначений

Марки/позиционные обозначения — буквенно-цифровые обозначения объектов, изображенных на чертежах. Марки/позиционные обозначения можно считать аналогами обозначений позиций, отличительной особенностью которых является наличие марки — текста перед номером позиции.

Марки/позиционные обозначения в графических документах создаются с помощью команд:

– Марка/позиционное обозначение с линией-выноской,

– Марка/позиционное обозначение без линии-выноски,

– Марка/позиционное обозначение на линии.

Эти команды подробно описаны в разделах 3.3.8.3–3.3.8.5.

Объекты спецификации могут иметь марку — текст перед номером позиции. Вместе с номером марка размещается в колонке Позиция. Марка задается для раздела спецификации и автоматически присваивается каждому базовому объекту этого раздела.

Чтобы включить в разделе спецификации использование марки, выполните следующие действия:

1. Вызовите команду Формат — Настройка спецификации.

2. В появившемся на экране диалоге настройки спецификации перейдите на вкладку Разделы.

3. Выделите нужный раздел в списке и нажмите кнопку Редактировать стиль раздела.

4. В появившемся на экране диалоге настройки стиля раздела (см. рис. 6.4.3) включите опцию Марка и введите ее текст.

При включении опции Марка становится доступна опция Независимая нумерация позиций. Она позволяет начинать нумерацию позиций объектов раздела заново — с номера, указанного в качестве начальной позиции.

5. Закройте диалог настройки стиля раздела, а затем — диалог настройки спецификации кнопкой ОК.

Все объекты выбранного раздела получат заданную марку. Она же будет добавляться к новым объектам этого раздела.

Блоки дополнительных разделов спецификации могут иметь собственную марку и независимую нумерацию разделов. Настройка марки и нумерации позиций для блока производится в диалоге настройки блока разделов (см. рис. 6.4.8).

Как и обозначение позиции, марку/позиционное обозначение можно связать с объектом спецификации, включив в состав этого объекта. В результате марки/позиционные обозначения в чертеже будут получать номера позиций и марки из спецификации. Эта передача будет происходить при синхронизации спецификации с чертежом.

Цифры в составе марки/обозначения позиции могут выполнять функции не только номера позиции, но и другие, например, они могут показывать номер элемента в проекте. Поэтому передача номеров позиций из спецификации в марки/позиционные обозначения может быть нежелательна.

Чтобы отменить присвоение объектам спецификации новых номеров, отключите в спецификации расчет позиций (см. рис. 6.4.1). В результате объекты будут сортироваться согласно правилам, заданным в стиле, но номера позиций будут оставаться прежними. Изменение номеров, сделанное вручную, будет передаваться как из чертежа в спецификацию, так и из спецификации в чертеж.

При подключении марки/позиционного обозначения к объекту спецификации марка обозначения заменяется маркой объекта спецификации, при этом ручное изменение марки на чертеже становится невозможным.

В отличие от обозначения позиции, одну и ту же марку/позиционное обозначение нельзя подключить к нескольким объектам спецификации.


6.2.6.17. Обозначения позиций в модели сборки

Как и в чертеже, в сборке могут быть созданы позиционные линии-выноски.

Благодаря тому, что сборка имеет четкую структуру, возможно автоматическое включение позиций в состав объектов спецификации, связанных с деталями и подсборками. Для автоматического включения позиций в состав объектов спецификации действуйте одним из следующих способов.

Способ 1 (для компонентов)

1. Создайте компоненты сборки с объектами спецификации, вставьте их в сборку.

2. Проставьте позиционные линии-выноски. Каждая линия-выноска будет автоматически включена в состав объекта спецификации, связанного с компонентом, к которому она проставлена. Благодаря этому на полках линий-выносок будут появляться номера позиций из объектов спецификации.

Способ 2 (для компонентов и тел)

1. Вставьте в сборку компоненты, постройте необходимые тела.

2. Проставьте позиционные линии-выноски к компонентам и телам.

3. Создайте объекты спецификации, выделяя компоненты (или тела) и вызывая команду Спецификация — Добавить объекты — Внутренние (подробнее — см. описание способа № 4 в разделе 6.2.3.4.2). В каждый объект спецификации будет автоматически включена позиционная линия-выноска, указывающая на выделенный компонент (или тело).

Вне зависимости от того, какой способ использован для автоматического включения позиций в состав объектов спецификации, выполняются следующие правила.

– Если позиционные линии-выноски указывают на разные компоненты одной и той же подсборки, то все эти линии-выноски включаются в один объект спецификации (соответствующий подсборке) и получают один и тот же номер позиции.
Аналогично, если позиционные линии-выноски указывают на разные части одного и того же тела, то все они включаются в один объект спецификации (соответствующий телу) и получают один и тот же номер позиции.

– Если разные ответвления позиционной линии-выноски указывают на разные компоненты сборки, то эта линия-выноска включается в несколько объектов спецификации (соответствующих компонентам), их номера позиций размещаются на полках линии-выноски.

– Если в сборке есть несколько вставок одного и того же компонента, то в ней формируются объекты спецификации — «двойники» (см. раздел 6.2.6.15).

• Если на вставки указывают разные позиционные линии-выноски, то каждая из них включается в состав одного из объектов-двойников. Так как номера позиций у объектов-двойников совпадают, вставки получают один и тот же номер позиции.

• Если на вставки указывают разные ответвления одной и той же позиционной линии-выноски, то эта линия-выноска включается в состав каждого объекта-двойника.

Чтобы убедиться в том, что позиционные линии-выноски включены в состав внутренних объектов спецификации сборки, просмотрите геометрию этих объектов (см. раздел 6.2.3.5.2).

Если объекты спецификации, связанные с компонентами, созданы после простановки позиционных линий-выносок — с помощью команды Создать объекты спецификации... или вручную в файлах компонентов — то автоматическое включение линий-выносок в состав объектов спецификации не происходит. В этом случае можно добавить позиции в состав объектов вручную (см. раздел 6.2.3.5.1).

Позиционные линии-выноски, входящие в состав объектов спецификации, отмечаются в Дереве построения буквами «СП» в круглых скобках. Буквы добавляются перед названием линии-выноски, например: «(СП) Обозначение позиции:5».

Позиционные линии-выноски передаются в ассоциативный чертеж сборки, как и другие обозначения. Если позиционная линия-выноска была включена в состав объекта спецификации в сборке, то она включается в состав этого же объекта спецификации в чертеже.


6.2.6.18. Объединение вариантов описаний спецификаций в документе

В одном и том же документе может оказаться несколько описаний спецификации, которые содержат аналогичные друг другу стили спецификации. Аналогичными считаются стили, взятые из библиотек с одним и тем же именем файла (например, Graphic.lyt) и имевшие в этих библиотеках один и тот же номер. При этом, если все параметры аналогичных стилей совпадают, они считаются дублями друг друга, а если отличаются (например, количеством дополнительных колонок), то — вариантами.

Несколько описаний с аналогичными друг другу стилями спецификации могут появиться, например, в сборке при вставке в нее деталей, созданных в версиях КОМПАС-3D, которые содержали разные редакции одного и того же стиля спецификации. В результате в сборке образуется столько групп объектов спецификации, сколько описаний. Просматривать эти группы можно только по отдельности. Объединение вариантов описаний спецификаций позволяет свести все группы в одну.

Объединение вариантов описаний производится в диалоге управления описаниями спецификации, вызываемом командой Спецификация — Управление описаниями спецификаций. Если в документе есть описания, содержащие дубли или варианты одного и того же стиля спецификации, в данном диалоге появляется кнопка Объединить варианты, которая позволяет свести все эти описания в одно. Кроме кнопки Объединить варианты в диалоге появляется колонка Вариант, в которой указано, дублем или вариантом является каждый стиль по отношению к образцу (рис. 6.2.39). Образцом считается стиль, содержащийся в первом из описаний, составляющих группу описаний с аналогичными стилями спецификации. Стиль-образец имеет в колонке Вариант прочерк.

Рис. 6.2.39. Диалог управления описаниями спецификаций

После нажатия кнопки Объединить варианты происходит следующее.

1. Если в документе есть описания, содержащие ненайденный стиль спецификации (т.е. стиль, чей номер отсутствует в библиотеке, откуда этот стиль был взят, или стиль, для которого не найдена сама библиотека), пользователю предлагается заменить стиль в каждом из этих описаний (рис. 6.2.40). После нажатия в диалоге кнопки Да на экране появляется диалог для указания библиотеки стилей и выбора стиля из нее.

Рис. 6.2.40. Запрос на замену стиля спецификации

Обратите внимание на то, что в случае отказа от замены стиля объединение прерывается.

2. После замены производится проверка, нет ли среди указанных стилей дублей или вариантов стиля-образца.

3. Приведение стилей спецификации в описаниях к стилю-образцу.

3.1. В описаниях, содержащих дубль или вариант стиля, информация об этом стиле заменяется информацией о стиле-образце.

3.2. Объекты спецификации, использовавшие дубль или вариант стиля, преобразуются в объекты спецификации со стилем-образцом. При этом в объекте происходят такие же изменения, как и в спецификации при смене стиля, см. раздел 6.4.3.

3.3. Объекты спецификации, использовавшие описания с дублями или вариантами описания, переносятся в группу объектов, использующих описание со стилем-образцом.

3.4. Описания, переставшие использоваться в объектах спецификации, удаляются из документа.

Если в сборке при объединении описаний спецификации обнаруживается пара одинаковых объектов спецификации, один из которых «пришел» из файла компонента, а другой был автоматически создан на основе свойств этого компонента (см. п. 2 в разделе 6.2.3.4.2), то последний удаляется.

Описанные в п.3 изменения производятся также в файлах — источниках объектов спецификации, если объекты переданы в текущий документ из других файлов (фрагментов или компонентов). Если какие-либо из источников в данный момент недоступны, то при обработке первого из них на экране появляется сообщение о том, что объединение описаний не удалось (рис. 6.2.41). Нажав в сообщении нужную кнопку, вы можете сохранить список необработанных документов в файл или отказаться от сохранения. В любом случае объединение описаний прерывается, т.е. оставшиеся файлы не обрабатываются. Устраните проблемы в документах — источниках объектов спецификаций, а затем попытайтесь объединить описания спецификаций еще раз.

Рис. 6.2.41. Сообщение о невозможности объединения описаний спецификации

После успешного объединения описаний на экране появляется сообщение об этом. В диалоге управления описаниями каждая группа описаний, содержавших дубли или варианты одного и того же стиля спецификации, заменяется одним описанием со стилем-образцом.

После объединения описаний спецификаций сохраните документ.


6.2.7. Частные приемы формирования спецификаций

6.2. Приемы работы со спецификацией

6.2.7. Частные приемы формирования спецификаций

В данном разделе рассматриваются приемы создания сложных вариантов групповых спецификаций, а также спецификаций с вложенными и дополнительными разделами.

В этом разделе:

6.2.7.1. Групповые спецификации

6.2.7.1.1. Групповая спецификация по варианту Б

6.2.7.1.2. Групповая спецификация по варианту А

6.2.7.1.3. Редактирование номеров исполнений

6.2.7.2. Спецификации с вложенными и дополнительными разделами


6.2.7.1. Групповые спецификации

Если специфицируемое изделие имеет более одного исполнения, то стандарт предписывает создавать групповые спецификации.

В КОМПАС-3D возможно создание следующих групповых спецификаций по ГОСТ 2.113–75:

– вариант Б по формам 1, 1а, 1б, 1в,

– вариант Б с числом исполнений не более трех по форме 5,

– вариант А по формам 1 и 1а (ГОСТ 2.106–96).

Общий порядок действий при создании групповой спецификации следующий.

1. Создание спецификации (см. раздел 6.2.2.1).

2. Смена стиля созданной спецификации, т.е. выбор стиля, соответствующего варианту, в котором выполняется спецификация (см. раздел 6.2.2.2.1).

3. Настройка текущей спецификации.

3.1. Задание количества исполнений специфицируемого изделия (см. раздел 6.4.2.1).

3.2. Настройка блоков исполнений (см. раздел 6.4.2.3).

4. Заполнение спецификации.

Особенность ввода текстовой части объектов групповых спецификаций состоит в том, что при их создании доступна не одна, а несколько ячеек для ввода количества. Их число равно количеству исполнений специфицируемого изделия, указанному при настройке спецификации. При вводе и редактировании любого объекта групповой спецификации пользователь может задать количество этого объекта для каждого исполнения.

Для удобства работы номер текущего исполнения — исполнения, в ячейке которого находится курсор — отображается в Строке сообщений в нижней части окна КОМПАС-3D.

Задание количеств на исполнение в спецификациях по вариантам А и Б выполняется очень похоже. Подробно порядок ввода данных о количестве для разных спецификаций описан в разделах 6.2.7.1.1 и 6.2.7.1.2.

При необходимости пользователь может редактировать автоматически сформированные номера исполнений. Это может потребоваться, например, для ввода дополнительных номеров исполнений. Подробно порядок редактирования номеров исполнений в спецификациях по вариантам А и Б описан в разделе 6.2.7.1.3.

Остальные приемы — подключение к объектам геометрии и документов, работа с дополнительными параметрами и т.п. — такие же, как при работе с обычной спецификацией (см. раздел 6.2.2).

В этом разделе:

6.2.7.1.1. Групповая спецификация по варианту Б

6.2.7.1.2. Групповая спецификация по варианту А

6.2.7.1.3. Редактирование номеров исполнений


6.2.7.1.1. Групповая спецификация по варианту Б

Если спецификация имеет стиль Груп. спецификация (менее 3 исп.) ГОСТ 2.113–75, то в ее таблице есть 3 колонки для ввода количества объектов (деталей, сборочных единиц).

Если спецификация имеет стиль Груп. спецификация (вариант Б) ГОСТ 2.113–75 Ф.1, 1а/Ф.1, 1в/Ф.1б, 1а/Ф.1б, 1в, то в ее таблице есть 10 колонок для ввода количества объектов.

Ввод данных в такие колонки Количество ничем не отличается от ввода данных в любые другие колонки.

Необязательно вводить количество во все доступные колонки. Если объект спецификации не входит в какое-либо исполнение изделия, то для этого исполнения колонку Количество не заполняют.

Если специфицируемое изделие имеет более десяти исполнений, то в режиме редактирования объекта спецификации становится доступной для ввода данных не одна строка таблицы, содержащая 10 колонок, а столько строк, сколько требуется для ввода количества объектов для всех исполнений. В первую строку вводятся количества для исполнений с основного по девятое, во вторую — с десятого по девятнадцатое и так далее.

После подтверждения создания объекта строки, содержащие данные о количестве, «разделятся».

– Если при настройке спецификации (см. раздел 6.4.2.3) указано, что информация должна выдаваться по объектам, то для каждого объекта будет создано нужное количество строк, и каждая из них будет предваряться началом блока исполнений — автоматически сформированной строкой с указанием номеров исполнений, для которых ниже введено количество.

– Если при настройке спецификации указано, что информация должна выдаваться блоками, то все объекты разделятся на несколько блоков, перед каждым из которых также будет находиться начало блока исполнений. Если при настройке спецификации включена опция Размещать блок на новом листе, то для начала блока не будет отводиться отдельная строка. Номера исполнений, для которых ниже введено количество, будут показаны в «шапке» таблицы спецификации.

– Если при настройке спецификации отключена опция Показывать заголовки блоков, то начала блоков исполнений (в том числе располагающиеся в «шапке» таблицы) не будут отображаться в бланке спецификации.

Пример групповой спецификации по варианту Б приведен на рис. 6.1.4.

Для практического ознакомления с созданием групповых спецификаций по варианту Б выполните упражнения 40 и 41.


6.2.7.1.2. Групповая спецификация по варианту А

Если текущая спецификация имеет стиль Груп. спецификация (вариант А) ГОСТ 2.113–75, то ее таблица не отличается от таблицы простой спецификации (со стилем Простая спецификация ГОСТ 2.106–96).

При вводе и редактировании каждого объекта групповой спецификации по варианту А ячейка колонки Количество отображается разделенной по горизонтали на несколько частей (строк). Их число равно количеству исполнений специфицируемого изделия, заданному при настройке спецификации. В первую строку вводится количество данного объекта для нулевого (базового) исполнения, во вторую — для первого исполнения и т.д.

– Те объекты, количество которых для всех исполнений изделия одинаково (т.е. в каждую строку ячейки Количество введено одно и то же значение), считаются относящимися к постоянным данным. Эти объекты автоматически располагаются в начале спецификации в соответствующих разделах (см. рис. 6.2.42).

– Те объекты, количество которых для разных исполнений изделия различно (т.е. в строки ячейки Количество введены разные значения), считаются относящимися к переменным данным. После подтверждения создания объекта строки, содержащие данные о количестве, «разделяются».

Порядок формирования переменных данных следующий.

1. В спецификации создается заголовок Переменные данные для исполнений. Согласно стандарту, он располагается после постоянных данных. Ниже этого заголовка формируются блоки — группы переменных данных, относящихся к одному и тому же исполнению изделия. Началом блока является строка, содержащая обозначение исполнения. Начала блоков формируются автоматически с использованием обозначения, заданного в основной надписи спецификации.

2. Строки, соответствующие объекту, количества которого различны для разных исполнений, появляются в исполнениях (блоках). Эти строки отличаются только значениями в графе Количество. В тех исполнениях, для которых при создании объекта не было задано количество (т.е. строка ячейки Количество была оставлена пустой), этот объект не возникает.

Если исполнение не содержит переменных данных (т.е. для него строка ячейки Количество была оставлена пустой во всех объектах), то блок этого исполнения состоит из одной строки со словом Отсутствуют. Если переменных данных нет ни в одном исполнении, то блоки для них не создаются, а в конец спецификации добавляется строка с текстом Различия исполнений по сборочному чертежу. Указанные строки представляют собой отметки об отсутствии переменных данных.

Текст отметок можно отредактировать. Измененный текст сохраняется в документе.

В случае появления в исполнении (или исполнениях) ранее отсутствовавших переменных данных отметка автоматически удаляется.

Рис. 6.2.42. Постоянные и переменные данные в групповой спецификации по варианту А

– Если при настройке спецификации (см. раздел 6.4.2.3) включена опция Размещать блок на новом листе, то начало каждого блока будет размещено вверху новой страницы.

– Если при настройке спецификации отключена опция Показывать исполнения, не содержащие переменных данных, то исполнения без переменных данных игнорируются: для них не формируются блоки и не создаются отметки об отсутствии переменных данных.

– Если при настройке спецификации отключена опция Показывать заголовки блоков, то начала блоков исполнений не будут отображаться в бланке спецификации. Блоки для исполнений без переменных данных в этом случае не создаются независимо от состояния опции Показывать исполнения, не содержащие переменных данных.

Для практического ознакомления с созданием групповой спецификации по варианту А выполните упражнение 42.

Особенности заполнения раздела Документация в групповой спецификации по варианту А

В разделе Документация групповой спецификации по варианту А графа Количество не заполняется.

Поэтому при создании объектов этого раздела в групповой спецификации по варианту А необходимо поставить отметку в строках тех исполнений, где документ отсутствует. Отметкой может служить любой символ, кроме цифры, например, «прочерк» — знак «минус».

В результате обозначение и наименование документа появятся в тех исполнениях, для которых строка оставлена пустой (в то время как для объектов остальных разделов это является признаком отсутствия объекта в исполнении). Если пусты все строки ячейки Количество, то документ будет отнесен к постоянным данным для исполнений.

Обратите внимание на то, что в групповой спецификации по варианту Б колонки Количество в разделе Документация заполняются — наличие отметки в них (например, «х») говорит об использовании документа в соответствующих исполнениях изделия.


6.2.7.1.3. Редактирование номеров исполнений

Редактирование номеров исполнений производится в нормальном режиме работы со спецификацией.

Чтобы изменить номер исполнения, дважды щелкните мышью в его ячейке. Номер исполнения (для варианта А) или строка номеров (для варианта Б) станет доступна для редактирования. Введите нужный номер или номера и нажмите комбинацию клавиш <Ctrl> + <Enter>.

Чтобы вернуть исполнениям прежние (присвоенные автоматически) номера, удалите номера, введенные вручную.


6.2.7.2. Спецификации с вложенными и дополнительными разделами

Использование вложенных и дополнительных разделов возможно в спецификации со стилем Простая спецификация ГОСТ 2.106–96 (подробно о блоках вложенных и дополнительных разделов — см. раздел 6.1.2.1.1).

Чтобы получить доступ к дополнительным и вложенным разделам, после создания спецификации указанного стиля необходимо ее настроить.

Применение блоков вложенных разделов возможно лишь в разделе Комплекты.

Включение этой возможности и настройка перечня вложенных разделов производятся на вкладке Вложенные разделы диалога настройки раздела Комплекты (см. раздел 6.4.2.2.3).

Включение возможности использования дополнительных разделов и настройка их перечня производится на вкладке Дополнительные разделы диалога настройки спецификации (см. раздел 6.4.2.4).

После того как вышеописанная настройка текущей спецификации произведена, при создании объектов в ней можно будет выбрать нужный вложенный или дополнительный раздел (см. рис. 6.2.43).

Рис. 6.2.43. Создание раздела Детали, вложенного в раздел Комплекты
(блок Комплект монтажных частей)

При необходимости вложенные и дополнительные разделы могут создаваться и в спецификациях других стилей. Для этого необходимо отредактировать соответствующие стили спецификации, включив использование блоков дополнительных и (или) вложенных разделов и выбрав разделы, которые будут входить в каждый блок.


6.2.8. Хранение в документах информации об используемом стиле спецификации

6.2. Приемы работы со спецификацией

6.2.8. Хранение в документах информации
об используемом стиле спецификации

Стиль, который имеет документ-спецификация, а также стиль, входящий в описание спецификации документа (см. раздел 6.1.3.4), внедряется в этот документ. Благодаря этому работа с объектами спецификации возможна даже в отсутствие библиотеки *.lyt, содержащей используемый стиль спецификации. Редактирование стиля спецификации, хранящегося в документе, невозможно.

Кроме того, в документе хранится ссылка на внешний файл библиотеки *.lyt, содержащий используемый стиль. Ссылка включает путь к библиотеке и номер стиля в ней. Благодаря этому при изменении стиля в библиотеке возможно обновление стиля документа.

Обратите внимание на то, что при обновлении стиля спецификации автоматически обновляются используемые в нем оформления (вместе с входящими в них основными надписями) для первого и последующих листов. Обновление оформлений отдельно от стиля невозможно.

Обновление стиля подчиняется настройке обновления оформления, см. раздел 11.2.1.2.1. В любое время при работе с документом возможно принудительное обновление используемого в нем стиля спецификации, см. раздел 6.2.8.1.

Если документ-спецификация имеет дополнительные листы (см. раздел 6.2.6.9), то оформления этих листов также внедряются в документ и обновляются согласно той же настройке.

Все имеющиеся в текущем документе ссылки, в том числе ссылки на библиотеки *.lyt, можно просмотреть на вкладке Внешние ссылки диалога информации о документе. Для его вызова служит команда Файл — Информация о документе...

Стиль спецификации внедряется в документ, начиная с 13 версии КОМПАС-3D. Если документ создан в более ранней версии, то при отсутствии библиотеки *.lyt, содержащей используемый в нем стиль спецификации, работа с объектами спецификации в этом документе невозможна (документ-спецификацию в этом случае невозможно открыть).

В этом разделе:

6.2.8.1. Перечитывание стиля


6.2.8.1. Перечитывание стиля

Перечитывание стиля — принудительное обновление стиля спецификации.

Возможно перечитывание стиля:

– В документе-спецификации. Для этого вызовите команду Сервис — Перечитать стиль. Эта команда доступна, если между стилем, хранящимся в документе, и соответствующим ему стилем в библиотеке *.lyt есть различия. Если различий нет, а также если отсутствует библиотека или стиль в ней (т.е. невозможно сравнить стили), команда недоступна.

– В текущем описании спецификации графического документа или модели. Для этого при работе со спецификацией в подчиненном режиме (см. раздел 6.1.3.3) вызовите команду Сервис — Перечитать стиль.

– В текущем описании спецификации чертежа и во всех спецификациях на чертеже. Для этого вызовите команду Спецификация — Перечитать стили.

– В отдельной спецификации на чертеже. Для этого вызовите команду Перечитать стиль из контекстного меню спецификации на чертеже.

Если спецификация содержит дополнительные листы, то их оформление обновляется при перечитывании стиля спецификации, т.е. при вызове для спецификации команды Сервис — Перечитать стиль.

Возможно также ручное обновление оформлений дополнительных листов в начале и/или в конце спецификации. Для этого вызовите команду Сервис — Параметры... — Текущая спецификация — Дополнительные листы. В правой части появившегося диалога выберите оформление и нажмите кнопку Изменить, а в следующем диалоге — кнопку Перечитать. Закройте настроечный диалог кнопкой ОК.


6.3. Практическое освоение основных навыков работы со спецификацией

6.3. Практическое освоение основных навыков
работы со спецификацией

В этом разделе:

6.3.1. Создание простой спецификации, не связанной с другими документами

6.3.1.1. Создание новой спецификации

Упражнение 1. Проверка умолчательных настроек

Упражнение 2. Создание файла документа-спецификации

6.3.1.2. Заполнение спецификации

Упражнение 3. Создание объектов спецификации

Упражнение 4. Создание раздела

Упражнение 5. Изучение свойств резервных строк

Упражнение 6. Сортировка и номера позиций

Упражнение 7. Создание объекта спецификации путем копирования

Упражнение 8. Создание исполнений объекта спецификации

Упражнение 9. Редактирование текстовой части объекта спецификации

Упражнение 10. Удаление объекта спецификации

Упражнение 11. Использование шаблонов заполнения

Упражнение 12. Редактирование текстовой части, заполненной по шаблону

Упражнение 13. Вспомогательные объекты спецификации

Упражнение 14. Вставка объекта спецификации из Справочника Стандартные Изделия

Упражнение 15. Шаблонная текстовая часть в виде строки

6.3.1.3. Окончательное оформление спецификации

Упражнение 16. Вставка разрыва страницы

Упражнение 17. Заполнение основной надписи

Упражнение 18. Печать спецификации

6.3.2. Создание спецификации, связанной со сборочным чертежом

Упражнение 19. Подготовительные действия

6.3.2.1. Объекты спецификации в чертеже

Упражнение 20. Создание объектов спецификации в чертеже

6.3.2.2. Геометрия объектов спецификации

Упражнение 21. Создание объекта спецификации, содержащего геометрию

Упражнение 22. Подключение геометрии к объекту спецификации

Упражнение 23. Просмотр геометрии объектов спецификации

Упражнение 24. Редактирование состава геометрии объектов спецификации

Упражнение 25. Создание объектов спецификации. Самостоятельная работа

6.3.2.3. Спецификация и Справочник Стандартные Изделия

Упражнение 26. Получение объектов спецификации из Справочника Стандартные Изделия

6.3.2.4. Связь сборочного чертежа и спецификации

Упражнение 27. Подключение сборочного чертежа к спецификации

Упражнение 28. Передача объектов между спецификацией и чертежом

Упражнение 29. Передача обозначения и наименования изделия между спецификацией и чертежом

6.3.2.5. Автоматический и полуавтоматический ввод данных в спецификацию

Упражнение 30. Подключение чертежа к объекту спецификации. Обмен данными между объектом и подключенным документом

6.3.2.6. Дополнительные колонки спецификации

Упражнение 31. Ввод данных в дополнительные колонки

Упражнение 32. Сложение значений в дополнительных колонках

6.3.2.7. Задания для самостоятельного выполнения

Упражнение 33. Оформление и печать спецификации

Упражнение 34. Создание спецификации

6.3.3. Создание спецификации, связанной с моделью-сборкой

6.3.3.1. Подготовка данных для спецификации в компонентах сборки

Упражнение 35. Создание объектов спецификации в деталях

Упражнение 36. Создание объектов спецификации в подсборке

6.3.3.2. Передача объектов из сборки в спецификацию

Упражнение 37. Создание документа-спецификации и подключение к ней сборки

Упражнение 38. Вставка объектов спецификации из Справочника Стандартные Изделия

6.3.3.3. Полный комплект ассоциативных документов

Упражнение 39. Создание спецификации, связанной со сборкой и сборочным чертежом

6.3.4. Создание групповой спецификации

Упражнение 40. Создание групповой спецификации по варианту Б

Упражнение 41. Создание групповой спецификации по варианту Б с числом исполнений более десяти

Упражнение 42. Создание групповой спецификации по варианту А


6.3.1. Создание простой спецификации, не связанной с другими документами

6.3. Практическое освоение основных навыков работы со спецификацией

6.3.1. Создание простой спецификации,
не связанной с другими документами

Заполнение спецификации в ручном режиме — самый незамысловатый способ создания спецификации. Он предоставляет пользователю минимум сервисных возможностей.

В начале изучения порядка работы со спецификациями КОМПАС-3D рекомендуется ознакомиться именно с этим способом, так как на примере созданной вручную спецификации хорошо видны многие приемы работы со спецификациями. Они будут рассмотрены в этом разделе на примере создания спецификации на изделие Фильтр, показанной на рис. 6.3.1.

Эта спецификация в формате PDF размещается в подпапке \Manual\Exercises главной папки системы, в файле Filter.pdf. Распечатайте ее, чтобы при выполнении упражнений она всегда могла быть перед глазами.

Все упражнения из этого раздела выполняются последовательно в одной и той же спецификации. Закончив выполнение одного упражнения, переходите к следующему, не закрывая спецификацию.

Кнопки вызова команд, приведенные в этом разделе, расположены на инструментальной панели Спецификация (см. раздел 6.2.1.3). Если используются кнопки с других панелей, это оговорено дополнительно.

Рис. 6.3.1. Образец спецификации

В этом разделе:

6.3.1.1. Создание новой спецификации

Упражнение 1. Проверка умолчательных настроек

Упражнение 2. Создание файла документа-спецификации

6.3.1.2. Заполнение спецификации

Упражнение 3. Создание объектов спецификации

Упражнение 4. Создание раздела

Упражнение 5. Изучение свойств резервных строк

Упражнение 6. Сортировка и номера позиций

Упражнение 7. Создание объекта спецификации путем копирования

Упражнение 8. Создание исполнений объекта спецификации

Упражнение 9. Редактирование текстовой части объекта спецификации

Упражнение 10. Удаление объекта спецификации

Упражнение 11. Использование шаблонов заполнения

Упражнение 12. Редактирование текстовой части, заполненной по шаблону

Упражнение 13. Вспомогательные объекты спецификации

Упражнение 14. Вставка объекта спецификации из Справочника Стандартные Изделия

Упражнение 15. Шаблонная текстовая часть в виде строки

6.3.1.3. Окончательное оформление спецификации

Упражнение 16. Вставка разрыва страницы

Упражнение 17. Заполнение основной надписи

Упражнение 18. Печать спецификации


6.3.1.1. Создание новой спецификации

В этом разделе:

Упражнение 1. Проверка умолчательных настроек

Упражнение 2. Создание файла документа-спецификации


Упражнение 1. Проверка умолчательных настроек

6.3. Практическое освоение основных навыков работы со спецификацией > 6.3.1. Создание простой спецификации, не связанной с другими документами > 6.3.1.1. Создание новой спецификации >

Упражнение 1. Проверка умолчательных настроек

1. Запустите КОМПАС-3D.

Вам требуется создать новый документ — спецификацию КОМПАС-3D. Однако не спешите вызывать команду создания документа.

2. Вызовите команду Сервис — Параметры.

3. В появившемся диалоге раскройте раздел Новые документы — Спецификация — Умолчательные настройки — Стиль.

4. Убедитесь, что в качестве библиотеки стилей в диалоге указан файл Graphic.lyt из подпапки \Sys главной папки КОМПАС-3D, а в качестве стиля — Простая спецификация ГОСТ 2.106–96. Если библиотека и стиль другие, выберите указанную библиотеку и стиль.

Теперь можно создавать новую спецификацию.


Упражнение 2. Создание файла документа-спецификации

6.3. Практическое освоение основных навыков работы со спецификацией > 6.3.1. Создание простой спецификации, не связанной с другими документами > 6.3.1.1. Создание новой спецификации >

Упражнение 2. Создание файла документа-спецификации

1. Вызовите команду Файл — Создать.

2. В появившемся диалоге выберите тип документа Спецификация и нажмите кнопку OK.

На экране появится бланк спецификации.

3. Сохраните файл спецификации под любым именем.


6.3.1.2. Заполнение спецификации

Бланк спецификации готов к вводу в него информации.

В этом разделе:

Упражнение 3. Создание объектов спецификации

Упражнение 4. Создание раздела

Упражнение 5. Изучение свойств резервных строк

Упражнение 6. Сортировка и номера позиций

Упражнение 7. Создание объекта спецификации путем копирования

Упражнение 8. Создание исполнений объекта спецификации

Упражнение 9. Редактирование текстовой части объекта спецификации

Упражнение 10. Удаление объекта спецификации

Упражнение 11. Использование шаблонов заполнения

Упражнение 12. Редактирование текстовой части, заполненной по шаблону

Упражнение 13. Вспомогательные объекты спецификации

Упражнение 14. Вставка объекта спецификации из Справочника Стандартные Изделия

Упражнение 15. Шаблонная текстовая часть в виде строки


Упражнение 3. Создание объектов спецификации

6.3. Практическое освоение основных навыков работы со спецификацией > 6.3.1. Создание простой спецификации, не связанной с другими документами > 6.3.1.2. Заполнение спецификации >

Упражнение 3. Создание объектов спецификации

1. Попытайтесь активизировать строки бланка спецификации курсором и ввести какой-либо текст.

У вас это не получится, так как в бланк должны вноситься не просто символы, а объекты спецификации (см. раздел 6.1.1).

Работа со вспомогательными объектами будет рассмотрена далее, а сейчас обратимся к созданию базовых объектов спецификации.

2. Вызовите команду Вставка — Базовый объект или нажмите клавишу <Insert>.

На экране появится диалог, в котором нужно выбрать раздел для размещения нового объекта спецификации (рис. 6.3.2). Объект спецификации обязательно должен принадлежать одному из ее разделов.

Рис. 6.3.2. Выбор раздела Документация

3. Выделите в списке раздел Документация, с которого начинается спецификация. Нажмите кнопку Создать.

В бланке спецификации появится название раздела. Первая строка этого раздела станет доступной для редактирования. Курсор будет находиться в первой колонке (Формат).

Перед названием раздела и после него будут находиться пустые строки, недоступные для ввода символов (см. раздел 6.1.2.3).

4. Введите с клавиатуры текстовую часть объекта спецификации, то есть первую строку первого раздела спецификации.

В режиме ввода/редактирования текстовой части объекта спецификации доступны все возможности текстового редактора. Сведения о режиме ввода/редактирования текстовой части объекта спецификации представлены в разделе 6.2.2.4.

4.1. Введите в первую колонку текст А2.

4.2. Трижды нажмите клавишу <Tab>, чтобы курсор переместился в четвертую колонку — Обозначение.

Обозначения в разделе Документы чаще всего составные, т.е. содержат дополнительные данные, обычно код документа. Для ввода составных обозначений служит специальный диалог Обозначения. Он появляется на экране автоматически при попытке ввода любого символа в колонку Обозначение раздела Документация.

4.3. Первый документ в разделе Документы должен иметь обозначение АЕКТ.620840.200 и код СБ. Введите первую букву обозначения — А. Продолжайте ввод в поле Базовое обозначение появившегося на экране диалога Обозначение (рис. 6.3.3).

Рис. 6.3.3. Диалог ввода обозначения документа

4.4. В поле Код диалога Обозначение введите СБ.

4.5. Закройте диалог Обозначение кнопкой ОК. В пятой колонке спецификации (Наименование) автоматически появляется текст, соответствующий заданному коду, — Сборочный чертеж.

Обратите внимание на то, что ввод текста и чисел в некоторые колонки невозможен. Например, находясь в разделе Документация, вы не можете работать с колонками Зона и Позиция.

5. После ввода текстовой части завершите создание объекта нажатием комбинации клавиш <Ctrl>+<Enter> или щелчком мыши в свободном месте спецификации.

Введенный объект будет выделен цветом. Это выделение указывает на текущий раздел спецификации.

6. Для создания следующего объекта вновь вызовите команду Вставка — Базовый объект либо нажмите клавишу <Insert>.

Так как раздел, в котором создается объект спецификации, уже существует, строка для ввода текстовой части нового объекта возникает в конце этого раздела.

7. Введите текстовую часть объекта:

• формат — А4 (в колонку Формат),

• обозначение — АЕКТ.620840.200 (в диалоге Обозначение)

Код документа (в данном случае — ПС, т.е. Паспорт) можно не вводить с клавиатуры, а выбирать из специального диалога, содержащего стандартный перечень кодов и наименований документов. Подробнее о работе с кодами и наименованиями рассказано в разделе 6.2.2.4.2.

8. Воспользуйтесь возможностью выбора кода и наименования документа из списка стандартных кодов и наименований.

8.1. Сделайте двойной щелчок мышью в поле Код диалога Обозначение.

8.2. В появившемся диалоге Коды и наименования раскройте раздел Документы эксплуатационные, выделите код ПС и нажмите кнопку ОК (рис. 6.3.4).

Рис. 6.3.4. Выбор кода и наименования

Диалог выбора кодов и наименований закроется. В поле Код диалога Обозначение появится текст ПС.

8.3. Закройте диалог Обозначение кнопкой ОК.

В колонке Обозначение отобразится текст АЕКТ.620840.200 ПС, а в колонке Наименование — текст Паспорт.

9. Нажмите комбинацию клавиш <Ctrl>+<Enter>.

Заполнение раздела Документация закончено.


Упражнение 4. Создание раздела

6.3. Практическое освоение основных навыков работы со спецификацией > 6.3.1. Создание простой спецификации, не связанной с другими документами > 6.3.1.2. Заполнение спецификации >

Упражнение 4. Создание раздела

1. Для создания нового раздела вызовите команду Вставка — Раздел.

2. В появившемся диалоге укажите название следующего раздела вашей спецификации — Сборочные единицы.

Так как спецификация КОМПАС-3D не может содержать пустой (состоящий только из заголовка) раздел, при создании нового раздела создается и первый объект в нем. Поэтому необходимо указать, какой объект (базовый или вспомогательный) будет создаваться в новом разделе.

3. Выберите в диалоге базовый объект (рис. 6.3.5) и нажмите кнопку Создать.

Рис. 6.3.5. Выбор раздела Сборочные единицы


Упражнение 5. Изучение свойств резервных строк

6.3. Практическое освоение основных навыков работы со спецификацией > 6.3.1. Создание простой спецификации, не связанной с другими документами > 6.3.1.2. Заполнение спецификации >

Упражнение 5. Изучение свойств резервных строк

Обратите внимание на то, что заголовок появившегося раздела располагается через три строки после предыдущего раздела. Над заголовком раздела расположена пустая строка, а над ней — две резервные строки предыдущего раздела (см. раздел 6.1.2.4).

1. Заполните текстовую часть нового объекта спецификации:

• формат — А3,

• обозначение — АЕКТ.620840.210,

• наименование — Указатель уровня,

• количество — 1.

В колонке Позиция оставьте число, возникшее автоматически. С формированием номеров позиций вы познакомитесь при выполнении следующего упражнения.

При заполнении колонки Обозначение во всех разделах, кроме раздела Документация, автоматическое открытие диалога Обозначение не происходит.

Обратите внимание на то, что в колонку Количество раздела Сборочные единицы невозможно ввести буквы.

2. Подтвердите создание объекта, нажав комбинацию клавиш <Ctrl>+<Enter>.

3. Щелкните мышью на любом объекте раздела Документация, активизировав тем самым этот раздел.

4. В поле Количество резервных строк на панели Текущее состояние выберите из списка количество резервных строк 1, отличающееся от заданного по умолчанию.

Рис. 6.3.6. Выбор количества резервных строк

5. Посмотрите, как изменилось положение последующего раздела в бланке спецификации.

6. Попытайтесь активизировать резервную строку и ввести в нее текст. У вас это не получится, т.к. резервные строки предназначены для внесения в них данных только на распечатке (вручную).


Упражнение 6. Сортировка и номера позиций

6.3. Практическое освоение основных навыков работы со спецификацией > 6.3.1. Создание простой спецификации, не связанной с другими документами > 6.3.1.2. Заполнение спецификации >

Упражнение 6. Сортировка и номера позиций

1. Активизируйте раздел Сборочные единицы, выделив первый объект в нем.

2. Создайте в разделе второй базовый объект и заполните его текстовую часть:

• формат — А4,

• обозначение — АЕКТ.620840.220,

• наименование — Насос,

• количество — 1.

В колонке Позиция оставьте число, возникшее автоматически.

При создании всех следующих объектов во всех следующих упражнениях также оставляйте в колонке Позиция числа, возникшие автоматически.

При создании каждого нового объекта в колонке Позиция автоматически возникает порядковый номер этого объекта. Эти номера указывают на последовательность создания объектов.

Если вы последовательно выполняли предыдущие упражнения, то в колонке Позиция у объектов Указатель уровня и Насос должны оказаться цифры 3 и 4 соответственно.

3. Для упорядочения номеров позиций отсортированных объектов вызовите команду Сервис — Расставить позиции.

Объекты будут пронумерованы начиная с 1 по порядку сортировки.

4. Установите для текущего раздела количество резервных строк 3.

5. Уже известным вам способом создайте следующий раздел — Детали.

6. Создайте в нем базовый объект и заполните его текстовую часть:

• формат — А4,

• обозначение — АЕКТ.620840.203,

• наименование — Пробка,

• количество — 2.

7. Создайте в разделе Детали базовый объект и заполните его текстовую часть:

• формат — А3,

• обозначение — АЕКТ.620840.202,

• наименование — Крышка,

• количество — 1.

– Если вы создаете объекты в порядке, соответствующем их стандартной сортировке, они располагаются в разделе в порядке ввода. Вы видели это при выполнении упражнений 3 и 6.

– Если вы создаете объекты в разделе в произвольном порядке, они автоматически сортируются по правилам, предписанным ГОСТ 2.106—96 (например, в разделе Детали происходит сортировка по тексту в колонке Обозначение). Подробнее см. разделы 6.1.2.6 и 6.2.2.7.

Объект, созданный позже других, может в результате сортировки оказаться в середине или начале раздела. И наоборот, объект, созданный первым, может попасть в конец или середину раздела.

Таким образом, Крышка расположится в таблице спецификации перед Пробкой, т.к. последнее число в обозначении Пробки (203) больше последнего числа в обозначении Крышки (202).

При этом в колонке Позиция по-прежнему находятся номера, отражающие порядок создания объектов.

8. Создайте в разделе Детали базовый объект со следующей текстовой частью:

• формат — А2,

• обозначение — АЕКТ.620840.201,

• наименование — Корпус,

• количество — 1.

9. Создайте в разделе Детали базовый объект со следующей текстовой частью:

• формат — А4,

• обозначение — АЕКТ.620840.204,

• наименование — Защелка левая,

• количество — 1.

10. Создайте в разделе Детали базовый объект со следующей текстовой частью:

• формат — А4,

• обозначение — АЕКТ.620840.206,

• наименование — Решетка,

• количество — 2.

На этом этапе выполнения упражнения раздел Детали должен быть заполнен, как показано на рис. 6.3.7.

Рис. 6.3.7. Объекты спецификации в разделе Детали

11. Вызовите команду Сервис — Расставить позиции.

Обратите внимание на то, с какого числа начинается нумерация объектов в разделе Детали после простановки позиций.

Первый номер позиции в разделе должен быть на единицу больше суммы последнего номера позиции в предыдущем разделе и количества резервных строк в нем. Раздел Сборочные единицы заканчивается позицией 2 и имеет три резервные строки (для последующего внесения в выпущенную спецификацию позиций 3, 4 и 5). Поэтому следующий раздел — Детали — будет начинаться с позиции 6.

Простановку позиций в разделе можно отключать.

12. Сделайте текущим раздел Сборочные единицы, щелкнув мышью на одном из его объектов.

13. Отожмите кнопку Проставлять позиции на панели Текущее состояние, отключив тем самым простановку позиций в этом разделе. На запрос системы об очистке позиций ответьте Да.

14. Вызовите команду Сервис — Расставить позиции.

Обратите внимание на то, что объекты в разделе Сборочные единицы теперь не пронумерованы. Соответственно изменилась нумерация объектов в разделе Детали.

15. Включите простановку позиций в разделе Сборочные единицы, нажав кнопку Проставлять позиции.

16. Снова вызовите команду Расставить позиции.


Упражнение 7. Создание объекта спецификации путем копирования

6.3. Практическое освоение основных навыков работы со спецификацией > 6.3.1. Создание простой спецификации, не связанной с другими документами > 6.3.1.2. Заполнение спецификации >

Упражнение 7. Создание объекта спецификации путем копирования

1. Установите выделение на объекте Защелка левая. Для этого щелкните по нему мышью или переместите на него выделение при помощи клавиш со стрелками.

2. Вызовите команду Редактор — Копировать объект.

В таблице спецификации возникнет новый объект, его строка станет доступной для редактирования, а его текстовая часть будет заполнена так же, как текстовая часть исходного объекта (Защелки левой).

3. Не подтверждая создание объекта, отредактируйте его текстовую часть: измените последнюю цифру в обозначении с 4 на 5, а слово «левая» в наименовании — на слово «правая».

4. Подтвердите создание объекта.

Убедитесь, что в результате автоматической сортировки новый объект — Защелка правая с обозначением АЕКТ.620840.205 — расположился после объекта с обозначением АЕКТ.620840.204 и перед объектом с обозначением АЕКТ.620840.206.


Упражнение 8. Создание исполнений объекта спецификации

6.3. Практическое освоение основных навыков работы со спецификацией > 6.3.1. Создание простой спецификации, не связанной с другими документами > 6.3.1.2. Заполнение спецификации >

Упражнение 8. Создание исполнений объекта спецификации

Два объекта, соответствующие первому и второму исполнению Решетки, можно создать уже известными вам способами — ввести текстовую часть вручную или скопировать существующий объект и отредактировать его текстовую часть.

Однако в данном случае целесообразно воспользоваться другим приемом — созданием исполнений существующего объекта.

Предварительно нужно настроить спецификацию.

1. Вызовите команду Формат — Настройка спецификации.

2. В появившемся диалоге активизируйте вкладку Блоки исполнений.

3. Убедитесь, что в группе Формировать обозначения исполнений объектов выбран вариант Показывать только номер.

4. Включите опцию Позиции возрастают. Нажмите кнопку OK.

Спецификация настроена для создания исполнений объектов.

5. Установите выделение на объекте Решетка.

6. Вызовите команду Вставка — Исполнение.

7. В появившемся диалоге введите строку 1,2,4-6 и нажмите кнопку OK.

Вы увидите, что под первым объектом Решетка появилось еще несколько. Они отличаются от исходного только тем, что в качестве их обозначения фигурируют суффиксы -01, -02, -04, -05 и -06. Кроме того, они имеют собственные номера позиций.

8. Вновь вызовите команду Формат — Настройка спецификации.

9. В появившемся диалоге активизируйте вкладку Блоки исполнений.

10. Выберите вариант Показывать полностью. Нажмите кнопку OK.

Вы увидите, что теперь объекты-исполнения имеют полное обозначение, а не только суффикс.

11. Вызовите команду Сервис — Расставить позиции.

Убедитесь, что теперь все объекты спецификации пронумерованы по порядку.


Упражнение 9. Редактирование текстовой части объекта спецификации

6.3. Практическое освоение основных навыков работы со спецификацией > 6.3.1. Создание простой спецификации, не связанной с другими документами > 6.3.1.2. Заполнение спецификации >

Упражнение 9. Редактирование текстовой части объекта спецификации

Текстовая часть объектов — исполнений Решетки была сформирована автоматически на основе исходного объекта. В результате в колонке Количество всех этих объектов стоят одинаковые цифры. Требуется исправить количество Решеток пятого и шестого исполнения в соответствии с образцом.

1. Дважды щелкните мышью по объекту с обозначением АЕКТ.620840.206-05.

Система перейдет в режим редактирования его текстовой части.

2. Установите курсор в колонку Количество и введите в ней вместо числа 2 число 4.

3. Подтвердите изменение текстовой части, нажав комбинацию клавиш <Ctrl>+<Enter>.

Система выйдет из режима редактирования текстовой части объекта спецификации, а выделение останется на этом объекте.

4. Нажмите клавишу <↓>, чтобы переместить выделение на следующий объект (с обозначением АЕКТ.620840.206-06).

5. Нажмите клавишу <Enter>, чтобы перейти в режим редактирования его текстовой части.

6. При помощи клавиши <Tab> переместите курсор в колонку Количество и введите в ней вместо числа 2 число 1.

7. Подтвердите изменение текстовой части.


Упражнение 10. Удаление объекта спецификации

6.3. Практическое освоение основных навыков работы со спецификацией > 6.3.1. Создание простой спецификации, не связанной с другими документами > 6.3.1.2. Заполнение спецификации >

Упражнение 10. Удаление объекта спецификации

Объекты-исполнения с обозначениями АЕКТ.620840.206-01, АЕКТ.620840.206-02 и АЕКТ.620840.206-04 были созданы в демонстрационных целях. В спецификации-образце их нет. Их нужно удалить.

1. Установите выделение на объекте Решетка с обозначением АЕКТ.620840.206-01.

2. Вызовите команду Редактор — Удалить объект.

3. Внимательно прочитайте сообщение в появившемся диалоге (рис. 6.3.8). Убедитесь, что удаляете действительно ненужный объект. Нажмите кнопку Да.

Рис. 6.3.8. Запрос на удаление объекта

Отменить удаление объекта спецификации невозможно.

Объект исчезнет из таблицы спецификации. При этом на его месте не останется пустой строки. Все следующие за ним объекты поднимутся на одну строку.

4. Установите выделение на объекте Решетка с обозначением АЕКТ.620840.206-02.

5. Нажмите клавишу <Delete>.

6. Подтвердите удаление объекта.

7. Удалите объект Решетка с обозначением АЕКТ.620840.206-04, вызвав команду удаления любым способом.

После удаления объектов порядок нумерации позиций нарушится.

8. Чтобы восстановить его, вызовите команду Расставить позиции.

9. Убедитесь, что теперь позиции пронумерованы без учета удаленных объектов.

На этом этапе выполнения упражнений разделы Документация, Сборочные единицы и Детали должны оказаться заполненными в полном соответствии с образцом.


Упражнение 11. Использование шаблонов заполнения

6.3. Практическое освоение основных навыков работы со спецификацией > 6.3.1. Создание простой спецификации, не связанной с другими документами > 6.3.1.2. Заполнение спецификации >

Упражнение 11. Использование шаблонов заполнения

Обозначения стандартных изделий (например, винтов, шайб, штуцеров и т.д.) и материалов (например, швеллеров, бумаги, паронита и т.д.) подчиняются правилам, установленным в ГОСТ на эти изделия и материалы. В соответствии с этими стандартными правилами для каждого вида объектов (шайб, швеллеров и т.д.) в КОМПАС-3D сформированы шаблоны заполнения — своеобразные «заготовки» с готовыми для ввода характеристик объектов полями.

1. Вызовите команду Вставка — Раздел.

2. В появившемся на экране диалоге выбора раздела выделите раздел Материалы.

Обратите внимание на то, что в диалоге выбора раздела после указания раздела Материалы стала доступной кнопка выбора шаблона заполнения текстовой части объекта (рис. 6.3.9).

Рис. 6.3.9. Выбор раздела Материалы

3. Нажмите в диалоге кнопку Выбрать шаблон.

4. В появившемся диалоге раскройте раздел Профили и выделите строку Уголок (рис. 6.3.10). Нажмите кнопку Выбрать.

5. Нажмите кнопку Создать в диалоге выбора раздела.

Рис. 6.3.10. Выбор шаблона заполнения Уголок

В колонке Наименование появится строка, автоматически сформированная из заполненных полей предписанного стандартом обозначения выбранного объекта (уголка). Значения типоразмеров уголка, подставленные по умолчанию, соответствуют образцу спецификации. Поэтому их изменять не надо.

6. Введите в колонку Количество текст 0,6м. Подтвердите создание объекта.

Обратите внимание на то, что в колонку Количество в разделе Материалы можно вводить не только цифры, но и буквы.

7. Чтобы вставить стандартное изделие, вновь вызовите команду Вставка — Раздел.

8. В появившемся на экране диалоге выбора раздела выделите раздел Стандартные изделия и нажмите кнопку Выбрать шаблон.

9. В появившемся диалоге раскройте раздел Крепежные изделия и выделите строку Винт (рис. 6.3.11). Нажмите кнопку Выбрать.

10. В диалоге выбора раздела нажмите кнопку Создать.

В колонке Наименование появится строка, автоматически сформированная из заполненных полей предписанного стандартом обозначения выбранного объекта (винта) — Винт 2 М10 х 1,25-6g х 25.58.35Х.01 ГОСТ Р 11738-84.

11. Чтобы сильное сужение символов не мешало читать обозначение, перенесите его часть на следующую строку. Для этого установите курсор перед аббревиатурой ГОСТ и нажмите клавишу <Enter>.

Не подтверждая создание объекта, переходите к выполнению следующего упражнения.

Рис. 6.3.11. Выбор шаблона заполнения Винт


Упражнение 12. Редактирование текстовой части, заполненной по шаблону

6.3. Практическое освоение основных навыков работы со спецификацией > 6.3.1. Создание простой спецификации, не связанной с другими документами > 6.3.1.2. Заполнение спецификации >

Упражнение 12. Редактирование текстовой части, заполненной по шаблону

(Продолжение упражнения 11)

12. Находясь в режиме редактирования текстовой части объекта спецификации, дважды щелкните мышью по его обозначению в колонке Наименование.

На экране появится окно с таблицей параметров винта (рис. 6.3.12).

Рис. 6.3.12. Таблица параметров винта

13. Поменяйте в таблице номинальный диаметр винта с 10 на 12, а шаг резьбы — с 1.25 на 1.75.

Числа в таблице по умолчанию представлены в экспоненциальном формате (10 в виде 1.000000E+001, а 1.25 — в виде 1.250000E+000). Вы можете вводить другие значения как в экспоненциальном, так и в обычном формате (просто 12 и 1.75).

14. Нажмите кнопку OK.

Вы увидите, что обозначение винта в строке спецификации изменилось в соответствии с новым значением диаметра и шага резьбы.

15. При необходимости вновь перенесите обозначение стандарта на другую строку. Подтвердите создание объекта.

Обратите внимание на то, что раздел Стандартные изделия расположился перед разделом Материалы, как требует стандарт. Таким образом, разделы спецификации можно создавать в любой последовательности, об их правильном расположении внутри документа позаботится Модуль проектирования спецификаций.

16. Создайте в текущем разделе еще один базовый объект с шаблоном заполнения Винт.

17. Вызовите окно с таблицей его параметров.

18. Поменяйте номинальный диаметр болта с 10 на 8, а шаг резьбы — с 1.25 на 1. Нажмите кнопку OK.

19. Подтвердите создание объекта.

Вы увидите, что после изменения обозначения и автоматической сортировки винт меньшего диаметра расположился перед винтом большего диаметра. Такое правило сортировки объектов предписано стандартом и учтено при разработке шаблона заполнения текстовой части.

20. Создайте в текущем разделе еще один базовый объект с шаблоном заполнения Винт.

21. Не вызывая окно с таблицей его параметров, в режиме редактирования текстовой части поменяйте номинальный диаметр винта с 10 на 6 и подтвердите создание объекта.

Вы увидите, что хотя обозначение винта и изменилось, в результате автоматической сортировки он не оказался перед винтом М8.

Дело в том, что истинными характеристиками объекта считаются те значения, которые можно увидеть в окне с таблицей параметров.

22. Войдите в режим редактирования объекта с текстовой частью Винт М6... и дважды щелкните по нему мышью.

Вы увидите, что в окне, содержащем параметры объекта, номинальный диаметр равен 10.

23. Измените его на 6, а шаг — на 1. Нажмите кнопку OK.

24. Подтвердите создание объекта.

В разделе Стандартные изделия спецификации на экране вашего компьютера должно появиться три винта, отсортированных в порядке возрастания номинального диаметра.


Упражнение 13. Вспомогательные объекты спецификации

6.3. Практическое освоение основных навыков работы со спецификацией > 6.3.1. Создание простой спецификации, не связанной с другими документами > 6.3.1.2. Заполнение спецификации >

Упражнение 13. Вспомогательные объекты спецификации

Теперь пришло время познакомиться со вспомогательными объектами спецификации.

Такие объекты можно использовать для ввода произвольных текстов (комментариев) в строку спецификации или для создания пустой строки в середине раздела (подробнее см. раздел 6.1.1.1.2). Учитывая то, что на вспомогательный объект не распространяются правила сортировки объектов внутри раздела, с его помощью можно создать строку, положение которой внутри раздела не зависит от текста в ней.

На некоторых предприятиях при записи ряда изделий и материалов, которые отличаются размерами и другими данными, но применяются по одному и тому же документу (и записываются в спецификацию вслед за обозначением этого документа), принято общую часть наименования этих изделий или материалов с обозначением указанного документа записывать на каждом листе спецификации один раз в виде общего заголовка. Например, вначале пишут «Винты ГОСТ Р 11738-84», а затем — «М6», «М10» и т.д.

В этом упражнении будет реализован такой способ записи.

1. Сделайте текущим раздел Стандартные изделия.

2. Вызовите команду Вставка — Вспомогательный объект.

3. Введите в колонке Наименование получившегося объекта строку
Винты ГОСТ Р 11738-84.

Обратите внимание на то, что вы можете вводить данные любого типа в любую колонку вспомогательного объекта (например, в колонку Количество можно ввести буквы). Это — одно из отличий вспомогательного объекта от базового.

4. Подтвердите создание объекта.

Новый вспомогательный объект расположен после того объекта спецификации, который был выделен в момент вызова команды создания вспомогательного объекта (на вспомогательный объект не действует автоматическая сортировка).

Ваша задача — расположить строку Винты ГОСТ Р 11738-84 над списком винтов.

5. Для этого, не снимая выделения с нового вспомогательного объекта, вызовите команду Редактор — Сдвинуть объект вверх или нажмите комбинацию клавиш <Shift>+<↑>.

Вспомогательный объект сместится вверх.

6. Повторите эту команду столько раз, сколько потребуется, чтобы строка Винты ГОСТ Р 11738-84 оказалась над списком винтов.

7. Если вы хотите, чтобы общая часть наименования отделялась от списка винтов пустой строкой, создайте еще один вспомогательный объект и не заполняйте его текстовую часть.

8. Войдите в режим редактирования текстовой части каждого из базовых объектов раздела Стандартные изделия. Удалите слово Винт и обозначение стандарта (окно с параметрами винта для этого вызывать не нужно). Удалите также сведения о покрытии. У винтов М6 и М12 удалите значение шага резьбы (т.к. крупный шаг в обозначении резьбы не указывается). Введите количество 12 для винта М6, 8 — для винта М8 и 4 — для винта М12.

9. Используя приемы работы, с которыми вы уже познакомились, самостоятельно создайте по образцу три объекта с шаблоном заполнения Шайба. Отредактируйте их параметры и текстовые части.

10. Пользуясь вспомогательными объектами, сформируйте общий заголовок для вновь созданных объектов.


Упражнение 14. Вставка объекта спецификации из Справочника Стандартные Изделия

6.3. Практическое освоение основных навыков работы со спецификацией > 6.3.1. Создание простой спецификации, не связанной с другими документами > 6.3.1.2. Заполнение спецификации >

Упражнение 14. Вставка объекта спецификации из Справочника Стандартные Изделия

Это упражнение вы сможете выполнить, только если на вашем рабочем месте установлен Справочник Стандартные Изделия и есть лицензия на его использование.

Последний объект раздела Стандартные изделия — шпонка. Его можно создать так же, как и остальные объекты этого раздела — используя шаблон заполнения. Однако все крепежные изделия, а также некоторые другие объекты можно вставлять в спецификацию из Справочника Стандартные Изделия (подробнее см. раздел 6.2.2.4.3).

В данном упражнении Справочник Стандартные Изделия будет использован для вставки объекта Шпонка 14 х 9 х 80 ГОСТ 23360–78.

1. Вызовите команду Библиотеки — Стандартные изделия — Вставить элемент.

На экране появляется окно Справочника.

2. На вкладке стандартных изделий раскройте раздел Подшипники и детали машин — Шпонки — Призматические шпонки — Шпонки ГОСТ 23360–78 и выберите шпонку согласно параметрам:

• исполнение 1,

• диаметр вала — 50,

• длина — 80.

Подробно выбор объекта описан в документации Справочника.

3. После завершения выбора в раздел Стандартные изделия будет добавлен новый объект — Шпонка 14 х 9 х 80 ГОСТ 23360–78.

4. На экране останется окно Справочника для добавления очередного аналогичного объекта. Чтобы прервать вставку, нажмите клавишу <Esc>.

Объект Шпонка 14 х 9 х 80 ГОСТ 23360–78, вставленный из Справочника Стандартные Изделия, заполнен по шаблону — так же, как если бы он создавался в чертеже.

5. Чтобы убедиться в этом, войдите в режим редактирования объекта Шпонка и дважды щелкните мышью в колонке Наименование.

На экране появится таблица параметров шпонки (рис. 6.3.13). Она заполнена значениями, которые вы выбрали при создании объекта. При необходимости можно изменить любые из них. Вызов Справочника для этого не требуется.

Рис. 6.3.13. Таблица параметров шпонки

6. Закройте окно с таблицей параметров шпонки.

7. Разбейте текстовую часть объекта Шпонка 14 х 9 х 80 ГОСТ 23360–78 на две строки в соответствии с образцом. Значение в колонке Количество менять не нужно.

8. Используя вспомогательный объект спецификации, отделите объект Шпонка 14 х 9 х 80 ГОСТ 23360–78 от группы шайб пустой строкой.


Упражнение 15. Шаблонная текстовая часть в виде строки

6.3. Практическое освоение основных навыков работы со спецификацией > 6.3.1. Создание простой спецификации, не связанной с другими документами > 6.3.1.2. Заполнение спецификации >

Упражнение 15. Шаблонная текстовая часть в виде строки

В поставку системы входят шаблоны заполнения не для всех существующих материалов и стандартных изделий. Если в списке нет нужного шаблона, вы можете создать его самостоятельно. Подробнее о создании пользовательских шаблонов рассказано в разделе 6.4.5.

Однако если вы не хотите создавать собственные шаблоны или редко сталкиваетесь с отсутствием необходимого шаблона, можно пойти более простым путем — вместо выбора шаблона вручную ввести нужную строку.

1. Активизируйте раздел Материалы.

2. Нажмите клавишу <Insert>.

3. В появившемся диалоге включите опцию Текстовая часть в виде строки и нажмите кнопку Создать.

Система перейдет в режим ввода текстовой части объекта спецификации.

4. Введите в колонку Наименование текст Войлок ПФ 10 ГОСТ 6308-71, а в колонку Количество — текст 0,5 кг. Подтвердите создание объекта.

5. Войдите в режим редактирования текстовой части только что созданного объекта.

6. Дважды щелкните по тексту Войлок ПФ 10 ГОСТ 6308-71.

На экране появится окно с таблицей параметров объекта (рис. 6.3.14). Система автоматически разбила введенную строку на поля.

Эти поля в отличие от полей текстовой части, заполненной по шаблону, не имеют названий. Это связано с тем, что при их автоматическом формировании система разбивает строку на последовательности символов и числа, но не может распознать, что означают конкретные слова и числа.

Рис. 6.3.14. Таблица параметров объекта Войлок

7. Отредактируйте толщину войлока. Для этого в шестой колонке таблицы (которая соответствует полю № 4 записи) поменяйте значение 10 на значение 8. Нажмите кнопку OK. Подтвердите изменение текстовой части.

Если на вашем рабочем месте используется Справочник Материалы и Сортаменты, то при выполнении п. 6 на экране появляется не таблица параметров объекта, а меню с командами Справочника. Чтобы открыть таблицу параметров объекта, вызовите команду Редактировать.

На этом этапе выполнения упражнений текстовая часть всех объектов спецификации должна соответствовать образцу.


6.3.1.3. Окончательное оформление спецификации

В этом разделе:

Упражнение 16. Вставка разрыва страницы

Упражнение 17. Заполнение основной надписи

Упражнение 18. Печать спецификации


Упражнение 16. Вставка разрыва страницы

6.3. Практическое освоение основных навыков работы со спецификацией > 6.3.1. Создание простой спецификации, не связанной с другими документами > 6.3.1.3. Окончательное оформление спецификации >

Упражнение 16. Вставка разрыва страницы

1. При помощи вертикальной линейки прокрутки расположите спецификацию в окне так, чтобы были видны конец раздела Детали и начало раздела Стандартные изделия.

Вы увидите, что под заголовком раздела Стандартные изделия проведена горизонтальная пунктирная линия. Эта линия — автоматически возникший разрыв страницы. Он появляется, когда текстовые части объектов спецификации заняли все строки, предусмотренные в бланке листа спецификации, и для их размещения образуется следующая страница.

2. Установите выделение на заголовке раздела Стандартные изделия. Убедитесь, что в поле Текущая страница на панели Текущее состояние указан номер страницы 1.

3. Установите выделение на любой строке внутри раздела Стандартные изделия. Убедитесь, что в поле Текущая страница указан номер страницы 2.

Получается, что заголовок раздела расположен на одной странице, а его объекты — на другой. Это затрудняет использование спецификации.

4. Установите выделение на заголовке раздела Стандартные изделия.

5. Активизируйте переключатель Размещать на новом листе на Панели свойств.

Раздел Стандартные изделия переместится вниз так, что разрыв страницы теперь находится перед первой пустой строкой раздела.


Упражнение 17. Заполнение основной надписи

6.3. Практическое освоение основных навыков работы со спецификацией > 6.3.1. Создание простой спецификации, не связанной с другими документами > 6.3.1.3. Окончательное оформление спецификации >

Упражнение 17. Заполнение основной надписи

1. Перейдите в режим разметки страниц, вызвав команду Вид — Разметка страниц или нажав кнопку Разметка страниц на панели Вид.

В режиме разметки страниц спецификации невозможно создавать, удалять и редактировать объекты спецификации.

Заполнение основной надписи спецификации аналогично заполнению основной надписи любого другого документа КОМПАС-3D.

2. Заполните основную надпись спецификации по образцу. Не забудьте заполнить графу Первичное применение в верхней левой таблице основной надписи.

3. Для возврата в режим редактирования спецификации вызовите команду Вид — Нормальный режим или нажмите кнопку Нормальный режим на панели Вид.

4. Сохраните спецификацию.


Упражнение 18. Печать спецификации

6.3. Практическое освоение основных навыков работы со спецификацией > 6.3.1. Создание простой спецификации, не связанной с другими документами > 6.3.1.3. Окончательное оформление спецификации >

Упражнение 18. Печать спецификации

Чтобы напечатать получившийся документ, выполните следующие действия.

1. Вызовите команду Файл — Печать.

2. В появившемся диалоге Печать документа настройте параметры печати.

3. Нажмите в диалоге кнопку Печать.

4. Сравните полученную спецификацию с образцом.

Спецификация в формате системы КОМПАС-3D, заполненная по образцу, находится в подпапке \Manual\Exercises\Ready главной папки системы, в файле АЕКТ.620840.200.spw. Вы можете сравнить свою спецификацию и с ней.

Можно напечатать спецификацию из режима предварительного просмотра. Для перехода в этот режим вызовите команду Файл — Предварительный просмотр. Настройте размещение страниц спецификации на листах бумаги, а затем вызовите команду Файл — Вывести на печать.


6.3.2. Создание спецификации, связанной со сборочным чертежом

6.3. Практическое освоение основных навыков работы со спецификацией

6.3.2. Создание спецификации,
связанной со сборочным чертежом

Если вы последовательно выполняли предложенные в предыдущем разделе упражнения, то вы уже умеете создавать спецификацию и ее объекты, редактировать, удалять и сортировать их, проставлять номера позиций, добавлять разделы спецификации. Вы знаете, чем отличаются базовые и вспомогательные объекты, и умеете применять их по назначению. Вы знаете, что разделы и объекты спецификации можно создавать в любой последовательности, а их сортировка будет произведена автоматически. Вы умеете редактировать объекты, созданные по шаблону. Наконец, вы можете оформить спецификацию.

Все это пригодится вам при выполнении упражнений в настоящем разделе. В нем уже не будет подробных инструкций по выполнению операций, с которыми вы познакомились ранее.

Для выполнения упражнений будет использоваться комплект документов, расположенных в подпапке \Manual\Exercises\Кронштейн главной папки системы. Комплект состоит из семи чертежей 12???.cdw.

12020.cdw — сборочный чертеж кронштейна. Остальные документы — чертежи деталей кронштейна. В ходе выполнения упражнений вы дополните этот комплект спецификацией.

Кнопки вызова команд, приведенные в этом разделе, расположены на инструментальной панели Спецификация (см. раздел 6.2.1.3). Если используются кнопки с других панелей, это оговорено дополнительно.

В этом разделе:

Упражнение 19. Подготовительные действия

6.3.2.1. Объекты спецификации в чертеже

Упражнение 20. Создание объектов спецификации в чертеже

6.3.2.2. Геометрия объектов спецификации

Упражнение 21. Создание объекта спецификации, содержащего геометрию

Упражнение 22. Подключение геометрии к объекту спецификации

Упражнение 23. Просмотр геометрии объектов спецификации

Упражнение 24. Редактирование состава геометрии объектов спецификации

Упражнение 25. Создание объектов спецификации. Самостоятельная работа

6.3.2.3. Спецификация и Справочник Стандартные Изделия

Упражнение 26. Получение объектов спецификации из Справочника Стандартные Изделия

6.3.2.4. Связь сборочного чертежа и спецификации

Упражнение 27. Подключение сборочного чертежа к спецификации

Упражнение 28. Передача объектов между спецификацией и чертежом

Упражнение 29. Передача обозначения и наименования изделия между спецификацией и чертежом

6.3.2.5. Автоматический и полуавтоматический ввод данных в спецификацию

Упражнение 30. Подключение чертежа к объекту спецификации. Обмен данными между объектом и подключенным документом

6.3.2.6. Дополнительные колонки спецификации

Упражнение 31. Ввод данных в дополнительные колонки

Упражнение 32. Сложение значений в дополнительных колонках

6.3.2.7. Задания для самостоятельного выполнения

Упражнение 33. Оформление и печать спецификации

Упражнение 34. Создание спецификации


Упражнение 19. Подготовительные действия

1. Скопируйте чертежи, находящиеся в подпапке \Manual\Exercises главной папки системы, в произвольное место на жестком диске.

2. Откройте скопированные чертежи, ознакомьтесь с ними.

3. Закройте чертежи деталей, оставьте открытым только сборочный чертеж.


6.3.2.1. Объекты спецификации в чертеже

В чертеже можно создавать, редактировать и хранить объекты спецификации (см. раздел 6.2.3.1). Это точно такие же объекты, какие вы создавали в спецификации, выполняя упражнения из раздела 6.3.1. Они не видны на чертеже, но их можно просмотреть и отредактировать в специальном диалоге.

После того как вы создали объекты спецификации в чертеже, их можно с помощью специальной команды передать в документ-спецификацию. В ней эти объекты автоматически расположатся в нужных разделах, будут отсортированы по стандартным правилам, а их текстовые части займут место в нужных колонках.

В этом разделе:

Упражнение 20. Создание объектов спецификации в чертеже


Упражнение 20. Создание объектов спецификации в чертеже

6.3. Практическое освоение основных навыков работы со спецификацией > 6.3.2. Создание спецификации, связанной со сборочным чертежом > 6.3.2.1. Объекты спецификации в чертеже >

Упражнение 20. Создание объектов спецификации в чертеже

1. Вызовите команду Спецификация — Добавить объект.

2. В появившемся диалоге выберите раздел Детали и включите опцию Базовый объект спецификации. Нажмите кнопку Создать.

В появившемся окне (рис. 6.3.15) вы увидите строку спецификации, предназначенную для нового объекта. Для удобства ввода текстовой части в окне есть заголовки колонок («шапка») спецификации.

Рис. 6.3.15. Окно для ввода текстовой части объекта спецификации

3. Введите в колонку Обозначение текст КСКВ.12.605, в колонку Наименование — Ось. Умолчательное значение в колонке Количество — 1. Не изменяйте его. Нажмите кнопку OK.

В чертеже теперь есть объект спецификации.


6.3.2.2. Геометрия объектов спецификации

Базовый объект спецификации может содержать не только текстовую часть и атрибуты. В него могут входить графические объекты чертежа (см. раздел 6.2.2.5).

В этом разделе:

Упражнение 21. Создание объекта спецификации, содержащего геометрию

Упражнение 22. Подключение геометрии к объекту спецификации

Упражнение 23. Просмотр геометрии объектов спецификации

Упражнение 24. Редактирование состава геометрии объектов спецификации

Упражнение 25. Создание объектов спецификации. Самостоятельная работа


Упражнение 21. Создание объекта спецификации, содержащего геометрию

6.3. Практическое освоение основных навыков работы со спецификацией > 6.3.2. Создание спецификации, связанной со сборочным чертежом > 6.3.2.2. Геометрия объектов спецификации >

Упражнение 21. Создание объекта спецификации, содержащего геометрию

1. Любым способом выделите графические объекты, составляющие изображение плиты на сборочном чертеже. В группу выделения должна войти и линия-выноска.

2. Добавьте базовый объект в раздел Детали. Введите в колонку Обозначение текст КСКВ.12.406, в колонку Наименование — Плита, значение в колонке Количество (1) не изменяйте.

В чертеже теперь два объекта спецификации, причем к одному из них подключены геометрические объекты.

Геометрию нужно подключить и к первому объекту.


Упражнение 22. Подключение геометрии к объекту спецификации

6.3. Практическое освоение основных навыков работы со спецификацией > 6.3.2. Создание спецификации, связанной со сборочным чертежом > 6.3.2.2. Геометрия объектов спецификации >

Упражнение 22. Подключение геометрии к объекту спецификации

1. Любым способом выделите графические объекты, составляющие изображение оси на сборочном чертеже, в том числе линию-выноску.

2. Вызовите команду Спецификация — Редактировать объекты.

На экране появится новое окно, содержащее бланк спецификации с уже созданными в нем объектами. Изменится состав Главного меню и панели Спецификация. Это означает, что система переключилась в подчиненный режим редактирования спецификации (см. разделы 6.1.3.3 и 6.2.3.5).

Обратите внимание на заголовок нового окна. Он сформирован из имени сборочного чертежа и содержит комментарий Объекты спецификации. Это свидетельствует о том, что вы продолжаете работать в чертеже, а не в отдельном документе-спецификации.

3. Переместите выделение на объект спецификации с наименованием Ось.

4. Вызовите команду Редактор — Редактировать состав объекта.

На экране появится сообщение о редактировании состава объекта (рис. 6.3.16).

5. Чтобы перенести выделенные в чертеже графические объекты в объект спецификации, нажмите кнопку Добавить.

Теперь объект спецификации Ось содержит указанные вами графические объекты.

Рис. 6.3.16. Подтверждение изменения состава геометрии Оси


Упражнение 23. Просмотр геометрии объектов спецификации

6.3. Практическое освоение основных навыков работы со спецификацией > 6.3.2. Создание спецификации, связанной со сборочным чертежом > 6.3.2.2. Геометрия объектов спецификации >

Упражнение 23. Просмотр геометрии объектов спецификации

1. Расположите мозаикой два окна сборочного чертежа — окно с графическими объектами и окно с объектами спецификации.

2. Сделайте так, чтобы в окне с графическими объектами был виден весь чертеж.

3. Активизируйте окно с объектами спецификации.

4. Вызовите команду Сервис — Показать состав объекта.

5. Переместите выделение на объект Плита.

Вы увидите, что в чертеже подсветились графические объекты, подключенные к этому объекту спецификации.

6. Переместите выделение на объект Ось.

7. Убедитесь, что в чертеже подсветились графические объекты, составляющие изображение оси.

Таким образом, подключение геометрии к объекту спецификации позволяет быстро находить изображение любого объекта спецификации на чертеже. Кроме того, благодаря включению в состав геометрии объекта линии-выноски впоследствии при перерасчете номеров позиций в спецификации будут автоматически изменены и номера линий-выносок в чертеже. Вы увидите это при выполнении упражнений 27 и 30.

Добавление полок с новыми номерами к линии-выноске, подключенной к объекту (или объектам) спецификации, невозможно — количество полок и номера позиций определяются объектами спецификации. Чтобы убедиться в этом, войдите в режим редактирования линии-выноски, указывающей, например, на Ось, и создайте новую полку с любым номером позиции. После завершения редактирования линия-выноска останется без изменений.


Упражнение 24. Редактирование состава геометрии объектов спецификации

6.3. Практическое освоение основных навыков работы со спецификацией > 6.3.2. Создание спецификации, связанной со сборочным чертежом > 6.3.2.2. Геометрия объектов спецификации >

Упражнение 24. Редактирование состава геометрии объектов спецификации

1. Разверните окно чертежа.

2. Выделите в нем любые графические объекты, не относящиеся к одной детали.

3. Не снимая с них выделения, создайте новый базовый объект в разделе Детали. Введите в колонку Наименование текст Подкос, в колонке Количество оставьте 1. В колонку Обозначение ничего не вводите. Нажмите кнопку OK.

В чертеже появится объект спецификации, графический состав которого требуется исправить (так как в него входит геометрия, не относящаяся к подкосу).

4. Любым способом выделите графические объекты, составляющие изображение подкоса на сборочном чертеже, в том числе линию-выноску.

5. Войдите в подчиненный режим редактирования объектов спецификации. Для этого нужно активизировать окно подчиненного режима или вызвать команду Редактировать объекты.

6. Переместите выделение на объект спецификации с наименованием Подкос.

7. Вызовите команду Редактор — Редактировать состав объекта.

На экране появится сообщение о редактировании состава объекта.

8. Чтобы перенести выделенные в чертеже графические объекты в объект спецификации и при этом удалить старый состав объекта (подключенную к нему ранее геометрию), нажмите кнопку Заменить.

Теперь объект спецификации Подкос содержит указанные вами графические объекты.

Если при редактировании состава объекта нажать кнопку Добавить, выделенные графические объекты добавятся к уже подключенной к объекту спецификации геометрии.


Упражнение 25. Создание объектов спецификации. Самостоятельная работа

6.3. Практическое освоение основных навыков работы со спецификацией > 6.3.2. Создание спецификации, связанной со сборочным чертежом > 6.3.2.2. Геометрия объектов спецификации >

Упражнение 25. Создание объектов спецификации. Самостоятельная работа

1. Создайте в чертеже два объекта спецификации с наименованиями Лапка и Косынка (с количеством 2). Обозначения не вводите. Любым способом включите в их состав графические объекты, в том числе линии-выноски. Если вы забыли указать линии-выноски, добавьте их к подключенным графическим объектам путем редактирования состава этих объектов.

2. Расположите мозаикой окна сборочного чертежа с графическими объектами и с объектами спецификации.

3. Сделайте так, чтобы в окне с графическими объектами был виден весь чертеж.

4. Активизируйте окно с объектами спецификации и включите режим показа состава объекта.

5. Перемещая выделение на разные объекты спецификации, убедитесь, что в чертеже подсвечиваются соответствующие графические объекты.

6. Активизируйте окно чертежа, разверните его.


6.3.2.3. Спецификация и Справочник Стандартные Изделия

В сборочном чертеже, с которым вы сейчас работаете, есть стандартные изделия, изображение которых может быть вставлено из Справочника Стандартные Изделия (далее Справочник). Эти изделия — болт, гайка и шайба.

Благодаря тому, что эти изделия взяты из Справочника, возможно автоматическое формирование соответствующих им объектов спецификации (вариант по умолчанию). Управление настройками Справочника описано в его документации.

В этом разделе:

Упражнение 26. Получение объектов спецификации из Справочника Стандартные Изделия


Упражнение 26. Получение объектов спецификации из Справочника Стандартные Изделия

6.3. Практическое освоение основных навыков работы со спецификацией > 6.3.2. Создание спецификации, связанной со сборочным чертежом > 6.3.2.3. Спецификация и Справочник Стандартные Изделия >

Упражнение 26. Получение объектов спецификации из Справочника Стандартные Изделия

Это упражнение вы сможете выполнить, только если на вашем рабочем месте установлен Справочник Стандартные Изделия и есть лицензия на его использование.

1. Увеличьте масштаб изображения так, чтобы вам было удобно выполнять вставку болта, гайки и шайбы.

2. Вызовите команду Библиотеки — Стандартные изделия — Вставить элемент.

Выберите из Справочника Болт М12 х 65 ГОСТ 7798-70, как описано в его документации.

3. На экране появится фантом вставляемого объекта — графического макроэлемента.

4. Расположите его на чертеже, используя привязки.

Сразу после размещения макроэлемента на экране появится окно создания нового объекта спецификации. В нем уже будет заполнена колонка Наименование для болта и колонка Количество.

5. Нажмите кнопку OK.

6. По умолчанию запускается процесс простановки позиционной линии-выноски.

Укажите начальную точку первого ответвления (первую точку, на которую указывает позиционная линия-выноска), а затем точку начала полки. Номер позиции проставляется автоматически.

7. На экране появляется фантом макроэлемента. Чтобы прервать его вставку и вернуться в Справочник, нажмите кнопку Прервать команду на Панели специального управления.

8. Выполните вставку объектов спецификации Гайка и Шайба из Справочника.

При обозначении позиций гайки и шайбы в чертеже используйте одну и ту же линию-выноску — линию-выноску болта. Для этого в процессе вставки сделайте настройку Справочника, позволяющую добавлять позицию к существующему обозначению.

9. Переключитесь в окно подчиненного режима редактирования объектов спецификации.

Вы увидите, что в нем возник раздел Стандартные изделия с тремя объектами.

Каждый раз после ввода нового объекта спецификации происходила автоматическая сортировка объектов. Благодаря тому, что в состав объектов входят линии-выноски, при сортировке эти линии-выноски получают номера, соответствующие новым номерам позиций объектов спецификации.

10. Закройте окно подчиненного режима.

11. Сохраните чертеж.

Для объектов из Справочника Стандартные Изделия, находящихся в документе, можно создать объекты спецификации следующими способами.

– Чтобы сформировать объекты спецификации сразу для всех стандартных изделий документа, вызовите команду Библиотеки — Стандартные изделия — Создать объекты спецификаций.

– Чтобы сформировать объект спецификации для одного изделия, проверьте умолчательную настройку Справочника, касающуюся создания объектов спецификации при вставке в документ (если она отключена, включите ее). Затем отредактируйте объект — например, дважды щелкните по нему мышью в окне документа и вновь выберите объект из Справочника.


6.3.2.4. Связь сборочного чертежа и спецификации

Хотя объекты спецификации созданы еще не для всех деталей в чертеже, можно перенести существующие объекты в новую спецификацию.

В этом разделе:

Упражнение 27. Подключение сборочного чертежа к спецификации

Упражнение 28. Передача объектов между спецификацией и чертежом

Упражнение 29. Передача обозначения и наименования изделия между спецификацией и чертежом


Упражнение 27. Подключение сборочного чертежа к спецификации

6.3. Практическое освоение основных навыков работы со спецификацией > 6.3.2. Создание спецификации, связанной со сборочным чертежом > 6.3.2.4. Связь сборочного чертежа и спецификации >

Упражнение 27. Подключение сборочного чертежа к спецификации

1. Создайте новую спецификацию и сохраните ее под именем 12020.spw в папке \Manual\Exercises\Кронштейн.

2. Вызовите команду Формат — Настройка спецификации.

3. В появившемся диалоге должны быть включены опции Связь сборки или чертежа со спецификацией, Связь с расчетом позиций, Рассчитывать позиции и Рассчитывать зоны. Включите эти опции, если они были выключены.

4. Вызовите команду Сервис — Управление сборкой.

5. В появившемся диалоге нажмите кнопку Подключить документ, а в стандартном диалоге открытия файлов выберите сборочный чертеж \Manual\Exercises\Кронштейн\12020.cdw, в котором вы создавали объекты спецификации.

В окне просмотра подключенных документов появится уменьшенное изображение выбранного чертежа.

По умолчанию в диалоге управления сборкой нажата кнопка Заполнить основную надпись спецификации. Это значит, что обозначение и наименование изделия из первого подключенного чертежа должно передаваться в основную надпись спецификации. Не отключайте кнопку Заполнить основную надпись спецификации.

6. Закройте диалог управления сборкой, нажав кнопку Выход.


Упражнение 28. Передача объектов между спецификацией и чертежом

6.3. Практическое освоение основных навыков работы со спецификацией > 6.3.2. Создание спецификации, связанной со сборочным чертежом > 6.3.2.4. Связь сборочного чертежа и спецификации >

Упражнение 28. Передача объектов между спецификацией и чертежом

Сразу после закрытия диалога управления сборкой вы увидите, что в спецификации, которая только что была пуста, появились все объекты, которые были созданы в чертеже.

1. Вызовите команду Сервис — Расставить позиции. В колонке Позиция появятся новые номера позиций, а в колонке Зона — обозначения зон чертежа, в которых начинаются линии-выноски объектов.

2. Сохраните спецификацию.

При этом в сборочный чертеж будет передана информация о том, что его подключили к спецификации. Вы получите соответствующее сообщение системы.

3. Вызовите окно подчиненного режима редактирования объектов спецификации в чертеже и убедитесь, что объекты спецификации в нем остались — они были не перенесены, а скопированы в спецификацию.

4. Закройте окно подчиненного режима.

5. Активизируйте окно чертежа.

6. Убедитесь, что номера линий-выносок теперь соответствуют новым номерам позиций объектов спецификации.

7. Расположите окно документа-спецификации и окно сборочного чертежа мозаикой. Сделайте так, чтобы в окне графического документа был виден весь чертеж.

8. Активизируйте окно спецификации и включите режим показа состава объекта.

9. Перемещая выделение на разные объекты спецификации, убедитесь, что в чертеже подсвечиваются соответствующие графические объекты.

10. Максимизируйте окно документа-спецификации и создайте в разделе Детали новый базовый объект с наименованием Шарнир и количеством 1. Обозначение не вводите.

11. Переключитесь в сборочный чертеж и войдите в подчиненный режим редактирования объектов спецификации.

12. Убедитесь, что среди объектов спецификации в чертеже шарнира нет.

13. Закройте окно подчиненного режима редактирования объектов спецификации.

Объект спецификации Шарнир пока не содержит графических объектов. Исправьте это положение.

14. Выделите в сборочном чертеже графические объекты, относящиеся к шарниру (не забудьте о линии-выноске).

15. Перейдите в окно документа-спецификации.

16. Выделите объект Шарнир и отредактируйте его состав.

17. Увеличьте количество резервных строк в разделе Детали до трех.

18. Расставьте позиции.

Обратите внимание на то, что после расстановки позиций у объекта Шарнир появилось обозначение зоны.

19. Вызовите команду Сервис — Синхронизировать данные.

Вы получите сообщение об изменении сборочного чертежа.

20. Перейдите в окно чертежа и вызовите окно подчиненного режима редактирования объектов спецификации.

21. Убедитесь, что среди объектов спецификации в чертеже появился Шарнир, а нумерация позиций соответствует новой нумерации позиций в документе-спецификации.

22. Активизируйте окно чертежа и убедитесь, что номера линий-выносок теперь соответствуют новым номерам позиций объектов спецификации.

Таким образом, по команде синхронизации произошла передача данных (объектов спецификации) из спецификации в чертеж.

23. Выделите в окне подчиненного режима объект с наименованием Подкос, войдите в режим его редактирования и введите обозначение КСКВ.12.805.

24. Переключитесь в окно чертежа и вызовите команду Спецификация — Синхронизировать данные.

Вы получите сообщение об изменении спецификации.

25. Перейдите в окно спецификации.

26. Убедитесь, что у объекта спецификации Подкос появилось обозначение.

Таким образом, по команде синхронизации произошла передача данных (объектов спецификации) из чертежа в спецификацию.

Направление передачи данных при синхронизации зависит от того, из какого документа была вызвана команда.

Если в момент вызова команды было активно окно спецификации, новое состояние ее объектов будет принято чертежом. И наоборот, при синхронизации из чертежа его объекты будут переданы в спецификацию.

Работа в подчиненном режиме ничем не отличается от работы в документе-спецификации (исключением является невозможность заполнить основную надпись и распечатать спецификацию из подчиненного режима).

Поэтому вы можете создавать объекты спецификации как в чертеже, так и в спецификации. В любой момент можно передать объекты из одного документа в другой.


Упражнение 29. Передача обозначения и наименования изделия между спецификацией и чертежом

6.3. Практическое освоение основных навыков работы со спецификацией > 6.3.2. Создание спецификации, связанной со сборочным чертежом > 6.3.2.4. Связь сборочного чертежа и спецификации >

Упражнение 29. Передача обозначения и наименования изделия
между спецификацией и чертежом

1. Перейдите в режим разметки страниц. Убедитесь, что обозначение и наименование изделия — КСКВ.12.020 и Кронштейн — передались из подключенного сборочного чертежа в основную надпись спецификации. Эта передача произошла благодаря тому, что при подключении к спецификации сборочного чертежа была нажата кнопка Заполнить основную надпись спецификации (см. п. 5 упражнения 27).

Обратите внимание на то, что обозначение и наименование подключенного документа — СБ и Сборочный чертеж — в спецификацию не попали.

Кнопка Заполнить основную надпись спецификации управляет передачей обозначения и наименования изделия только в одном направлении: из подключенного документа в спецификацию.

2. Чтобы убедиться в этом, войдите в режим редактирования основной надписи спецификации и произвольно отредактируйте обозначение и наименование изделия.

3. Выйдите из режима редактирования основной надписи и сохраните спецификацию.

4. Переключитесь в окно сборочного чертежа.

5. Убедитесь, что обозначение и наименование изделия в нем остались прежние — КСКВ.12.020 и Кронштейн.

6. Сохраните чертеж.

В этот момент из него в спецификацию будет передано обозначение и наименование изделия.

7. Переключитесь в окно спецификации и убедитесь, что обозначение и наименование изделия в ее основной надписи восстановились.

Передача обозначения и наименования изделия возможна и в обратном направлении — из спецификации в подключенный документ. В данном упражнении между основной надписью спецификации и сборочным чертежом будет установлена двусторонняя связь.

8. Вызовите команду Сервис — Управление сборкой.

9. В появившемся диалоге включите опцию в колонке Передавать изменения в документ для единственного подключенного документа. Эта колонка управляет передачей обозначения и наименования изделия из спецификации в подключенные документы.

10. Закройте диалог, нажав кнопку Выход.

11. Снова войдите в режим редактирования основной надписи спецификации и произвольным образом отредактируйте обозначение и наименование изделия.

12. Выйдите из режима редактирования основной надписи и сохраните спецификацию. Вы получите сообщение об изменении сборочного чертежа.

13. Переключитесь в окно чертежа.

14. Убедитесь, что в его основной надписи появились новые обозначение и наименование изделия. Они передались из спецификации в момент ее сохранения.

15. Войдите в режим редактирования основной надписи чертежа и восстановите наименование и обозначение изделия — КСКВ.12.020 и Кронштейн.

16. Выйдите из режима редактирования основной надписи чертежа и сохраните его.

Новые обозначение и наименования будут переданы в спецификацию. Вы получите сообщение об изменении документа-спецификации.

17. Переключитесь в окно спецификации и убедитесь, что в ее основной надписи появились нужные обозначение и наименование.

18. Сохраните спецификацию.

Таким образом, передача обозначения и наименования изделия между спецификацией и подключенным документом возможна в как обоих направлениях, так и в каком-либо одном.

Передача обозначения и наименования в спецификацию производится из одного документа — того, имя которого стоит первым в списке подключенных (для перемещения имени документа по списку пользуйтесь кнопками со стрелками).

Передача обозначения и наименования из спецификации производится во все документы, которые отмечены «галочкой» в колонке Передавать изменения в документ.

Если передача включена, то она производится автоматически при сохранении того документа, который передает обозначение и наименование изделия в другой документ (другие документы).

Подробнее передача данных между основной надписью спецификации и подключенными документами рассмотрена в разделе 6.2.4.2.3.


6.3.2.5. Автоматический и полуавтоматический ввод данных в спецификацию

6.3.2.5. Автоматический и полуавтоматический ввод данных
в спецификацию

Выполняя предыдущие упражнения, вы вводили текст в колонки спецификации вручную (с клавиатуры).

В этом разделе вы познакомитесь со способами автоматизации ввода данных в спецификацию.

В этом разделе:

Упражнение 30. Подключение чертежа к объекту спецификации. Обмен данными между объектом и подключенным документом


Упражнение 30. Подключение чертежа к объекту спецификации. Обмен данными между объектом и подключенным документом

6.3. Практическое освоение основных навыков работы со спецификацией > 6.3.2. Создание спецификации, связанной со сборочным чертежом > 6.3.2.5. Автоматический и полуавтоматический ввод данных в спецификацию >

Упражнение 30. Подключение чертежа к объекту спецификации.
Обмен данными между объектом и подключенным документом

На экране находится окно спецификации.

1. Если спецификация отображается в режиме разметки страниц, отключите его, нажав кнопку Нормальный режим.

2. Выделите объект Плита в разделе Детали.

3. Активизируйте вкладку Документы на Панели свойств.

4. Разверните панель Документы, расположенную на этой вкладке.

5. Нажмите на ней кнопку Добавить документ.

6. В стандартном диалоге открытия файлов выберите файл 12406.cdw из папки \Manual\Exercises\Кронштейн.

7. На запрос системы «Взять данные из основной надписи?» ответьте Да.

Вы подключили чертеж к объекту спецификации (подобно тому, как ранее вы подключили сборочный чертеж к самой спецификации).

8. Таким же способом подключите чертежи деталей к оставшимся в текущем разделе объектам спецификации:

• к объекту Косынка — чертеж 12405.cdw,

• к объекту Лапка — чертеж 12407.cdw,

• к объекту Ось — чертеж 12605.cdw,

• к объекту Подкос — чертеж 12805.cdw,

• к объекту Шарнир — чертеж 12604.cdw.

Вы увидите, что в колонке Формат появились обозначения форматов соответствующих чертежей деталей, а в колонке Обозначение теперь есть обозначения всех деталей. Эти данные были автоматически переданы в спецификацию из основных надписей подключенных к объектам спецификации чертежей.

Так как объекты в разделе Детали сортируются по обозначениям, после появления обозначений у тех деталей, у которых их ранее не было, произошла автоматическая сортировка объектов.

9. Если автоматическая сортировка не произошла, отожмите и вновь нажмите кнопку Автоматическая сортировка на панели Текущее состояние.

10. Расставьте позиции.

11. Сохраните спецификацию.

При сохранении спецификации происходит синхронизация данных (передача изменений объектов спецификации в подключенный сборочный чертеж). В сборочный чертеж передаются сведения о подключении файлов к объектам спецификации, поэтому вы получите сообщение об изменении файла со сборочным чертежом.

12. Откройте файл 12605.cdw, содержащий чертеж оси.

13. Убедитесь, что обозначение детали в его основной надписи совпадает с ее обозначением в спецификации.

14. Перейдите в режим редактирования основной надписи и отредактируйте обозначение. Например, вместо КСКВ.12.605 введите ВКСК.21.001. При помощи команды Параметры текущего чертежа измените формат с А4 на А3.

15. Сохраните чертеж.

На экране появится запрос о необходимости передать внесенные в чертеж изменения в спецификацию (чертеж «помнит», что он подключен к объекту спецификации).

16. Нажмите кнопку Да.

17. Закройте чертеж.

18. Активизируйте окно спецификации.

19. Убедитесь, что в ней появилось новое обозначение оси и формат чертежа оси изменился.

20. Выделите объект Лапка.

21. Активизируйте вкладку Документы на Панели свойств. Включите опцию Передавать изменения в документ напротив имени файла чертежа лапки.

22. Войдите в режим редактирования объекта Лапка.

23. Измените его обозначение (например, вместо КСКВ.12.407 введите КВКС.12.444). Подтвердите изменение текстовой части, нажав комбинацию клавиш <Ctrl>+<Enter>.

24. Сохраните спецификацию (при этом произойдет передача данных в чертежи).

25. Откройте файл 12407.cdw и убедитесь, что обозначение лапки в основной надписи ее чертежа изменилось.

26. Закройте чертеж лапки.

27. Любым способом отредактируйте обозначения, которые вы меняли, так, чтобы они стали прежними — КСКВ.12.605 и КСКВ.12.407. Откройте чертеж оси, измените его формат на А4 и сохраните.

28. Создайте в спецификации новый раздел — Документация и базовый объект в нем.

29. Не вводите никаких символов в строку, предназначенную для нового объекта. Подключите к новому объекту файл \Manual\Exercises\Кронштейн\12020.cdw, содержащий сборочный чертеж.

Опция Передавать изменения в документ должна быть выключена. В противном случае окажется, что основная надпись чертежа 12020.cdw получает данные сразу из двух мест: из объекта спецификации и из ее основной надписи (эта передача была включена при выполнении упражнения 29, п. 9). Такое «двойное» управление может привести к нестабильности в работе системы.

Передачу данных из объекта спецификации в документ 12020.cdw можно оставить включенной. Но в этом случае необходимо выключить передачу данных в него из основной надписи спецификации.

Вы увидите, что в колонках спецификации появились данные из основной надписи сборочного чертежа.

Из-за сильного сужения символов невозможно прочитать обозначение формата.

30. Поместите курсор в колонку Формат редактируемого объекта и нажмите правую кнопку мыши.

31. В появившемся контекстном меню выберите команду Перенести в последнюю колонку.

В результате действия этой команды содержимое ячейки, в которой находится курсор, переносится в последнюю колонку, предваряясь символами *), эти же символы появляются на месте текста в первой колонке.

32. Не изменяя содержимого остальных колонок, подтвердите создание объекта.

Вы увидите, что наименование изделия — Кронштейн — исчезло. Теперь в колонке Наименование присутствует, как этого требует стандарт, лишь наименование документа — Сборочный чертеж.

На самом деле наименование изделия осталось в объекте спецификации — просто его отображение автоматически отключилось. Это произошло потому, что обозначение и наименование изделия в объекте спецификации — КСКВ.12.020 и Кронштейн — совпало с обозначением и наименованием изделия в основной надписи спецификации. Подробно данный механизм рассмотрен в разделе 6.2.2.10.

33. Войдите в режим редактирования объекта Сборочный чертеж и убедитесь, что наименование изделия — Кронштейн — присутствует в колонке Наименование.

34. Не внося никаких изменений в текстовую часть объекта, выйдите из режима его редактирования.

Рассмотренный способ автоматизации заполнения спецификации применяется в случае, если уже существуют чертежи с заполненной основной надписью, из которых можно взять данные. Однако механизм подключения документов к объекту спецификации можно использовать и в другом направлении.

Вы можете вначале заполнить спецификацию, а затем передавать данные из нее в основные надписи создаваемых чертежей деталей (при этом не забывайте о включении соответствующей опции).

Если к объекту спецификации подключено несколько документов, информация будет передаваться в спецификацию из того документа, имя которого стоит первым в списке подключенных документов (для перемещения имени документа по списку пользуйтесь кнопками со стрелками). Например, вы подключили к объекту из раздела Сборочные единицы несколько документов, содержащих чертеж сборочной единицы. Первым в списке подключенных документов должен быть первый лист сборочного чертежа, тогда наименование изделия из него попадет в спецификацию (в последующих листах сборочного чертежа наименование изделия отсутствует).


6.3.2.6. Дополнительные колонки спецификации

Каждый материальный объект, включаемый в спецификацию (например, деталь или сборочная единица), обладает рядом свойств и характеристик, использование которых может понадобиться для расчетов или в справочных целях. В качестве примера можно привести массу детали.

Для хранения информации такого рода предназначены дополнительные колонки спецификации. Эти колонки (а следовательно, и данные в них) не видны в бланке спецификации и не выводятся на печать. Однако их можно просмотреть и отредактировать в специальном диалоге, а также использовать для выполнения вспомогательных вычислений.

В этом разделе:

Упражнение 31. Ввод данных в дополнительные колонки

Упражнение 32. Сложение значений в дополнительных колонках


Упражнение 31. Ввод данных в дополнительные колонки

6.3. Практическое освоение основных навыков работы со спецификацией > 6.3.2. Создание спецификации, связанной со сборочным чертежом > 6.3.2.6. Дополнительные колонки спецификации >

Упражнение 31. Ввод данных в дополнительные колонки

1. Выделите первый объект раздела Детали — Косынку.

2. Активизируйте вкладку Параметры на Панели свойств.

3. Разверните панель Дополнительные колонки, расположенную на этой вкладке.

По умолчанию в спецификации есть две дополнительные колонки — Масса и Код ОКП. Вы увидите в строке Масса значение, попавшее в спецификацию из основной надписи подключенного к объекту чертежа.

Вы можете отредактировать значение массы.

Если вы измените значение массы, то при сохранении спецификации или синхронизации данных новое значение массы из нее попадет в основную надпись чертежа детали (при условии, что опция передачи изменений в документ включена). Если вы измените значение массы в основной надписи чертежа, то при его сохранении можно будет подтвердить передачу изменения в спецификацию.

4. Просмотрите значения массы всех деталей, входящих в спецификацию. Для этого последовательно выделяйте объекты спецификации, не закрывая панель Дополнительные колонки.

5. Сравните эти значения со значениями массы в соответствующих чертежах (они должны совпадать).

6. Если хотите, отредактируйте значения массы объектов спецификации любым способом (непосредственно в спецификации или в чертеже с последующей передачей изменений в спецификацию).

7. Самостоятельно введите массы трех стандартных изделий, которые есть в спецификации (эти массы можно найти в справочнике).


Упражнение 32. Сложение значений в дополнительных колонках

6.3. Практическое освоение основных навыков работы со спецификацией > 6.3.2. Создание спецификации, связанной со сборочным чертежом > 6.3.2.6. Дополнительные колонки спецификации >

Упражнение 32. Сложение значений в дополнительных колонках

1. Вызовите команду Сервис — Сложить значения в колонках.

В появившемся диалоге вы увидите сумму масс объектов спецификации. При вычислении этой суммы было учтено количество каждого объекта.

2. Сохраните результат расчета в текстовом файле. Для этого нажмите в диалоге кнопку Записать... и укажите имя текстового файла.


6.3.2.7. Задания для самостоятельного выполнения

В этом разделе:

Упражнение 33. Оформление и печать спецификации

Упражнение 34. Создание спецификации


Упражнение 33. Оформление и печать спецификации

6.3. Практическое освоение основных навыков работы со спецификацией > 6.3.2. Создание спецификации, связанной со сборочным чертежом > 6.3.2.7. Задания для самостоятельного выполнения >

Упражнение 33. Оформление и печать спецификации

1. Еще раз расставьте позиции, если нарушен их порядок.

2. Заполните основную надпись.

3. Сохраните спецификацию.

4. Напечатайте ее.

5. Сравните получившуюся у вас спецификацию с образцом, который находится в подпапке \Manual\Exercises\Ready\12020 главной папки системы, в файле 12020.spw.


Упражнение 34. Создание спецификации

6.3. Практическое освоение основных навыков работы со спецификацией > 6.3.2. Создание спецификации, связанной со сборочным чертежом > 6.3.2.7. Задания для самостоятельного выполнения >

Упражнение 34. Создание спецификации

Самостоятельно создайте спецификацию на основе сборочного чертежа, который был ранее выпущен на вашем предприятии с использованием системы КОМПАС-3D.

По возможности применяйте все изученные вами приемы работы со спецификацией — создание объектов спецификации в чертеже и спецификации, синхронизацию данных, автоматическое заполнение текстовой части, подключение графических объектов и документов к объекту спецификации, задание дополнительных параметров и т.д.

Для разрешения вопросов, возникших в ходе работы, обращайтесь к настоящей Справочной системе.


6.3.3. Создание спецификации, связанной с моделью-сборкой

6.3. Практическое освоение основных навыков работы со спецификацией

6.3.3. Создание спецификации, связанной с моделью-сборкой

Для выпуска спецификаций на изделия, смоделированные в КОМПАС-3D, удобно воспользоваться возможностью автоматического заполнения спецификации на основе имеющихся данных о компонентах сборки.

Для выполнения упражнений будет использоваться комплект документов-моделей, расположенных в подпапке \Manual\Exercises\Блок направляющий главной папки системы. Скопируйте эти модели в произвольное место на жестком диске.

Блок направляющий.a3d — модель-сборка Блока направляющего.

Вилка.m3d, Кронштейн.m3d, Масленка.m3d, Ось.m3d, Планка.m3d — детали Блока направляющего.

Ролик в сборе.a3d — сборка, состоящая из деталей Втулка.m3d и Ролик.m3d и входящая в сборку Блок направляющий.a3d в качестве подсборки.

В этом разделе:

6.3.3.1. Подготовка данных для спецификации в компонентах сборки

Упражнение 35. Создание объектов спецификации в деталях

Упражнение 36. Создание объектов спецификации в подсборке

6.3.3.2. Передача объектов из сборки в спецификацию

Упражнение 37. Создание документа-спецификации и подключение к ней сборки

Упражнение 38. Вставка объектов спецификации из Справочника Стандартные Изделия

6.3.3.3. Полный комплект ассоциативных документов

Упражнение 39. Создание спецификации, связанной со сборкой и сборочным чертежом


6.3.3.1. Подготовка данных для спецификации в компонентах сборки

В этом разделе:

Упражнение 35. Создание объектов спецификации в деталях

Упражнение 36. Создание объектов спецификации в подсборке


Упражнение 35. Создание объектов спецификации в деталях

6.3. Практическое освоение основных навыков работы со спецификацией > 6.3.3. Создание спецификации, связанной с моделью-сборкой > 6.3.3.1. Подготовка данных для спецификации в компонентах сборки >

Упражнение 35. Создание объектов спецификации в деталях

1. Откройте файл модели \Блок направляющий\Вилка.m3d.

2. В Дереве построения выделите корневой объект — Вилка.

3. Вызовите команду Спецификация — Добавить объект.

4. В появившемся диалоге выберите раздел Детали, активизируйте опцию Базовый объект спецификации и нажмите кнопку Создать.

На экране появится окно, содержащее строку из бланка спецификации и «шапку» этого бланка. В ней уже находятся обозначение и наименование детали. Они были созданы в модели заранее, на этапе ее построения, что позволило сформировать текстовую часть нового объекта спецификации автоматически. Кроме того, в колонку Количество внесено значение 1.

5. Нажмите кнопку OK в окне Объект спецификации.

6. Сохраните и закройте файл детали.

7. Выполните п.п. 1–6 для остальных деталей, входящих в сборку — Кронштейн.m3d, Масленка.m3d, Ось.m3d, Планка.m3d.


Упражнение 36. Создание объектов спецификации в подсборке

6.3. Практическое освоение основных навыков работы со спецификацией > 6.3.3. Создание спецификации, связанной с моделью-сборкой > 6.3.3.1. Подготовка данных для спецификации в компонентах сборки >

Упражнение 36. Создание объектов спецификации в подсборке

1. Откройте файл модели \Блок направляющий\Ролик в сборе.a3d.

2. В Дереве построения выделите корневой объект — Ролик в сборе.

3. Вызовите команду Спецификация — Добавить объект — Внешний.

4. В появившемся диалоге выберите раздел Сборочные единицы, активизируйте опцию Базовый объект спецификации и нажмите кнопку Создать.

5. Убедитесь, что появившееся окно Объект спецификации содержит верные сведения о сборке и нажмите кнопку OK.

6. Сохраните и закройте файл сборки.


6.3.3.2. Передача объектов из сборки в спецификацию

В этом разделе:

Упражнение 37. Создание документа-спецификации и подключение к ней сборки

Упражнение 38. Вставка объектов спецификации из Справочника Стандартные Изделия


Упражнение 37. Создание документа-спецификации и подключение к ней сборки

6.3. Практическое освоение основных навыков работы со спецификацией > 6.3.3. Создание спецификации, связанной с моделью-сборкой > 6.3.3.2. Передача объектов из сборки в спецификацию >

Упражнение 37. Создание документа-спецификации и подключение к ней сборки

1. Создайте новую спецификацию.

2. Сохраните ее в файле \Блок направляющий\Блок.spw.

3. Вызовите команду Сервис — Управление сборкой.

4. В появившемся диалоге нажмите кнопку Подключить документ.

5. В следующем диалоге выберите файл сборки \Блок направляющий\Блок направляющий.a3d и нажмите кнопку Открыть.

6. Настройте передачу обозначения и наименования между основной надписью спецификации и подключенной сборкой по своему усмотрению.

7. Нажмите кнопку Выход в диалоге управления сборкой.

В таблице спецификации появятся объекты, соответствующие всем компонентам сборки (произойдет синхронизация спецификации со сборкой).

8. Заполните основную надпись спецификации.

9. Сохраните спецификацию.

Приемы работы с полученной спецификацией (сортировка объектов, подключение документов, простановка позиций и т.д.) — такие же, как при работе с любой другой спецификацией. Вы уже изучили их при выполнении предыдущих упражнений, поэтому в этом разделе они не рассматриваются.


Упражнение 38. Вставка объектов спецификации из Справочника Стандартные Изделия

6.3. Практическое освоение основных навыков работы со спецификацией > 6.3.3. Создание спецификации, связанной с моделью-сборкой > 6.3.3.2. Передача объектов из сборки в спецификацию >

Упражнение 38. Вставка объектов спецификации из Справочника Стандартные Изделия

Это упражнение вы сможете выполнить, только если на вашем рабочем месте установлен Справочник Стандартные Изделия и есть лицензия на его использование.

Объект спецификации создается по умолчанию при вставке в модель объекта из Справочника Стандартные Изделия (далее Справочника).

В данном упражнении производится вставка в сборку следующих стандартных изделий:

– Болт М18–8gx90 ГОСТ 15589–70 — 4 штуки,

– Шайба 2.18.21 ГОСТ 11371–78 — 4 штуки,

– Шайба 18 ГОСТ 6402–70 — 4 штуки,

– Гайка М18–6H ГОСТ 5927–70 — 4 штуки,

– Винт А.М6–6gx14 ГОСТ 17473–80 — 2 шутки,

– Шайба 2.6.21 ГОСТ 11371–78 — 2 штуки.

В качестве образца для размещения крепежа вы можете использовать готовую модель блока (\Manual\Exercises\Ready\01100\Блок направляющий.a3d), хотя, конечно, ни расположение стандартного изделия в сборке, ни наложенные на него сопряжения не влияют на связанный с ним объект спецификации.

1. Откройте сборку Блок направляющий\Блок направляющий.a3d.

2. Вызовите команду Библиотеки — Стандартные изделия — Вставить элемент.

Выберите из Справочника первый объект, например, болт М18x90 ГОСТ 15589-70. Порядок выбора объектов из справочника описан в его документации.

3. На экране появится фантом вставляемого объекта. Расположите его в модели.

Сразу после размещения макроэлемента на экране появится окно создания нового объекта спецификации. В нем уже будет заполнена колонка Наименование для болта и колонка Количество.

4. Нажмите кнопку OK.

5. На экране появляется фантом болта для повторной вставки. Чтобы прервать вставку и вернуться в Справочник, нажмите кнопку Прервать команду на Панели специального управления.

6. Перейдите в подчиненный режим редактирования внутренних объектов спецификации в сборке. Убедитесь, что в разделе Стандартные изделия появился Болт.

7. Вернитесь в окно редактирования сборки и аналогичным способом — вставляя из Справочника стандартные изделия — создайте в сборке остальные объекты спецификации.

Если в сборке есть несколько одинаковых стандартных изделий, необязательно создавать объект спецификации для каждого из них. Достаточно создать один объект и в его колонке Количество указать количество изделий.

8. Перейдите в подчиненный режим редактирования внутренних объектов спецификации в сборке. Убедитесь, что в разделе Стандартные изделия появилась информация обо всех вставленных крепежных изделиях. Закройте окно подчиненного режима.

Для объектов из Справочника Стандартные Изделия, находящихся в документе, можно создать объекты спецификации следующими способами.

– Чтобы сформировать объекты спецификации сразу для всех стандартных изделий документа, вызовите команду Библиотеки — Стандартные изделия — Создать объекты спецификаций.

– Чтобы сформировать объект спецификации для одного изделия, проверьте умолчательную настройку Справочника, касающуюся создания объектов спецификации при вставке в документ (если она отключена, включите ее). Затем отредактируйте объект — например, выделите компонент в Дереве построения и вызовите команду контекстного меню Редактировать, а затем сделайте выбор объекта из Справочника.

9. Сохраните сборку.

10. Вы получите сообщение об изменении подключенной к ней спецификации.

11. Откройте спецификацию и убедитесь, что в ней появился и оказался заполненным раздел Стандартные изделия.

Сравните получившуюся у вас спецификацию с образцом, который находится в подпапке \Manual\Exercises\Ready\01100 главной папки системы, в файле Блок.spw.

Объекты спецификации хранятся внутри компонентов сборки — деталей, подсборок, библиотечных компонентов. Вы создали объекты спецификации в компонентах при выполнении упражнений 35, 36 и 38.

Однако наличие в компоненте сборки объекта спецификации еще не означает, что он непременно появится в числе внутренних объектов спецификации этой сборки. Для включения объекта спецификации компонента во внутренние объекты спецификации сборки служит опция Создавать объекты спецификации, доступная на Панели свойств при настройке свойств компонента. По умолчанию эта опция включена, и объекты спецификации передаются из компонентов в сборку. Если отредактировать свойства компонента, отключив опцию Создавать объекты спецификации, то объект спецификации — оставаясь в компоненте — перестанет отображаться во внутренних объектах спецификации сборки.


6.3.3.3. Полный комплект ассоциативных документов

Вы можете организовать ассоциативную связь не только между сборочным чертежом и спецификацией или между сборкой и спецификацией, но и между всеми тремя документами.

В этом разделе:

Упражнение 39. Создание спецификации, связанной со сборкой и сборочным чертежом


Упражнение 39. Создание спецификации, связанной со сборкой и сборочным чертежом

6.3. Практическое освоение основных навыков работы со спецификацией > 6.3.3. Создание спецификации, связанной с моделью-сборкой > 6.3.3.3. Полный комплект ассоциативных документов >

Упражнение 39. Создание спецификации,
связанной со сборкой и сборочным чертежом

1. Откройте файлы моделей \Блок направляющий\Втулка.m3d и \Блок направляющий\Ролик.m3d, входящих в состав сборки Ролик в сборе.a3d.

2. Создайте в них объекты спецификации, как при выполнении п.п. 1 – 6 из упражнения 35.

3. Сохраните и закройте файлы деталей.

4. Откройте файл сборки \Блок направляющий\Ролик в сборе.a3d.

5. Перейдите в подчиненный режим редактирования внутренних объектов спецификации.

6. Убедитесь, что в сборке появились два объекта спецификации, соответствующие Втулке и Ролику.

7. Создайте и сохраните ассоциативный чертеж сборки Ролик в сборе.a3d.

8. Перейдите в подчиненный режим редактирования объектов спецификации в чертеже.

9. Убедитесь, что в чертеже появилось два объекта спецификации.

10. Создайте документ-спецификацию и подключите к ней сборку и сборочный чертеж.

11. Убедитесь, что в спецификации появились объекты.

12. Расположите мозаикой окна спецификации, сборки и сборочного чертежа.

13. Активизируйте спецификацию и включите режим показа геометрии объектов.

14. Последовательно выделяя объекты, убедитесь, что их геометрия подсвечивается как в сборке, так и в чертеже.

Хотя вы и не включали вручную графические объекты из чертежа в состав объектов спецификации, геометрия входит в состав объектов. Так получилось потому, что графические объекты в сборочном чертеже — ассоциативные (а не начерченные вручную). Они «приходят» в чертеж из сборки вместе с объектами спецификации и сохраняют связь с трехмерными компонентами, которые они изображают.

15. Проставьте в чертеже позиционные линии-выноски и включите их в состав объектов спецификации.

16. Синхронизируйте чертеж со спецификацией.

17. Создайте в спецификации раздел Документация и включите в него объект, соответствующий сборочному чертежу (как это было сделано при выполнении пп. 28–32 из упражнения 30).

18. Заполните основную надпись спецификации.

19. Сохраните все ассоциативные документы.


6.3.4. Создание групповой спецификации

6.3. Практическое освоение основных навыков работы со спецификацией

6.3.4. Создание групповой спецификации

В этом разделе:

Упражнение 40. Создание групповой спецификации по варианту Б

Упражнение 41. Создание групповой спецификации по варианту Б с числом исполнений более десяти

Упражнение 42. Создание групповой спецификации по варианту А


Упражнение 40. Создание групповой спецификации по варианту Б

Найдите твердую копию любой групповой спецификации, составленной на вашем предприятии. Количество исполнений изделия, на которое она составлена, должно быть не больше десяти (включая основное, не имеющее номера исполнение).

1. Создайте новую спецификацию.

2. Вызовите команду Сервис — Параметры — Текущая спецификация — Стиль и в качестве стиля спецификации укажите строку Групповая спецификация ГОСТ 2.113-75. Ф1, 1а.

3. Вызовите команду Формат — Настройка спецификации.

4. В появившемся диалоге введите в поле Количество исполнений количество исполнений специфицируемого изделия (считая базовое исполнение).

5. Заполните спецификацию путем создания в ней объектов. В каждом объекте будет несколько колонок Количество. Вводите в них количество данного объекта для исполнений (в первую колонку Количество — для базового исполнения, во вторую — для первого исполнения и так далее).

Обратите внимание на то, что номер текущего исполнения отображается в Строке сообщений.

В таблице спецификации номера исполнений специфицируемого изделия отображаются в специальной строке, озаглавленной Обозн. исполн. (Обозначения исполнений). Серый цвет этой строки показывает, что в режиме разметки страниц она не будет отображаться — номера исполнений перейдут в «шапку» спецификации.

6. Если у вас есть сборочный чертеж специфицируемого изделия, выполненный в КОМПАС-3D, подключите его к спецификации.

7. Введите в состав объектов спецификации соответствующую им геометрию из сборочного чертежа. Вы можете также подключить к объектам спецификации их чертежи.

8. Вызовите в спецификации команду Расставить позиции.

9. Сохраните спецификацию. При этом произойдет синхронизация — передача некоторых объектов из спецификации в подключенный чертеж (или чертежи).

10. Если сборочный чертеж в электронном виде отсутствует, сохраните заполненную вручную спецификацию.

11. Напечатайте получившийся документ-спецификацию.


Упражнение 41. Создание групповой спецификации по варианту Б с числом исполнений более десяти

Упражнение 41. Создание групповой спецификации по варианту Б
с числом исполнений более десяти

Это упражнение позволяет освоить создание и настройку спецификации на изделие, количество исполнений которого больше, чем количество колонок бланка спецификации для ввода количества на исполнение (проще говоря, спецификацию для количества исполнений больше десяти).

Если такие спецификации не выпускаются на вашем предприятии или вы не занимаетесь их составлением, это упражнение можно не выполнять.

Основной упор в упражнении сделан на порядок редактирования объектов и настройку их отображения в спецификации.

Подключение спецификации с количеством исполнений более десяти к сборочному чертежу, ввод геометрии в состав объектов спецификации, ввод дополнительных параметров объектов спецификации производятся в обычном порядке (вы изучили его при выполнении предыдущих упражнений).

1. Создайте новую спецификацию.

2. Вызовите команду Сервис — Параметры — Текущая спецификация — Стиль и в качестве стиля спецификации укажите строку Групповая спецификация ГОСТ 2.113-75. Ф1б, 1в.

3. Вызовите команду Формат — Настройка спецификации.

4. В появившемся диалоге активизируйте вкладку Блоки исполнений.

Опции этой вкладки служат для настройки ввода и отображения информации, касающейся исполнений (как исполнений специфицируемого изделия, так и исполнений изделий, входящих в его состав).

5. В группе Формирование номеров исполнений изделия включите опции Вставлять нули перед числом и Вставлять тире перед числом.

6. В группе Формировать обозначения исполнений объектов выберите вариант Показывать полностью.

7. Обратите внимание на то, что группа опций Выдавать информацию… недоступна. Эти опции служат для настройки отображения спецификации, если количество исполнений в ней больше десяти.

8. Активизируйте вкладку Настройки и в поле Количество исполнений введите 25.

Это означает, что текущая спецификация составляется для изделия с двадцатью пятью исполнениями (включая основное, не имеющее номера).

9. Вновь активизируйте вкладку Блоки исполнений.

Вы увидите, что прежде недоступные опции теперь открыты (так как число исполнений превысило число колонок для ввода количества на исполнение).

10. Активизируйте опцию Выдавать информацию — Блоками.

11. Закройте диалог настройки спецификации, нажав кнопку OK.

12. Сохраните спецификацию под любым именем.

Обычно таблица групповой спецификации в натуральную величину не помещается на экране по ширине. Рекомендуется для удобства работы подобрать такой масштаб отображения спецификации, чтобы ее строки были видны полностью.

13. Для этого нажмите кнопку Масштаб по ширине листа на панели Вид.

Масштаб отображения спецификации будет подобран автоматически.

Теперь можно приступать к вводу объектов спецификации.

14. Нажмите клавишу <Insert>.

15. В появившемся диалоге выберите раздел Документация для размещения нового объекта и нажмите кнопку Создать.

В таблице спецификации станет доступной строка для ввода текстовой части нового объекта.

Обратите внимание на то, что в колонках Количество строка разделена на три части (строки) по горизонтали. Такое разделение нужно для того, чтобы сделать возможным ввод двадцати пяти значений количества в десять колонок. В первую строку будут вводиться количества для исполнений с основного по девятое, во вторую — с десятого по девятнадцатое, в третью — оставшиеся количества.

16. Введите в колонку Формат текст А1.

Первый объект раздела Документы должен иметь обозначение АБВГ.000.000000 СБ. Как и при заполнении простой спецификации (см. Упражнение 3, п. 4), попытка ввода текста в колонку Обозначение приводит к автоматическому открытию диалога Обозначение.

17. Введите в поле Базовое обозначение диалога Обозначение текст АБВГ.000.000000, в поле Код — текст СБ, после чего закройте диалог кнопкой ОК.

Текст Сборочный чертеж в колонке Наименование появится автоматически.

18. Во всех ячейках Количество введите символ Х.

Обратите внимание на то, что в последние пять ячеек третьей строки, соответствующие исполнениям с 25 по 29, невозможно ввести данные — спецификация не позволяет вводить информацию об исполнениях, не предусмотренных при ее настройке.

Когда курсор находится в ячейке, доступной для ввода, в Строке сообщений отображается номер текущего исполнения, а когда в недоступной — сообщение «Текст недоступен для редактирования».

19. Подтвердите создание объекта.

При выполнении следующих действий в упражнениях подтверждайте создание объекта спецификации сразу после ввода или редактирования его текстовой части (если явно не указаны иные действия).

Вы увидите, что строки блока разделились. В таблице появились дополнительные строки, озаглавленные Обозн. исполн. (Обозначения исполнений). В колонках этих строк Количество находятся числа, соответствующие номерам исполнений.

20. Установите выделение на одну из таких строк и посмотрите на Панель свойств.

Вы увидите в поле Тип объекта название этой строки — Начало блока.

В общем случае блок исполнений — это часть спецификации, содержащая информацию обо всех ее объектах для числа исполнений, равного числу колонок для количества на исполнение в данной спецификации (см. раздел 6.1.2.5).

В спецификации, с которой вы работаете, блок — это часть с информацией о десяти исполнениях специфицируемого изделия. В этой спецификации три блока — для исполнений с основного по девятое, с десятого по девятнадцатое и с двадцатого по двадцать девятое. В последнем блоке заполняются только колонки, соответствующие предусмотренным настройкой номерам исполнений (с двадцатого по двадцать четвертое).

Начало блока, подобно заголовку раздела, обрамлено пустыми строками.

Обратите внимание на то, что текст в начале первого и третьего блока отображается серым цветом, а в начале второго блока — черным. Чем это вызвано?

Вообще говоря, место номеров исполнений изделия — в «шапке» спецификации. В нормальном режиме номера исполнений в начале блока показываются в таблице спецификации, т.к. в нем «шапка» для всех страниц одинаковая.

При переключении в режим разметки страниц те начала блоков, которые находятся в верхней строке страницы, будут помещены в «шапку» соответствующих страниц. Для того чтобы отличать такие начала блоков в нормальном режиме, они показываются серым цветом.

21. Перейдите в режим разметки страниц.

Пользуясь линейками прокрутки, просмотрите появившиеся страницы спецификации и убедитесь, что номера исполнений изделия первого и третьего блоков разместились в «шапке» спецификации, а номера исполнений второго блока остались в отдельной строке (начале блока) посередине листа.

22. Вернитесь в нормальный режим.

23. Активизируйте любую строку раздела Документация в первом блоке.

24. Нажмите клавишу <Insert>.

В разделе появится строка для ввода текстовой части нового объекта.

25. Введите в колонку Формат текст А4.

26. Задайте обозначение АБВГ.000.000000, код ВО.

27. Во всех доступных ячейках Количество введите символ Х.

Вы увидите, что три строки нового объекта разделились и оказались каждая в своем блоке. Так как положение начальных строк блоков на листах изменилось с появлением нового объекта, теперь серым цветом отображается только начало первого блока (следовательно, только его номера будут размещены в «шапке» спецификации). Начала второго и третьего блоков оказались в середине листа и поэтому номера исполнений из них не могут быть расположены в «шапке».

28. Вызовите команду Добавить раздел.

29. В появившемся диалоге выберите раздел Сборочные единицы и нажмите кнопку Создать.

В таблице спецификации появится новый раздел и откроется строка для ввода текстовой части нового объекта. Как и при создании предыдущих объектов, эта строка в колонках Количество разделена на три части для ввода количества на каждое исполнение.

30. Введите в колонку Формат текст А2, в колонку Обозначение — текст АААА.000.111000, в колонку Наименование — текст Рама. Во всех доступных ячейках Количество автоматически возникнут цифры 1. Не меняйте их.

Вы увидите, что в каждом из трех блоков появился раздел Сборочные единицы с новым объектом.

31. Активизируйте строку, соответствующую объекту Рама во втором блоке.

32. Запустите редактирование текстовой части объекта, нажав клавишу <Enter>.

Вы увидите, что для редактирования открылась такая же («тройная») строка, как и та, в которую вы вводили текстовую часть объекта.

33. Измените обозначение объекта с АААА.000.111000 на АБВГ.000.111000.

Вы увидите, что обозначение объекта изменилось во всех трех блоках.

Таким образом, в спецификации существует не три объекта Рама, а один. Он отображается в каждом блоке спецификации. В каком бы блоке не был отредактирован или создан объект, его текстовая часть и дополнительные параметры передаются во все блоки.

34. Активизируйте любую строку в третьем блоке.

35. Вызовите команду Добавить раздел.

36. В появившемся диалоге выберите раздел Детали и нажмите кнопку Создать.

В таблице спецификации появится новый раздел и откроется «многоэтажная» строка для ввода текстовой части нового объекта.

37. Введите в колонку Формат текст А3, в колонку Обозначение — текст АБВГ.000.000111, в колонку Наименование — текст Скоба. Во всех доступных ячейках Количество оставьте автоматически возникшую цифру 1.

Вы увидите, что в каждом из трех блоков появился раздел Детали с новым объектом.

38. Активизируйте любую строку раздела Сборочные единицы в любом блоке.

39. Нажмите клавишу <Insert>.

В разделе появится «многоэтажная» строка для ввода текстовой части нового объекта.

40. Введите в колонку Формат текст А1, в колонку Обозначение — текст АБВГ.000.333000, в колонку Наименование — текст Редуктор.

41. В первой и третьей строках колонок Количество оставьте значение 1. Во второй строке удалите все значения количества. Иными словами, введите количество 1 для исполнений с основного по девятое и с двадцатого по двадцать четвертое.

Вы увидите, что строки нового объекта разделились и оказались в первом и третьем блоках. Объект АБВГ.000.333000 Редуктор не отображается во втором блоке, так как ни в одном исполнении данного блока этот редуктор не встречается.

42. Создайте в разделе Сборочные единицы новый объект.

43. Введите в колонку Формат текст А1, в колонку Обозначение — текст АБВГ.000.444000, в колонку Наименование — текст Редуктор.

44. Во второй строке колонок Количество оставьте значение 1. Удалите все значения количества в первой и третьей строке. Таким образом, будет задано количество 1 для исполнений с десятого по девятнадцатое.

Вы увидите, что новый объект отображается только во втором блоке, так как ни в одном исполнении других блоков он не встречается.

45. Находясь в первом или третьем блоке, запустите режим редактирования текстовой части объекта АБВГ.000.333000 Редуктор.

46. Удалите данные из колонок Количество для исполнений с пятого по девятое включительно. Введите количество 1 для исполнений с пятнадцатого по девятнадцатое.

Вы увидите, что теперь объект отображается во всех трех блоках. Объект отображается в блоке, если он имеет ненулевое количество хотя бы в одном из исполнений этого блока.

47. Находясь во втором блоке, запустите режим редактирования текстовой части объекта АБВГ.000.444000 Редуктор.

48. Удалите данные из колонок Количество для исполнений с пятнадцатого по девятнадцатое. Введите количество 1 для исполнений с пятого по девятое.

49. Убедитесь, что в первом и втором блоках отображаются теперь оба объекта-редуктора, а в третьем блоке по-прежнему присутствует только объект АБВГ.000.333000 Редуктор.

50. Создайте в разделе Сборочные единицы новый объект.

51. Введите в колонку Формат текст А3, в колонку Обозначение — текст АБВГ.000.888000, в колонку Наименование — текст Муфта. Введите количество 1 только для основного исполнения (остальные количества удалите).

52. Убедитесь, что новый объект отображается только в первом блоке.

53. Установите выделение на этом объекте.

54. Вызовите команду Вставка — Исполнение.

55. В появившемся диалоге введите строку 1–3 и нажмите кнопку OK.

Вы увидите, что в первом блоке появилось три новых объекта-исполнения. Новые объекты не отображаются во втором и третьем блоках, так как для исполнений этих блоков пока не предусмотрены муфты.

Их текстовая часть (за исключением обозначения) повторяет текстовую часть исходного объекта АБВГ.000.888000 Муфта. К обозначениям новых объектов добавлены суффиксы с номерами исполнений муфты — 01, 02 и 03.

56. Вызовите команду Формат — Настройка спецификации.

57. В появившемся диалоге активизируйте вкладку Блоки исполнений и в группе Формировать обозначения исполнений объектов включите вариант Показывать только номер. Нажмите кнопку OK.

Вы увидите, что в обозначениях трех объектов-исполнений остались только их номера. Несмотря на то что система производит сортировку объектов по тексту в колонке Обозначение, объекты с цифровым обозначением не оказались в списке перед объектами, обозначение которых начинается с букв. Это происходит потому, что объекты, созданные по команде Добавить исполнения, «помнят» свое полное обозначение (а не только номер-суффикс), даже если показ полного обозначения в спецификации отключен. Сортировка объектов производится в соответствии с полным обозначением.

58. Выделите любой объект-исполнение.

59. Убедитесь, что на Панели свойств для этого объекта активизирован переключатель Объект является исполнением.

Этот переключатель активизируется автоматически для всех объектов, созданных по команде Добавить исполнения. Именно благодаря активизации этой опции объект располагается после своего исходного объекта и сохраняет информацию о своем полном обозначении.

60. Войдите в режим редактирования текстовой части первого исполнения муфты. Удалите данные из колонки Количество для основного исполнения. Введите количество 1 для первого, четвертого, седьмого, десятого, тринадцатого, шестнадцатого, девятнадцатого и двадцать второго исполнений.

61. Войдите в режим редактирования текстовой части второго исполнения муфты. Удалите данные из колонки Количество для основного исполнения. Введите количество 1 для второго, пятого, восьмого, одиннадцатого, четырнадцатого, семнадцатого, двадцатого и двадцать третьего исполнений.

62. Войдите в режим редактирования текстовой части третьего исполнения муфты. Удалите данные из колонки Количество для основного исполнения. Введите количество 1 для третьего, шестого, девятого, двенадцатого, пятнадцатого, восемнадцатого, двадцать первого и двадцать четвертого исполнений.

В каждом из трех блоков будут показаны объекты-исполнения муфты. Основное исполнение муфты отсутствует во втором и третьем блоках. Список муфт в этих блоках начинается сразу с объекта-исполнения. У объекта-исполнения, перед которым не отображается основной объект, в колонке Обозначение показывается полное обозначение (несмотря на то что при настройке спецификации включен показ только номеров исполнений). Это делается для того, чтобы в блоке не было объектов с неизвестным обозначением. Как только в блоке появится основное исполнение объекта, обозначение первого объекта-исполнения перестанет отображаться полностью.

63. Вызовите команду Расставить позиции.

64. Убедитесь, что в каждом блоке произошла простановка позиций в порядке расположения объектов с учетом количества резервных строк. Если в блоке не отображается какой-либо объект, который есть в других блоках, то номер позиции этого объекта пропускается в данном блоке. Номера позиций объектов-исполнений совпадают с номером позиции объекта-прототипа и не показываются в таблице.

65. Активизируйте раздел Сборочные единицы и уменьшите количество резервных строк в нем до одной.

66. Убедитесь, что теперь раздел Сборочные единицы имеет по одной резервной строке в каждом из трех блоков.

67. Вновь вызовите команду Расставить позиции.

68. Убедитесь, что во всех блоках изменился номер позиции объекта в разделе Детали.

69. Сохраните спецификацию.

70. Вызовите команду Формат — Настройка спецификации.

71. В появившемся диалоге активизируйте вкладку Блоки исполнений и в группе опций Выдавать информацию включите вариант По объектам. Закройте диалог, нажав кнопку OK.

Посмотрите, как выглядит спецификация в результате настройки. В ней теперь нет блоков, состоящих из разделов. Каждый раздел отображается в единственном экземпляре. В разделах последовательно расположены объекты спецификации. Каждый объект разделен на несколько строк, а перед этими строками указаны обозначения соответствующих исполнений (строки с обозначениями исполнений по-прежнему называются Начало блока, однако это не блоки, на которые делится спецификация, а «внутренние» блоки объекта).

Обратите особое внимание на то, что объекты-исполнения не отделились от своего исходного объекта. Т.к. они фигурируют в спецификации под одним номером позиции и соответствуют одной и той же сборочной единице (только в разных исполнениях), они отображаются вместе и делятся на блоки также совместно (показывается начало блока, за ним – все исполнения муфты для соответствующих исполнений изделия, затем – начало нового блока, исполнения муфты в нем и т.д.).

72. Установите выделение на разделе Детали.

73. Создайте в нем новый объект.

74. Введите в колонку Формат текст А4, в колонку Обозначение — текст АБВГ.000.000222, в колонку Наименование — текст Пластина. Введите во все доступные ячейки колонок Количество произвольные значения количества пластин.

75. Посмотрите, как новый объект отображается в спецификации. Он должен находиться в разделе Детали и состоять из трех блоков.

76. Вызовите диалог настройки спецификации и включите опцию Выдавать информацию — Блоками.

77. Убедитесь, что теперь спецификация вновь разбита на три блока и в каждом из них, в разделе Детали, есть новый объект — Пластина.

78. Вызовите команду простановки позиций.

79. Вызовите диалог настройки спецификации и включите опцию Размещать блок на новом листе.

В результате спецификация будет разделена на страницы таким образом, что начала всех блоков окажутся в начале страниц. При необходимости система добавит для этого дополнительные строки (их количество определяется автоматически, и они не учитываются при расчете позиций).

80. Убедитесь, что начала всех блоков отображаются серым цветом.

81. Перейдите в режим разметки страницы.

82. Убедитесь, что начала всех блоков располагаются в «шапке» страниц спецификации.

83. Заполните основную надпись спецификации.

Обратите внимание на то, что номера исполнений изделия в «шапках» всех листов проставлены автоматически.

Вы познакомились с принципами ввода и отображения объектов в спецификации с количеством исполнений более десяти.

Как вы, наверное, заметили, при создании такой спецификации доступны те же приемы и возможности, что и при создании простой спецификации или групповой спецификации с количеством исполнений не более десяти. Объекты создаются и редактируются при помощи тех же команд, происходит их автоматическая сортировка, действуют правила простановки позиций.

Единственное отличие — ввод количества объектов в несколько строк и представление объекта в нескольких блоках.

Несмотря на такое представление, свойства объектов не отличаются от свойств объектов в спецификациях без блоков. К каждому из них можно подключить документы КОМПАС-3D и геометрию из подключенного к спецификации сборочного чертежа. Можно задать для них значения в дополнительных колонках. Такие объекты можно создавать в и сборочном чертеже.

84. Подключите к спецификации какой-либо чертеж.

85. Введите графические объекты (в том числе позиционные линии-выноски) из этого чертежа в состав объектов спецификации.

86. Передайте данные из спецификации в чертеж (произведите синхронизацию). Убедитесь, что в чертеже появились объекты спецификации (для этого откройте окно подчиненного режима редактирования объектов спецификации).

87. Находясь в подчиненном режиме, подключите к объектам спецификации какие-либо чертежи. Убедитесь, что данные из их основных надписей попали в ячейки объектов спецификации.

88. Передайте данные из чертежа в спецификацию (произведите синхронизацию). Убедитесь, что объекты в спецификации соответствуют объектам в чертеже.


Упражнение 42. Создание групповой спецификации по варианту А

1. Создайте новую спецификацию.

2. Вызовите команду Сервис — Параметры — Текущая спецификация — Стиль и в качестве стиля спецификации укажите строку Групповая спецификация (вариант А) ГОСТ 2.113-75.

3. Вызовите команду Формат — Настройка спецификации.

4. На вкладке Настройки появившегося диалога установите Количество исполнений 3.

5. Сохраните спецификацию под любым именем.

6. Нажмите клавишу <Insert>.

7. В появившемся диалоге выберите раздел Детали для размещения нового объекта и нажмите кнопку Создать.

В таблице спецификации станет доступной строка для ввода текстовой части нового объекта.

Обратите внимание на то, что в колонке Количество строка разделена на три части (строки) по горизонтали. Такое разделение нужно для того, чтобы сделать возможным ввод трех значений количества в одну колонку. Первая строка содержит количество для нулевого (базового) исполнения изделия, вторая — для первого, третья — для второго. По умолчанию количество для всех исполнений равно 1.

8. Введите в колонку Формат текст А2, в колонку Обозначение — текст АБВГ.000000.004, в колонку Наименование — текст Вал. Содержимое строк колонки Количество оставьте без изменений — 1.

9. Подтвердите создание объекта.

Так как заданы одинаковые количества для исполнений, объект отнесен к постоянным данным для исполнений: в разделе спецификации Детали возник один объект.

Ниже этого объекта появилась строка «Различия исполнений по сборочному чертежу». Это — отметка об отсутствии переменных данных. Она создана автоматически, так как переменные данные для исполнений пока отсутствуют. При необходимости вы можете отредактировать текст отметки.

10. Создайте еще один объект в разделе Детали.

В разделе появится строка для ввода текстовой части нового объекта. Как и при создании предыдущего объекта, колонка Количество этого объекта разделена на три строки.

11. Введите в колонку Формат текст А3, в колонку Обозначение — текст АБВГ.000000.003, в колонку Наименование — текст Крышка. В первой и третьей строках колонки Количество оставьте значение 1, во вторую введите 2.

Обратите внимание на то, что номер текущего исполнения отображается в Строке сообщений.

12. Подтвердите создание объекта.

Отметка об отсутствии переменных данных исчезла.

Строки нового объекта разделились, в спецификации появились Переменные данные для исполнений, а также дополнительные строки, озаглавленные 000, 000-1 и 000-2.

13. Установите выделение на одну из таких строк и посмотрите на Панель свойств.

Вы увидите в поле Тип объекта название этой строки — Начало блока.

В данном случае блоком является часть спецификации, содержащая переменные данные для одного из исполнений изделия. В спецификации, с которой вы сейчас работаете, три блока: для нулевого, первого и второго исполнений.

Начало блока, подобно заголовку раздела, обрамлено пустыми строками.

Каждый блок содержит раздел Детали и только что созданный вами объект.

14. Активизируйте любую строку спецификации и нажмите клавишу <Insert>.

В разделе Детали появится строка для ввода текстовой части очередного объекта.

15. Введите в колонку Формат текст А2, в колонку Обозначение — текст АБВГ.000000.001, в колонку Наименование — текст Корпус. Удалите количество для второго исполнения, для первого и третьего оставьте умолчательное значение.

16. Подтвердите создание объекта.

Вы увидите, что строки нового объекта разделились и оказались в первом и третьем блоках. Объект АБВГ.000000.001 Корпус не отображается во втором блоке, так как количество для соответствующего исполнения не введено.

17. Создайте еще один объект в разделе Детали.

18. Введите в колонку Формат текст А2, в колонку Обозначение — текст АБВГ.000000.002, в колонку Наименование — текст Корпус. Удалите количество для первого и третьего исполнений, для второго оставьте умолчательное значение.

19. Подтвердите создание объекта.

20. Убедитесь, что созданный вами объект отображается лишь во втором блоке.

21. Убедитесь, что объекты спецификации, несмотря на то, что были введены в произвольном порядке, отсортировались по обозначению с учетом особенностей расположения объектов в групповой спецификации по варианту А. Так, в первом исполнении сначала указана Крышка АБВГ.000000.003, поскольку она есть и в основном исполнении, а затем — Корпус АБВГ.000000.002.

22. Вызовите команду Добавить раздел.

23. В появившемся диалоге выберите раздел Стандартные изделия и нажмите кнопку Выбрать шаблон.

24. В диалоге выбора шаблона заполнения текстовой части разверните список шаблонов для крепежных изделий и выберите Винт.

25. Закройте диалог выбора раздела и типа объекта, нажав кнопку Создать.

В постоянных данных спецификации появится новый раздел и откроется строка для ввода текстовой части нового объекта.

26. Разбейте текст колонки Наименование на две строки, а в каждую строку колонки Количество введите значение 4.

27. Подтвердите создание объекта.

Вы увидите, что разделения строк нового объекта не произошло, так как для всех исполнений введено одно и тоже количество. Объект Винт размещен в постоянных данных.

28. Измените количества для исполнений в текстовой части этого объекта.

28.1. Активизируйте строку, соответствующую объекту Винт.

28.2. Запустите редактирование текстовой части объекта, нажав клавишу <Enter>.

28.3. Вызовите окно редактирования параметров винта двойным щелчком мыши на текстовой части объекта.

28.4. Измените значение поля Диаметр с 10 на 12 и закройте окно кнопкой ОК.

28.5. Редактирование параметра отменяет предыдущее редактирование текста, поэтому наименование винта нужно повторно разбить на две строки.

29. Измените количество для первого исполнения с 4 на 8.

Так как количества для исполнений теперь не одинаковы, во всех трех блоках появился раздел Стандартные изделия с отредактированным вами объектом, каждая строка которого попала в свой блок.

Таким образом, в спецификации существует не три объекта Винт, а один. Он отображается в каждом блоке спецификации. В каком бы блоке ни был отредактирован или создан объект, его текстовая часть и дополнительные параметры передаются во все блоки. Если при этом введены одинаковые количества для исполнений, объект помещается в постоянные данные, если различные — в переменные.

30. Если в спецификации создается исполнение без переменных данных, то в соответствующем блоке автоматически формируется отметка об отсутствии переменных данных со словом «Отсутствуют». Чтобы убедиться в этом, выполните следующие действия.

30.1. Вызовите команду Формат — Настройка спецификации.

30.2. На вкладке Настройка появившегося диалога установите Количество исполнений 4 и закройте диалог кнопкой ОК.

В спецификации появилось новое, третье, исполнение изделия, количество составных частей для которого не задано. В результате:

- в спецификации возник блок с заголовком 000-3, содержащий строку «Отсутствует»,

- объект Вал АБВГ.000000.004 перестал относиться к постоянным данным — он появился в базовом, первом и втором исполнениях.

30.3. Вновь вызовите диалог настройки спецификации и на его вкладке Блоки исполн. отключите опцию Показывать исполнения, не содержащие переменных данных и нажмите кнопку ОК.

Блок третьего исполнения вместе с отметкой об отсутствии переменных данных исчезает из спецификации.

30.4. Вновь вызовите диалог настройки спецификации, верните прежнее количество исполнений — 3 и нажмите кнопку ОК.

31. Расставьте позиции.

32. Перейдите в режим разметки страниц.

33. Пользуясь полосами прокрутки, просмотрите появившиеся страницы спецификации.

34. Заполните основную надпись спецификации.

Вы увидите, что обозначения исполнений сформировались автоматически в соответствии с указанным в штампе обозначением спецификации.

Вы познакомились с принципами ввода объектов групповой спецификации по варианту А. Как вы, наверное, заметили, создание такой спецификации имеет много общего с созданием групповой спецификации с числом исполнений более десяти.


6.4. Пользовательские настройки спецификации

В этом разделе:

6.4.1. Стиль спецификации

6.4.1.1. Компоненты стиля

6.4.1.2. Использование механизмов спецификации для создания других документов

6.4.2. Настройка существующей спецификации

6.4.2.1. Общие настройки спецификации

6.4.2.1.1. Отключение связи сборки и спецификации

6.4.2.2. Настройка разделов спецификации

6.4.2.2.1. Общая настройка раздела

6.4.2.2.2. Настройка подразделов

6.4.2.2.3. Настройка блоков вложенных разделов

6.4.2.3. Настройка блоков исполнений

6.4.2.4. Настройка блоков дополнительных разделов

6.4.3. Изменение стиля существующей спецификации

6.4.4. Создание пользовательского стиля спецификации

6.4.4.1. Общие сведения

6.4.4.2. Типовая последовательность действий при создании пользовательского стиля спецификации

6.4.5. Создание пользовательских шаблонов заполнения

6.4.5.1. Общие сведения

6.4.5.2. Типовая последовательность действий при создании пользовательского шаблона заполнения

6.4.5.3. Приемы создания шаблонов заполнения


6.4.1. Стиль спецификации

6.4. Пользовательские настройки спецификации

6.4.1. Стиль спецификации

При выполнении упражнений из предыдущей части вы познакомились с некоторыми параметрами и настройками спецификации и узнали, каким образом они влияют на заполнение и отображение спецификации.

Вы меняли количество резервных строк в разделах, включали и выключали автоматическую сортировку объектов, включали и выключали простановку позиций.

Вы также создавали спецификации, имеющие разный стиль — простую и групповую. Вероятно, при этом вы заметили, что спецификации с разным стилем могут выглядеть и заполняться по-разному.

Стиль спецификации — совокупность параметров и настроек, присущих спецификации и влияющих на ее заполнение и отображение.

В этом разделе:

6.4.1.1. Компоненты стиля

6.4.1.2. Использование механизмов спецификации для создания других документов


6.4.1.1. Компоненты стиля

Параметры и настройки спецификации можно разделить на семь групп.

1. Оформление спецификации:

• Формат листа.

• Рамки.

• Специальным образом сформированная основная надпись (бланк)
первого и последующих листов спецификации.

2. Общие настройки:

• Наличие или отсутствие связи сборочного чертежа со спецификацией
и тип этой связи.

• Автоматический расчет позиций (включен или выключен).

• Расчет зон (включен или выключен).

• Удаление геометрии при удалении соответствующего объекта спецификации
(включено или выключено).

• Удаление объекта спецификации при удалении соответствующей геометрии
(включено или выключено).

• Копирование объекта спецификации при копировании соответствующей геометрии (включено или выключено).

• Номер позиции первого объекта спецификации.

• Направление построения спецификации (сверху вниз или снизу вверх).

• Количество исполнений специфицируемого изделия.

• Путь к файлу текстовых шаблонов, в котором будут сохраняться введенные тексты.

3. Колонки бланка спецификации.

Количество колонок соответствует количеству колонок в таблице спецификации (являющейся частью основной надписи). Для каждой колонки бланка указывается:

• Имя.

• Тип.

• Номер колонки данного типа.

• Тип данных в колонке.

• Наличие или отсутствие связи с графами основной надписи чертежей,
подключенных к объекту.

• Наличие или отсутствие выравнивания однострочных текстов в этой колонке
по нижней строке объекта спецификации.

• Возможен ли ввод текста в колонку при создании объектов спецификации в модели.

Если тип данных в колонке — целое или вещественное число, включается или выключается возможность суммирования данных в этой колонке (с умножением или без умножения данных на число в колонке Количество).

В одной из колонок включается показ заголовков разделов. В ней будут размещаться заголовки всех разделов спецификации.

Настройки каждой колонки являются умолчательными для всей спецификации.

4. Дополнительные колонки.

Список дополнительных колонок формируется пользователем. Для каждой из них указывается:

• Имя.

• Тип.

• Номер колонки данного типа.

• Тип данных в колонке.

• Наличие или отсутствие связи с графами основной надписи чертежей, подключенных к объекту.

• Возможен ли ввод текста в колонку при создании объектов спецификации в модели.

При настройке дополнительной колонки, содержащей числа, можно включить суммирование значений дополнительных параметров в этой колонке (с умножением на число в колонке Количество или без него).

Настройки каждой дополнительной колонки являются умолчательными для всей спецификации.

5. Разделы. Это самый обширный блок настроек.

Список разделов формируется пользователем.

Можно включить или отключить разбиение спецификации на разделы и показ заголовков разделов в спецификации.

Для каждого раздела указывается:

• Имя.

• Номер.

• Количество резервных строк в нем.

• Включена или отключена простановка позиций в данном разделе.

• Возможность подключения к объектам раздела геометрии.

• Размещение раздела — с нового листа или произвольное.

• Наличие или отсутствие марки раздела. При наличии марки — ее текст, а также включена или отключена независимая нумерация объектов раздела.

• Включено или отключено отображение кода документа. Эта настройка определяет, будет ли виден в таблице код документа, подключенного к объекту спецификации, а также будет ли возможно задание кода документа при ручном вводе текстовой части объекта спецификации.

• Включена или отключена сортировка объектов в разделе. Если включена, то можно указать колонки, по которым будет выполняться сортировка, и тип сортировки в каждой из них.

• Деление на подразделы, список подразделов.

• Включено или отключено использование блоков вложенных разделов.

• Способ заполнения колонок в разделе (только заполнение вручную или возможность передачи данных из подключенных документов).

Можно настроить колонки бланка и дополнительные колонки в данном разделе так, чтобы правила их заполнения отличались от умолчательных (заданных при настройке собственно колонок и доп. колонок):

• Включить или выключить заполнение каждой конкретной колонки в разделе.

• Изменить тип значения в колонке.

• Выключить или включить связь ячеек колонки с конкретной графой
основной надписи подключенного к объекту документа.

Если использование блоков вложенных разделов включено, то можно указать, требуется ли показ заголовков блоков в спецификации. Список блоков формируется пользователем. Для каждого блока указывается:

• Имя.

• Номер.

• Используется ли по умолчанию.

• Способ отображения блока — с нового листа или произвольное.

• Список разделов.

6. Блоки исполнений

Эта группа настроек предназначена для задания правил формирования и отображения номеров исполнений (как специфицируемого изделия, так и объектов спецификации).

В ней можно:

• Включить или отключить показ заголовков блоков исполнений.

• Выбрать способ отображения блока — с нового листа или произвольное.

• Включить или отключить автоматическое формирование отметок об отсутствии переменных данных в исполнениях (только для групповых спецификаций по варианту А).

• Включить или отключить вставку нулей и/или тире перед номером исполнения изделия.

• Выбрать способ отображения объектов спецификации (блоками или каждый объект в отдельности), если количество исполнений изделия превышает число колонок для записи количества на исполнение.

• Установить, каким образом должны показываться обозначения объектов-исполнений (полностью или в виде только номера исполнения).

• Установить, должны ли возрастать номера позиций объектов-исполнений.

7. Блоки дополнительных разделов.

Можно включить или отключить использование в спецификации блоков дополнительных разделов.

Если использование блоков дополнительных разделов включено, то можно указать, требуется ли показ заголовков блоков в спецификации.

Список блоков формируется пользователем. Для каждого блока указывается

• Имя.

• Номер.

• Список разделов.

• Используется ли по умолчанию.

• Размещение блока — с нового листа или произвольное.

• Наличие или отсутствие марки блока. При наличии марки — ее текст, а также включена или отключена независимая нумерация объектов.

Часть из этих параметров и настроек можно изменять для каждой конкретной существующей спецификации. Об этом рассказано в разделе 6.4.2.

Изменить другие настройки и параметры (например, разместить объекты текущей спецификации на другом бланке) можно только путем смены стиля спецификации на стиль, содержащий эти параметры и настройки. Об этом рассказано в разделе 6.4.3.

Если стиль спецификации с нужными параметрами и настройками (например, пользовательским бланком спецификации) еще не существует, его можно создать самостоятельно. Об этом рассказано в разделе 6.4.4.

Способы изменения внешнего облика и свойств существующей спецификации (изменение стиля и настройку спецификации) можно сочетать (например, изменить стиль спецификации, а затем — настроить те ее параметры, которые должны отличаться от умолчательных параметров данного стиля).


6.4.1.2. Использование механизмов спецификации для создания других документов

6.4.1.2. Использование механизмов спецификации
для создания других документов

Подобно тому, как документ-чертеж (файл *.cdw) может содержать не обязательно собственно чертеж, но и схему, плакат, документ-спецификация (файл *.spw) может содержать ведомость, список и т.п.

Разнообразие параметров и настроек, в особенности возможность использовать пользовательский бланк, позволяет создавать не только спецификации в соответствии с ГОСТ. Механизмы Модуля проектирования спецификаций подходят для работы с различными ведомостями, перечнями, папками и списками.

В общем случае документ-спецификация представляет собой таблицу, в которую построчно вводится разнородная информация, причем для размещения каждого типа информации отведено специальное место (колонка бланка, дополнительная колонка). Получившиеся в результате строки можно нумеровать, сортировать, связывать с документами и графическими объектами и т.д.

Комбинируя различные настройки, можно создать стили спецификаций для заполнения ведомости спецификаций, ведомости ссылочных документов, ведомости покупных изделий, таблицы соединений, листа регистрации изменений и прочих документов.


6.4.2. Настройка существующей спецификации

6.4. Пользовательские настройки спецификации

6.4.2. Настройка существующей спецификации

Внешний вид и правила заполнения спецификации зависят от того, какой стиль имеет эта спецификация.

Стиль спецификации состоит из большого количества разнородных параметров и настроек (см. раздел 6.4.1).

Для каждой существующей спецификации в отдельности можно изменить параметры и настройки, не требующие смены бланка спецификации и изменения структуры и содержания ее объектов.

К ним относятся все общие настройки и некоторые настройки разделов — количество резервных строк в разделе, простановка в нем позиций, подключение геометрии, сортировка (включена или выключена).

Кроме того, для каждого раздела можно включить или отключить использование блоков вложенных разделов, а для спецификации в целом — блоков дополнительных разделов. Если блоки используются, то их можно настроить (включить или отключить доступность определенных блоков и разделов в них и др.).

Изменение этих параметров называется настройкой спецификации.

Как вы знаете, некоторые настройки (например, количество резервных строк в разделе или необходимость сортировки объектов в нем) можно быстро изменить при помощи полей и кнопок на панели Текущее состояние.

Чтобы настроить другие параметры текущей спецификации, вызовите команду Формат — Настройка спецификации.

Если эта команда вызывается из подчиненного режима редактирования объектов спецификации, то выполненные настройки распространяются на подключенную к текущему чертежу спецификацию и на сам подчиненный режим. Если к текущей модели или чертежу не подключен документ-спецификация, команда настройки спецификации в подчиненном режиме недоступна.

После вызова команды на экране появляется диалог настройки спецификации (рис. 6.4.1).

В его верхней части указано название стиля текущей спецификации. Диалог содержит четыре вкладки — Настройки (см. раздел 6.4.2.1), Разделы (см. раздел 6.4.2.2), Блоки исполнений (см. раздел 6.4.2.3) и Блоки доп. разделов (см. раздел 6.4.2.4).

В этом разделе:

6.4.2.1. Общие настройки спецификации

6.4.2.1.1. Отключение связи сборки и спецификации

6.4.2.2. Настройка разделов спецификации

6.4.2.2.1. Общая настройка раздела

6.4.2.2.2. Настройка подразделов

6.4.2.2.3. Настройка блоков вложенных разделов

6.4.2.3. Настройка блоков исполнений

6.4.2.4. Настройка блоков дополнительных разделов


6.4.2.1. Общие настройки спецификации

Элементы управления вкладки Настройка (рис. 6.4.1) позволяют изменить общие настройки спецификации (сделать их отличающимися от настроек, предусмотренных стилем спецификации).

Рис. 6.4.1. Общие настройки спецификации

Табл. 6.4.1. Элементы управления вкладки Настройки

Элемент

Описание

Связь сборки
или чертежа со
спецификацией

Группа опций, позволяющая включать и блокировать связь подключенных друг к другу документов — спецификации и модели (сборочного чертежа) и устанавливать тип этой связи.

Если опция Связь сборки или чертежа со спецификацией выключена (подробнее см. раздел 6.4.2.1.1), то передача объектов из подключенных чертежей в спецификацию невозможна1.

Если эта опция включена, становятся доступны опции вариантов связи — Только вставка объектов спецификации и Связь с расчетом позиций.

Только вставка объектов
спецификации

Если выбран этот вариант связи, то объекты передаются из чертежа в спецификацию и сортируются. Новые номера позиций им не присваиваются. В результате объекты могут оказаться расположенными не в порядке возрастания номеров их позиций. Номера позиций не передаются из спецификации на линии-выноски в чертеже/сборке.

Если опция Рассчитывать позиции включена, возможен ручной расчет — с помощью команды Расставить позиции (см. раздел 6.2.2.8). Новые номера позиций затем можно передать в подключенный документ посредством синхронизации (см. раздел 6.2.4.2.2).

Рекомендуется использовать связь без расчета позиций в случае, если обозначения позиций на чертеже — буквенные.

Связь с расчетом позиций

Если выбран этот вариант связи, то объекты из чертежа/сборки передаются в спецификацию, сортируются и получают новые номера позиций. Затем обновленные номера позиций автоматически передаются обратно в подключенный документ.

Рассчитывать
позиции

Эта опция позволяет включить или отключить автоматический расчет позиций — присвоение объектам новых номеров позиций после того, как нумерация нарушилась в результате автоматической сортировки или удаления объектов.

Выключение опции делает невозможной связь с расчетом позиций.

Начальная
позиция

В этом поле вы можете ввести номер позиции, который должен иметь первый объект спецификации в первом разделе, для которого включена простановка позиций (см. раздел 6.4.2.2.1).

Рассчитывать
зоны

Эта опция позволяет включить или отключить передачу в спецификацию обозначений зон сборочного чертежа, в которых находятся позиционные линии-выноски объектов. Если передача разрешена, она происходит при вызове команды Расставить позиции, а также при синхронизации чертежа со спецификацией (см. раздел 6.2.4.2.1).

Строить
снизу вверх

Эта опция управляет порядком следования разделов и объектов в них. Если опция включена, разделы располагаются в порядке, обратном указанному в стиле спецификации, и порядок сортировки объектов также становится «обратным». Такой порядок расположения предписывается некоторыми СТП при заполнении спецификации, размещаемой на чертеже.

Удалять
геометрию при удалении объекта спецификации

Эта опция управляет удалением графических объектов, входящих в состав удаляемых объектов спецификации. Включение опции означает, что в результате удаления объекта спецификации из чертежа должны удаляться входящие в состав этого объекта графические объекты (см. раздел 6.2.6.1.1).

Удалять
объекты спецификации при удалении геометрии

Эта опция управляет удалением объектов спецификации при удалении входящих в их состав графических объектов. Включение опции означает, что в результате удаления из чертежа геометрии объекта спецификации этот объект должен удаляться из спецификации (см. раздел 6.2.6.1.2).

Копировать объекты спецификации при копировании геометрии

Эта опция управляет копированием объектов спецификации при копировании входящих в их состав графических объектов. Включение опции означает, что в результате копирования в чертеже геометрии объекта спецификации копия этого объекта должна создаваться в спецификации (см. раздел 6.2.6.1.3).

Количество
исполнений

Это поле доступно только при настройке групповых спецификаций. В нем можно указать количество исполнений специфицируемого изделия. Введенное число будет влиять на доступность ячеек Количество на исполнение и количество самих этих ячеек (см. также раздел 6.2.7.1).

Документ

Это справочное поле появляется в диалоге только при настройке групповых спецификаций. В зависимости от стиля текущей спецификации в нем показывается способ представления информации об исполнениях изделия — А или Б (эти способы соответствуют ГОСТ 2.113–75).

Имя файла
текстовых
шаблонов

В этом поле указано полное имя файла текстовых шаблонов (*.tdp), тексты из которого требуется вставлять при вводе и редактировании текстовой части объектов текущей спецификации (см. раздел 6.2.2.4.8). Чтобы выбрать другой файл, нажмите кнопку Обзор....

Файл текстовых шаблонов, указанный в диалоге настройки спецификации, может отличаться от файла предопределенных текстов, указанного при настройке текстового редактора.
  1. Важно понимать, что отключение этой опции не разрывает связь спецификации и сборочного чертежа (т.е. не отключает их друг от друга), а лишь блокирует передачу объектов из чертежа в спецификацию во время редактирования чертежа. При этом остаются доступными все сервисные возможности, обусловленные связью чертежа и спецификации. Например, возможен просмотр в чертеже геометрии объектов спецификации.

Если при настройке спецификации опции Рассчитывать позиции и Рассчитывать зоны были отключены, то команда Расставить позиции становится недоступна.

В этом разделе:

6.4.2.1.1. Отключение связи сборки и спецификации


6.4.2.1.1. Отключение связи сборки и спецификации

В каких случаях имеет смысл отключать опцию Связь сборки или чертежа со спецификацией?

Иногда сборочный чертеж состоит из нескольких листов. При этом над файлами, содержащими эти листы и спецификацию, к которой они подключены, могут одновременно работать несколько человек (каждый в своем файле).

Если опция Связь сборки или чертежа со спецификацией включена, то каждый раз при сохранении или закрытии листа чертежа все изменения, внесенные в объекты спецификации в нем, будут передаваться в подключенную спецификацию. Постоянный поток изменений, приходящих в спецификацию из нескольких листов, может сильно затруднить действия пользователя, работающего со спецификацией. Ему придется постоянно подтверждать сохранение полученных изменений, ориентироваться в непрерывно изменяющейся последовательности объектов и т.д.

Чтобы избавиться от этих непродуктивных хлопот, можно на время совместной работы с комплектом документов отключить опцию Связь сборки или чертежа со спецификацией (это может сделать как пользователь, непосредственно работающий со спецификацией, так и пользователь, работающий с любым из подключенных чертежей). После того как в листах сборочного чертежа созданы все объекты, опцию связи можно включить и произвести передачу данных (синхронизацию) из каждого листа сборки в спецификацию.


6.4.2.2. Настройка разделов спецификации

На вкладке Разделы (рис. 6.4.2) можно сделать отличающимися от умолчательных (предусмотренных стилем) некоторые настройки каждого конкретного раздела текущей спецификации.

Рис. 6.4.2. Настройка разделов спецификации

Табл. 6.4.2. Элементы управления вкладки Разделы

Элемент

Описание

Показывать
заголовки
разделов

Эта опция позволяет включать и отключать показ в таблице спецификации заголовков разделов и пустых строк.

Если опция выключена, объекты показываются в таблице спецификации непрерывным списком. При этом порядок их сортировки сохраняется (в том числе учитывается принадлежность объектов к разным разделам). На отображение резервных строк состояние этой опции не влияет.

Заголовок...

Эта кнопка позволяет вызвать команды изменения формата символов (шрифт, цвет, размер и т.д.), которыми отображаются первая и последующие строки заголовков разделов, выбрать способ выравнивания заголовков разделов (вправо, влево или по центру колонки), включить или выключить показ пустых строк, обрамляющих заголовки разделов.

Действие настроек распространяется на заголовки всех разделов.

Брать шрифт
из оформления

Если эта опция включена, шрифт текстовой части объектов спецификации будет таким, какой он установлен по умолчанию в таблице спецификации. Выключите опцию, если шрифт должен быть другим.

Шрифт объекта

Эта кнопка позволяет установить параметры шрифта текстовой части объектов спецификации, отличающиеся от параметров шрифта в оформлении.

Разделы

Это окно содержит список разделов текущей спецификации. В нем показаны и те разделы, в которых нет объектов и которые поэтому не видны в спецификации.

Напротив каждого раздела показана комбинация пиктограмм, говорящая о его настройках (см. табл. 6.4.3).

Для изменения настроек конкретного раздела выделите его название и нажмите кнопку Редактировать стиль раздела. На экране появится диалог настройки указанного раздела (см. разделы 6.4.2.2.1–6.4.2.2.3).

Табл. 6.4.3. Пиктограммы, символизирующие настройки раздела

Описание

Разрешено деление на подразделы

Данные из документов, подключенных к объектам спецификации,
передаются в спецификацию

Включена сортировка объектов внутри раздела

К объектам раздела можно подключить геометрию

Включена простановка позиций внутри раздела

В этом разделе:

6.4.2.2.1. Общая настройка раздела

6.4.2.2.2. Настройка подразделов

6.4.2.2.3. Настройка блоков вложенных разделов


6.4.2.2.1. Общая настройка раздела

В диалоге настройки раздела (рис. 6.4.3) можно изменить его свойства и правила заполнения (см. табл. 6.4.4).

Рис. 6.4.3. Настройка конкретного раздела

Для быстрого изменения настроек текущего раздела не требуется вызывать диалоги настройки спецификации и ее раздела. Можно воспользоваться опциями на панели Текущее состояние (см. раздел 6.2.1.2). Их действие дублирует действие большинства опций диалога настройки раздела.

Табл. 6.4.4. Настройки раздела спецификации

Элемент

Описание

Количество
резервных строк
в разделе

В этом поле можно изменить количество резервных строк в настраиваемом разделе.

Проставлять
позиции

Эта опция позволяет включить или отключить простановку позиций в разделе.

Если опция недоступна, это означает, что в стиле спецификации отключено заполнение колонки Позиция для данного раздела1.

Подключать
геометрию

Эта опция разрешает или запрещает подключение геометрии к объектам раздела.

Сортировать
объекты

Эта опция позволяет включить или отключить автоматическую сортировку объектов в разделе.

Размещать
на новом листе

Эта опция позволяет включить или отключить размещение раздела на новом листе.

Марка

Эта опция позволяет ввести текст, который будет автоматически вставляться перед номерами позиций базовых объектов настраиваемого раздела. Например, в стиле спецификации для использования в строительстве может быть раздел Перемычки с маркой ПР 2 (см. также раздел 6.2.6.16).

Независимая нумерация позиций

Эта опция позволяет включить в разделе собственную — независимую от предыдущего раздела — нумерацию. Первый объект раздела с независимой нумерацией получает номер начальной позиции (см. рис. 6.4.1).

Данная опция доступна, если включена опция Марка.

Показывать код документа

Эта опция управляет возможностью отображения и редактирования кода документа в объектах раздела.

Если опция включена, то:

– в таблице отображаются коды, входящие в обозначения документов, которые подключены к объектам раздела,

– при редактировании текстовой части объектов раздела доступна команда Вставить код и наименование (см. раздел 6.2.2.4.2),

– диалог ввода обозначения (см. раздел 3.6.3.1.1), вызванный для объекта раздела, содержит колонку Код.

Если опция отключена, то ни одна из указанных возможностей не доступна.
  1. Следует понимать, что отключение простановки позиций отличается от отключения показа позиций у объектов (см. раздел 6.2.2.6.1). Если в разделе включена простановка позиций, но запрещен показ позиций у каких-либо объектов, то этим объектам раздела при автоматической простановке позиций будут присвоены номера позиций; и хотя эти номера не будут видны в таблице (из-за запрета на отображение позиций), нумерация следующих объектов будет производиться с их учетом.
    Если же в разделе отключена простановка позиций, то вне зависимости от того, включен показ позиций или нет, колонка Позиция у всех объектов в этом разделе очистится, а номера позиций в следующем разделе не будут учитывать объекты и резервные строки данного раздела.
  2. Текст марки размещается в колонке Позиция. Поэтому, если заполнение колонки Позиция для данного раздела отключено в стиле спецификации, то объекты этого раздела будут отображаться без марки, даже если она задана.
    Состояние опции Проставлять позиции не влияет на отображение марки.


6.4.2.2.2. Настройка подразделов

На вкладке Подразделы диалога настройки раздела (рис. 6.4.4) можно отключить деление на подразделы.

Рис. 6.4.4. Настройка подразделов раздела

Если деление на подразделы включено, можно сформировать список подразделов. Для создания, изменения и удаления подразделов пользуйтесь кнопками Добавить..., Редактировать... и Удалить соответственно.

Если деление на подразделы включено, список подразделов можно оставить пустым. В этом случае подразделы в разделе можно будет создавать «на ходу», во время работы со спецификацией. Для этого на Панели свойств объекта спецификации нужно будет ввести номер подраздела, которому принадлежит объект.

После нажатия на кнопку Добавить... или Редактировать... на экране появится диалог описания подраздела (рис. 6.4.5). Задайте в нем имя и порядковый номер подраздела. Подразделы располагаются в разделе в порядке возрастания номеров.

Рис. 6.4.5. Описание подраздела

Рекомендуется присваивать разделам номера не в порядке сплошной нумерации (1, 2, 3, 4…), а с оставлением резервных номеров между ними (например, 5, 10, 15, 20…).

В этом случае при необходимости вы сможете добавить раздел в середину спецификации, не нарушая нумерации существующих разделов.


6.4.2.2.3. Настройка блоков вложенных разделов

На вкладке Блоки вложенных разделов диалога настройки раздела (рис. 6.4.6) можно настроить работу с блоками вложенных разделов.

Элементы управления, служащие для настройки блоков вложенных разделов аналогичны элементам, служащим для настройки блоков дополнительных разделов (см. раздел 6.4.2.4).

Рис. 6.4.6. Настройка блоков вложенных разделов


6.4.2.3. Настройка блоков исполнений

На вкладке Блоки исполнений (рис. 6.4.7) можно сделать отличающимися от умолчательных (предусмотренных стилем) настройки, касающиеся ввода и отображения информации об исполнениях специфицируемого изделия и объектов-исполнений (см. табл. 6.4.5).

Рис. 6.4.7. Настройка блоков исполнений

Табл. 6.4.5. Элементы управления вкладки Блоки исполнений

Элемент

Описание

Показывать
заголовки
блоков

Эта опция позволяет включать и отключать показ в таблице спецификации заголовков блоков исполнений и пустых строк вокруг них.

Заголовок...

Эта кнопка позволяет вызвать команды изменения формата символов (шрифт, цвет, размер и т.д.), которыми отображаются первая и последующие строки заголовков блоков, выбрать способ выравнивания заголовков блоков (вправо, влево или по центру колонки), включить или выключить показ пустых строк, обрамляющих заголовки блоков.

Действие настроек распространяется на заголовки всех блоков исполнений.

Размещать блок на новом листе

Эта опция позволяет указать, требуется ли располагать начала всех блоков на новых листах спецификации.

Показывать исполнения, не имеющие переменных данных

Эта опция управляет обработкой исполнений без переменных данных в групповой спецификации по варианту А (см. раздел 6.2.7.1.2).

При включенной опции:

– если переменные данные отсутствуют для исполнения, то в блок, соответствующий ему, автоматически добавляется строка со словом Отсутствуют 1,

– если переменные данные отсутствуют для всех исполнений, то блоки не создаются, а в конец спецификации добавляется строка с текстом Различия исполнений по сборочному чертежу.

При отключенной опции исполнения без переменных данных игнорируются.

Вставлять нули перед числом,

Вставлять тире перед числом

Эти опции позволяют настроить формат номеров исполнений специфицируемого изделия (номеров исполнений, располагающихся в «шапке» спецификации).

Настройка номеров исполнений имеет смысл только для групповых спецификаций.

По объектам,

Блоками

Если число исполнений, введенное в общих настройках спецификации, больше, чем количество колонок бланка спецификации, предназначенное для ввода количества на исполнение, становятся доступны выбора способа отображения информации.

Вы можете включить показ информации по объектам или по блокам (см. раздел 6.2.7.1.1 и упражнение 41).

Формировать обозначения
исполнений
объектов

Группа элементов управления для настройки отображения обозначений и позиций объектов-исполнений в таблице спецификации.

Показывать
полностью,
Показывать
только номер

Эти опции позволяют выбрать вариант отображения обозначений объектов-исполнений (см. раздел 6.2.2.3.3 и упражнение 41).

Позиции
возрастают

По умолчанию номера объектов-исполнений не возрастают и не показываются в таблице. Если требуется, чтобы в спецификации отображались возрастающие номера объектов, являющихся исполнениями, включите эту опцию.
  1. Отображение заголовков блоков должно быть включено (опция Показывать заголовки блоков).


6.4.2.4. Настройка блоков дополнительных разделов

На вкладке Блоки дополнительных разделов диалога настройки раздела (рис. 6.4.8) можно настроить работу с блоками дополнительных разделов.

Описание элементов управления вкладки представлено в таблице 6.4.6.

Рис. 6.4.8. Настройка блоков дополнительных разделов

Табл. 6.4.6. Элементы управления вкладки Блоки вложенных разделов

Элемент

Описание

Использовать блоки

Опция, управляющая возможностью использования блоков.

Если она включена, то при создании объектов в текущей спецификации доступны блоки дополнительных разделов.

Показывать
заголовки
блоков

Эта опция позволяет включать и отключать показ в таблице спецификации заголовков блоков разделов и пустых строк вокруг них.

Заголовок...

Эта кнопка позволяет вызвать команды изменения формата символов (шрифт, цвет, размер и т.д.), которыми отображаются первая и последующие строки заголовков блоков разделов, выбрать способ выравнивания заголовков блоков (вправо, влево или по центру колонки), включить или выключить показ пустых строк, обрамляющих заголовки блоков.

Действие настроек распространяется на заголовки всех блоков дополнительных разделов.

Список блоков

Перечень блоков дополнительных разделов формируется при настройке стиля спецификации. При настройке текущей спецификации можно лишь включить или выключить доступность того или иного блока. Для этого служат опции рядом с именами блоков. Включение опции означает, что блок будет доступен.

Кроме того, возможна настройка существующих блоков. Она производится в диалоге, вызываемом кнопкой Редактировать...

Редактировать...

Эта кнопка вызывает диалог настройки блока, выделенного в списке (см. рис. 6.4.9 и табл. 6.4.7).

Рис. 6.4.9. Диалог настройки блока

Табл. 6.4.7. Элементы управления диалога настройки блока

Элемент

Описание

Имя блока и Номер блока

Справочные поля. Их значения задаются при настройке стиля спецификации.

Разделы
спецификации

В списке разделов доступны все разделы, определенные в стиле спецификации. Чтобы отметить те из них, которые должны использоваться в настраиваемом блоке, включите опцию рядом с именем раздела. Настройки разделов, использующихся в блоках, полностью совпадают с настройками соответствующих обычных разделов.

Использовать в работе

Опция, управляющая доступностью настраиваемого блока при заполнении спецификации (данная опция дублирует соответствующую опцию в списке блоков — см. рис.6.4.8.

Размещать на новом листе

Опция, управляющая расположением настраиваемого блока.

Марка1

Опция, позволяющая ввести текст, который будет автоматически вставляться перед номерами позиций базовых объектов тех разделов блока, в которых разрешено заполнение колонки Позиция.

Если в разделе спецификации, входящем в блок, задана собственная марка, то она игнорируется и используется марка блока.

Независимая нумерация позиций1

Опция, позволяющая включить для объектов настраиваемого блока собственную — независимую от предыдущих объектов — нумерацию позиций. Первый объект в блоке с независимой нумерацией получает номер начальной позиции (см. рис. 6.4.1).

Если в блоке присутствует раздел с независимой нумерацией, эта настройка сохраняется, т.е. первый объект такого раздела будет иметь номер начальной позиции.

Опция Независимая нумерация позиций доступна, если включена опция Марка.

Документ

Поле, содержащее полное имя файла КОМПАС-документа для связи с заголовком блока. Обозначение из этого файла может включаться в заголовок блока. Чтобы это включение было возможно, имя блока (заданное при настройке стиля спецификации) должно содержать синтаксическую конструкцию вида #XXX#2. Вместо этой конструкции в заголовок блока в спецификации будет подставлено обозначение, полученное из документа, путь к которому указан в поле Документ.

Таким образом, указание документа имеет смысл лишь при настройке блоков, заголовки которых содержат конструкцию вида #XXX#. Обычно для связи с заголовком блока выбирается электромонтажный чертеж или таблица соединений.

Чтобы выбрать или сменить документ для связи, нажмите кнопку Обзор... справа от поля.
  1. Опция присутствует в диалоге только при настройке блока дополнительных разделов.
  2. Количество и тип символов между «решетками» не имеет значения.

Название блока, заданное в стиле, может также содержать одну или несколько конструкций типа \n. Она означает, что весь следующий за ней текст будет перенесен на новую строку. Таким образом, с помощью конструкции \n возможно формирование многострочных заголовков блоков.


6.4.3. Изменение стиля существующей спецификации

6.4. Пользовательские настройки спецификации

6.4.3. Изменение стиля существующей спецификации

Смена стиля спецификации, как правило, является более радикальным действием, чем настройка спецификации. Обычно при смене стиля изменяются параметры и настройки, влияющие на представление объектов в таблице спецификации (например, бланк спецификации или набор и настройки колонок).

Вы можете изменить стиль текущей спецификации (см. раздел 6.2.2.2).

Если в момент смены стиля спецификация не содержала ни одного объекта, то видимым результатом выбора другого стиля будет всего лишь изменение бланка спецификации.

Если спецификация содержала объекты, она перестроится по следующим правилам.

– Бланк спецификации изменится на бланк, входящий во вновь назначенный стиль спецификации.

– Объекты спецификации разместятся в разделах и подразделах, имеющих те же номера, что у их прежних разделов и подразделов. Например, объекты третьего подраздела пятого раздела по-прежнему останутся в третьем подразделе пятого раздела. Только заголовок пятого раздела может оказаться не таким, какой он был, когда спецификация имела предыдущий стиль. Объекты из раздела с номером, которого нет среди номеров разделов вновь назначенного стиля, показываться в спецификации не будут. Важно понимать, что эти объекты не удаляются, а просто не показываются в таблице, так как во вновь назначенном стиле спецификации для них не отведено места. Если спецификации назначить прежний стиль, объекты вновь станут видны.

– В колонки объектов спецификации данные будут передаваться по типу колонки и номеру колонки данного типа. Например, в колонку ОБОЗНАЧЕНИЕ(1) всех объектов спецификации попадут данные, которые были в их колонке с типом ОБОЗНАЧЕНИЕ(1) до смены стиля. При этом неважно, как называются эти колонки в стиле, какой у них заголовок в бланке спецификации и в каком порядке они расположены в бланке. Например, в предыдущем стиле спецификации тип ПОЗИЦИЯ(1) имела третья колонка в бланке, а во вновь назначенном стиле тип ПОЗИЦИЯ(1) имеет первая колонка в бланке. Тогда те данные, которые прежде находились в третьей колонке, теперь будут размещаться в первой колонке. Если вновь назначенный стиль спецификации содержит колонку какого-либо типа (и номера колонки типа), которой не было в прежнем стиле спецификации, сразу после перерождения колонка будет пустой. Впоследствии ее можно будет заполнить обычным способом при редактировании каждого объекта. Если вновь назначенный стиль спецификации не содержит колонку какого-либо типа (и номера колонки типа), который наличествовал в прежнем стиле спецификации, то данные из колонки этого типа в спецификации с новым стилем показываться не будут. Они не удалятся из объекта. Их можно будет увидеть, когда в стиле спецификации появится колонка нужного типа.

– По такому же принципу происходит передача данных в дополнительные колонки и показ информации в них.

Хорошим примером корректно организованного перерождения спецификации является смена стиля спецификации с Простого на Групповой и наоборот. В этих стилях разделы с одинаковыми заголовками имеют одинаковые номера, а соответствующие колонки — одинаковые типы. Поэтому при перерождении в спецификации сохраняются все разделы и текстовая часть объектов в них.

Откройте любую созданную вами с использованием системного стиля Простую спецификацию и измените ее стиль на Групповую. Убедитесь, что при этом изменился бланк, но текстовая часть расположенных в нем объектов спецификации осталась прежней.

Вообще говоря, смена стиля спецификации, содержащей объекты — нетипичная операция. Для того чтобы она привела к осмысленным результатам (а не просто к искажению существующего документа), требуется при настройке стилей (разделов и колонок) предусматривать возможность перерождения и учитывать ожидаемые результаты перерождения.

Например, если требуется, чтобы в результате перерождения стал невидимым какой-либо раздел спецификации, номер этого раздела не нужно присваивать разделам в других стилях. Если требуется, чтобы в результате перерождения поменялись местами колонки, нужно в разных стилях присвоить одинаковый тип разным колонкам бланка.

Вы можете создать стиль спецификации для составления ведомости покупных изделий и присвоить какому-либо его разделу тот же номер, который имеет раздел Стандартные изделия спецификации. Сменив стиль спецификации на ведомость покупных изделий, Вы получите заготовку ведомости (сборочные единицы, детали и т.п. не будут в ней видны).

Вы можете создать стиль спецификации для составления ведомости спецификаций и присвоить какому-либо его разделу тот же номер, который имеет раздел Сборочные единицы спецификации. Сменив стиль спецификации на ведомость спецификаций, вы получите заготовку ведомости спецификаций.

Вы можете создать разные стили спецификации с одинаковыми бланками (оформлениями) и разными комбинациями разделов (например, некоторые номера разделов совпадают с номерами разделов в других стилях, а некоторые номера разделов — уникальные). Тогда при перерождении вы будете видеть различные списки объектов в одном бланке.


6.4.4. Создание пользовательского стиля спецификации

6.4. Пользовательские настройки спецификации

6.4.4. Создание пользовательского стиля спецификации

В этом разделе:

6.4.4.1. Общие сведения

6.4.4.2. Типовая последовательность действий при создании пользовательского стиля спецификации


6.4.4.1. Общие сведения

В составе системы КОМПАС-3D поставляются стили спецификаций, позволяющие оформить спецификации и другие табличные документы по ГОСТ (конкретные номера стандартов указаны в названиях стилей).

Стили спецификаций, поставляемые в составе дистрибутива КОМПАС-3D, хранятся в файлах Graphic.lyt и Vector.lyt, расположенных в папке ...\Sys.

Для создания спецификации, которая будет оформляться и заполняться по другим правилам (например, по стандарту предприятия), требуется присвоить этой спецификации стиль, содержащий все нужные параметры и настройки.

О параметрах и настройках, которые могут быть изменены при формировании пользовательского стиля спецификации, подробно рассказано в разделе 6.4.1.

Следует отметить, что обычно новый стиль спецификации формируется для создания документов на бланке, которого нет в составе существующих стилей. Нецелесообразно создавать разные стили, отличающиеся только параметрами, которые можно настроить для каждой отдельной спецификации (например, количеством резервных строк в разделе).

Тем не менее если стиль спецификации, который предстоит создать, мало отличается от уже имеющегося, то этот последний можно использовать в качестве прототипа. Это возможно, если новый стиль создается в той же библиотеке, где находится прототип.

Перед созданием нового стиля выделите стиль-прототип. На вопрос системы об использовании выбранного стиля в качестве прототипа ответьте «Да».

Вновь созданный стиль будет иметь те же настройки, что и стиль-прототип — вам останется лишь откорректировать их.


6.4.4.2. Типовая последовательность действий при создании пользовательского стиля спецификации

6.4.4.2. Типовая последовательность действий
при создании пользовательского стиля спецификации

1. Перед созданием нового стиля спецификации требуется хорошо продумать все его настройки.

1.1. На каком бланке будет выпускаться новая спецификация? Какие таблицы нужны для ввода объектов спецификации и заполнения ее основной надписи?

1.2. Какие в ней будут разделы и подразделы? Какие свойства должен иметь каждый раздел (сортировка и нумерация объектов в нем и т.д.)?

1.3. Какие в ней будут колонки?

1.4. Данными какого типа будут заполняться колонки в каждом разделе? В каких разделах колонки не должны заполняться?

1.5. Какие дополнительные колонки нужны в спецификации? Данными какого типа они будут заполняться? Потребуется ли суммировать значения в них?

1.6. Должна ли спецификация поддерживать ассоциативную связь с чертежами и моделями?

1.7. Требуется ли рассчитывать в ней номера позиций и зоны?

1.8. Будет ли спецификация групповой? Если да, каким способом должна представляться информация об исполнениях изделия?

1.9. Потребуется ли создавать в спецификации объекты-исполнения?

1.10. Требуется ли в спецификации наличие блоков дополнительных разделов? Если да, то какие именно блоки нужны и какие разделы должны входить в каждый из них?

1.11. Требуется ли в каких-либо разделах спецификации наличие блоков вложенных разделов? Если да, то какие именно блоки нужны и какие разделы должны входить в каждый из них?

1.12. Какие из существующих шаблонов заполнения могут использоваться в различных разделах? Справьтесь о комбинациях ключей типов атрибутов, соответствующих этим шаблонам.

2. Если основной надписи, необходимой для создания спецификации, не существует, создайте ее. Можно воспользоваться похожей основной надписью в качестве прототипа.
В состав основной надписи должна входить таблица для ввода объектов спецификации. Для нее должна быть включена опция Использовать для спецификации. «Шапка» этой таблицы может содержать названия колонок. Остальные ячейки этой таблицы должны быть пусты. В их расширенном формате должен быть выбран тип Для таблицы спецификации, характер вводимых данных и указан номер строки таблицы.

3. Создайте оформление, содержащее основные надписи (бланки) для первого и последующих листов спецификации.

4. Если нужных шаблонов заполнения нет, создайте их (см. раздел 6.4.5). Постарайтесь воспользоваться шаблонами-прототипами.

5. Чтобы создать новый стиль, вызовите команду Сервис — Библиотеки стилей, типов, оформлений и основных надписей — Стили спецификаций.... В появившемся диалоге выберите библиотеку, в которой будет создаваться новый стиль, и нажмите кнопку Создать.

На экране появится диалог Стиль спецификации. В нем и в порождаемых им диалогах будут настраиваться все параметры стиля спецификации.

6. Введите имя стиля и номер стиля в библиотеке.

7. На вкладке Оформление выберите оформление первого и последующих листов спецификации.

8. На вкладке Настройка произведите настройку общих параметров.

9. На вкладке Колонки нажмите кнопку Сформировать по умолчанию и настройте параметры каждой колонки.

10. На вкладке Дополнительные колонки создайте список дополнительных колонок и настройте их.

11. На вкладке Разделы создайте список разделов и настройте их. Уточните правила ввода и сортировки объектов в каждом разделе и правила заполнения колонок в нем.

12. При необходимости на вкладке Блоки исполнений настройте правила ввода и отображения информации об исполнениях.

13. При необходимости на вкладке Блоки дополнительных разделов включите использование блоков дополнительных разделов и настройте их.

14. Протестируйте новый стиль спецификации: создайте спецификацию с новым стилем, заполните ее разделы, проверьте связь со сборочным чертежом, заполнение дополнительных колонок, сортировку, простановку позиций, прочие параметры и настройки.

15. При необходимости исправьте настройки стиля спецификации и вновь опробуйте новый стиль.

Не пренебрегайте проверкой нового стиля спецификации — в дальнейшем это позволит избежать множества ошибок при выпуске спецификаций с данным стилем.


6.4.5. Создание пользовательских шаблонов заполнения

6.4. Пользовательские настройки спецификации

6.4.5. Создание пользовательских шаблонов заполнения

В этом разделе:

6.4.5.1. Общие сведения

6.4.5.2. Типовая последовательность действий при создании пользовательского шаблона заполнения

6.4.5.3. Приемы создания шаблонов заполнения


6.4.5.1. Общие сведения

Создание пользовательских шаблонов заполнения имеет смысл, если текст формируется из нескольких полей и сортировка происходит по этим полям в последовательности, отличной от их порядка (например, сначала — по третьему полю, затем — по первому, затем — по второму).

Следует также иметь в виду, что при создании объекта спецификации текст, сформированный по шаблону, можно будет разместить лишь в одной колонке. Рекомендуется размещать его в той колонке, по которой должна производиться сортировка.

Шаблон заполнения создается на основе табличного типа атрибута с постоянным и равным единице количеством строк.

Каждому полю текста (или числа) в шаблоне (в том числе полям, предназначенным для разделителей и постоянных значений) соответствует колонка атрибута.

Для каждой колонки (а следовательно, и поля шаблона) можно задать правила заполнения (тип значения, диапазон или список значений, значение по умолчанию).

Порядок полей, по которым должна производиться сортировка, определяется значениями ключей этих полей.

Значения ключей полей должны возрастать в порядке сортировки полей. Они могут иметь не сплошную нумерацию.

По полям, ключи которых равны нулю, текст, сформированный из атрибута (запись), сортироваться не будет.

По остальным полям текст будет сортироваться в порядке возрастания ключей поля (вначале — по полю, имеющему наименьший ключ, затем — по полю со следующим значением ключа и так далее до поля с максимальным значением ключа).

Чтобы тип атрибута можно было использовать в качестве шаблона при заполнении какой-либо колонки какого-либо раздела спецификации, комбинация ключей атрибута должна совпадать с комбинацией, указанной при настройке этой колонки в этом разделе спецификации, а сам тип атрибута должен находиться в библиотеке, указанной при настройке колонки в разделе спецификации.

Чтобы шаблон заполнения был доступен при создании объекта в разделе Стандартные изделия Простой и Групповой спецификаций, атрибут, содержащий этот шаблон, должен находиться в системной библиотеке Spc.lat и иметь ключи 100, 5, 1.

Чтобы шаблон заполнения был доступен при создании объекта в разделе Материалы Простой и Групповой спецификаций, атрибут, содержащий этот шаблон, должен находиться в системной библиотеке Spc.lat и иметь ключи 100, 7, 1.


6.4.5.2. Типовая последовательность действий при создании пользовательского шаблона заполнения

6.4.5.2. Типовая последовательность действий
при создании пользовательского шаблона заполнения

1. Продумайте, из каких полей должен состоять текст (запись), сформированный по шаблону, и в каком порядке полей должна происходить сортировка текстов, сформированных по шаблону.

2. Откройте библиотеку типов атрибутов.

3. Создайте в ней новый тип атрибута — таблицу с постоянным и равным единице количеством строк.

4. Создайте в новом типе атрибута столько колонок, сколько полей должно быть в сформированном по шаблону тексте. Каждой колонке табличного атрибута будет соответствовать поле шаблона. Порядок полей шаблона будет соответствовать порядку колонок атрибута.

5. Введите для каждой колонки название (оно будет отображаться как название поля при редактировании текста в шаблоне), тип колонки, диапазон значений в ней и значение по умолчанию.

6. Установите для каждой колонки, соответствующей полю, по которому должна производиться сортировка, значение ключа, указывающее порядок сортировки.

7. Установите комбинацию ключей типа атрибута. По этой комбинации ключей созданный шаблон можно будет выбрать из библиотеки атрибутов и использовать при формировании объекта спецификации.


6.4.5.3. Приемы создания шаблонов заполнения

Обратите внимание на некоторые приемы формирования шаблонов.

– Неизменная часть какого-либо обозначения (например, «ГОСТ» или «М») может находиться в отдельном поле. Для различных разделителей (тире, знаков дроби, умножения и т.д.) также выделяется отдельное поле. Сортировка по этим полям не производится.

– Номер стандарта может быть разделен на две части, если необходима сортировка стандартов по годам.

– По возможности используйте списки допустимых значений полей и устанавливайте самое распространенное из них в качестве значения по умолчанию. Таким образом вы ускорите ввод значений в поле и одновременно снизите вероятность опечаток в нем.

– Если значение в поле постоянное (например, разделитель или аббревиатура ГОСТ), создайте список допустимых значений, состоящий из одного этого значения. Это позволит избежать ошибок, связанных со случайным редактированием значения в поле.

– Если в каком-либо строковом поле требуется сортировка, отличная от алфавитной, настройте его следующим образом. Задайте список строк для заполнения этого поля, расположите их в нужном порядке и включите учет порядка следования значений.

– При создании новых типов атрибутов по возможности используйте прототипы. После создания нового типа атрибута по прототипу отредактируйте его параметры: введите новые названия колонок, измените списки заполнения и диапазоны значений. Проверьте, соответствуют ли ключи полей требуемой последовательности сортировки.

Для практического ознакомления с порядком формирования пользовательских шаблонов заполнения выполните упражнения из раздела 6.5.1.


6.5. Практическое освоение настроек спецификации

В этом разделе:

6.5.1. Пользовательские шаблоны заполнения

6.5.1.1. Подготовительные действия

Упражнение 43. Создание библиотеки атрибутов

6.5.1.2. Формирование шаблона

Упражнение 44. Создание табличного атрибута

6.5.1.3. Настройка правил сортировки

Упражнение 45. Ввод ключей, задающих последовательность сортировки

6.5.1.4. Подготовка шаблона к использованию в спецификации

Упражнение 46. Задание ключей типа атрибута

6.5.1.5. Задания для самостоятельного выполнения

Упражнение 47. Создание нового типа атрибута

Упражнение 48. Изучение шаблонов, входящих в стандартную поставку

Упражнение 49. Создание шаблона для обозначения материала

6.5.1.6. Использование шаблона заполнения

Упражнение 50. Проверка работы пользовательского шаблона

6.5.1.7. Включение шаблона в стиль спецификации

Упражнение 51. Проверка возможности подключения пользовательского шаблона

Упражнение 52. Включение шаблона в стиль спецификации

Упражнение 53. Проверка работы подключенного шаблона

6.5.1.8. Автоматическое формирование записи из текста

Упражнение 54. Создание объектов спецификации с текстовой частью в виде строки

Упражнение 55. Коррекция правил сортировки

6.5.1.9. Дополнительная настройка сортировки

Упражнение 56. Задание порядка следования значений в полях

6.5.2. Пользовательский стиль спецификации

6.5.2.1. Подготовительные действия

Упражнение 57. Создание библиотеки основных надписей, оформлений и стилей спецификаций

6.5.2.2. Формирование бланка спецификации

Упражнение 58. Создание основной надписи и таблицы спецификации

Упражнение 59. Создание оформления спецификации

Упражнение 60. Проверка правильности бланка спецификации

6.5.2.3. Формирование стиля спецификации

Упражнение 61. Создание нового стиля

Упражнение 62. Выбор оформления

Упражнение 63. Настройка колонок

Упражнение 64. Настройка дополнительных колонок

Упражнение 65. Настройка разделов

Упражнение 66. Настройка подразделов

Упражнение 67. Настройка колонок в разделе

Упражнение 68. Подключение шаблонов заполнения

Упражнение 69. Настройка общих свойств спецификации

6.5.2.4. Проверка стиля спецификации

Упражнение 70. Проверка созданного стиля спецификации


6.5.1. Пользовательские шаблоны заполнения

6.5. Практическое освоение настроек спецификации

6.5.1. Пользовательские шаблоны заполнения

Для автоматизации ввода и сортировки текстов, формируемых по стандартным правилам, используются шаблоны заполнения (см. раздел 6.4.5).

Вы можете самостоятельно создавать шаблоны заполнения.

Шаблоны заполнения формируются на основе табличного атрибута, колонки которого соответствуют полям шаблона.

В этом разделе:

6.5.1.1. Подготовительные действия

Упражнение 43. Создание библиотеки атрибутов

6.5.1.2. Формирование шаблона

Упражнение 44. Создание табличного атрибута

6.5.1.3. Настройка правил сортировки

Упражнение 45. Ввод ключей, задающих последовательность сортировки

6.5.1.4. Подготовка шаблона к использованию в спецификации

Упражнение 46. Задание ключей типа атрибута

6.5.1.5. Задания для самостоятельного выполнения

Упражнение 47. Создание нового типа атрибута

Упражнение 48. Изучение шаблонов, входящих в стандартную поставку

Упражнение 49. Создание шаблона для обозначения материала

6.5.1.6. Использование шаблона заполнения

Упражнение 50. Проверка работы пользовательского шаблона

6.5.1.7. Включение шаблона в стиль спецификации

Упражнение 51. Проверка возможности подключения пользовательского шаблона

Упражнение 52. Включение шаблона в стиль спецификации

Упражнение 53. Проверка работы подключенного шаблона

6.5.1.8. Автоматическое формирование записи из текста

Упражнение 54. Создание объектов спецификации с текстовой частью в виде строки

Упражнение 55. Коррекция правил сортировки

6.5.1.9. Дополнительная настройка сортировки

Упражнение 56. Задание порядка следования значений в полях


6.5.1.1. Подготовительные действия

Для практического ознакомления с шаблонами вам потребуется пользовательская библиотека атрибутов (например, с именем Test.lat). Если у вас уже есть собственная библиотека атрибутов, упражняться можно в ней. Если такой библиотеки нет, создайте ее.

В этом разделе:

Упражнение 43. Создание библиотеки атрибутов


Упражнение 43. Создание библиотеки атрибутов

1. Вызовите команду Сервис — Библиотеки стилей, типов, оформлений и основных надписей — Типы атрибутов....

2. В появившемся диалоге работы с библиотеками нажмите кнопку Показать библиотеку.

3. В появившемся диалоге выбора файла введите имя несуществующей библиотеки Test.lat и нажмите кнопку Открыть.

4. В ответ на запрос системы (рис. 6.5.1) подтвердите создание нового файла библиотеки, нажав кнопку Да.

Рис. 6.5.1. Запрос на создание нового файла библиотеки

На жестком диске будет создан файл Test.lat. Новая библиотека откроется в диалоге работы с библиотеками типов атрибутов. Эта библиотека пока пуста. Не закрывайте ее. Вы будете работать в ней при выполнении следующего упражнения.


6.5.1.2. Формирование шаблона

Сформируйте шаблон заполнения наименования детали, изготовляемой по стандарту предприятия. Для этого нужно создать атрибут, структура которого соответствует составу шаблона.

Предположим, что по шаблону должны заполняться наименования стандартных изделий, состоящие из

– слова Втулка или Вкладыш,

– обозначения исполнения (А, Б или В),

– типоразмера (номинального диаметра и длины),

– обозначения нормативного документа.

В этом разделе:

Упражнение 44. Создание табличного атрибута


Упражнение 44. Создание табличного атрибута

1. В окне работы с библиотекой Test.lat нажмите кнопку Новый тип.

2. В появившемся диалоге параметров типа атрибута введите название типа атрибута Втулка и выберите структуру типа Таблица фиксированной длины с числом строк 1 (рис. 6.5.2).

3. Нажмите кнопку OK.

Рис. 6.5.2. Параметры нового типа атрибута

На экране появится диалог формирования структуры типа атрибута.

4. Пять раз нажмите в нем кнопку Добавить.

В результате в формируемом типе атрибута будет шесть колонок.

5. Введите название первой колонки — Название детали.

6. Смените тип колонки — вместо Целого укажите тип Строка. Включите опцию Заполнение из списка. Ключ поля пока не вводите.

7. Добавьте в список значений строки Втулка и Вкладыш (рис. 6.5.3).

Рис. 6.5.3. Список значений в поле атрибута

8. Нажмите кнопку OK.

9. Выберите значение по умолчанию Втулка.

10. Вторую колонку атрибута настройте следующим образом:

• название колонки — Исполнение,

• тип колонки — строка,

• заполнение из списка строками А, Б, В,

• значение по умолчанию — А.

11. Третью колонку атрибута настройте следующим образом:

• название колонки — Номинальный диаметр,

• тип колонки — действительный,

• диапазон значений — от 5 до 100,

• значение по умолчанию — 40.

12. Четвертую колонку атрибута (в ней будет размещаться символ-разделитель) настройте следующим образом:

• название колонки не вводите,

• тип колонки — строка,

• заполнение из списка строкой х (этот символ будет заменять стандартный знак умножения),

• значение по умолчанию — х.

13. Пятую колонку атрибута настройте следующим образом:

• название колонки — Длина,

• тип колонки — действительный,

• диапазон значений — от 5 до 70,

• значение по умолчанию — 50.

14. Шестую колонку атрибута настройте следующим образом:

• название колонки — Стандарт,

• тип колонки — строка,

• заполнение из списка строками СТП 56.102-01, СТП 56.112-01, СТП 68.211-22,

• значение по умолчанию — СТП 56.102-01.

В результате у вас должна получиться структура типа атрибута, показанная на рис. 6.5.4.

Рис. 6.5.4. Структура типа табличного атрибута

Обратите внимание на столбец Значение по умолчанию в диалоге настройки структуры типа атрибута.
В нем образовался текст шаблона по умолчанию (Втулка А 40х50 СТП 56.102-01).

Не закрывая диалог формирования структуры типа атрибута, переходите к выполнению следующего упражнения.


6.5.1.3. Настройка правил сортировки

Теперь требуется настроить атрибут так, чтобы сформированные из него тексты сортировались вначале по стандарту (шестому полю), затем — по названию детали (первому полю), затем — по исполнению (второму полю), затем — по номинальному диаметру (третьему полю) и по длине (пятому полю).

Для этого в диалоге выбора типа каждой колонки нужно ввести значение ключа поля, указывающее очередь сортировки по этому полю.

Значения ключей полей должны возрастать в порядке сортировки полей. Они могут иметь несплошную нумерацию.

В этом разделе:

Упражнение 45. Ввод ключей, задающих последовательность сортировки


Упражнение 45. Ввод ключей, задающих последовательность сортировки

1. В диалоге выбора типа шестой колонки (Стандарт) введите ключ поля 1.

2. В диалоге выбора типа первой колонки (Название детали) введите ключ поля 3.

3. В диалоге выбора типа второй колонки (Исполнение) введите ключ поля 5.

4. В диалоге выбора типа третьей колонки (Номинальный диаметр) введите ключ поля 7.

5. В диалоге выбора типа пятой колонки (Длина) введите ключ поля 9.

Ключ поля четвертой колонки (поля) остался равным нулю.

По полям, ключи которых равны нулю, текст, сформированный из атрибута (запись), сортироваться не будет.

По остальным полям текст будет сортироваться в порядке возрастания ключей поля (вначале — по полю, имеющему наименьший ключ, затем — по полю со следующим значением ключа и так далее до поля с максимальным значением ключа).

Не закрывая диалог формирования структуры типа атрибута, переходите к выполнению следующего упражнения.


6.5.1.4. Подготовка шаблона к использованию в спецификации

Чтобы получившийся тип атрибута можно было использовать в качестве шаблона, его требуется специальным образом пометить. Для этого ключам типа атрибута присваиваются определенные значения.

В этом разделе:

Упражнение 46. Задание ключей типа атрибута


Упражнение 46. Задание ключей типа атрибута

6.5. Практическое освоение настроек спецификации > 6.5.1. Пользовательские шаблоны заполнения > 6.5.1.4. Подготовка шаблона к использованию в спецификации >

Упражнение 46. Задание ключей типа атрибута

1. В диалоге формирования структуры типа атрибута нажмите кнопку Ключи.

2. В появившемся диалоге введите значения первого, второго и третьего ключей атрибута соответственно 200, 20 и 0 (рис. 6.5.5). Роль этих цифр будет разъяснена далее, при выполнении упражнения 52.

Рис. 6.5.5. Ввод ключей атрибута

По этой комбинации ключей сформированный шаблон можно будет выбрать из библиотеки атрибутов и использовать при формировании объекта спецификации.

Опция Автоматическое формирование текста должна быть включена — в этом случае в строке, сформированной из полей атрибута, будут автоматически (согласно стандартам) расставлены пробелы. При отключенной опции пробелы между полями не добавляются.

3. Выйдите из диалога ввода значений ключей атрибута, нажав кнопку OK.

4. Выйдите из диалога формирования структуры типа атрибута, нажав кнопку OK.


6.5.1.5. Задания для самостоятельного выполнения

Упражнения, представленные в этом разделе, служат для закрепления навыков создания шаблонов и знакомства с дополнительными приемами работы с шаблонами.

В этом разделе:

Упражнение 47. Создание нового типа атрибута

Упражнение 48. Изучение шаблонов, входящих в стандартную поставку

Упражнение 49. Создание шаблона для обозначения материала


Упражнение 47. Создание нового типа атрибута

Создайте в библиотеке Test.lat новый тип атрибута с названием Пластина и структурой, аналогичной структуре только что созданного типа атрибута Втулка.

1. При задании параметров типа атрибута укажите в качестве прототипа только что созданный тип атрибута (рис. 6.5.6).

Рис. 6.5.6. Создание нового типа атрибута с использованием прототипа

2. Измените список названий детали на строки Пластина и Прокладка.

3. По своему усмотрению измените списки заполнения и диапазоны значений в остальных полях.

4. Проверьте, соответствуют ли ключи полей желаемой последовательности сортировки.

Ключи нового типа атрибута должны быть 200, 20 и 0.


Упражнение 48. Изучение шаблонов, входящих в стандартную поставку

1. В диалоге работы с библиотеками типов атрибутов откройте библиотеку Spc.lat, поставляемую в составе КОМПАС-3D. Она находится в подпапке \Sys главной папки системы.

2. Последовательно входя в режим просмотра различных типов атрибутов, изучите их структуру. Обратите внимание на приемы формирования шаблонов.

Например, неизменная часть какого-либо обозначения (аббревиатура ГОСТ) может находиться в отдельном поле. Для различных разделителей (тире, знаков дроби, умножения и т.д.) также выделяются отдельные поля. Сортировка по этим полям не производится. Номер стандарта может быть разделен на две части, если необходима сортировка стандартов по годам.


Упражнение 49. Создание шаблона для обозначения материала

1. Создайте в библиотеке Spc.lat новый тип атрибута, который будет представлять собой шаблон обозначения какого-либо материала, применяющегося на вашем предприятии (например, резины, проволоки, припоя и т.п.). По возможности воспользуйтесь каким-либо из существующих типов атрибутов в качестве прототипа.

На рис. 6.5.7 приведен пример типа атрибута, соответствующего шаблону заполнения обозначения текстолита.

2. Установите соответствующее название типа (Резина, Проволока).

3. Создайте поля, из которых будет состоять обозначение.

4. Настройте эти поля, в том числе при помощи ключей установите порядок их сортировки.

5. Установите ключи созданного атрибута 100, 7 и 1. Опцию Автоматическое формирование текста не отключайте.

6. Закройте диалог настройки структуры типа атрибута и диалог работы с библиотеками атрибутов.

Рис. 6.5.7. Новый тип атрибута (шаблон заполнения обозначения текстолита)


6.5.1.6. Использование шаблона заполнения

Убедитесь в возможности использования созданного вами шаблона и проверьте правильность его работы.

В этом разделе:

Упражнение 50. Проверка работы пользовательского шаблона


Упражнение 50. Проверка работы пользовательского шаблона

1. Создайте новую спецификацию со стилем Простая спецификация ГОСТ 2.106-96 из системной библиотеки graphic.lyt.

2. Вызовите команду Вставка — Базовый объект.

3. В появившемся диалоге выделите раздел Материалы. Нажмите кнопку Выбрать шаблон.

4. Убедитесь, что в списке шаблонов заполнения текстовой части появился шаблон, созданный вами при выполнении упражнения 49 (рис. 6.5.8).

Если новый шаблон отсутствует в списке, вернитесь в библиотеку Spc.lat и установите значения ключей созданного вами атрибута равными 100, 7 и 1.

Рис. 6.5.8. Новый шаблон заполнения текстовой части объекта спецификации

5. Выделите созданный вами шаблон в списке и нажмите кнопку Выбрать.

В диалоге выбора раздела появится имя выбранного шаблона.

6. Нажмите кнопку Создать.

В спецификации появится раздел Материалы с новым объектом. В колонку Наименование этого объекта внесен текст, сформированный по вашему новому шаблону с умолчательными значениями полей.

7. Дважды щелкните мышью в колонке Наименование.

8. В появившемся окне редактирования атрибутов измените значения в каких-либо полях.

9. Создайте еще несколько объектов с новым шаблоном заполнения.

10. Измените у каждого из них значения в полях шаблона.

11. Убедитесь, что в результате автоматической сортировки объекты разместились по предписанным вами правилам.

12. Если объекты отсортированы не так, как вы ожидали, вернитесь в библиотеку Spc.lat и проверьте значения ключей полей созданного вами атрибута.

Не закрывая спецификацию, переходите к выполнению следующего упражнения.


6.5.1.7. Включение шаблона в стиль спецификации

Проверьте, можно ли использовать в спецификации шаблоны, которые вы создали при выполнении упражнений 44–46 и 47.

В этом разделе:

Упражнение 51. Проверка возможности подключения пользовательского шаблона

Упражнение 52. Включение шаблона в стиль спецификации

Упражнение 53. Проверка работы подключенного шаблона


Упражнение 51. Проверка возможности подключения пользовательского шаблона

Упражнение 51. Проверка возможности подключения
пользовательского шаблона

1. Находясь в разделе Материалы, вызовите команду Вставка — Базовый объект.

2. В появившемся диалоге нажмите кнопку Выбрать шаблон.

3. Попытайтесь отыскать в списке шаблонов заполнения Втулку и Пластину.

Вы их не обнаружите.

4. Закройте диалоги выбора шаблона.

5. Вызовите команду Вставка — Раздел.

6. Последовательно выделяя в списке названия разделов, выясните, в каких разделах могут использоваться шаблоны (при выделении имени таких разделов становятся доступными опции выбора шаблона в нижней части диалога).

Таких разделов два: Материалы и Стандартные изделия.

Вы уже видели, что в разделе Материалы нет шаблонов заполнения Втулка и Пластина.

7. Убедитесь, что этих шаблонов нет и в разделе Стандартные изделия.

8. Выйдите из диалогов. Закройте спецификацию.

Почему один созданный вами шаблон (для материала) доступен при заполнении спецификации, а другие (Втулка и Пластина) — нет? Разница между этими шаблонами состоит в следующем:

– они созданы в разных библиотеках атрибутов,

– они имеют разные значения ключей.

Следующее упражнение позволяет понять, как эти различия сказываются на использовании шаблона в спецификации.


Упражнение 52. Включение шаблона в стиль спецификации

Включите шаблоны Втулка и Пластина в стиль спецификации Простая спецификация ГОСТ 2.106–96.

1. Чтобы не повредить стиль в системной библиотеке graphic.lyt, создайте пользовательскую библиотеку test.lyt (команда Сервис — Библиотеки стилей, типов, оформлений и основных надписей — Стили спецификаций..., далее действуйте как при выполнении упражнения 43). Скопируйте в нее стиль Простая спецификация ГОСТ 2.106-96 из библиотеки graphic.lyt.

2. В диалоге работы со стилями спецификаций выделите стиль Простая спецификация ГОСТ 2.106-96 из библиотеки test.lyt. Нажмите кнопку Редактировать.

3. В появившемся диалоге активизируйте вкладку Разделы.

4. Выделите в списке раздел Стандартные изделия и нажмите кнопку Редактировать.

5. В появившемся диалоге активизируйте вкладку Колонки.

6. Выделите в списке строку, соответствующую колонке Наименование.

В нижней части диалога вы увидите правила заполнения колонки Наименование в разделе Стандартные изделия.

• В качестве типа значения выбрана Запись. Это — первое условие подключения шаблона к этой колонке.

• В справочном поле указан путь к библиотеке типов атрибутов, шаблоны из которой подключаются к колонке. Наличие такой библиотеки — второе условие подключения шаблона.

• Далее указаны значения ключей типов атрибутов, которые должны использоваться в колонке. Наличие в библиотеке типов атрибутов с такими ключами — третье условие подключения шаблона.

7. Нажмите кнопку Обзор... рядом с именем файла библиотеки типов атрибутов.

8. В появившемся диалоге выберите файл Test.lat, который вы создали при выполнении упражнения 43 и в котором вы создавали шаблоны Втулка и Пластина. Нажмите кнопку Открыть. Убедитесь, что полное имя файла библиотеки Test.lat появилось на вкладке настройки колонки.

9. Введите в поля Ключ 1, Ключ 2 и Ключ 3 значения 200, 20 и 0 соответственно.

Это — те ключи, которые вы задали для шаблонов Втулка и Пластина при выполнении упражнений 46 и 47. Именно благодаря соответствию набора ключей шаблона в библиотеке и в стиле спецификации произойдет подключение этого шаблона к спецификации данного стиля.

10. Закройте диалоги настройки стиля раздела и стиля спецификации, нажав кнопку OK.

11. Закройте диалог работы с библиотеками стилей спецификаций, нажав кнопку Выход.


Упражнение 53. Проверка работы подключенного шаблона

Убедитесь, что теперь шаблоны Втулка и Пластина можно использовать при заполнении спецификации.

1. Создайте новую спецификацию.

2. Установите для нее стиль Простая спецификация ГОСТ 2.106-96 из библиотеки test.lyt.

3. Создайте раздел Стандартные изделия. Убедитесь, что теперь в нем можно выбрать шаблоны Втулка и Пластина.

4. Создайте в разделе Стандартные изделия несколько объектов по доступным шаблонам.

5. Измените у каждого из них значения в полях шаблона.

6. Убедитесь, что в результате автоматической сортировки объекты разместились по предписанным вами правилам.

Как вы могли заметить, при выполнении упражнения 51 в разделе Стандартные изделия были доступны одни шаблоны, а при выполнении упражнения 53 — другие.

Так получилось потому, что в стиль Простая спецификация ГОСТ 2.106–96 из библиотеки graphic.lyt включена одна библиотека типов атрибутов (spc.lat), а в стиль Простая спецификация ГОСТ 2.106–96 из библиотеки test.lyt — другая (test.lat).

Не закрывайте спецификацию, если собираетесь продолжать выполнение упражнений.

Вы познакомились с порядком формирования пользовательских шаблонов заполнения текстовой части объекта спецификации.

Вы создали шаблоны заполнения в пользовательской библиотеке типов атрибутов Test.lat и в системной библиотеке Spc.lat.

Новый шаблон из библиотеки Spc.lat попал в список шаблонов заполнения текстовой части объектов раздела Материалы спецификаций, имеющих Простой или Групповой стили, поставляемые в составе системы.

Новые шаблоны из библиотеки Test.lat найдут применение при создании пользовательского стиля спецификации (см. раздел 6.5.2).


6.5.1.8. Автоматическое формирование записи из текста

Иногда в раздел спецификации, текстовые части объектов которого формируются с использованием шаблонов, необходимо внести объект, для которого не существует готового шаблона.

Если такие объекты приходится вводить довольно часто, то целесообразно создать для них специальный шаблон и сохранить его в библиотеке Spc.lat (как вы сделали при выполнении упражнения 49).

Если же такие объекты вводятся крайне редко, то можно обойтись и без специального шаблона. В этом случае текстовая часть объекта вводится с клавиатуры. После подтверждения создания объекта его текстовая часть автоматически разбивается на поля, по которым происходит сортировка объектов. Порядок сортировки можно изменить, отредактировав вручную ключи полей.

Этот механизм дополняет использование шаблонов заполнения.

В этом разделе:

Упражнение 54. Создание объектов спецификации с текстовой частью в виде строки

Упражнение 55. Коррекция правил сортировки


Упражнение 54. Создание объектов спецификации с текстовой частью в виде строки

6.5. Практическое освоение настроек спецификации > 6.5.1. Пользовательские шаблоны заполнения > 6.5.1.8. Автоматическое формирование записи из текста >

Упражнение 54. Создание объектов спецификации
с текстовой частью в виде строки

Это упражнение выполняется в файле, оставшемся открытым при выполнении упражнения 53. Если вы не выполняли это упражнение или закрыли созданную в нем спецификацию, создайте новый документ-спецификацию со стилем Простая спецификация ГОСТ 2.106-96 и работайте в нем.

1. Активизируйте раздел Материалы (если вы работаете в новом документе, создайте этот раздел).

2. Вызовите команду Вставка — Базовый объект или нажмите клавишу <Insert>.

3. В диалоге выбора раздела и шаблона заполнения включите опцию Текстовая часть в виде строки. Нажмите кнопку Создать.

В разделе Материалы появится новый объект. Колонка Наименование этого объекта пуста.

4. Введите в эту колонку наименование материала Гетинакс 1 ГОСТ 2718-74 и подтвердите создание объекта спецификации.

5. Таким же способом внесите в этот раздел Стеклотекстолит СТЭФ–1–2 ГОСТ 12652–74 и Стеклотекстолит ВФТ–С – 8 ГОСТ 10292–74.

Текстовые части всех созданных объектов спецификации автоматически разбились на строковые и числовые поля по следующим правилам:

– Пробел в строке — признак окончания поля. Пробел записывается в отдельное поле.

– Запятая — признак вещественного числа, то есть два числа, разделенные запятой, воспринимаются как одно вещественное число.

– Если строка содержит дробь, формируются поля с символами, определяющими дробь в формате КОМПАС 4: «$d», «;» и «$».

Как вы знаете, последовательность сортировки объектов спецификации определяется ключами полей. Для записи, сформированной из строки текста, назначение ключей полям происходит автоматически по следующим правилам:

– Строковые поля с одним символом (например, дефис или пробел) имеют ключ 0 (по этим полям сортировка не производится).

– Первое поле имеет ключ 1.

– Третье поле от конца (обычно оно содержит номер ГОСТ) имеет ключ 2.

– Остальные поля имеют ключ 3.

В диалоге редактирования параметров объекта вы можете просмотреть поля, на которые разбились строки текста (рис. 6.5.9).

Рис. 6.5.9. Значения в полях шаблона

Вы можете редактировать запись, изменяя данные в полях или текст в строке. В последнем случае сформированные ранее поля удаляются, строка разбивается заново.

Благодаря тому, что первое поле имеет ключ 1, произошла алфавитная сортировка объектов раздела Материалы, что соответствует требованию стандарта. Этот же стандарт требует, чтобы в пределах каждого наименования материалы записывались по возрастанию размеров или других технических параметров. Однако материалы Стеклотекстолит ВФТ–С – 8 ГОСТ 10292–74, имеющий толщину 8 мм, и Стеклотекстолит СТЭФ–1–2 ГОСТ 12652–74, имеющий толщину 2 мм, рассортированы по номерам ГОСТ (так как ключ 2 автоматически установлен полю с номером ГОСТ). Чтобы исправить сортировку объектов, необходимо переназначить ключи полей.


Упражнение 55. Коррекция правил сортировки

6.5. Практическое освоение настроек спецификации > 6.5.1. Пользовательские шаблоны заполнения > 6.5.1.8. Автоматическое формирование записи из текста >

Упражнение 55. Коррекция правил сортировки

1. Вызовите для записи Стеклотекстолит ВФТ-С - 8 ГОСТ 10292-74 окно редактирования данных в полях.

2. Установите курсор в поле Толщина (оно имеет номер 4).

3. Нажмите кнопку Ключ поля.

На экране появится диалог редактирования ключа поля атрибута.

4. Измените ключ с третьего на второй.

5. Соответственно ключ поля с номером ГОСТ измените со второго на третий.

6. Выйдите из диалога редактирования ключа поля атрибута, нажав кнопку ОК. Закройте окно редактирования данных в полях, нажав кнопку ОК.

7. Аналогичным образом отредактируйте ключи полей записи Стеклотекстолит СТЭФ-1-2 ГОСТ 12652-74.

Объекты будут рассортированы заново в последовательности, определенной вновь установленными ключами.

Не пользуйтесь ручным редактированием ключей полей для изменения порядка сортировки объектов, текстовая часть которых заполнена с использованием шаблонов. Эта настройка не передается в тип атрибута и предназначена в основном для сортировки записей, сформированных из строк текста.

Вы познакомились с порядком формирования записей из строк текста, создали и отредактировали несколько таких записей.

Если вы не собираетесь создавать пользовательские стили спецификаций и испытываете потребность только в создании пользовательских шаблонов заполнения текстовой части, то можете остановиться на изучении настоящего раздела.


6.5.1.9. Дополнительная настройка сортировки

Иногда возникает следующая ситуация: текст формируется из нескольких полей (т.е. есть предпосылки для использования шаблона), но для правильного размещения строк не подходит сортировка значений в полях ни по возрастанию, ни по убыванию.

Например, обозначения электротехнических элементов сначала сортируются по наименованию, затем — по единицам измерения номинального значения, а затем — по номинальным значениям и по типам:

Резистор МЛТ-0,25-210 Ом ТУ 11–85

Резистор МЛТ-0,5-240 Ом ТУ 11–85

Резистор МЛТ-0,25 24 кОм ТУ 11–85

Резистор МЛТ-0,25-27 кОм ТУ 11–85

Результат составной сортировки по возрастанию будет следующим:

Резистор МЛТ-0,25 24 кОм ТУ 11–85

Резистор МЛТ-0,25-27 кОм ТУ 11–85

Резистор МЛТ-0,25-210 Ом ТУ 11–85

Резистор МЛТ-0,5-240 Ом ТУ 11–85

Дело в том, что единицы измерения — кОм и Ом — это текстовые строки. При сортировке по возрастанию они располагаются в алфавитном порядке.

Чтобы избежать подобных ошибок, нужно специально настроить соответствующее поле шаблона заполнения.

В этом разделе:

Упражнение 56. Задание порядка следования значений в полях


Упражнение 56. Задание порядка следования значений в полях

В данном упражнении разрабатывается шаблон для обозначений резисторов, использующихся в приведенных выше примерах. Приемы работы, которые уже изучены вами при выполнении предыдущих упражнений, подробно не описываются.

1. Создайте в библиотеке Spc.lat раздел Электротехнические обозначения, а в нем — новый тип атрибута Резистор.

2. Создайте в типе атрибута 9 строк для описания 9 колонок шаблона. Настройте колонки в соответствии с таблицей 6.5.1.

2.1. При вводе списка значений для седьмой колонки расположите строки в порядке: Ом, кОм, МОм (рис. 6.5.10). При необходимости воспользуйтесь кнопками Переместить значение в списке вверх и Переместить значение в списке вниз, находящимися над списком.

Рис. 6.5.10.

2.2. Включите опцию Учитывать порядок размещения значений при сортировке. Благодаря этому сортировка по полю Единица измерения номинального значения будет производится в порядке следования строк: вначале окажутся резисторы, сопротивление которых указано в омах, за ними — резисторы с сопротивлением в килоомах и, наконец, резисторы с сопротивлением в мегаомах. Внутри групп с одинаковыми единицами измерения резисторы будут располагаться в порядке увеличения номинального значения сопротивления.

Табл. 6.5.1. Настройки колонок шаблона обозначений резисторов
Номер | Название | Тип | Диапазон значений | Значение по умолчанию | Ключ
1 | Наименование элемента | Строка | 0 | Резистор | 1
2 | Разделитель | Строка | 0 | (пробел) | 0
3 | Тип элемента | Список строк | МЛТ-0,25 МЛТ-0,5 | МЛТ-0,25 | 4
4 | Разделитель | Строка | 0 | (пробел) | 0
5 | Номинальное значение | Действительный | 0–1000 | 21 | 3
6 | Разделитель | Строка | 0 | (пробел) | 0
7 | Единица измерения номинального значения | Список строк | Ом кОм МОм | Ом | 2
8 | Разделитель | Строка | 0 | (пробел) | 0
9 | ГОСТ или ТУ элемента | Строка | 0 | ТУ 11–85 | 0

3. Задайте ключи атрибута 100, 5 и 1 — чтобы шаблон мог использоваться при создании объектов спецификации в разделе Стандартные изделия.

4. Закройте диалог настройки структуры типа атрибута и диалог работы с библиотеками атрибутов.

5. Создайте новую спецификацию со стилем Простая спецификация ГОСТ 2.106–96 из системной библиотеки graphic.lyt.

6. Создайте в ней раздел Стандартные изделия, а в нем — несколько объектов по шаблону Резистор с разными значениями сопротивления и единицами его измерения.

7. Убедитесь в правильности сортировки созданных объектов. Если правила сортировки не выполняются, вернитесь в библиотеку Spc.lat и проверьте настройку атрибута Резистор.


6.5.2. Пользовательский стиль спецификации

6.5. Практическое освоение настроек спецификации

6.5.2. Пользовательский стиль спецификации

Этот раздел содержит упражнения, позволяющие практически ознакомиться с порядком настройки спецификации и создания пользовательского стиля спецификации.

При изложении материала предполагается, что читателю известны приемы работы с таблицами в КОМПАС-3D, создания пользовательской основной надписи и оформления чертежа.

Создание нового стиля спецификации будет рассмотрено на примере таблицы составных частей. В нее записывают наименования и обозначения составных частей изделия. Располагают эту таблицу на чертеже общего вида изделия или выпускают на отдельных листах.

В этом разделе:

6.5.2.1. Подготовительные действия

Упражнение 57. Создание библиотеки основных надписей, оформлений и стилей спецификаций

6.5.2.2. Формирование бланка спецификации

Упражнение 58. Создание основной надписи и таблицы спецификации

Упражнение 59. Создание оформления спецификации

Упражнение 60. Проверка правильности бланка спецификации

6.5.2.3. Формирование стиля спецификации

Упражнение 61. Создание нового стиля

Упражнение 62. Выбор оформления

Упражнение 63. Настройка колонок

Упражнение 64. Настройка дополнительных колонок

Упражнение 65. Настройка разделов

Упражнение 66. Настройка подразделов

Упражнение 67. Настройка колонок в разделе

Упражнение 68. Подключение шаблонов заполнения

Упражнение 69. Настройка общих свойств спецификации

6.5.2.4. Проверка стиля спецификации

Упражнение 70. Проверка созданного стиля спецификации


6.5.2.1. Подготовительные действия

В этом разделе:

Упражнение 57. Создание библиотеки основных надписей, оформлений и стилей спецификаций


Упражнение 57. Создание библиотеки основных надписей, оформлений и стилей спецификаций

Упражнение 57. Создание библиотеки основных надписей,
оформлений и стилей спецификаций

1. Вызовите команду Сервис — Библиотеки стилей, типов, оформлений и основных надписей — Основные надписи....

2. В появившемся диалоге нажмите кнопку Показать библиотеку.

3. В стандартном диалоге открытия файлов введите имя несуществующего файла Test.lyt и нажмите кнопку Открыть.

4. Подтвердите создание файла Test.lyt.

В диалоге работы с основными надписями будет открыта новая библиотека — Test.lyt. Пока в ней нет ни одного объекта, окно просмотра состава этой библиотеки пусто.

При выполнении следующих упражнений вы будете размещать новые основные надписи, оформления и стили в библиотеке Test.lyt.

Если у вас уже есть собственная библиотека стилей, упражняться можно в ней.


6.5.2.2. Формирование бланка спецификации

Вначале требуется создать бланк, на котором будет располагаться таблица составных частей.

Если таблицу составных частей выпускают на отдельных листах, то они считаются последующими листами чертежа общего вида и имеют соответствующую основную надпись. Поэтому штамп таблицы составных частей удобно создавать на основе штампа последующих листов конструкторского чертежа, дополнив его таблицей для размещения объектов спецификации.

В этом разделе:

Упражнение 58. Создание основной надписи и таблицы спецификации

Упражнение 59. Создание оформления спецификации

Упражнение 60. Проверка правильности бланка спецификации


Упражнение 58. Создание основной надписи и таблицы спецификации

1. Скопируйте в библиотеку Test.lyt основную надпись Чертеж констр. Посл. листы. ГОСТ 2.104-2006 из библиотеки Graphic.lyt.

2. Выделите название основной надписи Чертеж констр. Посл. листы. ГОСТ 2.104-2006 в окне просмотра состава библиотеки Test.lyt и нажмите кнопку Создать.

3. В ответ на запрос системы подтвердите использование в качестве прототипа основной надписи Чертеж констр. Посл. листы. ГОСТ 2.104-2006 (нажмите кнопку Да).

На экране появится диалог редактирования параметров основной надписи.

4. Введите имя основной надписи Таблица составных частей.

5. Удалите из списка таблиц, входящих в состав основной надписи, таблицу Графа 26.

6. Чтобы добавить к уже существующим в основной надписи таблицам таблицу для размещения объектов спецификации, нажмите кнопку Добавить.

7. В появившемся диалоге введите следующие параметры новой таблицы:

• число столбцов — 5,

• число строк — 33,

• ширина столбца — 50 мм,

• высота строки — 8 мм,

• заголовок располагается в первой строке (рис. 6.5.11).

8. Нажмите кнопку OK.

На экране появится окно редактирования таблицы.

Рис. 6.5.11. Параметры новой таблицы

9. Пользуясь командами редактирования таблицы, выполните следующие преобразования.

• Установите высоту первой строки равной 15 мм
(в ней будет располагаться заголовок, «шапка» таблицы).

• Установите следующую ширину столбцов (слева направо):
10 мм, 60 мм, 60 мм, 12 мм, 43 мм.

• Введите в заголовок таблицы следующие названия колонок:
Поз., Обозначение, Наименование, Кол., Доп. указания.
Названия Поз. и Кол. можно ввести вертикально.

• Отформатируйте названия колонок так, чтобы таблица выглядела аккуратно (выровняйте их по центру колонки, примените крупный шрифт и т.д.).

Теперь требуется настроить ячейки таблицы, в которых должны будут размещаться объекты спецификации.

Информация о том, что ячейки предназначены для объектов спецификации, хранится в расширенном формате этих ячеек.

10. Начните настройку с первого столбца.

10.1. Активизируйте ячейку первого столбца, находящуюся прямо под заголовком таблицы.

10.2. Нажмите кнопку Расширенный формат ячейки на панели Таблицы и границы или вызовите команду Формат — Формат ячейки… и в появившемся диалоге нажмите кнопку Далее….

На экране появится диалог настройки расширенного формата ячейки.

10.3. В разделе Тип ячейки включите опцию Для таблицы спецификации, а из списка под этой опцией выберите строку Позиция. В поле Номер строки таблицы введите 1 (рис. 6.5.12).

Рис. 6.5.12. Расширенный формат ячейки

При настройке таблицы спецификации строки нумеруются начиная со строки, расположенной под заголовком таблицы. Строки, расположенные над первой строкой, впоследствии считаются «шапкой» спецификации. Они не перемещаются при прокручивании спецификации в окне, а остаются неподвижными в верхней части окна. Если «шапка» спецификации состоит из нескольких строк, при настройке расширенного формата номер строки 1 присваивают ячейкам первой не входящей в «шапку» строки.

Настройку расширенного формата ячеек «шапки» не производят.

10.4. Нажмите кнопку OK, а затем выйдите из диалога формата ячейки, также нажав кнопку OK.

10.5. Перейдите в ячейку, располагающуюся под только что настроенной ячейкой (вторую ячейку первого столбца, не считая ячейки «шапки»).

10.6. Вызовите диалог настройки расширенного формата ячейки.

10.7. В разделе Тип ячейки включите опцию Для таблицы спецификации, а из списка под этой опцией выберите строку Позиция. В поле Номер строки таблицы введите 2.

Такую настройку необходимо произвести для всех ячеек столбца, указывая для каждой из них номер строки. Для того чтобы не выполнять эту настройку вручную, предназначена опция Сформировать идентификаторы для всех нижележащих ячеек столбца.

10.8. Включите эту опцию.

10.9. Нажмите кнопку OK, а затем выйдите из диалога формата ячейки, также нажав кнопку OK.

10.10. На экране появится предупреждение об изменении идентификаторов ячеек текущего столбца (рис. 6.5.13).

10.11. Подтвердите изменение, нажав кнопку Да.

Рис. 6.5.13. Предупреждение об автоматическом изменении идентификаторов

В результате расширенный формат всех ячеек первого столбца будет автоматически настроен по образцу второй ячейки. Номера их строк также будут вычислены автоматически.

11. Чтобы убедиться в этом, установите курсор в какую-либо, например, десятую, ячейку первого столбца (не считая заголовка таблицы) и вызовите диалог настройки расширенного формата. Проверьте, соответствует ли автоматически сформированный расширенный формат параметрам, которые устанавливались вручную для первых ячеек и правильно ли рассчитан номер строки, в которой находится текущая ячейка (10).

12. Настройте ячейки второй колонки.

12.1. Активизируйте ее первую ячейку второй колонки (не считая ячеек заголовка).

12.2. Вызовите диалог настройки расширенного формата ячейки.

12.3. В разделе Тип ячейки включите опцию Для таблицы спецификации, а из списка под этой опцией выберите строку Обозначение. В поле Номер строки таблицы введите 1.

12.4. Включите опцию Сформировать идентификаторы для всех нижележащих ячеек столбца. Нажмите кнопку OK, а затем выйдите из диалога формата ячейки, также нажав кнопку OK.

12.5. Подтвердите изменение идентификаторов ячеек текущего столбца.

12.6. Активизируйте любую другую ячейку второго столбца и проверьте правильность автоматического формирования расширенного формата.

13. Аналогичным образом настройте расширенный формат ячеек третьего, четвертого и пятого столбца. Из списка типов ячеек выберите для них значения Наименование, Количество (исполнение 1) и Примечание соответственно.

Указание типа ячейки (Позиция, Наименование и т.п.) позволит в дальнейшем автоматически настроить тип колонки (вы познакомитесь с этим процессом подробнее при выполнении упражнения 63).

При выборе типа ячейки (а в дальнейшем — и типа колонки) следует указывать тип информации, наиболее соответствующий данным, которые предполагается вводить в колонку. Например, если в колонку будут вводиться порядковые номера, выберите тип Позиция (в колонку типа Позиция спецификация автоматически помещает номера объектов при их вводе). Если в колонку будет вводиться код или шифр, выберите тип Обозначение и т.д. Если ни один из предложенных типов не подходит для описания информации в ячейке, укажите Пользовательский тип.

Форматирование таблицы для размещения объектов спецификации завершено.

14. Закройте окно редактирования таблицы. В ответ на запрос системы подтвердите сохранение измененной таблицы.

15. В диалоге редактирования состава основной надписи измените наименование новой таблицы: вместо БЕЗ ИМЕНИ введите Таблица составных частей.

16. В группе опций Привязка совместите левый верхний угол рамки и левый верхний угол таблицы составных частей.

17. Выделите в списке таблиц, входящих в состав основной надписи, название Таблица составных частей. Включите опцию Использовать для спецификации (эта опция находится в нижней части диалога).

Текстовая часть объектов спецификации будет размещаться в той таблице основной надписи (бланка), для которой включена эта опция. Опцию Использовать для спецификации можно включить только для одной таблицы в основной надписи. Если эта опция не будет включена ни для одной таблицы в основной надписи, система «не будет знать», где показывать текстовую часть объектов спецификации, и вы получите сообщение об ошибке.

18. Выйдите из диалога редактирования состава основной надписи, нажав кнопку OK.

19. Выйдите из диалога работы с библиотеками, нажав кнопку Выход.

Когда вы будете самостоятельно создавать таблицы для спецификации, руководствуйтесь следующими правилами.

– В таблице для спецификации все строки (кроме строк «шапки») должны быть одинаковой высоты.

– Строки (кроме строк «шапки») в первом и последующих листах (предназначенных для одной и той же спецификации) должны быть одинаковой высоты.

– Ширина ячеек одной колонки должна быть одинаковой.

– В первом и последующих листах (предназначенных для одной и той же спецификации) должны быть одинаковые колонки.

– Таблица для спецификации (без учета «шапки») должна быть регулярной (постоянное количество строк и столбцов, не допускается слияние или разделение отдельных ячеек).

– Таблица для спецификации не может быть повернута.

– Все операции форматирования символов применимы к ячейкам таблицы спецификации.

Теперь требуется создать оформление, содержащее новую основную надпись.


Упражнение 59. Создание оформления спецификации

1. Вызовите команду Сервис — Библиотеки стилей, типов, оформлений и основных надписей — Оформление чертежей и спецификаций….

2. Создайте в библиотеке Test.lyt новое оформление с именем Таблица составных частей, автоматически предложенным системой номером и следующими параметрами:

• внешняя рамка рисуется тонкой линией,

• внутренняя рамка рисуется основной линией на расстоянии 20 мм слева и 5 мм справа, сверху и снизу от внешней рамки,

• основная надпись — Таблица составных частей (созданная при выполнении предыдущего упражнения).

3. Закройте диалог настройки оформления, нажав кнопку OK.

4. Выйдите из диалога работы с библиотеками.


Упражнение 60. Проверка правильности бланка спецификации

1. Для проверки правильности начертания получившегося бланка создайте новый чертеж, выберите для него формат А4 (вертикальный) и только что созданное вами оформление — Таблица составных частей.

2. Если таблица составных частей отрисована некорректно (например, «вылезает» за внутреннюю рамку), вернитесь к редактированию основной надписи и внесите в нее необходимые исправления.

В чертеже с созданным вами оформлением таблицу спецификации можно будет заполнять по тем же правилам, по которым заполняется основная надпись (таблица активизируется двойным щелчком мыши и в ее ячейки вводятся данные). Однако при этом не возникает объектов спецификации и сервисные функции спецификации (автоматическая сортировка и простановка позиций, передача данных из других документов и т.п.) недоступны.

3. Убедитесь, что ячейки таблицы спецификации доступны для ввода информации. Для этого введите любые данные в несколько ячеек таблицы, расположенных в разных столбцах.

Создав новое оформление, включающее специальным образом настроенную таблицу для размещения объектов спецификации, вы подготовили базу для нового стиля спецификации.


6.5.2.3. Формирование стиля спецификации

В этом разделе:

Упражнение 61. Создание нового стиля

Упражнение 62. Выбор оформления

Упражнение 63. Настройка колонок

Упражнение 64. Настройка дополнительных колонок

Упражнение 65. Настройка разделов

Упражнение 66. Настройка подразделов

Упражнение 67. Настройка колонок в разделе

Упражнение 68. Подключение шаблонов заполнения

Упражнение 69. Настройка общих свойств спецификации


Упражнение 61. Создание нового стиля

1. Вызовите команду Сервис — Библиотеки стилей, типов, оформлений и основных надписей — Стили спецификаций….

2. В диалоге работы с библиотеками активизируйте библиотеку Test.lyt и нажмите кнопку Создать.

На экране появится диалог настройки стиля спецификации.

3. В верхнем поле диалога введите имя стиля — Таблица составных частей. Номер стиля оставьте тот, который автоматически предложила система.


Упражнение 62. Выбор оформления

1. Активизируйте вкладку Оформление.

2. Нажмите кнопку Изменить… и в появившемся диалоге задайте формат листа А4 (вертикальный).

3. Укажите в качестве оформления первого и последующих листов оформление Таблица составных частей из библиотеки Test.lyt.

Если бланки первого и последующих листов отличаются друг от друга и вы создали для них разные основные надписи, а затем — разные оформления, то эти оформления должны быть указаны в соответствующих полях вкладки Оформление.


Упражнение 63. Настройка колонок

1. Активизируйте вкладку Колонки.

В ней показан список колонок и их настроек.

– Если вы еще не настраивали колонки для нового стиля спецификации, то в списке перечислены колонки, оставшиеся в памяти системы от предшествующей настройки. Они не соответствуют колонкам нового стиля спецификации.

– Если вы еще не настраивали ни одного стиля спецификации, список колонок пуст.

2. Чтобы получить список колонок, присутствующих в настраиваемом стиле спецификации, нажмите кнопку Сформировать по умолчанию.

3. В ответ на запрос системы (рис. 6.5.14) подтвердите удаление всех существующих колонок (нажмите кнопку Да). Если список колонок был пуст, подтверждение формирования нового списка колонок не потребуется.

Рис. 6.5.14. Предупреждение об удалении прежнего набора колонок

Вы увидите, что в списке появились колонки с именами Позиция, Обозначение, Наименование, Количество и Примечание, имеющие определенные настройки.

Каким образом произошло автоматическое формирование списка колонок?

Система получила информацию об оформлении листов спецификации и обратилась к этому оформлению.

Из параметров оформления была считана информация о входящей в состав оформления основной надписи.

Система обратилась к основной надписи и нашла в ней таблицу, помеченную опцией Использовать для спецификации.

Когда (при выполнении упражнения 58) вы настраивали расширенный формат ячеек этой таблицы, вы указывали тип ячеек. Теперь система считала этот тип и на его основе настроила тип каждой существующей в таблице колонки.

Тип колонки — это разновидность данных, которые должны храниться в этой колонке. Именно по типу колонки спецификация распознает, в какую колонку бланка автоматически помещать номера позиций, а в какую — обозначения зон.

На данном этапе настройки вы можете исправить тип колонки, если при настройке расширенного формата ячеек была допущена ошибка. Для этого не придется возвращаться к настройке ячеек. Отредактировать тип колонки можно непосредственно в диалоге настройки стиля спецификации.

Теперь требуется вручную произвести настройку параметров колонок, которые не могут быть сформированы автоматически.

4. Установите выделение на имя колонки Позиция и нажмите кнопку Редактировать….

На экране появится диалог описания колонки.

Верхнее поле в нем — Имя колонки. Это имя не оказывает никакого влияния на заполнение спецификации. Оно служит для того, чтобы пользователю было удобно различать однотипные колонки.

При автоматическом формировании колонок им присваиваются имена, совпадающие с названиями типов колонок. Вы можете ввести любое другое имя колонки. Желательно, чтобы оно отражало содержание этой колонки. Необязательно, чтобы имя колонки совпадало с ее заголовком в «шапке» таблицы спецификации.

Далее в диалоге следует группа опций Тип колонки.

В ней вы можете изменить тип, присвоенный колонке при ее автоматическом формировании. Следует отметить, что при правильной настройке ячеек таблицы спецификации необходимость в изменении автоматически присвоенного колонке типа обычно не появляется.

Опция Номер колонки данного типа позволяет системе различать однотипные колонки (например, в групповой спецификации несколько колонок имеют тип КОЛИЧЕСТВО, но номера у них разные; или ведомость содержит несколько колонок ПОЛЬЗОВАТЕЛЬСКОГО типа с разными номерами). Данные, которые система автоматически вносит в колонку заранее известного типа, при наличии в стиле спецификации нескольких колонок этого типа будут размещаться в первой из них (считая слева направо).

Если все колонки имеют разный тип, номер колонки каждого типа обычно устанавливают равным единице. При наличии нескольких однотипных колонок (даже имеющих разные имена) их номера должны быть разными.

5. Оставьте тип и номер колонки данного типа такими, какими они сформированы автоматически.

Еще одна возможность настройки колонки — включение сложения значений в колонке данного типа (при условии, что тип данных в колонке — целый или вещественный). В стиле, над которым вы сейчас работаете, сложение значений в колонках включаться не будет.

Опция Выравнивать однострочные тексты по нижнему краю служит для того, чтобы однострочные тексты в настраиваемой колонке располагались в той строке, в которой кончается текст предыдущей колонки. Чаще всего эту опцию включают при настройке колонки Количество, когда требуется, чтобы количество было записано в той строке, где заканчивается наименование.

Опция Располагать заголовки разделов в данной колонке включается при настройке той колонки, в которой должны располагаться заголовки разделов спецификации. В стандартных спецификациях заголовки разделов обычно располагаются в колонке Наименование. Включение этой опции для настраиваемой колонки отменяет ее включение в другой колонке (если оно производилось ранее). Данная опция может быть включена только для одной колонки спецификации. Если она не включена ни для одной колонки, заголовки разделов показываться не будут (даже при включении в настройке разделов опции Показывать заголовки разделов).

Состояние опции Использовать в модели имеет значение при настройке стилей спецификаций, которые предполагается использовать для создания объектов спецификации в моделях (деталях и сборках).

Остальные опции диалога описания колонки позволяют установить правила ее заполнения. Эти правила будут распространяться по умолчанию на заполнение этой колонки во всей спецификации. При необходимости их можно будет откорректировать (настроить более точно) для каждого раздела спецификации в отдельности.

6. Установите Целый тип данных в колонке Позиция, минимальное значение — 1, максимальное значение — 1000000. Поле Имя ячейки штампа для связи оставьте пустым (т.к. колонка Позиция заполняется автоматически с использованием механизма, отличного от передачи данных из подключенных документов).

7. Выйдите из диалога, нажав кнопку OK.

8. Настройте правила заполнения других колонок, не меняя автоматически присвоенный им тип и номер:

• Колонка Обозначение:

тип данных — строка, ячейка для связи — Обозначение документа.

• Колонка Наименование:

тип данных — строка, ячейка для связи — Наименование изделия,
включена опция Располагать заголовки разделов в данной колонке.

• Колонка Количество:

тип данных — целый, минимальное значение — 1, максимальное — по вашему усмотрению, ячейки для связи нет.

• Колонка Примечание:

тип данных — строка, ячейка для связи — Индекс предприятия.


Упражнение 64. Настройка дополнительных колонок

1. Активизируйте вкладку Дополнительные колонки.

В ней вы увидите список дополнительных колонок, оставшийся в памяти системы после предыдущей настройки стиля (если такая настройка производилась).

2. Пользуясь кнопками Добавить и Удалить, сформируйте нужный список дополнительных колонок (например, создайте дополнительные колонки Масса и Разработчик). Для изменения параметров существующей дополнительной колонки пользуйтесь кнопкой Редактировать.

Настройка дополнительной колонки очень похожа на настройку колонки. Точно так же требуется указать имя дополнительной колонки, ее тип и номер колонки данного типа, выбрать тип данных в ней (целый, вещественный или строка) и при необходимости указать имя ячейки штампа для связи. Если тип данных — целый или вещественный, нужно указать минимальное и максимальное значение числа в колонке, а также включить сложение данных в этой дополнительной колонке.

3. Войдите в диалог редактирования описания дополнительной колонки Масса.

3.1. Установите ее тип МАССА, номер колонки данного типа 1, вещественный тип данных, диапазон значений по вашему усмотрению.

Рекомендуется выбрать положительное минимальное значение массы. Вообще при выборе диапазона возможных значений в колонке следует учитывать, что ввод в колонку значения, не принадлежащего этому диапазону, будет невозможен.

3.2. Включите опции Складывать значения в таблице и Умножать на количество деталей.

Если последнюю опцию не включать, будет производиться только сложение введенных в дополнительную колонку значений. При включенной опции будут складываться произведения значений в дополнительной колонке объекта и чисел в колонке Количество этого объекта.

3.3. Выберите имя ячейки штампа для связи Масса изделия.

3.4. Выйдите из диалога, нажав кнопку OK.

4. Войдите в диалог редактирования описания дополнительной колонки Разработчик.

4.1. Установите ее тип ПРИМЕЧАНИЕ, номер колонки данного типа 2 (т.к. первая колонка типа ПРИМЕЧАНИЕ уже существует среди колонок бланка спецификации, которые вы настраивали в предыдущей вкладке диалога), тип данных — строка.

4.2. Укажите в качестве ячейки штампа для связи ячейку Фамилия разработавшего.

4.3. Выйдите из диалога, нажав кнопку OK.


Упражнение 65. Настройка разделов

1. Активизируйте вкладку Разделы.

Опция Разбивать на разделы должна быть включена (в противном случае разбить спецификацию на разделы будет невозможно).

2. Если опция Разбивать на разделы выключена, включите ее.

3. Нажмите кнопку Заголовок и выберите команду Шрифт первой строки.

4. В появившемся диалоге по своему усмотрению настройте параметры шрифта, которым должны отрисовываться первые строки заголовков разделов. Например, поменяйте шрифт с GOST type A, курсивного начертания на Arial прямого начертания.

5. Так же настройте параметры шрифта вторых строк заголовков.

Включенная опция Брать шрифт из оформления означает, что текст объектов спецификации будет вводиться с теми параметрами шрифта и абзаца, которые установлены для ячеек при создании таблицы спецификации в основной надписи.

6. Если вы хотите, чтобы текст объектов спецификации имел параметры, отличные от умолчательных, нажмите кнопку Шрифт объекта...

На экране появится диалог настройки параметров шрифта, в котором вы можете произвести необходимые настройки.

7. Установите для текстовых частей объектов спецификации шрифт, например, Arial прямого начертания.

В окне просмотра отображаются названия разделов, сохранившиеся в памяти системы от предыдущей настройки стиля (если такая настройка производилась).

8. Удалите их, воспользовавшись кнопкой Удалить (удаление каждого раздела нужно будет подтвердить).

В результате в списке останется единственный — Системный — раздел, удалить который невозможно.

9. Создайте и настройте новые разделы таблицы составных частей.

9.1. Нажмите кнопку Добавить.

На экране появится диалог настройки стиля раздела спецификации.

9.2. Введите имя раздела Вновь разрабатываемые изделия и номер раздела 15.

В какой бы последовательности вы ни создавали разделы при настройке стиля, в спецификации они будут располагаться в порядке возрастания их номеров.

Рекомендуется присваивать разделам номера не в порядке сплошной нумерации (1, 2, 3, 4…), а с оставлением резервных номеров между ними (например, 5, 10, 15, 20…).

В этом случае при необходимости вы сможете добавить раздел в середину спецификации, не нарушая нумерации существующих разделов.

9.3. Установите количество резервных строк в разделе равным единице.

9.4. Включите опцию Позиции в разделе ставить.

В результате при создании объектов в этом разделе им автоматически будут присваиваться номера. Эти номера будут располагаться в первой слева колонке, которой присвоен тип ПОЗИЦИЯ.

В некоторых случаях объекты в разделе не должны нумероваться (примером может служить раздел Документация стандартной спецификации). В этом случае опцию Позиции в разделе ставить нужно будет отключить.

9.5. Включите опцию Геометрию в разделе подключать.

9.6. Опцию Размещать на новом листе включите или выключите по своему усмотрению.

Если опция включена, настраиваемый раздел будет располагаться на новом листе.

Использование марок не требуется, поэтому опцию Марка оставьте выключенной.

Поскольку в таблице составных частей изделия не перечисляются документы на само изделие, опцию Показывать код документа оставьте выключенной.

9.7. В группе Заполнение колонок включите опцию Ручное заполнение или чтение из основной надписи.

Это позволит указать, из каких ячеек основной надписи подключенного к объекту чертежа можно передавать данные в колонки текстовой части объекта. Включение опции Ручное заполнение блокирует передачу данных из основной надписи в объекты настраиваемого раздела (при этом в других разделах такая передача данных может быть включена).

9.8. Активизируйте вкладку Сортировка и включите на ней опцию Объекты в разделе сортировать.

На вкладке Сортировка можно задать колонки для сортировки и тип сортировки в каждой из них. Сортировка будет производиться по выбранным колонкам в том порядке, в котором они перечислены в столбце Имя колонки.

9.9. Выберите имя колонки для сортировки Обозначение и тип сортировки Составная по возрастанию.

В результате объекты в этом разделе будут автоматически сортироваться по данным, введенным в колонку Обозначение. Подробно о типах сортировки рассказано в разделе 6.1.2.6.

Рекомендуется выбирать тип сортировки с учетом типа данных, хранящихся в колонке, по которой производится сортировка. Например, если при настройке колонки был указан Вещественный тип данных (то есть в нее будут вводиться числа), выберите сортировку По возрастанию.

Если вы хотите, чтобы объекты в разделе всегда располагались в порядке их ввода, включите простановку позиций и сортировку объектов по колонке Позиция.


Упражнение 66. Настройка подразделов

1. Активизируйте вкладку Подразделы.

2. Включите опцию Деление на подразделы включить.

– Если эта опция будет выключена, то в настраиваемом разделе (Вновь разрабатываемые изделия) спецификаций, имеющих настраиваемый стиль (Таблица составных частей), никаким способом нельзя будет создать подразделы.

– Если эту опцию включить, но не создавать в стиле спецификации подразделов, то при настройке каждой конкретной спецификации, имеющей этот стиль (Таблица составных частей), можно будет создать подразделы.

– Если опция включена и в стиле спецификации созданы подразделы, то эти подразделы будут существовать во всех спецификациях, имеющих данный стиль. При настройке каждой конкретной спецификации состав подразделов можно будет изменить (добавить или удалить подразделы). Можно будет также отключить деление на подразделы.

3. Нажмите кнопку Добавить.

4. В появившемся диалоге описания подраздела введите имя подраздела Сборочные единицы и номер 5.

Название подраздела служит для удобства выбора подраздела пользователем.

Вне зависимости от последовательности создания подразделы располагаются внутри раздела в порядке возрастания их номеров.

Рекомендуется присваивать подразделам номера не в порядке сплошной нумерации, а с оставлением резервных номеров. В этом случае вы сможете создать новый подраздел в середине раздела, не нарушая нумерацию существующих подразделов.

5. Выйдите из диалога, нажав кнопку OK.

6. Аналогичным образом создайте подраздел Детали с номером 10.


Упражнение 67. Настройка колонок в разделе

1. Активизируйте вкладку Колонки.

В ее верхней части вы увидите тот же список колонок, который вы сформировали во вкладке Колонки диалога настройки стиля спецификации.

На этом этапе вы будете производить точную настройку колонок в разделе. Такая настройка требуется потому, что одни и те же колонки в разных разделах могут заполняться по разным правилам. В диалоге настройки стиля спецификации вы настраивали колонки, указывая типы данных, которые будут использоваться по умолчанию во всех разделах. Теперь требуется уточнить некоторые параметры для конкретной колонки.

Выделив в списке название колонки, в нижней части диалога вы увидите правила, по которым заполняется данная колонка в настраиваемом разделе (Вновь разрабатываемые изделия). Пока вы не производили никаких настроек, эти правила полностью соответствуют правилам, установленным при настройке данной колонки спецификации.

Если какая-либо колонка не должна заполняться в настраиваемом разделе (например, в разделе Документация обычно не заполняются колонки Зона, Позиция и Количество), следует при настройке этой колонки в этом разделе отключить опцию Колонка в разделе заполняется.

Если в разделе отключено заполнение колонки с типом Позиция, то в состав геометрии этого раздела нельзя будет включать позиционные линии-выноски и марки/позиционные обозначения. Возможность включения геометрических объектов остается.

2. Последовательно выделяя названия колонок, убедитесь, что правила их заполнения соответствуют правилам, установленным вами при настройке этих колонок. Не меняйте правила заполнения колонок в разделе Вновь разрабатываемые изделия.

3. Активизируйте вкладку Доп. колонки.

Ее опции схожи с опциями предыдущей вкладки.

4. Последовательно выделяя названия дополнительных колонок, убедитесь, что правила их заполнения соответствуют правилам, установленным вами при настройке этих колонок.

5. По своему усмотрению измените правила заполнения дополнительных колонок в разделе Вновь разрабатываемые изделия или отключите их заполнение.

Использование блоков вложенных разделов в спецификации настраиваемого стиля не предусмотрено. Поэтому на вкладках Блоки вложенных разделов в диалогах настройки разделов ничего делать не нужно.

6. Выйдите из диалога настройки стиля раздела, нажав кнопку OK.


Упражнение 68. Подключение шаблонов заполнения

1. Создайте раздел Заимствованные изделия с номером 5.

2. Включите в нем составную сортировку по колонке Наименование.

3. При настройке колонки Наименование выберите тип значения в колонке Запись.

Это позволит вводить в колонку текст, сформированный по шаблону заполнения.

Если сортировка производится по колонке, содержащей запись (то есть заполняющейся по шаблону), то сортировка должна быть составной (см. раздел 6.1.2.6.3).

После выбора Записи в качестве типа значения в диалоге появятся опции, позволяющие указать, какой именно шаблон будет использоваться при заполнении данной колонки. Пробил час самостоятельно созданных вами шаблонов заполнения.

4. Нажмите кнопку Обзор...

5. В появившемся диалоге укажите путь к библиотеке Test.lat, созданной и наполненной при выполнении упражнений из раздела 6.5.1, и выберите саму эту библиотеку.

6. В поля Ключ 1, Ключ 2 и Ключ 3 введите числа 200, 20 и 0 соответственно.

Это та комбинация ключей, которую вы присвоили типам атрибутов Втулка и Пластина, когда создавали их в библиотеке Test.lat при выполнении упражнений 46 и 47.

Все шаблоны, имеющие в выбранной библиотеке указанную комбинацию ключей, будут доступны при создании объектов в настраиваемом разделе.

Шаблоны из другой библиотеки атрибутов (даже имеющие такую же комбинацию ключей) не будут доступны в разделе.

Шаблоны с другими ключами (даже из выбранной библиотеки атрибутов) также не будут доступны в разделе.

7. Очистите поле Имя ячейки штампа для связи.

8. Остальные настройки стиля раздела Заимствованные изделия произведите по своему усмотрению.

9. Выйдите из диалога настройки стиля раздела, нажав кнопку OK.

10. Создайте раздел Покупные изделия с номером 10.

11. Включите в нем составную сортировку по колонке Наименование.

12. При настройке колонки Наименование выберите тип значения в колонке Запись.

13. В качестве источника шаблона выберите системную библиотеку Spc.lat, расположенную в подпапке \Sys главной папки КОМПАС-3D.

14. Введите ключи 100, 5 и 1.

Как вы знаете, эта комбинация открывает шаблон заполнения наименований стандартных изделий.

15. Остальные настройки стиля раздела Покупные изделия произведите по своему усмотрению.

В создаваемом стиле спецификации получилось три раздела, каждый из которых обладает собственными настройками.


Упражнение 69. Настройка общих свойств спецификации

1. Активизируйте вкладку Настройка.

1.1. Включите Связь с расчетом позиций, Расчет позиций и Расчет зон.

1.2. Включите опцию Документ — Простой.

2. Активизируйте вкладку Блоки исполнений. В группе Формировать обозначения исполнений объектов выберите вариант Показывать только номер.

Благодаря этому в спецификациях, имеющих настраиваемый стиль, будет доступна команда создания исполнений объекта.

Использование блоков дополнительных разделов в спецификации настраиваемого стиля не предусмотрено. Поэтому на вкладке Блоки дополнительных разделов никаких настроек не делайте.

3. Выйдите из диалога настройки стиля спецификации, нажав кнопку OK, и из диалога работы с библиотеками, нажав кнопку Выход.

Создавая стиль спецификации, вы пользовались всеми вкладкам диалога настройки стиля спецификации. В некоторых из них приходилось вызывать дополнительные диалоги нескольких уровней вложенности. Такова специфика настройки стиля — для того, чтобы в спецификации были доступны разнообразные сервисные возможности (автоматическое заполнение колонок, использование шаблонов заполнения, автоматическая сортировка и т.д. и т.п.), приходится включить и настроить каждую из них.

Если вы терпеливо проделали все предлагавшиеся выше упражнения и внимательно прочитали сопровождавшие их теоретические сведения и примеры, то вас можно поздравить с успешным освоением одной из самых сложных процедур КОМПАС-3D — настройки стиля спецификации.


6.5.2.4. Проверка стиля спецификации

Теперь требуется проверить правильность сформированного стиля.

В этом разделе:

Упражнение 70. Проверка созданного стиля спецификации


Упражнение 70. Проверка созданного стиля спецификации

1. Создайте новую спецификацию.

2. Вызовите команду настройки параметров текущей спецификации и выберите для нее созданный вами стиль (Таблица составных частей).

3. Создайте в спецификации несколько объектов в разных разделах.

4. Убедитесь, что в разделе Вновь разрабатываемые изделия существуют подразделы и эти подразделы учитываются при сортировке объектов.

5. Убедитесь, что в разделах Заимствованные изделия и Покупные изделия текстовая часть объектов создается в соответствии с шаблонами заполнения. Проверьте правильность сортировки объектов в этих разделах.

6. Убедитесь, что заголовки разделов отрисовываются установленным вами шрифтом, а в самих разделах появляется указанное вами количество резервных строк.

7. Попытайтесь ввести в колонки данные непредусмотренного типа (например, буквы — в колонку Количество).

8. Проверьте соответствие спецификации остальным настройкам. Если вы забыли значение какого-либо параметра или настройки, о нем можно справиться, вызвав диалог настройки текущего стиля спецификации.

Если вы измените какую-нибудь настройку стиля, изменение будет передано во все спецификации, имеющие этот стиль (в отличие от настроек текущей спецификации).


7.1. Работа с переменными

В этом разделе:

7.1.1. Общие сведения о переменных документа

7.1.1.1. Виды переменных

7.1.1.2. Cтатусы переменных

7.1.1.2.1. Информационные переменные

7.1.1.2.2. Внешние переменные

7.1.1.3. Окно переменных

7.1.1.3.1. Цветовая индикация в Окне переменных

7.1.1.3.2. Настройка Окна переменных

7.1.1.4. Общий порядок работы с переменными

7.1.1.5. Особенности работы с переменными документов КОМПАС-3D версии 11 или более ранней

7.1.2. Создание переменных

7.1.2.1. Пользовательские переменные

7.1.2.2. Переменные параметров операций модели

7.1.2.3. Переменные размеров графических документов и эскизов

7.1.3. Присвоение значений переменным

7.1.3.1. Общие сведения

7.1.3.2. Ввод численного значения или константы

7.1.3.3. Ввод выражения

7.1.3.3.1. Синтаксис выражений

7.1.3.3.2. Пример использования алгебраического выражения

7.1.3.3.3. Пример использования логического выражения

7.1.3.4. Вставка элементов выражения

7.1.3.4.1. Файл коллекции математических выражений

7.1.3.5. Ссылка на переменную

7.1.3.6. Обновление ссылок на переменные

7.1.4. Редактирование и удаление переменных

7.1.4.1. Редактирование переменных

7.1.4.1.1. Особенности редактирования переменных исключения объектов из расчета

7.1.4.2. Назначение допусков в Окне переменных

7.1.4.3. Удаление переменных

7.1.5. Дополнительные возможности работы с переменными

7.1.5.1. Функциональные и интервальные переменные

7.1.5.1.1. Функциональные переменные

7.1.5.1.2. Интервальные переменные

7.1.5.2. Переменные предельных отклонений

7.1.5.3. Внешние переменные

7.1.5.3.1. Переменные параметрических фрагментов

7.1.5.3.2. Переменные моделей

7.1.5.4. Таблицы переменных

7.1.5.4.1. Создание, редактирование и удаление таблицы переменных

7.1.5.4.2. Использование таблицы переменных

7.1.5.4.3. Требования к файлу формата Excel, содержащему таблицу переменных


7.1.1. Общие сведения о переменных документа

7.1. Работа с переменными

7.1.1. Общие сведения о переменных документа

В этом разделе:

7.1.1.1. Виды переменных

7.1.1.2. Cтатусы переменных

7.1.1.2.1. Информационные переменные

7.1.1.2.2. Внешние переменные

7.1.1.3. Окно переменных

7.1.1.3.1. Цветовая индикация в Окне переменных

7.1.1.3.2. Настройка Окна переменных

7.1.1.4. Общий порядок работы с переменными

7.1.1.5. Особенности работы с переменными документов КОМПАС-3D версии 11 или более ранней


7.1.1.1. Виды переменных

Использование переменных в документе позволяет изменять параметры объектов, не прибегая к их редактированию.

В документах КОМПАС-3D используются переменные следующих видов.

Пользовательские переменные — переменные, созданные пользователем в Окне переменных. Они используются для получения значений других переменных. Вы можете создать переменные обычного вида, а также функциональные и интервальные переменные (см. раздел 7.1.5.1).

Переменные параметров операций — переменные, созданные автоматически в процессе задания числовых параметров операций в модели. Значениями этих переменных являются значения параметров. Данные переменные можно использовать для управления значениями параметров операций.

Переменные размеров — переменные, созданные пользователем в процессе создания размеров в графических документах и эскизах. Значениями этих переменных являются значения размеров. Если размер, для которого создана переменная, управляющий, то переменную можно использовать для управления значением размера. Если размер является информационным, то управлять его значением через переменную нельзя.

Переменные предельных отклонений — переменные, созданные пользователем в Окне переменных, предназначенные для задания значений предельных отклонений размеров и параметров, значения которых выражены в линейных или угловых величинах. Работа с переменными данного вида описана в разделе 7.1.5.2.

Кроме того, при работе с моделью автоматически создаются переменные, с помощью которых можно управлять исключением объектов из расчета.

В модели также автоматически создаются переменные объектов «измерение» и размеров — элементов оформления, проставленных вручную. В первом случае значениями переменных являются результаты измерения, а во втором — значения размеров, для которых они созданы. Эти переменные используются только для получения информации.

Об управляющих и информационных размерах, а также размерах — элементах оформления см. разделы 2.9.2.1 и 7.2.1.10.

Переменные могут иметь различные статусы (см. раздел 7.1.1.2).

Для выполнения различных операций с переменными документа используется Окно переменных (см. раздел 7.1.1.3).


7.1.1.2. Cтатусы переменных

Переменным могут присваиваться статусы «внешних» и/или «информационных».

Переменным параметров операций и размеров можно присвоить только статус «информационная». Пользовательская переменная может быть как внешней, так и информационной.

Если пользовательской переменной в документе присвоен статус «внешняя», то эта переменная доступна при вставке документа в другой документ (главный документ). Вы можете изменить значение внешней переменной вставки, использовать ее для получения значений других переменных главного документа.

Если пользовательская переменная в документе является и внешней, и информационной, то при вставке документа в другой документ эта переменная доступна только для получения значений других переменных. Изменить значение такой переменной нельзя.

Подробнее об информационных переменных см. раздел 7.1.1.2.1, о внешних переменных — раздел 7.1.1.2.2.

В этом разделе:

7.1.1.2.1. Информационные переменные

7.1.1.2.2. Внешние переменные


7.1.1.2.1. Информационные переменные

Информационная переменная — это переменная, значение которой зависит от других переменных, размеров или положения объектов документа.

Признаком информационной переменной является желтый или зеленый (если она также является внешней) цвет ячейки с именем переменной в таблице Окна переменных (см. раздел 7.1.1.3.1).

Статус «информационная» может присваиваться переменным вручную и автоматически.

Ручное присвоение статуса доступно только для пользовательских переменных.

Чтобы сделать пользовательскую переменную информационной, выделите ячейку в строке этой переменной и вызовите команду Информационная контекстного меню. Рядом с названием команды в меню появится «галочка». Повторный вызов команды вернет переменную в исходное состояние.

Статус «информационная» может быть назначен автоматически пользовательским переменным и переменным размеров в графических документах и эскизах. Назначение статуса выполняется в следующих случаях.

– Пользовательская переменная становится информационной, если для вычисления ее значения задается выражение, содержащее другие переменные. При удалении переменной из выражения или всего выражения статус «информационная» отменяется.

– Переменная размера получает статус «информационная», если размер, для которого она создана, становится информационным. При переходе информационного размера в управляющий статус «информационная» у переменной отменяется.

Кроме того, при работе с моделями могут создаваться переменные, изначально являющиеся информационными. В этом случае статус «информационная» у переменной нельзя отменить.

Информационные переменные в модели создаются для следующих объектов:

– размеры — элементы оформления, проставленные вручную,

– объекты «измерение»,

– параметры операций, значения которых зависят от положения объектов модели (к таким параметрам относится, например, параметр Расстояние операции выдавливание при выдавливании эскиза до вершины, так как в этом случае значение параметра зависит от положения вершины).

При работе с информационными переменными обратите внимание на следующую особенность.

Если информационная переменная является пользовательской, то ее значение можно изменить — соответствующая ей ячейка столбца Выражение в Окне переменных доступна для редактирования.

Для информационных переменных размеров и параметров операций данная возможность недоступна.


7.1.1.2.2. Внешние переменные

Внешние переменные используются в параметрических фрагментах и моделях. Формирование переменных и присвоение им статуса «внешняя» производится при создании фрагмента (модели).

Внешней переменной в параметрическом фрагменте называется переменная, значение которой можно изменять в главном документе — документе, в который вставлен фрагмент. Основное назначение внешних переменных в параметрическом фрагменте — управление параметрами вставленного в документ фрагмента без редактирования этого фрагмента «изнутри».

Внешней переменной в модели называется переменная, значение которой доступно и может быть изменено в другой модели, содержащей данную в качестве компонента. Основное назначение внешних переменных в модели — управление размерами и топологией модели после вставки ее в другую модель.

Признаком внешней переменной является синий или зеленый (если она также является информационной) цвет ячейки с именем переменной в таблице Окна переменных (см. раздел 7.1.1.3.1).

Формирование переменных и присвоение им статуса «внешняя» производится при создании/редактировании фрагмента (модели).

Статус «внешняя» может иметь только пользовательская переменная. Поэтому для того, чтобы внешняя переменная влияла на изображение или модель, пользовательскую переменную необходимо включить в выражение для вычисления нужной переменной размера или параметра операции (см. раздел 7.1.3.3).

Чтобы сделать пользовательскую переменную внешней, выделите ячейку в строке этой переменной и вызовите команду Внешняя контекстного меню. Рядом с названием команды в меню появится «галочка». Повторный вызов команды вернет переменную в исходное состояние.

Если внешняя переменная является также информационной (см. раздел 7.1.1.2.1), то в главном документе она будет видна, но недоступна для изменения. Статус «информационная» присваивается внешней переменной при создании/редактировании фрагмента (модели). Для этого служит команда Информационная в контекстном меню переменной.

Особенности работы с внешними переменными описаны в разделе 7.1.5.3.


7.1.1.3. Окно переменных

Все переменные документа отображаются в Окне переменных (рис. 7.1.1 и 7.1.2).

Включение и отключение показа Окна переменных производится с помощью команды Вид — Панели инструментов — Переменные. Можно также воспользоваться кнопкой Переменные на панели Стандартная.

Список переменных показывается в виде таблицы. На первом уровне списка расположены переменные, созданные пользователем (они образуют так называемый главный раздел списка переменных), на следующих — переменные параметров операций модели и переменные размеров графических документов и эскизов. Переменные размеров в чертеже объединены в разделы согласно видам, содержащим соответствующие размеры (рис. 7.1.1). Во фрагменте все переменные размеров образуют один раздел. В модели переменные параметров операций и переменные размеров эскизов объединены в разделы согласно объектам, параметрам которых они соответствуют (рис. 7.1.2).

Рис. 7.1.1. Переменные чертежа

Рис. 7.1.2. Переменные детали

Таблица, в виде которой представлен список переменных, содержит умолчательный набор столбцов, расположенных в определенном порядке. Вы можете изменить состав отображаемых столбцов и порядок их расположения в таблице (см. раздел 7.1.1.3.2).

Строки таблицы, содержащие переменные главного раздела, можно перемещать вверх или вниз. Для этого используются команды Переместить вверх и Переместить вниз, вызываемые из пункта меню Сервис Окна переменных или с помощью одноименных кнопок Панели инструментов этого окна.

Кроме того, вы можете выполнить сортировку переменных главного раздела по данным, содержащимся в одном из столбцов таблицы. Для этого выделите ячейку нужного столбца и вызовите команду Сервис — Сортировать меню Окна переменных.

В этом разделе:

7.1.1.3.1. Цветовая индикация в Окне переменных

7.1.1.3.2. Настройка Окна переменных


7.1.1.3.1. Цветовая индикация в Окне переменных

Для индикации в Окне переменных используются различные цвета.

В зависимости от вида и статуса переменной ячейка с ее именем может иметь один из следующих цветов:

– синий — внешняя переменная,

– желтый — информационная переменная,

– зеленый — внешняя информационная переменная,

– розовый — интервальная переменная,

– бирюзовый — функциональная переменная.

Ячейка столбца Допуск в строке переменной окрашивается салатовым цветом, если параметр операции или размер, которому она соответствует, имеет индивидуальный допуск (см. раздел 7.1.4.2).

Красный цвет используется для отображения объектов, содержащих ошибки.


7.1.1.3.2. Настройка Окна переменных

Список переменных показывается в Окне переменных в виде таблицы (см. рис. 7.1.1 и рис. 7.1.2). Вы можете управлять отображением и взаимным расположением всех столбцов таблицы, кроме столбца Имя.

Чтобы настроить набор и взаимное расположение столбцов, выполните следующие действия.

Вызовите команду Сервис — Настроить столбцы из меню Окна переменных. На экране появится диалог Настройка столбцов (рис. 7.1.3).

Рис. 7.1.3. Диалог настройки столбцов

В диалоге содержится список всех столбцов таблицы, отображение и расположение которых можно настроить. Опция слева от наименования столбца управляет его отображением в Окне переменных: если опция включена, столбец отображается в окне, если опция отключена — не отображается.

Сформируйте нужный состав таблицы, включая и отключая опции.

Обратите внимание на то, что опция, соответствующая столбцу Пересчитанное значение, доступна только при включенном режиме пересчета размеров с учетом допусков (см. раздел 2.10.3.3).

Вы также можете изменять взаимное расположение столбцов, перемещая их наименования в списке диалога. Для этого используются кнопки Вверх и Вниз. Порядок следования столбцов в списке определяет последовательность их расположения в таблице Окна переменных.

Чтобы завершить настройку таблицы, закройте диалог Настройка столбцов, нажав кнопку ОК.

Для управления отображением столбцов таблицы можно использовать не только описанный выше диалог, но и команды контекстного меню, вызываемого на заголовке любого из столбцов в Окне переменных. Чтобы включить/отключить отображение нужного столбца, вызовите соответствующую ему команду меню. «Галочка» рядом с названием команды означает, что отображение столбца включено.

Команда Пересчитанное значение контекстного меню доступна только при включенном режиме пересчета размеров с учетом допусков.


7.1.1.4. Общий порядок работы с переменными

Рекомендуется следующий порядок работы с переменными.

Первоначально создайте пользовательские переменные. Эти переменные будут использоваться для задания значений переменных параметров операций модели и переменных размеров графических документов и эскизов.

При работе с графическим документом создайте переменные размеров.

При работе с моделью создайте переменные размеров эскизов. Переменные параметров операций модели создаются автоматически после создания операций.

Способы создания переменных различных видов описаны в разделе 7.1.2.

При дальнейшей работе вы можете добавлять и удалять пользовательские переменные и переменные размеров графических документов и эскизов. Переменные параметров операций модели добавляются и удаляются автоматически.

Вы также можете редактировать переменные различными способами (см. раздел 7.1.4.1).

Используйте переменные для управления геометрией модели или изображения. Для этого присваивайте переменным нужные значения (см. раздел 7.1.3).

В результате присвоения значений переменным изменяются значения размеров в графическом документе или эскизе и числовых параметров операций в модели.

При работе с чертежом виды чертежа (кроме текущего), содержащие размеры, значения которых изменились, отмечаются красной «галочкой» в Дереве построения. При работе с моделью пиктограммы операций с измененными параметрами и эскизов, содержащих размеры с измененными значениями, отмечаются красной «галочкой» в Дереве построения. Это означает, что произведенные изменения еще не переданы в чертеж/модель.

Чтобы перестроить чертеж/модель, вызовите команду Вид — Перестроить. Изображение будет построено заново с учетом новых значений размеров и/или параметров операций.

Команду перестроения необходимо вызывать и в том случае, если изменился статус переменной, например, если пользовательской переменной был присвоен или отменен статус «информационная».

Текущий вид чертежа и изображение во фрагменте перестраиваются автоматически, без вызова данной команды, сразу после задания значения очередной переменной.

Также автоматически перестраивается изображение в эскизе, если значение переменной задается при работе с эскизом.


7.1.1.5. Особенности работы с переменными документов КОМПАС-3D версии 11 или более ранней

7.1.1.5. Особенности работы с переменными
документов КОМПАС-3D версии 11 или более ранней

В КОМПАС-3D версий 9 и 12 был значительно переработан механизм работы с переменными: для версии 9 — в эскизах, для версии 12 — в графических документах. Поэтому при открытии в текущей версии КОМПАС-3D модели, созданной в КОМПАС-3D версии 8 Plus или более ранней, или графического документа, созданного в КОМПАС-3D версии 11 или более ранней, система уравнений документа преобразуется. Преобразование выполняется таким образом, чтобы «поведение» параметризованного изображения сохранилось (если это возможно), т.е. изменение значения какой-либо переменной при работе с документом в КОМПАС-3D текущей версии должно приводить к таким же изменениям изображения, к каким привело бы такое же изменение этой переменной при работе с документом в предыдущих версиях.

В Окне переменных преобразование системы уравнений документа может проявиться в следующем.

1. Переменные могут оказаться как на первом уровне списка переменных, так и в группах следующего уровня (т.е. в одном из видов чертежа или среди переменных размеров фрагмента/эскиза). Общее количество переменных и выражений в документе может измениться. Например, переменная b использовалась в двух видах чертежа. В результате преобразования переменные распределяются по видам, получают разные имена и связывающее их выражение: в одном из видов появляется переменная b, а в другом — b1, значение которой равно b (ячейка Выражение переменной b1 содержит имя переменной b).

2. Уравнения, записанные в форме присвоения (т.е. уравнения, в правой части которых находится числовая константа или выражение, содержащее только числовые константы), не помещаются в область для работы с уравнениями. Числовая константа (или результат выражения) переносится в ячейку Выражение соответствующей переменной.

3. В эскизе, созданном в КОМПАС-3D версии 8 Plus или более ранней, или графическом документе, созданном в КОМПАС-3D версии 11 или более ранней, статус «внешняя» могут иметь как пользовательские переменные, так и переменные размеров. Если отменить у них этот статус (вызвав команду Внешняя из контекстного меню), то вернуть его будет невозможно. Вновь создаваемые переменные можно сделать внешними, только если они являются пользовательскими.


7.1.2. Создание переменных

7.1. Работа с переменными

7.1.2. Создание переменных

В этом разделе:

7.1.2.1. Пользовательские переменные

7.1.2.2. Переменные параметров операций модели

7.1.2.3. Переменные размеров графических документов и эскизов


7.1.2.1. Пользовательские переменные

Для создания пользовательской переменной выполните следующие действия.

1. Щелкните мышью в ячейке Имя пустой строки главного раздела списка переменных.

2. Введите в ячейку имя переменной и нажмите клавишу <Enter>.

Имя переменной может содержать буквы латинского алфавита (различаются символы верхнего и нижнего регистра), арабские цифры и символы подчеркивания («_»). Длина имени переменной не более 512 символов. Первый символ в имени переменной — буква или подчеркивание. Примеры записи: a, b_1.

В случае несоблюдения формата записи имени после нажатия клавиши <Enter> на экране появляется сообщение о том, что имя переменной является недопустимым, и заданное имя не сохраняется.

3. Щелкните мышью в ячейке Выражение создаваемой переменной.

4. Задайте способ присвоения значения переменной и нажмите клавишу <Enter>. Значение переменной может быть получено различными способами (см. раздел 7.1.3).

Если при заполнении ячейки Выражение использовались недопустимые символы, после нажатия клавиши <Enter> на экране появляется сообщение о наличии синтаксических ошибок и содержимое ячейки не сохраняется.

Для присвоения значения переменной может использоваться математическое выражение. Если заданное выражение содержит отсутствующие в документе переменные, они автоматически создаются в главном разделе. Задайте способ присвоения значений этим переменным.

После задания способа присвоения значения переменной рассчитанное значение появляется в ячейке Значение.

5. При необходимости в ячейке Комментарий введите комментарий к созданной переменной.


7.1.2.2. Переменные параметров операций модели

Переменные параметров операций модели создаются автоматически при создании операций. Создание переменных данного вида вручную невозможно.

Для каждой операции создается набор переменных, соответствующих всем ее числовым параметрам. Этим переменным присваиваются имена, сформированные по шаблону «vN», где N — порядковый номер переменной в списке переменных модели. Значениями переменных являются значения параметров, которые вводятся в процессе создания операции в поля Панели свойств. Способы присвоения значений параметрам описаны в разделах 2.1.4.2.1 и 2.1.4.2.4.

Если значение параметра операции зависит от положения объекта модели, то переменная, созданная для этого параметра, является информационной (см. раздел 7.1.1.2.1).

Для переменных параметров каждой операции в Окне переменных создается отдельная группа, имя которой соответствует названию операции. В этой группе также создается переменная параметра Исключить из расчета, управляющая исключением операции из расчета.


7.1.2.3. Переменные размеров графических документов и эскизов

Переменная размера графического документа или эскиза создается в диалоге установки значения размера. Данный диалог появляется автоматически при простановке размера или после вызова команды Установить значение размера и указания размера.

Диалог позволяет задать имя переменной, ее значение и комментарий к ней. Работа в диалоге описана в разделе 7.2.2.20.

В Окне переменных созданная переменная размещается следующим образом:

– в модели — в разделе с именем того эскиза, к которому относится соответствующий размер,

– в чертеже — в разделе с именем того вида, к которому относится соответствующий размер,

– во фрагменте — все переменные размеров составляют один раздел.

Переменная может быть создана только для ассоциативного размера (см. раздел 7.2.1.4).


7.1.3. Присвоение значений переменным

7.1. Работа с переменными

7.1.3. Присвоение значений переменным

В этом разделе:

7.1.3.1. Общие сведения

7.1.3.2. Ввод численного значения или константы

7.1.3.3. Ввод выражения

7.1.3.3.1. Синтаксис выражений

7.1.3.3.2. Пример использования алгебраического выражения

7.1.3.3.3. Пример использования логического выражения

7.1.3.4. Вставка элементов выражения

7.1.3.4.1. Файл коллекции математических выражений

7.1.3.5. Ссылка на переменную

7.1.3.6. Обновление ссылок на переменные


7.1.3.1. Общие сведения

Присвоение различных значений переменным позволяет управлять значениями других переменных и параметров объектов, не прибегая к прямому редактированию изображения или модели.

Значения пользовательских переменных используются для получения значений других пользовательских переменных, переменных параметров операций и переменных размеров.

Способ присвоения значения пользовательской переменной задается и может быть изменен в Окне переменных. Доступны следующие способы:

– непосредственный ввод числа или константы, являющейся значением переменной (см. раздел 7.1.3.2),

– ввод выражения для вычисления значения переменной (см. раздел 7.1.3.3),

– ссылка на переменную, т.е. присвоение значения другой переменной (см. раздел 7.1.3.5).

Присвоение различных значений переменным параметров операций позволяет управлять геометрией модели, а переменным размеров — геометрией изображения в графическом документе и эскизе.

Переменные параметров операций получают свои первоначальные значения автоматически при создании операций. Первоначальными значениями переменных размеров являются значения размеров, для которых они созданы.

Вы можете изменить значение переменной параметра операции или переменной размера, задав другой способ присвоения значения в Окне переменных. Для переменных данных видов доступны те же способы присвоения значения, что и для пользовательских переменных (см. выше). Кроме того, значения этих переменных могут быть изменены в диалоге установки значения размера и в полях Панели свойств (см. раздел 7.1.4.1).

Переменные параметра Исключить из расчета используются для управления исключением объектов из расчета. По умолчанию они имеют нулевые значения. Особенности присвоения значений данным переменным описаны в разделе 7.1.4.1.1.

При задании способа присвоения значения переменной обратите внимание на следующую особенность.

После ввода каждого выражения в документе создается уравнение. Это уравнение включается в систему уравнений документа. Необходимо, чтобы для заданного значения переменной система уравнений документа имела решение. В противном случае на экране появляется сообщение об ошибке.

Чтобы измененные значения переменных были переданы в документ, необходимо его перестроить.


7.1.3.2. Ввод численного значения или константы

Для присвоения значения переменной данным способом выполните следующие действия.

1. В Окне переменных найдите строку переменной, значение которой требуется задать.

2. Щелкните мышью в ячейке Выражение этой строки.

3. Введите с клавиатуры число, являющееся значением переменной, и нажмите клавишу <Enter>.

Переменная примет заданное значение — введенное число появится в ячейке Значение этой же строки.

В документе будет создано уравнение вида «имя переменной = значение».

Значением переменной может быть не только число, но и константа. В этом случае в ячейке Значение отображается значение выбранной константы.

Вы можете вводить константы с клавиатуры (перечень констант приведен в таблице 4 приложения IV), однако рекомендуется задавать их с помощью специального диалога (см. раздел 7.1.3.4).


7.1.3.3. Ввод выражения

Для присвоения значения переменной данным способом выполните следующие действия.

1. В Окне переменных найдите строку переменной, для которой требуется ввести выражение.

2. Щелкните мышью в ячейке Выражение этой строки.

3. Введите выражение для вычисления значения переменной и нажмите клавишу <Enter>. Выражение может быть введено с клавиатуры или вставлено из специального диалога (см. раздел 7.1.3.4). Синтаксис выражений описан в разделе 7.1.3.3.1.

Примеры использования выражений для получения значений переменных модели приведены в разделах 7.1.3.3.2 и 7.1.3.3.3.

После ввода выражения значение переменной будет автоматически рассчитано в соответствии с текущими значениями переменных, используемых в нем. Результат расчета появится в ячейке Значение.

В документе будет создано уравнение вида «имя переменной = выражение». Уравнение может содержать не более 80 элементов — чисел, констант, переменных, знаков операций и функций. Если это количество превышено, на экране появляется сообщение о том, что выражение слишком сложное.

После добавления каждого нового уравнения выполняется автоматическая проверка получившейся системы уравнений на наличие циклической зависимости и на предмет присвоения переменной самой себе. В случае обнаружения одной из указанных ошибок выдается сообщение об этом.

Циклическая зависимость — взаимная зависимость двух уравнений. Элементарный пример циклической зависимости — система из следующих уравнений:

a=b+1,
b=a+1.

Циклическая зависимость переменных в модели может быть опосредована иерархией отношений объектов.

Например, в модели создан эскиз 1 с переменной X. На основе этого эскиза создан элемент выдавливания, а на его грани — эскиз 2 с переменной Y. Переменные X и Y связаны уравнением (рис. 7.1.4).

Рис. 7.1.4. Возникновение циклической зависимости

До тех пор, пока переменная Y не является информационной, циклической зависимости в модели нет. Если отредактировать эскиз, сделав переменную Y информационной (для этого достаточно удалить у соответствующего размера ограничение фиксированный), то в системе уравнений модели появится циклическая зависимость: чтобы перестроить эскиз 1, надо знать значение переменной X, для этого надо знать значение переменной Y, которая может быть определена только после перестроения эскиза 2, а это требует перестроения элемента выдавливания и эскиза 1.

В этом разделе:

7.1.3.3.1. Синтаксис выражений

7.1.3.3.2. Пример использования алгебраического выражения

7.1.3.3.3. Пример использования логического выражения


7.1.3.3.1. Синтаксис выражений

При составлении выражения можно использовать следующие элементы.

• Арифметические операторы (за исключением оператора «=»), логические операторы и функции.

• Численные значения и константы. Пример использования констант: «a - sin (b * M_PI) <= FLT_EPS ? c : d».

Полный перечень операторов, функций и констант приведен в приложении IV.

• Любые переменные, содержащиеся в документе, кроме интервальных (см. раздел 7.1.5.1.2).

Если при составлении выражения используется имя переменной, не существующей в документе, то после фиксации выражения создается пользовательская переменная с таким именем. Эта переменная помещается в главный раздел Окна переменных.

• Формулы, перечень которых приведен в приложении III.

В выражение (но не в имена переменных и не в числа) может быть включено любое количество пробелов. При интерпретации выражения они не учитываются.

Примеры использования выражений для получения значений переменных модели приведены в разделах 7.1.3.3.2 и 7.1.3.3.3.


7.1.3.3.2. Пример использования алгебраического выражения

Эскиз вырезанного элемента выдавливания — окружность диаметром d1. Элемент формирует коническую часть отверстия. Диаметр цилиндрической части отверстия — d (рис. 7.1.5, б).

Рис. 7.1.5. Алгебраическое выражение
а) | б)

Глубина выдавливания (v92) должна вычисляться по формуле (рис. 7.1.5, а):

(d1-d)/2*tand(a*2),

где

d, d1 — диаметры оснований конуса,

a — половина угла при вершине конуса.


7.1.3.3.3. Пример использования логического выражения

Элемент выдавливания, формирующий уступ, должен присутствовать в модели фланцевого угольника при выполнении любого из следующих условий:

– ГОСТ 20189, угол 90°,

– ГОСТ 20190.

Для реализации этого требования в модели необходимо создать следующие переменные (рис. 7.1.6):

– задающую номер стандарта, например, GOST,

– задающую величину угла, например, angle.

Рис. 7.1.6. Логическое выражение

Выражение для вычисления значения переменной уступа, которая соответствует параметру Исключить из расчета (v86), должно быть следующим:

GOST==20189&&angle==90||GOST==20190?0:1 (рис. 7.1.6).

Для удобства работы в выражении можно использовать пробелы и скобки:

(GOST == 20189) && (angle == 90) || (GOST == 20190) ? 0 : 1


7.1.3.4. Вставка элементов выражения

В качестве элементов выражения могут быть вставлены системные функции, константы, операторы, целые выражения и функции кривых.

Вставка элементов выражения выполняется с помощью диалога Вставка математического выражения (рис. 7.1.7). Для вызова диалога нажмите кнопку Вставить функцию или Вставить константу на инструментальной панели Окна переменных. Эти кнопки доступны при редактировании содержимого ячейки Выражение.

Рис. 7.1.7. Диалог Вставка математического выражения

Диалог содержит перечень доступных для вставки элементов выражения. Они объединены в группы. Чтобы выбрать нужный элемент, раскройте группу, в которой он содержится. Перечень элементов этой группы отобразится в правой части диалога в виде таблицы.

В нижней части диалога находится поле Составление выражения. Оно служит для отображения результирующего выражения — элемента в том виде, в каком он будет передан в Окно переменных. Поле заполняется автоматически при выборе элемента. Содержимое поля сохраняется до закрытия диалога. При повторном выборе элемента происходит замена содержимого поля.

Если для вставки выбрано выражение, в диалоге в виде таблицы отображается список переменных, входящих в это выражение. Данная таблица позволяет присваивать переменным произвольные имена.

Чтобы присвоить имя переменной, щелкните мышью в ячейке колонки Подстановка имени, введите нужное имя и нажмите клавишу <Enter>. Данное имя будет использоваться для обозначения переменной в результирующем выражении, отображаемом в поле Составление выражения.

При необходимости вы можете отредактировать содержимое поля. Для этого включите соответствующую ему опцию.

При редактировании доступны следующие действия.

– Ввод символов с клавиатуры.

– Вставка символов с помощью буфера обмена.

– Добавление выражений и их элементов из таблицы элементов текущего диалога. Выбранный элемент добавляется в то место результирующего выражения, в котором в момент добавления находится курсор. Если в этот момент фрагмент результирующего выражения выделен, то он заменяется добавляемым элементом.

– Вставка переменных, используемых в документе. Выполняется с помощью команды Выбрать переменную контекстного меню поля Составление выражения. После вызова этой команды на экране появляется диалог Переменные, позволяющий выбрать нужную переменную из списка переменных текущего документа.

Отредактируйте результирующее выражение, используя описанные выше действия.

Вы можете сохранить полученное выражение в файл коллекции математических выражений collection.law (см. раздел 7.1.3.4.1). Для этого вызовите команду Сохранить выражение из контекстного меню.

Выражения, записанные в файл коллекции, автоматически добавляются в группу Из файла коллекции диалога Вставка математического выражения и могут быть вставлены в Окно переменных. Действия с выражениями из файла коллекции аналогичны действиям с выражениями и их элементами, содержащимися в других группах диалога.

Для вставки результирующего выражения в Окно переменных нажмите кнопку ОК. Диалог Вставка математического выражения закроется, сформированный элемент появится в ячейке Выражение редактируемой переменной.

При вставке функций кривых обратите внимание на следующую особенность.

Функции кривых представлены в диалоге выражениями функций для координат X, Y, Z. Необходимо отдельно вставлять выражения функций для каждой координаты.

Например, для вставки выражения эвольвенты окружности необходимо сначала вставить выражение для вычисления координаты Х, выделив соответствующую строку и нажав кнопку ОК, а затем повторно открыть диалог и вставить выражение для вычисления координаты Y.

При выделении строки с названием функции (в рассматриваемом примере — Эвольвента окружности) в результирующее выражение включаются выражения для вычисления всех координат и дополнительные символы. Выражение в таком виде не может использоваться для получения значения переменной. Его необходимо отредактировать.

В этом разделе:

7.1.3.4.1. Файл коллекции математических выражений


7.1.3.4.1. Файл коллекции математических выражений

Файл коллекции математических выражений collection.law — это xml-файл, содержащий математические выражения, используемые для задания значений переменных и параметрических уравнений кривой по закону (см. раздел 2.5.4.12) в документах КОМПАС-3D.

Путь к файлу определяется переменной EXPRCOLLECTION среды КОМПАС-3D (см. раздел 9.5.4). Если требуется, чтобы расположение файла коллекции математических выражений отличалось от умолчательного, используйте файл Kompas.ini (см. раздел 9.5.3).

Файл коллекции создается автоматически при сохранении первого математического выражения или группового закона, заданного для переменной (сохранение выполняется командой Сохранить выражение). Все сохраняемые в дальнейшем выражения и законы автоматически записываются в файл коллекции. При необходимости вы можете открыть и отредактировать файл с помощью одного из текстовых редакторов или создать свой файл коллекции.

Файл коллекции должен быть единственным и иметь имя collection.law.

Математические выражения, записанные в файл коллекции, отображаются в группе Из файла коллекции диалога Вставка математического выражения (см. раздел 7.1.3.4) и могут использоваться для задания значений переменных или параметрических уравнений кривой по закону.

Синтаксис файла коллекции имеет следующие особенности.

Файл должен содержать объявление XML и один корневой элемент <collection>.

Элементы, содержащие математические выражения, включаются в корневой элемент.

Каждое математическое выражение записывается в отдельный элемент <law>. Данный элемент содержит атрибут string, значением которого является заданное математическое выражение. Кроме того, он может содержать атрибут comment. В значение данного атрибута вы можете ввести дополнительные сведения о выражении. Эти сведения передаются в систему КОМПАС-3D и отображаются в соответствующей ячейке столбца Комментарий диалога Вставка математического выражения.

Несколько математических выражений, записанных последовательно, могут быть объединены в группу для представления группового закона. Для этого используется элемент <complex_law>. Он может содержать атрибут name, значением которого является название закона. Каждое выражение, входящее в закон, записывается в виде отдельного элемента <law>.

При необходимости вы можете изменять значения атрибутов. Все произведенные изменения передаются в диалог Вставка математического выражения.

Пример файла коллекции математических выражений:

<?xml version="1.0" encoding="utf-16"?>

<collection>

<law string="a*((1-x/a)^2-2*ln(1-x/a)-1)/4" comment="Погонная линия"></law>

<complex_law name= "Коническая спираль">

<law string="r*cos(t*M_PI2)" comment="Координата X"></law>

<law string="r*sin(t*M_PI2)" comment="Координата Y"></law>

<law string="h*t" comment="Координата Z"></law>

</complex_law>

<law string="k*a" comment="Спираль Архимеда"></law>

<law string="2*k*cos(a)+d" comment="Улитка Паскаля"></law>

</collection>


7.1.3.5. Ссылка на переменную

В качестве документа — источника ссылки может использоваться графический документ или модель.

Для присвоения значения переменной данным способом выполните следующие действия.

В Окне переменных найдите строку переменной, которая должна получать значение по ссылке, и щелкните мышью в любой ячейке этой строки.

Нажмите кнопку Вставить ссылку на инструментальной панели Окна переменных.

На экране появится диалог Переменные (рис. 7.1.8). В диалоге отображается полное имя текущего документа и таблица содержащихся в нем переменных.

Рис. 7.1.8. Диалог Переменные

Чтобы сделать ссылку на переменную текущего документа, укажите нужную переменную в таблице диалога.

Если текущий документ является моделью с исполнениями, то вы можете сделать ссылку на переменную любого из этих исполнений. В данном случае в диалоге доступен раскрывающийся список Исполнение, который содержит обозначения всех исполнений, имеющихся в модели. После выбора из списка обозначения нужного исполнения в диалоге будет отображена таблица переменных этого исполнения. Укажите нужную переменную в таблице.

Если требуется сделать ссылку на переменную другого документа, нажмите кнопку Файл-источник и укажите нужный документ в появившемся на экране диалоге открытия файлов. Если в качестве документа-источника выбрана модель, содержащая исполнения, то в правой части диалога отображается раскрывающийся список обозначений исполнений. Выберите обозначение нужного исполнения в списке.

После завершения выбора документа на экране снова появится диалог Переменные, содержащий таблицу переменных выбранного документа. Укажите нужную переменную.

Для завершения выбора переменной нажмите кнопку ОК.

Переменная, указанная в Окне переменных, получит значение переменной — источника ссылки. Оно отобразится в колонке Значение.

В документе будет создано уравнение вида «имя переменной = значение».

В колонке Выражение появится текст ссылки на переменную (см. рис. 7.1.9). Текст ссылки формируется по следующему шаблону:

<полный путь к файлу-источнику>|<номер исполнения (для моделей)>|<имя переменной>

Например, ссылка производится на переменную Н, находящуюся в чертеже C:\Work\Project.cdw.

Текст ссылки будет следующим: C:\Work\Project.cdw|H.

Если источником переменной служит другое исполнение текущей модели, то полный путь к файлу-источнику в текст ссылки не включается.


7.1.3.6. Обновление ссылок на переменные

При изменении в файле-источнике значения переменной, на которую имеется ссылка из документа (см. раздел 7.1.3.5), необходимо передать в этот документ новое значение переменной — обновить ссылку.

Обновление ссылок возможно, если файл-источник переменной открыт. Если источником переменных является модель, то для обновления ссылки можно открыть модель, содержащую источник в виде компонента.

Чтобы быстро открыть файл-источник ссылки, воспользуйтесь командой Открыть файл-источник из контекстного меню переменной-ссылки (рис. 7.1.9).

Рис. 7.1.9. Переменная-ссылка

После открытия файла-источника вызовите команду Вид — Перестроить для получения новых значений переменных.

Файл-источник во время перестроения документа, использующего ссылки, не перестраивается.

При открытии документа с переменной-ссылкой система проверяет, открыт ли источник. Если источник закрыт, то переменная-ссылка выделяется красным цветом в Окне переменных и остается выделенной до корректного обновления.


7.1.4. Редактирование и удаление переменных

7.1. Работа с переменными

7.1.4. Редактирование и удаление переменных

В этом разделе:

7.1.4.1. Редактирование переменных

7.1.4.1.1. Особенности редактирования переменных исключения объектов из расчета

7.1.4.2. Назначение допусков в Окне переменных

7.1.4.3. Удаление переменных


7.1.4.1. Редактирование переменных

Редактирование переменных выполняется в Окне переменных. В рамках редактирования вы можете изменять следующие параметры переменных:

– способ присвоения значения переменной — для пользовательских переменных, переменных размеров графических документов и эскизов и переменных параметров операций модели (в том числе параметра Исключить из расчета),

– комментарий к переменной — для всех переменных документа.

Если переменной присвоен статус «информационная», то вы можете отредактировать только комментарий к ней. Исключение составляют информационные пользовательские переменные. Для этих переменных остается доступным изменение способа присвоения значения.

Для задания и изменения способа присвоения значения переменной используется ячейка Выражение (все возможные способы присвоения значений описаны в разделе 7.1.3).

Изменяя значения переменных модели, необходимо иметь в виду следующее.

– Разные параметры операций имеют разные диапазоны значений. Например, значение переменной, соответствующей параметру Угол (этот параметр имеют элементы вращения, выдавливания и другие) не может быть меньше нуля и больше трехсот шестидесяти. Иногда случается так, что параметрам, диапазоны значений которых различны, приравнивается одна и та же переменная. Впоследствии этой переменной может быть присвоено значение, выходящее за пределы диапазона, установленного для одного из параметров. В этом случае в модели возникает ошибка.

– Если для переменной параметра Исключить из расчета задано выражение или ссылка, то произвольное исключение соответствующего объекта из расчета становится невозможным (в контекстном меню объекта становится недоступной команда Исключить из расчета).

Для переменных размеров графических документов и эскизов и переменных модели существуют дополнительные возможности редактирования.

При работе с графическим документом или эскизом для редактирования переменной размера можно использовать диалог установки значения этого размера, который появляется после двойного щелчка мышью на его размерной надписи. Диалог позволяет изменить не только способ присвоения значения переменной и комментарий к ней, но и имя переменной. Работа в диалоге описана в разделе 7.2.2.20.

Если переменная является информационной, т.е. соответствует информационному размеру, то в диалоге установки значения размера можно изменить только ее имя и комментарий (изменение способа присвоения значения недоступно).

При работе с моделью вы можете изменить способ присвоения значения переменной параметра операции, изменив значение соответствующего ей числового параметра в поле Панели свойств. Способы задания значений в полях Панели свойств описаны в разделах 2.1.4.2.1 и 2.1.4.2.4.

Если значение параметра выражено в линейных или угловых величинах, то для редактирования переменной можно также использовать диалог установки значения размера, который появляется после двойного щелчка мышью на размерной надписи размера операции, соответствующего нужному параметру. Диалог позволяет изменить способ присвоения значения переменной и комментарий к ней. Работа в диалоге описана в разделе 2.9.2.2.1.

Кроме того, этот диалог используется для редактирования переменных размеров — элементов оформления, проставленных вручную. Для этих переменных в диалоге доступно изменение имени и комментария.

Вы можете изменить переменную размера эскиза при редактировании трехмерного объекта, использующего данный эскиз. Для этого запустите редактирование объекта. В окне модели отобразятся размеры используемого эскиза. Вызовите диалог установки значения нужного размера, дважды щелкнув мышью на его размерной надписи, и выполните необходимые действия по изменению переменной. В диалоге доступно изменение имени переменной, способа задания ее значения и комментария к ней.

В этом разделе:

7.1.4.1.1. Особенности редактирования переменных исключения объектов из расчета


7.1.4.1.1. Особенности редактирования переменных исключения объектов из расчета

7.1.4.1.1. Особенности редактирования переменных
исключения объектов из расчета

Переменная параметра Исключить из расчета по умолчанию создается с нулевым значением. Это означает что объект, которому она соответствует, включен в расчет. Для исключения объекта из расчета значение переменной должно быть равным единице.

Чтобы исключить объект из расчета, в ячейке Выражение соответствующей ему переменной введите любое число, отличное от нуля, константу или выражение, результатом вычисления которого является число, отличное от нуля. В этом случае значение переменной автоматически приравнивается к единице, а объект исключается из расчета. Обратите внимание на то, что введенное выражение или константа сохраняется в ячейке Выражение, а введенное число заменяется числом 1.0.

Переменная параметра Исключить из расчета автоматически получает значение, равное единице, в следующих случаях:

– если объект исключен из расчета с помощью команды Исключить из расчета контекстного меню,

– если свойство объекта, созданное из переменной параметра Исключить из расчета (см. раздел 5.1.3.2.1), имеет значение Включено.

В этих случаях после включения объекта в расчет (с помощью соответствующей команды или присвоения свойству значения Выключено) значение переменной опять становится нулевым.

Если объект исключен из расчета в результате ручного заполнения ячейки Выражение Окна переменных, то включить объект в расчет можно только ручным вводом нулевого значения в этой ячейке. Команда включения объекта в расчет и изменение значения соответствующего свойства недоступны.

Если объект должен исключаться из расчета при выполнении определенного условия, то для задания значения переменной используется логическое выражение. Пример использования такого выражения приведен в разделе 7.1.3.3.2.


7.1.4.2. Назначение допусков в Окне переменных

Использование переменных позволяет изменять значения числовых параметров операций модели и управляющих размеров графического документа и эскиза. Изменение значений выполняется в Окне переменных. Кроме того, в этом окне вы можете назначить или изменить допуск на значение параметра или допуск на размер.

Допуски отображаются в столбце Допуск. По умолчанию этот столбец не показывается в Окне переменных. Чтобы включить отображение столбца, выполните действия, описанные в разделе 7.1.1.3.2.

Если ячейка столбца Допуск в строке переменной заполнена, то для этой переменной доступны просмотр, задание и изменение допуска. Ячейка заполняется в следующих случаях:

– при работе с моделью:

• если переменная соответствует параметру операции, значение которого выражено в линейных или угловых величинах,

• если переменная соответствует управляющему размеру эскиза,

– при работе с графическим документом — если переменная соответствует управляющему размеру.

Во всех остальных случаях ячейка столбца Допуск в строке переменной остается пустой.

При работе с моделью допуск значения параметра или управляющего размера (в эскизе) может быть либо общим, либо индивидуальным (см. раздел 2.10.2). В графических документах все допуски — индивидуальные. В Окне переменных отображаются как общие, так и индивидуальные допуски.

Допуск имеет вид интервала между предельными значениями параметра или размера. Например, на линейный размер 60, имеющий переменную, назначен допуск по квалитету Н10 с предельными отклонениями +0,00 и +0,12. Этот допуск отображается в Окне переменных в виде [60;60,12].

Если значению параметра или размера не назначен ни индивидуальный, ни общий допуск, то предельные значения, составляющие интервал, совпадают с номинальным значением параметра (размера). Например, линейному размеру 60, имеющему переменную, не назначен допуск. Содержимое ячейки столбца Допуск в Окне переменных имеет вид [60;60]. Такая запись используется и в том случае, если при назначении индивидуального допуска была включена опция Номинальный.

Ячейки столбца Допуск имеют серый цвет, за исключением ячеек, содержащих значения индивидуальных допусков. Эти ячейки салатового цвета. Независимо от цвета все ячейки столбца Допуск недоступны для ручного ввода. Чтобы назначить или изменить допуск, следует вызвать диалог назначения допуска одним из следующих способов:

– выделите ячейку с именем нужной переменной и вызовите команду Сервис — Назначить допуск меню Окна переменных,

– вызовите команду Назначить допуск контекстного меню имени переменной,

– дважды щелкните мышью в ячейке столбца Допуск, соответствующей переменной.

Диалог назначения допуска показан на рис. 2.10.2. Порядок работы в диалоге описан в разделе 2.10.2.2.

Пустая ячейка столбца Допуск может означать также, что переменная соответствует размеру или параметру, для которого отключено использование допуска. В этом случае, вызвав диалог назначения допуска, вы можете включить использование допуска и задать его значение.


7.1.4.3. Удаление переменных

Удаление переменных выполняется различными способами.

Для удаления пользовательской переменной выделите ячейку с ее именем в Окне переменных и нажмите кнопку Удалить на инструментальной панели этого окна или клавишу <Delete>. Переменная удаляется в том случае, если она не входит в выражения, заданные для вычисления других переменных. В противном случае переменная не удаляется, а на экране появляется диалог Использование переменной, содержащий список объектов текущего документа, в которых используется данная переменная.

Переменную размера графического документа или эскиза можно удалить двумя способами:

– удалить имя переменной в диалоге установки значения размера (см. раздел 7.2.2.20),

– удалить у размера ограничение размер с переменной (см. раздел 7.2.3.1).

Если удаляемая переменная размера входит в выражения, заданные для вычисления других переменных, то она включается в число пользовательских переменных. Текущее значение переменной или выражение, заданное для вычисления ее значения, сохраняется. В последнем случае переменной автоматически присваивается статус «информационная».

Переменные параметров операций модели, размеров — элементов оформления, проставленных вручную, и объектов «измерение» удаляются автоматически при удалении соответствующих параметров/размеров/объектов «измерение». Произвольное удаление этих переменных невозможно.

При необходимости вы можете удалить не саму переменную, а выражение, заданное для вычисления ее значения. Для этого выделите ячейку столбца Выражение в строке переменной и нажмите кнопку Удалить или клавишу <Delete>. Выражение будет удалено. При этом переменная сохранит свое текущее значение.


7.1.5. Дополнительные возможности работы с переменными

7.1. Работа с переменными

7.1.5. Дополнительные возможности работы с переменными

В этом разделе:

7.1.5.1. Функциональные и интервальные переменные

7.1.5.1.1. Функциональные переменные

7.1.5.1.2. Интервальные переменные

7.1.5.2. Переменные предельных отклонений

7.1.5.3. Внешние переменные

7.1.5.3.1. Переменные параметрических фрагментов

7.1.5.3.2. Переменные моделей

7.1.5.4. Таблицы переменных

7.1.5.4.1. Создание, редактирование и удаление таблицы переменных

7.1.5.4.2. Использование таблицы переменных

7.1.5.4.3. Требования к файлу формата Excel, содержащему таблицу переменных


7.1.5.1. Функциональные и интервальные переменные

В системе КОМПАС-3D предусмотрены дополнительные возможности работы с переменными — создание функциональных и интервальных переменных. Эти переменные используются для получения значений параметров построения объектов. Например, функциональные переменные можно использовать при построении кривых по закону (см. раздел 2.5.4.12), а также в тех случаях, когда требуется получить значения функции при различных значениях аргумента (см. рис. 7.1.11). Функциональная переменная может также использоваться для расчета значений пользовательских переменных.

Функциональные и интервальные пользовательские переменные создаются в главном разделе и автоматически помещаются в специальные разделы списка переменных: функциональные — в раздел Функции (рис. 7.1.10 и 7.1.11), интервальные — в раздел Интервалы. Эти разделы располагаются сразу после главного раздела.

Раздел Функции создается автоматически после ввода имени первой функциональной переменной, раздел Интервалы — первой интервальной переменной.

Рис. 7.1.10. Использование функциональных переменных в кривой по закону

Рис. 7.1.11. Использование функциональной переменной для разных значений аргумента

Описание функциональных переменных приведено в разделе 7.1.5.1.1, интервальных — в разделе 7.1.5.1.2.

При построении кривой по закону функциональные и интервальные переменные создаются автоматически при задании функций координат точек кривой и интервальных параметров этих функций. Созданные переменные не добавляются в разделы Функции и Интервалы Окна переменных. Они помещаются в раздел переменных кривой по закону.

При необходимости вы можете использовать созданные заранее функциональные и интервальные переменные при построении кривой (см. разделы 2.5.4.12.2 и 2.5.4.12.3).

В этом разделе:

7.1.5.1.1. Функциональные переменные

7.1.5.1.2. Интервальные переменные


7.1.5.1.1. Функциональные переменные

Функциональная переменная — переменная вида a(b).

Имя функциональной переменной записывается в виде f(x1; x2; ...; xn). Обозначения функции и аргументов могут содержать буквы латинского алфавита (различаются символы верхнего и нижнего регистра), арабские цифры и символы подчеркивания («_»). Длина имени переменной не более 512 символов. Первый символ в обозначении функции или аргумента — буква или подчеркивание. Примеры записи: a(b), а(b_1;b_2). При необходимости вы можете создать несколько функциональных переменных с одними и теми же аргументами.

Имя аргумента функциональной переменной может совпадать с именем пользовательской переменной обычного вида. Например, документ может содержать переменную b и функциональную переменную a(b). Переменная и одноименный аргумент являются самостоятельными величинами, имеющими собственные, отличные друг от друга, значения.

В ячейку Выражение Окна переменных, соответствующую функциональной переменной, вводится выражение (см. раздел 7.1.3.3) для вычисления значения функции при подстановке значений ее аргументов.

Текущего значения функциональная переменная не имеет.

Чтобы использовать значение функции при определенном значении аргумента для вычисления другой переменной или в качестве граничного значения интервала, следует записывать функциональную переменную с аргументом — числом или константой.

Например, имеется функциональная переменная a(b). В выражении требуется использовать значение этой переменной, рассчитанное для аргумента, равного 10. Для этого в выражении следует записать функциональную переменную в виде a(10).


7.1.5.1.2. Интервальные переменные

Интервальная переменная — переменная вида [a].

Имя интервальной переменной заключается в квадратные скобки и может содержать буквы латинского алфавита (различаются символы верхнего и нижнего регистра), арабские цифры и символы подчеркивания («_»). Длина имени переменной не более 512 символов. Первый символ в имени переменной — квадратная скобка, далее — буква или подчеркивание, последний символ — квадратная скобка. Примеры записи: [a], [b_1].

Значение интервальной переменной представляет собой интервал значений, например, [10.0;20.0].

Для присвоения значения интервальной переменной выполните следующие действия.

1. В Окне переменных найдите строку переменной, для которой требуется ввести интервал значений.

2. Щелкните мышью в ячейке Выражение этой строки.

3. Введите нужный интервал значений и нажмите клавишу <Enter>. Заданный интервал заключается в квадратные скобки. Значения, ограничивающие интервал, разделяются знаком «;». В качестве граничных значений интервала можно использовать:

• численные значения, например, «[0.0;10.0]», «[10;-10]»,

• константы (перечень констант приведен в таблице 4 приложения IV), например, «[0.0;M_PI]»,

• выражения (см. раздел 7.1.3.3.1), например, «[a-b;a+b]»,

• любые переменные, кроме интервальных, например, «[0.0;a]», «[а(10);а(20)]».

При задании интервала значений допускается, чтобы второе значение было меньше первого.

После ввода интервала значений в ячейке Выражение рассчитывается текущий интервал значений переменной. Он отображается в ячейке Значение и содержит только численные значения.

Если заданный интервал значений содержит отсутствующие в документе переменные, они автоматически создаются в главном разделе или в группе Функции (в случае использования функциональных переменных). Задайте значения или выражения для этих переменных.


7.1.5.2. Переменные предельных отклонений

Переменные предельных отклонений предназначены для задания значений предельных отклонений управляющих размеров графического документа или эскиза и параметров операций модели, значения которых выражены в линейных или угловых величинах.

Переменные данного вида создаются пользователем. Для их создания необходимо выбрать исходную переменную — переменную размера или параметра, предельные отклонения которого требуется задавать с помощью переменных.

Чтобы создать переменные предельных отклонений для нужного размера или параметра, выделите ячейку с именем соответствующей ему переменной и вызовите команду Вставка — Предельных отклонений меню Окна переменных.

В модели создаются две переменные — верхнего и нижнего предельных отклонений. Они располагаются сразу после исходной переменной и иерархически подчинены ей.

Имена переменных предельных отклонений формируются автоматически и имеют вид:

– для переменной верхнего отклонения — <имя исходной переменной>_ES (например, v7_ES),

– для переменной нижнего отклонения — <имя исходной переменной>_EI (например, v7_EI).

Если переменная с таким именем уже существует, то к имени вновь созданной переменной добавляется порядковый номер, например, v7_ES_1.

По умолчанию переменные предельных отклонений получают значения предельных отклонений того размера или параметра, для которого они созданы. Эти значения могут соответствовать общему или индивидуальному допуску на размер (параметр), а также быть равными нулю, если допуск не назначен. Значения помещаются в ячейки Значение переменных предельных отклонений, а соответствующие им ячейки Выражение остаются пустыми. Для задания нужных значений переменных в ячейки Выражение введите:

– число или константу (см. раздел 7.1.3.2),

– выражение для вычисления значения (см. раздел 7.1.3.3),

– ссылку на переменную (см. раздел 7.1.3.5).

Если ячейка Выражение хотя бы одной из переменных предельных отклонений заполнена, то допуск на соответствующий размер (параметр) можно назначить только с помощью этих переменных. Назначение допуска в диалогах Задание размерной надписи (см. раздел 3.3.1.3), Назначить допуск (см. раздел 2.10.2.2) и Значение и допуск (см. раздел 2.13.3.5.4) недоступно.

При необходимости вы можете удалить переменные предельных отклонений. Их удаление выполняется аналогично удалению пользовательских переменных. Кроме того, эти переменные удаляются автоматически при удалении их исходной переменной. Особенности удаления переменных описаны в разделе 7.1.4.3.


7.1.5.3. Внешние переменные

Как правило, в параметрическом изображении или модели одни переменные являются независимыми (их значения могут быть непосредственно введены пользователем), а другие — вычисляемыми (их значения зависят от значений остальных переменных). При вставке параметрического фрагмента в другой документ или модели в другую модель обычно требуется задание значений независимых переменных. Остальные переменные вычисляются согласно существующим во вставляемом фрагменте или модели выражениям.

Например, вы построили в параметрическом фрагменте изображение крышки и при помощи выражений задали зависимости между ее высотой, толщиной, диаметром и диаметрами отверстий в ней.

При вставке фрагмента с крышкой в чертеж размерами, определяющими все ее параметры, должны быть диаметр и высота. Сделайте переменные, соответствующие диаметру и высоте крышки, внешними. Тогда в момент вставки фрагмента в чертеж нужно будет задать только их значения. Расчет значений остальных переменных и соответствующее перестроение изображения будет выполнено автоматически.

Для быстрого присвоения внешним переменным вставляемого (вставленного) фрагмента или модели предопределенных значений можно использовать таблицу переменных (см. раздел 7.1.5.4).

В этом разделе:

7.1.5.3.1. Переменные параметрических фрагментов

7.1.5.3.2. Переменные моделей


7.1.5.3.1. Переменные параметрических фрагментов

При вставке параметрического фрагмента в другой документ внешние переменные фрагмента сохраняют свои имена и текущие значения. Порядок вставки фрагментов описан в разделе 3.8.2.1.

В процессе дальнейшей работы с документом вы можете изменять значения внешних переменных вставленного фрагмента.

Команда Разрушить позволяет разбить вставленный фрагмент на отдельные объекты. При этом внешние переменные фрагмента будут утеряны, а в группу переменных документа добавятся переменные, соответствующие размерам объектов фрагмента. Они автоматически получат имена, образованные по шаблону: «vN_name», где N — порядковый номер переменной в списке переменных документа, а name — имя переменной фрагмента. Текущие значения переменных будут переданы из фрагмента и отображены в ячейках Значение Окна переменных. Ячейки Выражение останутся пустыми.


7.1.5.3.2. Переменные моделей

При вставке модели в другую модель в качестве компонента все ее внешние переменные помещаются в группу переменных этого компонента. Они автоматически получают имена, образованные по шаблону: «vN_name» (рис. 7.1.12), где:

– N — порядковый номер переменной в списке переменных модели, содержащей компонент,

– name — имя внешней переменной компонента.

Ячейки Значение полученных переменных содержат текущие значения соответствующих им внешних переменных, переданные из файла-источника. Ячейки Выражение являются пустыми.

Рис. 7.1.12. Переменные сборки

До тех пор, пока значение внешней переменной компонента не задано в модели вручную, эта переменная сохраняет связь с файлом-источником компонента, т.е. после изменения значения переменной в файле-источнике компонент перестраивается в содержащей его модели.

В случае если в модели было введено значение или выражение для внешней переменной компонента, то связь этой переменной с файлом-источником прерывается. При любых изменениях в файле-источнике компонента такая переменная сохраняет значение, заданное ей в модели, содержащей компонент.

Если требуется восстановить связь между внешней переменной компонента и файлом-источником, вызовите из контекстного меню этой переменной команду Значение из источника.

Формирование переменных и присвоение им статуса «внешняя» производится в файле-источнике компонента.


7.1.5.4. Таблицы переменных

Таблица значений внешних переменных (таблица переменных) — это таблица, хранящаяся в файле и содержащая предопределенные значения внешних переменных этого файла.

Таблица переменных используется при вставке файла с внешними переменными в другой документ: из таблицы выбирается строка, каждая ячейка которой содержит значение одной внешней переменной. Эти значения присваиваются внешним переменным вставляемого файла.

Выбор значений переменных из таблицы не является обязательным. При необходимости вы можете задать внешним переменным произвольные значения вручную. Если в файле отсутствует таблица переменных, то ввод значений переменных вручную — единственный способ их изменения.

Таблица переменных формируется пользователем во время создания или редактирования файла, имеющего внешние переменные. Впоследствии таблица может быть отредактирована или удалена из файла.

Таблица переменных организована следующим образом (рис. 7.1.13):

– Первая строка, начиная со второй ячейки, содержит имена переменных — заголовки столбцов таблицы.

– Первый столбец, начиная со второй ячейки, содержит комментарии к строкам.

– Остальные ячейки содержат значения переменных.

Таким образом, каждая строка таблицы, начиная со второй, содержит определенный набор значений переменных и комментарий — название этого набора.

Рис. 7.1.13. Пример таблицы переменных

Переменные файла и хранящейся в нем таблицы не обязательно должны полностью совпадать. При выборе строки из таблицы значения будут присвоены лишь тем переменным файла, имена которых совпадают с заголовками столбцов таблицы.

Если в файле есть внешние переменные, то при создании в нем таблицы переменных можно использовать функцию чтения внешних переменных. В результате в таблице будут автоматически созданы столбцы, соответствующие имеющимся в файле внешним переменным.

Таблица переменных, хранящаяся в файле, может быть записана в файл формата Excel. Возможно также чтение таблицы переменных из файла формата Excel. Для того чтобы чтение было возможно, файл формата Excel должен удовлетворять определенным требованиям (см. раздел 7.1.5.4.3).

При создании или редактировании таблицы переменных пользователь может выбрать умолчательный способ ее отображения во время вставки файла в другой документ: отображение всей таблицы или отображение первого столбца (т.е. только комментариев к строкам).

В этом разделе:

7.1.5.4.1. Создание, редактирование и удаление таблицы переменных

7.1.5.4.2. Использование таблицы переменных

7.1.5.4.3. Требования к файлу формата Excel, содержащему таблицу переменных


7.1.5.4.1. Создание, редактирование и удаление таблицы переменных

Чтобы создать в текущем файле таблицу переменных, выполните следующие действия.

1. Откройте Окно переменных.

2. На инструментальной панели Окна переменных (см. рис. 7.1.1) нажмите кнопку Таблица переменных.

На экране появится окно Таблица переменных (рис. 7.1.14). Вновь созданная таблица переменных пуста.

3. Создайте таблицу.

3.1. Если нужная таблица создана заранее и записана в файле формата Excel, то нажмите кнопку Читать из файла на инструментальной панели окна Таблица переменных. В появившемся диалоге открытия файлов укажите нужный файл и нажмите кнопку Открыть. Если выбранный файл удовлетворяет требованиям (см. раздел 7.1.5.4.3), таблица будет заполнена данными из этого файла.

Не рекомендуется, чтобы файл *.xls был открыт в MS Excel во время передачи данных из этого файла в КОМПАС-3D.

3.2. Если в файле уже есть внешние переменные, то нажмите кнопку Читать внешние переменные. В таблице появятся столбцы, соответствующие имеющимся внешним переменным файла.

В таблицу переменных автоматически заносятся лишь те внешние переменные, которые не являются информационными.

3.3. Добавьте в таблицу нужное количество строк и столбцов с помощью кнопок:

• Добавить строку выше

• Добавить строку ниже

• Добавить столбец слева

• Добавить столбец справа

3.4. Введите комментарии к строкам и значения переменных.

4. Закройте окно Таблица переменных кнопкой ОК.

Рис. 7.1.14. Окно Таблица переменных

Созданная таблица будет добавлена в текущий файл.

Редактирование таблицы переменных практически аналогично ее созданию. Чтобы начать редактирование, откройте окно Таблица переменных, выполнив пп. 1 и 2 вышеприведенной последовательности действий. Доступны следующие возможности редактирования таблицы переменных.

– Замена таблицей, записанной в файле формата Excel. Для этого нажмите кнопку Читать из файла.

– Добавление столбцов, соответствующих внешним переменным файла. Для этого нажмите кнопку Читать внешние переменные. Внешние переменные файла, которых еще нет в таблице, будут добавлены в нее.

– Переименование столбцов. Для этого выделите нужный столбец и нажмите кнопку Переименовать столбец.

– Добавление строк перед или после выделенной строки.

– Добавление столбцов перед или после выделенного столбца.

– Удаление выделенных строк.

– Удаление выделенных столбцов.

– Перемещение выделенной строки в вертикальном направлении.

Чтобы отредактировать комментарий или значение переменной, активизируйте нужную ячейку таблицы щелчком мыши, а затем введите новый текст или число.

Если наличие таблицы переменных в файле больше не требуется, ее можно удалить. Для этого нажмите кнопку Удалить таблицу переменных на инструментальной панели Окна переменных. На запрос системы об удалении таблицы переменных из файла ответьте «Да».


7.1.5.4.2. Использование таблицы переменных

Основное назначение таблицы переменных — быстрое присвоение значений внешним переменным файла, вставляемого (или вставленного) в другой документ.

Для присвоения значений внешним переменным файла необходимо открыть содержащуюся в этом файле таблицу переменных и выбрать из нее нужную строку. Значения переменных, находящиеся в ячейках этой строки, будут переданы в файл.

Для открытия таблицы переменных служит кнопка Таблица переменных. Она расположена на Панели свойств:

– при работе с моделями (вставка компонента с диска или из библиотеки моделей, редактирование вставки) — на вкладке Параметры,

– при работе с графическими документами (вставка фрагмента с диска или из библиотеки фрагментов, редактирование вставки фрагмента) — на вкладке Переменные.

Для открытия таблицы переменных компонента, вставленного в модель с диска, служит команда Таблица переменных, расположенная в контекстном меню пиктограммы этого компонента в Дереве построения.

Кнопка (команда) Таблица переменных доступна, если таблица переменных, хранящаяся во вставляемом (вставленном) файле, содержит более одной строки.

После нажатия кнопки Таблица переменных или вызова команды Таблица переменных на экране появляется окно Таблица переменных (см. рис. 7.1.14). Выберите из таблицы нужную строку и закройте окно кнопкой ОК. Внешним переменным вставляемого (вставленного) файла будут присвоены значения, содержащиеся в ячейках выбранной строки.

Кроме изменения значений внешних переменных файла, вставленного в другой документ, таблицу переменных можно использовать для изменения текущих значений переменных в самом файле, содержащем таблицу. Для того чтобы присвоить внешним переменным файла значения из таблицы переменных, выполните следующие действия.

1. Откройте файл, содержащий внешние переменные и таблицу переменных.

2. Откройте Окно переменных.

3. На инструментальной панели Окна переменных нажмите кнопку Таблица переменных.

На экране появится окно Таблица переменных (см. рис. 7.1.14).

4. Выберите из таблицы нужную строку и нажмите кнопку Присвоить значения переменным.

Окно Таблица переменных закроется, внешние переменные текущего файла приобретут значения, содержащиеся в выбранной строке таблицы.

Если текущий файл — модель, то для ее перестроения необходимо вызвать команду Перестроить.

Если в файле есть внешние переменные, которые отсутствуют в таблице, то их значения после применения таблицы не меняются.

Значения информационных переменных после применения таблицы не меняются, даже если эти переменные присутствуют в таблице.


7.1.5.4.3. Требования к файлу формата Excel, содержащему таблицу переменных

В таблицу переменных могут быть переданы данные, хранящиеся в файле формата Excel. Для того чтобы импорт данных производился корректно, содержимое файла Excel должно удовлетворять следующим требованиям.

1. Лист с данными в книге Excel должен иметь имя VarTable. Если этот лист пустой или содержит некорректные данные, на экране появляется сообщение системы: «Данные не найдены».

2. Импортируемая таблица не должна содержать полностью пустых строк или столбцов. Сведения из ячеек, находящихся ниже пустой строки и справа от пустого столбца, в таблицу переменных не переносятся.

Таблица переменных формируется в строгом соответствии с таблицей формата Excel. Столбцы и строки будут расположены в последовательности, заданной на листе VarTable. Первыми столбцом и строкой таблицы переменных будут первые по счету заполненные столбец и строка из таблицы VarTable.

3. Ячейки импортируемой таблицы должны быть заполнены по следующим правилам.

– В первую строку, начиная со второй ячейки, вводятся имена переменных.

– В первый столбец, начиная со второй ячейки, вводятся комментарии к каждому набору параметров.

– В остальные ячейки вводятся значения переменных. Эти ячейки могут содержать только действительные числа.

Если таблица содержит данные неверного формата (например, в ячейках значений переменных присутствуют буквы), то при импорте на экране появится сообщение «Данные, имеющие неверный формат, будут заменены на "0"». Это сообщение также появляется, если в импортируемой таблице есть пустые или объединенные ячейки. Чтобы перенести измененные данные, нажмите кнопку ОК, чтобы отказаться от переноса — кнопку Отмена.

Такие элементы форматирования, как размер, стиль и цвет шрифта, размер ячеек и т.п. импортируемой таблицы игнорируются.


7.2. Параметризация геометрических объектов

В этом разделе:

7.2.1. Общие сведения о параметризации

7.2.1.1. Что такое параметрическое изображение

7.2.1.2. Идеология параметризации КОМПАС-3D

7.2.1.3. Параметрические возможности КОМПАС-3D

7.2.1.3.1. Связи и ограничения

7.2.1.3.2. Ассоциативные объекты

7.2.1.3.3. Непараметризуемые объекты

7.2.1.4. Принципы и приемы наложения связей и ограничений

7.2.1.5. Рекомендации по использованию параметрических возможностей

7.2.1.6. Особенности работы с параметрическими объектами

7.2.1.7. Параметрический режим

7.2.1.8. Включение и настройка параметрического режима

7.2.1.9. Общий порядок действий при построении параметрического изображения

7.2.1.10. Управляющие и информационные размеры. Размеры с переменными

7.2.2. Наложение связей и ограничений

7.2.2.1. Горизонталь

7.2.2.2. Вертикаль

7.2.2.3. Выравнивание точек по горизонтали

7.2.2.3.1. Выбор точки для выравнивания из нескольких совпадающих

7.2.2.4. Выравнивание точек по вертикали

7.2.2.5. Объединение точек

7.2.2.6. Точка на кривой

7.2.2.7. Точка на середине кривой

7.2.2.8. Симметрия двух точек

7.2.2.9. Параллельность

7.2.2.10. Перпендикулярность

7.2.2.11. Коллинеарность

7.2.2.12. Биссектриса

7.2.2.13. Касание

7.2.2.14. Равенство радиусов

7.2.2.15. Равенство длин

7.2.2.16. Фиксация точки

7.2.2.17. Фиксация размера

7.2.2.18. Фиксация длины

7.2.2.19. Фиксация угла

7.2.2.20. Установка значения размера

7.2.2.21. Параметризация объектов

7.2.3. Просмотр и удаление связей и ограничений

7.2.3.1. Показать/удалить ограничения

7.2.3.2. Удалить все ограничения

7.2.4. Особенности работы с ассоциативными обозначениями

7.2.5. Приемы работы с параметрическими изображениями

7.2.5.1. Преобразование обычного изображения в параметрическое

7.2.5.2. Преобразование параметрического изображения в обычное

7.2.5.3. Редактирование параметрического изображения

7.2.5.3.1. Изменение значений переменных

7.2.5.3.2. Управление значениями размеров

7.2.5.3.3. Редактирование «перетаскиванием» точек

7.2.6. Отображение ограничений и степеней свободы

7.2.6.1. Ограничения

7.2.6.1.1. Особенности отображения размеров с переменными

7.2.6.2. Степени свободы

7.2.7. Особенности использования некоторых команд в параметрическом режиме

7.2.7.1. Радиальный размер

7.2.7.2. Угловой размер

7.2.7.3. Обозначение центра

7.2.7.4. Симметрия

7.2.7.5. Автоосевая

7.2.7.6. Линейный размер с обрывом


7.2.1. Общие сведения о параметризации

7.2. Параметризация геометрических объектов

7.2.1. Общие сведения о параметризации

В этом разделе:

7.2.1.1. Что такое параметрическое изображение

7.2.1.2. Идеология параметризации КОМПАС-3D

7.2.1.3. Параметрические возможности КОМПАС-3D

7.2.1.3.1. Связи и ограничения

7.2.1.3.2. Ассоциативные объекты

7.2.1.3.3. Непараметризуемые объекты

7.2.1.4. Принципы и приемы наложения связей и ограничений

7.2.1.5. Рекомендации по использованию параметрических возможностей

7.2.1.6. Особенности работы с параметрическими объектами

7.2.1.7. Параметрический режим

7.2.1.8. Включение и настройка параметрического режима

7.2.1.9. Общий порядок действий при построении параметрического изображения

7.2.1.10. Управляющие и информационные размеры. Размеры с переменными


7.2.1.1. Что такое параметрическое изображение

Отличие параметрического изображения от обычного состоит в том, что в нем хранится информация не только о расположении и характеристиках геометрических объектов, но и о взаимосвязях между объектами и наложенных на них ограничениях.

Под взаимосвязью объектов подразумевается зависимость между параметрами нескольких объектов. При редактировании одного из взаимосвязанных параметров изменяются другие. Редактирование параметров одного объекта, не связанных с параметрами других объектов, не влияет ни на какие параметры. При удалении одного или нескольких объектов взаимосвязь исчезает.

В качестве примеров связей, наложенных на объекты, можно привести параллельность и перпендикулярность отрезков, прямых, стрелок взгляда, сегментов линии ступенчатого разреза, равенство длин отрезков или радиусов окружностей. Взаимозависимыми параметрами параллельных отрезков являются углы их наклона, т.к. параллельность отрезков тождественна равенству углов их наклона. Если повернуть один из связанных таким образом отрезков, т.е. изменить угол его наклона, повернется и другой отрезок. Если сдвинуть или промасштабировать один из отрезков, т.е. не изменять его угол наклона, второй отрезок не изменится. Если удалить один из отрезков, то угол наклона другого станет независимым.

Зависимость между параметрами может быть и более сложной, чем равенство одного параметра другому. Например, возможно задание функции, определяющей отношение между параметрами нескольких объектов.

Второй тип параметрической связи — ассоциативность объектов. Ассоциативными могут быть объекты, которые при построении привязываются к другим объектам — размеры, технологические обозначения, штриховки. Такие объекты «помнят» о своей принадлежности к базовому объекту (отрезку, окружности, другому размеру или обозначению и т.д.) или к нескольким объектам. При редактировании базовых объектов (например, их сдвиге или повороте) ассоциативные объекты перестраиваются соответствующим образом. В результате сохраняется взаимное расположение базового и ассоциированного с ним объекта.

Под ограничением подразумевается зависимость между параметрами отдельного объекта или равенство параметра объекта константе. Допускается только такое редактирование объекта, в результате которого не будут нарушены установленные зависимости.

В качестве примеров ограничений, наложенных на геометрические объекты, можно привести вертикальность и горизонтальность отрезков, прямых, стрелок взгляда, линий разреза/сечения. Вертикальность отрезка тождественна равенству X-координат его концов друг другу или равенству угла его наклона 90°. Отрезок, на который наложено такое ограничение, можно перемещать, но нельзя поворачивать, т.е. изменять угол его наклона.

При редактировании параметризованных и ассоциативных объектов перестроение изображения происходит таким образом, что соблюдаются все наложенные на объекты ограничения и сохраняются связи между объектами.

Параметрические изображения могут использоваться как самостоятельно (например, в чертеже, содержащем параметрические виды, в эскизе, содержащем сечение тела), так и для вставки в другие документы (чертежи или фрагменты). Параметрическое изображение, предназначенное для последующей вставки, обязательно должно храниться во фрагменте (файле с расширением frw) и иметь внешние переменные. Подробно о внешних переменных рассказано в разделе 7.1.5.3; порядок вставки параметрических фрагментов описан в разделе 3.8.2.1.


7.2.1.2. Идеология параметризации КОМПАС-3D

Существует два принципиально различных способа получения параметрического изображения.

– Программирование, либо интерактивное формирование изображения непосредственно при рисовании. В ряде CАD-систем можно вычерчивать изображение с одновременным заданием закона построения, который, однако, потом нельзя изменить в случае ошибки (придется удалить все построение и начать его заново), либо такое изменение сильно затруднено.

– Наложение ограничений (связей) на объекты начерченного ранее изображения узла или детали, причем в любом порядке, не придерживаясь какой-либо жесткой последовательности. В этом случае возможно произвольное изменение изображения, не приводящее к необходимости повторных построений с самого начала.

В КОМПАС-3D реализован второй способ параметризации изображений. Такая параметризация называется вариационной.

Работая в чертеже, фрагменте или эскизе трехмерного элемента, можно накладывать различные размерные (линейные, угловые, радиальные и диаметральные) и геометрические (параллельность, перпендикулярность, касание, принадлежность точки к кривой, фиксация точки и т.д.) ограничения и связи на объекты изображения.

При работе в чертеже создание взаимосвязей между объектами — например, выравнивание вершин отрезков — возможно, только если эти объекты принадлежат одному и тому же виду чертежа. О видах чертежа см. раздел 3.6.4.


7.2.1.3. Параметрические возможности КОМПАС-3D

В настоящем разделе перечислены связи и ограничения, накладываемые на объекты вручную или автоматически; объекты, создаваемые как ассоциативные; непараметризуемые объекты.

Чтобы автоматическое наложение связей и ограничений, а также создание ассоциативных объектов было возможно, необходимо, чтобы параметрический режим был включен и настроен (см. раздел 7.2.1.8).

Задание аналитических зависимостей между переменными осуществляется в Окне переменных (о работе с переменными см. раздел 7.1).

Для удобства работы можно включить отображение на экране значков, символизирующих ограничения, наложенные на объекты, а также значков, показывающих количество имеющихся у объектов степеней свободы (см. раздел 7.2.6).

В этом разделе:

7.2.1.3.1. Связи и ограничения

7.2.1.3.2. Ассоциативные объекты

7.2.1.3.3. Непараметризуемые объекты


7.2.1.3.1. Связи и ограничения

КОМПАС-3D предоставляет пользователю возможности наложения следующих связей и ограничений:

– Вертикальность объектов*

– Горизонтальность объектов*

– Коллинеарность отрезков*

– Параллельность объектов*

– Перпендикулярность объектов*

– Выравнивание характерных точек объектов по вертикали*

– Выравнивание характерных точек объектов по горизонтали*

– Зеркальная симметрия*

– Расположение объекта на биссектрисе угла*

– Равенство радиусов дуг и окружностей

– Равенство длин отрезков

– Касание кривых*

– Объединение характерных точек объектов*

– Принадлежность точки кривой*

– Расположение точки на середине кривой*

– Фиксация характерных точек объектов

– Фиксация длины

– Фиксация угла

– Фиксация размера* и редактирование его значения

– Присвоение размеру имени переменной*

Отмеченные «звездочкой» связи и ограничения могут накладываться автоматически при создании объектов определенными способами или с использованием привязок, а также при выполнении следующих построений:

– Скругление

– Фаска

– Сопряжение

– Усечение

– Усечение двумя точками

– Простановка точек вдоль кривой

– Симметрия

Так, например, в результате усечения одного отрезка другим усекаемый отрезок будет связан с усекающим связью точка на кривой.


7.2.1.3.2. Ассоциативные объекты

Предусмотрен ввод ассоциативных геометрических объектов и обозначений. К ним относятся:

– штриховки и заливки;

– обозначения шероховатости;

– обозначения базы;

– марки/позиционные обозначения на линии и с линией-выноской;

– линии-выноски (в том числе в составе других обозначений: допусков формы и расположения, обозначений шероховатости и т.п);

– размеры;

– обозначения центра;

– эквидистанты;

– условные пересечения.


7.2.1.3.3. Непараметризуемые объекты

Не предусмотрена возможность параметризации некоторых сложных объектов:

– прямоугольник;

– многоугольник;

– ломаная;

– кривая Безье;

– контур;

– текст;

– таблица;

– макроэлемент;

– оформление чертежа.

На точки и линии непараметризуемых объектов невозможно наложить связи и ограничения; проставляемые к ним размеры не могут быть ассоциативными.


7.2.1.4. Принципы и приемы наложения связей и ограничений

Ряд ограничений и связей может быть определен без явного ввода числовых значений (например, горизонтальность прямой или условие касания двух кривых). Напротив, такие ограничения, как значения размеров должны выражаться именно числовыми значениями. Некоторые связи и ограничения можно задать в форме выражения (например, указать функцию зависимости параметра объекта от параметров других объектов).

Часть ограничений и взаимосвязей (совпадения точек, параллельность и др.) могут формироваться автоматически при вводе, если пользователь включил такую возможность. Например, совпадение точек и положение точки на кривой параметризуются через выполненную при указании точки привязку (глобальную или локальную, см. раздел 3.1.1), а условия параллельности, перпендикулярности и касания — в соответствующих процессах ввода объектов. В любой момент можно выключить автоматическое формирование ограничений и взаимосвязей.

Дополнительные ограничения и взаимосвязи можно назначить объектам чертежа в любой момент работы над документом.

Ассоциативность объектов (размеров, штриховок и др.) возникает только при их вводе благодаря прямому или косвенному указанию базовых графических объектов. Отдельных команд для задания ассоциативности не существует.

Ограничения накладываются путем выбора их типа и указания параметризуемого объекта.

Например, вы выбрали горизонтальность и указываете отрезки, которые должны быть горизонтальны.

Связи накладываются путем выбора их типа и указания пары взаимосвязанных объектов.

Например, вы выбрали параллельность и указываете пары отрезков, которые должны быть параллельны.

При этом запоминаются только те связи, которые были установлены явно (либо путем обращения к соответствующей команде параметризации, либо путем рисования в параметрическом режиме). Обратите внимание на то, что новые связи, которые вытекают из нескольких ранее наложенных связей, автоматически не возникают, даже если они кажутся совершенно очевидными.

Например, вы начертили три отрезка и установили параллельность первого отрезка второму, а второго — третьему. При этом связь между первым и третьим отрезками является опосредованной — она осуществляется через второй отрезок. Сразу после удаления второго отрезка первый и третий будут параллельны, однако редактироваться они будут уже независимо друг от друга, т.к. прямой связи между ними нет.

Еще один способ наложения ограничений — фиксация ассоциативного размера. Если размер ассоциативный, то при помощи соответствующей команды его можно зафиксировать. Когда размер зафиксирован, его значение остается постоянным при любом перестроении объектов, составляющих изображение. Значение размера всегда характеризует какой-либо геометрический параметр. Например, значение ассоциативного линейного размера соответствует расстоянию между характерными точками объектов (или одного объекта), а значение ассоциативного радиального размера — радиусу базовой окружности или дуги окружности. Таким образом, фиксация размера позволяет установить равенство константе какого-либо параметра объекта. Значение каждого конкретного фиксированного размера можно изменить при помощи специальной команды, но нельзя изменить путем редактирования самих объектов.

Если зависимость между параметрами объектов требуется задать в аналитической форме, то сначала нужно создать переменные, соответствующие зависимым параметрам. Затем можно вводить выражения с участием созданных переменных.

Для создания переменной следует проставить ассоциативный размер, характеризующий ограничиваемый параметр (например, для длины отрезка это будет линейный размер между концами отрезка) и при помощи соответствующей команды присвоить этому размеру имя переменной.

Присвоив имя переменной фиксированному размеру, можно использовать значение этого размера в выражениях.

Ассоциативный размер без фиксации является информационным. Значение информационного размера, в противоположность фиксированному, зависит от размеров и положения геометрических объектов. Чтобы использовать в расчетах значение информационного размера, ему следует присвоить имя переменной.

Подробнее о фиксированных и информационных размерах см. раздел 7.2.1.10.

Ввод выражений осуществляется в Окне переменных.

Порядок снятия связей и ограничений рассмотрен в разделе 7.2.3.


7.2.1.5. Рекомендации по использованию параметрических возможностей

7.2.1.5. Рекомендации по использованию
параметрических возможностей

Наличие параметрических возможностей не накладывает каких-либо ограничений на стиль работы при создании чертежей. Вы можете выбирать, с каким именно изображением вам удобнее работать — с параметризованным или обычным. При необходимости в одном документе могут сочетаться параметризованные и непараметризованные объекты. Кроме того, можно без каких-либо проблем переходить от одного представления геометрии к другому, например, накладывая параметрические ограничения на созданный ранее обычный чертеж или удаляя ограничения, наложенные на созданное ранее параметрическое изображение.

К применению параметрических возможностей при работе с чертежной документацией следует подходить взвешенно, оценивая степень реальной необходимости полной параметризации того или иного чертежа.

Можно дать следующие общие рекомендации, связанные с параметризацией чертежей.

– Имеет смысл параметризовать чертежи деталей, при модификации которых изменяются только размеры и не меняется топология. Таким образом, однажды созданное параметрическое изображение детали может быть быстро перестроено простым изменением значений размеров.

– Если выполняется новая разработка, оцените, будет ли она применяться в будущем как прототип. Если нет, тогда параметризация чертежа может не выполняться, так как отпадает необходимость в последующей быстрой модификации. Если же новая деталь будет часто использоваться как стандартный прототип, параметризация ее чертежа или создание параметрического фрагмента имеет смысл.

– Скорее всего не будет оправданной полная параметризация сложных сборочных чертежей, так как в этом случае велик объем работы по вводу ограничений и управляющих размеров.

– Попробуйте оценить на конкретных примерах чертежей, типовых для вашей организации, какие преимущества дает применение параметризации. В дальнейшем учитывайте полученные результаты при новом проектировании или переработке имеющейся чертежной документации.


7.2.1.6. Особенности работы с параметрическими объектами

При работе с параметрическими чертежами и фрагментами может оказаться полезным знание следующих особенностей.

– Чем больше ограничений наложено на объекты, составляющие изображение детали, тем меньше вероятность сильных разбросов при пересчетах. В большинстве случаев рекомендуется полное определение изображения, т.е. лишение составляющих его объектов всех степеней свобод. В качестве вспомогательных ограничений применяйте фиксацию точек, назначение горизонтальности или вертикальности отрезков, простановку дополнительных размеров. Для удобства работы можно включить отображение на экране степеней свободы объектов (см. раздел 7.2.6.2).

– Рекомендуется не выполнять «резких движений» при редактировании параметрического изображения, лучший стиль при работе с ним — постепенность. Например, не следует слишком сильно изменять значение размера (было 5 градусов, а стало 120). Такие значительные изменения лучше выполнять постепенно, в несколько приемов. То же самое можно сказать и о редактировании перетаскиванием точек — не следует сдвигать объект или точку сразу на очень большое расстояние, лучше выполнить такое перемещение в несколько этапов.

– Помните, что время обработки параметрического изображения существенно зависит от насыщенности чертежа или фрагмента параметризованными объектами. Однако полностью определенное изображение обрабатывается быстрее, чем недоопределенное.


7.2.1.7. Параметрический режим

Параметрическим режимом называется такой режим создания и редактирования геометрических объектов и объектов оформления, в котором параметрические связи и ограничения накладываются автоматически. При этом тип накладываемых связей и ограничений определяется в процессе построения благодаря последовательности выполнения команды построения объекта или осуществлению привязки (в том числе локальной).

Вот несколько примеров работы в параметрическом режиме.

– Вычерчивание отрезка, параллельного другому отрезку, с помощью команды Параллельный отрезок вызовет автоматическое возникновение соответствующей связи — параллельности отрезков.

– Если при вычерчивании окружности ее центр будет привязан к концу отрезка, то соответствующая связь — совпадение точек — будет сформирована автоматически.

– Вычерчивание вертикального отрезка приводит к наложению на него соответствующего ограничения — вертикальности.

– Построение горизонтальной линии разреза с выравниванием по центру окружности приводит к наложению на линию разреза ограничения горизонтальность и формированию связи выравнивание точек по горизонтали между первым штрихом линии и центром окружности.

– Простановка обозначения шероховатости приводит к созданию ассоциативного знака шероховатости.

По умолчанию во фрагментах и чертежах параметрический режим отключен, а в эскизах трехмерных элементов — включен.

Рекомендуется включать параметрический режим при оформлении чертежей, содержащих ассоциативные виды. Это позволит создавать ассоциативные объекты оформления (размеры, обозначения центра, шероховатости и т.п.), которые будут «следовать» за графическими объектами при перестроении последних в результате редактирования модели.


7.2.1.8. Включение и настройка параметрического режима

Чтобы включить параметрический режим в текущем графическом документе, нажмите кнопку Параметрический режим на панели Текущее состояние. По умолчанию после этого включается ассоциативность всех объектов, параметризация всех построений и фиксация размеров.

Для изменения умолчательной настройки параметрического режима используется диалог, вызываемый командой Сервис — Параметры... — Текущий чертеж (фрагмент) — Параметризация (см. раздел 9.2.6.22).

Включение параметрического режима не имеет смысла, если в диалоге настройки отключены все опции в группах Ассоциировать при вводе: и Параметризовать:. Связи и ограничения в этом случае не будут накладываться, т.е. построения будут выполняться так, как если бы параметрический режим был отключен.

Настройка параметрического режима хранится в самом документе и не изменяется при его передаче на другое рабочее место.

Если вы создаете большинство графических документов в параметрическом режиме, то выполнение соответствующей настройки в каждом документе нерационально. В этом случае можно сделать так, чтобы во всех новых графических документах по умолчанию был включен параметрический режим.

Для этого вызовите команду Сервис — Параметры... — Новые документы — Графический документ — Параметризация и выполните необходимые настройки.


7.2.1.9. Общий порядок действий при построении параметрического изображения

7.2.1.9. Общий порядок действий
при построении параметрического изображения

Если параметрический режим включен (см. раздел 7.2.1.7), то отмеченные в диалоге настройки параметризации связи и ограничения формируются системой автоматически при вводе объектов.

Никаких специальных действий при создании объектов выполнять не нужно. Однако следует обязательно учитывать, что совпадения точек объектов параметризуются через выполненные при указании этих точек привязки. При этом не имеет значения, какая привязка действовала — глобальная или локальная. Точка, указанная просто «неподалеку» от другой точки, без выполнения привязки, параметризоваться не будет. Совпадение точек параметризуется и при перетаскивании характерных точек объектов (тоже через выполненную привязку).

Под словом «точка» здесь понимается не точка — геометрический объект, а любая задаваемая характерная точка объекта при его построении (начальная и конечная точки отрезка, центр окружности или эллипса и т.д.)

Ассоциативные объекты оформления создаются в обычном порядке.

Различные дополнительные взаимосвязи и ограничения можно назначить объектам в любой момент, когда это потребуется.

Задание аналитических зависимостей между переменными, связанными с размерам, производится в Окне переменных. Если размеры принадлежат текущему виду чертежа, то этот вид автоматически перестраивается сразу после изменения значений переменных в Окне переменных. Для перестроения видов, не являющихся текущими, после редактирования переменных или выражений необходимо вызвать команду Вид — Перестроить или нажать клавишу <F5>.


7.2.1.10. Управляющие и информационные размеры. Размеры с переменными

7.2.1.10. Управляющие и информационные размеры.
Размеры с переменными

Ассоциативные размеры могут быть двух типов: управляющие и информационные. От типа размера зависит, влияет размер на геометрический объект или, наоборот, объект влияет на размер.

Управляющий размер — размер, который управляет геометрическим объектом.

Значение управляющего размера может быть изменено пользователем путем ввода числа, константы или выражения (в двух последних случаях для размера должна быть создана переменная). После этого геометрический объект, к которому проставлен размер, перестраивается так, чтобы удовлетворять новому значению размера.

Чтобы размер был управляющим, он должен быть зафиксирован, т.е. иметь ограничение фиксированный размер. Признаком фиксации размера является прямоугольная рамка вокруг его значения.

Фиксация размеров может производиться автоматически при их простановке в параметрическом режиме. Для этого при настройке параметрического режима (см. раздел 7.2.1.8) должны быть включены опции Ассоциировать при вводе размеры и Фиксировать размеры.

Кроме того, зафиксировать размеры можно с помощью команды Зафиксировать размер (см. раздел 7.2.2.17).

Объект, к которому проставлен зафиксированный размер, можно редактировать только так, чтобы значение этого размера оставалось постоянным. Например, если к отрезку проставлен размер, фиксирующий его длину, то отрезок можно только перемещать и поворачивать, но нельзя изменять его длину.

Информационный размер — размер, которым управляет геометрический объект.

Ввод значения или выражения для информационного размера невозможен. Геометрический объект, к которому проставлен информационный размер, можно редактировать произвольным образом. После перестроения геометрического объекта происходит перестроение размера и пересчет его значения. Ограничения фиксированный размер у информационного размера нет.

При редактировании геометрических объектов учитываются не только проставленные к ним размеры, но и наложенные на них параметрические связи и ограничения.

Любой управляющий размер можно сделать информационным двумя способами:

– удалить у него ограничение фиксированный размер, воспользовавшись командой Показать/удалить ограничения (см. раздел 7.2.3.1),

– включить опцию Информационный размер в диалоге установки значения размера (см. раздел 7.2.2.20).

Информационный размер можно сделать управляющим двумя способами:

– воспользоваться командой Зафиксировать размер (см. раздел 7.2.2.17),

– отключить опцию Информационный размер в диалоге установки значения размера.

Однако, не каждый информационный размер можно сделать управляющим, т.е.зафиксировать его. Невозможность фиксации размера может быть обусловлена:

– геометрическими связями между объектами, например: расстояние между диагонально противоположными вершинами прямоугольника зависит от длин его сторон, поэтому, если длины сторон прямоугольника уже зафиксированы, то длину его диагонали зафиксировать невозможно.

– параметрическими связями и ограничениями, например:

• угол между двумя отрезками, на которые наложена связь перпендикулярность, всегда равняется 90°, поэтому угол между этими отрезками зафиксировать невозможно,

• диаметр окружности, сопрягающей параллельные отрезки, всегда равняется расстоянию между ними, поэтому, если это расстояние уже зафиксировано, диаметр окружности зафиксировать невозможно.

Невозможно также зафиксировать избыточный размер.

При попытке зафиксировать размер, который может быть только информационным, выдается соответствующее сообщение.

Как для информационного, так и для управляющего размера можно создать переменную. Для этого необходимо ввести ее имя в диалоге установки значения размера (см. раздел 7.2.2.20).

Размер, для которого создана переменная, имеет ограничение размер с переменной. Удаление этого ограничения приводит к удалению переменной.


7.2.2. Наложение связей и ограничений

7.2. Параметризация геометрических объектов

7.2.2. Наложение связей и ограничений

В описании каждой команды указаны ее возможности, кнопка для вызова команды, порядок указания объектов параметризации и механизм действия команды при отсутствии других связей и ограничений. Если связь или ограничение, накладываемые при помощи этой команды, могут возникать автоматически в параметрическом режиме, в описании команды указана соответствующая опция настройки параметрического режима.

Если объекты, участвующие в выполнении команды параметризации, уже имеют связи и ограничения, то новая связь или ограничение накладываются с учетом уже существующих. При этом перестроение изображения происходит таким образом, что соблюдаются все связи и ограничения, а изменение параметров объектов минимально.

Связи и ограничения, противоречащие уже существующим, накладываться не будут.

Команды наложения связей и ограничений сгруппированы в меню Инструменты — Параметризация, а кнопки для вызова команд — на панели Параметризация (рис. 7.2.1).

Рис. 7.2.1. Панель Параметризация

Обратите внимание на то, что некоторые объекты параметризовать невозможно (см. раздел 7.2.1.3.3).

При необходимости вы можете включить и настроить отображение на экране символов, показывающих связи и ограничения, наложенные на графические объекты (см. раздел 7.2.6).

В этом разделе:

7.2.2.1. Горизонталь

7.2.2.2. Вертикаль

7.2.2.3. Выравнивание точек по горизонтали

7.2.2.3.1. Выбор точки для выравнивания из нескольких совпадающих

7.2.2.4. Выравнивание точек по вертикали

7.2.2.5. Объединение точек

7.2.2.6. Точка на кривой

7.2.2.7. Точка на середине кривой

7.2.2.8. Симметрия двух точек

7.2.2.9. Параллельность

7.2.2.10. Перпендикулярность

7.2.2.11. Коллинеарность

7.2.2.12. Биссектриса

7.2.2.13. Касание

7.2.2.14. Равенство радиусов

7.2.2.15. Равенство длин

7.2.2.16. Фиксация точки

7.2.2.17. Фиксация размера

7.2.2.18. Фиксация длины

7.2.2.19. Фиксация угла

7.2.2.20. Установка значения размера

7.2.2.21. Параметризация объектов


7.2.2.1. Горизонталь

Чтобы преобразовать наклонные объекты (отрезки, стрелки взгляда и др.) в горизонтальные, вызовите команду Горизонталь.

Последовательно указывайте объекты, которые необходимо преобразовать.

При преобразовании отрезка в горизонтальный остается неизменной его проекция на горизонтальную ось, т.е. отрезок поворачивается с сохранением X-координат его концов. В результате длина наклонного отрезка уменьшается, длина горизонтального не меняется. Вертикальный отрезок нельзя преобразовать в горизонтальный, т.к. при этом он вырождается в отрезок нулевой длины.

Горизонтальным считается объект, параллельный оси абсцисс системы координат текущего вида. Поэтому, если вы наложите ограничение горизонтальность на объект, расположенный в виде, система координат которого повернута относительно абсолютной системы координат, этот объект не будет параллелен горизонтальным сторонам листа (о видах чертежа см. раздел 3.6.4).

Данное ограничение — горизонтальность — может автоматически возникать в параметрическом режиме. Для этого при настройке параметрического режима (см. 7.2.1.7) должна быть включена опция Параметризовать горизонтальность и вертикальность. Ограничение будет возникать при построении (любым способом) горизонтального объекта. Например, при указании второй точки отрезка (или прямой) можно воспользоваться привязкой Выравнивание к первой точке, или набрать одинаковые Y-координаты его характерных точек в полях Панели свойств, или ввести нулевой угол наклона. Даже если при построении объекта его горизонтальность не была задана явно, но создан горизонтальный объект (например, новый отрезок проведен параллельно горизонтальному объекту), на него будет наложено ограничение горизонтальность.


7.2.2.2. Вертикаль

Чтобы преобразовать наклонные объекты (отрезки, стрелки взгляда и др.) в вертикальные, вызовите команду Вертикаль.

Последовательно указывайте объекты, которые необходимо преобразовать.

При преобразовании отрезка в вертикальный остается неизменной его проекция на вертикальную ось, т.е. отрезок поворачивается с сохранением Y-координат его концов. В результате длина наклонного отрезка уменьшается, длина вертикального не меняется. Горизонтальный отрезок нельзя преобразовать в вертикальный, т.к. при этом он вырождается в отрезок нулевой длины.

Вертикальным считается объект, параллельный оси ординат системы координат текущего вида. Поэтому, если вы наложите ограничение вертикальность на объект, расположенный в виде, система координат которого повернута относительно абсолютной системы координат, этот объект не будет параллелен вертикальным сторонам листа (о видах чертежа см. раздел 3.6.4).

Данное ограничение — вертикальность — может автоматически возникать при построении объектов в параметрическом режиме. Для этого при настройке параметрического режима (см. раздел 7.2.1.7) должна быть включена опция Параметризовать горизонтальность и вертикальность. Ограничение будет возникать при построении (любым способом) вертикального объекта.


7.2.2.3. Выравнивание точек по горизонтали

Чтобы выровнять по горизонтали характерные точки геометрических объектов, вызовите команду Выровнять по горизонтали.

Указывайте попарно характерные точки геометрических объектов для выравнивания.

Для выполнения команд:

– Выровнять точки по горизонтали,

– Выровнять точки по вертикали,

– Объединить точки,

– Точка на середине кривой,

– Точка на кривой,

– Симметрия двух точек

можно указать только те точки, которые принадлежат текущему виду (об изменении состояния вида см. раздел 3.6.5.2).

В этом разделе:

7.2.2.3.1. Выбор точки для выравнивания из нескольких совпадающих


7.2.2.3.1. Выбор точки для выравнивания из нескольких совпадающих

Иногда точка, которую требуется указать для выравнивания, совпадает с характерной точкой другого объекта и выбрать точно ее невозможно, т.к. происходит привязка к точке другого объекта. В этом случае вы можете вначале указать графический объект, которому принадлежит параметризуемая точка, а затем — саму точку.

Для этого нажмите кнопку Указать объект.

Укажите объект и его характерную точку.

Указание одной из совпадающих точек при выполнении команд Выравнивание точек по вертикали и Совпадение точек производится аналогично.


7.2.2.4. Выравнивание точек по вертикали

Чтобы выровнять по вертикали характерные точки геометрических объектов, вызовите команду Выровнять по вертикали.

Указывайте попарно характерные точки геометрических объектов для выравнивания.

Связи выравнивание точек по горизонтали и выравнивание точек по вертикали могут автоматически возникать при построении объектов в параметрическом режиме. Для этого при настройке параметрического режима (см. раздел 7.2.1.7) должны быть включены опции Привязки и Привязку Выравнивание. Связи будут возникать при вводе характерной точки объекта с использованием привязки Выравнивание к другой характерной точке.


7.2.2.5. Объединение точек

Чтобы привязать характерные точки геометрических объектов друг к другу, вызовите команду Объединить точки.

Указывайте попарно характерные точки объектов для объединения.

Данная связь — совпадение точек — может автоматически возникать при построении объектов в параметрическом режиме. Для этого при настройке параметрического режима (см. раздел 7.2.1.7) должна быть включена опция Привязки. Связь будет возникать при вводе характерной точки объекта с использованием привязки к другой характерной точке, а также при вводе последовательности объектов с помощью команды Непрерывный ввод (см. раздел 3.2.10).


7.2.2.6. Точка на кривой

Чтобы привязать характерную точку объекта к другой кривой, вызовите команду Точка на кривой.

Укажите кривую, на которой должна располагаться точка, а затем — точку.

Данная связь — принадлежность точки кривой — может автоматически возникать при построении объектов в параметрическом режиме. Для этого при настройке параметрического режима (см. раздел 7.2.1.7) должна быть включена опция Привязки. Связь будет возникать при вводе характерной точки объекта с использованием привязки Точка на кривой, при построении окружности с помощью команды Окружность с центром на объекте (см. раздел 3.2.5.3), а также при простановке точек на кривой с помощью команд Точки по кривой (см. раздел 3.2.2.2) и Точка на заданном расстоянии (см. раздел 3.2.2.5).


7.2.2.7. Точка на середине кривой

Чтобы привязать характерную точку объекта к середине другой кривой, вызовите команду Точка на середине кривой.

Укажите кривую (отрезок или дугу окружности), на середине которой должна располагаться точка, а затем — точку.

Данная связь — точка на середине кривой — может автоматически возникать при построении объектов в параметрическом режиме. Для этого при настройке параметрического режима (см. раздел 7.2.1.7) должна быть включена опция Привязки. Связь будет возникать при вводе характерной точки объекта с помощью привязки Середина.


7.2.2.8. Симметрия двух точек

Чтобы установить симметрию характерных точек объектов относительно оси (зеркальную симметрию), вызовите команду Симметрия двух точек.

Укажите ось симметрии, а затем — пару характерных точек объектов, которые должны быть симметричны.

Данная связь — зеркальная симметрия — может автоматически возникать при построении объектов в параметрическом режиме. Для этого при настройке параметрического режима должна быть включена опция Симметрию. Связь будет возникать при выполнении команды Симметрия (см. раздел 3.5.4.3), если в качестве оси симметрии указан существующий отрезок (а не две точки, принадлежащие оси симметрии).


7.2.2.9. Параллельность

Чтобы установить параллельность объектов (отрезков, стрелок взгляда и др.) вызовите команду Параллельно.

Указывайте попарно объекты, параллельность которых требуется установить.

Для выполнения команд:

– Параллельность,

– Перпендикулярность,

– Коллинеарность,

– Биссектриса,

– Касание,

– Равенство радиусов,

– Равенство длин.

можно указывать только те объекты, которые принадлежат одному и тому же виду (о работе с видами чертежа см. раздел 3.6.5).

Данная связь — параллельность — может автоматически возникать при построении объектов в параметрическом режиме. Для этого при настройке параметрического режима (см. раздел 7.2.1.7) должна быть включена опция Параллельность. Связь будет возникать при создании прямых и отрезков с помощью команд Параллельная прямая (см. раздел 3.2.3.4) и Параллельный отрезок (см. раздел 3.2.4.2).


7.2.2.10. Перпендикулярность

Чтобы установить перпендикулярность объектов (отрезков, стрелок взгляда и др.), вызовите команду Перпендикулярно.

Указывайте попарно объекты, перпендикулярность которых требуется установить.

Данная связь — перпендикулярность — может автоматически возникать при построении объектов в параметрическом режиме. Для этого при настройке параметрического режима (см. раздел 7.2.1.7) должна быть включена опция Перпендикулярность. Связь будет возникать при создании прямых и отрезков, перпендикулярных прямым и отрезкам, с помощью команд Перпендикулярная прямая (см. раздел 3.2.3.5) и Перпендикулярный отрезок (см. раздел 3.2.4.3).


7.2.2.11. Коллинеарность

Чтобы установить коллинеарность отрезков, вызовите команду Коллинеарно.

Указывайте попарно отрезки, которые должны лежать на одной прямой.

Данная связь — коллинеарность — может автоматически возникать при построении объектов в параметрическом режиме. Для этого при настройке параметрического режима (см. раздел 7.2.1.7) должна быть включена опция Привязки. Связь будет возникать при разделении отрезка на две части с помощью команды Усечь кривую двумя точками (см. раздел 3.5.7.2).


7.2.2.12. Биссектриса

Чтобы расположить объект (отрезок, стрелку взгляда и др.) на биссектрисе угла, образованного двумя прямолинейными объектами, вызовите команду Биссектриса.

Указывайте по три объекта в следующем порядке.

Сначала укажите два объекта, образующие угол, с биссектрисой которого должна быть установлена связь. На экране появляется фантом биссектрисы угла. Варианты биссектрис поочередно отображаются при нажатии кнопок Следующий объект и Предыдущий объект Панели специального управления.

После того как на экране появится нужный вариант биссектрисы, укажите размещаемый объект.

Если первые два объекта параллельны друг другу, то третий объект располагается посередине между ними.

Данная связь — биссектриса — может автоматически возникать при построении объектов в параметрическом режиме. Для этого при настройке параметрического режима (см. раздел 9.2.6.22) должна быть включена опция Биссектрису. Связь будет возникать при построении прямой с помощью команды Биссектриса (см. раздел 3.2.3.9), автоосевой по двум отрезкам с помощью команды Автоосевая (см. раздел 3.3.7.16), отрезка на биссектрисе угла с помощью команды Линия (см. раздел 3.2.11.2.6).


7.2.2.13. Касание

Чтобы установить касание кривых, вызовите команду Касание.

Укажите первую и вторую кривые, касание которых требуется установить.

Данная связь — касание — может автоматически возникать при построении объектов в параметрическом режиме. Для этого при настройке параметрического режима (см. раздел 7.2.1.7) должна быть включена опция Касание. Связь будет возникать при построении (любым способом) касательных объектов.

При наложении связи касание на NURBS обратите внимание на следующие особенности:

– точкой касания NURBS с другой кривой является точка, в которой NURBS был указан,

– если требуется, чтобы точкой касания была крайняя точка NURBS, до наложения связи следует разместить эту точку на кривой, которой должен касаться NURBS (наложение связи принадлежность точки кривой не обязательно).


7.2.2.14. Равенство радиусов

Чтобы сделать радиусы указанных дуг и/или окружностей равными, вызовите команду Равенство радиусов.

Указывайте попарно дуги и/или окружности для выравнивания их радиусов.


7.2.2.15. Равенство длин

Чтобы сделать длины указанных отрезков равными, вызовите команду Равенство длин.

Указывайте попарно отрезки для выравнивания их длин.


7.2.2.16. Фиксация точки

Чтобы зафиксировать координаты характерных точек геометрических объектов, вызовите команду Зафиксировать точку.

Указывайте характерные точки геометрических объектов для их фиксации.

Данная связь — фиксированная точка — может автоматически возникать при построении объектов в параметрическом режиме. Для этого при настройке параметрического режима (см. раздел 7.2.1.7) должна быть включена опция Привязки. Связь будет возникать при вводе характерной точки объекта, совпадающей с началом системы координат, с использованием привязки Ближайшая точка.


7.2.2.17. Фиксация размера

Чтобы зафиксировать значение ассоциативного размера, вызовите команду Зафиксировать размер.

Указывайте размеры для их фиксации. При успешной фиксации размерная надпись заключается в прямоугольную рамку (она отображается на экране, если в текущем окне включен показ ограничений, см раздел 7.2.6). Эта рамка на печать не выводится.

Фиксация возможна для размеров всех типов, за исключением следующих:

– размер дуги,

– размер высоты для вида сверху с линией-выноской,

– размер высоты непосредственно на изображении,

– линейный размер с обрывом.

Для линейного размера с обрывом возможна автоматическая фиксация, если он проставлен к отрезку и осевой линии. Подробнее см. раздел 7.2.7.6.

Зафиксировать неассоциативные или избыточные размеры невозможно. Избыточным является размер, значение которого можно вычислить — либо исходя из существующих в документе выражений, либо на основе проставленных ранее управляющих размеров.

Фиксация размеров может производиться автоматически при их простановке в параметрическом режиме. Для этого при настройке параметрического режима (см раздел 7.2.1.7) должны быть включены опции Ассоциировать при вводе размеры и Фиксировать размеры. Связь будет возникать при простановке ассоциативных неизбыточных размеров.

При автоматической фиксации размеров им также присваиваются имена переменных.


7.2.2.18. Фиксация длины

Чтобы зафиксировать длину отрезка или осевой линии, вызовите команду Зафиксировать длину.

Указывайте объекты для фиксации их длин.

Фиксация длины автоосевой может производиться автоматически при ее построении в параметрическом режиме. Для этого при настройке параметрического режима (см раздел 9.2.6.22) должна быть включена опция Фиксировать длину автоосевой.


7.2.2.19. Фиксация угла

Чтобы зафиксировать угол наклона объекта (отрезка, осевой линии, линии обрыва и др.), вызовите команду Зафиксировать угол. Во фрагменте угол наклона объекта фиксируется в абсолютной системе координат, а в чертеже — в системе координат вида, в котором находится объект.

Указывайте объекты, углы наклона которых требуется зафиксировать.

Данная связь — фиксированный угол — может автоматически возникать при построении объектов в параметрическом режиме. Для этого при настройке параметрического режима (см. раздел 7.2.1.7) должны быть включены опции Привязки и Угловую привязку. Связь будет возникать при вводе характерной точки объекта с использованием Угловой привязки.


7.2.2.20. Установка значения размера

Ввод значения управляющего размера выполняется в диалоге установки значения размера (рис. 7.2.2). Этот диалог также позволяет создать переменную, соответствующую размеру. Данная переменная используется для управления значением размера.

Рис. 7.2.2. Диалог установки значения размера: а) линейного, диаметрального или радиального; б) углового
а) | б)

Диалог установки значения размера появляется автоматически при простановке размера. Кроме того данный диалог можно вызвать следующими способами:

– командой Установить значение размера,

– двойным щелчком мышью на размерной надписи размера.

Обратите внимание на то, что двойной щелчок мышью на любой другой части размера (например, на размерной линии) запускает процесс редактирования размера.

Чтобы задать значение размера, выполните следующие действия.

Для задания значения линейного, диаметрального или радиального размера в поле Выражение укажите способ получения значения: число, константу или выражение для вычисления значения (синтаксис выражений описан в разделе 7.1.3.3.1).

Значение углового размера можно задать двумя способами.

Для задания значения в формате ХХ°ХХ'ХХ" включите опцию Градусы и введите числовые значения в поля Градусы, Минуты и Секунды. Обратите внимание на то, что ни одно из полей не может быть оставлено пустым. Если значение должно быть нулевым, введите в поле ноль.

Для задания значения в формате ХХ,ХХХ° используйте поле Выражение, включив соответствующую ему опцию. Варианты задания значения в этом поле указаны выше.

Заданное значение размера одновременно является значением переменной, соответствующей этому размеру.

Чтобы создать для размера переменную, введите ее имя в поле Переменная. По умолчанию в диалоге предлагается имя переменной, сформированное по шаблону «vN», где N — порядковый номер переменной в списке переменных документа. При необходимости вы можете отредактировать имя переменной. Оно может содержать буквы латинского алфавита (различаются символы верхнего и нижнего регистра), арабские цифры и символы подчеркивания («_»). Длина имени переменной не более 512 символов. Первый символ в имени переменной — буква или подчеркивание.

Поле Комментарий позволяет задать комментарий к переменной.

Если требуется создать размер без переменной, удалите имя переменной, указанное в поле Переменная. В этом случае переменная не будет создана.

Опция Информационный размер позволяет выбрать тип размера — информационный или управляющий. Включенное состояние опции соответствует информационному размеру. Значение размера данного типа вручную задать нельзя. Если опция отключена, то размер управляющий. Значение размера данного типа задается, как описано выше. Подробнее о управляющих и информационных размерах см. раздел 7.2.1.10.

При создании размера без переменной или информационного размера обратите внимание на следующую особенность.

Если значение размера задано константой или выражением, то после завершения работы в диалоге кнопкой ОК обозначение этой константы/выражение не сохраняется. Содержимое поля Выражение заменяется вычисленным значением размера, которое отображается в поле при следующем открытии диалога.

Для размера без переменной не сохраняется также заданный комментарий (поле Комментарий становится пустым).

После выполнения всех необходимых действий в диалоге нажмите кнопку ОК. Все произведенные изменения будут сохранены.

Значение, заданное для размера, передается в документ, а вся информация о созданной переменной — в Окно переменных (см. раздел 7.1.1.3).

Переменная отображается в размерной надписи размера при включенном режиме отображения ограничений (см. раздел 7.2.6.1). Особенности отображения размеров с переменными описаны в разделе 7.2.6.1.1.

При завершении работы в диалоге кнопкой ОК могут возникнуть следующие проблемы:

– фиксация или применение нового значения размера невозможно, например, из-за наложенных ограничений,

– размер может быть только информационным, но в диалоге не включена опция Информационный размер.

В случае возникновения одной из указанных проблем на экране появляется сообщение с описанием проблемы. При этом диалог установки значения размера остается открытым.


7.2.2.21. Параметризация объектов

Чтобы полуавтоматически наложить некоторые типы связей и ограничений на геометрические объекты, выделите их (о способах выделения объектов см. раздел 3.1.2) и вызовите команду Параметризовать объекты.

На экране появится диалог настройки параметризации (рис. 7.2.3). Элементы управления этого диалога представлены в таблице 7.2.1.

Автоматическая параметризация объектов в ассоциативных видах, сохраняющих связь с моделями, невозможна.

Рис. 7.2.3. Диалог настройки параметризации выделенных объектов

Табл. 7.2.1. Элементы управления диалога настройки параметризации объектов

Элемент

Описание

Совпадение точек
Горизонтальность
Вертикальность
Параллельность
Перпендикулярность

Включите опции, соответствующие типам связей и ограничений, которые требуется наложить на выделенные объекты.

Допуск, мм

Поле ввода допуска для совпадения точек.

Если расстояние между характерными точками параметризуемых объектов меньше заданного допуска, то эти точки будут объединены1.

Угловой допуск, гр

Поле ввода углового допуска.
Если параметризуемые отрезки или прямые отклонены от горизонтали или вертикали на угол, меньший углового допуска и включены опции Горизонтальность и Вертикальность, то эти объекты станут соответственно горизонтальными или вертикальными1.

Если параметризуемые отрезки или прямые параллельны или перпендикулярны с угловым допуском, меньшим указанного, и включены опции Параллельность и Перпендикулярность, то эти объекты станут соответственно параллельными или перпендикулярными1.
  1. Произойдет автоматическое выполнение соответствующей команды наложения на объекты связей и ограничений.

При большом количестве выделенных объектов время выполнения команды может быть достаточно длительным.


7.2.3. Просмотр и удаление связей и ограничений

7.2. Параметризация геометрических объектов

7.2.3. Просмотр и удаление связей и ограничений

Перед вызовом команд просмотра и удаления связей и ограничений необходимо выделить объект, связи и ограничения которого требуется просмотреть или удалить. О способах выделения объектов см. раздел 3.1.2.

Если выделенный объект не имеет связей и ограничений, команды их просмотра и удаления будут недоступны.

Перед вызовом команды удаления всех ограничений можно выделить сразу несколько объектов.

Вы можете включить визуализацию ограничений, наложенных на графические объекты (см. раздел 7.2.6). В этом режиме на экране отображаются специальные значки, показывающие ограничения объектов.

В этом разделе:

7.2.3.1. Показать/удалить ограничения

7.2.3.2. Удалить все ограничения


7.2.3.1. Показать/удалить ограничения

Чтобы просмотреть список связей и ограничений, наложенных на выбранный объект, и удалить любое из них, вызовите команду Показать/удалить ограничения.

На Панели свойств появится список связей и ограничений, которые имеет выделенный объект.

Если выделить в списке какую-либо связь, щелкнув по ее названию мышью, то объект, с которым эта связь осуществляется, будет подсвечен. Таким способом вы можете контролировать выбор нужной связи из списка однотипных связей.

Чтобы удалить выделенную связь или ограничение, нажмите кнопку Удалить.

Чтобы перейти к просмотру связей и ограничений, наложенных на другой параметризованный объект, укажите его мышью в окне документа.


7.2.3.2. Удалить все ограничения

Чтобы удалить все связи и ограничения, наложенные на выделенные объекты, вызовите команду Удалить все ограничения.

В результате выбранные объекты освободятся от всех связей и ограничений.


7.2.4. Особенности работы с ассоциативными обозначениями

7.2. Параметризация геометрических объектов

7.2.4. Особенности работы с ассоциативными обозначениями

Обозначения могут быть ассоциированы не только с геометрическими объектами, но и с другими обозначениями. Так, например, обозначение базы, шероховатости или линию-выноску можно связать с размером, причем можно выбрать нужный элемент размера: размерную или выносную линию, выноску, полку.

Ассоциативное обозначение имеет ограничение — ассоциативность, которое связывает его с базовым объектом. Например, обозначение базы связано — ассоциировано — с отрезком, изображающим базовую поверхность.

Ограничение ассоциативность возникает автоматически при создании обозначения в параметрическом режиме. Наложение этого ограничения вручную невозможно. Поэтому, если ограничение было удалено или если требуется ассоциировать обозначение с другим объектом, необходимо войти в режим редактирования обозначения, указать нужный базовый объект, после чего подтвердить редактирование.

При удалении или разрушении объекта все ассоциированные с ним обозначения удаляются. Поэтому будьте внимательны, преобразуя размер на полке в размер без полки: если с линией-выноской или полкой были ассоциированы обозначения, они исчезнут.

Обратите внимание на следующие особенности некоторых ассоциативных обозначений.

– Обозначение базы, допуска формы

• Если ответвление обозначения ассоциировано с размерной линией размера, то оно ориентировано вдоль этой линии и располагается снаружи от нее. В связи с этим ассоциированное с размерной линией ответвление обозначения допуска формы сразу после создания имеет два сегмента, один из которых лежит на продолжении размерной линии. Преобразовать эти два сегмента в один (т.е. удалить вершину между ними) невозможно, пока обозначение остается ассоциативным.

• Если ответвление обозначения ассоциировано с другим объектом, то оно может быть ориентировано произвольно по отношению к нему.

– Линия-выноска (в том числе в составе других обозначений)
Ассоциированы с объектами могут быть как все ответвления линии-выноски, таки и лишь некоторые. Чтобы ответвление было ассоциативным или неассоциативным, включите или выключите параметрический режим перед созданием этого ответвления.

– Проекционные обозначения
Проекционные обозначения (т.е. обозначения, переданные в чертеж из модели, см. раздел 3.7.3.5) могут быть ассоциированы лишь с другими проекционными обозначениями или с геометрическими объектами, составляющими проекцию модели. Так, например, вы можете ассоциировать обозначение базы, проставленное к грани модели, с размером.

В отличие от других ассоциативных объектов, линейный не имеет ограничения ассоциативность, а считается ассоциативным, если начальные точки его выносных линий совпадают с точками геометрического объекта. Поэтому неассоциативный линейный размер можно вручную ассоциировать с нужным объектом, наложив ограничение совпадение на выносные линии размера.


7.2.5. Приемы работы с параметрическими изображениями

7.2. Параметризация геометрических объектов

7.2.5. Приемы работы с параметрическими изображениями

В этом разделе:

7.2.5.1. Преобразование обычного изображения в параметрическое

7.2.5.2. Преобразование параметрического изображения в обычное

7.2.5.3. Редактирование параметрического изображения

7.2.5.3.1. Изменение значений переменных

7.2.5.3.2. Управление значениями размеров

7.2.5.3.3. Редактирование «перетаскиванием» точек


7.2.5.1. Преобразование обычного изображения в параметрическое

Чтобы сделать размеры, штриховки, шероховатости и обозначения баз ассоциированными с геометрическими объектами, можно в режиме редактирования каждого из этих объектов указать заново базовые кривые и точки. Другим способом является удаление старых непараметрических объектов и простановка их заново (особенно рекомендуется для штриховок в случае сложной конфигурации штрихуемых областей). В обоих случаях параметрический режим должен быть предварительно включен (см. раздел 7.2.1.7).

Часть параметрических ограничений объектов (совпадения точек, горизонтальность, вертикальность, параллельность и перпендикулярность) можно наложить полуавтоматически. Для этого воспользуйтесь командой Параметризовать объекты (см. раздел 7.2.2.21).

Остальные типы связей и ограничений нужно наложить на непараметризованные объекты вручную.


7.2.5.2. Преобразование параметрического изображения в обычное

Чтобы полностью преобразовать параметрический чертеж или фрагмент в обычный, выполните следующие действия.

1. Выделите все объекты.

2. Вызовите команду Удалить все ограничения.

После того как все ограничения с объектов будут сняты, рекомендуется сохранить и закрыть документ, а затем открыть его снова.


7.2.5.3. Редактирование параметрического изображения

В этом разделе:

7.2.5.3.1. Изменение значений переменных

7.2.5.3.2. Управление значениями размеров

7.2.5.3.3. Редактирование «перетаскиванием» точек


7.2.5.3.1. Изменение значений переменных

7.2. Параметризация геометрических объектов > 7.2.5. Приемы работы с параметрическими изображениями > 7.2.5.3. Редактирование параметрического изображения

7.2.5.3.1. Изменение значений переменных

Изменение значений переменных производится в Окне переменных (см. раздел 7.1.1.2).

Если при заданном значении переменной система уравнений не может быть решена, на экране появится соответствующее сообщение.

Значения переменных размеров графических документов и эскизов можно также задать в диалоге установки значения размера (см. раздел 7.2.2.20).


7.2.5.3.2. Управление значениями размеров

7.2. Параметризация геометрических объектов > 7.2.5. Приемы работы с параметрическими изображениями > 7.2.5.3. Редактирование параметрического изображения

7.2.5.3.2. Управление значениями размеров

Изменение значения размера (и, соответственно, конфигурации управляемой им геометрии) возможно, только если этот размер зафиксирован.

Чтобы изменить значение размера, выполните следующие действия.

1. Дважды щелкните мышью на тексте размерной надписи параметрического размера. На экране появится диалог установки значения размера.

2. Если размер зафиксирован, то поле Выражение доступно. Введите новое значение размера.

Если размеру присвоено имя переменной, то вы можете ввести выражение для вычисления значения размера или, наоборот, заменить имеющееся выражение числовым значением (при этом переменные, входившие в удаленное выражение, не удаляются из документа).

Если размер не зафиксирован, отключите опцию Информационный размер. Размер зафиксируется, и поле Выражение станет доступно. Введите новое значение размера.

3. Нажмите кнопку OK. Значение размера изменится.

Если изменение значения размера или выполнение фиксации невозможно вследствие избыточности наложенных ограничений, будет выдано соответствующее сообщение.


7.2.5.3.3. Редактирование «перетаскиванием» точек

7.2. Параметризация геометрических объектов > 7.2.5. Приемы работы с параметрическими изображениями > 7.2.5.3. Редактирование параметрического изображения

7.2.5.3.3. Редактирование «перетаскиванием» точек

Вы можете редактировать параметрическое изображение мышью, «перетаскивая» характерные точки составляющих его объектов (см. раздел 3.5.1.1.3).

При перемещении характерной точки объекта все связанные с ним объекты также будут перестроены.

Если на объект наложены ограничения, полностью определяющие его положение (например, проставлены все необходимые размеры, связывающие геометрию детали), будет выполнено простое перемещение связанных объектов в новое положение без перестроения геометрии. Если же объект при этом связан с зафиксированной точкой, то не будет выполнено вообще никаких действий.

Имеется возможность «перетаскивания» характерных точек объектов или нет, легко определить, если включено отображение степеней свободы (см. раздел 7.2.6.2). Наличие хотя бы одной степени свободы говорит о том, что характерную точку можно переместить, а отсутствие степеней свободы — о том, что перемещение невозможно.

Степени свободы объекта отображаются и в том случае, если изображение полностью определено и перемещение характерной точки этого объекта приведет к простому перемещению изображения.


7.2.6. Отображение ограничений и степеней свободы

7.2. Параметризация геометрических объектов

7.2.6. Отображение ограничений и степеней свободы

Работать с параметрическим изображением (например, эскизом) гораздо удобнее, если на экране кроме самих геометрических объектов отображаются наложенные на них ограничения и имеющиеся у них степени свободы.

Для показа ограничений и степеней свобод служат команды:

– Отображать ограничения,

– Отображать степени свобод.

Ограничения и степени свободы показываются на экране все время, пока нажаты соответствующие кнопки. Для отключения показа всех символов того или иного типа отожмите нужную кнопку или вызовите команду повторно. Отключить показ ограничений или степеней свободы для отдельного объекта невозможно.

В чертежах ограничения и степени свободы отображаются только у тех объектов, которые принадлежат текущему виду.

Обратите внимание на то, что настройка отображения ограничений и степеней свободы распространяется только на текущее окно. В другом окне (в том числе в новом окне текущего документа) отображение символов может быть включено или выключено независимо от текущего окна.

В чертежах и фрагментах степени свободы отображаются только у тех объектов, которые имеют ограничения, в то время как в эскизах отображаются степени свободы всех объектов.

Отображение ограничений в чертежах и фрагментах по умолчанию выключено, а в эскизах трехмерных элементов — включено.

Вы можете выбрать цвет символов и включить (отключить) постоянное отображение переменных, рамок фиксированных размеров и символов фиксированных точек в диалоге настройки отображения ограничений и степеней свободы. Работа в диалоге описана в разделе 9.1.7.7.

В этом разделе:

7.2.6.1. Ограничения

7.2.6.1.1. Особенности отображения размеров с переменными

7.2.6.2. Степени свободы


7.2.6.1. Ограничения

Чтобы показать на экране символы связей и ограничений, наложенных на графические объекты, вызовите команду Отображать ограничения.

После вызова команды на экране появятся символы связей и ограничений (см. табл. 7.2.2).

Табл. 7.2.2. Символы, показывающие связи и ограничения графических объектов
Ограничение | Изображение | Расположение
Горизонтальность |  | В середине отрезка
Вертикальность |  | В середине отрезка
Выравнивание точек по горизонтали |  | Штриховой горизонтальный отрезок, связывающий выровненные точки
Выравнивание точек по вертикали |  | Штриховой вертикальный отрезок, связывающий выровненные точки
Совпадение точек |  | В точке
Точка на кривой |  | В точке; при необходимости кривая продляется пунктирной линией
Точка на середине кривой |  | В точке
Симметрия двух точек |  | Штриховой отрезок, связывающий симметричные точки, и квадрат в точке его пересечения с осью; при необходимости ось продляется штриховой линией до центра квадрата
Параллельность |  | В серединах отрезков
Перпендикулярность |  | В точке пересечения отрезков; при необходимости отрезки продляются штриховой линией
Коллинеарность |  | Над серединами отрезков; ближайшие концы отрезков соединяются штриховой линией
Биссектриса |  | Над серединой объекта
Касание |  | В точке касания; при необходимости кривые продляются до точки касания штриховой линией
Равенство радиусов |  | Для дуги — над серединой, для окружности — над верхней точкой
Равенство длин |  | Над серединами отрезков
Фиксация точки |  | В точке
Фиксация длины |  | В середине объекта
Фиксация угла |  | В середине объекта
Фиксированный размер |  |
Размер с переменной |  | Под размерной линией; особенности отображения размеров с переменными описаны в разделе 7.2.6.1.1

В этом разделе:

7.2.6.1.1. Особенности отображения размеров с переменными


7.2.6.1.1. Особенности отображения размеров с переменными

Если ассоциативный размер имеет переменную, то в режиме отображения связей и ограничений (см. раздел 7.2.6.1) имя этой переменной отображается в его размерной надписи (рис. 7.2.4). Имя переменной заключается в скобки и располагается под размерной линией размера. На печать оно не выводится.

Рис. 7.2.4. Отображение имени переменной в размерной надписи

Для управляющих размеров возможно отображение не только имени переменной, но и ее значения, если значение переменной размера задано константой, выражением или отрицательным числом. Пример отображения переменной: (a=b+10).

Для информационных размеров отображается только имя переменной.


7.2.6.2. Степени свободы

Чтобы показать на экране символы степеней свободы, имеющихся у графических объектов, вызовите команду Отображать степени свободы.

После вызова команды на экране появятся символы степеней свободы (см. табл. 7.2.3).

Табл. 7.2.3. Символы, показывающие степени свободы объектов
Объект | Изображение максимального количества степеней свободы | Комментарий
Точка |  |
Отрезок |  | Отображаются степени свободы каждого конца отрезка
Окружность |  | Отображаются степени свободы центра и радиуса
Дуга окружности |  | Отображаются степени свободы центра, радиуса и концов дуги
Эллипс |  | Отображаются степени свободы центра, полуосей и степень свободы поворота вокруг центра
Дуга эллипса |  | Отображаются степени свободы центра, концов и степень свободы поворота вокруг центра
Сплайн |  | Отображаются степени свободы концов и опорных точек

Если на объект наложены ограничения, лишающие его одной или нескольких степеней свободы, то символы, соответствующие отобранным степеням, не отображаются. Например, на рисунке 7.2.5 показано последовательное наложение ограничений на отрезки, образующие прямоугольник. Сначала, когда на них были наложены ограничения горизонтальность, вертикальность и совпадение точек, концы всех отрезков имели по две степени свободы, т.е. каждый из них можно было перемещать мышью в любом направлении. В результате наложения ограничения фиксированная точка и простановки двух размеров с ограничением фиксированный размер концы отрезков потеряли все степени свободы. Длинами сторон данного прямоугольника теперь можно управлять только путем изменения значений размеров. Перемещение составляющих его отрезков мышью невозможно.

Рис. 7.2.5. Уменьшение числа степеней свободы объектов


7.2.7. Особенности использования некоторых команд в параметрическом режиме

7.2. Параметризация геометрических объектов

7.2.7. Особенности использования некоторых команд
в параметрическом режиме

В этом разделе:

7.2.7.1. Радиальный размер

7.2.7.2. Угловой размер

7.2.7.3. Обозначение центра

7.2.7.4. Симметрия

7.2.7.5. Автоосевая

7.2.7.6. Линейный размер с обрывом


7.2.7.1. Радиальный размер

При редактировании радиального размера на полке c несколькими ответвлениями (см. раздел 3.3.3.2.1) необходимо учитывать следующее.

Если размер был проставлен к объектам в параметрическом режиме, то редактирование — добавление ответвлений к новым дугам или окружностям — должно производиться также в параметрическом режиме, т.е. при нажатой кнопке Параметрический режим на панели Текущее состояние. В диалоге настройки параметризации (см. раздел 9.2.6.22) должна быть включена ассоциативность размеров при вводе.

Если радиальный размер не ассоциативен с объектами, то при добавлении ответвлений необходимо выключить параметрический режим.


7.2.7.2. Угловой размер

При простановке углового размера можно указывать в качестве сторон угла оси абсолютной системы координат (в чертеже — также оси системы координат вида).

В этом случае в документе автоматически создается вспомогательная прямая, совпадающая с осью системы координат. Эта прямая имеет ограничение проекционная связь. До тех пор, пока это ограничение сохраняется, прямая совпадает с осью, т.е. изменение положения прямой невозможно. Если удалить ограничение проекционная связь, прямая становится доступной для редактирования.


7.2.7.3. Обозначение центра

В параметрическом режиме ассоциативное обозначение центра может быть создано при помощи команды Обозначение центра (см. раздел 3.3.7.14) или при создании осесимметричного объекта, например, окружности, с осями (см. раздел 3.2.5.1.1).

Включение ассоциативности обозначения центра производится в диалоге настройки параметризации (см. раздел 9.2.6.22).

Обозначение центра имеет три формы: две оси, одна ось и условное обозначение («крестик»).

При создании ассоциативного обозначения центра необходимо учитывать следующее.

– При изменении параметров базовой кривой происходит автоматическое перестроение ассоциативных осей таким образом, чтобы они проходили через центр кривой и выступали за нее на указанное расстояние.

– Оси можно удлинять/укорачивать редактированием характерных точек на концах, но после этого измененная ось перестает «отслеживать» размер кривой в своем направлении.

Чтобы ось вновь стала «отслеживать» размер кривой в своем направлении, необходимо войти в режим редактирования обозначения центра двойным щелчком мыши и переключить тип обозначения на условное и обратно. Эти действия нужно выполнять в параметрическом режиме при включенной ассоциативности осей.

– Для ассоциированного обозначения центра при редактировании перемещением характерных точек не выдается точка центра (т.к. обозначение центра не может «оторваться» от базовой кривой). При необходимости ассоциативность можно снять с помощью команды Показать/удалить связи и ограничения на панели Параметризация.

– На обозначение центра можно поставить только неассоциативный размер, поэтому при включенной ассоциативности размеров оси недоступны для указания. Если размер должен управлять положением центра кривой, то его нужно ставить к центру кривой.


7.2.7.4. Симметрия

Создание связанных симметричных объектов может производиться командой Симметрия (см. раздел 3.5.4.3).

Для этого необходимо выполнять команду в параметрическом режиме и задавать ось симметрии, указывая сам объект (а не две его точки).

Например, чтобы при построении симметричной окружности создалась связь симметрия, после вызова команды Симметрия нажмите кнопку Выбор базового объекта на Панели специального управления. Затем укажите курсором прямолинейный объект.


7.2.7.5. Автоосевая

На автоосевую могут автоматически накладываться ограничения биссекриса, фиксированная длина и некоторые другие. Наложение ограничений биссекриса и фиксированная длина можно отключить в диалоге настройки параметризации (см. раздел 9.2.6.22). В данном разделе рассматривается случай, когда эти ограничения включены.

При построении автоосевой относительно двух отрезков способом По объектам (см. раздел 3.3.7.16) на осевую линию накладываются ограничения Биссектриса и другие ограничения. Их типы зависят от взаимного расположения объектов, к которым проставляется обозначение (рис. 7.2.6).

Рис. 7.2.6. Ограничения, наложенные на автоосевую при различном расположении отрезков
а) | б) | в)

– Если отрезки параллельны или не пересекаются, а точка пересечения их продолжений не лежит на одном из отрезков, то на автоосевую в ее конечных точках накладываются ограничения Три точки на прямой (рис. 7.2.6, а).

– Если отрезок пересекается с продолжением другого отрезка, то на ось в точке пересечения накладывается ограничение Точка на кривой, а в противоположной точке — Три точки на прямой (рис. 7.2.6, б).

– Если отрезки пересекаются, то в точке пересечения на автоосевую накладывается ограничение Совпадение точек, а в противоположной точке — Три точки на прямой (рис. 7.2.6, в).

В случае, когда одна или обе конечные точки автоосевой оказываются свободными от ограничений, на нее накладывается ограничение фиксированная длина. Это происходит в следующих случаях:

– По объектам относительно отрезка — см. рис. 3.3.81,

– С указанием границы относительно отрезка, если не указана одна граница — см. рис. 3.3.85 или обе границы — см. рис. 3.3.84,

– С указанием границы относительно двух отрезков, если не указана одна или обе границы — см. рис. 3.3.86.


7.2.7.6. Линейный размер с обрывом

Для линейного размера с обрывом возможна только автоматическая фиксация. Она производится, если размер создается в параметрическом режиме, а при настройке режима включены опции Ассоциировать при вводе размеры и Фиксировать размеры.

Линейный размер с обрывом фиксируется, если проставлен к отрезку и параллельной ему осевой линии. Значение размера определяется как удвоенное расстояние между отрезком и осевой. Для того, чтобы после изменения значения размера объекты оставались параллельными, при простановке размера на них автоматически накладывается связь Параллельность (если она не была наложена ранее вручную).

До простановки размера на отрезок и осевую линию могли быть наложены ограничения, делающие связь Параллельность избыточной, например, оба объекта были горизонтальны. В этом случае значки связей и ограничений, в том числе рамка размера, означающая ограничение Фиксированный размер, отображаются коричневым цветом. Для исправления ошибки можно удалить какую-либо связь или ограничение, наложенное на объект до простановки размера. Так, в приведенном выше примере можно отменить горизонтальность отрезка или осевой. Удалять связь Параллельность нельзя, так как это сделает невозможной работу размера.

Однако, необходимости в исправлении вышеописанной ситуации нет. Несмотря на избыточность ограничений, изменение значения размера будет доступным, а перестроение объектов в результате этого — правильным.


8.1. Общие сведения о печати документов

КОМПАС-3D является приложением Windows и использует все возможности этой операционной системы по работе с устройствами вывода (принтерами и плоттерами).

Документ можно отправить на печать из главного окна программы, что позволяет напечатать:

– весь документ (кроме многолистового с листами разных размеров),

– выделенную часть документа,

– текущий лист или выбранный лист многолистового документа.

Подробно о печати из главного окна программы см. раздел 8.2.

Напечатать документ можно и из окна предварительного просмотра. В этом случае доступны дополнительные возможности, например:

– печать многолистового документа с листами разных размеров,

– печать сразу нескольких документов разных типов, например, чертежа и модели,

– различные приемы компоновки листов на поле вывода,

– печать только заданной части листа,

– автоподгонка масштаба вывода,

– задание произвольного масштаба вывода для любого листа.

Редактирование документов в режиме предварительного просмотра недоступно.

Подробно о печати из окна предварительного просмотра см. раздел 8.3.

Специальная печать позволяет с помощью виртуальных принтеров создавать электронные документы в форматах PDF и XPS, а также выводить документы на печатающие устройства, поддерживающие печать многолистовых документов с разными размерами листов. Подробно о специальной печати см. раздел 8.4.

Иногда приходится распечатывать документы с одними и теми же настройками. В этих случаях удобно использовать задания на печать (см. раздел 8.5.1) и конфигурации устройств печати (см. раздел 8.5.2).

По умолчанию для вывода всех типов документов в КОМПАС-3D используется одно устройство печати — выбранное в Windows в качестве умолчательного.

При необходимости можно задать умолчательное использование разных устройств для документов разных типов, выбрав конфигурации устройств печати в диалоге общих настроек печати (см. раздел 9.1.5.1).

В этом разделе:

8.1.1. Особенности вывода документов на векторные устройства


8.1.1. Особенности вывода документов на векторные устройства

8.1. Общие сведения о печати документов

8.1.1. Особенности вывода документов
на векторные устройства

Печать документов КОМПАС-3D на векторных устройствах (например, плоттерах) имеет некоторые особенности.

– Документам, которые будут напечатаны на векторном устройстве, следует присвоить специальные оформления, в которых используются векторные шрифты. Эти оформления хранятся в системной библиотеке Vector.lyt.

Изменение оформления текущего и новых графических документов описано в разделе 3.6.2.1; текущего и новых текстовых документов — в разделе 4.1.4.2.

– Такие графические объекты, как шрифты TrueType, сплошные заливки цветом и растровые изображения, не могут быть корректно выведены на векторное устройство. Поэтому при попытке напечатать документ, содержащий перечисленные объекты, на экране появляется предупреждение (рис. 8.2.4).

В нем перечислены документы, в которых обнаружены шрифты True Type, растровые изображения и заливки, а также типы объектов (например, размеры, макроэлементы и т.д.), содержащих шрифты True Type, растры и заливки.

Вы можете отказаться от вывода растровых изображений и заливок, либо указать, выводить или не выводить эти документы, нажав соответствующую кнопку диалога.


8.2. Печать из главного окна программы

Чтобы напечатать текущий документ, вызовите команду Файл — Печать.... На экране появится диалог Печать документа (рис. 8.2.1).

Рис. 8.2.1. Диалог настройки печати документов

Элементы управления диалога позволяют выполнить стандартные настройки параметров печати: задать количество копий, указать номера печатаемых листов и т.п. Если перед вызовом диалога в документе были выделены объекты, автоматически выбирается диапазон печати Выделение. Это означает, что будет выведена область документа, находящаяся внутри прямоугольной рамки, которая охватывает все выделенные объекты (в случае текстового документа будет выведен выделенный фрагмент текста).

С помощью кнопки Настройка... вы можете выбрать нужное устройство печати (принтер или плоттер) и задать его параметры (см. раздел 8.2.1). Кроме того, меню этой кнопки позволяет использовать конфигурации устройств печати (см. раздел 8.5.2), что ускоряет настройку печати документов, имеющих сходные параметры.

Устройство, выбранное для печати документа, будет по умолчанию использоваться для всех документов того же типа в текущем сеансе работы КОМПАС-3D.

При необходимости вы можете выполнить дополнительные настройки печати документа, например, выбрать вариант использования цветов при выводе документа на печать. Для этого вызовите диалог дополнительных настроек, нажав кнопку Параметры вывода... (см. раздел 8.2.2).

Кнопка Фильтры вывода... позволяет включить или отключить печать объектов документа в зависимости от их типа. Установка фильтров описана в разделе 8.2.3.

Если перед вызовом диалога печати в чертеже или текстовом документе было что-либо выделено, то автоматически отключается фильтр вывода элементов листа (рамок, основной надписи и т.п.). При необходимости вы можете включить фильтр. В этом случае в текстовом документе будут напечатаны элементы листа целиком, а в чертеже — только те их части, которые попадают в рамку, охватывающую выделенные объекты.

В правой части диалога находится окно просмотра страниц печати — листов бумаги с учетом «мертвых зон» (областей у краев листа, которые принтер не может запечатать в силу своих конструктивных особенностей). Одна страница печати может содержать один или несколько листов документа (в зависимости от настройки). Вы можете переходить от одной страницы печати к другой, используя кнопки навигации в нижней части окна просмотра.

Настроив параметры печати, нажмите кнопку Печать для начала вывода документа на бумагу.

Если при выполнении настроек в диалоге была включена печать в файл, то на экране появится диалог, в котором потребуется задать имя файла и указать папку для его размещения.

При работе с многолистовым графическим документом вы можете вывести на печать только его текущий лист. Для этого используется команда Задать параметры печати и напечатать лист контекстного меню. После вызова этой команды на экране появляется диалог настройки параметров печати, описанный выше. Элементы управления диалога, предназначенные для настройки многолистового документа, недоступны.

Обратите внимание на следующие особенности вывода документов.

– Если многолистовой документ содержит листы одного размера с разной ориентацией, то при печати все они будут иметь ориентацию первого листа. Выбрать нужную ориентацию страницы можно с помощью группы опций Ориентация страницы диалога Печать документа. Вывод на печать документа с листами разного размера из главного окна программы невозможен. Такие документы следует печатать из режима предварительного просмотра (см. раздел 8.3).

– Оптимизация отображения размеров и обозначений в модели используется только для экрана, но не для печати. При печати модели надписи в размерах и обозначениях могут оказаться слишком малы по сравнению с самой моделью. В этом случае отключите оптимизацию (см. раздел 9.1.11.12) и измените настройку размеров и обозначений в этой модели, увеличив высоту шрифта.

В этом разделе:

8.2.1. Выбор нужного устройства печати и его настройка

8.2.2. Дополнительные настройки параметров вывода

8.2.3. Установка фильтров вывода


8.2.1. Выбор нужного устройства печати и его настройка

8.2. Печать из главного окна программы

8.2.1. Выбор нужного устройства печати и его настройка

КОМПАС-3D позволяет выводить документы на любое внешнее устройство, которое поддерживается операционной системой.

Подключенным, или доступным, будем называть плоттер или принтер, название которого отображается в списке доступных устройств.

Для получения информации о том, как подключить принтер или плоттер, обратитесь к документации на ОС Windows и имеющееся у вас устройство вывода.

Чтобы выбрать нужный плоттер/принтер и настроить его параметры, выполните следующие действия.

1. В диалоге настройки печати документов или специальной печати документов (см. рис. 8.2.1 и рис. 8.4.1) нажмите кнопку Настройка.... Если после нажатия кнопки на экране появится сообщение о том, что настройки будут сохранены только в текущем сеансе работы КОМПАС-3D, нажмите кнопку ОК.

2. В появившемся на экране стандартном диалоге Настройка печати выберите нужное имя устройства из списка доступных устройств.

Выбранное устройство будет по умолчанию использоваться для печати всех документов того же типа в текущем сеансе работы КОМПАС-3D.

3. Установите размер и ориентацию листов бумаги. Размер бумаги выбирается из списка форматов, поддерживаемых принтером или плоттером.

4. Выберите нужный способ подачи бумаги при печати.

5. Если необходимо выполнить настройку различных параметров печати (цвета печати, качества печати и т.п. — набор параметров зависит от типа устройства), нажмите кнопку Свойства... для вызова системного диалога драйвера устройства.

6. После выполнения всех необходимых настроек нажмите кнопку ОК.


8.2.2. Дополнительные настройки параметров вывода

8.2. Печать из главного окна программы

8.2.2. Дополнительные настройки параметров вывода

Дополнительные настройки параметров вывода документов на печать выполняются в диалоге, показанном на рисунке 8.2.2. Чтобы вызвать этот диалог, нажмите кнопку Параметры вывода... в диалоге настройки печати документов или специальной печати документов (см. рис. 8.2.1 и рис. 8.4.1).

Рис. 8.2.2. Диалог дополнительных настроек параметров вывода

Диалог дополнительных настроек позволяет включить печать изображения тонкими линиями, использовать альтернативные способы вывода заливок и растров, выбрать вариант использования цветов при печати, задать точность печати.

После выполнения всех необходимых настроек нажмите кнопку ОК. Чтобы закрыть диалог без применения настроек, нажмите кнопку Отмена.


8.2.3. Установка фильтров вывода

8.2. Печать из главного окна программы

8.2.3. Установка фильтров вывода

Иногда требуется вывести документ таким образом, чтобы некоторые объекты оформления или некоторые графические объекты не были напечатаны. Для этого используются фильтры. Установка фильтров вывода на печать выполняется в одноименном диалоге (рис. 8.2.3). Чтобы вызвать этот диалог, нажмите кнопку Фильтры вывода... в диалоге настройки печати документов или специальной печати документов (см. рис. 8.2.1 и рис. 8.4.1). Установка фильтров вывода, настроенная в диалоге, не изменяет умолчательных настроек системы. Описание элементов управления диалога приведено в разделе 9.1.5.2.

Рис. 8.2.3. Диалог установки фильтров вывода на печать

Рис. 8.2.4. Предупреждение при печати на векторное устройство

При подтверждении вывода перечисленных в диалоге документов следует иметь в виду, что гарантии корректной печати указанных объектов отсутствуют.


8.3. Предварительный просмотр перед печатью

В этом разделе:

8.3.1. Общие сведения о режиме предварительного просмотра

8.3.1.1. Начало и завершение работы в режиме предварительного просмотра. Вывод на печать

8.3.1.2. Интерфейс окна предварительного просмотра

8.3.1.2.1. Масштаб просмотра

8.3.1.3. Добавление и удаление листов документов

8.3.1.3.1. Отмена печати указанных страниц

8.3.2. Масштабирование листов документов

8.3.2.1. Автоподгонка масштаба листов

8.3.2.2. Подгонка масштаба листов

8.3.3. Размещение листов документов на поле вывода

8.3.3.1. Перемещение листа

8.3.3.1.1. Произвольное перемещение

8.3.3.1.2. Перемещение с привязкой к узлам страниц

8.3.3.1.3. Перемещение с привязкой к углам других листов документов

8.3.3.2. Поворот листа

8.3.3.3. Размещение нескольких листов

8.3.3.4. Примеры размещения листов на поле вывода

8.3.4. Дополнительные возможности

8.3.4.1. Поиск перекрывающихся листов

8.3.4.2. Печать области листа

8.3.4.3. Печать выделенной части документа

8.3.5. Настройки предварительного просмотра

8.3.5.1. Выбор нужного устройства печати и его настройка

8.3.5.2. Настройка параметров вывода

8.3.5.3. Установка фильтров вывода


8.3.1. Общие сведения о режиме предварительного просмотра

8.3. Предварительный просмотр перед печатью

8.3.1. Общие сведения о режиме предварительного просмотра

В этом разделе:

8.3.1.1. Начало и завершение работы в режиме предварительного просмотра. Вывод на печать

8.3.1.2. Интерфейс окна предварительного просмотра

8.3.1.2.1. Масштаб просмотра

8.3.1.3. Добавление и удаление листов документов

8.3.1.3.1. Отмена печати указанных страниц


8.3.1.1. Начало и завершение работы в режиме предварительного просмотра. Вывод на печать

8.3.1.1. Начало и завершение работы в режиме
предварительного просмотра. Вывод на печать

Режим предварительного просмотра для печати — специальный режим работы системы КОМПАС-3D.

Для перехода в этот режим из обычного режима работы системы вызовите команду Файл — Предварительный просмотр или нажмите кнопку Предварительный просмотр на Стандартной панели.

Если в главном окне системы открыт один документ, он будет сразу показан в режиме предварительного просмотра.

Если открыто несколько документов, на экране появится диалог выбора документов для печати. Вы можете выбрать один или несколько документов, выделив их в списке. Кроме того, нажав кнопку Из файла..., можно выбрать для печати закрытые документы. Выбранные документы будут показаны в режиме предварительного просмотра.

Чтобы диалог выбора документов не появлялся на экране, а текущий документ был сразу показан в режиме предварительного просмотра, нажмите кнопку Предварительный просмотр, удерживая клавишу <Shift>.

Если в главном окне системы открытых документов нет, команда Предварительный просмотр отсутствует в меню, а одноименная кнопка на Стандартной панели недоступна.

При работе с графическим документом вы можете открыть в режиме предварительного просмотра не весь документ, а только его текущий лист. Для этого используется команда Отправить данный лист в предварительный просмотр контекстного меню.

В режиме предварительного просмотра вы можете выполнить необходимые настройки изображения документа и напечатать его.

Для начала вывода документа на печать вызовите команду Файл — Печать. Можно также нажать кнопку Печать на инструментальной панели.

Чтобы закончить работу в режиме предварительного просмотра и вернуться в обычный режим КОМПАС-3D, вызовите команду Файл — Закрыть просмотр или щелкните мышью по значку режима в окне просмотра.


8.3.1.2. Интерфейс окна предварительного просмотра

Режим предварительного просмотра имеет собственное Главное меню, инструментальную панель (рис. 8.3.1) и Панель свойств (рис. 8.3.2).

Рис. 8.3.1. Главное меню и инструментальная панель окна предварительного просмотра

Рис. 8.3.2. Панель свойств

В этой части Руководства под словами «меню», «инструментальная панель» и «Панель свойств» при отсутствии специальных указаний будут подразумеваться именно Главное меню, инструментальная панель и Панель свойств окна предварительного просмотра.

Некоторые команды можно вызвать из контекстного меню (рис. 8.3.3).

Рис. 8.3.3. Контекстное меню в режиме предварительного просмотра: а) выделенных листов; б) свободного места на поле вывода
а) | б)

В режиме предварительного просмотра на экране показывается условное поле вывода (один или несколько листов бумаги). На нем реалистично отображается выбранный документ (или несколько выбранных документов).

Если формат листа бумаги, установленный в настройках текущего принтера, меньше, чем изображение документа (или документов), система автоматически рассчитывает необходимое для вывода количество листов бумаги. При этом поле вывода в режиме просмотра разделено пунктирными линиями на части, соответствующие установленному в данный момент формату бумаги и ее ориентации.

Вы можете разместить документы на поле вывода наиболее удобным образом (см. раздел 8.3.3).

Размер листов бумаги с учетом «мертвых зон» (областей у краев листа, которые принтер не может запечатать в силу своих конструктивных особенностей) и необходимое количество листов отображается в нижней части экрана — Строке состояния.

В этой части Руководства лист бумаги, отображающийся на поле вывода, называется страницей печати, а лист однолистового или многолистового документа, выбранного для просмотра, — листом документа. Для фрагмента или модели листом документа является габаритный прямоугольник изображения.

В этом разделе:

8.3.1.2.1. Масштаб просмотра


8.3.1.2.1. Масштаб просмотра

8.3. Предварительный просмотр перед печатью > 8.3.1. Общие сведения о режиме предварительного просмотра > 8.3.1.2. Интерфейс окна предварительного просмотра

8.3.1.2.1. Масштаб просмотра

При входе в режим предварительного просмотра на экране полностью отображается первый лист документа. Если в списке документов для печати было выделено несколько документов, то это первый лист первого документа из списка. Остальные листы, присутствующие в окне предварительного просмотра, могут отображаться на экране полностью, частично или не отображаться совсем, если масштаб отображения поля вывода оказывается слишком крупным.

Текущий масштаб отображения поля вывода показывается в одноименном поле на инструментальной панели. В этом поле можно задать произвольный масштаб отображения. Для этого введите нужное значение и нажмите клавишу <Enter>.

Изменить масштаб отображения поля вывода можно с помощью команд меню Вид. Кнопки для их быстрого вызова находятся на инструментальной панели. Описание команд приведено в таблице 8.3.1.

Табл. 8.3.1. Команды изменения масштаба

Команда

Описание

Показать все

Позволяет отобразить на экране все поле вывода целиком.

Масштаб по выделенным листам

Позволяет отобразить выделенные листы на экране полностью в максимально возможном масштабе.

Увеличить масштаб

Позволяет увеличить масштаб изображения. Увеличить масштаб изображения можно также, нажав кнопку <+> на дополнительной (цифровой) клавиатуре.

Увеличить масштаб рамкой

Позволяет увеличить масштаб произвольного участка поля вывода.

После вызова команды щелкните мышью в точке первого угла рамки, которая должна охватить увеличиваемую область. Затем перемещайте курсор для достижения нужного размера рамки. При этом на экране будет отображаться фантом рамки.

После фиксации второго угла рамки изображение будет увеличено таким образом, чтобы область поля вывода, ограниченная рамкой, занимала всю площадь окна.

Уменьшить масштаб

Позволяет уменьшить масштаб изображения. Уменьшить масштаб изображения можно также, нажав кнопку <-> на дополнительной (цифровой) клавиатуре.

Чтобы вернуться к одному из предыдущих масштабов отображения поля вывода вызовите команду Вид — Масштаб — Предыдущий. Чтобы вновь перейти к следующему масштабу отображения, вызовите команду Последующий.

Когда масштаб отображения поля вывода увеличен, на экране отображается ограниченная область этого поля. Чтобы, не изменяя масштаб, увидеть другие области поля вывода, воспользуйтесь командой сдвига изображения.

Для вызова команды нажмите кнопку Сдвинуть.

После этого форма курсора изменится: он превратится в четырехстороннюю стрелку.

Перемещайте курсор, удерживая нажатой левую кнопку мыши. Вслед за движением курсора будет прокручиваться поле вывода с размещенными на нем документами. Если достигнут край экрана и необходимо продвинуть поле вывода еще дальше, отпустите кнопку мыши, переместите курсор в нужное положение, а затем вновь нажмите левую кнопку мыши и продолжайте прокрутку поля печати.


8.3.1.3. Добавление и удаление листов документов

Чтобы добавить листы документов в предварительный просмотр, вызовите команду Файл — Добавить документы.... В появившемся диалоге выберите нужное имя файла (или несколько имен файлов) и нажмите кнопку Открыть. На экране появится диалог выбора варианта добавления листов (рис. 8.3.4).

Рис. 8.3.4. Диалог выбора варианта добавления листов документов

Нажмите кнопку Добавить к имеющимся листам, чтобы добавить листы загружаемых документов к листам документов, открытых для просмотра. Вы можете заменить листы документов, открытых для просмотра, листами загружаемых документов. Для этого нажмите кнопку Заменить имеющиеся листы.

Обратите внимание на то, что в набор для печати добавляются все листы выбранных документов.

Если в при настройке параметров вывода включено использование зазора, то добавленные листы отстоят друг от друга на величину зазора.

Чтобы удалить лист или несколько листов из предварительного просмотра, выделите их и вызовите команду Файл — Удалить листы из просмотра.

Один и тот же лист можно добавить в предварительный просмотр несколько раз (например, для печати нескольких областей одного листа).

Для быстрого копирования уже имеющихся в предварительном просмотре листов выберите нужные листы и переместите их мышью, удерживая нажатой клавишу <Ctrl>. В процессе копирования можно использовать привязки к узлам страниц и к углам других листов (см. раздел 8.3.3.1).

В этом разделе:

8.3.1.3.1. Отмена печати указанных страниц


8.3.1.3.1. Отмена печати указанных страниц

8.3. Предварительный просмотр перед печатью > 8.3.1. Общие сведения о режиме предварительного просмотра > 8.3.1.3. Добавление и удаление листов документов

8.3.1.3.1. Отмена печати указанных страниц

В том случае, если листы (или лист) не умещаются на том формате, который может вывести подключенный принтер или плоттер, система автоматически размещает изображение на дополнительных форматах — страницах.

Вы можете управлять выводом каждой страницы. Для отмены печати каких-либо страниц выполните следующие действия.

1. Вызовите команду Сервис — Режим выбора страниц для печати.

Система перейдет в режим указания страниц на поле печати. Индикатором этого режима является отображение нажатой кнопки Режим выбора страниц для печати. В этом режиме не выполняются никакие действия по компоновке документов.

2. Щелкните мышью внутри страницы, печать которой требуется запретить. При этом изменится цвет, которым эта страница изображена на экране. Повторный щелчок мышью внутри отмеченной ранее страницы отменяет запрет на ее печать.

3. Для выхода из режима указания страниц вновь вызовите команду Режим выбора страниц для печати или отожмите соответствующую кнопку.


8.3.2. Масштабирование листов документов

8.3. Предварительный просмотр перед печатью

8.3.2. Масштабирование листов документов

Режим предварительного просмотра предоставляет различные возможности масштабирования листов документов.

При входе в этот режим и при добавлении в просмотр листов документов производится автоподгонка масштаба листов (см. раздел 8.3.2.1).

Во время дальнейшей работы в режиме предварительного просмотра вы можете самостоятельно подгонять масштаб листов (см. раздел 8.3.2.2).

Кроме того, можно установить умолчательный масштаб печати листов в диалоге настройки параметров вывода (см. раздел 8.3.5.2).

Вы можете также изменить масштаб печати отдельно взятого листа. Для этого выделите нужный лист и укажите требуемое значение масштаба в поле управления масштабом, находящемся на Панели свойств. Вы можете ввести значение вручную или выбрать его из раскрывающегося списка.

В этом разделе:

8.3.2.1. Автоподгонка масштаба листов

8.3.2.2. Подгонка масштаба листов


8.3.2.1. Автоподгонка масштаба листов

Автоподгонка масштаба листов документов — это автоматическое изменение масштаба листов для вписывания их в страницы печати с последующим авторазмещением листов на страницах печати.

Автоподгонка масштаба листов производится при входе в просмотр и при добавлении листов документов в просмотр.

При загрузке файла задания на печать автоподгонка не производится.

Для включения автоподгонки служит опция Автоподгонка при переходе в предварительный просмотр в диалоге настройки вывода (см. рис. 8.3.6).

Процесс автоподгонки масштаба листов включает в себя следующие этапы.

1. Проверка размеров листов.

Размеры листов должны соответствовать одному из следующих условий:

– габариты листов одинаковы,

– соответствующие размеры листов (высота, ширина) одинаковы или кратны друг другу.

При автоподгонке многолистовых чертежей система может менять ориентацию листов для обеспечения кратности соответствующих размеров.

Если ни одно условие не выполнено, то процесс автоподгонки прерывается.

2. Расчет масштаба листов.

3. Проверка полученного масштаба.

Допустимый масштаб ограничивается следующими значениями:

– максимум — умолчательный масштаб (заданный при настройке параметров вывода, см. раздел 8.3.5.2);

– минимум — масштаб, составляющий 0,94 от умолчательного масштаба.

Если полученный масштаб меньше минимума, то процесс автоподгонки прерывается.

Если полученный масштаб больше максимума, то для листов устанавливается умолчательный масштаб.

4. Авторазмещение листов на страницах печати.

Левый нижний угол первого листа размещается в точке поля вывода с координатами 0,0.

Каждый последующий лист, если он умещается на оставшемся месте страницы, располагается справа от предыдущего (с зазором, если включено его использование), в противном случае — привязываются к левому нижнему узлу следующей страницы печати.

При добавлении документов в просмотр их листы размещаются аналогично последующим листам многолистового документа.

Автоподгонка дает наилучший результат, если:

– размер листа примерно соответствует размеру страницы печати (например, формат листа и формат страницы печати равны А4),

– можно подобрать такой допустимый масштаб для листа, при котором его горизонтальный или вертикальный размер будет кратен соответствующему размеру страницы печати, т.е. документ может быть напечатан на целом числе страниц (например, лист формата А3 можно напечатать на двух страницах формата А4).

– можно подобрать такой допустимый масштаб для листов, при котором их общий горизонтальный или вертикальный размер будет равен соответствующему размеру страницы печати, т.е. на одной странице может быть напечатано целое число листов (например, на странице формата А1 можно напечатать восемь листов формата А4).

Если при настройке параметров вывода включено использование зазора между листами, то зазор учитывается при определении масштаба листов.


8.3.2.2. Подгонка масштаба листов

Иногда требуется разместить листы документов на определенном количестве страниц печати, при этом масштаб изображения на бумаге заранее точно не известен. Для такого размещения листов сначала выделите их, а затем вызовите команду Сервис — Подогнать масштаб....

После вызова этой команды на экране появляется диалог подгонки масштаба листов документов (рис. 8.3.5). Элементы управления этого диалога представлены в таблице 8.3.2.

Рис. 8.3.5. Диалог подгонки масштаба листов документов

Табл. 8.3.2. Элементы управления диалога подгонки листов документов

Элемент

Описание

Листы документов

Справочное поле, содержащее перечень листов, выбранных для подгонки масштаба. Для каждого листа указаны имя файла документа, которому он принадлежит, и его номер в документе.

Количество страниц
по горизонтали,
Количество страниц
по вертикали

Введите, задайте с помощью счетчика или выберите из списка требуемое значение любого из параметров. Второй параметр будет вычислен автоматически.

Масштаб

Поле задания масштаба. Ввод произвольного значения масштаба не допускается — его можно выбирать только из списка. Помимо стандартных значений в нем перечислены те масштабы, которые были установлены ранее в процессе работы с этим диалогом.

При масштабировании одного листа поле доступно для задания масштаба, при масштабировании нескольких листов — недоступно (и пусто, если выбранные листы имеют разные исходные масштабы).

Общее количество страниц

Справочное поле, содержащее количество страниц печати для вывода документов с заданными параметрами.

Центром масштабирования выделенных листов является левый нижний угол их габаритного прямоугольника. Если между листами есть зазор, то он тоже масштабируется.

Если исходные масштабы листов были разные, то и после масштабирования листов их масштабы будут разные.

Рекомендуется выделять листы, смежные друг с другом. В противном случае в результате масштабирования выделенных листов может возникнуть их перекрытие с другими листами. Чтобы найти перекрывающиеся листы, следует вызвать команду Сервис — Найти перекрывающиеся листы (см. раздел 8.3.4.1).


8.3.3. Размещение листов документов на поле вывода

8.3. Предварительный просмотр перед печатью

8.3.3. Размещение листов документов на поле вывода

Существуют следующие возможности размещения листов документов на поле вывода:

– перемещение,

– поворот,

– масштабирование.

Чтобы выделить лист (листы), положение которого на поле вывода нужно изменить, щелкните по его изображению мышью, выберите его имя из списка Лист на Панели свойств или используйте клавишу <Tab>. Лист отображается заключенным в габаритную рамку зеленого цвета.

Чтобы выделить несколько листов, указывайте их, удерживая нажатой клавишу <Ctrl>.

Также несколько листов можно выделить с помощью охватывающей или секущей рамки. Для этого служит команда Сервис — Выделить рамкой.

Чтобы выделить все листы, вызовите команду Сервис — Выделить все.

Разделы 8.3.3.1 и 8.3.3.2 посвящены размещению одного выделенного листа, а раздел 8.3.3.3 — размещению нескольких листов.

В этом разделе:

8.3.3.1. Перемещение листа

8.3.3.1.1. Произвольное перемещение

8.3.3.1.2. Перемещение с привязкой к узлам страниц

8.3.3.1.3. Перемещение с привязкой к углам других листов документов

8.3.3.2. Поворот листа

8.3.3.3. Размещение нескольких листов

8.3.3.4. Примеры размещения листов на поле вывода


8.3.3.1. Перемещение листа

Лист документа можно перемещать на поле вывода следующими способами:

– с помощью клавиш со стрелками,

– путем указания координат базовой точки изображения,

– мышью:

• произвольное,

• с привязкой к узлу страницы печати,

• с привязкой к углу другого листа.

При перемещении листа с помощью клавиш со стрелками одно нажатие клавиши сдвигает лист на один шаг. Для изменения шага перемещения введите или выберите его из списка Текущий шаг курсора на инструментальной панели.

После того как с помощью клавиш со стрелками достигнуто нужное положение габаритной рамки листа, зафиксируйте ее нажатием клавиши <Enter>. Изображение будет перерисовано в соответствии с новым положением листа на поле вывода.

Вы можете задать точное положение листа, введя координаты его базовой точки в соответствующие поля на Панели свойств. Началом системы координат является левый нижний угол страницы печати, а базовой точкой листа — его левый нижний угол. В этой точке расположено условное обозначение координатных осей. Обозначение служит лишь для удобства работы и не выводится на бумагу.

Обратите внимание на то, что ввод каждой координаты необходимо подтверждать нажатием клавиши <Enter>.

В поля X и Y можно ввести только положительные значения, так как отрицательное смещение означало бы, что какая-то часть листа должна оказаться в зоне, недоступной для печати.

Произвольное размещение листа на поле печати удобно применять, когда необходимо напечатать документ с большими полями. Размещение с привязкой к углам, напротив, позволяет экономить бумагу, печатая листы рядом друг с другом или максимально близко к краям листа. Способы перемещения листа мышью (произвольное и с привязкой) подробно описаны ниже.

В этом разделе:

8.3.3.1.1. Произвольное перемещение

8.3.3.1.2. Перемещение с привязкой к узлам страниц

8.3.3.1.3. Перемещение с привязкой к углам других листов документов


8.3.3.1.1. Произвольное перемещение

Чтобы переместить лист на поле печати, выполните следующие действия.

1. Выделите лист документа, который необходимо переместить.

2. Установите курсор так, чтобы он находился в пределах документа.

Вид курсора изменится.

3. Нажмите левую кнопку мыши и, не отпуская ее, перемещайте мышь. Габаритная рамка листа будет передвигаться по полю вывода.

4. Когда необходимое положение габаритной рамки будет достигнуто, отпустите кнопку мыши.

Изображение будет перерисовано в соответствии с новым положением листа на поле вывода. Дополнительные страницы печати будут появляться автоматически при выходе документа за текущие габариты поля вывода.


8.3.3.1.2. Перемещение с привязкой к узлам страниц

Когда один из углов габаритной рамки перемещаемого листа приближается к узлу любой из страниц, составляющих поле вывода, в узле страницы возникает маркер в виде небольшого кружочка. Если отпустить кнопку мыши, когда маркер находится на экране, произойдет привязка соответствующего угла листа к узлу страницы (при этом другие углы листа могут и не попасть точно в узлы страницы, если размеры листа не кратны размерам страниц).

Относительную величину расстояния между узлом и углом габаритной рамки листа, при достижении которого возникает маркер привязки, можно изменить в диалоге настройки параметров вывода (см. раздел 8.3.5.2). В этом же диалоге можно отключить привязку листа к узлам страниц.

Привязку к узлам страниц можно включать и отключать также с помощью кнопки Привязка к узлам страниц на инструментальной панели.


8.3.3.1.3. Перемещение с привязкой к углам других листов документов

Если для предварительного просмотра выбрано несколько листов документов, то вы можете перемещать их по полю вывода, привязывая углы листов друг к другу.

В отличие от описанного выше порядка действий курсор перед началом перемещения нужно установить не в середине выделенного листа, а ближе к его углу — так, чтобы курсор принял вид уголка, заключенного в рамку (ориентация курсора зависит от того, рядом с каким углом он был зафиксирован).

Нажмите левую клавишу мыши и перемещайте габаритную рамку листа по полю вывода.

Когда угол габаритной рамки, «за который» вы перемещаете выбранный лист, приближается к углу габаритной рамки другого листа документа, внутри рамки курсора возникает маркер в виде маленького квадрата. Если отпустить кнопку мыши, когда маркер находится на экране, произойдет привязка соответствующего угла выбранного листа к углу другого листа документа (при этом другие углы этих листов могут и не совпасть, если размеры сторон листов не равны).

Относительную величину расстояния между углами листов, при достижении которого возникает маркер привязки, можно изменить в диалоге настройки параметров вывода (см. раздел 8.3.5.2). В этом же диалоге можно включить или отключить использование зазора при привязке углов листов друг к другу и задать величину зазора.

Использование зазора при привязке к углам листов можно включать и отключать также с помощью кнопки Оставлять зазор между листами на инструментальной панели.

При «перетаскивании» листа за угол привязка листа к узлу страницы печати не осуществляется.


8.3.3.2. Поворот листа

Чтобы более рационально использовать бумагу, иногда бывает необходимо повернуть лист документа.

Поворот листа осуществляется с помощью команд Повернуть против часовой стрелки и Повернуть по часовой стрелке меню Сервис.


8.3.3.3. Размещение нескольких листов

Для размещения нескольких выделенных листов на поле вывода можно использовать приемы, представленные в таблице 8.3.3.

Рекомендуется выделять листы, смежные друг с другом. В противном случае в результате размещения выделенных листов может возникнуть их перекрытие с другими листами. Чтобы найти перекрывающиеся листы, следует вызвать команду Сервис — Найти перекрывающиеся листы (см. раздел 8.3.4.1).

Табл. 8.3.3. Приемы размещения листов на поле вывода

Прием

Описание

Поворот листов

Перемещение листов

Масштабирование листов

Поворот, перемещение и масштабирование нескольких выделенных листов осуществляются так же, как и для одного выделенного листа (см. разделы 8.3.2, 8.3.3.1 и 8.3.3.2).

Базовой точкой для выделенных листов является левый нижний угол их габаритного прямоугольника.

Смыкание и выравнивание листов

Изменение положения выделенных листов, при котором они сдвигаются сначала влево до границы их габаритного прямоугольника или ближайшего выделенного листа, а затем аналогично сдвигаются вниз. Для выполнения этого сдвига служит команда Сервис — Сомкнуть и выровнять листы 1.

Если при настройке параметров вывода (см. раздел. 8.3.5.2) включено использование зазора между листами, то сдвиг листов друг к другу производится с зазором.

При сдвиге ориентация листов не изменяется.

Размещение листов в узлах

Изменение положения выделенных листов, при котором их левые нижние углы совмещаются с левыми нижними узлами ближайших страниц печати. Для такого перемещения служит команда Сервис — Разместить листы в узлах страниц 1.

Перемещение листа в узел ближайшей страницы выполняется, если левый нижний угол листа входит в «зону чувствительности» узла этой страницы.

Радиус «зоны чувствительности» узла задается при настройке параметров вывода.
  1. В результате выполнения команды может возникнуть перекрытие листов. Это зависит от соотношения размеров листов и страниц печати, а также от исходного положения листов на поле вывода. Чтобы найти перекрывающиеся листы, вызовите команду Найти перекрывающиеся листы.


8.3.3.4. Примеры размещения листов на поле вывода

Пример 1: размещение листов документов, размеры которых примерно соответствуют размерам страницы печати или кратны им (например, формат страницы печати равен А4, форматы листов А4 и А3).

1. Выделите лист, размер которого примерно соответствует размеру страницы печати.

2. Подгоните масштаб выделенного листа с помощью команды Подогнать масштаб... (см. раздел 8.3.2.2).

3. Установите полученный масштаб для остальных листов.

4. Разместите листы в нужном порядке на поле вывода.

5. Выделите все листы.

6. Сдвиньте листы друг к другу и выровняйте их с помощью команды Сомкнуть и выровнять листы.

7. Разместите листы в узлах страниц печати с помощью команды Разместить листы в узлах страниц.

8. Проверьте листы на перекрытие с помощью команды Найти перекрывающиеся листы.

Пример 2: размещение листов, размеры которых меньше размеров страниц печати (например, несколько листов формата А4 печатаются на странице формата А1).

1. Расположите все листы на странице печати компактно и без перекрытия.

2. Выделите все листы.

3. Сдвиньте листы друг к другу и выровняйте их с помощью команды Сомкнуть и выровнять листы.

4. Подгоните масштаб выделенных листов с помощью команды Подогнать масштаб....


8.3.4. Дополнительные возможности

8.3. Предварительный просмотр перед печатью

8.3.4. Дополнительные возможности

В этом разделе:

8.3.4.1. Поиск перекрывающихся листов

8.3.4.2. Печать области листа

8.3.4.3. Печать выделенной части документа


8.3.4.1. Поиск перекрывающихся листов

Для поиска перекрывающихся листов служит команда Сервис — Найти перекрывающиеся листы.

После вызова команды производится проверка всех листов, добавленных в просмотр, на перекрытие.

– Если перекрывающиеся листы найдены, то они выделяются зелеными рамками.
Листы, перекрывающие друг друга полностью, выделяются красной рамкой.

– Если перекрывающиеся листы не найдены, то на экране появляется сообщение об этом.


8.3.4.2. Печать области листа

Вы можете вывести на печать лист документа целиком или его область, ограниченную прямоугольником произвольных размеров.

Для выбора нужного варианта печати служит группа переключателей Способ вывода Панели свойств.

Активизация переключателя Вывести текущий лист полностью позволяет напечатать выделенный лист документа целиком. При этом он полностью отображается на поле вывода.

Активизация переключателя Вывести заданную область текущего листа позволяет вывести на печать область выделенного листа документа. При этом на поле вывода отображается только указанная область.

Для задания границ печатаемых областей листов документа используется команда Сервис — Режим указания выводимых областей листов.

После вызова команды на Панели свойств появляются группа переключателей Способ указания области и поля управления областью печати текущего листа. Ввод значений в эти поля позволяет определить положение и размер области. Набор полей зависит от способа указания печатаемой области листа.

Доступно два способа указания области:

– задание размеров и положения области,

– задание отступов границ области от краев листа.

Для выбора нужного способа необходимо активизировать соответствующий ему переключатель.

По умолчанию размеры рамки, ограничивающей область печати листа, соответствуют его габаритам. Чтобы изменить размеры рамки и ее положение, введите нужные значения в поля управления областью печати (возможен ввод не только числовых значений, но и выражений для их вычисления). Кроме того, вы можете перемещать мышью стороны или углы рамки, а также рамку целиком. При этом значения в полях будут изменяться автоматически.

Если документ содержит несколько листов, можно указать печатаемую область каждого из них, не прерывая работу команды. Для выбора нужного листа щелкните по его изображению мышью, или укажите его имя в списке Лист на Панели свойств, или используйте клавишу <Tab>.

Текущий лист отображается на поле вывода целиком. Для остальных листов показываются только области, заданные для печати.

Для завершения настройки областей печати повторно вызовите команду Режим указания выводимых областей листов или нажмите клавишу <Esc>.

После этого на поле вывода будут отображаться только те области листов, которые указаны для печати, а в группе переключателей Способ вывода Панели свойств активизируется переключатель Вывести заданную область текущего листа. При необходимости вы можете изменить способ вывода каждого листа.

На одном листе можно указать только одну область для печати.

Если требуется вывести на печать несколько областей одного и того же листа, выполните следующие действия:

– создайте нужное количество копий листа, перемещая его мышью при нажатой клавише <Ctrl>,

– вызовите команду Режим указания выводимых областей листов,

– укажите нужные области на полученных копиях листа.

Область листа документа, заданную для печати, можно переместить, повернуть на поле вывода или промасштабировать так же, как и целый лист.

При работе с графическими документами вы можете задать область печати перед переходом в предварительный просмотр. Для этого увеличьте масштаб так, чтобы в окне отображалась только та часть изображения, которая должна быть напечатана.


8.3.4.3. Печать выделенной части документа

Вы можете ограничить выводимую часть изображения, указав в документе объекты, которые следует напечатать. Для этого выделите нужные объекты (в текстовом документе — фрагмент текста) и вызовите команду Отправить выделенное в предварительный просмотр из меню кнопки Предварительный просмотр.

После этого документ открывается в предварительном просмотре, причем:

– для графических документов и моделей:

• автоматически включается вывод заданной области (в группе Способ вывода на Панели свойств активизируется переключатель Вывести заданную область текущего листа, см. раздел 8.3.4.2),

• область печати представляет собой габаритный прямоугольник выделенных объектов, т.е. кроме выделенных печатаются все остальные объекты, полностью или частично попадающие в прямоугольник, охватывающий выделенные объекты.

– для текстовых документов: выделенный фрагмент размещается вверху страницы вне зависимости от того, где он находился в тексте;

– дополнительно для чертежей и текстовых документов:

• автоматически изменяется настройка фильтров: отключается вывод элементов листа — рамки, основной надписи и др. (в случае необходимости вы можете включить печать этих элементов, см. раздел 8.3.5.3, при этом в текстовом документе будут напечатаны элементы листа целиком, а в чертеже — только те их части, которые попадают в габаритный прямоугольник выделенных объектов);

– дополнительно для многолистовых чертежей:

• поскольку на одном листе можно задать только одну область печати, создается несколько областей печати — по одной на каждый лист, попавший в габаритный прямоугольник выделенных объектов или пересекающийся с ним,

• листы, не попавшие в габаритный прямоугольник выделенных объектов и не пересекающиеся с ним, не передаются в предварительный просмотр.

При работе со спецификацией команда Отправить выделенное в предварительный просмотр недоступна.


8.3.5. Настройки предварительного просмотра

8.3. Предварительный просмотр перед печатью

8.3.5. Настройки предварительного просмотра

В этом разделе:

8.3.5.1. Выбор нужного устройства печати и его настройка

8.3.5.2. Настройка параметров вывода

8.3.5.3. Установка фильтров вывода


8.3.5.1. Выбор нужного устройства печати и его настройка

КОМПАС-3D позволяет выводить документы на любое внешнее устройство, которое поддерживается операционной системой.

Подключенным, или доступным, будем называть плоттер или принтер, название которого отображается в списке доступных устройств.

Для получения информации о том, как подключить принтер или плоттер, обратитесь к документации на ОС Windows и имеющееся у вас устройство вывода.

Чтобы выбрать нужный плоттер/принтер для печати из режима предварительного просмотра, выполните следующие действия.

1. Вызовите команду Файл — Настройка плоттера/принтера....

2. В появившемся на экране диалоге выберите нужное устройство печати и настройте параметры печати, как описано в разделе 8.2.1.

Выбранное устройство будет по умолчанию использоваться для печати документов всех типов из режима предварительного просмотра в текущем сеансе работы КОМПАС-3D.

Выбрать и настроить принтер/плоттер для печати из предварительного просмотра можно заранее, работая в главном окне КОМПАС-3D. Для этого вызовите команду Файл — Настройки предварительного просмотра — Настройка плоттера/принтера....


8.3.5.2. Настройка параметров вывода

Настройка параметров вывода документов на печать из режима предварительного просмотра выполняется в диалоге, показанном на рис. 8.3.6. Этот диалог появляется на экране после вызова команды Файл — Настройка параметров вывода....

Рис. 8.3.6. Диалог настройки параметров вывода

Элементы управления диалога позволяют задать количество печатаемых копий документов, порядок размещения и печати листов, способы вывода на печать объектов различных типов, вариант использования цветов при печати, масштаб и точность печати.

После выполнения всех необходимых настроек нажмите кнопку ОК.

Такими параметрами, как Привязка к узлам страниц и Оставлять зазор между листами можно управлять без вызова диалога — с помощью кнопок на инструментальной панели.

Если в диалоге был изменен цвет вывода, а также, если была включена или отключена опция Вывод тонкими линиями, изображение перерисовывается. Изменение умолчательного масштаба никак не отражается на уже открытых документах — заданное значение будет применено лишь к вновь добавленным в просмотр документам.

Если была включена печать в файл, то после вызова команды Печать на экране появится диалог, в котором потребуется задать имя файла и указать папку для его размещения.

Настроить параметры вывода документов на печать из предварительного просмотра можно заранее, работая в главном окне КОМПАС-3D. Для этого вызовите команду Файл — Настройки предварительного просмотра — Настройка параметров вывода....


8.3.5.3. Установка фильтров вывода

Если требуется вывести документ таким образом, чтобы некоторые объекты оформления или некоторые графические объекты не были напечатаны, используйте фильтры вывода объектов на печать.

Чтобы установить фильтры вывода для печати документов из режима предварительного просмотра, вызовите команду Фильтры вывода на печать... из меню Сервис окна предварительного просмотра. На экране появится диалог установки фильтров (рис. 8.3.7). Описание элементов управления диалога приведено в разделе 9.1.5.2.

Рис. 8.3.7. Диалог установки фильтров вывода на печать

Вы можете применить сформированные фильтры, закрыв диалог или оставив его открытым. В первом случае нажмите кнопку ОК, во втором — кнопку Применить.

Установка фильтров вывода, выполненная в режиме предварительного просмотра, сохраняется только до конца текущего сеанса работы в этом режиме.


8.4. Специальная печать

Специальная печать предназначена для вывода текущего документа на печатающие устройства, позволяющие непосредственно в процессе печати менять размеры страницы печати под размер выводимого листа документа. Например, в результате вывода через механизм специальной печати на виртуальный xps-принтер многолистового документа, листы которого имеют разный формат, создается один xps-файл, размеры страниц в котором соответствуют размерам листов в выведенном документе.

При печати фрагментов и моделей через механизм специальной печати создается документ из одной страницы, размеры которой соответствуют габаритам изображения выведенного фрагмента или модели.

При обычном способе печати многолистового документа с разными форматами листов приходится, в зависимости от заданного размера страницы печати, либо разделять листы документа на несколько частей (под размер страницы печати), либо группировать их на одной странице печати.

Чтобы напечатать документ через механизм специальной печати, вызовите команду Файл — Специальная печать.... На экране появится диалог Специальная печать документа (рис. 8.4.1).

Рис. 8.4.1. Диалог настройки параметров специальной печати

Элементы управления диалога позволяют настроить диапазон вывода листов, указать номера печатаемых листов, порядок их вывода (четные, нечетные).

С помощью кнопки Настройка... вы можете выбрать нужное устройство печати и задать его параметры (см. раздел 8.2.1). С помощью меню этой кнопки можно использовать конфигурации устройств печати (см. раздел 8.5.2).

Дополнительные настройки печати документа выполняются в диалоге дополнительных настроек. Вызвать его можно, нажав кнопку Параметры вывода... (см. раздел 8.2.2).

Кнопка Фильтры вывода... позволяет вызвать диалог установки фильтров вывода объектов документа на печать. Установка фильтров описана в разделе 8.2.3.

Настроив параметры печати, нажмите кнопку Печать для начала вывода документа на указанный принтер.

Если для специальной печати будет выбрано устройство вывода, не поддерживающее изменений размеров страниц в процессе печати, документ выведется на печать в том же виде, что и при обычной печати — на страницах с размером, заданным по умолчанию для устройства печати.


8.5. Задания на печать. Конфигурации устройств печати

8.5. Задания на печать.
Конфигурации устройств печати

В этом разделе:

8.5.1. Задание на печать

8.5.1.1. Сохранение задания на печать

8.5.1.2. Загрузка задания на печать

8.5.1.2.1. Возможные проблемы при загрузке задания

8.5.2. Конфигурации устройств печати

8.5.2.1. Сохранение конфигурации

8.5.2.2. Загрузка конфигурации

8.5.2.2.1. Возможные проблемы при загрузке конфигурации


8.5.1. Задание на печать

8.5. Задания на печать. Конфигурации устройств печати

8.5.1. Задание на печать

Если вам приходится распечатывать одни и те же документы с одними и теми же настройками, удобно использовать задания на печать.

Задание на печать представляет собой файл, в который записываются номера листов и имена файлов документов, выбранных для печати, настройки их размещения на поле вывода, настройки параметров вывода и данные об устройстве вывода.

Файл задания на печать имеет расширение pjd.

Файл задания записывается в текстовом формате, поэтому при необходимости он может быть открыт и отредактирован любым текстовым редактором, например, Блокнотом, входящим в состав стандартных программ Windows.

При загрузке файла задания на печать записанные в него листы документов отображаются в режиме предварительного просмотра с сохраненными настройками.

В этом разделе:

8.5.1.1. Сохранение задания на печать

8.5.1.2. Загрузка задания на печать

8.5.1.2.1. Возможные проблемы при загрузке задания


8.5.1.1. Сохранение задания на печать

Чтобы сохранить задание на печать, вызовите команду Файл — Сохранить задание на печать... в режиме предварительного просмотра. На экране появится стандартный диалог сохранения файла. Введите имя файла и нажмите кнопку Сохранить. По умолчанию файлу задания присваивается имя «Задание на печать».

Каждое новое задание сохраняется в отдельном файле. При этом сохраняются следующие данные:

– относительные и абсолютные пути к файлам документов, выбранных для печати,

– номера и размеры листов документов, выбранных для печати,

– выбранное устройство печати и его настройки,

– расположение, ориентация и масштаб листов документов, заданные в режиме предварительного просмотра,

– признак печатаемости страниц устройства вывода, установленный при помощи команды Сервис — Режим выбора страниц для печати,

– настройки фильтров,

– настройки параметров вывода, кроме параметров Количество копий, Масштаб печати документов по умолчанию и Помнить список из N заданий на печать.

Чтобы иметь возможность переносить папки с файлами чертежей и файлом задания на печать в другие папки без нарушения актуальности файла задания, разместите файл задания на печать рядом с файлами чертежей (в одной папке) или в родительской папке.

В файл задания могут быть записаны только те документы, которые были хотя бы раз сохранены. Если среди документов, выбранных для печати, есть ни разу не сохраненные (без имени), то при сохранении задания на печать на экране появится сообщение о невозможности их записи в файл задания.

Нажмите кнопку Да, чтобы сохранить задание, пропустив эти документы. Нажмите кнопку Нет, чтобы отменить сохранение задания.

Если ни один из документов, выбранных для печати, ни разу не был сохранен, то сохранение задания на печать невозможно. При попытке сохранения задания на экране появится предупреждающее сообщение.


8.5.1.2. Загрузка задания на печать

Чтобы загрузить задание на печать, вызовите команду Файл — Загрузить задание на печать... в режиме предварительного просмотра. На экране появится стандартный диалог открытия файла. Выберите имя нужного файла задания и нажмите кнопку Открыть.

Если вы недавно сохраняли или загружали задание на печать, то можете выбрать его имя из списка заданий. Этот список отображается:

– в режиме предварительного просмотра — в меню Файл,

– в главном окне — в меню Файл — Задание на печать.

По умолчанию список содержит девять последних сохраненных или загруженных заданий на печать. Количество заданий в списке настраивается (см. раздел 9.1.5.1).

На экране появится диалог выбора варианта добавления листов документов (рис. 8.5.1).

Рис. 8.5.1. Диалог выбора варианта добавления листов документов

Нажмите кнопку Добавить к имеющимся листам, чтобы добавить листы документов задания к листам документов, открытых для просмотра. При этом листы документов задания будут расположены после листов документов, открытых для просмотра. Относительное размещение листов сохранится.

В случае добавления листов игнорируется сохраненный в задании признак печатаемости страниц устройства вывода, установленный при помощи команды Сервис — Режим выбора страниц для печати.

Текущие настройки вывода изменятся в соответствии с загруженным заданием.

Нажмите кнопку Заменить имеющиеся листы, чтобы заменить листы документов, открытых для просмотра, листами документов задания.

Кнопка Отмена позволяет отказаться от загрузки задания на печать.

Чтобы загрузить задание на печать из главного окна программы, вызовите команду Файл — Задание на печать — Загрузить... или выберите имя нужного файла из списка заданий. В этом случае диалог Выберите вариант добавления листов документов не появляется. Произойдет автоматический переход в режим предварительного просмотра, в котором отобразятся листы документов задания.

Если текущие параметры вывода, настройки принтера или фильтров отличаются от сохраненных в задании на печать, то в случае замены листов применяются настройки и параметры из задания, а в случае добавления листов на экране появляется сообщение, показанное на рисунке 8.5.2.

Рис. 8.5.2. Сообщение об отличии между текущими параметрами вывода и параметрами,
сохраненными в задании на печать

Кнопка Да позволяет заменить текущие параметры и настройки на сохраненные в задании.

Кнопка Нет позволяет использовать текущие параметры и настройки.

После загрузки задания на печать в режиме предварительного просмотра можно работать как обычно: изменять текущие настройки, удалять или перемещать листы документов и т.п.

Произведенные изменения не сохраняются в файле задания на печать. При необходимости вы можете сохранить текущие настройки в новый файл задания или перезаписать существующий.

В этом разделе:

8.5.1.2.1. Возможные проблемы при загрузке задания


8.5.1.2.1. Возможные проблемы при загрузке задания

При загрузке задания на печать возможно возникновение проблем разного рода.

Если файл задания содержит ошибки и не может быть загружен, то на экране появится сообщение Файл задания на печать содержит ошибки и не может быть загружен.

Если при загрузке задания на печать возникли проблемы, не препятствующие ее продолжению, то по окончании загрузки на экране появится Информационное окно (рис. 8.5.3).

Рис. 8.5.3. Информационное окно

Информационное окно имеет собственное меню (см. табл. 3.9.1 и 3.9.2). В окне отображаются:

– текущая дата,

– полное имя файла задания на печать,

– список проблем, возникших при загрузке.

При загрузке задания на печать могут возникать следующие проблемы.

– В задании на печать отсутствуют данные по устройству вывода. Будет использовано текущее устройство вывода. Это сообщение появляется в окне информации, если в задании на печать отсутствуют данные об устройстве вывода, которые задаются в диалоге Настройка печати. В этом случае устройством вывода станет текущее устройство или устройство по умолчанию.

– Указанное в задании на печать устройство вывода отсутствует в системе. Будет использовано текущее устройство вывода. Это сообщение появляется в окне информации, если сохраненное в задании на печать устройство вывода отсутствует в системе. В этом случае для печати используется текущее устройство вывода или назначенное по умолчанию. Сохраненный в задании признак печатаемости страниц устройства вывода, установленный при помощи команды Режим выбора страниц для печати игнорируется.

– В задании на печать отсутствуют параметры страницы. Будут использованы настройки устройства вывода. Это сообщение появляется в окне информации, если в задании на печать отсутствуют параметры страницы (размер и ориентация), которые задаются в диалоге Настройка печати. В этом случае при загрузке задания используются настройки устройства вывода.

– В задании на печать отсутствуют установки фильтров вывода на печать. Будут использованы текущие настройки фильтров. Это сообщение появляется в окне информации, если в задании на печать отсутствуют установки фильтров вывода, которые задаются в диалоге Установка фильтров вывода на печать. В этом случае при загрузке задания используются текущие настройки фильтров.

– В задании на печать отсутствуют настройки некоторых фильтров. Для этих фильтров будут оставлены текущие настройки. Это сообщение появляется в окне информации, если в задании на печать отсутствуют установки некоторых фильтров вывода, которые задаются в диалоге Установка фильтров вывода на печать. В этом случае при загрузке задания для фильтров, настройки которых отсутствуют в задании, используются текущие настройки фильтров.

– В задании на печать отсутствуют данные о параметрах вывода. Будут использованы текущие настройки параметров вывода. Это сообщение появляется в окне информации, если в задании на печать отсутствуют данные о параметрах вывода, которые задаются в диалоге Настройка параметров вывода. В этом случае при загрузке задания используются текущие настройки этих параметров.

– В задании на печать отсутствуют данные о некоторых параметрах вывода. Для этих параметров будут оставлены текущие значения. Это сообщение появляется в окне информации, если в задании на печать отсутствуют данные о некоторых параметрах вывода, которые задаются в диалоге Настройка параметров вывода. В этом случае при загрузке задания для параметров, данные о которых отсутствуют в задании, используются текущие настройки этих параметров.

– Лист <номер листа> отсутствует в файле <полное имя файла>. Это сообщение появляется в окне информации, если при загрузке задания не найден один из листов документов, записанных в задании. В этом случае задание загружается без этого листа. Если все листы всех документов, записанные в задании, отсутствуют, загрузка файла задания прерывается.

– Область печати для листа <номер листа> выходит за его пределы, файл <полное имя файла>. Это сообщение появляется в окне информации, если задана печать только части листа, и границы области печати выходят за текущие габариты листа. В этом случае задание загружается без этого листа. Если данная ошибка присутствует во всех листах всех документов, записанных в задании, загрузка файла задания прерывается.

– Не найден файл <полное имя файла>. Это сообщение появляется в окне информации, если при загрузке задания не найден один из документов, записанных в задании. В этом случае задание загружается без этого документа. Если все документы, записанные в задании, отсутствуют, загрузка файла задания прерывается.

– Невозможно открыть файл <полное имя файла>. Это сообщение появляется в окне информации, если один из документов, записанных в задании, найден, но не может быть открыт. В этом случае задание загружается без этого документа. Если все документы, записанные в задании, не могут быть открыты, загрузка файла задания прерывается.

– Изменились размеры листа <номер листа>, файл <полное имя файла>. Это сообщение появляется в окне информации, если при загрузке задания обнаружено, что записанные в задании размеры листов отличаются от их текущих размеров. После загрузки задания листы отображаются со своими текущими размерами. Положение листов на поле вывода не меняется.

Если загрузка задания на печать вызвана из главного окна программы, и все документы, записанные в задании, содержат ошибки, или не найден ни один из этих документов, то загрузка файла задания будет прервана. На экране появится сообщение При обработке выбранного файла задания на печать не удалось сформировать данные для вывода. Для получения подробной информации войдите в режим предварительного просмотра и загрузите этот файл.


8.5.2. Конфигурации устройств печати

8.5. Задания на печать. Конфигурации устройств печати

8.5.2. Конфигурации устройств печати

Использование конфигураций устройств печати позволяет:

– быстро сменить устройство печати и его параметры,

– задать умолчательное устройство и параметры печати документа из режима предварительного просмотра,

– задать умолчательные устройства и параметры печати документов различных типов из главного окна программы.

Конфигурация устройства печати представляет собой файл, в который записываются параметры печати (размер и способ подачи бумаги, ориентация страницы) и данные об устройстве печати.

Файл конфигурации имеет расширение pdc.

Вы можете сохранить файл конфигурации для любого доступного устройства печати (см. раздел 8.5.2.1). Для одного устройства печати может быть создано несколько файлов конфигураций.

Файл конфигурации записывается в текстовом формате, поэтому при необходимости он может быть открыт и отредактирован любым текстовым редактором, например, Блокнотом, входящим в состав стандартных программ Windows.

При загрузке конфигурации текущее устройство печати заменяется устройством печати, указанным в файле конфигурации, а значения параметров печати — значениями параметров, записанными в этом файле (см. раздел 8.5.2.2).

Вы можете выбрать конфигурации, которые будут использоваться по умолчанию при печати документов из главного окна и из режима предварительного просмотра (см. раздел 9.1.5.1). В этом случае умолчательными устройствами печати будут устройства, указанные в данных файлах.

Если файл конфигурации, используемый по умолчанию, не выбран или выбранный файл не найден, то умолчательным устройством печати является умолчательный принтер Windows.

Вы можете указать другое устройство печати и задать его параметры при настройке вывода документов на печать из главного окна (см. раздел 8.2.1) и из режима предварительного просмотра (см. раздел 8.3.5.1). Данные настройки сохраняются в течение сеанса работы.

В этом разделе:

8.5.2.1. Сохранение конфигурации

8.5.2.2. Загрузка конфигурации

8.5.2.2.1. Возможные проблемы при загрузке конфигурации


8.5.2.1. Сохранение конфигурации

Каждая конфигурация сохраняется в отдельном файле. При этом в него записываются следующие данные:

– имя и параметры текущего принтера,

– размер и способ подачи бумаги,

– ориентация страницы печати.

Для удобства работы рекомендуется давать файлам конфигураций имена, отражающие не только имена текущих устройств печати, но и настроенные параметры печати (размер бумаги и ориентацию страницы). Можно также именовать файлы с учетом назначения сохраненных в них конфигураций, например, используя названия типов документов, для печати которых они предназначены.

Сохранение конфигурации устройства печати выполняется следующими способами.

Способ 1

1. Откройте КОМПАС-документ.

2. Вызовите команду Файл — Печать... или Файл — Специальная печать.... На экране появится диалог настройки печати или специальной печати (см. рис. 8.2.1 и рис. 8.4.1).

3. Убедитесь, что используется нужное устройство печати и заданы требуемые параметры (при настройке печати для документов различных типов могут быть заданы различные устройства и параметры печати).

4. Вызовите команду Сохранить конфигурацию плоттера/принтера... из меню кнопки Настройка... (меню вызывается щелчком мыши по треугольнику справа от кнопки). На экране появится стандартный диалог сохранения файла.

5. Введите имя файла и нажмите кнопку Сохранить. По умолчанию именем файла конфигурации является имя текущего устройства печати.

При необходимости вы можете изменить параметры печати и сохранить их в новый файл конфигурации или перезаписать существующий.

6. Для завершения работы в диалоге настройки печати нажмите кнопку Отмена.

Способ 2

1. Вызовите команду Файл — Настройки предварительного просмотра — Настройка плоттера/принтера. На экране появится диалог настройки устройства печати.

2. Убедитесь, что используется нужное устройство печати и заданы требуемые параметры. После этого закройте диалог.

3. Вызовите команду Файл — Настройки предварительного просмотра — Сохранить конфигурацию плоттера/принтера.... На экране появится стандартный диалог сохранения файла.

4. Введите имя файла и нажмите кнопку Сохранить. По умолчанию именем файла конфигурации является имя текущего устройства печати.

Способ 3

1. Перейдите в режим предварительного просмотра, вызвав команду Файл — Предварительный просмотр или нажав кнопку Предварительный просмотр на Стандартной панели.

2. Вызовите команду Файл — Настройка плоттера/принтера. На экране появится диалог настройки устройства печати.

3. Убедитесь, что используется нужное устройство печати и заданы требуемые параметры. После этого закройте диалог.

4. Вызовите команду Файл — Конфигурация плоттера/принтера — Сохранить конфигурацию плоттера/принтера.... На экране появится стандартный диалог сохранения файла.

5. Введите имя файла и нажмите кнопку Сохранить. По умолчанию именем файла конфигурации является имя текущего устройства печати.


8.5.2.2. Загрузка конфигурации

Вы можете загрузить конфигурацию устройства печати при настройке печати документа из главного окна или из окна предварительного просмотра.

Загрузка конфигурации для печати документа из главного окна выполняется следующим образом.

1. Активизируйте нужный документ.

2. Вызовите команду Файл — Печать... или Файл — Специальная печать.... На экране появится диалог настройки печати или специальной печати (см. рис. 8.2.1 и рис. 8.4.1).

3. Вызовите команду Загрузить конфигурацию плоттера/принтера... из меню кнопки Настройка... (меню вызывается щелчком мыши по треугольнику справа от кнопки). На экране появится стандартный диалог выбора файла.

4. Укажите нужный файл конфигурации и нажмите кнопку Открыть.

Если вы недавно сохраняли или загружали конфигурацию, то вы можете загрузить ее, выбрав из списка конфигураций, расположенного в меню кнопки Настройка.... Список содержит конфигурации, которые сохранялись или загружались для документов того же типа, что и текущий документ.

По умолчанию список содержит девять последних сохраненных или загруженных файлов конфигураций. Количество объектов в списке настраивается (см. раздел 9.1.5.1).

5. Если требуется напечатать документ, нажмите кнопку Печать. Если печать документа в данный момент не требуется, нажмите кнопку Отмена.

Обратите внимание на то, что данные из файла конфигурации, выбранного для печати документа, будут использоваться для всех документов того же типа.

Загрузить конфигурацию для печати документа из режима предварительного просмотра можно как при работе в главном окне, так и при работе в окне предварительного просмотра. Для загрузки конфигурации выполните следующие действия.

1. Вызовите команду Загрузить конфигурацию плоттера/принтера... из меню Файл — Настройки предварительного просмотра в главном окне или меню Файл — Конфигурация плоттера/принтера в режиме предварительного просмотра.

На экране появится стандартный диалог выбора файла.

2. Укажите нужный файл конфигурации и нажмите кнопку Открыть.

Для выбора конфигурации можно использовать список последних сохраненных или загруженных конфигураций, расположенный в меню Файл — Настройки предварительного просмотра в главном окне или меню Файл — Конфигурация плоттера/принтера в режиме предварительного просмотра.

При загрузке конфигурации текущее устройство печати заменяется устройством печати, указанным в файле конфигурации; размер бумаги и ориентация страницы получают значения из файла. Все остальные параметры печати остаются без изменения. Эти параметры необходимо настраивать вручную.

Данные, загруженные из файла конфигурации, сохраняются в течение сеанса работы КОМПАС-3D.

Вы можете изменить значения параметров, полученные из файла конфигурации, а также выбрать другое устройство печати. Эти изменения не сохраняются в файле конфигурации. При необходимости вы можете сохранить текущие настройки в новый файл конфигурации или перезаписать существующий.

В этом разделе:

8.5.2.2.1. Возможные проблемы при загрузке конфигурации


8.5.2.2.1. Возможные проблемы при загрузке конфигурации

При загрузке конфигурации могут возникать следующие проблемы.

– Устройство печати, указанное в файле конфигурации, не может быть применено. В этом случае на экране появляется сообщение Указанное в файле конфигурации устройство вывода отсутствует в системе. Будет использовано текущее устройство вывода. Текущее устройство печати и параметры печати остаются без изменения.

– Невозможно задать сохраненный в конфигурации размер бумаги. В этом случае на экране появляется сообщение Невозможно установить размер бумаги, заданный в файле конфигурации. Текущее устройство печати заменяется устройством, указанным в файле конфигурации; ориентации страниц присваивается значение из файла, размеру бумаги присваиваются умолчательные параметры размера бумаги устройства печати, указанного в файле конфигурации.

– Данные из файла конфигурации не могут быть загружены (указанный файл не является файлом конфигурации, в файле отсутствуют данные или эти данные неверны и т.п.). В этом случае на экране появляется сообщение Указанный файл поврежден или не является файлом конфигурации устройства вывода. Текущее устройство печати и параметры печати остаются без изменения.


9.1. Параметры системы

В этом разделе:

9.1.1. Общие сведения о настройке системы

9.1.2. Общие

9.1.2.1. Отображение имен файлов

9.1.2.2. Представление чисел

9.1.2.3. Повтор команд

9.1.2.4. Управление системой

9.1.2.5. Обновление оформления документов

9.1.2.6. Всплывающие сообщения

9.1.2.7. Гиперссылки

9.1.2.8. Контекстная панель

9.1.2.9. OLE

9.1.2.10. Мышь

9.1.3. Экран

9.1.3.1. Фон рабочего поля

9.1.3.2. Фон рабочего поля моделей

9.1.3.3. Фон надписей

9.1.3.4. Цветовая схема

9.1.3.5. Цвет текстовых элементов

9.1.3.6. Панель свойств

9.1.3.7. Закладки документов

9.1.3.8. Настройка интерфейса

9.1.3.8.1. Команды

9.1.3.8.2. Панели инструментов

9.1.3.8.3. Утилиты

9.1.3.8.4. Клавиатура

9.1.3.8.5. Меню

9.1.3.8.6. Параметры

9.1.3.8.7. Размер значков

9.1.4. Файлы

9.1.4.1. Расположение

9.1.4.2. Установка прав доступа

9.1.4.3. Резервное копирование

9.1.4.4. Автосохранение

9.1.4.5. Сохранение конфигурации

9.1.5. Печать

9.1.5.1. Общие настройки

9.1.5.2. Фильтры вывода на печать

9.1.6. Общие для документов

9.1.6.1. Параметры резьбы

9.1.7. Графический редактор

9.1.7.1. Курсор

9.1.7.2. Сетка

9.1.7.3. Линейки прокрутки

9.1.7.4. Системные линии

9.1.7.5. Системные символы

9.1.7.6. Фантомы

9.1.7.7. Ограничения и степени свободы

9.1.7.8. Виды

9.1.7.9. Слои

9.1.7.10. Системы координат

9.1.7.11. Редактирование

9.1.7.12. Характерные точки

9.1.7.13. Растровые объекты, взятые в документ

9.1.7.14. Упрощенная отрисовка

9.1.7.15. Поиск объекта

9.1.7.16. Привязки

9.1.7.17. Управление изображением

9.1.8. Текстовый редактор

9.1.8.1. Линейки прокрутки

9.1.8.2. Редактирование

9.1.8.3. Текстовые шаблоны

9.1.8.4. Толщина линий спецзнаков

9.1.8.5. Масштаб редактирования

9.1.8.6. Параметры правописания

9.1.9. Редактор спецификаций

9.1.9.1. Линейки прокрутки

9.1.9.2. Параметры обновления документов

9.1.10. Прикладные библиотеки

9.1.10.1. Отключение

9.1.10.2. Редактирование элементов

9.1.11. Редактор моделей

9.1.11.1. Сетка

9.1.11.2. Линейки прокрутки

9.1.11.3. Системные линии

9.1.11.4. Библиотеки конструкторских элементов

9.1.11.5. Управление изображением

9.1.11.6. Изменение ориентации

9.1.11.7. Перспективная проекция

9.1.11.8. Редактирование

9.1.11.9. ЛСК

9.1.11.10. Исполнения

9.1.11.11. Зеркальное отражение

9.1.11.12. Размеры и обозначения

9.1.11.13. Габарит

9.1.11.14. Зоны

9.1.11.15. МЦХ

9.1.11.16. Упрощения

9.1.11.16.1. Модель

9.1.11.16.2. Прочие

9.1.12. Отчеты

9.1.12.1. Настройка списка стилей отчетов

9.1.12.2. Линейки прокрутки

9.1.12.3. Размещение таблицы

9.1.12.3.1. Формат листа

9.1.12.3.2. Поля листа


9.1.1. Общие сведения о настройке системы

9.1. Параметры системы

9.1.1. Общие сведения о настройке системы

Настройка параметров системы КОМПАС-3D производится на вкладке Система диалога, вызываемом командой Сервис — Параметры... (рис. 9.1.1).

В левой части вкладки находится представленный в виде «дерева» список объектов настройки. Они сгруппированы в разделы согласно своему назначению. После того как в левой части выбран тот или иной пункт, в правой части вкладки появляются элементы управления для выполнения настройки.

Рис. 9.1.1. Диалог настройки всплывающих сообщений

После закрытия диалога кнопкой ОК информация о настройках системы записывается в файл *.cfg (см. раздел 9.5.2) и используется в следующем сеансе работы.

Обратите внимание на следующие условности и упрощения, принятые в данном разделе:

– Далее под «диалогом» будет подразумеваться не весь настроечный диалог, а лишь набор элементов управления для настройки того или иного объекта.

– Обращение к этому набору элементов управления будет описано в виде: Сервис — Параметры... — Система — Название раздела (группа объектов настройки) — Название подраздела (подгруппа объектов настройки). Например, если в тексте сказано: «Настройка параметров отображения всплывающих сообщений выполняется в диалоге Всплывающие сообщения. Диалог появляется на экране после вызова команды Сервис — Параметры... — Система — Общие — Всплывающие сообщения», то это означает, что для доступа к настройке всплывающих сообщений необходимо выполнить такую последовательность действий.

1. Выбрать в Главном меню пункт Сервис.

2. В появившемся списке команд меню Сервис выбрать команду Параметры....

3. В появившемся диалоге активизировать вкладку Система.

4. В списке объектов настройки развернуть раздел Общие.

5. Выделить подраздел Всплывающие сообщения.
В правой части вкладки появятся элементы управления под общим заголовком Всплывающие сообщения для задания параметров сообщений.


9.1.2. Общие

9.1. Параметры системы

9.1.2. Общие

В этом разделе:

9.1.2.1. Отображение имен файлов

9.1.2.2. Представление чисел

9.1.2.3. Повтор команд

9.1.2.4. Управление системой

9.1.2.5. Обновление оформления документов

9.1.2.6. Всплывающие сообщения

9.1.2.7. Гиперссылки

9.1.2.8. Контекстная панель

9.1.2.9. OLE

9.1.2.10. Мышь


9.1.2.1. Отображение имен файлов

Настройка показа имени файла в заголовке окна и количества файлов в списке последних открывавшихся выполняется в диалоге Общие параметры настройки. Диалог появляется на экране после вызова команды Сервис — Параметры... — Система — Общие — Отображение имен файлов.

Табл. 9.1.1. Элементы управления диалога настройки отображения имен файлов
Элемент | Описание настройки
Полное имя файла в заголовке окна | Чтобы в заголовке окна системы был указан путь к файлу текущего документа и его имя, включите эту опцию. При отключенной опции путь к файлу выводиться не будет. Варианты показа имени файла отображаются в поле Пример.
Помнить список из N файлов | Поле позволяет ввести или задать с помощью счетчика количество файлов в списке последних открывавшихся. Этот список отображается в нижней части меню Файл.

Завершив настройку, нажмите кнопку OK. Для выхода из диалога без изменения настроек нажмите кнопку Отмена.


9.1.2.2. Представление чисел

Настройка точности отображения вещественных чисел и выбор единиц измерения углов выполняется в диалоге Настройка представления чисел. Диалог появляется на экране после вызова команды Сервис — Параметры... — Система — Общие — Представление чисел.

Максимальная точность, с которой могут отображаться вещественные числа (координаты точек, размеры объектов, значения переменных и т.п.) — 6 знаков.

Табл. 9.1.2. Элементы управления диалога настройки представления чисел

Элемент

Описание настройки

Числа

Группа элементов позволяет настроить отображение вещественных чисел. Данная настройка распространяется на поля и таблицы Панели свойств, колонку Значения Окна переменных (см. раздел 7.1.1.2) и диалог установки значения ассоциативного размера (см. раздел 7.2.2.20).

Количество знаков после запятой в полях ввода/вывода

Поле позволяет ввести или задать с помощью счетчика количество знаков после запятой для отображения вещественных чисел.

Показывать незначащие нули после запятой

Опция позволяет управлять добавлением нулей в конце дробной части вещественных чисел, у которых количество знаков после запятой меньше установленного.

Единицы измерения углов

Группа элементов позволяет указать единицы измерения углов. Выбранные единицы будут использоваться для отображения величин углов в полях Панели свойств при создании и редактировании объектов.

При простановке угловых размеров в графических документах углы измеряются — в зависимости от установленной точности (см. раздел 9.2.6.10.12) — в градусах; в градусах и минутах; в градусах, минутах и секундах.

Десятичная система счисления

Выбор этого варианта означает, что угловые значения будут отображаться в формате хх,ххх° с заданной точностью.

Градусы, минуты, секунды

Выбор этого варианта означает, что угловые значения будут отображаться в формате хх°хх'хх,ххх" с заданной точностью.

Радианы

Выбор этого варианта означает, что угловые значения будут отображаться в формате хх,ххх рад с заданной точностью.

Завершив настройку представления чисел, нажмите кнопку OK. Для выхода из диалога без изменения настроек нажмите кнопку Отмена.

Точность измерений настраивается непосредственно в процессе измерения.

Точность значений размеров определяется параметрами, заданными в диалоге настройки точности размерных надписей (см. раздел 9.2.6.10.12).

Вы можете выбрать нужные единицы измерения углов без вызова диалога. Для этого воспользуйтесь контекстным меню на свободном месте любой вкладки Панели свойств.


9.1.2.3. Повтор команд

Включение и отключение вызова последних команд из контекстного меню, а также выбор количества повторяемых команд осуществляется в диалоге Настройка повтора команд. Диалог появляется на экране после вызова команды Сервис — Параметры... — Система — Общие — Повтор команд.

Табл. 9.1.3. Элементы управления диалога настройки повторного вызова команд
Элемент | Описание настройки
Команда «Повторить» в контекстном меню | Включите эту опцию, чтобы в контекстном меню присутствовала команда повтора последней выполненной команды. Например, после построения отрезка в контекстном меню появится команда Повторить: Отрезок. Ее вызов равносилен вызову команды Отрезок. Если опция выключена, последняя команда Повторить команду в контекстном меню не отображается.
Помнить список из N команд | Включите эту опцию, чтобы в контекстном меню присутствовала команда Последние команды. Ее подменю содержит список последних команд. Команды могут быть вызваны в любой последовательности. Чтобы задать количество запоминаемых команд, введите или задайте с помощью счетчика число — от 2 до 11. Если опция отключена, список команд в контекстном меню не отображается.

После завершения настройки повтора команд нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.1.2.4. Управление системой

Такие параметры работы системы КОМПАС-3D, как доступ к системе трехмерного моделирования и к модулю проектирования спецификаций, задаются в диалоге Управление системой, вызываемом командой Сервис — Параметры... — Система — Общие — Управление системой.

Диалог содержит опции Получить лицензию на работу с КОМПАС-3D и Разрешить работу со спецификацией и группу Управление созданием/перестроением ассоциативных видов.

– Опция Получить лицензию на работу с КОМПАС-3D позволяет при запуске КОМПАС-3D автоматически получать лицензию на работу с системой трехмерного проектирования.

Лицензии хранятся в памяти сетевого ключа аппаратной защиты. Если лицензия на КОМПАС-3D есть, то она занимается в момент запуска системы. При этом в меню Сервис отмечается «галочкой» команда Получить лицензию на работу с КОМПАС-3D. Это означает, что лицензия занята. Если во время сеанса работы появится необходимость освободить лицензию, вызовите из меню Сервис указанную команду.

Бывают ситуации, когда получение лицензии невозможно. Причиной невозможности получения лицензии может быть недоступность Менеджера лицензий (специальная программа, которая определяет, имеется ли на ключе аппаратной защиты лицензия, запрашиваемая пользователем).

Лицензию на работу с КОМПАС-3D может быть также невозможно получить по следующим причинам:

• на ключе нет информации о продукте, лицензия на работу с которым запрашивается пользователем (т.е. нет ни одной лицензии),

• на ключе нет свободной лицензии (т.е. все лицензии заняты другими пользователями).

В случае невозможности получения лицензии работа с трехмерными моделями ведется в деморежиме. В этом режиме в заголовке окна документа соответствующего типа отображается слово «деморежим».

В демонстрационном режиме работы с моделями доступны следующие действия:

• просмотр с изменением типа отображения и положения в пространстве,

• вывод на печать,

• создание чертежа с помощью команды Новый чертеж из модели.

Редактирование модели и ее сохранение на диск невозможны.

Если во время сеанса работы появится возможность получения лицензии, то, чтобы занять ее, вызовите из меню Сервис соответствующую команду.

– Опция Разрешить работу со спецификацией позволяет автоматически при запуске КОМПАС-3D получать доступ к модулю проектирования спецификаций.

При этом в меню Сервис отмечается «галочкой» команда Разрешить работу со спецификацией, что означает использование модуля проектирования спецификации. При этом доступны:

• все команды работы с объектами спецификации в документах-спецификациях, графических документах и документах-моделях,

• все команды подключения к спецификации графических документов и документов моделей и команды синхронизации спецификации с подключенными документами,

• сохранение документа-спецификации.

Если во время сеанса работы появится необходимость отказаться от использования модуля проектирования спецификации, вызовите из меню Сервис команду Разрешить работу со спецификацией. После этого команды работы с объектами спецификации в графических документах и документах-моделях становятся недоступны, перестает производиться синхронизация документов, предусмотренная настройками спецификации. В то же время создание нового документа-спецификации и объектов в нем возможно. В заголовке окна документа-спецификации отображаются слова «работа со спецификацией запрещена»; при попытке сохранения документа на экране появляется запрос на включение работы со спецификацией, так как запись файла *.spw на диск возможна, только если работа со спецификацией разрешена.

– Группа Управление созданием/перестроением ассоциативных видов предназначена для включения и настройки параллельного создания и перестроения ассоциативных видов.

• Если опция Разрешить параллельную обработку включена, то несколько ассоциативных видов могут создаваться и перестраиваться одновременно. Если опция отключена, то виды обрабатываются по одному друг за другом.

• Если опция С пониженным приоритетом включена, то процессы создания и перестроения видов запускаются с пониженным приоритетом. Данная возможность позволяет сохранить комфортность работы в других приложениях во время обработки видов, но при высокой загрузке системы скорость создания и перестроения видов может снизиться. Опция С пониженным приоритетом доступна, если параллельная обработка видов включена.

• Если опция Выполнять автосохранение перед обработкой включена, то перед созданием или перестроением ассоциативных видов выполняется автоматическое сохранение документов. Автосохранение выполняется вне зависимости от того, включено оно по умолчанию или нет, и только для тех документов, которые изменились с момента последнего сохранения или автосохранения. Рекомендуется включить опцию Выполнять автосохранение перед обработкой, так как во время обработки ассоциативных видов автосохранение не производится.

Включение параллельной обработки видов имеет смысл, только если компьютер оснащен многоядерным процессором. Максимальное ускорение может быть достигнуто при условии, что компьютер работает под управлением 64-разрядной ОС и оснащен достаточным количеством оперативной памяти (от 8 ГБ).

Завершив настройку параметров системы, нажмите кнопку ОК диалога. Обратите внимание на то, что включение/отключение опций Автоматически получать лицензию на работу с КОМПАС-3D и Разрешить работу со спецификацией вступают в силу при следующей загрузке системы.

Чтобы закрыть диалог без сохранения изменений, нажмите кнопку Отмена.


9.1.2.5. Обновление оформления документов

Настройка обновления оформления текстовых и графических документов и стилей спецификаций выполняется в диалоге Обновление оформления документов. Подробно обновление оформлений описано в разделе 11.2.1.2.1.

Диалог появляется на экране после вызова команды Сервис — Параметры... — Система — Общие — Обновление оформления документов.

Табл. 9.1.4. Элементы управления диалога настройки обновления оформления документов

Элемент

Описание настройки

Не обновлять

Выбор этого варианта означает, что автоматическое обновление оформления (стиля) производиться не будет. Документ будет отображаться с внедренным в него оформлением (стилем). При необходимости можно вручную обновить оформление (см. раздел 11.2.1.2.2) или стиль (см. раздел 6.2.8.1).

Сообщать об изменении оформления в библиотеке

Опция, включающая выдачу сообщений о наличии изменений между оформлением (стилем), внедренным в документ, и соответствующим ему оформлением (стилем) в библиотеке *.lyt.

Обновлять

Выбор этого варианта означает, что обновление оформления (стиля), внедренного в документ будет производиться автоматически при обнаружении различий между ним и соответствующим оформлением (стилем) в библиотеке *.lyt. По окончании обновления выдается сообщение об этом.

Запрашивать подтверждение

Опция, включающая запрос подтверждения обновления оформления (стиля) перед выполнением обновления. Вы можете подтвердить обновление или отказаться от него.

При использовании автоматического обновления рекомендуется включать запрос подтверждения, чтобы снизить риск случайного искажения оформления документов, созданных с использованием библиотеки *.lyt, отличной от текущей.

После завершения настройки нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.

Обновление оформлений (стилей) уже открытых документов производится согласно настройке, действовавшей при их открытии. Поэтому, чтобы изменение настройки обновления (например, включение автоматического обновления) вступило в силу, необходимо закрыть документы и открыть их заново.


9.1.2.6. Всплывающие сообщения

Настройка параметров отображения всплывающих сообщений выполняется в диалоге Всплывающие сообщения. Диалог появляется на экране после вызова команды Сервис — Параметры... — Система — Общие — Всплывающие сообщения.

Табл. 9.1.5. Элементы управления диалога настройки всплывающих сообщений

Элемент

Описание настройки

Свойства

Группа элементов позволяет настроить режим отображения всплывающих сообщений.

Время отображения, сек

Поле позволяет задать время нахождения всплывающего сообщения на экране.

Введите с клавиатуры значение в секундах от 0,001 до 10000.

Анимация

Список позволяет выбрать визуальный эффект при появлении и исчезновении сообщения. Если выбран вариант Нет, то всплывающее сообщение отображается без эффектов.

Положение на экране

Список позволяет выбрать вариант расположения всплывающего сообщения на экране.

Прозрачность

Элемент управления позволяет задавать прозрачность всплывающего сообщения.

– Если установлена Прозрачность — 0%, то изображение полностью непрозрачно. Чтобы увеличить прозрачность, следует мышью передвинуть «ползунок» вправо.

– Если установлена Прозрачность — 100%, то изображение является полностью прозрачным.

Для изменения прозрачности можно использовать клавиши <→> и <←>, предварительно выделив шкалу, например, щелчком мыши.

Поле, расположенное справа от шкалы, служит для отображения числового значения прозрачности.

Просмотр

Кнопка позволяет включить демонстрацию примера всплывающего сообщения с установленными свойствами до выхода из диалога.

Использовать всплывающие сообщения вместо информационных диалогов

При включенной опции на экране будут появляться всплывающие сообщения, а при отключенной — информационные диалоги (рис. 9.1.2).

Обратите внимание на то, что некоторые сообщения справочного характера имеют вид всплывающих вне зависимости от состояния данной опции. Например, сообщение о количестве точек, прочитанных из файла, при построении поверхности по сети точек.

Использовать всплывающие сообщения вместо сообщений об ошибках построения модели

При включенной опции информация об ошибках построения модели будет появляться в виде всплывающих сообщений, а при отключенной — в виде диалогов (рис. 9.1.3).

Настройка, сделанная в данном диалоге, не распространяется на всплывающие сообщения об ошибках, которые появляются, например, при задании некорректных величин в полях диалогов или Панели свойств (рис. 9.1.4).

Завершив настройку вплывающих сообщений, нажмите кнопку OK. Для выхода из диалога без изменения настроек нажмите кнопку Отмена.

Рис. 9.1.2. Примеры отображения информационного сообщения:
а) в виде диалога, б) всплывающего

а)

б)

Рис. 9.1.3. Примеры отображения информационного сообщения
об ошибках построения модели:
а) в виде диалога, б) всплывающего

а)

б)

Рис. 9.1.4. Пример сообщения об ошибках при вводе параметров


9.1.2.7. Гиперссылки

Настройка параметров гиперссылок выполняется в диалоге Гиперссылки, вызываемом командой Сервис — Параметры... — Система — Общие — Гиперссылки.

Табл. 9.1.6. Элементы управления диалога настройки гиперссылок
Элемент | Описание настройки
Автоматически создавать гиперссылки | Если опция включена, то при простановке линии разреза/сечения, стрелки направления взгляда и выносного элемента автоматически будут формироваться гиперссылки между обозначением и автоматически созданным видом (см. раздел 3.3.9.1). Если опция выключена, гиперссылки автоматически не формируется.
ALT + щелчок для перехода по гиперссылке | Если опция включена, то для активизации гиперссылки необходимо щелкнуть мышью по объекту, удерживая нажатой клавишу <Alt>. Если опция отключена, гиперссылка активизируется простым щелчком мыши по объекту.
Отображать гиперссылки во всплывающих подсказках | Если опция включена, то при приближении курсора к объекту гиперссылки во всплывающей подсказке будет показано наименование целевого объекта (см. рис. 10.2.1). Если опция выключена, наименование целевого объекта в подсказке не отображается.
Отображать значок гиперссылки на курсоре | Если опция включена, то при приближении курсора к объекту гиперссылки рядом с курсором появится значок гиперссылки. Если опция выключена, значок рядом с курсором появляться не будет.

Завершив настройку гиперссылок, нажмите кнопку OK. Для выхода из диалога без изменения настроек нажмите кнопку Отмена.


9.1.2.8. Контекстная панель

Настройка параметров отображения контекстной панели выполняется в диалоге Контекстная инструментальная панель, вызываемом командой Сервис — Параметры... — Система — Общие — Контекстная панель.

Табл. 9.1.7. Элементы управления диалога настройки параметров контекстной панели

Элемент

Описание настройки

Использовать контекстную панель

Группа опций, позволяющая включить или отключить появление контекстной панели при работе с документами различных типов.

Показывать контекстную панель

Группа опций, позволяющая выбрать вариант появления контекстной панели. Сделанная настройка используется для всех типов документов, в которых включено использование контекстной панели.

– Если обе опции отключены, то контекстная панель не появляется.

– Если обе опции включены, то контекстная панель появляется и при выделении объектов, и при вызове контекстного меню.

– Если опция при выделении включена, а опция при вызове контекстного меню отключена, то контекстная панель появляется при выделении объекта и исчезает после вызова контекстного меню выделенного объекта.

– Если опция при вызове контекстного меню включена, а опция при выделении отключена, то контекстная панель появляется только после вызова контекстного меню при наличии выделенных объектов1.
Если контекстное меню вызвано во время работы какой-либо команды, например, построения окружности, то вне зависимости от настройки контекстная панель не появляется.
  1. В текстовом документе контекстная панель появляется также при вызове контекстного меню без выделения объектов.

При выделении некоторых объектов, например, OLE-вставок, не предусмотрено появление контекстной панели.

Завершив настройку контекстной панели, нажмите кнопку OK. Для выхода из диалога без изменения настройки нажмите кнопку Отмена.


9.1.2.9. OLE

Выбор формата файла, который будет использован при вставке КОМПАС-документов в другие документы с помощью технологии OLE (см. раздел 11.4), выполняется в диалоге OLE, вызываемом командой Сервис — Параметры... — Система — Общие — OLE.

Диалог содержит две опции: EMF и BMP. По умолчанию для OLE-вставок используется формат EMF. Это уменьшает размер файла, содержащего вставки.

В некоторых случаях следует применять формат BMP вместо EMF, например:

– использование приложений, в документах которых формат EMF не обеспечивает корректную работу с OLE-вставками (например, приложения пакета Open Office),

– наличие заливок во вставляемом графическом КОМПАС-документе (при использовании формата EMF заливки могут не отображаться в OLE-вставке).

Завершив настройку, нажмите кнопку ОК. Для выхода из диалога без изменения настройки нажмите кнопку Отмена.


9.1.2.10. Мышь

Вы можете сменить направление вращения колеса мыши, используемое для «приближения»/«отдаления» изображения, на противоположное.

Настройка направления вращения колеса мыши выполняется в диалоге, вызываемом командой Сервис — Параметры... — Система — Общие — Мышь.

Диалог содержит опцию Изменить направление вращения колеса мыши.

Если опция отключена, то при вращении колеса мыши «к себе» изображение отдаляется, а при вращении «от себя» — приближается. При включении опции все происходит наоборот.

Завершив настройку, нажмите кнопку ОК. Для выхода из диалога без изменения настройки нажмите кнопку Отмена.


9.1.3. Экран

9.1. Параметры системы

9.1.3. Экран

В этом разделе:

9.1.3.1. Фон рабочего поля

9.1.3.2. Фон рабочего поля моделей

9.1.3.3. Фон надписей

9.1.3.4. Цветовая схема

9.1.3.5. Цвет текстовых элементов

9.1.3.6. Панель свойств

9.1.3.7. Закладки документов

9.1.3.8. Настройка интерфейса

9.1.3.8.1. Команды

9.1.3.8.2. Панели инструментов

9.1.3.8.3. Утилиты

9.1.3.8.4. Клавиатура

9.1.3.8.5. Меню

9.1.3.8.6. Параметры

9.1.3.8.7. Размер значков


9.1.3.1. Фон рабочего поля

Настройка цвета фона для графических, текстовых документов и спецификаций выполняется в диалоге Настройка цвета фона. Диалог появляется на экране после вызова команды Сервис — Параметры... — Система — Экран — Фон рабочего поля.

В этом диалоге вы можете выполнить следующие действия.

– Задать цвет фона документов с помощью группы элементов Цвет фона рабочего поля.

– Задать цвет фона редактирования текста с помощью группы элементов Цвет фона редактирования текста.

Цвет фона редактирования текста — это цвет, на котором отображаются во время создания и редактирования следующие объекты:

– текст и таблицы на чертеже,

– надписи, входящие в состав обозначений,

– таблицы в текстовом документе,

– объекты спецификации.

Табл. 9.1.8. Элементы управления диалога настройки цвета фона
Элемент | Описание настройки
Цвет окна, установленный в Windows | Чтобы цвет фона соответствовал общим цветовым настройкам Windows, включите эту опцию. Чтобы выбрать цвет фона рабочего поля, который будет отличаться от цветовых настроек Windows, отключите опцию. После отключения опции становится доступной кнопка выбора цвета.
Цвет | Кнопка позволяет выбрать цвет фона в стандартном диалоге выбора цвета. Доступна при отключенной опции Цвет окна, установленный в Windows.
Окно просмотра цвета | Окно служит для отображения цвета, заданного с помощью кнопки Цвет.

После завершения настройки нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.

Настройка цветов отображения документа не распространяется на режим предварительного просмотра (см. раздел 8.3). Цвет фона в этом режиме — белый, а цвета объектов зависят от настройки параметров вывода.


9.1.3.2. Фон рабочего поля моделей

Настройка цвета фона рабочего поля для документов-моделей выполняется в диалоге Настройка цвета фона для моделей, вызываемом командой Сервис — Параметры... — Система — Экран — Фон рабочего поля моделей. В этом диалоге вы можете установить сплошной цвет фона или фон с градиентным переходом от одного цвета к другому.

Табл. 9.1.9. Элементы управления диалога настройки цвета фона для моделей

Элемент

Описание настройки

Цвет окна, установленный в Windows

Чтобы цвет фона соответствовал общим цветовым настройкам Windows, включите эту опцию.

Чтобы выбрать цвет фона рабочего поля, который будет отличаться от цветовых настроек Windows, отключите опцию. После отключения опции становится доступной кнопка выбора цвета.

Цвет

Кнопка позволяет выбрать цвет фона в стандартном диалоге выбора цвета. Доступна при отключенной опции Цвет окна, установленный в Windows.

Идентичные кнопки расположены в группе задания цветов градиентного перехода. Доступны при включенной опции Использовать градиентный переход.

Использовать градиентный переход

Опция позволяет использовать при задании цвета фона градиентный переход между двумя цветами. При работе с трехмерными моделями верхняя и нижняя части поля документа окрашиваются в выбранные цвета. Между ними создается плавный переход от одного цвета к другому.

После включения опции становятся доступными кнопки задания этих цветов.

Верхний цвет

Нижний цвет

Окна просмотра цветов, между которыми формируется градиентный переход. Каждый из цветов задается с помощью соответствующей ему кнопки Цвет.

После завершения настройки нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.

Настройка цветов отображения документа не распространяется на режим предварительного просмотра (см. раздел 8.3). Цвет фона в этом режиме — белый, а цвета объектов зависят от настройки параметров вывода.


9.1.3.3. Фон надписей

Настройка фона надписей выполняется в диалоге Фон надписей. Диалог появляется на экране после вызова команды Сервис — Параметры... — Система — Экран — Фон надписей. В диалоге настраивается цвет и прозрачность фона надписей у курсора.

Табл. 9.1.10. Элементы управления диалога настройки фона надписей
Элемент | Описание настройки
Цвет фона | После включения опции становится доступной кнопка выбора цвета фона надписей. Если опция отключена, надписи у курсора отображаются без фона.
Цвет... | Кнопка позволяет выбрать цвет фона в стандартном диалоге выбора цвета. Доступна при включенной опции Цвет фона.
Прозрачность | Шкала для настройки прозрачности фона надписей. Чтобы изменить прозрачность фона, следует передвинуть мышью «ползунок» — вправо для увеличения или влево для уменьшения уровня прозрачности. Шкала доступна при включенной опции Цвет фона.

Завершив настройку фона надписей, нажмите кнопку OK. Для выхода из диалога без изменения настроек нажмите кнопку Отмена.


9.1.3.4. Цветовая схема

Настройка цветов отображения элементов документа и элементов системы выполняется в диалоге Настройка цветовой схемы, вызываемом командой Сервис — Параметры... — Система — Экран — Цветовая схема.

Элементы документа — элементы, составляющие содержимое документа. Эти элементы создает пользователь: кривые, точки, штриховки, размеры, обозначения в графическом документе; тела и поверхности в документе-модели.

Элементы системы — различные вспомогательные элементы, которые могут присутствовать в окне документа (сетка, фантомы, надписи около курсора и т.п.). Кроме того, цвет, установленный для элементов системы, используется для отображения следующих объектов:

– выделенных и подсвеченных элементов документа,

– увеличенного курсора,

– фоновых видов и слоев,

– рамок выключенных и ассоциативных видов,

– рамок, отображающихся на экране при выделении объектов и при увеличении масштаба рамкой,

– обозначений систем координат в графическом документе и эскизе,

– габаритных рамок растровых и OLE-объектов и др.

Варианты, доступные при настройке цветов элементов, представлены в таблице 9.1.11.

Табл. 9.1.11. Варианты настройки цветов элементов
Вариант | Описание настройки
Заданный при настройке | Элементы отображаются теми цветами, которые были установлены при их настройке или создании.
Инверсный цвету фона1 | Если собственный цвет элемента (заданный при его настройке) совпадает с цветом фона или близок к нему, то элемент отображается цветом, противоположным цвету фона.
Определить | Отображение всех элементов и объектов одним и тем же цветом. Цвета, установленные при их настройке, будут игнорироваться. После включения опции Определить становится доступной кнопка Цвет, позволяющая выбрать цвет элементов.
  1. Если для моделей установлен цвет фона с градиентным переходом, то инверсные цвета элементов в документах-моделях не поддерживаются. Трехмерные элементы и элементы системы отображаются цветами, заданными при их настройке.

Завершив настройку цветовой схемы, нажмите кнопку OK. Для выхода из диалога без изменения настроек нажмите кнопку Отмена.

Настройка цветов отображения документа не распространяется на режим предварительного просмотра (см. раздел 8.3). Цвет фона в этом режиме — белый, а цвета объектов зависят от настройки параметров вывода.


9.1.3.5. Цвет текстовых элементов

Настройка цвета текстовых элементов, отображаемых в окне документа, выполняется в диалоге Цвет текстовых элементов. Диалог появляется на экране после вызова команды Сервис — Параметры... — Система — Экран — Цвет текстовых элементов. В этом диалоге вы можете задать цвет шрифта текстовых элементов и цвет подчеркивания при проверке правописания.

Табл. 9.1.12. Элементы управления диалога настройки цвета текстовых элементов

Элемент

Описание настройки

Цвет...

Кнопка позволяет задать цвет того текстового элемента, в строке которого она расположена. После нажатия кнопки открывается стандартный диалог Windows выбора цвета.

Ссылки

Элементы управления группы позволяют задать цвет текста ссылок в разном состоянии. Кнопка Цвет... доступна, если включена опция, соответствующая состоянию ссылки. Если опция выключена, то настройка цвета невозможна и ссылка отображается черным цветом.

– Рабочие ссылки — ссылки, сохраняющие связь с объектом-источником.

– Нерабочие ссылки — ссылки, потерявшие связь с объектом-источником (о ссылках на объекты см. раздел 3.4.1.4).

– Требующие обновления ссылки — ссылки, в которых еще не отражены изменения источника. Ссылки, требующие обновления, могут появляться в отчетах с данными в виде ссылок (см. раздел 5.2.3.7) и в ассоциативных отчетах (см. раздел 5.2.3.8) после изменения документа — источника отчета.

Номера позиций с объектами спецификации

Опция позволяет управлять цветовым оформлением обозначений позиций, которые включены в состав объектов спецификации.

При включенной опции доступна кнопка Цвет..., позволяющая задать цветовое оформление обозначений позиций.

Если опция отключена, кнопка Цвет... недоступна. Обозначения будут отображаться черным цветом.

Подчеркивание

Элементы управления группы позволяют задать цвет подчеркивания следующих фрагментов текста:

– в которых по результатам проверки правописания предполагаются орфографические и грамматические ошибки,

– для которых не задан язык проверки правописания или в качестве признака языка выбран вариант Без проверки.

О проверке правописания см. раздел 4.1.3.

Завершив настройку цвета текстовых элементов, нажмите кнопку OK. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.

Настройка цветов отображения документа не распространяется на режим предварительного просмотра (см. раздел 8.3). Цвет фона в этом режиме — белый, а цвета объектов зависят от настройки параметров вывода.


9.1.3.6. Панель свойств

Настройка параметров отображения Панели свойств выполняется в диалоге Оформление панели свойств. Диалог появляется на экране после вызова команды Сервис — Параметры... — Система — Экран — Панель свойств.

Табл. 9.1.13. Элементы управления диалога настройки оформления Панели свойств

Элемент

Описание настройки

«Корешки» вкладок

Группа элементов позволяет настроить внешний вид «корешков» вкладок и надписей на них.

Шрифт

Раскрывающийся список позволяет выбрать название шрифта. Список содержит все шрифты, подключенные в Windows.

Цвет

Кнопка позволяет изменить цвет символов названия активной вкладки. Вызывает стандартный диалог выбора цветов. Названия неактивных вкладок отображаются черным цветом.

Размер в пикселах

Поле позволяет задать значение высоты символов (в пикселах). Значение вводится вручную или задается с помощью счетчика.

Курсив

Опция позволяет задать курсивное начертание символов для названия активной вкладки.

Жирный

Опция позволяет задать утолщенное начертание символов для названия активной вкладки.

Вид

Варианты отображения «корешков» вкладок.

При выборе варианта Объемные:

– кроме надписей на «корешках» будут отображаться пиктограммы, символизирующие назначение вкладок,

– ширина «корешков» будет изменяться в соответствии с шириной Панели свойств, благодаря чему отпадает необходимость в прокрутке «корешков».

При выборе варианта Плоские на «корешках» будут отображаться лишь надписи, а ширина «корешков» меняться не будет.

Параметры

Группа элементов позволяет настроить отображение имен параметров и расположить кнопки управления допусками.

Показывать имена

Опция, включение которой означает, что рядом с элементами управления будут отображаться их названия.

Если эта опция активна, можно выбрать вариант отображения имен параметров — При оптимальном размещении или Всегда.

Кнопки управления допусками

Опция, включение которой означает, что рядом с полем величины (линейной, угловой) на Панели свойств будет находиться кнопка управления допуском этой величины.

Сброс

Кнопка позволяет восстановить умолчательные параметры отображения Панели свойств.

Окно просмотра

Окно служит для отображения внешнего вида настраиваемых объектов. Все произведенные изменения немедленно показываются в этом окне.

После завершения настройки параметров отображения Панели свойств нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.

Если Панель свойств находится на экране, то указанный диалог можно вызвать командой Оформление Панели свойств... из ее контекстного меню.

Кроме того, вы можете настроить оформление отдельных элементов Панели свойств, воспользовавшись командами контекстного меню Показывать имена параметров, а также Вид корешков вкладок.

Вы можете также настроить размер значков на Панели свойств, см. раздел 9.1.3.8.7.


9.1.3.7. Закладки документов

Управление отображением закладок документов и настройка их внешнего вида выполняется в диалоге Настройка закладок документов. Диалог появляется на экране после вызова команды Сервис — Параметры... — Система — Экран — Закладки документов. Диалог можно вызвать также с помощью команды Настроить... из контекстного меню закладки документа.

Табл. 9.1.14. Элементы управления диалога настройки закладок документов
Элемент | Описание настройки
Показывать закладки | Группа опций, управляющая отображением закладок на экране. При включенной опции Показывать закладки на экране отображаются закладки открытых документов.
Вверху | При включенной опции закладки документов располагаются над окном текущего документа.
Внизу | При включенной опции закладки документов располагаются под окном текущего документа.
Полное имя файла | При включенной опции на закладке отображается имя, включающее полный путь к файлу.
Показывать иконки | При включенной опции слева на закладке отображается иконка типа документа.
Цветные закладки документов | При включенной опции закладки отображаются разноцветными.
Показывать кнопку быстрого закрытия на активной закладке | При включенной опции справа на активной закладке отображается кнопка Закрыть для закрытия активного окна. При выключенной опции кнопка Закрыть отображается справа на строке закладок.
Ширина закладок | Группа элементов, управляющих шириной закладок.
Автонастройка | Выбор этого варианта означает, что все закладки отображаются в окне КОМПАС-3D. Если ширина закладки меньше имени файла, то имя файла обрезается и заканчивается многоточием.
Максимальная ширина закладки, пикс. | Выбор этого варианта означает, что максимальная ширина закладки не может быть больше заданной величины (в пикселах). Закладки отображаются различными по ширине в зависимости от длины имени файла. Если ширина закладки меньше имени файла, то имя файла обрезается и заканчивается многоточием. Если все закладки не умещаются в окне КОМПАС-3D, то одна или несколько закладок не отображаются. Допустимый диапазон ширины закладок 50–1000 пикс.
По имени файла | Выбор этого варианта означает, что имя файла отображается на закладке полностью. Закладки отображаются различными по ширине в зависимости от длины имени файла. Если все закладки не умещаются в окне КОМПАС-3D, то одна или несколько закладок не отображаются. Если ширина закладки превышает размер окна КОМПАС-3D,то имя файла обрезается и заканчивается многоточием.

Завершив настройку отображения закладок документов, нажмите кнопку OK. Для выхода из диалога без изменения настроек нажмите кнопку Отмена.


9.1.3.8. Настройка интерфейса

В этом разделе:

9.1.3.8.1. Команды

9.1.3.8.2. Панели инструментов

9.1.3.8.3. Утилиты

9.1.3.8.4. Клавиатура

9.1.3.8.5. Меню

9.1.3.8.6. Параметры

9.1.3.8.7. Размер значков


9.1.3.8.1. Команды

Вы можете настроить состав Главного меню инструментальных панелей (см. раздел 9.4.2.1).

Эта настройка выполняется в диалоге Команды, который появляется на экране после вызова команды Сервис — Параметры... — Система — Экран — Настройка интерфейса — Команды или Сервис — Настройка интерфейса — Команды.

Табл. 9.1.15. Элементы управления диалога настройки состава команд
Элемент | Описание настройки
Категории | Поле содержит перечень категорий команд системы КОМПАС-3D.
Команды | Поле содержит перечень команд, входящих в выбранную категорию.
Описание | В поле приводится описание назначения выбранной команды.

В общем случае название категории и список команд, входящих в нее, аналогичны соответствующему меню или инструментальной панели (например, Геометрия). В категории Все команды команды всех меню и инструментальных панелей располагаются в алфавитном порядке. В категорию Дополнительно в основном входят команды контекстных меню и контекстных панелей графического документа, а также контекстного меню режима просмотра перед печатью. Отдельные команды могут одновременно принадлежать нескольким категориям.

Выберите категорию и название команды в соответствующих полях. «Перетащите» команду на нужную панель или в нужное меню.

Для закрытия диалога нажмите кнопку ОК или Отмена.

Обратите внимание на то, что отмена изменений по нажатию кнопки Отмена не происходит. Для возврата интерфейса к прежнему виду измените настройку повторно.


9.1.3.8.2. Панели инструментов

Вы можете создавать пользовательские инструментальные панели и размещать на них любые команды (см. раздел 9.4.2.2). Для этого используется диалог Панели инструментов, который вызывается командой Сервис — Параметры... — Система — Экран — Настройка интерфейса — Панели инструментов или Сервис — Настройка интерфейса — Панели инструментов.

Табл. 9.1.16. Элементы управления диалога настройки инструментальных панелей

Элемент

Описание настройки

Панели

Поле содержит перечень инструментальных панелей системы КОМПАС-3D. «Галочка» рядом с названием панели означает, что эта панель отображается в окне программы. Чтобы отменить отображение панели, щелкните мышью по «галочке» рядом с ее названием.

Инструментальные панели, включенные в компактную панель (см. раздел 1.2.2.1.1), не содержатся в перечне.

Сбросить

Кнопка позволяет привести в умолчательное состояние выбранную панель. Если вы добавляли или удаляли команды панели или настраивали ее отображение, то после нажатия кнопки Сбросить все изменения будут отменены.

Сбросить все

Кнопка позволяет привести в умолчательное состояние все инструментальные панели и меню.

Новая...

Кнопка позволяет создать пользовательскую инструментальную панель.

Переименовать

Кнопка позволяет изменить название пользовательской инструментальной панели.

Удалить

Кнопка позволяет удалить пользовательскую инструментальную панель.

Подписи к кнопкам

Включите опцию, чтобы на выбранной панели рядом с кнопками отображались названия команд1.
  1. Если панель прикреплена к вертикальной границе окна, отображение подписей невозможно.

Для закрытия диалога нажмите кнопку ОК или Отмена.

Обратите внимание на то, что отмена изменений по нажатию кнопки Отмена не происходит. Для возврата интерфейса к прежнему виду измените настройку повторно.


9.1.3.8.3. Утилиты

Вы можете добавлять пользовательские команды для открытия файлов приложений, документов и т.п. в меню Сервис системы КОМПАС-3D (см. раздел 9.4.2.4).

Добавление команд выполняется в диалоге Утилиты. Диалог появляется на экране после вызова команды Сервис — Параметры... — Система — Экран — Настройка интерфейса — Утилиты или Сервис — Настройка интерфейса — Утилиты.

Табл. 9.1.17. Элементы управления диалога Утилиты
Элемент | Описание настройки
Меню | Список пользовательских команд, вызывающих утилиты. Над списком располагаются управляющие кнопки. Кнопка Новый позволяет включить в список новую команду. После нажатия этой кнопки в конце списка появляется пустая строка. Введите в нее название команды. Кнопка Удалить позволяет удалить выделенную команду из списка. Кнопки Переместить вверх и Переместить вниз управляют расположением команд в меню.
Команда | Поле содержит полное имя файла, который будет открываться при вызове команды. Может быть заполнено с клавиатуры, однако рекомендуется использовать стандартные средства операционной системы. Для этого необходимо нажать кнопку Обзор справа от поля. На экране появится стандартный диалог открытия файлов Windows. Выберите нужный файл и нажмите кнопку Открыть. Полное имя файла появится в поле Команда. Если выбран исполняемый файл, то при вызове созданной команды будет запущено приложение. Если вы укажете файл, который не является исполняемым, то при вызове команды будет запущено приложение Windows, сопоставленное с данным типом файлов.
Параметры | Поле для ввода параметров запуска команды.
Рабочая папка | Поле для ввода пути к папке приложения, запускаемого командой.

Для закрытия диалога нажмите кнопку ОК или Отмена.

Обратите внимание на то, что отмена изменений по нажатию кнопки Отмена не происходит. Для возврата меню Сервис к прежнему виду измените настройку повторно.


9.1.3.8.4. Клавиатура

Вы можете назначить командам клавиши или сочетания клавиш для быстрого вызова этих команд (см. раздел 9.4.2.3).

Эта настройка выполняется в диалоге Клавиатура, который появляется на экране после вызова команды Сервис — Параметры... — Система — Экран — Настройка интерфейса — Клавиатура или Сервис — Настройка интерфейса — Клавиатура.

Табл. 9.1.18. Элементы управления диалога настройки клавиш быстрого вызова команд
Элемент | Описание настройки
Категории | Поле содержит перечень категорий команд системы КОМПАС-3D.
Команды | Поле содержит перечень команд, входящих в выбранную категорию.
Описание | В поле приводится описание назначения выбранной команды.
Установить сочетание | Раскрывающийся список содержит перечень типов документов системы КОМПАС-3D. Вы можете выбрать тип документа, для которого будет действовать комбинация клавиш для вызова команды. Выбор варианта По умолчанию означает, что клавиатурная комбинация будет действовать при работе с документами тех типов, в которых она не является системной и не используется для вызова другой команды. При работе с документами остальных типов настройка игнорируется, и комбинация используется согласно своему назначению.
Текущие | Поле содержит список действующих клавиатурных комбинаций для вызова выбранной команды.
Новое сочетание клавиш: | Поле для указания клавиши или комбинации клавиш, назначаемой команде. Чтобы задать клавишу или комбинацию, просто нажмите на клавиатуре нужную клавишу (клавиши). В поле Новое сочетание клавиш появятся названия нажатой клавиши (клавиш), а ниже поля — информационное сообщение. Если выбранная клавиша (клавиши) уже используется для вызова другой команды, то показывается ее название (если команда не содержится ни в одном меню, а вызывается, например, кнопкой на Панели специального управления, отображается строка «Команда вне категорий»), а если не используется — строка «Не связано».
Связать | Кнопка позволяет назначить команде заданную клавишу или комбинацию клавиш. Доступна, если эта клавиша или комбинация не назначена другой команде.
Удалить | Кнопка позволяет удалить название клавиши (клавиш) из списка назначенных данной команде.
Сбросить все | Кнопка позволяет восстановить умолчательные клавиатурные комбинации вызова команд системы КОМПАС-3D.

Для закрытия диалога нажмите кнопку ОК или Отмена.

Обратите внимание на то, что отмена изменений по нажатию кнопки Отмена не происходит. Для возврата к прежним назначениям измените настройку повторно.


9.1.3.8.5. Меню

Управление отображением Главного меню и контекстных меню оконных закладок выполняется в диалоге Меню. Диалог появляется на экране после вызова команды Сервис — Параметры... — Система — Экран — Настройка интерфейса — Меню или Сервис — Настройка интерфейса — Меню.

Табл. 9.1.19. Элементы управления диалога настройки отображения меню
Элемент | Описание настройки
Показать меню | Выберите из раскрывающегося списка вариант Главного меню, который необходимо отобразить в текущем окне для настройки. Чтобы изменить состав меню, перейдите на вкладку Команды.
Показать контекстное меню | Чтобы настроить контекстное меню оконных закладок, выберите в этом списке строку Оконные закладки. Чтобы изменить состав меню, перейдите на вкладку Команды.
Сбросить | Эта кнопка позволяет отменить все изменения в меню (Главном или контекстном), т.е. привести его к умолчательному виду.
Эффект | Раскрывающийся список визуальных эффектов, которые могут сопровождать раскрытие списка команд.
Показывать тени меню | Опция позволяет показывать тени при отображении меню.

Для закрытия диалога нажмите кнопку ОК или Отмена.

Обратите внимание на то, что отмена изменений по нажатию кнопки Отмена не происходит. Для возврата интерфейса к прежнему виду измените настройку повторно.


9.1.3.8.6. Параметры

Вы можете настроить отображение:

– всплывающих подсказок — «ярлычков» на кнопках инструментальных и компактных панелей,

– кнопок на инструментальных и компактных панелях,

– команд Главного меню.

Данная настройка выполняется в диалоге Параметры. Диалог появляется на экране после вызова команды Сервис — Параметры... — Система — Экран — Настройка интерфейса — Параметры или Сервис — Настройка интерфейса — Параметры.

Табл. 9.1.20. Элементы управления диалога настройки элементов интерфейса
Элемент | Описание настройки
Отображать подсказки для кнопок | Опция позволяет управлять отображением всплывающих подсказок с названиями команд при наведении курсора на кнопку.
Включить в подсказки сочетания клавиш | Опция позволяет включать во всплывающую подсказку комбинации клавиш для быстрого вызова команды. Опция доступна при включенном отображении подсказок для кнопок.
Показывать недавно использованные команды первыми | Опция позволяет отображать наиболее часто используемые команды меню в первую очередь. Чтобы все команды отображались одновременно, отключите опцию.
Показывать полное меню после небольшой задержки | Опция позволяет управлять способом показа полного меню. Если задержать указатель мыши на открытом меню при включенной опции, то через короткий промежуток времени будут выведены все входящие в это меню команды. Если опция выключена, то, чтобы раскрыть полное меню, необходимо нажать кнопку Раскрыть (нижняя строка частично открытого меню).
Сбросить все настройки | Кнопка позволяет вернуть в умолчательное состояние перечень команд, которые отображаются в первую очередь при раскрытии меню при включенной опции Показывать недавно использованные команды первыми.

Для закрытия диалога нажмите кнопку ОК или Отмена.

Обратите внимание на то, что отмена изменений по нажатию кнопки Отмена не происходит. Для возврата интерфейса к прежнему виду измените настройку повторно.


9.1.3.8.7. Размер значков

Размер пиктограмм команд меню и кнопок вызова команд на инструментальных панелях можно изменять. Для этого служит диалог Размер значков, вызываемый командой Сервис — Параметры... — Система — Экран — Настройка интерфейса — Размер значков или Сервис — Настройка интерфейса — Размер значков.

Табл. 9.1.21. Элементы управления диалога настройки размера значков
Элемент | Описание настройки
Единый | Раскрывающийся список позволяет задать размер элементов управления (переключателей, кнопок, пиктограмм и т.п.) для всех элементов интерфейса. Данный список доступен по умолчанию — соответствующая ему опция включена. Чтобы задать размер элементов управления отдельно для каждого элемента интерфейса, отключите опцию.
Инструментальные панели | Раскрывающийся список позволяет задать размер кнопок вызова команд и пиктограмм на них.
Меню | Раскрывающийся список позволяет задать размер пиктограмм команд меню системы КОМПАС-3D.
Панель свойств, окна “Свойства” и “Нумерация“ |
Элементы управления | Раскрывающийся список позволяет задать размер элементов управления на вкладках Панели свойств (переключателей, опций и т.п.), а для окон Свойства и Нумерация — размер элементов в таблице.
Панель специального управления | Раскрывающийся список позволяет задать размер кнопок на Панели специального управления Панели свойств, а для окон Свойства и Нумерация — размер кнопок на инструментальной панели.
Дерево документа | Раскрывающийся список позволяет задать размер пиктограмм в Дереве документа, а также в дереве окна Редактора свойств.

Команды в меню и кнопки на инструментальных панелях могут отображаться в виде пиктограмм, текста или пиктограмм и текста. Выбор варианта отображения описан в разделе 9.4.2.

Завершив настройку, нажмите кнопку OK. Для выхода из диалога без изменения настроек нажмите кнопку Отмена.


9.1.4. Файлы

9.1. Параметры системы

9.1.4. Файлы

В этом разделе:

9.1.4.1. Расположение

9.1.4.2. Установка прав доступа

9.1.4.3. Резервное копирование

9.1.4.4. Автосохранение

9.1.4.5. Сохранение конфигурации


9.1.4.1. Расположение

В любой момент работы с системой вы можете получить сведения о расположении файла KOMPAS.ini, конфигурационных файлов, папок для временных, системных файлов, папок для файлов документов, библиотек, шаблонов, профилей. Для этого используется диалог Расположение системных файлов, вызываемый командой Сервис — Параметры... — Система — Файлы — Расположение. В этом диалоге отображаются текущие пути к вышеназванным файлам и папкам.

Перечень файлов и папок приведен в таблице 9.1.22.

Табл. 9.1.22.
Наименование | Описание
Файл Kompas.ini | Файл KOMPAS.ini, содержащий информацию о расположении конфигурационных файлов и системных папок. Файл KOMPAS.ini используется, если расположение должно отличаться от умолчательного (сведения об умолчательном расположении этих файлов и папок хранятся внутри системы в виде значений переменных среды КОМПАС-3D, переменные среды описаны в разделе 9.5.4). Кроме указанных сведений, может содержать дополнительную информацию о параметрах работы системы.
Параметры новых документов | Файл *.prj, содержащий информацию о настройках новых документов — о всех настройках, сделанных на вкладке Новые документы общего настроечного диалога.
Параметры системы | Файл *.cfg, содержащий информацию о настройках системы — о всех настройках, сделанных на вкладке Система общего настроечного диалога.
Параметры рабочего окна | Файл *.dsk, содержащий информацию о настройках рабочего окна системы.
Временные файлы | Папка для размещения временных файлов, а также автоматически сохраненных в процессе работы файлов документов КОМПАС-3D.
Рабочая папка | Папка для размещения КОМПАС-документов. Эта папка по умолчанию предлагается при первом открытии или сохранении документа.
Системные файлы | Папка, содержащая служебные файлы: файлы пользовательских меню, допусков, справочный файл плотностей материалов, библиотеки стилей и т.д.При настройке текстовых шаблонов, библиотек отверстий и эскизов по умолчанию предполагается размещение файлов graphic.tdp, holelib.lfr и skchlib.lfr именно в этой папке.
Файлы библиотек | Папка, содержащая файлы библиотек. Эта папка по умолчанию предлагается первой при добавлении библиотек в Менеджер библиотек.
Шаблоны | Папка, содержащая файлы шаблонов КОМПАС-документов. При создании документов будут предлагаться шаблоны, находящиеся в этой папке. Эта же папка по умолчанию предлагается для размещения вновь создаваемых шаблонов.
Профили пользователя | Папка, содержащая файлы профилей. При выборе профилей предлагаются находящиеся в этой папке. Эта же папка по умолчанию предлагается для размещения вновь создаваемых профилей.
Таблицы сгибов | Папка, содержащая файлы таблиц сгибов. При выборе таблицы сгибов предлагаются таблицы, находящиеся в этой папке. Эта же папка по умолчанию предлагается при записи в файл таблицы сгибов, хранящейся в листовой детали.
Таблицы резьб | Папка, содержащая файлы таблиц резьб. При выборе таблицы резьб предлагаются таблицы, находящиеся в этой папке.
Шаблоны мультилиний | Папка, содержащая файлы шаблонов мультилиний. При создании документов будут предлагаться шаблоны, находящиеся в этой папке. Эта же папка по умолчанию предлагается для размещения вновь создаваемых шаблонов.
Конфигурации плоттеров/принтеров | Папка, содержащая файлы конфигураций устройств печати. При сохранении конфигураций будет по умолчанию предлагаться эта папка. При загрузке конфигураций будут предлагаться находящиеся в этой же папке.
Файлы изображений | Папка, содержащая файлы с примерами изображений, которые можно использовать для проверки гладкости поверхностей деталей способом Отражение среды.
Коллекция математических выражений | Файл collection.law, содержащий математические выражения, которые могут использоваться для присвоения значений переменным в Окне переменных и задания координат точек при построении кривой по закону. Выражения, содержащиеся в файле, отображаются в диалоге Вставка математического выражения при выборе группы Из файла коллекции.
Файл неуказанных предельных отклонений размеров | Файл Gen_tol.ttl, содержащий значения предельных отклонений линейных и угловых размеров по общим допускам. Эти значения используются в моделях для размеров эскизов и параметров операций, которым не назначены индивидуальные допуски.

Если система КОМПАС-3D была запущена без использования файла KOMPAS.ini, то в диалоге отображаются умолчательные пути к файлам и папкам (путь к файлу KOMPAS.ini отсутствует). Чтобы записать файл KOMPAS.ini, нажмите кнопку Создать Kompas.ini. Файл KOMPAS.ini, содержащий текущие настройки, будет открыт в приложении, зарегистрированном в Windows для ini-файлов. Если ни одно приложение не зарегистрировано, выберите в появившемся диалоге любой текстовый редактор. Отредактируйте и сохраните файл. Структура и синтаксис файла KOMPAS.ini описана в разделе 9.5.3.

При запуске системы КОМПАС-3D поиск файла KOMPAS.ini ведется только в папке с файлом KOMPAS.exe, поэтому вновь созданный файл KOMPAS.ini автоматически располагается в этой папке. Размещение его в другой папке равносильно отсутствию этого файла.

Если в момент запуска системы файл KOMPAS.ini уже существует, то в диалоге отображается текущий путь к этому файлу. Чтобы отредактировать файл, нажмите кнопку Редактировать Kompas.ini. Внесите необходимые изменения и сохраните файл.

Вновь созданный или отредактированный файл KOMPAS.ini будет использован в следующем сеансе работы с КОМПАС-3D.

Отмена создания или редактирования файла KOMPAS.ini невозможна. При необходимости удалите (переименуйте) файл на диске или отредактируйте его заново.


9.1.4.2. Установка прав доступа

При организации совместной сетевой работы вы можете установить параметры доступа к подчиненным файлам (библиотекам стилей, типов атрибутов, оформлений и т.п.), а также включить контроль за изменением подчиненных файлов, файлов-источников вставок, сделанных внешней ссылкой (фрагменты, компоненты и т.п.) и документов, открытых для чтения.

Установка прав доступа к файлам производится в диалоге Установка прав доступа, вызываемом командой Сервис — Параметры... — Система — Файлы — Установка прав доступа.

Табл. 9.1.23. Элементы управления диалога настройки прав доступа

Элемент

Описание настройки

Уровень доступа
к подчиненным
файлам

Раскрывающийся список позволяет настроить права доступа к подчиненным файлам (библиотекам стилей, типов атрибутов и т.п).

Подчиненными по отношению к документам являются такие файлы, как библиотеки стилей, оформлений, типов атрибутов и т.п.

Варианты уровней доступа представлены в таблице 9.1.24.

Контроль
за изменением
файлов

Опция позволяет управлять контролем изменений совместно используемых файлов, а также файлов, открытых только для чтения. По умолчанию опция включена.

Включение опции означает, что система будет проверять, не был ли файл изменен кем-то из других пользователей в течение вашего сеанса работы. При положительном результате проверки на экране появится сообщение с предложением перечитать файл (см. раздел 10.3.1.3).

Периодичность
контроля, мин

Поле позволяет ввести или задать при помощи счетчика значение интервала времени, через который система будет выполнять контроль изменения совместно используемых файлов. По умолчанию значение равно 1 минуте.

Уведомлять при открытии файлов, доступных только для чтения1

Опция позволяет управлять оповещениями при открытии файлов, доступных только для чтения. Опция доступна, если включен контроль за изменением файлов.

По умолчанию оповещения отключены.

Отображать у компонента доступ
Только чтение1

Опция позволяет управлять отображением пиктограммы Только чтение в Дереве построения модели у компонентов (деталей, сборок), файлы-источники которых доступны только для чтения (см. Приложение I).

Данная пиктограмма отображается перед разделом Компоненты, группой или ветвью одинаковых компонентов, если все файлы-источники доступны только для чтения.

По умолчанию отображение выключено.

  1. В данном случае доступ Только чтение означает, что файлу назначен системный атрибут «Только чтение» в свойствах файла.
    Опция не распространяется на случаи установки временного доступа только чтение на открываемый файл, выполняемой, например, включением опции «Только чтение» в диалоге открытия файлов.

Табл. 9.1.24. Уровни доступа к подчиненным файлам

Уровень доступа

Описание

Разрешить чтение

Разрешает на других рабочих местах только чтение файлов, подчиненных документам, которые открыты на данном рабочем месте. Например, если вы открыли чертеж, использующий стиль линии из какой-либо библиотеки, то другие пользователи (на других рабочих местах) смогут применять стили из этой библиотеки, но не смогут изменять их. Кроме того, они смогут скопировать файл используемой вами библиотеки стилей линий, но не смогут переименовать или удалить его.

После закрытия чертежа, использующего библиотеку, она станет полностью доступна для других пользователей.

Разрешить чтение
и запись

Разрешает на других рабочих местах чтение, редактирование и сохранение файлов, подчиненных документам, которые открыты на данном рабочем месте.

Если опция Контроль за изменением файлов включена, то в случае изменения подчиненного файла другим пользователем вы получите сообщение об этом (см. раздел 10.3.1.3).

После завершения настройки прав доступа к файлам нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.1.4.3. Резервное копирование

Резервное копирование обеспечивает максимальную сохранность документов. Поэтому рекомендуется всегда использовать хотя бы одну из возможностей резервного сохранения файлов.

Настройка резервного копирования производится в диалоге Резервное копирование документов, вызываемом командой Сервис — Параметры... — Система — Файлы — Резервное копирование.

Табл. 9.1.25. Элементы управления диалога настройки резервного копирования

Элемент

Описание настройки

Сохранять
исходную копию

Если эта опция включена, то система сохраняет в заданном каталоге исходную копию документа. Копия сохраняется перед выполнением самой первой команды записи документа на диск во время сеанса работы. Сохранение выполняется с копированием полного пути доступа к файлу. Например, если мы работаем с чертежом, который был сохранен в файл c:\Work\First.cdw, а в качестве папки для сохранения исходных файлов указан d:\Original, то копия исходного файла будет записана как d:\Original\c\Work\First.cdw.

Обзор...

Кнопка позволяет указать папку для сохранения исходной копии документа. Кнопка доступна, если включена опция Сохранять исходную копию. После указания папки полный путь к ней отображается в поле В каталог.

Сохранять
предыдущую
копию

Если эта опция включена и указана папка для сохранения, то система сохраняет предыдущую копию состояния документа. Копия сохраняется каждый раз при выполнении команды записи документа на диск во время сеанса работы. Сохранение выполняется с копированием полного пути к файлу. Например, если мы работаем с чертежом c:\Work\First.cdw, а в качестве папки для сохранения предыдущих копий указана папка e:\Backup, то предыдущая копия будет записываться как e:\Backup\c\Work\First.cdw.

Если опция включена, но имя папки не указано, запись предыдущей копии выполняется в ту же папку, где находится сам документ. При этом имя файла копии формируется по следующему шаблону: <имя файла документа> + <.> + <расширение имени> + <.> + <bak> (например, example.frw.bak). Восстановление документов из файлов *.bak описано в разделе 10.3.2.2.

Обзор...

Кнопка позволяет указать папку для сохранения предыдущей копии документа. Кнопка доступна, если включена опция Сохранять предыдущую копию. После указания папки полный путь к ней отображается в поле В каталог.

В одном каталоге
с документом

Кнопка позволяет явно отказаться от сохранения предыдущей копии в папке, указанной при помощи кнопки Обзор.... После нажатия кнопки В одном каталоге с документом поле В каталог очистится. Копия будет записываться в ту же папку и с тем же именем, что и сам документ, но с расширением *.bak.

Сохранять
«зеркальную»
копию

«Зеркальное» копирование является дополнительным средством резервного сохранения данных, при котором создается дополнительная, дублирующая копия документа в другом месте одного диска или на другом физическом диске (например, на диске удаленного сервера с повышенной надежностью).

Если опция включена, то система будет сохранять «зеркальную» копию документа в заданной папке каждый раз при выполнении команды записи на диск во время сеанса работы. Сохранение выполняется с копированием полного пути доступа к файлу. Например, если мы работаем с чертежом c:\Work\First.cdw, а в качестве папки для сохранения предыдущих копий g:\Mirror, то «зеркальная» копия будет записываться как g:\Mirror\c\Work\First.cdw.

Обзор...

Кнопка позволяет указать папку для сохранения «зеркальной» копии документа. Кнопка доступна, если включена опция Сохранять «зеркальную» копию. После указания папки полный путь к ней отображается в поле В каталог.

После завершения настройки резервного копирования нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.

В папках, указанных для размещения резервных копий, при сохранении файлов создается структура папок, соответствующая расположению на диске основного файла документа. Имя верхней папки в создаваемой структуре соответствует имени диска, на котором сохраняется основной файл. Например, чертеж First.cdw сохраняется в папке C:\Work\, а в качестве папки для сохранения копии указана D:\Reserve. Полный путь к файлу копии документа будет следующим D:\Reserve\C\Work\First.cdw.

Для сохранения резервных копий разных типов не рекомендуется указывать одинаковые папки, поскольку при этом возможна потеря информации. При попытке завершить настройку резервного копирования с такими параметрами, на экране появится предупреждающее сообщение (рис. 9.1.5).

Рис. 9.1.5.

Кнопки этого сообщения позволяют подтвердить настройку или отказаться от нее. При отказе можно изменить папки для резервного копирования. Если настройка подтверждена, резервное копирование будет выполняться. При этом создается только один файл, аналогичный текущему состоянию сохраненного основного файла.


9.1.4.4. Автосохранение

Автоматическое сохранение документов обеспечивает максимальную сохранность результатов работы при различных сбоях (аварийный выход из системы, перебои электропитания, аппаратные ошибки компьютера и т.п.). Поэтому при работе с системой рекомендуется всегда включать автосохранение.

Настройка параметров автосохранения файлов документов производится в диалоге Автоматическое сохранение файлов документов, вызываемом командой Сервис — Параметры... — Система — Файлы — Автосохранение.

Табл. 9.1.26. Элементы управления диалога настройки автосохранения
Элемент | Описание настройки
Автоматическое сохранение Включить | Опция позволяет включить или отключить автосохранение файлов. При включенном автосохранении в указанной папке с заданной периодичностью создаются файлы автосохранения (см. раздел 10.3.3.1). Из этих файлов можно восстановить документы в случае в аварийного завершения работы (см. раздел 10.3.3.2).
Периодичность сохранения, мин | Поле позволяет ввести или задать с помощью счетчика величину интервала времени, через который система будет выполнять автоматическое сохранение файлов.
Сохранять в: | Группа элементов позволяет указать папку для автоматического сохранения файлов. По умолчанию автосохранение выполняется в системную папку временных файлов. Чтобы указать другую папку для автосохранения, включите опцию В другой каталог, нажмите кнопку Обзор... и выберите нужную папку.

После завершения настройки автосохранения нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.1.4.5. Сохранение конфигурации

Настройка параметров сохранения конфигурации системы КОМПАС-3D выполняется в диалоге Сохранение конфигурации системы, вызываемом командой Сервис — Параметры... — Система — Файлы — Сохранение конфигурации.

Табл. 9.1.27. Элементы управления диалога настройки параметров сохранения конфигурации

Элемент

Описание настройки

Настройки рабочего окна

Группа опций позволяет выбрать вариант сохранения настроек, определяющих внешний вид главного окна системы.

Если сохранение включено, то информация о состоянии рабочего окна записывается в файл *.dsk. Перечень сведений, составляющих информацию о состоянии рабочего окна, представлен в таблице 9.5.1.

Если сохранение отключено, то файл *.dsk не создается.

Настройки системы

Группа опций позволяет выбрать вариант сохранения системных настроек. К системным настройкам относятся настройки, произведенные на вкладке Система общего диалога настройки параметров.

Если сохранение включено, то информация о настройках системы записывается в файл *.cfg 1 .

Файл *.cfg записывается на диск как при включенном, так и при отключенном сохранении системных настроек. В последнем случае он содержит только информацию о том, что сохранение настроек отключено. При этом в текущем сеансе работы будут действовать имеющиеся настройки системы, а в следующем — умолчательные.

Настройки для новых документов

Группа опций позволяет выбрать вариант сохранения настроек новых документов. К настройкам новых документов относятся настройки, произведенные на вкладке Новые документы общего диалога настройки параметров.

Если сохранение включено, то информация о настройках новых документов записывается в файл *.prj.

Если сохранение отключено, то файл *.prj не создается.

Состояние открытых документов

Группа опций позволяет выбрать вариант записи состояния открытых для редактирования документов. Варианты доступны при включенном сохранении настроек рабочего окна.

Если сохранение состояния открытых окон включено, то информация об этом заносится в файл *.dsk. В следующем сеансе работы КОМПАС-3D автоматически будут открыты те же документы, что и на момент выхода из предыдущего сеанса.

Если сохранение состояния открытых окон отключено, то в новом сеансе работы КОМПАС-3D автоматическое открытие документов не производится.
  1. В этот файл не заносятся настройки интерфейса (они записываются в файл *.dsk), а также сведения, отображающиеся в диалоге просмотра расположения системных файлов и папок.

После завершения настройки параметров сохранения конфигурации нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.

Имеющуюся настройку конфигурации можно сохранить в файле профиля (см. раздел 9.4.1). Впоследствии применение этого профиля позволит быстро сменить текущую настройку на ту, которая записана в профиле.

Обратите внимание на то, что в файлы *.cfg и *.prj, а также в файл профиля заносятся лишь те настройки, которые были изменены по сравнению с умолчательными. Сведения о неизмененных параметрах не записываются.

Во время чтения файлов *.cfg и *.prj или применения профиля параметрам, информация о которых отсутствует, присваиваются умолчательные значения. При этом умолчательный путь к папке SYS берется из файла KOMPAS.ini (см. раздел 9.5.3), а при его отсутствии определяется по значению соответствующей переменной среды КОМПАС (см. раздел 9.5.4).


9.1.5. Печать

9.1. Параметры системы

9.1.5. Печать

В этом разделе:

9.1.5.1. Общие настройки

9.1.5.2. Фильтры вывода на печать


9.1.5.1. Общие настройки

Общие настройки печати документов выполняются в диалоге Общие настройки, вызываемом командой Сервис — Параметры... — Система — Печать — Общие настройки.

Табл. 9.1.28. Элементы управления диалога общих настроек печати

Элемент

Описание настройки

Размер списка последних файлов заданий на печать

Поле позволяет ввести или задать с помощью счетчика количество объектов в списке последних загруженных или сохраненных заданий на печать (см. раздел 8.5.1). Этот список отображается:

– в меню Файл — Задание на печать,

– в меню кнопки Загрузить задание на печать, расположенной на Стандартной панели,

– в меню Файл в режиме предварительного просмотра.

По умолчанию количество объектов в списке равно девяти.

Размер списка последних файлов конфигураций плоттеров/принтеров

Поле позволяет ввести или задать с помощью счетчика количество объектов в списке последних загруженных или сохраненных конфигураций устройств печати (см. раздел 8.5.2). Этот список отображается:

– в меню кнопки Настройка... диалога Печать документа (см. раздел 8.2) и диалога Специальная печать документа (см. раздел 8.4),

– в меню Файл — Настройки предварительного просмотра,

– в меню кнопки Предварительный просмотр, расположенной на Стандартной панели,

– в меню Файл — Конфигурация плоттера/принтера в режиме предварительного просмотра.

По умолчанию количество объектов в списке равно девяти.

Конфигурации плоттеров/принтеров по умолчанию

Группа элементов позволяет выбрать конфигурации устройств печати, которые будут по умолчанию использоваться для печати документов всех типов и специальной печати.

Для выбора нужных файлов конфигураций используются кнопки Обзор.... Полные имена файлов отображаются в полях диалога.

Выбранные файлы конфигураций будут использоваться по умолчанию в следующем сеансе работы КОМПАС-3D.

Если файлы конфигураций не выбраны, то умолчательным устройством печати является умолчательный принтер Windows.

Обзор...

Кнопка позволяет выбрать нужный файл конфигурации плоттера/принтера в стандартном диалоге выбора файла. Файл конфигурации имеет расширение pdc.

Полное имя файла в очереди печати

Состояние этой опции влияет на отображение имени файла документа в очереди печати Windows.

При включенной опции имя файла в очереди печати формируется по шаблону «KOMPAS - <полное имя файла>», например: KOMPAS - D:\Мои документы\Проект1\Чертеж.cdw, а при отключенной — по шаблону «KOMPAS - <короткое имя файла>», например: KOMPAS - Чертеж.cdw.

Если на печать отправлены одновременно несколько документов (это возможно при работе в режиме предварительного просмотра), то вне зависимости от состояния данной опции имя документа в очереди печати формируется по шаблону «KOMPAS - Задание на печать hms», где hms — время отправки задания на печать (часы в 24-часовом формате, минуты и секунды). Например: KOMPAS - Задание на печать 152436.

Обратите внимание на то, что некоторые печатающие устройства имеют ограничения на длину имени файла в очереди печати. Поэтому включать данную опцию следует, только если отображение полного имени файла действительно необходимо.

После завершения настройки нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.1.5.2. Фильтры вывода на печать

Настройка фильтров вывода на печать выполняется в диалоге Установка фильтров вывода на печать. Этот диалог появляется на экране в обычном режиме работы с КОМПАС-3D после вызова команды Сервис — Параметры... — Система — Печать — Фильтры вывода на печать.

Элементы управления диалога позволяют указать объекты документов, которые будут напечатаны.

Табл. 9.1.29. Элементы управления диалога настройки фильтров вывода на печать
Элемент | Описание настройки
Все объекты | Опция позволяет включить или отключить печать всех объектов документов. Если для вывода на печать выбрана часть объектов, «галочка» включения опции отображается на сером фоне. Щелчок по опции в таком состоянии отключит ее. Следующий — включит.
Выводить текст рамкой | Включение опции означает, что вместо текста в документе на печать будет выводиться его габаритная рамка.
Выводить растровые объекты рамками | Включение опции означает, что вместо растровых объектов в документе на печать будут выводиться их габаритные рамки.
Выводить OLE-объекты рамками | Включение опции означает, что вместо OLE-объектов в документе на печать будут выводиться их габаритные рамки.
Применять фильтры к макроэлементам и вставкам видов и фрагментов | Опция позволяет управлять применением фильтров к объектам, входящим в макроэлементы и во вставленные виды и фрагменты. Если опция включена, фильтры будут применены к этим объектам. Если опция отключена, эти объекты не будут рассматриваться как самостоятельные, подлежащие фильтрации.
Список элементов текущего графического документа | Список содержит названия элементов документа и их групп. Чтобы раскрыть список группы, щелкните по значку «+» слева от ее названия. Вы можете изменять набор объектов для печати, включая и выключая соответствующие им опции в списке.
Не использовать фильтры | Опция позволяет отменить применение фильтров и вывести на печать все объекты.

Чтобы задействовать сформированные фильтры и закрыть диалог, нажмите кнопку ОК. Чтобы закрыть диалог без сохранения изменений, нажмите кнопку Отмена.

Диалог, аналогичный вышеописанному, может быть вызван при работе в режиме предварительного просмотра, а также из диалога настройки печати. В этих случаях диалог содержит кнопку Применить, позволяющую задействовать сформированные фильтры без закрытия диалога.

Фильтры, установленные в режиме предварительного просмотра или в диалоге настройки печати, не влияют на системную настройку фильтров вывода.


9.1.6. Общие для документов

9.1. Параметры системы

9.1.6. Общие для документов

В этом разделе:

9.1.6.1. Параметры резьбы


9.1.6.1. Параметры резьбы

Настройка списка таблиц стандартных резьб и их подключение выполняется в диалоге Параметры резьбы. Диалог появляется на экране после вызова команды Сервис — Параметры... — Система — Общие для документов — Параметры резьбы.

В таблице Стандарты резьб находится умолчательный список файлов с параметрами стандартной резьбы. В столбце Имя файла отображается путь к файлу, а в столбце Тип резьбы — тип резьбы и наименование стандарта.

Вы можете дополнить список файлов с параметрами стандартных резьб. Чтобы внести новый файл в таблицу, нажмите кнопку Добавить. После нажатия кнопки на экране появляется стандартный диалог Выберите файлы для открытия.

Выберите необходимый файл (он должен иметь расширение xml) и нажмите кнопку Открыть. В таблице Стандарты резьб появится строка, соответствующая выбранному файлу.

Чтобы подключить файл, включите опцию слева от имени файла. При построении отверстий доступны только те виды стандартных резьб, которые подключены к системе.

Если вы хотите исключить из построения какой-либо вид резьбы, содержащийся в таблице, отключите опцию слева от имени файла.

Для перемещения строки с именем файла и типом резьбы в таблице используйте кнопку со стрелкой Переместить вверх/вниз.

Чтобы удалить файл с параметрами резьбы из списка, выделите строку с его названием и нажмите кнопку Удалить. Завершив настройку, нажмите кнопку ОК. Чтобы закрыть диалог без изменения настройки, нажмите кнопку Отмена.


9.1.7. Графический редактор

9.1. Параметры системы

9.1.7. Графический редактор

В этом разделе:

9.1.7.1. Курсор

9.1.7.2. Сетка

9.1.7.3. Линейки прокрутки

9.1.7.4. Системные линии

9.1.7.5. Системные символы

9.1.7.6. Фантомы

9.1.7.7. Ограничения и степени свободы

9.1.7.8. Виды

9.1.7.9. Слои

9.1.7.10. Системы координат

9.1.7.11. Редактирование

9.1.7.12. Характерные точки

9.1.7.13. Растровые объекты, взятые в документ

9.1.7.14. Упрощенная отрисовка

9.1.7.15. Поиск объекта

9.1.7.16. Привязки

9.1.7.17. Управление изображением


9.1.7.1. Курсор

Настройка внешнего вида курсора выполняется в диалоге Настройка курсора, вызываемом командой Сервис — Параметры... — Система — Графический редактор — Курсор.

Табл. 9.1.30. Элементы управления диалога настройки курсора

Элемент

Описание настройки

Стандартный

Группа элементов управления позволяет настроить параметры стандартного курсора (отображаемого в виде квадратной «ловушки»).

Размер “ловушки“

Элемент позволяет изменить размер стандартного курсора с помощью «ползунка». При этом текущий размер «ловушки» курсора отображается в специальном окне просмотра.

Размер курсора влияет на его «зону чувствительности»: выделены или указаны курсором могут быть те элементы, часть которых лежит внутри окружности, вписанной в квадратную «ловушку» курсора, а динамическая привязка срабатывает, если точка привязки лежит внутри этой окружности.

Обрамление текста

Включите эту опцию, чтобы вокруг символов надписи рядом с курсором (например, название привязки) отображалось белое поле шириной в один пиксел1.

Обрамление

Включите эту опцию, чтобы вокруг линий курсора отображалось белое поле шириной в один пиксел1. Благодаря обрамлению изображение курсора на объектах, близких к нему по цвету, становится более контрастным.

Цвет курсора

Группа элементов позволяет выбрать цвет отображения стандартного курсора: Инверсный или Цветной. При выборе варианта Цветной становится доступной кнопка Цвет, позволяющая выбрать нужный цвет курсора. После нажатия кнопки на экране появляется стандартный диалог выбора цвета.

Увеличенный

Группа элементов позволяет настроить параметры увеличенного курсора.

Включить

Для переключения на отображение увеличенного курсора (большое перекрестие в виде осей координат) выберите эту опцию.

Для быстрого переключения вида курсора (без обращения к настроечному диалогу) используйте комбинацию клавиш <Ctrl>+<K>.

Цвет

Кнопка позволяет выбрать нужный цвет увеличенного курсора. После ее нажатия на экране появляется стандартный диалог выбора цвета.

Шаг

Группа элементов позволяет изменить установленные по умолчанию значения шагов курсора, удалить любые из них, а также добавить в Список новые значения. При вводе автоматически проверяется корректность добавляемых значений.

Чтобы указать умолчательное значение шага, раскройте список По умолчанию и выберите нужную строку.

Отображать параметры команд

Опция управляет отображением параметров команд около курсора. Если она включена, то при построении и редактировании геометрического объекта на экране рядом с курсором показываются значения параметров этого объекта. Например, для отрезка будут отображаться длина и угол наклона.

Округление

Опция позволяет включать и выключать режим округления (см. раздел 1.4.2.15) для окон новых документов. Управление этим режимом в текущем окне осуществляется с помощью кнопки Округление на панели Текущее состояние.
  1. Обрамление видно в окне просмотра, если цвет фона рабочего поля отличается от белого. Настройка цвета фона рабочего поля описана в разделе 9.1.3.1.

После завершения настройки курсора нажмите кнопку ОК. Для выхода из диалога без изменения параметров курсора нажмите кнопку Отмена.


9.1.7.2. Сетка

Настройка внешнего вида отображаемой на экране вспомогательной сетки выполняется в диалоге Настройка сетки, вызываемом командой Сервис — Параметры... — Система — Графический редактор — Сетка.

Аналогичный диалог используется при настройке сетки редактора моделей и текущего окна.

Табл. 9.1.31. Элементы управления диалога настройки сетки
Элемент | Описание настройки
Вкладка Параметры |
Тип | Группа опций позволяет установить тип сетки. Для выбора нужного типа включите соответствующую ему опцию.
Шаг по оси Х, мм | Поле позволяет задать расстояние (в миллиметрах) между точками сетки в направлении оси Х текущей системы координат.
Шаг по оси Y, мм | Поле позволяет задать расстояние (в миллиметрах) между точками сетки в направлении оси Y текущей системы координат.
Угол поворота, гр | Поле позволяет задать угол поворота сетки относительно оси Х текущей системы координат (в градусах). Угол отсчитывается от положительного направления оси Х против часовой стрелки.
Угол искажения, гр | Поле позволяет задать угол (в градусах) между сторонами ячейки сетки, определяющий искажение (непрямоугольность) ячейки. По умолчанию устанавливается равным 90 градусам (прямоугольная ячейка).
Изометрия | Нажатие на эту кнопку автоматически устанавливает угол поворота равным 150 градусам, а угол искажения равным 60 градусам. Сетку с такими параметрами удобно использовать для вычерчивания изометрических изображений.
Прямоугольная | Нажатие на эту кнопку автоматически устанавливает нулевой угол поворота и угол искажения, равный 90 градусам (сетка с прямоугольной ячейкой, не повернутая относительно оси Х текущей системы координат).
Вкладка Отрисовка |
Размер точки, пикс. | Поле позволяет задать размер точки сетки в экранных единицах (пикселах). Допускаются только нечетные значения.
Цвет | Кнопка позволяет выбрать цвет точки сетки в стандартном диалоге выбора цвета.
Размер узла, пикс.1 | Поле позволяет задать размер узла сетки в экранных единицах (пикселах). Допускаются только нечетные значения.
Цвет1 | Кнопка позволяет выбрать цвет узла сетки в стандартном диалоге выбора цвета.
Отображать узел «крестиком»1 | Включите эту опцию, чтобы узлы сетки отображались в виде «крестиков». При отключенной опции узлы сетки показываются как маленькие квадратики.
Шаг узлов по оси Х1 | Поле позволяет задать количество точек сетки, через которое требуется проставлять узлы в направлении оси Х текущей системы координат.
Шаг узлов по оси Y1 | Поле позволяет задать количество точек сетки, через которое требуется проставлять узлы в направлении оси Y текущей системы координат.
Шаг разреживания | Группа опций определяет кратность отображения точек сетки при невозможности их нормальной отрисовки (в окне с мелким масштабом изображения).
Из ряда | Включите эту опцию, чтобы кратность отображения точек сетки выбиралась из ряда чисел: 2, 5, 10, 20, 50, 100, 200, 500, 1000, 2000, 5000, 10000, 20000, 50000, 100000, 500000. Это означает, что при установке такого масштаба отображения, который не позволяет корректно отображать каждую точку, на экране будет показываться каждая вторая точка сетки; при дальнейшем уменьшении масштаба — каждая пятая, затем десятая и так далее.
Кратный | Опция устанавливает шаг разреживания точек сетки кратным любому целому числу. Например, задание шага разреживания, кратного 2, означает, что при уменьшении масштаба изображения на экране сначала показывается каждая вторая точка сетки, затем — каждая четвертая, затем — шестая и так далее.
Минимальное расстояние между точками, пикс. | Поле позволяет задать минимальное расстояние (в пикселах) между точками сетки. При уменьшении масштаба изображения расстояние (в пикселах) между точками сетки на экране уменьшается. До тех пор, пока это расстояние больше заданного минимального расстояния, разрежение сетки не происходит. При дальнейшем уменьшении масштаба сетка разреживается в соответствии с заданными параметрами.
  1. Элемент доступен, если на вкладке Параметры выбран один из типов сетки с узлами.

После завершения настройки параметров сетки нажмите кнопку ОК. Изображение сетки в активном окне будет перерисовано в соответствии с заданными параметрами. Для выхода из диалога без изменения параметров сетки нажмите кнопку Отмена.


9.1.7.3. Линейки прокрутки

Управление отображением линеек прокрутки на экране и автоматическим сдвигом изображения в окне выполняется в диалоге Установка линеек прокрутки, вызываемом командой Сервис — Параметры... — Система — Графический редактор — Линейки прокрутки.

Аналогичный диалог используется при настройке линеек прокрутки:

– текстового редактора,

– редактора спецификаций,

– редактора моделей,

– отчетов,

– текущего окна.

Табл. 9.1.32. Элементы управления диалога установки линеек прокрутки
Элемент | Описание настройки
Горизонтальная линейка | Опция позволяет включить отображение на экране горизонтальной линейки прокрутки.
Вертикальная линейка | Опция позволяет включить отображение на экране вертикальной линейки прокрутки.
Автосдвиг | Группа элементов позволяет настроить параметры автосдвига. Автосдвиг происходит, если во время выполнения какой-либо команды при нажатой левой клавише мыши курсор перемещается за пределы рабочего поля. Изображение в окне сдвигается в сторону перемещения курсора на то расстояние, которое установлено в настройке автосдвига.
Включен | Опция позволяет включить автосдвиг в текущем окне.
От размера окна, % | Поле позволяет ввести вручную или задать с помощью счетчика расстояние, на которое должно сдвигаться изображение в окне. Расстояние задается в процентах от размера окна.

После завершения установки линеек прокрутки и автосдвига нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.1.7.4. Системные линии

Настройка параметров отображения и печати системных стилей линий выполняется в диалоге Системные стили линий. Диалог появляется на экране после вызова команды Сервис — Параметры... — Система — Графический редактор — Системные линии.

Диалог позволяет задать цвет, толщину на экране, толщину на бумаге системных (стандартно поддерживаемых КОМПАС-3D) стилей линий.

Табл. 9.1.33. Элементы управления диалога настройки системных линий

Элемент

Описание настройки

Толщина

Группа элементов управления позволяет установить толщину отрисовки для основных, тонких и утолщенных линий.

Чтобы задать толщину, с которой линии будут отображаться, введите или выберите нужное количество пикселов в поле На экране.

Чтобы задать толщину, с которой линии будут выводиться на печать, введите нужное значение (в миллиметрах) в поле На бумаге.

Список линий

Список содержит все системные линии КОМПАС-3D. Он представлен в виде таблицы из трех колонок: Цвет, Изображение, Наименование.

Чтобы изменить цвет линии, щелкните мышью на нужной строке таблицы. Затем нажмите кнопку с черным треугольником, появившуюся в ячейке Цвет, и укажите нужный цвет линии. Выбранный цвет будет использоваться как для отображения, так и для печати линий соответствующих стилей.

При изменении цвета, а также толщины отображения линии изменяется ее отрисовка в ячейке Изображение.

Наименования линий редактировать нельзя.

После завершения настройки стилей линий нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.1.7.5. Системные символы

Настройка цвета отрисовки системных (стандартно поддерживаемых КОМПАС-3D) символов выполняется в диалоге Цвета системных символов. Диалог появляется на экране после вызова команды Сервис — Параметры... — Система — Графический редактор — Системные символы.

Чтобы выбрать цвет символа, нажмите кнопку с его названием. В появившемся на экране стандартном диалоге выбора цвета укажите нужный цвет.

Внешний вид символов показывается в окнах просмотра, что позволяет оценить произведенные изменения.

После завершения настройки цветов символов нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.1.7.6. Фантомы

Фантом — изображение, временно появляющееся на экране при выполнении какой-либо операции и показывающее текущее состояние создаваемых или редактируемых объектов. Например, если создается отрезок прямой, то во время ожидания ввода его второй точки отображается фантом будущего отрезка. При изменении положения курсора фантом динамически перестраивается, показывая новое состояние вводимого отрезка.

В виде фантомов показываются также разные варианты построения объекта при одних и тех же исходных данных. Например, можно провести две касательные к окружности через одну и ту же точку. В этом случае один из фантомов активный — именно ему будет соответствовать созданный объект, остальные фантомы пассивные. До создания объекта пользователь может активизировать любой из фантомов. По умолчанию активный фантом отображается сплошной линией, а пассивные — точками.

Настройка внешнего вида отображаемых на экране фантомов заключается в настройке отрисовки линий, показывающих форму и положение создаваемых или редактируемых объектов до их фиксации. Данная настройка выполняется в диалоге Отрисовка фантомов, вызываемом командой Сервис — Параметры... — Система — Графический редактор — Фантомы.

Табл. 9.1.34. Элементы управления диалога настройки отображения фантомов
Элемент | Описание настройки
Активный | Опция позволяет включить настройку параметров активного фантома.
Пассивный | Опция позволяет включить настройку параметров пассивного фантома.
Стиль активного/пассивного фантома | Группа элементов позволяет выбрать стиль линий для отрисовки фантома (активного или пассивного). Доступны следующие варианты: – Сплошная, – Точками, – Штрихами, – По объекту — стиль линий фантома совпадает со стилем отрисовки имитируемого объекта. При выборе варианта По объекту настройка толщины и цвета линий невозможна.
Толщина | Поле позволяет выбрать толщину линий (в пикселах) для изображения фантома на экране. Чтобы толщина линий совпадала с толщиной отрисовки имитируемого объекта, включите опцию По объекту.
Цвет | Кнопка позволяет выбрать цвет линий фантома. Вызывает стандартный диалог выбора цвета. Чтобы цвет отрисовки линий фантома совпадал с цветом имитируемого объекта, включите опцию По объекту.

Внешний вид линий активного и пассивного фантомов показывается в соответствующих окнах просмотра, что позволяет оценить произведенные изменения.

После завершения настройки фантомов нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.1.7.7. Ограничения и степени свободы

Настройка параметров отображения значков, показывающих ограничения и степени свободы выполняется в диалоге Ограничения и степени свободы. Диалог появляется на экране после вызова команды Сервис — Параметры... — Система — Графический редактор — Ограничения и степени свободы.

Настройка, произведенная в данном диалоге, распространяется на эскизы и графические документы.

Табл. 9.1.35. Элементы управления диалога настройки отображения ограничений и степеней свободы
Элемент | Описание настройки
Ограничения | Группа элементов позволяет настроить отображение символов, обозначающих связи и ограничения, наложенные на графические объекты. Перечень символов ограничений приведен в разделе 7.2.6.1.
Цвет | Кнопка позволяет изменить цвет отображения символов, показывающих ограничения. После нажатия кнопки на экране появляется стандартный диалог выбора цвета.
Всегда показывать размеры с переменными, фиксированные размеры и точки | Опция позволяет управлять отображением следующих объектов: – переменные, присвоенные размерам, – рамки вокруг фиксированных размеров, – символы фиксированных точек. Если опция включена, данные объекты показываются на экране вне зависимости от того, включено или отключено отображение ограничений. Если опция отключена, данные объекты показываются только при включенном отображении ограничений.
Степени свободы | Группа элементов позволяет настроить цвет отображения символов степеней свободы, имеющихся у графических объектов. Перечень символов степеней свободы приведен в разделе 7.2.6.2. Группа содержит только кнопку Цвет, вызывающую стандартный диалог выбора цвета.

Внешний вид значков ограничений и степеней свобод показывается в соответствующих окнах просмотра, что позволяет оценить произведенные изменения.

Завершив настройку отображения символов, нажмите кнопку OK. Для выхода из диалога без изменения настройки нажмите кнопку Отмена.


9.1.7.8. Виды

Настройка отрисовки видов чертежа производится в диалоге Отрисовка видов. Диалог появляется на экране после вызова команды Сервис — Параметры... — Система — Графический редактор — Виды или нажатия кнопки Настройка видов в Менеджере документа (диалог Менеджер документа описан в разделе 3.6.6.2).

Табл. 9.1.36. Элементы управления диалога настройки отрисовки фоновых и выключенных видов
Элемент | Описание настройки
Отображать имена видов | Опция управляет отображением имен видов. Если опция включена, в поле Текущий вид на панели Текущее состояние (см. рис. 3.6.13) отображаются имена и номера видов, если опция отключена, — только номера видов.
Фоновые виды1 Рамки видов Рамки выключенных видов Рамки ассоциативных видов | Опции позволяют выбрать вариант настраиваемых объектов.
Показывать | Опция управляет отображением рамок видов. Присутствует в диалоге при включенной опции Рамки видов, Рамки выключенных видов или Рамки ассоциативных видов.
Толщина | Поле позволяет установить желаемую толщину (в пикселах) для отображения объекта на экране. Значение в поле вводится вручную или задается с помощью счетчика. Поле доступно для стиля линии Сплошная.
Линия | Группа опций позволяет выбрать стиль линий для отображения объекта. Для выбора стиля включите соответствующую ему опцию — Сплошная, Штрихами или Точками.
Цвет... | Кнопка позволяет задать цвет отображения объекта. Вызывает стандартный диалог выбора цвета.
  1. Данная настройка распространяется также на стиль линий объектов в режиме редактирования макроэлемента.

Внешний вид настраиваемых объектов показывается в соответствующих окнах просмотра. Это позволяет оценить произведенные изменения.

После завершения настройки параметров отрисовки видов нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.1.7.9. Слои

Настройка отрисовки элементов фоновых слоев чертежа производится в диалоге Отрисовка слоев. Диалог появляется на экране после вызова команды Сервис — Параметры... — Система — Графический редактор — Слои или нажатия кнопки Настройка слоев в Менеджере документа (диалог Менеджер документа описан в разделе 3.6.6.2).

Табл. 9.1.37. Элементы управления диалога настройки отрисовки слоев
Элемент | Описание настройки
Отображать имена слоев | Опция управляет отображением имен слоев. Если опция включена, в поле Текущий слой на Панели Текущее состояние (см. рис. 3.6.21) отображаются имена и номера слоев, если опция отключенной — номер.
Фоновые слои | Окно служит для просмотра внешнего вида настраиваемого объекта. Это позволяет оценить произведенные изменения.
Толщина | Поле позволяет установить желаемую толщину (в пикселах) для изображения объекта на экране. Значение в поле вводится вручную или задается с помощью счетчика. Поле доступно для стиля линии Сплошная.
Линия | Группа опций позволяет выбрать стиль линий для отображения фоновых слоев. Для выбора стиля включите соответствующую ему опцию — Сплошная, Штрихами или Точками.
Цвет... | Кнопка позволяет задать цвет отображения фоновых слоев. Вызывает стандартный диалог выбора цвета.

После завершения настройки параметров отрисовки слоев нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.1.7.10. Системы координат

Настройка параметров отрисовки на экране осей систем координат выполняется в диалоге Отрисовка осей систем координат. Диалог появляется на экране после вызова команды Сервис — Параметры... — Система — Графический редактор — Системы координат.

Табл. 9.1.38. Элементы управления диалога настройки систем координат
Элемент | Описание настройки
Оси локальной системы координат | Окно служит для просмотра внешнего вида настраиваемого объекта. Это позволяет оценить произведенные изменения.
Показывать | Опция управляет отображением на экране осей систем координат1.
Толщина | Поле позволяет задать толщину (в пикселах) для изображения осей систем координат на экране. Значение в поле вводится вручную или задается с помощью счетчика. Поле доступно для стиля линий Сплошная.
Линия | Группа опций позволяет выбрать стиль линий для отображения осей систем координат. Для выбора стиля включите соответствующую ему опцию — Сплошная, Штрихами или Точками.
Цвет... | Кнопка позволяет задать цвет отображения осей систем координат. Вызывает стандартный диалог выбора цвета.
  1. Оси систем координат не выводятся на печать.

После завершения настройки параметров отрисовки систем координат нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.1.7.11. Редактирование

Настройка параметров работы с объектами графического документа выполняется в диалоге Редактирование, вызываемом командой Сервис — Параметры... — Система — Графический редактор — Редактирование.

Табл. 9.1.39. Элементы управления диалога настройки параметров редактирования

Элемент

Описание настройки

Выделение

Кнопка позволяет настроить цвет выделенных объектов.

Выделение объектов часто требуется перед выполнением какой-либо команды. Например, для получения копии графического объекта необходимо выделить исходный графический объект; для построения формообразующего трехмерного элемента — его эскиз.

После нажатия кнопки на экране появляется стандартный диалог выбора цвета. Соответствующее окно просмотра позволяет визуально оценить произведенную настройку.

Подсвечивание

Кнопка позволяет настроить цвет указанных объектов.

Указание объектов требуется во время выполнения некоторых команд. Например, для построения кинематического элемента необходимо указать его траекторию; для построения параллельного отрезка — другой отрезок или прямую.

После нажатия кнопки на экране появляется стандартный диалог выбора цвета. Соответствующее окно просмотра позволяет визуально оценить произведенную настройку.

Показывать выключенные слои выделенных составных объектов

Включите эту опцию, чтобы при выделении составных объектов были видны элементы, расположенные на слоях, отрисовка которых в данный момент отключена (об управлении состоянием слоев см. раздел 3.6.6.5).

К составным объектам относятся группы (см. раздел 3.10.2), вставки фрагментов (см. раздел 3.8.2), макроэлементы (см. раздел 3.8.5).

Всегда показывать заливку установленным цветом

Включите эту опцию, чтобы при выделении заливки выделялся только ее контур, а цвет самой заливки не изменялся.

Если опция отключена, то при выделении заливки ее цвет меняется на установленный для выделенных объектов.

Всегда показывать рисунки в исходных цветах

Включите эту опцию, чтобы при выделении рисунка выделялся только его контур, а цвета самого рисунка не изменялись.

Если опция отключена, то при выделении рисунка его цвета заменяются оттенками цвета, установленного для выделенных объектов.

Обратите внимание на то, что переключение способа отображения выделенных рисунков возможно, если для отрисовки графических документов используется OpenGL1. Если же для отрисовки документов используется GDI2, то рисунки всегда показываются в исходных цветах; опция при этом недоступна.

Выбор средства формирования изображения — OpenGL или GDI — осуществляется в диалоге управления изображением (см. раздел 9.1.7.17).

Коэффициент изменения масштаба

Поле позволяет ввести коэффициент увеличения или уменьшения изображения в окне при нажатии комбинаций клавиш <SHIFT>+<+> и <SHIFT>+<-> соответственно.

Зона нечувствительности мыши к сдвигу, мм

Поле позволяет задать минимальную величину перемещения мыши (например, при сдвиге выделенных объектов), после которого система начинает реагировать на движение. Эта настройка введена для того, чтобы блокировать случайные сдвиги мыши (например, при дрожании руки, толчках стола и т.п.) и не допускать непредвиденных действий с объектами чертежа. Величина зоны нечувствительности определяется в миллиметрах, причем масштаб текущего изображения не оказывает влияния на это значение.

Количество шагов назад

Поле позволяет задать количество операций, которое может быть отменено и повторено при работе. Значение в поле вводится вручную или задается с помощью счетчика.

При увеличении этого значения увеличивается количество системных ресурсов (памяти) для поддержки списка выполненных операций, поэтому количество шагов должно быть обоснованным. Рекомендуется устанавливать число в интервале от 10 до 30.

Группировать однотипные операции

Включите эту опцию, чтобы несколько выполненных подряд действий по выделению или масштабированию объектов были сохранены в списке для отмены как одно действие. При этом будут отменяться или повторяться сразу все объединенные действия. Например, было произведено последовательное масштабирование одних и тех же объектов. Если опция группирования была включена, то при нажатии кнопки Отменить будет выполнен возврат к состоянию, имевшемуся перед самым первым масштабированием объектов.
  1. OpenGL (Open Graphics Library — открытая графическая библиотека) — спецификация, определяющая программный интерфейс для написания приложений, использующих двумерную и трехмерную компьютерную графику.
  2. GDI (Graphics Device Interface или Graphical Device Interface) — интерфейс Microsoft Windows для представления графических объектов и передачи их на устройства отображения, такие как мониторы и принтеры. Отвечает за отрисовку линий и кривых, отображение шрифтов и обработку палитры.

После завершения настройки редактирования нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.1.7.12. Характерные точки

Настройка отображения характерных точек выполняется в диалоге Характерные точки. Диалог появляется на экране после вызова команды Сервис — Параметры... — Система — Графический редактор — Характерные точки.

В диалоге Характерные точки содержатся:

– Поле Количество выделенных объектов для отображения характерных точек, max

Поле служит для указания максимального количества объектов, при одновременном выделении которых их характерные точки отображаются. Количество выделенных объектов задается в диапазоне от 0 до 100.

Если количество выделенных объектов превышает заданное, то их характерные точки не отображаются. Таким образом, если ввести 0, то характерные точки не будут отображаться никогда.

– Опция Отображать только общие характерные точки для группы выделенных объектов

Если опция включена, то на экране отображаются только те характерные точки, которые являются общими для выделенных объектов.

Если опция отключена, то на экране отображаются все характерные точки выделенных объектов.

– Группа вариантов Характерные точки надписей

Элементы группы позволяют задать количество характерных точек перемещения текстовой надписи. Для этого выберите один из предложенных вариантов.

Требуемое количество характерных точек зависит от решаемых задач. Например, если нужно размещать тексты в центре окружностей или многоугольников, выберите вариант 2. Если, кроме того, требуется выравнивать текст относительно середины стороны его габаритного прямоугольника, выберите вариант 3.

После завершения настройки отображения характерных точек нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.1.7.13. Растровые объекты, взятые в документ

Настройка параметров редактирования растровых объектов, взятых в графические документы, выполняется в диалоге Редактирование растровых объектов, взятых в документ. Диалог появляется на экране после вызова команды Сервис — Параметры... — Система — Графический редактор — Растровые объекты, взятые в документ.

Табл. 9.1.40. Элементы управления диалога настройки растровых объектов, взятых в документ

Элемент

Описание настройки

Тип файла при редактировании

Раскрывающийся список позволяет выбрать формат, в котором графическая информация должна быть представлена во время редактирования.

В соответствии с зарегистрированным в Windows типом файла

Включите эту опцию, чтобы для редактирования рисунков запускалась программа, сопоставленная в Windows типу файла, выбранному из списка Тип файла при редактировании.

Другая

Включите эту опцию, чтобы выбрать другую программу для редактирования рисунков. Полный путь к файлу программы отображается в поле просмотра. Чтобы сменить программу, нажмите кнопку с многоточием справа от поля.

Указанная программа должна поддерживать тип файлов, выбранный в списке Тип файла при редактировании.

Сохранять исходное разрешение растра

Включите эту опцию, чтобы изменение разрешения рисунка в результате редактирования было проигнорировано. Благодаря этому размер рисунка после редактирования останется таким же, как до редактирования.

Некоторые программы, например, MSPaint, при сохранении изображений, не имеющих сведений о разрешении (при вставке таких рисунков в КОМПАС-документ их разрешение можно задать произвольно) автоматически присваивают им определенное разрешение.

Для завершения настройки нажмите кнопку OK. Для выхода из диалога без изменения настроек нажмите кнопку Отмена.


9.1.7.14. Упрощенная отрисовка

Упрощенная отрисовка применяется в тех случаях, когда текущий масштаб изображения становится слишком мелким для детального показа документа. Настройка параметров для упрощенного изображения объектов на экране выполняется в диалоге Упрощенная отрисовка, вызываемом командой Сервис — Параметры... — Система — Графический редактор — Упрощенная отрисовка.

Табл. 9.1.41. Элементы управления диалога настройки упрощенной отрисовки

Элемент

Описание настройки

Минимальная высота строки текста, отображаемая на экране, мм

Поле позволяет задать минимальную высоту символов текста (в миллиметрах), при которой они будут отображаться на экране. Если высота текста на экране станет меньше установленного значения, надпись будет отрисовываться габаритным прямоугольником.

Значение в поле вводится вручную или выбирается из предопределенного списка.

Масштаб изображения, при котором все линии отрисовываются как сплошные и не рисуются стрелки

Поле позволяет задать масштаб изображения, при достижении которого будет выполняться упрощенная прорисовка линий (все линии будут отрисовываться как сплошные и не будут показываться стрелки).

Значение в поле вводится вручную или выбирается из предопределенного списка.

Отрисовывать вместо растровых объектов их габаритные прямоугольники

Включение этой опции означает, что на месте вставленных в графические документы растровых объектов будут отображаться их габаритные прямоугольники.

Отрисовывать вместо OLE-объектов их габаритные прямоугольники

Включение этой опции означает, что на месте вставленных в графические документы ОLE-объектов будут отображаться их габаритные прямоугольники.

Включение отрисовки габаритных прямоугольников вместо растровых и OLE-объектов позволяет сократить время загрузки документов.

Всегда отрисовывать заливку установленным цветом

Включенная опция означает, что все заливки в документах отображаются заданными для них цветами вне зависимости от состояния слоев и видов, на которых они расположены. Если опция отключена, то собственными цветами отображаются только заливки, лежащие на текущем слое, а остальные заливки принимают цвета содержащих их слоев или видов.

Обратите внимание на то, что данная настройка распространяется на печать документов и сохранение их в растровый формат. Например, если для вывода чертежа был выбран цвет, установленный для вида, то при включенной опции Всегда отрисовывать заливку установленным цветом заливки будут напечатаны собственными цветами, а при отключенной — цветами видов, в которых они находятся.

После завершения настройки упрощенной отрисовки нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.1.7.15. Поиск объекта

В ряде команд КОМПАС-3D осуществляется динамический поиск объектов. Это означает, что при проходе курсора над объектом, который может быть указан в данной команде, этот объект подсвечивается. Если несколько объектов, которые могут участвовать в выполнении команды, находятся близко друг к другу, динамический поиск облегчает выбор нужного объекта. Щелчок мышью позволяет указать тот объект, который подсвечен в данный момент.

При использовании динамического поиска становится возможным указание (выбор) одного из близко расположенных (в том числе наложенных друг на друга) объектов. Для перебора близко расположенных объектов служат соответствующие команды в контекстном меню. Эти команды доступны, если при указании (или выделении) объекта в «ловушку» курсора попадает несколько объектов.

Включение и выключение динамического поиска объектов выполняется в диалоге Установка динамического поиска объектов, вызываемом командой Сервис — Параметры... — Система — Графический редактор — Поиск объекта.

Единственная опция диалога позволяет включать и выключать динамический поиск.

После того как нужное значение опции установлено, нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.1.7.16. Привязки

Управление глобальными привязками курсора осуществляется в диалоге Установка глобальных привязок. Этот диалог появляется на экране в следующих случаях:

– после вызова команды Сервис — Параметры... — Система — Графический редактор — Привязки,

– после вызова команды Настроить параметры из меню кнопки Привязки, расположенной на панели Текущее состояние или панели Глобальные привязки.

В первом случае произведенная настройка сохраняется как умолчательная и используется для всех вновь открываемых и создаваемых документов. Во втором случае произведенная настройка используется только в окнах текущего документа до конца сеанса работы с ним.

Табл. 9.1.42. Элементы управления диалога настройки привязок

Элемент

Описание настройки

Список глобальных привязок

Список позволяет изменить набор глобальных привязок, действующих в документе. Для этого следует включать или выключать опции, соответствующие нужным названиям в списке.

Переместить вверх

Переместить вниз

Кнопки используются для настройки приоритета привязок.

Если включено несколько глобальных привязок и при текущем положении курсора возможно выполнение всех их, то срабатывает более приоритетная привязка. Приоритет привязки определяется ее положением в списке.

Чтобы повысить приоритет привязки, выделите ее в списке и нажмите кнопку Переместить вверх, а чтобы понизить — кнопку Переместить вниз. Выбранная привязка переместится на одну позицию в указанном направлении.

Все привязки

Опция позволяет включить или выключить все привязки. Если включены не все привязки, «галочка» включения опции отображается на сером фоне. Щелчок по опции в таком состоянии выключит ее. Следующий — включит.

Настройки, распространяющиеся как на глобальные, так и на локальные привязки

Динамически отслеживать

Опция управляет динамическим расчетом привязок. Если она включена, расчет выбранных привязок производится «на лету» — при подведении курсора к точке, к которой можно привязаться (она отмечается на экране фантомом в виде «крестика»1). При отключенной опции расчет производится только после фиксации точки.

Отображать текст

Опция позволяет отображать рядом с курсором название сработавшей привязки. Показ названия привязки возможен, если включена опция Динамически отслеживать.

Для угловой привязки дополнительно показывается значение угла.

Если опция отключена, то при подведении курсора к точке, к которой можно привязаться, на экране не отображается ни название привязки, ни фантом в виде «крестика».

Привязка к объектам фоновых слоев

Опция позволяет выполнять привязку к объектам, лежащим в фоновых слоях (см. раздел 3.6.6.1) графического документа или эскиза. В чертежах эта опция включает также привязку к объектам фоновых видов.

Только к видимым точкам сетки

Опция позволяет при выполнении привязки По сетке использовать только ее узлы. Доступна, если в набор действующих в документе привязок входит привязка По сетке — в списке глобальных привязок включена соответствующая ей опция.

Включенная опция означает, что привязка выполняется только к узлам сетки и только в том случае, если сетка отображается на экране (см. раздел 3.1.3.1).

При отключенной опции возможна привязка к точкам сетки, ставшим невидимыми в результате разрежения (см. раздел 3.1.3.3). Включение отображения сетки необязательно.

Шаг угловой привязки

Поле позволяет задать значение, кратно которому должен изменяться угол угловой привязки. Например, если значение шага угловой привязки установлено равным 15°, то будет возможна привязка к точкам, расположенным на прямых, проходящих через последнюю зафиксированную точку под углами 15°, 30°, 45°, 60°, 90° и т.д.

Привязка к элементам оформления чертежа

Опция позволяет выполнять привязку к линиям оформления чертежа (рамке, таблице основной надписи).

Привязка к элементам модели

Опция позволяет при работе с эскизом выполнять привязку к объектам модели. Привязка к объектам модели подробно описана в разделе 2.2.2.3.1.

Только к видимым элементам модели

Опция позволяет при выполнении привязки к объектам модели использовать только видимые объекты. Доступна при включенной опции Привязка к элементам модели.

Запретить
привязки

Опция позволяет включать и отключать действие всех настроенных глобальных привязок в текущем окне. Присутствует в диалоге, если он вызван командой Настроить параметры из меню кнопки Привязки.
  1. Цвет отображения фантома и текста соответствует цвету, установленному для увеличенного курсора.

После завершения настройки глобальных привязок нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.1.7.17. Управление изображением

Способ формирования изображения чертежа или фрагмента на экране монитора задается в диалоге Управление изображением, вызываемом командой Сервис — Параметры... — Система — Графический редактор — Управление изображением.

Для отрисовки документа может использоваться OpenGL или GDI.

OpenGL (Open Graphics Library — открытая графическая библиотека) — спецификация, определяющая программный интерфейс для написания приложений, использующих двумерную и трехмерную компьютерную графику.

GDI (Graphics Device Interface или Graphical Device Interface) — интерфейс Microsoft Windows для представления графических объектов и передачи их на устройства отображения, такие как мониторы и принтеры. Отвечает за отрисовку линий и кривых, отображение шрифтов и обработку палитры.

Диалог Управление изображением содержит две опции — Использовать OpenGL и Использовать аппаратное ускорение.

– Если включена опция Использовать OpenGL, то для отрисовки документа используется OpenGL, а если выключена — то GDI.

Включение опции Использовать OpenGL позволяет ускорить формирование изображения, например, при изменении масштаба или сдвиге изображения. Ускорение особенно заметно при работе с насыщенными чертежами.

Шрифты, заливки и растровые объекты, отображаемые с помощью OpenGL, могут иметь незначительные визуальные отличия от тех же объектов, отображаемых с помощью GDI, что не является дефектом. При формировании изображения в предварительном просмотре и при выводе на печать OpenGL не используется, поэтому на получение бумажных копий документов данная настройка не влияет.

Отображение векторных шрифтов, в том числе поставляемых с КОМПАС-3D шрифтов GOST type A (plotter), GOST type B (plotter), Symbol type A (plotter), Symbol type B (plotter), с помощью OpenGL невозможно.

Возможность отрисовки изображения средствами OpenGL обеспечивается не всеми типами видеокарт. Дополнительную информацию см. в файле ReadMe.pdf. Для его открытия можно вызвать из главного меню Windows команду Пуск — Программы — АСКОН — КОМПАС-3D — Информация об установке.

– Опция Использовать аппаратное ускорение доступна, если включена опция Использовать OpenGL.

Включение опции Использовать аппаратное ускорение означает, что изображение графического документа на экране монитора формируется графическим процессором. Если вы наблюдаете неудовлетворительное изображение документа, отключите опцию Использовать аппаратное ускорение. После этого функция формирования изображения будет передана центральному процессору (что, возможно, несколько замедлит работу компьютера).

Если ваш компьютер оснащен видеокартой, не предусматривающей аппаратное ускорение, опция отключена и недоступна.

Для того чтобы изменение способа формирования изображения вступило в силу, после включения или отключения опций данного диалога необходимо перезапустить КОМПАС-3D.


9.1.8. Текстовый редактор

9.1. Параметры системы

9.1.8. Текстовый редактор

В этом разделе:

9.1.8.1. Линейки прокрутки

9.1.8.2. Редактирование

9.1.8.3. Текстовые шаблоны

9.1.8.4. Толщина линий спецзнаков

9.1.8.5. Масштаб редактирования

9.1.8.6. Параметры правописания


9.1.8.1. Линейки прокрутки

Управление отображением линеек прокрутки на экране и автоматическим сдвигом изображения в окне выполняется в диалоге Установка линеек прокрутки, вызываемом командой Сервис — Параметры... — Система — Текстовый редактор — Линейки прокрутки. Работа в диалоге описана в разделе 9.1.7.3.


9.1.8.2. Редактирование

Настройка параметров работы текстового редактора системы КОМПАС-3D выполняется в диалоге Редактирование, вызываемом командой Сервис — Параметры... — Система — Текстовый редактор — Редактирование.

Табл. 9.1.43. Элементы управления диалога настройки текстового редактора
Элемент | Описание настройки
Коэффициент изменения масштаба | Введите коэффициент увеличения или уменьшения изображения в окне при нажатии комбинаций клавиш <SHIFT>+<+> и <SHIFT>+<-> соответственно.
Количество шагов назад | Введите количество операций, которое может быть отменено и повторено при работе. При увеличении этого значения увеличивается количество системных ресурсов (памяти) для поддержки списка выполненных операций. Количество шагов должно быть обоснованным. Рекомендуется устанавливать число в интервале от 10 до 30.
Группировать однотипные операции | Чтобы однотипные действия были сохранены в списке для отмены как одно действие, включите эту опцию. При этом отменяться или повторяться будут сразу все объединенные действия. Примерами однотипных действий могут служить ввод одного и того же символа, перемещение курсора в одну и ту же сторону.
Толщина | Установите желаемую толщину (в пикселах) для изображения габаритной рамки текста на экране. Настройка доступна для стиля линий сплошной.
Цвет | Чтобы вызвать диалог изменения цвета объекта, нажмите кнопку Цвет.
Линия | Выберите нужный стиль линии (сплошной, штрихами или точками) для изображения объекта на экране.

Внешний вид настраиваемой габаритной рамки текста показывается в окне просмотра, что позволяет оценить произведенные изменения.

Для завершения настройки нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.1.8.3. Текстовые шаблоны

Настройка текстовых шаблонов выполняется в диалоге Текстовые шаблоны, вызываемом командой Сервис — Параметры... — Система — Текстовый редактор — Текстовые шаблоны.

Табл. 9.1.44. Элементы управления диалога настройки текстовых шаблонов
Элемент | Описание настройки
Имя файла текстовых шаблонов | В этом поле отображается полный путь к файлу, который содержит текстовые шаблоны. Имя файла по умолчанию graphic.tdp.
Обзор... | Кнопка позволяет сменить файл текстовых шаблонов. После ее нажатия на экране появляется стандартный диалог выбора файла.
Сохранять введенный текст в файле | Опция позволяет автоматически сохранять в файл текстового шаблона вводимый в документе текст (при заполнении основной надписи, текстовой части объектов спецификации, вводе названий спецификации на листе).
Шрифт | Раскрывающийся список позволяет выбрать шрифт для отображения текстов шаблонов в окне Библиотекаря текстовых шаблонов. Список содержит все шрифты, подключенные в Windows.
Высота, мм | Поле позволяет ввести или выбрать из предопределенного списка значение высоты символов (в миллиметрах) текстов шаблонов. Введенное вручную значение добавляется в список и сохраняется в течение текущего сеанса работы КОМПАС-3D.
Курсив | Опция позволяет задать курсивное начертание символов.
Жирный | Опция позволяет задать утолщенное начертание символов.
Цвет... | Кнопка позволяет задать цвет символов. Вызывает стандартный диалог выбора цвета.
Пример | Окно просмотра служит для отображения настроенного текста. Это позволяет оценить произведенные изменения.

После завершения настройки текстовых шаблонов нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.1.8.4. Толщина линий спецзнаков

Настройка толщины линий, которыми должны выводиться (как на экран, так и на печать) специальные знаки (например, знаки шероховатости, обозначения сварных соединений и т.п.), выполняется в диалоге Толщина линий спецзнаков. Диалог появляется на экране после вызова команды Сервис — Параметры... — Система — Текстовый редактор — Толщина линий спецзнаков.

Табл. 9.1.45. Элементы управления диалога настройки толщины линий спецзнаков
Элемент | Описание настройки
Системные настройки толщины линий | Чтобы толщина линий спецзнаков соответствовала толщине основной или тонкой системных линий, включите эту опцию. Введите в поле высоту шрифта (в мм), при которой будет изменяться применяемый вариант системной линии. По умолчанию она составляет 10 мм. Если высота шрифта будет менее 10 мм, спецзнаки будут отрисовываться тонкими линиями. Если высота будет более 10 мм — основными.
Пользовательская настройка толщины линий | Чтобы толщина линий спецзнаков была пропорциональна высоте шрифта, включите эту опцию. Введите в поле соотношение (в процентах) между высотой шрифта и толщиной линий спецзнаков. По умолчанию толщина линий равна 7,14% (1/14) от высоты шрифта.

После завершения настройки толщины линий для отрисовки спецзнаков нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.1.8.5. Масштаб редактирования

Вы можете установить масштаб, в котором по умолчанию будут открываться для редактирования тексты и таблицы (в том числе основные надписи) в графических документах и таблицы в текстовых документах системы КОМПАС-3D. Данная настройка выполняется в диалоге Масштаб редактирования текстовых объектов, вызываемом командой Сервис — Параметры... — Система — Текстовый редактор — Масштаб редактирования.

Табл. 9.1.46. Элементы управления диалога настройки масштаба редактирования
Элемент | Описание настройки
Текущий масштаб документа | Чтобы при вызове команд редактирования текстов и таблиц масштаб изображения документа не изменялся, включите эту опцию.
Другой масштаб | Чтобы при вызове команд редактирования текстов и таблиц масштаб изображения документа был изменен, включите эту опцию. Введите в поле значение масштабного коэффициента или выберите это значение из раскрывающегося списка. Введенное вручную значение добавляется в список и сохраняется в течение текущего сеанса работы КОМПАС-3D.

Пример. Текущий масштаб изображения чертежа 1:5. В диалоге включена опция Другой масштаб и введено значение масштабного коэффициента 1.0. При двойном щелчке по основной надписи чертежа система КОМПАС-3D перейдет в режим редактирования. Основная надпись будет показана на экране в натуральную величину (в масштабе 1:1). После завершения редактирования основной надписи масштаб изображения 1:5 будет восстановлен.

После завершения настройки масштаба редактирования текстовых документов нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.1.8.6. Параметры правописания

Настройка проверки правописания выполняется в диалоге Параметры правописания.

Диалог появляется на экране после вызова команды Сервис — Параметры... — Система — Текстовый редактор — Параметры правописания или нажатия кнопки Параметры в диалоге Правописание.

Орфография проверяется для всех языков, грамматика — только для русского языка.

Табл. 9.1.47. Элементы управления диалога настройки проверки правописания
Элемент | Описание настройки
Группа Орфография
Автоматически проверять орфографию | Опция позволяет включить автоматическую проверку орфографии (см. раздел 4.1.3.2). Слова, предположительно содержащие ошибки, будут подчеркнуты в тексте волнистой линией. По умолчанию цвет линии красный.
Предлагать только из основного словаря | Опция позволяет отключить использование вспомогательных словарей (см. раздел 4.1.3.6) при отображении правильных вариантов написания.
Пропускать слова из прописных букв | Опция позволяет пропускать при проверке орфографии слова, состоящие из заглавных букв.
Пропускать слова с цифрами | Опция позволяет пропускать при проверке орфографии слова, состоящие из букв и цифр.
Пропускать дроби, индексы и надстроки | Опция позволяет пропускать при проверке орфографии дроби, индексы, надстрочный и подстрочный текст.
Пропускать адреса Интернета и имена файлов | Опция позволяет пропускать при проверке орфографии адреса Интернета, электронной почты и имена файлов.
Словари... | Кнопка, позволяющая выполнять различные действия со вспомогательными словарями, например, создавать, изменять и т.п. После нажатия этой кнопки на экране появляется диалог Вспомогательные словари.
Группа Грамматика 1
Автоматически проверять грамматику | Опция позволяет включить автоматическую проверку грамматики (см. раздел 4.1.3.2). Предложения или их части, предположительно содержащие ошибки, будут подчеркнуты в тексте волнистой линией. По умолчанию цвет линии зеленый.
Настройка... | Кнопка позволяет настроить параметры грамматической проверки. После вызова команды на экране появляется диалог Настройка грамматической проверки.
  1. Группа недоступна, если не установлены средства проверки правописания для русского языка (т.е. при установке КОМПАС-3D была отключена соответствующая опция). Чтобы установить средства проверки, измените установку.

Чтобы завершить настройку проверки правописания, нажмите кнопку ОК. Чтобы закрыть диалог, отказавшись от сделанных изменений, нажмите кнопку Отмена.


9.1.9. Редактор спецификаций

9.1. Параметры системы

9.1.9. Редактор спецификаций

В этом разделе:

9.1.9.1. Линейки прокрутки

9.1.9.2. Параметры обновления документов


9.1.9.1. Линейки прокрутки

Управление отображением линеек прокрутки на экране и автоматическим сдвигом изображения в окне выполняется в диалоге Установка линеек прокрутки, вызываемом командой Сервис — Параметры... — Система — Редактор спецификаций — Линейки прокрутки. Работа в диалоге описана в разделе 9.1.7.3.


9.1.9.2. Параметры обновления документов

В данном диалоге производится настройка обновления и сохранения документов, подключенных к спецификации.

Табл. 9.1.48. Элементы управления диалога настройки обновления документов

Элемент

Описание настройки

При перестроении спецификации сохранять подключенные документы, открытые в «слепом» режиме

Если эта опция включена, то подключенные к спецификации документы, которые при ее перестроении были открыты в «слепом» режиме и перестроены, записываются на диск немедленно и безусловно, а если отключена, то эти документы записываются только после сохранения спецификации и не записываются в случае закрытия спецификации без сохранения.

О перестроении спецификации см. раздел 6.1.3.6.4.

По умолчанию сохранение документов включено, благодаря чему при повторном открытии ранее перестроенной спецификации новый запрос на перестроение не выдается. С другой стороны, автоматическое сохранение документов может привести к тому, что документы, созданные в предыдущей версии КОМПАС-3D, перестанут открываться в ней.

При сохранении спецификации передавать данные в подключенные документы

Если эта опция включена, то при сохранении спецификации производится автоматическая передача данных из нее в подключенные документы, а если отключена, то передача не производится ни при сохранении спецификации, ни при вызове команды Синхронизация.

На передачу данных в обратном направлении — из подключенных документов в спецификацию — данная опция не влияет.

По умолчанию передача данных из спецификации в документы включена.

О передаче данных из спецификации в подключенные документы см. раздел 6.1.3.6.2.

После завершения настройки обновления документов нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.1.10. Прикладные библиотеки

9.1. Параметры системы

9.1.10. Прикладные библиотеки

В этом разделе:

9.1.10.1. Отключение

9.1.10.2. Редактирование элементов


9.1.10.1. Отключение

Отключение прикладных библиотек от системы КОМПАС-3D настраивается в диалоге Установка отключения библиотек, вызываемом командой Сервис — Параметры... — Система — Прикладные библиотеки — Отключение.

Табл. 9.1.49. Элементы управления диалога настройки отключения прикладных библиотек

Элемент

Описание настройки

Автоматически отключать библиотеки, подключенные в «слепом» режиме

В некоторых случаях библиотека подключается к КОМПАС-3D автоматически (в так называемом «слепом» режиме). Названия подключенных таким образом библиотек не отображаются в меню Библиотеки. Примерами подключения библиотеки в «слепом» режиме могут служить:

– выполнение команд экспорта/импорта файлов,

– редактирование параметров созданных прикладной библиотекой объектов документа,

– вызов команд библиотеки нажатием соответствующей кнопки на пользовательской Панели команд.

В целях экономии времени на повторное подключение библиотек при новом обращении к ним такие библиотеки по умолчанию не отключаются от системы автоматически после завершения их работы. При использовании КОМПАС-3D в однопользовательском режиме это не имеет значения. Однако при сетевой работе с КОМПАС-3D произойдет удержание «плавающей» лицензии на библиотеку на сетевом ключе защиты. Иными словами, неиспользуемая, но не отключенная от системы, библиотека будет занимать одну из сетевых лицензий, не давая тем самым запустить эту же библиотеку на другом компьютере. Включение опции автоматически выгружает библиотеки, подключенные к системе «вслепую», после завершения их работы. Другим способом является ручное отключение библиотеки в Менеджере библиотек (см. раздел 11.3.1).

Обязательно включите данную опцию в том случае, если при сетевой работе с системой КОМПАС-3D количество лицензий на библиотеку (например, на библиотеку экспорта в DXF) меньше, чем количество лицензий на систему КОМПАС-3D (например, 5 лицензий на КОМПАС-3D и 2 лицензии на библиотеку экспорта в DXF).

Отключать библиотеки при выходе из системы

Включение опции автоматически отключает все подключенные библиотеки моделей, фрагментов и прикладные библиотеки при завершении сеанса работы в КОМПАС-3D. При отключенной опции отключение библиотек не происходит. При следующей загрузке системы КОМПАС-3D все подключенные библиотеки будут автоматически открыты в том состоянии, в котором они находились на момент выхода из системы.

После завершения настройки отключения библиотек нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.1.10.2. Редактирование элементов

В документе, содержащем библиотечный макроэлемент, могут отображаться средства управления этим макроэлементом, определяемые библиотекой. К ним относятся специальные свойства и характерные точки макроэлемента, а также кнопки контекстной панели, которая появляется при его выделении.

Отображение в документе средств управления макроэлементом настраивается в диалоге Редактирование библиотечных макроэлементов, вызываемом командой Сервис — Параметры... — Система — Прикладные библиотеки — Редактирование элементов.

Для этого используется группа вариантов Отображение характерных точек, свойств и контекстной панели.

Чтобы средства управления макроэлементом не отображались в документе, выберите вариант отключено.

Если выбран вариант включено только при подключенной библиотеке, то средства управления макроэлементом отображаются в документе только если библиотека, из которой вставлен макроэлемент, подключена к системе.

Чтобы средства управления макроэлементом отображались в документе вне зависимости от того, подключена библиотека или нет, выберите вариант включено.

При включенном отображении вы можете использовать характерные точки и специальные свойства макроэлемента для редактирования объектов, а также выделять объекты по данным свойствам — в диалоге Выделение объектов по свойствам (см. раздел 3.1.2.3) появляется раздел Библиотечные макроэлементы.

Отображение контекстной панели имеет следующие особенности.

Если выбран вариант отключено, то при выделении библиотечного макроэлемента появляется панель системы КОМПАС-3D (т.е. типовая контекстная панель для макроэлементов). В двух других случаях состав панели определяется библиотекой. Возможны следующие варианты:

– команды библиотеки добавляются на панель системы КОМПАС-3D,

– панель из библиотеки отображается вместо панели системы КОМПАС-3D,

– панель системы КОМПАС-3D отображается в неизменном виде,

– панель системы КОМПАС-3D не отображается.

После завершения настройки нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.1.11. Редактор моделей

9.1. Параметры системы

9.1.11. Редактор моделей

В этом разделе:

9.1.11.1. Сетка

9.1.11.2. Линейки прокрутки

9.1.11.3. Системные линии

9.1.11.4. Библиотеки конструкторских элементов

9.1.11.5. Управление изображением

9.1.11.6. Изменение ориентации

9.1.11.7. Перспективная проекция

9.1.11.8. Редактирование

9.1.11.9. ЛСК

9.1.11.10. Исполнения

9.1.11.11. Зеркальное отражение

9.1.11.12. Размеры и обозначения

9.1.11.13. Габарит

9.1.11.14. Зоны

9.1.11.15. МЦХ

9.1.11.16. Упрощения

9.1.11.16.1. Модель

9.1.11.16.2. Прочие


9.1.11.1. Сетка

Настройка внешнего вида отображаемой на экране вспомогательной сетки выполняется в диалоге Настройка сетки, вызываемом командой Сервис — Параметры... — Система — Редактор моделей — Сетка. Работа в диалоге описана в разделе 9.1.7.2.


9.1.11.2. Линейки прокрутки

Управление отображением линеек прокрутки на экране и автоматическим сдвигом изображения в окне выполняется в диалоге Установка линеек прокрутки, вызываемом командой Сервис — Параметры... — Система — Редактор моделей — Линейки прокрутки. Работа в диалоге описана в разделе 9.1.7.3.


9.1.11.3. Системные линии

Толщина линий для отрисовки пространственных кривых в модели настраивается в диалоге Системные стили линий, вызываемом командой Сервис — Параметры... — Система — Редактор моделей — Системные линии.

Диалог содержит таблицу из трех колонок: Вид, Стиль, Толщина.

В колонке Вид отображаются образцы системных стилей линий КОМПАС-3D.

В колонке Стиль отображаются наименования стилей линий.

Колонка Толщина содержит значение толщины линии для каждого стиля.

Чтобы задать толщину линии, активизируйте щелчком мыши нужную ячейку в колонке Толщина и задайте толщину в пикселах.

При изменении толщины изменяется отрисовка образца стиля в ячейке Вид.

Наименование стиля линии отредактировать невозможно.

После завершения настройки нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.

Обратите внимание на то, что данная настройка влияет только на пространственные кривые (см. раздел 2.5.4) и не влияет на такие объекты, как эскизы, ребра, оси и т.п.

Вы можете настроить цвет пространственных кривых. Умолчательный цвет для кривых разных типов задается в диалоге настройки свойств объектов (см. раздел 9.2.7.4.7; при необходимости цвет создаваемой или редактируемой кривой можно изменить на вкладке Свойства Панели свойств.


9.1.11.4. Библиотеки конструкторских элементов

Диалог настройки библиотек конструкторских элементов позволяет указать файлы библиотек фрагментов *.lfr, которые используются в качестве библиотеки эскизов и библиотеки эскизов профилей круглых отверстий при вызове соответствующих команд КОМПАС-3D.

Этот диалог появляется на экране после вызова команды Сервис — Параметры... — Система — Редактор моделей — Библиотеки конструкторских элементов.

Табл. 9.1.50. Элементы управления диалога настройки библиотек конструкторских элементов
Элемент | Описание настройки
Имя файла библиотеки отверстий | Поле содержит полное имя файла библиотеки отверстий.
Изменить... | Кнопка позволяет использовать в качестве библиотеки отверстий другой файл. После нажатия кнопки на экране появляется стандартный диалог выбора файла. Укажите нужный файл библиотеки. Он будет автоматически использоваться системой при вызове команды Отверстие из библиотеки.
Имя файла библиотеки эскизов | Поле содержит полное имя файла библиотеки эскизов.
Изменить... | Кнопка позволяет использовать в качестве библиотеки эскизов другой файл. После нажатия кнопки на экране появляется стандартный диалог выбора файла. Укажите нужный файл библиотеки. Он будет автоматически использоваться системой при вызове команды Эскиз из библиотеки.

Указав имена файлов библиотек, нажмите кнопку OK. Для выхода из диалога без изменения настроек нажмите кнопку Отмена.


9.1.11.5. Управление изображением

Параметры изображения моделей в окне настраиваются в диалоге Управление изображением. Диалог появляется на экране после вызова команды Сервис — Параметры... — Система — Редактор моделей — Управление изображением.

Табл. 9.1.51. Элементы управления диалога настройки параметров изображения моделей

Элемент

Описание настройки

Шаг перемещения изображения модели (% окна)

Поле для ввода величины перемещения изображения модели в окне при однократном нажатии клавиши, сдвигающей изображение. Шаг перемещения устанавливается в процентах от размера окна.

Например, после ввода в это поле значения 25 при нажатии комбинации клавиш <Shift>+<→> изображение сместится вправо на четверть (25 %) ширины окна.

Шаг угла поворота модели (гр.)

Поле для ввода величины поворота модели в окне при однократном нажатии клавиатурной комбинации, вращающей деталь. Шаг перемещения устанавливается в градусах.

Например, после ввода в это поле значения 15 ° при нажатии комбинации <Alt>+<→> модель повернется вокруг вертикальной оси вправо на 15 ° (и ее изображение изменится соответствующим образом).

Коэффициент изменения масштаба

Поле для ввода коэффициента увеличения или уменьшения изображения в окне при однократном нажатии клавиатурной комбинации, изменяющей масштаб изображения.

Например, после ввода в это поле значения 1,5 при нажатии комбинации <Shift>+<-> линейные размеры изображения будут уменьшены в полтора раза.

Использовать аппаратное ускорение

Опция, включение которой означает, что изображение модели на экране монитора формируется графическим процессором. Если вы наблюдаете неудовлетворительное изображение модели, отключите опцию Использовать аппаратное ускорение. После этого функция формирования изображения будет передана центральному процессору (что, возможно, несколько замедлит работу компьютера).

Если ваш компьютер оснащен видеокартой, не предусматривающей аппаратное ускорение, опция отключена и недоступна.

Использовать дополнительный буфер изображения

Опция для включения и отключения использования дополнительных аппаратных возможностей видеокарты компьютера, которые позволяют ускорить отображение трехмерных моделей. Доступна, если включена опция Использовать аппаратное ускорение.

Использование дополнительного буфера изображения позволяет ускорить обновление ранее сформированного изображения1.

Например, возможно ускорение восстановления части изображения, которая была закрыта меню или диалогом; возможно также ускорение динамического поиска (если инверсия при подсвечивании отключена)2 — за счет более быстрого восстановления изображения во время перемещения курсора от одного объекта модели к другому.

Ускорение заметно тем сильнее, чем сложнее модель.

Следует, однако, иметь в виду, что не все видеокарты обладают дополнительными возможностями ускорения отображения, а также не все драйверы видеокарт задействуют эти возможности. Поэтому появление ускорения в результате включения опции Использовать дополнительный буфер изображения зависит от модели видеокарты и версии драйвера, установленных на конкретном компьютере.

Прозрачность

Группа опций позволяет выбрать способ отображения прозрачных объектов (граней, компонентов, поверхностей и др.).

Включите опцию Сетчатая, чтобы область, занимаемая прозрачным объектом, заполнялась отдельными пикселами. Цвет пикселов соответствует цвету объекта при нулевой прозрачности. Пикселы размещаются на экране, образуя регулярную структуру — сетку. «Ячейки сетки», т.е. участки, где пикселы прозрачного объекта отсутствуют, тем крупнее, чем большее значение параметра Прозрачность имеет данный объект3.

Включите опцию Реалистичная, чтобы отображение прозрачных объектов было максимально приближено к виду объектов, выполненных из прозрачного материала.
  1. Иногда включение опции может давать обратный эффект. В этом случае отключите ее.
  2. Динамический поиск описан в разделе 2.1.4.1.2; включение и выключение инверсии — в разделе 9.1.11.8.
  3. Степень прозрачности объекта задается при настройке его свойств (см. раздел 2.14.2). По умолчанию значение параметра Прозрачность равно 0%, т.е. все объекты создаются непрозрачными. При необходимости прозрачность можно увеличить. 100%-ная прозрачность означает, что объект будет невидим.

Задав параметры изображения, нажмите кнопку OK. Для выхода из диалога без изменения настроек нажмите кнопку Отмена.

Для того чтобы изменение способа формирования изображения вступило в силу, после включения или отключения опции Использовать аппаратное ускорение необходимо перезапустить КОМПАС-3D.


9.1.11.6. Изменение ориентации

Настройка изменения ориентации выполняется в диалоге Изменение ориентации, вызываемом командой Сервис — Параметры... — Система — Редактор моделей — Изменение ориентации. Диалог позволяет задать параметры отображения моделей во время изменения ориентации (масштаба) и после изменения ориентации, а также выбрать предопределенную ориентацию при редактировании эскиза и при выполнении операций.

Табл. 9.1.52. Элементы управления диалога настройки изменения ориентации

Элемент

Описание настройки

Плавность

Опция позволяет включить показ промежуточных кадров между кадрами, изображающими модель в начальном и конечном положениях (масштабах). Благодаря этому изменение положения (масштаба) модели выглядит не скачкообразным, а плавным. Когда опция Плавность включена, вы можете настроить количество промежуточных кадров, перемещая «ползунок» между позициями Меньше и Больше. При уменьшении количества кадров изменение изображения модели становится менее плавным, но ускоряется, а при увеличении — наоборот.

Центрировать изображение

Опция позволяет включить центрирование1 изображения модели во время изменения ее ориентации, в том числе при автоматическом изменении ориентации во время создания эскизов и операций (это изменение происходит, если включены опции При редактировании эскиза и При создании операции соответственно).

Сохранять текущий масштаб окна

Опция позволяет включить сохранение масштаба, установленного в окне модели, при изменении ее ориентации.

Если опция отключена, то после изменения ориентации, в том числе после автоматического изменения ориентации во время создания эскизов и операций, масштаб отображения модели изменяется (см. таблицу 9.1.53).

При редактировании эскиза

Опция позволяет включить автоматическую установку ориентации Нормально к при создании нового эскиза. При выходе из режима эскиза модель возвращается в прежнюю ориентацию. Если ориентация модели была изменена во время работы с эскизом, то при последующем его редактировании эта ориентация восстанавливается. Если опция При редактировании эскиза отключена, то ориентация модели во время создания и редактирования эскиза не изменяется.

При создании операции

Опция позволяет включить автоматическую установку указанной ориентации при создании нового формообразующего элемента, листового тела или новой поверхности. Для указания ориентации разверните список и выберите нужную строку.

При выходе из операции текущая ориентация модели сохраняется. При редактировании операций ориентация модели не изменяется.
  1. Центрирование — совмещение центра окна документа с центром проекции габаритного параллелепипеда модели. Центр окна определяется без учета области, занимаемой Деревом построения.

Табл. 9.1.53. Правила подбора масштаба отображения модели при изменении ее ориентации
Способ изменения ориентации | Правила подбора масштаба
Выбор нужной ориентации вручную Автоматическая установка в выбранную ориентацию при создании операции | Подбирается такой масштаб, чтобы в окне модели полностью умещался ее габаритный параллелепипед — условный параллелепипед, грани которого параллельны координатным плоскостям и проходят через наиболее удаленные друг от друга точки объектов модели.
Автоматическая установка в ориентацию Нормально к... при создании эскиза | При создании эскиза на координатной плоскости устанавливается масштаб 1.0. При создании эскиза на грани детали или на вспомогательной плоскости подбирается такой масштаб, при котором грань или плоскость полностью умещается в окне модели. Габариты вспомогательной плоскости определяются размерами прямоугольника, изображающего ее на экране.

Задав параметры отображения, нажмите кнопку OK. Для выхода из диалога без изменения настроек нажмите кнопку Отмена.


9.1.11.7. Перспективная проекция

Настройка параметров перспективной проекции (степень вносимого перспективой искажения) для всех окон выполняется в диалоге Перспективная проекция, вызываемом командой Сервис — Параметры... — Система — Редактор моделей — Перспективная проекция. При настройке параметров перспективной проекции для текущего окна используется аналогичный диалог.

Диалог содержит поле Расстояние в габаритах модели. Значение в этом поле показывает, во сколько раз расстояние от модели до плоскости изображения больше, чем максимальный габарит модели. Другими словами, на экране показывается такое изображение модели, которое получил бы оптический прибор, находящийся на указанном расстоянии от модели. Чем меньше указанное расстояние, тем сильнее будет заметно искажение изображения.

Для завершения настройки нажмите кнопку OK. Для выхода из диалога без сохранения изменения нажмите кнопку Отмена.


9.1.11.8. Редактирование

Настройка цветов выделенных и указанных объектов выполняется в диалоге Редактирование модели, вызываемом командой Сервис — Параметры... — Система — Редактор моделей — Редактирование.

Диалог позволяет задать цвета:

– объектов модели при их выделении и указании,

– объектов, указываемых в процессе выполнения операций,

– компонентов, составляющих «обстановку» при редактировании одного из компонентов в контексте содержащей его модели (см. раздел 2.11.7.2.1),

– фантомов.

Табл. 9.1.54. Элементы управления диалога настройки цветов выделенных и указанных объектов

Элемент

Описание настройки

Таблица цветов объектов

Первая колонка таблицы содержит цвета, а вторая — названия типов объектов, использующих эти цвета.

Чтобы сменить цвет, щелкните мышью в его ячейке, затем нажмите кнопку с треугольником, появившуюся в правой части ячейки, и выберите нужный цвет в стандартном диалоге выбора цвета.

Подсвечивание — Выделенный объект

Цвет выделенных объектов.

Выделение объектов часто требуется перед выполнением какой-либо команды. Например, для построения формообразующего трехмерного элемента необходимо выделить его эскиз; для получения копии графического объекта — исходный графический объект.

Подсвечивание — Указанный объект 1 / Указанный объект 2 / Указанный объект 3

Цвета объектов (или групп объектов), указываемых при выполнении операции.

Указание объектов требуется во время выполнения некоторых команд. Например, для построения кинематического элемента необходимо указать его траекторию; для построения параллельного отрезка — другой отрезок или прямую.

Разноцветная подсветка позволяет различать объекты при указании, так как в некоторых операциях используется не один, а несколько объектов, выполняющих разные функции. Например, при построении массива по параллелограммной сетке все исходные объекты будут подсвечены цветом для первого объекта, объект, указанный в качестве первой оси — цветом для второго объекта, а объект, указанный в качестве второй оси — цветом для третьего объекта.

Цвет, заданный для первого указанного объекта, используется также при подсвечивании объектов во время динамического поиска (динамическом подсвечивании)1 при условии, что опция Инверсия при динамическом подсвечивании отключена.

Контекстное редактирование — Пассивные компоненты

Цвет пассивных компонентов. Пассивные компоненты — компоненты, которые служат «обстановкой» при редактировании компонента в контексте модели, содержащей компоненты.

Если включена опции Использовать собственные цвета компонентов, то заданный цвет игнорируется.

Фантом — Грани

Цвет граней фантома, показывающегося на экране во время создания или редактирования трехмерного элемента. Так как фантом отображается полупрозрачным, его вид зависит также от настройки прозрачности — сетчатая или реалистичная (см. раздел 9.1.11.5).

Фантом — Надписи

Цвет надписей в составе фантома операции, например, номеров кривых при построении поверхности по сети кривых.

Размеры

Цвет размеров эскизов и операций.

Закрашивать грани при подсвечивании

Включите эту опцию, чтобы при выделении (указании) объектов их грани заливались цветом, выбранным для выделения (указания).

Если опция отключена, то при выделении (указании) изменяют цвет только ребра.

Обратите внимание на то, что при динамическом подсвечивании грани не закрашиваются — изменяется только цвет ребер.

Инверсия при динамическом подсвечивании

Опция позволяет включить инверсное динамическое подсвечивание ребер вместо подсвечивания цветом, заданным для первого указанного объекта. Рекомендуется включать данную опцию при работе со сложными сборками — это позволяет ускорить динамический поиск.

Собственные цвета компонентов при контекстном редактировании

Включение опции означает, что во время контекстного редактирования компоненты будут сохранять свои цвета.

При указании использовать
OpenGL-поиск

Включение опции означает, что динамический поиск ведется на основе объектов OpenGL. В некоторых случаях это позволяет оптимизировать процесс динамического поиска.
  1. Динамический поиск описан в разделе 2.1.4.1.2.

Задав нужные цвета выделенных и указанных объектов, нажмите кнопку OK. Для выхода из диалога без изменения настроек нажмите кнопку Отмена.


9.1.11.9. ЛСК

Выбор умолчательных способов работы с ЛСК (локальными системами координат, см. раздел 2.8.3.2) осуществляется в диалоге ЛСК. Диалог появляется на экране после вызова команды Сервис — Параметры... — Система — Редактор моделей — ЛСК. Описание опций, содержащихся в диалоге, приведено в таблице 9.1.55. По умолчанию опции включены.

Табл. 9.1.55. Элементы управления диалога настройки ЛСК

Элемент

Описание настройки

При создании ЛСК назначать ее текущей СК

– Если эта опция включена, то новой ЛСК автоматически присваивается статус «текущая».

– Если эта опция отключена, то после создания новой ЛСК текущей остается та ЛСК, что была до создания.

Вне зависимости от состояния данной опции пользователь может сделать текущей любую из имеющихся в модели систем координат (см. раздел 2.8.3.3).

Создавать ЛСК только в абсолютной СК

– Если эта опция включена, то при создании всех новых ЛСК их параметры задаются относительно абсолютной системы координат модели (см. раздел 2.8.3.1).

– Если эта опция отключена, то параметры новой ЛСК задаются относительно той системы координат, которая в данный момент является текущей. Таким образом возможно формирование в модели иерархии ЛСК.

Завершив настройку, нажмите кнопку ОК. Чтобы закрыть диалог без изменения настройки, нажмите кнопку Отмена.


9.1.11.10. Исполнения

Настройка создания объектов и переменных в зависимых исполнениях модели выполняется в диалоге Исполнения. Диалог появляется на экране после вызова команды Сервис — Параметры... — Система — Редактор моделей — Исполнения. Описание опций, содержащихся в диалоге, приведено в таблице 9.1.56. По умолчанию опции включены.

Табл. 9.1.56. Элементы управления диалога настройки создания объектов и переменных
Элемент | Описание настройки
Создавать объект в зависимых исполнениях | Если опция включена, то при создании нового объекта в исходном исполнении во всех его зависимых исполнениях создается идентичный объект. Если опция отключена, то новый объект в зависимых исполнениях не создается.
Создавать переменную в зависимых исполнениях | Если опция включена, то при создании новой пользовательской переменной в исходном исполнении во всех его зависимых исполнениях создается идентичная пользовательская переменная. Если опция отключена, то новая пользовательская переменная в зависимых исполнениях не создается.

Завершив настройку, нажмите кнопку ОК. Чтобы закрыть диалог без изменения настройки, нажмите кнопку Отмена.


9.1.11.11. Зеркальное отражение

Настройка параметров создания компонентов и исполнений зеркальным отражением или симметричной вставкой выполняется в диалоге Зеркальное отражение, вызываемом командой Сервис — Параметры... — Система — Редактор моделей — Зеркальное отражение, а также после нажатия кнопки Настройка общих параметров зеркального отражения в диалоге настройки параметров зеркального отражения (см. раздел 2.11.3.4).

Табл. 9.1.57. Элементы управления диалога настройки зеркального отражения компонента

Элемент

Описание настройки

Формат отображения результата зеркального отражения

Группа полей позволяет задать порядок формирования наименований компонентов, получаемых зеркальным отражением, а также создаваемых зеркальных исполнений.

Наименование компонента/исполнения формируется добавлением предопределенного суффикса к наименованию исходного компонента/исполнения по шаблону:

<Наименование исходного объекта><Суффикс>.

Наборы символов, составляющих суффиксы, задаются в полях данной группы.

Суффикс наименования компонента

Поле для ввода суффикса, который будет добавляться в наименования компонентов (кроме стандартных изделий), создаваемых зеркальным отражением с сохранением в отдельный файл. Добавленный суффикс передается в этот файл.

Суффикс наименования исполнения

Поле для ввода суффикса, который будет добавляться в наименования зеркальных исполнений. Суффикс добавляется независимо от того, каким способом создается зеркальное исполнение.

Суффикс имени файла при сохранении

Поле для ввода суффикса, добавляемого в имена файлов, в которые сохраняются модели зеркально отраженных компонентов.

Создание файлов и запись в них моделей компонентов выполняется в том случае, если при зеркальном отражении компонентов из группы вариантов получения результата выбран вариант Сохранить зеркальный компонент в файле (см. раздел 2.11.3.4.1).

Сохранять файлы при зеркальном отображении компонентов в:

Группа опций позволяет выбрать папку, в которой будут созданы файлы моделей зеркально отраженных компонентов.

Создание файлов и запись в них моделей компонентов выполняется в том случае, если при зеркальном отражении компонентов из группы вариантов получения результата выбран вариант Сохранить зеркальный компонент в файле.

Системный рабочий каталог

Опция позволяет создать файлы компонентов в рабочей папке системы.

Путь к папке отображается в поле, расположенном рядом с опцией.

Каталог, содержащий файл-источник исходного компонента

Опция позволяет создать файлы компонентов в тех папках, в которых содержатся файлы их исходных компонентов.

Другой каталог

Опция позволяет выбрать любую папку для создания файлов компонентов. При включенной опции доступна кнопка Обзор..., позволяющая указать нужную папку.

Обзор...

Кнопка позволяет указать папку для создания файлов компонентов. Вызывает диалог выбора папки. Кнопка доступна, если включена опция Другой каталог.

После выбора папки путь к ней отображается в поле, расположенном рядом с опцией.

Завершив настройку, нажмите кнопку ОК. Чтобы закрыть диалог без изменения настройки, нажмите кнопку Отмена.


9.1.11.12. Размеры и обозначения

Отображение на экране размеров и обозначений в модели настраивается в диалоге Отображение размеров и обозначений. Диалог появляется на экране после вызова команды Сервис — Параметры... — Система — Редактор моделей — Размеры и обозначения.

Элементы управления, содержащиеся в диалоге, описаны в таблице 9.1.58.

Табл. 9.1.58. Элементы управления диалога настройки отображения размеров и обозначений

Элемент

Описание настройки

Оптимизировать отображение

Опция управляет отображением размерных надписей и текстов в составе условных обозначений.

– Если опция включена, то можно выбрать вариант расположения размерных надписей (см. ниже). Высота шрифта размерной надписи и текста обозначения не изменяется при изменении масштаба отображения модели. Параметры размеров в эскизе (длина стрелок, выход выносных линий за размерную и т.п.) также не изменяются при изменении масштаба.

– Если опция отключена, то размерные надписи отображаются в плоскостях простановки размеров. Высота шрифта размерной надписи и текста обозначения изменяется соответственно изменению масштаба отображения модели.

Текст обозначения отображается в плоскости создания обозначения вне зависимости от состояния опции Оптимизировать отображение.

Размещать размерные надписи

Группа элементов управления, позволяющая выбрать вариант расположения размерных надписей:

– В плоскости размера;

– В плоскости экрана горизонтально;

– В плоскости экрана.

Показывать

Группа опций, управляющая отображением на экране размеров эскизов и операций (см. раздел 2.9.2.2) и соединительных линий.

– Включите опцию Размеры эскизов и операций, чтобы при создании или редактировании операции размеры эскизов и операций отображались на экране.

– Включите опцию Соединительные линии, чтобы соединительные линии проставленных размеров (например, линии проекций или линии, условно показывающие образмеренный объект) отображались на экране.

Обратите внимание на то, что оптимизация отображения размеров и обозначений не распространяется на печать изображения моделей. Модель выводится на печать так, как она показывается на экране при отключенной опции Оптимизировать отображение.

Чтобы завершить настройку отображения размеров и обозначений в модели, нажмите кнопку OK. Для выхода из диалога без изменения настроек нажмите кнопку Отмена.


9.1.11.13. Габарит

Настройка габарита модели выполняется в диалоге Габарит модели, вызываемом командой Сервис — Параметры... — Система — Редактор моделей — Габарит.

Элементы управления диалога позволяют указать типы объектов модели, которые должны учитываться при построении ее габаритного параллелепипеда — условного параллелепипеда, грани которого параллельны координатным плоскостям и проходят через наиболее удаленные друг от друга точки объектов модели.

Габаритный параллелепипед используется, например:

– для работы команды Показать все (как в режиме трехмерных построений, так и в режиме эскиза) — масштаб отображения изменяется так, чтобы проекция габаритного параллелепипеда модели на плоскость экрана вписалась в окно,

– при центрировании изображения после изменения ориентации модели — центр проекции габаритного параллелепипеда совмещается с центром окна модели.

Чтобы нужный тип объектов учитывался при построении габаритного параллелепипеда модели, включите опцию слева от названия этого типа в диалоге. При отключенной опции тип объектов учитываться не будет.

Отключить все опции невозможно — последняя включенная опция будет недоступна для отключения.

Чтобы в определении габарита модели участвовали также скрытые объекты указанных типов, включите опцию Учитывать скрытые объекты.

После завершения настройки габарита нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.1.11.14. Зоны

Настройка уровня документа, на котором выбираются объекты при выделении с помощью зоны, выполняется в диалоге Зоны, вызываемом командой Сервис — Параметры... — Система — Редактор моделей —Зоны.

– Если опция Выбирать зоной объекты только на первом уровне текущего документа включена, то с помощью зон можно выделять объекты, построенные непосредственно в модели, и компоненты первого уровня. Компоненты второго и последующих уровней выделить невозможно.

– Если опция отключена, то с помощью зон могут быть выделены объекты, построенные непосредственно в модели, и компоненты любого уровня.

Для завершения настройки нажмите кнопку OK. Для выхода из диалога без сохранения изменения нажмите кнопку Отмена.


9.1.11.15. МЦХ

Если масса и центр масс модели не заданы пользователем, а находятся расчетным путем, то после редактирования модели, которое может привести к изменению массы и положения центра масс, их текущие значения удаляются из модели. Чтобы получить новые значения массы и координат центра масс, необходимо пересчитать МЦХ. Это можно делать вручную (с помощью команды МЦХ модели, см. раздел 2.15.2.4) или автоматически.

По умолчанию автоматический пересчет МЦХ производится при сохранении модели. Пользователь может дополнительно включить автоматический пересчет МЦХ при перестроении модели или отключить автоматический пересчет МЦХ. Эта настройка производится в диалоге МЦХ, вызываемом командой Сервис — Параметры... — Система — Редактор моделей — МЦХ.

Вы можете включить одну из опций диалога — Пересчитывать МЦХ при сохранении или Пересчитывать МЦХ при перестроении или обе опции.

Результаты автоматического пересчета МЦХ сохраняются в файле модели. При вставке модели в другую модель они передаются в эту модель и используются при вычислении ее массо-центровочных характеристик.

Если ни одна из опций не включена, автоматический пересчет МЦХ не производится.

После завершения настройки нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.1.11.16. Упрощения

В этом разделе:

9.1.11.16.1. Модель

9.1.11.16.2. Прочие


9.1.11.16.1. Модель

Параметры отрисовки моделей в режиме упрощенного отображения (см. раздел 2.1.3.6) настраиваются в диалоге Упрощенное отображение модели. Диалог появляется на экране после вызова команды Сервис — Параметры... — Система — Редактор моделей — Упрощения — Модель.

Табл. 9.1.59. Элементы управления диалога настройки упрощенного отображения модели

Элемент

Описание настройки

Уровень детализации

Элемент управления позволяет задать уровень детализации компонентов и тел модели при работе режима упрощенного отображения.

Для изменения уровня детализации перемещайте «ползунок» между позициями Больше (медленнее) и Меньше (быстрее). Чем степень детализации меньше, тем более крупные компоненты или тела превращаются в параллелепипеды и тем быстрее происходит изменение положения (масштаба) модели.

Применять дополнительный режим для стандартных компонентов

Опция позволяет включить специальный режим упрощения стандартных компонентов (например, моделей, вставленных из Справочника Стандартные Изделия). Если опция отключена, стандартные компоненты упрощаются в общем режиме, т.е. подчиняются настройке уровня детализации компонентов.

Упрощать

Включите эту опцию, чтобы стандартные компоненты во время работы режима упрощенного отображения всегда показывались в виде параллелепипедов вне зависимости от установленного уровня детализации. Опция доступна при включенной опции Применять дополнительный режим для стандартных компонентов.

Скрывать

Включите эту опцию, чтобы стандартные компоненты всегда скрывались во время работы режима упрощенного отображения. Опция доступна при включенной опции Применять дополнительный режим для стандартных компонентов.

Задержка поиска объектов, мсек

Опция позволяет включить задержку динамического поиска объектов во время работы режима упрощенного отображения. В поле справа от опции введите величину задержки (в миллисекундах) — промежутка времени, в течение которого курсор должен находиться на объекте, прежде чем сработает динамический поиск.

Таким образом, если опция включена, то объект модели подсвечивается не сразу, а только после остановки курсора на нем. Если же опция отключена, то система пытается найти и подсветить объект немедленно. При работе с большими сборками это не всегда возможно (динамический поиск может отставать от движения курсора, т.е. могут подсвечиваться те объекты, которые курсор уже прошел), поэтому для таких моделей рекомендуется включать задержку поиска.

Чтобы завершить настройку упрощенного отображения, нажмите кнопку OK. Для выхода из диалога без изменения настроек нажмите кнопку Отмена.


9.1.11.16.2. Прочие

Вы можете включить дополнительные средства упрощения, позволяющие еще более ускорить работу в режиме упрощенного отображения модели (см. раздел 2.1.3.6). Для этого используется диалог Прочие параметры упрощения отображения, вызываемый командой Сервис — Параметры... — Система — Редактор моделей — Упрощения — Прочие.

Табл. 9.1.60. Элементы управления диалога прочих настроек режима упрощенного отображения

Элемент

Описание настройки

При изменении изображения

Группа опций позволяет включить или отключить дополнительные упрощения, которые будут действовать в режиме упрощенного отображения при следующих изменениях изображения:

– сдвиг и поворот модели мышью или с помощью команд Сдвинуть и Повернуть,

– изменение ориентации и масштаба модели, если включена плавность (см. раздел 9.1.11.6),

– сдвиг и поворот компонентов.

На статичное изображение модели состояние опций этой группы не влияет.

Быстрое отображение линий

Опция позволяет использовать быстрое отображение линий модели. Если эта опция включена, то при изменении изображения автоматически активизируется команда Быстрое отображение линий 1.

Скрыть конструктивные оси, плоскости
и пр.

Опция позволяет управлять отображением вспомогательных и некоторых других объектов модели. Если эта опция включена, то при изменении изображения автоматически активизируются следующие команды:

– Скрыть — Начала координат,

– Скрыть — Конструктивные плоскости,

– Скрыть — Конструктивные оси,

– Скрыть — Эскизы.

Скрыть поверхности

Опция позволяет управлять отображением поверхностей, присутствующих в окне модели. Если эта опция включена, то при изменении изображения автоматически активизируется команда Скрыть — Поверхности.

При отключенной опции поверхности остаются видны и упрощаются в соответствии с заданным уровнем детализации.

Скрыть пространственные кривые

Опция позволяет управлять отображением пространственных кривых — ломаных, сплайнов и спиралей.

Если эта опция включена, то при изменении изображения автоматически активизируется команда Скрыть — Пространственные кривые.

Отключить режим “Полутоновое
с каркасом”

Опция позволяет управлять использованием указанного типа отображения модели. Если эта опция включена, то для тех компонентов или тел, которые не превратились в параллелепипеды, при изменении изображения отключается полутоновое отображение с каркасом (если оно было включено).

Отключить отрисовку очерков

Опция позволяет отключить отрисовку линий очерков2 компонентов или тел.

Скрыть сетку

Опция позволяет отключить изображение сетки при изменении масштаба эскиза.

Отключить подсветку выделенных объектов

Опция позволяет отключить подсветку выделенных объектов (кроме граней) при изменении изображения.

Если опция отключена, то выделенные объекты остаются подсвеченными.

Наличие или отсутствие выделенных граней не влияет на скорость изменения изображения.

Сетчатая прозрачность

Опция позволяет включить показ прозрачных объектов (если таковые имеются) в виде сетки пикселов.

Скрыть контрольные точки,

Скрыть условные изображения резьбы,

Скрыть размеры,

Скрыть условные обозначения

Опции позволяют отключить отрисовку контрольных и присоединительных точек, изображений резьбы, размеров и обозначений.

Невидимые объекты отображать
в виде точек

Опция позволяет включить отображение точек на месте компонентов (или тел), ставших невидимыми из-за мелкого масштаба. Ставшие невидимыми объекты могут отображаться в виде точек только в режиме упрощенной отрисовки.

Если опция отключена, то компоненты и тела относительно малого размера могут совсем «исчезнуть» при определенном масштабе уменьшения.

Стандартные компоненты могут также стать невидимыми в результате включения опции Скрывать в диалоге настройки упрощения модели (см. раздел 9.1.11.16.1).
  1. Команда управляет одноименным режимом. При включенном режиме быстрого отображения линий ускоряется отрисовка линий, изображающих модель без невидимых линий, с тонкими невидимыми линиями или в каркасном отображении.
    Ускорение прорисовки модели достигается благодаря применению так называемого графического способа расчета линий модели. При отключенном режиме быстрого отображения этот расчет ведется математически. Математический расчет дает несколько более точный результат, но требует гораздо больше времени.
  2. Линия очерка — линия, в точках которой нормаль грани перпендикулярна направлению взгляда.

Чтобы завершить настройку упрощенного отображения, нажмите кнопку OK. Для выхода из диалога без изменения настроек нажмите кнопку Отмена.


9.1.12. Отчеты

9.1. Параметры системы

9.1.12. Отчеты

В этом разделе:

9.1.12.1. Настройка списка стилей отчетов

9.1.12.2. Линейки прокрутки

9.1.12.3. Размещение таблицы

9.1.12.3.1. Формат листа

9.1.12.3.2. Поля листа


9.1.12.1. Настройка списка стилей отчетов

Подключение стилей, находящихся в библиотеке стилей, выполняется в диалоге Настройка списка стилей отчетов, вызываемом командой Сервис — Параметры... — Система — Отчеты — Настройка списка стилей отчетов.

Диалог также можно вызвать при создании отчета выбором строки Другой... в списке стилей на Панели свойств.

Диалог позволяет указать ранее созданные библиотеки стилей (файлы *.lrt) и выбрать из них стили для использования в отчетах.

Табл. 9.1.61. Элементы управления диалога настройки списка стилей отчетов
Элемент | Описание настройки
Вкладка Библиотеки стилей | Элементы управления вкладки служат для подключения библиотек стилей. На вкладке отображается список библиотек, представленный в виде таблицы. Каждая строка таблицы содержит имя файла библиотеки и путь к нему. Кнопки Добавить и Удалить позволяют изменять состав списка. Чтобы подключить нужную библиотеку, включите опцию рядом с ее именем. Стили из подключенных библиотек доступны для выбора на вкладке Стили.
Добавить | Кнопка позволяет добавить библиотеку в список. После ее нажатия на экране появляется стандартный диалог выбора файла.
Удалить | Кнопка позволяет исключить из списка выделенную библиотеку.
Переместить вверх/вниз | Кнопки позволяют перемещать библиотеки в списке. Чтобы переместить библиотеку вверх, выделите ее название и нажмите кнопку Переместить вверх, а чтобы переместить вниз — кнопку Переместить вниз. Выбранная библиотека переместится на одну позицию в указанном направлении.
Вкладка Стили | Элементы управления вкладки служат для подключения стилей, используемых в отчете. На вкладке отображается список стилей из библиотек, подключенных на вкладке Библиотеки стилей. Список представлен в виде таблицы. Каждая строка таблицы содержит имя стиля и путь к файлу библиотеки, содержащему этот стиль. Чтобы подключить нужный стиль, включите опцию рядом с его именем.
Все | Опция позволяет подключить или отключить использование в отчете всех стилей, содержащихся в списке.
Просмотр | Кнопка позволяет просмотреть параметры выделенного стиля. После ее нажатия на экране появляется диалог настройки параметров стиля в режиме просмотра.

Объекты, расположенные в диалоге, могут быть отсортированы по любому из столбцов. Чтобы выбрать столбец для сортировки, щелкните мышью по его заголовку. Рядом с заголовком появляется треугольник. Он показывает направление сортировки. Если вершина треугольника направлена вниз, то сортировка списка производится по убыванию значений в этом столбце, а если вверх — то по возрастанию.

На вкладке Библиотеки стилей подключите библиотеку стилей отчета, а на вкладке Стили подключите стиль. Последовательность действий описана в разделе 5.2.2.2.8.


9.1.12.2. Линейки прокрутки

Управление отображением линеек прокрутки на экране и автоматическим сдвигом изображения в окне выполняется в диалоге Установка линеек прокрутки, вызываемом командой Сервис — Параметры... — Система — Отчеты — Линейки прокрутки. Работа в диалоге описана в разделе 9.1.7.3.


9.1.12.3. Размещение таблицы

В этом разделе:

9.1.12.3.1. Формат листа

9.1.12.3.2. Поля листа


9.1.12.3.1. Формат листа

Задание формата листов отчета выполняется в диалоге Формат листа, вызываемом командой Сервис — Параметры... — Система — Отчеты — Размещение таблицы — Формат листа.

Диалог позволяет выбрать формат листов из стандартного ряда или задать произвольные размеры листов.

Аналогичный диалог используется при задании формата листов текстовых и графических документов, а также дополнительных листов спецификации.

Табл. 9.1.62. Элементы управления диалога настройки формата листов
Элемент | Описание настройки
Стандартный | Опция позволяет задать размеры листов документа в соответствии с одним из стандартных форматов. При включенной опции доступны элементы выбора нужного формата и задания его параметров.
Обозначение | Раскрывающийся список позволяет выбрать нужный формат.
Кратность | Поле позволяет ввести или задать с помощью счетчика кратность размеров листов стандартному формату.
Ориентация | Группа опций позволяет выбрать вариант ориентации листов документа — Горизонтальная или Вертикальная.
Пользовательский | Опция позволяет задать произвольные размеры листов документа. При включенной опции доступны поля задания размеров.
Ширина, мм Высота, мм | Поля позволяют ввести произвольные значения размеров листов документа.
Применить к разделу | Список позволяет выбрать раздел текстового документа, к которому будут применены настройки, сделанные в диалоге. Список присутствует в диалоге только при настройке текущего текстового документа и доступен, если документ содержит более одного раздела.

После завершения настройки формата листов нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.1.12.3.2. Поля листа

Вы можете задать размеры рамки, ограничивающей область печати на листе. Для этого используется диалог Поля листа, вызываемый командой Сервис — Параметры... — Система — Отчеты — Размещение таблицы — Поля листа.

Введите или задайте с помощью счетчика значения отступов в миллиметрах. Отступы отсчитываются от границ формата листа

Для завершения настройки нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.2. Параметры новых и текущего документов

В этом разделе:

9.2.1. Общие сведения о настройке новых и текущего документов

9.2.1.1. Типы параметров объектов

9.2.2. Имя файла по умолчанию

9.2.3. Свойства документа

9.2.4. Текстовый документ

9.2.4.1. Шрифт по умолчанию

9.2.4.2. Параметры листа

9.2.4.2.1. Формат

9.2.4.2.2. Оформление

9.2.4.3. Текст документа

9.2.4.4. Заголовок таблицы

9.2.4.5. Ячейка таблицы

9.2.4.6. Нумерация листов

9.2.4.7. Параметры таблицы отчета

9.2.4.7.1. Заголовок

9.2.4.7.2. Ячейка

9.2.5. Спецификация

9.2.5.1. Умолчательные настройки

9.2.5.1.1. Стиль

9.2.5.1.2. Нумерация листов

9.2.5.1.3. Дополнительные листы

9.2.5.1.4. Отображение величин

9.2.5.2. По сборке с исполнениями

9.2.5.2.1. Параметры выбора варианта настроек

9.2.5.2.2. Общий вариант

9.2.5.2.3. При числе исполнений не более заданного

9.2.6. Графический документ

9.2.6.1. Шрифт по умолчанию

9.2.6.2. Единицы измерения

9.2.6.3. Группирование слоев

9.2.6.4. Дерево чертежа

9.2.6.5. Настройка списка свойств

9.2.6.6. Линии

9.2.6.6.1. Стили

9.2.6.6.2. Осевая линия

9.2.6.7. Линия разрыва

9.2.6.8. Линии обрыва

9.2.6.8.1. Волнистая линия

9.2.6.8.2. Линия с изломами

9.2.6.8.3. Фильтр стилей линий

9.2.6.9. Мультилиния

9.2.6.10. Размеры

9.2.6.10.1. Общие настройки

9.2.6.10.2. Параметры

9.2.6.10.3. Отметки уровня

9.2.6.10.4. Стрелки и засечки

9.2.6.10.5. Фильтры стрелок — Линейные размеры

9.2.6.10.6. Фильтры стрелок — Размеры окружностей и дуг

9.2.6.10.7. Фильтры стрелок — Угловые размеры

9.2.6.10.8. Надпись

9.2.6.10.9. Положение надписи

9.2.6.10.10. Допуски и предельные значения — Параметры

9.2.6.10.11. Допуски и предельные значения — Допуски по умолчанию

9.2.6.10.12. Точности

9.2.6.11. Линия-выноска

9.2.6.11.1. Параметры

9.2.6.11.2. Стрелки и засечки

9.2.6.11.3. Фильтр стрелок

9.2.6.11.4. Текст над/под/за полкой

9.2.6.11.5. Наклонный текст

9.2.6.11.6. Размеры знаков

9.2.6.12. Условное пересечение

9.2.6.13. Обозначения для машиностроения

9.2.6.13.1. Обозначение позиции — Параметры

9.2.6.13.2. Обозначение позиции — Параметры формы

9.2.6.13.3. Обозначение позиции — Стрелки

9.2.6.13.4. Обозначение позиции — Фильтр стрелок

9.2.6.13.5. Обозначение позиции — Текст обозначения позиций

9.2.6.13.6. Шероховатость

9.2.6.13.7. Отклонения формы и база

9.2.6.13.8. Линия разреза/сечения — Параметры

9.2.6.13.9. Линия разреза/сечения — Стрелки

9.2.6.13.10. Линия разреза/сечения — Фильтр стрелок

9.2.6.13.11. Стрелка взгляда — Параметры

9.2.6.13.12. Стрелка взгляда — Стрелки

9.2.6.13.13. Стрелка взгляда — Фильтр стрелок

9.2.6.13.14. Автосортировка

9.2.6.13.15. Обозначение изменения — Параметры

9.2.6.13.16. Обозначение изменения — Текст надписи

9.2.6.14. Обозначения для строительства

9.2.6.14.1. Марка/позиционное обозначение — Общие настройки

9.2.6.14.2. Марка/позиционное обозначение — С линией-выноской

9.2.6.14.3. Марка/позиционное обозначение — На линии

9.2.6.14.4. Марка/позиционное обозначение — Без линии-выноски

9.2.6.14.5. Линия разреза — Параметры

9.2.6.14.6. Линия разреза — Стрелки

9.2.6.14.7. Линия разреза — Фильтр стрелок

9.2.6.14.8. Обозначение узла и узла в сечении — Общие настройки

9.2.6.14.9. Обозначение узла и узла в сечении — Параметры

9.2.6.14.10. Обозначение узла и узла в сечении — Текст

9.2.6.14.11. Номер узла — Параметры

9.2.6.14.12. Номер узла — Текст

9.2.6.14.13. Выносная надпись — Общие настройки

9.2.6.14.14. Выносная надпись — Параметры

9.2.6.14.15. Выносная надпись — Стрелки и засечки

9.2.6.14.16. Выносная надпись — Фильтр стрелок

9.2.6.14.17. Выносная надпись — Текст

9.2.6.14.18. Фигурная скобка — Общие настройки

9.2.6.14.19. Фигурная скобка — Параметры

9.2.6.14.20. Фигурная скобка — Фильтр стилей линий

9.2.6.14.21. Фигурная скобка — Текст

9.2.6.14.22. Координационные оси — Общие настройки

9.2.6.14.23. Координационные оси — Параметры

9.2.6.14.24. Координационные оси — Указатель ориентации

9.2.6.14.25. Координационные оси — Текст

9.2.6.15. Текст на чертеже

9.2.6.16. Текстовая метка

9.2.6.17. Параметры таблицы

9.2.6.17.1. Заголовок таблицы

9.2.6.17.2. Ячейка таблицы

9.2.6.17.3. Название таблицы

9.2.6.18. Перекрывающиеся объекты

9.2.6.19. Параметры документа

9.2.6.19.1. Вид

9.2.6.19.2. Основная надпись

9.2.6.19.3. Нумерация листов

9.2.6.19.4. Разбиение на зоны

9.2.6.19.5. Технические требования — Текст

9.2.6.19.6. Технические требования — Параметры

9.2.6.19.7. Неуказанная шероховатость — Текст

9.2.6.19.8. Неуказанная шероховатость — Синхронизация

9.2.6.19.9. Название спецификации на листе

9.2.6.20. Параметры первого листа

9.2.6.20.1. Формат

9.2.6.20.2. Оформление

9.2.6.20.3. Таблица изменений

9.2.6.21. Параметры новых листов

9.2.6.21.1. Формат

9.2.6.21.2. Оформление

9.2.6.21.3. Таблица изменений

9.2.6.22. Параметризация

9.2.6.23. Нумерация

9.2.6.24. Параметры таблицы отчета

9.2.6.24.1. Заголовок

9.2.6.24.2. Ячейка

9.2.6.24.3. Название таблицы

9.2.7. Модель

9.2.7.1. Шрифт по умолчанию

9.2.7.2. Размеры

9.2.7.2.1. Общие настройки

9.2.7.2.2. Параметры

9.2.7.2.3. Стрелки и засечки

9.2.7.2.4. Фильтр стрелок — Линейные размеры

9.2.7.2.5. Фильтр стрелок — Размеры окружностей и дуг

9.2.7.2.6. Фильтр стрелок — Угловые размеры

9.2.7.2.7. Надпись

9.2.7.2.8. Положение надписи

9.2.7.2.9. Допуски и предельные значения — Параметры

9.2.7.2.10. Допуски и предельные значения — Допуски по умолчанию

9.2.7.2.11. Точности

9.2.7.3. Условные обозначения

9.2.7.3.1. Линия-выноска — Параметры

9.2.7.3.2. Линия-выноска — Стрелки и засечки

9.2.7.3.3. Линия-выноска — Фильтр стрелок

9.2.7.3.4. Линия-выноска — Текст над/под/за полкой

9.2.7.3.5. Линия-выноска — Наклонный текст

9.2.7.3.6. Линия-выноска — Размеры знаков

9.2.7.3.7. Обозначение позиции — Параметры

9.2.7.3.8. Обозначение позиции — Параметры формы

9.2.7.3.9. Обозначение позиции — Стрелки и засечки

9.2.7.3.10. Обозначение позиции — Фильтр стрелок

9.2.7.3.11. Обозначение позиции — Текст обозначения позиций

9.2.7.3.12. Шероховатость

9.2.7.3.13. Отклонения формы и база

9.2.7.3.14. Автосортировка

9.2.7.4. Деталь

9.2.7.4.1. Свойства

9.2.7.4.2. Настройка списка свойств

9.2.7.4.3. Номера новых исполнений

9.2.7.4.4. Цвет

9.2.7.4.5. Свойства абсолютной СК

9.2.7.4.6. Свойства локальных СК

9.2.7.4.7. Свойства объектов

9.2.7.4.8. Свойства листового тела

9.2.7.4.9. Общие допуски

9.2.7.4.10. Неуказанная шероховатость

9.2.7.4.11. Точность отрисовки и МЦХ

9.2.7.4.12. Дерево модели — Общие настройки отображения

9.2.7.4.13. Дерево модели — Структура

9.2.7.4.14. Дерево модели — Формат отображения имени

9.2.7.4.15. Зоны

9.2.7.4.16. Единицы задания МЦХ

9.2.7.5. Сборка

9.2.7.5.1. Свойства

9.2.7.5.2. Настройка списка свойств

9.2.7.5.3. Номера новых исполнений

9.2.7.5.4. Цвет

9.2.7.5.5. Свойства абсолютной СК

9.2.7.5.6. Свойства локальных СК

9.2.7.5.7. Свойства объектов

9.2.7.5.8. Общие допуски

9.2.7.5.9. Неуказанная шероховатость

9.2.7.5.10. Точность отрисовки и МЦХ

9.2.7.5.11. Дерево модели

9.2.7.5.12. Зоны

9.2.7.5.13. Единицы задания МЦХ

9.2.7.6. Технологическая сборка

9.2.7.6.1. Свойства

9.2.7.6.2. Настройка списка свойств

9.2.7.6.3. Номера новых исполнений

9.2.7.6.4. Цвет

9.2.7.6.5. Свойства абсолютной СК

9.2.7.6.6. Свойства локальных СК

9.2.7.6.7. Свойства объектов

9.2.7.6.8. Общие допуски

9.2.7.6.9. Неуказанная шероховатость

9.2.7.6.10. Точность отрисовки и МЦХ

9.2.7.6.11. Дерево модели

9.2.7.6.12. Единицы задания МЦХ

9.2.7.7. Эскиз

9.2.7.7.1. Параметризация

9.2.7.8. Параметры таблицы отчета

9.2.7.8.1. Заголовок

9.2.7.8.2. Ячейка

9.2.7.9. Технические требования

9.2.7.10. Неуказанная шероховатость


9.2.1. Общие сведения о настройке новых и текущего документов

9.2. Параметры новых и текущего документов

9.2.1. Общие сведения о настройке
новых и текущего документов

Настройка параметров новых и текущего документа производится в диалоге, вызываемом командой Сервис — Параметры....

Для настройки новых документов предназначена вкладка Новые документы этого диалога (рис. 9.2.1). В левой части вкладки находится представленный в виде «дерева» список объектов настройки. Они сгруппированы в разделы согласно типам документов. После того как в левой части выбран тот или иной пункт, в правой части вкладки появляются элементы управления для выполнения настройки.

Рис. 9.2.1. Диалог настройки имени файла по умолчанию

После закрытия диалога кнопкой ОК информация о настройках новых документов записывается в файл *.prj (см. раздел 9.5.2) и используется как умолчательная при создании новых документов.

После того как документ создан, его настройка сохраняется в нем. Изменение настройки существующего документа производится на специальной вкладке настроечного диалога. В зависимости от типа документа она имеет одно из названий:

– Текущий чертеж (рис. 9.2.2),

– Текущий фрагмент,

– Текущая сборка,

– Текущая деталь,

– Текущий текстовый документ,

– Текущая спецификация.

При работе с эскизом диалог содержит вкладку Текущий эскиз.

Как и вкладка для настройки новых документов, вкладка для настройки текущего имеет в левой части «дерево» объектов настройки, а в правой — элементы управления.

Рис. 9.2.2. Диалог настройки параметров мультилинии в текущем чертеже

Обратите внимание на следующие условности и упрощения, принятые в данном разделе:

– Далее под «диалогом» будет подразумеваться не весь настроечный диалог, а лишь набор элементов управления для настройки того или иного объекта.

1. Обращение к этому набору элементов управления будет описано в виде: Сервис — Параметры... — Название вкладки настроечного диалога — Название раздела (группа объектов настройки) — Название подраздела (подгруппа объектов настройки). Например, если в тексте сказано: «...настройка выполняется в диалоге Единицы измерения длины, вызываемом командой Сервис — Параметры — Новые документы — Графический документ — Единицы измерения...», то это означает, что для доступа к настройке единиц измерения необходимо выполнить такую последовательность действий.Выбрать в Главном меню пункт Сервис.

2. В появившемся списке команд меню Сервис выбрать команду Параметры....

3. В появившемся диалоге активизировать вкладку Новые документы.

4. В списке объектов настройки развернуть раздел Графический документ.

5. Выделить подраздел Единицы измерения.
В правой части вкладки появятся элементы управления под общим заголовком Единицы измерения длины для выбора единицы измерения длины в чертеже.

В этом разделе:

9.2.1.1. Типы параметров объектов


9.2.1.1. Типы параметров объектов

Все настраиваемые параметры по их действию на объекты текущего документа можно разделить на две группы с двумя подгруппами в каждой. В описаниях настроечных диалогов указан номер подгруппы, к которой относится тот или иной параметр.

1. Параметры документа — параметры, которыми нельзя управлять при создании объектов.

1.1. Параметры, определяющие внешние признаки объектов, которые должны быть одинаковыми для всех объектов данного типа, существующих в одном документе. Изменение этих параметров применяется как к уже существующим объектам, так и к вновь создаваемым.

1.2. Параметры, влияющие на доступность тех или иных возможностей при создании объектов. Изменение этих параметров не влияет на существующие объекты, но влияет на процесс создания новых.

2. Параметры объекта — параметры, которыми можно управлять при создании объектов.

2.1. Параметры, определяющие умолчательные значения одноименных параметров объектов. Их изменение приводит к изменению умолчательной настройки новых объектов. Существующие объекты при этом не меняются. Чтобы изменить значение параметров данной подгруппы у существующих объектов, необходимо отредактировать эти объекты.

2.2. Аналог параметров предыдущей подгруппы, но имеют одно отличие: после их изменения новые значения передаются в те из существующих объектов, которые были созданы с умолчательными значениями соответствующих параметров. Все эти объекты перерисовываются. Те объекты, при создании или редактировании которых значения параметров данной подгруппы были изменены вручную, остаются прежними. Чтобы изменить эти параметры у объектов, необходимо отредактировать объекты.


9.2.2. Имя файла по умолчанию

9.2. Параметры новых и текущего документов

9.2.2. Имя файла по умолчанию

Имя, которое будет по умолчанию предлагаться при первом сохранении файла, можно настроить. Настройка производится в диалоге Имя файла по умолчанию при первом сохранении, вызываемом командой Сервис — Параметры... — Новые документы — Имя файла по умолчанию.

Диалог содержит различные варианты формирования имени файла.

Вариант Тип документа позволяет использовать в качестве имени файла название типа сохраняемого документа. Например, при сохранении чертежа будет предложено имя «Чертеж.cdw», сборки — «Сборка.a3d».

Именем файла может быть обозначение документа, или его наименование, или и то, и другое вместе. Для этого выберите нужный вариант:

– Обозначение,

– Наименование,

– Обозначение+Наименование,

– Наименование+Обозначение.

Если выбран вариант, включающий и обозначение, и наименование, между этими элементами вставляется разделитель. Вы можете выбрать нужный разделитель из раскрывающегося списка или ввести его вручную в поле Разделитель:.

Для детали или сборки обозначение и наименование берутся из свойств документа. Для спецификации или текстового документа используется текст, введенный в соответствующие ячейки основной надписи. В чертеже обозначение и наименование могут быть заданы при заполнении основной надписи и переданы в свойства, а также наоборот.

Значение нужного свойства может быть не задано в документе. В этом случае для имен, состоящих из одной части (обозначения или наименования), используется название типа документа. Если имя состоит из двух частей, то используется вторая часть имени без разделителя. Если ни одна из частей имени не задана, то в качестве имени документа предлагается название его типа.

При сохранении фрагментов вне зависимости от настройки предлагается имя «Фрагмент.frw».

После завершения настройки умолчательного имени файла нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.

Если полученное имя содержит недопустимые в именах файлов символы (так как они присутствуют в обозначении, наименовании или разделителе), то при сохранении документа на экране появляется предупреждающее сообщение.

Нажмите кнопку Да, чтобы удалить недопустимые символы из имени файла. Кнопка Нет позволяет использовать в качестве имени файла название типа документа.


9.2.3. Свойства документа

9.2. Параметры новых и текущего документов

9.2.3. Свойства документа

Включение или отключение заполнения свойств документа, а также задание умолчательных сведений о документах выполняется в диалоге Общие свойства. Диалог появляется на экране после вызова команды Сервис — Параметры... — Новые документы — Свойства документа.

Табл. 9.2.1. Элементы управления диалога настройки общих свойств документа

Элемент

Описание настройки

Предлагать заполнение свойств документа

Опция управляет автоматическим вызовом диалога информации о документе при первом сохранении КОМПАС-документов.

Общие сведения о документе

Группа полей для редактирования общих сведений о документе.

По умолчанию сведения об авторе и организации совпадают с указанными при установке системы КОМПАС-3D — в диалоге Сведения о пользователе.

Данные, введенные в этом диалоге, будут по умолчанию содержаться в соответствующих полях диалога свойств. При необходимости для конкретного документа их можно изменить.

Завершив настройку общих свойств документа, нажмите кнопку OK. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.2.4. Текстовый документ

9.2. Параметры новых и текущего документов

9.2.4. Текстовый документ

В этом разделе:

9.2.4.1. Шрифт по умолчанию

9.2.4.2. Параметры листа

9.2.4.2.1. Формат

9.2.4.2.2. Оформление

9.2.4.3. Текст документа

9.2.4.4. Заголовок таблицы

9.2.4.5. Ячейка таблицы

9.2.4.6. Нумерация листов

9.2.4.7. Параметры таблицы отчета

9.2.4.7.1. Заголовок

9.2.4.7.2. Ячейка


9.2.4.1. Шрифт по умолчанию

Выбор шрифта, который будет по умолчанию использоваться в текстовых документах (как новых, так и текущих), выполняется в диалоге Шрифт по умолчанию, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Текстовый документ — Шрифт по умолчанию,

– для текущего документа — Сервис — Параметры... — Текущий текстовый документ — Шрифт по умолчанию.

Аналогичный диалог используется при настройке умолчательного шрифта:

– в текстовых надписях новых или текущего графических документов (кроме основной надписи чертежа),

– в размерах и обозначениях новых и текущей модели.

Раскрывающийся список Шрифт позволяет выбрать шрифт, который будет по умолчанию использоваться для текста и таблиц в документах.

Поле Пример служит для отображения образца выбранного шрифта.

После завершения настройки нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.

Выбранный шрифт используется в качестве умолчательного для всех объектов документа (текста документа, заголовка таблицы, ячейки таблицы и т.п.). Чтобы выбрать другой шрифт для какого-либо объекта (например, для надписей в обозначениях шероховатости или для ячейки таблицы), выделите соответствующий ему пункт в левой части диалога настройки параметров. В правой части появятся элементы управления диалога настройки параметров текста. Включите опцию Отличается от шрифта по умолчанию и выберите другой шрифт. Последующие изменения умолчательного шрифта не будут оказывать влияния на шрифт, выбранный для объекта. В случае отключения опции Отличается от шрифта по умолчанию для объектов данного типа вновь будет использоваться шрифт по умолчанию.

Для некоторых объектов опция Отличается от шрифта по умолчанию находится в диалоге Параметры шрифта, вызываемом кнопкой Шрифт....

При редактировании настроек текущего документа изменения сохраняются в самом документе, при этом объекты документа автоматически перестраиваются.

Если при создании или редактировании объекта в окне документа для него был выбран персональный шрифт, то изменения умолчательного шрифта в диалоге настройки на него не действуют.

Векторные шрифты, в том числе поставляемые с КОМПАС-3D шрифты GOST type A (plotter), GOST type B (plotter), Symbol type A (plotter), Symbol type B (plotter), не поддерживаются в режиме работы с трехмерной моделью, а также в режиме работы с графическими документами, если для их отрисовки на экране используется OpenGL (см. раздел 9.1.7.17).


9.2.4.2. Параметры листа

В этом разделе:

9.2.4.2.1. Формат

9.2.4.2.2. Оформление


9.2.4.2.1. Формат

Вы можете выбрать формат листов текстовых документов (как новых, так и текущих) из стандартного ряда или задать произвольные размеры листов. Для этого используется диалог Формат листа, вызываемый командой:

– для новых документов — Сервис — Параметры... — Новые документы — Текстовый документ — Параметры листа — Формат,

– для текущего документа — Сервис — Параметры... — Текущий текстовый документ — Параметры листа — Формат.

Работа в диалоге описана в разделе 9.1.12.3.1.


9.2.4.2.2. Оформление

Выбор оформления листов текстовых документов (как новых, так и текущих) выполняется в диалоге Оформление, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Текстовый документ — Параметры листа — Оформление,

– для текущего документа — Сервис — Параметры... — Текущий текстовый документ — Параметры листа — Оформление.

Аналогичный диалог используется для выбора оформления листов графических документов, а также стиля спецификации (в последнем случае диалог называется Стиль).

Для текстовых документов в диалоге выбирается оформление первого листа и последующих листов (отдельно четных и нечетных), для графических документов — первого листа или всех вновь добавляемых листов, для спецификаций — стиль оформления спецификаций.

Оформления документов и стили спецификаций хранятся в специальных системных библиотеках — файлах с расширением *.lyt. Элементы управления диалога позволяют выбрать файл нужной библиотеки и оформление (стиль) из нее.

Табл. 9.2.2. Элементы управления диалога выбора оформления или стиля

Элемент

Описание настройки

Единое оформление

Опция позволяет применить единое оформление ко всем листам выбранного раздела. Если опция включена, то вместо нескольких групп выбора оформления отдельно для первого, всех четных и всех нечетных листов присутствует одна группа выбора оформления для всех листов раздела.

Библиотека

Поле служит для отображения полного имени файла библиотеки *.lyt.

Показать библиотеку

Кнопка позволяет выбрать нужный файл библиотеки оформлений (стилей) в стандартном диалоге выбора файла. После выбора библиотеки на экране появляется диалог, показывающий перечень содержащихся в ней оформлений (стилей). Укажите нужное оформление (стиль). Его название появится в поле Название, а полное имя выбранной библиотеки — в поле Библиотека.

Название

Поле служит для отображения названия оформления, присвоенного листу (стиля, присвоенного спецификации).

Оформление (стиль), внедренное в текущий, т.е. уже существующий, документ, может отличаться от соответствующего ему оформления в библиотеке *.lyt (отличия могут возникнуть, например, после редактирования библиотеки). В этом случае перед названием оформления (стиля) отображается «звездочка» (*).

Выбрать

Кнопка позволяет выбрать другое оформление (стиль) из текущей библиотеки оформлений (стилей).

После нажатия кнопки на экране появляется диалог, показывающий перечень оформлений (стилей), содержащихся в текущей библиотеке. Укажите нужное оформление (стиль) и нажмите кнопку ОК.

Очистить

Кнопка позволяет отключить текущую библиотеку оформлений (стилей). При этом поля Библиотека и Название очищаются.

Документ без оформления не имеет рамки и основной надписи.

Спецификация без стиля существовать не может, поэтому в диалоге выбора стиля спецификации кнопка Очистить отсутствует.

Перечитать

Позволяет обновить оформление (стиль), если оно отличается от библиотечного. После нажатия этой кнопки листу будет присвоено оформление из библиотеки (спецификации будет присвоен стиль из библиотеки), «звездочка» перед названием оформления (стиля) исчезнет.

Кнопка Перечитать присутствует в диалоге, если он вызван для текущего документа. Она доступна, если оформление (стиль) документа отличается от соответствующего оформления (стиля) в библиотеке *.lyt.

Применить к разделу

Список позволяет выбрать раздел текстового документа, к которому будут применены настройки, сделанные в диалоге. Список присутствует в диалоге только при настройке текущего документа и доступен, если документ содержит более одного раздела.

После завершения настройки нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.2.4.3. Текст документа

Настройка параметров абзацев текста текстовых документов (как новых, так и текущих) выполняется в диалоге Текст документа, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Текстовый документ — Текст документа,

– для текущего документа — Сервис — Параметры... — Текущий текстовый документ — Текст документа.

Табл. 9.2.3. Элементы управления диалога настройки текста документа
Элемент | Описание настройки
Шаг строк, мм | Поле для ввода расстояния между строками текста в абзаце. Изменение шага строк позволяет сохранять пропорциональность расстояний между строками, набранными шрифтом с различной высотой символов (например, при включении в текст каких-либо сносок, комментариев или примечаний, набранных более мелким по сравнению с основным текстом шрифтом).
Красная строка, мм | Поле для ввода отступа первой строки абзаца. Отступ измеряется от границы текста. При создании нового абзаца курсор автоматически устанавливается в позицию с заданным отступом.
Отступы | Поля для ввода расстояний между левой и правой границами поля ввода и соответствующими границами текста.
Интервал | Поля для задания расстояния между двумя соседними абзацами. Данное расстояние складывается из двух величин — интервала после первого абзаца и интервала перед вторым абзацем. Установка интервалов позволяет выделить абзацы в текстовом документе для их наилучшего восприятия при чтении, а также для привлечения внимания к особо важной информации.
Выравнивание | Опции позволяют выбрать нужный способ выравнивания абзацев (по левой границе, по правой границе, центрирование, выравнивание по двум границам).
Шрифт... | Кнопка для вызова диалога настройки параметров шрифта.
Табуляция... | Кнопка для вызова диалога настройки параметров табуляции.
Параметры списка... | Кнопка для вызова диалога настройки параметров списка. В диалоге задаются параметры нумерации абзацев текста.

После завершения настройки параметров абзаца нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.2.4.4. Заголовок таблицы

Параметры текста заголовка таблицы текстовых документов (как новых, так и текущих) настраиваются в диалоге, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Текстовый документ — Заголовок таблицы,

– для текущего документа — Сервис — Параметры... — Текущий текстовый документ — Заголовок таблицы.

Аналогичный диалог используется при настройке:

– заголовка таблицы в графическом документе,

– ячейки таблицы в текстовом или графическом документе,

– заголовка таблицы отчета,

– ячейки таблицы отчета.

Табл. 9.2.4. Элементы управления диалога настройки текста документа
Элемент | Описание настройки
Шаг строк, мм | Поле для ввода расстояния между строками текста в абзаце. Изменение шага строк позволяет сохранять пропорциональность расстояний между строками, набранными шрифтом с различной высотой символов (например, при включении в текст каких-либо сносок, комментариев или примечаний, набранных более мелким по сравнению с основным текстом шрифтом).
Красная строка, мм | Поле для ввода отступа первой строки абзаца. Отступ измеряется от границы текста. При создании нового абзаца курсор автоматически устанавливается в позицию с заданным отступом.
Отступы | Поля для ввода расстояний между левой и правой границами поля ввода и соответствующими границами текста.
Интервал | Поля для задания расстояния между двумя соседними абзацами. Данное расстояние складывается из двух величин — интервала после первого абзаца и интервала перед вторым абзацем. Установка интервалов позволяет выделить абзацы в текстовом документе для их наилучшего восприятия при чтении, а также для привлечения внимания к особо важной информации.
Выравнивание | Опции позволяют выбрать нужный способ выравнивания абзацев (по левой границе, по правой границе, центрирование, выравнивание по двум границам).
Шрифт... | Кнопка для вызова диалога настройки параметров шрифта.
Табуляция... | Кнопка для вызова диалога настройки параметров табуляции.

После завершения настройки параметров абзаца нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.2.4.5. Ячейка таблицы

Параметры текста ячейки таблицы текстовых документов (как новых, так и текущих) настраиваются в диалоге, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Текстовый документ — Ячейка таблицы,

– для текущего документа — Сервис — Параметры... — Текущий текстовый документ — Ячейка таблицы.

Работа в аналогичном диалоге описана в разделе 9.2.4.4.


9.2.4.6. Нумерация листов

Настройка нумерации листов текстового документа (только текущего) выполняется в диалоге Нумерация листов, вызываемом командой Сервис — Параметры — Текущий текстовый документ — Нумерация листов.

Настройка нумерации представляет собой задание правил заполнения граф основной надписи Количество листов и Номер листа.

Табл. 9.2.5. Элементы управления диалога настройки нумерации листов

Элемент

Описание настройки

Автоматическая нумерация листов

Опция управляет автонумерацией листов.

Если она включена, всем листам документа автоматически присваиваются порядковые номера.

Если опция отключена, то графа Номер листа в основной надписи текущего документа не заполняется. Вы можете ввести произвольный номер для каждого листа документа и произвольное значение общего числа листов.

Начинать нумерацию с

Поле позволяет ввести номер первого листа — номер, с которого начнется автоматическая нумерация. По умолчанию он равен единице. Вы можете ввести или задать с помощью счетчика нужное значение. Поле доступно при включенной опции Автоматическая нумерация листов.

Продолжать нумерацию

Опция позволяет продолжить нумерацию предыдущего раздела. Доступна при включенной опции Автоматическая нумерация листов.

Количество листов

Группа переключателей позволяет указать способ определения количества листов документа.

Автоматическое определение

Опция позволяет автоматически подсчитать фактическое количество листов текущего документа и занести полученное значение в графу Количество листов основной надписи.

При включенной опции Автоматическое определение ручной ввод данных в графу Количество листов основной надписи невозможен.

Предопределенное

Опция позволяет задать произвольное количество листов документа. Это может понадобиться, если текущий документ является частью другого документа, состоящего из известного количества листов.

Поле справа от опции позволяет ввести нужное значение вручную или задать его с помощью счетчика. Заданное значение заносится в графу Количество листов основной надписи каждого листа текущего документа.

При включенной опции ручной ввод данных в эту графу невозможен.

Исключить из подсчета

Опция позволяет исключить из нумерации раздел документа.

Применить к разделу

Список позволяет выбрать раздел документа, к которому будут применены настройки, сделанные в диалоге. Список присутствует в диалоге, если документ содержит более одного раздела.

После завершения настройки нумерации листов нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.2.4.7. Параметры таблицы отчета

В этом разделе:

9.2.4.7.1. Заголовок

9.2.4.7.2. Ячейка


9.2.4.7.1. Заголовок

Параметры текста заголовка таблицы отчета настраиваются в диалоге, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Текстовый документ — Параметры таблицы отчета — Заголовок,

– для текущего документа — Сервис — Параметры... — Текущий текстовый документ — Параметры таблицы отчета — Заголовок.

Работа в аналогичном диалоге описана в разделе 9.2.4.4.

Настройки используются при размещении отчета в текстовом документе.


9.2.4.7.2. Ячейка

Параметры текста ячейки таблицы отчета настраиваются в диалоге, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Текстовый документ — Параметры таблицы отчета — Ячейка,

– для текущего документа — Сервис — Параметры... — Текущий текстовый документ — Параметры таблицы отчета — Ячейка.

Работа в аналогичном диалоге описана в разделе 9.2.4.4.

Настройки используются при размещении отчета в текстовом документе.


9.2.5. Спецификация

9.2. Параметры новых и текущего документов

9.2.5. Спецификация

В этом разделе:

9.2.5.1. Умолчательные настройки

9.2.5.1.1. Стиль

9.2.5.1.2. Нумерация листов

9.2.5.1.3. Дополнительные листы

9.2.5.1.4. Отображение величин

9.2.5.2. По сборке с исполнениями

9.2.5.2.1. Параметры выбора варианта настроек

9.2.5.2.2. Общий вариант

9.2.5.2.3. При числе исполнений не более заданного


9.2.5.1. Умолчательные настройки

В этом разделе:

9.2.5.1.1. Стиль

9.2.5.1.2. Нумерация листов

9.2.5.1.3. Дополнительные листы

9.2.5.1.4. Отображение величин


9.2.5.1.1. Стиль

Выбор стиля спецификаций (как новых, так и текущих) выполняется в диалоге Стиль, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Спецификация — Умолчательные настройки — Стиль,

– для текущего документа — Сервис — Параметры... — Текущая спецификация — Стиль.

Работа в диалоге аналогична описанной в разделе 9.2.4.2.2.


9.2.5.1.2. Нумерация листов

Настройка нумерации листов спецификации (только текущей) выполняется в диалоге Нумерация листов, вызываемом командой Сервис — Параметры... — Текущая спецификация — Нумерация листов.

Аналогичный диалог используется при настройке нумерации листов чертежа.

Табл. 9.2.6. Элементы управления диалога настройки нумерации листов

Элемент

Описание настройки

Автоматическая нумерация листов

Опция управляет автонумерацией листов.

Если она включена, всем листам документа автоматически присваиваются порядковые номера.

Если опция отключена, то графа Номер листа в основной надписи текущего документа не заполняется. Вы можете ввести произвольный номер для каждого листа документа и произвольное значение общего числа листов.

Номер первого листа

Поле позволяет ввести номер первого листа — номер, с которого начнется автоматическая нумерация. По умолчанию он равен единице. Вы можете ввести или задать с помощью счетчика нужное значение. Поле доступно при включенной опции Автоматическая нумерация листов.

Количество листов

Группа переключателей позволяет указать способ определения количества листов документа.

Автоматическое определение

Опция позволяет автоматически подсчитать фактическое количество листов текущего документа и занести полученное значение в графу Количество листов основной надписи. Дополнительные листы (при их наличии) включаются в общее число листов.

При включенной опции Автоматическое определение ручной ввод данных в графу Количество листов основной надписи невозможен.

Предопределенное

Опция позволяет задать произвольное количество листов документа. Это может понадобиться, если текущий документ является частью другого документа, состоящего из известного количества листов.

Поле справа от опции позволяет ввести нужное значение вручную или задать его с помощью счетчика. Заданное значение заносится в графу Количество листов основной надписи каждого листа текущего документа.

При включенной опции ручной ввод данных в эту графу невозможен.

После завершения настройки нумерации листов нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.2.5.1.3. Дополнительные листы

Для управления дополнительными листами спецификаций (как новых, так и текущих) используется диалог Дополнительные листы, вызываемый командой:

– для новых документов — Сервис — Параметры... — Новые документы — Спецификация — Умолчательные настройки — Дополнительные листы,

– для текущего документа — Сервис — Параметры... — Текущая спецификация — Дополнительные листы.

Диалог позволяет создать дополнительные листы в начале и/или в конце документа, выбрать варианты их оформления, формат и задать порядок следования в документе. Например, с помощью этого диалога можно создать в документе титульный лист и лист регистрации изменений.

Табл. 9.2.7. Элементы управления диалога настройки дополнительных листов документа

Элемент

Описание настройки

В начале
документа,
В конце
документа

Списки названий оформлений дополнительных листов.

Количество дополнительных листов, а также порядок их следования в документе определяются количеством и расположением оформлений в списках. Вы можете добавлять новые листы в список, удалять их, изменять их расположение и оформление.

Добавить

Кнопка позволяет создать в документе дополнительный лист. После ее нажатия на экране появляется диалог выбора оформления листа. Диалог позволяет выбрать библиотеку оформлений и указать нужное оформление. Указанное оформление появляется в соответствующем списке диалога Дополнительные листы.

Изменить

Кнопка позволяет изменить оформление дополнительного листа. Оформление этого листа должно быть предварительно выделено в списке диалога.

После нажатия кнопки на экране появляется диалог выбора оформления.

Формат

Кнопка позволяет изменить формат дополнительного листа. Оформление этого листа должно быть предварительно выделено в списке диалога.

После нажатия кнопки на экране появляется диалог настройки формата листа. В нем можно выбрать один из стандартных форматов или ввести произвольные длины сторон листа.

Удалить

Кнопка позволяет удалить дополнительный лист из документа. Оформление этого листа должно быть предварительно выделено в списке диалога.

Переместить
вверх/вниз

Порядок следования дополнительных листов в документе определяется порядком расположения их оформлений в списках диалога. Кнопки позволяют изменить этот порядок.

Чтобы изменить положение дополнительного листа в документе, выделите его оформление в соответствующем списке и нажмите кнопку Переместить вверх (для перемещения листа вперед) или Переместить вниз (для перемещения листа назад).

После завершения настройки дополнительных листов нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.

Работа с дополнительными листами спецификации описана в разделе 6.2.6.9.


9.2.5.1.4. Отображение величин

Вы можете задать единицы измерения массы и точность отображения ее значения (количество знаков после запятой) для использования в соответствующих колонках спецификации, например, в колонке Масса плазовой спецификации или в дополнительной колонке Масса. Данная настройка выполняется в диалоге Отображение величин, вызываемом командой:

– для новых спецификаций — Сервис — Параметры... — Новые документы — Спецификация — Умолчательные настройки — Отображение величин,

– для текущей спецификации — Сервис — Параметры... — Текущая спецификация — Отображение величин.

Выберите единицу измерения массы и задайте количество знаков после запятой в значении массы.

Завершив настройку, нажмите кнопку OK. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.

После настройки текущей спецификации изменяется отображение значений массы в соответствующих ячейках спецификации.

Обратите внимание на то, что заданное количество знаков после запятой применяется только для отображения значения массы. То есть в ячейке постоянно хранится значение массы с той точностью, с которой оно было получено из модели или введено пользователем, а отображается в ячейке значение, округленное до указанного знака.


9.2.5.2. По сборке с исполнениями

В этом разделе:

9.2.5.2.1. Параметры выбора варианта настроек

9.2.5.2.2. Общий вариант

9.2.5.2.3. При числе исполнений не более заданного


9.2.5.2.1. Параметры выбора варианта настроек

Спецификация, создаваемая по сборке с исполнениями, может иметь различную настройку в зависимости от количества исполнений сборки.

Количество исполнений, относительно которого определяется, какой вариант настройки будет применен к спецификации, задается в диалоге Параметры выбора варианта настроек, вызываемом командой Сервис — Параметры... — Новые документы — Спецификация — По сборке с исполнениями — Параметры выбора варианта настроек.

Опция При числе исполнений не более управляет применением к спецификации специального варианта настройки. Поле справа от опции позволяет задать количество исполнений, относительно которого определяется, какой вариант настройки использовать (доступно, если опция включена).

При включенной опции:

– для спецификации, созданной по сборке с числом исполнений не более заданного в поле, используются параметры, установленные в разделе При числе исполнений не более заданного (см. раздел 9.2.5.2.3),

– для спецификации, созданной по сборке с числом исполнений, превышающим заданное в поле, используются параметры, установленные в разделе Общий вариант (см. раздел 9.2.5.2.2).

При отключенной опции для сборки с любым количеством исполнений создается спецификация с параметрами, заданными в разделе Общий вариант.


9.2.5.2.2. Общий вариант

В данном разделе задается вариант настройки, который будет использоваться для спецификации, созданной по сборке, число исполнений которой превышает заданное в диалоге Параметры выбора варианта настроек (см. раздел 9.2.5.2.1).

Стиль

Выбор стиля для новых спецификаций, созданных по сборке с исполнениями, выполняется в диалоге Стиль, вызываемом командой Сервис — Параметры... — Новые документы — Спецификация — По сборке с исполнениями — Общий вариант — Стиль.

Работа в диалоге аналогична описанной в разделе 9.2.4.2.2.

Дополнительные листы

Задание параметров дополнительных листов для новых спецификаций, созданных по сборке с исполнениями, выполняется в диалоге Дополнительные листы, вызываемый командой Сервис — Параметры... — Новые документы — Спецификация — По сборке с исполнениями — Общий вариант — Дополнительные листы.

Работа в диалоге описана в разделе 9.2.4.3.

Отображение величин

Выбор единицы измерения массы и задание количества знаков после запятой в значении массы для новых спецификаций, созданных по сборке с исполнениями, выполняется в диалоге Отображение величин, вызываемом командой Сервис — Параметры... — Новые документы — Спецификация — По сборке с исполнениями — Общий вариант — Отображение величин.

Работа в диалоге описана в разделе 9.2.5.1.4.


9.2.5.2.3. При числе исполнений не более заданного

В данном разделе задается вариант настройки, который будет использоваться для спецификации, созданной по сборке, число исполнений которой не более заданного в диалоге Параметры выбора варианта настроек (см. раздел 9.2.5.2.1).

Стиль

Выбор стиля для спецификаций, созданных по сборке с количеством исполнений не более заданного, выполняется в диалоге Стиль, вызываемом командой Сервис — Параметры... — Новые документы — Спецификация — По сборке с исполнениями — При числе исполнений не более заданного — Стиль.

Работа в диалоге аналогична описанной в разделе 9.2.4.2.2.

Дополнительные листы

Задание параметров дополнительных листов для новых спецификаций, созданных по сборке с количеством исполнений не более заданного, выполняется в диалоге Дополнительные листы, вызываемый командой Сервис — Параметры... — Новые документы — Спецификация — По сборке с исполнениями — При числе исполнений не более заданного — Дополнительные листы.

Работа в диалоге описана в разделе 9.2.4.3.

Отображение величин

Выбор единицы измерения массы и задание количества знаков после запятой в значении массы для новых спецификаций, созданных по сборке с количеством исполнений не более заданного, выполняется в диалоге Отображение величин, вызываемом командой Сервис — Параметры... — Новые документы — Спецификация — По сборке с исполнениями — При числе исполнений не более заданного — Отображение величин.

Работа в диалоге описана в разделе 9.2.5.1.4.


9.2.6. Графический документ

9.2. Параметры новых и текущего документов

9.2.6. Графический документ

В этом разделе:

9.2.6.1. Шрифт по умолчанию

9.2.6.2. Единицы измерения

9.2.6.3. Группирование слоев

9.2.6.4. Дерево чертежа

9.2.6.5. Настройка списка свойств

9.2.6.6. Линии

9.2.6.6.1. Стили

9.2.6.6.2. Осевая линия

9.2.6.7. Линия разрыва

9.2.6.8. Линии обрыва

9.2.6.8.1. Волнистая линия

9.2.6.8.2. Линия с изломами

9.2.6.8.3. Фильтр стилей линий

9.2.6.9. Мультилиния

9.2.6.10. Размеры

9.2.6.10.1. Общие настройки

9.2.6.10.2. Параметры

9.2.6.10.3. Отметки уровня

9.2.6.10.4. Стрелки и засечки

9.2.6.10.5. Фильтры стрелок — Линейные размеры

9.2.6.10.6. Фильтры стрелок — Размеры окружностей и дуг

9.2.6.10.7. Фильтры стрелок — Угловые размеры

9.2.6.10.8. Надпись

9.2.6.10.9. Положение надписи

9.2.6.10.10. Допуски и предельные значения — Параметры

9.2.6.10.11. Допуски и предельные значения — Допуски по умолчанию

9.2.6.10.12. Точности

9.2.6.11. Линия-выноска

9.2.6.11.1. Параметры

9.2.6.11.2. Стрелки и засечки

9.2.6.11.3. Фильтр стрелок

9.2.6.11.4. Текст над/под/за полкой

9.2.6.11.5. Наклонный текст

9.2.6.11.6. Размеры знаков

9.2.6.12. Условное пересечение

9.2.6.13. Обозначения для машиностроения

9.2.6.13.1. Обозначение позиции — Параметры

9.2.6.13.2. Обозначение позиции — Параметры формы

9.2.6.13.3. Обозначение позиции — Стрелки

9.2.6.13.4. Обозначение позиции — Фильтр стрелок

9.2.6.13.5. Обозначение позиции — Текст обозначения позиций

9.2.6.13.6. Шероховатость

9.2.6.13.7. Отклонения формы и база

9.2.6.13.8. Линия разреза/сечения — Параметры

9.2.6.13.9. Линия разреза/сечения — Стрелки

9.2.6.13.10. Линия разреза/сечения — Фильтр стрелок

9.2.6.13.11. Стрелка взгляда — Параметры

9.2.6.13.12. Стрелка взгляда — Стрелки

9.2.6.13.13. Стрелка взгляда — Фильтр стрелок

9.2.6.13.14. Автосортировка

9.2.6.13.15. Обозначение изменения — Параметры

9.2.6.13.16. Обозначение изменения — Текст надписи

9.2.6.14. Обозначения для строительства

9.2.6.14.1. Марка/позиционное обозначение — Общие настройки

9.2.6.14.2. Марка/позиционное обозначение — С линией-выноской

9.2.6.14.3. Марка/позиционное обозначение — На линии

9.2.6.14.4. Марка/позиционное обозначение — Без линии-выноски

9.2.6.14.5. Линия разреза — Параметры

9.2.6.14.6. Линия разреза — Стрелки

9.2.6.14.7. Линия разреза — Фильтр стрелок

9.2.6.14.8. Обозначение узла и узла в сечении — Общие настройки

9.2.6.14.9. Обозначение узла и узла в сечении — Параметры

9.2.6.14.10. Обозначение узла и узла в сечении — Текст

9.2.6.14.11. Номер узла — Параметры

9.2.6.14.12. Номер узла — Текст

9.2.6.14.13. Выносная надпись — Общие настройки

9.2.6.14.14. Выносная надпись — Параметры

9.2.6.14.15. Выносная надпись — Стрелки и засечки

9.2.6.14.16. Выносная надпись — Фильтр стрелок

9.2.6.14.17. Выносная надпись — Текст

9.2.6.14.18. Фигурная скобка — Общие настройки

9.2.6.14.19. Фигурная скобка — Параметры

9.2.6.14.20. Фигурная скобка — Фильтр стилей линий

9.2.6.14.21. Фигурная скобка — Текст

9.2.6.14.22. Координационные оси — Общие настройки

9.2.6.14.23. Координационные оси — Параметры

9.2.6.14.24. Координационные оси — Указатель ориентации

9.2.6.14.25. Координационные оси — Текст

9.2.6.15. Текст на чертеже

9.2.6.16. Текстовая метка

9.2.6.17. Параметры таблицы

9.2.6.17.1. Заголовок таблицы

9.2.6.17.2. Ячейка таблицы

9.2.6.17.3. Название таблицы

9.2.6.18. Перекрывающиеся объекты

9.2.6.19. Параметры документа

9.2.6.19.1. Вид

9.2.6.19.2. Основная надпись

9.2.6.19.3. Нумерация листов

9.2.6.19.4. Разбиение на зоны

9.2.6.19.5. Технические требования — Текст

9.2.6.19.6. Технические требования — Параметры

9.2.6.19.7. Неуказанная шероховатость — Текст

9.2.6.19.8. Неуказанная шероховатость — Синхронизация

9.2.6.19.9. Название спецификации на листе

9.2.6.20. Параметры первого листа

9.2.6.20.1. Формат

9.2.6.20.2. Оформление

9.2.6.20.3. Таблица изменений

9.2.6.21. Параметры новых листов

9.2.6.21.1. Формат

9.2.6.21.2. Оформление

9.2.6.21.3. Таблица изменений

9.2.6.22. Параметризация

9.2.6.23. Нумерация

9.2.6.24. Параметры таблицы отчета

9.2.6.24.1. Заголовок

9.2.6.24.2. Ячейка

9.2.6.24.3. Название таблицы


9.2.6.1. Шрифт по умолчанию

Вы можете выбрать шрифт, который будет по умолчанию использоваться во всех текстовых надписях новых или текущего графического документа (кроме основной надписи чертежа).

Для этого используется диалог Шрифт по умолчанию, вызываемый командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Шрифт по умолчанию,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Шрифт по умолчанию.

Работа в диалоге описана в разделе 9.2.4.1.


9.2.6.2. Единицы измерения

Вы можете выбрать единицу измерения длины в графических документах (как новых, так и текущих). Она будет использоваться для отображения параметров команд (например, длины или радиуса), координат, шага курсора, автоматически сформированных номиналов и отклонений размеров. Данная настройка выполняется в диалоге Единицы измерения длины, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Единицы измерения,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Единицы измерения.

Для выбора нужной единицы измерения включите соответствующую ей опцию.

Для завершения настройки нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.

Настройка единиц измерения длины не распространяется на Окно переменных (см. раздел 7.1.1.2). Все значения линейных величин (например, линейных размеров), отображающиеся в этом окне, переводятся в миллиметры; все значения, введенные для расчета таких величин, считаются заданными в миллиметрах.


9.2.6.3. Группирование слоев

Способ группирования слоев в графических документах (как новых, так и текущих) настраивается в диалоге Группирование слоев. Диалог вызывается командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Группирование слоев,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Группирование слоев.

Табл. 9.2.8. Элементы управления диалога настройки способа группирования слоев

Элемент

Описание настройки

Группировать слои

Опция позволяет создавать и использовать группы слоев и фильтры1.

Группировать свойства слоев

Опция позволяет создавать и использовать группы свойств слоев1. При включенной опции доступна опция Наследовать состав родительского объекта.

Наследовать состав родительского объекта

Опция позволяет автоматически включать слои родительского объекта в состав группы свойств слоев. Родительским объектом считается документ, вид или группа, где создается новая группа свойств слоев.

Если эта опция включена, то создание группы свойств происходит следующим образом:

– если родительским объектом является группа свойств, то в новую группу будут скопированы все слои этой группы с заданными для них настройками,

– если родительским объектом является вид, то новая группа будет содержать все слои этого вида и их свойства,

– если родительским объектом является Документ (корневой объект Дерева листов, видов, слоев), то новая группа будет содержать все слои всех видов.
  1. Описание групп слоев и групп свойств слоев приведено в разделе 3.6.6.9.1.

Изменение способа группировки в документе приводит к необратимым изменениям созданных групп и фильтров.

Если в документе действовал режим группирования свойств слоев, то при включении режима группирования слоев группы свойств станут группами слоев. Состояние слоев групп будет соответствовать текущему состоянию их в документе.

Если в документе действовал режим группирования слоев, то при включении режима группирования свойств слоев группы слоев станут группами свойств. Состояние слоев групп будет соответствовать текущему состоянию их в документе. Настройки групп необходимо выполнить заново. Поскольку использование фильтров при группировании свойств слоев невозможно, все имевшиеся фильтры автоматически преобразуются в группы свойств слоев. Их имена не изменятся, то есть будут состоять из слова «Фильтр» с прежним порядковым номером.

После завершения настройки нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.2.6.4. Дерево чертежа

Настройка умолчательного состава Дерева чертежа для новых или текущих графических документов выполняется в диалоге Отображение в дереве, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Дерево чертежа,

– для текущего документа — Сервис — Параметры... — Текущий чертеж — Дерево чертежа.

Кроме того, во время работы с чертежом диалог настройки Дерева чертежа может быть вызван нажатием кнопки Состав Дерева чертежа в верхней части окна Дерева.

Диалог содержит опции, соответствующие группам объектов в Дереве чертежа. Включая и отключая опции, вы можете управлять отображением соответствующих им групп в Дереве чертежа.

При настройке отображения Дерева чертежа следует учитывать, что существование в Дереве «пустых» групп невозможно. Поэтому группы, отображение которых включено, появляются в Дереве только после создания первого объекта соответствующего типа. Например, если в чертеже нет ни одного макроэлемента, то и группы Макроэлементы в Дереве не будет.

После завершения настройки Дерева нажмите кнопку ОК. При настройке текущего чертежа изменения отразятся в Дереве: в нем исчезнут или появятся группы. При настройке новых чертежей произведенные изменения вступят в силу при создании этих чертежей.

Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.2.6.5. Настройка списка свойств

Вы можете настроить подключение нужных библиотек свойств и отображение свойств в графических документах (как новых, так и текущих). Для этого используется диалог Настройка списка свойств, вызываемый командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Настройка списка свойств,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Настройка списка свойств.

Аналогичный диалог используется для настройки списка свойств документов-моделей (деталей, простых и технологических сборок) и отчетов.

Для новых документов и отчетов диалог позволяет подключать библиотеки свойств и настраивать отображение нужных свойств в документе. В диалоге содержатся вкладки Библиотеки свойств и Свойства.

Для текущего документа диалог позволяет выполнить только настройку отображения свойств. В этом случае в диалоге содержится одна вкладка Свойства.

Табл. 9.2.9. Элементы управления диалога настройки списка свойств

Элемент

Описание настройки

Библиотеки свойств

Вкладка позволяет сформировать список библиотек, свойства из которых могут использоваться в новых документах и отчетах.

Список библиотек

Список содержит имена файлов выбранных пользователем библиотек свойств и пути к этим файлам. Слева от имени файла каждой библиотеки находится опция. Она позволяет подключить библиотеку свойств. После этого свойства из библиотеки добавляются в список свойств новых документов или в список свойств, используемых для настройки стиля отчета в диалоге Параметры стиля отчета.

Добавить

Кнопка позволяет добавить библиотеку в список библиотек. Вызывает стандартный диалог Windows выбора файла.

Удалить

Кнопка позволяет удалить библиотеку из списка библиотек.

Переместить вверх/вниз

Кнопка позволяет переместить библиотеку, выделенную в списке библиотек, на одну позицию вверх или вниз.

Свойства

Вкладка позволяет настроить отображение свойств в текущем документе, в новых документах или в списке свойств диалога Параметры стиля отчета.

Список свойств

Список содержит системные и дополнительные свойства.

Набор системных свойств одинаков для всех документов. Набор дополнительных свойств формируется следующим образом:

– для текущего документа в набор включаются свойства, заданные пользователем для этого документа,

– для новых документов и отчетов — свойства из подключенных библиотек свойств.

Для каждого свойства в списке свойств отображаются следующие данные: наименование, информация об источнике свойства и комментарий, заданный для свойства.

Опция слева от наименования свойства позволяет управлять отображением этого свойства в текущем документе, в новых документах или в списке свойств диалога Параметры стиля отчета.

Все

Опция позволяет включить/отключить отображение всех свойств, содержащихся в списке свойств. Если список содержит как отображаемые, так и неотображаемые свойства (не все опции в списке включены), опция Все показывается на сером фоне.

Щелчок по опции в таком состоянии отключит ее. Следующий — включит.

Просмотр

Кнопка позволяет просмотреть параметры свойства, выделенного в списке свойств. Вызывает диалог Параметры свойства.

После завершения настройки списка свойств нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.2.6.6. Линии

В этом разделе:

9.2.6.6.1. Стили

9.2.6.6.2. Осевая линия


9.2.6.6.1. Стили

Использование стилей линий в графических документах (как новых, так и текущих) настраивается в диалоге Стили линий, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Линии — Стили,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Линии — Стили.

Табл. 9.2.10. Элементы управления диалога настройки списка стилей линий

Элемент

Описание настройки

Фильтр линий

Группа элементов управления для формирования набора стилей линий, доступных при создании и редактировании геометрических объектов.

Список стилей линий

Список содержит названия и образцы стилей линий. Включите опции, соответствующие стилям, которые должны присутствовать в списке Стиль на Панели свойств при работе с объектами.

Включить все

Опция позволяет включить/отключить доступность всех стилей, содержащихся в списке. Если список содержит как доступные, так и недоступные стили (не все опции в списке включены), опция Все показывается на сером фоне.

Щелчок по опции в таком состоянии отключит ее. Следующий — включит.

Переместить вверх/вниз

Кнопка позволяет переместить стиль, выделенный в списке, на одну позицию вверх или вниз.

Перестроение списка

Кнопка позволяет сгруппировать стили, отображение которых включено, в верхней части списка.

Изменить список

Кнопка позволяет добавить в список или исключить из него пользовательские стили линий. После нажатия этой кнопки на экране появляется Менеджер стилей линий (см. раздел 3.2.1.2.1).

Запоминать последний стиль

Опция управляет способом определения умолчательного стиля линии.

– Если опция включена, то для отрисовки каждого следующего геометрического объекта используется стиль линии предыдущего.

– Если опция отключена, то стиль линии, оказавшийся на первой позиции списка, становится умолчательным — к его названию добавляются слова «По умолчанию». Если первый или несколько первых по списку стилей отключены, то умолчательным является первый включенный стиль. Умолчательный стиль будет предлагаться всякий раз после вызова команды построения геометрического объекта. Однако, при построении нескольких объектов во время работы одной и той же команды умолчательным стилем отрисовки очередного объекта является стиль линии, использовавшийся для предыдущего.

Завершив настройку использования стилей линий, нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.2.6.6.2. Осевая линия

Умолчательный внешний вид осевых линий, создаваемых в с помощью команд Осевая линия по двум точкам, Автоосевая и Обозначение центра настраивается в диалоге Осевая линия. Диалог вызывается командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Линии — Осевая линия,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Линии — Осевая линия.

Для большего удобства работы в диалог включен поясняющий рисунок.

Табл. 9.2.11. Элементы управления диалога настройки осевых линий

Элемент

Описание настройки

№ подгруппы1

1-выход линии за контур, мм

2-пунктир, мм

3-промежуток, мм

Поля позволяют ввести нужные значения параметров вручную или установить их с помощью счетчика.

2.2

4-штрих, мм

Согласно ГОСТ осевые линии должны начинаться и заканчиваться штрихами. Чтобы выполнить это требование, при отрисовке линий производится пропорциональное изменение длин штрихов.

Если при расчете длины штриха должно учитываться условие попадания полученного значения в диапазон, заданный стандартом (5-30 мм), выберите вариант автоопределение длины.

Если нужно, чтобы длина штриха не превышала определенного значения (без учета требований стандарта), выберите вариант длина не более, мм, а затем введите или установите с помощью счетчика значение максимальной длины.

2.2

5-размер «крестика», мм

Поле позволяет задать длины штрихов, образующих перекрестие в центре объекта при создании обозначения центра в виде «крестика». Во всех остальных случаях длина центральных штрихов будет определяться системой автоматически.

2.2
  1. Номер подгруппы, к которой относится настраиваемый параметр. Параметры объединены в группы и подгруппы по их действию на объекты текущего документа, см. раздел 9.2.1.1.

Настройка размера «крестика» распространяется также на радиальный размер с изломом.

После завершения настройки параметров отрисовки осевых линий нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.2.6.7. Линия разрыва

Умолчательные параметры линий разрывов видов в чертежах (как новых, так и текущих) настраиваются в диалоге Параметры линии разрыва, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Линия разрыва,

– для текущего документа — Сервис — Параметры... — Текущий чертеж — Линия разрыва.

Табл. 9.2.12. Элементы управления диалога настройки параметров линии разрыва
Элемент | Описание настройки | № подгруппы1
Тип линии разрыва | Группа опций позволяет выбрать тип линии разрыва, который будет по умолчанию использоваться при создании разрывов видов. | 2.1
Амплитуда волнистой линии в % от длины Амплитуда, max | Поля для настройки амплитуды волнистой линии или линии с изломом. Подробно назначение этих полей рассмотрено в разделе 3.6.5.8.3. | 2.1
Зазор | Поле для ввода или выбора расстояния между линиями разрыва — расстояния, на котором будут располагаться друг от друга видимые части изображения после создания разрыва. Минимальное значение зазора — 1 мм. 2 | 2.1
  1. Номер подгруппы, к которой относится настраиваемый параметр. Параметры объединены в группы и подгруппы по их действию на объекты текущего документа, см. раздел 9.2.1.1.
  2. При использовании линий разрыва с изломом зазор должен составлять не менее двух амплитуд. Поэтому, если умолчательный зазор меньше удвоенной максимальной амплитуды, то при создании разрыва, ограниченного линиями с изломом, умолчательное значение зазора автоматически увеличивается.

Завершив настройку параметров линий разрывов, нажмите кнопку OK. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.

Настройка, произведенная в данном диалоге, хранится в самом документе и не изменяется при его передаче на другое рабочее место.


9.2.6.8. Линии обрыва

В этом разделе:

9.2.6.8.1. Волнистая линия

9.2.6.8.2. Линия с изломами

9.2.6.8.3. Фильтр стилей линий


9.2.6.8.1. Волнистая линия

Настройка отрисовки волнистой линии для графических документов (как новых, так и текущих) выполняется в диалоге Волнистая линия, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Линии обрыва — Волнистая линия,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Линии обрыва — Волнистая линия.

Диалог позволяет выбрать умолчательные амплитуду волны и количество полуволн волнистой линии. Для большего удобства работы в диалог включен поясняющий рисунок.

Табл. 9.2.13. Элементы управления диалога настройки волнистой линии
Элемент | Описание настройки | № подгруппы1
1-амплитуда | Введите или задайте с помощью счетчика в поле Значение величину амплитуды волны. Укажите единицы измерения амплитуды, выбрав один из вариантов: – в % — число, введенное в поле Значение, показывает соотношение между амплитудой и длиной волны; – в мм — число, введенное в поле Значение, показывает амплитуду волны в миллиметрах. Амплитуда — расстояние между средней линией и максимально удаленной от нее точкой волны. | 2.2
Количество полуволн | Введите или задайте с помощью счетчика целое число полуволн. | 2.1
  1. Номер подгруппы, к которой относится настраиваемый параметр. Параметры объединены в группы и подгруппы по их действию на объекты текущего документа, см. раздел 9.2.1.1.

После завершения настройки нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.2.6.8.2. Линия с изломами

Настройка отрисовки линии с изломами для графических документов (как новых, так и текущих) выполняется в диалоге Линия с изломами, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Линии обрыва — Линия с изломами,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Линии обрыва — Линия с изломами.

Диалог позволяет выбрать умолчательные амплитуду, количество и тип изломов, а также задать выступ линии за начальную и конечную точки. Для большего удобства работы в диалог включен поясняющий рисунок.

Табл. 9.2.14. Элементы управления диалога настройки линии с изломами
Элемент | Описание настройки | № подгруппы1
1-амплитуда, мм | Введите или задайте с помощью счетчика величину амплитуды излома. Амплитуда — расстояние между линией и максимально удаленной от нее точкой излома. | 2.2
2-выступ линии за конечные точки, мм | Введите или задайте с помощью счетчика величину выступа линии за начальную и конечную точки. | 2.2
Количество изломов | Введите или задайте с помощью счетчика целое число изломов. | 2.1
Тип изломов | Выберите вариант отрисовки излома: – Тип 1 — кососимметричный с двумя вершинами, – Тип 2 — осесимметричный с тремя вершинами. | 2.1
  1. Номер подгруппы, к которой относится настраиваемый параметр. Параметры объединены в группы и подгруппы по их действию на объекты текущего документа, см. раздел 9.2.1.1.

Если заданное количество изломов с текущими параметрами не умещается между конечными точками линии, то строится максимально возможное целое число изломов.

После завершения настройки параметров нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.2.6.8.3. Фильтр стилей линий

Настройка фильтра стилей линий для линии обрыва в графических документах (как новых, так и текущих) выполняется в диалоге Фильтр стилей линий объекта. Диалог вызывается командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Линии обрыва — Фильтр стилей линий,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Линии обрыва — Фильтр стилей линий.

Аналогичный диалог используется для настройка фильтра стилей линий:

– марок/позиционных обозначений,

– фигурных скобок.

Диалог позволяет указать, какие стили линий будут доступны при создании объекта, задать их последовательность в списке и выбрать умолчательный вариант.

Табл. 9.2.15. Элементы управления диалога настройки фильтра стилей линий

Элемент

Описание настройки

№ подгруппы1

Список линий

Список содержит названия и образцы системных стилей линий.

Те стили, рядом с названиями которых включены опции, доступны в документе: они попадают в список, из которого выбирается стиль линии при создании объекта.

Если вы используете отличный от умолчательного набор стилей, измените настройку, включив или выключив опции рядом с названиями стилей линий.

Первый по списку стиль линии не имеет опции. Его нельзя отключить, т.е. он всегда считается включенным. Поэтому он постоянно доступен при создании объекта.

1.2

Переместить вверх/вниз

Кнопки позволяют настроить порядок следования стилей в списке.

Чтобы изменить положение стиля, выделите его и нажмите нужную кнопку. Выбранный стиль переместится на одну позицию в указанном направлении.

Порядок следования стилей, установленный в данном диалоге, передается в список, из которого выбирается стиль линии при создании объекта.

Для ускорения создания объектов в документе рекомендуется поставить на первую позицию тот стиль линии, который используется чаще всего, а за ним расположить остальные применяемые стили линий в порядке убывания частоты их использования.

1.2

Включить все

Опция позволят включить или выключить сразу все стили линий. Если включены не все опции списка, опция отображается на сером фоне. Щелчок по опции в таком состоянии выключит ее. Следующий — включит.

При любом состоянии опции Включить все стиль линии Основная является включенным.

—
  1. Номер подгруппы, к которой относится настраиваемый параметр. Параметры объединены в группы и подгруппы по их действию на объекты текущего документа, см. раздел 9.2.1.1.

После завершения настройки нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.2.6.9. Мультилиния

Умолчательные параметры мультилинии для графических документов (как новых, так и текущих) настраиваются в диалоге Мультилиния, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Мультилиния,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Мультилиния.

Табл. 9.2.16. Элементы управления диалога настройки параметров мультилинии

Элемент

Описание настройки

№ подгруппы1

Линии

Группа элементов позволяет задать умолчательный набор линий мультилинии.

Чтобы добавить линию в набор, нажмите кнопку Добавить линию, изменить линию — кнопку Изменить линию, удалить — кнопку Удалить линию.

После нажатия кнопки Добавить линию или Изменить линию на экране появляется диалог задания параметров линии. Задайте нужный стиль линии и ее смещение относительно базовой линии.

2.1

Ограничитель 1

Ограничитель 2

Группа элементов позволяет задать умолчательный вид ограничителя конечного сегмента мультилинии и его параметры — высоту и стиль линии отрисовки. Подробнее об ограничителях — см. раздел 3.2.12.8.

2.1

Загрузить из шаблона

Кнопка позволяет загрузить из шаблона набор линий и виды ограничителей конечных сегментов мультилинии. Подробнее о шаблоне — см. раздел 3.2.12.5. После нажатия кнопки Загрузить из шаблона на экране появится стандартный диалог открытия файла. Выберите имя нужного файла и нажмите кнопку Открыть.

В группе Линии отобразится набор линий мультилинии, в группах Ограничитель 1 и Ограничитель 2 — виды ограничителей конечных сегментов и их параметры.

При необходимости вы можете изменить полученные из шаблона параметры.

—
  1. Номер подгруппы, к которой относится настраиваемый параметр. Параметры объединены в группы и подгруппы по их действию на объекты текущего документа, см. раздел 9.2.1.1.

Завершив настройку параметров мультилинии, нажмите кнопку OK. Для выхода из диалога без изменения настройки нажмите кнопку Отмена.

Настройка, произведенная в данном диалоге, хранится в самом документе и не изменяется при его передаче на другое рабочее место.


9.2.6.10. Размеры

В этом разделе:

9.2.6.10.1. Общие настройки

9.2.6.10.2. Параметры

9.2.6.10.3. Отметки уровня

9.2.6.10.4. Стрелки и засечки

9.2.6.10.5. Фильтры стрелок — Линейные размеры

9.2.6.10.6. Фильтры стрелок — Размеры окружностей и дуг

9.2.6.10.7. Фильтры стрелок — Угловые размеры

9.2.6.10.8. Надпись

9.2.6.10.9. Положение надписи

9.2.6.10.10. Допуски и предельные значения — Параметры

9.2.6.10.11. Допуски и предельные значения — Допуски по умолчанию

9.2.6.10.12. Точности


9.2.6.10.1. Общие настройки

Общие настройки размеров для графических документов (как новых, так и текущих) выполняются в диалоге Общие настройки, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Размеры — Общие настройки,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Размеры — Общие настройки.

Аналогичный диалог используется для выполнения общих настроек размеров моделей.

Диалог позволяет настроить умолчательный зазор/длину выносных линий для линейных размеров и умолчательный формат отображения значений угловых размеров.

Табл. 9.2.17. Элементы управления диалога общих настроек размеров

Элемент

Описание настройки

№ подгруппы1

Фиксировать для линейных размеров

При простановке размеров выносная линия может начинаться на некотором расстоянии от точки привязки.

Вы можете зафиксировать как длину выносных линий, так и зазор между точкой привязки и началом выносной линии. Для этого введите нужное значение в поле Зазор или длина, мм.

Допускаются только целые значения длины (зазора).

Если требуется, чтобы заданное число определяло зазор между выносной линией и точкой привязки размера, включите опцию Зазор выносных линий.

Если же введенное значение должно определять длину выносной линии, включите опцию Длину выносных линий.

Если значение в поле Зазор или длина, мм равно нулю, то выносные линии начинаются в точках привязки размера и могут иметь любую длину.

2.1

Формат отображения угловых размеров

Выберите формат отображения значения угла в размерных надписях угловых размеров.

Если требуется отображать значения углов в формате ХХ°ХХ'ХХ", включите опцию Градусы, минуты, секунды.

Если требуется отображать значения углов в формате ХХ,ХХХ°, включите опцию Десятичная система.

Точность отображения значений задается в диалоге настройки точности размерных надписей (см. раздел 9.2.6.10.12).

2.1
  1. Номер подгруппы, к которой относится настраиваемый параметр. Параметры объединены в группы и подгруппы по их действию на объекты текущего документа, см. раздел 9.2.1.1.

После завершения общей настройки размеров нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.2.6.10.2. Параметры

Настройка отрисовки размеров для графических документов (как новых, так и текущих) выполняется в диалоге Параметры отрисовки размеров, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Размеры — Параметры,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Размеры — Параметры.

Аналогичный диалог используется для настройки отрисовки размеров моделей.

Диалог позволяет настроить геометрические параметры размеров: выход выносной линии за размерную, длина и угол стрелки, расстояние от выносной линии до текста и т.п. Настраиваемые параметры относятся к подгруппе 1.1 (см. раздел 9.2.1.1).

Для большего удобства работы в диалог включен поясняющий рисунок.

В поля диалога введите нужные значения параметров или выберите их из раскрывающихся списков. Введенные значения будут добавляться в списки и сохраняться в течение сеанса работы КОМПАС-3D.

Настройка распространяется на следующие объекты документа, имеющие в своем составе стрелки или засечки:

– размеры всех типов,

– обозначения допусков формы,

– обозначения шероховатости на полке.

После завершения настройки параметров отрисовки размеров нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.2.6.10.3. Отметки уровня

Настройка параметров отрисовки отметок уровня при простановке размеров высоты для графических документов (как новых, так и текущих) выполняется в диалоге Параметры отрисовки отметок уровня, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Размеры — Отметки уровня,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Размеры — Отметки уровня.

Для большего удобства работы в диалог включен поясняющий рисунок.

Табл. 9.2.18. Элементы управления диалога настройки отрисовки отметок уровня
Элемент | Описание настройки | № подгруппы1
Основная | Опция позволяет выбрать вариант отрисовки стрелок отметок уровней. По умолчанию опция отключена — стрелки отрисовываются тонкими линиями. Чтобы стрелки отрисовывались основными линиями, включите опцию. Изменение состояния опции отражается на примере стрелки. | 1.1
1 - длина стрелки, мм | Поле позволяет ввести или задать с помощью счетчика длину стрелки в миллиметрах. | 1.1
2 - расстояние до полки, мм | Поле позволяет ввести или задать с помощью счетчика расстояние от стрелки до полки в миллиметрах. | 1.1
  1. Номер подгруппы, к которой относится настраиваемый параметр. Параметры объединены в группы и подгруппы по их действию на объекты текущего документа, см. раздел 9.2.1.1.

После завершения настройки отрисовки стрелок нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.2.6.10.4. Стрелки и засечки

Настройка отрисовки стрелок и засечек размеров для графических документов (как новых, так и текущих) выполняется в диалоге Стрелки и засечки, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Размеры — Стрелки и засечки,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Размеры — Стрелки и засечки.

Аналогичный диалог используется при настройке отрисовки стрелок и засечек размеров для моделей.

Табл. 9.2.19. Элементы управления диалога настройки отрисовки стрелок и засечек

Элемент

Описание настройки

№ подгруппы1

Размещение стрелок

Чтобы выбрать вариант размещения стрелок размерных линий относительно выносных линий размера, включите нужную опцию: Изнутри, Снаружи, Авто.

Вариант Авто означает, что система будет для каждого размера автоматически определять, ставить ли стрелки изнутри или снаружи.

2.1

Стрелки размерных линий

Чтобы стрелки размерных линий зачернялись, включите опцию Зачернять стрелки. Если опция отключена, то стрелки отрисовываются линиями.

Изменение состояния опции отражается на примере стрелки.

Настройка зачернения распространяется на следующие объекты:

– все размеры со стрелками следующих видов: «Стрелка», «Стрелка закрытая», «Точка», «Точка маленькая»;

– обозначения допусков формы;

– стрелки направления взгляда,

– обозначения шероховатости на полке.

1.1

Засечки

Чтобы засечки отрисовывались основными линиями, включите опцию Основная. Если опция отключена, то засечки отрисовываются тонкими линиями. Изменение состояния опции отражается на примере засечек.

Настройка отрисовки засечек распространяется на все объекты, которые имеют (или могут иметь) в своем составе засечки:

– размеры со стрелками в виде засечек;

– обозначения шероховатости на полке.

1.1
  1. Номер подгруппы, к которой относится настраиваемый параметр. Параметры объединены в группы и подгруппы по их действию на объекты текущего документа, см. раздел 9.2.1.1.

После завершения настройки отрисовки стрелок и засечек нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.2.6.10.5. Фильтры стрелок — Линейные размеры

Настройка фильтра стрелок линейных размеров для графических документов (как новых, так и текущих) выполняется в диалоге Фильтр стрелок линейных размеров, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Размеры — Фильтры стрелок — Линейные размеры,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Размеры — Фильтры стрелок — Линейные размеры.

Аналогичный диалог используется для настройки фильтра стрелок:

– в графических документах

• размеров окружностей и дуг,

• угловых размеров,

• линий-выносок,

• обозначений позиций,

• марок/позиционных обозначений,

• выносных надписей,

• линий разреза,

• линий разреза/сечения,

– стрелок взгляда,в моделях

• линейных размеров,

• размеров окружностей и дуг,

• угловых размеров,

• линий-выносок,

• обозначений позиций.

Диалог позволяет указать, какие стрелки будут доступны при создании объектов, задать их последовательность в списке и выбрать умолчательный вариант.

Табл. 9.2.20. Элементы управления диалога настройки фильтра стрелок

Элемент

Описание настройки

№ подгруппы1

Список стрелок

Список содержит названия и образцы всех имеющихся в системе видов стрелок для выбранного типа объектов (размер, линия-выноска или другое обозначение).

Те стрелки, рядом с названиями которых включены опции, доступны в документе: они попадают в список, из которого выбирается вид стрелки при создании объекта.

Если вы используете отличный от умолчательного набор стрелок, измените настройку, включив или выключив опции рядом с названиями стрелок.

Один вид стрелки — Без стрелки — не имеет опции. Его нельзя отключить, т.е. он всегда считается включенным. Поэтому он постоянно доступен при создании объектов в документах.

1.2

Переместить вверх/вниз

Кнопки позволяют настроить порядок следования стрелок в списке.

Чтобы изменить положение стрелки, выделите ее и нажмите нужную кнопку. Выбранная стрелка переместится на одну позицию в указанном направлении.

Порядок следования стрелок, установленный в данном диалоге, передается в список, из которого выбирается вид стрелки при создании объекта. Стрелка, оказавшаяся на первой позиции списка, становится умолчательной.

Если первая или несколько первых по списку стрелок отключены, то умолчательной является первая включенная стрелка.

Для ускорения создания объектов в документе рекомендуется поставить на первую позицию тот вид стрелки, который используется чаще всего, а за ним расположить остальные применяемые виды стрелок в порядке убывания частоты их использования.

1.2

Включить все

Опция позволят включить или отключить сразу все виды стрелок. Если включены не все стрелки, опция отображается на сером фоне. Щелчок по опции в таком состоянии отключит ее. Следующий — включит.

При любом состоянии опции Включить все вид стрелки Без стрелки является включенным.

—
  1. Номер подгруппы, к которой относится настраиваемый параметр. Параметры объединены в группы и подгруппы по их действию на объекты текущего документа, см. раздел 9.2.1.1.

После завершения настройки фильтра стрелок нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.2.6.10.6. Фильтры стрелок — Размеры окружностей и дуг

Настройка фильтра стрелок размеров окружностей и дуг для графических документов (как новых, так и текущих) выполняется в диалоге Фильтр стрелок размеров окружностей и дуг, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Размеры — Фильтры стрелок — Размеры окружностей и дуг,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Размеры — Фильтры стрелок — Размеры окружностей и дуг.

Работа в аналогичном диалоге описана в разделе 9.2.6.10.5.


9.2.6.10.7. Фильтры стрелок — Угловые размеры

Настройка фильтра стрелок угловых размеров для графических документов (как новых, так и текущих) выполняется в диалоге Фильтр стрелок угловых размеров, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Размеры — Фильтры стрелок — Угловые размеры,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Размеры — Фильтры стрелок — Угловые размеры.

Работа в аналогичном диалоге описана в разделе 9.2.6.10.5.


9.2.6.10.8. Надпись

Настройка параметров текста размерных надписей для графических документов (как новых, так и текущих) выполняется в диалоге Параметры размерной надписи, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Размеры — Надпись,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Размеры — Надпись.

Аналогичный диалог используется для настройки параметров текста:

– в графических документах

• надписей линий-выносок,

• обозначений позиций,

• обозначений изменений,

• марок/позиционных обозначений,

• обозначений узлов,

• выносных надписей,

• фигурных скобок,

• марок,знака неуказанной шероховатости,

• текстовых меток,

– в моделях

• размерных надписей,

• надписей линий-выносок,

• обозначений позиций,

• знака неуказанной шероховатости.

Табл. 9.2.21. Элементы управления диалога настройки параметров размерной надписи
Элемент | Описание настройки | № подгруппы1
Шрифт | Раскрывающийся список позволяет выбрать нужный шрифт. Список содержит все шрифты, подключенные в Windows. | 2.2
Отличается от шрифта по умолчанию | Опция позволяет установить соответствие или отличие шрифта от заданного по умолчанию шрифта документа. Если опция отключена, шрифт всегда совпадает с установленным по умолчанию. | 2.2
Высота, мм | Поле позволяет ввести значение высоты символов (в миллиметрах) или выбрать это значение из раскрывающегося списка. Введенное вручную значение добавляется в список и сохраняется в течение сеанса работы КОМПАС-3D. | 2.2
Сужение | Поле позволяет ввести значение сужения символов или выбрать это значение из раскрывающегося списка. Введенное вручную значение добавляется в список и сохраняется в течение сеанса работы КОМПАС-3D. | 2.2
Шаг строк, мм | Поле позволяет ввести значение расстояния между строками текста. Для некоторых надписей шаг строк не имеет значения, поэтому при их настройке данное поле отсутствует. | 2.2
Цвет... | Кнопка позволяет выбрать цвет символов в стандартном диалоге выбора цвета. | 2.2
Курсив | Опция позволяет задать курсивное начертание символов. | 2.2
Жирный | Опция позволяет задать утолщенное начертание символов. | 2.2
Подчеркнутый | Опция позволяет задать подчеркнутое начертание символов. | 2.2
Пример | Окно просмотра показывает внешний вид текста. Это позволяет визуально оценить произведенные изменения. | —
Текст | Поле для ввода умолчательного текста текстовой метки. Поле присутствует в диалоге при настройке параметров текста текстовых меток. | 2.2
  1. Номер подгруппы, к которой относится настраиваемый параметр. Параметры объединены в группы и подгруппы по их действию на объекты текущего документа, см. раздел 9.2.1.1.

После завершения настройки нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.2.6.10.9. Положение надписи

Настройка положения размерных надписей для графических документов (как новых, так и текущих) выполняется в диалоге Положение размерной надписи, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Размеры — Положение надписи,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Размеры — Положение надписи.

Аналогичный диалог используется при настройке положения размерных надписей для моделей.

Диалог позволяет задать умолчательные параметры расположения размерных надписей линейных и угловых размеров. Настраиваемые параметры относятся к подгруппе 2.1 (см. раздел 9.2.1.1).

Чтобы выбрать вариант расположения размерных надписей линейных размеров, включите нужную опцию в группе Линейные размеры, угловых размеров — в группе Угловые размеры. Схемы расположения надписей, соответствующие вариантам, показаны на рисунках.

Выбранный вариант расположения линейного размера определяет также расположение диаметрального и радиального размеров.

После завершения настройки нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.2.6.10.10. Допуски и предельные значения — Параметры

Настройка параметров отображения допусков и предельных значений в размерах для графических документов (как новых, так и текущих) выполняется в диалоге Параметры допусков и предельных значений, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Размеры — Допуски и предельные значения — Параметры,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Размеры — Допуски и предельные значения — Параметры.

Аналогичный диалог используется при настройке допусков и предельных значений размеров для моделей.

Табл. 9.2.22. Элементы управления диалога настройки допусков и предельных значений размеров

Элемент

Описание настройки

№ подгруппы1

Использовать квалитеты

Группа элементов позволяет управлять доступностью основных и дополнительных квалитетов при простановке размеров.

Если выбраны оба варианта — Основные и Дополнительные, то при простановке размеров помимо предпочтительных квалитетов будут доступны основные и дополнительные.

Если не выбран ни один вариант, то будет возможен выбор только из предпочтительных квалитетов.

Возможность отображения квалитета в надписи определяется настройкой, произведенной в диалоге задания точности размеров (см. раздел 9.2.6.10.12). В нем можно указать номер, начиная с которого квалитет не показывается в размерной надписи.

1.2

Отображать в надписи

Группа элементов позволяет управлять умолчательным включением в размерную надпись квалитетов и значений, определяющих поле допуска.

Чтобы в размерной надписи присутствовали предельные отклонения или предельные значения размера, включите опцию Предельные отклонения или значения.

Если выбран вариант Отклонения, в размерной надписи будут присутствовать предельные отклонения размеров. Если выбран вариант Пределы — предельные значения размера.

При выборе варианта Пределы становится доступна опция Пределы в одну строку. При ее включении максимальное и минимальное значения размера записываются не одно над другим, а друг за другом через дефис.

2.1

Выравнивание текста

Группа опций позволяет выбрать способ расположения отклонений или предельных значений относительно номинального значения.

Схемы расположения показаны на рисунках.

Чтобы выбрать умолчательный вариант размещения значений, включите нужную опцию.

2.1
  1. Номер подгруппы, к которой относится настраиваемый параметр. Параметры объединены в группы и подгруппы по их действию на объекты текущего документа, см. раздел 9.2.1.1.

После завершения настройки допусков и предельных значений нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.2.6.10.11. Допуски и предельные значения — Допуски по умолчанию

Настройка умолчательных параметров допусков в графических документах (как новых так и текущих) выполняется в диалоге Значение и состояние допусков по умолчанию, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Размеры — Допуски и предельные значения — Допуски по умолчанию,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Размеры — Допуски и предельные значения — Допуски по умолчанию.

Диалог содержит группу кнопок Допуски размеров по умолчанию. Кнопки служат для вызова диалога Допуск, в котором задается умолчательное значение допуска — либо указанием квалитета, либо вводом предельных отклонений. Настройка производится отдельно для каждого типа размеров: линейные, угловые, диаметральные, радиальные (для угловых размеров задаются только отклонения). Настраиваемые параметры относятся к подгруппе 2.1 (см. раздел 9.2.1.1).

Рядом с каждой кнопкой находится поле для просмотра текущего значения допуска. Поле недоступно для ручного редактирования; варианты содержимого:

– число 10 с квалитетом или отклонениями1 — размеры данного типа будут иметь указанный допуск,

– пустое поле — размеры данного типа не будут иметь допуска.

Поле может содержать только число 10. Это означает, что допуск задан квалитетом, но выбран такой номер квалитета, для которого отключено отображение в размерной надписи. Номер, начиная с которого квалитет не вносится в надпись, задается при настройке точностей размерных надписей (см. раздел 9.2.6.10.12).

После завершения настройки нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.

  1. Значение 10 служит для иллюстрации.


9.2.6.10.12. Точности

Настройка параметров отображения значений размеров в размерных надписях для графических документов (как новых, так и текущих) выполняется в диалоге Точности размерных надписей, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Размеры — Точности,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Размеры — Точности.

Аналогичный диалог используется при настройке параметров отображения значений размеров для моделей.

Табл. 9.2.23. Элементы управления диалога настройки параметров размерных надписей

Элемент

Описание настройки

№ подгруппы1

Линейные размеры

Группа элементов позволяет настроить отображение значений размеров, записанных в десятичной системе, т.е. линейных, имеющих формат хх,ххх, и угловых, имеющих формат хх,ххх°.

В поле Число знаков после запятой в размерных надписях введите или задайте с помощью счетчика количество знаков после запятой, которые необходимо отображать в размерных надписях.

Чтобы размерные надписи всегда содержали указанное количество знаков после запятой, включите опцию Показывать незначащие нули после запятой. В этом случае в размерные надписи будут автоматически добавляться нули.

1.1

Угловые размеры

Группа опций позволяет настроить отображение значений угловых размеров, имеющих формат хх°хх'хх".

Значения углов могут отображаться с точностью до градусов, минут и секунд. Чтобы выбрать нужный вариант, включите соответствующую опцию: Градусы, Минуты, Секунды.

Формат отображения угловых размеров задается в диалоге общих настроек размеров (см. раздел 9.2.6.10.1).

1.1

Hoмep, нaчинaя c кoтopoгo нe внocить квaлитeт в paзмepную нaдпиcь

Поле позволяет ввести или задать с помощью счетчика номер квалитета. Например, если установить в этом поле значение 9, то наименования всех квалитетов с номерами 9, 10, 11 и т.д. не будут отображаться в размерных надписях. Данный элемент управления доступен при отключенной опции Показывать все.

Если опция Показывать все включена, в размерную надпись можно включить квалитет с любым номером.

1.1
  1. Номер подгруппы, к которой относится настраиваемый параметр. Параметры объединены в группы и подгруппы по их действию на объекты текущего документа, см. раздел 9.2.1.1.

После завершения настройки нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.2.6.11. Линия-выноска

В этом разделе:

9.2.6.11.1. Параметры

9.2.6.11.2. Стрелки и засечки

9.2.6.11.3. Фильтр стрелок

9.2.6.11.4. Текст над/под/за полкой

9.2.6.11.5. Наклонный текст

9.2.6.11.6. Размеры знаков


9.2.6.11.1. Параметры

Настройка отрисовки линий-выносок для графических документов (как новых, так и текущих) выполняется в диалоге Параметры отрисовки линий-выносок, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Линия выноска — Параметры,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Линия выноска — Параметры.

Аналогичный диалог используется при настройке параметров отрисовки линий-выносок для моделей.

Диалог позволяет настроить геометрические параметры линий-выносок — длину и угол стрелки, расстояние от выносной полки до текста и т.п. Настраиваемые параметры относятся к подгруппе 1.1 (см. раздел 9.2.1.1).

Для большего удобства работы в диалог включен поясняющий рисунок.

В поля диалога введите нужные значения параметров или выберите их из раскрывающихся списков. Введенные значения добавляются в списки и сохраняются в течение сеанса работы КОМПАС-3D.

После завершения настройки параметров отрисовки линий-выносок нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.2.6.11.2. Стрелки и засечки

Настройка отрисовки стрелок и засечек линий-выносок для графических документов (как новых, так и текущих) выполняется в диалоге Стрелки и засечки, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Линия-выноска — Стрелки и засечки,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Линия-выноска — Стрелки и засечки.

Аналогичный диалог используется при настройке параметров отрисовки стрелок и засечек марок/позиционных обозначений с линией-выноской в графических документах и линий-выносок в моделях.

Табл. 9.2.24. Элементы управления диалога настройки стрелок и засечек
Элемент | Описание настройки | № подгруппы1
Стрелки линий-выносок | Чтобы стрелки линий-выносок зачернялись, включите опцию Зачернять стрелки. Если опция отключена, стрелки отрисовываются линиями. Изменение состояния опции отражается на примере стрелки в диалоге. | 1.1
Засечки линий-выносок | Чтобы засечки отрисовывались основными линиями, включите опцию Основная. Если опция отключена, засечки отрисовываются тонкими линиями. Изменение состояния опции отражается на примере засечек. | 1.1
  1. Номер подгруппы, к которой относится настраиваемый параметр. Параметры объединены в группы и подгруппы по их действию на объекты текущего документа, см. раздел 9.2.1.1.

После завершения настройки отрисовки стрелок и засечек нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.2.6.11.3. Фильтр стрелок

Настройка фильтра стрелок линий-выносок для графических документов (как новых, так и текущих) выполняется в диалоге Фильтр стрелок линий-выносок, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Линия-выноска — Фильтр стрелок,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Линия-выноска — Фильтр стрелок.

Работа в аналогичном диалоге описана в разделе 9.2.6.10.5.


9.2.6.11.4. Текст над/под/за полкой

Настройка параметров текста надписей на линиях-выносках для графических документов (как новых, так и текущих) выполняется в диалоге Параметры текста над/под/за полкой, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Линия-выноска — Текст над/под/за полкой,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Линия-выноска — Текст над/под/за полкой.

Работа в аналогичном диалоге описана в разделе 9.2.6.10.8.


9.2.6.11.5. Наклонный текст

Настройка параметров наклонного текста на линиях-выносках для графических документов (как новых, так и текущих) выполняется в диалоге Параметры наклонного текста, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Линия-выноска — Наклонный текст,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Линия-выноска — Наклонный текст.

Работа в аналогичном диалоге описана в разделе 9.2.6.10.8.


9.2.6.11.6. Размеры знаков

Настройка размеров знаков для графических документов (как новых, так и текущих) выполняется в диалоге Размеры знаков, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Линия-выноска — Размеры знаков,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Линия-выноска — Размеры знаков.

Аналогичный диалог используется при настройке размеров знаков для моделей.

Диалог позволяет задать размеры окружности знака маркирования, треугольника знака клеймения и высоту знаков обозначения соединений.

Табл. 9.2.25. Элементы управления диалога настройки размеров знаков
Элемент | Описание настройки | № подгруппы1
Диаметр окружности знака маркирования, мм | Поле позволяет задать значение диаметра окружности знаков маркирования (в миллиметрах) в документе. Согласно ГОСТ 2.314-68 этот диаметр должен быть от 10 до 15 мм. | 1.1
Высота треугольника знака клеймения, мм | Поле позволяет задать значение высоты треугольников знаков клеймения (в миллиметрах) в документе. Согласно ГОСТ 2.314-68 эта высота должна быть от 10 до 15 мм. | 1.1
Высота знаков обозначения соединений, получаемых пайкой, склеиванием, сшиванием и металлическими скобками, мм | Поле позволяет задать высоту знаков обозначения соединений, получаемых пайкой, склеиванием, сшиванием и металлическими скобками (в миллиметрах) в документе. | 1.1
  1. Номер подгруппы, к которой относится настраиваемый параметр. Параметры объединены в группы и подгруппы по их действию на объекты текущего документа, см. раздел 9.2.1.1.

Если размер знаков маркировки и клеймения будет слишком мал, то тексты этих обозначений могут выйти за пределы знаков. Для изменения шрифта в обозначениях пользуйтесь диалогом настройки текста над/под/за полкой линии-выноски (см. раздел 9.2.6.11.4).

После завершения настройки размеров знаков нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.2.6.12. Условное пересечение

Настройка параметров условного пересечения для графических документов (как новых, так и текущих) выполняется в диалоге Условное пересечение, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Условное пересечение,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Условное пересечение.

Табл. 9.2.26. Элементы управления диалога настройки параметров условного пересечения

Элемент

Описание настройки

№ подгруппы1

Выход выносных линий за точку пересечения, мм

Поле позволяет задать значение выхода выносных линий за точку пересечения (в миллиметрах) в документе.

1.1

Отрисовывать точку пересечения стилем

Группа элементов позволяет выбрать способ отображения точки пересечения выносных линий.

Чтобы в условном пересечении проставлялось обозначение точки, включите опцию Отрисовывать точку пересечения стилем. Выберите стиль отрисовки точки из раскрывающегося списка.

2.1

Фиксировать для условного пересечения

Группа элементов позволяет фиксировать длину или зазор выносных линий.

Выносная линия может начинаться на некотором расстоянии от конечной точки объекта.

Вы можете зафиксировать как длину выносных линий, так и зазор между объектом и началом выносной линии. Для этого введите нужное значение в поле Зазор или длина, мм.

Допускаются только целые значения длины (зазора).

Если требуется, чтобы заданное число определяло зазор между объектом и выносной линией, включите опцию Зазор выносных линий.

Если же введенное значение должно определять длину выносной линии, включите опцию Длину выносных линий.

Если значение в поле Зазор или длина, мм равно нулю или превышают расстояние от объекта до точки пересечения, то выносные линии строятся от конечных точек объектов до точки пересечения.

2.1
  1. Номер подгруппы, к которой относится настраиваемый параметр. Параметры объединены в группы и подгруппы по их действию на объекты текущего документа, см. раздел 9.2.1.1.

После завершения настройки параметров нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.2.6.13. Обозначения для машиностроения

В этом разделе:

9.2.6.13.1. Обозначение позиции — Параметры

9.2.6.13.2. Обозначение позиции — Параметры формы

9.2.6.13.3. Обозначение позиции — Стрелки

9.2.6.13.4. Обозначение позиции — Фильтр стрелок

9.2.6.13.5. Обозначение позиции — Текст обозначения позиций

9.2.6.13.6. Шероховатость

9.2.6.13.7. Отклонения формы и база

9.2.6.13.8. Линия разреза/сечения — Параметры

9.2.6.13.9. Линия разреза/сечения — Стрелки

9.2.6.13.10. Линия разреза/сечения — Фильтр стрелок

9.2.6.13.11. Стрелка взгляда — Параметры

9.2.6.13.12. Стрелка взгляда — Стрелки

9.2.6.13.13. Стрелка взгляда — Фильтр стрелок

9.2.6.13.14. Автосортировка

9.2.6.13.15. Обозначение изменения — Параметры

9.2.6.13.16. Обозначение изменения — Текст надписи


9.2.6.13.1. Обозначение позиции — Параметры

Настройка отрисовки обозначений позиций для графических документов (как новых, так и текущих) выполняется в диалоге Параметры отрисовки обозначений позиций, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Обозначения для машиностроения — Обозначение позиции — Параметры,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Обозначения для машиностроения — Обозначение позиции — Параметры.

Аналогичный диалог используется для настройки отрисовки обозначений позиций в моделях.

Диалог позволяет настроить геометрические параметры обозначений позиций — длину и угол стрелки, расстояние от выносной полки до текста и т.п. Настраиваемые параметры относятся к подгруппе 1.1 (см. раздел 9.2.1.1).

Для большего удобства работы в диалог включен поясняющий рисунок.

В поля диалога введите нужные значения параметров или выберите их из раскрывающихся списков. Введенные значения добавляются в списки и сохраняются в течение сеанса работы КОМПАС-3D.

После завершения настройки параметров отрисовки обозначений позиций нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.2.6.13.2. Обозначение позиции — Параметры формы

Настройка параметров формы обозначений позиций для графических документов (как новых, так и текущих) выполняется в диалоге Параметры формы обозначений позиций, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Обозначения для машиностроения — Обозначение позиции — Параметры формы,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Обозначения для машиностроения — Обозначение позиции — Параметры формы.

Аналогичный диалог используется для настройки отрисовки обозначений позиций в моделях.

Табл. 9.2.27. Элементы управления диалога настройки формы обозначений позиций

Элемент

Описание настройки

№ подгруппы1

Размер формы

Вы можете задать размер для обозначений позиций с типом формы «Круг», «Шестиугольник», «Круг с разделителем». В поле Значение задайте нужное значение размера (в миллиметрах) вручную или выберите его из раскрывающегося списка.

Для формы типа «Круг» это значение определяет диаметр, для формы типа «Шестиугольник» — диаметр вписанной окружности, для формы типа «Круг с разделителем» — радиус.

Если размер формы будет слишком мал, то номера позиций могут выйти за пределы значков. Для изменения высоты шрифта номеров позиций пользуйтесь диалогом настройки текста обозначений позиций (см. раздел 9.2.6.13.5).

1.1

Параметры формы

Группа элементов позволяет задать параметры формы обозначений позиций.

—

Тип формы

Раскрывающийся список позволяет выбрать нужный тип формы обозначений позиций.

2.1

Горизонтально

Опция управляет расположением обозначения позиции, содержащего несколько номеров позиций.

Если опция включена, то номера располагаются в строку, если отключена — в колонку.

2.1

Формировать полку

Опция управляет отрисовкой полки позиционной линии-выноски.

Для позиций с типом формы «Простой текст» полка представляет собой обычную полку линии-выноски, над которой располагается текст. Для остальных типов формы полка — это отрезок, соединяющий текст с линией-выноской.

Примеры типов формы обозначения позиций приведены на рисунке 3.3.67.

2.1
  1. Номер подгруппы, к которой относится настраиваемый параметр. Параметры объединены в группы и подгруппы по их действию на объекты текущего документа, см. раздел 9.2.1.1.

После завершения настройки нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.2.6.13.3. Обозначение позиции — Стрелки

Настройка отрисовки стрелок обозначений позиций для графических документов (как новых, так и текущих) выполняется в диалоге Стрелки, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Обозначения для машиностроения — Обозначение позиции — Стрелки,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Обозначения для машиностроения — Обозначение позиции — Стрелки.

Аналогичный диалог используется для настройки отрисовки стрелок линий разреза/сечения, стрелок взгляда, стрелок линий разреза для строительства, а также стрелок обозначений позиций в моделях.

Диалог содержит опцию Зачернять. Если она отключена, стрелки отрисовываются линиями. При включенной опции стрелки обозначений позиций зачерняются. Изменение состояния опции отражается на примере стрелки в диалоге.

Настраиваемый параметр — Зачернение стрелок — относится к подгруппе 1.1 (см. раздел 9.2.1.1).

После завершения настройки отрисовки стрелок нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.2.6.13.4. Обозначение позиции — Фильтр стрелок

Настройка фильтра стрелок обозначений позиций для графических документов (как новых, так и текущих) выполняется в диалоге Фильтр стрелок обозначений позиций, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Обозначения для машиностроения — Обозначение позиции — Фильтр стрелок,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Обозначения для машиностроения — Обозначение позиции — Фильтр стрелок.

Работа в аналогичном диалоге описана в разделе 9.2.6.10.5.


9.2.6.13.5. Обозначение позиции — Текст обозначения позиций

Настройка параметров текста обозначения позиций для графических документов (как новых, так и текущих) выполняется в диалоге Параметры текста обозначения позиций, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Обозначения для машиностроения — Обозначение позиции — Текст обозначения позиций,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Обозначения для машиностроения — Обозначение позиции — Текст обозначения позиций.

Работа в аналогичном диалоге описана в разделе 9.2.6.10.8.


9.2.6.13.6. Шероховатость

Настройка параметров обозначения шероховатости для графических документов (как новых, так и текущих) выполняется в диалоге Параметры обозначения шероховатости, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Обозначения для машиностроения — Шероховатость,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Обозначения для машиностроения — Шероховатость.

Аналогичный диалог используется для настройки параметров обозначения шероховатости в моделях.

Табл. 9.2.28. Элементы управления диалога настройки обозначения шероховатости

Элемент

Описание настройки

№ подгруппы1

Соответствие ГОСТ 2.309-73

Группа опций позволяет выбрать структуру обозначений шероховатости.

При изменении данной настройки для текущего документа все имеющиеся в нем обозначения шероховатости перестраиваются.

Таким образом, чтобы отредактировать чертеж, обозначения шероховатости в котором соответствуют предыдущей редакции ГОСТ 2.309-73, необходимо открыть этот чертеж, изменить настройку обозначений шероховатости и сохранить.

1.1

Параметры текста

Группа элементов позволяет настроить текст в обозначениях шероховатости — ввести нужный шаг строк (в миллиметрах) и задать параметры шрифта.

2.2
  1. Номер подгруппы, к которой относится настраиваемый параметр. Параметры объединены в группы и подгруппы по их действию на объекты текущего документа, см. раздел 9.2.1.1.

Зачернение стрелок и толщина линии засечки (для обозначения шероховатости на полке) подчиняется настройке, произведенной для размеров.

Настройка текста, произведенная в данном диалоге, распространяется на обозначения шероховатости, проставленные на изображениях поверхностей. Настройка текста неуказанной шероховатости производится в разделе Параметры документа — Неуказанная шероховатость диалогов настройки текущего и новых чертежей (см. раздел 9.2.6.19.7).

После завершения настройки параметров отображения шероховатости нажмите кнопку OK. Для выхода из диалога без изменения настроек нажмите кнопку Отмена.


9.2.6.13.7. Отклонения формы и база

Настройка параметров отрисовки обозначений отклонений формы и баз для графических документов (как новых, так и текущих) выполняется в диалоге Параметры отрисовки отклонения формы и базы, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Обозначения для машиностроения — Отклонения формы и база,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Обозначения для машиностроения — Отклонения формы и база.

Аналогичный диалог используется для настройки параметров отрисовки обозначений отклонений формы и баз в моделях.

Диалог позволяет задать параметры, которые будут использоваться по умолчанию при простановке допусков формы и расположения поверхностей, а также обозначений баз.

Табл. 9.2.29. Элементы управления диалога настройки отклонений формы и баз
Элемент | Описание настройки | № подгруппы1
Зачернять треугольник | Опция позволяет закрашивать треугольник при отрисовке обозначения базы или допуска формы. Зачернение стрелок подчиняется настройке, произведенной для размеров. | 1.1
Название | Раскрывающийся список позволяет выбрать нужный шрифт. Список содержит все шрифты, подключенные в Windows. | 2.2
Отличается от шрифта по умолчанию | Опция позволяет установить соответствие или отличие шрифта от заданного по умолчанию шрифта документа. Если опция отключена, шрифт всегда совпадает с установленным по умолчанию. | 2.2
Высота, мм | Поле позволяет ввести значение высоты символов (в миллиметрах) или выбрать это значение из раскрывающегося списка. Введенное вручную значение добавляется в список и сохраняется в течение сеанса работы КОМПАС-3D. | 2.2
Сужение | Поле позволяет ввести значение сужения символов или выбрать это значение из раскрывающегося списка. Введенное вручную значение добавляется в список и сохраняется в течение сеанса работы КОМПАС-3D. | 2.2
Цвет... | Кнопка позволяет выбрать цвет символов в стандартном диалоге выбора цвета. | 2.2
Курсив | Опция позволяет задать курсивное начертание символов. | 2.2
Жирный | Опция позволяет задать утолщенное начертание символов. | 2.2
Подчеркнутый | Опция позволяет задать подчеркнутое начертание символов. | 2.2
Пример | Окно просмотра показывает внешний вид текста. Это позволяет визуально оценить произведенные изменения. | —
  1. Номер подгруппы, к которой относится настраиваемый параметр. Параметры объединены в группы и подгруппы по их действию на объекты текущего документа, см. раздел 9.2.1.1.

Высота треугольника определяется системой автоматически. По ГОСТ 2.308-79 она равна высоте шрифта размерных чисел.

Высота рамки также определяется автоматически. В соответствии с обязательным Приложением 1 к ГОСТ 2.308-79 она равна удвоенной высоте шрифта, используемого в надписи допуска формы.

После завершения настройки параметров нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.2.6.13.8. Линия разреза/сечения — Параметры

Настройка параметров линий разреза/сечения для графических документов (как новых, так и текущих) выполняется в диалоге Параметры линии разреза/сечения, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Обозначения для машиностроения — Линия разреза/сечения — Параметры,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Обозначения для машиностроения — Линия разреза/сечения — Параметры.

Аналогичный диалог используется для настройки параметров линий разреза для строительства.

Табл. 9.2.30. Элементы управления диалога настройки линии разреза/сечения
Элемент | Описание настройки | № подгруппы1
Название | Раскрывающийся список позволяет выбрать нужный шрифт. Список содержит все шрифты, подключенные в Windows. | 2.2
Отличается от шрифта по умолчанию | Опция позволяет установить соответствие или отличие шрифта от заданного по умолчанию шрифта документа. Если опция отключена, шрифт всегда совпадает с установленным по умолчанию. | 2.2
Высота, мм | Поле позволяет ввести значение высоты символов (в миллиметрах) или выбрать это значение из раскрывающегося списка. Введенное вручную значение добавляется в список и сохраняется в течение сеанса работы КОМПАС-3D. | 2.2
Сужение | Поле позволяет ввести значение сужения символов или выбрать это значение из раскрывающегося списка. Введенное вручную значение добавляется в список и сохраняется в течение сеанса работы КОМПАС-3D. | 2.2
Цвет... | Кнопка позволяет выбрать цвет символов в стандартном диалоге выбора цвета. | 2.2
Курсив | Опция позволяет задать курсивное начертание символов. | 2.2
Жирный | Опция позволяет задать утолщенное начертание символов. | 2.2
Подчеркнутый | Опция позволяет задать подчеркнутое начертание символов. | 2.2
Пример | Окно просмотра показывает внешний вид текста. Это позволяет визуально оценить произведенные изменения. | —
Длина штриха, мм | Поле позволяет ввести длину штриха линии разреза или сечения (в миллиметрах). | 1.1
Текст для обозначения | Поле позволяет ввести текст, который будет добавляться перед номером разреза при создании ссылки на обозначение разреза. Произведенные изменения текста передаются в уже созданные ссылки. Поле присутствует в диалоге при настройке параметров линии разреза для строительства. | 1.1
  1. Номер подгруппы, к которой относится настраиваемый параметр. Параметры объединены в группы и подгруппы по их действию на объекты текущего документа, см. раздел 9.2.1.1.

После завершения настройки нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.2.6.13.9. Линия разреза/сечения — Стрелки

Настройка отрисовки стрелок линий разреза/сечения для графических документов (как новых, так и текущих) выполняется в диалоге Стрелки, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Обозначения для машиностроения — Линия разреза/сечения — Стрелки,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Обозначения для машиностроения — Линия разреза/сечения — Стрелки.

Работа в аналогичном диалоге описана в разделе 9.2.6.13.3.


9.2.6.13.10. Линия разреза/сечения — Фильтр стрелок

Настройка фильтра стрелок линии разреза/сечения для графических документов (как новых, так и текущих) выполняется в диалоге Фильтр стрелок линии разреза/сечения, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Обозначения для машиностроения — Линия разреза/сечения — Фильтр стрелок,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Обозначения для машиностроения — Линия разреза/сечения — Фильтр стрелок.

Работа в аналогичном диалоге описана в разделе 9.2.6.10.5.


9.2.6.13.11. Стрелка взгляда — Параметры

Настройка параметров стрелки направления взгляда для графических документов (как новых, так и текущих) выполняется в диалоге Параметры стрелки взгляда, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Обозначения для машиностроения — Параметры,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Обозначения для машиностроения — Параметры.

Табл. 9.2.31. Элементы управления диалога настройки стрелки взгляда
Элемент | Описание настройки | № подгруппы1
Название | Раскрывающийся список позволяет выбрать нужный шрифт. Список содержит все шрифты, подключенные в Windows. | 2.2
Отличается от шрифта по умолчанию | Опция позволяет установить соответствие или отличие шрифта от заданного по умолчанию шрифта документа. Если опция отключена, шрифт всегда совпадает с установленным по умолчанию. | 2.2
Высота, мм | Поле позволяет ввести значение высоты символов (в миллиметрах) или выбрать это значение из раскрывающегося списка. Введенное вручную значение добавляется в список и сохраняется в течение сеанса работы КОМПАС-3D. | 2.2
Сужение | Поле позволяет ввести значение сужения символов или выбрать это значение из раскрывающегося списка. Введенное вручную значение добавляется в список и сохраняется в течение сеанса работы КОМПАС-3D. | 2.2
Цвет... | Кнопка позволяет выбрать цвет символов в стандартном диалоге выбора цвета. | 2.2
Курсив | Опция позволяет задать курсивное начертание символов. | 2.2
Жирный | Опция позволяет задать утолщенное начертание символов. | 2.2
Подчеркнутый | Опция позволяет задать подчеркнутое начертание символов. | 2.2
Пример | Окно просмотра показывает внешний вид текста. Это позволяет визуально оценить произведенные изменения. | —
Длина объекта, мм | Поле позволяет ввести длину отрезка, входящего в состав стрелки взгляда. | 1.1
  1. Номер подгруппы, к которой относится настраиваемый параметр. Параметры объединены в группы и подгруппы по их действию на объекты текущего документа, см. раздел 9.2.1.1.

После завершения настройки нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.2.6.13.12. Стрелка взгляда — Стрелки

Настройка отрисовки стрелок направления взгляда для графических документов (как новых, так и текущих) выполняется в диалоге Стрелки, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Обозначения для машиностроения — Стрелка взгляда — Стрелки,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Обозначения для машиностроения — Стрелка взгляда — Стрелки. Работа в аналогичном диалоге описана в разделе 9.2.6.13.3.


9.2.6.13.13. Стрелка взгляда — Фильтр стрелок

Настройка фильтра стрелок направления взгляда для графических документов (как новых, так и текущих) выполняется в диалоге Фильтр стрелок взгляда, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Обозначения для машиностроения — Стрелка взгляда — Фильтр стрелок,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Обозначения для машиностроения — Стрелка взгляда — Фильтр стрелок.

Работа в аналогичном диалоге описана в разделе 9.2.6.10.5.


9.2.6.13.14. Автосортировка

Включение и настройка режима автосортировки для графических документов (как новых, так и текущих) выполняется в диалоге Автосортировка буквенных обозначений, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Обозначения для машиностроения — Автосортировка,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Обозначения для машиностроения — Автосортировка.

Аналогичный диалог используется для настройки автосортировки в моделях.

Табл. 9.2.32. Элементы управления диалога настройки автосортировки

Элемент

Описание настройки

№ подгруппы1

Буквы сортировки

Поле определяет, какие буквы и в каком порядке будут присваиваться объектам оформления. В данное поле можно вводить только буквы (как заглавные, так и строчные). Повторение букв не допускается.

После того как будут использованы все буквы перечня, объектам присваиваются те же буквы в том же порядке, но с добавлением нижнего числового индекса: A1, Б1, ... ; затем A2, Б2, ... и так далее до A9, Б9.

1.1

Порядок сортировки

Группа элементов управления позволяет определить порядок автоматического присвоения буквенных обозначений объектам различных типов.

В списке отображаются названия типов объектов оформления, обозначения которых могут автоматически сортироваться.

Приоритет объектов того или иного типа определяется положением названия типа в списке. Чтобы повысить приоритет объектов нужного типа, выделите его название в списке и нажмите кнопку Переместить вверх, а чтобы понизить — кнопку Переместить вниз. Выбранное название переместится на одну позицию в указанном направлении.

При настройке документа-модели список содержит только один тип объектов — обозначение базы.

1.1

По умолчанию включить сортировку для:

Группа опций позволяет указать типы объектов, которым будут автоматически присваиваться буквенные обозначения.

Включите опции, соответствующие нужным типам объектов. Действие опций распространяется только на вновь создаваемые объекты.

Если во время создания объекта на Панели свойств включается/отключается опция Автосортировка, то в группе По умолчанию включить сортировку для: автоматически включается/отключается опция с названием объектов того же типа.

При настройке документа-модели доступна только одна опция — Обозначений базы. Ее действие распространяется на все обозначения баз, имеющиеся в модели.

  1. Номер подгруппы, к которой относится настраиваемый параметр. Параметры объединены в группы и подгруппы по их действию на объекты текущего документа, см. раздел 9.2.1.1.

После завершения настройки автосортировки нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.2.6.13.15. Обозначение изменения — Параметры

Настройка параметров обозначения изменений для графических документов (как новых, так и текущих) выполняется в диалоге Параметры обозначения изменения, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Обозначения для машиностроения — Обозначение изменения — Параметры,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Обозначения для машиностроения — Обозначение изменения — Параметры.

Табл. 9.2.33. Элементы управления диалога настройки обозначения изменения
Элемент | Описание настройки | № подгруппы1
Тип знака | Группа опций позволяет выбрать вариант знака обозначения изменения — квадрат, окружность, скобки. Для знака типа скобки доступен выбор вида скобок из раскрывающегося списка. | 2.1
Высота знаков обозначения изменения, мм | Поле позволяет ввести размер знаков обозначения изменения: сторону квадрата (для знака типа квадрат) или диаметр окружности (для знака типа окружность). Для знака типа скобки высота скобок определяется высотой шрифта текста обозначения изменения. При выборе этого типа знака поле Высота знаков обозначения изменения, мм недоступно. | 2.1
Тип выноски | Группа опций позволяет выбрать вариант задания длины линий-выносок обозначения изменения. | —
полной длины | Включите эту опцию, чтобы длины линий-выносок могли быть произвольными. | 2.1
ограниченный отрезок, мм | Включите эту опцию, чтобы все линии-выноски имели одну фиксированную длину. При выборе этого варианта доступен ввод значения длины. | 2.1
  1. Номер подгруппы, к которой относится настраиваемый параметр. Параметры объединены в группы и подгруппы по их действию на объекты текущего документа, см. раздел 9.2.1.1.

После завершения настройки нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.2.6.13.16. Обозначение изменения — Текст надписи

Настройка параметров текста обозначений изменений для графических документов (как новых, так и текущих) выполняется в диалоге Параметры текста обозначений изменений, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Обозначения для машиностроения — Обозначение изменения — Текст надписи,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Обозначения для машиностроения — Обозначение изменения — Текст надписи.

Работа в аналогичном диалоге описана в разделе 9.2.6.10.8.


9.2.6.14. Обозначения для строительства

В этом разделе:

9.2.6.14.1. Марка/позиционное обозначение — Общие настройки

9.2.6.14.2. Марка/позиционное обозначение — С линией-выноской

9.2.6.14.3. Марка/позиционное обозначение — На линии

9.2.6.14.4. Марка/позиционное обозначение — Без линии-выноски

9.2.6.14.5. Линия разреза — Параметры

9.2.6.14.6. Линия разреза — Стрелки

9.2.6.14.7. Линия разреза — Фильтр стрелок

9.2.6.14.8. Обозначение узла и узла в сечении — Общие настройки

9.2.6.14.9. Обозначение узла и узла в сечении — Параметры

9.2.6.14.10. Обозначение узла и узла в сечении — Текст

9.2.6.14.11. Номер узла — Параметры

9.2.6.14.12. Номер узла — Текст

9.2.6.14.13. Выносная надпись — Общие настройки

9.2.6.14.14. Выносная надпись — Параметры

9.2.6.14.15. Выносная надпись — Стрелки и засечки

9.2.6.14.16. Выносная надпись — Фильтр стрелок

9.2.6.14.17. Выносная надпись — Текст

9.2.6.14.18. Фигурная скобка — Общие настройки

9.2.6.14.19. Фигурная скобка — Параметры

9.2.6.14.20. Фигурная скобка — Фильтр стилей линий

9.2.6.14.21. Фигурная скобка — Текст

9.2.6.14.22. Координационные оси — Общие настройки

9.2.6.14.23. Координационные оси — Параметры

9.2.6.14.24. Координационные оси — Указатель ориентации

9.2.6.14.25. Координационные оси — Текст


9.2.6.14.1. Марка/позиционное обозначение — Общие настройки

Общие настройки марок/позиционных обозначений для графических документов (как новых, так и текущих) выполняются в диалоге Общие настройки, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Обозначения для строительства — Марка/позиционное обозначение — Общие настройки,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Обозначения для строительства — Марка/позиционное обозначение — Общие настройки.

Диалог позволяет установить разделитель — один или несколько символов между текстом марки и ее номером, а также включить автонумерацию. Настраиваемые параметры относятся к следующим подгруппам (см. раздел 9.2.1.1):

– Разделитель между текстом марки и ее номером — к подгруппе 1.1,

– Автонумерация — к подгруппе 1.2.

Введите символы в поле Разделитель между текстом марки и ее номером. Максимальное количество символов — три. Эти символы будут автоматически вставляться между текстом марки и ее номером. Если один из элементов обозначения — название марки или ее номер — отсутствует, то разделитель не отображается. В окне просмотра диалога ввода текста марки/позиционного обозначения (см. раздел 3.3.8.3.1) текст марки отображается вместе с разделителем.

Разделитель не является текстом и не редактируется в диалоге ввода текста.

Включите опцию Автонумерация, чтобы при создании каждой новой марки ей автоматически присваивался следующий по счету свободный номер. Автонумерация работает для марок с одинаковым текстовым обозначением. Тип марки — с линией-выноской, на линии или без линии-выноски — значения не имеет.

После завершения настройки нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.2.6.14.2. Марка/позиционное обозначение — С линией-выноской

Параметры

Настройка параметров отрисовки марок/позиционных обозначений с линией выноской для графических документов (как новых, так и текущих) выполняется в диалоге Параметры отрисовки марки/позиционного обозначения, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Обозначения для строительства — Марка/позиционное обозначение — С линией-выноской — Параметры,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Обозначения для строительства — Марка/позиционное обозначение — С линией-выноской — Параметры.

Диалог позволяет настроить геометрические параметры линий-выносок обозначения —длину и угол стрелки, расстояние от выносной полки до текста и т.п. Настраиваемые параметры относятся к подгруппе 1.1 (см. раздел 9.2.1.1).

Для большего удобства работы в диалог включены поясняющие рисунки.

В поля диалога введите нужные значения параметров или выберите их из раскрывающихся списков. Введенные значения добавляются в списки и сохраняются в течение сеанса работы КОМПАС-3D.

После завершения настройки параметров нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.

Стрелки и засечки

Настройка отрисовки стрелок и засечек линий-выносок для графических документов (как новых, так и текущих) выполняется в диалоге Стрелки и засечки, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Обозначения для строительства — Марка/позиционное обозначение — С линией-выноской — Стрелки и засечки,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Обозначения для строительства — Марка/позиционное обозначение — С линией-выноской — Стрелки и засечки.

Работа в диалоге описана в разделе 9.2.6.11.2.

Фильтр стрелок

Настройка фильтра стрелок марок/позиционных обозначений для графических документов (как новых, так и текущих) выполняется в диалоге Фильтр стрелок марок/позиционных обозначений, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Обозначения для строительства — Марка/позиционное обозначение — С линией-выноской — Фильтр стрелок,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Обозначения для строительства — Марка/позиционное обозначение — С линией-выноской — Фильтр стрелок.

Работа в аналогичном диалоге описана в разделе 9.2.6.10.5.

Текст

Настройка параметров текста на линии-выноске марок/позиционных обозначений для графических документов (как новых, так и текущих) выполняется в диалоге Параметры текста марки/позиционного обозначения, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Обозначения для строительства — Марка/позиционное обозначение — С линией-выноской — Текст,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Обозначения для строительства — Марка/позиционное обозначение — С линией-выноской — Текст.

Работа в аналогичном диалоге описана в разделе 9.2.6.10.8.


9.2.6.14.3. Марка/позиционное обозначение — На линии

Параметры

Настройка параметров марок/позиционных обозначений на линии для графических документов (как новых, так и текущих) выполняется в диалоге Параметры марки/позиционного обозначения, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Обозначения для строительства — Марка/позиционное обозначение — На линии — Параметры,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Обозначения для строительства — Марка/позиционное обозначение — На линии — Параметры.

Диалог позволяет задать расстояния от текста до линии под/над ним. Настраиваемые параметры относятся к подгруппе 1.1 (см. раздел 9.2.1.1).

Для большего удобства работы в диалог включен поясняющий рисунок.

Если при создании марки/позиционного обозначения введен двухстрочный текст и выбран способ его размещения На линии, то расстояние между строками будет равно сумме расстояний от верхней и нижней строк до линии.

В поля диалога введите нужные значения параметров или выберите их из раскрывающихся списков. Введенные значения добавляются в списки и сохраняются в течение сеанса работы КОМПАС-3D.

После завершения настройки параметров отрисовки нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.

Текст

Настройка параметров текста на линии марок/позиционных обозначений для графических документов (как новых, так и текущих) выполняется в диалоге Параметры текста марки/позиционного обозначения, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Обозначения для строительства — Марка/позиционное обозначение — На линии — Текст,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Обозначения для строительства — Марка/позиционное обозначение — На линии — Текст.

Работа в аналогичном диалоге описана в разделе 9.2.6.10.8.


9.2.6.14.4. Марка/позиционное обозначение — Без линии-выноски

Параметры

Настройка параметров марок/позиционных обозначений без линии-выноски для графических документов (как новых, так и текущих) выполняется в диалоге Параметры марки/позиционного обозначения, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Обозначения для строительства — Марка/позиционное обозначение — Без линии-выноски — Параметры,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Обозначения для строительства — Марка/позиционное обозначение — Без линии-выноски — Параметры.

Диалог позволяет задать размеры форм обозначений различных типов, а также расстояния от текста до разделителя формы. Для большего удобства работы в диалог включены поясняющие рисунки.

Табл. 9.2.34. Элементы управления диалога настройки параметров марок/позиционных обозначений

Элемент

Описание настройки

№ подгруппы1

Размеры форм

Группа элементов позволяет задать размеры для различных форм марки/позиционного обозначения. Для этого выполните следующие действия.

Выберите из раскрывающегося списка Форма нужный тип формы.

Задайте размеры этой формы.

– Если выбранная форма требует задания одного габаритного размера, его значение вводится или задается с помощью счетчика в поле 1 - габарит, мм. В случае двойной окружности заданное значение определяет диаметр внутренней окружности. Зазор между наружной и внутренней окружностями составляет 1 мм.

– Если выбранная форма требует задания двух габаритных размеров, их значения вводятся или задаются с помощью счетчика в полях 1 - ширина, мм и 2 - высота, мм. В случае выбора скругленного прямоугольника в поле 1 - ширина, мм вводится расстояние между центрами полуокружностей.

Обратите внимание на то, что в данном диалоге задаются только размеры форм. Умолчательный вариант формы и перечень форм, доступных при создании объектов, настраиваются в диалоге Фильтр форм марок/позиционных обозначений (см. раздел Фильтр форм на с. 2043).

2.2

Размещение текста

Группа элементов позволяет задать расстояние от текста до разделителя формы.

Разделитель — горизонтальная черта посередине формы — автоматически создается в обозначении, если введен двухстрочный текст. Первая строка текста располагается над разделителем, а вторая — под разделителем.

В поля Расстояние от разделителя формы до текста над/под ним, мм введите нужные значения расстояний или выберите эти значения из раскрывающихся списков. Введенные значения добавляются в списки и сохраняются в течение сеанса работы КОМПАС-3D.

2.2
  1. Номер подгруппы, к которой относится настраиваемый параметр. Параметры объединены в группы и подгруппы по их действию на объекты текущего документа, см. раздел 9.2.1.1.

После завершения настройки нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.

Фильтр стилей линий

Настройка фильтра стилей линий для марок/позиционных обозначений в графических документах (как новых, так и текущих) выполняется в диалоге Фильтр стилей линий объекта. Диалог вызывается командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Обозначения для строительства — Марка/позиционное обозначение — Без линии-выноски — Фильтр стилей линий,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Обозначения для строительства — Марка/позиционное обозначение — Без линии-выноски — Фильтр стилей линий.

Работа в диалоге описана в разделе 9.2.6.8.3.

Фильтр форм

Настройка фильтра форм марок/позиционных обозначений без линии-выноски для графических документов (как новых, так и текущих) выполняется в диалоге Фильтр форм марок/позиционных обозначений, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Обозначения для строительства — Марка/позиционное обозначение — Без линии-выноски — Фильтр форм,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Обозначения для строительства — Марка/позиционное обозначение — Без линии-выноски — Фильтр форм.

Диалог позволяет указать, какие формы будут доступны при создании объектов, задать их последовательность в списке и выбрать умолчательный вариант.

Табл. 9.2.35. Элементы управления диалога настройки фильтра форм

Элемент

Описание настройки

№ подгруппы1

Список форм

Список содержит названия и образцы всех имеющихся в системе форм марок/позиционных обозначений (настройка параметров форм описана в разделе Параметры на с. 2041).

Те формы, рядом с названиями которых включены опции, доступны в документе: они попадают в список, из которого выбирается форма обозначения при создании объекта.

Если вы используете отличный от умолчательного набор форм, измените настройку, включив или отключив опции рядом с названиями форм.

В список форм включен вид отрисовки обозначения — Без формы, который не имеет опции. Его нельзя отключить, т.е. он всегда считается включенным. Поэтому он постоянно доступен при создании объектов в графических документах.

1.2

Переместить вверх/вниз

Кнопки позволяют настроить порядок следования форм в списке.

Чтобы изменить положение формы, выделите ее и нажмите нужную кнопку. Выбранная форма переместится на одну позицию в указанном направлении.

Порядок следования форм, установленный в данном диалоге, передается в список, из которого выбирается форма марки/позиционного обозначения при создании объекта. Форма, находящаяся на первой позиции списка, является умолчательной.

Для ускорения создания объектов в документе рекомендуется поставить на первую позицию ту форму, которая используется чаще всего, а за ней расположить остальные применяемые формы в порядке убывания частоты их использования.

1.2

Включить все

Опция позволят включить или отключить сразу все формы. Если включены не все опции списка, опция отображается на сером фоне. Щелчок по опции в таком состоянии отключит ее, следующий — включит.

При любом состоянии опции Включить все форма Без формы является включенной.

—
  1. Номер подгруппы, к которой относится настраиваемый параметр. Параметры объединены в группы и подгруппы по их действию на объекты текущего документа, см. раздел 9.2.1.1.

После завершения настройки фильтра форм нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.

Текст

Настройка параметров текста марок/позиционных обозначений без линии-выноски для графических документов (как новых, так и текущих) выполняется в диалоге Параметры текста марки/позиционного обозначения, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Обозначения для строительства — Марка/позиционное обозначение — Без линии-выноски — Текст,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Обозначения для строительства — Марка/позиционное обозначение — Без линии-выноски — Текст.

Работа в аналогичном диалоге описана в разделе 9.2.6.10.8.


9.2.6.14.5. Линия разреза — Параметры

Настройка параметров линий разреза для графических документов (как новых, так и текущих) выполняется в диалоге Параметры линии разреза, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Обозначения для строительства — Линия разреза — Параметры,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Обозначения для строительства — Линия разреза — Параметры.

Работа в аналогичном диалоге описана в разделе 9.2.6.13.8.


9.2.6.14.6. Линия разреза — Стрелки

Настройка отрисовки стрелок линий разреза для графических документов (как новых, так и текущих) выполняется в диалоге Стрелки, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Обозначения для строительства — Линия разреза — Стрелки,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Обозначения для строительства — Линия разреза — Стрелки.

Работа в аналогичном диалоге используется в разделе 9.2.6.13.3.,


9.2.6.14.7. Линия разреза — Фильтр стрелок

Настройка фильтра стрелок линий разреза для графических документов (как новых, так и текущих) выполняется в диалоге Фильтр стрелок линии разреза, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Обозначения для строительства — Линия разреза — Фильтр стрелок,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Обозначения для строительства — Линия разреза — Фильтр стрелок.

Работа в аналогичном диалоге описана в разделе 9.2.6.10.5


9.2.6.14.8. Обозначение узла и узла в сечении — Общие настройки

Общие настройки обозначений узлов в сечении для графических документов (как новых, так и текущих) выполняются в диалоге Общие настройки, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Обозначения для строительства — Обозначение узла и узла в сечении — Общие настройки,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Обозначения для строительства — Обозначение узла и узла в сечении — Общие настройки.

Диалог позволяет выбрать стили линии штриха, указать, требуется ли соединять штрихи линией, и выбрать стиль этой линии. Для большего удобства работы в диалог включены рисунки, поясняющие выбор параметров.

Табл. 9.2.36. Элементы управления диалога настройки обозначения узлов

Элемент

Описание настройки

№ подгруппы1

Стиль линии штриха

Группа опций позволяет выбрать стиль линии для отрисовки штриха — Основная или Утолщенная. Переключение опций отражается на поясняющем рисунке.

1.1

Линия между штрихами

Группа опций позволяет выбрать стиль для отрисовки линии между штрихами — Тонкая или Штрихпунктирная, а также отключить отрисовку линии, выбрав вариант Не отрисовывать. Переключение опций отражается на поясняющем рисунке.

Обратите внимание на то, что линия не отрисовывается, если расстояние между штрихами меньше удвоенной величины зазора, заданной в диалоге настройки параметров обозначения узлов (см. раздел 9.2.6.14.9).

1.1
  1. Номер подгруппы, к которой относится настраиваемый параметр. Параметры объединены в группы и подгруппы по их действию на объекты текущего документа, см. раздел 9.2.1.1.

После завершения настройки нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.2.6.14.9. Обозначение узла и узла в сечении — Параметры

Настройка параметров отрисовки обозначений узлов и узлов в сечении для графических документов (как новых, так и текущих) выполняется в диалоге Параметры отрисовки обозначения узла и узла в сечении, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Обозначения для строительства — Обозначение узла и узла в сечении — Параметры,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Обозначения для строительства — Обозначение узла и узла в сечении — Параметры.

Диалог позволяет задать параметры штриха и расположения текста в обозначениях узлов. Параметр Длина штриха относится к подгруппе 2.1, все остальные параметры — к подгруппе 1.1 (см. раздел 9.2.1.1).

Для большего удобства работы в диалог включены поясняющие рисунки.

В поля диалога введите нужные значения параметров или выберите их из раскрывающихся списков. Введенные значения добавляются в списки и сохраняются в течение сеанса работы КОМПАС-3D.

После завершения настройки параметров отрисовки нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.2.6.14.10. Обозначение узла и узла в сечении — Текст

Настройка параметров текста обозначений узлов и узлов в сечении для графических документов (как новых, так и текущих) выполняется в диалоге Параметры текста обозначения узла, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Обозначения для строительства — Обозначение узла и узла в сечении — Текст,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Обозначения для строительства — Обозначение узла и узла в сечении — Текст.

Работа в аналогичном диалоге описана в разделе 9.2.6.10.8.


9.2.6.14.11. Номер узла — Параметры

Настройка параметров отрисовки номеров узлов для графических документов (как новых, так и текущих) выполняется в диалоге Параметры отрисовки номера узла, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Обозначения для строительства — Номер узла — Параметры,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Обозначения для строительства — Номер узла — Параметры.

Диалог позволяет выбрать тип формы номера узла, задать размеры формы и расстояния от текста до разделителя формы. Для большего удобства работы в диалог включен поясняющий рисунок.

Табл. 9.2.37. Элементы управления диалога настройки параметров номера узла

Элемент

Описание настройки

№ подгруппы1

Тип формы

Раскрывающийся список позволяет выбрать умолчательный тип формы обозначения номера узла.

Тип формы определяет количество окружностей и стили линий отрисовки окружностей.

1.1

1 - размер формы, мм

Поле позволяет ввести или выбрать из раскрывающегося списка диаметр окружности обозначения номера узла. В случае двойной окружности выбранное значение будет определять диаметр внутренней окружности.

1.1

2 - ширина кольца, мм

Поле позволяет ввести или выбрать из раскрывающегося списка ширину кольца — расстояние между окружностями обозначения номера узла.

1.1

3 - расстояние от разделителя формы до текста над ним, мм

4 - расстояние от разделителя формы до текста под ним, мм

Поле позволяет ввести или выбрать из раскрывающегося списка расстояние от текста до разделителя формы.

Разделитель — горизонтальная черта посередине формы — формируется автоматически, если текст номера узла двухстрочный. Стиль линии разделителя — тонкая.

1.1
  1. Номер подгруппы, к которой относится настраиваемый параметр. Параметры объединены в группы и подгруппы по их действию на объекты текущего документа, см. раздел 9.2.1.1.

Введенные вручную значения параметров добавляются в списки и сохраняются в течение сеанса работы КОМПАС-3D.

После завершения настройки нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.2.6.14.12. Номер узла — Текст

Настройка параметров текста номеров узлов для графических документов (как новых, так и текущих) выполняется в диалоге Параметры текста номера узла, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Обозначения для строительства — Номер узла — Текст,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Обозначения для строительства — Номер узла — Текст.

Табл. 9.2.38. Элементы управления диалога настройки текста номера узла
Элемент | Описание настройки | № подгруппы1
Шрифт | Раскрывающийся список позволяет выбрать нужный шрифт. Список содержит все шрифты, подключенные в Windows. | 2.2
Отличается от шрифта по умолчанию | Опция позволяет установить соответствие или отличие шрифта от заданного по умолчанию шрифта документа. Если опция отключена, шрифт всегда совпадает с установленным по умолчанию. | 2.2
Высота, мм | Поля позволяют ввести или выбрать из раскрывающегося списка значение высоты символов (в миллиметрах) для однострочного или двухстрочного текста. Введенное вручную значение добавляется в список и сохраняется в течение сеанса работы КОМПАС-3D. | 2.2
Сужение | Поле позволяет ввести или выбрать из раскрывающегося списка значение сужения символов. Введенное вручную значение добавляется в список и сохраняется в течение сеанса работы КОМПАС-3D. | 2.2
Цвет... | Кнопка позволяет выбрать цвет символов в стандартном диалоге выбора цвета. | 2.2
Курсив | Опция позволяет задать курсивное начертание символов. | 2.2
Жирный | Опция позволяет задать утолщенное начертание символов. | 2.2
Подчеркнутый | Опция позволяет задать подчеркнутое начертание символов. | 2.2
Пример | Окно просмотра показывает внешний вид символов. Это позволяет визуально оценить произведенные изменения. | —
  1. Номер подгруппы, к которой относится настраиваемый параметр. Параметры объединены в группы и подгруппы по их действию на объекты текущего документа, см. раздел 9.2.1.1.

После завершения настройки параметров нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.2.6.14.13. Выносная надпись — Общие настройки

Общие настройки выносных надписей для графических документов (как новых, так и текущих) выполняются в диалоге Общие настройки, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Обозначения для строительства — Выносная надпись — Общие настройки,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Обозначения для строительства — Выносная надпись — Общие настройки.

Диалог позволяет задать умолчательные параметры, определяющие форму и выравнивание полок выносных надписей. Для большего удобства работы в диалог включены поясняющие рисунки.

Табл. 9.2.39. Элементы управления диалога общей настройки выносной надписи
Элемент | Описание настройки | № подгруппы1
Тип формы | Группа опций позволяет выбрать вариант формы выносной надписи. Если выбран вариант Тип 1, верхняя полка отображается с дополнительным вертикальным сегментом. Если выбран вариант Тип 2, полка отображается без дополнительного сегмента. | 2.1
Выравнивание полок | Группа опций позволяет выбрать вариант, определяющий длину полок. Если выбран вариант Равной длины, то длина всех полок выравнивается по самой длинной полке. Если выбран вариант По длине текста, то длина каждой полки выравнивается по длине текста на ней. Выступ полки за текст настраивается в диалоге настройки отрисовки выносной надписи (см. раздел 9.2.6.14.14). | 2.1
  1. Номер подгруппы, к которой относится настраиваемый параметр. Параметры объединены в группы и подгруппы по их действию на объекты текущего документа, см. раздел 9.2.1.1.

После завершения общих настроек выносной надписи нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.2.6.14.14. Выносная надпись — Параметры

Настройка параметров отрисовки выносных надписей для графических документов (как новых, так и текущих) выполняется в диалоге Параметры отрисовки выносных надписей, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Обозначения для строительства — Выносная надпись — Параметры,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Обозначения для строительства — Выносная надпись — Параметры.

Диалог позволяет задать параметры стрелки и засечки, а также параметры, определяющие расположение текста на полках выносной надписи. Настраиваемые параметры относятся к подгруппе 1.1 (см. раздел 9.2.1.1).

Для большего удобства работы в диалог включены поясняющие рисунки.

В поля диалога введите нужные значения параметров или выберите их из раскрывающихся списков. Введенные значения добавляются в списки и сохраняются в течение сеанса работы КОМПАС-3D.

После завершения настройки нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.2.6.14.15. Выносная надпись — Стрелки и засечки

Настройка отрисовки стрелок и засечек выносных надписей для графических документов (как новых, так и текущих) выполняется в диалоге Стрелки и засечки, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Обозначения для строительства — Выносная надпись — Стрелки и засечки,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Обозначения для строительства — Выносная надпись — Стрелки и засечки.

Табл. 9.2.40. Элементы управления диалога настройки стрелок и засечек
Элемент | Описание настройки | № подгруппы1
Стрелки выносных надписей | Чтобы стрелки выносной надписи зачернялись, включите опцию Зачернять. Если опция отключена, стрелки отрисовываются линиями. Изменение состояния опции отражается на примере стрелки в диалоге. | 1.1
Засечки выносных надписей | Чтобы засечки отрисовывались основными линиями, включите опцию Основная. Если опция отключена, засечки отрисовываются тонкими линиями. Изменение состояния опции отражается на примере засечек. | 1.1
  1. Номер подгруппы, к которой относится настраиваемый параметр. Параметры объединены в группы и подгруппы по их действию на объекты текущего документа, см. раздел 9.2.1.1.

После завершения настройки нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.2.6.14.16. Выносная надпись — Фильтр стрелок

Настройка фильтра стрелок выносных надписей для графических документов (как новых, так и текущих) выполняется в диалоге Фильтр стрелок выносных надписей, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Обозначения для строительства — Выносная надпись — Фильтр стрелок,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Обозначения для строительства — Выносная надпись — Фильтр стрелок.

Работа в аналогичном диалоге описана в разделе 9.2.6.10.5.


9.2.6.14.17. Выносная надпись — Текст

Настройка параметров текста выносных надписей для графических документов (как новых, так и текущих) выполняется в диалоге Параметры текста выносной надписи, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Обозначения для строительства — Выносная надпись — Текст,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Обозначения для строительства — Выносная надпись — Текст.

Работа в аналогичном диалоге описана в разделе 9.2.6.10.8.


9.2.6.14.18. Фигурная скобка — Общие настройки

Общие настройки фигурных скобок для графических документов (как новых, так и текущих) выполняются в диалоге Общие настройки, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Обозначения для строительства — Фигурная скобка — Общие настройки,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Обозначения для строительства — Фигурная скобка — Общие настройки.

Диалог позволяет задать умолчательный вариант размещения текста и направления фигурной скобки.

Табл. 9.2.41. Элементы управления диалога общей настройки фигурной скобки

Элемент

Описание настройки

№ подгруппы1

Размещение текста

Группа опций позволяет выбрать вариант размещения текста.

Если выбран вариант На полке, то текст располагается на полке линии-выноски.

Если выбран вариант Автоматическое, то текст располагается с наружной стороны скобки — в виде надписи, параллельной скобке.

2.1

Направление скобки

Группа опций позволяет выбрать вариант направления фигурной скобки.

Если выбран вариант Направление 1, то фигурная скобка располагается справа от вектора, направленного от первой точки привязки скобки ко второй.

Если выбран вариант Направление 2, то фигурная скобка располагается слева от вектора, направленного от первой точки привязки скобки ко второй.

2.1
  1. Номер подгруппы, к которой относится настраиваемый параметр. Параметры объединены в группы и подгруппы по их действию на объекты текущего документа, см. раздел 9.2.1.1.

После завершения настройки нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.2.6.14.19. Фигурная скобка — Параметры

Настройка параметров отрисовки фигурных скобок для графических документов (как новых, так и текущих) выполняется в диалоге Параметры отрисовки фигурной скобки, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Обозначения для строительства — Фигурная скобка — Параметры,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Обозначения для строительства — Фигурная скобка — Параметры.

Диалог позволяет задать радиус закругления фигурной скобки и параметры расположения текста. Параметр Радиус закругления скобки относится к подгруппе 2.2, параметры расположения текста — к подгруппе 1.1 (см. раздел 9.2.1.1).

Доступны два варианта расположения текста.

– С наружной стороны скобки в виде надписи со строками, параллельными скобке. Текст автоматически центрируется относительно скобки.

– На полке линии-выноски. Выноска начинается от середины скобки.

Для большего удобства работы в диалог включены поясняющие рисунки.

В поля диалога введите нужные значения параметров или выберите их из раскрывающихся списков. Введенные значения добавляются в списки и сохраняются в течение сеанса работы КОМПАС-3D.

После завершения настройки параметров отрисовки нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.2.6.14.20. Фигурная скобка — Фильтр стилей линий

Настройка фильтра стилей линий для фигурных скобок в графических документах (как новых, так и текущих) выполняется в диалоге Фильтр стилей линий объекта. Диалог вызывается командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Обозначения для строительства — Фигурная скобка — Фильтр стилей линий,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Обозначения для строительства — Фигурная скобка — Фильтр стилей линий.

Работа в диалоге описана в разделе 9.2.6.8.3.


9.2.6.14.21. Фигурная скобка — Текст

Настройка параметров текста фигурных скобок для графических документов (как новых, так и текущих) выполняется в диалоге Параметры текста фигурной скобки, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Обозначения для строительства — Фигурная скобка — Текст,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Обозначения для строительства — Фигурная скобка — Текст.

Работа в аналогичном диалоге описана в разделе 9.2.6.10.8.


9.2.6.14.22. Координационные оси — Общие настройки

Общие настройки отрисовки координационных осей для графических документов (как новых, так и текущих) выполняются в диалоге Общие настройки, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Обозначения для строительства — Координационные оси — Общие настройки,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Обозначения для строительства — Координационные оси — Общие настройки.

Диалог позволяет задать размер марки, список букв для обозначения осей, а также выбрать, на каком конце оси будет отрисовываться марка.

Табл. 9.2.42. Элементы управления диалога общей настройки координационных осей

Элемент

Описание настройки

№ подгруппы1

Марки

Группа элементов позволяет задать размеры и расположение марки.

—

1 - размер марки, мм

Поле позволяет ввести или выбрать из списка диаметр окружности обозначения марки. В случае двойной окружности выбранное значение определяет диаметр внешней окружности. Введенное вручную значение добавляется в список и сохраняется в течение сеанса работы КОМПАС-3D.

2.2

2 - ширина кольца, мм

Поле позволяет ввести или выбрать из списка ширину кольца — расстояние между окружностями обозначения марки. Введенное вручную значение добавляется в список и сохраняется в течение сеанса работы КОМПАС-3D.

2.2

Включить марку 1,

Включить марку 2

Включите опцию Включить марку 1, чтобы ось отрисовывалась с маркой, расположенной на выступе за начальную точку (т1).

Включите опцию Включить марку 2, чтобы ось отрисовывалась с маркой, расположенной на выступе за конечную точку (т2).

Если обе опции отключены, ось будет отрисовываться без марок.

Для круговых осей достаточно включение одной из опций — Включить марку 1 или Включить марку 2, чтобы ось отрисовывалась с маркой.

1.1

Буквы для обозначений

Поле позволяет ввести список букв, используемых для обозначения марок. Буквы располагаются в порядке их использования.

После того как все буквы из списка будут присвоены, автоматически начнут использоваться сдвоенные буквы, взятые по порядку из списка одинарных букв.

1.2
  1. Номер подгруппы, к которой относится настраиваемый параметр. Параметры объединены в группы и подгруппы по их действию на объекты текущего документа, см. раздел 9.2.1.1.

После завершения настройки нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.2.6.14.23. Координационные оси — Параметры

Настройка параметров отрисовки координационных осей для графических документов (как новых, так и текущих) выполняется в диалоге Параметры отрисовки координационной оси, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Обозначения для строительства — Координационные оси — Параметры,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Обозначения для строительства — Координационные оси — Параметры.

Диалог позволяет выбрать умолчательные размеры элементов координационных осей и задать параметры штрихпунктирной линии. Для большего удобства работы в диалог включены поясняющие рисунки.

Табл. 9.2.43. Элементы управления диалога настройки параметров координационных осей

Элемент

Описание настройки

№ подгруппы1

1 - выступ оси за начальную точку, мм

2 - выступ оси за конечную точку, мм

3-4 - смещение излома, %

5 - пунктир

6 - промежуток

Группа полей позволяет ввести вручную или задать с помощью счетчика значения параметров координационных осей.

2.2

7 - штрих

Группа элементов позволяет выбрать вариант определения длины штриха при его отрисовке.

Чтобы длина штриха определялась автоматически, включите опцию Автоопределение длины. В этом случае производится автоматическое вычисление такой длины штриха, при которой в начальной и конечной точках оси будет находиться штрих, а не пунктир или промежуток.

Чтобы длина штриха не превышала некоторого заданного значения, включите опцию Длина не более, мм. Станет доступным поле ввода длины штриха. Введите максимальную длину штриха или задайте ее с помощью счетчика.

2.2
  1. Номер подгруппы, к которой относится настраиваемый параметр. Параметры объединены в группы и подгруппы по их действию на объекты текущего документа, см. раздел 9.2.1.1.

После завершения настройки нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.2.6.14.24. Координационные оси — Указатель ориентации

Настройка параметров отрисовки указателей ориентации координационных осей для графических документов (как новых, так и текущих) выполняется в диалоге Параметры отрисовки указателя ориентации, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Обозначения для строительства — Координационные оси — Указатель ориентации,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Обозначения для строительства — Координационные оси — Указатель ориентации.

Диалог позволяет настроить размеры и вид стрелок указателей ориентации. Для большего удобства работы в диалог включены поясняющие рисунки.

Табл. 9.2.44. Элементы управления диалога настройки указателя ориентации
Элемент | Описание настройки | № подгруппы1
1 - длина, мм | Поле позволяет ввести или задать с помощью счетчика длину указателя. | 2.2
2 - длина стрелки, мм | Поле позволяет ввести или выбрать из списка значение длины стрелки указателя. Введенное вручную значение добавляется в список и сохраняется в течение сеанса работы КОМПАС-3D. | 1.1
3 - угол стрелки, град | Поле позволяет ввести или выбрать из списка значение угла стрелки указателя. Введенное вручную значение добавляется в список и сохраняется в течение сеанса работы КОМПАС-3D. | 1.1
4 - зазор, мм | Поле позволяет ввести или задать с помощью счетчика значение зазора между указателем и обозначением марки. | 1.1
Стрелки | Группа элементов позволяет выбрать вид стрелки указателя. Для выбора варианта отрисовки включите нужную опцию — Стрелка, Стрелка закрытая или Стрелка открытая. Чтобы стрелка зачернялась, включите опцию Зачернять. Если данная опция отключена, стрелки отрисовываются линиями. Настройка зачернения распространяется на варианты отрисовки Стрелка и Стрелка закрытая. Изменение состояния опции отражается на примере стрелки в поле Пример. | 1.1
  1. Номер подгруппы, к которой относится настраиваемый параметр. Параметры объединены в группы и подгруппы по их действию на объекты текущего документа, см. раздел 9.2.1.1.

После завершения настройки отрисовки указателей ориентации нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.2.6.14.25. Координационные оси — Текст

Настройка параметров текста марок координационных осей для графических документов (как новых, так и текущих) выполняется в диалоге Параметры текста марки, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Обозначения для строительства — Координационные оси — Текст,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Обозначения для строительства — Координационные оси — Текст.

Работа в аналогичном диалоге описана в разделе 9.2.6.10.8.


9.2.6.15. Текст на чертеже

Настройка параметров отступов абзацев текста на чертеже для графических документов (как новых, так и текущих) выполняется в диалоге Параметры текста на чертеже, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Текст на чертеже,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Текст на чертеже.

Табл. 9.2.45. Элементы управления диалога настройки текста на чертеже
Элемент | Описание настройки
Шаг строк, мм | Поле для ввода расстояния между строками текста в абзаце. Изменение шага строк позволяет сохранять пропорциональность расстояний между строками, набранными шрифтом с различной высотой символов (например, при включении в текст каких-либо сносок, комментариев или примечаний, набранных более мелким по сравнению с основным текстом шрифтом).
Красная строка, мм | Поле для ввода отступа первой строки абзаца. Отступ измеряется от границы текста. При создании нового абзаца курсор автоматически устанавливается в позицию с заданным отступом.
Отступы | Поля для ввода расстояний между левой и правой границами поля ввода и соответствующими границами текста.
Интервал | Поля для задания расстояния между двумя соседними абзацами. Данное расстояние складывается из двух величин — интервала после первого абзаца и интервала перед вторым абзацем. Установка интервалов позволяет выделить абзацы в текстовом документе для их наилучшего восприятия при чтении, а также для привлечения внимания к особо важной информации.
Выравнивание | Опции позволяют выбрать нужный способ выравнивания абзацев (по левой границе, по правой границе, центрирование, выравнивание по двум границам).
Шрифт... | Кнопка для вызова диалога настройки параметров шрифта.
Табуляция... | Кнопка для вызова диалога настройки параметров табуляции.
Параметры списка... | Кнопка для вызова диалога настройки параметров списка. В диалоге задаются параметры нумерации абзацев текста.

Установленные в данном диалоге умолчательные параметры списка используются только при создании новых текстовых объектов в документе.

После завершения настройки нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.2.6.16. Текстовая метка

Настройка параметров текста текстовой метки для графических документов (как новых, так и текущих) выполняется в диалоге Параметры текстовой метки, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Текстовая метка,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Текстовая метка.

Работа в аналогичном диалоге описана в разделе 9.2.6.10.8.


9.2.6.17. Параметры таблицы

В этом разделе:

9.2.6.17.1. Заголовок таблицы

9.2.6.17.2. Ячейка таблицы

9.2.6.17.3. Название таблицы


9.2.6.17.1. Заголовок таблицы

Параметры текста заголовка таблицы для графических документов (как новых, так и текущих) выполняется в диалоге Параметры текста заголовка таблицы, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Заголовок таблицы,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Заголовок таблицы.

Работа в аналогичном диалоге описана в разделе 9.2.4.4.


9.2.6.17.2. Ячейка таблицы

Параметры текста ячейки таблицы для графических документов (как новых, так и текущих) выполняется в диалоге Параметры текста ячейки таблицы, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Ячейка таблицы,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Ячейка таблицы.

Работа в аналогичном диалоге описана в разделе 9.2.4.4.


9.2.6.17.3. Название таблицы

Настройка параметров названия таблицы на листе для графических документов (как новых, так и текущих) выполняется в диалоге Параметры текста названия таблицы, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Параметры таблицы — Название таблицы,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Параметры таблицы — Название таблицы.

Диалог позволяет настроить умолчательные параметры текста названия таблицы (в том числе для неассоциативного отчета) и расстояние от таблицы до названия (о названиях таблиц см. раздел 3.4.2.4).

Аналогичные параметры для ассоциативных таблиц задаются при настройке отчетов (см. раздел 9.2.6.24.3).

Табл. 9.2.46. Элементы управления диалога настройки названия таблицы
Элемент | Описание настройки
Шаг строк, мм | Поле позволяет задать расстояние между строками текста.
Красная строка, мм | Поле позволяет задать величину отступа вправо от границы абзаца в его первой строке.
Шрифт... | Кнопка для вызова диалога настройки параметров шрифта.
Табуляция... | Кнопка для вызова диалога настройки параметров табуляции.
Отступы | Группа полей позволяет установить величины (в миллиметрах) абзацных отступов слева и справа. Границами абзацев названия таблицы являются вертикальные линии, на которых лежат ее правая и левая границы. От этих линий отсчитываются отступы слева, справа и отступ красной строки. Другими словами, максимальная ширина абзаца названия равна ширине таблицы.
Интервал | Группа полей позволяет установить величины (в миллиметрах) интервалов перед абзацем и после абзаца.
Выравнивание | Группа полей позволяет выбрать нужный способ выравнивания абзацев (по левой границе, по правой границе, центрирование, выравнивание по двум границам).
Расстояние до таблицы, мм | Поле позволяет задать расстояние между названием и верхней границей таблицы.

После завершения настройки нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.2.6.18. Перекрывающиеся объекты

Настройка отображения перекрывающихся объектов для графических документов (как новых, так и текущих) выполняется в диалоге Отображение перекрывающихся объектов, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Перекрывающиеся объекты,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Перекрывающиеся объекты.

Диалог позволяет включить или отключить очистку фона — автоматическое прерывание штриховок и линий при пересечении их со следующими объектами:

– текст на чертеже,

– стрелки и/или надписи в составе:

• размеров,

• обозначений шероховатости,

• обозначений баз,

• линий-выносок,

• обозначений клеймения,

• обозначений маркировки,

• обозначений изменений,

• обозначений позиций,

• допуска формы,

• обозначений линий разреза,

• обозначений стрелок взгляда,

• обозначений выносных элементов.

При включенном прерывании вы можете:

– включить игнорирование надписей, состоящих только из пробелов, т.е. отменить очистку фона под надписями, которые не содержат других символов, кроме пробелов,

– задать величину зазора, т.е. определить ширину поля вокруг перечисленных объектов, внутри которого не будут отображаться перекрываемые объекты.

Установленная величина зазора не влияет на габариты очищаемого поля вокруг текстов. Эти габариты определяются системой автоматически. Они пропорциональны высоте символов текста.

После завершения настройки нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.

Настройка, произведенная в данном диалоге, будет использоваться по умолчанию. При необходимости для каждого из вышеназванных объектов можно включить или отключить очистку фона, вызвав одноименную команду из контекстного меню или из меню Сервис.


9.2.6.19. Параметры документа

В этом разделе:

9.2.6.19.1. Вид

9.2.6.19.2. Основная надпись

9.2.6.19.3. Нумерация листов

9.2.6.19.4. Разбиение на зоны

9.2.6.19.5. Технические требования — Текст

9.2.6.19.6. Технические требования — Параметры

9.2.6.19.7. Неуказанная шероховатость — Текст

9.2.6.19.8. Неуказанная шероховатость — Синхронизация

9.2.6.19.9. Название спецификации на листе


9.2.6.19.1. Вид

Если в большинстве создаваемых ассоциативных видов отображается один и тот же набор объектов и используются одни и те же параметры отрисовки, выполнение настройки объектов, элементов оформлений и линий для каждого вида нерационально. В этом случае вы можете настроить текущий, а также все будущие документы таким образом, чтобы в их ассоциативных видах по умолчанию отображались нужные объекты и нужные линии. Для этого используется диалог Параметры нового вида, вызываемый командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Параметры документа — Вид,

– для текущего документа — Сервис — Параметры... — Текущий чертеж — Параметры документа — Вид.

Табл. 9.2.47. Элементы управления диалога настройки параметров видов

Элемент

Описание настройки

Вкладка Параметры

Позволяет настроить умолчательные параметры создания видов чертежа. После создания вида управление отображением компонентов производится с помощью команд Скрыть и Показать из контекстного меню этих компонентов в Дереве чертежа.

Масштаб

Введите в поля масштаб, который будет по умолчанию использоваться при создании Произвольного и Стандартных ассоциативных видов, а также при создании всех неассоциативных видов. Масштаб может быть задан в виде отношения любых чисел. Можно также выбрать масштаб вида из стандартного ряда. Для этого нажмите кнопку, расположенную между полями ввода масштаба. Из появившегося меню выберите нужный масштаб.

Создавать новый вид

Опция присутствует только в диалоге настройки новых чертежей. Ее включение означает, что при создании нового чертежа в нем автоматически будет создаваться новый вид с заданным масштабом. Этому виду будет присвоен номер 1, имя — Вид 1. Начало координат будет располагаться в точке 0,0 абсолютной системы координат, угол поворота вида — 0 градусов. Масштаб созданного вида будет передан в соответствующую ячейку основной надписи нового чертежа.

Вне зависимости от состояния опции Создавать новый вид при создании нового чертежа в нем автоматически формируется системный вид.

Создавать ссылку на масштаб вида в основной надписи

Включите эту опцию, чтобы в ячейку Масштаб основной надписи чертежа была вставлена ссылка на масштаб первого созданного пользователем вида.

Опция работает, только если в чертеже нет других видов, кроме системного.

При необходимости вы можете создать ссылку вручную, либо откорректировать имеющуюся ссылку, указав другой вид-источник значения масштаба.

Передаваемые компоненты

Группа опций, позволяющая указать, должны ли скрытые и библиотечные компоненты по умолчанию отображаться в следующих ассоциативных видах:

– Стандартные,

– Произвольный,

– Проекционный,

– Вид по стрелке,

– Разрез/сечение 1 .

В остальных ассоциативных видах по умолчанию отображаются те же компоненты, что и в их опорных видах.

Управление отображением компонентов в уже созданном ассоциативном виде производится с помощью команд Скрыть и Показать из контекстного меню этих компонентов в Дереве чертежа.

Проекционный метод

Группа опций позволяет выбрать проекционный метод. Проекционный метод определяет схему расположения на чертеже видов, создаваемых командой Стандартные виды.

– Если включена опция Проекция по первому углу, то применяется схема расположения видов, показанная на рис 3.7.8, а.

– Если включена опция Проекция по третьему углу, то применяется схема расположения видов, показанная на рис 3.7.8, б.

Выбор проекционного метода влияет также на изображение модели в виде, полученном с помощью команды Проекционный вид.

Вкладка Линии

Позволяет настроить отрисовку ассоциативных видов чертежа.

В дальнейшем, при настройке параметров конкретного ассоциативного вида, параметры отрисовки линий можно изменить на вкладке Линии Панели свойств.

Видимые линии,

Невидимые линии,

Линии переходов,

Линии сгиба

Кнопки позволяют задать умолчательный стиль отрисовки соответствующих линий в ассоциативном виде. Образец линии отображается в поле справа от кнопки.

Передавать в чертеж

Опция управляет передачей в чертеж линий невидимого контура.

Если эта опция включена, то при формировании нового ассоциативного вида в него по умолчанию будут включены линии невидимого контура.

Если опция Передавать в чертеж отключена, то по умолчанию вид будет формироваться без линий невидимого контура. Опция Показывать в группе Невидимые линии в этом случае недоступна: раз в виде нет невидимых линий, то и показать их нельзя.

Рекомендуется отключать передачу в чертеж невидимых линий при построении ассоциативных видов сборок, содержащих более 1000 компонентов.

Показывать

Опция управляет отображением соответствующих линий в ассоциативном виде. Эта настройка доступна для всех линий, кроме видимых.

Вкладка Объекты

Позволяет настроить умолчательное отображение в ассоциативных видах объектов модели.

В дальнейшем, при настройке параметров конкретного вида, включать и отключать отображение объектов можно на вкладке Объекты Панели свойств.

Передаваемые объекты

Список объектов, изображения которых могут передаваться из модели в чертеж.

Включите опции у названий объектов, которые должны по умолчанию изображаться в чертеже при построении Произвольного и Стандартных ассоциативных видов.

При создании остальных ассоциативных видов в них передаются те объекты, которые изображены в их опорных видах.

После создания вида набор переданных в него объектов можно изменить.

Все объекты

Опция позволяет включить или отключить сразу все опции списка объектов. Если включены не все опции списка, опция Все объекты отображается на сером фоне. Щелчок по опции в таком состоянии отключит ее, следующий — включит.

Отображать скрытые объекты

Опция управляет отображением в ассоциативных видах объектов, показ которых в модели отключен.

Вкладка Элементы оформления

Позволяет настроить умолчательное отображение в ассоциативных видах элементов оформления модели — изображений резьбы, размеров и обозначений.

В дальнейшем, при настройке параметров конкретного вида, включать и отключать отображение элементов оформления можно на вкладке Объекты Панели свойств. Кроме того, можно скрыть отдельные обозначения.

Передаваемые обозначения

Список элементов оформления, которые могут передаваться из модели в чертеж.

Включите опции у названий обозначений, которые должны по умолчанию передаваться в чертеж при построении ассоциативных видов.

После создания вида набор переданных в него обозначений можно изменить.

Обратите внимание на то, что переданные в чертеж размеры и обозначения могут быть автоматически скрыты — если они скрыты в модели или если на чертеже уже есть хотя бы один видимый экземпляр этого объекта.

Все обозначения

Опция позволяет включить или отключить сразу все опции списка обозначений. Если включены не все опции списка, опция Все обозначения отображается на сером фоне. Щелчок по опции в таком состоянии отключит ее, следующий — включит.

Вкладка Надпись

Позволяет настроить умолчательные параметры надписей над ассоциативными видами исходного и зеркального исполнений (см. раздел 3.7.3.12).

Создавать надписи при вставке ассоциативного вида зеркального исполнения

Опция управляет автоматическим созданием надписей ассоциативных видов при вставке ассоциативного вида зеркального исполнения модели.

При включенной опции надписи создаются, при отключенной нет.

Обратите внимание на то, что данные надписи могут быть добавлены в чертеж только автоматически. Создать их вручную нельзя.

Шаблон надписи

Поле содержит шаблон, в соответствии с которым формируется надпись ассоциативного вида зеркального исполнения модели. Шаблон имеет следующий вид:

#<PartNo> - зеркальное отражение

Остальное - см. #<PartNo|Doc>, где

#<PartNo> — ссылка на обозначение зеркального исполнения модели,

#<PartNo|Doc> — ссылка на обозначение исходного исполнения модели.

Данный шаблон доступен для редактирования.
  1. Набор компонентов, отображающийся в Проекционном виде, Виде по стрелке или на Разрезе/сечении, может отличаться от набора компонентов в опорном виде, если после создания опорного вида была изменена настройка передачи компонентов или если в модели был включен или отключен показ каких-либо компонентов.

После завершения настройки параметров нового вида нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.

Параметры, заданные при настройке текущего чертежа, будут применяться только для вновь создаваемых видов; параметры видов, созданных до изменения настройки, останутся прежними.


9.2.6.19.2. Основная надпись

Настройка параметров синхронизации данных модели и основной надписи чертежа, содержащего ассоциативные виды, выполняется для графических документов (как новых, так и текущих) в диалоге Синхронизация данных основной надписи и модели. Диалог вызывается командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Параметры документа — Основная надпись,

– для текущего документа — Сервис — Параметры... — Текущий чертеж — Параметры документа — Основная надпись.

Настройка единиц измерения массы, произведенная в данном диалоге, распространяется также на неассоциативные чертежи. Выбранная единица учитывается при передаче значения массы между объектом спецификации и подключенным к нему чертежом: если в спецификации и чертеже используются различные единицы измерения массы, то ее значение пересчитывается. Выбор единицы измерения массы для спецификации производится в диалоге настройки отображения величин (см. раздел 9.2.5.1.4).

Табл. 9.2.48. Элементы управления диалога настройки основной надписи

Элемент

Описание настройки

Синхронизировать основную надпись

Опция позволяет включить синхронизацию данных основной надписи активного чертежа и модели (см. раздел 3.7.3.8.1). Если опция отключена, то синхронизация данных не производится.

Вне зависимости от состояния данной опции при вставке в чертеж первого ассоциативного вида модели основная надпись чертежа заполняется данными, взятыми из этой модели.

автоматически

Опция позволяет включить автоматическую синхронизацию данных основной надписи активного чертежа и модели. Автоматическая синхронизация производится при открытии и активизации документа, а также при перестроении изображения в чертеже.

по запросу

Опция позволяет выполнять синхронизацию данных после вызова команды Синхронизировать данные из контекстного меню основной надписи.

синхронизировать значение массы

Включение этой опции означает, что всякий раз при синхронизации значение массы модели будет рассчитано заново и записано в ячейку Масса.

Количество знаков после запятой

Поле позволяет указать, до какого знака требуется округлять рассчитанное значение массы модели.

Единицы измерения массы

Группа опций позволяет выбрать единицы измерения массы: килограммы, граммы или тонны. В поле рядом с единицей измерения вы можете ввести дополнительное обозначение единицы. Этот текст добавляется к значению массы в соответствующей графе основной надписи.

Завершив настройку, нажмите кнопку ОК.

Изменение количества знаков после запятой или единицы измерения, произведенное для текущего чертежа, отразится в его основной надписи.

Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.2.6.19.3. Нумерация листов

Настройка нумерации листов чертежа (только текущего) выполняется в диалоге Нумерация листов, вызываемом командой Сервис — Параметры... — Текущий чертеж — Параметры документа — Нумерация листов.

Работа в диалоге описана в разделе 9.2.5.1.2.


9.2.6.19.4. Разбиение на зоны

Включение и настройка разбиения чертежа (как нового, так и текущего) на зоны производится в диалоге Разбиение листа на зоны, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Параметры документа — Разбиение на зоны,

– для текущего документа — Сервис — Параметры... — Текущий чертеж — Параметры документа — Разбиение на зоны.

Диалог позволяет включить режим разбиения чертежа на зоны, задать размеры этих зон и их обозначения.

Табл. 9.2.49. Элементы управления диалога настройки разбиения чертежа на зоны
Элемент | Описание настройки
Разбивать на зоны | Опция позволяет активизировать разбиение листа на зоны и настроить параметры разбиения. По умолчанию опция отключена и все элементы управления диалога недоступны.
Прямоугольник разбиения... | Кнопка позволяет вызвать диалог задания размеров зон. В полях появившегося диалога введите значения высоты и ширины зон или выберите эти значения из раскрывающихся списков. При разбиении листа на зоны ориентация прямоугольника разбиения игнорируется: сторона листа делится на длину той стороны прямоугольника, которая максимальное количество раз укладывается в длину этой стороны листа.
Отметки | Группа элементов управляет простановкой обозначений зон на листе чертежа и настройкой их параметров.
Использовать | Группа опций позволяет проставлять обозначения зон по вертикали и/или по горизонтали листа чертежа. При включении опций становятся доступными соответствующие им элементы настройки параметров обозначений зон.
Тип текста | Раскрывающийся список позволяет выбрать символы для обозначения зон (арабские или римские цифры, буквы русского или латинского алфавита).
Начинать с | Поле позволяет ввести или задать с помощью счетчика цифру или номер буквы, с которой будет начинаться ряд обозначений.
Направление | Группа опций позволяет выбрать вариант направления простановки обозначений: – снизу вверх, – сверху вниз, – слева направо, – справа налево.
Текст всегда горизонтально | Опция позволяет располагать горизонтально все символы обозначения зон.
Шрифт... | Кнопка позволяет настроить параметры шрифта обозначений зон в стандартном диалоге настройки шрифта.
Тип линии | Раскрывающийся список позволяет выбрать тип линии для отрисовки границ зон.
Ширина поля обозначения зон, мм | Раскрывающийся список позволяет выбрать значение ширины поля обозначения зон (в миллиметрах).
Располагать снаружи внутренней рамки листа | Опция позволяет располагать поле обозначения зон снаружи внутренней рамки листа. Если опция отключена, то поле обозначения зон будет расположено внутри внутренней рамки.

После завершения настройки нажмите кнопку ОК. Параметры разбиения чертежа на зоны изменятся в соответствии с выполненной настройкой.

Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.

Настройка параметров разбиения на зоны хранится в самом чертеже и не изменяется при его передаче на другое рабочее место.


9.2.6.19.5. Технические требования — Текст

Настройка параметров текста (символов и абзацев) технических требований чертежа (как нового, так и текущего) выполняется в диалоге Параметры текста технических требований, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Параметры документа — Технические требования — Текст,

– для текущего документа — Сервис — Параметры... — Текущий чертеж — Параметры документа — Технические требования — Текст.

Диалог позволяет настроить параметры текста.

Табл. 9.2.50. Элементы управления диалога настройки текста технических требований документа
Элемент | Описание настройки
Шаг строк, мм | Поле для ввода расстояния между строками текста в абзаце. Изменение шага строк позволяет сохранять пропорциональность расстояний между строками, набранными шрифтом с различной высотой символов (например, при включении в текст каких-либо сносок, комментариев или примечаний, набранных более мелким по сравнению с основным текстом шрифтом).
Красная строка, мм | Поле для ввода отступа первой строки абзаца. Отступ измеряется от границы текста. При создании нового абзаца курсор автоматически устанавливается в позицию с заданным отступом.
Отступы | Поля для ввода расстояний между левой и правой границами поля ввода и соответствующими границами текста.
Интервал | Поля для задания расстояния между двумя соседними абзацами. Данное расстояние складывается из двух величин — интервала после первого абзаца и интервала перед вторым абзацем. Установка интервалов позволяет выделить абзацы в текстовом документе для их наилучшего восприятия при чтении, а также для привлечения внимания к особо важной информации.
Выравнивание | Опции позволяют выбрать нужный способ выравнивания абзацев (по левой границе, по правой границе, центрирование, выравнивание по двум границам).
Шрифт... | Кнопка для вызова диалога настройки параметров шрифта.
Табуляция... | Кнопка для вызова диалога настройки параметров табуляции.
Параметры списка... | Кнопка для вызова диалога настройки параметров списка. В диалоге задаются параметры нумерации абзацев текста.

После завершения настройки параметров текста технических требований нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.2.6.19.6. Технические требования — Параметры

Настройка параметров технических требований чертежа (как нового, так и текущего) выполняется в диалоге Параметры технических требований, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Параметры документа — Технические требования — Параметры,

– для текущего документа — Сервис — Параметры... — Текущий чертеж — Параметры документа — Технические требования — Параметры.

В диалоге находятся следующие опции:

– Опция Устанавливать нумерацию при создании управляет автонумерацией пунктов технических требований при их вводе. Если она включена, то нумерация абзацев технических требований устанавливается автоматически. Включение или отключение данной опции не влияет на уже существующие в текущем чертеже технические требования.

– Опция Располагать на последних листах документа управляет умолчательным расположением технических требований.

При включенной опции Располагать на последних листах документа страница технических требований автоматически формируется на последнем листе документа. Если объем текста технических требований превышает размер страницы, то формируется новая страница на предыдущем листе. Текст технических требований распределяется между страницами следующим образом.

• Начало технических требований перемещается на страницу предыдущего листа, причем она заполняется целиком.

• Текст, выходящий за пределы этой страницы, размещается на странице технических требований, расположенной на последнем листе.

Вновь вводимые технические требования будут заполнять эту страницу. Если при продолжении ввода технических требований их объем опять превысит размер страницы, автоматически сформируется следующая страница на предыдущем листе и текст технических требований будет перераспределен между страницами аналогично рассмотренному выше. Таким образом при вводе технических требований их начало будет смещаться на предыдущие листы чертежа.

При отключенной опции Располагать на последних листах документа страница технических требований формируется на первом листе чертежа. Если объем текста технических требований превышает размер страницы, автоматически формируется новая страница слева от рамки первого листа. Начало технических требований при этом остается на первом листе чертежа. При последующем вводе технических требований они будут смещаться влево от первого листа чертежа.

Состояние данной опции определяет результат работы команды Авторазмещение технических требований. Включение или отключение опции влияет на расположение технических требований, только если оно не изменялось вручную (см. раздел 3.6.7.2).

– Опция Синхронизировать технические требования управляет автоматической передачей технических требований из модели в чертеж. Если она включена, то при создании ассоциативного вида в чертеж передаются технические требования, заданные в модели, если выключена, то не передаются. Условия передачи технических требований из модели в чертеж и способы их обновления после редактирования описаны в разделе 3.7.3.9.

После завершения настройки параметров технических требований нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.

Настройка параметров технических требований хранится в самом чертеже и не изменяется при его передаче на другое рабочее место.


9.2.6.19.7. Неуказанная шероховатость — Текст

Задание параметров текста знака неуказанной шероховатости при его создании невозможно. Эти параметры определяются настройкой документа (как нового, так и текущего). Данная настройка выполняется в диалоге Параметры текста неуказанной шероховатости, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Параметры документа — Неуказанная шероховатость —Текст,

– для текущего документа — Сервис — Параметры... — Текущий чертеж — Параметры документа — Неуказанная шероховатость — Текст.

Работа в аналогичном диалоге описана в разделе 9.2.6.10.8.

После завершения настройки параметров и выхода из диалога отрисовка текста неуказанной шероховатости изменится в соответствии с выполненной настройкой.

Настройка параметров текста неуказанной шероховатости хранится в самом чертеже и не изменяется при его передаче на другое рабочее место.


9.2.6.19.8. Неуказанная шероховатость — Синхронизация

Настройка параметров синхронизации неуказанной шероховатости в модели и в чертеже, содержащем ассоциативные виды, выполняется для документов (как новых, так и текущих) в диалоге Синхронизация неуказанной шероховатости, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Параметры документа — Неуказанная шероховатость — Синхронизация.

– для текущих документов — Сервис — Параметры... — Текущий чертеж — Параметры документа — Неуказанная шероховатость — Синхронизация.

Диалог позволяет настроить параметры синхронизации неуказанной шероховатости.

Табл. 9.2.51. Элементы управления диалога синхронизации неуказанной шероховатости
Элемент | Описание настройки
Синхронизировать неуказанную шероховатость | Опция управляет синхронизацией неуказанной шероховатости в модели и в чертеже, содержащем ассоциативные виды. Если опция отключена, то синхронизация данных не производится.
автоматически | Если выбран этот вариант, то синхронизация производится автоматически при открытии и активизации документа, а также при перестроении изображения в чертеже.
по запросу | Если выбран этот вариант, то синхронизация производится вручную. Для этого нужно вызвать команду Синхронизировать из контекстного меню знака неуказанной шероховатости на чертеже.

Завершив настройку, нажмите кнопку ОК.

Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.

При создании ассоциативного чертежа передача неуказанной шероховатости из модели в чертеж происходит независимо от состояния опции Синхронизировать неуказанную шероховатость.


9.2.6.19.9. Название спецификации на листе

Настройка параметров названия спецификации на листе для чертежей (как новых, так и текущих) выполняется в диалоге Параметры названия спецификации на листе, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Параметры документа — Название спецификации на листе,

– для текущего документа — Сервис — Параметры... — Текущий чертеж — Параметры документа — Название спецификации на листе.

Диалог позволяет настроить умолчательные параметры текста названия спецификации (см. раздел 6.2.6.12.3) и расстояние от таблицы спецификации до названия.

Табл. 9.2.52. Элементы управления диалога настройки названия спецификации на листе
Элемент | Описание настройки
Шаг строк, мм | Поле позволяет задать расстояние между строками текста.
Красная строка, мм | Поле позволяет задать величину отступа вправо от границы абзаца в его первой строке.
Шрифт... | Кнопка для вызова диалога настройки параметров шрифта.
Табуляция... | Кнопка для вызова диалога настройки параметров табуляции.
Отступы | Группа полей позволяет установить величины (в миллиметрах) абзацных отступов слева и справа. Границами абзацев названия спецификации являются вертикальные линии, на которых лежат правая и левая границы таблицы спецификации. От этих линий отсчитываются отступы слева, справа и отступ красной строки. Другими словами, максимальная ширина абзаца названия равна ширине таблицы спецификации.
Интервал | Группа полей позволяет установить величины (в миллиметрах) интервалов перед абзацем и после абзаца.
Выравнивание | Группа полей позволяет выбрать нужный способ выравнивания абзацев (по левой границе, по правой границе, центрирование, выравнивание по двум границам).
Расстояние до спецификации, мм | Поле позволяет задать расстояние между названием спецификации и верхней границей таблицы спецификации.

После завершения настройки нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.2.6.20. Параметры первого листа

В этом разделе:

9.2.6.20.1. Формат

9.2.6.20.2. Оформление

9.2.6.20.3. Таблица изменений


9.2.6.20.1. Формат

Вы можете выбрать формат первого листа для графических документов (как новых, так и текущих) из стандартного ряда или задать произвольные размеры листа. Для этого используется диалог Формат листа, вызываемый одним из следующих способов:

– для новых документов — командой Сервис — Параметры — Новые документы — Графический документ — Параметры первого листа — Формат,

– для текущего документа — командой Сервис — Параметры — Текущий чертеж — Параметры первого листа — Формат или командой Формат контекстного меню листа в Списке листов, видов и слоев диалога Менеджер документа (см. раздел 3.6.6.2).

Работа в диалоге Формат листа описана в разделе 9.1.12.3.1.


9.2.6.20.2. Оформление

Выбор оформления первого листа для графических документов (как новых, так и текущих) выполняется в диалоге Оформление, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Параметры первого листа — Оформление,

– для текущего документа — Сервис — Параметры... — Текущий чертеж — Параметры первого листа — Оформление.

Работа в диалоге описана в разделе 9.2.4.2.2.


9.2.6.20.3. Таблица изменений

Настройка таблицы изменений для первого листа графических документов (как новых, так и текущих) выполняется в диалоге Таблица изменений, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Параметры первого листа — Таблица изменений,

– для текущего документа — Сервис — Параметры... — Текущий чертеж — Параметры первого листа — Таблица изменений.

Аналогичный диалог используется при настройке таблиц изменений для новых листов графических документов.

Диалог содержит одну опцию — Разбивать на блоки. При отключенной опции все объекты таблицы изменений располагаются друг над другом, составляя единый блок. Чтобы разделить таблицу изменений на блоки, включите эту опцию.

Размер (количество строк) блоков определяется настройкой оформления текущего документа.

После завершения настройки нажмите кнопку ОК.

При настройке текущего документа произведенные изменения будут отображаться на экране. При настройке новых документов изменения вступят в силу при их создании.

Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.2.6.21. Параметры новых листов

В этом разделе:

9.2.6.21.1. Формат

9.2.6.21.2. Оформление

9.2.6.21.3. Таблица изменений


9.2.6.21.1. Формат

Вы можете выбрать формат новых листов графических документов (как новых, так и текущих) из стандартного ряда или задать произвольные размеры листов. Для этого используется диалог Формат листа, вызываемый командой:

– для новых документов — Сервис — Параметры — Новые документы — Графический документ — Параметры новых листов — Формат,

– для текущего документа — Сервис — Параметры — Текущий чертеж — Параметры новых листов — Формат.

Работа в диалоге описана в разделе 9.1.12.3.1.


9.2.6.21.2. Оформление

Выбор оформления новых листов графических документов (как новых, так и текущих) выполняется в диалоге Оформление, вызываемом командой:

– для новых документов — Сервис — Параметры — Новые документы — Графический документ — Параметры новых листов — Оформление,

– для текущего документа — Сервис — Параметры — Текущий чертеж — Параметры новых листов — Оформление.

Работа в диалоге описана в разделе 9.2.4.2.2.


9.2.6.21.3. Таблица изменений

Настройка таблиц изменений для новых листов графических документов (как новых, так и текущих) выполняется в диалоге Таблица изменений, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Параметры новых листов — Таблица изменений,

– для текущего документа — Сервис — Параметры... — Текущий чертеж — Параметры новых листов — Таблица изменений.

Работа в диалоге описана в разделе 9.2.6.20.3.


9.2.6.22. Параметризация

Настройка использования параметрического режима системы КОМПАС-3D для графических документов (как новых, так и текущих) выполняется в диалоге Управление параметризацией, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Параметризация,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Параметризация.

Аналогичный диалог используется для управления параметризацией при работе с эскизами.

Табл. 9.2.53. Элементы управления диалога настройки параметрического режима

Элемент

Описание настройки

Ассоциировать при вводе:

Список содержит названия типов объектов.

Включите опции рядом с названиями типов объектов, которые должны создаваться как ассоциативные (связанные с другими объектами) при их построении. При включенной ассоциативности размеров ассоциативные диаметральные, радиальные и угловые размеры будут проставляться только к тем кривым, с которыми можно осуществить ассоциативность. Невозможна простановка ассоциативных размеров к дугам и отрезкам в контуре или в макроэлементе, к сторонам прямоугольников и многоугольников.

Параметризовать:

Список содержит названия типов связей между объектами.

Включите опции рядом с названиями типов связей между объектами, которые должны быть автоматически параметризованы при вводе и редактировании изображения.

Все

Опция позволяет включить или отключить ассоциирование всех объектов (параметризацию всех типов связей). Если включено ассоциирование не всех объектов (параметризация не всех типов связей), опция отображается на сером фоне. Щелчок по опции в таком состоянии отключит ее, следующий — включит.

Фиксировать
размеры

Включение опции означает, что ассоциативные размеры при создании будут автоматически фиксироваться и связываться с переменной (управляющие размеры). При отключенной опции ассоциативные размеры создаются информационными и без переменных. Об управляющих и информационных размерах см. раздел 7.2.1.10.

Опция доступна, если в группе Ассоциировать при вводе включена опция Размеры.

Фиксировать длину автоосевой

Включение опции означает, что на автоосевую — в случае, если хотя бы одна ее точка останется свободна от ограничений — дополнительно будет накладываться ограничение фиксированная длина. Если опция отключена, то это ограничение не накладывается. Подробнее об автоматически накладываемых на автоосевую ограничениях см. раздел 7.2.7.5.

Запретить все

Опция позволяет включать и отключать параметрический режим в документе.

– Если опция отключена, то параметрический режим включен и в данном диалоге доступны опции его настройки.

– Если опция включена, то параметрический режим отключен и опции его настройки недоступны.

Включение и отключение параметрического режима не изменяет его настройку.

Включение и отключение параметрического режима возможно также при помощи кнопки Параметрический режим на панели Текущее состояние.

Включение параметрического режима не имеет смысла, если отключены все опции в группах Ассоциировать при вводе: и Параметризовать:. Связи и ограничения в этом случае не будут накладываться, т.е. построения будут выполняться так, как если бы параметрический режим был отключен.

После завершения настройки нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.

Настройка параметрического режима хранится в самом документе и не изменяется при его передаче на другое рабочее место.


9.2.6.23. Нумерация

Для настройки параметров нумерации объектов в группах нумерации, а также добавления/изменения/удаления пользовательских групп используются диалоги Параметры системных групп нумерации и Параметры пользовательских групп нумерации.

Диалоги вызываются с помощью команд Сервис — Параметры... — Текущий чертеж/фрагмент — Нумерация — Системные группы и Сервис — Параметры... — Текущий чертеж/фрагмент — Нумерация — Пользовательские группы соответственно.

Для быстрого вызова диалогов используется кнопка Параметры групп нумерации, расположенная на инструментальной панели окна Нумерация или на Панели специального управления при работе команды Знак изменения.

Диалог Параметры системных групп нумерации

Диалог содержит системную группу #Нумерация обозначений изменений и перечень соответствующих ей параметров нумерации. Значения параметров можно изменить, задав их вручную или выбрав из предопределенных списков. Перечень параметров и порядок задания их значений приведены в таблице 9.2.54.

Табл. 9.2.54. Параметры нумерации

Наименование

Описание настройки

Тип номера

Номера объектов в группе могут быть представлены числами от 1 до 2 147 483 647 или произвольно заданными символами.

По умолчанию для нумерации используются числа. При этом значением параметра является 1,2,3,4,5....

Чтобы использовать символы для задания номеров, щелкните мышью в поле значения параметра и выберите из раскрывающегося списка вариант Заданные символы. Перечень используемых символов задается в поле Набор символов.

Разрядность номеров

Поле присутствует в списке при числовой нумерации объектов (параметр Тип номера имеет значение 1,2,3,4,5...).

Определяет минимальное количество разрядов номера объекта.

Разрядность может быть задана натуральным числом от 1 до 10.

Если разрядность номера объекта меньше заданной, то перед номером добавляются нули.

Если разрядность номера объекта больше заданной, номер остается без изменений.

Набор символов

Поле присутствует в списке при символьной нумерации объектов (параметр Тип номера имеет значение Заданные символы).

Определяет, какие символы и в каком порядке будут присваиваться объектам, добавляемым в группу нумерации.

По умолчанию набор символов состоит из букв русского алфавита. Вы можете вводить произвольные символы в набор. Повторение символов не допускается. Общее количество символов в наборе не более 64.

Количество объектов в группе может превышать количество заданных символов. В этом случае для нумерации объектов сначала используются заданные символы, а потом эти же символы с номером, например, А1, Б1, В1,..., А2, Б2, В2 и т.д.

Обратите внимание на то, что при переходе от символьной нумерации к числовой набор заданных символов возвращается к умолчательному виду.

Текст перед номером

Позволяет ввести строку символов, которая должна отображаться перед номером объекта. Количество символов в строке не более 256.

Текст после номера

Позволяет ввести строку символов, которая должна отображаться после номера объекта. Количество символов в строке не более 256.

Начинать с

Позволяет ввести число или порядковый номер символа (при символьной нумерации), с которого будет начинаться нумерация объектов в группе.

Например, набор символов для нумерации состоит из букв русского алфавита А, Б, В и т.п. В поле Начинать с введем значение 3. При этом нумерация объектов в группе будет начинаться с буквы В.

При изменении значения параметра Начинать с номера объектов группы автоматически изменяются. Исключение составляет тот случай, когда автоперестроение нумерации отключено (параметр Автоперестроение нумерации имеет значение Нет) и номер уменьшается. При этом номера объектов не изменяются, в списке перед первым объектом появляются пустые строки, содержащие свободные номера. Первая пустая строка в списке содержит начальный номер.

Автоперестроение нумерации

Позволяет управлять автоматическим перестроением номеров объектов группы.

Щелкните мышью в поле значения параметра и выберите из раскрывающегося списка нужное значение.

Если параметр имеет значение Да, то нумерация начинается с начального номера (начальный номер задается в поле Начинать с). При удалении объекта из группы нумерации номера объектов, находящихся в списке после удаляемого, автоматически изменяются.

Если параметр имеет значение Нет, то нумерация может начинаться с произвольного номера, большего, чем начальный. Номера объектов группы не изменяются при удалении объекта, в списке остаются строки, содержащие свободные номера.

Обратите внимание на то, что при переходе к значению Да строки, содержащие свободные номера, автоматически удаляются.

При необходимости вы можете вернуться к умолчательным значениям параметров нумерации. Для этого выделите наименование группы и нажмите кнопку Сбросить.

Диалог Параметры пользовательских групп нумерации

Позволяет создать нужные группы нумерации и настроить параметры нумерации для каждой из них.

По умолчанию в диалоге не содержится ни одной пользовательской группы.

Чтобы создать группу, нажмите кнопку Создать. Умолчательное имя и параметры созданной группы будут отображены в списке групп диалога. На экране появится диалог задания имени группы, позволяющий изменить умолчательное имя. Внесите необходимые изменения и нажмите кнопку ОК. Кнопка Отмена позволяет закрыть диалог без изменения имени группы. Имя группы должно быть уникальным в пределах документа. Его длина не более 256 символов.

В дальнейшем вы можете изменить имя группы или удалить группу.

Для изменения имени выделите его и нажмите клавишу <F2>. На экране появится диалог задания имени группы. Произведите необходимые изменения и нажмите кнопку ОК. Кнопка Отмена позволяет закрыть диалог, отказавшись от изменения имени группы.

Чтобы удалить группу, выделите ее имя и нажмите кнопку Удалить. Если группа содержит объекты, то на экране появится запрос на подтверждение удаления. В случае удаления непустой группы ссылки на номера объектов, содержащихся в этой группе, становятся нерабочими.

Пользовательской группе соответствует такой же набор параметров нумерации, что и системной группе. Перечень параметров и порядок задания их значений приведены в таблице 9.2.54.

При создании группы ее параметрам присваиваются умолчательные значения. Чтобы новая группа имела такие же параметры нумерации, как уже существующая, выделите имя этой группы перед созданием новой.

После завершения настройки нажмите кнопку ОК. Изменения в составе групп нумерации будут переданы в список групп, отображаемый в окне Нумерация.

Список групп нумерации отображается не только в окне Нумерация, но и на Панели свойств при работе команд создания нумеруемых объектов (см. раздел 3.10.1.1).

Также настроечный диалог может быть вызван в процессе работы команды Знак изменения. В этом случае изменения в составе групп не будут переданы в список сразу после закрытия диалога, а будут применены только изменения в настройках параметров нумерации групп, уже имеющихся в списке. Чтобы привести список в соответствие со всеми произведенными изменениями, завершите работу команды Знак изменения и вызовите ее повторно.

Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.2.6.24. Параметры таблицы отчета

В этом разделе:

9.2.6.24.1. Заголовок

9.2.6.24.2. Ячейка

9.2.6.24.3. Название таблицы


9.2.6.24.1. Заголовок

Параметры текста заголовка таблицы отчета для графических документов (как новых, так и текущих) настраиваются в диалоге Параметры текста заголовка таблицы, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Параметры таблицы отчета — Заголовок,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Параметры таблицы отчета — Заголовок.

Работа в аналогичном диалоге описана в разделе 9.2.4.4.

Настройки используются при размещении отчета в графическом документе и при отображении отчета по графическому документу в Окне подготовки данных.


9.2.6.24.2. Ячейка

Параметры текста ячейки таблицы отчета для графических документов (как новых, так и текущих) настраиваются в диалоге Параметры текста ячейки таблицы, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Параметры таблицы отчета — Ячейка,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Параметры таблицы отчета — Ячейка.

Работа в аналогичном диалоге описана в разделе 9.2.4.4.

Настройки используются при размещении отчета в графическом документе и при отображении отчета по графическому документу в Окне подготовки данных.


9.2.6.24.3. Название таблицы

Настройка параметров названия таблицы ассоциативного отчета на листе для графических документов (как новых, так и текущих) выполняется в диалоге Параметры текста названия таблицы, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Графический документ — Параметры таблицы отчета — Название таблицы,

– для текущего документа — Сервис — Параметры... — Текущий чертеж/фрагмент — Параметры таблицы отчета — Название таблицы.

Диалог позволяет настроить умолчательные параметры текста названия таблицы ассоциативного отчета и расстояние от таблицы до названия (о названиях таблиц см. раздел 3.4.2.4).

Работа в аналогичном диалоге описана в разделе 9.2.6.17.3.

Названия неассоциативных отчетов подчиняются настройке для названий простых таблиц (см. указанный раздел).


9.2.7. Модель

9.2. Параметры новых и текущего документов

9.2.7. Модель

В этом разделе:

9.2.7.1. Шрифт по умолчанию

9.2.7.2. Размеры

9.2.7.2.1. Общие настройки

9.2.7.2.2. Параметры

9.2.7.2.3. Стрелки и засечки

9.2.7.2.4. Фильтр стрелок — Линейные размеры

9.2.7.2.5. Фильтр стрелок — Размеры окружностей и дуг

9.2.7.2.6. Фильтр стрелок — Угловые размеры

9.2.7.2.7. Надпись

9.2.7.2.8. Положение надписи

9.2.7.2.9. Допуски и предельные значения — Параметры

9.2.7.2.10. Допуски и предельные значения — Допуски по умолчанию

9.2.7.2.11. Точности

9.2.7.3. Условные обозначения

9.2.7.3.1. Линия-выноска — Параметры

9.2.7.3.2. Линия-выноска — Стрелки и засечки

9.2.7.3.3. Линия-выноска — Фильтр стрелок

9.2.7.3.4. Линия-выноска — Текст над/под/за полкой

9.2.7.3.5. Линия-выноска — Наклонный текст

9.2.7.3.6. Линия-выноска — Размеры знаков

9.2.7.3.7. Обозначение позиции — Параметры

9.2.7.3.8. Обозначение позиции — Параметры формы

9.2.7.3.9. Обозначение позиции — Стрелки и засечки

9.2.7.3.10. Обозначение позиции — Фильтр стрелок

9.2.7.3.11. Обозначение позиции — Текст обозначения позиций

9.2.7.3.12. Шероховатость

9.2.7.3.13. Отклонения формы и база

9.2.7.3.14. Автосортировка

9.2.7.4. Деталь

9.2.7.4.1. Свойства

9.2.7.4.2. Настройка списка свойств

9.2.7.4.3. Номера новых исполнений

9.2.7.4.4. Цвет

9.2.7.4.5. Свойства абсолютной СК

9.2.7.4.6. Свойства локальных СК

9.2.7.4.7. Свойства объектов

9.2.7.4.8. Свойства листового тела

9.2.7.4.9. Общие допуски

9.2.7.4.10. Неуказанная шероховатость

9.2.7.4.11. Точность отрисовки и МЦХ

9.2.7.4.12. Дерево модели — Общие настройки отображения

9.2.7.4.13. Дерево модели — Структура

9.2.7.4.14. Дерево модели — Формат отображения имени

9.2.7.4.15. Зоны

9.2.7.4.16. Единицы задания МЦХ

9.2.7.5. Сборка

9.2.7.5.1. Свойства

9.2.7.5.2. Настройка списка свойств

9.2.7.5.3. Номера новых исполнений

9.2.7.5.4. Цвет

9.2.7.5.5. Свойства абсолютной СК

9.2.7.5.6. Свойства локальных СК

9.2.7.5.7. Свойства объектов

9.2.7.5.8. Общие допуски

9.2.7.5.9. Неуказанная шероховатость

9.2.7.5.10. Точность отрисовки и МЦХ

9.2.7.5.11. Дерево модели

9.2.7.5.12. Зоны

9.2.7.5.13. Единицы задания МЦХ

9.2.7.6. Технологическая сборка

9.2.7.6.1. Свойства

9.2.7.6.2. Настройка списка свойств

9.2.7.6.3. Номера новых исполнений

9.2.7.6.4. Цвет

9.2.7.6.5. Свойства абсолютной СК

9.2.7.6.6. Свойства локальных СК

9.2.7.6.7. Свойства объектов

9.2.7.6.8. Общие допуски

9.2.7.6.9. Неуказанная шероховатость

9.2.7.6.10. Точность отрисовки и МЦХ

9.2.7.6.11. Дерево модели

9.2.7.6.12. Единицы задания МЦХ

9.2.7.7. Эскиз

9.2.7.7.1. Параметризация

9.2.7.8. Параметры таблицы отчета

9.2.7.8.1. Заголовок

9.2.7.8.2. Ячейка

9.2.7.9. Технические требования

9.2.7.10. Неуказанная шероховатость


9.2.7.1. Шрифт по умолчанию

Выбор шрифта, который будет по умолчанию использоваться в моделях (как новых, так и текущих), выполняется в диалоге Шрифт по умолчанию, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Модель — Шрифт по умолчанию,

– для текущего документа — Сервис — Параметры... — Текущая деталь/сборка/Текущий эскиз — Шрифт по умолчанию.

Работа в диалоге описана в разделе 9.2.4.1.


9.2.7.2. Размеры

В этом разделе:

9.2.7.2.1. Общие настройки

9.2.7.2.2. Параметры

9.2.7.2.3. Стрелки и засечки

9.2.7.2.4. Фильтр стрелок — Линейные размеры

9.2.7.2.5. Фильтр стрелок — Размеры окружностей и дуг

9.2.7.2.6. Фильтр стрелок — Угловые размеры

9.2.7.2.7. Надпись

9.2.7.2.8. Положение надписи

9.2.7.2.9. Допуски и предельные значения — Параметры

9.2.7.2.10. Допуски и предельные значения — Допуски по умолчанию

9.2.7.2.11. Точности


9.2.7.2.1. Общие настройки

Общие настройки размеров для моделей (как новых, так и текущих) выполняются в диалоге Общие настройки, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Модель — Размеры — Общие настройки,

– для текущего документа — Сервис — Параметры... — Текущая деталь/сборка — Размеры — Общие настройки.

Работа в диалоге описана в разделе 9.2.6.10.1.


9.2.7.2.2. Параметры

Настройка отрисовки размеров для моделей (как новых, так и текущих) выполняется в диалоге Параметры отрисовки размеров, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Модель — Размеры — Параметры,

– для текущего документа — Сервис — Параметры... — Текущая деталь/сборка/Текущий эскиз — Размеры — Параметры.

Работа в диалоге описана в разделе 9.2.6.10.2.


9.2.7.2.3. Стрелки и засечки

Настройка отрисовки стрелок и засечек размеров для моделей (как новых, так и текущих) выполняется в диалоге Стрелки и засечки, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Модель — Размеры — Стрелки и засечки,

– для текущего документа — Сервис — Параметры... — Текущая деталь/сборка — Размеры — Стрелки и засечки.

Работа в диалоге описана в разделе 9.2.6.10.4.


9.2.7.2.4. Фильтр стрелок — Линейные размеры

Настройка фильтра стрелок линейных размеров для моделей (как новых, так и текущих) выполняется в диалоге Фильтр стрелок линейных размеров, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Модель — Размеры — Фильтры стрелок — Линейные размеры,

– для текущего документа — Сервис — Параметры... — Текущая деталь/сборка — Размеры — Фильтры стрелок — Линейные размеры.

Работа в аналогичном диалоге описана в разделе 9.2.6.10.5.


9.2.7.2.5. Фильтр стрелок — Размеры окружностей и дуг

Настройка фильтра стрелок размеров окружностей и дуг для моделей (как новых, так и текущих) выполняется в диалоге Фильтр стрелок размеров окружностей и дуг, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Модель — Размеры — Фильтры стрелок — Размеры окружностей и дуг,

– для текущего документа — Сервис — Параметры... — Текущая деталь/сборка — Размеры — Фильтры стрелок — Размеры окружностей и дуг.

Работа в аналогичном диалоге описана в разделе 9.2.6.10.5.


9.2.7.2.6. Фильтр стрелок — Угловые размеры

Настройка фильтра стрелок угловых размеров для моделей (как новых, так и текущих) выполняется в диалоге Фильтр стрелок угловых размеров, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Модель — Размеры — Фильтры стрелок — Угловые размеры,

– для текущего документа — Сервис — Параметры... — Текущая деталь/сборка — Размеры — Фильтры стрелок — Угловые размеры.

Работа в аналогичном диалоге описана в разделе 9.2.6.10.5.


9.2.7.2.7. Надпись

Настройка параметров текста размерных надписей для моделей (как новых, так и текущих) выполняется в диалоге Параметры размерной надписи, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Модель — Размеры — Надпись,

– для текущего документа — Сервис — Параметры... — Текущая деталь/сборка/Текущий эскиз — Размеры — Надпись.

Работа в аналогичном диалоге описана в разделе 9.2.6.10.8.


9.2.7.2.8. Положение надписи

Настройка положения размерных надписей для моделей (как новых, так и текущих) выполняется в диалоге Положение размерной надписи, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Модель — Размеры — Положение надписи,

– для текущего документа — Сервис — Параметры... — Текущая деталь/сборка — Размеры — Положение надписи.

Работа в диалоге описана в разделе 9.2.6.10.9.


9.2.7.2.9. Допуски и предельные значения — Параметры

Настройка параметров отображения допусков и предельных значений размеров для моделей (как новых, так и текущих) выполняется в диалоге Параметры допусков и предельных значений, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Модель — Размеры — Допуски и предельные значения — Параметры,

– для текущего документа — Сервис — Параметры... — Текущая деталь/сборка — Размеры — Допуски и предельные значения — Параметры.

Работа в диалоге описана в разделе 9.2.6.10.10.


9.2.7.2.10. Допуски и предельные значения — Допуски по умолчанию

Задание умолчательных параметров допусков для моделей (как новых, так и текущих) выполняется в диалоге Значение и состояние допусков по умолчанию, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Модель — Размеры — Допуски и предельные значения — Допуски по умолчанию,

– для текущего документа — Сервис — Параметры... — Текущая деталь/сборка — Размеры — Допуски и предельные значения — Допуски по умолчанию.

Диалог содержит следующие элементы управления:

– Группа кнопок Допуски размеров по умолчанию. Кнопки служат для вызова диалога Допуск, в котором задается умолчательное значение допуска — либо указанием квалитета, либо вводом предельных отклонений. Настройка производится отдельно для каждого типа размеров: линейные, угловые, диаметральные, радиальные (для угловых размеров задаются только отклонения). Настраиваемые параметры относятся к подгруппе 2.1 (см. раздел 9.2.1.1).

Рядом с каждой кнопкой находится поле для просмотра текущего значения допуска. Поле недоступно для ручного редактирования; варианты содержимого:

• число 10 с квалитетом или отклонениями1 — размеры данного типа будут иметь указанный индивидуальный допуск,

• пустое поле — ни квалитет, ни отклонения не заданы, размеры данного типа будут иметь общий допуск.

Поле может содержать только число 10. Это означает, что допуск задан квалитетом, но выбран такой номер квалитета, для которого отключено отображение в размерной надписи. Номер, начиная с которого квалитет не вносится в надпись, задается при настройке точностей размерных надписей (см. раздел 9.2.7.2.11).

– Группа опций Назначать допуски на размеры позволяет выбрать объекты, на размеры (параметры) которых автоматически назначаются допуски. Отключение опции означает, что размеры (параметры) соответствующих объектов по умолчанию не будут иметь допуска — ни общего, ни индивидуального.

После завершения настройки нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.

Подробнее о допусках в модели см. раздел 2.10.2.

  1. Значение 10 служит для иллюстрации.


9.2.7.2.11. Точности

Настройка параметров отображения значений размеров в размерных надписях для моделей (как новых, так и текущих) выполняется в диалоге Точности размерных надписей, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Модель — Размеры — Точности,

– для текущего документа — Сервис — Параметры... — Текущая деталь/сборка/Текущий эскиз — Размеры — Точности.

Работа в диалоге описана в разделе 9.2.6.10.12.


9.2.7.3. Условные обозначения

В этом разделе:

9.2.7.3.1. Линия-выноска — Параметры

9.2.7.3.2. Линия-выноска — Стрелки и засечки

9.2.7.3.3. Линия-выноска — Фильтр стрелок

9.2.7.3.4. Линия-выноска — Текст над/под/за полкой

9.2.7.3.5. Линия-выноска — Наклонный текст

9.2.7.3.6. Линия-выноска — Размеры знаков

9.2.7.3.7. Обозначение позиции — Параметры

9.2.7.3.8. Обозначение позиции — Параметры формы

9.2.7.3.9. Обозначение позиции — Стрелки и засечки

9.2.7.3.10. Обозначение позиции — Фильтр стрелок

9.2.7.3.11. Обозначение позиции — Текст обозначения позиций

9.2.7.3.12. Шероховатость

9.2.7.3.13. Отклонения формы и база

9.2.7.3.14. Автосортировка


9.2.7.3.1. Линия-выноска — Параметры

Настройка отрисовки линий-выносок для моделей (как новых, так и текущих) выполняется в диалоге Параметры отрисовки линий-выносок, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Модель — Условные обозначения — Линия выноска — Параметры,

– для текущего документа — Сервис — Параметры... — Текущая деталь/сборка — Условные обозначения — Линия выноска — Параметры.

Работа в диалоге описана в разделе 9.2.6.11.1.


9.2.7.3.2. Линия-выноска — Стрелки и засечки

Настройка отрисовки стрелок и засечек линий-выносок для моделей (как новых, так и текущих) выполняется в диалоге Стрелки и засечки, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Модель — Условные обозначения — Линия-выноска — Стрелки и засечки,

– для текущего документа — Сервис — Параметры... — Текущая деталь/сборка —Условные обозначения — Линия-выноска — Стрелки и засечки.

Работа в диалоге описана в разделе 9.2.6.11.2.


9.2.7.3.3. Линия-выноска — Фильтр стрелок

Настройка фильтра стрелок линий-выносок для моделей (как новых, так и текущих) выполняется в диалоге Фильтр стрелок линий-выносок, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Модель — Условные обозначения — Линия-выноска — Фильтр стрелок,

– для текущего документа — Сервис — Параметры... — Текущая деталь/сборка — Условные обозначения — Линия-выноска — Фильтр стрелок.

Работа в аналогичном диалоге описана в разделе 9.2.6.10.5.


9.2.7.3.4. Линия-выноска — Текст над/под/за полкой

Настройка параметров текста надписей на линиях-выносках для моделей (как новых, так и текущих) выполняется в диалоге Параметры текста над/под/за полкой, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Модель — Условные обозначения — Линия-выноска — Текст над/под/за полкой,

– для текущего документа — Сервис — Параметры... — Текущая деталь/сборка — Условные обозначения — Линия-выноска — Текст над/под/за полкой.

Работа в аналогичном диалоге описана в разделе 9.2.6.10.8.


9.2.7.3.5. Линия-выноска — Наклонный текст

Настройка параметров наклонного текста на линиях-выносках для моделей (как новых, так и текущих) выполняется в диалоге Параметры наклонного текста, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Модель — Условные обозначения — Линия-выноска — Наклонный текст,

– для текущего документа — Сервис — Параметры... — Текущая деталь/сборка — Условные обозначения — Линия-выноска — Наклонный текст.

Работа в аналогичном диалоге описана в разделе 9.2.6.10.8.


9.2.7.3.6. Линия-выноска — Размеры знаков

Настройка размеров знаков для моделей (как новых, так и текущих) выполняется в диалоге Размеры знаков, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Модель — Условные обозначения — Линия-выноска — Размеры знаков,

– для текущего документа — Сервис — Параметры... — Текущая деталь/сборка — Условные обозначения — Линия-выноска — Размеры знаков.

Работа в диалоге описана в разделе 9.2.6.11.6.


9.2.7.3.7. Обозначение позиции — Параметры

Настройка отрисовки обозначений позиций для моделей (как новых, так и текущих) выполняется в диалоге Параметры отрисовки обозначений позиций, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Модель — Условные обозначения — Обозначение позиции — Параметры,

– для текущего документа — Сервис — Параметры... — Текущая деталь/сборка — Условные обозначения — Обозначение позиции — Параметры.

Работа в диалоге описана в разделе 9.2.6.13.1.


9.2.7.3.8. Обозначение позиции — Параметры формы

Настройка параметров формы обозначений позиций для моделей (как новых, так и текущих) выполняется в диалоге Параметры формы обозначений позиций, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Модель — Условные обозначения — Обозначение позиции — Параметры формы,

– для текущего документа — Сервис — Параметры... — Текущая деталь/сборка — Условные обозначения — Обозначение позиции — Параметры формы.

Работа в диалоге описана в разделе 9.2.6.13.2.


9.2.7.3.9. Обозначение позиции — Стрелки и засечки

Настройка отрисовки стрелок обозначений позиций для графических документов (как новых, так и текущих) выполняется в диалоге Стрелки, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Модель — Условные обозначения — Обозначение позиции — Стрелки и засечки,

– для текущего документа — Сервис — Параметры... — Текущая деталь/сборка — Условные обозначения — Обозначение позиции — Стрелки и засечки.

Работа в диалоге описана в разделе 9.2.6.13.3.


9.2.7.3.10. Обозначение позиции — Фильтр стрелок

Настройка фильтра стрелок обозначений позиций для моделей (как новых, так и текущих) выполняется в диалоге Фильтр стрелок обозначений позиций, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Модель — Условные обозначения — Обозначение позиции — Фильтр стрелок,

– для текущего документа — Сервис — Параметры... — Текущая деталь/сборка — Условные обозначения — Обозначение позиции — Фильтр стрелок.

Работа в аналогичном диалоге описана в разделе 9.2.6.10.5.


9.2.7.3.11. Обозначение позиции — Текст обозначения позиций

Настройка параметров текста обозначения позиций для моделей (как новых, так и текущих) выполняется в диалоге Параметры текста обозначения позиций, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Модель — Условные обозначения — Обозначение позиции — Текст обозначения позиций,

– для текущего документа — Сервис — Параметры... — Текущая деталь/сборка — Условные обозначения — Обозначение позиции — Текст обозначения позиций.

Работа в аналогичном диалоге описана в разделе 9.2.6.10.8.


9.2.7.3.12. Шероховатость

Настройка параметров обозначения шероховатости для моделей (как новых, так и текущих) выполняется в диалоге Параметры обозначения шероховатости, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Модель — Условные обозначения — Шероховатость,

– для текущего документа — Сервис — Параметры... — Текущая деталь/сборка — Условные обозначения — Шероховатость.

Работа в аналогичном диалоге описана в разделе 9.2.6.13.6.


9.2.7.3.13. Отклонения формы и база

Настройка параметров отрисовки обозначений отклонений формы и баз для моделей (как новых, так и текущих) выполняется в диалоге Параметры отрисовки отклонения формы и базы, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Модель — Условные обозначения — Отклонения формы и база,

– для текущего документа — Сервис — Параметры... — Текущая деталь/сборка — Условные обозначения — Отклонения формы и база.

Работа в аналогичном диалоге описана в разделе 9.2.6.13.7.


9.2.7.3.14. Автосортировка

Включение и настройка режима автосортировки для моделей (как новых, так и текущих) выполняется в диалоге Автосортировка буквенных обозначений, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Модель — Условные обозначения — Автосортировка,

– для текущего документа — Сервис — Параметры... — Текущая деталь/сборка — Условные обозначения — Автосортировка.

Работа в диалоге описана в разделе 9.2.6.13.14.


9.2.7.4. Деталь

В этом разделе:

9.2.7.4.1. Свойства

9.2.7.4.2. Настройка списка свойств

9.2.7.4.3. Номера новых исполнений

9.2.7.4.4. Цвет

9.2.7.4.5. Свойства абсолютной СК

9.2.7.4.6. Свойства локальных СК

9.2.7.4.7. Свойства объектов

9.2.7.4.8. Свойства листового тела

9.2.7.4.9. Общие допуски

9.2.7.4.10. Неуказанная шероховатость

9.2.7.4.11. Точность отрисовки и МЦХ

9.2.7.4.12. Дерево модели — Общие настройки отображения

9.2.7.4.13. Дерево модели — Структура

9.2.7.4.14. Дерево модели — Формат отображения имени

9.2.7.4.15. Зоны

9.2.7.4.16. Единицы задания МЦХ


9.2.7.4.1. Свойства

Свойства новых деталей настраиваются в диалоге Свойства детали, вызываемом командой Сервис — Параметры... — Новые документы — Модель — Деталь — Свойства.

Диалог позволяет ввести параметры, которые будут использованы по умолчанию как свойства — наименование и обозначение детали, материал и плотность материала, из которого она изготавливается, параметры штриховки для отображения детали в разрезах и сечениях на ассоциативных чертежах по модели.

Табл. 9.2.55. Элементы управления диалога настройки свойств

Элемент

Описание настройки

Обозначение

Поле позволяет ввести обозначение, которое будет присваиваться детали по умолчанию.

Наименование

Поле позволяет ввести наименование, которое будет присваиваться детали по умолчанию.

Материал

Группа элементов позволяет задать умолчательный материал и его плотность, параметры штриховки детали.

В таблице содержатся значения свойств, которые можно настроить.

– Выберите материал из списка или из Справочника Материалы и Сортаменты при помощи кнопки Выбрать материал из списка или Выбрать материал из справочника.
После выбора материала ячейки колонки Значение заполняются автоматически.

– Если требуется ввести вручную плотность или параметры штриховки, щелкните мышью по нужной ячейке и задайте значение.

Обозначение материала

Поле обозначения материала детали. Заполняется автоматически после выбора материала. Недоступно для ручного ввода.

Удаление обозначение материала производится нажатием кнопки Удалить.

Обозначение материала передается в основную надпись чертежа при создании в нем ассоциативного вида детали (если этот вид первый в порядке вставки в чертеж).

Плотность, г/см3

Поле плотности материала. Заполняется автоматически после выбора материала. Доступно для ручного ввода.

Плотность материала используется при вычислении массо-центровочных характеристик детали (при расчете по плотности).

Стиль штриховки

Поле стиля штриховки. Заполняется автоматически после выбора материала. В поле доступен выбор стиля из списка, а также из библиотеки стилей штриховок.

Стиль штриховки передается в чертеж при создании разреза/сечения ассоциативного разреза/сечения детали.

Цвет штриховки

Поле цвета штриховки. В поле доступна смена цвета.

Цвет штриховки передается в чертеж при создании разреза/сечения ассоциативного разреза/сечения детали.

Угол штриховки

Поле угла штриховки. В поле доступен выбор значений из списка или ввод вручную.

Угол штриховки передается в чертеж при создании разреза/сечения ассоциативного разреза/сечения детали.

Выбрать материал из списка

Кнопка позволяет выбрать материал из справочного файла плотностей (файл ...\ASCON\KOMPAS-3D V...\Sys\Grарhic.dns; значения плотностей материалов, содержащиеся в нем, могут редактироваться пользователем).

После нажатия кнопки на экране появляется диалог выбора плотности материала.

После выбора материала происходит автоматическое заполнение значений свойств Обозначение материала, Плотность, Стиль штриховки, Цвет штриховки.

Выбрать материал из справочника

Кнопка позволяет выбрать материал из внешнего Справочника Материалы и Сортаменты (Справочник должен быть подключен к системе КОМПАС-3D).

После выбора материала происходит автоматическое заполнение значений свойств Обозначение материала, Плотность, Стиль штриховки, Цвет штриховки.

Удалить обозначение

Кнопка позволяет очистить поле Обозначение материала.

После завершения настройки свойства детали нажмите кнопку OK. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.2.7.4.2. Настройка списка свойств

Вы можете настроить подключение нужных библиотек свойств и отображение свойств в деталях (как новых, так и текущих). Для этого используется диалог Настройка списка свойств. Диалог появляется на экране в следующих случаях:

– для новых документов — после вызова команды Сервис — Параметры... — Новые документы — Модель — Деталь — Настройка списка свойств,

– для текущего документа — после вызова команды Сервис — Параметры... — Текущая деталь — Настройка списка свойств, а также после нажатия кнопки Настройка списка свойств на Панели свойств при задании свойств детали или тела.

Для новых документов в диалоге настраивается подключение нужных библиотек свойств и отображение свойств в документе. Для текущего документа — только отображение свойств в документе.

Работа в диалоге описана в разделе 9.2.6.5.


9.2.7.4.3. Номера новых исполнений

Параметры формирования номеров новых исполнений настраиваются в диалоге Номера новых исполнений. Диалог появляется на экране в следующих случаях:

– для новых документов — после вызова команды Сервис — Параметры... — Новые документы — Модель — Деталь — Номера новых исполнений,

– для текущего документа — после вызова команды Сервис — Параметры... — Текущая деталь — Номера новых исполнений, а также после нажатия кнопки Параметры формирования номеров новых исполнений в Менеджере документа при работе с исполнениями или дополнительными номерами.

Аналогичный диалог используется при настройке номеров новых исполнений для простых и технологических сборок.

Табл. 9.2.56. Элементы управления диалога настройки номеров новых исполнений

Элемент

Описание настройки

Формировать номера новых исполнений

Опция позволяет управлять автоматическим формированием номеров при создании исполнений.

Если опция включена, то номер нового исполнения создается автоматически в соответствии с заданными параметрами.

Если опция отключена, то при создании зависимого исполнения ему присваивается номер исходного исполнения, а при создании независимого — номер отсутствует.

Сквозная нумерация

Опция позволяет задать порядок формирования номеров исполнений.

– При включенной опции для каждого нового исполнения, как зависимого, так и независимого, формируется номер, следующий за самым большим номером исполнения, имеющимся в документе.

– При отключенной опции номер создаваемого исполнения формируется с учетом того, на каком уровне вложенности находится это исполнение и какому независимому исполнению оно подчинено.

Например, исходным исполнением является исполнение АБВ-123.45-03, где АБВ-123.45 — базовое обозначение, а 03 — номер исполнения. Этот номер является наибольшим.

– Если опция включена, новое исполнение (зависимое или независимое) получает номер 04. Обозначение исполнения имеет вид АБВ-123.45-04.

– Если опция отключена, новое зависимое исполнение создается с номером 03-01. Его обозначение имеет вид АБВ-123.45-03-01. Новое независимое исполнение создается с номером 04. Обозначение этого исполнения — АБВ-123.45-04.

Разделительный знак

Поле позволяет задать символ, который будет отображаться перед номером в обозначении исполнения.

Вставлять нули перед числом

Опция позволяет управлять добавлением нулей перед числом, входящим в номер. При включенной опции нули добавляются, при отключенной — нет. Количество добавляемых нулей зависит от разрядности номера.

Разрядность номера

Раскрывающийся список позволяет задать минимальное количество разрядов номера.

Начинать с

Поле позволяет ввести или задать с помощью счетчика число, с которого будет начинаться нумерация исполнений.

Формировать дополнительные номера исполнений

Опция позволяет управлять порядком формирования дополнительных номеров.

– При включенной опции номера формируются автоматически в соответствии с настройками, описанными ниже.

– При отключенной опции номера не формируются.

Если документ содержит номера, созданные при включенной опции, то дальнейшее отключение опции не влияет на порядок формирования номеров, т.е. следующий номер будет создан с теми же настройками, что и номера, имеющиеся в документе.

Разделительный знак

Поле позволяет задать символ, который будет отображаться перед дополнительным номером в обозначении исполнения.

Вставлять нули перед числом

Опция позволяет управлять добавлением нулей перед числом, входящим в дополнительный номер. При включенной опции нули добавляются, при отключенной — нет. Количество добавляемых нулей зависит от разрядности дополнительного номера.

Разрядность номера

Раскрывающийся список позволяет задать минимальное количество разрядов дополнительного номера.

Начинать с

Поле позволяет ввести или задать с помощью счетчика число, с которого будет начинаться нумерация исполнений.

Выполнив необходимые настройки, нажмите кнопку OK. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.2.7.4.4. Цвет

Цвет и оптические свойства поверхностей новых деталей настраиваются в диалоге Цвет детали, вызываемом командой Сервис — Параметры... — Новые документы — Модель — Деталь — Цвет.

Аналогичный диалог используется при настройке цвета и оптических свойств для простых и технологических сборок.

Обратите внимание на то, что компоненты, входящие в состав модели, сохраняют собственные цвета. Произведенные в диалоге настройки касаются только операций добавления и удаления материала, выполненных непосредственно в модели.

Табл. 9.2.57. Элементы управления диалога настройки цвета и оптических свойств
Элемент | Описание настройки
Цвет | Кнопка позволяет выбрать цвет детали в стандартном диалоге выбора цвета.
Оптические свойства | Набор элементов позволяет задать оптические свойства поверхностей детали.
Общий цвет Диффузия Зеркальность Блеск Прозрачность Излучение | Чтобы задать значения параметров, переместите на нужное расстояние соответствующий «ползунок». Числовое значение параметра отображается в справочном поле.
Окно просмотра | В окне просмотра отображается сфера с указанными в диалоге цветом и свойствами поверхности. Это позволяет визуально оценить произведенные изменения.

Настроив цвет и оптические свойства детали, нажмите кнопку OK. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.2.7.4.5. Свойства абсолютной СК

Настройка свойств абсолютной системы координат для деталей (как новых, так и текущих) выполняется в диалоге Свойства объекта, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Модель — Деталь — Свойства абсолютной СК,

– для текущего документа — Сервис — Параметры... — Текущая деталь — Свойства абсолютной СК.

Аналогичный диалог используется при настройке свойств абсолютной системы координат для простых и технологических сборок.

Диалог позволяет задать наименования и цвет изображения координатных плоскостей, осей и обозначения начала координат.

Табл. 9.2.58. Элементы управления диалога настройки абсолютной СК

Элемент

Описание настройки

Список объектов

Список содержит объекты, имя и цвет которых можно настроить: три координатные плоскости, три координатные оси и обозначение начала координат.

Вы можете установить разные или одинаковые цвета для отображения в окне модели этих объектов.

Чтобы указать настраиваемые объекты, выделите их в списке щелчком мыши.

Чтобы переименовать объект, выделите его и щелкните по нему мышью. Строка откроется для редактирования, и вы сможете ввести в нее нужное название. Закончив ввод названия, нажмите клавишу <Enter> для его подтверждения или щелкните мышью в свободном месте диалога. Введенные таким образом названия объектов будут отображаться в Дереве построения.

Использовать цвет детали (сборки)

Включите эту опцию, если все элементы выбранного типа должны отображаться цветом детали (сборки).

Отключите эту опцию, если цвет элементов выбранного типа должен отличаться от цвета детали (сборки).

Цвет

Нажмите эту кнопку для выбора цвета указанного объекта. Кнопка присутствует в диалоге, если отключена опция Использовать цвет детали.

Все по умолчанию

Нажмите эту кнопку, если требуется восстановить цвет по умолчанию для всех типов объектов.

Окно просмотра

Изменения настройки отображения элементов модели показываются в окне просмотра. Это позволяет визуально оценить произведенные изменения. Окно просмотра присутствует в диалоге, если отключена опция Использовать цвет детали.

Задав параметры абсолютной системы координат, нажмите кнопку OK. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.2.7.4.6. Свойства локальных СК

Настройка свойств локальных систем координат для деталей (как новых, так и текущих) выполняется в диалоге Свойства объекта, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Модель — Деталь — Свойства локальных СК,

– для текущего документа — Сервис — Параметры... — Текущая деталь — Свойства локальных СК.

Аналогичный диалог используется при настройке свойств локальных систем координат для простых и технологических сборок.

Диалог позволяет задать наименования и цвет изображения координатных плоскостей, осей и обозначения начала координат.

Табл. 9.2.59. Элементы управления диалога настройки локальных СК

Элемент

Описание настройки

Список объектов

Список содержит объекты, имя и цвет которых можно настроить: три координатные плоскости, три координатные оси и обозначение локальной системы координат.

Вы можете установить разные или одинаковые цвета для отображения в окне модели этих объектов.

Чтобы указать настраиваемые объекты, выделите их в списке щелчком мыши.

Чтобы переименовать объект, выделите его и щелкните по нему мышью. Строка откроется для редактирования, и вы сможете ввести в нее нужное название. Закончив ввод названия, нажмите клавишу <Enter> для его подтверждения или щелкните мышью в свободном месте диалога. Введенные таким образом названия объектов будут отображаться в Дереве построения.

Использовать цвет детали (сборки)

Включите эту опцию, если все элементы выбранного типа должны отображаться цветом детали (сборки).

Отключите эту опцию, если цвет элементов выбранного типа должен отличаться от цвета детали (сборки).

Цвет

Нажмите эту кнопку для выбора цвета указанного объекта. Кнопка присутствует в диалоге, если отключена опция Использовать цвет детали.

Все по умолчанию

Нажмите эту кнопку, если требуется восстановить цвет по умолчанию для всех типов объектов.

Окно просмотра

Изменения настройки отображения элементов модели показываются в окне просмотра. Это позволяет визуально оценить произведенные изменения. Окно просмотра присутствует в диалоге, если отключена опция Использовать цвет детали.

Задав параметры локальных систем координат, нажмите кнопку OK. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.2.7.4.7. Свойства объектов

Настройка свойств объектов для деталей (как новых, так и текущих) выполняется в диалоге Свойства объекта, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Модель — Деталь — Свойства объектов,

– для текущего документа — Сервис — Параметры... — Текущая деталь — Свойства объектов.

Аналогичный диалог используется при настройке свойств объектов для простых и технологических сборок.

Диалог позволяет задать цвет изображения различных объектов.

Табл. 9.2.60. Элементы управления диалога настройки объектов
Элемент | Описание настройки | № подгруппы1
Список элементов | Список содержит все типы объектов модели. Рядом с названием элемента показана пиктограмма, соответствующая ему в Дереве построения. Чтобы изменить цвет отображения элементов определенного типа, выделите его название. | —
Использовать цвет детали (сборки) | Включите эту опцию, если все объекты выбранного типа должны отображаться цветом детали (сборки). Отключите эту опцию, если цвет объектов выбранного типа должен отличаться от цвета детали (сборки). | 2.1
Цвет | Нажмите эту кнопку для задания цвета объектов выбранного типа. Кнопка присутствует в диалоге, если отключена опция Использовать цвет детали (сборки). | 2.1
Дополнительно | Нажмите эту кнопку для выбора оптических свойств поверхности объектов выбранного типа. Кнопка присутствует в диалоге при настройке всех объектов, имеющих поверхность, если отключена опция Использовать цвет детали (сборки). | 2.1
Все по умолчанию | Нажмите эту кнопку, если требуется восстановить цвет по умолчанию для всех типов объектов. | 2.1
Окна просмотра | Изменения настройки отображения объектов модели отображаются в окнах просмотра. Это позволяет визуально оценить произведенные изменения. Окна просмотра присутствуют в диалоге, если отключена опция Использовать цвет детали. | —
  1. Номер подгруппы, к которой относится настраиваемый параметр. Параметры объединены в группы и подгруппы по их действию на объекты текущего документа, см. раздел 9.2.1.1.

Задав параметры изображения объектов, нажмите кнопку OK. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.2.7.4.8. Свойства листового тела

Настройка умолчательных параметров листовых тел для деталей (как новых, так и текущих) выполняется в диалоге Свойства листового тела, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Модель — Деталь — Свойства листового тела,

– для текущего документа — Сервис — Параметры... — Текущая деталь — Свойства листового тела.

Обратите внимание на то, что настройка параметров листовых тел для текущей детали отличается от настройки этих параметров для новых деталей. Приведенное в таблице описание соответствует настройке параметров листовых тел для новых деталей. Особенности выполнения настройки для текущей детали описаны ниже таблицы.

Табл. 9.2.61. Элементы управления диалога настройки параметров листового тела

Элемент

Описание настройки

Толщина, мм

Поле для ввода толщины листового тела.

Радиус, мм

Поле для ввода радиуса сгибов.

Опция Наружный позволяет выбрать способ построения сгибов. Если она включена, сгибы будут строиться по наружному радиусу, в противном случае — по внутреннему1.

Угол, градусы

Поле для ввода умолчательного значения угла сгибов.

Опция Дополняющий позволяет указать интерпретацию угла. Если эта опция включена, то угол рассматривается как дополняющий, в противном случае — как угол сгиба (см. раздел 2.4.4.3.1).

Освобождение

Включите эту опцию, чтобы в модели по умолчанию создавались освобожденные сгибы (см. раздел 2.4.4.4.5).

Прямоугольное,
Скругленное

Выберите умолчательный вариант формы освобождения.

Глубина,
Ширина

Введите умолчательные размеры освобождения сгиба.

Развертка

Группа опций позволяет указать, как должны определяться длины разверток сгибов.

Коэффициент, определяющий положение нейтрального слоя

Выберите этот вариант, если длина развертки должна рассчитываться с использованием коэффициента положения нейтрального слоя (см. раздел 2.4.1.4.1).

Введите умолчательное значение коэффициента.

Величина сгиба

Выберите этот вариант, если длина развертки будет задаваться явно (см. раздел 2.4.1.4.2), и введите умолчательное значение величины сгиба.

Уменьшение сгиба

Выберите этот вариант, если длина развертки должна определяться путем задания уменьшения сгиба (см. раздел 2.4.1.4.3).

Введите умолчательное значение уменьшения.

Таблица сгибов

Включите эту опцию, если длины разверток сгибов должны браться из таблицы сгибов (см. раздел 2.4.1.4.4).

Чтобы выбрать файл таблицы, нажмите кнопку с многоточием и укажите нужный файл в стандартном диалоге выбора файла. Полное имя указанного файла появится в поле Таблица сгибов.

Обратите внимание на то, что при включении опции Таблица сгибов варианты определения длины развертки становятся недоступными, поскольку использование таблицы является приоритетным по отношению к этим вариантам. В то же время числовые поля группы Развертка остаются доступными. Введенные в них значения будут применяться по умолчанию для сгибов, использующих соответствующие варианты определения длины развертки.
  1. При построении листового тела сгибы, соответствующие углам контура в эскизе, строятся по внутреннему радиусу вне зависимости от состояния этой опции.

Настройка параметров листовых тел для текущей модели имеет следующие особенности.

Все числовые поля в диалоге настройки листового тела (Толщина, Радиус сгиба и т.п.) являются справочными. Они соответствуют текущим значениям переменных листового тела (см. раздел 2.4.1.3). При изменении значения какой-либо переменной содержимое соответствующего поля также изменяется.

Таким образом, непосредственно в диалоге параметров листового тела для текущей модели возможна следующая настройка:

– изменение способа задания радиусов сгибов,

– изменение интерпретации угла,

– включение или отключение освобождений сгибов и выбор формы освобождения,

– выбор способа определения длины разверток сгибов,

– смена таблицы сгибов.

Задав параметры листового тела, нажмите кнопку OK. Для выхода из диалога без изменения настроек нажмите кнопку Отмена.

Заданные параметры будут использоваться как умолчательные при создании новых сгибов в листовом теле. Параметры сгибов, созданных до изменения настройки, останутся прежними.

Выбор новой таблицы сгибов повлияет на уже существующие в модели сгибы. Подробнее об этом рассказано в разделе Смена таблицы сгибов.


9.2.7.4.9. Общие допуски

Настройка общих допусков на размеры деталей (как новых, так и текущих), выполняется в диалоге Общие допуски (Неуказанные предельные отклонения размеров). Диалог вызывается следующими способами:

– для новых документов — командой Сервис — Параметры... — Новые документы — Модель — Деталь — Общие допуски,

– для текущего документа — командой Сервис — Параметры... — Текущая деталь — Общие допуски.

Аналогичный диалог используется при настройке общих допусков для размеров простых и технологических сборок.

Табл. 9.2.62. Элементы управления диалога настройки общих допусков
Элемент | Описание настройки
Использовать общие допуски по ГОСТ 30893.1 (ISO2768-1) | При включенной опции на размеры эскизов и операций модели с неуказанными индивидуальными допусками будут назначаться общие допуски. При отключенной опции общий допуск не назначается — размер либо не имеет допуск, либо имеет индивидуальный допуск. Подробнее о размерах эскизов и операций см. раздел 2.9, о допусках см. раздел 2.10.
Класс точности | Список позволяет выбрать класс точности, определяющий значения общих допусков.

После завершения настройки нажмите кнопку OK. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.2.7.4.10. Неуказанная шероховатость

Параметры текста знака неуказанной шероховатости, задаваемой для текущей детали, настраиваются в диалоге Параметры текста неуказанной шероховатости, вызываемом командой Сервис — Параметры... — Текущая деталь — Неуказанная шероховатость.

Работа в аналогичном диалоге описана в разделе .9.2.6.10.8.


9.2.7.4.11. Точность отрисовки и МЦХ

Настройка точности отрисовки и расчета массо-центровочных характеристик, а также точности расчета площадей граней в деталях (как новых, так и текущих) выполняется в диалоге Точность отрисовки и МЦХ. Диалог вызывается командой:

– для новых документов — Сервис — Параметры... — Новые документы — Модель — Деталь — Точность отрисовки и МЦХ,

– для текущего документа — Сервис — Параметры... — Текущая деталь — Точность отрисовки и МЦХ.

Аналогичный диалог используется для настройки точности отрисовки и расчета массо-центровочных характеристик и площадей граней в простых или технологических сборках.

Табл. 9.2.63. Элементы управления диалога настройки точности отрисовки и расчета МЦХ

Элемент

Описание настройки

Точность отрисовки

Позволяет увеличить или уменьшить точность аппроксимации криволинейных ребер и линий очерка модели отрезками прямых линий, а криволинейных поверхностей — треугольниками.

Изменение точности отрисовки модели влияет только на отображение тел, созданных в этой модели или вставленных в нее в качестве заготовок, и поверхностей, созданных в этой модели или импортированных в нее. Точность отрисовки компонентов модели следует настраивать в их файлах.

Для изменения точности перемещайте «ползунок» между позициями Грубо и Точно. В справочном поле диалога будет показан условный параметр точности отображения — количество треугольников, а в окне просмотра — изображение поверхности сферы при выбранной степени точности.

Чем выше точность, тем более «гладким» выглядит изображение и тем больше времени требуется на расчеты.

Точность расчета МЦХ

Позволяет увеличить или уменьшить погрешность вычисления массо-центровочных характеристик модели и площадей граней.

Для изменения точности перемещайте «ползунок» между позициями Низкая и Высокая.

Чем выше точность, тем дольше производятся вычисления. Использовать максимальную точность без крайней необходимости не рекомендуется, поскольку расчет с такой точностью занимает значительное время.

Обратите внимание на то, что расчет МЦХ и площадей в текущей модели производится с точностью, установленной для этой модели. Точность, заданная для компонентов при их создании или редактировании, игнорируется.

После завершения настройки нажмите кнопку OK. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.2.7.4.12. Дерево модели — Общие настройки отображения

Настройка отображения Дерева построения модели для деталей (как новых, так и текущих) выполняется в диалоге Общие настройки отображения. Диалог вызывается следующими способами:

– для новых документов — командой Сервис — Параметры... — Новые документы — Модель — Деталь — Дерево модели — Общие настройки отображения,

– для текущего документа — командой Сервис — Параметры... — Текущая деталь — Дерево модели — Общие настройки отображения.

Аналогичный диалог используется при настройке отображения Дерева построения для простых или технологических сборок.

Диалог позволяет выбрать сохраняемый вид Дерева построения, а также включить или выключить группировку компонентов.

Табл. 9.2.64. Элементы управления диалога общих настроек отображения Дерева построения

Элемент

Описание настройки

Сохраняемый вид Дерева

Группа опций позволяет выбрать способ отображения объектов в Дереве построения — Отображение структуры (см. раздел 2.1.2.2) или Отображение последовательности построения (см. раздел 2.1.2.3).

При настройке текущей модели выбранный способ определяет сохраняемый вид Дерева, т.е. способ, который будет сохранен при закрытии файла и использован при последующем его открытии.

При настройке новых моделей выбранный способ отображения будет использоваться в качестве умолчательного.

Группировать компоненты

Опция позволяет разбить компоненты в Дереве построения на группы в зависимости от типа — Сборочные единицы, Детали, Библиотечные компоненты, Локальные детали, Стандартные изделия.

«Пустые» группы не отображаются. Группа появляется в Дереве после создания первого объекта соответствующего типа.

При настройке текущей модели изменения отображаются в Дереве.

При настройке новых моделей выбранный вариант будет использоваться в качестве умолчательного.

При первом открытии модели, созданной в КОМПАС-3D V8 Plus или более ранней версии системы, используется способ отображения Дерева, установленный при настройке новых моделей.

Этот же способ отображения принимается как сохраняемый вид Дерева. При необходимости вы можете сменить сохраняемый вид Дерева.

После сохранения модели в КОМПАС-3D V9 и более поздних версиях информация о сохраняемом виде Дерева запишется в файл этой модели и будет применяться при очередном ее открытии.

Если же модель не будет сохранена, то при последующем открытии этой модели снова будет использован способ отображения Дерева, установленный для новых моделей.

После завершения настройки Дерева нажмите кнопку ОК.

Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.2.7.4.13. Дерево модели — Структура

Настройка структуры Дерева построения модели для деталей (как новых, так и текущих) выполняется в диалоге Отображение в Дереве. Диалог вызывается следующими способами:

– для новых документов — командой Сервис — Параметры... — Новые документы — Модель — Деталь — Дерево модели — Структура,

– для текущего документа — командой Сервис — Параметры... — Текущая деталь — Дерево модели — Структура или нажатием кнопки Состав Дерева модели на инструментальной панели Дерева построения.

Аналогичный диалог используется при настройке структуры Дерева построения для простых или технологических сборок.

Диалог позволяет настроить умолчательный состав Дерева построения.

Табл. 9.2.65. Элементы управления диалога настройки структуры Дерева построения

Элемент

Описание настройки

Отображение структуры

Группа опций, соответствующих разделам Дерева. Вы можете включать и отключать отображение разделов в Дереве построения, включая и отключая соответствующие им опции.

«Пустые» разделы не отображаются. Раздел появляется в Дереве построения после создания первого объекта соответствующего типа. Например, если в модели нет ни одного эскиза, то и раздел Эскизы в Дереве будет отсутствовать.

При первом открытии модели, созданной в КОМПАС-3D V8 Plus или более ранней версии системы, используется способ отображения Дерева, установленный при настройке новых моделей.

После завершения настройки Дерева нажмите кнопку ОК. При настройке текущей модели произведенные изменения отразятся в Дереве: в нем исчезнут или появятся разделы. При настройке новых моделей изменения вступят в силу при создании этих моделей.

Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.2.7.4.14. Дерево модели — Формат отображения имени

Настройка отображения имени в Дереве построения модели для деталей (как новых, так и текущих) выполняется в диалоге Формат отображения имени. Диалог вызывается следующими способами:

– для новых документов — командой Сервис — Параметры... — Новые документы — Модель — Деталь — Дерево модели — Формат отображения имени,

– для текущего документа — командой Сервис — Параметры... — Текущая деталь — Дерево модели — Формат отображения имени.

Аналогичный диалог используется при настройке отображения имен корневого объекта и компонентов в Дереве построения для простых или технологических сборок.

Табл. 9.2.66. Элементы управления диалога настройки формата отображения имени
Элемент | Описание настройки
 | Имена объектов в Дереве могут состоять из одной или двух частей — обозначения и наименования — текста, вводимого в поля Обозначение и Наименование при настройке свойств объекта (см. раздел 5.1.4.1.1).
Наименование | Выберите этот вариант, чтобы в качестве имен объектов использовались их наименования. Если наименование какого-либо объекта не задано, то в качестве имени используется название типа объекта.
Обозначение + Наименование Наименование + Обозначение | Выберите один из этих вариантов, чтобы в качестве имен объектов использовались их наименования и обозначения, разделенные пробелами. Если какая-либо из частей имени не задана, то используется вторая часть без пробела. Если ни одна из частей имени не задана, то в качестве имени используется название типа объекта.

После завершения настройки Дерева нажмите кнопку ОК.

Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.2.7.4.15. Зоны

Настройка списка объектов, определяющих габариты зоны, для текущих деталей (сборок) выполняется в диалоге Зоны по габаритам объектов, вызываемом командой Сервис — Параметры... — Текущая деталь/сборка — Зоны.

Диалог позволяет задать объекты, по которым определяются:

– габариты компонента при выделении объектов с помощью зон,

– габариты зоны в случае, если для создания зоны указан составной объект — сама модель или ее компонент.

Настройка, сделанная в данном диалоге, не влияет на ручной выбор объектов, определяющих габарит зоны, т.е. вручную можно указать объект любого типа.

Табл. 9.2.67. Элементы управления диалога
Элемент | Описание настройки
Элементы, участвующие в определении габарита | Список объектов, участвующих в определении габарита. Включите опцию слева от названия объекта, чтобы он учитывался при определении габарита.
Учитывать скрытые объекты | Включите опцию, чтобы в определении габарита участвовали скрытые объекты.

Для завершения настройки нажмите кнопку OK. Для выхода из диалога без сохранения изменения нажмите кнопку Отмена.


9.2.7.4.16. Единицы задания МЦХ

Настройки единиц измерения МЦХ для деталей (как новых, так и текущих) выполняется в диалоге Единицы задания МЦХ, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Модель — Деталь — Единицы задания МЦХ,

– для текущего документа — Сервис — Параметры... — Текущая деталь — Единицы задания МЦХ.

Аналогичный диалог используется при настройке единиц измерения МЦХ для простых или технологических сборок.

Диалог позволяет задать умолчательные единицы измерения длины и массы для ввода и отображения массо-центровочных характеристик модели при настройке ее свойств.

При вычислении МЦХ с помощью специальной команды (см. раздел 2.1.2.2) единицы измерения задаются в процессе ее выполнения и могут отличаться от установленных в данном диалоге.

Для задания единиц измерения выберите нужные названия из списков Единицы длины и Единицы массы.

После завершения настройки нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.2.7.5. Сборка

В этом разделе:

9.2.7.5.1. Свойства

9.2.7.5.2. Настройка списка свойств

9.2.7.5.3. Номера новых исполнений

9.2.7.5.4. Цвет

9.2.7.5.5. Свойства абсолютной СК

9.2.7.5.6. Свойства локальных СК

9.2.7.5.7. Свойства объектов

9.2.7.5.8. Общие допуски

9.2.7.5.9. Неуказанная шероховатость

9.2.7.5.10. Точность отрисовки и МЦХ

9.2.7.5.11. Дерево модели

9.2.7.5.12. Зоны

9.2.7.5.13. Единицы задания МЦХ


9.2.7.5.1. Свойства

Настройка свойств для новых сборок выполняется в диалоге Свойства сборки, вызываемом командой Сервис — Параметры... — Новые документы — Модель — Сборка — Свойства.

Аналогичный диалог используется при настройке свойств для новых технологических сборок.

Табл. 9.2.68. Элементы управления диалога настройки свойств
Элемент | Описание настройки
Обозначение | Поле позволяет ввести обозначение, которое будет присваиваться сборке по умолчанию.
Наименование | Поле позволяет ввести наименование, которое будет присваиваться сборке по умолчанию.

Настроив свойства сборки, нажмите кнопку OK. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.2.7.5.2. Настройка списка свойств

Вы можете настроить подключение нужных библиотек свойств и отображение свойств в сборках (как новых, так и текущих). Для этого используется диалог Настройка списка свойств. Диалог появляется на экране в следующих случаях:

– для новых документов — после вызова команды Сервис — Параметры... — Новые документы — Модель — Сборка — Настройка списка свойств,

– для текущего документа — после вызова команды Сервис — Параметры... — Текущая сборка — Настройка списка свойств, а также после нажатия кнопки Настройка списка свойств на Панели свойств при задании свойств сборки, компонента или тела.

Для новых документов в диалоге настраивается подключение нужных библиотек свойств и отображение свойств в документе. Для текущего документа — только отображение свойств в документе.

Работа в диалоге описана в разделе 9.2.6.5.


9.2.7.5.3. Номера новых исполнений

Параметры формирования номеров новых исполнений настраиваются в диалоге Номера новых исполнений. Диалог появляется на экране в следующих случаях:

– для новых документов — после вызова команды Сервис — Параметры... — Новые документы — Модель — Сборка — Номера новых исполнений,

– для текущего документа — после вызова команды Сервис — Параметры... — Текущая сборка — Номера новых исполнений, а также после нажатия кнопки Параметры формирования номеров новых исполнений в Менеджере документа при работе с исполнениями или дополнительными номерами.

Работа в диалоге описана в разделе 9.2.7.4.3.


9.2.7.5.4. Цвет

Цвет и оптические свойства для новых сборок настраиваются в диалоге Цвет сборки, вызываемом командой Сервис — Параметры... — Новые документы — Модель — Сборка — Цвет.

Обратите внимание на то, что детали, входящие в состав сборки, сохраняют собственные цвета. Произведенные в диалоге настройки касаются только операций добавления и удаления материала, выполненных непосредственно в сборке.

Работа в аналогичном диалоге описана в разделе 9.2.7.4.4.


9.2.7.5.5. Свойства абсолютной СК

Настройка свойств абсолютной системы координат для сборок (как новых, так и текущих) выполняется в диалоге Свойства объекта, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Модель — Сборка — Свойства абсолютной СК,

– для текущего документа — Сервис — Параметры... — Текущая сборка — Свойства абсолютной СК.

Работа в диалоге описана в разделе 9.2.7.4.5.


9.2.7.5.6. Свойства локальных СК

Настройка свойств локальных систем координат для сборок (как новых, так и текущих) выполняется в диалоге Свойства объекта, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Модель — Сборка — Свойства локальных СК,

– для текущего документа — Сервис — Параметры... — Текущая сборка — Свойства локальных СК.

Работа в диалоге описана в разделе 9.2.7.4.6.


9.2.7.5.7. Свойства объектов

Настройка свойств объектов для сборок (как новых, так и текущих) выполняется в диалоге Свойства объекта, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Модель — Сборка — Свойства объектов,

– для текущего документа — Сервис — Параметры... — Текущая сборка — Свойства объектов.

Работа в диалоге описана в разделе 9.2.7.4.7.


9.2.7.5.8. Общие допуски

Настройка общих допусков на размеры сборок (как новых, так и текущих), выполняется в диалоге Общие допуски (Неуказанные предельные отклонения размеров). Диалог вызывается следующими способами:

– для новых документов — командой Сервис — Параметры... — Новые документы — Модель — Сборка— Общие допуски,

– для текущего документа — командой Сервис — Параметры... — Текущая деталь — Модель — Сборка — Общие допуски.

Работа в диалоге описана в разделе 9.2.7.4.9.


9.2.7.5.9. Неуказанная шероховатость

Параметры текста знака неуказанной шероховатости, задаваемой для текущей сборки, настраиваются в диалоге, вызываемом командой Сервис — Параметры... — Текущая сборка — Неуказанная шероховатость.

Работа в аналогичном диалоге описана в разделе .9.2.6.10.8.


9.2.7.5.10. Точность отрисовки и МЦХ

Настройка точности отрисовки и расчета массо-центровочных характеристик, а также точности расчета площадей граней в сборках (как новых, так и текущих) выполняется в диалоге Точность отрисовки и МЦХ. Диалог вызывается командой:

– для новых документов — Сервис — Параметры... — Новые документы — Модель — Сборка — Точность отрисовки и МЦХ,

– для текущего документа — Сервис — Параметры... — Текущая сборка — Точность отрисовки и МЦХ.

Работа в диалоге описана в разделе 9.2.7.4.11.


9.2.7.5.11. Дерево модели

Настройка отображения Дерева построения модели для сборок (как новых, так и текущих) выполняется в диалоге Отображение в Дереве. Диалог вызывается следующими способами:

– для новых документов — командой Сервис — Параметры... — Новые документы — Модель — Сборка — Дерево модели,

– для текущего документа — командой Сервис — Параметры... — Текущая сборка — Дерево модели или нажатием кнопки Состав Дерева модели на инструментальной панели Дерева построения.

Работа в диалоге описана в разделе 9.2.7.4.13.


9.2.7.5.12. Зоны

Настройка списка объектов, определяющих габариты зоны, для текущих сборок выполняется в диалоге Зоны по габаритам объектов, вызываемом командой Сервис – Параметры... – Текущая сборка – Зоны. Работа в диалоге описана в разделе 9.2.7.4.15.


9.2.7.5.13. Единицы задания МЦХ

Настройки единиц измерения МЦХ для сборок (как новых, так и текущих) выполняется в диалоге Единицы задания МЦХ, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Модель — Сборка — Единицы задания МЦХ,

– для текущего документа — Сервис — Параметры... — Текущая сборка — Единицы задания МЦХ.

Работа в диалоге описана в разделе 9.2.7.4.16.


9.2.7.6. Технологическая сборка

В этом разделе:

9.2.7.6.1. Свойства

9.2.7.6.2. Настройка списка свойств

9.2.7.6.3. Номера новых исполнений

9.2.7.6.4. Цвет

9.2.7.6.5. Свойства абсолютной СК

9.2.7.6.6. Свойства локальных СК

9.2.7.6.7. Свойства объектов

9.2.7.6.8. Общие допуски

9.2.7.6.9. Неуказанная шероховатость

9.2.7.6.10. Точность отрисовки и МЦХ

9.2.7.6.11. Дерево модели

9.2.7.6.12. Единицы задания МЦХ


9.2.7.6.1. Свойства

Настройка свойств для новых технологических сборок выполняется в диалоге Свойства сборки, вызываемом командой Сервис — Параметры... — Новые документы — Модель — Технологическая сборка — Свойства.

Работа в диалоге описана в разделе 9.2.7.5.1.


9.2.7.6.2. Настройка списка свойств

Вы можете настроить подключение нужных библиотек свойств и отображение свойств в технологических сборках (как новых, так и текущих). Для этого используется диалог Настройка списка свойств. Диалог появляется на экране в следующих случаях:

– для новых документов — после вызова команды Сервис — Параметры... — Новые документы — Модель — Технологическая сборка — Настройка списка свойств,

– для текущего документа — после вызова команды Сервис — Параметры... — Текущая сборка — Настройка списка свойств, а также после нажатия кнопки Настройка списка свойств на Панели свойств при задании свойств сборки, компонента или тела.

Для новых документов в диалоге настраивается подключение нужных библиотек свойств и отображение свойств в документе. Для текущего документа — только отображение свойств в документе.

Работа в диалоге описана в разделе 9.2.6.5.


9.2.7.6.3. Номера новых исполнений

Параметры формирования номеров новых исполнений настраиваются в диалоге, вызываемом командой Сервис — Параметры... — Новые документы — Модель — Технологическая сборка — Номера новых исполнений.

Работа в диалоге описана в разделе 9.2.7.4.3.


9.2.7.6.4. Цвет

Цвет и оптические свойства для новых технологических сборок настраиваются в диалоге Цвет сборки, вызываемом командой Сервис — Параметры... — Новые документы — Модель — Технологическая сборка — Цвет.

Обратите внимание на то, что детали, входящие в состав технологической сборки, сохраняют собственные цвета. Произведенные в диалоге настройки касаются только операций добавления и удаления материала, выполненных непосредственно в технологической сборке.

Работа в аналогичном диалоге описана в разделе 9.2.7.4.4.


9.2.7.6.5. Свойства абсолютной СК

Настройка свойств абсолютной системы координат для технологических сборок (как новых, так и текущих) выполняется в диалоге Свойства объекта, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Модель — Технологическая сборка — Свойства абсолютной СК,

– для текущего документа — Сервис — Параметры... — Текущая сборка — Свойства абсолютной СК.

Работа в диалоге описана в разделе 9.2.7.4.5.


9.2.7.6.6. Свойства локальных СК

Настройка свойств локальных систем координат для технологических сборок (как новых, так и текущих) выполняется в диалоге Свойства объекта, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Модель — Технологическая сборка — Свойства локальных СК,

– для текущего документа — Сервис — Параметры... — Текущая сборка — Свойства локальных СК.

Работа в диалоге описана в разделе 9.2.7.4.6.


9.2.7.6.7. Свойства объектов

Настройка свойств объектов для технологических сборок (как новых, так и текущих) выполняется в диалоге Свойства объекта, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Модель — Технологическая сборка — Свойства объектов,

– для текущего документа — Сервис — Параметры... — Текущая сборка — Свойства объектов.

Работа в диалоге описана в разделе 9.2.7.4.7.


9.2.7.6.8. Общие допуски

Настройка общих допусков на размеры технологических сборок (как новых, так и текущих), выполняется в диалоге Общие допуски (Неуказанные предельные отклонения размеров). Диалог вызывается следующими способами:

– для новых документов — командой Сервис — Параметры... — Новые документы — Модель — Технологическая сборка— Общие допуски,

– для текущего документа — командой Сервис — Параметры... — Текущая деталь — Модель — Сборка — Общие допуски.

Работа в диалоге описана в разделе 9.2.7.4.9.


9.2.7.6.9. Неуказанная шероховатость

Параметры текста знака неуказанной шероховатости, задаваемой для текущей технологической сборки, настраиваются в диалоге, вызываемом командой Сервис — Параметры... — Текущая сборка — Неуказанная шероховатость.

Работа в аналогичном диалоге описана в разделе .9.2.6.10.8.


9.2.7.6.10. Точность отрисовки и МЦХ

Настройка точности отрисовки и расчета массо-центровочных характеристик, а также точности расчета площадей граней в технологических сборках (как новых, так и текущих) выполняется в диалоге Точность отрисовки и МЦХ. Диалог вызывается командой:

– для новых документов — Сервис — Параметры... — Новые документы — Модель — Технологическая сборка — Точность отрисовки и МЦХ,

– для текущего документа — Сервис — Параметры... — Текущая сборка — Точность отрисовки и МЦХ.

Работа в диалоге описана в разделе 9.2.7.4.11.


9.2.7.6.11. Дерево модели

Настройка отображения Дерева построения модели для технологических сборок (как новых, так и текущих) выполняется в диалоге Отображение в Дереве. Диалог вызывается следующими способами:

– для новых документов — командой Сервис — Параметры... — Новые документы — Модель — Технологическая сборка — Дерево модели,

– для текущего документа — командой Сервис — Параметры... — Текущая сборка — Дерево модели или нажатием кнопки Состав Дерева модели на инструментальной панели Дерева построения.

Работа в диалоге описана в разделе 9.2.7.4.13.


9.2.7.6.12. Единицы задания МЦХ

Настройки единиц измерения МЦХ для технологических сборок (как новых, так и текущих) выполняется в диалоге Единицы задания МЦХ, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Модель — Технологическая сборка — Единицы задания МЦХ,

– для текущего документа — Сервис — Параметры... — Текущая сборка — Единицы задания МЦХ.

Работа в диалоге описана в разделе 9.2.7.4.16.


9.2.7.7. Эскиз

В этом разделе:

9.2.7.7.1. Параметризация


9.2.7.7.1. Параметризация

Настройка использования параметрического режима системы КОМПАС-3D для эскизов моделей (как новых, так и текущих) выполняется в диалоге Управление параметризацией, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Модель — Эскиз — Параметризация,

– для текущего документа — Сервис — Параметры... — Текущий эскиз — Параметризация.

Работа в диалоге описана в разделе 9.2.6.22.


9.2.7.8. Параметры таблицы отчета

В этом разделе:

9.2.7.8.1. Заголовок

9.2.7.8.2. Ячейка


9.2.7.8.1. Заголовок

Параметры текста заголовка таблицы отчета для моделей (как новых, так и текущих) настраиваются в диалоге Параметры текста заголовка таблицы, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Модель — Параметры таблицы отчета — Заголовок,

– для текущего документа — Сервис — Параметры... — Текущая деталь/сборка — Параметры таблицы отчета — Заголовок.

Работа в аналогичном диалоге описана в разделе 9.2.4.4.

Настройки используются при отображении отчета по модели в Окне подготовки данных.


9.2.7.8.2. Ячейка

Параметры текста ячейки таблицы отчета для моделей (как новых, так и текущих) настраиваются в диалоге Параметры текста ячейки таблицы, вызываемом командой:

– для новых документов — Сервис — Параметры... — Новые документы — Модель — Параметры таблицы отчета — Ячейка,

– для текущего документа — Сервис — Параметры... — Текущая деталь/сборка — Параметры таблицы отчета — Ячейка.

Работа в аналогичном диалоге описана в разделе 9.2.4.4.

Настройки используются при отображении отчета по модели в Окне подготовки данных.


9.2.7.9. Технические требования

Параметры текста технических требований, задаваемых в модели, для новых документов настраиваются в диалоге, вызываемом командой Сервис — Параметры... — Новые документы — Модель — Технические требования.

Табл. 9.2.69. Элементы управления диалога настройки текста технических требований
Элемент | Описание настройки
Шаг строк, мм | Поле для ввода расстояния между строками текста в абзаце. Изменение шага строк позволяет сохранять пропорциональность расстояний между строками, набранными шрифтом с различной высотой символов.
Красная строка, мм | Поле для ввода отступа первой строки абзаца. Отступ измеряется от границы текста. При создании нового абзаца курсор автоматически устанавливается в позицию с заданным отступом.
Отступы | Поля для ввода расстояний между левой и правой границами поля ввода и соответствующими границами текста.
Интервал | Поля для задания расстояния между двумя соседними абзацами. Данное расстояние складывается из двух величин — интервала после первого абзаца и интервала перед вторым абзацем.
Выравнивание | Опции позволяют выбрать нужный способ выравнивания абзацев (по левой границе, по правой границе, центрирование, выравнивание по двум границам).
Устанавливать нумерацию при создании | Опция управляет автонумерацией пунктов технических требований при их вводе. Если она включена, то нумерация абзацев технических требований устанавливается автоматически.
Шрифт... | Кнопка для вызова диалога настройки параметров шрифта.
Табуляция... | Кнопка для вызова диалога настройки параметров табуляции.
Параметры списка... | Кнопка для вызова диалога настройки параметров списка. В диалоге задаются параметры нумерации абзацев текста.

После завершения настройки параметров нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


9.2.7.10. Неуказанная шероховатость

Параметры текста знака неуказанной шероховатости, задаваемой в модели, для новых документов настраиваются в диалоге, вызываемом командой Сервис — Параметры... — Новые документы — Модель — Неуказанная шероховатость.

Работа в аналогичном диалоге описана в разделе 9.2.6.10.8.


9.3. Параметры текущего окна

В этом разделе:

9.3.1. Сетка

9.3.2. Линейки прокрутки

9.3.3. Перспективная проекция

9.3.4. Зоны


9.3.1. Сетка

9.3. Параметры текущего окна

9.3.1. Сетка

Вид сетки, отображающейся в активном окне, настраивается в диалоге Настройка сетки, вызываемом командой Сервис — Параметры... — Текущее окно — Сетка или командой Настроить параметры из меню кнопки Сетка, расположенной на панели Текущее состояние. Работа в диалоге описана в разделе 9.1.7.2.


9.3.2. Линейки прокрутки

9.3. Параметры текущего окна

9.3.2. Линейки прокрутки

Управление отображением линеек прокрутки на экране и автоматическим сдвигом изображения в текущем окне выполняется в диалоге Установка линеек прокрутки, вызываемом командой Сервис — Параметры — Текущее окно — Линейки прокрутки. Работа в диалоге описана в разделе 9.1.7.3.


9.3.3. Перспективная проекция

9.3. Параметры текущего окна

9.3.3. Перспективная проекция

Настройка параметров перспективной проекции (степень вносимого перспективой искажения) для текущего окна выполняется в диалоге Перспективная проекция, вызываемом командой Сервис — Параметры — Текущее окно — Перспективная проекция.

Диалог содержит поле Расстояние в габаритах модели. Значение в этом поле показывает, во сколько раз расстояние от модели до плоскости изображения больше, чем максимальный габарит модели. Другими словами, на экране показывается такое изображение модели, которое получил бы оптический прибор, находящийся на указанном расстоянии от модели. Чем меньше указанное расстояние, тем сильнее будет заметно искажение изображения.

Для завершения настройки нажмите кнопку OK. Для выхода из диалога без сохранения изменения нажмите кнопку Отмена.


9.3.4. Зоны

9.3. Параметры текущего окна

9.3.4. Зоны

Настройка параметров отображения зон для текущего окна выполняется в диалоге Отображение зон, вызываемом командой Сервис — Параметры... — Текущее окно – Зоны.

Элементы управления диалогом описаны в табл. 9.3.1.

Табл. 9.3.1. Элементы управления диалога настройки отображения зон
Элемент | Описание настройки
Отображение ребер | Опция позволяет управлять отображением ребер многогранника, ограничивающего зону.
Цвет | Кнопка позволяет выбрать цвет ребер многогранника зоны, в стандартном диалоге выбора цвета. Доступна при включенной опции Отображение ребер.
Линия | Список для выбора стиля линии ребер многогранника зоны. Ребра могут отображаться: – сплошной линией, – штрихами, – точками. Список доступен при включенной опции Отображение ребер.
Закрашивать грани | Опция позволяет управлять отображением граней многогранника, ограничивающего зону.
Цвет | Кнопка позволяет выбрать цвет граней многогранника зоны в стандартном диалоге выбора цвета. Доступна при включенной опции Закрашивать грани.
Оптические свойства | Набор элементов позволяет задать оптические свойства граней многогранника зоны. Доступен при включенной опции Закрашивать грани.
Общий цвет Диффузия Зеркальность Блеск Прозрачность Излучение | Чтобы задать значения параметров, переместите на нужное расстояние соответствующий «ползунок». Числовое значение параметра отображается в справочном поле.
Окно просмотра | В окне просмотра отображается сфера с указанными в диалоге цветом и оптическими свойствами. Это позволяет визуально оценить произведенные изменения.

Для завершения настройки нажмите кнопку OK. Для выхода из диалога без сохранения изменения нажмите кнопку Отмена.


9.4. Профили. Настройка интерфейса. Вид приложения

9.4. Профили. Настройка интерфейса.
Вид приложения

В этом разделе:

9.4.1. Профили

9.4.2. Настройка интерфейса

9.4.2.1. Настройка состава Главного меню и инструментальных панелей

9.4.2.2. Создание пользовательской инструментальной панели

9.4.2.3. Настройка клавиш быстрого вызова команд («горячих клавиш»)

9.4.2.4. Утилиты

9.4.2.5. Настройка размеров значков

9.4.3. Вид приложения


9.4.1. Профили

9.4. Профили. Настройка интерфейса. Вид приложения

9.4.1. Профили

Профиль — комплекс сведений о настройке конфигурации системы.

С помощью профилей можно быстро перенастроить текущую конфигурацию системы.

Например, вы можете создать профиль для трехмерного моделирования (т.е. профиль, содержащий настройки, при которых вам наиболее удобно работать с трехмерными моделями), профиль для разработки конструкторской документации и т.д. Затем, чтобы настроить систему для выполнения той или иной задачи, вам будет достаточно применить соответствующий профиль.

Чтобы сохранить текущую настройку конфигурации в файле профиля, выполните следующие действия.

1. Вызовите команду Сервис — Профили....

2. В появившемся диалоге включите опции, соответствующие группам настроек, которые необходимо сохранить в профиле.

3. Нажмите кнопку Сохранить как....

4. В появившемся диалоге укажите имя и задайте расположение файла профиля. Расширение файла профиля — pfl.

В файл профиля не записываются имена последних открывавшихся документов, а также состояние окон открытых документов.

Чтобы применить ранее созданный файл профиля, выполните следующие действия.

1. Вызовите команду Сервис — Профили....

2. В появившемся диалоге выберите профиль из списка Профили.

3. Включите опции, соответствующие группам настроек, которые необходимо использовать.

4. Нажмите кнопку Применить.

5. Указанные настройки будут применены.

6. Нажмите кнопку Выход.

Вместе с КОМПАС-3D поставляются несколько готовых файлов профилей. Они расположены в подпапке Profiles главной папки системы.

При использовании готовых файлов профилей следует иметь в виду, что в них нет сведений о библиотеках. Поэтому после применения любого такого профиля текущее содержимое Менеджера библиотек будет удалено, и Менеджер автоматически наполнится в соответствии с файлами *.lms, имеющимися в подпапке Sys главной папки системы.

Файлы *.lms содержат сведения о составе Менеджера библиотек (названия разделов, подразделов и перечни входящих в них библиотек). Эти файлы используются для первичного наполнения Менеджера библиотек и его обновления. Формат файлов — текстовый, поэтому при необходимости вы можете открыть их в любом текстовом редакторе и изменить хранящуюся в них информацию.


9.4.2. Настройка интерфейса

9.4. Профили. Настройка интерфейса. Вид приложения

9.4.2. Настройка интерфейса

На рис. 1.2.1 показан умолчательный вид экрана КОМПАС-3D. Вы можете настроить интерфейс системы по своему усмотрению. Для этого вызовите команду Сервис — Настройка интерфейса. На экране появится настроечный диалог с раскрытым разделом Экран — Настройка интерфейса. Раздел содержит следующие пункты:

– Команды,

– Панели инструментов,

– Утилиты,

– Клавиатура,

– Меню,

– Параметры,

– Размер значков.

При выборе каждого из этих пунктов в правой части вкладки появляется диалог, наименование которого соответствует пункту раздела. Элементы управления, расположенные в диалогах, позволяют выполнить необходимые настройки.

Далее при описании настройки элементов интерфейса упоминаются пункты именно этого раздела.

Порядок настройки интерфейса КОМПАС-3D во многом аналогичен порядку настройки других приложений Windows, поэтому подробное описание каждой возможности здесь не приводится.

Обратите внимание на то, что изменения настройки (кроме изменения размеров значков) невозможно отменить. Чтобы вернуть интерфейс к прежнему виду, измените настройку повторно.

Вы можете выполнять дополнительные настройки отображения команд в меню и кнопок на инструментальных панелях с помощью контекстного меню.

Для работы с контекстным меню откройте диалог Параметры, выберите один из пунктов раздела Настройка интерфейса и, не закрывая диалог, вызовите контекстное меню элемента, который требуется настроить.

Команды контекстного меню позволяют выбрать вариант отображения элемента — в виде пиктограммы, текста, пиктограммы и текста; заменить пиктограмму пользовательской; скопировать пиктограмму и т.п.

В этом разделе:

9.4.2.1. Настройка состава Главного меню и инструментальных панелей

9.4.2.2. Создание пользовательской инструментальной панели

9.4.2.3. Настройка клавиш быстрого вызова команд («горячих клавиш»)

9.4.2.4. Утилиты

9.4.2.5. Настройка размеров значков


9.4.2.1. Настройка состава Главного меню и инструментальных панелей

Выберите пункт Команды (рис. 9.4.1). В диалоге Команды выберите категорию и название команды. «Перетащите» команду на нужную панель или в нужное меню.

Рис. 9.4.1. Диалог Команды

Вы можете изменять положение команд и их групп на инструментальных панелях и в меню, «перетаскивая» их мышью. Контекстное меню команды (кнопки) позволяет осуществить дополнительную настройку (изменить название команды, ее пиктограмму и т.п.), а также удалить выбранный элемент.

Кнопка Сбросить все в диалоге Панели инструментов позволяет привести все меню и панели в умолчательное состояние.

Вы можете перемещать кнопки между панелями и без вызова диалога настройки. Для этого «перетаскивайте» их мышью, удерживая нажатой клавишу <Alt>.

Настройку инструментальных панелей, находящихся в диалогах или окнах, изменить невозможно.


9.4.2.2. Создание пользовательской инструментальной панели

Рис. 9.4.2. Диалог Панели инструментов

Вы можете создавать пользовательские инструментальные панели и размещать на них любые команды.

Чтобы создать пользовательскую инструментальную панель, выберите пункт Панели инструментов и нажмите кнопку Новая... (рис. 9.4.2). Введите название новой панели. Вновь созданная панель появится на экране.

Первоначально панель пуста. Настройте состав панели, как это описано в разделе 9.4.2.1.

Если требуется вставить разделить между командами, выделите на панели команду, перед которой должен стоять разделитель, и вызовите из контекстного меню команду Начать группу. Разделитель появится перед указанной командой.


9.4.2.3. Настройка клавиш быстрого вызова команд («горячих клавиш»)

Выберите пункт Клавиатура.

Рис. 9.4.3. Диалог Клавиатура

Выберите категорию и команду из этой категории (рис. 9.4.3). Если команде уже назначено сочетание клавиш, оно отображается в списке Текущие. Одной команде может быть назначено несколько клавиатурных комбинаций.

Выберите из списка Установить сочетание режим, в котором будет действовать настраиваемое сочетание клавиш.

Задайте новое сочетание клавиш. Вы можете использовать как одиночные клавиши, например, буквы или цифры, так и их сочетание с клавишами <Ctrl>, <Alt> или с комбинациями клавиш <Ctrl> + <Alt>, <Ctrl> + <Shift>, <Shift> + <Alt>. Сочетание помогает избежать путаницы при вызове команд и вводе букв и цифр. Задать клавишу или комбинацию клавиш, которые уже используются для вызова команды, невозможно.

Подтвердите назначение команде нового сочетания клавиш, нажав кнопку Связать. Чтобы отменить использование какого-либо сочетания клавиш, выделите его в списке Текущие и нажмите кнопку Удалить.

Чтобы восстановить умолчательные назначения клавиатурных комбинаций всем командам, нажмите кнопку Сбросить все.

Обратите внимание на то, что клавиши дополнительной цифровой клавиатуры работают по-разному в зависимости от того, включен или выключен режим NumLoc. Если связывание клавиши цифровой клавиатуры с командой производилось при включенном (выключенном) режиме NumLoc, то и для вызова команды путем нажатия этой клавиши режим NumLoc должен быть включен (выключен).


9.4.2.4. Утилиты

В меню Сервис системы КОМПАС-3D вы можете добавить пользовательские команды для открытия файлов приложений, документов и т.п. (рис. 9.4.4).

Рис. 9.4.4. Вызов утилит из меню Сервис

Для добавления новой команды в меню выберите пункт Утилиты (рис. 9.4.5).

Рис. 9.4.5. Диалог Утилиты

Нажмие кнопку Новый.

В появившейся в списке пустой строке введите название команды.

В поле Команда: введите полное имя файла, который будет открываться или запускаться при вызове команды. Во избежание опечаток рекомендуется использовать кнопку Обзор для указания файла.

Если выбран исполняемый файл, то при вызове созданной команды будет запущено приложение. Если выбран файл, который не является исполняемым, то при вызове команды будет запущено приложение Windows, сопоставленное с данным типом файлов. В этом приложении будет открыт файл.

В поле Параметры введите параметры запуска приложения.

В поле Рабочая папка введите путь к папке приложения, запускаемого командой.

Если после вызова команды из меню (рис. 9.4.4) запуск файла не происходит, проверьте правильность указания пути к этому файлу. Путь может оказаться неверным, например, если вы используете профиль, созданный на другом рабочем месте.


9.4.2.5. Настройка размеров значков

Размер пиктограмм команд меню и кнопок вызова команд на инструментальных панелях можно изменять. Для этого выберите пункт Размер значков.

Выберите из списков размеры отображения значков каждого типа.

Команды в меню и кнопки на инструментальных панелях могут отображаться в виде пиктограмм, текста или пиктограмм и текста. Выбор варианта отображения описан в разделе 9.4.2.


9.4.3. Вид приложения

9.4. Профили. Настройка интерфейса. Вид приложения

9.4.3. Вид приложения

Вы можете выбрать стиль отображения элементов окна системы в специальном диалоге (рис. 9.4.6).

Рис. 9.4.6. Диалог выбора вида приложения

Этот диалог появляется на экране после первого запуска системы КОМПАС-3D или после вызова команды Сервис — Вид приложения...

Элементы управления диалога представлены в таблице 9.4.1.

Табл. 9.4.1. Элементы управления диалога выбора вида приложения

Элемент

Описание

Стиль приложения

Список, из которого можно выбрать стиль приложения.

Укажите в раскрывающемся списке один из вариантов.

Цветовая схема

Список, из которого можно выбрать цветовое оформление приложения. Список доступен, если стиль приложения — Microsoft® Office 2007 или Microsoft® Office 2010.

Укажите в раскрывающемся списке один из вариантов.

Размер значков

Список, из которого можно выбрать размер значков на панелях, в меню и в Дереве документа.

Если в диалоге настройки размера значков (см. раздел 9.1.3.8.7) отключена опция Единый, то в списке размеров значков появляется строка Согласно настройке. Ее выбор означает, что значки будут иметь размеры, заданные в диалоге настройки размеров значков.

Цветные закладки документов

Опция, управляющая стилем закладок документов.

При включении этой опции закладки отображаются разноцветными, а кнопка прокрутки закладок влево находится слева от них.

Скругленные «корешки» панелей

Опция, управляющая стилем «корешков» панелей.

Опция доступна, если стиль приложения — Microsoft® Visual Studio 2005.

При включении этой опции «корешки» панелей и окон, если они находятся в свернутом состоянии, отображаются скругленными. О сворачивании панелей и окон см. раздел 1.2.2.3.3.

Расширенные всплывающие подсказки

Опция, управляющая видом всплывающих подсказок.

Если опция включена, то во всплывающую подсказку, появляющуюся при подведении курсора к элементу рабочего окна, добавляется информация, находящаяся в строке сообщений.

Если опция выключена, то всплывающая подсказка будет содержать только название команды.

Показывать этот диалог при запуске

Опция, управляющая автоматическим открытием диалога. Если она включена, то диалог появляется на экране каждый раз после запуска системы.

Опция присутствует в диалоге, если он появился автоматически при загрузке (а не был вызван командой Сервис — Вид приложения...).

ОК

Нажатие этой кнопки закрывает диалог и применяет выбранную настройку.

Закрыть

Нажатие этой кнопки закрывает диалог без применения выбранной настройки. Такой же результат дает закрытие диалога кнопкой в его заголовке.

Кнопка присутствует в диалоге, если он был вызван командой Сервис — Вид приложения... (а не появился автоматически при запуске системы).

Применить

Нажатие этой кнопки применяет выбранную настройку без закрытия диалога.


9.5. Хранение настроек системы

В этом разделе:

9.5.1. Общие сведения

9.5.2. Конфигурационные файлы

9.5.3. Файл KOMPAS.ini

9.5.4. Определение путей к системным файлам и папкам. Переменные среды КОМПАС-3D

9.5.5. Служебные файлы

9.5.5.1. Файл пользовательских меню

9.5.5.1.1. Структура файла

9.5.5.1.2. Синтаксис файла

9.5.5.2. Справочный файл плотностей

9.5.5.3. Файл кодов и наименований

9.5.5.4. Файл, определяющий порядок сортировки по коду

9.5.5.5. Файл конфигурации Менеджера библиотек

9.5.6. Рекомендуемая настройка системы КОМПАС-3D при коллективной работе


9.5.1. Общие сведения

9.5. Хранение настроек системы

9.5.1. Общие сведения

Во время работы системы КОМПАС-3D, кроме собственно файлов системы (которые находятся в подпапке \Bin главной папки системы), используются так называемые системные файлы и папки. К ним относятся:

– конфигурационные файлы, в которых хранится информация о настройке параметров системы, ее окна и новых документов (см. раздел 9.5.2),

– умолчательные папки для размещения файлов определенных типов (библиотек стилей и оформлений, шаблонов, профилей и т.п.).

Пути к системным файлам и папкам определяются при загрузке КОМПАС-3D и хранятся в виде значений переменных среды КОМПАС-3D до конца сеанса работы. Порядок определения путей к системным файлам и папкам описан в разделе 9.5.4.

При необходимости вы можете указать пути к системным файлам и папкам в файле KOMPAS.ini (см. раздел 9.5.3).

В любой момент работы с системой вы можете получить сведения о текущем расположении файла KOMPAS.ini, системных файлов и папок в диалоге просмотра расположения файлов (см. раздел 9.1.4.1). С помощью этого диалога можно также создать или отредактировать файл KOMPAS.ini.

Вновь созданный или отредактированный файл KOMPAS.ini будет использован в следующем сеансе работы с КОМПАС-3D.

Сведения, не относящиеся к настройке системы, но необходимые для работы КОМПАС, хранятся в реестре. Это следующая информация:

– сведения о пользователе,

– список последних открывавшихся файлов,

– текущее разрешение экрана (эти данные необходимы для привязки главного окна системы).

Настройки параметров текущего документа (настройки, произведенные на вкладке Текущий документ общего диалога настройки параметров) хранятся в самом документе. Благодаря этому они не изменяются при передаче документов с одного рабочего места на другое.


9.5.2. Конфигурационные файлы

9.5. Хранение настроек системы

9.5.2. Конфигурационные файлы

Конфигурационные файлы (или файлы конфигурации) содержат информацию о настройке конфигурации системы КОМПАС-3D. Настройка конфигурации включает в себя три группы настроек, поэтому конфигурационных файлов тоже три: *.cfg, *.prj и *.dsk (см. табл. 9.5.1).

Табл. 9.5.1. Файлы конфигурации КОМПАС-3D и хранящиеся в них настройки

Файл конфигурации

Настройки, хранящиеся в файле

*.cfg

Настройки параметров системы

Настройки, которые сделаны на вкладке Система общего настроечного диалога1.

Исключением являются настройки интерфейса (они выполняются в разделе Экран — Настройка интерфейса). Эти настройки сохраняются в файле *.dsk.

Содержимое раздела Файлы — Расположение предназначено для просмотра, поэтому оно не включается в файл *.cfg.

Настройки системы подробно описаны в разделе 9.1.

*.prj

Настройки новых документов

Настройки, которые сделаны на вкладке Новые документы общего настроечного диалога1.

Настройки новых документов подробно описаны в разделе 9.2.

*.dsk

Настройки рабочего окна:

– размер главного окна,

– настройки интерфейса, выполненные в разделе Экран — Настройка интерфейса на вкладке Система общего настроечного диалога1,

– вид приложения,

– состояние открытых документов (размеры и местоположение окон, шаг курсора, масштаб, настройка локальных привязок, сетки, линеек прокрутки),

– расположение и состав строки меню и инструментальных панелей (в том числе пользовательских)2,

– расположение и размер:

– Панели свойств,

– окна переменных,

– окна информации,

– окна Библиотекаря текстовых шаблонов,

– окон библиотек,

– Менеджера документа и диалога настройки фильтра слоев,

– Менеджера библиотек,

– структура Менеджера библиотек,

– состояние каждой библиотеки: подключена или отключена.
  1. Диалог, вызываемый командой Сервис — Параметры...
  2. Не сохраняются сведения о составе панелей Вид и Текущее состояние в режиме редактирования локального фрагмента, редактирования технических требований, редактирования объектов спецификации в графическом документе. Изменения состава указанных панелей в этих режимах хранится только до конца сеанса работы.

Сразу после установки системы файлы конфигурации отсутствуют. Они возникают при первом изменении настроек и их сохранении. Определение папок для размещения конфигурационных файлов описано в разделе 9.5.4. Каждый раз после изменения соответствующих настроек файлы конфигурации перезаписываются.

При необходимости можно отключить создание конфигурационных файлов (см. раздел 9.1.4.5).

В отсутствие файлов конфигурации (например, при первом запуске системы КОМПАС-3D) используются хранящиеся внутри системы умолчательные настройки.

Если требуется запустить КОМПАС-3D с умолчательными параметрами, удалите или переименуйте файлы конфигурации.

Текущую настройку конфигурации можно сохранить в файле профиля (см. раздел 9.4.1). Впоследствии применение этого профиля позволит быстро сменить имеющуюся настройку на ту, которая записана в профиле.

Обратите внимание на то, что в файлы *.cfg и *.prj, а также в файл профиля заносятся лишь те настройки, которые были изменены по сравнению с умолчательными. Сведения о неизмененных параметрах не записываются.

Во время чтения файлов *.cfg и *.prj или применения профиля параметрам, информация о которых отсутствует, присваиваются умолчательные значения. При этом умолчательный путь к папке SYS берется из файла KOMPAS.ini (см. раздел 9.5.3), а при его отсутствии — определяется по значению соответствующей переменной среды КОМПАС (см. раздел 9.5.4).


9.5.3. Файл KOMPAS.ini

9.5. Хранение настроек системы

9.5.3. Файл KOMPAS.ini

KOMPAS.ini — текстовый файл с данными, определяющими различные параметры работы системы.

Файл KOMPAS.ini отсутствует в поставке. Его необходимо создать самостоятельно и поместить в ту же папку, где находится файл KOMPAS.exe. Поиск файла KOMPAS.ini ведется только в папке с файлом KOMPAS.exe.

Файл KOMPAS.ini можно создать вручную или нажав специальную кнопку в диалоге просмотра расположения системных файлов (см. раздел 9.1.4.1).

Данные в файле KOMPAS.ini представлены в виде значений ключей, распределенных по секциям. Описание секций и ключей приведено в таблице 9.5.2.

Табл. 9.5.2. Секции и ключи файла KOMPAS.ini
[Секция]/ключ | Описание
[Directories] | Содержит пути к системным файлам и папкам.
Cfg | Указывает имя конфигурационного файла *.cfg и путь к нему1. В папке, содержащей системный файл *.cfg, разыскиваются и размещаются также конфигурационные файлы библиотек.
Prj | Указывает имя конфигурационного файла *.prj и путь к нему1.
Dsk | Указывает имя конфигурационного файла *.dsk и путь к нему1.
Temp | Указывает, в какой папке нужно размещать временные файлы, а также автоматически сохраненные в процессе работы файлы документов КОМПАС-3D2. При настройке параметров автосохранения (см. раздел 9.1.4.4) эта папка будет предложена в качестве системной папки для временных файлов.
Work | Указывает, в какой папке нужно размещать КОМПАС-документы2. Эта папка будет по умолчанию предложена при первом открытии или сохранении документа.
Sys | Указывает, в какой папке находятся системные файлы2: файлы пользовательских меню, допусков, справочный файл плотностей материалов, библиотеки стилей и т.д. Если требуемый системный файл не будет найден в этой папке, пользователю предоставляется возможность явно указать путь к нему. При настройке текстовых шаблонов, библиотек отверстий и эскизов по умолчанию предполагается размещение файлов Graphic.tdp, holelib.lfr и skchlib.lfr именно в этой папке.
Libs | Указывает, в какой папке находятся файлы библиотек2. Эта папка будет по умолчанию предлагаться первой при добавлении библиотек в Менеджер библиотек.
Templates | Указывает, в какой папке находятся файлы шаблонов КОМПАС-документов2. При создании документов будут предлагаться шаблоны, находящиеся в этой папке. Эта же папка будет по умолчанию предлагаться для размещения вновь создаваемых шаблонов.
Profiles | Указывает, в какой папке находятся файлы профилей2. При выборе профилей будут предлагаться находящиеся в этой папке. Эта же папка будет по умолчанию предлагаться для размещения вновь создаваемых профилей.
SheetMetal | Указывает, в какой папке находятся файлы таблиц сгибов2. При выборе таблицы сгибов будут предлагаться таблицы, находящиеся в этой папке. Эта же папка будет по умолчанию предлагаться при записи в файл таблицы сгибов, хранящейся в детали.
Thread | Указывает, в какой папке находятся файлы таблиц резьб2. При выборе таблицы резьб будут предлагаться таблицы, находящиеся в этой папке
MultilineTemplates | Указывает, в какой папке находятся файлы шаблонов мультилиний2. При создании мультилиний будут предлагаться шаблоны, находящиеся в этой папке. Эта же папка будет по умолчанию предлагаться для размещения вновь создаваемых шаблонов.
PrintDevCfg | Указывает, в какой папке находятся файлы конфигураций устройств печати2. При сохранении конфигураций будет по умолчанию предлагаться эта папка. При загрузке конфигураций будут предлагаться находящиеся в этой же папке.
Pictures | Указывает, в какой папке находятся файлы с примерами изображений, которые можно использовать для проверки гладкости поверхностей деталей способом Отражение среды 2. При загрузке файла изображения по умолчанию предлагается выбрать его из этой папки.
[Windows] | Содержит сведения об отображении заставки КОМПАС-3D при запуске системы.
ShowSplash | Значение YES включает показ заставки, NO — отключает.
[Bmp] | Содержит сведения о максимальном размере блока для вывода растровых и полутоновых изображений на принтер.
MaxBlockSize | Указывает максимальный размер блока (в десятках килобайт). Например, если ключ равен 1000, то растровые и полутоновые изображения выводятся блоками по 10 Мегабайт. Если значение ключа меньше или равно 0, все изображение выводится за один проход.
[FontEscapement] | Содержит сведения о способе вывода текста.
TextAsBitmap | Значение YES включает вывод символов текста в виде растра, NO — отключает. Включение вывода текста в виде растра позволяет решить проблему печати на некоторых плоттерах (например, Calcomp 720C) шрифтов True Type, поставляемых вместе с системой.
[Files] | Содержит пути к файлам с дополнительной информацией.
ExprCollection | Указывает имя файла коллекции математических выражений *.law и путь к нему1.
GeneralTolerance | Указывает имя файла неуказанных предельных отклонений размеров *.ttl и путь к нему. Если указанный файл отсутствует, то общие допуски на размеры моделей не назначаются.
  1. Если указанная папка отсутствует, то она создается.
  2. Если указанная папка отсутствует, то используется другая папка. Путь к ней определяется, как описано в разделе 9.5.4.

В файле KOMPAS.ini для указания расположения папок и файлов возможно использование как абсолютных путей (например, Sys=C:\Program Files\Ascon\Kompas-3D V...\Sys), так и путей относительно папки, содержащей файлы KOMPAS.ini и KOMPAS.exe (например, Sys=..\Sys).

Кроме того, при задании путей возможно использование системных переменных Windows (например, Temp=%Temp%).

Строки, начинающиеся с символа «точка с запятой» (;), считаются комментариями и не учитываются при обработке файла KOMPAS.ini.

Если значение ключа содержит пробел, то оно должно заключаться в кавычки (например, Temp="D:\Рабочие материалы\Временные файлы".

Пример файла KOMPAS.ini:

[Directories]

Sys=..\Sys
Libs=..\Libs
Templates=..\Templates
Cfg=%APPDATA%\Ascon\Kompas-3D\[версия]\tuning.cfg
Prj=%APPDATA%\Ascon\Kompas-3D\[версия]\new.prj
Dsk="%UserProfile%\Local Settings\Application Data\Ascon\Kompas-3D\[версия]\desktop.dsk"
Profiles="%AllUsersProfile%\Application Data\Ascon\Kompas-3D\[версия]\Profiles"
Temp=%Temp%
Work="%UserProfile%\Мои документы"
MultilineTemplates=..\Templates

[Windows]

ShowSplash=YES


9.5.4. Определение путей к системным файлам и папкам. Переменные среды КОМПАС-3D

9.5. Хранение настроек системы

9.5.4. Определение путей к системным файлам и папкам.
Переменные среды КОМПАС-3D

Пути к системным файлам и папкам определяются во время загрузки системы КОМПАС-3D и хранятся до конца сеанса работы в качестве значений переменных среды КОМПАС-3D. Имена и назначение переменных такие же, как у ключей секций [Directories] и [Files] файла KOMPAS.ini (см. табл. 9.5.2).

В приведенных ниже путях к системным файлам и папкам используются следующие параметры:

[APPDATA] — папка, содержащая сведения о приложениях для текущего пользователя <User>;

[COMMON_APPDATA] — папка, содержащая сведения о приложениях, общая для всех пользователей компьютера;

[версия] — номер версии системы в формате «X.X», например: 10.0;

[имя папки] — имя системной папки, совпадающее с именем переменной.

В зависимости от версии операционной системы параметры [COMMON_APPDATA] и [APPDATA] принимают значения, приведенные в табл. 9.5.3).

Табл. 9.5.3. Значения параметров [COMMON_APPDATA] и [APPDATA]
Версия ОС | Значение параметра
 | [COMMON_APPDATA]
Windows XP | C:\documents and settings\all users\application data
Windows Vista, Windows 7, Windows 8 | C:\ProgramData
 | [APPDATA]
Windows XP | C:\documents and settings\[user]\application data
Windows Vista, Windows 7, Windows 8 | C:\Users\<User>\AppData\Roaming

Порядок определения путей к системным файлам и папкам:

1. Поиск файла KOMPAS.ini, а в нем — пути к системному файлу (папке). Если файл KOMPAS.ini присутствует и содержит нужный путь, то этот путь становится значением соответствующей переменной среды. Файл KOMPAS.ini подробно описан в разделе 9.5.3.

2. Если файл KOMPAS.ini отсутствует или не содержит нужного пути, то путь определяется следующим образом:

 2.1. Для переменных Cfg,
Prj, Dsk:
Cfg=[APPDATA]\Ascon\Kompas-3D\[версия]\Kompas.cfg
Prj=[APPDATA]\Ascon\Kompas-3D\[версия]\Kompas.prj
Dsk=[APPDATA]\Ascon\Kompas-3D\[версия]\Kompas.dsk

Если папка [APPDATA]\Ascon\Kompas-3D \[версия] не существует, то она будет создана при записи конфигурационного файла.

2.2. Для переменных Sys, Libs, Templates, Profiles:

• Проверяется наличие папки
[APPDATA]\Ascon\Kompas-3D \[версия]\[имя папки].

Если она существует, то
[имя переменной]=[APPDATA]\Ascon\Kompas-3D\[версия]\[имя папки], например:
Sys=C:\Documents and Settings\sidorov\Application Data\ASCON\Kompas-3D\12.0\Sys.

• Если указанная папка не существует, то проверяется наличие папки
[COMMON_APPDATA]\Ascon\Kompas-3D\[версия]\[имя папки].

Если она существует, то
[имя переменной]=[COMMON_APPDATA]\Ascon\Kompas-3D\[версия]\[имя папки], например:
Sys=C:\Documents and Settings\All Users\Application Data\ASCON\Kompas-3D\12.0\Sys.

• Если указанная папка не существует, то проверяется наличие папки [имя папки] по пути относительно файла KOMPAS.exe (т.е. в папке, содержащей папку с файлом KOMPAS.exe).

Если она существует, то
[имя переменной]=[путь к папке, содержащей папку с KOMPAS.exe]\[имя папки], например:
Sys=C:\Program Files\ASCON\KOMPAS-3D V13\Sys.

• Если указанная папка не существует, то значением переменной становится путь к папке с файлом KOMPAS.exe, например,
Sys=C:\Program Files\ASCON\KOMPAS-3D V13\Bin.

2.3. Для переменной MultilineTemplates:

Порядок определения пути такой же, как для переменной Templates.

2.4. Для переменных SheetMetal и Thread:

• Проверяется наличие папки
[APPDATA]\Ascon\Kompas-3D\[версия]\Sys\[имя папки].

Если она существует, то
[имя переменной]=[APPDATA]\Ascon\Kompas-3D\[версия]\Sys\[имя папки].

• Если указанная папка не существует, то проверяется наличие папки
[COMMON_APPDATA]\Ascon\Kompas-3D\[версия]\Sys\[имя папки].

Если она существует, то
[имя переменной]=[COMMON_APPDATA]\Ascon\Kompas-3D\[версия]\Sys\[имя папки].

• Если указанная папка не существует, то проверяется наличие папки \Sys\ [имя папки] по пути относительно файла KOMPAS.exe (т.е. в папке, содержащей папку с файлом KOMPAS.exe).

Если она существует, то
[имя переменной]=..\Sys\[имя папки].

• Если указанная папка не существует, то значением переменной становится путь к папке с файлом Kompas.exe.

2.5. Для переменной Temp:

Temp=%Temp%
Если переменная среды Temp (TMP) определена для текущего пользователя, то используется эта переменная, например:
Temp="%UserProfile%\Local Settings\Temp".
В противном случае используется системная переменная Temp (TMP), например, Temp=%SystemRoot%\Temp.

2.6. Для переменных Work и PrintDevCfg:

Work="%UserProfile%\Мои документы",
PrintDevCfg="%UserProfile%\Мои документы".

2.7. Для переменной Pictures:

• Проверяется наличие папки \Samples\Surfaces\Maps по пути относительно файла KOMPAS.exe (т.е. в папке, содержащей папку с файлом KOMPAS.exe).

Если она существует, то
Pictures=..\Samples\Surfaces\Maps.

• Если указанная папка не существует, то
Pictures="%UserProfile%\Мои документы".

2.8. Для переменной ExprCollection:

ExprCollection=[APPDATA]\Ascon\Kompas-3D\[версия]\collection.law.

2.9. Для переменной GeneralTolerance:

• Проверяется наличие папки
[APPDATA]\Ascon\Kompas-3D\[версия]\Sys.

Если она существует, то
GeneralTolerance=[APPDATA]\Ascon\Kompas-3D\[версия]\\Sys\gen_tol.ttl.

• Если указанная папка не существует, то проверяется наличие папки
[COMMON_APPDATA]\Ascon\Kompas-3D\[версия]\Sys.

Если она существует, то
GeneralTolerance=[COMMON_APPDATA]\Ascon\Kompas-3D\[версия]\Sys\gen_tol.ttl.

• Если указанная папка не существует, то проверяется наличие папки \Sys по пути относительно файла KOMPAS.exe (т.е. в папке, содержащей папку с файлом KOMPAS.exe).

Если она существует, то
GeneralTolerance=..\Sys\gen_tol.ttl.

• Если указанная папка не существует, то считается, что файл gen_tol.ttl находится в одной папке с файлом Kompas.exe, например:
Sys=C:\Program Files\ASCON\KOMPAS-3D V14\Bin\gen_tol.ttl.

Обратите внимание на то, что при отсутствии файла KOMPAS.ini файл неуказанных предельных отклонений может иметь только умолчательное имя — gen_tol.ttl. Если требуется, чтобы файл отклонений назывался по-другому, для указания его имени и расположения следует использовать KOMPAS.ini.


9.5.5. Служебные файлы

9.5. Хранение настроек системы

9.5.5. Служебные файлы

В этом разделе:

9.5.5.1. Файл пользовательских меню

9.5.5.1.1. Структура файла

9.5.5.1.2. Синтаксис файла

9.5.5.2. Справочный файл плотностей

9.5.5.3. Файл кодов и наименований

9.5.5.4. Файл, определяющий порядок сортировки по коду

9.5.5.5. Файл конфигурации Менеджера библиотек


9.5.5.1. Файл пользовательских меню

Файл пользовательских меню — файл, описывающий меню, команды которых предназначены для вставки текстовых фрагментов в различные надписи. Этот файл называется Grарhic.рmn и располагается в подпапке \Sys главной папки КОМПАС-3D.

Рис. 9.5.1. Пользовательское меню при вводе надписи
в обозначении шероховатости

Примерами меню, описанных в файле Grарhic.рmn, являются меню, вызываемые по двойному щелчку левой кнопки мыши в следующих случаях:

– работа с диалогом ввода надписи специального знака (рис. 9.5.1), допуска формы и т.п.,

– заполнение основной надписи документа (рис. 9.5.2).

Рис. 9.5.2. Пользовательское меню при заполнении основной надписи чертежа

Grарhic.рmn — текстовый файл, доступный для непосредственного редактирования пользователем.

Редактируя этот файл, пользователь может, например, настроить меню, появляющееся при заполнении основной надписи так, чтобы оно содержало необходимые фамилии и инициалы должностных лиц, дополнить список масштабов и т.п.

Пользователь может также создавать новые разделы в файле Grарhic.рmn, описывающие меню, доступные при вводе текста в графы оригинальных (пользовательских) основных надписей (см. раздел 11.2.1.5.2).

Если во время редактирования файла Graphics.pmn система КОМПАС-3D была запущена, то внесенные в файл изменения станут доступными после перезапуска системы КОМПАС-3D.

В этом разделе:

9.5.5.1.1. Структура файла

9.5.5.1.2. Синтаксис файла


9.5.5.1.1. Структура файла

Файл состоит из разделов. Вы можете добавить в файл собственные разделы. Рекомендуется присваивать им номера от 1001 до 4000.

Номера разделов с 1 по 1000 зарезервированы за компанией АСКОН. Не используйте их во избежание конфликтов составленных вами меню с новыми версиями файла Graphic.pmn, поставляемыми в дистрибутиве системы.


9.5.5.1.2. Синтаксис файла

Файл пользовательских меню позволяет формировать иерархическую структуру меню. Он состоит из отдельных строк. Строка может описывать раздел или команду меню. Строки могут быть снабжены комментариями. Комментарии не отображаются на экране и не вставляются в документ. Комментарием является строка, расположенная после символа ' (апостроф). Например, в строке MENU 2 'Параметр шероховатости комментарием является Параметр шероховатости.

Каждый раздел файла имеет заголовок MENU num, где num — номер раздела.

Раздел файла должен начинаться с ключевого слова BEGIN и заканчиваться словом END. Строки, находящиеся между этими словами (внутри раздела), будут показываться в пользовательском меню.

Внутри раздела перечисляются строки меню (отдельные команды) и вложенные в раздел подменю (названия групп команд), которые, в свою очередь, также могут содержать строки меню и подменю.

Строка меню записывается в виде:

MENUITEM "nаme" FLАGS, где

name — имя меню,

FLAGS — комбинация флагов (см. табл. 9.5.7).

Вложенный раздел меню — подменю — записывается в виде:

РOРUР "nаme", где

name — имя подменю (оно появляется в меню).

Подменю, как и содержащее его меню, должно начинаться со слова BEGIN, заканчиваться словом END и содержать строки меню (MENUITEM) и вложенные подменю (РOРUР).

Порядок формирования имени nаme в строке меню или подменю:

nаme = nаme1|nаme2, где

nаme1 — подстрока, которая появится в меню, т.е. название команды,

nаme2 — подстрока, которая будет подставлена в текст при выборе команды.

Если имя nаme состоит из одной подстроки (имеет вид nаme = nаme), то эта подстрока появится в меню и будет подставлена в текст.

Подстрока nаme1 может содержать управляющий символ &. Символ, следующий за ним, подчеркивается — он будет служить акселератором. Символ-акселератор позволяет вызвать команду с помощью клавиатуры, нажав соответствующую клавишу. Меню, содержащее вызываемую команду, при этом должно отображаться на экране. Например, в файле Graphic.pmn есть строка MENUITEM "&Полировать|Полировать". В пользовательском меню она появляется в виде Полировать, а буква «П» будет служить акселератором, т.е. после вызова меню, содержащего команду Полировать, для вызова этой команды достаточно будет нажать на клавиатуре клавишу <П>.

Подстрока nаme2 может содержать различные управляющие символы, которые определяют вид строки, подставляемой в текст. Ниже даны варианты конструкций с использованием этих управляющих символов и описано назначение каждой конструкции.

1. Вставка индексов

Конструкция вида $XX;YY$ позволяет вставить в документ верхний и нижний индексы.

Подстрока, введенная после первого символа $, будет вставлена в документ в виде верхнего индекса. Если после первого символа $ введен символ ;, то подстрока после этого символа будет вставлена в виде нижнего индекса. Следующий символ $ завершает ввод индексов. Если символ ; отсутствует или между ним и завершающим $ находится пустая строка, будет вставлен только верхний индекс. Если между первым $ и ; находится пустая строка, будет вставлен только нижний индекс.

Строка меню АА$XX;YY$BB будет вставлена в документ в виде:

Строка меню может содержать несколько индексов. При этом необходимо, чтобы $, открывающий индекс, был отделен от $, закрывающего предыдущий индекс, хотя бы одним знаком. Если строка меню содержит последовательность $$, то в документ будет вставлен одиночный символ $.

Символы s, m или l позволяют управлять размером символов индекса. Они должны располагаться после управляющего символа $. Действие символов, управляющих размером, распространяется на весь индекс. Текст после s будет иметь малую, m — среднюю, l — полную высоту. По умолчанию текст индекса имеет полную высоту.

Пример ввода индексов и управления размером индекса приведен в табл. 9.5.4.

Табл. 9.5.4. Вставка индексов в документ; управление размером индекса
Строка меню | Отображаемая команда меню | Строка, вставленная в документ | Высота индекса
MENUITEM "L min в кубе|L$3;min$" | L min в кубе |  | полная
MENUITEM "L min в кубе|L$l3;min$"
MENUITEM "L min в кубе|L$s3;min$" | L min в кубе |  | малая

2. Вставка дробей

Конструкция вида $bXX;YY$ или $dXX;YY$ позволяет вставить в документ дробь.

Подстрока, введенная после символа $b или $d, будет вставлена в документ в виде числителя дроби. Если после символа $b ($d) введен символ ;, то подстрока после этого символа будет вставлена в виде знаменателя дроби. Следующий символ $ завершает ввод дроби. Если символ ; отсутствует или между ним и $ находится пустая строка, дробь имеет только числитель. Если между $b ($d) и ; находится пустая строка, дробь имеет только знаменатель.

Строка меню АА$dXX;YY$BB или АА$bXX;YY$BB будет вставлена в документ в виде:

Символы s, m или l позволяют управлять размером символов дроби. Они должны располагаться после управляющего символа $b ($d). Действие символов, управляющих размером, распространяется на всю дробь. Текст после s будет иметь малую, m — среднюю, l — полную высоту. По умолчанию дроби имеет полную высоту.

Пример ввода дробей и управления размером дроби приведен в табл. 9.5.5.

Табл. 9.5.5. Вставка дробей в документ; управление размером дроби
Строка меню | Отображаемая команда меню | Строка, вставленная в документ | Высота дроби
MENUITEM "Посадка с зазором H7/h6|$bH7;h6$" | Посадка с зазором H7/h6 |  | полная
MENUITEM "Посадка с зазором H7/h6|$blH7;h6$"
MENUITEM "Посадка с зазором H7/h6|$bmH7;h6$" | Посадка с зазором H7/h6 |  | малая

Строка меню может содержать несколько дробей.

3. Вставка спецзнаков и символов

В конструкциях для вставки спецзнаков и символов используется знак ~ (тильда). Он служит признаком окончания номера спецзнака или кода символа.

3.1. Вставка спецзнаков системы КОМПАС

АА@+XXXXX~BB

В текст будет вставлена строка вида
АА <спецзнак №XXXХХ из файла Graphic.sss> BB.

Номера, изображения и названия спецзнаков приведены в Приложении V.

Например, в файле Graphic.pmn есть строка
MENUITEM "2 отверстия диаметра 20|2 отв. @+2~20".

В пользовательском меню она появляется в виде
2 отверстия диаметра 20.

В текст при ее выборе будет внесена строка

Таким образом, конструкция @+2 в файле Graphic.pmn заменяет значок диаметра.

Спецзнаки №№ 78–80, 83, 93–99, 171, 172 содержат текст (например, № 80 — текст в рамке). Этот текст, в свою очередь, может содержать другие спецзнаки.

Все символы, стоящие в подстроке name2 после номера любого спецзнака, содержащего текст, считаются формирующими текст данного спецзнака (включая управляющие символы).

Например, в файле Graphic.pmn есть строка
MENUITEM "Корень из одной третьей|@+98~$b1;3$".

В пользовательском меню она появляется в виде
Корень из одной третьей.

В текст при ее выборе будет внесена строка

Наибольший допустимый номер спецзнака — 65536.
Если в качестве номера спецзнака задано число большее 65536, то номер находится как остаток от целочисленного деления заданного числа на 65536.

3.2. Вставка символов из шрифтов, установленных в операционной системе

АА^(FNAME)YXXXXX~BB

В текст будет вставлена строка вида
АА <символ с кодом XXХXХ из шрифта FNAME> BB

Символ Y в конструкции YXXXXX обозначает модификатор представления кода. Модификатор показывает, в какой системе счисления представлен код символа — шестнадцатиричной или десятичной (табл. 9.5.6).

Табл. 9.5.6. Модификаторы представления кода символа
Модификатор | Система счисления | Примечания | Пример
* | Шестнадцати-ричная | Максимальное число знаков — 4. Регистр букв A, B, C, D, E, F значения не имеет. | *221E
+ | Десятичная | Максимальное число знаков — 5. Наибольшее значение кода — 65536; если в качестве кода символа задано число большее 65536, то код находится как остаток от целочисленного деления заданного числа на 65536. | +61448

Чтобы определить имя шрифта, начертание и код символа, можно использовать, например, стандартное приложение Windows Таблица символов (рис. 9.5.3).

Рис. 9.5.3. Окно приложения Таблица символов

Например, в файле Graphic.pmn есть строка
MENUITEM "Число оборотов барабана при макс. деформации|^(Symbol Type A)+121~$m*;3$".

В пользовательском меню она появляется в виде
Число оборотов барабана при макс. деформации.

В текст при ее выборе будет вставлена строка

3.3. Вставка символов из текущего шрифта

АА^YXXXXX~BB

В текст будет вставлена строка вида
АА <символ с кодом XXXXX из текущего шрифта текста> BB

Символ Y в конструкции YXXXXX обозначает модификатор представления кода. Модификатор показывает, в какой системе счисления представлен код символа — шестнадцатиричной или десятичной (см. табл. 9.5.6).

Чтобы определить начертание и код символа, можно использовать, например, стандартное приложение Windows Таблица символов (см. рис. 9.5.3).

Если в текст требуется вставить сами символы @, ^, ~, $, & из текущего шрифта, то вместо конструкции ^YXXXXX~ можно использовать конструкции @@, ^^, ~~, $$, && соответственно.

Вместо основных конструкций для вставки спецзнаков и символов — АА@YXXXXX~BB, АА^(FNAME)YXXXXX~BB и АА^YXXXXX~BB — могут использоваться дополнительные: АА&XX~BB, АА#(FNAME)XX~BB и АА#XX~BB соответственно. Отличия дополнительных конструкций от основных:

– для записи номера спецзнака или кода символа может использоваться только два знака, а не пять,

– в конструкциях для вставки символа отсутствует модификатор; заданный код считается представленным в десятичной системе счисления.

4. Вставка переноса строки

АА@/BB

В текст будут вставлены две строки: АА и BB.

Например, в файле Graphic.pmn есть строка
MENUITEM "Вентиль запорный угловой| Вентиль запорный@/угловой".

В пользовательском меню она появляется в виде
Вентиль запорный угловой.

В документ при ее выборе будут внесены две строки:
Вентиль запорный
угловой

Таким образом, конструкция @/ в файле Graphic.pmn является знаком переноса строки.

Если ячейка таблицы основной надписи настроена для ввода однострочного текста, перенос строк будет проигнорирован.

Табл. 9.5.7. Флаги для MENUITEM
Флаг | Назначение
SEРАRАTOR | Отрисовка горизонтальной линии-разделителя. Любой текст и флаги игнорируются.
MENUBREАK | Помещение команды меню в новую колонку.
DISАBLED или GRАYED | Команда меню недоступна для выполнения и отображается серым цветом.

Допускается комбинация флагов, разделенных пробелами или запятыми.

Ниже приведен фрагмент файла Grарhic.рmn, на примере которого вы можете ознакомиться со структурой и синтаксисом этого файла.

MENU 12

BEGIN

MENUITEM "Меню, настраиваемое пользователем (Grарhic.рmn MENU 12)" GRAYED

MENUITEM SEРАRАTOR

MENUITEM "&Николаева И.В. Вице-президент|Николаева"

MENUITEM SEРАRАTOR

РOРUР "Разработчики"

BEGIN

MENUITEM "&Поликарпов П.П. Нач. отдела|Поликарпов"

MENUITEM SEРАRАTOR

MENUITEM "&Иванов И.И.|Иванов"

MENUITEM "П&етров П.П.|Петров"

MENUITEM "&Сидоров С.С.|Сидоров"

END

РOРUР "Технологи"

BEGIN

MENUITEM "&Семенов Ю.Ю. Нач. отдела|Семенов"

MENUITEM SEРАRАTOR

MENUITEM "&Дубинина А.Б.|Дубинина"

MENUITEM "&Петрова М.Я.|Петрова"

MENUITEM "П&оловинин И.И.|Половинин"

END

РOРUР "Нормоконтроль"

BEGIN

MENUITEM "&Буянов М.Ю. Нач. отдела|Буянов"

MENUITEM SEРАRАTOR

MENUITEM "&Поликарпов П.П.|Поликарпов"

MENUITEM "&Самохвалов А.А.|Самохвалов"

END

END

Этому разделу файла пользовательского меню соответствует меню, вызываемое при вводе фамилий должностных лиц в графы основной надписи (рис. 9.5.2).

При редактировании файла пользовательского меню нужно помнить, что некоторые его разделы используются системой для полуавтоматического ввода текста при простановке размеров и технологических обозначений (например, из пользовательского меню можно выбрать значение параметра шероховатости). Редактировать соответствующие разделы не рекомендуется, т.к. они содержат стандартные тексты и значения.


9.5.5.2. Справочный файл плотностей

При расчетах МЦХ тел вращения и выдавливания вы можете не вводить значение плотности материала вручную, а выбрать его из специального справочного файла.

Этот же файл можно использовать для выбора материала, заменителя материала и покрытия при настройке свойств моделей. В этом случае выбор материала позволяет задать не только плотность, но и предопределенный стиль штриховки (системный или пользовательский), отображаемый на разрезах/сечениях в ассоциативных видах чертежей.

Наименования материалов и соответствующие им значения плотностей, а также ссылки на стили штриховок хранятся в файле Grарhic.dns, расположенном в подпапке \Sys главной папки КОМПАС-3D.

Файл Grарhic.dns — текстовый файл, доступный для непосредственного редактирования пользователем.

Разделы в файле открываются и закрываются символами «{» и «}» соответственно. Название раздела должно находиться на той же строке, что и открывающая скобка. Разделы могут быть вложенными. Пробелы не являются значащими символами и не влияют на последующее отображение строк в справочном диалоге на экране.

Ниже приводится фрагмент файла Grарhic.dns, который описывает раздел Металлы, содержащий два подраздела — Алюминиевые сплавы и Бронзы.

{ Металлы

{ Алюминиевые сплавы

АД0 ГОСТ 4784-97 = 2.71 | 0

АД1 ГОСТ 4784-97 = 2.71 | 0

Д1 ГОСТ 4784-97 = 2.80 | 0

}

{ Бронзы

БрАЖ9-4 ГОСТ 18175-78 = 7.50 | 0

БрАЖМц10-3-1.5 ГОСТ 18175-78 = 7.50 | 0

БрКМц3-1 ГОСТ 18175-78 = 8.40 | 0

}

Пользователь может отредактировать файл плотностей, например, изменив записи в строках или добавив новые.

Строка файла плотностей формируется по следующему правилу:

<Обозначение материала> = <плотность> | <имя файла> | <номер>

Обозначение материала — запись, которая отображается в свойствах материала.

Плотность — числовое значение плотности в г/см3.

Имя файла — имя файла библиотеки, содержащей стиль штриховки, в одном из вариантов:

– полное,

– краткое, если файл находится в подпапке \Sys главной папки КОМПАС-3D,

– имя файла отсутствует, если стиль системный.

Номер — номер стиля в библиотеке стилей штриховок или номер системного стиля.

| — знак разделителя.

Ниже приводятся примеры строк с полным, кратким именем файла и без имени.

Полистирол = 1.06 | d:\work\styles.lhs | 501

Полистирол = 1.06 | graphic.lhs | 25

Полистирол = 1.06 | 1

О создании пользовательских стилей штриховок и сохранении их в библиотеку см. раздел 11.1.1.2.2.

Список системных стилей штриховок и их номеров:

Металл 0

Неметалл 1

Камень естественный 2

Керамика 3

Бетон 4

Стекло 5

Жидкость 6

Естественный грунт 7

Насыпной грунт 8

Камень искусственный 9

Железобетон 10

Напряженный железобетон 11

Дерево в продольном сечении 12

Дерево 13

Песок 14


9.5.5.3. Файл кодов и наименований

Номенклатура конструкторских документов установлена ГОСТ 2.102–68. Согласно этому стандарту каждому типу документа соответствуют определенные код и наименование. При работе с КОМПАС-3D коды и наименования неосновных конструкторских, эксплуатационных, ремонтных документов и схем извлекаются из файла Graphic.kds.

Содержимым этого файла определяются:

– наполнение диалога Коды и наименования, возникающего после вызова команды вставки кода и наименования,

– стандартные коды и наименования, используемые

• при автоматическом заполнении основной надписи спецификации,

• при отключении показа наименования изделия в объекте спецификации,

• при синхронизации основной надписи чертежа и модели.

Изменение файла Graphic.kds средствами КОМПАС-3D невозможно. Однако файл является текстовым, поэтому он может быть открыт и отредактирован любым текстовым редактором, например, Блокнотом, входящим в состав Windows.

Разделы в файле открываются и закрываются символами { и } соответственно. Название раздела должно находиться на той же строке, что и открывающая скобка. Разделы могут быть вложенными. Это позволяет формировать древовидную структуру типов документов. Пробелы не являются значащими символами и не влияют на отображение строк в диалоге.

Если во время редактирования файла graphic.kds система КОМПАС-3D была запущена, то внесенные в файл изменения станут доступными после перезапуска системы.

Ниже приводится фрагмент файла Graphic.kds, который описывает раздел Документы ремонтные диалога Коды и наименования (рис. 9.5.4). Этот раздел содержит подразделы:

– Капитальный ремонт;

– Средний ремонт.

Пример показывает соответствие структуры и содержимого файла Graphic.kds структуре и содержимому диалога.

Рис. 9.5.4. Диалог Коды и наименования; раздел Документы ремонтные

{Документы ремонтные

{Капитальный ремонт

РК = Руководство по ремонту

УК = Технические условия на ремонт

ЗК = Нормы расхода запасных частей на ремонт

МК = Нормы расхода материалов на ремонт

ЗИК = Ведомость ЗИП на ремонт

ВРК = Ведомость документов для ремонта

}

{Средний ремонт

РС = Руководство по ремонту

УС = Технические условия на ремонт

ЗС = Нормы расхода запасных частей на ремонт

МС = Нормы расхода материалов на ремонт

ЗИС = Ведомость ЗИП на ремонт

ВРС = Ведомость документов для ремонта

}

Файл Graphic.kds должен находиться в папке, путь к которой указан системной переменной SYS. По умолчанию это папка \Sys системы КОМПАС-3D.

Наличие файла кодов и наименований проверяется системой в следующих случаях:

– при вызове команды вставки кодов и наименований,

– при создании объекта спецификации в чертеже с заполненной основной надписью,

– при переходе в подчиненный режим работы с объектами спецификации в чертеже с заполненной основной надписью,

– при открытии чертежа с заполненной основной надписью и с таблицей спецификации на листе,

– при открытии спецификации, имеющей хотя бы один объект и заполненную основную надпись,

– при открытии спецификации, основная надпись которой связана с подключенным к ней документом.

Наличие файла кодов и наименований проверяется один раз за сеанс работы, т.е. в том из перечисленных случаев, который наступит раньше.

Если файл Graphic.kds отсутствует в папке, которая задана по умолчанию, то на экране появляется диалог, показанный на рисунке 9.5.5.

Кнопки этого диалога описаны в таблице 9.5.8.

Рис. 9.5.5. Диалог замены файла кодов и наименований

Табл. 9.5.8. Кнопки диалога замены файла кодов и наименований

Кнопка

Позволяет

Изменить путь

Искать файл кодов и наименований на диске. После нажатия этой кнопки на экране появляется стандартный диалог открытия файлов Windows. Вы можете указать любой файл (в том числе с расширением, отличным от kds), структура которого соответствует структуре файла кодов и наименований.

Указанный файл используется только в текущем сеансе работы. При следующем запуске система снова будет разыскивать файл Graphic.kds в папке, указанной в переменной SYS.

Игнорировать

Отказаться от использования файла Graphic.kds в текущем сеансе работы. После нажатия этой кнопки автоматизированный ввод и обработка кодов и наименований будут невозможны до конца сеанса.

Порядок следования кодов, используемый для сортировки объектов спецификации в разделе Документация (см.раздел 6.1.2.6.4), определяется файлом graphic.kdsp. По умолчанию он находится в подпапке \Sys главной папки системы. Формат файла — текстовый, поэтому при необходимости он может быть открыт и отредактирован в любом текстовом редакторе.


9.5.5.4. Файл, определяющий порядок сортировки по коду

Если в спецификации для раздела Документация включена автоматическая сортировка, то объекты внутри раздела сортируются с учетом кода документа, см. раздел 6.1.2.6.4. Порядок следования кодов определяется файлом graphic.kdsp, входящим в комплект поставки.

Файл graphic.kdsp содержит перечень кодов документов в том порядке, в котором они перечислены в ГОСТ 2.102-2013. Формат файла — текстовый, поэтому при необходимости файл может быть открыт и отредактирован в любом текстовом редакторе.

Файл graphic.kdsp должен находиться в папке, путь к которой указан системной переменной SYS. По умолчанию это папка \Sys системы КОМПАС-3D. В отсутствие файла graphic.kdsp объекты раздела Документация сортируются по коду в алфавитном порядке.

Если во время редактирования файла graphic.kdsp система КОМПАС-3D была запущена, то внесенные в файл изменения будут учитываться после перезапуска системы.


9.5.5.5. Файл конфигурации Менеджера библиотек

Файлы конфигурации Менеджера библиотек содержат описание структуры Менеджера библиотек. Они имеют расширение lms. Эти файлы используются в следующих случаях:

– первоначальное наполнение Менеджера библиотек,

– выполнение команды Обновить Менеджер библиотек.

При запуске Менеджера библиотек или вызове команды Обновить менеджер библиотек выполняются следующие действия.

– Анализ файла конфигурации.

– Проверка наличия файлов библиотек, указанных в файле конфигурации, в папке \Libs системы КОМПАС.

– Добавление найденных файлов в Менеджер библиотек в соответствии с заданной структурой.

Если перед вызовом команды Обновить менеджер библиотек в Менеджере были библиотеки, которые не описаны в файле конфигурации, они остаются без изменений. Если в Менеджере были библиотеки, которые описаны в файле конфигурации, но расположены по путям, которые не соответствуют этому файлу, их положение в Менеджере не изменится. Повторное добавление библиотек не выполняется.

Изменение файла конфигурации средствами КОМПАС-3D невозможно. Однако файл является текстовым, поэтому он может быть создан или отредактирован любым текстовым редактором, например, Блокнотом, входящим в состав Windows.

Файлов конфигурации может быть несколько. Состав Менеджера библиотек формируется с использованием содержания всех файлов конфигурации. Пользовательским файлам конфигурации Менеджера библиотек необходимо присваивать расширение lms и сохранять в папке \Sys системы КОМПАС.

Каждая строка файла содержит описание подключаемой библиотеки и состоит из следующих частей:

– путь к библиотеке в Менеджере,

– имя файла библиотеки,

– комментарий.

Части строки файла предваряются следующими условными обозначениями:

– /d- путь к библиотеке в Менеджере; элементы пути разделяются вертикальной чертой |,

– /f- имя файла библиотеки,

– /c- комментарий.

Ниже приводится фрагмент файла Graphic.lms, входящего в комплект поставки КОМПАС-3D.

/d-Примеры библиотек|Обозначения/f-Graphic.lfr/c-Библиотека конструктивных элементов

/d-Примеры библиотек|Обозначения/f-Tech.lfr/c-Библиотека технологических обозначений

Пример структуры Менеджера библиотек, сформированной в соответствии с этим фрагментом, изображен на рис. 9.5.6.

Рис. 9.5.6. Пример структуры Менеджера библиотек


9.5.6. Рекомендуемая настройка системы КОМПАС-3D при коллективной работе

9.5. Хранение настроек системы

9.5.6. Рекомендуемая настройка системы КОМПАС-3D
при коллективной работе

В настоящем разделе даны некоторые рекомендации по организации коллективной работы пользователей в системе КОМПАС-3D. Прежде, чем приступать к выполнению этих рекомендаций, необходимо ознакомиться с разделами 9.5.1–9.5.4.

Использование предлагаемых рекомендаций позволяет организовать работу в системе КОМПАС-3D таким образом, чтобы выполнялись следующие требования.

– Единство оформления всех выпускаемых документов (как бумажных, так и электронных): некоторые предприятия имеют собственные стандарты на документацию, корпоративные шаблоны, формы и т.п.

– Централизованное хранение документации.

Для настройки системы КОМПАС-3D при коллективной работе выполните следующие действия.

1. На каком-либо компьютере сети (например, на сервере) организуйте общий ресурс. Он должен быть разделен на четыре части:

• папка для оригиналов документов,

• папка для резервных копий документов,

• папка для конфигурационных файлов,

• папка для системных файлов.

2. Подключите созданный общий ресурс к рабочим местам КОМПАС-3D как сетевой диск — это упростит смену расположения ресурса, если она потребуется.

3. На одном из рабочих мест выполните настройку системы КОМПАС-3D требуемым образом. Особое внимание обратите на следующие объекты настройки.

– Установка прав доступа (см. раздел 9.1.4.2).

– Резервное копирование (см. раздел 9.1.4.3). Для размещения копий указывайте подпапки папки для резервных копий, расположенной на общем ресурсе.

Настройки системы будут сохранены в файле *.cfg. По умолчанию он называется KOMPAS.cfg.

4. Перенесите файл *.cfg, содержащий сделанные настройки, в папку для конфигурационных файлов, расположенную на общем ресурсе.

5. На одном из рабочих мест КОМПАС-3D настройте оформления документов, стили, текстовые шаблоны, пользовательские меню и другие системные файлы, входящие в поставку (по умолчанию все эти файлы располагаются в подпапке \SYS главной папки системы). При необходимости вы можете создать собственные библиотеки оформлений и стилей.

6. Перенесите все содержимое папки \SYS (в том числе отредактированные или созданные вами файлы) в папку для системных файлов, расположенную на общем ресурсе.

7. Настройте новые документы с учетом требований, предъявляемых к документации на вашем предприятии.

Настройки новых документов будут сохранены в файле *.prj. По умолчанию он называется KOMPAS.prj.

Выполнение настроек, перечисленных в пп. 5 и 7, требует опыта работы с системой КОМПАС.

8. Перенесите файл *.prj, содержащий сделанные настройки, в папку для конфигурационных файлов, расположенную на общем ресурсе.

9. Создайте файл KOMPAS.ini с секцией [Directories].

9.1. В ключе CFG укажите путь к файлу *.cfg.

9.1. В ключе PRJ укажите путь к файлу *.prj.

9.2. В ключе SYS укажите путь к папке для системных файлов.

9.3. В ключе WORK укажите путь к папке для оригиналов документов.

10. Скопируйте полученный файл KOMPAS.ini на каждое рабочее место КОМПАС, разместив его в той же папке, где находится файл KOMPAS.exe.

Единство оформления документов при использовании описанной настройки достигается за счет следующих факторов:

– на всех рабочих местах одинаковы настройки вновь создаваемых документов, поскольку эти параметры берутся из одного и того же файла *.prj,

– оформления документов, начертание линий, текстов, штриховок, вид и содержимое шаблонных надписей и других стандартных объектов одинаковы, так как используются одни и те же системные файлы,

– толщина линий в бумажных документах, а также набор выводимых на печать объектов одинаковы, так как соответствующая информация берется из одного и того же файла *.cfg.

Для достижения единства оформления документации можно использовать шаблоны КОМПАС-документов.

Создав необходимые шаблоны (или отредактировав входящие в поставку), разместите их в отдельной папке на общем ресурсе. Для упорядочения массы шаблонов и удобства их поиска эта папка может иметь подпапки.

В ключе TEMPLATES в секции [Directories] файла KOMPAS.ini укажите путь к папке шаблонов.

Централизованное хранение документации при использовании описанной настройки достигается благодаря тому, что при открытии и сохранении документов на всех рабочих местах автоматически предлагается одна и та же папка — папка для оригиналов документов.

Чтобы управление документами (поиск, архивирование и др.) было более удобным, рекомендуется хранить их упорядоченно. Можно распределять документы по папкам в соответствии с принадлежностью их к тому или иному проекту и т.п.


10.1. Импорт и экспорт

В этом разделе:

10.1.1. Импорт и экспорт графических документов

10.1.1.1. Импорт

10.1.1.2. Экспорт

10.1.2. Импорт и экспорт моделей

10.1.2.1. Импорт

10.1.2.1.1. Особенности импорта объектов модели

10.1.2.2. Экспорт

10.1.2.2.1. Особенности экспорта объектов модели

10.1.3. Сохранение в растровый формат и формат PDF

10.1.3.1. Чертеж, фрагмент, модель

10.1.3.2. Многолистовой чертеж

10.1.3.3. Текстовый документ, спецификация

10.1.3.4. Условия, определяющие возможность записи в растровый формат


10.1.1. Импорт и экспорт графических документов

10.1. Импорт и экспорт

10.1.1. Импорт и экспорт графических документов

Обмен графическими документами между КОМПАС-3D и другими системами возможен через форматы, представленные в таблице 10.1.1. Числа в колонках «Импорт» и «Экспорт» таблицы означают номер версии формата, причем импорт возможен как указанной, так и всех предыдущих версий формата, а экспорт производится только в указанную версию (версии) формата.

Табл. 10.1.1. Форматы обмена графикой
Формат | Импорт | Экспорт
IGES (*.igs) | 5.3 | 5.3
AutoCAD DXF (*.dxf), AutoCAD DWG (*.dwg) | 2013 | 2000, 2004, 2007, 2010, 2013 (версию выбирает пользователь при настройке экспорта)

Кроме того, возможно чтение текстовых документов форматов txt и rtf.

Запись графических и текстовых документов КОМПАС-3D V16 возможна также в:

– форматы предыдущих версий КОМПАС-3D: КОМПАС 5.11 R03, КОМПАС-3D V14 SP2 и КОМПАС-3D V15.1,

– растровые форматы (GIF, JPEG и др.),

– формат Enhanced Metafile (*.emf),

– Portable Document Format (*.pdf)

– формат txt (только для текстовых документов).

В результате экспорта формируется документ выбранного формата, сохраняющий визуальную идентичность исходному. Однако структура и внутренние связи объектов документа системы КОМПАС-3D и аналогичных объектов в новом формате могут отличаться. В качестве примера таких объектов можно привести элементы оформления чертежа: размеры, линии-выноски и т.п. При редактировании полученного документа внешний вид подобных объектов может измениться таким образом, что они утратят идентичность объектам исходного документа. Аналогичные изменения объектов могут произойти при многократном конвертировании документа из формата системы КОМПАС в другой формат и обратно.

В этом разделе:

10.1.1.1. Импорт

10.1.1.2. Экспорт


10.1.1.1. Импорт

Для чтения документа любого из импортируемых форматов выполните следующие действия.

1. Вызовите команду Файл — Открыть.

2. В списке Тип файлов: появившегося диалога выберите нужный формат и укажите имя файла.

3. Нажмите кнопку Открыть. Выбранный документ будет импортирован в КОМПАС-3D и загружен для редактирования.

Импорт графических документов из файлов некоторых форматов имеет особенности.

При импорте документа из файла формата IGES после нажатия кнопки Открыть на экране появляется диалог, в котором нужно указать тип открываемого файла (двухмерный или трехмерный). После этого на экране появляется диалог настройки импорта. Задав параметры импорта, нажмите кнопку Начать чтение.

При импорте документа из файла формата DXF или DWG после выбора из списка Тип файлов: строки AutoCAD DXF (*.dxf) или AutoCAD DWG (*.dwg) в диалоге открытия файла появляются следующие элементы управления.

– Опции Читать в графический документ и Читать в модель, позволяющие указать тип открываемого документа. Чтобы прочитать чертеж, записанный в файле формата DXF или DWG, включите опцию Читать в графический документ.

– Стрелка в правой части кнопки Открыть, которая позволяет развернуть меню этой кнопки, состоящее из команд Открыть и Открыть с параметрами... Чтобы вызвать диалог настройки импорта, выберите команду Открыть с параметрами... Задав параметры импорта, нажмите в настроечном диалоге кнопку Начать чтение.


10.1.1.2. Экспорт

Для записи КОМПАС-документа в другой формат выполните следующие действия.

1. Вызовите команду Файл — Сохранить как.... На экране появится диалог записи файла. В зависимости от типа текущего документа список Тип файла этого диалога содержит различные названия форматов, доступных для записи.

2. Выберите нужный формат и нажмите кнопку Сохранить.

При выборе в списке Тип файла: строки AutoCAD DXF (*.dxf) и AutoCAD DWG (*.dwg) в диалоге появляется кнопка Параметры. Она вызывает диалог настройки записи документа в выбранный формат. Завершив настройку, закройте диалог кнопкой ОК, а затем нажмите кнопку Сохранить диалога сохранения файлов. Документ будет записан в файл выбранного формата.

Для формата IGES настройка экспорта невозможна.

Настройка записи в формат EMF производится в диалоге, который автоматически появляется после нажатия кнопки Сохранить. Этот диалог аналогичен диалогу настройки записи в растровый формат с той лишь разницей, что в нем отсутствуют элементы управления параметрами растра. Диалоги настройки записи в растровые форматы для различных типов документов описаны в разделе 10.1.3.

Экспорт в формат IGES производится с некоторыми ограничениями — не записываются вставки видов, вставки многослойных фрагментов и многослойные макроэлементы.

Документ, сохраненный в другом формате, целесообразно использовать для просмотра и вывода на печать.

В результате экспорта формируется документ выбранного формата, сохраняющий визуальную идентичность исходному. Однако структура и внутренние связи объектов документа системы КОМПАС-3D и аналогичных объектов в новом формате могут отличаться. В качестве примера таких объектов можно привести элементы оформления чертежа системы AutoCad. При редактировании полученного документа внешний вид подобных объектов может измениться таким образом, что они утратят идентичность объектам исходного документа.


10.1.2. Импорт и экспорт моделей

10.1. Импорт и экспорт

10.1.2. Импорт и экспорт моделей

Обмен трехмерными моделями между КОМПАС-3D и другими системами возможен через форматы, представленные в таблице 10.1.2. Числа в колонках «Импорт» и «Экспорт» таблицы означают номер версии формата, причем импорт возможен как указанной, так и всех предыдущих версий формата, а экспорт производится только в указанную версию формата.

Табл. 10.1.2. Форматы обмена трехмерными моделями
Формат | Импорт | Экспорт
IGES (*.igs) | 5.3 | 5.3
ACIS (*.sat) | 8.0 | 2.0
Parasolid (*.x_t, *.x_b, *.xmt_txt, *.xmt_bin, *.xmp_txt, *.xmp_bin) | 25.0 | 10.0 (экспорт возможен в файлы типа *.x_t и *.x_b)
STEP AP 203 (*.stp, *.step) | 1.0 | 1.0
STEP AP214 (*.stp, *.step) | 1.0 | 1.0
STL (*.stl) | импорт не производится | формат не имеет версионности
AutoCAD DXF (*.dxf), AutoCAD DWG (*.dwg) | 2007 | экспорт не производится

Запись моделей КОМПАС-3D V16 возможна также в:

– форматы предыдущих версий КОМПАС-3D: КОМПАС 5.11 R03, КОМПАС-3D V14 SP2 и КОМПАС-3D V15.1,

– растровые форматы (GIF, JPEG, Enhanced Windows Metafile и др.),

– формат для просмотра VRML (*.wrl); версия формата — 2.0,

– формат математического ядра С3D (*.c3d),

– Portable Document Format (*.pdf).

В этом разделе:

10.1.2.1. Импорт

10.1.2.1.1. Особенности импорта объектов модели

10.1.2.2. Экспорт

10.1.2.2.1. Особенности экспорта объектов модели


10.1.2.1. Импорт

Для чтения документа какого-либо из импортируемых форматов выполните следующие действия.

1. Вызовите команду Файл — Открыть.

2. В списке Тип файлов: появившегося диалога выберите нужный формат и укажите имя файла.

3. Если выбран формат DXF или DWG, то в правой части диалога появляются опции Читать в графический документ и Читать в модель. Они позволяют указать тип открываемого документа. Для чтения модели включите опцию Читать в модель.

4. Для некоторых форматов в правой части кнопки Открыть появляется стрелка, которая позволяет развернуть меню этой кнопки. Данное меню состоит из команд Открыть и Открыть с параметрами...

• Команда Открыть позволяет импортировать модель без изменения параметров импорта (вызов этой команды равносилен нажатию самой кнопки Открыть).

• Команда Открыть с параметрами... позволяет настроить параметры импорта модели. После вызова этой команды на экране появляется диалог настройки параметров импорта. Выполните необходимые настройки и нажмите кнопку ОК диалога или кнопку Начать чтение (для формата DXF или DWG).

Выбранный документ будет импортирован в КОМПАС-3D и загружен для редактирования.

Результатом импорта детали является один файл — деталь КОМПАС-3D, которая отображается в текущем окне.

Результатом импорта сборки являются несколько файлов:

– основная сборка;

– компоненты основной сборки: подсборки и детали.

В текущем окне находится основная сборка.

Особенности импорта объектов модели (тел, поверхностей и т.п.) описаны ниже.

В этом разделе:

10.1.2.1.1. Особенности импорта объектов модели


10.1.2.1.1. Особенности импорта объектов модели

При импорте модели из всех импортируемых форматов передаются поверхности и тела.

Поверхности преобразуются в «импортированные поверхности», а тела — в «операции без истории».

При импорте модели из формата IGES и STEP AP203/STEP AP214 кроме поверхностей и тел передаются кривые и точки.

Точки передаются с сохранением типа объекта.

Импорт кривых имеет следующие особенности: отрезки, дуги, ломаные и сплайны передаются с сохранением типов объектов, остальные кривые преобразуются в «кривые без истории».

При импорте из формата STEP AP214 передаются размеры и технические требования. Размеры преобразуются в «размеры без истории».

Тексты технических требований и размеров передаются в виде букв, символов и спецзнаков либо в виде наборов отрезков, объединенных в макроэлементы.

Особенностью чтения размеров с предельным отклонениями является то, что символы, обозначающие отклонения, располагаются в одну строку с номинальным значением размера и имеют ту же высоту. При этом сначала идет верхнее отклонение, а затем нижнее.

При импорте модели из формата DXF или DWG кроме поверхностей и тел передаются кривые (отрезки, дуги).


10.1.2.2. Экспорт

Для записи КОМПАС-модели в другой формат выполните следующие действия.

1. Вызовите команду Файл — Сохранить как.... На экране появится диалог записи файла. В зависимости от типа текущего документа список Тип файлов: этого диалога содержит различные названия форматов, доступных для записи.

2. Выберите нужный формат и нажмите кнопку Сохранить.

При экспорте в некоторые форматы появляется диалог настройки параметров записи. Для остальных настройка экспорта невозможна.

Экспорт модели в форматы IGES, STEP AP203/STEP AP214 и STL имеет следующую особенность.

После выбора из списка Тип файла строки с каким-либо из этих форматов в правой части кнопки Сохранить появляется стрелка, которая позволяет развернуть меню этой кнопки. Данное меню состоит из команд Сохранить и Сохранить с параметрами.... Чтобы выполнить экспорт модели без дополнительной настройки параметров экспорта, выберите команду Сохранить. Команда Сохранить с параметрами... позволяет настроить параметры экспорта модели. После вызова этой команды на экране появляется диалог настройки параметров экспорта. Выполнив необходимые настройки, нажмите кнопку ОК.

Если сохранение преобразованной модели в другой формат производится в режиме пересчета размеров, то модель сохраняется с размерами выбранного режима. Подробнее о режиме пересчета размеров модели см. раздел 2.10.3.

В этом разделе:

10.1.2.2.1. Особенности экспорта объектов модели


10.1.2.2.1. Особенности экспорта объектов модели

– При экспорте модели в различные форматы передаются следующие объекты:

• в формат Parasolid, ACIS и STL — тела и поверхности,

• в формат STEP AP203 /STEP AP214 и IGES — тела, поверхности, точки, кривые,

Кроме этого в формат STEP AP214 передаются размеры и технические требования, а в формат IGES — эскизы.

– Тела, поверхности и точки передаются без изменения.

– Экспорт кривых имеет следующие особенности.

• Отрезки, дуги, ломаные и сплайны передаются без изменения.

• Кривые по закону, изопараметрические кривые, спирали (цилиндрические и конические), кривые скругления и соединения кривых преобразуются в сплайны.

Если кривая скругления является дугой, то она передается без изменения.

• Эквидистанты преобразуются в кривые, аналогичные базовым, например, если базовой кривой является отрезок, то эквидистанта преобразуется в отрезок, если дуга — в дугу, если криволинейный сегмент кривой — в сплайн.

– Размеры передаются в виде набора пространственных кривых и текстов.

– Точность записи модели в формат VRML определяется настройкой точности ее отрисовки, см. раздел 9.2.7.4.11. При записи сборки для всех ее компонентов используется точность, заданная в файле сборки (а не в файлах компонентов).


10.1.3. Сохранение в растровый формат и формат PDF

10.1. Импорт и экспорт

10.1.3. Сохранение в растровый формат и формат PDF

Чтобы записать документ в растровый файл или формат PDF, вызовите команду Файл — Сохранить как.... В появившемся диалоге задайте тип и имя файла. Для сохранения документа нажмите кнопку Сохранить.

Параметры записи можно настроить в специальном диалоге.

При записи документа в растровый формат диалог настройки параметров записи автоматически появляется на экране после нажатия кнопки Сохранить в диалоге выбора файла. При записи документа в формат PDF диалог вызывается нажатием кнопки Параметры в диалоге выбора файла.

Завершив настройку параметров записи, нажмите кнопку ОК диалога.

Наборы элементов управления настроечных диалогов несколько отличаются в зависимости от типа сохраняемого документа (см. разделы 10.1.3.1–10.1.3.3).

Если при записи в растровый формат файл не создается, то выдается сообщение о причине этого. Рекомендуемый порядок действий в таких случаях и условия, выполнение которых необходимо для записи растрового файла, описаны в разделе 10.1.3.4.

Сохранение в растровый формат и формат PDF подчиняется настройке фильтров вывода на печать, т.е. полученное растровое изображение будет содержать только те объекты исходного документа, печать которых включена. О настройке фильтров вывода см. раздел 9.1.5.2.

При экспорте модели в формат PDF передаются тела и поверхности.

В этом разделе:

10.1.3.1. Чертеж, фрагмент, модель

10.1.3.2. Многолистовой чертеж

10.1.3.3. Текстовый документ, спецификация

10.1.3.4. Условия, определяющие возможность записи в растровый формат


10.1.3.1. Чертеж, фрагмент, модель

Диалоги настройки параметров записи чертежа, фрагмента или модели в растровый формат и формат PDF (для графических документов) приведены на рис. 10.1.1.

Элементы управления диалога представлены в таблице 10.1.3.

Рис. 10.1.1. Диалог настройки записи чертежа или фрагмента: а) в растровый формат, б) в формат PDF
а) | б)

Табл. 10.1.3. Диалог настройки записи в растровый формат и формат PDF

Элемент

Описание

Параметры
документа

Справочные сведения о записываемом документе.

Цвет

Список, из которого можно выбрать цвет изображения (см. табл. 10.1.4).

Все линии тонкие

Опция, позволяющая записать все линии с толщиной 1 пиксел1.

Масштаб

Поле для ввода масштаба изображения.

Цветность2

Список, позволяющий выбрать количество цветов.

Так как размер растрового файла пропорционален количеству цветов, высокую цветность рекомендуется использовать только для записи трехмерных моделей — это позволит корректно передать цветовые переходы.

Записав файл, просмотрите его в соответствующем растровом редакторе. Если цветовые переходы выглядят недостаточно «гладкими», увеличьте цветность и запишите файл снова.

Разрешение,
точек на дюйм

Поле для задания разрешения изображения.

Так как размер растрового файла пропорционален разрешению, большое разрешение рекомендуется использовать для записи документов, содержащих мелкие детали и контуры значительной кривизны — это позволит передать их с минимальными потерями.

Записав файл, просмотрите его в соответствующем растровом редакторе. Если качество изображения вас не удовлетворит, увеличьте разрешение и запишите файл снова.

Оттенки серого

Опция, позволяющая записать цветные оттенки оттенками серого цвета. Количество оттенков серого будет тем больше, чем большая цветность установлена.

Размер
изображения1

Габариты изображения страницы в точках. Эта величина зависит от заданного масштаба и разрешения.

Встроить шрифты3

Опция, позволяющая получить в PDF-файле такой же вид текста, как и в исходном документе.

Фильтр

Кнопка позволяет настроить фильтры вывода на печать. После вызова команды на экране появится диалог Установка фильтров вывода на печать (см. раздел 9.1.5.2). В созданном файле будут присутствовать только те объекты КОМПАС-документа, печать которых включена.

Сохранить настройки

Опция, позволяющая сохранить заданные настройки записи в формат PDF для дальнейшего использования.
  1. Состояние опции не влияет на толщину линий шрифта.
  2. Опция присутствует в диалоге только при записи в растровый формат.
  3. Опция присутствует в диалоге только при записи в формат PDF.

Табл. 10.1.4. Варианты использования

Вариант

Описание

Черный

Все линии и текст записываются черным цветом, а заливки и растровые изображения — оттенками серого.

Установленный для объекта

Линии записываются цветами, установленными для них в диалоге настройки системы, заливки и штриховки — цветами, установленными при их создании.

Изображения трехмерных объектов записываются цветами, установленными при настройке свойств этих объектов.

Установленный для вида1

Объекты, расположенные в разных видах, записываются цветами, установленными для этих видов.

Установленный для слоя

Объекты, расположенные на разных слоях, записываются цветами, установленными для этих слоев.
  1. Вариант доступен при записи чертежей.

Диалог настройки параметров записи модели в формат PDF приведен на рис. 10.1.2. В таблице 10.1.5 представлены элементы управления диалогом.

Рис. 10.1.2. Диалог настройки параметров записи модели в формат PDF

Табл. 10.1.5. Диалог настройки параметров записи модели в формат PDF
Элемент | Описание
Формат документа | Группа опций позволяет задать формат листа документа. Подробное описание элементов управления представлено в таблице 9.1.62.
Точность вывода моделей | Элемент позволяет изменять точность вывода изображения модели. Для изменения точности вывода перемещайте «ползунок» между позициями Грубо и Точно.
Оттенки серого | Опция позволяет записать цветные оттенки оттенками серого цвета.
Сохранить настройки | Опция, позволяющая сохранить заданные настройки записи в формат PDF для дальнейшего использования.

Если в сборке заданы параметры разнесения компонентов, то они передаются в формат PDF. При просмотре такого файла в Adobe Reader управление разнесением производится с помощью элемента для просмотра анимации на панели 3D-инструментов.


10.1.3.2. Многолистовой чертеж

Диалоги настройки параметров записи многолистового чертежа в растровый файл и формат PDF приведены на рис. 10.1.3.

Основное отличие этих диалогов от диалогов настройки записи чертежа (см. рис. 10.1.1) — наличие группы Диапазон. Элементы управления этой группы представлены в таблице 10.1.6. Описание остальных элементов — см. табл. 10.1.3.

Рис. 10.1.3. Диалог настройки записи многолистового чертежа: а) в растровый формат, б) в формат PDF
а) | б)

Табл. 10.1.6. Элементы управления группы Диапазон

Элемент

Описание

Количество страниц документа

Общее количество листов документа.

Весь документ
в один файл1

Опция позволяет разместить все листы документа на одной странице в файле формата TIFF. Для остальных форматов позволяет сохранить все листы чертежа в одном файле.

Если опция выключена, то при сохранении во все форматы, кроме формата TIFF, для каждого листа создается отдельный растровый файл. К заданному имени файла для сохранения документа будут автоматически добавляться дополнительные символы, формирующие имена файлов для отдельных листов.

Способ сохранения в формат TIFF при отключенной опции Весь документ в один файл определяется состоянием опции Многостраничный TIFF.

Все страницы

Вариант позволяет сохранить все листы документа.

Страницы

Вариант позволяет указать номера листов для сохранения. При его выборе становится доступным поле для ввода номеров листов.

Многостраничный TIFF1

Опция позволяет при сохранении документа в формате TIFF сформировать один многостраничный файл, на каждой странице которого будет расположен один лист документа.
При выключенной опции для каждого листа создается отдельный файл формата TIFF.

Для других форматов опция недоступна.

Все страницы в один файл 2

Опция позволяет размещать все листы исходного документа в одном файле. При выключенной опции создается число файлов по количеству страниц.
  1. Опция присутствует в диалоге только при записи в растровый формат.
  2. Опция присутствует в диалоге только при записи в формат PDF.


10.1.3.3. Текстовый документ, спецификация

Диалоги настройки параметров записи текстовых документов и спецификаций в растровый формат и формат PDF приведены на рисунке 10.1.4.

Основное отличие этих диалогов от диалогов настройки записи чертежа (см. рис. 10.1.1) — наличие группы Диапазон. Элементы управления этой группы представлены в таблице 10.1.7. Описание остальных элементов — см. табл. 10.1.3.

Обратите внимание на то, что при сохранении во все растровые форматы, кроме формата TIFF, для каждого листа документа формируется отдельный растровый файл. Способ сохранения в формат TIFF определяется состоянием опции Многостраничный TIFF в группе Диапазон.

Рис. 10.1.4. Диалог настройки записи текстовых документов и спецификаций: а) в растровый формат, б) в формат PDF
а) | б)

Табл. 10.1.7. Элементы управления группы Диапазон
Элемент | Описание
Все страницы | Опция, включение которой означает, что будут записаны все страницы документа.
Текущую страницу | Опция, включение которой означает, что будет записана только текущая страница документа — страница, на которой находился курсор перед вызовом команды записи.
Страницы | Поле, в котором можно ввести номера и/или диапазоны номеров страниц для записи. Например, «1, 3–5».
Сохранять | Список, позволяющий указать, какие страницы диапазона требуется записать: все, только четные или только нечетные.
Многостраничный TIFF1 | Опция, позволяющая при сохранении документа в формате TIFF сформировать один многостраничный файл, на каждой странице которого будет расположен один лист документа. При выключенной опции для каждого листа создается отдельный файл формата TIFF. Для других форматов опция недоступна.
Все страницы в один файл 2 | Опция позволяет размещать все листы исходного документа в одном файле. При выключенной опции создается число файлов по количеству страниц.
  1. Опция присутствует в диалоге только при записи в растровый формат.
  2. Опция присутствует в диалоге только при записи в формат PDF.


10.1.3.4. Условия, определяющие возможность записи в растровый формат

10.1.3.4. Условия, определяющие возможность записи
в растровый формат

Запись КОМПАС-документа в растровый формат происходит в два этапа.

1. Формирование временного растрового файла с глубиной цвета 24 бита. Максимально возможное количество точек в нем — 1 431 655 724. Место расположения временного файла — папка, определяемая переменной TEMP среды КОМПАС-3D (или соответствующим ключом файла Kompas.ini).

2. Преобразование временного файла в файл заданного формата с указанными разрешением и цветностью.

Поскольку максимальный размер временного файла ограничен, после нажатия кнопки ОК в диалоге настройки записи в растровый файл система сравнивает общее количество точек в создаваемом файле и максимально допустимое количество точек.

Если количество точек оказывается больше допустимого, то на экране появляется сообщение «Размер растра превышает допустимый максимальный размер».

Если количество точек не выходит за допустимые границы, система рассчитывает размер временного файла. Это значение (в битах) получается умножением общего количества точек на 24, так как для передачи цвета каждой точки изображения используется 24 бита (соответственно, умножение на 3 дает размер файла в байтах). Полученная величина сравнивается с количеством дискового пространства, доступного для записи временных файлов системы КОМПАС-3D.

Если выясняется, что места для временного файла не хватит, то на экране появляется сообщение «Недостаточно свободного места на диске для создания временного файла».

Таким образом, если вы получили сообщение о превышении допустимого размера растра, то вам необходимо уменьшить общее количество точек в изображении. Это можно сделать, уменьшив масштаб или разрешение в диалоге настройки записи в растр.

Если же получено сообщение о нехватке места на диске, то вам следует либо уменьшить количество точек в изображении, либо увеличить размер дискового пространства, доступного для записи временных файлов.

Сведения о размещении временных файлов можно получить в диалоге просмотра расположения служебных файлов и папок. Для доступа к этому диалогу вызовите команду Сервис — Параметры... — Система — Файлы — Расположение.


10.2. Гиперссылки

В этом разделе:

10.2.1. Общие сведения о гиперссылках

10.2.1.1. Отображение и активизация гиперссылок

10.2.2. Работа с гиперссылками

10.2.2.1. Создание гиперссылки

10.2.2.1.1. Гиперссылка на файл или веб-страницу

10.2.2.1.2. Гиперссылка на место в документе

10.2.2.1.3. Гиперссылка на адрес электронной почты

10.2.2.2. Редактирование гиперссылки

10.2.2.3. Удаление гиперссылки


10.2.1. Общие сведения о гиперссылках

10.2. Гиперссылки

10.2.1. Общие сведения о гиперссылках

В графических документах КОМПАС-3D возможно создание гиперссылок.

Гиперссылка — это связь между объектами, позволяющая переходить от одного объекта к другому.

Гиперссылка не может существовать в документе «сама по себе» (т.е. отдельно от объектов), поэтому она добавляется к существующему объекту и становится одним из его свойств. Создать гиперссылку — значит указать объект, который будет содержать гиперссылку, и объект, к которому будет осуществляться переход (целевой объект).

Переход к целевому объекту происходит после активизации гиперссылки. По умолчанию, чтобы активизировать гиперссылку, следует щелкнуть мышью по содержащему ее объекту при нажатой клавише <Alt>. Способ активизации можно изменить при настройке гиперссылок (см. раздел 9.1.2.7).

Гиперссылки можно добавлять к следующим объектам:

– геометрическим объектам;

– размерам;

– обозначениям;

– вставкам фрагментов и видов;

– макроэлементам, в том числе библиотечным;

– таблицам и текстам.

Целевыми объектами могут являться следующие объекты:

– файл, папка или веб-страница;

– место в текущем документе;

– адрес электронной почты.

Один объект может содержать только одну гиперссылку. В одном графическом документе может быть несколько объектов с гиперссылками.

Гиперссылка на место в документе является внутренней. Переход по внутренней ссылке осуществляется к области этого же документа — например, области расположения вида, текста или выносного элемента. Остальные гиперссылки являются внешними. При переходе по внешней ссылке открывается файл, папка, веб-страница или окно отправки электронного сообщения.

В этом разделе:

10.2.1.1. Отображение и активизация гиперссылок


10.2.1.1. Отображение и активизация гиперссылок

Внешний вид объекта после создания гиперссылки не изменяется. При подведении курсора к объекту, содержащему гиперссылку, на экране появляется всплывающая подсказка, в которой отображена информация, характерная для каждого типа ссылки: путь к файлу, или веб-адрес, или наименование элемента в документе, или адрес электронной почты.

Чтобы активизировать гиперссылку, щелкните мышью по объекту при нажатой клавише <Alt>. Указатель мыши при этом принимает вид указателя ссылки (рис. 10.2.1). После активизации гиперссылки на экране появляется целевой объект гиперссылки — открытые файл, папка или веб-страница, область текущего документа, окно создания электронного сообщения.

Рис. 10.2.1. Отображение гиперссылки

Информация о гиперссылке отображается в таблице свойств объекта (см. раздел 3.5.1.2.1).

Перечень всех внешних гиперссылок текущего документа содержится в диалоге Информация о документе на вкладке Внешние ссылки. Для вызова этого диалога служит команда Информация о документе.


10.2.2. Работа с гиперссылками

10.2. Гиперссылки

10.2.2. Работа с гиперссылками

В этом разделе:

10.2.2.1. Создание гиперссылки

10.2.2.1.1. Гиперссылка на файл или веб-страницу

10.2.2.1.2. Гиперссылка на место в документе

10.2.2.1.3. Гиперссылка на адрес электронной почты

10.2.2.2. Редактирование гиперссылки

10.2.2.3. Удаление гиперссылки


10.2.2.1. Создание гиперссылки

Чтобы создать гиперссылку, выделите один или несколько объектов и вызовите команду Гиперссылка... из меню Вставка или из контекстного меню.

Диалог создания гиперссылки можно также вызвать щелчком мыши по строке Гиперссылка в таблице свойств объекта (см. раздел 3.5.1.2.1).

На экране появляется диалог (рис. 10.2.2), в котором требуется выбрать тип гиперссылки и задать ее параметры. Кнопки для выбора типа гиперссылки — Файл, веб-страница, Место в документе и Электронная почта — расположены в левой части диалога.

Рис. 10.2.2. Диалог создания гиперссылки

После нажатия кнопки центральная часть диалога изменяется, что позволяет задать параметры гиперссылки того или иного типа. Описание создания гиперссылок приведено в разделах 10.2.2.1.1, 10.2.2.1.2, 10.2.2.1.3.

Если было выделено несколько объектов, то после создания гиперссылки ее будет содержать каждый из выделенных объектов.

Команда Гиперссылка... недоступна, если выделенных объектов нет. Команда также недоступна, если одновременно выделены объекты с гиперссылками и объекты без гиперссылок.

Гиперссылки могут создаваться автоматически при простановке некоторых обозначений (см. раздел 3.3.9.2).

В этом разделе:

10.2.2.1.1. Гиперссылка на файл или веб-страницу

10.2.2.1.2. Гиперссылка на место в документе

10.2.2.1.3. Гиперссылка на адрес электронной почты


10.2.2.1.1. Гиперссылка на файл или веб-страницу

Создание гиперссылки на файл или веб-страницу производится при нажатой кнопке Файл, веб-страница в левой части диалога (рис. 10.2.3).

Рис. 10.2.3. Диалог создания гиперссылки на файл или веб-страницу

Если требуется создать гиперссылку на файл или папку, нажмите кнопку Текущая папка. Выберите целевой объект — файл или папку — в окне просмотра содержимого папки. Сменить текущую папку можно при помощи списка Папка и кнопок Назад и Вверх.

Чтобы выбрать целевой объект из стандартного диалога открытия файлов, нажмите кнопку Открыть, расположенную в верхней части диалога Гиперссылка, и откройте нужный файл.

Если требуется создать гиперссылку на один из последних файлов, нажмите кнопку Последние файлы и выберите нужный файл.

Если требуется создать гиперссылку на одну из последних просмотренных веб-страниц, нажмите кнопку Просмотренные страницы и выберите нужную веб-страницу.

После выбора целевого объекта путь к нему или его адрес появится в поле Адрес. Вы можете ввести путь (адрес) с клавиатуры или выбрать из раскрывающегося списка Адрес путь (адрес), использованный в текущем сеансе КОМПАС-3D.

Нажмите кнопку ОК. Кнопка доступна, если поле Адрес заполнено.

После создания гиперссылки во всплывающей подсказке содержится путь к файлу (папке) или веб-адрес.

При активизации гиперссылки папки открываются Проводником Windows, файлы — приложением, сопоставленным в Windows данному типу файла, а веб-страницы — веб-браузером.


10.2.2.1.2. Гиперссылка на место в документе

Создание гиперссылки на место в текущем документе производится при нажатой кнопке Место в документе в левой части диалога (рис. 10.2.4).

Рис. 10.2.4. Диалог создания гиперссылки на место в документе

В окне диалога отображены группы объектов текущего документа, на которые можно сделать гиперссылку. Группы можно разворачивать (сворачивать), щелкая мышью на значке «плюс» (минус) слева от названия группы. По умолчанию группы показаны в свернутом виде.

Выберите в списке нужный целевой объект; выбранный объект выделяется в документе.

Нажмите кнопку ОК. Кнопка доступна, если целевой объект выделен.

После создания гиперссылки всплывающая подсказка содержит наименования документа и целевого объекта.

При активизации гиперссылки происходит переход к области документа, в которой расположен целевой объект. При этом центр целевого объекта разместится в центре экрана.

Если целевой объект гиперссылки находится в погашенном виде или слое, то ее активизация невозможна.


10.2.2.1.3. Гиперссылка на адрес электронной почты

Создание гиперссылки на адрес электронной почты производится при нажатой кнопке Электронная почта в левой части диалога (рис. 10.2.5).

Рис. 10.2.5. Диалог создания гиперссылки на окно электронной почты

Введите адрес в поле mailto: или выберите его двойным щелчком мыши из списка в центральном окне диалога. Этот список содержит адреса, использовавшиеся в последнем сеансе работы КОМПАС-3D.

Нажмите кнопку ОК. Кнопка доступна, если в поле mailto: внесен адрес электронной почты.

После создания гиперссылки всплывающая подсказка содержит адрес получателя электронного сообщения.

При активизации гиперссылки открывается программа, зарегистрированная в системе как почтовая по умолчанию. На экране появляется окно составления электронного сообщения с автоматически заполненным адресом получателя.


10.2.2.2. Редактирование гиперссылки

Редактирование гиперссылки — это изменение ее типа или смена целевого объекта.

Чтобы отредактировать гиперссылку, выделите содержащий ее объект и вызовите команду Вставка — Гиперссылка... или команду Редактировать гиперссылку... из контекстного меню. Вы можете отредактировать несколько одинаковых гиперссылок сразу, предварительно выделив содержащие их объекты.

Команда редактирования гиперссылки недоступна, если выделенный объект не содержит гиперссылку или если выделенные объекты содержат разные гиперссылки.

После вызова команды на экране появляется диалог Гиперссылка в том виде, в котором он был при создании гиперссылки. Введите новые параметры и нажмите кнопку ОК диалога. Диалог закроется, гиперссылка изменится.

Редактирование целевого объекта не влияет на гиперссылку, если в результате редактирования сохраняются:

– для папки и файла — путь и имя;

– для веб-страницы — адрес;

– для объекта текущего документа — принадлежность виду.


10.2.2.3. Удаление гиперссылки

Чтобы удалить гиперссылку, выделите объект, который ее содержит, и вызовите команду контекстного меню Удалить гиперссылку. Вы можете удалить гиперссылки у нескольких объектов одновременно, предварительно выделив эти объекты.

Команда доступна, если среди выделенных есть хотя бы один объект с гиперссылкой.

Удаление гиперссылки также производится в диалоге Гиперссылка при ее редактировании (см. раздел 10.2.2.2) нажатием кнопки Удалить ссылку.

В результате удаления целевого объекта переход к нему по гиперссылке становится невозможным. После активизации такой гиперссылки выдается сообщение о том, что целевой объект не найден.


10.3. Совместная работа. Восстановление документов

В этом разделе:

10.3.1. Совместная работа

10.3.1.1. Совместная работа с КОМПАС-документами

10.3.1.2. Совместная работа с подчиненными файлами

10.3.1.3. Контроль за изменением документов и файлов

10.3.1.4. Файлы-сателлиты

10.3.2. Резервное копирование

10.3.2.1. Файлы резервного копирования

10.3.2.2. Восстановление документов из файлов резервного копирования

10.3.3. Автосохранение

10.3.3.1. Файлы автосохранения

10.3.3.2. Восстановление документов из файлов автосохранения


10.3.1. Совместная работа

10.3. Совместная работа. Восстановление документов

10.3.1. Совместная работа

В этом разделе:

10.3.1.1. Совместная работа с КОМПАС-документами

10.3.1.2. Совместная работа с подчиненными файлами

10.3.1.3. Контроль за изменением документов и файлов

10.3.1.4. Файлы-сателлиты


10.3.1.1. Совместная работа с КОМПАС-документами

Если КОМПАС-документ открыт на другом рабочем месте, то при попытке его открытия на данном рабочем месте на экране появляется сообщение, показанное на рисунке 10.3.1.

Рис. 10.3.1. Сообщение о том, что документ в данный момент занят

Это и остальные упомянутые в данном разделе сообщения появляются, если в диалоге установки прав доступа (см. раздел 9.1.4.2) включен контроль за изменением файлов.

В противном случае документ открывается для чтения. Ни при открытии документа, ни во время работы с ним никаких сообщений не выдается.

Вы можете выбрать один из вариантов действий:

– открыть только для чтения

Документ открывается для чтения. В заголовке окна документа, открытого для чтения, присутствует текст «(только чтение)». Такой документ можно редактировать, но нельзя сохранить в той же папке под тем же именем.

При изменении документа пользователем, работающим с ним в данный момент, вы будете получать сообщения (см. раздел 10.3.1.3).

– открыть только для чтения и уведомить, когда файл станет доступным

Документ открывается для чтения. Когда пользователь, работающий с документом, закроет его, вы получите сообщение о том, что документ стал доступен для редактирования.

• Если вы не редактировали документ, сообщение будет иметь вид, показанный на рисунке 10.3.2, а. При нажатии кнопки Да документ, открытый для чтения, закрывается, вместо него открывается ставший доступным документ. При нажатии кнопки Нет остается открытым документ для чтения.

• Если вы редактировали документ, сообщение будет иметь вид, показанный на рисунке 10.3.2, б. При выборе варианта сохранить изменения... вам будет предложено сохранить текущий документ под другим именем, затем будет открыт ставший доступным документ. При выборе варианта открыть файл... текущий документ закрывается без сохранения, вместо него открывается ставший доступным документ.

– уведомить, когда файл станет доступным

Документ не открывается, но, когда он станет доступным, вы получите сообщение, которое имеет вид, показанный на рисунке 10.3.2, а.

Рис. 10.3.2. Сообщение о доступности файла: а) в случае, когда документ, открытый для чтения, не редактировался, б) в случае, когда документ, открытый для чтения, редактировался
а) | б)

Если в диалоге установки прав доступа (см. раздел 9.1.4.2) включена опция Уведомлять при открытии файлов, доступных только для чтения, сообщение, аналогичное показанному на рис. 10.3.1, выдается также в следующих случаях:

– открываемый файл имеет атрибут «только чтение»,

– у пользователя, пытающегося открыть файл, отсутствует разрешение на запись или дозапись данных в этот файл.

Если опция уведомления отключена, то в перечисленных случаях документы открываются для чтения без выдачи сообщения.


10.3.1.2. Совместная работа с подчиненными файлами

Подчиненными по отношению к документам считаются файлы библиотек оформлений, типов атрибутов, стилей линий, штриховок и текстов, стилей спецификаций.

Использование этих файлов, т.е. применение хранящихся в них оформлений, стилей, типов атрибутов, возможно на нескольких рабочих местах одновременно. Более того, именно такой подход позволяет поддерживать единообразие документов, созданных на разных рабочих местах.

Возможность же редактирования на том или ином рабочем месте подчиненных файлов, уже используемых на одном из рабочих мест, зависит от настройки КОМПАС-3D на этом рабочем месте. Эта настройка выполняется в диалоге установки доступа к файлам (см. раздел 9.1.4.2) с помощью списка Уровень доступа к подчиненным файлам. Он содержит два варианта:

– Разрешить чтение.
Этот вариант означает, что на других рабочих местах будет возможно лишь использование занятых подчиненных файлов. Кроме того, другие пользователи смогут скопировать сами подчиненные файлы.

– Разрешить чтение и запись.
Этот вариант означает, что на других рабочих местах будет возможно не только использование, но и редактирование занятых подчиненных файлов: создание, изменение и удаление оформлений, типов атрибутов, стилей.
При изменении кем-либо используемого вами подчиненного файла вы будете получать сообщения (см. раздел 10.3.1.3).


10.3.1.3. Контроль за изменением документов и файлов

Включение контроля за изменением файлов и настройка его периодичности производится в диалоге установки прав доступа (см. раздел 9.1.4.2).

Если контроль включен, то обрабатываются следующие случаи изменения файлов:

1. Изменение документа, открытого для чтения

Выдается сообщение, которое имеет вид, показанный на рисунке 10.3.3, а. Оно содержит путь к файлу и две кнопки:

• Да — документ будет как бы открыт заново. Оставаясь доступным только для чтения, он отобразится на вашем рабочем месте в том виде, в каком его в последний раз сохранил другой пользователь. Все изменения, если они были вами сделаны в документе до перечитывания, будут потеряны.

• Нет — никаких изменений в открытом документе не произойдет.

Таким образом, если вы внесли в открытый для чтения документ изменения, которые требуется сохранить, то нажмите кнопку Нет, а затем сохраните документ под новым именем. Если же вы не редактировали документ или сохранение изменений не требуется, нажмите кнопку Да.

2. Изменение источника вставки — фрагмента, вида или компонента

Выдается сообщение, которое имеет вид, показанный на рис. 10.3.3, а. Оно содержит путь к файлу-источнику вставки и две кнопки:

• Да — источник вставки будет немедленно перечитан. Например, другой пользователь отредактировал фрагмент, вставленный в документ, с которым вы в данный момент работаете. В результате перечитывания источника изображение вставки будет перерисовано.

• Нет — отказ от немедленного перечитывания. При последующем открытии документа, содержащего вставку, все изменения, сделанные в источнике вставки, будут безусловно переданы в открываемый документ.

3. Изменение подчиненного файла

Выдается сообщение, которое имеет вид, показанный на рис. 10.3.3, б. Оно содержит путь к файлу и две кнопки:

• Да — из подчиненного файла немедленно будет получен измененный стиль, тип атрибута или оформление. Например, другой пользователь отредактировал библиотеку стилей линий, изменив цвет у стиля №5. В результате перечитывания библиотеки в документе, открытом на вашем компьютере, изменится цвет линий с этим стилем.

• Нет — отказ от перечитывания подчиненного файла. Это означает лишь, что перечитывание не будет произведено сразу же. При последующем открытии документа, использующего подчиненный файл, все изменения, произведенные в этом файле, безусловно отобразятся в открываемом документе.

Перечитывание библиотек оформлений (файлов *.lyt) производится согласно настройке обновления оформления (см. раздел 11.2.1.2.1), действовавшей при открытии документа.

Рис. 10.3.3. Сообщение: а) об изменении модели, открытой для чтения, б) об изменении библиотеки стилей линий
а) | б)


10.3.1.4. Файлы-сателлиты

После открытия КОМПАС-документа на редактирование автоматически создается его файл-сателлит.

Файл-сателлит является служебным и располагается в той же папке, что и открываемый документ.

Имя файла-сателлита формируется по следующим правилам:

– знаки ~$ добавляются к имени документа и стоят на первом месте, если имя документа содержит не более 6 символов;

– знаки ~$ заменяют первый и второй символы, если имя содержит более 6 символов;

– знак ~ заменяет последний символ расширения файла документа.

Например, документ SAM.CDW будет иметь файл-сателлит ~$SAM.CD~, а документ SAMPLE_1.CDW будет иметь файл-сателлит ~$MPLE_1.CD~.

Наличие в папке файла-сателлита свидетельствует о том, что КОМПАС-документ уже используется и при повторном его открытии будет доступен только для чтения.

Файл-сателлит содержит текстовую информацию о пользователе, открывшем документ на редактирование, а также номер, который идентифицирует документ на момент открытия.

Файл-сателлит удаляется из папки файлов автоматически после закрытия документа, открытого на редактирование.

Если произошел аварийный выход из системы, то файлы-сателлиты автоматически не удаляются. Иногда они могут препятствовать повторному открытию документа (появляется сообщение об открытии файла для чтения). В этом случае рекомендуется удалить файлы-сателлиты в Проводнике Windows вручную.

При открытии КОМПАС-документа для чтения файл-сателлит не создается.


10.3.2. Резервное копирование

10.3. Совместная работа. Восстановление документов

10.3.2. Резервное копирование

В этом разделе:

10.3.2.1. Файлы резервного копирования

10.3.2.2. Восстановление документов из файлов резервного копирования


10.3.2.1. Файлы резервного копирования

Файл резервного копирования создается при сохранении отредактированного КОМПАС-документа и содержит предыдущую редакцию этого документа, т.е. документ в том виде, в котором он был до редактирования. Если документ сохраняется впервые, то файл резервного копирования не создается.

При настройке КОМПАС-3D (см. раздел 9.1.4.3) может быть включено или отключено сохранение предыдущих копий документов. Если сохранение предыдущих копий включено, то они могут размещаться в одной папке с документами или в отличной от нее папке.

Сохранение документа происходит в следующем порядке: после вызова команды Файл — Сохранить сначала предыдущая версия документа сохраняется как файл резервного копирования, а затем новая версия записывается в файл документа.

– Если сохранение предыдущих копий отключено, то по окончании сохранения документа файл резервного копирования удаляется. В случае аварийного завершения работы КОМПАС-3D во время сохранения документа файл резервного копирования остается. Он размещается в той же папке, что и документ. Имя файла резервного копирования формируется по следующему шаблону: <имя файла документа> + <.> + <расширение имени> + <.> + <bak> (например, example.frw.bak).

– Если сохранение предыдущих копий включено, то

• при размещении копии в одной папке с документом имя файла резервного копирования формируется по шаблону, приведенному выше,

• при размещении копии в другой папке имя и расширение файла резервного копирования совпадают с именем и расширением файла документа.

Таким образом, если документы утрачены или если во время сохранения документа работа КОМПАС-3D завершилась аварийно, то информацию можно частично восстановить из файлов резервного копирования. Об открытии файлов резервного копирования с расширением bak рассказано в разделе 10.3.2.2.


10.3.2.2. Восстановление документов из файлов резервного копирования

Чтобы открыть файл резервной копии, в Проводнике Windows удалите расширение файла bak, запустите систему КОМПАС-3D и откройте файл стандартным способом, вызвав команду Файл — Открыть.

Система КОМПАС-3D не сопоставлена файлам с расширением bak в качестве программы для открытия. Поэтому двойной щелчок по файлу *.bak в Проводнике Windows не запускает КОМПАС-3D автоматически. На экране появляется диалог для выбора программы. Укажите исполняемый файл системы КОМПАС-3D (KOMPAS.exe) в качестве программы для открытия файла — система будет запущена, в ней откроется выбранный файл.

Не рекомендуется в диалоге выбора программы включать опцию Использовать ее для всех файлов такого типа. Файлы резервного копирования документов с расширением bak создают различные программы. Если система КОМПАС-3D будет сопоставлена с файлами, имеющими расширение bak, то при попытке открыть подобный файл, сохраненный другими программами, на экране появится сообщение об ошибке.

Второй способ открытия файла резервного копирования заключается в следующем: запустите систему КОМПАС-3D и вызовите команду Файл — Открыть. В списке Тип файлов появившегося диалога открытия файлов выберите строку Все файлы (*.*), а в списке файлов — нужный файл с расширением bak. Система КОМПАС-3D определит тип документа, сохраненного в резервной копии, и откроет его. Сохраните открытый файл с помощью команды Файл — Сохранить как.... Сохраняемым файлам будет автоматически назначено расширение, соответствующее типу документа.


10.3.3. Автосохранение

10.3. Совместная работа. Восстановление документов

10.3.3. Автосохранение

В этом разделе:

10.3.3.1. Файлы автосохранения

10.3.3.2. Восстановление документов из файлов автосохранения


10.3.3.1. Файлы автосохранения

Файлы автоматического сохранения создаются следующим образом. Если автоматическое сохранение включено (см. раздел 9.1.4.4), то по истечении заданного периода для документа, редактируемого в текущем сеансе работы, создается файл автосохранения. Он содержит документ с изменениями, внесенными в него после создания или последнего вызова команды Файл — Сохранить, то есть последнего сохранения на диск.

Имена файлов автосохранения формируются автоматически по следующему шаблону:

<k> + <номер версии системы КОМПАС> + <случайный набор из шести латинских символов>.

Расширение имени файла автосохранения формируется в соответствии с типом документа, последний символ расширения заменяется символом $.

Например, файл автосохранения для фрагмента, редактируемого в системе КОМПАС версии 9, может иметь имя k9cxfhme.fr$.

По истечении очередного заданного промежутка времени содержание файла автосохранения сравнивается с текущим документом. Если обнаружены изменения, то файл автосохранения перезаписывается. Если изменений нет, файл остается прежним.

При сохранении документа командой Файл — Сохранить файл автосохранения удаляется и цикл повторяется.

Если работа системы завершается аварийно, то файл автосохранения не удаляется. При последующем запуске КОМПАС-3D этот файл автоматически используется для восстановления документа.


10.3.3.2. Восстановление документов из файлов автосохранения

Восстановление документов после аварийного завершения работы системы из файлов автосохранения производится автоматически.

Для этого необходимо запустить систему КОМПАС-3D любым стандартным способом, кроме двойного щелчка в Проводнике Windows по имени файла, который редактировался или был открыт на момент аварийного выхода.

Почему не нужно запускать КОМПАС-3D щелчком по имени этого файла? Потому, что в этом случае не происходит восстановление документа. Открывается файл, в котором записано состояние документа на момент последнего перед аварийным выходом вызова команды Файл — Сохранить (на момент последнего сохранения на диск). Очевидно, что, если при настройке был задан сравнительно небольшой период автосохранения, то в файле автосохранения вероятнее всего будет записано больше изменений, чем в последней версии документа, сохраненной вручную.

После загрузки системы правильным способом выполняется поиск файлов автосохранения в папке, указанной для записи этих файлов. Из всех найденных файлов восстанавливаются соответствующие им документы.

В заголовке окна восстановленного документа отображается надпись «восстановлен». Она сохраняется до первого редактирования документа.

Чтобы записать восстановленный документ на диск, вызовите команду Файл — Сохранить (для записи в тот же файл, что и до аварийного выхода из системы) или команду Файл — Сохранить как... (для записи в новый файл), при этом файл автосохранения, из которого документ был восстановлен, удаляется.

Если система была запущена двойным щелчком по файлу, редактировавшемуся в момент аварийного выхода (назовем его файл Х), то восстановление документа (документа Х), записанного в этом файле, не происходит — документ Х открывается в том виде, в котором он был записан на диск в последний раз. Если в момент аварийного выхода в КОМПАС-3D были открыты другие документы, они восстанавливаются. Удаляются все файлы автосохранения, кроме того, который соответствует документу. Этот файл автосохранения остается на прежнем месте и не изменяется ни при каких операциях с документом Х.

Таким образом, после «неправильного» запуска необходимо выполнить следующие действия.

1. Сохранить все восстановленные документы.

2. Документ Х закрыть без сохранения.

3. Закрыть систему.

4. Запустить систему альтернативным способом.

5. Сохранить документ Х, восстановленный из файла автосохранения, соответствующего файлу Х.


11.1. Стили объектов

В этом разделе:

11.1.1. Общие сведения

11.1.1.1. Разновидности стилей и их хранение

11.1.1.2. Управление стилями

11.1.1.2.1. Создание библиотек и наборов стилей

11.1.1.2.2. Общий порядок создания стилей

11.1.1.2.3. Удаление отдельных стилей, наборов и библиотек стилей

11.1.1.2.4. Номер стиля

11.1.1.2.5. Хранение в документе информации о стилях объектов

11.1.1.3. Особенности работы со стилями линий

11.1.2. Пользовательский стиль линии

11.1.2.1. Настройка стиля линии

11.1.2.1.1. Стиль линии с фрагментами

11.1.2.2. Практика создания стилей линий

Упражнение 71. Создание библиотеки стилей линий

Упражнение 72. Создание стиля линии без фрагментов

Упражнение 73. Проверка созданного стиля линии

Упражнение 74. Создание стиля линии с фрагментами

Упражнение 75. Создание стиля линии с фрагментами. Самостоятельная работа

11.1.3. Пользовательский стиль штриховки

11.1.3.1. Настройка стиля штриховки

11.1.3.1.1. Установка параметров линии штриховки

11.1.3.2. Практика создания стилей штриховок

Упражнение 76. Создание библиотеки стилей штриховок. Самостоятельная работа

Упражнение 77. Создание стиля штриховки Фарфор

Упражнение 78. Проверка созданного стиля штриховки

Упражнение 79. Создание стиля штриховки Термопласт

Упражнение 80. Создание стилей штриховок. Самостоятельная работа

11.1.4. Пользовательский стиль текста

11.1.4.1. Настройка стиля текста

11.1.4.1.1. Шрифт

11.1.4.1.2. Табуляция

11.1.4.1.3. Расширенный стиль текста

11.1.4.2. Практика создания и редактирования стилей текстов

Упражнение 81. Создание библиотеки стилей текстов. Самостоятельная работа

Упражнение 82. Создание стилей заголовков и основного текста

Упражнение 83. Проверка созданных стилей текстов

Упражнение 84. Редактирование системных стилей текстов в текущем документе

Упражнение 85. Редактирование системных стилей текстов в новых документах

Упражнение 86. Проверка настройки системных стилей текстов


11.1.1. Общие сведения

11.1. Стили объектов

11.1.1. Общие сведения

Внешний вид объекта (линии, точки, штриховки или фрагмента текста) определяется его стилем.

Вместе с системой КОМПАС-3D поставляются готовые стили, которые можно присваивать объектам при их создании и редактировании.

Возможно создание пользовательских стилей.

Пользовательские стили могут храниться (см. также табл. 11.1.1):

– непосредственно внутри документа,

– во внешних файлах — библиотеках стилей,

– в именованных группах — наборах.

В этом разделе:

11.1.1.1. Разновидности стилей и их хранение

11.1.1.2. Управление стилями

11.1.1.2.1. Создание библиотек и наборов стилей

11.1.1.2.2. Общий порядок создания стилей

11.1.1.2.3. Удаление отдельных стилей, наборов и библиотек стилей

11.1.1.2.4. Номер стиля

11.1.1.2.5. Хранение в документе информации о стилях объектов

11.1.1.3. Особенности работы со стилями линий


11.1.1.1. Разновидности стилей и их хранение

Стили точек, линий, штриховок и текстов, хранящиеся непосредственно в коде программы, называются системными. Дополнительно в комплект поставки входят библиотека стилей линий (Graphic.lcs) и библиотека стилей штриховок (Graphic.lhs).

Пользователь может создавать собственные стили линий, штриховок и текстов. Создание пользовательских стилей точек невозможно.

Создавая новые стили, пользователь может сохранять их в различных местах. Возможные места хранения стилей и особенности работы с ними представлены в таблице 11.1.1.

Табл. 11.1.1. Места хранения стилей

Место хранения

Особенности работы

Документ

Стили, хранящиеся непосредственно в файле документа (внедренные в документ стили), передаются вместе с ним на другие рабочие места. Эти стили являются принадлежностью данного документа и доступны только в нем. Для использования их в других документах стили необходимо предварительно скопировать из документа в набор или библиотеку.

Библиотека

Библиотеки стилей — внешние по отношению к документам файлы1. При передаче документов, использующих библиотечные стили, на другие рабочие места необходима также передача библиотек стилей. Стили, хранящиеся в библиотеках, доступны при создании разных документов. Редактирование библиотечного стиля приводит к изменению внешнего вида всех объектов, использующих этот стиль.

Набор

Набор — именованная группа стилей. Информация о созданных пользователем наборах хранится в файле *.cfg (см. раздел 9.5.2).

По умолчанию стили, содержащиеся в наборах, доступны только на том рабочем месте, где они были созданы2.

Преимущество наборов стилей перед библиотеками стилей состоит в следующем. Однажды использованный набор запоминается системой до конца сеанса работы, в то время как к библиотеке всякий раз приходится обращаться заново. Таким образом, повторный доступ к стилям, хранящимся в наборе, легче, чем повторный доступ к библиотечным стилям.
  1. Файлы библиотек стилей линий имеют расширение lcs, стилей штриховок — lhs, стилей текстов — lts.
  2. Перенос наборов стилей с одного рабочего места на другое возможен путем переноса файла *.cfg. При этом следует помнить, что, помимо сведений о наборах, в этом файле хранятся также настройки системы КОМПАС-3D.


11.1.1.2. Управление стилями

Управление стилями линий, штриховок и текстов осуществляется в диалогах, вызываемых командами Сервис — Библиотеки стилей, типов, оформлений и основных надписей — Стили линий... / Стили штриховок... / Стили текстов.... Например, на рис. 11.1.1 показан диалог работы с наборами и библиотеками стилей штриховок.

Рис. 11.1.1. Диалог работы с наборами и библиотеками стилей штриховок

Диалоги имеют одинаковые элементы управления. Они представлены в таблице 11.1.2.

Табл. 11.1.2. Диалог работы с наборами и библиотеками стилей

Элемент

Описание

Окно просмотра

Окно, в котором отображается выбранный список стилей.

Так как окон просмотра два, в диалоге может одновременно отображаться два разных списка стилей. Активным может быть только одно окно — оно выделено рамкой. Например, на рис. 11.1.1 активным является правое окно. Активизация производится щелчком мыши в окне.

Стили в списках могут быть отсортированы по именам или по номерам. Чтобы изменить сортировку, щелкните мышью по заголовку нужного столбца. В заголовке столбца, по которому сортируются стили, отображается треугольник. Его положение показывает направление сортировки — по возрастанию или по убыванию.

Если для показа выбран список стилей документа или набора, окно просмотра содержит две вкладки.

На вкладке Внедренные отображается список стилей, хранящихся непосредственно в документе или в наборе (см. рис. 11.1.1). На вкладке Библиотечные отображается список стилей, хранящихся в виде ссылок на соответствующие библиотечные стили.

Показать набор

Позволяет отобразить в активном окне список стилей, хранящихся в наборе. После нажатия этой кнопки на экране появится диалог со списком созданных ранее наборов стилей. В этом диалоге необходимо указать имя нужного набора.

Показать
библиотеку

Позволяет отобразить в активном окне список стилей, хранящихся в библиотеке. После нажатия этой кнопки на экране появится диалог, в котором необходимо указать имя файла библиотеки стилей для открытия.

Показать
документ

Позволяет отобразить в активном окне список стилей документа. После ее нажатия в активном окне появится список стилей, хранящихся или использованных в текущем документе. Если открытых документов нет, а также если текущий документ не может содержать объекты, со стилями которых ведется работа, данная кнопка недоступна. Например, если активен текстовый документ, то в диалогах работы со стилями линий и штриховок кнопка Показать документ будет недоступна.

Создать

Кнопка, позволяющая создать новый стиль. После ее нажатия на экране появляется диалог создания и редактирования стиля.

Вновь созданный стиль будет храниться в документе (наборе, библиотеке), список стилей которого отображается в активном окне просмотра.

Редактировать

Кнопка, позволяющая отредактировать выделенный стиль. После ее нажатия на экране появляется диалог создания и редактирования стиля.

Копировать

Кнопка, позволяющая производить обмен стилями между библиотеками, наборами и документами. После ее нажатия выделенный стиль (стили) копируется в соседнее окно просмотра.

Если при копировании в документ или набор активна вкладка Внедренные, копирование стиля производится непосредственно в документ или набор.

Если при копировании в документ или набор активна вкладка Библиотечные, в документе или наборе создается ссылка на копируемый стиль.

Удалить

Кнопка, позволяющая удалить выделенный стиль (стили). Подробнее об удалении стилей рассказано в разделе 11.1.1.2.3.

Для завершения работы со стилями служит кнопка Выход. После ее нажатия все добавления, удаления или изменения стилей будут автоматически сохранены.

В этом разделе:

11.1.1.2.1. Создание библиотек и наборов стилей

11.1.1.2.2. Общий порядок создания стилей

11.1.1.2.3. Удаление отдельных стилей, наборов и библиотек стилей

11.1.1.2.4. Номер стиля

11.1.1.2.5. Хранение в документе информации о стилях объектов


11.1.1.2.1. Создание библиотек и наборов стилей

Чтобы создать новую библиотеку стилей, выполните следующие действия.

1. Вызовите команду Сервис — Библиотеки стилей, типов, оформлений и основных надписей — Стили линий... / Стили штриховок... / Стили текстов... в зависимости от типа объектов, со стилями которых будет вестись работа.

На экране появится диалог работы с наборами и библиотеками стилей.

2. Нажмите кнопку Показать библиотеку.

3. В появившемся диалоге укажите или создайте папку, в которой должна размещаться новая библиотека.

4. Введите имя новой (несуществующей) библиотеки и нажмите кнопку Открыть.

5. Ответьте Да на запрос системы о создании нового файла (рис 11.1.2).

Активное окно просмотра диалога работы со стилями очистится, так как вновь созданная библиотека пуста.

Рис. 11.1.2. Запрос на создание файла новой библиотеки

Вы можете на практике ознакомиться с порядком создания библиотеки стилей, выполнив упражнение 71.

Чтобы создать новый набор стилей, выполните следующие действия.

1. Вызовите команду Сервис — Библиотеки стилей, типов, оформлений и основных надписей — Стили линий... / Стили штриховок... / Стили текстов... в зависимости от типа объектов, со стилями которых будет вестись работа.

2. Нажмите кнопку Показать набор.

3. В появившемся на экране диалоге работы с наборами стилей нажмите кнопку Новый....

4. В появившемся на экране диалоге задания имени введите имя набора и нажмите кнопку OK.

Оба диалога закроются, на экране останется диалог работы со стилями. Активное окно просмотра в этом диалоге очистится, так как вновь созданный набор пуст.

С помощью кнопки Создать вы можете создать в библиотеке или наборе новые стили.

С помощью кнопок Копировать вы можете скопировать в библиотеку или набор уже существующие стили. Для этого в соседнем окне необходимо открыть нужный источник стилей для копирования — библиотеку, набор или документ.


11.1.1.2.2. Общий порядок создания стилей

Чтобы создать новый стиль, выполните следующие действия.

1. Вызовите команду Сервис — Библиотеки стилей, типов, оформлений и основных надписей — Стили линий... / Стили штриховок... / Стили текстов... в зависимости от типа объектов, со стилями которых будет вестись работа.

На экране появится диалог работы с наборами и библиотеками стилей.

2. Выберите место хранения будущего стиля.

Для этого используйте кнопки Показать библиотеку..., Показать набор... или Показать документ. Можно также создать библиотеку или набор (см. раздел 11.1.1.2.1) для размещения нового стиля.

3. Нажмите кнопку Создать.

Обратите внимание на то, что создание нового стиля в текущем документе или в наборе возможно, если активна вкладка Внедренные. После нажатия кнопки Создать на экране появится диалог создания и редактирования стиля объекта. Работа с диалогом создания стилей линий описана в разделе 11.1.2.1, с диалогом создания стилей штриховок — в разделе 11.1.3.1, с диалогом создания стилей текстов — в разделе 11.1.4.1.

4. Настройте параметры нового стиля и закройте диалог создания стиля кнопкой ОК.

Название созданного стиля появится в активном окне просмотра диалога работы с наборами и библиотеками стилей. Вы можете отредактировать новый стиль или скопировать его в другое место — библиотеку, набор или текущий документ.

Новый стиль линии, штриховки или текста текущем документе можно также создать во время создания или редактирования объекта — кривой, штриховки или текста.

При создании или редактировании кривой для создания нового стиля линии выполните следующие действия.

1. Разверните список Стиль на Панели свойств и выберите строку Другой стиль.

На экране появится диалог выбора стиля линии (рис. 11.1.3).

Рис. 11.1.3. Диалог выбора стиля линии

2. Нажмите в этом диалоге кнопку Менеджер стилей...

На экране появится Менеджер стилей линий (см. рис. 11.1.9).

3. В Менеджере стилей линий нажмите кнопку Новый стиль.

На экране появится диалог создания и редактирования стиля линии. Работа с ним описана в разделе 11.1.2.1.

4. Настройте параметры нового стиля и закройте диалог создания стиля кнопкой ОК.

5. Название созданного стиля появится в списке Менеджера стилей линий. Закройте Менеджер стилей линий кнопкой ОК.

Название созданного стиля появится в диалоге выбора стиля на вкладке Внедренные. Вы можете назначить этот стиль текущей кривой, нажав кнопку Выбрать.

При создании или редактировании штриховки (текста) для создания нового стиля штриховки (текста) выполните следующие действия.

1. Разверните список Стиль на Панели свойств и выберите строку Другой стиль.

На экране появится диалог выбора стиля. На рис. 11.1.4 приведен пример диалога выбора стиля штриховки, диалог выбора стиля текста аналогичен ему. По умолчанию в диалоге выбора стиля отображается список стилей документа (о чем свидетельствует строка в верхней части диалога — см. рис. 11.1.4).

2. Если это не так, нажмите кнопку Документ в группе Показать.

3. Активизируйте вкладку Внедренные и нажмите кнопку Новый....

Рис. 11.1.4. Диалог выбора стиля штриховки

На экране появится диалог создания и редактирования стиля объекта. Работа с диалогом создания стилей штриховок описана в разделе 11.1.3.1, а с диалогом создания стилей текстов — в разделе 11.1.4.1.

4. Настройте параметры нового стиля и закройте диалог создания стиля кнопкой ОК.

Название созданного стиля появится в списке на вкладке Внедренные. Вы можете назначить этот стиль текущему объекту, нажав кнопку Выбрать.

Стиль, созданный при создании или редактировании объекта, ничем не отличается от созданного в диалоге работы с наборами и библиотеками стилей.


11.1.1.2.3. Удаление отдельных стилей, наборов и библиотек стилей

Чтобы удалить ставшие ненужными стили, выполните следующие действия.

1. Вызовите команду Сервис — Библиотеки стилей, типов, оформлений и основных надписей — Стили линий... / Стили штриховок... / Стили текстов... в зависимости от типа объектов, со стилями которых будет вестись работа.

На экране появится диалог работы с наборами и библиотеками стилей.

2. Отобразите в диалоге тот список стилей, в котором хранится удаляемый стиль.

Для этого используйте кнопки Показать библиотеку..., Показать набор... или Показать документ.

3. Выделите стили, подлежащие удалению, и нажмите кнопку Удалить.

На экране появится диалог удаления стилей (рис. 11.1.5). Этот диалог содержит наименование удаляемого стиля и кнопки управления удалением. Назначение кнопок представлено в таблице 11.1.3.

Рис. 11.1.5. Диалог удаления стилей

Табл. 11.1.3. Кнопки управления удалением стилей объектов
Кнопка | Назначение
Удалить | Удаление стиля, название которого отображается в диалоге. После нажатия этой кнопки происходит переход к следующему стилю (если для удаления было выбрано несколько стилей).
Удалить все1 | Удаление всех выделенных стилей.
Пропустить1 | Отмена удаления стиля, название которого отображается в диалоге. После нажатия этой кнопки происходит переход к следующему стилю.
Отмена | Прерывание операции удаления стилей.
  1. Кнопка доступна, если для удаления было выбрано несколько стилей.

Внедренные в документ стили линий, при условии, что они не используются, можно удалить в Менеджере стилей линий (см. рис. 11.1.9).

Будьте внимательны при удалении стилей, так как их восстановление невозможно.

Чтобы удалить ставший ненужным набор стилей, выполните следующие действия.

1. Вызовите команду Сервис — Библиотеки стилей, типов, оформлений и основных надписей — Стили линий... / Стили штриховок... / Стили текстов... в зависимости от типа объектов, со стилями которых будет вестись работа.

На экране появится диалог работы с наборами и библиотеками стилей.

2. Нажмите кнопку Показать набор....

3. В появившемся диалоге работы с наборами стилей выделите набор, подлежащий удалению, и нажмите кнопку Удалить.

4. Ответьте Да на вопрос системы об удалении набора.

5. Нажмите кнопку Выход диалога работы с наборами стилей.

Удаление текущего набора (список стилей которого отображается в данный момент в диалоге работы с наборами и библиотеками стилей) невозможно.

Будьте внимательны при удалении наборов: после выхода из диалога работы с наборами отмена операции невозможна. Восстановить набор можно только сразу после положительного ответа на вопрос об удалении. Для этого следует нажать кнопку Отмена в диалоге работы с наборами стилей.

Для удаления библиотеки стилей необходимо удалить ее файл с диска.


11.1.1.2.4. Номер стиля

Каждый стиль имеет номер, который присваивается стилю при его создании.

Номера стилей, хранящихся в документах и наборах, могут совпадать, так как эти стили используются непосредственно (без формирования ссылок).

Номера стилей, хранящихся в библиотеке, обязательно должны быть различными. Это связано с тем, что при назначении объекту библиотечного стиля в документе, содержащем объект, возникает ссылка на этот стиль. Ссылка включает в себя следующие сведения: полное имя библиотеки и номер стиля из нее.

При попытке помещения в библиотеку стиля (путем создания или копирования), номер которого совпадает с номером одного из имеющихся в ней стилей, на экране появляется диалог-предупреждение (рис. 11.1.6).

Рис. 11.1.6. Диалог-предупреждение
о наличии стиля в библиотеке

Он содержит названия стилей, имеющих одинаковые номера, и управляющие кнопки. Назначение кнопок представлено в таблице 11.1.4.

Табл. 11.1.4. Кнопки, управляющие помещением объекта в библиотеку
Кнопка | Назначение
Добавить с сохранением старого | Помещение объекта в библиотеку без удаления из нее существующего объекта. Новому объекту будет присвоен первый из «незанятых» номеров.
Добавить вместо старого | Помещение объекта в библиотеку с замещением существующего объекта. Имеющийся объект будет удален — таким образом «освободится» его номер. Новый объект будет размещен в библиотеке без изменения номера.
Не добавлять | Отказ от помещения объекта в библиотеку. Отказ от помещения в библиотеку вновь созданного объекта означает потерю всех сделанных настроек. Так как в данном случае помещаемый объект еще не используется ни в одном документе, его целесообразнее добавить с сохранением имеющегося.

Если в библиотеке есть стиль, который совпадает с добавляемым стилем как по номеру, так и по имени, то на экране появится запрос на перезапись стиля — замену старого стиля новым. Вы можете подтвердить перезапись или отказаться от нее.

Если вероятность обмена стилями между несколькими библиотеками достаточно велика, то следует позаботиться о том, чтобы все стили в этих библиотеках имели разные номера. Это позволит избежать вышеописанных конфликтов.


11.1.1.2.5. Хранение в документе информации о стилях объектов

Итак, если объект (линия, штриховка или текст) использует стиль, отличный от системного, то возможны два варианта хранения в документе информации об этом стиле.

Первый вариант — хранение самого стиля внутри документа (внедренный стиль).

Второй вариант — хранение ссылки на библиотеку, содержащую используемый стиль (библиотечный стиль).

Все имеющиеся в текущем документе ссылки, в том числе на библиотеки стилей, можно просмотреть на вкладке Внешние ссылки диалога информации о документе. Для его вызова служит команда Файл — Информация о документе....

Наборы, как и документы, могут содержать либо сами стили (их перечень отображается на вкладке Внедренные — см. рис. 11.1.1), либо ссылки на библиотечные стили (их перечень отображается на вкладке Библиотечные).

При назначении объекту стиля, непосредственно содержащегося в наборе, использованный стиль копируется в документ, т.е. реализуется первый вариант хранения информации о стиле.

При назначении объекту стиля, содержащегося в наборе в виде ссылки, в документе также формируется ссылка на выбранный стиль, т.е. реализуется второй вариант хранения информации о стиле.

Редактирование стиля, хранящегося в документе, отражается только на этом документе: изменяется внешний вид всех объектов, которые используют отредактированный стиль.

Редактирование стиля, хранящегося в библиотеке, отражается на всех документах, содержащих объекты, которые используют отредактированный стиль.

Если при открытии документа не найдена (удалена, перемещена или переименована) библиотека, стиль штриховки или текста из которой используется в этом документе, то на экране появляется диалог-предупреждение (рис. 11.1.7).

Рис. 11.1.7. Диалог-предупреждение об отсутствии библиотеки стилей штриховки

Диалог содержит полное имя ненайденной библиотеки и управляющие кнопки. Назначение кнопок представлено в таблице 11.1.5.

Табл. 11.1.5. Кнопки диалога-предупреждения об отсутствии библиотеки стилей
Кнопка | Назначение
Найти файл | Указание файла библиотеки, из которой следует взять стиль.
Удалить стиль | Удаление ссылки на библиотеку и присвоение объектам системного стиля.
Отказ от чтения | Отмена команды открытия документа.

Если библиотека, на которую ссылается документ, обнаружена, но в ней отсутствует стиль штриховки или текста с нужным номером, то производится замена стиля по следующему правилу:

– вместо ненайденного стиля штриховки — системный стиль Металл,

– вместо ненайденного стиля текста — соответствующий системный стиль (Текст на чертеже, Размерные надписи и т.д.).

Если при открытии документа не найдена библиотека, стиль линии из которой используется в этом документе, либо в библиотеке не найден стиль, то на экране появляется сообщение, показанное на рисунке 11.1.8.

Рис. 11.1.8. Диалог-предупреждение об отсутствии библиотек или стилей линий

В документе начертание линии, использующей ненайденный библиотечный стиль, не изменяется.


11.1.1.3. Особенности работы со стилями линий

Особенностью работы со стилями линий (в отличие от работы со стилями штриховок и текстов) является возможность составления списка стилей для текущего и новых документов.

Настройка списка производится в Менеджере стилей линий (рис. 11.1.9). При работе с текущим документом Менеджер также позволяет выполнять основные действия со стилями линий — создание, редактирование и удаление.

Рис. 11.1.9. Менеджер стилей линий при настройке списка стилей линий текущего документа

В левой части Менеджера стилей линий отображается список стилей документа. Кнопки над списком позволяют:

– создавать новые стили линий в документе,

– редактировать внедренные стили,

– удалять внедренные стили (при условии, что они не используются).

В правой части Менеджера стилей линий (она появляется после нажатия кнопки Добавить стили) можно открыть библиотеку (или набор) для включения стилей из нее в список стилей документа. Доступно два способа добавления стилей:

– создание ссылки на библиотечный стиль,

– внедрение в документ стиля из библиотеки или набора.

Менеджер стилей линий может быть вызван двумя способами:

– нажатием кнопки Изменить список... в диалоге настройки стилей линий для текущего или новых графических документов,

– нажатием кнопки Менеджер стилей... в диалоге выбора стиля линии (см. рис. 11.1.3).


11.1.2. Пользовательский стиль линии

11.1. Стили объектов

11.1.2. Пользовательский стиль линии

Чтобы создать стиль линии, выполните следующие действия.

1. Вызовите команду Сервис — Библиотеки стилей, типов, оформлений и основных надписей — Стили линий....

На экране появится диалог работы с наборами и библиотеками стилей.

2. Выберите место хранения будущего стиля.

Для этого используйте кнопки Показать библиотеку..., Показать набор... или Показать документ. О местах хранения стилей рассказано в разделе 11.1.1.1.

3. Нажмите кнопку Создать.

На экране появится диалог создания и редактирования стиля линии.

4. Настройте параметры нового стиля (см. раздел 11.1.2.1) и закройте диалог.

Название созданного стиля появится в активном окне просмотра диалога работы с наборами и библиотеками стилей.

После изучения материала, изложенного в разделе 11.1.2.1, рекомендуется выполнить упражнения раздела 11.1.2.2. Это позволит вам на практике ознакомиться с описанными приемами создания стилей линий.

В этом разделе:

11.1.2.1. Настройка стиля линии

11.1.2.1.1. Стиль линии с фрагментами

11.1.2.2. Практика создания стилей линий

Упражнение 71. Создание библиотеки стилей линий

Упражнение 72. Создание стиля линии без фрагментов

Упражнение 73. Проверка созданного стиля линии

Упражнение 74. Создание стиля линии с фрагментами

Упражнение 75. Создание стиля линии с фрагментами. Самостоятельная работа


11.1.2.1. Настройка стиля линии

Настройка параметров стиля линии производится в диалоге создания и редактирования стиля (рис. 11.1.10). Элементы управления этого диалога представлены в таблице 11.1.6.

Рис. 11.1.10. Диалог создания и редактирования стиля линии

Табл. 11.1.6. Диалог создания и редактирования стиля линии

Элемент

Описание

Название

Поле для ввода (редактирования) имени стиля. Рекомендуется давать стилям информативные названия, которые хорошо отражают назначения стилей. В дальнейшем это упростит поиск стиля в списке.

Номер

Поле для ввода (редактирования) номера стиля. Правила нумерации стилей изложены в разделе 11.1.1.2.4.

Тип кривой

Группа опций, позволяющая выбрать тип линии: Сплошная или Прерывистая.

Назначить прототип

Кнопка, позволяющая указать существующий стиль в качестве шаблона (прототипа) вновь создаваемого стиля. Назначение прототипа удобно использовать, если новый стиль является модификацией уже имеющегося.

После нажатия данной кнопки на экране появляется диалог, в котором требуется выбрать стиль-прототип.

После этого в диалоге создания и редактирования стиля линии включаются опции и появляются значения, соответствующие параметрам стиля-прототипа.

Является границей
для штриховки

Включение этой опции означает, что линии данного стиля будут учитываться системой при автоматическом определении границ штриховки.

Параметры пера

Группа элементов (см. табл. 11.1.7), позволяющая задать параметры отрисовки линии на экране и при выводе на печать.

Цвет

Кнопка, позволяющая выбрать цвет линии.

Описание прерывистой кривой

Группа элементов (см. табл. 11.1.8), позволяющая задать параметры прерывистой кривой. Данная группа доступна, если в группе Тип кривой включена опция Прерывистая.

Просмотр

В этом поле отображается внешний вид стиля линии, что позволяет немедленно оценить внесенные изменения.

Табл. 11.1.7. Элементы группы Параметры пера

Элемент

Описание

Назначаемые

Опция, позволяющая назначить произвольные параметры пера. После ее включения становятся доступны поля ввода толщины.

Основной/
Тонкой/
Утолщенной линии

Если параметры отрисовки линии создаваемого стиля должны совпадать с параметрами, установленными для какой-либо системной линии (основной, тонкой или утолщенной), включите соответствующую опцию. При включении одной из этих опций поля ввода толщины становятся недоступны.

При изменении параметров основной, тонкой или утолщенной системной линии1 изменяется также внешний вид линий пользовательского стиля, при настойке которого была включена соответствующая опция.

Толщина
на бумаге

Толщина отрисовки линии при выводе на бумагу (в миллиметрах).

Толщина
на экране

Толщина отрисовки линии на экране (в пикселах).
  1. Настройка параметров системных линий производится в диалоге, вызываемом командой Сервис — Параметры... — Система — Графический редактор — Системные линии.

Табл. 11.1.8. Элементы группы Описание прерывистой кривой

Элемент

Описание

Штрих-промежуток

Список заданных сочетаний длин штрихов и промежутков. Линия может состоять из последовательности таких сочетаний.

Чтобы отредактировать размеры штриха и промежутка в сочетании, выделите его в списке и измените значения в полях Длина штриха и Длина промежутка.

Длина штриха,

Длина промежутка

Размеры штрихов и промежутков в миллиметрах.

Добавить

Кнопка, позволяющая создать новое сочетание штриха и промежутка.

Размеры штриха и промежутка в новом сочетании такие же, как в сочетании, выделенном перед созданием нового.

Новое сочетание добавляется в конец списка.

Удалить

Кнопка, позволяющая удалить выделенное в списке сочетание штриха и промежутка.

Фрагмент

Кнопка, позволяющая добавить к сочетанию штриха и промежутка произвольный фрагмент КОМПАС-3D. Подробнее об этой возможности рассказано в разделе 11.1.2.1.1.

X, Y

Поля для ввода смещений начала координат фрагмента относительно начала штриха.

Игнорировать стили линий фрагментов

Если эта опция включена, то для всех линий всех фрагментов используются толщина и цвет, заданные для настраиваемого стиля линии (с помощью кнопки Цвет и группы Параметры пера).

Если опция выключена, то толщина и цвет линий фрагментов зависят от использованных в них стилей линий следующим образом:

– Пользовательские стили линии фрагмента заменяются системным стилем линии Основная с текущими параметрами (т.е. с цветом и толщинами для экрана и для печати, установленными в системе на момент включения фрагмента в стиль линии).

– Системные стили линии фрагмента записываются в стиль линии с текущими параметрами (если во время создания фрагмента параметры системных линий были другими, то эти параметры заменяются текущими)1. Разрывы линий удаляются (т.е. прерывистые линии, такие как Штриховая, Осевая и т.п., заменяются сплошными).

Кривая всегда заканчивается штрихом

Включение этой опции означает, что линия будет начинаться и заканчиваться штрихом (а не промежутком). Подгонка производится путем пропорционального изменения длин штрихов.

Состояние данной опции учитывается, только если штрихи имеют ненулевую длину.
  1. Параметры линий фрагмента сохраняются в стиле линии. Их изменение недоступно ни во время, ни после создания стиля.

В этом разделе:

11.1.2.1.1. Стиль линии с фрагментами


11.1.2.1.1. Стиль линии с фрагментами

КОМПАС-3D позволяет получать не только сплошные и прерывистые линии, но также линии, в состав которых входят фрагменты — изображения, периодически повторяющиеся на протяжении линии (рис. 11.1.11).

Рис. 11.1.11. Примеры линий, содержащих фрагменты

Выбор фрагментов производится при настройке стиля линии — в группе Описание прерывистой кривой диалога создания и редактирования стиля линии (см. рис. 11.1.10). Фрагменты можно включать только в прерывистую кривую.

Для имитации непрерывной линии задайте длину промежутка равной нулю.

Чтобы добавить фрагмент в сочетание штрих-промежуток, выделите это сочетание в списке и нажмите кнопку Фрагмент....

На экране появится стандартный диалог выбора файлов, в котором требуется указать включаемый в стиль линии фрагмент *.frw (разумеется, его необходимо заранее подготовить).

Затем следует указать положение изображения относительно начала штриха. Для этого в поле X введите значение смещения в направлении штрихов (вдоль линии), а в поле Y — смещение перпендикулярно направлению штрихов (перпендикулярно линии).

Фрагменты включаются в стиль линии в соответствии со следующими правилами.

– В одно сочетание штриха и промежутка можно включить один фрагмент.

– Начало координат фрагмента сдвигается на указанные значения X и Y относительно начала штриха в сочетании «штрих-промежуток», фрагмент не поворачивается и не масштабируется.

– Начало координат фрагмента должно попадать в интервал длина штриха + длина промежутка (т.е. смещение фрагмента по Х должно быть меньше общей длины сочетания «штрих-промежуток»).

– Фрагмент, включенный в стиль линии, теряет связь со своим файлом-источником.

Для удаления фрагмента из стиля линии необходимо удалить сочетание штрих-промежуток, содержащее этот фрагмент.

– В состав «картинки» в стиле линии из фрагмента передаются только кривые, заливки и надписи, имеющие шрифт True Type. При этом буквы превращаются в заливки.

– Собственные цвета заливок и текстов в составе фрагментов игнорируются. Для них используется цвет, выбранный для штрихов настраиваемого стиля линии.

– Толщина и цвет линий «картинки» в зависимости от состояния опции Игнорировать стили линий фрагментов (см. табл. 11.1.8) могут совпадать с толщиной и цветом штрихов в настраиваемом стиле линии, а могут зависеть от использованных во фрагментах стилей линий.

Линии, в стиль которых включены фрагменты, отрисовываются в документе в соответствии со следующими правилами.

– Фрагменты, габариты которых выходят за пределы кривой, не отрисовываются.

– Фрагменты располагаются так, чтобы ось X каждого из них была направлена по касательной к кривой в точке начала штриха.

– Штриховки, заливки и эквидистанты контуров, образованных линиями, включающими фрагменты, строятся без учета фрагментов.


11.1.2.2. Практика создания стилей линий

Настоящий раздел содержит упражнения, позволяющие овладеть приемами создания стилей линий (в том числе стилей, содержащих фрагменты).

В этом разделе:

Упражнение 71. Создание библиотеки стилей линий

Упражнение 72. Создание стиля линии без фрагментов

Упражнение 73. Проверка созданного стиля линии

Упражнение 74. Создание стиля линии с фрагментами

Упражнение 75. Создание стиля линии с фрагментами. Самостоятельная работа


Упражнение 71. Создание библиотеки стилей линий

Задание. Создайте файл библиотеки стилей линий user_lines.lcs.

1. Вызовите команду Сервис — Библиотеки стилей, типов, оформлений и основных надписей — Стили линий.... На экране появится диалог работы с наборами и библиотеками стилей.

2. Щелкните мышью в правом окне просмотра. Оно станет активным — вокруг него появится рамка.

3. Нажмите кнопку Показать библиотеку.

4. На экране появится диалог открытия файлов. По умолчанию текущей является папка \Sys, содержащая системную библиотеку стилей линий Graphic.lcs. Если необходимо, выберите другую папку.

5. Введите в поле Имя файла имя новой библиотеки — user_lines.

6. Нажмите кнопку Открыть. На экране появится диалог с запросом на создание файла user_lines.lcs.

7. Нажмите кнопку Да.

В текущей папке будет создана новая библиотека стилей линий — user_lines.lcs.

Диалог с запросом и диалог открытия файлов закроются, на экране останется диалог работы с наборами и библиотеками стилей. Заголовок активного (правого) окна просмотра будет содержать слово «Библиотека» и полный путь к созданной библиотеке. Так как в ней еще нет стилей, активное окно просмотра пусто.

Не закрывая диалог работы с наборами и библиотеками стилей, переходите к выполнению следующего упражнения.


Упражнение 72. Создание стиля линии без фрагментов

Задание. Создайте стиль линии, показанный на рисунке 11.1.12. Размеры штрихов и промежутков показаны на рисунке 11.1.13. Толщина линии — 1,2 мм, цвет — темно-синий.

Рис. 11.1.12. Образец стиля линии

Рис. 11.1.13. Размеры штрихов и промежутков

1. Нажмите кнопку Создать в диалоге работы с наборами и библиотеками стилей.

На экране появится диалог создания стиля линии.

2. Введите в поле Номер значение 100.

3. Введите в поле Название имя создаваемого стиля — Штриховая специальная.

4. В группе Тип кривой выберите вариант Прерывистая.

5. Включите опцию Является границей для штриховки, чтобы линия создаваемого стиля могла ограничивать штриховку.

6. Выберите вариант Назначаемые в группе Параметры пера.

7. Введите в поле Толщина на бумаге значение 1.2, а в поле Толщина на экране — 2.

8. Нажмите кнопку Цвет и выберите для линии темно-синий цвет.

Создаваемый стиль состоит из четырех сочетаний штрих-промежуток (рис. 11.1.14).

Рис. 11.1.14. Сочетания штрихов и промежутков в стиле линии Штриховая специальная

Список Штрих-промежуток в группе Описание прерывистой кривой пока содержит одно сочетание штриха и промежутка. Длина штриха по умолчанию равна длине промежутка и равна 1 мм.

9. Измените эти значения на следующие: длина штриха — 4, длина промежутка — 2.

Сделанные изменения будут переданы в список сочетаний Штрих-промежуток. В поле Просмотр будет показана линия, состоящая из четырехмиллиметровых штрихов, разделенных двухмиллиметровыми промежутками.

10. Нажмите кнопку Добавить.

В списке Штрих-промежуток появится новое сочетание, которое дублирует имеющееся.

11. Сделайте длину штриха равной 2, а промежутка — 1.

Это изменение также отразится в списке сочетаний и в поле Просмотр.

12. Добавьте третье и четвертое сочетания в соответствии с рис. 11.1.14.

13. Включите опцию Кривая всегда заканчивается штрихом, чтобы линия создаваемого стиля начиналась и заканчивалась штрихами, а не промежутками.

Настройка нового стиля завершена (рис. 11.1.15).

Нажмите кнопку ОК в диалоге создания стиля.

Рис. 11.1.15. Настройки стиля линии Штриховая специальная

Диалог создания стиля будет закрыт. На экране останется диалог работы с наборами и библиотеками стилей. В правом окне просмотра появится название первого стиля текущей библиотеки — созданного вами стиля Штриховая специальная.

14. Закройте диалог работы с наборами и библиотеками стилей.


Упражнение 73. Проверка созданного стиля линии

Задание. Проверьте, соответствует ли созданный вами стиль линии Штриховая специальная требованиям, указанным в задании к упражнению 72.

1. Создайте графический документ КОМПАС-3D.

2. Вызовите команду Инструменты — Геометрия — Отрезки — Отрезок.

3. Щелкните мышью в поле Стиль на Панели свойств.

4. В развернувшемся списке выберите строку Другой стиль....

5. В появившемся диалоге выбора текущего стиля нажмите кнопку Менеджер стилей....

6. В появившемся на экране Менеджере стилей линий нажмите кнопку Добавить стили.

7. В правой части Менеджера нажмите кнопку Показать библиотеку.

8. В появившемся диалоге открытия файла укажите созданную вами библиотеку user_lines.lcs и нажмите кнопку Открыть. В правой части Менеджера стилей линий появляется список стилей, содержащихся в выбранной библиотеке. В данном случае список состоит из одной строки; эта строка выделена.

Чтобы библиотечный стиль можно было использовать в документе, его следует добавить или внедрить в этот документ. Добавленный стиль сохраняет связь с библиотекой, т.е. изменение стиля в библиотеке отразится в документе; внедренный стиль связи с библиотекой не имеет (фактически он не отличается от стиля, созданного непосредственно в документе).

9. Нажмите кнопку Добавить библиотечный стиль или кнопку Внедрить стиль в документ.

10. Закройте Менеджер стилей линий кнопкой ОК.

На экране останется диалог выбора текущего стиля.

11. Если стиль был добавлен, активизируйте в диалоге выбора текущего стиля вкладку Библиотечные, а если внедрен — Внедренные.

12. В списке стилей на вкладке укажите единственный стиль — Штриховая специальная — и нажмите кнопку Выбрать.

Диалог закроется, а выбранный стиль линии станет текущим: он будет отображаться в поле Стиль.

13. Создайте отрезок длиной 50 мм.

Получившаяся линия должна иметь темно-синий цвет и толщину на экране 2 пиксела.

Так как при настройке стиля линии была включена опция Кривая всегда заканчивается штрихом, при отрисовке линии производится подгонка штрихов — такое пропорциональное изменение их длин, чтобы указанное условие выполнялось. Благодаря тому, что длина отрезка значительно превышает длины штрихов, их искажения не видны.

При малой длине отрезка изменения длин штрихов могут стать заметными.

Если же длина отрезка меньше суммы длин всех сочетаний штрих-промежуток, заданных при настройке стиля линии, то отрисовывается сплошная линия.

При отключенной опции Кривая всегда заканчивается штрихом подгонка длин штрихов не производится.

14. Чтобы проверить, соблюдается ли толщина, заданная для печати (1.2 мм), выведите документ на печать.

15. Чтобы проверить, является ли созданная линия границей штриховки, постройте окружность таким образом, чтобы созданный отрезок являлся ее хордой.

16. Создайте штриховку, указав ее базовую точку внутри окружности. Штриховка должна появиться только в части окружности, ограниченной отрезком.


Упражнение 74. Создание стиля линии с фрагментами

Задание. Создайте стиль линии Перекрытие маслонепроницаемое (рис. 11.1.16, 11.1.17). Толщина и цвет линии соответствуют основной линии.

Рис. 11.1.16. Образец стиля линии

Рис. 11.1.17. Размеры элементов

1. Создайте фрагмент, который будет входить в стиль линии.

1.1. Создайте новый фрагмент.

1.2. В этом фрагменте создайте изображение окружности радиусом 1 мм с центром в начале координат. Стиль линии окружности может быть любым.

1.3. Сохраните фрагмент под именем line_style.frw.

2. Вызовите команду Сервис — Библиотеки стилей, типов, оформлений и основных надписей — Стили линий....

3. Откройте библиотеку user_lines.lcs, созданную при выполнении упражнения 71.

3.1. Нажмите кнопку Показать библиотеку.

3.2. В появившемся диалоге открытия файлов укажите файл user_lines.lcs.

В заголовке текущего окна просмотра появится полное имя библиотеки, а в самом окне — перечень содержащихся в ней стилей.

4. Создайте новый стиль.

4.1. Нажмите кнопку Создать.

На экране появится диалог создания стиля линии.

4.2. Введите в поле Номер значение 101.

4.3. Введите в поле Название имя создаваемого стиля — Перекрытие маслонепроницаемое.

4.4. В группе Тип кривой выберите вариант Прерывистая.

4.5. Включите опцию Является границей для штриховки.

4.6. В группе Параметры пера выберите вариант Основной линии.

4.7. Список Штрих-промежуток в группе Описание прерывистой кривой содержит одно сочетание штриха и промежутка. Длина штриха по умолчанию равна длине промежутка и равна 1 мм. Поменяйте эти значения на следующие: длина штриха — 3, длина промежутка — 2.

Если перед нажатием кнопки Создать в диалоге был выделен стиль Штриховая специальная, то этот стиль по умолчанию используется как прототип. Поэтому список Штрих-промежуток будет содержать четыре сочетания. Удалите три из них, воспользовавшись кнопкой Удалить. Оставшееся сочетание отредактируйте, изменив длины штриха и промежутка.

Сделанные изменения будут переданы в список сочетаний Штрих-промежуток. В поле Просмотр будет показана линия, состоящая из трехмиллиметровых штрихов, разделенных двухмиллиметровыми промежутками.

4.8. Включите опцию Кривая всегда заканчивается штрихом, чтобы линия создаваемого стиля начиналась и заканчивалась штрихами.

4.9. Нажмите кнопку Фрагмент.... На экране появится диалог открытия файлов.

4.10. В этом диалоге укажите файл, созданный при выполнении п.1, и нажмите кнопку Открыть.

В текущее (выделенное в списке) сочетание штриха и промежутка будет добавлен выбранный фрагмент. Это отражается в поле Просмотр: в нем появилось изображение из выбранного фрагмента — окружность.

Так как значения в полях X и Y — смещения начала координат фрагмента относительно начала штриха — по умолчанию равны нулю, штрихи «перекрывают» окружности.

Чтобы создаваемый стиль соответствовал образцу, необходимо разместить центр окружности в середине промежутка (рис. 11.1.18).

Рис. 11.1.18. Положение окружности относительно начала штриха

4.11. Введите в поле X значение 4.

Окружности в поле Просмотр будут смещены на 4 мм вправо, благодаря чему займут требуемое положение.

Вертикальное смещение не требуется, поэтому в поле Y нужно оставить значение 0.

4.12. Настройка нового стиля завершена (рис. 11.1.19). Нажмите кнопку ОК диалога создания стиля линии.

Диалог создания стиля закроется, а в текущем окне просмотра появится название второго стиля — Перекрытие маслонепроницаемое.

Рис. 11.1.19. Настройки стиля линии Перекрытие маслонепроницаемое

5. Закройте диалог работы с наборами и библиотеками стилей, нажав кнопку Выход.

6. Убедитесь в том, что стиль создан правильно, выполнив действия, аналогичные описанным в упражнении 73.


Упражнение 75. Создание стиля линии с фрагментами. Самостоятельная работа

Задание. Создайте стиль линии Перекрытие газонепроницаемое (рис. 11.1.20, 11.1.21). Толщина и цвет линии соответствуют основной линии.

Рис. 11.1.20. Образец стиля линии

Рис. 11.1.21. Размеры элементов


11.1.3. Пользовательский стиль штриховки

11.1. Стили объектов

11.1.3. Пользовательский стиль штриховки

Чтобы создать стиль штриховки, выполните следующие действия.

1. Вызовите команду Сервис — Библиотеки стилей, типов, оформлений и основных надписей — Стили штриховок....

На экране появится диалог работы с наборами и библиотеками стилей.

2. Выберите место хранения будущего стиля.

Для этого используйте кнопки Показать библиотеку..., Показать набор... или Показать документ. О местах хранения стилей рассказано в разделе 11.1.1.1.

3. Нажмите кнопку Создать.

На экране появится диалог создания и редактирования стиля штриховки.

4. Настройте параметры нового стиля (см. раздел 11.1.3.1) и закройте диалог.

Название созданного стиля появится в активном окне просмотра диалога работы с наборами и библиотеками стилей.

После изучения материала, изложенного в разделе 11.1.3.1, рекомендуется выполнить упражнения раздела 11.1.3.2. Это позволит вам на практике ознакомиться с описанными приемами создания стилей штриховок.

В этом разделе:

11.1.3.1. Настройка стиля штриховки

11.1.3.1.1. Установка параметров линии штриховки

11.1.3.2. Практика создания стилей штриховок

Упражнение 76. Создание библиотеки стилей штриховок. Самостоятельная работа

Упражнение 77. Создание стиля штриховки Фарфор

Упражнение 78. Проверка созданного стиля штриховки

Упражнение 79. Создание стиля штриховки Термопласт

Упражнение 80. Создание стилей штриховок. Самостоятельная работа


11.1.3.1. Настройка стиля штриховки

Настройка стиля штриховки — описание составляющих ее групп периодически повторяющихся линий. В этом разделе и в разделе 11.1.3.2 под словом «группа линий» будет подразумеваться группа линий штриховки.

Простая штриховка (например, штриховка системного стиля Металл) состоит из одной группы, а сложная штриховка (например, Неметалл) — из нескольких групп, наложенных друг на друга.

Настройка стиля штриховки производится в диалоге создания и редактирования стиля (рис. 11.1.22). Элементы управления этого диалога представлены в таблице 11.1.9.

Рис. 11.1.22. Диалог создания и редактирования стиля штриховки

Табл. 11.1.9. Диалог создания и редактирования стиля штриховки

Элемент

Описание

Название

Поле для ввода (редактирования) имени стиля.
Рекомендуется давать стилям информативные названия, хорошо отражающие назначения стилей. В дальнейшем это упростит поиск стиля в списке.

Номер

Поле для ввода (редактирования) номера стиля. Правила нумерации стилей изложены в разделе 11.1.1.2.4.

Окно просмотра

Содержит изображение текущего внешнего вида штриховки. Любое изменение параметров немедленно отражается в этом окне.

Линии
для штриховки

Группа элементов для работы с линиями, образующими штриховку. Эта группа содержит список групп линий, окно просмотра внешнего вида выделенной группы, а также кнопки управления группами.

Кнопка Добавить... позволяет включить в стиль штриховки новую группу линий. После ее нажатия на экране появляется диалог установки параметров линии штриховки (см. табл. 11.1.11). Новая группа всегда добавляется в конец списка.

Кнопка Редактировать... позволяет изменить параметры группы, выделенной в списке. После ее нажатия на экране также появляется диалог установки параметров линии.

Кнопка Удалить позволяет исключить из штриховки группу, выделенную в списке.

Масштаб

Поле для ввода масштаба изображения штриховки1. Если требуется, чтобы при создании штриховки данного стиля было возможно изменение ее масштаба, отключите опцию Не изменять 2 .

Угол наклона

Поле угла наклона изображения штриховки. Если требуется, чтобы при создании штриховки данного стиля было возможно изменение угла ее наклона, отключите опцию Не изменять 2.

Тип заполнения

Вариант Область позволяет задать сплошное заполнение штриховкой выбранных границ.

Вариант Полоса позволяет задать штриховку в виде полосы вдоль границы.

Поле Ширина полосы позволяет задать ширину полосы (в миллиметрах), которая будет заполняться штриховкой.
  1. На коэффициент, заданный в этом поле, умножаются следующие значения: Х, Y, deltaХ, deltaY (см. табл. 11.1.10), а также длины штрихов и промежутков в прерывистых линиях. Толщина линии не изменяется.
  2. В этом случае при формировании штриховки в графическом документе на Панели свойств появляется соответствующее поле.

В этом разделе:

11.1.3.1.1. Установка параметров линии штриховки


11.1.3.1.1. Установка параметров линии штриховки

При создании стиля штриховки взаимное расположение групп задается их смещением и поворотом относительно начала некоторой произвольно выбранной прямоугольной системы координат (рис. 11.1.23).

Внешний вид самой штриховки не зависит от того, как располагалась вспомогательная система координат при создании стиля штриховки. Поэтому положение системы координат рекомендуется выбирать исходя из соображений удобства работы. С примерами выбора положения системы координат вы можете ознакомиться, выполнив упражнения 77 и 79 из раздела 11.1.3.2.

При создании штриховки в графическом документе она располагается так, чтобы начало ее системы координат совпадало с началом системы координат фрагмента или вида чертежа. Угол поворота системы координат штриховки определяется значением, заданным в поле Угол наклона диалога создания и редактирования штриховки (см. табл. 11.1.9).

Рис. 11.1.23. Параметры группы линий штриховки

Параметры, характеризующие размещение группы линий в системе координат штриховки, представлены в таблице 11.1.10.

Табл. 11.1.10. Параметры группы линий штриховки
Параметр | Описание
угол | Угол наклона линий группы к оси Х системы координат штриховки.
X | Абсцисса начальной точки первой линии1.
Y | Ордината начальной точки первой линии.
deltaX | Сдвиг последующей линии относительно предыдущей (для групп прерывистых линий).
deltaY | Шаг линий (расстояние между соседними линиями).
  1. Начальной точкой сплошной линии является ее произвольная точка. Начальной точкой прерывистой линии является начало штриха в первом сочетании штрих-промежуток (см. табл. 11.1.8).

Выбор линий, составляющих группу, и задание размещения группы в системе координат штриховки производится в диалоге установки параметров линии (рис. 11.1.24).

Элементы управления этого диалога приведены в таблице 11.1.11.

Рис. 11.1.24. Диалог установки параметров линии штриховки

Табл. 11.1.11. Диалог установки параметров линии штриховки
Элемент | Описание
Выбор стиля линии | Группа элементов (см. табл. 11.1.12), позволяющих выбрать стиль линий, составляющих настраиваемую группу.
Угол, X, Y, deltaX, deltaY | Поля для ввода значений параметров, определяющих размещение группы линий в системе координат штриховки (см. рис. 11.1.23). Значения линейных величин задаются в миллиметрах.

Табл. 11.1.12. Элементы группы Выбор стиля линии

Элемент

Описание

Системные линии

Список системных линий, из которых может состоять настраиваемая группа линий штриховки.

Все
пользовательские
стили линий
данной
штриховки

Список пользовательских линий, из которых может состоять настраиваемая группа линий штриховки.

Новый...

Кнопка, позволяющая создать новый пользовательский стиль линии. Кнопка доступна, если активным элементом диалога является список пользовательских линий. Активизация производится щелчком мыши на этом списке.

После нажатия кнопки Новый... на экране появляется диалог создания и редактирования стиля линии (см. табл 11.1.6)1.

Редактировать...

Кнопка, позволяющая редактировать выделенный в списке пользовательский стиль линии. После нажатия этой кнопки на экране также появляется диалог создания и редактирования стиля линии.

Удалить

Кнопка, позволяющая удалить выделенный в списке пользовательский стиль линии.

При удалении пользовательского стиля все линии данной штриховки, для которых применялся этот стиль, будут отрисовываться системным стилем линии Основная.

Окно просмотра

Содержит изображение внешнего вида линии, выделенной в списке.
  1. При создании стиля линии для штриховки невозможно добавление фрагментов в сочетания штрих-промежуток, поэтому в диалоге создания стиля линии отсутствуют соответствующие элементы.


11.1.3.2. Практика создания стилей штриховок

В составе системы КОМПАС-3D поставляются штриховки, соответствующие российским ГОСТ. Вы можете разработать стили штриховок, соответствующие другим стандартам — ISO, DIN и др.

Настоящий раздел содержит упражнения, позволяющие овладеть приемами создания стилей штриховок на примере штриховок, использование которых предписано немецким стандартом DIN 201.

В этом разделе:

Упражнение 76. Создание библиотеки стилей штриховок. Самостоятельная работа

Упражнение 77. Создание стиля штриховки Фарфор

Упражнение 78. Проверка созданного стиля штриховки

Упражнение 79. Создание стиля штриховки Термопласт

Упражнение 80. Создание стилей штриховок. Самостоятельная работа


Упражнение 76. Создание библиотеки стилей штриховок. Самостоятельная работа

Упражнение 76. Создание библиотеки стилей штриховок.
Самостоятельная работа

Задание. Создайте библиотеку стилей штриховок user_hatches.lhs.

1. Вызовите команду Сервис — Библиотеки стилей, типов, оформлений и основных надписей — Стили штриховок....

2. Создайте библиотеку стилей штриховок user_hatches.lhs аналогично тому, как вы создавали библиотеку стилей линий в упражнении 71.

Не закрывая диалог работы с наборами и библиотеками стилей штриховок, переходите к выполнению следующего упражнения.


Упражнение 77. Создание стиля штриховки Фарфор

Задание. Создайте стиль штриховки Фарфор (рис. 11.1.25). Стиль линии штриховки — Тонкая.

Рис. 11.1.25. Стиль штриховки Фарфор: а) образец штриховки, б) расположение элементов штриховки
а) | б)

Данная штриховка состоит из четырех групп непрерывных линий (рис. 11.1.26).

Рис. 11.1.26. Группы линий, составляющие штриховку Фарфор: а) группа 1, б) группа 2, в) группа 3, г) группа 4
а) | б) | в) | г)

Положение системы координат выбрано так, чтобы в ней было удобно определять размещение групп. Параметры, характеризующие это размещение, приведены в таблице 11.1.13.

Табл. 11.1.13. Параметры, характеризующие размещение групп линий в системе координат штриховки
Группа | Угол | X | Y | deltaY
Группа 1 | 90° | 0 | 0 | 4
Группа 2 | 0° | 0 | 0 | 4
Группа 3 | 90° | 1 | 0 | 4
Группа 4 | 0° | 0 | 1 | 4

1. Нажмите кнопку Создать в диалоге работы с наборами и библиотеками стилей штриховок.

Проследите, чтобы активным было окно библиотеки user_hatches.lhs. В противном случае новый стиль будет добавлен в библиотеку (набор или документ), открытую в соседнем окне.

На экране появится диалог создания стиля штриховки. По умолчанию он содержит настройки, соответствующие системному стилю штриховки Металл.

2. Введите в поле Номер значение 100.

3. Введите в поле Название имя создаваемого стиля — Фарфор.

4. В поле Масштаб введите 1. Опцию Не изменять не включайте, чтобы при создании в чертеже штриховки данного стиля можно было изменить ее масштаб.

5. В поле Угол наклона введите 0, так как штриховка не должна быть повернута относительно абсолютной системы координат чертежа (фрагмента). Включите опцию Не изменять, чтобы при создании штриховки в чертеже невозможно было изменить ее угол наклона.

6. Так как штриховка должна быть образована тонкими линиями, можно использовать уже имеющуюся группу линий. Чтобы настроить ее параметры требуемым образом, нажмите кнопку Редактировать....

На экране появится диалог установки параметров линии штриховки. В нем необходимо задать параметры, характеризующие размещение первой группы линий в системе координат штриховки. Так как группа образована тонкими линиями, в списке Системные стили выделен стиль Тонкая.

6.1. В поле Угол введите 90.

6.2. В поле X введите 0.

6.3. В поле Y введите 0.

6.4. В поле deltaY введите 4.

6.5. На этом настройка группы 1 завершена. Нажмите кнопку ОК.

Диалог установки параметров линии закроется. На экране останется диалог создания стиля штриховки. В малом окне просмотра диалога отображается текущая (выделенная в списке) группа линий, а в большом окне просмотра — внешний вид штриховки. Пока штриховка содержит только одну группу, изображения в обоих окнах просмотра одинаковы.

7. Нажмите кнопку Добавить..., чтобы добавить в штриховку вторую группу линий.

На экране появится диалог установки параметров линии.

7.1. В группе Стили линий выделите стиль Тонкая.

7.2. Задайте параметры второй группы линий в соответствии с таблицей 11.1.13 и закройте диалог установки параметров линии.

Рис. 11.1.27. Создание стиля штриховки Фарфор

8. Аналогичным образом добавьте в штриховку третью и четвертую группы линий.

Настройка стиля штриховки Фарфор завершена (рис. 11.1.27).

9. Закройте диалог создания стиля штриховки, нажав кнопку ОК.

На экране останется диалог работы с наборами и библиотеками стилей штриховок. В библиотеке user_hatches.lhs появится созданный вами стиль штриховки Фарфор.

10. Закройте диалог работы с наборами и библиотеками стилей, нажав кнопку Выход.


Упражнение 78. Проверка созданного стиля штриховки

Задание. Проверьте, правильно ли настроен созданный вами стиль штриховки Фарфор.

1. Создайте графический документ КОМПАС-3D.

2. Создайте в нем замкнутый контур (прямоугольник, окружность или др.), используя системный стиль линии Основная.

3. Вызовите команду Инструменты — Штриховка.

4. Щелкните мышью в поле Стиль на Панели свойств.

5. В развернувшемся списке выберите строку Другой стиль.

6. В появившемся диалоге выбора текущего стиля нажмите кнопку Библиотеку....

7. В появившемся диалоге открытия файла укажите созданную вами библиотеку user_hatches.lhs.

8. На вкладке Библиотека диалога выбора текущего стиля выделите имя библиотечного стиля — Фарфор — и нажмите кнопку Выбрать.

Диалог закроется, а выбранный стиль штриховки станет текущим: он будет отображаться в поле Стиль.

9. Убедитесь в том, что поле Шаг, позволяющее изменить масштаб штриховки, присутствует на Панели свойств, а поле Угол наклона — отсутствует.

10. Нажмите кнопку Создать объект на Панели специального управления.

11. Рассмотрите созданную штриховку. Убедитесь в том, что рисунок штриховки совпадает с образцом, представленным на рис. 11.1.25, а используемый стиль линии — Тонкая.

Если при создании штриховки вы установили на Панели свойств масштаб, отличный от 1, расстояние между линиями изменится в соответствии с заданным коэффициентом.


Упражнение 79. Создание стиля штриховки Термопласт

Задание. Создайте стиль штриховки Термопласт (рис. 11.1.28). Стиль линии штриховки — Тонкая.

Рис. 11.1.28. Стиль штриховки Термопласт: а) образец штриховки, б) размер и расположение элементов штриховки
а) | б)

Данная штриховка состоит из двух групп непрерывных линий и четырех групп прерывистых линий (рис. 11.1.29).

В качестве системы координат штриховки выбрана система, ось X которой совпадает с одной из сплошных линий, расположенных под углом 45° к горизонтали, а ось Y — со сплошной линией, расположенной под углом 135°. На рисунке 11.1.29 штриховка повернута так, чтобы ось абсцисс ее системы координат располагалась горизонтально.

Рис. 11.1.29. Группы линий, составляющие штриховку Термопласт: а) группа 1, б) группа 2, в) группа 3, г) группа 4, д) группа 5, е) группа 6
а) группа 1 | б) группа 2 | в) группа 3
г) группа 4 | д) группа 5 | е) группа 6

Параметры, характеризующие размещение групп линий в системе координат штриховки, приведены в таблице 11.1.14.

Табл. 11.1.14. Параметры, характеризующие размещение групп линий в системе координат штриховки
Группа | Угол | X | Y | deltaХ | deltaY
Группа 1 | 90° | 0 | 0 |  | 8
Группа 2 | 0° | 0 | 0 |  | 8
Группа 3 | 90° | 1 | 1 | 8 | 8
Группа 4 | 90° | 7 | 1 | 8 | 8
Группа 5 | 0° | 1 | 1 | 8 | 8
Группа 6 | 0° | 1 | 7 | 8 | 8

Группы 3–6 содержат прерывистые линии. Все они образованы одинаковыми сочетаниями штрихов и промежутков. Эти сочетания, а также длины штрихов и промежутков показаны на рис. 11.1.30.

Рис. 11.1.30. Сочетания штрихов и промежутков в прерывистых линиях штриховки Термопласт

1. Вызовите команду Сервис — Библиотеки стилей, типов, оформлений и основных надписей — Стили штриховок....

На экране появится диалог работы с наборами и библиотеками стилей штриховок.

2. Откройте библиотеку user_hatches.lhs, созданную при выполнении упражнения 71.

2.1. Нажмите кнопку Показать библиотеку.

2.2. В появившемся диалоге открытия файлов укажите файл user_hatches.lhs.

В заголовке текущего окна просмотра появится полное имя библиотеки, а в самом окне — перечень содержащихся в ней стилей.

3. Нажмите кнопку Создать.

Проследите, чтобы активным было окно библиотеки user_hatches.lhs. В противном случае новый стиль будет добавлен в библиотеку (набор или документ), открытую в соседнем окне.

На экране появится диалог создания стиля штриховки. Если перед нажатием кнопки Создать в списке стилей текущей библиотеки был выделен имеющийся стиль Фарфор, то его параметры содержатся в диалоге создания стиля (т.е. выделенный стиль используется в качестве прототипа). В этом случае, воспользовавшись кнопкой Удалить, удалите из списка все линии, кроме первой (Тонкая).

Если стиль Фарфор не был выделен, то диалог содержит параметры, соответствующие системному стилю штриховки Металл.

4. Введите в поле Номер значение 101.

5. Введите в поле Название имя создаваемого стиля — Термопласт.

6. В поле Масштаб введите 1. Опцию Не изменять не включайте, чтобы при создании в чертеже штриховки данного стиля можно было изменить ее масштаб.

7. В поле Угол наклона введите 45, так как система координат штриховки повернута относительно абсолютной системы координат чертежа (фрагмента) на 45°. Включите опцию Не изменять, чтобы при создании штриховки в документе невозможно было изменить ее угол наклона.

8. Выполнив действия, аналогичные описанным в пп. 6–7 упражнения 77, отредактируйте имеющуюся группу тонких линий и добавьте новую. Параметры, характеризующие размещение этих групп в системе координат штриховки, приведены в таблице 11.1.14. Чтобы проконтролировать правильность ваших действий, сравните диалог, который вы видите на экране, с диалогом, показанным на рис. 11.1.31.

Рис. 11.1.31. Создание первой и второй групп линий

9. Нажмите кнопку Добавить..., чтобы добавить в штриховку третью группу линий.

На экране появится диалог установки параметров линии.

Третья группа содержит прерывистые линии. Так как все доступные системные линии — сплошные, необходимо создать пользовательский стиль линии.

9.1. Щелкните мышью в окне Все пользовательские стили линий данной штриховки.

9.2. Нажмите ставшую доступной кнопку Новый....

На экране появится диалог создания стиля линии.

Рис. 11.1.32. Настройка пользовательского стиля линии

9.3. В поле Название введите Тонкая прерывистая.

9.4. В группе Тип кривой выберите вариант Прерывистая.

9.5. В группе Параметры пера выберите вариант Тонкой линии.

9.6. Нажмите кнопку Цвет... и установите для линии черный цвет.

9.7. Линия состоит из четырех сочетаний штрихов и промежутков (см. рис. 11.1.30) В списке Штрих-промежуток по умолчанию содержится одно сочетание, длины штриха и промежутка в котором равны и составляют 1 мм. Введите в поле длины штриха и в поле длины промежутка значение 2. Это изменение будет передано в список Штрих-промежуток, а также отобразится в окне просмотра.

9.8. Нажмите кнопку Добавить. В списке появится второе сочетание штриха и промежутка. Отредактируйте его в соответствии с рис. 11.1.30.

9.9. Аналогичным образом добавьте третье и четвертое сочетание.

9.10. Настройка пользовательского стиля линии завершена (рис. 11.1.32). Нажмите кнопку ОК диалога.

Диалог создания стиля линии закроется. На экране останется диалог установки параметров линии.

10. Список Все пользовательские стили линий данной штриховки содержит имя созданного вами стиля линии — Тонкая прерывистая. Выделите этот стиль и введите в поля параметров значения, характеризующие размещение третьей группы линий в системе координат штриховки (см. табл. 11.1.14).

11. Настройка третьей группы линий завершена. Закройте диалог установки параметров линии, нажав кнопку ОК.

На экране останется диалог создания стиля штриховки. В списке линий появится строка Тонкая прерывистая, а в окне просмотра штриховки — изображение соответствующей группы линий.

Рис. 11.1.33. Создание третьей и четвертой групп линий

12. Нажмите кнопку Добавить....

13. В появившемся диалоге установки параметров линии выделите стиль Тонкая прерывистая и задайте параметры размещения четвертой группы линий. Затем закройте диалог, нажав кнопку ОК. Чтобы проконтролировать правильность ваших действий, сравните диалог, который вы видите на экране, с диалогом, показанным на рис. 11.1.33.

14. Аналогичным образом добавьте в штриховку пятую и шестую группы линий.

На этом создание стиля штриховки Термопласт завершено (рис. 11.1.34).

Рис. 11.1.34. Создание пятой и шестой групп линий

15. Закройте диалог создания стиля, нажав кнопку ОК.

На экране останется диалог работы с наборами и библиотеками стилей штриховок. Теперь текущая библиотека user_ hatches.lhs содержит два стиля: Фарфор и Термопласт.

16. Закройте диалог, нажав кнопку Выход.

17. Убедитесь в том, что стиль создан правильно, выполнив действия, аналогичные описанным в упражнении 78.


Упражнение 80. Создание стилей штриховок. Самостоятельная работа

Задание. Создайте стиль штриховки Изоляционный слой (рис. 11.1.35). Стиль линии штриховки — Тонкая.

Рис. 11.1.35. Стиль штриховки Изоляционный слой: а) образец штриховки, б) размер и расположение элементов штриховки
а) | б)

Задание. Создайте стиль штриховки Соли (рис. 11.1.36). Стиль линии штриховки — Тонкая.

Рис. 11.1.36. Стиль штриховки Соли: а) образец штриховки, б) размер и расположение элементов штриховки
а) | б)

Задание. Создайте стиль штриховки Гранит (рис. 11.1.37). Стиль линии штриховки — Тонкая.

Рис. 11.1.37. Стиль штриховки Гранит: а) образец штриховки, б) размер и расположение элементов штриховки
а) | б)

Задание. Создайте стиль штриховки Смола (рис. 11.1.38). Стиль линии штриховки — Тонкая.

Рис. 11.1.38. Стиль штриховки Смола: а) образец штриховки, б) размер и расположение элементов штриховки
а) | б)


11.1.4. Пользовательский стиль текста

11.1. Стили объектов

11.1.4. Пользовательский стиль текста

Чтобы создать стиль текста, выполните следующие действия.

1. Вызовите команду Сервис — Библиотеки стилей, типов, оформлений и основных надписей — Стили текстов....

На экране появится диалог работы с наборами и библиотеками стилей.

2. Выберите место хранения будущего стиля.

Для этого используйте кнопки:

– Показать библиотеку...,

– Показать набор...,

– Показать документ.

О местах хранения стилей рассказано в разделе 11.1.1.1.

3. Нажмите кнопку Создать.

На экране появится диалог создания и редактирования стиля текста.

4. Настройте параметры нового стиля (см. раздел 11.1.2.1) и закройте диалог.

Название созданного стиля появится в активном окне просмотра диалога работы с наборами и библиотеками стилей.

После изучения материала, изложенного в разделе 11.1.4.1, рекомендуется выполнить упражнения 81–83 из раздела 11.1.4.2. Это позволит вам на практике ознакомиться с описанными приемами создания стилей текстов.

В этом разделе:

11.1.4.1. Настройка стиля текста

11.1.4.1.1. Шрифт

11.1.4.1.2. Табуляция

11.1.4.1.3. Расширенный стиль текста

11.1.4.2. Практика создания и редактирования стилей текстов

Упражнение 81. Создание библиотеки стилей текстов. Самостоятельная работа

Упражнение 82. Создание стилей заголовков и основного текста

Упражнение 83. Проверка созданных стилей текстов

Упражнение 84. Редактирование системных стилей текстов в текущем документе

Упражнение 85. Редактирование системных стилей текстов в новых документах

Упражнение 86. Проверка настройки системных стилей текстов


11.1.4.1. Настройка стиля текста

Настройка стиля текста производится в диалоге создания и редактирования стиля (рис. 11.1.39). Элементы управления этого диалога представлены в таблице 11.1.15.

Рис. 11.1.39. Диалог создания и редактирования стиля текста

Табл. 11.1.15. Диалог создания и редактирования стиля текста
Элемент | Описание
Название | Поле для ввода (редактирования) имени стиля. Рекомендуется давать стилям информативные названия, которые хорошо отражают назначения стилей. В дальнейшем это упростит поиск стиля в списке.
Номер | Поле для ввода (редактирования) номера стиля. Правила нумерации стилей изложены в разделе 11.1.1.2.4.
Расширенный стиль текста | Опция, позволяющая установить дополнительные параметры стиля текста. После ее включения становится доступна кнопка Далее..., вызывающая диалог настройки расширенного стиля текста.
Шаг строк | Расстояние между базовыми линиями строк в абзаце (см. рис. 11.1.40).
Красная строка | Величина отступа вправо в первой строке абзаца (см. рис. 11.1.40)1.
Отступ слева Отступ справа | Расстояния между левой и правой границами поля ввода и соответствующими границами текста (см. рис. 11.1.40)1.
Интервал | Расстояние между двумя соседними абзацами. Оно складывается из двух величин — интервала после предыдущего абзаца и интервала перед последующим абзацем.
Выравнивание | Группа переключателей, позволяющая установить способ выравнивания абзацев (по левой границе, по правой границе, центрирование, выравнивание по двум границам).
Шрифт | Кнопка, позволяющая настроить параметры шрифта (см. раздел 11.1.4.1.1).
Табуляция | Кнопка, позволяющая настроить параметры табуляции (см. раздел 11.1.4.1.2).
Далее... | Кнопка, позволяющая настроить расширенный стиль текста (см. раздел 11.1.4.1.3).
  1. Обратите внимание на то, что из-за наличия просветов в символах шрифта, необходимых для того, чтобы буквы не «слипались» друг с другом, это расстояние может незначительно отличаться от заданного в диалоге.

Рис. 11.1.40. Параметры абзаца

В этом разделе:

11.1.4.1.1. Шрифт

11.1.4.1.2. Табуляция

11.1.4.1.3. Расширенный стиль текста


11.1.4.1.1. Шрифт

Настройка параметров шрифта производится в диалоге (рис. 11.1.41), который появляется после нажатия кнопки Шрифт... диалога создания и редактирования стиля текста.

Элементы управления диалога настройки параметров шрифта приведены в таблице 11.1.16.

Рис. 11.1.41. Диалог настройки параметров шрифта

Табл. 11.1.16. Диалог настройки параметров шрифта
Элемент | Описание
Шрифт | Список, позволяющий выбрать любой шрифт, установленный в Windows, за исключением растровых.
Высота | Поле для ввода или выбора высоты шрифта. Напоминаем, что высотой стандартного чертежного шрифта является вертикальный размер прописной буквы в миллиметрах.
Сужение | Поле для ввода или выбора сужения шрифта. Сужение меньше единицы означает уменьшение ширины букв и пробелов между ними в указанное количество раз, больше единицы — увеличение.
Цвет | Кнопка для выбора цвета символов текста.
Курсив | Опция, позволяющая установить наклонное начертание символов.
Жирный | Опция, позволяющая установить утолщенное начертание символов.
Подчеркнутый | Опция, позволяющая установить подчеркивание символов.
Пример | Окно просмотра выбранного шрифта с текущими параметрами.


11.1.4.1.2. Табуляция

Настройка табуляции производится в диалоге (рис. 11.1.42), который появляется на экране после нажатия кнопки Табуляция... диалога создания и редактирования стиля текста.

Элементы управления диалога настройки табуляции приведены в таблице 11.1.17.

Рис. 11.1.42. Диалог настройки параметров табуляции

Табл. 11.1.17. Диалог настройки табуляции
Элемент | Описание
Позиция | Положение отступа табуляции в миллиметрах.
Заполнение | Список, позволяющий выбрать способ заполнения табуляции.
Выравнивание | Группа переключателей, управляющая способом выравнивания текста относительно позиции табуляции (табл. 11.1.18). Выравнивание текста с помощью табуляций может использоваться, например, при формировании оглавлений.
Установить | Кнопка, позволяющая добавить настраиваемую табуляцию в список.
Удалить | Кнопка, позволяющая удалить выделенную табуляцию.
Удалить все | Кнопка, позволяющая очистить сразу весь список табуляций.

Табл. 11.1.18. Способы выравнивания текста относительно позиции табуляции
Способ | Описание | Пример
Влево | Часть строки, введенная после табуляции, располагается справа от ее позиции. Несколько строк, начинающихся с такой табуляции, оказываются выровненными по левому краю. | Многоколонная верстка. Каждый абзац состоит из одной строки и содержит табуляции, число которых равно числу колонок.
По центру | Часть строки, введенная после табуляции, располагается симметрично относительно ее позиции. | Заголовки. Табуляция вставляется на каждой строке перед текстом заголовка.
Вправо | Часть строки, введенная после табуляции, располагается слева от ее позиции, т.е. эта часть строки заканчивается в позиции табуляции. Несколько строк, содержащих такую табуляцию, оказываются выровненными по правому краю. | Оглавления. Между текстом заголовка и номером страницы вставляется правая табуляция с заполнением.
По десятичной точке | В позиции табуляции располагается точка, введенная в любом месте строки после табуляции. | Многоуровневые списки, вложенные оглавления.


11.1.4.1.3. Расширенный стиль текста

Расширенный стиль применяется для текстов, вводимых в графы основной надписи документа или в ячейки других таблиц с фиксированными размерами. Расширенный стиль текста задает зависимость между количеством строк текста: одна, две или три и его параметрами: высотой символов, сужением символов и шагом строк.

Настройка расширенного стиля текста производится в диалоге (рис. 11.1.43), который появляется после нажатия кнопки Далее... диалога создания и редактирования стиля текста.

Рис. 11.1.43. Диалог настройки расширенного стиля текста

Расширенный стиль текста используется только в таблицах, в основном для описания различных случаев ввода текста в графы основной надписи документа, в ячейку таблицы с фиксированными габаритами и т.п. При использовании стиля текста, содержащего настройку расширенного стиля, вне таблиц параметры расширенного стиля игнорируются.

Например, вы можете создать стиль текста Обычный с высотой символов 3,5 мм и настроить расширенный стиль внутри стиля Обычный следующим образом: высота символов для однострочного текста — 10 мм, для двухстрочного — 7 мм и для трехстрочного — 5 мм. Это означает, что текст в ячейке таблицы, оформленный стилем Обычный, будет иметь высоту символов 10 мм, если он состоит из одной строки, 7 мм — если из двух, 5 мм — если из трех и 3,5 мм — если из четырех и более. Если применить стиль Обычный, допустим, к тексту текстового документа, то вне зависимости от количества строк высота символов будет равна 3,5 мм.

Элементы управления диалога настройки расширенного стиля текста приведены в таблице 11.1.19.

Табл. 11.1.19. Диалог настройки параметров расширенного стиля текста
Элемент | Описание
Количество строк | Группа опций, позволяющая указать возможное количество строк текста.
Высота символов | Поля для ввода высоты символов текста, состоящего из указанного числа строк.
Сужение символов | Поля для ввода сужения символов текста, состоящего из указанного числа строк.
Шаг строк | Поля для ввода шага строк в тексте, состоящего из указанного числа строк.

Если текст состоит из большего числа строк, чем это задано при настройке расширенного стиля текста, то параметры расширенного текста игнорируются.


11.1.4.2. Практика создания и редактирования стилей текстов

Данный раздел содержит упражнения, позволяющие овладеть приемами создания пользовательских и редактирования системных стилей текстов.

В этом разделе:

Упражнение 81. Создание библиотеки стилей текстов. Самостоятельная работа

Упражнение 82. Создание стилей заголовков и основного текста

Упражнение 83. Проверка созданных стилей текстов

Упражнение 84. Редактирование системных стилей текстов в текущем документе

Упражнение 85. Редактирование системных стилей текстов в новых документах

Упражнение 86. Проверка настройки системных стилей текстов


Упражнение 81. Создание библиотеки стилей текстов. Самостоятельная работа

Упражнение 81. Создание библиотеки стилей текстов.
Самостоятельная работа

Задание. Создайте библиотеку стилей текстов user_texts.lts.

1. Вызовите команду Сервис — Библиотеки стилей, типов, оформлений и основных надписей — Стили текстов....

2. Создайте библиотеку стилей текстов с именем user_texts аналогично тому, как вы создавали библиотеку стилей линий в упражнении 71.

Не закрывая диалог работы с наборами и библиотеками стилей текстов, переходите к выполнению следующего упражнения.


Упражнение 82. Создание стилей заголовков и основного текста

Задание. Создайте стили текстов, позволяющие оформлять документы в соответствии с макетом, показанным на рис. 11.1.44. В стилях должен использоваться шрифт Arial прямого начертания.

Рис. 11.1.44. Макет страницы

1. Нажмите кнопку Создать в диалоге работы с наборами и библиотеками стилей текстов.

Проследите, чтобы активным было окно библиотеки user_texts.lts. В противном случае новый стиль будет добавлен в библиотеку (набор или документ), открытую в соседнем окне.

На экране появится диалог создания стиля текста.

2. Введите в поле Номер значение 100.

3. Введите в поле Название имя создаваемого стиля — Основной текст.

4. В поле Шаг строк введите 5.

5. В поле Красная строка введите 0, так как, согласно макету, первая строка абзаца не имеет отступа.

6. В поля группы Отступы тоже введите 0, так как абзацы основного текста начинаются и заканчиваются непосредственно у границы ввода.

7. В поля группы Интервалы введите 2.

8. В группе Выравнивание выберите вариант на всю ширину, так как абзацы основного текста выровнены по обоим сторонам (ни одна из границ абзаца не является «рваной»).

9. Нажмите кнопку Шрифт..., чтобы установить параметры шрифта для основного текста.

На экране появится диалог настройки параметров шрифта.

9.1. Из списка Шрифт выберите строку Arial.

9.2. В поле Высота введите или выберите 3.5.

9.3. В поле Сужение введите или выберите 1.

9.4. Нажмите кнопку Цвет... и выберите черный цвет для текста.

9.5. Опции Курсив, Жирный, Подчеркнутый не включайте.

9.6. Закройте диалог настройки параметров шрифта, нажав кнопку ОК.

На экране останется диалог создания стиля текста.

Опция Расширенный стиль текста позволяет задать некоторые параметры текста в зависимости от количества строк в нем. Эта настройка применяется при создании стилей для текстов, размещаемых в ячейках таблиц. В данном случае параметры расширенного стиля текста устанавливать не нужно.

10. На этом создание стиля Основной текст завершено. Закройте диалог создания стиля, нажав кнопку ОК.

На экране останется диалог работы с наборами и библиотеками стилей. В активном окне просмотра отображается имя созданного вами стиля — Основной текст.

11. Нажмите кнопку Создать.

На экране появится диалог создания стиля текста.

12. Введите в поле Номер значение 101.

13. Введите в поле Название имя создаваемого стиля — Заголовок 1.

14. В поле Шаг строк введите 10.

15. В поле Красная строка введите 0.

16. В поля группы Отступы тоже введите 0.

17. Введите следующие значения интервалов: перед абзацем — 12, после абзаца — 8.

При задании интервалов следует помнить, что интервал между соседними абзацами складывается из интервала после предыдущего абзаца и интервала перед последующим.

18. В группе Выравнивание выберите вариант влево. Выбор варианта на всю ширину не рекомендуется, так как он обычно приводит к непропорциональному увеличению пробелов между словами заголовка, абзац которого состоит из нескольких строк (рис. 11.1.45).

Рис. 11.1.45. Выравнивание абзаца заголовка: а) на всю ширину, б) влево
а) | б)

Выравнивание абзацев основного текста по ширине также достигается за счет увеличения пробелов между словами. Но из-за меньшей высоты символов и наличия переносов в строках основного текста умещается больше слов, чем в строках заголовка. Поэтому разница между пробелами в строках основного текста невелика.

19. Нажмите кнопку Шрифт..., чтобы установить параметры шрифта для заголовка первого уровня.

На экране появится диалог настройки параметров шрифта.

19.1. В поле Высота введите или выберите 7.

19.2. Остальные параметры настройте так же, как для основного текста (см. пп. 9.1, 9.3–9.5).

19.3. Закройте диалог настройки параметров шрифта.

На экране останется диалог создания стиля текста.

Как и при настройке основного текста, опцию Расширенный стиль текста включать не нужно.

20. На этом создание стиля Заголовок1 завершено. Закройте диалог создания стиля, нажав кнопку ОК.

На экране останется диалог работы с наборами и библиотеками стилей. В активном окне просмотра теперь отображаются два названия стиля — Основной текст и Заголовок1.

21. Самостоятельно создайте стиль для заголовков второго уровня в соответствии с макетом.


Упражнение 83. Проверка созданных стилей текстов

Задание. Проверьте, правильно ли настроены созданные вами стили текстов Заголовок1, Заголовок2 и Основной текст.

1. Создайте новый текстовый документ КОМПАС-3D.

2. Введите 6 абзацев текста средней длины (например, чтобы они умещались на половине страницы). По умолчанию ко всем абзацам применяется системный стиль текста.

3. Выделите первый абзац.

4. Примените к нему стиль Основной текст из созданной вами библиотеки user_texts.lts.

4.1. Вызовите команду Формат — Стиль....

На экране появится диалог выбора текущего стиля текста.

4.2. Нажмите кнопку Библиотеку... в группе Показать.

4.3. В появившемся диалоге укажите файл user_texts.lts и нажмите кнопку Открыть.

В верхней части диалога выбора текущего стиля появится полное имя выбранной библиотеки. Список содержащихся в ней стилей отобразится на вкладке Библиотека.

4.4. Выделите в списке стиль Основной текст и нажмите кнопку Выбрать.

Диалог выбора текущего стиля текста закроется. Убедитесь, что выделенный абзац оформлен в соответствии с настройками стиля Основной текст: шрифт Arial, высота прописных букв — 3,5 мм, выравнивание по ширине.

5. Аналогичным образом примените ко второму абзацу стиль Заголовок1, к четвертому — Заголовок2.

6. К остальным абзацам примените стиль Основной текст.

6.1. Выделите нужный абзац и вызовите команду Формат — Стиль....

6.2. Активизируйте вкладку Библиотека появившегося диалога.

Она содержит перечень ссылок на уже использованные библиотечные стили.

6.3. Выделите в списке стиль Основной текст и нажмите кнопку Выбрать.

Диалог выбора текущего стиля текста закроется, а выделенный абзац будет оформлен требуемым образом. Таким образом, для повторного выбора стиля из библиотеки ее подключение уже не требуется.

7. Убедитесь в том, что

• высота символов (вертикальный размер прописных букв) и шаг строк (расстояние между базовыми линиями соседних строк) во всех абзацах соответствует параметрам, заданным при настройке стилей,

• выравнивание абзацев соответствует вариантам, выбранным при настройке стилей,

8. Сохраните документ под именем text.kdw.


Упражнение 84. Редактирование системных стилей текстов в текущем документе

Как вы знаете, вместе с системой КОМПАС-3D поставляются системные стили линий, штриховок, текстов. В то время как редактирование системных стилей линий и штриховок ограничено (пользователь может лишь изменить цвет и толщину системных линий, что, в свою очередь, повлияет на внешний вид тех штриховок, которые используют эти линии), редактирование системных стилей текстов доступно в весьма широких пределах.

Второе отличие между системными стилями линий (штриховок) и текстов состоит в следующем. Настройки системных линий и штриховок хранятся внутри системы и применяются ко всем открытым документам одновременно. Настройки системных стилей текстов хранятся в самих документах и поэтому в каждом из них могут быть различными.

Задание. Отредактируйте в документе text.kdw системный стиль текста для заголовков таблиц. В стиле должен использоваться шрифт Arial прямого начертания, жирный. Высота символов — 3,5 мм. Выравнивание текста в ячейке — по левому краю.

1. Откройте документ text.kdw, созданный в предыдущем упражнении.

2. Создайте в нем произвольную таблицу с заголовком в первой строке и заполните ее ячейки. Тексты в ячейках заголовка таблицы имеют системный стиль Заголовок таблицы с умолчательными настройками.

3. Выйдите из режима редактирования таблицы.

4. Вызовите команду Сервис — Параметры... — Текущий текстовый документ — Заголовок таблицы.

В правой части появившегося диалога находятся элементы управления, позволяющие настроить системный стиль текста Заголовок таблицы.

5. В поле Шаг строк введите 5.

6. В поля группы Отступы введите 1. Отступы — это расстояния от текста в ячейке до ее левой и правой границ.

7. В группе Интервалы введите следующие значения: Перед абзацем — 2, После абзаца — 0.

8. В группе Выравнивание выберите вариант влево.

9. Нажмите кнопку Шрифт..., чтобы настроить параметры шрифта для заголовка таблицы.

На экране появится диалог настройки шрифта.

9.1. Из списка Шрифт выберите строку Arial. При этом автоматически включится опция Отличается от шрифта по умолчанию. Оставьте эту опцию включенной. Ее выключение позволяет быстро выбрать при настройке стиля шрифт, установленный для данного документа в качестве умолчательного.

Выбор умолчательного шрифта для текущего документа тоже производится в диалоге настройки параметров. Для этого следует выбрать в левой части вкладки Текущий текстовый документ пункт Шрифт по умолчанию.

В данном случае указанная настройка не требуется.

9.2. В поле Высота введите или выберите 3.5.

9.3. В поле Сужение введите или выберите 1.

9.4. Включите опцию Жирный, а опции Курсив и Подчеркнутый выключите.

9.5. Нажав кнопку Цвет..., установите для текста черный цвет.

9.6. Закройте диалог настройки шрифта.

10. Настройка системного стиля текста Заголовок таблицы завершена. Закройте диалог настройки параметров, нажав кнопку ОК.

Вы увидите, что оформление первой строки таблицы изменилось: внешний вид текста и его расположение в ячейках теперь соответствуют не умолчательным настройкам стиля Заголовок таблицы, а настройкам, заданным вами.

Стиль текста в остальных ячейках не изменится, так как он не был отредактирован.

11. Самостоятельно отредактируйте в документе text.kdw системный стиль текста для ячеек таблиц. В стиле должен использоваться шрифт Arial прямого начертания. Высота символов — 3 мм. Выравнивание текста в ячейке — по левому краю.

12. Убедитесь в том, что после изменения системного стиля Ячейка таблицы внешний вид текста в ячейках таблицы изменился в соответствии с заданными параметрами.

13. Сохраните документ. При этом сохранятся также выполненные вами настройки стилей. Они будут использоваться для заголовков и ячеек таблиц в этом документе при его повторном открытии, в том числе на других рабочих местах.


Упражнение 85. Редактирование системных стилей текстов в новых документах

Задание. Отредактируйте системные стили текста Заголовок таблицы и Ячейка таблицы, предназначенные для использования по умолчанию в новых текстовых документах. Стили должны удовлетворять тем же условиям, что и одноименные стили в документе text.kdw.

1. Вызовите команду Сервис — Параметры... — Новые документы.

2. В правой части появившегося диалога раскройте раздел Текстовый документ.

3. Выделите в этом разделе пункт Заголовок таблицы.

В правой части диалога появятся элементы управления, позволяющие настроить системный стиль текста Заголовок таблицы, который будет использоваться по умолчанию в новых текстовых документах.

4. Выполните пункты 5–9 из упражнения 84.

5. Выделите в разделе Текстовый документ пункт Ячейка таблицы и аналогичным образом настройте одноименный системный стиль.

6. Закройте диалог настройки параметров, нажав кнопку ОК.


Упражнение 86. Проверка настройки системных стилей текстов

Задание. Проверьте правильность умолчательной настройки системных стилей текстов Заголовок таблицы и Ячейка таблицы в новом текстовом документе.

1. Создайте новый текстовый документ.

2. Вызовите команду Сервис — Параметры... — Текущий текстовый документ.

3. Поочередно выбирая пункты Заголовок таблицы и Ячейка таблицы в левой части диалога, убедитесь, что новый документ имеет необходимые настройки одноименных системных стилей текстов.

Можно также создать в новом документе таблицу и, заполнив ее ячейки, убедиться, что текст по умолчанию имеет требуемые параметры.

Таким образом, если используемые вами стили текстов отличаются от умолчательных, необходимо выполнить следующие действия.

– Настроить системные стили текстов для новых документов так, чтобы они имели требуемые параметры.

– Создать недостающие стили текстов (для заголовков разделов и подразделов, подписей к иллюстрациям и т.п.) и сохранить их в пользовательской библиотеке стилей текстов.


11.2. Оформления документов

В этом разделе:

11.2.1. Основная надпись и оформление документов

11.2.1.1. Общие сведения об оформлениях и основных надписях

11.2.1.2. Хранение в документе информации об используемом оформлении

11.2.1.2.1. Обновление оформления

11.2.1.2.2. Перечитывание оформления

11.2.1.3. Номер основной надписи и оформления в библиотеке

11.2.1.4. Рекомендации по созданию оформлений документов

11.2.1.5. Создание основной надписи

11.2.1.5.1. Общие приемы настройки таблиц

11.2.1.5.2. Настройка расширенного формата ячеек

11.2.1.5.3. Задание положения таблиц на листе

11.2.1.6. Дополнительные приемы создания основной надписи

11.2.1.6.1. Предварительная подготовка таблиц

11.2.1.6.2. Использование прототипов основных надписей

11.2.1.7. Создание оформления

11.2.1.7.1. Настройка оформления

11.2.1.8. Шаблоны документов

11.2.2. Практика создания оформлений

11.2.2.1. Приемы работы с библиотеками оформлений

Упражнение 87. Создание библиотеки оформлений. Самостоятельная работа

Упражнение 88. Копирование оформлений между библиотеками

11.2.2.2. Оформление чертежей

11.2.2.2.1. Основные надписи

Упражнение 89. Создание изображения таблицы во фрагменте

Упражнение 90. Основная надпись для первого листа

Упражнение 91. Основная надпись для последующих листов

11.2.2.2.2. Оформления

Упражнение 92. Оформление для первого листа

Упражнение 93. Оформление для последующих листов

11.2.2.2.3. Проверка правильности оформлений

Упражнение 94. Контроль созданных оформлений

11.2.2.3. Оформление текстовых документов

Упражнение 95. Оформление для текстового документа


11.2.1. Основная надпись и оформление документов

11.2. Оформления документов

11.2.1. Основная надпись и оформление документов

Оформление присваивается листам каждого документа — чертежа, текстового документа, спецификации.

По умолчанию листы чертежа имеют оформление, соответствующее конфигурации системы. Например, первый лист машиностроительного чертежа КОМПАС-3D имеет оформление Чертеж констр. Первый лист. ГОСТ 2.104–2006; а его последующие листы — Чертеж констр. Посл. листы. ГОСТ 2.104–2006. В процессе работы с чертежом вы можете присвоить другое оформление любому листу этого документа. Подробно о смене оформления чертежа см. раздел 3.6.2.1.

При работе с текстовым документом оформление, заданное по умолчанию, также можно изменить. Присваивается оформление первому листу, а для последующих листов — одновременно всем четным или нечетным листам. Подробно о смене оформления текстового документа см. раздел 4.1.4.2.

Для спецификации оформление является неотъемлемой частью ее стиля, влияющего на ее заполнение. Подробно об изменении стиля спецификации см. раздел 6.4.4.

В этом разделе:

11.2.1.1. Общие сведения об оформлениях и основных надписях

11.2.1.2. Хранение в документе информации об используемом оформлении

11.2.1.2.1. Обновление оформления

11.2.1.2.2. Перечитывание оформления

11.2.1.3. Номер основной надписи и оформления в библиотеке

11.2.1.4. Рекомендации по созданию оформлений документов

11.2.1.5. Создание основной надписи

11.2.1.5.1. Общие приемы настройки таблиц

11.2.1.5.2. Настройка расширенного формата ячеек

11.2.1.5.3. Задание положения таблиц на листе

11.2.1.6. Дополнительные приемы создания основной надписи

11.2.1.6.1. Предварительная подготовка таблиц

11.2.1.6.2. Использование прототипов основных надписей

11.2.1.7. Создание оформления

11.2.1.7.1. Настройка оформления

11.2.1.8. Шаблоны документов


11.2.1.1. Общие сведения об оформлениях и основных надписях

Оформление — часть чертежа или текстового документа КОМПАС-3D, содержащая основную надпись и рамки (внешнюю и внутреннюю). Оформление текстового документа содержит также сведения о размерах поля ввода текста, а оформление чертежа — сведения о наличии таблицы изменений и правила ее размещения на листе.

Основная надпись включает в себя одну или несколько таблиц, ячейки которых специальным образом настроены. Благодаря этим настройкам становятся доступными некоторые сервисные функции (автоматический ввод данных, передача данных из одной ячейки в другие и т.п.).

Использование оформлений значительно облегчает создание типовых документов: вам не нужно всякий раз вычерчивать рамку и таблицу основной надписи, так как они уже содержатся в присвоенном документу оформлении.

В состав КОМПАС-3D входят стандартные оформления для конструкторских документов. Эти оформления хранятся в системной библиотеке оформлений — файле Graphic.lyt, расположенном в подпапке \Sys главной папки системы.

В комплект поставки входит также файл Vector.lyt. Он содержит оформления для документов, печать которых осуществляется на векторных устройствах.

Для работы некоторых библиотек, например, библиотеки СПДС-обозначений, необходимы специальные оформления, отличные от системных. Эти оформления включены в комплекты поставки библиотек. При установке этих библиотек соответствующие библиотеки оформлений размещаются в подпапке \Sys.

Пользователь может редактировать имеющиеся оформления и создавать собственные. Возможно также создание пользовательских библиотек оформлений. В них можно помещать как новые оформления, так и уже существующие, т.е. копировать оформления между библиотеками.

Поскольку основные надписи являются составными частями оформлений документов, они хранятся в тех же библиотеках *.lyt, что и оформления. При этом основные надписи создаются и редактируются как отдельные объекты. Оформление, содержащееся в какой-либо библиотеке *.lyt, может включать в себя основную надпись, находящуюся только в этой же библиотеке.

Работа с основными надписями и оформлениями чертежей и текстовых документов производится в диалогах, вызываемых командами Сервис — Библиотеки стилей, типов, оформлений и основных надписей — Основные надписи... / Оформление чертежей и спецификаций... / Оформление текстовых документов.... Элементы управления этих диалогов практически аналогичны элементам управления диалогов работы с наборами и библиотеками стилей объектов (см. табл. 11.1.2). Отличие состоит в том, что вместо группы из трех кнопок — Показать набор, Показать библиотеку, Показать документ — в нем присутствует одна кнопка — Показать библиотеку, так как основные надписи и оформления, в отличие от стилей, могут храниться только в библиотеках.

При копировании оформления из одной библиотеки в другую в эту библиотеку копируется также основная надпись, используемая в оформлении.

Вы можете убедиться в этом, выполнив упражнение 88 из раздела 11.2.2.

На рис. 11.2.1 показан диалог работы с библиотеками оформлений чертежей.

Рис. 11.2.1. Диалог работы с библиотеками оформлений чертежей


11.2.1.2. Хранение в документе информации об используемом оформлении

11.2.1.2. Хранение в документе информации
об используемом оформлении

Присвоенное документу оформление (вместе с входящей в него основной надписью), внедряется в этот документ. Благодаря этому рамка и основная надпись отображаются в документе даже в отсутствие библиотеки *.lyt, содержащей присвоенное документу оформление.

Кроме того, в документе хранится ссылка на внешний файл библиотеки *.lyt, содержащий выбранное оформление. Ссылка включает путь к библиотеке и номер оформления в ней. Благодаря этому при изменении оформления в библиотеке возможно обновление оформления документа.

При настройке КОМПАС-3D можно включить автоматическое обновление оформления (см. раздел 11.2.1.2.1).

В этом разделе:

11.2.1.2.1. Обновление оформления

11.2.1.2.2. Перечитывание оформления


11.2.1.2.1. Обновление оформления

11.2. Оформления документов > 11.2.1. Основная надпись и оформление документов > 11.2.1.2. Хранение в документе информации об используемом оформлении

11.2.1.2.1. Обновление оформления

Обновление оформления — замена оформления, внедренного в документ, оформлением, номер и путь к библиотеке которого хранится в этом документе.

Обновление оформления не влияет на тексты, введенные при заполнении основной надписи — они остаются в документе без изменения.

Настройка обновления оформления производится в диалоге, вызываемом командой Сервис — Параметры... — Система — Общие — Обновление оформления документа.

– Для автоматического обновления в этом диалоге должен быть выбран вариант Обновлять. Дополнительно может быть включена опция Запрашивать подтверждение.

В этом случае при обнаружении отличий между оформлением, хранящимся в документе, и соответствующим ему оформлением в библиотеке *.lyt 1 происходит следующее:

• Если запрос подтверждения отключен, оформление автоматически обновляется. На экране появляется всплывающее сообщение о том, что обновление применено (рис. 11.2.2, а).

• Если запрос подтверждения включен, на экране появляется сообщение, показанное на рис. 11.2.2, б. Нажатие кнопки Да означает обновление оформления, нажатие кнопки Нет — отказ от обновления.

Рис. 11.2.2. Сообщения: а) о завершении обновления оформления, б) о необходимости обновления оформления
а) | б)

– Для отказа от автоматического обновления в диалоге настройки обновления должен быть выбран вариант Не обновлять. Дополнительно может быть включена опция Сообщать об изменении оформления в библиотеке.

В этом случае работа с оформлениями документа ведется следующим образом:

• Если выдача сообщений об изменении оформления в библиотеке отключена, то никаких сообщений, касающихся оформлений документов, не появляется.

• Если выдача сообщений об изменении оформления в библиотеке включена, то при обнаружении отличий между оформлением, хранящимся в документе, и соответствующим ему оформлением в библиотеке *.lyt, на экране появляется всплывающее сообщение об этом. Сообщение содержит также команду Применить оформление из библиотеки (рис. 11.2.3). Вызвав эту команду, вы можете обновить оформление.

Рис. 11.2.3. Сообщение о необходимости обновления оформления

Обновление оформления текущего документа производится согласно настройке, действовавшей на момент его открытия. Поэтому, чтобы изменение настройки обновления (например, включение автоматического обновления) вступило в силу, необходимо закрыть документ и открыть его заново.

Если обновление оформления невозможно, то на экране появляется сообщение об этом. Примеры сообщений приведены на рис. 11.2.4. При включенном обновлении оформлений сообщение выдается всякий раз, когда обновление производится, а при отключенном — только если включена выдача сообщений об изменении оформления.

Рис. 11.2.4. Сообщения: а) об отсутствии стиля в библиотеке, б) об отсутствии библиотеки
а) | б)

В любое время при работе с документом возможно принудительное обновление оформления, см. раздел 11.2.1.2.2.

Если оформление документа отличается от соответствующего ему оформления в библиотеке *.lyt, то во всех диалогах, где отображается наименование оформления документа (например, в Менеджере документа, см. рис. 3.6.2), это наименование предваряется «звездочкой» (*).

Отменить обновление оформления документа с помощью команды отмены невозможно. Поэтому для возврата прежнего оформления следует закрыть документ без сохранения и открыть его заново.

  1. Оформления всегда сверяются при открытии документа. Сверка оформлений после редактирования библиотеки происходит немедленно, если редактирование производится на том же рабочем месте, где открыт документ, а если на другом, то — согласно настройке установки прав доступа (см. раздел 9.1.4.2).


11.2.1.2.2. Перечитывание оформления

11.2. Оформления документов > 11.2.1. Основная надпись и оформление документов > 11.2.1.2. Хранение в документе информации об используемом оформлении

11.2.1.2.2. Перечитывание оформления

Перечитывание оформления — принудительное обновление оформления документа.

Возможно перечитывание оформления:

– Всех листов документа сразу. Для этого вызовите команду Сервис — Перечитать оформление. Эта команда доступна, если между оформлением, хранящимся в документе, и соответствующим ему оформлением в библиотеке *.lyt есть различия. Если различий нет, а также если отсутствует библиотека или оформление в ней (т.е. невозможно сравнить оформления), команда недоступна.

– Произвольного листа чертежа. Для этого вызовите из контекстного меню основной надписи нужного листа команду Изменить оформление и нажмите в появившемся диалоге кнопку Перечитать. Кроме того, перечитывание оформлений отдельных листов возможно в диалоге Менеджера документа (см. раздел 3.6.2.1): в списке листов выделите строку, соответствующую нужному листу, щелкните мышью в ячейке оформления и в появившемся диалоге нажмите кнопку Перечитать.

– Первого листа, всех четных листов, всех нечетных листов. Для этого вызовите команду Сервис — Параметры... — Текущий текстовый документ — Параметры листа. Выберите в левой части появившегося диалога пункт Оформление, затем в правой части нажмите кнопку Перечитать в нужной группе.

Закройте настроечный диалог кнопкой ОК.


11.2.1.3. Номер основной надписи и оформления в библиотеке

Каждая основная надпись и каждое оформление имеет номер, который присваивается основной надписи или оформлению при создании.

Номер — это уникальный признак основной надписи (оформления).

Одна и та же библиотека не может содержать две основные надписи с одинаковыми номерами. Это связано с тем, что именно по своему номеру основная надпись включается в оформление.

Одна и та же библиотека не может содержать два оформления с одинаковыми номерами. Это связано с тем, что при присвоении оформления документу в нем возникает ссылка на это оформление. Ссылка включает в себя следующие сведения: полное имя библиотеки и номер оформления из нее.

Кроме того, номер оформления, присвоенного документу, имеет значение для совместимости с предыдущими версиями, а также для разработки приложений к КОМПАС-3D с помощью языковых инструментальных средств. Номера с 1 по 100 зарезервированы для стандартных оформлений, поэтому при создании новых оформлений рекомендуется задавать номера начиная со 101.

Номера основных надписей и оформлений, содержащихся в библиотеке, могут быть одинаковыми или различаться — это не имеет значения. Например, в библиотеке Graphic.lyt номера основных надписей совпадают с номерами использующих их оформлений, но это сделано лишь для удобства работы.

При попытке помещения в библиотеку основной надписи (путем создания или копирования), номер которой совпадает с номером одной из имеющихся в этой библиотеке основных надписей, на экране появляется диалог-предупреждение. Этот диалог аналогичен диалогу-предупреждению о наличии стиля в библиотеке (см. рис. 11.1.6). Он так же содержит названия библиотечных объектов (в данном случае основных надписей), имеющих одинаковые номера, и управляющие кнопки (см. табл. 11.1.4).

При помещении в библиотеку нового или скопированного оформления сначала происходит проверка наличия в этой библиотеке копируемой основной надписи, а затем — копируемого оформления.

Если в библиотеке есть объект (основная надпись или оформление), который совпадает с добавляемым объектом как по номеру, так и по имени, то на экране появится запрос на перезапись объекта — замену старого объекта новым. Вы можете подтвердить перезапись или отказаться от нее.

Если вероятность обмена оформлениями между несколькими библиотеками достаточно велика, то следует позаботиться о том, чтобы все оформления (а также основные надписи) в этих библиотеках имели разные номера. Это позволит избежать вышеописанных конфликтов.


11.2.1.4. Рекомендации по созданию оформлений документов

Создание оформления документа включает в себя два основных этапа:

1. создание основной надписи,

2. создание оформления с использованием этой основной надписи.

Вы можете создать собственную библиотеку *.lyt для размещения новой основной надписи и оформления. Создание библиотеки оформлений аналогично созданию библиотеки стилей (см. раздел 11.1.1.2.1).

Если создаваемая основная надпись (оформление) является модификацией уже существующей, то последнюю можно использовать в качестве прототипа (см. раздел 11.2.1.6.2).

Прежде чем приступать к созданию оформления, его необходимо тщательно продумать. Особенно это относится к таблицам основной надписи, потому что очень важно правильно настроить их ячейки (см. разделы 11.2.1.5.1, 11.2.1.5.2).

Созданное оформление рекомендуется внимательно протестировать и немедленно исправить обнаруженные ошибки. Это связано с тем, что внесение изменений в уже присвоенные документам оформления занимает обычно очень много времени.

Так как оформление документа — довольно сложный объект, работа с ним требует определенных навыков. Поэтому перед созданием оформлений, которые будут использоваться для выпуска документации на вашем предприятии, рекомендуется ознакомиться с разделом 11.2.1 и его подразделами, а также создать несколько пробных оформлений, выполнив упражнения, содержащиеся в разделе 11.2.2.


11.2.1.5. Создание основной надписи

Основная надпись как часть оформления документа — специальный сложный объект КОМПАС-3D. В состав основной надписи может входить одна или несколько таблиц. Эти таблицы имеют только одно отличие от обычных таблиц. Оно заключается в том, что при создании таблицы основной надписи каждая ее ячейка должна быть специальным образом настроена (см раздел 11.2.1.5.2). Заполнение таблиц основной надписи в документе ничем не отличается от заполнения обычной таблицы.

Общий порядок действий при создании новой основной надписи следующий.

1. Вызовите команду Сервис — Библиотеки стилей, типов, оформлений и основных надписей — Основные надписи....

2. В появившемся диалоге откройте или создайте библиотеку для размещения новой основной надписи.

3. Нажмите кнопку Создать для перехода к созданию новой основной надписи в текущей библиотеке.

На экране появится диалог создания основной надписи (рис. 11.2.5).

Рис. 11.2.5. Диалог создания и редактирования основной надписи

4. Введите имя и номер новой основной надписи. Имя основной надписи может быть любым. Обычно оно содержит краткую информацию об основной надписи (например, стандарт и область применения). Правила нумерации основных надписей изложены в разделе 11.2.1.3.

5. Нажмите кнопку Добавить для перехода к созданию первой таблицы основной надписи.

6. Создайте и настройте первую таблицу основной надписи (см. разделы 11.2.1.5.1, 11.2.1.5.2).

7. Сохраните созданную таблицу и закройте ее окно.

Система вернется к диалогу создания основной надписи.

Наименование вновь созданной таблицы (оно отображается в одноименном поле диалога создания основной надписи) — «БЕЗ ИМЕНИ».

8. Введите в поле Наименование таблицы название, соответствующее назначению таблицы.

9. В диалоге создания основной надписи настройте положение созданной таблицы на листе (см. раздел 11.2.1.5.3).

10. Если созданную таблицу нужно использовать для ввода объектов спецификации, включите опцию Использовать для спецификаций.

11. Добавьте в основную надпись необходимое количество таблиц и настройте их размещение, повторив пункты 5–7 нужное количество раз.

12. Закройте диалог создания основной надписи.

Система вернется к диалогу работы с основными надписями. В списке основных надписей текущей библиотеки появится имя созданной вами основной надписи.

13. Закройте диалог работы с основными надписями.

Предполагается, что пользователь, приступающий к разработке таблиц основной надписи, достаточно хорошо владеет приемами работы с таблицами в документах КОМПАС-3D. Поэтому в разделе 11.2.1.5.1 рассматриваются не все возможности работы с таблицами, а только те, использование которых в данном случае имеет специфический характер или особым образом влияет на таблицу основной надписи.

В этом разделе:

11.2.1.5.1. Общие приемы настройки таблиц

11.2.1.5.2. Настройка расширенного формата ячеек

11.2.1.5.3. Задание положения таблиц на листе


11.2.1.5.1. Общие приемы настройки таблиц

Предварительная настройка новой таблицы основной надписи, как и обычной таблицы, производится в диалоге создания новой таблицы (рис. 11.2.6). Он появляется на экране после нажатия кнопки Добавить... диалога создания основной надписи (рис. 11.2.5).

Рис. 11.2.6. Диалог создания новой таблицы

Если таблица для основной надписи была заранее подготовлена (см раздел 11.2.1.6.1), нажмите кнопку Из файла и откройте нужный файл таблицы или фрагмента.

Если готовой таблицы нет, задайте в диалоге ее параметры и нажмите кнопку ОК.

Система перейдет в режим редактирования таблицы: на экране появится новое окно, содержащее таблицу с заданными параметрами. Главное меню, Компактная панель и Панель свойств в этом режиме будут содержать команды для работы с таблицами.

При создании таблиц основной надписи доступны все приемы работы с таблицами в документах КОМПАС-3D (см. раздел 4.2.2). Эти приемы позволяют выполнить общую настройку таблицы основной надписи. Кроме того, каждая ячейка этой таблицы обязательно должна иметь специальную настройку — настройку расширенного формата (см. раздел 11.2.1.5.2). Эта возможность недоступна при создании обычных таблиц.

Выполняя общую настройку таблицы основной надписи, необходимо принять к сведению следующую информацию.

– На любую ячейку, содержащую текст, автоматически накладывается запрет на изменение этого текста. Другими словами, наличие в ячейке хотя бы одного символа означает, что при заполнении основной надписи в документе редактирование текста в этой ячейке будет невозможно. Пользователь не сможет ни удалить имеющийся текст, ни дополнить его, ни изменить его параметры (шрифт, цвет, размер и т.п.).

– Внешний вид текста, который будет введен в пустую ячейку при заполнении основной надписи в документе, определяется тем, как была отформатирована эта ячейка при создании таблицы основной надписи. Для настройки форматирования ячейки установите в нее курсор и вызовите команду Формат — Формат ячейки.... В появившемся диалоге вы можете настроить разнообразные параметры: стиль текста, отступы текста от границ ячейки и др.

Напоминаем, что стиль текста может содержать настройки расширенного стиля текста — сведения о том, какими должны быть шаг строк, высота и сужение символов в тексте в зависимости от количества строк в этом тексте (см. раздел 11.1.4.1.3).

Если к тексту в ячейке необходимо применить пользовательский стиль, то его рекомендуется сохранить непосредственно в создаваемой основной надписи — это исключит потерю стиля при переносе библиотеки оформлений на другое рабочее место. Создание стиля текста в основной надписи аналогично созданию стиля текста в документе (см. раздел 11.1.1.2.2).

– После того как размеры ячеек и отступов текста в них заданы, рекомендуется заблокировать размеры таблицы. Для этого вызовите команду Таблица — Блокировка таблицы и включите все опции появившегося диалога.

– Если создаваемая таблица основной надписи будет располагаться на листе так, что какие-либо из ее границ совпадут с внутренней рамкой документа (или с границами других таблиц), рекомендуется установить для этих границ стиль линий обрамления Невидимая.

Это связано с тем, что некоторые векторные устройства вывода воспринимают четное количество линий, наложенных друг на друга, как отсутствие линии. В результате в напечатанном документе может отсутствовать часть линий оформления.

В итоге ячейки созданной таблицы основной надписи должны либо содержать текст, либо иметь определенные настройки формата и расширенного формата, т.е. настройки, определяющие свойства текста, который будет вводиться в ячейку при заполнении основной надписи.


11.2.1.5.2. Настройка расширенного формата ячеек

Расширенный формат ячейки — совокупность свойств ячейки основной надписи, определяющая, какие сервисные функции будут доступны при заполнении соответствующей графы основной надписи в документе (автоматический ввод некоторых типов данных, передача данных из одной ячейки в другие, вызов пользовательского меню и т.п.). Кроме того, свойства ячеек, установленные при настройке расширенного формата, определяют возможность и порядок передачи данных из одной основной надписи в другую при смене оформления документа.

Настройка расширенного формата ячейки производится в одноименном диалоге (рис. 11.2.7). Его вызов осуществляется нажатием кнопки Далее... в диалоге настройки формата ячейки, либо кнопки Расширенный формат ячейки на панели Таблицы и границы или на вкладке Таблицы Панели свойств.

Рис. 11.2.7. Диалог настройки расширенного формата ячейки

При создании таблицы основной надписи расширенный формат необходимо настроить для каждой ячейки, которая будет заполняться пользователем при работе с документом. Для этого следует поочередно устанавливать курсор в пустые ячейки таблицы, вызывать диалог настройки расширенного формата и задавать в нем нужные свойства текущей ячейки (той, в которой находится курсор).

Каждая пустая ячейка таблицы основной надписи характеризуется следующими свойствами:

– тип,

– идентификатор,

– значение идентификатора.

Если настройка расширенного формата текущей ячейки не производилась, ее тип считается неопределенным, поэтому при первом вызове диалога в нем активна опция Тип не определен. Оставлять тип ячейки неопределенным нельзя, так как при заполнении основной надписи в документе ввод данных в эту ячейку будет невозможен.

Варианты Системный, Общий для документа, Общий для листа и Для таблицы спецификации группы Тип ячейки позволяют выбрать тип данных текущей ячейки.

Описание типов ячеек и правила задания идентификаторов представлены в таблице 11.2.1.

Табл. 11.2.1. Типы ячеек таблицы основной надписи

Тип

Описание ячейки

Пример

Системный

Ячейка этого типа заполняется в основной надписи документа автоматически (без участия пользователя). Чтобы указать, какие именно данные должны быть занесены в ячейку системного типа, выберите из списка нужный идентификатор.

Графы Номер листа и Количество листов основной таблицы в текстовых документах и спецификациях.

Общий
для документа

Данные, введенные в ячейку этого типа при заполнении основной надписи, могут автоматически передаваться в другие ячейки таблиц основных надписей на этом же листе и на остальных листах многолистового документа.

Условие передачи — совпадение типов и идентификаторов ячеек.

При смене оформления документа данные из этой ячейки передаются в ячейки «новой» основной надписи, имеющие такой же тип и такой же идентификатор.

Таким образом, для ячеек всех основных надписей, между которыми должен выполняться автоматический перенос информации, нужно установить тип Общий для документа и выбрать один и тот же идентификатор.

Графа Обозначение основной таблицы, в которую заносится обозначение документа. Его можно ввести на любом листе документа, и введенный текст будет автоматически занесен в Графу 26 этого же листа и аналогичные графы всех остальных листов, если документ многолистовой.

Общий
для листа

Данные, введенные в ячейку этого типа при заполнении основной надписи, могут автоматически передаваться в ячейку другой таблицы основной надписи на этом же листе.

Условие передачи — совпадение типов и идентификаторов ячеек.

При смене оформления документа данные из этой ячейки передаются в ячейки «новой» основной надписи, имеющие такой же тип и такой же идентификатор.

Содержимое этой ячейки не передается во все листы многолистового документа.

Графа Изменение основной таблицы, в которую вводится номер изменения документа. При смене одного типа основной надписи данного документа на другой содержимое графы будет автоматически перенесено в аналогичную графу с таким же идентификатором.

Для таблицы
спецификации

Этот тип предназначен для ячеек таблицы спецификации (оформление, содержащее основную надпись с такой таблицей, затем включается в стиль спецификации).

При установке данного типа ячейки требуется выбрать из списка идентификатор (Позиция, Наименование, Обозначение, Количество и т.д.) и указать номер строки таблицы спецификации, в которой находится настраиваемая ячейка.

Все ячейки в одном столбце должны иметь одинаковые идентификаторы и отличаться только номером строки. Чтобы ускорить настройку однотипных ячеек столбца (присвоение им идентификаторов и номеров строк), пользуйтесь опцией Сформировать идентификаторы для всех нижележащих ячеек столбца.

Для ячейки типа Общий для листа необходимо задать значение идентификатора в поле Идентификатор ячейки.

Идентификаторы ячеек всех остальных типов должны быть выбраны из раскрывающегося списка (табл. 11.2.2 и 11.2.3). Значения этих идентификаторов являются предопределенными, поэтому поле Идентификатор ячейки будет недоступным для ввода.

Одним из предопределенных идентификаторов является Пользовательский. Особенности его применения рассмотрены в разделе Особенности использования типов ячеек Общий для листа и Общий для документа.

Табл. 11.2.2. Идентификаторы ячеек типа Системный
Идентификатор | Значения идентификатора
Номер листа | 7
Количество листов | 8
Формат | Определяется системой автоматически
Имя файла (полное) | 43
Имя файла (короткое) | 44
Строка обозначения и дефис | 45
Пользовательский |

Табл. 11.2.3. Идентификаторы ячеек типа Общий для документа
Идентификатор | Значения идентификатора
Наименование изделия | 1
Обозначение документа | 2
Обозначение материала | 3
Литера документа (графа 1) | 40
Литера документа (графа 2) | 41
Литера документа (графа 3) | 42
Масса изделия | 5
Масштаб | 6
Индекс предприятия | 9
Фамилия разработавшего | 110
Дата оконч. разработки | 130
Фамилия проверившего | 111
Дата проверки | 131
Фамилия тех. контр. | 112
Дата тех. контр. | 132
Характер работы | 10
Фамилия вып. работу | 113
Дата выполнения | 133
Фамилия норм. контр. | 114
Дата норм. контр. | 134
Фамилия утверждающего | 115
Дата утверждения | 135
Обозначение исполнения [осн. исполн.] | 2110
Обозначение исполнения [исполнение 1] | 2111
Обозначение исполнения [исполнение 2] | 2112
Обозначение исполнения [исполнение 3] | 2113
Обозначение исполнения [исполнение 4] | 2114
Обозначение исполнения [исполнение 5] | 2115
Обозначение исполнения [исполнение 6] | 2116
Обозначение исполнения [исполнение 7] | 2117
Обозначение исполнения [исполнение 8] | 2118
Обозначение исполнения [исполнение 9] | 2119
Номер документа | не используется
Наименование документа | 51
Код документа | 52
Код ОКП | 53
Пользовательский |

Значения идентификаторов отображаются в Строке сообщений в режиме редактирования таблицы основной надписи.

В диалоге настройки расширенного формата ячейки можно также ввести текст, который будет отображаться в Строке сообщений КОМПАС-3D при заполнении данной ячейки основной надписи (когда курсор будет находиться внутри ячейки). Этот текст необходимо ввести в поле Запрос при вводе текста в ячейку.

Строка запроса должна в максимальной степени пояснять назначение текущей ячейки, поскольку она будет служить единственной подсказкой системы при вводе текста в эту ячейку.

Если требуется, чтобы при вводе текста в эту ячейку было доступно пользовательское меню, сразу после текста запроса необходимо ввести символ «|» (вертикальная черта), а затем — номер раздела файла пользовательского меню, строки которого будут отображаться при вызове этого меню в заполняемой графе штампа.

Если требуется, чтобы в ячейках для ввода дат был доступен диалог выбора даты, после текста запроса и символа «|» следует ввести число 4099.

Ввод текста в графы основной надписи путем выбора нужных строк из пользовательского меню ускоряет ее заполнение и позволяет исключить опечатки, возможные при наборе текста с клавиатуры. Назначение файла пользовательского меню, его структура и синтаксис подробно рассмотрены в разделе 9.5.5.1.

Особенности использования типов ячеек
Общий для листа и Общий для документа

Использование типов Общий для документа и Общий для листа на одном листе дает один и тот же результат: данные, введенные в ячейки этого типа, могут быть переданы (при условии совпадения идентификаторов) в ячейки других таблиц на этом же листе. Однако тип Общий для документа более универсален: он обеспечивает копирование данных также и между листами многолистового документа. Так как любая из основных надписей может использоваться для многолистовых документов, рекомендуется придерживаться следующих правил.

– Ячейки, содержащие данные, уникальные для листа (например, номер изменения), должны иметь тип Общий для листа. Если среди этих ячеек есть ячейки, данные в которых должны быть одинаковы, присвойте им одинаковые идентификаторы — это обеспечит автоматическое заполнение остальных ячеек на листе после заполнения какой-либо одной.

– Ячейки, содержащие данные, уникальные для документа (например, его обозначение, наименование детали, обозначение предприятия), должны иметь тип Общий для документа. Если среди этих ячеек есть ячейки, данные в которых должны быть одинаковы, присвойте им одинаковые идентификаторы — это обеспечит автоматическое заполнение остальных ячеек на листе (листах) после заполнения какой-либо одной.

– Ячейки, которые заполняются вручную после распечатки документа (например, ячейки для подписей), могут иметь как тип Общий для листа, так и Общий для документа. Необходимо только проследить, чтобы в них не передавались никакие сведения из других ячеек. Для ячейки типа Общий для листа это достигается заданием уникального значения идентификатора, а для ячейки типа Общий для документа — заданием идентификатора Пользовательский с уникальным значением.

Применение пользовательских идентификаторов

Итак, при настройке расширенного формата ячейки необходимо указать ее тип и идентификатор. Если нужного вам идентификатора нет среди предопределенных — содержащихся в списке — идентификаторов, выберите из этого списка вариант Пользовательский.

В этом случае для указания ячеек, между которыми должна осуществляться передача данных, требуется задание значения пользовательского идентификатора. Это значение (целое число) вводится в поле Идентификатор ячейки, которое становится доступным при выборе пользовательского идентификатора.

Значения пользовательских идентификаторов, присвоенных ячейкам разного назначения, обязательно должны быть различны!

Например, требуется, чтобы передача данных происходила между ячейками, имеющими пользовательский идентификатор и находящимися в основных надписях листов многолистового документа. Для этого необходимо присвоить всем этим ячейкам тип Общий для документа и одинаковые значения идентификатора.

При смене оформления документа возможна передача данных между ячейками, имеющими пользовательские идентификаторы. Условие передачи — совпадение типов и значений идентификаторов у ячеек прежней и новой основных надписей.

Следует внимательно следить за тем, чтобы пользовательские идентификаторы, присвоенные аналогичным ячейкам, имели одинаковые значения, необходимо только при создании оформлений, вероятность замены которых друг на друга достаточно велика.

Во избежание случайного совпадения идентификатора, назначенного пользователем, с уже имеющимся в системе (понятно, что это приведет к «смешению» данных в ячейках) рекомендуется использовать идентификаторы, указанные в таблице 11.2.4.

Табл. 11.2.4. Рекомендуемые идентификаторы (значения пользовательских идентификаторов)
Диапазон | Тип ячейки
1000–2000, 2500-16383 | Общий для листа, Общий для документа (идентификатор Пользовательский)
100–150 | Для спецификации

Контроль идентификаторов

При создании таблицы основной надписи имеется возможность проверки ее ячеек на наличие идентификаторов и на их совпадение.

Для такой проверки вызовите команду Сервис — Проверка идентификаторов.

На экране появится диалог контроля идентификаторов. Он содержит изображение текущей таблицы основной надписи. Те ячейки таблицы, типы и идентификаторы которых совпадают, выделены голубым цветом, а те ячейки, тип (и, соответственно, идентификатор) которых не определен — розовым.

Наличие ячеек без идентификаторов или с одинаковыми идентификаторами является грубой ошибкой создания таблицы основной надписи. Поэтому при обнаружении таких ячеек необходимо перенастроить их расширенный формат.


11.2.1.5.3. Задание положения таблиц на листе

Чтобы задать положение таблицы основной надписи на листе, выделите ее в списке Состав основной надписи диалога создания основной надписи. Она станет текущей — ее название будет отображаться в поле Наименование таблицы, а ее изображение будет подсвечено в окне Предварительный просмотр. Размещением таблицы на листе управляют элементы, расположенные в группе Привязка. Описание этих элементов представлено в таблице 11.2.5.

Табл. 11.2.5. Элементы группы Привязка

Элемент

Описание

Опорная точка
на листе

Список, позволяющий указать, какая характерная точка внутренней рамки документа будет использоваться в качестве опорной для привязки текущей таблицы. Эта точка показана в окне Предварительный просмотр в виде маленького квадратика.

Опорная точка
в таблице

Список, позволяющий указать, какая характерная точка таблицы будет использоваться в качестве опорной для привязки.

Сдвиг
по горизонтали,

Сдвиг
по вертикали

Поля для ввода смещений опорной точки таблицы относительно опорной точки на листе.

Поворот таблицы

Группа элементов, определяющих величину и направление поворота таблицы вокруг ее опорной точки.

Величина поворота задается выбором нужной строки из списка Угол поворота. Он содержит значения углов, кратные 90°.

В том случае, если расположение таблицы зависит от формата и ориентации листа (например, таблица Графа 26 основной надписи), следует включить опцию Относительно длинной стороны.


11.2.1.6. Дополнительные приемы создания основной надписи

Некоторые этапы создания основной надписи можно заметно ускорить с помощью таких приемов, как предварительная подготовка таблиц и использование прототипов.

В этом разделе:

11.2.1.6.1. Предварительная подготовка таблиц

11.2.1.6.2. Использование прототипов основных надписей


11.2.1.6.1. Предварительная подготовка таблиц

Перед созданием уникальной (не имеющей прототипа) основной надписи можно предварительно сформировать все таблицы, из которых она будет состоять, и сохранить их в отдельных файлах на диске.

Подготовка файлов таблиц не является обязательной. Создание таблиц возможно во время формирования основной надписи.

Для создания файла таблицы выполните следующие действия.

1. Создайте графический или текстовый документ КОМПАС-3D.

2. Создайте в этом документе таблицу, оформите ее и примените к ее ячейкам нужный формат.

3. Находясь в режиме редактирования таблицы, вызовите команду Файл — Сохранить таблицу в файл....

4. В появившемся диалоге укажите папку и имя файла для записи таблицы. Умолчательное расширение для файлов таблиц КОМПАС-3D — tbl.

Если таблица создаваемой основной надписи практически не имеет участков с регулярной структурой, целесообразнее заранее начертить ее во фрагменте КОМПАС-3D (*.frw).


11.2.1.6.2. Использование прототипов основных надписей

Если в текущей библиотеке уже есть основные надписи, вы можете использовать любую из них как прототип для вновь создаваемой основной надписи. Для этого перед нажатием кнопки Создать в диалоге работы с основными надписями выделите в списке нужную основную надпись (рис. 11.2.8).

Рис. 11.2.8. Выбор основной надписи-прототипа

На вопрос системы об использовании выбранной основной надписи в качестве прототипа ответьте «Да» (рис. 11.2.9).

Рис. 11.2.9. Подтверждение использования прототипа

В этом случае диалог создания основной надписи будет содержать перечень таблиц основной надписи-прототипа (рис. 11.2.10), и вы сможете разработать новую основную надпись, редактируя эти таблицы и их размещение. Возможно также удаление таблиц и добавление новых.

Рис. 11.2.10. Редактирование основной надписи-прототипа

Чтобы отредактировать таблицу, выделенную в списке, нажмите кнопку Редактировать..., а чтобы удалить — кнопку Удалить.

Основная надпись, созданная с использованием прототипа, ничем не отличается от основных надписей, созданных без него.

Аналогичным образом возможно создание оформлений на основе прототипа.


11.2.1.7. Создание оформления

После настройки основной надписи, которая будет входить в новое оформление документа, можно приступать к созданию самого оформления.

Общий порядок действий при создании нового оформления следующий.

1. Вызовите команду Сервис — Библиотеки стилей, типов, оформлений и основных надписей — Оформление чертежей и спецификаций... / Оформление текстовых документов... в зависимости от типа документа, для которого предназначается оформление.

2. В появившемся диалоге работы с оформлениями откройте библиотеку *.lyt, содержащую основную надпись, которая будет использоваться в создаваемом оформлении.

Основные надписи, хранящиеся в текущей библиотеке *.lyt, не отображаются в диалоге работы с оформлениями. Чтобы открыть нужную библиотеку, вы должны знать имя ее файла. Например, его можно запомнить или записать при создании оформления.

3. Нажмите кнопку Создать для перехода к созданию нового оформления в текущей библиотеке.

4. Настройте параметры нового оформления в появившемся диалоге (см. раздел 11.2.1.7.1). Закройте диалог настройки оформления нажатием кнопки ОК. Система вернется к диалогу работы с библиотеками оформлений. В списке оформлений текущей библиотеки появится имя созданного вами оформления.

5. Закройте диалог работы с библиотеками оформлений.

В этом разделе:

11.2.1.7.1. Настройка оформления


11.2.1.7.1. Настройка оформления

Настройка оформлений чертежей и текстовых документов производится в одноименных диалогах.

Диалоги настройки оформлений чертежей (рис. 11.2.11) и текстовых документов (рис. 11.2.12) частично отличаются друг от друга. Общие для обоих диалогов элементы управления представлены в таблице 11.2.6.

Табл. 11.2.6. Общие элементы управления диалогов настройки оформлений документов

Элемент

Описание

Имя

Поле для ввода названия оформления. Обычно название содержит краткую информацию о назначении оформления.

Номер

Поле для ввода номера оформления. Правила нумерации оформлений приведены в разделе 11.2.1.3.

Внешняя
рамка

Опция, управляющая присутствием в оформлении внешней рамки, ограничивающей формат. Чтобы указать стиль линии для отрисовки внешней рамки, выберите нужную строку из списка Линия. Внешний вид линии текущего стиля отображается в окне просмотра справа от списка.

Внутренняя
рамка

Опция, управляющая присутствием в оформлении внутренней рамки.

Чтобы указать стиль линии для отрисовки внешней рамки, выберите нужную строку из списка Линия. Внешний вид линии текущего стиля отображается в окне просмотра справа от списка.

Чтобы задать расстояния между соответствующими сторонами внешней и внутренней рамки, введите нужные значения (в миллиметрах) в поля группы Отступы от внешней рамки.

Основная
надпись

Опция, управляющая присутствием в оформлении таблиц основной надписи.

В поле, расположенном под данной опцией, отображается имя и номер основной надписи, которая используется в настраиваемом оформлении.

Чтобы сменить основную надпись, нажмите кнопку Выбор, находящуюся справа от поля. На экране появится диалог, содержащий перечень основных надписей, содержащихся в текущей библиотеке *.lyt.

Выбирать основную надпись удобнее, если ее имя совпадает с именем настраиваемого оформления — например, как в библиотеке Graphic.lyt.

Диалог настройки оформлений чертежей дополнительно содержит группу элементов Таблица изменений. Эти элементы представлены в таблице 11.2.7.

Рис. 11.2.11. Диалог настройки оформлений чертежей

Табл. 11.2.7. Группа элементов Таблица изменений

Элемент

Описание

Таблица изменений

Опция, управляющая присутствием в оформлении таблицы изменений как отдельной таблицы, не являющейся частью основной надписи.

Такая таблица изменений разрабатывается с помощью модуля проектирования спецификаций, т.е. фактически является специальным образом настроенной таблицей спецификации.

Стиль

Поле, в котором отображается стиль таблицы изменений, использующийся в настраиваемом оформлении.

Чтобы сменить стиль таблицы изменений, нажмите кнопку Выбор, находящуюся справа от поля. На экране появится диалог, содержащий перечень стилей спецификаций, содержащихся в текущей библиотеке *.lyt. В нем нужно указать стиль, соответствующий таблице изменений, которая будет использоваться в настраиваемом оформлении1.

В составе системы КОМПАС-3D поставляются два стиля, разработанных для таблицы изменений: Таблица изменений. ГОСТ 2.104–2006 и Таблица изменений с зонами. ГОСТ 2.104–2006. Они содержатся в библиотеке Graphic.lyt.

Сдвиг таблицы относительно главной таблицы основной надписи

Поля для ввода смещения нижнего правого угла таблицы изменений относительно верхнего левого угла главной таблицы основной надписи (главной считается первая таблица в списке таблиц основной надписи, см. рис. 11.2.5).

Количество строк в первом блоке

Поле для ввода количества записей об изменениях в первом блоке таблицы.

Например, чтобы таблица изменений не выходила за пределы таблицы основной надписи первого листа конструкторского чертежа, в первом блоке должно быть не более четырех строк.

Количество строк в последующих блоках

Поле для ввода количества записей об изменениях в последующих блоках таблицы.

Например, чтобы последующие блоки таблицы изменений по высоте были равны таблице основной надписи первого листа конструкторского чертежа, количество строк в них должно быть равно десяти.

Последующий блок располагать справа
от предыдущего

Опция, включение которой означает, что последующий блок изменений будет располагаться справа от предыдущего.

При выключенной опции последующие блоки располагаются слева от предыдущих.
  1. Работа с таблицей изменений в документе, использующем это оформление, будет возможна при включении работы со спецификацией.

Диалог настройки оформлений текстовых документов (рис. 11.2.12) дополнительно содержит группу элементов Поля текста. В этой группе можно задать расстояния между сторонами внутренней рамки и соответствующими им границами поля ввода. От границы поля ввода отсчитываются значения отступов и красной строки текста (см. рис. 11.1.40).

Рис. 11.2.12. Диалог настройки оформлений текстовых документов


11.2.1.8. Шаблоны документов

Шаблон КОМПАС-документа — это его заготовка, содержащая некоторые типовые настройки. Файлы шаблонов имеют следующие расширения:

– шаблон чертежа — cdt,

– шаблон фрагмента — frt,

– шаблон текстового документа — kdt,

– шаблон спецификации — spt,

– шаблон детали — m3t,

– шаблон сборки — a3t.

Выбор шаблона производится при создании документа (рис. 11.2.13).

Рис. 11.2.13. Создание чертежа по шаблону

Благодаря использованию шаблонов оформление и настройка новых типовых документов ускоряется и унифицируется.

В составе КОМПАС-3D поставляется несколько шаблонов для чертежей, текстовых документов, спецификаций и деталей. Шаблоны хранятся в подпапке \Templates главной папки системы.

Пользователь может отредактировать имеющиеся и сформировать собственные шаблоны для документов любого типа.

Чтобы сформировать шаблон, выполните следующие действия.

1. Создайте документ нужного типа.

2. Оформите и настройте его требуемым образом.

3. Сохраните документ, выбрав строку Шаблон в списке Тип файла диалога сохранения.

Путь к папке с шаблонами (т.е. к папке, которая по умолчанию предлагается для сохранения шаблона) определяется переменой TEMPLATES среды КОМПАС-3D (см. раздел 9.5.4). По умолчанию это подпапка \Templates главной папки системы. Если требуется, чтобы путь к папке с шаблонами отличался от умолчательного, используйте файл Kompas.ini (см. раздел 9.5.3).

Можно порекомендовать хранение в шаблоне следующих настроек и объектов:

– формат,

– оформление,

– заполнение типовых граф основной надписи (Разработал, Проверил, Нормоконтролер, Наименование предприятия и др.),

– настройки объектов (размеров, линий-выносок и др.),

– настройки системных стилей текстов,

– настройки свойств и точность отображения деталей и сборок.

При работе с документом, созданным по шаблону, пользователь может изменить любой из параметров, хранившихся в шаблоне.


11.2.2. Практика создания оформлений

11.2. Оформления документов

11.2.2. Практика создания оформлений

Данный раздел содержит упражнения, выполнение которых позволит вам овладеть основными приемами работы с оформлениями чертежей и текстовых документов. Прежде чем приступать к упражнениям, рекомендуется внимательно изучить теоретические сведения, содержащиеся в предыдущем разделе.

В этом разделе:

11.2.2.1. Приемы работы с библиотеками оформлений

Упражнение 87. Создание библиотеки оформлений. Самостоятельная работа

Упражнение 88. Копирование оформлений между библиотеками

11.2.2.2. Оформление чертежей

11.2.2.2.1. Основные надписи

Упражнение 89. Создание изображения таблицы во фрагменте

Упражнение 90. Основная надпись для первого листа

Упражнение 91. Основная надпись для последующих листов

11.2.2.2.2. Оформления

Упражнение 92. Оформление для первого листа

Упражнение 93. Оформление для последующих листов

11.2.2.2.3. Проверка правильности оформлений

Упражнение 94. Контроль созданных оформлений

11.2.2.3. Оформление текстовых документов

Упражнение 95. Оформление для текстового документа


11.2.2.1. Приемы работы с библиотеками оформлений

Упражнения по настройке основных надписей и оформлений рекомендуется выполнять в отдельной библиотеке, специально созданной для тренировок.

В этом разделе:

Упражнение 87. Создание библиотеки оформлений. Самостоятельная работа

Упражнение 88. Копирование оформлений между библиотеками


Упражнение 87. Создание библиотеки оформлений. Самостоятельная работа

Задание. Создайте библиотеку оформлений user_forms.lyt.

1. Вызовите команду Сервис — Библиотеки стилей, типов, оформлений и основных надписей — Оформление чертежей и спецификаций....

2. Создайте библиотеку оформлений с именем user_forms аналогично тому, как вы создавали библиотеку стилей линий в упражнении 71.

Не закрывая диалог работы с оформлениями, переходите к выполнению следующего упражнения.


Упражнение 88. Копирование оформлений между библиотеками

Задание. Скопируйте в библиотеку user_forms.lyt системные оформления Чертеж констр. Первый лист. ГОСТ 2.104-2006 и Чертеж констр. Посл. листы. ГОСТ 2.104-2006 из библиотеки Graphic.lyt.

1. Щелчком мыши активизируйте соседнее (левое) окно просмотра диалога работы с оформлениями.

2. Нажмите кнопку Показать библиотеку.

3. В появившемся диалоге откройте папку \Sys, укажите в ней файл Graphic.lyt и нажмите кнопку Открыть.

В левом окне просмотра отобразится список оформлений, хранящихся в выбранной библиотеке.

4. Выделите в списке оформления Чертеж констр. Первый лист. ГОСТ 2.104–2006 и Чертеж констр. Посл. листы. ГОСТ 2.104–2006. Для этого указывайте их, удерживая нажатой клавишу <Ctrl>.

5. Нажмите кнопку Копировать.

Выбранные оформления появятся в правом окне — в списке оформлений библиотеки user_forms.lyt. Эти оформления будут использованы для создания пользовательских оформлений при выполнении упражнений 92 и 93.

6. Закройте диалог работы с оформлениями чертежей, нажав кнопку Выход.

При копировании оформлений Чертеж констр. Первый лист. ГОСТ 2.104-2006 и Чертеж констр. Посл. листы. ГОСТ 2.104-2006 в библиотеку user_forms.lyt были скопированы также основные надписи, использующиеся в этих оформлениях.

7. Чтобы удостовериться в этом, вызовите команду Сервис — Библиотеки стилей, типов, оформлений и основных надписей — Основные надписи....

На экране появится диалог работы с основными надписями. Обратите внимание на то, что в окнах просмотра этого диалога показывается содержимое тех же библиотек, что и в диалоге работы с оформлениями.

8. Убедитесь, что окно библиотеки user_forms.lyt содержит две основные надписи Чертеж констр. Первый лист. ГОСТ 2.104-2006 и Чертеж констр. Посл. листы. ГОСТ 2.104-2006.

Эти основные надписи будут использованы для создания пользовательских основных надписей при выполнении упражнений 90 и 91.

9. Закройте диалог работы с основными надписями, нажав кнопку Выход.


11.2.2.2. Оформление чертежей

Данный раздел содержит упражнения, позволяющие овладеть приемами создания основных надписей и оформлений. Использование приемов показано на примере создания оформлений для первого и последующих листов чертежей, содержащих элементы отливок. В соответствии с Приложением 2 к ГОСТ 3.1125–88 эти чертежи должны иметь дополнительный штамп (рис. 11.2.14, 11.2.15). Назначение граф дополнительного штампа приведено в таблице 11.2.8.

Рис. 11.2.14. Расположение дополнительного штампа на листе

Рис. 11.2.15. Структура и размеры дополнительного штампа

Табл. 11.2.8. Назначение граф дополнительного штампа для чертежей, содержащих элементы отливок
Номер графы | Назначение
1 | Код отливки (или обозначение).
2 | Обозначение документа по ГОСТ 3.1201–85.
3 | Разработчик отливки.
4 | Фамилия разработчика отливки.
5 | Подпись разработчика отливки.
6 | Дата подписи.
7 | Нормоконтролер.
8 | Фамилия нормоконтролера.
9 | Подпись нормоконтролера.
10 | Порядковый номер изменения документа.
11 | Отметка о замене и введении листа извещения по ГОСТ 2.503–90.
12 | Обозначение (код) извещения.
13 | Подпись лица, ответственного за внесение изменения.
14 | Резервная.

В этом разделе:

11.2.2.2.1. Основные надписи

Упражнение 89. Создание изображения таблицы во фрагменте

Упражнение 90. Основная надпись для первого листа

Упражнение 91. Основная надпись для последующих листов

11.2.2.2.2. Оформления

Упражнение 92. Оформление для первого листа

Упражнение 93. Оформление для последующих листов

11.2.2.2.3. Проверка правильности оформлений

Упражнение 94. Контроль созданных оформлений


11.2.2.2.1. Основные надписи

В этом разделе:

Упражнение 89. Создание изображения таблицы во фрагменте

Упражнение 90. Основная надпись для первого листа

Упражнение 91. Основная надпись для последующих листов


Упражнение 89. Создание изображения таблицы во фрагменте

1. Создайте новый фрагмент.

2. Используя системные стили линий Основная и Тонкая, начертите в нем таблицу по размерам, указанным на рис. 11.2.15.

Как видно из рис. 11.2.14, нижняя граница дополнительного штампа совпадает с верхней границей главной таблицы чертежа. Поэтому не проводите линию, ограничивающую штамп снизу.

3. Сохраните созданный фрагмент под именем stamp.frw и закройте его.


Упражнение 90. Основная надпись для первого листа

1. Вызовите команду Сервис — Библиотеки стилей, типов, оформлений и основных надписей — Основные надписи....

На экране появится диалог работы с основными надписями. Если библиотека user_forms.lyt закрыта, откройте ее с помощью кнопки Показать библиотеку.

При выполнении упражнения 88 в библиотеку user_forms.lyt были скопированы оформления Чертеж констр. Первый лист. ГОСТ 2.104-2006 и Чертеж констр. Посл. листы. ГОСТ 2.104-2006. Как вы помните, при этом автоматически были скопированы также соответствующие основные надписи. Их названия отображаются сейчас в текущем окне просмотра.

2. Выделите основную надпись Чертеж констр. Первый лист. ГОСТ 2.104-2006 и нажмите кнопку Редактировать.

На экране появится диалог создания и редактирования основной надписи, содержащий параметры выбранной основной надписи. Эти параметры необходимо отредактировать.

3. Введите в поле Номер значение 101.

4. Введите в поле Имя Чертеж с элементами отливок. Первый лист. ГОСТ 3.1125–88.

5. Нажмите кнопку Добавить....

6. В появившемся диалоге создания таблицы нажмите кнопку Из файла и выберите из меню команду Создать из графического фрагмента.

7. В появившемся диалоге открытия файла укажите файл stamp.frw, содержащий изображение таблицы.

8. В появившемся диалоге параметров создания таблицы нажмите кнопку ОК.

9. В окне КОМПАС-3D появится таблица, изображение которой находилось в выбранном фрагменте (рис. 11.2.16).

Рис. 11.2.16. Окно КОМПАС-3D в режиме создания таблицы основной надписи

Так как во фрагменте отсутствовала линия, ограничивающая штамп снизу, для нижних границ соответствующих ячеек таблицы автоматически был выбран стиль линии Невидимая. По умолчанию невидимые границы не отображаются на экране. Чтобы включить их показ, нажмите кнопку Отображать сетку на вкладке Таблица Панели свойств.

Внутри ячеек штриховой линией показаны границы ввода текста. Расстояния от границы ввода до соответствующих границ ячейки — отступы текста. По умолчанию используются следующие значения отступов:

– слева 0.5 мм

– справа 0.5 мм

– сверху 0 мм

– снизу 0 мм

10. Задайте для граф 1, 2 и 14 отступы сверху и снизу равными 0.5 мм.

10.1. Установите курсор в нужную ячейку и вызовите команду Формат — Формат ячейки.

10.2. В полях сверху и снизу появившегося диалога введите значения 0.5.

10.3. Остальные значения отступов этих же и остальных ячеек не меняйте.

11. Вызовите команду Таблица — Блокировка таблицы.

12. Включите все опции появившегося диалога и закройте его.

13. Присвойте всем графам, кроме 1, 2, 3, 7 и 14, стиль текста Default и установите возможность ввода только одной строки текста в каждую из них.

13.1. Установите курсор в нужную ячейку и вызовите команду Формат — Формат ячейки.

13.2. В появившемся диалоге включите опцию Однострочный текст.

Благодаря данной настройке при заполнении дополнительного штампа перенос строк в этих графах будет игнорироваться. Длина строки будет подгоняться к ширине графы путем автоматического увеличения сужения символов.

13.3. Нажмите кнопку Изменить....

13.4. В появившемся диалоге активизируйте вкладку Внедренные.

13.5. Из списка на этой вкладке выберите стиль Default и нажмите кнопку Выбрать.

Название выбранного стиля появится в поле Стиль текста по умолчанию диалога настройки формата ячейки.

13.6. Закройте диалог настройки формата ячейки.

Как в новой таблице основной надписи появились стили текста Default, Лит-Масса-Масштаб, Обозначение, Наименование и Материал-Предприятие, названия которых отображаются в диалоге выбора текущего стиля текста?

Они были созданы и сохранены в основной надписи Чертеж констр. Первый лист. ГОСТ 2.104-2006, на основе которой разрабатывается новая основная надпись.

Создание стиля текста в основной надписи возможно при создании или редактировании любой таблицы в этой основной надписи. Стили текста, созданные в основной надписи, доступны в любой ее таблице, а не только в той, при работе с которой были созданы.

В этом вы только что убедились, присвоив стиль Default ячейкам вновь созданной таблицы. Данный стиль будет применен к текстам, введенным в эти ячейки при заполнении дополнительного штампа в документе.

14. Присвойте графам 3, 7 и 14 стиль текста Default.

Запрет переносов строк в них устанавливать не нужно. Графы 3 и 7 будут содержать текст, а значит, станут недоступными для пользователя. Графа 14 — резервная, поэтому для нее следует оставить возможность ввода нескольких строк.

15. Установите левое выравнивание для всех граф, кроме 1 и 2.

16. Введите в графу 3 текст Разработал, а в графу 7 — Норм. контр.

При заполнении дополнительного штампа ввод и редактирование текста в этих графах будут невозможны.

17. Графам 1 и 2 присвойте стиль Обозначение.

Данный стиль имеет настройку расширенного стиля — настройку, определяющую шаг строк, высоту и сужение символов в тексте в зависимости от количества строк в нем.

17.1. Чтобы просмотреть настройку расширенного стиля, вызовите команду Сервис — Библиотеки стилей, типов, оформлений и основных надписей — Стили текстов....

17.2. В появившемся диалоге нажмите кнопку Показать документ.

17.3. В активном окне просмотра активизируйте вкладку Внедренные. На ней отображается список стилей текстов, имеющихся в текущей основной надписи (основной надписи, содержащей редактируемую таблицу).

17.4. Выделите в списке стиль Обозначение.

17.5. Нажмите кнопку Редактировать.

17.6. В появившемся диалоге нажмите кнопку Далее....

На экране появится диалог настройки расширенного стиля текста (рис. 11.2.17).

Рис. 11.2.17. Диалог настройки расширенного стиля текста

Настройка, сделанная в этом диалоге, определяет следующие правила расположения текста в ячейке:

• если текст состоит из одной строки, высота символов в нем — 7 мм; шаг строк в данном случае не имеет значения,

• если текст состоит из двух строк, то они располагаются с шагом 7 мм; высота символов — 5 мм.

17.7. Не изменяя настроек, закройте диалоги расширенного стиля текста, редактирования стиля текста и работы с наборами и библиотеками стилей.

Общая настройка ячеек — определение внешнего вида текстов в ячейках — завершена. Теперь нужно настроить расширенный формат — определить сервисные функции, доступные при заполнении граф дополнительного штампа в документе, а также возможность и порядок передачи данных из одного дополнительного штампа в другой при смене оформления документа.

Настройку расширенного формата необходимо выполнить для каждой пустой ячейки, т.е. для всех ячеек, кроме 3 и 7. Для этого необходимо поочередно устанавливать курсор в нужные ячейки, вызывать диалог настройки расширенного формата (рис. 11.2.18) и устанавливать необходимые параметры.

Рис. 11.2.18. Диалог настройки расширенного формата ячейки

18. Вызовите диалог настройки расширенного формата ячейки. Для этого нажмите кнопку Расширенный формат ячейки на инструментальной панели Таблицы и границы.

19. Настройте расширенный формат ячеек в соответствии с таблицей 11.2.9.

Табл. 11.2.9. Настройка расширенного формата ячеек
№ графы | Тип ячейки | Идентификатор ячейки | Значение (для идент. Пользовательский)
1 | Общий для документа | Пользовательский | 1000
2 | Общий для документа | Пользовательский | 1001
4 | Общий для документа | Пользовательский | 1002
5 | Общий для листа | 1003 |
6 | Общий для документа | Пользовательский | 1004
8 | Общий для документа | Фамилия норм. контр. |
9 | Общий для листа | 1005 |
6а | Общий для документа | Дата норм. контр. |

20. Для всех остальных ячеек установите тип Общий для листа и присвойте им идентификаторы с 1006 по 1017.

21. В качестве Запроса при вводе текста в ячейку введите сведения о назначении граф из таблицы 11.2.8.

Так, например, запросом для первой графы будет Код или обозначение отливки, для второй — Обозначение документа по ГОСТ 3.1201–85 и т.д.

22. При настройке граф для ввода дат (6, 6а, 6б и 6в) после текста запроса введите вертикальную черту и число 4099: |4099.

Благодаря этому в дальнейшем (при заполнении дополнительного штампа) двойной щелчок мыши в этих графах будет вызывать диалог выбора даты.

Почему расширенный формат ячеек таблицы нужно настраивать именно так?

– Ни одна ячейка не содержит данные, которые система могла бы определить самостоятельно, поэтому ни одной ячейке не присвоен тип Системный.

– Точно также ни одна ячейка не предназначена для ввода объектов спецификации, поэтому тип Для таблицы спецификации тоже не используется.

– Руководствуясь правилами, приведенными в разделах Особенности использования типов ячеек Общий для листа и Общий для документа и Применение пользовательских идентификаторов, ячейки созданной таблицы необходимо настроить следующим образом.

• Код отливки и обозначение документа — сведения, которые должны быть одинаковыми на всех листах многолистового документа, поэтому для граф 1 и 2 выбран тип Общий для документа. Так как системного идентификатора для этих ячеек нет, для них выбран Пользовательский идентификатор. Значения идентификаторов заданы в соответствии с таблицей 11.2.4.

• Фамилия разработчика чертежа отливки одна и та же на всех листах многолистового чертежа. То же можно сказать о фамилии нормоконтролера. Поэтому для граф 4 и 8 выбран тип Общий для документа.

• Так как разработчик чертежа отливки и разработчик чертежа детали (чья фамилия указывается в главной таблице основной надписи) обычно разные люди, графе Разработчик отливки нельзя присвоить системный идентификатор Фамилия разработавшего. Это привело бы к передаче в нее фамилии разработчика из основной надписи. Поэтому графе 4 присвоен пользовательский идентификатор.

• В отличие от разработчиков, нормоконтролером чертежа детали и отливки может являться один и тот же человек, поэтому графе 8 присвоен системный идентификатор Фамилия норм. контр. Благодаря этому фамилия, введенная в графу Н. контр. при заполнении основной надписи, будет автоматически передана в графу Норм. контр. дополнительного штампа и наоборот.

• Графы 5, 9, 13 и 13а предназначены для подписей, поэтому они имеют тип Общий для листа и уникальные числовые идентификаторы.

• Графы 6 и 6а содержат даты подписи документа разработчиком отливки и нормоконтролером. Они настроены аналогично графам 4 и 8: обе имеют тип Общий для документа, но идентификатор графы 6 пользовательский, а графы 6а — системный (Дата норм. контр.).

Если нормоконтролеры, проверяющие чертежи деталей и отливок, разные, то графы 8 и 6а следует настраивать аналогично графам 4 и 6.

• Графы 10, 10а, 11, 11а, 12 и 12а содержат данные, уникальные для листа, поэтому их тип — Общий для листа.

23. Вызовите команду Сервис — Проверка идентификаторов.

На экране появится диалог с изображением текущей таблицы. Отображение каких-либо из ее ячеек голубым или розовым цветом означает соответственно отсутствие или совпадение идентификаторов у этих ячеек.

24. Если в таблице есть такие ячейки, проверьте их настройку и измените ее.

25. Вызовите команду Файл — Сохранить таблицу.

Созданная таблица и ее настройки будут записаны в основную надпись Чертеж с элементами отливок. Первый лист. ГОСТ 3.1125–88.

26. Теперь сохраните таблицу в файл. Этот файл будет использоваться при создании основной надписи для последующих листов чертежей, содержащих изображения отливок.

26.1. Вызовите команду Файл — Сохранить таблицу в файл....

26.2. В появившемся диалоге выберите папку для сохранения файла таблицы. В поле Имя файла введите stamp и нажмите кнопку Сохранить.

В указанной папке будет создан файл stamp.tbl, содержащий структуру и оформление таблицы, формат и расширенный формат ее ячеек.

27. Вызовите команду Файл — Завершить редактирование таблицы или щелкните мышью по значку режима редактирования в окне таблицы.

Окно редактирования таблицы закроется. На экране вновь появится диалог создания основной надписи.

Вновь созданная таблица размещается в конце списка Состав основной надписи и называется «БЕЗ ИМЕНИ». Ее изображение выделено зеленым цветом в окне Предварительный просмотр.

28. Выделите новую таблицу в списке и введите в поле Наименование таблицы Дополнительная.

29. Разместите новую таблицу на листе так, чтобы ее левый нижний угол совпал с левым верхним углом Главной таблицы.

29.1. Выберите из списка Опорная точка на листе строку правый нижний угол рамки.

29.2. Выберите из списка Опорная точка в таблице строку левый нижний угол.

29.3. В поле Сдвиг по горизонтали введите -185.

29.4. В поле Сдвиг по вертикали введите 55.

29.5. В поле Угол поворота введите 0.

30. Опции Относительно длинной стороны и Использовать для спецификации не включайте.

31. На этом создание основной надписи Чертеж с элементами отливок. Первый лист. ГОСТ 3.1125–88 завершено. Нажмите кнопку ОК.

Диалог создания основной надписи закроется. На экране появится диалог работы с основными надписями. Он содержит основные надписи Чертеж констр. Посл. листы. ГОСТ 2.104-2006 и Чертеж с элементами отливок. Первый лист. ГОСТ 3.1125–88.


Упражнение 91. Основная надпись для последующих листов

Создание основной надписи для последующих листов не включает этап настройки таблицы, так как таблица для этой основной надписи уже готова — она хранится в файле stamp.tbl. Остальные этапы аналогичны этапам создания основной надписи для первого листа, поэтому их подробное описание не приводится.

1. Выделите основную надпись Чертеж констр. Посл. листы. ГОСТ 2.104-2006 и нажмите кнопку Редактировать.

На экране появится диалог создания и редактирования основной надписи.

2. В поле Номер введите 102.

3. В поле Имя введите Чертеж с элементами отливок. Посл. листы. ГОСТ 3.1125–88.

4. Нажмите кнопку Добавить....

5. В появившемся диалоге создания таблицы нажмите кнопку Из файла и выберите из меню команду Загрузить из файла таблиц...

6. В появившемся диалоге открытия файла укажите файл stamp.tbl, содержащий таблицу, созданную и настроенную при выполнении предыдущего упражнения.

Выбранная таблица появится в окне КОМПАС-3D.

7. Убедитесь в том, что таблица сохранила свою структуру и оформление, а все ячейки — свои тексты, настройки формата и расширенного формата.

8. Вызовите команду Файл — Сохранить таблицу.

9. Повторите пункты 28–30 из предыдущего упражнения, задав сдвиг по вертикали 15 мм.

10. На этом создание основной надписи Чертеж с элементами отливок. Посл. листы. ГОСТ 3.1125–88 завершено. Нажмите кнопку ОК.

Диалог создания основной надписи закроется. На экране появится диалог работы с основными надписями. Теперь он содержит основные надписи Чертеж с элементами отливок. Первый лист. ГОСТ 3.1125–88 и Чертеж с элементами отливок. Посл. листы. ГОСТ 3.1125–88.

11. Закройте диалог работы с основными надписями.


11.2.2.2.2. Оформления

В этом разделе:

Упражнение 92. Оформление для первого листа

Упражнение 93. Оформление для последующих листов


Упражнение 92. Оформление для первого листа

1. Вызовите команду Сервис — Библиотеки стилей, типов, оформлений и основных надписей — Оформление чертежей и спецификаций....

На экране появится диалог работы с оформлениями. В одном из его окон отображается перечень оформлений, содержащихся в библиотеке user_forms.lyt: Чертеж констр. Первый лист. ГОСТ 2.104-2006 и Чертеж констр. Посл. листы. ГОСТ 2.104-2006.

2. Если это не так, нажмите кнопку Показать библиотеку и откройте файл user_forms.lyt.

3. Выделите оформление Чертеж констр. Первый лист. ГОСТ 2.104-2006 и нажмите кнопку Редактировать.

На экране появится диалог настройки оформления документа.

4. В поле Имя введите Чертеж с элементами отливок. Первый лист. ГОСТ 3.1125–88.

5. В поле Номер введите 101.

6. Нажмите кнопку Выбор в группе Основная надпись.

7. В появившемся диалоге выбора основной надписи укажите строку Чертеж с элементами отливок. Первый лист. ГОСТ 3.1125–88 и нажмите кнопку ОК.

Диалог выбора основной надписи закроется. На экране останется диалог настройки оформления.

8. Не изменяя остальных параметров, закройте диалог настройки оформления кнопкой ОК.

На экране останется диалог работы с оформлениями. В его активном окне просмотра вместо оформления Чертеж констр. Первый лист. ГОСТ 2.104-2006 появится оформление Чертеж с элементами отливок. Первый лист. ГОСТ 3.1125–88.


Упражнение 93. Оформление для последующих листов

1. Выделите оформление Чертеж констр. Посл. листы. ГОСТ 2.104-2006 и нажмите кнопку Редактировать.

На экране появится диалог настройки оформления документа.

2. В поле Имя введите Чертеж с элементами отливок. Посл. листы. ГОСТ 3.1125–88.

3. В поле Номер введите 102.

4. Выберите основную надпись Чертеж с элементами отливок. Посл. листы. ГОСТ 3.1125–88.

5. Остальные параметры не изменяйте.

6. Нажмите кнопку ОК.

7. Закройте диалог работы с оформлениями.


11.2.2.2.3. Проверка правильности оформлений

Сразу после создания оформлений нужно проверить правильность их настроек. Обнаружив ошибку, ее следует немедленно исправить, так как редактирование уже присвоенных документам оформлений — очень долгая и кропотливая работа.

В этом разделе:

Упражнение 94. Контроль созданных оформлений


Упражнение 94. Контроль созданных оформлений

1. Создайте новый чертеж КОМПАС-3D.

Первому листу нового чертежа присвоено умолчательное оформление — Чертеж констр. Первый лист. ГОСТ 2.104-2006 из библиотеки Graphic.lyt.

2. Присвойте этому листу оформление Чертеж с элементами отливок. Первый лист. ГОСТ 3.1125–88 из библиотеки user_forms.lyt.

2.1. Вызовите команду Сервис — Менеджер документа.

2.2. В Дереве листов, видов и слоев (оно расположено в левой части диалога Менеджер документа) выделите объект Листы.

В правой части диалога — в Списке листов, видов и слоев — появится строка, соответствующая единственному листу. Список листов, видов и слоев — это таблица, в колонках которой отображаются свойства объектов. Любое свойство можно изменить непосредственно в Менеджере документа.

2.3. Выделите строку, соответствующую первому листу чертежа, щелчком мыши.

2.4. Щелкните мышью в последней ячейке строки — ячейке, находящейся в колонке Библиотека оформлений.

На экране появится диалог выбора оформления листа.

2.5. Нажмите в нем кнопку Библиотека.

2.6. В появившемся диалоге открытия файла укажите файл user_forms.lyt и нажмите кнопку Открыть.

Диалог открытия файлов закроется. На экране появится диалог выбора оформления из библиотеки.

2.7. Выделите строку Чертеж с элементами отливок. Первый лист. ГОСТ 3.1125–88.

2.8. Закройте диалог выбора оформления из библиотеки кнопкой ОК, затем нажмите в диалоге выбора оформления листа кнопку Перечитать.

2.9. В диалоге Менеджер документа нажмите кнопку Применить.

Вы увидите, что изображение листа чертежа на экране изменилось: теперь он содержит дополнительный штамп. Для удобства просмотра «перетащите» Менеджер документа в сторону, не закрывая его.

3. Добавьте в чертеж новый лист и присвойте ему оформление Чертеж с элементами отливок. Посл. листы. ГОСТ 3.1125–88. Эти операции выполняются с помощью Менеджера документа.

3.1. Расположите Менеджер документа на экране так, чтобы с ним было удобно работать.

3.2. Нажмите на инструментальной панели Менеджера документа кнопку Создать лист.

В Списке листов, видов и слоев появится новая строка, соответствующая добавленному листу. По умолчанию вновь добавленный лист имеет оформление Чертеж констр. Посл. листы. ГОСТ 2.104-2006 из библиотеки Graphic.lyt.

3.3. Присвойте ему оформление Чертеж с элементами отливок. Посл. листы. ГОСТ 3.1125–88 из библиотеки user_forms.lyt. Для этого выполните действия, аналогичные описанным в пп. 2.3–2.8.

4. Закройте диалог Менеджер документа кнопкой ОК.

5. Проверьте правильность настройки таблицы дополнительного штампа.

5.1. Войдите в режим редактирования штампа на первом листе, дважды щелкнув мышью по его изображению.

5.2. Установите курсор в графу 1 — верхнюю левую ячейку таблицы.

5.3. Убедитесь, что Строка сообщений содержит текст «Код или обозначение отливки».

5.4. Введите несколько символов в эту ячейку. Убедитесь, что высота их равна 7 мм.

5.5. Нажав клавишу <Enter>, сформируйте еще одну строку в этой ячейке и введите текст этой строки. Убедитесь, что высота символов стала равна 5 мм.

5.6. Дважды щелкните мышью в любой из граф ввода даты (6, 6а, 6б или 6в). Убедитесь, что на экране появляется диалог выбора даты.

5.7. Заполните произвольными данными все графы дополнительного штампа, кроме граф, предназначенных для подписей (5, 9, 13 и 13а).

Убедитесь, что в графу 14 можно ввести произвольное количество строк, а во все остальные — только одну.

Убедитесь, что к вводимому тексту применяется стиль Default.

5.8. Выйдите из режима редактирования штампа, нажав комбинацию клавиш <Ctrl> + <Enter>.

Убедитесь, в том, что:

– данные, введенные в графы Код или обозначение отливки и Обозначение документа по ГОСТ 3.1201–85 (1 и 2), передались в соответствующие ячейки дополнительного штампа на втором листе;

– данные, введенные в графы Фамилия разработчика отливки, Фамилия нормоконтролера, Дата подписи разработчика и Дата подписи нормоконтролера (4, 8, 6 и 6а), передались в соответствующие ячейки дополнительного штампа на втором листе;

– данные, введенные в графы Фамилия нормоконтролера и Дата подписи нормоконтролера (8 и 6а), передались также в соответствующие графы Главной таблицы основной надписи на первом листе;

– данные об изменениях отливки никуда не передались.

6. Сохраните чертеж.

7. Присвойте первому листу оформление Чертеж с элементами отливок. Посл. листы. ГОСТ 3.1125–88.

Убедитесь, что после смены оформления все данные в дополнительном штампе сохранились.

Фактически при смене оформления произошло следующее. Таблицы основных надписей, входящие в оформления Чертеж с элементами отливок. Перв. лист. ГОСТ 3.1125–88 и Чертеж с элементами отливок. Посл. листы. ГОСТ 3.1125–88, были проверены на наличие идентичных ячеек — ячеек с одинаковыми типами и идентификаторами. Затем данные из ячеек прежней основной надписи были переданы в идентичные им ячейки новой основной надписи.

В данном случае идентичные ячейки нашлись благодаря использованию в оформлениях одной и той же таблицы.

Если же требуется организовать передачу данных между ячейками разных таблиц, находящихся в разных основных надписях, необходимо вручную настроить эти ячейки так, чтобы их типы и идентификаторы совпадали.


11.2.2.3. Оформление текстовых документов

Создание оформлений для текстовых документов включает те же два основных этапа, что и создание оформлений для чертежей:

– создание основной надписи,

– создание оформления, содержащего основную надпись.

Создание основной надписи для текстового документа аналогично созданию основной надписи для чертежа.

В упражнении 95 рассматривается создание оформления с использованием готовой основой основной надписи.

Оформление, создание которого описано в упражнении 95, уже существует в библиотеке Graphic.lyt.

В этом разделе:

Упражнение 95. Оформление для текстового документа


Упражнение 95. Оформление для текстового документа

Задание. Создайте в библиотеке user_forms оформление для листа регистрации изменений в текстовом документе. Используйте основную надпись Лист регистр. изменен. (вертик.) Посл. листы. ГОСТ 2.503-90 Ф3 из библиотеки Graphic.lyt.

1. Вызовите команду Сервис — Библиотеки стилей, типов, оформлений и основных надписей — Основные надписи....

На экране появится диалог работы с основными надписями.

2. Используя кнопку Показать библиотеку, откройте в одном окне диалога библиотеку user_forms.lyt, а в другом — Graphic.lyt.

3. Скопируйте основную надпись Лист регистр. измен. (вертик.) Посл. листы. ГОСТ 2.503-90 Ф3 из библиотеки Graphic.lyt в user_forms.lyt и закройте диалог работы с основными надписями.

4. Вызовите команду Сервис — Библиотеки стилей, типов, оформлений и основных надписей — Оформление текстовых документов....

На экране появится диалог работы с оформлениями текстовых документов.

5. Используя кнопку Показать библиотеку, откройте библиотеку user_forms.lyt.

6. Создайте оформление Лист регистр. измен. (вертик.) Посл. листы. ГОСТ 2.503-90 Ф3.

6.1. Нажмите кнопку Создать в диалоге работы с оформлениями текстовых документов.

На экране появится диалог настройки оформления текстового документа.

6.2. В поле Имя введите Лист регистр. изменен. (вертик.) Посл. листы. ГОСТ 2.503-90 Ф3.

6.3. В поле Номер введите 101.

6.4. Включите опцию Основная надпись. Под ней находится поле с именем основной надписи. Пока это поле пусто.

6.5. Нажмите кнопку Выбрать слева от поля с именем основной надписи.

6.6. На экране появится диалог выбора основной надписи.

6.7. В этом диалоге укажите основную надпись Лист регистр. изменен. (вертик.) Посл. листы. ГОСТ 2.503-90 Ф3 и нажмите кнопку ОК.

Диалог выбора основной надписи закроется, а имя выбранной основной надписи появится в диалоге настройки оформления текстовых документов.

На этом создание оформления завершено (рис 11.2.19).

Рис. 11.2.19. Создание оформления для листа регистрации изменений в текстовом документе

6.8. Не изменяя остальных параметров, закройте диалог, нажав кнопку ОК.

На экране останется диалог работы с оформлениями текстовых документов. В списке хранящихся в библиотеке user_forms.lyt оформлений для текстовых документов появится созданное вами оформление Лист регистр. изменен. (вертик.) Посл. листы. ГОСТ 2.503-90 Ф3.

7. Закройте диалог работы с оформлениями текстовых документов.

8. Проверьте правильность созданного оформления. Для этого создайте текстовый документ КОМПАС-3D с несколькими разделами и присвойте последнему разделу оформление Лист регистр. изменен. (вертик.) Посл. листы. ГОСТ 2.503-90 ФЗ из библиотеки user_forms.lyt. Пример создания текстового документа рассмотрен в разделе 4.1.4.6.


11.3. Прикладные библиотеки и библиотеки документов

11.3. Прикладные библиотеки
и библиотеки документов

В этом разделе:

11.3.1. Менеджер библиотек

11.3.1.1. Окно Менеджера библиотек

11.3.1.2. Управление Менеджером библиотек

11.3.1.3. Управление библиотеками

11.3.2. Библиотека фрагментов

11.3.2.1. Создание библиотеки фрагментов

11.3.2.2. Вставка фрагментов из библиотеки

11.3.2.3. Отключение библиотеки

11.3.2.4. Сервисные функции

11.3.3. Прикладные библиотеки

11.3.3.1. Сервисные инструменты

11.3.3.2. Проверка графических документов (Проверка документа)

11.3.4. Библиотека эскизов

11.3.4.1. Подключение библиотеки эскизов

11.3.4.2. Использование библиотеки эскизов

11.3.4.3. Пользовательская библиотека отверстий

11.3.5. Библиотека моделей

11.3.5.1. Особенности библиотечных моделей

11.3.5.2. Вставка в модель библиотечного компонента


11.3.1. Менеджер библиотек

11.3. Прикладные библиотеки и библиотеки документов

11.3.1. Менеджер библиотек

Управление прикладными библиотеками и библиотеками документов КОМПАС-3D производится в Менеджере библиотек.

Для включения и отключения окна Менеджера библиотек служит команда Сервис — Менеджер библиотек.

В этом разделе:

11.3.1.1. Окно Менеджера библиотек

11.3.1.2. Управление Менеджером библиотек

11.3.1.3. Управление библиотеками


11.3.1.1. Окно Менеджера библиотек

Окно Менеджера библиотек может содержать несколько вкладок. На первой вкладке — Библиотеки КОМПАС — отображается структура Менеджера: списки разделов и библиотек (рис. 11.3.1).

Рис. 11.3.1. Окно Менеджера библиотек

Если в разделе имеются подключенные библиотеки, то его пиктограмма отображается серым цветом, если нет — голубым.

Слева от названия каждой библиотеки находится пиктограмма, характеризующая тип этой библиотеки:

– прикладная библиотека,

– библиотека фрагментов,

– библиотека моделей.

На остальных вкладках Менеджера отображается содержимое подключенных на данный момент библиотек фрагментов, моделей и прикладных библиотек, работающих в режиме панели.

Подключенные библиотеки отмечены красной «галочкой».

Для работы с Менеджером и с библиотеками предназначены команды контекстных меню вкладок.


11.3.1.2. Управление Менеджером библиотек

Для управления Менеджером библиотек предназначены команды контекстного меню области просмотра разделов (рис. 11.3.1). Эти команды представлены в таблице 11.3.1.

Табл. 11.3.1. Команды управления Менеджером библиотек
Команда | Описание
Добавить описание | Добавление библиотеки в Менеджер библиотек.
Вид | Настройка внешнего вида панели Менеджера библиотек.
Создать раздел | Создание нового раздела (подраздела) в Менеджере библиотек.
Удалить | Удаление выделенного раздела из Менеджера библиотек. Раздел удаляется вместе со своими подразделами.
Вставить | Вставить в выделенный раздел Менеджера библиотеку, находящуюся в буфере обмена1. Если буфер обмена пуст, команда недоступна.
Обновить Менеджер библиотек | Удаление библиотек, файлы которых отсутствуют по заданным для них путям, и добавление библиотек, указанных в файлах *.lms, находящихся в подпапке Sys главной папки системы2.
Очистить Менеджер библиотек | Удаление из Менеджера всех библиотек, кроме подключенных на момент вызова команды.
  1. Менеджер библиотек использует собственный механизм буфера обмена, отличающийся от стандартного буфера Windows.
  2. Команда доступна также в разделе Сервис Главного меню КОМПАС-3D.


11.3.1.3. Управление библиотеками

Для управления библиотеками предназначены команды контекстного меню библиотеки, выделенной в списке (рис. 11.3.1). Эти команды представлены в таблице 11.3.2.

Табл. 11.3.2. Команды управления библиотеками

Команда

Описание

Запустить

Запуск библиотеки, выделенной в списке.

Запуск библиотек фрагментов и моделей происходит также при их подключении.

Подключить

Подключение библиотеки, выделенной в списке. Подключение необходимо, чтобы функции библиотеки были доступны пользователю.

Команда доступна для неподключенных библиотек.

Выбранная библиотека подключается в установленном для нее режиме. В поле рядом с названием библиотеки появляется красная «галочка» — признак того, что библиотека подключена.

Для отключения библиотеки повторно вызовите команду Подключить. Можно также щелкнуть мышью в поле с красной «галочкой» рядом с названием библиотеки.

Режим работы

Выбор режима работы библиотеки, выделенной в списке.

Свойства

Настройка свойств библиотеки, выделенной в списке. После вызова команды на экране появляется настроечный диалог. Команда доступна для неподключенных библиотек.

Удалить

Удаление библиотеки, выделенной в списке, из Менеджера библиотек1.

Вырезать

Удаление библиотеки, выделенной в списке, из Менеджера библиотек и помещение ее в буфер обмена Менеджера. Вырезание в буфер очередной библиотеки удаляет его предыдущее содержимое.

Вставить

Вставка библиотеки из буфера в текущий раздел Менеджера.

Отключить все

Отключение от системы КОМПАС-3D всех подключенных библиотек.
  1. Удаление библиотеки означает отключение доступа к ней из Менеджера библиотек. Никаких действий с файлом библиотеки на диске при этом не производится.


11.3.2. Библиотека фрагментов

11.3. Прикладные библиотеки и библиотеки документов

11.3.2. Библиотека фрагментов

При работе в КОМПАС-3D вы можете сохранять созданные изображения типовых деталей во фрагментах, а затем вставлять их в новые чертежи. Если во время работы часто возникает необходимость вставлять в чертежи одни и те же фрагменты, удобно пользоваться библиотеками фрагментов. В библиотеках можно упорядоченно хранить различные типовые фрагменты с произвольными комментариями к ним. Использование библиотек фрагментов упрощает поиск и вставку в документ готовых изображений.

Каждая библиотека фрагментов представляет собой отдельный файл с расширением lfr. Фрагменты библиотеки не являются отдельными файлами на диске, а входят составными частями в единый файл библиотеки. Фрагменты хранятся в виде упорядоченных списков в подразделах и корневом разделе библиотеки. Имена фрагментов и разделов библиотеки могут состоять из любых символов, количество фрагментов и разделов не ограничено.

В комплект поставки КОМПАС-3D включены некоторые библиотеки фрагментов (например, библиотека технологических обозначений). Для работы с библиотеками фрагментов, не входящими в комплект поставки системы, требуется отдельно оплачиваемая лицензия.

Каждая библиотека фрагментов отображается на отдельной вкладке Менеджера библиотек (рис. 11.3.2).

Рис. 11.3.2. Пример библиотеки фрагментов

Для настройки внешнего вида вкладки служит команда Вид из ее контекстного меню.

В этом разделе:

11.3.2.1. Создание библиотеки фрагментов

11.3.2.2. Вставка фрагментов из библиотеки

11.3.2.3. Отключение библиотеки

11.3.2.4. Сервисные функции


11.3.2.1. Создание библиотеки фрагментов

Чтобы создать новую библиотеку фрагментов, выполните следующие действия.

1. Вызовите из контекстного меню списка разделов Менеджера команду Добавить описание — библиотеки документов.

2. В появившемся диалоге введите имя несуществующей библиотеки и подтвердите ее создание.

3. В появившемся диалоге свойств библиотеки введите ее название в Менеджере.

Созданная библиотека появится в списке библиотек текущего раздела Менеджера. Эта библиотека пока не подключена.

4. Выделите созданную библиотеку и вызовите из контекстного меню команду Подключить.

В окне Менеджера библиотек появится вкладка, соответствующая созданной библиотеке. Эта вкладка пуста, поскольку вновь созданная библиотека еще не содержит фрагменты.

5. Сформируйте структуру библиотеки с помощью команды Создать раздел из контекстного меню вкладки.

6. Включите фрагменты в разделы. Это можно сделать двумя способами:

– поместить в библиотеку готовые фрагменты,

– создать фрагменты непосредственно в библиотеке.

Если имеются готовые фрагменты, которые будут храниться в библиотеке, выполните следующие действия.

6.1. Вызовите из контекстного меню вкладки команду Добавить фрагмент в библиотеку....

6.2. В появившемся диалоге укажите папку и имя файла (файлов) *.frw для включения в библиотеку.

6.3. В появившемся диалоге задания имени фрагмента установите имя по умолчанию (полное или относительное) или введите произвольное имя фрагмента (фрагментов) в библиотеке.

Выбранные фрагменты будут помещены в текущий раздел библиотеки под заданными именами.

Если готовых фрагментов нет, выполните следующие действия.

6.4. Вызовите из контекстного меню вкладки команду Новый фрагмент.

6.5. В появившемся диалоге введите имя фрагмента в библиотеке.

КОМПАС-3D откроет новое окно фрагмента.

6.6. Создайте изображение, которое будет храниться во фрагменте.

6.7. Сохраните и закройте фрагмент.

Созданный фрагмент будет помещен в текущий раздел библиотеки.

В дальнейшем, чтобы отредактировать библиотечный фрагмент, выделите его в списке и вызовите из контекстного меню команду Редактировать.

Для управления структурой библиотеки служат команды Удалить, Копировать, Вырезать и Вставить контекстного меню. С их помощью вы можете переносить фрагменты и подразделы между разделами, а также удалять ставшие ненужными разделы и фрагменты.

Кроме того, с помощью команд копирования, вырезания и вставки возможен обмен разделами и фрагментами между различными библиотеками фрагментов.


11.3.2.2. Вставка фрагментов из библиотеки

Чтобы вставить фрагмент из библиотеки в текущий графический документ, выполните следующие действия.

1. Выделите в списке фрагмент, который требуется вставить, и вызовите из контекстного меню команду Вставить фрагмент в документ. Можно также дважды щелкнуть мышью по имени нужного фрагмента.

Система перейдет в режим вставки фрагмента. На Панели свойств появятся элементы управления вставкой (см. табл. 3.8.2).

2. Настройте параметры вставки на Панели свойств и укажите базовую точку фрагмента.

3. Выполните необходимое количество вставок и нажмите кнопку Прервать команду.

Вставка фрагмента из библиотеки возможна также с помощью команды Вставить фрагмент, см. раздел 3.8.2.1.


11.3.2.3. Отключение библиотеки

Если какая-либо из библиотек фрагментов больше не требуется, вызовите из контекстного меню одноименной вкладки команду Закрыть. Библиотека будет отключена от системы КОМПАС-3D.


11.3.2.4. Сервисные функции

При работе с библиотекой фрагментов доступны сервисные функции, вызываемые командами контекстного меню вкладки. Эти команды представлены в таблице 11.3.3.

Табл. 11.3.3. Сервисные функции библиотеки

Команда

Описание

Оптимизировать

Оптимизация библиотеки.

При удалении фрагментов из библиотеки размер ее файла на диске не меняется. Место в файле, на котором хранился удаленный фрагмент, остается свободным. При последующем создании фрагмента в этой библиотеке он записывается на свободное место в файле библиотеки. Если свободного места нет, размер библиотеки увеличивается.

Случается, что файл библиотеки, содержащей небольшое количество фрагментов, имеет значительный размер.

Команда Оптимизировать служит для приведения размера файла в соответствие с количеством хранящихся в нем фрагментов. После вызова команды из файла библиотеки исключаются свободные участки1.

При значительном размере файла библиотеки выполнение команды может занять несколько минут.

Втянуть
внешние ссылки

Копирование в библиотеку всех объектов, существующих в ней в виде ссылок на файлы:

– типов атрибутов из библиотек типов атрибутов,

– стилей линий, штриховок, текстов из соответствующих библиотек,

– фрагментов, вставленных внешней ссылкой.

Перечень ссылок можно просмотреть в диалоге информации о документе2 на вкладке Внешние ссылки во время редактирования библиотечного документа.

Связь с библиотеками и файлами-источниками фрагментов после выполнения команды Втянуть внешние ссылки не сохраняется. Втянутые ссылки исчезают из списка внешних ссылок в диалоге информации о документе.

Ссылки на библиотеки оформлений (они присутствуют в документе, если в нем есть объекты спецификации), а также ссылки модели на ее компоненты втянуть невозможно. Эти ссылки остаются в документах, т.е. после вызова команды Втянуть внешние ссылки они по-прежнему отображаются в диалоге информации о документе. Для корректной работы с библиотечными документами, ссылающимися на внешние файлы, необходимо наличие этих файлов по путям, указанным в диалоге информации о документе.

Сохранить
фрагмент
в файл как...

Сохранение фрагмента библиотеки в отдельном файле на диске.

После вызова команды на экране появляется диалог, в котором требуется указать папку и имя файла для записи.

Сведения

Вывод на экран диалога информации о выбранном фрагменте.
  1. Оптимизацию библиотеки фрагментов можно сравнить с дефрагментацией жесткого диска, произведенной в пределах одного файла.
  2. Для вызова диалога информации служит команда Файл — Информация о документе...

Две последние команды доступны только в контекстном меню библиотечного фрагмента.


11.3.3. Прикладные библиотеки

11.3. Прикладные библиотеки и библиотеки документов

11.3.3. Прикладные библиотеки

Прикладная библиотека — это приложение, созданное для расширения стандартных возможностей КОМПАС-3D и работающее в его среде.

В прикладных библиотеках через языковые средства могут использоваться все возможности КОМПАС-3D, предоставляемые при интерактивной работе (создание и редактирование объектов, работа с моделью документа, открытие и сохранение чертежей и фрагментов и т.д.).

Прикладные библиотеки входят в комплект поставки системы КОМПАС-3D. Чтобы начать работу с библиотекой, следует подключить ее в окне Менеджера библиотек (см. раздел 11.3.1.3). Команды библиотеки могут быть вызваны стандартным образом (из меню, диалога, окна, панели) или нажатием кнопок инструментальной панели или пользовательской инструментальной панели (о создании пользовательской панели см. раздел 9.4.2.2).

Для работы с библиотеками Сервисные инструменты, Проверка документа и некоторыми другими не требуется отдельно оплачиваемая лицензия. Они находятся в разделе Прочие на вкладке Библиотеки КОМПАС окна Менеджера библиотек (см. раздел 11.3.1.1). Для быстрого подключения выбранной библиотеки можно щелкнуть мышью в поле рядом с ее названием, после чего в этом поле появляется красная «галочка» — признак того, что библиотека подключена.

В этом разделе:

11.3.3.1. Сервисные инструменты

11.3.3.2. Проверка графических документов (Проверка документа)


11.3.3.1. Сервисные инструменты

Приложение Сервисные инструменты содержит команды для выполнения различных операций в графических документах, эскизах и спецификациях. Сходные по назначению команды объединены в разделы.

Описание команд представлено в таблице 11.3.4.

Табл. 11.3.4. Описание команд библиотеки Сервисные инструменты

Раздел

Описание

Операции
со спецификацией

Команды этого раздела позволяют выполнять следующие действия со спецификацией:

– преобразование во фрагмент (файлы *.frw), в таблицу баз данных (файлы *.dbf) или MS Excel (файлы *.xls); в результате создается новый файл — фрагмент или таблица, в который помещаются данные из спецификации;

– обработка числовых колонок — присвоение переменных значениям в колонках и связывание их уравнениями для выполнения арифметических действий над ними; вычисленные значения заносятся в ячейки спецификации.

Отверстия и обозначения резьбы

Раздел содержит команды, позволяющие создавать изображения резьб или глухих и сквозных, гладких и резьбовых отверстий следующих типов:

– Простое,

– Коническое,

– С зенковкой,

– С цековкой,

– С зенковкой и цековкой.

Отверстия и резьбы можно строить на основе образца — уже существующего в документе отверстия или резьбы. Отверстия также можно строить, используя ранее созданный файл-шаблон.

Отверстия и резьбы могут связываться с кривой — в этом случае после изменения кривой их можно перестроить, т.е. восстановить их положение на кривой.

Выравнивание объектов

Раздел содержит команды, позволяющие выровнять по заданной точке края или центры габаритных прямоугольников указанных объектов (или групп объектов), либо совместить центры этих прямоугольников.

Поворот объектов

Команды этого раздела позволяют выполнять над объектом (или группой объектов) следующие действия:

– поворачивать на 180о или на 90о влево/вправо вокруг центра габаритного прямоугольника объекта или группы;

– отражать относительно прямой, проходящей вертикально или горизонтально через центр габаритного прямоугольника объекта или группы.

Инструменты

Команды этого раздела позволяют выполнять следующие действия:

– преобразовывать заливки в штриховки и наоборот,

– аппроксимировать контуры или кривые,

– вставлять в документ готовые фигуры, знаки, обозначения из библиотеки фрагментов,

– заменять один фрагмент текста другим,

– выявлять размеры, номинальное значение которых было введено вручную, а не установлено автоматически,

– формировать ассоциативные связи между размерами и объектами, к которым они проставлены,

– выравнивать геометрические объекты, продолжая их до пересечения друг с другом или усекая в точке пересечения,

– строить объекты, подобные указанному (т.е. эквидистанты),

– рассчитывать массо-центровочные характеристики профиля,

–

– отключать показ выделенных объектов путем переноса их на погашенный слой.

Операции с контурами

В разделе содержатся команды, позволяющие выполнять следующие действия:

– строить замкнутый контур по пересекающимся кривым;

– строить замкнутый контур путем объединения, вычитания или пересечения двух указанных контуров;

– выявлять в документе разомкнутые контуры.


11.3.3.2. Проверка графических документов (Проверка документа)

Приложение Проверка документа позволяет выявлять в документах системы КОМПАС-3D (чертежах, фрагментах и эскизах) возможные ошибки:

– перекрывающиеся или наложенные друг на друга отрезки, окружности, дуги;

– обозначения позиций, не имеющие связей с объектами спецификации;

– размерные линии линейного размера, пересекающие другие линии чертежа;

– расстояния между размерными линиями, нанесенными параллельно, меньшие заданной величины.

После вызова команды библиотеки следует задать условия проверки. В результате работы команды обнаруженные ошибки могут быть автоматически исправлены.


11.3.4. Библиотека эскизов

11.3. Прикладные библиотеки и библиотеки документов

11.3.4. Библиотека эскизов

Одна из возможностей автоматизации трехмерного моделирования — создание пользовательских библиотек эскизов. Например, можно сформировать библиотеку параметрических эскизов, содержащих контуры шпоночных пазов, а затем использовать их при создании моделей валов.

В этом случае не потребуется многократное создание одинаковых эскизов. В каждом новом эскизе можно будет использовать однажды построенное и сохраненное в библиотеке изображение, в том числе параметрическое.

Пользовательская библиотека эскизов — это обычная библиотека фрагментов КОМПАС-3D (файл с расширением lfr).

Она создается точно так же, как любая другая библиотека фрагментов (см. раздел 11.3.2.1).

Если фрагменты в библиотеке создаются с целью использования их в качестве эскизов трехмерных элементов, они должны удовлетворять требованиям, предъявляемым к эскизам для конкретных операций.

Фрагменты, содержащие эскизы, могут быть параметрическими.

В этом разделе:

11.3.4.1. Подключение библиотеки эскизов

11.3.4.2. Использование библиотеки эскизов

11.3.4.3. Пользовательская библиотека отверстий


11.3.4.1. Подключение библиотеки эскизов

Чтобы использовать созданную библиотеку фрагментов в качестве библиотеки эскизов, нужно указать путь к этой библиотеке в диалоге, вызываемом командой Сервис — Параметры... — Cистема — Редактор моделей — Библиотеки конструкторских элементов. Описание диалога приведено в разделе 9.1.11.4.


11.3.4.2. Использование библиотеки эскизов

Если на выделенной плоскости или плоской грани требуется создать не новый, а использовать уже существующий в библиотеке эскиз, вызовите из контекстного меню команду Эскиз из библиотеки.

После этого на Панели свойств появится библиотека эскизов, имя которой было указано в диалоге настройки системы (рис. 11.3.3). Эскиз, выделенный в списке, показывается в окне просмотра на Панели свойств.

Рис. 11.3.3. Выбор эскиза на Панели свойств

Фантом выделенного в библиотеке эскиза отображается в окне модели. При этом начало координат библиотечного фрагмента совмещается с началом координат плоскости или грани, на которой размещается эскиз.

Вы можете изменить положение эскиза на плоскости (сместить или повернуть его). На Панели свойств находятся поля для ввода положения начала координат библиотечного эскиза в системе координат плоскости эскиза (т) и угла поворота эскиза (Угол).

После задания требуемого положения выбранного эскиза нажмите кнопку Создать объект. Графические объекты из библиотечного фрагмента будут скопированы в новый эскиз, и система вернется в режим работы с деталью.

Пиктограмма созданного эскиза появится в Дереве построения.

Вставленный из библиотеки эскиз теряет связь со своим источником. Порядок его дальнейшего редактирования не отличается от порядка редактирования других эскизов.


11.3.4.3. Пользовательская библиотека отверстий

Если в трехмерной модели создается круглое отверстие при помощи команды Отверстие из библиотеки (см. раздел 2.3.9.2), для его формирования используется эскиз профиля отверстия. Этот эскиз представляет собой фрагмент из библиотеки (см. раздел 11.3.2). По умолчанию полное имя библиотеки — ...\Program Files\ASCON\KOMPAS-3D V...\Sys\Holelib.lfr.

Вы можете создать собственную библиотеку фрагментов, в которой будут храниться эскизы круглых отверстий.

Эскизы, которые планируется использовать при выполнении команды Отверстие из библиотеки, должны удовлетворять следующим требованиям:

– Ось вращения должна быть изображена отрезком со стилем линии Осевая.

– Ось вращения должна быть одна.

– Ось вращения должна проходить вертикально через начало координат фрагмента.

– Точка вставки отверстия (точка пересечения его оси и плоскости, на которой оно базируется), должна совпадать с началом координат фрагмента.

– В эскизе может быть только один контур, изображенный стилем линии Основная.

– Этот контур должен лежать по одну сторону от оси вращения.

– Контур должен быть разомкнутым.

Для хранения эскизов профилей отверстий с разной топологией должны использоваться разные фрагменты.

Чтобы реализовать вставку отверстий с одинаковой топологией и разными параметрами, фрагмент можно сделать параметрическим.

Иногда для параметризации фрагмента требуется, чтобы в нем находилось изображение профиля отверстия по обе стороны от оси вращения. В этом случае примените к геометрическим объектам по одну сторону от оси стиль линии Тонкая, а по другую сторону — Основная.

Чтобы использовать созданную библиотеку фрагментов при выполнении команды Отверстие из библиотеки, нужно изменить настройку системы, указав путь к этой библиотеке (см. раздел 9.1.11.4).


11.3.5. Библиотека моделей

11.3. Прикладные библиотеки и библиотеки документов

11.3.5. Библиотека моделей

Часто в разных моделях используются компоненты, различающиеся только значениями своих параметров — типовые модели (обычно это несложные детали типа втулок, колец и т.п.).

Создавать и хранить на диске множество файлов типовых моделей, имеющих различные комбинации значений параметров, не обязательно. Вместо этого можно построить одну параметрическую модель и при вставке в другие модели изменять ее параметры. Такие параметрические модели рекомендуется хранить в библиотеках моделей.

Разные вставки модели из библиотеки могут иметь различные значения одних и тех же параметров. При этом модель-источник в библиотеке не изменяется.

Каждая библиотека моделей представляет собой отдельный файл с расширением *.l3d. Модели библиотеки не являются отдельными файлами на диске, а входят составными частями в единый файл библиотеки. Список моделей библиотеки может быть структурирован.

В библиотеки можно добавлять различные модели, упорядочивать их по определенному признаку, вводить произвольные комментарии к ним. При помощи библиотек вы можете производить многократные вставки моделей в другие модели. Использование библиотек упрощает поиск и вставку в модель готовых компонентов и заметно ускоряет создание сборочных моделей, содержащих типовые детали и подсборки.

Приемы работы в библиотеке моделей (создание библиотеки, разделов и моделей в ней) не отличаются от приемов работы с библиотекой фрагментов (см. раздел 11.3.2). При работе в библиотеке моделей вместо команд Добавить фрагмент в библиотеку..., Новый фрагмент используются команды Добавить модель в библиотеку..., Новая деталь/сборка соответственно.

В этом разделе:

11.3.5.1. Особенности библиотечных моделей

11.3.5.2. Вставка в модель библиотечного компонента


11.3.5.1. Особенности библиотечных моделей

Чтобы во время вставки из библиотеки и после нее модель можно было редактировать (изменять ее размеры и топологию), в ней должны существовать внешние переменные. (см. раздел 7.1.5.3).


11.3.5.2. Вставка в модель библиотечного компонента

Чтобы вставить компонент — деталь или сборку — из библиотеки в текущую модель, выполните следующие действия.

1. Выделите нужную модель в окне библиотеки и вызовите из контекстного меню команду Вставить модель или дважды щелкните мышью по модели в окне библиотеки.

В окне текущей модели появится фантом вставляемого компонента, а на Панели свойств — вкладки Размещение и Свойства.

2. На вкладке Размещение выполните следующие действия.

• Задайте параметры расположения компонента в модели. Данные действия выполняются для компонента из библиотеки так же, как для обычного компонента (см. раздел 2.11.2.5.2).

• Если компонент содержит внешние переменные, вы можете изменить их значения. В этом случае на Панели свойств присутствует панель Переменные. Она содержит перечень всех внешних переменных компонента. Значения внешних переменных показываются такими, какими они были в момент последнего сохранения модели в библиотеке.
Чтобы изменить значение переменной, дважды щелкните мышью в соответствующем ей поле Значение и задайте нужное значение вручную или с помощью счетчика. Переменная, значение которой изменено, отмечается значком «галочка». Щелчок мышью по этой «галочке» возвращает исходное значение переменной.

Значения переменных можно также изменить, используя таблицу переменных (см. ниже).

3. На вкладке Свойства настройте цвет и оптические свойства компонента (используемые для этого элементы управления описаны в разделе 2.14.2), включите/отключите создание объекта спецификации.

Если компонент содержит таблицу переменных, вы также можете выбрать новые значения внешних переменных с помощью данной таблицы. Для этого требуется нажать кнопку Таблица переменных, выбрать нужную строку в появившейся на экране таблице и нажать кнопку ОК. Внешние переменные вставляемой модели получат значения, записанные в ячейках выбранной строки.

Кнопка Таблица переменных доступна, если таблица переменных, имеющаяся в компоненте, содержит более одной строки. Таблица переменных формируется в файле модели при его создании или редактировании и хранится в нем. Подробно о таблице переменных рассказано в разделе 7.1.5.4.

В модели может быть несколько вставок одного и того же компонента с разными значениями одних и тех же переменных (а следовательно, с разными размерами и топологией).

4. Для завершения вставки в модель компонента из библиотеки нажмите кнопку Создать объект.

В Дереве построения появится пиктограмма компонента из пользовательской библиотеки моделей.

Если необходимо вставить этот же компонент еще раз, вызовите команду вставки из библиотеки повторно. Можно также воспользоваться способом копирования компонентов при помощи мыши (см. раздел 2.14.4.6).

Иногда после вставки библиотечный компонент помечается в Дереве построения как ошибочный. В этом случае компонент отображается только в Дереве, в окне модели он не виден.

Причина ошибки в библиотечном компоненте может заключаться в следующем:

– Ввод таких значений внешних переменных, при которых система уравнений, связывающих переменные компонента, не может быть решена.

– Присвоение одной или нескольким внешним переменным компонента значений, выходящих за пределы допустимого диапазона.

– Ошибка в модели компонента (т.е. компонент, вставленный из библиотеки, содержал ошибку еще на этапе создания этой библиотеки).

Если компонент имеет внешние переменные (т.е. если ошибка может быть вызвана первой или второй причинами), отредактируйте значения переменных этого компонента (см. раздел 2.14.3.3.1) или восстановите их.

Если после изменения значений переменных ошибка не исчезла (или если у компонента нет внешних переменных), эта ошибка вызвана третьей причиной, и для ее исправления необходимо редактирование модели в библиотеке. Чтобы отредактировать модель в библиотеке, подключите эту библиотеку, выделите ошибочную модель и вызовите из контекстного меню команду Редактировать. После редактирования сохраните модель, закройте ее окно и вставьте снова.


11.4. Использование технологии OLE

В этом разделе:

11.4.1. Общие сведения о технологии OLE

11.4.2. Работа со вставками

11.4.2.1. Вставка КОМПАС-документа

11.4.2.2. Редактирование вставленного КОМПАС-документа

11.4.2.3. Обновление связи с файлом-источником

11.4.2.4. Удаление вставленного КОМПАС-документа


11.4.1. Общие сведения о технологии OLE

11.4. Использование технологии OLE

11.4.1. Общие сведения о технологии OLE

Технология OLE (Object Linking and Embedding — связывание и внедрение объектов) является одним из наиболее мощных средств Windows, обеспечивающих совместную работу различных приложений и обмен информацией между ними.

Используя OLE, пользователь может вставлять в документ, созданный в одном приложении Windows, объекты других приложений. Например, можно вставить чертеж или фрагмент, разработанный с помощью системы КОМПАС-3D, в текстовый документ Microsoft Word. В дальнейшем вставленный объект (документ) можно отредактировать, причем для редактирования будут использоваться команды «родного» для данного объекта приложения (то есть для редактирования вставленного в Word чертежа или фрагмента будет активизироваться КОМПАС-3D).

Вставлять в другие документы можно только файлы КОМПАС-документов целиком. Вставка отдельных объектов системы КОМПАС-3D через буфер обмена (Clipboard) не поддерживается (КОМПАС-3D использует свой собственный буфер обмена, отличающийся от стандартного Clipboard).

Можно выполнить вставку таким образом, чтобы была сохранена связь с файлом-источником и выполнялось автоматическое обновление вставки при внесении изменений в файл-источник.

В дальнейшем при описании применения механизмов OLE в качестве примера будет использоваться взаимодействие программ КОМПАС-3D и Microsoft Word. Взаимодействие с другими приложениями Windows выглядит аналогично, а отличия могут наблюдаться только в конкретном оформлении команд и диалогов этих приложений.


11.4.2. Работа со вставками

11.4. Использование технологии OLE

11.4.2. Работа со вставками

При создании OLE-вставок может использоваться один из двух графических форматов: EMF или BMP. О выборе формата см. раздел 9.1.2.9.

Отображение OLE-вставки подчиняется настройке фильтров вывода на печать, т.е. в документе, содержащем вставку, видны только те объекты файла-источника, печать которых включена. О настройке фильтров вывода см. раздел 9.1.5.2.

Если используется формат EMF, то во вставке графического документа могут не отображаться заливки цветом. Смените используемый формат (см. раздел 9.1.2.9) и повторите вставку.

В этом разделе:

11.4.2.1. Вставка КОМПАС-документа

11.4.2.2. Редактирование вставленного КОМПАС-документа

11.4.2.3. Обновление связи с файлом-источником

11.4.2.4. Удаление вставленного КОМПАС-документа


11.4.2.1. Вставка КОМПАС-документа

Для вставки КОМПАС-документа из существующего файла в документ Word выполните следующие действия.

1. Вызовите в Word команду Вставка — Объект....

2. В появившемся на экране диалоге активизируйте вкладку Создание из файла. Если требуется, чтобы внедренный КОМПАС-документ отображался в документе Word как пиктограмма, включите опцию В виде значка.

3. Если требуется, чтобы вставленный КОМПАС-документ сохранял связь с файлом-источником, включите опцию Связь с файлом. Впоследствии любое изменение файла-источника будет отражаться в документе, куда была выполнена вставка.

4. Введите в поле Имя файла полное имя вставляемого файла. Можно также нажать кнопку Обзор и указать нужную папку и файл документа.

5. Нажмите кнопку ОК в диалоге Вставка объекта.

Содержимое выбранного файла будет вставлено в документ Word.

OLE-вставка КОМПАС-документа, состоящего из нескольких листов (текстового документа, спецификации или многолистового чертежа), содержит только первый лист документа.

Будьте внимательны при переименовании или переносе файлов, которые являются источниками связанных вставок, так как может произойти разрыв связей с ними.


11.4.2.2. Редактирование вставленного КОМПАС-документа

Чтобы отредактировать вставленный КОМПАС-документ, выполните следующие действия.

1. Щелкните правой кнопкой мыши на вставленном КОМПАС-документе.

2. Выберите в появившемся меню команду Объект <тип КОМПАС-документа>....

На экране появится подменю, содержащее команды Редактировать, Открыть и Преобразовать. Чтобы внести изменения во вставленный документ, вызовите команду Редактировать или команду Открыть.

После этого производится загрузка КОМПАС-3D либо в отдельном окне, либо в окне Word: его меню и панели заменяются меню и панелями КОМПАС-3D. Вариант загрузки КОМПАС-3D зависит от версии Word, а для некоторых его версий — от того, имеет ли вставленный документ связь с файлом-источником.

3. Внесите в документ необходимые изменения.

Если вы работали в документе Word, щелкните в любом его месте, не занятом вставленным документом.

Если вы работали в системе КОМПАС-3D, сохраните документ и закройте сеанс.

В окне Word будет отображаться отредактированный КОМПАС-документ.

Не рекомендуется изменять перетаскиванием размер габаритной рамки вставленного КОМПАС-документа во время обычной работы в Word. Это может привести к искажению изображения вставленного документа.


11.4.2.3. Обновление связи с файлом-источником

Чтобы принудительно обновить связь между вставкой КОМПАС-документа и файлом-источником, щелкните правой кнопкой мыши на вставленном КОМПАС-документе и выберите из контекстного меню команду Обновить связь.

Чтобы выполнить различные действия над связями с файлами-источниками (установка типа обновления, изменение источника, обновление или разрыв связи), используйте диалог, вызываемой командой Правка — Связи из меню Word.


11.4.2.4. Удаление вставленного КОМПАС-документа

Чтобы удалить ранее вставленный КОМПАС-документ, выполните следующие действия.

1. Щелкните на вставленном КОМПАС-документе. Он будет выделен габаритной рамкой.

2. Нажмите клавишу <Delete> или выберите в меню Word команду Правка — Удалить.


11.5. Атрибуты

В этом разделе:

11.5.1. Общие сведения об атрибутах

11.5.2. Создание типов атрибутов

11.5.2.1. Создание атрибута табличного типа

11.5.2.1.1. Выбор прототипа

11.5.2.1.2. Описание структуры

11.5.2.2. Создание библиотеки типов атрибутов

11.5.2.3. Управление типами атрибутов

11.5.3. Использование атрибутов

11.5.3.1. Присвоение атрибутов объектам и документам

11.5.3.1.1. Атрибут одного графического объекта

11.5.3.1.2. Атрибут нескольких графических объектов

11.5.3.1.3. Атрибут документа

11.5.3.2. Копирование атрибутов между объектами

11.5.3.3. Копирование атрибутов вместе с объектами

11.5.3.4. Операции с атрибутами объектов

11.5.3.5. Поиск объектов с использованием атрибутов

11.5.3.5.1. Атрибуты численного типа

11.5.3.5.2. Атрибуты строчного типа

11.5.3.5.3. Атрибуты табличного типа


11.5.1. Общие сведения об атрибутах

11.5. Атрибуты

11.5.1. Общие сведения об атрибутах

Атрибут — это дополнительная неграфическая информация, связанная с объектом или несколькими объектами чертежа, самим чертежом, спецификацией, фрагментом или фрагментом в библиотеке фрагментов.

Атрибуты могут использоваться для поиска объектов, а также обрабатываться различными приложениями (например, Модулем проектирования спецификаций, расчетными программами и т.п.).

В атрибутах могут храниться разнородные сведения, относящиеся к объекту (изображению или документу). В зависимости от характера информации ее удобнее представлять тем или иным образом, то есть использовать ту или иную структуру атрибута.

В КОМПАС-3D атрибут может иметь одну из четырех структур:

– число,

– строка текста,

– таблица с фиксированным количеством строк,

– таблица с произвольным количеством строк.

Одну и ту же структуру можно использовать для представления различных сведений, то есть разные атрибуты могут иметь сходную структуру.

Например, один и тот же объект может иметь несколько атрибутов-таблиц, отличающихся числом колонок и строк, несколько атрибутов-строк текста, содержащих различные сведения об этом объекте.

Информация о структуре того или иного атрибута (а для табличных атрибутов также информация о параметрах таблицы и содержимом ячеек), содержится в типе атрибута. Каждый тип атрибута имеет имя. Типы атрибутов могут создаваться пользователем и храниться внутри документа (в этом случае они доступны только при работе с этим документом) или во внешних файлах *.lat — библиотеках типов атрибутов (в этом случае они доступны при работе с любым документом).

Общий порядок назначения (присвоения) атрибута чертежному объекту или документу следующий:

1. Указание типа атрибута

2. Ввод значения атрибута

Значение атрибута — информация, которая хранится в атрибуте, присвоенном объекту. Значения одного и того же атрибута, присвоенного разным объектам, могут быть различными.

Таким образом, можно сказать, что атрибуты — это классы (или разделы) сведений об объектах, а значения атрибутов — сами сведения, относящиеся к тому или иному классу (или разделу). Для разных объектов эти сведения могут быть одинаковыми или различаться благодаря тому, что описания атрибутов (типы атрибутов) хранятся отдельно от самих атрибутов объектов (значений атрибутов).


11.5.2. Создание типов атрибутов

11.5. Атрибуты

11.5.2. Создание типов атрибутов

Порядок действий при создании нового типа атрибута следующий.

1. Вызовите команду Сервис — Библиотеки стилей, типов, оформлений и основных надписей — Типы атрибутов....

На экране появится диалог работы с типами атрибутов (рис. 11.5.1).

Рис. 11.5.1. Диалог работы с типами атрибутов

Диалог имеет два окна просмотра списков типов атрибутов. Активным может быть только одно окно просмотра. Например, на рис. 11.5.1 активным является правое окно. Активизация производится щелчком мыши в окне.

– Чтобы создать новый тип атрибута в текущем документе, активизируйте окно просмотра, озаглавленное Локальные типы документа. Если в обоих окнах отображаются библиотечные типы атрибутов (заголовки окон содержат пути к файлам библиотек), нажмите кнопку Документ. В активном окне появится список типов атрибутов текущего документа.

– Чтобы создать новый тип атрибута в какой-либо библиотеке, нажмите кнопку Библиотека. В появившемся на экране диалоге укажите нужный файл *.lat и нажмите кнопку Открыть 1 . В активном окне просмотра появится список типов атрибутов выбранной библиотеки. Выделите раздел библиотеки, в который требуется добавить тип атрибута.

2. Нажмите кнопку Новый тип.

На экране появится диалог создания типа атрибута (рис. 11.5.2).

Рис. 11.5.2. Диалог создания типа атрибута

3. Введите имя создаваемого типа атрибута.

4. Включите опцию, соответствующую структуре создаваемого типа атрибута.

5. Нажмите кнопку ОК диалога.

Создание строкового или числового атрибута на этом заканчивается — в диалоге работы с типами атрибутов появляется пиктограмма, соответствующая структуре созданного типа атрибута, и его имя.

Создание атрибута табличного типа имеет некоторые особенности. Они описаны в разделе 11.5.2.1.

  1. Вы можете также создать собственную библиотеку для хранения типов атрибутов (см. раздел 11.5.2.2).

В этом разделе:

11.5.2.1. Создание атрибута табличного типа

11.5.2.1.1. Выбор прототипа

11.5.2.1.2. Описание структуры

11.5.2.2. Создание библиотеки типов атрибутов

11.5.2.3. Управление типами атрибутов


11.5.2.1. Создание атрибута табличного типа

Если атрибут является таблицей, то в типе атрибута хранится количество столбцов таблицы, а для каждого столбца — заголовок, тип данных, диапазон значений данных (если он назначен) либо список разрешенных значений. Таблица атрибута организована таким образом, что в каждом ее столбце все ячейки содержат данные одного типа и имеют одинаковые ограничения на диапазон значений. Таким образом, таблица атрибута всегда имеет регулярную структуру.

В этом разделе:

11.5.2.1.1. Выбор прототипа

11.5.2.1.2. Описание структуры


11.5.2.1.1. Выбор прототипа

После включения опции Таблица фиксированной длины или Таблица переменной длины в диалоге создания типа атрибута в нем появляется кнопка Назначить прототип. После ее нажатия в нижней части диалога появляется группа кнопок Прототип, а в правой части — окно выбора прототипа (рис. 11.5.3).

Описание кнопок группы Прототип представлено в таблице 11.5.1.

Рис. 11.5.3. Выбор прототипа табличного атрибута

Табл. 11.5.1. Кнопки группы Прототип
Кнопка | Позволяет
Документ | Отобразить в окне выбора прототипа типы атрибутов, хранящиеся в текущем документе (локальные типы атрибутов документа).
Библиотеки... | Отобразить в окне выбора прототипа типы атрибутов, хранящиеся во внешнем файле библиотеки типов атрибутов *.lat.
Просмотр | Просмотреть тип атрибута, выделенный в окне выбора прототипа.
Назначить | Выбрать выделенный тип атрибута в качестве прототипа для создаваемого.


11.5.2.1.2. Описание структуры

После подтверждения создания табличного атрибута (закрытия диалога создания атрибута кнопкой ОК) на экране появляется диалог описания структуры табличного атрибута (рис. 11.5.4).

В нижней части диалога отображается таблица, с помощью которой создается описание структуры. Каждая строка содержит сведения о способе формирования колонки в табличном атрибуте. Та строка, в которой находится курсор, является активной.

Элементы управления диалога описания структуры табличного атрибута представлены в таблице 11.5.2.

Рис. 11.5.4. Диалог описания структуры табличного атрибута

Табл. 11.5.2. Диалог описания структуры табличного атрибута

Имя

Описание

Название

Поле, в котором можно отредактировать название создаваемого типа атрибута.

Уникальный номер типа

Справочное поле, содержащее уникальный номер, который система автоматически присваивает создаваемому типу атрибута. Вновь созданный тип атрибута не имеет номера. Вы можете увидеть его при последующем просмотре или редактировании сформированного атрибута.

Таблица

Установите с помощью переключателей тип табличного атрибута (таблица фиксированной или переменной длины). В случае таблицы фиксированной длины введите нужное значение в поле Число строк.

Номер

Автоматически присваиваемый номер колонки.

Название колонки

Поле для ввода названия (заголовка) колонки атрибута.

Тип колонки

Поле для выбора типа данных в колонке. Чтобы вызвать диалог изменения типа данных, щелкните в поле левой кнопкой мыши, а затем нажмите появившуюся кнопку Сменить тип. Диалог выбора типа данных в колонке описан в следующем разделе.

Диапазон значений

Поле для задания диапазона значений, допустимых для данных в колонке. Чтобы изменить диапазон значений, щелкните в поле левой кнопкой мыши, а затем нажмите появившуюся кнопку.

Для целых и действительных чисел необходимо указать максимальное и минимальное значения, для строки текста — максимальную длину в символах1.

Если тип данных в колонке — запись, то щелчок на кнопке в поле Диапазон значений вызывает диалог формирования структуры записи. Подробно о создании записи рассказано на Формирование структуры записи.

Значение по умолчанию

Поле для ввода умолчательного значения в колонке атрибута.

Добавить

Кнопка, позволяющая добавить в атрибут новую колонку. После ее нажатия в диалоге описания структуры атрибута появляется новая строка, расположенная под строкой, которая была активна в момент нажатия кнопки.

Удалить

Кнопка, позволяющая удалить колонку из атрибута. После ее нажатия из диалога описания структуры атрибута удаляется строка, которая была активна в момент нажатия кнопки.

Переместить

Кнопка, позволяющая переместить колонку. После ее нажатия укажите новое положение активной строки.

Пароль

Кнопка, позволяющая установить пароль доступа к структуре атрибута (например, для защиты от несанкционированного редактирования структуры).

Ключи

Кнопка, позволяющая задать ключи атрибута. Они используются для сортировки объектов по атрибутам.
  1. Максимально возможный диапазон для целых чисел: от -2147483647 до 2147483647.
    Максимально возможный диапазон для вещественных чисел: от -1.7e+307 до 1.7e+307.
    Максимально возможная длина строки: 4000 символов.

Завершив описание структуры, нажмите кнопку ОК диалога. В диалоге работы с типами атрибутов появится пиктограмма созданного табличного атрибута и его название.

Выбор типа данных

Диалог выбора типа данных в колонке показан на рис. 11.5.5.

Элементы управления этого диалога представлены в таблице 11.5.3.

Рис. 11.5.5. Диалог выбора типа данных

Табл. 11.5.3. Диалог выбора типа данных
Элемент | Описание
Целый, Действительный, Строка, Запись | Варианты типов данных в колонке атрибута. О типе данных запись подробно рассказано на Формирование структуры записи.
Ключ поля | Поле для ввода ключевого значения для данной колонки. Допускаются целые числа не более 9999.
Заполнение из списка | Опция, позволяющая сформировать список значений для ячеек настраиваемой колонки. Впоследствии, когда атрибут данного типа будет присвоен объекту, ввод значений в эту колонку будет возможен только путем выбора из списка (о формировании списка рассказано в следующем разделе). Если выбран тип данных запись, то эта опция не доступна.
Соответствует в языке С | Справка о том, какому типу данных в языке С соответствует выбранный тип данных в колонке (эта информация может потребоваться при разработке прикладных библиотек КОМПАС).

Формирование списков значений для заполнения ячеек

Если для колонки установлено заполнение ячеек значениями из списка, необходимо создать сам список.

Для этого щелкните левой кнопкой мыши в поле Диапазон значений, а затем нажмите появившуюся кнопку Показать список (рис. 11.5.6).

Рис. 11.5.6. Вызов диалога ввода значений

На экране появится диалог ввода значений списка (рис. 11.5.7).

Введите в нижнее поле диалога значение, которое должно содержаться в списке, и нажмите кнопку Добавить. Это значение будет добавлено в список — перемещено в верхнее поле. Нижнее поле очистится. Повторяя описанные действия, сформируйте список.

Чтобы удалить значение, выделите его и нажмите кнопку Удалить.

Рис. 11.5.7. Диалог ввода значений списка

Формирование структуры записи

Запись представляет собой строку другой таблицы, на которую ссылается данная ячейка.

Чтобы сформировать эту таблицу, щелкните левой кнопкой мыши в поле Диапазон значений, а затем нажмите появившуюся кнопку Показать запись (рис. 11.5.8).

Рис. 11.5.8. Вызов диалога формирования структуры записи

На экране появится диалог формирования структуры записи (рис. 11.5.9).

Формирование структуры записи практически аналогично формированию структуры табличного атрибута. Отличие состоит в невозможности создания записи, т.е. уровень вложенности записей может быть только один.

Рис. 11.5.9. Диалог формирования структуры записи


11.5.2.2. Создание библиотеки типов атрибутов

Чтобы создать новую библиотеку *.lat, нажмите кнопку Библиотека в диалоге работы с библиотеками (рис. 11.5.1). В появившемся диалоге выбора файлов введите несуществующее имя, нажмите кнопку Открыть и подтвердите создание файла. Активное окно диалога работы с типами атрибутов очистится, так как вновь созданная библиотека пуста.

Если вы планируете хранить в библиотеке большое количество типов атрибутов, рекомендуется разбить их на тематические группы — разделы; впоследствии это облегчит поиск нужного типа. Чтобы создать раздел, нажмите кнопку Новый раздел и введите в появившемся диалоге имя раздела. Сформируйте структуру библиотеки, добавляя в нее разделы.

Затем создайте типы атрибутов в разделах библиотеки, как это описано выше.

Разделы, подразделы и типы атрибутов в них автоматически сортируются по алфавиту.


11.5.2.3. Управление типами атрибутов

Работа с типами атрибутов ведется в специальном диалоге, вызываемом командой Сервис — Библиотеки стилей, типов, оформлений и основных надписей — Типы атрибутов... (рис. 11.5.1).

Назначение кнопок Документ, Библиотека, Новый тип и Новый раздел описано в предыдущих разделах. Остальные кнопки представлены в таблице 11.5.4.

Табл. 11.5.4. Кнопки диалога работы с типами атрибутов
Имя | Описание
Просмотреть | Позволяет просмотреть характеристики выделенного типа атрибута.
Редактировать | Позволяет отредактировать характеристики выделенного типа атрибута или название выделенного раздела библиотеки.
Удалить | Позволяет удалить выделенный тип атрибута или выделенный раздел библиотеки (вместе с содержащимися в нем типами атрибутов). Внимание! Восстановление удаленного типа атрибута или раздела библиотеки невозможно.
Копировать | Позволяет скопировать выделенный тип атрибута или выделенный раздел библиотеки1. После нажатия этой кнопки выбранный тип атрибута или раздел появляется также в соседнем окне просмотра2.
Перенести | Позволяет перенести выделенный тип атрибута или выделенный раздел библиотеки1. После нажатия этой кнопки выбранный тип атрибута или раздел удаляется со своего прежнего места и переносится в соседнее окно просмотра2.
  1. Копирование и перемещение разделов возможно только между библиотеками. Из библиотеки в документ можно скопировать только отдельные типы атрибутов.
  2. При копировании и перемещении разделов и атрибутов между библиотеками вставка производится в выделенный раздел библиотеки, открытой в соседнем окне.

Таким образом, диалог работы с типами атрибутов позволяет просматривать, редактировать, удалять типы атрибутов, хранящиеся как в текущем документе, так и вне его — в библиотеках типов атрибутов. С помощью этого диалога можно редактировать структуру библиотек, а также копировать и перемещать типы атрибутов между библиотеками и документами.

При редактировании табличных типов атрибутов необходимо иметь в виду следующее:

1. При внесении существенных изменений в описание структуры данных (перенос, удаление или добавление столбцов таблицы, изменение типа данных в столбце, изменение диапазона значений столбца, изменение таблицы с фиксированным числом строк на таблицу с переменным числом строк и т.п.), система автоматически удаляет старый атрибут и создает вместо него новый.

2. При изменении параметров табличного типа атрибута, не влияющих на структуру данных (название типа, заголовки столбцов таблицы, списки разрешенных значений в ячейках), тип атрибута не удаляется.

Удаление числового и строкового типов атрибутов никак не влияет на атрибуты, использующие эти типы. Удаление же (вручную или в результате редактирования структуры) табличного типа атрибута приводит к невозможности редактирования атрибутов, использующих этот тип.


11.5.3. Использование атрибутов

11.5. Атрибуты

11.5.3. Использование атрибутов

В этом разделе:

11.5.3.1. Присвоение атрибутов объектам и документам

11.5.3.1.1. Атрибут одного графического объекта

11.5.3.1.2. Атрибут нескольких графических объектов

11.5.3.1.3. Атрибут документа

11.5.3.2. Копирование атрибутов между объектами

11.5.3.3. Копирование атрибутов вместе с объектами

11.5.3.4. Операции с атрибутами объектов

11.5.3.5. Поиск объектов с использованием атрибутов

11.5.3.5.1. Атрибуты численного типа

11.5.3.5.2. Атрибуты строчного типа

11.5.3.5.3. Атрибуты табличного типа


11.5.3.1. Присвоение атрибутов объектам и документам

Присвоение атрибута объекту — связывание объекта (изображения или документа) с атрибутом того или иного типа и ввод значения атрибута.

В этом разделе:

11.5.3.1.1. Атрибут одного графического объекта

11.5.3.1.2. Атрибут нескольких графических объектов

11.5.3.1.3. Атрибут документа


11.5.3.1.1. Атрибут одного графического объекта

Чтобы присвоить атрибут графическому объекту (изображению), выполните следующие действия.

1. Выделите объекты, которым нужно назначить атрибут (о выделении объектов см. раздел 3.1.2).

2. Вызовите команду Сервис — Атрибуты... На экране появится диалог работы с атрибутами объекта (рис. 11.5.10).

Если у выделенного объекта еще нет ни одного атрибута, то список имеющихся атрибутов пуст.

Рис. 11.5.10. Диалог работы с атрибутами объекта

3. Нажмите кнопку Новый... для вызова диалога выбора типа атрибута (рис. 11.5.11).

4. Откройте нужный список типов атрибутов с помощью кнопок Документ или Библиотеки....

Если в списке отсутствует требуемый тип атрибута, вы можете создать его. Для этого нажмите кнопку Новый.... На экране появится диалог создания типа атрибута (рис. 11.5.2). Порядок создания типов атрибутов описан в разделе 11.5.2. Вновь созданный тип атрибута появится в списке типов.

5. Выделите нужный тип атрибута в списке и нажмите кнопку Выбрать.

На экране появится диалог ввода значения атрибута.

6. Введите значение, соответствующее типу атрибута (число или строку текста), или заполните таблицу.

Рис. 11.5.11. Диалог выбора типа атрибута

Вы можете защитить значение атрибута паролем от несанкционированного изменения. Для этого нажмите кнопку Пароль. В появившемся диалоге введите любую комбинацию символов.

В списке атрибутов объекта появится пиктограмма, соответствующая структуре выбранного типа атрибута, и его название.

7. Для завершения диалога работы с атрибутами объекта нажмите кнопку Выход.


11.5.3.1.2. Атрибут нескольких графических объектов

Атрибут можно присвоить не только одиночному объекту, но и нескольким объектам одновременно. В этом случае формируется так называемый групповой атрибут. Групповой атрибут может быть присвоен только графическим объектам, назначить один и тот же атрибут сразу нескольким документам невозможно.

Чтобы присвоить групповой атрибут, выделите нужные объекты и выполните те же действия, что и при назначении атрибута отдельному объекту — одиночного атрибута (см. раздел 11.5.3.1.1). На рис. 11.5.12 показан диалог работы с атрибутами объекта, имеющего как одиночные (собственные) атрибуты, так и групповые (общие с несколькими другими объектами).

Обратите внимание на то, что групповые атрибуты содержатся в отдельной папке с изображением знака суммы — S.

Если перед вызовом этого диалога были выделены все объекты, которым присвоены одни и те же групповые атрибуты, то на содержащей их папке знак суммы не отображается.

Рис. 11.5.12. Атрибуты объекта: одиночные и групповые

Операции с групповыми атрибутами имеют следующие особенности.

1. При редактировании значения группового атрибута оно изменяется для всех объектов группы.

2. Перенос группового атрибута в буфер выполняется по приведенному выше правилу удаления.

3. Групповой атрибут удаляется только после того, как он удален в последнем объекте из группы, либо если он удаляется при выделении всех объектов группы.

При попытке удалить или отредактировать значение группового атрибута на экране появится предупреждающее сообщение.

4. Если был выделен один объект, и вы перенесли имевшийся у него групповой атрибут в буфер, а затем извлекли из буфера, то этот атрибут будет сохранен как собственный атрибут объекта.


11.5.3.1.3. Атрибут документа

Присвоение атрибута документу практически аналогично присвоению атрибута графическому объекту.

Чтобы присвоить атрибут активному документу, выполните следующие действия.

1. Вызовите команду Файл — Информация о документе….

2. В появившемся диалоге информации о документе активизируйте вкладку Атрибуты (рис. 11.5.13).

3. Нажмите кнопку Новый....

4. Откройте нужный список типов атрибутов с помощью кнопок Документ или Библиотеки....

5. Выделите нужный тип атрибута в списке и нажмите кнопку Выбрать.

На экране появится диалог задания значения атрибута.

6. Введите значение, соответствующее типу атрибута (число или строку текста), или заполните таблицу.

Рис. 11.5.13. Диалог информации о документе. Вкладка Атрибуты


11.5.3.2. Копирование атрибутов между объектами

Если нужно присвоить объекту атрибут, тип которого совпадает с типом атрибута, уже имеющимся у другого объекта, можно не создавать этот тип атрибута заново, а скопировать аналог.

Вы можете копировать атрибуты между объектами одного и того же документа, а также между объектами разных документов, открытых в одном окне системы КОМПАС-3D. Копирование атрибутов между документами, открытыми в разных окнах системы, невозможно.

Для копирования атрибутов между объектами в КОМПАС-3D используется специальный буфер (отличающийся от стандартного буфера обмена Windows). Значение скопированного атрибута можно впоследствии отредактировать.

Копирование атрибутов между объектами чертежа выполняется в следующем порядке.

1. Выделите объект, у которого имеется нужный для копирования атрибут.

2. Вызовите команду Сервис — Атрибуты.... На экране появится диалог работы с атрибутами (рис. 11.5.10).

3. Выделите в списке название атрибута, который требуется скопировать, и нажмите кнопку Копия в буфер. Если нажать кнопку Перенос в буфер, то атрибут будет скопирован в буфер и затем удален из объекта-источника.

В буфере может одновременно находиться только один атрибут. Копирование или перенос туда следующего атрибута приводит к удалению предыдущего.

4. Закройте диалог работы с атрибутами.

5. Выделите объект, в который нужно скопировать атрибут.

6. Вызовите команду Сервис — Атрибуты....

7. В появившемся диалоге нажмите кнопку Взять из буфера.

Атрибут, находящийся в буфере, будет присвоен выделенному объекту.

При необходимости отредактируйте значение скопированного атрибута.

Возможно также копирование атрибутов между документами. Оно производится с помощью кнопок Копия в буфер, Перенос в буфер и Взять из буфера на вкладке Атрибуты диалога информации о документе (рис. 11.5.13).


11.5.3.3. Копирование атрибутов вместе с объектами

Графические объекты копируются вместе с атрибутами. Например, при перетаскивании объекта мышью при нажатой клавише <Ctrl> у объектов-копий автоматически создаются атрибуты, повторяющие атрибуты исходного объекта.

Вы можете управлять копированием атрибутов при вставке объекта из буфера обмена или выполнении команд симметрии, масштабирования, сдвига, поворота, а также операций копирования указанием, по кривой, по сетке и т.п.

Для этого служит группа переключателей Копирование атрибутов на вкладке Атрибуты Панели свойств команды.

При активном переключателе Не копировать объект копируется без атрибутов.

Если требуется создать копию с такими же атрибутами, как у оригинала, активизируйте переключатель Копировать.

Если в команде предусмотрена возможность удаления или оставления исходного объекта, то атрибуты копируются при выбранном варианте Оставлять исходные объекты в группе Режим на Панели свойств.

Если ни один из объектов, выбранных для копирования, не имеет атрибутов, переключатели Копирование атрибутов недоступны.


11.5.3.4. Операции с атрибутами объектов

Операции с атрибутами геометрических объектов производятся в диалоге (рис. 11.5.10), вызываемом командой Сервис — Атрибуты....

Операции с атрибутами документов производятся на вкладке Атрибуты диалога информации о документе (рис. 11.5.13), вызываемом командой Файл — Информация о документе….

Назначение кнопок Новый…, Копия в буфер, Перенос в буфер и Взять из буфера описано в предыдущих разделах. Остальные кнопки представлены в таблице 11.5.5.

Табл. 11.5.5. Кнопки диалога работы с атрибутами

Имя

Описание

Редактировать

Позволяет отредактировать значение атрибута, выделенного в списке. После нажатия кнопки на экране появляется диалог ввода значения атрибута — такой же, как и при назначении атрибута объекту (рис. 11.5.7).

Если при назначении атрибута был введен пароль доступа, то после нажатия кнопки Редактировать будет запрошен пароль. Диалог ввода значения атрибута в этом случае появляется только после правильного ввода пароля.

Просмотреть

Позволяет просмотреть значение атрибута, выделенного в списке. После нажатия кнопки на экране появляется диалог просмотра значения атрибута.

Для просмотра значения атрибута можно также дважды щелкнуть мышью на его названии в списке.

Удалить

Позволяет удалить выделенный в списке атрибут. После нажатия кнопки на экране появляется запрос на подтверждение удаления.

Отмена удаления атрибута невозможна. Чтобы вернуть удаленный атрибут в список, его необходимо присвоить объекту заново.

При вставке в документ фрагмента с диска (см. раздел 3.8.2.1) или из библиотеки (см. раздел 11.3.2.2) в этот же документ передаются и атрибуты вставленного документа, если они имелись.

Вы можете просмотреть их в обычном порядке. В диалоге работы с атрибутами они отображаются на «ветке» Атрибуты документа (рис. 11.5.14). Обратите внимание на то, что редактирование атрибута документа недоступно.

Рис. 11.5.14. Просмотр атрибутов вставленного фрагмента


11.5.3.5. Поиск объектов с использованием атрибутов

Одна из основных целей применения атрибутов в чертежах и фрагментах — это хранение различной информации, связанной с объектами, и быстрый поиск с ее использованием. Вы можете быстро выделить все объекты, имеющие указанный тип атрибута или его значение (например, можно выделить на плане цеха все изображения станков одной модели).

Для поиска и выделения объектов по типу или значению атрибутов выполните следующие действия.

1. Вызовите команду Выделить — По атрибутам…. На экране появится диалог назначения условий поиска (рис. 11.5.15).

В верхнем поле диалога отображается список всех типов атрибутов, используемых в документе, в том числе атрибуты вставок фрагментов.

Рис. 11.5.15. Диалог назначения условий поиска

2. Чтобы использовать тип атрибута при поиске, выберите его в списке и нажмите кнопку со стрелкой вниз. Выбранные для поиска типы атрибутов показываются в нижнем поле.

Чтобы отменить использование типа при поиске, выделите его в нижнем списке и нажмите кнопку со стрелкой вверх.

Вы можете назначить условие поиска — указать определенное значение атрибута. В этом случае будут выделены не все объекты, имеющие атрибут указанного типа, а только те из них, значения атрибутов которых удовлетворяют заданному условию.

Чтобы назначить условие поиска, нажмите кнопку Редактировать условие. На экране появится диалог ввода условий поиска. Набор элементов управления этого диалога зависят от типа атрибута (строка, число или таблица); работа с ними описана в разделах 11.5.3.5.1, 11.5.3.5.2 и 11.5.3.5.3 соответственно.

Если потребуется удалить условие поиска по значению атрибута, выделите в нижнем списке название типа атрибута, для которого было задано условие, и нажмите кнопку Очистить условие.

Задав необходимые условия, нажмите кнопку OK для начала поиска.

Все объекты, которым присвоен хотя бы один из указанных атрибутов (если условие не задано) или хотя бы один из указанных атрибутов, значение которого удовлетворяет заданному условию, будут выделены. С ними можно выполнять различные операции (копирование, перемещение и т.д.).

В этом разделе:

11.5.3.5.1. Атрибуты численного типа

11.5.3.5.2. Атрибуты строчного типа

11.5.3.5.3. Атрибуты табличного типа


11.5.3.5.1. Атрибуты численного типа

Диалог ввода условий поиска для атрибутов численного типа (рис. 11.5.16) позволяет задать условия поиска по значениям для атрибутов, имеющих целочисленный или действительный тип (а также условие поиска по значениям в целочисленных или действительных колонках табличных атрибутов).

Рис. 11.5.16. Диалог ввода условий поиска для атрибутов численного типа

В верхней части диалога отображается название типа атрибута, для которого задаются условия, или заголовок колонки табличного атрибута, для которой задаются условия.

Задание условий производится в следующем порядке.

1. Введите значение для формирования условия в поле Значение.

2. Укажите нужное условие выбора в списке Отношение.

3. Нажмите кнопку Добавить в список для фиксации условия — переноса его в список условий поиска, расположенный в левой части диалога.

4. Сформируйте нужное количество условий.

Чтобы исключить какое-либо условие из списка, выделите его и нажмите кнопку Удалить из списка.

5. Укажите, какая логическая операция — и или или — должна быть произведена над условиями, включив нужную опцию.


11.5.3.5.2. Атрибуты строчного типа

Диалог ввода условий поиска для атрибутов строчного типа (рис. 11.5.17) позволяет задать условия поиска по значениям для атрибутов, имеющих строчный (а также условие поиска по значениям в строковых колонках табличных атрибутов).

Рис. 11.5.17. Диалог ввода условий поиска для атрибутов строчного типа

В верхней части диалога отображается название типа атрибута, для которого задаются условия, или заголовок колонки табличного атрибута, для которой задаются условия.

Задание условий производится в следующем порядке.

1. Введите подстроку для формирования условия в поле Текст подстроки для выбора.

2. Нажмите кнопку Добавить в список для фиксации условия — переноса его в список подстрок для выбора, расположенный в верхней части диалога.

3. Сформируйте нужное количество условий.

4. Чтобы исключить какую-либо подстроку из списка, выделите ее и нажмите кнопку Удалить из списка.

5. Укажите, какая логическая операция — и или или — должна быть произведена над условиями, включив нужную опцию.

Если при поиске необходимо различать регистр символов, включите опцию Учитывать регистр символов.


11.5.3.5.3. Атрибуты табличного типа

Диалог ввода условий поиска для атрибутов табличного типа позволяет задать условия поиска по значениям в колонках атрибутов табличного типа.

Все поля и опции этого диалога, а также колонки таблицы, кроме колонки Условие выбора, являются справочными — редактирование их невозможно.

Чтобы задать условие поиска по какой-либо колонке атрибута, щелкните в нужной ячейке колонки Условие выбора, а затем нажмите появившуюся кнопку Показать условие.

В зависимости от типа значений в выбранной колонке на экране появится диалог ввода условий поиска для атрибутов строчного или числового типа. Работа с ними описана в разделах 11.5.3.5.1 и 11.5.3.5.2

Если тип данных в колонке запись, то для задания условий поиска нужно щелкнуть мышью в колонке Диапазон значений, а затем нажать кнопку Показать запись. На экране появится диалог структуры записи. Для задания условий поиска по тому или иному полю записи служат ячейки колонки Условие выбора.


Термины и определения

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

А Б В Г Д Е Ж З И К Л М Н О П Р С Т У Ф Х Ц Ч Ш Щ Э Ю Я

A

B

C

CALS

D

DXF

DWG

E

F

G

GDI

H

I

IGES

J

K

L

M

N

O

OpenGL

P

Q

R

S

SHX-шрифт

STEP AP203

T

U

V

W

EMF

X

Y

Z

А

Абсолютная система координат

Активное окно

Активный вид (слой)

Ассоциативная штриховка (заливка)

Ассоциативность (ассоциативная связь)

Ассоциативный вид

Ассоциативный отчет

Атрибут

Б

Базовая грань сгиба

Базовая точка трехмерного объекта

В

Величина сгиба

Вершина

Вес точки

Вид-владелец

Вид-источник

Вид чертежа

Видимый вид (слой)

Вложенные разделы спецификации

Внешний объект спецификации в сборке

Внешняя переменная модели

Внешняя переменная фрагмента

Внутренний объект спецификации в сборке

Выделение объектов

Г

Габаритный параллелепипед

Геометрический калькулятор

Геометрический массив

Главная центральная система координат

Главное окно КОМПАС-3D

Главный раздел списка переменных

Главная ось инерции

Гладкая цепочка кривых

Грань

Группа

Группа свойств слоев

Группа слоев

Д

Дерево документа

Дерево зон

Дерево исполнений

Дерево построения модели

Дерево чертежа

Деталь

Динамический поиск

Документ-владелец

Дополнительные разделы спецификации

Е

Ж

З

Задание на печать

Зазор

Замыкаемый угол

Запись

Запрет редактирования объекта

Зона

И

Иерархия защищенных типов загрузки

Инструментальная панель

Информационная переменная

Исполнение модели

Источник вставки

К

Коллекция

Компактная панель

Компонент

Компоновочная геометрия

Контекстная панель

Контекстное меню

Контрольная точка

Контур

Конфигурация устройства печати

Копия геометрических объектов

Коэффициент нейтрального слоя

Кривая NURBS

Кривая Безье

Л

Линия очерка

Линия построения вершины

Линия сгиба

Листовое тело

Локальная система координат (ЛСК)

Локальный фрагмент

М

Макроэлемент

Многолистовой чертеж

Н

Надпись вида

Название спецификации

Нормаль грани (плоскости, поверхности)

Направление сгиба

Направление сдвига

Неподвижная сторона

О

Область применения операции

Обозначение центра

Обход по стрелке

Объект спецификации

Объект таблицы изменений

Объекты-«двойники»

Окно подготовки данных

Операция

Описание спецификации

Опорный вид

Освобождение сгиба

Освобождение угла

Осевая линия

Основание уклона

Открытое ребро

Оформление документов

Оформление листа

Отчет

П

Параметр развертки сгиба

Параметрический режим

Переменная параметра операции

Переменная размера

Пластина

Плоский участок подсечки

Поверхность

Погашенный вид (слой)

Подраздел спецификации

Подчиненный режим

Пользовательская переменная

Полюс грани

Порядок NURBS

Привязка

Прикладная библиотека

Примитив

Присоединительная точка

Продолжение сгиба

Проекционное обозначение

Простое и составное обозначение документа

Профиль

Профиль штамповки

Пустая строка

Р

Рабочая область главного окна приложения

Размеры операции

Расширенная панель команд

Ребро

Резервная строка

С

Сборка

Свойство документа

Связная совокупность граней

Связная совокупность кривых

Сгиб

Серия стандартов ISO 10303 STEP

Сетка

Сетчатая прозрачность

Синхронизация

Система PDM

Система координат объекта

Системное меню

Системный вид

Слой

Смежные сгибы

Смещение сгиба

Сопряжение

Сопряжение механической связи

Сопряжение позиционирующее

Спецификация

Ссылка

Ссылка на переменную

Стартовая страница

Стиль

Стиль отчета

Стиль спецификации

Строка сообщений

Т

Таблица изменений

Таблица сгибов

Таблица переменных

Таблица изменяемых переменных

Текстово-графический документ

Текстовые шаблоны

Текущий вид (слой)

Текущий лист

Текущий стиль спецификации

Тело

Теоретическая поверхность

Технологическая сборка

Типы загрузки компонента

Тип загрузки сборки

У

Указание объектов

Уклоняемые грани

Уменьшение сгиба

Ф

Файлы конфигурации

Фантом

Фильтр слоев

Фоновый вид (слой)

Фрагмент

Х

Характерная точка

Ц

Центральная система координат

Ч

Чертеж

Ш

Шаблон документа

Шаблон заполнения

Шаг курсора

Щ

Э

Элемент модели

Эскиз

Ю

Я


Приложение I. Обозначения в Дереве документа

Табл. 1. Разделы Дерева документа
Раздел |  | Типы объектов, содержащиеся в разделе
Системы координат |  | Абсолютная и локальные системы координат
Компоновочная геометрия |  | Компоновочная геометрия. Может включать объекты тех же типов, что и раздел Компоненты, кроме стандартных изделий и библиотечных компонентов.
Компоненты1 |  |
Типы компонентов
 | Подсборка
 | Зеркальное исполнение подсборки |
 | Деталь
 | Зеркальное исполнение детали |
 | Локальная деталь
 | Зеркальное исполнение локальной детали |
 | Деталь-заготовка
 | Деталь-заготовка без истории
 | Стандартное изделие
 | Библиотечный компонент
Ветви одинаковых компонентов
 | Подсборки
 | Детали
 | Локальные детали или детали-заготовки без истории
 | Библиотечные компоненты
 | Стандартные изделия
Группы однотипных компонентов
 | Группа подсборок | Каждая группа может содержать как одиночные компоненты, так и ветви одинаковых компонентов. Стандартные изделия включаются в группу библиотечных компонентов.
 | Группа деталей
 | Группа локальных деталей
 | Группа библиотечных компонентов
Поверхности |  | Поверхности
 | Поверхность | Операции, участвующие в создании поверхности
Тела |  | Тела
 | Тело | Операции, участвующие в создании тела. После того как части тела будут соединены или целостность тела будет восстановлена, пиктограмма тела из частей или тела с нарушенной целостностью заменяется обычной пиктограммой тела
 | Тело из частей
 | Тело с нарушенной целостностью
Сопряжения |  | Сопряжения
Вспомогательная геометрия |  | Вспомогательные оси, вспомогательные плоскости, контрольные точки, присоединительные точки
Элементы оформления |  | Элементы оформления
Кривые и точки |  | Точки, группы точек, массивы точек, пространственные кривые, массивы пространственных кривых
Эскизы |  | Эскизы
Измерения |  | Измерения
Макроэлементы трехмерные |  | Трехмерные макроэлементы
Исключенные из расчета2 |  | Элементы тел, исключенные из расчета
Вставки видов |  | Вставки изображений из видов других чертежей
Вставки фрагментов |  | Вставки фрагментов
Макроэлементы графические |  | Графические макроэлементы
  1. при редактировании компонента «на месте» его пиктограмма выделяется цветом (из синей становится желтой)
  2. только при наличии исключенных элементов

Разделы Системы координат, Компоновочная геометрия и Сопряжения присутствуют в Дереве построения при отображении в нем как последовательности построения, так и структуры модели. Остальные разделы, а также ветви одинаковых компонентов и группы однотипных компонентов могут присутствовать в Дереве только при отображении структуры.

Табл. 2. Дополнительные обозначения в Дереве документа

Название

Описание

(т)

– В документе-модели — признак текущей системы координат в Дереве построения; признак текущего исполнения в Дереве исполнений.

– В чертеже — признак текущего вида.

(ф)

– В документе-модели — признак того, что компонент зафиксирован.

– В чертеже — признак фонового вида.

(п)

– В документе-модели — признак того, что компонент имеет не номинальные размеры, а пересчитанные с учетом допуска.

– В чертеже — признак погашенного вида.

(+)/(-)

– Перед названием компонента знак (+) — признак того, что компонент полностью определен позиционирующими сопряжениями, а знак (–) — не полностью определен.

– Перед названием эскиза знак (+) — признак того, что эскиз полностью определен параметрическими ограничениями в нем, а знак (–) — не полностью определен.

– Перед названием корневого объекта, раздела компонентов, его группы или ветви знак (+) — признак того, что все входящие компоненты зафиксированы и/или полностью определены, а знак (–) — в остальных случаях.

(!)

– Признак того, что эскиз переопределен параметрическими связями и ограничениями в нем.

Тело из частей

– На пиктограмме модели (в том числе модели компонента) — признак того, что модель содержит тела, состоящие из частей.

– На пиктограмме операции — признак того, что в результате операции образовалось тело из частей или изменилось исходное количество частей; количество частей можно изменить, вызвав команду контекстного меню Изменить набор частей.

Ошибка

Признак ошибки. Причину ошибки можно узнать, вызвав команду контекстного меню Что не верно?

Зависимость от ЛСК

Признак того, что положение и/или ориентация объекта заданы относительно локальной системы координат.

Исключено из расчета

Признак того, что объект исключен из расчета.

Входит в макроэлемент

Признак того, что объект включен в состав трехмерного макроэлемента.

Развернутый сгиб

Признак того, что листовой элемент, содержащий сгибы, находится в разогнутом состоянии.

Упрощенный

Признак того, что к компоненту, разделу, группе, ветви одинаковых компонентов применен Упрощенный тип загрузки.

Пустой

Признак того, что к компоненту, разделу, группе, ветви одинаковых компонентов применен Пустой тип загрузки.

Габарит

Признак того, что к компоненту, разделу, группе, ветви одинаковых компонентов применен тип загрузки Габарит.

Только чтение

Признак того, что файл компонента имеет атрибут «только чтение». Отображается, если это включено при установке прав доступа (см. раздел 9.1.4.2).

Замок

Признак того, что объект заблокирован. Появляется в следующих случаях:

– на пиктограммах объектов, расположенных под Указателем окончания построения,

– на пиктограмме объекта, редактируемого в данный момент, и всех объектов, расположенных ниже него,

– на пиктограмме сопряжения, если к одному или обоим его объектам применен Пустой тип загрузки,

– на пиктограмме операций, массивов компонентов и сопряжений, если хотя бы один из их исходных компонентов получил запрет на редактирование,

– на пиктограмме объекта, входящего в состав другого объекта, редактирование которого запрещено,

– на пиктограммах объектов зависимого исполнения, связанных с объектами исходного исполнения.

Необходимо перестроение

Признак того, что требуется перестроение модели или ассоциативного чертежа.

Щит синий

Признак того, что редактирование объекта запрещено, но запрет можно снять при помощи команды контекстного меню Редактирование — Разрешено или Редактирование — По слою.

Щит серый

Признак того, что редактирование компонента запрещено, но снять запрет нельзя (так как компонент получил его в результате применения к сборке пользовательского типа загрузки с паролем).

«Неразрезаемый» компонент

Признак того, что компонент показан не разрезанным в ассоциативном виде, содержащем разрез или сечение модели.


Приложение II. Системные клавиши-ускорители

Табл. 1. Общесистемные действия
Сочетание клавиш | Описание
<Enter>, <Пробел> | Зафиксировать (ввести) точку. В графическом документе — запустить редактирование выделенного объекта (курсор не должен находиться над ним).
<Ctrl>+<Enter> | Создать объект (завершить операцию).
<Esc> | Прервать выполнение команды, закрыть страницу меню или диалог, отменить выделение объектов.
<Delete> | Удалить все выделенные объекты.
<Ctrl>+<Z>, <Alt>+<BackSpace> | Отменить удаление объектов, разрушение вида.
<Ctrl>+<+>/<-> | Увеличить/уменьшить масштаб отображения в текущем окне относительно центра окна.
<Shift>+<+>/<-> | Увеличить/уменьшить масштаб отображения в текущем окне относительно курсора.
<F1> | Вызвать справочную систему КОМПАС-3D (контекстную справку).
<Shift>+<F1> | Вызвать команду Что это такое?.
<Ctrl>+<F4>, <Ctrl>+<W> | Закрыть активное окно документа.
<Alt>+<F4> | Завершить работу с КОМПАС-3D.

Табл. 2. Управление курсором при вводе и редактировании текста в таблице
Сочетание клавиш | Описание
Управление курсором при вводе и редактировании текста в таблице
<Tab> | Перейти в следующую ячейку.
<Shift>+<Tab> | Перейти в предыдущую ячейку.
<Ctrl>+<←> | Переместить курсор на одно слово влево внутри ячейки, а затем — перейти в предыдущую ячейку.
<Ctrl>+<→> | Переместить курсор на одно слово вправо внутри ячейки, а затем — перейти в следующую ячейку.

Табл. 3. Управление курсором при вводе и редактировании текста
Сочетание клавиш | Описание
<←> | Переместить курсор на одну позицию влево.
<→> | Переместить курсор на одну позицию вправо.
<↓> | Переместить курсор на одну строку вниз.
<↑> | Переместить курсор на одну строку вверх.
<Page Up> | Переместить курсор в верхнюю строку текущего окна.
<Page Down> | Переместить курсор в нижнюю строку текущего окна.
<Home> | Переместить курсор в начало строки.
<End> | Переместить курсор в конец строки.
<Ctrl>+<←> | Переместить курсор на одно слово влево. Для таблицы производится перемещение внутри ячейки, а затем — переход в предыдущую ячейку.
<Ctrl>+<→> | Переместить курсор на одно слово вправо. Для таблицы производится перемещение внутри ячейки, а затем — переход в следующую ячейку.
<Ctrl>+<↑> | Переместить курсор в начало текущего абзаца; если курсор находился в начале абзаца, то — в начало предыдущего абзаца.
<Ctrl>+<↓> | Переместить курсор в начало следующего абзаца. Из начальной позиции последнего абзаца курсор перемещается в конец этого абзаца.
<Ctrl>+<Home> | Переместить курсор в начало первого абзаца документа или редактируемого текста на чертеже.
<Ctrl>+<End> | Переместить курсор в конец последнего абзаца документа или редактируемого текста на чертеже.
<Tab> | Переместить вправо на заданную величину табуляции.
<Enter> | Начать следующий абзац.
<Ctrl>+<Enter> | Начать следующий абзац на новой странице (т.е. вставить принудительный разрыв страницы).
<Shift>+<Enter> | Начать новую строку в текущем абзаце (т.е. вставить принудительный разрыв строки).

Табл. 4. Специальные действия при вводе и редактировании текста
Сочетание клавиш | Описание
<Delete> | Удалить один символ справа от курсора (правая часть строки при этом сдвигается влево). Если курсор находится перед маркером конца абзаца, то нажатие клавиши <Delete> приведет к слиянию двух абзацев.
<Ctrl>+<Delete> | Удалить одно слово справа от курсора (правая часть строки при этом сдвигается влево).
<Backspace> | Удалить один символ слева от курсора (правая часть строки при этом сдвигается влево). При удалении самого левого в строке символа курсор переходит в последнюю позицию предыдущей строки.
<Ctrl>+<Backspace> | Удалить одно слово слева от курсора (правая часть строки при этом сдвигается влево).
<Ctrl>+<Shift>+<Space> | Вставить неразрывный пробел.
<Ctrl>+<Shift>+<-> | Вставить неразрывный дефис.
<Insert> | Переключиться между режимами вставки и замены. В режиме вставки символ вставляется в позицию курсора, раздвигая остальные символы. В режиме замены вводимые символы заменяют символы справа от курсора. Когда включен режим замены, курсор отображается утолщенным для индикации этого режима.
<Ctrl>+<Пробел> | Привести параметры текста к стилевым.
<Ctrl>+<Shift>+<←> | Выделить одно слово слева от курсора.
<Ctrl>+<Shift>+<→> | Выделить одно слово справа от курсора.
<Shift>+<←> | Выделить один символ слева от курсора.
<Shift>+<→> | Выделить один символ справа от курсора.
<Shift>+<↑> | Выделить одну строку слева от курсора.
<Shift>+<↓> | Выделить одну строку справа от курсора.
<Ctrl>+<Shift>+<R> | Перевести выделенные символы в кириллические.
<Ctrl>+<Shift>+<L> | Перевести выделенные символы в латинские.
<Ctrl>+<Shift>+<D> | Перевести выделенные символы в нижний регистр.
<Ctrl>+<Shift>+<U> | Перевести выделенные символы в верхний регистр.
<Ctrl>+<F7> | Выполнить проверку правописания во всех текстовых объектах документа или во всем текстовом объекте, редактируемом в данный момент.

Табл. 5. Управление окнами
Сочетание клавиш | Описание
<Ctrl>+<F6>, <Ctrl>+<Tab> | Перейти к следующему окну.
<Ctrl>+<Shift>+<F6>, <Ctrl>+<Shift>+<Tab> | Перейти к предыдущему окну.

Табл. 6. Управление отображением в окне
Сочетание клавиш | Описание
<Ctrl>+<G> | Включить/выключить отрисовку сетки в активном окне.
<Ctrl>+<F9> | Обновить изображение в активном окне.
<PageUp> | Пролистать изображение на один экран вверх.
<PageDn> | Пролистать изображение на один экран вниз.
<Home> | Пролистать изображение до верхней границы документа.
<End> | Пролистать изображение до нижней границы документа.
<Ctrl>+<PageUp> | Пролистать изображение на один экран влево.
<Ctrl>+<PageDn> | Пролистать изображение на один экран вправо.
<Ctrl>+<Home> | Пролистать изображение до левой границы документа.
<Ctrl>+<End> | Пролистать изображение до правой границы документа.

Табл. 7. Управление положением курсора и привязка (Используются клавиши на дополнительной цифровой клавиатуре; режим NumLоck должен быть включен (горит индикатор NumLоck).)
Сочетание клавиш | Описание
<Ctrl>+<0> | Переместить курсор в точку (0,0) текущей системы координат.
<Ctrl>+<Shift>+<5> | Установить курсор в ближайшую к нему характерную точку элемента с учетом фоновых видов и слоев.
<Ctrl>+<5> | Установить курсор в ближайшую к нему характерную точку элемента без учета фоновых видов и слоев. Данная комбинация клавиш доступна также при отключенном режиме NumLоck. В этом случае она позволяет установить курсор в ближайшую к нему характерную точку элемента с учетом фоновых видов и слоев.
<Ctrl>+<.> | Установить курсор по нормали в ближайшую точку ближайшего элемента.
<Alt>+<5> | Установить курсор в ближайшую к нему точку пересечения двух объектов.
<Shift>+<5> | Установить курсор в ближайшую к нему середину объекта.
<Ctrl>+<1> | Привязка к ближайшему элементу по диагонали между отрицательным направлением оси ОХ и отрицательным направлением оси ОY текущей системы координат.
<Ctrl>+<2>, <Ctrl>+<↓> | Привязка к ближайшему элементу против направления оси OY текущей системы координат.
<Ctrl>+<3> | Привязка к ближайшему элементу по диагонали между положительным направлением оси ОХ и отрицательным направлением оси ОY текущей системы координат.
<Ctrl>+<4>, <Ctrl>+<←> | Привязка к ближайшему элементу против направления оси OХ текущей системы координат.
<Ctrl>+<6>, <Ctrl>+<→> | Привязка к ближайшему элементу по направлению оси OХ текущей системы координат.
<Ctrl>+<7> | Привязка к ближайшему элементу по диагонали между отрицательным направлением оси ОХ и положительным направлением оси ОY текущей системы координат.
<Ctrl>+<8>, <Ctrl>+<↑> | Привязка к ближайшему элементу по направлению оси OY текущей системы координат.
<Ctrl>+<9> | Привязка к ближайшему элементу по диагонали между положительным направлением оси ОХ и положительным направлением оси ОY текущей системы координат.

Табл. 8. Пошаговое перемещение курсора (Используются клавиши на дополнительной цифровой клавиатуре; режим NumLоck должен быть включен (горит индикатор NumLоck).)
Сочетание клавиш | Описание
<Ctrl>+<Alt>+<1> | Сдвинуть курсор на шаг вдоль отрицательного направления OX и отрицательного направления OY текущей системы координат (СК).
<Ctrl>+<Alt>+<2> | Сдвинуть курсор на шаг вдоль отрицательного направления OY СК.
<Ctrl>+<Alt>+<3> | Сдвинуть курсор на шаг вдоль положительного направления OX и отрицательного направления OY СК.
<Ctrl>+<Alt>+<4> | Сдвинуть курсор на шаг вдоль отрицательного направления OX СК.
<Ctrl>+<Alt>+<6> | Сдвинуть курсор на шаг вдоль положительного направления OX СК.
<Ctrl>+<Alt>+<7> | Сдвинуть курсор на шаг вдоль отрицательного направления OX и положительного направления OY СК.
<Ctrl>+<Alt>+<8> | Сдвинуть курсор на шаг вдоль положительного направления OY СК.
<Ctrl>+<Alt>+<9> | Сдвинуть курсор на шаг вдоль положительного направления OX и положительного направления OY СК.
Если режим NumLоck отключен (индикатор NumLоck не горит), то возможно перемещение в следующих направлениях:
<Ctrl>+<Alt>+<2> | Сдвинуть курсор на шаг вдоль отрицательного направления OY СК.
<Ctrl>+<Alt>+<4> | Сдвинуть курсор на шаг вдоль отрицательного направления OX СК.
<Ctrl>+<Alt>+<6> | Сдвинуть курсор на шаг вдоль положительного направления OX СК.
<Ctrl>+<Alt>+<8> | Сдвинуть курсор на шаг вдоль положительного направления OY СК.
Кроме того, если не вызвана ни одна команда, то при отключенном режиме NumLоck курсор можно перемещать клавишами <2>, <4>, <6>, <8> и клавишами со стрелками.

Табл. 9. Работа с Панелью свойств и в диалогах
Сочетание клавиш | Описание
<Tab> | Перейти от одного элемента управления к другому в прямом направлении.
<Shift>+<Tab> | Перейти от одного элемента управления к другому в обратном направлении.
<↑>, <↓> | Перебирать значения в списке (в том числе в списке со счетчиком). Перебирать опции или варианты внутри группы.
<→>, <←> | Перебирать переключатели в группе переключателей на Панели свойств. Перебирать опции или варианты внутри группы.
<Пробел> | Активизировать переключатель Панели свойств, на котором находится фокус. Включить/выключить опцию или нажать кнопку, на которой находится фокус. (Фокус — выделение элемента управления. Отображается в виде пунктирной рамки вокруг элемента.)

Табл. 10. Поворот модели
Сочетание клавиш | Описание
<Ctrl> + <Shift> + <↑> | Повернуть вверх в вертикальной плоскости, перпендикулярной плоскости экрана.
<Ctrl> + <Shift> + <↓> | Повернуть вниз в вертикальной плоскости, перпендикулярной плоскости экрана.
<Ctrl> + <Shift> + <→> | Повернуть вправо в горизонтальной плоскости.
<Ctrl> + <Shift> + <←> | Повернуть влево в горизонтальной плоскости.
<Alt> + <→> | Повернуть против часовой стрелки в плоскости экрана.
<Alt> + <←> | Повернуть по часовой стрелке в плоскости экрана.
<Пробел> + <↑> | Повернуть на 90° вверх в вертикальной плоскости, перпендикулярной плоскости экрана.
<Пробел> + <↓> | Повернуть на 90° вниз в вертикальной плоскости, перпендикулярной плоскости экрана.
<Пробел> + <→> | Повернуть на 90° вправо в горизонтальной плоскости.
<Пробел> + <←> | Повернуть на 90° влево в горизонтальной плоскости.
<Alt> + <↑> | Повернуть на 90° по часовой стрелке в плоскости экрана.
<Alt> + <↓> | Повернуть на 90° против часовой стрелки в плоскости экрана.

Табл. 11. Специальные действия в режиме предварительного просмотра перед печатью
Сочетание клавиш | Описание
<Y> | Вызвать диалог настройки параметров вывода
<Z> | Повернуть выделенные листы против часовой стрелки.
<X> | Повернуть выделенные листы по часовой стрелке.
<E> | Включить/отключить режим указания выводимых областей листов.
<D> | Выделить листы рамкой (слева направо — охватывающей, справа налево — секущей).
<F> | Вызов диалога подгонки масштаба листов.
<C> | Вызов команды Сомкнуть и выровнять листы.
<H> | Вызов команды Разместить листы в узлах страниц.
<G> | Вызов команды Найти перекрывающиеся листы.
<Ctrl> + <F> | Вызов диалога установки фильтров вывода на печать.
<Delete> | Удалить выделенный лист из предварительного просмотра.

Табл. 12. Разное

Сочетание клавиш

Описание

<Shift> + <указание модели>

Выделить весь компонент сборки, выделить всю деталь.

<Ctrl>+

<«удержание» левой кнопкой мыши выделенного элемента>

Копировать выделенный компонент сборки, копировать выделенный элемент чертежа (фрагмента).

<Ctrl> + <T>

Начать перебор объектов, расположенных «под курсором».

<Ctrl> + <D>

Запретить/разрешить глобальные привязки.

<F3>

Найти или заменить следующее вхождение заданного текста.

<F4>

Повторить последнюю вызванную команду.

<F5>

Перестроить.

<Ctrl> +<Alt> +<F5>

Перепроецировать (заново создать проекции модели/моделей в ассоциативных видах чертежа).

<F7>

Включить/выключить режим округления значений параметров.

<F8>

Включить/выключить режим ортогонального черчения.

<F9>

Показать документ полностью.

<F11>

Включить/выключить режим отображения имен переменных в размерах эскизов и операций.

<Аlt> + <F9>

Показать эскиз полностью.

<Аlt> + <X>

Активизировать поля текущих координат курсора на панели Текущее состояние.

<Ctrl> + <K>

Переключить внешний вид курсора (большой или маленький).

<Shift> + </>

Активизировать поле Текущий шаг курсора.

<Ctrl> + <A>

Выделить все объекты, которые содержатся в текущем фрагменте или в текущем виде активного чертежа.

<Shift> + <Enter>, <Пробел> + <Enter>, <Shift> + <щелчок левой кнопки мыши>

Открыть диалог редактирования надписи в составе выделенного размера или обозначения (курсор не должен находиться над выделенным объектом).

Обратите внимание на то, что сочетания <Пробел> + <Enter> и <Shift> + <щелчок левой кнопки мыши> работают только в графических документах.

<Ctrl> + <Shift> + <Enter>

Включить/отключить автосоздание объекта (вызов команды Автосоздание).

<Ctrl> + <Shift> + <Z>

Вызов команды Указать заново.

<Ctrl> + <Shift> + <P>

Вызов команды Запомнить состояние.

<Ctrl> + <Shift> + <С>

Вызов команды Копировать свойства.

<Ctrl> + <С>, <Ctrl> + <Ins>

Копировать выделенные объекты в буфер обмена.

<Ctrl> + <X>, <Shift> + <Delete>

Вырезать выделенные объекты в буфер обмена.

<Ctrl> + <V>, <Shift> + <Ins>

Вставить содержимое буфера обмена в документ.


Приложение III. Справочник формул

Справочник содержит формулы:

– тождественных преобразований:

• Свойства дробей, табл. 1,

• Формулы сокращенного умножения, табл. 2,

– тригонометрические формулы:

• Формулы сложения аргументов, табл. 3,

• Формулы кратных аргументов, табл. 4,

• Сложение тригонометрических функций, табл. 5,

• Произведение тригонометрических функций, табл. 6,

• Формулы понижения степени, табл. 7,

• Формулы косоугольных треугольников, табл. 8.

В колонке Формула представлен стандартный вид формул, а в колонке Синтаксис КОМПАС-3D — их запись в синтаксисе КОМПАС-3D. Текст из колонки Синтаксис КОМПАС-3D можно копировать через буфер обмена в Окно переменных и поля Панели свойств, например, при задании параметров кривой по закону.

Табл. 1. Свойства дробей
Формула | Синтаксис КОМПАС-3D
 | a/b | = | (a*m)/(b*m)
 | a/b | = | (a/m)/(b/m)
 | (a/b)/(c/d) | = | a/b*d/c
 |  | = | (a*d)/(b*c)
 | a/b*c/d | = | (a*c)/(b*d)
 | a/b+c/d | = | (a*d+b*c)/(b*d)
 | a/b-c/d | = | (a*d-b*c)/(b*d)
 | c/((n+a)*(n+b)) | = | (1/(n+a)-1/(n+b))*c/(b-a)

Табл. 2. Формулы сокращенного умножения
Формула | Синтаксис КОМПАС-3D
 | a^2-b^2 | = | (a-b)*(a+b)
 | (a+b)^2 | = | a^2+2*a*b+b^2
 | (a-b)^2 | = | a^2-2*a*b+b^2
 | a^3+b^3 | = | (a+b)*(a^2-a*b+b^2)
 | a^3-b^3 | = | (a-b)*(a^2+a*b+b^2)
 | (a+b)^3 | = | a^3+3*a^2*b+3*a*b^2+b^3
 | (a-b)^3 | = | a^3-3*a^2*b+3*a*b^2-b^3

Табл. 3. Формулы сложения аргументов
Формула | Синтаксис КОМПАС-3D
 | sin(a+b) | = | sin(a)*cos(b)+cos(a)*sin(b)
 | sin(a-b) | = | sin(a)*cos(b)-cos(a)*sin(b)
 | cos(a+b) | = | cos(a)*cos(b)-sin(a)*sin(b)
 | cos(a-b) | = | cos(a)*cos(b)+sin(a)*sin(b)
 | tan(a+b) | = | (tan(a)+tan(b))/(1-tan(a)*tan(b))
 | tan(a-b) | = | (tan(a)-tan(b))/(1+tan(a)*tan(b))

Табл. 4. Формулы кратных аргументов
Формула | Синтаксис КОМПАС-3D
 | sin(2*a) | = | 2*sin(a)*cos(a)
 | sin(2*a) | = | (2*tan(a))/(1+tan(a)^2)
 | cos(2*a) | = | cos(a)^2-sin(a)^2
 | cos(2*a) | = | 2*cos(a)^2-1
 | cos(2*a) | = | 1-2*sin(a)^2
 | tan(2*a) | = | (2*tan(a))/(1-tan(a)^2)
 | sin(3*a) | = | 3*sin(a)-4*sin(a)^3
 | cos(3*a) | = | 4*cos(a)^3-3*cos(a)
 | tan(3*a) | = | (3*tan(a)-tan(a)^3)/(1-3*tan(a)^2)

Табл. 5. Сложение тригонометрических функций
Формула | Синтаксис КОМПАС-3D
 | sin(a)+sin(b) | = | 2*sin((a+b)/2)*cos((a-b)/2)
 | sin(a)-sin(b) | = | 2*sin((a-b)/2)*cos((a+b)/2)
 | cos(a)+cos(b) | = | 2*cos((a+b)/2)*cos((a-b)/2)
 | cos(a)-cos(b) | = | -2*sin((a+b)/2)*sin((a-b)/2)
 | tan(a)+tan(b) | = | sin(a+b)/(cos(a)*cos(b))
 | tan(a)-tan(b) | = | sin(a-b)/(cos(a)*cos(b))

Табл. 6. Произведение тригонометрических функций
Формула | Синтаксис КОМПАС-3D
 | sin(a)*sin(b) | = | 1/2*(cos(a-b)-cos(a+b))
 | cos(a)*cos(b) | = | 1/2*(cos(a-b)+cos(a+b))
 | sin(a)*cos(b) | = | 1/2*(sin(a-b)+sin(a+b))

Табл. 7. Формулы понижения степени
Формула | Синтаксис КОМПАС-3D
 | cos(a)^2 | = | (1+cos(2*a))/2
 | sin(a)^2 | = | (1-cos(2*a))/2
 | cos(a)^3 | = | (3*cos(a)+cos(3*a))/4
 | sin(a)^3 | = | (3*sin(a)-sin(3*a))/4

Табл. 8. Формулы косоугольных треугольников
Формула | Синтаксис КОМПАС-3D
 | 2*R | = | L1/sin(a)
 |  | = | L2/sin(b)
 |  | = | L3/sin(c)
 | L3^2 | = | L1^2+L2^2-2*L1*L2*cos(c)
 | (L1-L2)/(L1+L2) | = | tan((a-b)/2)/tan((a+b)/2)
 | R | = | p/(4*cos(a/2)*cos(b/2)*cos(c/2))
 | r | = | 4*R*sin(a/2)*sin(b/2)*sin(c/2)
 | S | = | 1/2*L1*L2*sin(c)
 | S | = | 2*R^2*sin(a)*sin(b)*sin(c)


Приложение IV. Операторы, функции, константы

Табл. 1. Арифметические операторы
Обозначение | Описание
() | скобки операторные
+ | сложить, или унарный плюс
- | вычесть, или унарный минус
* | умножить
/ | разделить
% | разделить целочисленно (левоассоциативный1)
^ | возвести в степень (правоассоциативный2)
= | равно
  1. При равенстве приоритетов операторов результат выражения вычисляется слева направо, т.е. а%b%c = (а%b)%c.
  2. При равенстве приоритетов операторов результат выражения вычисляется справа налево, т.е. а^b^c = а^(b^c).

Табл. 2. Логические операторы
Обозначение | Описание
== | тождественно
!= | не тождественно
> | больше
< | меньше
>= | больше или равно
<= | меньше или равно
! | логическое отрицание
&& | логическое И
|| | логическое ИЛИ
?: | логическое выражение вида a ? b : c (если a — истина (не равно 0), то b, иначе c, где a, b и c могут быть выражениями)

Табл. 3. Функции
Обозначение | Описание
sin | синус с аргументом в радианах;
cos | косинус с аргументом в радианах
tan | тангенс с аргументом в радианах
atan | арктангенс с результатом в радианах
acos | арккосинус с результатом в радианах
asin | арксинус с результатом в радианах
sind | синус с аргументом в градусах
cosd | косинус с аргументом в градусах
tand | тангенс с аргументом в градусах
atand | арктангенс с результатом в градусах
acosd | арккосинус с результатом в градусах
asind | арксинус с результатом в градусах
deg | перевод из радиан в градусы
rad | перевод из градусов в радианы
sqrt | корень квадратный
exp | экспонента
ln | натуральный логарифм
lg | десятичный логарифм
abs | абсолютное значение
ceil | округление до большего целого числа
floor | округление до меньшего целого числа
round | округление до ближайшего целого числа

Табл. 4. Константы
Обозначение | Значение | Описание
M_FI | 1.6180339887499 | j — иррациональное число золотого сечения
M_E | 2.71828182845904523536 | е — основание натурального логарифма
M_PI | 3.14159265358979323846 | p — отношение длины окружности к диаметру
M_PI_2 | 1.57079632679489661923 | p/2
M_PI_4 | 0.785398163397448309616 | p/4
M_PI2 | 6.28318530717959 | 2p
M_SQRT2 | 1.41421356237309504880 | Корень квадратный из двух
M_RADDEG | 57.29577951308 | Коэффициент пересчета из радиан в градусы (180/p)
M_DEGRAD | 0.01745329251994 | Коэффициент пересчета из градусов в радианы (p/180)
FLT_EPS | 1.19209290E–07 | Разница между двумя числами, при которой эти числа считаются равными


Приложение V. Спецзнаки КОМПАС-3D

I. Простановка размеров
 | 1 | Градус | 6 | Меньше или равно
 | 2 | Диаметр | 7 | Больше или равно
 | 3 | Плюс-минус | 80 | Текст в рамке
 | 82 | Минус-плюс | 83 | Размер притупления
 | 4 | Умножить | 95 | Надчеркнутый текст
 | 14 | Квадрат | 96 | Подчеркнутый текст
 | 77 | Радиус | 169 | Перечеркнутый текст
 | 81 | Метрическая резьба | 97 | Текст с дугой
 | 90 | Сфера | 98 | Квадратный корень
 | 68 | Символ & | 99 | Кубический корень
 | 212 | Символ ~ | 210 | Номер
 | 5 | Приблизительно равно |  |
 | I.I Звезда с индексом
 | 100 | Звезда | 184 | Звезда с индексом 15
 | 8 | Две звезды | 185 | Звезда с индексом 16
 | 101 | Звезда с индексом 1 | 186 | Звезда с индексом 17
 | 102 | Звезда с индексом 2 | 187 | Звезда с индексом 18
 | 103 | Звезда с индексом 3 | 188 | Звезда с индексом 19
 | 104 | Звезда с индексом 4 | 189 | Звезда с индексом 20
 | 105 | Звезда с индексом 5 | 190 | Звезда с индексом 21
 | 106 | Звезда с индексом 6 | 191 | Звезда с индексом 22
 | 107 | Звезда с индексом 7 | 192 | Звезда с индексом 23
 | 108 | Звезда с индексом 8 | 193 | Звезда с индексом 24
 | 109 | Звезда с индексом 9 | 194 | Звезда с индексом 25
 | 110 | Звезда с индексом 10 | 195 | Звезда с индексом 26
 | 180 | Звезда с индексом 11 | 196 | Звезда с индексом 27
 | 181 | Звезда с индексом 12 | 197 | Звезда с индексом 28
 | 182 | Звезда с индексом 13 | 198 | Звезда с индексом 29
 | 183 | Звезда с индексом 14 | 199 | Звезда с индексом 30
I.II Верхний индекс
 | 200 | Верхний индекс «0» | 204 | Верхний индекс «4»
 | 125 | Верхний индекс «+» | 205 | Верхний индекс «5»
 | 127 | Верхний индекс «,» | 206 | Верхний индекс «6»
 | 128 | Верхний индекс «1» | 207 | Верхний индекс «7»
 | 129 | Верхний индекс «2» | 208 | Верхний индекс «8»
 | 203 | Верхний индекс «3» | 209 | Верхний индекс «9»
I.III Нижний индекс
 | 111 | Нижний индекс «1» | 117 | Нижний индекс «7»
 | 112 | Нижний индекс «2» | 118 | Нижний индекс «8»
 | 113 | Нижний индекс «3» | 119 | Нижний индекс «9»
 | 114 | Нижний индекс «4» | 120 | Нижний индекс «0»
 | 115 | Нижний индекс «5» | 126 | Нижний индекс «-»
 | 116 | Нижний индекс «6» |  |
II. Углы, уклоны, конусность
 | 76 | Уклон (влево) | 13 | Конусность (вправо)
 | 11 | Уклон (вправо) | 9 | Угол (влево)
 | 12 | Конусность (влево) | 69 | Угол (вправо)
 | III. Допуски формы и расположения поверхностей
 | 30 | Зависимый допуск | 32 | Независимый допуск
 | 31 | Выступающее поле допуска | 220 | Допуск для нежестких деталей
III.I Допуск формы
 | 16 | Допуск прямолинейности | 23 | Допуск цилиндричности
 | 17 | Допуск плоскостности | 18 | Допуск профиля продольного сечения
 | 22 | Допуск круглости |
 | III.II Допуск расположения
 | 24 | Допуск параллельности | 19 | Допуск симметричности
 | 25 | Допуск перпендикулярности | 27 | Позиционный допуск
 | 10 | Допуск наклона | 33 | Допуск пересечения осей
 | 26 | Допуск соосности |  |
 | III.III Суммарные допуски формы и расположения
 | 28 | Допуск биения | 20 | Допуск формы заданного профиля
 | 29 | Допуск полного биения | 21 | Допуск формы заданной поверхности
 | IV. Направления неровностей шероховатости
 | 70 | Параллельное | 74 | Кругообразное
 | 71 | Перпендикулярное | 75 | Радиальное
 | 72 | Перекрещивающееся | 170 | Точечное
 | 73 | Произвольное |  |
 | V. Швы сварных соединений
 | 34 | Знак размера катета | 40 | Шов по незамкнутой линии
 | 35 | Усиление шва снять (лицевой) | 148 | Знак монтажного шва
 | 36 | Усиление шва снять (оборотный) | 121 | Обозначение сварного шва
 | 37 | Наплывы обр. с плавным переходом (лицевой) | 122 | Обозначение сварного шва. По контуру
 | 38 | Наплывы обр. с плавным переходом (оборотный) | 123 | Обозначение сварного шва. Монтажный шов
 | 15 | Шов прерыв. или точ. c шахм. расположением (1) | 124 | Обозначение сварного шва. Монтажный шов по контуру
 | 39 | Шов прерыв. или точ. c шахм. расположением (2) |  |
 | V.I Сварные швы по ISO 2553:1992
 | 1001 | Стыковой шов между пластинами с отбортовкой кромок | 1013 | Шовная контактная сварка
 | 1002 | Стыковой шов без скоса кромок | 1014 | Стыковой шов между пластинами с отбортовкой кромок. Зеркальный символ
 | 1003 | V-образный стыковой шов со скосом кромок | 1015 | V-образный стыковой шов со скосом кромок. Зеркальный символ
 | 1004 | Стыковой шов со скосом одной кромки | 1016 | Стыковой шов со скосом одной кромки. Зеркальный символ
 | 1005 | V-образный стыковой шов со скосом кромок с широкой поверхностью притупления | 1017 | V-образный стыковой шов со скосом кромок с широкой поверхностью притупления. Зеркальный символ
 | 1006 | Стыковой шов со скосом одной кромки с широкой поверхностью притупления | 1018 | Стыковой шов со скосом одной кромки с широкой поверхностью притупления. Зеркальный символ
 | 1007 | U-образный стыковой шов с криволинейным скосом кромок | 1019 | U-образный стыковой шов с криволинейным скосом кромок. Зеркальный символ
 | 1008 | J-образный стыковой шов с криволинейным скосом одной кромки | 1020 | J-образный стыковой шов с криволинейным скосом одной кромки. Зеркальный символ
 | 1009 | Подварочный шов | 1021 | Подварочный шов. Зеркальный символ
 | 1010 | Угловой сварной шов | 1022 | Угловой сварной шов. Зеркальный символ
 | 1011 | Пробочный сварочный шов | 1023 | Пробочный сварочный шов. Зеркальный символ
 | 1012 | Точечный шов |  |
 | V.II Другие знаки
 | 84 | Знак размера катета (перевернутый 1) | 86 | Знак размера катета (перевернутый 3)
 | 85 | Знак размера катета (перевернутый 2) |  |
 | VI. Обозначения видов, разрезов и сечений
 | 63 | Повернуто | 64 | Развернуто
VII. Знаки шероховатости
 | 171 | Верхний. Изм. №3 ГОСТ 2.309–73 | 211 | Верхний без параметров
 | 172 | Верхний. С удалением материала. Изм. №3 ГОСТ 2.309–73 | 91 | Верхний. Без удаления материала
 | 78 | Верхний | 92 | Нижний. Без удаления материала
 | 79 | Нижний | 87 | Шероховатость. Верхний. По контуру
 | 93 | Верхний. С удалением материала | 88 | Шероховатость. Верхний. С удалением материала. По контуру
 | 94 | Нижний. С удалением материала | 89 | Шероховатость. Верхний. Без удаления материала. По контуру
 | VIII. Спецзнаки для совместимости с версией 4.x
VIII.I Римские цифры
 | 41 | Римская 1 | 46 | Римская 6
 | 42 | Римская 2 | 47 | Римская 7
 | 43 | Римская 3 | 48 | Римская 8
 | 44 | Римская 4 | 49 | Римская 9
 | 45 | Римская 5 | 50 | Римская 10
 | VIII.II Знаки предопределенной шероховатости
 | 65 | Rz40 | 67 | Rz20
 | 66 | Rz80 |  |
VIII.III Греческий алфавит
 | 51 | Альфа строчная | 57 | Сигма прописная
 | 52 | Бета строчная | 58 | Сигма строчная
 | 53 | Гамма строчная | 59 | Тау строчная
 | 54 | Дельта прописная | 60 | Фи строчная
 | 55 | Дельта строчная | 61 | Омега прописная
 | 56 | Пи строчная | 62 | Омега строчная
IX. Условные обозначения профилей проката
 | 130 | Круг | 143 | Швеллер
 | 131 | Квадрат/прямоугольник | 144 | Профиль рельсовый
 | 132 | Профиль шестигранный | 145 | Углобульб
 | 133 | Профиль трехгранный | 146 | Профиль С-образный равнополочный
 | 134 | Профиль сегментный | 147 | Профиль зетовый равнополочный
 | 135 | Профиль трапециевидный | 213 | Швеллер неравнополочный
 | 136 | Профиль овальный | 214 | Уголок неравнополочный
 | 137 | Профиль полосовой | 215 | Спаренные равнополочные уголки
 | 138 | Полособульб | 216 | Спаренные неравнополочные уголки
 | 139 | Полособульб сдвоенный | 217 | Накрестлежащие уголки
 | 140 | Уголок | 218 | Коробка из 2-х швеллеров
 | 141 | Профиль тавровый | 219 | Спаренные швеллеры
 | 142 | Профиль двутавровый |  |
X. Номера изменений
 | 149 | Изменение №1 | 159 | Изменение №11
 | 150 | Изменение №2 | 160 | Изменение №12
 | 151 | Изменение №3 | 161 | Изменение №13
 | 152 | Изменение №4 | 162 | Изменение №14
 | 153 | Изменение №5 | 163 | Изменение №15
 | 154 | Изменение №6 | 164 | Изменение №16
 | 155 | Изменение №7 | 165 | Изменение №17
 | 156 | Изменение №8 | 166 | Изменение №18
 | 157 | Изменение №9 | 167 | Изменение №19
 | 158 | Изменение №10 | 168 | Изменение №20
XI. Спецзнаки для гравирования
 | 173 | Знакоместо 12.0 для символов 2, 3, ... | 177 | Знакоместо 17.6 для символов Д, M, ...
 | 174 | Знакоместо 14.4 для символов Б, В, ... | 178 | Знакоместо 20.0 для символов Ш, Ы, ...
 | 175 | Знакоместо 15.2 для символов И, Н, ... | 179 | Знакоместо 20.8 для символов Щ, Ю, ...
 | 176 | Знакоместо 16.0 для символов А, О, ... |  |
XII. Обозначения условные графические в схемах. ГОСТ 2.751-73
 | 201 | Витая пара | 202 | Экранированный кабель


Приложение VI. Файл данных

Файл данных — это файл, содержащий числовые значения, которые могут использоваться в качестве параметров точек или переменных экземпляров массива.

Файлы данных могут иметь следующие форматы и, соответственно, расширения имени:

– текстовый, txt,

– текстовая таблица, csv,

– электронная таблица MS Excel, xls,

– электронная таблица Open Office, ods (для записи в этот формат необходимо, чтобы на компьютере был установлен пакет Open Office).

Не рекомендуется, чтобы файл *.xls был открыт в MS Excel во время передачи данных из этого файла в КОМПАС-3D.

При работе в КОМПАС-3D возможна как запись данных в файл, так и чтение данных из файла.

В этом разделе:

1. Запись в файл

2. Чтение из файла


1. Запись в файл

Приложение VI. Файл данных

1. Запись в файл

Запись в файл данных доступна для объектов следующих типов:

– сплайн и ломаная (при работе с таблицей параметров, см. раздел 2.5.4.8.1),

– сплайновая форма (при настройке сетки, см. раздел 2.6.3.3.2),

– массивы (при управлении переменными экземпляров, см. раздел 2.7.2; при задании позиций экземпляров массива по таблице, см. раздел 2.7.7.2).

Параметры каждого объекта (точки или экземпляра массива) располагаются в отдельной строке. Для точек максимальное количество параметров в строке — четыре, для экземпляра — не ограничено. В качестве разделителя значений параметров используется пробел или несколько пробелов, а в качестве десятичного разделителя — точка.

Координаты точек измеряются в абсолютной системе координат.

Количество знаков после запятой в значениях в файле соответствует настройке, произведенной в диалоге настройки представления чисел (см. раздел 9.1.2.2).

Для сплайна, ломаной и массивов строки данных в файле располагаются одной группой.

Для сплайновой формы строки объединены в несколько групп. Каждая группа содержит параметры полюсов одного ряда сетки сплайновой формы и отделена от следующей группы пустой строкой. Количество групп равно количеству рядов сетки.


2. Чтение из файла

Приложение VI. Файл данных

2. Чтение из файла

Чтение данных из файла возможно при работе с объектами следующих типов:

– поверхность по сети точек (см. раздел 2.6.1.6.2),

– поверхность по пласту точек (см. раздел 2.6.1.7.2),

– сплайн и ломаная (см. раздел 2.5.4.8),

– группа точек из файла (см. раздел 2.5.3.4),

– импортированная поверхность (см. раздел 2.6.1.1),

– массивы (см. раздел 2.7).

Чтобы файл данных был прочитан корректно, он должен удовлетворять следующим требованиям.

– Параметры каждого объекта (точки или экземпляра массива) располагаются в отдельной строке.

– Пустые значения параметров не допускаются.

– Для точки максимальное количество параметров в строке — четыре. Перечень параметров и порядок их следования в зависимости от типа объекта приведены в таблице 1.

– Для экземпляра максимальное количество параметров в строке не ограничено.

– В файле текстового формата в качестве разделителя значений параметров используется пробел или несколько пробелов, а в качестве десятичного разделителя — точка.

– Значения углов записываются в формате десятичной системы счисления.

– Строка файла, начинающаяся с символа «#», считается комментарием.

Дополнительные требования к файлу данных для поверхности по сети точек:

– ряды точек описываются группами строк; количество строк в группах одинаково,

– разделитель групп — пустая строка или строка, содержащая любое целое число (обычно — номер ряда), или один из следующих символов: плюс (+), минус (-), звездочка (*); несколько следующих подряд разделителей групп считаются одним разделителем.

Файл данных для поверхности по сети точек может содержать одну группу или не целое количество групп. В этом случае, чтобы построение поверхности было возможно, после чтения файла необходимо указать или построить недостающие точки.

Табл. 1. Параметры точек, необходимые для корректного чтения данных из файла
Тип объекта | Параметры точек объекта, хранящиеся в файле | Порядок следования параметров в строке
Поверхность по сети точек, поверхность по пласту точек, импортированная поверхность, сплайн по точкам | Прямоугольные координаты | X Y Z
Сплайн по полюсам | Прямоугольные координаты и веса | X Y Z вес
Ломаная | Прямоугольные координаты и радиусы скругления при вершинах | X Y Z радиус
Группа точек из файла, массив по таблице | Прямоугольные, цилиндрические или сферические координаты1 | X Y Z, R A Z или R A B
  1. Вариант интерпретации данных, записанных в файле, выбирается пользователем при задании параметров операции.


Приложение VII. Методики проектирования сборок.Коллективная работа

Приложение VII. Методики проектирования сборок.
Коллективная работа

В этом разделе:

1. Общие сведения

2. Методика «Сверху вниз с предварительной компоновкой»

3. Методика «Сверху вниз с преобразованием тел в компоненты»

4. Методика «Снизу вверх с предварительной компоновкой»

5. Методика «Снизу вверх с размещением компонентов»

6. Условные обозначения, применяемые в схемах

7. Коллективная работа над сборкой


1. Общие сведения

Приложение VII. Методики проектирования сборок.Коллективная работа

1. Общие сведения

При проектировании сборок используются следующие подходы:

– проектирование сверху вниз,

– проектирование снизу вверх.

Проектирование сверху вниз

Схема проектирования сверху вниз

При проектировании сверху вниз:

– проектирование начинается с верхнего уровня и завершается на нижних уровнях;

– компоненты, как правило, создаются в контексте сборки.

Проектирование снизу вверх

Схема проектирования снизу вверх

При проектировании снизу вверх:

– проектирование начинается с нижних уровней и завершается на верхнем уровне;

– разработка компонентов, как правило, выполняется в отдельных окнах, вне контекста сборки;

– по мере готовности компоненты размещаются в сборке (подсборке);

В рамках описанных выше подходов реализуются следующие методики проектирования:

– «Сверху вниз с предварительной компоновкой».

– «Сверху вниз с преобразованием тел в компоненты».

– «Снизу вверх с предварительной компоновкой».

– «Снизу вверх с размещением компонентов».

Назначение методик — помощь при выборе сценария разработки сборки в целом. На практике в ходе разработки сборки обычно сочетаются несколько методик.


2. Методика «Сверху вниз с предварительной компоновкой»

Приложение VII. Методики проектирования сборок.Коллективная работа

2. Методика «Сверху вниз с предварительной компоновкой»

Схема проектирования сверху вниз с предварительной компоновкой

Методика предполагает последовательное, начиная с верхнего и завершая нижними уровнями, создание компонентов в контексте моделей, куда эти компоненты входят. Разработка компонентов после их создания выполняется в отдельных окнах. Построения в деталях опираются на копии объектов компоновочной геометрии, в подсборках — на вставки компоновочной геометрии.

Методика применяется если:

– изначально отсутствует полная определенность по составу и конструкции;

– большинство деталей и узлов разрабатываются впервые.

Последовательность проектирования сверху вниз с предварительной компоновкой
Шаг | Описание | Комментарий
1.Подготовка компоновочной геометрии | – создается файл детали или сборки, в котором строится компоновочная геометрия разрабатываемой сборки | – при необходимости для основных узлов сборки создаются коллекции геометрических объектов
2.Создание сборки и вставка компоновочной геометрии | – создается файл разрабатываемой сборки; – в сборку вставляется ранее подготовленная компоновочная геометрия | – вставленная компоновочная геометрия впоследствии используется для контроля разработки сборки
3.Контекстное создание компонентов | – в контексте сборки создаются компоненты | – по завершению создания компонентов модель сборки может быть закрыта
4.Разработка компонентов | – каждый из компонентов открывается в отдельном окне; – в компонент вставляется компоновочная геометрия либо копируются ее отдельные объекты; – разрабатывается геометрия компонента (если компонент подсборка, то в ее контексте, в свою очередь, повторяются действия шага 3) | – объекты компоновочной геометрии в подсборках используются для контроля их разработки; – для копирования могут использоваться подготовленные на шаге 1 коллекции


3. Методика «Сверху вниз с преобразованием тел в компоненты»

Приложение VII. Методики проектирования сборок.Коллективная работа

3. Методика «Сверху вниз с преобразованием тел в компоненты»

Схема проектирования сверху вниз с преобразованием тел в компоненты

Методика предполагает изначальное моделирование сборки телами с последующим преобразованием тел в детали — компоненты сборки. При создании тел используются объекты предварительно созданной и вставленной в сборку компоновочной геометрии.

Методика применяется при проектировании небольших сборок, состоящих в основном из деталей, большинство из которых разрабатывается впервые.

Последовательность проектирования сверху вниз с преобразованием тел в компоненты
Шаг | Описание | Комментарий
1.Подготовка компоновочной геометрии | – создается файл детали или сборки, в котором строится компоновочная геометрия разрабатываемой сборки |
2.Создание сборки и вставка компоновочной геометрии | – создается файл разрабатываемой сборки; – в сборку вставляется ранее подготовленная компоновочная геометрия |
3.Построение тел в сборке | – в сборке на объектах компоновочной геометрии создаются тела будущих деталей | – в компоновочной геометрии создаются объекты (плоскости, поверхности и т.д.); – тела, которые будут входить в разные детали, не должны объединяться операциями построения
4.Преобразование тел в детали | – тела в Дереве модели последовательно преобразуются в детали с помощью команды Создать деталь 1 |
  1. Опцию Удалять оригинал в команде рекомендуется оставлять включенной (в противном случае оставшиеся тела будут учитываться при расчете МЦХ модели сборки).


4. Методика «Снизу вверх с предварительной компоновкой»

Приложение VII. Методики проектирования сборок.Коллективная работа

4. Методика «Снизу вверх с предварительной компоновкой»

Схема проектирования снизу вверх с предварительной компоновкой

Методика предполагает последовательное, начиная с нижнего и завершая верхним уровнем, создание компонентов сборки и ее подсборок в отдельных окнах. В компоненты копируются требуемые части предварительно подготовленной компоновочной геометрии. Начала координат сборки, подсборок и деталей совпадают.

Методика применяется если:

– состав и конструкция сборки изначально полностью определены;

– большинство деталей и узлов разрабатываются впервые (количество заимствованных и библиотечных моделей незначительно);

– не требуется моделировать перемещение подвижных частей.

Последовательность проектирования снизу вверх с предварительной компоновкой
Шаг | Описание | Комментарий
1.Подготовка компоновочной геометрии | – создается файл детали или сборки, в котором строится компоновочная геометрия разрабатываемой сборки | – при необходимости для основных узлов сборки создаются коллекции геометрических объектов
2.Создание деталей | – создаются файлы деталей; – с помощью команды Копировать объекты из файла компоновочной геометрии в файлы деталей копируются необходимые для построений объекты и (или) их коллекции; – в файлах деталей выполняются построения |
3.Создание подсборок, вставка компонентов в подсборки | – создаются файлы подсборок; – в каждую из подсборок вставляется компоновочная геометрия; – в начало координат подсборки вставляются компоненты | – если подсборки должны входить в подсборки более высокого уровня, действия этого шага в подсборках более высокого уровня повторяются
4.Создание сборки | – создается файл разрабатываемой сборки; – в сборку вставляется ранее подготовленная компоновочная геометрия; – в начало координат сборки вставляются компоненты | – вставка компоновочной геометрии используется для контроля разрабатываемой сборки


5. Методика «Снизу вверх с размещением компонентов»

Приложение VII. Методики проектирования сборок.Коллективная работа

5. Методика «Снизу вверх с размещением компонентов»

Схема проектирования снизу вверх с размещением компонентов.

Методика предполагает последовательное, начиная с нижнего и завершая верхним уровнем, создание компонентов сборки и ее подсборок. Компоненты сборки на всех уровнях создаются и редактируются в отдельных окнах. Модели разрабатываются независимо, на основе изначально определенных требований к составу сборки и ее конструкции. Компоненты в сборке и ее подсборках после вставки позиционируются с помощью сопряжений.

Методика применяется если:

– состав и конструкция изначально полностью определены;

– большая часть деталей и узлов разработана ранее (например, представлена библиотечными элементами либо заимствована из других сборок).

Последовательность проектирования снизу вверх с размещением компонентов
Шаг | Описание | Комментарий
1.Создание деталей | – создаются файлы деталей; – в файлах деталей выполняются необходимые построения |
2.Создание подсборок, вставка компонентов в подсборки | – создаются файлы подсборок; – в подсборки вставляются компоненты; – на компоненты накладываются требуемые сопряжения | – если подсборки должны входить в подсборки более высокого уровня, действия этого шага в подсборках более высокого уровня повторяются
3.Создание сборки | – создается файл разрабатываемой сборки; – в сборку вставляются подготовленные компоненты; – на компоненты накладываются требуемые сопряжения |


6. Условные обозначения, применяемые в схемах

Приложение VII. Методики проектирования сборок.Коллективная работа

6. Условные обозначения, применяемые в схемах

Условные обозначения в схемах

Тело

Деталь – компонент сборки

Деталь

Подсборка

Сборка

Компоновочная геометрия

Копия геометрии

Локальная система координат (ЛСК)

Сопряжение


7. Коллективная работа над сборкой

Приложение VII. Методики проектирования сборок.Коллективная работа

7. Коллективная работа над сборкой

В данном разделе приведены рекомендации по организации коллективной работы над сборочной моделью. Данные рекомендации учитывают следующие требования к процессу коллективной разработки сборки:

– работы разработчиков не должны дублироваться;

– работа над сборкой и ее частями одного разработчика по возможности не должна препятствовать работе над сборкой и ее частями других разработчиков;

– при необходимости результаты работы одного разработчика могут быть защищены от возможных несанкционированных изменений другими разработчиками.

Рекомендации составлены исходя из следующего состава участников разработки:

– ответственный за разработку;

– разработчики узлов.

Ответственный за разработку:

– принимает решения по конструкции сборки;

– создает файл сборки, файлы моделей узлов;

– разрабатывает исходные данные — компоновочную геометрию сборки;

– вставляет в сборку компоновочную геометрию;

– размещает в сборке модели ее узлов.

– создает и настраивает типы загрузки сборки.

Разработчики компонентов:

– разрабатывают узлы и другие компоненты сборки;

– при необходимости размещают отдельные компоненты в сборке.

Работу целесообразно организовать таким образом, чтобы разработчики узлов выполняли минимум действий в контексте сборки.

Для эффективной организации работы рекомендуется:

– защитить паролем системные типы загрузки (пароль, как правило, известен только ответственному за разработку);

– создать защищенные индивидуальными паролями пользовательские типы загрузки, представленные в таблице.

Тип загрузки | Назначение | Описание | Комментарий
Разработка АБВ1 | для работы над узлом (узлами) «АБВ» в контексте сборки | – компонентам АБВ назначается тип загрузки Полный без запрета редактирования; – остальным компонентам назначается один из системных типов загрузки, с запретом редактирования2; – компоненту компоновочной геометрии назначается тип загрузки Полный с запретом редактирования | – типы загрузки создаются для работы каждого из разработчиков; – работая с этим типом загрузки, разработчик может редактировать разрабатываемые им узлы в контексте сборки, добавлять в сборку новые компоненты, но не имеет доступа к редактированию других компонентов сборки
Подробный просмотр | для просмотра сборки с полной загрузкой ее компонентов | – всем компонентам, а также компоненту компоновочной геометрии сборки назначается тип загрузки Полный с запретом редактирования | – пользоваться этим типом загрузки могут все участники разработки
Просмотр в упрощенном виде | для просмотра сборки с упрощенной загрузкой ее компонентов | – всем компонентам, а также компоненту компоновочной геометрии сборки назначается тип загрузки Упрощенный с запретом редактирования3 |
  1. «АБВ» — название узла (узлов), который разрабатывает тот или иной разработчик.
  2. Назначается тип загрузки Полный, если разрешается использовать геометрию компонента, Упрощенный — если предполагается только просмотр компонента, Пустой или Габарит — если просмотр компонента нежелателен.
  3. При типе загрузки Упрощенный эскизы, кривые, точки не отображаются. Если объекты указанного типа, входящие в компоновочную геометрию, должны быть видны, то ей следует назначить тип загрузки Полный.

Дополнительно, для решения тех или иных задач, могут создаваться другие пользовательские типы загрузки (например, тип загрузки, в котором всем крепежным элементам назначен тип загрузки Пустой, либо тип загрузки для просмотра отдельных узлов в составе сборки, в котором редактирование всех компонентов запрещено, а просматриваемые компоненты загружаются упрощенно).


Приложение VIII. Защита КОМПАС-3D

В этом разделе:

1. Общие сведения об аппаратной защите системы КОМПАС-3D

1.1. Устройство аппаратной защиты

1.2. Программная реализация системы защиты

2. Схема защиты

2.1. Локальные ключи аппаратной защиты

2.2. Сетевые ключи аппаратной защиты

2.3. Порядок использования защищенного программного обеспечения

3. Управление лицензиями при сетевом использовании системы КОМПАС-3D

3.1. Запуск Admin Control Center

3.1.1. Способы запуска

3.1.2. Использование языковых шаблонов

3.2. Интерфейс ACC

3.3. Просмотр списка ключей, доступных в сети

3.4. Просмотр полного списка приложений, доступных для текущего компьютера в сети

3.5. Просмотр списка компонентов приложения

3.6. Просмотр списка сеансов доступа к защищенным продуктам и управление сеансами

3.7. Просмотр журнала истории подключений к Менеджеру лицензий на текущем компьютере

3.8. Просмотр сведений о текущем Менеджере лицензий

4. Настройка ACC

4.1. Общие настройки (Basic Settings)

4.1.1. Общие настройки ACC

4.1.2. Шаблон журнала учета

4.1.3. Парольная защита ACC

4.2. Пользователи (Users)

4.3. Доступ к удаленным Менеджерам лицензий (Access to Remote License Managers)

4.4. Доступ с удаленных клиентов (Access from Remote Clients)

5. Дистанционное перепрограммирование ключа аппаратной защиты

5.1. Общий порядок действий для обновления лицензий

5.2. Формирование файла статуса ключа

5.3. Отправка файла статуса

5.4. Перепрограммирование ключа после получения ответа

5.5. Установка компонентов системы КОМПАС-3D

6. Обновление прошивки ключа


1. Общие сведения об аппаратной защите системы КОМПАС-3D

Приложение VIII. Защита КОМПАС-3D

1. Общие сведения об аппаратной защите
системы КОМПАС-3D

Система КОМПАС-3D и ее приложения, начиная с версии V11, защищаются от несанкционированного использования при помощи технологии Sentinel HASP. Система защиты представляет собой программно-аппаратный комплекс, использующий 128-битный криптографический алгоритм в соответствии со стандартом Advanced Encryption Standard (AES).

В этом разделе:

1.1. Устройство аппаратной защиты

1.2. Программная реализация системы защиты


1.1. Устройство аппаратной защиты

В стандартную поставку системы КОМПАС-3D входит устройство защиты от несанкционированного использования — ключ аппаратной защиты (рис. 1), который устанавливается в разъем USB-поpта компьютера. Ключ обладает собственной памятью, в которой хранится информация об оплаченных компонентах системы КОМПАС-3D и условиях их использования.

Рис. 1. Ключи аппаратной защиты

Аппаратная защита системы КОМПАС-3D и отдельных ее компонентов от несанкционированного использования обеспечивается применением ключей HASP HL с прошивкой версии 3.25.

Для обеспечения гибкости условий лицензирования могут быть использованы ключи различных типов (табл. 1). Все модели ключей обеспечивают защиту от несанкционированного использования программ. Отличия между ключами различных типов заключаются в особенностях управления лицензиями, записанными на ключе, и объеме памяти, доступной для использования.

Табл. 1. Типы ключей аппаратной защиты, используемых в системе КОМПАС-3D
Тип ключа | Описание | Тип поддерживаемых лицензий
HASP HL Pro HASP HL Max | Защита нескольких приложений и их компонентов на локальном компьютере. | – Бессрочная, – Компонентоориентированная, – По количеству запусков продукта, – Демонстрационная, – Схема лицензирования, настраиваемая по счетчику запусков.
HASP HL Time | Защита нескольких приложений и их компонентов на локальном компьютере. Содержит встроенные часы реального времени. | – Бессрочная, – Компонентоориентированная, – Подписная (оплата обновлений и новых версий), – Арендная (оплата оговоренного времени эксплуатации), – Схема лицензирования, настраиваемая по состоянию встроенных часов.
HASP HL Net | Сетевая защита нескольких приложений и их компонентов. | – Бессрочная, – Компонентоориентированная, – Плавающая (передаваемая между пользователями), – Демонстрационная, – Схема лицензирования, настраиваемая по количеству пользователей и счетчику запусков.
HASP HL NetTime | Сетевая защита нескольких приложений и их компонентов. Содержит встроенные часы реального времени. | – Бессрочная, – Компонентоориентированная, – Плавающая (Передаваемая между пользователями), – Подписная или арендная, – Демонстрационная, – Схема лицензирования, настраиваемая по количеству пользователей, счетчику запусков и состоянию встроенных часов.

Ключи аппаратной защиты, изготовленные по технологии HASP, за исключением ключей типа HASP HL Max, обратно совместимы с ключами HASP4 и HASP HL, которые использовались для защиты системы КОМПАС-3D предыдущих версий.

Ключи HASP HL могут быть перепрограммированы таким образом, чтобы использовать все возможности новой технологии (см. раздел 6).


1.2. Программная реализация системы защиты

Программы ключа защиты устанавливаются на компьютер при установке системы КОМПАС-3D.

– Выбор пункта Драйвер ключа защиты и средства администрирования означает установку программы HASP Run-time Environment. Она обеспечивает запуск программного обеспечения, защищенного системой HASP, и его взаимодействие с ключом защиты во время работы. При установке этой программы автоматически устанавливаются следующие компоненты программного обеспечения HASP:

• драйвер ключа аппаратной защиты,

• HASP Admin Control Center — программа, обеспечивающая управление сетевыми лицензиями (см. раздел 3).

– Выбор пункта Программа обновления лицензий означает установку программы HASP SRM Remote Update System. Она обеспечивает обновление лицензий в установленных ключах при изменении лицензионного соглашения (см. раздел 5).


2. Схема защиты

Приложение VIII. Защита КОМПАС-3D

2. Схема защиты

Система HASP позволяет использовать защищенное программное обеспечение, установленное на локальных компьютерах либо на компьютерах, объединенных в локальную сеть.

Корректной работе защиты HASP может препятствовать сетевой экран (например, Брандмауэр Windows). Если при наличии ключа и лицензии на нем КОМПАС-3D запускается в ознакомительном или демонстрационном режиме, необходимо изменить настройки сетевого экрана.

В этом разделе:

2.1. Локальные ключи аппаратной защиты

2.2. Сетевые ключи аппаратной защиты

2.3. Порядок использования защищенного программного обеспечения


2.1. Локальные ключи аппаратной защиты

Для работы защищенного приложения на локальном компьютере могут использоваться локальные ключи следующих типов:

– HASP HL Pro,

– HASP HL Max,

– HASP HL Time.

Один или несколько таких ключей, в соответствии с выбранными условиями лицензирования, входит в комплект поставки отдельного рабочего места.

В памяти локального ключа записаны сведения об оплаченных компонентах и условиях лицензирования.


2.2. Сетевые ключи аппаратной защиты

Для использования системы КОМПАС-3D, установленной на компьютерах, объединенных в локальную сеть, достаточно сетевого ключа аппаратной защиты типа HASP HL Net или HASP HL NetTime. В память ключа записаны сведения об оплаченных компонентах, количестве лицензий и условиях лицензирования. Этот ключ подключается к одному из компьютеров локальной сети, на котором установлена программа защиты HASP Run-time Environment.

Сетевой ключ входит в комплект поставки нескольких рабочих мест, предназначенных для работы в сети. Он позволяет работать с каждым компонентом системы нескольким пользователям одновременно. Максимальное количество пользователей, одновременно работающих с каждым компонентом, определяется количеством лицензий на этот компонент. Компьютер, на котором установлен сетевой ключ, называется сервером сетевого ключа.

На компьютерах, объединенных в сеть, для запуска системы КОМПАС-3D вместе с сетевым могут использоваться и локальные ключи.


2.3. Порядок использования защищенного программного обеспечения

При загрузке системы КОМПАС-3D и/или отдельных компонентов выполняется поиск действующих и доступных лицензий на их использование. Первоначально проверяется локальный ключ. Если требуемые лицензии не обнаружены на локальном ключе, автоматически выполняется их поиск на доступных сетевых ключах.

Если лицензии не найдены, система КОМПАС-3D будет запущена в ознакомительном режиме. В этом режиме обеспечивается полная функциональность системы и всех компонентов в течение 30 календарных дней с момента первого запуска.

Чтобы запустить систему КОМПАС-3D и ее компоненты заведомо в ознакомительном режиме, необходимо выполнить следующие действия:

– отключить локальный ключ,

– в настройках HASP Admin Control Center отключить возможность использования сетевых ключей (см. раздел 4.3).

При каждом запуске системы КОМПАС-3D в течение ознакомительного периода на экране будет появляться информационное сообщение, содержащее сведения о количестве оставшихся до окончания этого периода дней.

Ознакомительный режим является однократным для конкретного компьютера.

Если ключ не найден или на нем нет лицензии на систему КОМПАС-3D и/или запускаемые компоненты, или исчерпано количество лицензий на сетевом ключе, или исчерпан лимит времени на ключе со встроенными часами (HASP HL NetTime или HASP HL Time), то система КОМПАС-3D будет работать в демонстрационном режиме. В зависимости от программной реализации конкретного компонента (системы трехмерного моделирования, какой-либо библиотеки и т.п.) он будет работать в демонстрационном режиме либо не запустится.

В процессе работы с КОМПАС-3D периодически производится проверка наличия локального или сетевого ключа аппаратной защиты и определяется, разрешено ли использование загруженных в данный момент компонентов системы. Если при выполнении проверки ключ не обнаружен, или произошел сбой при обращении к нему, или исчерпан лимит времени на ключе со встроенными часами, на экране появится предупреждающее сообщение о переходе системы в демонстрационный режим через пять минут. Началом отсчета этого интервала времени является момент нажатия кнопки ОК в сообщении, после которого в правом нижнем углу окна приложения появится предупреждающий значок. По истечении пяти минут на экране появится сообщение о том, что система работает в демонстрационном режиме, соответственно изменится и вид предупреждающего значка.

После получения первого сообщения необходимо сохранить все открытые документы и перезапустить систему КОМПАС-3D.

При работе с системой КОМПАС-3D в демонстрационном режиме действуют различные ограничения, в том числе запрет на сохранение документов.


3. Управление лицензиями при сетевом использовании системы КОМПАС-3D

Приложение VIII. Защита КОМПАС-3D

3. Управление лицензиями при сетевом
использовании системы КОМПАС-3D

При установке HASP Run-time Environment на компьютере устанавливается менеджер лицензий HASP License Manager. Он позволяет управлять лицензиями при сетевом использовании системы КОМПАС-3D и ее компонентов. Для доступа к менеджеру лицензий и управлению ими используется программа Admin Control Center (далее ACC), входящая в состав HASP Run-time Environment.

Умолчательная конфигурация ACC обеспечивает доступ ко всем командам программы и изменениям ее настроек. ACC, запущенный на любом компьютере сети, обеспечивает управление Менеджерами лицензий всех компьютеров. Рекомендуется разграничить доступ пользователей к ресурсам ACC, установленных на их компьютерах.

В этом разделе:

3.1. Запуск Admin Control Center

3.1.1. Способы запуска

3.1.2. Использование языковых шаблонов

3.2. Интерфейс ACC

3.3. Просмотр списка ключей, доступных в сети

3.4. Просмотр полного списка приложений, доступных для текущего компьютера в сети

3.5. Просмотр списка компонентов приложения

3.6. Просмотр списка сеансов доступа к защищенным продуктам и управление сеансами

3.7. Просмотр журнала истории подключений к Менеджеру лицензий на текущем компьютере

3.8. Просмотр сведений о текущем Менеджере лицензий


3.1. Запуск Admin Control Center

В этом разделе:

3.1.1. Способы запуска

3.1.2. Использование языковых шаблонов


3.1.1. Способы запуска

Запустить программу Admin Control Center можно следующими способами.

– Вызвать команду главного меню Windows Пуск — Программы — АСКОН — КОМПАС-3D V... — Программы ключа защиты — Сведения о ключах защиты. При использовании такого способа запуска в браузере будет раскрыта вкладка с информацией о доступных для текущего компьютера ключах аппаратной защиты (см. раздел 3.3).

– Вызвать команду главного меню Windows Пуск — Программы — АСКОН — КОМПАС-3D — Программы ключа защиты — Сведения о системе защиты. При использовании такого способа запуска в браузере будет раскрыта вкладка с информацией о текущем менеджере лицензий (см. раздел 3.8).

– В общем случае, чтобы запустить ACC, необходимо в окне браузера (Internet Explorer, Opera, и т.п.) ввести доменное имя или IP-адрес компьютера с установленным менеджером лицензий и номер порта 1947, например, http://10.3.1.37:1947 или http://LM_server:1947, и перейти по этому адресу.

Порт 1947 должен быть открыт, иначе использование ACC будет невозможно.

Чтобы получить доступ к менеджеру лицензий на удаленном компьютере, необходимо выполнение следующих условий:

– в настройках ACC удаленного компьютера должен быть разрешен доступ удаленных пользователей (см. раздел 4.4),

– для изменения настроек ACC удаленного компьютера необходимо знать пароль на доступ к ACC этого компьютера (см. раздел 4.1.3).

Чтобы получить доступ к менеджеру лицензий на локальном компьютере, содержание адресной строки должно быть следующим: http://localhost:1947.

В Windows 8 при использовании metro-версии Internet Explorer с умолчательной настройкой доступ к менеджеру лицензий на локальном компьютере невозможен. Это обусловлено спецификой работы защитного механизма «Расширенный защитный режим» (EPM — Enhanced Protected Mode). По умолчанию этот механизм блокирует обращения к http://localhost.

Чтобы в metro-версии Internet Explorer использовать адрес http://localhost:1947, можно добавить его в список надежных сайтов или изменить настройку браузера, отключив автоматическое определение принадлежности адресов к интрасети.


3.1.2. Использование языковых шаблонов

Оригинальным языком интерфейса ACC является английский. В комплект поставки входит шаблон, обеспечивающий использование интерфейса и справочной системы на русском языке.

Подробную информацию об использовании шаблонов для локализации ACC можно получить в документации на сайте разработчика программы.

При запуске ACC командой из главного меню Windows (см. раздел 3.1.1) в качестве языка интерфейса используется русский. Если программа запускается непосредственно из браузера, то использование адресной строки вида http://<имя сервера>:1947 может привести к запуску англоязычной версии ACC. Для смены языка интерфейса используйте ярлыки в левой части страницы.

Последующее описание интерфейса ACC приводится для обоих вариантов используемого интерфейса — русского и английского. Английский вариант имени команды приводится в скобках.


3.2. Интерфейс ACC

После запуска ACC на экране появится окно умолчательного браузера, в котором открыта страница программы. На рис. 2 показано окно Internet Explorer после вызова команды Пуск — Программы — АСКОН — КОМПАС-3D V... — Программы ключа защиты — Сведения о ключах защиты.

Рис. 2. Страница АСС в браузере

В левой части страницы представлено меню команд ACC. Описание команд приведено в табл. 2. Эти команды относятся к Менеджеру лицензий компьютера, сетевое имя или IP-адрес которого показан в строке заголовка ACC (далее упоминается как текущий компьютер). После вызова команды в окне браузера появляется новая вкладка, элементы управления которой позволяют выполнять дополнительные действия, связанные с этой командой.

Табл. 2. Описание команд Admin Control Center
Имя команды | Назначение команды
Ключи Sentinel (Sentinel Keys) | Отображает список ключей аппаратной защиты, доступных в сети, включая сетевые и локальные ключи.
Продукты (Products) | Отображает список всех приложений, доступных при помощи всех Менеджеров лицензий в сети.
Компоненты (Features) | Отображает следующие сведения: – список компонентов системы КОМПАС-3D, лицензированных для каждого ключа, включая сетевые и локальные ключи, – условия лицензирования компонентов, – количество пользователей, использующих каждый компонент.
Сеансы (Sessions) | Отображает сессии клиентов на текущем компьютере, как локальных, так и подключенных к Менеджеру лицензий на этом компьютере по сети. При необходимости сессии могут быть завершены принудительно.
Обновление/прикрепление (Update/Attach) | Позволяет обновить лицензию на ключе.
Журнал доступа (Access Log) | Отображает журнал истории подключений к Менеджеру лицензий на текущем компьютере. Журнал может сохраняться в текстовом файле access.log, который автоматически создается в той же папке, что и файл настроек ACC hasplm.ini. Полный путь к этому файлу отображается в нижней части вкладки браузера на странице настройки ACC (см. раздел 4).
Конфигурация (Configuration) | Позволяет настроить параметры использования ACC на текущем компьютере, например, доступ пользователей к управлению ACC, доступ к удаленному Менеджеру лицензий с текущего компьютера, доступ удаленных пользователей к Менеджеру лицензий текущего компьютера, формат создаваемых файлов журнала отчета (см. раздел 4).
Диагностика (Diagnostics) | Позволяет просмотреть сведения о текущем Менеджере лицензий и подготовить отчет для службы технической поддержки.
Справка (Help) | Обеспечивает доступ к справочной системе ACC.
О программе (About) | Предоставляет сведения о версии Менеджера лицензий и содержит ссылку на сайт базы знаний разработчика системы HASP.

В правом нижнем углу вкладки каждой команды находится ссылка для вызова раздела справочной системы ACC, связанного с этой вкладкой.


3.3. Просмотр списка ключей, доступных в сети

Чтобы просмотреть список сетевых и локальных ключей аппаратной защиты, подключенных к компьютерам сети, следует вызвать команду Ключи Sentinel (Sentinel Keys).

В окне браузера появится вкладка Ключи Sentinel, доступные на (Sentinel Keys available on) <имя текущего компьютера>. На вкладке показана таблица, содержащая сведения о ключах. Описание таблицы приведено в табл. 3.

Табл. 3. Список ключей, доступных в сети

Имя колонки

Содержание колонки

Компьютер

(Location)

Имя компьютера, к которому подключен ключ. Если ключ подключен к текущему компьютеру, его имя будет показано как Local. Имя удаленного компьютера является ссылкой. После перехода по этой ссылке текущим становится этот компьютер. ACC этого компьютера будет открыто на новой вкладке. В настройках ACC удаленного компьютера должен быть разрешен доступ удаленных пользователей.

Поставщик

Vendor

Код поставщика программного обеспечения.

ID ключа

(Key ID)

Уникальный идентификатор ключа.

Тип ключа

(Key Type)

Обозначение типа ключа аппаратной защиты и его уменьшенное изображение.

Конфигурация

(Configuration)

Сведения о конфигурации ключа.

Версия

(Version)

Номер версии прошивки ключа.

Сеансы

(Sessions)

Количество открытых сеансов доступа (сессий) для ключа.

Действия

(Actions)

Команды, обеспечивающие доступ к дополнительным сведениям о ключе. Набор команд зависит от того, является ли ключ сетевым или локальным.

– Сеансы (Sessions) — позволяет открыть вкладку, содержащую информацию о сессиях для этого ключа.

– Компоненты (Features) — позволяет открыть вкладку, содержащую информацию о компонентах приложения, лицензии для которых записаны на этом ключе. Доступна для локального ключа текущего компьютера.

– Диод вкл./выкл. (Blink on/off) — позволяет управлять мерцанием светодиода ключа, позволяя идентифицировать его.

– Обзор (Browse) — позволяет просмотреть все компоненты приложения для заданного сетевого ключа. Менеджер лицензий, установленный на компьютере, к которому подключен этот ключ, будет открыт на новой вкладке браузера. Доступ к удаленному менеджеру лицензий возможен, если в его настройках разрешен доступ удаленных пользователей (см. раздел 4.1).

– Сетевые комп. (Net Features) — позволяет просмотреть компоненты приложения для заданного сетевого ключа, доступные для текущего компьютера.

В списке доступных локальных и сетевых ключей аппаратной защиты первым показан локальный ключ программной защиты. Этот ключ обеспечивает работу системы КОМПАС-3D и отдельных компонентов в течение ознакомительного периода. Команда Компоненты позволяет просмотреть следующие сведения об этом периоде:

– состояние (запущена работа в ознакомительном периоде или нет, возможна работа в ознакомительном режиме или срок его действия истек),

– дата и время начала и окончания.


3.4. Просмотр полного списка приложений, доступных для текущего компьютера в сети

3.4. Просмотр полного списка приложений, доступных
для текущего компьютера в сети

Чтобы просмотреть список приложений, следует вызвать команду Продукты (Products).

В окне браузера появится вкладка Продукты на (Products available on) <имя текущего компьютера>.

На вкладке показана таблица, содержащая обозначения приложений, относящихся ко всем Менеджерам лицензий в сети. Описание таблицы приведено в табл. 4.

Табл. 4. Список приложений, доступных для текущего компьютера в сети
Имя колонки | Содержание колонки
Название продукта (Product Name) | Имя приложения, определенное поставщиком.
Поставщик (Vendor) | Код поставщика программного обеспечения.
Компьютер (Location) | Имя компьютера, к которому подключен ключ для данного компонента. Если ключ подключен к текущему компьютеру, его имя будет показано как Local.
Действия (Actions) | Команды, обеспечивающие доступ к дополнительным сведениям о приложении. – Компоненты (Features) — позволяет открыть вкладку Компоненты на, отображающую список компонентов приложения.


3.5. Просмотр списка компонентов приложения

Чтобы просмотреть список компонентов приложения, лицензированных на ключах, доступных в сети, следует вызвать команду Компоненты (Features).

В окне браузера появится вкладка Лицензии на (Features available on) <имя текущего компьютера>. На вкладке показана таблица, содержащая сведения о компонентах приложения, лицензированных на каждом из ключей (сетевых и локальных), доступных в сети. В таблице приводятся сведения об условиях лицензирования и текущем использовании компонентов. Описание таблицы приведено в табл. 5.

Табл. 5. Список компонентов приложения, лицензированных на ключах, доступных в сети

Имя колонки

Содержание колонки

#

Порядковый номер строки

Поставщик

(Vendor)

Код поставщика программного обеспечения.

ID ключа

(Key)

Уникальный идентификатор ключа.

Продукт

(Product)

Уникальный идентификатор и наименование продукта, установленное поставщиком.

Компонент

(Feature)

Уникальный идентификационный номер и наименование компонента приложения, установленное поставщиком.

Компьютер

(Location)

Имя компьютера, к которому подключен ключ. Если ключ подключен к текущему компьютеру, его имя будет показано как Local.

Доступ

(Access)

Тип компьютеров, для которых разрешен доступ к использованию компонента. Возможными вариантами являются следующие:

– Loc — доступ разрешен только для локального компьютера,

– Net — доступ разрешен для удаленных компьютеров по сети,

– Disp — доступ разрешен для удаленных компьютеров с использованием терминального сервера (в системе КОМПАС-3D не используется).

Счетчик

(Counting)

Способ подсчета количества использований компонента. Возможными вариантами являются следующие:

– Process — все запросы доступа к использованию одного процесса считаются одним доступом,

– Station — все запросы доступа к использованию одного компьютера считаются одним доступом,

– Login — в подсчет количества использований компонента включаются все запросы к использованию.

Сеансы

(Logins)

Количество пользователей, использующих компонент приложения в текущий момент времени.

Лимит

(Limit)

Максимально возможное количество пользователей, которые могут одновременно использовать компонент.

Откреплено

(Detached)

В настоящее время не используется.

Ограничения

(Restrictions)

Ограничения, связанные с использованием компонента приложения на данном ключе. Например, Expired — истек срок действия лицензии на ключе со встроенными часами реального времени.

Сеансы

(Sessions)

Количество текущих сеансов доступа к ключу.

Действия

(Actions)

Команды, обеспечивающие доступ к дополнительным сведениям о приложении.

– Сеансы (Sessions) — позволяет открыть вкладку Сеансы на (Sessions on), содержащую сведения о сеансах доступа к конкретному компоненту приложения.


3.6. Просмотр списка сеансов доступа к защищенным продуктам и управление сеансами

3.6. Просмотр списка сеансов доступа
к защищенным продуктам и управление сеансами

Чтобы просмотреть список сеансов доступа, необходимо вызвать команду Сеансы (Sessions).

В окне браузера откроется страница Сеансы на (Sessions on) <имя текущего компьютера>. На странице показана таблица, содержащая сведения о всех сеансах доступа локальных и удаленных пользователей к текущему компьютеру. Элементы управления, расположенные на странице, обеспечивают просмотр сведений о сеансах доступа и позволяют прерывать их.

Описание таблицы приведено в табл. 6.

Табл. 6. Список сеансов доступа к текущему компьютеру

Имя колонки

Содержание колонки

ID

Уникальный идентификатор сеанса.

Ключ

(Key)

Уникальный идентификатор ключа.

Компьютер

(Location)

Имя или IP-адрес компьютера, к которому подключен ключ. Если ключ подключен к текущему компьютеру, его имя будет показано как Local.

Продукт

(Product)

Уникальный идентификатор и наименование продукта, установленное поставщиком.

Компонент

(Feature)

Уникальный идентификационный номер и наименование компонента приложения, установленное поставщиком.

Адрес

(Address)

IP-адрес компьютера, доступ с которого выполнен или Local, если доступ выполнен с локального компьютера.

Пользователь

(User)

Имя пользователя, использующего компонент приложения.

Клиент

(Machine)

Сетевое имя компьютера, с которого используется компонент приложения, и идентификатор процесса, открывшего сеанс доступа.

Время входа

(Login Time)

Время начала сеанса доступа к компоненту приложения.

Время ожидания

(Timeout)

Оставшееся на текущий момент время удержания лицензии на сервере. Начальное значение временного интервала равна 12 часам.

Во время проверки наличия лицензии, то есть каждые 15 минут, значение в колонке становится равным начальному.

Если работа системы КОМПАС-3D завершается аварийно, проверка лицензии перестает выполняться. Если работа системы КОМПАС-3D на данном рабочем месте не будет возобновлена, то после обнуления значения колонки лицензия будет отключена.

Действия

(Actions)

Команды, обеспечивающие доступ к дополнительным сведениям о приложении.

– Прервать (Disconnect) — позволяет прервать сеанс доступа текущего пользователя к текущему компоненту приложения (отключить пользователя от лицензии). Для выполнения команды необходимо знать пароль доступа к ACC компьютера, к которому подключен ключ аппаратной защиты (см. раздел 4.1.3).


3.7. Просмотр журнала истории подключений к Менеджеру лицензий на текущем компьютере

3.7. Просмотр журнала истории подключений
к Менеджеру лицензий на текущем компьютере

Чтобы просмотреть журнал истории подключений, необходимо вызвать команду Журнал доступа (Access Log). В окне браузера появится страница Журнал доступа для (Access Log for) <имя текущего компьютера>. На странице показана таблица, содержащая сведения о сеансах доступа локальных и удаленных пользователей к Менеджеру лицензий текущего компьютера. По умолчанию в таблице показаны крайние 20 записей. Кнопки 20, 100 и 1000 позволяют выбрать количество отображаемых записей на странице.

Каждая запись журнала по умолчанию содержит следующие сведения:

– дата и время формирования записи,

– IP адрес и порт пользователя,

– идентификатор пользователя,

– метод доступа,

– URL ресурса, к которому адресован запрос,

– используемая функция,

– параметры функции,

– значение, возвращаемое функцией.

Умолчательный шаблон журнала может быть изменен на вкладке Общие настройки (Basic Settings) страницы настройки ACC (см. раздел 4.1.2).

Если на вкладке Общие настройки страницы конфигурации ACC включена опция Вести Журнал доступа (Write an Access Log File), журнал истории подключений сохраняется в текстовом файле access.log. Файл автоматически создается в той же папке, что и файл настроек ACC hasplm.ini. Полный путь к этому файлу отображается в нижней части вкладки браузера на странице настройки ACC (см. раздел 4). По умолчанию указанные файлы сохраняются в папке C:\Program Files\Common Files\Aladdin Shared\HASP\.


3.8. Просмотр сведений о текущем Менеджере лицензий

Чтобы просмотреть сведения о текущем Менеджере лицензий, необходимо вызвать команду Диагностика (Diagnostics).

В окне браузера появится вкладка Диагностика Менеджера лицензий Sentinel на (Diagnostics for Sentinel License Manager on) <имя текущего компьютера>. На вкладке показана таблица, содержащая сведения о Менеджере лицензий.

Описание таблицы приведено в табл. 7.

Табл. 7. Сведения о Менеджере лицензий
Описание сведений | Содержание сведений
Версия менеджера лицензий (License Manager Version) | Версия текущего Менеджера лицензий.
Имя компьютера (Computer Name) | Имя компьютера, на котором установлен Менеджер лицензий, и идентификатор процесса (PID).
Операционная система (Host Operating System) | Наименование и версия операционной системы компьютера, на котором запущен Менеджер лицензий.
Протоколы (LM Protocols) | – Текущий протокол, используемый Менеджером лицензий. Возможными вариантами значений являются IPv4 (только IPv4) или IPv4, IPv6 (IPv4 и IPv6). – IP-адрес текущего менеджера лицензий.
Время работы (Uptime) | Длительность текущего сеанса доступа к Менеджеру лицензий.
Наборы шаблонов (Template Sets) | Список доступных шаблонов интерфейса ACC.
Текущий шаблон (Current Template) | Наименование, номер версии и дата разработки используемого в настоящий момент шаблона интерфейса.
Текущее использование (Current Usage) | Сведения о текущем использовании Менеджера лицензий: – входов (logins) — количество захваченных лицензий, – сеансов (sessions) — количество текущих сеансов доступа к Менеджеру лицензий, – соединений (connections) — количество текущих сетевых соединений из общего количества доступных.
Сессии (Login Requests) | Количество полученных лицензий у текущего Менеджера лицензий с момента его запуска.
Запросы (Requests) | Количество запросов к Менеджеру лицензий с момента его запуска.
Объем данных (Data Volume) | Количество принятых и переданных этим сервером байт информации с момента запуска Менеджера лицензий.
Ошибки (Errors) | Суммарное количество ошибок, связанное с ключом или передачей на этом сервере с момента запуска Менеджера лицензий.
Клиентские потоки (Client Threads) | Количество одновременно протекающих подпроцессов, открытых Менеджером лицензий.
Среда исполнения (Run-time) | Список запущенных компонентов системы HASP с указанием их версий.

Под таблицей со сведениями о Менеджере лицензий находится кнопка вызова команды Создать отчет (Generate Report). Команда позволяет создать диагностический отчет в формате HTML. Отчет содержит детальную информацию о системе, на которой запущен конкретный экземпляр Менеджера лицензий, использованию лицензий и другие сведения, которые могут быть использованы в диагностических целях. Отчет следует использовать при обращении в службу технической поддержки.


4. Настройка ACC

Приложение VIII. Защита КОМПАС-3D

4. Настройка ACC

Настройки ACC позволяют установить следующие параметры:

– права доступа пользователей к сетевым ресурсам системы защиты,

– параметры доступа к удаленным Менеджерам лицензий,

– права доступа пользователей сетевых компьютеров к управлению Менеджером лицензий текущего компьютера.

Чтобы выполнить настройки, следует вызвать команду Конфигурация (Configuration). В окне браузера появится новая вкладка Конфигурация Менеджера лицензий Sentinel на (Configuration for Sentinel License Manager on) <имя текущего компьютера>. Элементы управления, обеспечивающие настройку, сгруппированы на вкладках. Названия вкладок соответствуют типу настроек.

Для выполнения настроек ACC необходимо ввести пароль администратора, если он был ранее задан (см. раздел 4.1.3).

Настройки ACC сохраняются в файле hasplm.ini, который создается автоматически при первом изменении умолчательных настроек. Полный путь к файлу отображается в нижней части вкладки браузера.

В этом разделе:

4.1. Общие настройки (Basic Settings)

4.1.1. Общие настройки ACC

4.1.2. Шаблон журнала учета

4.1.3. Парольная защита ACC

4.2. Пользователи (Users)

4.3. Доступ к удаленным Менеджерам лицензий (Access to Remote License Managers)

4.4. Доступ с удаленных клиентов (Access from Remote Clients)


4.1. Общие настройки (Basic Settings)

В этом разделе:

4.1.1. Общие настройки ACC

4.1.2. Шаблон журнала учета

4.1.3. Парольная защита ACC


4.1.1. Общие настройки ACC

Общие настройки ACC включают в себя задание имени компьютера, ACC которого настраивается, параметры формирования журналов отчетов и настройку парольной защиты. Описание элементов управления вкладки приведено в табл. 8.

Табл. 8. Элементы управления вкладки Общие настройки
Имя элемента управления | Описание
Имя компьютера (Machine Name) | Сетевое имя компьютера, для ACC которого выполняются настройки.
Разрешить удаленный доступ к ACC (Allow Remote Access to ACC) | Опция позволяет управлять доступом удаленных пользователей к ACC компьютера, имя которого задано в поле Имя компьютера. По умолчанию опция выключена.
Время обновления страницы (Display Refresh Time) | Период обновления информации на вкладках ACC в секундах.
Записей на странице (Table Rows per Page) | Количество строк в таблицах, отображаемых на каждой странице вкладки. Значение может изменяться в пределах от 5 до 100.
Вести Журнал доступа (Write an Access Log File) | Опция позволяет управлять созданием файла журнала учета доступа к Менеджеру лицензий. Если опция включена, становятся доступными следующие опции, позволяющие управлять содержанием журнала: Локальные запросы (Include Local Requests), Удаленные запросы (Include Remote Requests), Административные запросы (Include Administration Requests).
Локальные запросы (Include Local Requests) | Позволяет добавлять в журнал сведения о сеансах доступа пользователей локального компьютера к компонентам приложения, лицензированным на ключе, подключенном к этому компьютеру.
Удаленные запросы (Include Remote Requests) | Позволяет добавлять в журнал сведения о сеансах доступа пользователей сетевых компьютеров к компонентам приложения, лицензированным на ключе, подключенном к текущему компьютеру.
Административные запросы (Include Administration Requests) | Позволяет добавлять в журнал сведения о сеансах доступа к Менеджеру лицензий при помощи ACC.
Вести Журнал ошибок (Write an Error Log File) | Опция позволяет управлять созданием журнала ошибок.
Записывать ежедневно (Write Log Files Daily) | Опция позволяет создавать отдельный файл журнала для каждого дня, в течение которого в журнал были записаны какие-либо события.
Дней до сжатия файлов журнала (Days Before Compressing Log Files) | Позволяет задать количество дней, по истечении которого закрытые файлы журнала сжимаются. Для сжатия используется стандартный алгоритм ZIP, к имени файла добавляется расширение zip. Максимальное количество дней — 9999. Если значение равно нулю, файлы не сжимаются.
Дней до удаления файлов журнала (Days Before Deleting Log Files) | Позволяет задать число дней, в течение которых закрытый файл журнала (сжатый или несжатый) хранится на жестком диске компьютера. По истечении этого срока файл автоматически удаляется. При нулевом значении файлы журнала автоматически не удаляются.
Вести Журнал процессов (Write a Process ID (.pid) File) | Опция позволяет создавать файл идентификаторов процессов.
Защита паролем (Password Protection) | Позволяет защитить доступ к АСС паролем. Укажите, требуется ли защитить только Страницы конфигурации (Configuration Pages) или Все страницы ACC (All ACC Pages). Чтобы задать или сменить пароль, нажмите кнопку Смена пароля (Change Password).


4.1.2. Шаблон журнала учета

Команда Параметры Журнала (Edit Log Parameters) позволяет изменить шаблон журнала учета доступа к Менеджеру лицензий.

После вызова команды Параметры Журнала в окне браузера появляется страница Параметры журнала (Edit Log Parameters). Поле в верхней части страницы содержит текущий набор обозначений элементов шаблона. Содержание поля представлено в текстовом формате. Обозначения элементов являются зарезервированными словами. Они помещаются между фигурными скобками. Для пояснения элементов журнала можно добавлять к ним комментарии. Обозначения элементов можно редактировать как обычный текст или с использованием содержания поля Доступные метки: (Available tags for log:).

Поле Доступные метки: содержит обозначения и краткие описания доступных элементов шаблона. Чтобы добавить элемент в шаблон, следует выделить его мышью и вызвать команду Добавить (Add). Обозначение элемента будет добавлено в конец списка.

Команда Назад (Back to Configuration) позволяет завершить редактирование шаблона и вернуться на страницу конфигурации.

Пример сформированного шаблона журнала приведен на рис. 3.

Рис. 3. Пример сформированного шаблона

В соответствии с этим шаблоном каждая запись журнала будет содержать следующие сведения:

– дату и время записи,

– идентификатор ключа, лицензия которого используется,

– идентификатор пользователя,

– длительность сеанса использования лицензии,

– идентификатор компонента,

– тип запроса, например, получение лицензии (LOGIN), освобождение лицензии (LOGOUT).

– IP адрес сервера лицензий,

– код результата выполнения запроса.

Элемент newline обеспечивает перевод строки в журнале.

Код результата выполнения запроса может быть использован для анализа возможных неудач при выполнении запросов. Например, значение кода, равное 0, соответствует успешному выполнению запроса. Значение кода, равное 7, возвращается в случае, если ключ аппаратной защиты не найден.

Фрагмент файла журнала, сформированного по шаблону, показанному на рис. 3, приведен ниже.

2009-01-23 11:30:00 HASP ID:1086818230 ID пользователя:Test@Tester длительность сеанса: 0 days 0 hours 0 minutes 0 seconds ID компонента:120 тип запроса:LOGIN IP сервера лицензий: 127.0.0.1 код результата:0

2009-01-23 11:31:54 HASP ID:1086818230 ID пользователя:Test@Tester длительность сеанса: 0 days 0 hours 1 minutes 54 seconds ID компонента:120 тип запроса:LOGOUT IP сервера лицензий: 10.3.1.2 код результата:0

Помимо записей, содержащих сведения об использовании лицензий пользователями, журнал отчета содержит большое количество других сведений. Для удобства анализа журнала целесообразно обеспечить фильтрацию его содержания, например, средствами текстового редактора.


4.1.3. Парольная защита ACC

Команда Смена пароля (Change Password) позволяет задать пароль ACC.

При использовании программного обеспечения HASP паролем защищаются следующие действия:

– отключение пользователя от лицензии (см. раздел 3.6),

– изменение конфигурации ACC.

Чтобы задать пароль, необходимо вызвать команду Смена пароля (Change Password). В окне браузера появится страница Изменение пароля (Change Password). В поле Текущий пароль администратора (Current Admin Password) необходимо ввести текущий пароль.

По умолчанию пароль не задан. При первом задании пароля следует оставить поле Текущий пароль администратора пустым.

В поле Новый пароль (New Admin Password) необходимо ввести новый пароль и повторно ввести его в поле Подтверждение нового пароля (Re-enter new Admin Password). После задания нового пароля необходимо вызвать команду Применить (Submit). Чтобы отказаться от изменений, вызовите команду Отмена (Cancel).

Вкладка задания пароля будет закрыта. Активной станет вкладка Общие настройки (Basic Settings).

Прежний пароль продолжает действовать в течение сеанса работы браузера. Чтобы изменения вступили в силу, необходимо перезапустить браузер.

Чтобы изменения настроек, выполненные на вкладке Общие настройки, вступили в силу, вызовите команду Применить (Submit). Команда Сбросить настройки (Set Defaults) позволяет вернуть все настройки к умолчательным значениям.

Действие команды Сбросить настройки не распространяется на установленный пароль.


4.2. Пользователи (Users)

Настройки, выполняемые на вкладке Пользователи, позволяют явно указать имена пользователей, которым разрешен или запрещен доступ к Менеджерам лицензий, и имена компьютеров, на которых установлены Менеджеры лицензий, к которым выполняются попытки доступа.

Описание элементов управления вкладки приведено в табл. 9.

Табл. 9. Элементы управления вкладки Пользователи
Имя элемента управления | Описание
Ограничения доступа (User Restrictions) | Поле позволяет задать правила разрешений/ограничений, применяемые при попытках доступа к Менеджеру лицензий со стороны пользователей.

Правила имеют следующий формат:

<restricrion>=[username]@[hostname]

Описание параметров приведено в табл.10.

Табл. 10. Элементы правил разграничения доступа
Обозначение параметра | Наименование | Возможные значения | Описание
restriction | Тип ограничения | allow | разрешено
 |  | deny | запрещено
hostname | Имя компьютера | test-2 |
 |  | all | все компьютеры сети
 |  | none | ни один компьютер сети
username | Имя пользователя | User1, testuser |
 |  | all | все пользователи сети
 |  | none | ни один из пользователей

Параметры hostname и username являются необязательными. Отсутствие параметра при вводе строки соответствует его значению, равному all.

Например, если задать правило вида allow=[username], то доступ к Менеджеру лицензий для пользователя [username] будет разрешен вне зависимости от того, на каком компьютере в сети установлен Менеджер лицензий.

Если при вводе строка задана в виде allow=[username], то после подтверждения изменений конфигурации командой Применить (Submit) она будет преобразована к виду allow=[username]@all.

Аналогично, если задать строку вида allow=@[hostname], то доступ к Менеджеру лицензий, установленному на компьютере [hostname], будет разрешен вне зависимости от того, какой пользователь выполняет доступ.

Если при вводе строка задана в виде allow=@[hostname], то после подтверждения изменений конфигурации командой Применить она будет преобразована к виду allow=all@[hostname].

Каждое правило должно быть записано в отдельной строке. Правила обрабатываются по порядку следования сверху вниз. Обработка правил прекращается после нахождения первого соответствия условий.

Примеры обработки правил приведены в табл. 11. Предполагается, что все правила записаны в поле Ограничения доступа (User Restriction) в том порядке, в котором они расположены в таблице.

Табл. 11. Примеры обработки правил разграничения доступа
Правило | Описание обработки правила, выполняемое ACC
deny=User1@seat1 | Пользователю User1 запрещен доступ к Менеджеру лицензий, установленному на компьютере seat1.
allow=User1@all | Пользователю User1 разрешен доступ ко всем компьютерам, за исключением seat1. Запрет определяется предыдущим правилом.
allow=User2@all | Пользователю User2 разрешен доступ ко всем компьютерам.
deny=all@seat2 deny=all@seat3 deny=all@seat4 | Всем пользователям запрещен доступ к Менеджерам лицензий, установленным на компьютерах seat2, seat3, seat4, за исключением пользователей User1 и User2. Правила доступа этих пользователей уже обработаны.

Команда Недавние пользователи (Show Recent Users) позволяет отобразить список пользователей, выполнявших доступ к Менеджерам лицензий последними.

Чтобы изменения настроек, выполненные на этой вкладке, вступили в силу, вызовите команду Применить (Submit). Команда Отмена (Cancel) позволяет отказаться от изменений в настройках. Команда Сбросить настройки (Set Defaults) позволяет вернуть все настройки к умолчательным значениям.


4.3. Доступ к удаленным Менеджерам лицензий (Access to Remote License Managers)

4.3. Доступ к удаленным Менеджерам лицензий
(Access to Remote License Managers)

Элементы управления, расположенные на вкладке Доступ к удаленным Менеджерам лицензий, позволяют указать имена компьютеров, с установленными Менеджерами лицензий, к которым может быть выполнен доступ.

Описание элементов управления вкладки приведено в табл. 12.

Табл. 12. Элементы управления вкладки Доступ к удаленным Менеджерам лицензий
Имя элемента управления | Описание
Доступ к удаленным лицензиям (Allow Access to Remote Licenses) | Опция позволяет управлять доступом к Менеджерам лицензий других компьютеров сети с текущего компьютера. По умолчанию включена.
Широковещательный поиск (Broadcast Search for Remote Licenses) | Опция позволяет управлять поиском компьютеров с установленными Менеджерами лицензий в сети. Если опция выключена, имена компьютеров, среди которых будет выполнен поиск Менеджеров лицензий, должны быть явно указаны в поле Параметры поиска (Specify Search Parameters). Если опция включена, поиск будет выполняться среди всех компьютеров (широковещательный поиск).
Агрессивный поиск (Aggressive Search for Remote Licenses) | Опция позволяет управлять способом поиска компьютеров с установленными Менеджерами лицензий. Если она включена, доступ к удаленным Менеджерам лицензий будет доступным даже в случае невозможности их обнаружения стандартными средствами поиска протокола UDP. «Агрессивный» способ поиска уменьшает частоту обновления информации о состоянии системы HASP, однако может позволить обходить файерволы.
Параметры поиска (Specify Search Parameters) | Поле позволяет явно указать имена компьютеров, среди которых будет выполнен поиск Менеджеров лицензий. Адреса компьютеров могут быть заданы следующими способами: – IP-адрес компьютера, например, 10.3.1.37; – сетевое имя компьютера, например, test-2; – широковещательный адрес, например, 10.3.1.255. При использовании протокола Ipv6 следует записывать адреса в формате этого протокола. Каждый адрес должен располагаться на отдельной строке.

Чтобы изменения настроек, выполненные на этой вкладке, вступили в силу, вызовите команду Применить (Submit). Команда Отмена (Cancel) позволяет отказаться от изменений в настройках. Команда Сбросить настройки (Set Defaults) позволяет вернуть все настройки к умолчательным значениям.


4.4. Доступ с удаленных клиентов (Access from Remote Clients)

Элементы управления, расположенные на вкладке Доступ с удаленных клиентов, позволяют настроить следующие параметры:

– имена компьютеров, пользователям которых разрешен или запрещен доступ к Менеджеру лицензий текущего компьютера,

– правила доступа к Менеджеру лицензий.

Описание элементов управления вкладки приведено в табл. 13.

Табл. 13. Элементы управления вкладки Доступ Удаленных клиентов
Имя элемента управления | Описание
Доступ с удаленных клиентов (Allow access from Remote Clients) | Опция позволяет управлять доступом удаленных пользователей к Менеджеру лицензий текущего компьютера.
Ограничения доступа (Access Restrictions) | Поле позволяет задать правила разрешений/ограничений, применяемые при попытках доступа к Менеджеру лицензий со стороны пользователей.

Правила имеют следующий формат:

<restricrion>=[item]

Описание параметров приведено в табл.14.

Табл. 14.
Обозначение параметра | Наименование | Возможные значения | Описание
restriction | Тип ограничения. | allow | разрешено
 |  | deny | запрещено
item | IP-адрес компьютера или имя компьютера в сети. | 10.3.1.27 или TEST2 |
 |  | all | все компьютеры сети
 |  | none | ни один компьютер сети

Каждое правило должно быть записано в отдельной строке. Правила обрабатываются по порядку следования сверху вниз. Обработка правил прекращается после нахождения первого соответствия условий.

Команда Показать недавних клиентов (Show Recent Client Access) позволяет просмотреть список компьютеров, с которых был выполнен доступ к Менеджеру лицензий текущего компьютера за последнее время.

Чтобы изменения настроек, выполненные на этой вкладке, вступили в силу, вызовите команду Применить (Submit). Команда Отмена (Cancel) позволяет отказаться от изменений в настройках. Команда Сбросить настройки (Set Defaults) позволяет вернуть все настройки к умолчательным значениям.


5. Дистанционное перепрограммирование ключа аппаратной защиты

Приложение VIII. Защита КОМПАС-3D

5. Дистанционное перепрограммирование
ключа аппаратной защиты

Дистанционное перепрограммирование ключа производится с помощью программы системы дистанционного обновления HASP Remote Update System.

В этом разделе:

5.1. Общий порядок действий для обновления лицензий

5.2. Формирование файла статуса ключа

5.3. Отправка файла статуса

5.4. Перепрограммирование ключа после получения ответа

5.5. Установка компонентов системы КОМПАС-3D


5.1. Общий порядок действий для обновления лицензий

При покупке программного обеспечения КОМПАС вы получаете сетевые или локальные аппаратные ключи. В памяти ключей содержатся сведения о наборе модулей КОМПАС, которые были оплачены и с которыми, следовательно, разрешено работать пользователю.

В дальнейшем может возникнуть необходимость изменить лицензионные условия, например, приобрести дополнительные модули системы КОМПАС-3D и установить их на тот же компьютер, изменить количество лицензий и т.п.

Чтобы изменить лицензионные условия, необходимо выполнить следующие действия.

1. Оформить договор об изменении лицензионных условий.

2. Сформировать файл статуса ключа, содержащий сведения о состоянии лицензий пользователя.

3. Отправить файл статуса в компанию АСКОН по электронной почте.

4. Оплатить добавляемые компоненты.

5. Получить файл ответа из компании АСКОН.

6. Перепрограммировать ключ, записав в его память информацию о вновь приобретенных модулях.

7. Установить оплаченные компоненты системы КОМПАС-3D.


5.2. Формирование файла статуса ключа

Формирование файла статуса ключа и перепрограммирование ключа производится с помощью программы HASP SRM Remote Update System (далее HASP SRM RUS). Исполняемым файлом программы является hasprusa.exe.

Для запуска HASP SRM RUS вызовите команду главного меню Windows Пуск — Программы — АСКОН — КОМПАС-3D V... — Программы ключа защиты — Обновление лицензий. Можно также запустить файл hasprusa.exe, расположенный в папке \HASP главной папки КОМПАС-3D.

После запуска программы на экране появляется окно HASP SRM RUS (рис. 4).

Рис. 4. Окно программы обновления лицензий; вкладка сбора сведений

По умолчанию раскрыта вкладка сбора сведений о состоянии лицензий на ключе Collect Key Status Information.

Чтобы подготовить файл статуса ключа, выполните следующие действия.

1. Вставьте аппаратный ключ в разъем порта компьютера.

2. Нажмите кнопку Collect information.

На экране появится стандартный диалог сохранения файлов Windows. По умолчанию файл статуса ключа имеет расширение c2v (от customer to vendor).

3. Введите имя файла запроса и закройте диалог.

В окне программы появится сообщение об успешном выполнении операции Key status retrieved from HASP successfully. Сформированный файл будет сохранен в указанной папке.

Если при выполнении операции программа не обнаружит ключ, на экране появится предупреждающее сообщение (рис 5).

Рис. 5. Сообщение HASP SRM RUS, если ключ не обнаружен

В таком случае необходимо вставить ключ аппаратной защиты в USB порт и повторить операции.

Если при выполнении операции программа обнаружит несколько ключей, на экране появится диалог Select HASP (рис 6).

Рис. 6. Сообщение HASP SRM RUS, если обнаружено несколько ключей

В таком случае необходимо выбрать мышью обозначение одного из ключей и нажать кнопку ОК либо отключить все ключи, кроме нужного, и нажать кнопку Refresh.

Если необходимо обновить лицензии на нескольких ключах, следует выполнить рассмотренные операции для каждого из них поочередно. Для каждого ключа будет сформирован файл статуса.


5.3. Отправка файла статуса

Завершив подготовку файлов статуса ключей, отправьте их в компанию АСКОН по электронной почте, сопроводив необходимыми комментариями.

Рекомендуется контактировать с тем офисом, в котором было первоначально приобретено программное обеспечение компании АСКОН. Если вы приобрели систему КОМПАС-3D у регионального дилера, можно выполнить процедуру обновления ключей с его помощью.


5.4. Перепрограммирование ключа после получения ответа

После того как вы оплатите заказанные дополнительные модули системы КОМПАС-3D, компания АСКОН вышлет вам файлы, содержащие обновления лицензий.

Файлы обновления могут поставляться в следующих форматах:

– файл с расширением v2c (от vendor to customer).

– исполняемый файл с расширением exe.

Для перепрограммирования ключа с использованием файла с расширением v2c выполните следующие действия.

1. Вставьте аппаратный ключ в разъем порта компьютера.

2. Запустите программу HASP SRM RUS и в появившемся на экране окне программы раскройте вкладку обновления лицензий Apply License Update (рис. 7).

Рис. 7. Окно программы обновления лицензий; вкладка обновления лицензии

3. Нажмите кнопку поиска файла обновления Browse for update file. На экране появится стандартный диалог открытия файлов Windows.

4. Откройте полученный от компании АСКОН файл обновления.

5. Нажмите кнопку Apply Update.

Данные о дополнительных продуктах, содержащиеся в файле обновления лицензии и соответствующие текущему ключу, будут записаны в этот ключ. После успешной записи данных в ключ на экране появляется сообщение об этом.

Если необходимо обновить лицензии на нескольких ключах, следует выполнить рассмотренные операции для каждого из них поочередно.

Если файл обновления предоставлен поставщиком в виде исполняемого файла, имеющего расширение exe, для обновления лицензий необходимо запустить этот файл на выполнение. Программа HASP SRM RUS будет запущена автоматически.


5.5. Установка компонентов системы КОМПАС-3D

После перепрограммирования ключа аппаратной защиты можно установить компоненты системы КОМПАС-3D, лицензии на которые получены. Для этого следует выполнить следующие действия.

– Выберите часть инсталляционного пакета системы КОМПАС-3D, к которой относятся вновь устанавливаемые компоненты (Базовый пакет или одна из конфигураций).

– Запустите установку выбранной части.

– В диалоге Обслуживание программы Мастера установки выберите вариант Изменить.

– В последующих диалогах Мастера установки укажите необходимые компоненты и установите их.


6. Обновление прошивки ключа

Приложение VIII. Защита КОМПАС-3D

6. Обновление прошивки ключа

Прошивка ключей аппаратной защиты HASP HL, полученных от поставщика при покупке системы КОМПАС-3D предыдущих версий, может быть обновлена до версии 3.21. Эта версия прошивки поддерживает полную функциональность системы защиты HASP SRM. Для обновления прошивки следует использовать программу обновления, исполняемым файлом которой является FirmwareUpdate.exe. Этот файл находится в папке KOMPAS-3D_V...\KOMPAS-3D\Support установочного диска.

Подключите ключ, прошивку которого следует обновить.

Чтобы запустить программу, откройте ее исполняемый файл. На экране появится окно HASP SRM RUS (рис 8).

Рис. 8. Окно программы обновления прошивки

Кнопка Apply Update позволяет обновить прошивку ключа аппаратной защиты. После обновления прошивки окно программы следует закрыть.


Приложение IX. Кривые и поверхности

В этом разделе:

1. Параметрическое представление кривой

2. Параметрическое представление поверхности. Изопараметрические кривые

3. Сплайновые кривые и поверхности. Порядок кривых. Вес точек

4. Базисные векторы в точке кривой

5. Кривизна кривой. Соприкасающаяся окружность

6. Условия сопряжения кривых и поверхностей

7. Конические кривые


1. Параметрическое представление кривой

Приложение IX. Кривые и поверхности

1. Параметрическое представление кривой

В общем случае кривая математически описана в файле модели как геометрическое место точек, координаты которых в пространстве определяются функциями от одного параметра t:

x = x(t),

y = y(t),

z = z(t),

где параметр t ограничен предельными значениями tmin Ј t Ј tmax.

Такое описание кривой является ее параметрическим представлением.

Параметрическая область кривой — это множество значений параметра t, представленное в виде отрезка прямой (см. рис. 1, а). Кривая является отображением этого отрезка в трехмерное пространство модели. Каждому значению параметра t соответствует определенная точка на кривой (см. рис. 1, б).

Рис. 1. Полукубическая парабола (парабола Нейля): а) параметрическая область кривой — значения параметра t; б) отображение значений параметра t на кривую в трехмерном пространстве
а) | б)

Обратите внимание на то, что в общем случае точки, равномерно разбивающие параметрическую область кривой, отображаются в точки кривой, разбивающие ее неравномерно.

Рассмотрим параметрическое представление полукубической параболы (параболы Нейля).

Уравнение кривой (или закон кривой):

y 2 = a 2· x 3, a > 0.

Параметрическое представление кривой:

x = t 2,

y = a · t 3,

z = 0,

-Ґ < t <+Ґ.


2. Параметрическое представление поверхности. Изопараметрические кривые

Приложение IX. Кривые и поверхности

2. Параметрическое представление поверхности.
Изопараметрические кривые

Поверхность описана в файле модели как геометрическое место точек, координаты которых определяются функциями от двух параметров U и V:

x = x(U; V),

y = y(U; V),

z = z(U; V),

где параметры U и V ограничены предельными значениями Umin Ј U Ј Umax, Vmin Ј V Ј Vmax.

Такое описание поверхности является ее параметрическим представлением.

Параметрическая область поверхности — это множество значений параметров U и V, представленное в виде плоской прямоугольной области. Поверхность является отображением этой области в трехмерное пространство модели. Каждой паре значений параметров U и V соответствует определенная точка на поверхности.

Если значение одного из параметров U или V зафиксировать, а другой изменять, то получится кривая, лежащая на поверхности. Эта кривая называется изопараметрической. Кривые, полученные изменением параметра U при зафиксированном параметре V, считаются изопараметрическими кривыми направления U, а кривые, полученные изменением параметра V при зафиксированном параметре U — изопараметрическими кривыми направления V. Кривые обоих направлений образуют изопараметрическую сеть, которая позволяет увидеть на экране теоретическую поверхность, соответствующую грани. Обычно показываются по пять кривых каждого направления, соответствующих значениям 0, 25, 50, 75, 100 параметров U или V (рис. 2). Например, изопараметрическая сеть отображается при построении точки способом На поверхности.

Границы теоретической поверхности не обязательно совпадают с контуром грани, но грань всегда находится в границах своей теоретической поверхности. Кроме того, теоретическая поверхность, в отличие от грани, не имеет отверстий.

Рис. 2. Пример изопараметрической сети


3. Сплайновые кривые и поверхности. Порядок кривых. Вес точек

Приложение IX. Кривые и поверхности

3. Сплайновые кривые и поверхности. Порядок кривых. Вес точек

Сплайновые кривые и поверхности, построенные с использованием неоднородных рациональных В-сплайнов (NURBS), определяются следующими параметрами: набором точек, называемых полюсами, и порядком.

При построении кривой полюсы можно указывать произвольно, а для создания поверхности набор полюсов должен представлять собой сетку, построенную по параметрической области поверхности (см. раздел 2 Приложения IX), т.е. полюсы должны быть расположены рядами с одинаковым количеством полюсов в каждом. Изопараметрические кривые будущей поверхности пройдут вдоль этих рядов.

Очевидно, что форма сплайновой кривой или поверхности определяется расположением полюсов в пространстве. Поверхности, построенные по полюсам, обладают весьма полезным для моделирования свойством локальной деформации: при изменении положения одного полюса меняется форма только части поверхности вблизи этого полюса, а не вся поверхность.

Порядок сплайна в случае кривой равен числу, которое на единицу больше максимальной степени полиномов, описывающих участки этой кривой.

Количество полюсов может быть больше или равно порядку, но не меньше порядка. Порядок не может быть меньше 2. Частные случаи сплайновых кривых приведены на рисунке 3.

Рис. 3. Частные случаи сплайновых кривых: а) линейная кривая (количество полюсов — 2, порядок — 2, степень полинома — 1), б) коническая кривая (количество полюсов — 3, порядок — 3, степень полинома — 2), в) кубическая кривая (количество полюсов — 4, порядок — 4, степень полинома — 3)
а) | б) | в)

При построении сплайновой поверхности необходимо указать два значения, определяющих порядок по каждому из ее направлений: U и V. Заданный порядок будут иметь изопараметрические кривые соответствующих направлений.

Увеличение порядка сплайна до значений больше 6 на практике редко используется в связи с тем, что это значительно усложнит (и, следовательно, замедлит) вычисления при операциях с кривыми и поверхностями.

Дополнительным параметром, влияющим на форму сплайновой кривой или поверхности, является вес каждого полюса. Геометрический смысл этого параметра следующий: чем больше вес полюса, тем ближе к нему расположена кривая (поверхность), т.е. полюсы с большим весом «притягивают» сплайн сильнее, чем полюсы с маленьким весом.

Например, на рисунке 4 показано, как меняется форма кривой при увеличении веса одного из полюсов. Положение I кривой соответствует случаю, когда все полюсы имеют единичный вес, положение II — случаю, когда полюс 4 имеет вес 2, а положение III — случаю, когда он имеет вес 6.

Рис. 4. Влияние веса полюса на форму кривой

Форму кривой определяют не абсолютные веса полюсов, а разница между ними, т.е. при изменении весов всех полюсов в одно и то же число раз вид кривой не изменится.


4. Базисные векторы в точке кривой

Приложение IX. Кривые и поверхности

4. Базисные векторы в точке кривой

С каждой точкой кривой связаны три взаимно перпендикулярные плоскости: нормальная, соприкасающаяся и спрямляющая, а также три взаимно перпендикулярных базисных вектора: касательный t, главной нормали n и бинормали b (см. рис. 5).

Рис. 5. Базисные векторы в точке кривой

Касательный вектор и вектор главной нормали лежат в соприкасающейся плоскости, а вектор бинормали ей перпендикулярен.

Соприкасающаяся плоскость — это плоскость, стремящаяся принять положение плоскости, проходящей через три точки кривой М, М1, М2, при условии, что точки M1 и М2 стремятся к точке М (см. рис. 6).

Рис. 6. Соприкасающаяся плоскость

Плоскость, в которой лежат касательный вектор и вектор бинормали — это спрямляющая плоскость, а плоскость, в которой лежат вектор главной нормали и вектор бинормали — это нормальная плоскость.


5. Кривизна кривой. Соприкасающаяся окружность

Приложение IX. Кривые и поверхности

5. Кривизна кривой. Соприкасающаяся окружность

Кривизна кривой в точке M — величина, характеризующая отклонение кривой в окрестности точки от касательной прямой в этой точке.

Кривизну кривой в точке М можно определить с помощью окружности, соприкасающейся с ней в этой точке.

Соприкасающейся окружностью называется предельное положение окружности, когда она проходит через точку М и две другие бесконечно близкие к ней точки М1 и М2 (см. рис. 7). Соприкасающаяся окружность лежит в соприкасающейся плоскости кривой в точке М (о соприкасающейся плоскости см. раздел 4 Приложения IX).

Рис. 7. Соприкасающаяся окружность в точке М кривой

Центр окружности, соприкасающейся с кривой в точке М, является центром кривизны (O) кривой в данной точке, а радиус этой окружности — радиусом кривизны R кривой в данной точке.

Радиус кривизны (R) является величиной, обратной кривизне (К): R=1/K.

Центр кривизны кривой всегда находится на главной нормали.


6. Условия сопряжения кривых и поверхностей

Приложение IX. Кривые и поверхности

6. Условия сопряжения кривых и поверхностей

Условие сопряжения определяет форму создаваемой кривой или поверхности вблизи места соединения ее с существующей кривой или поверхностью. Эта существующая кривая или поверхность по отношению к создаваемой является объектом сопряжения. Кривые сопрягаются друг с другом и с поверхностями в точке сопряжения, а поверхности сопрягаются вдоль кривой — границы сопряжения.

Результат сопряжения кривых и поверхностей при выполнении различных условий сопряжения описан в табл. 1. Также в таблице показаны примеры соединения кривых с разными условиями сопряжения. Слева на рисунках находится кривая — объект сопряжения, а справа — сопрягаемая кривая; точка сопряжения отмечена кружком.

Табл. 1. Условия сопряжения кривых и поверхностей
Условие сопряжения | Результат сопряжения
Не задано Конечная точка кривой или граница поверхности принадлежит объекту сопряжения. |
По касательной Выполняется условие Не задано. Кроме этого, выполняется условие: – для кривой: в точке сопряжения кривая и объект сопряжения имеют общую касательную1, – для поверхности: в точках границы сопряжения изопараметрические кривые сопрягаемой поверхности и поверхности сопряжения имеют общую касательную. |
Перпендикулярно Выполняется условие Не задано. Кроме этого, выполняется условие: – для кривой: в точке сопряжения касательные кривой и объекта сопряжения перпендикулярны, – для поверхности: в точках границы сопряжения касательные к изопараметрическим кривым сопрягаемой поверхности и поверхности сопряжения перпендикулярны. |
Гладкое Выполняется условие По касательной. Кроме этого, выполняется условие: – для кривой: в точке сопряжения кривизна кривой равна кривизне объекта сопряжения1, – для поверхности: в точках границы сопряжения изопараметрические кривые сопрягаемой поверхности и поверхности сопряжения имеют одинаковую кривизну. |
  1. Если объект сопряжения — поверхность, то для сопряжения дополнительно указывается кривая, лежащая на этой поверхности и проходящая через точку сопряжения.

В некоторых системах трехмерного моделирования сопряжение кривых или поверхностей с условием Не задано называется «сопряжением с непрерывностью G0», По касательной — «сопряжением с непрерывностью G1», Гладкое — «сопряжением с непрерывностью G2».


7. Конические кривые

Приложение IX. Кривые и поверхности

7. Конические кривые

Конические кривые или кривые конических сечений — плоские кривые линии, получаемые при пересечении прямого кругового конуса с плоскостями, различно расположенными по отношению к оси конуса.

Существуют три типа конических сечений:

– Секущая плоскость пересекает все образующие конуса в точках одной его полости; линией пересечения является замкнутая кривая — эллипс (рис. 8, а). Окружность как частный случай эллипса получается, когда секущая плоскость перпендикулярна оси конуса. Если плоскость проходит через вершину конуса, не пересекая при этом ни одной его полости, окружность вырождается в точку.

– Секущая плоскость параллельна одной из образующих конуса; в сечении получается незамкнутая, уходящая в бесконечность кривая — парабола, целиком лежащая на одной полости конуса (рис. 8, б). Если плоскость касается поверхности конуса по образующей, парабола вырождается в две совпавшие прямые.

– Секущая плоскость пересекает обе полости конуса; линия пересечения — гипербола — состоит из двух незамкнутых уходящих в бесконечность частей (ветвей гиперболы), лежащих на обеих полостях конуса (рис. 8, в). Если секущая плоскость проходит через ось конуса, гипербола вырождается в две пересекающиеся прямые.

Рис. 8. Конические сечения: а) эллипс, б) парабола, в) гипербола
а) | б) | в)

В алгебраических терминах конические сечения определяются как плоские кривые, координаты которых в декартовой системе координат удовлетворяют уравнению второй степени. Уравнение всех конических сечений можно записать в общем виде как

Ax2 + Bxy + Cy2 + Dx + Ey + F = 0

Знак дискриминанта B2 - 4AC определяет тип конического сечения:

– если дискриминант меньше нуля, то это эллипс (или точка),

– если дискриминант равен нулю, то это парабола (или прямая),

– если дискриминант больше нуля, то это гипербола (или пара пересекающихся прямых).

В параметрическом виде коническая кривая может быть представлена уравнениями:

– парабола

x = t

y = a * t2 + b * t + c

-Ґ < t <+Ґ

– гипербола

• левая ветвь

x = -a * (et + e-t) / 2

y = b * (et - e-t) / 2

-Ґ < t <+Ґ

• правая ветвь

x = a * (et + e-t) / 2

y = b * (et - e-t) / 2

-Ґ < t <+Ґ

– эллипс

x = a * cos (t)

y = b * sin (t)

0 < t < 2 p

Параметрические уравнения конических кривых могут быть использованы для их построения с помощью команды Кривая по закону (см. раздел 2.5.4.12). Эти уравнения доступны в разделе Законы диалога Вставка математического выражения (см. рис. 5.1.7).

При графическом построении коническая кривая может быть задана произвольным набором n своих точек и m касательных, при условии, что n + m = 5. Один из наиболее употребительных способов задания конической кривой — задание ее двумя касательными, точками касания на них и коэффициентом k (инженерным дискриминантом).

Коэффициент k (инженерный дискриминант) — отношение части медианы треугольника АВС, расположенной под кривой, к полной величине медианы треугольника (рис. 9, а).

Для параболы значение коэффициента k равно 0,5.

Для эллипса значение k больше 0, но меньше 0,5 (0 < k < 0,5).

Для гиперболы значение k больше 0,5, но меньше 1 (0,5 < k < 1).

Рис. 9. Зависимость типа конической кривой от величины коэффициента: а) парабола; б) эллипс; в) гипербола
а) | б) | в)

Точка пересечения конической кривой с медианой треугольника может быть задана высотой.

Высота h конической кривой — расстояние от точки пересечения кривой с медианой треугольника до стороны, к которой проведена медиана (рис. 10).

Рис. 10. Высота конической кривой


Выбор файла-источника вставки

При редактировании свойств модели, вставленной из файла в качестве компонента, вы можете выбрать другую модель — источник вставки. Для этого используются элементы вкладки Файл-источник.

Имя файла-источника вставки отображается в поле Файл-источник. Чтобы выбрать другой файл, нажмите кнопку, расположенную справа от этого поля. На экране появится диалог выбора файлов.

Укажите нужный файл модели.

Если выбранная модель содержит исполнения, то в правой части диалога отображается раскрывающийся список исполнений. Выберите обозначение нужного исполнения из списка.

Модель с исполнениями может также содержать дополнительные номера. Если такая модель вставляется в текущую модель в качестве компонента, то в диалоге выбора файлов отображается не только список исполнений, но и список дополнительных номеров. Выберите нужный дополнительный номер из списка.

Для завершения выбора файла модели нажмите кнопку Открыть.

В дальнейшем вы можете перевыбрать исполнение или дополнительный номер вставленной модели, используя списки Исполнение и Дополнительный номер Панели свойств.

Списки Исполнение и Дополнительный номер присутствуют на Панели свойств при редактировании не только указанных выше компонентов, но и локальной детали или детали-заготовки, вставленной без истории, если источником вставки была модель, содержащая исполнения и дополнительные номера.


Элементы управления положением компонента(способ По координатам)

Элементы управления положением компонента
(способ По координатам)

Элементы управления положением компонента (модели из файла или библиотеки, локальной детали, детали-заготовки) при его вставке или редактировании расположены на вкладке Размещение Панели свойств. Набор элементов вкладки зависит от способа размещения компонента. Нужный способ выбирается с помощью группы переключателей Способ размещения.

Элементы управления для способа размещения По координатам приведены в таблице.

Способ размещения По координатам

Элемент

Описание

Опорная точка

Группа элементов позволяет задать точку вставки компонента. С этой точкой будет совпадать начало текущей системы координат компонента.

Вы можете указать положение точки вручную или ввести ее координаты в поле Панели свойств.

При ручном указании точку вставки можно указать произвольно или используя привязку (например, к началу координат или к вершине). Для выполнения привязки подведите курсор к нужному объекту и, когда рядом с ним появится значок этого объекта, щелкните левой кнопкой мыши. Привязку к началу текущей системы координат можно выполнить с помощью клавиатуры. Для этого нажмите комбинацию клавиш <Ctrl>+<0>, а затем — клавишу <Enter>.

Кроме того, можно задать положение точки вставки путем построения точки. Для этого используется кнопка Построение точки на Панели специального управления. Обратите внимание на то, что в данном случае процесс построения точки используется только для определения положения точки вставки. Новая точка при этом не создается.

Положение точки вставки фиксируется с помощью опции, расположенной рядом с полем ввода координат. Включенному состоянию опции (т.е. зафиксированному положению точки вставки) соответствует значок «крестик», а отключенному — значок «галочка». После ручного указания точки, ввода ее координат или создания опорной точки опция автоматически включается.

Направление осей

Группа элементов позволяет задать положение осей системы координат компонента.

Чтобы выбрать ось, направление которой требуется задать, активизируйте соответствующий переключатель:

– Направляющий объект оси Х,

– Направляющий объект оси Y,

– Направляющий объект оси Z.

На Панели свойств появятся дополнительные элементы управления.

Укажите направляющий объект в окне модели. Его наименование появится в поле отображения направляющего объекта.

Если требуется сменить направление выбранной оси на противоположное, нажмите кнопку Перевернуть ось X/Y/Z рядом с полем. Подробнее...

Углы Эйлера

Поле позволяет задать ориентацию осей с помощью углов Эйлера. В поле вводятся углы нутации, прецессии и вращения.

В случае выбора направляющих объектов для задания положения осей координат углы рассчитываются автоматически, их значения появляются в поле. Вы можете изменить значения углов. При этом произведенный ранее выбор направляющих объектов отменяется.

СК компонента

Список позволяет выбрать СК компонента, начало которой совмещается с заданной точкой вставки. После выбора СК положение компонента изменяется.

Список доступен, если модель — источник компонента содержит локальные системы координат.

При необходимости вы можете изменить положение СК компонента. Для этого нажмите кнопку Изменить положение СК компонента на Панели специального управления. Подробнее...

СК текущего документа

Список позволяет выбрать СК текущей модели для определения координат компонента. Он доступен, если текущая модель содержит локальные системы координат. В этом случае на Панели свойств рядом со списком присутствует опция Сохранять положение. Эта опция управляет изменением положения компонента в модели.

Если СК выбирается при включенной опции, то положение компонента в модели не изменяется, изменяются значения координат его точки вставки.

Если СК выбирается при отключенной опции, то координаты точки вставки компонента остаются неизменными, но откладываются в выбранной системе координат. Положение компонента в модели изменяется.

Положением компонента в модели можно управлять с помощью элемента базирования.

Смотрите также

Задание параметров положения компонента


Элементы управления положением компонента(способ По сопряжениям)

Элементы управления положением компонента
(способ По сопряжениям)

Элементы управления положением компонента (модели из файла или библиотеки, локальной детали, детали-заготовки) при его вставке или редактировании расположены на вкладке Размещение Панели свойств. Набор элементов вкладки зависит от способа размещения компонента. Нужный способ выбирается с помощью группы переключателей Способ размещения.

Элементы управления для способа размещения По сопряжениям приведены в таблице. Кроме того, при выборе данного способа в окне модели отображается Окно модели-источника. Оно используется для выбора объектов компонента.

Окно модели-источника не отображается при вставке/редактировании модели из библиотеки.

Описание элементов управления

Элемент

Описание

Объект сборки

Поле для отображения наименования сопрягаемого объекта текущей модели. Объект указывается в Дереве построения или в окне модели.

Объект компонента

Поле для отображения наименования сопрягаемого объекта компонента. Объект указывается в Дереве построения или в окне текущей модели. Объект также может быть указан в Окне модели-источника.

Выбор сопряжения

Группа переключателей позволяет выбрать тип позиционирующего сопряжения, которое требуется создать. После активизации переключателя запускается процесс создания сопряжения соответствующего типа.

Сопрягаемые объекты можно выбрать до активизации переключателя или после, находясь в процессе создания сопряжения. В первом случае доступны только переключатели тех сопряжений, которые можно создать для выбранных объектов.

После завершения создания сопряжения система возвращается к выполнению исходной команды.

Подробнее...

Сопряжения

Панель для отображения списка созданных сопряжений. Данная панель позволяет выполнить следующие действия:

– включить сопряжение в расчет или исключить его из расчета, включив/отключив соответствующую ему опцию,

– отредактировать параметры сопряжения, выбрав его в списке и нажав кнопку Редактировать.

– удалить сопряжение, выбрав его в списке и нажав кнопку Удалить.

Смотрите также

Задание параметров положения компонента


Команда Закрыть просмотр

Позволяет завершить работу в режиме предварительного просмотра для печати и вернуться к редактированию документов.

Для вызова команды нажмите кнопку Закрыть просмотр на инструментальной панели или выберите ее название из меню Файл.


Файл соответствия типов и стилей линий (*.ALS)

Текстовый файл, содержащий соответствия между типами линий системы AutoCAD и стилями линий чертежно-графического редактора системы КОМПАС-3D.

Пример файла *.ALS:

Continuous | 1 | 0 | 0.4 |

Center | 5 | 2 | 0.18 |

Dashed | 50 | 3 | 0.18 |

Divide | 130 | 5 | 0.18 |

FENCELINE2 | 7 | 6 | 0.18 | D:\KOMPAS V...\sys\Graphic.lcs |

В каждой строке этого файла записано одно соответствие следующим образом: название типа линии в AutoCAD, вертикальная черта, номер цвета линии в AutoCAD, вертикальная черта, номер системного стиля линии КОМПАС или номер стиля в библиотеке, вертикальная черта, значение толщины линии в миллиметрах, вертикальная черта, абсолютный путь к файлу библиотеки стилей линий.

Если вы передаете на другой компьютер файл *.ALS, содержащий ссылки на пользовательские библиотеки стилей линий, то вместе с ним следует передать и эти библиотеки. Чтобы файл *.ALS можно было использовать на другом компьютере, необходимо разместить библиотеки по путям, указанным в этом файле. Если это трудно сделать (например, на компьютере нет жесткого диска с нужным именем), отредактируйте файл *.ALS, указав фактические пути к библиотекам стилей линий.

Если при импорте обнаруживается, что в библиотеке отсутствует стиль с номером, указанным в файле *.ALS, или сама библиотека отсутствует по пути, указанному в файле *.ALS, то соответствующий тип линии AutoCAD заменяется системной линией КОМПАС Тонкая (№1).

Смотрите также

Номера системных стилей линий КОМПАС


Arrays_H

Arrays_H


Особенности чтения размеров и линий-выносок при импорте файлов форматов DWG и DXF

Особенности чтения размеров и линий-выносок
при импорте файлов форматов DWG и DXF

При импорте изображений, содержащих размерные линии, выполняется следующее соответствие между типами размерных стрелок AutoCAD (Arrowhead) и типами стрелок КОМПАС.

– Стрелка типа Dot small импортируется в КОМПАС-3D как точка.

– Стрелка типа Closed filled, Open, Open 30, Closed, Closed blank импортируется в КОМПАС-3D как стрелка.

– Стрелка типа Oblique и Architectural tick импортируется в КОМПАС-3D как засечка.

– Стрелки остальных типов при чтении превращаются в макроэлементы.

При импорте изображений, содержащих линии-выноски, выполняется такое же соответствие между типами стрелок, за исключением типов Oblique и Architectural tick — линии-выноски с этим типом стрелки превращаются в макроэлементы.

Размерные линии и линии-выноски AutoCAD с типом стрелки None импортируются в КОМПАС без точки и стрелки.

Описанное соответствие выполняется, если размеры читаются обычным или комбинированным способом. Если чтение размеров производится макроэлементами, то все размеры и линии-выноски вне зависимости от используемого типа стрелки превращаются в макроэлементы.

Кроме того, размеры в документе AutoCAD могут иметь пользовательский тип стрелки (так называемые блок-стрелки). Размеры с такими типами стрелок импортируются в КОМПАС-3D как макроэлементы вне зависимости от выбранного варианта чтения размеров.


Инструментальная панель Вспомогательная геометрия

Панель, на которой расположены кнопки вызова команд построения вспомогательных прямых и плоскостей.

По умолчанию панель Вспомогательная геометрия включена в состав компактной инструментальной панели.

Для активизации панели Вспомогательная геометрия нажмите одноименную кнопку переключения на компактной панели.

Если указанной кнопки переключения на компактной панели нет, это означает, что панель Вспомогательная геометрия была исключена из нее. В этом случае для отображения на экране панели Вспомогательная геометрия следует вызвать команду Вид — Панели инструментов — Вспомогательная геометрия.

Кнопки сгруппированы по типам команд, которые они вызывают, например, группа кнопок для построения осей. На панели отображается только одна кнопка из группы. Чтобы увидеть остальные кнопки, нужно нажать на видимую кнопку группы и не отпускать кнопку мыши.

Через секунду рядом с курсором появится панель, содержащая остальные кнопки для вызова команд выбранного типа (расширенная панель команд). По-прежнему не отпуская кнопку мыши, переведите курсор на кнопку вызова нужной команды. Отпустите кнопку мыши. При этом выбранная кнопка появится на Инструментальной панели, а соответствующая ей команда будет активизирована. Кнопки, позволяющие вызвать расширенную панель команд, отмечены маленьким черным треугольником в правом нижнем углу.

Расширенная панель команд может быть преобразована в отдельную панель, имеющую обобщенный заголовок.


Базовая кривая(команда Проекционная кривая)

Базовая кривая
(команда Проекционная кривая)

В качестве базовой кривой может использоваться:

– пространственная кривая (в том числе экземпляр массива),

– ребро тела и поверхности,

– линия эскиза,

– набор вышеперечисленных объектов,

– координатная или вспомогательная ось,

– массив кривых,

– группа изопараметрических кривых.


Базовая точка трехмерного объекта

Базовая точка трехмерного объекта — точка, которая используется как начальная для построения геометрии объекта в модели. Положение базовой точки объекта определяется системой автоматически и зависит от типа объекта и способа его построения. Например, базовой точкой компонента является его абсолютная система координат, базовой точкой операции, построенной на эскизе, является центр масс кривых этого эскиза.


Сгиб

Сгиб — цилиндрический участок листового тела.

Cгибы формируются в детали при выполнении следующих команд:

– Сгиб,

– Сгиб по линии,

– Сгиб по эскизу,

– Подсечка.

Кроме того, формирование сгибов возможно при построении листового тела на основе разомкнутого эскиза (см. раздел 2.4.2.2.2).


Смежные сгибы

Рис. 1

Смежными считаются сгибы, имеющие общее ребро, расположенное так, как показано на рис. 1.

Сгибы, имеющие освобождения, а также сдвинутые друг относительно друга, смежными не являются. Соответствующие им углы не могут быть замкнуты (рис. 2).

Рис. 2

Плоские части детали, модифицируемые при замыкании угла, называются сторонами замыкаемого угла.


Интерпретация угла

Значение, введенное в поле Угол, может интерпретироваться как

– угол сгиба или

– дополняющий угол.

Чтобы выбрать интерпретацию значения угла, активизируйте нужный переключатель в группе Интерпретация угла.

Угол сгиба

Дополняющий угол

Построение сгиба с дополняющим углом 180° невозможно, так как это означает отсутствие сгиба: угол сгиба равен 0°.

Схема построения сгиба в зависимости от направления отсчета и интерпретации угла


Освобождение угла

Соседние сгибы листового тела могут располагаться, например, таким образом, как показано на рисунке.

Совпадающие грани сгибов (выделены серым цветом):
Сгиб 1 — создаваемый, Сгиб 2 — соседний с ним

Вы можете выполнить освобождение такого угла.

Использование освобождения угла при работе с командой Сгиб имеет следующие особенности.

– Освобождение угла возможно, только если линия создаваемого сгиба перпендикулярна линиям соседних сгибов.

– Для включения освобождения следует активизировать переключатель Освобождение угла на вкладке Освобождение Панели свойств. После этого станут доступны переключатели способа освобождения.


Освобождение угла

Освобождение угла при построении сгиба — частичное удаление соседнего с ним сгиба, или соседнего сгиба и его продолжения, или соседнего сгиба, его продолжения и всех сгибов, построенных на этом продолжении. Удаление указанных элементов производится в направлении создаваемого сгиба от плоскости, перпендикулярной линии соседнего сгиба и проходящей через точку пересечения линий сопряжения цилиндрических поверхностей сгибов.


Способы освобождения угла

Только сгиб

Сгиб и его продолжение

Все сгибы


Примеры сгибов, для которых замыкание углов невозможно


Базовая грань сгиба

Базовая грань сгиба — плоская грань детали, содержащая линию сгиба.


Освобождение сгиба

Переключатель Освобождение сгиба на вкладке Освобождение Панели свойств позволяет включить освобождение сгиба.

– Чтобы выбрать форму освобождения, активизируйте нужный переключатель в группе Тип.

• Прямоугольное

• Скругленное

– Введите размеры освобождения в поля Глубина и Ширина. Эти значения не могут быть отрицательными.

– Опция Включить в ширину сгиба управляет расположением освобождений относительно сгиба. Если значения ширины освобождений должны включаться в ширину сгиба, активизируйте эту опцию. При отключенной опции ширины освобождений не включаются в ширину сгиба.

ширина сгиба без освобождений | освобождения включены в ширину сгиба | освобождения не включены в ширину сгиба

Особенности освобождения сгиба


Замыкаемый угол

Замыкаемый угол измеряется в проекции детали на плоскость, перпендикулярную сторонам угла. Такой плоскостью может служить любая плоскость, перпендикулярная линии пересечения внешних или внутренних граней сторон угла.


Зазор

Зазор — расстояние, на котором будут расположены друг от друга стороны замыкаемого угла. Зазор измеряется в проекции детали на плоскость, перпендикулярную сторонам угла. Такой плоскостью может служить любая плоскость, перпендикулярная линии пересечения внешних или внутренних граней сторон угла.


Направление отсчета

При построении сгиба угол может откладываться как в одну, так и в другую сторону от базовой грани. Прямым направлением отсчета угла считается направление наружу по отношению к телу детали. Это направление определяется системой автоматически и показывается фантомной стрелкой в окне модели.

Чтобы выбрать направление отсчета угла — Прямое или Обратное — активизируйте соответствующий переключатель в группе Направление.

Прямое направление

Обратное направление

Схема построения сгиба в зависимости от направления отсчета и интерпретации угла.


Направление сгиба

Направление сгиба — направление сгиба относительно базовой грани. Направление в сторону базовой грани — прямое; противоположное направление — обратное.


Продолжение сгиба

Продолжение сгиба — часть листового тела, примыкающая к сгибу со стороны, противоположной ребру, вдоль которого расположен этот сгиб.


Освобождение сгиба

Освобождение сгиба — пазы в листовом теле, расположенные по бокам сгиба.


Способ задания длины

Укажите способ задания длины продолжения сгиба, выбрав нужный переключатель группы Способ задания длины.

Значение опции Способ задания длины | Угол сгиба более 90° | Угол сгиба 90° | Угол сгиба от 0° до 90°
Длина |  |  |
Длина по контуру |  |  |
Длина по касанию |  |  |
Длина по контуру внутри |  |  |
Длина по касанию внутри |  |  |

Особенности задания параметров продолжения сгиба...


Линия сгиба

Линия сгиба — прямолинейный объект, определяющий положение сгиба в листовом теле.


Коэффициент нейтрального слоя

Коэффициент нейтрального слоя (коэффициент положения нейтрального слоя) определяет положение нейтрального слоя по толщине сгибаемого тела. Он используется для определения длин развернутых участков (при разгибании сгибов).

Длина нейтрального слоя в сгибе не изменяется при его разгибании. При увеличении коэффициента нейтральный слой смещается к внешней поверхности сгиба, а длина развернутого участка увеличивается. При уменьшении коэффициента происходят обратные изменения.

Значение коэффициента нейтрального слоя зависит от физических характеристик материала, его толщины и радиуса сгиба (подробнее см. раздел 2.4.1.4.1).


Способ задания радиуса сгиба

Чтобы выбрать способ задания радиуса сгиба, активизируйте нужный переключатель в группе Способ задания радиуса.

Внутренний радиус

Наружный радиус

В зависимости от выбранного способа задания радиуса будет построен сгиб, внутренний или наружный радиус которого равен заданному значению.

Минимальное значение внутреннего радиуса — 0,0002 мм. Внутренний и наружный радиусы связаны соотношением:

Rнаружн. = Rвнутр. + S,

где S — толщина материала.

Поэтому минимальное значение наружного радиуса равно сумме (S + 0,0002) мм.

Переключение способа задания радиуса и изменение его значения невозможно при редактировании сгибов, принадлежащих листовому телу с разомкнутым эскизом и соответствующих дугам в эскизе этого листового тела.


Размещение сгиба на ребре

При создании сгиба возможны различные варианты его размещения на ребре. Чтобы указать размещение сгиба, выберите нужный вариант из списка Размещение. В зависимости от выбранного варианта на Панели свойств появятся поля для ввода ширины сгиба или его отступов от концов ребра.

Описание элементов управления

Наименование

Описание

По всей длине

Ширина сгиба равна длине ребра.

По центру

Значение ширины сгиба вводится в поле Ширина. Сгиб размещается по центру ребра.

Слева

Значение ширины вводится в поле Ширина. Сгиб размещается так, чтобы левый конец ребра лежал в плоскости левой стороны сгиба.

Левый конец ребра — конец, на котором располагается фантомная стрелка (показывающая прямое направление отсчета угла). Прилежащая к левому концу ребра сторона сгиба также считается левой. Противоположный конец ребра и противоположная сторона сгиба — правые.

Справа

Значение ширины вводится в поле Ширина. Сгиб размещается так, чтобы правый конец ребра лежал в плоскости правой стороны сгиба.

Два отступа

Ширина сгиба определяется автоматически как разница между длиной ребра и суммарной величиной отступов. Значения отступов слева и справа вводятся в поля Отступ 1 и Отступ 2 соответственно. Положение сгиба определяется размерами отступов.

Отступ слева

Ширина сгиба и величина отступа вводятся в поля Отступ и Ширина. Сгиб размещается так, чтобы расстояние от левого конца ребра до левой стороны сгиба равнялось заданному значению отступа.

Отступ справа

Ширина сгиба и величина отступа вводятся в поля Отступ и Ширина. Сгиб размещается так, чтобы расстояние от правого конца ребра до правой стороны сгиба равнялось заданному значению отступа.

Значение отступа может быть как положительными, так и отрицательным. Положительный отступ откладывается внутрь по отношению к телу детали, а отрицательный — наружу. Значения отступов, при которых сгиб оказывается отделенным от тела детали, не допускаются.


Смещение сгиба

Смещение сгиба — параметр, характеризующий сдвиг сгиба в плоскости базовой грани. Смещение сгиба производится перпендикулярно ребру, вдоль которого он располагается.


Неподвижная сторона

Неподвижная сторона при построении сгиба — та часть базовой грани, положение которой при сгибе не изменится. Именно в этой части базовой грани начинается фантомная стрелка, показывающая направление отсчета угла сгиба. При изменении неподвижной стороны положение стрелки изменяется.


CALS

CALS (Continuous Acquisition and Life cycle Support) — концепция и идеология информационной поддержки жизненного цикла продукции на всех его стадиях, основанная на использовании единого информационного пространства (интегрированной информационной среды), обеспечивающая единообразные способы взаимодействия всех участников этого цикла: заказчиков продукции (включая государственные учреждения и ведомства), поставщиков (производителей) продукции, эксплуатационного и ремонтного персонала, реализованная в форме международных стандартов, регламентирующих правила указанного взаимодействия преимущественно посредством электронного обмена данными.


Команда Линейный размер от отрезка до точки (графический документ)

Команда Линейный размер от отрезка до точки
 (графический документ)

Позволяет построить линейный размер между двумя геометрическими элементами — отрезком и произвольной точкой (в том числе характерной точкой другого графического объекта).

Для вызова команды нажмите кнопку Линейный от отрезка до точки на инструментальной панели Размеры.

Укажите курсором отрезок, от которого проставляется размер.

Выносные линии размера будут параллельны этому отрезку, а один из его концов будет первой точкой привязки размера.

Задайте вторую точку привязки размера т2. Для этого укажите один из следующих объектов:

– произвольную точку;

– отрезок, параллельный отрезку, от которого проставляется размер — точкой т2 станет один из концов указанного отрезка;

– окружность (дугу окружности) — точкой т2 станет точка касания окружности и прямой параллельной отрезку, от которого проставляется размер.

В поле Текст на вкладке Размер отображается автоматически сформированная размерная надпись. Чтобы вызвать диалог редактирования и настройки размерной надписи, щелкните мышью в этом поле.

В списке Размещение текста отображается текущий способ размещения размерной надписи. Если необходимо, смените способ размещения. Подробнее...

Затем укажите точку т3, определяющую положение размерной линии и текста.

Если выбрано размещение размерной надписи на полке, задайте точку начала полки т4. В этом случае точка т3 является начальной точкой линии-выноски.

Тот конец отрезка, ближе к которому окажется размерная линия, будет принят за первую точку привязки размера т1.

Пример простановки размера между отрезком и точкой

Настройка параметров размеров (выбор вида стрелки, положения надписи и т.п.).

Формирование зазора между выносной линией и точкой привязки

Смотрите также

Другие размеры

Выравнивание размерных линий


Команда Редактировать в окне

Позволяет отредактировать модель (деталь или сборку), выделенную в Дереве чертежа.

Команда доступна, если на компьютере установлен КОМПАС-3D.

Команда находится в контекстном меню модели или любого ее объекта, выделенного в Дереве чертежа.

После вызова команды открывается окно, содержащее выбранную трехмерную модель. Внесите в нее необходимые изменения, сохраните и закройте окно модели или перейдите в окно чертежа.

При возврате в окно чертежа система выдаст запрос на перестроение чертежа. Ответ Да запускает перестроение изображения в чертеже с учетом изменений, внесенных в модель.

Чтобы отложить перестроение чертежа, нажмите кнопку Нет диалога. Запрос на перестроение чертежа исчезнет, а пиктограмма вида (видов), компонентом которого является отредактированная модель, в Дереве чертежа будет отмечена красной «галочкой», означающей, что чертеж необходимо перестроить. Кроме того, виды, требующие перестроения, в окне чертежа будут отображаться перечеркнутыми.

Вы можете в любое время перестроить чертеж. Для этого нажмите кнопку Перестроить на панели Вид или клавишу <F5>.

Если изображенная в чертеже сборка состоит из большого числа компонентов, ее перестроение может занять значительное время. Поэтому, если необходимо отредактировать несколько компонентов, целесообразно перестраивать чертеж один раз — после внесения всех изменений (а не каждый раз после редактирования отдельного компонента).

Чтобы перейти к редактированию компонента в окне, можно открыть содержащий его файл обычным способом — нажать кнопку Открыть документ или вызвать команду Файл — Открыть и выбрать нужный файл. При использовании команды Редактировать в окне не требуется искать нужный файл в списке — система находит его автоматически.


Команда Скрыть

Позволяет отредактировать один или несколько видов чертежа, отключив изображение выбранных компонентов (сборок или деталей).

Команда доступна для компонентов активных видов чертежа.

После вызова команды пиктограммы редактируемых видов в Дереве чертежа помечаются «галочкой», а виды в окне чертежа перечеркиваются.

Это означает, что чертеж необходимо перестроить. Для этого нажмите кнопку Перестроить на панели Вид или клавишу <F5>.

Изображение в чертеже будет перерисовано с учетом внесенных изменений.

Пиктограммы скрытых компонентов отображаются в Дереве чертежа серым цветом.

Отключение изображения компонентов на одном из видов не влияет на показ этих компонентов в других видах чертежа.

Чтобы вновь включить показ компонентов, выделите их в Дереве чертежа и вызовите из контекстного меню команду Показать, после чего перестройте чертеж.


Команда Не разрезать

Позволяет отредактировать один или несколько разрезов (сечений), отключив изображение выбранных компонентов (сборок или деталей) в разрезанном виде.

Команда доступна для активных видов, отображающих компоненты, если эти виды содержат изображения разрезов (сечений).

После вызова команды пиктограммы редактируемых видов в Дереве чертежа помечаются «галочкой», а виды в окне чертежа перечеркиваются.

Это означает, что чертеж необходимо перестроить. Для этого нажмите кнопку Перестроить на панели Вид или клавишу <F5>.

Изображение в чертеже будет перерисовано с учетом внесенных изменений.

Пиктограммы неразрезанных компонентов помечаются в Дереве чертежа значком.

Отключение изображения компонентов в разрезе на одном из видов не влияет на отображение этих компонентов в других видах чертежа.

Чтобы вновь включить показ компонентов в разрезе, выделите их в Дереве чертежа и вызовите из контекстного меню команду Разрезать, после чего перестройте чертеж.


Команда Свойства компонента...

Вызывает диалог, в котором вы можете включить (отключить) создание объекта спецификации и просмотреть наименование, обозначение и путь к файлу-источнику компонента.


Команда Разрезать

Позволяет отредактировать виды, включив изображение одного или нескольких выбранных компонентов (сборок или деталей) в разрезе.

Команда доступна, если хотя бы один из выделенных компонентов не разрезан.

После вызова команды пиктограммы редактируемых видов в Дереве чертежа помечаются «галочкой», а виды в окне чертежа перечеркиваются.

Это означает, что чертеж необходимо перестроить. Для этого нажмите кнопку Перестроить на панели Вид или клавишу <F5>.


Команда Показать

Позволяет включить изображение одного или нескольких выбранных компонентов (сборок или деталей) на видах чертежа.

Команда недоступна, если ни один из выделенных компонентов не скрыт.

После вызова команды пиктограммы редактируемых видов в Дереве чертежа помечаются «галочкой», а виды в окне чертежа перечеркиваются.

Это означает, что чертеж необходимо перестроить. Для этого нажмите кнопку Перестроить на панели Вид или клавишу <F5>.

Изображение в чертеже будет перерисовано с учетом внесенных изменений.


Команда Открыть документ-владелец

Позволяет открыть модель, содержащую выбранную локальную деталь.

Команда доступна, если на компьютере установлен КОМПАС-3D.

Команда находится в контекстном меню локальной детали или любого ее объекта, выделенного в Дереве чертежа.

После вызова команды открывается окно модели. Внесите в модель необходимые изменения, сохраните и закройте окно модели или перейдите в окно чертежа.

При возврате в окно чертежа система выдаст запрос на перестроение чертежа. Ответ Да запускает перестроение изображения в чертеже с учетом изменений, внесенных в модель.

Чтобы отложить перестроение чертежа, нажмите кнопку Нет диалога. Запрос на перестроение чертежа исчезнет. Пиктограммы видов, источником которых является отредактированная модель, будут отмечены красной «галочкой» в Дереве чертежа. Это означает, что чертеж необходимо перестроить. Кроме того, в окне чертежа виды, требующие перестроения, будут отображаться перечеркнутыми.

Вы можете в любое время перестроить чертеж. Для этого нажмите кнопку Перестроить на панели Вид или клавишу <F5>.


Команда Создать сборку

Позволяет начать построение подсборки в текущей модели.

Для вызова команды нажмите кнопку Создать сборку на инструментальной панели Редактирование сборки или выберите пункт меню Операции — Создать — Сборку.

После вызова команды на экране появляется стандартный диалог сохранения файлов. Выберите в нем нужную папку и введите имя файла, в который будет записана новая сборка.

Если в указанной папке уже есть файл сборки с таким именем, то на экране появляется запрос на перезапись файла. Если эта сборка вставлена в текущую модель, то в случае положительного ответа на запрос появляется сообщение о том, что документ уже существует и запись невозможна. Процесс создания подсборки прерывается.

После сохранения файла новой подсборки система перейдет в режим редактирования компонента на месте. Все команды построения в этом режиме распространяются только на редактируемый компонент (он выделен цветом). Остальные компоненты видны в окне, но недоступны для редактирования (служат «обстановкой»). Их можно использовать при построении (указывать грани, ребра, вершины).

Признаком того, что режим редактирования на месте включен, является отображение нажатой кнопки Редактировать на месте на панели Текущее состояние, а в окне модели — значка режима контекстного редактирования. Завершив создание подсборки, отожмите кнопку или щелкните на значке для возврата в режим работы с основной моделью.

Сборка, созданная в контексте другой модели, связывается с этой моделью сопряжением Совпадение. Сопряжение накладывается на абсолютную систему координат сборки и текущую систему координат модели. Пиктограмма сопряжения появляется в группе сопряжений Дерева построения. При необходимости вы можете отредактировать или удалить автоматически созданное сопряжение.


Команда Добавить компонент из файла...

Позволяет вставить в текущую модель деталь или подсборку, существующую в файле на диске.

Для вызова команды нажмите кнопку Добавить из файла на инструментальной панели Редактирование сборки или выберите пункт меню Операции — Добавить из файла — Компонент....

После вызова команды на экране появляется диалог выбора файлов, в котором требуется указать нужную модель.

Если модель содержит исполнения, то в диалоге можно выбрать обозначение нужного исполнения. Если для исполнений в модели созданы дополнительные номера, то вы также можете выбрать нужный дополнительный номер. Геометрия и свойства вставленного компонента будут соответствовать выбранному исполнению модели и дополнительному номеру.

Списки исполнений и дополнительных номеров отображаются в диалоге при выборе модели, содержащей исполнения и дополнительные номера.

После того как модель выбрана, ее фантом появляется в окне текущей модели. На Панели свойств появляются вкладки Размещение и Свойства.

На вкладке Размещение вы можете задать параметры, определяющие положение компонента в модели.

Порядок настройки параметров зависит от способа размещения компонента:

– По координатам,

– По сопряжениям.

На вкладке Свойства расположены элементы управления, позволяющие выполнить следующие действия:

– задать цвет и оптические свойства компонента,

– включить/отключить создание объекта спецификации,

– выбрать новые значения внешних переменных компонента, если он содержит таблицу переменных.

Для завершения вставки компонента нажмите кнопку Создать объект на Панели специального управления.

В Дереве построения появится пиктограмма, соответствующая типу компонента:

– Пиктограмма детали

– Пиктограмма сборки

Смотрите также

Параметры расчета МЦХ компонентов


Вставка в сборку модели из библиотеки

После выбора библиотечной модели и вызова команды Вставить модель в сборку на Панели свойств появляются вкладки Размещение и Свойства.

На вкладке Размещение вы можете задать параметры, определяющие положение библиотечной модели в сборке.

Порядок настройки параметров зависит от способа размещения модели:

– По координатам,

– По сопряжениям.

Если в библиотечной модели имеются внешние переменные, то на вкладке Размещение присутствует панель Переменные. Она содержит список внешних переменных и позволяет изменить их значения.

Вы можете изменить значение переменной, дважды щелкнув мышью в соответствующем ей поле Значение и задав нужное значение вручную или с помощью счетчика. Переменная, значение которой изменено, помечается значком «галочка».

Значения внешних переменных можно также изменить с помощью таблицы переменных (см. ниже).

На вкладке Свойства расположены элементы управления, позволяющие выполнить следующие действия:

– задать цвет и оптические свойства модели из библиотеки,

– включить/отключить создание объекта спецификации,

– выбрать новые значения внешних переменных модели из библиотеки, если она содержит таблицу переменных.

Для завершения вставки модели нажмите кнопку Создать объект на Панели специального управления.

В Дереве построения появится пиктограмма компонента, вставленного из библиотеки.

Смотрите также

Параметры расчета МЦХ компонентов


Команда Создать деталь(на месте)

Команда Создать деталь
(на месте)

Позволяет начать построение детали непосредственно в текущей модели.

Для вызова команды нажмите кнопку Создать деталь на инструментальной панели Редактирование сборки или выберите пункт меню Операции — Создать — Деталь.

После вызова команды на экране появляется стандартный диалог сохранения файлов. Выберите в нем нужную папку и введите имя файла, в который будет записана новая деталь.

Если в указанной папке уже есть файл детали с таким именем, то на экране появляется запрос на перезапись файла. Если эта деталь вставлена в текущую модель, то в случае положительного ответа на запрос появляется сообщение о том, что документ уже существует и запись невозможна. Процесс создания детали прерывается.

Система перейдет в режим редактирования компонента на месте. Все команды построения в этом режиме распространяются только на редактируемую деталь (она выделена цветом). Остальные компоненты видны в окне, но недоступны для редактирования (служат «обстановкой»). Их можно использовать при построении (указывать грани, ребра, вершины).

Признаком того, что режим редактирования на месте включен, является отображение нажатой кнопки Редактировать на месте на панели Текущее состояние, а в окне модели — значка режима контекстного редактирования. Завершив построение детали, отожмите кнопку или щелкните на значке для возврата в режим работы с основной моделью.

Деталь, созданная в контексте другой модели, связывается с этой моделью сопряжением Совпадение. Сопряжение накладывается на абсолютную систему координат детали и текущую систему координат модели. Пиктограмма сопряжения появляется в группе сопряжений Дерева построения. При необходимости вы можете отредактировать или удалить автоматически созданное сопряжение.

Если первый элемент создаваемой детали планируется строить на основе эскиза, и плоский объект для его размещения уже есть в модели, укажите этот объект перед вызовом команды создания детали. В этом случае после сохранения файла детали система автоматически перейдет в режим редактирования эскиза, располагающегося в указанной плоскости. Выполните необходимые построения и выйдите из режима эскиза.


Команда Создать компоновочную геометрию

Позволяет начать построение компоновочной геометрии непосредственно в текущей модели.

Для вызова команды нажмите кнопку Создать компоновочную геометрию на инструментальной панели Редактирование сборки или выберите пункт меню Операции — Создать — Компоновочную геометрию.

После вызова команды на экране появляется диалог Создать компоновочную геометрию, позволяющий выбрать тип компоновочной геометрии:

– Деталь,

– Сборка,

– Локальная деталь.

Компоновочная геометрия, представленная деталью или сборкой, хранится в отдельном файле, а представленная локальной деталью — в файле текущей модели.

Выберите вариант, соответствующий нужному типу компоновочной геометрии, в поле Имя компонента введите имя компоновочной геометрии и нажмите кнопку ОК.

Диалог закроется. В случае создания детали или сборки на экране появится диалог сохранения файлов. Укажите папку и имя файла для записи новой детали/сборки и нажмите кнопку Сохранить. После этого в Дереве построения модели в разделе Компоновочная геометрия появится пиктограмма, обозначающая новую деталь/сборку, а система перейдет в режим контекстного редактирования этой детали/сборки. О том, что ведется контекстное редактирование компонента, говорит желтый цвет его пиктограммы.

В случае создания локальной детали ввод имени файла детали не требуется, так как локальная деталь хранится в той же модели, где создается. Система сразу переходит в режим контекстного редактирования локальной детали, а в разделе Компоновочная геометрия Дерева построения появляется соответствующая ей пиктограмма.

Абсолютная система координат создаваемой детали, сборки или локальной детали совпадает с текущей системой координат модели.

Выполните все необходимые действия по созданию детали, сборки или локальной детали в режиме контекстного редактирования. Для выхода из режима отожмите кнопку Редактировать на месте на панели Текущее состояние, или вызовите из контекстного меню детали/сборки команду Редактировать на месте, или щелкните мышью по значку режима контекстного редактирования в окне модели. Система вернется в режим работы с текущей моделью, пиктограмма нового объекта из желтой превратится в синюю.

После выполнения каких-либо построений в режиме контекстного редактирования детали, сборки или локальной детали требуется перестроение модели.

Смотрите также

Добавление компоновочной геометрии в модель

Редактирование компоновочной геометрии


Команда Добавить компоновочную геометрию

Позволяет в качестве компоновочной геометрии вставить в модель деталь или сборку, существующую в файле на диске.

Для вызова команды нажмите кнопку Добавить компоновочную геометрию на инструментальной панели Редактирование модели/детали или Редактирование сборки. При работе со сборкой можно также выбрать пункт меню Операции — Добавить из файла — Компоновочную геометрию....

После вызова команды на экране появляется диалог выбора файлов, в котором требуется указать модель, которая будет вставлена в качестве компоновочной геометрии.

Если модель содержит исполнения, то в диалоге можно выбрать обозначение нужного исполнения. Если для исполнений в модели созданы дополнительные номера, то вы также можете выбрать нужный дополнительный номер.

Списки исполнений и дополнительных номеров отображаются в диалоге при выборе модели, содержащей исполнения и дополнительные номера.

Для завершения выбора файла нажмите кнопку Открыть. Диалог закроется. В текущей модели будет создана компоновочная геометрия, содержащая модель из выбранного файла. Абсолютная система координат модели из файла совпадет с абсолютной системой координат текущей модели.

В Дереве построения модели в разделе Компоновочная геометрия появится пиктограмма, соответствующая типу компоновочной геометрии (деталь или сборка), и наименование компоновочной геометрии, взятое из ее файла.

Смотрите также

Добавление компоновочной геометрии в модель

Редактирование компоновочной геометрии


Команда Добавить локальную деталь из файла...

Позволяет вставить в текущую модель локальную деталь из файла другой модели. В качестве локальной детали может быть вставлена деталь из файла *.m3d или сборка из файла *.а3d.

Выбранная для вставки модель может сама содержать локальные детали. В этом случае обратите внимание на следующие особенности.

• Если выбранная модель является сборкой, то в виде локальной детали может быть вставлена как вся сборка, так и одна из ее локальных деталей.

• Если выбранная модель является деталью, то в виде локальной детали может быть вставлена только вся эта деталь. Выбор содержащихся в ней локальных деталей невозможен.

Для вызова команды нажмите кнопку Добавить локальную деталь из файла на инструментальной панели Редактирование сборки или выберите пункт меню Операции — Добавить из файла — Локальную деталь....

После вызова команды на экране появляется диалог выбора файлов, в котором требуется указать нужную модель. Выберите файл нужной детали или сборки в данном диалоге и нажмите кнопку Открыть.

В случае выбора сборки, содержащей локальные детали, на экране появится диалог Выберите локальную деталь.

Чтобы в виде локальной детали была вставлена одна из локальных деталей, имеющихся в сборке, укажите ее в данном диалоге и нажмите кнопку ОК.

Чтобы в виде локальной детали была вставлена вся сборка, в данном диалоге нажмите кнопку Отмена.

После того как модель выбрана, фантом локальной детали появляется в окне текущей модели. На Панели свойств появляются вкладки Размещение и Свойства.

На вкладке Размещение вы можете задать параметры, определяющие положение локальной детали в модели.

Порядок настройки параметров зависит от способа размещения локальной детали:

– По координатам,

– По сопряжениям.

На вкладке Свойства расположены элементы управления, позволяющие выполнить следующие действия:

– задать цвет и оптические свойства локальной детали,

– включить/отключить создание объекта спецификации,

– выбрать новые значения внешних переменных локальной детали, если модель — источник вставки содержит таблицу переменных.

Для завершения вставки локальной детали нажмите кнопку Создать объект на Панели специального управления.

Локальная деталь будет вставлена в текущую модель и зафиксирована.

В Дереве построения модели появится пиктограмма локальной детали.

Смотрите также

Особенности работы с локальной деталью

Параметры расчета МЦХ компонентов


Команда Создать локальную деталь(на месте)

Команда Создать локальную деталь
(на месте)

Позволяет начать построение локальной детали непосредственно в текущей модели.

Для вызова команды нажмите кнопку Создать локальную деталь на инструментальной панели Редактирование сборки или выберите пункт меню Операции — Создать — Локальную деталь.

Система перейдет в режим редактирования компонента на месте. Все команды построения в этом режиме распространяются только на редактируемую деталь (ее пиктограмма выделена цветом в Дереве построения). Остальные компоненты видны в окне, но недоступны для редактирования (служат «обстановкой»). Их можно использовать при построении (указывать грани, ребра, вершины).

Признаком того, что режим редактирования на месте включен, является отображение нажатой кнопки Редактировать на месте на панели Текущее состояние, а в окне модели — значка режима контекстного редактирования. Завершив построение детали, отожмите кнопку Редактировать на месте или щелкните на значке в окне модели.

Деталь, созданная в контексте модели, связывается с этой моделью сопряжением Совпадение. Сопряжение накладывается на абсолютную систему координат детали и текущую систему координат модели. Пиктограмма сопряжения появляется в группе сопряжений Дерева построения. При необходимости вы можете отредактировать или удалить автоматически созданное сопряжение.

Если первый элемент создаваемой детали планируется строить на основе эскиза, и плоский объект для его размещения уже есть в модели, укажите этот объект перед вызовом команды создания детали. В этом случае после сохранения файла детали система автоматически перейдет в режим редактирования эскиза, располагающегося в указанной плоскости. Выполните необходимые построения и выйдите из режима эскиза.

Смотрите также

Особенности работы с локальной деталью


Команда Разрушить

Позволяет разрушить на отдельные составляющие следующие объекты:

– массивы объектов (кроме операций),

– группы точек,

– группы изопараметрических кривых,

– копии геометрических объектов.

Перед вызовом команды выделите разрушаемый объект в Дереве построения.

Команда вызывается из меню Редактор или контекстного меню выделенного объекта. Если для разрушения выделено несколько объектов, то вызов команды возможен только из меню Редактор.

После вызова команды на экране появляется диалог разрушения объектов. Чтобы подтвердить разрушение, нажмите кнопку ОК, а чтобы отказаться от разрушения — кнопку Отмена.

Смотрите также

Разрушение массивов

Разрушение группы точек

Разрушение копии геометрических объектов


Команда Перебор объектов (трехмерных объектов)

Команда Перебор объектов
(трехмерных объектов)

Позволяет выделить любой из близко расположенных (в том числе наложенных друг на друга) объектов. Команда доступна в контекстном меню в режиме выделения или выбора трехмерных объектов, если в «ловушку» курсора попадает более одного объекта.

Для быстрого вызова команды можно воспользоваться комбинацией клавиш <Ctrl>+<t>.

После вызова команды объекты можно перебирать, нажимая клавишу <Пробел> или вызывая команду Следующий объект из контекстного меню.

После того как нужный объект будет выделен, прервите перебор с подтверждением выбора. Для этого нажмите клавишу <Enter> или вызовите из контекстного меню команду Выбрать подсвеченный объект. Можно также щелкнуть мышью на выделенном объекте или в любом свободном месте окна модели.

Если требуется выйти из режима перебора без выделения объекта, нажмите клавишу <Esc> или вызовите из контекстного меню команду Отказ от перебора.


Команда Завершить/Продолжить ввод вершин сплайна или ломаной

Команда Завершить/Продолжить ввод вершин
сплайна или ломаной

Позволяет перейти к редактированию вершин создаваемого сплайна или ломаной, а затем вернуться к добавлению новых вершин.

Команда доступна в контекстном меню во время построения кривой, а также во время встраивания совокупности вершин ломаной.

После вызова команды Завершить ввод вершин процесс создания очередной вершины прерывается. Последняя созданная вершина выделяется в окне модели и в таблице параметров вершин. Название команды в меню меняется на Продолжить ввод вершин.

Вы можете отредактировать или удалить любую из созданных вершин.

Завершив редактирование вершин сплайна или ломаной, вызовите из контекстного меню команду Продолжить ввод вершин.

Таблица параметров вершин сплайна или ломаной...

Таблица параметров вершин сплайна на поверхности...

Редактирование параметров вершины сплайна или ломаной...

Редактирование сплайна на поверхности...


Команда Следующий объект (трехмерный объект)

Команда Следующий объект
(трехмерный объект)

Позволяет выделить следующий из близко расположенных (в том числе наложенных друг на друга) объектов. Команда доступна в контекстном меню в режиме перебора объектов.

Для перехода к следующему объекту можно также нажать клавишу <Пробел>.


Команда Выбрать тело

Позволяет выделить тело, которому принадлежит выделенная грань, вершина, ребро или элемент в Дереве построения.

Команда Выбрать тело доступна в контекстном меню окна модели и Дерева построения.


Команда Выбрать компонент

Позволяет выделить в Дереве и в окне модели компонент, объектом которого является или в состав которого входит указанный объект.

Команду можно вызвать из контекстного меню объекта, выделенного в Дереве или в окне модели. Результат выполнения команды зависит от того, какой именно объект был выделен перед ее вызовом.

– Если выделенный объект принадлежит компоненту, то после вызова команды Выбрать компонент подсвечивается компонент.

– Если выделенный объект принадлежит модели в целом, то после вызова команды Выбрать компонент подсвечивается вся текущая модель.

Если требуется развернуть Дерево построения так, чтобы выделенный компонент был виден, используйте команду Показать в Дереве.

Смотрите также

Выбор объектов

Выбор объектов в Дереве построения

Выбор объектов в окне модели

Фильтры объектов

Выбор скрытых, совпадающих или близко расположенных объектов


Команда Сохранить как... (для компонента модели)

Команда Сохранить как...
(для компонента модели)

Позволяет сохранить модель-источник выбранного компонента в новый файл.

Чтобы выполнить сохранение, выделите нужный компонент в Дереве построения и вызовите команду Сохранить как... из контекстного меню или из меню Редактор — Редактировать компонент.

Команда доступна только для компонентов, находящихся на первом уровне структуры модели.

После вызова команды на экране появляется стандартный диалог сохранения файла. В списке Тип файла выберите строку КОМПАС-сборки (*.a3d) или КОМПАС-детали (*.m3d).

Затем укажите папку и имя файла для записи и нажмите кнопку Сохранить.

Компонент будет сохранен и вставлен в текущую модель вместо прежнего. Прежний компонент удаляется из модели, но его файл на диске не изменяется.

После сохранения локальной детали в отдельный файл ее пиктограмма в Дереве построения текущей модели изменяется.

Вы можете использовать команду Сохранить как... для преобразования выбранной детали в подсборку или выбранной подсборки в деталь. Подробнее...

Смотрите также

Перенос и копирование компонентов

Команда Сохранить как... (для группы компонентов модели)

Команда Разрушить подсборку

Команда Объединить в подсборку


Команда Взять в документ

Позволяет преобразовать имеющийся в модели компонент — деталь или подсборку — в локальную деталь этой же модели.

Преобразование возможно только для компонентов первого уровня, т.е. вставленных непосредственно в текущую модель.

Для выполнения преобразования выделите компонент и вызовите команду Взять в документ. При работе со сборкой команда вызывается из меню Редактор или контекстного меню компонента, а при работе с деталью — только из контекстного меню.

После вызова команды выбранный компонент становится локальной деталью текущей модели.

Смотрите также

Особенности работы с локальной деталью


Изменение положения и параметров вставки компонента

Для запуска процесса изменения положения и параметров вставки компонента (модели из файла или из библиотеки, локальной детали, детали-заготовки) выделите его в Дереве построения и вызовите команду Редактор — Редактировать или команду Разместить компонент контекстного меню.

На Панели свойств появятся вкладки Размещение и Свойства.

Вкладка Размещение позволяет изменить параметры размещения компонента в модели. Порядок настройки параметров зависит от способа размещения компонента:

– По координатам,

– По сопряжениям.

Кроме того, на этой вкладке вы можете включить/отключить фиксацию компонента с помощью переключателей группы Фиксация.

Если компонент является моделью из библиотеки и имеет внешние переменные, то вы также можете изменить значения его внешних переменных. В этом случае на вкладке Размещение присутствует панель Переменные.

На вкладке Свойства расположены элементы управления, позволяющие настроить свойства компонента:

– задать цвет и оптические свойства,

– включить/отключить создание объекта спецификации с помощью соответствующей опции (для всех компонентов, кроме детали-заготовки),

– включить компонент в расчет или исключить его из расчета с помощью переключателей группы Состояние,

– выбрать новые значения внешних переменных модели, если вставляемый компонент содержит таблицу переменных.

Выполнив все необходимые действия, нажмите кнопку Создать объект на Панели специального управления.

Смотрите также

Параметры расчета МЦХ компонентов


Команда Создать новый чертеж из модели

Позволяет создать чертеж с ассоциативным видом текущей трехмерной модели.

Для вызова команды нажмите кнопку Создать новый чертеж из модели на инструментальной панели Редактирование детали или Редактирование сборки.

Команда Создать новый чертеж из модели недоступна, если текущая модель еще не записана в файл.

После вызова команды автоматически создается новый чертеж, а в нем — произвольный ассоциативный вид. При этом в качестве модели, изображаемой в виде, уже выбрана текущая трехмерная модель. Остальные параметры вида — умолчательные (ориентация — спереди, цвет — черный, масштаб — 1:1 и т.д.). Если необходимо, измените параметры.

Затем укажите положение базовой точки вида.

В чертеже будет создан произвольный вид, изображающий текущую модель.

Дальнейшая работа с чертежом — создание других ассоциативных видов, оформление и т.п. ведется так же, как и с чертежом, созданным обычным способом.


Команда Разрушить макроэлемент

Позволяет разрушить макроэлементы, выделенные в Дереве построения. Команда доступна в контекстном меню.

После разрушения макроэлемента его пиктограмма удаляется из Дерева построения, а составлявшие его элементы возвращаются на свои места.


Команда Редактировать — Через библиотеку

Позволяет отредактировать параметры компонента сборки, вставленного в нее из прикладной библиотеки. Для вызова команды выберите ее название из меню Редактор или из контекстного меню на пиктограмме вставленного компонента. На экране появится такой же диалог, как при вставке этого компонента из библиотеки. Отредактируйте параметры компонента (например, измените тип головки и длину стержня винта и т.п.) и нажмите кнопку ОК диалога. Если необходимо, укажите новую точку вставки компонента.

Затем нажмите кнопку Создать объект на Панели специального управления.

Компонент перестроится в соответствии с заданными параметрами.

Чтобы отказаться от редактирования, нажмите кнопку Прервать команду на Панели специального управления.


Команда Редактировать на месте

Позволяет начать редактирование указанного компонента в текущем окне модели в окружении других компонентов.

Для вызова команды нажмите кнопку Редактировать на месте на панели Текущее состояние или выберите ее название из меню Редактор — Редактировать компонент или контекстного меню пиктограммы компонента в Дереве построения.

Система перейдет в режим редактирования компонента (детали или сборки).

Пиктограмма редактируемого компонента в Дереве построения из синей превратится в оранжевую, а пиктограмма модели, наоборот, из оранжевой превратится в синюю. Это говорит о том, что текущим документом вместо основной модели стал компонент.

Признаком того, что режим редактирования на месте включен, является отображение нажатой кнопки Редактировать на месте, а также значка режима контекстного редактирования в окне модели. Все команды построения и редактирования в этом режиме распространяются только на указанный компонент (он выделен цветом). Остальные компоненты видны в окне, но недоступны для редактирования (служат «обстановкой»), их можно использовать при выполнении команд (указывать грани, ребра, вершины).

Чтобы завершить редактирование компонента, отожмите кнопку Редактировать на месте или щелкните мышью на значке режима контекстного редактирования в окне модели.

После этого на экране появится запрос на сохранение файла отредактированного компонента. Чтобы сохранить изменения, нажмите кнопку Да (при редактировании локальной детали запрос не выдается, так как она хранится не во внешнем файле, а в файле модели).

Пиктограмма отредактированного компонента в Дереве построения будет отмечена красной «галочкой», означающей, что модель необходимо перестроить.

Если вы хотите немедленно увидеть, как будет выглядеть модель с учетом изменившихся параметров компонента (эти изменения могут привести, например, к изменению положения вспомогательных или формообразующих элементов, базирующихся на компоненте), нажмите кнопку Перестроить на панели Вид или вызовите команду Вид — Перестроить.

Перестроение модели, состоящей из большого числа компонентов, может занять значительное время. Поэтому, если необходимо отредактировать несколько компонентов сложной модели, целесообразно перестраивать ее один раз — после внесения всех изменений (а не каждый раз после редактирования отдельного компонента).

Смотрите также

Команда Редактировать компонент — В окне


Значок режима

Служит для информирования пользователя о текущем режиме.

Появление в окне документа значка режима является признаком того, что данный режим включился, исчезновение — выключился.

Щелчок мышью по значку позволяет выйти из режима.

Для отмены показа значков при включении/выключении режимов служит команда Показать значки режимов в меню Вид или контекстном меню значка.

Контекстное меню значка также содержит команды, позволяющие изменить его расположение в окне документа.


Команда Редактировать в окне

Позволяет начать редактирование компонента модели в отдельном окне, содержащем только этот компонент (без остальных компонентов).

Для вызова команды выделите нужный компонент в Дереве построения и выберите ее название из меню Редактор — Редактировать компонент или из контекстного меню на пиктограмме этого компонента.

После вызова команды откроется файл-источник этого компонента. Внесите в модель компонента необходимые изменения и сохраните ее. Затем закройте окно компонента или перейдите в окно основной модели.

Пиктограмма отредактированного компонента в Дереве построения будет отмечена красной «галочкой», означающей, что модель необходимо перестроить. Возможно также появление запроса на перестроение модели.

Если вы хотите немедленно увидеть, как будет выглядеть модель с учетом изменившихся параметров компонента (эти изменения могут привести, например, к изменению положения вспомогательных или формообразующих элементов, базирующихся на компоненте), ответьте «Да» на запрос или нажмите кнопку Перестроить на панели Вид или вызовите команду Вид — Перестроить.

Перестроение модели, состоящей из большого числа компонентов, может занять значительное время. Поэтому, если необходимо отредактировать несколько компонентов сложной модели, целесообразно перестраивать ее один раз — после внесения всех изменений (а не каждый раз после редактирования отдельного компонента).

Перейти к редактированию компонента в окне можно, открыв содержащий его файл обычным способом: нажать кнопку Открыть документ или вызвать команду Файл — Открыть и выбрать нужный файл. При использовании команды Редактировать компонент — В окне не требуется искать нужный файл в списке — система находит его автоматически.

Смотрите также

Команда Редактировать компонент — На месте


Команда Редактировать исходную сборку

Открывает окно сборки, в контексте которой был создан выбранный элемент детали.


Команда Разместить компонент

Позволяет изменить положение:

– компонента модели,

– компонента исполнения модели,

– компонента компоновочной геометрии.

При работе с компонентами модели и компоновочной геометрии с помощью этой команды можно также изменить свойства компонентов.

Команда вызывается из контекстного меню компонента в Дереве построения модели.

Изменение положения и параметров вставки компонента

Изменение положения компонента исполнения модели

Изменение положения и параметров вставки компонента компоновочной геометрии


Изменение положения и параметров вставки компоновочной геометрии

Для запуска процесса изменения положения и параметров вставки компонента компоновочной геометрии выделите его в Дереве построения и вызовите команду Редактор — Редактировать или команду Разместить компонент контекстного меню.

На Панели свойств появятся вкладки Размещение и Свойства.

Вкладка Размещение содержит раскрывающиеся списки систем координат компоновочной геометрии и текущей модели. Списки доступны, если в компоновочной геометрии и текущей модели имеются локальные системы координат.

Чтобы изменить положение компоновочной геометрии, выберите из списков системы координат для совмещения.

Рядом с каждым из списков находится кнопка, позволяющая указать нужную систему координат не в списке, а в Дереве построения или в окне модели. Система координат компоновочной геометрии выбирается после нажатия кнопки СК компонента, а система координат модели — после нажатия кнопки СК текущего документа.

Выбранные системы координат совмещаются друг с другом и положение компоновочной геометрии в модели изменяется.

На вкладке Свойства вы можете выполнить следующие действия:

– задать цвет и оптические свойства отображения компоновочной геометрии,

– включить компоновочную геометрию в расчет или исключить ее из расчета с помощью переключателей группы Состояние,

– выбрать новые значения внешних переменных модели, являющейся источником компоновочной геометрии, если она содержит таблицу переменных.

Выполнив все необходимые действия, нажмите кнопку Создать объект на Панели специального управления.


Команда Выбрать подсвеченный объект (трехмерный объект)

Команда Выбрать подсвеченный объект
(трехмерный объект)

Позволяет прервать перебор близко расположенных объектов (выйти из режима перебора), подтвердив выбор подсвеченного объекта.

После вызова этой команды подсвеченным остается объект, которым закончился перебор.

Подтвердить выбор подсвеченного объекта можно также при помощи клавиатуры или мыши. Для этого нажмите клавишу <Enter> либо щелкните мышью на подсвеченном объекте или на свободном месте в окне модели.

Для выхода из режима перебора объектов и отказа от выбора какого-либо объекта воспользуйтесь командой Отказ от перебора объектов из контекстного меню. Можно также нажать клавишу <Esc>.


Команда Исключить из расчета

Позволяет исключить из расчета выбранный объект или объекты (плоскости, оси, компоненты и др.).

Команда вызывается из контекстного меню выделенного объекта.

Команда недоступна, если объект уже исключен из расчета или если в Окне переменных введено выражение для вычисления переменной, соответствующей параметру «Исключить из расчета» выбранного объекта.

После вызова команды модель перестроится без учета исключенных объектов и производных от них операций и объектов. Пиктограммы объектов, исключенных из расчета, отобразятся в Дереве построения серым цветом и будут отмечены пиктограммой — «крестиком».

Подробнее об исключении объектов из расчета...

Смотрите также

Управление видимостью объектов


Команда Скрыть состав(локальной детали)

Команда Скрыть состав
(локальной детали)

Позволяет скрыть состав локальной детали, выделенной в Дереве построения. Команда доступна в контекстном меню локальной детали, состав которой не скрыт.

После вызова команды Скрыть состав значок «+» у пиктограммы локальной детали исчезнет. Просмотр состава такой локальной детали в Дереве построения станет невозможен.

Способ отображения локальной детали в Дереве никак не влияет на отображение составляющих ее объектов в окне модели.

Чтобы вернуть отображение состава локальной детали, следует выделить ее и вызвать из контекстного меню команду Показать состав.


Команда Включить в расчет

Позволяет включить в расчет выбранные объекты (плоскости, оси, компоненты и др.).

Команда вызывается из контекстного меню выделенного объекта.

Команда недоступна, если ни один из выделенных объектов не является исключенным из расчета.

Подробнее об исключении объектов из расчета...

Смотрите также

Управление видимостью объектов


Команда Скрыть состав (макроэлемента)

Команда Скрыть состав
(макроэлемента)

Позволяет скрыть состав макроэлементов, выделенных в Дереве построения. Команда доступна в контекстном меню макроэлементов, состав которых не скрыт.

После вызова команды Скрыть состав значок «+» у пиктограммы макроэлемента исчезнет. Просмотр состава такого макроэлемента в Дереве построения станет невозможен.

Способ отображения макроэлемента в Дереве никак не влияет на отображение составляющих его объектов в окне модели.

Чтобы вернуть отображение состава макроэлементов, следует выделить их и вызвать из контекстного меню команду Показать состав.


Команда Показать состав (макроэлемента)

Команда Показать состав
(макроэлемента)

Позволяет показать состав макроэлементов, выделенных в Дереве построения. Команда доступна в контекстном меню макроэлементов, состав которых скрыт.

После вызова команды Показать состав у пиктограммы макроэлемента появится значок «+». Чтобы просмотреть состав макроэлемента в Дереве построения, следует щелкнуть мышью по этому значку.

Способ отображения макроэлемента в Дереве никак не влияет на отображение составляющих его объектов в окне модели.

Чтобы вновь отключить отображение состава макроэлементов, следует выделить их и вызвать из контекстного меню команду Скрыть состав.


Команда Переместить компонент

Позволяет переместить компонент.

Для вызова команды нажмите кнопку Переместить компонент на инструментальной панели Редактирование сборки или выберите ее название из меню Сервис.

После вызова команды курсор меняет свою форму на четырехстороннюю стрелку.

Установите курсор на перемещаемый компонент (при этом подсвечивается грань, ребро или вершина, оказавшаяся под курсором), нажмите левую кнопку мыши и, не отпуская ее, перемещайте курсор. Компонент будет перемещаться в том же направлении. Когда нужное положение компонента будет достигнуто, отпустите кнопку мыши.

Группа переключателей Режимы позволяет выполнить:

– Простое перемещение — перемещение без дополнительных действий,

– Автосопряжения — перемещение с автоматическим наложением сопряжений,

– Контроль соударений — перемещение с контролем соударений компонентов.

Сдвиг компонента возможен, если движению в данном направлении не препятствуют наложенные сопряжения.

Положение зафиксированного компонента изменить нельзя. При установке курсора на таком компоненте ни один из его объектов не подсвечивается — это означает, что сдвиг невозможен по причине фиксации компонента.

Для выхода из команды перемещения компонента нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Команда Повернуть компонент


Команда Создать макроэлемент (трехмерный)

Команда Создать макроэлемент
(трехмерный)

Позволяет создать в модели новый макроэлемент, не содержащий ни одного объекта. Команда доступна в контекстном меню и в меню Сервис.

Созданный макроэлемент будет расположен внизу Дерева построения. Вы можете добавить в него существующие и вновь созданные объекты.


Команда Объединить в макроэлемент

Позволяет создать в модели новый макроэлемент, содержащий выделенные объекты (объект). Команда доступна в контекстном меню и в меню Сервис.

После вызова команды в модели появится макроэлемент, содержащий указанные объекты. Он будет расположен на месте самого нижнего из включенных в этот макроэлемент объектов. Пиктограммы объектов разместятся на уровне, следующем за уровнем макроэлемента. Порядок расположения объектов в макроэлементе совпадает с порядком их расположения в Дереве построения перед созданием макроэлемента.

Объединить в макроэлемент можно только такие объекты, которые входят в состав одного и того же «родительского» объекта и располагаются на одном и том же уровне, за исключением:

– эскизов в составе операции по сечениям,

– сгибов в составе листового элемента (например, сгибов в составе подсечки),

– экземпляров массива.

Таким образом, невозможно объединить в макроэлемент объекты, принадлежащие разным компонентам модели, разным макроэлементам, макроэлементу и всей модели, компоненту модели и всей модели и т.п.


Команда Перестроить

После редактирования модели (перемещения компонентов, изменения значений переменных и т.п.) связи между компонентами модели могут нарушиться. Например, вспомогательные элементы после перемещения их опорных объектов остаются на прежних местах. Компоненты, редактирование которых вызвало конфликты такого рода, помечаются в Дереве построения красной «галочкой».

Перестроение может также потребоваться после изменения последовательности операций или после изменения значений переменных.

Чтобы устранить возникшие противоречия, необходимо перестроить и/или переместить объекты так, чтобы их форма, параметры и положение соответствовали положению опорных объектов, значениям переменных, последовательности построения и не противоречили наложенным сопряжениям. Для этого используется команда Перестроить.

Для вызова команды нажмите кнопку Перестроить на панели Вид или выберите ее название в меню Вид.

Иногда после перестроения модели в ней могут появиться признаки ошибки — восклицательные знаки в красном кружке, свидетельствующие об ошибках построения объектов. Например, на грани детали был построен эскиз вырезанного элемента выдавливания. При редактировании эту деталь переместили так, что эскиз, по-прежнему оставаясь в плоскости грани, при выдавливании не пересекает тела детали. Вырезание элемента выдавливания становится невозможным, и после перестроения модели эта операция помечается в Дереве построения как ошибочная.

Предупреждения об ошибках...


Команда Разнести

Позволяет разнести в пространстве компоненты сборки (это может потребоваться для более наглядного представления сборки).

Команда доступна, если для текущей сборки заданы компоненты и параметры разнесения (направление и расстояние). Для настройки разнесения служит команда Сервис — Разнести компоненты — Параметры.

Разнесение компонентов сборки

Для разнесения сборки нажмите соответствующую кнопку на панели Режимы или вызовите команду Сервис — Разнести компоненты — Разнести.

Все компоненты сборки, для которых заданы параметры разнесения, будут разнесены в соответствии с этими параметрами, а кнопка останется нажатой. К имени документа в заголовке окна добавятся слова «Разнесенный вид» в круглых скобках. В окне документа появляется значок режима разнесения компонентов.

Чтобы отключить разнесение компонентов (привести сборку в «неразобранное» состояние), вызовите команду Разнести снова или щелкните мышью по значку режима.

Когда компоненты сборки разнесены, недоступны все команды редактирования сборки (в том числе команда Редактировать в окне), команды создания пространственных кривых, поверхностей, вспомогательных объектов, элементов оформления, команды наложения сопряжений и команды работы со спецификацией.

Подсборка не может быть отображена в окне сборки в разнесенном виде.


Команда Разнести компоненты — Параметры

Позволяет установить или отредактировать параметры разнесения компонентов сборки.

Для вызова команды выберите ее название из меню Сервис или из меню кнопки Разнести компоненты на панели Режимы.

После вызова команды на экране появляется диалог задания параметров разнесения компонентов.

В окне Шаг разнесения на вкладке Параметры Панели свойств отображается список шагов разнесения компонентов. Если настройка параметров разнесения текущей сборки еще не производилась, то список пуст.

Чтобы добавить шаг разнесения, нажмите кнопку Добавить.

После этого нужно указать компоненты, участвующие в шаге разнесения, выбрать направление разнесения и задать расстояние.

Указание компонентов для разнесения

Выбор объекта, задающего направление разнесения

Введите в соответствующее поле расстояние, на которое должен переместиться компонент относительно своего прежнего положения.

После задания параметров шага разнесения компонентов нажмите кнопку Применить на Панели специального управления. Выбранные компоненты будут разнесены в соответствии с установленными параметрами.

Если полученное разнесение компонентов отличается от ожидаемого, отредактируйте параметры разнесения.

Для изменения направления перемещения компонента воспользуйтесь переключателем Направление.

После этого снова нажмите кнопку Применить.

Задайте требуемое количество шагов разнесения и настройте их параметры.

Для завершения настройки разнесения сборки нажмите кнопку Прервать команду на Панели специального управления.

После этого сборка отображается в разнесенном виде.

Чтобы включить режим обычного отображения сборки, нажмите кнопку Разнести компоненты на панели Режимы, или вызовите команду Сервис — Разнести компоненты — Разнести, или щелкните мышью по значку режима разнесения в окне документа.

Эта команда служит переключателем режима разнесения и обычного отображения сборки. Когда компоненты разнесены, кнопка Разнести компоненты находится в нажатом состоянии, а в окне документа появляется значок режима разнесения.


Команда Удалить элементы под указателем

Позволяет удалить все элементы и объекты модели, расположенные в Дереве построения ниже Указателя окончания построения модели.

После вызова команды на экране появляется диалог-предупреждение. В нем перечислены удаляемые элементы модели. Вы можете отказаться от удаления или подтвердить его.

Обратите особое внимание на то, что отменить удаление объекта в документе-модели невозможно. Поэтому командой удаления нужно пользоваться очень осторожно.


Команда Указатель в конец Дерева

Перемещает Указателя окончания построения модели в конец Дерева построения.

После вызова команды все элементы модели включаются в расчет (если только они не исключены специально). Модель перестраивается с учетом включенных элементов.


Команда Повернуть компонент

Позволяет повернуть компонент следующими способами:

– вокруг центральной точки габаритного параллелепипеда данного компонента,

– вокруг точки (вершины, начала системы координат или точки в эскизе),

– вокруг прямолинейного объекта.

Для вызова команды нажмите кнопку Повернуть компонент на инструментальной панели Редактирование сборки или выберите ее из меню Сервис.

После вызова команды внешний вид курсора изменится (он превратится в две дугообразные стрелки).

По умолчанию в команде выполняется вращение компонента вокруг центральной точки габаритного параллелепипеда.

Чтобы повернуть компонент вокруг точки или прямолинейного объекта, активизируйте переключатель Центр/ось вращения и укажите нужный объект в Дереве построения или в окне модели.

Установите курсор на компоненте, который необходимо повернуть (при этом подсвечивается грань, ребро или вершина, оказавшаяся под курсором), нажмите левую кнопку мыши в окне модели и, не отпуская ее, перемещайте курсор. Компонент будет поворачиваться вокруг центральной точки своего габаритного параллелепипеда.

Зависимость между движением курсора и направлением поворота компонента

Группа переключателей Режимы позволяет выполнить:

– Простое вращение — вращение без дополнительных действий,

– Автосопряжения — вращение с автоматическим наложением сопряжений,

– Контроль соударений — вращение с контролем соударений компонентов.

Поворот компонента возможен, если перемещению в данном направлении не препятствуют наложенные сопряжения.

Положение зафиксированного компонента изменить нельзя. При установке курсора на таком компоненте ни один из его объектов не подсвечивается — это означает, что поворот невозможен по причине фиксации компонента.

Для выхода из команды перемещения компонента нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Команда Переместить компонент


Команда Выбрать

Позволяет выбрать таблицу сгибов для текущей детали.

После вызова команды на экране появится диалог, в котором следует указать папку и имя файла таблицы сгибов. По умолчанию таблицы сгибов разыскиваются в папке, заданной переменной среды SHEETMETAL.

В дальнейшем — при создании в детали сгиба с применением таблицы — будет использоваться указанная таблица сгибов. Данные из таблицы при этом записываются в деталь. Связь детали с файлом таблицы не формируется.

Если деталь уже содержит таблицу сгибов, то вызов команды Выбрать означает смену таблицы. В этом случае на экране появится диалог с сообщением: «Выбор другой таблицы сгибов приведет к замене таблицы сгибов в текущей детали. Все сгибы, параметр развертки которых определяется по таблице, получат новые значения этого параметра. Продолжить?» Вы можете отказаться от смены таблицы сгибов или подтвердить ее.

В результате смены таблицы сгибов автоматически изменяются свойства всех элементов листового тела, параметр развертки которых извлекался из таблицы: значение этого параметра будет выбрано из новой таблицы. Пиктограммы измененных элементов в Дереве модели будут отмечены красными «галочками», означающими необходимость перестроения.


Команда Удалить таблицу сгибов

Позволяет удалить таблицу сгибов из текущей детали.

При этом у листовых элементов, построенных с использованием таблицы, автоматически изменится способ определения длины развертки. Он будет соответствовать типу использовавшейся таблицы сгибов. Значение параметра развертки останется равным табличному значению для текущего радиуса, угла сгиба и толщины материала.

Пример...

Модель может содержать элементы с автоматически определяемыми углами сгиба:

– листовое тело с разомкнутым эскизом (углы сгибов определяются параметрами объектов эскиза),

– подсечка, заданный размер которой меньше минимального (углы сгибов рассчитываются системой).

Если эти элементы используют таблицу сгибов, то при ее удалении обработка этих элементов производится следующим образом.

Способ определения длины развертки автоматически меняется на способ, соответствующий типу использовавшейся таблицы. Параметр развертки принимает умолчательное значение.

Если листовые элементы с автоматически определяемыми углами сгиба содержат сгибы, у которых включено определение параметров по исходному объекту (т.е. активна опция По исходному объекту, подробнее см. раздел Редактирование сгиба), то на экране появляется диалог выбора сгибов.

Он содержит перечень сгибов, имеющих описанные свойства, и позволяет настроить обработку этих сгибов при удалении таблицы.


Команда Сохранить как...

Позволяет записать в файл таблицу сгибов, хранящуюся в текущей детали.

Команда Таблица сгибов — Сохранить как... доступна, если в детали есть хотя бы один сгиб, построенный с использованием таблицы.

После вызова команды на экране появляется диалог, в котором следует указать папку и имя файла для записи. Умолчательное расширение файла таблицы сгибов — loa, умолчательное местоположение — папка, заданная переменной среды SHEETMETAL.


Команда Показать состав(локальной детали)

Команда Показать состав
(локальной детали)

Позволяет показать состав локальной детали, выделенной в Дереве построения. Команда доступна в контекстном меню локальной детали, состав которой скрыт.

После вызова команды Показать состав у пиктограммы локальной детали появится значок «+». Чтобы просмотреть состав локальной детали в Дереве построения, следует щелкнуть мышью по этому значку.

Способ отображения локальной детали в Дереве никак не влияет на отображение составляющих ее объектов в окне модели.

Чтобы вновь отключить отображение состава локальной детали, следует выделить ее и вызвать из контекстного меню команду Скрыть состав.


Команда Таблица переменных

Позволяет открыть таблицу переменных модели, вставляемой (вставленной) в другую модель, и выбрать новые значения внешних переменных модели.

Во время вставки модели в другую модель вызов команды Таблица переменных осуществляется с помощью одноименной кнопки на вкладке Файл-источник Панели свойств.

После того как модель вставлена, команда Таблица переменных доступна в контекстном меню пиктограммы этой модели в Дереве построения, а также на Панели свойств во время редактирования вставки.

После вызова команды на экране появляется окно Таблица переменных. Укажите в таблице нужную строку и закройте окно кнопкой ОК. Внешние переменные модели получат значения, записанные в ячейках выбранной строки.

Команда Таблица переменных доступна, если таблица переменных, хранящаяся во вставляемой (вставленной) модели, содержит более одной строки.

Смотрите также

Создание, редактирование и удаление таблицы переменных


Команда Удалить параметры развертки

Команда позволяет удалить из текущей детали параметры развертки листового тела. При удалении параметров развертки из детали удаляется также ориентация Развертка.


Команда Отобразить сечение

Позволяет включить режим сечения модели. В этом режиме модель отображается усеченной текущим сечением.

Команда вызывается следующими способами:

– из меню Вид — Сечение модели,

– нажатием кнопки Сечение модели на панели Вид.

Если в модели не создано ни одного сечения, то после вызова команды запускается процесс создания сечения, а после завершения процесса включается режим сечения модели.

При включенном режиме кнопка Сечение модели активизирована, а в окне модели отображается соответствующий значок.

В режиме сечения модели вы можете выполнять любые операции построения объектов, измерения, включать другие режимы (например, режим контекстного редактирования, режим эскиза и др.).

При выполнении операций доступно указание вершин, ребер и граней модели, в том числе усеченных, но недоступно указание вершин, ребер и граней сечения.

Чтобы завершить работу в режиме, повторно вызовите команду Вид — Сечение модели — Отобразить сечение, или нажмите кнопку Сечение модели на панели Вид, или щелкните мышью по значку режима в окне модели.

Смотрите также

Управление сечениями

Список сечений модели


Кнопка Добавить компонент в группу

Позволяет включить компонент в группу компонентов с одним и тем же номером позиции. Компонент включается в текущую группу.

Перед нажатием кнопки добавляемый компонент следует выделить в Дереве построения или в окне модели.

После добавления компонента в группу его обозначение появляется в окне Группы компонентов, в списке компонентов текущей группы.

Подробнее о компонентах с одним номером позиции...


Активизация вкладки Панели свойств

Команда позволяет активизировать соответствующую вкладку Панели свойств.

Если рядом с названием команды в меню находится «галочка», это означает, что вкладка отображается на экране.


Команда Добавить объект таблицы изменений

Позволяет создать в чертеже объект таблицы изменений.

После вызова команды на экране появляется окно, оформленное в виде строки таблицы изменений, в котором можно ввести текстовую часть объекта таблицы изменений, а также перейти к вводу дополнительных параметров нового объекта таблицы изменений.

Если чертеж включает несколько листов с оформлениями, содержащими таблицу изменений, то после вызова команды на экране появится диалог, позволяющий выбрать номер листа, в таблицу изменений которого будет добавлен объект.

Если в чертеже не используются оформления, содержащие таблицу изменений, то команда Добавить объект таблицы изменений недоступна.


Команда Добавить объект таблицы изменений (контекстное меню)

Команда Добавить объект таблицы изменений
(контекстное меню)

Команда позволяет добавить объект в таблицу изменений, из контекстного меню которой она была вызвана.

После вызова команды на экране появляется окно, оформленное в виде строки таблицы изменений, в котором можно ввести текстовую часть объекта таблицы изменений, а также перейти к вводу дополнительных параметров нового объекта таблицы изменений.


Команда Добавить объект спецификации

Позволяет создать в документе (листе чертежа, фрагменте или модели) объект для последующего его переноса в подключенную спецификацию.

Для вызова команды нажмите кнопку Объект спецификации на панели Спецификация или выберите ее название из меню Спецификация.

После вызова команды на экране появляется окно, оформленное в виде строки бланка спецификации, в котором можно ввести текстовую часть объекта спецификации, а также перейти к вводу дополнительных параметров нового объекта спецификации.

При вставке деталей в сборку в нее автоматически переносятся объекты спецификации, созданные в этих деталях.


Команда Добавить объект спецификации — Внешний

Позволяет создать в документе-сборке внешний объект спецификации.

Для вызова команды нажмите кнопку Добавить внешний объект спецификации на панели Спецификация или выберите ее название из меню Спецификация.

После вызова команды на экране появляется диалог выбора раздела и типа объекта, в котором требуется указать раздел для расположения внешнего объекта. После этого на экране появляется окно, оформленное в виде строки бланка спецификации. Вы можете ввести текстовую часть нового внешнего объекта спецификации сборки, а также перейти к вводу его дополнительных параметров.

Если перед вызовом команды создания объекта спецификации в Дереве построения была выделена текущая сборка (самый первый элемент Дерева), то колонки Обозначение, Наименование и дополнительная колонка Масса заполняются автоматически, а текущий документ-сборка подключается к создаваемому объекту спецификации. При этом в колонки Обозначение и Наименование помещаются данные, введенные при настройке свойств сборки, а в колонку Масса — суммарная масса компонентов сборки.

Автоматическое заполнение текстовой части объекта спецификации предпочтительнее, чем ручной ввод данных, так как позволяет избежать случайных ошибок.


Кнопка Создать группу

Позволяет создать в сборке новую группу компонентов с одним и тем же номером позиции. После нажатия кнопки на экране появляется диалог для ввода имени группы.

Новая группа пуста. Включите в нее компоненты с помощью кнопки Добавить компонент в группу.

Подробнее о компонентах с одним номером позиции...


Команда Добавить текстовую метку

Позволяет добавить текстовую метку к следующим объектам:

– обозначению допуска формы,

– знаку шероховатости,

– обозначению базовой поверхности.

Команда вызывается из контекстного меню выделенного объекта. Команда отображается, если среди выделенных объектов находится объект (объекты), к которому можно добавить метку. После вызова команды к выбранному объекту добавляется текстовая метка с умолчательным текстом.

Подробнее о текстовых метках...


Кнопка Добавить выделенные объекты

Позволяет добавить в текущую группу нумерации объекты, выделенные в окне документа.

При добавлении объекта в группу ему автоматически присваивается номер. Номер объекта в документе является ссылкой на номер соответствующего ему объекта в группе нумерации.

Подробнее о добавлении объектов в группу нумерации...

Смотрите также

Автоматическая нумерация объектов


Команда Создать новую вершину

Позволяет добавить строку в таблицу параметров сплайна или ломаной.

Для вызова команды можно также нажать кнопку Создать новую вершину на панели Координаты вершин.

Новая строка добавляется перед выделенной и содержит такие же значения.

Вы можете ввести значения координат вручную или указать существующую в модели вершину.


Команда Лист

Позволяет добавить лист чертежа. Параметры добавленного листа будут соответствовать настройкам новых листов документа.


Команда Булева операция

Позволяет произвести булеву операцию над двумя телами, имеющимися в текущей модели. Результатом операции является новое тело. Оно может участвовать в любых последующих операциях, в том числе булевых.

Команда доступна, если в модели существует более одного тела.

Пример объединения тел

Пример вычитания тел

Пример пересечения тел

Для вызова команды нажмите кнопку Булева операция на инструментальной панели редактирования детали или на инструментальной панели редактирования модели. Можно также выбрать название команды из меню Операции.

Укажите первое и второе тела, участвующие в операции.

Указанные тела подсвечиваются в окне модели. Соответствующие им пиктограммы выделяются цветом в Дереве построения. Названия объектов, принадлежащих телам, отображаются в Списке объектов на вкладке Параметры Панели свойств.

Чтобы выбрать другие объекты для выполнения операции, нажмите кнопку Указать заново на Панели специального управления. Текущее выделение объектов будет отменено, и вы сможете указать новые.

Если неправильно выбрано только второе тело, просто укажите нужное, не отменяя предыдущего выбора.

Задайте тип булевой операции с помощью группы переключателей Результат операции.

Чтобы объединить выбранные тела, активизируйте переключатель Объединение.

Чтобы удалить из первого тела объем, занимаемый вторым телом, активизируйте переключатель Вычитание. Первым считается тело, находящееся на первой позиции списка, а вторым — тело, находящееся на второй позиции.

Для изменения порядка следования тел воспользуйтесь кнопками Переместить вверх и Переместить вниз на панели Список тел.

Чтобы удалить весь объем обоих тел, кроме их общего объема, активизируйте переключатель Пересечение.

Объединение тел возможно, если они пересекаются или имеют общую поверхность, а вычитание и пересечение возможны, только если тела пересекаются.

Наименование объекта (название, которое отображается в Дереве построения) можно задать на вкладке Свойства.

Задав параметры операции, нажмите кнопку Создать объект на Панели специального управления. Если в результате операции образуется тело из нескольких частей, то после выполнения операции запускается процесс изменения набора частей.

Чтобы отказаться от операции, нажмите кнопку Прервать команду Панели специального управления или клавишу <Esc>.

Смотрите также

Другие команды редактирования детали

Другие команды редактирования сборки


Команда Вставка — Выражения из коллекции (меню Окна переменных)

Команда Вставка — Выражения из коллекции
(меню Окна переменных)

Позволяет использовать элементы выражения из предопределенного списка для присвоения значения переменной.

Команда вызывается из меню Окна переменных.

После вызова команды на экране появляется диалог Вставка математического выражения, в котором раскрыта группа для выбора выражения, содержащегося в файле коллекции collection.law.

Вы можете вставить в Окно переменных выражение из коллекции или элемент любой другой группы.

Вставка элементов выражения


Команда Вставить константу (меню Окна переменных)

Команда Вставить константу
(меню Окна переменных)

Позволяет использовать элементы выражения из предопределенного списка для присвоения значения переменной.

Для вызова команды нажмите кнопку Вставить константу на инструментальной панели Окна переменных или вызовите команду Вставка — Константы системной из меню этого окна.

После вызова команды на экране появляется диалог Вставка математического выражения, в котором раскрыта группа для выбора констант.

Вы можете вставить в Окно переменных константу или элемент любой другой группы.

Вставка элементов выражения


Команда Удалить (меню Окна переменных)

Команда Удалить
(меню Окна переменных)

Позволяет удалить переменную или выражение, заданное для получения ее значения. Для удаления переменной необходимо выделить ячейку с ее именем, для удаления выражения — ячейку, содержащую это выражение. Ячейка выделяется щелчком мыши.

Для вызова команды нажмите кнопку Удалить на инструментальной панели Окна переменных или вызовите из меню этого Окна команду Редактор — Удалить. Можно также нажать клавишу <Delete>.

Переменная удаляется в том случае, если она не входит в выражения, заданные для вычисления других переменных. В противном случае переменная не удаляется, а на экране появляется диалог Использование переменной, содержащий список объектов текущего документа, в которых используется данная переменная.

Удаление автоматически созданной переменной, которая соответствует параметру трехмерного объекта, невозможно.

Удаление переменной размера...


Команда Переместить вниз (меню Окна переменных)

Команда Переместить вниз
(меню Окна переменных)

Позволяет переместить переменную главного раздела Окна переменных на одну позицию вниз.

Для этого щелкните мышью в строке переменной, которую требуется переместить, и вызовите команду Редактор — Переместить вниз из меню Окна переменных или нажмите кнопку Переместить вниз на инструментальной панели этого окна.

Команда доступна только для пользовательских переменных.


Команда Вызов справки

Позволяет вывести на экран раздел Справочной системы, содержащий общие сведения об Окне переменных.

Для вызова команды нажмите кнопку Вызов справки на инструментальной панели Окна переменных.


Команда Переместить вверх (меню Окна переменных)

Команда Переместить вверх
(меню Окна переменных)

Позволяет переместить переменную главного раздела Окна переменных на одну позицию вверх.

Для этого щелкните мышью в строке переменной, которую требуется переместить, и вызовите команду Редактор — Переместить вверх из меню Окна переменных или нажмите кнопку Переместить вверх на инструментальной панели этого окна.

Команда доступна только для пользовательских переменных.


Команда Открыть файл-источник ссылки (меню Окна переменных)

Команда Открыть файл-источник ссылки
(меню Окна переменных)

Позволяет открыть файл, значение переменной которого получает по ссылке переменная текущего документа, выделенная в окне переменных.

Команда находится в контекстном меню выделенной переменной и доступна при условии, что эта переменная получает значение по ссылке.

Если источником ссылки является модель с исполнениями, то при ее открытии текущим является исполнение, которое было текущим во время последнего сохранения. Обратите внимание на то, что это исполнение может не совпадать с исполнением, содержащим переменную, на которую сделана ссылка. Для перехода к редактированию нужного исполнения сделайте его текущим.


Команда Вставить функцию (меню Окна переменных)

Команда Вставить функцию
(меню Окна переменных)

Позволяет использовать элементы выражения из предопределенного списка для присвоения значения переменной.

Для вызова команды нажмите кнопку Вставить функцию на инструментальной панели Окна переменных или вызовите команду Вставка — Функции системной из меню этого окна.

После вызова команды на экране появляется диалог Вставка математического выражения, в котором раскрыта группа для выбора системных функций.

Вы можете вставить в Окно переменных системную функцию или элемент любой другой группы.

Вставка элементов выражения


Команда Вставка — Выражения из закона (меню Окна переменных)

Команда Вставка — Выражения из закона
(меню Окна переменных)

Позволяет использовать элементы выражения из предопределенного списка для присвоения значения переменной.

Команда вызывается из меню Окна переменных.

После вызова команды на экране появляется диалог Вставка математического выражения, в котором раскрыта группа для выбора выражений координат функций.

Вы можете вставить в Окно переменных выражение координаты нужной функции или элемент любой другой группы.

Вставка элементов выражения


Команда Меню (Окна переменных)

Команда Меню
(Окна переменных)

Позволяет вызвать меню, содержащее команды работы с переменными и выражениями.

Для вызова некоторых команд можно использовать также кнопки на инструментальной панели Окна переменных и контекстное меню.


Команда Вставка — Оператора (меню Окна переменных)

Команда Вставка — Оператора
(меню Окна переменных)

Позволяет использовать элементы выражения из предопределенного списка для присвоения значения переменной.

Команда вызывается из меню Окна переменных.

После вызова команды на экране появляется диалог Вставка математического выражения, в котором раскрыта группа для выбора операторов.

Вы можете вставить в Окно переменных оператор или элемент любой другой группы.

Вставка элементов выражения


Команда Вставка — Функции для полярной СК (меню Окна переменных)

Команда Вставка — Функции для полярной СК
(меню Окна переменных)

Позволяет использовать элементы выражения из предопределенного списка для присвоения значения переменной.

Команда вызывается из меню Окна переменных.

После вызова команды на экране появляется диалог Вставка математического выражения, в котором раскрыта группа для выбора функций для полярной СК.

Вы можете вставить в Окно переменных функцию или элемент любой другой группы.

Вставка элементов выражения


Команда Сохранить выражение

Позволяет сохранить выражение, используемое для вычисления значения переменной, в файл коллекции математических выражений collection.law.

Команда вызывается следующими способами:

– из меню Окна переменных,

– из контекстного меню переменной в Окне переменных,

– из контекстного меню поля Составление выражения в диалоге Вставка математического выражения.

В первых двух случаях в файл коллекции записывается содержимое поля Выражение Окна переменных, в последнем случае — содержимое поля Составление выражения диалога Вставка математического выражения.

Выражение, сохраненное в файл коллекции, добавляется в группу Из файла коллекции указанного выше диалога.


Команда Добавить в список свойств

Позволяет создать свойство из выбранной переменной.

После вызова команды рядом с ее названием появляется «галочка». Это означает, что свойство из данной переменной создано в документе. Повторный вызов команды удаляет это свойство.

Смотрите также

Свойства, созданные из переменных


Команда Назначить допуск (меню Окна переменных)

Команда Назначить допуск
(меню Окна переменных)

Позволяет выполнить назначение допуска для следующих переменных:

– переменных, соответствующих параметрам операций модели, выраженным в линейных или угловых величинах, — допуск назначается на параметр,

– переменных, соответствующих управляющим размерам эскизов и графических документов, — допуск назначается на размер.

В случае вызова команды для любой другой переменной на экране появляется сообщение о невозможности назначения допуска.

Команда вызывается из меню Окна переменных или контекстного меню переменной в этом окне. Доступна, если в Окне переменных выделена ячейка с именем переменной.

После вызова команды на экране появляется диалог Назначить допуск, позволяющий выполнить все необходимые действия.

Подробнее о назначении допусков в Окне переменных...

Смотрите также

Допуски


Команда Вставка — Предельных отклонений (меню Окна переменных)

Команда Вставка — Предельных отклонений
(меню Окна переменных)

Позволяет создать переменные предельных отклонений для:

– управляющего размера графического документа или эскиза,

– параметра операции модели, значение которого выражено в линейных или угловых величинах.

Команда вызывается из меню Окна переменных. Она доступна, если в Окне переменных выделена ячейка с именем переменной.

Перед вызовом команды необходимо выбрать исходную переменную — переменную указанного выше размера или параметра.

В случае вызова команды для любой другой переменной на экране появляется сообщение о невозможности создания переменных предельных отклонений.

Подробнее о создании переменных предельных отклонений...


Команда Вставка — Функции (меню Окна переменных)

Команда Вставка — Функции
(меню Окна переменных)

Позволяет использовать элементы выражения из предопределенного списка для присвоения значения переменной.

Команда вызывается из меню Окна переменных.

После вызова команды на экране появляется диалог Вставка математического выражения, в котором раскрыта группа для выбора функций.

Вы можете вставить в Окно переменных функцию или элемент любой другой группы.

Вставка элементов выражения


Команда Копировать (меню Окна переменных)

Команда Копировать
(меню Окна переменных)

Позволяет скопировать содержимое выделенной ячейки в буфер обмена. Чтобы выделить ячейку, щелкните в ней мышью один раз.


Команда Вырезать (меню Окна переменных)

Команда Вырезать
(меню Окна переменных)

Позволяет вырезать содержимое выделенной ячейки в буфер обмена. Чтобы выделить ячейку, щелкните в ней мышью один раз.


Команда Внешняя (меню Окна переменных)

Команда Внешняя
(меню Окна переменных)

Позволяет присвоить статус «внешняя» пользовательской переменной или отменить этот статус.

Команда доступна в контекстном меню переменных. Если переменная имеет статус «внешняя», то рядом с названием команды в меню отображается «галочка».

Внешние переменные модели доступны в той модели, в которую она вставлена. Аналогично внешние переменные фрагмента доступны в графическом документе, куда этот фрагмент вставлен.

Изменение внешней переменной вставки возможно, если эта переменная не является информационной.

Подробнее о внешних переменных...

В таблице переменных используется цветовая индикация статуса переменных:

– внешняя — синий цвет,

– информационная — желтый цвет,

– внешняя информационная — зеленый цвет.

Указанный цвет имеет ячейка таблицы, содержащая имя переменной.


Команда Найти (меню Окна переменных)

Команда Найти
(меню Окна переменных)

Позволяет найти в таблице переменных заданный текст. Для вызова команды можно также нажать комбинацию клавиш <Ctrl> + <F>.

После вызова команды на экране появляется диалог, в котором требуется ввести текст для поиска.


Команда Продолжить (меню Окна переменных)

Команда Продолжить
(меню Окна переменных)

Позволяет повторить поиск заданного текста в таблице переменных.

Для вызова команды можно также нажать клавишу <F3>.


Команда Информационная (меню Окна переменных)

Команда Информационная
(меню Окна переменных)

Позволяет присвоить пользовательской переменной статус «информационная» или отменить этот статус.

Команда доступна в контекстном меню пользовательских переменных в следующих случаях:

– переменная не является информационной,

– статус «информационная» присвоен вручную.

Если переменная имеет статус «информационная», то рядом с названием команды в меню отображается «галочка».

Если статус «информационная» присвоен внешней переменной модели или фрагмента, то эта переменная доступна при вставке модели в другую модель или фрагмента в другой графический документ, но изменение ее значения невозможно.

В таблице переменных используется цветовая индикация статуса переменных:

– внешняя — синий цвет,

– информационная — желтый цвет,

– внешняя информационная — зеленый цвет.

Указанный цвет имеет ячейка таблицы, содержащая имя переменной.


Команда Вставить (меню Окна переменных)

Команда Вставить
(меню Окна переменных)

Позволяет вставить содержимое буфера обмена в текущую позицию курсора.


Команда Только чтение (контекстное меню Окна переменных)

Команда Только чтение
(контекстное меню Окна переменных)

Позволяет запретить изменение способа получения значения выбранной переменной, т.е. сделать недоступной ячейку Выражение в строке этой переменной. Команда доступна, если данная ячейка не пуста.

После вызова команды слева от ее названия в меню появляется «галочка».

Чтобы вернуть возможность редактирования ячейки Выражение, повторно вызовите для нее команду Только чтение.

Если переменная, доступная только для чтения, имеет также статус «внешняя», то она может получать новые значения из таблицы переменных.


Команда Перестроить (меню Окна переменных)

Команда Перестроить
(меню Окна переменных)

Позволяет передать в модель изменения переменных.

После вызова команды модель перестраивается с учетом новых значений переменных.


Команда Использование переменной (меню Окна переменных)

Команда Использование переменной
(меню Окна переменных)

Позволяет просмотреть список объектов текущего документа, в которых используется выделенная в списке переменная.

Для вызова команды нажмите кнопку Использование переменной на инструментальной панели Окна переменных или выберите ее название из меню этого Окна.

После этого на экране появляется диалог с перечнем объектов.


Команда Сортировать (меню Окна переменных)

Команда Сортировать
(меню Окна переменных)

Позволяет выполнить сортировку переменных главного раздела. Перед вызовом команды выделите ячейку столбца, по данным которого требуется отсортировать переменные. Повторный вызов команды изменяет направление сортировки на противоположное.

Переменные сортируются по любому из столбцов, кроме столбца Выражение.


Выравнивание абзацев текста

Чтобы выровнять выделенные или набираемые заново абзацы текста по левому краю, нажмите кнопку Выровнять влево.

Чтобы выровнять выделенные или набираемые заново абзацы текста по центру, нажмите кнопку Центрировать.

Чтобы выровнять выделенные или набираемые заново абзацы текста по правому краю, нажмите кнопку Выровнять вправо.

Чтобы выровнять выделенные или набираемые заново абзацы текста по ширине, нажмите кнопку Выровнять по ширине.


Команда Все точки пересечений кривой

Позволяет построить точки в местах всех пересечений указанной кривой с другими кривыми.

Для вызова команды нажмите кнопку Все точки пересечений кривой на инструментальной панели Геометрия.

Укажите курсором кривую для поиска пересечений.

После этого автоматически будут созданы точки в местах ее пересечения с другими кривыми, расположенными в текущих и активных видах и слоях.

Пример простановки всех точек пересечений эллипса
с двумя кривыми

Выбор стиля точки

Для выхода из команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие геометрические объекты


Переключатель Сортировка

Активизация переключатель Сортировка позволяет расположить в алфавитном порядке свойства выделенного объекта (объектов), отображающиеся в окне Свойства.

Второй способ отображения перечня свойств — разбиение на группы. Группы можно сворачивать (разворачивать), щелкая мышью на значке «плюс» (минус) слева от названия группы. Набор групп свойств зависит от типа выделенного объекта (объектов). Для применения этого способа служит активизация переключателя Группировка.


Команда Угловой размер(документ-модель)

Команда Угловой размер
(документ-модель)

Позволяет проставить угловой размер между прямолинейными и плоскими объектами, которые являются сторонами угла.

Пример

Для вызова команды нажмите кнопку Угловой размер на инструментальной панели Элементы оформления.

Укажите курсором два прямолинейных объекта, два плоских или прямолинейный и плоский.

Подробнее...

Тип вновь созданного углового размера определяется системой автоматически. При необходимости с помощью переключателей группы Тип на вкладке Размер Панели свойств вы можете изменить предложенный системой способ простановки размера, в том числе включить простановку угла больше 180° (автоматический выбор этого варианта невозможен).

Задайте положение размерной линии. Для этого введите значение длины выносных линий в поле Длина (значение может быть как положительным, так и отрицательным) или переместите мышью характерные точки на ее концах.

Чтобы направить размерные линии в противоположную сторону, сохранив их длину, нажмите кнопку Сменить положение.

В поле Текст отображается автоматически сформированная размерная надпись. Чтобы вызвать диалог редактирования и настройки размерной надписи, щелкните мышью в этом поле.

Элементы управления, расположенные на вкладке Параметры, позволяют настроить параметры размеров (вид стрелки, способ размещения текста и т.п.).

Элементы управления, расположенные на вкладке Свойства, позволяют задать наименование размера в Дереве построения и цвет отрисовки размерных линий.

Размещение размерной надписи на полке

Смотрите также

Другие элементы оформления


Команда Вид приложения...

Позволяет выбрать стиль отображения элементов окна системы. После вызова команды на экране появляется диалог, в котором можно установить нужный стиль.


Команда За объектом

Помещает выделенный объект за указанным. После вызова команды необходимо указать объект, за которым требуется разместить выделенный. В результате он будет перекрываться указанным объектом и всеми последующими объектами.

Смотрите также

Управление порядком отрисовки объектов


Команда Перед объектом

Помещает выделенный объект перед указанным. После вызова команды необходимо указать объект, перед которым требуется разместить выделенный. В результате он будет перекрывать указанный объект и все предыдущие объекты.

Смотрите также

Управление порядком отрисовки объектов


Команда На уровень назад

Меняет местами выделенный объект и объект, находящийся за ним.

Смотрите также

Управление порядком отрисовки объектов


Команда На уровень вперед

Меняет местами выделенный объект и объект, находящийся перед ним.

Смотрите также

Управление порядком отрисовки объектов


Команда Позади всех

Помещает выделенный объект за всеми объектами. В результате перемещенный объект будет перекрываться всеми остальными.

Смотрите также

Управление порядком отрисовки объектов


Команда Впереди всех

Помещает выделенный объект перед всеми объектами. В результате перемещенный объект будет перекрывать все остальные.

Смотрите также

Управление порядком отрисовки объектов


Команда Передать в исполнения

Команда позволяет передать объекты текущего исполнения в другие исполнения модели. Вызывается из меню Редактор.

После вызова команды на Панели свойств появляются панели Список объектов и Исполнения.

Сформируйте список объектов текущего исполнения, которые требуется передать, указав их мышью в Дереве построения или в окне модели. Наименования выбранных объектов будут отображены на панели Список объектов.

Кнопка Удалить из списка, расположенная на этой панели, позволяет удалить объект из списка передаваемых.

При необходимости вы можете полностью очистить список объектов, нажав кнопку Указать заново на Панели специального управления.

Для настройки списка исполнений, в которые должны быть переданы объекты, используется панель Исполнения.

По умолчанию на этой панели отображаются все исполнения, имеющиеся в модели. Если требуется, чтобы список содержал только зависимые исполнения текущего исполнения, нажмите кнопку Только зависимые исполнения.

Опция, расположенная слева от обозначения исполнения в списке, управляет передачей объектов в это исполнение. Если опция включена, то объекты передаются в исполнение, если опция отключена — не передаются. Настройте список исполнений, включая и отключая нужные опции.

Если требуется включить или отключить все опции в списке, используйте кнопки Включить все и Выключить все.

Для передачи объектов нажмите кнопку Создать объект.

Особенности передачи объектов в исполнения:

– если передаваемый объект имеет исходные объекты, например, эскизы, то эти объекты также передаются в выбранные исполнения,

– если передаваемый объект уже содержится в выбранных исполнениях, то в эти исполнения данный объект не передается,

– если на передаваемые компоненты модели наложены сопряжения, то эти сопряжения не передаются в зеркальное исполнение модели.

Если требуется прервать работу команды до ее завершения, нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.


Начальная точка

Переключатель, позволяющий перейти к редактированию положения начальной точки.

Указание точки дуги...

Изменение положения точки отображается на фантоме дуги в окне модели.


Конечная точка

Переключатель, позволяющий перейти к редактированию положения конечной точки дуги.

Указание точки дуги...

Изменение положения точки отображается на фантоме дуги в окне модели.


Элемент Кривая

Переключатель, позволяющий задать кривую, которой должна касаться окружность дуги.

В качестве кривой может использоваться:

– координатная или вспомогательная ось,

– пространственная кривая,

– линия эскиза,

– ребро.

Кривую следует указывать в окне модели или в Дереве построения.

Название указанной кривой отображается в поле рядом с переключателем.

Чтобы сменить ранее выбранную кривую, активизируйте переключатель Кривая и укажите нужную кривую.


Точка на окружности

Переключатель, позволяющий перейти к редактированию положения точки на окружности (промежуточной).

Указание точки дуги...

Изменение положения точки отображается на фантоме дуги в окне модели.


Команда Дуга окружностиПостроение способом По 3 точкам

Команда Дуга окружности
Построение способом По 3 точкам

Данный способ позволяет построить дугу окружности по трем точкам.

Пример

Способ можно сделать текущим, выбрав название По 3 точкам из списка Способ на Панели свойств или контекстного меню команды Дуга окружности.

Укажите начальную точку дуги 1, затем конечную точку дуги 2 и промежуточную точку на дуге 3.

Подробнее...


Команда Дуга по двум точкам

Позволяет построить дугу с указанными конечными точками.

Для вызова команды нажмите кнопку Дуга по двум точкам на инструментальной панели Геометрия.

Введите значение радиуса или диаметра создаваемой дуги в поле Радиус или Диаметр на Панели свойств.

Укажите начальную (т1) и конечную (т2) точки дуги.

Для точного позиционирования курсора воспользуйтесь привязками или меню геометрического калькулятора в полях т1 и т2 на Панели свойств.

В документе будет построена дуга с указанными параметрами.

Вы можете создать дугу по двум точкам, не вводя точное значение диаметра. В этом случае будет построена дуга с углом раствора в 180 градусов и радиусом, равным половине расстояния между указанными точками.

Построение дуги по двум точкам

Выбор стиля линии

Группа переключателей Направление на Панели свойств управляет направлением построения дуги.

Для выхода из команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие геометрические объекты


Команда Дуга по двум точкам и углу раствора

Позволяет построить одну или несколько дуг, начинающихся и заканчивающихся в указанных точках и имеющих заданный угол раствора.

Для вызова команды нажмите кнопку Дуга по двум точкам и углу раствора на инструментальной панели Геометрия.

Введите в поле Угол Панели свойств угол раствора дуги (по умолчанию он равен 90 градусам).

Укажите начальную (т1) и конечную (т2) точки дуги.

Для точного позиционирования курсора воспользуйтесь привязками или меню геометрического калькулятора в полях т1 и т2 на Панели свойств.

Координаты центральной точки дуги и ее радиус будут рассчитаны автоматически.

Построение дуги по двум точкам и углу раствора

Выбор стиля линии

Группа переключателей Направление на Панели свойств управляет направлением построения дуги.

Для выхода из команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие геометрические объекты


Команда Дуга по трем точкам

Позволяет построить дугу с указанными конечными точками и проходящей через заданную точку.

Для вызова команды нажмите кнопку Дуга по трем точкам на инструментальной панели Геометрия.

Укажите начало дуги (т1), точку, через которую должна пройти дуга (т2), и конец дуги (т3) в любом порядке. Центр и радиус дуги будут рассчитаны автоматически.

Для точного позиционирования курсора воспользуйтесь привязками или меню геометрического калькулятора в полях т1, т2 и т3 на Панели свойств.

Построение дуги по трем точкам

Выбор стиля линии

Чтобы построить несколько дуг, выходящих из одной точки, введите начальную точку первой дуги и нажмите кнопку Запомнить состояние Панели специального управления. После этого последовательно вводите дуги, задавая их вторую и третью точки.

Подробнее о запоминании параметров...

Для выхода из команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие геометрические объекты


Угол дуги

Поле для ввода угла дуги, определяющего точку дуги (начальную или конечную).

Угол отсчитывается от оси абсцисс системы координат базовой плоскости.

Вы можете задать угол дуги следующими способами:

– ввести значение вручную или установить с помощью счетчика;

– указать положение точки дуги мышью в окне модели: угол определяется автоматически и заносится в поле Угол;

– связать с уже имеющимся точечным объектом: включить опцию Ассоциировать и указать в модели точечный объект.


Угол дуги

Поле для ввода угла дуги, определяющего точку дуги (начальную или конечную).

Угол отсчитывается от луча, направленного из центра дуги в точку касания.

Вы можете задать угол дуги следующими способами:

– ввести значение вручную или установить с помощью счетчика;

– указать положение точки дуги мышью в окне модели: угол определяется автоматически и заносится в это поле;

– связать с уже имеющимся точечным объектом: включить опцию Ассоциировать и указать в модели точечный объект.


Команда Дуговая координационная ось

Позволяет создать обозначение дуговой координационной оси, используемое в строительной документации.

Для вызова команды нажмите кнопку Дуговая координационная ось на инструментальной панели Обозначения для строительства или выберите ее название из меню Инструменты — Обозначения для строительства.

Укажите точку центра дуги оси (тС). На экране появится фантом обозначения с умолчательными параметрами.

Чтобы ввести надпись в обозначение, вызовите диалог ввода текста. Для этого щелкните мышью в поле Текст на Панели свойств или вызовите команду Текст надписи... из контекстного меню.

Пример использования и параметры дуговой координационной оси

Чтобы при вводе текста производилось автоматическое присвоение обозначений маркам, активизируйте переключатель Автопродолжение. Выберите из контекстных меню поля Текст номер, букву и индекс текущего обозначения. В режиме автопродолжения следующей марке будет присвоено следующее по порядку обозначение.

Формирование обозначения координационной оси

Укажите начальную (т1) и конечную (т2) точки оси или введите полярные координаты этих точек в поля Угол 1, Угол 2 и Радиус (или Диаметр). Значения углов отсчитываются от оси ОХ текущей системы координат.

В документе будет создана дуговая координационная ось, состоящая из дуги, ограниченной точками т1 и т2, и прямолинейных выступов. Выступы расположены по касательным к дуге оси.

В случае построения оси при помощи мыши углы и радиус дуги будут определены автоматически и занесены в поля Угол 1, Угол 2 и Радиус (или Диаметр).

Группа переключателей Направление на Панели свойств управляет направлением построения дуги координационной оси.

Во время построения оси можно изменить параметры отрисовки оси и параметры выступов.

Совет...

Вы можете создать несколько обозначений за один вызов команды Дуговая координационная ось.

Чтобы завершить команду, нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

По умолчанию включен режим автоматического создания объекта, о чем свидетельствует нажатая кнопка Автосоздание объекта Панели специального управления. Чтобы строить обозначение в ручном режиме, отожмите кнопку.

Чтобы сформировать дополнительные обозначения, создайте ось в ручном режиме и перейдите на вкладку Дополнительные обозначения Панели свойств для добавления и настройки дополнительных обозначений.

a) | б) | в)
Элементы дополнительных обозначений: а) указатель ориентации, б) марка, в) текст

Завершив построение оси, нажмите кнопку Создать объект.

Смотрите также

Прямая координационная ось

Круговая координационная ось

Создание и редактирование дополнительных обозначений координационной оси

Другие обозначения для строительства


Команда Размер дуги окружности

Позволяет построить размер, характеризующий длину дуги окружности.

Для вызова команды нажмите кнопку Размер дуги окружности на инструментальной панели Размеры.

Укажите курсором дугу, которую требуется образмерить.

Если вы случайно ошиблись при выборе объекта, нажмите кнопку Указать заново на Панели специального управления и выберите другую дугу.

На вкладке Размер Панели свойств находится группа переключателей Тип, с помощью которой можно задать направление выносных линий — от центра или параллельно радиусу, проведенному в середину дуги. Если угол раствора дуги больше 180 градусов, возможно создание размера только с выносными линиями от центра.

Пример простановки размеров дуги с различной ориентацией выносных линий

В поле Текст на вкладке Размер отображается автоматически сформированная размерная надпись. Чтобы вызвать диалог редактирования и настройки размерной надписи, щелкните мышью в этом поле.

В списке Размещение текста отображается текущий способ размещения надписи. Если необходимо, смените способ размещения. Подробнее...

Затем укажите точку т3, определяющую положение размерной линии и надписи.

Если выбрано размещение текста на полке, укажите точку начала полки т4. В этом случае точка т3 является начальной точкой линии-выноски.

На вкладке Параметры Панели свойств находится опция Указатель от текста к дуге. Включите ее, если требуется соединить указателем дугу и текст относящегося к ней размера. Это может потребоваться, например, при простановке размеров концентрических дуг с одинаковым раствором и начальным углом.

Пример простановки размера дуги с указателем от текста к дуге

Настройка параметров размеров (выбор вида стрелки, положения надписи и т.п.).

Смотрите также

Другие размеры


Радиус дуги/диаметр дуги

Поле радиуса/диаметра дуги окружности.


Команда Дуга, касательная к кривой

Позволяет построить дугу, касательную к заданному объекту.

Для вызова команды нажмите кнопку Дуга, касательная к кривой на инструментальной панели Геометрия.

Укажите курсором объект, которого должна касаться дуга.

Укажите точку т1, через которую должна пройти дуга.

Затем укажите конечную точку дуги т2.

Для точного позиционирования курсора воспользуйтесь привязками или меню геометрического калькулятора в полях т1 и т2 на Панели свойств.

Координаты центра дуги и ее радиус будут рассчитаны автоматически. Начальная точка дуги — точка касания.

На экране появятся фантомы всех вариантов дуг, удовлетворяющих заданным параметрам.

Выберите нужный фантом мышью или с помощью кнопок Следующий объект и Предыдущий объект на Панели специального управления.

Затем зафиксируйте выбранную дугу, щелкнув по ней мышью или нажав кнопку Создать объект на Панели специального управления.

Построение дуги, касательной к отрезку

Выбор стиля линии

Группа переключателей Направление на Панели свойств управляет направлением построения дуги.

Чтобы перейти к построению дуг, касательных к другой кривой, нажмите кнопку Выбор объекта на Панели специального управления, а затем укажите курсором новую базовую кривую.

Для выхода из команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие геометрические объекты


Направление дуги

Переключатель, позволяющий выбрать направление построения дуги: по часовой стрелке или против часовой стрелки. Изменение направления немедленно отражается на фантоме дуги.

Если вариантов построения дуги несколько, на экране показываются несколько фантомов. Действие переключателя Направление дуги распространяется только на активный фантом.


Направление оси

Группа переключателей, позволяющая выбрать направление построения оси: по часовой стрелке или против часовой стрелки.

При построении мышью после указания центра (тС) и начальной точки (т1) переключатель, соответствующий текущему положению фантома, активизируется автоматически. Активный переключатель определяет направление построения оси.

— против часовой стрелки,

— по часовой стрелке.

Чтобы изменить направление, следует провести курсор вдоль оси через начальную точку (т1) или активизировать переключатель противоположного направления.

Если координаты начальной и конечной точек оси вводятся с клавиатуры, то группа переключателей Направление становится доступна после ввода значений в любые три поля Центр, Угол 1, Угол 2 или Радиус.


Центральная точка

Переключатель, позволяющий перейти к редактированию положения центральной точки дуги.

Указание точки дуги...

Изменение положения точки отображается на фантоме дуги в окне модели.


Начальная точка

Переключатель, позволяющий перейти к редактированию положения начальной точки дуги.

Положение начальной точки дуги определяется углом дуги.

Изменение положения точки отображается на фантоме дуги в окне модели.


Радиус

Переключатель, позволяющий перейти к редактированию радиуса дуги — положения точки 4.

При указании точки 4 мышью в окне модели радиус определяется автоматически и рассчитанное значение отображается в поле Радиус.

Вы можете ввести значение радиуса в поле Радиус или установить с помощью счетчика.

Изменение радиуса отображается на фантоме дуги в окне модели.

Чтобы задать диаметр, активизируйте переключатель Диаметр.


Конечная точка

Переключатель, позволяющий перейти к редактированию положения конечной точки дуги.

Положение конечной точки дуги определяется углом дуги.

Изменение положения точки отображается на фантоме дуги в окне модели.


Команда Дуга окружностиПостроение способом По центру и радиусу

Команда Дуга окружности
Построение способом По центру и радиусу

Данный способ позволяет построить дугу окружности с указанием плоскости дуги и заданием параметров: центра дуги, начального и конечного углов, радиуса. Плоскость дуги располагается параллельно базовой плоскости.

Пример

Способ можно сделать текущим, выбрав название По центру и радиусу из списка Способ на Панели свойств или контекстного меню команды Дуга окружности.

Чтобы построить дугу окружности, выполните следующие действия.

1. Укажите центральную точку дуги 1.

По умолчанию базовая плоскость — одна из координатных плоскостей. Система выбирает ее автоматически в зависимости от расположения модели относительно плоскости экрана.

2. Введите радиус/диаметр дуги. По умолчанию система ожидает ввода радиуса. При этом в группе Параметр активен переключатель Радиус. Чтобы ввести диаметр, активизируйте переключатель Диаметр.

3. Укажите начальную точку дуги 2, задав начальный угол дуги.

4. Укажите конечную точку дуги 3, задав конечный угол дуги.

При необходимости можно выбрать другую базовую плоскость. Для этого активизируйте переключатель Базовая плоскость и укажите нужный объект в окне модели или в Дереве построения (эскиз следует указывать в Дереве построения).

Выбор объектов в окне модели

Выбор объектов в Дереве построения

Построение дуги можно начинать с указания базовой плоскости: активизируйте переключатель Базовая плоскость, выберите нужный объект, а затем укажите точку 1.

Подробнее...


Тип размера дуги

Переключатель, позволяющий указать направление выносных линий размера дуги: от центра или параллельно радиусу, проведенному в середину дуги.

Для выбора нужного варианта вызовите из контекстного меню команду Выносные линии от центра или нажмите нужную кнопку в группе Тип на вкладке Размер Панели свойств.

Размеры дуги с различной ориентацией размерных линий


Указатель от текста к дуге

Опция, позволяющая указать, требуется ли соединить указателем дугу и текст относящегося к ней размера.

Чтобы отрисовать указатель, включите опцию. Это может потребоваться, например, при простановке размеров концентрических дуг с одинаковым раствором и начальным углом.

Размер дуги с указателем


Команда Дуга окружностиПостроение способом По 2 точкам с направлением

Команда Дуга окружности
Построение способом По 2 точкам с направлением

Данный способ позволяет построить дугу окружности по двум точкам с указанием в одной из них направления касательного вектора. Направление касательного вектора задается с помощью направляющего объекта или вектора.

Пример

Способ можно сделать текущим, выбрав название По 2 точкам с направлением из списка Способ на Панели свойств или контекстного меню команды Дуга окружности.

Чтобы построить дугу, выполните следующие действия.

1. Укажите начальную точку дуги 1.

2. Укажите конечную точку дуги 2.

3. Укажите нужный направляющий объект в окне модели или в Дереве построения (эскиз следует указывать в Дереве построения) или постройте вектор.

Выбор объектов в окне модели

Выбор объектов в Дереве построения

Построение вектора

По умолчанию система предлагает задать направление для конечной точки дуги 2.
Чтобы задать направление в точке 1, выполните следующие действия.

1. Активизируйте переключатель Начальная точка.

2. Активизируйте переключатель Направление в точке.

3. Укажите нужный направляющий объект в Дереве построения или в окне модели или постройте вектор.

Подробнее...


Команда Дуга окружностиПостроение способом С касанием к кривой

Команда Дуга окружности
Построение способом С касанием к кривой

Данный способ позволяет построить дугу окружности с указанием кривой, которой должна касаться окружность дуги, и заданием параметров дуги: центра, начального и конечного углов.

Пример

Способ можно сделать текущим, выбрав название С касанием к кривой из списка Способ на Панели свойств или контекстного меню команды Дуга окружности.

В качестве кривой может использоваться:

– координатная или вспомогательная ось,

– пространственная кривая,

– линия эскиза,

– ребро.

Чтобы построить дугу, выполните следующие действия.

1. Укажите в окне модели или в Дереве построения кривую, которой должна касаться окружность дуги.

Выбор объектов в окне модели

Выбор объектов в Дереве построения

2. Укажите центральную точку дуги 1.

3. Укажите начальную точку дуги 2, задав начальный угол дуги.

4. Укажите точку дуги 3, задав конечный угол дуги.

Подробнее...


Конечная точка

Переключатель, позволяющий перейти к редактированию положения конечной точки дуги.

Положение начальной точки дуги определяется углом дуги.

Изменение положения точки отображается на фантоме дуги в окне модели.


Команда Группа изопараметрических кривых на поверхности

Позволяет построить группу изопараметрических кривых на теоретической поверхности указанной грани. Количества кривых каждого направления (U и V) в группе задаются пользователем и могут быть различными.

Общие сведения о теоретической поверхности грани и изопараметрических кривых...

Пример

Для вызова команды нажмите кнопку Группа изопараметрических кривых на поверхности на инструментальной панели Пространственные кривые или выберите ее название из меню Операции — Пространственные кривые — Кривые на поверхности.

Укажите окне в модели нужную грань.

Выбор объектов в окне модели

Базовую грань для построения группы изопараметрических кривых можно указать и перед вызовом команды.

Указанная грань подсвечивается. На ней появляются фантомы изопараметрических кривых U и V. Стрелками показаны направления влияния параметров U и V в точке начала U=0, V=0. В поле Поверхность Панели свойств отображается наименование выбранной грани.

В поле Количество, U (Количество, V) вводится количество кривых по направлению параметра поверхности U(V). Это кривые направления V(U), расположенные с равным шагом по параметру U(V).
Введите или задайте счетчиком нужное количество кривых V(U) в поле Количество, U (Количество, V).

По умолчанию группа кривых создается с граничными кривыми. При этом в группе переключателей Границы на Панели свойств активен переключатель Оставить границы. Чтобы создать группу без граничных кривых, активизируйте переключатель Удалить границы.

Опция Рассыпать управляет результатом построения сети кривых.

– Если опция отключена, то после завершения команды кривые будут отображаться в Дереве модели как объекты, подчиненные группе.

– Если опция включена, то после завершения команды кривые не будут объединены в группу — каждая кривая будет отображаться в Дереве построения как самостоятельный объект.

Чтобы сменить грань для построения группы кривых, нажмите кнопку Указать заново на Панели специального управления и повторите выбор грани.

Название, цвет и параметры отображения кривых группы можно изменить на вкладке Свойства Панели свойств.

Чтобы завершить построение группы изопараметрических кривых, нажмите кнопку Создать объект на Панели специального управления.

В окне модели появляются изопараметрические кривые, а в Дереве построения — группа изопараметрических кривых или набор отдельных изопараметрических кривых (если была включена опция Рассыпать). Сначала в Дереве построения располагаются изопараметрические кривые направления V, разбивающие грань по направлению U, а затем — изопараметрические кривые направления U, разбивающие грань по направлению V.

Для выхода из команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Обратите внимание на то, что опция Рассыпать присутствует на Панели свойств только при создании группы кривых. Если уже созданную группу кривых требуется преобразовать в набор отдельных кривых, то вы можете разрушить эту группу, используя команду Разрушить. После разрушения группы каждая кривая отображается в Дереве построения как самостоятельный объект.


Команда Группа точек из файла

Позволяет создать группу точек по данным, считанным из файла.

В результате выполнения команды создается группа точек, координаты которых были прочитаны из ранее сохраненного файла данных.

Для вызова команды нажмите кнопку Группа точек из файла на инструментальной панели Пространственные кривые или выберите ее название из меню Операции — Пространственные кривые — Группа точек.

Чтобы указать имя файла, нажмите кнопку Файл-источник на Панели свойств.

Имя файла появится в поле.

Выбор варианта интерпретации осуществляется при помощи переключателей группы Тип координат.

В модели появляется фантом группы. До завершения построения параметры группы можно изменить, введя новые параметры на Панели свойств.

Если необходимо, чтобы после завершения команды положение точек соответствовало настройкам, но они не были элементами группы, а являлись самостоятельными объектами, включите опцию Рассыпать. Состояние построенных точек будет таким же, как если бы к построенной группе была применена команда Разрушить.

Название, цвет и стиль отображения точек можно изменить на вкладке Свойства Панели свойств.

Чтобы завершить построение, нажмите кнопку Создать объект на Панели специального управления.

Построенная группа точек сохраняет связь с файлом-источником.


Команда Группа точек по кривой

Позволяет создать группу точек в пространстве, лежащих на существующей кривой.

Пример

Для вызова команды нажмите кнопку Группа точек по кривой на инструментальной панели Пространственные кривые или выберите ее название из меню Операции — Пространственные кривые — Группа точек.

Чтобы построить группу точек, укажите кривую, на которой должны лежать точки. В качестве кривой может быть выбрана пространственная кривая (или ее сегмент), линия эскиза или ребро.

Название кривой появится в поле Кривая.

В модели появляется фантом группы. Крайние точки фантома являются ее характерными точками. Вы можете использовать их для задания рабочего участка кривой.

Задайте количество точек в группе и их положение, используя элементы управления, которые становятся доступными при выборе одного из вариантов раскрывающегося списка Способ.

Для способа Равномерно по длине в поле Количество точек выберите при помощи счетчика или введите с клавиатуры количество точек в группе.

Для способа Шаг по кривой в поле Шаг выберите при помощи счетчика или введите с клавиатуры расстояние между точками.

Для этого способа доступна опция По всей кривой. Если она включена, то в пределах всего рабочего участка кривой будет построена группа, количество точек в которой равно результату целочисленного деления длины кривой на указанный шаг плюс одна точка. Этот результат появится в поле Количество точек, доступном только для чтения.

Если опция выключена, поле Количество точек становится доступным для изменения. От начальной точки рабочего участка будет построено столько точек с выбранным шагом, сколько задано в этом поле.

Произведение шага и числа, на единицу меньшего количества точек, не должно превышать длины кривой.

Для способа Равный шаг по параметру кривой в поле Количество точек выберите при помощи счетчика или введите с клавиатуры количество создаваемых точек.

Задайте положение рабочего участка на кривой, используя элементы управления Панели свойств или перемещая мышью характерные точки.

Если необходимо, чтобы после завершении команды положение точек соответствовало настройкам, но они не были элементами группы, а являлись самостоятельными объектами, включите опцию Рассыпать. Состояние построенных точек будет таким же, как если бы к построенной группе была применена команда Разрушить.

При необходимости назначьте допуски на значения параметров операции, выраженных в линейных или угловых величинах. Для этого используйте кнопку Назначить допуск, расположенную на Панели свойств рядом с полем числового параметра операции.
Подробнее о допусках...
Подробнее о назначении допуска...

Название, цвет и стиль отображения точек можно изменить на вкладке Свойства Панели свойств.

Чтобы завершить построение, нажмите кнопку Создать объект на Панели специального управления.

Смотрите также

Особенности задания числовых параметров операции в полях Панели свойств


Команда Группа точек по поверхности

Позволяет создать группу точек в пространстве, лежащих на существующей поверхности. Поверхностями могут служить грани поверхностей и тел.

Пример

Для вызова команды нажмите кнопку Группа точек по поверхности на инструментальной панели Пространственные кривые или выберите ее название из меню Операции — Пространственные кривые — Группа точек.

1. Активизируйте переключатель Поверхность на Панели свойств и укажите грань, на которой должны лежать точки.

Выбор объектов в окне модели

Название объекта появляется в поле Поверхность.

В модели выбранная грань подсвечивается. На ней появляются:

– фантом ее теоретической поверхности; стрелками показаны направления влияния параметров U и V в точке начала U=0, V=0;

– фантом группы точек; пунктирными линиями показаны фантомы параметров U и V в точке указания.

До завершения построения параметры группы можно изменить, введя новые параметры на Панели свойств.

2. Задайте количество точек в группе и их взаимное положение, используя элементы управления, которые становятся доступными при выборе одного из следующих вариантов раскрывающегося списка Способ.

– По количеству точек в направлениях U и V

Точки строятся таким образом, чтобы в направлении U было N точек, а в направлении V — М. В полях Количество точек, U и Количество точек, V выберите при помощи счетчика или введите с клавиатуры количество точек в данном направлении.

– По линейному отклонению

Точки строятся таким образом, чтобы отклонения ребер аппроксимирующего многогранника, соединяющих соседние точки в направлениях U и V, от поверхности, не превышали заданного пользователем значения. В поле Линейное отклонение выберите при помощи счетчика или введите с клавиатуры значение максимального отклонения.

– По угловому отклонению

Точки строятся таким образом, чтобы углы между касательными к поверхности в точке и ребрами аппроксимирующего многогранника, соединяющими точку с соседними в направлениях U и V, не превышали заданного пользователем значения. В поле Угловое отклонение выберите при помощи счетчика или введите с клавиатуры значение максимального углового отклонения.

При выборе способов по линейному и угловому отклонению плотность расположения точек по поверхности будет зависеть от ее кривизны. На участках с большей кривизной точки будут расположены чаще, с меньшей кривизной — реже.

– По сетке вокруг заданной точки

Точки располагаются на теоретической поверхности указанной грани так, чтобы образовывать сетку вокруг заданной точки, лежащей на этой же теоретической поверхности. Заданная точка является центром сетки. Сетка может быть прямоугольной, концентрической или гексагональной. Примеры...

Задание центра сетки

Настройка параметров сетки

До завершения команды система «запоминает» данные, введенные для каждого способа построения группы точек, поэтому вы можете переключаться между способами без потери этих данных.

3. Выберите вариант построения группы точек с помощью опции Учитывать границы.

– При включенной опции группа точек строится в пределах контура указанной грани.

– При отключенной опции группа строится на теоретической поверхности грани. При необходимости теоретическая поверхность грани будет продлеваться. Примеры...

4. Если необходимо, чтобы после завершении команды положение точек соответствовало настройкам, но они не были элементами группы, а являлись самостоятельными объектами, включите опцию Рассыпать. Состояние построенных точек будет таким же, как если бы к построенной группе была применена команда Разрушить.

5. При необходимости измените название группы, цвет и стиль отображения точек. Для этого служат элементы управления, расположенные на вкладке Свойства Панели свойств.

6. Нажмите кнопку Создать объект на Панели специального управления.

Для выхода из команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.


Команда Назначить допуск

Позволяет назначить или изменить допуск на значение параметра экземпляра. Команда доступна в контекстном меню выделенной ячейки таблицы изменяемых переменных, соответствующей параметру экземпляра.

После вызова команды на экране появляется диалог Значение и допуск.

В появившемся диалоге выполните необходимые действия.

Диалог Значение и допуск для линейных величин...

Диалог Значение и допуск для угловых величин...

Подробнее об индивидуальных допусках в таблице изменяемых переменных...


Команда Значение по базовому

Позволяет отменить изменения в ячейке или в столбце таблицы изменяемых переменных. Команда доступна в контекстном меню выделенной ячейки или столбца.

Отмена изменений в таблице заключается в удалении из ее ячеек новых значений. Пустая ячейка таблицы означает, что значение в этой ячейке совпадает с базовым

– Чтобы отменить изменения в ячейки, щелчком мыши выделите нужную ячейку таблицы и вызовите из контекстного меню команду Значение по базовому.

– Чтобы отменить изменения в столбце, выделите нужный столбец, щелкнув мышью по его заголовку, и вызовите из контекстного меню команду Значение по базовому.

Подробнее о работе с таблицей изменяемых переменных...


Команда Все значения по базовому

Позволяет отменить все изменения в таблице изменяемых переменных. Команда доступна в контекстном меню окна Таблица изменяемых переменных.

Отмена изменений в таблице заключается в удалении из ее ячеек новых значений. Пустая ячейка таблицы означает, что значение в этой ячейке совпадает с базовым.

Для удаления всех изменений в таблице, вызовите из контекстного меню окна Таблица изменяемых переменных команду Все значения по базовому.

Подробнее о работе с таблицей изменяемых переменных...


Команда Таблица изменяемых переменных

Открывает окно Таблица изменяемых переменных при работе с массивами.

Для вызова команды нажмите кнопку Таблица изменяемых переменных на Панели специального управления или выберите ее название из контекстного меню.

Кнопка Таблица изменяемых переменных недоступна, если копируются:

– тела или поверхности,

– операции при включенной опции Геометрический массив.


Команда Удалить таблицу

Позволяет удалить из текущего файла имеющуюся в нем таблицу изменяемых переменных.

Для вызова команды нажмите кнопку Удалить таблицу на Панели специального управления или выберите ее название из контекстного меню.

Подробнее об удалении таблицы изменяемых переменных...


Опция Отображать скрытые объекты

Включите эту опцию, чтобы в настраиваемом ассоциативном виде формировались проекции объектов, которые скрыты (не отображаются) в модели.

При выключенной опции вид содержит изображения только тех объектов, которые отображаются в модели.

Перечень типов объектов, которые предаются в чертеж из модели, настраивается на Панели Объекты.

Если требуется отключить показ в чертеже всех тел, составляющих компонент модели, воспользуйтесь командой Скрыть в контекстном меню этого компонента в Дереве чертежа.


Кнопка Вставить ссылку (редактирование вида)

Кнопка Вставить ссылку
(редактирование вида)

Позволяет создать или изменить в надписи вида ссылку на обозначение объекта оформления — стрелки взгляда, линии разреза/сечения, выносной элемент, узла или узла в сечении.

После нажатия кнопки Ссылка на экране появится диалог создания ссылки. Выберите нужный тип источника, задайте остальные параметры ссылки и нажмите кнопку ОК.

После того как ссылка будет создана, между видом и объектом оформления, выбранным в качестве источника ссылки, сформируется ассоциативная связь. Текст ссылки появится в Окне просмотра надписи вида на Панели свойств. Станут доступны опции Имя, Лист и Зона.


Опция Обозначение (ассоциативный вид)

Опция Обозначение
(ассоциативный вид)

Опция, управляющая включением в надпись вида обозначения объекта оформления, связанного с этим видом.

Отключение этой опции исключает из его надписи обозначение объекта оформления (например, «В-В»). Для последующего включения этого обозначения необходимо включить опцию Обозначение.

Если вид не связан с объектом оформления, то опция Обозначение недоступна.

Виды Разрез/сечение, Выносной элемент, Вид по стрелке автоматически связываются с указанными для их построения объектами оформления. Удалить эту связь невозможно. Остальные ассоциативные виды нельзя связать с объектом оформления.


Опция Лист (ассоциативный вид)

Опция Лист
(ассоциативный вид)

Опция, управляющая включением в надпись вида ссылки на номер листа чертежа, где располагается связанный с видом объект оформления.

Если вид не связан с объектом оформления, то опция Лист недоступна.

Виды Разрез/сечение, Выносной элемент, Вид по стрелке автоматически связываются с указанными для их построения объектами оформления. Удалить эту связь невозможно. Остальные ассоциативные виды нельзя связать с объектом оформления.


Опция Масштаб (ассоциативный вид)

Опция Масштаб
(ассоциативный вид)

Опция, управляющая включением в надпись вида его текущего масштаба.


Окно просмотра надписи вида

Окно, в котором отображается текущая надпись вида. При включении или отключении элементов надписи содержимое окна просмотра изменяется.


Опция Повернуто (ассоциативный вид)

Опция Повернуто
(ассоциативный вид)

Опция, управляющая включением в надпись вида значка «повернуто».

Если опция отключена, то значок не включается в надпись вида.

Если она включена, то значок «повернуто» включается в надпись при условии, что угол поворота, заданный на вкладке Параметры, отличен от нуля.

Если поворот вида обусловлен наличием проекционной связи с его опорным видом (на вкладке Параметры активен переключатель Проекционная связь), то значок «повернуто» не включается в надпись вида.

Чтобы включить в надпись вида значение угла поворота, активизируйте опцию Угол на Панели свойств.


Опция Угол (ассоциативный вид)

Опция Угол
(ассоциативный вид)

Опция, управляющая включением в надпись вида значения угла поворота этого вида.

Опция Угол доступна, если включена опция Повернуто.


Опция Развернуто (ассоциативный вид)

Опция Развернуто
(ассоциативный вид)

Опция, управляющая включением значка «развернуто» в надпись вида.

Если опция отключена, то значок не включается в надпись вида.

Если она включена, то значок «развернуто» включается:

– в надпись вида, содержащего разрез/сечение или выносной элемент, если в его опорном виде изображена развертка листового тела,

– в надпись вида по стрелке, если в нем изображена развертка листового тела (т.е. на вкладке Параметры активен переключатель Развертка).


Опция Зона (ассоциативный вид)

Опция Зона
(ассоциативный вид)

Опция, управляющая включением в надпись вида ссылки на обозначение зоны чертежа, где располагается связанный с видом объект оформления.

Если опция включена, то обозначение зоны — при условии, что в чертеже включено разбиение на зоны — добавляется в надпись.

Если опция отключена, то обозначение зоны не добавляется в надпись вида.

Если вид не связан с объектом оформления, то опция Зона недоступна.

Виды Разрез/сечение, Выносной элемент, Вид по стрелке автоматически связываются с указанными для их построения объектами оформления. Удалить эту связь невозможно. Остальные ассоциативные виды нельзя связать с объектом оформления.


Команда Собрать контур

Позволяет сформировать контур, последовательно обходя пересекающиеся между собой геометрические объекты.

Для вызова команды нажмите кнопку Собрать контур на инструментальной панели Геометрия.

Укажите точку вблизи геометрического объекта, с которого требуется начать обход контура.

На экране появится фантомное изображение первого участка контура (поверх базового элемента), а также стрелка, указывающая предложенное системой направление дальнейшего движения.

Оно определяется следующим образом. Из указанной точки строится вектор, направленный к объекту и лежащий на перпендикуляре к нему, опущенном из этой точки. Обход контура начинается в правую сторону от полученного вектора (см. рисунок).

Зависимость направления обхода контура от точки указания первого объекта

Для задания дальнейшего направления щелкайте мышью на нужных объектах. Чтобы подтвердить предложенное системой направление, щелкните на стрелке.

Выбор направления обхода и перемещение по сегментам контура возможны с помощью кнопок на Панели специального управления, а также клавиатурных комбинаций.

Группа переключателей Способ прохода узлов позволяет указать, каким образом проходить неветвящиеся узлы контура — узлы, в которых направление дальнейшего движения всего одно (то есть в узле нет разветвлений). По умолчанию используется автоматическая обработка таких узлов (без запроса на выбор дальнейшего движения).

Группа переключателей Режим позволяет указать, требуется ли оставлять или удалять исходные объекты после выполнения операции.

Чтобы отказаться от продолжения обхода и начать формирование контура заново, нажмите кнопку Повторный выбор объекта, а затем укажите нужный объект.

При указании участка, замыкающего контур (т.е. участка, конечная точка которого совпадает с начальной точкой первого участка), происходит автоматическая фиксация контура.

Чтобы зафиксировать разомкнутый контур, нажмите кнопку Создать объект на Панели специального управления.

За один вызов команды можно сформировать произвольное количество контуров.

Для выхода из команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие геометрические объекты


Команда Эквидистанта по стрелке

Позволяет построить эквидистанту контура, образованного обходом по стрелке.

Для вызова команды нажмите кнопку Эквидистанта по стрелке на инструментальной панели Геометрия.

Укажите точку вблизи геометрического объекта, с которого требуется начать обход контура.

На экране появится фантом эквидистанты выбранного участка, а также стрелка, указывающая предлагаемое системой направление дальнейшего движения.

Для указания нужного направления щелкните мышью на соответствующем объекте.

Выбор направления обхода и перемещение по сегментам контура возможны с помощью кнопок на Панели специального управления, а также клавиатурных комбинаций.

Группа переключателей Способ прохода узлов позволяет указать, каким образом проходить неветвящиеся узлы контура — узлы, в которых направление дальнейшего движения всего одно (то есть в узле нет разветвлений). По умолчанию используется автоматическая обработка таких узлов (без запроса на выбор дальнейшего движения).

Чтобы отказаться от продолжения обхода и начать формирование контура заново, нажмите кнопку Повторный выбор объекта, а затем укажите нужный объект.

В любой момент вы можете изменить параметры эквидистанты.

Зафиксируйте фантом эквидистанты, щелкнув по нему мышью или нажав кнопку Создать объект на Панели специального управления.

Пример эквидистанты, полученной обходом по стрелке

Выбор стиля линии

За один вызов команды можно построить произвольное количество эквидистант.

Для выхода из команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие геометрические объекты


Команда Разрушить(подсборку)

Команда Разрушить
(подсборку)

Позволяет разбить выделенную подсборку текущей модели на отдельные компоненты.

Команда доступна в контекстном меню подсборки, выделенной в Дереве построения, и в меню Редактор — Редактировать компонент.

После вызова команды все компоненты выбранной подсборки передаются в текущую модель. Их положение в окне модели не изменяется. Остальные объекты, которые имелись в подсборке — поверхности, кривые и т.п., а также выполненные в подсборке операции (фаски, отверстия и др.) — не передаются в текущую модель.

Разрушенная подсборка удаляется из модели. Файл подсборки на диске не изменяется.

Особенности применения команды разрушения.

– Разрушение возможно только для подсборок первого уровня, т.е. вставленных непосредственно в текущую модель, а не в какую-либо из ее подсборок.

– Подсборки, находившиеся внутри разрушенной подсборки, не разрушаются. При необходимости вы можете применить к ним команду разрушения.

– Разрушение подсборки, являющейся исходным объектом массива, невозможно.

– Разрушение подсборки нельзя отменить.

Если компонентом модели является локальная деталь, полученная из подсборки, то к этой локальной детали можно применить команду разрушения.

Также можно разрушить деталь-заготовку, источником которой является сборка. В результате разрушения детали-заготовки пиктограммы ее компонентов, переданных в текущую модель, заменяются пиктограммами деталей-заготовок.

Смотрите также

Команда Объединить в подсборку

Команда Сохранить как...

Перенос и копирование компонентов


Способ прохода неветвящихся узлов

Переключатель, позволяющий указать, каким образом проходить неветвящиеся узлы контура — узлы, в которых направление дальнейшего движения всего одно (то есть в узле нет разветвлений).

Возможна автоматическая обработка таких узлов (без запроса на выбор дальнейшего движения) или ручная, когда система будет ожидать подтверждения на следующий шаг.


Команда Объединить в подсборку

Позволяет объединить выделенные компоненты текущей модели в подсборку. Объединение возможно только для компонентов первого уровня, т.е. вставленных непосредственно в текущую модель, а не в какую-либо из ее подсборок.

Команда доступна в контекстном меню компонентов, выделенных в Дереве построения.

После вызова команды на экране появляется стандартный диалог сохранения файла. Укажите в нем папку и имя файла сборки для записи, а затем нажмите кнопку Сохранить.

Диалог закрывается; в указанной папке создается новый файл сборки (*.a3d), содержащий компоненты текущей модели, указанные для объединения. Новая сборка вставляется в текущую модель в качестве подсборки, а компоненты, из которых она составлена, удаляются из текущей модели. Файлы этих компонентов на диске не изменяются.

Абсолютная система координат новой подсборки совпадает с абсолютной системой координат текущей модели.

Объединение в подсборку недоступно для следующих компонентов:

– деталей-заготовок,

– компонентов, являющихся экземплярами или исходными объектами массива.

Объединение в подсборку нельзя отменить.

Смотрите также

Команда Разрушить подсборку

Команда Сохранить как...

Перенос и копирование компонентов


Команда Зафиксировать

Управляет фиксацией на экране окна Информации и Таблица изменяемых переменных.

При вызове команды рядом с ее названием в меню появляется «галочка». При этом окно фиксируется на экране, т.е. остается развернутым до завершения работы в нем.

Повторный вызов команды удаляет «галочку» и отключает фиксацию окна. Незафиксированное окно автоматически сворачивается до заголовка, если работа с ним не ведется. Чтобы развернуть окно и продолжить работу в нем, поместите курсор на его заголовок.

Фиксацией окна (Информации и Таблица изменяемых переменных) можно управлять также с помощью кнопки Фиксация, расположенной в заголовке окна. Изображение на кнопке после нажатия изменяется, являясь индикатором фиксации:

— фиксация включена,

— фиксация выключена.

Результаты измерений добавляются в окно Информации вне зависимости от его состояния.


Команда Внимание

Эта команда присутствует в следующих контекстных меню:

– в Дереве построения на пиктограмме модели, отмеченной восклицательным знаком,

– в Дереве построения на пиктограмме тела из нескольких частей,

– в окне модели, непосредственно содержащей тела из частей.

После вызова команды Внимание на экране появляется сообщение о наличии тел из нескольких частей.

Смотрите также

Тела, состоящие из отдельных частей


Автопродолжение

Переключатель Автопродолжение позволяет автоматически присваивать номер или букву создаваемой координационной оси. Переключатель доступен при создании оси и скрыт при редактировании.

При создании новых обозначений поле Текст пусто.

Автопродолжение действует для обозначения оси — букв или чисел, введенных в первое поле ввода диалога ввода текста.

– Если предыдущая ось имеет цифровое обозначение (номер), то следующей оси присваивается следующий номер в порядке возрастания.

– Если предыдущая ось имеет буквенное обозначение, то следующей оси присваивается следующая по порядку буква. Перечень букв вводится в диалоге общих настроек координационных осей. Буквы, не указанные при настройке, игнорируются.

– Если предыдущая ось имеет буквенное и цифровое обозначение, то автопродолжение действует для первого символа. Например, после оси с обозначением А1 будет создана ось Б1.

Если координационная ось с автоматически присвоенным номером или буквой удаляется из документа, номера и буквы оставшихся осей не изменяются.

Автопродолжение действует только для основных марок — марок, присоединенных к координационным осям. Автопродолжение для марок дополнительных обозначений не производится.

Автопродолжение действует только в течение одного вызова команды построения осей. Чтобы автопродолжение действовало до конца сеанса работы КОМПАС-3D, следует дополнительно включить опцию Сохранять текст на вкладке Параметры Панели свойств.

Если режим автопродолжения выключен, поле Текст пусто. В этом случае обозначение координационной оси выбирается вручную из контекстного меню или задается в диалоге ввода текста.

Смотрите также

Формирование обозначения координационной оси


Команда Создать объекты спецификации...

Позволяет автоматически создать объекты спецификации в деталях и подсборках текущей сборки.

Для вызова команды выберите ее название из меню Спецификация.

Команда недоступна в следующих случаях:

– сборка не сохранена в файле на диске,

– в сборке уже есть внутренние объекты спецификации, соответствующие всем компонентам первого уровня.

После вызова команды на экране появится диалог, в котором можно указать, требуется ли обрабатывать компоненты текущей сборки и всех ее подсборок или только компоненты текущей сборки. Кроме того, вы можете включить создание документа-спецификации (*.spw) и подключение его к текущей сборке, а также автоматическое сохранение файла текущей сборки. Завершив настройку формирования объектов спецификации, нажмите кнопку OK диалога.

Объекты спецификации, соответствующие компонентам, будут созданы только в тех компонентах, в которых они отсутствовали. При этом:

– в колонки Обозначение и Наименование помещаются данные, введенные при настройке свойств компонента,

– в дополнительную колонку Масса заносится текущая масса компонента,

– файл компонента подключается к создаваемому объекту спецификации.

Команда Спецификация — Создать объекты спецификации... не обрабатывает тела, построенные в сборке, и библиотечные компоненты.

К объектам, вставленным из Библиотеки Стандартные Изделия, при вызове данной команды автоматически применяется аналогичная команда из меню Библиотеки.

Для передачи объектов спецификации из деталей и подсборок во внутренние объекты спецификации сборки необходимо, чтобы при настройке свойств этих компонентов была включена опция Создавать объекты спецификации.

Важное замечание...


Команда Удалить объекты спецификации...

Позволяет автоматически удалить объекты спецификации из текущей сборки, ее деталей и подсборок.

Для вызова команды выберите ее название из меню Спецификация.

После вызова команды на экране появится диалог, в котором можно указать, требуется ли обрабатывать компоненты текущей сборки и всех ее подсборок или только компоненты текущей сборки. Кроме того, вы можете включить удаление документа-спецификации (*.spw), а также автоматическое сохранение файла текущей сборки. Завершив настройку удаления объектов спецификации, нажмите кнопку OK диалога.

Из компонентов сборки будут удалены все объекты спецификации текущего стиля. Если в текущей сборке присутствовали внешние объекты спецификации, или внутренние объекты спецификации, не связанные с компонентами (например, в разделе Материалы), то они тоже будут удалены.

Команда Удалить объекты спецификации доступна, если текущая сборка сохранена в файле на диске и содержит объекты спецификации.

Важное замечание...


Команда Вращать модель

Позволяет запустить непрерывное вращение загруженной для просмотра модели. При просмотре графических и текстовых документов команда недоступна.

Для вызова команды нажмите кнопку Вращать модель.

Нажмите левую кнопку мыши в окне просмотра, переместите курсор в требуемом направлении вращения и отпустите кнопку мыши. Модель начнет вращаться в заданном направлении вокруг центра габаритного параллелограмма.

– Чтобы модель вращалась вокруг определенной точки (вершины детали, центра сферы, точки), подведите курсор к нужному элементу в окне модели и щелкните мышью.Затем нажмите левую кнопку мыши, переместите курсор в требуемом направлении и отпустите кнопку.

– Чтобы модель вращалась вокруг оси, прямолинейного ребра, оси конической или цилиндрической грани либо вокруг касательной к кривой, подведите курсор к нужному элементу в окне модели и щелкните мышью. Затем нажмите левую кнопку мыши, переместите курсор в требуемом направлении и отпустите кнопку.

– Чтобы модель вращалась вокруг оси, проходящей через указанную точку грани перпендикулярно этой грани, подведите курсор к нужной точке в окне модели и щелкните мышью. Затем нажмите левую кнопку мыши, переместите курсор в требуемом направлении и отпустите кнопку.

Чем быстрее перемещался курсор при задании направления вращения, тем выше будет скорость вращения.

Чтобы прервать вращение, щелкните мышью в любом месте окна. Модель остановится. При этом команда Вращать модель не прерывается, и вы можете задать другие направление и скорость вращения.

Отказаться от вращения детали можно, нажав клавишу <Esc> или вызвав другую команду.

Команда Вращать модель относится к командам программы просмотра. Чтобы использовать эту команду в КОМПАС-3D, добавьте ее в любое меню или на любую панель.


Команда Автосопряжение

Позволяет включить или выключить режим автоматического наложения сопряжений.

Для вызова команды нажмите кнопку Включить/выключить режим автосопряжений на Панели специального управления или выберите ее название в контекстном меню.

Нажатая кнопка означает, что режим автосопряжений включен, отжатая — выключен.


Команда Осевая линия по двум точкам

Позволяет построить произвольно расположенную осевую линию, указав ее начальную и конечную точки.

Для вызова команды нажмите кнопку Осевая линия по двум точкам на инструментальной панели Обозначения.

Укажите первую и вторую точки осевой линии (например, точки ее пересечения с контуром детали). В документе будет создана осевая линия, выступающая за указанные точки.

Построение осевой линии по двум точкам: а) указание точек, б) результат построения

Настройка отрисовки осевой линии аналогична настройке отрисовки обозначения центра.

Для выхода из команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие обозначения


Отрисовка осей

Переключатель, позволяющий указать, требуется ли отрисовка осевых линий для окружности, эллипса или правильного многоугольника.

Отрисовка осей правильного многоугольника возможна, если число его сторон — четное.


Команда Шаг на сегмент назад

Позволяет переместиться на один сегмент назад при сборке контура или построении эквидистанты по стрелке.


Команда База (графический документ)

Команда База
 (графический документ)

Позволяет создать обозначение базовой поверхности.

Для вызова команды нажмите кнопку База на инструментальной панели Обозначения.

Укажите курсором объект, изображающий базовый элемент (контур детали, осевую линию и т.п.).

Если вы случайно ошиблись при выборе объекта, нажмите кнопку Указать заново на Панели специального управления и выберите новую базу.

Укажите точку основания треугольника, обозначающего базу. Если указанная точка не принадлежат выбранному объекту, то положение знака будет определяться проекцией указанной точки на объект или его продолжение. В последнем случае объект автоматически будет продолжен на нужное расстояние тонкой линией.

Для точного позиционирования курсора воспользуйтесь привязками или меню геометрического калькулятора в поле Положение знака на вкладке Знак Панели свойств. Например, если базой является ось симметрии, удобно использовать привязку Ближайшая точка, чтобы совместить основание треугольника с концом размерной линии.

Укажите точку т1, определяющую положение рамки с надписью.

Пример простановки обозначения базы

В поле Текст на Панели свойств отображается предлагаемая системой буква для обозначения базы. Вы можете выбрать другую букву из контекстного меню этого поля. Если необходимо изменить также начертание символа, вызовите диалог ввода надписи обозначения, щелкнув в поле Текст левой кнопкой мыши.

Опция Автосортировка показывает, включена или выключена для текущего объекта автоматическая сортировка обозначений баз. Если опция активна, то произвольное изменение буквы, обозначающей базу, невозможно: поле Текст недоступно. При выключении опции Автосортировка поле Текст становится доступным и вы можете ввести любые символы.

По умолчанию формируется обозначение базы, перпендикулярное указанному объекту. При этом в группе Тип на Панели свойств активен переключатель Перпендикулярно к опорному элементу. Если требуется создать наклонное обозначение, активизируйте переключатель Произвольное расположение.

Смотрите также

Другие обозначения


Команда База (документ-модель)

Команда База
 (документ-модель)

Позволяет создать в модели обозначение базовой поверхности. Для простановки обозначения базы могут быть указаны следующие объекты:

– грани поверхностей и тел,

– ребра поверхностей и тел,

– размеры,

– вспомогательные оси и плоскости,

– пространственные кривые.

Пример

Для вызова команды нажмите кнопку База на инструментальной панели Элементы оформления.

Укажите объект для простановки обозначения базы.

Если требуется сменить выбранный объект, нажмите кнопку Указать заново на Панели специального управления и укажите новый объект.

Вы можете сменить базовую плоскость обозначения с помощью списка Базовая плоскость на вкладке Знак Панели свойств.

Кроме того, если отключено автосоздание объекта (а также при редактировании обозначения), вы можете сместить плоскость обозначения параллельно самой себе, используя элемент управления Положение. Он доступен, если указана точка расположения рамки с надписью.

Если в качестве обозначаемого объекта указан размер или обозначение, то обозначение базы проставляется в плоскости этого объекта. Изменение положения плоскости невозможно.

По умолчанию формируется обозначение базы, перпендикулярное указанному объекту. При этом в группе Тип на Панели свойств активен переключатель Перпендикулярно к опорному элементу. Если требуется создать наклонное обозначение, активизируйте переключатель Произвольное расположение.

В поле Текст отображается предлагаемая системой буква для обозначения базы.

По умолчанию включена опция Автосортировка — при этом обозначениям баз в порядке их создания автоматически присваиваются буквы алфавита, что исключает совпадение букв. При включенной опции Автосортировка поле Текст недоступно. Если необходимо ввести букву для обозначения базы вручную, отключите опцию Автосортировка. Поле Текст станет доступным, но контроль совпадения букв будет отключен.

При последующем включении опции Автосортировка введенные вручную буквы заменяются автоматически определенными.

Укажите точку, определяющую положение рамки с надписью.

Пример простановки обозначения базы

Смотрите также

Другие элементы оформления


Команда Редактировать источник

Позволяет открыть для редактирования файл, деталь из которого служит заготовкой текущей модели. Команда доступна в контекстном меню детали-заготовки, выделенной в Дереве построения.

Файл-источник заготовки может быть открыт, только если заготовка вставлена в текущую модель с сохранением ссылки на него.

Сделанные в файле-источнике заготовки изменения после их сохранения передаются в файл модели, использующей отредактированную заготовку. После этого модель перестраивается в соответствии с новыми параметрами заготовки.

Если деталь-заготовка содержит исполнения, то при ее открытии текущим является исполнение, которое было текущим во время последнего сохранения. Обратите внимание на то, что это исполнение может не совпадать с исполнением, вставленным в качестве заготовки. Для перехода к редактированию нужного исполнения сделайте его текущим.

Данная команда применима только к заготовкам в моделях, которые созданы в КОМПАС-3D версии 14 или более ранних. В 15-й и более поздних версиях КОМПАС-3D заготовка представляет собой компонент и может редактироваться обычными для него способами. Команда Редактировать источник в контекстом меню заготовки-компонента отсутствует.

Смотрите также

Команда Заменить источник детали-заготовки


Команда Кинематическая операция

Позволяет добавить к модели кинематический элемент. Кинематический элемент образуется путем перемещения сечения вдоль траектории.

Пример

Для построения в модели кинематического элемента выполните следующие действия.

1. Вызовите команду Кинематическая операция. Команда доступна, если в модели существует хотя бы один эскиз.

2. Задайте параметры операции на Панели свойств.

• Сечение
Активизируйте переключатель Сечение и укажите в Дереве построения или в окне модели эскиз.

Требования к эскизу-сечению кинематического элемента...

• Траектория
Активизируйте переключатель Траектория. Затем укажите в Дереве построения или в окне модели траекторию: пространственную кривую, линию эскиза, ребро или цепочку из этих объектов в любом сочетании.

Требования к траектории кинематического элемента...

• Тип движения сечения
Выберите тип движения сечения по траектории. Для этого активизируйте нужный переключатель в группе Движение сечения.

Подробнее о типе движения сечения...

• Параметры тонкой стенки
Задаются на вкладке Тонкая стенка Панели свойств. Подробнее...

• Результат операции
Задается на вкладке Результат операции Панели свойств.
Подробно о результате операции...

• Область применения операции
Выберите тип области применения, а затем укажите составляющие ее объекты. Подробнее...

Объекты, указанные для выполнения операции, подсвечиваются. Кинематический элемент с текущими параметрами отображается на экране в виде фантома. Фантом позволяет визуально проконтролировать правильность задания параметров.

Значение толщины стенки можно задать с помощью характерных точек.

3. При необходимости вы можете:

– Назначить допуски на значения параметров операции, выраженных в линейных или угловых величинах. Для этого используйте кнопку Назначить допуск, расположенную на Панели свойств рядом с полем числового параметра операции.
Подробнее о допусках...
Подробнее о назначении допуска...

– Задать наименование элемента и свойства его поверхности, сменить версию оптимизации построения. Для этого активизируйте вкладку Свойства Панели свойств.

4. Нажмите кнопку Создать объект для завершения операции.

Результат операции — новое тело или приклеенный элемент — появляется в графической области. В Дереве построения появляется пиктограмма операции.

Если требуется прервать операцию до ее завершения, нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие команды редактирования детали

Другие команды редактирования сборки

Особенности задания числовых параметров операции в полях Панели свойств


Команда Операция выдавливания

Позволяет добавить к модели элемент выдавливания. Элемент выдавливания образуется путем перемещения сечения по прямолинейной направляющей.

Пример выдавливания эскиза

Пример выдавливания грани

Для построения в модели элемента выдавливания выполните следующие действия.

1. Вызовите команду Операция выдавливания.

2. Задайте параметры операции на Панели свойств.

• Сечение
Активизируйте переключатель Сечение. Укажите в Дереве построения или в окне модели объект-сечение: эскиз, грань, пространственную кривую или ребро.

Подробнее об указании сечения...
Зависимость результата операции выдавливания от выбора сечения...

• Направляющий объект
Если в качестве сечения используется эскиз или плоская грань, то эти же объекты автоматически выбираются в качестве направляющих. Выдавливание производится перпендикулярно плоскости эскиза или грани.

Чтобы задать другой направляющий объект, активизируйте переключатель Направляющий объект. Затем укажите в Дереве построения или в окне модели любой плоский или прямолинейный объект.

Подробнее об указании направляющего объекта...

• Направление выдавливания
Выберите направление выдавливания из списка Направление: Прямое, Обратное, Два направления, Средняя плоскость.

Подробнее о направлении выдавливания...

• Глубина выдавливания
Выберите способ определения глубины выдавливания из списка Способ и задайте соответствующие способу параметры.

Подробнее о задании глубины выдавливания...

Если было выбрано выдавливание В двух направлениях, то способ определения глубины выдавливания и параметры требуется задать дважды — для прямого и обратного направления.
Если был выбран вариант Средняя плоскость, то параметры задаются один раз. При этом возможно выдавливание только на заданное расстояние (в каждую сторону откладывается его половина).

• Угол уклона
Уклон боковых граней элемента возможен, если в качестве сечения используется эскиз или плоская грань, а направление выдавливания перпендикулярно сечению.

Выберите направление уклона с помощью группы переключателей Уклон, а затем введите угол уклона в поле Угол.

Подробнее о задании угла уклона...

• Параметры тонкой стенки
Задаются на вкладке Тонкая стенка Панели свойств. Подробнее...

• Результат операции
Задается на вкладке Результат операции Панели свойств.
Подробно о результате операции...

• Область применения операции
Выберите тип области применения, а затем укажите составляющие ее объекты. Подробнее...

Объекты, указанные для выполнения операции, подсвечиваются. Элемент выдавливания с текущими параметрами отображается на экране в виде фантома. Фантом позволяет визуально проконтролировать правильность задания параметров.

Значения глубины выдавливания, угла уклона и толщины стенки можно задать с помощью характерных точек.

3. При необходимости вы можете назначить допуски на значения параметров операции, выраженных в линейных или угловых величинах. Для этого используйте кнопку Назначить допуск, расположенную на Панели свойств рядом с полем числового параметра операции.
Подробнее о допусках...
Подробнее о назначении допуска...

4. При необходимости используйте кнопки Панели специального управления для выполнения следующих действий:

– Построение контура для использования в качестве сечения.

– Построение вектора, задающего направление выдавливания.

– Отмена выбора всех объектов (сечения, направляющего объекта и т.п.).

– Редактирование эскиза-сечения (доступно, если в качестве сечения используется эскиз).

5. При необходимости вы можете задать наименование элемента и свойства его поверхности. Для этого активизируйте вкладку Свойства Панели свойств.

6. Нажмите кнопку Создать объект для завершения операции.

7. Если в результате операции образуется тело из нескольких частей, то после выполнения операции запускается процесс изменения набора частей. Выберите части, которые следует оставить.

Результат операции — новое тело или приклеенный элемент — появляется в графической области. В Дереве построения появляется пиктограмма операции.

Если требуется прервать операцию до ее завершения, нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Требования к эскизу элемента выдавливания

Другие команды редактирования детали

Другие команды редактирования сборки

Особенности задания числовых параметров операции в полях Панели свойств


Команда Операция по сечениям

Позволяет добавить к модели элемент по сечениям. Элемент по сечениям образуется путем соединения нескольких сечений. Крайнее сечение может быть точкой. Если необходимо, можно указать осевую линию — контур, задающий направление построения элемента по сечениям.

Пример

Для построения в модели элемента по сечениям выполните следующие действия.

1. Вызовите команду Операция по сечениям. Команда доступна, если в модели существует хотя бы два эскиза.

2. Задайте параметры операции на Панели свойств.

• Сечения
Активизируйте переключатель Сечения и укажите в Дереве построения или в окне модели эскизы сечений элемента.

Требования к эскизам-сечениям...
Подробнее об указании сечений элемента по сечениям...

• Осевая линия
Задается при необходимости. Активизируйте переключатель Осевая линия и укажите в Дереве построения или в окне модели осевую линию элемента: пространственную кривую, ребро или эскиз.

Требования к осевой линии...
Подробнее об осевой линии элемента по сечениям...

• Способ построения элемента у крайних сечений
Выберите способы построения элемента из списков Начальное сечение и Конечное сечение.

Подробнее о способах построения элемента у крайних сечений...

• Траектория соединения сечений

С помощью группы переключателей Траектория укажите способ выбора соединяемых точек сечений: автоматически или вручную. Подробнее...

С помощью группы переключателей Режим укажите, требуется ли замыкать элемент по сечениям. Подробнее...

• Параметры тонкой стенки
Задаются на вкладке Тонкая стенка Панели свойств. Подробнее...

Построение тонкостенного элемента по сечениям возможно, только если все эскизы-сечения содержат контуры. Использовать эскизы, содержащие точки, для создания такого элемента нельзя.

• Результат операции
Задается на вкладке Результат операции Панели свойств.
Подробно о результате операции...

• Область применения операции
Выберите тип области применения, а затем укажите составляющие ее объекты. Подробнее...

Объекты, указанные для выполнения операции, подсвечиваются. Элемент по сечениям с текущими параметрами отображается на экране в виде фантома. Фантом позволяет визуально проконтролировать правильность задания параметров.

Значение толщины стенки можно задать с помощью характерных точек.

3. При необходимости вы можете назначить допуски на значения параметров операции, выраженных в линейных или угловых величинах. Для этого используйте кнопку Назначить допуск, расположенную на Панели свойств рядом с полем числового параметра операции.
Подробнее о допусках...
Подробнее о назначении допуска...

4. При необходимости вы можете задать наименование элемента и свойства его поверхности. Для этого активизируйте вкладку Свойства Панели свойств.

5. Нажмите кнопку Создать объект для завершения операции.

Результат операции — новое тело или приклеенный элемент — появляется в графической области. В Дереве построения появляется пиктограмма операции.

Если требуется прервать операцию до ее завершения, нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие команды редактирования детали

Другие команды редактирования сборки

Особенности задания числовых параметров операции в полях Панели свойств


Команда Операция вращения

Позволяет добавить к модели элемент вращения. Элемент вращения образуется путем поворота сечения вокруг оси.

Пример вращения эскиза

Пример вращения грани

Для построения в модели элемента вращения выполните следующие действия.

1. Вызовите команду Операция вращения.

2. Задайте параметры операции на Панели свойств.

• Сечение
Активизируйте переключатель Сечение. Укажите в Дереве построения или в окне модели объект-сечение: эскиз, грань, пространственную кривую или ребро.

Подробнее об указании сечения...
Зависимость результата операции вращения от выбора сечения...

• Ось вращения
Ось вращения может определяться автоматически. Для этого она должна находиться в том же эскизе, что и сечение элемента и являться отрезком со стилем Осевая или объектом Осевая линия.

Чтобы задать другой объект, определяющий ось вращения, активизируйте переключатель Ось. Затем укажите в Дереве построения или в окне модели любой прямолинейный объект или поверхность вращения.

Подробнее об указании оси вращения...

• Тип построения
Выбор типа построения — тороид или сфероид — возможен, если в качестве сечения используется незамкнутый эскиз, а ось вращения лежит в плоскости сечения.

Выберите тип построения с помощью группы переключателей Тип.

Подробнее о типе построения...

• Направление вращения
Выберите направление вращения из списка Направление: Прямое, Обратное, Два направления, Средняя плоскость.

Подробнее о направлении вращения...

• Угол вращения
Выберите способ определения угла вращения из списка Способ и задайте соответствующие способу параметры.

Подробнее о способах определения угла вращения...

Если было выбрано вращение В двух направлениях, то способ определения угла вращения и параметры требуется задать дважды — для прямого и обратного направления.
Если был выбран вариант Средняя плоскость, то параметры задаются один раз. При этом возможно вращение только на заданный угол (в каждую сторону откладывается его половина).

• Параметры тонкой стенки
Задаются на вкладке Тонкая стенка Панели свойств. Подробнее...

• Результат операции
Задается на вкладке Результат операции Панели свойств.
Подробно о результате операции...

• Область применения операции
Выберите тип области применения, а затем укажите составляющие ее объекты. Подробнее...

Объекты, указанные для выполнения операции, подсвечиваются. Элемент вращения с текущими параметрами отображается на экране в виде фантома. Фантом позволяет визуально проконтролировать правильность задания параметров.

Значения угла вращения и толщины стенки можно задать с помощью характерных точек.

3. При необходимости вы можете назначить допуски на значения параметров операции, выраженных в линейных или угловых величинах. Для этого используйте кнопку Назначить допуск, расположенную на Панели свойств рядом с полем числового параметра операции.
Подробнее о допусках...
Подробнее о назначении допуска...

4. При необходимости используйте кнопки Панели специального управления для выполнения следующих действий:

– Построение контура для использования в качестве сечения.

– Построение оси для использования в качестве оси вращения.

– Отмена выбора всех объектов (сечения, оси и т.п.).

– Редактирование эскиза-сечения (доступно, если в качестве сечения используется эскиз).

5. При необходимости вы можете задать наименование элемента и свойства его поверхности. Для этого активизируйте вкладку Свойства Панели свойств.

6. Нажмите кнопку Создать объект для завершения операции.

7. Если в результате операции образуется тело из нескольких частей, то после выполнения операции запускается процесс изменения набора частей. Выберите части, которые следует оставить.

Результат операции — новое тело или приклеенный элемент — появляется в графической области. В Дереве построения появляется пиктограмма операции.

Если требуется прервать операцию до ее завершения, нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Требования к эскизу элемента вращения

Другие команды редактирования детали

Другие команды редактирования сборки

Особенности задания числовых параметров операции в полях Панели свойств


Команда Заменить источник

Позволяет заменить файл-источник заготовки, используемой в текущей модели. Команда доступна в контекстном меню детали-заготовки, выделенной в Дереве построения.

Заменить файл-источник можно, только если заготовка вставлена в текущую модель с сохранением ссылки на него.

После вызова команды на экране появляется стандартный диалог выбора файлов, в котором требуется указать файл, содержащий нужную заготовку. Выбранная деталь вставляется в текущий файл в качестве заготовки. После этого текущая модель перестраивается в соответствии с параметрами новой заготовки.

Данная команда применима только к заготовкам в моделях, которые созданы в КОМПАС-3D версии 14 или более ранних. В 15-й и более поздних версиях КОМПАС-3D заготовка представляет собой компонент и может редактироваться обычными для него способами. Команда Заменить источник в контекстом меню заготовки-компонента отсутствует.

Смотрите также

Команда Редактировать источник детали-заготовки


Расположение базы

Переключатель, позволяющий выбрать расположение обозначения базы: перпендикулярно поверхности или под произвольным углом к ней.


Команда Свернуть

Позволяет включить автоматическое сворачивание зафиксированной панели.

Чтобы отключить автоматическое сворачивание, вызовите команду повторно.

Сворачиванием зафиксированной панели можно управлять также с помощью кнопки Фиксация, расположенной в заголовке панели. Изображение на кнопке после нажатия изменяется, что является индикацией режима автоматического сворачивания:

— автоматическое сворачивание панели включено,

— автоматическое сворачивание панели выключено.


Команда Зафиксированная

Позволяет перевести «плавающее» окно в зафиксированное состояние.

Если включено автоматическое сворачивание окна или его положение закреплено, то команда Зафиксированная недоступна.


Команда Плавающая

Позволяет перевести зафиксированное окно в «плавающее» состояние.

Если включено автоматическое сворачивание окна или его положение закреплено, то команда Плавающая недоступна.


Команда Закрыть

Позволяет закрыть панель.

После закрытия панель исчезает с экрана. Чтобы вернуть ее, необходимо вызвать соответствующую команду.


Команда Перебор объектов

Позволяет выделить указанием любой из близко расположенных (в том числе наложенных друг на друга) объектов. Команда доступна в контекстном меню в режиме выделения объектов, если в «ловушку» курсора попадает более одного объекта.

Для быстрого вызова команды можно воспользоваться комбинацией клавиш <Ctrl>+<t>.

После вызова команды объекты можно перебирать, нажимая клавишу <Пробел> или вызывая команду Следующий объект из контекстного меню.


Команда Продолжить создание исполнения

Позволяет перейти к настройке параметров отражения компонентов, входящих в исходное исполнение модели. Кнопка для вызова команды появляется на Панели специального управления после включения опции Зеркальное исполнение, если исходное исполнение модели содержит компоненты.

После вызова команды на экране появляется диалог Параметры зеркального отражения компонентов, а элементы Панели свойств перестают отображаться.


Команда Продолжить зеркальное отражение

Позволяет перейти к настройке параметров зеркального отражения/симметричной вставки добавляемых компонентов. После вызова команды на экране появляется диалог Параметры зеркального отражения компонентов, а элементы Панели свойств перестают отображаться.

Кнопка становится доступной после выбора плоскости симметрии и указания исходных компонентов.


Команда Сгиб

Позволяет создать сгиб вдоль ребра листового тела. Ребро должно быть прямолинейным и принадлежать внешней или внутренней плоской грани листового тела. Указанное ребро будет считаться линией сгиба, а грань — базовой гранью сгиба.

Пример

Чтобы вызвать команду, нажмите кнопку Сгиб на панели Элементы листового тела. или выберите ее название из меню Операции — Элементы листового тела.

Укажите линию сгиба.

По умолчанию отображение фантома листового элемента включено, и в окне модели показывается фантом элемента с текущими параметрами.

Задайте параметры сгиба, используя элементы управления на Панели свойств.

– Выберите направление отсчета угла.

– Выберите вариант размещения сгиба на ребре из раскрывающегося списка. В зависимости от выбранного варианта на Панели свойств появляются поля для ввода ширины сгиба и/или его отступов от концов ребра.

– Выберите вариант задания длины продолжения сгиба из списка Способ построения 1. В зависимости от выбранного способа на Панели свойств появляются элементы управления длиной продолжения сгиба. Если необходимо задать длину сторон продолжения сгиба по отдельности, включите опцию По 2 сторонам. При включенной опции на Панели свойств присутствуют два списка Способ построения 1 и Способ построения 2 для выбора способов определения длины сторон продолжения сгиба.

– Выберите вариант интерпретации угла и введите значение угла в поле Угол.

– Выберите способ задания радиуса сгиба и введите значение радиуса в поле Радиус сгиба.

– Выберите тип смещения сгиба и введите величину смещения в соответствующем поле.

– Укажите способ определения длины развертки сгиба.

– Выберите требуемое состояние сгиба, используя опцию Разогнуть.

– При создании сгиба вы можете управлять параметрами боковых сторон сгиба с помощью элементов управления, расположенных на вкладке Боковые стороны.

– Используя элементы управления, расположенные на вкладке Освобождение, вы можете задать параметры освобождения сгиба и угла.

Направление, радиус, угол и другие параметры сгиба можно задать с помощью характерных точек.

Для снятия значений параметров с других объектов воспользуйтесь меню геометрического калькулятора в полях Длина, Ширина, Отступ, Расстояние, Угол, Радиус сгиба на Панели свойств.

При необходимости вы можете назначить допуски на значения параметров операции, выраженных в линейных или угловых величинах. Для этого используйте кнопку Назначить допуск, расположенную на Панели свойств рядом с полем числового параметра операции.
Подробнее о допусках...
Подробнее о назначении допуска...

Смотрите также

Команда Сгиб по линии

Особенности задания числовых параметров операции в полях Панели свойств


Команда Замыкание углов

Позволяет замкнуть один или несколько сгибов листового тела.

Пример

Чтобы вызвать команду, нажмите кнопку Замыкание углов на панели Элементы листового тела или выберите название команды из меню Операции — Элементы листового тела.

– Укажите пару смежных сгибов. Подробнее...

В окне модели подсветятся боковые грани выбранных смежных сгибов и примыкающих к ним плоских частей детали (сторон замыкаемого угла). На вкладке Параметры Панели свойств появятся элементы для настройки замыкания.

Вы можете указать несколько углов для замыкания. Их список отображается на панели Углы. Опция Единые параметры позволяет применить одинаковые параметры замыкания ко всем выбранным углам. Подробнее...

– Выберите вариант модификации сторон угла, указав способ замыкания: встык, с перекрытием или плотное замыкание. Для замыкания с перекрытием можно изменить направление перекрытия с помощью кнопки Изменить перекрытие.

– Выберите вариант модификации сгибов, указав обработку угла: без обработки, круговая, стык по кромке или стык по хорде.

– Задайте величину зазора.

– Для продолжения замыкания включите опцию Продолжить.

Завершив настройку замыкания углов, нажмите кнопку Создать объект на Панели специального управления.

Выбранные углы будут замкнуты, а в Дереве построения появится пиктограмма замыкания углов.

В некоторых случаях смежные сгибы имеют такие параметры или располагаются друг относительно друга так, что замыкание угла становится невозможным. Пример...

Смотрите также

Принцип построения замыкания встык и плотного замыкания

Принцип построения замыкания с перекрытием


Команда Сгиб по линии

Позволяет создать в детали сгиб по прямой линии относительно какой-либо грани этой детали. Указанные линия и грань будут считаться линией сгиба и базовой гранью сгиба.

Пример

Исходные объекты и результат построения

Чтобы вызвать команду, нажмите кнопку Сгиб по линии на панели Элементы листового тела или выберите ее название из меню Операции — Элементы листового тела.

Укажите базовую грань и линию сгиба.

По умолчанию отображение фантома листового элемента включено, и в окне модели показывается фантом элемента с текущими параметрами.

– Выберите направление отсчета угла.

– Задайте неподвижную сторону.

– Выберите вариант интерпретации угла и задайте значение угла в поле Угол.

– Выберите способ задания радиуса сгиба и задайте его значение в поле Радиус сгиба.

– Выберите способ формирования сгиба.

– Укажите способ определения длины развертки сгиба.

– Выберите требуемое состояние сгиба, используя опцию Разогнуть.

– Используя элементы управления, расположенные на вкладке Освобождение, вы можете задать параметры освобождения угла.

Направление, неподвижную сторону, радиус и угол сгиба по линии можно задать с помощью характерных точек.

Для снятия значений параметров с других объектов воспользуйтесь меню геометрического калькулятора в полях Угол и Радиус сгиба на Панели свойств.

При необходимости вы можете назначить допуски на значения параметров операции, выраженных в линейных или угловых величинах. Для этого используйте кнопку Назначить допуск, расположенную на Панели свойств рядом с полем числового параметра операции.
Подробнее о допусках...
Подробнее о назначении допуска...

Смотрите также

Команда Сгиб

Особенности задания числовых параметров операции в полях Панели свойств


Команда контекстного меню Согнуть

Позволяет согнуть сгибы листового элемента (элементов), имеющего признак «разогнуто». Если этот листовой элемент содержит несколько сгибов (как, например, подсечка), то будут разогнуты все его сгибы.

Вызов команды Согнуть равносилен отключению опции Разогнуть при редактировании листового элемента. Возможность применения команды Согнуть сразу к нескольким выделенным листовым элементам позволяет избежать редактирования каждого из них в отдельности.

После применения команды Согнуть значок «разогнуто» у элементов исчезает.

Команда Согнуть недоступна в следующих случаях:

– все выделенные листовые элементы согнуты,

– выделены листовые элементы, не содержащие сгибы (например, пластина).

Чтобы вновь включить признак «разогнуто» у листовых элементов (и, соответственно, разогнуть все их сгибы), необходимо выделить эти элементы и вызвать из контекстного меню команду Разогнуть.

Можно также применить команду Разогнуть из главного меню (Операции — Элементы листового тела).

Различия между способами изменения состояния сгибов


Команда Деталь-заготовка

Позволяет включить в текущую модель существующую модель (деталь или сборку), т.е. использовать ее в качестве заготовки.

Для вызова команды нажмите кнопку Деталь-заготовка на инструментальной панели редактирования детали или на инструментальной панели редактирования модели. Можно также выбрать название команды из меню Операции.

После этого на экране появляется диалог выбора файлов, в котором требуется указать модель для вставки.

Если модель содержит исполнения, то в диалоге можно выбрать обозначение нужного исполнения. Если для исполнений в модели созданы дополнительные номера, то вы также можете выбрать нужный дополнительный номер. Геометрия и свойства вставленного компонента будут соответствовать выбранному исполнению модели и дополнительному номеру.

Списки исполнений и дополнительных номеров отображаются в диалоге при выборе модели, содержащей исполнения и дополнительные номера.

После того как модель выбрана, ее фантом появляется в окне текущей модели. На Панели свойств появляются вкладки Размещение и Свойства.

На вкладке Размещение вы можете задать параметры, определяющие положение заготовки в модели.

Порядок настройки параметров зависит от способа размещения заготовки:

– По координатам,

– По сопряжениям.

Кроме того, на этой вкладке вы можете выбрать способ вставки заготовки. Для этого активизируйте соответствующий переключатель в группе Способ вставки.

При активном переключателе Вставка внешней ссылкой сохраняется связь заготовки с файлом-источником. Заготовка не копируется в модель, а существует в ней в виде ссылки на свой файл. Если в дальнейшем файл-источник будет отредактирован, изменения автоматически передадутся в модель, использующую данную заготовку.

Если активным является переключатель Вставка без истории, то связь заготовки с файлом-источником не сохраняется. Заготовка копируется в модель и теряет информацию о названии и расположении источника. Редактирование файла-источника не влияет на такую заготовку.

На вкладке Свойства расположены элементы управления, позволяющие задать цвет и оптические свойства заготовки, выбрать новые значения внешних переменных заготовки, если она содержит таблицу переменных.

Для завершения вставки заготовки нажмите кнопку Создать объект на Панели специального управления.

Деталь-заготовка будет вставлена в текущую модель и зафиксирована. В Дереве построения появится пиктограмма, соответствующая способу вставки:

– деталь-заготовка, сохраняющая связь с файлом-источником,

– деталь-заготовка, утратившая связь с файлом-источником.

Смотрите также

Параметры расчета МЦХ компонентов


Команда Сплайновая форма

Позволяет изменить форму и положение грани, преобразованной в сплайновую поверхность. Команда доступна, если модель содержит тела и/или поверхности.

При работе со сборкой обратите внимание на то, что команда доступна только в том случае, если в сборке содержатся тела и/или поверхности, созданные непосредственно в ней.

Для вызова команды нажмите кнопку Сплайновая форма на инструментальной панели Поверхности или выберите ее название из меню Операции — Поверхность.

После вызова команды запустится специальный режим редактирования грани. Вид компактной панели изменится. Она будет содержать кнопки переключения между двумя инструментальными панелями: Сплайновая форма (активна по умолчанию) и Фильтры.

Укажите грань, которую требуется отредактировать.

Грань можно указать и перед вызовом команды Сплайновая форма.

Указанная грань преобразуется в сплайновую поверхность и подсвечивается. На экране появляется фантом, который представляет собой сетку, образованную рядами точек — полюсов. Ряды сетки располагаются в двух направлениях — U и V. При изменении положения полюсов форма и/или положение грани могут изменяться.

При необходимости вы можете отредактировать не саму выбранную грань, а эквидистантную ей сплайновую поверхность. Для этого используется команда Эквидистанта грани.

Редактирование грани или ее эквидистанты выполняется произвольным перемещением полюсов мышью или командами инструментальной панели Сплайновая форма.

В режиме редактирования грани возможны отмена выполненных действий и повтор отмененных действий.

Кроме того, можно переопределить редактируемый объект — выбрать другую грань для редактирования, используя кнопку Указать заново Панели специального управления. Обратите внимание на то, что все изменения грани и ее эквидистанты, произведенные до перевыбора объекта, будут утеряны.

Чтобы завершить редактирование грани/эквидистанты грани, нажмите кнопку Создать объект. Работа в режиме редактирования грани закончится, все изменения сохранятся. В Дереве построения появится пиктограмма операции Сплайновая форма.

Кнопка Прервать команду позволяет выйти из режима редактирования грани без сохранения изменений.


Команда Порядок

Позволяет изменить порядок сплайновой поверхности, в которую преобразована выбранная для редактирования грань детали.

Для вызова команды нажмите кнопку Порядок на панели Сплайновая форма.

Порядок поверхности задается по каждому из ее направлений: U и V. Введите нужные значения в поля Порядок по U и Порядок по V. Значение в поле не может быть меньше 3.

Если требуется изменить количество полюсов сетки, включите опцию Новая сетка. На Панели свойств появятся дополнительные элементы управления.

Введите нужные значения в поля Количество точек по U и Количество точек по V и нажмите кнопку Разбить заново. Сетка, отображаемая на экране, перестроится. Количество ее полюсов будет соответствовать заданным значениям.

Аналогичным образом можно изменить количество полюсов сетки при работе с командой Сетка.

Обратите внимание на то, что количество полюсов сетки по выбранному направлению не может быть меньше порядка поверхности, заданного по этому направлению. Поэтому при увеличении порядка количество полюсов автоматически увеличивается. Уменьшение порядка не изменяет количество полюсов.

Для завершения команды нажмите кнопку Создать объект.

Кнопка Прервать команду позволяет отказаться от произведенных изменений.

Смотрите также

Сплайновая форма. Произвольное редактирование грани


Команда Фиксировать полюсы

Позволяет зафиксировать некоторое количество полюсов сетки редактируемой грани, т.е. сделать эти полюсы неподвижными.

Для вызова команды нажмите кнопку Фиксировать полюсы на панели Сплайновая форма.

Доступны следующие способы фиксации.

– Фиксация полюсов, расположенных на границах сетки (в ее крайних рядах). Для этого используются группы переключателей Границы вдоль U (для границ сетки, расположенных вдоль направления U) и Границы вдоль V (для границ сетки, расположенных вдоль направления V). Для фиксации нужных границ активизируйте соответствующие переключатели в группах. В каждой из групп может быть активным только один переключатель.

– Произвольная фиксация полюсов. Для этого включите опцию Выбор полюсов и укажите нужные полюсы или ряды полюсов. Подробнее о выборе полюсов...

Выбранные полюсы могут располагаться в любом ряду сетки, в том числе и на ее границе.

Отмена фиксации отдельно взятого полюса (ряда полюсов) выполняется повторным щелчком мыши по этому полюсу (ряду полюсов). Чтобы отменить фиксацию всех полюсов, зафиксированных данным способом, отключите опцию Выбор полюсов.

– Фиксация полюсов, обеспечивающих неизменность формы и положения ребер грани. Для этого включите опцию Выбор ребер грани и последовательно укажите все нужные ребра, щелкая по ним мышью.

Для отмены фиксации полюсов, обеспечивающих неизменность формы и положения одного из выбранных ребер, повторно щелкните мышью по этому ребру. Если требуется отменить фиксацию полюсов для всех выбранных ребер, отключите опцию Выбор ребер грани.

Вы можете фиксировать полюсы одним или несколькими способами одновременно.

Зафиксированные полюсы отображаются на экране кружками увеличенного диаметра. Если для фиксации указываются ряды полюсов, то сегменты этих рядов подсвечиваются. Кроме того, подсвечиваются ребра грани, форма и положение которых зафиксированы.

Для завершения фиксации полюсов нажмите кнопку Создать объект.

Кнопка Прервать команду позволяет отказаться от произведенных изменений.

В режиме редактирования грани вы можете зафиксировать все границы сетки или произвольно выбранные полюсы, не вызывая команду Фиксировать полюсы. Для этого используются следующие команды контекстного меню:

– Зафиксировать границы сетки/Расфиксировать границы сетки,

– Фиксировать полюсы с Shift.

Смотрите также

Сплайновая форма. Произвольное редактирование грани

Способы редактирования грани/эквидистанты грани


Команда Сетка

Позволяет сгустить или разредить сетку, которая используется для редактирования грани детали, преобразованной в сплайновую поверхность.

Для вызова команды нажмите кнопку Сетка на панели Сплайновая форма.

Группа Операции позволяет добавлять и удалять ряды полюсов сетки. Кнопки этой группы становятся доступными после выбора ряда.

Кнопки Вставить перед выбранным рядом или Вставить после выбранного ряда служат для добавления ряда, расположенного в том же направлении, что и выбранный.

Для удаления ряда используется кнопка Удалить выбранный ряд.

Опция Новая сетка позволяет изменить количество полюсов сетки по направлениям U и V. После включения опции на Панели свойств появляются дополнительные элементы управления.

Введите нужные значения в поля Количество точек по U и Количество точек по V и нажмите кнопку Разбить заново. Сетка, отображаемая на экране, перестроится в соответствии с заданными значениями.

Аналогичным образом можно изменить количество полюсов сетки при работе с командой Порядок.

При необходимости вы можете записать координаты полюсов сетки в файл данных. Для этого нажмите кнопку Сохранить в файл на Панели специального управления и укажите имя файла и папку для сохранения в появившемся диалоге. По умолчанию файлу присваивается расширение txt.

Для завершения настройки сетки нажмите кнопку Создать объект.

Кнопка Прервать команду позволяет отказаться от произведенных изменений.

Смотрите также

Сплайновая форма. Произвольное редактирование грани


Команда Вращение

Позволяет переместить некоторое количество полюсов сетки редактируемой грани вращением.

Для вызова команды нажмите кнопку Вращение на панели Сплайновая форма. На экране отобразятся круговые стрелки.

1. Укажите полюсы, которые нужно переместить.

Выбор полюсов...

2. Выберите направление оси вращения из раскрывающегося списка Направление.

3. Из раскрывающегося списка Центр выберите центр вращения.

4. В поле Угол введите значение угла вращения. Оно может быть как положительное — вращение в направлении, указанном стрелками, так и отрицательное — вращение в противоположном направлении.

Выбранные полюсы сетки переместятся в соответствии с заданными параметрами вращения.

5. При необходимости вы можете указать заново выбранные вручную объекты — полюсы сетки или объекты, определяющие параметры вращения. Для указания нужного объекта активизируйте соответствующий ему переключатель. Чтобы переопределить все выбранные вручную объекты, нажмите кнопку Указать заново Панели специального управления и повторите выбор, активизируя нужные переключатели.

6. Для завершения команды нажмите кнопку Создать объект.

Кнопка Прервать команду позволяет отказаться от произведенных изменений.

Смотрите также

Подробнее о вращении...

Сплайновая форма. Произвольное редактирование грани

Способы редактирования грани/эквидистанты грани


Команда Масштабирование

Позволяет переместить некоторое количество полюсов сетки редактируемой грани масштабированием.

Для вызова команды нажмите кнопку Масштабирование на панели Сплайновая форма.

1. Укажите полюсы, которые нужно переместить.

Выбор полюсов...

2. В поле Коэффициент введите коэффициент масштабирования. Выбранные полюсы переместятся в соответствии с заданным коэффициентом в направлении, которое определяется способом и центром масштабирования, заданными по умолчанию.

3. Выберите нужный способ масштабирования из раскрывающегося списка Способ.

4. Из раскрывающегося списка Центр выберите центр масштабирования.

5. При необходимости вы можете указать заново выбранные вручную объекты — полюсы сетки или объекты, определяющие параметры масштабирования. Для указания нужного объекта активизируйте соответствующий ему переключатель. Если требуется переопределить все выбранные вручную объекты, нажмите кнопку Указать заново Панели специального управления и повторите выбор объектов, активизируя нужные переключатели.

6. Для завершения масштабирования нажмите кнопку Создать объект.

Кнопка Прервать команду позволяет отказаться от произведенных изменений.

Смотрите также

Подробнее о масштабировании...

Сплайновая форма. Произвольное редактирование грани

Способы редактирования грани/эквидистанты грани


Команда Выравнивание

Позволяет переместить некоторое количество полюсов сетки редактируемой грани выравниванием относительно прямолинейного или плоского объекта.

Для вызова команды нажмите кнопку Выравнивание на панели Сплайновая форма.

1. Укажите полюсы, которые нужно переместить. Выбранные полюсы переместятся в соответствии с умолчательными параметрами выравнивания.

Выбор полюсов...

2. Из раскрывающегося списка Способ выберите способ выравнивания — По направлению или По плоскому объекту.

3. Задайте направление или плоскость выравнивания. Для выравнивания По направлению используется раскрывающийся список Направление, а для выравнивания По плоскому объекту — раскрывающийся список Плоскость.

4. Из раскрывающегося списка Центр выберите центр выравнивания.

После задания всех параметров выравнивания выбранные полюсы займут требуемое положение.

5. При необходимости вы можете указать заново выбранные вручную объекты — полюсы сетки или объекты, определяющие параметры выравнивания. Для указания нужного объекта активизируйте соответствующий ему переключатель. Если требуется переопределить все выбранные вручную объекты, нажмите кнопку Указать заново Панели специального управления и повторите выбор объектов, активизируя нужные переключатели.

6. Для завершения выравнивания нажмите кнопку Создать объект.

Кнопка Прервать команду позволяет отказаться от произведенных изменений.

Смотрите также

Подробнее о выравнивании...

Сплайновая форма. Произвольное редактирование грани

Способы редактирования грани/эквидистанты грани


Команда Перемещение со сглаживанием

Позволяет переместить некоторое количество полюсов сетки редактируемой грани со сглаживанием. Расстояние, на которое перемещается каждый полюс, рассчитывается с использованием сплайновой или степенной функции. Подробнее...

Для вызова команды нажмите кнопку Перемещение со сглаживанием на панели Сплайновая форма.

1. Укажите полюсы, которые нужно переместить.

Выбор полюсов...

Если требуется переместить один полюс (один ряд полюсов), указание полюса (ряда полюсов) не требуется. Перемещение выполняется, как описано в п. 5.

2. Выберите направление перемещения полюсов из раскрывающегося списка Направление и выполните дополнительные действия по настройке перемещения в соответствии с выбранным вариантом. Подробнее...

3. Выберите вид сглаживания, активизировав один из следующих переключателей группы Вид:

– Плавный переход,

– Выпуклый,

– Вогнутый.

4. Для варианта Выпуклый или Вогнутый введите значение степени функции в поле Степень. Поле появляется на Панели свойств после выбора варианта.

5. Переместите выбранные полюсы вручную. Для этого подведите курсор к одному из них. Когда рядом с курсором появится символ вершины, нажмите левую кнопку мыши и, не отпуская кнопку, переместите мышь в нужное место. Затем отпустите кнопку. Все выбранные полюсы (кроме полюса, наиболее удаленного от перемещаемого мышью) переместятся в соответствии с заданным видом сглаживания.

6. Для завершения команды нажмите кнопку Создать объект.

Кнопка Прервать команду позволяет отказаться от произведенных изменений.

Смотрите также

Сплайновая форма. Произвольное редактирование грани

Способы редактирования грани/эквидистанты грани


Команда Линейное перемещение

Позволяет переместить некоторое количество полюсов сетки редактируемой грани в заданном направлении.

Для вызова команды нажмите кнопку Линейное перемещение на панели Сплайновая форма.

1. Укажите полюсы, которые нужно переместить.

Выбор полюсов...

Линейное перемещение полюсов может выполняться вручную или автоматически.

Если требуется переместить вручную один полюс (один ряд полюсов), указание полюса (ряда полюсов) не требуется. Перемещение выполняется, как описано в п. 3.

2. Выберите направление перемещения полюсов из раскрывающегося списка Направление и выполните дополнительные действия по настройке перемещения в соответствии с выбранным вариантом. Подробнее...

3. Переместите выбранные полюсы вручную или автоматически.

Для ручного перемещения подведите курсор к одному из выбранных полюсов. Когда рядом с курсором появится символ вершины, нажмите левую кнопку мыши и, не отпуская кнопку, переместите мышь в нужное место. Затем отпустите кнопку.

Если в числе выбранных полюсов есть полюсы, которые выбирались указанием ряда, то вы можете подвести курсор к сегменту этого ряда. Когда рядом с курсором появится символ пространственной кривой, нажмите левую кнопку мыши и, не отпуская кнопку, переместите мышь в нужное место. Затем отпустите кнопку.

Если задано направление перемещения По нормали, перемещение полюсов за сегмент ряда невозможно.

Чтобы переместить полюсы автоматически, в поле Смещение введите расстояние, на которое переместятся полюсы. Оно может быть как положительным, так и отрицательным. После перемещения полюсов поле Смещение обнуляется.

Для направления перемещения В плоскости экрана доступно только ручное перемещение полюсов.

4. При ручном перемещении выбранных полюсов вы можете задать дополнительное условие перемещения, позволяющее переместить также некоторое количество соседних с выбранными полюсов сетки. Для этого используется список Условия. Подробнее о задании условия...

5. Для завершения команды нажмите кнопку Создать объект.

Кнопка Прервать команду позволяет отказаться от произведенных изменений.

Смотрите также

Подробнее о линейном перемещении...

Сплайновая форма. Произвольное редактирование грани

Способы редактирования грани/эквидистанты грани


Поле Порядок по U

Поле для задания порядка сплайновой поверхности по направлению U.


Поле Порядок по V

Поле для задания порядка сплайновой поверхности по направлению V.


Команда Биссектриса(вспомогательная прямая)

Команда Биссектриса
(вспомогательная прямая)

Позволяет построить биссектрису угла, образованного двумя указанными прямолинейными объектами.

Для вызова команды нажмите кнопку Биссектриса на инструментальной панели Геометрия.

Укажите курсором два прямолинейных объекта.

На экране будут показаны фантомы биссектрис углов, образованных выбранными объектами.

Выберите нужный фантом мышью или с помощью кнопок Следующий объект и Предыдущий объект на Панели специального управления.

Затем зафиксируйте выбранную прямую, щелкнув по ней мышью или нажав кнопку Создать объект на Панели специального управления.

Построение биссектрисы угла

Простановка точек пересечений

Для выхода из команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие геометрические объекты


Команда Очистить область

Позволяет удалить все объекты, находящиеся внутри или снаружи от некоторой границы.

Для вызова команды нажмите кнопку Очистить область на инструментальной панели Редактирование или выберите ее название из меню команду Редактор — Удалить.

Переключатели группы Режим Панели свойств позволяет указать, требуется ли удаление объектов внутри границы или снаружи от нее.

Укажите замкнутые геометрические объекты (окружности, многоугольники, замкнутые ломаные и т.п.), все изображение внутри или снаружи которых необходимо удалить.

Кнопки Панели специального управления предоставляют дополнительные возможности задания границ области. Кнопка Ручное формирование границ позволяет перейти к созданию временной ломаной линии, а Обход границы по стрелке — к формированию контура, образованного пересекающимися объектами.

После того как области указаны, нажмите для их очистки кнопку Создать объект на Панели специального управления.

Вы можете указать для очистки сразу несколько расположенных в разных местах областей с границами, заданными различными способами.

Для завершения команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Подробнее об очистке области...

Смотрите также

Другие команды редактирования


Режим удаления области

Переключатель, позволяющий указать, требуется ли удалять объекты снаружи или внутри заданной границы.


Команда Поверхность соединения

Позволяет построить поверхность, соединяющую две грани.

Пример

Для создания поверхности соединения выполните следующие действия.

1. Вызовите команду Поверхность соединения.

Система ожидает указания первой границы поверхности соединения — в группе переключателей Выбор границы активен переключатель Граница 1.

2. Укажите первую границу — ребро или гладкую цепочку ребер одной из граней, которые требуется соединить. Граница подсвечивается в окне модели, рядом с ней отображается номер и значок выбранного по умолчанию условия сопряжения.

Задайте параметры соединения вдоль первой границы:

• Поверхность сопряжения — поверхность, с которой сопрягается поверхность соединения.
В качестве поверхности сопряжения автоматически выбирается грань, содержащая указанную границу. Эта грань подсвечена в окне модели. Если граница принадлежит двум граням, вы можете указать в окне модели другую грань для использования в качестве поверхности сопряжения.

• Условие сопряжения поверхности соединения с поверхностью сопряжения.
Выберите нужное условие из списка Условие. Подробнее об условиях сопряжения поверхностей...

При необходимости используйте переключатель Сменить направление для смены направления сопряжения.

• Натяжение — параметр, влияющий на форму поверхности вблизи границы: чем натяжение больше, тем больше кривизна поверхности. Задается в процентах.
Введите значение натяжения в поле Натяжение, %.
Если на второй границе должно быть такое же натяжение, активизируйте опцию Общее натяжение.

• Положение боковых ребер.
Выберите вариант построения — как продолжение боковых ребер поверхности сопряжения или перпендикулярно границе. Подробнее...

3. Активизируйте в группе Выбор границы переключатель Граница 2.
Укажите вторую границу поверхности соединения и задайте параметры соединения вдоль нее, выполнив действия, аналогичные вышеописанным.
В окне модели отображается фантом поверхности.

4. Оцените фантом. При необходимости измените параметры соединения вдоль границ, переключаясь между ними с помощью переключателей группы Выбор границы.

Если требуется сменить направление построения поверхности вблизи границы, активизируйте переключатель Сменить направление.

5. При необходимости используйте следующие возможности:

• Проверка поверхности на самопересечения. Для включения проверки активизируйте опцию Проверка самопересечений. В случае обнаружения самопересечений созданная поверхность будет отмечена в Дереве как ошибочная.

• Отмена выбора всех указанных объектов. Для этого нажмите кнопку Указать заново на Панели специального управления.

• Изменение разбиения поверхности на грани. Для этого активизируйте вкладку Панели свойств Разбиение. Разбиение выполняется так же, как при построении линейчатой поверхности, с единственным отличием: отсутствует опция По вершинам.

• Изменение названия и свойств поверхности. Для этого активизируйте вкладку Панели свойств Свойства.

6. Подтвердите построение поверхности, нажав кнопку Создать объект на Панели специального управления.

Созданная поверхность появляется в окне модели, а ее пиктограмма — в Дереве построения.

Смотрите также

Подробнее о построении поверхности соединения...

Другие команды создания поверхностей


Автоопределение базовой точки

Команда, позволяющая отменить ручное указание базовой точки базового экземпляра.

Вызов команды отменяет ручное указание базовой точки. После этого базовой точкой базового экземпляра считается базовая точка копируемого объекта.

Смотрите также

Выбор способа задания базовой точки базового экземпляра...


Команда Изменить положение тела или поверхности

Позволяет создать в модели новое тело или новую поверхность путем изменения положения имеющегося тела или поверхности. Изменение положения возможно только для тел и поверхностей, построенных непосредственно в модели (а не в каком-либо из ее компонентов).

Изменение положения объекта производится в указанной пользователем системе координат с помощью специального элемента управления — фантома системы координат. Взаимное положение фантома и объекта не изменяется, поэтому при сдвиге и повороте фантома соответствующим образом сдвигается и поворачивается объект. Первоначально фантом совпадает с указанной системой координат.

Пример

Чтобы изменить положение тела или поверхности, выполните следующие действия.

1. Вызовите команду Изменить положение.

2. Укажите объект (тело или поверхность), положение которого требуется изменить, в Дереве или в окне модели.

Пиктограммы и названия тел показываются в Дереве, если в нем включено отображение структуры модели.

Если в модели содержится одно тело или одна поверхность, то это тело или поверхность выбирается автоматически.

Выбранный объект и система координат (по умолчанию — текущая), в которой производится изменение положения объекта, подсвечиваются. В окне модели также отображается фантом системы координат. Для произвольного сдвига и перемещения фантома «перетаскивайте» мышью его характерные точки.

3. При необходимости смените систему координат, в которой производится изменение положения объекта. Для этого укажите в Дереве построения нужную систему координат.

4. Укажите, требуется ли удалять первоначальное тело или поверхность, используя переключатели группы Режим.

5. Активизируйте вкладку Параметры Панели свойств и выберите способ задания позиции и ориентации фантома системы координат из списка Способ (эти способы такие же, как при создании ЛСК):

– Относительно СК, в которой производится изменение положения. Задайте позицию и ориентацию условной системы координат с помощью элементов управления Панели свойств. Подробнее...

– По объекту, свойства которого позволяют однозначно определить позицию и ориентацию условной системы координат. Укажите объект. Подробнее...

Изменение положения условной системы координат отображается на фантоме тела или поверхности: объект занимает позицию, соответствующую новому положению фантома системы координат.

6. При необходимости назначьте допуски на значения параметров операции, выраженных в линейных или угловых величинах. Для этого используйте кнопку Назначить допуск, расположенную на Панели свойств рядом с полем числового параметра операции.
Подробнее о допусках...
Подробнее о назначении допуска...

7. При необходимости измените наименование и свойства поверхности нового объекта на вкладке Свойства Панели свойств. На этой же вкладке отображается название системы координат объекта.

8. При необходимости используйте кнопки Панели специального управления для выполнения следующих действий:

– Построение локальной системы координат для определения исходного положения условной системы координат объекта.

– Отмена выбора всех объектов (тела, системы координат и т.п.).

– Отключение отображения на экране фантома тела или поверхности в новом положении.

9. Нажмите кнопку Создать объект на Панели специального управления/

Тело или поверхность изменит свое положение в окне модели, в Дереве построения появится пиктограмма операции изменения положения.

Чтобы отказаться от операции до ее завершения, нажмите кнопку Прервать команду Панели специального управления или клавишу <Esc>.

Смотрите также

Подробнее об изменении положения тела или поверхности...

Другие команды редактирования детали

Другие команды редактирования сборки

Особенности задания числовых параметров операции в полях Панели свойств


Команда Внешние границы

Позволяет применить текущий стиль линии к внешним границам текущей ячейки или выделенного диапазона ячеек.

Для выбора текущего стиля линии границ служит элемент Текущий стиль линии границы.


Команда Все границы

Позволяет применить текущий стиль линии ко всем границам текущей ячейки или выделенного диапазона ячеек.

Для выбора текущего стиля линии границ служит элемент Текущий стиль линии границы.


Команда Верхняя граница

Позволяет применить текущий стиль линии к верхней границе текущей ячейки или выделенного диапазона ячеек.

Для выбора текущего стиля линии границ служит элемент Текущий стиль линии границы.


Команда Левая граница

Позволяет применить текущий стиль линии к левой границе текущей ячейки или выделенного диапазона ячеек.

Для выбора текущего стиля линии границ служит элемент Текущий стиль линии границы.


Команда Внутренняя горизонтальная граница

Позволяет применить текущий стиль линии к внутренним горизонтальным границам выделенного диапазона ячеек.

Для выбора текущего стиля линии границ служит элемент Текущий стиль линии границы.


Команда Внутренние границы

Позволяет применить текущий стиль линии к внутренним границам выделенного диапазона ячеек.

Для выбора текущего стиля линии границ служит элемент Текущий стиль линии границы.


Команда Нет границ

Позволяет отменить отображение границ текущей ячейки или выделенного диапазона ячеек.

Совет...


Команда Нижняя граница

Позволяет применить текущий стиль линии к нижней границе текущей ячейки или выделенного диапазона ячеек.

Для выбора текущего стиля линии границ служит элемент Текущий стиль линии границы.


Команда Правая граница

Позволяет применить текущий стиль линии к правой границе текущей ячейки или выделенного диапазона ячеек.

Для выбора текущего стиля линии границ служит элемент Текущий стиль линии границы.


Команда Внутренняя вертикальная граница

Позволяет применить текущий стиль линии к внутренним вертикальным границам выделенного диапазона ячеек.

Для выбора текущего стиля линии границ служит элемент Текущий стиль линии границы.


Команда Границы...

Позволяет вызывать диалог настройки границ.

Этот диалог служит для управления отображением и стилем линии границ текущей ячейки (или выделенного диапазона ячеек) таблицы.


Команда Фигурная скобка

Позволяет создать изображение фигурной скобки, используемое в строительной документации для обозначения фрагментов.

Для вызова команды нажмите кнопку Фигурная скобка на инструментальной панели Обозначения для строительства или выберите ее название из меню Инструменты — Обозначения для строительства.

Если известны первая (т1) и вторая (т2) точки привязки скобки, укажите их. При этом длина и угол наклона скобки будут определены автоматически.

Если известны первая точка привязки скобки, ее длина и угол наклона, задайте их любым способом и в любом порядке. Обратите внимание на то, что минимальная длина фигурной скобки зависит от величины радиуса закругления.

На экране появится фантом изображения фигурной скобки.

В случае если текст фигурной скобки размещается на полке линии-выноски, то следует указать точку начала полки (т3).

Группа переключателей Тип позволяет выбрать тип ориентации фигурной скобки.

Группа переключателей Направление позволяет выбрать направление фигурной скобки.

Чтобы ввести текст обозначения, вызовите диалог ввода текста. Для этого щелкните мышью в поле Текст на Панели свойств или вызовите команду Текст надписи... из контекстного меню.

Текст фигурной скобки может содержать ссылку на другой объект и может являться источником ссылки.

Настройте параметры фигурной скобки на вкладке Параметры Панели свойств.

Примеры фигурных скобок

Кнопка Редактировать точки на Панели специального управления служит для перехода в режим редактирования характерных точек линии-выноски. В этом режиме можно создавать изломы линии-выноски и перемещать мышью ее характерные точки. Кнопка Редактировать точки доступна, если выбран один из вариантов размещения текста на полке и указана точка начала полки т3.

Чтобы зафиксировать изображение, нажмите кнопку Создать объект на Панели специального управления.

Вы можете создать несколько обозначений за один вызов команды Фигурная скобка. Для этого после нажатия кнопки Создать объект укажите новые точки привязки.

Чтобы отказаться от создания фигурной скобки, нажмите кнопку Прервать команду на Панели специального управления.

Смотрите также

Особенности редактирования фигурной скобки с помощью мыши

Другие обозначения для строительства


Команда Направление 1

Позволяет изменить направление отрисовки фигурной скобки на противоположное (см. рис.).

При вызове команды рядом с ее названием в меню появляется «галочка».


Команда Направление 2

Позволяет изменить направление отрисовки фигурной скобки на противоположное (см. рис.).

При вызове команды рядом с ее названием в меню появляется «галочка».


Направление фигурной скобки

Группа переключателей, позволяющая выбрать направление отрисовки фигурной скобки (см. рис.).

Для смены направления скобки активизируйте переключатель Направление 1 или Направление 2.


Радиус закругления

Поле выбора радиуса закругления фигурной скобки.

Возможен также ввод значений радиуса с клавиатуры.

Введенные значения будут добавляться в список и сохраняться в течение сеанса работы КОМПАС-3D.

Умолчательный радиус закругления задается в диалоге настройки отрисовки фигурной скобки.

Если задается такой радиус закругления, при котором текущее значение длины скобки оказывается меньше минимального, длина скобки автоматически принимает это минимальное значение.


Размещение текста

Список, позволяющий выбрать вариант размещения текста.

Наименование | Описание
На полке, вправо На полке, влево На полке, вверх На полке, вниз | При выборе одного из этих способов для размещения надписи формируется линия-выноска с полкой указанного направления. В этом случае пользователю требуется указать точку начала полки (т3).
Автоматическое | При выборе этого способа текст располагается с внешней стороны фигурной скобки без линии-выноски. Строки текста параллельны скобке. Текст автоматически центрируется относительно середины скобки.


Ответвления (варианты добавления ответвлений)

Ответвления
(варианты добавления ответвлений)

Группа переключателей, позволяющая выбрать вариант добавления ответвлений к линии-выноске или к марке/позиционному обозначению с линией-выноской.

Описание элементов управления
Вариант добавления ответвлений | Построение
От начала полки При активизации этого переключателя ответвления отрисовываются от начальной точки полки. |
От конца полки При активизации этого переключателя ответвления отрисовываются от конечной точки полки. |
Параллельные При активизации этого переключателя ответвления отрисовываются параллельно друг другу с одной или с обеих сторон относительно полки. |

Выбранный вариант добавления ответвлений влияет на вид элемента управления Полка:

– если ответвления строятся от начала или конца полки, то элемент управления Полка имеет вид списка из четырех строк: Влево, Вправо, Вверх, Вниз;

– если ответвления строятся параллельно друг другу, то элемент управления Полка имеет вид группы переключателей: Горизонтально, Вертикально.

Если линия-выноска или марка/позиционное обозначение уже имела ответвления, то при смене текущего варианта добавления ответвлений она перестраивается.

Вы можете создать линию-выноску или марку/позиционное обозначение с ответвлениями от начала и от конца полки. Для этого выполните следующие действия. Построив необходимое количество ответвлений от начала полки, активизируйте переключатель От конца полки и укажите начальные точки ответвлений.

К ответвлениям, построенным при помощи переключателя Параллельные, невозможно добавить ответвления От начала полки/От конца полки и наоборот.

Добавление ответвлений возможно только в режиме добавления ответвлений. Для перехода в этот режим нажмите кнопку Добавить ответвления на Панели специального управления.


Кнопка Дополнительное окно Дерева

Позволяет создать дополнительное окно Дерева построения для объекта или раздела, выделенного в Дереве построения модели.

Кнопка находится на инструментальной панели вкладки Построение в окне Дерево модели.

Если в Дереве построения нет выделенных объектов (разделов) или если выделено несколько объектов (разделов), то кнопка Дополнительное окно Дерева недоступна.


Направление знака клеймения

Переключатель, позволяющий выбрать направление отрисовки знака клеймения: вправо или влево.


Команда Знак клеймения (графический документ)

Команда Знак клеймения
 (графический документ)

Позволяет создать линию-выноску для обозначения клеймения.

Для вызова команды нажмите кнопку Знак клеймения на инструментальной панели Обозначения.

Укажите начальную точку первого ответвления (точку нанесения первого клейма).

Укажите точку т1, определяющую положение знака клеймения.

Затем укажите начальные точки остальных ответвлений.

Настройка отрисовки обозначения клеймения

В поле Текст на Панели свойств отображается предлагаемый системой текст для обозначения клеймения. Чтобы изменить надпись, вызовите диалог ввода надписи обозначения, щелкнув в поле Текст левой кнопкой мыши.

Кнопка Ссылка позволяет вставить в текст обозначения ссылку, например, на пункт технических требований.

По умолчанию при создании знака клеймения включен режим добавления ответвлений. Об этом свидетельствует нажатая кнопка Добавить ответвления на Панели специального управления. В этом режиме каждая вновь указанная точка воспринимается системой как начальная точка очередного ответвления.

В режиме редактирования характерных точек объекта можно внести изменения в конфигурацию знака. Добавление ответвлений в этом режиме невозможно. Для перехода в режим редактирования нажмите кнопку Редактировать точки на Панели специального управления.

Между режимами можно произвольно переключаться при помощи кнопок Панели специального управления или команд в контекстном меню. При выходе из одного режима автоматически включается другой.

Чтобы зафиксировать изображение, нажмите кнопку Создать объект на Панели специального управления.

Простановка обозначения клеймения

При редактировании проекционного знака клеймения часть элементов управления Панели свойств недоступна. Соответствующие параметры обозначения передаются в чертеж из модели, поэтому их ручное изменение невозможно.

Смотрите также

Добавление ответвлений

Другие обозначения


Команда Знак клеймения (документ-модель)

Команда Знак клеймения
 (документ-модель)

Позволяет создать в модели линию-выноску для обозначения клеймения. Обозначение клеймения может проставляться к грани тела или поверхности.

Пример

Для вызова команды нажмите кнопку Знак клеймения на инструментальной панели Элементы оформления.

Укажите объект, на который будет указывать первое ответвление линии-выноски. Начальной точкой первого ответвления будет точка, в которой был указан объект.

Задайте точку, определяющую положение знака клеймения.

На экране появляется фантом обозначения.

Вы можете сменить базовую плоскость обозначения с помощью списка Базовая плоскость на вкладке Знак Панели свойств.

Кроме того, вы можете сместить плоскость обозначения параллельно самой себе, используя элемент управления Положение.

В поле Текст на Панели свойств отображается предлагаемый системой текст для обозначения клеймения. Чтобы изменить надпись, вызовите диалог ввода надписи обозначения, щелкнув в поле Текст левой кнопкой мыши.

Настройка отрисовки обозначения клеймения

По умолчанию при создании обозначения маркировки включен режим добавления ответвлений. Об этом свидетельствует нажатая кнопка Добавить ответвления на Панели специального управления. В этом режиме каждая вновь указанная точка воспринимается системой как начальная точка очередного ответвления.

Подробнее о добавлении и удалении ответвлений...

В режиме редактирования характерных точек объекта можно внести изменения в конфигурацию обозначения. Добавление ответвлений в этом режиме невозможно. Для перехода в режим редактирования нажмите кнопку Редактировать точки на Панели специального управления.

Между режимами можно произвольно переключаться при помощи кнопок Панели специального управления или команд в контекстном меню. При выходе из одного режима автоматически включается другой.

Чтобы зафиксировать обозначение, нажмите кнопку Создать объект на Панели специального управления.

Пример простановки обозначения клеймения

Смотрите также

Другие элементы оформления


Команда Разбить кривую

Позволяет разбить объект в какой-либо точке на две части.

Для вызова команды нажмите кнопку Разбить кривую на инструментальной панели Редактирование.

Укажите курсором кривую, подлежащую разбиению.

Если выбрана незамкнутая кривая, то для разбиения ее на две части требуется указание одной точки т1.

Если выбрана замкнутая кривая, то для ее разбиения необходимо указать точки т1 и т2.

Если указанная точка не принадлежит выбранной кривой, то положение точки разбиения будет определяться проекцией указанной точки на кривую.

Для точного позиционирования курсора воспользуйтесь привязками или меню геометрического калькулятора в полях т1 и т2 на Панели свойств.

За один вызов команды вы можете разбить на две части произвольное количество кривых.

Для завершения команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие команды редактирования


Команда Разбить кривую на N частей

Позволяет разбить объект на несколько равных частей.

Для вызова команды нажмите кнопку Разбить кривую на N частей на инструментальной панели Редактирование.

Введите в поле N на Панели свойств количество частей, на которые нужно разбить кривую.

Затем укажите курсором кривую для разбиения.

Если кривая замкнута, необходимо указать начальную точку для разбиения.

Если указанная точка не принадлежит выбранной кривой, то положение точки разбиения будет определяться проекцией указанной точки на кривую.

Для точного позиционирования курсора воспользуйтесь привязками или меню геометрического калькулятора в поле т на Панели свойств.

За один вызов команды вы можете разбить на равные части произвольное количество кривых.

Для завершения команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие команды редактирования


Команда Показать разрывы

Позволяет управлять изображением вида: включать и выключать отображение разрывов.

Команда может быть вызвана из контекстного меню выделенного вида. Она доступна, если в виде имеется разрыв.

Вид может отображаться либо полностью — без всех разрывов, либо со всеми разрывами, которые в нем созданы. Отключить какой-либо один из разрывов невозможно.


Команда Параметры разрыва...

Позволяет настроить параметры разрыва изображения вида.

Команда может быть вызвана из контекстного меню выделенного вида. Она доступна, если в виде имеется разрыв.

После вызова команды на Панели свойств появляются элементы управления команды Разрыв вида. Выполните действия, предусмотренные в команде.


Команда Линия с изломами

Позволяет построить линию обрыва с изломами.

Для вызова команды нажмите кнопку Линия с изломами на инструментальной панели Обозначения или выберите ее название из меню Инструменты — Обозначения — Линии обрыва.

Линия с изломами представляет собой отрезок с равномерно расположенными изломами (см. рисунок).

Пример использования и параметры линии с изломами

а)

б)

– Если известны начальная (т1) и конечная (т2) точки линии с изломами, укажите их. При этом длина и угол наклона линии будут определены автоматически.

– Если известны начальная точка линии с изломами, ее длина и угол наклона, задайте их любым способом и в любом порядке. Например, вы можете указать курсором положение точки т1, ввести длину в поле на Панели свойств и задать курсором угол наклона линии. При этом конечная точка линии будет определена автоматически.

В документе будет создана линия с изломами, выходящая за точки т1 и т2 на величину выступа.

Если заданное количество изломов с текущими параметрами не умещается между конечными точками линии, то строится максимально возможное целое число изломов.

Во время построения линии с изломами можно настроить параметры линии с изломами на вкладке Параметры Панели свойств.

Чтобы быстро построить несколько одинаковых линий с изломами, например, для обозначения разрыва изображения, сделайте следующее. Не указывая точек т1 и т2 сделайте настройки на вкладке Параметры.

Задайте и зафиксируйте значения в полях Угол и Длина, а затем нажмите кнопку Запомнить состояние на Панели специального управления. Укажите последовательно начальные точки (т1) новых линий разрыва.

Вы можете создать несколько обозначений за один вызов команды Линия с изломами.

Чтобы завершить команду, нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

При использовании привязки к линии с изломами в процессе построения других объектов необходимо иметь в виду следующее: привязка Середина позволяет привязаться к середине промежутка, привязка Центр — к середине всей линии.

Смотрите также

Волнистая линия

Автоматическое и ручное создание объектов

Другие обозначения


Команда Дерево чертежа/Дерево модели

Позволяет включить или выключить показ Дерева документа — Дерева чертежа в активном окне чертежа или Дерева построения модели в активном окне модели.


Тип кривой (способ построения сплайна)

Тип кривой
(способ построения сплайна)

Переключатель, позволяющий указать способ построения сплайна: по точкам или по полюсам.

Изменение способа построения немедленно отображается на фантоме сплайна в окне модели.

Подробнее...


Команда Объемные «корешки» вкладок

Позволяет включить объемное отображение «корешков» вкладок. При вызове команды рядом с ее названием в меню появляется «галочка».

Когда включено объемное отображение «корешков», то:

– кроме надписей на них отображаются пиктограммы, символизирующие назначение вкладок,

– ширина «корешков» изменяется в соответствии с шириной Панели свойств, благодаря чему отпадает необходимость в прокрутке «корешков», поэтому кнопки прокрутки не отображаются.


Команда Отказ от перебора (трехмерный объект)

Команда Отказ от перебора
(трехмерный объект)

Позволяет отказаться от перебора объектов (выйти из режима перебора).

После вызова этой команды выделение снимается со всех близко расположенных объектов. Для выхода из режима перебора с сохранением выделения на одном из объектов воспользуйтесь командой Выбрать подсвеченный объект из контекстного меню.


Переключатель Группировка

Активизация переключателя Группировка позволяет разбить на группы свойства выделенного объекта (объектов), отображающиеся в окне Свойства. Группы можно сворачивать (разворачивать), щелкая мышью на значке «плюс» (минус) слева от названия группы. Набор групп свойств зависит от типа выделенного объекта (объектов).

Второй способ отображения перечня свойств — в алфавитном порядке. Для его применения служит активизация переключателя Сортировка.


Команда Ось через вершину по объекту

Позволяет создать вспомогательную ось, проходящую через точечный объект в направлении другого объекта или вектора.

Пример

Для вызова команды нажмите кнопку Ось через вершину по объекту на панели Вспомогательная геометрия или выберите ее название из меню Операции.

Если объекты для построения оси уже существуют в модели, укажите их.

Выбор объектов в окне модели

Выбор объектов в Дереве построения

Объекты могут быть выделены и перед вызовом команды.

При указании точки, построенной способом На кривой или На поверхности, автоматически выбирается направляющий объект для оси — кривая или поверхность, на которой построена точка. При необходимости вы можете сменить направляющий объект. Для этого укажите нужный объект в окне модели.

Если нужных объектов в модели нет, то вы можете построить их, не выходя из команды.

• Чтобы создать точку, нажмите кнопку Построение точки на Панели специального управления.

• Чтобы создать вектор, определяющий направление оси, нажмите кнопку Построение вектора на Панели специального управления.

Обратите внимание на то, что созданная точка отображается как самостоятельный объект в Дереве построения. Изменение параметров точки производится непосредственно путем редактирования этого объекта, а не в процессе редактирования оси.

После выбора исходных объектов на экране появляется фантом создаваемой оси.

В ряде случаев можно выбрать направление создаваемой оси: вдоль направляющего объекта или перпендикулярно ему. Для этого служит группа переключателей Ориентация.

– Параллельно объекту,

– Перпендикулярно объекту.

Изменение ориентации оси отображается на фантоме в окне модели.

Чтобы сменить объекты, используемые для построения оси, нажмите кнопку Указать заново на Панели специального управления и повторите выбор объектов.

Название и цвет оси можно изменить на вкладке Свойства Панели свойств.

Чтобы завершить построение, нажмите кнопку Создать объект на Панели специального управления.

Прервать построение можно, нажав кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие команды построения вспомогательных осей


Команда Построение оси через вершину по объекту

Позволяет построить вспомогательную ось, которая будет использоваться в качестве оси вращения при выполнении операции вращения.

Для вызова команды нажмите кнопку Ось на Панели специального управления. Команда доступна также в контекстном меню окна модели.

После вызова команды запускается операция создания оси. Укажите точку и направляющий объект для оси.

Затем нажмите кнопку Создать объект.

Система вернется в процесс операции вращения.

Построенная ось появится в Дереве построения перед текущей операцией как самостоятельный объект и будет автоматически выбрана в качестве оси вращения.

Ось, создаваемая в процессе выполнения операции вращения, ничем не отличается от оси, создаваемой командой Ось через вершину по объекту.


Команда Ось на пересечении плоскостей

Позволяет создать одну или несколько конструктивных осей, каждая из которых является линией пересечения двух плоских объектов (или их продолжений).

Для вызова команды нажмите кнопку Ось на пересечении плоскостей на панели Вспомогательная геометрия или выберите ее название из меню Операции.

Укажите курсором пару плоских объектов, на пересечении которых требуется построить ось.

Выбор объектов в окне модели

Выбор объектов в Дереве построения

Вы можете задать название и цвет оси на вкладке Свойства Панели свойств.

Завершить ввод осей можно, нажав кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие команды построения вспомогательных осей


Команда Ось через две вершины

Позволяет создать одну или несколько конструктивных осей, каждая из которых проходит через указанные точечные объекты.

Для вызова команды нажмите кнопку Ось через две вершины на панели Вспомогательная геометрия или выберите ее название из меню Операции.

Укажите курсором пару точечных объектов, через которые должна проходить ось.

Выбор объектов в окне модели

Вы можете задать название и цвет оси на вкладке Свойства Панели свойств.

Завершить ввод осей можно, нажав кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие команды построения вспомогательных осей


Команда Ось конической поверхности

Позволяет создать одну или несколько конструктивных осей, каждая из которых является осью поверхности вращения.

Для вызова команды нажмите кнопку Ось конической поверхности на панели Вспомогательная геометрия или выберите ее название из меню Операции.

Укажите курсором поверхность вращения, ось которой требуется построить.

Выбор объектов в окне модели

Вы можете задать название и цвет оси на вкладке Свойства Панели свойств.

Завершить ввод осей можно, нажав кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие команды построения вспомогательных осей


Команда Ось через ребро

Позволяет создать одну или несколько конструктивных осей, каждая из которых проходит через указанный прямолинейный объект.

Для вызова команды нажмите кнопку Ось через ребро на панели Вспомогательная геометрия или выберите ее название из меню Операции.

Укажите курсором прямолинейный объект, через который должна проходить ось.

Выбор объектов в окне модели

Вы можете задать название и цвет оси на вкладке Свойства Панели свойств.

Завершить ввод осей можно, нажав кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие команды построения вспомогательных осей


Команда Дуга окружности

Позволяет создать дугу окружности в пространстве. Доступно несколько способов построения.

Для вызова команды нажмите кнопку Дуга окружности на панели Пространственные кривые или выберите ее название из меню Операции — Пространственные кривые.

Выберите способ построения дуги из списка Способ или при помощи команд контекстного меню.

Задайте параметры дуги, необходимые для ее построения выбранным способом.

– По 3 точкам

– По центру и радиусу

– По 2 точкам с направлением

– С касанием к кривой

Во всех способах объектами построения являются точки. Точку дуги можно указать следующими способами:

– задать координаты в пространстве (координаты задаются относительно системы координат дуги);

– указать положение мышью в окне модели: координаты точки определяются автоматически и заносятся в поля X, Y, Z;

– связать с уже имеющимся точечным объектом: включить опцию Ассоциировать и указать в модели точечный объект.

– построить, нажав кнопку Построение точки на Панели специального управления.

При необходимости вы можете построить окружность. Для этого активизируйте переключатель Окружность в группе Дуга. Такая возможность существует во всех способах построения дуги.

После задания всех необходимых данных появляется фантом дуги окружности. Пока построение не завершено, можно изменить параметры дуги, активизировав необходимый элемент управления на Панели свойств.

Чтобы сменить объекты, используемые для построения дуги окружности выбранным способом, нажмите кнопку Указать заново на Панели специального управления и повторите выбор объектов.

При необходимости назначьте допуски на значения параметров операции, выраженных в линейных или угловых величинах. Для этого используйте кнопку Назначить допуск, расположенную на Панели свойств рядом с полем числового параметра операции.

Подробнее о допусках...

Подробнее о назначении допуска...

Элементы управления, расположенные на вкладке Свойства Панели свойств, позволяют изменить название и цвет дуги, настроить параметры ее отображения. Также на этой вкладке отображается название системы координат дуги.

Чтобы завершить построение, нажмите кнопку Создать объект на Панели специального управления.

Отказаться от построения дуги можно, нажав кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

При всех способах построения дуги окружности доступен режим автосоздания, который по умолчанию включен.


Команда Ломаная (документ-модель)

Команда Ломаная
(документ-модель)

Позволяет создать пространственную ломаную.

Для вызова команды нажмите кнопку Ломаная на инструментальной панели Пространственные кривые или выберите ее название из меню Операции — Пространственные кривые.

Построение ломаной заключается в последовательном задании ее вершин.

При построении очередной вершины на экране отображается линия, соединяющая эту вершину с предыдущей — линия построения вершины кривой.

Выберите способ построения вершины из раскрывающегося списка Способ построения на Панели свойств:

– По точкам,

– По осям,

– По объектам.

Первая вершина ломаной может быть построена только способом По точкам.

Вторая вершина по умолчанию строится способом По осям. Способ построения для этой вершины может быть изменен.

Если пространственная ломаная строится из присоединительной точки, то направление линии построения будет совпадать с вектором этой точки (вторая вершина по умолчанию строится способом По объектам).

Каждая вершина ломаной характеризуется набором параметров, которые отображаются в таблице параметров вершин.

Вы можете задать координаты вершины следующими способами:

– ввести значения координат в таблицу параметров вершин,

– построить специальную точку,

– связать вершину с точечным объектом в окне модели.

Координаты вершин ломаной задаются в ее системе координат.

Осям этой же системы координат параллельны сегменты ломаной при построении по осям.

Команда Встроить совокупность вершин позволяет создать несколько вершин ломаной между двумя уже существующими вершинами.

Группа переключателей Характерные точки позволяет указать, какие характерные точки ломаной должны отображаться на экране: характерные точки вершин и ненулевых радиусов или пары характерных точек (вершин и скруглений любого радиуса).

Задать радиус скругления ломаной в вершине можно только после того, как эта вершина построена. Для этого нужно выделить вершину и ввести значение в поле Радиус на Панели свойств. Можно также ввести радиусы в таблице параметров вершин.

При построении очередной вершины на экране отображается фантом сегмента, соединяющего эту вершину с предыдущей. Это позволяет оценить правильность ввода параметров и, при необходимости, откорректировать их.

Опция Ассоциировать позволяет сформировать ассоциативную связь между вершинами ломаной и точечными объектами. Если при построении вершины ломаной эта опция отключена, то вершина совпадает с указанным точечным объектом (или с его проекцией на линию построения вершины), но не связывается с ним, т.е. при перемещении точечного объекта вершина останется на прежнем месте.

Группа переключателей Замкнутость позволяет указать, требуется замыкать ломаную или нет.

При необходимости вы можете назначить допуски на значения параметров операции, выраженных в линейных или угловых величинах. Для этого используйте кнопку Назначить допуск, расположенную на Панели свойств рядом с полем числового параметра операции.
Подробнее о допусках...
Подробнее о назначении допуска...

Элементы управления, расположенные на вкладке Свойства Панели свойств, позволяют изменить название и цвет ломаной, настроить параметры ее отображения. Также на этой вкладке отображается название системы координат ломаной.

Чтобы завершить построение, нажмите кнопку Создать объект на Панели специального управления.

Отказаться от создания ломаной можно, нажав кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Использование характерных точек

Особенности задания числовых параметров операции в полях Панели свойств


Команда Сплайн (документ-модель)

Команда Сплайн
(документ-модель)

Позволяет построить пространственный сплайн.

Для вызова команды нажмите кнопку Сплайн на инструментальной панели Пространственные кривые или выберите ее название из меню Операции — Пространственные кривые.

Построение сплайна заключается в последовательном задании его вершин.

При построении очередной вершины на экране отображается линия, соединяющая эту вершину с предыдущей — линия построения вершины кривой.

Выберите способ построения вершины из раскрывающегося списка Способ построения на Панели свойств:

– По точкам,

– По осям,

– По объектам.

Обратите внимание на то, что первая вершина сплайна может быть построена только способом По точкам.

Каждая вершина сплайна характеризуется набором параметров, которые отображаются в таблице параметров вершин.

Вы можете задать координаты вершины следующими способами:

– ввести значения координат в таблицу параметров вершин,

– построить специальную точку,

– cвязать вершину с точечным объектом в окне модели.

Координаты вершин сплайна задаются в его системе координат.

Группа переключателей Тип позволяет выбрать способ построения: По точкам или По полюсам.

При построении сплайна по полюсам становятся доступными поле Порядок и колонка Вес. По умолчанию система устанавливает порядок кривой 4, а вес точек — 1. При необходимости вы можете ввести любое значение веса точки из диапазона 0,0001–999, а значение порядка кривой — из диапазона 2–10.

Если начальная и/или конечная вершина сплайна принадлежит существующему объекту модели, вы можете сопрячь сплайн с этим объектом. Для задания условий сопряжения служит вкладка Сопряжения Панели свойств.

На экране отображается фантом сплайна с заданными параметрами вершин. Это позволяет оценить правильность ввода параметров и при необходимости откорректировать их.

Опция Ассоциировать позволяет сформировать ассоциативную связь между вершинами сплайна и точечными объектами. Если при построении вершины сплайна эта опция отключена, то вершина совпадает с указанным точечным объектом (или с его проекцией на линию построения вершины), но не связывается с ним, т.е. при перемещении точечного объекта вершина останется на прежнем месте.

Группа переключателей Замкнутость позволяет указать, требуется замыкать сплайн или нет.

При необходимости вы можете изменить форму сплайна по точкам, управляя касательностью и/или кривизной в любой ее вершине. Для этого выделите в таблице параметров строку с номером нужной вершины и нажмите кнопку Управление формой в точках на Панели специального управления. Система переходит в режим управления формой сплайна в текущей вершине.

Если начальная или конечная вершина сплайна сопряжена с объектом модели, то управление формой сплайна в этих вершинах невозможно. Удалите заданное сопряжение, чтобы получить возможность управлять формой сплайна в этой вершине (например, с помощью команд контекстного меню Удалить параметры управления —В точке или Удалить параметры управления — Во всех точках).

При необходимости вы можете назначить допуски на значения параметров операции, выраженных в линейных или угловых величинах. Для этого используйте кнопку Назначить допуск, расположенную на Панели свойств рядом с полем числового параметра операции.
Подробнее о допусках...
Подробнее о назначении допуска...

Элементы управления, расположенные на вкладке Свойства Панели свойств, позволяют изменить название и цвет кривой, настроить параметры ее отображения. Также на этой вкладке отображается название системы координат сплайна.

Чтобы завершить построение, нажмите кнопку Создать объект на Панели специального управления.

Отказаться от создания сплайна можно, нажав кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Особенности задания числовых параметров операции в полях Панели свойств


Команда Обозначение центра

Позволяет создать обозначение центра.

Для вызова команды нажмите кнопку Обозначение центра на инструментальной панели Обозначения.

По умолчанию обозначение центра формируется в виде двух пересекающихся осей. При этом в группе Тип на Панели свойств активен переключатель Две оси. Чтобы создать условное обозначение центра или одну ось, активизируйте соответствующий переключатель.

Если требуется сформировать обозначение центра осесимметричного объекта (окружности, дуги окружности, эллипса, дуги эллипса, прямоугольника, правильного многоугольника), укажите этот объект.

Если указан эллипс, дуга эллипса, прямоугольник или правильный многоугольник, обозначение центра немедленно фиксируется. Угол наклона обозначения при этом определяется автоматически.

Если указана окружность или ее дуга, то для фиксации обозначения центра необходимо также указать угол его наклона мышью или введя в поле Угол нужное значение.

Чтобы перейти к построению обозначения центра другого объекта, нажмите кнопку Указать заново на Панели специального управления и выберите нужный объект.

Если необходимо построить осевые линии, не принадлежащие ни одному осесимметричному объекту, активизируйте поле Центр или Угол на Панели свойств. Затем задайте положение центральной точки обозначения и угол его наклона любыми способами в любом порядке.

Настройка отрисовки обозначения центра

В результате выполнения команды создается специальный системный макроэлемент — обозначение центра. Оси обозначения центра пересекаются в центре базовой кривой всегда штрихами.

По умолчанию обозначение центра никак не связано с объектом, указанным в ходе выполнения операции, и может редактироваться отдельно.

Смотрите также

Особенности использования команды в параметрическом режиме

Другие обозначения


Команда Угловой цепной размер

Позволяет построить цепь угловых размеров.

Для вызова команды нажмите кнопку Угловой цепной на инструментальной панели Размеры. На Панели свойств появятся элементы управления.

Задайте первую и вторую стороны угла. Для этого укажите прямолинейные объекты или точки, при соединении которых образуются стороны угла. Прямолинейные объекты указываются при нажатой кнопке Выбор базового объекта, а точки — при отжатой.

Подробнее об указании сторон углов...

На Панели свойств отображаются координаты вершины угла, точек привязки т1 и т2.

Управление ориентацией размера

В поле Текст на вкладке Размер Панели свойств отображается автоматически сформированная размерная надпись. Чтобы вызвать диалог редактирования и настройки размерной надписи, щелкните мышью в этом поле.

В списке Размещение текста отображается текущий способ размещения надписи. Если необходимо, смените способ размещения. Подробнее...

Укажите точку, определяющую положение размерной линии т3. Это положение будет одинаковым для всех размеров цепи. Точка т3 определяет также положение размерной надписи, если выбрано автоматическое, фиксированное или ручное размещение текста.

Если выбрано размещение текста на полке, укажите точку начала полки т4. В этом случае точка т3 является начальной точкой линии-выноски.

Последовательно укажите вторые стороны углов и положение надписей для остальных размеров цепи. В качестве вторых сторон следует указать отрезки.

Все отрезки, указываемые для построения цепного углового размера, должны проходить через одну точку — центр окружности, содержащей размерные линии.

Простановка цепи угловых размеров
(способ задания сторон углов — по двум отрезкам)

Выбор вида выносных линий

Настройка параметров размеров (выбор вида стрелки, положения надписи и т.п.).

Группа размеров, построенная с помощью команды Угловой цепной размер, не является единым объектом — это цепь простых угловых размеров, составленная по определенным правилам (первая сторона угла каждого последующего размера совпадает со второй стороной угла предыдущего; размерные линии расположены на одной окружности). Поэтому, если у всех размеров цепи должны быть одинаковые параметры (например, стрелки определенного типа), необходимо после настройки первого размера включить опцию По умолчанию.

Для перехода к простановке другого цепного размера нажмите кнопку Указать заново на Панели специального управления и укажите новый базовый отрезок.

Смотрите также

Особенности использования команды в параметрическом режиме

Другие размеры

Выравнивание размерных линий

Редактирование углового размера с помощью мыши


Команда Линейный цепной размер

Позволяет проставить цепь линейных размеров.

Для вызова команды нажмите кнопку Линейный цепной на инструментальной панели Размеры.

Укажите курсором точки привязки размера — т1 и т2 (точки выхода выносных линий).

Для точного позиционирования курсора воспользуйтесь привязками или меню геометрического калькулятора в полях т1 и т2 на Панели свойств.

На вкладке Размер Панели свойств находится группа переключателей Тип, с помощью которой можно установить ориентацию всех размеров цепи (вертикальный или горизонтальный).

Выбор ориентации возможен только до фиксации первого размера цепи.

В поле Текст на вкладке Размер отображается автоматически сформированная размерная надпись. Чтобы вызвать диалог редактирования и настройки размерной надписи, щелкните мышью в этом поле.

В списке Размещение текста отображается текущий способ размещения надписи. Если необходимо, смените способ размещения. Подробнее...

Укажите точку, определяющую положение размерной линии т3. Это положение будет одинаковым для всех размеров цепи.

Если выбрано фиксированное или ручное размещение текста, то точка т3 определяет также положение размерной надписи.

Если выбрано размещение текста на полке, то точка т3 является начальной точкой линии-выноски. В этом случае необходимо указать точку начала полки т4.

Последовательно укажите точки т2 и т3 для остальных размеров цепи.

Простановка цепного линейного размера

Настройка параметров размеров (выбор вида стрелки, положения надписи и т.п.).

Формирование зазора между выносной линией и точкой привязки

Группа размеров, построенная с помощью команды Линейный цепной размер, не является единым объектом — это цепь простых линейных размеров, составленная по определенным правилам (первая точка привязки каждого последующего размера совпадает со второй точкой привязки предыдущего; размерные линии расположены на одной прямой). Поэтому, если у всех размеров цепи должны быть одинаковые параметры (например, стрелки определенного типа), необходимо после настройки первого размера включить опцию По умолчанию на вкладке Параметры Панели свойств.

Для перехода к простановке другого цепного размера необходимо расфиксировать первую точку привязки цепи (поле т1 на вкладке Размер Панели свойств) и указать ее новое положение.

Смотрите также

Другие размеры

Выравнивание размерных линий


Команда Фаска

Позволяет построить отрезок, соединяющий две пересекающиеся кривые.

Для вызова команды нажмите кнопку Фаска на инструментальной панели Геометрия.

С помощью переключателя из группы Тип выберите способ задания параметров фаски.

Введите параметры фаски в поля Панели свойств.

Укажите первый и второй объекты, между которыми нужно построить фаску.

Исходное изображение и изображение после построения фасок

Управление усечением объектов

Создание условного пересечения

Если вы неправильно задали параметры фаски или указали не те объекты для построения, не прерывайте команду. Нажмите кнопку Отменить на Стандартной панели для отказа от неправильного построения. Затем введите правильные параметры и постройте по ним новую фаску.

Для выхода из команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие геометрические объекты


Команда Фаска на углах объекта

Позволяет построить фаски на углах объектов следующих типов: контур, ломаная или многоугольник.

Для вызова команды нажмите кнопку Фаска на углах объекта на инструментальной панели Геометрия.

С помощью переключателя из группы Тип выберите способ задания параметров фаски.

Введите параметры фаски.

Укажите курсором угол контура, многоугольника или ломаной, на котором необходимо построить фаску.

Группа переключателей Режим позволяет указать, требуется ли построение фаски только на указанном угле или сразу на всех углах объекта.

Построение фасок на всех вершинах многоугольника

Управление усечением объектов

Если вы неправильно задали параметры фаски или указали не те объекты для построения, не прерывайте команду. Нажмите кнопку Отменить на Стандартной панели для отказа от неправильного построения. Затем введите правильные параметры и постройте по ним новую фаску.

Для выхода из команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие геометрические объекты


Способ построения фаски

Переключатель, позволяющий выбрать способ построения фаски: по двум длинам или по длине и углу.


Команда Изменить оформление

Позволяет сменить оформление выбранного листа чертежа.

Команда доступна в контекстном меню основной надписи листа. После ее вызова на экране появляется диалог выбора оформления листа. В этом диалоге вы можете выбрать нужную библиотеку *.lyt и оформление из нее. Кроме того, возможно перечитывание уже примененного к документу оформления, а также отказ от использования оформления.

Смотрите также

Хранение в документе информации об используемом оформлении


Команда Подогнать фрагмент под высоту ячейки

Позволяет автоматически подобрать масштаб вставляемого в ячейку таблицы фрагмента таким образом, чтобы вертикальный габарит вставки был равен высоте ячейки.


Команда Подогнать фрагмент под заданные размеры

Позволяет автоматически подобрать масштаб вставляемого в ячейку таблицы фрагмента таким образом, чтобы вставка поместилась в прямоугольнике с заданными размерами.

После указания пользователем в соответствующем диалоге высоты и ширины вставки ее масштаб изменяется таким образом, чтобы вставка поместилась в прямоугольник с выбранными габаритами без изменения пропорций (соотношение габаритов фрагмента остается постоянным).


Команда Подогнать фрагмент под ширину ячейки

Позволяет автоматически подобрать масштаб вставляемого в ячейку таблицы фрагмента таким образом, чтобы горизонтальный габарит вставки был равен ширине ячейки.


Команда Подогнать фрагмент/лист под высоту страницы

Позволяет автоматически подобрать масштаб вставляемого в текстово-графический документ фрагмента или листа таким образом, чтобы вертикальный габарит вставки был равен высоте страницы.


Команда Подогнать фрагмент/лист под заданные размеры

Позволяет автоматически подобрать масштаб вставляемого в текстово-графический документ фрагмента или листа таким образом, чтобы вставка поместилась в прямоугольнике с заданными размерами.

После указания пользователем в соответствующем диалоге высоты и ширины вставки ее масштаб изменяется таким образом, чтобы вставка поместилась в прямоугольник с выбранными габаритами без изменения пропорций (соотношение габаритов фрагмента или листа остается постоянным).


Команда Подогнать фрагмент/лист под ширину страницы

Позволяет автоматически подобрать масштаб вставляемого в текстово-графический документ фрагмента или листа таким образом, чтобы горизонтальный габарит вставки был равен ширине страницы.


Команда Изменить стиль

Позволяет заменить стиль выделенных объектов документа (линий, точек, штриховок, текстов).

Перед вызовом команды выделите все объекты, стиль которых необходимо изменить. Можно выделять объекты разного типа.

После вызова команды на экране появляется диалог, в котором можно указать стили для замены.

Если вы случайно ошиблись при замене стилей объектов, нажмите кнопку Отменить на Стандартной панели.


Команда Изменить источник для вставок видов

Команда Изменить источник
 для вставок видов

Позволяет сменить файл-источник всех выделенных вставок видов.

Команда доступна в контекстном меню вставки, выделенной в окне документа или в Дереве чертежа.

После вызова команды на экране появляется стандартный диалог выбора файлов, в котором нужно указать новый чертеж — источник вставок.

Параметры вставок, источник которых изменился, остаются прежними. Они отображаются на Панели свойств. При необходимости вы можете изменить параметры.

Чтобы подтвердить замену источника, нажмите кнопку Создать объект.


Команда Изменить источник для вставок фрагментов

Команда Изменить источник
 для вставок фрагментов

Позволяет сменить файл-источник всех выделенных вставок фрагментов.

Команда доступна в контекстном меню вставки, выделенной в окне документа или в Дереве чертежа.

После вызова команды на экране появляется стандартный диалог выбора файлов, в котором нужно указать новый фрагмент — источник вставок.

Параметры (масштаб, угол поворота и др.) вставок, источник которых изменился, остаются прежними. Они отображаются на Панели свойств. При необходимости вы можете изменить параметры.

Чтобы подтвердить замену источника, нажмите кнопку Создать объект.


Команда Изменить слой...(графического объекта)

Команда Изменить слой...
(графического объекта)

Позволяет перенести выделенные объекты на другой слой.

Перед выполнением команды выделите объекты, которые требуется перенести на другой слой. Все выделяемые объекты должны принадлежать одному виду (не обязательно текущему в настоящий момент).

После вызова команды на экране появится диалог, в котором можно выбрать слой для размещения объектов. Перенос возможен только на слой того же вида, к которому принадлежат выделенные объекты.

Если вы случайно ошиблись при переносе объектов на другой слой, нажмите кнопку Отменить на Стандартной панели для отмены неправильных действий.


Поле Файл-источник

Справочное поле, содержащее полное имя файла модели, вставленной или вставляемой в текущую модель, а также используемой в качестве источника объектов для создания копии. Кнопка, расположенная справа от этого поля позволяет выбрать другой файл — источник вставки. Вызывает стандартный диалог открытия файлов.


Команда Знак изменения

Позволяет создать линию-выноску для обозначения изменения.

Для вызова команды нажмите кнопку Знак изменения на инструментальной панели Обозначения.

Укажите начальную точку первого ответвления (первую точку, на которую указывает линия-выноска).

Укажите точку т1, определяющую положение знака обозначения изменения.

Затем укажите начальные точки остальных ответвлений.

Настройка отрисовки обозначения изменения

По умолчанию предлагаемый системой номер изменения является простым текстом. При этом в списке Нумерация, расположенном на вкладке Знак Панели свойств, активизирован вариант Не использовать.

Вы можете задать номер изменения, поместив создаваемое обозначение в одну из групп нумерации. Для этого следует выбрать из списка Нумерация название нужной группы. Данный способ позволяет нумеровать изменения автоматически. Номер каждого изменения является ссылкой на номер обозначения этого изменения в группе нумерации.

Если требуется создать пользовательскую группу нумерации или настроить параметры нумерации для системных и пользовательских групп, нажмите кнопку Параметры групп нумерации на Панели специального управления.

Настройка нумерации и создание пользовательских групп

Заданный номер изменения отображается в поле Текст вкладки Знак. При необходимости вы можете добавить текст, расположенный до или после номера, изменить начертание символов, изменить значение номера, если он является простым текстом. Для этого вызовите диалог ввода надписи обозначения, щелкнув в поле Текст левой кнопкой мыши.

По умолчанию при создании знака изменения включен режим добавления ответвлений. Об этом свидетельствует нажатая кнопка Добавить ответвления на Панели специального управления. В этом режиме каждая вновь указанная точка воспринимается системой как начальная точка очередного ответвления.

В режиме редактирования характерных точек объекта можно внести изменения в конфигурацию знака Добавление ответвлений в этом режиме невозможно. Для перехода в режим редактирования нажмите кнопку Редактировать точки на Панели специального управления.

Между режимами можно произвольно переключаться при помощи кнопок Панели специального управления или команд в контекстном меню. При выходе из одного режима автоматически включается другой.

Чтобы зафиксировать изображение, нажмите кнопку Создать объект на Панели специального управления.

Простановка обозначения изменения

Смотрите также

Добавление ответвлений

Другие обозначения


Длина линии-выноски

Поле для ввода длины линии-выноски. Доступно, если в списке Тип выноски выбран вариант Ограниченный отрезок.


Высота знака обозначения изменения

Поле для ввода или выбора размера знака: стороны квадрата или диаметра окружности. Если знак обозначения изменения имеет вид скобок, то поле Высота знака недоступно, так как высота скобок определяется размером шрифта текста обозначения изменения.


Команда Сменить режим работы

Позволяет изменить режим работы библиотек.

После вызова команды на экране появится диалог со списком подключенных на данный момент библиотек. Выделите библиотеки, режим работы которых требуется изменить, выберите нужный вариант: меню, диалог, окно или панель и нажмите кнопку ОК. Для выхода из диалога без изменения режима работы нажмите кнопку Отмена.


Команда Найти перекрывающиеся листы

Позволяет выполнить проверку всех листов документов, добавленных в просмотр, на перекрытие.

Команда доступна, если отключен режим указания страниц на поле печати.

Для вызова команды нажмите кнопку Найти перекрывающиеся листы на инструментальной панели или выберите ее название из меню Сервис.

– Если перекрывающиеся листы найдены, то они выделяются зеленой рамкой.
Листы, перекрывающие друг друга полностью, выделяются красной рамкой.

– Если перекрывающиеся листы не найдены, то на экране появляется сообщение об этом.


Команда Разбивать таблицу изменений на блоки

Команда позволяет разделить на блоки таблицу изменений, из контекстного меню которой она была вызвана. Размер (количество строк) этих блоков задается при настройке оформления, присвоенного листу.


Команда Следующий объект

Позволяет выделить следующий из близко расположенных (в том числе наложенных друг на друга) объектов. Команда доступна в контекстном меню в режиме перебора объектов.

Для перехода к следующему объекту можно также нажать клавишу <Пробел>.


Процесс изменения набора частей тела

Позволяет указать, какие из частей тела (тел), получившиеся в результате операции, требуется оставить в модели.

Этот процесс запускается автоматически после выполнения или редактирования операции, в результате которой образуется тело из нескольких несвязанных частей или изменяется количество частей тела.

При необходимости процесс изменения набора частей тела можно запустить вручную с помощью команды Изменить набор частей.

В процессе изменения набора частей на Панели свойств отображается опция Все. Если она включена, то в модели останутся все части тела, образовавшиеся в результате операции.

Чтобы изменить набор частей, отключите опцию Все. На Панели свойств появится Список частей. Он представлен в виде таблицы, первая колонка которой содержит номер тела и части, а вторая — опцию Оставить.

Отключите опции тех частей, которые не будут использоваться, или укажите эти части в окне модели. Повторное указание части включает ее в число оставляемых.

Исключенные части тел как бы отсутствуют в модели: они не отображаются на экране, не могут использоваться при построении других объектов, не учитываются при вычислении МЦХ, не передаются в ассоциативные виды модели и в результирующие файлы при экспорте в другие форматы и т.д.

В то же время информация об исключенных частях тел не удаляется из файла модели, благодаря чему впоследствии набор частей можно изменить.

Если нужно оставить или исключить большинство частей, воспользуйтесь кнопками Выбрать все части и Отменить выбор для всех частей, расположенными над списком или одноименными командами контекстного меню.

Части тела отображаются на экране в виде фантомов разных цветов:

– оставленные части — цветом подсветки (по умолчанию — красный),

– исключенные части — серым цветом,

– часть, выделенная в Списке частей — цветом выделения (по умолчанию — зеленый),

– не затронутые операцией части редактируемых тел — голубым цветом.

Завершив выбор частей тела, нажмите кнопку Создать объект. Кнопка доступна, если оставлено хотя бы по одной части каждого тела.

В процессе изменения набора частей доступны только части тел, построенных в текущей модели. Если в результате операции образуются также части тел компонентов (например, при удалении материала), то изменение числа этих частей невозможно — все они остаются в модели.

Смотрите также

Тела, состоящие из отдельных частей


Команда Выбрать все полюсы

Команда позволяет выделить все полюсы сетки.

При необходимости вы можете отменить выделение некоторых полюсов, щелкнув по ним мышью при нажатой клавише <Ctrl>. Для отмены выделения всех полюсов вызовите команду Отменить выбор полюсов контекстного меню.

Смотрите также

Произвольное перемещение полюсов мышью


Переключатель Произвольный

Активизируйте этот переключатель, чтобы перейти к указанию произвольного набора объектов для создания массива.

Подробнее о выборе копируемых объектов...


Переключатель Автоопределение по указанию

Активизируйте этот переключатель, чтобы включить автоматическое определение типа копируемого объекта после указания первого объекта.

Подробнее о выборе копируемых объектов...


Переключатель Кривые или точки

Активизируйте этот переключатель, чтобы перейти к указанию кривых или точек для создания массива.

Подробнее о выборе копируемых объектов...


Переключатель Тела или поверхности

Активизируйте этот переключатель, чтобы перейти к указанию тел или поверхностей для создания массива.

Подробнее о выборе копируемых объектов...


Переключатель Компоненты

Активизируйте этот переключатель, чтобы перейти к указанию компонентов для создания массива.

Подробнее о массиве произвольных объектов...


Переключатель Операции

Активизируйте этот переключатель, чтобы перейти к указанию операций для создания массива.

Подробнее о выборе копируемых объектов...


Команда Зеркальный массив

Позволяет создать копии объектов, симметричные им относительно указанного плоского объекта.

Создание зеркальной копии компонентов невозможно. Поэтому, если модель содержит только компоненты, команда недоступна.

Результат зеркального копирования:

– для операции, поверхности, кривой, точки или вспомогательной плоскости/оси — новый объект, зеркально симметричный копируемому, и имеющий тот же тип, что копируемый объект.

– для тела — тело, обладающее плоскостью симметрии или новое тело, зеркально симметричное имеющемуся.

Зеркальный массив для различных типов объектов строится по-разному. Поэтому набор элементов управления для создания зеркальной копии объекта зависит от типа этого объекта: для тела и поверхности используется один набор элементов управления, для операций, кривых, точек, вспомогательных плоскостей и осей — другой.

За один вызов команды вы можете скопировать:

– либо одну или несколько операций,

– либо один или несколько объектов следующих типов: кривая, точка, вспомогательная плоскость или ось,

– либо одно тело,

– либо одну поверхность.

Пример зеркального копирования операции

Пример зеркального копирования тела

Для вызова команды нажмите кнопку Зеркальный массив на панели Массивы.

Чтобы создать зеркальный массив, необходимо указать в Дереве построения или в окне модели копируемый объект (или объекты) и плоский объект, который будет служить плоскостью симметрии.

Порядок построения зеркального массива операций, кривых, точек, вспомогательных плоскостей и осей...

Порядок построения зеркальной копии тела или поверхности...

Зеркальные массивы кривых, точек и вспомогательных объектов можно разрушить на отдельные экземпляры.

Смотрите также

Другие команды построения массивов


Команда Указание деталей

Позволяет использовать при определении габаритов зоны компоненты на произвольном уровне модели.

– Если кнопка команды нажата, то при указании объекта, входящего в компонент, выбирается только сам этот компонент вне зависимости от его уровня.

– Если же кнопка не нажата, то при указании объекта выделяется компонент первого уровня, содержащий указанный объект.


Команда Окружность по двум точкам

Позволяет построить окружность, проходящую через две заданные точки.

Для вызова команды нажмите кнопку Окружность по двум точкам на инструментальной панели Геометрия.

Укажите две точки т1 и т2, через которые должна пройти окружность.

Для точного позиционирования курсора воспользуйтесь привязками или меню геометрического калькулятора в полях т1 и т2 на Панели свойств.

В документе будет построена окружность, проходящая через заданные точки, с диаметром, равным расстоянию между ними.

Построение окружности по двум диаметрально противоположным точкам

Если диаметр создаваемой окружности не должен равняться расстоянию между указываемыми точками, введите его в поле Диаметр на Панели свойств. Затем укажите точки, через которые должна пройти окружность.

Выбор стиля линии

Группа переключателей Оси на Панели свойств управляет отрисовкой осей симметрии окружности.

За один вызов команды можно построить произвольное число окружностей.

Чтобы построить несколько окружностей, проходящих через одну и ту же точку, выполните следующее. Указав первую точку, нажмите кнопку Запомнить состояние на Панели специального управления. Затем последовательно постройте нужное количество окружностей. Аналогичным образом система может «запомнить» радиус окружностей.

Для выхода из команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие геометрические объекты


Команда Окружность по трем точкам

Позволяет построить окружность, проходящую через три заданные точки.

Для вызова команды нажмите кнопку Окружность по трем точкам на инструментальной панели Геометрия.

Задайте точки т1, т2 и т3, через которые должна пройти окружность.

Для точного позиционирования курсора воспользуйтесь привязками или меню геометрического калькулятора в полях т1, т2 и т3 на Панели свойств.

Координаты центра окружности и ее радиус будут определены автоматически.

Построение окружности по трем точкам

Выбор стиля линии

Группа переключателей Оси на Панели свойств управляет отрисовкой осей симметрии окружности.

Если требуется построить несколько окружностей, проходящих через одну точку, укажите эту точку и нажмите кнопку Запомнить состояние на Панели свойств, а затем последовательно указывайте вторые и третьи точки нескольких окружностей.

Подробнее о запоминании параметров...

Таким же способом можно построить и несколько разных окружностей, проходящих через две точки. Кнопку Запомнить состояние в этом случае нужно нажать после задания двух точек, а затем указать третьи точки нескольких окружностей.

Для выхода из команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие геометрические объекты


Команда Окружность с центром на объекте

Позволяет построить окружность с центром на указанной кривой.

Для вызова команды нажмите кнопку Окружность с центром на объекте на инструментальной панели Геометрия.

Укажите объект, на котором должен лежать центр окружности.

Затем задайте точку, лежащую на окружности.

Для точного позиционирования курсора воспользуйтесь привязками или меню геометрического калькулятора в полях Центр и т на Панели свойств.

На экране появятся фантомы всех вариантов окружностей заданного радиуса с центром на выбранной кривой.

Выберите нужный фантом мышью или с помощью кнопок Следующий объект и Предыдущий объект на Панели специального управления.

Затем зафиксируйте выбранную окружность, щелкнув по ней мышью или нажав кнопку Создать объект на Панели специального управления.

Построение окружности с центром на объекте

Выбор стиля линии

Группа переключателей Оси на Панели свойств управляет отрисовкой осей симметрии окружности.

Чтобы построить несколько окружностей с центром на одном и том же объекте, выполните следующее. Указав объект, на котором должны лежать центры окружностей, нажмите кнопку Запомнить состояние на Панели специального управления. Затем последовательно постройте нужное количество окружностей.

Чтобы перейти к построению окружностей с центром на другом объекте, нажмите кнопку Указать заново на Панели специального управления, а затем укажите курсором новый объект.

Для выхода из команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие геометрические объекты


Марка

Переключатель, позволяющий включать или выключать отрисовку марки на координационной оси.

Активизируйте переключатель Марка, чтобы ось отрисовывалась с маркой, расположенной на окружности оси.

Если переключатель не активен, координационная ось строится без марки.

Настройка умолчательного состояния переключателя Марка производится в диалоге общих настроек координационных осей.

Чтобы построить цепочки марок, перейдите на вкладку Дополнительные обозначения.


Команда Окружность, касательная к кривой

Позволяет построить окружность, касательную к заданной кривой.

Для вызова команды нажмите кнопку Окружность, касательная к кривой на инструментальной панели Геометрия.

Доступно два основных способа построения окружности, касательной к заданной кривой:

– задание двух точек, принадлежащих окружности,

– задание точки центра окружности.

Укажите объект, которого должна касаться окружность.

Если известно положение двух точек т1 и т2, через которые должна проходить создаваемая окружность, последовательно задайте их. Радиус окружности будет определен автоматически.

На экране появятся фантомы всех окружностей, касательных к указанной кривой и проходящих через заданные точки.

Выберите нужный фантом мышью или с помощью кнопок Следующий объект и Предыдущий объект на Панели специального управления.

Затем зафиксируйте выбранную окружность, щелкнув по ней мышью или нажав кнопку Создать объект на Панели специального управления.

Построение окружности, касательной к кривой

Если известна точка центра окружности, задайте ее.

На экране появятся фантомы всех окружностей с центром в заданной точке и касательных к указанной кривой.

Выберите нужный фантом и зафиксируйте его.

Выбор стиля линии

Группа переключателей Оси на Панели свойств управляет отрисовкой осей симметрии окружности.

Чтобы построить несколько окружностей, касательных к одному и тому же объекту, выполните следующее. Указав объект, которого должны касаться окружности, нажмите кнопку Запомнить состояние на Панели специального управления. Затем последовательно постройте нужное количество окружностей.

Чтобы перейти к построению окружностей, касательных к другому объекту, нажмите кнопку Указать заново на Панели специального управления, а затем укажите курсором новый объект.

Для выхода из команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие геометрические объекты


Команда Окружность, касательная к двум кривым

Позволяет построить окружность, касательную к двум указанным кривым.

Для вызова команды нажмите кнопку Окружность, касательная к двум кривым на инструментальной панели Геометрия.

Доступно два способа построения окружности, касательной к двум кривым:

– задание точки на окружности,

– задание радиуса или диаметра окружности.

Укажите объекты, которых должна касаться окружность.

Если известна точка, через которую должна проходить создаваемая окружность, задайте ее.

На экране появятся фантомы всех окружностей, касательных к указанной кривой и проходящих через заданную точку.

Выберите нужный фантом мышью или с помощью кнопок Следующий объект и Предыдущий объект на Панели специального управления.

Затем зафиксируйте выбранную окружность, щелкнув по ней мышью или нажав кнопку Создать объект на Панели специального управления.

Построение окружности, касательной к двум кривым

Если известен радиус окружности, введите нужное значение в поле Радиус или Диаметр на Панели свойств.

На экране появятся фантомы всех окружностей заданного радиуса, касательных к указанной кривой.

Выберите нужный фантом и зафиксируйте его.

Выбор стиля линии

Группа переключателей Оси на Панели свойств управляет отрисовкой осей симметрии окружности.

Чтобы построить несколько окружностей, касательных к одним и тем же объектам, выполните следующее. Указав объекты, которых должны касаться окружности, нажмите кнопку Запомнить состояние на Панели специального управления. Затем последовательно постройте нужное количество окружностей.

Чтобы перейти к построению окружностей, касательных к другим объектам, нажмите кнопку Указать заново на Панели специального управления, а затем последовательно укажите курсором два объекта.

Для выхода из команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие геометрические объекты


Команда Окружность, касательная к трем кривым

Позволяет построить окружность, касательную к трем указанным кривым.

Для вызова команды нажмите кнопку Окружность, касательная к трем кривым на инструментальной панели Геометрия.

Укажите первый, второй и третий объекты, касательно к которым должна пройти окружность. Если среди указанных объектов есть эллипс или сплайн, потребуется также указание примерного местоположения окружности.

На экране появятся фантомы всех вариантов окружностей, касательных к указанным объектам.

Выберите нужный фантом мышью или с помощью кнопок Следующий объект и Предыдущий объект на Панели специального управления.

Затем зафиксируйте выбранную окружность, щелкнув по ней мышью или нажав кнопку Создать объект на Панели специального управления.

Построение окружности, касательной к трем кривым

Выбор стиля линии

Группа переключателей Оси на Панели свойств управляет отрисовкой осей симметрии окружности.

Чтобы перейти к построению окружностей, касательных к другим объектам, нажмите кнопку Указать заново на Панели специального управления, а затем последовательно укажите курсором три объекта.

Для выхода из команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие геометрические объекты


Команда Окружность

Позволяет построить произвольную окружность.

Для вызова команды нажмите кнопку Окружность на инструментальной панели Геометрия.

Укажите центр окружности.

Затем укажите точку, лежащую на окружности.

Для точного позиционирования курсора воспользуйтесь привязками или меню геометрического калькулятора в полях Центр и т на Панели свойств.

Построение окружности по центру и точке

Выбор стиля линии

Группа переключателей Оси на Панели свойств управляет отрисовкой осей симметрии окружности.

Чтобы построить несколько концентрических окружностей, укажите точку центра и нажмите кнопку Запомнить состояние Панели специального управления. Затем последовательно создавайте окружности, указывая лежащие на них точки.

Подробнее о запоминании параметров...

За один вызов команды можно построить произвольное число окружностей.

Для выхода из команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие геометрические объекты


Команда Круговая координационная ось

Позволяет создать обозначение круговой координационной оси, используемое в строительной документации.

Для вызова команды нажмите кнопку Круговая координационная ось на инструментальной панели Обозначения для строительства или выберите ее название из меню Инструменты — Обозначения для строительства.

Укажите точку центра окружности оси (тС). На экране появится фантом обозначения с умолчательными параметрами.

Чтобы ввести надпись в обозначение, вызовите диалог ввода текста. Для этого щелкните мышью в поле Текст на Панели свойств или вызовите команду Текст надписи... из контекстного меню.

Пример использования и параметры круговой координационной оси

Чтобы при вводе текста производилось автоматическое присвоение обозначений маркам, активизируйте переключатель Автопродолжение. Выберите из контекстных меню поля Текст номер, букву и индекс текущего обозначения. В режиме автопродолжения следующей марке будет присвоено следующее по порядку обозначение.

Формирование обозначения координационной оси

Укажите точку размещения марки (т). Точка т определяет величину радиуса окружности. В документе будет создана круговая координационная ось с радиусом, равным расстоянию от центра (тС) до точки размещения марки (т). При построении мышью величина радиуса вычисляется автоматически и заносится в поле Радиус или поле Диаметр.

Во время построения можно изменить параметры отрисовки оси.

Совет...

Вы можете создать несколько обозначений за один вызов команды Круговая координационная ось.

Чтобы завершить команду, нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

По умолчанию включен режим автоматического создания объекта, о чем свидетельствует нажатая кнопка Автосоздание объекта Панели специального управления. Чтобы строить обозначение в ручном режиме, отожмите кнопку.

Чтобы сформировать дополнительные обозначения, создайте ось в ручном режиме и перейдите на вкладку Дополнительные обозначения Панели свойств для добавления и настройки дополнительных обозначений.

a) | б) | в)
Элементы дополнительных обозначений: а) указатель ориентации, б) марка, в) текст

Завершив построение оси, нажмите кнопку Создать объект.

Смотрите также

Прямая координационная ось

Дуговая координационная ось

Создание и редактирование дополнительных обозначений координационной оси

Другие обозначения для строительства


Команда Дуга

Позволяет построить одну или несколько произвольных дуг окружности.

Для вызова команды нажмите кнопку Дуга на инструментальной панели Геометрия.

Укажите центральную, а затем начальную и конечную точки дуги.

Для точного позиционирования курсора воспользуйтесь привязками.

Построение дуги

Выбор стиля линии

Группа переключателей Направление на Панели свойств управляет направлением построения дуги.

Чтобы построить несколько дуг, имеющих одинаковый центр и величину радиуса, сделайте следующее. Укажите точку центра. Введите нужное значение радиуса в поле Строки параметров и зафиксируйте его, а затем нажмите кнопку Запомнить состояние Панели специального управления. После этого последовательно создавайте дуги, указывая их начальные и конечные точки.

Подробнее о запоминании параметров...

Для выхода из команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие геометрические объекты


Команда Удалить линии-выноски

Позволяет удалять линии-выноски из состава таких объектов, как вставки и макроэлементы.

Чтобы удалить линии-выноски объекта, выделите его в окне документа или в Дереве чертежа, а затем вызовите команду Удалить линии-выноски из контекстного меню объекта.

Команда появляется в меню, если выделен один объект с обозначением, построенным командой Линия-выноска объекта.


Команда Обрезать

Позволяет обрезать рисунок, вставленный в графический документ, по замкнутой линии — границе обрезки. Части рисунка, оказавшиеся за пределами границы, не удаляются, а скрываются, благодаря чему имеется возможность переключения режима отображения рисунка — полностью или частично.

Чтобы выполнить или изменить обрезку рисунка, выделите его и вызовите команду Обрезать из меню Редактор или из контекстного меню.

Команду можно вызвать из меню Редактор и без выделения рисунка. В этом случае после вызова команды потребуется указать рисунок, щелкнув по нему мышью.

– Если обрезка рисунка еще не производилась, необходимо выполнить полную последовательность действий.

– Если обрезка рисунка уже была произведена, то вы можете:

• Указать другую границу обрезки. Для этого нажмите кнопку Повторный выбор контура на Панели специального управления и щелкните мышью на нужном объекте.

• Построить ломаную — границу обрезки. Для этого нажмите кнопку Ручное рисование границ на Панели специального управления и сформируйте ломаную. Подробнее о ручном рисовании границ...

Граница обрезки должна удовлетворять определенным требованиям.

• Сменить режим отображения. Для этого активизируйте нужный переключатель в группе Режим на Панели свойств.

Выполнив любое из перечисленных действий, нажмите кнопку Создать объект на Панели специального управления.

Обратите внимание на то, что новый контур заменяет предыдущий, так как для одного рисунка можно задать только одну границу обрезки.

После выполнения или редактирования обрезки одного рисунка система ожидает указания следующего. Чтобы завершить выполнение команды, нажмите кнопку Прервать команду.

Смотрите также

Выбор режима отображения рисунка


Команда Закрыть другие окна документа

Позволяет закрыть все открытые окна документа, кроме текущего.

Для вызова команды выберите ее название из контекстного меню закладки документа.

Смотрите также

Разделение рабочей области главного окна

Закладки документов


Замкнутость кривой

Переключатель, позволяющий указать, требуется ли замыкать сплайн или ломаную.

Изменение режима построения немедленно отображается на фантоме кривой в окне модели: если замыкание включено, то к кривой добавляется участок, соединяющий ее начальную и конечную точки, а если отключено, то этот участок удаляется.


Команда Закрыть все другие окна

Позволяет закрыть все окна открытых документов, кроме текущего.

Для вызова команды выберите ее название из контекстного меню закладки документа.

Смотрите также

Разделение рабочей области главного окна

Закладки документов


Команда Завершить редактирование таблицы

Позволяет закрыть окно редактирования таблицы, входящей в состав основной надписи и вернуться в диалог создания основной надписи.

Для вызова команды нажмите кнопку Завершить редактирование таблицы или выберите ее название из меню Файл.

Если внесенные в таблицу изменения не были сохранены в основной надписи, система выдаст запрос о необходимости их сохранения.


Команда Закрыть все окна

Закрывает все открытые окна КОМПАС-документов. Если внесенные в какие-либо документы изменения не были сохранены, на экране будет появляться запрос на их сохранение.

Для быстрого закрытия всех документов, записи всех несохраненных документов и завершения сеанса работы вызовите команду Файл — Выход.


Команда Отключить библиотеку

Позволяет отключить от системы КОМПАС-3D одну или несколько библиотек.

После вызова команды на экране появится диалог со списком подключенных на данный момент библиотек. Выделите библиотеки, которые требуется отключить, и нажмите кнопку ОК. Для выхода из диалога без отключения нажмите кнопку Отмена.


Резервные строки

В этом поле отображается количество резервных строк в текущем разделе спецификации (текущим считается раздел, в котором находится курсор).


Команда Коллекция

Позволяет создать в текущей модели коллекцию объектов этой модели.

В коллекцию могут быть включены следующие объекты модели:

– тела,

– поверхности,

– грани,

– ребра,

– вершины,

– пространственные кривые и точки,

– вспомогательные оси и плоскости,

– системы координат,

– эскизы.

Объекты, входящие в коллекцию, могут быть выбраны как до, так и после вызова команды.

Для вызова команды нажмите кнопку Коллекция на инструментальной панели Редактирование модели или выберите пункт меню Операции — Дополнительные элементы — Коллекция.

На Панели свойств появятся две вкладки Параметры и Свойства.

На вкладке Параметры сформируйте набор объектов коллекции. Этот набор отображается на панели Список объектов. Объекты, указанные до вызова команды, уже содержатся в списке. Чтобы добавить объект в список укажите его в Дереве построения или в окне модели.

Тело или поверхность можно указать только в Дереве построения.

Повторное указание объекта удаляет его из списка. Можно также удалить объект, выделив его в списке и нажав кнопку Удалить из списка. Кнопка Указать заново полностью очищает список.

На вкладке Свойства задайте наименование создаваемой коллекции.

Для завершения создания коллекции нажмите кнопку Создать объект на Панели специального управления.

В Дереве построения появится пиктограмма коллекции и ее наименование.

Подробнее о коллекциях...


Команда Контроль столкновений

Позволяет включить или выключить режим контроля соударений при перемещении компонентов.

Для вызова команды нажмите кнопку Включить/выключить контроль соударений на Панели специального управления или выберите ее название в контекстном меню.

Нажатая кнопка означает, что режим контроля соударений включен, отжатая — выключен.

При контроле соударений учитываются только полностью загруженные компоненты.


Цвет текста

Список, позволяющий выбрать цвет символов выделенного или набираемого заново текста.


Плавное изменение цвета (контекстное меню команды Заливка)

Плавное изменение цвета
(контекстное меню команды Заливка)

Позволяет переключать способы переходов цвета заливки: плавного или посредством заданного количества шагов.

Для вызова команды выберите название Плавное изменение цвета из контекстного меню команды Заливка.

После вызова команды слева от названия команды появится «галочка», что свидетельствует о том, что режим плавного изменения цвета включен.

Чтобы отключить режим, вызовите команду повторно — «галочка» исчезнет.

Если «галочка» отсутствует, то переход цвета заливки выполняются в заданное количество шагов, число которых вводится через Панель свойств.


Команда Заливка

Позволяет залить однотонным или изменяющимся цветом одну или несколько областей в текущем виде чертежа или во фрагменте. Возможно построение градиентных заливок шести типов с изменяющимися характеристиками — количеством переходов цвета, углом наклона заливки, сдвигом начала заливки, прозрачностью.

Область заливки может состоять из одного или нескольких замкнутых контуров, в том числе и несвязанных друг с другом.

Для вызова команды нажмите кнопку Заливка на инструментальной панели Геометрия.

Если до вызова команды в документе были выделены объекты, то на экране появляется диалог, содержащий сообщения системы. Содержание сообщений зависит от того, могут ли выделенные объекты быть использованы в качестве границы заливки.

Если они могут быть использованы в качестве границы заливки, то нажатие кнопки Да в диалоге приведет к автоматическому построению заливки с умолчательными значениями параметров. Выделение объектов будет снято. Команда построения заливки останется активной.

Если выделенные объекты не могут быть использованы в качестве границы заливки, то нажатие кнопки Да приведет к снятию выделения с объектов. Команда построения заливки также останется активной.

Если перед вызовом команды объекты не были выделены или необходимо продолжить построение заливки, следует указать точку внутри области, которую нужно залить цветом. Система автоматически определит ближайшие возможные границы, внутри которых указана точка.

Примеры использования заливок

Команды контекстного меню, входящие в группы Добавить границу и Удалить границу, позволяют изменить конфигурацию заливаемой цветом области.

Кнопки Панели специального управления предоставляют дополнительные возможности создания границ заливки.

Кнопка Ручное формирование границ позволяет создать временную ломаную линию, которая будет служить границей заливки.

Кнопка Обход границы по стрелке позволяет сформировать контур, образованный пересекающимися объектами.

При вводе ассоциативной заливки режимы ручного рисования границ и обхода границ по стрелке недоступны.

После задания очередной границы создаваемая заливка изменяет свой вид внутри области в зависимости от выбора типа заливки с учетом ее особенностей.

До фиксации заливки вы можете изменить ее тип и настроить параметры.

Чтобы перенести параметры заливки, ранее построенной в документе, на вновь создаваемую, удобно воспользоваться командой Копировать свойства. После переноса параметры заливки можно отредактировать.

На экране появляется заполненные цветом одна или несколько областей, что позволяет контролировать правильность задания областей и параметров заливки.

Чтобы зафиксировать полученную заливку и перейти к построению следующей, нажмите кнопку Создать объект на Панели специального управления.

Для выхода из команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Все области заливки, созданные в сеансе построения, являются единым объектом, даже если они несмежные. Команды редактирования параметров, удаления и т. п. применяются ко всему объекту.

Смотрите также

Дополнительные переходы цвета и уровни прозрачности заливки

Редактирование заливки

Команда Штриховка

Другие геометрические объекты


Прозрачность (заливки)

Прозрачность
(заливки)

Элемент управления, предназначенный для изменения степени прозрачности выбранного цвета заливки.

Элемент управления принимает различный вид в зависимости от типа заливки, выбранного в списке Тип.

– Если выбран тип — одноцветная, то доступен элемент управления Прозрачность.

– Если выбраны другие типы — линейная, цилиндрическая и др., то доступны элементы управления Начальная прозрачность и Конечная прозрачность.

Если установлена нулевая прозрачность, то заливка считается полностью непрозрачной. Например, если установлена Начальная прозрачность — 0%, то интенсивность цвета заливки соответствует отображенной в поле Цвет 1.

Чтобы увеличить прозрачность каждого цвета, выбранного в поле Цвет, следует передвинуть мышью «ползунок» вправо. В поле будет отображена установленная прозрачность в процентах.

«Ползунок» в правом крайнем положении, например, Конечная прозрачность — 100 %, задает заливку, которая считается полностью прозрачной.

Пример заливки: а) с прозрачностью для всех областей 0%, б) с прозрачностью в области 1 цветов 1 и 2 — 25%
а) | б)

Дополнительные промежуточные уровни прозрачности задаются и отображаются в диалоге расширенного управления заливкой. Начальная и конечная прозрачности также могут быть изменены в этом диалоге. При этом в полях Начальная и Конечная прозрачность на Панели свойств значения изменятся автоматически.

Смотрите также

Дополнительные переходы цвета и уровни прозрачности градиентной заливки


Группа Переходы цвета (заливки)

Группа Переходы цвета
(заливки)

Группа переключателей, позволяющая выбрать способ изменения цвета.

– Если активен переключатель Плавное изменение цвета, то переход цвета выполняется плавно.

– Если активен переключатель Заданное количество шагов, то переходы цвета выполняются в заданное количество шагов. Становится доступно поле для ввода или задания счетчиком количества шагов — от 1 до 255.

Пример изменения цвета цилиндрической заливки: а) плавного, б) с количеством шагов — 6
а) | б)


Сдвиг

Поле для ввода или задания счетчиком относительного смещения начальной точки заливки от центра до стороны габаритного прямоугольника заливки.

Значение может изменяться от -100 до 100%.

Для цилиндрической заливки доступно поле Сдвиг для ввода смещения начальной точки в направлении к начальной или конечной линии заливки (см. рис. 1).

Рис.1. Пример цилиндрической заливки со сдвигом: а) 0%, б) 50%, в) 100%
a) | б) | в)

Для остальных видов заливки доступны поля Сдвиг X и Сдвиг Y.

Если установлено значения 0% Сдвига X (Cдвига Y), то начальная точка лежит на линии, проходящей через центр габаритного прямоугольника (см. рис. 2).

Значение 100% Сдвига X (Cдвига Y) означает, что начальная точка лежит на стороне габаритного прямоугольника.

Рис. 2. Пример радиальной заливки со сдвигом: а) 0%, б) -37% (по оси X) и 67% (по оси Y)
а) | б)

При вводе угла поворота в поле Угол величина сдвига в полях Сдвиг может измениться вследствие изменения размеров и наклона габаритного прямоугольника.

При перемещении точки мышью, также как и при изменении угла поворота, величина сдвига определяется автоматически и заносится в эти поля.

Кроме того, возможен ввод значения сдвига с клавиатуры.

Поля Сдвиг X и Сдвиг Y недоступны для линейной заливки.


Цвет 1 заливки

Позволяет выбрать Цвет заливки (в случае градиентной заливки — Цвет 1).

После щелчка мышью по полю Цвет (Цвет 1) на экране появляется диалог выбора цвета.

Смотрите также

Дополнительные переходы цвета и уровни прозрачности градиентной заливки


Цвет 1 заливки (контекстное меню команды Заливка)

Цвет 1 заливки
(контекстное меню команды Заливка)

Позволяет задать Цвет заливки (в случае градиентной заливки — Цвет 1).

Для вызова команды выберите ее название из контекстного меню команды Заливка. После вызова команды на экране появляется диалог выбора цвета.

Смотрите также

Дополнительные переходы цвета и уровни прозрачности градиентной заливки


Цвет 2 заливки

Позволяет выбрать Цвет 2 градиентной заливки.

После щелчка мышью по полю Цвет 2 на экране появляется диалог выбора цвета.

Смотрите также

Дополнительные переходы цвета и уровни прозрачности градиентной заливки


Цвет 2 заливки (контекстное меню команды Заливка)

Цвет 2 заливки
(контекстное меню команды Заливка)

Позволяет задать Цвет 2 градиентной заливки.

Для вызова команды выберите ее название из контекстного меню команды Заливка. После вызова команды на экране появляется диалог выбора цвета.

Смотрите также

Дополнительные переходы цвета и уровни прозрачности градиентной заливки


Текущая позиция

В этом поле, расположенном на панели Текущее состояние, отображается позиция от начала строки того символа, на котором находится курсор.

Чтобы переместиться на другую позицию в строке, наберите ее номер в этом поле и нажмите клавишу <Enter>.

Если панель Текущее состояние расположена вертикально, то для доступа к полю Текущая позиция нажмите соответствующую кнопку.


Операции со столбцами таблиц

Чтобы выделить текущий столбец таблицы (столбец, в ячейке которого находится курсор), нажмите кнопку Выделить столбец или вызовите команду Таблица — Столбец — Выделить.

Чтобы добавить столбец справа от текущего, нажмите кнопку Вставить столбец справа или вызовите команду Таблица — Столбец — Вставить справа.

Чтобы добавить столбец слева от текущего, нажмите кнопку Вставить столбец слева или вызовите команду Таблица — Столбец — Вставить слева.

Форматирование текста в ячейках новых столбцов совпадает с форматированием текста в соответствующих ячейках исходного столбца.

Чтобы удалить текущий столбец таблицы, нажмите кнопку Удалить столбец или вызовите команду Таблица — Столбец — Удалить.

Команды вставки и удаления столбцов недоступны, если установлена блокировка размеров таблицы.


Команда Добавить ответвления

Позволяет перейти из режима редактирования точек в режим добавления ответвлений объекта оформления (линии-выноски, знака клеймения и т.п.). Для вызова команды нажмите кнопку Добавить ответвления на Панели специального управления. Кнопка остается нажатой — признак того, что режим добавления ответвлений активен.

– При создании объектов оформления режим добавления ответвлений активизируется автоматически после указания точки начала полки. Каждая вновь указанная точка воспринимается системой как начальная точка очередного ответвления.
Чтобы перейти в режим редактирования точек, нажмите кнопку Редактировать точки на Панели специального управления.

– При редактировании объектов автоматически активизируется режим редактирования точек.
Чтобы перейти в режим добавления ответвлений, нажмите кнопку Добавить ответвления на Панели специального управления.


Команда Добавить штрихи

Позволяет перейти из режим редактирования точек в режим добавления штрихов обозначения узла в сечении. Для вызова команды нажмите кнопку Добавить штрихи на Панели специального управления. Кнопка остается нажатой — признак того, что режим добавления штрихов активен.

– При создании обозначения узла в сечении режим добавления штрихов активизируется автоматически после указания точек линии-выноски (т) и (т1). Каждая вновь указанная точка воспринимается системой как точка привязки очередного штриха.

Чтобы перейти в режим редактирования точек, нажмите кнопку Редактировать точки на Панели специального управления.

– При редактировании обозначения узла в сечении автоматически активизируется режим редактирования точек.

Чтобы перейти в режим добавления штрихов, нажмите кнопку Добавить штрихи на Панели специального управления.


Команда Угловой размер от общей базы

Позволяет построить группу угловых размеров с общей базой.

Для вызова команды нажмите кнопку Угловой от общей базы на инструментальной панели Размеры. На Панели свойств появятся элементы управления.

Задайте первую сторону угла, общую для группы создаваемых размеров, и вторую сторону угла для первого размера группы. Для этого укажите прямолинейные объекты или точки, при соединении которых образуются стороны угла. Прямолинейные объекты указываются при нажатой кнопке Выбор базового объекта, а точки — при отжатой.

Подробнее об указании сторон углов...

На Панели свойств отображаются координаты вершины угла, точек привязки т1 и т2.

В поле Текст на вкладке Размер Панели свойств отображается автоматически сформированная размерная надпись. Чтобы вызвать диалог редактирования и настройки размерной надписи, щелкните мышью в этом поле.

В списке Размещение текста отображается текущий способ размещения надписи. Если необходимо, смените способ размещения. Подробнее...

Укажите точку, определяющую положение размерной линии т3. Точка т3 определяет также положение размерной надписи, если выбрано автоматическое, фиксированное или ручное размещение текста.

Если выбрано размещение текста на полке, укажите точку начала полки т4. В этом случае точка т3 является начальной точкой линии-выноски.

Управление ориентацией размера

Последовательно укажите вторые базовые отрезки и точку т3 для остальных размеров группы.

Простановка угловых размеров от общей базы
(способ задания сторон углов — по двум отрезкам)

Выбор вида выносных линий

Настройка параметров размеров (выбор вида стрелки, положения надписи и т.п.).

Группа размеров, построенная с помощью команды Угловой от общей базы, не является единым объектом — это несколько простых угловых размеров, первые стороны углов которых совпадают. Поэтому, если у всех размеров группы должны быть одинаковые параметры (например, стрелки определенного типа), необходимо после настройки первого размера включить опцию По умолчанию на вкладке Параметры.

Для перехода к простановке группы размеров от другой базы нажмите кнопку Указать заново на Панели специального управления и укажите новую сторону угла.

Смотрите также

Особенности использования команды в параметрическом режиме

Другие размеры

Выравнивание размерных линий

Редактирование углового размера с помощью мыши


Команда Линейный размер от общей базы

Позволяет проставить группу линейных размеров от общей базы.

Для вызова команды нажмите кнопку Линейный от общей базы на инструментальной панели Размеры.

Укажите первую точку привязки т1. Она будет общей для группы создаваемых размеров.

Укажите вторую точку привязки т2 для первого размера группы.

Для точного позиционирования курсора воспользуйтесь привязками или меню геометрического калькулятора в полях т1 и т2 на Панели свойств.

На вкладке Размер Панели свойств находится группа переключателей Тип, с помощью которой можно установить ориентацию каждого из создаваемых размеров (вертикальный или горизонтальный).

В поле Текст на вкладке Размер отображается автоматически сформированная размерная надпись. Чтобы вызвать диалог редактирования и настройки размерной надписи, щелкните мышью в этом поле.

В списке Размещение текста отображается текущий способ размещения размерной надписи. Если необходимо, смените способ размещения. Подробнее...

Укажите точку т3, определяющую положение размерной линии и надписи.

Если выбрано размещение текста на полке, то точка т3 является начальной точкой линии-выноски. В этом случае необходимо указать точку начала полки т4.

Последовательно укажите точки т2 и т3 для остальных размеров группы.

Простановка линейного размера от общей базы

Настройка параметров размеров (выбор вида стрелки, положения надписи и т.п.).

Формирование зазора между выносной линией и точкой привязки

Группа размеров, построенная с помощью команды Линейный от общей базы, не является единым объектом — это несколько простых линейных размеров, первые точки привязки которых совпадают. Поэтому, если у всех размеров группы должны быть одинаковые параметры (например, стрелки определенного типа), необходимо после настройки первого размера включить опцию По умолчанию на вкладке Параметры Панели свойств.

Для перехода к простановке группы размеров от другой базы необходимо расфиксировать первую базовую точку (поле т1 на вкладке Размер Панели свойств) и указать ее новое положение.

Смотрите также

Другие размеры

Выравнивание размерных линий


Команда Угловой размер с общей размерной линией

Позволяет построить группу угловых размеров с общей размерной линией.

Для вызова команды нажмите кнопку Угловой с общей размерной линией на инструментальной панели Размеры. На Панели свойств появятся элементы управления.

Задайте первую и вторую стороны угла. Для этого укажите прямолинейные объекты или точки, при соединении которых образуются стороны угла. Прямолинейные объекты указываются при нажатой кнопке Выбор базового объекта, а точки — при отжатой.

Подробнее об указании сторон углов...

На Панели свойств отображаются координаты вершины угла, точек привязки т1 и т2.

Укажите точку, определяющую положение размерной линии т3. Это положение будет одинаковым для всех размеров группы.

Последовательно укажите вторые стороны углов, точку т3 для остальных размеров группы. В качестве вторых сторон можно указать отрезок или точку на стороне угла.

Все отрезки, указываемые для построения углового размера с общей размерной линией, должны проходить через одну точку — центр окружности, содержащей размерные линии. При задании вторых сторон угла точкой это условие выполняется автоматически.

Простановка угловых размеров с общей размерной линией;
(способ задания сторон углов — по трем точкам)

Выбор вида выносных линий

В поле Текст на вкладке Размер Панели свойств отображается автоматически сформированная размерная надпись. Чтобы вызвать диалог редактирования и настройки размерной надписи, щелкните мышью в этом поле.

Настройка параметров размеров

Группа размеров, построенная с помощью команды Угловой с общей размерной линией, не является единым объектом — это цепь угловых размеров с совпадающими первыми сторонами углов и специальным образом расположенными размерными надписями. Поэтому, если у всех размеров группы должны быть одинаковые параметры (например, стрелки определенного типа), необходимо после настройки первого размера включить опцию По умолчанию.

Для создания другой группы размеров с общей размерной линией нажмите кнопку Указать заново на Панели специального управления и укажите новую сторону угла.

Ориентация каждого размера цепи определяется системой автоматически. В группе Тип на вкладке Размер активизируется переключатель, соответствующий этой ориентации.

Смотрите также

Особенности использования команды в параметрическом режиме

Другие размеры

Выравнивание размерных линий

Редактирование углового размера с помощью мыши


Команда Линейный размер с общей размерной линией

Позволяет проставить группу линейных размеров с общей размерной линией.

Для вызова команды нажмите кнопку Линейный с общей размерной линией на инструментальной панели Размеры.

Укажите первую точку привязки т1 для группового размера.

Затем укажите вторую точку привязки т2.

Для точного позиционирования курсора воспользуйтесь привязками или меню геометрического калькулятора в полях т1 и т2 на Панели свойств.

На вкладке Размер Панели свойств находится группа переключателей Тип, с помощью которой можно установить ориентацию группового размера (вертикальный или горизонтальный).

Выбор ориентации возможен только до формирования первого размера группы.

Укажите точку, определяющую положение размерной линии т3. Это положение будет одинаковым для всех размеров группы.

Затем укажите точки т2 для остальных размеров группы.

Простановка линейного размера с общей размерной линией

В поле Текст на вкладке Размер отображается автоматически сформированная размерная надпись. Чтобы вызвать диалог редактирования и настройки размерной надписи, щелкните мышью в этом поле.

Настройка параметров размеров (выбор вида стрелки, включение/отключение отрисовки выносных линий и т.п.).

Формирование зазора между выносной линией и точкой привязки

Группа размеров, построенная с помощью команды Линейный с общей размерной линией, не является единым объектом — это группа линейных размеров с совпадающими первыми точками привязки и специальным образом расположенными размерными надписями. Поэтому, если у всех размеров группы должны быть одинаковые параметры (например, стрелки определенного типа), необходимо после настройки первого размера включить опцию По умолчанию на вкладке Параметры Панели свойств.

Для создания другой группы размеров с общей размерной линией необходимо расфиксировать первую точку привязки группы (поле т1 на вкладке Размер Панели свойств) и указать ее новое положение.

Смотрите также

Другие размеры

Выравнивание размерных линий


Команда Копировать свойства мультилинии

Команда Копировать свойства
 мультилинии

Позволяет скопировать свойства (параметры) ранее построенной мультилинии в создаваемую или редактируемую мультилинию.

Вы можете скопировать из одной мультилинии в другую следующие параметры:

– количество линий и их параметры — стиль и смещение от базовой линии;

– виды ограничителей на концах мультилинии и их параметры — высоту ограничителей и стиль линий.

Чтобы скопировать свойства одной мультилинии в другую, нажмите кнопку Копировать свойства. Кнопка для ее вызова расположена на Панели специального управления.

Команду Копировать свойства можно вызвать и из контекстного меню.

Курсор изменит вид.

Укажите мультилинию — источник свойств, щелкнув по ней мышью в окне документа. Скопированные свойства будут переданы в создаваемую (или редактируемую) мультилинию. Фантом мультилинии изменится соответственно скопированным свойствам.

При необходимости вы можете отредактировать скопированные свойства мультилинии. Подробнее об этом рассказано в разделах:

– Линии мультилинии

– Ограничители мультилинии


Команда Копировать свойства марки/позиционного обозначения

Команда Копировать свойства
 марки/позиционного обозначения

Позволяет копировать текст между марками/позиционными обозначениями, не выходя из процесса их создания или редактирования.

Для вызова команды служит кнопка Копировать свойства на Панели специального управления.

Например, чтобы перенести весь текст из марки на линии в марку с линией-выноской, выполните следующие действия.

1. Находясь в процессе создания или редактирования марки с линией-выноской, нажмите кнопку Копировать свойства.

Курсор изменит вид.

Подведите курсор к марке на линии, текст которой требуется скопировать. Когда марка подсветится, нажмите левую кнопку мыши.

Чтобы поменять объект копирования, необходимо вновь вызвать команду Копировать свойства и указать другой объект.

В поле Текст Панели свойств появится текст над полкой. При необходимости текст можно отредактировать.

2. Вызовите команду Создать объект. Марка с линией-выноской будет иметь скопированный текст.

При копировании свойств между марками без линии-выноски передается также тип формы обозначения.


Ответвления

Группа переключателей, позволяющая выбрать вариант добавления ответвлений к радиальному размеру на полке. Переключатели доступны, если из списка Размещение текста выбран один из вариантов размещения текста размерной надписи на полке.

По умолчанию в группе активизирован переключатель От начала полки. При этом добавляемое ответвление будет отрисовано от начальной точки полки.

Чтобы новое ответвление отрисовывалось от конечной точки полки, активизируйте переключатель От конца полки.

Первое ответвление всегда отрисовывается от начала полки.

Добавление ответвлений возможно только в режиме добавления ответвлений. Для перехода в этот режим нажмите кнопку Добавить ответвления на Панели специального управления.


Сохранять текст

Опция, позволяющая использовать текст текущего обозначения в последующих таких же обозначениях.

Если эта опция включена, то введенный или отредактированный текст будет по умолчанию использоваться в следующих объектах данного типа до конца сеанса КОМПАС-3D.

Если опция Сохранять текст выключена, то следующий объект данного типа формируется без текста.

При редактировании ранее созданных обозначений опция Сохранять текст всегда находится в выключенном состоянии. Чтобы сохранить отредактированный текст для новых обозначений, включите опцию Сохранять текст.

В обозначении узла при включенной опции Сохранять текст производится сохранение текста под полкой.


Команда Свойства компонента

Позволяет изменить свойства компонента модели (в том числе экземпляра массива, библиотечного компонента, компонента компоновочной геометрии):

– отредактировать значения свойств текущей модели, заданные для компонента (можно также внести изменения в список свойств модели),

– изменить цвет и оптические свойства компонента,

– задать параметры компонента для расчета МЦХ модели,

– рассчитать МЦХ компонента (кратко),

– задать параметры штриховки материала для отображения на разрезах/сечениях в ассоциативных видах чертежей,

– изменить размеры компонента с учетом полей допусков (размеры эскизов и размеры операций);

– включить и отключить фиксацию компонента, создание объекта спецификации,

– включить компонент в расчет или исключить его из расчета,

– сменить источник компонента,

– преобразовать правостороннюю систему координат компонента в левостороннюю и наоборот.

Особенности задания свойств материала в модели...

Положение экземпляров массива определяется параметрами копирования, поэтому включение и отключение фиксации для экземпляров недоступно.

Команда Свойства компонента доступна в контекстном меню компонента, выделенного в Дереве построения. Эта команда также может быть вызвана в окне модели:

– из контекстного меню выделенного компонента — в этом случае она позволяет редактировать свойства непосредственно этого компонента,

– из контекстного меню выделенной грани, ребра, вершины — в этом случае команда позволяет редактировать свойства компонента первого уровня, которому принадлежит выделенный объект.

После вызова команды на Панели свойств появятся вкладки, содержащие элементы управления для настройки свойств компонента.

Изменения настроек будут действовать только для той модели и только для тех компонентов, для которых они были сделаны. Вновь добавляемые компоненты (в том числе повторные вставки уже имеющихся компонентов) будут иметь те параметры, которые записаны в их файлах.


Команда Свойства модели

Позволяет изменить свойства детали или сборки:

– отредактировать список системных и дополнительных свойств,

– изменить цвет и оптические свойства,

– задать параметры для расчета МЦХ — материал и плотность материала либо массу и координаты центра масс,

– рассчитать МЦХ модели (кратко),

– задать параметры штриховки материала для отображения на разрезах/сечениях в ассоциативных видах чертежей.

Особенности задания свойств материала в модели...

Команда Свойства модели доступна в контекстном меню корневого объекта Дерева построения и в меню Файл.

После вызова команды на Панели свойств появятся вкладки, содержащие элементы управления для настройки свойств модели.

Элементы управления свойствами детали

Элементы управления свойствами сборки

Изменения настроек будут действовать только для модели, в которой они были сделаны. Во вновь создаваемых моделях объекты будут иметь умолчательные свойства.


Команда Зеркальное отражение компонентов

Позволяет добавить в модель компонент, который является зеркальным отражением или симметричной вставкой исходного.

Для вызова команды нажмите кнопку Зеркальное отражение компонентов на инструментальной панели Редактирование сборки или выберите пункт меню Операции — Зеркальное отражение компонентов.

После вызова команды на Панели свойств появляются элементы управления. Выполните следующие действия.

1. Выберите плоскость симметрии, указав плоский объект — плоскую грань, координатную или вспомогательную плоскость. Плоская грань может быть указана только в окне модели, а остальные объекты — как в окне модели, так и в Дереве построения. Выбранная плоскость симметрии подсвечивается.

2. Выберите исходные компоненты. Для этого укажите компоненты или принадлежащие им объекты в Дереве построения или в окне модели. Выбранные компоненты выделяются цветом, их перечень отображается на панели Список объектов. В окне модели появляются фантомы добавляемых компонентов.

Если исходный компонент в свою очередь содержит компоненты, то построение выполняется для всех этих компонентов, однако на панели Список объектов отображается только сам исходный компонент.

Исходные компоненты можно выбрать и перед вызовом команды зеркального отражения, указав компоненты (принадлежащие им объекты) в Дереве построения или в окне модели.

Если среди указанных объектов есть вспомогательные плоскости, то первая из них становится плоскостью симметрии операции.

При необходимости вы можете удалить компонент из списка исходных, выделив его на панели Список объектов и нажав кнопку Удалить на этой панели. Исключение компонента из списка происходит и в том случае, если вы повторно укажете его в Дереве построения или в окне модели.

3. С помощью переключателей группы Режим укажите, требуется ли оставлять исходные компоненты после выполнения команды или нет.

4. Настройте параметры вставки компонентов. Для этого нажмите кнопку Продолжить зеркальное отражение на Панели специального управления. На экране появится диалог Параметры зеркального отражения компонентов, а элементы выбора объектов на Панели свойств перестанут отображаться.

Подробнее о настройке параметров вставки компонентов

5. При необходимости вы можете вернуться к выбору объектов. Для этого в диалоге Параметры зеркального отражения компонентов нажмите кнопку Выбор объектов.... Диалог закроется, на Панели свойств появятся элементы управления.

Измените набор выбранных компонентов и нажмите кнопку Продолжить зеркальное отражение. Диалог настройки параметров отражения вновь появится на экране.

6. Для завершения добавления компонентов нажмите кнопку Создать объект на Панели специального управления или закройте диалог, нажав кнопку ОК. В Дереве построения модели появятся добавленные компоненты.

Кнопки Прервать команду на Панели специального управления и Отмена в диалоге позволяют завершить операцию без создания компонентов.

При отражении компонентов не учитываются операции, произведенные над компонентами в сборочной модели. Вы можете получить эти операции с помощью команд построения массивов или выполнить их повторно.


Выносная линия 1

Переключатель, управляющий отрисовкой выносной линии первого объекта условного пересечения.

Чтобы включить или отключить создание выносной линии, нажмите кнопку-переключатель.


Выносная линия 2

Переключатель, управляющий отрисовкой выносной линии второго объекта условного пересечения.

Чтобы включить или отключить создание выносной линии, нажмите кнопку-переключатель.


По умолчанию

Опция, включение которой означает, что все текущие настройки будут использоваться при создании следующих условных пересечений до конца сеанса работы. При выключенной опции настройка распространяется только на текущее (создаваемое) пересечение.


Отрисовывать точку

Позволяет управлять созданием точки в обозначении условного пересечения.

При включенной опции на продолжении выносных линий указанных объектов создается точка.

Если опция выключена, то точка не создается.

Выберите из раскрывающегося списка стиль отрисовки точки.


Стиль точки

Список, из которого можно выбрать текущий стиль отрисовки точки пересечения выносных линий.


Команда Условное пересечение

Позволяет построить условное пересечение объектов — обозначение, представляющее собой пересечение продолжения объекта с другим объектом или его продолжением. Продолжения объектов отображаются выносными линиями. На пересечении выносной линии с объектом или другой выносной линией создается точка.

Объектами являются отрезки, дуги окружностей и эллипсов, а также эквидистанты отрезков и дуг окружностей. Объекты могут входить в состав макроэлементов, вставок фрагментов и видов.

Условное пересечение: a) для продолжений двух объектов; б) для объекта и продолжения другого объекта
а) | б)

Для вызова команды нажмите кнопку Условное пересечение на инструментальной панели Обозначения или выберите ее название из меню Инструменты — Обозначения.

Укажите курсором первый, а затем второй объект ближе к той его конечной точке, от которой следует построить его продолжение. Фиксация курсора выполняется нажатием левой кнопки мыши или клавиши <Enter>.

При попадании второго объекта в «ловушку» курсора на экране появляется фантом условного пересечения. Это происходит, если для данной пары объектов существует хотя бы один вариант построения.

Если точек пересечения несколько, то для отображения другого варианта фантома подведите курсор, не фиксируя его, ближе к другой конечной точки объекта. После появления фантома в нужной точке зафиксируйте курсор.

Настройка параметров условного пересечения

Если вы случайно ошиблись при выборе объекта, нажмите кнопку Указать заново на Панели специального управления и выберите новый объект.

За один вызов команды вы можете построить несколько условных пересечений, указывая попарно объекты.

По умолчанию созданные условные пересечения никак не связаны с объектами, указанными в ходе выполнения команды, и могут редактироваться отдельно.

Условное пересечение усекаемых объектов может быть создано в командах Фаска или Скругление. Также вы можете задать координаты объектов при помощи команды Условное пересечение, вызываемой из меню геометрического калькулятора.

Смотрите также

Другие обозначения


Команда Коническая кривая

Позволяет построить кривую конического сечения.

Пример

Для вызова команды нажмите кнопку Коническая кривая на инструментальной панели Геометрия.

Укажите начальную и конечную точки кривой т1 и т2. Каждую точку можно указать одним из следующих способов.

– Укажите точку мышью в окне документа или введите значения координат с клавиатуры.

– Выберите объект в документе (отрезок, дугу, сплайн и пр.) и укажите точку на нем. Если необходимо временно отключить привязки при выборе объекта, нажмите и удерживайте <Alt>. Используя этот способ, вы одновременно указываете точку конической кривой и касательную к кривой в этой точке.

Если вы случайно ошиблись при выборе объекта, нажмите кнопку Указать заново, а затем укажите курсором новый объект.

На экране отображаются фантомы: фантом конической кривой и фантомы касательных к ней в точках т1 и т2, пересекающиеся в точке т3.

Если касательные к конической кривой в точках т1 и т2 определены (перед указанием точек т1 и т2 были выбраны объекты и точки указаны на них), то точка т3 определяется и фиксируется автоматически.

Если касательные к конической кривой в точках т1 и т2 не заданы, точка их пересечения т3 не зафиксирована. Укажите положение точки пересечения касательных т3. Это можно сделать следующими способами.

– Укажите точку в окне документа или введите ее координаты с клавиатуры. Углы наклона касательных к конической кривой в точках т1 и т2 определяются автоматически. Углы отсчитываются от оси абсцисс текущей системы координат.

– Введите значения углов наклонов касательных в поля Угол1 и Угол2 на Панели свойств. Положение точки т3 определяется автоматически.

Форма кривой определяется положением точки т4 на кривой либо значением параметра коэффициент/высота.

Укажите точку т4, через которую должна пройти коническая кривая, или задайте значение параметра коэффициент/высота, активизировав соответствующий переключатель на Панели свойств либо используя одноименные команды контекстного меню.

Параметр коэффициент может принимать значения в диапазоне 0,0001–0,9999. Значение связанного с ним параметра высота должно обеспечивать значение параметра коэффициент в указанных пределах.

Для точного позиционирования курсора воспользуйтесь привязками или меню геометрического калькулятора в полях т1, т2, т3, т4 на Панели свойств.

Для снятия значений угловых параметров с уже существующих объектов используйте геометрический калькулятор в полях Угол1 и Угол2 на Панели свойств.

Выбор стиля линии

Построенная коническая кривая остается незафиксированной в документе, что позволяет изменять ее параметры. Для фиксации кривой следует нажать кнопку Создать объект.

За один вызов команды можно построить произвольное количество конических кривых.

Для выхода из команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Подробнее о построении конической кривой...


Параметр конической кривой

Группа переключателей, позволяющая выбрать текущий способ задания параметра конической кривой — коэффициент или высоту.

При активном переключателе Коэффициент на Панели свойств находится поле значения коэффициента, при активном переключателе Высота — поле значения высоты.

Вместо переключателей можно использовать одноименные им команды контекстного меню.

Обратите внимание на то, что поле значения параметра доступно для ввода, если определены начальная и конечная точки конической кривой и точка пересечения касательных к кривой в этих точках.

При смене способа задания параметра происходит пересчет значения одного параметра конической кривой в значение другого.


Поле Зазор/длина

Поле для ввода или задания счетчиком значения длины или зазора выносных линий условного пересечения. Допускаются только целые значения длины (зазора).

При нулевом значении или значении, превышающем расстояние от объекта до точки пересечения, выносные линии строятся от конечных точек объектов до точки пересечения.


Зазор/длина

Группа переключателей позволяет выбрать способ формирования зазора между объектом и выносной линией условного пересечения.

Отрисовка выносных линий при задании ненулевого значения: a) зазора; б) длины
а) | б)

Если требуется, чтобы заданное число определяло зазор между конечной точкой объекта и началом выносной линии, активизируйте переключатель Зазор (рис. а).

Если же введенное значение должно определять длину выносной линии, активизируйте переключатель Длина (рис. б).

В поле параметра введите или задайте счетчиком значения длины или зазора. Допускаются только целые значения длины (зазора). При нулевом значении или значении, превышающем расстояние от объекта до точки т1, выносные линии строятся от конечных точек объектов до точки пересечения т1.


Непрерывный ввод объектов

Переключатель, позволяющий указать, требуется ли создание отдельных объектов или их последовательности.

Если переключатель Непрерывный ввод объектов активен, то начальная точка каждого следующего объекта линии совпадает с конечной точкой предыдущего.

Чтобы задавать начальные точки объектов произвольно, и создавать, таким образом, отдельные объекты вместо последовательности, отключите переключатель Непрерывный ввод объектов.


Команда Непрерывный ввод объектов

Позволяет построить последовательность отрезков, дуг и сплайнов.

Для вызова команды нажмите кнопку Непрерывный ввод объектов на инструментальной панели Геометрия.

При вводе конечная точка созданного объекта автоматически становится начальной точкой следующего объекта. Использовать эту команду удобно, например, при построении контура детали, состоящего из объектов различного типа.

Построенная последовательность не является единым объектом. Сегменты линии будут выделяться, редактироваться и удаляться по отдельности.

После вызова команды на Панели свойств отображается группа Тип, содержащая переключатели, позволяющие указать, каким именно геометрическим объектом должен являться текущий (создаваемый) сегмент:

– отрезок,

– параллельный отрезок,

– перпендикулярный отрезок,

– касательный отрезок,

– дуга по трем точкам,

– сопряженная дуга,

– сплайн,

– NURBS-кривая.

По умолчанию при первом обращении к команде текущий тип объекта — Отрезок. Это означает, что при указании точек в поле чертежа будет построена проходящая через них последовательность отрезков.

В любой момент ввода последовательности вы можете изменить текущий тип объекта или способ его построения. Для этого активизируйте нужный переключатель в группе Тип.

Способы построения различных объектов при непрерывном вводе, а также приемы управления их параметрами соответствуют способам и приемам построения отдельных объектов.

Последовательность геометрических объектов

Выбор стиля линии

На Панели свойств имеются также элементы Замкнуть и Новый ввод.

После вызова команды Замкнуть автоматически создается точка, совпадающая с первой точкой последовательности объектов, и построение последовательности завершается. Автоматически введенная точка принадлежит тому типу объекта, построение которого было включено в момент замыкания. Если количество уже введенных точек объекта недостаточно для автоматического построения объекта, замыкающего последовательность, то элемент Замкнуть недоступен. После замыкания введенной последовательности система ожидает ввода новой непрерывной последовательности объектов.

После вызова команды Новый ввод построение последовательности завершается без замыкания, и система ожидает ввода новой непрерывной последовательности объектов.

Для выхода из команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие геометрические объекты


Команда Контур

Позволяет построить контур из уже существующих объектов — пространственных кривых, ребер или линий эскиза.

Пример

Для вызова команды нажмите кнопку Контур на панели Пространственные кривые или выберите название из меню Операции — Пространственные кривые. Команда доступна, если в документе есть хотя бы одна кривая, поверхность, тело или эскиз.

Укажите объекты, из которых состоит контур выбранного типа — кривые, линии эскиза, ребра тел или поверхностей, другие ранее построенные контуры.

При указании должно выполняться условие непрерывности создаваемого контура и отсутствия самопересечений.

При необходимости задайте тип контура с помощью группы переключателей Тип.

Выбор объектов в окне модели

Объекты могут быть выделены до вызова команды.

На экране появляется фантом контура. Начальная вершина контура отмечена стрелкой.

Повторное указание объекта отменяет его выбор, а также выбор всех следующих за ним объектов в направлении конечной вершины контура.

Если требуется сменить начальную вершину контура, используйте группу переключателей Начальная/Конечная вершина.

Чтобы построить скругления в местах соединения сегментов контура, активизируйте переключатель Обход скруглением в группе Обход углов на Панели свойств. Задайте значения радиусов на вкладках Параметры и (при необходимости) Переменный радиус.
Построение контура со скруглениями

Чтобы построить контур со смещением от указанных кривых, нажмите кнопку Эквидистанта кривой на Панели специального управления. Система переходит в процесс создания эквидистантной кривой.
Построение контура по эквидистанте

Чтобы сменить объекты, используемые для построения контура, нажмите кнопку Указать заново на Панели специального управления и повторите выбор объектов.

При необходимости вы можете назначить допуски на значения параметров операции, выраженных в линейных или угловых величинах. Для этого используйте кнопку Назначить допуск, расположенную на Панели свойств рядом с полем числового параметра операции.
Подробнее о допусках...
Подробнее о назначении допуска...

Элементы управления, расположенные на вкладке Свойства Панели свойств, позволяют изменить название и цвет кривой, настроить параметры ее отображения.

Чтобы завершить построение, нажмите кнопку Создать объект на Панели специального управления.

Созданный контур появится в окне модели, а его пиктограмма — в Дереве построения.

Обратите внимание на то, что контур ассоциативно связан с объектами, по которым он был построен, благодаря чему при изменении формы этих объектов меняется и форма контура.

Смотрите также

Особенности задания числовых параметров операции в полях Панели свойств


Команда Построение контура для сечения

Позволяет построить контур, который будет использоваться в качестве сечения при выполнении операции выдавливания или вращения.

Для вызова команды нажмите кнопку Контур на Панели специального управления. Команда доступна также в контекстном меню окна модели.

После вызова команды запускается операция создания контура. Укажите объекты, входящие в контур: ребра, пространственные кривые, линии эскиза (они должны быть созданы заранее).

Затем нажмите кнопку Создать объект.

Система вернется в процесс операции выдавливания или вращения.

Построенный контур появится в Дереве построения перед текущей операцией как самостоятельный объект и будет автоматически выбран в качестве сечения.

Контур, создаваемый в процессе выполнения операции выдавливания или вращения, ничем не отличается от контура, создаваемого командой Контур.


Построение дуги по трем точкам при непрерывном вводе

Построение дуги по трем точкам
при непрерывном вводе

Чтобы добавить дугу по трем точкам в последовательность объектов, нажмите соответствующую кнопку в группе Тип на Панели свойств или вызовите из контекстного меню команду Дуга по трем точкам.

Если создаваемая дуга — первый сегмент последовательности, укажите ее начальную точку т1.

Если создаваемая дуга — не первый сегмент последовательности, точка т1 совпадает с конечной точкой предыдущего сегмента.

Укажите точку на дуге т2 и конечную точку дуги т3.

Для точного позиционирования курсора воспользуйтесь привязками или меню геометрического калькулятора в полях Панели свойств.

Выбор стиля линии


Режим обхода границы по стрелке

Обход границы по стрелке — задание границы области для выполнения какой-либо операции (например, для штрихования области или создания контура), последовательным обходом пересекающиеся между собой геометрических объектов.

Для перехода в режим обхода границы по стрелке служит кнопка Обход границы по стрелке на Панели специального управления.

Укажите курсором точку вблизи геометрического объекта, с которого требуется начать обход контура.

На экране появится фантомное изображение первого участка контура (поверх базового элемента), а также стрелка, указывающая предложенное системой направление дальнейшего движения.

Оно определяется следующим образом. Из указанной точки строится вектор, направленный к объекту и лежащий на перпендикуляре к нему, опущенном из этой точки. Обход контура начинается в правую сторону от полученного вектора (см. рисунок).

Зависимость направления обхода контура от точки указания первого объекта

Для задания дальнейшего направления щелкайте мышью на нужных объектах. Чтобы подтвердить предложенное системой направление, щелкните на стрелке.

Выбор направления обхода и перемещение по сегментам контура возможны с помощью кнопок на Панели специального управления, а также клавиатурных комбинаций.

Группа переключателей Способ прохода узлов позволяет указать, каким образом проходить неветвящиеся узлы контура — узлы, в которых направление дальнейшего движения всего одно (то есть в узле нет разветвлений). По умолчанию используется автоматическая обработка таких узлов (без запроса на выбор дальнейшего движения).

Чтобы отказаться от продолжения обхода и начать формирование контура заново, нажмите кнопку Повторный выбор объекта, а затем укажите нужный объект.

Для подтверждения построенной границы нажмите кнопку Создать объект на Панели специального управления.

Для отказа от формирования границы нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.


Построение сопряженной дуги при непрерывном вводе

Построение сопряженной дуги
при непрерывном вводе

Чтобы добавить сопряженную дугу в последовательность объектов, нажмите соответствующую кнопку в группе Тип на Панели свойств или вызовите из контекстного меню команду Сопряженная дуга.

Если создаваемая дуга — первый сегмент последовательности, укажите объект для сопряжения и точку т1, принадлежащую дуге.

Если создаваемая дуга — не первый сегмент последовательности, она сопрягается с предыдущим сегментом, а точка т1 совпадает с конечной точкой этого сегмента.

Если необходимо, введите точное значение радиуса или диаметра в соответствующее поле на Панели свойств.

Укажите конечную точку дуги т2.

Для точного позиционирования курсора воспользуйтесь привязками или меню геометрического калькулятора в полях Панели свойств.

Выбор стиля линии


Построение отрезка при непрерывном вводе

Чтобы добавить отрезок в последовательность объектов, нажмите соответствующую кнопку в группе Тип на Панели свойств или вызовите из контекстного меню команду Отрезок.

Если создаваемый отрезок — первый сегмент последовательности, укажите его начальную точку т1.

Если создаваемый отрезок — не первый сегмент последовательности, его начальная точка совпадает с конечной точкой предыдущего сегмента.

Укажите конечную точку отрезка т2.

При этом длина и угол наклона отрезка будут определены автоматически.

Если необходимо, вы можете ввести длину и угол наклона в соответствующие поля на Панели свойств. В этом случае положение точки т2 будет определено автоматически.

Выбор стиля линии


Построение NURBS при непрерывном вводе

Чтобы добавить NURBS в последовательность объектов, нажмите соответствующую кнопку в группе Тип на Панели свойств или выберите из контекстного меню команду NURBS.

Если создаваемый NURBS — первый сегмент последовательности, укажите его начальную точку.

Если создаваемый NURBS — не первый сегмент последовательности, его начальная точка совпадает с конечной точкой предыдущего сегмента.

Указывайте опорные точки NURBS.

Для точного позиционирования курсора воспользуйтесь привязками или меню геометрического калькулятора для поля т на Панели свойств.

В полях Панели свойств можно задать характеристики кривой — вес каждой характерной точки и порядок.

Выбор стиля линии


Построение параллельного отрезка при непрерывном вводе

Построение параллельного отрезка
при непрерывном вводе

Чтобы добавить параллельный отрезок в последовательность объектов, нажмите соответствующую кнопку в группе Тип на Панели свойств или вызовите из контекстного меню команду Параллельный отрезок.

Укажите прямолинейный объект, которому должен быть параллелен отрезок.

Если создаваемый отрезок — первый сегмент последовательности, укажите его начальную точку т1.

Если создаваемый отрезок — не первый сегмент последовательности, его начальная точка совпадает с конечной точкой предыдущего сегмента.

Укажите конечную точку отрезка т2.

При этом длина отрезка будет определена автоматически.

Если необходимо, вы можете ввести длину в соответствующее поле на Панели свойств. В этом случае положение точки т2 будет определено автоматически.

Выбор стиля линии


Построение перпендикулярного отрезка при непрерывном вводе

Построение перпендикулярного отрезка
при непрерывном вводе

Чтобы добавить перпендикулярный отрезок в последовательность объектов, нажмите соответствующую кнопку в группе Тип на Панели свойств или вызовите из контекстного меню команду Перпендикулярный отрезок.

Укажите объект, которому должен быть перпендикулярен отрезок.

Если создаваемый отрезок — первый сегмент последовательности, укажите его начальную точку т1.

Если создаваемый отрезок — не первый сегмент последовательности, его начальная точка совпадает с конечной точкой предыдущего сегмента.

Укажите конечную точку отрезка т2.

При этом длина отрезка будет определена автоматически.

Если необходимо, вы можете ввести длину в соответствующее поле на Панели свойств. В этом случае положение точки т2 будет определено автоматически.

Выбор стиля линии


Команда Новый ввод (меню непрерывного ввода объектов)

Команда Новый ввод
(меню непрерывного ввода объектов)

Позволяет завершить текущее построение последовательности без замыкания.

После выполнения команды система ожидает ввода новой непрерывной последовательности объектов.


Построение сплайна при непрерывном вводе

Чтобы добавить сплайн в последовательность объектов, нажмите соответствующую кнопку в группе Тип на Панели свойств или выберите из контекстного меню команду Сплайн.

Если создаваемый сплайн — первый сегмент последовательности, укажите его начальную точку.

Если создаваемый сплайн — не первый сегмент последовательности, его начальная точка совпадает с конечной точкой предыдущего сегмента.

Указывайте точки, через которые должен пройти сплайн.

Для точного позиционирования курсора воспользуйтесь привязками или меню геометрического калькулятора для поля т на Панели свойств.

Выбор стиля линии


Построение касательного отрезка при непрерывном вводе

Построение касательного отрезка
при непрерывном вводе

Чтобы добавить касательный отрезок в последовательность объектов, нажмите соответствующую кнопку в группе Тип на Панели свойств или вызовите из контекстного меню команду Касательный отрезок.

Укажите объект, которого должен касаться отрезок.

Если создаваемый отрезок — первый сегмент последовательности, укажите его начальную точку т1.

Если создаваемый отрезок — не первый сегмент последовательности, его начальная точка совпадает с конечной точкой предыдущего сегмента.

Укажите курсором нужный фантом и нажмите кнопку Создать объект на Панели специального управления.

Конечная точка отрезка т2 по умолчанию совпадает с точкой касания; длина отрезка определяется автоматически.

Если необходимо, вы можете ввести длину в соответствующее поле на Панели свойств. В этом случае положение точки т2 будет определено автоматически.

Выбор стиля линии


Команда Замкнуть контур (меню непрерывного ввода объектов)

Команда Замкнуть контур
(меню непрерывного ввода объектов)

Позволяет замкнуть создаваемую последовательность объектов, соединяя точку, введенную последней, с начальной точкой последовательности.


Команда Преобразовать в NURBS

Позволяет преобразовать геометрический объект или текст, написанный TrueType-шрифтом, в NURBS.

Для вызова команды нажмите кнопку Преобразовать в NURBS на инструментальной панели Редактирование.

Такое преобразование может потребоваться для последующего гибкого редактирования объекта перемещением его характерных точек.

Задайте тип кривой, в которую нужно преобразовать объект. Для этого на Панели свойств из списка Тип кривой выберите нужный тип кривой — Сплайн по полюсам или NURBS-кривая по точкам.

Если выполняется преобразование в NURBS-кривую по точкам, необходимо задать способ аппроксимации. Для этого на Панели свойств из списка Аппроксимация кривой выберите нужный способ аппроксимации — Аппроксимация по стрелке прогиба или Аппроксимация по углу касательной. Введите значение точности аппроксимации в поле Шаг аппроксимации на Панели свойств.

Укажите курсором объекты для преобразования.

Группа переключателей Режим на Панели свойств позволяет указать, требуется ли оставлять или удалять исходные объекты после выполнения операции.

За один вызов команды вы можете преобразовать в NURBS произвольное количество объектов.

Для завершения команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Обратите внимание на следующие особенности работы команды Преобразовать в NURBS:

– Некоторые объекты невозможно преобразовать в один NURBS без кратных точек. Результатом преобразования таких объектов является контур, состоящий из нескольких NURBS без кратных точек.

– Преобразование невозможно в том случае, когда исходный объект и кривая, в которую он преобразуется, являются кривой одного и того же типа.

– В некоторых случаях преобразование текста в NURBS может выполняться некорректно, на экране появляется сообщение Преобразование текста выполнено не полностью. Ошибка преобразования может вызываться различными причинами, например, особенностями используемого шрифта. Чтобы устранить ошибку, целесообразно выбрать для текста другой шрифт.

– Результат преобразования текстов в кривые NURBS зависит от типа используемого шрифта. Так, при обработке TrueType-шрифтов создаются контуры букв (рис. 1), а при обработке векторных шрифтов — наборы отрезков (рис. 2).

Смотрите также

Другие команды редактирования


Команда Сплайн по объектам

Позволяет построить сплайн, повторяющий форму объекта (или объектов) модели.

В качестве исходных объектов могут использоваться пространственные кривые, ребра тел и поверхностей, кривые эскиза.

– Если исходные объекты образуют цепочку и гладко состыкованы, то создается один сплайн.

– Если исходные объекты не гладко состыкованы или не образуют цепочку, то создается несколько отдельных сплайнов.

Сплайн, построенный по исходным объектам, не отличается от сплайна, построенного с помощью команды Сплайн. Поэтому для редактирования созданного сплайна могут использоваться типовые приемы редактирования сплайна.

Для вызова команды нажмите кнопку Сплайн по объектам на инструментальной панели Пространственные кривые или выберите ее название из меню Операции — Пространственные кривые.

Укажите исходные объекты для создания сплайна в окне модели. Пространственные кривые можно указать в Дереве построения.

Выбор объектов в окне модели

Выбор объектов в Дереве построения

Исходные объекты могут быть выделены и перед вызовом команды.

Повторное указание объекта отменяет его выбор.

Переключатели группы Режим позволяют указать, требуется ли оставлять исходные объекты после выполнения команды или нет.

Элементы управления, расположенные на вкладке Свойства Панели свойств, позволяют изменить название и цвет сплайна, настроить параметры его отображения. Также на этой вкладке отображается название системы координат сплайна.

Чтобы завершить построение, нажмите кнопку Создать объект на Панели специального управления.

– Если выбран режим построения сплайна без удаления исходных объектов, в окне модели появляется созданный сплайн, а в Дереве построения — пиктограмма сплайна.

– Если выбран режим построения сплайна с удалением исходных объектов, на экране появляется диалог удаления объектов. Диалог позволяет просмотреть удаляемые объекты модели. Вы можете отказаться от удаления или подтвердить его.

• В случае отказа от удаления: в окне модели появляется сплайн, исходные объекты остаются.

• В случае подтверждения удаления: в окне модели появляется сплайн, исходные объекты исчезают.

Обратите внимание на то, связь между сплайном и указанным объектом не формируется, т.е. удаление или редактирование объекта не влияет на созданный сплайн.

Объекты, принадлежащие компонентам модели, нельзя удалить при редактировании этой модели. Поэтому, если для построения сплайна выбираются объекты компонентов, то после нажатия кнопки Создать объект сплайн создается, а на экране появляется сообщение о том, что удаление выбранных объектов невозможно.


Команда Массив по концентрической сетке

Позволяет создать массив, экземпляры которого располагаются в узлах концентрической сетки.

Схема построения массива...

Пример

1. Вызовите команду Массив по концентрической сетке.

2. Укажите в Дереве построения или в окне модели копируемые объекты.

Подробнее о выборе копируемых объектов...

На экране появляется фантом базовой точки копируемого объекта в виде трех взаимно перпендикулярных векторов.

3. Перейдите на вкладку Параметры Панели свойств.

4. Задайте ось массива. Для этого активизируйте переключатель Ось на Панели свойств и укажите нужный объект-ось в окне модели — прямолинейный объект или поверхность вращения (кроме сферы).

На экране появляются фантом массива и стрелки, показывающие направление добавления экземпляров относительно копируемых элементов. Cетка строится с умолчательными параметрами.

5. Задайте параметры сетки в кольцевом направлении.

– Ведите в поле N 2 количество экземпляров в кольцевом направлении.

– Введите в поле Шаг 2 угловой шаг между экземплярами в кольцевом направлении.

– В группе Режим 2 активизируйте переключатель, соответствующий введенному значению шага.

– С помощью переключателей группы Направление выберите направление добавления экземпляров относительно копируемых элементов — Прямое направление или Обратное направление. Направление, соответствующее активному в данный момент переключателю, показано на экране стрелками.

Подробнее о задании параметров сетки в кольцевом направлении...

6. Задайте параметры сетки в радиальном направлении.

– Ведите в поле N 1 количество экземпляров в радиальном направлении.

– Введите в поле Шаг 1 шаг между копиями в радиальном направлении.

– В группе Режим 1 активизируйте переключатель, соответствующий введенному значению шага.

– С помощью переключателей группы Направление выберите направление добавления экземпляров относительно копируемых элементов — Прямое направление (от центра сетки) или Обратное направление (к центру).

Подробнее о задании параметров сетки в радиальном направлении...

Для задания параметров сетки массива можно использовать характерные точки.

7. Выберите ориентацию экземпляров массива. Для этого в группе Ориентация активизируйте нужный переключатель.

Подробнее об ориентации экземпляров...

Все сделанные изменения отображаются на фантоме массива.

8. При необходимости используйте следующие возможности:

– Сдвиг экземпляров вдоль оси массива.
Для этого задайте значение шага в поле Шаг по оси. Подробнее...

– Изменение положения экземпляров массива относительно базового экземпляра.
Для этого включите опцию Базовый экземпляр и введите в поля Номер 1 и Номер 2 нужные номера базового экземпляра по осям сетки или задайте их счетчиком. Подробнее...

– Изменение варианта размещения копий в списке Схема. Подробнее...

– Смена положения базовой точки базового экземпляра. Подробнее...

– Отключение использования проекции базовой точки копируемого объекта — доступно, если копируются тела/поверхности вращения. Для этого отключите опцию На оси вращения. Подробнее...

– Построение геометрического массива — доступно, если копируются операции.
Для этого включите опцию Геометрический массив. Подробнее...

– Удаление или восстановление экземпляров массива.
Для этого активизируйте вкладку Экземпляры Панели свойств. В группе Режим активизируйте переключатель Удалить/восстановить. Затем в окне модели установите курсор на характерной точке того экземпляра массива, который требуется удалить или восстановить. Когда рядом с курсором появится надпись «Удалить/восстановить экземпляр», щелкните левой кнопкой мыши. Подробнее...

– Управление формой и размерами экземпляров путем изменения значений переменных. Доступны следующие способы.

• Использование Таблицы изменяемых переменных
Нажмите кнопку Таблица изменяемых переменных на Панели специального управления или выберите ее название из контекстного меню. На экране появляется окно Таблица изменяемых переменных, позволяющее задавать новые значения переменных для экземпляров. Подробнее...

• Изменение значений размеров экземпляров
Раскройте вкладку Экземпляры Панели свойств. В группе Режим активизируйте переключатель Редактировать размеры. На панели Список экземпляров выберите нужный экземпляр. На панели Список объектов выберите объект, размеры которого требуется изменить. В окне модели появятся размеры данного объекта для выбранного экземпляра. Отредактируйте значения размеров. Подробнее...

Для геометрического массива (см. выше) данные способы управления формой и размерами экземпляров недоступны.

– Назначение допусков на значения параметров операции, выраженных в линейных или угловых величинах. Для этого используйте кнопку Назначить допуск, расположенную на Панели свойств рядом с полем числового параметра операции.
Подробнее о допусках...
Подробнее о назначении допуска...

– Задание области применения операции (только для массива произвольных объектов). Подробнее...

– Изменение наименования массива и свойств поверхности экземпляров.
Для этого активизируйте вкладку Свойства Панели свойств.

– Отмена выбора всех объектов на текущей вкладке Панели свойств.
Для этого нажмите кнопку Указать заново на Панели специального управления.

– Включение/отключение отображения фантома массива на экране. Для этого служит кнопка Показать фантом на Панели специального управления. Подробнее...

9. Подтвердите создание массива, нажав кнопку Создать объект на Панели специального управления.

Прервать создание массива можно, нажав кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Каждый экземпляр массива операций наследует область применения своего исходного элемента.

Смотрите также

Базовая точка экземпляра массива

Разрушение массивов

Другие команды построения массивов

Особенности задания числовых параметров операции в полях Панели свойств


Команда Массив вдоль кривой

Позволяет создать массив, экземпляры которого располагаются вдоль указанной кривой. В качестве этой кривой можно использовать:

– пространственную кривую,

– ребро,

– линию эскиза,

– цепочку вышеперечисленных объектов в любом сочетании.

Схема образования массива...

Пример

Чтобы построить массив вдоль кривой, выполните следующие действия.

1. Вызовите команду Массив вдоль кривой.

2. Укажите в Дереве построения или в окне модели копируемые объекты.

Подробнее о выборе копируемых объектов...

На экране появляется фантом базовой точки копируемого объекта в виде трех взаимно перпендикулярных векторов.

3. Перейдите на вкладку Параметры Панели свойств.

4. Задайте кривую для построения массива. Для этого активизируйте переключатель Кривая и укажите нужный объект или объекты в Дереве построения или в окне модели.

По умолчанию в качестве базовой точки базового экземпляра используется начальная точка указанной кривой (крайняя точка кривой, ближайшая к копируемому объекту).

На экране появляется фантом создаваемого массива. Начальная точка указанной кривой выделена.

5. Введите в поле Количество количество копий.

6. Задайте шаг копирования.

Выберите способ задания шага копирования с помощью переключателей группы Способ — По шагу или Вдоль всей направляющей.

Подробнее о задании шага копирования...

7. С помощью переключателей группы Направление смените направление копирования вдоль траектории, предложенное системой.

Подробнее о направлении копирования...

8. Выберите ориентацию экземпляров массива с помощью переключателей группы Ориентация.

Подробнее об ориентации экземпляров...

9. При необходимости используйте следующие возможности:

– Задание начальной точки кривой вручную (для замкнутой кривой).
Для этого активизируйте переключатель Начальная точка на Панели свойств и укажите нужную точку на траектории или ее вершину.

– Смена положения базовой точки базового экземпляра. Подробнее...

– Отключение использования проекции базовой точки копируемого объекта — доступно, если копируются тела/поверхности вращения. Для этого отключите опцию На оси вращения. Подробнее...

– Построение геометрического массива — доступно, если копируются операции.
Для этого включите опцию Геометрический массив. Подробнее...

– Удаление или восстановление экземпляров массива.
Для этого активизируйте вкладку Экземпляры Панели свойств. В группе Режим активизируйте переключатель Удалить/восстановить. Затем в окне модели установите курсор на характерной точке того экземпляра массива, который требуется удалить или восстановить. Когда рядом с курсором появится надпись «Удалить/восстановить экземпляр», щелкните левой кнопкой мыши. Подробнее...

– Управление формой и размерами экземпляров путем изменения значений переменных. Доступны следующие способы.

• Использование Таблицы изменяемых переменных
Нажмите кнопку Таблица изменяемых переменных на Панели специального управления или выберите ее название из контекстного меню. На экране появляется окно Таблица изменяемых переменных, позволяющее задавать новые значения переменных для экземпляров. Подробнее...

• Изменение значений размеров экземпляров
Раскройте вкладку Экземпляры Панели свойств. В группе Режим активизируйте переключатель Редактировать размеры. На панели Список экземпляров выберите нужный экземпляр. На панели Список объектов выберите объект, размеры которого требуется изменить. В окне модели появятся размеры данного объекта для выбранного экземпляра. Отредактируйте значения размеров. Подробнее...

Для геометрического массива (см. выше) данные способы управления формой и размерами экземпляров недоступны.

– Задание области применения операции (только для массива произвольных объектов). Подробнее...

– Изменение наименования массива и свойств поверхности экземпляров. Для этого активизируйте вкладку Свойства Панели свойств.

– Отмена выбора всех объектов на текущей вкладке Панели свойств. Для этого нажмите кнопку Указать заново на Панели специального управления.

– Включение/отключение отображения фантома массива на экране. Для этого служит кнопка Показать фантом на Панели специального управления. Подробнее...

10. Подтвердите создание массива, нажав кнопку Создать объект на Панели специального управления.

Прервать создание массива можно, нажав кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Каждый экземпляр массива операций наследует область применения своего исходного элемента.

Смотрите также

Базовая точка экземпляра массива

Разрушение массивов

Другие команды построения массивов


Команда Копировать полное имя файла

Позволяет скопировать полное имя файла в буфер обмена. Из буфера обмена имя файла может быть вставлено в любой текстовый документ, например, при помощи сочетания клавиш <Ctrl> + <V>.

Для вызова команды выберите ее название из контекстного меню закладки документа.

Смотрите также

Закладки документов


Команда Копировать объекты

Позволяет создать в текущей модели ассоциативную копию геометрических объектов этой модели или модели из файла.

В копию геометрических объектов могут быть включены следующие объекты модели:

– тела,

– поверхности,

– грани,

– ребра,

– вершины,

– пространственные кривые и точки,

– вспомогательные оси и плоскости,

– системы координат,

– эскизы.

Если копия должна содержать объекты текущей модели, то нужные объекты можно выбрать как до, так и после вызова команды.

Если требуется создать копию из объектов другой модели, то выбор объектов возможен только после вызова команды.

Для вызова команды нажмите кнопку Копировать объекты на инструментальной панели Редактирование модели или выберите пункт меню Операции — Дополнительные элементы — Копировать объекты.

На Панели свойств появятся две вкладки Параметры и Свойства.

На вкладке Параметры выполните следующие действия:

1. Выберите источник копируемых объектов. Для этого в группе Способ копирования активизируйте один из следующих переключателей:

• Контекстное — объекты копируются из текущей модели,

• Из файла — объекты копируются из другой модели.
После выбора способа копирования Из файла на экране появляется диалог выбора файла. Укажите файл, который будет являться источником для выбора объектов, и нажмите кнопку Открыть. Полное имя выбранного файла будет отображено в поле Файл-источник. Кнопка, расположенная справа от этого поля, позволяет перевыбрать файл.
Кроме того, в окне текущей модели появляется Окно модели-источника. Оно содержит окно модели из выбранного файла и Дерево построения этой модели. Подробнее...

2. Выберите способ формирования набора объектов и укажите объекты для копирования. Способ задается с помощью группы переключателей Выбор объектов.

• Ручное указание. Данный способ позволяет сформировать произвольный набор объектов. Этот набор отображается на панели Список объектов.
Чтобы добавить объект в список, укажите его в Дереве построения или в окне той модели, которая выбрана в качестве источника копирования (в случае контекстного копирования — это текущая модель, в случае копирования из файла — модель, показанная в Окне модели-источника). Указанный объект подсветится. Его фантом появится в окне текущей модели.
Повторное указание объекта удаляет его из списка копируемых. Можно также удалить объект, выделив его в списке и нажав кнопку Удалить из списка. Кнопка Указать заново полностью очищает список.

Тело или поверхность можно указать только в Дереве построения.

Если в Дереве построения указана операция построения тела, например, операция выдавливания, то копируются все грани этого тела.

• Коллекции. Данный способ позволяет выбрать одну из имеющихся в модели коллекций объектов. Нужная коллекция выбирается из раскрывающегося списка. Этот список появляется на Панели свойств только в том случае, если модель, из которой выбираются объекты, содержит хотя бы одну коллекцию.

После выбора объектов любым из описанных выше способов в окне текущей модели появляются фантомы выбранных объектов.

3. Определите положение копии в модели. Для этого выполните следующие действия.

• Если объекты копируются из текущей модели, копия по умолчанию размещается в текущей системе координат модели. Чтобы задать другое положение копии, сделайте текущей другую систему координат. Для этого выберите ее из списка СК текущего документа или нажмите одноименную кнопку и укажите нужную систему координат в Дереве построения или в окне модели.

• Если объекты копируются из другой модели, по умолчанию абсолютная система координат модели-источника совпадает с текущей системой координат модели, в которой создается копия. Чтобы задать другое положение копии, укажите другие системы координат для совмещения. Для этого выберите их из списков СК источника и СК текущего документа. Для выбора систем координат можно также использовать одноименные кнопки Панели свойств. После нажатия кнопки доступно указание в Дереве построения или в окне текущей модели (для системы координат текущего документа) и в Дереве построения или в окне модели-источника (для системы координат модели-источника).

Элементы выбора систем координат доступны, если текущая модель и/или модель — источник копирования содержат локальные системы координат.

4. Если требуется, чтобы объекты копии были зеркальным отражением исходных, включите опцию Зеркально. Выбранные объекты будут отражены зеркально относительно плоскости XY системы координат, в которой размещается копия.

При копировании объектов модели с левосторонней системой координат в модель с правосторонней и наоборот копируемая геометрия автоматически отражается относительно плоскости XY системы координат, в которой размещается копия. При включении опции Зеркально происходит повторное отражение геометрии.

Системы координат, входящие в копию, всегда имеют то же направление, что и система координат модели, содержащей эту копию, т.е. левосторонняя система координат становится правосторонней, а правосторонняя — левосторонней. Действие опции Зеркально не распространяется на копируемые системы координат.

5. На вкладке Свойства введите наименование создаваемой копии объектов.

6. Для завершения создания копии нажмите кнопку Создать объект на Панели специального управления.

В Дереве построения модели в разделе Копии появится пиктограмма и наименование созданной копии объектов, а в окне текущей модели — объекты, входящие в данную копию.

Смотрите также

Создание копии геометрических объектов


Команда Копировать свойства

Команда Копировать свойства позволяет копировать свойства и значения параметров существующих элементов листовых тел, не выходя из процесса создания или редактирования элемента.

Команда доступна на Панели специального управления после вызова большинства команд, размещенных на инструментальной панели Элементы листового тела.

Свойства копируются только между элементами одного и того же типа.

Чтобы скопировать свойства элемента:

1. Нажмите кнопку Копировать свойства на Панели специального управления или выберите ее название из контекстного меню.

Система переходит в режим указания объекта.

2. Укажите элемент для копирования свойств в Дереве построения или принадлежащий ему примитив в графической области (ребро, грань и т.п.).

Система автоматически возвращается к выполнению команды, из которой была вызвана команда Копировать свойства.

3. Если необходимо, задайте или отредактируйте параметры элемента.

4. Завершите процесс создания или редактирования.

Элемент листового тела будет иметь свойства элемента — источника.

Команду Копировать свойства можно прервать до возвращения в команду, из которой она была вызвана, нажав кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Обратите внимание на особенности копирования свойств при выполнении некоторых команд.

– Замыкание углов

• Кнопка Копировать свойства недоступна, если список Углы пуст.

• Копирование свойств невозможно, если в операции — источнике свойств углы имеют разные параметры.

• Если включена опция Единые параметры, то свойства копируются во все объекты списка Углы. При отключенной опции свойства копируются в текущий объект списка Углы.

– Обечайка

• Параметры сегментации не копируются, если у элемента — источника свойств отключена опция Единые параметры.


Команда Массив по сетке

Позволяет создать массив, экземпляры которого располагаются в узлах параллелограммной сетки.

Схема образования сетки...

Пример

Чтобы построить массив по сетке, выполните следующие действия.

1. Вызовите команду Массив по сетке.

2. Укажите в Дереве построения или в окне модели копируемые объекты.

Подробнее о выборе копируемых объектов...

На экране появляется фантом массива.

3. Перейдите на вкладку Параметры Панели свойств.

4. Задайте параметры сетки по первой оси.

• Направление первой оси

Способы задания направления:

- введите в поле Наклон значение угла между первой осью и ее умолчательным положением (угол наклона первой оси);

- укажите в Дереве построения или в окне модели в качестве направляющего объекта прямолинейный либо плоский объект или цилиндрическую либо коническую поверхность.

Чтобы направить ось в противоположную сторону, воспользуйтесь группой переключателей Направление.

Подробнее о задании направления первой оси сетки...

• Шаг сетки вдоль первой оси

- Введите в поле N 1 количество копий в направлении первой оси.

- Введите в поле Шаг 1 значение шага между копиями.

- В группе Режим 1 активизируйте переключатель, соответствующий введенному значению шага.

Подробнее о задании шага сетки вдоль первой оси...

5. Задайте направление второй оси сетки.
Для этого активизируйте на Панели свойств переключатель Ось 2.

• Направление второй оси

Способы задания направления:

- ведите в поле Угол раствора значение угла между осями сетки;

- укажите в Дереве построения или в окне модели в качестве направляющего объекта прямолинейный либо плоский объект или цилиндрическую либо коническую поверхность.

Чтобы направить ось в противоположную сторону, воспользуйтесь группой переключателей Направление.

• Шаг сетки вдоль второй оси

Параметры шага сетки вдоль второй оси аналогичны параметрам шага вдоль первой оси (см. выше). Для их задания используйте поля и переключатели N 2, Шаг 2 и Режим 2.

Для задания параметров сетки массива можно использовать характерные точки.

Все сделанные изменения отображаются на фантоме массива.

6. При необходимости используйте следующие возможности:

– Изменение положения экземпляров массива относительно базового экземпляра.
Для этого включите опцию Базовый экземпляр и введите в поля Номер 1 и Номер 2 нужные номера базового экземпляра по осям сетки или задайте их счетчиком. Подробнее...

– Выбор варианта размещения копий внутри сетки.
Для этого используйте список Схема. Подробнее...

– Построение геометрического массива, если копируются операции.
Для этого включите опцию Геометрический массив. Подробнее...

– Удаление или восстановление экземпляров массива.
Для этого активизируйте вкладку Экземпляры Панели свойств. В группе Режим активизируйте переключатель Удалить/восстановить. Затем в окне модели установите курсор на характерной точке того экземпляра массива, который требуется удалить или восстановить. Когда рядом с курсором появится надпись «Удалить/восстановить экземпляр», щелкните левой кнопкой мыши. Подробнее...

– Управление формой и размерами экземпляров путем изменения значений переменных. Доступны следующие способы.

• Использование Таблицы изменяемых переменных
Нажмите кнопку Таблица изменяемых переменных на Панели специального управления или выберите ее название из контекстного меню. На экране появляется окно Таблица изменяемых переменных, позволяющее задавать новые значения переменных для экземпляров. Подробнее...

• Изменение значений размеров экземпляров
Раскройте вкладку Экземпляры Панели свойств. В группе Режим активизируйте переключатель Редактировать размеры. На панели Список экземпляров выберите нужный экземпляр. На панели Список объектов выберите объект, размеры которого требуется изменить. В окне модели появятся размеры данного объекта для выбранного экземпляра. Отредактируйте значения размеров. Подробнее...

Для геометрического массива (см. выше) данные способы управления формой и размерами экземпляров недоступны.

– Назначение допусков на значения параметров операции, выраженных в линейных или угловых величинах. Для этого используйте кнопку Назначить допуск, расположенную на Панели свойств рядом с полем числового параметра операции.
Подробнее о допусках...
Подробнее о назначении допуска...

– Задание области применения операции (только для массива произвольных объектов). Подробнее...

– Изменение наименования массива и свойств поверхности экземпляров. Для этого активизируйте вкладку Свойства Панели свойств.

7. При необходимости используйте кнопки Панели специального управления для выполнения следующих действий:

– Построение вектора, задающего направление оси сетки.

– Отмена выбора всех объектов на текущей вкладке Панели свойств.

– Включение/отключение отображения фантома массива на экране. Для этого служит кнопка Показать фантом на Панели специального управления. Подробнее...

8. Подтвердите создание массива, нажав кнопку Создать объект на Панели специального управления.

Прервать создание массива можно, нажав кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Каждый экземпляр массива операций наследует область применения своего исходного элемента.

Смотрите также

Разрушение массивов

Другие команды построения массивов

Особенности задания числовых параметров операции в полях Панели свойств


Команда Копировать свойства(между объектами)

Команда Копировать свойства
(между объектами)

Позволяет скопировать свойства указанного объекта (источника свойств) в другие объекты, т.е. сделать свойства других объектов совпадающими со свойствами указанного объекта.

Для вызова команды нажмите кнопку Копировать свойства на Стандартной панели или выберите ее название из меню Редактор.

Копирование свойств возможно только при работе с графическими документами и эскизами. Оно производится по следующим правилам:

– свойство Слой объекта, а также свойства, являющиеся значениями координат и углов, в чертеже копируются между объектами, принадлежащими одному виду,

– свойство Стиль (стиль линии) копируется между всеми объектами, допускающими изменение стиля линии (например, стиль линии окружности можно скопировать в отрезок, эквидистанту, волнистую линию, фигурную скобку и т.п.),

– свойства из групп Текст (или свойство Стиль текста), Параметры шрифта и Параметры абзаца копируются между всеми объектами, содержащими текст и допускающими изменение указанных свойств,

– остальные свойства копируются только между объектами одного и того же типа (например, вид стрелки линии-выноски можно скопировать только в другую линию-выноску, но не в размер).

Чтобы скопировать свойства, выполните следующие действия.

1. Укажите объект-источник свойств. Для этого выделите его в окне документа. Указание объекта-источника возможно как до вызова команды Копировать свойства, так и после.

2. Укажите объект или объекты, в которые будут скопированы свойства источника. Для этого щелкайте по ним мышью или выделите рамкой.

Свойства объектов будут изменяться.

Во время копирования свойств объект-источник остается выделенным.

Чтобы сменить источник свойств, нажмите кнопку Указать заново на Панели специального управления и укажите новый объект-источник.

3. Чтобы прервать копирование свойств, нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

По умолчанию копирование некоторых свойств объектов отключено. К ним относятся свойство Слой объекта, значения координат характерных точек и другие свойства, копирование которых обычно не требуется. Включение (и отключение) копирования свойств производится в окне Свойства. Если оно не отображается на экране, включите его, нажав кнопку Свойства.

Команду Свойства удобно вызывать из контекстного меню.

Возможно копирование свойств объектов между разными графическими документами и эскизами, открытыми в одном окне КОМПАС-3D. Оно производится так же, как копирование свойств между объектами одного документа. Единственное условие выполнения этой операции — в документе, куда копируются свойства, не должна быть запущена ни одна другая команда.


Команда Массив по точкам

Позволяет создать массив, позиции экземпляров которого заданы точечными объектами.

Пример

Чтобы построить массив по точкам, выполните следующие действия.

1. Вызовите команду Массив по точкам.

2. Укажите в Дереве построения или в окне модели копируемые объекты.

Подробнее о выборе копируемых объектов...

На экране появляется фантом базовой точки копируемого объекта в виде трех ортогональных отрезков с общей вершиной.

3. Перейдите на вкладку Параметры Панели свойств.

4. Задайте позиции экземпляров. Для этого активизируйте переключатель Точки и укажите нужные точечные объекты в Дереве построения или в окне модели.

На экране появляется фантом создаваемого массива: базовой точкой базового экземпляра считается базовая точка копируемого объекта; базовые точки остальных экземпляров массива совмещаются с указанными точками.

Если позиции экземпляров массива задаются точками группы или точками эскиза, то вы можете указать нужные точки в Дереве построения или в окне модели. Для выбора сразу всех точек группы или эскиза укажите эту группу или эскиз в Дереве построения.

Если для задания позиций экземпляров используется эскиз, указанный в Дереве построения, то вы можете управлять плоскостью расположения этих экземпляров.

5. Выберите способ ориентации экземпляров, позиции которых заданы точками, лежащими на кривой или на поверхности.

Подробнее об ориентации экземпляров...

Все заданные изменения отображаются на фантоме массива.

6. При необходимости используйте следующие возможности:

– Смена положения базовой точки базового экземпляра. Подробнее...

– Отключение использования проекции базовой точки копируемого объекта — доступно, если копируются тела/поверхности вращения. Для этого отключите опцию На оси вращения. Подробнее...

– Построение геометрического массива — доступно, если копируются операции.
Для этого включите опцию Геометрический массив. Подробнее...

– Удаление или восстановление экземпляров массива.
Для этого активизируйте вкладку Экземпляры Панели свойств. В группе Режим активизируйте переключатель Удалить/восстановить. Затем в окне модели установите курсор на характерной точке того экземпляра массива, который требуется удалить или восстановить. Когда рядом с курсором появится надпись «Удалить/восстановить экземпляр», щелкните левой кнопкой мыши. Подробнее...

– Управление формой и размерами экземпляров путем изменения значений переменных. Доступны следующие способы.

• Использование Таблицы изменяемых переменных
Нажмите кнопку Таблица изменяемых переменных на Панели специального управления или выберите ее название из контекстного меню. На экране появляется окно Таблица изменяемых переменных, позволяющее задавать новые значения переменных для экземпляров. Подробнее...

• Изменение значений размеров экземпляров
Раскройте вкладку Экземпляры Панели свойств. В группе Режим активизируйте переключатель Редактировать размеры. На панели Список экземпляров выберите нужный экземпляр. На панели Список объектов выберите объект, размеры которого требуется изменить. В окне модели появятся размеры данного объекта для выбранного экземпляра. Отредактируйте значения размеров. Подробнее...

Для геометрического массива (см. выше) данные способы управления формой и размерами экземпляров недоступны.

– Задание области применения операции (только для массива произвольных объектов). Подробнее...

– Изменение наименования массива и свойств поверхности экземпляров.
Для этого активизируйте вкладку Свойства Панели свойств.

– Отмена выбора всех объектов на текущей вкладке Панели свойств.
Для этого нажмите кнопку Указать заново на Панели специального управления.

– Включение/отключение отображения фантома массива на экране. Для этого служит кнопка Показать фантом на Панели специального управления. Подробнее...

7. Подтвердите создание массива, нажав кнопку Создать объект на Панели специального управления.

Прервать создание массива можно, нажав кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Число копий равно числу точек, задающих позиции экземпляров массива (n).

Если в результате одна из копий совпадает с копируемым объектом, то эта копия не создается. Число копий элемента равно n-1.

Каждый экземпляр массива операций наследует область применения своего исходного элемента.

Смотрите также

Базовая точка экземпляра массива

Разрушение массивов

Другие команды построения массивов


Команда Массив по таблице

Чтобы построить массив по таблице, выполните следующие действия.

1. Вызовите команду Массив по таблице.

2. Укажите в Дереве построения или в окне модели копируемые объекты.

Подробнее о выборе копируемых объектов...

На экране появляется фантом базовой точки копируемого объекта в виде трех взаимно перпендикулярных векторов.

3. Перейдите на вкладку Параметры Панели свойств.

4. Задайте позиции экземпляров. Выберите способ задания позиций экземпляров с помощью переключателей группы Источник данных:

– Файл-источник — чтение данных из файла данных;

– Ввод вручную — ввод данных в таблицу изменяемых переменных.

После задания позиций экземпляров на экране появляется фантом массива: базовой точкой базового экземпляра считается базовая точка копируемого объекта; базовые точки остальных экземпляров массива совмещаются с точками, координаты которых считаны из файла данных или заданы в таблице изменяемых переменных.

Если позиции экземпляров заданы с помощью файла данных, то созданный массив сохраняет связь с этим файлом. Связь в целом аналогична связи группы точек с файлом-источником. Отличие состоит в том, что отказаться от ее формирования невозможно.

5. Выберите тип координат для интерпретации данных из таблицы изменяемых переменных или из файла данных. Для этого в группе Тип координат на Панели свойств активизируйте нужный переключатель:

• Прямоугольные X,Y,Z,

• Цилиндрические R,A,Z,

• Сферические R,A,B.

Значения, считанные из файла данных или из таблицы изменяемых переменных, могут интерпретироваться как прямоугольные, цилиндрические или сферические координаты точек.

При смене типа координат можно сохранить значения координат или пересчитать их. Подробнее...

6. Для цилиндрических и сферических координат точек выберите способ ориентации экземпляров массива. Для этого активизируйте нужный переключатель в группе Ориентация. Подробнее об ориентации экземпляров массива...

Все заданные изменения отображаются на фантоме массива.

7. При необходимости используйте следующие возможности:

– Смена положения базовой точки базового экземпляра. Подробнее...

– Отключение использования проекции базовой точки копируемого объекта — доступно, если копируются тела/поверхности вращения. Для этого отключите опцию На оси вращения. Подробнее...

– Построение геометрического массива — доступно, если копируются операции.
Для этого включите опцию Геометрический массив. Подробнее...

– Удаление или восстановление экземпляров массива.
Для этого раскройте вкладку Экземпляры Панели свойств. В группе Режим активизируйте переключатель Удалить/восстановить. Затем в окне модели установите курсор на характерной точке того экземпляра массива, который требуется удалить или восстановить. Когда рядом с курсором появится надпись «Удалить/восстановить экземпляр», щелкните левой кнопкой мыши. Подробнее...

– Управление формой и размерами экземпляров, а также их позициями, путем изменения значений переменных. Доступны следующие способы.

• Использование Таблицы изменяемых переменных
Нажмите кнопку Таблица изменяемых переменных на Панели специального управления или выберите ее название из контекстного меню. На экране появляется окно Таблица изменяемых переменных, позволяющее задавать новые значения переменных для экземпляров. Подробнее...

• Изменение значений размеров экземпляров
Раскройте вкладку Экземпляры Панели свойств. В группе Режим активизируйте переключатель Редактировать размеры. Для изменения позиции экземпляра выберите его на панели Список экземпляров. В окне модели появятся размеры позиции данного экземпляра. Если требуется также изменить форму и размеры экземпляра, на панели Список объектов выберите один из объектов, размеры которых влияют на геометрию экземпляра. В окне модели появятся размеры данного объекта. Отредактируйте значения размеров. Подробнее...

Для геометрического массива (см. выше) данные способы управления формой, размерами и позициями экземпляров недоступны.

– Задание области применения операции (только для массива произвольных объектов). Подробнее...

– Изменение наименования массива и свойств поверхности экземпляров.
Для этого активизируйте вкладку Свойства Панели свойств.

– Отмена выбора всех объектов на текущей вкладке Панели свойств.
Для этого нажмите кнопку Указать заново на Панели специального управления.

– Включение/отключение отображения фантома массива на экране. Для этого служит кнопка Показать фантом на Панели специального управления. Подробнее...

8. Подтвердите создание массива, нажав кнопку Создать объект на Панели специального управления.

Прервать создание массива можно, нажав кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Каждый экземпляр массива операций наследует область применения своего исходного элемента.

Смотрите также

Базовая точка экземпляра массива

Разрушение массивов

Другие команды построения массивов


Команда Копировать значение по первой ячейке

Позволяет заменить содержимое всех ячеек выделенного столбца значением, введенным в первую ячейку.


Поле После

Поле для задания количества перемещаемых полюсов сетки, которые расположены в том же ряду, что и выбранный полюс, по направлению U/V. Если выбрано несколько полюсов, то заданное количество отсчитывается в ряду каждого из них.

Полюсы перемещаются в соответствии с дополнительным условием, заданным для линейного перемещения полюсов.


Поле Перед

Поле для задания количества перемещаемых полюсов сетки, которые расположены в том же ряду, что и выбранный полюс, против направления U/V. Если выбрано несколько полюсов, то заданное количество отсчитывается в ряду каждого из них.

Полюсы перемещаются в соответствии с дополнительным условием, заданным для линейного перемещения полюсов.


Поле Количество ссылок на источник

Справочное поле, в котором отображается количество ссылок модели на файл — источник компонента.

Фактически это поле содержит число вставок выбранного компонента в модель.


Поле Количество удаляемых граней

Справочное поле, в котором отображается число граней тела или поверхности, удаляемых при формировании оболочки или выполнении команды Удалить грани.


Команда Плоскость через три вершины

Позволяет создать одну или несколько вспомогательных плоскостей, каждая из которых проходит через три точечных объекта.

Для вызова команды нажмите кнопку Плоскость через три вершины плоскости на панели Вспомогательная геометрия или выберите ее название из меню Операции.

Последовательно указывайте тройки точечных объектов, через которые должны проходить создаваемые плоскости.

Выбор объектов в окне модели

Вы можете задать название и цвет плоскости на вкладке Свойства Панели свойств.

Завершить построение плоскостей можно, нажав кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие команды построения вспомогательных плоскостей


Команда Плоскость под углом к другой плоскости

Позволяет создать одну или несколько вспомогательных плоскостей, проходящих через прямолинейный объект под заданным углом к существующему плоскому объекту.

Прямолинейный объект должен быть параллелен плоскому объекту или принадлежать ему.

Для вызова команды нажмите кнопку Плоскость под углом к другой плоскости на панели Вспомогательная геометрия или выберите ее название из меню Операции.

Укажите плоский объект, под углом к которому должна пройти новая плоскость.

Укажите прямолинейный объект, через который должна пройти новая плоскость.

Выбор объектов в окне модели

Выбор объектов в Дереве построения

Введите в поле Угол на Панели свойств значение угла между плоским объектом и создаваемой плоскостью или выберите его из списка.

Чтобы указать, в какую сторону от плоского объекта должен быть отложен указанный угол, воспользуйтесь переключателем Направление угла на вкладке Параметры Панели свойств.

Величину и направление угла можно задать с помощью характерных точек.

При необходимости вы можете назначить допуски на значения параметров операции, выраженных в линейных или угловых величинах. Для этого используйте кнопку Назначить допуск, расположенную на Панели свойств рядом с полем числового параметра операции.
Подробнее о допусках...
Подробнее о назначении допуска...

Вы можете задать название и цвет плоскости на вкладке Свойства Панели свойств.

Плоскость с заданными параметрами отображается на экране в виде фантома.

Чтобы подтвердить ее создание, нажмите кнопку Создать объект на Панели специального управления.

Завершить построение плоскостей можно, нажав кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие команды построения вспомогательных плоскостей

Особенности задания числовых параметров операции в полях Панели свойств


Команда Плоскость через ребро и вершину

Позволяет создать одну или несколько вспомогательных плоскостей, каждая из которых проходит через прямолинейный и точечный объекты.

Для вызова команды нажмите кнопку Плоскость через ребро и вершину на панели Вспомогательная геометрия или выберите ее название из меню Операции.

Укажите прямолинейный объект и точечный объект, через которые должна проходить создаваемая плоскость.

Выбор объектов в окне модели

Выбор объектов в Дереве построения

Вы можете задать название и цвет плоскости на вкладке Свойства Панели свойств.

Завершить построение плоскостей можно, нажав кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие команды построения вспомогательных плоскостей


Команда Плоскость через ребро параллельно/перпендикулярно другому ребру

Команда Плоскость через ребро
параллельно/перпендикулярно другому ребру

Позволяет создать одну или несколько вспомогательных плоскостей, проходящих через указанные прямолинейные объекты параллельно или перпендикулярно другим прямолинейным объектам.

Для вызова команды нажмите кнопку Плоскость через ребро параллельно/перпендикулярно другому ребру на панели Вспомогательная геометрия или выберите ее название из меню Операции.

Укажите прямолинейный объект, через который должна пройти плоскость.

Чтобы выбрать вариант построения — параллельно или перпендикулярно другому ребру (оси), активизируйте соответствующий переключатель на вкладке Параметры Панели свойств.

Укажите прямолинейный объект, параллельно (или перпендикулярно) которому должна пройти плоскость.

Выбор объектов в окне модели

Выбор объектов в Дереве построения

Вы можете задать название и цвет плоскости на вкладке Свойства Панели свойств.

Плоскость с заданными параметрами отображается на экране в виде фантома.

Чтобы подтвердить ее создание, нажмите кнопку Создать объект на Панели специального управления.

Завершить построение плоскостей можно, нажав кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие команды построения вспомогательных плоскостей


Положение плоскости

Переключатель, позволяющий выбрать ориентацию создаваемой плоскости: параллельно или перпендикулярно выбранному ребру.

Изменение положения немедленно отображается на фантоме плоскости в окне модели.


Команда Плоскость через ребро параллельно/перпендикулярно грани

Команда Плоскость через ребро
параллельно/перпендикулярно грани

Позволяет создать одну или несколько вспомогательных плоскостей, проходящих через указанные прямолинейные объекты параллельно или перпендикулярно плоским объектам.

Для вызова команды нажмите кнопку Плоскость через ребро параллельно/перпендикулярно грани на панели Вспомогательная геометрия или выберите ее название из меню Операции.

Укажите прямолинейный объект, через который должна пройти плоскость.

Чтобы выбрать вариант построения — параллельно или перпендикулярно плоской грани (или плоскости), активизируйте соответствующий переключатель на вкладке Параметры Панели свойств.

Укажите плоский объект, параллельно (или перпендикулярно) которому должна пройти плоскость.

Выбор объектов в окне модели

Выбор объектов в Дереве построения

Вы можете задать название и цвет плоскости на вкладке Свойства Панели свойств.

Плоскость с заданными параметрами отображается на экране в виде фантома.

Чтобы подтвердить ее создание, нажмите кнопку Создать объект на Панели специального управления.

Завершить построение плоскостей можно, нажав кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие команды построения вспомогательных плоскостей


Положение плоскости

Переключатель, позволяющий выбрать ориентацию создаваемой плоскости: параллельно или перпендикулярно существующей.

Изменение положения немедленно отображается на фантоме плоскости в окне модели.


Команда Средняя плоскость

Команда позволяет построить биссекторную плоскость двугранного угла.

Двугранный угол — часть пространства, ограниченная двумя полуплоскостями, границей каждой из которых служит их общая прямая. Эти полуплоскости называются гранями двугранного угла, а граница — ребром двугранного угла. Угол между линиями пересечения граней двугранного угла с плоскостью, перпендикулярной ребру двугранного угла, называется линейным углом двугранного угла.

Биссекторная плоскость двугранного угла — плоскость, проходящая через биссектрису линейного угла этого двугранного угла.

Для вызова команды нажмите кнопку Средняя плоскость на панели Вспомогательная геометрия или выберите ее название из меню Операции.

Двугранный угол для построения средней плоскости может быть задан:

– гранями — для этого необходимо указать два плоских объекта,

– линейным углом — для этого необходимо указать два прямолинейных объекта,

– гранью и стороной линейного угла — для этого необходимо указать плоский и прямолинейный объекты.

Выбор объектов в окне модели

Выбор объектов в Дереве построения

Чтобы задать положение средней плоскости относительно объектов, активизируйте переключатель Положение 1 или Положение 2 на вкладке Параметры Панели свойств.

Вы можете задать название и цвет плоскости на вкладке Свойства Панели свойств.

Плоскость с заданными параметрами отображается на экране в виде фантома.

В частном случае, если указаны параллельные объекты, построение выполняется следующим образом (вне зависимости от того, какой переключатель положения активен).

– Если объекты прямолинейные, то средняя плоскость строится перпендикулярно проходящей через них плоскости на равном расстоянии от них.

– Если объекты плоские, а также, если один плоский, а второй — прямолинейный, то средняя плоскость строится параллельно им на равном расстоянии от них.

Чтобы подтвердить создание средней плоскости, нажмите кнопку Создать объект на Панели специального управления.

После создания средней плоскости команда остается активной. Система ожидает задания параметров и построения следующего экземпляра средней плоскости.

Завершить построение плоскостей можно, нажав кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие команды построения вспомогательных плоскостей


Положение плоскости

Переключатель, позволяющий выбрать ориентацию создаваемой средней плоскости.

Вариант Положение 1 позволяет построить биссекторную плоскость.

Вариант Положение 2 позволяет построить плоскость, перпендикулярную биссекторной и проходящую через ребро двугранного угла.

Изменение положения немедленно отображается на фантоме плоскости в окне модели.


Команда Нормальная плоскость

Позволяет создать одну или несколько вспомогательных плоскостей, нормальных к поверхностям вращения (кроме сферы).

Для вызова команды нажмите кнопку Нормальная плоскость на панели Вспомогательная геометрия или выберите ее название из меню Операции.

Выберите способ создания нормальной плоскости. Для этого активизируйте нужный переключатель в группе Способ на Панели свойств:

– Автопостроение — будет построена нормальная плоскость, проходящая через ось поверхности вращения и точку этой поверхности с нулевыми значениями параметров U и V;

– Параллельно объекту — будет построена нормальная плоскость, проходящая через ось поверхности вращения параллельно указанной координатной плоскости или плоской грани.

Укажите объекты для построения.

– Если выбран способ Автопостроение, укажите поверхность вращения.

– Если выбран способ Параллельно объекту, укажите поверхность вращения, а затем координатную плоскость или плоскую грань, относительно которой будет задаваться положение плоскости.

Выбор объектов в окне модели

Выбор объектов в Дереве построения

По умолчанию включено автосоздание объектов. В этом режиме плоскость создается автоматически (т.е. подтверждение создания не требуется) в умолчательном положении.

Если необходимо задать угол поворота нормальной плоскости вокруг оси поверхности вращения, отключите режим автосоздания объектов (отожмите кнопку Автосоздание объекта на Панели специального управления.

Угол отсчитывается от умолчательного положения нормальной плоскости.

Введите нужное значение угла поворота плоскости в поле Угол.

Чтобы указать, в какую сторону от умолчательного положения должен быть отложен заданный угол, активизируйте переключатель Прямое направление или Обратное направление в группе Направление угла.

Величину и направление отсчета угла можно задать с помощью характерной точки.

При необходимости вы можете назначить допуски на значения параметров операции, выраженных в линейных или угловых величинах. Для этого используйте кнопку Назначить допуск, расположенную на Панели свойств рядом с полем числового параметра операции.
Подробнее о допусках...
Подробнее о назначении допуска...

Вы можете задать название и цвет плоскости на вкладке Свойства Панели свойств.

Плоскость с заданными параметрами отображается на экране в виде фантома.

Чтобы сменить объекты, используемые для построения плоскости, нажмите кнопку Указать заново на Панели специального управления, а затем повторите выбор объектов.

Чтобы подтвердить создание плоскости, нажмите кнопку Создать объект на Панели специального управления.

Завершить построение плоскостей можно, нажав кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие команды построения вспомогательных плоскостей

Особенности задания числовых параметров операции в полях Панели свойств


Команда Смещенная плоскость

Позволяет создать одну или несколько вспомогательных плоскостей, расположенных на заданном расстоянии от указанной плоскости или плоской грани детали.

Для вызова команды нажмите кнопку Смещенная на панели Вспомогательная геометрия или выберите ее название из меню Операции.

Укажите плоскость, относительно которой должна быть смещена новая плоскость.

Выбор объектов в окне модели

Выбор объектов в Дереве построения

Введите в поле Расстояние на Панели свойств значение расстояния от существующей плоскости (плоской грани) до новой конструктивной плоскости или задайте его, используя счетчик.

Для того чтобы указать, по какую сторону от существующей должна быть построена новая плоскость, активизируйте один из переключателей (Прямое направление или Обратное направление) на вкладке Параметры Панели свойств.

Расстояние и направление смещения можно задать с помощью характерных точек.

При необходимости вы можете назначить допуски на значения параметров операции, выраженных в линейных или угловых величинах. Для этого используйте кнопку Назначить допуск, расположенную на Панели свойств рядом с полем числового параметра операции.
Подробнее о допусках...
Подробнее о назначении допуска...

Вы можете задать название и цвет плоскости на вкладке Свойства Панели свойств.

Плоскость с заданными параметрами отображается на экране в виде фантома.

Чтобы подтвердить ее создание, нажмите кнопку Создать объект на Панели специального управления.

Завершить построение плоскостей можно, нажав кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие команды построения вспомогательных плоскостей

Особенности задания числовых параметров операции в полях Панели свойств


Команда Плоскость через вершину параллельно другой плоскости

Команда Плоскость через вершину
параллельно другой плоскости

Позволяет создать одну или несколько вспомогательных плоскостей, проходящих через точечные объекты параллельно плоским объектам.

Для вызова команды нажмите кнопку Плоскость через вершину параллельно другой плоскости на панели Вспомогательная геометрия или выберите ее название из меню Операции.

Укажите точечный объект, через который должна пройти новая плоскость, и плоский объект, параллельно которому должна пройти новая плоскость.

Выбор объектов в окне модели

Выбор объектов в Дереве построения

Вы можете задать название и цвет плоскости на вкладке Свойства Панели свойств.

Завершить построение плоскостей можно, нажав кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие команды построения вспомогательных плоскостей


Команда Плоскость через вершину перпендикулярно ребру

Команда Плоскость через вершину
перпендикулярно ребру

Позволяет создать одну или несколько вспомогательных плоскостей, проходящих через точечные объекты перпендикулярно кривым (ребрам, сплайнам, линиям эскиза и т.п.).

Для вызова команды нажмите кнопку Плоскость через вершину перпендикулярно ребру на панели Вспомогательная геометрия или выберите ее название из меню Операции.

Если объекты для построения плоскости существуют в модели, укажите их.

Выбор объектов в окне модели

Выбор объектов в Дереве построения

Объекты могут быть выделены и перед вызовом команды.

Точечный объект необязательно должен принадлежать кривой.

Если нужных объектов в модели нет, то вы можете построить их, не выходя из команды.

• Чтобы создать точку, нажмите кнопку Построение точки на Панели специального управления.

• Чтобы создать вектор, нажмите кнопку Построение вектора на Панели специального управления.

Обратите внимание на то, что созданная точка отображается как самостоятельный объект в Дереве построения. Изменение параметров точки производится непосредственно путем редактирования этого объекта, а не в процессе редактирования плоскости.

Вы можете задать название и цвет плоскости на вкладке Свойства Панели свойств.

Завершить построение плоскостей можно, нажав кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие команды построения вспомогательных плоскостей


Команда Плоскость через плоскую кривую

Позволяет создать одну или несколько вспомогательных плоскостей, проходящих через указанные плоские кривые.

Пример

Для вызова команды нажмите кнопку Плоскость через плоскую кривую на панели Вспомогательная геометрия или выберите ее название из меню Операции.

В качестве кривой может использоваться:

– линия эскиза,

– сплайн или ломаная с тремя вершинами,

– дуга,

– другие плоские кривые: ребро, имеющее форму окружности, и т.п.

Укажите кривую, через которую должна пройти новая плоскость.

Выбор объектов в окне модели

Выбор объектов в Дереве построения

Вы можете задать название и цвет плоскости на вкладке Свойства Панели свойств.

Завершить построение плоскостей можно, нажав кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие команды построения вспомогательных плоскостей


Положение плоскости

Переключатель, позволяющий выбрать положение создаваемой плоскости относительно существующей.

Изменение положения немедленно отображается на фантоме плоскости в окне модели.


Команда Плоскость, касательная к грани в точке

Позволяет создать одну или несколько вспомогательных плоскостей, касательных указанным граням в заданных точках.

Пример

Для вызова команды нажмите кнопку Плоскость, касательная к грани в точке на панели Вспомогательная геометрия или выберите ее название из меню Операции.

Укажите грань, касательно к которой должна пройти новая плоскость.

На выбранной грани появляются фантом ее теоретической поверхности в виде сетки изопараметрических кривых U и V и фантом создаваемой плоскости в виде прямоугольника. По умолчанию новая плоскость проходит через точку указания грани.

Задайте положение новой плоскости. Это можно сделать следующими способами.

– Задайте нужное положение точки, через которую будет проходить плоскость. Положение точки определяется смещением вдоль изопараметрических кривых U и V.
Для задания смещения точки введите нужные значения в поля Параметр U, % и Параметр V, %.

– Свяжите точку, через которую будет проходить плоскость, с существующим точечным объектом. Для этого укажите нужный объект в Дереве построения или в окне модели.

Выбор объектов в окне модели

Выбор объектов в Дереве построения

О наличии ассоциативной связи плоскости с выбранным объектом свидетельствует «галочка» на кнопке Точка.

При необходимости связь можно отменить, нажав кнопку Точка. «Галочка» на кнопке исчезнет.

Для задания положения плоскости могут быть указаны точечные объекты как принадлежащие выбранной грани, так и не принадлежащие, но проецирующиеся на эту грань. Положение создаваемой плоскости в этом случае определяет проекция.

Если для построения плоскости нужного точечного объекта в модели нет, то вы можете построить точку, не выходя из команды. Для этого нажмите кнопку Построение точки на Панели специального управления.

После завершения создания точки система вернется в процесс построения плоскости.

Обратите внимание на то, что созданная точка отображается как самостоятельный объект в Дереве построения. Изменение параметров точки производится непосредственно путем редактирования этого объекта, а не в процессе редактирования плоскости.

Чтобы сменить объекты, используемые для построения плоскости, нажмите кнопку Указать заново на Панели специального управления и повторите выбор объектов.

Вы можете задать название и цвет плоскости на вкладке Свойства Панели свойств.

Чтобы подтвердить создание плоскости, нажмите кнопку Создать объект на Панели специального управления.

Завершить построение плоскостей можно, нажав кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие команды построения вспомогательных плоскостей


Команда Касательная плоскость

Позволяет создать одну или несколько вспомогательных плоскостей, касательных к цилиндрической или конической грани детали.

Для вызова команды нажмите кнопку Касательная плоскость на панели Вспомогательная геометрия или выберите ее название из меню Операции.

Укажите цилиндрическую (коническую) грань, касательно к которой должна пройти новая плоскость.

Затем укажите плоскость или плоскую грань, проходящую через ось указанной цилиндрической (конической) грани. Эта плоскость или плоская грань необходима для определения первоначального положения касательной плоскости.

Выбор объектов в окне модели

Выбор объектов в Дереве построения

На экране появляется фантом касательной плоскости. По умолчанию она проходит через линию пересечения указанных — цилиндрической (конической) и плоской — поверхностей перпендикулярно последней. При этом значение в поле Угол на Панели свойств равно нулю.

Чтобы повернуть касательную плоскость на определенный угол относительно умолчательного положения, введите нужное значение в поле Угол.

Повернуть плоскость можно также с помощью характерной точки.

Чтобы указать, по какую сторону от цилиндрической (конической) грани должна быть построена новая плоскость, активизируйте соответствующий переключатель.

При необходимости вы можете назначить допуски на значения параметров операции, выраженных в линейных или угловых величинах. Для этого используйте кнопку Назначить допуск, расположенную на Панели свойств рядом с полем числового параметра операции.
Подробнее о допусках...
Подробнее о назначении допуска...

Вы можете задать название и цвет плоскости на вкладке Свойства Панели свойств.

Плоскость с заданными параметрами отображается на экране в виде фантома.

Чтобы подтвердить ее создание, нажмите кнопку Создать объект на Панели специального управления.

Завершить построение плоскостей можно, нажав кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие команды построения вспомогательных плоскостей

Особенности задания числовых параметров операции в полях Панели свойств


Направление угла

Переключатель, позволяющий выбрать направление измерения угла поворота создаваемой или редактируемой нормальной плоскости.

Изменение направления немедленно отображается на фантоме плоскости в окне модели.


Команда Точка (документ-модель)

Команда Точка
(документ-модель)

Позволяет создать точку в пространстве. Доступно несколько способов построения, а также формирования ассоциативной связи с имеющимися объектами.

Для вызова команды нажмите кнопку Точка на панели Пространственные кривые или выберите ее название из меню Операции — Пространственные кривые.

Выберите вариант из списка Способ или при помощи команд контекстного меню — набор элементов управления при этом изменится.

Выбор способа, а следовательно, и объекта, используемого для построения, обусловливает ассоциативную связь точки с этим объектом — например, принадлежность точки поверхности.

Выполните действия, характерные для каждого способа построения.

– По координатам (XYZ)

– Переносом относительно другой точки

– На пересечении двух объектов

– На кривой

– На поверхности

– В центре объекта

– Проекцией точки на объект

– По цилиндру (RAZ)

– По сфере (RAB)

После задания всех необходимых данных в модели появляется фантом точки. До завершения построения положение точки можно изменить, введя новые параметры на Панели свойств или перемещая мышью характерную точку.

Чтобы сменить объекты, используемые при построении точки, нажмите кнопку Указать заново на Панели специального управления и повторите выбор объектов.

В любой момент построения точки вы можете просмотреть ее координаты в системе координат этой точки. Для этого переключитесь на способ По координатам (XYZ), а затем вернитесь к прежнему способу.

Если завершить построение во время, пока активен способ По координатам (XYZ), ассоциативная связь с указанными ранее объектами будет утеряна.

При необходимости вы можете назначить допуск на значения параметров операции, выраженных в линейных или угловых величинах. Для этого используйте кнопку Назначить допуск, расположенную на Панели свойств рядом с полем числового параметра операции.
Подробнее о допусках...
Подробнее о назначении допуска...

Название, цвет и стиль отображения точки можно изменить на вкладке Свойства Панели свойств.

Чтобы завершить построение, нажмите кнопку Создать объект на Панели специального управления.

В способах По координатам (XYZ) и В центре доступен режим автосоздания точек, который по умолчанию включен.

Смотрите также

Особенности задания числовых параметров операции в полях Панели свойств


Команда ТочкаПостроение способом В центре

Команда Точка
Построение способом В центре

Данный способ позволяет задать положение точки в центре кривой или сферы либо в центре масс тела или грани.

Пример

Способ можно сделать текущим, выбрав название В центре из списка Способ на Панели свойств или контекстного меню команды Точка.

Чтобы построить точку, укажите в модели окружность, эллипс (либо дугу окружности/эллипса), сферическую поверхность или тело.

Указание тел производится в Дереве построения. Пиктограммы и названия тел показываются в Дереве, если в нем включено отображение структуры модели.

После завершения построения первой точки система ожидает задания положения очередной точки.

Подробнее...


Команда ТочкаПостроение способом По координатам (XYZ)

Команда Точка
Построение способом По координатам (XYZ)

Данный способ позволяет задать положение точки путем ввода координат или связи ее с существующим в модели точечным объектом.

Пример

Способ можно сделать текущим, выбрав название По координатам (XYZ) из списка Способ на Панели свойств или контекстного меню команды Точка.

– Чтобы построить в модели точку, укажите положение точки путем ввода координат на Панели свойств или при помощи мыши.

– Чтобы создаваемая точка была связана с объектом, включите опцию Ассоциировать на Панели свойств и укажите в модели точечный объект — вершину или точку.

После завершения построения первой точки система ожидает задания положения следующей точки.

При редактировании можно как установить, так и отменить связь точки с объектом.

– Чтобы связать точку с объектом, укажите точечный объект при включенной опции Ассоциировать.

– Чтобы отменить связь с объектом, нажмите кнопку Объект. Ассоциативная связь будет удалена («галочка» на кнопке исчезнет), точка останется в прежнем положении с зафиксированными координатами.

Подробнее о построении точки по координатам...

Если способ построения точки по координатам выбран для позиционирования начала ЛСК, то кроме вышеупомянутых элементов управления Панель свойств содержит также группу переключателей Смещение и поле Расстояние. Эти элементы позволяют задать смещение ЛСК вдоль собственных осей.


Команда ТочкаПостроение способом По цилиндру (RAZ)

Команда Точка
Построение способом По цилиндру (RAZ)

Данный способ позволяет задать положение точки путем ввода ее цилиндрических координат (R, A, Z) или связи ее с существующим в модели точечным объектом.

Пример

Построение точки по цилиндрическим координатам;
XYZ — система координат точки

Способ можно сделать текущим, выбрав название По цилиндру (RAZ) из списка Способ на Панели свойств или контекстного меню команды Точка.

– Чтобы построить в модели точку, укажите положение точки путем ввода координат на Панели свойств или при помощи мыши.
Для задания радиуса цилиндра можно ввести нужное значение в поле координаты R или, активизировав переключатель Объект радиуса, указать объект, определяющий радиус.

– Чтобы создаваемая точка была связана с объектом, включите опцию Ассоциировать на Панели свойств и укажите в модели точечный объект — вершину или точку.

После завершения построения первой точки система ожидает задания положения следующей точки.

При редактировании можно как установить, так и отменить связь точки с объектами.

– Чтобы связать точку с объектом, укажите точечный объект при включенной опции Ассоциировать.

– Чтобы отменить связь с объектом, нажмите кнопку Объект. Ассоциативная связь будет удалена («галочка» на кнопке исчезнет), точка останется в прежнем положении с зафиксированными координатами.

– Чтобы отменить связь с объектом, определяющим радиус цилиндра, укажите этот объект повторно при нажатом переключателе Объект радиуса.

Подробнее о построении точки по цилиндру и сфере...


Команда ТочкаПостроение способом Перенос

Команда Точка
Построение способом Перенос

Данный способ позволяет определить положение точки в модели заданием координат относительно опорной точки или смещением от нее на заданное расстояние в указанном направлении.

Пример

Способ можно сделать текущим, выбрав название Перенос из списка Способ на Панели свойств или контекстного меню команды Точка.

Чтобы построить точку, выполните следующие действия.

1. Укажите опорную точку.

Если необходимо задать направление переноса, нажмите кнопку Направляющий объект на Панели свойств или вызовите из контекстного меню команду Выбрать направляющий объект и укажите направляющий объект или постройте вектор.

2. Введите координаты (или расстояние, если указан направляющий объект) либо укажите положение создаваемой точки мышью.

Подробнее...


Команда ТочкаПостроение способом Пересечение

Команда Точка
Построение способом Пересечение

Данный способ позволяет задать положение точки на пересечении двух кривых или кривой и поверхности в модели.

Пример

Способ можно сделать текущим, выбрав название Пересечение из списка Способ на Панели свойств или контекстного меню команды Точка.

Чтобы построить точку, выполните следующие действия.

1. Укажите первую кривую.

2. Укажите вторую кривую или поверхность.

Подробнее...


Команда ТочкаПостроение способом На кривой

Команда Точка
Построение способом На кривой

Данный способ позволяет задать положение точки, лежащей на кривой в модели.

Пример

Способ можно сделать текущим, выбрав название На кривой из списка Способ на Панели свойств или контекстного меню команды Точка.

Чтобы построить точку, выполните следующие действия.

1. Укажите кривую.

2. Задайте положение точки одним из способов:

– при помощи мыши,

– путем ввода параметров на Панели свойств,

– указанием точечного объекта.

Подробнее...


Команда ТочкаПостроение способом На поверхности

Команда Точка
Построение способом На поверхности

Данный способ позволяет задать положение точки, лежащей на поверхности в модели.

Пример

Способ можно сделать текущим, выбрав название На поверхности из списка Способ на Панели свойств или контекстного меню команды Точка.

Чтобы построить точку, выполните следующие действия.

1. Укажите поверхность.

2. Выберите вариант указания положения точки, а затем задайте параметры, определяющие положение.

Подробнее...


Команда ТочкаПостроение способом Проекция

Команда Точка
Построение способом Проекция

Данный способ позволяет задать положение точки, являющейся проекцией опорной точки на поверхность или кривую в модели.

Пример

Способ можно сделать текущим, выбрав название Проекция из списка Способ на Панели свойств или контекстного меню команды Точка.

Чтобы построить точку, выполните следующие действия.

1. Укажите опорную точку.

2. Укажите поверхность или кривую, на которую эта точка проецируется.

Если необходимо задать направление проецирования, нажмите кнопку Направляющий объект на Панели свойств или вызовите из контекстного меню команду Выбрать направляющий объект. Затем укажите направляющий объект или постройте вектор.

Подробнее...


Команда ТочкаПостроение способом По сфере (RAB)

Команда Точка
Построение способом По сфере (RAB)

Данный способ позволяет задать положение точки путем ввода ее сферических координат (R, A, B) или связи ее с существующим в модели точечным объектом.

Пример

Построение точки по сферическим координатам;
XYZ — система координат точки

Способ можно сделать текущим, выбрав название По сфере (RAB) из списка Способ на Панели свойств или контекстного меню команды Точка.

– Чтобы построить в модели точку, укажите положение точки путем ввода координат на Панели свойств или при помощи мыши.
Для задания радиуса сферы можно ввести нужное значение в поле координаты R или, активизировав переключатель Объект радиуса, указать объект, определяющий радиус.

– Чтобы создаваемая точка была связана с объектом, включите опцию Ассоциировать на Панели свойств и укажите в модели точечный объект — вершину или точку.

После завершения построения первой точки система ожидает задания положения следующей точки.

При редактировании можно как установить, так и отменить связь точки с объектами.

– Чтобы связать точку с объектом, укажите точечный объект при включенной опции Ассоциировать.

– Чтобы отменить связь с объектом, нажмите кнопку Объект. Ассоциативная связь будет удалена («галочка» на кнопке исчезнет), точка останется в прежнем положении с зафиксированными координатами.

– Чтобы отменить связь с объектом, определяющим радиус сферы, укажите этот объект повторно при нажатом переключателе Объект радиуса.

Подробнее о построении точки по цилиндру и сфере...


Команда Присоединительная точка

Позволяет построить в модели присоединительную точку.

1. Для вызова команды нажмите кнопку Присоединительная точка на панели Вспомогательная геометрия.

2. Выберите тип присоединительной точки — с одной осью или с двумя осями — с помощью группы переключателей Тип на вкладке Параметры Панели свойств.

3. Выберите способ построения присоединительной точки из списка Способ и задайте соответствующие способу параметры. Доступны два способа построения точки:

– По объекту,

– Ручное задание направления осей.

Все изменения положения и направления осей присоединительной точки немедленно отображаются на фантоме.

4. При необходимости используйте следующие возможности:

– Отмена сразу всех объектов, заданных для построения точки. Для этого нажмите кнопку Указать заново на Панели специального управления.

Сменить объекты при построении присоединительной точки способом Ручное указание направления осей можно следующим образом:

– Для смены точечного объекта просто укажите новый точечный объект.

– Для смены направляющего объекта активизируйте нужный переключатель — Объект 1 или Объект 2, а затем постройте вектор или укажите новый направляющий объект. Если точка имеет одну ось, то активизация переключателя не требуется — построенный вектор или указанный прямолинейный или плоский объект автоматически воспринимается как направляющий.

– Изменение наименования и цвета создаваемой присоединительной точки на вкладке Свойства Панели свойств.

5. Нажмите кнопку Создать объект на Панели специального управления.

Созданная присоединительная точка появляется в окне модели, а ее пиктограмма — в Дереве построения.

После завершения построения первой присоединительной точки система ожидает указания объекта для создания следующей точки.

Для выхода из команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.


Команда Контрольная точка

Позволяет построить в модели контрольную точку.

Для вызова команды нажмите кнопку Контрольная точка на панели Вспомогательная геометрия.

Фантом точки отображается в окне модели. По умолчанию новая контрольная точка совмещена с началом текущей локальной системы координат.

Укажите существующий в модели точечный объект, с которым будет совпадать контрольная точка. Название точечного объекта появится в поле Точка на вкладке Параметры Панели свойств.

Если в модели нет нужного точечного объекта, вы можете создать его, не выходя из команды. Для этого нажмите кнопку Построение точки на Панели специального управления.

Чтобы быстро вернуть контрольную точку в исходное положение, нажмите кнопку Указать заново на Панели специального управления. Исходным положением точки является начало системы координат объекта.

Вы можете задать название и цвет присоединительной точки на вкладке Свойства Панели свойств.

Чтобы подтвердить создание контрольной точки, нажмите кнопку Создать объект на Панели специального управления.

Пиктограмма контрольной точки появится в Дереве построения.


Команда Произвольный вид...

Позволяет выбрать существующую трехмерную модель и создать в активном документе ассоциативный вид с этой модели.

Для вызова команды нажмите кнопку Произвольный вид... на инструментальной панели Виды или выберите ее название в меню Вставка — Вид с модели.

На экране появится диалог, в котором следует выбрать модель.

Если выбранная модель содержит исполнения, то в диалоге можно указать обозначение нужного исполнения. Если для исполнений в модели созданы дополнительные номера, то вы также можете выбрать нужный дополнительный номер.

Списки исполнений и дополнительных номеров отображаются в диалоге при выборе модели, содержащей исполнения и дополнительные номера.

После того как модель выбрана, в окне чертежа показывается фантом изображения в виде габаритного прямоугольника вида.

Настройка параметров вида

Настройка отрисовки линий

Настройка надписи вида

Настройка передачи объектов и элементов оформления

В поле Файл-источник отображается полное имя файла выбранной модели. Чтобы указать другую модель, вид которой требуется разместить в чертеже, нажмите кнопку Выбрать другую модель и укажите нужный файл в появившемся на экране диалоге открытия файлов.

Если выбранная модель содержит исполнения и дополнительные номера, то вы можете указать обозначение нужного исполнения и дополнительный номер в соответствующих списках диалога.

Вы также можете выбрать другое исполнение модели из списка Исполнение, расположенного на Панели свойств.

По умолчанию система предлагает создание вида спереди. Вы можете указать для построения любой другой вид модели, а также создать проекцию модели в пользовательской ориентации. Для этого разверните список Ориентация модели и выберите нужную строку.

Переключатель Разнести позволяет отобразить сборку в разнесенном виде. Этот переключатель доступен, если в выбранной сборочной модели настроены параметры разнесения.

Переключатель Развертка позволяет отобразить листовое тело в разогнутом виде. Этот переключатель доступен, если в выбранной детали имеется листовое тело и настроены параметры развертки.

С помощью переключателя Слои в вид можно передать слои, группы слоев и фильтры слоев, имеющиеся в модели. Подробне...

После настройки вида задайте его угол поворота и положение точки привязки.

Если в модели имеются несохраненные изменения, то при создании ее ассоциативного вида на экране появляется запрос на сохранение модели. Нажмите кнопку Да, чтобы немедленно сохранить файл модели или кнопку Нет, чтобы отказаться от сохранения. В любом случае в ассоциативном виде создается изображение модели в ее текущем виде.

Чтобы отказаться от создания произвольного вида, нажмите кнопку Прервать команду на Панели специального управления.

Смотрите также

Другие виды


Команда Вид по стрелке

Позволяет построить дополнительный вид по направлению взгляда, показанного на чертеже стрелкой.

Для построения вида по стрелке требуется наличие в его опорном виде стрелки, показывающей направление взгляда. Если стрелки нет, создайте ее при помощи команды Стрелка взгляда. Кнопка для ее вызова находится на инструментальной панели Обозначения.

Необходимым условием корректного построения вида по стрелке является расположение стрелки именно в его опорном виде. Поэтому при создании стрелки взгляда проследите, чтобы текущим был соответствующий вид.

Команда Вид по стрелке запускается автоматически после простановки в ассоциативном виде стрелки взгляда.

Если вы прервали выполнение автоматически запущенной команды, то, чтобы построить вид по стрелке, вызовите команду Вид по стрелке вручную. Для этого нажмите кнопку Вид по стрелке на инструментальной панели Виды или выберите ее название в меню Вставка — Вид с модели. Затем укажите стрелку взгляда.

На экране появится фантом габаритного прямоугольника вида по стрелке.

Вид по стрелке располагается в проекционной связи со своим опорным видом, что ограничивает возможность его перемещения.

При необходимости проекционную связь можно отключить. Для этого нажмите кнопку Проекционная связь на вкладке Параметры.

Настройка параметров вида

Настройка отрисовки линий

Настройка надписи вида

Настройка передачи объектов и элементов оформления

После настройки вида укажите точку его привязки. Если проекционная связь отключена, возможно также задание угла поворота вида.

Переключатель Разнести позволяет отобразить сборку в разнесенном виде. Этот переключатель доступен, если в выбранной сборочной модели настроены параметры разнесения.

Переключатель Развертка позволяет отобразить листовое тело в разогнутом виде. Этот переключатель доступен, если в выбранной детали имеется листовое тело и настроены параметры развертки.

С помощью переключателя Слои в вид можно передать слои, группы слоев и фильтры слоев, имеющиеся в модели. Подробне...

Вид по стрелке автоматически строится с разрывом, если опорный вид имеет разрыв.

Чтобы отказаться от создания вида по стрелке, нажмите кнопку Прервать команду на Панели специального управления.

Смотрите также

Другие виды


Команда Разрыв вида

Позволяет работать с разрывами изображения вида — создавать, редактировать или удалять разрывы. Команда может быть применена к любому, кроме системного, виду чертежа.

При создании видов с разрывами рекомендуется следующий порядок работы в нем:

– создание в виде всех геометрических объектов;

– построение в виде требуемого количества разрывов с помощью команды Разрыв вида;

– при работе с ассоциативными видами — создание видов, использующих вид с разрывом в качестве опорного;

– добавление в вид объектов оформления: размеров, обозначений, надписей и т.п.

Для вызова команды нажмите кнопку Разрыв вида на инструментальной панели Виды или выберите ее название в меню Вставка.

На экране появляются параллельные линии — границы разрыва, а на Панели свойств — элементы управления, позволяющие настроить параметры разрыва.

Разрыв, если он первый в виде, добавляется автоматически. Чтобы добавить новый разрыв, нажмите кнопку Добавить на панели Разрывы Панели свойств. В списке на панели Разрывы появляется строка Разрыв N.

Переместите мышью характерные точки границ разрыва, ограничивая часть изображения, которую нужно удалить.

Задайте угол, тип линии, зазор и амплитуду (для волнистой линии или линии с изломами) при помощи элементов управления на Панели свойств.

Чтобы отредактировать разрыв, сделайте его текущим щелчком мыши в списке на панели Разрывы, затем измените параметры и положение границ разрыва.

Чтобы удалить текущий разрыв из вида, нажмите кнопку Удалить.

Направления сдвига разрывов одного и того же вида могут быть только параллельны или перпендикулярны друг другу. Подробнее...

Чтобы подтвердить изменения, нажмите кнопку Создать объект на Панели специального управления.

Подробнее о создании разрыва...

Особенности работы с разрывами изображений

В контекстном меню вида с разрывом в Дереве чертежа доступна команда Показать разрывы, позволяющая управлять отображением разрывов.

Смотрите также

Другие виды

Автоматическое создание разрыва в ассоциативном виде


Показать разрывы

Опция, включение которой означает, что текущий вид будет отображаться с разрывами. При отключенной опции изображение в виде показывается полностью.

Вид может отображаться либо полностью — без всех разрывов, либо со всеми разрывами, которые в нем созданы. Отключить какой-либо один из разрывов невозможно.

Для включения и выключения отображения разрывов можно использовать команду Показать разрывы.


Команда Управление сечениями...

Позволяет выполнять различные действия с сечениями модели: создать, изменить и удалить сечение, выбрать текущее сечение, включить/отключить режим сечения модели.

Для вызова команды выберите ее название из меню Вид — Сечение модели или меню кнопки Сечение модели на панели Вид.

После вызова команды на экране появляется диалог Сечения модели, в котором выполняются указанные выше действия.


Команда Производные размеры

Позволяет представить размеры эскизов и операций в виде элементов оформления. В результате в окне модели появляются производные размеры, соответствующие размерам эскизов и операций. В Дереве построения производные размеры отображаются подчиненными эскизам и операциям.

Производные размеры можно передать в чертеж при создании в нем ассоциативных видов модели. Переданные в чертеж размеры являются проекционными обозначениями.

Для вызова команды нажмите кнопку Производные размеры на инструментальной панели Элементы оформления или выберите ее название из меню Операции — Элементы оформления.

1. Выделите в Дереве построения объекты, размеры которых требуется отобразить в виде элементов оформления, или укажите в окне модели любой примитив объектов: грань, ребро или вершину.

Выбор объектов в окне модели
Выбор объектов в Дереве построения

Объекты могут быть выделены и перед вызовом команды.

На панели Список объектов появляются наименования выбранных объектов.

Повторное указание объекта отменяет его выбор.

2. Включите опцию Размеры с нулевым значением, если требуется создать производные размеры для размеров операций с нулевым значением.

3. Чтобы сменить объекты, размеры которых нужно отобразить в виде элементов оформления, нажмите кнопку Указать заново на Панели специального управления и повторите выбор объектов.

4. Чтобы подтвердить выполнение операции, нажмите кнопку Создать объект на Панели специального управления.

Размер эскиза, не имеющий переменную, нельзя представить в виде элемента оформления.

Размеры выбранных объектов в виде производных размеров появляются в Дереве построения и в окне модели.

Обратите внимание на то, что управляющие размеры эскизов и операций, представленные как элементы оформления, сохраняют свой тип, т.е. остаются управляющими.

Если требуется прервать операцию до ее завершения, нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Размеры, проставленные вручную


Команда Создать исполнение

Позволяет создать новое исполнение модели из исполнения, уже имеющегося в документе.

Команда вызывается следующими способами:

– в Дереве исполнений — из контекстного меню выбранного исполнения модели,

– в Дереве построения — из контекстного меню корневого объекта Дерева (объекты, отображаемые в Дереве построения, входят в состав текущего исполнения модели), а при работе со сборкой также из контекстного меню компонента в процессе его редактирования «на месте».

Команда доступна для всех исполнений, кроме зеркальных.

Выбранное исполнение модели будет исходным для создания нового исполнения.

После вызова команды на Панели свойств появляются вкладки Параметры и Свойства.

Вкладка Параметры содержит следующие элементы управления.

– Поле Обозначение — позволяет сформировать обозначение исполнения.

По умолчанию обозначение включает в себя базовое обозначение и код, переданные из исходного исполнения, а также автоматически сформированный номер.

При необходимости автоматическое формирование номеров обозначения можно отключить при настройке.

Поле Обозначение недоступно для ручного ввода. Чтобы изменить обозначение, щелкните мышью в поле и произведите необходимые изменения в диалоге Обозначение.

Вы также можете выбрать обозначение из внешнего справочника (Классификатор ЕСКД). Для этого нажмите кнопку Выбор из справочника. Справочник должен быть подключен к КОМПАС-3D.

Обратите внимание на то, что номер исполнения должен быть уникальным в пределах документа. В противном случае новое исполнение не будет создано.

– Опция Зависимое исполнение — позволяет выбрать вариант создания исполнения. Если опция включена, создается зависимое исполнение, если опция отключена — независимое.

Подробнее о зависимых и независимых исполнениях...

– Опция Зеркальное исполнение — позволяет создать зависимое зеркальное исполнение. Присутствует на Панели свойств, если исходное исполнение еще не имеет зависимых зеркальных исполнений. Опция доступна при включенной опции Зависимое исполнение.

– Поле Комментарий — позволяет ввести дополнительные сведения об исполнении.

Вкладка Свойства содержит раскрывающийся список выбора цвета исполнения и панель настройки его оптических свойств.

Завершите создание исполнения одним из следующих способов.

– При создании обычного исполнения модели, а также зеркального исполнения модели, не содержащей компоненты, нажмите кнопку Создать объект на Панели специального управления.

– При создании зеркального исполнения модели, содержащей компоненты, вместо кнопки Создать объект на Панели специального управления отображается кнопка Продолжить создание исполнения. Нажмите эту кнопку. На экране появится диалог, позволяющий настроить параметры отражения компонентов, входящих в модель. Выполните необходимые действия и завершите создание зеркального исполнения, нажав кнопку ОК в диалоге или кнопку Создать объект на Панели специального управления.

В Дереве исполнений появится новое исполнение. Оно будет текущим.

Вы можете отказаться от создания исполнения следующим образом:

– нажав кнопку Прервать команду на Панели специального управления,

– нажав кнопку Отмена в диалоге настройки параметров отражения компонентов при создании зеркального отражения модели с компонентами.

Смотрите также

Создание исполнения

Обозначение и наименование исполнения


Команда Применить в зависимых исполнениях(меню Окна переменных)

Команда Применить в зависимых исполнениях
(меню Окна переменных)

Позволяет передать в зависимые исполнения пользовательскую переменную, созданную в исходном исполнении, т.е. создать идентичную переменную во всех зависимых исполнениях исходного исполнения.

Команда присутствует в контекстном меню пользовательской переменной текущего исполнения, если оно имеет зависимые исполнения.

Смотрите также

Пользовательская переменная в исполнении


Команда Создать локальный фрагмент

Позволяет создать локальный фрагмент.

Для вызова команды нажмите кнопку Создать локальный фрагмент на инструментальной панели Вставки и макроэлементы.

После вызова команды КОМПАС открывает новое окно, в котором можно создавать и редактировать содержимое локального фрагмента.

При закрытии окна локального фрагмента система запрашивает имя, под которым этот фрагмент будет сохранен внутри документа.

Одновременно может редактироваться только один локальный фрагмент документа.

Смотрите также

Общие сведения о фрагментах


Команда Местный разрез

Позволяет построить местный разрез или сечение модели.

Для вызова команды нажмите кнопку Местный разрез на инструментальной панели Виды или выберите ее название в меню Вставка — Вспомогательный вид.

Укажите в опорном виде замкнутый контур, ограничивающий местный разрез.

Необходимым условием корректного построения местного разреза является расположение контура именно в его опорном виде. Поэтому при создании контура проследите, чтобы текущим был соответствующий вид.

Контур не должен иметь самопересечений.

Создание местных разрезов на выносных элементах невозможно.

При необходимости введите номер и имя местного разреза в одноименные поля на Панели свойств. Кнопка Секущая плоскость доступна при отключенном автосоздании объектов, а также при редактировании ранее созданного местного разреза. Она позволяет заново указать положение секущей плоскости.

Переключатели группы Разрез/сечение позволяют выбрать тип изображения: разрез или сечение.

Эта группа доступна, если вид, на котором базируется местный разрез, не является разрезом (сечением). В противном случае тип изображения совпадает с типом изображения в опорном виде, и переключение невозможно.

Настройка параметров штриховки

На экране появится фантом прямой линии — след секущей плоскости. Обратите внимание на то, что этот фантом виден, когда курсор проходит над видом, плоскость проекций которого перпендикулярна плоскости проекций вида, на котором базируется местный разрез.

Укажите положение секущей плоскости.

Местный разрез будет построен. Его пиктограмма появится на ветви Дерева чертежа, соответствующей опорному виду.

По умолчанию все детали, попавшие в секущую плоскость, показываются в разрезе. При необходимости вы можете сделать некоторые из них неразрезаемыми.

При необходимости вы можете отключить отображение местного разреза на его опорном виде. Для этого в Дереве чертежа вызовите контекстное меню на местном разрезе, показ которого требуется отключить. Вызовите из меню команду Местный разрез.

При отключении показа местного разреза ограничивающая его кривая по-прежнему остается на экране.

Чтобы вновь включить отображение местного разреза, вызовите команду Местный разрез повторно.

Смотрите также

Другие виды


Команда Местный вид

Позволяет построить изображение отдельного, ограниченного места поверхности модели.

Для вызова команды нажмите кнопку Местный вид на инструментальной панели Виды или выберите ее название в меню Вставка — Вспомогательный вид.

Укажите в опорном виде замкнутый контур, ограничивающий местный вид. Содержимое вида, находящееся вне пределов указанного контура, перестает отображаться на экране.

Чтобы вновь включить полное изображение вида, вызовите контекстное меню на нем в Дереве чертежа и выберите команду Местный вид.

Необходимым условием корректного построения местного вида является расположение ограничивающего его контура именно в опорном виде. Поэтому при создании контура проследите, чтобы текущим был соответствующий вид.

Смотрите также

Другие виды


Команда Выносной элемент (панель Виды)

Команда Выносной элемент
(панель Виды)

Позволяет построить вид, содержащий изображение выносного элемента.

Для построения вида-выносного элемента требуется наличие в его опорном виде обозначения выносного элемента. Если обозначения нет, создайте его при помощи команды Выносной элемент. Кнопка для ее вызова находится на инструментальной панели Обозначения.

Необходимым условием корректного построения вида, содержащего выносной элемент, является расположение обозначения выносного элемента именно в его опорном виде. Поэтому при создании обозначения проследите, чтобы текущим был соответствующий вид.

Команда Выносной элемент запускается автоматически после простановки в виде обозначения выносного элемента.

Если вы прервали выполнение автоматически запущенной команды, то, чтобы построить вид-выносной элемент, вызовите команду Выносной элемент вручную. Для этого нажмите кнопку Выносной элемент на инструментальной панели Виды или выберите ее название в меню Вставка — Выносной элемент. Затем укажите обозначение выносного элемента.

На экране появится фантом габаритного прямоугольника вида.

Настройка параметров вида

Настройка отрисовки линий

Настройка надписи вида

После настройки вида задайте его угол поворота и положение точки привязки.

Чтобы отказаться от создания выносного элемента, нажмите кнопку Прервать команду на Панели специального управления.

Смотрите также

Другие виды


Выбор плоскости/центра симметрии компонента в окне Модели-источника

Процесс выбора плоскости/центра симметрии компонента позволяет вручную указать объект, используемый для расчета положения компонента при его отражении способом Симметричное расположение компонента.

Данный процесс запускается после нажатия кнопки Указать плоскость или точку в компоненте в группе элементов Положение: диалога Параметры зеркального отражения компонентов.

Указание объекта выполняется в Окне модели — источника компонента.

Вид Окна модели-источника и работа в нем

Укажите нужный объект. Положение фантома компонента в окне модели изменится. Наименование выбранного объекта появится в поле Объект Панели свойств. При необходимости вы можете выбрать другой объект, указав его в Окне модели-источника. Для завершения выбора нажмите кнопку Применить на Панели специального управления.

Кнопка Прервать команду позволяет отказаться от выбора объекта.

В процессе ручного указания объекта диалог настройки параметров отражения компонентов не показывается на экране.


Команда Эквидистанта грани

Позволяет создать сплайновую поверхность, эквидистантную редактируемой грани, и изменить ее форму и положение.

Команда вызывается в специальном режиме редактирования грани, который запускается командой Сплайновая форма.

Для вызова команды создания эквидистантной поверхности нажмите кнопку Эквидистанта грани на Панели специального управления. Будет создана сплайновая поверхность, эквидистантная редактируемой грани. Она совпадает с этой гранью, т.е. расстояние между гранью и ее эквидистантой равно нулю.

Редактирование эквидистанты грани выполняется теми же способами, что и редактирование грани.

При нажатой кнопке Эквидистанта грани все действия, произведенные в режиме редактирования грани применяются к ее эквидистанте. При необходимости вы можете вернуться к редактированию грани. Для этого отожмите кнопку Эквидистанта грани.

Подробнее о построении сплайновой формы на эквидистанте грани...


Команда Проекционный вид

Позволяет построить вид по направлению, указанному относительно другого — опорного — вида.

Для вызова команды нажмите кнопку Проекционный вид... на инструментальной панели Виды или выберите ее название в меню Вставка — Вид с модели.

Укажите в окне чертежа опорный вид для создания проекционного вида. Затем начинайте перемещать курсор (он превратится в изображение начала системы координат) в направлении, соответствующем виду, который требуется создать. Например, для получения вида справа курсор необходимо перемещать слева направо, вида сверху — сверху вниз и т.д. В окне чертежа появится фантом изображения в виде габаритной рамки вида. При движении курсора фантом будет перемещаться. Перемещение фантома нового вида ограничено существованием проекционных связей между ним и главным видом: виды сверху и снизу могут перемещаться только по вертикали, виды справа и слева — только по горизонтали.

При необходимости проекционную связь можно отключить. Для этого нажмите кнопку Проекционная связь на вкладке Параметры.

Настройка параметров вида

Настройка отрисовки линий

Настройка надписи вида

Настройка передачи объектов и элементов оформления

После настройки параметров нового проекционного вида укажите положение его точки привязки. Если проекционная связь отключена, возможно также задание угла поворота вида.

Переключатель Разнести позволяет отобразить сборку в разнесенном виде. Этот переключатель доступен, если в выбранной сборочной модели настроены параметры разнесения.

Переключатель Развертка позволяет отобразить листовое тело в разогнутом виде. Этот переключатель доступен, если в выбранной детали имеется листовое тело и настроены параметры развертки.

С помощью переключателя Слои в вид можно передать слои, группы слоев и фильтры, имеющиеся в модели. Подробне...

Проекционный вид автоматически строится с разрывом, если опорный вид имеет разрыв.

Чтобы отказаться от создания проекционного вида, нажмите кнопку Прервать команду на Панели специального управления.

Смотрите также

Другие виды


Команда Разрез/сечение

Позволяет построить разрез или сечение модели.

Для построения разреза/сечения требуется наличие в его опорном виде линии разреза/сечения. Если линии нет, создайте ее при помощи команды Линия разреза. Кнопка для ее вызова находится на инструментальной панели Обозначения.

Необходимым условием корректного построения разреза/сечения является расположение обозначения линии разреза именно в опорном виде. Поэтому при создании обозначения проследите, чтобы текущим был соответствующий вид.

Команда Разрез/сечение запускается автоматически после простановки в ассоциативном виде линии разреза/сечения.

Если вы прервали выполнение автоматически запущенной команды, то, чтобы построить разрез/сечение, вызовите команду Разрез/сечение вручную. Для этого нажмите кнопку Разрез/сечение на инструментальной панели Виды или выберите ее название в меню Вставка — Вид с модели.

На экране появится фантом габаритного прямоугольника вида.

Переключатель Разрез/сечение на Панели свойств позволяет выбрать тип изображения: разрез или сечение.

Разрез (сечение) располагается в проекционной связи со своим опорным видом, что ограничивает возможность его перемещения.

При необходимости проекционную связь можно отключить. Для этого нажмите кнопку Проекционная связь на вкладке Параметры.

Настройка параметров вида

Настройка отрисовки линий

Настройка надписи вида

Настройка передачи объектов и элементов оформления

Настройка параметров штриховки

После настройки вида укажите положение точки привязки изображения. Если проекционная связь отключена, возможно также задание угла поворота вида.

Кнопка Разнести позволяет создать разнесенное изображение сборки. Эта кнопка доступна, если в выбранной модели заданы параметры разнесения.

С помощью переключателя Слои в вид можно передать слои, группы слоев и фильтры слоев, имеющиеся в модели. Подробне...

Разрез/сечение автоматически строится с разрывом, если рассекаемая область опорного вида имеет разрыв.

Чтобы отказаться от создания разреза или сечения, нажмите кнопку Прервать команду на Панели специального управления.

Смотрите также

Другие виды


Создавать объекты спецификации

Опция, которая управляет созданием в сборке внутреннего объекта спецификации, соответствующего компоненту.

Объект (объекты) спецификации формируется в детали или подсборке при ее создании или редактировании и хранится внутри файла этой модели. При вставке модели в сборку ее объект спецификации включается в число внутренних объектов спецификации сборки.

Если в файле компонента нет объекта спецификации, то в сборке создается объект спецификации на основе данных (обозначение, наименование, масса) в свойствах этого компонента.

По умолчанию опция Создавать объект спецификации включена, и объект спецификации, соответствующий компоненту, передается в сборку (или создается в ней).

При отключенной опции Создавать объекты спецификации объект спецификации не передается из файла компонента и не создается на основе свойств компонента.

Объект спецификации для компонента, вставленного из Библиотеки Стандартные Изделия, создается, если это включено при настройке Библиотеки (умолчательный вариант настройки).


Опция Создавать объекты спецификации

Позволяет формировать в чертеже объект (объекты) спецификации, соответствующие выбранному компоненту вида. Эти объекты должны быть сформированы в компоненте при его создании.

Если компонент — деталь, то в чертеж передается имеющийся в ней объект спецификации.

Если компонент — сборка, то в чертеж передаются все внутренние объекты спецификации этой сборки.

Включение или отключение опции возможно только для компонентов первого уровня, т.е. для деталей и сборок, непосредственно подчиненных виду в Дереве документа.

По умолчанию опция включена, если на данном рабочем месте разрешена работа со спецификацией, и выключена в противном случае.


Команда Неуказанная шероховатость

Позволяет включить или отключить отображение неуказанной шероховатости в окне модели. Если модель имеет исполнения, то для каждого из них можно включить или отключить отображение неуказанной шероховатости.

Для вызова команды выберите ее название в меню Вид или в контекстном меню окна модели.

Подробнее о неуказанной шероховатости...


Команда Стандартные виды...

Позволяет выбрать существующую (сохраненную на диске) трехмерную модель и создать в активном документе чертеж этой модели, состоящий из одного или нескольких стандартных ассоциативных видов.

Для вызова команды нажмите кнопку Стандартные виды... на инструментальной панели Виды или выберите ее название в меню Вставка — Вид с модели.

На экране появится диалог, в котором следует выбрать модель.

Если выбранная модель содержит исполнения, то в диалоге можно указать обозначение нужного исполнения. Если для исполнений в модели созданы дополнительные номера, то вы также можете выбрать нужный дополнительный номер.

Списки исполнений и дополнительных номеров отображаются в диалоге при выборе модели, содержащей исполнения и дополнительные номера.

После того как модель выбрана, в окне чертежа показывается фантом изображения в виде габаритных прямоугольников видов.

Кнопка Схема видов на вкладке Параметры Панели свойств позволяет изменить набор стандартных видов выбранной модели. Взаимное расположение видов зависит от проекционного метода. Выбор проекционного метода выполняется в диалоге настройки параметров вида.

Настройка параметров вида

Настройка отрисовки линий

В поле Файл-источник отображается полное имя файла выбранной модели. С помощью кнопки Выбрать другую модель вы можете указать другой файл модели, виды которой требуется разместить в чертеже.

Если выбранная модель содержит исполнения и дополнительные номера, то вы можете указать обозначение нужного исполнения и дополнительный номер в соответствующих списках диалога выбора файла модели.

Вы также можете выбрать другое исполнение модели из списка Исполнение, расположенного на Панели свойств.

При создании стандартных видов вы может воспользоваться автоматическим подбором масштаба. Для этого нажмите кнопку Подобрать. Из стандартного ряда будет выбран масштаб, при котором все виды, указанные для построения, полностью умещаются на чертеже выбранного формата. При подборе коэффициента масштабирования учитываются области чертежа, занятые основной надписью и другими элементами оформления.

С помощью переключателя Слои в вид можно передать слои, группы слоев и фильтры слоев, имеющиеся в модели. Подробне...

После выбора нужных стандартных видов и их настройки укажите положение точки привязки изображения — начала координат главного вида.

В активный документ будут вставлены виды модели, в основную надпись чертежа передадутся следующие сведения из документа-модели:

– обозначение

– наименование

– масса

– материал.

Ячейка «Материал» заполняется только в основных надписях чертежей деталей.

В Дереве чертежа появятся пиктограммы созданных видов и их названия.

Виды располагаются в проекционной связи, что ограничивает возможность их взаимного перемещения. Если возникнет необходимость произвольного расположения видов, проекционную связь между ними и главным видом можно отключить.

Если в модели имеются несохраненные изменения, то при создании ее ассоциативного вида на экране появляется запрос на сохранение модели. Нажмите кнопку Да, чтобы немедленно сохранить файл модели или кнопку Нет, чтобы отказаться от сохранения. В любом случае в ассоциативном виде создается изображение модели в ее текущем виде.

Отключение проекционной связи между видами

Смотрите также

Другие виды


Разнесенный вид

Переключатель, управляющий изображением сборки в разнесенном виде. Этот переключатель доступен, если в выбранной сборочной модели настроены параметры разнесения.


Проекционная связь

Переключатель, управляющий проекционной связью между ассоциативными видами.


Команда Схема видов

Позволяет изменить набор видов, предлагаемый по умолчанию.

После вызова команды на экране появляется диалог, в котором можно указать, какие стандартные виды модели требуется создать в чертеже.


Команда Изменить файл-источник

Позволяет выбрать другую модель для изображения в чертеже.

После вызова команды на экране появляется стандартный диалог выбора фалов, в котором нужно указать нужный файл модели.


Развертка

Переключатель, управляющий изображением листового тела в развернутом виде. Этот переключатель доступен, если в выбранной детали имеется листовое тело и настроены параметры развертки.


Команда Линия-выноска объекта

Позволяет создать и добавить к объекту одну или несколько линий-выносок. В результате работы команды линии-выноски становятся частью объекта, но при этом могут редактироваться отдельно.

Объектами, к которым может быть добавлена линия-выноска, являются:

– макроэлементы (в том числе библиотечные),

– вставки фрагментов,

– вставки изображений из видов других чертежей.

Примеры объектов с линиями-выносками

Чтобы создать и добавить к объекту линию выноску, выполните следующие действия.

1. Выделите один объект, которому необходимо задать линию-выноску. Команда доступна также в режиме редактирования макроэлемента.

2. Нажмите кнопку Линия-выноска объекта на панели Вставки и макроэлементы или выберите название команды из контекстного меню объекта в окне документа или в Дереве чертежа.

3. Задайте начальную точку первого ответвления.

Задайте точку присоединения линии-выноски к объекту т1.

Точка т1 связывается с объектом: в дальнейшем, при его редактировании она отображается как одна из характерных точек, перемещение которой перемещает весь объект. В некоторых случаях может оказаться удобным совмещение точки присоединения линии-выноски с точкой перемещения объекта. В то же время некоторые библиотечные макроэлементы могут иметь характерные точки для управления размерами. Присоединение линии-выноски к одной из таких точек нежелательно, так как в этом случае она потеряет свою функцию.

Затем задайте начальные точки остальных ответвлений. Их количество не ограничено.

4. Настройте параметры отрисовки, как для обычной линии-выноски. Следует учитывать, что при добавлении линии-выноски к объекту на Панели свойств отсутствуют элементы управления для полки и надписи.

На экране отображается фантом создаваемой линии-выноски.

По умолчанию при создании линии-выноски включен режим добавления ответвлений. Об этом свидетельствует нажатая кнопка Добавить ответвления на Панели специального управления. В этом режиме каждая вновь указанная точка воспринимается системой как начальная точка очередного ответвления.

В режиме редактирования характерных точек объекта можно внести изменения в конфигурацию линии-выноски. Добавление ответвлений в этом режиме невозможно. Для перехода в режим редактирования нажмите кнопку Редактировать точки на Панели специального управления.

Между режимами можно произвольно переключаться при помощи кнопок Панели специального управления или команд в контекстном меню. При выходе из одного режима автоматически включается другой.

Чтобы зафиксировать изображение, нажмите кнопку Создать объект на Панели специального управления.

Чтобы добавить к объекту следующую линию-выноску, вызовите команду Линия-выноска объекта повторно.

В качестве привязки линии-выноски удобно использовать характерную точку макроэлемента. Для этого войдите в режим его редактирования, задайте для него характерную точку и, не выходя из режима, постройте линию-выноску из этой точки.

Смотрите также

Редактирование и удаление линии-выноски

Добавление ответвлений линии-выноски


Команда Создать новый вид

Позволяет создать в активном чертеже новый вид.

Для вызова команды нажмите кнопку Создать новый вид на инструментальной панели Виды или выберите ее название в меню Вставка.

Если Дерево чертежа находится на экране, то команда Создать новый вид может быть вызвана из контекстного меню первого элемента Дерева.

Элементы управления, расположенные на вкладке Параметры Панели свойств позволяют настроить параметры вида.

В поле Номер отображается номер вида, автоматически присвоенный ему системой. Если необходимо, введите в это поле другое значение.

В поле Имя отображается имя вида, автоматически присвоенное ему системой. Если необходимо, введите в это поле другой текст. Содержимое поля Имя отображается в Дереве чертежа.

Список Цвет позволяет выбрать цвет вида в активном состоянии.

В поле Масштаб можно ввести произвольный масштаб создаваемого изображения в виде отношения любых чисел. Вы можете также выбрать масштаб вида из стандартного ряда. Для этого разверните список Масштаб и выделите нужную строку.

Группа переключателей Точка вида позволяет выбрать положение базовой точки вида: в центре габаритного прямоугольника или в начале координат.

Задайте угол поворота вида и положение его точки привязки.

Настройка надписи вида

Чтобы отказаться от создания вида, нажмите кнопку Прервать команду на Панели специального управления.

Смотрите также

Другие виды


Список сечений модели

Список содержится в меню кнопки Сечение модели на панели Вид. Он включает в себя все сечения, созданные в модели. Сечения расположены в списке в порядке их создания.

Текущее сечение обозначено «галочкой». Чтобы сделать текущим другое сечение, щелкните по его наименованию в списке. Для выбора текущего сечения можно также использовать диалог Сечения модели.


Кнопка Настройка отрисовки СК

Вызывает диалог настройки отрисовки локальных систем координат. В нем можно установить параметры отображения осей локальных систем координат.


Команда Разрыв страницы

Позволяет начать следующий абзац на новой странице текстового документа. Для вызова команды выберите ее название из меню Вставка или используйте комбинацию клавиш <Ctrl> + <Enter>.


Команда Управление описаниями спецификаций...

Вызывает на экран диалог управления описаниями спецификаций.

Для вызова команды нажмите кнопку Описания спецификаций на панели Спецификация или выберите ее название из меню Спецификация.


Команда Текущая зона

Позволяет сделать текущей зону, выбранную в Дереве зон.


Команда Кривая по закону

Позволяет построить кривую, задав ее параметрическими уравнениями.

Подробнее о параметрическом представлении кривой...

Кривая относится к объектам, использующим систему координат.

Параметрические уравнения кривой можно задать в прямоугольных, цилиндрических или сферических координатах. По умолчанию кривая строится в прямоугольной системе координат, которая совпадает с системой координат кривой. Цилиндрическая или сферическая система координат размещается относительно системы координат кривой так же, как при построении точки по цилиндрическим или сферическим координатам.

Для вызова команды нажмите кнопку Кривая по закону на инструментальной панели Пространственные кривые или выберите ее название из меню Операции — Пространственные кривые.

На экране появляется фантом создаваемой кривой в умолчательном виде.

Используя переключатели группы Тип координат на Панели свойств, выберите тип координат для построения кривой:

– Прямоугольные X,Y,Z,

– Цилиндрические R,A,Z,

– Сферические R,A,B.

Задайте функции для координат точек кривой.

Все изменения отображаются на фантоме создаваемой кривой в окне модели.

Элементы управления, расположенные на вкладке Свойства Панели свойств, позволяют изменить название и цвет кривой, настроить параметры ее отображения. Также на этой вкладке отображается название системы координат кривой.

Чтобы завершить построение, нажмите кнопку Создать объект на Панели специального управления.

Для выхода из команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Примеры создания кривых по параметрическим уравнениям


Команда Редактировать точки

Позволяет изменить конфигурацию сплайна или ломаной.

После вызова команды система переходит в режим редактирования характерных точек объекта.

Завершив редактирование, отожмите кнопку.


Команда Управление Касательностью и кривизной

Позволяет перейти к управлению формой сплайна в текущей вершине сразу двумя параметрами — величиной касательности и кривизной. Подробнее...

Смотрите также

Управление формой сплайна...


Команда Управление Кривизной

Позволяет перейти к управлению кривизной сплайна в текущей вершине: управление формой сплайна путем задания кривизны или радиуса кривизны. Подробнее...

Смотрите также

Управление формой сплайна...


Команда Управления нет

Позволяет отменить управление формой сплайна в текущей вершине.

Смотрите также

Управление формой сплайна...


Команда Управление Касательностью

Позволяет перейти к управлению касательностью сплайна в текущей вершине: управление формой сплайна путем задания направления вектора касательной и величины касательности. Подробнее...

Смотрите также

Управление формой сплайна...


Команда Кривая по двум проекциям

Позволяет построить кривую на основе двух эскизов, расположенных в непараллельных плоскостях. Линии в эскизах считаются ортогональными проекциями создаваемой кривой на плоскости этих эскизов. Поэтому кривая создается как кривая пересечения двух поверхностей, образованных перемещением заданных проекций в направлениях, перпендикулярных их плоскостям.

Пример

Для вызова команды нажмите кнопку Кривая по двум проекциям на инструментальной панели Пространственные кривые или выберите ее название из меню Операции — Пространственные кривые.

Укажите в окне модели первую проекцию — эскиз или отдельные линии в нем.

Эскиз можно указать в Дереве построения или в окне модели. В последнем случае необходимо предварительно включить фильтр эскизов при помощи команды контекстного меню Фильтровать эскизы. Обратите внимание на то, что этот фильтр действует только в процессе создания кривой по двум проекциям.

Подробнее о фильтрах объектов...

Линии первой проекции могут быть выделены и перед вызовом команды.

Название объекта или количество объектов отображается в поле Проекция 1 на Панели свойств.

Выбор объектов в окне модели

Выбор объектов в Дереве построения

Укажите вторую проекцию — эскиз или отдельные линии в нем. Название объекта или количество объектов отображается в поле Проекция 2.

На экране появляется фантом создаваемой кривой.

Повторное указание объекта отменяет его выбор.

Все изменения отображаются на фантоме кривой.

Создаваемая кривая может состоять из одного или нескольких контуров. Опция Все контуры позволяет выбрать нужные контуры для построения.

Чтобы сменить объекты проекций, нажмите кнопку Указать заново на Панели специального управления и повторите выбор объектов.

Элементы управления, расположенные на вкладке Свойства Панели свойств, позволяют изменить название и цвет кривой, настроить параметры ее отображения.

Чтобы завершить построение, нажмите кнопку Создать объект на Панели специального управления.

Для выхода из команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.


Команда Соединение кривых

Позволяет соединить вершины двух кривых или начальную и конечную вершины одной кривой соединительной кривой. В качестве исходных кривых могут использоваться:

– пространственные кривые;

– ребра тел и поверхностей;

– контуры в эскизе.

Для вызова команды нажмите кнопку Соединение кривых на инструментальной панели Пространственные кривые или выберите ее название из меню Операции — Пространственные кривые.

Укажите исходные кривые в окне модели.

Исходную кривую следует указывать в точке, близкой к той вершине, в которой предполагается соединение с другой кривой.

Если в качестве исходной кривой используется пространственная кривая, то ее можно указать в Дереве построения. В этом случае точкой соединения автоматически выбирается начальная вершина кривой.

Выбор объектов в окне модели

Выбор объектов в Дереве построения

Исходные кривые могут быть выделены и перед вызовом команды.

Для соединения концов одной и той же кривой следует указать ее в окне модели дважды — у начальной и конечной вершины.

В режиме автосоздания объектов (при нажатой кнопке Автосоздание объектов на Панели специального управления) исходные кривые соединяются сразу после их указания. Соединение выполняется с умолчательными параметрами.

Вы можете управлять параметрами соединительной кривой во время ее создания. Для этого после вызова команды отключите режим автосоздания объектов (отожмите кнопку Автосоздание объекта на Панели специального управления).

Укажите исходные кривые.

Выберите условие сопряжения для соединительной и исходных кривых. Для этого раскройте список Условие 1 (или Условие 2) на Панели свойств и укажите в нем нужную строку. Обозначения условий сопряжения отображаются около вершин соединительной кривой.

Задайте натяжение соединительной кривой.

При необходимости смените вершину сопряжения исходной кривой.

Чтобы сменить исходные кривые, нажмите кнопку Указать заново на Панели специального управления и повторите выбор объектов.

Элементы управления, расположенные на вкладке Свойства Панели свойств, позволяют изменить название и цвет соединительной кривой, настроить параметры ее отображения.

Чтобы завершить создание соединительной кривой, нажмите кнопку Создать объект на Панели специального управления.

Для выхода из команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.


Команда Скругление кривых

Позволяет скруглить угол, образованный двумя кривыми. В зависимости от взаимного расположения кривых, скругление выполняется дугой окружности определенного радиуса или сплайном, лежащим на цилиндрической поверхности определенного радиуса.

В качестве исходных кривых могут использоваться:

– пространственные кривые;

– ребра тел и поверхностей;

– контуры в эскизе.

Параллельные отрезки, а также концентрические дуги скруглить нельзя.

Для вызова команды нажмите кнопку Скругление кривых на инструментальной панели Пространственные кривые или выберите ее название из меню Операции — Пространственные кривые.

Укажите исходные кривые в окне модели.

Выбор объектов в окне модели

Исходные кривые следует указывать в точках, близких к предполагаемому месту сопряжения.

На экране появляется фантом скругления — дуга окружности с характерной точкой или цилиндр с характерной точкой и сплайн.

Кривая скругления строится так, чтобы точки касания ее с исходными кривыми находились вблизи точек указания. Радиус скругления кривых определяется автоматически, и его значение отображается в поле Радиус.

Вы можете задать нужный радиус скругления следующими способами:

– ввести значение радиуса в поле Радиус или установить с помощью счетчика;

– «перетащить» мышью характерную точку.

Изменение радиуса отображается на фантоме скругления в окне модели.

По умолчанию включено усечение исходных кривых — активны опции Усекать кривую 1/2. В этом случае для исходной кривой создается копия. Копия кривой усекается в точке касания ее с кривой скругления.

Вы можете отключить усечение. При этом создается только кривая скругления.

Если предложенный системой вариант усечения кривых отличается от ожидаемого, отключите усечение, а для удаления частей кривых воспользуйтесь командой Усечение кривой.

Группа переключателей Дуга позволяет выбрать нужное направление скругления.

Если в качестве исходных кривых указаны ребра одной грани, то вы можете расположить их скругление на этой же грани. Для этого включите опцию По поверхности.

Скругление других кривых, лежащих на грани, можно расположить на ней только в том случае, если кривые являются непосредственно производными по отношению к объекту, содержащему грань.

Элементы управления, расположенные на вкладке Свойства Панели свойств, позволяют изменить название и цвет скругления, настроить параметры его отображения.

Чтобы сменить исходные кривые, нажмите кнопку Указать заново на Панели специального управления и повторите выбор объектов.

Чтобы завершить построение, нажмите кнопку Создать объект на Панели специального управления.

– Если исходные кривые скруглялись с усечением, то ветвь Дерева построения, соответствующая данному скруглению кривых, имеет подчиненные объекты — кривую скругления и усеченные кривые.

– Если исходные кривые скруглялись без усечения, то ветвь Дерева построения, соответствующая данному скруглению кривых, имеет только один подчиненный объект — кривую скругления.

Если после указания исходных кривых на экране не появляется фантом скругления, это означает, что выбранные кривые нельзя скруглить вблизи точек указания. Измените радиус скругления. Если при изменении радиуса фантом скругления не появляется на экране, укажите исходные кривые заново в других точках.


Команда Кривая пересечения поверхностей

Позволяет создать кривую пересечения двух поверхностей, или двух наборов поверхностей, или поверхности и набора.

Для вызова команды нажмите кнопку Кривая пересечения поверхностей на инструментальной панели Пространственные кривые или выберите ее название из меню Операции — Пространственные кривые.

Укажите первый объект пересечения — грань или плоскость.

Выбор объектов в окне модели

Выбор объектов в Дереве построения

Название указанного объекта отображается в поле рядом с переключателем Набор поверхностей 1.

После задания первого объекта пересечения автоматически активизируется переключатель Набор поверхностей 2.

Укажите второй объект пересечения или несколько объектов. Название объекта или количество объектов отображается в поле рядом с переключателем Набор поверхностей 2.

На экране появляется фантом кривой пересечения.

Если требуется добавить объекты в первый набор, активизируйте переключатель Набор поверхностей 1 и укажите нужные объекты. В поле рядом с переключателем отображается количество объектов набора.

Если в текущий набор поверхностей нужно добавить все грани какого-либо тела или поверхности, укажите это тело или поверхность в Дереве построения.

Кривую пересечения координатных плоскостей построить невозможно.

Кривая пересечения может состоять из одного или нескольких непрерывных участков — контуров.

Опция Все контуры позволяет выбрать нужные контуры для построения.

Все изменения отображаются на фантоме кривой пересечения.

Чтобы сменить объекты пересечения, нажмите кнопку Указать заново на Панели специального управления и повторите выбор объектов.

Элементы управления, расположенные на вкладке Свойства Панели свойств, позволяют изменить название и цвет кривой пересечения, настроить параметры ее отображения.

Чтобы завершить построение кривой пересечения, нажмите кнопку Создать объект на Панели специального управления.

Отказаться от построения кривой пересечения можно, нажав кнопку Прервать команду на Панели специального управления или клавишу <Esc>.


Команда Усечение кривой

Вы можете создать усеченную копию кривой.

В качестве исходной кривой может использоваться незамкнутая кривая: пространственная кривая, линия эскиза или ребро.

В качестве секущего объекта может использоваться:

– любой точечный объект, лежащий на усекаемой кривой (точка начала координат, точка в пространстве, вершины контуров в эскизах, отдельные точки в эскизах, вершины пространственных кривых, вершины ребер и т.п.);

– объект, пересекающийся с исходной кривой:

• координатная и вспомогательная плоскость;

• координатная или вспомогательная ось;

• пространственная кривая;

• ребро;

• грань;

• линия эскиза.

Исходная кривая и секущий объект должны иметь общую точку, не совпадающую с вершиной исходной кривой.

Для вызова команды нажмите кнопку Усечение кривой на инструментальной панели Пространственные кривые или выберите ее название из меню Операции — Пространственные кривые.

Укажите исходную кривую в окне модели. Пространственную кривую можно указать в Дереве построения.

Выбор объектов в окне модели

Выбор объектов в Дереве построения

Исходную кривую можно указать и перед вызовом команды.

Укажите секущий объект в окне модели или в Дереве построения.

После выбора исходной кривой и секущего объекта создается копия исходной кривой, которая разбивается точкой пересечения на две части. Та часть копии, которая не содержит точку указания исходной кривой, отображается на экране в виде фантома. Фантом показывает результат усечения исходной кривой. Он ограничен двумя точками: точкой пересечения и концевой точкой, совпадающей с вершиной исходной кривой.

Фантом усеченной кривой

Точка касания копии исходной кривой и секущего объекта считается точкой пересечения.

Переключатель Сменить направление позволяет выбрать для удаления другую часть кривой — противоположную по отношению к точке пересечения.

Сменить направление усечения можно, указав в окне модели любую из концевых точек исходной кривой.

Если исходная кривая и секущий объект имеют несколько общих точек, на экране появляются фантом усеченной кривой и точки пересечения выбранных объектов. В этом случае фантом усеченной кривой ограничен первой точкой пересечения 1 и концевой точкой исходной кривой 2. Вы можете выбрать другие точки 1 и 2, ограничивающие фантом.

– Чтобы задать новую позицию точки 1, укажите нужную точку пересечения в окне модели.

Изменение положения точки 1: а) выбор точки пересечения; б) результат
а) | б)

– Чтобы задать новую позицию точки 2, укажите нужную точку пересечения, удерживая нажатой клавишу <Ctrl>.

Изменение положения точки 2: а) выбор точки пересечения; б) результат
а) | б)

Чтобы сменить исходную кривую и секущий объект, нажмите кнопку Указать заново на Панели специального управления и повторите выбор объектов.

Элементы управления, расположенные на вкладке Свойства Панели свойств, позволяют изменить название и цвет усеченной кривой, настроить параметры ее отображения.

Чтобы завершить создание усеченной кривой, нажмите кнопку Создать объект на Панели специального управления.

Вы можете создать копию кривой, усеченную двумя объектами.


Команда Угловой размер с обрывом

Позволяет проставить угловой размер с обрывом.

Для вызова команды нажмите кнопку Угловой с обрывом на инструментальной панели Размеры. На Панели свойств появятся элементы управления.

Задайте объект, от которого требуется проставить размер (первую сторону угла) и ось симметрии размера (задается так же, как вторая сторона угла). Для этого укажите прямолинейные объекты или точки, при соединении которых образуются стороны угла. Прямолинейные объекты указываются при нажатой кнопке Выбор базового объекта, а точки — при отжатой.

Подробнее об указании сторон углов...

В качестве оси может быть указана вспомогательная прямая.

На Панели свойств отображаются координаты вершины угла, точек т1 и т2.

Если вы случайно ошиблись при выборе объектов, нажмите кнопку Указать заново на Панели специального управления и выберите новые стороны угла.

Управление ориентацией размера

В поле Текст на вкладке Размер Панели свойств отображается автоматически сформированная размерная надпись. Чтобы вызвать диалог редактирования и настройки размерной надписи, щелкните мышью в этом поле.

В списке Размещение текста отображается текущий способ размещения надписи. Если необходимо, смените способ размещения. Подробнее...

Укажите точку т3, определяющую положение размерной линии и ее длину.

Если выбрано размещение текста на полке, укажите точку начала полки т4.

Простановка Углового размера с обрывом
(способ задания стороны и оси симметрии угла — по двум отрезкам)

Выбор вида выносных линий

Настройка параметров размеров (выбор вида стрелки, положения надписи и т.п.).

Смотрите также

Особенности использования команды в параметрическом режиме

Другие размеры

Выравнивание размерных линий

Редактирование углового размера с помощью мыши


Команда Линейный размер с обрывом

Позволяет проставить линейный размер с обрывом.

Для вызова команды нажмите кнопку Линейный с обрывом на инструментальной панели Размеры.

Укажите курсором отрезок, который будет базовым для размера с обрывом. Выбранный объект будет подсвечен.

– Если на изображении есть ось симметрии образмериваемого элемента, укажите ее (осевая линия должна быть параллельна отрезку, от которого проставляется размер). Значение размера вычисляется как удвоенное расстояние между отрезком и осью. При необходимости можно отредактировать размерную надпись.

– Если оси образмериваемого элемента нет, то введите текст размерной надписи вручную.

Для ввода текста размера вызовите специальный диалог. Для этого щелкните мышью в поле Текст на вкладке Размер.

В списке Размещение текста отображается текущий способ размещения размерной надписи. Если необходимо, смените способ размещения. Подробнее...

Затем укажите точку т3, определяющую положение размерной линии и ее длину.

Если выбрано размещение размерной надписи на полке, задайте точку начала полки т4. Точка начала линии-выноски находится в середине размерной линии, изменить ее положение нельзя.

Простановка размера с обрывом

Настройка параметров размеров (выбор вида стрелки, положения надписи и т.п.).

Смотрите также

Особенности использования команды в параметрическом режиме

Другие размеры

Выравнивание размерных линий


Команда Вырезать кинематически

Позволяет вырезать из модели кинематический элемент. Кинематический элемент образуется путем перемещения сечения вдоль траектории.

Пример

Для вырезания из модели кинематического элемента выполните следующие действия.

1. Вызовите команду Вырезать кинематически. Команда доступна, если в модели уже существует тело и хотя бы один эскиз.

2. Задайте параметры операции на Панели свойств.

• Сечение
Активизируйте переключатель Сечение и укажите в Дереве построения или в окне модели эскиз.

Требования к эскизу-сечению кинематического элемента...

• Траектория
Активизируйте переключатель Траектория. Затем укажите в Дереве построения или в окне модели траекторию: пространственную кривую, линию эскиза, ребро или цепочку из этих объектов в любом сочетании.

Требования к траектории кинематического элемента...

• Тип движения сечения
Выберите тип движения сечения по траектории. Для этого активизируйте нужный переключатель в группе Движение сечения.

Подробнее о типе движения сечения...

• Параметры тонкой стенки
Задаются на вкладке Тонкая стенка Панели свойств. Подробнее...

• Результат операции
Задается на вкладке Результат операции Панели свойств. Подробнее...

• Область применения операции
Выберите тип области применения, а затем укажите составляющие ее объекты. Подробнее...

Объекты, указанные для выполнения операции, подсвечиваются. Кинематический элемент с текущими параметрами отображается на экране в виде фантома. Фантом позволяет визуально проконтролировать правильность задания параметров.

Значение толщины стенки можно задать с помощью характерных точек.

3. При необходимости вы можете:

– Назначить допуски на значения параметров операции, выраженных в линейных или угловых величинах. Для этого используйте кнопку Назначить допуск, расположенную на Панели свойств рядом с полем числового параметра операции.
Подробнее о допусках...
Подробнее о назначении допуска...

– Задать наименование элемента и свойства его поверхности, сменить версию оптимизации построения. Для этого активизируйте вкладку Свойства Панели свойств.

4. Нажмите кнопку Создать объект для завершения операции.

5. Если в результате операции образуется тело из нескольких частей, то после выполнения операции запускается процесс изменения набора частей. Выберите части, которые следует оставить.

Результат операции — вырезанный элемент или пересечение тела и элемента — появляется в графической области. В Дереве построения появляется пиктограмма операции.

Если требуется прервать операцию до ее завершения, нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие команды редактирования детали

Другие команды редактирования сборки

Особенности задания числовых параметров операции в полях Панели свойств


Команда Вырезать выдавливанием

Позволяет вырезать из модели элемент выдавливания. Элемент выдавливания образуется путем перемещения сечения по прямолинейной направляющей.

Пример

Для вырезания из модели элемента выдавливания выполните следующие действия.

1. Вызовите команду Вырезать выдавливанием. Команда доступна, если в модели существует тело.

2. Задайте параметры операции на Панели свойств.

• Сечение
Активизируйте переключатель Сечение. Укажите в Дереве построения или в окне модели объект-сечение: эскиз, грань, пространственную кривую или ребро.

Подробнее об указании сечения...
Зависимость результата операции выдавливания от выбора сечения...

• Направляющий объект
Если в качестве сечения используется эскиз или плоская грань, то эти же объекты автоматически выбираются в качестве направляющих. Выдавливание производится перпендикулярно плоскости эскиза или грани.

Чтобы задать другой направляющий объект, активизируйте переключатель Направляющий объект. Затем укажите в Дереве построения или в окне модели любой плоский или прямолинейный объект.

Подробнее об указании направляющего объекта...

• Направление выдавливания
Выберите направление выдавливания из списка Направление: Прямое, Обратное, Два направления, Средняя плоскость.

Подробнее о направлении выдавливания...

• Глубина выдавливания
Выберите способ определения глубины выдавливания из списка Способ и задайте соответствующие способу параметры.

Подробнее о задании глубины выдавливания...

Если было выбрано выдавливание В двух направлениях, то способ определения глубины выдавливания и параметры требуется задать дважды — для прямого и обратного направления.
Если был выбран вариант Средняя плоскость, то параметры задаются один раз. При этом возможно выдавливание только на заданное расстояние (в каждую сторону откладывается его половина).

• Угол уклона
Уклон боковых граней элемента возможен, если в качестве сечения используется эскиз или плоская грань, а направление выдавливания перпендикулярно сечению.

Выберите направление уклона с помощью группы переключателей Уклон, а затем введите угол уклона в поле Угол.

Подробнее о задании угла уклона...

• Параметры тонкой стенки
Задаются на вкладке Тонкая стенка Панели свойств. Подробнее...

• Результат операции
Задается на вкладке Результат операции Панели свойств. Подробнее...

• Область применения операции
Выберите тип области применения, а затем укажите составляющие ее объекты. Подробнее...

Объекты, указанные для выполнения операции, подсвечиваются. Элемент выдавливания с текущими параметрами отображается на экране в виде фантома. Фантом позволяет визуально проконтролировать правильность задания параметров.

Значения глубины выдавливания, угла уклона и толщины стенки можно задать с помощью характерных точек.

3. При необходимости вы можете назначить допуски на значения параметров операции, выраженных в линейных или угловых величинах. Для этого используйте кнопку Назначить допуск, расположенную на Панели свойств рядом с полем числового параметра операции.
Подробнее о допусках...
Подробнее о назначении допуска...

4. При необходимости используйте кнопки Панели специального управления для выполнения следующих действий:

– Построение контура для использования в качестве сечения.

– Построение вектора, задающего направление выдавливания.

– Отмена выбора всех объектов (сечения, направляющего объекта и т.п.).

– Редактирование эскиза-сечения (доступно, если в качестве сечения используется эскиз).

5. При необходимости вы можете задать наименование элемента и свойства его поверхности. Для этого активизируйте вкладку Свойства Панели свойств.

6. Нажмите кнопку Создать объект для завершения операции.

7. Если в результате операции образуется тело из нескольких частей, то после выполнения операции запускается процесс изменения набора частей. Выберите части, которые следует оставить.

Результат операции — вырезанный элемент или пересечение тела и элемента — появляется в графической области. В Дереве построения появляется пиктограмма операции.

Если требуется прервать операцию до ее завершения, нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Требования к эскизу элемента выдавливания

Другие команды редактирования детали

Другие команды редактирования сборки

Особенности задания числовых параметров операции в полях Панели свойств


Команда Вырезать по сечениям

Позволяет вырезать из модели элемент по сечениям. Элемент по сечениям образуется путем соединения нескольких сечений. Крайнее сечение может быть точкой. Если необходимо, можно указать осевую линию — контур, задающий направление построения элемента по сечениям.

Пример

Для вырезания из модели элемента по сечениям выполните следующие действия.

1. Вызовите команду Вырезать по сечениям. Команда доступна, если в модели существует тело и хотя бы два эскиза.

2. Задайте параметры операции на Панели свойств.

• Сечения
Активизируйте переключатель Сечения и укажите в Дереве построения или в окне модели эскизы сечений элемента.

Требования к эскизам-сечениям...
Подробнее об указании сечений элемента по сечениям...

• Осевая линия
Задается при необходимости. Активизируйте переключатель Осевая линия и укажите в Дереве построения или в окне модели осевую линию элемента: пространственную кривую, ребро или эскиз.

Требования к осевой линии...
Подробнее об осевой линии элемента по сечениям...

• Способ построения элемента у крайних сечений
Выберите способы построения элемента из списков Начальное сечение и Конечное сечение.

Подробнее о способах построения элемента у крайних сечений...

• Траектория соединения сечений

С помощью группы переключателей Траектория укажите способ выбора соединяемых точек сечений: автоматически или вручную. Подробнее...

С помощью группы переключателей Режим укажите, требуется ли замыкать элемент по сечениям. Подробнее...

• Параметры тонкой стенки
Задаются на вкладке Тонкая стенка Панели свойств. Подробнее...

Построение тонкостенного элемента по сечениям возможно, только если все эскизы-сечения содержат контуры. Использовать эскизы, содержащие точки, для создания такого элемента нельзя.

• Результат операции
Задается на вкладке Результат операции Панели свойств. Подробнее...

• Область применения операции
Выберите тип области применения, а затем укажите составляющие ее объекты. Подробнее...

Объекты, указанные для выполнения операции, подсвечиваются. Элемент по сечениям с текущими параметрами отображается на экране в виде фантома. Фантом позволяет визуально проконтролировать правильность задания параметров.

Значение толщины стенки можно задать с помощью характерных точек.

3. При необходимости вы можете назначить допуски на значения параметров операции, выраженных в линейных или угловых величинах. Для этого используйте кнопку Назначить допуск, расположенную на Панели свойств рядом с полем числового параметра операции.
Подробнее о допусках...
Подробнее о назначении допуска...

4. При необходимости вы можете задать наименование элемента и свойства его поверхности. Для этого активизируйте вкладку Свойства Панели свойств.

5. Нажмите кнопку Создать объект для завершения операции.

6. Если в результате операции образуется тело из нескольких частей, то после выполнения операции запускается процесс изменения набора частей. Выберите части, которые следует оставить.

Результат операции — вырезанный элемент или пересечение тела и элемента — появляется в графической области. В Дереве построения появляется пиктограмма операции.

Если требуется прервать операцию до ее завершения, нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие команды редактирования детали

Другие команды редактирования сборки

Особенности задания числовых параметров операции в полях Панели свойств


Команда Вырезать вращением

Позволяет вырезать из модели элемент вращения. Элемент вращения образуется путем поворота сечения вокруг оси.

Пример

Для вырезания из модели элемента вращения выполните следующие действия.

1. Вызовите команду Вырезать вращением. Команда доступна, если в модели существует тело.

2. Задайте параметры операции на Панели свойств.

• Сечение
Активизируйте переключатель Сечение. Укажите в Дереве построения или в окне модели объект-сечение: эскиз, грань, пространственную кривую или ребро.

Подробнее об указании сечения...
Зависимость результата операции вращения от выбора сечения...

• Ось вращения
Ось вращения может определяться автоматически. Для этого она должна находиться в том же эскизе, что и сечение элемента и являться отрезком со стилем Осевая или объектом Осевая линия.

Чтобы задать другой объект, определяющий ось вращения, активизируйте переключатель Ось. Затем укажите в Дереве построения или в окне модели любой прямолинейный объект или поверхность вращения.

Подробнее об указании оси вращения...

• Тип построения
Выбор типа построения — тороид или сфероид — возможен, если в качестве сечения используется незамкнутый эскиз, а ось вращения лежит в плоскости сечения.

Выберите тип построения с помощью группы переключателей Тип.

Подробнее о типе построения...

• Направление вращения
Выберите направление вращения из списка Направление: Прямое, Обратное, Два направления, Средняя плоскость.

Подробнее о направлении вращения...

• Угол вращения
Выберите способ определения угла вращения из списка Способ и задайте соответствующие способу параметры.

Подробнее о задании угла вращения...

Если было выбрано вращение В двух направлениях, то способ определения угла вращения и параметры требуется задать дважды — для прямого и обратного направления.
Если был выбран вариант Средняя плоскость, то параметры задаются один раз. При этом возможно вращение только на заданный угол (в каждую сторону откладывается его половина).

• Параметры тонкой стенки
Задаются на вкладке Тонкая стенка Панели свойств. Подробнее...

• Результат операции
Задается на вкладке Результат операции Панели свойств. Подробнее...

• Область применения операции
Выберите тип области применения, а затем укажите составляющие ее объекты. Подробнее...

Объекты, указанные для выполнения операции, подсвечиваются. Элемент вращения с текущими параметрами отображается на экране в виде фантома. Фантом позволяет визуально проконтролировать правильность задания параметров.

Значения угла вращения и толщины стенки можно задать с помощью характерных точек.

3. При необходимости вы можете назначить допуски на значения параметров операции, выраженных в линейных или угловых величинах. Для этого используйте кнопку Назначить допуск, расположенную на Панели свойств рядом с полем числового параметра операции.
Подробнее о допусках...
Подробнее о назначении допуска...

4. При необходимости используйте кнопки Панели специального управления для выполнения следующих действий:

– Построение контура для использования в качестве сечения.

– Построение оси для использования в качестве оси вращения.

– Отмена выбора всех объектов (сечения, оси и т.п.).

– Редактирование эскиза-сечения (доступно, если в качестве сечения используется эскиз).

5. При необходимости вы можете задать наименование элемента и свойства его поверхности. Для этого активизируйте вкладку Свойства Панели свойств.

6. Нажмите кнопку Создать объект для завершения операции.

7. Если в результате операции образуется тело из нескольких частей, то после выполнения операции запускается процесс изменения набора частей. Выберите части, которые следует оставить.

Результат операции — вырезанный элемент или пересечение тела и элемента — появляется в графической области. В Дереве построения появляется пиктограмма операции.

Если требуется прервать операцию до ее завершения, нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Требования к эскизу элемента вращения

Другие команды редактирования детали

Другие команды редактирования сборки

Особенности задания числовых параметров операции в полях Панели свойств


Переключатель Направление отсечения

Переключатель, позволяющий выбрать направление отсечения.

Направление отсечения показывается фантомной стрелкой в окне модели.


Результат операции вырезания

Группа переключателей, позволяющая выбрать результат операции — вычитание или пересечение.

Чтобы удалить материал модели, находящийся внутри поверхности элемента, активизируйте переключатель Вычитание элемента.

Чтобы удалить материал модели, находящийся снаружи поверхности элемента, активизируйте переключатель Пересечение элементов.


Режим удаления

Переключатель, позволяющий указать, требуется ли удалять сам указанный участок или внешнюю по отношению к нему часть кривой.


Команда Линия разреза/сечения(для машиностроения)

Команда Линия разреза/сечения
(для машиностроения)

Позволяет создать линию разреза или сечения.

Для вызова команды нажмите кнопку Линия разреза/сечения на инструментальной панели Обозначения.

Укажите первую и вторую точки линии разреза. При необходимости вы можете задать направление линии разреза. Для этого перед указанием второй точки выберите любой линейный объект (кроме объектов, входящих в состав сложных объектов). В зависимости от направления движения курсора при указании второй точки линия разреза будет параллельна или перпендикулярна выбранному объекту.

Первая и вторая указанные точки считаются начальными — расположенными ближе к контуру детали — точками штрихов, обозначающих линию разреза или сечения. После указания второй точки на экране появляется фантом обозначения линии разреза/сечения.

Если требуется построить линию ступенчатого или ломаного разреза, нажмите кнопку Сложный разрез на Панели специального управления.

При необходимости выберите из списка Стрелка вид стрелки линии разреза/сечения.

Вы можете изменить конфигурацию создаваемой линии, не выходя из команды. Для этого нажмите кнопку Редактировать точки на Панели специального управления. Система перейдет в режим редактирования характерных точек объекта. Внесите необходимые изменения, после чего отожмите кнопку Редактировать точки.

Чтобы выбрать, с какой стороны от линии разреза/сечения должны располагаться стрелки, перемещайте курсор. Когда он пересечет прямую, содержащую линию разреза/сечения, фантом перестроится: стрелки расположатся по другую сторону от линии.

Щелкните левой кнопкой мыши с той стороны от линии, где должны располагаться стрелки.

Создание линии разреза: а) указание первой и второй точек, б) выбор положения стрелок, в) результат построения
а) | б) | в)

Формирование текста на линии разреза/сечения аналогично формированию текста обозначения стрелки направления взгляда.

Группа переключателей Размещение позволяет указать, рядом с какой из стрелок — первой или последней — должен располагаться дополнительный текст (например, номер листа, где находится изображение разреза или сечения). Если дополнительный текст не используется, состояние переключателей этой группы не имеет значения.

Сразу после создания линии разреза/сечения автоматически запускается команда создания нового вида. После выполнения команды в чертеже появится вид, обозначение которого будет ассоциативно связано с созданной линией разреза/сечения.

Вы можете отказаться от создания нового вида, нажав кнопку Прервать команду. Однако делать это не рекомендуется, поскольку ручное создание вида и формирование связи между его обозначением и обозначением линии разреза/сечения займет дополнительное время. Кроме того, размещение разреза/сечения в отдельном виде позволяет быстро изменять масштаб изображения и делает более удобной компоновку чертежа.

При создании линии разреза может автоматически создаваться гиперссылка, связывающая обозначение с вновь созданным видом.


Команда Редактировать точки

Позволяет перейти в режим редактирования характерных точек объекта.


Построение линии сложного разреза

Для перехода в режим построения линии ступенчатого или ломаного разреза служит кнопка Сложный разрез на Панели специального управления.

Она доступна после указания первой точки линии разреза.

После нажатия этой кнопки каждая последующая указанная точка считается вершиной ломаной — линии сложного разреза. Для точного указания пользуйтесь привязками или меню геометрического калькулятора в полях Текущая точка на вкладке Знак Панели свойств. Можно также вводить в эти поля значения с клавиатуры.

Если требуется задать направление сегмента ломаной, перед указанием конечной точки этого сегмента выберите любой линейный объект (кроме объектов, входящих в состав сложных объектов). В зависимости от направления движения курсора сегмент линии разреза будет расположен параллельно или перпендикулярно выбранному объекту.

После указания очередной точки фантом линии разреза перестраивается.

а) | б) | в)
Пример создания линии ступенчатого разреза: а) переход в режим построения линии сложного разреза и указание третьей точки (первая и вторая указаны до перехода в этот режим), б), в) указание четвертой точки

Указав последнюю точку линии разреза, отожмите кнопку Сложный разрез. Система вернется в режим построения простого разреза.

Линию разреза, сегменты которой перпендикулярны друг другу (например, при оформлении ступенчатого разреза), удобно создавать в режиме ортогонального черчения. Для его включения и выключения служит кнопка Ортогональное черчение на панели Текущее состояние, а также клавиша <F8>. Чтобы временно перейти в режим ортогонального черчения, нажмите и удерживайте клавишу <Shift>. Если режим ортогонального черчения отключен, возможно создание линии сечения, сегменты которой наклонены друг к другу под произвольными углами (например, при оформлении ломаного разреза).


Команда Линия разреза(для строительства)

Команда Линия разреза
(для строительства)

Позволяет создать линию разреза.

Для вызова команды нажмите кнопку Линия разреза на инструментальной панели Обозначения для строительства или выберите ее название из меню Инструменты — Обозначения для строительства.

Укажите первую и вторую точки линии разреза. Указанные точки считаются начальными — расположенными ближе к контуру детали — точками штрихов, обозначающих линию разреза.

На экране появится фантом обозначения линии разреза.

Построение линии ступенчатого или ломаного разреза аналогично построению линии ступенчатого или ломаного разреза для машиностроения.

Вы можете изменить конфигурацию создаваемой линии, не выходя из команды. Для этого нажмите кнопку Редактировать точки на Панели специального управления. Система перейдет в режим редактирования характерных точек объекта. Внесите необходимые изменения, после чего отожмите кнопку Редактировать точки.

Чтобы выбрать, с какой стороны от линии разреза должны располагаться стрелки, перемещайте курсор. Когда он пересечет прямую, содержащую линию разреза, фантом перестроится: стрелки расположатся по другую сторону от линии.

Щелкните левой кнопкой мыши с той стороны от линии, где должны располагаться стрелки.

Создание линии разреза: а) указание первой и второй точек, б) выбор положения стрелок, в) результат построения
а) | б) | в)

Сформируйте текст обозначения линии разреза

Группа переключателей Размещение позволяет указать, рядом с какой из стрелок — первой или последней — должен располагаться дополнительный текст (например, номер листа, где находится изображение разреза). Если дополнительный текст не используется, состояние переключателей этой группы не имеет значения.

Опция Создавать вид позволяет сформировать новый вид сразу после создания линии разреза.

Из списка Стрелка вы можете выбрать вид стрелки линии разреза.

Если режим автосоздания включен (кнопка Автосоздание объекта на Панели специального управления нажата), то обозначение линии разреза фиксируется после указания направления стрелок разреза.

При отключенном автосоздании для фиксации обозначения следует нажать кнопку Создать объект.

• Если опция Создавать вид была включена, то после фиксации стрелки линии разреза автоматически запускается команда Создать новый вид. Настройте параметры вида и задайте его положение. Новый вид является текущим, и вы можете приступать к вычерчиванию изображения в нем.

После выполнения команды в чертеже появится вид, надпись которого будет ассоциативно связана с созданной линией разреза.

Вы можете отказаться от создания нового вида, нажав кнопку Прервать команду. Однако делать это не рекомендуется, поскольку ручное создание вида и формирование связи между его надписью и разрезом займет дополнительное время. Кроме того, размещение изображения разреза в отдельном виде позволяет быстро изменять масштаб изображения и делает более удобной компоновку чертежа.

При простановке обозначения линии разреза может автоматически создаваться гиперссылка, связывающая обозначение с вновь созданным видом.

• Если опция Создавать вид была выключена, то после фиксации линии разреза вид не создается. Вы можете создать несколько обозначений за один вызов команды Линия разреза. Для этого укажите новые начальную и конечную точки и точку, задающую направление стрелок. Новому обозначению присваивается очередной номер.

Чтобы завершить работу команды, нажмите кнопку Прервать команду на Панели специального управления.

Текст обозначения, добавляемый перед номером разреза при создании ссылки, задается в диалоге настройки параметров линии разреза.

Смотрите также

Другие обозначения для строительства

Автоматическое создание вида


Расположение дополнительного текста

Переключатель, позволяющий указать, рядом с какой стрелкой — первой или последней — должен располагаться дополнительный текст (номер листа или обозначение зоны, где находится изображение разреза).

Если дополнительный текст не используется, состояние данных переключателей не имеет значения.


Команда Обозначение узла в сечении

Позволяет создать специальное обозначение узла в сечении, используемое в строительной документации.

Для вызова команды нажмите кнопку Обозначение узла в сечении на инструментальной панели Обозначения для строительства или выберите ее название из меню Инструменты — Обозначения для строительства.

Введите координаты точки привязки (т) штриха на Панели свойств или укажите положение точки привязки штриха в окне документа (точкой привязки штриха является его средняя точка).

На экране появится фантом обозначения с умолчательными настройками.

Введите длину штриха в поле Штрих. Укажите точку начала полки т1. Угол наклона штриха вычисляется автоматически и заносится в поле Угол. Угол наклона отсчитывается от оси ОХ текущей системы координат. Если необходимо установить определенный угол наклона штриха, введите эту величину с клавиатуры в поле Угол и зафиксируйте ее.

Чтобы начать построение от точки начала полки, активизируйте поле ввода координат точки т1 на Панели свойств, нажав переключатель, и укажите точки (т1) и (т).

Настройте параметры обозначения узла в сечении на вкладке Параметры Панели свойств.

Примеры обозначений узла в сечении

В поле Текст отображается надпись над полкой обозначения. По умолчанию надпись представляет собой номер, определяемый автоматически. Это первый свободный номер среди обозначений узлов и узлов в сечении, имеющихся в текущем документе. Чтобы изменить надпись, вызовите диалог ввода текста. Для этого щелкните мышью в поле Текст на Панели свойств или вызовите команду Текст надписи... из контекстного меню.

Текст обозначения узла в сечении может содержать ссылку на другой объект, например, номер узла.

По умолчанию при создании обозначения узла в сечении включен режим добавления штрихов. Об этом свидетельствует нажатая кнопка Добавить штрихи на Панели специального управления. В этом режиме каждая вновь указанная точка воспринимается системой как точка середины очередного штриха. Вы можете создать несколько штрихов подряд на линии-выноске, указывая их точки привязки. Если штрихи должны иметь разную длину, вводите в поле Штрих размер каждого следующего штриха.

В режиме редактирования характерных точек объекта можно изменить угол наклона штрихов, расположение штрихов и полки, а также удалить штрихи. Для перехода в режим редактирования нажмите кнопку Редактировать точки на Панели специального управления.

Чтобы изменить угол наклона штрихов в режиме редактирования характерных точек, расфиксируйте поле Угол.

Между режимами можно произвольно переключаться при помощи кнопок Панели специального управления или команд в контекстном меню. При выходе из одного режима автоматически включается другой.

Опция Создавать вид позволяет сформировать новый вид сразу после создания узла в сечении.

Чтобы подтвердить создание узла в сечении, нажмите кнопку Создать объект на Панели специального управления.

• Если опция Создавать вид была включена, то обозначение узла в сечении фиксируется, после чего автоматически запускается команда Создать новый вид. Настройте параметры вида и задайте его положение. Новый вид является текущим, и вы можете приступать к вычерчиванию изображения в нем.

После выполнения команды в чертеже появится вид, надпись которого будет ассоциативно связана с созданным узлом.

Вы можете отказаться от создания нового вида, нажав кнопку Прервать команду. Однако делать это не рекомендуется, поскольку ручное создание вида и формирование связи между его надписью и обозначением узла займет дополнительное время. Кроме того, размещение изображения узла в отдельном виде позволяет быстро изменять масштаб изображения и делает более удобной компоновку чертежа.

При простановке узла может автоматически создаваться гиперссылка, связывающая обозначение с вновь созданным видом.

• Если опция Создавать вид была выключена, то обозначение узла в сечении фиксируется без создания нового вида. Вы можете создать несколько обозначений за один вызов команды Обозначение узла в сечении. Для этого после нажатия кнопки Создать объект укажите новые точки т и т1.

Чтобы завершить работу команды, нажмите кнопку Прервать команду на Панели специального управления.

Умолчательный размер штрихов, расстояние между ними и линией-выноской и параметры расположения текста на полке задаются в диалоге параметров отрисовки обозначения узла; стили линии штрихов и линии, их соединяющей, задаются в диалоге общих настроек обозначения узла.

Смотрите также

Обозначение узла

Другие обозначения для строительства

Автоматическое создание вида


Команда Усечь кривую

Позволяет удалить часть объекта, ограниченную точками пересечения его с другими объектами.

Для вызова команды нажмите кнопку Усечь кривую на инструментальной панели Редактирование или выберите ее название из меню Редактор — Удалить.

Усекать можно любые геометрические объекты за исключением эквидистант и вспомогательных прямых.

По умолчанию удаляется тот участок кривой, который указан курсором. При этом в группе Режим на Панели свойств активен переключатель Удалять указанный участок. Если же требуется удалить внешние по отношению к указанному участки кривой, активизируйте переключатель Оставлять указанный участок. Например, на рисунке б) для усечения обоих отрезков были указаны те их участки, которые лежали внутри окружности. Однако верхний отрезок был выбран в режиме оставления указанного участка, а нижний — в режиме удаления.

Установив требуемый режим, укажите курсором нужный участок кривой.

Усечение объектов:
а) исходное изображение; б) результат выполнения команды

Для усечения можно указывать группу объектов, используя секущий отрезок. Усечены будут те объекты, которые пересекаются этим отрезком.

За один вызов команды вы можете усечь произвольное количество объектов.

Для завершения команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие команды редактирования


Команда Усечь кривую двумя точками

Позволяет удалить часть объекта, ограниченную двумя произвольно заданными точками.

Для вызова команды нажмите кнопку Усечь кривую двумя точками на инструментальной панели Редактирование или выберите ее название из меню Редактор — Удалить.

Усекать по точкам можно любые геометрические объекты за исключением эквидистант и вспомогательных прямых.

По умолчанию удаляется участок кривой, заключенный между указанными точками (если объект не замкнут) или участок, указанный курсором (если объект замкнут). При этом в группе Режим на Панели свойств активен переключатель Удалять указанный участок. Если же требуется удалить внешние по отношению к указанному участки кривой, активизируйте переключатель Оставлять указанный участок.

Установив нужный режим, укажите курсором усекаемый геометрический объект.

Затем укажите две точки (т1 и т2), ограничивающие участок кривой, который следует удалить. Если указанные точки не принадлежат выбранной кривой, то положение границ участка будет определяться проекциями указанных точек на кривую.

Для точного позиционирования курсора воспользуйтесь привязками или меню геометрического калькулятора в полях т1 и т2 на Панели свойств.

Если объект замкнут, необходимо указать точку внутри удаляемого участка.

Усечение объектов по указанным точкам:
а) исходное изображение, б) результат выполнения команды

За один вызов команды вы можете усечь произвольное количество объектов.

Для завершения команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие команды редактирования


Команда Построение вектора

Позволяет создать вектор в пространстве. Доступно несколько способов построения.

Для вызова команды нажмите кнопку Построение вектора на панели Панели специального управления или выберите ее название из контекстного меню.

Выберите способ построения вектора из списка Способ или при помощи команд контекстного меню.

Задайте параметры и укажите в окне модели или в Дереве построения объекты, необходимые для построения вектора выбранным способом.

– По двум вершинам

– Угол в плоскости СК

– По оси СК

– По коэффициентам

– По двум углам

– По прямолинейному ребру, оси или перпендикулярно плоскости кривой

– По оси цилиндра или перпендикулярно плоской грани, плоскости

– Перпендикулярно грани в указанной точке

– По базисному вектору в точке кривой

– Перпендикулярно плоскости экрана

После задания всех необходимых данных в модели появляется фантом вектора заданного направления. Длина фантома не зависит от масштаба отображения модели.

Чтобы сменить объекты, используемые для построения вектора, нажмите кнопку Указать заново на Панели специального управления и повторите выбор объектов.

Чтобы завершить построение, нажмите кнопку Создать объект на Панели специального управления.

Система вернется в процесс построения объекта.


Команда Построение вектораПостроение способом По двум углам

Команда Построение вектора
Построение способом По двум углам

Данный способ позволяет построить вектор путем выбора системы координат и указания азимутального и зенитного углов, задающих направление вектора.

Способ можно сделать текущим, выбрав название По двум углам из списка Способ на Панели свойств или контекстного меню команды Построение вектора.

Чтобы построить вектор, выполните следующие действия.

1. Выберите систему координат для построения вектора.

2. Введите или задайте счетчиком значения азимутального и зенитного углов.

Подробнее...


Команда Построение вектораПостроение способом По двум вершинам

Команда Построение вектора
Построение способом По двум вершинам

Данный способ позволяет построить вектор по двум точечным объектам.

Способ можно сделать текущим, выбрав название По двум вершинам из списка Способ на Панели свойств или контекстного меню команды Построение вектора.

Чтобы построить вектор, укажите в окне модели или Дереве построения две вершины, через которые должен проходить вектор.

Выбор объектов в окне модели

Выбор объектов в Дереве построения

Подробнее...


Команда Построение вектораПостроение способом Угол в плоскости СК

Команда Построение вектора
Построение способом Угол в плоскости СК

Данный способ позволяет построить вектор путем указания системы координат и задания угла наклона вектора относительно какой-либо оси этой системы координат.

Способ можно сделать текущим, выбрав название Угол в плоскости СК из списка Способ на Панели свойств или контекстного меню команды Построение вектора.

Чтобы построить вектор, выполните следующие действия.

1. Выберите систему координат для построения вектора.

2. Выберите ось этой системы координат для отсчета угла наклона вектора.

3. Задайте значение угла наклона вектора.

Подробнее...


Команда Построение вектораПостроение способом По оси СК

Команда Построение вектора
Построение способом По оси СК

Данный способ позволяет построить вектор путем выбора системы координат и указанием оси этой системы координат, вдоль которой будет направлен вектор.

Способ можно сделать текущим, выбрав название По оси СК из списка Способ на Панели свойств или контекстного меню команды Построение вектора.

Чтобы построить вектор, выполните следующие действия.

1. Выберите систему координат для построения вектора.

2. Выберите ось этой системы координат для задания направления вектора.

Подробнее...


Команда Построение вектораПостроение способом По коэффициентам

Команда Построение вектора
Построение способом По коэффициентам

Данный способ позволяет построить вектор путем выбора системы координат и указания в ней коэффициентов разложения вектора по координатным осям X, Y, Z. Коэффициенты разложения вектора определяют его направление в пространстве.

Способ можно сделать текущим, выбрав название По коэффициентам из списка Способ на Панели свойств или контекстного меню команды Построение вектора.

Чтобы построить вектор, выполните следующие действия.

1. Выберите систему координат для построения вектора.

2. Введите коэффициенты разложения вектора по координатным осям выбранной системы координат.

Подробнее...


Команда Построение вектораПостроение способом По базисному вектору в точке кривой

Команда Построение вектора
Построение способом По базисному вектору в точке кривой

Данный способ позволяет построить вектор путем задания положения его начальной точки на кривой и выбора базисного вектора кривой в этой точке. Выбранный базисный вектор определяет направление создаваемого вектора в пространстве.

Общие сведения о базисных векторах...

Способ можно сделать текущим, выбрав название По базисному вектору в точке кривой из списка Способ на Панели свойств или контекстного меню команды Построение вектора.

В качестве кривой может быть выбрана пространственная кривая, ребро, линия эскиза или сегмент ломаной.

Положение начальной точки вектора задается смещением вдоль кривой на некоторое расстояние от ее вершины.

Чтобы построить вектор в пространстве, выполните следующие действия.

1. Укажите кривую в окне модели или в Дереве построения.

2. Задайте смещение начальной точки вектора вдоль указанной кривой.

3. Задайте направление создаваемому вектору.

Подробнее...


Команда Построение вектораПостроение способом По прямолинейному ребру, оси или перпендикулярно плоскости кривой

Команда Построение вектора
Построение способом По прямолинейному ребру, оси или перпендикулярно плоскости кривой

Данный способ позволяет построить вектор путем указания направляющего объекта.

Способ можно сделать текущим, выбрав название По прямолинейному ребру, оси или перпендикулярно плоскости кривой из списка Способ на Панели свойств или контекстного меню команды Построение вектора.

В качестве направляющего в данном способе может использоваться любой прямолинейный объект или плоская кривая: линия эскиза, дуга, окружность, ребро в виде дуги, окружности или эллипса.

Чтобы построить вектор, укажите направляющий объект в окне модели или в Дереве построения.

Выбор объектов в окне модели

Выбор объектов в Дереве построения

Подробнее...


Команда Построение вектораПостроение способом По оси цилиндра или перпендикулярно плоской грани, плоскости

Команда Построение вектора
Построение способом По оси цилиндра или перпендикулярно плоской грани, плоскости

Данный способ позволяет построить вектор путем указания направляющего объекта.

Способ можно сделать текущим, выбрав название По оси цилиндра или перпендикулярно плоской грани, плоскости из списка Способ на Панели свойств или контекстного меню команды Построение вектора.

В качестве направляющего объекта в данном способе может использоваться плоский объект или любая поверхность вращения, кроме сферической.

Чтобы построить вектор, укажите направляющий объект в окне модели или в Дереве построения.

Выбор объектов в окне модели

Выбор объектов в Дереве построения

Подробнее...


Команда Построение вектораПостроение способом Перпендикулярно плоскости экрана

Команда Построение вектора
Построение способом Перпендикулярно плоскости экрана

Данный способ позволяет построить вектор, перпендикулярный плоскости экрана.

Способ можно сделать текущим, выбрав название Перпендикулярно плоскости экрана из списка Способ на Панели свойств или контекстного меню команды Построение вектора.

После выбора данного способа построения в центре экрана появляется фантом вектора, направленный к наблюдателю.

Подробнее...


Команда Построение вектораПостроение способом Перпендикулярно грани в указанной точке

Команда Построение вектора
Построение способом Перпендикулярно грани в указанной точке

Данный способ позволяет построить вектор, перпендикулярный указанной грани в заданной точке. Положение точки задается смещением вдоль изопараметрических кривых U и V теоретической поверхности указанной грани.

Способ можно сделать текущим, выбрав название Перпендикулярно грани в указанной точке из списка Способ на Панели свойств или контекстного меню команды Построение вектора.

Чтобы построить вектор, выполните следующие действия.

1. Укажите курсором в модели нужную грань.

2. Задайте положение начальной точки вектора.

Подробнее...


Кнопка Построение вектора

Находится на Панели специального управления. Служит для запуска процесса создания (редактирования) вектора без выхода из команды построения объекта.

После нажатия кнопки система переходит в процесс создания (редактирования) вектора с помощью команды Построение вектора. Выберите способ построения вектора, а затем задайте требуемые для этого способа параметры (введите значения или укажите объекты). Создаваемый (редактируемый) вектор отображается на экране в виде фантома.


Кнопка Прервать команду

Позволяет завершить выполнение текущей команды.

Для вызова команды нажмите кнопку Прервать команду на Панели специального управления или выберите ее название из контекстного меню.


По умолчанию

Опция, включение которой означает, что все текущие настройки вкладки Параметры будут использоваться при создании следующих объектов данного типа до конца сеанса работы. При выключенной опции настройка распространяется только на текущий (создаваемый) объект.


Команда Исключить/добавить объект

Позволяет снять выделение с объектов, попавших в рамку. Для исключения объекта укажите его курсором. Повторное указание объекта снова включает его в выделенную группу.

Объект, находящийся вне рамки, невозможно добавить к выделенным.


Команда Выделить новой рамкой

Позволяет сформировать рамку заново. После ее нажатия прежнее выделение отменяется, и система вновь ожидает выделения объектов


Кнопка Удалить компонент из группы

Позволяет исключить компонент из группы компонентов с одним и тем же номером позиции.

Перед нажатием кнопки удаляемый компонент следует выделить в списке компонентов текущей группы в окне Группы компонентов.

Подробнее о компонентах с одним номером позиции...


Кнопка Исключить из группы

Позволяет исключить объект из текущей группы нумерации. Объект, который требуется исключить, должен быть выделен в списке объектов группы.

Если объект исключается из группы нумерации, номер-ссылка автоматически удаляется из надписи этого объекта или преобразуется в простой текст.

При исключении объекта из группы присвоенный ему номер может быть удален из списка объектов группы или оставлен в качестве свободного номера.

Вы также можете удалить из группы нумерации строки списка, содержащие свободные номера. Удаление строк со свободными номерами аналогично исключению объектов из группы нумерации.

Подробнее об исключении объектов из группы нумерации...

Смотрите также

Автоматическая нумерация объектов


Кнопка Удалить группу

Позволяет удалить из сборки одну или несколько групп компонентов с одним и тем же номером позиции.

После нажатия кнопки на экране появляется диалог, в котором можно выбрать удаляемые группы.

Удаление группы означает лишь удаление информации о ней из файла сборки. Компоненты, входившие в группу, остаются в сборке на прежних местах.

Подробнее о компонентах с одним номером позиции...


Команда Удалить историю построения

Позволяет удалить из модели информацию о способах и последовательности создания ее объектов. Команда Удалить историю построения находится в меню Редактор. Она доступна, если модель не имеет исполнений.

После вызова команды на экране появляется диалог Параметры удаления истории построения. Выполните в диалоге необходимые настройки и нажмите кнопку ОК.

Подробнее об удалении истории построения...


Команда Удалить гиперссылку

Позволяет удалить гиперссылки в графическом документе или эскизе.

Для вызова команды выделите объекты, из которых нужно удалить гиперссылки, и выберите название команды из контекстного меню.

Команда недоступна, если среди выделенных нет объектов, содержащих гиперссылки.

После вызова команды гиперссылки из всех выделенных объектов будут удалены.

Смотрите также

Команда Гиперссылка...

Редактирование гиперссылок

Удаление гиперссылок


Команда Удалить — Вспомогательные кривые и точки во всех видах

Команда Удалить — Вспомогательные кривые и точки
во всех видах

Позволяет удалить из активного документа следующие объекты:

– линии и точки со стилем Вспомогательная,

– вспомогательные прямые.

Для вызова команды выберите ее название из меню Редактор.

Для быстрой отмены ошибочного удаления вспомогательных кривых и точек нажмите кнопку Отменить на Стандартной панели или комбинацию клавиш <Alt>+<BackSpace> либо <Ctrl>+<Z>.

Смотрите также

Команда Удалить вспомогательные кривые и точки в текущем виде


Команда Удалить — Вспомогательные кривые и точки в текущем виде

Команда Удалить — Вспомогательные кривые и точки
в текущем виде

Позволяет удалить из текущего вида активного документа следующие объекты:

– линии и точки со стилем Вспомогательная,

– вспомогательные прямые.

Для вызова команды выберите ее название из меню Редактор.

Для быстрой отмены ошибочного удаления вспомогательных кривых и точек нажмите кнопку Отменить на Стандартной панели или комбинацию клавиш <Alt>+<BackSpace> либо <Ctrl>+<Z>.

Смотрите также

Команда Удалить вспомогательные кривые и точки во всех видах


Команда Удалить разрез

Позволяет удалить местный разрез. Контур, ограничивавший удаленный местный разрез, остается. Его нужно удалить отдельно.


Команда Удалить вид

Позволяет удалить один или несколько выделенных видов чертежа.

Команда доступна для всех, кроме системного, видов чертежа, находящихся в активном или текущем состоянии.

При удалении вида чертежа базировавшиеся на нем проекционные виды превращаются в произвольные виды, а виды по стрелке, выносные элементы, разрезы и сечения — удаляются.

Если вы допустили ошибку при удалении, нажмите кнопку Отменить на Стандартной панели или комбинацию клавиш <Alt>+<BackSpase> либо <Ctrl>+<Z>. Удаленный вид будет немедленно восстановлен.


Команда Удалить таблицу переменных

Позволяет удалить из текущего файла имеющуюся в нем таблицу переменных.

Для вызова команды нажмите кнопку Удалить таблицу переменных на инструментальной панели Окна переменных.

После вызова команды на экране появляется запрос на удаление таблицы. Вы можете подтвердить удаление или отказаться от него.


Команда Удалить характерную точку (графического макроэлемента)

Команда Удалить характерную точку
(графического макроэлемента)

Позволяет удалить характерную точку из макроэлемента.

Кнопка вызова команды находится на Панели специального управления во время работы команды Задать характерную точку. После нажатия кнопки характерная точка удаляется из макроэлемента.

Кнопка Удалить характерную точку доступна, если в макроэлементе была построена характерная точка.

Смотрите также

Редактирование характерной точки макроэлемента


Команда Удалить ошибочные проекции

Позволяет удалить из эскиза вспомогательные проекции объектов модели, которые не могут быть корректно перестроены при имеющемся состоянии модели и/или положении плоскости эскиза.

Команда Удалить ошибочные проекции доступна в контекстном меню эскиза с ошибкой «Потеряна связь» или «Вырожденная проекция ребра». После вызова команды из эскиза удаляются все ошибочные вспомогательные проекции и, соответственно, связи между ними и графическими объектами. Если других ошибок в эскизе нет, признак ошибки с него снимается.

Для исправления указанных ошибок можно также отредактировать эскиз, вручную удалив связи графических объектов с некорректными вспомогательными проекциями с помощью команды Показать/удалить ограничения.


Команда Удалить — Неуказанную шероховатость

Позволяет удалить из чертежа обозначение шероховатости неуказанных поверхностей (знак неуказанной шероховатости).

Для быстрой отмены ошибочного удаления знака неуказанной шероховатости нажмите кнопку Отменить на Стандартной панели или комбинацию клавиш <Alt>+<BackSpace> либо <Ctrl>+<Z>.


Команда Удалить — Технические требования

Позволяет удалить содержимое технических требований чертежа.

Для быстрой отмены ошибочного удаления технических требований нажмите кнопку Отменить на Стандартной панели или комбинацию клавиш <Alt>+<BackSpace> либо <Ctrl>+<Z>.


Команда Удалить содержимое основной надписи

Позволяет удалить содержимое основных надписей на всех листах чертежа.

Будьте внимательны при удалении содержимого основной надписи, так как отмена этой операции невозможна.


Команда Удалить связь

Позволяет удалить связь вершины сплайна или ломаной с точечным объектом, а также cопряжение сплайна с объектом модели.

Команда доступна:

– для строк вершин сплайна или ломаной, которые связаны точечными объектами,

– для строк системных полюсов сплайна.

Будьте внимательны при удалении связи, так как отменить это действие невозможно.


Команда Массив по образцу

Позволяет создать массив компонентов, расположив их так же, как расположены экземпляры другого, уже существующего, массива — массива-образца.

В качестве массива-образца можно использовать массив любого типа, кроме массива по образцу.

Изменение параметров массива-образца передается в массив по образцу — он перестраивается.

Чтобы построить массив компонентов по образцу, выполните следующие действия.

1. Вызовите команду Массив по образцу.

2. Укажите в Дереве построения или в окне модели копируемые компоненты для создания массива.

3. Перейдите на вкладку Параметры Панели свойств.

4. Выберите массив-образец. Для этого активизируйте переключатель Массив-образец и укажите в Дереве построения или в окне модели нужный массив объектов.

На экране появляется фантом создаваемого массива с умолчательными параметрами.

5. С помощью группы Способ выберите способ размещения экземпляров массива относительно массива-образца. Подробнее о размещении экземпляров...

6. Если массив-образец имеет вложенность (т.е. его исходным объектом является другой массив), вы можете управлять количеством экземпляров создаваемого массива с помощью опции Учитывать вложенность.

Если опция включена, то количество экземпляров создаваемого массива будет равно произведению количества экземпляров массива-образца на количество экземпляров вложенного массива, а если отключена — просто равно количеству экземпляров массива-образца.

7. Если в массиве-образце имеются удаленные экземпляры, то вы можете управлять количеством экземпляров создаваемого массива с помощью опции Учитывать удаленные.

Если опция включена, создаваемый массив не будет содержать экземпляры, номера которых равны номерам удаленных экземпляров массива-образца, а если отключена — будет содержать.

Все изменения отображаются на фантоме массива.

8. При необходимости используйте следующие возможности:

– Изменение наименования массива.
Для этого активизируйте вкладку Свойства Панели свойств.

– Отмена выбора всех объектов на текущей вкладке Панели свойств.
Для этого нажмите кнопку Указать заново на Панели специального управления.

9. Подтвердите создание массива, нажав кнопку Создать объект на Панели специального управления.

Прервать создание массива можно, нажав кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Разрушение массивов

Другие команды построения массивов


Команда Разрушить вид

Позволяет разрушить один или несколько выделенных видов чертежа.

Команда доступна для всех ассоциативных видов, находящихся в активном или текущем состоянии.

Разрушение вида — разрыв ассоциативной связи вида с моделью КОМПАС-3D, изображение которой в нем содержится. При этом вид из ассоциативного превращается в обычный вид чертежа КОМПАС-3D. Вид, ранее существовавший как единый объект, разрушается на отдельные объекты (отрезки, окружности и т.д.).

При разрушении вида чертежа базировавшиеся на нем проекционные виды превращаются в произвольные виды, а виды по стрелке, выносные элементы, разрезы и сечения — разрушаются.

Разрушенный вид может быть отредактирован различными способами: деформация сдвигом, редактирование с помощью характерных точек и др.

Для быстрой отмены ошибочного разрушения ассоциативного вида нажмите кнопку Отменить на Стандартной панели или комбинацию клавиш <Alt>+<BackSpase> либо <Ctrl>+<Z>. Разрушенный вид будет немедленно восстановлен.

Команда разрушения вида может быть использована на этапе оформления чертежей или по окончании работы над ними, когда связь с моделью уже не существенна. Чертеж с разрушенными ассоциативными связями требует меньше машинных ресурсов, он быстрее загружается, перестраивается и т.п.

Ассоциативные виды могут присутствовать в чертежах, созданных в КОМПАС-3D.


Команда Разрушить (графический объект)

Команда Разрушить
(графический объект)

Позволяет разрушить выделенные составные объекты на отдельные примитивы или объекты.

Разрушать можно вставки видов и фрагментов, макроэлементы, ломаные, контуры, мультилинии, таблицы, размеры, обозначения и некоторые другие объекты.

Команда также доступна в режиме редактирования макроэлемента. В этом случае она позволяет разрушить входящие в редактируемый макроэлемент составные объекты.

Если ни один из объектов нужного типа не выделен, команда будет недоступна.

Если среди выделенных перед вызовом команды объектов были такие, которые невозможно разрушить, они остаются без изменений.

Для окончательного разрушения некоторых объектов необходимо несколько раз вызвать команду Разрушить. Например, мультилиния после разрушения превращается в набор контуров, которые, в свою очередь, могут быть разрушены на отрезки и дуги.

Чтобы полностью разрушить подобные объекты за одно применение команды Разрушить, вызывайте ее, удерживая нажатой клавишу <Shift>.

Для быстрой отмены ошибочного разрушения объектов нажмите кнопку Отменить на Стандартной панели или комбинацию клавиш <Alt>+<BackSpace> либо <Ctrl>+<Z>.

Смотрите также

Команда Разрушить оформление


Команда Разрушить оформление

Позволяет преобразовать оформления всех листов чертежа в набор отрезков и текстов. Информация об оформлениях, присвоенных листам, удаляется из документа.

Команда доступна в контекстом меню любой из таблиц, входящих в оформление листа. После ее вызова появляется запрос на подтверждение разрушения. Вы можете отказаться от разрушения или подтвердить его.

Отменить разрушение оформления чертежа невозможно. Чтобы возвратить прежнее состояние документа, его следует закрыть без сохранения и открыть заново.


Команда Диаметральный размер (документ-модель)

Команда Диаметральный размер
 (документ-модель)

Позволяет проставить диаметральный размер к объектам различного типа.

Пример

Для вызова команды нажмите кнопку Диаметральный размер на инструментальной панели Элементы оформления.

Укажите курсором объект для простановки размера

Размерная линия может быть полная или с обрывом. Для выбора нужного варианта воспользуйтесь группой переключателей Тип на вкладке Размер Панели свойств.

Задайте положение размерной линии, перемещая мышью характерную точку т1.

Диаметральный размер с ручным размещением размерной линии

В поле Текст отображается автоматически сформированная размерная надпись. Чтобы вызвать диалог редактирования и настройки размерной надписи, щелкните мышью в этом поле.

Элементы управления, расположенные на вкладке Параметры, позволяют настроить параметры размеров (вид стрелки, способ размещения текста и т.п.).

Элементы управления, расположенные на вкладке Свойства, позволяют задать наименование размера в Дереве построения и цвет отрисовки размерных линий.

Размещение размерной надписи на полке

Особенности простановки диаметрального размера

Смотрите также

Другие элементы оформления


Сменить положение

Кнопка, позволяющая направить размерные линии углового размера в противоположную сторону. Длина размерных линий при этом не изменяется.


Выносная линия

Переключатель, управляющий отрисовкой выносной линии линейного размера с обрывом и радиальных размеров.

Чтобы включить или отключить создание выносной линии, нажмите кнопку-переключатель.


Выносная линия 1

Переключатель, управляющий отрисовкой первой выносной линии размера.

Чтобы включить или отключить создание выносной линии, нажмите кнопку-переключатель.


Выносная линия 2

Переключатель, управляющий отрисовкой второй выносной линии размера.

Чтобы включить или отключить создание выносной линии, нажмите кнопку-переключатель.


Команда Угловой размер (графический документ)

Команда Угловой размер
 (графический документ)

Позволяет проставить простой угловой размер.

Для вызова команды нажмите кнопку Угловой размер на инструментальной панели Размеры. На Панели свойств появятся элементы управления.

Задайте первую и вторую стороны угла. Для этого укажите прямолинейные объекты или точки, при соединении которых образуются стороны угла. Прямолинейные объекты указываются при нажатой кнопке Выбор базового объекта, а точки — при отжатой.

Подробнее об указании сторон углов...

На Панели свойств отображаются координаты вершины угла, точек привязки т1 и т2.

Если вы случайно ошиблись при выборе объектов, нажмите кнопку Указать заново на Панели специального управления и выберите новые стороны угла.

В поле Текст на вкладке Размер отображается автоматически сформированная размерная надпись. Чтобы вызвать диалог редактирования и настройки размерной надписи, щелкните мышью в этом поле.

В списке Размещение текста отображается текущий способ размещения размерной надписи. Если необходимо, смените способ размещения надписи. Подробнее...

Укажите точку т3, определяющую положение размерной линии и надписи. Те концы отрезков, ближе к которым окажется размерная линия, будут приняты за точки привязки размера.

Если выбрано размещение текста на полке, укажите точку начала полки т4.

Управление ориентацией размера

Угловые размеры с ручным размещением размерной надписи
(способ задания сторон углов — по двум отрезкам)

Выбор вида выносных линий

Настройка параметров размеров (выбор вида стрелки, положения надписи и т.п.).

При редактировании проекционного размера часть элементов управления Панели свойств недоступна. Соответствующие параметры размера передаются в чертеж из модели, поэтому их ручное редактирование невозможно.

Смотрите также

Особенности использования команды в параметрическом режиме

Другие размеры

Выравнивание размерных линий

Редактирование углового размера с помощью мыши


Вид выносных линий

Группа переключателей Выносные линии на вкладке Размеры позволяет указать требуется ли отрисовывать выносные линии от центра или от точек привязки размера.

Подробнее...


Команда Выбор базового объекта (для угловых размеров)

Команда Выбор базового объекта
(для угловых размеров)

Позволяет выбрать режим указания объектов для простановки угловых размеров — указание отрезков или указание точек.

– Если кнопка нажата, в качестве сторон угла указываются отрезки. Одна из конечных точек первого отрезка принимается за точку привязки размера т1, второго — за точку привязки т2. Положение вершины угла вычисляется автоматически.

– Если кнопка отжата, указывается точка, которая будет являться вершиной угла, а затем точки т1 и т2 на его сторонах — точки привязки размера. При наведении указателя мыши на отрезок срабатывает одна из привязок, включенных в документе. Если ни одна из привязок не сработала, то выбирается не точка на отрезке, а отрезок целиком.

Если требуется проставить угловой размер, задав одну из его сторон отрезком, а вторую двумя точками используйте один из следующих способов:

– в режиме указания отрезков (кнопка Выбор базового объекта нажата) — укажите отрезок, отожмите кнопку Выбор базового объекта и укажите две точки,

– в режиме указания точек (кнопка Выбор базового объекта отжата) — укажите отрезок, удерживая клавишу <Alt>, а затем укажите две точки.

За первую точку привязки размера принимается одна из конечных точек отрезка, а за вторую — одна из указанных точек. Отрезок и прямая, проходящая через указанные точки, образуют угол. Положение вершины угла вычисляется автоматически.


Команда Диаметральный размер (графический документ)

Команда Диаметральный размер
 (графический документ)

Позволяет построить диаметральный размер.

Для вызова команды нажмите кнопку Диаметральный размер на инструментальной панели Размеры.

Укажите курсором окружность или дугу, которую требуется образмерить.

Если вы случайно ошиблись при выборе окружности, нажмите кнопку Указать заново на Панели специального управления и выберите другую окружность.

Размерная линия может быть полная или с обрывом. Для выбора нужного варианта воспользуйтесь группой переключателей Тип на вкладке Размер Панели свойств.

Размерная линия с обрывом выходит за центр окружности на расстояние, равное 1/5 ее радиуса, но не менее, чем на расстояние, установленное в данном документе для выхода размерной линии за текст. Это значение задается в диалоге настройки отрисовки размеров.

В поле Текст на вкладке Размер отображается автоматически сформированная размерная надпись. Чтобы вызвать диалог редактирования и настройки размерной надписи, щелкните мышью в этом поле.

В списке Размещение текста отображается текущий способ размещения размерной надписи. Если необходимо, смените способ размещения надписи. Подробнее...

Настройка параметров размеров (выбор вида стрелки, положения надписи и т.п.).

Укажите точку т1, определяющую положение размерной линии и надписи.

1. Диаметральные размеры с фиксированным размещением текста надписи

Если выбрано размещение размерной надписи на полке, надпись может быть расположена, как показано на рис. 2.

2. Диаметральные размеры с надписью, размещенной на полке: а) линия-выноска не совпадает с размерной линией, б) линия-выноска совпадает с размерной линией
а) | б)

– Чтобы расположить размерную надпись, как показано на рис. 2, а, задайте точку т1, определяющую начало линии-выноски, и точку т2 начала полки. Точка т1 должна лежать внутри окружности.

– Чтобы расположить размерную надпись, как показано на рис. 2, б, задайте только точку т2 начала полки. Заданная точка должна лежать вне окружности.

Формирование зазора между выносной линией и точкой привязки

При редактировании проекционного размера часть элементов управления Панели свойств недоступна. Соответствующие параметры размера передаются в чертеж из модели, поэтому их ручное редактирование невозможно.

Смотрите также

Другие размеры


Тип диаметрального размера

Переключатель, позволяющий указать тип размерной линии диаметрального размера: полная или с обрывом.

Для выбора нужного варианта вызовите из контекстного меню команду Размерная линия с обрывом или нажмите нужную кнопку в группе Тип на вкладке Размер Панели свойств.

Диаметральный размер: а) с полной размерной линией;
б) с оборванной размерной линией


Команда Линейный размер (графический документ)

Команда Линейный размер
 (графический документ)

Позволяет проставить простой линейный размер.

Для вызова команды нажмите кнопку Линейный размер на инструментальной панели Размеры. На Панели свойств появятся элементы управления.

Задайте точки привязки размера — т1 и т2 (точки выхода выносных линий) одним из следующих способов:

– указание характерных точек объектов или отдельных точек — доступно при отжатой кнопке Выбор базового объекта,

– указание базового объекта (или объектов) — доступно при нажатой кнопке Выбор базового объекта.

Подробнее о способах указания объектов для простановки размеров...

По умолчанию размерная линия параллельна линии, проходящей через точки привязки размера. При этом активен переключатель Параллельно объекту в группе Тип на вкладке Размер. Чтобы построить горизонтальный или вертикальный размер, активизируйте соответствующий переключатель. Подробнее...

В поле Текст на вкладке Размер отображается автоматически сформированная размерная надпись. Чтобы вызвать диалог редактирования и настройки размерной надписи, щелкните мышью в этом поле.

В списке Размещение текста отображается текущий способ размещения размерной надписи. Если необходимо, смените способ размещения. Подробнее...

Укажите точку т3, определяющую положение размерной линии. Если выбрано автоматическое, фиксированное или ручное размещение размерной надписи, то точка т3 определяет также ее положение.

Если выбрано размещение надписи на полке, то точка т3 является начальной точкой линии-выноски. В этом случае необходимо указать точку начала полки т4.

Для точного позиционирования курсора воспользуйтесь привязками или меню геометрического калькулятора в полях т1, т2, т3 и т4 на Панели свойств.

Простановка простого линейного размера

Настройка параметров размеров (выбор вида стрелки, включение/отключение отрисовки выносных линий и т.п.).

Создание размера с наклонными выносными линиями

Формирование зазора между выносной линией и точкой привязки

При редактировании проекционного размера часть элементов управления Панели свойств недоступна. Соответствующие параметры размера передаются в чертеж из модели, поэтому их ручное редактирование невозможно.

Смотрите также

Другие размеры

Выравнивание размерных линий


Команда Выбор базового объекта (для линейных размеров)

Команда Выбор базового объекта
(для линейных размеров)

Позволяет выбрать режим указания объектов для простановки линейных размеров — указание точек привязки размера или указание базовых объектов.

– Если кнопка отжата, указываются точки привязки размера. При наведении на объект указателя мыши срабатывает одна из привязок, включенных в документе. Если ни одна из привязок не сработала, объект выбирается целиком, и точками привязки размера становятся его крайние точки.

– Если кнопка нажата, указывается базовый объект или объекты. При указании одного базового объекта его граничные точки являются точками привязки размера. Если требуется проставить размер между точками различных объектов (например, между центрами двух окружностей), укажите два базовых объекта.
Пока ни один из объектов не выбран, привязки не работают, поэтому при наведении указателя мыши на объект он выбирается целиком. После выбора объекта привязки снова начинают работать, однако возможность выбора базового объекта сохраняется. В данном режиме выбор объекта имеет приоритет перед выбором точек привязки. Поэтому вы можете указать еще один базовый объект.


Команда Наклонить размер

Позволяет наклонить выносные линии линейного размера.

После вызова команды введите значение угла наклона в поле Угол на вкладке Размер Панели свойств или «перетащите» мышью одну из характерных точек размера.

Подробнее...


Команда Текст надписи...

Вызывает диалог ввода размерной надписи, в котором вы можете задать нужное значение размера и настроить его оформление.

Для вызова этого диалога можно также щелкнуть мышью в поле Текст на вкладке Размер Панели свойств.

Кроме того, вы можете вводить разные части размерной надписи по отдельности. Для этого вызовите из контекстного меню поля Текст нужную команду, например, Текст до... или Единицы измерения.... На экране появится диалог ввода выбранной части размерной надписи.


Команда Выровнять размерные линии

Позволяет расположить размерные линии для линейных размеров — на одной прямой, угловых размеров — на одной окружности (или на окружностях с равными радиусами). Выравнивание производится по размеру-образцу.

Выравниваемые размеры можно указывать как после вызова команды (способ 1), так и до вызова (способ 2).

Чтобы произвести выравнивание, выполните следующие действия.

Способ 1.

1. Вызовите команду Выровнять размерные линии из меню Инструменты. Команда доступна, если в графическом документе имеется хотя бы один линейный или угловой размер.

2. Подведите курсор к размеру-образцу, по размерной линии которого требуется произвести выравнивание, и щелкните по нему левой кнопкой мыши. После указания образец подсветится.

3. Укажите курсором один или несколько размеров подряд для выравнивания. При подведении курсора, если размер может быть выровнен, он подсвечивается, а после указания его выносные и размерные линии перестраиваются.

Размер может быть выровнен, если он соответствует типу размера-образца, а для линейных размеров необходимо также, что бы их размерные линии были параллельны размерной линии размера-образца.

Пример выравнивания линейных размеров: а) указание образца, б) результат выравнивания
а) | б)

Обозначение размера-образца остается подсвеченным до конца работы команды.

Чтобы перейти к выравниванию другой группы обозначений, нажмите кнопку Указать заново на Панели специального управления. Затем укажите образец и обозначения для выравнивания.

Способ 2.

1. Выделите на чертеже размеры, которые нужно выровнять. Если в выделение попадут другие объекты, не являющиеся размерами, они не помешают работе команды, а будут проигнорированы.

2. Вызовите команду Выровнять размерные линии и укажите размер-образец. Те из выделенных размеров, которые могут быть выровнены по данному образцу, выровняются, остальные размеры проигнорируются.

Чтобы выровнять сразу несколько групп размеров, например, вертикальные и горизонтальные размеры, нужно выделить все выравниваемые размеры (применяя способ 1 или способ 2) и последовательно указать для них нужные образцы, используя кнопку Указать заново.


Команда Радиальный размер (графический документ)

Команда Радиальный размер
 (графический документ)

Позволяет построить простой радиальный размер.

Для вызова команды нажмите кнопку Радиальный размер на инструментальной панели Размеры.

Укажите курсором окружность или дугу окружности, которую требуется образмерить.

Если вы случайно ошиблись при выборе объекта, нажмите кнопку Указать заново на Панели специального управления и выберите новый объект.

Группа переключателей Тип на вкладке Размер позволяет указать, требуется ли проставить радиальный размер от центра или не от центра окружности.

В поле Текст на этой вкладке отображается автоматически сформированная размерная надпись. Чтобы вызвать диалог редактирования и настройки размерной надписи, щелкните мышью в этом поле.

В списке Размещение текста отображается текущий способ размещения размерной надписи. Если необходимо, смените способ размещения надписи. Подробнее...

Настройка параметров размеров (выбор вида стрелки, положения надписи и т.п.).

Укажите точку т1, определяющую положение размерной линии.

Радиальный размер с фиксированным размещением текста надписи

Если выбрано размещение размерной надписи на полке, укажите точку начала полки т2.

Радиальный размер на полке

Размеры одинаковых радиусов допускается указывать на общей полке. Для такого варианта простановки размеров используются полки с несколькими ответвлениями.

Радиальный размер на полке с ответвлением

Формирование зазора между выносной линией и точкой привязки

При редактировании проекционного размера часть элементов управления Панели свойств недоступна. Соответствующие параметры размера передаются в чертеж из модели, поэтому их ручное редактирование невозможно.

Смотрите также

Редактирование радиального размера

Другие размеры


Простановка радиального размера на полке с несколькими ответвлениями

Радиальный размер на полке с несколькими ответвлениями может быть проставлен следующими способами.

Способ 1

Используется для простановки размера, у которого все размерные линии начинаются от начала полки.

Укажите все окружности (дуги окружностей), которые требуется образмерить, а затем точку т2 начала полки (полка создается автоматически).

Способ 2

Используется для простановки размера с двумя размерными линиями, одна из которых начинается от начала полки, а другая — от ее конца.

1. Укажите первую окружность (дугу окружности), которую требуется образмерить.

2. Создайте полку, переместив курсор при нажатой клавише <Ctrl>.

3. На вкладке Параметры Панели свойств активизируйте переключатель От конца полки.

4. Укажите следующую окружность (дугу окружности).

5. Задайте положение точки т2 начала полки.

Способ 3

Используется для простановки размера с несколькими (более двух) размерными линиями, одни из которых начинаются от начала полки, а другие — от ее конца.

1. Укажите все окружности (дуги окружностей), для которых размерные линии должны начинаться от начала полки.

2. Создайте полку, переместив курсор при нажатой клавише <Ctrl>.

3. На вкладке Параметры Панели свойств активизируйте переключатель От конца полки.

4. Укажите все остальные окружности (дуги окружностей).

5. Задайте положение точки т2 начала полки.

Подробнее о простановке радиального размера на полке с несколькими ответвлениями

Особенности редактирования радиального размера на полке с несколькими ответвлениями


Тип радиального размера

Переключатель, позволяющий указать тип размерной линии радиального размера: от центра или не от центра.

Для выбора нужного варианта вызовите из контекстного меню команду Размерная линия от центра или нажмите нужную кнопку в группе Тип на вкладке Размер Панели свойств.

В обоих случаях размерная линия принадлежит прямой, проходящей через центр образмериваемой окружности. Отличие состоит в следующем. Если размер проставлен от центра, то длина его размерной линии не может быть меньше радиуса. Если размер проставлен не от центра, то длина размерной линии может быть любой.

Радиальный размер: а) с размерной линией от центра;
б) с размерной линией не от центра


Команда Радиальный размер с изломом

Радиальный размер с изломом используется, когда требуется образмерить дугу очень малой кривизны, например, как на рисунке.

Рис 1. Радиальные размеры с изломом

В этом случае размерная линия представляет собой ломаную, причем то ее звено, которое оканчивается размерной стрелкой, совпадает с истинным радиусом, проведенным в выбранную точку дуги.

Чтобы построить радиальный размер с изломом, нажмите кнопку Радиальный с изломом на инструментальной панели Размеры.

Укажите курсором окружность или дугу окружности, которую требуется образмерить.

Если вы случайно ошиблись при выборе объекта, нажмите кнопку Указать заново на Панели специального управления и выберите новый объект.

В поле Текст на вкладке Размер отображается автоматически сформированная размерная надпись. Чтобы вызвать диалог редактирования и настройки размерной надписи, щелкните мышью в этом поле.

В списке Размещение текста отображается текущий способ размещения размерной надписи. Если необходимо, смените способ размещения надписи. Подробнее...

Настройка параметров размеров (выбор вида стрелки, положения надписи и т.п.).

Если выбрано фиксированное или ручное размещение размерной надписи, укажите точку т1, определяющую положение размерной линии и надписи.

Рис. 2. Радиальные размеры с изломом с автоматически размещенной надписью

Если выбрано размещение размерной надписи на полке, укажите точку начала полки т2.

Рис. 3. Радиальный размер с надписью, размещенной на полке

Укажите точку C’ — положение фиктивного центра окружности, расположенного ближе к дуге, чем фактический центр.

Чтобы создать несколько размеров с изломом к концентрическим дугам или окружностям с одним фиктивным центром (рис. 1), их следует проставлять подряд, не выходя из команды.

Например, укажите первую окружность, точки т1 и C’. Затем указывайте попарно следующие окружности и точки т1. Новые точки центра создаются автоматически совпадающими с точкой C’.

Формирование зазора между выносной линией и точкой привязки

Редактирование размерной линии с изломом при помощи мыши

Смотрите также

Другие размеры


Команда Авторазмер

Позволяет построить размер, тип которого автоматически определяется системой в зависимости от того, какие объекты указаны для простановки размера.

Пример

Пример

Для вызова команды нажмите кнопку Авторазмер на инструментальной панели Размеры.

Порядок и способы указания геометрических объектов зависят от того, какой именно размер требуется проставить:

Линейный

Линейный с обрывом

Линейный от отрезка до точки

Угловой

Угловой с обрывом

Диаметральный

Радиальный

На вкладках Панели свойств находятся элементы управления, позволяющие настроить различные параметры создаваемого размера.

Возможности настройки авторазмеров практически аналогичны возможностями настройки соответствующих размеров, создаваемых с помощью специальных команд.

Смотрите также

Поиск объектов для авторазмера

Другие размеры


Угловой авторазмер

Для простановки углового авторазмера могут использоваться: отрезки, вспомогательные прямые, объекты осевая линия, оси абсолютной системы координат и системы координат вида. Чтобы создать размер, укажите любые два из перечисленных объектов.

Правила указания объектов для создания авторазмера

Если один из указанных объектов является отрезком с системный стилем Осевая или объектом осевая линия, то тип размера автоматически определяется как Угловой с обрывом. Таким образом, если требуется проставить простой угловой размер, необходимо обращать внимание на стиль линии выбираемых отрезков и тип выбираемых объектов.

На экране появится фантом углового размера.

В поле Текст на вкладке Размер Панели свойств отображается автоматически сформированная размерная надпись. Чтобы вызвать диалог редактирования и настройки размерной надписи, щелкните мышью в этом поле.

Перемещая курсор, выберите тип размера — на острый угол, на тупой угол или на угол больше 180 градусов.

В списке Размещение текста отображается текущий способ размещения размерной надписи. Если необходимо, смените способ размещения. Подробнее...

Укажите точку, определяющую положение размерной линии и надписи.

Настройка параметров размеров (выбор вида стрелки, положения надписи и т.п.).

Смотрите также

Авторазмеры

Особенности использования команды в параметрическом режиме

Угловой авторазмер с обрывом


Угловой авторазмер с обрывом

Для простановки углового авторазмера с обрывом могут использоваться: отрезки, вспомогательные прямые, объекты осевая линия, оси абсолютной системы координат и системы координат вида. Чтобы создать размер, укажите два объекта. Один из них должен быть отрезком с системным стилем Осевая или объектом осевая линия.

Правила указания объектов для создания авторазмера

На экране появится фантом углового размера с обрывом.

В поле Текст на вкладке Размер Панели свойств отображается автоматически сформированная размерная надпись. Чтобы вызвать диалог редактирования и настройки размерной надписи, щелкните мышью в этом поле.

В списке Размещение текста отображается текущий способ размещения размерной надписи. Если необходимо, смените способ размещения. Подробнее...

Укажите точку, определяющую положение размерной линии и надписи.

Настройка параметров размеров (выбор вида стрелки, положения надписи и т.п.).

Смотрите также

Авторазмеры

Простой угловой авторазмер


Диаметральный авторазмер

Для создания диаметрального авторазмера укажите окружность.

Правила указания объектов для создания авторазмера

На экране появится фантом диаметрального размера.

В поле Текст на вкладке Размер Панели свойств отображается автоматически сформированная размерная надпись. Чтобы вызвать диалог редактирования и настройки размерной надписи, щелкните мышью в этом поле.

Размерная линия может быть полная или с обрывом. Для выбора нужного варианта воспользуйтесь группой переключателей Тип.

Группа переключателей Размер на вкладке Размер позволяет указать, требуется ли проставить диаметральный или радиальный размер. При выборе радиального размера система переключается в режим создания этого размера.

В списке Размещение текста отображается текущий способ размещения размерной надписи. Если необходимо, смените способ размещения. Подробнее...

При создании диаметрального авторазмера может быть построен линейный размер со знаком «диаметр» или собственно диаметральный размер. Для простановки линейного размера необходимо перемещать курсор в направлениях осей системы координат текущего вида чертежа (во фрагменте — в направлениях осей абсолютной системы координат, т.е. вертикально или горизонтально), а для простановки диаметрального размера — под углом к этим направлениям.

Размер окружности: а) диаметральный, б) линейный

При простановке диаметрального размера дуги создание размера с выносными линиями невозможно.

Укажите точку, определяющую положение размерной линии и надписи.

Настройка параметров размеров (выбор вида стрелки, способа размещения текста и т.п.).


Линейный авторазмер от отрезка до точки

Для создания линейного авторазмера от отрезка до точки укажите отрезок и точку, или два параллельных отрезка, или отрезок и окружность (дугу окружности).

Правила указания объектов для создания авторазмера

Если один из указанных отрезков имеет системный стиль Осевая или является системным объектом «осевая линия», то тип размера автоматически определяется как Линейный с обрывом. Таким образом, если требуется проставить линейный размер от отрезка до точки, необходимо обращать внимание на стиль линии выбираемых отрезков.

На экране появится фантом линейного размера.

В поле Текст на вкладке Размер Панели свойств отображается автоматически сформированная размерная надпись. Чтобы вызвать диалог редактирования и настройки размерной надписи, щелкните мышью в этом поле.

В списке Размещение текста отображается текущий способ размещения размерной надписи. Если необходимо, смените способ размещения. Подробнее..

Укажите точку, определяющую положение размерной линии и надписи.

Настройка параметров размеров (выбор вида стрелки, положения надписи и т.п.).

Смотрите также

Авторазмеры

Простой линейный авторазмер

Линейный авторазмер с обрывом


Линейный авторазмер

Для создания линейного авторазмера укажите точки и/или объекты в документе. Подробнее...

Правила указания объектов для создания авторазмера

На экране появится фантом линейного размера.

В поле Текст на вкладке Размер Панели свойств отображается автоматически сформированная размерная надпись. Чтобы вызвать диалог редактирования и настройки размерной надписи, щелкните мышью в этом поле.

Перемещая курсор, выберите ориентацию размера — горизонтальный, вертикальный или параллельный объекту.

Задайте положение размерной линии и надписи. Подробнее...

Настройка параметров размеров (выбор вида стрелки, положения надписи и т.п.).

Линейный авторазмер предлагается системой по умолчанию после вызова команды Авторазмер и указания отрезка. Если требуется проставить не простой линейный размер, а, например, линейный размер от отрезка до точки или угловой размер, то продолжайте указание объектов. Система перейдет в режим построения размера, соответствующего указанным объектам.

Смотрите также

Авторазмеры

Линейный авторазмер с обрывом

Линейный авторазмер от отрезка до точки


Линейный авторазмер с обрывом

Для создания линейного авторазмера с обрывом укажите в любой последовательности два параллельных отрезка, один из которых имеет системный стиль линии Осевая или является объектом осевая линия.

Правила указания объектов для создания авторазмера

На экране появится фантом линейного размера с обрывом.

В поле Текст на вкладке Размер Панели свойств отображается автоматически сформированная размерная надпись. Чтобы вызвать диалог редактирования и настройки размерной надписи, щелкните мышью в этом поле.

В списке Размещение текста отображается текущий способ размещения размерной надписи. Если необходимо, смените способ размещения. Подробнее...

Укажите точку, определяющую положение размерной линии и надписи.

Настройка параметров размеров (выбор вида стрелки, положения надписи и т.п.).

Смотрите также

Авторазмеры

Особенности использования команды в параметрическом режиме

Простой линейный авторазмер

Линейный авторазмер от отрезка до точки


Радиальный авторазмер

Для создания радиального авторазмера укажите дугу окружности.

Правила указания объектов для создания авторазмера

На экране появится фантом радиального размера.

В поле Текст на вкладке Размер Панели свойств отображается автоматически сформированная размерная надпись. Чтобы вызвать диалог редактирования и настройки размерной надписи, щелкните мышью в этом поле.

Группа переключателей Тип на вкладке Размер позволяет указать, требуется ли проставить радиальный размер от центра или не от центра окружности

Группа переключателей Размер позволяет указать, требуется ли проставить диаметральный или радиальный размер. При выборе диаметрального размера система переключается в режим создания этого размера.

В списке Размещение текста отображается текущий способ размещения размерной надписи. Если необходимо, смените способ размещения. Подробнее...

Укажите точку, определяющую положение размерной линии и надписи.

Настройка параметров размеров (выбор вида стрелки, положения надписи и т.п.).

Смотрите также

Авторазмеры


Поиск объектов для простановки авторазмера

Для создания авторазмера необходимо указать кривые или точки.

Указание объектов производится по следующим правилам:

– если при указании объекта в «ловушку» курсора попала характерная точка этого объекта, то считается, что указана точка, а не объект,

– если при указании объекта в «ловушку» курсора не попала ни одна характерная точка этого объекта, то считается, что указан объект, т.е. кривая,

– если в «ловушку» попали несколько объектов, то указанным считается объект (точка или кривая), ближайший к центру «ловушки»,

– при использовании привязок Ближайшая точка, Середина или Пересечение указанной считается точка, а не кривая, которой она принадлежит.

Таким образом, для простановки линейного размера нужно указать отрезок или две точки, между которыми требуется проставить размер, для простановки углового размера — два непараллельных отрезка и так далее.

Если указать кривую не удается из-за срабатывания привязки, нажмите при указании объекта клавишу <Alt> — все привязки будут временно отключены. После указания отпустите клавишу.

Чтобы настроить размер «ловушки» курсора, вызовите команду Сервис — Параметры... — Система — Графический редактор — Курсор.


Команда Перпендикулярно объекту

Команда позволяет переместить выбранные полюсы сетки перпендикулярно произвольному плоскому объекту.

После вызова команды рядом с ее названием появляется «галочка».

Укажите нужный объект в Дереве построения или в окне модели. Выбранные полюсы будут перемещаться вдоль перпендикуляра к указанному объекту.

Вы можете использовать команду для задания направления при произвольном перемещении полюсов мышью, а также при изменении положения полюсов с помощью команд Линейное перемещение, Перемещение со сглаживанием, Вращение, Масштабирование и Выравнивание.

Смотрите также

Особенности задания направления перемещения полюсов


Команда Равномерно

Команда позволяет переместить каждый выбранный полюс сетки по прямой, соединяющей центр масштабирования с этим полюсом.

После вызова команды рядом с ее названием появляется «галочка».


Команда Вдоль многоугольника

Команда позволяет переместить выбранные полюсы сетки вдоль одного из следующих направлений:

– По U — полюсы перемещаются вдоль направления U,

– По V — полюсы перемещаются вдоль направления V.

Доступно два варианта перемещения по каждому из направлений: К последующему и К предыдущему. Вызовите команду, соответствующую нужному варианту. Рядом с ее названием появится «галочка».

При выборе варианта К последующему перемещение каждого выбранного полюса выполняется вдоль сегмента сетки, соединяющего этот полюс с полюсом, следующим за ним по направлению U/V, при выборе варианта К предыдущему — против направления U/V.

Вы можете использовать команду для задания направления при произвольном перемещении полюсов мышью, а также при изменении положения полюсов с помощью команды Линейное перемещение.

Смотрите также

Особенности задания направления перемещения полюсов


Команда Параллельно объекту

Команда позволяет переместить выбранные полюсы сетки параллельно произвольному прямолинейному объекту или оси цилиндра, конуса, тора.

После вызова команды рядом с ее названием появляется «галочка».

Укажите нужный объект в Дереве построения или в окне модели. Направление перемещения выбранных полюсов будет определяться указанным объектом.

Вы можете использовать команду для задания направления при произвольном перемещении полюсов мышью, а также при изменении положения полюсов с помощью команд Линейное перемещение, Перемещение со сглаживанием, Вращение, Масштабирование и Выравнивание.

Смотрите также

Особенности задания направления перемещения полюсов


Команда В выбранной плоскости

Команда позволяет переместить выбранные полюсы сетки в плоскости, параллельной произвольному плоскому объекту. Перемещение выполняется масштабированием.

После вызова команды рядом с ее названием появляется «галочка».

Укажите нужный объект в Дереве построения или в окне модели.


Команда В плоскости XY

Команда позволяет переместить выбранные полюсы сетки в плоскости ХY текущей системы координат. Перемещение выполняется масштабированием.

После вызова команды рядом с ее названием появляется «галочка».


Команда В плоскости XZ

Команда позволяет переместить выбранные полюсы сетки в плоскости ХZ текущей системы координат. Перемещение выполняется масштабированием.

После вызова команды рядом с ее названием появляется «галочка».


Команда В плоскости YZ

Команда позволяет переместить выбранные полюсы сетки в плоскости YZ текущей системы координат. Перемещение выполняется масштабированием.

После вызова команды рядом с ее названием появляется «галочка».


Команда В плоскости экрана

Команда позволяет переместить выбранные полюсы сетки в плоскости экрана.

После вызова команды рядом с ее названием появляется «галочка».

Вы можете использовать команду для задания направления при произвольном перемещении полюсов мышью, а также при изменении положения полюсов с помощью команды Линейное перемещение.

Смотрите также

Особенности задания направления перемещения полюсов


Команда По нормали

Команда позволяет переместить выбранные полюсы сетки вдоль нормали к редактируемой грани. После вызова команды рядом с ее названием появляется «галочка».

Вы можете использовать команду для задания направления при произвольном перемещении полюсов мышью, а также при изменении положения полюсов с помощью команд Линейное перемещение и Перемещение со сглаживанием.

Положение нормали может рассчитываться относительно исходной или текущей формы редактируемой грани. Это зависит от состояния опции От исходной, которая находится на Панели свойств при перемещении полюсов По нормали командой Линейное перемещение или Перемещение со сглаживанием.

Если опция включена, положение нормали рассчитывается относительно исходной формы редактируемой грани, если опция отключена — относительно текущей формы этой грани. Исходной формой грани считается та форма, которую имела грань на момент вызова команды Сплайновая форма.

При выборе направления По нормали перемещение ряда полюсов за сегмент ряда невозможно.

Смотрите также

Особенности задания направления перемещения полюсов


Команда По U

Команда позволяет переместить выбранные полюсы сетки вдоль направления U или V сетки.

После вызова команды рядом с ее названием появляется «галочка». При этом перемещение выполняется вдоль направления U.

После повторного вызова команды «галочка» исчезает. При этом перемещение выполняется вдоль направления V.

Смотрите также

Особенности задания направления перемещения полюсов


Команда К предыдущему

Команда позволяет переместить каждый выбранный полюс сетки вдоль сегмента сетки по направлению U/V или против направления U/V.

После вызова команды рядом с ее названием появляется «галочка». При этом перемещение выполняется вдоль сегмента сетки, соединяющего перемещаемый полюс с полюсом, расположенном в том же ряду против направления U/V, т.е. к предыдущему полюсу.

После повторного вызова команды «галочка» исчезает. При этом перемещение выполняется вдоль сегмента сетки, соединяющего перемещаемый полюс с полюсом, следующим за ним по направлению U/V, т.е. к последующему полюсу.

Для выбора направления U или V сетки используется команда По U.

Смотрите также

Особенности задания направления перемещения полюсов


Команда По оси Х

Команда позволяет переместить выбранные полюсы сетки вдоль оси Х текущей системы координат. После вызова команды рядом с ее названием появляется «галочка».

Вы можете использовать команду для задания направления при произвольном перемещении полюсов мышью, а также при изменении положения полюсов с помощью команд Линейное перемещение, Перемещение со сглаживанием, Вращение, Масштабирование и Выравнивание.

Смотрите также

Особенности задания направления перемещения полюсов


Команда По оси Y

Команда позволяет переместить выбранные полюсы сетки вдоль оси Y текущей системы координат. После вызова команды рядом с ее названием появляется «галочка».

Вы можете использовать команду для задания направления при произвольном перемещении полюсов мышью, а также при изменении положения полюсов с помощью команд Линейное перемещение, Перемещение со сглаживанием, Вращение, Масштабирование и Выравнивание.

Смотрите также

Особенности задания направления перемещения полюсов


Команда По оси Z

Команда позволяет переместить выбранные полюсы сетки вдоль оси Z текущей системы координат. После вызова команды рядом с ее названием появляется «галочка».

Вы можете использовать команду для задания направления при произвольном перемещении полюсов мышью, а также при изменении положения полюсов с помощью команд Линейное перемещение, Перемещение со сглаживанием, Вращение, Масштабирование и Выравнивание.

Смотрите также

Особенности задания направления перемещения полюсов


Направление смещения марки 1

Группа переключателей, позволяющая выбрать, в какую сторону от координационной оси смещена марка 1 (см. рис.).

Направление 1

Направление 2

Чтобы изменить направление смещения марки относительно оси, активизируйте переключатель Направление 1 или Направление 2.

Переключатели доступны, если активизирован переключатель Марка.


Направление смещения марки 2

Группа переключателей, позволяющая выбрать, в какую сторону от координационной оси смещена марка 2 (см. рис.).

Направление 1

Направление 2

Чтобы изменить направление смещения марки относительно оси, активизируйте переключатель Направление 1 или Направление 2.

Переключатели доступны, если активизирован переключатель Марка.


Команда Прямая координационная ось

Позволяет создать обозначение прямой координационной оси, используемое в строительной документации.

Для вызова команды нажмите кнопку Прямая координационная ось на инструментальной панели Обозначения для строительства или выберите ее название из меню Инструменты — Обозначения для строительства.

Укажите начальную точку оси (т1). На экране появится фантом обозначения с умолчательными параметрами.

Чтобы ввести надпись в обозначение, вызовите диалог ввода текста. Для этого щелкните мышью в поле Текст на Панели свойств или вызовите команду Текст надписи... из контекстного меню.

Пример использования и параметры прямой координационной оси

Чтобы при вводе текста производилось автоматическое присвоение обозначений маркам, активизируйте переключатель Автопродолжение. Выберите из контекстных меню поля Текст номер, букву и индекс текущего обозначения. В режиме автопродолжения следующей марке будет присвоено следующее по порядку обозначение.

Формирование обозначения координационной оси

Укажите конечную точку оси (т2).

В документе будет создана прямая координационная ось, выходящая за точки т1 и т2 на величины выступов. При этом длина отрезка между точками т1, т2 и угол оси будут определены автоматически и занесены в поля Длина и Угол.

Во время построения оси можно изменить параметры отрисовки оси и параметры выступов.

Совет...

Вы можете создать несколько обозначений за один вызов команды Прямая координационная ось.

Чтобы завершить команду, нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

По умолчанию включен режим автоматического создания объекта, о чем свидетельствует нажатая кнопка Автосоздание объекта Панели специального управления. Чтобы строить обозначение в ручном режиме, отожмите кнопку.

Чтобы сформировать дополнительные обозначения, создайте ось в ручном режиме и перейдите на вкладку Дополнительные обозначения Панели свойств для добавления и настройки дополнительных обозначений.

а) | б) | в)
Элементы дополнительных обозначений: а) указатель ориентации, б) марка, в) текст

Завершив построение оси, нажмите кнопку Создать объект.

Смотрите также

Дуговая координационная ось

Круговая координационная ось

Создание и редактирование дополнительных обозначений координационной оси

Другие обозначения для строительства


Направление в точке

Переключатель, позволяющий задать направление касательного вектора в текущей точке дуги. Направление касательного вектора задается с помощью направляющих объектов. Направляющий объект следует указывать в Дереве построения или в окне модели (эскиз следует указывать в Дереве построения).

Кроме того, направляющим объектом может служить вектор. Чтобы создать этот вектор, нажмите кнопку Построение вектора на Панели специального управления. В этом случае направление касательного вектора будет совпадать с направлением построенного вектора.

Название указанного объекта отображается в поле рядом с переключателем. Если направление задано вектором, то в этом поле отображается слово «Вектор».

– Чтобы изменить заданное направление касательного вектора в текущей точке, активизируйте переключатель Направление в точке и укажите нужный направляющий объект или постройте вектор.

– Чтобы изменить точку для задания направления, активизируйте переключатель требуемой точки, затем активизируйте переключатель Направление в точке и укажите нужный направляющий объект или постройте вектор.

Направление может быть задано только в одной точке дуги — начальной или конечной. Поэтому, если направление в одной из этих точек было задано, то после указания направления в другой точке выбор объекта для первой точки отменяется.


Команда Нормальный режим

Позволяет установить нормальный режим отображения текстового документа, отчета или спецификации. В этом режиме на экране не показываются элементы оформления — рамка документа и его основная надпись.

Для вызова команды нажмите кнопку Нормальный режим на панели Режимы или выберите ее название из меню Вид.


Команда Округление

Служит для включения и отключения режима округления. Другой способ управления этим режимом — нажатие клавиши <F7>.

Кнопка Округление находится на панели Текущее состояние и является индикатором режима: нажатая кнопка означает, что округление в окне (окнах) текущего документа включено, отжатая — выключено.

Умолчательная настройка режима округления (включен или выключен) для окон новых документов производится в диалоге настройки курсора.

В режиме округления числовые параметры создаваемых и редактируемых объектов округляются до значений, кратных текущему шагу курсора. Величина округляется в меньшую сторону, если разница между ней и ближайшим кратным значением меньше половины шага курсора, и в большую сторону в противном случае.

При этом в графических документах и эскизах округляются только линейные величины, а в деталях и сборках — линейные и угловые. Значения координат не округляются.


Работа со списками

Чтобы установить или отменить нумерацию выделенных или набираемых заново абзацев, нажмите кнопку Установить/снять нумерацию или вызовите команду Формат — Список — Установить нумерацию.

Чтобы установить нумерацию текущего и следующих за ним абзацев с начального значения (как нового списка нумерации), нажмите кнопку Новый список или вызовите команду Формат — Список — Новый список.

Чтобы увеличить вложенность выделенных абзацев текста на один уровень, нажмите кнопку Увеличить вложенность или вызовите команду Формат — Список — Увеличить вложенность.

Чтобы уменьшить вложенность выделенных абзацев текста на один уровень, нажмите кнопку Уменьшить вложенность или вызовите команду Формат — Список — Уменьшить вложенность.

Для изменения формата символов нумерации, отступов в списке и других назначений используйте команду Формат — Параметры списка.


Команда Размещение внизу

Позволяет расположить Панель свойств вдоль нижней границы окна программы. При вызове команды рядом с ее названием в меню появляется «галочка».


Команда Размещение слева

Позволяет расположить Панель свойств вдоль левой границы окна программы. При вызове команды рядом с ее названием в меню появляется «галочка».


Команда Размещение справа

Позволяет расположить Панель свойств вдоль правой границы окна программы. При вызове команды рядом с ее названием в меню появляется «галочка».


Команда Размещение вверху

Позволяет расположить Панель свойств вдоль верхней границы окна программы. При вызове команды рядом с ее названием в меню появляется «галочка».


Кнопка Построение точки

Находится на Панели специального управления. Служит для запуска процесса создания точки без выхода из команды построения объекта.

После нажатия кнопки система переходит в процесс создания точки, полностью аналогичный вызываемому командой Точка. Выберите способ построения точки, а затем задайте требуемые для этого способа параметры (введите значения или укажите объекты). Создаваемая точка отображается на экране в виде фантома.

Завершив задание параметров точки, нажмите кнопку Создать объект на Панели специального управления. После этого система автоматически возвращается в команду, из которой процесс создания точки был запущен.

Если точка создается для построения сплайна или ломаной, то после нажатия кнопки Создать объект точка фиксируется, но возврат в команду не происходит. Благодаря этому можно создать сразу несколько вершин сплайна или ломаной. Для возврата в команду следует нажать кнопку Прервать команду.

Созданная точка используется в текущем построении.

Обратите внимание на то, что в одних случаях (команды Ось через вершину по объекту, Масштабирование и др.) созданная точка отображается в Дереве построения как самостоятельный объект, а в других (команды Дуга окружности, Поверхность по сети точек и др.) — нет, т.е. хранится внутри объекта, для которого была создана.

Изменение параметров точки, являющейся самостоятельным объектом, производится путем непосредственного ее редактирования, а изменение параметров точки, хранящейся внутри объекта — при редактировании этого объекта. Подробнее о возможностях редактирования точки, построенной в процессе создания объекта...

Процесс создания точки можно использовать для задания положения компонента при его вставке или редактировании. В этом случае параметры создаваемой точки определяют координаты точки вставки компонента, а новая точка в модели не создается.


Расположение эквидистанты

Переключатель, позволяющий выбрать расположение эквидистанты относительно объекта: справа, слева или с двух сторон.


Направление уклона

Переключатель, позволяющий выбрать направление уклона: наружу или внутрь.


Вставка дробей

Чтобы объявить выделенный или набираемый заново текст дробью малой высоты (с высотой шрифта, равной около 45% от установленной высоты обычного текста), нажмите кнопку Вставить дробь (малой высоты) или вызовите команду Вставка — Дробь — Малой высоты.

Чтобы объявить выделенный или набираемый заново текст дробью средней высоты (с высотой шрифта, равной около 67% от установленной высоты обычного текста), нажмите кнопку Вставить дробь (средней высоты) или вызовите команду Вставка — Дробь — Средней высоты.

Чтобы объявить выделенный или набираемый заново текст дробью нормальной высоты (с высотой шрифта, равной установленной высоте обычного текста), нажмите кнопку Вставить дробь (нормальной высоты) или вызовите команду Вставка — Дробь — Нормальной высоты.


Команда Текст под...

Выводит на экран диалог для ввода дополнительных строк, которые будут размещены под размерной линией.


Команда Ввод значения...

Вызывает на экран диалог ввода значения размера высоты.


Команда Текст до...

Выводит на экран диалог, в котором можно ввести или отредактировать текст, предшествующий основному содержанию размерной надписи (префикс).


Команда Текст после...

Выводит на экран диалог, в котором можно ввести, следующий за основным содержанием размерной надписи (суффикс).


Команда Символ...

Выводит на экран диалог, в котором можно выбрать символ для простановки перед размерным числом.


Команда Квалитет

Выводит на экран диалог, в котором можно назначить нужный квалитет или подобрать его по заданным предельным отклонениям.


Команда Единицы измерения...

Выводит на экран диалог, в котором можно ввести обозначение единиц измерения проставляемого размера. Этот текст размещается в размерной надписи после предельных отклонений.


Процесс задания параметров сечения модели

Данный процесс позволяет задать параметры создаваемого/редактируемого сечения модели.

Процесс запускается:

– вызовом команды Вид — Сечение модели — Отобразить сечение или нажатием кнопки Сечение модели на панели Вид, при условии, что в модели еще не создано ни одного сечения,

– нажатием кнопки Создать сечение или Редактировать сечение в диалоге Сечения модели.

После запуска процесса в окне модели появляется фантом плоскости сечения, а на Панели свойств вкладки Параметры и Свойства.

На вкладке Параметры создайте нужное количество шагов отсечения и задайте их параметры или измените параметры шагов (при редактировании сечения). Список шагов отсечения отображается на панели Шаг отсечения. Параметры задаются для шага, указанного в списке.

Способ задания параметров выбирается из списка Способ. Доступны следующие варианты:

– Свободное размещение,

– Смещенная плоскость,

– Повернутая плоскость,

– Параллелепипед,

– Зона.

При выборе способа задания параметров набор элементов Панели свойств изменяется.

В некоторых случаях при настройке параметров шага отсечения используются объекты, имеющиеся в модели. Если требуется перевыбрать объекты, нажмите кнопку Указать заново на Панели специального управления.

При размещении плоскости сечения способом Свободное размещение, Смещенная плоскость или Повернутая плоскость вы можете управлять направлением отсечения. Чтобы сменить направление отсечения на противоположное, нажмите кнопку Сменить направление.

При использовании этих способов размещения вы также можете задать такую ориентацию модели, при которой плоскость сечения параллельна плоскости экрана. Для этого нажмите кнопку Вид по нормали к плоскости сечения на Панели специального управления.

Чтобы в месте сечения модели полученной плоскостью отображалась фантомная грань (или грани), включите опцию Закрашивать сечение. Фантомная грань не является объектом и отображается только при включенном режиме сечения модели.

Чтобы фантомная грань (или грани) не отображалась в модели, отключите опцию.

Включение/отключение опции Закрашивать сечение выполняется для всего создаваемого сечения, а не для отдельных его шагов, т.е. фантомные грани отображаются (либо не отображаются) для всех шагов отсечения.

На вкладке Свойства вы можете выполнить следующие действия:

– задать имя сечения с помощью поля Наименование,

– задать цвет и оптические свойства фантомной грани, используя группу элементов Назначить цвет.

Для завершения задания параметров сечения нажмите кнопку Создать объект.

Смотрите также

Создание сечения


Команда Доступ

Позволяет задать пароль на доступ к файлу детали, изменить пароль или удалить его.

Команда находится в контекстном меню детали, выделенной в Дереве построения.

После вызова команды на экране появляется диалог для задания или удаления пароля.

Завершив ввод или удаление пароля, сохраните модель.

Пароль, если он задан, будет запрашиваться каждый раз при загрузке файла модели.

Подробнее об установке пароля на доступ к модели...


Команда Редактировать в окне (окно Технические требования)

Команда Редактировать в окне
(окно Технические требования)

Позволяет перейти в окно режима работы с техническими требованиями.

Чтобы вернуться к работе с моделью, закройте данное окно.

Окно режима работы с техническими требованиями удобно использовать, если требуется:

– просматривать, как будет выглядеть текст (разбиение на строки) при выводе на печать;

– работать с блоками готовых текстов из текстовых файлов (*.txt) или текстовых документов КОМПАС-3D (*.kdw);

– выполнять проверку текста на разных языках.


Команда Редактировать источник

Позволяет открыть для редактирования источник вставки.

Команда доступна в контекстном меню вставки, выделенной в окне документа или в Дереве чертежа.

– Если команда вызвана для вставки, сделанной внешней ссылкой, произойдет открытие файла-источника.

– Если команда вызвана для взятого в документ фрагмента, то внутри документа-владельца будет открыто окно, в котором можно отредактировать выбранный фрагмент.

Редактирование вставок видов, взятых в документ, невозможно, поэтому для них команда Редактировать источник недоступна.


Команда Редактировать обозначение...

Позволяет вызвать диалог, в котором можно ввести составное обозначение документа.

Команда вызывается из контекстного меню ячейки Обозначение основной надписи или объекта спецификации.

Подробнее...

Если обозначение не составное, а простое, его можно ввести непосредственно в ячейку Обозначение.


Настройка параметров отражения компонентов(для зеркального исполнения и сопряжения Симметрия)

Настройка параметров отражения компонентов
(для зеркального исполнения и сопряжения Симметрия)

Данная настройка выполняется в следующих случаях:

– при изменении положения компонента зеркального исполнения (настраивается компонент зеркального исполнения, который является зеркальной или симметричной вставкой исходного компонента),

– при наложении на компоненты сопряжения Симметрия (настраивается взаимное положение компонентов сопряжения).

Для изменения параметров отражения выполните следующие действия.

С помощью переключателей группы Способ выберите способ отражения компонента:

– Зеркальное отражение,

– Симметричное расположение.

При выборе способа Зеркальное отражение дополнительные настройки не требуются.

Для способа Симметричное расположение необходимо настроить параметры положения компонента. Выберите вариант настройки, активизировав соответствующий переключатель.

– Типовое положение

На Панели свойств появляется предопределенный список объектов исходного компонента (для исполнения) или первого компонента (для сопряжения), которые могут использоваться для определения положения настраиваемого компонента. Выберите нужную строку списка.

– Положение при ручном указании объекта

В окне модели появляется Окно модели — источника исходного компонента (для исполнения) или первого компонента (для сопряжения). Данное окно позволяет вручную указать объект, который будет использоваться для расчета положения настраиваемого компонента.

Вид окна модели-источника и работа в нем

Выберите нужный объект. Его наименование появится в поле Объект внутренней симметрии Панели свойств.

– Положение по базовому компоненту (вариант доступен только при настройке положения компонента зеркального исполнения)

Выберите базовый компонент в Дереве построения или в окне модели. Его наименование появится в поле Положение по базовому компоненту.

Под базовым компонентом понимается компонент, относительно которого сохраняется положение настраиваемого компонента. В качестве базового может быть выбран компонент, который расположен на одном уровне с настраиваемым и получен способом Симметричное расположение компонента. Наименование выбранного компонента появляется в соответствующем поле.

При изменении параметров отражения в окне модели изменяется положение настраиваемого компонента (для сопряжения) или фантома настраиваемого компонента (для зеркального исполнения).

Вы можете отменить ручной выбор объекта или выбор базового компонента, нажав кнопку Указать заново.

Чтобы завершить изменение параметров, нажмите кнопку Применить на Панели специального управления.

Кнопка Прервать команду позволяет отказаться от произведенных изменений.


Настройка параметров размещения компонентов сопряжения

Если в качестве объектов сопряжения Симметрия выбраны компоненты, на Панели свойств отображается кнопка Настроить.... Она позволяет изменить взаимное положение компонентов сопряжения, выбрав для них другой способ размещения.

Кнопка присутствует на Панели свойств только в том случае, если системы координат обоих компонентов либо правосторонние, либо левосторонние.

Подробнее о системах координат...

Чтобы выполнить настройку, нажмите кнопку Настроить... на Панели свойств. Запустится процесс настройки параметров размещения компонента.

При изменении параметров размещения один из компонентов сопряжения изменяет свое положение в окне модели. Это может быть как первый, так и второй компонент сопряжения, в зависимости от дополнительных ограничений, наложенных на компоненты.

После завершения настройки система вернется в процесс создания сопряжения.


Команда Редактировать эскиз

Позволяет отредактировать эскиз выделенного элемента. После вызова команды происходит переход в режим эскиза.

Признаком того, что режим эскиза включен, является отображение нажатой кнопки Эскиз на панели Текущее состояние и появление значка режима эскиза в окне документа.

Завершив изменение эскиза, отожмите кнопку или щелкните мышью по значку режима.

После этого элемент (и вся модель) перестраивается в соответствии с новыми параметрами эскиза.

Смотрите также

Команда Разместить эскиз


Команда Редактировать

Позволяет перейти к редактированию выделенного объекта.

После вызова команды на Панели свойств появляются те же элементы управления, что и при создании объекта. С их помощью вы можете изменить любые параметры объекта.


Команда Редактировать источник

Позволяет открыть для редактирования файл данных, являющийся источником для группы.

Файл будет открыт в окне программы, соответствующей его типу (текстового редактора, электронных таблиц MS Excel или OpenOffice.org Calc).

Чтобы изменения группы, связанные с редактированием файла, вступили в силу, необходимо выполнить следующие действия:

– сохранить изменения файла.

– перестроить изображение.


Команда Редактировать в Окне подготовки данных (меню ассоциативного отчета)

Команда Редактировать в Окне подготовки данных
(меню ассоциативного отчета)

Позволяет перейти в Окно подготовки данных для редактирования ассоциативного отчета.

Команда находится в контекстном меню выделенного в документе ассоциативного отчета. После вызова команды отчет отображается в Окне подготовки данных. Доступны элементы управления для изменения его внешнего вида: стиля отчета, компоновки, содержимого ячеек.

В этом режиме невозможно управлять отображением данных в виде ссылок или ассоциативностью отчета, выбирать другой документ для размещения.

Отредактируйте отчет в Окне подготовки данных.

Чтобы подтвердить изменения, нажмите кнопку Создать отчет на Панели специального управления.

Способы редактирования отчета


Команда Редактировать

Позволяет отредактировать макроэлемент, вставленный из прикладной библиотеки, средствами этой библиотеки.

Команда доступна в контекстном меню пиктограммы библиотечного макроэлемента в Дереве построения.


Команда Редактировать

Позволяет изменить параметры выбранного объекта.

После вызова команды на Панели свойств появляются те же элементы управления, что и при создании объекта.

Отредактируйте нужные параметры и нажмите кнопку Создать объект на Панели специального управления.

После этого модель будет перестроена в соответствии с новыми параметрами отредактированного объекта.

Если команда Редактировать вызвана для эскиза, то система перейдет в режим редактирования этого эскиза.

Признаком того, что режим редактирования эскиза включен, является отображение нажатой кнопки Эскиз на панели Текущее состояние и появление значка режима эскиза в окне документа.

Завершив изменение эскиза, отожмите кнопку или щелкните мышью по значку режима. После этого модель перестроится в соответствии с новыми параметрами эскиза.


Команда Типы загрузки

Позволяет выполнять различные действия с типами загрузки в сборке, в зависимости от способа ее вызова.

– Команда Типы загрузки может быть вызвана из контекстного меню сборки или нажатием кнопки Примененный тип загрузки на инструментальной панели Текущее состояние. Она позволяет создавать, редактировать, удалять типы загрузки сборки, а также применять к сборке.

– Команда Типы загрузки — Выбрать... может быть вызвана из контекстного меню компонента-подсборки или нажатием кнопки Примененный тип загрузки на инструментальной панели Текущее состояние (при выделенном компоненте-подсборке). Она позволяет применять к компоненту-подсборке тип загрузки, ранее созданный в его файле-источнике.

Работа с типами загрузки сборки

После вызова команды Типы загрузки на Панели свойств доступны элементы управления типами загрузки сборки. Выполните следующие действия.

1. Чтобы создать или отредактировать тип загрузки, загрузите компоненты необходимым образом и/или наложите запрет на редактирование компонентов до или после вызова команды.

Для создания пользовательского типа загрузки нажмите кнопку Создать. Подробнее о создании...

Для редактирования типа загрузки укажите его в списке и нажмите кнопку Редактировать. Подробнее о редактировании...

Введите параметры в появившемся диалоге.

Пароли для типов загрузки сборки

2. Чтобы удалить тип загрузки, укажите его в списке и нажмите кнопку Удалить объект. Подробнее об удалении...

3. Чтобы применить тип загрузки сборки, укажите его в списке и нажмите кнопку Применить на Панели специального управления.

Если выбран для редактирования, удаления, применения тип загрузки, защищенный паролем, введите пароль в появившемся диалоге запроса пароля.

Работа с типами загрузки компонента-подсборки

После вызова команды Типы загрузки — Выбрать... доступен список типов загрузки, созданных в файле компонента-подсборки. Укажите в нем тип загрузки, который требуется применить, и нажмите кнопку Применить на Панели специального управления.

Чтобы отредактировать типы загрузки компонента-подсборки, воспользуйтесь командой Редактировать в окне для этого компонента, а затем в его файле примените команду Типы загрузки, как для сборки.

Загрузка компонентов и состояние запрета на редактирование компонентов изменятся согласно выбранному типу загрузки сборки или компонента-подсборки.

Для выхода из команды нажмите кнопку Прервать команду.

Смотрите также

Выбор типа загрузки компонента

Выбор типа загрузки сборки


Команда Шаблон заполнения текстовой части

Позволяет вызвать диалог, в котором можно отредактировать содержимое шаблона заполнения текстовой части объекта спецификации.

Команда вызывается из контекстного меню ячейки свойства Раздел спецификации, выделенной на Панели свойств в команде Свойства (объекта).

Доступна, если свойство Раздел спецификации имеет значение Стандартные изделия или Материалы и текстовая часть объекта спецификации заполнена по шаблону.

После вызова команды Шаблон заполнения текстовой части на экране появляется диалог, аналогичный диалогу редактировании табличного атрибута. В нем отображается таблица, в ячейках которой можно вводить или изменять значения, редактируя тем самым содержимое полей шаблона.

Подтвердите изменение текста шаблона нажатием кнопки ОК диалога.

Если материал объекта не задан по шаблону, а выбран из файла плотностей или из Справочника Материалы и Сортаменты, то команда Шаблон заполнения текстовой части недоступна.


Команда Редактировать объект спецификации по линии-выноске

Позволяет перейти к редактированию объекта спецификации, которому принадлежит выделенная линия-выноска.

Команду можно вызвать только из контекстного меню, если в графическом документе выделена линия-выноска, принадлежащая объекту спецификации.

Если выделенная линия-выноска принадлежит нескольким объектам спецификации, на экране появляется диалог для выбора того из них, который требуется отредактировать.


Команда Редактировать объект спецификации по геометрии

Позволяет отредактировать объект спецификации, в состав которого входит указанный графический объект.

Для вызова команды выберите ее название из контекстного меню на выделенном графическом объекте.

После вызова команды на экране появляется окно, оформленное в виде строки бланка спецификации, в котором можно отредактировать текстовую часть и дополнительные параметры объекта спецификации.

После редактирования текстовой части и/или дополнительных параметров нажмите кнопку OK.

После сохранения чертежа или синхронизации данных отредактированный объект спецификации будет передан в подключенную к этому чертежу спецификацию.


Команда Редактировать параметры неуказанной шероховатости

Позволяет вызвать диалог, в котором можно задать знак и значение неуказанной шероховатости. Введенные параметры становятся системными свойствами.

Команда вызывается из контекстного меню ячейки свойства Знак неуказанной шероховатости или Параметр неуказанной шероховатости, выделенной на Панели свойств в команде Свойства.


Управление исходными объектами

Переключатель, позволяющий указать, требуется ли оставлять исходные объекты после выполнения команды.


Выносные линии

Переключатель, позволяющий указать, требуется ли масштабировать выносные линии размеров.


Команда Управление пересчетом...

Позволяет открыть Менеджер документа для работы в режиме пересчета.

Команда находится:

– в меню кнопки Пересчитать размеры с учетом допусков на панели Режимы;

– в меню Сервис — Пересчет размеров.

Команда недоступна при редактировании компонента «на месте».

Смотрите также

Режим пересчета размеров модели


Команда Назначить допуск

Позволяет назначить или изменить допуск на размер, а также допуск на значение параметра операции, выраженное в линейных или угловых величинах. Допуск может быть назначен, если в модели создано свойство из переменной указанного выше размера или параметра.

Команда вызывается из контекстного меню ячейки свойства, созданного из переменной, на панели Список свойств. Данная панель отображается на Панели свойств при редактировании свойств модели или ее исполнения.

Для вызова команды необходимо, чтобы строка, содержащая ячейку нужного свойства, была выделена.

Команда присутствует в контекстном меню свойства только в том случае, если допуск может быть назначен.

После вызова команды на экране появляется диалог назначения допуска для линейных или угловых величин (в зависимости от того, в каких величинах выражено значение в ячейке).


Команда Редактировать обозначение

Позволяет вызвать диалог, в котором можно ввести составное обозначение документа или объекта. Введенный текст становится системным свойством Обозначение для документа или объекта.

Команда вызывается из контекстного меню ячейки свойства Обозначение, выделенной на Панели свойств в команде Свойства (объекта).

Подробнее...

Если обозначение не составное, а простое, его можно ввести непосредственно в ячейку свойства Обозначение.


Команда Изменить точку привязки

Позволяет сменить точку привязки:

– ассоциативного отчета,

– ассоциативной таблицы исполнений модели,

– ассоциативной таблицы отчета по массиву.

Команда находится в контекстном меню выделенного в документе ассоциативного отчета/ассоциативной таблицы. После вызова команды запускается процесс, в котором можно выбрать другую точку привязки.

Выберите точку привязки из списка Точка привязки на Панели свойств.

Укажите место расположения точки привязки таблицы курсором или путем ввода координат на Панели свойств.

При необходимости отредактируйте координаты точки вставки таблицы. Для этого расфиксируйте поля Точка вставки на Панели свойств и укажите новое положение точки курсором или путем ввода координат.

Чтобы подтвердить изменения, нажмите кнопку Создать объект на Панели специального управления.


Команда Оформление чертежей и спецификаций...

Позволяет создать новые или отредактировать уже имеющиеся стили оформления чертежей и спецификаций. В состав оформления входят внешняя и внутренняя рамки документа, а также основная надпись.

После вызова команды на экран выводится диалог работы со стилями оформления.


Команда Редактировать макроэлемент (графический)

Команда Редактировать макроэлемент
(графический)

Позволяет перейти в режим редактирования макроэлемента.

В этом режиме можно выполнять следующие действия:

– редактировать отдельные объекты макроэлемента,

– строить новые или добавлять существующие объекты в макроэлемент,

– создавать или удалять характерную точку макроэлемента,

– создавать, добавлять, удалять линии-выноски макроэлемента.

Чтобы перейти в режим редактирования макроэлемента, дважды щелкните мышью по макроэлементу или, выделив его, вызовите команду Редактировать макроэлемент. Для вызова команды нажмите кнопку Редактировать макроэлемент на инструментальной панели Вставки и макроэлементы или панели Режимы, либо выберите ее название из меню Редактор.

Пока система находится в режиме редактирования макроэлемента, кнопка Редактировать макроэлемент остается нажатой. В окне документа появляется значок режима. Редактируемый макроэлемент отмечается в Дереве чертежа пиктограммой — «замком».

В режиме редактирования объекты макроэлемента становятся доступными для редактирования. Все остальные объекты недоступны — они отображаются на экране стилем отрисовки фоновых видов. Все объекты, построенные в режиме редактирования макроэлемента, автоматически включаются в его состав.

– Отредактируйте отдельные объекты макроэлемента. Вы можете построить новые объекты, в том числе и многослойные, чтобы включить их в макроэлемент, а также удалить имеющиеся.

– Чтобы добавить в макроэлемент объект из числа имеющихся в документе, воспользуйтесь командой Добавить геометрию.

– Чтобы создать или удалить характерную точку макроэлемента, воспользуйтесь командой Задать характерную точку.

– Чтобы создать линию-выноску в макроэлементе, воспользуйтесь командой Линия-выноска объекта.

После создания макроэлемента для возвращения в режим работы с документом отожмите кнопку Редактировать макроэлемент, или вызовите команду из меню Редактор, или щелкните мышью по значку режима редактирования в окне документа.

Примеры использования команды редактирования макроэлемента...

Смотрите также

Редактирование и удаление линии-выноски

Редактирование характерной точки макроэлемента


Команда Название...

Позволяет ввести или отредактировать текст названий таблиц, размещенных в графическом документе. Команда находится в контекстном меню выделенной в документе таблицы, в том числе и ассоциативной.

После вызова команды на экране появляется диалог ввода названия таблиц.

Подробнее о вставке названий таблиц...


Команда Редактировать объект

Позволяет отредактировать вставленный в текст объект (таблицу, фрагмент), на котором находится курсор.

Другим способом перехода к редактированию объекта является двойной щелчок на нем левой кнопкой мыши.


Размещение текста относительно точки привязки

Группа переключателей, позволяющая выбрать расположение текста относительно точки привязки. Доступны три варианта размещения: слева, справа и по центру.

Нажмите кнопку Справа, если текст должен располагаться с правой стороны то точки, выбранной в качестве точки привязки. С этой точкой будет совпадать крайняя левая точка первой текстовой строки.

Нажмите кнопку По центру, если текст должен располагаться симметрично относительно точки, выбранной в качестве точки привязки. С этой точкой будет совпадать центральная точка первой текстовой строки.

Нажмите кнопку Слева, если текст должен располагаться с левой стороны то точки, выбранной в качестве точки привязки. С этой точкой будет совпадать крайняя правая точка первой текстовой строки.

Выбор расположения текста относительно точки привязки не влияет на способ выравнивания абзацев внутри текста. Например, текст, абзацы которого выровнены по левому краю, может размещаться справа от точки привязки.


Команда Оформление текстовых документов...

Позволяет создать новые или отредактировать уже имеющиеся стили оформления текстовых документов. В состав оформления входят внешняя и внутренняя рамки документа, размер полей, а также основная надпись.

После вызова команды на экран выводится диалог работы со стилями оформления.


Команда Основные надписи...

Позволяет создать новые или отредактировать уже имеющиеся основные надписи (штампы) для оформления документов.

После вызова команды на экран выводится диалог работы с основными надписями.


Команда Копировать(меню окна Информация)

Команда Копировать
(меню окна Информация)

Позволяет копировать выделенный фрагмент в буфер обмена Windows.

Предыдущее содержимое буфера обмена будет удалено.

Команда доступна если часть или все содержимое окна просмотра выделено.


Команда Вырезать(меню окна Информация)

Команда Вырезать
(меню окна Информация)

Позволяет копировать выделенный фрагмент текста в буфер обмена Windows. Этот фрагмент будет удален из окна просмотра.

Предыдущее содержимое буфера обмена будет удалено.

Команда доступна, если часть или все содержимое окна просмотра выделено.


Команда Удалить(меню окна Информация)

Команда Удалить
(меню окна Информация)

Позволяет удалить выделенный фрагмент из окна просмотра.

Команда доступна, если часть или все содержимое окна просмотра выделено.


Команда Выход(меню окна Информация)

Команда Выход
(меню окна Информация)

Позволяет завершить работу команды измерения.


Команда Найти(меню окна Информация)

Команда Найти
(меню окна Информация)

Позволяет найти в окне просмотра заданную строку текста. После вызова команды на экране появится диалог, в котором вы можете задать параметры поиска.


Команда Шрифт(меню окна Информация)

Команда Шрифт
(меню окна Информация)

Позволяет задать параметры шрифта для отображения результатов измерений в окне просмотра. После вызова команды на экране появится диалог, в котором вы можете выбрать название шрифта и задать его параметры.


Команда Вставить(меню окна Информация)

Команда Вставить
(меню окна Информация)

Позволяет вставить текстовое содержимое буфера обмена Windows в окно просмотра. Фрагмент будет вставлен от позиции курсора.

Команда доступна, если в буфере обмена содержится текстовый фрагмент.


Команда Печать...(меню окна Информация)

Команда Печать...
(меню окна Информация)

Позволяет вывести на печать содержимое окна просмотра. После вызова команды на экране появится диалог, в котором вы можете задать параметры печати.


Команда Сохранить(меню окна Информация)

Команда Сохранить
(меню окна Информация)

Позволяет сохранить содержимое окна просмотра в текстовый файл. После вызова команды на экране появится стандартный диалог Windows, в котором вы можете ввести имя файла и задать папку для его сохранения.


Команда Выделить все(меню окна Информация)

Команда Выделить все
(меню окна Информация)

Позволяет выделить все содержимое окна просмотра.


Команда Эллипс по центру и трем точкам

Позволяет построить эллипс с заданным центром и проходящий через три указанные точки.

Для вызова команды нажмите кнопку Эллипс по центру и трем точкам на инструментальной панели Геометрия.

Укажите положение центральной точки создаваемого эллипса, а затем точки т1, т2 и т3, через которые он должен проходить.

Для точного позиционирования курсора воспользуйтесь привязками или меню геометрического калькулятора в полях Центр, т1, т2 и т3 на Панели свойств.

Построение эллипса по центру и трем точкам

Выбор стиля линии

Группа переключателей Оси на Панели свойств управляет отрисовкой осей симметрии эллипса.

Для выхода из команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие геометрические объекты


Команда Эллипс по центру и вершине габаритного прямоугольника

Команда Эллипс по центру и вершине
габаритного прямоугольника

Позволяет построить эллипс, вписанный в прямоугольник с заданным центром и вершиной.

Для вызова команды нажмите кнопку Эллипс по центру и вершине габаритного прямоугольника на инструментальной панели Геометрия.

Введите в поле Угол Панели свойств величину угла наклона первой полуоси эллипса к оси абсцисс текущей системы координат (по умолчанию она равна 0°).

Затем укажите центральную точку и вершину прямоугольника, описанного вокруг создаваемого эллипса.

Для точного позиционирования курсора воспользуйтесь привязками или меню геометрического калькулятора в полях Центр и т на Панели свойств.

Длины полуосей эллипса будут рассчитаны автоматически.

Построение эллипса по центру и вершине

габаритного прямоугольника

Выбор стиля линии

Группа переключателей Оси на Панели свойств управляет отрисовкой осей симметрии эллипса.

Для выхода из команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие геометрические объекты


Команда Эллипс по диагонали габаритного прямоугольника

Позволяет построить эллипс, вписанный в прямоугольник с заданной диагональю.

Для вызова команды нажмите кнопку Эллипс по диагонали габаритного прямоугольника на инструментальной панели Геометрия.

Введите в соответствующее поле Панели свойств величину угла наклона первой полуоси эллипса к оси абсцисс текущей системы координат (по умолчанию она равна 0°).

Затем укажите начальную (т1) и конечную (т2) точки диагонали прямоугольника, описанного вокруг создаваемого эллипса.

Для точного позиционирования курсора воспользуйтесь привязками или меню геометрического калькулятора в полях т1 и т2 на Панели свойств.

Длины полуосей эллипса будут рассчитаны автоматически.

Построение эллипса по диагонали габаритного прямоугольника

Выбор стиля линии

Группа переключателей Оси на Панели свойств управляет отрисовкой осей симметрии эллипса.

Для выхода из команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие геометрические объекты


Команда Эллипс по трем вершинам описанного параллелограмма

Команда Эллипс по трем вершинам
описанного параллелограмма

Позволяет построить эллипс, вписанный в параллелограмм с тремя заданными вершинами.

Для вызова команды нажмите кнопку Эллипс по трем вершинам описанного параллелограмма на инструментальной панели Геометрия.

Укажите положения вершин т1, т2 и т3 параллелограмма, описанного вокруг создаваемого эллипса.

Для точного позиционирования курсора воспользуйтесь привязками или меню геометрического калькулятора в полях т1, т2 и т3 на Панели свойств.

Длины полуосей эллипса и угол наклона его первой полуоси к оси абсцисс текущей системы координат будут рассчитаны автоматически.

Построение эллипса по трем вершинам описанного параллелограмма

Выбор стиля линии

Группа переключателей Оси управляет отрисовкой осей симметрии эллипса.

Для выхода из команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие геометрические объекты


Команда Эллипс по центру, середине стороны и вершине описанного параллелограмма

Команда Эллипс по центру, середине стороны
и вершине описанного параллелограмма

Позволяет построить эллипс, вписанный в параллелограмм с заданным центром, серединой стороны и вершиной.

Для вызова команды нажмите кнопку Эллипс по центру, середине стороны и вершине описанного параллелограмма на инструментальной панели Геометрия.

Укажите точку точки центра, затем середину стороны (т1) и вершину (т2) параллелограмма, описанного вокруг создаваемого эллипса.

Для точного позиционирования курсора воспользуйтесь привязками или меню геометрического калькулятора в полях Центр, т1 и т2 на Панели свойств.

Длины полуосей эллипса и угол наклона его первой полуоси к оси абсцисс текущей системы координат будут рассчитаны автоматически.

Построение эллипса по центру, середине стороны

и вершине параллелограмма

Выбор стиля линии

Группа переключателей Оси на Панели свойств управляет отрисовкой осей симметрии эллипса.

Для выхода из команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие геометрические объекты


Команда Эллипс, касательный к двум кривым

Позволяет построить эллипс, касательный к двум заданным объектам.

Для вызова команды нажмите кнопку Эллипс, касательный к двум кривым на инструментальной панели Геометрия.

Укажите точки т1 и т2, в которых создаваемый эллипс должен касаться первого и второго объектов.

Если вы случайно ошиблись при указании точек касания, нажмите кнопку Указать заново на Панели специального управления, а затем укажите нужные точки.

Задайте точку т3, через которую должен проходить создаваемый эллипс.

Для точного позиционирования курсора воспользуйтесь привязками или меню геометрического калькулятора в полях т1, т2 и т3 на Панели свойств.

Построение эллипса, касательного к двум кривым

Выбор стиля линии

Группа переключателей Оси на Панели свойств управляет отрисовкой осей симметрии эллипса.

Для выхода из команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие геометрические объекты


Команда Эллипс

Позволяет построить произвольный эллипс.

Для вызова команды нажмите кнопку Эллипс на инструментальной панели Геометрия.

Укажите центральную точку эллипса и конечную точку первой полуоси т1.

Укажите конечную точку второй полуоси эллипса т2.

Для точного позиционирования курсора воспользуйтесь привязками или меню геометрического калькулятора в полях Центр, т1 и т2 на Панели свойств.

Построение эллипса

Выбор стиля линии

Группа переключателей Оси на Панели свойств управляет отрисовкой осей симметрии эллипса.

Для выхода из команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие геометрические объекты


Команда Удлинить до ближайшего объекта

Позволяет продлить объект до ближайшей точки пересечения (или касания) с другим объектом. Удлинение возможно для отрезков, дуг окружностей и эллипсов.

Для вызова команды нажмите кнопку Удлинить до ближайшего объекта на инструментальной панели Редактирование.

Укажите объект для удлинения.

Удлинение объекта происходит от той его конечной точки, ближе к которой находился курсор при выборе объекта, до ближайшей точки пересечения с другим объектом (в том числе в составе макроэлементов и вставок).

При удлинении объектов учитываются их пересечения с геометрическими объектами, осями и линиями обрыва. Если ни один из этих объектов не пересекается с продолжением объекта, выбранного для удлинения, то удлинение не происходит.

Исходное изображение и изображение после удлинения отрезков

Объекты для продления можно указывать по одному или группой. Для указания группы объектов используется секущий отрезок. Продлены будут те объекты, которые пересекаются этим отрезком.

За один вызов команды вы можете продолжить несколько объектов или несколько раз продолжить один и тот же объект.

Для завершения команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Если имеется несколько объектов, часть из которых нужно продолжить до пересечения с объектом, а часть — усечь в точках пересечения с тем же объектом, воспользуйтесь командой Выровнять по границе.

Имейте в виду, что продолжение объекта с помощью этой команды возможно как до явных точек пересечения с границей, так и до точек пересечения с ее продолжением, в то время как команда Удлинить до ближайшего объекта продолжает объект только до явных точек пересечения с другими объектами.

Смотрите также

Другие команды редактирования


Команда Управление исполнениями...

Позволяет сформировать перечень исполнений модели, задать значения свойств исполнений, выполнять различные действия с дополнительными номерами исполнений.

Команда вызывается следующими способами:

– из меню Редактор,

– нажатием одноименной кнопки на панели Текущее состояние,

– в Дереве исполнений — из контекстного меню любого из исполнений модели,

– в Дереве построения — из подменю Текущее исполнение контекстного меню корневого объекта Дерева.

На панели Текущее состояние, если она расположена горизонтально, справа от кнопки Управление исполнениями находится поле для выбора текущего исполнения.

После вызова команды Управление исполнениями на экране появляется диалог Менеджер документа. В дереве диалога активизирован элемент Исполнения. При этом в правой части диалога отображается список исполнений документа и элементы работы с исполнениями.

Управление исполнениями в Менеджере документа

После активизации в дереве диалога элемента Дополнительные номера в правой части диалога будет отображен список дополнительных номеров исполнений, имеющихся в документе, и элементы работы с дополнительными номерами.

Управление дополнительными номерами в Менеджере документа


Команда Исполнение в дополнительном окне

Команда позволяет создать дополнительное окно Дерева построения для исполнения модели. Доступна в контекстном меню любого исполнения в Дереве исполнений.

В дополнительном окне отображается копия Дерева построения выбранного исполнения. Заголовок дополнительного окна Дерева содержит название этого исполнения.

Подробно о дополнительном окне Дерева построения...


Команда Свойства исполнения

Позволяет изменить свойства исполнения:

– отредактировать список системных и дополнительных свойств,

– изменить цвет и оптические свойства,

– задать параметры для расчета МЦХ — материал и плотность материала либо массу и координаты центра масс,

– рассчитать МЦХ модели (кратко),

– задать параметры штриховки материала для отображения на разрезах/сечениях в ассоциативных видах чертежей.

Особенности задания свойств материала в модели...

Команда Свойства исполнения доступна в контекстном меню исполнения Дерева исполнений.

После вызова команды на Панели свойств появятся вкладки, содержащие элементы управления для настройки свойств детали или сборки.

Элементы управления свойствами детали

Элементы управления свойствами сборки

Изменения настроек распространяются на то исполнение, для которого они сделаны, и не передаются в его зависимые исполнения, уже имеющиеся в модели. Если в дальнейшем из данного исполнения создаются новые исполнения, как зависимые, так и независимые, эти исполнения наследуют измененные настройки.

Смотрите также

Редактирование свойств исполнений...


Команда Создать копию

Команда позволяет сохранить исполнение модели в отдельный файл. Доступна в контекстном меню любого исполнения в Дереве исполнений.

После вызова команды на экране появляется диалог Информация о документе, а после завершения работы в этом диалоге — стандартный диалог сохранения файла. Укажите нужное имя и место расположения файла в этом диалоге.

Исполнение, сохраненное в файл, будет основным исполнением в этом файле.


Команда Разметка страниц

Позволяет установить режим разметки страниц для отображения текстового документа, отчета или спецификации. В этом режиме на экране реалистично показываются элементы оформления — рамка документа и его основная надпись.

В режиме разметки можно перейти к заполнению основной надписи текстового документа или спецификации, дважды щелкнув мышью в поле основной надписи.

В режиме разметки отображаются дополнительные листы текстового документа и спецификации, на которых можно ввести текст.

Для вызова команды нажмите кнопку Разметка страниц на панели Режимы или выберите ее название из меню Вид.


Команда Выбрать подсвеченный объект

Позволяет прервать перебор близко расположенных объектов (выйти из режима перебора), подтвердив выбор подсвеченного объекта.

После вызова этой команды подсвеченным остается объект, которым закончился перебор.

Подтвердить выбор подсвеченного объекта можно также при помощи клавиатуры или мыши. Для этого нажмите клавишу <Enter> или щелкните мышью на подсвеченном объекте или на свободном от изображения участке графического документа.

Для выхода из режима перебора объектов и отказа от выбора какого-либо объекта пользуйтесь командой Отказ от перебора объектов.


Команда Закончить перебор объектов

Позволяет прервать перебор близко расположенных объектов (выйти из режима перебора), оставив выделенным объект, которым закончился перебор.

Для выхода из режима перебора можно также нажать клавишу <Enter>.

Следует отметить, что вызывать команду Закончить перебор необязательно, если для выделенного в результате перебора объекта будет вызываться какая-либо команда редактирования (например, симметрия, ввод атрибутов и т.д.). Команду редактирования можно вызвать сразу, как только нужный объект будет выделен в результате действия команды Следующий объект.

Для выхода из режима перебора объектов и снятия выделения со всех объектов можно щелкнуть мышью на свободном от изображения участке графического документа.


Команда Режим проверки гладкости

Позволяет включить такой режим отображения модели, при котором все грани модели представляются зеркально отражающими окружающую среду. Данный режим позволяет визуально оценить кривизну граней модели, наличие и гладкость их стыков. Для вызова команды нажмите кнопку Режим проверки гладкости на панели Режимы или выберите ее название из меню Сервис.

После вызова команды отображение модели изменяется в соответствии с одним из следующих способов.

– Зебра — в гранях модели отражается сфера с нанесенными на нее полосами. Данный способ является умолчательным.

– Отражение среды — в гранях модели отражается сфера с нанесенным на нее растровым изображением из файла. Способ выбирается при настройке параметров отображения модели.


Команда Эквидистанта кривой(графический документ)

Команда Эквидистанта кривой
(графический документ)

Позволяет построить эквидистанту какого-либо геометрического объекта.

Для вызова команды нажмите кнопку Эквидистанта кривой на инструментальной панели Геометрия.

Настройка параметров эквидистанты

Укажите курсором объект.

Если вы случайно ошиблись и указали объект неверно, нажмите кнопку Выбор объекта на Панели специального управления, а затем укажите курсором нужную кривую.

На экране появится фантом эквидистанты. Если необходимо, измените параметры эквидистанты.

Зафиксируйте фантом, щелкнув по нему мышью или нажав кнопку Создать объект на Панели специального управления.

Пример эквидистанты кривой

Выбор стиля линии

За один вызов команды можно построить произвольное количество эквидистант.

Для выхода из команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие геометрические объекты


Обход углов

Переключатель, позволяющий выбрать способ обхода углов: срезом или скруглением.


Вырожденные участки

Переключатель, позволяющий указать, требуется ли оставлять вырожденные участки эквидистанты.


Команда Кинематическая поверхность

Позволяет построить в модели кинематическую поверхность. Кинематическая поверхность образуется путем перемещения сечения вдоль траектории.

Для построения в модели кинематической поверхности выполните следующие действия.

1. Вызовите команду Кинематическая поверхность. Команда доступна, если в модели существует хотя бы один эскиз.

2. Задайте параметры на Панели свойств (они аналогичны параметрам кинематической операции).

• Сечение
Активизируйте переключатель Сечение и укажите в Дереве построения или в окне модели эскиз.

Требования к эскизу-сечению кинематического элемента...

• Траектория
Активизируйте переключатель Траектория. Затем укажите в Дереве построения или в окне модели траекторию: пространственную кривую, линию эскиза, ребро или цепочку из этих объектов в любом сочетании.

Требования к траектории кинематического элемента...

• Тип движения сечения
Выберите тип движения сечения по траектории. Для этого активизируйте нужный переключатель в группе Движение сечения.

Подробнее о типе движения сечения...

• Замыкание поверхности
Если сечение поверхности замкнуто, становится доступна опция Замкнутая поверхность. Включите ее, если требуется добавить к поверхности плоские грани, соответствующие начальному и конечному положению сечения.

Объекты, указанные для выполнения операции, подсвечиваются. Кинематическая поверхность с текущими параметрами отображается на экране в виде фантома. Фантом позволяет визуально проконтролировать правильность задания параметров.

3. При необходимости вы можете:
- ввести наименование поверхности и настроить ее свойства,
- сменить версию оптимизации построения.
Для этого активизируйте вкладку Свойства Панели свойств.

4. Нажмите кнопку Создать объект для завершения операции.

Результат операции — новая поверхность — появляется в графической области. В Дереве модели появляется пиктограмма операции.

Если требуется прервать операцию до ее завершения, нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие команды создания поверхностей


Тип марки дополнительных обозначений

Группа переключателей, позволяющая выбрать тип марки для дополнительного обозначения координационной оси.

Активизируйте переключатель, чтобы создаваемый дополнительный элемент отрисовывался с маркой в виде простой или двойной окружности.

Окружность.

Двойная окружность.

Если активизация переключателя изменяет тип марки, то изображение создаваемого элемента перестраивается.

Переключатели Тип марки становятся доступны, если активизирован переключатель Добавить указатель ориентации оси или Добавить марку в группе Элементы.

– В процессе построения оси элементы управления вкладки Дополнительные обозначения Панели свойств становятся доступны по завершении построения оси при отключенном режиме Автосоздание на Панели специального управления. Если построения ведутся в режиме Автосоздание, его следует отключить до того, как будет указано расположение конечной точки оси (т2).

– В режиме редактирования оси элементы управления вкладки Дополнительные обозначения доступны всегда.


Команда Исключить из расчета последующие

Позволяет исключить из расчета все объекты модели, находящиеся в Дереве построения ниже выделенного объекта (при отображении в Дереве последовательности построения модели).


Группа переключателей Состояние

Группа переключателей, управляющая включением объекта в расчет.


Команда Исключить прежний список

Позволяет исключить из набора выделенных объектов те из них, которые выделялись в предыдущий раз (элементы прежнего списка).

Для вызова команды нажмите кнопку Исключить прежний список на инструментальной панели Выделение или выберите ее название в меню Выделить — Исключить.

Смотрите также

Выделение объектов и отмена выделения


Команда Исключить по стилю кривой

Позволяет отменить выделение элементов активного документа, указав их стиль.

Для вызова команды нажмите кнопку Исключить по стилю кривой на инструментальной панели Выделение или выберите ее название в меню Выделить — Исключить.

После этого на экране появляется диалог со списком стилей элементов, выделенных в активном документе. Выберите из списка стили, с которых нужно снять выделение, и нажмите кнопку ОК. Для выхода из диалога без выбора стиля нажмите кнопку Отмена.

Смотрите также

Выделение объектов и отмена выделения


Команда Исключить по атрибутам

Позволяет отменить выделение объектов активного документа в соответствии с типами или значениями атрибутов.

Для вызова команды выберите ее название в меню Выделить — Исключить.

После этого на экране появляется диалог со списком типов атрибутов, используемых в документе. Выберите из списка типы, по которым нужно исключать объекты, при необходимости задайте условия поиска и нажмите кнопку ОК. Чтобы отказаться от исключения объектов, нажмите кнопку Отмена.

Смотрите также

Выделение объектов и отмена выделения


Команда Исключить по типу

Позволяет отменить выделение элементов активного документа, указав их тип.

Для вызова команды нажмите кнопку Исключить по типу на инструментальной панели Выделение или выберите ее название в меню Выделить — Исключить.

После этого на экране появляется диалог со списком типов элементов, выделенных в активном документе. Выберите из списка типы, с которых нужно снять выделение, и нажмите кнопку ОК. Для выхода из диалога без выбора нажмите кнопку Отмена.

Смотрите также

Выделение объектов и отмена выделения


Команда Исключить группу

Позволяет отменить выделение объектов одной или нескольких именованных групп активного документа.

Для вызова команды нажмите кнопку Исключить группу на инструментальной панели Выделение или выберите ее название в меню Выделить — Исключить.

После этого на экране появляется диалоговое окно со списком имен групп, имеющихся в активном документе. Выберите из списка группы, с которых нужно снять выделение, и нажмите кнопку ОК. Для выхода из диалога без выбора нажмите кнопку Отмена.

Смотрите также

Выделение объектов и отмена выделения


Команда Исключить слой указанием

Позволяет отменить выделение объектов одного или нескольких слоев в текущем виде чертежа или во фрагменте.

Для вызова команды нажмите кнопку Исключить слой указанием на инструментальной панели Выделение или выберите ее название в меню Выделить — Исключить.

Затем укажите элементы, принадлежащие слоям, выделение которых нужно отменить.

Смотрите также

Выделение объектов и отмена выделения


Команда Исключить слой выбором

Позволяет отменить выделение объектов одного или нескольких слоев в текущем виде чертежа или во фрагменте.

Для вызова команды выберите ее название в меню Выделить — Исключить.

После этого на экране появляется диалог со списком слоев, которые выделены в текущем виде или фрагменте. Выберите из списка слои, с которых нужно снять выделение, и нажмите кнопку ОК. Для выхода из диалога без выбора нажмите кнопку Отмена.

Смотрите также

Выделение объектов и отмена выделения


Команда Исключить объект

Позволяет отменить выделение отдельного объекта активного документа.

Для вызова команды нажмите кнопку Исключить объект на инструментальной панели Выделение или выберите ее название в меню Выделить — Исключить.

Укажите курсором элемент, с которого нужно снять выделение. При этом элемент должен попасть в «ловушку» курсора.

За один вызов команды можно отменить выделение произвольного количества объектов.

Смотрите также

Выделение объектов и отмена выделения


Команда Исключить вне рамки

Позволяет отменить выделение объектов активного документа, не попавших в заданную прямоугольную рамку.

Для вызова команды нажмите кнопку Исключить вне рамки на инструментальной панели Выделение или выберите ее название в меню Выделить — Исключить.

Укажите курсором первую и вторую вершины прямоугольной рамки.

С выделенных элементов, целиком оставшихся снаружи заданной рамки, будет снято выделение.

За один вызов команды можно задать произвольное количество рамок. «Вне рамки»

Смотрите также

Выделение объектов и отмена выделения


Команда Исключить вид указанием

Позволяет отменить выделение объектов одного или нескольких видов чертежа.

Для вызова команды нажмите кнопку Исключить вид указанием на инструментальной панели Выделение или выберите ее название в меню Выделить — Исключить.

Затем укажите элементы, принадлежащие видам, выделение которых нужно отменить.

Смотрите также

Выделение объектов и отмена выделения


Команда Исключить вид выбором

Позволяет отменить выделение одного или нескольких видов чертежа. С помощью этой команды снимается выделение видов как единых объектов. Признаком того, что вид был выделен как единое целое, является отрисовка подсвеченной габаритной рамки вокруг этого вида.

Для вызова команды выберите ее название в меню Выделить — Исключить.

После этого на экране появляется диалог со списком выделенных видов, имеющихся в листе чертежа. Выберите из списка виды, с которых нужно снять выделение, и нажмите кнопку ОК. Для выхода из диалога без выбора нажмите кнопку Отмена.

Смотрите также

Выделение объектов и отмена выделения


Команда Исключить секущей ломаной

Позволяет отменить выделение объектов активного документа, пересекая их ломаной линией.

Для вызова команды нажмите кнопку Исключить секущей ломаной на инструментальной панели Выделение или выберите ее название в меню Выделить — Исключить.

Указывайте курсором вершины ломаной так, чтобы ее сегменты пересекались с объектами, выделение которых требуется отменить.

Смотрите также

Выделение объектов и отмена выделения


Команда Исключить секущей рамкой

Позволяет отменить выделение объектов активного документа, частично или полностью попавших в заданную прямоугольную рамку.

Для вызова команды нажмите кнопку Исключить секущей рамкой на инструментальной панели Выделение или выберите ее название в меню Выделить — Исключить.

Укажите курсором первую и вторую вершины прямоугольной рамки.

С выделенных элементов, которые целиком или частично попали внутрь заданной рамки, будет снято выделение.

За один вызов команды можно задать произвольное количество секущих рамок.

Смотрите также

Выделение объектов и отмена выделения


Команда Исключить рамкой

Позволяет отменить выделение объектов активного документа с помощью прямоугольной рамки.

Для вызова команды нажмите кнопку Исключить рамкой на инструментальной панели Выделение или выберите ее название в меню Выделить — Исключить.

Укажите курсором первую и вторую вершины прямоугольной рамки.

С выделенных элементов, целиком попавших в заданную рамку, будет снято выделение.

За один вызов команды можно задать произвольное количество рамок.

Смотрите также

Выделение объектов и отмена выделения


Дополнительно

Позволяет создать в градиентной заливке промежуточные цвета и уровни прозрачности.

Примеры заливок с промежуточными цветами и уровнями прозрачности: а) цилиндрической, б) квадратной, в) линейной
а) | б)

Для вызова команды нажмите кнопку Дополнительно на Панели свойств или выберите ее название из контекстного меню команды Заливка. После вызова команды на экране появляется диалог расширенного управления заливкой.


Команда Выделить по свойствам

Позволяет выделить объекты по указанным свойствам, снять выделение с объектов по указанным свойствам или инвертировать выделение в активном документе.

Объектами для выделения являются геометрические объекты, размеры и обозначения.

Команда доступна, если имеется хотя бы один объект для выделения.

Свойствами, по которым выбираются объекты, являются параметры, которые задаются на Панели свойств при создании того или иного объекта. Например, свойствами объектов раздела Геометрия являются:

– геометрические параметры — координаты точек и центров фигур, размеры;

– стиль линии;

– цвета штриховки и заливки;

– наличие и тип параметрических ограничений.

Принадлежность видам и слоям является общим свойством всех объектов.

Для вызова команды нажмите кнопку Выделить по свойствам на инструментальной панели Выделение или выберите ее название в меню Выделить.

После этого на экране появляется диалог выбора объектов для выделения по свойствам.

1. Выберите в дереве объекты. Для этого включите опции около названий типов объектов.

2. Задайте свойства для объектов каждого типа в таблице, выбрав условия и значения параметров.

Чтобы быстро задать свойства, общие для всех объектов группы, включите в дереве опцию всего раздела, например, Геометрия. Выберите общие условия и значения параметров. Затем в дереве выключите опции типов объектов, не подлежащих внесению в группу. Далее задайте остальные параметры для каждого типа объектов группы.

– Чтобы исключить указанные объекты из ранее выделенных, нажмите кнопку Исключить из группы.

– Чтобы сделать обратное выделение, то есть выделить все объекты документа кроме указанных, нажмите кнопку Инвертировать выделение.

За один вызов команды можно произвести несколько действий по добавлению и исключению объектов нескольких типов, а также инвертированию выделения. Чтобы завершать каждое действие без выхода из диалога, используйте кнопку Применить.

Чтобы завершить выделение, нажмите кнопку ОК диалога.

Чтобы отменить выделение, щелкните в свободном месте окна левой кнопкой мыши или нажмите клавишу <Esc>.

Смотрите также

Выделение объектов и отмена выделения


Команда Продление поверхности

Позволяет продлить грань поверхности или грань тела с нарушенной целостностью за пределы указанных кромок этой грани — открытых ребер.

Продление выполняется путем изменения положения указанных кромок или путем создания новых граней, примыкающих к указанным кромкам.

Грань продлевается за пределы указанных кромок на заданную длину или до указанного точечного объекта.

Пример

Чтобы продлить грань, вызовите команду Продление поверхности на инструментальной панели Поверхности или выберите ее название из меню Операции — Поверхность.

Укажите в окне модели кромку грани или набор кромок. Если требуется продлить грань за пределы всех кромок, то укажите саму грань.

Кромки грани или саму грань можно указать в окне модели и перед вызовом команды.

Выбор объектов в окне модели

Выбор объектов в Дереве построения

На экране появится фантом продления с характерной точкой для задания величины удлинения грани.

Повторное указание объекта отменяет его выбор.

Название выбранного объекта или количество выбранных объектов отображается в поле рядом с переключателем Кромки на Панели свойств.

Группа переключателей Тип позволяет выбрать тип продления грани.

Раскрывающийся список Способ позволяет выбрать способ продления грани.

Все изменения отображаются на фантоме продления в окне модели.

Чтобы сменить объекты, используемые для продления грани, нажмите кнопку Указать заново на Панели специального управления и повторите выбор объектов.

При необходимости вы можете назначить допуски на значения параметров операции, выраженных в линейных или угловых величинах. Для этого используйте кнопку Назначить допуск, расположенную на Панели свойств рядом с полем числового параметра операции.
Подробнее о допусках...
Подробнее о назначении допуска...

Элементы управления, расположенные на вкладке Свойства Панели свойств, позволяют изменить название и цвет объекта.

Чтобы завершить продление грани, нажмите кнопку Создать объект на Панели специального управления.

Отказаться от продления грани можно, нажав кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие команды создания поверхностей

Особенности задания числовых параметров операции в полях Панели свойств


Тип построения

Переключатель, позволяющий указать направление отсчета расстояния до вершины или поверхности.

Изменение направления построения немедленно отражается на фантоме элемента в окне модели.


Команда Поверхность выдавливания

Позволяет построить в модели поверхность выдавливания. Поверхность выдавливания образуется путем перемещения сечения по прямолинейной направляющей.

Для создания в модели поверхности выдавливания выполните следующие действия.

1. Вызовите команду Поверхность выдавливания.

2. Задайте параметры на Панели свойств (они аналогичны параметрам операции выдавливания).

• Сечение
Активизируйте переключатель Сечение. Укажите в Дереве построения или в окне модели объект-сечение: эскиз, грань, пространственную кривую или ребро.

Подробнее об указании сечения...

• Направляющий объект
Если в качестве сечения используется эскиз или плоская грань, то эти же объекты автоматически выбираются в качестве направляющих. Выдавливание производится перпендикулярно плоскости эскиза или грани.

Чтобы задать другой направляющий объект, активизируйте переключатель Направляющий объект. Затем укажите в Дереве построения или в окне модели любой плоский или прямолинейный объект.

Подробнее об указании направляющего объекта...

• Направление выдавливания
Выберите направление выдавливания из списка Направление: Прямое, Обратное, Два направления, Средняя плоскость.

Подробнее о направлении выдавливания...

• Глубина выдавливания
Выберите способ определения глубины выдавливания из списка Способ и задайте соответствующие способу параметры.

Подробнее о задании глубины выдавливания...

Если было выбрано выдавливание В двух направлениях, то способ определения глубины выдавливания и параметры требуется задать дважды — для прямого и обратного направления.
Если был выбран вариант Средняя плоскость, то параметры задаются один раз. При этом возможно выдавливание только на заданное расстояние (в каждую сторону откладывается его половина).

• Угол уклона
Уклон боковых граней элемента возможен, если в качестве сечения используется эскиз или плоская грань, а направление выдавливания перпендикулярно сечению.

Выберите направление уклона с помощью группы переключателей Уклон, а затем введите угол уклона в поле Угол.

Подробнее о задании угла уклона...

• Замыкание поверхности
Если в качестве сечения используется грань или замкнутый эскиз, становится доступна опция Замкнутая поверхность. Включите ее, если требуется добавить к поверхности грани, соответствующие начальному и конечному положению сечения.

Объекты, указанные для выполнения операции, подсвечиваются. Поверхность выдавливания с текущими параметрами отображается на экране в виде фантома. Фантом позволяет визуально проконтролировать правильность задания параметров.

Значения глубины выдавливания и угла уклона можно задать с помощью характерных точек.

3. При необходимости вы можете назначить допуски на значения параметров операции, выраженных в линейных или угловых величинах. Для этого используйте кнопку Назначить допуск, расположенную на Панели свойств рядом с полем числового параметра операции.
Подробнее о допусках...
Подробнее о назначении допуска...

4. При необходимости используйте кнопки Панели специального управления для выполнения следующих действий:

– Построение контура для использования в качестве сечения.

– Построение вектора, задающего направление выдавливания.

– Отмена выбора всех объектов (сечения, направляющего объекта и т.п.).

– Редактирование эскиза-сечения (доступно, если в качестве сечения используется эскиз).

5. При необходимости вы можете ввести наименование поверхности и настроить ее свойства. Для этого активизируйте вкладку Свойства Панели свойств.

6. Нажмите кнопку Создать объект для завершения операции.

Результат операции — новая поверхность — появляется в графической области. В Дереве модели появляется пиктограмма операции.

Если требуется прервать операцию до ее завершения, нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Требования к эскизу поверхности выдавливания

Другие команды создания поверхностей

Особенности задания числовых параметров операции в полях Панели свойств


Команда Быстрое отображение линий

Управляет режимом быстрого отображения линий модели.

Команда находится в меню Вид.

При включенном режиме ускоряется отрисовка линий, изображающих модель без невидимых линий, с тонкими невидимыми линиями или в каркасном отображении.

Ускорение прорисовки модели достигается благодаря применению так называемого графического способа расчета линий модели. При отключенном режиме быстрого отображения этот расчет ведется математически. Математический расчет дает несколько более точный результат, но требует гораздо больше времени.

Ускорение отрисовки особенно заметно во время сдвига или поворота модели: он становится быстрее и выглядит более «плавным», т.е. приближается к перемещению в реальном времени. Благодаря этому становится удобнее контролировать перемещения, например, при создании сопряжений между компонентами модели.


Обработка углов контура

Переключатель, позволяющий указать, требуется построение фаски/скругления только на выбранном угле контура или сразу на всех углах.


Команда Вставить ссылку (меню Окна переменных)

Команда Вставить ссылку
(меню Окна переменных)

Позволяет создать в документе ссылку на переменную.

Для вызова команды нажмите кнопку Вставить ссылку на Инструментальной панели Окна переменных или вызовите команду Ссылка контекстного меню.

В диалогах, появляющихся после вызова команды, необходимо выбрать файл-источник и переменную-источник ссылки.

Переменная текущего документа, строка которой была выделена перед вызовом команды, получит значение переменной-источника — оно отобразится в колонке Значение.

В колонке Выражение появится текст ссылки.

Смотрите также

Обновление ссылок на переменную


Команда Вывести на печать

Позволяет вывести на печать все имеющиеся в предварительном просмотре документы с их текущими настройками.

Для вызова команды выберите ее название из меню Файл или нажмите кнопку Печать на инструментальной панели. После этого будут напечатаны все страницы, печать которых включена. Порядок вывода на печать можно задать в диалоге настройки параметров вывода.


Команда Специальная печать

Позволяет настроить параметры специальной печати и вывести на печать текущий документ.

Для вызова команды выберите ее название из меню Файл или нажмите кнопку Специальная печать на Стандартной панели. На экране появится диалог Специальная печать документа, позволяющий настроить параметры специальной печати. Для ускорения настройки удобно использовать конфигурации устройств печати.

После установки всех необходимых параметров нажмите кнопку ОК для начала печати. Чтобы выйти из диалога без вывода документа на печать, нажмите кнопку Отмена.

Подробнее о специальной печати...


Команда Открыть с проверкой...

Позволяет в отдельных случаях исправить в файлах ошибки, приводящие к невозможности их открытия (с сообщением «Неверная структура файла...» или без какого-либо сообщения) или к аварийному завершению работы КОМПАС-3D при попытке открытия файла.

Команда Открыть с проверкой... доступна в меню Файл. После ее вызова на экране появляется стандартный диалог открытия файлов. Укажите в нем файл (файлы) для открытия с проверкой и нажмите кнопку Открыть.

В случае успешной обработки файл открывается.

Прежде, чем выполнять открытие файлов с проверкой, рекомендуется:

– создать копии файлов,

– с файлов, защищенных с помощью приложения КОМПАС-Защита, снять защиту.


Команда Скругление

Позволяет построить скругление дугой окружности между двумя пересекающимися объектами.

Для вызова команды нажмите кнопку Скругление на инструментальной панели Геометрия.

В поле Радиус на Панели свойств введите или выберите из списка значение радиуса скругления.

Укажите два объекта, между которыми нужно построить скругление.

Исходное изображение и изображение

после построения скруглений

Управление усечением объектов

Создание условного пересечения

Для выхода из команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие геометрические объекты


Команда Скругление на углах объекта

Позволяет построить скругления дугами окружности на углах объектов следующих типов: контур, ломаная или многоугольник.

Для вызова команды нажмите кнопку Скругление на углах объекта на инструментальной панели Геометрия.

В поле Радиус на Панели свойств введите или выберите из списка значение радиуса скругления.

Укажите курсором угол контура, многоугольника или ломаной, на котором необходимо построить фаску.

Группа переключателей Режим позволяет указать, требуется ли скругление только указанного угла или сразу всех углов объекта.

Построение скруглений на всех вершинах многоугольника

Управление усечением объектов

Для выхода из команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие геометрические объекты


Создание условного пересечения

Переключатель, позволяющий указать, требуется ли создавать условное пересечение объектов, выбранных для построения фаски/скругления.


Усечение первого объекта

Переключатель, позволяющий указать, требуется ли усекать первый объект, выбранный для построения фаски/скругления.


Усечение второго объекта

Переключатель, позволяющий указать, требуется ли усекать второй объект, выбранный для построения фаски/скругления.


Список Фильтр

Раскрывающийся список позволяет управлять отображением компонентов в таблице диалога Параметры зеркального отражения компонентов.

Доступны следующие варианты отображения:

– Все компоненты (активен по умолчанию),

– Все компоненты, кроме библиотечных,

– Все библиотечные компоненты.

В диалоге показываются только те объекты, которые указаны в выбранном варианте.


Команда Фильтровать все объекты

Вызывается кнопкой на инструментальной панели Фильтры. Служит для включения режима, в котором возможен динамический поиск и указание курсором любых объектов модели — осей, плоскостей, граней, ребер, вершин, элементов оформления и т.п.

Если нажата кнопка Фильтровать все, то остальные кнопки панели Фильтры отжаты. После нажатия любой кнопки, разрешающей поиск и указание объектов определенного типа, кнопка Фильтровать все отключается.

Если выключаются все кнопки, соответствующие типам объектов, то кнопка Фильтровать все автоматически включается (то есть отключить указание всех типов объектов невозможно).

Подробнее о фильтрах объектов...


Команда Фильтровать элементы оформления

Вызывается кнопкой на инструментальной панели Фильтры. Служит для включения режима, в котором возможен динамический поиск и указание курсором ребер элементов оформления.

Виды курсора при фильтрации элементов оформления:

— линейного размера,

— обозначения шероховатости,

— линии-выноски

и т.п.

Если кнопка Фильтровать элементы оформления нажата, то кнопка Фильтровать все отключается.

Чтобы запретить динамический поиск и указание курсором элементов оформления, отожмите (выключите) кнопку Фильтровать элементы оформления.

Вы можете выбрать несколько доступных для указания (выделения) объектов, нажав соответствующие объектам кнопки на панели Фильтры.

Подробнее о фильтрах объектов...


Команда Фильтровать тела

Вызывается кнопкой на инструментальной панели Фильтры. Служит для включения режима, в котором возможен динамический поиск и указание курсором тел или их граней, ребер, вершин.

– Чтобы выбирать тела целиком, нажмите кнопку Фильтровать тела.

— вид курсора при фильтрации тел

– Чтобы выбирать трехмерные примитивы тел, нажмите дополнительно кнопку Фильтровать грани, Фильтровать ребра или Фильтровать вершины, соответственно. При наведении на объект курсор примет вид, как при динамическом поиске граней, ребер или вершин.

Если кнопка Фильтровать тела или другие кнопки панели нажаты, то кнопка Фильтровать все отключается автоматически.

– Чтобы запретить динамический поиск и указание курсором тел, отожмите (выключите) кнопку Фильтровать тела.

Вы можете выбрать несколько доступных для указания (выделения) объектов, нажав соответствующие объектам кнопки на панели Фильтры.

Подробнее о фильтрах объектов...


Команда Фильтровать конструктивные оси

Вызывается кнопкой на инструментальной панели Фильтры. Служит для включения режима, в котором возможен динамический поиск и указание курсором осей, существующих в модели.

— вид курсора при фильтрации конструктивных осей

Если кнопка Фильтровать конструктивные оси нажата, то кнопка Фильтровать все отключается.

Чтобы запретить динамический поиск и указание курсором осей, отожмите (выключите) кнопку Фильтровать конструктивные оси.

Вы можете выбрать несколько доступных для указания (выделения) объектов, нажав соответствующие объектам кнопки на панели Фильтры.

Подробнее о фильтрах объектов...


Команда Фильтровать компоненты

Вызывается кнопкой на инструментальной панели Фильтры. Служит для включения режима, в котором возможен динамический поиск и указание курсором компонентов или их граней, ребер, вершин.

– Чтобы выбирать компоненты целиком, нажмите кнопку Фильтровать компоненты.

— вид курсора при фильтрации компонентов

– Чтобы выбирать трехмерные примитивы компонентов, нажмите дополнительно кнопку Фильтровать грани, Фильтровать ребра или Фильтровать вершины, соответственно. При наведении на объект курсор примет вид, как при динамическом поиске граней, ребер или вершин.

Если кнопка Фильтровать компоненты или другие кнопки панели нажаты, то кнопка Фильтровать все отключается автоматически.

– Чтобы запретить динамический поиск и указание курсором компонентов, отожмите (выключите) кнопку Фильтровать компоненты.

Вы можете выбрать несколько доступных для указания (выделения) объектов, нажав соответствующие объектам кнопки на панели Фильтры.

Подробнее о фильтрах объектов...


Команда Фильтровать контрольные и присоединительные точки

Вызывается кнопкой на инструментальной панели Фильтры. Служит для включения режима, в котором возможен динамический поиск и указание курсором контрольных и присоединительных точек.

— вид курсора при фильтрации контрольных и присоединительных точек

Если кнопка Фильтровать контрольные и присоединительные точки нажата, то кнопка Фильтровать все отключается.

Чтобы запретить динамический поиск и указание курсором контрольных и присоединительных точек, отожмите (выключите) кнопку Фильтровать контрольные и присоединительные точки.

Вы можете выбрать несколько доступных для указания (выделения) объектов, нажав соответствующие объектам кнопки на панели Фильтры.

Подробнее о фильтрах объектов...


Команда Фильтровать системы координат

Вызывается кнопкой на инструментальной панели Фильтры. Служит для включения режима, в котором возможен динамический поиск и указание курсором систем координат.

— вид курсора при фильтрации систем координат

Если кнопка Фильтровать системы координат нажата, то кнопка Фильтровать все отключается автоматически.

Чтобы запретить динамический поиск и указание курсором систем координат, отожмите (выключите) кнопку Фильтровать системы координат.

Вы можете выбрать несколько доступных для указания (выделения) объектов, нажав соответствующие объектам кнопки на панели Фильтры.

Чтобы выбирать только оси систем координат, воспользуйтесь командой Фильтровать конструктивные оси.

Подробнее о фильтрах объектов...


Команда Фильтровать конструктивные плоскости

Вызывается кнопкой на инструментальной панели Фильтры. Служит для включения режима, в котором возможен динамический поиск и указание курсором плоскостей, существующих в модели.

— вид курсора при фильтрации конструктивных плоскостей

Если кнопка Фильтровать конструктивные плоскости нажата, то кнопка Фильтровать все отключается.

Чтобы запретить динамический поиск и указание курсором плоскостей, отожмите (выключите) кнопку Фильтровать конструктивные плоскости.

Вы можете выбрать несколько доступных для указания (выделения) объектов, нажав соответствующие объектам кнопки на панели Фильтры.

Подробнее о фильтрах объектов...


Команда Фильтровать кривые

Вызывается кнопкой на инструментальной панели Фильтры. Служит для включения режима, в котором возможен динамический поиск и указание курсором кривых или их ребер, вершин.

– Чтобы выбирать кривые целиком, нажмите кнопку Фильтровать кривые.

— вид курсора при фильтрации кривых

– Чтобы выбирать только вершины кривых, нажмите дополнительно кнопку Фильтровать вершины. При наведении на объект курсор примет вид, как при динамическом поиске ребер или вершин.

Если кнопка Фильтровать кривые нажата, то кнопка Фильтровать все отключается автоматически.

– Чтобы запретить динамический поиск и указание курсором кривых, отожмите (выключите) кнопку Фильтровать кривые.

Вы можете выбрать несколько доступных для указания (выделения) объектов, нажав соответствующие объектам кнопки на панели Фильтры.

Подробнее о фильтрах объектов...


Команда Фильтровать ребра

Вызывается кнопкой на инструментальной панели Фильтры. Служит для включения режима, в котором возможен динамический поиск и указание курсором ребер модели.

— вид курсора при фильтрации ребер

Если кнопка Фильтровать ребра нажата, то кнопка Фильтровать все отключается.

Чтобы запретить динамический поиск и указание курсором ребер, отожмите (выключите) кнопку Фильтровать ребра.

Вы можете выбрать несколько доступных для указания (выделения) объектов, нажав соответствующие объектам кнопки на панели Фильтры.

Подробнее о фильтрах объектов...


Команда Фильтровать грани

Вызывается кнопкой на инструментальной панели Фильтры. Служит для включения режима, в котором возможен динамический поиск и указание курсором граней модели.

— вид курсора при фильтрации граней

Если кнопка Фильтровать грани нажата, то кнопка Фильтровать все отключается.

Чтобы запретить динамический поиск и указание курсором граней, отожмите (выключите) кнопку Фильтровать грани.

Вы можете выбрать несколько доступных для указания (выделения) объектов, нажав соответствующие объектам кнопки на панели Фильтры.

Подробнее о фильтрах объектов...


Команда Фильтровать точки

Вызывается кнопкой на инструментальной панели Фильтры. Служит для включения режима, в котором возможен динамический поиск и указание курсором точек.

— вид курсора при фильтрации точек

Если кнопка Фильтровать точки нажата, то кнопка Фильтровать все отключается.

Чтобы запретить динамический поиск и указание курсором точек, отожмите (выключите) кнопку Фильтровать точки.

Вы можете выбрать несколько доступных для указания (выделения) объектов, нажав соответствующие объектам кнопки на панели Фильтры.

Подробнее о фильтрах объектов...


Команда Фильтровать эскизы

Вызывается кнопкой на инструментальной панели Фильтры или из контекстного меню команды Кривая по двум проекциям. Служит для включения режима, в котором возможен динамический поиск и указание курсором эскизов или их ребер, вершин.

– Чтобы выбирать эскизы целиком, нажмите кнопку Фильтровать эскизы.

— вид курсора при фильтрации эскизов

– Чтобы выбирать только ребра или вершины эскизов, нажмите дополнительно кнопку Фильтровать ребра или Фильтровать вершины, соответственно. При наведении на объект курсор примет вид, как при динамическом поиске ребер или вершин.

Если кнопка Фильтровать эскизы нажата, то кнопка Фильтровать все отключается автоматически.

– Чтобы запретить динамический поиск и указание курсором эскизов, отожмите (выключите) кнопку Фильтровать эскизы.

Вы можете выбрать несколько доступных для указания (выделения) объектов, нажав соответствующие объектам кнопки на панели Фильтры.

Подробнее о фильтрах объектов...


Команда Фильтровать поверхности

Вызывается кнопкой на инструментальной панели Фильтры. Служит для включения режима, в котором возможен динамический поиск и указание курсором поверхностей или их граней, ребер, вершин.

– Чтобы выбирать поверхности целиком, нажмите кнопку Фильтровать поверхности.

— вид курсора при фильтрации поверхностей

– Чтобы выбирать трехмерные примитивы поверхностей, нажмите дополнительно кнопку Фильтровать грани, Фильтровать ребра или Фильтровать вершины, соответственно. При наведении на объект курсор примет вид, как при динамическом поиске граней, ребер или вершин.

Если кнопка Фильтровать поверхности или другие кнопки панели нажаты, то кнопка Фильтровать все отключается автоматически.

– Чтобы запретить динамический поиск и указание курсором поверхностей, отожмите (выключите) кнопку Фильтровать поверхности.

Вы можете выбрать несколько доступных для указания (выделения) объектов, нажав соответствующие объектам кнопки на панели Фильтры.

Подробнее о фильтрах объектов...


Команда Фильтровать резьбы

Вызывается кнопкой на инструментальной панели Фильтры. Служит для включения режима, в котором возможен динамический поиск и указание курсором изображения резьб.

— вид курсора при фильтрации резьб

Если кнопка Фильтровать резьбы нажата, то кнопка Фильтровать все отключается.

Чтобы запретить динамический поиск и указание курсором изображения резьб, отожмите (выключите) кнопку Фильтровать резьбы.

Вы можете выбрать несколько доступных для указания (выделения) объектов, нажав соответствующие объектам кнопки на панели Фильтры.

Подробнее о фильтрах объектов...


Команда Фильтровать вершины

Вызывается кнопкой на инструментальной панели Фильтры. Служит для включения режима, в котором возможен динамический поиск и указание курсором вершин модели.

— вид курсора при фильтрации вершин

Если кнопка Фильтровать вершины нажата, то кнопка Фильтровать все отключается.

Чтобы запретить динамический поиск и указание курсором вершин, отожмите (выключите) кнопку Фильтровать вершины.

Вы можете выбрать несколько доступных для указания (выделения) объектов, нажав соответствующие объектам кнопки на панели Фильтры.

Подробнее о фильтрах объектов...


Команда Указать замкнутую кривую

Если требуется вычислить площадь фигуры, ограниченной замкнутой кривой, вызовите команду Указать замкнутую кривую, а затем укажите курсором нужную кривую.

Для вызова команды можно нажать кнопку Указать замкнутую кривую на Панели специального управления.


Команда Закрепить положение — Зафиксированных панелей

Позволяет закрепить положение зафиксированных панелей.

При вызове команды рядом с ее названием в меню появляется «галочка».

После вызова команды блокируется перемещение и изменение размеров зафиксированных панелей.

Подробнее...


Команда Закрепить положение — Зафиксированных окон

Позволяет закрепить положение зафиксированных окон.

При вызове команды рядом с ее названием в меню появляется «галочка».

После вызова команды блокируется перемещение и изменение размеров зафиксированных окон.

Подробнее...


Команда Закрепить положение — Плавающих панелей

Позволяет закрепить положение плавающих панелей.

При вызове команды рядом с ее названием в меню появляется «галочка».

После вызова команды блокируется перемещение и изменение размеров плавающих панелей.

Подробнее...


Команда Закрепить положение — Плавающих окон

Позволяет закрепить положение плавающих окон.

При вызове команды рядом с ее названием в меню появляется «галочка».

После вызова команды блокируется перемещение и изменение размеров плавающих окон.

Подробнее...


Опция Выбор полюсов

Включите опцию, чтобы зафиксировать полюсы сетки, выбранные произвольно. Полюсы (ряды полюсов) выбираются щелчком мыши после включения опции.

Подробнее о выборе полюсов...

Отмена фиксации отдельно взятого полюса (ряда полюсов) выполняется повторным щелчком мыши по этому полюсу (ряду полюсов). Чтобы отменить фиксацию всех полюсов, зафиксированных данным способом, отключите опцию Выбор полюсов.

Для фиксации произвольно выбранных полюсов можно использовать команду Фиксировать полюсы с Shift контекстного меню.


Команда Фиксировать полюсы с Shift

Команда позволяет зафиксировать произвольно выбранные полюсы сетки.

После вызова команды рядом с ее названием появляется «галочка». Это означает, что выбранные в дальнейшем полюсы будут зафиксированы. Полюсы выбираются при нажатой клавише <Shift>. Аналогичный выбор сегмента сетки добавляет в набор зафиксированных полюсов все полюсы ряда, содержащего этот сегмент.

Если требуется отменить фиксацию какого-либо полюса (ряда полюсов), повторно щелкните по нему мышью при нажатой клавише <Shift>.

Чтобы снять фиксацию всех произвольно выбранных полюсов, повторите вызов команды Фиксировать полюсы с Shift.

Фиксация и отмена фиксации произвольно выбранных полюсов может выполняться с помощью опции Выбор полюсов команды Фиксировать полюсы.

Обратите внимание на то, что включение опции Выбор полюсов автоматически вызывает команду Фиксировать полюсы с Shift, а ее отключение отменяет работу команды. В свою очередь вызов команды влияет на состояние опции.

Смотрите также

Произвольное перемещение полюсов мышью


Команда Зафиксировать границы сетки/Расфиксировать границы сетки

Команда Зафиксировать границы сетки позволяет зафиксировать все полюсы, расположенные на границах сетки (в ее крайних рядах). Зафиксированные полюсы отображаются на экране кружками увеличенного диаметра. Положение зафиксированных полюсов нельзя изменить.

После фиксации границ данная команда заменяется командой Расфиксировать границы сетки. Эта команда позволяет снять фиксацию со всех зафиксированных границ.

Фиксация и отмена фиксации границ сетки может выполняться с помощью переключателей групп Границы вдоль U и Границы вдоль V команды Фиксировать полюсы.

Состояние переключателей этих групп и использование указанных команд контекстного меню взаимосвязано. При активизации в обеих группах переключателей Обе границы сетки автоматически вызывается команда Зафиксировать границы сетки, а переключателей Нет фиксации — команда Расфиксировать границы сетки. В свою очередь вызов команд активизирует соответствующие переключатели в группах.

Смотрите также

Произвольное перемещение полюсов мышью


Опция Выбор ребер грани

Включите опцию, чтобы сохранить форму и положение нужных ребер редактируемой грани в неизменном виде. Ребра выбираются щелчком мыши после включения опции.

Выбранные ребра подсвечиваются, все полюсы сетки, влияющие на форму и положение этих ребер, автоматически фиксируются.

Для отмены фиксации полюсов, обеспечивающих неизменность формы и положения одного из выбранных ребер, повторно щелкните мышью по этому ребру. Если требуется отменить фиксацию полюсов для всех выбранных ребер, отключите опцию Выбор ребер грани.


Группа переключателей Фиксация

Группа переключателей, управляющая фиксацией компонента.

Данная группа переключателей присутствует на Панели свойств при редактировании свойств компонента, который находится на первом уровне редактируемой модели (т.е. вставлен непосредственно в саму эту модель).


Команда Плоские корешки вкладок

Позволяет включить плоское отображение корешков вкладок. При вызове команды рядом с ее названием в меню появляется «галочка».


Шрифт

Список, из которого можно выбрать шрифт выделенного или набираемого текста.


Команда Шрифт...

Позволяет назначить или изменить параметры шрифта (высоту, сужение, начертание и т.д.) для выделенного или набираемого заново текста.

Для вызова команды нажмите кнопку Шрифт или выберите ее имя из меню Формат.

После этого на экране появится диалог установки параметров шрифта.

Для быстрого управления отдельными параметрами шрифта используйте элементы управления на Панели свойств или панели Форматирование.


Команда Скрыть

Позволяет отключить отображение в чертеже проекционного обозначения.

Команда доступна в контекстном меню выделенного проекционного обозначения (или обозначений).

После вызова команды выбранные обозначения перестают показываться на экране.

Для включения отображения скрытых проекционных обозначений служит команда Показать скрытые обозначения.

Смотрите также

Управление отображением проекционных обозначений


Команда Формат текста...

Позволяет задать габариты многострочного текста и методы его форматирования (правила размещения текста в габаритной рамке).

Для вызова команды нажмите кнопку Параметры форматирования или выберите ее название из меню Формат.

После вызова команды на экран выводится диалог настройки формата текста.


Команда Формат ячейки

Позволяет изменить габариты текущей ячейки и методы форматирования текста в ней.

Для вызова команды нажмите кнопку Формат ячейки или выберите ее название из меню Таблица.

После вызова команды на экране появляется диалог, в котором можно установить габариты ячейки и указать стиль текста в ячейке по умолчанию, запретить или разрешить изменение текста в ячейке, задать отступы текста от границ ячейки и правила отслеживания размеров ячейки (должен ли текст в ячейке подгоняться под заданные габариты или границы ячейки должны передвигаться при вводе не помещающегося в них текста).


Команда Расширенный формат ячейки

Позволяет установить дополнительные параметры для ячейки таблицы. Эти параметры нужны только при настройке таблицы основной надписи, поэтому команда доступна только в режиме создания или редактирования таблицы основной надписи.

Для вызова команды нажмите кнопку Расширенный формат ячейки или выберите ее название из меню Таблица.

После вызова команды на экране появляется диалог настройки расширенного формата ячейки таблицы. Другим способом вызова этого диалога является нажатие на кнопку Далее... диалога Формат ячейки.

Установите в диалоге нужный тип ячейки (графы основной надписи) и введите текст, который будет отображаться в Строке сообщений при вводе содержимого в данную ячейку основной надписи.

После установки параметров расширенного формата ячейки нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


Команда Допуск формы (графический документ)

Команда Допуск формы
 (графический документ)

Позволяет создать обозначение допуска формы и расположения поверхности.

Для вызова команды нажмите кнопку Допуск формы на инструментальной панели Обозначения.

Укажите точку вставки рамки допуска. По умолчанию в выбранную точку помещается левый нижний угол рамки. При этом в списке Базовая точка выбран вариант Слева внизу. Чтобы изменить положение рамки относительно точки вставки, разверните указанный список и выберите нужную строку.

Чтобы включить вертикальное расположение рамки, активизируйте опцию Вертикально.

Создание таблицы допуска

Создание ответвлений со стрелками или треугольниками

На экране отображается фантом создаваемого обозначения. Вы можете изменить его конфигурацию, не выходя из команды. Для этого нажмите кнопку Редактировать точки на Панели специального управления. Система перейдет в режим редактирования характерных точек объекта. Внесите необходимые изменения, после чего отожмите кнопку Редактировать точки.

Чтобы зафиксировать изображение, нажмите кнопку Создать объект на Панели специального управления.

Обозначение допуска формы и расположения поверхности

Смотрите также

Добавление ответвлений

Другие обозначения


Команда Шаг на сегмент вперед

Позволяет переместиться на один сегмент вперед при сборке контура или построении эквидистанты по стрелке.


Команда Менеджер вставок видов и фрагментов...

Позволяет выполнить различные действия над вставленными в документ видами и/или фрагментами (смена способа вставки, редактирование, удаление, переименование вставки, создание новых локальных фрагментов и т.д.).

Для вызова команды нажмите кнопку Менеджер вставок видов и фрагментов на инструментальной панели Вставки и макроэлементы либо выберите ее название из меню Редактор или контекстного меню на любом свободном месте документа.

После вызова команды на экране появляется Менеджер вставок видов и фрагментов.


Команда Масштаб по высоте листа

Позволяет изменить масштаб отображения текущего текстового документа, технических требований, таблицы основной надписи или спецификации таким образом, чтобы страница документа полностью помещалась в окне по высоте (вертикальный размер изображения становится равным высоте окна).

Для вызова команды нажмите кнопку Масштаб по высоте листа на панели Вид.


Команда Масштаб по ширине листа

Позволяет изменить масштаб отображения текущего текстового документа, технических требований, таблицы основной надписи или спецификации таким образом, чтобы страница документа полностью помещалась в окне по ширине (горизонтальный размер изображения становится равным ширине окна).

Для вызова нажмите кнопку Масштаб по ширине листа на панели Вид.


Команда Типы загрузки — Пустой

Позволяет применить к выбранному компоненту или компонентам тип загрузки — Пустой.

Команда может быть вызвана нажатием кнопки на инструментальной панели Редактирование сборки или из контекстного меню выбранных компонентов.

Доступна, если среди выбранных есть компоненты с непустой загрузкой — с типами загрузки Полный, Упрощенный, Габарит.

После вызова команды выбранные компоненты, которые имели непустую загрузку, выгружаются:

– они перестают отображаться в окне модели,

– на пиктограммы компонентов в Дереве построения накладываются полупрозрачные серые квадраты,

– становится недоступен просмотр состава компонентов в Дереве построения.

Особенности компонентов с неполной загрузкой

Подробнее о выборе типа загрузки компонента...

Смотрите также

Типы загрузки сборки


Команда Типы загрузки — Габарит

Позволяет применить к выбранному компоненту или компонентам, загруженным полностью или упрощенно, тип загрузки — Габарит.

Команда может быть вызвана нажатием кнопки на инструментальной панели Редактирование сборки или из контекстного меню выбранных компонентов.

Доступна, если среди выбранных есть компоненты с типом загрузки Полный или Упрощенный.

Чтобы тип загрузки Пустой сменить на Габарит, назначьте сначала этим компонентам тип загрузки Полный.

После вызова команды вид выбранных компонентов, которые имели полную или упрощенную загрузку, изменяется:

– в окне модели вместо компонента отображается его габаритный параллелепипед,

– пиктограммы компонентов в Дереве построения отмечаются значком «параллелепипед»,

– становится недоступен просмотр состава компонентов в Дереве построения.

Типы объектов модели, включаемых в габарит, указываются в диалоге настройки габарита.

Особенности компонентов с неполной загрузкой

Подробнее о выборе типа загрузки компонента...

Смотрите также

Типы загрузки сборки


Команда Добавить геометрию (в графический макроэлемент)

Команда Добавить геометрию
(в графический макроэлемент)

Позволяет добавлять существующие в активном документе объекты в макроэлемент.

Указание объектов для добавления в макроэлемент (в режиме его редактирования)

Чтобы добавить в макроэлемент объекты, выполните следующие действия.

1. Выделите один макроэлемент, которому необходимо добавить геометрию, или войдите в режим его редактирования.

2. Вызовите команду Добавить геометрию. Для вызова команды нажмите кнопку Добавить геометрию на панели Вставки и макроэлементы или выберите ее название из меню Инструменты — Макроэлементы.

3. Укажите объекты для добавления, щелкая на них мышью.

При попадании объекта в «ловушку» курсора объект подсвечивается.

Объекты, находящиеся в другом виде, недоступны для указания.

Чтобы исходные объекты автоматически удалялись, активизируйте переключатель Удалять исходные объекты. Активизация переключателя Оставлять исходные объекты означает, что исходные объекты будут сохранены.

Чтобы завершить выполнение команды, нажмите кнопку Прервать команду.

Смотрите также

Создание макроэлемента


Режим ожидания указания области

Система ожидает указания области, необходимой для выполнения текущей команды (например, расчета геометрических характеристик профиля).

Вы можете указать замкнутую область, ограниченную графическими объектами, щелкнув внутри нее мышью.


Режим ожидания задания точки и угла

Система ожидает задания положения точки и значения угла, необходимых для выполнения текущей команды (например, точки и угла для вставки в документ библиотечного объекта и т.п.).

Вы можете указать положение точки и угол курсором или ввести координаты точки и угол в соответствующие поля Панели свойств.


Режим ожидания задания точки

Система ожидает указания положения точки, необходимой для выполнения текущей команды (например, базовой точки для выравнивания линий-выносок и т.п.).

Вы можете указать положение точки курсором или ввести ее координаты в соответствующем поле Панели свойств.


Команда Показать в Дереве

При построении модели каждый ее объект отображается в Дереве построения в виде пиктограммы. Слева от нее может находиться знак «+», означающий, что объект включает в себя другие объекты, но их список свернут. Кроме того, если в Дереве включено отображение структуры модели, то объекты группируются в разделы, которые обычно находятся в свернутом состоянии.

Команда Показать в дереве позволяет выделить в Дереве построения:

– объект, выделенный в окне модели (ось, кривая, точка, плоскость и т.п.)

– объект, которому принадлежит выделенный в окне модели примитив (вершина, ребро или грань).

Для вызова команды выберите ее название из контекстного меню на выделенном объекте или из меню Сервис.

После вызова команды пиктограмма соответствующего объекта выделяется цветом, а Дерево построения разворачивается так, чтобы она была видна.

Смотрите также

Выбор объектов в Дереве построения


Команда Сетка

Позволяет включить или отключить отображение вспомогательной сетки в активном окне.

При работе в эскизе сетка показывается на экране в случае, если угол между плоскостью эскиза и плоскостью экрана меньше 45 градусов. Если модель отображается в перспективной проекции, то сетка показывается только при условии параллельности плоскостей эскиза и экрана. Для установки такой ориентации плоскости эскиза служит команда Нормально к....

Чтобы изменить параметры отрисовки сетки (шаг, внешний вид, цвет и т.д.) в активном окне, щелкните мышью по треугольнику, расположенном рядом с кнопкой Сетка и вызовите команду Настроить параметры из раскрывшегося меню. На экране появится диалог, в котором можно установить нужные параметры отображения сетки.

Смотрите также

Использование сетки


Команда Отображать параметры, если сетка активна

Включает отображение параметров сетки на панели Текущее состояние в случае, если в активном окне присутствует вспомогательная сетка.

Если слева от этой команды в меню стоит метка, параметры сетки появляются на экране при включении отображения сетки.

Смотрите также

Команда Отображать параметры


Команда Отображать параметры

Включает отображение параметров сетки на панели Текущее состояние.

Если слева от этой команды в меню стоит метка, параметры сетки показываются на экране.

Смотрите также

Команда Отображать параметры, если сетка активна


Команда Настроить параметры

Позволяет настроить параметры сетки (шаг, угол наклона осей и т.д.) в текущем окне.

После вызова команды на экране появляется диалог настройки параметров сетки.

Установите нужные параметры сетки и нажмите кнопку ОК для подтверждения настроек.

Изображение сетки в активном окне будет немедленно перерисовано в соответствии с заданными параметрами.

Другим способом изменения параметров сетки в активном окне является выбор раздела Сетка в диалоге настройки параметров текущего окна. Этот диалог вызывается командой Сервис — Параметры.


Режим ручного рисования границ

Ручное рисование границ — задание вручную границы области для выполнения какой-либо операции (например, для штрихования этой области или удаления объектов, лежащих внутри нее). Нарисованная таким образом граница (временная ломаная линия) отображаются на экране только до завершения команды.

Для перехода в Режим ручного рисования границ нажмите кнопку Ручное рисование границ на Панели специального управления.

Последовательно указывайте вершины ломаной, которая ограничивает область. При этом замыкание ломаной выполняется системой автоматически.

В некоторых случаях, например, при создании границы для штриховки, на Панели свойств присутствует группа переключателей Режим для управления замыканием ломаной.

Вы можете изменять положение характерных точек границы непосредственно в процессе рисования. Для этого нажмите кнопку Редактировать точки на Панели специального управления, а затем «перетаскивайте» вершины ломаной мышью.

В процессе редактирования характерных точек вы можете добавлять и удалять вершины.

Для удаления вершины выделите ее одинарным щелчком мыши и нажмите клавишу <Delete>. Ломаная будет построена заново через оставшиеся вершины.

Для добавления вершины щелкните мышью на звене ломаной. Выбранное звено будет разбито на две части новой вершиной, расположенной в указанной точке. Вы можете «перетащить» ее в любое место.

Для выхода из режима редактирования положения характерных точек отожмите кнопку Редактировать точки.

После того как граница нарисована, нажмите кнопку Создать объект на Панели специального управления.

Для отказа от формирования границы нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.


Команда Штриховка

Позволяет заштриховать одну или несколько областей в текущем виде чертежа или во фрагменте.

Для вызова команды нажмите кнопку Штриховка на инструментальной панели Геометрия.

Если до вызова команды в документе были выделены объекты, то на экране появляется диалог, содержащий сообщения системы. Содержание сообщений зависит от того, могут ли выделенные объекты быть использованы в качестве границы штриховки.

Если они могут быть использованы в качестве границы штриховки, то нажатие кнопки Да в диалоге приведет к автоматическому построению штриховки с умолчательными значениями параметров. Выделение объектов будет снято. Команда построения штриховки останется активной.

Если выделенные объекты не могут быть использованы в качестве границы штриховки, то нажатие кнопки Да приведет к снятию выделения с объектов. Команда построения штриховки также останется активной.

Если перед вызовом команды объекты не были выделены или необходимо продолжить построение штриховки, следует указать точку внутри области, которую нужно заштриховать. Система автоматически определит ближайшие возможные границы, внутри которых указана точка.

Границами штриховки могут служить системные линии стилей Основная и Для линии обрыва или линии пользовательских стилей, при настройке которых указано, что они могут использоваться в качестве границы штриховки.

Построение штриховки: а) точки внутри областей, указанные для построения, б) полученная штриховка
а) | б)

Команды контекстного меню, входящие в группы Добавить границу и Удалить границу, позволяют изменить конфигурацию заштрихованной области.

Кнопки Панели специального управления предоставляют дополнительные возможности создания границ штриховки.

Кнопка Ручное формирование границ позволяет создать временную ломаную линию, которая будет служить границей штриховки.

Кнопка Обход границы по стрелке позволяет сформировать контур, образованный пересекающимися объектами.

При вводе ассоциативной штриховки режимы ручного рисования границ и обхода границ по стрелке недоступны.

Если граница штриховки является незамкнутым контуром (обычно в случае штриховки полосой), выбрать его можно только в режиме обхода границы по стрелке.

После задания очередной границы фантом создаваемой штриховки перестраивается. До фиксации штриховки вы можете настроить ее параметры.

Чтобы зафиксировать полученную штриховку и перейти к построению следующей, нажмите кнопку Создать объект на Панели специального управления.

Для выхода из команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Все области штриховки, созданные в сеансе построения, являются единым объектом, даже если они несмежные. Команды редактирования параметров, удаления и т. п. применяются ко всему объекту.

Смотрите также

Команда Заливка

Другие геометрические объекты


Команда Исключить — Указанием (меню задания границ штриховки)

Команда Исключить — Указанием
(меню задания границ штриховки)

Позволяет исключить из границ штриховки произвольные объекты графического документа.

После вызова команды указывайте курсором те объекты, которые должны быть исключены из границ.

После исключения каждого нового объекта штриховка будет автоматически перестраиваться.

Для выхода из режима исключения объектов нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.


Команда Исключить — Вне рамки (меню задания границ штриховки)

Команда Исключить — Вне рамки
(меню задания границ штриховки)

Позволяет исключить из границ штриховки объекты графического документа, не попавшие в заданную прямоугольную рамку.

После вызова команды укажите первую вершину рамки, нажмите левую кнопку мыши и перемещайте мышь, пока рамка не достигнет нужного размера. Затем отпустите кнопку.

Объекты, целиком оставшиеся снаружи заданной рамки, будут исключены из границ штриховки.

После исключения каждого нового набора объектов штриховка будет автоматически перестраиваться.

За один вызов команды можно задать произвольное количество рамок.

Для выхода из режима исключения рамкой нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.


Команда Исключить — Секущей ломаной (меню задания границ штриховки)

Команда Исключить — Секущей ломаной
(меню задания границ штриховки)

Позволяет исключить из границ штриховки, пересекая их ломаной линией.

После вызова команды указывайте вершины ломаной так, чтобы ее сегменты пересекали нужные объекты.

После исключения каждого нового объектов штриховка будет автоматически перестраиваться.

За один вызов команды можно задать произвольное количество секущих ломаных.

Для выхода из режима исключения секущей ломаной нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.


Команда Исключить — Секущей рамкой (меню задания границ штриховки)

Команда Исключить — Секущей рамкой
(меню задания границ штриховки)

Позволяет исключить из границ штриховки элементы объекты графического документа, полностью или частично попавшие в заданную прямоугольную рамку.

После вызова команды укажите первую вершину рамки, нажмите левую кнопку мыши и перемещайте мышь, пока рамка не достигнет нужного размера. Затем отпустите кнопку.

Объекты, которые целиком или частично попали внутрь заданной рамки, будут исключены из границ штриховки.

После исключения каждого нового набора объектов штриховка будет автоматически перестраиваться.

За один вызов команды можно задать произвольное количество секущих рамок.

Для выхода из режима исключения секущей рамкой нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.


Команда Исключить — Рамкой (меню задания границ штриховки)

Команда Исключить — Рамкой
(меню задания границ штриховки)

Позволяет исключить из границ штриховки объекты графического документа, указывая их прямоугольной рамкой.

После вызова команды укажите первую вершину рамки, нажмите левую кнопку мыши и перемещайте мышь, пока рамка не достигнет нужного размера. Затем отпустите кнопку.

Элементы, целиком попавшие в заданную рамку, будут исключены из границ штриховки.

После исключения каждого нового набора элементов штриховка будет автоматически перестраиваться.

За один вызов команды можно задать произвольное количество рамок.

Для выхода из режима выбора рамкой нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.


Опция Параметры из модели

Опция, управляющая способом задания параметров штриховки — из модели или вручную.

При включенной опции Параметры из модели (вариант по умолчанию) штриховка на разрезе/сечении получает параметры, заданные в модели телам и компонентам. Доступна группа переключателей Тип, позволяющая выбрать способ отображения штриховки внутри границ.

Особенности использования штриховки, параметры которой заданы в модели...

Если опция выключена, то параметры штриховки могут быть заданы вручную. Все элементы управления Панели свойств становятся доступны.

Настройка параметров штриховки производится так же, как при работе с командой Штриховка.


Цвет штриховки

Поле, в котором отображается текущий цвет штриховки.

Чтобы изменить цвет, щелкните в поле мышью и выберите из появившегося диалога нужный цвет.


Команда Цвет штриховки

Позволяет изменить цвет текущей штриховки. Команда доступна в контекстном меню при создании или редактировании штриховки.

После вызова команды Цвет штриховки на экране появляется диалог, в котором можно выбрать нужный цвет.


Команда Добавить — Указанием (меню задания границ штриховки)

Команда Добавить — Указанием
(меню задания границ штриховки)

Позволяет выбрать в качестве сегментов границ штриховки произвольные объекты графического документа.

После вызова команды последовательно указывайте курсором те объекты, которые должны войти в границу.

После указания каждого нового объекта штриховка будет автоматически перестраиваться.

Для выхода из режима выбора объектов нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.


Команда Добавить — Вне рамки (меню задания границ штриховки)

Команда Добавить — Вне рамки
(меню задания границ штриховки)

Позволяет выбрать в качестве границ штриховки объекты графического документа, не попавшие в заданную прямоугольную рамку.

После вызова команды укажите первую вершину рамки, нажмите левую кнопку мыши и перемещайте мышь, пока рамка не достигнет нужного размера. Затем отпустите кнопку.

Объекты, целиком оставшиеся снаружи заданной рамки, будут включены в границы штриховки.

После указания каждого нового набора объектов штриховка будет автоматически перестраиваться.

За один вызов команды можно задать произвольное количество рамок.

Для выхода из этого режима выбора нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.


Команда Добавить — Секущей ломаной (меню задания границ штриховки)

Команда Добавить — Секущей ломаной
(меню задания границ штриховки)

Позволяет выбрать в качестве границ штриховки объекты графического документа, пересекая их ломаной линией.

После вызова команды указывайте вершины ломаной так, чтобы ее сегменты пересекали нужные объекты.

После указания каждого нового набора объектов штриховка будет автоматически перестраиваться.

За один вызов команды можно задать произвольное количество секущих ломаных.

Для выхода из режима выбора секущей ломаной нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.


Команда Добавить — Секущей рамкой (меню задания границ штриховки)

Команда Добавить — Секущей рамкой
(меню задания границ штриховки)

Позволяет выбрать в качестве границ штриховки объекты графического документа, полностью или частично попавшие в заданную прямоугольную рамку.

После вызова команды укажите первую вершину рамки, нажмите левую кнопку мыши и перемещайте мышь, пока рамка не достигнет нужного размера. Затем отпустите кнопку.

Объекты, которые целиком или частично попали внутрь заданной рамки, будут включены в границы штриховки.

После указания каждого нового набора объектов штриховка будет автоматически перестраиваться.

За один вызов команды можно задать произвольное количество секущих рамок.

Для выхода из режима выбора секущей рамкой нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.


Команда Добавить — Рамкой (меню задания границ штриховки)

Команда Добавить — Рамкой
(меню задания границ штриховки)

Позволяет выбрать в качестве границ штриховки объекты графического документа, указывая их прямоугольной рамкой.

После вызова команды укажите первую вершину рамки, нажмите левую кнопку мыши и перемещайте мышь, пока рамка не достигнет нужного размера. Затем отпустите кнопку.

Объекты, целиком попавшие в заданную рамку, будут включены в границы штриховки.

После указания каждого нового набора объектов штриховка будет автоматически перестраиваться.

За один вызов команды можно задать произвольное количество рамок.

Для выхода из режима выбора рамкой нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.


Высота символов

Управление высотой символов выделенного или набираемого текста производится с помощью элементов инструментальной панели Форматирование.

Кнопка Высота символов выводит на экран диалог настройки параметров шрифта, в котором можно установить любые параметры шрифта.

В поле Высота символов отображается текущее значение высоты. Вы можете ввести нужное значение с клавиатуры или выбрать из списка.

Поле Высота символов присутствует на панели, если она расположена горизонтально.


Команда Команды клавиатуры

Позволяет просмотреть и распечатать перечень клавиатурных комбинаций, установленных пользователем в диалоге настройки интерфейса.


Команда Отображение — Без невидимых линий

Позволяет отобразить модель без линий невидимого контура.

Отображение модели без невидимых линий представляет собой совокупность видимых (в текущей ориентации модели) ребер, видимых частей ребер и видимых частей линии очерка модели.

Для вызова команды нажмите кнопку Без невидимых линий на панели Вид или выберите ее название из меню Вид.

Сразу после вызова команды модель в активном окне отобразится без невидимых линий.

Отображение модели без невидимых линий

Смотрите также

Команда Отображение — Каркас

Команда Отображение — Невидимые линии тонкие

Команда Отображение — Полутоновое

Команда Отображение — Полутоновое с каркасом


Команда Отображение — Невидимые линии тонкие

Позволяет отобразить линии невидимого контура (невидимые ребра, невидимые части ребер и невидимые части линии очерка) модели более светлыми, чем видимые линии.

Для вызова команды нажмите кнопку Невидимые линии тонкие на панели Вид или выберите ее название из меню Вид.

Сразу после вызова команды модель в активном окне отобразится с невидимыми линиями, отличающимися от видимых линий.

Отображение модели с тонкими невидимыми линиями

Смотрите также

Команда Отображение — Каркас

Команда Отображение — Без невидимых линий

Команда Отображение — Полутоновое

Команда Отображение — Полутоновое с каркасом


Команда Не показывать имена параметров

Позволяет отменить отображение названий элементов управления на Панели свойств. При вызове команды рядом с ее названием в меню появляется «галочка».


Команда Скрыть все вспомогательные объекты

Позволяет отменить или включить одновременный показ всех вспомогательных объектов в окне модели.

Команда может быть вызвана нажатием кнопки Скрыть все объекты на панели Вид или из меню Вид — Скрыть.

Вызов команды равносилен одновременному вызову следующих команд:

– Скрыть системы координат,

– Скрыть конструктивные плоскости,

– Скрыть конструктивные оси,

– Скрыть эскизы,

– Скрыть поверхности,

– Скрыть изображения резьбы,

– Скрыть пространственные кривые,

– Скрыть контрольные точки,

– Скрыть размеры,

– Скрыть условные обозначения,

– Скрыть компоновочную геометрию.

Если модель содержит компоненты, вы можете скрыть все вспомогательные объекты в компонентах. Для этого нажмите кнопку Скрыть все объекты в компонентах на панели Вид или вызовите команду Скрыть все вспомогательные объекты из меню Вид — Скрыть в компонентах.

Для удобства работы команды меню Скрыть и Скрыть в компонентах можно разместить на инструментальных панелях.

В момент вызова команды некоторые объекты могут находиться в скрытом состоянии, о чем свидетельствуют нажатые кнопки инструментальных панелей или меню.

После вызова команды Скрыть все вспомогательные объекты в окне модели перестают показываться все вспомогательные объекты — ранее существовавшие и вновь появляющиеся.

Признаком того, что все вспомогательные объекты скрыты, служит нажатая кнопка Скрыть все объекты и/или Скрыть все объекты в компонентах на панели Вид. Кроме того, в нажатом состоянии будут находиться кнопки всех команд скрытия вспомогательных объектов на соответствующих инструментальных панелях и в меню Вид — Скрыть и/или Вид — Скрыть в компонентах.

Скрываемые объекты по-прежнему показываются в Дереве построения. Их можно выбирать при выполнении команд.

Чтобы включить показ всех объектов, вызовите команду Скрыть все вспомогательные объекты повторно.


Команда Скрыть конструктивные оси

Позволяет отменить или включить показ всех вспомогательных и координатных осей в окне модели.

Команда может быть вызвана из меню кнопки Скрыть все объекты панели Вид или из меню Вид — Скрыть.

После вызова команды в окне модели не показываются не только ранее существовавшие, но и вновь появляющиеся оси.

Обычно вспомогательные оси скрывают, если они больше не потребуются при построении модели или если они мешают просмотру изображения модели.

Ось, которая не видна в окне модели, по-прежнему показывается в Дереве построения. Ее можно выбрать при выполнении какой-либо команды.

Если модель содержит компоненты, вы можете скрыть оси компонентов, оставив оси модели. Для этого вызовите команду Скрыть конструктивные оси из меню кнопки Скрыть все объекты в компонентах панели Вид или из меню Вид — Скрыть в компонентах.

Для удобства работы команды меню Скрыть и Скрыть в компонентах можно разместить на инструментальных панелях.

Признаком того, что конструктивные оси скрыты, служит нажатая кнопка на панели или в меню.

Смотрите также

Команда Скрыть системы координат

Команда Скрыть конструктивные плоскости

Команда Скрыть эскизы

Команда Скрыть поверхности

Команда Скрыть изображения резьбы

Команда Скрыть пространственные кривые

Команда Скрыть контрольные точки

Команда Скрыть размеры

Команда Скрыть условные обозначения

Команда Скрыть компоновочную геометрию

Команда Скрыть все вспомогательные объекты


Команда Скрыть системы координат

Позволяет отменить или включить показ всех обозначений систем координат в окне детали или сборки.

Команда может быть вызвана из меню кнопки Скрыть все объекты панели Вид или из меню Вид — Скрыть.

После вызова команды в окне модели не показываются не только ранее существовавшие, но и вновь появляющиеся (при вставке компонентов из файла) системы координат.

Обычно системы координат скрывают, если они больше не потребуются при построении модели или если они мешают просмотру изображения.

Система координат, которая не видна в окне модели, по-прежнему показывается в Дереве построения. Ее можно выбрать при выполнении какой-либо команды.

Если модель содержит компоненты, вы можете скрыть системы координат компонентов, оставив системы координат модели. Для этого вызовите команду Скрыть системы координат из меню кнопки Скрыть все объекты в компонентах панели Вид или из меню Вид — Скрыть в компонентах.

Для удобства работы команды меню Скрыть и Скрыть в компонентах можно разместить на инструментальных панелях.

Признаком того, что системы координат скрыты, служит нажатая кнопка на панели или в меню.

Смотрите также

Команда Скрыть конструктивные плоскости

Команда Скрыть конструктивные оси

Команда Скрыть эскизы

Команда Скрыть поверхности

Команда Скрыть изображения резьбы

Команда Скрыть пространственные кривые

Команда Скрыть размеры

Команда Скрыть условные обозначения

Команда Скрыть контрольные точки

Команда Скрыть компоновочную геометрию

Команда Скрыть все вспомогательные объекты


Команда Скрыть конструктивные плоскости

Позволяет отменить или включить показ всех вспомогательных и координатных плоскостей в окне модели.

Команда может быть вызвана из меню кнопки Скрыть все объекты панели Вид или из меню Вид — Скрыть.

После вызова команды в окне модели не показываются не только ранее существовавшие, но и вновь появляющиеся плоскости.

Обычно вспомогательные плоскости скрывают, если они больше не потребуются при построении модели или если они мешают просмотру изображения модели.

Плоскость, которая не видна в окне модели, по-прежнему показывается в Дереве построения. Ее можно выбрать при выполнении какой-либо команды.

Если модель содержит компоненты, вы можете скрыть плоскости компонентов, оставив плоскости модели. Для этого вызовите команду Скрыть конструктивные плоскости из меню кнопки Скрыть все объекты в компонентах панели Вид или из меню Вид — Скрыть в компонентах.

Для удобства работы команды меню Скрыть и Скрыть в компонентах можно разместить на инструментальных панелях.

Признаком того, что конструктивные плоскости скрыты, служит нажатая кнопка на панели или в меню.

Смотрите также

Команда Скрыть системы координат

Команда Скрыть конструктивные оси

Команда Скрыть эскизы

Команда Скрыть поверхности

Команда Скрыть изображения резьбы

Команда Скрыть пространственные кривые

Команда Скрыть контрольные точки

Команда Скрыть размеры

Команда Скрыть условные обозначения

Команда Скрыть компоновочную геометрию

Команда Скрыть все вспомогательные объекты


Команда Скрыть контрольные точки

Позволяет отменить или включить показ всех контрольных и присоединительных точек в окне модели.

Команда может быть вызвана из меню кнопки Скрыть все объекты панели Вид или из меню Вид — Скрыть.

После вызова команды в окне модели не показываются не только ранее существовавшие, но и вновь появляющиеся точки.

Контрольные и присоединительные точки, которые не видны в окне модели, по-прежнему показываются в Дереве построения. Их можно выбрать при выполнении какой-либо команды.

Если модель содержит компоненты, вы можете скрыть контрольные и присоединительные точки компонентов, оставив точки модели. Для этого вызовите команду Скрыть контрольные точки из меню кнопки Скрыть все объекты в компонентах панели Вид или из меню Вид — Скрыть в компонентах.

Для удобства работы команды меню Скрыть и Скрыть в компонентах можно разместить на инструментальных панелях.

Признаком того, что контрольные и присоединительные точки скрыты, служит нажатая кнопка на панели или в меню.

Смотрите также

Команда Скрыть системы координат

Команда Скрыть конструктивные плоскости

Команда Скрыть конструктивные оси

Команда Скрыть эскизы

Команда Скрыть поверхности

Команда Скрыть изображения резьбы

Команда Скрыть пространственные кривые

Команда Скрыть размеры

Команда Скрыть условные обозначения

Команда Скрыть компоновочную геометрию

Команда Скрыть все вспомогательные объекты


Команда Скрыть пространственные кривые

Позволяет отменить или включить показ всех пространственных кривых в окне детали или сборки.

Команда может быть вызвана из меню кнопки Скрыть все объекты панели Вид или из меню Вид — Скрыть.

После вызова команды в окне модели не показываются не только ранее существовавшие, но и вновь появляющиеся кривые.

Обычно кривые скрывают, если они мешают просмотру изображения.

Пространственная кривая, которая не видна в окне модели, по-прежнему показывается в Дереве построения. Ее можно выбрать при выполнении какой-либо команды.

Если модель содержит компоненты, вы можете скрыть кривые компонентов, оставив пространственные кривые модели. Для этого вызовите команду Скрыть пространственные кривые из меню кнопки Скрыть все объекты в компонентах панели Вид или из меню Вид — Скрыть в компонентах.

Для удобства работы команды меню Скрыть и Скрыть в компонентах можно разместить на инструментальных панелях.

Признаком того, что пространственные кривые скрыты, служит нажатая кнопка на панели или в меню.

Смотрите также

Команда Скрыть системы координат

Команда Скрыть конструктивные плоскости

Команда Скрыть конструктивные оси

Команда Скрыть эскизы

Команда Скрыть поверхности

Команда Скрыть изображения резьбы

Команда Скрыть контрольные точки

Команда Скрыть размеры

Команда Скрыть условные обозначения

Команда Скрыть компоновочную геометрию

Команда Скрыть все вспомогательные объекты


Команда Скрыть условные обозначения

Позволяет отменить или включить показ всех условных обозначений в окне модели.

Команда может быть вызвана из меню кнопки Скрыть все объекты панели Вид или из меню Вид — Скрыть.

После вызова команды в окне модели не показываются не только ранее существовавшие, но и вновь появляющиеся обозначения.

Обозначения, которые не видны в окне модели, по-прежнему показываются в Дереве построения. Их можно выбрать при выполнении какой-либо команды.

При создании в чертеже ассоциативного вида модели можно включить передачу в вид имеющихся в модели обозначений. Скрытые в модели обозначения передаются в вид, но не показываются в нем. Если необходимо, скрытые обозначения можно сделать видимыми.

Если модель содержит компоненты, вы можете скрыть условные обозначения компонентов, оставив условные обозначения модели. Для этого вызовите команду Скрыть условные обозначения из меню кнопки Скрыть все объекты в компонентах панели Вид или из меню Вид — Скрыть в компонентах.

Для удобства работы команды меню Скрыть и Скрыть в компонентах можно разместить на инструментальных панелях.

Признаком того, что условные обозначения скрыты, служит нажатая кнопка на панели или в меню.

Смотрите также

Команда Скрыть системы координат

Команда Скрыть конструктивные плоскости

Команда Скрыть конструктивные оси

Команда Скрыть эскизы

Команда Скрыть поверхности

Команда Скрыть изображения резьбы

Команда Скрыть пространственные кривые

Команда Скрыть контрольные точки

Команда Скрыть размеры

Команда Скрыть компоновочную геометрию

Команда Скрыть все вспомогательные объекты


Команда Скрыть размеры

Позволяет отменить или включить показ справочных размеров всех типов в окне модели.

Команда может быть вызвана из меню кнопки Скрыть все объекты панели Вид или из меню Вид — Скрыть.

После вызова команды в окне модели не показываются не только ранее существовавшие, но и вновь появляющиеся размеры.

Размеры, которые не видны в окне модели, по-прежнему показываются в Дереве построения. Их можно выбрать при выполнении какой-либо команды.

При создании в чертеже ассоциативного вида модели можно включить передачу в вид имеющихся в модели размеров. Скрытые в модели размеры передаются в вид, но не показываются в нем. Если необходимо, скрытые размеры можно сделать видимыми.

Если модель содержит компоненты, вы можете скрыть размеры компонентов, оставив размеры модели. Для этого вызовите команду Скрыть размеры из меню кнопки Скрыть все объекты в компонентах панели Вид или из меню Вид — Скрыть в компонентах.

Для удобства работы команды меню Скрыть и Скрыть в компонентах можно разместить на инструментальных панелях.

Признаком того, что обозначения размеров скрыты, служит нажатая кнопка на панели или в меню.

Смотрите также

Команда Скрыть системы координат

Команда Скрыть конструктивные плоскости

Команда Скрыть конструктивные оси

Команда Скрыть эскизы

Команда Скрыть поверхности

Команда Скрыть изображения резьбы

Команда Скрыть пространственные кривые

Команда Скрыть контрольные точки

Команда Скрыть условные обозначения

Команда Скрыть компоновочную геометрию

Команда Скрыть все вспомогательные объекты


Команда Закрыть

Позволяет закрыть окно Информации и Таблица изменяемых переменных.

Закрытие окна Информации завершает работу команды измерения.


Команда Отключить фиксацию

Позволяет выключить фиксацию выбранных компонентов модели, т.е. разрешить их перемещение в системе координат модели.

Для вызова команды выберите ее название из контекстного меню или нажмите кнопку Отключить фиксацию на панели Редактирование сборки.

Команда доступна:

– для одного или нескольких компонентов;

– для одной или нескольких групп компонентов.

Фиксацию можно отключить у компонентов, которые уже зафиксированы и находятся на первом уровне редактируемой модели (т.е. вставлены непосредственно в саму эту модель).

Подробнее о фиксации компонентов...


Команда Скрыть компоновочную геометрию

Позволяет отменить или включить показ компоновочной геометрии в окне модели.

Команда может быть вызвана из меню кнопки Скрыть все объекты панели Вид или из меню Вид — Скрыть.

После вызова команды в окне модели не показывается не только ранее существовавшая, но и вновь появляющаяся компоновочная геометрия.

Компоновочная геометрия, которая не видна в окне модели, по-прежнему показывается в Дереве построения. Ее можно выбрать при выполнении какой-либо команды.

Если модель содержит компоненты, вы можете скрыть компоновочную геометрию компонентов, оставив компоновочную геометрию модели. Для этого вызовите команду Скрыть компоновочную геометрию из меню кнопки Скрыть все объекты в компонентах панели Вид или из меню Вид — Скрыть в компонентах.

Для удобства работы команды меню Скрыть и Скрыть в компонентах можно разместить на инструментальных панелях.

Признаком того, что условные обозначения скрыты, служит нажатая кнопка на панели или в меню.

Смотрите также

Команда Скрыть системы координат

Команда Скрыть конструктивные плоскости

Команда Скрыть конструктивные оси

Команда Скрыть эскизы

Команда Скрыть поверхности

Команда Скрыть изображения резьбы

Команда Скрыть пространственные кривые

Команда Скрыть контрольные точки

Команда Скрыть размеры

Команда Скрыть условные обозначения

Команда Скрыть все вспомогательные объекты


Команда Скрыть

Позволяет отключить показ выделенных объектов модели.

Обратите внимание на то, что тело всегда скрывается целиком, даже если при вызове команды Скрыть был выделен отдельный формообразующий элемент. Например, в результате скрытия элемента выдавливания на экране перестанет отображаться все тело, в состав которого он входит.

Аналогично действие команды Скрыть на поверхности. Например, в результате скрытия поверхности, участвующей в операции Сшивка поверхностей, перестанут отображаться все остальные поверхности, участвующие в этой же операции.

После вызова команды Скрыть для остальных объектов (вспомогательной оси, спирали, ломаной и т.п.) на экране перестают отображаться только эти объекты.

Команда Скрыть недоступна, если все выделенные объекты уже скрыты.

Обычно объекты скрывают, если они больше не потребуются при построении модели или если они мешают просмотру изображения модели.

Объект, который не виден в окне модели, по-прежнему отображается в Дереве построения, но его пиктограмма имеет серый цвет. Скрытый объект — например, эскиз — можно указать при выполнении какой-либо команды.

Смотрите также

Управление видимостью объектов

Исключение объектов из расчетов


Команда Скрыть эскизы

Позволяет отменить или включить показ в окне модели всех эскизов, не задействованных в выполнении операций.

Команда может быть вызвана из меню кнопки Скрыть все объекты панели Вид или из меню Вид — Скрыть.

После вызова команды в окне модели не показываются не только ранее существовавшие, но и вновь появляющиеся эскизы.

Обычно «свободные» эскизы скрывают, если они больше не потребуются при построении модели или если они мешают просмотру изображения модели.

Эскиз, который не виден в окне модели, по-прежнему показывается в Дереве построения. Его можно выбрать при выполнении какой-либо команды.

Если модель содержит компоненты, вы можете скрыть эскизы компонентов, оставив эскизы модели. Для этого вызовите команду Скрыть эскизы из меню кнопки Скрыть все объекты в компонентах панели Вид или из меню Вид — Скрыть в компонентах.

Для удобства работы команды меню Скрыть и Скрыть в компонентах можно разместить на инструментальных панелях.

Признаком того, что эскизы скрыты, служит нажатая кнопка на панели или в меню.

Смотрите также

Команда Скрыть системы координат

Команда Скрыть конструктивные плоскости

Команда Скрыть конструктивные оси

Команда Скрыть поверхности

Команда Скрыть изображения резьбы

Команда Скрыть пространственные кривые

Команда Скрыть контрольные точки

Команда Скрыть размеры

Команда Скрыть условные обозначения

Команда Скрыть компоновочную геометрию

Команда Скрыть все вспомогательные объекты


Команда Скрыть поверхности

Позволяет отменить или включить показ всех поверхностей в окне детали или сборки.

Команда может быть вызвана из меню кнопки Скрыть все объекты панели Вид или из меню Вид — Скрыть.

После вызова команды в окне модели не показываются не только ранее существовавшие, но и вновь появляющиеся поверхности.

Обычно поверхности скрывают, если они больше не потребуются при построении модели или если они мешают просмотру изображения.

Поверхность, которая не видна в окне модели, по-прежнему показывается в Дереве построения. Ее можно выбрать при выполнении какой-либо команды.

Если модель содержит компоненты, вы можете скрыть поверхности компонентов, оставив поверхности модели. Для этого вызовите команду Скрыть поверхности из меню кнопки Скрыть все объекты в компонентах панели Вид или из меню Вид — Скрыть в компонентах.

Для удобства работы команды меню Скрыть и Скрыть в компонентах можно разместить на инструментальных панелях.

Признаком того, что поверхности скрыты, служит нажатая кнопка на панели или в меню.

Поверхности, использованные для создания тела с помощью операции Сшивка, становятся гранями этого тела. Поэтому такие поверхности не скрываются в результате вызова команды Скрыть поверхности.

Смотрите также

Команда Скрыть системы координат

Команда Скрыть конструктивные плоскости

Команда Скрыть конструктивные оси

Команда Скрыть эскизы

Команда Скрыть изображения резьбы

Команда Скрыть пространственные кривые

Команда Скрыть контрольные точки

Команда Скрыть размеры

Команда Скрыть условные обозначения

Команда Скрыть компоновочную геометрию

Команда Скрыть все вспомогательные объекты


Команда Скрыть изображения резьбы

Позволяет отменить или включить показ всех условных изображений резьбы в окне детали или сборки.

Команда может быть вызвана из меню кнопки Скрыть все объекты панели Вид или из меню Вид — Скрыть.

После вызова команды в окне модели не показываются не только ранее существовавшие, но и вновь появляющиеся резьбы.

Обычно изображения резьбы скрывают, если они мешают просмотру изображения.

Изображение резьбы, которое не видно в окне модели, по-прежнему показывается в Дереве построения. Его можно выбрать при выполнении какой-либо команды.

Если модель содержит компоненты, вы можете скрыть обозначения резьбы компонентов, оставив обозначения резьбы модели. Для этого вызовите команду Скрыть изображения резьбы из меню кнопки Скрыть все объекты в компонентах панели Вид или из меню Вид — Скрыть в компонентах.

Для удобства работы команды меню Скрыть и Скрыть в компонентах можно разместить на инструментальных панелях.

Признаком того, что обозначения резьбы скрыты, служит нажатая кнопка на панели или в меню.

Смотрите также

Команда Скрыть системы координат

Команда Скрыть конструктивные плоскости

Команда Скрыть конструктивные оси

Команда Скрыть эскизы

Команда Скрыть поверхности

Команда Скрыть пространственные кривые

Команда Скрыть контрольные точки

Команда Скрыть размеры

Команда Скрыть условные обозначения

Команда Скрыть компоновочную геометрию

Команда Скрыть все вспомогательные объекты


Команда Вырез в листовом теле

Позволяет построить отверстия произвольной формы на внешних или внутренних плоских гранях, принадлежащих листовому телу или листовым элементам.

Команда Вырез доступна, если выделен один эскиз — эскиз выреза.

Пример

Требования к эскизу выреза:

– объекты эскиза могут составлять один или несколько контуров,

– контуры в должны быть замкнуты.

Чтобы вызвать команду, нажмите кнопку Вырез в листовом теле на панели Элементы листового тела или выберите ее название из меню Операции — Элементы листового тела.

В окне модели появится фантом выреза и стрелка, показывающая направление вырезания материала. Изменить направление невозможно.

– Выберите тип построения выреза, активизировав один из переключателей в группе Тип.

Построение выреза способом По толщине возможно при выполнении следующих условий:

– эскиз должен быть построен на внешней или внутренней плоской грани листового тела или листового элемента,

– эскиз должен пересекаться с гранью, на которой он построен.

– Если вырез строится По толщине, то можно выбрать способ определения глубины выреза с помощью списка Объект толщины на Панели свойств.

– Если вырез строится На глубину, то введите ее значение в поле Глубина на вкладке Параметры.

– Если вырез строится До грани, то укажите объект, ограничивающий расстояние выдавливания, в окне модели. В качестве этого объекта может использоваться грань, поверхность, проекционная или вспомогательная плоскость.

Если в файле редактируемой детали присутствует несколько листовых тел, то при построении выреза На глубину и До грани необходимо указать листовое тело, в котором будет создан этот вырез. Чтобы указать тело, щелкните по нему мышью в окне модели.
Для смены листового тела используйте кнопку Указать заново на Панели специального управления

– На вкладе Вырезание выберите результат операции: вычитание или пересечение.

– При необходимости назначьте допуски на значения параметров операции, выраженных в линейных или угловых величинах. Для этого используйте кнопку Назначить допуск, расположенную на Панели свойств рядом с полем числового параметра операции.
Подробнее о допусках...
Подробнее о назначении допуска...

– Чтобы подтвердить формирование выреза, нажмите кнопку Создать объект на Панели специального управления.

В детали появится вырез, а в Дереве построения — его пиктограмма.

Если вырез захватывает сгиб, то при изменении состояния сгиба вырез перестраивается. Получившаяся в результате форма выреза зависит от типа его построения и от того, в каком состоянии находился сгиб во время создания выреза. Примеры...

Вырез, захватывающий сгиб, может быть построен таким образом, что изменение состояния сгиба станет невозможным.

Если в результате операции образуется тело из нескольких частей, то после выполнения операции запускается процесс изменения набора частей.

Смотрите также

Особенности задания числовых параметров операции в полях Панели свойств


Группа переключателей Направление построения

Группа переключателей Направление построения, управляющая направлением построения отверстия.

Активизируйте нужный переключатель: Прямое направление или Обратное направление.


Команда Отверстие в листовом теле

Позволяет построить круглые отверстия в листовом теле. Команда доступна, если в детали выделена плоская грань.

Пример

Чтобы вызвать команду, нажмите кнопку Отверстие в листовом теле на панели Элементы листового тела или выберите ее название из меню Операции — Элементы листового тела.

В окне модели появится фантом отверстия и стрелка, показывающая направление вырезания материала. Изменить направление невозможно.

По умолчанию центр отверстия размещается в начале локальной системы координат выбранной грани.

– Чтобы расположить отверстие в нужном месте грани, введите значения координат в поле точка привязки на вкладке Панели свойств Параметры. Вы можете также указать положение отверстия мышью. Для этого расфиксируйте поле т и укажите нужную точку в окне модели. Координаты выбранной точки будут определены автоматически.

– Выберите тип построения отверстия, активизировав один из переключателей в группе Тип.

Построение отверстия способом По толщине возможно при выполнении следующих условий:

– для построения должна быть указана внешняя или внутренняя плоская грань листового тела или листового элемента,

– параметры отверстия (расположение и диаметр) должны быть такими, чтобы оно пересекалось с указанной гранью.

– Если отверстие строится По толщине, то можно выбрать способ определения глубины отверстия с помощью списка Объект толщины на Панели свойств.

– Если отверстие строится На глубину, то введите ее значение в поле Глубина на вкладке Параметры Панели свойств.

– Если отверстие строится До грани, то укажите объект, ограничивающий расстояние выдавливания, в окне модели. В качестве этого объекта может использоваться грань, поверхность, проекционная или вспомогательная плоскость.

Если в файле редактируемой детали присутствует несколько листовых тел, то при построении отверстия На глубину и До грани необходимо указать в окне модели листовое тело, в котором будет создано это отверстие.
Для смены листового тела используйте кнопку Указать заново на Панели специального управления

– Введите значение диаметра отверстия в поле Диаметр.

Значение диаметра и положение центра отверстия можно задать с помощью характерных точек.

Для снятия значений параметров с других объектов воспользуйтесь меню геометрического калькулятора в поле Диаметр на Панели свойств.

При необходимости назначьте допуски на значения параметров операции, выраженных в линейных или угловых величинах. Для этого используйте кнопку Назначить допуск, расположенную на Панели свойств рядом с полем числового параметра операции.
Подробнее о допусках...
Подробнее о назначении допуска...

Все сделанные изменения немедленно отражаются на фантоме отверстия в окне модели.

– Чтобы подтвердить формирование отверстия, нажмите кнопку Создать объект на Панели специального управления.

В детали появится круглое отверстие, а в Дереве построения — его пиктограмма.

При создании отверстия в детали автоматически формируется эскиз. Он располагается на грани, указанной для построения отверстия, и содержит вспомогательную точку, находящуюся на оси отверстия.

Если отверстие захватывает сгиб, то при изменении состояния сгиба отверстие перестраивается. Получившаяся в результате форма отверстия зависит от типа его построения и от того, в каком состоянии находился сгиб во время создания отверстия. Примеры...

Отверстие, захватывающее сгиб, может быть построено таким образом, что изменение состояния сгиба станет невозможным.

Если в результате операции образуется тело из нескольких частей, то после выполнения операции запускается процесс изменения набора частей.

Смотрите также

Особенности задания числовых параметров операции в полях Панели свойств


Группа переключателей Длина резьбы

Группа переключателей, позволяющая задать длину резьбы.

При выборе способа На заданную глубину/На заданную длину введите длину резьбы в поле Длина резьбы.

При выборе способа На всю глубину /До конечной границы длина резьбы определяется автоматически. При необходимости можно изменить автоматически определенную конечную границу резьбы. Для этого активизируйте переключатель Конечная граница, а затем укажите в окне модели или в Дереве построения поверхность, грань или плоскость, до которой нужно построить резьбу.


Горизонтальное расположение фигурной скобки

Переключатель, позволяющий создать фигурную скобку, расположенную горизонтально.


Горизонтальный размер

Переключатель, позволяющий создать размер с горизонтально расположенной размерной линией.


Команда Горизонтальная прямая

Позволяет построить горизонтальную прямую.

Для вызова команды нажмите кнопку Горизонтальная прямая на инструментальной панели Геометрия.

Укажите положение точки, через которую должна пройти прямая.

Для точного позиционирования курсора воспользуйтесь привязками или меню геометрического калькулятора для поля т на Панели свойств.

Простановка точек пересечений

Горизонтальной считается прямая, параллельная оси абсцисс текущей системы координат. Поэтому если вы построите горизонтальную прямую в виде, система координат которого повернута относительно абсолютной системы координат, эта прямая не будет параллельна горизонтальным сторонам листа.

Для выхода из команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие геометрические объекты


Процесс сдвига характерной точки

Процесс сдвига характерной точки запускается автоматически после активизации характерной точки выделенного объекта. Для активизации характерной точки следует подвести к ней курсор и щелкнуть левой кнопкой мыши или нажать клавишу <Enter>.

Процесс позволяет задать новое положение точки путем ввода параметров сдвига относительно ее исходного положения.

На экране отображаются точка в исходном положении и фантом редактируемого объекта. При перемещении курсора объект перестраивается. Система ожидает указания нового положения точки.

На Панели свойств находятся поля сдвига по осям X и Y, расстояния и угла.

Сдвиг характерной точки: а) исходное изображение, б) отображение параметров
а) | б)

Укажите новое положение точки одним из способов:

• щелкните мышью в нужном месте документа,

• задайте значения любых двух параметров на Панели свойств,

• переместите точку при помощи клавиш со стрелками и зафиксируйте точку,

• введите координаты курсора на панели Текущее состояние и зафиксируйте точку.

Фиксация точки производится щелчком мыши или нажатием клавиши <Enter>.

После ввода первого параметра с Панели свойств он фиксируется на экране. Если введено значение сдвига по оси X или Y, то оно отображается в виде прямой, параллельной оси координат. Второй параметр может быть введен как с Панели свойств, так и указанием мыши.

Для указания положения точки удобно использовать привязки и геометрический калькулятор.

Вы можете быстро удлинить или укоротить отрезок без изменения его угла наклона. Для этого после активизации точки отрезка щелкните на ней правой кнопкой мыши. Затем в поле Угол на Панели свойств вызовите команду геометрического калькулятора Направление прямой/отрезка. Укажите в качестве измеряемого объекта данный отрезок, после чего задайте положение точки.

После фиксации точки процесс сдвига завершается автоматически.

Чтобы прекратить процесс без сдвига, нажмите кнопку Прервать команду на Панели специального управления или нажмите клавишу <Esc>.

Подробнее о редактировании характерных точек...


Команда Гиперссылка...

Позволяет создать или отредактировать гиперссылку в графическом документе или эскизе.

Объектами, в которые можно вставить гиперссылку, являются:

– геометрические объекты, размеры, обозначения;

– макроэлементы, в том числе библиотечные;

– вставки фрагментов и видов;

– таблицы и тексты.

Подробнее о гиперссылках...

Чтобы создать гиперссылку, выделите объект (или объекты), в который она должна быть вставлена, а чтобы отредактировать — выделите объект (или объекты), содержащий гиперссылку. Затем вызовите команду Гиперссылка... одним из следующих способов:

– из меню Вставка,

– из контекстного меню (при редактировании команда называется Редактировать гиперссылку),

– щелчком мыши по строке Гиперссылка в таблице свойств объекта.

После вызова команды на экране появляется диалог, в котором можно выбрать тип гиперссылки и настроить ее параметры.

Гиперссылка на файл, папку или веб-страницу...

Гиперссылка на место в документе...

Гиперссылка на окно электронной почты...

Если было выделено несколько объектов, то после создания гиперссылки ее будет содержать каждый из выделенных объектов.

Команда Гиперссылка... недоступна, если выделенных объектов нет. Команда также недоступна, если одновременно выделены объекты с гиперссылками и объекты без гиперссылок.

Смотрите также

Отображение и активизация гиперссылок

Редактирование гиперссылок

Удаление гиперссылок


Команда Вставить ссылку

Позволяет создать ссылку.

После вызова команды на экране появится диалог Ссылка. Настройте параметры ссылки, используя элементы управления этого диалога, и нажмите кнопку ОК для вставки ссылки в текст.


Команда Разрушить ссылку

Позволяет удалить связь между ссылкой и ее источником. В результате разрушения содержимое ссылки становится обычным текстом, который можно редактировать вручную. Обновление разрушенной ссылки становится невозможным.


Команда Редактировать ссылку

Позволяет изменить параметры ссылки.

После вызова команды на экране появится диалог Ссылка. Настройте параметры ссылки, используя элементы управления этого диалога, и нажмите кнопку ОК для вставки ссылки.


Команда Расстановка переносов

Позволяет расставить переносы во всем тексте или выделенном фрагменте.


Команда Импортированная кривая

Позволяет импортировать пространственные кривые в файл модели КОМПАС-3D.

Для вызова команды нажмите кнопку Импортированная кривая на инструментальной панели Пространственные кривые или выберите ее название из меню Операции — Пространственные кривые.

На экране появляется стандартный диалог Выберите файл для открытия. Выберите в диалоге нужный файл:

– файл с расширением igs, step или stp;

– файл данных с расширением txt, xls, ods или csv.

Для завершения процесса выбора файла нажмите кнопку Открыть.

Если выбран файл с расширением igs, step или stp, он проверяется на наличие в нем пространственных кривых. При наличии в файле пространственных кривых они будут вставлены в модель. Если пространственные кривые в файле отсутствуют, на экране появится всплывающее сообщение, при этом диалог выбора файла останется активным.

Особенности импорта кривых из файла с расширением igs, step или stp

Если выбран файл с координатами точек, в текущей модели по заданным координатам будет построена пространственная кривая.

Чтобы выйти из диалога и завершить команду без сохранения изменений, нажмите кнопку Отмена.

Если в исходном файле присутствуют кривые, состыкованные по цепочке, во время его чтения на экране появится запрос на объединение кривых. При положительном ответе те кривые, объединение которых возможно, будут объединены в одну кривую.

Системой координат импортированной кривой или кривых является текущая система координат — абсолютная или локальная.

Если системой координат импортированной кривой является не абсолютная, а локальная система координат, то, изменяя положение локальной системы координат относительно абсолютной, можно изменять положение импортированной кривой в модели.


Команда Импортированная поверхность

Позволяет импортировать поверхности в файл модели КОМПАС-3D.

Для вызова команды нажмите кнопку Импортированная поверхность на инструментальной панели Поверхности или выберите ее название из меню Операции — Поверхность.

На экране появится стандартный диалог открытия файла. Выберите в диалоге нужный файл:

– файл с расширением sat, igs, stp или step,

– файл данных с расширением txt, xls или ods.

Для завершения выбора файла нажмите кнопку Открыть.

Если выбран файл с расширением sat, igs, stp или step, имеющиеся в нем свободные поверхности и поверхности тел будут вставлены в текущую модель.

Если выбран файл данных, по заданным в нем координатам в текущей модели будет построена многогранная поверхность. Каждая грань поверхности имеет треугольную форму.

Системой координат импортированной поверхности или поверхностей является текущая система координат — абсолютная или локальная.

Если системой координат импортированной поверхности является не абсолютная, а локальная система координат, то, изменяя положение локальной системы координат относительно абсолютной, можно изменять положение импортированной поверхности в модели.

Импортированная поверхность может использоваться для отсечения части модели, в качестве объекта, до которого производится выдавливание (см. рисунок), сшиваться с другими поверхностями и т.п.

Пример использования импортированной поверхности:
а) импортированная поверхность и эскиз элемента выдавливания,
стрелкой показано направление выдавливания;
б) результат выдавливания до поверхности

Во время чтения файла *.igs, записанного без топологии, на экране появляется запрос на сшивку поверхностей. При положительном ответе те импортируемые поверхности, сшивка которых возможна, будут объединены.

Если в выбранном файле *.sat, *.igs, *.stp или *.step записана сборочная модель, то в результате чтения в текущей модели создаются детали, содержащие импортированные поверхности.

Сформированные детали записываются на диск только при сохранении файла модели. Они помещаются в ту же папку, что и сама модель.

Смотрите также

Другие команды создания поверхностей


Команда Включить в расчет последующие

Позволяет включить в расчет все объекты модели, находящиеся в Дереве построения ниже выделенного объекта (при отображении в Дереве последовательности построения модели).


Команда Разрыв раздела

Позволяет создать новый раздел в текстовом документе. Для вызова команды нажмите кнопку Вставить разрыв раздела на инструментальной панели Вставка в текст или выберите ее название из меню Вставка.


Кнопка Вставить функцию из коллекции

Находится на Панели специального управления при работе с командой Кривая по закону.

Позволяет вставить в редактируемое выражение функции для координаты точки кривой элементы выражения или целое выражение функции из коллекции.

Кнопка доступна, если курсор находится в поле Выражение функции по <имя координаты>.

После нажатия кнопки на экране появляется диалог вставки математического выражения. Выберите нужный элемент выражения или составьте выражение из нескольких элементов и нажмите кнопку ОК.

Подробнее о работе в диалоге...

Для вставки выражения функции или его элементов из коллекции можно также использовать команды контекстного меню:

– Выбрать из коллекции — Функцию по Х,

– Выбрать из коллекции — Функцию по Y,

– Выбрать из коллекции — Функцию по Z.

Команды доступны при работе с командой Кривая по закону. После вызова одной из этих команд на экране также появляется диалог вставки математического выражения. Выражение вставляется в поле той координаты, которая соответствует вызванной команде, и заменяет содержимое этого поля.

Вставленное выражение доступно для редактирования.

Смотрите также

Ввод выражения и задание параметра функции...


Кнопка Групповой закон

Находится на Панели специального управления при работе с командой Кривая по закону.

Позволяет задать для кривой групповой закон из коллекции, т.е. задать функции сразу для всех координат точки кривой. Каждая координата будет определена соответствующей ей функцией, содержащейся в выбранном групповом законе.

После нажатия кнопки на экране появляется диалог вставки математического выражения. Выберите нужный групповой закон из списка и нажмите кнопку ОК.

Подробнее о работе в диалоге...

После вставки группового закона в полях Выражение функции по <имя координаты> появляются функции для соответствующих координат.

Если групповой закон задает функции только для координат X и Y (например, для эвольвенты окружности), то выражение функции для координаты Z не изменяется — остается умолчательным.

Для задания группового закона из коллекции можно также использовать команду контекстного меню Выбрать из коллекции — Групповой закон.

Смотрите также

Ввод выражения и задание параметра функции...


Кнопка Вставить ссылку

Позволяет вставить ссылку в надпись знака клеймения или маркировки либо в надпись вида.

Для вызова команды нажмите кнопку Ссылка на Панели свойств. После этого на экране появится диалог создания ссылки. Для знака клеймения или маркировки в диалоге доступен только один источник ссылки — Технические требования, а для надписи вида — три: Стрелка взгляда, Линия разреза/сечения, Выносной элемент. Настройте в диалоге параметры ссылки и нажмите кнопку ОК.

Вы также можете вставить ссылку в знак маркировки или клеймения при работе с диалогом ввода надписи:

– нажав кнопку Ссылка справа от первого поля ввода,

– вызвав команду Вставка — Ссылка.


Команда Добавить индекс «с»

Команда служит для быстрого создания марки с индексом «с» при формировании обозначения координационной оси.

Чтобы добавить индекс в обозначение, вызовите команду Добавить индекс «с» из контекстного меню поля Текст на Панели свойств.

В поле Текст отобразится индекс.

Индекс сохраняется в обозначении при автопродолжении.

Чтобы удалить индекс, вызовите диалог ввода текста, щелкнув левой кнопкой мыши в поле Текст.


Кнопка Вставить имя переменной

Находится на Панели специального управления при работе с командой Кривая по закону.

Позволяет вставить в редактируемое выражение функции для координаты точки кривой имя существующей переменной модели.

После нажатия кнопки на экране появляется диалог Переменные, содержащий список всех переменных модели. Чтобы указать нужную переменную, выделите любую ячейку в строке этой переменной, а затем нажмите кнопку ОК диалога.

Имя переменной добавляется в выражение функции, ее данные передаются в таблицу Значение параметров.

Кнопка доступна, если курсор находится в поле Выражение функции по <имя координаты>.

Смотрите также

Ввод выражения и задание параметра функции...


Команда Вставить код и наименование

Позволяет вставить стандартные код и наименование документа в основную надпись документа или в текстовую часть объекта спецификации.

Команда доступна в меню Вставка и в контекстном меню в следующих режимах:

– заполнение основной надписи документа;

– ввод или редактирование текстовой части объекта спецификации

• в графическом документе;

• в документе-спецификации;

• в подчиненном режиме.

После вызова команды Код и наименование... на экране появляется диалог Коды и наименования.

Вставка кода и наименования с помощью данной команды превращает простое обозначение документа в составное. Подробнее...

Автоматическая вставка кода и наименования в основной надписи производится в ячейки типа Наименование изделия и Обозначение документа, а в объекте спецификации — в колонки с типом данных «строка», связанные с ячейкой штампа Наименование изделия или Обозначение документа.

При работе со спецификацией доступность команды Вставить код и наименование... зависит от настройки стиля и раздела спецификации. Подробнее...


Команда Вставить изображение из вида другого чертежа...

Позволяет вставить в чертеж содержимое вида другого чертежа, т.е. создать в текущем чертеже вставку вида.

Для вызова команды нажмите кнопку Вставить изображение из вида другого чертежа на инструментальной панели Вставки и макроэлементы выберите ее название из меню Вставка. Команда доступна только при работе с чертежами.

После вызова команды на экране появляется стандартный диалог открытия файлов, в котором следует выбрать нужный чертеж.

Выбрав нужный файл чертежа, нажмите кнопку ОК.

Полное имя выбранного чертежа отображается в поле Файл-источник на вкладке Параметры Панели свойств.

На экране отображается фантом изображения, содержащегося в текущем виде-источнике вставки. Чтобы указать другой вид-источник, выберите его в списке Вид. Фантом изменится. Обратите внимание на то, что в фантоме показываются все слои вида-источника, в том числе погашенные. После создания вставки погашенные слои не будут отображаться в документе.

Укажите Способ вставки: взятием в документ, внешней ссылкой или россыпью.

Введите имя вставки.

Переключатель Выносные линии позволяет указать, требуется ли масштабировать имеющиеся во вставке выносные линии и линии-выноски размеров.

– Если активен переключатель Не масштабировать, то длина выносных линий и линий-выносок остается такой же, как в файле-источнике.

– Если активен переключатель Масштабировать, то длина выносных линий и линий-выносок изменяется в соответствии с текущим масштабом вида-владельца.

Сделанная настройка сохраняется во вставке и в дальнейшем учитывается при изменении масштаба вида-владельца или масштаба вставки (включение/отключение масштабирования выносных линий при выполнении этих операций игнорируется).

Введите угол поворота вставки в соответствующее поле вкладки Параметры.

Опция В тонких линиях позволяет отобразить вместо основных и утолщенных линий вставки соответствующие тонкие линии (только для системных стилей линий).

Опция Как в документе позволяет привести параметры объектов вставки к параметрам, заданным при настройке текущего документа (для параметров, общих для документа, и параметров, не изменявшихся вручную).

Укажите положение базовой точки вставляемого вида.

Вы можете создать несколько вставок одного и того же или разных видов-источников.

Вставки вида размещаются в текущем виде чертежа. Этот вид становится видом-владельцем вставки.

Смотрите также

Свойства вставок видов

Вставки видов в Менеджере документа

Вставки видов и фрагментов в Дереве чертежа


Команда Вставить фрагмент... в графический документ

Команда Вставить фрагмент...
 в графический документ

Позволяет вставить в активный документ содержимое из внешнего файла фрагмента или библиотеки фрагментов.

Для вызова команды нажмите кнопку Вставить фрагмент на инструментальной панели Вставки и макроэлементы или выберите ее название из меню Вставка.

После вызова команды на экране появляется стандартный диалог открытия файлов. Выберите тип файла (*.frw или *.lfr), задайте путь и имя фрагмента или библиотеки фрагментов, нажмите кнопку Открыть.

– Если выбран фрагмент, то его полное имя отображается в поле Файл-источник на вкладке Параметры Панели свойств. На экране появляется фантом изображения, содержащегося в выбранном фрагменте.

– Если выбрана библиотека фрагментов, то на вкладке Параметры присутствует панель Библиотека. Выберите нужный раздел библиотеки и укажите фрагмент. Изображение, содержащееся в фрагменте, отображается в окне просмотра, а его фантом появляется на экране.

Укажите способ вставки фрагмента с помощью группы переключателей Способ вставки:

– взятием в документ,

– внешней ссылкой,

– россыпью.

При необходимости измените имя вставки.

Группа переключателей Режим 1 позволяет управлять размещением объектов на слоях (если фрагмент «многослойный»).

– Если активен переключатель На текущий слой, то все изображение будет расположено на одном (текущем) слое фрагмента или вида чертежа.

– Если активен переключатель На слои-источники, то объекты вставляемого фрагмента будут расположены во фрагменте или в виде на слоях с теми же номерами, как во вставляемом фрагменте.

Группа переключателей Выносные линии позволяет указать, требуется масштабировать имеющиеся во вставке выносные линии и линии-выноски размеров.

– Если активен переключатель Не масштабировать, то длина выносных линий и линий-выносок остается такой же, как в файле-источнике.

– Если активен переключатель Масштабировать, то длина выносных линий и линий-выносок изменяется в соответствии с текущим масштабом вида-владельца и/или с масштабом, заданным для вставки фрагмента.

Сделанная настройка сохраняется во вставке и в дальнейшем учитывается при изменении масштаба вида-владельца или масштаба вставки (включение/отключение масштабирования выносных линий при выполнении этих операций игнорируется).

При вставке параметрического фрагмента вы можете управлять значениями его внешних переменных. Подробнее о вставке параметрического фрагмента...

Введите угол поворота и масштаб вставки в соответствующие поля вкладки Параметры.

Укажите положение базовой точки фрагмента.

Вы можете создать несколько вставок фрагмента с различными масштабами и углами поворота.


Вставка россыпью

Способ вставки вида или фрагмента, при котором его объекты копируются в документ, а всякая связь между этими объектами и файлом-источником теряется.


Команда Выбрать другой источник вставки

Позволяет выбрать другой файл в качестве источника вставки.

После вызова команды на экране появляется диалог, в котором можно указать нужный файл.


Вставка внешней ссылкой

Способ вставки вида или фрагмента, при котором в документе формируется только ссылка на файл-источник без вставки содержащихся в нем объектов. Поэтому при редактировании файла-источника будут обновляться и все сделанные вставки этого источника. Этот способ вставки удобно использовать, когда хранящееся в файле-источнике изображение детали или узла используется сразу в нескольких различных документах, и модификация источника должна приводить к автоматическому изменению этих документов при их открытии. Таким образом, отпадает необходимость в редактировании каждого документа при изменении общей для них детали или узла.


Вставка взятием в документ

Способ вставки вида или фрагмента, при котором его содержимое копируется в документ и хранится там как единое целое.

При этом связь с файлом-источником не сохраняется, за исключением информации о его имени и полном пути к файлу. Такой способ вставки подходит для случаев, когда изменения в изображении детали, хранящемся во вставке, должны отражаться только в одном документе (хотя и в нескольких местах).


Команда Сведения об источнике...

Позволяет получить информацию о файле-источнике вставки вида или фрагмента.

Команда доступна в контекстном меню вставки, выделенной в окне документа или в Дереве чертежа.

После вызова команды на экране появляется диалог, в котором содержатся общие сведения о документе-источнике (автор, комментарий, дата создания и т.д.), перечислены внешние файлы, с которыми связан документ, и типы атрибутов, присвоенных документу в целом.


Показ погашенных слоев

Группа переключателей, позволяющая указать, требуется ли отображать в фантоме погашенные слои вставляемого фрагмента.

Переключатели недоступны, если происходит вставка однослойного фрагмента или многослойный фрагмент вставляется на один слой.

Обычно показ погашенных слоев отключают при вставке параметрического фрагмента, в котором скрыты управляющие изображением объекты (например, размеры).

Все слои фрагмента будут вставлены в текущий документ вне зависимости от того, показывались ли они в фантоме.


Команда Вставить рисунок в текст или таблицу

Команда Вставить рисунок
 в текст или таблицу

Позволяет вставить в текст или таблицу изображение, содержащееся в растровом файле формата BMP, GIF, JPEG, PNG, TIFF или TGA.

Для вызова команды нажмите кнопку Рисунок или выберите ее название из меню Вставка.

После вызова команды на экране отображается диалог, в котором нужно указать тип и имя файла.

После того как файл будет выбран, в диалоге станет доступна кнопка Параметры. После ее нажатия на экране появится диалог настройки параметров вставки рисунка в документ.

Если необходимо, настройте параметры вставки, а затем нажмите кнопку Открыть для выполнения вставки.

Рисунок вставляется в отдельный абзац.

В дальнейшем для перехода к редактированию параметров вставки рисунка дважды щелкните на нем левой кнопкой мыши.

Вы можете вставить растровое изображение через буфер обмена.

Вставка рисунков в надписи на чертеже, а также в технические требования и в основную надпись невозможна.


Команда Объект...

Позволяет вставить в активный графический КОМПАС-документ внешний файл с помощью технологии OLE (Object Linking and Embedding, связывание и встраивание объектов).

После вызова команды на экране появляется диалог, в котором можно настроить различные параметры вставки. Так, в этом диалоге можно указать, требуется ли создать и внедрить в текущий документ новый файл или нужно вставить уже существующий файл. В последнем случае возможна вставка со связью (т.е. изменения файла будут передаваться в КОМПАС-документ), а также в виде значка (т.е. в КОМПАС-документе будет отображаться не содержимое файла, а его пиктограмма).

Вставка существующего файла *.ods или *.odt (документы пакета Open Office) возможна только со связью.


Команда Вставить фрагмент в текст или таблицу

Команда Вставить фрагмент
 в текст или таблицу

Позволяет вставить в текст или таблицу КОМПАС-чертеж или КОМПАС-фрагмент.

Для вызова команды нажмите кнопку Фрагмент или выберите ее название из меню Вставка.

После вызова команды на экране отображается диалог, в котором нужно указать тип и имя файла.

После того как файл будет выбран, в диалоге станет доступна кнопка Параметры. После ее нажатия на экране появится диалог настройки параметров вставки чертежа или фрагмента в документ.

Если необходимо, настройте параметры вставки, а затем нажмите кнопку Открыть для выполнения вставки.

Чертеж или фрагмент вставляется в отдельный абзац.

В дальнейшем для перехода к редактированию параметров вставки чертежа или фрагмента дважды щелкните на нем левой кнопкой мыши.

Вы можете вставить графический объект из КОМПАС-документа через буфер обмена.

Вставка чертежей и фрагментов в надписи на чертеже, а также в технические требования и в основную надпись невозможна.

В таблицу на чертеже можно вставить только КОМПАС-фрагмент.


Команда Вставить рисунок в графический документ или эскиз

Команда Вставить рисунок
 в графический документ или эскиз

Позволяет вставить в чертеж, фрагмент или эскиз изображение, содержащееся в растровом файле формата BMP, GIF, JPEG, PNG, TIFF или TGA.

Для вызова команды выберите ее название из меню Вставка.

В появившемся на экране стандартном диалоге выбора файлов укажите нужный файл-источник вставки.

После этого в текущем документе появится габаритная рамка вставляемого изображения.

С помощью переключателя Способ вставки на Панели свойств укажите, требуется ли внедрить изображение в документ или создать внешнюю ссылку.

В поле Угол можно ввести или выбрать из списка угол поворота вставки, а в поле Масштаб — коэффициент ее масштабирования.

Если в файле-источнике нет информации о разрешении изображения, на Панели свойств присутствует поле Разрешение, в котором вы можете ввести или выбрать из списка нужное разрешение.

Укажите базовую точку растровой вставки.

За один вызов команды вы можете вставить выбранное изображение несколько раз, при необходимости изменяя его масштаб и угол поворота.

Чтобы перейти к вставке другого изображения, нажмите кнопку Сменить источник вставки, расположенную справа от поля Файл-источник.

Для завершения команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Вы можете вставить растровое изображение через буфер обмена.

Смотрите также

Обрезка рисунка

Выполнение обрезки рисунка


Команда Таблица

Позволяет вставить в текст (начиная с текущего положения курсора) таблицу произвольной структуры.

Для вызова команды нажмите кнопку Таблица или выберите ее название из меню Вставка.

После вызова команды на экран выводится диалог, в котором следует назначить параметры создаваемой таблицы.

Для перехода к редактированию ранее созданной таблицы дважды щелкните на ней левой кнопкой мыши или вызовите команду Редактор — Редактировать объект.

Смотрите также

Приемы работы с таблицами


Команда Вставить вертикальный текст

Позволяет вставить в текстовый документ или в таблицу (начиная с текущего положения курсора) вертикально расположенные строки текста.

Для вызова команды нажмите кнопку Вставить вертикальный текст или выберите ее название из меню Вставка.

После вызова команды в текущей позиции курсора открывается прямоугольное поле ввода текста. После того как текст (он может состоять из нескольких строк) введен, щелкните левой кнопкой мыши за пределами поля ввода — текст будет размещен вертикально.

Для перехода к редактированию ранее вставленного вертикального текста дважды щелкните по нему левой кнопкой мыши или вызовите команду Редактор — Редактировать объект.

При вводе технических требований, текста на чертеже и заполнении основной надписи вставка вертикального текста невозможна.


Команда Редактирование — По слою

Позволяет сделать доступ к редактированию выбранного объекта зависимым от состояния слоя, на котором находится этот объект.

Команда может быть вызвана нажатием кнопки на инструментальной панели Редактирование детали и Редактирование сборки или из контекстного меню выделенных объектов.

После вызова команды запрет на редактирование объекта устанавливается или снимается в зависимости от того, запрещено или доступно редактирование слоя, содержащего этот объект (свойство Редактирование объекта принимает значение свойства Редактируемость слоя). Если запрет устанавливается, то у объекта появляется значок «щит» в Дереве построения, если снимается — исчезает.

Чтобы сделать редактируемость объекта независимой от слоя, следует вызвать команду Редактирование — Запрещено или Редактирование — Разрешено.

Подробнее о запрете редактирования объектов...

Компоненты сборки могут быть отмечены значком «щит» серого цвета. Это означает, что к сборке был применен тип загрузки, защищенный паролем и содержащий информацию о запрете редактирования компонентов. В этом случае после вызова команды Редактирование — Разрешено или Редактирование — По слою необходимо ввести пароль системного типа загрузки.

Если к сборке применен защищенный паролем тип загрузки, а затем в нее добавлены компоненты, то в других пользовательских типах загрузки эти компоненты автоматически получают запрет на редактирование — «серый щит».

Подробнее о запрете редактирования компонентов...


Команда Редактирование — Запрещено

Позволяет наложить запрет на редактирование выбранного объекта.

Команда может быть вызвана нажатием кнопки на инструментальной панели Редактирование детали и Редактирование сборки или из контекстного меню выделенных объектов.

После вызова команды объект становится невозможно отредактировать и удалить (свойство Редактирование объекта принимает значение Запрещено). Объекты, имеющие запрет на редактирование, отмечаются в Дереве построения значком «щит».

Чтобы снять запрет на редактирование объекта, следует вызвать команду Редактирование — Разрешено.

Кроме того, вызвав команду Редактирование — По слою, можно сделать доступ к редактированию объекта зависимым от слоя, на котором этот объект находится.

Подробнее о запрете редактирования объектов...

Компоненты сборки могут быть отмечены значком «щит» серого цвета. Это означает, что к сборке был применен тип загрузки, защищенный паролем и содержащий информацию о запрете редактирования компонентов. В этом случае после вызова команды Редактирование — Разрешено или Редактирование — По слою необходимо ввести пароль системного типа загрузки.

Если к сборке применен защищенный паролем тип загрузки, а затем в нее добавлены компоненты, то в других пользовательских типах загрузки эти компоненты автоматически получают запрет на редактирование — «серый щит».

Подробнее о запрете редактирования компонентов...


Команда Редактирование — Разрешено

Позволяет снять запрет на редактирование выбранного объекта.

Команда может быть вызвана нажатием кнопки на инструментальной панели Редактирование детали и Редактирование сборки или из контекстного меню выделенных объектов.

После вызова команды ограничения, наложенные на редактирование объекта, снимаются (свойство Редактирование объекта принимает значение Разрешено). Значок «щит» у объекта в Дереве построения исчезает.

Чтобы вновь наложить запрет на редактирование объекта, следует вызвать команду Редактирование — Запрещено.

Кроме того, вызвав команду Редактирование — По слою, можно сделать доступ к редактированию объекта зависимым от слоя, на котором этот объект находится.

Подробнее о запрете редактирования объектов...

Компоненты сборки могут быть отмечены значком «щит» серого цвета. Это означает, что к сборке был применен тип загрузки, защищенный паролем и содержащий информацию о запрете редактирования компонентов. В этом случае после вызова команды Редактирование — Разрешено или Редактирование — По слою необходимо ввести пароль системного типа загрузки.

Если к сборке применен защищенный паролем тип загрузки, а затем в нее добавлены компоненты, то в других пользовательских типах загрузки эти компоненты автоматически получают запрет на редактирование — «серый щит».

Подробнее о запрете редактирования компонентов...


Опция Как в документе

Опция, позволяющая отображать объекты вставки с умолчательными параметрами, т.е. параметрами, заданными при настройке документа-владельца.

Если эта опция включена, то отображение объектов изменяется следующим образом:

– параметры, которые нельзя изменить при создании объекта (например, длина стрелок размеров), приводятся к умолчательным,

– параметры, которые можно изменить при создании объекта (например, высота шрифта размерной надписи), приводятся к умолчательным только в том случае, если они не редактировались.

При выключенной опции все объекты вставки отображаются так же, как в виде-источнике.


Опция В тонких линиях

Опция, позволяющая отображать вместо основных и утолщенных линий вставки соответствующие тонкие линии. Если она включена, то линии вставки отображаются следующим образом:

– основные и утолщенные — тонкими;

– штриховые основные — штриховыми;

– осевые основные — осевыми.

Указанная замена производится только для системных стилей линий. Имеющиеся во вставке линии пользовательских стилей сохраняют свой вид вне зависимости от состояния опции В тонких линиях.


Команда Объединить с окном Свойства/Панелью свойств

Команда служит для объединения окна Свойства и Панели свойств в одно окно. Это позволяет сэкономить место на экране, так как окно Свойства и Панель свойств не используются одновременно.

Команда Объединить с окном Свойства находится в подменю команды Размещение контекстного меню Панели свойств, а команда Объединить с Панелью свойств — в контекстном меню заголовка окна Свойства.

В объединенном окне отображается, в зависимости от выполняемого действия, либо окно Свойства, либо Панель свойств.

Чтобы отменить объединение, следует вызвать команду Объединить с окном Свойства/Панелью свойств повторно.

Подробнее об объединении окна Свойства и Панели свойств...


Команда Исключить объект

Позволяет отменить выделение указанного объекта.

После вызова команды укажите курсором выделенный объект, с которого требуется снять выделение. При этом он должен попасть в «ловушку» курсора.

За один вызов команды можно исключить из числа выделенных произвольное количество объектов.


Команда Исключить вне рамки

Позволяет отменить выделение объектов, расположенных снаружи прямоугольной рамки.

После вызова команды укажите первую вершину рамки, нажмите левую кнопку мыши и перемещайте мышь, пока рамка не достигнет нужного размера. Затем отпустите кнопку.

Выделенные элементы, целиком оставшиеся снаружи заданной рамки, будут исключены из числа выделенных.


Команда Исключить секущей ломаной

Позволяет отменить выделение объектов, пересекая их ломаной линией.

После вызова команды указывайте вершины ломаной так, чтобы ее звенья пересекали выделенные объекты, с которых требуется снять выделение.


Команда Исключить секущей рамкой

Позволяет отменить выделение объектов, полностью или частично попавших в прямоугольную рамку.

После вызова команды укажите первую вершину рамки, нажмите левую кнопку мыши и перемещайте мышь, пока рамка не достигнет нужного размера. Затем отпустите кнопку.

Выделенные элементы, целиком или частично попавшие в рамку, будут исключены из числа выделенных.

За один вызов команды можно отменить выделение произвольное количество объектов, указывая их секущей рамкой.


Команда Исключить рамкой

Позволяет отменить выделение объектов, полностью попавших в прямоугольную рамку.

После вызова команды укажите первую вершину рамки, нажмите левую кнопку мыши и перемещайте мышь, пока рамка не достигнет нужного размера. Затем отпустите кнопку.

Выделенные элементы, целиком попавшие в рамку, будут исключены из числа выделенных.

За один вызов команды можно отменить выделение произвольное количество объектов, указывая их рамкой.


Команда Копировать свойства (при создании и редактировании объектов)

Команда Копировать свойства
(при создании и редактировании объектов)

Позволяет копировать свойства существующих объектов в новый или редактируемый объект, не выходя из процесса создания или редактирования.

Команда Копировать свойства доступна на Панели специального управления после вызова большинства команд, размещенных на инструментальных панелях Геометрия, Размеры, Обозначения и Обозначения для строительства.

Чтобы скопировать свойства:

1. Нажмите кнопку Копировать свойства на Панели специального управления или нажмите комбинацию клавиш <Ctrl> + <Shift> + <С>.

Курсор изменит вид.

2. Установите курсор на объекте — источнике свойств. После того как объект подсветится, щелкните левой кнопкой мыши.

Система автоматически возвратится в команду, из которой была вызвана команда Копировать свойства.

Чтобы поменять объект копирования, вызовите вновь команду Копировать свойства и укажите другой объект.

3. Задайте параметры объекта.

4. Создайте новый объект или завершите процесс редактирования.

Объект будет иметь свойства объекта-источника.

Команду Копировать свойства можно прервать до возвращения в команду, из которой она была вызвана, нажав кнопку Прервать команду на Панели специального управления.


Команда Добавить объект

Позволяет добавить к выделенным указанный объект активного документа.

После вызова команды укажите курсором объект, который нужно добавить к выделенным. При этом он должен попасть в «ловушку» курсора.

За один вызов команды можно включить в число выделенных произвольное количество объектов.


Команда Добавить вне рамки

Позволяет добавить к выделенным объекты активного документа, расположенные снаружи прямоугольной рамки.

После вызова команды укажите первую вершину рамки, нажмите левую кнопку мыши и перемещайте мышь, пока рамка не достигнет нужного размера. Затем отпустите кнопку.

Элементы, целиком оставшиеся снаружи заданной рамки, будут добавлены к выделенным.


Команда Добавить секущей ломаной

Позволяет добавить к выделенным объекты активного документа, пересекая их ломаной линией.

После вызова команды указывайте вершины ломаной так, чтобы ее звенья пересекали объекты, которые требуется добавить к выделенным.


Команда Добавить секущей рамкой

Позволяет добавить к выделенным объекты активного документа, полностью или частично попавшие в прямоугольную рамку.

После вызова команды укажите первую вершину рамки, нажмите левую кнопку мыши и перемещайте мышь, пока рамка не достигнет нужного размера. Затем отпустите кнопку.

Элементы, целиком или частично попавшие в рамку, будут добавлены к выделенным.

За один вызов команды можно включить в число выделенных произвольное количество объектов, выделяя их секущей рамкой.


Команда Добавить рамкой

Позволяет добавить к выделенным объекты активного документа, полностью попавшие в прямоугольную рамку.

После вызова команды укажите первую вершину рамки, нажмите левую кнопку мыши и перемещайте мышь, пока рамка не достигнет нужного размера. Затем отпустите кнопку.

Элементы, целиком попавшие в рамку, будут добавлены к выделенным.

За один вызов команды можно включить в число выделенных произвольное количество объектов, выделяя их рамкой.


Команда Точки пересечений двух кривых

Позволяет построить точки в местах пересечений кривых.

Для вызова команды нажмите кнопку Точки пересечений двух кривых на инструментальной панели Геометрия.

Укажите курсором первую и вторую кривые. В местах пересечений указанных кривых автоматически создаются точки.

Пример простановки точек пересечений

Выбор стиля точки

Для выхода из команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие геометрические объекты


Команда Инвертировать выбор полюсов

Команда позволяет инвертировать выделение полюсов сетки: с выделенных полюсов выделение снимается, выделяются все остальные полюсы.

Команда доступна, если хотя бы один полюс является выделенным.

Смотрите также

Произвольное перемещение полюсов мышью


Команда Изолировать объекты

Позволяет разорвать связи объекта с его исходными объектами. Команда вызывается из меню Редактор после указания объекта в Дереве построения.

При указании тела или поверхности команда недоступна.

После вызова команды в модели появляется копия исходных объектов изолируемого объекта. Данная копия представляет собой объект модели, содержащий геометрические объекты без истории. Эти объекты являются копиями исходных геометрических объектов изолируемого объекта и ассоциативно связаны с ними.

Связи изолированного объекта с его исходными объектами разрываются и создаются связи между изолированным объектом и объектами полученной копии.

Подробнее об изолировании объектов...


Команда Изопараметрическая кривая

Позволяет построить изопараметрическую кривую теоретической поверхности указанной грани, проходящую через заданную точку этой грани.

Общие сведения о теоретической поверхности грани и изопараметрических кривых...

Положение точки на грани можно задать двумя способами:

– заданием параметров U и V точки на теоретической поверхности грани,

– указанием точечного объекта.

Пример

Для вызова команды нажмите кнопку Изопараметрическая кривая на инструментальной панели Пространственные кривые или выберите ее название из меню Операции — Пространственные кривые — Кривые на поверхности.

Укажите в окне модели нужную грань.

Выбор объектов в окне модели

Базовую грань для построения изопараметрической кривой можно указать и перед вызовом команды.

Указанная грань подсвечивается. На грани появляются: фантом точки указания грани и фантомы изопараметрических кривых U и V, проходящие через эту точку. В поле Поверхность Панели свойств отображается наименование выбранной грани. В полях ввода Параметр U, % и Параметр V, % отображаются значения параметров U и V в точке указания грани. Направление отсчета значений показано стрелками из точки начала U=0, V=0.

Задайте положение точки, через которую должна проходить изопараметрическая кривая.

По умолчанию строится изопараметрическая кривая направления U — ее фантом активный. При этом в группе переключателей Выбор по направлению на Панели свойств активен переключатель Кривая по направлению U. Чтобы построить изопараметрическую кривую направления V, активизируйте переключатель Кривая по направлению V. Фантом кривой направления V становится активным.

Чтобы сменить объекты, используемые для построения кривой, нажмите кнопку Указать заново на Панели специального управления и повторите выбор объектов.

Элементы управления, расположенные на вкладке Свойства Панели свойств, позволяют изменить название и цвет кривой, настроить параметры ее отображения.

Чтобы завершить создание кривой, нажмите кнопку Создать объект на Панели специального управления.

После завершения построения первой кривой система ожидает указания объектов для создания следующей кривой.

Для выхода из команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.


Команда Изопараметрическая кривая

Позволяет построить изопараметрическую кривую, которая будет использоваться в качестве секущего объекта при выполнении операции усечения или разбиения поверхности.

Для вызова команды нажмите кнопку Изопараметрическая кривая на Панели специального управления.

После вызова команды запускается операция построения изопараметрической кривой.

Если исходная поверхность состоит из одной грани, то она выбирается автоматически, а если из нескольких, то следует указать грань, на которой должна располагаться кривая. Затем укажите на грани точку, выберите направление проходящей через нее изопараметрической кривой и нажмите кнопку Создать объект.

Система вернется в процесс операции разбиения или усечения.

Созданная кривая появится в Дереве построения и будет автоматически выбрана в качестве секущего объекта.


Команда Кривая направления U

Позволяет построить изопараметрическую кривую грани направления U.

Общие сведения о теоретической поверхности грани и изопараметрических кривых...

Изопараметрическая кривая...


Команда Кривая направления V

Позволяет построить изопараметрическую кривую грани направления V.

Общие сведения о теоретической поверхности грани и изопараметрических кривых...

Изопараметрическая кривая...


Команда Выровнять по границе

Позволяет продлить объекты до указанной границы или усечь по ней.

Выравнивание может потребоваться при построении изображений тел вращения, например, как на рисунке 1, а также во многих других случаях.

Для вызова команды нажмите кнопку Выровнять по границе на инструментальной панели Редактирование.

Укажите границу выравнивания — любой геометрический объект.

Затем укажите объекты, которые должны быть выровнены.

Вспомогательные прямые нельзя выровнять по границе. Кривые Безье и NURBS могут быть только усечены по границе, продление их с помощью команды выравнивания невозможно.

Рис. 1. Исходное изображение детали и изображение после выравнивания ребер по оси вращения

Объекты для выравнивания можно указывать по одному или группой. Для указания группы объектов используется секущий отрезок. Выровнены будут те объекты, которые пересекаются этим отрезком.

Если объект пересекается с границей выравнивания несколько раз, то учитываются все пересечения (например, как на рисунке 2).

Рис. 2. Исходное изображение и изображение после выравнивания эллипса по кривой Безье

Продление дуги окружности или эллипса до кривой NURBS или Безье возможно, только если продолжение дуги пересекается с кривой как минимум в двух точках.

Чтобы перейти к выравниванию по другой границе, нажмите кнопку Указать заново на Панели специального управления и выберите новую границу.

Для завершения команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие команды редактирования


Команда Номер узла

Позволяет создать обозначение номера узла, используемое в строительной документации.

Для вызова команды нажмите кнопку Номер узла на инструментальной панели Обозначения для строительства или выберите ее название из меню Инструменты — Обозначения для строительства.

После вызова команды на экране появляется фантом номера узла. Точка привязки располагается в центре окружности.

Введите координаты точки привязки (т) номера узла на Панели свойств или укажите точку, определяющую положение номера узла в окне документа.

Чтобы ввести надпись в номере узла, вызовите диалог ввода текста. Для этого щелкните мышью в поле Текст на Панели свойств или вызовите команду Текст надписи... из контекстного меню.

Примеры обозначений номера узла

Чтобы зафиксировать изображение, нажмите кнопку Создать объект на Панели специального управления.

Геометрические параметры обозначения номера узла задаются в диалоге параметров отрисовки номера узла. Настройка, сделанная в этом диалоге, распространяется на все номера узлов в текущем документе.

Вы можете создать несколько обозначений за один вызов команды Номер узла. Для этого после нажатия кнопки Создать объект укажите новую точку расположения номера узла.

Для выхода из команды Номер узла, нажмите кнопку Прервать команду на Панели специального управления.

По сравнению с изображением номера узла, полученным посредством геометрических построений, обозначение, созданное при помощи команды Номер узла, имеет следующие преимущества:

– сохраняет размеры и взаимное расположение частей при масштабировании, повороте или преобразовании симметрии,

– может содержать ссылку на другой объект (например, обозначение узла) и может являться источником ссылки.

Номер узла может входить в надпись вида — если вид был автоматически сформирован после создания обозначения узла или узла в сечении. В этом случае номер узла представляет собой ссылку на соответствующее обозначение узла, а на Панели свойств появляется вкладка Надпись вида, позволяющая управлять составом надписи.

Смотрите также

Другие обозначения для строительства


Команда Менеджер документа...

Команда доступна при работе с моделями, графическими документами, текстовыми документами и спецификациями.

Вызывается следующими способами:

– из меню Сервис,

– нажатием одноименной кнопки на инструментальной панели Стандартная.

Команда позволяет выполнять операции:

– в моделях — со слоями, исполнениями модели и режимом пересчета размеров,

– в графических документах — с листами, видами и слоями документа,

– в текстовых документах — c разделами,

– в спецификациях — с листами.

После вызова команды на экране появляется диалог Менеджер документа.

Менеджер документа в модели

Менеджер документа в графическом документе, текстовом документе или спецификации


Команда Панель (меню Менеджера)

Команда Панель
(меню Менеджера)

Устанавливает режим панели для работы с библиотекой, имя которой выделено в списке.

Команда доступна для прикладных КОМПАС-библиотек.

Название режима работы, установленного для библиотеки, отображается в окне сведений о ней.


Команда Меню (меню Менеджера)

Команда Меню
(меню Менеджера)

Устанавливает режим меню для работы с библиотекой, имя которой выделено в списке.

Команда доступна для прикладных КОМПАС-библиотек.

Название режима работы, установленного для библиотеки, отображается в окне комментария к ней.


Команда Окно (меню Менеджера)

Команда Окно
(меню Менеджера)

Устанавливает режим окна для работы с библиотекой, имя которой выделено в списке.

Команда доступна для прикладных КОМПАС-библиотек.

При изменении режима работы подключенной библиотеки происходит ее запуск.

Название режима работы, установленного для библиотеки, отображается в окне комментария к ней.


Команда Дополнительные способы

Позволяет перейти к дополнительным способам построения ЛСК. Эти способы предоставляют расширенные возможности определения позиции и ориентации ЛСК (в том числе путем задания углов Эйлера).

Для вызова команды нажмите кнопку Дополнительные способы на Панели специального управления.

Подробнее о построении ЛСК дополнительными способами...


Команда Линия-выноска (графический документ)

Команда Линия-выноска
(графический документ)

Позволяет создать произвольную линию-выноску.

Для вызова команды нажмите кнопку Линия-выноска на инструментальной панели Обозначения.

Укажите начальную точку первого ответвления линии-выноски.

Укажите точку начала полки т1.

Затем укажите начальные точки остальных ответвлений. Их количество не ограничено.

Варианты создания ответвлений можно выбрать с помощью группы Ответвления на вкладке Параметры Панели свойств. Например, вы можете включить построение ответвлений от конца полки или параллельно друг другу.

Буква для простановки на полке линии-выноски может выбираться системой автоматически. Для этого включите опцию Автосортировка рядом с полем Текст. При отключенной опции вы можете ввести в обозначение любой произвольный текст. Для этого вызовите диалог ввода надписи обозначения, щелкнув в поле Текст левой кнопкой мыши.

Дополнительный текст обозначения можно ввести и при включенной опции Автосортировка (диалог ввода надписи остается доступным).

На экране отображается фантом создаваемой линии-выноски.

Настройка отрисовки линии-выноски

По умолчанию при создании линии-выноски включен режим добавления ответвлений. Об этом свидетельствует нажатая кнопка Добавить ответвления на Панели специального управления. В этом режиме каждая вновь указанная точка воспринимается системой как начальная точка очередного ответвления.

В режиме редактирования характерных точек объекта можно внести изменения в конфигурацию линии-выноски. Добавление ответвлений в этом режиме невозможно. Для перехода в режим редактирования нажмите кнопку Редактировать точки на Панели специального управления.

Между режимами можно произвольно переключаться при помощи кнопок Панели специального управления или команд в контекстном меню. При выходе из одного режима автоматически включается другой.

Чтобы зафиксировать изображение, нажмите кнопку Создать объект на Панели специального управления.

Дополнительные варианты добавления ответвлений: а) на разных концах полки, б) параллельно друг другу
Пример простановки линии-выноски
а) | б)

При редактировании проекционной линии-выноски часть элементов управления Панели свойств недоступна. Соответствующие параметры обозначения передаются в чертеж из модели, поэтому их ручное изменение невозможно.

Смотрите также

Добавление ответвлений

Другие обозначения


Команда Линия-выноска (документ-модель)

Команда Линия-выноска
 (документ-модель)

Позволяет создать в модели произвольную линию-выноску. Линия-выноска может быть проставлена к следующим объектам:

– грань тела или поверхности,

– координатная плоскость,

– вспомогательная плоскость,

– точка в эскизе,

– пространственная точка,

– вершина пространственной кривой,

– линия эскиза,

– сегмент пространственной ломаной,

– пространственная кривая,

– ребро тела или поверхности,

– координатная ось,

– вспомогательная ось,

– размер,

– обозначение.

Пример

Для вызова команды нажмите кнопку Линия-выноска на инструментальной панели Элементы оформления.

Укажите объект, на который указывает первое ответвление линии-выноски. Начальной точкой первого ответвления будет точка, в которой был указан объект.

Укажите точку начала полки.

На экране появляется фантом обозначения.

Вы можете сменить базовую плоскость обозначения с помощью списка Базовая плоскость на вкладке Знак Панели свойств.

Кроме того, вы можете сместить плоскость обозначения параллельно самой себе, используя элемент управления Положение.

Если в качестве обозначаемого объекта выбран размер или условное обозначение, то линия-выноска проставляется в плоскости этого объекта. Изменение положения плоскости обозначения невозможно.

Букву для простановки на полке линии-выноски можно выбрать из контекстного меню поля Текст на вкладке Знак Панели свойств. Для ввода произвольного текста вызовите диалог ввода надписи обозначения, щелкнув в поле Текст левой кнопкой мыши.

Настройка отрисовки линии-выноски

По умолчанию при создании линии-выноски включен режим добавления ответвлений. Об этом свидетельствует нажатая кнопка Добавить ответвления на Панели специального управления. В этом режиме каждая вновь указанная точка воспринимается системой как начальная точка очередного ответвления.

Подробнее о добавлении и удалении ответвлений...

В режиме редактирования характерных точек объекта можно внести изменения в конфигурацию линии-выноски. Добавление ответвлений в этом режиме невозможно. Для перехода в режим редактирования нажмите кнопку Редактировать точки на Панели специального управления.

Между режимами можно произвольно переключаться при помощи кнопок Панели специального управления или команд в контекстном меню. При выходе из одного режима автоматически включается другой.

Чтобы зафиксировать обозначение, нажмите кнопку Создать объект на Панели специального управления.

Пример простановки линии-выноски

Смотрите также

Другие элементы оформления


Команда Редактировать точки

Позволяет перейти из режима добавления штрихов в режим редактирования точек обозначения узла в сечении.


По контуру

Переключатель, управляющий формированием обозначения обработки по контуру.


Команда Заменить зеркальным исполнением

Вызывается из контекстного меню компонента, входящего в зеркальное исполнение модели. Команда присутствует в меню компонента, если для его получения использовался любой вариант отражения, кроме отражения способом Зеркальное отражение компонента с результатом операции Сохранить зеркальный компонент в файле.

Подробнее о способах отражения компонентов

При активном состоянии команды (рядом с названием команды в меню компонента отображается «галочка») компонент является зеркальным исполнением, т.е. зеркальное исполнение модели содержит зеркальное исполнение компонента. Если «галочки» рядом с названием команды нет, то в исполнение модели входит исходное исполнение компонента.

Вызвав команду, вы можете заменить исходное исполнение компонента зеркальным и наоборот.

Подробнее о работе команды...


Команда Сведения (меню Менеджера)

Команда Сведения
(меню Менеджера)

Выводит на экран диалог информации о выбранном фрагменте.


Команда Менеджер библиотек

Позволяет включить или отключить отображение на экране окна Менеджера библиотек — системы управления КОМПАС-библиотеками.

Для вызова команды нажмите кнопку Менеджер библиотек на панели Стандартная или выберите ее название из меню Сервис.


Команда Очистить Менеджер библиотек

Позволяет удалить содержимое Менеджера библиотек.

Команда доступна в контекстном меню Менеджера библиотек.

После вызова команды из Менеджера удаляются все библиотеки, кроме подключенных на момент вызова команды. Ставшие пустыми разделы Менеджера также удаляются.

Файлы библиотек не удаляются — они остаются на диске на прежних местах.

Смотрите также

Команда Обновить Менеджер библиотек


Команда Обновить Менеджер библиотек

Позволяет обновить содержимое Менеджера библиотек в соответствии с файлами (файлом) *.lms, имеющимися в подпапке Sys главной папки системы.

Команда доступна в меню Сервис и в контекстном меню Менеджера библиотек.

Если на момент вызова команды Менеджер библиотек пуст, то в него добавляются библиотеки согласно файлам *.lms, найденным в папке Sys.

Если на момент вызова команды Менеджер библиотек не пуст, то производятся следующие действия.

1. Проверка актуальности текущего содержимого Менеджера библиотек. Если файлы каких-либо библиотек отсутствуют по заданным для них путям, то эти библиотеки удаляются из Менеджера библиотек.

2. Поиск первого файла *.lms в папке Sys и его обработка. Обработка состоит в следующем. Для каждой указанной в файле *.lms библиотеки производится проверка наличия ее файла по заданному пути. Если файл библиотеки найден, производится поиск этой библиотеки в текущем содержимом Менеджера библиотек. Отсутствующие библиотеки добавляются в Менеджер, а присутствующие (даже если они располагаются в иных разделах Менеджера, чем это указано в файле *.lms) — нет.

3. Поиск следующего по алфавиту файла *.lms, его обработка и так далее до последнего файла *.lms в папке Sys.

Если в последующих файлах *.lms обнаруживаются библиотеки, которые уже добавлены согласно одному из предыдущих файлов, повторное добавление не производится.

Смотрите также

Команда Очистить Менеджер библиотек


Команда Получить лицензию на КОМПАС-3D

Позволяет получить лицензию на работу с системой трехмерного проектирования, записанную в памяти сетевого ключа электронной защиты.

Для вызова команды выберите ее название в меню Сервис или наведите курсор на значок в нижнем правом углу окна приложения и щелкните по нему левой кнопкой мыши. При наведении курсора значок Деморежим изменится на значок Получить лицензию на КОМПАС-3D.

После этого система проверяет, есть ли на сетевом ключе свободные лицензии на работу с КОМПАС-3D.

– Если лицензии есть, то одна из них занимается. В меню рядом с именем команды Получить лицензию на КОМПАС-3D появляется «галочка». Это свидетельствует о том, что на данном рабочем месте используется лицензия на работу с КОМПАС-3D. При этом становятся доступны все команды редактирования трехмерных моделей.

Завершив работу с моделями, вы можете освободить лицензию. Для этого вызовите команду Получить лицензию на КОМПАС-3D повторно. «Галочка» в меню исчезнет. Освободившуюся лицензию сможет получить другой пользователь на другом рабочем месте.

– Если лицензию получить нельзя, то после вызова команды Получить лицензию на КОМПАС-3D выдается сообщение: «Невозможно получить лицензию на работу с КОМПАС-3D. Работа с трехмерными моделями возможна только в деморежиме».

В этом случае команды редактирования трехмерных объектов недоступны, а файлы деталей (*.m3d) и сборок (*.a3d) открываются в демонстрационном режиме. Модель, открытую в демонстрационном режиме, можно просматривать, изменяя тип отображения и положение в пространстве, а также печатать. Кроме того, в демонстрационном режиме работы с моделями доступна команда Новый чертеж из модели, позволяющая создать чертеж с ассоциативными видами текущей модели.

Вы можете настроить систему КОМПАС-3D так, чтобы получение лицензии на работу с КОМПАС-3D происходило автоматически при загрузке системы. Эта настройка производится в диалоге управления системой.


Команда Разрешить работу со спецификацией

Позволяет включить работу со спецификацией.

Для вызова команды выберите ее название в меню Сервис.

После включения работы со спецификацией становятся доступны:

• все команды работы с объектами спецификации в документах-спецификациях, графических документах и документах-моделях,

• все команды подключения к спецификации графических документов и документов моделей и команды синхронизации спецификации с подключенными документами,

• сохранение документа-спецификации.

Если работа со спецификацией включена, то в меню рядом с именем команды Разрешить работу со спецификацией отображается «галочка», если выключена — «галочки» нет.

В случае если работа со спецификацией выключена, команды работы с объектами спецификации в графических документах и документах-моделях недоступны, не производится синхронизация документов, предусмотренная настройками спецификации. В то же время создание нового документа-спецификации и объектов в нем возможно. В заголовке окна документа-спецификации отображаются слова «работа со спецификацией запрещена»; при попытке сохранения документа на экране появляется запрос на включение работы со спецификацией, так как запись файла *.spw на диск возможна, только если работа со спецификацией разрешена.

Управление автоматическим включением работы со спецификацией производится в диалоге управления системой.


Направление

Группа переключателей, позволяющая задать для разделителей Дуговой и Перекрытие направление, т.е. выбрать, для какого из двух стыкующихся сегментов будет создан разделитель.

Активизируйте нужный переключатель: Направление 1 или Направление 2.


Команда Вспомогательная прямая

Позволяет построить произвольно расположенную прямую.

Для вызова команды нажмите кнопку Вспомогательная прямая на инструментальной панели Геометрия.

Укажите положение первой (т1), а затем второй (т2) точек, через которые должна проходить прямая.

Для точного позиционирования курсора воспользуйтесь привязками или меню геометрического калькулятора в полях т1 и т2 на Панели свойств.

Угол наклона прямой (угол между прямой и осью абсцисс текущей системы координат) будет определен автоматически.

Построение вспомогательной прямой

Простановка точек пересечений

Чтобы быстро построить пучок прямых, проходящих через одну точку, сделайте следующее. При построении самой первой прямой укажите в качестве первой точки общую для всех прямых точку и нажмите кнопку Запомнить состояние на Панели специального управления. Затем последовательно постройте нужное количество прямых, задавая их вторые точки.

Подробнее о запоминании параметров...

Для выхода из команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие геометрические объекты


Команда Линейный размер от отрезка до точки (документ-модель)

Команда Линейный размер от отрезка до точки
 (документ-модель)

Позволяет проставить линейный размер между прямолинейным и точечным объектами.

Пример

Для вызова команды нажмите кнопку Линейный от отрезка до точки на инструментальной панели Элементы оформления.

Укажите курсором прямолинейный объект, а затем — точечный.

Подробнее...

Задайте положение размерной линии. Для этого введите значение длины выносных линий в поле Длина на вкладке Размер Панели свойств (значение может быть как положительным, так и отрицательным) или переместите мышью характерные точки на ее концах.

В поле Текст отображается автоматически сформированная размерная надпись. Чтобы вызвать диалог редактирования и настройки размерной надписи, щелкните мышью в этом поле.

Элементы управления, расположенные на вкладке Параметры, позволяют настроить параметры размеров (вид стрелки, способ размещения текста и т.п.).

Элементы управления, расположенные на вкладке Свойства, позволяют задать наименование размера в Дереве построения и цвет отрисовки размерных линий.

Размещение размерной надписи на полке

Смотрите также

Другие элементы оформления


Команда Линейный размер (документ-модель)

Команда Линейный размер
 (документ-модель)

Позволяет проставить линейный размер между объектами различного типа.

Пример

Для вызова команды нажмите кнопку Линейный размер на инструментальной панели Элементы оформления.

Укажите курсором объекты для простановки размера и базовую плоскость — плоский объект, параллельно которому будет расположена плоскость размера.

Подробнее...

Задайте положение размерной линии. Для этого введите значение длины выносных линий в поле Длина на вкладке Размер Панели свойств (значение может быть как положительным, так и отрицательным) или переместите мышью характерные точки на ее концах.

В поле Текст отображается автоматически сформированная размерная надпись. Чтобы вызвать диалог редактирования и настройки размерной надписи, щелкните мышью в этом поле.

Элементы управления, расположенные на вкладке Параметры, позволяют настроить параметры размеров (вид стрелки, способ размещения текста и т.п.).

Элементы управления, расположенные на вкладке Свойства, позволяют задать наименование размера в Дереве построения и цвет отрисовки размерных линий.

Размещение размерной надписи на полке

Смотрите также

Зависимость значения размера от выбора базовой плоскости

Другие элементы оформления


Простановка точек пересечения

Переключатель, позволяющий указать, требуется ли простановка точек пересечения вспомогательной прямой со всеми графическими объектами, лежащими в активных слоях текущего вида.

Стиль автоматически проставленных точек — Вспомогательная.


Кнопка Отображение вершин

Позволяет управлять отображением вершин пространственной кривой.

Кнопка Отображение вершин находится на вкладке Свойства Панели свойств. Если эта кнопка нажата, то на Панели свойств присутствует список Стиль вершин. Вы можете выбрать стиль отображения вершины из этого списка.

После завершения построения кривой ее вершины будут отображаться выбранным стилем.

Для ломаной со скругленными вершинами отмечаются также концевые точки скруглений (см. рис.).

Отображение вершин включено | Отображение вершин отключено

Кнопка Отображение вершин доступна при редактировании ломаных, созданных в КОМПАС-3D версии 9 и выше.


Текущая строка

В этом поле, расположенном на панели Текущее состояние, отображается номер строки, в которой находится курсор.

Чтобы переместиться на другую строку текста, наберите ее номер в этом поле и нажмите клавишу <Enter>.

Если панель Текущее состояние расположена вертикально, то для доступа к полю Текущая строка нажмите соответствующую кнопку.


Угол

Поле для ввода угла наклона отрезка.

Угол отсчитывается от оси абсцисс системы координат базовой плоскости.

Вы можете указать положение угла наклона отрезка следующими способами:

– ввести значение вручную или установить с помощью счетчика;

– указать положение угла мышью в окне модели или связать его с уже имеющимся точечным объектом: включив опцию Ассоциировать и указав в модели точечный объект. Угол наклона отрезка определяется автоматически и заносится в поле Угол.


Длина

Поле для задания длины отрезка.

Вы можете задать длину отрезка следующими способами:

– ввести значение вручную или установить с помощью счетчика;

– указать длину отрезка мышью в окне модели или связать точку с имеющимся точечным объектом: включив опцию Ассоциировать и указав в модели точечный объект. Длина отрезка определяется автоматически и заносится в поле Длина.


Команда ОтрезокПостроение способом По точке, длине и углу наклона

Команда Отрезок
Построение способом По точке, длине и углу наклона

Данный способ позволяет построить отрезок с указанием плоскости отрезка и заданием параметров: начальной вершины, длины и угла наклона отрезка в плоскости. Отрезок располагается параллельно базовой плоскости.

Способ можно сделать текущим, выбрав название По точке, длине и углу наклона из списка Способ на Панели свойств или контекстного меню команды Отрезок.

Чтобы построить отрезок, выполните следующие действия.

1. Укажите начальную вершину отрезка. Переключатель Начальная вершина активизирован по умолчанию.

После задания начальной вершины отрезка автоматически активизируется переключатель Конечная вершина.

2. Задайте длину отрезка.

3. Задайте угол наклона отрезка.

Можно также указать точку в окне модели — длина и угол наклона отрезка будут определены автоматически.

По умолчанию базовая плоскость отрезка — одна из координатных плоскостей. Если требуется выбрать другую базовую плоскость, активизируйте переключатель Базовая плоскость на Панели свойств и укажите нужный объект в окне модели или в Дереве построения.

Выбор объектов в окне модели

Выбор объектов в Дереве построения

Подробнее...


Команда Отрезок (графический документ)

Команда Отрезок
(графический документ)

Позволяет построить произвольно расположенный отрезок.

Для вызова команды нажмите кнопку Отрезок на инструментальной панели Геометрия.

Доступно два основных способа построения произвольного отрезка:

– задание начальной и конечной точек отрезка,

– задание начальной точки, длины и угла наклона отрезка.

Если известны начальная (т1) и конечная (т2) точки отрезка, укажите их. При этом длина и угол наклона отрезка будут определены автоматически.

Если известны начальная точка отрезка, его длина и угол наклона, задайте их любым способом и в любом порядке. Например, вы можете указать курсором положение точки т1, ввести длину в поле на Панели свойств и задать курсором угол наклона отрезка. При этом конечная точка отрезка будет определена автоматически.

Построение отрезка по двум точкам

Выбор стиля линии

Чтобы быстро построить несколько отрезков, начинающихся в одной точке, сделайте следующее. При построении самого первого отрезка укажите в качестве начальной точки общую для всех отрезков точку и нажмите кнопку Запомнить состояние на Панели специального управления. Затем последовательно постройте нужное количество отрезков, задавая их остальные параметры.

Подробнее о запоминании параметров...

Для выхода из команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие геометрические объекты


Команда ОтрезокПостроение способом По 2 точкам

Команда Отрезок
Построение способом По 2 точкам

Данный способ позволяет построить отрезок по двум точкам.

Пример

Способ можно сделать текущим, выбрав название По 2 точкам из списка Способ на Панели свойств или контекстного меню команды Отрезок.

Чтобы построить отрезок, выполните следующие действия.

1. Укажите начальную вершину отрезка. Переключатель Начальная вершина активизирован по умолчанию.

После задания начальной вершины отрезка автоматически активизируется переключатель Конечная вершина.

2. Укажите конечную вершину отрезка.

Подробнее...


Команда Отрезок(документ-модель)

Команда Отрезок
(документ-модель)

Позволяет создать отрезок в пространстве.

Для вызова команды нажмите кнопку Отрезок на панели Пространственные кривые или выберите ее название из меню Операции — Пространственные кривые.

Отрезок можно построить двумя способами.

Выберите вариант построения отрезка из списка Способ или при помощи команд контекстного меню.

Задайте параметры отрезка для построения выбранным способом.

– По 2 точкам

– По точке, длине и углу наклона

После задания всех необходимых данных появляется фантом отрезка. Пока построение не завершено, можно изменить параметры отрезка, активизировав необходимый элемент управления на Панели свойств.

Чтобы сменить объекты, используемые для построения отрезка выбранным способом, нажмите кнопку Указать заново на Панели специального управления и повторите выбор объектов.

При необходимости назначьте допуски на значения параметров операции, выраженных в линейных или угловых величинах. Для этого используйте кнопку Назначить допуск, расположенную на Панели свойств рядом с полем числового параметра операции.
Подробнее о допусках...
Подробнее о назначении допуска...

Элементы управления, расположенные на вкладке Свойства Панели свойств, позволяют изменить название и цвет отрезка, настроить параметры его отображения. Также на этой вкладке отображается название системы координат отрезка.

Чтобы завершить построение, нажмите кнопку Создать объект на Панели специального управления.

Отказаться от построения отрезка можно, нажав кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

При всех способах построения отрезка доступен режим автосоздания, который по умолчанию включен.

Смотрите также

Особенности задания числовых параметров операции в полях Панели свойств


Команда Втянуть внешние ссылки (Меню Менеджера)

Команда Втянуть внешние ссылки
(Меню Менеджера)

Документы, хранящиеся в библиотеке, могут иметь ссылки на внешние файлы. Перечень ссылок можно просмотреть в диалоге информации о документе на вкладке Внешние ссылки во время редактирования библиотечного документа.

Команда Втянуть внешние ссылки позволяет скопировать во фрагменты библиотеки следующие объекты из внешних файлов, на которые имеются ссылки:

– типы атрибутов из библиотек типов атрибутов,

– стили линий, штриховок, текстов из соответствующих библиотек,

– фрагменты, вставленные внешней ссылкой.

Связь с библиотеками и файлами-источниками фрагментов после выполнения команды Втянуть внешние ссылки не сохраняется. Втянутые ссылки исчезают из списка внешних ссылок в диалоге информации о документе.

Ссылки на библиотеки оформлений (они присутствуют в документе, если в нем есть объекты спецификации), а также ссылки модели на ее компоненты втянуть невозможно. Эти ссылки остаются в документах, т.е. после вызова команды Втянуть внешние ссылки они по-прежнему отображаются в диалоге информации о документе. Для корректной работы с библиотечными документами, ссылающимися на внешние файлы, необходимо наличие этих файлов по путям, указанным в диалоге информации о документе.


Команда Добавить документ... (меню Менеджера)

Команда Добавить документ...
(меню Менеджера)

Позволяет добавить модель (фрагмент) или группу моделей (фрагментов) в библиотеку. При этом добавляемые документы должны быть уже созданы и сохранены в файлах на диске.

После вызова команды на экране появляется стандартный диалог выбора файла.

После ввода или выбора имен нужных файлов нажмите кнопку Открыть для добавления моделей (фрагментов) в библиотеку. В появившемся диалоге задайте имя или последовательно ряд имен моделей (фрагментов) в библиотеке и нажмите кнопку ОК. При нажатии на кнопку Отмена модели (фрагменты) не будут записаны в библиотеку.


Команда Вставить модель (фрагмент) в документ (меню Менеджера)

Команда Вставить модель (фрагмент) в документ
(меню Менеджера)

Позволяет вставить в активный документ выделенную модель или выделенный фрагмент библиотеки.

После вызова команды на Панели свойств появляются элементы, позволяющие управлять вставкой.


Команда Сохранить документ как... (меню Менеджера)

Команда Сохранить документ как...
(меню Менеджера)

Сохраняет модель (фрагмент) библиотеки в отдельном файле на диске.

После вызова команды на экране появляется стандартный диалог записи файлов.

После ввода или выбора имени нужного файла нажмите кнопку Сохранить для записи этого файла. Для выхода из диалога без записи файла нажмите кнопку Отмена.


Команда Оптимизировать (меню Менеджера)

Команда Оптимизировать
(меню Менеджера)

При удалении моделей (фрагментов) из библиотеки размер ее файла на диске не меняется (место в файле, на котором хранилась удаленная модель (фрагмент), остается свободным). При последующем создании модели (фрагмента) в этой библиотеке она записывается на свободное место в файле библиотеки (если свободного места нет, размер библиотеки увеличивается). По этой причине случается, что файл библиотеки, содержащей небольшое количество моделей (фрагментов), имеет очень большой размер.

Команда Оптимизировать служит для приведения размера файла в соответствие с количеством хранящихся в нем моделей (фрагментов). После вызова команды из файла библиотеки исключаются свободные участки, а ее внутренняя структура упорядочивается.

При значительном размере файла библиотеки выполнение команды может занять несколько минут.

Оптимизацию библиотеки моделей можно сравнить с дефрагментацией жесткого диска, произведенной в пределах одного файла.


Команда Добавить описание прикладной библиотеки (меню Менеджера)

Команда Добавить описание прикладной библиотеки
(меню Менеджера)

Позволяет добавить описание прикладной библиотеки в текущий раздел Менеджера библиотек.

После вызова команды на экране появляется диалог выбора файлов. Выберите файл библиотеки для добавления в Менеджер и нажмите кнопку Открыть диалога. Чтобы отказаться от добавления библиотеки, нажмите кнопку Отмена.

К системе КОМПАС-3D одновременно может быть подключено не более 25 библиотек.


Команда Запустить (меню Менеджера)

Команда Запустить
(меню Менеджера)

Позволяет запустить библиотеку, имя которой выделено в списке.

Если перед вызовом команды библиотека не была подключена, то в результате выполнения команды выполняются следующие действия:

– библиотека подключается,

– библиотека активизируется в избранном режиме работы.

Если перед вызовом команды библиотека была подключена, то в результате выполнения команды библиотека активизируется в избранном режиме работы.

Запуск библиотек фрагментов и моделей происходит также при их подключении.

Для работы с библиотеками фрагментов и моделей предусмотрен только режим панели.


Команда Отключить все библиотеки (меню Менеджера)

Команда Отключить все библиотеки
(меню Менеджера)

Отключает все подключенные библиотеки во всех разделах Менеджера библиотек.


Команда Подключить (меню Менеджера)

Команда Подключить
(меню Менеджера)

Позволяет подключить библиотеку, имя которой выделено в списке.

Команда доступна для неподключенных библиотек.

Выбранная библиотека подключается в установленном для нее режиме: меню, окно, диалог или панель. В поле рядом с названием библиотеки появляется красная «галочка» — признак того, что библиотека подключена; «галочкой» помечается также название команды в меню, а кнопка на инструментальной панели остается нажатой.

Для отключения библиотеки выделите ее в списке и повторно вызовите команду Подключить. Можно также щелкнуть мышью в поле с красной «галочкой» рядом с названием библиотеки.


Команда Типы загрузки — Полный

Позволяет применить к выбранному компоненту или компонентам тип загрузки — Полный.

Команда может быть вызвана нажатием кнопки на инструментальной панели Редактирование сборки или из контекстного меню выбранных компонентов.

После вызова команды тип загрузки выбранных компонентов заменяется на Полный. Для компонентов-подсборок команда распространяется на их компоненты всех уровней.

Подробнее о выборе типа загрузки компонента...

Смотрите также

Особенности компонентов с неполной загрузкой

Типы загрузки сборки


Команда Пересчитать размеры с учетом допусков

Позволяет включать и отключать режим пересчета размеров модели.

Этот режим служит для пересчета размеров модели с учетом назначенных допусков (общих и индивидуальных). Пересчет размеров модели производится согласно параметрам текущего пересчета.

Для вызова команды нажмите кнопку Пересчитать размеры с учетом допусков на панели Режимы или вызовите одноименную команду из меню Сервис — Пересчет размеров.

Команда Пересчитать размеры с учетом допусков недоступна при редактировании компонента «на месте».

Меню кнопки Пересчитать размеры с учетом допусков содержит перечень всех пересчетов размеров модели и команды Управление пересчетом... и Создать копию.

В этом меню вы можете:

– выбрать текущий пересчет, согласно которому производится пересчет размеров модели;

– открыть Менеджер документа для управления пересчетом, используя команду Управление пересчетом...;

– создать копию преобразованной модели, используя команду Создать копию.

Все команды меню кнопки Пересчитать размеры с учетом допусков, кроме пользовательских пересчетов, можно также вызвать из меню Сервис — Пересчет размеров.

После вызова команды Пересчитать размеры с учетом допусков включается режим пересчета размеров модели:

– значения переменных, соответствующих размерам модели, на которые назначены допуски, изменяются согласно параметрам выбранного пересчета;

– пересчитанные значения переменных отображаются в Окне переменных в столбце Пересчитанное значение;

– в заголовок окна документа добавляется надпись «(Пересчет — <наименование выбранного пересчета>)»;

– модель перестраивается с учетом новых размеров.

Обратите внимание на то, что при включенном режиме пересчета недоступны команды создания новых объектов и команды редактирования уже имеющихся объектов. Возможны только следующие действия:

– просмотр и печать модели;

– измерение геометрических (без создания объектов «изменения») и массо-центровочных характеристик модели;

– создание отчетов.

Подробнее о режиме пересчета размеров модели...


Команда ЛСК

Позволяет создать в модели локальную систему координат (ЛСК).

Для вызова команды нажмите кнопку ЛСК на панели Вспомогательная геометрия или выберите ее название из меню Операции.

В окне модели появится фантом ЛСК, а на Панели свойств — элементы управления построением.

Чтобы создать ЛСК, необходимо определить положение ее начала (позиция ЛСК) и направления ее осей (ориентация ЛСК). Эти параметры задаются относительно собственной системы координат ЛСК. Собственной системой координат ЛСК является текущая или абсолютная система координат — это зависит от настройки ЛСК.

По умолчанию после вызова команды ЛСК активен способ построения Относительно СК. Чтобы построить ЛСК этим способом, выполните следующие действия.

1. Задайте позицию ЛСК. Это можно сделать следующими способами.

– Введите координаты начала ЛСК в поля на Панели свойств.

– Используя характерные точки фантома ЛСК, «перетащите» его мышью в нужное место. Для позиционирования ЛСК служат точки в виде квадратов. Точку начала ЛСК можно перемещать произвольно, а точки на концах осей — только в направлении этих осей.

– Свяжите начало координат ЛСК с точечным объектом (используются те же точечные объекты, что и при построении точки). Для этого укажите нужный объект в окне модели. О наличии ассоциативной связи ЛСК с выбранным объектом свидетельствует «галочка» на кнопке Объект. Чтобы отменить связь, нажмите кнопку Объект.

Для восстановления ассоциативной связи точки с точечным объектом необходимо указать объект повторно.

Если требуется сменить выбранный точечный объект, нажмите кнопку Указать заново на Панели специального управления и укажите нужный объект в окне модели.

2. Задайте ориентацию ЛСК. Это можно сделать следующими способами.

– Используя характерные точки фантома ЛСК, поверните его мышью. Для ориентирования ЛСК служат точки в виде кружков. Каждая точка соответствует одной из плоскостей ЛСК и позволяет вращать ЛСК вокруг оси, перпендикулярной этой плоскости.

– Свяжите ось ЛСК с прямолинейным или плоским направляющим объектом. Для этого щелкните мышью по оси фантома ЛСК, а затем — по нужному объекту (используются те же прямолинейные и плоские направляющие объекты, что и при построении точки).

Кроме того, направляющим объектом может служить вектор. В этом случае направление выбранной оси будет совпадать с направлением вектора. Чтобы создать вектор, нажмите кнопку Построение вектора на Панели специального управления (кнопка становится доступна после выбора оси).

Направление можно задать только для двух осей ЛСК, третья ось автоматически располагается так, чтобы образовывать с двумя другими правую тройку векторов.

Направляющий объект для второй оси может задавать направление, не перпендикулярное первой оси. В этом случае направление второй оси определяется как проекция направления, которое задает объект, на плоскость, перпендикулярную первой оси.

Объект не может использоваться в качестве направляющего для второй оси, если он параллелен первой оси или лежит на одной прямой с ней.

Вектор не может использоваться в качестве направляющего объекта для второй оси, если он коллинеарен первой оси. При обнаружении ошибки выдается сообщение об этом.

– При необходимости вы можете направить любую ось ЛСК в противоположную сторону. Для этого, удерживая нажатой клавишу <Ctrl>, щелкните мышью по характерной точке на конце нужной оси.

При смене направления одной из осей автоматически меняется направление оси, следующей за ней в тройке XYZ. Это необходимо для того, чтобы ЛСК оставалась правосторонней.

Построение ЛСК способом Относительно СК завершено.

Второй способ построения — По объекту. Он позволяет построить ЛСК, указав объект, который однозначно определяет ее позицию и ориентацию.
Подробнее о построении ЛСК по объекту...

Кроме способов Относительно СК и По объекту доступны дополнительные способы построения ЛСК. Эти способы предоставляют расширенные возможности определения позиции и ориентации ЛСК (в том числе путем задания углов Эйлера). Для перехода к построению ЛСК дополнительными способами нажмите кнопку Дополнительные способы на Панели специального управления.

При необходимости вы можете назначить допуски на значения параметров операции, выраженных в линейных или угловых величинах. Для этого используйте кнопку Назначить допуск, расположенную на Панели свойств рядом с полем числового параметра операции.
Подробнее о допусках...
Подробнее о назначении допуска...

Название ЛСК можно изменить на вкладке Свойства Панели свойств. Там же отображается название собственной системы координат для создаваемой ЛСК.

Задав параметры ЛСК, нажмите кнопку Создать объект на Панели специального управления.

Если в диалоге настройки ЛСК включена опция При создании ЛСК назначать ее текущей СК, то созданная ЛСК становится текущей.

Отказаться от построения ЛСК можно, нажав кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Использование ЛСК

Переменные ЛСК

Настройка ЛСК

Удаление ЛСК

Особенности задания числовых параметров операции в полях Панели свойств


Построение ЛСК способом По объекту

Для построения ЛСК по объекту необходимо указать объект, параметры которого позволяют однозначно определить позицию и ориентацию ЛСК. Такими объектами являются:

– эскиз,

– промежуточная вершина ломаной,

– точка, созданная способом На кривой,

– точка, созданная способом На поверхности или Проекция,

– дуга окружности или эллипса (кривая, контур в эскизе или ребро),

– система координат,

– тело,

– плоская грань.

После указания объекта в окне модели появляется фантом ЛСК, расположенный согласно параметрам объекта. Название объекта появляется в поле Объект.

Подробнее о построении ЛСК по объекту...


Ориентирование ЛСК способом Система углов Эйлера

При ориентировании ЛСК способом Система углов Эйлера необходимо ввести значения углов нутации и прецессии и вращения в соответствующие поля.

При необходимости вы можете направить любую из осей в противоположную сторону. Для этого, удерживая нажатой клавишу <Ctrl>, в окне модели щелкните левой кнопкой мыши по характерной точке на конце нужной оси. Положение фантома ЛСК на экране изменится, а в полях углов отобразятся значения, соответствующие новому положению.

Текущие координаты единичных векторов, сонаправленных осям ЛСК, отображаются на панели Направление осей. С помощью кнопок этой панели вы можете вернуть ЛСК исходную ориентацию, записать текущие координаты в файл или получить координаты из файла.


Ориентирование ЛСК способом Направление осей

При ориентировании ЛСК способом Направление осей вы можете задать направляющие объекты или построить векторы для осей ЛСК и при необходимости задать произвольные углы поворота ЛСК вокруг каждой из ее осей.

Чтобы задать ориентацию ЛСК, выполните следующие действия:

1. Выберите ось ЛСК, направление которой требуется задать. Для этого активизируйте переключатель Направляющий объект оси X/Y/Z или щелкните мышью по нужной оси фантома.

2. Укажите направляющий объект в окне модели (используются те же прямолинейные и плоские направляющие объекты, что и при построении точки) или постройте вектор.

Для создания вектора нажмите кнопку Построение вектора. Эта кнопка находится на Панели специального управления и становится доступна после выбора оси.

Фантом ЛСК в окне модели повернется, а название указанного объекта появится в поле рядом с выбранным переключателем. Если направление оси задано вектором, то в этом поле отобразится слово «Вектор».

Направляющий объект для второй оси может задавать направление, не перпендикулярное первой оси. В этом случае направление второй оси определяется как проекция направления, которое задает объект, на плоскость, перпендикулярную первой оси.

Объект не может использоваться в качестве направляющего для второй оси, если он параллелен первой оси или лежит на одной прямой с ней.

Вектор не может использоваться в качестве направляющего объекта для второй оси, если он коллинеарен первой оси. При обнаружении ошибки выдается сообщение об этом.

Чтобы задать углы поворота ЛСК вокруг ее осей, выполните следующие действия:

1. Выберите ось ЛСК, вокруг которой ее требуется повернуть. Для этого активизируйте переключатель Вокруг оси Х / Y / Z.

2. Введите значение угла поворота в поле Угол.
Фантом ЛСК в окне модели повернется.

Вы можете поворачивать ЛСК вокруг собственных осей мышью. Для этого «перетащите» характерную точку фантома, соответствующую плоскости, которая перпендикулярна нужной оси.

Ассоциативные связи осей ЛСК с направляющими объектами, препятствующие повороту, удаляются.

Текущие координаты единичных векторов, сонаправленных осям ЛСК, отображаются на панели Направление осей. С помощью кнопок этой панели вы можете вернуть ЛСК исходную ориентацию, записать текущие координаты в файл или получить координаты из файла.


Секущая плоскость

Кнопка, позволяющая заново указать положение секущей плоскости.


Команда Местный разрез

Управляет отображением местного разреза на его опорном виде.


Команда Упрощенное отображение

Позволяет включать и выключать режим упрощенного отображения модели.

Для вызова команды нажмите кнопку Упрощенное отображение на панели Вид или выберите название команды из меню Вид — Упрощения.


Команда Поверхность по сечениям

Позволяет создать в модели поверхность по сечениям. Поверхность по сечениям образуется путем соединения нескольких сечений. Крайнее сечение может быть точкой. Если необходимо, можно указать осевую линию — контур, задающий направление построения поверхности по сечениям.

Для создания в модели поверхности по сечениям выполните следующие действия.

1. Вызовите команду Поверхность по сечениям. Команда доступна, если в модели существует хотя бы два эскиза.

2. Задайте параметры на Панели свойств (они аналогичны параметрам операции по сечениям).

• Сечения
Активизируйте переключатель Сечения и укажите в Дереве построения или в окне модели эскизы сечений элемента.

Требования к эскизам-сечениям...
Подробнее об указании сечений элемента по сечениям...

• Осевая линия
Задается при необходимости. Активизируйте переключатель Осевая линия и укажите в Дереве построения или в окне модели осевую линию поверхности: пространственную кривую, ребро или эскиз.

Требования к осевой линии...
Подробнее об осевой линии элемента по сечениям...

• Способ построения элемента у крайних сечений
Выберите способы построения элемента из списков Начальное сечение и Конечное сечение.

Подробнее о способах построения элемента у крайних сечений...

• Траектория соединения сечений

С помощью группы переключателей Траектория укажите способ выбора соединяемых точек сечений: автоматически или вручную. Подробнее...

С помощью группы переключателей Режим укажите, требуется ли замыкать элемент по сечениям. Подробнее...

• Замыкание поверхности
Если сечения замкнуты, становится доступна опция Замкнутая поверхность. Включите ее, если требуется добавить к поверхности плоские грани, соответствующие первому и последнему сечениям.

Включение опции Замкнутая поверхность имеет смысл, если осевая линия не замкнута и в группе Режим активен переключатель Не замыкать траекторию.

Объекты, указанные для выполнения операции, подсвечиваются. Поверхность по сечениям с текущими параметрами отображается на экране в виде фантома. Фантом позволяет визуально проконтролировать правильность задания параметров.

3. При необходимости вы можете ввести наименование поверхности и настроить ее свойства. Для этого активизируйте вкладку Свойства Панели свойств.

4. Нажмите кнопку Создать объект для завершения операции.

Результат операции — новая поверхность — появляется в графической области. В Дереве модели появляется пиктограмма операции.

Если требуется прервать операцию до ее завершения, нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие команды создания поверхностей


Режим ожидания задания положения или объекта (объектов)

Система ожидает указания курсором точки в окне модели, координаты которой будут использоваться для выполнения текущей команды библиотеки, или объекта (элемента модели, поверхности, грани, ребра, вершины, вспомогательного элемента), необходимого для выполнения текущей команды библиотеки.


Режим ожидания задания положения

Система ожидает указания курсором точки в окне модели, координаты которой будут использоваться для выполнения текущей команды библиотеки.


Режим ожидания задания объекта

Система ожидает указания объекта (элемента модели, поверхности, грани, ребра, вершины, вспомогательного элемента), необходимого для выполнения текущей команды библиотеки.


Режим ожидания задания положения эскиза

Система ожидает указания нового положения эскиза для выполнения текущей команды библиотеки.


Команда Фаска

Позволяет создать фаску на указанных ребрах модели.

Пример

Команда не выполняется для ребер, образованных гладко сопряженными гранями.

Для вызова команды нажмите кнопку Фаска на инструментальной панели редактирования детали или на инструментальной панели редактирования модели. Можно также выбрать название команды из меню Операции.

Укажите в окне модели ребра, на которых требуется построить фаску. Если требуется построить фаски на всех ребрах какой-либо грани, укажите эту грань.

Выбор объектов в окне модели

В полях группы Объекты на вкладке Параметры отображаются наименования и количества объектов, указанных для выполнения операции.

Чтобы исключить какой-либо объект (ребро или грань) из числа выбранных, укажите его в окне модели повторно. Выделение с этого объекта будет снято, и при построении фаски он учитываться не будет.

После указания первого ребра в окне модели возникает фантом фаски и стрелка, направленная вдоль одной из граней. Она показывает направление первой стороны фаски.

Для изменения направления воспользуйтесь переключателем Направление первой стороны.

С помощью переключателя Способ построения на вкладке Параметры Панели свойств выберите способ построения фаски — по стороне и углу или по двум сторонам.

Если фаска строится по стороне и углу, введите в поле Длина 1 длину стороны фаски, а в поле Угол — угол между этой стороной и поверхностью фаски.

Если фаска строится по двум сторонам, введите их длины в поля Длина 1 и Длина 2.

Значения длин и угла можно задать с помощью характерных точек.

Опция Продолжать по касательным ребрам в некоторых случаях позволяет упростить указание ребер для выполнения команды.

При необходимости назначьте допуски на значения параметров операции, выраженных в линейных или угловых величинах. Для этого используйте кнопку Назначить допуск, расположенную на Панели свойств рядом с полем числового параметра операции.
Подробнее о допусках...
Подробнее о назначении допуска...

На вкладке Свойства можно настроить свойства поверхности фаски.

После задания всех параметров фаски и настройки ее свойств нажмите кнопку Создать объект на Панели специального управления.

Прервать построение фаски можно, нажав кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Не стройте фаску для каждого ребра в отдельности; если это возможно, указывайте при создании фаски как можно большее количество ребер, параметры фаски для которых одинаковы.

Однако, выполнение этого совета может быть затруднено, если фаска неравносторонняя. Если ребра, выбранные для построения такой фаски, относятся не к одной грани, то выбор единого направления фаски для всех ребер может привести к неверному результату построения. В этом случае рекомендуется указывать для построения фаски ребра, относящиеся к одной грани, и создавать отдельную фаску для каждой грани.

Смотрите также

Другие команды редактирования детали

Другие команды редактирования сборки

Особенности задания числовых параметров операции в полях Панели свойств


Команда Сечение поверхностью

Эта команда позволяет удалить часть модели, находящуюся по одну сторону пересекающей эту модель поверхности. В качестве поверхности сечения могут использоваться следующие объекты:

– координатные и вспомогательные плоскости,

– импортированные и построенные в детали поверхности,

– грани.

Пример

Плоская поверхность может быть продолжена в любую строну, поэтому она не обязательно должна располагаться так, чтобы пересекать всю деталь. Продолжение неплоской поверхности невозможно, поэтому корректное отсечение части детали такой поверхностью возможно, только если она полностью пересекает тело детали.

Для вызова команды нажмите кнопку Сечение поверхностью на инструментальной панели редактирования детали или на инструментальной панели редактирования модели.

Если перед вызовом команды была выделена поверхность, пересекающая модель, название этой поверхность появляется в поле Поверхность сечения на вкладке Параметры Панели свойств. Если поверхность не была выделена перед вызовом команды, укажите ее.

Выбор объектов в окне модели...

Выбор объектов в Дереве построения...

Вы можете удалить часть модели по любую сторону от указанной поверхности.

Чтобы изменить направление отсечения (оно показывается на фантоме в окне модели в виде стрелки), воспользуйтесь соответствующим переключателем на вкладке Параметры Панели свойств.

С помощью группы переключателей Область применения на вкладке Параметры вы можете задать область применения операции. Подробнее...

Настройка свойств поверхности отсечения...

После выбора направления отсечения и выполнения настройки нажмите кнопку Создать объект на Панели специального управления. Если в результате операции образуется тело из нескольких частей, то после выполнения операции запускается процесс изменения набора частей.

Прервать выполнение отсечения можно, нажав кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие команды редактирования детали

Другие команды редактирования сборки


Команда Сечение по эскизу

Позволяет удалить часть модели, находящуюся по одну сторону пересекающей эту модель поверхности, образованной перемещением указанного эскиза в направлении, перпендикулярном его плоскости.

Перед вызовом команды выделите эскиз, в котором изображен профиль поверхности.

Пример

Требования к эскизу поверхности отсечения:

– Объекты эскиза должны составлять один контур.

– Контур должен быть разомкнутым.

– Контур должен пересекать проекцию детали на плоскость эскиза.

Для вызова команды нажмите кнопку Сечение по эскизу на инструментальной панели редактирования детали или на инструментальной панели редактирования модели. Можно также выбрать название команды в меню Операции.

Название эскиза, по которому производится отсечение, появляется в поле Профиль сечения на вкладке Параметры Панели свойств.

Вы можете удалить часть модели по любую сторону от поверхности.

Чтобы изменить направление отсечения (оно показывается на фантоме в окне модели в виде стрелки), воспользуйтесь соответствующим переключателем на вкладке Параметры Панели свойств.

С помощью группы переключателей Область применения на вкладке Параметры вы можете задать область применения операции. Подробнее...

Настройка свойств поверхности отсечения...

После выбора направления отсечения и выполнения настройки нажмите кнопку Создать объект на Панели специального управления. Если в результате операции образуется тело из нескольких частей, то после выполнения операции запускается процесс изменения набора частей.

Прервать выполнение отсечения можно, нажав кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие команды редактирования детали

Другие команды редактирования сборки


Команда Уклон

Позволяет придать уклон плоским граням, перпендикулярным грани-основанию, или цилиндрическим граням, образующие которых перпендикулярны грани-основанию.

Пример

Для вызова команды нажмите кнопку Уклон на инструментальной панели редактирования детали или на инструментальной панели редактирования модели. Можно также выбрать название команды из меню Операции.

Укажите объекты для выполнения уклона

Введите угол уклона в соответствующее поле на вкладке Параметры Панели свойств.

Переключатель Направление позволяет выбрать направление уклона — внутрь или наружу.

Величину и направление уклона можно задать с помощью характерных точек.

Если грань, указанная для выполнения операции, гладко соединяется с другими гранями, то им автоматически придается уклон с теми же параметрами, что были заданы для выбранной грани.

Если требуется скруглить одно или несколько ребер, ограничивающих уклоняемую грань, сделайте это после придания грани уклона.

Не наклоняйте каждую грань в отдельности. Если это возможно, указывайте при выполнении команды Уклон как можно большее количество граней, которые требуется наклонить под одинаковым углом к одному и тому же основанию. В этом случае расчеты при перестроении модели будут производиться быстрее.

При необходимости назначьте допуски на значения параметров операции, выраженных в линейных или угловых величинах. Для этого используйте кнопку Назначить допуск, расположенную на Панели свойств рядом с полем числового параметра операции.
Подробнее о допусках...
Подробнее о назначении допуска...

На вкладке Свойства можно настроить свойства поверхности уклона.

Чтобы подтвердить создание уклона, нажмите кнопку Создать объект на Панели специального управления.

Прервать построение можно, нажав кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Команда не выполняется, если система обнаружит, что грани, перестроенные в соответствии с заданными параметрами уклона, не образуют тело.

Если применить команду Уклон к грани, уже наклоненной к основанию под каким-либо углом, то этот угол учитываться не будет (то есть результат будет таким, как если бы команда была применена к грани, перпендикулярной основанию).

Применение команды Уклон наиболее эффективно на завершающих этапах проектирования литых деталей, когда отдельным граням требуется придать небольшой уклон для облегчения выемки отливок из форм.

Смотрите также

Другие команды редактирования детали

Другие команды редактирования сборки

Особенности задания числовых параметров операции в полях Панели свойств


Команда Удалить грани

Позволяет удалить грань поверхности или тела.

Для вызова команды нажмите кнопку Удалить грани на инструментальной панели Поверхности или выберите ее название из меню Операции.

Укажите в окне модели подлежащие удалению грани. Они будут выделены цветом.

В поле Количество удаляемых граней на Панели свойств отображается количество выбранных граней.

Чтобы исключить какую-либо грань из числа удаляемых, укажите ее в окне модели повторно. Выделение с этой грани будет снято.

Чтобы сменить грани, нажмите кнопку Указать заново на Панели специального управления и повторите выбор граней.

Наименование объекта (название, которое отображается в Дереве построения) можно задать на вкладке Свойства.

Чтобы подтвердить выполнение операции, нажмите кнопку Создать объект на Панели специального управления.

– В Дереве построения появляется пиктограмма удаления граней.

– Если грань удалена у тела, то этот объект становится телом с нарушенной целостностью, а его пиктограмма появляется в Дереве построения. При этом модель отмечается в Дереве как ошибочная.

Пиктограммы и названия тел показываются в Дереве, если в нем включено отображение структуры модели.

Прервать удаление граней можно, нажав кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Другие команды создания поверхностей


Команда Скругление

Эта команда позволяет скруглить указанные ребра модели.

Пример

Команда не выполняется для ребер, образованных гладко сопряженными гранями.

Для вызова команды нажмите кнопку Скругление на инструментальной панели редактирования детали или на инструментальной панели редактирования модели. Можно также выбрать название команды из меню Операции.

Тип скругления можно выбрать с помощью одноименной группы переключателей. По умолчанию активен переключатель Постоянный радиус. Если необходимо построить скругление с переменным радиусом, активизируйте переключатель Переменный радиус.

Укажите в окне модели ребра, которые требуется скруглять. Если необходимо скруглить все ребра какой-либо грани, укажите эту грань.

Выбор объектов в окне модели

В полях группы Объекты отображаются наименования и количества объектов, указанных для выполнения операции.

Чтобы исключить какой-либо объект (ребро или грань) из числа выбранных, укажите его в окне модели повторно. Выделение с этого объекта будет снято, и при построении скругления он учитываться не будет.

Не выполняйте скругление для каждого ребра в отдельности. Если это возможно, указывайте при создании скругления как можно большее количество ребер, которые требуется скруглить с одинаковым радиусом.

Для скругления с постоянным радиусом выберите способ построения и задайте параметры скругления.

Для скругления с переменным радиусом задайте параметры скругления на вкладке Переменный радиус Панели свойств.

Для остановки скругления в определенном месте на ребре активизируйте вкладку Остановка скругления и задайте параметры точки остановки.

Активизируйте вкладку Параметры Панели свойств и выберите способы сглаживания и обхода углов.

Опция Продолжать по касательным ребрам в некоторых случаях позволяет упростить указание ребер для выполнения команды.

Активизируйте опцию Автоопределение, чтобы включить автоматический выбор способа построения скругления в случаях его пересечения с соседними гранями. Если во всех таких случаях необходимо сохранение кромки, выключите опцию Автоопределение и включите опцию Сохранять кромку. Эти опции доступны только при создании скругления с постоянным радиусом.

Значение радиуса скругления можно задать также с помощью характерной точки.

Если радиус скругления постоянный, то характерная точка одна, а если переменный, то минимальное количество точек равно количеству скругляемых ребер. При указании точек изменения радиуса появляются дополнительные характерные точки.

При необходимости назначьте допуски на значения параметров операции, выраженных в линейных или угловых величинах. Для этого используйте кнопку Назначить допуск, расположенную на Панели свойств рядом с полем числового параметра операции.
Подробнее о допусках...
Подробнее о назначении допуска...

На вкладке Свойства можно настроить свойства поверхности скругления.

После задания всех параметров скругления и настройки его свойств нажмите кнопку Создать объект на Панели специального управления.

Прервать построение скругления можно, нажав кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие команды редактирования детали

Другие команды редактирования сборки

Особенности задания числовых параметров операции в полях Панели свойств


Команда Отверстие из библиотеки

Позволяет создать в модели круглое отверстие со сложным профилем.

Перед вызовом команды требуется выделить плоский объект (плоскую грань, вспомогательную или конструктивную плоскость), на котором должно располагаться отверстие.

Пример

Для вызова команды нажмите кнопку Отверстие из библиотеки на инструментальной панели редактирования детали или на инструментальной панели редактирования модели.

Выбор формы отверстия и задание его размеров...

Группа переключателей Способ построения на вкладке Параметры Панели свойств позволяет выбрать способ определения глубины отверстия.

Фантом отверстия с заданными параметрами отображается в окне модели. Точка привязки отверстия по умолчанию располагается в начале локальной системы координат плоского объекта, на котором создается это отверстие.

Чтобы разместить отверстие в нужном месте плоского объекта, расфиксируйте поле т на вкладке Параметры и укажите положение отверстия мышью или введите координаты центра отверстия в поле т. Положение отверстия можно задать также с помощью характерной точки. Расфиксация поля т в этом случае не требуется.

Чтобы выбрать направление построения отверстия, активизируйте соответствующий переключатель в группе Направление.

С помощью группы переключателей Область применения на вкладке Параметры можно задать область применения операции. Подробнее...

Настройка свойств поверхности отверстия...

Чтобы подтвердить создание отверстия, нажмите кнопку Создать объект на Панели специального управления. Если в результате операции образуется тело из нескольких частей, то после выполнения операции запускается процесс изменения набора частей.

При создании отверстия в модели автоматически формируется эскиз. Он располагается на плоскости или грани, указанной для построения отверстия, и содержит вспомогательную точку со стилем «Конверт», находящуюся на оси отверстия.

Прервать построение можно, нажав кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие команды редактирования детали

Другие команды редактирования сборки


Команда Эскиз из библиотеки

Позволяет создать на выделенной плоскости или плоской грани новый эскиз, используя в качестве изображения в нем фрагмент из библиотеки.

После вызова команды на вкладке Параметры Панели свойств появляется панель выбора эскиза из библиотеки, указанной в диалоге настройки библиотек.

Библиотека эскизов представляет собой библиотеку фрагментов КОМПАС-3D (файл с расширением lfr).

Фрагмент, название которого выделено в списке, показывается в области просмотра на панели выбора эскиза.

При выделении фрагмента его фантом показывается в окне модели. По умолчанию точка начала библиотечного фрагмента совпадает с началом координат эскиза, а угол поворота фрагмента равен нулю.

Чтобы изменить расположение фрагмента, введите нужные значения в поля т и Угол на вкладке Параметры.

Вы можете задать название и цвет эскиза, используя элементы управления на вкладке Свойства Панели свойств.

Выбрав эскиз и закончив его настройку, нажмите кнопку Создать объект на Панели специального управления.

Графические объекты из библиотечного фрагмента будут скопированы в новый эскиз. Система вернется в режим работы с моделью.

Вставленный из библиотеки эскиз теряет связь со своим источником. Порядок его дальнейшего редактирования не отличается от порядка редактирования других эскизов.


Команда Вычесть компоненты

Эта команда позволяет образовать в редактируемой детали полость, имеющую форму другой детали. Обе детали должны быть вставлены в одну сборку (*.a3d).

Команда доступна в режиме редактирования детали в контексте сборки.

Для вызова команды нажмите кнопку Вычесть компоненты на инструментальной панели редактирования детали или выберите ее название в меню Операции.

Вычитание возможно, если редактируемая деталь и вычитаемые из нее детали содержат по одному телу. Для многотельных деталей вычитание невозможно.

Выберите детали, которые необходимо вычесть из редактируемой детали, указав их в окне сборки или в Дереве построения.

Выбор объектов в окне модели

Выбор объектов в Дереве построения

В операции вычитания могут участвовать только детали: вычесть из детали подсборку невозможно.

Указанные детали подсвечиваются в окне модели. Соответствующие им пиктограммы выделяются цветом в Дереве построения. Названия этих деталей отображаются в Списке компонентов на вкладке Параметры Панели свойств.

Чтобы исключить деталь из числа вычитаемых, выделите ее в Списке компонентов и нажмите кнопку Удалить. Можно также повторно указать деталь в Дереве построения или в окне модели.

Если необходимо, чтобы размеры создаваемой полости отличались от размеров вычитаемой детали, задайте коэффициент масштабирования в одноименном поле.

По умолчанию центром масштабирования полости является центр габаритного параллелепипеда вычитаемой детали. При необходимости вы можете задать центр масштабирования явно. Для этого укажите нужную точку в окне модели мышью. Чтобы отказаться от использования этой точки в качестве центра масштабирования, укажите ее заново.

Настройка свойств поверхности полости

Задав параметры вычитания, нажмите кнопку Создать объект на Панели специального управления. Если в результате операции образуется тело из нескольких частей, то после выполнения операции запускается процесс изменения набора частей.

Чтобы отказаться от вычитания, нажмите кнопку Прервать команду Панели специального управления или клавишу <Esc>.

Смотрите также

Команда Объединить компоненты


Команда Редактировать таблицу

Команда позволяет изменить параметры следующих таблиц:

– таблицы исполнений модели;

– таблицы отчета по массиву.

Находится в контекстном меню выделенной в документе ассоциативной таблицы.

При редактировании таблицы доступны все те же действия, что и при ее создании, кроме управления ассоциативностью (опция, управляющая ассоциативностью таблицы, на Панели свойств отсутствует).


Команда Ребро жесткости

Позволяет создавать в модели ребра жесткости. Ребро жесткости может быть приклеено как к телу, построенному в самой модели, так и к телу компонента. Обратите внимание на то, что грани, ограничивающие ребро, должны принадлежать одному и тому же телу.

Команда доступна, если выделен один эскиз.

Пример

Требования к эскизу ребра жесткости

Контур ребра жесткости может не доходить до тела. В этом случае система продолжит контур до пересечения с ближайшей гранью. Криволинейные контуры продолжаются по касательным к ним в крайних точках.

Для вызова команды нажмите кнопку Ребро жесткости на инструментальной панели редактирования детали или на инструментальной панели редактирования модели. Можно также выбрать название команды из меню Операции.

Группа переключателей Плоскость на вкладке Параметры Панели свойств управляет положением ребра относительно плоскости эскиза.

Направление построения ребра жесткости показано фантомной стрелкой в окне модели. Если требуется изменить автоматически выбранное направление, активизируйте другую опцию в группе Направление.

Если требуется, чтобы боковые грани ребра имели уклон, введите в поле Угол уклона значение угла. Направление уклона граней ребра жесткости — наружу, изменить его нельзя.

Кнопка Следующий позволяет указать сегмент, задающий направление уклона.

Для задания толщины ребра жесткости активизируйте вкладку Панели свойств Толщина, выберите тип построения тонкой стенки и задайте ее толщину.

Положение, направление и толщину ребра жесткости можно задать с помощью характерных точек.

Если модель содержит несколько тел, то для построения ребра жесткости необходимо указать то из них, к которому будет приклеено создаваемое ребро. Чтобы выбрать тело, укажите в окне модели любую грань, вершину или ребро этого тела, либо выделите в Дереве модели принадлежащий телу объект одного из следующих типов:

– первый формообразующий элемент,

– приклеенный формообразующий элемент,

– приклеенное листовое тело,

– приклеенная зеркальная копия тела,

– булева операция.

Выбранный объект будет подсвечен.

Удобнее всего указывать в окне модели грань (или одну из граней), к которой будет непосредственно примыкать создаваемое ребро жесткости.

Если вы случайно ошиблись при указании тела, нажмите кнопку Указать заново на Панели специального управления. Подсветка с ранее выбранного объекта будет снята, и вы сможете указать другое тело.

При необходимости назначьте допуски на значения параметров операции, выраженных в линейных или угловых величинах. Для этого используйте кнопку Назначить допуск, расположенную на Панели свойств рядом с полем числового параметра операции.
Подробнее о допусках...
Подробнее о назначении допуска...

На вкладке Свойства можно настроить свойства поверхности ребра жесткости.

Чтобы подтвердить создание ребра, нажмите кнопку Создать объект на Панели специального управления.

Прервать построение можно, нажав кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие команды редактирования детали

Другие команды редактирования сборки

Особенности задания числовых параметров операции в полях Панели свойств


Команда Оболочка

Позволяет преобразовать тело (или несколько тел) в тонкостенную оболочку (или оболочки).

Пример

При создании оболочки все указанное тело исключается из расчетов, а к его граням добавляется слой материала, образующий оболочку.

Для создания оболочки требуется исключить одну или несколько граней тела, к которым не должен добавляться материал. Эти грани превратятся в отверстие (или отверстия) в получившейся оболочке.

При работе с телом, состоящим из нескольких частей, вы можете исключить грань (или грани) только одной части. Эта часть преобразуется в оболочку с отверстием, а остальные части — в замкнутые оболочки.

Для вызова команды нажмите кнопку Оболочка на инструментальной панели редактирования детали или на инструментальной панели редактирования модели. Можно также выбрать название команды из меню Операции.

С помощью списка Тип на вкладке Тонкая стенка Панели свойств укажите направление добавления материала — наружу или внутрь относительно поверхности тела.

Введите толщину оболочки в поле Толщина стенки.

Укажите в окне модели грани тела, которые не должны участвовать в построении оболочки.

Выбор объектов в окне модели

В поле Количество удаляемых граней отображается количество выбранных граней.

Чтобы исключить какую-либо грань из числа выбранных, укажите ее в окне модели повторно. Выделение с этой грани будет снято, и при создании оболочки она удаляться не будет.

Если требуется отменить выбор всех граней, нажмите кнопку Указать заново на Панели специального управления.

При необходимости назначьте допуски на значения параметров операции, выраженных в линейных или угловых величинах. Для этого используйте кнопку Назначить допуск, расположенную на Панели свойств рядом с полем числового параметра операции.
Подробнее о допусках...
Подробнее о назначении допуска...

На вкладке Свойства можно настроить свойства поверхности оболочки.

После задания параметров оболочки и настройки ее свойств нажмите кнопку Создать объект на Панели специального управления.

Деталь перед созданием оболочки (удаляемые грани выделены) и получившаяся оболочка

Прервать построение оболочки можно, нажав кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие команды редактирования детали

Другие команды редактирования сборки

Особенности задания числовых параметров операции в полях Панели свойств


Команда Простое отверстие / Отверстие с зенковкой / Отверстие с цековкой / Отверстие с зенковкой и цековкой / Коническое отверстие

Позволяет создать в модели круглое отверстие различных типов.

Для вызова команды нажмите соответствующую ей кнопку на инструментальной панели редактирования детали или выберите название в меню Отверстие — Операции.

Простое отверстие;

Отверстие с зенковкой;

Отверстие с цековкой;

Отверстие с зенковкой и цековкой;

Коническое отверстие.

В процессе построения можно выбрать другой тип отверстия из списка Тип отверстия на Панели свойств или из контекстного меню.

На Панели свойств появляются элементы управления общие для всех типов отверстий и характерные для выбранного типа отверстия.

Чтобы построить круглое отверстие, выполните следующие действия.

1. Укажите поверхность для построения отверстия.

В процессе построения можно выбрать другую поверхность для размещения отверстия.

2. Задайте в поле Диаметр значение диаметра отверстия.

3. Задайте глубину отверстия. Выберите способ определения глубины отверстия из списка Глубина и задайте соответствующие способу параметры.
Подробнее о задании глубины отверстия...

4. Задайте дополнительные параметры, характерные для выбранного типа отверстия:

– Для отверстия с зенковкой выберите способ определения параметров из списка Способ и задайте соответствующие способу параметры.

– Для отверстия с цековкой задайте значения диаметра и глубины цековки.

– Для отверстия с цековкой и зенковкой задайте значения общего диаметра зенковки/цековки, глубину цековки и угол конуса зенковки.
Подробнее о задании параметров для отверстия с зенковкой и/или цековкой...

– Для конического отверстия выберите способ определения параметров конического отверстия из списка Способ и задайте их значения.
Подробнее о задании параметров конического отверстия...

5. При необходимости используйте следующие возможности:

– Создание резьбового отверстия. На Панели свойств выберите наименование резьбы из списка Резьба, задайте диаметр и шаг резьбы.
Подробнее о задании параметров резьбового отверстия...

– Выбор формы торца отверстия. Выберите нужный вариант из списка Форма торца.
Подробнее о выборе формы торца...

– Создание оси отверстия. Для этого включите опцию Ось.

Задание параметров размещения отверстия. Для этого служит вкладка Размещение. Подробнее...

– Назначение допусков на значения параметров операции, выраженных в линейных или угловых величинах. Для этого используйте кнопку Назначить допуск, расположенную на Панели свойств рядом с полем числового параметра операции.
Подробнее о допусках...
Подробнее о назначении допуска...

– Создание отверстия по образцу. Подробнее...

– Выбор результата операции. Для этого служит вкладка Панели свойств Результат операции. Подробнее...

– Задание области применения операции. Подробнее...

– Изменение названия отверстия и свойства его поверхности. Для этого служит вкладка Свойства. Подробнее...

6. После задания всех параметров отверстия нажмите кнопку Создать объект на Панели специального управления.

Модель с отверстием на указанной поверхности будет показана в окне, а пиктограмма, соответствующая типу выбранного отверстия, появится в Дереве построения. Если отверстие создавалось с осью и/или с резьбой, то пиктограмма вспомогательной оси и/или условного изображения резьбы отображается в Дереве построения как подчиненный объект отверстия. Рядом с условным изображением резьбы указывается обозначение резьбы (для нестандартной резьбы используется надпись Условное изображение резьбы).

Прервать построение можно, нажав кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Команда Отверстие из библиотеки


Команда Эскиз

Позволяет перейти в режим эскиза.

Для вызова команды нажмите кнопку Эскиз на панели Текущее состояние или выберите ее название из меню Операции. Кнопка Эскиз останется нажатой, а в окне модели появится значок режима эскиза. Это свидетельствует о том, что система находится в режиме эскиза.

– Если перед вызовом команды был выделен существующий эскиз, происходит переход к редактированию этого эскиза.

– Если перед вызовом команды был выделен плоский объект, создается новый эскиз, плоскость которого совпадает с плоскостью объекта.

– Если перед вызовом команды ничего не было выделено, создается новый эскиз и запускается процесс его размещения. Укажите плоский объект, при необходимости задайте положение системы координат эскиза.

Создайте или отредактируйте изображение в эскизе.

По окончании создания или редактирования эскиза следует выйти из режима эскиза, чтобы продолжить построение модели. Для этого вызовите из контекстного меню команду Эскиз, или отожмите кнопку Эскиз на панели Текущее состояние, или щелкните мышью по значку режима эскиза в окне модели.

Смотрите также

Порядок создания эскиза

Использование объектов модели при построении эскиза

Особенности использования в эскизе некоторых типов объектов


Команда Разбиение поверхности

Позволяет разбить грани тела или поверхности на несколько граней.

В качестве разбиваемой поверхности можно использовать произвольный набор граней. В качестве секущего объекта можно использовать плоскость, поверхность, кривую, лежащую на разбиваемой поверхности, или эскиз, проецирующийся на разбиваемую поверхность.

Требования к объектам...

Пример

Для вызова команды нажмите кнопку Разбиение поверхности на панели Поверхности или выберите ее название из меню Операции — Поверхность.

На Панели свойств автоматически активизируется переключатель Поверхность. Укажите разбиваемую поверхность. Если требуется разбить все грани тела или поверхности, то это тело или поверхность можно указать в Дереве построения.

Выбор объектов в окне модели

Выбор объектов в Дереве построения

Разбиваемую поверхность можно указать и перед вызовом команды.

Выбранные грани выделяются цветом.

Чтобы задать объект, по линии пересечения с которым должна быть усечена поверхность, активизируйте переключатель Секущий объект и укажите секущие объекты в окне модели или в Дереве построения.

Если требуется разбить поверхность по изопараметрической кривой, то эту кривую можно построить, не выходя из процесса разбиения. Для этого нажмите кнопку Изопараметрическая кривая на Панели специального управления.

Разбиваемая поверхность и секущие объекты подсвечиваются, а их названия появляются в полях Поверхность и Секущий объект. В окне модели отображаются фантомы ребер, которые образуются при разбиении.

Если в качестве секущего объекта указан эскиз, на Панели свойств появляется группа переключателей Направление проецирования, позволяющая задать направление перемещения эскиза для образования секущей поверхности. Активизируйте нужный переключатель: Оба направления, Прямое направление или Обратное направление. Если выбрано перемещение эскиза в прямом или обратном направлении, то это направление показывается стрелкой на фантоме в окне модели.

Чтобы отказаться от использования объекта в качестве разбиваемого или секущего, активизируйте переключатель Поверхность или Секущий объект соответственно, и укажите объект в окне модели повторно. Подсветка с объекта будет снята.

Чтобы отменить выбор всех объектов, нажмите кнопку Указать заново на Панели специального управления и повторите выбор объектов.

Наименование операции разбиения можно изменить на вкладке Свойства Панели свойств.

Чтобы завершить разбиение поверхности, нажмите кнопку Создать объект на Панели специального управления.

Выбранные грани разбиваются на несколько граней, а в Дереве построения появляется пиктограмма операции разбиения поверхности.

Если требуется прервать операцию до ее завершения, нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие команды создания поверхностей


Команда Объединить компоненты

Позволяет создать новую деталь, являющуюся объединением двух или более деталей, входящих в сборку (*.a3d).

Команда доступна в режиме редактирования детали в контексте сборки.

Объединение деталей возможно, если каждая из них содержит по одному телу. Многотельные детали объединить нельзя.

Перед вызовом команды необходимо создать новую деталь в контексте текущей сборки. Для этого нажмите кнопку Создать деталь или Создать локальную деталь на инструментальной панели Редактирование сборки.

– Если была вызвана команда Создать деталь, в появившемся на экране диалоге задайте имя файла, в который будет записана новая деталь. После сохранения файла новой детали система переходит в режим редактирования детали.

– Если была вызвана команда Создать локальную деталь, система сразу переходит в режим редактирования детали, так как локальная деталь не имеет файлового представления, а хранится непосредственно в модели, в которой создана.

Нажмите кнопку Объединить компоненты на инструментальной панели редактирования детали или выберите ее название в меню Операции.

Выберите детали, которые необходимо объединить, указав их в окне модели или в Дереве модели. Для выполнения операции необходимо, чтобы выбранные детали пересекались друг с другом или имели совпадающие грани.

Выбор объектов в окне модели

Выбор объектов в Дереве построения

В операции объединения могут участвовать только детали. Объединить деталь с подсборкой невозможно.

Указанные детали подсвечиваются в окне модели. Соответствующие им пиктограммы выделяются цветом в Дереве построения. Названия этих деталей отображаются в Списке компонентов на вкладке Параметры Панели свойств.

Чтобы исключить какую-либо деталь из числа объединяемых, выделите ее в Списке компонентов и нажмите кнопку Удалить. Можно также повторно указать деталь в Дереве модели или в окне модели.

Настройка свойств поверхности детали, полученной объединением

После выбора деталей нажмите кнопку Создать объект на Панели специального управления для создания новой детали, объединяющей указанные. Отредактируйте созданную деталь или выйдите из режима контекстного редактирования.

При необходимости вы можете скрыть или исключить из расчета детали, объединением которых является новая деталь.

Смотрите также

Команда Вычесть компоненты


Команда Текущий

Позволяет переключить выделенный вид чертежа в текущее состояние.

Если вид находится в текущем состоянии, слева от этой команды в меню стоит «галочка».

Текущий вид всегда только один. Слева от названия текущего вида в Дереве чертежа отображается буква «т» в круглых скобках.


Команда Фоновый

Позволяет переключить выделенный вид (виды) чертежа вид в фоновое состояние. Слева от названия фонового вида в Дереве чертежа отображается буква «ф» в круглых скобках.

Если вид находится в фоновом состоянии, то слева от этой команды в меню стоит «галочка».


Команда Погасить

Позволяет переключить выделенный вид (виды) чертежа в погашенное состояние (отменяет прорисовку вида на экране). Слева от названия погашенного вида в Дереве чертежа отображается буква «п» в круглых скобках.

Если вид находится в погашенном состоянии, то слева от этой команды в меню стоит «галочка».


Команда Создать макроэлемент (графический)

Команда Создать макроэлемент
(графический)

Позволяет объединить выделенные объекты активного документа в макроэлемент.

Команда доступна, если выделенные объекты принадлежат одному виду.

Невозможно включение в макроэлемент объектов ассоциативного вида, сохраняющего связь с моделью.

Для вызова команды нажмите кнопку Создать макроэлемент на инструментальной панели Вставки и макроэлементы или выберите ее название из меню Сервис.

Подробнее о создании макроэлемента...

Действия с макроэлементами...

Созданный макроэлемент можно отредактировать без его разрушения.

Смотрите также

Команда Разрушить


Команда Изменить набор частей

Позволяет отредактировать набор оставленных частей тела (тел), которые получились в результате операции.

Команду можно вызвать из контекстного меню пиктограммы операции в Дереве построения, если пиктограмма имеет признак наличия нескольких частей — восклицательный знак.

После вызова команды запускается процесс изменения набора частей тела, в котором можно указать, какие части тела необходимо оставить.

Завершив выбор оставляемых частей тела, нажмите кнопку Создать объект на Панели специального управления для выхода из процесса изменения набора частей тела.

Смотрите также

Тела, состоящие из отдельных частей


Команда Марка/позиционное обозначение на линии

Позволяет создать обозначение, используемое в проектной документации, — марка/позиционное обозначение на линии.

Для вызова команды нажмите кнопку Марка/позиционное обозначение на линии на инструментальной панели Обозначения для строительства или выберите ее название из меню Инструменты — Обозначения для строительства.

Укажите курсором линию для размещения обозначения. После того как объект подсветится, щелкните левой кнопкой мыши.

Чтобы сменить объект, нажмите кнопку Указать заново на Панели специального управления и выберите новую линию.

На экране появится фантом габаритного прямоугольника марки/позиционного обозначения.

Группа переключателей Размещение текста позволяет выбрать расположение обозначения относительно линии. В процессе построения при помощи мыши автоматически активизируется переключатель, соответствующий текущему положению фантома.

Чтобы ввести надпись в обозначение, вызовите диалог ввода текста. Для этого щелкните мышью в поле Текст на Панели свойств или вызовите команду Текст надписи... из контекстного меню.

Чтобы при вводе текста производилось автоматическое присвоение свободных номеров элементам, активизируйте переключатель Автонумерация.

Контекстное меню поля Текст содержит все марки, созданные в документе. Чтобы создать марку с уже существующим текстовым обозначением, вы можете выбрать его из этого меню. В режиме автонумерации ей будет присвоен очередной номер.

Если текст, сформированный для текущей (создаваемой) марки/позиционного обозначения, нужно использовать для остальных подобных обозначений, созданных за этот вызов команды, включите опцию Сохранять текст. При выключенной опции каждое следующее обозначение формируется без текста.

Текст надписи может служить источником ссылки другого текстового объекта, находящегося в этом документе.

Перемещая курсор, выберите размещение текста — над линией, на линии или под линией и щелкните левой кнопкой мыши.

Если указанная точка не принадлежит выбранной линии, то положение обозначения будет определяться проекцией указанной точки на линию или ее продолжение. В последнем случае линия автоматически будет продолжена на нужное расстояние выносной линией со стилем тонкая.

Продление дуг эллипсов, NURBS и кривых Безье невозможно.

Для точного позиционирования курсора воспользуйтесь привязками или меню геометрического калькулятора в поле Положение марки на вкладке Знак Панели свойств.

Пример использования марки/позиционного обозначения на линии и варианты размещения текста

Расстояния между линией и текстом задаются в диалоге параметров марки/позиционного обозначения. Настройка, сделанная в этом диалоге, распространяется на все подобные обозначения в текущем документе.

Фон под обозначением всегда очищается независимо от настроек, сделанных в диалоге параметров отображения перекрывающихся объектов.

Кнопка Копировать свойства на Панели специального управления позволяет копировать текст в текущее обозначение из уже существующей марки/позиционного обозначения (этого же или другого типа).

Вы можете создать несколько обозначений за один вызов команды Марка/позиционное обозначение на линии.

Чтобы завершить создание марок/позиционных обозначений на линии, нажмите кнопку Прервать команду на Панели специального управления.

Смотрите также

Марка/позиционное обозначение c линией-выноской

Марка/позиционное обозначение без линии-выноски

Другие обозначения для строительства


Команда Марка/позиционное обозначение без линии-выноски

Команда Марка/позиционное обозначение
без линии-выноски

Позволяет создать обозначение, используемое в проектной документации — марку/позиционное обозначение без линии-выноски.

Для вызова команды нажмите кнопку Марка/позиционное обозначение без линии-выноски на инструментальной панели Обозначения для строительства или выберите ее название из меню Инструменты — Обозначения для строительства.

После вызова команды на экране появляется фантом обозначения. Точка привязки (т) располагается в центре габаритного прямоугольника.

Введите координаты марки/позиционного обозначения на Панели свойств или укажите точку, определяющую ее положение в окне документа.

Чтобы построить повернутое обозначение, введите нужное значение угла поворота текста в поле Угол.

Чтобы ввести надпись в обозначение, вызовите диалог ввода текста. Для этого щелкните мышью в поле Текст на Панели свойств или вызовите команду Текст надписи... из контекстного меню.

Примеры использования и типы формы марки/позиционного обозначения без линии-выноски

Чтобы при вводе текста производилось автоматическое присвоение свободных номеров элементам, активизируйте переключатель Автонумерация.

Контекстное меню поля Текст содержит все марки, созданные в документе. Чтобы создать марку с уже существующим текстовым обозначением, вы можете выбрать его из этого меню. В режиме автонумерации ей будет присвоен очередной номер.

Если текст, сформированный для текущей (создаваемой) марки/позиционного обозначения, нужно использовать для остальных обозначений, созданных за этот вызов команды, включите опцию Сохранять текст. При выключенной опции каждое следующее обозначение формируется без текста.

Текст надписи может служить источником ссылки другого текстового объекта, находящегося в этом документе.

Настройте параметры марки/позиционного обозначения на вкладке Параметры Панели свойств.

Размеры формы задаются в диалоге параметров отрисовки марки/позиционного обозначения. Настройка, сделанная в этом диалоге, распространяется на все подобные обозначения в текущем документе.

Фон под обозначением всегда очищается независимо от настроек, сделанных в диалоге параметров отображения перекрывающихся объектов.

Кнопка Копировать свойства на Панели специального управления позволяет копировать текст в текущее обозначение из уже существующей марки/позиционного обозначения (этого же или другого типа).

Чтобы зафиксировать изображение, нажмите кнопку Создать объект на Панели специального управления.

Вы можете создать несколько обозначений за один вызов команды Марка/позиционное обозначение без линии-выноски. Для этого после нажатия кнопки Создать объект укажите новую точку привязки (т).

Чтобы отказаться от создания марки/позиционного обозначения с линией-выноской, нажмите кнопку Прервать команду на Панели специального управления.

Смотрите также

Марка/позиционное обозначение c линией-выноской

Марка/позиционное обозначение на линии

Другие обозначения для строительства


Команда Знак маркировки (графический документ)

Команда Знак маркировки
 (графический документ)

Позволяет создать линию-выноску для обозначения маркировки.

Для вызова команды нажмите кнопку Знак маркировки на инструментальной панели Обозначения.

Укажите начальную точку первого ответвления (первую точку нанесения маркировки).

Укажите точку т1, определяющую положение знака маркировки.

Затем укажите начальные точки остальных ответвлений.

В поле Текст на Панели свойств отображается предлагаемый системой текст для обозначения маркировки. Чтобы изменить надпись, вызовите диалог ввода надписи обозначения, щелкнув в поле Текст левой кнопкой мыши.

Кнопка Ссылка позволяет вставить в текст обозначения ссылку, например, на пункт технических требований.

С помощью списка Стрелка на вкладке Параметры Панели свойств можно выбрать тип стрелки линии-выноски. Если этот тип стрелки необходимо использовать в обозначениях маркировки до конца текущего сеанса работы, включите опцию По умолчанию.

По умолчанию при создании знака маркировки включен режим добавления ответвлений. Об этом свидетельствует нажатая кнопка Добавить ответвления на Панели специального управления. В этом режиме каждая вновь указанная точка воспринимается системой как начальная точка очередного ответвления.

В режиме редактирования характерных точек объекта можно внести изменения в конфигурацию знака. Добавление ответвлений в этом режиме невозможно. Для перехода в режим редактирования нажмите кнопку Редактировать точки на Панели специального управления.

Между режимами можно произвольно переключаться при помощи кнопок Панели специального управления или команд в контекстном меню. При выходе из одного режима автоматически включается другой.

Чтобы зафиксировать изображение, нажмите кнопку Создать объект на Панели специального управления.

Простановка обозначения маркировки

При редактировании проекционного знака маркировки часть элементов управления Панели свойств недоступна. Соответствующие параметры обозначения передаются в чертеж из модели, поэтому их ручное изменение невозможно.

Смотрите также

Добавление ответвлений

Другие обозначения


Команда Знак маркировки (документ-модель)

Команда Знак маркировки
 (документ-модель)

Позволяет создать в модели линию-выноску для обозначения маркировки. Обозначение маркировки может проставляться к грани тела или поверхности.

Пример

Для вызова команды нажмите кнопку Знак маркировки на инструментальной панели Элементы оформления.

Укажите объект, на который будет указывать первое ответвление линии-выноски. Начальной точкой первого ответвления будет точка, в которой был указан объект.

Задайте точку, определяющую положение знака маркировки.

На экране появляется фантом обозначения.

Вы можете сменить базовую плоскость обозначения с помощью списка Базовая плоскость на вкладке Знак Панели свойств.

Кроме того, вы можете сместить плоскость обозначения параллельно самой себе, используя элемент управления Положение.

В поле Текст на Панели свойств отображается предлагаемый системой текст для обозначения маркировки. Чтобы изменить надпись, вызовите диалог ввода надписи обозначения, щелкнув в поле Текст левой кнопкой мыши.

С помощью списка Стрелка на вкладке Параметры Панели свойств можно выбрать тип стрелки линии-выноски. Если этот тип стрелки необходимо использовать в обозначениях маркировки до конца текущего сеанса работы, включите опцию По умолчанию.

По умолчанию при создании обозначения маркировки включен режим добавления ответвлений. Об этом свидетельствует нажатая кнопка Добавить ответвления на Панели специального управления. В этом режиме каждая вновь указанная точка воспринимается системой как начальная точка очередного ответвления.

Подробнее о добавлении и удалении ответвлений...

В режиме редактирования характерных точек объекта можно внести изменения в конфигурацию обозначения. Добавление ответвлений в этом режиме невозможно. Для перехода в режим редактирования нажмите кнопку Редактировать точки на Панели специального управления.

Между режимами можно произвольно переключаться при помощи кнопок Панели специального управления или команд в контекстном меню. При выходе из одного режима автоматически включается другой.

Чтобы зафиксировать обозначение, нажмите кнопку Создать объект на Панели специального управления.

Пример простановки обозначения маркировки

Смотрите также

Другие элементы оформления


Размещение текста марки/позиционного обозначения на линии

Группа переключателей, позволяющая выбрать вариант размещения обозначения относительно линии. При активизации переключателя обозначение строится:

— над линией,

— на линии,

— под линией.

В процессе построения при помощи мыши переключатель, соответствующий текущему положению фантома, активизируется автоматически. Активный переключатель определяет место, где будет построено обозначение.


Угол поворота текста марки/позиционного обозначения без линии-выноски

Угол поворота текста марки/позиционного обозначения
без линии-выноски

Поле для ввода угла поворота текста марки/позиционного обозначения без линии-выноски.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Команда Кулачок – толкатель

Позволяет установить взаимосвязь между перемещениями в кулачковом механизме. Кулачок совершает вращательное движение, а толкатель — возвратно-поступательное. При этом рабочая поверхность толкателя остается в контакте с рабочей поверхностью кулачка. Команда служит для визуализации работы кулачковых механизмов и подобных им моделей.

Пример применения сопряжения

Сопряжение Кулачок – толкатель следует накладывать после размещения компонентов в модели и наложения позиционирующих сопряжений.

Контакт между объектами обеспечивается механизмом сопряжения Кулачок – толкатель. Поэтому не накладывайте на кулачок и толкатель позиционирующее сопряжение Касание — это приведет к ошибке в сопряжении Кулачок – толкатель.

Сопряжение накладывается на два компонента в модели. Конструкция механизма должна обеспечивать контакт кулачка и толкателя в пределах рабочей поверхности кулачка.

Для вызова команды нажмите кнопку Кулачок – толкатель на инструментальной панели Сопряжения или выберите ее название из меню Операции — Механические сопряжения компонентов.

Объекты, которые могут быть использованы для сопряжения Кулачок – толкатель...

При нажатой кнопке Грани кулачка укажите последовательно те грани рабочей поверхности кулачка, которые будут использованы в сопряжении. Количество граней появляется в поле Грани кулачка.

Нажмите кнопку Ось и укажите ось, вокруг которой происходит вращение кулачка. Наименование появляется в поле Ось.

Если грани рабочей поверхности кулачка гладко сопрягаются друг с другом, то при включенной опции По касательной указание одной из граней объекта влечет за собой автоматическое указание смежных с ней граней. Выбираются только те грани, которые стыкуются по отрезкам прямых, параллельных оси кулачка.

Нажмите кнопку Грань толкателя и укажите рабочую грань или вершину толкателя.

Нажмите кнопку Траектория и укажите траекторию, в направлении которой перемещается толкатель. Наименование появляется в поле Траектория.

Указанные объекты, ось и траектория подсвечиваются, а на экране появляются стрелки, показывающие направления вращения и перемещения по умолчанию. Рабочие поверхности кулачка и толкателя приходят в контакт.

Чтобы выбрать другие объекты для выполнения операции, нажмите кнопку Указать заново на Панели специального управления. Текущий выбор объектов отменяется, и вы можете указать новые.

Задав параметры сопряжения, нажмите кнопку Создать объект на Панели специального управления.

Пиктограмма созданного сопряжения появляется в Дереве построения.

За один вызов команды вы можете создать несколько сопряжений Кулачок – толкатель.

Чтобы отказаться от выполнения команды, нажмите кнопку Прервать команду Панели специального управления или клавишу <Esc>.

Один и тот же компонент может быть связан различными механическими сопряжениями с несколькими компонентами. Механические сопряжения могут накладываться, редактироваться или удаляться независимо друг от друга. После создания сопряжений можно просмотреть их работу.

Смотрите также

Другие команды наложения сопряжений


Команда Совпадение

Позволяет установить совпадение выбранных объектов.

Для вызова команды нажмите кнопку Совпадение на инструментальной панели Сопряжения или выберите ее название из меню Операции — Сопряжения компонентов.

Команда также запускается после активизации переключателя Совпадение объектов в группе Выбор сопряжения при размещении компонента в модели способом По сопряжениям.

Укажите первый и второй объекты (грани, ребра, вершины и т.д. в любой комбинации), совпадение которых вы хотите установить.

Если форма указанных объектов и уже имеющиеся сопряжения не препятствуют совпадению, произойдет перестроение модели, после которого указанные объекты (или их продолжения) будут совпадать.

Если включено автосоздание объектов, то системой будет выбрана наиболее близкая к исходной ориентация компонента.

При отключенном режиме автосоздания расположением компонентов можно управлять с помощью переключателя Ориентация.

Для некоторых пар объектов ориентация определяется однозначно, и изменить ее нельзя.

Совпадение ребер возможно только в случае, если они прямолинейные.

Если перед вызовом команды сопряжения в окне модели были выделены какие-либо объекты, сопряжение будет наложено на них.

За один вызов команды Совпадение вы можете наложить сопряжения на несколько пар объектов. Для этого, не выходя из команды, последовательно указывайте объекты, совпадение которых требуется установить.

Вы можете установить совпадение сразу нескольких объектов (т.е. расположить в одной плоскости все выбранные объекты).

Для этого после указания первого объекта нажмите кнопку Запомнить состояние на Панели специального управления и указывайте остальные объекты.

Подробнее о запоминании параметров...

Завершить команду можно, нажав кнопку Прервать команду на Панели специального управления или клавишу <Esc>.


Команда Компонент в отдельном окне

Позволяет управлять отображением Окна модели-источника при размещении компонента способом По сопряжениям. По умолчанию отображение окна включено. При этом рядом с названием команды в меню отображается «галочка». Чтобы отключить отображение окна, вызовите команду. Повторный вызов команды включит отображение.


Команда Соосность

Позволяет установить соосность выбранных объектов.

Для вызова команды нажмите кнопку Соосность на инструментальной панели Сопряжения или выберите ее название из меню Операции — Сопряжения компонентов.

Команда также запускается после активизации переключателя Соосность в группе Выбор сопряжения при размещении компонента в модели способом По сопряжениям.

Укажите первый и второй объекты (оси, конические грани и т.д.), соосность которых вы хотите установить.

Если уже имеющиеся сопряжения не препятствуют соосности указанных объектов, произойдет перестроение модели, после которого указанные объекты (или их продолжения) станут соосны.

Если включено автосоздание объектов, то системой будет выбрана наиболее близкая к исходной ориентация компонента.

При отключенном режиме автосоздания расположением компонентов можно управлять с помощью переключателя Ориентация.

Для некоторых пар объектов ориентация определяется однозначно, и изменить ее нельзя.

Если перед вызовом команды сопряжения в окне модели были выделены какие-либо объекты, сопряжение будет наложено на них.

За один вызов команды Соосность вы можете наложить сопряжения на несколько пар объектов. Для этого, не выходя из команды, последовательно указывайте объекты, соосность которых требуется установить.

Вы можете установить соосность сразу нескольких объектов (т.е. расположить на одной оси все выбранные объекты).

Для этого после указания первого объекта нажмите кнопку Запомнить состояние на Панели специального управления и указывайте остальные объекты.

Подробнее о запоминании параметров...

Завершить команду можно, нажав кнопку Прервать команду на Панели специального управления или клавишу <Esc>.


Команда Зависимое положение

Позволяет зафиксировать положение одного выбранного компонента — зависимого относительно другого выбранного компонента — базового.

Для вызова команды нажмите кнопку Зависимое положение на инструментальной панели Сопряжения или выберите ее название из меню Операции — Сопряжения компонентов.

Выберите зависимый и базовый компоненты, указав принадлежащие им объекты в Дереве построения или в окне модели.

Если включено автосоздание объектов, то после выбора компонентов автоматически создается сопряжение. Если автосоздание отключено, то необходимо подтвердить создание сопряжения кнопкой Создать объект.

Кнопка Прервать команду позволяет отказаться от создания сопряжения.

Если требуется, чтобы компоненты сопряжения были расположены друг относительно друга так же, как два других компонента модели, используйте опцию По образцу.

После включения опции на Панели свойств появляются элементы выбора зависимого и базового компонентов-образцов, взаимное расположение которых будет образцом для сопрягаемых компонентов. Положение зависимого компонента-образца рассчитывается относительно системы координат базового компонента-образца, т.е. системы координат базового и зависимого компонентов сопряжения будут располагаться друг относительно друга так же, как системы координат образцов.

Укажите зависимый и базовый компоненты-образцы. При этом зависимый компонент сопряжения переместится таким образом, чтобы занять положение в соответствии с образцом. Данное положение фиксируется относительно базового компонента сопряжения и сохраняется в случае перемещения одного из сопряженных компонентов. Если перемещается один из компонентов-образцов, то зависимый компонент сопряжения перемещается в соответствии с новым образцом положения.

При включенном автосоздании после выбора компонентов-образцов сопряжение создается автоматически. Если автосоздание отключено, требуется подтвердить создание сопряжения.


Команда Под углом

Позволяет расположить выбранные объекты под заданным углом.

Для вызова команды нажмите кнопку Под углом на инструментальной панели Сопряжения или выберите ее название из меню Операции — Сопряжения компонентов.

Команда также вызывается при активизации переключателя Под углом в группе Выбор сопряжения при размещении компонента в модели способом По сопряжениям.

Укажите тип угла сопряжения. Для этого в группе переключателей Тип угла активизируйте нужный переключатель:

– Пространственный (3D) угол,

– Плоский (2D) угол.

Для создания сопряжения данного вида могут использоваться различные объекты. В зависимости от их сочетания углом сопряжения является:

– для прямолинейных объектов — угол между скрещивающимися или пересекающимися прямыми, содержащими эти объекты,

– для прямолинейного и плоского объектов — угол между прямолинейным объектом и его проекцией на плоский объект,

– для двух плоских объектов — угол между плоскостями объектов,

– для прямолинейного объекта и поверхности вращения — угол между объектом и осью поверхности вращения,

– для плоского объекта и поверхности вращения — угол между осью поверхности вращения и ее проекцией на плоский объект,

– для двух поверхностей вращения — угол между осями вращения.

К поверхностям вращения, которые могут использоваться для создания сопряжения данного вида, относятся цилиндрические, конические и тороидальные.

Для создания сопряжения с углом типа Пространственный необходимо указать только сопрягаемые объекты, для создания сопряжения с углом типа Плоский — сопрягаемые объекты и ось, определяющую направление измерения угла сопряжения в плоскости. Подробнее о выборе оси...

Если перед вызовом команды сопряжения в окне модели были выделены какие-либо объекты, сопряжение будет наложено на них.

После указания всех необходимых объектов становится доступным поле Угол, позволяющее ввести значение угла сопряжения.

При включенной опции Ближайшее решение, значение угла сопряжения определяется автоматически и заносится в поле Угол. Использование этого значения позволяет создать сопряжение, при котором взаимное расположение компонентов совпадает с исходным или минимально отличается от него.

Вы можете изменить определенное автоматически значение угла сопряжения. После этого один из компонентов поворачивается в пространстве (для угла типа Пространственный) или в плоскости измерения угла (для угла типа Плоский) таким образом, чтобы значение угла сопряжения соответствовало заданному.

При необходимости можно задать значение угла сопряжения до указания объектов. Для этого следует отключить опцию Ближайшее решение.

Вы можете управлять расположением компонентов с помощью переключателя Ориентация. При включенной опции Ближайшее решение изменение ориентации доступно после выбора объектов.

При необходимости можно назначить допуски на значения параметров операции, выраженных в линейных или угловых величинах. Для этого следует использовать кнопку Назначить допуск, расположенную на Панели свойств рядом с полем числового параметра операции.
Подробнее о допусках...
Подробнее о назначении допуска...

Чтобы завершить команду, нажмите кнопку Создать объект на Панели специального управления.

Вы можете сопрячь несколько объектов с одним выбранным без его повторного указания. Для этого выберите объект, с которым будут сопрягаться все остальные, и нажмите кнопку Запомнить состояние на Панели специального управления. Для создания сопряжений последовательно указывайте сопрягаемые объекты, нажимая кнопку Создать объект после указания каждого из них.

Подробнее о запоминании параметров...

Смотрите также

Особенности задания числовых параметров операции в полях Панели свойств


Команда На расстоянии

Позволяет расположить выбранные объекты на заданном расстоянии.

Для вызова команды нажмите кнопку На расстоянии на инструментальной панели Сопряжения или выберите ее название из меню Операции — Сопряжения компонентов.

Команда также вызывается при активизации переключателя На расстоянии в группе Выбор сопряжения при размещении компонента в модели способом По сопряжениям.

Опция Ближайшее решение позволяет создать сопряжение, при котором взаимное расположение компонентов совпадает с исходным или минимально отличается от него. Расстояние и направление его измерения определяются автоматически, исходя из положения указанных объектов.

При включенной опции Ближайшее решение изменение ориентации, направления и расстояния доступно после выбора объектов.

Укажите первый и второй объекты (грани, ребра, вершины и т.д.).

Если перед вызовом команды сопряжения в окне модели были выделены какие-либо объекты, сопряжение будет наложено на них.

Чтобы задать точное значение расстояния, на котором должны быть расположены объекты, введите значение расстояния в соответствующее поле на Панели свойств.

Если уже имеющиеся сопряжения не препятствуют расположению указанных объектов на заданном расстоянии, произойдет перестроение модели, после которого это условие будет выполняться.

Расположением компонентов можно управлять с помощью переключателя Ориентация.

Для некоторых пар объектов ориентация определяется однозначно, и изменить ее нельзя.

При необходимости можно назначить допуски на значения параметров операции, выраженных в линейных или угловых величинах. Для этого используйте кнопку Назначить допуск, расположенную на Панели свойств рядом с полем числового параметра операции.
Подробнее о допусках...
Подробнее о назначении допуска...

Чтобы завершить команду, нажмите кнопку Создать объект на Панели специального управления.

Вы можете сопрячь несколько объектов с одним выбранным без его повторного указания. Для этого выберите объект, с которым будут сопрягаться все остальные, и нажмите кнопку Запомнить состояние на Панели специального управления. Для создания сопряжений последовательно указывайте сопрягаемые объекты, нажимая кнопку Создать объект после указания каждого из них.

Подробнее о запоминании параметров...

Смотрите также

Особенности задания числовых параметров операции в полях Панели свойств


Команда Параллельность

Позволяет установить параллельность выбранных объектов.

Для вызова команды нажмите кнопку Параллельность на инструментальной панели Сопряжения или выберите ее название из меню Операции — Сопряжения компонентов.

Команда также вызывается при активизации переключателя Параллельность в группе Выбор сопряжения при размещении компонента в модели способом По сопряжениям.

Укажите первый и второй объекты (грани, ребра и т. д.), параллельность которых требуется установить.

Если уже имеющиеся сопряжения не препятствуют параллельности указанных объектов, произойдет перестроение модели, после которого указанные объекты (или их продолжения) будут параллельны.

Если включено автосоздание объектов, то системой будет выбрана наиболее близкая к исходной ориентация компонента.

При отключенном режиме автосоздания расположением компонентов можно управлять с помощью переключателя Ориентация.

Если перед вызовом команды сопряжения в окне модели были выделены какие-либо объекты, сопряжение будет наложено на них.

За один вызов команды Параллельность можно наложить сопряжения на несколько пар объектов. Для этого, не выходя из команды, последовательно указывайте пары объектов, параллельность которых требуется установить.

Вы можете установить параллельность сразу нескольких объектов (т.е. расположить все выбранные объекты параллельно друг другу).

Для этого после указания первого объекта нажмите кнопку Запомнить состояние на Панели специального управления и указывайте остальные объекты.

Подробнее о запоминании параметров...

Завершить команду можно, нажав кнопку Прервать команду на Панели специального управления или клавишу <Esc>.


Команда Перпендикулярность

Позволяет установить выбранные объекты перпендикулярно друг другу.

Для вызова команды нажмите кнопку Перпендикулярность на инструментальной панели Сопряжения или выберите ее название из меню Операции — Сопряжения компонентов.

Команда также вызывается при активизации переключателя Перпендикулярность в группе Выбор сопряжения при размещении компонента в модели способом По сопряжениям.

Подробнее о запоминании параметров...

Укажите первый и второй объекты (грани, ребра и т. д.), перпендикулярность которых вы хотите установить.

Если уже имеющиеся сопряжения не препятствуют перпендикулярности указанных объектов, произойдет перестроение модели, после которого указанные объекты (или их продолжения) будут перпендикулярны.

Если включено автосоздание объектов, то системой будет выбрана наиболее близкая к исходной ориентация компонента.

При отключенном режиме автосоздания расположением компонентов можно управлять с помощью переключателя Ориентация.

Для некоторых пар объектов ориентация определяется однозначно, и изменить ее нельзя.

Если перед вызовом команды сопряжения в окне модели были выделены какие-либо объекты, сопряжение будет наложено на них.

За один вызов команды Перпендикулярность можно наложить сопряжения на несколько пар объектов. Для этого, не выходя из команды, последовательно указывайте пары объектов, перпендикулярность которых требуется установить.

Вы можете установить несколько объектов так, чтобы они были перпендикулярны выбранному.

Для этого сначала укажите объект, перпендикулярно которому должны располагаться другие объекты, нажмите кнопку Запомнить состояние на Панели специального управления и указывайте остальные объекты.

Завершить команду можно, нажав кнопку Прервать команду на Панели специального управления или клавишу <Esc>.


Команда Вращение – вращение

Позволяет установить взаимосвязь между вращениями двух объектов, при которой вращение одного объекта влечет за собой вращение другого объекта.

Команда служит для визуализации работы механизмов с зубчатыми, ременными, цепными, фрикционными передачами и других моделей.

Пример применения сопряжения

Сопряжение Вращение – вращение следует накладывать после размещения компонентов в модели и наложения позиционирующих сопряжений. Сопряжение накладывается на два компонента или на компонент и тело в модели, необязательно находящиеся в контакте между собой.

Для вызова команды нажмите кнопку Вращение – вращение на инструментальной панели Сопряжения или выберите ее название из меню Операции — Механические сопряжения компонентов.

Объекты, которые могут быть использованы в механических сопряжениях...

При нажатой кнопке Компонент 1 укажите первый вращающийся объект — компонент или тело в модели. Наименование объекта появляется в поле Компонент 1.

При нажатой кнопке Ось 1 укажите ось, вокруг которой вращается первый объект. Наименование появляется в поле Ось 1.

Аналогично укажите второй объект и его ось.

Если перед вызовом команды сопряжения в окне модели были выделены какие-либо объекты, то компоненты, которым они принадлежат, участвуют в сопряжении. После вызова команды в поля Компонент 1 и Компонент 2 заносятся их наименования. Вам останется указать оси.

Указанные объекты и оси подсвечиваются, а на экране появляются стрелки, показывающие направления вращения по умолчанию.

Чтобы выбрать другие объекты для выполнения операции, нажмите кнопку Указать заново на Панели специального управления. Текущий выбор объектов отменяется, и вы можете указать новые.

При необходимости измените направление перемещения одного компонента относительно другого.

Задайте соотношение перемещений в поле Соотношение. Значение вводится с клавиатуры или выбирается из раскрывающегося списка соотношений, ранее использованных в текущем сеансе работы КОМПАС-3D.

Для двух поверхностей вращения выбор всех параметров можно сделать, щелкнув мышью по этим поверхностям.

Сопряжение невозможно наложить на пару объектов, находящиеся на одной оси вращения. На рисунке такими объектами являются колеса 2 и 3.

Задав параметры сопряжения, нажмите кнопку Создать объект на Панели специального управления.

Пиктограмма созданного сопряжения появляется в Дереве построения.

За один вызов команды вы можете создать несколько сопряжений Вращение – вращение.

Чтобы завершить команду, нажмите кнопку Прервать команду Панели специального управления или клавишу <Esc>.

Один и тот же компонент может быть связан различными механическими сопряжениями с несколькими компонентами. Механические сопряжения могут накладываться, редактироваться или удаляться независимо друг от друга. После создания сопряжений можно просмотреть их работу.

Смотрите также

Другие команды наложения сопряжений


Команда Вращение – перемещение

Позволяет установить взаимосвязь между вращением одного объекта и перемещением другого. При вращении первого объекта сопряженный с ним второй объект перемещается вдоль прямолинейной траектории и наоборот — перемещение второго объекта влечет поворот первого. Команда служит для визуализации работы механизмов в зубчато-реечных передачах, передачах винт-гайка и других моделей.

Пример применения сопряжения

Сопряжение Вращение – перемещение следует накладывать после размещения компонентов в модели и наложения позиционирующих сопряжений. Сопряжение накладывается на два компонента или на компонент и тело в модели, необязательно находящиеся в контакте между собой.

Для вызова команды нажмите кнопку Вращение – перемещение на инструментальной панели Сопряжения или выберите ее название из меню Операции — Механические сопряжения компонентов.

Объекты, которые могут быть использованы в механических сопряжениях...

При нажатой кнопке Компонент 1 укажите вращающийся объект — компонент или тело в модели. Наименование объекта появляется в поле Компонент 1.

При нажатой кнопке Ось укажите ось, вокруг которой происходит вращение первого объекта. Наименование появляется в поле Ось.

При нажатой кнопке Компонент 2 укажите перемещающийся объект.

При нажатой кнопке Траектория укажите объект, в направлении которого происходит перемещение второго объекта.

Если перед вызовом команды сопряжения в окне модели были выделены какие-либо объекты, то компоненты, которым они принадлежат, участвуют в сопряжении. После вызова команды в поля Компонент 1 и Компонент 2 заносятся их наименования. Вращающимся и перемещающимся объектами являются первый и второй в порядке выделения. Вам останется указать ось и траекторию.

Указанные объекты, ось и траектория подсвечиваются, а на экране появляются стрелки, показывающие направления вращения и перемещения по умолчанию.

Чтобы выбрать другие объекты для выполнения операции, нажмите кнопку Указать заново на Панели специального управления. Текущий выбор объектов отменяется, и вы можете указать новые.

При необходимости измените направление перемещения одного компонента относительно другого.

Задайте соотношение перемещений в поле Соотношение. Значение вводится с клавиатуры или выбирается из раскрывающегося списка соотношений, ранее использованных в текущем сеансе работы КОМПАС-3D.

Задав параметры сопряжения, нажмите кнопку Создать объект на Панели специального управления.

Пиктограмма созданного сопряжения появляется в Дереве построения.

За один вызов команды вы можете создать несколько сопряжений Вращение –перемещение.

Чтобы отказаться от выполнения команды, нажмите кнопку Прервать команду Панели специального управления или клавишу <Esc>.

Один и тот же компонент может быть связан различными механическими сопряжениями с несколькими компонентами. Механические сопряжения могут накладываться, редактироваться или удаляться независимо друг от друга. После создания сопряжений можно просмотреть их работу.

Смотрите также

Другие команды наложения сопряжений


Команда Симметрия

Позволяет расположить выбранные объекты симметрично относительно указанной плоскости.

Для вызова команды нажмите кнопку Симметрия на инструментальной панели Сопряжения или выберите ее название из меню Операции — Сопряжения компонентов.

Укажите плоскость симметрии — плоскую грань, вспомогательную или координатную плоскость.

Укажите первый и второй объекты, которые требуется разместить симметрично. Такими объектами могут быть точечные объекты, плоские объекты, оси, системы координат, компоненты. Кроме того, вы можете указать цилиндрические, конические, сферические, тороидальные грани, если параметры их теоретических поверхностей совпадают, а также ребра в форме дуг или окружностей, имеющие одинаковые радиусы.

При выборе второго объекта доступны только объекты того же типа, что и первый.

Компоненты и системы координат можно выбрать только в Дереве построения модели.

Если перед вызовом команды в окне модели были выделены какие-либо объекты, сопряжение будет наложено на них.

Если среди указанных объектов есть плоскости или плоские грани, то первая из них становится плоскостью симметрии операции.

Если уже имеющиеся сопряжения не препятствуют симметрии указанных объектов, произойдет перестроение модели, после которого указанные объекты будут располагаться симметрично.

Если включено автосоздание объектов, то после указания плоскости симметрии и сопрягаемых объектов автоматически создается сопряжение. Если автосоздание отключено, вы можете задать параметры сопряжения:

– направление сопряжения,

– параметры размещения компонентов.

Чтобы завершить создание сопряжения, нажмите кнопку Создать объект.

Кнопка Прервать команду позволяет отказаться от создания сопряжения.

Вы можете создать несколько сопряжений Симметрия, объекты которых будут расположены симметрично относительно одной и той же плоскости.

Для этого после указания плоскости симметрии нажмите кнопку Запомнить состояние на Панели специального управления и указывайте объекты сопряжений.

Аналогичным образом система может «запомнить» другие параметры сопряжения.

Подробнее о запоминании параметров...


Команда Касание

Позволяет установить касание выбранных объектов.

Для вызова команды нажмите кнопку Касание на инструментальной панели Сопряжения или выберите ее название из меню Операции — Сопряжения компонентов.

Команда также вызывается при активизации переключателя Касание в группе Выбор сопряжения при размещении компонента в модели способом По сопряжениям.

Для пар объектов, имеющих единственно возможный вариант сопряжения касания

Укажите первый и второй объекты (например, прямолинейное ребро и цилиндрическую грань), касание которых вы хотите установить.

Если перед вызовом команды сопряжения в окне модели были выделены какие-либо объекты, сопряжение будет наложено на них.

В режиме автосоздания объектов (при нажатой кнопке Автосоздание на Панели специального управления) автоматически создается вариант сопряжения, наиболее близкий к исходному положению объектов.

Для пар объектов, имеющих несколько вариантов сопряжения касания (сопряжения с коническими, цилиндрическими, сферическими, тороидальными поверхностями)

Отключите режим автосоздания объектов.

Укажите первый и второй объекты (грань, ребро, поверхность), касание которых требуется установить.

Возможны следующие виды касания:

– по окружности — в случаях сопряжения с тором, круглым ребром и др.,

– по образующей — в случаях сопряжения с цилиндрической, конической поверхностями,

– в точке — в случаях сопряжения со сферической поверхностью и касания двух цилиндрических поверхностей.

После указания второго объекта автоматически определяется вид касания объектов и включается соответствующая опция — По окружности или По образующей. Обе выключенные опции означают касание в точке. Изменение состояния опций невозможно.

Исключение составляют следующие пары объектов:

– цилиндр – цилиндр (в точке, по образующей);

– конус – сфера (в точке, по окружности).

Чтобы задать вид касания для объектов этих пар, включите или выключите соответствующую опцию.

После указания элементов на экране компоненты располагаются следующим образом. В случае касания по окружности в общей плоскости оказываются совпадающие окружности. В случае касания по образующей образующие располагаются на одной прямой. В случае касания в точке объекты имеют общую точку.

В паре сфера – тор возможен особый вид касания — в точках внешней и внутренней экваториальных окружностей тора. Этот вид касания считается касанием по окружности.

Для плоской, цилиндрической, конической, незамкнутых тороидальной или сферической грани линия или точка касания может находиться на продолжении грани.

Если возможны два варианта сопряжения, то доступны переключатели группы Ориентация. Для смены ориентации нажмите переключатель Прямая ориентация или Обратная ориентация. Если существует более двух вариантов сопряжений, то вместо переключателя ориентации доступна кнопка Следующий. При нажатии кнопки отображается следующий вариант.

Чтобы отображались варианты другого вида касания для пар объектов цилиндр – цилиндр и конус – сфера, включите нужную опцию и возобновите просмотр.

После выбора варианта сопряжения подтвердите его создание.

Для некоторых пар объектов ориентация определяется однозначно, и изменить ее нельзя.

За один вызов команды Касание вы можете наложить сопряжения на несколько пар объектов. Для этого, не выходя из команды, последовательно указывайте объекты, касание которых требуется установить.

Вы можете установить несколько объектов так, чтобы все они касались выбранного объекта.

Для этого после указания объекта, которого должны касаться другие объекты, нажмите кнопку Запомнить состояние на Панели специального управления и указывайте остальные объекты.

Подробнее о запоминании параметров...

Завершить команду можно, нажав кнопку Прервать команду на Панели специального управления или клавишу <Esc>.


Команда Угол между 2 прямыми/отрезками

Позволяет измерить угол между двумя прямолинейными объектами (прямыми, отрезками, звеньями ломаной и т.п.).

Для вызова команды нажмите кнопку Угол между 2 прямыми/отрезками на инструментальной панели Измерения или выберите ее из меню Сервис — Измерить.

После этого укажите первый и второй объект, угол между которыми нужно определить.

Вы можете быстро просмотреть результаты измерения, а можете внести их в Информационное окно.

При быстром просмотре результатов измерения рядом с курсором отображается значение угла между указанными прямолинейными объектами. В Информационном окне к значению угла добавляется разница между измеренным углом и углами, равными 180° и 360°.

Управление параметрами процесса измерения производится с помощью элементов Панели свойств. Описание элементов — см. в таблице.

Не выходя из команды, вы можете определить углы между разными объектами. Последовательно указывайте нужные пары объектов. В Информационном окне будут отображаться соответствующие значения.

Если необходимо измерить угол между несколькими разными объектами и одним и тем же объектом, после его указания нажмите кнопку Запомнить состояние на Панели специального управления. Чтобы указать другой объект для измерения, нажмите кнопку Указать заново.

Подробнее о запоминании параметров...

Вы можете сохранить или распечатать результаты измерения. Для этого воспользуйтесь командами меню Информационного окна.

Для выхода из команды нажмите кнопку Прервать команду, клавишу <Esc> или закройте Информационное окно.


Биссектриса

Переключатель, управляющий отрисовкой вспомогательной прямой — биссектрисы измеряемого угла.


Команда Угол, заданный 3 точками

Позволяет измерить угол, указав три образующие его точки.

Для вызова команды нажмите кнопку Угол по 3 точкам на инструментальной панели Измерения или выберите ее из меню Сервис — Измерить.

После этого укажите вершину угла и две точки, лежащие на его сторонах.

Вы можете быстро просмотреть результаты измерения, а можете внести их в Информационное окно.

При быстром просмотре результатов измерения рядом с курсором отображается значение угла между указанными точками. В Информационном окне к значению угла добавляется разница между измеренным углом и углами, равными 180° и 360°.

Управление параметрами процесса измерения производится с помощью элементов Панели свойств. Описание элементов — см. в таблице.

Для точного позиционирования курсора при указании точек воспользуйтесь привязками или меню геометрического калькулятора в полях Первая точка и Вторая точка на Панели свойств.

Не выходя из команды, вы можете измерить несколько углов. Последовательно указывайте нужные точки. В Информационном окне будут отображаться соответствующие значения.

Если необходимо измерить несколько углов с общей вершиной, после ее указания нажмите кнопку Запомнить состояние на Панели специального управления. Чтобы указать новую вершину угла, нажмите кнопку еще раз.

Подробнее о запоминании параметров...

Вы можете сохранить или распечатать результаты измерения. Для этого воспользуйтесь командами меню Информационного окна.

Для выхода из команды нажмите кнопку Прервать команду, клавишу <Esc> или закройте Информационное окно.


Команда Площадь

Позволяет измерить площадь произвольной фигуры.

Для вызова команды нажмите кнопку Площадь на инструментальной панели Измерения или выберите ее из меню Сервис — Измерить.

После этого укажите точку внутри замкнутой области, ограниченной пересекающимися геометрическими объектами.

Система автоматически определит границы фигуры, образованной этими объектами. Измеряемая площадь выделится цветом.

Вы можете быстро просмотреть результаты измерения, а можете внести их в Информационное окно.

При быстром просмотре результатов измерения рядом с курсором отображается значение площади указанной фигуры. Это же значение отображается в Информационном окне.

Вы можете просмотреть значения площадей других фигур, подведя к ним курсор. Для внесения результатов измерений в Информационное окно последовательно щелкайте по этим фигурам мышью.

В Информационное окно добавляется список измеренных площадей. В конце списка указана сумма всех измеренных значений.

Если повторно указать уже измеренную площадь, щелкнув по ней мышью, она удаляется из списка измеренных площадей, а выделение цветом отменяется.

Используя кнопки Панели специального управления, вы можете вычислить площадь:

– Фигуры, ограниченной замкнутым контуром (окружностью, эллипсом, многоугольником и т.п.). Для этого нажмите кнопку Указать замкнутую кривую и укажите нужный контур.

– Фигуры, образованной набором геометрических объектов. Для этого нажмите кнопку Обход границы по стрелке. Система перейдет в режим обхода границы по стрелке. Сформируйте нужную фигуру. После формирования фигуры результат измерения появится в Информационном окне.

– Фигуры, границы которой не существуют в чертеже. Для этого нажмите кнопку Ручное рисование границ. Система перейдет в режим ручного рисования границ. После формирования фигуры результат измерения появится в Информационном окне.

Управление параметрами процесса измерения производится с помощью элементов Панели свойств. Описание элементов — см. в таблице.

Вы можете сохранить или распечатать результаты измерения. Для этого воспользуйтесь командами меню Информационного окна.

Для выхода из команды нажмите кнопку Прервать команду, клавишу <Esc> или закройте Информационное окно.


Команда Измерить площадь грани

Позволяет измерить площадь граней.

Для вызова команды нажмите кнопку Площадь на панели Измерения и диагностика (3D) или выберите ее название из меню Сервис — Измерить.

Задать точность отображения результатов и выбрать единицы измерения длины вы можете на вкладке Измерение на Панели свойств.

Погрешность вычисления площадей граней подчиняется настройке точности расчета МЦХ.

Подведите курсор к грани, площадь которой вы хотите измерить. Результат измерения появляется рядом с курсором.

Если полученный результат необходимо внести в Информационное окно, то щелкните по выбранной грани левой кнопкой мыши.

На экране появляется Информационное окно с результатом измерения. Указанная грань подсвечивается.

Чтобы просмотреть значения площадей других граней, подведите к ним курсор. Для внесения результатов измерений в Информационное окно последовательно щелкайте по этим граням мышью.

Выбор объектов в окне модели

Выбранные грани будут подсвечиваться. В Информационное окно добавится список измеренных площадей. В конце списка будет указана сумма всех измеренных значений.

Если какая-либо грань указана повторно, подсветка с нее снимается, а соответствующий ей результат измерения исключается из списка.

Объекты могут быть выделены до вызова команды. После вызова команды на экране появляется Информационное окно с результатами измерений.

Чтобы создать объект «измерение», нажмите кнопку Создать измерение на Панели свойств. Подробнее...

Пиктограмма созданного измерения появляется в Дереве построения.

Для завершения команды измерения нажмите кнопку Прервать команду на Панели специального управления или закройте Информационное окно.

Смотрите также

Команда Измерить расстояние и угол

Команда Измерить длину ребра

Команда Вычислить МЦХ модели

Команда Проверка пересечений


Отрисовка центра масс

Переключатель, управляющий отрисовкой центра масс фигуры, площадь которой определяется.

Стиль точки, обозначающей центр масс, можно задать с помощью списка Стиль.


Команда Отклонение поверхностей

Команда Отклонение поверхностей позволяет измерять расстояния между двумя объектами. Такими объектами могут являться координатные и вспомогательные плоскости, грани, поверхности, заплатки. Далее для обозначения объектов измерений будет применяться термин поверхность.

Для вызова команды нажмите кнопку Отклонение поверхностей на панели Измерения и диагностика (3D) или выберите ее название из меню Сервис — Измерить.

Точность представления результатов вычислений и единицы измерения длины вы можете задать, используя элементы управления вкладки Параметры на Панели свойств.

Используя переключатели группы Способ, выберите способ измерения:

– нормально к первой поверхности,

– параллельно выбранному направляющему объекту.

Поверхности могут быть выбраны как до вызова команды, так и после.

Измерения выполняются между точками первой поверхности и их проекциями на вторую поверхность в заданном направлении. Количество точек определяется пользователем, их расположение на поверхности задается автоматически. Направление измерения зависит от выбранного способа измерения.

Переключатели группы Направление позволяют выбрать направление измерения — прямое, обратное или в обоих направлениях. Направление измерения в окне модели показано фантомом. Оно должно совпадать с направлением на вторую поверхность, иначе измерение не будет выполнено.

Если направление измерения будет выбрано неправильно, при попытке выполнения команды в окне Информация появится сообщение Некорректно заданы параметры для расчета.

Поля со счетчиком Точек по U и Точек по V позволяют задать количество точек измерения по параметрам U и V. По умолчанию значения полей составляют 20. Общее количество измерений равно произведению значений полей.

Поля со счетчиком Минимумов и Максимумов позволяют задать количество первых искомых минимумов и максимумов, параметры которых отображаются в Информационном окне. По умолчанию значения полей составляют 1.

Опция Кратко позволяет выбрать количество измерений, параметры которых будут показаны в окне Информация в результате выполнения команды. Если опция включена, будут показаны только первые искомые максимумы и минимумы. Если опция выключена, будут показаны все результаты измерений.

Чтобы выполнить измерения, нажмите кнопку Создать объект на Панели свойств.

Результаты измерений отображаются в Информационном окне.

В окне модели будут показаны линии, соединяющие точки измерений первых искомых минимумов и максимумов. Линии измерений первых искомых минимумов показаны сплошными линиями, первых искомых максимумов — пунктирными.

Система будет ожидать изменения параметров команды для последующих измерений.

Кнопка Прервать команду позволяет завершить работу команды.


Отрисовка точек

Переключатель, управляющий отрисовкой точек, ограничивающих измеряемый участок кривой.

Стиль точек можно задать с помощью списка Стиль.


Отрисовка точек

Переключатель, управляющий отрисовкой точек, сформированных в процессе измерения.

Стиль точек можно задать с помощью списка Стиль.


Команда Измерить расстояние и угол

Позволяет измерить расстояние и, если возможно, угол между двумя указанными объектами. Такими объектами могут являться координатные и вспомогательные оси и плоскости, грани, ребра, вершины, пространственные кривые и точки. Объекты можно указывать в любой комбинации (например, плоскость и вершина, ребро и ось, две грани). При указании поверхности вращения измеряется расстояние до оси вращения, а при указании двух поверхностей вращения — межосевое расстояние и угол между осями.

Для вызова команды нажмите кнопку Расстояние и угол на панели Измерения и диагностика (3D) или выберите ее название из меню Сервис — Измерить.

Задать точность отображения результатов и выбрать единицы измерения длины и угла вы можете на вкладке Измерение на Панели свойств.

Щелкните мышью по первому объекту в окне модели.

Подведите курсор ко второму объекту.

Результаты вычислений отображаются рядом с курсором.

Если объекты пересекаются, параллельны или перпендикулярны, рядом с курсором появится соответствующее сообщение.

Выдаваемый системой результат измерений зависит от типов указанных объектов и их взаимного расположения.

Если результаты измерений необходимо внести в Информационное окно, то щелкните по второму объекту левой кнопкой мыши.

На экране появляются Информационное окно, фантомы измеряемых расстояний и, если указана поверхность вращения, оси вращения.

Последовательно указывайте курсором пары объектов, расстояние и угол между которыми требуется измерить.

Выбор объектов в окне модели

Выбор объектов в Дереве построения

Выбранные объекты будут подсвечиваться. В Информационное окно добавятся результаты измерений.

Объекты могут быть выделены до вызова команды. После вызова команды на экране появляется Информационное окно с результатами измерений.

Чтобы получить дополнительные сведения, выключите опцию Кратко на Панели свойств и повторите измерение.

В Информационное окно добавятся следующие данные:

– максимальное расстояние L(max), если оно имеется,

– расстояния в проекциях на оси абсолютной системы координат X, Y, Z;

– дополняющие углы до 180 и 360 градусов.

Чтобы при подведении ко второму объекту курсора на нем кроме расстояния L(min) отображалась величина L(max), выключите опцию Кратко.

Чтобы создать объект «измерение», нажмите кнопку Создать измерение на Панели свойств. Подробнее...

Пиктограмма созданного измерения появляется в Дереве построения.

Если требуется измерить расстояние и угол между одним объектом и несколькими другими, после указания первого объекта нажмите кнопку Запомнить состояние на Панели специального управления, а затем укажите другие объекты. Подробнее о запоминании параметров...

Для завершения команды измерения нажмите кнопку Прервать команду на Панели специального управления или закройте Информационное окно.

Смотрите также

Команда Измерить длину ребра

Команда Измерить площадь

Команда Вычислить МЦХ модели

Команда Проверка пересечений


Команда Расстояние между 2 кривыми

Позволяет определить расстояние между ближайшими точками выбранных кривых.

Для вызова команды нажмите кнопку Расстояние между 2 кривыми на инструментальной панели Измерения или выберите ее из меню Сервис — Измерить.

После этого укажите первую и вторую кривые, расстояние между которыми нужно определить.

Вы можете быстро просмотреть результаты измерения, а можете внести их в Информационное окно.

При быстром просмотре результатов измерения рядом с курсором отображается значение расстояния между указанными кривыми. В Информационном окне к значению расстояния добавляются некоторые справочные параметры.

Возможно измерение только ненулевых расстояний, т.е. указанные кривые не должны пересекаться.

Управление параметрами процесса измерения производится с помощью элементов Панели свойств. Описание элементов — см. в таблице.

Не выходя из команды, вы можете определить расстояния между разными кривыми. Последовательно указывайте нужные пары кривых. В Информационном окне будут отображаться соответствующие значения.

Если необходимо измерить расстояния от нескольких разных кривых до одной и той же кривой, после ее указания нажмите кнопку Запомнить состояние на Панели специального управления. Чтобы указать другую кривую для измерения, нажмите кнопку Указать заново.

Подробнее о запоминании параметров...

Вы можете сохранить или распечатать результаты измерения. Для этого воспользуйтесь командами меню Информационного окна.

Для выхода из команды нажмите кнопку Прервать команду, клавишу <Esc> или закройте Информационное окно.


Команда Расстояние между 2 точками

Позволяет определить расстояние между двумя точками.

Для вызова команды нажмите кнопку Расстояние между 2 точками на инструментальной панели Измерения или выберите ее из меню Сервис — Измерить.

После этого укажите точки, расстояние между которыми требуется определить.

Система определяет кратчайшее расстояние между указанными точками (длину соединяющего их отрезка прямой).

Вы можете быстро просмотреть результаты измерения, а можете внести их в Информационное окно.

При быстром просмотре результатов измерения рядом с курсором отображается значение расстояния между указанными точками. В Информационном окне к значению расстояния между точками добавляются значение расстояния между точками вдоль осей текущей системы координат и некоторые справочные параметры.

Управление параметрами процесса измерения производится с помощью элементов Панели свойств. Описание элементов — см. в таблице.

Для точного позиционирования курсора при указании точек воспользуйтесь привязками или меню геометрического калькулятора в полях Первая точка и Вторая точка на Панели свойств.

Не выходя из команды, вы можете определить расстояние между несколькими парами точек. Последовательно указывайте их. В Информационном окне будут отображаться соответствующие значения.

Вы можете сохранить или распечатать результаты измерения. Для этого воспользуйтесь командами меню Информационного окна.

Для выхода из команды нажмите кнопку Прервать команду, клавишу <Esc> или закройте Информационное окно.


Команда Расстояние между 2 точками на кривой

Позволяет определить длину участка кривой, ограниченного указанными точками.

Для вызова команды нажмите кнопку Расстояние между 2 точками на кривой на инструментальной панели Измерения или выберите ее из меню Сервис — Измерить.

После этого укажите кривую, вдоль которой будет измеряться расстояние, а затем — две лежащие на ней точки.

Вы можете быстро просмотреть результаты измерения, а можете внести их в Информационное окно.

При быстром просмотре результатов измерения рядом с курсором отображается значение длины участка кривой, ограниченного указанными точками. В Информационном окне к длине участка кривой добавляются некоторые справочные параметры.

Если указанные точки не принадлежит выбранной кривой, то положение границ участка будет определяться проекциями указанных точек на кривую. Для точного позиционирования курсора при указании точек воспользуйтесь привязками.

Если выбрана замкнутая кривая, требуется указать также измеряемый участок.

Управление параметрами процесса измерения производится с помощью элементов Панели свойств. Описание элементов — см. в таблице.

Не выходя из команды, вы можете определить длины нескольких участков различных кривых. Последовательно указывайте нужные кривые и точки на них. В Информационном окне будут отображаться соответствующие значения.

Если необходимо измерить несколько участков одной и той же кривой, после ее указания нажмите кнопку Запомнить состояние на Панели специального управления. Чтобы указать другую кривую для измерения, нажмите кнопку Указать заново.

Подробнее о запоминании параметров...

Вы можете сохранить или распечатать результаты измерения. Для этого воспользуйтесь командами меню Информационного окна.

Для выхода из команды нажмите кнопку Прервать команду, клавишу <Esc> или закройте Информационное окно.


Отрисовка средней точки

Переключатель, управляющий отрисовкой точки, расположенной посередине между указанными.

Стиль точки можно задать с помощью списка Стиль.


Команда Расстояние от кривой до точки

Позволяет определить расстояние между кривой и точкой.

Для вызова команды нажмите кнопку Расстояние от кривой до точки на инструментальной панели Измерения или выберите ее из меню Сервис — Измерить.

После этого укажите кривую, а затем — точку, расстояние до которой нужно определить.

Система определяет длину кратчайшего перпендикуляра, опущенного из точки на кривую.

Вы можете быстро просмотреть результаты измерения, а можете внести их в Информационное окно.

При быстром просмотре результатов измерения рядом с курсором отображается значение расстояния от кривой до указанной точки. В Информационном окне к значению расстояния добавляются некоторые справочные параметры.

Управление параметрами процесса измерения производится с помощью элементов Панели свойств. Описание элементов — см. в таблице.

Для точного позиционирования курсора при указании точки воспользуйтесь привязками или меню геометрического калькулятора в полях Первая точка и Вторая точка на Панели свойств.

Не выходя из команды, вы можете определить расстояния между разными кривыми и точками. Последовательно указывайте нужные объекты. В Информационном окне будут отображаться соответствующие значения.

Если необходимо измерить расстояния между разными точками и одной и той же кривой, после ее указания нажмите кнопку Запомнить состояние на Панели специального управления. Чтобы указать другую кривую для измерения, нажмите кнопку Указать заново.

Подробнее о запоминании параметров...

Вы можете сохранить или распечатать результаты измерения. Для этого воспользуйтесь командами меню Информационного окна.

Для выхода из команды нажмите кнопку Прервать команду, клавишу <Esc> или закройте Информационное окно.


Команда Информация об объекте

Позволяет получать информацию об объектах при работе с моделями.

Для вызова команды нажмите кнопку Информация об объекте на панели Измерения и диагностика (3D) или выберите ее название из меню Сервис.

Чтобы быстро получить информацию об объекте, подведите курсор к нему в окне модели. Рядом с курсором появляются символ объекта и базовые сведения об объекте.

Щелкните по выбранному объекту левой кнопкой мыши.

На экране появляется Информационное окно.

По умолчанию выдается краткая информация об объекте, т.е. только основные сведения. При необходимости вы можете получить также дополнительные сведения об объекте. Для этого отключите опцию Кратко на Панели свойств и укажите объект еще раз.

Объект или объекты, информацию о которых нужно получить, можно выбрать и до вызова команды.

Выбор объектов в Дереве построения

Выбор объектов в окне модели

Одни объекты можно указать только в Дереве, например, сборки, детали, элементы, эскизы, ломаные, другие — только в окне, например, ребра, грани, вершины, сегменты контура в эскизе, сегменты ломаной, третьи — и в Дереве, и в окне, например, начала координат, вспомогательные и конструктивные плоскости, точки, сплайны.

Если перед вызовом команды Информация об объекте в Дереве построения или в окне модели были выделены объекты, то Информационное окно появляется на экране сразу после вызова команды и содержит сведения об этих объектах.

Для просмотра информации о другом объекте подведите к нему курсор. При щелчке мышью на объекте сведения о нем будут добавлены в Информационное окно.

На Панели свойств можно также задать точность отображения результатов вычислений, единицы измерения длины и угла. Изменение этих параметров немедленно отражается в Информационном окне.

Для завершения команды получения информации нажмите кнопку Прервать команду на Панели специального управления или закройте Информационное окно.


Команда Проверка пересечений

Позволяет проверить, пересекаются ли указанные тела или компоненты.

Для вызова команды нажмите кнопку Проверка пересечений на панели Измерения и диагностика (3D) или выберите ее название из меню Сервис.

После вызова команды на вкладке Параметры Панели свойств появятся окна Список объектов и Обнаруженные пересечения.

Последовательно указывайте курсором объекты, которые требуется проверить на пересечение.

– Если для проверки выбраны компоненты, то будут найдены пересечения между телами, принадлежащими этим компонентам (но не между телами, принадлежащими одному компоненту). Указание компонентов производится в Дереве построения.

– Если для проверки выбраны тела, то будут найдены пересечения между ними. Указание тел возможно как в Дереве построения, так и в окне модели.

Выбор объектов в Дереве построения

Выбор объектов в окне модели

Выбранные объекты будут выделены цветом. Их названия появятся в окне Список объектов.

Вы можете изменять положение выбранных объектов в списке и удалять их из него. Для этого используйте кнопки Переместить вверх, Переместить вниз, Удалить.

Если требуется обнаружить также касающиеся объекты, включите опцию Считать касания пересечениями.

После указания объектов нажмите кнопку Проверить пересечения на Панели специального управления.

В списке Обнаруженные пересечения появляется пронумерованный перечень пересечений, содержащий названия пересекающихся (касающихся) объектов. В окне модели будет показан каркас области их пересечения и/или линия касания.

Вы можете выполнять проверку пересечений разных компонентов или тел, не выходя из диалога.

Для завершения команды проверки пересечений нажмите кнопку Прервать команду на Панели специального управления.

Для завершения команды измерения нажмите клавишу <Esc> или закройте Информационное окно.

Смотрите также

Команда Измерить расстояние и угол

Команда Измерить длину ребра

Команда Измерить площадь

Команда Вычислить МЦХ модели


Команда МЦХ модели

Позволяет выполнить расчет массо-центровочных характеристик существующей модели (детали или сборки).

Для вызова команды нажмите кнопку МЦХ модели на панели Измерения и диагностика (3D) или выберите ее название из меню Сервис.

Точность отображения результатов вычислений, единицы измерения длины и массы вы можете задать, используя элементы управления вкладки Измерение на Панели свойств.

Чтобы положение рассчитанного центра масс и осей главной центральной системы координат было показано в окне модели в виде фантома, нажмите кнопку Центр масс. Оси главной центральной системы координат обозначены J1, J2 и J3 в порядке убывания момента инерции относительно оси.

Чтобы создать точку в центре масс, включите опцию Точка на Панели свойств, а затем нажмите кнопку Центр масс. В модели будет создана точка с названием «Точка в ЦМ».

При последующем редактировании модели положение ранее созданной Точки в ЦМ не меняется. Чтобы создать новую точку, соответствующую фактическому центру масс, воспользуйтесь командой Вычислить МЦХ модели повторно.

Расчет МЦХ ведется в абсолютной системе координат модели.

Результаты вычислений отображаются в появляющемся на экране Информационном окне. По умолчанию показывается краткая информация о модели. Это следующие данные:

– площадь поверхности модели,

– объем модели,

– масса модели,

– координаты центра масс в абсолютной системе координат модели.

Чтобы получить дополнительные сведения, выключите опцию Кратко на Панели свойств. В Информационное окно добавятся следующие данные:

– осевые моменты инерции (в абсолютной, центральной и главной центральной системах координат),

– центробежные моменты инерции (в абсолютной и центральной системах координат),

– направление главных осей инерции.

Для завершения команды вычисления МЦХ нажмите кнопку Прервать команду на Панели специального управления или закройте Информационное окно.

По умолчанию в расчетах используются значения плотностей материалов тел и деталей.

Если требуется, вы можете задать следующие параметры текущей модели и ее составных частей:

– для модели в целом — плотность или массу, а при необходимости — и координаты центра масс (Подробнее...)

– для тел — плотность (Подробнее...)

– для компонентов — плотность (применяется к телам) или массу, а при необходимости — и координаты центра масс (Подробнее...)

Смотрите также

Задание точности вычислений МЦХ

Команда Измерить расстояние и угол

Команда Измерить длину ребра

Команда Измерить площадь

Команда Проверка пересечений


Режим измерения

Переключатель, позволяющий выбрать режим измерения длин и площадей.

Он появляется на Панели свойств, если масштаб текущего вида отличен от единицы.

Кнопка Без учета масштаба вида позволяет получить истинный результат измерения.

Кнопка По бумаге позволяет получить такой же результат, как и при измерении на распечатанном в натуральную величину документе.

Таким образом, значения линейных величин, измеренные «по бумаге», получаются из истинных значений делением на коэффициент масштабирования, а значения площадей — на квадрат коэффициента.


Команда Измерить длину ребра

Позволяет измерить длину пространственной кривой (или ее сегмента), ребра, линии эскиза или периметр грани.

Для вызова команды нажмите кнопку Длина ребра на панели Измерения и диагностика (3D) или выберите ее название из меню Сервис — Измерить.

Задать точность отображения результатов и выбрать единицы измерения длины вы можете на вкладке Измерение Панели свойств.

Подведите курсор к объекту, длину которого вы хотите измерить. Результат измерения появляется рядом с курсором.

Если полученный результат необходимо внести в Информационное окно, то щелкните по выбранному объекту левой кнопкой мыши.

Чтобы просмотреть значения длин других объектов, подведите к ним курсор. Для внесения результатов измерений в Информационное окно последовательно щелкайте по этим объектам мышью.

Выбранные объекты будут подсвечиваться. В Информационное окно добавится список измеренных длин. В конце списка будет указана сумма всех полученных значений.

Чтобы измерить длину ломаной или контура, укажите этот объект в Дереве построения.

Если требуется измерить периметр грани, укажите эту грань сразу после вызова команды. В этом случае сумма измеренных значений будет соответствовать ее периметру.

Выбор объектов в окне модели

Выбор объектов в Дереве построения

Если какой-либо объект указан повторно, подсветка с него снимается, а соответствующие ему результаты измерения исключаются из списка и из суммы значений.

Объекты могут быть выделены до вызова команды. После вызова команды на экране появляется Информационное окно с результатами измерений.

Чтобы создать объект «измерение», нажмите кнопку Создать измерение на Панели свойств. Подробнее...

Пиктограмма созданного измерения появляется в Дереве построения.

Для завершения команды измерения нажмите кнопку Прервать команду на Панели специального управления или закройте Информационное окно.

Смотрите также

Команда Измерить расстояние и угол

Команда Измерить площадь

Команда Вычислить МЦХ модели

Команда Проверка пересечений


Команда Координаты точки

Позволяет определить положение указанной точки в текущей системе координат.

Для вызова команды нажмите кнопку Координаты точки на инструментальной панели Измерения или выберите ее из меню Сервис — Измерить.

После этого укажите точку, положение которой требуется определить.

Вы можете быстро просмотреть результаты измерения, а можете внести их в Информационное окно.

При быстром просмотре рядом с курсором отображаются координаты точки в текущей системе координат. В Информационном окне появляются значения, характеризующие положение указанной точки: координаты по осям Х и Y, длина и угол наклона радиус-вектора.

Управление параметрами процесса измерения производится с помощью элементов Панели свойств. Описание элементов — см. в таблице.

Для точного позиционирования курсора при указании точки воспользуйтесь привязками или меню геометрического калькулятора в поле Координаты точки на Панели свойств.

Не выходя из команды, вы можете определить положение произвольного количества точек. Последовательно указывайте их. В Информационном окне будут отображаться соответствующие значения.

Вы можете сохранить или распечатать результаты измерения. Для этого воспользуйтесь командами меню Информационного окна.

Для выхода из команды нажмите кнопку Прервать команду, клавишу <Esc> или закройте Информационное окно.


Отрисовка точки

Переключатель, управляющий отрисовкой точки, положение которой определяется.

Стиль точки можно задать с помощью списка Стиль.


Кнопка Вид по нормали к плоскости сечения

Находится на Панели специального управления.

Позволяет установить такую ориентацию модели, при которой плоскость сечения параллельна плоскости экрана. Использование кнопки возможно при задании параметров шага отсечения способом Свободное размещение, Смещенная плоскость или Повернутая плоскость.

Для способов Смещенная плоскость и Повернутая плоскость команда становится доступной после выбора базовых объектов.

Для установки вида по нормали к плоскости сечения можно также вызвать команду Нормально к из контекстного меню в окне модели.


Настройка параметров зеркального отражения компонентов

Вы можете настроить параметры отражения компонентов, создаваемых зеркальным отражением, или компонентов создаваемого зеркального исполнения. Для этого используется диалог Параметры зеркального отражения компонентов.

Кнопки, расположенные на Панели специального управления, позволяют соответственно завершить — Создать объект или прервать — Прервать команду процесс зеркального отражения компонентов/создания зеркального исполнения.


Видимость компонентов

При работе в диалоге Параметры зеркального отражения компонентов вы можете управлять видимостью фантомов компонентов, создаваемых зеркальным отражением и симметричной вставкой.

По умолчанию фантомы всех компонентов являются видимыми (в столбце Видимость фантома отображается соответствующая пиктограмма).

Чтобы скрыть фантом компонента, выделите его в диалоге и вызовите из контекстного меню команду Скрыть фантом.

Пиктограмма в соответствующей ячейке столбца Видимость фантома изменится. Фантом компонента перестанет отображаться в окне модели.

Чтобы компонент снова стал видимым, вызовите из его контекстного меню команду Показать фантом.

Данные команды можно вызвать сразу для нескольких компонентов, выбранных в диалоге.

При необходимости вы можете управлять видимостью фантомов, щелкая мышью в ячейках столбца Видимость фантома.


Команда Расчет МЦХ плоских фигур

Позволяет рассчитать МЦХ плоской фигуры произвольной формы.

Для вызова команды нажмите кнопку Расчет МЦХ плоских фигур на инструментальной панели Измерения или выберите ее из меню Сервис — МЦХ.

Последовательно указывайте курсором замкнутые контуры (эллипсы, окружности, сплайны и т.п.), ограничивающие фигуру для расчета.

Если в качестве границы требуется указать контур, образованный набором геометрических объектов или их частей, нажмите кнопку Обход границы по стрелке на Панели специального управления. Система перейдет в режим обхода границы по стрелке. Сформируйте нужную фигуру.

Если границы фигуры, МЦХ которой требуется вычислить, не существуют в чертеже, вы можете сформировать временную ломаную линию. Для этого нажмите кнопку Ручное рисование границ на Панели специального управления. Система перейдет в режим ручного рисования границ. Сформируйте нужную фигуру.

В диалоге, появляющемся после задания каждого контура, требуется указать, тело или отверстие ограничивает этот контур.

Указанные контуры выделяются цветом, а в Информационном окне появляются массо-центровочные характеристики фигуры, ограниченной выбранными контурами.

Чтобы исключить из границ фигуры какой-либо контур, укажите его повторно. Значения в Информационном окне будут пересчитаны в соответствии с получившимися границами.

Управление параметрами процесса измерения производится с помощью элементов Панели свойств. Описание элементов — см. в таблице.

Вы можете сохранить или распечатать результаты измерения. Для этого воспользуйтесь командами меню Информационного окна.

До тех пор, пока выполнение команды не закончится, каждый новый контур добавляется к уже выбранным, и расчет производится для сложной фигуры, состоящей из всех указанных контуров. Поэтому для начала нового расчета необходимо прервать выполнение команды и вызвать ее вновь.

Для выхода из команды нажмите кнопку Прервать команду, клавишу <Esc> или закройте Информационное окно.


Команда Расчет МЦХ тел выдавливания

Позволяет рассчитать МЦХ тела выдавливания произвольного сечения.

Для вызова команды нажмите кнопку Расчет МЦХ тел выдавливания на инструментальной панели Измерения или выберите ее из меню Сервис — МЦХ.

Правила указания сечения тела выдавливания:

– Сечение тела выдавливания лежит в плоскости XOY (в плоскости чертежа).

– Выдавливание сечения происходит в направлении оси Z.

Последовательно указывайте курсором замкнутые контуры (эллипсы, окружности, сплайны и т.п.), ограничивающие сечение тела.

Если в качестве границы сечения требуется указать контур, образованный набором геометрических объектов или их частей, нажмите кнопку Обход границы по стрелке на Панели специального управления. Система перейдет в режим обхода границы по стрелке. Сформируйте нужную фигуру.

Если границы сечения не существуют в чертеже, вы можете сформировать временную ломаную линию. Для этого нажмите кнопку Ручное рисование границ на Панели специального управления. Система перейдет в режим ручного рисования границ. Сформируйте нужную фигуру.

В диалоге, появляющемся после выбора каждого контура, требуется указать, тело или отверстие ограничивает этот контур, задать плотность материала и толщину тела.

Указанные контуры выделяются цветом, а в Информационном окне появляются массо-центровочные характеристики тела выдавливания, сечение которого ограничено выбранными контурами.

Чтобы исключить из границ сечения какой-либо контур, укажите его повторно. Значения в Информационном окне будут пересчитаны в соответствии с получившимися границами.

Управление параметрами процесса измерения производится с помощью элементов Панели свойств. Описание элементов — см. в таблице.

Вы можете сохранить или распечатать результаты измерения. Для этого воспользуйтесь командами меню Информационного окна.

До тех пор, пока выполнение команды не закончится, каждый новый контур добавляется к уже выбранным, и расчет производится для сложного тела. Поэтому для начала нового расчета необходимо прервать выполнение команды и вызвать ее вновь.

Для выхода из команды нажмите кнопку Прервать команду, клавишу <Esc> или закройте Информационное окно.


Команда Расчет МЦХ тел вращения

Позволяет рассчитать МЦХ тела вращения произвольного сечения.

Для вызова команды нажмите кнопку Расчет МЦХ тел вращения на инструментальной панели Измерения или выберите ее из меню Сервис — МЦХ.

Правила указания сечения и оси тела вращения:

– Образующее сечение тела вращения задается контуром, его ограничивающим.

– Образующее сечение лежит в плоскости XOY (в плоскости чертежа) с одной стороны от оси X.

– Вращение сечения происходит относительно оси X.

– Для тел вращения угол раствора дуги вращения равен 360°. Для сегментов тел вращения угол раствора дуги вращения меньше 360°.

Последовательно указывайте курсором замкнутые контуры (эллипсы, окружности, сплайны и т.п.), ограничивающие сечение тела.

Если в качестве границы сечения требуется указать контур, образованный набором геометрических объектов или их частей, нажмите кнопку Обход границы по стрелке на Панели специального управления. Система перейдет в режим обхода границы по стрелке. Сформируйте нужную фигуру.

Если границы сечения не существуют в чертеже, вы можете сформировать временную ломаную линию. Для этого нажмите кнопку Ручное рисование границ на Панели специального управления. Система перейдет в режим ручного рисования границ. Сформируйте нужную фигуру.

В диалоге, появляющемся после выбора каждого контура, требуется указать, тело или отверстие ограничивает этот контур, задать плотность материала и угол раствора дуги вращения.

Указанные контуры выделяются цветом, а в Информационном окне появляются массо-центровочные характеристики тела вращения, сечение которого ограничено выбранными контурами.

Чтобы исключить из границ сечения какой-либо контур, укажите его повторно. Значения в Информационном окне будут пересчитаны в соответствии с получившимися границами.

Управление параметрами процесса измерения производится с помощью элементов Панели свойств. Описание элементов — см. в таблице.

Вы можете сохранить или распечатать результаты измерения. Для этого воспользуйтесь командами меню Информационного окна.

До тех пор, пока выполнение команды не закончится, каждый новый контур добавляется к уже выбранным, и расчет производится для сложного тела. Поэтому для начала нового расчета необходимо прервать выполнение команды и вызвать ее вновь.

Для выхода из команды нажмите кнопку Прервать команду, клавишу <Esc> или закройте Информационное окно.


Центр масс

Кнопка, позволяющая включить отрисовку центра масс фигуры, расчет МЦХ которой производится.

Стиль точки, обозначающей центр масс, можно задать с помощью списка Стиль.


Форма

Группа переключателей, позволяющая выбрать форму верхней полки выносной надписи.

Тип 1. Верхняя полка отображается с дополнительным вертикальным сегментом.

Тип 2. Верхняя полка отображается без дополнительного сегмента.


Выравнивание

Группа переключателей, позволяющая выбрать способ определения длины полок выносной надписи.

Полки одинаковой длины. Все полки имеют одинаковую длину, равную длине наиболее протяженной полки. Ее длина складывается из длины строки текста на ней и величин отступов.

Полки по длине текста. Полки могут иметь различную длину. Длина каждой полки складывается из длины строки текста на ней и величин отступов.

Величины отступов задаются в диалоге настройки отрисовки выносной надписи.


Направление полок

Группа переключателей, позволяющая выбрать направление полок выносной надписи.

Полки вправо

Полки влево

Расстояние от начала полки до текста и выход полки за текст задаются в диалоге настройки отрисовки выносной надписи.


Текст вверх/вниз

Группа переключателей, позволяющая выбрать расположение полок с текстом относительно точки т1.

Текст вниз. С точкой т1 совмещается начало верхней полки.

Текст вверх. С точкой т1 совмещается начало нижней полки.

При переключении направления текста порядок следования полок не изменяется.


Команда Добавить сегменты

Позволяет перейти в режим добавления сегментов в базовую линию и задать параметры мультилинии.

Подробнее о параметрах мультилинии рассказано в разделах:

– Линии мультилинии

– Способы обхода угла в вершине

– Ограничители мультилинии


Команда Редактировать элементы

Позволяет перейти в режим редактирования элементов базовой линии: редактировать вершину базовой линии, вставлять новую вершину и изменять параметры мультилинии.

Подробнее о параметрах мультилинии рассказано в разделах:

– Линии мультилинии

– Способы обхода угла в вершине

– Ограничители мультилинии


Выбор способа отражения компонентов

Способ отражения компонентов выбирается с помощью группы Способ:, расположенной на инструментальной панели диалога Параметры зеркального отражения компонентов.

По умолчанию для всех компонентов используется способ Зеркальное отражение компонента. При этом доступна группа Результат:, позволяющая выбрать результат выполнения операции.

Вы можете выбрать другой способ отражения для любого из компонентов — Симметричное расположение компонента. Для этого укажите нужный компонент или несколько компонентов и нажмите одноименную кнопку инструментальной панели. Для компонентов, добавляемых этим способом, доступна группа Положение:, позволяющая настроить положение компонента.

Если для компонента выбран способ Симметричное расположение компонента, то все компоненты, входящие в него, также размещаются данным способом. Эти компоненты перестают отображаться в диалоге.

При выборе способа Зеркальное отражение компонента отображение компонентов в таблице зависит от особенностей выбора результата зеркального отражения.

Пиктограмма выбранного способа отражения показывается в соответствующей компоненту ячейке столбца Способ вставки. Щелчок мышью в данной ячейке позволяет раскрыть список вариантов отражения и, при необходимости, выбрать другой вариант.


Команда Деформация сдвигом

Позволяет выполнить деформацию сдвигом объектов чертежа или фрагмента.

Для вызова команды нажмите кнопку Деформация сдвигом на инструментальной панели Редактирование или выберите ее название из меню Редактор.

Укажите объекты для деформации

Укажите базовую точку для сдвига т1, а затем точку т2, определяющую ее новое положение.

Если значения перемещений в направлениях осей текущей системы координат известны, то для выполнения деформации вы можете ввести их в соответствующие поля на Панели свойств. Точки т1 и т2 при этом указывать не нужно.

Исходное изображение и изображение после деформации сдвигом

Правила деформации объектов сдвигом:

– элементы, полностью попавшие в рамку выделения, просто сдвигаются на заданное расстояние,

– элементы, частично попавшие в рамку выделения, редактируются таким образом, чтобы их характерные точки, попавшие в рамку выделения, переместились на заданное расстояние, а характерные точки, не попавшие в рамку выделения, остались на прежнем месте,

– элементы, не попавшие в рамку выделения, не редактируются.

За один вызов команды вы можете отредактировать несколько объектов чертежа.

Для завершения команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие команды редактирования


Кнопка Передвинуть вниз/вверх

Позволяет переместить выделенную строку списка объектов на одну позицию вниз или вверх. Кнопка доступна, если строку можно переместить в указанном направлении.

При перемещении строки она занимает положение соседней строки и получает содержащийся в ней номер, т.е. строки меняются местами и номерами друг с другом.

Вы можете переместить как строку, содержащую объект, так и строку со свободным номером. Если строка со свободным номером попадает на последнюю позицию в списке, то она автоматически удаляется.

Подробнее о перемещении объекта в списке...

Смотрите также

Автоматическая нумерация объектов


Команда Перенести в компоновочную геометрию

Позволяет создать компоновочную геометрию из компонента, имеющегося в модели.

Команда вызывается из меню Редактор. Она доступна, если в модели выделен компонент.

После вызова команды выбранный компонент преобразуется в компоновочную геометрию и приобретает ее свойства. Пиктограмма компонента переносится из раздела Компоненты Дерева построения в раздел Компоновочная геометрия.

Положение объектов компонента в окне модели не изменяется. Однако, если абсолютная система координат компонента не совпадает ни с одной из систем координат модели, то в модели будет создана совпадающая с ней локальная система координат.

При необходимости вы можете преобразовать в компоновочную геометрию сразу несколько компонентов модели. Для этого перед вызовом команды выделите все нужные компоненты.

Смотрите также

Преобразование компонента в компоновочную геометрию


Команда Сдвинуть

Позволяет сдвинуть изображение в активном окне.

Для вызова команды нажмите кнопку Сдвинуть на панели Вид или выберите ее название из меню Вид.

После этого форма курсора изменится: он превратится в четырехстороннюю стрелку.

Удерживая кнопку мыши нажатой, перемещайте курсор. Вслед за движением курсора будет прокручиваться рабочее поле документа. Если достигнут край экрана и необходимо продвинуть рабочее поле еще дальше, отпустите кнопку мыши, переместите курсор в нужное положение, а затем вновь нажмите левую кнопку мыши и продолжайте прокрутку рабочего поля.

Можно сказать, что с помощью описанного способа сдвига изображения можно увеличить размер поля чертежа. Такой прием удобно использовать в тех случаях, когда не хватает диапазона действия линеек прокрутки.

Если вы пользуетесь трехкнопочной мышью или мышью с колесом, то для сдвига изображения в графическом, текстовом документе и документе-спецификации можно перемещать мышь с нажатой средней кнопкой (колесом). Для сдвига изображения в документе-модели следует дополнительно удерживать нажатой клавишу <Shift>.

Смотрите также

Управление масштабом отображения документа в окне


Команда Показать лист

Кнопка Показать лист позволяет показать текущий лист полностью. При этом масштаб отображения изменятся так, чтобы текущий лист полностью умещался в окне чертежа, а положение текущего листа изменяется так, чтобы его центр совпадал с центром окна чертежа.

Поле Список листов позволяет выбрать текущий лист. Разверните список и укажите в нем номер нужного листа. Лист с выбранным номером будет показан на экране без изменения масштаба.


Команда Первый лист

Позволяет сделать текущим первый лист документа. Масштаб отображения при этом не изменяется. Кнопка недоступна, если первый лист является текущим.


Команда Последний лист

Позволяет сделать текущим последний лист документа. Масштаб отображения при этом не изменяется. Кнопка недоступна, если последний лист является текущим.


Команда Последующий лист

Позволяет сделать текущим лист, следующий за листом, который является текущим в данный момент. Масштаб отображения при этом не изменяется. Кнопка недоступна, если последний лист является текущим.


Команда Предыдущий лист

Позволяет сделать текущим лист, предшествующий листу, который является текущим в данный момент. Масштаб отображения при этом не изменяется. Кнопка недоступна, если первый лист является текущим.


Команда Мультилиния

Позволяет создать в графическом документе мультилинию — геометрический объект, состоящий из одной или нескольких линий, построенных эквидистантно к базовой линии.

Мультилиния используется для изображения трубопроводов, стен, перегородок, ограждений и других протяженных объектов со сложным контуром из нескольких линий.

Не рекомендуется изображать одной мультилинией несколько объектов (например, группу параллельных трубопроводов).

Пример использования мультилиний...

Для вызова команды нажмите кнопку Мультилиния на инструментальной панели Геометрия.

По умолчанию включен режим добавления сегментов в мультилинию — нажата кнопка Добавить сегменты.

Задайте параметры мультилинии: количество, смещение и стили линий. Это можно сделать следующими способами:

– задать параметры линий на Панели свойств,

– получить параметры из шаблона мультилинии,

– скопировать параметры ранее построенной мультилинии.

Максимальное количество линий в мультилинии — 64.

Добавьте сегменты базовой линии и выберите способы обхода угла в вершинах.

В окне документа отображается фантом создаваемой мультилинии.

Вы можете непосредственно в процессе построения мультилинии отредактировать конфигурацию базовой линии (изменить положение вершины и способ обхода угла в ней, а также добавить или удалить вершину). Все сделанные изменения немедленно отражаются на фантоме мультилинии.

Группа переключателей Режим построения позволяет указать, требуется замыкать мультилинию или нет. Мультилиния замыкается прямолинейным сегментом.

Мультилинию, состоящую из одного прямолинейного или сплайнового сегмента, замкнуть нельзя.

Для незамкнутой мультилинии вы можете выбрать вид ограничителей и задать их параметры.

Чтобы завершить построение мультилинии, нажмите кнопку Создать объект на Панели специального управления.

Для выхода из команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Настройка параметров мультилинии

Особенности редактирования мультилинии

Другие геометрические объекты


Команда Выносная надпись

Позволяет создать выносную надпись — обозначение, используемое в строительной документации для надписей к многослойным конструкциям.

Для вызова команды нажмите кнопку Выносная надпись на инструментальной панели Обозначения для строительства или выберите ее название из меню Инструменты — Обозначения для строительства.

Укажите начальную точку первого ответвления выносной надписи (т).

Укажите точку начала полки т1.

Затем укажите начальные точки остальных ответвлений. Их количество не ограничено.

Чтобы ввести текст выносной надписи, вызовите диалог ввода текста. Для этого щелкните мышью в поле Текст на Панели свойств или вызовите команду Текст надписи... из контекстного меню.

Текст выносной надписи может содержать ссылку на другой объект и может являться источником ссылки.

Настройте параметры выносной надписи на вкладке Параметры Панели свойств.

Пример выносной надписи

По умолчанию при создании выносной надписи включен режим добавления ответвлений. Об этом свидетельствует нажатая кнопка Добавить ответвления на Панели специального управления. В этом режиме каждая вновь указанная точка воспринимается системой как начальная точка очередного ответвления.

В режиме редактирования характерных точек объекта можно внести изменения в конфигурацию обозначения. Добавление ответвлений в этом режиме невозможно. Для перехода в режим редактирования нажмите кнопку Редактировать точки на Панели специального управления.

Между режимами можно произвольно переключаться при помощи кнопок Панели специального управления или команд в контекстном меню. При выходе из одного режима автоматически включается другой.

Чтобы зафиксировать изображение, нажмите кнопку Создать объект на Панели специального управления.

Вы можете создать несколько обозначений за один вызов команды Выносная надпись. Для этого после нажатия кнопки Создать объект укажите новые точки т и т1.

Чтобы отказаться от создания выносной надписи, нажмите кнопку Прервать команду на Панели специального управления.

Смотрите также

Добавление ответвлений

Другие обозначения для строительства


Направление копирования

Переключатель, позволяющий указать направление копирования по окружности: по часовой стрелке или против часовой стрелки.

Переключатель доступен, если выбран режим копирования С заданным шагом.


Расположение копий

Переключатель, позволяющий выбрать режим копирования: равномерно по окружности или с заданным угловым шагом.


Интерпретация значения шага

Переключатель, управляющий интерпретацией значения шага копий вдоль кривой.


Ориентация копий

Переключатель, позволяющий указать, требуется ли доворот копий до нормали к кривой.


Направление копирования

Переключатель, позволяющий указать направление копирования по кривой.


Интерпретация значения шага вдоль первой оси

Переключатель, управляющий интерпретацией значения шага вдоль первой оси.


Интерпретация значения шага вдоль второй оси

Переключатель, управляющий интерпретацией значения шага вдоль второй оси.


Копии в углах сетки

Переключатель, позволяющий указать, требуется ли оставлять копии в углах сетки.


Копии внутри сетки

Переключатель, позволяющий указать, требуется ли оставлять копии внутри сетки.


Копия в центре

Переключатель, позволяющий указать, требуется ли создать копию, базовая точка которой совпадала бы с центром сетки.


Ориентация копий

Переключатель, позволяющий указать, требуется ли доворот копий до радиального направления.


Интерпретация значения шага в кольцевом направлении

Переключатель, управляющий интерпретацией значения шага в кольцевом направлении.


Интерпретация значения шага в радиальном направлении

Переключатель, управляющий интерпретацией значения шага в радиальном направлении.


Управление атрибутами

Переключатель, позволяющий указать, требуется создание у объектов-копий таких же атрибутов, как и у объекта-оригинала.

Переключатель доступен, если хотя бы один из копируемых объектов имеет атрибуты.

Подробнее...


Управление свойствами

Переключатель, позволяющий указать, требуется ли создание у объектов-копий таких же свойств, как и у объекта-оригинала.

Переключатель доступен, если хотя бы один из копируемых объектов имеет свойства, значения которых заданы пользователем.

Управление копированием распространяется на следующие объекты:

– в графических документах — макроэлементы, вставки видов и фрагментов;

– в документе-модели — компоненты и тела.

Подробнее...


Поле Наименование

Поле для ввода наименования объекта (компонента модели, формообразующего элемента, конструктивной плоскости, оси и т.д.).

Это наименование отображается около пиктограммы объекта в Дереве построения.


Поле Объект

Содержит название объекта (эскиза или операции), размеры которого представлены в виде элементов оформления.

Смотрите также

Производные размеры


Поле Параметр

Содержит название размера эскиза или параметра операции, представленного в виде элемента оформления.

Смотрите также

Производные размеры


Команда Неразрывный дефис

Позволяет вставить в текст неразрывный дефис. Для вызова команды выберите ее название из меню Вставка — Символ форматирования.


Команда Неразрывный пробел

Позволяет вставить в текст неразрывный пробел. Для вызова команды выберите ее название из меню Вставка — Символ форматирования.


Команда Следующее направление

Позволяет выделить следующее за текущим возможное направление движения в узле в при сборке контура или построении эквидистанты по стрелке.


Поле Обозначение

Поле для отображения обозначения модели или исполнения модели. Недоступно для ручного ввода. Обозначение задается в диалоге Обозначение, который появляется на экране после щелчка мышью в поле.

Смотрите также

Обозначение и наименование исполнения


Список Нумерация

Позволяет выбрать группу нумерации, в которую будет добавлен создаваемый или редактируемый объект.

Список содержит перечень всех системных групп (кроме группы #Автосортировка), созданных в документе пользовательских групп и строку Не использовать.

– Если выбрана группа, то текущему объекту назначается номер, следующий по порядку в этой группе. Данный номер является ссылкой на номер объекта в группе нумерации.

– Если выбрана строка Не использовать, то текущий объект не нумеруется.

При редактировании объекта, имеющего автоматически сформированный номер (объект входит в одну из групп нумерации), обратите внимание на следующие особенности:

– при выборе из списка другой группы нумерации объект переносится из исходной группы в выбранную,

– при выборе из списка варианта Не использовать объект удаляется из группы нумерации.

Для просмотра состава групп и изменения номеров внутри группы служит окно Нумерация.

Смотрите также

Автоматическая нумерация объектов

Названия и нумерация таблиц


Кнопка Параметры групп нумерации

Позволяет сформировать список пользовательских групп нумерации в документе; настроить параметры нумерации объектов, содержащихся в системных и пользовательских группах нумерации, а также в группе #Автосортировка.

После нажатия кнопки на экране появляется диалог, соответствующий типу группы, выбранной из списка групп окна Нумерация.

Настройка нумерации и формирование списка пользовательских групп...

Настройка автосортировки...

Смотрите также

Автоматическая нумерация объектов


Команда Сплайн по полюсам

Позволяет построить сплайн по полюсам.

Для вызова команды нажмите кнопку Сплайн по полюсам на инструментальной панели Геометрия.

Задайте вершины сплайна. Для этого укажите вершины опорной ломаной.

Для точного позиционирования курсора воспользуйтесь привязками или меню геометрического калькулятора для поля т на Панели свойств.

Каждая вершина сплайна характеризуется набором параметров, которые отображаются в таблице Координаты вершин. С помощью элементов управления таблицей и команд контекстного меню таблицы вы можете изменять параметры существующих вершин.

Задайте порядок сплайна и вес точки. Для этого введите нужные значения в поля Порядок и Вес на Панели свойств. Порядок может принимать значения в диапазоне 2–10, а вес — в диапазоне 0,0001–999.

Сплайн с текущими параметрами отображается на экране в виде фантома.

Группа переключателей Режим позволяет указать, требуется замыкать сплайн или нет.

Вы можете изменять конфигурацию сплайна, не выходя из команды. Для этого нажмите кнопку Редактировать точки на Панели специального управления. Система перейдет в режим редактирования характерных точек объекта. Внесите необходимые изменения. Если требуется продолжить указание вершин, отожмите кнопку Редактировать точки.

Построение NURBS

Выбор стиля линии

Для подтверждения создания сплайна нажмите кнопку Создать объект на Панели специального управления.

Для выхода из команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие геометрические объекты


Кнопка Вставить ряд после выбранного

Кнопка для вставки ряда точек после выбранного ряда (по направлению U или V).

Выбранный в данный момент ряд точек показан цветом в окне модели. Чтобы выбрать другой ряд этого же направления, щелкните мышью по любой его точке. Если требуется выбрать ряд другого направления, активизируйте нужный переключатель в группе Выбор точек, а затем укажите точку ряда.


Кнопка Вставить ряд перед выбранным

Кнопка для вставки ряда точек перед выбранным рядом (по направлению U или V).

Выбранный в данный момент ряд точек показан цветом в окне модели. Чтобы выбрать другой ряд этого же направления, щелкните мышью по любой его точке. Если требуется выбрать ряд другого направления, активизируйте нужный переключатель в группе Выбор точек, а затем укажите точку ряда.


Кнопка Удалить ряд

Кнопка для удаления выбранного ряда точек (по направлению U или V).

Выбранный в данный момент ряд точек показан цветом в окне модели. Чтобы выбрать другой ряд этого же направления, щелкните мышью по любой его точке. Если требуется выбрать ряд другого направления, активизируйте нужный переключатель в группе Выбор точек, а затем укажите точку ряда.


Кнопка Удалить

Позволяет исключить выделенную точку из числа указанных для построения поверхности по пласту точек. Для выделения точки щелкните по ней мышью в окне модели.

Кнопка Удалить точку находится на Панели специального управления и доступна в режиме редактирования поверхности.

После нажатия кнопки Удалить выделенная точка перестает участвовать в построении поверхности, что отражается на ее фантоме в окне модели.

Вместо кнопки Удалить можно использовать команду контекстного меню Удалить текущую точку.

Если нужно сразу удалить все точки, нажмите кнопку Указать заново на Панели специального управления.


Команда Поверхность по пласту точек

Поверхность по пласту точек — это сплайновая поверхность или многогранная поверхность, построенная по точкам, которые образуют в пространстве пласт, т.е. расположены так, что высота их габаритного параллелепипеда мала по сравнению с его длиной и шириной. Система инерпретирует пласт точек как сеть точек и уже по этой сети создает поверхность.

Пример

Для вызова команды нажмите кнопку Поверхность по пласту точек на панели Поверхности.

1. Выберите тип поверхности — По точкам, По полюсам или Многогранная, — активизировав нужный переключатель в группе Тип на Панели свойств.

2. Укажите точки для построения поверхности. Совпадение точек не допускается. Точки можно задавать следующими способами:

– указать точечные объекты, группы точек или массивы точек; при включенной опции Ассоциировать поверхность ассоциативно связывается с указанными объектами,

– построить, нажав кнопку Построение точки на Панели специального управления.

– получить из файла данных, нажав кнопку Читать из файла на Панели специального управления; если имелись уже указанные точки, то точки из файла добавляются к ним.

В окне модели отображается фантом создаваемой поверхности. Точки нумеруются в порядке задания.

3. При необходимости задайте порядок поверхности в поле Порядок (недоступно для многогранной поверхности).

4. Выберите способ распознавания сети точек с помощью группы переключателей Способ. Способ распознавания сети определяет форму поверхности.

5. При необходимости используйте следующие возможности:

– Отмена задания одной или нескольких последних точек. Для этого нажмите кнопку Отменить указание на Панели специального управления нужное количество раз.

– Отмена сразу всех заданных точек. Для этого нажмите кнопку Указать заново на Панели специального управления.

– Изменение положения уже заданных точек. Для этого перейдите в режим редактирования поверхности, нажав кнопку Редактирование на Панели специального управления. В этом режиме можно также удалять точки.

Чтобы вернуться к заданию точек, отожмите кнопку Редактирование.

– Изменение наименования и цвета создаваемой поверхности. Для этого активизируйте вкладку Свойства Панели свойств. Также на этой вкладке можно просмотреть название системы координат поверхности.

– Проверка поверхности на самопересечения (недоступно для многогранной поверхности). Для включения проверки активизируйте опцию Проверка самопересечений. В случае обнаружения самопересечений созданная поверхность будет отмечена в Дереве как ошибочная.

6. Нажмите кнопку Создать объект на Панели специального управления.

Кнопка Создать объект доступна, если введено три или больше точек.

В случае построения сплайновой поверхности команду Поверхность по пласту точек можно использовать как эквивалент команды Поверхность по сети точек, не требующий соблюдения строго порядка при указании точек. Если же результат окажется неудовлетворителен, вызовите команду Поверхность по сети точек и укажите точки в порядке их расположения в сети.

Смотрите также

Другие команды создания поверхностей


Команда Поверхность по сети кривых

Позволяет построить сплайновую поверхность по двум взаимно пересекающимся семействам кривых. Все кривые первого семейства считаются кривыми направления U, а все кривые второго семейства — кривыми направления V. Для какого-либо одного направления вместо одной или обеих крайних кривых могут быть указаны точки.

Пример

Кривые и точки сети должны быть созданы заранее.

Требования к кривым и точкам...

Для вызова команды нажмите кнопку Поверхность по сети кривых на панели Поверхности.

Команда доступна, если в модели есть хотя бы две кривых или одна кривая и точка.

1. Укажите объекты для направления U. Как минимум для этого направления должны быть заданы две кривые, или одна кривая и точка, или одна кривая и две точки. Указанные объекты заносятся в список Кривые направления U на Панели свойств.

В окне модели отображается фантом поверхности.

Для направления V можно не указывать ни одной кривой, указать одну кривую или несколько кривых. Если для направления U не были указаны точки, то можно указать точки для направления V.

Если для направления V задана одна кривая, то она должна проходить через крайние (начальные или конечные) точки всех кривых направления U.

2. Чтобы задать объекты для направления V, активизируйте на Панели свойств переключатель Направление V и укажите нужные объекты в порядке их следования в сети. Они заносятся в список Кривые направления V.

3. Если требуется замкнуть поверхность по одному или обоим направлениям, воспользуйтесь переключателями Замкнуть по U и Замкнуть по V. Они доступны, если замыкание возможно. Замыкание поверхности по тому или иному направлению возможно, если все кривые данного направления замкнуты.

4. Если создаваемая поверхность стыкуется с какой-либо существующей поверхностью, то на вкладке Сопряжения можно задать условие сопряжения создаваемой поверхности с существующей.

Кнопки над списками объектов позволяют настраивать списки, перемещая, добавляя и удаляя объекты.

Если требуется быстро очистить оба списка, нажмите кнопку Указать заново на Панели специального управления.

Все изменения формы поверхности отображаются на ее фантоме в окне модели.

Для включения проверки поверхности на самопересечения активизируйте опцию Проверка самопересечений. В случае обнаружения самопересечений созданная поверхность будет отмечена в Дереве как ошибочная.

На вкладке Свойства Панели свойств можно задать наименование и цвет создаваемой поверхности.

Завершив указание кривых и настроив свойства поверхности, нажмите кнопку Создать объект на Панели специального управления.

Смотрите также

Другие команды создания поверхностей


Команда Поверхность по сети точек

Позволяет построить сплайновую поверхность по сети точек. Точки поверхности должны располагаться рядами, содержащими одно и то же количество точек. Совпадение точек не допускается.

Пример

Для вызова команды нажмите кнопку Поверхность по сети точек на панели Поверхности.

1. Выберите тип поверхности — По точкам или По полюсам, — активизировав нужный переключатель в группе Тип на Панели свойств.

2. Укажите точки для построения поверхности.

– Если требуется получить точки путем аппроксимации имеющейся поверхности, нажмите кнопку Сеть точек по поверхности на Панели специального управления и укажите поверхность.

– Если имеется файл, содержащий координаты точек, загрузите его, нажав кнопку Читать из файла на Панели специального управления.

– Если файла данных нет, то задайте точки по отдельности. Для этого выполните следующие действия.

2.1. Задайте точки первого ряда в порядке их следования в ряду. Точки можно задавать следующими способами:

• указать точечный объект, группу точек или массив точек; при включенной опции Ассоциировать поверхность ассоциативно связывается с указанным объектом или объектами,

• построить, нажав кнопку Построение точки на Панели специального управления.

2.2. Нажмите кнопку Закончить ряд. После нажатия кнопка исчезает с Панели свойств, а количество точек во втором и последующих рядах принимается равным количеству точек в первом ряду.

Количество рядов и точек в ряду определяется автоматически, если была указана группа точек по поверхности или массив точек по параллелограммной сетке с отличным от 1 количеством экземпляров по обеим осям.

2.3. Задайте точки остальных рядов сети в порядке их следования.

В окне модели отображается фантом создаваемой поверхности.

3. При необходимости используйте следующие возможности:

– Отмена задания одной или нескольких последних точек. Для этого нажмите кнопку Отменить указание на Панели специального управления нужное количество раз.

– Отмена сразу всех заданных точек. Для этого нажмите кнопку Указать заново на Панели специального управления.

– Изменение положения уже заданных точек. Для этого перейдите в режим редактирования поверхности, нажав кнопку Редактирование. В этом режиме можно также управлять порядком и замкнутостью поверхности, задавать веса точек (при построении по полюсам), добавлять и удалять ряды точек.

Кнопка Редактирование доступна, если введено целое количество рядов точек, начиная с двух.

Чтобы вернуться к заданию точек, отожмите кнопку Редактирование.

– Изменение наименования и цвета создаваемой поверхности. Для этого активизируйте вкладку Свойства Панели свойств. Также на этой вкладке можно просмотреть название системы координат поверхности.

– Проверка поверхности на самопересечения. Для включения проверки активизируйте опцию Проверка самопересечений. В случае обнаружения самопересечений созданная поверхность будет отмечена в Дереве как ошибочная.

4. Нажмите кнопку Создать объект на Панели специального управления.

Кнопка Создать объект доступна, если введено целое количество рядов точек, начиная с двух.

Смотрите также

Другие команды создания поверхностей


Кнопка Отменить указание

Позволяет отменить последнюю из заданных точек при построении поверхности по сети точек или поверхности по пласту точек.

Кнопка Отменить указание находится на Панели специального управления.

Если ни одной точки поверхности не задано, кнопка не доступна.

После нажатия кнопки Отменить указание последняя точка поверхности удаляется. Нажав кнопку несколько раз, можно последовательно удалить несколько последних точек.

Вместо кнопки Отменить указание можно использовать команду контекстного меню Отменить последнее указание точки.

Если нужно сразу удалить все точки, нажмите кнопку Указать заново на Панели специального управления.


Команда Очистить фон

Включает или выключает перекрывание выделенным объектом (текстом, размером или обозначением) штриховок и линий.

Умолчательная настройка перекрывания производится в диалоге настройки отображения перекрывающихся объектов. В этом же диалоге вы можете задать ширину очищаемого поля.

Объект, настройка перекрывания для которого производилась с помощью данной команды, в дальнейшем уже не подчиняется настройке, сделанной в указанном диалоге.

При очистке фона прерываются линии и штриховки, расположенные в одном виде с объектом, для которого выполняется очистка. Подробно о видах...


Команда Атрибуты...

Позволяет задать или отредактировать атрибуты какого-либо графического объекта или объемного элемента, образующего тело детали.

После вызова команды на экране отображается диалог работы с атрибутами.


Команда Объект по образцу

Позволяет создавать новые графические объекты со свойствами существующих объектов — образцов. Образцами могут быть геометрические объекты (кроме контуров и дуг эллипсов), обозначения и размеры.

Чтобы создать объект по образцу:

1. Нажмите кнопку Объект по образцу.

Курсор изменит вид.

2. Установите курсор на объекте — образце копируемых свойств. После того как объект подсветится, щелкните левой кнопкой мыши.

После указания объекта автоматически запускается команда, соответствующая типу указанного объекта. Например, если в качестве образца был указан отрезок, то запускается команда Отрезок.

3. Задайте параметры нового объекта.

4. Создайте объект.

Новый объект будет иметь свойства объекта-образца.

Команду Объект по образцу можно прервать до запуска команды, соответствующей типу указанного объекта, нажав кнопку Прервать команду на Панели специального управления.

Если перед вызовом команды Объект по образцу объект-образец уже был выделен, то после вызова команды сразу запускается команда, соответствующая типу объекта-образца.

Подробнее...


Команда Копия

Позволяет скопировать выделенные объекты чертежа или фрагмента.

Для вызова команды нажмите кнопку Копия на инструментальной панели Редактирование или выберите команду меню Редактор — Копия — Указанием.

Укажите базовую точку для копирования т1.

Укажите точку т2, определяющую новое положение базовой точки.

Значения смещений по осям текущей системы координат будут рассчитаны автоматически и показаны в полях Смещение по оси Х и Смещение по оси Y.

При необходимости настройте дополнительные параметры копирования:

– Масштаб и поворот копий

– Копирование атрибутов и свойств

После фиксации нового положения базовой точки система копирует выделенные элементы в заданное место.

Исходное изображение и изображение после копирования отверстий

Объекты-копии располагаются в тех же видах и на тех же слоях, что и исходные объекты.

Если значения перемещений в направлениях осей известны, то для выполнения копирования вы можете ввести их в соответствующие поля на Панели свойств. Точки т1 и т2 при этом указывать не нужно.

За один вызов команды вы можете создать произвольное количество копий объектов.

Для завершения команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие команды редактирования


Команда Копия по окружности

Позволяет выполнить копирование выделенных объектов, разместив их по окружности с указанным центром.

Для вызова команды нажмите кнопку Копия по окружности на инструментальной панели Редактирование или выберите ее название из меню Редактор — Копия.

Порядок действий при копировании объектов по окружности следующий.

1. Укажите центр копирования.

На экране появится фантом массива с умолчательными параметрами.

2. В поле Количество копий на Панели свойств введите общее количество экземпляров массива.

Так при копировании по окружности исходный объект входит в состав массива, количество созданных копий будет на единицу меньше введенного значения.

3. С помощью переключателя Режим выберите способ размещения экземпляров массива: Вдоль всей окружности или С заданным шагом.

Копирование по окружности:
а) вдоль всей окружности, б) с угловым шагом 45 градусов

4. Если на предыдущем этапе установлено размещение копий с заданным угловым шагом, введите его значение в поле Шаг, а с помощью переключателя Направление установите нужное направление копирования: по часовой стрелке или против часовой стрелки от исходного объекта.

Каждое изменение того или иного параметра массива немедленно отражается на его фантоме.

Копирование атрибутов и свойств

5. Для фиксации массива нажмите кнопку Создать объект на Панели специального управления.

Для завершения команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие команды редактирования


Команда Копия по кривой

Позволяет выполнить копирование выделенных объектов, разместив их вдоль указанной кривой.

Для вызова команды нажмите кнопку Копия по кривой на инструментальной панели Редактирование или выберите ее название из меню Редактор — Копия.

Порядок действий при копировании объектов вдоль кривой следующий.

1. Укажите базовую точку для копирования т1.

2. Введите количество копий в одноименное поле Панели свойств.

3. Укажите курсором кривую, вдоль которой должны копироваться объекты.

4. Введите значение шага в поле Шаг и выберите его интерпретацию.

Это расстояние будет измеряться вдоль кривой, по которой производится копирование.

5. При необходимости настройте дополнительные параметры копирования:

– Масштаб и поворот копий

– Управление исходными объектами

– Расположение копий

– Копирование атрибутов и свойств

6. Укажите на кривой начальную точку копирования т2. С этой точкой совпадет базовая точка первого экземпляра массива.

Пример копирования по кривой

По умолчанию копирование по кривой направлено против часовой стрелки от начальной точки. При этом в группе Направление на вкладке Копия Панели свойств активен переключатель Отрицательное направление. Если массив должен располагаться по другую сторону от начальной точки, активизируйте переключатель Положительное направление.

Очевидно, что выбор направления создания массива имеет смысл только в тех случаях, когда в качестве начальной точки указана не крайняя точка кривой.

Для завершения команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие команды редактирования


Команда Копия по сетке

Позволяет выполнить копирование выделенных объектов чертежа или фрагмента, разместив их в узлах сетки с заданными параметрами

Для вызова команды нажмите кнопку Копия по сетке на инструментальной панели Редактирование или выберите ее название из меню Редактор — Копия.

Порядок действий при копировании объектов по сетке следующий.

1. Укажите базовую точку для копирования т1.

На экране появится фантом массива с умолчательными параметрами. Чтобы настроить их требуемым образом, активизируйте вкладку Параметры Панели свойств.

2. В поля N1 и N2 введите количества экземпляров массива соответственно вдоль первой и второй осей сетки.

3. В поле Наклон введите угол наклона первой оси сетки к оси абсцисс текущей системы координат.

4. В поле Угол раствора введите угол между осями сетки.

5. В поля Шаг 1 и Шаг 2 введите шаг копий соответственно вдоль первой и второй осей и выберите интерпретацию шага.

6. С помощью переключателей Копии в углах сетки и Копии внутри сетки установите нужный способ размещения копий.

Эти группы переключателей доступны, если количество копий вдоль каждой из осей больше или равно трем.

Каждое изменение того или иного параметра массива немедленно отражается на его фантоме.

7. При необходимости настройте дополнительные параметры копирования:

– Масштаб и поворот копий

– Управление исходными объектами

– Копирование атрибутов и свойств

8. Укажите точку вставки массива т2.

Пример копирования по сетке

Объекты-копии располагаются в тех же видах и на тех же слоях, что и исходные объекты.

Для завершения команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие команды редактирования


Команда Копия по концентрической сетке

Позволяет выполнить копирование выделенных объектов чертежа или фрагмента, разместив их в узлах концентрической сетки.

Для вызова команды нажмите кнопку Копия по концентрической сетке на инструментальной панели Редактирование или выберите ее название в меню Редактор — Копия.

Порядок действий при копировании объектов по концентрической сетке следующий.

1. Укажите базовую точку для копирования т1.

На экране появится фантом массива с умолчательными параметрами. Чтобы настроить их требуемым образом, активизируйте вкладку Параметры Панели свойств.

2. В поля N1 и N2 введите количества экземпляров массива соответственно в радиальном и кольцевом направлении.

3. В поле Радиус введите значение радиуса начальной окружность сетки.

4. В поле Угол введите угол между осью абсцисс текущей системы координат и первой радиальной линией сетки.

5. В поля Шаг 1 и Шаг 2 введите шаг копий соответственно в радиальном и кольцевом направлениях и выберите интерпретацию шага.

6. С помощью переключателя Копия в центре укажите, требуется создание экземпляра массива в центре сетки.

Эти группы переключателей доступны, если количество копий вдоль каждой из осей больше или равно трем.

Каждое изменение того или иного параметра массива немедленно отражается на его фантоме.

7. При необходимости настройте дополнительные параметры копирования:

– Масштаб и поворот копий

– Управление исходными объектами

– Расположение копий

– Копирование атрибутов и свойств

8. Укажите точку вставки массива т2.

Пример копирования по концентрической сетке

Объекты-копии располагаются в тех же видах и на тех же слоях, что и исходные объекты.

Для завершения команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие команды редактирования


Команда Поворот

Позволяет повернуть выделенные объекты чертежа или фрагмента.

Для вызова команды нажмите кнопку Поворот на инструментальной панели Редактирование или выберите ее название из меню Редактор.

Укажите точку центра поворота.

Укажите базовую точку т1, а затем точку т2, определяющую новое положение базовой точки.

Группа переключателей Режим на Панели свойств позволяет указать, требуется ли оставлять или удалять исходные объекты после выполнения операции.

Исходное изображение и изображение после поворота отверстия относительно центра пластины на 120 градусов

Для завершения команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие команды редактирования


Команда Масштабирование(графический документ)

Команда Масштабирование
(графический документ)

Позволяет выполнить масштабирование выделенных объектов чертежа или фрагмента.

Для вызова команды нажмите кнопку Масштабирование на инструментальной панели Редактирование или выберите ее название из меню Редактор.

Задайте в соответствующих полях на Панели свойств значения коэффициентов масштабирования в направлении осей координат (вы можете ввести разные значения коэффициента масштабирования по горизонтали и по вертикали).

Ввод масштаба по оси Y невозможен, если среди выделенных объектов есть окружности, или дуги окружностей, или виды целиком. В этом случае выполнение операции производится со значением масштаба по оси Y, равным масштабу по оси X.

Группа переключателей Режим на Панели свойств позволяет указать, требуется ли оставлять или удалять исходные объекты после выполнения операции.

Группа переключателей Выносные линии позволяет указать, требуется ли масштабировать выносные линии размеров.

Копирование атрибутов и свойств

Укажите точку центра масштабирования.

Исходное изображение и изображение после масштабирования рукоятки

Для завершения команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие команды редактирования


Команда Сдвиг

Позволяет сдвинуть выделенные объекты чертежа или фрагмента.

Для вызова команды нажмите кнопку Сдвиг на инструментальной панели Редактирование или выберите команду меню Редактор — Сдвиг — Указанием.

Доступно два способа выполнения сдвига объектов:

– с использованием базовой точки

– заданием перемещений по осям.

Для выполнения перемещения первым способом сначала укажите базовую точку для сдвига т1, а затем точку т2, определяющую ее новое положение.

Исходное изображение и изображение после сдвига отверстий

Для выполнения перемещения вторым способом введите в поля Сдвиг X и Сдвиг Y на Панели свойств значения смещений в направлениях осей текущей системы координат.

Группа переключателей Режим на Панели свойств позволяет указать, требуется ли оставлять или удалять исходные объекты после выполнения операции.

В ряде случаев удобнее выполнять перемещение выделенных объектов мышью, не прибегая к команде сдвига.

Копирование атрибутов и свойств

Для завершения команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие команды редактирования


Команда Сдвиг по углу и расстоянию

Позволяет переместить выделенные объекты на определенное расстояние в заданном направлении.

Для вызова команды нажмите кнопку Сдвиг по углу и расстоянию на инструментальной панели Редактирование или выберите ее название из меню Редактор — Сдвиг.

Введите значения угла и расстояния в поля Угол и Расстояние на Панели свойств. Значения смещений вдоль осей текущей системы координат будут рассчитаны автоматически и показаны в соответствующих справочных полях.

Группа переключателей Режим на Панели свойств позволяет указать, требуется ли оставлять или удалять исходные объекты после выполнения операции.

Копирование атрибутов и свойств

Для выполнения сдвига выделенных объектов нажмите кнопку Создать объект на Панели специального управления.

Исходное изображение и изображение после сдвига правого отверстия на 15 мм в направлении 120 градусов к оси Х

Для завершения команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие команды редактирования


Команда Симметрия

Позволяет выполнить преобразование симметрии относительно прямой для выделенных объектов чертежа или фрагмента.

Для вызова команды нажмите кнопку Симметрия на инструментальной панели Редактирование или выберите ее название из меню Редактор.

Укажите положение первой (т1), а затем второй (т2) точек оси симметрии. Угол наклона оси к оси абсцисс текущей системы координат будет определен автоматически.

Если выделенный объект содержит текст, определите, как будет выглядеть этот текст после преобразования симметрии. Для этого используется опция Зеркально отразить тексты. При включенной опции текст будет отражен зеркально, при отключенной — останется в исходном виде.

Действие опции не распространяется на текст обозначений, выбранных для преобразования симметрии.

Группа переключателей Режим на Панели свойств позволяет указать, требуется ли оставлять или удалять исходные объекты после выполнения операции.

Копирование атрибутов и свойств

Исходное изображение и изображение после выполнения преобразования симметрии

Если прямолинейный объект, являющийся осью симметрии, существует в документе, вы можете указать сам этот объект, а не точки, принадлежащие ему.

Для этого нажмите кнопку Выбор базового объекта на Панели специального управления и укажите курсором нужный прямолинейный объект.

Для завершения команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Особенности использования команды в параметрическом режиме

Другие команды редактирования


Команда Эквидистанта кривой(документ-модель)

Команда Эквидистанта кривой
(документ-модель)

Позволяет построить кривую, эквидистантную базовой.

В качестве базовой кривой может использоваться пространственная кривая, ребро, линия эскиза или цепочка перечисленных объектов в любом сочетании.

Пример

Для вызова команды нажмите кнопку Эквидистанта кривой на инструментальной панели Пространственные кривые или выберите ее название из меню Операции — Пространственные кривые.

Укажите в окне модели базовую кривую.

Выбор объектов в окне модели

Выбор объектов в Дереве построения

Базовую кривую можно указать и перед вызовом команды.

На экране появляется фантом эквидистантной кривой с умолчательными параметрами. Начальная вершина базовой кривой отмечена стрелкой.

– Повторное указание кривой отменяет ее выбор.

– Повторное указание одной кривой из совокупности отменяет ее выбор, а также выбор всех следующих за ней кривых в направлении конечной вершины.

Название выбранного объекта или количество выбранных объектов отображается в поле рядом с переключателем Кривая.

Выберите способ построения эквидистантной кривой из раскрывающегося списка Способ на Панели свойств:

– Смещение по направлению от вершины;

– Смещение вдоль поверхности.

Все изменения отображаются на фантоме создаваемой кривой в окне модели.

Чтобы сменить объекты, используемые для построения эквидистантной кривой, нажмите кнопку Указать заново на Панели специального управления и повторите выбор объектов.

При необходимости вы можете назначить допуски на значения параметров операции, выраженных в линейных или угловых величинах. Для этого используйте кнопку Назначить допуск, расположенную на Панели свойств рядом с полем числового параметра операции.
Подробнее о допусках...
Подробнее о назначении допуска...

Элементы управления, расположенные на вкладке Свойства Панели свойств, позволяют изменить название и цвет кривой, настроить параметры ее отображения.

Чтобы завершить построение, нажмите кнопку Создать объект на Панели специального управления.

Отказаться от построения эквидистантной кривой можно, нажав кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

При нулевом смещении эквидистантная кривая представляет собой копию базовой.

Данная копия является единым объектом, даже если в качестве базовой кривой указана совокупность кривых.

Смотрите также

Особенности задания числовых параметров операции в полях Панели свойств


Кнопка Эквидистанта кривой

Находится на Панели специального управления. Служит для запуска процесса создания контура по эквидистанте указанной кривой.

После нажатия кнопки система переходит в процесс создания эквидистантной кривой, полностью аналогичный вызываемому командой Эквидистанта кривой.

Выберите способ построения эквидистанты, а затем задайте требуемые для этого способа параметры (введите значения или укажите объекты). Все изменения отображаются на фантоме создаваемой кривой в окне модели.

Завершив задание параметров эквидистанты, нажмите кнопку Создать объект на Панели специального управления.

Система возвращается к выполнению команды Контур.

Название эквидистантной кривой отображается в таблице Список объектов на Панели свойств.

Подробнее о построении эквидистанты в процессе создания контура...


Группа переключателей Начальная/конечная вершина

Используется при построении эквидистантной кривой или контура.

Позволяет сменить вершину базовой кривой, через которую проходит плоскость смещения, или начальную вершину контура.

Активизируйте нужный переключатель: Начальная точка или Конечная точка.

Смена вершины немедленно отображается на фантоме кривой в окне модели.

Переключатели доступны, если указана кривая.

Подробнее о построении эквидистантной кривой смещением по направлению от вершины

Подробнее о построении контура


Группа переключателей Обход углов

Позволяет выбрать способ обхода углов — способ стыковки сегментов эквидистантной кривой или контура.

Примеры результатов построения эквидистанты приведены в таблице.

Способы обхода углов эквидистанты
Способ | Результат построения
Обход скруглением |
Обход срезом |

Подробнее о построении эквидистантной кривой смещением по направлению от вершины...

Подробнее о построении контура со скруглениями...


Поле Смещение

Служит для задания расстояния, на которое должны быть смещены выбранные полюсы сетки при линейном перемещении полюсов. Поле находится на Панели свойств, если в списке Направление выбран любой вариант направления перемещения, кроме варианта В плоскости экрана. Поле становится доступным после выбора полюсов.

Значение расстояния может быть как положительным, так и отрицательным. Смещение полюсов выполняется автоматически после ввода значения в поле. После смещения полюсов поле обнуляется.


Команда Эквидистанта поверхности

Позволяет построить поверхность, эквидистантную базовой.

В качестве базовой поверхности могут использоваться следующие объекты:

– грань тела или поверхности;

– связная совокупность граней одного тела или поверхности.

Пример

Для вызова команды нажмите кнопку Эквидистанта поверхности на инструментальной панели Поверхности или выберите ее название из меню Операции — Поверхность.

Укажите базовую поверхность в окне модели.

Если в качестве базовой поверхности используются все грани тела или поверхности, то это тело или поверхность можно указать в Дереве построения.

Базовую поверхность можно указать и перед вызовом команды.

Повторное указание базовой поверхности отменяет ее выбор.

Выбор объектов в окне модели

Выбор объектов в Дереве построения

Название выбранного объекта или количество выбранных объектов отображается в поле Поверхность на Панели свойств.

В окне модели отображается фантом создаваемой поверхности с характерной точкой для задания расстояния от базовой поверхности до создаваемой.

Чтобы указать, с какой стороны от базовой поверхности будет построена эквидистантная поверхность, активизируйте нужный переключатель в группе Направление.

Задайте расстояние от базовой поверхности до создаваемой. Для этого введите нужное значение в поле Расстояние.

Все изменения параметров отображаются на фантоме эквидистантной поверхности в окне модели.

Чтобы сменить базовую поверхность, нажмите кнопку Указать заново на Панели специального управления и повторите выбор объекта или объектов.

При необходимости вы можете назначить допуски на значения параметров операции, выраженных в линейных или угловых величинах. Для этого используйте кнопку Назначить допуск, расположенную на Панели свойств рядом с полем числового параметра операции.
Подробнее о допусках...
Подробнее о назначении допуска...

Элементы управления, расположенные на вкладке Свойства Панели свойств, позволяют изменить название и цвет создаваемой поверхности.

Чтобы завершить построение эквидистантной поверхности, нажмите кнопку Создать объект на Панели специального управления.

Отказаться от построения эквидистантной поверхности можно, нажав кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

При нулевом смещении эквидистантная поверхность представляет собой копию базовой. Таким способом можно создать необходимое количество копий поверхности, являющейся основой для нескольких тел или деталей.

Смотрите также

Другие команды создания поверхностей

Особенности задания числовых параметров операции в полях Панели свойств


Марка 1

Переключатель, позволяющий включать или выключать отрисовку марки в начале координационной оси.

Активизируйте переключатель Марка 1, чтобы ось отрисовывалась с маркой на конце выступа за начальную точку (т1).

Если переключатель не активен, координационная ось строится без марки на конце выступа 1.

Настройка умолчательного состояния переключателя Марка производится в диалоге общих настроек координационных осей.

Чтобы построить цепочки марок, перейдите на вкладку Дополнительные обозначения.


Марка 2

Переключатель, позволяющий включать или выключать отрисовку марки в конце координационной оси.

Активизируйте переключатель Марка 2, чтобы ось отрисовывалась с маркой на конце выступа за конечную точку (т2).

Если переключатель не активен, координационная ось строится без марки на конце выступа 2.

Настройка умолчательного состояния переключателя Марка производится в диалоге общих настроек координационных осей.

Чтобы построить цепочки марок, перейдите на вкладку Дополнительные обозначения.


Группа переключателей Направление

Служит для изменения направления смещения точки вдоль кривой.

При нажатой кнопке От начальной вершины смещение отсчитывается от начальной вершины кривой в направлении вектора смещения (см. рис. а).

Чтобы смещение отсчитывалось от конечной вершины, следует нажать кнопку От конечной вершины (см. рис. б).

Выбор направления смещения а) от начальной вершины, б) от конечной вершины
а) | б)


Команда Открыть папку с файлом

Позволяет загрузить Проводник Windows и открыть в нем папку, в которой хранится активный документ.

Файл с документом выделяется в папке цветом.

Для вызова команды выберите ее название из контекстного меню закладки документа.

Смотрите также

Закладки документов


Команда Открыть документ-источник

Для ассоциативного отчета команда позволяет открыть документ, по объектам которого получен отчет.

Если отчет располагается в документе, по объектам которого он получен, т.е. в документе-источнике, то команда Открыть документ-источник для него недоступна.

Для таблицы исполнений модели или таблицы отчета по массиву команда позволяет открыть модель, для которой создана эта таблица.

В случае создания таблицы исполнений для ассоциативного вида с модели также открывается исходная модель.

Команда находится в контекстном меню выделенного ассоциативного отчета/таблицы в документе.


Команда Читать из файла

Позволяет прочитать значения параметров ломаной или сплайна из файла.

Для вызова команды можно также нажать кнопку Читать из файла на панели Координаты вершин.

Команда доступна, если таблица параметров пуста.


Команда Подключить библиотеку

Позволяет подключить к системе КОМПАС-3D одну или несколько библиотек.

После вызова команды на экране появится диалог, в котором требуется указать файл библиотеки и режим ее работы.

К системе КОМПАС-3D одновременно может быть подключено не более 25 библиотек.


Поле Цвет

Поле позволяет выбрать цвет объекта из палитры цветов.

При настройке свойств всей модели поле Цвет присутствует на Панели свойств всегда, а при настройке остальных объектов — только если в группе Назначить цвет активен переключатель Вручную.


Порядок

Поле значения порядка сплайна.

Вы можете ввести значение вручную или установить с помощью счетчика.

Поле Порядок доступно только при построении сплайна по полюсам.


Команда Размер высоты

Позволяет построить размер высоты.

Для вызова команды нажмите кнопку Размер высоты на инструментальной панели Размеры.

На Панели свойств находится список Тип, с помощью которого можно выбрать размер нужного назначения.

Чтобы построить размер высоты для вида спереди или разреза, укажите точку т0, от которой нужно отсчитывать значения высот (то есть точку нулевого уровня).

Укажите точку привязки т1, определяющую положение образмериваемого уровня.

Система автоматически рассчитывает значение высоты указанной точки относительно точки т0 (расчет производится в метрах с точностью до одной десятой).

Вы можете отредактировать автоматически установленное значение, а также настроить параметры надписи. Для этого щелкните мышью в поле Текст на Панели свойств. На экране появится диалог задания надписи.

Размер высоты для вида спереди или разреза

Затем укажите точку т2, определяющую положение надписи.

Укажите точки т1 и т2 для других уровней, высота которых должна быть проставлена от этой же нулевой точки.

Для перехода к созданию группы размеров высоты от другого нулевого уровня необходимо расфиксировать точку, от которой производится отсчет (поле т0 на Панели свойств), и указать ее новое положение.

Чтобы построить размер высоты с линией-выноской, укажите точку т1, определяющую образмериваемый уровень (в ней будет начинаться линия-выноска), а затем точку, определяющую положение размерной надписи т2.

Размер высоты для вида сверху с линией-выноской

Чтобы построить размер высоты непосредственно на изображении, укажите точку, определяющую положение размерной надписи т2.

Размер высоты для вида сверху непосредственно на изображении

При простановке размера высоты на виде сверху возможен только ручной ввод текста.

Смотрите также

Другие размеры


Ориентирование ЛСК способом По объекту

При ориентировании ЛСК по объекту необходимо указать объект, свойства которого позволяют однозначно определить ориентацию ЛСК.

Перечень объектов, которые могут быть указаны, приведен в таблице. Направления осей ЛСК, задаваемые этими объектами, приведены в колонке Ориентация той же таблицы.

После указания объекта в окне модели появляется фантом ЛСК, расположенный согласно параметрам объекта. Название объекта появляется в поле Объект.


Команда Ориентация

Позволяет изменить текущую ориентацию модели.

Для вызова команды выберите ее название из меню Вид или нажмите кнопку Ориентация на панели Вид.

На экране появится диалог ориентаций модели, в котором можно изменить текущую ориентацию на стандартную или пользовательскую ориентацию из списка, а также сохранить текущую ориентацию в списке.

Другим способом задания нужной ориентации модели является выбор нужной команды из меню кнопки Ориентация.

Команды меню кнопки Ориентация можно расположить в виде набора кнопок на отдельной панели и поместить ее в любом удобном месте. Для этого «перетащите» меню кнопки Ориентация мышью за заголовок в любом направлении. Будет сформирована панель Ориентация.

Панель Ориентация не содержит кнопки для задания пользовательских ориентаций модели.

Обратите внимание на отличие панели Ориентация от остальных инструментальных панелей: состав и порядок кнопок на ней изменить невозможно.

После вызова команды смены ориентации модель поворачивается так, чтобы направление взгляда соответствовало указанному.

Вы можете настроить изображение модели при смене ориентации — изменить плавность поворота или выключить центрирование в диалоге настройки изменения ориентации модели.

Подробнее об ориентации модели...

Смотрите также

Команда Нормально к

Команда Повернуть

Ориентация Развертка


Команда Нормально к...

Иногда требуется такая ориентация модели, при которой ее плоская грань или вспомогательная плоскость параллельна плоскости экрана. Команда Нормально к... служит для установления такой ориентации.

Эта команда доступна, если в окне модели выделен плоский объект (плоскость или плоская грань).

Для вызова команды выберите ее название из контекстного меню на выделенном объекте. Модель повернется так, чтобы направление взгляда было перпендикулярно выбранному объекту или плоскости выбранного эскиза.

Другим способом установления ориентации Нормально к... является выбор соответствующей команды из меню кнопки Ориентация на панели Вид.

В режиме редактирования эскиза команда Нормально к... позволяет повернуть модель так, чтобы направление взгляда было перпендикулярно плоскости эскиза. Эта команда присутствует в контекстном меню, если не активна ни одна команда создания геометрических объектов.


Команда Ортогональное черчение

Служит для включения и отключения режима ортогонального черчения. Другой способ управления этим режимом — нажатие клавиши <F8>.

Кнопка Ортогональное черчение находится на панели Текущее состояние и является индикатором режима: нажатая кнопка означает, что ортогональное черчение включено, отжатая — выключено. Если в процессе ввода какого-либо объекта вам требуется временно отключить (или включить) этот режим, нажмите и удерживайте клавишу <Shift>.


Команда Оставлять зазор между листами

Позволяет включить или выключить использование зазора между листами.

Для вызова команды нажмите кнопку Оставлять зазор между листами на инструментальной панели.

Зазор учитывается, например, при размещении листов с привязкой к углам друг друга, при выполнении команды Сомкнуть и выровнять листы, при добавлении документов в предварительный просмотр (т.е. непосредственно после вызова команды положение листов на поле вывода не меняется).

– Если зазор включен, то листы располагаются друг от друга на расстоянии, заданном в диалоге настройки параметров вывода в поле Зазор.

– Если зазор отключен, то листы располагаются вплотную, т.е. с нулевым зазором.


Команда Привязка к узлам страниц

Позволяет включить или выключить привязку листов документов, перемещаемых по полю вывода, к узлам страниц печати.

Для вызова команды нажмите кнопку Привязка к узлам страниц на инструментальной панели.


Команда Линия очерка

Позволяет построить линию очерка грани — линию, в точках которой нормаль грани перпендикулярна заданному направлению взгляда.

Ребра грани не включаются в линию очерка.

Построение линии очерка грани невозможно, если грань плоская или нормаль грани в каждой ее точке перпендикулярна направлению взгляда.

Линию очерка можно построить для набора граней.

Пример

Для вызова команды нажмите кнопку Линия очерка на инструментальной панели Пространственные кривые или выберите ее название из меню Операции — Пространственные кривые — Кривые на поверхности.

На Панели свойств автоматически активизируется переключатель Поверхность. Укажите в окне модели нужную грань или набор граней.

Если требуется построить линию очерка для всех граней тела или поверхности, укажите это тело или поверхность в Дереве построения.

Исходные объекты могут быть выделены и перед вызовом команды.

Название выбранного объекта или количество выбранных объектов отображается в поле Поверхность на Панели свойств.

Повторное указание грани отменяет ее выбор.

Выбор объектов в окне модели

Выбор объектов в Дереве построения

На экране появляется фантом линии очерка. По умолчанию линия очерка строится в направлении взгляда, перпендикулярном плоскости экрана.

Опция Фиксировать положение позволяет зафиксировать линию очерка в виде, который соответствует текущей ориентации модели. При отключенной опции линия очерка перестраивается всякий раз после изменения ориентации модели.

Выберите направляющий объект или создайте вектор, если требуется задать направление взгляда.

После задания направления взгляда фантом линии очерка перестраивается.

Линия очерка может состоять из одного или нескольких участков — контуров. Опция Все контуры позволяет выбрать нужные контуры линии очерка для построения.

Все изменения отображаются на фантоме кривой.

Чтобы сменить объекты, используемые для построения линии очерка, нажмите кнопку Указать заново на Панели специального управления и повторите выбор объектов.

Элементы управления, расположенные на вкладке Свойства Панели свойств, позволяют изменить название и цвет кривой, настроить параметры ее отображения.

Чтобы завершить построение линии очерка, нажмите кнопку Создать объект на Панели специального управления.

Для выхода из команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.


Текущая страница

В этом поле, расположенном на панели Текущее состояние, отображается фактический номер страницы документа, на которой находится курсор.

Чтобы переместиться на другую страницу, наберите ее номер в этом поле и нажмите клавишу <Enter>.

Если панель Текущее состояние расположена вертикально, то для доступа к полю Текущая страница нажмите соответствующую кнопку.


Команда Приблизить/отдалить изображение

Позволяет плавно менять масштаб, приближая или отдаляя изображение.

Для вызова команды нажмите кнопку Увеличить масштаб на панели Вид или выберите ее название из меню Вид.

Нажмите левую кнопку мыши и перемещайте курсор в вертикальном направлении. При движении курсора вверх изображение будет плавно увеличиваться, в обратном направлении — уменьшаться.

Центр панорамирования находится в точке, в которой была нажата левая кнопка мыши.

Чтобы центром панорамирования была центральная точка экрана, удерживайте нажатой клавишу <Shift>.

Если вы пользуетесь мышью с колесом, то для панорамирования изображения вращайте колесо мыши. Центр панорамирования находится в точке, в которой было начато вращение колеса мыши. Возможна настройка направления вращения колеса мыши.

Чтобы центром панорамирования была центральная точка экрана, удерживайте нажатой клавишу <Shift>.

С помощью колеса мыши можно также панорамировать текстовые документы и документы-спецификации. Для этого следует вращать колесо, удерживая нажатой клавишу <Ctrl>. Центром панорамирования является центральная точка экрана.

Смотрите также

Управление масштабом отображения документа в окне


Команда Абзац...

Позволяет назначить или изменить параметры форматирования (шаг строк, отступы, интервалы и т.д.) для выделенных или набираемых заново абзацев текста.

Для вызова команды нажмите кнопку Параметры абзаца или выберите ее название из меню Формат.

После вызова команды на экран выводится диалог установки параметров абзаца.


Произвольное расположение фигурной скобки

Переключатель, позволяющий создать фигурную скобку произвольной ориентации.


Размер параллельно объекту

Переключатель, позволяющий создать размер, размерная линия которого параллельна прямой, проходящей через точки привязки размера.


Команда Параллельная прямая

Позволяет построить прямую, параллельную выбранному прямолинейному объекту.

Для вызова команды нажмите кнопку Параллельная прямая на инструментальной панели Геометрия.

Укажите курсором объект, которому должна быть параллельна прямая.

Задайте расстояние от объекта до параллельной прямой. Для этого введите нужное значение в поле Расстояние на Панели свойств или укажите точку, через которую должна пройти прямая.

По умолчанию система предлагает фантомы двух прямых, расположенных на заданном расстоянии по обе стороны от объекта.

Вы можете зафиксировать одну из них или обе, щелкая мышью на нужном фантоме либо нажимая кнопку Создать объект на Панели специального управления.

Построение прямой, параллельной отрезку

Простановка точек пересечений

Управление количеством прямых производится с помощью переключателя Количество прямых на Панели свойств.

Чтобы быстро построить несколько прямых, параллельных одному и тому же объекту, сделайте следующее. Указав объект, нажмите кнопку Запомнить состояние на Панели специального управления. После этого последовательно постройте нужное количество прямых, указывая принадлежащие им точки или задавая расстояния до объекта.

Подробнее о запоминании параметров...

Чтобы перейти к построению прямых, параллельных другому объекту, нажмите кнопку Выбор объекта на Панели специального управления, а затем укажите курсором нужный объект.

Для выхода из команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие геометрические объекты


Количество прямых

Переключатель, позволяющий выбрать количество прямых, параллельных выбранному объекту.


Команда Параллельный отрезок

Позволяет построить один или несколько отрезков, параллельных другим прямолинейным объектам.

Для вызова команды нажмите кнопку Параллельный отрезок на инструментальной панели Геометрия.

Доступно два способа построения параллельных отрезков:

– задание начальной и конечной точек,

– задание длины и начальной (конечной) точки.

Укажите объект, параллельно которому должен пройти отрезок.

Если известны начальная т1 и конечная т2 точки отрезка, задайте их. Длина отрезка и его расстояние от объекта будут определены автоматически.

Для точного позиционирования курсора воспользуйтесь привязками или меню геометрического калькулятора в полях т1 и т2 на Панели свойств.

Построение отрезка, параллельного стороне прямоугольника

Если известна длина отрезка, введите ее значение в поле Длина на Панели свойств. На экране появится фантом отрезка. Его направление определяется автоматически.

Если это направление вас устраивает, укажите точку привязки отрезка — ожидаемую системой по умолчанию начальную точку т1.

Чтобы изменить направление отрезка, активизируйте параметр т2, щелкнув мышью по его имени на Панели свойств. Фантом вводимого отрезка «повернется» на 180 градусов, так как теперь система ожидает указание конечной точки отрезка. Укажите точку т2.

Выбор стиля линии

Можно построить несколько отрезков, параллельных указанному объекту, не выходя из команды.

Вы можете построить несколько отрезков, параллельных указанному объекту, и расположенных на одном и том же расстоянии от него. Для этого действуйте следующим образом. Указав объект, введите в поле Расстояние нужное значение и нажмите кнопку Запомнить состояние на Панели специального управления. Затем последовательно постройте нужное количество отрезков, указывая их начальные (конечные) точки. Аналогичным образом система может «запомнить» и длину отрезка.

Чтобы перейти к построению отрезков, параллельных другому объекту, нажмите кнопку Выбор объекта на Панели специального управления, а затем укажите курсором нужный объект.

Для выхода из команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие геометрические объекты


Команда Оформление Панели свойств

Позволяет вызвать на экран диалог настройки оформления Панели свойств.


Команда Блокировка размеров

Позволяет установить блокировку размеров и структуры текущей таблицы.

Для вызова команды нажмите кнопку Блокировка размеров таблицы или выберите ее название из меню Таблица.

После этого на экране появится диалог настройки блокировки.

Описание элементов управления
Наименование | Описание
Зафиксировать габариты ячеек | Включите эту опцию, чтобы размеры ячеек таблицы нельзя было изменить.
Запретить изменять число строк | Включите эту опцию для фиксации текущего количества строк таблицы.
Запретить изменять число столбцов | Включите эту опцию для фиксации текущего количества колонок таблицы.

После завершения настройки блокировки таблицы нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


Команда Параметры...

Позволяет настроить различные системные параметры и параметры новых документов.

После вызова команды на экране появляется настроечный диалог.

Для изменения какой-либо группы настроек перейдите на нужную вкладку диалога, в ее правой части выберите название группы настроек, а в левой — установите нужные значения параметров.

Чтобы развернуть содержание какого-либо раздела, установите курсор на значке плюса рядом с заголовком раздела и щелкните левой кнопкой мыши. Повторный щелчок на символе (после разворачивания раздела он отображается как минус) приведет к сворачиванию содержания.

Для сохранения всех изменений и выхода из диалога нажмите кнопку ОК, для выхода без сохранения изменений — кнопку Отмена.


Команда Биссектриса(параметрическая связь)

Команда Биссектриса
(параметрическая связь)

Позволяет расположить объект (отрезок, стрелку взгляда и др.) на биссектрисе угла, образованного двумя прямолинейными объектами.

Для вызова команды нажмите кнопку Биссектриса на инструментальной панели Параметризация или выберите название из меню Инструменты — Параметризация — Прямые/отрезки.

Указывайте по три объекта в следующем порядке.

1. Сначала укажите два объекта, образующих угол. На экране появляется фантом биссектрисы угла.

Чтобы указать другие объекты, нажмите кнопку Указать заново.

Варианты биссектрис поочередно отображаются при нажатии кнопок Следующий объект и Предыдущий объект Панели специального управления.

2. После того как на экране появится нужный вариант биссектрисы, укажите размещаемый объект.

Если первые два объекта параллельны друг другу, то третий объект располагается посередине между ними.

Завершить преобразование объектов можно, нажав кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Наложение и снятие ограничений

Другие команды наложения ограничений

Отображение ограничений

Отображение степеней свободы

Общие сведения о параметризации

Непараметризуемые объекты


Команда Установить значение размера

Позволяет изменить числовое значение ассоциативного управляющего размера, зафиксировать размер или сделать его информационным, создать для размера переменную. Созданная таким образом переменная может участвовать в выражениях, определяющих зависимость между параметрами изображения.

Для вызова команды нажмите кнопку Установить значение размера на инструментальной панели Параметризация или выберите название из меню Инструменты — Параметризация.

Укажите размер, значение которого требуется установить, в появившемся диалоге введите новое значение размера (доступно для управляющих размеров) и/или имя переменной, включите или выключите опцию Информационный размер и нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.

Имя переменной может содержать буквы латинского алфавита (различаются символы верхнего и нижнего регистра), арабские цифры и символы подчеркивания («_»). Длина имени переменной не более 512 символов. Первый символ в имени переменной — буква или подчеркивание.

Значение неассоциированных (не имеющих привязки) размеров изменить невозможно. Операция изменения размера не будет выполнена также в случае, если перестроение изображения с учетом наложенных ограничений невозможно при указанном изменении размера. Если размер может быть только информационным, то его фиксация невозможна.

Чтобы завершить команду, нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Управляющие и информационные размеры. Размеры с переменными

Наложение и снятие ограничений

Другие команды наложения ограничений

Отображение ограничений

Отображение степеней свободы

Общие сведения о параметризации


Команда Коллинеарность

Позволяет установить коллинеарность выбранных отрезков или коллинеарность отрезка и прямой или коллинеарность двух прямых.

Для вызова команды нажмите кнопку Коллинеарность на инструментальной панели Параметризация или выберите название из меню Инструменты — Параметризация — Прямые/отрезки.

Указывайте попарно объекты для установления их коллинеарности.

После установления коллинеарности двух отрезков они располагаются на одной прямой. После установления коллинеарности отрезка и прямой отрезок располагается на этой прямой. После установления коллинеарности двух прямых эти прямые совпадают.

Вы можете расположить на одной прямой сразу несколько отрезков.

Для этого после указания первого из них нажмите кнопку Запомнить состояние на Панели специального управления. Затем укажите остальные отрезки.

Кнопка Указать заново позволяет выбрать другой отрезок в качестве первого отрезка для установления коллинеарности.

Завершить преобразование объектов можно, нажав кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Наложение и снятие ограничений

Другие команды наложения ограничений

Отображение ограничений

Отображение степеней свободы

Общие сведения о параметризации

Непараметризуемые объекты


Команда Удалить все ограничения

Позволяет удалить все ограничения выделенных объектов.

Если ни один объект не выделен, команда будет недоступна.

Для вызова команды нажмите кнопку Удалить все ограничения на инструментальной панели Параметризация или выберите название из меню Инструменты — Параметризация — Ограничения.

После этого все ограничения выделенных объектов удаляются.

Для завершения команды нажмите кнопку ОК в окне сообщения.


Команда Показать/удалить ограничения

Позволяет просмотреть ограничения выделенного объекта и удалить любые из них.

Если в документе нет ни одного параметризованного объекта, команда будет недоступна.

Для вызова команды нажмите кнопку Показать/удалить ограничения на инструментальной панели Параметризация или выберите название из меню Инструменты — Параметризация — Ограничения.

После этого на Панели свойств появляется окно с перечнем ограничений, наложенных на выбранный объект. При выделении какой-либо строки этого списка в окне документа подсвечиваются объекты, участвующие в выбранном ограничении.

Чтобы удалить выделенное ограничение, нажмите кнопку Удалить.

Чтобы просмотреть ограничения другого параметризованного объекта, укажите его мышью в окне документа.

Завершив просмотр связей и ограничений, нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.


Команда Равенство длин

Позволяет установить равные длины для выбранных отрезков.

Для вызова команды нажмите кнопку Равенство длин на инструментальной панели Параметризация или выберите название из меню Инструменты — Параметризация — Равенство.

Указывайте попарно отрезки для выравнивания их длин.

Вы можете установить равенство длин сразу для нескольких отрезков.

Для этого после указания первого из них нажмите кнопку Запомнить состояние на Панели специального управления. Затем укажите остальные отрезки.

Чтобы указать другой отрезок для выравнивания длины, нажмите кнопку Указать заново.

Чтобы завершить команду, нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Наложение и снятие ограничений

Другие команды наложения ограничений

Отображение ограничений

Отображение степеней свободы

Общие сведения о параметризации

Непараметризуемые объекты


Команда Равенство радиусов

Позволяет установить равные радиусы для выбранных дуг и окружностей.

Для вызова команды нажмите кнопку Равенство радиусов на инструментальной панели Параметризация или выберите название из меню Инструменты — Параметризация — Равенство.

Указывайте попарно дуги и окружности для выравнивания их радиусов.

Вы можете установить равенство радиусов сразу для нескольких дуг и/или окружностей.

Для этого после указания первой из них нажмите кнопку Запомнить состояние на Панели специального управления. Затем укажите остальные дуги и окружности.

Чтобы указать другую дугу или окружность для выравнивания радиуса, нажмите кнопку Указать заново.

Чтобы завершить команду, нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Наложение и снятие ограничений

Другие команды наложения ограничений

Отображение ограничений

Отображение степеней свободы

Общие сведения о параметризации

Непараметризуемые объекты


Команда Зафиксировать угол

Позволяет зафиксировать угол наклона объекта (отрезка, осевой линии, линии обрыва и др.). Во фрагменте угол наклона объекта фиксируется в абсолютной системе координат, а в чертеже — в системе координат вида, в котором находится объект.

Для вызова команды нажмите кнопку Зафиксировать угол на инструментальной панели Параметризация или выберите название из меню Инструменты — Параметризация — Зафиксировать.

Указывайте последовательно объекты для фиксации углов их наклона.

Завершить фиксацию можно, нажав кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Наложение и снятие ограничений

Другие команды наложения ограничений

Отображение ограничений

Отображение степеней свободы

Общие сведения о параметризации

Непараметризуемые объекты


Команда Зафиксировать размер

Позволяет зафиксировать значение выбранного ассоциативного линейного, диаметрального, радиального или углового размера.

Для вызова команды нажмите кнопку Зафиксировать размер на инструментальной панели Параметризация или выберите название из меню Инструменты — Параметризация — Зафиксировать.

Указывайте последовательно размеры для их фиксации. Признаком успешной фиксации является заключение размерной надписи в прямоугольную рамку бирюзового цвета.

Неассоциированные (не имеющие привязки) или избыточные размеры (вычисляемые с помощью поставленных ранее размеров) зафиксировать невозможно.

Завершить преобразование объектов можно, нажав кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Наложение и снятие ограничений

Другие команды наложения ограничений

Отображение ограничений

Отображение степеней свободы

Общие сведения о параметризации

Непараметризуемые объекты


Команда Зафиксировать длину

Позволяет зафиксировать длину отрезка или осевой линии.

Для вызова команды нажмите кнопку Зафиксировать длину на инструментальной панели Параметризация или выберите название из меню Инструменты — Параметризация — Зафиксировать.

Указывайте последовательно объекты для фиксации их длин.

Завершить фиксацию можно, нажав кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Наложение и снятие ограничений

Другие команды наложения ограничений

Отображение ограничений

Отображение степеней свободы

Общие сведения о параметризации

Непараметризуемые объекты


Команда Зафиксировать точку

Позволяет зафиксировать координаты характерных точек геометрических объектов (концов отрезков, дуг, центров дуг, окружностей и т.д.).

Для вызова команды нажмите кнопку Зафиксировать точку на инструментальной панели Параметризация или выберите название из меню Инструменты — Параметризация — Зафиксировать.

Указывайте характерные точки объектов для их фиксации. Признаком того, что координаты точки фиксированы, является отрисовка под ней специального значка — в виде треугольника.

Завершить преобразование объектов можно, нажав кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Наложение и снятие ограничений

Другие команды наложения ограничений

Отображение ограничений

Отображение степеней свободы

Общие сведения о параметризации

Непараметризуемые объекты


Команда Горизонтальность

Позволяет преобразовать наклонные объекты (отрезки, стрелки взгляда и др.) в горизонтальные.

Для вызова команды нажмите кнопку Горизонтальность на инструментальной панели Параметризация или выберите название из меню Инструменты — Параметризация — Прямые/отрезки.

После этого указывайте объекты, которые необходимо преобразовать. Выбранные объекты будут расположены параллельно оси OХ системы координат фрагмента или текущего вида.

Завершить преобразование объектов можно, нажав кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Наложение и снятие ограничений

Другие команды наложения ограничений

Отображение ограничений

Отображение степеней свободы

Общие сведения о параметризации

Непараметризуемые объекты


Команда Объединить точки

Позволяет привязать друг к другу характерные точки объектов.

Для вызова команды нажмите кнопку Объединить точки на инструментальной панели Параметризация или выберите название из меню Инструменты — Параметризация — Точки.

Указывайте попарно характерные точки объектов для объединения.

Если точка, которую требуется указать, совпадает с характерной точкой другого объекта (и поэтому невозможно выбрать точно ее, т.к. происходит привязка к точке другого объекта), вы можете вначале указать графический объект, которому принадлежит параметризуемая точка, а затем — саму точку.

Для этого нажмите кнопку Указать объект на Панели специального управления или выберите в контекстном меню команду Указать объект, затем точку. Выберите нужный объект и укажите его характерную точку.

Вы можете привязать друг к другу сразу несколько точек.

Для этого после указания первой из них нажмите кнопку Запомнить состояние на Панели специального управления. Затем укажите остальные точки.

Кнопка Указать заново позволяет выбрать другую точку в качестве первой точки для объединения.

Чтобы завершить команду, нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Наложение и снятие ограничений

Другие команды наложения ограничений

Отображение ограничений

Отображение степеней свободы

Общие сведения о параметризации

Непараметризуемые объекты


Команда Перпендикулярность

Позволяет установить перпендикулярность выбранных объектов (отрезков, стрелок взгляда и др.).

Для вызова команды нажмите кнопку Перпендикулярность на инструментальной панели Параметризация или выберите название из меню Инструменты — Параметризация — Прямые/отрезки.

Указывайте попарно объекты для установления их перпендикулярности.

Вы можете расположить сразу несколько объектов перпендикулярно выбранному.

Для этого после указания первого объекта нажмите кнопку Запомнить состояние на Панели специального управления. Затем укажите объекты, которые должны быть перпендикулярны выбранному.

Кнопка Указать заново позволяет выбрать другой объект в качестве первого для установления перпендикулярности.

Завершить преобразование объектов можно, нажав кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Наложение и снятие ограничений

Другие команды наложения ограничений

Отображение ограничений

Отображение степеней свободы

Общие сведения о параметризации

Непараметризуемые объекты


Команда Параллельность

Позволяет установить параллельность выбранных объектов (отрезков, стрелок взгляда и др.).

Для вызова команды нажмите кнопку Параллельность на инструментальной панели Параметризация или выберите название из меню Инструменты — Параметризация — Прямые/отрезки.

Указывайте попарно объекты для установления их параллельности.

Вы можете расположить сразу несколько объектов параллельно выбранному.

Для этого после указания первого объекта нажмите кнопку Запомнить состояние на Панели специального управления. Затем укажите объекты, которые должны быть параллельны выбранному.

Кнопка Указать заново позволяет выбрать другой объект в качестве первого для установления параллельности.

Завершить преобразование объектов можно, нажав кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Наложение и снятие ограничений

Другие команды наложения ограничений

Отображение ограничений

Отображение степеней свободы

Общие сведения о параметризации

Непараметризуемые объекты


Команда Точка на середине кривой

Позволяет привязать характерную точку объекта к середине отрезка или дуги окружности.

Для вызова команды нажмите кнопку Точка на середине кривой на инструментальной панели Параметризация или выберите название из меню Инструменты — Параметризация — Точки.

Указывайте попарно объекты — кривую, к середине которой выполняется привязка, а затем характерную точку.

Вы можете привязать к одной кривой несколько точек.

Для этого после указания кривой нажмите кнопку Запомнить состояние на Панели специального управления. Затем укажите нужные точки.

Чтобы указать другую кривую, нажмите кнопку Указать заново.

Чтобы завершить команду, нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Наложение и снятие ограничений

Другие команды наложения ограничений

Отображение ограничений

Отображение степеней свободы

Общие сведения о параметризации

Непараметризуемые объекты


Команда Точка на кривой

Позволяет привязать характерную точку объекта к кривой.

Для вызова команды нажмите кнопку Точка на кривой на инструментальной панели Параметризация или выберите название из меню Инструменты — Параметризация — Точки.

Указывайте попарно характерные точки объектов и кривые, к которым они должны быть привязаны.

Вы можете привязать к одной кривой несколько точек.

Для этого после указания кривой нажмите кнопку Запомнить состояние на Панели специального управления. Затем укажите нужные точки.

Чтобы указать другую кривую, нажмите кнопку Указать заново.

Чтобы завершить команду, нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Наложение и снятие ограничений

Другие команды наложения ограничений

Отображение ограничений

Отображение степеней свободы

Общие сведения о параметризации

Непараметризуемые объекты


Команда Симметрия двух точек

Позволяет установить симметрию характерных точек объектов относительно отрезка (зеркальную симметрию).

Для вызова команды нажмите кнопку Симметрия двух точек на инструментальной панели Параметризация или выберите название из меню Инструменты — Параметризация — Точки.

Укажите ось симметрии, а затем — пару характерных точек объектов, которые должны быть симметричны.

Если несколько пар точек должны быть симметричны относительно одного отрезка, можно после указания этого отрезка нажать кнопку Запомнить состояние на Панели специального управления, а затем указывать пары симметричных точек.

Для выбора другого отрезка в качестве оси симметрии отожмите кнопку Указать заново.

Чтобы завершить команду, нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Наложение и снятие ограничений

Другие команды наложения ограничений

Отображение ограничений

Отображение степеней свободы

Общие сведения о параметризации

Непараметризуемые объекты


Команда Параметризовать объекты

Позволяет автоматически наложить на выделенные объекты связи и ограничения.

Если ни один объект не выделен, команда будет недоступна.

Для вызова команды нажмите кнопку Параметризовать объекты на инструментальной панели Параметризация или выберите название из меню Инструменты — Параметризация.

После этого на экране появится диалог, в котором можно выбрать ограничения и связи, которые требуется наложить на выделенные объекты, и задать допуски для совпадения точек и отклонений углов наклона.

После закрытия диалог нажатием кнопки OK система автоматически наложит на выделенные объекты указанные ограничения.

При большом количестве выделенных объектов время выполнения команды может быть длительным.

Смотрите также

Наложение и снятие ограничений

Другие команды наложения ограничений

Общие сведения о параметризации

Непараметризуемые объекты


Команда Отображать ограничения

Позволяет показать на экране значки, символизирующие ограничения, наложенные на графические объекты.

Для вызова команды нажмите кнопку Отображать ограничения на инструментальной панели Параметризация или выберите название из меню Инструменты — Параметризация — Ограничения.

После вызова команды на экране появятся значки ограничений. Пока кнопка Отображать ограничения нажата, ограничения показываются. Чтобы выключить показ значков, отожмите кнопку. Обратите внимание на то, что данная настройка распространяется только на текущее окно. В другом окне (в том числе в новом окне текущего документа) отображение ограничений может быть включено или выключено независимо от текущего окна.

Отображение ограничений в чертежах и фрагментах по умолчанию выключено, а в эскизах — включено. Значки, показывающие ограничения, отображаются только для объектов, лежащих в текущем виде.

Вы можете выбрать цвет значков и включить (выключить) постоянное отображение переменных, рамок зафиксированных размеров и значков фиксированных точек в диалоге настройки символов ограничений и степеней свободы.


Команда Отображать степени свободы

Позволяет показать на экране значки, символизирующие степени свободы, имеющиеся у графических объектов.

Для вызова команды нажмите кнопку Отображать степени свободы на инструментальной панели Параметризация или выберите название из меню Инструменты — Параметризация — Ограничения.

После вызова команды на экране появятся значки степеней свободы. Пока кнопка Отображать степени свободы нажата, степени свободы показываются. Чтобы выключить показ значков, отожмите кнопку. Обратите внимание на то, что данная настройка распространяется только на текущее окно. В другом окне (в том числе в новом окне текущего документа) отображение ограничений может быть включено или выключено независимо от текущего окна.

Значки, показывающие степени свободы, отображаются только для объектов, лежащих в текущем виде.

В чертежах и фрагментах степени свободы отображаются только у тех объектов, которые имеют ограничения, в то время как в эскизах отображаются степени свободы всех объектов.

Вы можете выбрать цвет значков в диалоге настройки символов ограничений и степеней свободы.


Команда Касание

Позволяет установить касание выбранных кривых.

Для вызова команды нажмите кнопку Касание на инструментальной панели Параметризация или выберите название из меню Инструменты — Параметризация.

Укажите первую и вторую кривые, касание которых требуется установить. Если этому не препятствуют уже наложенные на объекты связи и ограничения, произойдет перестроение изображения, после которого указанные кривые будут касаться. При этом могут измениться числовые значения, характеризующие одну или обе кривые (например, радиус окружности или координаты концов отрезка).

Вы можете установить сразу нескольких кривых с выбранной кривой.

Для этого после указания первой кривой нажмите кнопку Запомнить состояние на Панели специального управления. Затем укажите кривые, которые должны касаться выбранной кривой.

Чтобы указать другую кривую, нажмите кнопку Указать заново.

Завершить преобразование объектов можно, нажав кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

При наложении связи касание на NURBS обратите внимание на следующие особенности:

– точкой касания NURBS с другой кривой является точка, в которой NURBS был указан,

– если требуется, чтобы точкой касания была крайняя точка NURBS, до наложения связи следует разместить эту точку на кривой, которой должен касаться NURBS (наложение связи принадлежность точки кривой не обязательно).

Смотрите также

Наложение и снятие ограничений

Другие команды наложения ограничений

Отображение ограничений

Отображение степеней свободы

Общие сведения о параметризации

Непараметризуемые объекты


Команда Вертикальность

Позволяет преобразовать наклонные объекты (отрезки, стрелки взгляда и др.) в вертикальные.

Для вызова команды нажмите кнопку Вертикальность на инструментальной панели Параметризация или выберите название из меню Инструменты — Параметризация — Прямые/отрезки.

После этого указывайте объекты, которые необходимо преобразовать. Выбранные объекты будут расположены параллельно оси OY системы координат фрагмента или текущего вида.

Чтобы завершить команду, нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Наложение и снятие ограничений

Другие команды наложения ограничений

Отображение ограничений

Отображение степеней свободы

Общие сведения о параметризации

Непараметризуемые объекты


Команда Выровнять точки по горизонтали

Позволяет выровнять по горизонтали характерные точки объектов.

Для вызова команды нажмите кнопку Выровнять точки по горизонтали на инструментальной панели Параметризация или выберите название из меню Инструменты — Параметризация — Точки.

Указывайте попарно характерные точки объектов для выравнивания.

Если точка, которую требуется указать, совпадает с характерной точкой другого объекта (и поэтому невозможно выбрать точно ее, т.к. происходит привязка к точке другого объекта), вы можете вначале указать графический объект, которому принадлежит параметризуемая точка, а затем — саму точку.

Для этого нажмите кнопку Указать объект на Панели специального управления или выберите в контекстном меню команду Указать объект, затем точку. Выберите нужный объект и укажите его характерную точку.

Вы можете расположить на одной горизонтали сразу несколько точек.

Для этого после указания первой из них нажмите кнопку Запомнить состояние на Панели специального управления. Затем укажите остальные точки.

Кнопка Указать заново позволяет выбрать другую точку в качестве первой точки для выравнивания.

Чтобы завершить команду, нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Наложение и снятие ограничений

Другие команды наложения ограничений

Отображение ограничений

Отображение степеней свободы

Общие сведения о параметризации

Непараметризуемые объекты


Команда Выровнять точки по вертикали

Позволяет выровнять по вертикали характерные точки объектов.

Для вызова команды нажмите кнопку Выровнять точки по вертикали на инструментальной панели Параметризация или выберите название из меню Инструменты — Параметризация — Точки.

Указывайте попарно характерные точки объектов для выравнивания.

Если точка, которую требуется указать, совпадает с характерной точкой другого объекта (и поэтому невозможно выбрать точно ее, т.к. происходит привязка к точке другого объекта), вы можете вначале указать графический объект, которому принадлежит параметризуемая точка, а затем — саму точку.

Для этого нажмите кнопку Указать объект на Панели специального управления или выберите в контекстном меню команду Указать объект, затем точку. Выберите нужный объект и укажите его характерную точку.

Вы можете расположить на одной вертикали сразу несколько точек.

Для этого после указания первой из них нажмите кнопку Запомнить состояние на Панели специального управления. Затем укажите остальные точки.

Кнопка Указать заново позволяет выбрать другую точку в качестве первой точки для выравнивания.

Чтобы завершить команду, нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Наложение и снятие ограничений

Другие команды наложения ограничений

Отображение ограничений

Отображение степеней свободы

Общие сведения о параметризации

Непараметризуемые объекты


Команда Параметрический режим

Служит для включения и отключения в текущем документе параметрического режима.

Кнопка Параметрический режим находится на панели Текущее состояние и является индикатором режима: нажатая кнопка означает, что параметрический режим включен, отжатая — выключен.

По умолчанию после вызова команды Параметрический режим включается ассоциативность всех объектов, параметризация всех построений и фиксация размеров. Умолчательную настройку параметрического режима можно изменить в диалоге управления параметризацией.

Когда параметрический режим включен, связи и ограничения накладываются на объекты автоматически.

При отключенном параметрическом режиме возможно ручное наложение на объекты связей и ограничений с помощью специальных команд.


Команда Указать объект, затем точку

Позволяет указать объект, которому принадлежит параметризуемая точка.

Такое указание может потребоваться, если параметризуемая точка совпадает с характерной точкой другого объекта (и поэтому невозможно выбрать точно ее, т.к. происходит привязка к точке другого объекта).

Для вызова команды нажмите кнопку Указать объект на Панели специального управления.

Выберите нужный объект и укажите его характерную точку.


Команда Восстановить связь

Команда позволяет восстановить отмененную ранее связь объекта зависимого исполнения с соответствующим объектом исходного исполнения. После восстановления связи и перестроения модели объект зависимого исполнения становится идентичным соответствующему объекту исходного исполнения. Изменения, произведенные с объектом зависимого исполнения до восстановления связи, не сохраняются.


Команда Отменить связь

Команда позволяет отменить связь объекта зависимого исполнения с соответствующим объектом исходного исполнения. При этом объект зависимого исполнения станет доступным для изменения и удаления.


Размещение на слоях

Группа переключателей, управляющая размещением объектов многослойного фрагмента.

Выбор варианта На текущий слой означает, что все изображение будет расположено на одном (текущем) слое фрагмента или вида чертежа.

Выбор варианта На слои-источники означает, что во фрагменте или в текущем виде чертежа будет создано столько же слоев для размещения объектов, сколько во вставляемом фрагменте.


Команда Заплатка

Позволяет создать поверхность, ограниченную замкнутым контуром. Сегментами контура могут быть ребра тел и поверхностей, контуры эскизов, пространственные кривые.

Пример

Требования к контуру заплатки

Для вызова команды нажмите кнопку Заплатка на инструментальной панели Поверхности или выберите ее название из меню Операции.

Укажите в окне модели сегменты контура в порядке их соединения.

Если контур, ограничивающий заплатку, расположен в одном эскизе, укажите этот эскиз в Дереве построения или в окне модели.

Выбранные объекты будут подсвечены в окне модели и в Дереве построения.

Список объектов, составляющих контур, появится на Панели свойств. Кнопка Удалить, расположенная над списком, позволяет исключить какой-либо объект из контура. Для исключения объекта можно также повторно указать его. Выделение с исключенного объекта будет снято.

Для включения проверки поверхности на самопересечения активизируйте опцию Проверка самопересечений. В случае обнаружения самопересечений созданная поверхность будет отмечена в Дереве как ошибочная.

Чтобы подтвердить выполнение операции, нажмите кнопку Создать объект на Панели специального управления. Созданная заплатка появится в окне модели, а соответствующая ей пиктограмма — в Дереве построения.

Обратите внимание на то, что кнопка Создать объект доступна, если указанные объекты образуют замкнутую цепочку.

Прервать создание поверхности можно, нажав кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Другие команды создания поверхностей


Команда Загрузить конфигурацию плоттера/принтера...

Команда позволяет загрузить конфигурацию плоттера/принтера для печати документов из окна предварительного просмотра. Команда вызывается следующими способами:

– в основном окне — из меню Файл — Настройки предварительного просмотра или меню кнопки Предварительный просмотр, расположенной на Стандартной панели,

– в режиме предварительного просмотра — из меню Файл — Конфигурация плоттера/принтера.

После вызова команды на экране появляется стандартный диалог выбора файла.

Укажите нужный файл конфигурации (файл с расширением pdc) и нажмите кнопку Открыть.

Если вы недавно сохраняли или загружали файл конфигурации, то можете выбрать его имя из списка последних файлов конфигураций.

При загрузке файла конфигурации текущее устройство печати заменяется устройством печати, указанным в файле; размер бумаги и параметры страницы получают значения из файла. Все остальные параметры печати остаются без изменения. Данные параметры необходимо настраивать вручную.

Вы можете изменять настройки, переданные из файла конфигурации. Данные изменения не сохраняются в файл.

Возможные проблемы при загрузке конфигурации

Смотрите также

Команда Сохранить конфигурацию плоттера/принтера...


Команда Сохранить конфигурацию плоттера/принтера...

Команда позволяет сохранить конфигурацию устройства печати, заданного для режима предварительного просмотра. Команда вызывается следующими способами:

– в главном окне — из меню Файл — Настройки предварительного просмотра или меню кнопки Предварительный просмотр, расположенной на Стандартной панели,

– в режиме предварительного просмотра — из меню Файл — Конфигурация плоттера/принтера.

После вызова команды на экране появляется стандартный диалог сохранения файла.

Введите нужное имя файла и нажмите кнопку Сохранить. По умолчанию именем файла конфигурации является имя текущего устройства печати.

Смотрите также

Команда Загрузить конфигурацию плоттера/принтера...


Команда Длина кривой

Позволяет измерить полную длину произвольной кривой.

Для вызова команды нажмите кнопку Длина кривой на инструментальной панели Измерения или выберите ее из меню Сервис — Измерить.

После этого укажите кривую, длину которой требуется определить.

Вы можете быстро просмотреть результаты измерения, а можете внести их в Информационное окно.

При быстром просмотре результатов измерения рядом с курсором отображается значение длины указанной кривой. Это же значение отображается в Информационном окне.

Вы можете просмотреть значения длин других кривых, подведя к ним курсор. Для внесения результатов измерений в Информационное окно последовательно щелкайте по этим кривым мышью.

Указанные объекты подсвечиваются. В Информационное окно добавляется список измеренных длин. В конце списка указана сумма всех измеренных значений.

Чтобы исключить какую-либо кривую из списка, укажите ее повторно. Выделение с этой кривой будет снято, запись о ее длине будет удалена из окна, а сумма длин — вычислена заново.

Если требуется вычислить суммарную длину объектов (отрезков, дуг, сплайнов) или их частей, составляющих непрерывную последовательность, нажмите кнопку Обход границы по стрелке на Панели специального управления. Система перейдет в режим обхода границы по стрелке. Сформируйте нужную фигуру. После формирования фигуры результат измерения появится в Информационном окне.

Если требуется измерить длину временной (несуществующей в чертеже) ломаной, нажмите кнопку Ручное рисование границ на Панели специального управления. Система перейдет в режим ручного рисования границ. Сформируйте нужную фигуру. После формирования фигуры результат измерения появится в Информационном окне.

Управление параметрами процесса измерения производится с помощью элементов Панели свойств. Описание элементов — см. в таблице.

Вы можете сохранить или распечатать результаты измерения. Для этого воспользуйтесь командами меню Информационного окна.

Для выхода из команды нажмите кнопку Прервать команду, клавишу <Esc> или закройте Информационное окно.


Команда Перпендикулярная прямая

Позволяет построить прямую, перпендикулярную выбранному объекту.

Для вызова команды нажмите кнопку Перпендикулярная прямая на инструментальной панели Геометрия.

Укажите курсором объект, которому должна быть пепрендикулярна прямая.

Затем задайте точку, через которую должна пройти создаваемая прямая.

На экране будут показаны фантомы всех вариантов прямых, перпендикулярных выбранному объекту и проходящих через указанную точку.

Выберите нужный фантом мышью или с помощью кнопок Следующий объект и Предыдущий объект на Панели специального управления.

Затем зафиксируйте выбранную прямую, щелкнув по ней мышью или нажав кнопку Создать объект на Панели специального управления.

Построение прямой, перпендикулярной сплайну

Простановка точек пересечений

Управление количеством прямых производится с помощью переключателя Количество прямых на Панели свойств.

Чтобы быстро построить несколько прямых, перпендикулярных одному и тому же объекту, сделайте следующее. Указав объект, нажмите кнопку Запомнить состояние. После этого последовательно постройте нужное количество прямых, указывая принадлежащие им точки.

Подробнее о запоминании параметров...

Чтобы перейти к построению прямых, перпендикулярных другому объекту, нажмите кнопку Выбор объекта на Панели специального управления, а затем укажите курсором нужный объект.

Для выхода из команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие геометрические объекты


Команда Перпендикулярный отрезок

Позволяет построить один или несколько отрезков, перпендикулярных другим объектам.

Для вызова команды нажмите кнопку Перпендикулярный отрезок на инструментальной панели Геометрия.

Укажите объект, перпендикулярно которому должен пройти отрезок.

Задайте начальную (т1) и конечную (т2) точки отрезка.

Для точного позиционирования курсора воспользуйтесь привязками или меню геометрического калькулятора в полях т1 и т2 на Панели свойств.

Построение отрезка, перпендикулярного дуге

Выбор стиля линии

Можно построить несколько отрезков, перпендикулярных указанному объекту, не выходя из команды.

Вы можете построить несколько отрезков одной длины, перпендикулярных указанному объекту. Для этого действуйте следующим образом. Указав объект, введите в поле Длина нужно значение и нажмите кнопку Запомнить состояние на Панели специального управления. Затем последовательно постройте нужное количество отрезков, указывая их начальные (конечные) точки.

Чтобы перейти к построению отрезков, перпендикулярных другому объекту, нажмите кнопку Выбор объекта на Панели специального управления, а затем укажите курсором нужный объект.

Для выхода из команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие геометрические объекты


Команда Отображение — Перспектива

Позволяет включить или выключить отображение модели в перспективной проекции.

Для вызова команды нажмите кнопку Перспектива на панели Режимы или выберите ее название из меню Вид.

Все типы отображения (каркасное, полутоновое, без невидимых линий и с тонкими невидимыми линиями) можно сочетать с перспективной проекцией.

Степень вносимого перспективой искажения изображения можно изменить. Для этого служит диалог настройки параметров перспективной проекции.


Команда Настроить параметры

Позволяет вызвать диалог Перспективная проекция. В диалоге настраивается степень вносимого перспективой искажения. Для вызова команды выберите ее название из меню кнопки Перспектива на панели Режимы.


Команда Параметры вставки...

Позволяет изменить параметры вставки графического документа или растрового изображения в текст или таблицу.

Команда доступна в контекстном меню выделенной вставки.

После вызова команды на экране появляется диалог, в котором можно отредактировать размер, угол поворота и другие свойства вставки, а также сменить ее источник (для вставок, сделанных внешней ссылкой).

Диалог параметров вставки иллюстрации в текст...

Диалог параметров вставки иллюстрации в ячейку таблицы...

Для быстрого вызов диалога параметров вставки дважды щелкните на ней мышью.


Команда Загрузить задание на печать...

Команда позволяет загрузить задание на печать.

Чтобы загрузить задание на печать из главного окна, вызовите команду Задание на печать — Загрузить... из меню Файл или из меню кнопки Предварительный просмотр на Стандартной панели. На экране появится стандартный диалог открытия файла. Выберите имя нужного файла и нажмите кнопку Открыть. Произойдет автоматический переход в режим предварительного просмотра, в котором отобразятся листы документов задания.

Если вы недавно сохраняли или загружали задание на печать, то можете выбрать его имя из списка заданий.

Чтобы вызвать загрузку задания на печать из окна предварительного просмотра, вызовите команду Загрузить задание на печать... из меню Файл или нажмите одноименную кнопку на инструментальной панели. В этом случае после стандартного диалога открытия файла на экране появится диалог выбора варианта добавления листов документов. Для продолжения загрузки выберите один из предлагаемых в диалоге вариантов добавления листов документов задания. Для прекращения загрузки нажмите кнопку Отмена.

После загрузки задания на печать в режиме предварительного просмотра можно работать как обычно: изменять текущие настройки, удалять или перемещать листы документов и т.п.

Произведенные изменения не сохраняются в файле задания на печать. При необходимости вы можете сохранить текущие настройки в новом файле задания или перезаписать существующий.

Возможные проблемы при загрузке задания

Смотрите также

Команда Сохранить задание на печать...


Команда Сохранить задание на печать...

Команда позволяет сохранить задание на печать.

Чтобы сохранить задание на печать, вызовите команду Сохранить задание на печать... из меню Файл или нажмите одноименную кнопку на инструментальной панели. На экране появится стандартный диалог сохранения файла. Введите имя файла и нажмите кнопку Сохранить. По умолчанию файлу задания присваивается имя «Задание на печать».

Подробнее...

Смотрите также

Команда Загрузить задание на печать...


Команда Разместить производные размеры

Позволяет для размеров, представленных в виде элементов оформления (производных размеров), изменить плоскость размещения или отменить сделанные изменения и разместить размеры в плоскостях, в которых они находились сразу после создания.

Плоскость, в которой производный размер находится сразу после создания, называется исходной плоскостью. Эта плоскость определяется системой автоматически.

Новая плоскость размещения размеров называется базовой плоскостью. В качестве базовой плоскости может использоваться:

– координатная или вспомогательная плоскость;

– плоская грань.

Подробнее о размещении производных размеров...

1. Для вызова команды нажмите кнопку Разместить производные размеры на инструментальной панели Элементы оформления или выберите ее название из меню Редактор.

2. Сформируйте набор производных размеров, размещение которых требуется изменить. Для этого укажите в Дереве построения или в окне модели нужные размеры.

Выбор объектов в окне модели
Выбор объектов в Дереве построения

Производные размеры могут быть выделены и перед вызовом команды.

Указанные размеры выделяется цветом, а на панели Список размеров появляются их наименования. Повторное указание размера отменяет его выбор.

– Чтобы выбрать сразу все производные размеры, нажмите кнопку Выделить все размеры на панели Список размеров.

– Чтобы сменить размеры, нажмите кнопку Указать заново на Панели специального управления и повторите выбор размеров.

– Чтобы удалить размер из набора, выделите его название в списке размеров на панели Список размеров и нажмите кнопку Удалить.

3. Задайте плоскость размещения для размеров набора с помощью группы переключателей Базовая плоскость на Панели свойств.
Условия размещения производных размеров в базовой плоскости...

– Активизируйте переключатель Автоопределение, чтобы разместить размеры набора в их исходных плоскостях.

– Чтобы разместить размеры набора в новой плоскости, активизируйте переключатель Ручное указание.

После активизации переключателя станет доступен переключатель Базовая плоскость.

Активизируйте переключатель и укажите в окне модели нужную плоскость или плоскую грань. Указанный объект выделяется цветом, а его имя отображается в поле Плоскость на Панели свойств.

4. Если необходимо задать траекторию перемещения производных размеров, активизируйте переключатель Траектория. Укажите в окне модели нужное ребро или кривую. Указанный объект выделяется цветом, а его имя отображается в поле Траектория на Панели свойств.

5. Для выбора нужного варианта размещения нажмите кнопку Следующий объект или Предыдущий объект Панели специального управления. Кнопки доступны, если при размещении одного производного размера существует несколько вариантов размещения.

6. Завершив настройку размещения размеров, нажмите кнопку Создать объект на Панели специального управления.

Размеры размещаются в соответствии с выполненной настройкой:

– Если выбрано автоопределение плоскости расположения размеров, то каждый размер набора размещается в своей исходной плоскости, наименования всех размеров набора удаляются из панели Список размеров.

– Если задана базовая плоскость, то размеры набора размещаются в заданной плоскости, линии проекций размеров и линии, условно показывающие образмеренные объекты, показываются на экране соединительными линиями. Наименования размеров удаляются из панели Список размеров.
Если после нажатия кнопки Создать объект на панели Список размеров остаются наименования размеров, это означает, что эти размеры невозможно разместить в указанной плоскости. На экране появляется сообщение об этом, а размеры остаются в своих текущих базовых плоскостях (или исходных плоскостях). Выделение таких размеров не отменяется. Вы можете задать для них другую базовую плоскость.

За один вызов команды Разместить производные размеры можно сменить плоскость расположения произвольному количеству размеров.

Для отказа от размещения размеров нажмите клавишу <Esc> или кнопку Прервать команду.

Обратите внимание на то, что соединительные линии размеров отображаются на экране, если в диалоге настройки отображения размеров и обозначений включена опция Соединительные линии. Особенность размеров, перемещенных по траектории: для них отображаются только линии, показывающие образмеренные объекты, а линии проекций не отображаются.


Размещение таблиц

Процесс размещения таблиц в документе является продолжением работы следующих команд:

– Создать отчет;

– Создать таблицу исполнений;

– Создать отчет по массиву с таблицей изменяемых переменных.

Процесс размещения таблиц запускается автоматически.

– При создании отчета запуск процесса осуществляется:

• после нажатия кнопки Создать отчет на Панели специального управления, если на вкладке Отчеты неактивен переключатель Окно подготовки данных;

• в Окне подготовки данных:

- после нажатия кнопки Создать отчет на Панели специального управления Окна подготовки данных,

- после вызова команды Передать отчет в документ,

- после вызова команды Передать в документ выделенное.

– При создании таблицы исполнений процесс размещения таблиц запускается:

• после нажатия кнопки Создать объект на Панели специального управления, если для создания таблицы исполнений используется ассоциативный вид с модели,

• после открытия графического документа, в котором должна быть размещена таблицы исполнений, если для ее создания используется модель.

– При создании таблицы отчета по массиву процесс размещения таблиц запускается после открытия графического документа, в котором должна быть размещена таблица.

Укажите место расположения точки привязки таблицы курсором или путем ввода координат на Панели свойств.

После фиксации размещения таблицы:

– для отчета — происходит возврат в процесс создания отчета,

– для таблицы исполнений — происходит завершение процесса создания таблицы; если таблица создавалась для модели, активным вновь становится документ-модель, при этом графический документ, в который вставлена таблица, остается открытым,

– для таблицы отчета по массиву — происходит завершение процесса создания таблицы; графический документ, в который вставлена таблица, остается открытым.

Чтобы прервать размещение таблицы, нажмите кнопку Прервать команду на Панели специального управления.

При необходимости вы можете запустить процесс размещения таблицы для ранее созданного отчета, таблицы исполнений или таблицы отчета по массиву. Для этого вызовите из контекстного меню отчета/таблицы исполнений команду Изменить точку привязки.


Команда Пластина

Позволяет добавить к листовому телу пластину.

Команда Пластина доступна, если выделен один эскиз.

Пример

Требования к эскизу пластины

Чтобы вызвать команду, нажмите кнопку Пластина на панели Элементы листового тела или выберите ее название из меню Операции — Элементы листового тела.

После вызова команды в окне модели появится фантомное изображение создаваемой пластины. Стрелкой показано направление выдавливания. Это направление определяется системой автоматически.

Список Объект толщины на вкладке Параметры Панели свойств позволяет указать, будет ли толщина пластины совпадать с текущей толщиной листового тела или будет равна постоянной величине, заданной пользователем.

Раскройте список Объект толщины и выберите из него нужное листовое тело. Толщина выбранного тела отобразится в справочном поле Толщина.

Если требуется задать произвольную толщину пластины, выберите в списке Объект толщины строку Без объекта. Поле Толщина станет доступно для редактирования. Введите в него нужное значение.

При необходимости вы можете назначить допуски на значения параметров операции, выраженных в линейных или угловых величинах. Для этого используйте кнопку Назначить допуск, расположенную на Панели свойств рядом с полем числового параметра операции.
Подробнее о допусках...
Подробнее о назначении допуска...

Чтобы подтвердить формирование пластины в листовом теле, нажмите кнопку Создать объект на Панели специального управления.

В окне модели появится созданная пластина, а в Дереве построения — соответствующая пиктограмма.

исходное состояние детали и эскиз пластины | результат операции

Если пластина полностью или частично перекрывает сгиб, то его разгибание делается невозможным.

Смотрите также

Особенности задания числовых параметров операции в полях Панели свойств


Группа переключателей Направление

Позволяет выбрать вершину кривой, расстояние от которой до текущей крайней точки группы или угол между вершиной кривой и текущей крайней точкой группы, отображается в полях % от длины кривой, Длина сегмента или Угол.


Команда Точка (граф. документ)

Команда Точка
(граф. документ)

Позволяет построить произвольно расположенную точку.

Для вызова команды нажмите кнопку Точка на инструментальной панели Геометрия.

Задайте положение точки.

Для точного позиционирования курсора воспользуйтесь привязками или меню геометрического калькулятора для поля т на Панели свойств.

Выбор стиля точки

Для выхода из команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие геометрические объекты


Команда Точки по кривой

Позволяет построить нескольких точек, равномерно расположенных на какой-либо кривой.

Для вызова команды нажмите кнопку Точки по кривой на инструментальной панели Геометрия.

В поле Количество участков на Панели свойств введите количество участков, на которые проставленные точки должны разбить кривую. Затем укажите курсором кривую для простановки точек.

Если кривая не замкнута, точки будут построены сразу после ее указания. Первая точка будет совпадать с начальной точкой кривой, последняя — с конечной.

Если кривая замкнута, то после ее указания требуется задать положение первой точки на ней (определить точку т1).

Если указанная точка не принадлежит выбранной кривой, то положение первой точки будет определяться проекцией указанной точки на кривую.

Равномерная простановка 5 точек по эллипсу

Выбор стиля точки

Для выхода из команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие геометрические объекты


Команда Точка на заданном расстоянии

Позволяет построить точки на кривой, находящиеся на заданном расстоянии от указанной точки на этой кривой (базовой точки) и друг от друга.

Для вызова команды нажмите кнопку Точка на заданном расстоянии на инструментальной панели Геометрия.

В поле Количество точек на Панели свойств задайте количество точек, которые требуется создать.

Укажите курсором кривую для простановки точек.

Если вы случайно ошиблись при выборе объекта, нажмите кнопку Указать заново на Панели специального управления и выберите другую кривую.

Укажите базовую точку на кривой — точку т1.

Если указанная точка не принадлежит выбранной кривой, то положение базовой точки будет определяться проекцией указанной точки на кривую.

В поле Расстояние введите расстояние между базовой точкой и первой создаваемой точкой. Если создается несколько точек, то указанное значение будет определять также расстояния между ними.

При перемещении курсора в разные стороны от базовой точки на экране отображаются фантомы точки (точек), которые могут быть построены. Зафиксируйте нужный фантом, щелкнув по нему мышью.

Простановка точек вдоль дуги

на заданном расстоянии базовой точки

Выбор стиля точки

Для выхода из команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие геометрические объекты


Кнопка Сеть точек по поверхности

Позволяет построить поверхность по сети точек, которая аппроксимирует какую-либо из существующих в модели поверхностей.

Кнопка Сеть точек по поверхности находится на Панели специального управления. Кнопка доступна, когда не задана ни одна точка сети, т.е. сразу после вызова команды или после нажатия кнопки Указать заново.

После нажатия кнопки Сеть точек по поверхности укажите в окне модели грань или плоскость для аппроксимации. На экране появится фантом поверхности и ее точек.

Подробнее о построении сети точек по поверхности...


Команда Многоугольник

Позволяет построить правильный многоугольник

Для вызова команды нажмите кнопку Многоугольник на инструментальной панели Геометрия.

В поле Количество вершин на Панели свойств введите или выберите из списка число вершин многоугольника.

С помощью переключателя Способ укажите способ построения многоугольника: по вписанной или по описанной окружности.

Укажите точку центра базовой окружности.

Затем укажите точку т — положение одной из вершин (при построении по описанной окружности) или середины одной из сторон (при построении по вписанной окружности) создаваемого многоугольника.

Радиус базовой окружности и угол наклона многоугольника будут определены автоматически.

Построение многоугольника по

вписанной и описанной окружностям

Выбор стиля линии

Группа переключателей Оси на Панели свойств управляет отрисовкой осей симметрии многоугольника. Если отрисовка осей включена, то при четном числе сторон многоугольника формируются оси обычного размера, а при нечетном — обозначение центра в виде «крестика».

За один вызов команды можно построить произвольное число многоугольников.

Для выхода из команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Обратите внимание на то, что многоугольник, построенный в графическом документе, — это единый объект, а не набор отдельных отрезков. Он будет выделяться, редактироваться и удаляться целиком. Многоугольник же, построенный в эскизе трехмерного элемента, — это, наоборот, набор отдельных отрезков. На каждый из них наложены связи и ограничения, благодаря которым отрезки составляют многоугольник.

Смотрите также

Другие геометрические объекты


Способ построения многоугольника

Переключатель, позволяющий указать способ построения многоугольника: по вписанной или по описанной окружности.


Команда Ломаная(графический документ)

Команда Ломаная
(графический документ)

Позволяет построить ломаную линию.

Для вызова команды нажмите кнопку Ломаная на инструментальной панели Геометрия.

Последовательно указывайте вершины создаваемой ломаной.

Для точного позиционирования курсора воспользуйтесь привязками или меню геометрического калькулятора для поля т на Панели свойств.

Каждая вершина ломаной характеризуется набором параметров, которые отображаются в таблице Координаты вершин. С помощью элементов управления таблицей и команд контекстного меню таблицы вы можете изменять параметры существующих вершин.

Группа переключателей Режим позволяет указать, требуется замыкать ломаную или нет.

Вы можете изменить конфигурацию ломаной, не выходя из команды. Для этого нажмите кнопку Редактировать точки на Панели специального управления. Система перейдет в режим редактирования характерных точек объекта. Внесите необходимые изменения. Если требуется продолжить указание вершин, отожмите кнопку Редактировать точки.

Построение ломаной

Выбор стиля линии

Для фиксации созданной ломаной нажмите кнопку Создать объект на Панели специального управления.

Для выхода из команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Обратите внимание на то, что ломаная, построенная в графическом документе, — это единый объект, а не набор отдельных отрезков. Она будет выделяться, редактироваться и удаляться целиком. Ломаная же, построенная в эскизе трехмерного элемента, — это, наоборот, набор отдельных отрезков. На каждый из них наложены связи и ограничения, благодаря которым отрезки составляют ломаную.

Смотрите также

Другие геометрические объекты


Меню чисел

Меню, содержащее числа для использования в обозначениях. Служит для быстрого ввода текста обозначения, если этот текст состоит из одного числа от 1 до 99.

Вызов меню чисел возможен:

– из поля Текст на Панели свойств — одинарным щелчком правой кнопки мыши,

– из диалога ввода текста обозначения — двойным щелчком левой кнопки мыши.

При создании координационных осей возможен ввод как цифр, так и букв. Поэтому после выполнения любого из вышеуказанных действий на экране сначала появляется меню, содержащее команды Цифра и Буква. Чтобы перейти к меню чисел, выберите команду Цифра.

При создании координационных осей возможно автопродолжение нумерации. Для этого активизируйте переключатель Автопродолжение.


Меню слоев

Меню слоев служит для переноса объекта на другой слой в модели.

Содержит системный и пользовательские слои. Текущий слой отмечен «галочкой» слева от его имени.

Меню доступно при вызове команды Слой объекта из контекстного меню, если выделен один объект.

Чтобы сменить слой объекта, выберите нужный слой из меню. Если требуется создать и выбрать новый слой, используйте команду Изменить слой.


Список марок(контекстное меню поля Текст)

Список марок
(контекстное меню поля Текст)

Содержит все марки, созданные в документе. Находится в контекстном меню поля Текст.

Чтобы создать марку с уже существующим текстовым обозначением, вызовите контекстное меню поля Текст и в появившемся списке выберите нужную марку. В режиме автонумерации ей будет присвоен очередной номер.

Смотрите также

Команда Текст надписи


Меню букв

Меню, содержащее буквы для использования в обозначениях координационных осей. Служит для быстрого ввода текста обозначения, если этот текст состоит из одной буквы.

Вызов меню букв возможен:

– из поля Текст на Панели свойств — одинарным щелчком правой кнопки мыши,

– из диалога ввода текста обозначения — двойным щелчком левой кнопки мыши.

При создании координационных осей возможен ввод как букв, так и цифр. Поэтому после выполнения любого из вышеуказанных действий на экране сначала появляется меню, содержащее команды Буква и Цифра. Чтобы перейти к меню букв, выберите команду Буква.

Задание букв, используемых при создании координационных осей, производится в диалоге общих настроек координационных осей.

При создании координационных осей возможно автопродолжение нумерации. Для этого активизируйте переключатель Автопродолжение.

В модели вы можете использовать меню букв для задания обозначений баз при отключенной автосортировке. Уже использованные буквы отмечены в меню «галочкой». Если автосортировка включена, то вызов меню букв невозможен, так как буква определяется системой автоматически.

Задание букв, используемых при создании баз, производится в диалоге настройки автосортировки.


Строка пользовательского меню

При выборе строки пользовательского меню соответствующий этой строке текст автоматически вводится в текущее поле или ячейку. Этот механизм используется при вводе текста размерных надписей, технологических и условных обозначений, заполнении ячеек основной надписи. Он позволяет ускорить ввод текста и избежать опечаток.

Смотрите также

Пользовательские меню при вводе текста


Направление полки обозначения позиции

Группа переключателей, позволяющая выбрать направление отрисовки полки линии-выноски.

Изменение направления полки имеет смысл, если ее отрисовка включена (активна опция Полка). Исключение — обозначение позиции с типом формы «Простой текст»: для него смена направления полки при отключенной опции Полка означает изменение положения текста относительно линии-выноски.


Направление текста

Группа переключателей, позволяющая выбрать направление добавления номеров позиций.

Изменение направления добавления номеров позиций имеет смысл, если они размещаются вертикально (отключена опция Горизонтально).


Настройка симметричного расположения компонентов

Настройка положения выполняется для тех компонентов, способом отражения которых является Симметричное расположение компонента. Если для компонента выбран это способ отражения, то на инструментальной панели диалога Параметры зеркального отражения компонентов доступна группа Положение:.

Для расчета положения компонента используется плоскость/центр симметрии исходного компонента или другой компонент, который выбирается базовым.

В качестве плоскости/центра симметрии компонента может быть выбран принадлежащий ему плоский или точечный объект. Для этого используются следующие элементы группы.

– Кнопки Предыдущее положение и Следующее положение — позволяют в автоматическом режиме выбрать плоскость/центр симметрии исходного компонента. При каждом нажатии одной из этих кнопок системой предлагается объект, входящий в предопределенный список. Варианты перебираются циклически.

– Кнопка Указать плоскость или точку в компоненте — используется для ручного указания плоскости/центра симметрии исходного компонента. После нажатия кнопки запускается процесс указания объекта. Диалог настройки параметров отражения скрывается. На экране появляется Окно модели — источника исходного компонента.

Вид Окна модели-источника и работа в нем

Укажите нужный объект. Положение фантома компонента в окне модели изменится. Наименование выбранного объекта появится в поле Объект Панели свойств. При необходимости вы можете выбрать другой объект, указав его в Окне модели-источника. Для завершения выбора нажмите кнопку Применить на Панели специального управления. Диалог настройки параметров отражения вновь появится на экране. Выбранный объект будет использоваться для расчета положения компонента. В список вариантов объектов для этого компонента добавится новый вариант.

Подробнее о выборе плоскости/центра симметрии исходного компонента...

Если в модель требуется добавить несколько компонентов как одно целое (с сохранением их взаимного расположения), используется базовый компонент, т.е. компонент, относительно которого сохраняется положение всех выбранных компонентов.

Компонент может использоваться как базовый, если он удовлетворяет следующим условиям:

– размещается способом Симметричное расположение компонента,

– входит в тот же исходный компонент и расположен на том же уровне, что и компоненты, выбранные для размещения по базовому, но не выбран вместе с ними.

Чтобы разместить несколько компонентов относительно базового, выполните следующие действия.

1. В таблице диалога укажите компоненты, которые требуется разместить симметрично с сохранением взаимного положения. Указанные компоненты должны находиться на одном уровне Дерева построения. Компонент, который предполагается использовать как базовый, не должен быть выбран.

2. Нажмите кнопку Указать базовый компонент на инструментальной панели диалога.

3. На экране появится диалог Выбор базового компонента.

Диалог содержит список компонентов, каждый из которых может быть базовым для указанных компонентов.

4. Выберите базовый компонент.

По умолчанию базовым является компонент, который находится на верхней строке списка. Рядом с его именем отображается «галочка». Чтобы сделать базовым другой компонент, дважды щелкните по строке списка, содержащей этот компонент, или выделите его в списке и нажмите кнопку Выбор базового компонента.

5. Для завершения работы в диалоге нажмите кнопку ОК.

Диалог закроется. Положение указанных компонентов будет определяться относительно базового. В списки вариантов объектов для этих компонентов добавится новый вариант, содержащий имя базового компонента.

Подробнее о выборе базового компонента...

Сведения о выбранном объекте (компоненте) отображаются в диалоге следующим образом.

– В поле Вариант положения содержится номер выбранного варианта в списке вариантов объектов. Поле недоступно для ручного ввода.

– В ячейке столбца Положение компонента содержится описание выбранного варианта. Вы можете просмотреть весь список вариантов, щелкнув мышью в ячейке. Данный список можно использовать для выбора другого объекта.

Подробнее о списке объектов, используемых для расчета положения компонента...


Команда Обозначение позиции (графический документ)

Команда Обозначение позиции
(графический документ)

Позволяет создать номер позиции составной части сборочной единицы.

Для вызова команды нажмите кнопку Обозначение позиции на инструментальной панели Обозначения.

Укажите начальную точку первого ответвления (первую точку, на которую указывает позиционная линия-выноска).

Укажите точку начала полки т1.

Затем укажите начальные точки остальных ответвлений.

В поле Текст на вкладке Знак отображается предлагаемый системой номер позиции. Чтобы изменить надпись, вызовите диалог ввода надписи обозначения, щелкнув в поле Текст левой кнопкой мыши. Если в обозначении должно быть несколько номеров позиций, создайте в поле ввода диалога отдельные абзацы для каждого номера.

Настройка отрисовки позиционной линии-выноски

По умолчанию при создании обозначения позиции включен режим добавления ответвлений. Об этом свидетельствует нажатая кнопка Добавить ответвления на Панели специального управления. В этом режиме каждая вновь указанная точка воспринимается системой как начальная точка очередного ответвления.

В режиме редактирования характерных точек объекта можно внести изменения в конфигурацию обозначения. Добавление ответвлений в этом режиме невозможно. Для перехода в режим редактирования нажмите кнопку Редактировать точки на Панели специального управления.

Между режимами можно произвольно переключаться при помощи кнопок Панели специального управления или команд в контекстном меню. При выходе из одного режима автоматически включается другой.

Чтобы зафиксировать изображение, нажмите кнопку Создать объект на Панели специального управления.

Простановка линий-выносок с позициями

При редактировании проекционного обозначения позиции часть элементов управления Панели свойств недоступна. Соответствующие параметры обозначения передаются в чертеж из модели, поэтому их ручное изменение невозможно.

Смотрите также

Добавление ответвлений

Другие обозначения


Команда Обозначение позиции (документ-модель)

Команда Обозначение позиции
 (документ-модель)

Позволяет создать в модели линию-выноску для обозначения позиции. Обозначение позиции может проставляться к следующим объектам:

– грань тела или поверхности,

– ребро тела или поверхности.

Пример

Для вызова команды нажмите кнопку Обозначение позиций на инструментальной панели Элементы оформления.

Укажите объект, на который будет указывать первое ответвление линии-выноски. Тело (или поверхность), которому принадлежит выбранный объект, подсветится. Начальной точкой первого ответвления будет точка, в которой был указан объект.

Задайте точку начала полки.

На экране появляется фантом обозначения.

Вы можете сменить базовую плоскость обозначения с помощью списка Базовая плоскость на вкладке Знак Панели свойств.

Кроме того, вы можете сместить плоскость обозначения параллельно самой себе, используя элемент управления Положение.

В поле Текст на вкладке Знак отображается предлагаемый системой номер позиции. Чтобы изменить надпись, вызовите диалог ввода надписи обозначения, щелкнув в поле Текст левой кнопкой мыши. Если в обозначении должно быть несколько номеров позиций, создайте в поле ввода диалога отдельные абзацы для каждого номера.

Настройка отрисовки позиционной линии-выноски

По умолчанию при создании обозначения позиции включен режим добавления ответвлений. Об этом свидетельствует нажатая кнопка Добавить ответвления на Панели специального управления. В этом режиме каждая вновь указанная точка воспринимается системой как начальная точка очередного ответвления.

Подробнее о добавлении и удалении ответвлений...

В режиме редактирования характерных точек объекта можно внести изменения в конфигурацию обозначения. Добавление ответвлений в этом режиме невозможно. Для перехода в режим редактирования нажмите кнопку Редактировать точки на Панели специального управления.

Между режимами можно произвольно переключаться при помощи кнопок Панели специального управления или команд в контекстном меню. При выходе из одного режима автоматически включается другой.

Чтобы зафиксировать обозначение, нажмите кнопку Создать объект на Панели специального управления.

Пример простановки обозначения позиции

Смотрите также

Другие элементы оформления

Связь позиций с объектами спецификации модели


Опция Горизонтально

Опция, управляющая расположением обозначения, содержащего несколько номеров позиций. Если опция отключена, то номера располагаются в колонку, а если включена — в строку.


Опция Полка

Опция, управляющая отрисовкой полки позиционной линии-выноски.

Для позиций с типом формы «Простой текст» полка представляет собой обычную полку линии-выноски, над которой располагается текст. Для остальных типов формы полка — это отрезок, соединяющий текст с линией-выноской.


Команда Марка/позиционное обозначение с линией-выноской

Позволяет создать обозначение, используемое в проектной документации — марка/позиционное обозначение с линией-выноской.

Для вызова команды нажмите кнопку Марка/позиционное обозначение с линией-выноской на инструментальной панели Обозначения для строительства или выберите ее название из меню Инструменты — Обозначения для строительства.

Укажите начальную точку первого ответвления обозначения (т).

Укажите точку начала полки т1.

Затем укажите начальные точки остальных ответвлений. Их количество не ограничено.

Чтобы ввести надпись в обозначение, вызовите диалог ввода текста. Для этого щелкните левой кнопкой мыши в поле Текст на Панели свойств или вызовите команду Текст надписи... из контекстного меню.

Чтобы при вводе текста производилось автоматическое присвоение свободных номеров элементам активизируйте переключатель Автонумерация.

Контекстное меню поля Текст содержит все марки, созданные в документе. Чтобы создать марку с уже существующим текстовым обозначением, вы можете выбрать его из этого меню. В режиме автонумерации ей будет присвоен очередной номер.

Если текст, сформированный для текущей (создаваемой) марки/позиционного обозначения, нужно использовать для остальных подобных обозначений, созданных за этот вызов команды, включите опцию Сохранять текст. При выключенной опции каждое следующее обозначение формируется без текста.

Текст надписи может служить источником ссылки другого текстового объекта, находящегося в этом документе.

Настройте параметры марки/позиционного обозначения на вкладке Параметры Панели свойств.

Примеры марки/позиционного обозначения с линией-выноской

Параметры расположения текста на полке задаются в диалоге параметров отрисовки марки/позиционного обозначения. Настройка, сделанная в этом диалоге, распространяется на все подобные обозначения в текущем документе.

По умолчанию при создании марки/позиционного обозначения включен режим добавления ответвлений. Об этом свидетельствует нажатая кнопка Добавить ответвления на Панели специального управления. В этом режиме каждая вновь указанная точка воспринимается системой как начальная точка очередного ответвления.

В режиме редактирования характерных точек объекта можно внести изменения в конфигурацию обозначения. Добавление ответвлений в этом режиме невозможно. Для перехода в режим редактирования нажмите кнопку Редактировать точки на Панели специального управления.

Между режимами можно произвольно переключаться при помощи кнопок Панели специального управления или команд в контекстном меню. При выходе из одного режима автоматически включается другой.

Кнопка Копировать свойства на Панели специального управления позволяет копировать текст в текущее обозначение из уже существующей марки/позиционного обозначения (этого же или другого типа).

Чтобы зафиксировать изображение, нажмите кнопку Создать объект на Панели специального управления.

Вы можете создать несколько обозначений за один вызов команды Марка/позиционное обозначение с линией-выноской. Для этого после нажатия кнопки Создать объект укажите новые точки т и т1.

Чтобы отказаться от создания марки/позиционного обозначения с линией-выноской, нажмите кнопку Прервать команду на Панели специального управления.

Смотрите также

Марка/позиционное обозначение без линии-выноски

Марка/позиционное обозначение на линии

Добавление ответвлений

Другие обозначения для строительства


Автонумерация

Переключатель Автонумерация позволяет автоматически присваивать номер создаваемой марке. Переключатель доступен при создании марки/позиционного обозначения и недоступен при редактировании.

В режиме автонумерации происходит автоматическое заполнение той части строки, которая содержит номер (после текста марки). Автонумерация работает для марок с одинаковым текстовым обозначением. Тип марки — с линией-выноской, на линии или без линии-выноски — значения не имеет. Также не имеет значения способ задания номеров предыдущих марок — вручную или автоматически.

Для создания марки с автоматически присвоенным номером выполните следующие действия.

1. Активизируйте переключатель Автонумерация на Панели свойств. По умолчанию поле Текст пусто. Если включена опция Сохранять текст на вкладке Знак, то в поле Текст отображается текст, размещенный над полкой последнего созданного обозначения.

2. Щелкните правой кнопкой мыши в поле Текст. Появится контекстное меню, содержащее список марок в алфавитном порядке, использовавшихся в документе.

Марка, обозначаемая в списке символами < >, не содержит текстового обозначения, а состоит только из номера.

3. Выберите из контекстного меню нужную марку. В поле Текст отобразится обозначение марки с присвоенным ей следующим свободным номером.

В диалоге ввода текста можно отредактировать обозначение, ввести дополнительный текст над полкой и под полкой, ввести комментарий.

Если марка/позиционное обозначение с автоматически присвоенным номером удаляется из документа, номера оставшихся объектов не изменяются.

Вы можете настроить систему так, чтобы режим автонумерации для марок всех типов был включен по умолчанию. Для этого активизируйте опцию Автонумерация в диалоге общих настроек марки/позиционного обозначения.

Изменение состояния переключателя Автонумерация на Панели свойств равносильно изменению состояния опции Автонумерация в диалоге общих настроек.

Если режим автонумерации выключен, поле Текст пусто. В этом случае номер марке/позиционному обозначению присваивается вручную в диалоге ввода текста.


Команда Выбрать базовой Плоскость XY / ZX / ZY

Позволяет сменить базовую плоскость обозначения — плоскость, которой параллельна плоскость обозначения. В качестве базовых плоскостей используются координатные плоскости абсолютной системы координат.

Команда, соответствующая текущей базовой плоскости, отмечена «галочкой».

Команды выбора базовой плоскости находятся в контекстном меню. Они не доступны в следующих случаях:

– указано более двух точек обозначения (например, для линии-выноски задано начало первого ответвления, начало полки и начало второго ответвления),

– при задании положения плоскости указан объект фиксации.

Для смены базовой плоскости можно также воспользоваться списком Базовая плоскость на Панели свойств.


Команда Вставить текстовый шаблон

Позволяет открыть текстовый шаблон и скопировать в набираемый текст нужные разделы из этого шаблона. Особенно удобна такая возможность при вводе технических требований, когда многие пункты являются стандартными, и требуется лишь небольшая их корректировка.

Одновременно могут быть открыты несколько различных шаблонов. Каждый шаблон отображается в своем собственном окне.

Для вызова команды нажмите кнопку Вставить текстовый шаблон или выберите ее название из меню Вставка.

После этого на экране появится окно Библиотекаря текстовых шаблонов.

Выберите в нем шаблоны, которые требуется скопировать в текущий документ, и нажмите кнопку Вставить в документ на инструментальной панели Библиотекаря.

После этого Библиотекарь текстовых шаблонов закроется, а в текущую позицию курсора будет вставлен указанный текст. Дальнейшая работа с ним не отличается от работы с текстом, введенным с клавиатуры.


Команда Предыдущее направление

Позволяет выделить предшествующее текущему направление движения в узле в при сборке контура или построении эквидистанты по стрелке.


Команда Добавить документы...

Позволяет добавить один или несколько листов документов в набор предварительного просмотра для печати.

Команда доступна, если отключен режим указания страниц на поле печати.

Для вызова команды нажмите кнопку Добавить документы... на инструментальной панели или выберите ее название из меню Файл.

На экране появится стандартный диалог открытия файла. Выберите нужные файлы документов и нажмите кнопку Открыть.

На экране появится диалог выбора варианта добавления листов документов. Для продолжения загрузки документов выберите один из предлагаемых в диалоге вариантов добавления листов — добавление к имеющимся листам или замена их.

Если при настройке параметров вывода включено использование зазора, то добавленные листы будут отстоять друг от друга на величину зазора.

Смотрите также

Размещение нескольких листов


Команда Исключить пустые страницы

Позволяет запретить вывод всех страниц печати, которые не заняты печатаемыми листами документов.

Смотрите также

Отмена печати указанных страниц


Команда Режим указания выводимых областей листов

Команда позволяет указать, какие области листов требуется вывести на печать.

Для вызова команды нажмите кнопку Режим указания выводимых областей листов на инструментальной панели или выберите ее название из меню Сервис.

На Панели свойств появятся группа переключателей Способ указания области и поля управления областью печати текущего листа.

Выберите способ указания печатаемой области текущего листа. Для этого в группе Способ указания области активизируйте нужный переключатель:

– Указание выводимой области листа заданием ее размеров и положения,

– Указание выводимой области листа заданием ее отступов от края листа.

Введите значения в поля управления областью печати (набор полей соответствует выбранному способу указания области). Рамка, ограничивающая печатаемую область текущего листа, изменит свой размер и положение. Кроме того, вы можете перемещать мышью стороны или углы рамки, а также рамку целиком. При этом значения в полях будут изменяться автоматически.

Аналогично укажите печатаемые области других листов документа (выполняется при необходимости). Нужный лист можно выбрать, щелкнув мышью по его изображению, указав его имя в списке Лист на Панели свойств или используя клавишу <Tab>.

Для завершения работы в команде вызовите ее повторно или нажмите клавишу <Esc>.

В дальнейшем вы можете управлять способом печати каждого листа документа с помощью переключателей группы Способ вывода на Панели свойств. Активизация переключателя Вывести заданную область текущего листа позволяет напечатать указанную область листа документа, активизация переключателя Вывести текущий лист полностью — весь лист целиком.

Смотрите также

Печать области листа


Команда Удалить листы из просмотра

Позволяет исключить выделенный лист документа или лист (листы) многолистового документа из очереди на печать.

Для вызова команды нажмите кнопку Удалить листы из просмотра на инструментальной панели или выберите ее название из меню Файл.

Команда недоступна, если в поле просмотра находится один лист документа, а также если включен режим указания страниц на поле печати.


Команда Выделить рамкой

Позволяет выделить несколько листов документов с помощью охватывающей или секущей рамки.

Команда доступна, если отключен режим указания страниц на поле печати.

Для вызова команды нажмите кнопку Выделить рамкой на инструментальной панели или выберите ее название из меню Сервис.


Команда Выделить все

Позволяет выделить все листы документов, добавленные в просмотр.

Команда доступна, если отключен режим указания страниц на поле печати.

Для вызова команды нажмите кнопку Выделить все на инструментальной панели или выберите ее название из меню Сервис.


Команда Включить все страницы

Вызывается из контекстного меню.

Позволяет включить все выключенные на момент вызова команды страницы печати. Команда доступна, если запрещен вывод на печать хотя бы одной страницы.

Для включения и выключения отдельных страниц пользуйтесь командой Режим выбора страниц для печати.


Команда Инвертировать страницы

Вызывается из контекстного меню.

Позволяет включить выключенные на момент вызова команды страницы печати и выключить включенные.

Для включения и выключения отдельных страниц пользуйтесь командой Режим выбора страниц для печати.

Смотрите также

Отмена печати указанных страниц


Команда Режим выбора страниц для печати

Позволяет запретить вывод на печать указанной страницы печати или отменить запрет.

Для вызова команды нажмите кнопку Режим выбора страниц для печати на инструментальной панели или выберите ее название из меню Сервис.

После вызова команды включается режим указания страниц на поле печати (признаком того, что режим включен, является отображение кнопки Режим выбора страниц для печати как нажатой). Чтобы отменить вывод на печать какой-либо страницы, зафиксируйте курсор внутри этой страницы. При этом изменится цвет, которым указанная страница изображена на экране.

Повторная фиксация курсора внутри отмеченной страницы отменяет запрещение на ее печать.

Для выхода из режима указания страниц вызовите еще раз команду или нажмите кнопку Режим выбора страниц для печати (она вернется в исходное ненажатое положение).


Команда Повернуть против часовой стрелки

Поворачивает лист документа на 90 градусов против часовой стрелки на поле печати.

Команда доступна, если отключен режим указания страниц на поле печати.

Для вызова команды нажмите кнопку Повернуть против часовой стрелки на инструментальной панели или выберите ее название из меню Сервис.

Смотрите также

Перемещение листа


Команда Повернуть по часовой стрелке

Поворачивает лист документа на 90 градусов по часовой стрелке на поле печати.

Команда доступна, если отключен режим указания страниц на поле печати.

Для вызова команды нажмите кнопку Повернуть по часовой стрелке на инструментальной панели или выберите ее название из меню Сервис.

Смотрите также

Перемещение листа


Команда Фильтры вывода на печать...

Позволяет запретить вывод на печать объектов, обладающих определенными признаками (например, объектов конкретного типа), или отменить запрет.

Для вызова команды нажмите кнопку Фильтры вывода на печать на инструментальной панели или выберите ее название из меню Сервис.

После вызова команды на экране появляется диалог настройки фильтров. Объекты с отмеченными в нем признаками (стилем линии, типом и т.д.) будут выводиться на печать.


Команда Настройка параметров вывода...

Позволяет настроить параметры вывода листов на печать (количество копий, цвет, точность вывода моделей и т.п.).

Для вызова команды выполните одно из следующих действий:

– в главном окне — выберите название команды из меню Файл — Настройки предварительного просмотра или меню кнопки Предварительный просмотр, расположенной на Стандартной панели,

– в режиме предварительного просмотра — выберите название команды из меню Файл или нажмите кнопку Настройка параметров вывода на инструментальной панели.

После вызова команды на экране появится диалог, позволяющий выполнить необходимые настройки.


Команда Подогнать масштаб...

Позволяет автоматически пересчитать масштаб печати выделенных листов документов для их размещения на заданном количестве страниц печати. Команда Подогнать масштаб... доступна, если отключен режим указания страниц на поле печати.

Для вызова команды нажмите кнопку Подогнать масштаб... на инструментальной панели или выберите ее название из меню Сервис.

После вызова команды на экране появляется диалог для задания количества страниц печати, на которых следует разместить выделенные листы.

Смотрите также

Масштабирование листа документа


Команда Справка

Для вызова команды служит кнопка Справка.

Если команда вызывается кнопкой Панели специального управления, то на экране появляется раздел Справочной системы, содержащий сведения о выполняемой команде.

Если команда вызывается кнопкой инструментальной панели одного из окон, используемых для ввода и вывода информации в системе КОМПАС-3D (например, Окна переменных, окна Нумерация и т.п.), то на экране появляется раздел Справочной системы, содержащий информацию о данном окне.


Команда Проекционная кривая

Вы можете построить проекционную кривую — проекцию указанной кривой (базовой) на поверхность проецирования.

Пример

Объекты, используемые при построении...

Для вызова команды нажмите кнопку Проекционная кривая на инструментальной панели Пространственные кривые или выберите ее название из меню Операции — Пространственные кривые.

1. На Панели свойств автоматически активизируется переключатель Поверхность. Укажите в окне модели нужную грань или плоскость.

Указанный объект подсвечивается.

2. После задания поверхности проецирования автоматически активизируется переключатель Кривая. Задайте базовую кривую, указав в окне или в Дереве построения нужный объект или объекты.

Обратите внимание на то, что ось, массив кривых и группа изопараметрических кривых не могут входить в набор объектов, составляющих базовую кривую. Поэтому выбор, например, новой оси отменяет выбор всех остальных объектов, входивших в базовую кривую.

На экране появляется фантом проекционной кривой.

Отсутствие фантома — признак невозможности существования проекционной кривой при выбранных исходных объектах и текущих параметрах построения.

3. При необходимости измените поверхность проецирования (например, можно составить набор граней) и/или базовую кривую.

– Чтобы изменить поверхность проецирования, активизируйте переключатель Поверхность, а затем укажите нужные объекты. Плоскость не может входить в набор объектов, составляющих поверхность проецирования. Поэтому выбор новой плоскости отменяет выбор всех остальных объектов, входивших в поверхность проецирования.

Если в набор граней нужно добавить все грани какого-либо тела или поверхности, укажите это тело или поверхность в Дереве построения.

– Чтобы изменить базовую кривую, активизируйте переключатель Кривая, а затем укажите нужные объекты.

Повторное указание объекта отменяет его выбор.

Все изменения отображаются на фантоме кривой.

Выбор объектов в окне модели

Выбор объектов в Дереве построения

4. С помощью переключателей группы Тип проекции задайте направление проецирования базовой кривой: по нормали к поверхности проецирования или по заданному направлению. Подробнее...

5. Выберите вариант построения проекции с помощью опции Усечение по границам.

– При включенной опции проекция базовой кривой строится в пределах контура грани (обрезана по контуру грани). Если в качестве поверхности проецирования используется набор граней, то проекция базовой кривой обрезается по контуру каждой грани набора.

– При отключенной опции строится вся проекция базовой кривой. Базовая кривая проецируется на теоретическую поверхность грани. При необходимости теоретическая поверхность грани продлевается.

Обратите внимание на следующие особенности проецирования:

– Проекция базовой кривой на плоскость всегда строится полностью.

– Если в качестве базовой кривой указана ось, то ее проекция всегда строится в пределах контура поверхности проецирования.

В обоих случаях опция Усечение по границам недоступна.

Общие сведения о теоретической поверхности грани...

Варианты построения проекции базовой кривой...

6. Проекционная кривая может состоять из одного или нескольких участков — контуров. Выберите те контуры, которые должны быть построены. Подробнее...

7. При необходимости используйте следующие возможности:

– Отмена сразу всех объектов, заданных для построения кривой. Для этого нажмите кнопку Указать заново на Панели специального управления.

– Изменение наименования и цвета создаваемой кривой. Для этого активизируйте вкладку Свойства Панели свойств. Также на этой вкладке можно настроить параметры отображения кривой.

8. Нажмите кнопку Создать объект на Панели специального управления.

Для выхода из команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.


Команда Спроецировать объект

Позволяет создать в текущем эскизе прямоугольную проекцию указанного трехмерного объекта — вершины, грани, ребра, пространственной кривой, оси, точки и т.п.

Для вызова команды нажмите кнопку Спроецировать объект на инструментальной панели Геометрия или выберите ее название из меню Редактор.

После вызова команды указывайте объекты, которые требуется спроецировать.

В результате в эскизе создаются геометрические объекты, представляющие собой проекции указанных объектов на плоскость эскиза.

В зависимости от того, какие объекты выбраны для проецирования, в эскизе создаются следующие геометрические объекты:

– точка со стилем Вспомогательная — при проецировании вершины,

– вспомогательная прямая — при проецировании координатной или вспомогательной оси,

– объект типа проекционная кривая со стилем Основная — при проецировании ребра, пространственной кривой или грани (в последнем случае создаются проекционные кривые — проекции ребер, ограничивающих грань).

Если для проецирования выбрано прямолинейное ребро, перпендикулярное плоскости эскиза, то в эскиз проецируется одна из вершин этого ребра.

Созданные в эскизе проекции ассоциативно связаны со своими исходными объектами. Например, при перемещении ребра в результате редактирования параметров породившей его операции проекция этого ребра в эскизе будет отслеживать его новое положение.

На созданную проекцию автоматически накладывается параметрическая связь — проекционная связь. На проекционную кривую, если она разомкнута, также накладываются связи проекция конечной вершины. Эти связи обеспечивают совпадение крайних вершин проекционной кривой с проекциями крайних вершин исходного объекта.

Подробнее о создании проекции в эскизе...


Команда Свойства модели/тела/компонента

Позволяет просмотреть список свойств объекта, изображение которого находится в ассоциативном виде.

Данная команда доступна в контекстном меню модели, тела или компонента, выделенного в Дереве построения. После вызова команды список свойств выбранного объекта появляется на Панели свойств.


Команда Свойства вставки фрагмента

Позволяет изменить свойства вставки фрагмента — отредактировать список системных и дополнительных свойств.

Команда Свойства вставки фрагмента доступна в контекстном меню вставки, выделенной в окне или в Дереве чертежа.

После вызова команды на Панели свойств появляются элементы управления для настройки свойств вставки фрагмента.

Элементы управления свойствами в документе

Чтобы сделанные изменения вступили в силу, нажмите кнопку Создать объект на Панели специального управления.

Чтобы выйти из режима настроек без фиксации сделанных изменений, нажмите кнопку Прервать команду.

Изменения свойств будут действовать только для данной вставки. Вновь создаваемые вставки фрагментов будут иметь умолчательные свойства.


Команда Свойства макроэлемента

Позволяет изменить свойства графического макроэлемента — отредактировать список системных и дополнительных свойств.

Команда Свойства макроэлемента доступна в контекстном меню макроэлемента, выделенного в окне или в Дереве чертежа.

После вызова команды на Панели свойств появляются элементы управления для настройки свойств макроэлемента.

Элементы управления свойствами в документе

Чтобы сделанные изменения вступили в силу, нажмите кнопку Создать объект на Панели специального управления.

Чтобы выйти из режима настроек без фиксации сделанных изменений, нажмите кнопку Прервать команду.

Изменения свойств будут действовать только для данного макроэлемента. Вновь создаваемые макроэлементы будут иметь умолчательные свойства.


Команда Свойства чертежа/фрагмента

Позволяет изменить свойства графического документа — отредактировать список системных и дополнительных свойств.

Команда Свойства чертежа/фрагмента доступна в меню Файл или для чертежа в контекстном меню корневого объекта Дерева чертежа.

После вызова команды на Панели свойств появляются элементы управления для настройки свойств документа.

Элементы управления свойствами в документе

Чтобы сделанные изменения вступили в силу, нажмите кнопку Создать объект на Панели специального управления.

Чтобы выйти из режима настроек без фиксации сделанных изменений, нажмите кнопку Прервать команду.

Изменения свойств будут действовать только для чертежа или фрагмента, в котором они были сделаны. Вновь создаваемые документы будут иметь умолчательные свойства.


Команда Свойства вставки вида

Позволяет изменить свойства вставки вида — отредактировать список системных и дополнительных свойств.

Команда Свойства вставки вида доступна в контекстном меню вставки, выделенной в окне или в Дереве чертежа.

После вызова команды на Панели свойств появляются элементы управления для настройки свойств вставки вида.

Элементы управления свойствами в документе

Чтобы сделанные изменения вступили в силу, нажмите кнопку Создать объект на Панели специального управления.

Чтобы выйти из режима настроек без фиксации сделанных изменений, нажмите кнопку Прервать команду.

Изменения свойств будут действовать только для данной вставки. Вновь создаваемые вставки видов будут иметь умолчательные свойства.


Текущий масштаб поля вывода

В этом поле, расположенном на инструментальной панели, показан масштаб отображения поля вывода.

Чтобы изменить масштаб, разверните список и выберите нужное значение. Можно также ввести значение с клавиатуры.

Смотрите также

Масштаб просмотра


Текущий шаг курсора

В этом поле отображается значение шага курсора, то есть расстояние, на которое переместится текущий лист (листы) при однократном нажатии управляющей клавиши (любой из клавиш со стрелками).

Вы можете изменить шаг курсора, набрав вручную нужное значение. Чтобы поле ввода стало доступным, установите в него курсор и щелкните левой кнопкой мыши.

Можно также выбрать значение шага из списка. Чтобы открыть список, щелкните на клавише со стрелкой рядом с полем ввода.


Команда Сдвинуть

Позволяет сдвинуть поле вывода в окне предварительного просмотра.

Для вызова команды нажмите кнопку Сдвинуть на инструментальной панели или выберите ее название из меню Вид.

После этого форма курсора изменится: он превратится в четырехстороннюю стрелку.

Удерживая кнопку мыши нажатой, перемещайте курсор. Вслед за движением курсора будет прокручиваться поле вывода. Если достигнут край экрана и необходимо продвинуть поле вывода еще дальше, отпустите кнопку мыши, переместите курсор в нужное положение, а затем вновь нажмите левую кнопку мыши и продолжайте прокрутку рабочего поля.

Если вы пользуетесь трехкнопочной мышью или мышью с колесом, то для сдвига поля вывода можно перемещать мышь с нажатой средней кнопкой (колесом).

Если масштаб отображения в окне предварительного просмотра таков, что поле вывода отображается целиком, командой сдвига воспользоваться невозможно.


Команда Показать все

Изменяет масштаб отображения поля вывода таким образом, чтобы оно было видно на экране целиком.

Для вызова команды нажмите кнопку Показать все на инструментальной панели или выберите ее название из меню Вид. Можно также нажать клавишу <F9>.

Смотрите также

Масштаб просмотра


Команда Увеличить масштаб

Позволяет увеличить масштаб отображения поля вывода в определенное количество раз.

Для вызова команды нажмите кнопку Увеличить масштаб на инструментальной панели или выберите ее название из меню Вид — Масштаб. Можно также нажать клавишу <+> на цифровой клавиатуре.

Умолчательное значение коэффициента масштабирования можно изменить в диалоге настройки параметров редактирования.

Смотрите также

Масштаб просмотра


Команда Уменьшить масштаб

Позволяет уменьшить масштаб отображения поля вывода в определенное количество раз.

Для вызова команды нажмите кнопку Уменьшить масштаб на инструментальной панели или выберите ее название из меню Вид — Масштаб. Можно также нажать клавишу <-> на цифровой клавиатуре.

Умолчательное значение коэффициента масштабирования можно изменить в диалоге настройки параметров редактирования.

Смотрите также

Масштаб просмотра


Команда Последующий масштаб

Позволяет вернуться к последующему масштабу отображения поля вывода. Команда доступна в том случае, если перед этим был выполнен возврат к предыдущему масштабу.

Для вызова команды выберите ее название из меню Вид — Масштаб.

Смотрите также

Масштаб просмотра


Команда Масштаб по выделенным листам

Позволяет автоматически изменить масштаб отображения выделенных листов так, чтобы в окне предварительного просмотра они отображались полностью в максимально возможном масштабе.

Для вызова команды нажмите кнопку Масштаб по выделенным листам на инструментальной панели или выберите ее название из меню Вид. Можно также нажать клавишу <F10> на клавиатуре.

Смотрите также

Масштаб просмотра


Команда Предыдущий масштаб

Позволяет возвратиться к предыдущему масштабу отображения поля вывода.

Для вызова команды выберите ее название из меню Вид — Масштаб.

Смотрите также

Масштаб просмотра


Команда Увеличить масштаб рамкой

Позволяет изменить масштаб отображения поля вывода с помощью прямоугольной рамки.

Для вызова команды нажмите кнопку Увеличить масштаб рамкой на инструментальной панели или выберите ее название из меню Вид — Масштаб.

После этого внешний вид курсора изменится: он превратится в перекрестье. Укажите первый угол, затем перемещайте курсор для достижения нужного размера рамки. На экране будет отображаться фантом рамки. Укажите второй угол рамки.

Масштаб отображения увеличится так, чтобы область, ограниченная рамкой, полностью умещалась в окне предварительного просмотра.

Смотрите также

Масштаб просмотра


Команда Текст надписи

Вызывает диалог ввода текста, в котором можно ввести надпись для следующих объектов:

– марка/позиционное обозначение с линией-выноской,

– марка/позиционное обозначение на линии,

– марка/позиционное обозначение без линии-выноски.

Для вызова этого диалога можно также щелкнуть мышью в поле Текст на вкладке Знак Панели свойств.

Контекстное меню поля Текст содержит все марки, созданные в документе. Чтобы создать марку с уже существующим текстовым обозначением, вы можете выбрать его из этого меню. В режиме автонумерации ей будет присвоен очередной номер.

Для обозначения марок рекомендуется использовать символы, ввод которых возможен непосредственно с клавиатуры — цифры и буквы русского и латинского алфавитов и т.п. Если обозначение марки содержит символы, введенные при помощи команд Вставить — Символ... и Вставить — Спецзнак, то это обозначение будет создано, но в контекстное меню поля Текст попадает только часть обозначения, находящаяся перед первым таким символом.


Команда Разместить листы в узлах страниц

Позволяет изменить положение выделенных листов так, чтобы их левые нижние углы совмещались с левыми нижними узлами ближайших страниц печати.

Команда доступна, если отключен режим указания страниц на поле печати.

Для вызова команды нажмите кнопку Разместить листы в узлах страниц на инструментальной панели или выберите ее название из меню Сервис.

Перемещение листа в узел ближайшей страницы выполняется, если левый нижний угол листа входит в «зону чувствительности» узла этой страницы.

Радиус «зоны чувствительности» узла задается при настройке параметров вывода.


Команда Сомкнуть и выровнять листы

Позволяет изменить положение выделенных листов документов, при котором они сдвигаются сначала влево до границы их габаритного прямоугольника или ближайшего выделенного листа, а затем аналогично сдвигаются вниз.

Команда доступна, если отключен режим указания страниц на поле печати.

Для вызова команды нажмите кнопку Сомкнуть и выровнять листы на инструментальной панели или выберите ее название из меню Сервис.

Если при настройке параметров вывода включено использование зазора между листами, то сдвиг листов друг к другу производится с зазором.

При сдвиге ориентация листов не изменяется.


Параметр дуги

Группа переключателей, позволяющая выбрать текущий параметр дуги — радиус или диаметр.

При активном переключателе Радиус на Панели свойств находится поле радиуса, при активном переключателе Диаметр — поле диаметра дуги окружности.

При нажатии переключателя происходит пересчет значений одного параметра дуги в другой.


Параметр окружности

Группа переключателей, позволяющая выбрать текущий параметр окружности — радиус или диаметр.

При активном переключателе Радиус на Панели свойств находится поле радиуса, при активном переключателе Диаметр — поле диаметра окружности.

При нажатии переключателя происходит пересчет значений одного параметра окружности в другой.


Команда Радиальный размер (документ-модель)

Команда Радиальный размер
 (документ-модель)

Позволяет проставить радиальный размер к объектам различного типа.

Пример

Для вызова команды нажмите кнопку Радиальный размер на инструментальной панели Элементы оформления.

Укажите курсором объект для простановки размера

Размерная линия может быть от центра или не от центра окружности. Для выбора нужного варианта воспользуйтесь группой переключателей Тип на вкладке Размер Панели свойств.

Задайте положение размерной линии, перемещая мышью характерную точку т1.

Радиальный размер с ручным размещением размерной линии

В поле Текст отображается автоматически сформированная размерная надпись. Чтобы вызвать диалог редактирования и настройки размерной надписи, щелкните мышью в этом поле.

Элементы управления, расположенные на вкладке Параметры, позволяют настроить параметры размеров (вид стрелки, способ размещения текста и т.п.).

Элементы управления, расположенные на вкладке Свойства, позволяют задать наименование размера в Дереве построения и цвет отрисовки размерных линий.

Размещение размерной надписи на полке

Особенности простановки радиального размера

Смотрите также

Другие элементы оформления


Команда Масштабирование(документ-модель)

Команда Масштабирование
(документ-модель)

Позволяет произвести операцию масштабирования над телом или поверхностью в текущей модели (в том числе в любом из ее компонентов).

Пример

Команда доступна, если в модели существует хотя бы одно тело или поверхность.

Для вызова команды нажмите кнопку Масштабирование на инструментальной панели редактирования детали или на инструментальной панели редактирования модели. Можно также выбрать название команды из меню Операции.

1. Укажите тело или поверхность для масштабирования в Дереве построения или в окне модели.

Пиктограммы и названия тел показываются в Дереве, если в нем включено отображение структуры модели.

Если в модели содержится одно тело или одна поверхность, то это тело или поверхность выбирается автоматически.

2. Задайте коэффициент масштабирования — в поле на Панели свойств или с помощью характерной точки.

3. При необходимости укажите центр масштабирования — вершину или точку в пространстве (по умолчанию центром является начало текущей системы координат модели).

Вы можете, не выходя из команды, создать точку в пространстве, которая будет использоваться в качестве центра масштабирования. Для этого нажмите кнопку Построение точки на Панели специального управления.

Чтобы выбрать другие объекты для выполнения операции, нажмите кнопку Указать заново на Панели специального управления. Текущий выбор объектов отменяется, и вы можете указать новые.

Настройка свойств поверхности промасштабированного объекта

Задав параметры операции, нажмите кнопку Создать объект на Панели специального управления.

Чтобы отказаться от операции, нажмите кнопку Прервать команду Панели специального управления или клавишу <Esc>.

Обратите внимание на то, что масштабируются только сами тела и поверхности. Их исходные и производные объекты — эскизы, условные изображения резьбы, обозначения и т.п. — не изменяются.

При дальнейшем редактировании модели, для построения которой использовалась команда Масштабирование, необходимо учитывать следующее.

– Промасштабированное листовое тело теряет свойства, характерные для данного типа тел.

– При построении массивов объектов операция масштабирования, произведенная над объектом ранее, игнорируется. Экземпляры массивов имеют такие размеры и положение в модели, как если бы массивы были построены до выполнения масштабирования.

– Сопряжения, наложенные на компоненты (или тела), игнорируют последующие изменения размеров и положения объектов, вызванные масштабированием. Чтобы исправить сопряжения, их следует отредактировать, повторно указав сопрягаемые элементы или объекты.

Смотрите также

Подробнее о масштабировании...

Другие команды редактирования детали

Другие команды редактирования сборки


Команда Сменить источник растровой вставки

Позволяет выбрать для вставки в КОМПАС-документ другой растровый файл вместо выделенного.


Команда Сменить источник растровой вставки

Позволяет выбрать для вставки в КОМПАС-документ другой растровый файл вместо текущего.


Команда Редактировать источник растровой вставки...

Позволяет отредактировать файл-источник растровой вставки.

Если растровый объект был вставлен ссылкой, то после вызова команды происходит запуск приложения, зарегистрированного в Windows для работы с файлами соответствующего типа. В этом приложении открывается непосредственно файл-источник вставки. После завершения редактирования и закрытия графического файла изменения будут переданы в КОМПАС-документ, содержащий вставку этого файла.

Если растровый объект был взят в документ, то редактирование происходит в следующем порядке.

1. В папке для временных файлов создается графический файл, содержащий вставленный рисунок. Этот файл имеет тип, заданный в диалоге настройки редактирования растровых объектов, взятых в документ.

2. Загружается приложение (программа), указанное в этом же диалоге.

3. В приложении открывается временный файл рисунка.

4. После завершения редактирования и закрытия рисунка сделанные изменения передаются в КОМПАС-документ, содержащий вставку.

5. Временный файл удаляется.

Если редактируемый рисунок будет закрыт после завершения сеанса работы КОМПАС-3D, то изменения рисунка в КОМПАС-документ не передадутся, а временный файл не удалится.


Команда Редактировать с помощью...

Позволяет отредактировать вставленный рисунок, указав приложение для редактирования.

Команда доступна только для рисунков, вставленных ссылкой.

После вызова команды Редактировать с помощью... на экране появится диалог выбора программы. Укажите в нем нужное приложение.

Это приложение будет загружено, в нем откроется файл-источник вставки. После завершения редактирования и закрытия графического файла изменения будут переданы в КОМПАС-документ, содержащий вставку этого файла.


Команда Взять в документ

Позволяет взять в документ растровое изображение, вставленное ссылкой на файл.


Команда Сохранить источник как...

Позволяет сохранить файл-источник растровой вставки на диске.

После вызова команды на экране появляется стандартный диалог сохранения файла, в котором можно задать тип и имя файла.


Кнопка Читать из файла

Позволяет получить координаты точек, записанные в файле, для построения поверхности по сети точек или поверхности по пласту точек.

Подробнее о файле координат...

Числа, записанные в файле, воспринимаются системой как координаты точек в декартовой системе координат, совпадающей с системой координат поверхности.

Кнопка Читать из файла находится на Панели специального управления.

При создании поверхности по сети точек кнопка Читать из файла доступна, когда не задана ни одна точка сети, т.е. сразу после вызова команды или после нажатия кнопки Указать заново.

После нажатия кнопки Читать из файла на экране появляется стандартный диалог открытия файлов Windows. Выберите в диалоге нужный файл и нажмите кнопку Открыть.

В окне модели появляется фантом поверхности, построенной по точкам, полученным из файла. При создании поверхности по пласту точек точки из файла добавляются к ранее заданным, если таковые имеются.


Команда Перестроить вид

Позволяет перестроить изображение выносного элемента или узла. Команда вызывается из контекстного меню вида в Дереве чертежа.


Команда Перестроить таблицу

Позволяет перестроить таблицу, отображаемую в Окне подготовки данных, после внесения изменений в текущий стиль отчета.

Команда может быть вызвана:

– нажатием кнопки Перестроить таблицу на панели Вид;

– нажатием клавиши <F5>;

– из меню Вид;

– из контекстного меню Окна подготовки данных.

После вызова команды таблица перестраивается согласно текущим настройкам стиля.

Перестроение фактически является повторным созданием отчета, поэтому, если отчет был изменен вручную (редактировался/форматировался текст, добавлялись/удалялись строки и т.п.), то после перестроения эти изменения теряются.

Таким образом, при редактировании отчета рекомендуется сначала проверить и настроить стиль, а затем вносить изменения в текст.


Команда Перестроить

Позволяет перестроить виды текущего чертежа. Виды чертежа, требующие перестроения, отмечаются красными «галочками» в Дереве чертежа.

Для вызова команды нажмите кнопку Перестроить на панели Вид или клавишу <F5>.

Если в модели имеются несохраненные изменения, то при перестроении ее ассоциативного вида на экране появляется запрос на сохранение модели. Нажмите кнопку Да, чтобы немедленно сохранить файл модели или кнопку Нет, чтобы отказаться от сохранения. В любом случае в ассоциативном виде создается изображение модели в ее текущем состоянии.

Перестроение может потребоваться после изменения значений переменных, если отредактированы переменные, связанные с размерами, которые принадлежат не текущему виду (текущий вид перестраивается автоматически после ввода значения переменной).

После вызова команды Перестроить изображение в видах формируется заново — так, чтобы параметры геометрических объектов соответствовали значениям переменных.

При работе с ассоциативными видами перестроение может потребоваться для приведения видов в соответствие с моделью, которая в них изображена, а также после отключения/включения отображения компонентов, назначения неразрезаемых компонентов и в некоторых других случаях.

При открытии и активизации чертежей, содержащих ассоциативные виды, система автоматически проверяет соответствие между изображениями в этих видах и соответствующими моделями.

Если будет обнаружено какое-либо рассогласование, выдается запрос на перестроение чертежа. Положительный ответ на этот запрос запускает немедленное перестроение изображения в чертеже. Отрицательный ответ откладывает перестроение. При этом пиктограммы видов, изображения в которых не соответствуют моделям, в Дереве чертежа отмечаются красной «галочкой»; в окне чертежа такие виды отображаются перечеркнутыми.

Вы можете в любое время перестроить ассоциативные виды, воспользовавшись клавишей <F5> или кнопкой Перестроить.


Системный пересчет размеров модели

Команда позволяет назначить текущим один из системных пересчетов:

– в середину поля допуска,

– по верхнему пределу,

– по нижнему пределу.

Согласно текущему пересчету будет производиться пересчет размеров модели.

Команда находится:

– в меню Сервис — Пересчет размеров;

– в меню кнопки Пересчитать размеры с учетом допусков на панели Режимы.

Команда недоступна при редактировании компонента «на месте».

Сделать текущим системный пересчет можно также в Менеджере документа.

Подробнее о пересчетах размеров модели...


Команда Прямоугольник

Позволяет построить произвольный прямоугольник.

Для вызова команды нажмите кнопку Прямоугольник на инструментальной панели Геометрия.

С помощью группы переключателей Способ выберите способ построения прямоугольника.

Доступно два способа:

– Задание противоположных вершин.
Активизируйте в группе Способ переключатель По двум вершинам и задайте две противоположные вершины прямоугольника (т1 и т2). При необходимости задайте угол наклона прямоугольника в поле Угол. Высота и ширина прямоугольника определяются автоматически.

– Задание центра и вершины.
Активизируйте в группе Способ переключатель По центру и вершине. Задайте центр прямоугольника и одну из его вершин т1. При необходимости задайте угол наклона прямоугольника в поле Угол. Высота и ширина прямоугольника определяются автоматически.

Угол наклона прямоугольника отсчитывается от оси абсцисс текущей системы координат.

– Чтобы построить квадрат, указывайте вторую точку при нажатой клавише <Shift>.

– Для быстрой смены способа построения нажмите комбинацию клавиш <Ctrl>+<Tab>.

– Для точного позиционирования курсора воспользуйтесь привязками или меню геометрического калькулятора в полях Центр, т1, т2 на Панели свойств.

В команде Прямоугольник доступно автосоздание. По умолчанию оно включено (нажата кнопка Автосоздание на Панели специального управления) и прямоугольник автоматически фиксируется в документе после задания необходимого минимума параметров, например, двух противоположных вершин. Если автосоздание отключено, то построенный прямоугольник остается незафиксированным в документе, что позволяет изменять его параметры. Для фиксации прямоугольника следует нажать кнопку Создать объект.

Выбор стиля линии...

Группа переключателей Оси на Панели свойств управляет отрисовкой осей симметрии прямоугольника.

За один вызов команды можно построить произвольное количество прямоугольников.

Для выхода из команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Обратите внимание на то, что прямоугольник, построенный в графическом документе, — это единый объект, а не набор отдельных отрезков. Он будет выделяться, редактироваться и удаляться целиком. Прямоугольник же, построенный в эскизе трехмерного элемента, — это, наоборот, набор отдельных отрезков. На каждый из них наложены связи и ограничения, благодаря которым отрезки составляют прямоугольник.

Смотрите также

Другие геометрические объекты


Команда Прямоугольник по трем точкам

Позволяет построить прямоугольник, задав три его точки.

Для вызова команды нажмите кнопку Прямоугольник по трем точкам на инструментальной панели Геометрия.

С помощью группы переключателей Способ выберите способ построения прямоугольника.

Доступно два способа:

– Задание трех вершин.
Активизируйте в группе Способ переключатель По трем точкам и задайте три вершины прямоугольника (т1, т2, т3). Высота, ширина и угол наклона прямоугольника определяются автоматически.

– Задание центра, середины стороны и вершины.
Активизируйте в группе Способ переключатель По центру и двум точкам точкам. Задайте центр прямоугольника, середину одной из сторон т1 и вершину т2. Высота, ширина и угол наклона прямоугольника определяются автоматически.

– Для быстрой смены способа построения нажмите комбинацию клавиш <Ctrl>+<Tab>.

– Для точного позиционирования курсора воспользуйтесь привязками или меню геометрического калькулятора в полях Центр и т на Панели свойств.

В команде Прямоугольник по трем точкам доступно автосоздание. По умолчанию оно включено (нажата кнопка Автосоздание на Панели специального управления) и прямоугольник автоматически фиксируется в документе после задания необходимого минимума параметров, например, трех вершин. Если автосоздание отключено, то построенный прямоугольник остается незафиксированным в документе, что позволяет изменять его параметры. Для фиксации прямоугольника следует нажать кнопку Создать объект.

Выбор стиля линии...

Группа переключателей Оси на Панели свойств управляет отрисовкой осей симметрии прямоугольника.

За один вызов команды можно построить произвольное количество прямоугольников.

Для выхода из команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Обратите внимание на то, что прямоугольник, построенный в графическом документе, — это единый объект, а не набор отдельных отрезков. Он будет выделяться, редактироваться и удаляться целиком. Прямоугольник же, построенный в эскизе трехмерного элемента, — это, наоборот, набор отдельных отрезков. На каждый из них наложены связи и ограничения, благодаря которым отрезки составляют прямоугольник.

Смотрите также

Другие геометрические объекты


Команда Обновить изображение

Позволяет обновить изображение в активном окне.

При обновлении масштаб отображения документа в окне не изменяется.

Для вызова команды нажмите кнопку Обновить изображение на панели Вид или выберите ее название из меню Вид. Можно также нажать комбинацию клавиш <Ctrl>+<F9>.


Команда Привести текстовую часть к исходному виду

Позволяет отменить редактирование строки отчета, произведенное в Окне подготовки данных.

Команда Привести текстовую часть к исходному виду вызывается из контекстного меню Окна подготовки данных.

После нажатия кнопки строка приобретает тот вид, который она имела после передачи отчета в Окно подготовки данных.


Команда Выровнять позиции по горизонтали

Позволяет расположить на одной горизонтали полки нескольких позиционных линий-выносок.

Выделите позиционные линии-выноски, полки которых необходимо выровнять по горизонтали и нажмите кнопку Выровнять позиции по горизонтали на инструментальной панели Обозначения.

После этого задайте точку, по Y-координате которой требуется выровнять начала полок выбранных линий-выносок. Точку можно указать мышью или ввести ее координаты в поля Базовая точка на Панели свойств.


Команда Выровнять позиции по вертикали

Позволяет расположить на одной вертикали начальные точки полок нескольких позиционных линий-выносок.

Выделите позиционные линии-выноски, полки которых необходимо выровнять по вертикали и нажмите кнопку Выровнять позиции по вертикали на инструментальной панели Обозначения.

После этого задайте точку, по Х-координате которой требуется выровнять начала полок выбранных линий-выносок. Точку можно указать мышью или ввести ее координаты в поля Базовая точка на Панели свойств.


Команда Отношения

Доступна в контекстном меню ассоциативного вида, выделенного в Дереве чертежа или в окне документа.

Команда позволяет просмотреть виды, которые являются исходными и производными для выбранного вида.

После вызова команды на экране появляется диалог иерархии отношений видов.


Команда Отношения в дополнительном окне

Позволяет создать дополнительное окно Дерева построения и отобразить в нем объекты, являющиеся исходными и производными для объекта, выделенного в Дереве построения.

Смотрите также

Просмотр отношений объектов


Команда Выносной элемент (панель Обозначения)

Команда Выносной элемент
(панель Обозначения)

Позволяет создать обозначение выносного элемента.

Для вызова команды нажмите кнопку Выносной элемент на инструментальной панели Обозначения.

Укажите точку центра контура, ограничивающего выносной элемент.

Задайте размеры контура: для окружности — диаметр или радиус, для прямоугольника — ширину и высоту.

Укажите точку начала полки т2.

Обозначение положения выносного элемента

Настройка отрисовки выносного элемента

Формирование текста обозначения выносного элемента аналогично формированию текста обозначения стрелки направления взгляда.

Сразу после создания обозначения выносного элемента автоматически запускается команда создания нового вида. После выполнения команды в чертеже появится вид, обозначение которого будет ассоциативно связано с созданным обозначением выносного элемента.

Если обозначение создавалось в ассоциативном виде, то и новый вид ассоциативный. Он содержит проекцию модели.

Если же обозначение создавалось в обычном (неассоциативном) виде, то и новый вид обычный. Он содержит копии объектов исходного вида, попавших в контур обозначения. Подробнее...

Вы можете отказаться от создания нового вида, нажав кнопку Прервать команду. Однако делать это не рекомендуется, поскольку ручное создание вида и формирование связи между его обозначением и обозначением выносного элемента займет дополнительное время. Кроме того, размещение выносного элемента в отдельном виде позволяет быстро изменять масштаб изображения и делает более удобной компоновку чертежа.

При создании обозначения выносного элемента может автоматически создаваться гиперссылка, связывающая обозначение с вновь созданным видом.

Смотрите также

Другие обозначения


Команда Удалить фаску или скругление

Позволяет удалить отрезок или дугу, соединяющие концы двух других объектов (отрезков или дуг), и продолжить эти объекты до точки их пересечения.

Для вызова команды нажмите кнопку Удалить фаску или скругление на инструментальной панели Редактирование.

Укажите курсором фаску или скругление, подлежащие удалению. Если объекты, которые соединяет указанный отрезок или дуга, можно перестроить, продолжив их до точки пересечения, то фаска или скругление будут удалены.

За один вызов команды вы можете удалить произвольное количество фасок и скруглений.

Для завершения команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие команды редактирования


Сменить направление

Переключатель, позволяющий выбрать, какой участок исходной кривой по отношению к точке пересечения следует удалить.

Текущее состояние переключателя соответствует фантому усеченной кривой.

Чтобы удалить другой участок исходной кривой, нажмите переключатель Сменить направление.

Смена участка исходной кривой немедленно отображается на фантоме.

Сменить участок исходной кривой можно, указав другую ее концевую точку в окне модели.


Команда Удалить текстовую метку

Позволяет удалить текстовую метку. Команда вызывается из контекстного меню выделенного объекта. Команда отображается, если среди выделенных объектов находится объект (объекты) с текстовой меткой.

Подробнее о текстовых метках...


Команда Указать заново

Позволяет переопределить объекты, выбранные для выполнения команды, не прерывая ее.

Для вызова команды нажмите кнопку Указать заново на Панели специального управления или нажмите комбинацию клавиш <Ctrl> + <Shift> + <Z>.

После вызова команды выберите нужные объекты снова.

В некоторых командах задействуется сразу несколько объектов, причем их наименования указаны на разных вкладках Панели свойств. Например, команда Отверстие: объект, задающий глубину отверстия, регистрируется на первой вкладке Панели свойств, а объекты, определяющие положение отверстия, — на второй. В подобных случаях вызов команды Указать заново отменяет выбор объектов, соответствующих текущей вкладке Панели свойств.


Команда Повторный выбор контура — границы обрезки

Позволяет выбрать другой контур в качестве границы обрезки рисунка.

Для перехода к повторному указанию границы нажмите кнопку Повторный выбор контура на Панели специального управления или вызовите команду Указать заново из контекстного меню.

Команда доступна, если граница обрезки уже задана.

После вызова команды укажите контур — границу обрезки, щелкнув по нему мышью (при прохождении курсора над объектами, которые могут использоваться в качестве границы, они подсвечиваются).

Требования к границе обрезки...

Переключатели группы Режим на Панели свойств позволяют указать, требуется ли удалять указанный контур после создания границы или нет.

Связь между рисунком и указанным контуром не формируется, т.е. удаление или редактирование контура не влияет на границу обрезки.


Команда Повторный выбор объекта

Позволяет отказаться от продолжения обхода и начать формирование контура заново (при сборке контура или построении эквидистанты по стрелке).


Команда Значение из источника (контекстное меню Окна переменных)

Команда Значение из источника
(контекстное меню Окна переменных)

Позволяет отменить ручное изменение значения внешней переменной компонента и синхронизировать ее с соответствующей переменной файла-источника этого компонента.

Команда доступна, если для внешней переменной компонента было вручную введено значение или выражение.

После вызова команды Значение из источника переменная получает значение из файла-источника, компонент перестраивается.

До следующего ручного изменения значения этой переменной она будет получать значение из файла-источника при каждом перестроении модели, в которую вставлен компонент.


Команда Восстановить границу

Позволяет восстановить исходное состояние контура выносного элемента. Команда Восстановить границу доступна в контекстном меню выносного элемента, выделенного в Дереве чертежа или в окне документа.


Команда Восстановить кривую

Позволяет вернуть проекционной кривой в исходное состояние (например, после усечения).

Подробнее о проекционной кривой в эскизе...


Команда Восстановить стили

Позволяет привести стили линий, точек и штриховок в ассоциативном виде к умолчательным.

Умолчательными стилями являются:

– для проекций тел и поверхностей — стили, заданные при настройке вида,

– для проекций кривых и точек — стили соответствующих объектов в модели,

– для штриховок — стили, заданные для деталей, компонентов и тел в модели.

Команда Восстановить стили доступна в контекстном меню ассоциативного вида, выделенного в Дереве чертежа или в окне документа.


Выбор результата зеркального отражения компонентов

Результат зеркального отражения выбирается для тех компонентов, способом отражения которых является Зеркальное отражение компонента. В этом случае на инструментальной панели диалога Параметры зеркального отражения компонентов доступна группа Результат:. Кнопки данной группы позволяют выбрать один из вариантов компонента, получаемого в результате выполнения операции. Пиктограмма выбранного варианта отображается в соответствующей компоненту ячейке столбца Результат создания зеркальной модели.

Результат зеркального отражения компонентов

Вариант

Описание

Создать зеркальное исполнение

Зеркально отраженный компонент сохраняется в файле-источнике исходного компонента в виде зеркального исполнения модели, т.е. добавленный компонент является зеркальным исполнением модели исходного.

Данный вариант является умолчательным для всех компонентов, кроме стандартных изделий. Для стандартных изделий выбрать этот вариант нельзя.

Если файл модели исходного компонента недоступен для записи, то для этого компонента по умолчанию выбран вариант Сохранить зеркальный компонент в файле (см. ниже). Это связано с тем, что в данный файл невозможно будет сохранить полученное зеркальное исполнение компонента.

Сохранить зеркальный компонент в файле

Зеркально отраженный компонент сохраняется в отдельном файле, т.е. добавленный компонент является самостоятельной моделью. Полное имя файла, в который добавляется компонент, отображается в диалоге в соответствующей ячейке столбца Файл. Папка для сохранения моделей компонентов выбирается при настройке.

Если сохранение файла невозможно (например, папка, выбранная для сохранения, недоступна для записи), то после нажатия кнопки ОК в диалоге настройки параметров отражения на экране появляется диалог Ошибка сохранения файла. В этом диалоге вы можете выбрать другую папку для сохранения файла или отказаться от создания новой модели для данного компонента. В последнем случае создаваемый компонент будет еще одной вставкой исходного компонента, отраженной зеркально.

Отображать компонент в зеркальном виде

Зеркально отраженный компонент является зеркальной вставкой исходного компонента. Фактически это та же самая модель, вставленная зеркально.

Данный вариант является умолчательным для стандартных изделий.

Если данный вариант выбран для стандартного изделия, не обладающего симметрией, строка этого изделия в диалоге настройки параметров имеет розовый цвет.

Компоненты, входящие в состав другого компонента, не показываются в диалоге, если содержащий их компонент отражается с результатом операции в виде зеркальной вставки (вариант Отображать компонент в зеркальном виде). Если результатом отражения является зеркальное исполнение (вариант Создать зеркальное исполнение), то компоненты не отображаются в следующих случаях.

– Документ содержит несколько вставок одной и той же модели с компонентами, т.е. одна и та же модель с компонентами является источником нескольких компонентов. В этом случае полный состав модели показывается только для первого из компонентов, а компоненты, входящие в остальные, не отображаются.

– Зеркальное исполнение уже есть в файле модели исходного компонента, поэтому оно используется при создании зеркального компонента. Новое зеркальное исполнение не создается. В этом случае строка компонента в диалоге настройки параметров имеет бирюзовый цвет, а компоненты, входящие в него, не отображаются.

При необходимости вы можете выбрать нужный вариант с помощью столбца Результат создания зеркальной модели. Для этого щелкните мышью в ячейке этого столбца, соответствующей компоненту, раскройте список вариантов и укажите нужную строку списка.


Команда Повторить: (команду)

Позволяет повторить последнюю выполненную команду.

Вызовите команду Повторить: (команду) из меню Редактор или из контекстного меню. Это действие равносильно вызову команды через Инструментальную панель.

При закрытии документа последняя команда сохраняется в памяти до конца сеанса работы КОМПАС-3D.

Если условия выполнения команды отсутствуют, то ее повторный вызов невозможен. Например, для выполнения команды Копирование необходимо, чтобы исходные объекты были выделены. Если в документе нет ни одного выделенного объекта, то команда Повторить: Копирование будет недоступна.

Из контекстного меню вы можете вызвать не только последнюю команду, но и одну из предыдущих.

Смотрите также

Повтор последних команд


Команда Поверхность вращения

Позволяет создать в модели поверхность вращения. Поверхность вращения образуется путем поворота сечения вокруг оси.

Для построения в модели поверхности вращения выполните следующие действия.

1. Вызовите команду Поверхность вращения.

2. Задайте параметры на Панели свойств (они аналогичны параметрам операции выдавливания).

• Сечение
Активизируйте переключатель Сечение. Укажите в Дереве построения или в окне модели объект-сечение: эскиз, грань, пространственную кривую или ребро.

Подробнее об указании сечения...

• Ось вращения
Ось вращения может определяться автоматически. Для этого она должна находиться в том же эскизе, что и сечение и являться отрезком со стилем Осевая или объектом Осевая линия.

Чтобы задать другой объект, определяющий ось вращения, активизируйте переключатель Ось. Затем укажите в Дереве построения или в окне модели любой прямолинейный объект или поверхность вращения.

Подробнее об указании оси вращения...

• Тип построения
Выбор типа построения — тороид или сфероид — возможен, если в качестве сечения используется незамкнутый эскиз, а ось вращения лежит в плоскости сечения.

Выберите тип построения с помощью группы переключателей Тип.

Подробнее о типе построения...

• Направление вращения
Выберите направление вращения из списка Направление: Прямое, Обратное, Два направления, Средняя плоскость.

Подробнее о направлении вращения...

• Угол вращения
Выберите способ определения угла вращения из списка Способ и задайте соответствующие способу параметры.

Подробнее о задании угла вращения...

Если было выбрано вращение В двух направлениях, то способ определения угла вращения и параметры требуется задать дважды — для прямого и обратного направления.
Если был выбран вариант Средняя плоскость, то параметры задаются один раз. При этом возможно вращение только на заданный угол (в каждую сторону откладывается его половина).

• Замыкание поверхности
Если в качестве сечения используется грань или замкнутый эскиз, становится доступна опция Замкнутая поверхность. Включите ее, если требуется добавить к поверхности грани, соответствующие начальному и конечному положению сечения.

Объекты, указанные для выполнения операции, подсвечиваются. Поверхность вращения с текущими параметрами отображается на экране в виде фантома. Фантом позволяет визуально проконтролировать правильность задания параметров.

Значение угла вращения можно задать с помощью характерных точек.

3. При необходимости вы можете назначить допуски на значения параметров операции, выраженных в линейных или угловых величинах. Для этого используйте кнопку Назначить допуск, расположенную на Панели свойств рядом с полем числового параметра операции.
Подробнее о допусках...
Подробнее о назначении допуска...

4. При необходимости используйте кнопки Панели специального управления для выполнения следующих действий:

– Построение контура для использования в качестве сечения.

– Построение оси для использования в качестве оси вращения.

– Отмена выбора всех объектов (сечения, оси и т.п.).

– Редактирование эскиза-сечения (доступно, если в качестве сечения используется эскиз).

5. При необходимости вы можете ввести наименование поверхности и настроить ее свойства. Для этого активизируйте вкладку Свойства Панели свойств.

6. Нажмите кнопку Создать объект для завершения операции.

Результат операции — поверхность вращения — появляется в графической области. В Дереве построения появляется пиктограмма операции.

Если требуется прервать операцию до ее завершения, нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Требования к эскизу поверхности вращения

Другие команды создания поверхностей

Особенности задания числовых параметров операции в полях Панели свойств


Команда Указатель под выделенный объект

Позволяет переместить Указатель окончания построения в Дереве построения так, чтобы он разместился под выделенным объектом.

Команда доступна в контекстном меню объектов, находящихся над Указателем.

Указатель находится в окне Дерева, если в нем включено отображение последовательности построения модели.


Команда Деформация поворотом

Позволяет выполнить деформацию поворотом объектов чертежа или фрагмента.

Для вызова команды нажмите кнопку Деформация поворотом на инструментальной панели Редактирование или выберите ее название из меню Редактор.

Укажите объекты для деформации

Укажите точку центра поворота.

Затем укажите базовую точку т1 и точку т2, определяющую новое положение базовой точки.

После фиксации угла поворота будет выполнено перестроение объектов.

Исходное изображение и изображение после деформации поворотом

Правила деформации объектов поворотом:

– элементы, полностью попавшие в рамку выделения, будут просто повернуты на заданный угол относительно центра поворота,

– элементы, частично попавшие в рамку выделения, будут отредактированы таким образом, чтобы их характерные точки, попавшие в рамку выделения, повернулись на заданный угол относительно центра поворота, а характерные точки, не попавшие в рамку выделения, остались на прежнем месте,

– элементы, не попавшие в рамку выделения, не редактируются.

За один вызов команды вы можете отредактировать несколько объектов чертежа.

Для завершения команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие команды редактирования


Команда Повернуть

Позволяет динамически поворачивать изображение модели.

Для вызова команды нажмите кнопку Повернуть на панели Вид или выберите ее название из меню Вид.

Нажмите левую кнопку мыши в окне модели и, не отпуская ее, перемещайте курсор. Модель будет поворачиваться вокруг центральной точки габаритного параллелепипеда.

– Если требуется вращать модель вокруг точки (вершины детали, центра сферы, точки), подведите курсор к нужному объекту в окне модели. Объект подсветится, а курсор примет вид, соответствующий выбираемому объекту. Щелкните левой кнопкой мыши, затем нажмите ее и, не отпуская кнопку, перемещайте курсор (внешний вид курсора изменится на «звездочку» с двумя дугообразными стрелками). Модель будет поворачиваться вокруг выбранной точки.

Направление вращения вокруг центральной точки габаритного параллелепипеда или вокруг точки зависит от направления перемещения курсора.

Чтобы вращать модель вокруг выбранной точки в плоскости экрана, перемещайте курсор (с нажатой левой кнопкой мыши) горизонтально, удерживая при этом нажатой клавишу <Alt>.

– Если требуется вращать модель вокруг оси, прямолинейного ребра, оси конической или цилиндрической грани либо вокруг касательной к кривой, подведите курсор к нужному объекту в окне модели. Элемент подсветится, а курсор примет вид, соответствующий выбираемому объекту. Щелкните левой кнопкой мыши, затем нажмите ее и, не отпуская кнопку, перемещайте курсор. (курсор примет вид «оси» с двумя дугообразными стрелками). Модель будет поворачиваться вокруг выбранной оси.

– Если требуется вращать модель вокруг перпендикуляра к поверхности (грани или плоскости) в некоторой ее точке, подведите курсор к нужной точке поверхности в окне модели и щелкните левой кнопкой мыши. На экране появится фантом оси, перпендикулярной к поверхности в точке указания. Нажмите левую кнопку мыши в окне модели (курсор примет вид «плоскости» с двумя дугообразными стрелками) и, не отпуская ее, перемещайте курсор. Модель будет поворачиваться вокруг выбранной оси.

Если вы пользуетесь мышью с колесом или трехкнопочной мышью, то перейти к вращению модели вокруг центра габаритного параллелепипеда можно и без вызова команды поворота. Для этого просто перемещайте мышь с нажатой средней кнопкой или колесом. Если при этом удерживать нажатой клавишу <Alt>, то модель будет вращаться в плоскости экрана.

Для того чтобы, не выходя из команды, выбрать другой объект, нажмите кнопку Указать заново на Панели специального управления.

Для выхода из команды поворота модели нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Вращение модели с помощью клавиатуры


Команда Шероховатость(графический документ)

Команда Шероховатость
(графический документ)

Позволяет создать обозначение шероховатости поверхности.

Для вызова команды нажмите кнопку Шероховатость на инструментальной панели Обозначения.

Укажите курсором объект для нанесения обозначения шероховатости (контур детали, выносную линию размера и т.п.).

Если вы случайно ошиблись при выборе объекта, нажмите кнопку Указать заново на Панели специального управления и выберите новый базовый отрезок.

Параметр шероховатости и его значение можно выбрать из контекстного меню поля Текст на вкладке Знак Панели свойств. Если обозначение кроме параметра шероховатости должно содержать дополнительные сведения, вызовите диалог ввода надписи обозначения, щелкнув в поле Текст левой кнопкой мыши.

Затем укажите точку, определяющую положение знака. Если указанная точка не принадлежат выбранному объекту, то положение знака будет определяться проекцией указанной точки на объект или его продолжение. В последнем случае объект автоматически будет продолжен на нужное расстояние тонкой линией.

Продление NURBS и кривых Безье невозможно.

Для точного позиционирования курсора воспользуйтесь привязками или меню геометрического калькулятора в поле Положение знака на вкладке Знак Панели свойств.

Настройка отрисовки знака шероховатости

Управление расположением знака шероховатости

Не выходя из команды, вы можете создать несколько обозначений шероховатости. При этом выбранный тип знака и сформированная надпись сохраняются.

Структура обозначения шероховатости определяется ГОСТ 2.309-73 (см. рисунок).

Обозначение шероховатости: а) структура обозначения, соответствующая предыдущей редакции ГОСТ 2.309-73, б) структура обозначения, соответствующая изменению №3, 2003 в ГОСТ 2.309-73

Выбор структуры, используемой в текущем документе, производится в диалоге настройки обозначения шероховатости.

При редактировании проекционного обозначения шероховатости часть элементов управления Панели свойств недоступна. Соответствующие параметры обозначения передаются в чертеж из модели, поэтому их ручное изменение невозможно.

Смотрите также

Другие обозначения


Команда Шероховатость(документ-модель)

Команда Шероховатость
(документ-модель)

Позволяет создать в модели обозначение шероховатости поверхности. Обозначение шероховатости может проставляться на следующих объектах:

– грань тела или поверхности,

– ребро тела или поверхности,

– сегмент пространственной ломаной,

– размер,

– обозначение.

Пример

Для вызова команды нажмите кнопку Шероховатость на инструментальной панели Элементы оформления.

Укажите объект для простановки обозначения шероховатости.

Если требуется сменить выбранный объект, нажмите кнопку Указать заново на Панели специального управления и укажите новый объект.

На экране появляется фантом обозначения.

Вы можете сменить базовую плоскость обозначения с помощью списка Базовая плоскость на вкладке Знак Панели свойств.

Кроме того, если отключено автосоздание объекта (а также при редактировании обозначения) вы можете сместить плоскость обозначения параллельно самой себе, используя элемент управления Положение. Он доступен, если указана точка расположения знака или две точки — начало ответвления и начало полки.

Если в качестве обозначаемого объекта указан размер или обозначение, то обозначение шероховатости располагается в плоскости этого объекта. Изменение положения плоскости невозможно.

Чтобы выбрать тип знака, активизируйте нужный переключатель в группе Тип.

Параметр шероховатости и его значение можно выбрать из контекстного меню поля Текст на вкладке Знак Панели свойств. Если обозначение шероховатости должно содержать дополнительные сведения, вызовите диалог ввода надписи обозначения, щелкнув в поле Текст левой кнопкой мыши.

Настройка отрисовки знака шероховатости

По умолчанию в модели создается обозначение шероховатости на полке.

Укажите точку начала полки.

Пример простановки обозначения шероховатости

Структура обозначения шероховатости определяется ГОСТ 2.309–73.

Выбор структуры, используемой в текущей модели, производится в диалоге настройки обозначения шероховатости для текущей модели. По умолчанию в новых моделях создаются обозначения шероховатости в соответствии с изменением № 3 в ГОСТ 2.309–73.

Не выходя из команды, вы можете создать несколько обозначений шероховатости. При этом выбранный тип знака и сформированная надпись сохраняются.

Смотрите также

Другие элементы оформления


Обработка по контуру

Переключатель, управляющий формированием обозначения шероховатости поверхности, образующей контур.


Поле Высота строк, мм

Введите высоту строк таблицы в это поле.


Удалить строку

Переключатель, позволяющий удалить текущую табличную строку в процессе редактирования выносной надписи.


Вставить строку снизу

Переключатель, позволяющий вставить табличную строку снизу от текущей ячейки в процессе редактирования выносной надписи.


Вставить строку сверху

Переключатель, позволяющий вставить табличную строку сверху от текущей ячейки в процессе редактирования выносной надписи.


Операции со строками таблиц

Чтобы выделить текущую строку таблицы (строку, в ячейке которой находится курсор), нажмите кнопку Выделить строку или вызовите команду Таблица — Строка — Выделить.

Чтобы добавить строку над текущей, нажмите кнопку Вставить строку сверху или вызовите команду Таблица — Строка — Вставить сверху.

Чтобы добавить строку под текущей, нажмите кнопку Вставить строку снизу или вызовите команду Таблица — Строка — Вставить снизу.

Чтобы добавить строку внизу таблицы, установите курсор в крайнюю позицию нижней правой ячейки и нажмите клавишу <Tab>.

Форматирование текста в ячейках новых строк совпадает с форматированием текста в соответствующих ячейках исходной строки.

Чтобы удалить текущую строку таблицы, нажмите кнопку Удалить строку или вызовите команду Таблица — Строка — Удалить.

Команды вставки и удаления строк недоступны, если установлена блокировка размеров таблицы.


Всего строк в отчете

В этом поле отображается количество строк в отчете.

Если панель Текущее состояние расположена вертикально, то для доступа к полю Всего строк нажмите соответствующую кнопку.

Поле находится на панели Текущее состояние в Окне подготовки данных.


Команда Применить фильтр

Позволяет применить фильтр к строкам таблицы, отображенной в Окне подготовки данных.

Команда может быть вызвана:

– нажатием кнопки Применить фильтр на панели Таблица отчета;

– из меню Таблица.

На Панели свойств появляются элементы управления, позволяющие задать условия фильтрации.

Настройка условий фильтрации строк

Чтобы выполнить фильтрацию, нажмите кнопку Создать объект на Панели специального управления.

На экране появляется отфильтрованная таблица.

Редактирование условий фильтрации

Для отмены фильтрации служит команда Удалить фильтры.


Кнопка Фильтровать объекты по свойствам

Позволяет включать и отключать режим фильтрации объектов по свойствам модели.

В режиме фильтрации в отчет попадают объекты со свойствами, удовлетворяющими заданным условиям.

Чтобы включить режим фильтрации, нажмите кнопку Фильтровать объекты по свойствам на Панели специального управления.

Нажатая кнопка означает, что режим фильтрации включен, отжатая — выключен.

Кнопка доступна, если при помощи команды Настроить фильтр объектов по свойствам заданы условия фильтрации.

Чтобы выключить режим фильтрации, нажмите кнопку Фильтровать объекты по свойствам повторно.

В Окне подготовки данных вы можете просмотреть отчет и задать дополнительно фильтрацию строк.


Команда Создать отчет по массиву с таблицей изменяемых переменных

Команда позволяет создать отчет по массиву с таблицей изменяемых переменных.

Чтобы создать отчет по массиву, выполните следующие действия.

1. Откройте модель, содержащую массив с таблицей изменяемых переменных.

2. Вызовите команду Создать отчет по массиву с таблицей изменяемых переменных из меню Сервис — Отчеты или с помощью одноименной кнопки на панели Отчеты.

На Панели свойств появляются элементы создания отчета.

3. Укажите в Дереве построения или в окне модели нужный массив.

Выбор объектов в окне модели
Выбор объектов в Дереве построения модели

Выбор массива без таблицы изменяемых переменных невозможен.

Указанный массив подсвечивается. Название выбранного массива отображается в поле рядом с переключателем Массив.

После выбора массива на экране появляется диалог настройки параметров таблицы отчета по массиву.

Чтобы перевыбрать массив для создания отчета, закройте диалог настройки параметров таблицы отчета и укажите нужный массив. После указания массива на экране снова появится диалог настройки параметров таблицы отчета.

Массив для создания отчета можно указать и перед вызовом команды. В этом случае диалог настройки параметров таблицы отчета следует вызвать нажатием кнопки Настроить... на Панели свойств.

4. Настройте свойства таблицы отчета.

5. Чтобы задать таблице отчета автоматический номер, поместите ее в одну из групп нумерации, выбрав название нужной группы из раскрывающегося списка Нумерация. Номер таблицы формируется в соответствии с положением таблицы в группе и настроенными для этой группы параметрами нумерации. Подробнее о нумерации объектов...

6. С помощью опции Ассоциативный отчет включите/отключите создание ассоциативной связи создаваемого отчета с документом-источником (моделью).

– Если опция включена, то созданный отчет ассоциативно связывается с документом-источником. Изменения в документе-источнике (в таблице изменяемых переменных) будут передаваться в отчет.

– Если опция отключена, то создается отчет без ассоциативной связи с документом-источником. В этом случае изменения в документе-источнике в созданный отчет не будут передаваться.

Опция Ассоциативный отчет присутствует на Панели свойств, если документ-источник сохранен в файл на диске.

Ассоциативный отчет по массиву следует размещать в графическом документе. При размещении в текстовом документе ассоциативная связь отчета с документом-источником не создается.

7. Настройте компоновку таблицы отчета.

8. Чтобы создать отчет, нажмите кнопку Создать объект.

На экране появляется диалог выбора документа или стандартный диалог открытия файлов. Откройте нужный графический или текстовый файл.

– В графическом документе разместите фантом таблицы отчета. Для этого укажите место расположения точки привязки таблицы курсором или путем ввода координат на Панели свойств и щелкните левой кнопкой мыши для фиксации таблицы.

– В текстовом документе таблица отчета размещается автоматически.


Команда Удалить фильтры

Позволяет отменить фильтрацию строк отчета, произведенную в Окне подготовки данных.

Команда может быть вызвана:

– нажатием кнопки Удалить фильтры на панели Таблица отчета;

– из меню Таблица.

Команда доступна, если была выполнена команда Применить фильтр.

После вызова команды отчет на экране приобретает первоначальный вид — все фильтры удаляются.

Отмена фильтрации строк происходит также и при отмене группирования отчета в Окне подготовки данных.

Подробнее о фильтрации строк...


Команда Копировать строку

Позволяет вставить в отчет копию строки.

Для этого выделите строку, которую требуется скопировать, щелкнув по ней мышью.

Вызовите команду Копировать строку из меню Таблица или из контекстного меню.

Команда доступна в Окне подготовки данных в нормальном режиме.

После вызова команды копия добавляется снизу от скопированной строки.


Текущая строка отчета

В этом поле отображается номер строки, в которой находится курсор.

Чтобы переместиться на другую строку отчета, наберите ее номер в этом поле и нажмите клавишу <Enter>.

Если панель Текущее состояние расположена вертикально, то для доступа к полю Текущая строка нажмите соответствующую кнопку.

Поле находится на панели Текущее состояние в Окне подготовки данных.


Команда Редактировать строку

Позволяет войти в режим редактирования строки отчета в Окне подготовки данных команды Создать отчет. Команда применяется для редактирования текста строки и объединения ячеек.

Войти в режим редактирования строки можно следующими способами:

– дважды щелкнуть мышью по строке;

– выделить строку и вызвать команду Редактировать строку из контекстного меню;

– выделить строку и вызвать команду из меню Таблица;

– выделить строку и нажать клавишу <Enter>.

После вызова команды на экране появляется Панель свойств редактирования строки отчета в текстовом режиме.

В текстовом режиме доступны элементы управления панелей Форматирование и Вставка в текст.

Выполните действия по редактированию текста.

Объединение ячеек в строке...

Настройки параметров текста...

Выйти их режима редактирования можно следующими способами:

– нажатием кнопки Создать объект на Панели специального управления;

– щелчком мыши в любом месте таблицы вне редактируемой строки;

– при помощи комбинации клавиш <Ctrl>+<Enter>.

Чтобы отменить редактирование строки, выделите отредактированную строку и вызовите команду Привести текстовую часть к исходному виду из контекстного меню.


Команда Создать отчет

Служит для создания табличных отчетов по свойствам объектов в графическом документе или модели.

Команда может быть вызвана:

– нажатием кнопки Создать отчет на панели Отчеты;

– из меню Сервис — Отчеты.

Чтобы создать отчет, выполните следующие действия.

1. Убедитесь в том, что переключатель Окно подготовки данных на Панели свойств активен.

2. Нажмите кнопку Создать отчет на Панели специального управления.

На экране появляется отчет в Окне подготовки данных.

По умолчанию в отчет по модели включаются все компоненты первого уровня и тела, построенные в сборке, а в отчет по чертежу — все объекты текущего вида.

3. Выполните в Окне действия по настройке, размещению и сохранению отчета.

Работа в Окне подготовки данных...

После закрытия Окна подготовки данных процесс создания отчета не завершается.

После вставки отчета командой Вставить отчет в документ, из которого эта команда вызвана, процесс создания отчета завершается автоматически.

Если переключатель Окно подготовки данных не активен, то отчет после нажатия кнопки Создать отчет размещается в документе. Предварительный просмотр и настройка внешнего вида отчета в этом случае невозможны.

За один вызов команды вы можете создать несколько отчетов, размещая их в отдельных документах или выводя на печать.

При создании отчетов вы можете:

– выбирать объекты:

• указывать объекты с помощью группы Способ на Панели свойств;

• указывать тип объектов на вкладке Объекты;

• фильтровать объекты по свойствам (для документа-модели);

– выбирать и настраивать стиль отчета с помощью элементов управления Стиль;

– включать или отключать автоматическую нумерацию таблиц отчета с помощью списка Нумерация,

– настраивать компоновку таблиц на вкладке Компоновка;

– размещать отчет в новом документе (для документа-модели);

– выбирать вид отчета — ассоциативный отчет или отчет без связи с документом, с данными в виде ссылок или в виде обычного текста.

Для ассоциативных отчетов или отчетов с данными в виде ссылок связь с документом или объектами поддерживается в случае размещения в графическом документе.

Чтобы сменить все объекты, нажмите кнопку Указать заново на Панели специального управления.

Прервать процесс создания отчетов можно, нажав кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Подробнее о команде создания отчета...

Смотрите также

Подготовка к созданию отчета

Задание свойств в документах

Создание и вставка отчета в документы

Пример создания отчета

Пример создания ассоциативного отчета


Команда Вставить отчет

Позволяет вставлять в документ отчет, создаваемый по объектам другого документа.

Команда доступна в графических (*.cdw, *.frw) и текстовом (*.kdw) документе.

Команда может быть вызвана:

– нажатием кнопки Вставить отчет

в графическом документе — на панели Отчеты,

в текстовом документе — на панели Вставка в текст или на вкладке Вставка Панели свойств;

– из меню Вставка.

После вызова команды на экране появляется диалог открытия файлов. Выберите документ-модель или графический документ, объекты которого будут включены в отчет.

Выбранный документ открывается, одновременно в нем запускается процесс создания отчета.

Выполните действия, предусмотренные в команде Создать отчет.

После размещения отчета в документе, из которого вызвана команда Вставить отчет, создание и вставка отчета завершается автоматически.

Подробнее о создании отчета...


Команда С новой страницы

Позволяет переместить строки, начиная с выделенной, в начало следующей страницы.

Выделите строку, с которой должна начинаться новая страница, и вызовите команду одним из способов:

– нажатием кнопки С новой страницы на панели Таблица отчета;

– из меню Таблица;

– из контекстного меню.

Команда доступна в Окне подготовки данных в нормальном режиме.

Чтобы вернуть перемещенные строки на исходную страницу, выделите строку, к которой была применена команда С новой страницы. При этом кнопка вызова команды будет находиться в нажатом состоянии. Затем отожмите кнопку С новой страницы.


Команда Создать таблицу исполнений

Команда позволяет создать таблицу исполнений модели.

Для создания таблицы можно использовать модель или ассоциативный вид с модели, созданный в чертеже.

При создании таблицы в чертеже по умолчанию выбирается текущий ассоциативный вид. Вы можете указать нужный вид до вызова команды создания таблицы или в процессе работы с ней.

Команда вызывается следующими способами:

– из меню Сервис — Отчеты,

– нажатием одноименной кнопки на панели Отчеты.

После вызова команды на Панели свойств появятся элементы создания таблицы исполнений. Кроме того, автоматически откроется диалог Параметры таблицы исполнений, позволяющий настроить внешний вид создаваемой таблицы.

Диалог настройки параметров таблицы можно также вызвать кнопкой Настроить... Панели свойств.

На вкладке Таблица исполнений Панели свойств выполните следующие действия.

С помощью переключателей Обозначение задайте порядок отображения обозначений исполнений в таблице. Если активным является переключатель Только номера исполнений, то для первого исполнения в таблице отображается полное обозначение, а для остальных исполнений — только номера. Чтобы обозначение каждого исполнения отображалось полностью, активизируйте переключатель Полные обозначения.

Чтобы таблица исполнений была ассоциативно связана с документом — источником данных, включите опцию Ассоциативная таблица. При отключенной опции созданная таблица исполнений будет неассоциативной.

Если таблица исполнений создается для модели, то опция Ассоциативная таблица присутствует на Панели свойств только в том случае, если эта модель сохранена в файл на диске.

Ассоциативная таблица может быть размещена только в графическом документе. При размещении в текстовом документе таблица становится неассоциативной вне зависимости от включения опции.

Вы можете задать таблице исполнений автоматический номер. Для этого поместите ее в одну из групп нумерации, выбрав название нужной группы из раскрывающегося списка Нумерация. Номер таблицы формируется в соответствии с положением таблицы в группе и настроенными для этой группы параметрами нумерации. Подробнее о нумерации объектов...

Кроме того, ассоциативная таблица, создаваемая в чертеже для ассоциативного вида с модели, может быть связана с основной надписью чертежа.

Если требуется, чтобы перечень исполнений был представлен в виде нескольких таблиц, откройте вкладку Компоновка и включите опцию Разбить таблицу на этой вкладке. Станут доступными элементы настройки параметров формирования и размещения таблиц.

В поле Строк в таблице задайте максимальное количество строк, входящих в каждую таблицу. Соответственно этому значению общий список исполнений будет разделен на несколько списков, каждый из которых помещается в отдельную таблицу. Параметры отображения всех таблиц одинаковы.

Выберите нужное направление размещения таблиц из раскрывающегося списка Компоновка.

Вариант Вправо, затем вниз позволяет располагать таблицы горизонтальными рядами. Количество таблиц в ряду задается в поле Вправо не более.

Вариант Вниз, затем вправо позволяет располагать таблицы вертикальными рядами. Количество таблиц в ряду задается в поле Вниз не более.

В поле Зазор, мм введите или выберите из раскрывающегося списка расстояние между таблицами.

Для завершения создания таблицы исполнений нажмите кнопку Создать объект на Панели специального управления.

Если создание таблицы выполняется в чертеже, то в поле чертежа появится фантом таблицы. Укажите место расположения точки привязки таблицы курсором или путем ввода координат на Панели свойств и щелкните левой кнопкой мыши для фиксации таблицы.

Подробнее о размещении таблицы...

Если создание таблицы выполняется в модели, то на экране появится диалог открытия файла. Откройте нужный графический или текстовый документ. В графическом документе разместите фантом таблицы, как описано выше. В текстовом документе таблица размещается автоматически.

Чтобы отказаться от создания таблицы, нажмите кнопку Прервать команду.

Смотрите также

Работа с таблицей исполнений


Команда Без рамки и пустых строк

Позволяет отключить в Окне подготовки данных в режиме разметки страниц показ оформления и пустых строк.

Для вызова команды нажмите кнопку Без рамки и пустых строк на панели Режимы при включенном режиме Разметка страниц.

В режиме разметки на экране отображается отчет, расположенный на страницах, у которых не показаны оформление, границы листов и пустые строки на последней странице.

Для навигации по отчету можно использовать панель Текущее состояние.

Подробнее о режимах работы в Окне подготовки данных...


Команда Сохранить текущий отчет как...

Позволяет сохранить отчет в виде отдельных документов следующих типов.

– КОМПАС-Чертежи (файл *.cdw),

– КОМПАС-Фрагменты (файл *.frw),

– КОМПАС-Текстовые документы (файл *.kdw),

– КОМПАС-Таблицы (файл *.tbl),

– Текстовые файлы (файл *.txt),

– Электронные таблицы ODF (файл *.ods),

– Электронные таблицы Microsoft Excel (файл *.xls).

Команда доступна в Окне подготовки данных.

Команда может быть вызвана:

– нажатием кнопки Сохранить текущий отчет как... на панели Таблица отчета;

– из меню Файл.

После нажатия кнопки на экране появляется стандартный диалог сохранения файлов.

Выберите тип файла и введите имя файла.

Для ассоциативных отчетов или отчетов с данными в виде ссылок связь с документом или объектами поддерживается в случае сохранения в файлы *.cdw, *.frw.


Команда Найти... (В Окне подготовки данных отчета)

Команда Найти...
(В Окне подготовки данных отчета)

Позволяет найти в отчете строку, содержащую заданный текст.

Команда Найти... может быть вызвана в Окне подготовки данных из меню Редактор.

После вызова команды на Панели свойств появляются элементы управления, позволяющие настроить параметры поиска.

Введите искомый текст в поле Текст.

Чтобы начать поиск, нажмите кнопку Применить поиск на Панели специального управления.

При активном переключателе К концу документа или К началу документа строка с искомым тестом становится выделенной. Повторите поиск, нажав кнопку Применить поиск. При каждом нажатии кнопки выделяется одна строка, найденная в заданном направлении.

При активном переключателе Найти все все найденные строки становятся выделенными.

Подробнее о поиске...

Если искомый текст не найден, то на экране появляется сообщение об этом.

Команда Найти... также может быть вызвана в режиме редактирования текста из меню Редактор или при помощи комбинации клавиш <Ctrl> + <F>. В этом случае поиск текста производится в пределах текущей ячейки. После вызова команды на экране появляется диалог, позволяющий ввести параметры поиска и замены текста.


Команда Группировать

Позволяет создавать отчет, отображенный в Окне подготовки данных, в сгруппированном или разгруппированном виде.

Команда может быть вызвана:

– нажатием кнопки Группировать на панели Таблица отчета;

– из меню Таблица.

По умолчанию отчет сгруппирован. Это означает, что объекты, имеющие одинаковые свойства в отчете, представлены одной результирующей строкой.

Признаком того, что отчет сгруппирован, является нажатая кнопка на панели или в меню.

Настройка параметров группирования производится в диалоге настройки стиля отчета.

Чтобы просмотреть или изменить параметры группирования, нажмите кнопку Настроить... в группе Стиль на Панели свойств. В появившемся диалоге настройте элемент Группировка.

После внесения изменений в стиль вызовите команду Перестроить таблицу.

Отчет с измененным параметрами группировки отобразится в Окне подготовки данных.

Чтобы привести в отчете полный список объектов, вызовите команду Группировать повторно.

Отмена группирования приводит к отмене фильтрации строк, произведенной в Окне подготовки данных.


Команда Сдвинуть строку вверх/вниз

Позволяет переместить вверх или вниз по таблице строку или диапазон строк.

Для этого выделите строку или один диапазон строк и вызовите команду одним из способов:

– нажатием кнопки Сдвинуть строку вверх/вниз на панели Таблица отчета;

– из меню Таблица;

– из контекстного меню.

Команда доступна в Окне подготовки данных в нормальном режиме.


Команда Передать в документ выделенное

Позволяет составить отчет из выделенных строк и передать его из Окна подготовки данных в документ.

Команда может быть вызвана:

– нажатием кнопки Передать в документ выделенное на панели Таблица отчета;

– из меню Файл.

Команда доступна, если в отчете выделены строки.

Выделение строк

Кнопка Передать в документ выделенное может находиться в нажатом состоянии. Это свидетельствует о том, что отчет находится в режиме просмотра выделенных строк, включенным командой Скрыть все строки, кроме выделенных.

После вызова команды на экране появляется диалог выбора документа или стандартный диалог открытия файлов.

После выбора документа система автоматически переходит к размещению в нем отчета.

Для ассоциативных отчетов или отчетов с данными в виде ссылок связь с документом или объектами поддерживается в случае передачи строк в графический документ.


Команда Передать отчет в документ

Позволяет передать отчет из Окна подготовки данных в документ.

Команда может быть вызвана:

– нажатием кнопки Передать отчет в документ на панели Таблица отчета;

– из меню Файл.

После вызова команды на экране появляется диалог выбора документа или стандартный диалог открытия файлов.

После выбора документа система автоматически переходит к размещению в нем отчета.

Для ассоциативных отчетов или отчетов с данными в виде ссылок связь с документом или объектами поддерживается в случае передачи в графический документ.


Команда Редактор свойств

Позволяет просматривать и редактировать свойства объектов в текущем документе, создавать и добавлять в документ новые свойства, сохранять свойства в виде отчетов или выводить их на печать.

Команда может быть вызвана:

– нажатием кнопки Редактор свойств на панели Отчеты;

– из меню Сервис — Редактор свойств.

Команда доступна в документе-модели или графическом документе.

После вызова команды на экране появляется диалог Редактора свойств. Выполните необходимые действия по настройке и редактированию свойств.

Подробно о работе в Редакторе свойств...

Внесенные изменения свойств передаются объектам текущего документа.


Команда Удалить строку

Позволяет удалить выделенные строки.

Выделите строки и вызовите команду одним из способов:

– нажатием кнопки Удалить строку на панели Таблица отчета;

– из меню Таблица;

– из контекстного меню;

– нажатием клавиши <Delete>.

Команда доступна в Окне подготовки данных в нормальном режиме.


Команда Вставить строку снизу

Позволяет вставить в отчет строку снизу от выделенной строки.

Выделите строку, щелкнув по ней мышью, и вызовите команду одним из способов:

– нажатием кнопки Вставить строку снизу на панели Таблица отчета;

– из меню Таблица;

– из контекстного меню;

– нажатием клавиши <Insert>.

После вызова команды вставляется строка. Одновременно запускается режим редактирования текста, в котором вы можете ввести текст.

Чтобы оставить строку незаполненной, после вставки щелкните мышью по любой строке, нажмите комбинацию клавиш <Ctrl> + <Enter> или клавишу <Esc>.

Команда доступна в Окне подготовки данных в нормальном режиме.


Выделено строк в отчете

В этом поле отображается количество выделенных строк в отчете.

При этом выделение может быть не показано на экране, например, если отчет переведен в режим разметки страниц или к отчету была применена команда Скрыть все строки, кроме выделенных.

Если панель Текущее состояние расположена вертикально, то для доступа к полю Выделено строк нажмите соответствующую кнопку.

Поле находится на панели Текущее состояние в Окне подготовки данных.


Команда Скрыть все строки, кроме выделенных

Позволяет скрыть все строки, за исключением выделенных, в Окне подготовки данных. Команда применяется для просмотра отчета, составленного из выделенных строк.

Команда может быть вызвана:

– нажатием кнопки Скрыть все строки, кроме выделенных на панели Таблица отчета;

– из меню Таблица.

После нажатия кнопки все строки, кроме выделенных, в таблице не показываются.

В режиме скрытия строк редактирование отчета невозможно.

Чтобы привести отчет в состояние, когда все строки показаны, отожмите кнопку Скрыть все строки, кроме выделенных на панели Таблица отчета или вызовите команду из меню Таблица повторно.

Отмена группирования приводит отчет к первоначальному виду, в том числе к отмене скрытия строк.


Команда Настроить фильтр объектов по свойствам

Позволяет задать или отредактировать условия, по которым производится отбор объектов для помещения их в отчет по модели.

Для вызова команды нажмите кнопку Настроить фильтр объектов по свойствам на Панели специального управления.

После вызова команды на Панели свойств появляются элементы управления, позволяющие задать условия фильтрации.

Заданные условия фильтрации будут использованы в режиме фильтрации.

Подробно о фильтрации по свойствам...


Команда Линейчатая поверхность

Позволяет построить поверхность, образованную движением прямой линии в пространстве. Движение производится по двум направляющим. Одной из направляющих может быть точка.

Направляющими могут служить пространственные кривые, ребра, линии эскиза или цепочки перечисленных объектов в любом сочетании, и точечные объекты.

Пример

Для вызова команды нажмите кнопку Линейчатая поверхность на панели Поверхности.

Команда доступна, если в модели есть хотя бы две кривых или одна кривая и точечный объект.

После вызова команды автоматически активизируется переключатель Кривая 1.

Укажите первую направляющую. Кривые, образующие цепочку, следует указывать в порядке их соединения. Название выбранного объекта или количество объектов (в случае указания цепочки) появятся в поле Кривая 1.

Активизируйте переключатель Кривая 2 и укажите вторую направляющую аналогично первой.

На экране появится фантом поверхности.

Если требуется отменить выбор какого-либо из объектов, активизируйте нужный переключатель и укажите этот объект.

Если требуется быстро отменить выбор всех объектов, нажмите кнопку Указать заново на Панели специального управления.

Чтобы проверить поверхность на самопересечения, включите опцию Проверка самопересечений. В случае обнаружения самопересечений созданная поверхность будет отмечена в Дереве как ошибочная.

Вкладка Разбиение Панели свойств позволяет управлять разбиением линейчатой поверхности на грани. Отключив опцию Автоопределение, находящуюся на этой вкладке, вы можете добавлять или удалять ребра, а также перемещать вершины ребер по направляющим. Подробнее об управлении разбиением...

Вкладка Свойства позволяет задать наименование и цвет поверхности.

Завершив выбор направляющих и настройку свойств поверхности, нажмите кнопку Создать объект на Панели специального управления.

Смотрите также

Другие команды создания поверхностей


Группа переключателей Кромки оснований

Служит для выбора формы кромок оснований обечайки.

При активном переключателе Перпендикулярно плоскости листа кромки обрезаются перпендикулярно плоскости развертки обечайки.

При активном переключателе Совпадение с поверхностями оснований кромки обрезаются поверхностями оснований.

Подробнее о кромках оснований...


Группа переключателей Кромки стыка

Служит для выбора формы кромок стыка. Доступна, если указан замкнутый контур.

При активном переключателе Перпендикулярно поверхности листа кромки обрезаются перпендикулярно поверхности обечайки.

При активном переключателе Параллельно друг другу кромки обрезаются параллельными плоскостями.

Подробнее о кромках стыка...


Управление типами загрузки

Управление типами загрузки сборки может производиться с помощью элементов панели Текущее состояние.

В поле Примененный тип загрузки отображается примененный тип загрузки. Чтобы сменить тип загрузки, введите или выберите из списка его наименование.

Список содержит все типы загрузки сборки.

Кнопка Примененный тип загрузки позволяет выполнять следующие действия.

– Если выделен компонент-подсборка в Дереве построения, то нажатие кнопки вызывает список типов загрузки, имеющихся в файле-источнике подсборки. Выбором из списка и нажатием кнопки Применить на Панели специального управления можно сменить примененный тип загрузки.

– В остальных случаях (если выделен объект, не являющийся подсборкой, или объекты не выделены), то нажатие кнопки вызывает команду Типы загрузки для сборки. При помощи команды можно создать, отредактировать, удалить тип загрузки из сборки, а также применить тип загрузки.

Поле Примененный тип загрузки присутствует на Панели, если она расположена горизонтально.

Звездочка (*) перед именем типа загрузки означает, что текущий тип загрузки одного или нескольких компонентов отличается от примененного (т.е. был изменен пользователем или произошла автоматическая смена неполной загрузки на полную).


Команда Сохранить как... (для группы компонентов модели)

Команда Сохранить как...
(для группы компонентов модели)

Позволяет сохранить модель, которая является источником нескольких компонентов модели, в новый файл.

Чтобы выполнить сохранение, выделите нужную ветвь компонентов — деталей, сборок, локальных деталей — и вызовите из контекстного меню команду Сохранить как.... Команда доступна, если для всех компонентов выбранной ветви разрешено редактирование.

После вызова команды на экране появляется диалог сохранения файла.

Укажите папку и имя файла для сохранения и нажмите кнопку Сохранить. При этом модель-источник компонентов записывается в новый файл, а в текущую модель вместо прежних компонентов автоматически вставляются компоненты, источником которых является полученный файл модели. Прежние компоненты удаляются из модели, но их файл на диске не изменяется.

Обратите внимание на то, что при таком варианте сохранения тип документа нельзя изменить, т.е. сборку можно сохранить только как сборку, деталь — как деталь, а локальную деталь — либо как сборку, либо как деталь, в зависимости от того, какой моделью (деталью или сборкой) она является.

После группового сохранения локальных деталей их пиктограммы в Дереве построения текущей модели изменяются.

Смотрите также

Команда Сохранить как... (для компонента модели)


Команда Создать деталь (из объекта модели)

Команда Создать деталь
(из объекта модели)

Позволяет преобразовать объекты, построенные в текущей модели (детали или сборке), в деталь. Полученная деталь сохраняется в отдельном файле (*.m3d). При работе со сборкой она автоматически добавляется в эту сборку в виде компонента.

Команда вызывается из меню Редактор.

Вы можете указать нужные объекты как до, так и после вызова команды. Для преобразования в деталь доступны следующие объекты модели:

– тела,

– поверхности,

– пространственные кривые и точки,

– локальные системы координат,

– вспомогательные плоскости,

– вспомогательные оси.

Обратите внимание, что можно преобразовывать только объекты, построенные непосредственно в модели, а не в каком-либо из ее компонентов. Если требуется преобразовать объект, построенный в компоненте, необходимо войти в режим редактирования этого компонента.

Объекты указываются в Дереве построения или в окне модели (для указания тела или поверхности в окне модели вы можете выделить любую его грань, ребро или вершину).

Если вы выбрали объект в Дереве построения, то команду Создать деталь можно вызвать из контекстного меню.

После вызова команды на Панели свойств появляются элементы управления преобразованием.

1. Для задания обозначения создаваемой детали щелкните мышью в поле Обозначение и выполните необходимые действия в появившемся диалоге.

2. В поле Наименование введите наименование создаваемой детали.

3. Сформируйте набор преобразуемых объектов с помощью панели Список объектов. Объекты, выбранные до вызова команды, уже содержатся в списке. Чтобы добавить объект в список, укажите его в Дереве построения или в Окне модели (для указания тела или поверхности в окне модели вы можете выделить любую его грань, ребро или вершину). Повторное указание объекта удалит его из списка. Можно также удалить объект, выделив его в списке и нажав кнопку Удалить из списка.

В список могут быть добавлены только объекты, указанных выше типов.

4. Выберите способ записи объектов в файл детали, используя группу переключателей Способ.

• Активизируйте переключатель Сохранение с историей, чтобы в новую деталь были переданы сами объекты, их исходные объекты (кроме тех, которые принадлежат другим телам и/или компонентам модели), а также выражения, заданные для вычисления параметров элементов объектов и переменные главного раздела.

• Активизируйте переключатель Сохранение без истории, чтобы в новую деталь были переданы только сами объекты — без исходных объектов, переменных и выражений. В этом случае доступна опция Зеркально. При включенной опции объекты, переданные в новую деталь, будут расположены симметрично своему исходному положению относительно выбранной плоскости. Данная плоскость выбирается из списка Плоскость симметрии, который становится доступным после включения опции.
Подробнее о способах преобразования объектов...

5. При работе со сборкой на Панели свойств присутствуют дополнительные элементы управления.

• Опция Компоновочная геометрия. Включите эту опцию, чтобы новая деталь была добавлена в сборку не в виде компонента, а в виде компоновочной геометрии.

• Опция Удалять оригинал. Включите эту опцию, если после преобразования объекты должны быть удалены из сборки. Обратите внимание на то, что удаляются только объекты, выбранные для преобразования. Их исходные объекты остаются без изменения.

6. Для завершения преобразования нажмите кнопку Создать объект на Панели специального управления.

7. В появившемся диалоге сохранения файла укажите папку и имя файла детали для записи, а затем нажмите кнопку Сохранить. Выбранные объекты будут записаны в указанный файл.

Преобразование объектов в деталь нельзя отменить. Также становится невозможной отмена операций, выполненных в текущей модели до этого преобразования.

Подробнее о преобразовании объектов модели в деталь...


Команда Создать локальную деталь(из объектов сборки)

Команда Создать локальную деталь
(из объектов сборки)

Позволяет преобразовать объекты, построенные в текущей сборке, в локальную деталь этой же сборки. Созданная локальная деталь автоматически добавляется в список компонентов текущей сборки.

Команда вызывается из меню Редактор.

Вы можете указать нужные объекты как до, так и после вызова команды. Для преобразования в локальную деталь доступны следующие объекты сборки:

– тела,

– поверхности,

– пространственные кривые и точки,

– локальные системы координат,

– вспомогательные плоскости,

– вспомогательные оси.

Обратите внимание, что можно преобразовывать только объекты, построенные непосредственно в сборке, а не в каком-либо из ее компонентов. Если компонентом сборки является подсборка, то в режиме ее редактирования вы также можете выполнить преобразование объектов.

Объекты указываются в Дереве построения или в окне модели (для указания тела или поверхности в окне модели вы можете выделить любую его грань, ребро или вершину).

Если вы выбрали объект в Дереве построения, то команду Создать локальную деталь можно вызвать из контекстного меню.

После вызова команды на Панели свойств появляются элементы управления преобразованием.

1. Для задания обозначения создаваемой локальной детали щелкните мышью в поле Обозначение и выполните необходимые действия в появившемся диалоге.

2. В поле Наименование введите наименование локальной детали.

3. Сформируйте набор преобразуемых объектов с помощью панели Список объектов. Объекты, выбранные до вызова команды, уже содержатся в списке. Чтобы добавить объект в список, укажите его в Дереве построения или в Окне модели (для указания тела или поверхности в окне модели вы можете выделить любую его грань, ребро или вершину). Повторное указание объекта удалит его из списка. Можно также удалить объект, выделив его в списке и нажав кнопку Удалить из списка.

В список могут быть добавлены только объекты, указанных выше типов.

4. Если требуется, чтобы созданная локальная деталь добавилась в сборку не в виде компонента, а в виде компоновочной геометрии, включите опцию Компоновочная геометрия.

5. Если после преобразования объекты должны быть удалены из сборки, включите опцию Удалять оригинал.

6. Выберите способ преобразования объектов, используя группу переключателей Способ.

• Активизируйте переключатель Сохранение с историей, чтобы в локальную деталь были переданы сами выбранные объекты, их исходные объекты (кроме тех, которые принадлежат другим телам и/или компонентам сборки), а также выражения, заданные для вычисления параметров элементов объектов и переменные главного раздела.

• Активизируйте переключатель Сохранение без истории, чтобы в локальную деталь были переданы только выбранные объекты — без исходных объектов, переменных и выражений. В этом случае доступна опция Зеркально. При включенной опции объекты, переданные в локальную деталь, будут расположены симметрично своему исходному положению относительно выбранной плоскости. Данная плоскость выбирается из списка Плоскость симметрии, который становится доступным после включения опции.
Подробнее о способах преобразования объектов...

7. Для завершения преобразования нажмите кнопку Создать объект на Панели специального управления. В сборке появится новая локальная деталь.

Преобразование объектов в локальную деталь нельзя отменить. Также становится невозможной отмена операций, выполненных в текущей сборке до этого преобразования.

Преобразование объектов в локальную деталь практически аналогично преобразованию объектов в деталь. Отличие только в том, что в результате преобразования объектов в локальную деталь не создается отдельный файл детали (*.m3d). Локальная деталь хранится в файле той сборки, в которой создается.

Смотрите также

Особенности работы с локальной деталью


Команда Сохранить в коллекцию — Функцию по Х

Команда позволяет сохранить выражение функции, заданное для координаты Х точки кривой при работе с командой Кривая по закону. Выражение функции сохраняется в файл коллекции математических выражений collection.law.

Выражение, сохраненное в файл коллекции, добавляется в группу Из файла коллекции диалога Вставка математического выражения.

Смотрите также

Ввод выражения и задание параметра функции...


Команда Сохранить в коллекцию — Функцию по Y

Команда позволяет сохранить выражение функции, заданное для координаты Y точки кривой при работе с командой Кривая по закону. Выражение функции сохраняется в файл коллекции математических выражений collection.law.

Выражение, сохраненное в файл коллекции, добавляется в группу Из файла коллекции диалога Вставка математического выражения.

Смотрите также

Ввод выражения и задание параметра функции...


Команда Сохранить в коллекцию — Функцию по Z

Команда позволяет сохранить выражение функции, заданное для координаты Z точки кривой при работе с командой Кривая по закону. Выражение функции сохраняется в файл коллекции математических выражений collection.law.

Выражение, сохраненное в файл коллекции, добавляется в группу Из файла коллекции диалога Вставка математического выражения.

Смотрите также

Ввод выражения и задание параметра функции...


Команда Сохранить в коллекцию — Групповой закон

Команда позволяет сохранить групповой закон, заданный для кривой при работе с командой Кривая по закону. Групповой закон сохраняется в файл коллекции математических выражений collection.law. При этом в файл записываются выражения функций, заданные для всех координат точки кривой.

Групповой закон, сохраненный в файл коллекции, добавляется в группу Из файла коллекции диалога Вставка математического выражения.

Смотрите также

Ввод выражения и задание параметра функции...


Команда Сохранить таблицу основной надписи

Позволяет сохранить текущую таблицу, входящую в состав редактируемой основной надписи. Сохранение происходит не в файле на диске, а в открытой для редактирования основной надписи.

Для вызова команды нажмите кнопку Сохранить таблицу или выберите ее название из меню Файл.

Чтобы сохранить основную надпись в файле библиотеки *.lyt на диске, следует выйти из диалога редактирования основной надписи, нажав кнопку OK.


Команда Создать копию

Позволяет в режиме пересчета размеров модели создать копию пересчитанной модели — модель, номинальными размерами которой будут размеры, пересчитанные согласно текущему пересчету.

Чтобы создать копию пересчитанной модели, выполните следующие действия.

1. В режиме пересчета размеров раскройте меню Сервис — Пересчет размеров (или меню кнопки Пересчитать размеры с учетом допусков на панели Режимы).

2. Выберите из появившегося меню команду Создать копию.

3. На экране появится диалог сохранения файла. Укажите в нем имя файла и папку для сохранения, а затем нажмите кнопку Сохранить.

Команда Создать копию доступна только в режиме пересчета размеров.

Смотрите также

Режим пересчета размеров модели


Команда Сохранить все

Позволяет сохранить все открытые КОМПАС-документы. В том случае, если какой-либо из документов сохраняется впервые, на экране появится соответствующий диалог.


Команда Сохранить в файл

Позволяет записать значения параметров ломаной или сплайна в файл.

Для вызова команды можно также нажать кнопку Сохранить в файл на панели Координаты вершин.

Команда доступна, если в таблице параметров есть хотя бы одна не пустая строка.


Команда Отношение длин кривых (меню геометрического калькулятора)

Команда Отношение длин кривых
(меню геометрического калькулятора)

Позволяет вычислить отношение длин двух указанных кривых.

Укажите курсором сначала первую кривую, а затем вторую. Фиксация курсора выполняется нажатием левой кнопки мыши или клавиши <Enter>.

После того как значение отношения первой длины ко второй будет вычислено, оно автоматически будет занесено в поле Панели свойств.

Размер «ловушки» курсора можно изменить в диалоге настройки курсора.

Смотрите также

Геометрический калькулятор

Меню геометрического калькулятора


Команда Отношение радиусов (меню геометрического калькулятора)

Команда Отношение радиусов
(меню геометрического калькулятора)

Позволяет вычислить отношение радиусов двух указанных дуг или окружностей.

Укажите курсором сначала первую дугу или окружность, а затем вторую. Фиксация курсора выполняется нажатием левой кнопки мыши или клавиши <Enter>.

После того как значение отношения первого радиуса ко второму будет вычислено, оно автоматически будет занесено в поле Панели свойств.

Размер «ловушки» курсора можно изменить в диалоге настройки курсора.

Смотрите также

Геометрический калькулятор

Меню геометрического калькулятора


Команда Угловая привязка (меню привязок)

Команда Угловая привязка
(меню привязок)

При выборе данного способа привязки курсор будет перемещаться относительно последней зафиксированной точки под углами, кратными указанному при настройке привязок значению.

Для включения глобальной угловой привязки нажмите одноименную кнопку на панели Глобальные привязки или вызовите одноименную команду из меню кнопки Привязки на панели Текущее состояние.

Для включения локальной угловой привязки нажмите одноименную кнопку на панели Локальные привязки или вызовите одноименную команду из контекстного меню.

Например, при настройке привязок значение шага угловой привязки установлено равным 15°. Тогда в результате действия угловой привязки курсор будет перемещаться вдоль прямых, проходящих через последнюю зафиксированную точку, под углами 15°, 30°, 45°, 60°, 90°, 105° и т.д.

Последней зафиксированной точкой считается не только точка, указанная при выполнении какой-либо команды, но и точка, в которую курсор был установлен при помощи клавиатурной привязки.

Например, вы нарисовали отрезок. Последней зафиксированной точкой является его конечная точка (p2). Если теперь с помощью комбинации клавиш <Сtrl>+<.> привязаться к ближайшей точке этого отрезка, она (ближайшая точка) станет последней зафиксированной точкой, и курсор начнет перемещаться относительно нее под углами, кратными шагу угла привязки.

Отсчет углов ведется в текущей системе координат.

По умолчанию шаг угловой привязки равен 45°.

Смотрите также

Глобальные и локальные привязки

Общие сведения о привязках


Команда Раствор дуги (меню геометрического калькулятора)

Команда Раствор дуги
(меню геометрического калькулятора)

Позволяет снять значение угла раствора заданной дуги окружности.

Укажите курсором точку на дуге, угол раствора которой нужно определить. Фиксация курсора выполняется нажатием левой кнопки мыши или клавиши <Enter>.

После того как значение угла раствора будет вычислено, оно автоматически будет занесено в поле Панели свойств.

Размер «ловушки» курсора можно изменить в диалоге настройки курсора.

Смотрите также

Геометрический калькулятор

Меню геометрического калькулятора


Команда Полуось эллипса — Большая (меню геометрического калькулятора)

Команда Полуось эллипса — Большая
(меню геометрического калькулятора)

Позволяет выполнить снятие длины большой полуоси эллипса.

Укажите курсором эллипс, величину большой полуоси которого нужно определить. Фиксация курсора выполняется нажатием левой кнопки мыши или клавиши <Enter>.

После того как значение длины полуоси будет вычислено, оно автоматически будет занесено в поле Панели свойств.

Размер «ловушки» курсора можно изменить в диалоге настройки курсора.

Смотрите также

Геометрический калькулятор

Меню геометрического калькулятора


Команда Полуось эллипса — Малая (меню геометрического калькулятора)

Команда Полуось эллипса — Малая
(меню геометрического калькулятора)

Позволяет выполнить снятие длины малой полуоси эллипса.

Укажите курсором эллипс, величину малой полуоси которого нужно определить. Фиксация курсора выполняется нажатием левой кнопки мыши или клавиши <Enter>.

После того как значение длины полуоси будет вычислено, оно автоматически будет занесено в поле Панели свойств.

Размер «ловушки» курсора можно изменить в диалоге настройки курсора.

Смотрите также

Геометрический калькулятор

Меню геометрического калькулятора


Команда Полуось эллипса

После вызова команды на экран выводится дополнительное меню, из которого следует выбрать, величину какой полуоси эллипса необходимо определить.

Большая

Малая

Смотрите также

Меню геометрического калькулятора

Геометрический калькулятор


Команда По 2 точкам (с осью Х) (меню геометрического калькулятора)

Команда По 2 точкам (с осью Х)
(меню геометрического калькулятора)

Позволяет снять значение угла между воображаемой линией, проходящей через две заданные точки, и положительным направлением оси X текущей системы координат.

Последовательно укажите курсором первую и вторую точки, через которые проходит воображаемая линия. Фиксация курсора выполняется нажатием левой кнопки мыши или клавиши <Enter>.

После того как значение угла наклона линии будет вычислено, оно автоматически будет занесено в поле Панели свойств.

Размер «ловушки» курсора можно изменить в диалоге настройки курсора.

Смотрите также

Геометрический калькулятор

Меню геометрического калькулятора


Команда По 3 точкам (меню геометрического калькулятора)

Команда По 3 точкам
(меню геометрического калькулятора)

Позволяет снять значение угла между двумя воображаемыми линиями, каждая из которых определяется двумя заданными точками.

Укажите курсором первую (центральную) точку, общую для двух линий, а затем вторую и третью точки. Фиксация курсора выполняется нажатием левой кнопки мыши или клавиши <Enter>.

После того как значение угла между линиями будет вычислено, оно автоматически будет занесено в поле Панели свойств.

Размер «ловушки» курсора можно изменить в диалоге настройки курсора.

Смотрите также

Геометрический калькулятор

Меню геометрического калькулятора


Команда По точке на окружности/дуге (меню геометрического калькулятора)

Команда По точке на окружности/дуге
(меню геометрического калькулятора)

Позволяет снять значение угла между радиусом, проведенным из центра окружности в указанную на ней точку, и положительным направлением оси X текущей системы координат.

Укажите курсором нужную точку на окружности. Фиксация курсора выполняется нажатием левой кнопки мыши или клавиши <Enter>.

После того как значение угла между радиусом и осью X будет вычислено, оно автоматически будет занесено в поле Панели свойств.

Размер «ловушки» курсора можно изменить в диалоге настройки курсора.

Смотрите также

Геометрический калькулятор

Меню геометрического калькулятора


Команда Точка кривой, ближайшая к другой кривой (меню геометрического калькулятора)

Команда Точка кривой, ближайшая к другой кривой
(меню геометрического калькулятора)

Позволяет выполнить снятие значений координат точки, расположенной на указанном элементе и ближайшей к другому элементу.

Укажите элемент, на котором должна находиться точка, а затем — второй элемент, до которого будет определяться минимальное расстояние. Фиксация курсора выполняется нажатием левой кнопки мыши или клавиши <Enter>.

После того как положение точки будет вычислено, значения ее координат автоматически будут занесены в поля Панели свойств.

Размер «ловушки» курсора можно изменить в диалоге настройки курсора.

Смотрите также

Геометрический калькулятор

Меню геометрического калькулятора


Команда Длина сегмента (меню геометрического калькулятора)

Команда Длина сегмента
(меню геометрического калькулятора)

Позволяет снять значение длины сегмента ломаной или контура.

Установите курсор так, чтобы его «ловушка» захватывала нужный сегмент. После этого зафиксируйте курсор нажатием левой кнопки мыши или клавиши <Enter>.

После того как значение длины сегмента будет вычислено, оно автоматически будет занесено в поле Панели свойств.

Размер «ловушки» курсора можно изменить в диалоге настройки курсора.

Смотрите также

Геометрический калькулятор

Меню геометрического калькулятора


Команда Диаметр (меню геометрического калькулятора)

Команда Диаметр
(меню геометрического калькулятора)

Позволяет снять значение диаметра окружности или дуги.

Укажите курсором дугу или окружность, диаметр которой нужно определить. Фиксация курсора выполняется нажатием левой кнопки мыши или клавиши <Enter>.

После того как значение диаметра будет вычислено, оно автоматически будет занесено в поле Панели свойств.

Размер «ловушки» курсора можно изменить в диалоге настройки курсора.

Смотрите также

Геометрический калькулятор

Меню геометрического калькулятора


Команда Между 2 точками на кривой (меню геометрического калькулятора)

Команда Между 2 точками на кривой
(меню геометрического калькулятора)

Позволяет снять расстояние между двумя точками, лежащими на указанном элементе.

Последовательно укажите курсором элемент, а затем лежащие на нем точки, расстояние между которыми нужно определить. Фиксация курсора выполняется нажатием левой кнопки мыши или клавиши <Enter>.

После того как значение расстояния будет вычислено, оно автоматически будет занесено в поле Панели свойств.

Размер «ловушки» курсора можно изменить в диалоге настройки курсора.

Смотрите также

Геометрический калькулятор

Меню геометрического калькулятора


Команда Наклон оси эллипса (меню геометрического калькулятора)

Команда Наклон оси эллипса
(меню геометрического калькулятора)

Позволяет снять значение угла между большой (главной) осью заданного эллипса и положительным направлением оси X текущей системы координат.

Укажите курсором эллипс, угол наклона большой оси которого нужно определить. Фиксация курсора выполняется нажатием левой кнопки мыши или клавиши <Enter>.

После того как значение угла наклона оси будет вычислено, оно автоматически будет занесено в поле Панели свойств.

Размер «ловушки» курсора можно изменить в диалоге настройки курсора.

Смотрите также

Геометрический калькулятор

Меню геометрического калькулятора


Команда По сетке (меню привязок)

Команда По сетке
(меню привязок)

Позволяет выполнить привязку к ближайшей точке вспомогательной сетки. При этом изображение самой сетки на экране может быть выключено.

Для включения глобальной привязки По сетке нажмите одноименную кнопку на панели Глобальные привязки или вызовите одноименную команду из меню кнопки Привязки на панели Текущее состояние.

Для включения локальной привязки По сетке нажмите одноименную кнопку на панели Локальные привязки или вызовите одноименную команду из контекстного меню.

Размер «ловушки» курсора можно изменить в диалоге настройки курсора.

Смотрите также

Глобальные и локальные привязки

Общие сведения о привязках


Команда Пересечение (меню привязок)

Команда Пересечение
(меню привязок)

Позволяет выполнить привязку к ближайшему пересечению объектов.

Для включения глобальной привязки Пересечение нажмите одноименную кнопку на панели Глобальные привязки или вызовите одноименную команду из меню кнопки Привязки на панели Текущее состояние.

Для включения локальной привязки Пересечение нажмите одноименную кнопку на панели Локальные привязки или вызовите одноименную команду из контекстного меню.

Для привязки установите курсор так, чтобы точка пересечения, которую нужно захватить, находилась внутри «ловушки» курсора. После этого зафиксируйте курсор нажатием левой кнопки мыши или клавиши <Enter>.

Размер «ловушки» курсора можно изменить в диалоге настройки курсора.

Смотрите также

Глобальные и локальные привязки

Общие сведения о привязках


Команда Направление прямой/отрезка (меню геометрического калькулятора)

Команда Направление прямой/отрезка
(меню геометрического калькулятора)

Позволяет снять значение угла между прямой или отрезком и положительным направлением оси X текущей системы координат.

Укажите курсором отрезок или прямую, для которой нужно определить угол наклона к оси X. Фиксация курсора выполняется нажатием левой кнопки мыши или клавиши <Enter>.

После того как значение угла будет вычислено, оно автоматически будет занесено в поле Панели свойств.

Размер «ловушки» курсора можно изменить в диалоге настройки курсора.

Смотрите также

Геометрический калькулятор

Меню геометрического калькулятора


Команда Между прямыми/отрезками (меню геометрического калькулятора)

Команда Между прямыми/отрезками
(меню геометрического калькулятора)

Позволяет снять значение угла между двумя прямыми или отрезками.

Последовательно укажите курсором первый и второй элементы, угол между которыми нужно определить. Фиксация курсора выполняется нажатием левой кнопки мыши или клавиши <Enter>.

После того как значение угла между элементами будет вычислено, оно автоматически будет занесено в поле Панели свойств.

Размер «ловушки» курсора можно изменить в диалоге настройки курсора.

Смотрите также

Геометрический калькулятор

Меню геометрического калькулятора


Команда Ближайшая точка (меню привязок)

Команда Ближайшая точка
(меню привязок)

Позволяет выполнить привязку к ближайшей характерной точке объекта (например, к начальной точке отрезка), к угловым точкам таблицы основной надписи или к точке начала текущей системы координат.

Для включения глобальной привязки Ближайшая точка нажмите одноименную кнопку на панели Глобальные привязки или вызовите одноименную команду из меню кнопки Привязки на панели Текущее состояние.

Для включения локальной привязки Ближайшая точка нажмите одноименную кнопку на панели Локальные привязки или вызовите одноименную команду из контекстного меню.

Для привязки установите курсор так, чтобы характерная точка объекта, которую нужно захватить, находилась внутри «ловушки» курсора. После этого зафиксируйте курсор нажатием левой кнопки мыши или клавиши <Enter>.

Размер «ловушки» курсора можно изменить в диалоге настройки курсора.

Смотрите также

Глобальные и локальные привязки

Общие сведения о привязках


Команда Нормаль (меню привязок)

Команда Нормаль
(меню привязок)

Позволяет выполнить привязку таким образом, чтобы создаваемый объект (например, отрезок) располагался перпендикулярно указанному объекту.

Для включения глобальной привязки Нормаль нажмите одноименную кнопку на панели Глобальные привязки или вызовите одноименную команду из меню кнопки Привязки на панели Текущее состояние.

Для включения локальной привязки Нормаль нажмите одноименную кнопку на панели Локальные привязки или вызовите одноименную команду из контекстного меню.

Для привязки установите курсор так, чтобы точка пересечения создаваемого объекта и объекта, перпендикулярно которому он должен располагаться, находилась внутри «ловушки». После этого зафиксируйте курсор нажатием левой кнопки мыши или клавиши <Enter>.

Размер «ловушки» курсора можно изменить в диалоге настройки курсора.

Смотрите также

Глобальные и локальные привязки

Общие сведения о привязках


Команда Наклон нормали (меню геометрического калькулятора)

Команда Наклон нормали
(меню геометрического калькулятора)

Позволяет снять значение угла между нормалью к элементу, проходящей через заданную точку на этом элементе, и положительным направлением оси X текущей системы координат.

Укажите курсором точку на элементе (дуге, окружности, сплайне и т.д.), через которую должна проходить нормаль. Фиксация курсора выполняется нажатием левой кнопки мыши или клавиши <Enter>.

После того как значение угла наклона нормали будет вычислено, оно автоматически будет занесено в поле Панели свойств.

Размер «ловушки» курсора можно изменить в диалоге настройки курсора.

Смотрите также

Геометрический калькулятор

Меню геометрического калькулятора


Команда Центр (меню привязок)

Команда Центр
(меню привязок)

Позволяет выполнить привязку к центральной точке окружности, дуги или эллипса.

Для включения глобальной привязки Центр нажмите одноименную кнопку на панели Глобальные привязки или вызовите одноименную команду из меню кнопки Привязки на панели Текущее состояние.

Для включения локальной привязки Центр нажмите одноименную кнопку на панели Локальные привязки или вызовите одноименную команду из контекстного меню.

Для привязки установите курсор так, чтобы его «ловушка» захватывала нужный элемент. После этого зафиксируйте курсор нажатием левой кнопки мыши или клавиши <Enter>.

Размер «ловушки» курсора можно изменить в диалоге настройки курсора.

Смотрите также

Глобальные и локальные привязки

Общие сведения о привязках


Команда Габарит объекта

После вызова команды на экран выводится дополнительное меню, из которого следует выбрать, величину какого габарита объекта необходимо определить.

По горизонтали

По вертикали

Смотрите также

Меню геометрического калькулятора

Геометрический калькулятор


Команда Середина (меню привязок)

Команда Середина
(меню привязок)

Позволяет выполнить привязку к середине объекта или к середине стороны внутренней рамки листа чертежа.

Для включения глобальной привязки Середина нажмите одноименную кнопку на панели Глобальные привязки или вызовите одноименную команду из меню кнопки Привязки на панели Текущее состояние.

Для включения локальной привязки Середина нажмите одноименную кнопку на панели Локальные привязки или вызовите одноименную команду из контекстного меню.

Для привязки установите курсор так, чтобы его «ловушка» захватывала нужный объект. После этого зафиксируйте курсор нажатием левой кнопки мыши или клавиши <Enter>.

Размер «ловушки» курсора можно изменить в диалоге настройки курсора.

Смотрите также

Глобальные и локальные привязки

Общие сведения о привязках


Команда Длина кривой (меню геометрического калькулятора)

Команда Длина кривой
(меню геометрического калькулятора)

Позволяет снять значение длины (периметра) указанного элемента.

Установите курсор так, чтобы его «ловушка» захватывала нужный элемент. После этого зафиксируйте курсор нажатием левой кнопки мыши или клавиши <Enter>.

После того как значение длины будет вычислено, оно автоматически будет занесено в поле ввода Панели свойств.

Размер «ловушки» курсора можно изменить в диалоге настройки курсора.

Смотрите также

Геометрический калькулятор

Меню геометрического калькулятора


Команда Между 2 кривыми (меню геометрического калькулятора)

Команда Между 2 кривыми
(меню геометрического калькулятора)

Позволяет снять расстояние между ближайшими точками указанных элементов.

Последовательно укажите курсором два элемента, расстояние между которыми нужно определить. Фиксация курсора выполняется нажатием левой кнопки мыши или клавиши <Enter>.

После того как значение расстояния будет вычислено, оно автоматически будет занесено в поле Панели свойств.

Размер «ловушки» курсора можно изменить в диалоге настройки курсора.

Смотрите также

Геометрический калькулятор

Меню геометрического калькулятора


Команда От точки до кривой

После вызова команды на экран выводится дополнительное меню, из которого следует выбрать нужный вариант определения расстояния.

По нормали

По Y

Против Y

По X

Против X

Смотрите также

Меню геометрического калькулятора

Геометрический калькулятор


Команда От точки до кривой — По нормали (меню геометрического калькулятора)

Команда От точки до кривой — По нормали
(меню геометрического калькулятора)

Позволяет снять значение кратчайшего расстояния между точкой и элементом.

Последовательно укажите курсором точку и элемент, кратчайшее расстояние между которыми нужно определить. Фиксация курсора выполняется нажатием левой кнопки мыши или клавиши <Enter>.

После того как значение расстояния будет вычислено, оно автоматически будет занесено в поле Панели свойств.

Размер «ловушки» курсора можно изменить в диалоге настройки курсора.

Смотрите также

Геометрический калькулятор

Меню геометрического калькулятора


Команда От точки до кривой — Против Y (меню геометрического калькулятора)

Команда От точки до кривой — Против Y
(меню геометрического калькулятора)

Позволяет снять расстояние между точкой и элементом в направлении, противоположном оси Y текущей системы координат.

Последовательно укажите курсором точку и элемент, расстояние между которыми нужно определить. Фиксация курсора выполняется нажатием левой кнопки мыши или клавиши <Enter>.

После того как значение расстояния будет вычислено, оно автоматически будет занесено в поле Панели свойств.

Размер «ловушки» курсора можно изменить в диалоге настройки курсора.

Смотрите также

Геометрический калькулятор

Меню геометрического калькулятора


Команда От точки до кривой — Против Х (меню геометрического калькулятора)

Команда От точки до кривой — Против Х
(меню геометрического калькулятора)

Позволяет снять расстояние между точкой и элементом в направлении, противоположном оси X текущей системы координат.

Последовательно укажите курсором точку и элемент, расстояние между которыми нужно определить. Фиксация курсора выполняется нажатием левой кнопки мыши или клавиши <Enter>.

После того как значение расстояния будет вычислено, оно автоматически будет занесено в поле Панели свойств.

Размер «ловушки» курсора можно изменить в диалоге настройки курсора.

Смотрите также

Геометрический калькулятор

Меню геометрического калькулятора


Команда От точки до кривой — По Х (меню геометрического калькулятора)

Команда От точки до кривой — По Х
(меню геометрического калькулятора)

Позволяет снять расстояние между точкой и элементом в положительном направлении оси X текущей системы координат.

Последовательно укажите курсором точку и элемент, расстояние между которыми нужно определить. Фиксация курсора выполняется нажатием левой кнопки мыши или клавиши <Enter>.

После того как значение расстояния будет вычислено, оно автоматически будет занесено в поле Панели свойств.

Размер «ловушки» курсора можно изменить в диалоге настройки курсора.

Смотрите также

Геометрический калькулятор

Меню геометрического калькулятора


Команда От точки до кривой — По Y (меню геометрического калькулятора)

Команда От точки до кривой — По Y
(меню геометрического калькулятора)

Позволяет снять расстояние между точкой и элементом в положительном направлении оси Y текущей системы координат.

Последовательно укажите курсором точку и элемент, расстояние между которыми нужно определить. Фиксация курсора выполняется нажатием левой кнопки мыши или клавиши <Enter>.

После того как значение расстояния будет вычислено, оно автоматически будет занесено в поле Панели свойств.

Размер «ловушки» курсора можно изменить в диалоге настройки курсора.

Смотрите также

Геометрический калькулятор

Меню геометрического калькулятора


Команда Между 2 точками (меню геометрического калькулятора)

Команда Между 2 точками
(меню геометрического калькулятора)

Позволяет снять расстояние между двумя указанными точками.

Последовательно укажите курсором положение точек, расстояние между которыми нужно определить. Фиксация курсора выполняется нажатием левой кнопки мыши или клавиши <Enter>.

После того как значение расстояния будет вычислено, оно автоматически будет занесено в поле Панели свойств.

Размер «ловушки» курсора можно изменить в диалоге настройки курсора.

Смотрите также

Геометрический калькулятор

Меню геометрического калькулятора


Команда Точка на кривой (меню привязок)

Команда Точка на кривой
(меню привязок)

Позволяет выполнить привязку к ближайшей точке указанной кривой.

Для включения глобальной привязки Точка на кривой нажмите одноименную кнопку на панели Глобальные привязки или вызовите одноименную команду из меню кнопки Привязки на панели Текущее состояние.

Для включения локальной привязки Точка на кривой нажмите одноименную кнопку на панели Локальные привязки или вызовите одноименную команду из контекстного меню.

Для привязки установите курсор так, чтобы его «ловушка» захватывала нужную кривую. После этого зафиксируйте курсор нажатием левой кнопки мыши или клавиши <Enter>.

Размер «ловушки» курсора можно изменить в диалоге настройки курсора.

Смотрите также

Глобальные и локальные привязки

Общие сведения о привязках


Команда Радиус (меню геометрического калькулятора)

Команда Радиус
(меню геометрического калькулятора)

Позволяет снять значение радиуса окружности или дуги.

Укажите курсором дугу или окружность, радиус которой нужно определить. Фиксация курсора выполняется нажатием левой кнопки мыши или клавиши <Enter>.

После того как значение радиуса будет вычислено, оно автоматически будет занесено в поле Панели свойств.

Размер «ловушки» курсора можно изменить в диалоге настройки курсора.

Смотрите также

Геометрический калькулятор

Меню геометрического калькулятора


Команда Выровнять по двум точкам (меню геометрического калькулятора)

Команда Выровнять по двум точкам
(меню геометрического калькулятора)

Позволяет снять значения координат точки, выровненной по двум другим точкам. Точка считается выровненной по двум другим точкам, если они являются ее проекциями на оси текущей СК. Для указания точек удобно использовать привязки.

Пример построения точки, выровненной по точкам A и B

Укажите курсором первую, а затем вторую точку, не лежащие на одной оси текущей СК (на рисунке точки A и B).

Фиксация курсора выполняется нажатием левой кнопки мыши или клавиши <Enter>.

После указания точек на экране отображается фантом одного из двух вариантов создаваемой точки. Чтобы отобразился другой вариант точки, подведите курсор к этой точке. После того как появится фантом нужной точки, зафиксируйте курсор еще раз.

Чтобы указать другую пару точек, нажмите кнопку Указать заново.

После завершения работы команды координаты точки будут вычислены и автоматически занесены в поля Панели свойств.

Размер «ловушки» курсора можно изменить в диалоге настройки курсора.

Смотрите также

Геометрический калькулятор

Меню геометрического калькулятора


Команда Условное пересечение (меню геометрического калькулятора)

Команда Условное пересечение
(меню геометрического калькулятора)

Позволяет снять значения координат точки, расположенной на пересечении продолжений двух указанных объектов, с автоматическим построением их условного пересечения, как при выполнении команды Условное пересечение.

Пример указания точек привязки размера: a) указание первого объекта (т1); б) указание второго объекта (т1); в) результат работы команды создания размера
а) | б | в)

После вызова команды укажите курсором первый, а затем второй объект ближе к той его конечной точке, от которой следует построить его продолжение. Фиксация курсора выполняется нажатием левой кнопки мыши или клавиши <Enter>.

При попадании второго объекта в «ловушку» курсора на экране появляется фантом условного пересечения. Это происходит, если для данной пары объектов существует хотя бы один вариант построения.

Если точек пересечения несколько, то для отображения другого варианта фантома подведите курсор, не фиксируя его, ближе к другой конечной точки объекта. После появления фантома в нужной точке зафиксируйте курсор.

Чтобы указать другую пару объектов, нажмите кнопку Указать заново на Панели специального управления.

После завершения работы команды координаты точки будут вычислены и автоматически занесены в поля Панели свойств.

Для построения используются умолчательные значения параметров, задаваемые в разделе Условное пересечение диалога настройки документа.

По умолчанию созданное условное пересечение никак не связано с объектами, указанными в ходе выполнения команды, и может редактироваться отдельно.

Размер «ловушки» курсора можно изменить в диалоге настройки курсора.

Смотрите также

Геометрический калькулятор

Меню геометрического калькулятора


Команда На расстоянии от точки (меню геометрического калькулятора)

Команда На расстоянии от точки
(меню геометрического калькулятора)

Позволяет снять значения координат точки, расположение которой определяется параметрами вектора смещения от базовой точки.

Укажите курсором точку, являющейся базовой для отсчета параметров. Фиксация курсора выполняется нажатием левой кнопки мыши или клавиши <Enter>. После указания базовой точки на экране появляется фантом вектора смещения и на Панели свойств становятся доступными поля смещения по осям X и Y, расстояния и угла.

Введите любые два из параметров смещения от базовой точки.

После ввода первого параметра он фиксируется на экране и отображается в виде прямой, параллельной оси координат, или радиуса-вектора заданной длины, или направления радиуса-вектора. Второй параметр может быть введен как с Панели свойств, так и указанием мыши.

Для указания точек удобно использовать привязки.

Чтобы выбрать другую базовую точку, нажмите кнопку Указать заново.

После завершения работы команды координаты точки будут вычислены и автоматически занесены в поля Панели свойств.

Размер «ловушки» курсора можно изменить в диалоге настройки курсора.

Смотрите также

Геометрический калькулятор

Меню геометрического калькулятора


Команда На расстояниях от двух кривых (меню геометрического калькулятора)

Команда На расстояниях от двух кривых
(меню геометрического калькулятора)

Позволяет снять значения координат точки, расположенной на заданных расстояниях от указанных элементов. При выполнении команды автоматически строятся точки пересечения эквидистант (или их продолжений) указанных элементов.

Указываемые элементы могут являться частями объектов, например, сегментами ломаной. Они могут входить в состав макроэлементов, вставок фрагментов и видов.

Эквидистанты отрезков и прямолинейных фрагментов других объектов автоматически строятся бесконечно продолженными.

Эквидистанты остальных элементов (дуг, кривых Безье, волнистой линии и т.п) не имеют продолжения.

После вызова команды выполните следующие действия.

1. Задайте расстояния от кривых до создаваемой точки на Панели свойств.

2. Укажите курсором первый, а затем второй элемент для построения точки. Фиксация курсора выполняется нажатием левой кнопки мыши или клавиши <Enter>.

При попадании второго элемента в «ловушку» курсора на экране появляются фантомы эквидистант или продолжений эквидистант и всех их точек пересечения (рис. а). Это происходит, если для данной пары элементов существует хотя бы одна точка пересечения или касания их эквидистант. Если точек пересечения нет, то элемент не подсвечивается.

До момента фиксации второго элемента расстояния от кривых до точки можно изменить.

Пример построения: а) отображение точек при наведении курсора на вторую кривую, б), отображение точки после фиксации курсора, в) смена варианта точки, г) результат построения точки 1
a) | б) | в) | г)

3. В зависимости от типа указанных элементов возможны следующие способы завершения работы команды.

– Если точка пересечения единственная, то после второй фиксации курсора команда завершается автоматически.

– Если точек пересечения несколько, то система ожидает выбора нужной точки. При этом на экране будет находиться фантом точки пересечения, ближайшей к месту указания курсором элемента (рис. б). Чтобы отобразился другой вариант точки пересечения, подведите курсор к этой точке (рис. в). После того как появится фантом нужной точки, зафиксируйте курсор еще раз.

Чтобы указать другую пару элементов, нажмите кнопку Указать заново.

После завершения работы команды координаты точки будут вычислены и автоматически занесены в поля Панели свойств.

Размер «ловушки» курсора можно изменить в диалоге настройки курсора.

Смотрите также

Геометрический калькулятор

Меню геометрического калькулятора


Команда На пересечении продолжений кривых (меню геометрического калькулятора)

Команда На пересечении продолжений кривых
(меню геометрического калькулятора)

Позволяет снять значения координат точки, расположенной на пересечении продолжений двух указанных элементов.

Указываемые элементы могут являться частями объектов, например, сегментами ломаной. Они могут входить в состав макроэлементов, вставок фрагментов и видов.

Команда применяется также для пар элементов, один из которых может иметь продолжение, а другой нет. В этом случае строится точка пересечения продолжения одного элемента и непосредственно другого элемента, не имеющего продолжения.

– Элементы, имеющие продолжение — отрезки и дуги, а также прямолинейные и дуговые фрагменты объектов геометрии и обозначений.

– Элементы, не имеющие продолжения — окружности, эллипсы, кривые Безье, кривые NURBS, волнистая линия, части обозначений и т.п.

Точки пересечения самих объектов (а не их продолжений) не строятся. Для выполнения команды необходимо, чтобы был продолжен хотя бы один объект из указанной пары.

После вызова команды укажите курсором первый, а затем второй элемент для построения точки. Фиксация курсора выполняется нажатием левой кнопки мыши или клавиши <Enter>.

При попадании второго элемента в «ловушку» курсора на экране появляются фантомы продолжений элементов и всех их точек пересечения (рис. а). Это происходит, если для данной пары элементов существует хотя бы один вариант построения. Если точек пересечения нет, то элемент не подсвечивается.

Пример построения: а) отображение точек при наведении курсора на вторую кривую, б), отображение точки после фиксации курсора, в) смена варианта точки, г) результат построения точки 1
а) | б) | в) | г)

В зависимости от типа указанных элементов возможны следующие способы завершения работы команды.

– Если точка пересечения продолжений единственная, то после второй фиксации курсора команда завершается автоматически.

– Если точек пересечения продолжений несколько, то система ожидает выбора нужной точки. При этом на экране будет находиться фантом точки пересечения, ближайшей к месту указания курсором элемента (рис. б). Чтобы отобразился другой вариант точки пересечения, подведите курсор к этой точке (рис. в). После того как появится фантом нужной точки, зафиксируйте курсор еще раз.

Чтобы указать другую пару элементов, нажмите кнопку Указать заново.

После завершения работы команды координаты точки будут вычислены и автоматически занесены в поля Панели свойств.

Размер «ловушки» курсора можно изменить в диалоге настройки курсора.

Вы можете снять значения координат точки, расположенной на пересечении продолжений объектов (отрезков, дуг окружностей и эллипсов, эквидистант отрезков и дуг окружностей), с построением точки пересечения продолжений. Для этого следует воспользоваться командой геометрического калькулятора Условное пересечение.

Смотрите также

Геометрический калькулятор

Меню геометрического калькулятора


Команда Касание (меню привязок)

Команда Касание
(меню привязок)

Позволяет выполнить привязку таким образом, чтобы создаваемый объект (отрезок, дуга и т.п.) касался указанного объекта в точке, ближайшей к текущему положению курсора.

Для включения глобальной привязки Касание нажмите одноименную кнопку на панели Глобальные привязки или вызовите одноименную команду из меню кнопки Привязки на панели Текущее состояние.

Для включения локальной привязки Касание нажмите одноименную кнопку на панели Локальные привязки или вызовите одноименную команду из контекстного меню.

Для привязки установите курсор так, чтобы точка касания объектов находилась внутри «ловушки». После этого зафиксируйте курсор нажатием левой кнопки мыши или клавиши <Enter>.

Размер «ловушки» курсора можно изменить в диалоге настройки курсора.

Смотрите также

Глобальные и локальные привязки

Общие сведения о привязках


Команда Наклон касательной (меню геометрического калькулятора)

Команда Наклон касательной
(меню геометрического калькулятора)

Позволяет снять значение угла между касательной к элементу, проходящей через заданную точку на этом элементе, и положительным направлением оси X текущей системы координат.

Укажите курсором точку на элементе (дуге, окружности, сплайне и т.д.), через которую должна проходить касательная. Фиксация курсора выполняется нажатием левой кнопки мыши или клавиши <Enter>.

После того как значение угла наклона касательной будет вычислено, оно автоматически будет занесено в поле Панели свойств.

Размер «ловушки» курсора можно изменить в диалоге настройки курсора.

Смотрите также

Геометрический калькулятор

Меню геометрического калькулятора


Команда Направление строки текста (меню геометрического калькулятора)

Команда Направление строки текста
(меню геометрического калькулятора)

Позволяет снять значение угла между текстовой строкой и положительным направлением оси X текущей системы координат.

Укажите курсором строку текста, угол наклона которой нужно определить. Фиксация курсора выполняется нажатием левой кнопки мыши или клавиши <Enter>.

После того как значение угла наклона строки будет вычислено, оно автоматически будет занесено в поле Панели свойств.

Размер «ловушки» курсора можно изменить в диалоге настройки курсора.

Смотрите также

Геометрический калькулятор

Меню геометрического калькулятора


Команда Длина строки текста (меню геометрического калькулятора)

Команда Длина строки текста
(меню геометрического калькулятора)

Позволяет выполнить снятие длины текстовой строки.

Укажите курсором строку текста, длину которой нужно определить. Фиксация курсора выполняется нажатием левой кнопки мыши или клавиши <Enter>.

После того как значение длины текста будет вычислено, оно автоматически будет занесено в поле Панели свойств.

Размер «ловушки» курсора можно изменить в диалоге настройки курсора.

Смотрите также

Геометрический калькулятор

Меню геометрического калькулятора


Команда Габарит объекта — По горизонтали (меню геометрического калькулятора)

Команда Габарит объекта — По горизонтали
(меню геометрического калькулятора)

Позволяет снять значение горизонтального габарита объекта.

Укажите курсором объект, горизонтальный габарит которого нужно определить. Фиксация курсора выполняется нажатием левой кнопки мыши или клавиши <Enter>.

После того как значение габарита будет вычислено, оно автоматически будет занесено в поле Панели свойств.

Размер «ловушки» курсора можно изменить в диалоге настройки курсора.

Смотрите также

Геометрический калькулятор

Меню геометрического калькулятора


Команда Выравнивание (меню привязок)

Команда Выравнивание
(меню привязок)

При выборе данного способа привязки будет выполняться выравнивание вводимой точки объекта по другим характерным точкам, а также по последней зафиксированной точке.

Последней зафиксированной точкой считается не только точка, указанная при выполнении какой-либо команды, но и точка, в которую курсор был установлен при помощи клавиатурной привязки.

Для включения глобальной привязки Выравнивание нажмите одноименную кнопку на панели Глобальные привязки или вызовите одноименную команду из меню кнопки Привязки на панели Текущее состояние.

Для включения локальной привязки Выравнивание нажмите одноименную кнопку на панели Локальные привязки или вызовите одноименную команду из контекстного меню.

Например, вы нарисовали отрезок. Последней зафиксированной точкой является его конечная точка (p2). Если теперь с помощью комбинации клавиш <Ctrl>+<.> привязаться к ближайшей точке этого отрезка, она (ближайшая точка) станет последней зафиксированной точкой, и при перемещении курсора фантомные линии выравнивания будут проходить через эту точку.

Выравнивание выполняется без учета угла наклона локальной системы координат.

Цвет отображения фантомных линий выравнивания соответствует цвету, установленному для увеличенного курсора.

Размер «ловушки» курсора можно изменить в диалоге настройки курсора.

Смотрите также

Глобальные и локальные привязки

Общие сведения о привязках


Команда Габарит объекта — По вертикали (меню геометрического калькулятора)

Команда Габарит объекта — По вертикали
(меню геометрического калькулятора)

Позволяет снять значение вертикального габарита объекта.

Укажите курсором объект, вертикальный габарит которого нужно определить. Фиксация курсора выполняется нажатием левой кнопки мыши или клавиши <Enter>.

После того как значение габарита будет вычислено, оно автоматически будет занесено в поле Панели свойств.

Размер «ловушки» курсора можно изменить в диалоге настройки курсора.

Смотрите также

Геометрический калькулятор

Меню геометрического калькулятора


Команда Деформация масштабированием

Позволяет выполнить деформацию масштабированием объектов чертежа или фрагмента.

Для вызова команды нажмите кнопку Деформация масштабированием на инструментальной панели Редактирование или выберите ее название из меню Редактор.

Укажите объекты для деформации

Задайте в соответствующих полях Панели свойств нужные значения коэффициента масштабирования в направлении осей координат (вы можете ввести разные значения коэффициента масштабирования по горизонтали и по вертикали).

Ввод масштаба по оси Y невозможен, если среди выделенных объектов есть окружности или дуги окружностей или виды целиком. В этом случае выполнение операции производится со значением масштаба по оси Y, равным масштабу по оси X.

Укажите точку центра масштабирования.

После этого будет выполнено перестроение объектов.

Исходное изображение и изображение после деформации масштабированием (коэффициенты масштабирования по осям разные)

Правила деформации объектов масштабированием:

– элементы, полностью попавшие в рамку выделения, будут просто промасштабированы с заданным коэффициентом относительно центра масштабирования,

– элементы, частично попавшие в рамку выделения, будут отредактированы таким образом, чтобы координаты их характерных точек, попавших в рамку выделения, изменились относительно центра масштабирования в соответствии с заданными коэффициентами, а характерные точки, не попавшие в рамку выделения, остались на прежнем месте,

– элементы, не попавшие в рамку выделения, не редактируются.

За один вызов команды вы можете отредактировать несколько объектов чертежа.

Для завершения команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие команды редактирования


Текущий масштаб

В этом поле, расположенном на панели Вид, показан масштаб отображения в активном окне.

Если панель расположена вертикально, для вызова этого поля нажмите кнопку Текущий масштаб.

Чтобы изменить масштаб, разверните список и выберите нужное значение. Можно также ввести значение с клавиатуры.

Смотрите также

Управление масштабом отображения документа в окне


Поле Текущий раздел

В этом поле, расположенном на панели Текущее состояние, отображается номер раздела, на котором находится курсор.

Чтобы переместиться в другой раздел, выберите его номер из списка.

Если панель Текущее состояние расположена вертикально, то для доступа к полю Текущий раздел нажмите соответствующую кнопку.


Команда Выделить тело

Позволяет выделить в виде все изображение тела, которому принадлежит выделенный геометрический объект.

Команда доступна из контекстного меню на любом выделенном в ассоциативном виде геометрическом объекте.

После вызова команды в виде выделяется проекция тела, частью которого является выбранный объект (если тело состоит из нескольких частей, то выделяются все части), а Дереве чертежа — пиктограмма модели, содержащей выбранное тело.

Например, в одном из ассоциативных видов чертежа выделен отрезок, изображающий ребро тела детали, которая является компонентом модели. После вызова команды Выделить тело в этом виде выделяются все геометрические объекты, составляющие изображение тела детали, а в Дереве чертежа выделяется ее пиктограмма, расположенная на ветви, соответствующей выбранному виду.


Команда Выделить столбец

Позволяет выделить столбец, содержащий текущую ячейку.

Другой способ выделения столбца — щелчок мышью по его заголовку.


Команда Выделить компонент

Позволяет выделить в виде и в Дереве чертежа компонент, в состав проекции которого входит выделенный геометрический объект.

Команда доступна из контекстного меню на любом выделенном в ассоциативном виде геометрическом объекте.

После вызова команды в виде выделяется изображение, частью которого является выбранный объект, а Дереве чертежа — пиктограмма модели, изображением которой является выделенная геометрия.

Например, в одном из ассоциативных видов чертежа выделен отрезок, изображающий ребро детали. После вызова команды Выделить компонент в этом виде выделяются все геометрические объекты, составляющие изображение детали, а в Дереве чертежа выделяется ее пиктограмма, расположенная на ветви, соответствующей выбранному виду.


Команда Компоненты вне габарита

Позволяет выбрать группу компонентов, которые располагаются вне габаритного параллелепипеда указанных компонентов.

Команда вызывается из меню Выделить – По габариту. Перед вызовом команды укажите компонент (компоненты), определяющие габарит.

После вызова команды компоненты, оказавшиеся вне габарита, выделяются в окне модели и в Дереве построения. Выделение с компонентов, определявших габарит, снимается.


Команда Компоненты внутри габарита

Позволяет выбрать группу компонентов, которые располагаются полностью внутри габаритного параллелепипеда указанных компонентов.

Команда вызывается из меню Выделить – По габариту. Перед вызовом команды укажите компонент (компоненты), определяющие габарит.

После вызова команды компоненты, оказавшиеся внутри габарита, выделяются в окне модели и в Дереве построения. Выделение с компонентов, определявших габарит, снимается.


Команда Выбрать текущую СК

Позволяет назначить текущей одну из систем координат модели — абсолютную или локальную (ЛСК).

Для вызова команды выберите ее название в меню Редактор или нажмите кнопку Выбор текущей СК на панели Текущее состояние.

После вызова команды в окне модели подсвечивается система координат, являющаяся текущей в данный момент. Система ожидает указания системы координат, которая должна стать текущей.

Укажите нужную систему координат в Дереве построения.

Команда автоматически завершается, а выбранная система координат получает статус «текущая» — ее изображение в окне модели становится цветным, а перед названием этой системы координат в Дереве построения появляется буква «т» в круглых скобках.

Чтобы сделать систему координат текущей, можно вызвать команду Текущая СК из ее контекстного меню в Дереве построения.


Команда Выделить по слою указанием

Позволяет выделить все объекты, которые принадлежат тому же слою, что и указанный объект.

Для вызова команды выберите ее название из меню Выделить — По слою.

Затем укажите объект в Дереве построения или в окне модели. Выделятся все объекты, принадлежащие слою, на котором располагается выделенный объект.

Если требуется прервать работу команды до ее завершения, нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.


Текущий стиль линии границы

Элемент управления, позволяющий указать текущий стиль линии границы.

На Панели свойств и на панели Таблицы и границы данный элемент имеет вид списка, из которого можно выбрать нужный стиль.

Если панель Таблицы и границы расположена вертикально, то данный элемент имеет вид кнопки Стиль линии. После нажатия на эту кнопку на экране появляется диалог, в котором можно указать нужный стиль линии.


Команда Выбрать вне зоны

Позволяет выбрать группу объектов, находящихся вне зоны.

Команда вызывается:

– из меню Выделить – По зоне,

– из контекстного меню зоны в Дереве зон.

После вызова команды объекты выделяются в окне модели, а их список отображается в нижней части Дерева зон.

Подробнее о выделении объектов зоной...


Команда Выбрать источник вставки

Позволяет вызвать диалог выбора файла — источника копируемых объектов. Команда доступна при активном переключателе Из файла группы переключателей Способ копирования.


Команда Выделить прежний список

Позволяет выделить объекты, которые выделялись предыдущий раз (элементы прежнего списка).

Для вызова команды нажмите кнопку Выделить прежний список на инструментальной панели Выделение или выберите ее название в меню Выделить.

Если какие-либо объекты уже выделены, то элементы прежнего списка будут к ним добавлены.

Смотрите также

Выделение объектов и отмена выделения


Команда Выделить строку

Позволяет выделить строку, содержащую текущую ячейку.

Другой способ выделения строки — щелчок мышью по ячейке с номером этой строки.


Команда Назначить раздел

Позволяет вызвать диалог, в котором можно задать значение системного свойства Раздел спецификации. В результате работы команды создается и размещается в указанном разделе объект спецификации, связанный с настраиваемым объектом документа. Если с ним уже был связан объект спецификации, то он переносится в указанный раздел.

Команда вызывается из контекстного меню ячейки свойства Позиция или Раздел спецификации, выделенной на Панели свойств в команде Свойства (объекта).

Команда недоступна, если объект спецификации, связанный с настраиваемым объектом, синхронизируется с документом-владельцем. Если сменить раздел необходимо, отключите синхронизацию.

Подробнее о свойстве Раздел спецификации...


Команда Выбрать секущей зоной

Позволяет выбрать группу объектов, находящихся внутри зоны, и пересекающихся с зоной.

Команда вызывается:

– из меню Выделить – По зоне,

– из контекстного меню зоны в Дереве зон.

После вызова команды объекты выделяются в окне модели, а их список отображается в нижней части Дерева зон.

Подробнее о выделении объектов зоной...


Команда Выбрать внутри зоны

Позволяет выбрать группу объектов, находящихся внутри зоны.

Команда вызывается:

– из меню Выделить – По зоне,

– из контекстного меню зоны в Дереве зон.

После вызова команды объекты выделяются в окне модели, а их список отображается в нижней части Дерева зон.

Подробнее о выделении объектов зоной...


Команда Выделить по атрибутам

Позволяет выделить объекты активного документа в соответствии с типами и значениями атрибутов.

Для вызова команды выберите ее название в меню Выделить.

После этого на экране появляется диалог со списком типов атрибутов, используемых в документе. Выберите из списка типы, по которым нужно выделять объекты, при необходимости задайте условия поиска и нажмите кнопку ОК. Чтобы отказаться от выделения, нажмите кнопку Отмена.

Если какие-либо объекты уже выделены, то выбранные по атрибутам объекты будут к ним добавлены.

Смотрите также

Выделение объектов и отмена выделения


Команда Выделить по стилю кривой

Позволяет выделить объекты активного документа в соответствии с их стилем.

Для вызова команды нажмите кнопку Выделить по стилю кривой на инструментальной панели Выделение или выберите ее название в меню Выделить.

После этого на экране появляется диалог со списком стилей кривых, используемых в активном документе. Выберите из списка стили, которые нужно выделить, и нажмите кнопку ОК. Для выхода из диалога без выбора нажмите кнопку Отмена.

Если какие-либо объекты уже выделены, то выбранные по стилю кривой объекты будут к ним добавлены.

Обратите внимание на следующие особенности работы команды Выделить по стилю кривой.

1. Командой не обрабатываются объекты, входящие в состав макроэлементов, локальных фрагментов, а также фрагментов, вставленных взятием в документ и внешней ссылкой.

2. C помощью команды нельзя выделить такие объекты, осевая линия и обозначение центра. Для их выделения воспользуйтесь командой Выделить по типу.

3. Автоматически сформированные при создании вида с разрывом линии разрыва не имеют признака «стиль». Поэтому их невозможно выделить с помощью команды Выделить по стилю кривой.

Смотрите также

Выделение объектов и отмена выделения


Команда Выделить по типу

Позволяет выделить объекты активного документа в соответствии с их типом.

Для вызова команды нажмите кнопку Выделить по типу на инструментальной панели Выделение или выберите ее название в меню Выделить.

После вызова команды на экране появляется диалог со списком типов объектов, имеющихся в активном документе. Выберите из списка типы, которые нужно выделить, и нажмите кнопку ОК. Для выхода из диалога без выбора нажмите кнопку Отмена.

Если какие-либо объекты уже выделены, то выбранные по типу объекты будут к ним добавлены.

Смотрите также

Выделение объектов и отмена выделения


Команда Свойства тела

Позволяет изменить свойства тела:

– отредактировать значения свойств текущей модели, заданные для тела (можно также внести изменения в список свойств модели),

– изменить цвет и оптические свойства,

– задать материал и плотность материала тела,

– рассчитать МЦХ тела (кратко),

– задать параметры штриховки материала для отображения на разрезах/сечениях в ассоциативных видах чертежей.

Особенности задания свойств материала в модели...

Команда Свойства тела доступна в контекстном меню тела, выделенного в Дереве построения.

Пиктограммы и названия тел показываются в Дереве, если в нем включено отображение структуры модели.

После вызова команды на Панели свойств появятся вкладки, содержащие элементы управления для настройки свойств тела.


Команда Параметры разреза...

Позволяет настроить параметры местного разреза: изменить имя, номер, положение секущей плоскости и тип изображения.

Параметры штриховки существующего местного разреза таким образом изменить нельзя. Для этого необходимо отредактировать саму штриховку.


Команда Свойства исходного элемента

Позволяет установить некоторые параметры отображения формообразующего элемента, которому принадлежит выделенный объект — вершина, ребро или грань.

После вызова команды на Панели свойств появятся элементы управления для настройки свойств элемента.


Команда Свойства проекционных плоскостей, операций, эскизов, пространственных кривых и начала координат

Команда Свойства проекционных плоскостей,
операций, эскизов, пространственных кривых
и начала координат

Позволяет задать наименование, цвет, стиль отображения вершин, стиль линии, оптические свойства и состояние объектов (включено в расчет/исключено из расчета). После вызова команды на Панели свойств появятся элементы управления для настройки свойств.

Команда доступна в контекстном меню объекта, выделенного в окне модели или в Дереве модели.

Изменения свойств будут действовать только для документа, в котором они были сделаны. Во вновь создаваемых документах объекты будут иметь умолчательные свойства.


Команда Отправить выделенное в предварительный просмотр

Позволяет отправить в режим предварительного просмотра выделенную часть документа (набор объектов или фрагмент текста).

Команда Отправить выделенное в предварительный просмотр находится в меню кнопки Предварительный просмотр. Если в документе ничего не выделено, команда недоступна. Также команда недоступна при работе со спецификацией.

После вызова команды происходит переход в режим предварительного просмотра. Печатаемая часть текущего документа автоматически ограничивается согласно выделению.

Подробнее о печати выделенной части документа...


Команда Параметры вида...

Позволяет настроить параметры выделенного вида чертежа.

Команда может быть вызвана из контекстного меню вида, выделенного в окне чертежа или Дереве чертежа.

Команда доступна для всех, кроме системного, видов чертежа, находящихся в активном или текущем состоянии.

После вызова команды Параметры вида... на Панели свойств появляются элементы управления, позволяющие изменить параметры вида.


Команда Выделить группу

Позволяет выделить объекты одной или нескольких именованных групп активного документа.

Для вызова команды нажмите кнопку Выделить группу на инструментальной панели Выделение или выберите ее название в меню Выделить.

После этого на экране появляется окно со списком групп, имеющихся в активном документе. Выберите из списка группы, которые нужно выделить, и нажмите кнопку ОК. Для выхода из диалога без выбора групп нажмите кнопку Отмена.

Если какие-либо объекты уже выделены, то элементы выбранных групп будут к ним добавлены.

Смотрите также

Выделение объектов и отмена выделения


Команда Выделить слой указанием

Позволяет выделить объекты одного или нескольких слоев в текущем виде чертежа или во фрагменте.

Для вызова команды нажмите кнопку Выделить слой указанием на инструментальной панели Выделение или выберите ее название в меню Выделить.

Затем укажите элементы, принадлежащие слоям, которые должны быть выделены.

Если какие-либо объекты документа уже выделены, то элементы выбранных слоев будут к ним добавлены.

Смотрите также

Выделение объектов и отмена выделения


Команда Выделить слой выбором

Позволяет выделить объекты одного или нескольких слоев в текущем виде чертежа или во фрагменте.

Для вызова команды выберите ее название в меню Выделить.

После этого на экране появляется окно со списком слоев, имеющихся в текущем виде или фрагменте. Выберите из списка слои, которые нужно выделить, и нажмите кнопку ОК. Для выхода из диалога без выбора нажмите кнопку Отмена.

Если какие-либо объекты уже выделены, то элементы выбранных слоев будут к ним добавлены.

Смотрите также

Выделение объектов и отмена выделения


Команда Выделить по слою выбором...

Позволяет выделить все объекты, лежащие на выбранных слоях.

Для вызова команды выберите ее название из меню Выделить — По слою.

После этого на экране появляется окно со списком слоев, имеющихся в текущей модели. Выберите из списка нужные слои и нажмите кнопку ОК. Для выхода из диалога без выбора нажмите кнопку Отмена.


Команда Выделить объект

Позволяет выделить отдельный объект активного документа.

Для вызова команды нажмите кнопку Выделить объект указанием на инструментальной панели Выделение или выберите ее название в меню Выделить.

Укажите курсором элемент, который нужно выделить. При этом элемент должен попасть в «ловушку» курсора.

Если какие-либо объекты уже выделены, то указанный элемент будет к ним добавлен.

За один вызов команды можно указать произвольное количество выделяемых объектов.

Смотрите также

Выделение объектов и отмена выделения


Команда Выделить вне рамки

Позволяет выделить объекты активного документа, не попавшие в заданную прямоугольную рамку.

Для вызова команды нажмите кнопку Выделить вне рамки на инструментальной панели Выделение или выберите ее название в меню Выделить.

Укажите курсором первую и вторую вершины прямоугольной рамки.

Элементы, целиком оставшиеся снаружи заданной рамки, будут выделены.

Если какие-либо объекты уже выделены, то указанные с помощью рамки (то есть не попавшие в нее) элементы будут к ним добавлены.

За один вызов команды можно задать произвольное количество рамок.

Смотрите также

Выделение объектов и отмена выделения


Команда Выделить вид указанием

Позволяет выделить один или несколько видов чертежа. С помощью этой команды виды выделяются как единые объекты.

Для вызова команды нажмите кнопку Выделить вид указанием на инструментальной панели Выделение или выберите ее название в меню Выделить.

Затем укажите элементы, принадлежащие видам, которые должны быть выделены.

Признаком того, что вид выделен как единое целое, служит появление подсвеченной габаритной рамки вокруг этого вида.

Если какие-либо объекты уже выделены, то элементы выбранных видов будут к ним добавлены.

Смотрите также

Выделение объектов и отмена выделения


Команда Выделить вид выбором

Позволяет выделить один или несколько видов чертежа. С помощью этой команды виды выделяются как единые объекты.

Для вызова команды выберите ее название в меню Выделить.

После этого на экране появляется диалог со списком видов, имеющихся в чертеже. Выберите из списка виды, которые нужно выделить, и нажмите кнопку ОК. Для выхода из диалога без выбора нажмите кнопку Отмена.

Если какие-либо объекты уже выделены, то элементы выбранных видов будут к ним добавлены.

Признаком того, что вид был выделен как единое целое, является отрисовка подсвеченной габаритной рамки вокруг этого вида.

Смотрите также

Выделение объектов и отмена выделения


Команда Локальная система координат

Позволяет создавать в текущем виде чертежа или во фрагменте различные локальные системы координат, устанавливать любую из них в качестве текущей СК, а также изменять их параметры.

Для вызова команды нажмите кнопку Локальная СК на панели Текущее состояние или выберите ее название в меню Вставка.

Если в текущем документе еще нет локальных систем координат, курсор принимает форму осей системы координат.

Задайте точку начала отсчета создаваемой ЛСК и угол поворота ее осей. Положение начала каждой новой ЛСК задается в текущей системе координат, а угол поворота новой ЛСК отсчитывается от оси Х текущей системы координат.

Эти параметры можно указать мышью или ввести в соответствующие поля Панели свойств.

В поле Имя ЛСК можно ввести произвольное имя для облегчения ее последующего поиска и выбора из списка.

После создания ЛСК она автоматически будет установлена в качестве текущей системы координат. Ее имя появится на панели Выбор ЛСК.

Панель Выбор ЛСК

Чтобы задать параметры отрисовки символа начала ЛСК, нажмите кнопку Настройка... на Панели свойств. На экране появится диалог настройки параметров отрисовки осей координат.

Если в текущем документе уже есть локальные системы координат, то после вызова команды Локальная СК система ожидает выбора дальнейшего действия.

Вы можете создать новую систему координат. Для этого нажмите кнопку Новая ЛСК на панели Выбор ЛСК, укажите начало новой ЛСК, задайте угол ее поворота и введите ее имя.

Вы можете сделать текущей одну из ранее созданных ЛСК. Для этого выделите имя нужной ЛСК в списке на панели Выбор ЛСК и нажмите кнопку Текущая локальная СК.

Вы можете удалить одну или все ранее созданные ЛСК. Для этого выделите имя ЛСК в списке на панели Выбор ЛСК и нажмите кнопку Удалить.

Чтобы отказаться от использования ЛСК без их удаления, установите выделение на имени текущей ЛСК и нажмите кнопку Текущая локальная СК.

Текущей станет система координат фрагмента или текущего вида чертежа.

Все локальные системы координат сохранятся в документе, и в дальнейшем вы сможете использовать любую из них.


Команда Выделить секущей ломаной

Позволяет выделить объекты активного документа, пересекая их ломаной линией.

Для вызова команды нажмите кнопку Выделить секущей ломаной на инструментальной панели Выделение или выберите ее название в меню Выделить.

Указывайте курсором вершины ломаной так, чтобы ее звенья пересекались с объектами, которые требуется выделить.

Если какие-либо объекты уже выделены, то указанные с помощью секущей ломаной элементы будут к ним добавлены.

Смотрите также

Выделение объектов и отмена выделения


Команда Выделить секущей рамкой

Позволяет выделить объекты активного документа, частично или полностью попавшие в заданную прямоугольную рамку.

Для вызова команды нажмите кнопку Выделить секущей рамкой на инструментальной панели Выделение или выберите ее название в меню Выделить.

Укажите курсором первую и вторую вершины прямоугольной рамки.

Элементы, которые целиком или частично попали внутрь заданной рамки, будут выделены.

Если какие-либо объекты уже выделены, то указанные с помощью секущей рамки элементы будут к ним добавлены.

За один вызов команды можно задать произвольное количество секущих рамок.

Смотрите также

Выделение объектов и отмена выделения


Команда Выделить рамкой

Позволяет выделить объекты активного документа с помощью прямоугольной рамки.

Для вызова команды нажмите кнопку Выделить рамкой на инструментальной панели Выделение или выберите ее название в меню Выделить.

Укажите курсором первую и вторую вершины прямоугольной рамки.

Элементы, целиком попавшие в заданную рамку, будут выделены.

Если какие-либо объекты уже выделены, то указанные с помощью рамки элементы будут к ним добавлены.

За один вызов команды можно задать произвольное количество рамок.

Смотрите также

Выделение объектов и отмена выделения


Стиль линий сгиба

Список, позволяющий выбрать стиль отрисовки линий сгиба.


Команда Текущее

Команда позволяет сделать текущим исполнение, выбранное в Дереве исполнений.


Команда Установить значение размера

Вызывает диалог установки значения размера, в котором вы можете отредактировать значение выделенного в Дереве построения производного размера.

Команда доступна в контекстном меню размера, выделенного в Дереве построения или в окне модели.


Стиль невидимых линий

Список, позволяющий выбрать стиль отрисовки линий невидимого контура.


Команда Местный вид

Включает полное изображение вида или усеченное (местный вид).

Команда доступна для тех ассоциативных видов, которые используются для создания местных видов. Если около команды в меню стоит «галочка», то вид отображается как местный. Чтобы включить отображение вида целиком, вызовите эту команду. «Галочка» в меню исчезнет, а на экране появится полное изображение выбранного вида.


Команда Изменить слой (трехмерного объекта)

Команда Изменить слой
(трехмерного объекта)

Позволяет перенести объекты модели на другой слой.

Команда может быть вызвана из меню Сервис или из контекстного меню. Если выделен один объект, в его контекстном меню доступна команда Слой объекта — Изменить слой.

После вызова команды на Панели свойств появляются панели Список объектов и Слой.

Укажите объекты, слои которых требуется изменить, в Дереве построения или в окне модели — компоненты, тела, обозначения, размеры, поверхности, кривые и другие объекты.

При указании объектов необходимо учитывать следующее:

– перенос абсолютной системы координат невозможен — она всегда находится на системном слое;

– если указана операция, то на другой слой будет перенесено все тело, в состав которого она входит.

После указания объекты подсвечиваются, а их наименования отображаются на панели Список объектов. Повторное указание объекта в модели отменяет его выбор.

Объекты могут быть выделены до вызова команды.

Кнопка Удалить из списка, расположенная на этой панели, позволяет удалить объект из списка.

При необходимости вы можете полностью очистить список объектов, нажав кнопку Указать заново на Панели специального управления.

В списке на панели Слой укажите слой, на который требуется поместить объекты.

Чтобы создать новый слой, нажмите кнопку Создать новый слой, расположенную над списком.

После того как объекты указаны, нажмите кнопку Создать объект для их переноса на выбранный слой.

Если требуется прервать работу команды до ее завершения, нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Чтобы быстро сменить слой одного объекта, вызовите из его контекстного меню команду Слой объекта и укажите нужный слой из подменю этой команды.

Смотрите также

Переключение между слоями


Команда Эскиз сечения элемента

Позволяет сменить эскиз, определяющий форму сечения создаваемого (редактируемого) элемента выдавливания или вращения.

Для вызова команды нажмите кнопку Эскиз сечения элемента на Панели специального управления.

Система перейдет в процесс выбора эскиза, определяющего форму сечения элемента.

Укажите нужный эскиз в Дереве построения или в окне модели, а затем нажмите кнопку Создать объект для возвращения в текущую команду построения элемента.


Процесс выбора эскиза, определяющего форму сечения элемента

Позволяет указать или сменить эскиз, который содержит контур, определяющий форму сечения создаваемого (редактируемого) элемента выдавливания или вращения.

Укажите эскиз, содержащий сечение элемента, в Дереве построения или в окне модели.

Выбор объектов в Дереве построения

Выбор объектов в окне модели

По умолчанию включено автосоздание объектов. В этом случае сразу после указания эскиза система возвращается к выполнению команды построения элемента с использованием указанного эскиза.

Если автосоздание отключено, то после указания эскиза его название появится в поле Сечение, а в окне модели отобразится фантом элемента, полученного на основе указанного эскиза. При необходимости вы можете выбрать другой эскиз, указав его в Дереве построения или в окне модели.

Завершив выбор эскиза, нажмите кнопку Создать объект для возвращения в команду построения элемента.

Процесс выбора эскиза запускается автоматически после вызова команды построения элемента, если перед вызовом этой команды эскиз не был указан.

Во время построения элемента выдавливания или вращения процесс выбора эскиза можно запустить вручную, чтобы сменить текущий эскиз-сечение. Для этого нужно нажать кнопку Эскиз сечения элемента на Панели специального управления.


Стиль линий переходов

Список, позволяющий выбрать стиль отрисовки линий переходов.


Стиль видимых линий

Список, позволяющий выбрать стиль отрисовки линий видимого контура.


Команда Типы атрибутов...

Позволяет создать новые и отредактировать уже существующие типы атрибутов (как локальных, доступных только в активном документе, так и библиотечных).

После вызова команды на экране отображается диалог работы с типами атрибутов.


Команда Стиль

Позволяет изменить текущий стиль создаваемого объекта. После ее вызова на экране появляется диалог, в котором можно указать нужный стиль.


Команда Стили линий...

Позволяет создать новые или отредактировать уже имеющиеся стили линий, а также выполнять различные операции с наборами и библиотеками стилей.

После вызова команды на экран выводится диалог работы со стилями линий.


Команда Стили штриховок...

Позволяет создать новые или отредактировать уже имеющиеся стили штриховок, а также выполнять различные операции с наборами и библиотеками стилей.

После вызова команды на экран выводится диалог работы со стилями штриховок.


Команда Параметры списка

Позволяет назначить или изменить параметры нумерации абзацев текста (тип нумерации, отступы и т.д).

Для вызова команды нажмите кнопку Параметры списка или выберите ее название из меню Формат. Команда доступна, если курсор находится в списке.

После вызова команды на экране появится диалог настройки параметров нумерации абзацев текста.


Команда Управление свойствами

Позволяет создавать новые или редактировать уже имеющиеся свойства текущего документа, а также выполнять различные операции с библиотеками свойств.

Команда может быть вызвана:

– нажатием кнопки Управление свойствами на панели Отчеты;

– из меню Сервис — Библиотеки стилей, типов, оформлений и основных надписей.

После вызова команды на экран выводится диалог работы со свойствами.

Подробнее...


Команда Стили отчетов

Позволяет создавать и редактировать библиотеки стилей отчетов, а также входящие в их состав стили.

Команда может быть вызвана:

– нажатием кнопки Стили отчетов на панели Отчеты;

– из меню Сервис — Библиотеки стилей, типов, оформлений и основных надписей.

После вызова команды на экране появляется диалог работы с библиотеками стилей отчетов.

Подробнее...


Команда Стили спецификаций...

Позволяет вызвать диалог настройки текущей спецификации.


Команда Стили текстов...

Позволяет создать новые или отредактировать уже имеющиеся стили для различных текстовых надписей.

После вызова команды на экран выводится диалог работы со стилями текстов.


Общие настройки зеркального отражения

Кнопка Настройка общих параметров зеркального отражения, расположенная на инструментальной панели диалога Параметры зеркального отражения компонентов, позволяет выполнить следующие настройки:

– определить порядок формирования наименований создаваемых компонентов, исполнений, файлов отраженных моделей,

– выбрать папку для сохранения моделей, созданных в процессе зеркального отражения.

Настройки выполняются в диалоге Зеркальное отражение, который появляется на экране после нажатия кнопки.

Подробно о выполнении настроек


Команда Задать характерную точку (графического макроэлемента)

Команда Задать характерную точку
(графического макроэлемента)

Позволяет создать в макроэлементе характерную точку или удалить ранее созданную. Характерная точка, если она есть в макроэлементе, используется для его перемещения и поворота при редактировании изображения.

Отображение характерной точки: а) в режиме редактирования макроэлемента, б) при редактировании документа
а) | б)

Чтобы задать характерную точку, выполните следующие действия.

1. Выделите один макроэлемент, которому необходимо задать характерную точку, или войдите в режим его редактирования.

2. Вызовите команду Задать характерную точку. Для вызова команды нажмите кнопку Задать характерную точку на инструментальной панели Вставки и макроэлементы или выберите ее название из меню Инструменты — Макроэлементы.

3. Укажите положение базовой точки мышью или введите координаты на Панели свойств. Для этого вы можете воспользоваться привязками или меню геометрического калькулятора.

После указания на экране появляется условное изображение точки.

Чтобы удалить ранее построенную характерную точку, воспользуйтесь командой Удалить характерную точку на Панели специального управления.

Чтобы завершить выполнение команды, нажмите кнопку Прервать команду.

Подробнее о создании макроэлемента...

Созданный макроэлемент можно отредактировать без разрушения.

Смотрите также

Команда Разрушить

Редактирование характерной точки макроэлемента


Переключатель Слои

Позволяет создать в ассоциативном виде такие же слои, какие имеются в выбранной для проецирования модели. Каждый слой будет содержать проекции объектов, находящихся на соответствующем слое в модели.

Если переключатель активен, то в вид передаются также группы слоев и фильтры слоев из модели.

При неактивном переключателе в ассоциативном виде создается один слой — системный, на котором размещаются все объекты, составляющие изображение модели.

Обратите внимание на то, что переключатель доступен лишь при создании, но не при редактировании ассоциативного вида.

Подробнее о передаче слоев из модели в чертеж...


Команда Параметры...

Позволяет настроить различные системные параметры, параметры новых и текущего документов, а также параметры текущего окна.

После вызова команды на экране появляется настроечный диалог.

Для изменения какой-либо группы настроек перейдите на нужную вкладку диалога, в ее правой части выберите название группы настроек, а в левой — нужные значения параметров.

Чтобы развернуть содержание какого-либо раздела, установите курсор на значке плюса рядом с заголовком раздела и щелкните левой кнопкой мыши. Повторный щелчок на символе (после разворачивания раздела он отображается как минус) приведет к сворачиванию содержания.

Для сохранения всех изменений и выхода из диалога нажмите кнопку ОК, для выхода без сохранения изменений — кнопку Отмена.


Команда Сшивка поверхностей

Позволяет соединить открытые ребра указанной поверхности или поверхностей с получением целой поверхности, а также присоединить поверхность (поверхности) к открытым ребрам тела, целостность которого нарушена.

Для вызова команды нажмите кнопку Сшивка поверхностей на инструментальной панели Поверхности или выберите ее название из меню Операции.

Задайте точность сшивки в одноименном поле на Панели свойств.

Укажите в окне модели или в Дереве построения сшиваемые объекты. Они будут выделены цветом. Список сшиваемых объектов появится на Панели свойств. С помощью кнопок, расположенных над списком, вы можете менять порядок следования поверхностей и удалять их из списка. Исключить какую-либо поверхность из числа сшиваемых можно также повторным указанием в окне модели или в Дереве построения.

Опция Создавать тело позволяет создать тело, ограниченное сшиваемыми поверхностями. Если в списке сшиваемых поверхностей есть тело с нарушенной целостностью, опция Создавать тело включается автоматически и ее выключение невозможно.

Чтобы подтвердить выполнение операции, нажмите кнопку Создать объект на Панели специального управления. Если в списке сшиваемых поверхностей только один объект, то кнопка Создать объект доступна только при включенной опции Создавать тело.

Поверхности, расстояние между ближайшими ребрами которых меньше или равно заданному значению точности, будут объединены в одну. Если создание тела включено, то проводится проверка созданной поверхности на замкнутость. В случае положительного результата создается твердое тело, ограниченное полученной поверхностью, а в случае отрицательного — тело с нарушенной целостностью.

Прервать сшивку поверхностей можно, нажав кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Другие команды создания поверхностей


Команда Отображение — Полутоновое

Позволяет получить полутоновое изображение модели.

Для вызова команды нажмите кнопку Полутоновое отображение на панели Вид или выберите ее название из меню Вид.

Сразу после вызова команды в активном окне появится полутоновое изображение модели.

При полутоновом отображении модели учитываются оптические свойства ее поверхности (цвет, блеск, диффузия и т.д.).

Смотрите также

Команда Отображение — Каркас

Команда Отображение — Без невидимых линий

Команда Отображение — Невидимые линии тонкие

Команда Отображение — Полутоновое с каркасом


Команда Отображение — Полутоновое с каркасом

Позволяет получить полутоновое изображение модели с видимыми (в текущей ориентации) ребрами, линиями очерка и частями ребер и линий очерка.

Для вызова команды нажмите кнопку Полутоновое с каркасом на панели Вид или выберите ее название из меню Вид.

Цвет линий каркаса — черный.

Смотрите также

Команда Отображение — Каркас

Команда Отображение — Без невидимых линий

Команда Отображение — Невидимые линии тонкие

Команда Отображение — Полутоновое


Команда Листовое тело

Позволяет создать листовое тело. Оно формируется путем выдавливания эскиза в направлении, перпендикулярном его плоскости. Перед построением листового тела в детали необходимо создать эскиз, определяющий форму тела.

Команда Листовое тело доступна, если выделен один эскиз.

Пример создания листового тела с замкнутым эскизом

Пример создания листового тела с разомкнутым эскизом

Требования к эскизу листового тела

Чтобы вызвать команду, нажмите кнопку Листовое тело на панели Элементы листового тела или выберите ее название из меню Операции — Элементы листового тела.

После вызова команды следует ввести параметры листового тела, используя элементы управления на Панели свойств.

Эти параметры будут различными для листового тела с замкнутым эскизом и с разомкнутым эскизом.

Параметры листового тела можно задать с помощью характерных точек.

Выбор результата операции...

При необходимости вы можете назначить допуски на значения параметров операции, выраженных в линейных или угловых величинах. Для этого используйте кнопку Назначить допуск, расположенную на Панели свойств рядом с полем числового параметра операции.
Подробнее о допусках...
Подробнее о назначении допуска...

При необходимости вы можете задать наименование элемента и свойства его поверхности. Для этого активизируйте вкладку Свойства Панели свойств.

После завершения построения в окне модели появится листовое тело с заданными параметрами, а в Дереве построения — пиктограмма листового тела.

После создания листового тела в детали формируется определенный набор переменных.

Смотрите также

Особенности задания числовых параметров операции в полях Панели свойств


Команда Отправить лист в предварительный просмотр

Находится в контекстном меню окна документа.

Позволяет открыть в режиме предварительного просмотра не весь чертеж, а только его текущий лист. Дальнейшая работа в режиме предварительного просмотра ведется обычным образом.


Команда Задать параметры печати и напечатать лист

Находится в контекстном меню окна документа.

Позволяет вывести на печать только текущий лист чертежа.

После вызова команды на экране появляется диалог Печать документа, позволяющий настроить параметры печати листа. Обратите внимание на то, что при настройке печати текущего листа элементы управления диалога, предназначенные для настройки многолистового документа, недоступны.


Команда Неуказанная шероховатость – Ввод

Позволяет создать или отредактировать обозначение шероховатости неуказанных поверхностей (знак неуказанной шероховатости) на чертеже.

После вызова команды на экран выводится диалог, в котором нужно задать обозначение неуказанной шероховатости.

Чтобы отредактировать уже существующий знак неуказанной шероховатости, дважды щелкните на нем левой кнопкой мыши.

По умолчанию знак неуказанной шероховатости размещается в правом верхнем углу первого листа чертежа на расстоянии 7 мм от верхней линии рамки и 8 мм от правой линии рамки. Если требуется разместить знак в другом месте листа, пользуйтесь командой Неуказанная шероховатость — Размещение.

Для удаления знака используйте команду Удалить неуказанную шероховатость из меню Удалить.


Команда Спецификация на листе — Показать

Позволяет включить и выключить отображение содержащихся в листе чертежа объектов спецификации текущего стиля в таблице спецификации на этом листе.

Для вызова команды выберите ее название из меню Спецификация.

Команда доступна, если текущее описание спецификации не содержит имени файла спецификации, т.е. если чертеж не подключен к спецификации текущего стиля. Чтобы отобразить спецификацию текущего стиля на листе, необходимо отключить чертеж от документа-спецификации этого стиля.

Подключить лист, на котором отображается спецификация, к документу-спецификации этого же стиля невозможно.

В режиме показа спецификации на листе рядом с названием команды меню появляется «галочка». Повторный вызов этой команды отключает показ таблицы спецификации на листе, при этом объекты спецификации из листа не удаляются (они просто перестают быть видны на листе чертежа), и их можно просматривать и редактировать в подчиненном режиме.

После отключения показа спецификации на листе этот лист вновь можно подключать к документу-спецификации.

По умолчанию после вызова команды Спецификация — Показать на листе отображается одна спецификация — текущего стиля. Чтобы включить размещение на листе остальных подключенных к чертежу спецификаций (или некоторых из них), вызовите диалог управления описаниями спецификаций. Включите в этом диалоге отображение на листе для нужных описаний спецификаций.


Команда Основная надпись

Команда позволяет ввести или отредактировать содержимое основной надписи на первом листе чертежа.

Для вызова команды выберите ее название из меню Вставка.


Команда Заполнить основную надпись

Позволяет заполнить или отредактировать содержимое основной надписи, из контекстного меню которой она была вызвана.


Команда Название... (меню спецификации)

Команда Название...
(меню спецификации)

Позволяет ввести или отредактировать текст названия спецификации текущего стиля.

Для вызова команды выберите ее название из меню Спецификация — Спецификация на листе.

Команда доступна, если в чертеже отображается спецификация текущего стиля.

После вызова команды на экране появляется диалог ввода названия спецификации.


Команда Название... (контекстное меню таблицы спецификации)

Команда Название...
(контекстное меню таблицы спецификации)

Позволяет ввести или отредактировать текст названия спецификации.

Для вызова команды выберите ее название из контекстного меню таблицы спецификации, отображающейся на чертеже.

После вызова команды на экране появляется диалог ввода названия спецификации.


Команда Надпись вида...

Позволяет настроить надпись выделенного вида чертежа.

Команда может быть вызвана из контекстного меню вида, выделенного в окне чертежа или Дереве чертежа.

Команда доступна для всех, кроме системного, видов чертежа, находящихся в активном или текущем состоянии.

После вызова команды Надпись вида... на Панели свойств появляются элементы управления, позволяющие изменить параметры надписи. Подробнее...


Команда Параметры текущего вида...

Позволяет настроить параметры текущего вида чертежа.

Для вызова команды нажмите кнопку Параметры текущего вида на инструментальной панели Виды или выберите ее название в меню Сервис.

Команда доступна для всех, кроме системного, видов чертежа.

После вызова команды Параметры текущего вида... на Панели свойств появляются элементы управления, позволяющие изменить параметры вида.


Управление видами

Управление видами чертежа производится с помощью элементов панели Текущее состояние.

Кнопка Управление видами открывает Менеджер документа, в котором можно изменить параметры существующих видов, удалить один или несколько видов, а также создать новые слои в любом виде.

Поле Управление видами служит для изменения состояния видов и выбора текущего вида.

Поле Управление видами присутствует на Панели, если она расположена горизонтально.


Угол наклона выноски

Поле, в котором отображается значение угла наклона выноски (при построении размера с размерной надписью на полке или обозначения шероховатости на полке).

Ввод значения с клавиатуры в это поле возможен при отключенном автосоздании объекта и только после того, как линия-выноска сформирована (указана точка начала полки).


Длина выноски

Поле, в котором отображается длина выноски (при построении размера с размерной надписью на полке или обозначения шероховатости на полке).

Ввод значения с клавиатуры в это поле возможен при отключенном автосоздании объекта и только после того, как линия-выноска сформирована (указана точка начала полки).


Положение полки

Элемент управления, позволяющий задать положение полки линии-выноски.

Активизируйте переключатель, чтобы выбрать положение полки:

Горизонтально.

Вертикально.

Группа переключателей Положение полки отображается на Панели свойств при активном переключателе Параллельные группы Ответвления.

Если в группе переключателей Ответвления активен переключатель От начала полки или От конца полки, то вместо группы переключателей Положение полки на Панели свойств появляется раскрывающийся список, позволяющий выбрать направление полки относительно точки ее начала (т1).


Автокоррекция ошибочного ввода

Чтобы преобразовать выделенные символы в латинские, вызовите команду Перевести в латинский регистр или нажмите комбинацию клавиш <Ctrl>+<Shift>+<L>.

Чтобы преобразовать выделенные символы в кириллические, вызовите команду Перевести в русский регистр или нажмите комбинацию клавиш <Ctrl>+<Shift>+<R>.

Чтобы преобразовать выделенные символы в нижний регистр, вызовите команду Перевести в нижний регистр или нажмите комбинацию клавиш <Ctrl>+<Shift>+<D>.

Чтобы преобразовать выделенные символы в верхний регистр, вызовите команду Перевести в верхний регистр или нажмите комбинацию клавиш <Ctrl>+<Shift>+<U>.

По умолчанию перечисленные команды не присутствуют ни в одном меню и ни на одной панели. При необходимости вы можете добавить эти команды в меню или на любую панель.


Команда Согнуть

Команда позволяет согнуть сгиб (несколько сгибов) листового тела.

Пример

Эта команда может быть применена к сгибам, имеющим признак «разогнуто», а также к сгибам, разогнутым с помощью команды Разогнуть.

Чтобы вызвать команду сгибания, нажмите кнопку Согнуть на панели Элементы листового тела или выберите ее название из меню Операции — Элементы листового тела.

После вызова команды необходимо задать неподвижную грань или плоскость и сгибы, состояние которых требуется изменить.

Завершив настройку сгибания, нажмите кнопку Создать объект на Панели специального управления.

Листовое тело будет перестроено в соответствии с заданными параметрами сгибания, а в Дереве построения появится пиктограмма выполненной операции.


Команда Подсечка

Позволяет создать в листовом теле сразу два сгиба по прямой линии относительно какой-либо грани этого тела. Указанные линия и грань будут считаться линией сгиба и базовой гранью подсечки.

Пример

Исходные объекты и результат построения

Чтобы вызвать команду, нажмите кнопку Подсечка на панели Элементы листового тела или выберите ее название из меню Операции — Элементы листового тела.

Укажите базовую грань подсечки и линию сгиба.

По умолчанию отображение фантома листового элемента включено, и в окне модели показывается фантом элемента с текущими параметрами.

– Выберите направление отсчета угла.

– Задайте неподвижную сторону.

– Выберите вариант интерпретации угла и задайте значение угла в поле Угол.

Значение угла сгиба подсечки должно быть больше 0 и меньше 180 градусов; дополняющего угла — больше 0 и меньше 360 градусов.

– Выберите способ задания радиуса сгиба и введите его значение в поле Радиус сгиба.

– Выберите способ формирования сгиба.

– Укажите способ определения длины развертки сгиба.

Заданные величина и способ задания радиуса, а также способ определения длины развертки по умолчанию используются для обоих сгибов подсечки. В дальнейшем каждому из сгибов можно будет назначить собственные параметры.

– Выберите вариант задания размера подсечки и введите значение расстояния.

– С помощью опции С добавлением материала укажите, требуется ли построение подсечки с добавлением материала или без добавления.

– Выберите требуемое состояние сгибов, используя опцию Разогнуть.

– Используя элементы управления, расположенные на вкладке Освобождение, вы можете задать параметры освобождения угла.

Наличие в подсечке плоского участка зависит от сочетания значений угла сгиба, радиуса сгиба и расстояния. Подробнее...

Направление, размер, радиус и другие параметры подсечки можно задать с помощью характерных точек.

Для снятия значений параметров с других объектов воспользуйтесь меню геометрического калькулятора в полях Угол, Радиус сгиба и Расстояние на Панели свойств.

При необходимости вы можете назначить допуски на значения параметров операции, выраженных в линейных или угловых величинах. Для этого используйте кнопку Назначить допуск, расположенную на Панели свойств рядом с полем числового параметра операции.
Подробнее о допусках...
Подробнее о назначении допуска...

Завершив настройку, нажмите кнопку Создать объект на Панели специального управления.

В листовом теле появится подсечка, а в Дереве построения — соответствующая пиктограмма.

Обратите внимание на то, что сгибы, получившиеся в результате построения подсечки, отображаются в Дереве построения как самостоятельные объекты.

Смотрите также

Особенности задания числовых параметров операции в полях Панели свойств


Редактирование сгиба

Редактирование сгиба — изменение параметров отдельного сгиба, входящего в состав листового элемента. Этот листовой элемент является исходным объектом редактируемого сгиба. Параметры исходного объекта в результате редактирования сгиба не изменяются.

При редактировании сгиба вы можете изменить следующие его параметры:

– величину и способ задания радиуса,

– параметр развертки сгиба.

Чтобы отредактировать сгиб, выделите его в Дереве построения и вызовите команду Редактировать из контекстного меню или из меню Редактор.

На Панели свойств появятся элементы, позволяющие задать параметры сгиба.

Включение опции По исходному объекту означает, что параметры сгиба должны быть такими же, как у исходного объекта. В этом случае изменение параметров при редактировании исходного объекта приведет к перестроению сгиба: он получит новые параметры. По умолчанию сразу после создания листового элемента у всех его сгибов включена опция По исходному объекту.

Чтобы задать для сгиба собственные параметры, выключите опцию По исходному объекту. После этого станут доступны остальные элементы вкладки, и вы сможете настроить сгиб. Отредактированный сгиб будет сохранять заданные параметры при изменении настройки исходного объекта.

При редактировании сгибов, принадлежащих листовому телу с разомкнутым эскизом и соответствующих дугам в эскизе этого листового тела, переключение способа задания радиуса и изменение его значения невозможно.

Сгибы, у которых отключено определение параметров по исходному объекту, отображаются в Окне переменных как самостоятельные элементы, подчиненные своему исходному объекту. Параметрами этих сгибов являются радиус и параметр развертки (величина сгиба, или уменьшение сгиба, или коэффициент нейтрального слоя). Если длина развертки определяется по таблице, то параметр развертки отсутствует.

Если сгиб принадлежит листовому телу с разомкнутым эскизом и соответствует дуге в эскизе листового тела, то параметр Радиус этого сгиба не показывается в окне переменных. А если длина развертки такого сгиба определяется по таблице, то сгиб не отображается в окне переменных, даже если у него отключено определение параметров по исходному объекту.


Команда Параметры развертки

Позволяет задать параметры отображения листового тела (тел) в развернутом виде.

Пример

Для вызова команды нажмите кнопку Параметры развертки на панели Элементы листового тела или выберите ее название из меню Операции — Элементы листового тела. Настроить параметры развертки можно, выбрав из меню кнопки Развертка на панели Режимы название Настроить параметры.

Если в детали несколько листовых тел, укажите тело для настройки, выбрав его на панели Тела.

Активизируйте переключатель Плоскость и укажите в окне модели неподвижную грань или плоскость для создания развертки выбранного листового тела.

Затем активизируйте переключатель Выбор сгибов и задайте состояния сгибов листового тела на панели Сгибы.

Задав параметры развертки для одного листового тела, выберите в списке Тела следующее и так далее.

Не обязательно настраивать все листовые тела. Можно задать параметры развертки только для одного тела или для некоторых тел.

При необходимости активизируйте вкладку Вид Панели свойств и выберите грань или плоскость для задания ориентации Развертка.

Завершив настройку параметров развертки, нажмите кнопку Создать объект.

После задания параметров развертки становится доступна команда Развертка, позволяющая переключиться в режим развернутого отображения листового тела.


Команда Разогнуть

Команда позволяет разогнуть сгиб (несколько сгибов) листового тела.

Пример

Эта команда может быть применена к сгибам без признака «разогнуто», а также к сгибам, согнутым с помощью команды Согнуть.

Чтобы вызвать команду разгибания, нажмите кнопку Разогнуть на панели Элементы листового тела или выберите ее название из меню Операции — Элементы листового тела.

После вызова команды необходимо задать неподвижную грань или плоскость и сгибы, состояние которых требуется изменить.

Завершив настройку разгибания, нажмите кнопку Создать объект на Панели специального управления.

Листовое тело будет перестроено в соответствии с заданными параметрами разгибания или сгибания, а в Дереве построения появится пиктограмма выполненной операции.


Команда Развертка

Позволяет отобразить листовое тело в режиме развертки.

Команда доступна, если заданы параметры развертки.

Пример

В режиме развертки выбранные пользователем сгибы показываются в согнутом состоянии, а остальные — в разогнутом.

Состояния сгибов, установленные в режиме редактирования детали, при переходе в режим развертки игнорируются.

Для отображения листового тела в режиме развертки нажмите кнопку Развертка на панели Элементы листового тела или Режимы, либо выберите ее название из меню Операции — Элементы листового тела.

После вызова команды Развертка все листовые тела текущей детали будут показаны в соответствии с заданными параметрами развертки. К имени документа в заголовке окна добавляется слово «Развертка» в круглых скобках. В окне документа появляется значок режима развертки.

В режиме развертки возможен просмотр детали, а также измерение ее геометрических и массо-центровочных характеристик. Редактирование детали в этом режиме невозможно.

Для удобства просмотра развернутого листового тела можно воспользоваться ориентацией Развертка.

Чтобы перейти в обычный режим работы с листовым телом, следует вызвать команду Развертка повторно или щелкнуть мышью по значку режима развертки.

Штамповки, буртики и жалюзи представляют собой результат операций деформирования материала, а не гибки. Поэтому штамповки, буртики и жалюзи не содержат сгибов и, следовательно, разгибание этих элементов невозможно.

Смотрите также

Особенности разгибания и сгибания


Команда Закрытая штамповка

Позволяет создать в листовом теле закрытую штамповку. Команда доступна, если выделен один эскиз.

Пример

Требования к эскизу штамповки

Грань, содержащая эскиз штамповки, считается базовой (см. рисунок). Базовой гранью штамповки может быть только внешняя или внутренняя плоская грань листового тела или листового элемента.

Фактически создание закрытой штамповки относится не к операциям гибки, а к операциям деформирования, когда листовой материал вытягивается и его толщина уменьшается. При выполнении команды Закрытая штамповка это изменение толщины материала не учитывается.

Чтобы вызвать команду, нажмите кнопку Закрытая штамповка на панели Элементы листового тела или выберите ее название из меню Операции — Элементы листового тела.

По умолчанию отображение фантома листового элемента включено, и в окне модели показывается фантом элемента с текущими параметрами.

Укажите направление построения штамповки.

Выберите сторону от профиля, с которой будет располагаться неподвижная часть грани.

Выберите способ задания высоты штамповки: Полный, Внутри или Снаружи. Введите значение высоты в поле Высота.

При использовании способа Полный заданное значение высоты штамповки должно быть больше толщины листового тела.

Укажите направление добавления материала боковых стенок: внутрь или наружу по отношению к поверхности, образованной перемещением профиля в направлении построения.

Чтобы уклонить боковые стенки штамповки, введите значение угла уклона в поле Угол.
Нулевое значение в поле Угол означает построение без уклона.

Чтобы скруглить боковые ребра, включите опцию Скругление ребер и введите радиус скругления.

Чтобы скруглить ребра основания, включите опцию Скругление основания и введите радиус скругления.

Чтобы скруглить ребра дна, включите опцию Скругление дна и введите радиус скругления.

Если штамповка строится со скруглениями ребер дна и/или основания, то при малых (по сравнению с радиусами) высотах штамповки становится невозможным одновременное соблюдение заданных значений угла, радиусов и высоты. Поскольку высота и радиус имеют более высокий приоритет, значение, введенное в поле Угол, игнорируется. Величина угла уклона боковых стенок (фактически, угла наклона касательных к боковым стенкам, так как их плоские участки в этих случаях вырождаются) вычисляется системой автоматически.

Значения высоты, угла уклона, радиусов, а также направление и неподвижную сторону штамповки можно задать с помощью характерных точек.

При необходимости вы можете назначить допуски на значения параметров операции, выраженных в линейных или угловых величинах. Для этого используйте кнопку Назначить допуск, расположенную на Панели свойств рядом с полем числового параметра операции.
Подробнее о допусках...
Подробнее о назначении допуска...

Чтобы сохранить текущие значения параметров штамповки для дальнейшего использования до конца сеанса работы, включите опцию По умолчанию.

Все сделанные изменения немедленно отражаются на фантоме штамповки в окне модели. Если эскиз штамповки выходит за пределы базовой грани, то штамповка обрезается плоскостью (плоскостями) соответствующей торцевой грани (см. рисунок).

Чтобы подтвердить формирование штамповки, нажмите кнопку Создать объект на Панели специального управления.

В листовом теле появится закрытая штамповка, а в Дереве построения — ее пиктограмма.

Смотрите также

Особенности задания числовых параметров операции в полях Панели свойств


Команда Сгиб по эскизу

Позволяет создать в детали сгиб по эскизу — элемент с несколькими сгибами, профиль которого определяется контуром в эскизе. Сгиб по эскизу располагается вдоль прямолинейного ребра (или нескольких прямолинейных ребер). Это ребро будет считаться линией сгиба, а содержащая его грань (внешняя или внутренняя) — базовой гранью сгиба.

Пример

Чтобы построить сгиб по эскизу, укажите эскиз и вызовите команду Сгиб по эскизу.

Требования к эскизу...

– Выберите способ построения сгиба и укажите ребро или последовательность ребер, вдоль которых должен располагаться сгиб. Подробнее...

По умолчанию отображение фантома листового элемента включено, и в окне модели показывается фантом элемента с текущими параметрами.

– Выберите способ задания радиуса сгиба и введите его значение в поле Радиус сгиба.

– Укажите способ определения длины развертки сгиба.

– Выберите требуемое состояние сгибов, используя опцию Разогнуть.

Выбранные величина и способ задания радиуса, а также способ определения длины развертки по умолчанию используются для всех сгибов создаваемого элемента. В дальнейшем каждому из сгибов можно будет назначить собственные параметры.

– Используя элементы управления, расположенные на вкладке Замыкание углов Панели свойств, вы можете настроить замыкание смежных углов, а также задать параметры обработки начальной и конечной кромок сгиба по эскизу. Подробнее...

– Используя элементы управления, расположенные на вкладке Освобождение Панели свойств, вы можете задать параметры освобождения сгиба и освобождения угла. Подробнее...

Направление, радиус, ширину и другие параметры сгиба по эскизу можно задать с помощью характерных точек.

Для снятия значений параметров с других объектов воспользуйтесь меню геометрического калькулятора в полях Радиус сгиба и Ширина на Панели свойств.

При необходимости вы можете назначить допуски на значения параметров операции, выраженных в линейных или угловых величинах. Для этого используйте кнопку Назначить допуск, расположенную на Панели свойств рядом с полем числового параметра операции.
Подробнее о допусках...
Подробнее о назначении допуска...

Завершив настройку, нажмите кнопку Создать объект на Панели специального управления.

В листовом теле появится сгиб по эскизу, а в Дереве построения — соответствующая пиктограмма.

Обратите внимание на то, что сгибы, получившиеся в результате построения сгиба по эскизу, отображаются в Дереве построения как самостоятельные объекты.

Смотрите также

Особенности задания числовых параметров операции в полях Панели свойств


Поле Глубина

Введите значение глубины выдавливания в это поле.


Поле Глубина

Введите значение глубины освобождения сгиба в это поле.


Поле Диаметр

Введите значение диаметра отверстия в это поле.

Смотрите также

Пример перестроения отверстий при изменении состояния сгиба


Команда Жалюзи

Позволяет создать в листовом теле жалюзи по прямой линии.

Команда Жалюзи доступна, если выделен один эскиз.

Пример

Доступно два типа жалюзи: вытянутое и подрезанное (см. рисунок):

Фактически создание жалюзи относится не к операциям гибки, а к операциям деформирования, когда листовой материал вытягивается и его толщина уменьшается. При выполнении команды Жалюзи это изменение толщины материала не учитывается.

В качестве эскизов жалюзи используются отрезки. Грань, содержащая эскиз жалюзи, считается базовой. Базовой гранью жалюзи может быть только внешняя или внутренняя плоская грань листового тела или листового элемента.

Требования к эскизу жалюзи

Чтобы вызвать команду, нажмите кнопку Жалюзи на панели Элементы листового тела или выберите ее название из меню Операции — Элементы листового тела.

По умолчанию отображение фантома листового элемента включено, и в окне модели показывается фантом элемента с текущими параметрами.

Чтобы указать, по какую сторону от базовой грани будет располагаться жалюзи, активизируйте нужный переключатель в группе Направление построения.

Прямым направлением построения считается направление наружу от базовой грани, а обратным — внутрь. Текущее направление построения отображается на экране фантомной стрелкой.

Выберите положение жалюзи — справа или слева относительно эскиза, активизировав нужный переключатель в группе Положение.

Задайте высоту жалюзи: выберите способ задания высоты и введите значение высоты.

Выберите способ создания жалюзи из списка Способ. Доступны два способа: Вытяжка и Подрезка.

При использовании способа Подрезка можно выбрать форму торца — по направлению подрезки или по нормали к толщине.

Введите значение ширины жалюзи в поле Ширина. Значение ширины В должно удовлетворять следующему условию: 2*S < B, где S — толщина листового материала. Для вытянутого жалюзи значение ширины должно удовлетворять также условию B < L/2, где L — длина отрезка в эскизе жалюзи.

Чтобы скруглить ребра основания жалюзи, включите опцию Скругление и введите радиус скругления в поле Радиус.

Значения высоты, ширины, радиуса, а также направление и положение жалюзи можно задать с помощью характерных точек.

При необходимости вы можете назначить допуски на значения параметров операции, выраженных в линейных или угловых величинах. Для этого используйте кнопку Назначить допуск, расположенную на Панели свойств рядом с полем числового параметра операции.
Подробнее о допусках...
Подробнее о назначении допуска...

Чтобы сохранить текущие значения параметров жалюзи для дальнейшего использования до конца сеанса работы, включите опцию По умолчанию.

Все сделанные изменения немедленно отражаются на фантоме жалюзи в окне модели.

Чтобы подтвердить формирование жалюзи, нажмите кнопку Создать объект на Панели специального управления.

В листовом теле появится жалюзи, а в Дереве построения — соответствующая пиктограмма.

Смотрите также

Особенности задания числовых параметров операции в полях Панели свойств


Команда Линейчатая обечайка

Позволяет добавить к модели линейчатую обечайку.

Линейчатая обечайка формируется путем соединения двух эскизов с добавлением толщины получившейся поверхности. Контуры эскизов могут быть замкнутые или разомкнутые. Если оба контура замкнуты, то строится линейчатая обечайка с зазором. В углах контуров создаются сгибы заданного радиуса.

Перед построением линейчатой обечайки в модели необходимо создать два эскиза, определяющие форму ее оснований. Требования к эскизам оснований...

Пример

Для построения линейчатой обечайки выполните следующие действия.

1. Вызовите команду Линейчатая обечайка.

2. Укажите эскиз первого, а затем второго основания.
Эскизы могут быть указаны до вызова команды. Повторное указание эскиза отменяет его выбор.

Если требуется отменить выбор обоих эскизов, нажмите кнопку Указать заново на Панели специального управления.

3. Задайте параметры линейчатой обечайки.

• Толщина
Выберите направление добавления материала с помощью группы переключателей Направление для толщины, затем введите значение в поле Толщина.

• Радиус сгиба
Задайте радиус сгиба в местах соединения участков контуров. В зависимости от направления добавления материала строится сгиб, внутренний или наружный радиус которого равен заданному значению. Подробнее...

• Развертка
Задайте параметры развертки линейчатой обечайки. Данные параметры актуальны для цилиндрических и конических сгибов обечайки; на разгибание сгибов с линейчатой поверхностью параметры развертки не влияют.

Подробнее о задании параметров развертки...

• Параметры кромок и зазора
Задаются на вкладке Кромки Панели свойств.
Параметры кромок оснований...

Для линейчатой обечайки с замкнутыми эскизами:

- Параметры кромок стыка и зазор...
- Смещение зазора...

• Разбиение
Настройка разбиения линейчатой обечайки на грани производится на вкладке Разбиение Панели свойств. Настройка разбиения выполняется так же, как при построении линейчатой поверхности, с единственным отличием: отсутствует опция По вершинам.
Подробнее о разбиении на грани...

• Результат и область применения операции
Задаются на вкладке Результат операции Панели свойств.
Подробно о результате операции...
Подробно об области применения операции...

Толщину стенки, радиус сгиба, величину и смещение зазора можно задать с помощью характерных точек.

4. При необходимости вы можете назначить допуски на значения параметров операции, выраженных в линейных или угловых величинах. Для этого используйте кнопку Назначить допуск , расположенную на Панели свойств рядом с полем числового параметра операции.
Подробнее о допусках...

5. Для завершения построения нажмите кнопку Создать объект.

В модели появляется новый элемент с заданными параметрами, а в Дереве построения — пиктограмма линейчатой обечайки.

После создания линейчатой обечайки в модели формируется набор переменных.

Если требуется прервать команду до ее завершения, нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.


Команда Открытая штамповка

Позволяет создать в листовом теле открытую штамповку. Команда доступна, если выделен один эскиз.

Пример

Требования к эскизу штамповки

Грань, содержащая эскиз штамповки, считается базовой (см. рисунок). Базовой гранью штамповки может быть только внешняя или внутренняя плоская грань листового тела или листового элемента.

Фактически создание открытой штамповки относится не к операциям гибки, а к операциям деформирования, когда листовой материал вытягивается и его толщина уменьшается. При выполнении команды Открытая штамповка это изменение толщины материала не учитывается.

Чтобы вызвать команду, нажмите кнопку Открытая штамповка на панели Элементы листового тела или выберите ее название из меню Операции — Элементы листового тела.

По умолчанию отображение фантома листового элемента включено, и в окне модели показывается фантом элемента с текущими параметрами.

Укажите направление построения штамповки.

Выберите сторону от профиля, с которой будет располагаться неподвижная часть грани.

Выберите способ задания высоты штамповки: Полный или Снаружи. Введите значение высоты в поле Высота.

При использовании способа Полный заданное значение высоты штамповки должно быть больше толщины листового тела.

Укажите направление добавления материала боковых стенок: внутрь или наружу по отношению к поверхности, образованной перемещением профиля в направлении построения.

Чтобы уклонить боковые стенки штамповки, введите значение угла уклона в поле Угол.
Нулевое значение в поле Угол означает построение без уклона.

Чтобы скруглить боковые ребра, включите опцию Скругление ребер и введите радиус скругления.

В зависимости от состояния переключателя Сторона открытая штамповка может иметь либо дно, либо основание. Чтобы скруглить ребра дна или ребра основания, включите опцию Скругление и введите радиус скругления.

Если штамповка строится со скруглениями ребер дна или основания, то при малых (по сравнению с радиусами) высотах штамповки становится невозможным одновременное соблюдение заданных значений угла, радиуса и высоты. Поскольку высота и радиус имеют более высокий приоритет, значение, введенное в поле Угол, игнорируется. Величина угла уклона боковых стенок (фактически, угла наклона касательных к боковым стенкам, так как их плоские участки в этих случаях вырождаются) вычисляется системой автоматически.

Значения высоты, угла уклона, радиусов, а также направление и неподвижную сторону штамповки можно задать с помощью характерных точек.

При необходимости вы можете назначить допуски на значения параметров операции, выраженных в линейных или угловых величинах. Для этого используйте кнопку Назначить допуск, расположенную на Панели свойств рядом с полем числового параметра операции.
Подробнее о допусках...
Подробнее о назначении допуска...

Чтобы сохранить текущие значения параметров штамповки для дальнейшего использования до конца сеанса работы, включите опцию По умолчанию.

Все сделанные изменения немедленно отражаются на фантоме штамповки в окне модели. Если эскиз штамповки выходит за пределы базовой грани, то штамповка обрезается плоскостью (плоскостями) соответствующей торцевой грани (см. рисунок).

Чтобы подтвердить формирование штамповки, нажмите кнопку Создать объект на Панели специального управления.

В листовом теле появится открытая штамповка, а в Дереве построения — ее пиктограмма.

В системе КОМПАС-3D реализован упрощенный вариант моделирования открытой штамповки с уклоном или изгибом боковых стенок: условно считается, что в результате построения грань, выделенная на рисунке утолщенной линией, оказывается параллельна базовой грани.

Смотрите также

Особенности задания числовых параметров операции в полях Панели свойств


Переключатель Прямое направление

Активизируйте этот переключатель, чтобы эскиз был выдавлен в направлении по стрелке.


Переключатель Наружу

Активизируйте этот переключатель, чтобы при построении листового тела материал добавлялся наружу по отношению к поверхности, образованной перемещением эскиза в указанном направлении.


Переключатель Обратное направление

Активизируйте этот переключатель, чтобы эскиз был выдавлен в направлении, противоположном стрелке.


Переключатель Внутрь

Активизируйте этот переключатель, чтобы при построении листового тела материал добавлялся внутрь по отношению к поверхности, образованной перемещением эскиза в указанном направлении.


Уклон и угол слева

Активизируйте этот переключатель, чтобы левая сторона сгиба имела уклон продолжения и угол на сгибе (см. раздел Уклон и угол).

Левая сторона сгиба — сторона, прилежащая к тому концу ребра, на котором располагается фантомная стрелка (показывающая прямое направление отсчета угла). Противоположная сторона сгиба считается правой.

Управление боковыми сторонами сгиба: а) углы на сгибе, б) уклон боковых сторон продолжения сгиба, в), г) углы на сгибе и уклон боковых сторон продолжения
а) | б)
в) | г)


Расширение сгиба слева

Активизируйте этот переключатель, чтобы продолжение сгиба с левой стороны имело расширение (см. раздел Расширение).

Левая сторона сгиба — сторона, прилежащая к тому концу ребра, на котором располагается фантомная стрелка (показывающая прямое направление отсчета угла). Противоположная сторона сгиба считается правой.

Расширение продолжения сгиба: а) положительное, б) отрицательное
а) | б)


Уклон и угол справа

Активизируйте этот переключатель, чтобы правая сторона сгиба имела уклон продолжения и угол на сгибе (см. раздел Уклон и угол).

Левая сторона сгиба — сторона, прилежащая к тому концу ребра, на котором располагается фантомная стрелка (показывающая прямое направление отсчета угла). Противоположная сторона сгиба считается правой.

Управление боковыми сторонами сгиба: а) углы на сгибе, б) уклон боковых сторон продолжения сгиба, в), г) углы на сгибе и уклон боковых сторон продолжения
а) | б)
в) | г)


Расширение сгиба справа

Активизируйте этот переключатель, чтобы правая сторона сгиба имела расширение (см. раздел Расширение).

Левая сторона сгиба —сторона, прилежащая к тому концу ребра, на котором располагается фантомная стрелка (показывающая прямое направление отсчета угла). Противоположная сторона сгиба считается правой.

Расширение продолжения сгиба: а) положительное, б) отрицательное
а) | б)


Переключатель Скругленное

Активизируйте этот переключатель, чтобы создаваемое освобождение сгиба имело скругленную форму.


Переключатель Прямоугольное

Активизируйте этот переключатель, чтобы создаваемое освобождение сгиба имело прямоугольную форму.


Команда Обечайка

Позволяет добавить к модели обечайку. Обечайка формируется путем перемещения эскиза в направлении, перпендикулярном его плоскости, и добавлением толщины. Если эскиз представляет собой замкнутый контур, то строится обечайка с зазором.

Перед построением обечайки в модели необходимо создать эскиз, определяющий ее форму. Требования к эскизу обечайки...

Пример

Для построения обечайки выполните следующие действия.

1. Вызовите команду Обечайка.

2. Укажите эскиз.

Эскиз может быть указан до вызова команды.

3. Задайте параметры обечайки на Панели свойств.

• Направление построения
Выберите направление в группе Направление: Прямое или Обратное.

• Расстояние построения
Выберите способ определения расстояния построения из списка Способ и задайте соответствующие способу параметры. Доступны следующие способы (они аналогичны способам определения глубины при выполнении операции выдавливания):
- На расстояние,
- До вершины,
- До поверхности

• Угол уклона
Выберите направление уклона с помощью группы переключателей Уклон, а затем введите угол уклона в поле Угол.

• Толщина
Выберите направление добавления материала с помощью группы переключателей Направление для толщины, а затем введите величину в поле Толщина.

• Тип
Выберите тип сгиба в местах соединения участков контура — С постоянным радиусом или С переменным радиусом. Данный параметр актуален для обечаек с уклоном. Подробнее...

• Радиус сгиба
Задайте радиус сгиба в местах соединения участков контура. В зависимости от направления добавления материала строится сгиб, внутренний или наружный радиус которого равен заданному значению. Подробнее...

• Развертка
Задайте параметры развертки обечайки. Данные параметры актуальны для обечаек, контур в эскизе которых содержит отрезки и/или дуги (если контур включает другие объекты, то на разгибание сгибов, образованных этими объектами, параметры развертки не влияют).

Подробнее о задании параметров развертки...

• Параметры кромок и зазора
Задаются на вкладке Кромки Панели свойств.
Параметры кромок оснований...
Для обечайки с замкнутым эскизом:
- Параметры кромок стыка и зазор...
- Смещение зазора...

• Параметры сегментации
Задаются на вкладке Сегментация Панели свойств.
Подробно о сегментации обечайки...

• Результат и область применения операции
Задаются на вкладке Результат операции Панели свойств.
Подробно о результате операции...
Подробно об области применения операции...

Объекты, указанные для выполнения операции, подсвечиваются. Обечайка с текущими параметрами отображается на экране в виде фантома. Фантом позволяет визуально проконтролировать правильность задания параметров.

Направление и значения расстояния, угла уклона, толщины стенки, радиуса сгиба, а также величину и место расположения зазора можно задать с помощью характерных точек.

4. При необходимости вы можете назначить допуски на значения параметров операции, выраженных в линейных или угловых величинах. Для этого используйте кнопку Назначить допуск, расположенную на Панели свойств рядом с полем числового параметра операции.
Подробнее о допусках...
Подробнее о назначении допуска...

5. При необходимости вы можете задать наименование элемента и свойства его поверхности. Для этого активизируйте вкладку Свойства Панели свойств.

6. Нажмите кнопку Создать объект для завершения операции.

Результат операции — новое тело или приклеенный элемент — появляется в графической области. В Дереве построения появляется пиктограмма операции.

После создания обечайки в модели формируется определенный набор переменных.

Если требуется прервать операцию до ее завершения, нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Особенности задания числовых параметров операции в полях Панели свойств


Команда Буртик

Позволяет создать в листовом теле буртик с одной из трех форм сечения:

круглая | U-образная | V-образная

Команда доступна, если выделен один эскиз.

Пример

Фактически создание буртиков относится не к операциям гибки, а к операциям деформирования, когда листовой материал вытягивается и его толщина уменьшается. При выполнении команды Буртик это изменение толщины материала не учитывается.

Эскиз буртика — кривая, определяющая его конфигурацию и положение. Грань, содержащая эскиз буртика, считается базовой. Базовой гранью буртика может быть только внешняя или внутренняя плоская грань листового тела или листового элемента.

Требования к эскизу буртика

Построение буртика невозможно, если его эскиз имеет общие точки с ребрами, к которым примыкают сгибы.

Чтобы вызвать команду, нажмите кнопку Буртик на панели Элементы листового тела или выберите ее название из меню Операции — Элементы листового тела.

По умолчанию отображение фантома листового элемента включено, и в окне модели показывается фантом элемента с текущими параметрами.

Чтобы указать, по какую сторону от базовой грани будет располагаться буртик, активизируйте нужный переключатель в группе Направление построения.

Прямым направлением построения считается направление наружу от базовой грани, а обратным — внутрь. Текущее направление построения отображается на экране фантомной стрелкой.

Выберите форму сечения буртика, активизировав нужный переключатель в группе Форма сечения.

Выберите тип обработки концов буртика.

На панели Просмотр показано изображение буртика.

Выберите способ построения буртика из списка Способ. Количество доступных способов построения зависит от формы сечения: круглая, U-образная или V-образная.

Введите значения параметров буртика в соответствующие поля на Панели свойств. Набор этих полей зависит от выбранного способа построения.

Для построения буртика с круглым сечением необходимо, чтобы высота была меньше радиуса или равна ей.

Чтобы скруглить ребра основания, включите опцию Скругление основания и введите радиус скругления.

Направление построения буртика, радиус скругления основания и другие параметры — в зависимости от выбранных формы сечения и способа построения — можно задать с помощью характерных точек.

Если при построении V-образного буртика или U-образного со скруглениями ребер дна и/или основания задана малая (по сравнению с радиусами) высота, то становится невозможным одновременное соблюдение заданных значений угла, радиуса (радиусов) и высоты. Поскольку высота и радиус имеют более высокий приоритет, значение, введенное в поле Угол, игнорируется. Величина угла уклона боковых стенок (фактически, угла наклона касательных к боковым стенкам, так как их плоские участки в этих случаях вырождаются) вычисляется системой автоматически.

При необходимости вы можете назначить допуски на значения параметров операции, выраженных в линейных или угловых величинах. Для этого используйте кнопку Назначить допуск, расположенную на Панели свойств рядом с полем числового параметра операции.
Подробнее о допусках...
Подробнее о назначении допуска...

Чтобы сохранить текущие значения параметров буртика для дальнейшего использования до конца сеанса работы, включите опцию По умолчанию.

Все сделанные изменения немедленно отражаются на фантоме буртика в окне модели. Если эскиз буртика выходит за пределы базовой грани, то буртик обрезается плоскостью (плоскостями) соответствующей торцевой грани (см. рисунок).

Чтобы подтвердить формирование буртика, нажмите кнопку Создать объект на Панели специального управления.

В листовом теле появится буртик, а в Дереве построения — его пиктограмма.

Смотрите также

Особенности задания числовых параметров операции в полях Панели свойств


Поле Ширина

Введите значение ширины освобождения сгиба в это поле.


Скругление ребер дна буртика

Скругление ребер дна возможно только для буртика с U-образной формой сечения.

Ребра дна — ребра, образующиеся на стыках граней дна буртика и граней его боковых стенок. При этом ребра, принадлежащие внутренним боковым граням буртика, считаются внутренними ребрами дна, а принадлежащие внешним боковым граням внешними ребрами дна.

U-образный буртик может создаваться со скруглением ребер дна или без скругления.

Чтобы скруглить ребра дна, включите опцию Скругление дна и введите радиус скругления в поле Радиус скругления дна. Заданное значение радиуса R используется для скругления внутренних ребер дна. Радиус скругления внешних ребер равен сумме (R + S), где S — толщина листового материала. Минимальное значение радиуса скругления ребер дна — 0,0002 мм.

буртик без скругления дна | буртик со скруглением дна


Команда Показывать все имена параметров

Позволяет включить отображение названий всех элементов управления на Панели свойств. При вызове команды рядом с ее названием в меню появляется «галочка».


Команда Имена переменных в размерах

Служит для включения и отключения режима отображения имен переменных и признака «управляющий» в размерах эскизов и операций.

Подробнее об управляющих размерах...

Для вызова команды выберите ее название из меню Вид или нажмите клавишу <F11>.

При включенном режиме размеры эскизов и операций отображаются следующим образом:

– значения управляющих размеров заключены в рамки,

– имена переменных, соответствующие размерам, отображаются под их размерными линиями.

Пример отображения размеров выделенного объекта: а) эскиза, б) элемента выдавливания
а) | б)

Если значение числового параметра операции или размера эскиза задается константой, выражением или отрицательным числом, то под размерной линией размера кроме имени переменной отображается ее значение, например: v10 = a + b.


Команда Уравнения (панель окна переменных)

Команда Уравнения
(панель окна переменных)

Позволяет включить показ специальной области внизу окна переменных, предназначенной для просмотра и удаления уравнений и неравенств в документах, созданных в ранних версиях КОМПАС-3D.

Так, уравнения и неравенства могут присутствовать:

– в чертежах и фрагментах, созданных в КОМПАС-3D V11 и более ранних версиях,

– в эскизах трехмерных моделей, созданных в КОМПАС-3D V8 Plus и более ранних версиях.


Команда Включить фиксацию

Позволяет зафиксировать выделенные компоненты модели, т.е. запретить их перемещение в системе координат модели.

Для вызова команды выберите ее название из контекстного меню или нажмите кнопку Включить фиксацию на панели Редактирование сборки.

Справа от пиктограмм зафиксированных компонентов в Дереве построения отображается буква ф в круглых скобках.

Команда доступна:

– для одного или нескольких компонентов;

– для одной или нескольких групп компонентов.

Фиксируются компоненты, которые не имеют фиксации и находятся на первом уровне редактируемой модели (т.е. вставлены непосредственно в саму эту модель).

Подробнее о фиксации компонентов...


Команда Показать значки режимов

Позволяет включить или отключить показ значков режимов в окне документа КОМПАС-3D, которые служат для информирования пользователя о текущем режиме работы.

Для вызова команды выберите ее название в меню Вид или в контекстном меню значка режима.

В контекстном меню значка доступны команды, позволяющие изменить его расположение в окне документа: вверху по центру, вверху справа, внизу слева и т.д.


Команда Показать фантом

Позволяет включить или отключить отображение на экране фантома текущего (создаваемого или редактируемого) массива. Такая возможность доступна для всех массивов, кроме зеркального массива и массива по образцу.

Для вызова команды нажмите кнопку Показать фантом на Панели специального управления.

При изменении параметров массива его фантом динамически изменяется.

Использование фантомов делает создание массива более удобным, так как позволяет визуально контролировать результат построения.

Цвет фантома можно задать в диалоге настройки параметров редактирования модели.


Команда Показать фантом элемента

Позволяет включить или выключить отображение на экране фантома создаваемого или редактируемого в данный момент объекта.

Для вызова команды нажмите кнопку Показать фантом элемента на Панели специального управления.

При создании или редактировании локальной системы координат кнопка Показать фантом элемента управляет отображением линий, показывающих положение точки начала ЛСК в текущей системе координат модели.

Фантом самой ЛСК отображается на экране вне зависимости от состояния кнопки.

Фантом трехмерного элемента представляет собой каркас элемента с текущими параметрами, а фантом точки — линии, показывающие положение точки в системе координат (прямоугольной, цилиндрической или сферической).

При изменении параметров объекта его фантом динамически изменяется.

При работе с листовым телом отсутствие фантома на экране (при нажатой кнопке Показать фантом элемента) говорит о том, что создание листового элемента с текущими параметрами невозможно.

Использование фантомов делает построение более удобным, так как позволяет визуально контролировать его результат. Однако иногда (например, при построении буртиков в листовой детали) элемент оказывается довольно сложным, а отрисовка (и перерисовка) его фантома — длительной. В таких случаях для повышения скорости работы показ фантома рекомендуется отключать.

Цвет фантома элемента можно задать в диалоге настройки параметров редактирования модели.


Команда Показать фантом тела

Позволяет включить или выключить отображение на экране фантома объекта (тела или поверхности), положение которого изменяется.

Для вызова команды нажмите кнопку Показать фантом элемента на Панели специального управления.

При изменении положения фантома системы координат меняется и положение фантома тела или поверхности.

Использование фантомов делает выполнение операции более удобным, так как позволяет визуально контролировать ее результат. Однако иногда объект имеет довольно сложную форму, и отрисовка (а также перерисовка) его фантома может быть длительной. В таких случаях для повышения скорости работы показ фантома рекомендуется отключать.

Цвет фантома можно задать в диалоге настройки параметров редактирования модели.


Группа переключателей Характерные точки

Позволяет выбрать вариант отображения характерных точек вершин ломаной:

– Если активен переключатель Все характерные точки, то в каждой вершине (кроме начальной и конечной вершин разомкнутой ломаной) отображается по две точки: одна для изменения положения вершины, другая для изменения радиуса скругления.

– Если активен переключатель Характерные точки вершин и ненулевых скруглений, то точка для изменения радиуса скругления отображается, только если значение радиуса отлично от нуля. Таким образом, в вершинах с нулевым радиусом (а также в начальной и конечной вершине разомкнутой ломаной) отображается одна точка, а в остальных — две.

Вместо группы переключателей для выбора варианта отображения характерных точек можно использовать команду контекстного меню Все характерные точки.


Команда Лицензионное соглашение

Позволяет открыть документ лицензионного соглашения.


Команда Показать закладки

Управляет отображением на экране закладок документов.

Для вызова команды выберите ее название из меню Окно.

Использование закладок возможно только при развернутых (максимизированных) окнах документов. Поэтому при включении отображения закладок все открытые окна автоматически разворачиваются. Системные кнопки Свернуть и Восстановить у окон исчезают, а кнопка Закрыть помещается справа на закладке открытого документа или на строке закладок (положение кнопки зависит от настройки, выполненной в диалоге Настройки закладок документов).

Команда Показать закладки недоступна, если хотя бы один из КОМПАС-документов открыт путем перехода по гиперссылке из документа MS Office. После закрытия этого КОМПАС-документа команда становится доступна.

Смотрите также

Разделение рабочей области главного окна

Закладки документов


Команда Показать сообщение (меню Окна переменных)

Команда Показать сообщение
(меню Окна переменных)

Позволяет вывести на экран сообщение о проблеме в модели, вызванной ссылкой на переменную.


Команда Показывать оптимальный набор параметров

Позволяет выключить отображение на Панели свойств названий некоторых элементов управления. Благодаря этому все элементы становятся одновременно видны на экране, и прокрутка Панели свойств не требуется.

Обычно после вызова команды Показывать оптимальный набор параметров перестают отображаться наименования групп переключателей, а названия полей остаются видны.

Показ оптимального набора параметров возможен, если Панель свойств зафиксирована горизонтально — около верхней или нижней границы окна системы. При других вариантах расположения Панели свойств на ней отображаются названия всех параметров.


Команда Вспомогательные проекции

Позволяет включить или выключить отображение в эскизе вспомогательных проекций. Команда доступна при работе в эскизе.

Кнопка вызова команды расположена на панели Текущее состояние. Если кнопка нажата, вспомогательные проекции отображаются в эскизе; если кнопка отжата — не отображаются.

Смотрите также

Привязка к объектам модели при работе в эскизе

Проецирование объектов модели в эскиз


Кнопка Отношения

Позволяет включить или отключить область просмотра иерархии отношений объекта — дополнительную область в нижней части Дерева построения, в которой можно просмотреть объекты, являющиеся исходными и производными для объекта, выделенного в Дереве построения.

Кнопка Отношения находится на инструментальной панели вкладки Построение в окне Дерево модели.

Смотрите также

Просмотр отношений объектов


Команда Размеры выбранного элемента

Позволяет включать и отключать режим отображения размеров выбранного элемента.

Для вызова команды нажмите кнопку Размеры выбранного элемента на панели Режимы либо выберите ее название из меню Вид или из контекстного меню элемента, выделенного в Дереве построения или в окне модели. Кнопка Размеры выбранного элемента доступна, если не активна ни одна команда трехмерных построений.

После вызова команды включается режим отображения размеров выбранного элемента.

В этом режиме доступны следующие действия:

– Просмотр размеров объекта (эскиза или операции), вне процесса его редактирования.
Для этого выберите нужный объект, выделив его в Дереве построения или указав в окне модели любой его примитив: грань, ребро или вершину.
На экране отображаются размеры выбранного объекта.

– Изменение значения размеров объекта.
Для этого выберите объект (см. выше), затем дважды щелкните мышью по нужной размерной надписи. На экране появляется диалог установки значения размера. Используя этот диалог, задайте нужное значение размера.

Подробнее об отображении размеров эскизов и операций в окне модели...

Подробнее о размерах эскизов и операций...

Если при выделении объекта его размеры не отображаются в окне модели, это означает, что:

– операция не имеет числовых параметров, выраженных в линейных или угловых величинах;

– эскиз не содержит размеров или размер эскиза не имеет переменной.


Команда Показать

Позволяет включить показ выделенных объектов.

Обратите внимание на то, что тело всегда отображается целиком, даже если при вызове команды Показать был выделен отдельный формообразующий элемент. Например, в результате показа элемента выдавливания на экране появится все тело, в состав которого входит этот элемент.

Аналогично действие команды Показать на поверхности. Например, в результате показа поверхности, участвующей в операции Сшивка поверхностей, на экране возникнут все остальные поверхности, участвующие в этой же операции.

После вызова команды Показать для остальных объектов (вспомогательной оси, спирали, ломаной и т.п.) на экране появляются только эти объекты.

Команда Показать недоступна, если ни один из выделенных объектов не скрыт.

Смотрите также

Управление видимостью объектов

Исключение объектов из расчетов


Команда Источник

Позволяет скопировать значение свойства из файла-источника в текущий документ.

Выделите в Редакторе свойств ячейку, значение в которой требуется изменить, и вызовите команду Источник из контекстного меню. Команда доступна, если выделена одна ячейка.

Если опция рядом с названием команды включена, то значение в ячейке соответствует значению из файла-источника.

Если опция отключена, то значение свойства в документе было изменено.


Команда Стартовая страница

Позволяет включить или отключить отображение на экране Стартовой страницы.


Команда Таблица переменных (меню Окна переменных)

Команда Таблица переменных
(меню Окна переменных)

Позволяет создать или отредактировать таблицу переменных текущего файла.

Для вызова команды нажмите кнопку Таблица переменных на инструментальной панели Окна переменных.

После вызова команды на экране появится окно Таблица переменных, предназначенное для работы с таблицей значений внешних переменных файла.

Смотрите также

Создание, редактирование и удаление таблицы переменных


Команда Настроить...

Позволяет вызвать диалог Настройка закладок документов. В диалоге настраивается внешний вид закладок, включение и отключение закладок.

Для вызова команды выберите ее название из контекстного меню закладки документа.

Смотрите также

Закладки документов


Команда Показать скрытые обозначения

Позволяет управлять отображением в чертеже проекционных обозначений.

Для вызова команды выберите ее название из меню Вид.

После этого все скрытые проекционные обозначения будут показаны на экране светло-серым цветом.

Чтобы сделать скрытое проекционное обозначение видимым или видимое — скрытым, щелкните мышью на нужном обозначении.

За один вызов команды вы можете показать или скрыть несколько проекционных обозначений.

Чтобы завершить команду, нажмите кнопку Прервать команду на Панели специального управления.

Подробнее об управлении отображением проекционных обозначений...


Свойства в графическом документе

Элементы управления служат для задания значений свойств чертежа, фрагмента или входящих в этот документ объектов — вставок видов и фрагментов, графических макроэлементов. Кроме того, элементы управления панели позволяют отредактировать список свойств документа и настроить отображение свойств в списке.

Появляется на Панели свойств после вызова команды

– Свойства чертежа, Свойства фрагмента — из меню Файл, а для чертежа также из контекстного меню документа, выделенного в Дереве чертежа;

– Свойства вставки вида, Свойства вставки фрагмента, Свойства макроэлемента — из контекстного меню объекта, выделенного в окне построения, а в чертеже также и в Дереве чертежа;

– Свойства модели, Свойства компонента — из контекстного меню объекта, выделенного в Дереве ассоциативного чертежа.

Задайте или отредактируйте свойства на панели Список свойств.

В ассоциативном чертеже можно просмотреть свойства модели, по которой этот чертеж создан. Но эти свойства недоступны для редактирования.

Чтобы сделанные изменения вступили в силу, нажмите кнопку Создать объект на Панели специального управления.

Чтобы выйти из режима настроек без фиксации сделанных изменений, нажмите кнопку Прервать команду.

Заданными свойствами будут обладать документ или объект, для которого вызвана команда. Вновь создаваемые документы или объекты будут иметь умолчательные свойства.


Команда Отображать сетку

Позволяет показать на экране выключенные границы ячеек в виде тонких серых линий.

Эти линии отображаются только в режиме редактирования таблицы и не выводятся на печать.


Команда Обозначение узла

Позволяет создать специальное обозначение узла, используемое в строительной документации.

Для вызова команды нажмите кнопку Обозначение узла на инструментальной панели Обозначения для строительства или выберите ее название из меню Инструменты — Обозначения для строительства.

Точка привязки обозначения узла находится в центре контура, ограничивающего узел.

Введите координаты центра узла на Панели свойств или укажите точку, определяющую его положение, в окне документа.

Задайте размеры контура: для окружности — диаметр или радиус, для прямоугольников — ширину, высоту и радиус скругления.

Настройте параметры обозначения узла.

Укажите точку начала полки т2.

Примеры обозначений узла

Чтобы ввести надпись на полке обозначения узла, вызовите диалог ввода текста. Для этого щелкните мышью в поле Текст на Панели свойств или вызовите команду Текст надписи... из контекстного меню.

Текст обозначения узла может содержать ссылку на другой объект (например, номер узла) и может являться источником ссылки.

Опция Создавать вид позволяет сформировать новый вид сразу после создания обозначения узла.

Если режим автосоздания включен (кнопка Автосоздание объекта на Панели специального управления нажата), то обозначение узла фиксируется после указания точки т2.

При отключенном автосоздании для фиксации обозначения следует нажать кнопку Создать объект.

• Если опция Создавать вид была включена, то сразу после создания обозначения выносного элемента автоматически запускается команда создания нового вида. После выполнения команды в чертеже появится вид, обозначение которого будет ассоциативно связано с созданным обозначением выносного элемента.

Если обозначение создавалось в ассоциативном виде, то и новый вид ассоциативный. Он содержит проекцию модели.

Если же обозначение создавалось в обычном (неассоциативном) виде, то и новый вид обычный. Он содержит копии объектов исходного вида, попавших в контур обозначения. Подробнее...

Вы можете отказаться от создания нового вида, нажав кнопку Прервать команду. Однако делать это не рекомендуется, поскольку ручное создание вида и формирование связи между его надписью и обозначением узла займет дополнительное время. Кроме того, размещение изображения узла в отдельном виде позволяет быстро изменять масштаб изображения и делает более удобной компоновку чертежа.

При простановке обозначения узла может автоматически создаваться гиперссылка, связывающая обозначение с вновь созданным видом.

• Если опция Создавать вид была выключена, то после фиксации обозначения узла вид не создается. Вы можете создать несколько обозначений за один вызов команды Обозначение узла. Для этого укажите новые точки центра контура и начала полки. Новому обозначению присваивается очередной номер.

Чтобы завершить работу команды, нажмите кнопку Прервать команду на Панели специального управления.

Умолчательные параметры расположения текста на полке задаются в диалоге параметров отрисовки обозначения узла.

Смотрите также

Обозначение узла в сечении

Другие обозначения для строительства

Автоматическое создание вида


Опция Обозначение (неассоциативный вид)

Опция Обозначение
(неассоциативный вид)

Опция, управляющая включением в надпись вида обозначения объекта оформления, связанного с этим видом.

Выключение этой опции разрывает связь вида с объектом оформления, поэтому последующее включение опции становится невозможным. Чтобы сформировать связь заново, следует нажать кнопку Вставить ссылку.


Опция Лист (неассоциативный вид)

Опция Лист
(неассоциативный вид)

Опция, управляющая включением в надпись вида ссылки на номер листа чертежа, где располагается связанный с видом объект оформления.

Если вид не связан с объектом оформления, то опция Лист недоступна.

Чтобы связать вид с объектом оформления, воспользуйтесь кнопкой Вставить ссылку на Панели свойств.


Опция Масштаб (неассоциативный вид)

Опция Масштаб
(неассоциативный вид)

Опция, управляющая включением в надпись вида его текущего масштаба.


Опция Повернуто (неассоциативный вид)

Опция Повернуто
(неассоциативный вид)

Опция, управляющая включением в надпись вида значка «повернуто».

Чтобы добавить в надпись значение угла поворота, включите на Панели свойств опцию Угол.


Опция Угол (неассоциативный вид)

Опция Угол
(неассоциативный вид)

Опция, управляющая включением в надпись вида значения угла поворота этого вида.

Опция Угол доступна, если на Панели свойств включена опция Повернуто.


Опция Развернуто (неассоциативный вид)

Опция Развернуто
(неассоциативный вид)

Опция, управляющая включением значка «развернуто» в надпись вида.


Опция Зона (неассоциативный вид)

Опция Зона
(неассоциативный вид)

Опция, управляющая включением в надпись вида ссылки на обозначение зоны чертежа, где располагается связанный с видом объект оформления.

Если опция включена, то обозначение зоны — при условии, что в чертеже включено разбиение на зоны — добавляется в надпись.

Если опция отключена, то обозначение зоны не добавляется в надпись вида.

Если вид не связан с объектом оформления, то опция Зона недоступна.

Чтобы связать вид с объектом оформления, воспользуйтесь кнопкой Вставить ссылку на Панели свойств.


Размер марки

Поле выбора диаметра окружности обозначения марки координационных осей. В случае отрисовки двойной окружности выбирается диаметр внешней окружности.

Возможен также ввод значений диаметра с клавиатуры.

Введенные значения будут добавляться в список и сохраняться в течение сеанса работы КОМПАС-3D.

Умолчательный диаметр окружности и ширина кольца задаются в диалоге общих настроек координационных осей.

Если умолчательное значение диаметра было изменено на Панели свойств, то дальнейшие изменения этого значения возможны только с Панели свойств.

Для прямых и дуговых осей марка заданного размера отрисовывается с обоих концов координационной оси.


Команда Редактировать эскиз

Позволяет отредактировать эскиз, используемый в качестве сечения при выполнении операции выдавливания или вращения. Если в качестве сечения используется другой объект, команда Редактировать эскиз недоступна.

Для вызова команды нажмите кнопку Редактировать эскиз на Панели специального управления. Команда доступна также в контекстном меню окна модели.

Система перейдет в режим редактирования эскиза. Внесите в эскиз необходимые изменения.

Затем нажмите кнопку Эскиз на панели Текущее состояние или щелкните мышью по значку режима эскиза в окне документа для возврата в процесс операции выдавливания или вращения.

Фантом элемента в окне модели перестраивается.

Смотрите также


Команда Разместить эскиз

Позволяет задать плоскость эскиза, а также положение системы координат эскиза в этой плоскости.

Команда Разместить эскиз запускается автоматически, если при входе в режим эскиза не был выделен плоский объект. В этом случае необходимо указать плоскость для размещения нового эскиза и положение его системы координат.

Если требуется изменить расположение уже существующего эскиза, вызовите команду Разместить эскиз из его контекстного меню в Дереве построения.

После запуска команды в окне модели отображается фантом системы координат эскиза.

Чтобы задать плоскость, на которой должен находиться эскиз, укажите нужный плоский объект в Дереве построения или в окне модели.

Чтобы задать положение системы координат эскиза на плоскости, введите координаты ее начальной точки и угол поворота в поля Точка привязки и Угол на Панели свойств.

Расфиксировав поле Точка привязки или Угол, вы можете произвольно переместить или повернуть систему координат эскиза в его плоскости.

Положение системы координат эскиза (координаты начальной точки и угол поворота) задается относительно проекции на плоскость этого эскиза системы координат, в которой он находится.

Если требуется, чтобы эскиз не был связан с плоскостью, выбранной для его размещения, включите опцию Независимое размещение.

Если вы создаете новый эскиз, то, чтобы иметь возможность задать положение системы координат и включить опцию Независимое размещение, отключите автосоздание объекта, нажав одноименную кнопку на Панели специального управления.

Для завершения процесса размещения эскиза с подтверждением изменений нажмите кнопку Создать объект на Панели специального управления.
В случае создания нового эскиза система остается в режиме эскиза. Постройте графические объекты, составляющие эскиз, после чего выйдите из режима, нажав кнопку Эскиз на панели Текущее состояние или щелкните мышью по значку эскиза в окне документа.
В случае редактирования существующего эскиза он перемещается в пространстве согласно заданным параметрам. Модель перестраивается с учетом нового положения эскиза. Обратите внимание на то, что в некоторых случаях смена плоскости эскиза означает также и смену системы координат эскиза:

– при переносе эскиза на плоскость абсолютной или локальной системы координат она становится системой координат эскиза,

– при переносе эскиза на вспомогательную плоскость системой координат эскиза становится система координат этой плоскости,

– при переносе эскиза на плоскую грань системой координат эскиза становится текущая система координат модели.

Для отказа от изменения положения эскиза нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>. В случае создания нового эскиза это означает также отказ от создания.

Если графические объекты в эскизе параметрически связаны со вспомогательными проекциями объектов модели, то после вызова команды Разместить эскиза на экране появляется сообщение о возможном нарушении этих связей при смене плоскости. Чтобы продолжить работу, нажмите кнопку ОК, чтобы отказаться от размещения эскиза — кнопку Отмена.

Например, в эскизе присутствовала проекция ребра детали. Перенос эскиза на плоскость, перпендикулярную этому ребру, приведет к ошибке. Ее причиной является вырождение проекции ребра. Эскиз будет отмечен как ошибочный. Для исправления ошибки можно перенести эскиз на другую плоскость или отредактировать его, удалив связи и ограничения, приводящие к ошибке. Можно также воспользоваться командой Удалить ошибочные проекции.

Смотрите также

Команда Редактировать эскиз


Команда Закрыть — Локальный фрагмент

Позволяет закрыть текущее окно редактирования типового фрагмента, хранящегося внутри документа (созданный непосредственно в документе или взятый в него) и вернуться в окно этого документа.

Если во время сеанса работы в типовой фрагмент были внесены какие-либо изменения и вы не сохраняли их, на экране появится запрос о сохранении фрагмента. Сохранение производится в файл чертежа (аналогично команде Файл — Сохранить — В документ-владелец). При закрытии окна фрагмента без сохранения все внесенные в него изменения будут утрачены.

Чтобы закрыть окно редактирования типового фрагмента, можно также нажать системную кнопку Закрыть в правом верхнем углу окна.

Если требуется сохранить типовой фрагмент и весь чертеж, используйте команду Файл — Сохранить — С владельцем в файл.


Команда Редактировать объекты таблицы изменений

Позволяет перейти в режим редактирования объектов таблицы изменений.

Для вызова команды нажмите кнопку Объекты таблицы изменений или выберите ее название из меню Спецификация.

После вызова команды на экране появляется окно работы с объектами таблицы изменений, в котором можно просмотреть и отредактировать объекты таблицы изменений.

Если чертеж включает несколько листов с оформлениями, содержащими таблицу изменений, то после вызова команды на экране появится диалог, позволяющий выбрать номер листа, таблица изменений которого будет отредактирована.

Если в чертеже не используются оформления, содержащие таблицу изменений, то команда Редактировать объект таблицы изменений недоступна.


Команда Сохранить — В документ-владелец

Позволяет сохранить редактируемый типовой фрагмент, хранящийся внутри документа (созданный непосредственно в документе или взятый в него) в этом документе.

Если необходимо сохранить документ-владелец под новым именем или в другом месте, используйте команду Файл — Сохранить с владельцем в файл как.


Команда Редактировать объекты

Позволяет перейти в режим редактирования объектов спецификации текущего стиля внутри документа (чертежа, фрагмента или модели).

После вызова команды на экране появляется окно подчиненного режима работы со спецификацией, в котором можно просмотреть и отредактировать объекты спецификации, принадлежащие текущему документу. Изменения, произведенные в подчиненном режиме, можно впоследствии передать в связанную с документом спецификацию.

Для вызова команды нажмите кнопку Редактировать объекты на панели Спецификация или выберите ее название из меню Спецификация.

Окно спецификации в подчиненном режиме


Команда Редактировать объекты спецификации — Внешние

Позволяет перейти в режим редактирования внешних объектов спецификации.

Для вызова команды нажмите кнопку Редактировать внешние объекты спецификации на панели Спецификация или выберите ее название из меню Спецификация.

После вызова команды на экране появляется окно подчиненного режима работы со спецификацией, в котором можно просмотреть и отредактировать внешние объекты спецификации, принадлежащие текущему документу-сборке. После сохранения текущей сборки изменения ее внешних объектов будут переданы во все сборки, в которые она входит в качестве подсборки.


Группа Способ

Переключатель По объектам позволяет построить автоосевую линию, положение которой относительно выбранных объектов будет определено системой автоматически.

Переключатель С указанием границы позволяет построить автоосевую линию, положение которой относительно выбранных объектов может быть задано пользователем.


Команда Автоосевая

Позволяет построить осевую линию.

Положение и размеры осевой линии могут быть автоматически определены системой относительно объектов чертежа либо заданы пользователем.

Пример

Объекты для построения автоосевой:

– точки,

– отрезки,

– осесимметричные объекты.

Для вызова команды нажмите кнопку Автоосевая на инструментальной панели Обозначения.

Для управления параметрами автоосевой служат переключатели группы Способ.

Автоосевая может быть построена:

– без использования переключателей группы Способ:

• по двум точкам,

• в виде обозначения центра осесимметричного объекта.

– с использованием переключателей группы Способ:

• по объектам,

• с указанием границы.

Настройка отрисовки осевой линии аналогична настройке отрисовки обозначения центра.

Примеры использования автоосевой

Смотрите также

Особенности работы команды в параметрическом режиме

Другие обозначения


Указание объектов для построения автоосевой

Задайте положение осевой линии.

Если активизирован переключатель По объектам, то длина автоосевой будет определена системой автоматически в соответствии с настройками параметров осевой линии, сделанными на вкладке Параметры.

Если активизирован переключатель С указанием границы, то длина и положение автоосевой должны быть заданы пользователем.


Задание угла наклона автоосевой; обозначение центра

Задание угла наклона автоосевой;
обозначение центра

Для окружности или дуги окружности задайте угол наклона обозначения центра, перемещая курсор, и зафиксируйте положение обозначения щелчком мыши.


Команда Размер на полке

Позволяет создать размер с размерной надписью, расположенной на полке.

После вызова команды у размера появляется линия-выноска и горизонтальная полка.

Перемещая мышь, вы можете задать точку начала полки и ее направление.

Повторный вызов команды позволяет отказаться от размещения размерной надписи на полке.


Переключатель размера

Группа переключателей Размер позволяет указать, требуется ли проставить диаметральный или радиальный размер.

При нажатом переключателе Диаметральный размер система находится в режиме создания диаметрального размера.

При нажатом переключателе Радиальный размер система находится в режиме создания радиального размера.


Команда Линия

Позволяет построить линию, состоящую из отрезков и дуг окружностей.

Пример

Пример построения отрезков и дуг

Для вызова команды нажмите кнопку Линия на инструментальной панели Геометрия.

При вводе линии конечная точка созданного объекта автоматически становится начальной точкой следующего объекта.

Построенная последовательность не является единым объектом. Сегменты линии будут выделяться, редактироваться и удаляться по отдельности.

Доступно два типа объектов, составляющих линию: отрезок и дуга. В любой момент построения линии вы можете изменить текущий тип объекта. Для этого активизируйте нужный переключатель в группе Тип:

Отрезок,

Дуга.

Способ создания отрезка или дуги определяется системой автоматически в зависимости от того, какие объекты указаны пользователем. Например, если во время построения отрезка указан прямолинейный объект, то отрезок может быть параллелен или перпендикулярен ему. Это определяется направлением движения курсора.

При создании первого объекта последовательности доступны дополнительные способы построения, поскольку у этого объекта, в отличие от последующих, не зафиксирована ни одна точка.

Способы построения отрезков

Способы построения дуг

В тех случаях, когда возможно несколько вариантов построения объектов, выбирается вариант, ближайший к точке указания объекта. Этим создание сегментов линии отличается от создания аналогичных объектов с помощью специальных команд. Такой подход позволяет ускорить построение, но требует наличия определенного навыка.

Например, известно, что из одной точки может быть построено две касательных к окружности.

Если при построении отрезка, касательного к окружности, с помощью команды Касательный отрезок через внешнюю точку можно выбрать, на какой из касательных он будет лежать, то при построении касательного отрезка в составе линии выбор невозможен. Отрезок будет лежать на той прямой, которая касается окружности в точке, ближайшей к точке, в которой была указана окружность.

Переключатель Новый ввод, расположенный на Панели свойств, позволяет прервать создание текущей линии и начать новую.

Переключатель Непрерывный ввод объектов позволяет создавать отдельные объекты вместо последовательности объектов. По умолчанию при первом вызове команды Линия этот переключатель активен и начальная точка каждого следующего объекта совпадает с конечной точкой предыдущего. Чтобы задавать начальные точки объектов произвольно, отключите переключатель Непрерывный ввод объектов. Чтобы вернуться к созданию последовательности, активизируйте переключатель вновь.

Во время построения линии на Панели свойств отображаются поля параметров этих объектов: координаты начальной и конечной точек, радиус или диаметр (для дуг), длина и угол (для отрезков). Эти поля используются так же, как при создании отрезков и дуг с помощью специальных команд.

Выбор стиля линии объектов

Для выхода из команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие геометрические объекты


Команда Центр выбранных

Позволяет задать такое положение центра вращения, масштабирования или выравнивания полюсов сетки, при котором он будет совпадать с центром масс выбранных полюсов. Для расчета центра масс полюсы представляются материальными точками одинакового веса.

После вызова команды рядом с ее названием появляется «галочка».

Вы можете использовать команду при изменении положения полюсов с помощью команд Вращение, Масштабирование и Выравнивание.


Команда ЛСК

Позволяет задать такое положение центра вращения, масштабирования или выравнивания полюсов сетки, при котором он будет совпадать с началом текущей системы координат. После вызова команды рядом с ее названием появляется «галочка».

Вы можете использовать команду при изменении положения полюсов с помощью команд Вращение, Масштабирование и Выравнивание.


Команда Нет

Позволяет определить положение оси вращения полюсов сетки, а также прямой (плоскости) выравнивания полюсов без задания центра. После вызова команды рядом с ее названием появляется «галочка».

При вращении полюсов ось вращения совпадает с направляющим объектом либо с нормалью к этому объекту (для направления Перпендикулярно объекту).

При выравнивании полюсов прямая (плоскость), на которую перемещаются полюсы, совпадает с выбранным прямолинейным (плоским) объектом или нормалью к этому объекту (для варианта Перпендикулярно объекту).

Вы можете использовать команду при изменении положения полюсов с помощью команд Вращение и Выравнивание.


Команда Центр объекта

Позволяет задать такое положение центра вращения, масштабирования или выравнивания полюсов сетки, при котором он будет совпадать с центром масс редактируемой грани. Координаты центра масс рассчитываются для той формы грани, которую она имеет на момент редактирования.

После вызова команды рядом с ее названием появляется «галочка».

Вы можете использовать команду при изменении положения полюсов с помощью команд Вращение, Масштабирование и Выравнивание.


Команда Точка

Позволяет указать в качестве центра вращения, масштабирования или выравнивания полюсов сетки произвольный точечный объект, в том числе один из полюсов сетки. После вызова команды рядом с ее названием появляется «галочка». Вызовите команду и укажите щелчком мыши нужный объект.

Вы можете использовать команду при изменении положения полюсов с помощью команд Вращение, Масштабирование и Выравнивание.


Команда Выбранная плоскость

Позволяет выровнять полюсы сетки по произвольному плоскому объекту. После вызова команды рядом с ее названием появляется «галочка».

Вызовите команду и укажите нужный объект в Дереве построения или в окне модели.


Команда Плоскость XY

Позволяет выровнять полюсы сетки по плоскости XY текущей системы координат. После вызова команды рядом с ее названием появляется «галочка».


Команда Плоскость ZX

Позволяет выровнять полюсы сетки по плоскости ZX текущей системы координат. После вызова команды рядом с ее названием появляется «галочка».


Команда Плоскость ZY

Позволяет выровнять полюсы сетки по плоскости ZY текущей системы координат. После вызова команды рядом с ее названием появляется «галочка».


Команда Параметры проверки гладкости

Позволяет настроить параметры режима проверки гладкости модели — режима, при котором все грани модели представляются зеркально отражающими окружающую среду. Команда доступна, если в модели есть хотя бы одна поверхность.

Параметры отображения можно настроить, вызвав команду Параметры проверки гладкости из меню кнопки Режим проверки гладкости на панели Режимы или из меню Сервис — Проверка гладкости.

Внешний вид модели изменится, на Панели свойств появятся элементы управления параметрами отображения.

Из раскрывающегося списка Способ выберите нужный способ отображения:

– Зебра — в гранях модели отражается сфера с нанесенными на нее полосами (данный способ является умолчательным),

– Отражение среды — в гранях модели отражается сфера с нанесенным на нее растровым изображением из файла.

При этом модель находится внутри воображаемой сферы.

Для способа Зебра задайте цвет полос с помощью поля Цвет полос и параметры полос на панели Параметры “зебры”.

Для способа Отражение среды выберите файл, в котором содержится нужное изображение. Для этого нажмите кнопку Файл изображения. На экране появится стандартный диалог выбора файлов. Укажите файл формата BMP, GIF, JPEG, PNG, TIFF или TGA и нажмите кнопку Открыть. Полное имя файла появится в поле Файл-источник. Станет доступной панель Параметры отражения. С помощью этой панели настройте параметры нанесения изображения на отражаемую сферу.

При изменении параметров отображения модели ее внешний вид в окне изменяется.

Если границы отражаемых полос или участков выбранного изображения имеют неровности, включите опцию Повышенная точность отрисовки. Границы станут более ровными.

Для завершения работы в команде нажмите кнопку Прервать команду на Панели специального управления. Если в документе не включен режим проверки гладкости, то модель примет прежний вид. Если этот режим включен, отображение модели будет соответствовать настроенным параметрам.

Настройка параметров отображения модели сохраняется до конца текущего сеанса работы с документом.


Панель Параметры отражения

Панель присутствует на Панели свойств, если в списке способов отображения модели выбран способ Отражение среды. Показывает текущие значения параметров нанесения выбранного изображения на сферу, отражаемую в модели, и позволяет изменить их. Становится доступной после выбора файла изображения.

Панель содержит область предварительного просмотра и поля, соответствующие следующим параметрам:

– смещение по горизонтали,

– масштаб по горизонтали,

– смещение по вертикали,

– масштаб по вертикали,

– поворот,

– прозрачность.

«Ползунок» в каждом поле позволяет управлять значением соответствующего параметра. Область предварительного просмотра служит для визуальной оценки произведенных изменений — в ней изображена сфера с нанесенным на нее изображением. При изменении значений параметров изображение в области предварительного просмотра и внешний вид модели автоматически изменяются.


Панель Параметры “зебры”

Панель присутствует на Панели свойств, если в списке способов отображения модели выбран способ Зебра. Показывает текущие значения параметров полос «зебры» и позволяет изменять их.

Панель содержит область предварительного просмотра и поля, соответствующие следующим параметрам:

– частота полос,

– ширина полос,

– размытие границ,

– поворот,

– прозрачность.

«Ползунок» в каждом поле позволяет управлять значением соответствующего параметра. Область предварительного просмотра служит для визуальной оценки произведенных изменений — в ней изображена сфера с нанесенными на нее полосами. При изменении значений параметров изображение в области предварительного просмотра и внешний вид модели автоматически изменяются.


Команда Привязка к объектам фоновых слоев

Служит для включения и отключения привязки к объектам, лежащим в фоновых слоях графического документа или эскиза.

Команда находится в меню кнопки Привязки, расположенной на панели Текущее состояние или панели Глобальные привязки.

Смотрите также

Глобальные и локальные привязки

Общие сведения о привязках


Команда Привязка к элементам модели

Служит для включения и отключения привязки к объектам модели при построении объектов эскиза.

Команда находится в меню кнопки Привязки, расположенной на панели Текущее состояние или Глобальные привязки.

Привязка к элементам модели выполняется с помощью стандартных привязок КОМПАС-3D — Ближайшая точка, Середина и т.п. Для выполнения привязки укажите курсором нужный объект модели — вершину, ребро или ось. Когда в плоскости эскиза отобразится вспомогательная проекция указанного объекта и предполагаемая точка привязки, щелкните мышью или нажмите клавишу <Enter>.

Подробнее о привязке к объектам модели...

Смотрите также

Глобальные и локальные привязки

Общие сведения о привязках

Проецирование элементов модели в эскиз


Команда Только к видимым элементам модели

Позволяет выполнение привязки только к тем элементам модели, которые видны при ее текущем положении.

Команда находится в меню кнопки Привязки, расположенной на панели Текущее состояние или Глобальные привязки. Команда Только к видимым элементам модели доступна, если привязка к объектам модели включена (команда Привязка к элементам модели отмечена «галочкой»).

Подробнее о привязке к объектам модели...

Смотрите также

Глобальные и локальные привязки

Общие сведения о привязках

Проецирование элементов модели в эскиз


Команда Привязки

Команда позволяет управлять действием глобальных привязок, а также настраивать параметры использования привязок в документе. Доступна при работе в графическом документе или эскизе.

Для вызова команды Привязки используется одноименная кнопка на панели Текущее состояние или на панели Глобальные привязки.

Если кнопка нажата, то в документе действуют все глобальные привязки, включенные при настройке. В противном случае действие привязок отключено. Для переключения кнопки при помощи клавиатуры используется комбинация клавиш <Ctrl>+<d>. Для временного отключения глобальных привязок нажмите и удерживайте клавишу <Alt>; после того как вы отпустите клавишу, привязки включатся.

При работе с документом может потребоваться использование локальных привязок вместо глобальных. Приоритет локальной привязки выше, чем приоритет глобальной привязки. Поэтому нет необходимости отключать глобальные привязки каждый раз, когда необходимо осуществить локальную привязку: при вызове локальной привязки действие глобальных приостанавливается до фиксации точки.

Вы можете изменить набор действующих в текущем сеансе работы с документом глобальных привязок и настроить параметры использования привязок в документе. Для этого щелкните мышью по треугольнику справа от кнопки Привязки.

На экране появится меню, содержащее список глобальных привязок, опции, позволяющие расширить возможности применения привязок для различных объектов, и команду настройки параметров использования привязок в документе.

Чтобы включить или выключить нужную привязку, щелкните по ее названию в меню. Аналогично включаются и выключаются содержащиеся в меню опции.

Чтобы настроить параметры использования привязок, вызовите из списка команду Настроить параметры и выполните необходимые действия в появившемся на экране диалоге Установка глобальных привязок.

Смотрите также

Глобальные и локальные привязки

Общие сведения о привязках


Команда Настроить параметры

Позволяет настроить работу привязок в текущем окне, включить или отключить какие-либо глобальные привязки.

Команда вызывается из меню кнопки Привязки на панели Текущее состояние или панели Глобальные привязки.

После вызова команды на экране появляется диалог Установка глобальных привязок. Настройка, произведенная в данном диалоге, действительна только для текущего окна до конца сеанса работы.

Если документ открыт в нескольких окнах, то настройка привязок, произведенная в одном из них, распространяется на все окна этого документа.

Умолчательная настройка глобальных привязок — настройка, которая будет использоваться для окон вновь созданных или открытых документов — останется прежней. Чтобы изменить ее, вызовите команду Сервис — Параметры... — Система — Графический редактор — Привязки.


Команда Привязка к элементам оформления чертежа

Служит для включения и отключения привязки к линиям оформления чертежа.

Команда находится в меню кнопки Привязки, расположенной на панели Текущее состояние или панели Глобальные привязки.

Для привязки установите курсор так, чтобы его «ловушка» захватывала нужный элемент. После этого зафиксируйте курсор нажатием левой кнопки мыши или клавиши <Enter>.

Размер «ловушки» курсора можно изменить в диалоге настройки курсора.

Команда не доступна во фрагменте и эскизе.

Смотрите также

Глобальные и локальные привязки

Общие сведения о привязках


Команда Выбрать все части

Позволяет оставить в модели все части тела (тел), получившиеся в результате операции.

Команда доступна в контекстном меню в процессе изменения набора частей тела.


Команда Отменить выбор для всех

Позволяет исключить все части тела (тел), получившиеся в результате операции.

Команда доступна в контекстном меню в процессе изменения набора частей тела.

Если все части тел исключены, то выход из процесса изменения набора частей невозможен. Необходимо оставить хотя бы по одной части каждого тела.


Кнопка Сортировка

Позволяет отобразить список объектов, содержащихся в текущей группе нумерации, в порядке возрастания или убывания их номеров.

Если кнопка нажата, объекты располагаются в порядке возрастания номеров, если кнопка отжата — в порядке убывания.

Смотрите также

Автоматическая нумерация объектов


Команда Авторазмещение спецификации

Позволяет расположить спецификацию на листе, совместив правый нижний угол ее таблицы с правым верхним углом основной надписи (штампа) первого листа чертежа.

Для того чтобы разместить спецификацию на листе произвольным образом, пользуйтесь командой Спецификация на листе — Размещение.

Если на листе чертежа отображаются несколько спецификаций, то команда будет применена к спецификации текущего стиля.


Команда Сложить значения в колонках...

Позволяет вычислить сумму значений в тех дополнительных колонках и колонках бланка спецификации, при настройке которых включена опция сложения значений.

Для вызова команды нажмите кнопку Сложить значения в колонках на панели Спецификация или выберите ее название из меню Сервис.

С помощью этой команды можно подсчитать массу сборочной единицы (при условии, что в дополнительную колонку каждого объекта — сборки, детали и т.д. — введена его масса) или ее стоимость (при условии, что в дополнительные параметры каждого объекта — сборки, детали и т.д. — введена его стоимость). Перечисленные примеры не исчерпывают возможности применения данной команды.

Настраивая стиль спецификации, можно выключить или включить возможность суммирования значений в колонках, а также указать, нужно ли учитывать при сложении количество объектов. При суммировании значений в колонках групповой спецификации результатом выполнения команды будут суммы значений для каждого исполнения.

Результаты суммирования выдаются на экран в окне диалога; их можно сохранить в текстовом файле.


Команда Редактировать состав объекта

Позволяет изменить состав объектов графического документа, принадлежащих выделенному базовому объекту спецификации, или включить состав базового объекта спецификации геометрию из трехмерной модели.

Для вызова команды нажмите кнопку Редактировать состав объекта на панели Спецификация или выберите ее название из меню Редактор.

Редактирование состава объекта при работе с чертежом

Перед вызовом команды выделите в листе сборочного чертежа, подключенного к спецификации, геометрические объекты и линии-выноски, которые должны войти в состав объекта спецификации. Не снимая выделения с объектов чертежа и не закрывая его, перейдите в окно спецификации и выделите объект спецификации.

Вызовите команду Редактировать состав объекта. На экране появится диалог, в котором необходимо указать, каким образом ввести выделенные объекты чертежа в состав объекта спецификации: добавить их к уже входящим в состав объекта спецификации геометрическим объектам или заменить входящие в состав объекта спецификации геометрические объекты на выделенные. Используя эти опции, можно дополнить состав объекта или полностью изменить его.

Если перед вызовом команды Редактировать состав объекта не было выделено ни одного графического объекта в подключенном к спецификации сборочном чертеже, то единственное доступное действие по изменению состава объекта спецификации — очистить объект спецификации от всех находящихся в нем геометрических объектов.

Редактирование состава объекта при работе со сборкой

Перед вызовом команды выделите в сборке, подключенной к спецификации, подсборку или деталь, которая должна войти в состав объекта спецификации. Не снимая выделения с компонента и не закрывая сборку, перейдите в окно спецификации и выделите объект спецификации (этот объект не должен содержать геометрию из модели).

Вызовите команду Редактировать состав объекта. В появившемся на экране диалоге нажмите кнопку Добавить.

После этого в файле выбранной модели (детали или подсборке) создается объект спецификации с обозначением и наименованием этой модели; сам документ-модель подключается к созданному объекту спецификации. Затем объект спецификации из модели передается в сборку, а из нее — в подключенную спецификацию.

Таким образом, объект спецификации, который был выделен перед вызовом команды Редактировать состав объекта, «превращается» в объект, полученный из модели: к нему подключается документ-модель, а в колонки Обозначение, Наименование и дополнительную колонку Масса передаются данные модели. Остальные колонки и параметры объекта спецификации не изменяются.

Будьте внимательны при изменении состава объекта спецификации, т.к. отменить эту операцию — как при работе с чертежом, так и при работе со сборкой — невозможно.


Команда Подключать геометрию

Позволяет включать и выключать возможность подключения графических объектов к объектам текущего раздела спецификации.

Для вызова команды нажмите кнопку Подключать геометрию на панели Текущее состояние.

Кнопка вызова команды служит индикатором действующей настройки раздела — нажатая кнопка означает, что подключение геометрии к объектам текущего раздела спецификации разрешено, а отжатая — что геометрию к объектам раздела подключать запрещено.

Переключение этой кнопки эквивалентно переключению опции Геометрию в разделе подключать в диалоге настройки стиля раздела спецификации.


Команда Проставлять позиции

Позволяет включать и выключать возможность простановки номеров позиций в текущем разделе спецификации.

Для вызова команды нажмите кнопку Проставлять позиции на панели Текущее состояние.

Кнопка вызова команды служит индикатором действующей настройки раздела — нажатая кнопка означает, что позиции в текущем разделе спецификации проставляются, а отжатая — что позиции в разделе не проставляются.

Переключение этой кнопки эквивалентно переключению опции Позиции в разделе ставить в диалоге настройки стиля раздела спецификации.


Команда Сортировка

Позволяет включать и выключать возможность сортировки объектов в текущем разделе спецификации.

Для вызова команды нажмите кнопку Автоматическая сортировка на панели Текущее состояние.

Переключение этой кнопки эквивалентно переключению опции Сортировать объекты в диалоге настройки стиля раздела спецификации.

Кнопка вызова команды служит индикатором действующей настройки раздела — нажатая кнопка означает, что сортировка объектов внутри текущего раздела спецификации разрешена, а отжатая — что сортировка запрещена. Если сортировка объектов внутри раздела выключена, то их можно располагать в произвольном порядке, перемещать внутри раздела.


Команда Копировать объект

Позволяет скопировать выделенный объект спецификации внутри одного раздела или выделенный объект таблицы изменений. Скопированный объект размещается следом за исходным.

При копировании базового объекта возникает базовый объект, при копировании вспомогательного объекта — вспомогательный. Скопированный объект имеет такую же текстовую часть и дополнительные параметры, как и исходный объект.


Команда Создать спецификацию по сборке

Служит для автоматического создания спецификации, содержащей данные обо всех компонентах текущей сборки, которые находятся на первом уровне.

Для вызова команды выберите ее название из меню Спецификация или нажмите кнопку Создание спецификации по сборке на панели Редактирование сборки.

На экране появляется заполненная и подключенная к текущей сборке спецификация.

Если в файле какого-либо из компонентов не было объекта спецификации, этот объект создается в сборке на основе свойств компонента (обозначение, наименование, масса).

Созданная спецификация имеет умолчательный стиль, или (если текущая сборка имеет исполнения) один из стилей, заданных для спецификаций по сборке с исполнениями.

Обратите внимание на то, что автоматическое сохранение спецификации в файл не производится. Сохраните спецификацию вручную.

Команда Создать спецификацию по сборке не создает объекты спецификации для тел и компонентов из прикладных библиотек.

Подробнее о создании спецификации по сборке...

Смотрите также

Команда Создать объекты спецификации


Команда Удалить объект

Позволяет удалить выделенный объект спецификации (базовый или вспомогательный) или выделенный объект таблицы изменений.

После вызова команды система выдает запрос на подтверждение удаления объекта.

Отменить операцию удаления объекта невозможно.

Для быстрого удаления объекта выделите его щелчком мыши и нажмите клавишу <Delete>.

В спецификации КОМПАС не допускается наличие раздела, не содержащего ни одного объекта. Поэтому при удалении последнего объекта в разделе удаляется и сам раздел — его заголовок, пустые и резервные строки.


Команда Управление сборкой...

Позволяет подключать КОМПАС-документы (листы чертежа — *.сdw и сборки — *.a3d) к спецификации и отключать их, запускать редактирование подключенных документов, настраивать обмен данными между спецификацией и подключенными документами. Количество документов, одновременно подключенных к спецификации, не ограничено.

Для вызова команды нажмите кнопку Управление сборкой на панели Спецификация или выберите ее название из меню Сервис.

После вызова команды на экране появится диалог, в котором можно произвести настройку, описанную выше.


Команда Добавить базовый объект

Позволяет создать новый базовый объект в текущем разделе спецификации.

Для вызова команды нажмите кнопку Добавить базовый объект на панели Спецификация или выберите ее название из меню Вставка.

Для быстрого перехода к команде нажмите клавишу <Insert>.

Если спецификация пуста, на экране появится диалог, в котором нужно выбрать раздел для нового объекта. Если в спецификации есть хотя бы один объект (а следовательно, и раздел), то новый объект будет вставлен в текущий раздел. Текущим считается раздел, в котором находится курсор.


Команда Добавить исполнения

Позволяет создать в текущем разделе несколько объектов спецификации, отличающихся от выделенного объекта спецификации наличием суффикса (-01, -02, -03 и т.д.) в обозначении.

Для вызова команды нажмите кнопку Добавить исполнения на панели Спецификация или выберите ее название из меню Вставка.

После вызова команды на экране появляется диалог, в котором требуется указать номера создаваемых исполнений объекта (соответствующие суффиксы появятся затем в обозначениях новых объектов).

В результате выполнения команды в текущем разделе сразу за выделенным объектом спецификации (он считается исходным) появится несколько объектов, отличающихся от выделенного только суффиксом в обозначении.

При выделении объекта-исполнения в группе Настройки на Панели свойств активизируется переключатель Объект является исполнением.

Исполнения создаются только для базовых объектов спецификации, которые удовлетворяют следующим условиям:

– сортировка производится по колонке Обозначение,

– тип данных в колонке Обозначение — текст.

Текст в колонке Обозначение объекта-исполнения может быть только однострочным.


Команда Добавить раздел

Позволяет создать новый раздел спецификации.

Для вызова команды нажмите кнопку Добавить раздел на панели Спецификация или выберите ее название из меню Вставка.

В спецификации КОМПАС не допускается наличие раздела, не содержащего ни одного объекта. Поэтому сразу же после создания раздела в нем возникает новый объект и система переходит в режим ввода текста объекта.

Последовательность расположения разделов спецификации КОМПАС задается при настройке стиля спецификации. Вновь созданный раздел размещается не в конце спецификации, а в предназначенном для него месте. Поэтому вы можете создавать разделы спецификации в произвольном порядке.


Команда Добавить вспомогательный объект

Позволяет создать новый вспомогательный объект в текущем разделе спецификации.

Для вызова команды нажмите кнопку Добавить вспомогательный объект на панели Спецификация или выберите ее название из меню Вставка.

Если спецификация пуста, на экране появится диалог, в котором нужно выбрать раздел для нового вспомогательного объекта. Если в спецификации есть хотя бы один объект (а следовательно, и раздел), то новый вспомогательный объект будет вставлен в текущий раздел. Текущим считается раздел, в котором находится курсор.


Команда Расставить позиции

Позволяет упорядочить номера позиций после того, как их порядок нарушился в результате сортировки объектов.

Для вызова команды нажмите кнопку Расставить позиции на панели Спецификация или выберите ее название из меню Сервис.

Зачастую объекты спецификации создаются в произвольной последовательности. Если при этом в настройках соответствующего раздела включена простановка позиций, то этим объектам автоматически присваиваются порядковые номера. Если в настройках раздела включена сортировка, то после ввода каждого объекта спецификации происходит сортировка объектов, при этом последовательность порядковых номеров «сбивается» — объект, введенный в спецификацию последним, может оказаться в начале или середине раздела, а следовательно, и больший порядковый номер — перед меньшим.

При автоматическом присвоении объекту порядкового номера не учитываются резервные строки внутри каждого раздела. Поэтому даже если ввести объекты спецификации с учетом правил сортировки или отключив сортировку, их нумерация будет сплошной в порядке возрастания (без пропуска номеров для резервных строк).

По команде Расставить позиции перерасчет позиций происходит таким образом, чтобы были пронумерованы объекты в тех разделах, где включена простановка позиций, их номера располагались в порядке сортировки объектов и были пропущены номера резервных строк.

Еще одним результатом действия этой команды является расчет зон и включение обозначений зон в спецификацию (или обновление имеющихся обозначений зон).

Команда Расставить позиции доступна, если при настройке стиля текущей спецификации (либо при настройке текущей спецификации) включена опция Рассчитывать позиции или опция Рассчитывать зоны. Если обе опции выключены, то команда Расставить позиции недоступна.


Команда Сдвинуть объект вниз

Позволяет сдвинуть выделенный объект спецификации или объект таблицы изменений на одну позицию вниз.

Сдвиг объекта выполняется только внутри одного раздела (объект не может в результате сдвига переместиться в другой раздел).

Базовый объект спецификации можно перемещать только тогда, когда отключена автоматическая сортировка объектов внутри текущего раздела спецификации. Вспомогательный объект можно перемещать внутри раздела всегда. Пустые и резервные строки перемещать нельзя.

Для вызова команды нажмите кнопку Сдвинуть объект вниз или выберите ее название из меню Редактор.

Вы можете также переместить выделенный объект вниз, нажав комбинацию клавиш <Shift>+<↓>.

Перемещение объектов в групповой спецификации по вар. Б


Команда Сдвинуть объект вверх

Позволяет сдвинуть выделенный объект спецификации или объект таблицы изменений на одну позицию вверх.

Сдвиг объекта выполняется только внутри одного раздела (объект не может в результате сдвига переместиться в другой раздел).

Базовый объект спецификации можно перемещать только тогда, когда отключена автоматическая сортировка объектов внутри текущего раздела спецификации. Вспомогательный объект можно перемещать внутри раздела всегда. Пустые и резервные строки перемещать нельзя.

Для вызова команды нажмите кнопку Сдвинуть объект вверх или выберите ее название из меню Редактор.

Вы можете также переместить выделенный объект вверх, нажав комбинацию клавиш <Shift>+<↑>.

Перемещение объектов в групповой спецификации по вар. Б


Команда Загрузить документы

Позволяет открыть один или несколько документов, из которых в спецификацию был передан выбранный объект, или геометрия из которых подключена к выбранному объекту.

Команда доступна в контекстном меню объекта после нажатия кнопки Показать состав объекта.

После вызова команды на экране появляется окно выбора документов для открытия. Выберите в нем нужные документы и нажмите кнопку ОК. Чтобы отказаться от открытия документов, нажмите кнопку Отмена диалога.


Команда Спецификация на листе – Размещение

Позволяет изменить положение на листе таблицы спецификации, которая имеет текущий стиль.

После вызова команды на экране появляется фантом габаритной рамки таблицы спецификации и характерная точка (точка привязки) спецификации. Зафиксируйте курсор вблизи точки привязки и перемещайте габаритную рамку, не отпуская левую кнопку мыши. Когда габаритная рамка займет требуемое положение, отпустите кнопку мыши.

Если требуется изменить точку привязки спецификации (объявить точкой привязки другой угол габаритной рамки спецификации) и/или задать точные координаты точки привязки, вызовите из контекстного меню, возникающего при нажатии правой кнопки мыши на размещаемой таблице спецификации, команду Точка привязки...


Команда Перестроить

Позволяет актуализировать текущую спецификацию. Команда становится доступна, если пользователь отказался от автоматического перестроения, т.е. нажал кнопку Отмена в диалоге запроса на перестроение. Этот запрос появляется, если обнаружено рассогласование между спецификацией и подключенными к ней документами.

Для вызова команды выберите ее название из меню Вид или нажмите кнопку Перестроить на панели Вид.

После этого все связанные со спецификацией чертежи и сборки, которые на данный момент не актуальны, перестраиваются, после чего данные из них передаются в спецификацию. Если эти документы не были загружены, то они открываются в «слепом» режиме, т.е. без отображения на экране. В зависимости от настройки открытые в «слепом» режиме и перестроенные документы могут быть сохранены немедленно или после сохранения спецификации.

Если подключенных документов много и/или они насыщенны, то их открытие и перестроение может занять значительное время.

Спецификацию можно перестроить в любое время при работе с ней или не перестраивать вовсе, если это не требуется. Пока спецификация не перестроена, каждая ее страница отображается перечеркнутой пунктирными линиями. Это не препятствует редактированию спецификации; пунктирные линии на печать не выводятся.

Подробнее о перестроении спецификации...


Команда Показать состав объекта

Позволяет подсветить объекты, входящие в состав выделенного объекта спецификации.

Перед вызовом команды необходимо выделить в спецификации объект, состав которого требуется просмотреть. Лист сборочного чертежа или документ-сборка, подключенный к спецификации, должен быть открыт (иначе подсвечивать объекты будет просто негде).

Для вызова команды нажмите кнопку Показать состав объекта на панели Спецификация.

После вызова команды кнопка Показать состав объекта остается нажатой. При выделении другого объекта спецификации будут подсвечены объекты, относящиеся к нему.

Этой командой удобнее пользоваться, если расположить мозаикой окна спецификации и подключенного к ней документа. Тогда при перемещении выделения по объектам в окне спецификации можно наблюдать синхронное подсвечивание соответствующих графических объектов в окне сборочного чертежа.

Если сборочный чертеж состоит из нескольких листов, можно открыть и разместить мозаикой все его листы. Тогда при переходе от одного объекта спецификации к другому будут подсвечиваться графические объекты в разных листах.

Команда Показать состав объекта будет работать корректно, если сборочный чертеж подключен к спецификации, открыт в момент вызова команды и какие-либо графические объекты из него входят в состав выделенного объекта спецификации.


Команда Показать все объекты

Включает режим работы, в котором на экране отображаются все объекты спецификации (или объекты таблицы изменений), в том числе базовые объекты спецификации, имеющие одинаковую текстовую часть (в обычном режиме на экране виден только первый из одинаковых объектов), а также базовые объекты спецификации, в настройках дополнительных параметров которых выключена опция показа объекта в таблице.

Для вызова команды нажмите кнопку Показать все объекты на панели Спецификация или выберите ее название из меню Вид.

Одинаковые объекты могут иметь одинаковые или разные номера позиций, могут находиться в соседних строках или в разных местах таблицы (в пределах одного раздела спецификации). Если объекты с одинаковой текстовой частью находятся в разных разделах спецификации, то они считаются разными.

Режим просмотра всех объектов остается включенным до тех пор, пока нажата кнопка Показать все объекты. Чтобы вернуться в обычный режим, отожмите эту кнопку или снова вызовите команду Показать все объекты из меню Вид.

Смена режима показа объектов спецификации считается изменением документа (даже если его объекты не редактировались). При сохранении спецификации сохраняется и информация о действующем режиме показа объектов.


Команда Синхронизировать данные

Позволяет передать в листы сборочного чертежа изменения, внесенные в объекты спецификации. Необязательно, чтобы сборочный чертеж, в который передаются изменения, был открыт.

Для вызова команды нажмите кнопку Синхронизировать данные на панели Спецификация или выберите ее название из меню Сервис.

К изменениям, передаваемым в графический документ, относятся изменение текстовой части объекта, изменение значений и настроек дополнительных параметров, изменение номера позиции объекта, а также удаление объекта из спецификации.

Например, вы отредактировали в спецификации название и обозначение объекта, и в результате сортировки изменились номера позиций. При вызове команды синхронизации произойдет передача нового названия и обозначения в соответствующий объект чертежа и будут пересчитаны номера позиций во всех листах сборочного чертежа, подключенных к спецификации.

Если был удален объект (или несколько объектов) спецификации, а в настройке стиля этой спецификации включены опции удаления геометрии и линии-выноски при удалении объекта спецификации, то синхронизация вызовет удаление геометрических объектов и линий-выносок из чертежа.

Команда Синхронизировать данные автоматически выполняется при сохранении спецификации (в том числе при закрытии спецификации с сохранением изменений). При выполнении команды Синхронизировать данные автоматического сохранения спецификации не происходит. Поэтому если вы синхронизируете данные, а затем выйдете из спецификации, не сохраняя сделанные в ней изменения, возникнет рассогласование данных в спецификации и сборочном чертеже.


Команда Настройка спецификации

Вызывает на экран диалог настройки текущей спецификации.

Для вызова команды нажмите кнопку Настройка спецификации на панели Спецификация или выберите ее название из меню Формат.

Настройка спецификации распространяется на саму спецификацию и подключенные к ней графические документы (сборочные чертежи).


Команда Редактировать объект

Позволяет перейти в режим редактирования текста выделенного объекта спецификации или объекта таблицы изменений.

Для быстрого перехода к редактированию текста выделенного объекта нажмите клавишу <Enter> или дважды щелкните мышью на объекте.

Выход из режима редактирования текста производится точно так же, как выход из режима ввода объекта — щелчком мышью в любом месте таблицы спецификации или таблицы изменений вне редактируемого объекта или при помощи комбинации клавиш <Ctrl>+<Enter>.


Команда Закрыть — Окно объектов

Позволяет закрыть окно подчиненного режима или окно работы с объектами таблицы изменений и вернуться в окно документа, содержащего редактируемые объекты спецификации или таблицы изменений.

Чтобы закрыть окно подчиненного режима, можно также нажать системную кнопку Закрыть в правом верхнем углу окна.

Так как объекты спецификации (таблицы изменений) сохраняются в документе сразу после их создания (или редактирования), запрос на сохранение сделанных в подчиненном режиме изменений не выдается.


Команда Точка привязки...

Позволяет изменить точку привязки спецификации на листе (выбрать в качестве точки привязки другой угол габаритной рамки спецификации) и/или задать точные координаты точки привязки.

После вызова команды на экране появляется диалог, в котором можно установить положение точки привязки и ее координаты в абсолютной системе координат.


Процесс редактирования неуказанной шероховатости

При редактировании неуказанной шероховатости возможно задание параметров неуказанной шероховатости в модели.

Чтобы запустить процесс редактирования, активизируйте знак неуказанной шероховатости и вызовите из контекстного меню правой кнопкой команду Редактировать неуказанную шероховатость, либо дважды щелкните по знаку левой кнопкой мыши.

На Панели свойств появятся элементы управления, позволяющие задать параметры неуказанной шероховатости.

Чтобы выбрать тип знака, активизируйте нужный переключатель в группе Тип.

Чтобы задать надпись, введите в поле Текст текст с клавиатуры или выберите из пользовательского меню.

При необходимости используйте следующие возможности:

– добавление к неуказанной шероховатости знака шероховатости в скобках — для этого включите опцию Добавить знак в скобках,

– изменение цвета знака — для этого активизируйте вкладку Свойства и выберите нужный цвет.

Чтобы завершить настройку, нажмите кнопку Создать объект.

Подробнее о неуказанной шероховатости...


Команда Размещение — Внизу справа

Позволяет расположить в окне модели обозначение неуказанной шероховатости внизу справа.


Команда Размещение — Вверху слева

Позволяет расположить в окне модели обозначение неуказанной шероховатости вверху слева.


Команда Размещение — Вверху справа

Позволяет расположить в окне модели обозначение неуказанной шероховатости вверху справа.


Команда Авторазмещение неуказанной шероховатости

Позволяет восстановить положение знака неуказанной шероховатости по умолчанию. Команда находится в контекстном меню, которое можно вызвать на знаке неуказанной шероховатости; она доступна для знака, который размещали на листе чертежа вручную (при помощи команды Неуказанная шероховатость — Размещение).

После вызова команды авторазмещения знак неуказанной шероховатости размещается в правом верхнем углу первого листа чертежа на расстоянии 7 мм от верхней линии рамки и 8 мм от правой линии рамки.

Если требуется разместить знак в другом месте листа, пользуйтесь командой Неуказанная шероховатость — Размещение.

Для редактирования обозначения неуказанной шероховатости дважды щелкните на нем левой кнопкой мыши.

Для удаления знака используйте команду Удалить неуказанную шероховатость из меню Удалить.


Команда Неуказанная шероховатость – Размещение

Позволяет разместить на листе чертежа знак неуказанной шероховатости. Команда доступна, если на листе уже проставлено обозначение неуказанной шероховатости.

По умолчанию (сразу после создания) знак неуказанной шероховатости размещается в правом верхнем углу первого листа чертежа на расстоянии 7 мм от верхней линии рамки и 8 мм от правой линии рамки.

После вызова команды размещения знака на экране появляется габаритная рамка знака и подсвечивается точка его привязки (характерная точка). Знак можно перетащить мышью за характерную точку в любое место чертежа.

Для выхода из команды размещения знака неуказанной шероховатости перейдите к выполнению другой команды или нажмите кнопку Прервать команду на Панели специального управления.

Для того чтобы восстановить положение знака по умолчанию, вызовите из возникающего на нем контекстного меню команду Авторазмещение.

Для редактирования обозначения неуказанной шероховатости дважды щелкните на нем левой кнопкой мыши.

Для удаления знака используйте команду Удалить неуказанную шероховатость из меню Редактор — Удалить.


Команда Правописание...

Позволяет выполнить проверку правописания во всех текстовых объектах документа или во всем текстовом объекте, редактируемом в данный момент.

Для вызова команды нажмите кнопку Правописание или выберите ее название из меню Сервис. Можно также нажать комбинацию клавиш <Ctrl>+<F7>.

Такие текстовые объекты, как текст на чертеже, линия-выноска и таблица можно выделить перед вызовом команды — тогда проверка будет выполнена только в них. Если ни один объект не выделен, то проверяются все имеющиеся в документе текстовые объекты.

При редактировании отдельного текстового объекта можно выделить его фрагмент перед вызовом команды — тогда будет проверен только этот фрагмент. Если выделенных фрагментов нет, проверяется весь текстовый объект целиком.

Текст, имеющий признак языка Без проверки, остается непроверенным.


Команда Добавить в словарь

Позволяет добавить в текущий вспомогательный словарь слово, в котором предполагается орфографическая ошибка. По умолчанию такие слова подчеркнуты красной волнистой линией. После вызова команды это слово считается правильным и больше не подчеркивается.

Команда доступна в контекстном меню подчеркнутого слова.


Список Язык

Позволяет изменить признак языка текста. Признак языка определяет язык, в соответствии с которым производится проверка правописания текста.

В поле Язык отображается признак языка текущего текста.

Чтобы изменить признак, выделите текст и выберите вариант из раскрывающегося списка. Если выбран язык, то тексту присваивается указанный признак. Этот означает, что проверка выделенного текста будет произведена по соответствующему словарю. Если выбран вариант Без проверки, то текст не подлежит проверке.

После изменения языка в поле Язык слова, предположительно содержащие орфографические ошибки, по умолчанию подчеркиваются красной волнистой линией, а фрагменты текста, предположительно содержащие грамматические ошибки — зеленой. Текст с признаком «без проверки» подчеркивается серой волнистой линией.

Подробнее о проверке текста на разных языках...


Команда Язык — Английский

Позволяет для подчеркнутого слова изменить язык словаря.

После вызова команды слово проверяется по английскому словарю и приобретает признак Английский.

Если подчеркивание этого слова отменяется, то в слове ошибки нет, если цвет подчеркивания красный, то предполагается орфографическая ошибка.

Указанный цвет являются умолчательным. Он может быть изменен в диалоге настройки цвета текстовых элементов.

Команда доступна в контекстном меню подчеркнутого слова.


Команда Язык — Немецкий

Позволяет для подчеркнутого слова изменить язык словаря.

После вызова команды слово проверяется по немецкому словарю и приобретает признак Немецкий.

Если подчеркивание этого слова отменяется, то в слове ошибки нет, если цвет подчеркивания красный, то имеется орфографическая ошибка.

Указанный цвет являются умолчательным. Он может быть изменен в диалоге настройки цвета текстовых элементов.

Команда доступна в контекстном меню подчеркнутого слова.


Команда Язык — Без проверки

Позволяет для подчеркнутого слова отменить проверку по словарям.

После вызова команды слово приобретает признак Без проверки и не проверяется. Цвет подчеркивания этого слова изменяется с красного на серый. Указанные цвета являются умолчательными. Они могут быть изменены в диалоге настройки цвета текстовых элементов.

Команда доступна в контекстном меню подчеркнутого слова.


Команда Язык — Русский

Позволяет для подчеркнутого слова изменить язык словаря.

После вызова команды слово проверяется по русскому словарю и приобретает признак Русский.

Если подчеркивание этого слова отменяется, то в слове ошибки нет, если цвет подчеркивания красный, то имеется орфографическая ошибка.

Указанный цвет являются умолчательным. Он может быть изменен в диалоге настройки цвета текстовых элементов.

Команда доступна в контекстном меню подчеркнутого слова.


Команда Язык — Украинский

Позволяет для подчеркнутого слова изменить язык словаря.

После вызова команды слово проверяется по украинскому словарю и приобретает признак Украинский.

Если подчеркивание этого слова отменяется, то в слове ошибки нет, если цвет подчеркивания красный, то имеется орфографическая ошибка.

Указанный цвет являются умолчательным. Он может быть изменен в диалоге настройки цвета текстовых элементов.

Команда доступна в контекстном меню подчеркнутого слова.


Команда Пропустить все

Позволяет отказаться от орфографической проверки выделенного слова. После вызова команды подчеркивание этого слова во всем тексте отменяется. Отказ от проверки слова запоминается системой до закрытия окна документа.

При последующем редактировании пропущенного слова оно проверяется вновь.

Команда доступна в контекстном меню подчеркнутого слова.


Команда Пропустить предложение

Позволяет отказаться от грамматической проверки выбранного предложения. После вызова команды подчеркивание ошибки отменяется. Дальнейший поиск грамматических ошибок в этом предложении не производится.

Команда доступна в контекстном меню подчеркнутой части предложения.


(нет вариантов)

Эта строка появляется в контекстном меню слова, в котором предполагается орфографическая ошибка. По умолчанию такие слова подчеркнуты красной волнистой линией, если в словаре не найдено слов, близких к нему по написанию.

Вы можете добавить слово в словарь или пропустить его.


Описание грамматической ошибки

Краткое описание грамматической ошибки содержится в виде команды в контекстном меню части предложения, в котором предполагается грамматическая ошибка. По умолчанию такие слова подчеркнуты зеленой волнистой линией.

Если описание является указанием, например, «Не хватает запятой после слова «но».», то команда доступна. Вызвав ее, можно выполнить указание.

Если описание является рекомендацией, например, «Предложение перегружено глаголами. Попробуйте...», то команда недоступна. Это объясняется тем, что рекомендацию невозможно выполнить автоматически.

Вы можете отредактировать предложение или пропустить его.


Вариант написания слова

Вариант написания слова — слово, близкое по написанию к слову, в котором предполагается орфографическая ошибка. По умолчанию такие слова подчеркнуты красной волнистой линией. Варианты написания выбираются системой из словарей и отображаются в виде команд в контекстном меню предположительно ошибочного слова.

Чтобы заменить ошибочное слово правильным, вызовите из его контекстного меню нужную команду.

Вспомогательный словарь используется, если при настройке параметров проверки правописания выключена опция Предлагать только из основного словаря.

При необходимости вы можете добавить слово в словарь или пропустить его.


Команда Спираль коническая

Позволяет создать коническую спираль.

Перед вызовом команды требуется выделить плоскую грань или плоскость, на которой должна располагаться спираль.

Пример

Для вызова команды нажмите кнопку Спираль коническая на панели Пространственные кривые или выберите ее название из меню Операции — Пространственные кривые.

Выберите способ построения спирали из соответствующего списка на Панели свойств.

При использовании способа По числу витков и шагу введите нужные значения в поля Шаг и Число витков.

При использовании способов По числу витков и высоте или По шагу витков и высоте введите число или шаг витков и задайте высоту спирали.

Укажите направление построения спирали: Прямое или Обратное. Если высота спирали определяется по объекту, то изменение направления невозможно.

Выберите направление навивки спирали: Левое или Правое.

Задайте начальный и конечный диаметры спирали на вкладке Диаметр.

Введите начальный угол спирали в градусах в соответствующее поле.

Фантом конической спирали с заданными параметрами отображается в окне модели. Точка привязки спирали по умолчанию располагается в начале локальной системы координат грани или плоскости, на которой создается эта спираль.

Чтобы разместить спираль в нужном месте грани или плоскости, расфиксируйте поле т на Панели свойств. Укажите положение спирали мышью или введите координаты центра спирали в поле т.

Количество и шаг витков, а также другие параметры спирали можно задать с помощью характерных точек.

При необходимости назначьте допуски на значения параметров операции, выраженных в линейных или угловых величинах. Для этого используйте кнопку Назначить допуск, расположенную на Панели свойств рядом с полем числового параметра операции.
Подробнее о допусках...
Подробнее о назначении допуска...

Элементы управления, расположенные на вкладке Свойства Панели свойств, позволяют изменить название и цвет спирали, настроить параметры ее отображения.

Чтобы подтвердить создание спирали, нажмите кнопку Создать объект на Панели специального управления.

При создании спирали в детали автоматически формируется эскиз. Он располагается на плоскости или грани, указанной для построения спирали, и содержит вспомогательную точку со стилем «Конверт», находящуюся на оси спирали.

Отказаться от построения спирали можно, нажав кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Особенности задания числовых параметров операции в полях Панели свойств


Команда Спираль цилиндрическая

Позволяет создать цилиндрическую спираль.

Перед вызовом команды требуется выделить плоскую грань или плоскость, на которой должна располагаться спираль.

Пример

Для вызова команды нажмите кнопку Спираль цилиндрическая на панели Пространственные кривые или выберите ее название из меню Операции — Пространственные кривые.

Выберите способ построения спирали из соответствующего списка на Панели свойств.

При использовании способа По числу витков и шагу введите нужные значения в поля Шаг и Число витков.

При использовании способов По числу витков и высоте или По шагу витков и высоте введите число или шаг витков и задайте высоту спирали.

Укажите направление построения спирали: Прямое или Обратное. Если высота спирали определяется по объекту, то изменение направления невозможно.

Выберите направление навивки спирали: Левое или Правое.

Задайте диаметр спирали на вкладке Диаметр.

Введите начальный угол спирали в градусах в соответствующее поле.

Фантом цилиндрической спирали с заданными параметрами отображается в окне модели. Точка привязки спирали по умолчанию располагается в начале локальной системы координат грани или плоскости, на которой создается эта спираль.

Чтобы разместить спираль в нужном месте грани или плоскости, расфиксируйте поле т на Панели свойств. Укажите положение спирали мышью или введите координаты центра спирали в поле т.

Количество и шаг витков, а также другие параметры спирали можно задать с помощью характерных точек.

При необходимости назначьте допуски на значения параметров операции, выраженных в линейных или угловых величинах. Для этого используйте кнопку Назначить допуск, расположенную на Панели свойств рядом с полем числового параметра операции.
Подробнее о допусках...
Подробнее о назначении допуска...

Элементы управления, расположенные на вкладке Свойства Панели свойств, позволяют изменить название и цвет спирали, настроить параметры ее отображения.

Чтобы подтвердить создание спирали, нажмите кнопку Создать объект на Панели специального управления.

При создании спирали в детали автоматически формируется эскиз. Он располагается на плоскости или грани, указанной для построения спирали, и содержит вспомогательную точку со стилем «Конверт», находящуюся на оси спирали.

Отказаться от построения спирали можно, нажав кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Особенности задания числовых параметров операции в полях Панели свойств


Команда Управление положением вершины

Позволяет перейти к изменению положения текущей вершины сплайна.


Команда Управление касанием в вершине

Позволяет перейти к управлению касательным вектором сплайна в текущей вершине.


Команда Восстановить целостность линии мультилинии

Позволяет восстановить все участки указанной линии мультилинии, удаленные с помощью команды Усечь кривую или Усечь кривую двумя точками.

Для вызова команды нажмите кнопку Восстановить целостность линии мультилинии на инструментальной панели Редактирование или выберите ее название из меню Редактор.

Укажите курсором или секущим отрезком линии мультилиний, удаленные участки которых требуется восстановить.

Для указания курсором наведите его на нужную линию мультилинии. Указанная линия подсветится. После щелчка мышью все удаленные участки данной линии будут восстановлены.

Указание секущим отрезком удобно использовать для восстановления удаленных участков всех линий мультилинии или нескольких мультилиний. Указанные линии подсвечиваются. После формирования секущего отрезка удаленные участки всех указанных линий восстанавливаются.

Мультилинии, содержащие удаленные участки, могут быть выделены в окне документа до вызова команды восстановления целостности линии мультилинии. В этом случае после вызова команды на экране появляется запрос на восстановление всех удаленных участков данных мультилиний. Чтобы восстановить удаленные участки, нажмите кнопку ОК. Кнопка Отмена позволяет отказаться от восстановления.

За один вызов команды вы можете восстановить целостность произвольного количества линий мультилиний, указывая их курсором или секущим отрезком.

Для завершения команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие команды редактирования


Команда Восстановить удаленный участок линии мультилинии

Позволяет восстановить участки линии мультилинии, удаленные с помощью команды Усечь кривую или Усечь кривую двумя точками.

Для вызова команды нажмите кнопку Восстановить удаленный участок линии мультилинии на инструментальной панели Редактирование или выберите ее название из меню Редактор.

Укажите участки линий, подлежащие восстановлению, курсором или рамкой.

Для указания курсором наведите его на одну из крайних точек удаленного участка. Указанный участок подсветится. После щелчка мышью данный участок будет восстановлен.

Указание рамкой удобно использовать для восстановления нескольких удаленных участков одной мультилинии или нескольких мультилиний. Для указания участка данным способом достаточно, чтобы одна из его крайних точек находилась внутри рамки. Все участки, указанные рамкой, подсвечиваются и восстанавливаются после формирования рамки.

За один вызов команды вы можете восстановить произвольное количество удаленных участков линий мультилиний, указывая их курсором или рамкой.

Для завершения команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие команды редактирования


Команда Сплайн по точкам

Позволяет построить сплайн по точкам, проходящий через заданные вершины.

Пример

Для вызова команды нажмите кнопку Сплайн по точкам на инструментальной панели Геометрия.

Задайте тип кривой — кривая Безье или NURBS-кривая по точкам, выбрав нужный вариант из списка Тип кривой на Панели свойств.

Задайте вершины сплайна. Для этого укажите точки, через которые должен пройти сплайн.

Для точного позиционирования курсора воспользуйтесь привязками или меню геометрического калькулятора для поля т на Панели свойств.

Каждая вершина сплайна характеризуется набором параметров, которые отображаются в таблице Координаты вершин. С помощью элементов управления таблицей и команд контекстного меню таблицы вы можете изменять параметры существующих вершин.

При построении сплайна, являющегося NURBS-кривой по точкам, задайте способ формирования параметров точек сплайна, выбрав нужный вариант из списка Способ на Панели свойств.

Сплайн с текущими параметрами отображается на экране в виде фантома.

Группа переключателей Режим позволяет указать, требуется замыкать сплайн или нет.

Вы можете изменять положение вершин сплайна и управлять его формой в текущей вершине (только для NURBS-кривой по точкам). Для этого нажмите кнопку Редактировать точки на Панели специального управления. Система перейдет в режим редактирования характерных точек объекта. Внесите необходимые изменения. Если требуется продолжить указание вершин, отожмите кнопку Редактировать точки.

Построение кривой Безье

Для подтверждения создания сплайна нажмите кнопку Создать объект на Панели специального управления.

Выбор стиля линии

Для выхода из команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие геометрические объекты


Команда Сплайн на поверхности

Позволяет построить сплайн, лежащий на теоретической поверхности указанной грани. При необходимости теоретическая поверхность грани продлевается.

Общие сведения о теоретической поверхности грани...

Вершина сплайна может быть построена двумя способами:

– заданием параметров U и V;

– указанием точечного объекта.

Пример

Для вызова команды нажмите кнопку Сплайн на поверхности на инструментальной панели Пространственные кривые или выберите ее название из меню Операции — Пространственные кривые.

1. Укажите в окне модели грань, на которой будет располагаться сплайн.

Выбор объектов в окне модели

Базовую грань для построения сплайна можно указать и перед вызовом команды.

Указанная грань подсвечивается. Название выбранного объекта отображается в поле Поверхность на Панели свойств.

2. Задайте вершины сплайна.

Каждая вершина сплайна характеризуется набором параметров, которые отображаются в таблице параметров вершин. С помощью элементов управления над таблицей и команд контекстного меню таблицы вы можете изменять параметры существующих вершин или создавать новые вершины.

Сплайн с текущими параметрами отображается на экране в виде фантома.

3. С помощью группы переключателей Режим выберите вариант построения кривой: разомкнутая или замкнутая.

4. С помощью группы переключателей Тип выберите тип сплайна: сплайн по точкам или сплайн по полюсам.

5. При необходимости используйте следующие возможности:

– Изменение положения вершин и управление формой сплайна в вершинах. Для этого выделите в таблице параметров строку с номером нужной вершины. Система переходит в режим редактирования сплайна. В этом режиме можно также удалять вершины сплайна. Чтобы перейти в режим построения сплайна, выделите последнюю (ненумерованную) строку таблицы. Кроме того, вы можете переключаться между режимами построения и редактирования сплайна при помощи команды контекстного меню Завершить/Продолжить ввод вершин.

– Смена грани для построения кривой. Для этого нажмите кнопку Указать заново на Панели специального управления, а затем укажите другую грань и вершины сплайна.

– Изменение наименования и цвета создаваемой кривой, а также параметров ее отображения. Для этого активизируйте вкладку Свойства Панели свойств.

6. Нажмите кнопку Создать объект на Панели специального управления.


Замкнуть объект

Переключатель, позволяющий указать, требуется ли замыкать создаваемый объект (сплайн, ломаную или мультилинию).


Режим управления формой сплайна

Данный режим позволяет изменить форму сплайна по точкам, управляя касательностью и/или кривизной в любой ее вершине.

Существует три варианта управления формой сплайна в текущей вершине:

– Управление касательностью;

– Управление кривизной;

– Управление касательностью и кривизной .

Подробнее об управлении формой сплайна...


Направление проецирования

Группа переключателей, позволяющая выбрать направление движения эскиза для образования поверхности разбиения. Эскиз может двигаться в прямом направлении от своей плоскости, в обратном, или в двух направлениях.

Переключатель Направление проецирования присутствует на Панели свойств, если в качестве секущего объекта в операции разбиения указан эскиз.

Подробнее об объектах для операции разбиения...


Кнопка Управление формой сплайна в вершинах

Находится на Панели специального управления.

Позволяет войти в режим управления формой сплайна, построенного по точкам, или выйти из этого режима

Кнопка доступна при построении или редактировании сплайна, если выделена одна из его вершин.

Управление формой сплайна...


Кнопка Редактирование

Позволяет войти в режим редактирования поверхности или выйти из этого режима.

Кнопка Редактирование доступна при построении и редактировании поверхности по сети точек или поверхности по пласту точек и находится на Панели специального управления.

Режим редактирования поверхности по сети точек...

Режим редактирования поверхности по пласту точек...

При работе с поверхностью по сети точек кнопка Редактирование доступна, если введено целое количество рядов точек, начиная с двух, а при работе с поверхностью по пласту точек — если задана хотя бы одна точка.


Редактирование отображения производного углового размера

При редактировании отображения производного углового размера возможно изменение размерной надписи и задание новых параметров отрисовки.

Чтобы изменить отображение производного углового размера, нужно выделить его в Дереве построения или в окне модели и вызвать из контекстного меню команду Редактировать.

Выбор объектов в окне модели
Выбор объектов в Дереве построения

На Панели свойств появляются вкладки Размер, Параметры, Свойства.

Используя элементы управления вкладок, измените параметры размера.

Чтобы завершить редактирование размера, нажмите кнопку Создать объект на Панели специального управления.

Для отказа от редактирования размера нажмите клавишу <Esc> или кнопку Прервать команду.


Редактирование отображения производного диаметрального размера

При редактировании отображения производного диаметрального размера возможно изменение размерной надписи и задание новых параметров отрисовки.

Чтобы изменить отображение производного диаметрального размера, нужно выделить его в Дереве построения или в окне модели и вызвать из контекстного меню команду Редактировать.

Выбор объектов в окне модели
Выбор объектов в Дереве построения

На Панели свойств появляются вкладки Размер, Параметры, Свойства.

Используя элементы управления вкладок, измените параметры размера.

Чтобы завершить редактирование размера, нажмите кнопку Создать объект на Панели специального управления.

Для отказа от редактирования размера нажмите клавишу <Esc> или кнопку Прервать команду.


Редактирование отображения производного линейного размера

При редактировании отображения производного линейного размера возможно изменение размерной надписи и задание новых параметров отрисовки.

Чтобы изменить отображение производного линейного размера, нужно выделить его в Дереве построения или в окне модели и вызвать из контекстного меню команду Редактировать.

Выбор объектов в окне модели
Выбор объектов в Дереве построения

На Панели свойств появляются вкладки Размер, Параметры, Свойства.

Используя элементы управления вкладок, измените параметры размера.

Чтобы завершить редактирование размера, нажмите кнопку Создать объект на Панели специального управления.

Для отказа от редактирования размера нажмите клавишу <Esc> или кнопку Прервать команду.


Редактирование отображения производного радиального размера

При редактировании отображения производного радиального размера возможно изменение размерной надписи и задание новых параметров отрисовки.

Чтобы изменить отображение производного радиального размера, нужно выделить его в Дереве построения или в окне модели и вызвать из контекстного меню команду Редактировать.

Выбор объектов в окне модели
Выбор объектов в Дереве построения

На Панели свойств появляются вкладки Размер, Параметры, Свойства.

Используя элементы управления вкладок, измените параметры размера.

Чтобы завершить редактирование размера, нажмите кнопку Создать объект на Панели специального управления.

Для отказа от редактирования размера нажмите клавишу <Esc> или кнопку Прервать команду.


Текущий шаг курсора

В этом поле, расположенном на панели Текущее состояние, отображается текущее значение шага курсора.

Вы можете ввести или выбрать из списка другое значение шага.

Если панель Текущее состояние расположена вертикально, то для доступа к полю Шаг курсора нажмите соответствующую кнопку.

Возможна активизация поля Шаг курсора с помощью комбинации клавиш <Shift>+</> (клавишу </> необходимо нажимать на дополнительной цифровой клавиатуре).

Настройка шага курсора — ввод новых значений в список и выбор умолчательного значения — производится в диалоге настройки курсора.


Шаг строк

Управление шагом строк текста в текущем или выделенных абзацах производится с помощью элементов инструментальной панели Форматирование.

Кнопка Шаг строк выводит на экран диалог настройки параметров абзаца, в котором можно установить любые параметры абзаца.

В поле Шаг строк отображается текущее значение шага. Вы можете ввести нужное значение шага в это поле.

Поле Шаг строк присутствует на панели, если она расположена горизонтально.


Команда Группы...

Позволяет объединять выделенные объекты документа в именованную группу, а также выполнить различные операции редактирования групп — добавление и удаление объектов, разбиение групп и т.д.

Если в документе нет выделенных объектов и ранее не создавалась ни одна группа, команда будет недоступна.

После вызова команды на экране отображается диалог создания и редактирования групп.


Команда контекстного меню Разогнуть

Позволяет разогнуть выбранный листовой элемент (элементы). Если этот листовой элемент содержит несколько сгибов (как, например, подсечка), то будут разогнуты все его сгибы.

Вызов этой команды равносилен включению опции Разогнуть при редактировании листового элемента. Возможность применения команды Разогнуть сразу к нескольким выделенным листовым элементам позволяет избежать редактирования каждого из них в отдельности.

Пиктограммы разогнутых таким способом листовых элементов отмечаются в Дереве построения значком «разогнуто».

Пиктограмма разогнутого листового тела

Пиктограмма разогнутого сгиба

Пиктограмма разогнутого сгиба по линии

Пиктограмма разогнутого сгиба по эскизу

Пиктограмма разогнутой подсечки

Команда Разогнуть недоступна в следующих случаях:

– все выделенные листовые элементы разогнуты,

– выделены листовые элементы, не содержащие сгибы (например, пластина).

Чтобы отключить признак «разогнуто» у листовых элементов (и, соответственно, согнуть все их сгибы), необходимо выделить эти элементы и вызвать из контекстного меню команду Согнуть.

Можно также применить команду Согнуть из главного меню (Операции — Элементы листового тела).

Различия между способами изменения состояния сгибов


Кнопка Состав Дерева модели

Позволяет управлять отображением разделов и групп Дерева построения модели.

Кнопка Состав Дерева модели находится на инструментальной панели вкладки Построение в окне Дерево модели.

При нажатии кнопки со стрелкой (справа от кнопки Состав Дерева модели) на экране появляется меню, содержащее команды, одноименные разделам. Чтобы включить или выключить отображение раздела в Дереве построения, вызовите нужную команду.

Команда Группировать компоненты, находящаяся в меню, позволяет разбить компоненты в Дереве построения на группы в зависимости от типа — Сборочные единицы, Детали, Библиотечные компоненты и т.д.

«Галочка» слева от названия команды означает, что отображение соответствующего раздела и/или группировка включены, отсутствие «галочки» — отключены.

При нажатии кнопки Состав Дерева модели на экране появляется диалог настройки Дерева построения модели.

Включите (выключите) опции, соответствующие разделам, которые требуется (не требуется) отображать. Закройте диалог кнопкой ОК.

Объекты, входящие в отключенный раздел, по-прежнему отображаются в окне модели (если только их показ не отключен специально).

Настройка состава Дерева возможна, если нажата кнопка Отображение структуры модели, так как только в этом случае производится объединение объектов модели в разделы и группы.

Если модель открыта в нескольких окнах, то настройка состава Дерева, сделанная в одном из них, распространяется на все окна этой модели.


Кнопка Состав Дерева чертежа

Позволяет управлять отображением групп в Дереве чертежа.

Группы содержат однотипные объекты в порядке их создания в чертеже. Ассоциативные виды содержат модели, которые в них изображены.

Кнопка Состав Дерева чертежа находится в верхней части окна Дерева.

При нажатии кнопки со стрелкой (справа от кнопки Состав Дерева чертежа) на экране появляется меню, содержащее команды, одноименные группам. Чтобы включить или выключить отображение группы в Дереве чертежа, вызовите нужную команду.

«Галочка» слева от названия команды означает, что отображение соответствующей группы включено, отсутствие «галочки» — что отображение группы отключено.

При нажатии кнопки Состав Дерева чертежа на экране появляется диалог настройки Дерева чертежа.

Включите (выключите) опции, соответствующие группам, которые требуется (не требуется) отображать в Дереве чертежа. Закройте диалог кнопкой ОК.

Объекты, входящие в отключенную группу, по-прежнему отображаются в окне чертежа.

Если чертеж открыт в нескольких окнах, то настройка состава Дерева, сделанная в одном из них, распространяется на все окна этого чертежа.


Список Тип таблицы

Раскрывающийся список позволяет выбрать тип создаваемой таблицы — Таблица исполнений или Таблица дополнительных номеров. При изменении типа таблицы изменяется содержимое окна настройки диалога — в нем появляется соответствующая информация. Набор элементов управления диалога остается неизменным.


Команда Информация о документе...

Позволяет просмотреть и отредактировать справочную информацию, хранящуюся вместе с активным документом. При этом на экран выводится соответствующий диалог. На вкладках диалога вы можете просмотреть сведения об авторе, датах создания и изменения файла, комментарий к документу и его внешние ссылки (ссылки на библиотеки стилей, фрагментов, внешние вставки и др.).

При просмотре сведений о графических документах, моделях и спецификациях в диалоге появляется специальная вкладка для просмотра и редактирования атрибутов, присвоенных текущему документу в целом.


Вставка индексов

Чтобы объявить выделенный или набираемый заново текст состоящим из индексов малой высоты (с высотой шрифта, равной около 45% от установленной высоты обычного текста), нажмите кнопку Вставить индекс (малой высоты) или вызовите команду Вставка — Индекс — Малой высоты.

Чтобы объявить выделенный или набираемый заново текст состоящим из индексов средней высоты (с высотой шрифта, равной около 67% от установленной высоты обычного текста), нажмите кнопку Вставить индекс (средней высоты) или вызовите команду Вставка — Индекс — Средней высоты.

Чтобы объявить выделенный или набираемый заново текст состоящим из индексов нормальной высоты (с высотой шрифта, равной установленной высоте обычного текста), нажмите кнопку Вставить индекс (нормальной высоты) или вызовите команду Вставка — Индекс — Нормальной высоты.


Команда Придать толщину

Позволяет придать толщину граням тела или поверхности, т.е. добавить слой материала на эти грани. Сформированный слой материала представляет собой заполненное материалом пространство между исходной и эквидистантной поверхностями или двумя эквидистантными поверхностями.

Пример придания толщины поверхности

Пример добавления материала на грани тела

Для вызова команды нажмите кнопку Придать толщину на инструментальной панели редактирования детали или на инструментальной панели редактирования модели. Можно также выбрать название команды в меню Операции.

Команда доступна, если в модели есть хотя бы одна поверхность или тело.

Исходные объекты для придания толщины

Укажите исходный объект.

Исходные объекты для добавления материала можно указать и перед вызовом команды.

Повторное указание грани отменяет ее выбор.

Если требуется сменить все объекты, указанные для придания толщины, нажмите кнопку Указать заново на Панели специального управления, а затем повторите выбор объектов.

Указанные объекты подсвечиваются в окне модели.

Для задания толщины добавляемого слоя выберите направление добавления материала из списка Тип построения тонкой стенки и введите толщину стенки на Панели свойств.

Добавляемый слой отображается на экране в виде фантома с характерными точками для задания его толщины.

Выбор результата операции

Настройка свойств поверхности элемента

Придание толщины граням тела из частей невозможно. Необходимо сначала сделать тело целым, отредактировав имеющиеся элементы или создав новые элементы, которые соединят части.

Кроме того, выполнение операции придания толщины невозможно, если добавляемый ею слой является телом с нарушенной топологией.

При необходимости назначьте допуски на значения параметров операции, выраженных в линейных или угловых величинах. Для этого используйте кнопку Назначить допуск, расположенную на Панели свойств рядом с полем числового параметра операции.
Подробнее о допусках...
Подробнее о назначении допуска...

Чтобы подтвердить выполнение операции, нажмите кнопку Создать объект на Панели специального управления.

Пиктограмма созданного элемента появляется в Дереве построения.

Прервать построение можно, нажав кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие команды редактирования детали

Другие команды редактирования сборки


Команда Текущая СК

Позволяет присвоить системе координат статус «текущая» или отменить этот статус.

Команда доступна в контекстном меню абсолютной или локальной системы координат в Дереве построения.

– Если команда отмечена «галочкой», значит, система координат уже является текущей; после вызова команды она перестанет быть ею, и текущей станет абсолютная система координат.

– Если команда не отмечена «галочкой», значит, система координат не текущая; после вызова команды она станет текущей.


Команда Перенести в СК

Позволяет перенести объект из его системы координат в другую систему координат.

Для вызова команды выберите ее название из меню Редактор.

Укажите в Дереве построения объекты, систему координат которых требуется заменить. Перечень объектов отображается в Списке объектов на Панели свойств.

В списке СК укажите систему координат, в которую требуется перенести объекты.

Опция Сохранять положение позволяет указать, требуется ли сохранение положения объекта в абсолютной системе координат модели после переноса в другую систему координат.

Завершив настройку, нажмите кнопку Создать объект на Панели специального управления. Выбранные объекты будут перенесены в указанную систему координат.

Чтобы отказаться от замены системы координат объектов, нажмите кнопку Прервать команду или клавишу <Esc>.

Подробнее о замене системы координат объектов...


Поле Текст

Поле для ввода текста обозначения.

Текст обозначения можно сформировать также в диалоге ввода текста обозначения. Для вызова этого диалога щелкните мышью в поле Текст на вкладке Знак Панели свойств или вызовите команду Текст надписи... из контекстного меню. Можно также просто начать ввод текста — диалог автоматически появится на экране.

Для обозначений базы, линии разреза/сечения (для машиностроения), стрелки взгляда, выносного элемента и линии-выноски может использоваться автоматическая сортировка букв. При этом буква обозначения выбирается автоматически. Признаком того, что к текущему объекту применяется автосортировка, является включенная опция Автосортировка на Панели свойств.

Особенности ввода обозначений объектов при включенной автосортировке:

– база — ручной ввод текста обозначения невозможен (недоступны поле Текст и команда Текст надписи...),

– линия разреза/сечения (для машиностроения), стрелка взгляда, выносной элемент — в обозначение возможен ввод дополнительного текста (доступны поле Текст и команда Текст надписи..., недоступна ссылка на букву в диалоге ввода текста обозначения),

– линия-выноска — возможен ввод любой части обозначения (доступны поле Текст, команда Текст надписи... и ссылка на букву; при удалении буквы-ссылки опция Автосортировка отключается).

Смотрите также

Автосортировка буквенных обозначений в графических документах


Команда Условное изображение резьбы

Позволяет создать условное изображение резьбы на цилиндрической или конической поверхности модели.

Для вызова команды нажмите кнопку Условное изображение резьбы на инструментальной панели Элементы оформления.

На Панели свойств появляются элементы управления, позволяющие настраивать создаваемое изображение.

1. Укажите базовый объект — цилиндрическую или коническую грань, на которой должна быть построена резьба.

По умолчанию создается метрическая резьба с крупным шагом. В окне модели возникает фантом условного изображения резьбы. Начальная граница резьбы определяется автоматически. Если требуется сменить границу, активизируйте переключатель Начальная граница, а затем укажите в окне модели или в Дереве построения поверхность, грань, ребро или плоский объект от которого нужно построить резьбу.

2. Если требуется изменить параметры резьбы, выберите из списка Резьба нужный стандарт резьбы или строку Нестандартная резьба.

• для стандартной резьбы выберите номинальный диаметр и шаг в одноименных полях или в диалоге, вызываемом кнопкой Выбор параметров стандартной резьбы,

• для нестандартной резьбы введите номинальный диаметр и шаг в одноименных полях.

3. Задайте длину резьбы с помощью группы переключателей Длина резьбы:

• На заданную длину: длина резьбы определяется заданным расстоянием. Введите значение длины резьбы в поле Длина резьбы.

• До конечной границы: длина резьбы определяется автоматически по положению конечной границы резьбы.
Конечную границу резьбы можно изменить, активизировав переключатель Конечная граница и указав нужную поверхность.

Диаметр и шаг (для нестандартной резьбы), а также длину резьбы можно задать с помощью характерных точек.

4. При необходимости используйте следующие возможности:

– Подгонка — изменение геометрических параметров базового объекта согласно выбранному номинальному диаметру резьбы (использование подгонки — обязательное условие построения конической стандартной резьбы). Для этого включите опцию Подгонка.
Подробнее о подгонке...

– Использование диаметра базового объекта резьбы в качестве номинального диаметра резьбы (доступно только для нестандартной резьбы). Для этого включите опцию Автоопределение диаметра. Автоматически определенное значение диаметра отображается в поле Номинальный диаметр резьбы.

– Назначение допусков на значения параметров операции, выраженных в линейных или угловых величинах. Для этого используйте кнопку Назначить допуск, расположенную на Панели свойств рядом с полем числового параметра операции.
Подробнее о допусках...
Подробнее о назначении допуска...

Назначение допуска на диаметр и шаг резьбы возможно, если создается нестандартная резьба.

– Создание условного изображения резьбы по образцу. Подробнее...

5. На вкладке Свойства Панели свойств вы можете задать название и цвет отображения резьбы.

6. Завершив настройку, нажмите кнопку Создать объект на Панели специального управления для фиксации условного изображения резьбы в детали.

Подробнее о создании условного изображения резьбы...


Команда Символы форматирования

Позволяет включить или отключить отображение на экране служебных символов форматирования текста (конец абзаца, табуляция, пробел и т.д.).

Для вызова команды нажмите кнопку Символы форматирования или выберите ее название из меню Вид.


Команда Выбор базового объекта

Позволяет указать существующий в документе прямолинейный объект в качестве оси симметрии.


Команда Технические требования – Синхронизация

Позволяет передать в чертеж технические требования из модели, по которой создан ассоциативный вид. Передача данных происходит из документа-модели, который связан с основной надписью чертежа.

Для выполнения синхронизации выберите название команды из меню Вставка или из контекстного меню технических требований на чертеже. Команда доступна, если в документе есть ассоциативный вид.

В результате выполнения команды в чертеже появляются актуальные технические требования из модели. Если в чертеже находились требования, ранее переданные из модели, отредактированные или введенные вручную, то они полностью заменяются на новые.

Подробнее о синхронизации технических требований...

Для быстрой отмены синхронизации технических требований нажмите кнопку Отменить на Стандартной панели или комбинацию клавиш <Alt> + <BackSpace> либо <Ctrl> + <Z>.

Смотрите также

Ввод технических требований в модели

Размещение технических требований


Команда Синхронизировать данные

Позволяет привести данные основной надписи чертежа в соответствие со свойствами модели — синхронизировать основную надпись.

Команда доступна, если синхронизация основной надписи включена. Управление синхронизацией производится переключателем Синхронизация данных. Он доступен на вкладке Параметры Панели свойств после двойного щелчка мышью на основной надписи. На этой же вкладке вы можете включить автоматическую синхронизацию основной надписи.

Если ассоциативный вид модели скопирован в новый чертеж через буфер обмена, то для передачи данных из этой модели в основную надпись чертежа его необходимо перестроить.

Если в модели имеются несохраненные изменения, то после вызова команды Синхронизировать данные на экране появляется запрос на сохранение модели. Нажмите кнопку Да, чтобы немедленно сохранить файл модели или кнопку Нет, чтобы отказаться от сохранения.


Команда Синхронизировать данные

Передает изменения объектов спецификации из чертежа или модели в подключенную к этому документу спецификацию. Спецификация, в которую передаются изменения, может быть не загружена в момент синхронизации.

Для вызова команды нажмите кнопку Синхронизировать данные на панели Спецификация или выберите ее название из меню Спецификация.

После выполнения команды система выдает сообщение о том, какая спецификация была изменена.


Команда Синхронизировать

Позволяет вручную синхронизировать параметры неуказанной шероховатости в ассоциативном чертеже и в модели. Команда вызывается из контекстного меню знака неуказанной шероховатости в чертеже.

Команда доступна, если в настройках синхронизации графического документа включена опция Синхронизировать неуказанную шероховатость.


Остановить команду Перейти под управление системы

Остановить команду
Перейти под управление системы

Данная команда приостанавливает передачу управления от библиотеки к системе КОМПАС-3D.


Команда Ввод таблицы

Позволяет создать таблицу в чертеже или фрагменте.

Для вызова команды нажмите кнопку Ввод таблицы на инструментальной панели Обозначения.

После вызова команды КОМПАС переключается в режим работы с текстом. При этом изменяются количество и названия команд главного меню, а также состав Компактной панели.

В поле Угол можно ввести угол наклона таблицы к оси Х системы координат текущего вида.

Укажите точку привязки таблицы.

На экране появится диалог создания таблицы, в котором можно настроить параметры создаваемой таблицы или выбрать существующую таблицу в качестве прототипа.

После закрытия этого диалога кнопкой ОК в документе появляется таблица с заданными параметрами.

Введите текст в ячейки таблицы.

Вы можете изменить установленные по умолчанию параметры текста с помощью элементов управления, расположенных на вкладке Форматирование Панели свойств, а также вставить различные специальные объекты с помощью элементов вкладки Вставка.

Элементы управления вкладки Таблица позволяют изменить структуру таблицы и ее оформление.

Чтобы зафиксировать изображение, нажмите кнопку Создать объект на Панели специального управления.

Вы можете создать несколько таблиц за один вызов команды Таблица. Закончив формирование первой таблицы, переместите курсор за ее пределы и нажмите левую кнопку мыши. Предыдущая таблица автоматически зафиксируется, и на экране снова появится диалог создания таблицы.

Вы можете изменить расположение таблицы, не прерывая команды. Для этого вызовите из контекстного меню команду Редактировать размещение. На панели свойств появятся элементы управления Точка привязки и Угол, и вы сможете задать нужное расположение текста.

Для выхода из режима ввода таблицы нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Приемы работы с таблицами

Названия и нумерация таблиц

Команда Текст


Команда Выбор файла-таблицы координат

Позволяет выбрать файл, содержащий координаты точек, задающих позиции экземпляров массива. После вызова команды на экране появляется диалог открытия файлов Windows. Укажите имя нужного файла и нажмите кнопку Открыть.


Встраивание совокупности вершин

Чтобы встроить совокупность вершин между двумя уже существующими, следует нажать кнопку Вставить совокупность вершин. Система переходит в процесс создания новых вершин ломаной между двумя уже существующими вершинами.

Укажите курсором граничные вершины ломаной, между которыми будет встраиваться совокупность.

В качестве второй граничной вершины не может быть выбрана вершина, номер которой меньше, чем у первой.

Участок ломаной между граничными вершинами исчезнет.

Задайте новые вершины ломаной. При построении совокупности вершин доступны те же приемы, что и при построении ломаной. Параметры вставленных вершин отображаются в таблице параметров вершин.

Чтобы завершить встраивание, нажмите кнопку Создать объект на Панели специального управления.

Вершины встроенной совокупности заменят собой вершины, ранее находившиеся между граничными. Параметры вставленных вершин будут добавлены в таблицу параметров. Вершины ломаной будут перенумерованы.

Чтобы отказаться от встраивания совокупности вершин, нажмите кнопку Прервать команду.


Кнопка Встроить совокупность вершин

Позволяет встроить между двумя вершинами пространственной ломаной несколько вершин.

Вершины, между которыми встраивается совокупность, могут быть несмежными. Например, можно вставить совокупность вершин между существующими вершинами №4 и №7.


Команда Область применения «Компоненты»

Позволяет перейти к заданию области применения «Компоненты» для текущей операции.

Для вызова команды нажмите кнопку Область применения «Компоненты» на Панели специального управления. Система перейдет в режим задания области применения операции.

В этом режиме на Панели свойств отображаются элементы, позволяющие указать компоненты, к которым будет применена текущая операция.

Вы можете использовать автоматическое определение области применения или воспользоваться дополнительными способами.

Автоопределение области применения

Другие способы задания области применения

Завершив определение области применения, нажмите кнопку Создать объект на Панели специального управления. Система вернется в режим выполнения операции, для которой производилась настройка области применения.

Если действие операции распространяется только на тела (в группе Область применения активен переключатель Область применения «Тела»), то элементы управления областью применения «Компоненты» недоступны.


Команда Раствор дуги(меню геометрического калькулятора)

Команда Раствор дуги
(меню геометрического калькулятора)

Позволяет снять значение угла раствора указанной пространственной дуги, дуги в эскизе, дугообразного ребра.

Объект, который может быть указан для измерения угла раствора, при наведении курсора подсвечивается, а его пиктограмма отображается рядом с курсором.

Укажите курсором дугу, значение угла раствора которой нужно определить. Фиксация курсора выполняется нажатием левой кнопки мыши или клавиши <Enter>.

Значение угла раствора будет вычислено и автоматически занесено в поле ввода на Панели свойств.

Смотрите также

Геометрический калькулятор

Меню геометрического калькулятора


Команда Копировать свойство(меню геометрического калькулятора)

Команда Копировать свойство
(меню геометрического калькулятора)

Позволяет присвоить параметру редактируемого листового элемента такое же значение, как в другом, уже существующем, элементе. Свойства копируются только между элементами одного типа (например, в сгиб можно скопировать радиус другого сгиба, но не сгиба по линии).

Чтобы задать источник копируемого свойства, укажите нужный листовой элемент в Дереве построения или принадлежащий ему примитив в графической области (ребро, грань и т.д.). В графической области объект, который может быть указан для копирования свойства, при наведении курсора подсвечивается, а его пиктограмма отображается рядом с курсором.

После указания источника свойства значение параметра будет определено и автоматически занесено в поле ввода на Панели свойств.

Смотрите также

Геометрический калькулятор

Меню геометрического калькулятора


Команда Диаметр(меню геометрического калькулятора)

Команда Диаметр
(меню геометрического калькулятора)

Позволяет снять значение диаметра указанного объекта.

Объектом может являться пространственная дуга, окружность или дуга в эскизе, круглое ребро, цилиндрическая или сферическая грань. Объект, который может быть указан для измерения значения параметра, при наведении курсора подсвечивается, а его пиктограмма отображается рядом с курсором.

Укажите курсором объект, значение диаметра которого нужно определить. Фиксация курсора выполняется нажатием левой кнопки мыши или клавиши <Enter>.

Значение диаметра будет вычислено и автоматически занесено в поле ввода на Панели свойств.

Смотрите также

Геометрический калькулятор

Меню геометрического калькулятора


Команда Направление объекта(меню геометрического калькулятора)

Команда Направление объекта
(меню геометрического калькулятора)

Позволяет определить угол сгиба по указанному прямолинейному или плоскому объекту.

Объект, который может быть указан для измерения значения угла, при наведении курсора подсвечивается, а его пиктограмма отображается рядом с курсором.

Если указанный объект прямолинейный, то измеряется значение угла между указанным объектом и базовой гранью сгиба. Указанный прямолинейный объект должен располагаться в плоскости, перпендикулярной линии сгиба.

Если указанный объект плоский, то измеряется значение угла между базовой гранью сгиба и линией пересечения указанного объекта с плоскостью, перпендикулярной линии сгиба. Указанный плоский объект не должен быть перпендикулярен линии сгиба.

Укажите объект для определения угла сгиба. Фиксация курсора выполняется нажатием левой кнопки мыши или клавиши <Enter>.

Значение угла будет вычислено и автоматически занесено в поле ввода на Панели свойств.

Смотрите также

Геометрический калькулятор

Меню геометрического калькулятора


Команда Между 2 объектами(меню геометрического калькулятора)

Команда Между 2 объектами
(меню геометрического калькулятора)

Позволяет снять значение угла между двумя указанными объектами.

Объектами могут являться координатные и вспомогательные оси и плоскости, пространственные кривые, кривые в эскизе, ребра, грани. Объекты можно указывать в любой комбинации.

Объект, который может быть указан для измерения угла, при наведении курсора подсвечивается, а его пиктограмма отображается рядом с курсором.

Последовательно укажите курсором два объекта, угол между которыми необходимо определить. Фиксация курсора выполняется нажатием левой кнопки мыши или клавиши <Enter>.

При указании плоского или прямолинейного объекта и поверхности вращения измеряется угол между объектом и осью вращения, при указании двух поверхностей вращения — угол между осями вращения.

Значение угла будет вычислено и автоматически занесено в поле ввода на Панели свойств.

Смотрите также

Геометрический калькулятор

Меню геометрического калькулятора


Команда Расстояние между 2 объектами(меню геометрического калькулятора)

Команда Расстояние между 2 объектами
(меню геометрического калькулятора)

Позволяет снять значение расстояния между двумя указанными объектами.

Объектами могут являться координатные и вспомогательные оси и плоскости, грани, ребра, вершины, пространственные кривые и точки. Объекты можно указывать в любой комбинации. Если указана поверхность вращения, то объектом, от/до которого измеряется расстояние, является ось вращения; при указании двух поверхностей вращения измеряется межосевое расстояние.

Последовательно укажите курсором два объекта, значение расстояния между которыми нужно определить. Фиксация курсора выполняется нажатием левой кнопки мыши или клавиши <Enter>.

Значение расстояния будет вычислено и автоматически занесено в поле ввода на Панели свойств.

Смотрите также

Геометрический калькулятор

Меню геометрического калькулятора


Команда Длина ребра(меню геометрического калькулятора)

Команда Длина ребра
(меню геометрического калькулятора)

Позволяет снять значение длины указанного ребра, пространственной кривой или кривой в эскизе.

Наведите курсор на объект. После того, как объект подсветится и его пиктограмма появится рядом с курсором, нажмите левую кнопку мыши или клавишу <Enter>.

Значение длины будет вычислено и автоматически занесено в поле ввода на Панели свойств.

Смотрите также

Геометрический калькулятор

Меню геометрического калькулятора


Команда Радиус(меню геометрического калькулятора)

Команда Радиус
(меню геометрического калькулятора)

Позволяет снять значение радиуса указанного объекта.

Объектом может являться пространственная дуга, окружность или дуга в эскизе, круглое ребро, цилиндрическая или сферическая грань. Объект, который может быть указан для измерения, при наведении курсора подсвечивается, а его пиктограмма отображается рядом с курсором.

Укажите курсором объект, значение радиуса которого нужно определить. Фиксация курсора выполняется нажатием левой кнопки мыши или клавиши <Enter>.

Значение радиуса будет вычислено и автоматически занесено в поле ввода на Панели свойств.

Смотрите также

Геометрический калькулятор

Меню геометрического калькулятора


Команда Прямая, касательная к двум кривым

Позволяет построить прямую, касательную к двум объектам.

Для вызова команды нажмите кнопку Прямая, касательная к двум кривым на инструментальной панели Геометрия.

Укажите курсором первый и второй объекты, касательно к которым должна пройти прямая. На экране появятся фантомы всех возможных вариантов касательных.

Выберите нужный фантом мышью или с помощью кнопок Следующий объект и Предыдущий объект на Панели специального управления.

Затем зафиксируйте выбранную прямую, щелкнув по ней мышью или нажав кнопку Создать объект на Панели специального управления.

Построение прямой, касательной к двум кривым

Выбор стиля линии

Чтобы перейти к построению прямых, касательных к другим объектам, нажмите кнопку Выбор объекта на Панели специального управления, а затем последовательно укажите курсором два объекта.

Для выхода из команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие геометрические объекты


Команда Отрезок, касательный к двум кривым

Позволяет построить отрезок, касательный к двум кривым.

Для вызова команды нажмите кнопку Отрезок, касательный к двум кривым на инструментальной панели Геометрия.

Укажите первую и вторую кривые, касательно к которым должен пройти отрезок.

По умолчанию система предлагает построение отрезков с концами в точках касания. При необходимости вы можете ввести нужное значение длины отрезка в соответствующее поле на Панели свойств.

На экране будут показаны фантомы всех вариантов отрезков, касательных к указанным кривым.

Выберите нужный вариант отрезка мышью или с помощью кнопок Следующий объект и Предыдущий объект на Панели специального управления.

Затем зафиксируйте выбранный отрезок, щелкнув по нему мышью или нажав кнопку Создать объект на Панели специального управления.

Построение отрезка, касательного к двум кривым

Выбор стиля линии

Для выхода из команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие геометрические объекты


Команда Касательная прямая через внешнюю точку

Позволяет построить прямую, касательную к другому объекту и проходящей через произвольную точку, не принадлежащую этому объекту.

Для вызова команды нажмите кнопку Касательная прямая через внешнюю точку на инструментальной панели Геометрия.

Укажите курсором объект, касательно к которому должна пройти прямая. Затем задайте точку, через которую должна пройти создаваемая прямая.

На экране появятся фантомы всех вариантов прямых, касательных к объекту и проходящих через заданную точку.

Выберите нужный фантом мышью или с помощью кнопок Следующий объект и Предыдущий объект на Панели специального управления.

Затем зафиксируйте выбранную прямую, щелкнув по ней мышью или нажав кнопку Создать объект на Панели специального управления.

Построение касательной через внешнюю точку

Чтобы перейти к построению линий, касательных к другому объекту, нажмите кнопку Выбор объекта на Панели специального управления, а затем укажите курсором новый объект.

Для выхода из команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие геометрические объекты


Команда Касательная прямая через точку кривой

Позволяет построить прямую, касательную к другому объекту и проходящую через указанную точку на этом объекте.

Для вызова команды нажмите кнопку Касательная прямая через точку кривой на инструментальной панели Геометрия.

Доступно два способа построения касательной к объекту:

– задание точки касания,

– задание угла наклона касательной.

Укажите объект, касательно к которому должна пройти прямая.

Если известна точка касания, задайте ее.

Зафиксируйте фантом касательной, щелкнув по нему мышью или нажав кнопку Создать объект на Панели специального управления.

Построение касательной заданием точки касания

Если известен угол наклона касательной (угол между прямой и осью абсцисс текущей системы координат), введите его в поле Угол на Панели свойств.

После этого на экране появятся фантомы всех возможных вариантов прямых, касательных к указанному объекту и расположенных под заданным углом.

Выберите нужный фантом мышью или с помощью кнопок Следующий объект и Предыдущий объект на Панели специального управления.

Затем зафиксируйте выбранную прямую, щелкнув по ней мышью или нажав кнопку Создать объект на Панели специального управления.

Построение касательной заданием угла ее наклона

Чтобы перейти к построению прямых, касательных к другому объекту, нажмите кнопку Выбор объекта на Панели специального управления, а затем укажите курсором новый объект.

Для выхода из команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие геометрические объекты


Команда Касательный отрезок через внешнюю точку

Позволяет построить отрезок, касательный к другому объекту.

Для вызова команды нажмите кнопку Касательный отрезок через внешнюю точку на инструментальной панели Геометрия.

Укажите кривую, касательно к которой должен пройти отрезок. Затем укажите начальную точку отрезка т1.

По умолчанию конечной точкой отрезка является точка касания. Если необходимо, вы можете изменить длину отрезка, введя нужное значение в соответствующее поле Панели свойств.

На экране появятся фантомы всех вариантов отрезков, касательных к выбранному объекту и проходящих через заданную точку.

Выберите нужный фантом мышью или с помощью кнопок Следующий объект и Предыдущий объект на Панели специального управления.

Затем зафиксируйте выбранный фантом, щелкнув по нему мышью или нажав кнопку Создать объект на Панели специального управления.

Построение касательного отрезка

Выбор стиля линии

Можно построить несколько отрезков касательных к другому объекту через внешнюю точку, не выходя из команды.

Вы можете построить несколько отрезков одинаковой длины, касательных к одному и тому же объекту. Для этого действуйте следующим образом. Указав объект, введите в поле Длина нужное значение и нажмите кнопку Запомнить состояние на Панели специального управления. Затем последовательно постройте нужное количество отрезков, указывая их начальные точки.

Подробнее о запоминании параметров...

Для выхода из команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие геометрические объекты


Команда Касательный отрезок через точку кривой

Позволяет построить один или несколько отрезков, касательных к другим (базовым) объектам и проходящих через указанные точки этих объектов.

Для вызова команды нажмите кнопку Касательный отрезок через точку кривой на инструментальной панели Геометрия.

Укажите объект, касательно к которому должен пройти отрезок. На экране появится фантом касательной.

– Если известно положение точки касания, задайте ее.

При этом значение угла наклона и координаты точки т2 касательного отрезка определятся автоматически.

Построение касательного отрезка заданием точки касания

– Если известен угол наклона касательного отрезка (угол между ним и осью абсцисс текущей системы координат), введите его в поле Угол на Панели свойств.

После ввода значения угла отображаются фантомы всех вариантов касательных, расположенных под заданным углом. Выберите подходящий вариант касательной. Для этого подведите курсор к нужному фантому. После того, как соответствующая ему точка касания появится на экране, зафиксируйте ее щелчком мыши.

Построение касательного отрезка заданием угла его наклона

Укажите точку т1, определяющую длину отрезка. Если известна длина касательного отрезка, то введите ее значение в поле Длина на Панели свойств.

Для точного позиционирования курсора воспользуйтесь меню геометрического калькулятора на Панели свойств или привязками.

Выбор стиля линии

По умолчанию включено автосоздание объектов. В этом случае отрезок фиксируется после задания минимального набора параметров, например, точки касания и длины отрезка.

Если автосоздание объектов отключено, то чтобы зафиксировать появившийся фантом касательного отрезка, нажмите кнопку Создать объект на Панели специального управления.

Для выхода из команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие геометрические объекты


Команда Сохранить таблицу в файл...

Позволяет сохранить текущую таблицу в специальном формате в файл *.tbl.

Для вызова команды нажмите кнопку Сохранить таблицу в файл или выберите ее название из меню Файл.

Таблицы, хранящиеся в файлах *.tbl, могут впоследствии использоваться для вставки в графические и текстовые документы, а также при создании таблиц основных надписей.


Команда Редактировать размещение

Позволяет отредактировать положение текста или таблицы в графическом документе.

Для вызова команды дважды щелкните мышью на тексте (таблице) и выберите название команды из контекстного меню.

На Панели свойств появятся элементы управления размещением объекта.

Задав новое положение текста (таблицы) нажмите кнопку Создать объект на Панели специального управления.

Объект будет удален со старого места и помещен на новое с учетом введенных параметров.


Команда Авторазмещение технических требований

Позволяет автоматически разместить технические требования на листе чертежа.

Эту команду можно вызвать из контекстного меню на поле технических требований.

При авторазмещении ширина технических требований равна ширине основной надписи (с отступом слева и справа по 5 мм). Первая их страница размещается над основной надписью. Если высота листа не позволяет разместить технические требования в одну колонку, формируются последующие страницы технических требований, расположенные слева от основной надписи.

В зависимости от настройки параметров технических требований умолчательным местом расположения технических требований может являться первый лист или последние листы чертежа.

Смотрите также

Позиционирование технических требований


Команда Технические требования – Размещение

Позволяет нужным образом разместить технические требования на листе чертежа.

Команда недоступна, если отсутствует текст технических требований (его можно создать с помощью команды Технические требования — Ввод.

Вокруг текста технических требований появляется прямоугольная габаритная рамка. Если подвести курсор к вертикальным или горизонтальным границам рамки либо к ее углам, он изменит свою форму. Зафиксируйте курсор в этот момент, нажав левую кнопку мыши, и перетаскивайте границу или угол рамки в нужное место, удерживая кнопку мыши нажатой. После того как рамка примет нужный размер, отпустите левую кнопку мыши.

Если при изменении размера рамки текст перестал умещаться внутри нее, автоматически будет создана новая рамка (новая страница технических требований), в которую будет перенесен оставшийся текст. Если затем рамку увеличить до нужного размера, то весь текст вновь будет размещен внутри нее, а дополнительные рамки — удалены. Таким образом, вы можете разбить технические требования на несколько страниц и разместить каждую из них в нужном месте.

Для точного изменения границ текущей страницы (на которой находится курсор) вызовите из контекстного меню команду Позиционировать. На экране появится диалог с координатами всех границ текущей страницы, в котором вы можете задать требуемые значения.

Если нужно просто переместить технические требования на новое место, не изменяя их габаритов и не разбивая на несколько страниц, поместите курсор внутри рамки. Когда он примет форму четырех стрелок, нажмите левую кнопку мыши, и, не отпуская кнопку, «перетащите» рамку в нужное место. После достижения нужного расположения отпустите кнопку мыши.

Завершить работу в режиме размещения технических требований можно, нажав клавишу <Esc>.

Смотрите также

Позиционирование технических требований


Команда Позиционировать...

Позволяет точно расположить границы текущей страницы технических требований (над которой находился курсор при вызове команды) на листе чертежа.

После вызова команды на экране появляется диалог, в котором нужно ввести нужные значения.

Смотрите также

Команда Технические требования — Размещение


Команда Технические требования – Ввод

Переключает систему в режим создания и редактирования технических требований.

Созданный текст можно затем разместить в нужном месте листа чертежа, используя команду Технические требования — Размещение.


Команда Закрыть — Технические требования

Позволяет закрыть текущее окно редактирования технических требований.

В том случае, если во время сеанса работы в технические требования были внесены какие-либо изменения и вы не сохраняли их, на экране появится запрос о сохранении технических требований. Сохранение производится в документе (аналогично команде Файл — Сохранить — В документ). При закрытии окна без сохранения технических требований все внесенные в них изменения будут утрачены.

Чтобы закрыть окно редактирования технических требований, можно также нажать системную кнопку Закрыть в правом верхнем углу окна.

Если требуется сохранить текст технических требований и весь документ, используйте команду Файл — Сохранить — С документом в файл.


Команда Файл...

Позволяет вставить блок текста — содержимое внешнего файла *.txt или файла в формате текстового документа КОМПАС (*.kdw) в текущий документ, начиная с текущей позиции курсора.

Для вызова команды нажмите кнопку Загрузить блок или выберите ее название из меню Вставка.

После вызова команды на экран выводится диалог выбора нужного файла.

Завершив выбор нужного файла, нажмите кнопку Открыть для вставки его содержимого в текущий документ. Для выхода из диалога без загрузки блока нажмите кнопку Отмена.


Команда Сохранить как — Текстовый документ...

Позволяет сохранить текст технических требований в отдельном файле *.txt или в файле текстового документа КОМПАС-3D (*.kdw).

После вызова команды на экране появляется диалог задания имени файла для записи.

После ввода или выбора нужного имени файла нажмите кнопку Сохранить для записи технических требований в этот файл. Для выхода из диалога без записи файла нажмите кнопку Отмена.


Команда Сохранить блок

Позволяет сохранить выделенный фрагмент текста в отдельном файле в формате текстового документа КОМПАС (*.kdw) или текстового файла (*.txt).

Для вызова команды нажмите кнопку Сохранить блок.

После вызова команды на экране появится диалог задания имени файла для записи блока.

После ввода или выбора нужного имени файла нажмите кнопку Сохранить для записи выделенного блока в этот файл. Для выхода из диалога без создания файла нажмите кнопку Отмена.


Команда Сохранить — В документ

Позволяет сохранить текст технических требований в документе, которому они принадлежат. При этом полное сохранение документа в файл на диске не производится.

Если вы хотите сохранить текст технических требований и весь документ, используйте команду Файл — Сохранить — С документом в файл.


Команда Проверка идентификаторов

Эта команда расположена в меню Сервис в режиме просмотра и редактирования таблицы основной надписи.

Она позволяет проконтролировать, в каких ячейках текущей таблицы не были введены числовые идентификаторы и какие ячейки имеют одинаковые идентификаторы.

После вызова команды на экране появляется диалог контроля идентификаторов таблицы. В нем условно (без соблюдения размеров ячеек и отображения текстов в них) показана текущая таблица основной надписи. В ней розовым цветом отмечены ячейки, для которых не задан идентификатор, а сиреневым — ячейки с одинаковыми идентификаторами.

Вообще говоря, в корректно сформированной таблице основной надписи не может быть ячеек без идентификаторов (не считая уже заполненных ячеек, в которые пользователю не нужно вводить данные) и ячеек с одинаковыми идентификаторами.

Редактирование ячеек (в том числе изменение их формата) в диалоге контроля невозможно. Для исправления идентификаторов запомните ячейки, которые требуется отредактировать, выйдите из диалога и измените расширенный формат нужных ячеек. Вновь вызовите диалог контроля и убедитесь, что «розовые» и «сиреневые» ячейки в таблице отсутствуют.


Стиль текста

Управление стилем текста текущего или выделенных абзацев производится с помощью элементов Панели свойств или инструментальной панели Форматирование.

В поле Стиль текста отображается название текущего стиля текста, т.е. стиля, примененного к абзацу, в котором находится курсор, или к нескольким выделенным абзацам.

Если выделено несколько абзацев с различными стилями, поле Стиль текста пусто.

Если параметры абзаца или шрифта в текущем или выделенных абзацах отличаются от установленных в стиле, то перед названием стиля отображается «звездочка». Чтобы привести параметры текста к стилевым, следует нажать комбинацию клавиш <Ctrl> + <Пробел> или повторно применить к абзацу (абзацам) прежний стиль.

Чтобы применить к тексту один из системных стилей, разверните список стилей, нажав кнопку со стрелкой в правой части поля Стиль текста, и выберите нужный стиль.

Чтобы применить к тексту стиль из библиотеки или создать и использовать в документе новый стиль, выберите в списке строку Другой стиль... или нажмите кнопку Стиль текста. На экране появится диалог выбора стиля текста.

Поле Стиль текста присутствует на инструментальной панели Форматирование, если она расположена горизонтально.


Команда Ввод текста

Позволяет создать текстовую надпись в чертеже или фрагменте. Каждая надпись может состоять из произвольного количества строк.

Для вызова команды нажмите кнопку Ввод текста на инструментальной панели Обозначения.

После вызова команды КОМПАС переключается в режим работы с текстом. При этом изменяются количество и названия команд главного меню, а также состав Компактной панели.

С помощью группы переключателей Размещение выберите расположение текста относительно точки привязки.

В поле Угол можно ввести угол наклона строк текста к оси Х системы координат текущего вида.

Если требуется зеркально отразить текст надписи внутри ее габаритного прямоугольника, включите опцию Зеркальное отражение. При зеркальном отражении текста положение точки привязки надписи не изменяется.

Укажите точку привязки текста.

Введите нужное количество строк, заканчивая набор каждой из них нажатием клавиши <Enter>.

Пример текстовой надписи на чертеже

Вы можете изменить установленные по умолчанию параметры текста с помощью элементов управления, расположенных на вкладке Форматирование Панели свойств, а также вставить различные специальные объекты с помощью элементов вкладки Вставка.

Чтобы зафиксировать изображение, нажмите кнопку Создать объект на Панели специального управления.

Вы можете создать несколько надписей за один вызов команды Текст. Закончив ввод первой надписи, переместите курсор за пределы рамки ввода и нажмите левую кнопку мыши. Предыдущая надпись автоматически зафиксируется, а в указанном вами месте откроется новое поле ввода текста.

Вы можете изменить расположение текста, не прерывая команды. Для этого вызовите из контекстного меню команду Редактировать размещение. На Панели свойств появятся элементы Точка привязки, Угол и Размещение, и вы сможете задать нужное расположение текста.

Для выхода из режима ввода текста нажмите или кнопку Прервать команду на Панели специального управления клавишу <Esc>.

Смотрите также

Команда Ввод таблицы


Опция Зеркально отразить тексты

Позволяет определить, как будет выглядеть текст объекта после преобразования симметрии. При включенной опции текст будет отражен зеркально, при отключенной — останется в исходном виде.

Действие опции не распространяется на текст обозначений, выбранных для преобразования симметрии.


Опция Зеркальное отражение

Позволяет зеркально отразить текст надписи внутри ее габаритного прямоугольника. При этом положение точки привязки надписи не изменяется.


Поле Толщина стенки

Поле значения толщины стенки.

Вы можете ввести значение вручную или установить с помощью счетчика.

Изменение толщины немедленно отображается на фантоме в окне модели.


Переключатель Смещение 1

Позволяет сместить начальную границу базового объекта резьбы для сохранения глубины зенковки или высоты фаски/скругления.

Активизируйте переключатель Смещение 1 на Панели свойств.

Переключатель доступен, если включена опция Подгонка.


Опция Подгонка

Включение опции позволяет изменить геометрические параметры базового объекта резьбы в соответствии с номинальным диаметром и шагом резьбы, заданными в полях Диаметр резьбы и Шаг резьбы.

Включение/отключение «подгонки» возможно как в процессе создания или редактирования резьбы, так и вне его — с помощью команды Подгонка в контекстном меню резьбы, выделенной в Дереве модели.

Команда Подгонка недоступна в контекстном меню резьбы, если:

– диаметр базового объекта «подходит» под резьбу,

– документ-модель создан в КОМПАС-3D версии 14 SP1 или более ранней.

Подробнее об использовании подгонки...


Переключатель Смещение 2

Позволяет сместить конечную границу базового объекта резьбы для сохранения длины участка поверхности, на котором создается резьба.

Активизируйте переключатель Смещение 2 на Панели свойств.

Переключатель доступен, если включена опция Подгонка.


Команда Мозаика для текущего документа

Размещает все открытые окна активного документа таким образом, чтобы они прилегали друг к другу и все были видимыми.

Команда Мозаика для текущего документа доступна, если текущий документ открыт в нескольких окнах (открытие дополнительного окна производится командой Новое окно документа).

Вызов команды Мозаика для текущего документа отключает показ закладок документов (если он был включен), так как использование закладок возможно только при развернутых окнах документов.


Команда Переключиться на слой объекта

Эта команда доступна в контекстном меню на единственном выделенном объекте, расположенном не в текущем слое.

После вызова команды слой, в котором лежит выделенный объект, становится текущим.

Команда недоступна, если выделена «многослойная» вставка фрагмента или вставка вида.


Команда Допуск формы (документ-модель)

Команда Допуск формы
 (документ-модель)

Позволяет создать в модели обозначение допуска формы и расположения поверхности. Обозначение допуска может быть проставлено к следующим объектам:

– грань тела или поверхности,

– координатная плоскость,

– вспомогательная плоскость,

– ребро тела или поверхности,

– сегмент пространственной ломаной,

– вспомогательная ось,

– размер,

– обозначение.

Пример

Для вызова команды нажмите кнопку Допуск формы на инструментальной панели Элементы оформления.

Укажите обозначаемый объект.

Укажите точку, определяющую положение рамки. По умолчанию в выбранную точку помещается левый нижний угол рамки. При этом в списке Базовая точка на Панели свойств выбран вариант Слева внизу. Чтобы изменить положение рамки относительно точки вставки, разверните указанный список и выберите нужную строку.

Чтобы рамка была расположена вертикально, включите опцию Вертикально на Панели свойств.

На экране появляется фантом обозначения.

Вы можете сменить базовую плоскость обозначения с помощью списка Базовая плоскость на вкладке Знак Панели свойств. Список доступен, если указаны точка, определяющая положение рамки, и точка начала одного ответвления.

Кроме того, вы можете сместить плоскость обозначения параллельно самой себе, используя элемент управления Положение.

Если в качестве обозначаемого объекта выбран размер или условное обозначение, то обозначение допуска проставляется в плоскости этого объекта. Изменение положения плоскости обозначения невозможно.

Создание таблицы допуска

Чтобы создать ответвление со стрелкой или треугольником, нажмите соответствующую кнопку на Панели специального управления и укажите начальную точку ответвления в плоскости обозначения. Конечной точкой всех ответвлений является базовая точка (точка рамки, выбранная в списке Базовая точка).

Чтобы завершить формирование ответвления, отожмите соответствующую кнопку на Панели специального управления.

Подробнее о добавлении и удалении ответвлений...

Для создания следующего ответвления снова нажмите нужную кнопку.

Кнопка Редактировать точки на Панели специального управления позволяет изменить конфигурацию ответвлений. После ее нажатия эти точки отображаются в виде черных квадратиков и кружков. Подведите курсор к любой характерной точке. Форма курсора изменится — он превратится в четырехстороннюю стрелку. Измените положение характерных точек, «перетаскивая» их мышью.

Для выхода из режима редактирования точек отожмите кнопку Редактировать точки.

Чтобы зафиксировать обозначение, нажмите кнопку Создать объект.

Пример простановки допуска формы и расположения поверхности

Смотрите также

Другие элементы оформления


Команда Ответвление со стрелкой

Позволяет сформировать соединительную линию между таблицей обозначения допуска и изображением поверхности. Созданная соединительная линия будет оканчиваться стрелкой.


Команда Ответвление с треугольником

Позволяет сформировать соединительную линию между таблицей обозначения допуска и изображением поверхности. Созданная соединительная линия будет оканчиваться треугольником.


Таблица допуска

Позволяет сформировать таблицу допуска в полуавтоматическом режиме.

После вызова команды на экране появится диалог создания таблицы, в котором можно выбрать нужные параметры для ввода в ячейки.


Вертикальное расположение

Опция, включение которой означает, что таблица допуска будет расположена вертикально. Положение базовой точки таблицы при этом не изменяется.


Панель свойств в текстовом режиме

Во время работы с объектами чертежа, содержащими текст, например, при заполнении основной надписи чертежа, текстовой части объекта спецификации, редактировании надписи вида, на Панели свойств появляются элементы настройки параметров текста.

В зависимости от типа редактируемого объекта Панель свойств может содержать следующие вкладки:

– Надпись вида — вкладка позволяет управлять составом надписи вида (включать/исключать обозначение, номер листа, зоны и т.п.), присутствует на Панели свойств при редактировании надписи вида,

– Формат — вкладка позволяет задать форматирование текста (выбрать шрифт, настроить параметры абзаца и т.п.),

– Вставка — вкладка позволяет вставить в документ различные объекты, например, текстовые шаблоны, спецзнаки, символы, фрагменты и т.п.,

– Таблица — вкладка позволяет управлять конфигурацией таблицы и форматировать ее ячейки,

– Модели — вкладка позволяет указать модель для синхронизации основной надписи,

– Параметры — вкладка позволяет задать параметры синхронизации модели с данными основной надписи. Подробнее о настройке параметров синхронизации...

Вкладки Модели и Параметры присутствуют на Панели свойств при заполнении основной надписи чертежа, содержащего ассоциативные виды модели.


Команда Прозрачность — N%

Позволяет управлять прозрачностью «плавающих» окон.

Доступны следующие степени прозрачности:

– 0%;

– 20%;

– 40%;

– 60%;

– 80%.

После указания степени прозрачности рядом с выбранным значением в меню появляется «галочка».

При вызове команды Прозрачность — 0% окно отображается непрозрачным.

На ПК под управлением Microsoft Windows XP команда Прозрачность отсутствует в контекстном меню заголовка «плавающих» окон Технические требования и Дерево документа. Окна Технические требования и Дерево документа отображаются непрозрачными.


Команда Типы загрузки — Упрощенный

Позволяет применить к выбранному компоненту или компонентам, загруженным полностью, тип загрузки — Упрощенный.

Команда может быть вызвана нажатием кнопки на инструментальной панели Редактирование сборки или из контекстного меню выбранных компонентов.

Доступна, если среди выбранных есть компоненты с типом загрузки Полный.

Чтобы тип загрузки Пустой или Габарит сменить на Упрощенный, назначьте сначала этим компонентам тип загрузки Полный.

После вызова команды вид выбранных компонентов, которые имели тип загрузки Полный, изменяется:

– в окне модели снижается точность отрисовки компонентов и отменяется отображение каркаса, если оно было включено,

– пиктограммы компонентов в Дереве построения отмечаются значком «облако»,

– становится недоступен просмотр состава компонентов в Дереве построения.

Особенности компонентов с неполной загрузкой

Подробнее о выборе типа загрузки компонента...

Смотрите также

Типы загрузки сборки


Команда Усечение поверхности

Позволяет усечь поверхность при помощи объектов, лежащих на этой поверхности или пересекающих ее. Команда доступна, если в модели есть хотя бы одна поверхность.

Требования к объектам

Усечение поверхности при помощи другой поверхности: а) объекты до выполнения операции, б) объекты после их указания, в) результат усечения
а) | б) | в)

Пример

Для вызова команды нажмите кнопку Усечение поверхности на инструментальной панели Поверхности или выберите ее название из меню Операции — Поверхность.

Укажите усекаемую поверхность.

Выбор объектов в окне модели

Выбор объектов в Дереве построения

Усекаемую поверхность можно указать и перед вызовом команды.

Чтобы задать объект, по линии пересечения с которым должна быть усечена поверхность, активизируйте переключатель Секущий объект.

Укажите секущие объекты в окне модели или в Дереве построения.

Если требуется разбить поверхность по изопараметрической кривой, то эту кривую можно построить, не выходя из процесса разбиения. Для этого нажмите кнопку Изопараметрическая кривая на Панели специального управления.

Усекаемая поверхность и секущий объект подсвечиваются, а их названия появляются в полях рядом с переключателями Поверхности и Секущий объект. Если выбранный объект состоит из нескольких граней или сегментов кривых, то в полях отображается их количество.

На линии пересечения объектов отображается стрелка, указывающая направление усечения.

Переключатель Сменить направление позволяет выбрать для удаления другую часть усекаемой поверхности.

Чтобы отказаться от использования объекта в качестве усекаемого или секущего объекта, активизируйте переключатель Поверхность или Секущий объект, соответственно, и укажите объект в окне модели повторно. Выбор с объекта будет снят.

Чтобы сменить объекты, нажмите кнопку Указать заново на Панели специального управления и повторите выбор объектов.

Наименование усеченной поверхности можно изменить на вкладке Свойства Панели свойств.

Чтобы завершить создание усеченной поверхности, нажмите кнопку Создать объект на Панели специального управления.

Усеченная поверхность появляется в окне модели, а соответствующая ей пиктограмма — в Дереве построения.

Если в качестве усекаемой поверхности было указано целое тело или его грани, то в результате усечения целостность тела может быть нарушена.

Прервать команду можно, нажав кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Другие команды создания поверхностей


Команда Азбука КОМПАС-График

Позволяет запустить интерактивное учебное пособие «Азбука КОМПАС-График» — набор упражнений для самостоятельного изучения основ работы в КОМПАС-График. Учебное пособие реализовано в виде файла КОМПАС-2D.chm, поставляемого вместе с системой КОМПАС-3D.

Для вызова команды выберите ее название из меню Справка.

Если учебное пособие не установлено, его запуск будет невозможен — на экране появится сообщение об этом.


Команда Азбука КОМПАС-3D

Позволяет запустить интерактивное учебное пособие «Азбука КОМПАС-3D» — набор упражнений для самостоятельного изучения основ работы в КОМПАС-3D. Учебное пособие реализовано в виде файла КОМПАС-3D.chm, поставляемого вместе с системой КОМПАС-3D.

Для вызова команды выберите ее название из меню Справка.

Если учебное пособие не установлено, его запуск будет невозможен — на экране появится сообщение об этом.


Команда Значки (меню Менеджера)

Команда Значки
(меню Менеджера)

Включает отображение элементов в разделе в виде значков.


Команда Закрыть (меню Менеджера)

Команда Закрыть
(меню Менеджера)

Позволяет отключить текущую библиотеку.


Команда Копировать (меню Менеджера)

Команда Копировать
(меню Менеджера)

Копирует выделенную модель (фрагмент) или раздел в буфер обмена.

Предыдущее содержимое буфера обмена будет удалено.

Раздел помещается в буфер обмена, сохраняя структуру подразделов.


Команда Создать раздел (меню Менеджера)

Команда Создать раздел
(меню Менеджера)

Позволяет создать новый раздел (подраздел) в библиотеке или в Менеджере библиотек.

После вызова команды на экране появляется окно, в котором требуется ввести наименование нового раздела. Ввод названия является обязательным.


Команда Добавить (меню Менеджера)

Команда Добавить
(меню Менеджера)

Позволяет добавить библиотеку фрагментов или библиотеку моделей в текущий раздел Менеджера библиотек или фрагмент (модель) в библиотеку.

При добавлении библиотеки на экране появляется диалог выбора файлов. Укажите нужный тип файла, его имя и нажмите кнопку Открыть диалога. Чтобы отказаться от добавления библиотеки, нажмите кнопку Отмена.

При добавлении фрагмента или модели на экране появляется диалог ввода имени элемента в библиотеке. В поле диалога необходимо ввести имя нового фрагмента в виде любого набора символов.

Новый фрагмент (модель) записывается в текущий раздел библиотеки. При этом открывается новое окно фрагмента (модели), в котором можно создать, отредактировать и сохранить документ. Имена нового фрагмента (модели) и раздела, в который он добавляется, «замораживаются» — их нельзя удалить, вырезать, переименовать до сохранения документа. Фрагмент (модель) при создании и редактировании невозможно также вставить в другой активный документ.

К системе КОМПАС-3D одновременно может быть подключено не более 25 библиотек.


Команда Вырезать (меню Менеджера)

Команда Вырезать
(меню Менеджера)

Удаляет выделенную модель (фрагмент) из библиотеки или библиотеку из состава Менеджера и помещает в буфер обмена Менеджера библиотек (Clipboard).

Предыдущее содержимое буфера обмена будет удалено.


Команда Вырезать раздел (меню Менеджера)

Команда Вырезать раздел
(меню Менеджера)

Удаляет выделенный раздел библиотеки и помещает в буфер обмена Менеджера библиотек (Clipboard).

Предыдущее содержимое буфера обмена будет удалено.

Раздел помещается в буфер обмена, сохраняя структуру подразделов.


Команда Удалить (меню Менеджера)

Команда Удалить
(меню Менеджера)

Удаляет выделенную модель (фрагмент) из состава библиотеки или библиотеку из состава Менеджера.

После удаления восстановление модели (фрагмента) или раздела невозможно.


Команда Удалить раздел (меню Менеджера)

Команда Удалить раздел
(меню Менеджера)

Удаляет выделенный раздел из состава Менеджера библиотек.

Раздел Менеджера удаляется вместе со всеми своими подразделами.

После удаления восстановление раздела невозможно.

Команда доступна только для разделов, не содержащих подключенные библиотеки.


Команда Редактировать (меню Менеджера)

Команда Редактировать
(меню Менеджера)

Открывает новое окно КОМПАС-3D и загружает в него выделенный фрагмент или выделенную модель для редактирования.

При этом меняется цвет «иконки» раздела, в который входит редактируемая модель (фрагмент). Во время редактирования модель (фрагмент) не может быть удалена, вырезана, переименована или вставлена в документ.


Команда Вставить (меню Менеджера)

Команда Вставить
(меню Менеджера)

Вставляет копию содержимого буфера обмена Менеджера библиотек (Clipboard) в текущий раздел библиотеки или Менеджера библиотек.

Если буфер обмена пуст, команда будет недоступна.


Команда Список (меню Менеджера)

Команда Список
(меню Менеджера)

Включает отображение элементов в разделе в виде списка без значков.


Команда Вид — Комментарий (меню Менеджера)

Команда Вид — Комментарий
(меню Менеджера)

Управляет отображением на вкладке области комментария.

Если слева от этой команды в меню стоит метка, область комментария находится на экране.


Команда Вид – Папки (меню Менеджера)

Команда Вид – Папки
(меню Менеджера)

Управляет отображением структуры библиотеки и Менеджера библиотек.

Если слева от этой команды в меню стоит метка, структура библиотеки или Менеджера отображается на экране.


Команда Окно просмотра (меню Менеджера)

Команда Окно просмотра
(меню Менеджера)

Управляет отображением окна просмотра.

Если слева от этой команды в меню стоит метка, окно просмотра находится на экране.


Команда Стиль...

Позволяет назначить или изменить стиль текущего абзаца или набираемого заново текста.

Для вызова команды нажмите кнопку Стиль текста или выберите ее имя из меню Формат.

После вызова команды на экран выводится диалог выбора стилей.


Тип заливки — Угловая (контекстное меню команды Заливка)

Тип заливки — Угловая
(контекстное меню команды Заливка)

Позволяет сделать текущим тип заливки Угловая при построении или редактировании.

Для вызова команды выберите название Тип заливки — Угловая из контекстного меню команды Заливка.

Если при вызове команды слева от названия находится «галочка», это свидетельствует о том, что данный тип заливки — текущий.

После вызова команды укажите на экране область заливки.


Тип заливки — Радиальная (контекстное меню команды Заливка)

Тип заливки — Радиальная
(контекстное меню команды Заливка)

Позволяет сделать текущим тип заливки Радиальная при построении или редактировании.

Для вызова команды выберите название Тип заливки — Радиальная из контекстного меню команды Заливка.

Если при вызове команды слева от названия находится «галочка», это свидетельствует о том, что данный тип заливки — текущий.

После вызова команды укажите на экране область заливки.


Тип заливки — Коническая (контекстное меню команды Заливка)

Тип заливки — Коническая
(контекстное меню команды Заливка)

Позволяет сделать текущим тип заливки Коническая при построении или редактировании.

Для вызова команды выберите название Тип заливки — Коническая из контекстного меню команды Заливка.

Если при вызове команды слева от названия находится «галочка», это свидетельствует о том, что данный тип заливки — текущий.

После вызова команды укажите на экране область заливки.


Тип заливки — Цилиндрическая (контекстное меню команды Заливка)

Тип заливки — Цилиндрическая
(контекстное меню команды Заливка)

Позволяет сделать текущим тип заливки Цилиндрическая при построении или редактировании.

Для вызова команды выберите название Тип заливки — Цилиндрическая из контекстного меню команды Заливка.

Если при вызове команды слева от названия находится «галочка», это свидетельствует о том, что данный тип заливки — текущий.

После вызова команды укажите на экране область заливки.


Тип заливки — Линейная (контекстное меню команды Заливка)

Тип заливки — Линейная
(контекстное меню команды Заливка)

Позволяет сделать текущим тип заливки Линейная при построении или редактировании.

Для вызова команды выберите название Тип заливки — Линейная из контекстного меню команды Заливка.

Если при вызове команды слева от названия находится «галочка», это свидетельствует о том, что данный тип заливки — текущий.

После вызова команды укажите на экране область заливки.


Тип заливки — Одноцветная (контекстное меню команды Заливка)

Тип заливки — Одноцветная
(контекстное меню команды Заливка)

Позволяет сделать текущим тип заливки Одноцветная при построении или редактировании.

Для вызова команды выберите название Тип заливки — Одноцветная из контекстного меню команды Заливка.

Если при вызове команды слева от названия находится «галочка», это свидетельствует о том, что данный тип заливки — текущий.

После вызова команды укажите на экране область заливки.


Тип заливки — Квадратная (контекстное меню команды Заливка)

Тип заливки — Квадратная
(контекстное меню команды Заливка)

Позволяет сделать текущим тип заливки Квадратная при построении или редактировании.

Для вызова команды выберите название Тип заливки — Квадратная из контекстного меню команды Заливка.

Если при вызове команды слева от названия находится «галочка», это свидетельствует о том, что данный тип заливки — текущий.

После вызова команды укажите на экране область заливки.


Команда По оси X

Позволяет построить линию построения вершины сплайна или ломаной параллельно оси Х.

Смотрите также

Построение по осям


Команда По оси Y

Позволяет построить линию построения вершины сплайна или ломаной параллельно оси Y.

Смотрите также

Построение по осям


Команда По оси Z

Позволяет построить линию построения вершины сплайна или ломаной параллельно оси Z.

Смотрите также

Построение по осям


Команда Параллельно объекту

Позволяет построить линию построения вершины пространственного сплайна или ломаной параллельно существующему в окне модели прямолинейному объекту (ребру, оси и т.п.) или вектору.

Подробнее...

Смотрите также

Другие способы построения


Команда Перпендикулярно объекту

Позволяет построить линию построения вершины пространственного сплайна или ломаной перпендикулярно существующему в окне модели плоскому или прямолинейному объекту: плоскости, грани, поверхности, ребру, оси и т.п.

Подробнее...

Смотрите также

Другие способы построения


Команда По точкам

Позволяет построить пространственный сплайн или ломаную способом по точкам.

Подробнее...

Смотрите также

Другие способы построения


Команда Удалить построение точки

Эта команда доступна, если положение текущей вершины сплайна или ломаной было задано точкой, построенной с помощью команды Точка. Команда позволяет удалить построение этой точки. После вызова команды будет удалена связь вершины с построенной точкой.


Тип марки

Группа переключателей, позволяющая выбрать тип марки обозначения координационной оси. При активизации переключателя координационная ось отрисовывается с марками в виде простой или двойной окружности.

Окружность.

Двойная окружность.

Для прямых и дуговых осей марка заданного типа отрисовывается с обоих концов координационной оси.


Команда Отменить выбор полюсов

Команда позволяет снять выделение со всех полюсов сетки. Доступна, если хотя бы один полюс является выделенным.

Смотрите также

Произвольное перемещение полюсов мышью


Оформление символов

Чтобы назначить или отменить курсивное начертание выделенного или набираемого заново текста, нажмите кнопку Курсив.

Чтобы назначить или отменить жирное начертание выделенного или набираемого заново текста, нажмите кнопку Полужирный.

Чтобы назначить или отменить подчеркивание выделенного или набираемого заново текста, нажмите кнопку Подчеркнутый.

Для изменения всех параметров шрифта используйте команду Формат — Шрифт.


Команда Десятичная система счисления

Позволяет выбрать в качестве единиц измерения углов градусы.

После вызова команды величины углов в полях Панели свойств отображаются в формате ХХ,ХХХ° с заданной точностью.


Команда Градусы, минуты, секунды

Позволяет выбрать в качестве единиц измерения углов градусы, минуты и секунды.

После вызова команды величины углов в полях Панели свойств отображаются в формате ХХ°ХХ'ХХ,ХХХ" с заданной точностью.

Обратите внимание на то, что значение угла с количеством секунд 59,999 округляется до минут. Например, величина 30°29'59,999", введенная в поле Панели свойств, превратится в 30°30'.


Команда Радианы

Позволяет выбрать в качестве единиц измерения углов радианы.

После вызова команды величины углов в полях Панели свойств отображаются в формате ХХ,ХХХ рад с заданной точностью.


Команда Выгрузить все библиотеки

Позволяет отключить от системы КОМПАС-3D все подключенные прикладные библиотеки. Библиотеки фрагментов (*.lfr) и библиотеки моделей (*.l3d) остаются подключенными. Их необходимо отключать непосредственно в Менеджере библиотек.

Если ни одна прикладная библиотека не подключена, команда Выгрузить все библиотеки недоступна.

Для отключения библиотек всех типов воспользуйтесь командой Отключить все библиотеки. Она доступна в контекстном меню списка библиотек в окне Менеджера библиотек.


Команда Обновить таблицу

Позволяет привести данные ассоциативного отчета, ассоциативной таблицы исполнений модели или ассоциативной таблицы отчета по массиву в актуальное состояние. Признаком неактуальности отчета/таблицы является перечеркивание таблицы.

Команда находится в контекстном меню выделенного в документе ассоциативного отчета/ассоциативной таблицы.

После вызова команды данные в отчете/таблице заменяются данными из документа-источника, а перечеркивание таблицы исчезает.

В чертеже обновить таблицу также можно при помощи команды Перестроить.


Команда Перечитать оформление(чертежа)

Команда Перечитать оформление
(чертежа)

Позволяет обновить оформление всех листов чертежа.

Команда Перечитать оформление находится в меню Сервис. Она доступна, если между оформлением, хранящимся в документе, и соответствующим ему оформлением в библиотеке *.lyt есть различия. Если различий нет, а также если отсутствует библиотека или оформление в ней (т.е. невозможно сравнить оформления), команда недоступна.

Вы можете обновить оформление отдельного листа чертежа. Для этого вместо команды Перечитать оформление вызовите из контекстного меню основной надписи нужного листа команду Изменить оформление и нажмите в появившемся диалоге кнопку Перечитать. Кроме того, перечитывание оформлений отдельных листов возможно в диалоге Менеджер документа: в списке листов выделите строку, соответствующую нужному листу, щелкните мышью в ячейке оформления и в появившемся диалоге нажмите кнопку Перечитать.

Смотрите также

Хранение в документе информации об используемом оформлении

Настройка обновления оформления


Команда Перечитать стили

Позволяет обновить стиль спецификации, входящий в текущее описание спецификации в чертеже, а также стили всех спецификаций на чертеже.

Команда Перечитать стили находится в меню Спецификации. Она доступна, если между стилями, хранящимися в документе, и соответствующими им стилями в библиотеках *.lyt есть различия. Если различий нет, а также если отсутствуют библиотеки или стили в них (т.е. невозможно сравнить стили), команда недоступна.

Вы можете обновить стиль отдельной спецификации на чертежа. Для этого вместо команды Перечитать стили вызовите из контекстного меню нужной спецификации команду Перечитать стиль.

Смотрите также

Хранение в документе информации об используемом стиле спецификации

Настройка обновления стиля


Команда Перечитать стиль

Позволяет обновить стиль документа-спецификации или стиль, входящий в текущее описание спецификации в графическом документе или документе модели.

Команда Перечитать стиль находится в меню Сервис. Она доступна, если между стилем, хранящимся в документе, и соответствующим ему стилем в библиотеке *.lyt есть различия. Если различий нет, а также если отсутствует библиотека или стиль в ней (т.е. невозможно сравнить стили), команда недоступна.

Если документ-спецификация содержит дополнительные листы, то их оформление обновляется при вызове для спецификации команды Сервис — Перечитать стиль.

Возможно также ручное обновление оформлений дополнительных листов в начале и/или в конце спецификации. Для этого вызовите диалог настройки дополнительных листов. Чтобы обновить оформление, выберите его в списке и нажмите кнопку Изменить, а затем в появившемся диалоге — кнопку Перечитать.

Смотрите также

Хранение в документе информации об используемом стиле спецификации

Настройка обновления стиля


Команда Перечитать стиль

Команда позволяет обновить стиль той спецификации на чертеже, из контекстного меню которой она была вызвана.

Смотрите также

Хранение в документе информации об используемом стиле спецификации

Настройка обновления стиля


Команда Перечитать оформление(текстового документа)

Команда Перечитать оформление
(текстового документа)

Позволяет обновить оформление всех листов текстового документа.

Команда Перечитать оформление находится в меню Сервис. Она доступна, если между оформлением, хранящимся в документе, и соответствующим ему оформлением в библиотеке *.lyt есть различия. Если различий нет, а также если отсутствует библиотека или оформление в ней (т.е. невозможно сравнить оформления), команда недоступна.

Вы можете обновить оформление не всех листов, а только первого, четных, нечетных, дополнительных в начале или дополнительных в конце. Для этого вместо команды Перечитать оформление используйте:

– Диалог настройки оформления — для первого, четных и нечетных листов. Чтобы обновить оформление, нажмите в диалоге кнопку Перечитать в группе Первый лист, Четный лист или Нечетный лист.

– Диалог настройки дополнительных листов — для дополнительных листов в начале или в конце документа. Чтобы обновить оформление, выберите его в списке, нажмите кнопку Изменить, а затем в появившемся диалоге — кнопку Перечитать.

Смотрите также

Хранение в документе информации об используемом оформлении

Настройка обновления оформления


Вставка надстрок и подстрок

Чтобы объявить выделенный или набираемый заново текст состоящим из основания с над- и подстрокой (высота шрифта основания увеличена и составляет около 150% от установленной высоты обычного текста), нажмите кнопку Вставить надстроку (увеличенной высоты) или вызовите команду Вставка — Над/Подстрока — Увеличенной высоты.

Чтобы объявить выделенный или набираемый заново текст состоящим из основания с над- и подстрокой (высота шрифта основания равна установленной высоте обычного текста), нажмите кнопку Вставить надстроку (нормальной высоты) или вызовите команду Вставка — Над/Подстрока — Нормальной высоты.

Для перехода между основанием, надстрокой и подстрокой используйте клавиши <←> и <→>.


Использовать цвет модели

Включите эту опцию, чтобы объект отображался цветом, заданным для объектов модели.

Если опция выключена, то доступен список Цвет и вы можете выбрать произвольный цвет для объекта.


Опция Использовать цвет детали

Опция, включение которой означает, что для отображения элемента или объекта будет использован цвет, установленный для детали.

При этом настройка собственного цвета элемента или объекта невозможна.


Использовать цвет источника

Включите эту опцию, чтобы объект отображался тем же цветом, что и его источник.

Если опция выключена, то доступен список Цвет и вы можете выбрать произвольный цвет для объекта.


Команда вызова внешней утилиты

Позволяет запустить внешний файл.

Подключение утилит — задание названия для команды вызова утилиты и указание файла для запуска — производится при настройке интерфейса. Подробнее...

Если после вызова команды запуск файла не происходит, проверьте правильность указания пути к этому файлу в диалоге создания пользовательских команд. Путь может оказаться неверным, например, если вы используете профиль, созданный на другом рабочем месте.


Команда Спецзнак...

Позволяет вставлять в текст (начиная с текущего положения курсора) специальные знаки, отсутствующие в обычных наборах шрифтов (знак диаметра, различные символы для технологических обозначений и т.д.).

Для вызова команды нажмите кнопку Вставить специальный знак или выберите ее название из меню Вставка.

После вызова команды на экран выводится диалог, в котором следует выбрать специальный знак для вставки в текст.

Если вы выбрали спецзнак, изображение которого связано с вводимыми символами (например, корень или подчеркивание) и ввели нужную текстовую часть, нажмите клавишу со стрелкой вправо для перехода к дальнейшему вводу обычного текста.


Команда Символ

Позволяет вставлять в текст (начиная с текущего положения курсора) символы, недоступные для ввода с клавиатуры.

Для вызова команды нажмите кнопку Вставить специальный символ или выберите ее имя из меню Вставка.

После вызова команды на экран выводится диалог, в котором следует выбрать нужный шрифт и символ из него для вставки в текст.


Команда Обнулить значение

Позволяет заменить содержимое всех ячеек выделенного столбца значением 0,0.


Кнопка Отображение структуры модели

Позволяет управлять способом представления информации в Дереве построения модели.

Кнопка Отображение структуры модели находится на инструментальной панели вкладки Построение в окне Дерево модели.

Если эта кнопка нажата, то в окне Дерева отображается структура модели, а если отжата, то — последовательность построения модели.


Команда Настроить столбцы/Дополнительно... (Окно переменных)

Команда Настроить столбцы/Дополнительно...
(Окно переменных)

Позволяет сформировать набор отображаемых столбцов таблицы Окна переменных и настроить их взаимное расположение. Команда Настроить столбцы вызывается из пункта меню Сервис Окна переменных, а команда Дополнительно... — из контекстного меню заголовка любого из столбцов.

После вызова команды на экране появляется диалог Настройка столбцов, позволяющий выполнить все необходимые действия.


Обход скруглением с одинаковым радиусом

Переключатель, позволяющий выбрать способ обхода угла в вершине скруглением.

Радиус скругления для всех линий мультилинии одинаковый.

По умолчанию радиус скругления равен 10.

Введите нужный радиус скругления в поле Радиус или установите с помощью счетчика.

Смотрите также

Способы обхода угла в вершине


Обход срезом

Переключатель, позволяющий выбрать обход угла в вершине срезом.

Смотрите также

Способы обхода угла в вершине


Обход скруглением

Переключатель, позволяющий выбрать способ обхода угла в вершине скруглением. Скругление выполняется радиусом эквидистанты.

Смотрите также

Способы обхода угла в вершине


Вертикальное расположение фигурной скобки

Переключатель, позволяющий создать фигурную скобку, расположенную вертикально.


Вертикальный размер

Переключатель, позволяющий создать размер с вертикально расположенной размерной линией.


Команда Вертикальная прямая

Позволяет построить вертикальную прямую.

Для вызова команды нажмите кнопку Вертикальная прямая на инструментальной панели Геометрия.

Укажите положение точки, через которую должна пройти прямая.

Для точного позиционирования курсора воспользуйтесь привязками или меню геометрического калькулятора для поля т на Панели свойств.

Простановка точек пересечений

Вертикальной считается прямая, параллельная оси ординат текущей системы координат. Поэтому если вы построите вертикальную прямую в виде, система координат которого повернута относительно абсолютной системы координат, эта прямая не будет параллельна вертикальным сторонам листа.

Для выхода из команды нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Другие геометрические объекты


Команда Настройка интерфейса...

Позволяет настроить интерфейс системы: состав инструментальных панелей, клавиатурные комбинации для вызова команд, отображение кнопок и другие параметры.


Команда Переменные

Позволяет включить или отключить отображение на экране окна работы с переменными.

Для вызова команды нажмите кнопку Переменные на панели Стандартная или выберите ее название из меню Вид — Панели инструментов.


Команда Свойства

Позволяет включить или отключить отображение на экране окна Свойства.

Для вызова команды нажмите кнопку Свойства на Стандартной панели или выберите ее название из меню Редактор.

В окне Свойства отображаются названия и значения свойств объектов, выделенных в модели, графическом документе или эскизе. Если выделенных объектов нет, то окно Свойства пусто.

В окне Свойства пользователь может просматривать и изменять свойства выделенных объектов, не прибегая к редактированию каждого из них в отдельности.

Примеры...

В графическом документе или эскизе во время работы команды Копировать свойства окно Свойства служит для просмотра копируемых свойств и включения/отключения копирования тех или иных свойств.

Смотрите также

Изменение свойств

Копирование свойств (в графическом документе)


Кнопка Группы компонентов

Служит для включения/отключения отображения на экране окна Группы компонентов. Это окно предназначено для работы с группами компонентов сборки, которые должны иметь одинаковые номера позиций.

Кнопка Группы компонентов находится на панели Спецификация.

Подробнее о компонентах с одним номером позиции...


Команда Панель свойств

Позволяет включить или отключить отображение на экране Панели свойств.


Команда Нумерация

Позволяет автоматически нумеровать объекты в графическом документе.

Команда Нумерация вызывается из меню Вид. После вызова команды на экране появляется окно Нумерация.

Чтобы назначить номер объекту, требуется добавить его в одну из групп нумерации.

Подробнее об Автоматической нумерации объектов...


Команда Проекционная связь

Позволяет включить или отключить проекционную связь выделенного ассоциативного вида (видов) с его опорным видом (видами).

Команда доступна для проекционных видов, видов по стрелке и видов, содержащих разрезы или сечения.

Если проекционная связь вида с его опорным видом выключена, то он может быть перемещен в любое место поля чертежа.

При включенной связи вид перемещается так, чтобы его проекционная связь с опорным видом не нарушалась.


Команда Технические требования

Позволяет включить или выключить показ окна Технические требования.

Команда может быть вызвана:

– из меню Вид;

– из контекстного меню в окне модели.


Команда Профили...

Вызывает диалог работы с профилями.

С помощью этого диалога вы можете сохранить сведения о текущей настройке конфигурации системы в файле профиля (*.pfl) или выбрать другой файл профиля и, следовательно, другой вариант настройки.

В комплект поставки КОМПАС-3D входят несколько готовых файлов профилей. Они расположены в подпапке Profiles главной папки системы.


Команда Использовать цвета объектов

Позволяет включить такой режим отображения объектов, при котором объекты во всех видах документа отображаются установленными для них цветами:

– линии отображаются цветами, установленными для них в диалоге настройки системы,

– заливки и штриховки отображаются цветами, установленными при их создании в КОМПАС-3D.

Данные цвета соответствуют отображению текущего вида, а также одноименному цвету вывода на печать.

Команда Использовать цвета объектов относится к командам программы просмотра. Чтобы использовать эту команду в КОМПАС-3D, добавьте ее в любое меню или на любую панель.


Команда Перечитать файл

Позволяет перечитать текущий документ.

Для вызова команды нажмите кнопку Перечитать файл.

После вызова команды произойдет «повторное открытие» текущего документа: система вновь обратится к хранящемуся на диске файлу и отобразит на экране его содержимое.

Это позволяет увидеть документ в его последней редакции, если редактирование было завершено после начала просмотра.

Команда Перечитать файл относится к командам программы просмотра. Чтобы использовать эту команду в КОМПАС-3D, добавьте ее в любое меню или на любую панель.


Команда Показать погашенные слои

Позволяет включить показ объектов, расположенных в погашенных слоях текущего графического документа.

Команда Показать погашенные слои относится к командам программы просмотра. Чтобы использовать эту команду в КОМПАС-3D, добавьте ее в любое меню или на любую панель.


Команда Показать погашенные виды

Позволяет включить показ объектов, расположенных в погашенных видах текущего чертежа.

Команда Показать погашенные виды относится к командам программы просмотра. Чтобы использовать эту команду в КОМПАС-3D, добавьте ее в любое меню или на любую панель.


Управление слоями

Управление слоями документа производится с помощью элементов панели Текущее состояние.

Кнопка Управление слоями выводит на экран Менеджер документа, в котором можно изменить параметры существующих слоев и создать новые слои.

Менеджер графического документа

Менеджер документа-модели

Поле Управление слоями служит для изменения состояния слоев и выбора текущего слоя.

Поле Управление слоями присутствует на Панели, если она расположена горизонтально.


Команда Стрелка взгляда

Позволяет построить стрелку, указывающую направление взгляда.

Для вызова команды нажмите кнопку Стрелка взгляда на инструментальной панели Обозначения.

Укажите начальную точку (острие) стрелки т1.

Укажите точку т2, определяющую направление стрелки.

Стрелку, расположенную строго вертикально или горизонтально, удобно создавать в режиме ортогонального черчения. Для его включения и выключения служит кнопка Ортогональное черчение на панели Текущее состояние, а также клавиша <F8>. Чтобы временно перейти в режим ортогонального черчения, нажмите и удерживайте клавишу <Shift>.

Простановка стрелки направления взгляда

Формирование текста обозначения стрелки взгляда.

Выбор из списка Стрелка вида стрелки взгляда.

Сразу после создания стрелки взгляда автоматически запускается команда создания нового вида. После выполнения команды в чертеже появится вид, обозначение которого будет ассоциативно связано с созданной стрелкой.

Вы можете отказаться от создания нового вида, нажав кнопку Прервать команду. Однако делать это не рекомендуется, поскольку ручное создание вида и формирование связи между его обозначением и обозначением стрелки займет дополнительное время. Кроме того, размещение вида по стрелке в отдельном виде позволяет быстро изменять масштаб изображения и делает более удобной компоновку чертежа.

При создании стрелки взгляда может автоматически создаваться гиперссылка, связывающая обозначение с вновь созданным видом.


Команда Подобрать масштаб

Позволяет автоматически подобрать такой масштаб из стандартного ряда, при котором все виды, указанные для построения, полностью умещаются на чертеже выбранного формата. При подборе коэффициента масштабирования учитываются области чертежа, занятые основной надписью и другими элементами оформления.


Группа переключателей Режим

Позволяет выбрать режим отображения рисунка — полностью или частично.

Группа Режим присутствует на Панели свойств:

– при выполнении команды Обрезать; в этом случае группа доступна всегда1,

– при редактировании вставки рисунка; в этом случае группа доступна, если для рисунка уже указана граница обрезки, т.е. выполнена команда Обрезать.

  1. За исключением случаев, когда в результате редактирования в графическом редакторе площадь рисунка изменилась так, что граница обрезки оказалась за его пределами.


Команда Показывать часть

Позволяет сменить режим отображения рисунка Показывать полностью на режим отображения Показывать часть.

Команда доступна в контекстном меню при выполнении обрезки рисунка. Если команда отмечена «галочкой», это означает, что режим Показывать часть уже включен.

Для смены режима отображения рисунка можно также использовать группу переключателей Режим на Панели свойств.


Команда Показывать полностью

Позволяет сменить режим отображения рисунка Показывать часть на режим отображения Показывать полностью.

Команда доступна в контекстном меню при выполнении обрезки рисунка. Если команда отмечена «галочкой», это означает, что режим Показывать полностью уже включен.

Для смены режима отображения рисунка можно также использовать группу переключателей Режим на Панели свойств.


Команда Сайт компании АСКОН

Позволяет посетить Интернет-сайт компании АСКОН — разработчика программных продуктов КОМПАС.

Если вы имеете подключение к Интернету, то после вызова команды запустится установленный на вашем компьютере web-браузер, в котором будет открыт Сайт компании АСКОН.

Адрес сайта: http://ascon.ru.


Команда Форум пользователей систем КОМПАС

Позволяет посетить WWW-конференцию пользователей систем КОМПАС.

Если вы имеете подключение к Интернету, то после вызова команды запустится установленный на вашем компьютере web-браузер, в котором будет открыт Форум пользователей систем КОМПАС.

Адрес форума: http://forum.ascon.ru.


Команда Сайт Службы технической поддержки

Позволяет посетить Интернет-сайт Службы технической поддержки пользователей САПР КОМПАС.

Если вы имеете подключение к Интернету, то после вызова команды запустится установленный на вашем компьютере web-браузер, в котором будет открыт Сайт Службы технической поддержки.

Адрес сайта: http://support.ascon.ru.


Команда Удалить(Контекстное меню в диалоге выбора ориентации модели)

Команда Удалить
(Контекстное меню в диалоге выбора ориентации модели)

Позволяет удалить текущую ориентацию. Команду можно вызвать из контекстного меню текущей ориентации в диалоге выбора ориентации вида. Команда доступна только для пользовательских ориентаций.


Команда Применить(Контекстное меню в диалоге выбора ориентации модели)

Команда Применить
(Контекстное меню в диалоге выбора ориентации модели)

Позволяет установить выбранную ориентацию. Команду можно вызвать из контекстного меню текущей ориентации в диалоге выбора ориентации вида.


Команда Переименовать(Контекстное меню в диалоге выбора ориентации модели)

Команда Переименовать
(Контекстное меню в диалоге выбора ориентации модели)

Позволяет переименовать текущую ориентацию. Команду можно вызвать из контекстного меню текущей ориентации в диалоге выбора ориентации вида. Команда доступна только для пользовательских ориентаций.


Команда Волнистая линия

Позволяет построить волнистую линию обрыва.

Для вызова команды нажмите кнопку Волнистая линия на инструментальной панели Обозначения или выберите ее название из меню Инструменты — Обозначения — Линии обрыва.

Волнистая линия представляет собой синусоиду, имеющую целое количество полуволн. Начальная и конечная точки (т1 и т2) волнистой линии лежат на средней линии синусоиды (см. рисунок).

Пример использования и параметры волнистой линии

а)

б)

– Если известны начальная (т1) и конечная (т2) точки отрезка средней линии, укажите их. При этом длина и угол наклона отрезка будут определены автоматически.

– Если известны начальная точка отрезка средней линии, его длина и угол наклона, задайте их любым способом и в любом порядке. Например, вы можете указать курсором положение точки т1, ввести длину в поле на Панели свойств и задать курсором угол наклона отрезка. При этом конечная точка отрезка будет определена автоматически.

После указания точек т1 и т2 в документе создается волнистая линия с умолчательными параметрами.

Во время построения волнистой линии вы можете изменить направление отрисовки волнистой линии с помощью группы переключателей Направление на вкладке Волнистая линия Панели свойств. На вкладке Параметры можно настроить параметры волнистой линии (выбрать способ построения, задать амплитуду, стиль линии и т.п.).

Чтобы быстро построить несколько одинаковых волнистых линий, например, для обозначения разрыва изображения, сделайте следующее. Не указывая точек т1 и т2 сделайте настройки на вкладке Параметры.

Задайте и зафиксируйте значения в полях Угол и Длина, а затем нажмите кнопку Запомнить состояние на Панели специального управления. Укажите последовательно начальные точки (т1) новых волнистых линий.

Вы можете создать несколько обозначений за один вызов команды Волнистая линия.

Чтобы завершить команду, нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также

Линия с изломами

Автоматическое и ручное создание объектов

Особенности редактирования волнистой линии

Другие обозначения


Сужение символов

Управление сужением символов выделенного или набираемого текста производится с помощью элементов инструментальной панели Форматирование.

Кнопка Сужение выводит на экран диалог настройки параметров шрифта, в котором можно установить любые параметры шрифта.

В поле Сужение отображается текущее значение сужения. Вы можете ввести нужное значение с клавиатуры или выбрать из списка.

Поле Сужение присутствует на панели, если она расположена горизонтально.


Команда Что неверно?

Позволяет вызвать на экран диалог с описанием конфликтных ситуаций, возникших в процессе редактирования модели или в процессе перестроения чертежа.

Если команда вызвана из контекстного меню на корневом объекте Дерева построения или Окна переменных, в диалоге отображаются предупреждения обо всех конфликтных ситуациях.

Если команда вызвана из контекстного меню на названии объекта в Дереве построения или в Окне переменных, в диалоге отображаются предупреждения о конфликтных ситуациях, возникших при перестроении этого объекта.

Для получения справочных сведений о конкретном предупреждении выделите это предупреждение в диалоге и нажмите кнопку Справка.


Команда Все окна...

Вызывает диалог управления окнами.

В этом диалоге перечислены все документы, открытые в текущем сеансе работы (документы, открытые в нескольких окнах, названы соответствующее количество раз).

Выбрав одно или несколько окон в списке, вы можете, воспользовавшись соответствующими кнопками, выполнить одно из следующих действий:

– активизировать (возможно, если выделено одно окно),

– сохранить,

– закрыть,

– расположить каскадом (возможно, если выделены несколько окон),

– расположить горизонтально (возможно, если выделены несколько окон),

– расположить вертикально (возможно, если выделены несколько окон),

– минимизировать.

Последние четыре возможности доступны, если отключено использование закладок документов.


Команда Отображение — Каркас

Позволяет отобразить модель в виде каркаса.

Каркас представляет собой совокупность всех ребер и линии очерка модели.

Для вызова команды нажмите кнопку Каркас на панели Вид или выберите ее название из меню Вид.

Сразу после вызова команды модель в активном окне отобразится в виде каркаса.

Отображение модели в виде каркаса

Смотрите также

Команда Отображение — Без невидимых линий

Команда Отображение — Невидимые линии тонкие

Команда Отображение — Полутоновое

Команда Отображение — Полутоновое с каркасом


Команда Закрыть окно

Команду можно вызвать из меню Окно или из контекстного меню закладки окна документа (контекстное меню закладки доступно, если в рабочей области включен показ закладок документов). Команда закрывает текущее окно.

Закрытие единственного окна документа эквивалентно закрытию этого документа. Закрыть текущее окно документа можно также при помощи комбинации клавиш <Ctrl>+<F4> или <Ctrl>+<W>.

Для закрытия окна можно нажать кнопку Закрыть, помещенную справа на закладке документа или на строке закладок (положение кнопки зависит от настройки, выполненной в диалоге Настройка закладок документов).

Если перед выходом из системы или закрытием документа не были сохранены внесенные в него изменения, будет выдан запрос на их сохранение.

Чтобы закрыть окно, дважды щелкните левой кнопкой или один раз средней кнопкой (колесом) мыши на закладке документа.


Команда Выход (окно Технические требования)

Команда Выход
(окно Технические требования)

Позволяет закрыть окно Технические требования.

Вы также можете нажать системную кнопку Закрыть в правом верхнем углу окна или щелкнуть мышью по значку режима редактирования технических требований.

Заданные технические требования сохраняются при сохранении документа-модели.


Команда Сохранить в документ (окно Технические требования)

Команда Сохранить в документ
(окно Технические требования)

Позволяет сохранить технические требования в отдельный текстовый файл (*.txt) или текстовый документ КОМПАС-3D (*.kdw).

В файл модели технические требования сохраняются при сохранении модели (с помощью команды Файл — Сохранить).


Команда Сохранить в файл

Позволяет записать текущие координаты полюсов сетки в файл данных.

Для вызова команды нажмите кнопку Сохранить в файл на Панели специального управления. На экране появится стандартный диалоге сохранения файла. Укажите имя файла и папку для его сохранения. По умолчанию файлу присваивается расширение txt.


Поля Координаты курсора

В этих полях, расположенных на панели Текущее состояние, отображаются текущие значения координат курсора по осям текущей системы координат.

Чтобы активизировать нужное поле, щелкните в нем мышью. Затем введите нужное значение с клавиатуры.

Если панель Текущее состояние расположена вертикально, то для доступа к полям координат курсора нажмите кнопку Координаты курсора.

Активизация этих полей возможна также с помощью клавиатурной комбинации <Alt> + <X>. После ее нажатия активным становится поле координаты Х. Введите в него нужное значение. Чтобы перейти к полю координаты Y, нажмите клавишу <Tab>. Введите значение.

Вы можете указывать в полях координат курсора приращения к текущим координатам. Для этого введите символ <^>, а затем — значение приращения.

Подтвердите задание координат курсора, нажав клавишу <Enter>. Курсор переместится в точку с указанными координатами.


Команда Создать зону

Позволяет создать зону в модели.

1. Вызовите команду из меню Редактор – Зоны модели или нажмите соответствующую кнопку на панели Вспомогательная геометрия.

2. Задайте параметры для построения зоны выбранным способом:

– По координатам;

– По габаритам объектов.

После задания всех необходимых данных на экране появляется фантом создаваемой зоны.

Пока построение не завершено, можно изменить параметры зоны, активизировав необходимый элемент управления на Панели свойств.

Чтобы сменить объекты, используемые для построения выбранным способом, нажмите кнопку Указать заново Панели специального управления и повторите выбор объектов.

Элементы управления, расположенные на вкладке Свойства Панели свойств, позволяют изменить название зоны. Также на этой вкладке отображается название системы координат зоны.

3. Создайте зону, нажав кнопку Создать объект.

Прервать создание зоны можно, нажав кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Подробнее о создании зон...


Команда Разбить зону

Позволяет разбить зону на несколько новых зон.

1. Вызовите команду из меню Редактор – Зоны модели или нажмите соответствующую кнопку на панели Вспомогательная геометрия.

2. Задайте параметры разбиения зоны выбранным способом:

– Равномерно по осям;

– По набору плоскостей.

После задания всех необходимых данных на экране появляется фантом зон, получаемых в результате разбиения.

Пока построение не завершено, можно изменить параметры разбиения, активизировав необходимый элемент управления на Панели свойств.

Чтобы сменить объекты, используемые для разбиения зоны выбранным способом, нажмите кнопку Указать заново Панели специального управления и повторите выбор объектов.

Элементы управления, расположенные на вкладке Свойства Панели свойств, позволяют изменить название разбиения.

3. Создайте разбиение, нажав кнопку Создать объект.

Прервать разбиение зоны можно, нажав кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Подробнее о разбиении зон...


Команда Показать зоны

Позволяет получить постоянное отображение зон в окне модели.

Для вызова команды выберите ее название из меню Вид — Отображение или нажмите соответствующую кнопку на инструментальной Панели Вид.

Если кнопка не нажата, то зоны отображаются, только если в Дереве модели активна вкладка Зоны.


Команда Масштаб 1,0

Позволяет установить коэффициент масштаба отображения в активном окне равным 1,0.

Для вызова команды при работе с графическим документом нажмите кнопку Масштаб 1,0 на контекстной инструментальной панели или выберите ее название из меню Вид.

При работе с моделью данная команда не входит в умолчательный набор команд меню Вид или кнопок контекстной инструментальной панели. Вы можете добавить ее в набор обычным образом.

Вы также можете разместить кнопку вызова команды на любой инструментальной панели.

Смотрите также

Управление масштабом отображения документа в окне


Команда Показать все

Изменяет масштаб отображения в активном окне следующим образом:

– для графических документов — так, чтобы в окне были полностью видны все объекты,

– для моделей — так, чтобы проекция габаритного параллелепипеда модели на плоскость экрана была вписана в окно.

Для вызова команды нажмите кнопку Показать все на панели Вид или выберите ее название из меню Вид. Можно также нажать клавишу <F9>.

Смотрите также

Управление масштабом отображения документа в окне


Команда Увеличить масштаб

Позволяет увеличить масштаб отображения в активном окне в определенное количество раз.

Для вызова команды нажмите кнопку Увеличить масштаб на панели Вид или выберите ее название из меню Вид. Можно также нажать комбинацию клавиш <Shift>+<+>.

Умолчательное значение коэффициента изменения масштаба в графических документах можно изменить в диалоге настройки редактирования, в текстовых документах и отчетах — в диалоге настройки редактирования текста, а в документах-моделях — в диалоге настройки управления изображением.

Если вы пользуетесь мышью с колесом, то для изменения масштаба отображения графических документов или моделей вращайте колесо мыши. Центром панорамирования является точка, в которой было начато вращение колеса. Возможна настройка направления вращения колеса мыши.

Чтобы центр изменения масштаба отображения находился в центре экрана, удерживайте нажатой клавишу <Shift>.

Колесо мыши можно использовать также для изменения масштаба отображения в текстовых документах и документах-спецификациях. Для этого вращайте колесо, удерживая нажатой клавишу <Ctrl>.

Смотрите также

Управление масштабом отображения документа в окне


Команда Уменьшить масштаб

Позволяет уменьшить масштаб отображения в активном окне в определенное количество раз.

Для вызова команды нажмите кнопку Уменьшить масштаб на панели Вид или выберите ее название из меню Вид. Можно также нажать комбинацию клавиш <Shift>+<->.

Умолчательное значение коэффициента изменения масштаба в графических документах можно изменить в диалоге настройки редактирования, в текстовых документах и отчетах — в диалоге настройки редактирования текста, а в документах-моделях — в диалоге настройки управления изображением.

Если вы пользуетесь мышью с колесом, то для изменения масштаба отображения графических документов или моделей вращайте колесо мыши. Центром панорамирования является точка, в которой было начато вращение колеса. Возможна настройка направления вращения колеса мыши.

Чтобы центр изменения масштаба отображения находился в центре экрана, удерживайте нажатой клавишу <Shift>.

Колесо мыши можно использовать также для изменения масштаба отображения в текстовых документах и документах-спецификациях. Для этого вращайте колесо, удерживая нажатой клавишу <Ctrl>.

Смотрите также

Управление масштабом отображения документа в окне


Команда Последующий масштаб

Позволяет вернуться к последующему масштабу отображения графического документа или модели в активном окне. Команда доступна в том случае, если перед этим был выполнен возврат к предыдущему масштабу.

Для вызова команды нажмите кнопку Последующий масштаб или выберите ее название из меню Вид.

Смотрите также

Управление масштабом отображения документа в окне


Команда Масштаб по выделенным объектам

Изменяет масштаб отображения в активном окне так, чтобы в нем полностью помещались все выделенные объекты в максимально возможном масштабе.

Если ни один объект не выделен, команда недоступна.

Для вызова команды нажмите кнопку Масштаб по выделенным объектам или выберите ее название из меню Вид.

Выделенные вспомогательные прямые и пустые (не содержащие ни одного объекта) виды при выполнении команды не учитываются. Не учитывается также единственная выделенная точка.

Смотрите также

Управление масштабом отображения документа в окне


Команда Показать эскиз полностью

Изменяет масштаб отображения в активном окне таким образом, что текущий эскиз полностью умещается в окне.

Для вызова команды нажмите кнопку Показать эскиз полностью на панели Вид или выберите ее название из меню Вид. Команда доступна только при работе с эскизом.

Вспомогательные прямые и вспомогательные проекции, построенные в эскизе, при выполнении команды не учитываются.

Смотрите также

Управление масштабом отображения документа в окне


Команда Предыдущий масштаб

Позволяет возвратиться к предыдущему масштабу отображения графического документа или модели в активном окне.

Для вызова команды нажмите кнопку Предыдущий масштаб или выберите ее название из меню Вид.

Смотрите также

Управление масштабом отображения документа в окне


Команда Увеличить масштаб рамкой

Позволяет изменить масштаб отображения в активном окне с помощью прямоугольной рамки.

Для вызова команды нажмите кнопку Увеличить масштаб рамкой на панели Вид или выберите ее название из меню Вид.

После этого внешний вид курсора изменится: он превратится в перекрестье. Укажите первый угол, затем перемещайте курсор для достижения нужного размера рамки. На экране будет отображаться фантом рамки. Укажите второй угол рамки.

Масштаб изображения увеличится так, чтобы область, ограниченная рамкой, полностью умещалась в окне документа.

Смотрите также

Управление масштабом отображения документа в окне


Рабочий участок кривой

Часть кривой, в пределах которой выполняется построение группы точек. Характеризуется смещением крайних точек от вершин кривой.


Объекты-«двойники»

Объекты-«двойники» — объекты спецификации, принадлежащие одному и тому же разделу и содержащие одинаковые данные в колонке, по которой производится сортировка (подробнее см. раздел 6.2.6.15).


Пустая строка

Пустая строка — строка в бланке спецификации, расположенная непосредственно над или под заголовком раздела. Она отделяет заголовок раздела от объектов спецификации.

В пустую строку невозможно ввести текст. Ее наличие в спецификации продиктовано стандартом.


Подраздел спецификации

Подраздел спецификации — группа объектов внутри раздела спецификации (подробнее см. раздел 6.1.2.2).


Стиль спецификации

Стиль спецификации — совокупность параметров и настроек, присущих спецификации и влияющих на ее заполнение и отображение. Компоненты стиля спецификации описаны в разделе 6.4.1.1.


Синхронизация

Синхронизация — процесс передачи объектов спецификации из чертежа в подключенную спецификацию или из спецификации в подключенные чертежи (подробнее см. разделы 6.2.4.2.1 и 6.2.4.2.2).


Диалог ввода значения размера высоты

Этот диалог появляется на экране после вызова команды Ввод значения... из контекстного меню в поле Текст на Панели свойств.

В диалоге можно ввести значение размера высоты. Если проставляется размер высоты для вида спереди и разреза, система автоматически вычисляет величину размера относительно заданной нулевой точки.

Для выбора значения из пользовательского меню нажмите кнопку.

Подробнее о пользовательских меню при вводе текста...

После завершения ввода значения нажмите кнопку ОК. Для выхода из диалога без изменения значения нажмите кнопку Отмена.


Диалог разрушения объектов

Диалог появляется на экране после вызова команды Разрушить.

Позволяет просмотреть список разрушаемых объектов (массивов, групп, копий геометрических объектов) и подтвердить разрушение либо отказаться от него.

Чтобы подтвердить разрушение, нажмите кнопку ОК. Чтобы отказаться от разрушения, нажмите кнопку Отмена.

При разрушении массива, являющегося исходным объектом для другого (производного) массива, этот производный массив также разрушается. Производные массивы (если такие есть) показываются в диалоге разрушения как подчиненные объекты разрушаемого массива.


Диалог удаления объектов

Диалог появляется на экране после вызова команды удаления объектов.

Позволяет просмотреть удаляемые элементы и объекты модели и подтвердить удаление либо отказаться от него.

В окне просмотра диалога отображается иерархический список, в котором:

– на первом уровне — модель или исполнение, объекты которого удаляются;

– на втором уровне — удаляемые объекты;

– на третьем и последующих уровнях — объекты модели, связанные с удаляемыми объектами (связанными объектами являются также сопряжения, в которых участвуют удаляемые объекты); связанные объекты удаляются вместе со своими исходными объектами.

Чтобы подтвердить удаление, нажмите кнопку ОК. Будут удалены указанные объекты и связанные с ними объекты и сопряжения.

Чтобы отказаться от удаления, нажмите кнопку Отмена.


Диалог выбора сгибов

Этот диалог появляется при удалении таблицы сгибов из детали.

Он содержит перечень сгибов, которые входят в состав листовых элементов с автоматически определяемыми углами сгиба, и у которых включено определение параметров по исходному объекту (т.е. активна опция По исходному объекту, подробнее см. раздел Редактирование сгиба).

Элементами с автоматически определяемыми углами сгиба являются:

– листовое тело с разомкнутым эскизом (углы сгибов определяются параметрами объектов эскиза),

– подсечка, заданный размер которой меньше минимального (углы сгибов рассчитываются системой).

Отметьте в диалоге выбора сгибов те сгибы, для которых требуется сохранить значение параметра развертки, полученное из таблицы. Нажмите кнопку ОК.

У выбранных сгибов будет автоматически отключено определение параметров по исходному объекту. Способ определения длины развертки поменяется на способ, соответствующий типу использовавшейся таблицы. Параметр развертки каждого сгиба примет значение, выбранное из таблицы с учетом величины угла этого сгиба.

У остальных сгибов будет сохранен признак определения параметров по исходному объекту. Поэтому каждый из них получит — вне зависимости от угла сгиба — такие же параметры, как исходный объект.

Кнопка Отмена диалога выбора сгибов позволяет отказаться от удаления таблицы сгибов.


Диалог Допуск (для угловых размеров)

Диалог Допуск
(для угловых размеров)

Позволяет задать умолчательный допуск угловых размеров.

Диалог вызывается нажатием кнопки в диалоге настройки умолчательных параметров допусков либо при редактировании размера в окне Свойства — после щелчка мышью в ячейке значения свойства Допуск — Включен.

Поля Верхнее и Нижнее служат для задания значений угловых отклонений размера. Значения отклонений вводятся вручную.
При вводе отклонений доступна кнопка ±. Она позволяет сделать отклонения равными. Перед значением верхнего отклонения ставится знак «+», а перед значением нижнего — знак «-».

Для простановки значков градусов, минут и секунд используйте соответствующие кнопки рядом с полем ввода отклонений.

После задания допуска закройте диалог, нажав кнопку ОК. Для выхода из диалога без изменения допуска нажмите кнопку Отмена.


Диалог выбора вида приложения

Этот диалог появляется на экране после первого запуска системы КОМПАС-3D или после вызова команды Сервис — Вид приложения...

Позволяет настроить стиль отображения элементов окна системы.

Описание элементов управления
Наименование | Описание
Стиль приложения | Список, из которого можно выбрать стиль приложения. Укажите в раскрывающемся списке один из вариантов.
Цветовая схема | Список, из которого можно выбрать цветовое оформление приложения. Список доступен, если стиль приложения — Microsoft® Office 2007 или Microsoft® Office 2010. Укажите в раскрывающемся списке один из вариантов.
Размер значков | Список, из которого можно выбрать размер значков на панелях, в меню и в Дереве документа. Если в диалоге настройки размера значков отключена опция Единый, то в списке размеров значков появляется строка Согласно настройке. Ее выбор означает, что значки будут иметь размеры, заданные в диалоге настройки размеров значков.
Цветные закладки документов | Опция, управляющая стилем закладок документов. При включении этой опции закладки отображаются разноцветными, а кнопка прокрутки закладок влево находится слева от них.
Скругленные «корешки» панелей | Опция, управляющая стилем «корешков» панелей. Опция доступна, если стиль приложения — Microsoft® Visual Studio 2005. При включении этой опции «корешки» панелей, если панели находятся в свернутом состоянии, отображаются скругленными.
Расширенные всплывающие подсказки | Опция, управляющая видом всплывающих подсказок. Если опция включена, то во всплывающую подсказку, появляющуюся при подведении курсора к элементу рабочего окна, добавляется информация, находящаяся в строке сообщений. Если опция выключена, то всплывающая подсказка будет содержать только название команды.
Показывать этот диалог при запуске | Опция, управляющая автоматическим открытием диалога. Если она включена, то диалог появляется на экране каждый раз после запуска системы.
ОК | Нажатие этой кнопки закрывает диалог и применяет выбранную настройку.
Закрыть | Нажатие этой кнопки закрывает диалог без применения выбранной настройки. Такой же результат дает закрытие диалога кнопкой в его заголовке.
Применить | Нажатие этой кнопки применяет выбранную настройку без закрытия диалога.

При первом запуске системы диалог выбора вида приложения появляется без кнопки Закрыть.


Диалог редактирования атрибута-числа

Этот диалог позволяет задать содержимое атрибута, имеющего тип число.

Введите значение атрибута в соответствующем поле диалога. Если ввод выполняется в первый раз, то предлагается установленное при создании типа значение по умолчанию.

Описание элементов управления
Элемент | Описание
Пароль | Нажмите кнопку для задания пароля доступа к значению атрибута (например, для защиты от несанкционированного изменения).
Ключи | Нажмите кнопку для вызова диалога, в котором можно задать специальные ключевые значения для идентификации атрибута.
Следующий Предыдущий | Вы можете последовательно переходить от одного атрибута объекта к другому, используя кнопки со стрелками. Кнопки доступны, если документ или выбранный объект имеет более одного атрибута.

Завершив ввод значения атрибута, нажмите кнопку ОК. Для выхода из диалога без изменения содержимого атрибута нажмите кнопку Отмена.


Диалог редактирования атрибута-строки

Этот диалог появляется на экране после нажатия кнопки Редактировать... в диалоге Имеющиеся атрибуты.

Позволяет задать содержимое атрибута, имеющего тип строка.

Введите строку в соответствующем поле диалога. Если ввод выполняется в первый раз, то предлагается установленное при создании типа значение по умолчанию.

Описание элементов управления
Элемент | Описание
Пароль | Нажмите кнопку для задания пароля доступа к значению атрибута (например, для защиты от несанкционированного изменения).
Ключи | Нажмите кнопку для вызова диалога, в котором можно задать специальные ключевые значения для идентификации атрибута.
Следующий Предыдущий | Вы можете последовательно переходить от одного атрибута объекта к другому, используя кнопки со стрелками. Кнопки доступны, если документ или выбранный объект имеет более одного атрибута.

Завершив ввод значения атрибута, нажмите кнопку ОК. Для выхода из диалога без изменения содержимого атрибута нажмите кнопку Отмена.


Диалог выбора типа нового атрибута

Этот диалог появляется на экране после нажатия кнопки Новый тип в диалоге Типы атрибутов.

Позволяет выбрать нужный тип для нового атрибута объекта.

В структурированном списке отображаются названия типов, которые хранятся в активном документе (локальные типы) или в подключенной библиотеке типов (библиотечные типы).

Описание элементов управления
Элемент | Описание
Библиотеки Документ | Чтобы просмотреть список типов из другой библиотеки или локальных типов, нажмите нужную кнопку.
Просмотреть | Чтобы получить информацию о типе, выберите его из списка и нажмите кнопку.
Новый | Используйте кнопку для перехода к диалогу создания нового типа атрибута.
Выбрать | Найдите в списке подходящий для нового атрибута тип и нажмите кнопку.

Для завершения диалога без выбора типа нажмите кнопку Отмена.


Диалог редактирования ключа поля атрибута

Этот диалог появляется на экране после нажатия кнопки Ключ поля диалога Структура типа. В этом диалоге вы можете ввести значение ключа указанного поля табличного атрибута.

Таким образом вы можете, например, сделать ключ поля атрибута отличающимся от установленного по умолчанию в типе этого атрибута.

После ввода нового значения ключа нажмите кнопку ОК. Для выхода из диалога без изменения ключа нажмите кнопку Отмена.


Диалог редактирования табличного атрибута

Позволяет задать содержимое ячеек атрибута, имеющего тип таблицы с постоянным или переменным количеством строк.

В диалоге отображается таблица, в ячейках которой можно вводить или изменять значения. Если ввод выполняется в первый раз, то предлагаются значения установленные по умолчанию (при создании типа атрибута).

Описание элементов управления
Элемент | Описание
Следующий Предыдущий | Вы можете последовательно переходить от одного атрибута объекта к другому, используя кнопки со стрелками. Эти кнопки доступны, во-первых, при работе с атрибутами документов или объектов графических документов и документов-моделей, а во-вторых, если у выбранного объекта имеется более одного атрибута.
Пароль | Нажмите эту кнопку для задания пароля доступа к атрибуту (например, для защиты от несанкционированного изменения). Кнопка Пароль доступна при работе с атрибутами объектов графических документов и документов-моделей.
Ключи | Нажмите эту кнопку для вызова диалога, в котором можно задать специальные ключевые значения для идентификации атрибута.
Запретить | Чтобы запретить редактирование значений в какой-либо колонке табличного атрибута, установите в нее курсор и нажмите эту кнопку. На колонке появится надпись Запрещенная колонка, а кнопка изменит свое название.
Разрешить | Нажмите эту кнопку для снятия запрета на редактирование колонки.
Добавить | Для добавления новой строки в таблицу нажмите эту кнопку. Кнопка доступна, если тип атрибута — таблица с переменным количеством строк.
Удалить | Для уничтожения строки таблицы установите на нее курсор и нажмите эту кнопку. Кнопка доступна, если тип атрибута — таблица с переменным количеством строк.
Переместить | Чтобы изменить положение строки, выберите ее и нажмите эту кнопку. Затем установите курсор на той строке, куда нужно переместить выбранную строку, и щелкните левой кнопкой мыши. Кнопка Переместить доступна, если тип атрибута — таблица с переменным количеством строк.
Ключ поля | Нажмите эту кнопку, чтобы задать ключ поля, в котором находится курсор. Присвоение ключей полям используется, например, при работе со спецификацией. Они влияют на порядок сортировки объектов, текстовая часть которых заполнена по шаблону. Произвольное изменение ключей полей атрибутов при использовании шаблонов не рекомендуется.

Завершив ввод значений в ячейках табличного атрибута, нажмите кнопку ОК. Для выхода из диалога без изменения содержимого атрибута нажмите кнопку Отмена.


Диалог редактирования записи в табличном атрибуте

Этот диалог появляется на экране после нажатия кнопки Редактировать... в диалоге Имеющиеся атрибуты.

Позволяет ввести или отредактировать значения в полях записи. Если ввод выполняется в первый раз, то предлагаются установленные при создании типа значения по умолчанию.

Описание элементов управления
Элемент | Описание
Запретить | Для того чтобы запретить редактирование значений в каком-либо поле записи, установите курсор на это поле и нажмите кнопку. При этом на поле появится надпись Запрещенная колонка, а кнопка изменит свое название.
Разрешить | Нажмите кнопку, чтобы снять запрет на редактирование поля.

Завершив ввод значений в полях записи, нажмите кнопку Выход. Для выхода из диалога без изменения значений нажмите кнопку Отмена.


Диалог ввода значений в список

Этот диалог появляется на экране после нажатия кнопки Показать список в диалоге Структура типа.

Вы можете определить колонку табличного атрибута как заполняемую из предварительно заданного списка значений (с запрещением ввода произвольного значения). В диалоге ввода значений можно задать значения списка.

Наберите в строке ввода нужное значение (число или строку текста, в зависимости от выбранного типа данных), а затем нажмите кнопку Добавить значение. Введенное значение немедленно добавляется в список.

Описание элементов управления
Элемент | Описание
Добавить значение | Нажмите эту кнопку для добавления содержимого строки ввода в список предопределенных значений.
Удалить значение | Чтобы удалить значение, выберите его в списке и нажмите эту кнопку.
Переместить значение вверх/вниз | Нажмите эту кнопку, чтобы переместить значение, выделенное в списке, на одну позицию вверх или вниз.
Учитывать порядок размещения значений при сортировке | Эта опция используется при создании шаблонов заполнения записей. Доступна, если тип данных в колонке — строка. Включение опции Учитывать порядок означает, что сортировка по настраиваемой колонке будет производиться в порядке следования строк.

После того как список значений сформирован, нажмите кнопку ОК. Чтобы выйти из диалога без сохранения изменений в списке, нажмите кнопку Отмена.


Диалог Поля ключей атрибута(при редактировании текстовой части объекта спецификации)

Диалог Поля ключей атрибута
(при редактировании текстовой части объекта спецификации)

Диалог позволяет просмотреть текущие значения ключей атрибута. Значения ключей определяют доступность атрибутов для использования в качестве шаблонов заполнения текстовой части объектов спецификации того или иного раздела спецификации. Подробнее...

Для уже созданного объекта спецификации, а также для атрибута, присвоенного объекту, ключи не имеют значения.


Диалог Поля ключей атрибута(при создании и редактировании типа атрибута)

Диалог Поля ключей атрибута
(при создании и редактировании типа атрибута)

Диалог позволяет настроить параметры использования атрибута для формирования текстовой части объекта спецификации.

Введите ключи атрибута в поля диалога. Значения ключей определяют, в каком разделе спецификации этот атрибут будет доступен в качестве шаблона заполнения текстовой части (атрибут должен находиться в файле Spc.lat). Подробнее...

Опция Автоматическое формирование текста определяет вариант расстановки пробелов в тексте, составленном из символов, введенных в колонки атрибута.

– Если опция включена, то пробелы между фрагментами текста расставляются автоматически, согласно стандартам. Так, например, в обозначении болта «Болт 1 М12...» перед обозначением исполнения и после него добавляются пробелы, а перед значением диаметра пробел не добавляется.

– Если опция отключена, то пробелы между фрагментами текста не добавляются. При необходимости их можно включить в имеющиеся колонки (доступно, если тип колонки — Строка) или создать между колонками, которые следует разделить пробелом, новые колонки, содержимым которых будет пробел.


Диалог работы с атрибутами объектов

Этот диалог появляется на экране после вызова команды Сервис — Атрибуты.

Позволяет ввести или отредактировать атрибуты для выделенного объекта (или нескольких выделенных объектов).

Если ни один объект не выделен, команда будет недоступна.

В структурированном списке отображаются названия типов атрибутов, которые уже назначены для данного объекта.

Описание элементов управления
Элемент | Описание
Новый | Нажмите кнопку, чтобы добавить новый атрибут к объекту, при этом на экране появится диалог выбора типа для этого атрибута.
Просмотреть Редактировать | Для просмотра или изменения содержимого атрибута выберите его из списка, а затем нажмите нужную кнопку.
Удалить | Чтобы удалить один или несколько атрибутов, выберите их из списка и нажмите эту кнопку.
Копия в буфер | Вы можете обмениваться атрибутами между различными объектами документа. Выберите нужные атрибуты в списке, а затем нажмите кнопку. Выбранные атрибуты будут скопированы в специальный буфер обмена (Clipboard).
Перенос в буфер | Нажмите кнопку для копирования атрибутов в буфер с их одновременным удалением из списка.
Взять из буфера | Нажмите кнопку, чтобы присвоить объекту атрибуты, находящиеся в буфере обмена.

Для завершения диалога работы с атрибутами нажмите кнопку Выход.


Диалог создания нового типа атрибута

Этот диалог появляется на экране после нажатия кнопки Новый тип в диалоге Типы атрибутов.

Позволяет создать новый тип атрибута для его последующего использования.

Описание элементов управления
Элемент | Описание
Название типа | В этом поле необходимо ввести или отредактировать название типа атрибута.
Структура типа | Установите с помощью переключателей нужный тип атрибута. Поддерживаются следующие типы: – строка – число – таблица фиксированной длины – таблица переменной длины
Назначить прототип | Кнопка появляется в том случае, если выбран вариант таблицы переменной длины. После нажатия кнопки Назначить прототип в диалоге появляются дополнительные разделы.
Число строк таблицы | Поле ввода появляется в случае выбора варианта таблицы фиксированной длины.
Типы атрибутов | В этом поле отображается структурированный список типов атрибутов, хранящихся в документе или библиотеке.
Прототип | В этом поле отображается название типа атрибута, выбранного для использования в качестве прототипа.
Назначить | Для выбора выделенного в списке типа в качестве прототипа выберите его из списка и нажмите кнопку.
Документ Библиотека | Чтобы просмотреть список типов в текущем документе или другой библиотеке, нажмите нужную кнопку.
Просмотр | Для просмотра типа выберите его из списка и нажмите кнопку.
Отменить прототип | Чтобы отказаться от выбранного прототипа, нажмите кнопку.

После того как описание нового типа атрибута закончено, нажмите кнопку ОК. Чтобы завершить диалог без создания нового типа, нажмите кнопку Отмена.

Если создается табличный тип атрибута, после нажатия кнопки ОК на экране появится еще один диалог, в котором нужно описать структуру типа (количество столбцов, их типы, допустимые интервалы данных и т.д.).


Диалог ввода пароля доступа к типу атрибута

Введите или отредактируйте строку пароля доступа к структуре типа атрибута. Если пароль установлен, то он будет запрашиваться при любой попытке изменения структуры данного типа, и только при правильном вводе пароля редактирование будет разрешено.

После ввода строки пароля нажмите кнопку ОК. Для выхода из диалога без ввода пароля нажмите кнопку Отмена.


Диалог ввода условий поиска для атрибутов типа Число

Диалог ввода условий поиска
для атрибутов типа Число

Этот диалог появляется на экране после нажатия кнопки Редактирование условия диалога Выбор значений атрибутов.

Позволяет задать или отредактировать условия поиска по значениям для атрибутов, имеющих целочисленный или действительный тип (в том числе для колонок табличных атрибутов).

Описание элементов управления
Элемент | Описание
Имя типа | В этом поле отображается название типа атрибута, для которого задаются условия.
Значение | В этом поле можно задать значение для формирования условия.
Отношение | Выберите из списка нужное логическое отношение для формирования условия.
Добавить в список | После того как условие сформировано, нажмите кнопку для его перемещения в список условий. В нем отображаются все введенные условия поиска.
Удалить из списка | Если необходимо отменить условие, выберите его в списке и нажмите кнопку
и, или | Чтобы связать несколько условий логическим отношением, выберите нужный вариант.

После задания условий поиска нажмите кнопку ОК. Для завершения диалога без сохранения внесенных изменений нажмите кнопку Отмена.


Диалог ввода условий поиска для атрибутов типа Строка

Диалог ввода условий поиска
для атрибутов типа Строка

Этот диалог появляется на экране после нажатия кнопки Редактирование условия диалога Выбор значений атрибутов.

Позволяет задать или отредактировать условия поиска по значениям для атрибутов, имеющих строчный тип (в том числе для колонок табличных атрибутов).

Описание элементов управления
Элемент | Описание
Имя типа | В этом поле отображается название типа атрибута, для которого задаются условия.
Добавить в список | После того как подстрока введена, нажмите кнопку для ее перемещения в список подстрок. В списке отображаются все введенные для поиска подстроки.
Список подстрок для выбора | В этом поле отображаются все введенные подстроки, которые нужно использовать при поиске.
Отношение | Выберите из списка нужное логическое отношение для формирования условия.
Текст подстроки для выбора | В этом поле можно ввести подстроку для использования при поиске.
Удалить из списка | Если необходимо отменить условие, выберите его в списке и нажмите кнопку
и, или | Чтобы связать несколько условий логическим отношением, выберите нужный вариант.
Учитывать регистр символов | Если вы хотите, чтобы при поиске различался регистр символов, включите опцию.

После задания условий поиска нажмите кнопку ОК. Для завершения диалога без сохранения внесенных изменений нажмите кнопку Отмена.


Диалог задания диапазона значений в колонке

Этот диалог появляется на экране после нажатия кнопки Сменить пределы диалога Структура типа.

Позволяет задать или отредактировать интервал допустимых значений для ввода в колонке табличного атрибута.

В зависимости от типа данных поля ввода в диалоге могут быть различными. Например, для целочисленного типа задаются минимальное и максимальное значения, а для строки текста — ее допустимая длина.

Задайте нужные ограничения для данных в колонке и нажмите кнопку ОК. Для выхода из диалога без изменения диапазона значений нажмите кнопку Отмена.


Диалог выбора объектов по атрибутам

Этот диалог появляется на экране после вызова команды Выделить — По атрибутам....

Позволяет выбрать объекты в соответствии с указанными типами и значениями атрибутов.

Описание элементов управления
Элемент | Описание
Типы, используемые в документе | В этом поле отображаются названия типов атрибутов, которые используются в документе.
Выбранные типы | В этом поле отображается список типов атрибутов, которые выбраны для поиска. Чтобы использовать тип атрибута для поиска, выберите его название в верхнем списке, а затем нажмите кнопку со стрелкой. Выбранный тип отобразится в нижнем списке.
Редактирование условия | Если необходимо назначить или изменить условия поиска по значениям атрибута, выберите его название в нижнем списке и нажмите кнопку. На экране появится диалог, в котором можно задать нужные условия для поиска.
Очистка условия | Нажмите кнопку для сброса условия поиска.

После ввода нужных параметров для поиска нажмите кнопку ОК. Для завершения диалога без последующего поиска объектов по атрибутам нажмите кнопку Отмена.


Диалог выбора типа данных в колонке

Этот диалог появляется на экране после нажатия кнопки Сменить тип в диалоге Структура типа.

Позволяет установить тип данных для колонки табличного атрибута.

Описание элементов управления

Элемент

Описание

- целое число

- действительное число

- строка текста

- запись

Выберите нужный вариант типа данных для колонки.

Ключ поля

Вы можете задать число, являющееся ключевым значением для данной колонки. Допускаются целые числа не более 254.

Заполнение из списка

Вы можете определить колонку как заполняемую из предварительно заданного списка значений (с запрещением ввода произвольного значения), если включите данную опцию. В дальнейшем можно в специальном диалоге ввести нужные значения в список. Для записей заполнение из списка невозможно.

Если вы хотите изменить тип данных в колонке, для которой ранее было включено заполнение из списка, то предварительно выключите эту опцию. В результате созданный ранее список значений будет удален после подтверждения.

В справочной строке диалога указано, какому типу данных в языке С соответствует выбранный тип данных в колонке.

(Эта информация может потребоваться при разработке прикладных библиотек КОМПАС-3D)

После выбора нужного типа данных колонки нажмите кнопку ОК. Для выхода из диалога без изменения типа нажмите кнопку Отмена.


Диалог работы с типами атрибутов

Этот диалог появляется на экране после выполнения команды Сервис — Библиотеки стилей, типов, оформлений и основных надписей — Типы атрибутов....

Позволяет создать новые или отредактировать уже имеющиеся типы атрибутов, а также выполнять различные операции с внешними библиотеками типов атрибутов.

Диалог имеет два окна просмотра списков типов атрибутов. Активным может быть только одно окно просмотра. Активизация производится щелчком мыши в окне.

Описание элементов управления
Элемент | Описание
Показать библиотеку | Чтобы отобразить в активном окне список типов атрибутов, хранящихся в библиотеке *.lat, нажмите эту кнопку.
Показать документ | Чтобы отобразить в активном окне список типов атрибутов, хранящихся в активном документе, нажмите эту кнопку.
Новый раздел | Чтобы создать новый раздел (подраздел) для размещения типов атрибутов, нажмите эту кнопку. На экране появится диалог, в котором нужно ввести имя нового раздела.
Новый тип | Чтобы создать новый тип атрибута в текущем разделе, нажмите эту кнопку. На экране появится диалог создания типа атрибута.
Просмотреть | Для просмотра выделенного типа атрибута нажмите эту кнопку.
Редактировать | Чтобы отредактировать выделенный тип атрибута, нажмите эту кнопку.
Удалить | Чтобы удалить раздел или тип атрибута из документа или библиотеки, выделите его в списке и нажмите эту кнопку.
Копировать | Чтобы скопировать выделенный тип атрибута, нажмите нужную кнопку. Тип атрибута будет скопирован в соседнее окно (в раздел, который является там текущим).
Перенести | Чтобы перенести выделенный тип атрибута, нажмите нужную кнопку. Тип атрибута будет удален из активного окна и помещен в соседнее (в раздел, который является там текущим).

Чтобы завершить диалог работы с типами атрибутов, нажмите кнопку Выход.


Диалог просмотра табличного атрибута

Этот диалог появляется на экране после нажатия кнопки Просмотреть... в диалоге Имеющиеся атрибуты.

Позволяет просмотреть содержимое ячеек атрибута табличного типа.

Если документ или выбранный объект имеет более одного атрибута, вы можете последовательно переходить от одного атрибута к другому, используя кнопки со стрелками.

Для завершения просмотра атрибута нажмите кнопку Выход.


Диалог просмотра записи в табличном атрибуте

Этот диалог появляется на экране после нажатия кнопки Просмотреть... в диалоге Имеющиеся атрибуты.

Позволяет просмотреть содержимое полей записи, хранящейся в ячейке табличного атрибута.

Описание элементов управления
Элемент | Описание
Следующий | Нажмите кнопку для просмотра следующей записи.
Предыдущий | Нажмите кнопку для просмотра предыдущей записи.

Для завершения просмотра атрибута нажмите кнопку Выход.


Диалог просмотра и редактирования характеристик строкового или числового типа атрибута

Диалог просмотра и редактирования
характеристик строкового или числового типа атрибута

Этот диалог позволяет просмотреть или отредактировать название и ключи числового или строкового типа атрибута и просмотреть значение уникального номера типа атрибута.

Для вызова диалога просмотра и редактирования ключей атрибута нажмите кнопку Ключи....

Изменив название типа атрибута и (или) его ключи, нажмите кнопку OK. Для выхода из диалога без изменения характеристик типа атрибута нажмите кнопку Отмена.

Если данный диалог вызван для просмотра характеристик, то изменение названия типа и его ключей невозможно, а кнопка OK недоступна.


Диалог описания структуры атрибута типа Таблица

Этот диалог позволяет задать или отредактировать описание структуры для табличного типа атрибута.

Описание элементов управления
Элемент | Описание
Название | В этом поле необходимо ввести или отредактировать название типа атрибута.
Уникальный номер типа | В этом поле отображается специальный номер, который система автоматически присваивает данному типу.
Постоянной длины Переменной длины | Выберите нужный вариант типа атрибута типа Таблица
Число строк | Введите нужное значение в поле. Доступно при выборе типа таблицы Переменной длины.
В нижней части диалога отображается таблица, с помощью которой создается или редактируется описание структуры типа. Каждая строка содержит сведения, определяющие способ формирования колонки в атрибуте.
Номер | Автоматически присваиваемый номер колонки
Название колонки | В этом поле задается название (заголовок) для колонки атрибута.
Тип колонки | В этом поле устанавливается тип данных в колонке. Для вызова диалога изменения типа данных щелкните левой кнопкой мыши на поле, а затем нажмите появившуюся кнопку Сменить тип.
Диапазон значений | В этом поле устанавливается диапазон значений, допустимых для данных в колонке. Чтобы изменить диапазон значений, щелкните левой кнопкой мыши на поле, а затем нажмите появившуюся кнопку, название которой зависит от типа данных в колонке.
Значение по умолчанию | В этом поле можно ввести значение по умолчанию для колонки.
Добавить | Для добавления новой колонки типа атрибута нажмите кнопку.
Удалить | Чтобы удалить колонку, выберите ее и нажмите кнопку.
Переместить | Для изменения положения активной строки нажмите кнопку и укажите мышью новое положение строки.
Пароль | При необходимости вы можете установить пароль доступа к структуре типа атрибута (например, для защиты от несанкционированного редактирования структуры). Чтобы вызвать диалог назначения пароля, нажмите кнопку.

После того как описание структуры табличного типа атрибута закончено, нажмите кнопку ОК. Чтобы выйти из диалога без внесения изменений в структуру, нажмите кнопку Отмена.


Диалог описания структуры записи

Этот диалог позволяет задать или отредактировать структуру записи для колонки табличного атрибута. Фактически запись представляет собой однострочную таблицу, вложенную в ячейку головной таблицы.

Описание элементов управления
Элемент | Описание
В нижней части диалога отображается таблица, с помощью которой создается или редактируется описание структуры записи. Каждая строка содержит сведения, определяющие способ формирования колонки в записи.
Номер | Автоматически присваиваемый номер колонки
Название колонки | В этом поле задается название (заголовок) для колонки атрибута.
Тип колонки | В этом поле устанавливается тип данных в колонке. Для вызова диалога изменения типа данных щелкните левой кнопкой мыши на поле, а затем нажмите появившуюся кнопку Сменить тип.
Диапазон значений | В этом поле устанавливается диапазон значений, допустимых для данных в колонке. Чтобы изменить диапазон значений, щелкните левой кнопкой мыши на поле, а затем нажмите появившуюся кнопку, название которой зависит от типа данных в колонке.
Значение по умолчанию | В этом поле можно ввести значение по умолчанию для колонки.
Добавить | Для добавления новой колонки типа атрибута нажмите кнопку.
Удалить | Чтобы удалить колонку, выберите ее и нажмите кнопку.
Переместить | Для изменения положения активной строки нажмите кнопку и укажите мышью новое положение строки.

После того как редактирование структуры записи закончено, нажмите кнопку ОК. Чтобы выйти из диалога без внесения изменений в структуру, нажмите кнопку Отмена.


Диалог настройки параметров списка

Позволяет задать параметры нумерации абзацев текста. Сделанная настройка является единой для всего текста.

Диалог появляется на экране:

– при вводе и редактировании текста — установите курсор в абзац списка и вызовите команду Формат — Параметры списка,

– при настройке параметров текстов (текста на чертеже, текста технических требований, текста текстового документа и т.п.) — нажмите в настроечном диалоге кнопку Параметры списка....

Описание элементов управления
Наименование | Описание
Использовать для | Вы можете установить различные параметры для списков разных уровней. Выберите нужный уровень из списка и задайте соответствующие параметры в разделах диалога. Максимальное число уровней —10.
Текст перед | Задайте текст, который будет добавляться перед номером.
Тип номера | Выберите из списка нужный тип нумерации (арабские цифры, римские цифры, буквы и т.д.).
Текст после | Задайте текст, который будет добавляться после номера.
Начинать с позиции | Установите, с какой позиции начинать нумерацию.
Добавлять к номеру верхнего уровня | Включите эту опцию, если хотите, чтобы текущий номер добавлялся к номеру более высокого уровня (например, как 2.1).
Применить для всех уровней | Нажмите эту кнопку, чтобы применить заданные параметры для списков всех уровней.
Величина отступа | Устанавливает значение отступа при нумерации. Способ формирования отступа определяется двумя следующими переключателями.
Фиксированный отступ от номера до текста | Устанавливает одинаковый для всех нумерованных абзацев отступ от последнего символа, входящего в номер, до начала текста абзаца.
Фиксированный отступ до начала текста | Устанавливает одинаковый для всех нумерованных абзацев отступ от левой границы до начала текста абзаца.
Шрифт... | Нажмите эту кнопку для вызова диалога настройки параметров шрифта нумерации.
Сбросить | Нажмите эту кнопку, чтобы отменить заданные ранее параметры нумерации для всех уровней.

После завершения настройки параметров нумерации нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


Диалог создания объектов спецификации для модели

Этот диалог появляется на экране после вызова команды Спецификация — Создать объекты спецификации...

Позволяет задать параметры автоматического формирования объектов спецификации в деталях и подсборках текущей сборки.

Описание элементов управления

Элемент

Описание

Обработать файлы компонентов

Группа элементов, позволяющая задать область действия команды.

Включение опции Всех уровней означает, что:

– в деталях текущей сборки и в деталях подсборок будут созданы объекты спецификации,

– во всех подсборках будут созданы внешние объекты спецификации.

Включение опции Первого уровня означает, что:

– в деталях текущей сборки будут созданы объекты спецификации,

– в подсборках текущей сборки будут созданы внешние объекты спецификации.

Раздел спецификации

Группа элементов, позволяющая указать, каким разделам должны принадлежать объекты спецификации.

В списках КОМПАС-Сборки (.a3d) и КОМПАС-Детали (*.m3d) содержатся названия разделов спецификации текущего стиля. Если текущий стиль спецификации не определен (т.е. если отсутствует описание спецификации), то используется стиль, установленный для новых спецификаций.

Выберите разделы, в которые будут помещаться объекты спецификации в файлах деталей и внешние объекты спецификации в файлах сборок.

Если не нужно создавать объекты спецификации в файлах деталей или сборок, то выберите пустую строку в списке КОМПАС-Сборки (*.a3d) или КОМПАС-Детали (*.m3d).

Создавать документ спецификации

Включите эту опцию, чтобы автоматически создать и подключить к текущей сборке документ-спецификацию (*.spw). Если в группе Обработать файлы компонентов включена опция Всех уровней, автоматически создаются и подключаются к подсборкам всех уровней документы-спецификации, соответствующие этим подсборками. Документы-спецификации именуются так же, как сборки, к которым они подключаются, и размещаются там же, где сборки.

Сохранять изменения

Включите эту опцию, чтобы после создания объектов спецификации текущая сборка была сохранена.

Файлы компонентов сохраняются вне зависимости от состояния данной опции.

Завершив настройку, нажмите кнопку OK диалога. В тех компонентах, которые не содержали объекты спецификации, будут созданы объекты спецификации.

Чтобы отказаться от формирования объектов спецификации в компонентах сборки, нажмите кнопку Отмена.


Диалог удаления объектов спецификации

Этот диалог появляется на экране после вызова команды Спецификация — Удалить объекты спецификации...

Позволяет задать параметры автоматического удаления объектов спецификации текущего стиля из текущей сборки, ее деталей и подсборок.

Описание элементов управления

Элемент

Описание

Обработать файлы компонентов

Группа элементов, позволяющая задать область действия команды.

Включение опции Всех уровней означает, что из текущей сборки и всех ее компонентов будут удалены все объекты спецификации.

Включение опции Первого уровня означает, что:

– из деталей текущей сборки будут удалены все объекты спецификации,

– из подсборок будут удалены все внешние объекты спецификации,

– из текущей сборки будут удалены внешние объекты спецификации и внутренние объекты спецификации, не связанные с компонентами (например, в разделе Материалы).

Удалить документ спецификации

Включите эту опцию, чтобы удалить подключенный к текущей сборке документ-спецификацию (*.spw). Если в группе Обработать файлы компонентов включена опция Всех уровней, автоматически удаляются документы-спецификации, подключенные к подсборкам.

Сохранять изменения

Включите эту опцию, чтобы после удаления объектов спецификации текущая сборка и все ее компоненты были сохранены.

Завершив настройку, нажмите кнопку OK диалога. Объекты спецификации будут удалены из сборки и ее компонентов.

Чтобы отказаться от удаления объектов спецификации из компонентов сборки, нажмите кнопку Отмена.


Диалог изменения стилей выделенных объектов

Этот диалог появляется на экране после вызова команды Сервис — Изменить стиль.

В нем можно указать, какие стили выделенных объектов (кривых, точек, текстов и штриховок) должны быть заменены, а также выбрать стили, на которые их нужно заменить.

Описание элементов управления
Элемент | Описание
 | Диалог содержит вкладки, соответствующие типам выделенных объектов.
Символы | Содержит элементы управления, позволяющие изменить стиль точек.
Кривые | Содержит элементы управления, позволяющие изменить стиль кривых.
Штриховки | Содержит элементы управления, позволяющие изменить стиль штриховок.
Тексты | Содержит элементы управления, позволяющие изменить стиль текста.
Что заменять | Выберите из списка стиль, который необходимо заменить. Если требуется заменить стиль на единый для всех выделенных объектов данного типа, хотя перед этим они имели разные стили, выберите в списке вариант Для всех стилей.
 | В поле просмотра показан образец начертания заменяемого стиля.
Чем заменять | Список имеющихся в документе стилей. Вы можете выбрать из этого списка стиль для замены.
Кнопка (>>) | Позволяет выбрать стиль, отсутствующий в активном документе. После нажатия кнопки на экране появится диалог выбора стиля объекта.
Дополнительно на вкладке Штриховка |
Шаг Угол | Позволяют изменить значения параметров штриховки.
Цвет... | Позволяет выбрать цвет штриховки. После нажатия кнопки на экране появится диалог выбора цвета.
Область Полоса | Позволяют выбрать тип заполнения границ штриховки.
Ширина полосы | Позволяет задать ширину полосы заполнения. Поле доступно, если выбран вариант Полоса.
Применить к Выделенным объектам | Позволяет выбрать способ смены стиля. При выборе варианта Выделенным объектам стили заменяются у всех выделенных штриховок (вариант по умолчанию).
Телам | При выборе варианта Телам заменяются одновременно – стили выделенных штриховок; – стили невыделенных штриховок во всех ассоциативных видах для тех тел, стили которых попали в группу выделения. Выбор доступен, если выделена хотя бы одна штриховка, параметры которой получены из модели.
Не изменять стиль штриховки в случае вырождения Удалять штриховку в случае вырождения | Позволяют выбрать вариант отображения штриховки в случае ее вырождения при изменении стиля.
 | Стили (кроме стилей текста) отображаются в полях просмотра, что позволяет быстро подобрать нужный вариант замены.

После задания всех параметров для замены стилей нажмите кнопку ОК. Для выхода из диалога без замены стилей нажмите кнопку Отмена.


Диалог работы с наборами стилей

Позволяет подключить, создать новые или отредактировать уже имеющиеся наборы стилей (линий, текстов, штриховок и т.п.).

Этот диалог появляется на экране после нажатия кнопки Показать набор в диалоге Работа с наборами и библиотеками стилей или в диалоге выбора текущего стиля.

Описание элементов управления
Наименование | Описания
 | В списке отображаются имена существующих наборов стилей (линий, текстов и т.п.) для их указания и подключения.
Новый | Для создания нового набора стилей нажмите кнопку.
Переименовать | Чтобы изменить имя набора, выберите его из списка и нажмите кнопку.
Удалить | Для удаления набора выберите его из списка и нажмите кнопку.
Выбрать | Для закрытия диалога с подключением нужного набора нажмите кнопку.
Отмена | Для выхода без подключения набора нажмите кнопку.


Диалог установки параметров линии штриховки

Позволяет настроить параметры линии, входящей в состав пользовательского стиля штриховки.

Этот диалог появляется на экране после нажатия кнопки Добавить в группе Линии для штриховки диалога Создание нового стиля штриховки.

Описание элементов управления

Наименование

Описание

Выбор стиля линии

Стиль линии можно выбрать из перечня системных (допускаются стили основная, тонкая и утолщенная). Системные стили нельзя редактировать или удалять из списка.

Кроме того, можно создавать пользовательские стили линий, которые будут доступны только внутри данного стиля штриховки.

Внешний вид текущей линии отображается в окне просмотра.

Новый...

Для создания нового пользовательского стиля линии нажмите кнопку.

Редактировать...

Для редактирования пользовательского стиля выберите его из списка и нажмите кнопку.

Удалить

Чтобы удалить пользовательский стиль линии, выберите его из списка и нажмите кнопку. При удалении пользовательского стиля все линии данной штриховки, для которых применялся этот стиль, будут отрисовываться системным основным стилем линии.

Угол, гр.

Устанавливает угол наклона данной линии в штриховке (в градусах).

X

Задает координату X начальной точки линии относительно базовой точки штриховки. Отсчет выполняется в системе координат штриховки.

Y

Задает координату Y начальной точки линии относительно базовой точки штриховки. Отсчет выполняется в системе координат штриховки.

deltaX

Задает смещение следующей линии в штриховке относительно предыдущей. Отсчет выполняется по направлению линии.

deltaY

Задает смещение следующей линии в штриховке относительно предыдущей. Отсчет выполняется перпендикулярно направлению линии.

После настройки всех параметров линии нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


Диалог выбора стиля штриховки

Позволяет выбрать текущий стиль отрисовки штриховки.

Этот диалог появляется на экране после вызова команды Стиль штриховки... из контекстного меню при создании штриховки или выбора варианта Другой стиль... в раскрывающемся списке Стиль на вкладке Штриховка Панели свойств.

Описание элементов управления
Элемент | Описание
Системные Внедренные Библиотечные | Вкладки содержат следующие наборы стилей: – системные стили штриховки, доступные в любом документе, – стили штриховки, хранящихся непосредственно внутри документа или набора, если набор подключен, – стили, взятые в документ или набор из внешних библиотек. Стили в списках могут быть отсортированы по именам или по номерам. Чтобы изменить сортировку, щелкните мышью по заголовку нужного столбца. В заголовке столбца, по которому сортируются стили, отображается треугольник. Его положение показывает направление сортировки — по возрастанию или по убыванию. Выделенная в списке штриховка отображается в поле просмотра.
Показать набор... | Кнопка позволяет подключить созданный ранее набор стилей.
Показать библиотеку... | Кнопка позволяет подключить внешнюю библиотеку стилей.
Показать документ | Кнопка позволяет просмотреть список стилей, уже использованных в активном документе.
Новый... | Кнопка позволяет открыть диалог создания нового стиля штриховки.

Чтобы завершить выбор стиля штриховки, следует нажать кнопку Выбрать. Кнопка Отмена позволяет закрыть диалог, отказавшись от выбора.

Создать новый стиль или изменить параметры существующего можно в диалоге создания или редактирования стиля штриховки.


Диалог задания параметров линии мультилинии

Этот диалог появляется на экране после нажатия кнопки Добавить линию или Изменить линию в диалоге настройки параметров мультилинии.

Позволяет задать стиль и нужное смещение для линии умолчательного набора линий мультилинии при добавлении или изменении.

Описание элементов управления
Элемент | Описание
Таблица стилей линий | Содержит перечень системных стилей линий КОМПАС-3D. Стили в таблице могут быть отсортированы по именам или по номерам. Чтобы изменить сортировку, щелкните мышью по заголовку нужного столбца. В заголовке столбца, по которому сортируются стили, отображается треугольник. Его положение показывает направление сортировки — по возрастанию или по убыванию. Образец стиля, название которого выделено в списке, отображается в поле просмотра. Установите для линии нужный стиль, выделив его в списке.
Смещение | Поле смещения линии относительно базовой линии. Введите или задайте счетчиком нужное смещение.

Завершив настройку параметров линии, нажмите кнопку ОК.

Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


Диалог выбора стиля линии

Позволяет выбрать стиль линии для отрисовки настраиваемого объекта.

Описание элементов управления

Элемент

Описание

Системные

Внедренные

Библиотечные

При переключении между закладками отображается список системных (всегда доступных в любом документе) стилей линии либо список стилей линий, хранящихся непосредственно внутри документа (или набора, если он подключен), либо список стилей, взятых в документ или набор из внешних библиотек.

Стили в списках могут быть отсортированы по именам или по номерам. Чтобы изменить сортировку, щелкните мышью по заголовку нужного столбца. В заголовке столбца, по которому сортируются стили, отображается треугольник. Его положение показывает направление сортировки — по возрастанию или по убыванию.

Выбрать

После выбора нужного стиля нажмите кнопку.

Отмена

Нажмите эту кнопку для выхода из диалога без смены стиля линии объекта.

Менеджер стилей

Кнопка для настройки списка стилей линий документа. После ее нажатия на экране появляется Менеджер стилей линий, с помощью которого вы можете создать в документе новые стили, отредактировать имеющиеся внедренные стили или добавить стили из библиотек и наборов.

Для удобства поиска и выбора внешний вид стиля отображается в специальном окне просмотра.


Диалог выбора стиля линии

Позволяет установить стиль для отрисовки линии.

Диалог содержит таблицу системных стилей линий КОМПАС-3D.

Стили в списке могут быть отсортированы по именам или по номерам. Чтобы изменить сортировку, щелкните мышью по заголовку нужного столбца. В заголовке столбца, по которому сортируются стили, отображается треугольник. Его положение показывает направление сортировки — по возрастанию или по убыванию.

Образец стиля, название которого выделено в списке, отображается в поле просмотра.

Выделив в списке нужный стиль, нажмите кнопку Выбрать, чтобы установить для линии указанный стиль. Чтобы отказаться от изменения стиля линии, нажмите кнопку Отмена.


Диалог выбора стиля текста

Этот диалог появляется на экране после вызова команды Формат — Стиль... или после выбора строки Другой стиль... из списка стилей текста.

Позволяет установить текущий стиль текста.

Описание элементов управления

Наименование

Описание

Системные/

Внедренные/

Библиотечные

При переключении между вкладками отображается список системных (всегда доступных в любом документе) стилей либо список стилей, хранящихся непосредственно внутри документа (или набора, если он подключен), либо список стилей, взятых в документ или набор из внешних библиотек.

Стили в списках могут быть отсортированы по именам или по номерам. Чтобы изменить сортировку, щелкните мышью по заголовку нужного столбца. В заголовке столбца, по которому сортируются стили, отображается треугольник. Его положение показывает направление сортировки — по возрастанию или по убыванию.

Набор...

Для подключения созданного ранее набора стилей нажмите кнопку.

Библиотеку...

Для подключения внешней библиотеки стилей нажмите кнопку.

Документ

Чтобы просмотреть список стилей, уже использованных в активном документе, нажмите кнопку.

Новый...

Чтобы перейти к диалогу создания нового стиля, нажмите кнопку.

Выбрать

После установки курсора на нужный стиль нажмите кнопку.

Отмена

Для выхода из диалога без изменения текущего стиля нажмите кнопку.

Для изменения параметров уже существующих стилей текстов используйте команду Сервис — Библиотеки стилей, типов, оформлений и основных надписей — Стили текстов....


Диалог выбора квалитета

Позволяет назначить нужный квалитет для параметра операции и проставляемого размера или подобрать квалитет по предельным отклонениям.

Описание элементов управления
Наименование | Описание
Предпочтительные | В этом поле отображается список предпочтительных для использования квалитетов.
Значение | В этом справочном поле отображается значение размера, вычисленное автоматически или заданное пользователем вручную. Поле недоступно для редактирования.
Отклонения: Верхнее Нижнее | В этих справочных полях отображаются значения текущих отклонений размера, вычисленных по квалитету или заданных пользователем вручную. Поля недоступны для редактирования.
Система | Выберите, в какой системе будет выполняться образмеривание (в системе отверстия или в системе вала).
Подобрать квалитет | Для того чтобы выполнить подбор квалитета, введите требуемые значения предельных отклонений размера в полях Верхнее и Нижнее. После этого нажмите кнопку Подобрать квалитет. В списках для выбора останутся наименования только тех квалитетов, которые соответствуют установленным ограничениям.

После завершения выбора нужного квалитета нажмите кнопку ОК. Для выхода из диалога без назначения нового квалитета нажмите кнопку Отмена.


Диалог выбора квалитета

Позволяет назначить нужный квалитет для параметра операции и проставляемого размера или подобрать квалитет по предельным отклонениям.

Описание элементов управления
Наименование | Описание
Предпочтительные | В этом поле отображается список предпочтительных для использования квалитетов.
Основные | В этом поле отображается список основных квалитетов.
Значение | В этом справочном поле отображается значение размера, вычисленное автоматически или заданное пользователем вручную. Поле недоступно для редактирования.
Отклонения: Верхнее Нижнее | В этих справочных полях отображаются значения текущих отклонений размера, вычисленных по квалитету или заданных пользователем вручную. Поля недоступны для редактирования.
Система | Выберите, в какой системе будет выполняться образмеривание (в системе отверстия или в системе вала).
Подобрать квалитет | Для того чтобы выполнить подбор квалитета, введите требуемые значения предельных отклонений размера в полях Верхнее и Нижнее. После этого нажмите кнопку Подобрать квалитет. В списках для выбора останутся наименования только тех квалитетов, которые соответствуют установленным ограничениям.

После завершения выбора нужного квалитета нажмите кнопку ОК. Для выхода из диалога без назначения нового квалитета нажмите кнопку Отмена.


Диалог выбора квалитета

Позволяет назначить нужный квалитет для параметра операции и проставляемого размера или подобрать квалитет по предельным отклонениям.

Описание элементов управления
Наименование | Описание
Предпочтительные | Поле содержит список предпочтительных для использования квалитетов.
Основные | Поле содержит список основных квалитетов.
Дополнительные | Поле содержит список дополнительных квалитетов.
Значение | Справочное поле содержит номинальное значение размера. Поле недоступно для редактирования.
Отклонения: Верхнее Нижнее | Справочные поля содержат значения текущих отклонений размера. Эти отклонения могут быть автоматически вычислены по квалитету или заданы пользователем вручную. Поля недоступны для редактирования.
Показать квалитеты для | Группа опций позволяет указать, в какой системе будет выполняться назначение допуска (в системе отверстия или в системе вала).
Подбор квалитета | Группа элементов позволяет подобрать квалитет по заданным предельным отклонениям размера. Введите требуемые значения предельных отклонений размера в поля Верхнее и Нижнее и нажмите кнопку Подобрать. В списках для выбора останутся наименования только тех квалитетов, которым соответствует указанный диапазон отклонений.

После завершения выбора нужного квалитета нажмите кнопку ОК. Для выхода из диалога без назначения нового квалитета нажмите кнопку Отмена.


Диалог свойств компонента вида

Этот диалог появляется на экране после вызова команды Свойства компонента....

Описание элементов управления

Наименование

Описание

Наименование

В этом справочном поле отображается наименование модели, являющейся компонентом вида.

Обозначение

В этом справочном поле отображается обозначение модели, являющейся компонентом вида.

Файл-источник

В этом справочном поле отображается путь к файлу модели, изображение которой содержится в виде.

Создавать объекты спецификации

Если вы работаете с КОМПАС-спецификацией, то включите эту опцию для формирования в чертеже объекта (объектов) спецификации, соответствующего выбранному компоненту вида. Эти объекты должны быть сформированы в компоненте при его создании.

Если компонент — деталь, то в чертеж передается имеющийся в ней объект спецификации.

Если компонент — сборка, то в чертеж передаются все внутренние объекты спецификации этой сборки.

Включение/отключение создания объектов спецификации возможно только для компонентов первого уровня, т.е. для деталей и сборок, непосредственно подчиненных виду в Дереве чертежа.

По умолчанию опция Создавать объекты спецификации включена, если на данном рабочем месте включена работа со спецификацией, и выключена в противном случае.


Не прочитан файл компонента

Этот диалог появляется, если при открытии модели невозможно прочитать модель, вставленную в открываемую в качестве компонента (в том числе из библиотеки).

В окне диалога показаны имена файлов открываемой модели и компонента, который невозможно прочитать. Файл может отсутствовать или оказаться поврежденным.

Выберите нужное действие, нажав одну из кнопок диалога. При необходимости перед нажатием кнопки Заменить или Игнорировать включите опцию Применить для всех последующих.

– Кнопка Заменить позволяет использовать вместо непрочитанного другой файл или указать новый путь к файлу компонента. После нажатия этой кнопки на экране появляется диалог открытия файла, в котором нужно указать заменяющую модель. Если включена опция Применить для всех последующих, то каждая следующая непрочитанная модель автоматически разыскивается в той папке, где находится последняя указанная для замены модель. При положительном результате поиска найденная модель вставляется взамен непрочитанной, происходит переход к следующей. При отрицательном результате на экране появляется диалог открытия файла.

Чтобы подтвердить замену компонентов, сохраните модель после открытия. В противном случае при последующем открытии модели вновь появится сообщение о том, что не прочитан файл компонента.

– Кнопка Игнорировать позволяет открыть модель без непрочитанного компонента. Сам этот компонент и все производные от него объекты (например, сопряжения, в которых он участвует) отмечаются в Дереве построения как ошибочные. В то же время информация о вставленной модели сохраняется в модели, и впоследствии, при условии наличия файла компонента, модель может быть отображена в прежнем виде. В отсутствие файла компонента при открытии модели по-прежнему будет выдаваться сообщение о том, что файл не прочитан.

– Кнопка Отказ от чтения позволяет прервать открытие модели.

Компоненты из Справочника Стандартные Изделия могут быть не найдены потому, что текущий путь к хранилищу моделей отличается от пути, записанного в открываемой модели (например, из-за того, что она была создана на другом рабочем месте). В этом случае можно игнорировать ненайденные компоненты, а после того, как модель откроется, отредактировать пути (т.е. обновить ссылки на модели) средствами Справочника Стандартные изделия.

Если открываемая модель включает компоненты, которые являются исполнениями одной и той же модели, то для каждого из них будет появляться диалог Не прочитан файл компонента, содержащий имя одного и того же файла — источника данных компонентов.

Вы можете выполнить замену ненайденных исполнений модели вручную или автоматически.

Для замены вручную при каждом появлении диалога требуется нажимать кнопку Заменить и указывать файл и нужное исполнение в появившемся диалоге открытия файла.

Чтобы заменить все исполнения автоматически, включите опцию Применить для всех последующих, нажмите кнопку Заменить. В появившемся диалоге открытия файла укажите файл модели с исполнениями, не выбирая исполнения из списка. Компоненты открываемой модели будут автоматически заменены соответствующими исполнениями из выбранного файла. Если требуется заменить все компоненты одним конкретным исполнением, то после указания файла модели выберите нужное исполнение из списка исполнений.

Аналогично выполняется замена ненайденных компонентов, входящих в разные исполнения одной и той же сборочной модели.


Компонент содержит рекурсивную вложенность

Это предупреждение выдается при попытке включить в модель компонент, ссылающийся на эту модель, или при попытке открыть КОМПАС-документ, который содержит ссылку на себя самого (причем эта ссылка может быть косвенной).

Как исправить эту ошибку

– Нажмите кнопку Заменить, если хотите разместить во вставленной модели на месте «кольцевой» ссылки ссылку на какую-либо другую модель, устранив тем самым рекурсивную вложенность. В появившемся стандартном диалоге открытия файлов выберите документ-модель, который должен заменить вставку, вызывающую конфликт.

– Или нажмите кнопку Удалить вставки, если хотите удалить в документе «кольцевую» ссылку, устранив тем самым рекурсивную вложенность.

– Или нажмите кнопку Отказ от чтения для того, чтобы отказаться от чтения документа модели.


Параметры создания таблицы

Этот диалог появляется после вызова команды Создать из графического фрагмента... при работе с диалогом создания новой таблицы.

В нем можно назначить параметры для создаваемой из графического фрагмента таблицы.

Описание элементов управления

Наименование

Описание

Использовать привязку к сетке

Включите эту опцию, если значения габаритов ячеек должны быть дискретными (кратными какому-либо числу). В этом случае при формировании таблицы габариты ячеек изображенной во фрагменте таблицы будут округлены до ближайшего кратного указанному шагу числа.

Если опция выключена, габариты ячеек получившейся таблицы будут совпадать с габаритами ячеек в графическом фрагменте.

Шаг сетки для привязки габаритов ячеек

Эта группа опций доступна, если включена опция Использовать привязку по сетке. Вы можете задать значение шага по горизонтали и по вертикали. Габариты ячеек сформированной таблицы будут кратны указанным значениям.

Стиль текста для незаполненных ячеек таблицы

В этом поле отображается имя стиля, назначенного для текста в незаполненных во фрагменте ячейках таблицы (стиль текста заполненных ячеек при формировании таблицы из фрагмента сохраняется). Для назначения другого стиля текста нажмите кнопку Изменить..., а затем в появившемся диалоге выберите нужный стиль или создайте новый.

После задания всех параметров нажмите кнопку ОК для создания таблицы. Для выхода из диалога без создания новой таблицы нажмите кнопку Отмена.


Диалог настройки свойств библиотеки документов

Этот диалог появляется на экране после вызова команды Добавить описание библиотеки документов из контекстного меню вкладки Библиотеки КОМПАС в окне Менеджера библиотек.

В диалоге можно настроить свойства новой библиотеки моделей или фрагментов.

Описание элементов управления
Наименование | Описание
Название библиотеки | В этом поле вы можете ввести название библиотеки в Менеджере.
Имя файла библиотеки | В этом поле отображается полное имя файла библиотеки.

После настройки свойств библиотеки нажмите кнопку ОК диалога для ее создания. Чтобы отказаться от добавления библиотеки, нажмите кнопку Отмена.


Диалог ввода размерной надписи углового размера

Этот диалог появляется на экране после щелчка мышью в поле Текст на вкладке Размер Панели свойств или вызова команды Текст надписи... из контекстного меню при создании углового размера.

Позволяет сформировать нужный текст размерной надписи при вводе углового размера или дополнить текст, автоматически предложенный системой.

Описание элементов управления

Наименование

Описание

Текст до

Поле для ввода текста, предшествующего основному содержанию размерной надписи. Для вызова пользовательского меню с возможными вариантами текста дважды щелкните мышью в поле ввода.

Значение

В этом поле отображается автоматически вычисленное системой значение размера. При необходимости вы можете ввести другое значение вручную. Для простановки значков градусов, минут и секунд используйте соответствующие кнопки рядом с полем ввода.

Авто

Опция управляет способом определения значения размера. По умолчанию опция включена. При этом значение размера вычисляется автоматически. После ручного ввода значения (в том числе из пользовательского меню) опция автоматически отключается. Чтобы восстановить автоматически определенное значение, вновь включите опцию Авто.

Точность отображения автоматически вычисленного значения можно задать в диалоге настройки точности размерных надписей.

Формат отображения

Раскрывающийся список позволяет выбрать формат отображения номинального значения угла в размерной надписи текущего размера.

Вариант Градусы, минуты, секунды позволяет отобразить значение угла в формате ХХ°ХХ'ХХ", а вариант Десятичная система — в формате ХХ,ХХХ°.

Текст после

Поле для ввода текста, следующего за основным содержанием размерной надписи. Для вызова пользовательского меню с возможными вариантами текста дважды щелкните мышью в поле ввода.

Текст под

Поле для ввода текста, который будет располагаться под размерной надписью. Для вызова пользовательского меню с возможными вариантами текста дважды щелкните мышью в поле ввода.

Поле просмотра

Поле позволяет просмотреть текущий внешний вид размерной надписи (за исключением текста под размерной надписью). Недоступно для ручного ввода.

Использовать по умолчанию

Если опция включена, то текущие настройки сохраняются и используются при создании следующих размеров данного типа до конца сеанса работы.

Если опция отключена, то текущие настройки распространяются только на текущий (создаваемый или редактируемый) размер. Новые размеры создаются в соответствии с настройкой, произведенной в диалоге задания параметров допусков и предельных значений и в диалоге задания допусков по умолчанию.

Допуск

Опция позволяет управлять назначением допуска на размер. Если опция включена, размер может иметь допуск. При этом в диалоге доступны элементы назначения допуска. При отключенной опции эти элементы недоступны.

Отклонения, Пределы

Группа элементов позволяет добавить в размерную надпись предельные отклонения размера или его предельные значения.

Предельные отклонения добавляются, если выбран вариант Отклонения, а предельные значения размера, — если выбран вариант Пределы.

При вводе отклонений доступна кнопка ±. Она позволяет сделать отклонения равными. Перед значением верхнего отклонения ставится знак «+», а перед значением нижнего — знак «-».

Отобразить

Опция управляет отображением отклонений или предельных значений в размерной надписи. При включенной опции отклонения (предельные значения) отображаются в размерной надписи, при отключенной — нет.

Номинальный (в рамке)

Опция позволяет отрисовать рамку вокруг той части размерной надписи, которая содержит значение размера и отклонения или пределы.

Подчеркнуть

Опция позволяет включить подчеркнутое отображение той части размерной надписи, которая содержит значение размера и отклонения или пределы.

Пределы в одну строку

Опция позволяет отобразить предельные значения размера не одно под другим, а друг за другом через дефис. Опция доступна при включенной опции Пределы.

Размер в скобках

Группа опций позволяет отобразить в скобках ту часть размерной надписи, которая содержит значение размера и отклонения или пределы. Включите опцию, соответствующую нужной форме скобок (круглые или квадратные).

Указанные элементы заключаются в скобки вместе с рамкой и подчеркиванием, если они есть.

Выравнивание текста

Раскрывающийся список позволяет выбрать способ расположения отклонений или предельных значений размера относительно его номинального значения. Выберите нужный вариант расположения из списка.

После установки нужных значений параметров оформления размерной надписи нажмите кнопку ОК. Кнопка Отмена позволяет закрыть диалог без сохранения изменений.

Если для размера созданы переменные предельных отклонений и ячейка Выражение Окна переменных заполнена хотя бы для одной из них, в диалоге недоступны поля задания предельных отклонений/предельных значений размера.

При редактировании проекционного размера часть элементов управления диалога недоступна. Соответствующие параметры размерной надписи передаются в чертеж из модели, поэтому их ручное изменение невозможно.

Смотрите также

Ввод размерной надписи


Диалог ввода текста под размерной надписью

Этот диалог появляется на экране

– после вызова команды Текст под... из контекстного меню в поле Текст на Панели свойств в графических документах;

– при редактировании размера в окне Свойства — после щелчка мышью в ячейке значения свойства Текст под.

В диалоге можно ввести или отредактировать одну или несколько дополнительных строк размерной надписи, которые будут размещены под размерной линией.

Для вызова пользовательского меню с вариантами текстов под размерной линией дважды щелкните мышью в поле ввода.

Подробнее о пользовательских меню при вводе текста...

После завершения ввода текста строк нажмите кнопку ОК. Для выхода из диалога без изменений текста последующих строк нажмите кнопку Отмена.


Диалог ввода размерной надписи линейного, диаметрального и радиального размеров

Этот диалог появляется на экране после щелчка мышью в поле Текст на вкладке Размер Панели свойств или вызова команды Текст надписи... из контекстного меню при создании/редактировании линейного, диаметрального или радиального размера.

Позволяет сформировать нужный текст размерной надписи или дополнить текст, автоматически предложенный системой.

Описание элементов управления

Наименование

Описание

Текст до

Поле для ввода текста, предшествующего основному содержанию размерной надписи. Для вызова пользовательского меню с возможными вариантами текста дважды щелкните мышью в поле ввода.

Список символов

Раскрывающийся список позволяет выбрать нужный символ для простановки перед размерным числом. Вы можете выбрать символ диаметра, квадрата, радиуса, обозначения метрической резьбы или вариант Нет символа.

Значение

В этом поле отображается автоматически вычисленное системой значение размера. При необходимости вы можете ввести другое значение вручную. Для выбора значения из пользовательского меню нажмите кнопку Значение.

Подробнее о пользовательских меню при вводе текста...

Авто

Опция управляет способом определения значения размера. По умолчанию опция включена. При этом значение размера вычисляется автоматически. После ручного ввода значения (в том числе из пользовательского меню) опция автоматически отключается. Чтобы восстановить автоматически определенное значение, вновь включите опцию Авто.

Точность отображения автоматически вычисленного значения можно задать в диалоге настройки точности размерных надписей.

Единица измерения

Поле позволяет ввести текст для обозначения единиц измерения проставляемого размера. Текст отрисовывается в размерной надписи сразу после предельных отклонений. Для вызова пользовательского меню с вариантами названий единиц измерения дважды щелкните мышью в поле ввода.

Текст после

Поле для ввода текста, следующего за основным содержанием размерной надписи. Для вызова пользовательского меню с возможными вариантами текста дважды щелкните мышью в поле ввода.

х45°

Кнопка позволяет добавить в текст, следующий за значением размера, строку х45°.

Текст под

Поле для ввода текста, который будет располагаться под размерной надписью. Для вызова пользовательского меню с возможными вариантами текста дважды щелкните мышью в поле ввода.

Поле просмотра

Поле позволяет просмотреть текущий внешний вид размерной надписи (за исключением текста под размерной надписью). Недоступно для ручного ввода.

Использовать по умолчанию

Если опция включена, то текущие настройки сохраняются и используются при создании следующих размеров данного типа до конца сеанса работы.

Если опция отключена, то текущие настройки распространяются только на текущий (создаваемый или редактируемый) размер. Новые размеры создаются в соответствии с настройкой, произведенной в диалоге параметров допусков и предельных значений и в диалоге настройки допусков по умолчанию.

Допуск

Опция позволяет управлять назначением допуска на размер. Если опция включена, размер может иметь допуск. При этом в диалоге доступны элементы назначения допуска. При отключенной опции эти элементы недоступны.

Квалитет...

Кнопка позволяет задать квалитет с помощью специального диалога Выбор квалитета. Выбранный квалитет отображается в поле, расположенном справа от кнопки. Данное поле доступно для ручного ввода.

Отобразить

Опция управляет отображением квалитета в размерной надписи. При включенной опции квалитет отображается в размерной надписи, при отключенной — нет.

Если опция недоступна, это означает, что выбран такой номер квалитета, для которого отключена вставка в размерную надпись. Номер, начиная с которого квалитет не вносится в надпись, задается в диалоге настройки точности размеров.

Отклонения,

Пределы

Группа элементов позволяет добавить в размерную надпись предельные отклонения размера или его предельные значения.

Предельные отклонения добавляются, если выбран вариант Отклонения, а предельные значения размера, — если выбран вариант Пределы.

Отклонения или предельные значения размера вычисляются автоматически в соответствии с выбранным квалитетом и номинальным значением размера.

При необходимости вы можете ввести значения отклонений или пределов вручную. При этом поле Квалитет очищается.

При вводе отклонений доступна кнопка ±. Она позволяет сделать отклонения равными. Перед значением верхнего отклонения ставится знак «+», а перед значением нижнего — знак «-».

Отобразить

Опция управляет отображением отклонений или предельных значений в размерной надписи. При включенной опции отклонения (предельные значения) отображаются в размерной надписи, при отключенной — нет.

Замечание...

Номинальный (в рамке)

Опция позволяет отрисовать рамку вокруг той части размерной надписи, которая содержит символ, значение размера, квалитет и отклонения (пределы).

Подчеркнуть

Опция позволяет включить подчеркнутое отображение той части размерной надписи, которая содержит символ, значение размера, квалитет и отклонения (пределы).

Пределы в одну строку

Опция позволяет отобразить предельные значения размера не одно под другим, а друг за другом через дефис. Опция доступна при включенной опции Пределы.

Размер в скобках

Группа опций позволяет отобразить в скобках ту часть размерной надписи, которая содержит символ, значение размера, квалитет и отклонение. Включите опцию, соответствующую нужной форме скобок (круглые или квадратные).

Указанные элементы заключаются в скобки вместе с рамкой и подчеркиванием, если они есть.

Выравнивание текста

Раскрывающийся список позволяет выбрать способ расположения отклонений или предельных значений размера относительно его номинального значения. Выберите нужный вариант расположения из списка.

После установки нужных значений параметров оформления размерной надписи нажмите кнопку ОК. Кнопка Отмена позволяет закрыть диалог без сохранения изменений.

Если для размера созданы переменные предельных отклонений и ячейка Выражение Окна переменных заполнена хотя бы для одной из них, в диалоге недоступны следующие элементы управления: кнопка Квалитет, поле значения квалитета, опция, управляющая отображением квалитета, а также поля предельных отклонений/предельных значений размера.

При редактировании проекционного размера часть элементов управления диалога недоступна. Соответствующие параметры размерной надписи передаются в чертеж из модели, поэтому их ручное изменение невозможно.

Смотрите также

Ввод размерной надписи


Невозможность пересчета предельных значений размеров при изменении геометрии. Замечание

При включении отображения в размерной надписи предельных значений ассоциативного размера обратите внимание на следующую особенность.

Если для размера выбран квалитет, то предельные значения этого размера вычисляются автоматически. В этом случае при изменении геометрического объекта, к которому проставлен размер, предельные значения автоматически пересчитываются.

Если в дальнейшем выбранный квалитет удаляется (остаются только предельные значения размера) или предельные значения задаются вручную, то при изменении геометрического объекта, к которому проставлен размер, автоматический пересчет предельных значений не выполняется.


Диалог ввода размерной надписи размера высоты

Этот диалог появляется на экране после вызова команды Текст надписи... из контекстного меню при создании размера высоты.

Позволяет сформировать нужный текст надписи для размера высоты.

Описание элементов управления
Наименование | Описание
Значение | В этом поле вы можете ввести значение размера высоты. Если проставляется размер высоты для вида спереди и разреза, система автоматически вычисляет величину размера относительно заданной нулевой точки.
Кнопка Значение | Для выбора значения из пользовательского меню нажмите кнопку. Подробнее о пользовательских меню при вводе текста...
Авто | Если нужно задать значение размера вручную, выключите опцию.
Размер в рамке | Включите опцию, чтобы размерная надпись отображалась в рамке.
Подчеркнуть | Включите опцию, чтобы размерная надпись была подчеркнутой.
Использовать по умолчанию | Активизируйте эту опцию, чтобы сделанные настройки использовались при формировании остальных размерных надписей этого типа в текущем сеансе работы.

Внешний вид размерной надписи показывается в окне просмотра.

После установки нужного оформления размерной надписи нажмите кнопку ОК. Для выхода из диалога без изменения надписи нажмите кнопку Отмена.


Диалог ввода текста перед размерной надписью

Этот диалог появляется на экране

– после вызова команды Текст до... из контекстного меню в поле Текст на Панели свойств в графических документах;

– при редактировании размера в окне Свойства — после щелчка мышью в ячейке значения свойства Текст до.

В диалоге можно ввести или отредактировать текст, предшествующий основному содержанию размерной надписи (префикс).

Для вызова пользовательского меню с вариантами текстов, предшествующих размерной надписи, дважды щелкните мышью в поле ввода.

Подробнее о пользовательских меню при вводе текста...

После завершения ввода текста префикса размерной надписи нажмите кнопку ОК. Для выхода из диалога без изменения текста префикса нажмите кнопку Отмена.


Диалог ввода текста после размерной надписи

Этот диалог появляется на экране

– после вызова команды Текст после... из контекстного меню в поле Текст на Панели свойств в графических документах;

– при редактировании размера в окне Свойства — после щелчка мышью в ячейке значения свойства Текст после.

В диалоге можно ввести или отредактировать текст, следующий за основным содержанием размерной надписи (суффикс).

Для вызова пользовательского меню с вариантами текстов, следующих за размерной надписью, дважды щелкните мышью в поле ввода.

Подробнее о пользовательских меню при вводе текста...

После завершения ввода текста суффикса размерной надписи нажмите кнопку ОК. Для выхода из диалога без изменения текста суффикса нажмите кнопку Отмена.


Диалог ввода символа в размерной надписи

Этот диалог появляется на экране после вызова команды Символ... из контекстного меню в поле Текст на Панели свойств при простановке/редактировании линейного, диаметрального или радиального размера.

Диалог позволяет выбрать символ для внесения его в текст размерной надписи перед значением размера.

Из раскрывающегося списка Символ выберите нужный вариант символа. Возможна простановка символа диаметра, квадрата, радиуса или обозначения метрической резьбы. Если символ в размерной надписи отображать не требуется, выберите вариант Нет символа.

В поле справа от раскрывающегося списка отображается текущий вид размерной надписи. Это поле недоступно для ручного ввода.

После выбора символа нажмите кнопку ОК. Кнопка Отмена позволяет закрыть диалог без сохранения изменений.


Диалог ввода единиц измерения

Этот диалог появляется на экране

– после вызова команды Единицы измерения... из контекстного меню в поле Текст на Панели свойств в графических документах,

– при редактировании размера в окне Свойства — после щелчка мышью в ячейке значения свойства Единицы измерения.

В диалоге можно ввести или отредактировать текст обозначения единиц измерения проставляемого размера.

Для вызова пользовательского меню с вариантами названий единиц измерения дважды щелкните мышью в поле ввода.

Подробнее о пользовательских меню при вводе текста...

Название единиц измерения будет отрисовано в размерной надписи сразу после предельных отклонений.

После завершения ввода текста нажмите кнопку ОК. Для выхода из диалога без изменений нажмите кнопку Отмена.


Диалог Значение размера(для угловых величин)

Диалог Значение размера
(для угловых величин)

Позволяет ввести значение размера в текст размерной надписи. Если в диалоге назначения текста размерной надписи была включена опция Авто, она автоматически отключается.


Диалог Значение размера(для линейных размеров)

Диалог Значение размера
(для линейных размеров)

Позволяет ввести значение размера в текст размерной надписи. Если в диалоге назначения текста размерной надписи была включена опция Авто, она автоматически отключается.


Диалог Назначить допуск(для угловых величин)

Диалог Назначить допуск
(для угловых величин)

Позволяет назначить или изменить допуск:

– на значение параметра операции, выраженного в угловых величинах (далее в этом разделе под «параметром» будет подразумеваться параметр операции, выраженный в угловых величинах),

– на угловой размер эскиза или графического документа.

Допуск можно назначить как при работе с моделью, так и в Окне переменных при работе с переменными, созданными для указанных выше параметра операции и размера.

Вызов диалога при работе с моделью...
Вызов диалога при работе в Окне переменных...

Работа в диалоге: основные действия; особенности...

Общие сведения о допусках...

Описание элементов управления

Элемент

Описание

Допуск

Включение опции означает, что размер или значение параметра имеет допуск. При этом в диалоге доступны элементы назначения допуска. При отключенной опции размер или значение параметра не имеет допуска, элементы назначения допуска недоступны. Обратите внимание на то, что при отключении опции Допуск выбранные отклонения или пределы удаляются. Кроме того, отключается опция Номинальный (в рамке) (описание опции приведено ниже). Последующее включение опции Допуск не восстанавливает удаленные данные и состояние указанной опции.

Отклонения,
Пределы

Группа элементов, позволяющая задать предельные отклонения значения или его пределы.

Предельные отклонения добавляются, если выбран вариант Отклонения, а пределы значения — если выбран вариант Пределы.

Введите вручную нужные отклонения или пределы.

При вводе отклонений доступна кнопка ±. Она позволяет сделать отклонения равными. Перед значением верхнего отклонения ставится знак «+», а перед значением нижнего — знак «-».

Для простановки значков градусов, минут и секунд используйте соответствующие кнопки рядом с полем ввода отклонений или пределов.

Отобразить

Опция управляет отображением отклонений или предельных значений в размерной надписи размеров эскизов и операций.

При включенной опции отклонения (предельные значения) отображаются в размерной надписи, при отключенной — нет.

Номинальный (в рамке)

Опция позволяет отрисовать рамку вокруг той части размерной надписи размера эскиза или операции, которая содержит значение размера и отклонения или пределы. При включении этой опции автоматически отключается отображение отклонений или пределов. При необходимости их можно тут же включить вновь.

После выполнения всех необходимых действий в диалоге закройте его, нажав кнопку ОК. Для выхода из диалога без назначения нового допуска нажмите кнопку Отмена.

Если для размера или параметра операции созданы переменные предельных отклонений и ячейка Выражение Окна переменных заполнена хотя бы для одной из них, в диалоге недоступны поля задания предельных отклонений/предельных значений размера.


Диалог Назначить допуск(для линейных величин)

Диалог Назначить допуск
(для линейных величин)

Позволяет назначить или изменить допуск:

– на значение параметра операции, выраженного в линейных величинах (далее в этом разделе под «параметром» будет подразумеваться параметр операции, выраженный в линейных величинах),

– на линейный, диаметральный или радиальный размер эскиза или графического документа.

Допуск можно назначить как при работе с моделью, так и в Окне переменных при работе с переменными, созданными для указанных выше параметра операции и размера.

Вызов диалога при работе с моделью...
Вызов диалога при работе в Окне переменных...

Работа в диалоге: основные действия; особенности...

Общие сведения о допусках...

Описание элементов управления

Элемент

Описание

Допуск

Включение опции означает, что размер или значение параметра имеет допуск. При этом в диалоге доступны элементы назначения допуска. При отключенной опции размер или значение параметра не имеет допуска, элементы назначения допуска недоступны.

Обратите внимание на то, что при отключении опции Допуск выбранные квалитет и отклонения (пределы) удаляются. Кроме того, отключаются опции Включить и Номинальный (в рамке) (описание опций приведено ниже). Последующее включение опции Допуск не восстанавливает удаленные данные и состояние указанных опций.

Квалитет...

Кнопка позволяет задать квалитет с помощью специального диалога Выбор квалитета. Выбранный квалитет отображается в поле, расположенном справа от кнопки. Данное поле доступно для ручного ввода.

Квалитет, заданный для размера эскиза или графического документа, сохраняется в системе и используется при назначении допусков на вновь созданные размеры. Удаление квалитета из поля также сохраняется в системе.

Отобразить

Опция управляет отображением квалитета в размерной надписи размера эскиза или операции.

Подробнее о размерах эскизов и операций...

При включенной опции квалитет отображается в размерной надписи, при отключенной — нет.

Опция недоступна, если выбран такой номер квалитета, для которого отключена вставка в размерную надпись. Номер, начиная с которого квалитет не вносится в надпись, задается в диалоге настройки точности размеров.

Отклонения,
Пределы

Группа элементов, позволяющая задать предельные отклонения значения или его пределы.

Предельные отклонения добавляются, если выбран вариант Отклонения, а пределы значения — если выбран вариант Пределы.

Отклонения или предельные значения значения вычисляются автоматически в соответствии с выбранным квалитетом и номинальным значением размера.

При необходимости вы можете ввести значения отклонений или пределов вручную. При этом поле Квалитет очищается.

При вводе отклонений доступна кнопка ±. Она позволяет сделать отклонения равными. Перед значением верхнего отклонения ставится знак «+», а перед значением нижнего — знак «-».

Отобразить

Опция управляет отображением отклонений или предельных значений в размерной надписи размеров эскизов и операций.

При включенной опции отклонения (предельные значения) отображаются в размерной надписи, при отключенной — нет.

Замечание...

Номинальный (в рамке)

Опция позволяет отрисовать рамку вокруг той части размерной надписи размера эскиза или операции, которая включает символ, значение размера, квалитет и отклонения (пределы). При включении этой опции автоматически отключается отображение квалитета и отклонений (пределов). При необходимости их можно тут же включить вновь.

После выполнения всех необходимых действий в диалоге закройте его, нажав кнопку ОК. Для выхода из диалога без назначения нового допуска нажмите кнопку Отмена.


Диалог Значение и допуск(для угловых величин)

Диалог Значение и допуск
(для угловых величин)

Позволяет задать значение и назначить допуск:

– для параметра операции, выраженного в угловых величинах,

– для углового размера эскиза или графического документа.

Диалог вызывается при работе с переменными указанных выше параметра и размера, или со свойствами, созданными из этих переменных.

Способы вызова диалога:

– в Таблице изменяемых переменных экземпляров массива и в Менеджере документа (при работе с исполнениями модели):

• командой Назначить допуск контекстного меню ячейки переменной,

• при нажатой кнопке Отображать индивидуальные допуски — нажатием кнопки с многоточием в ячейке переменной, двойным щелчком мышью по этой ячейке или указанной выше командой контекстного меню,

– в Редакторе свойств — командой Назначить допуск контекстного меню ячейки свойства, созданного из переменной,

– на панели Список свойств при редактировании свойств модели или исполнения модели — командой Назначить допуск контекстного меню ячейки свойства, созданного из переменной (строка, содержащая данную ячейку, должна быть выделена).

Для задания значения параметра/размера используется поле Значение. Нужное значение вводится в это поле.

Для назначения допуска используются элементы, аналогичные элементам диалога Назначить допуск.

После выполнения всех необходимых действий в диалоге, нажмите кнопку ОК. Кнопка Отмена позволяет закрыть диалог, отказавшись от изменений.

Смотрите также

Задание значения переменной экземпляра массива

Назначение допусков при работе с переменными в исполнениях

Задание значений свойств, созданных из переменных


Диалог Значение и допуск(для линейных величин)

Диалог Значение и допуск
(для линейных величин)

Позволяет задать значение и назначить допуск:

– для параметра операции, выраженного в линейных величинах,

– для линейного, диаметрального или радиального размера эскиза или графического документа.

Диалог вызывается при работе с переменными указанных выше параметров и размеров, или со свойствами, созданными из этих переменных.

Способы вызова диалога:

– в Таблице изменяемых переменных экземпляров массива и в Менеджере документа (при работе с исполнениями модели):

• командой Назначить допуск контекстного меню ячейки переменной,

• при нажатой кнопке Отображать индивидуальные допуски — нажатием кнопки с многоточием в ячейке переменной, двойным щелчком мышью по этой ячейке или указанной выше командой контекстного меню,

– в Редакторе свойств — командой Назначить допуск контекстного меню ячейки свойства, созданного из переменной,

– на панели Список свойств при редактировании свойств модели или исполнения модели — командой Назначить допуск контекстного меню ячейки свойства, созданного из переменной (строка, содержащая данную ячейку, должна быть выделена).

Для задания значения параметра/размера используются поле Значение и одноименная кнопка. Нужное значение вводится в поле или выбирается из пользовательского меню, которое появляется на экране после нажатия кнопки. По умолчанию меню содержит нормальные линейные размеры по ГОСТ 6636-69.

Для назначения допуска используются элементы, аналогичные элементам диалога Назначить допуск.

После выполнения всех необходимых действий в диалоге, нажмите кнопку ОК. Кнопка Отмена позволяет закрыть диалог, отказавшись от изменений.

Смотрите также

Задание значения переменной экземпляра массива

Назначение допусков при работе с переменными в исполнениях

Задание значений свойств, созданных из переменных


Диалог ввода имени набора стилей

Задайте или отредактируйте имя набора стилей.

После ввода имени набора нажмите кнопку ОК. Для выхода из диалога без сохранения имени набора нажмите кнопку Отмена.


Диалог ввода текста

В диалоге можно ввести или отредактировать текстовую надпись.

Диалог содержит страницы меню Редактор, Вставить и Формат, команды которых соответствуют командам одноименных страниц Главного меню системы при вводе/редактировании текста и служат для создания и оформления строки.

Для подтверждения внесенных изменений нажмите кнопку OK, для выхода из диалога без создания нового или изменения старого текста нажмите кнопку Отмена.


Диалог замены файла спецзнаков

Позволяет заменить, создать новый или проигнорировать файл спецзнаков graphic.bss, который невозможно прочитать в данном сеансе работы из подпапки \Sys главной папки КОМПАС-3D.

Описание элементов управления
Наименование | Описание
Изменить путь | Нажмите эту кнопку для указания другого пути к файлу graphic.bss и в появившемся диалоге выберите этот файл в другой папке.
Создать новый | Нажмите эту кнопку для генерации нового файла graphic.bss из выбранного в открывшемся диалоге исходного файла спецзнаков *.sss. Вновь созданный файл спецзнаков graphic.bss будет помещен в подпапку \Sys.
Игнорировать | При нажатии этой кнопки будут игнорироваться все спецзнаки (без уведомления об их наличии) во всех документах в данном сеансе работы КОМПАС-3D.


Диалог замены файла кодов и наименований

Этот диалог появляется на экране, если при поиске файла graphic.kds система не обнаружила его по пути, указанной переменной среды SYS.

Описание элементов управления

Наименование

Описание

Изменить путь

Позволяет найти файл кодов и наименований на диске. После нажатия этой кнопки на экране появляется стандартный диалог открытия файлов Windows. Вы можете указать любой файл (в том числе с расширением, отличным от kds), структура которого соответствует структуре файла кодов и наименований.

Указанный файл используется только в текущем сеансе работы. При следующем запуске система снова будет разыскивать файл graphic.kds в папке, указанной в переменной SYS.

Игнорировать

Позволяет отказаться от использования файла graphic.kds в текущем сеансе работы. После нажатия этой кнопки автоматизированный ввод и обработка кодов и наименований при работе со спецификацией будут невозможны до конца сеанса.


Диалог редактирования расширенного стиля текста

Позволяет настроить расширенный стиль текста.

Расширенный стиль текста — дополнительные данные, хранящиеся в стиле текста, которые определяют зависимость между количеством строк текста: одна, две или три и его параметрами: высотой символов, сужением символов и шагом строк.

Если текст состоит из большего числа строк, то настройка расширенного стиля игнорируется, и параметры текста определяются настройкой стиля.

Описание элементов управления
Наименование | Описание
Количество строк | Включите нужные опции для настройки параметров текста из соответствующего числа строк.
Высота | Устанавливает высоту символов в миллиметрах для данного количества строк.
Сужение символов | Устанавливает величину коэффициента сужения символов для данного количества строк.
Шаг строк | Устанавливает расстояние между строками текста.

После завершения редактирования расширенного стиля нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.

Расширенный стиль текста используется только в таблицах — в основном для описания различных случаев ввода текста в графы основной надписи документа, в ячейку таблицы с фиксированными габаритами и т.п. При использовании стиля текста, содержащего настройку расширенного стиля, вне таблиц параметры расширенного стиля игнорируются.

Например, вы можете создать стиль текста Обычный с высотой символов 3,5 мм и настроить расширенный стиль внутри стиля Обычный следующим образом: высота символов для однострочного текста — 10 мм, для двухстрочного — 7 мм и для трехстрочного — 5 мм. Это означает, что текст в ячейке таблицы, оформленный стилем Обычный, будет иметь высоту символов 10 мм, если он состоит из одной строки, 7 мм — если из двух, 5 мм — если из трех и 3,5 мм — если из четырех и более. Если применить стиль Обычный, допустим, к тексту текстового документа, то вне зависимости от количества строк высота символов будет равна 3,5 мм.


Не прочитана заготовка, вставленная внешней ссылкой

Этот диалог появляется, если при открытии документа невозможно прочитать файл, который содержит модель, вставленную в открываемый документ в качестве детали-заготовки.

В окне диалога показано название открываемого документа и файла детали-заготовки, который невозможно прочитать. Файл может отсутствовать или оказаться поврежденным.

Выберите нужное действие, нажав одну из кнопок диалога. При необходимости перед нажатием кнопки Заменить или Игнорировать включите опцию Применить для всех последующих.

– Кнопка Заменить позволяет использовать вместо непрочитанного другой файл или указать новый путь к файлу детали-заготовки. После нажатия этой кнопки на экране появляется диалог открытия файла, в котором нужно указать заменяющую модель. Если включена опция Применить для всех последующих, то каждая следующая непрочитанная модель автоматически разыскивается в той папке, где находится последняя указанная для замены модель. При положительном результате поиска найденная модель вставляется взамен непрочитанной, происходит переход к следующей. При отрицательном результате на экране появляется диалог открытия файла.

– Кнопка Игнорировать позволяет открыть модель без непрочитанной детали-заготовки. Тело, построенное на основе заготовки, отображаться не будет. В Дереве построения будет присутствовать последовательность объектов этого тела, но все они будут отмечены как ошибочные. При необходимости источник заготовки можно заменить. Для этого выделите деталь-заготовку в Дереве построения и вызовите команду Заменить источник.

– Кнопка Отказ от чтения позволяет прервать открытие модели.


Внешняя ссылка на заготовку содержит рекурсивную вложенность

Это предупреждение выдается при попытке использовать для текущей детали в качестве заготовки деталь, которая, в свою очередь, использует текущую в качестве заготовки, или при попытке открыть деталь, которая является заготовкой для своей же заготовки.

Как исправить эту ошибку

– Нажмите кнопку Заменить, чтобы сменить заготовку заготовки, устранив тем самым рекурсивную вложенность. В появившемся стандартном диалоге открытия файлов выберите документ-модель, который должен заменить вставку, вызывающую конфликт. Вставка заготовки или открытие детали с заготовкой будет произведено.
Чтобы при последующем открытии текущей детали не выдавалось настоящее сообщение, изменения в заготовке необходимо сохранить. Для быстрого доступа к файлу заготовки используйте команду Редактировать источник.

– Или нажмите кнопку Отказ от чтения для того, чтобы прервать команду вставки заготовки или отказаться от чтения документа модели.


Не прочитан/не найден файл

Этот диалог появляется на экране при открытии:

– графического КОМПАС-документа:

• если невозможно прочитать файл-источник вставки фрагмента (в том числе библиотечного), вида или растрового изображения,

• если не обнаружена модель, изображенная в ассоциативном виде (видах) этого чертежа;

– текстового КОМПАС-документа:

• если невозможно прочитать файл-источник вставки фрагмента или растрового изображения.

В окне диалога показаны имена документа и файла-источника, который невозможно прочитать (если не прочитана модель для ассоциативного вида, то показывается только имя файла модели). Файл может отсутствовать или оказаться поврежденным.

Выберите нужное действие, нажав одну из кнопок диалога. При необходимости перед нажатием кнопки Заменить, Игнорировать или Удалить включите опцию Применить для всех последующих.

– Кнопка Заменить позволяет использовать вместо непрочитанного другой файл или указать новый путь к файлу-источнику. После нажатия этой кнопки на экране появляется диалог открытия файла, в котором нужно указать заменяющий файл. Если включена опция Применить для всех последующих, то каждый следующий непрочитанный файл автоматически разыскивается в той папке, где находится последний указанный для замены файл. При положительном результате поиска найденный файл используется вместо непрочитанного, происходит переход к следующему. При отрицательном результате на экране появляется диалог открытия файла.

– Кнопка Игнорировать позволяет открыть документ, несмотря на отсутствие файла-источника. Информация об используемом файле не удаляется из документа, и впоследствии, при условии наличия файла-источника, документ можно будет просмотреть полностью. В отсутствие файла-источника при открытии документа по-прежнему будет выдаваться сообщение о том, что источник не прочитан.

В результате нажатия кнопки Игнорировать:

• документ, содержащий ссылку на фрагмент, вид или растр, открывается без соответствующего изображения,

• документ, содержащий ассоциативные виды, открывается с проекциями модели, но перестроение видов становится невозможно.

– Кнопка Удалить позволяет открыть документ, удалив из него вставки, источник которых не прочитан.
Если не прочитана модель для ассоциативного вида, то данная кнопка в диалоге отсутствует.

– Кнопка Отказ от чтения позволяет прервать открытие документа.

Чтобы подтвердить замену или удаление вставок, следует сохранить документ после открытия. В противном случае при последующем открытии документа вновь появится сообщение о том, что не прочитан файл-источник.


Окно Таблица переменных

Позволяет создать или отредактировать таблицу переменных текущего файла.

Окно появляется на экране после нажатия кнопки Таблица переменных на Инструментальной панели Окна переменных или после вызова команды Таблица переменных. Подробнее о команде (кнопке) Таблица переменных...

Окно Таблица переменных содержит собственно таблицу и расположенные над ней кнопки для вызова команд.

Описание элементов управления

Элемент

Описание

Читать из файла

Кнопка позволяет импортировать в Таблицу переменных информацию из файла формата MS Excel.

Содержимое импортируемого файла должно удовлетворять определенным требованиям.

После нажатия кнопки на экране появляется диалог открытия файлов. Выберите необходимый файл и нажмите кнопку Открыть. Данные из выбранного файла будут перенесены в таблицу переменных.

Сохранить в файл

Кнопка позволяет сохранить таблицу переменных в файл формата MS Excel. Кнопка становится доступной после ввода информации в таблицу.

После нажатия кнопки на экране появляется диалог записи файлов. Задайте местоположение и имя файла и нажмите кнопку Сохранить. Таблица переменных будет записана в файл формата MS Excel. Если заголовки столбцов пустые или содержат одинаковое имя переменной, сохранение таблицы невозможно. В этом случае после нажатия кнопки Сохранить в файл на экране появится сообщение: «Невозможно записать таблицу».

Читать внешние переменные

Кнопка позволяет перенести внешние переменные и их значения из файла в Таблицу переменных.

Переименовать столбец

Кнопка позволяет ввести заголовок столбца. Доступна после выделения ячейки или столбца. В открывшемся диалоге введите имя переменной, содержащее не менее одного символа.

Добавить строку выше

Группа кнопок позволяет изменять количество строк таблицы. Кнопка Удалить строки доступна после выделения строки или ячейки.

Добавить строку ниже

Удалить строки

Добавить столбец слева

Группа кнопок позволяет изменять количество столбцов таблицы. Кнопка Удалить столбец доступна после выделения столбца или ячейки.

Добавить столбец справа

Удалить столбец

Переместить вверх

Группа кнопок позволяет перемещать выделенные строки в вертикальном направлении. Кнопки доступны после выделения строки или ячейки.

Переместить вниз

При вставке показывать только первый столбец

Если кнопка нажата, то во время вставки этого файла в другой документ в Таблице переменных будет показан только первый столбец — столбец с комментариями.

В центральной части окна отображается или новая или уже созданная таблица.

Первая строка таблицы выделена цветом; ее ячейки, начиная со второй, служат для отображения имен переменных. Ячейки первого столбца, имеющего заголовок «Комментарий», предназначены для пояснений к наборам переменных. Остальные ячейки таблицы предназначены для числовых значений переменных.

Строка, добавляемая в пустую таблицу, имеет комментарий «Новая строка». При добавлении очередной строки происходит копирование выделенной строки.

При добавлении столбцов на экране появляется диалог ввода имени столбца.

Чтобы ввести или отредактировать комментарий или значение переменной, щелкните мышью в ячейке, введите данные и нажмите клавишу <Enter>. Для перехода к соседним ячейкам можно использовать клавиши со стрелками.

Чтобы выделить строку, щелкните мышью слева от ее первой ячейки. Чтобы выделить столбец, щелкните мышью по его заголовку.

Кнопка Присвоить значения переменным, расположенная в нижней части окна, позволяет передать значения внешних переменных из Таблицы переменных в файл. Кнопка доступна после выделения строки или ячейки. После нажатия кнопки внешние переменные файла принимают значения, указанные в выделенной строке Таблицы переменных. Значения будут присвоены лишь тем переменным, имена которых совпадают с заголовками столбцов таблицы. Одновременно с передачей значений окно Таблица переменных закрывается с сохранением изменений.

Для закрытия окна и сохранения изменений нажмите кнопку ОК. Значения внешних переменных файла при этом не меняются.

Для закрытия окна без сохранения изменений нажмите кнопку Отмена.

Во время вставки файла с внешними переменными в другой документ все кнопки, кроме кнопки При вставке показывать только первый столбец, недоступны. Редактирование таблицы также недоступно.

Смотрите также

Таблица значений внешних переменных. Общие сведения

Создание и редактирование таблицы


Диалог установки параметров поиска

Этот диалог появляется на экране после вызова команды Редактор — Найти....

В нем можно задать параметры для поиска подстроки в тексте.

Описание элементов управления
Наименование | Описание
Найти: | Введите в это поле подстроку, которую необходимо найти. Если поиск уже выполнялся, то можно выбрать одну из подстрок в списке.
Различать регистр | Включите эту опцию, если требуется, чтобы система различала строчные и прописные буквы при поиске.
Только полное слово | Включите эту опцию, если заданная подстрока должна разыскиваться только как отдельное слово в тексте.
Направление | Выберите нужное направление поиска в тексте: Вперед или Назад.
Начало поиска | Установите нужное начало поиска в тексте: От курсора или Граница текста.
Замена... | Нажмите эту кнопку для немедленного перехода в диалог параметров замены текста.

После задания всех параметров нажмите кнопку ОК для начала поиска. Для выхода из диалога без выполнения поиска нажмите кнопку Отмена.

Для продолжения замены с заданными параметрами вызовите команду Редактор — Продолжить или нажмите клавишу <F3>.

Поиск текста в таблице производится в пределах текущей ячейки.


Диалог настройки параметров шрифта

Позволяет назначить параметры шрифта, которые будут использоваться по умолчанию при вводе соответствующих надписей либо будут применены к выделенным или вводимым символам.

Описание элементов управления

Элемент

Описание

Шрифт

Выберите название шрифта из списка доступных шрифтов.

Отличается от шрифта по умолчанию

Эта опция присутствует в диалоге при задании умолчательных параметров надписей. При настройке шрифта текущей надписи или текста опции Отличается от шрифта по умолчанию в диалоге нет.

Выключенная опция означает, что шрифт объекта совпадает с установленным по умолчанию шрифтом документа. При этом в поле Шрифт отображается название умолчательного шрифта. Смена умолчательного шрифта документа приведет к смене шрифта объекта.

Включенная опция означает, что шрифт объекта отличается от умолчательного шрифта документа. Смена умолчательного шрифта документа в этом случае не отразится на объекте.

Если из списка Шрифт выбирается шрифт, отличный от умолчательного, то опция включается автоматически. Выключение ее приводит к возврату умолчательного шрифта.

Высота

Устанавливает высоту символов (в миллиметрах).

Сужение

Устанавливает величину коэффициента сужения для символов.

Курсив

Задает курсивное (наклонное) начертание символов.

Жирный

Задает утолщенное начертание символов.

Подчеркнутый

Задает подчеркивание текста.

Цвет...

Для вызова диалога изменения цвета символов нажмите эту кнопку.

Внешний вид текста показывается в окне просмотра, что позволяет немедленно оценить сделанные изменения.

После завершения настройки параметров шрифта нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


Диалог настройки формата текста

Этот диалог появляется на экране после вызова команды Формат — Формат текста....

В нем можно изменить параметры форматирования текстовой надписи.

Описание элементов управления
Наименование | Описание
Стиль всего текста по умолчанию | Список доступных стилей, из которого можно выбрать стиль для всей надписи. Для вызова диалога выбора стиля нажмите кнопку Изменить....
Ширина текста | Устанавливает габарит текста по ширине (в миллиметрах).
Высота текста | Устанавливает габарит текста по высоте (в миллиметрах).
Перенос правой границы | Включите эту опцию, если форматирование текста по мере его ввода должно выполняться за счет перемещения правой границы. При этом поле ввода ширины текста становится недоступным для редактирования.
Изменение сужения текста | Включите эту опцию, если форматирование текста по мере его ввода должно выполняться за счет пересчета сужения символов. Таким образом, текст будет вписываться в заданные габариты.
Форматирование строк | Включите эту опцию, если форматирование текста по мере его ввода должно выполняться за счет автоматического переноса слова на новую строку при достижении границы.
Перенос нижней границы | Включите эту опцию, если по мере ввода текста должно выполняться перемещение нижней границы. При этом поле ввода высоты текста становится недоступным для редактирования.
Изменение шага строк | Включите эту опцию, если по мере ввода текста должен изменяться шаг строк. Таким образом, текст будет вписываться в заданные габариты.

После завершения настройки нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


Диалог настройки расширенного формата ячейки

Позволяет установить дополнительные параметры для ячейки таблицы. Эти параметры нужны только при создании или редактировании таблиц основной надписи, поэтому диалог можно вызвать на экран только в данном режиме.

Он появляется на экране после вызова команды Расширенный формат ячейки или после нажатия на кнопку Далее... в диалоге настройки формата ячейки.

Описание элементов управления

Наименование

Описание

Тип ячейки

В этом разделе диалога устанавливается нужный тип ячейки (графы основной надписи).

Тип не определен

Эта опция — информационная. Она включена по умолчанию для ячейки, настройка которой еще не производилась. При настройке ячейки нужно обязательно выбрать один из следующих типов. Если тип ячейки оставить неопределенным, то ввод данных в нее при заполнении штампа будет невозможен.

Системный

Включите эту опцию, чтобы текст в ячейке появлялся автоматически. Система может определять и размещать в ячейке следующие параметры документов:

– номер листа — текущий номер листа,

– количество листов — количество листов текущего документа,

– формат листа — обозначение формата листа или листов текущего документа (заполнение ячейки возможно, если для документа выбран стандартный формат: А4, А3 и т.д.),

– имя файла (полное) — имя файла текущего документа с указанием полного пути к этому файлу,

– имя файла (короткое) — имя файла текущего документа без указания полного пути к этому файлу,

– строку обозначения и дефис — обозначение текущего документа (из ячейки типа Общий для документа с типом данных Обозначение документа) и дефис.

Выберите один из указанных типов данных из списка, который становится доступным при включении опции Системный тип.

Список содержит также строку Пользовательский. Выберите ее, если ячейка будет содержать данные, тип которых отсутствует в списке. Автоматическое заполнение такой ячейки невозможно, поэтому ее нужно будет заполнять вручную.

Общий для документа

Обычно эту опцию используют при настройке ячеек штампа многолистового документа. Содержимое ячеек этого типа с одинаковым типом данных (например, «Масштаб» или «Наименование изделия») одинаково во всех листах документа. Тип данных в ячейке выбирается из списка.

Общий для листа

Если на одном и том же листе есть несколько ячеек этого типа, имеющих одинаковые идентификаторы, содержимое всех ячеек будет совпадать (то есть достаточно ввести текст в одну из ячеек, чтобы он появился в других ячейках). После выбора этого типа ячейки требуется ввести ее числовой идентификатор.

Запрос при вводе текста в ячейку

Текст, набранный в этом поле, будет отображаться в Строке сообщений при вводе содержимого в данную ячейку основной надписи. Если после текста запроса ввести «|» (символ вертикальной черты) и номер пользовательского меню из файла Graphic.pmn, то по двойному щелчку мышью в этой ячейке будет возникать соответствующее пользовательское меню.

Подробнее о пользовательских меню при вводе текста...

После установки параметров расширенного формата ячейки нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


Диалог настройки формата ячейки таблицы

Позволяет установить параметры размещения текста в выделенных или создаваемых заново ячейках таблицы.

Описание элементов управления
Наименование | Описание
Стиль текста по умолчанию | В этом поле отображается имя стиля, назначенного для всего текста в ячейке.
Изменить | Для назначения другого стиля текста нажмите кнопку, а затем в появившемся диалоге выберите нужный стиль или создайте новый.
Запретить изменение текста в ячейке | Включите эту опцию, чтобы текст в ячейке был в дальнейшем недоступен для редактирования.
Однострочный текст | Устанавливает, что текст в ячейке всегда состоит только из одной строки. При этом переносы строк будут игнорироваться.
Слева | Устанавливает величину отступа от границы ячейки до текста слева.
Справа | Устанавливает величину отступа от границы ячейки до текста справа.
Сверху | Устанавливает величину отступа от границы ячейки до текста сверху.
Снизу | Устанавливает величину отступа от границы ячейки до текста снизу.
Ширина столбца | Устанавливает ширину столбца, в котором находится ячейка.
Высота строки | Устанавливает высоту строки, в которой находится ячейка.
Отслеживание размера по горизонтали | В этом разделе устанавливается способ форматирования текста в ячейке по ширине.
Перенос правой границы | Форматирование текста по мере его ввода выполняется за счет перемещения правой границы ячейки.
Изменение сужения текста | Форматирование текста по мере его ввода выполняется за счет пересчета сужения символов. Таким образом, текст вписывается в габариты ячейки с учетом назначенных отступов слева и справа.
Форматирование строк | Форматирование текста по мере его ввода выполняется за счет автоматического переноса слова на новую строку при достижении границы ячейки.
Отслеживание размера по вертикали | В этом разделе устанавливается способ форматирования текста в ячейке по высоте.
Перенос нижней границы | По мере ввода текста выполняется перемещение нижней границы ячейки.
Изменение шага строк | По мере ввода текста изменяется шаг строк. Таким образом, текст вписывается в габариты ячейки с учетом назначенных отступов снизу и сверху.

Замечание...

После завершения настройки нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


Диалог настройки формата ячейки штампа

Этот диалог появляется на экране после вызова команды Таблица — Формат ячейки... при создании или редактировании таблиц основной надписи.

В нем можно установить параметры размещения текста в выделенных ячейках таблицы.

Описание элементов управления
Наименование | Описание
Стиль текста по умолчанию | В этом поле отображается имя стиля, назначенного для всего текста в ячейке.
Изменить... | Для назначения другого стиля текста нажмите эту кнопку, а затем в появившемся диалоге выберите нужный стиль или создайте новый.
Однострочный текст | Устанавливает, что текст в ячейке всегда состоит только из одной строки. При этом переносы строк игнорируются.
Слева | Устанавливает величину отступа от границы ячейки до текста слева.
Справа | Устанавливает величину отступа от границы ячейки до текста справа.
Сверху | Устанавливает величину отступа от границы ячейки до текста сверху.
Снизу | Устанавливает величину отступа от границы ячейки до текста снизу.
Ширина столбца | Устанавливает ширину столбца, в котором находится ячейка.
Высота строки | Устанавливает высоту строки, в которой находится ячейка.
Отслеживание размера по горизонтали | В этом разделе устанавливается способ форматирования текста в ячейке по ширине.
Перенос правой границы | Форматирование текста по мере его ввода выполняется за счет перемещения правой границы ячейки.
Изменение сужения текста | Форматирование текста по мере его ввода выполняется за счет пересчета сужения символов. Таким образом, текст вписывается в габариты ячейки с учетом назначенных отступов слева и справа.
Форматирование строк | Форматирование текста по мере его ввода выполняется за счет автоматического переноса слова на новую строку при достижении границы ячейки.
Отслеживание размера по вертикали | В этом разделе устанавливается способ форматирования текста в ячейке по высоте.
Перенос нижней границы | По мере ввода текста выполняется перемещение нижней границы ячейки.
Изменение шага строк | По мере ввода текста изменяется шаг строк. Таким образом, текст вписывается в габариты ячейки с учетом назначенных отступов снизу и сверху.
Далее... | При нажатии этой кнопки на экран выдается диалог расширенной настройки формата ячейки основной надписи.

Замечание...

После завершения настройки нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


Диалог удаления вставок

Этот диалог появляется на экране, если для удаления выбрано несколько вставок видов или фрагментов.

Описание элементов управления
Элемент | Описание
Имя вставки | Имя вставки, которое было задано при создании или редактировании вставки.
Количество экземпляров | Количество экземпляров данной вставки в документе.
ОК | Эта кнопка позволяет подтвердить удаление данной вставки.
Удалить все | Эта кнопка позволяет удалить все выбранные вставки без дополнительных запросов.
Не удалять | Эта кнопка позволяет пропустить данную вставку, не удаляя его.
Отмена | Эта кнопка служит для закрытия диалога и завершения удаления.

Локальные фрагменты и вставки, взятые в документ, удаляются из документа физически (то есть уничтожается их содержимое). В случае вставок внешней ссылкой удаляются только ссылки на файлы-источники вставок, а сами файлы-источники на диске остаются неизменными.

Для быстрой отмены ошибочного удаления вставок нажмите кнопку Отменить на Стандартной панели после выхода из Менеджера вставок видов и фрагментов.


Диалог создания новой таблицы

Этот диалог появляется на экране после вызова команды вставки таблицы в графический или текстовый документ.

В нем можно установить параметры для вновь создаваемой таблицы.

Описание элементов управления
Наименование | Описание
Число столбцов | В этом поле можно ввести количество столбцов новой таблицы.
Число строк | В этом поле можно ввести количество строк новой таблицы.
Ширина столбца | В этом поле можно назначить ширину столбцов новой таблицы (в миллиметрах).
Высота строки | В этом поле можно назначить высоту строк новой таблицы (в миллиметрах).
Располагать заголовок | Выберите с помощью переключателей, в каком месте таблицы будет находиться ее шапка (заголовок). Для ячеек заголовка автоматически устанавливается соответствующий стиль текста. Шапку можно разместить в первой строке или первом столбце. Можно также отказаться от ее создания.
Из файла | При создании таблицы можно использовать в качестве прототипа ранее созданную и сохраненную в отдельном файле таблицу. Для чтения таблицы нажмите кнопку и в появившемся меню выберите нужную команду.
Загрузить из файла таблиц... | Команда позволяет загрузить таблицу, сохраненную в специальном формате в файле *.tbl. После вызова команды на экране появляется диалог, в котором можно выбрать нужный файл *.tbl.
Создать из графического фрагмента... | Команда позволяет создать таблицу из файла графического КОМПАС-документа. После вызова команды на экране появляется диалог, в котором можно выбрать файл *.frw или *.cdw, содержащий изображение таблицы, составленное из отрезков и текстов. При автоматической генерации таблицы из графического документа учитываются все существующие в нем тексты, горизонтальные отрезки и вертикальные отрезки. Другие объекты в формировании таблицы не участвуют. Стили текстов и отрезков сохраняются в получившейся таблице (в виде стилей текстов ячеек и стилей обрамления ячеек).

После задания всех параметров нажмите кнопку ОК для продолжения работы с таблицей. Для выхода из диалога без создания новой таблицы нажмите кнопку Отмена.


Диалог ввода даты

Позволяет быстро ввести нужную дату в ячейку основной надписи (штампа) документа.

По умолчанию в нем активна текущая дата. Вы можете выбрать другую дату, воспользовавшись списками годов, месяцев и чисел. После нажатия клавиши <Enter> указанная дата будет автоматически размещена в соответствующей графе штампа.

Формат даты, автоматически сформированной в ячейке основной надписи, будет подчиняться настройкам Windows для краткого формата вывода даты (Пуск — Настройки — Панель управления — Язык и стандарты — Дата).


Диалог настройки параметров проверки грамматики

Появляется на экране после нажатия кнопки Настройка... в диалоге настройки проверки правописания.

Элементы управления диалога позволяют настроить проверку грамматики.

Описание элементов управления

Элемент

Описание

Используемый набор правил:

Список, позволяющий выбрать или сформировать стиль, в соответствии с которым будет проверяться текст:

– Строго (все правила) — полный набор грамматических и стилистических правил,

– Для деловой переписки — набор правил для проверки деловой прозы: корреспонденции, текстов контрактов, научных статей и пр.,

– Для обычной переписки — набор правил для проверки неформальных текстов: писем, внутрифирменных докладных записок и пр.,

– Пользовательский стиль — набор правил, формируемый пользователем. Чтобы создать произвольный набор правил, выберите один из пользовательских стилей, включите или выключите использование правил по своему усмотрению и закройте диалог, нажав кнопку OK.

Грамматика,

Стиль

В списке названий правил могут одновременно отображаться правила либо для грамматической проверки, либо для стилистической. Для указания типа правил выберите нужный вариант: Грамматика или Стиль.

Чтобы то или иное правило использовалось во время проверки текста, включите опцию слева от названия правила, чтобы отказаться от использования правила — выключите. Вы можете получить подробную информацию о каждом правиле. Для этого выделите его в списке и нажмите кнопку Пояснения.

Требовать

Группа элементов управления, позволяющая настроить использование некоторых правил литературной правки текста:

– Родительные падежи подряд — задает максимально допустимое число идущих подряд существительных в родительном падеже,

– Предложно-именные группы подряд — задает максимально допустимое число идущих подряд сочетаний предлога и существительного.

– Согласование с «который» — задает максимально допустимое число слов между относительным местоимением (который, какой, каковой) и существительным, к которому оно относится,

– Ограничение на количество слов в предложении — задает максимальное количество слов в предложении. Слишком длинные предложения, таким образом, считаются ошибочными.

Начальная установка

Кнопка, позволяющая вернуть выбранному стилю проверки используемый по умолчанию набор правил. После ее нажатия все изменения стиля, сделанные пользователем, отменяются.

Пояснения

Кнопка, позволяющая просмотреть пояснения к выделенному в списке правилу. После ее нажатия на экране появляется окно с подробным описанием выбранного правила.


Диалог выбора файла формата IGES

Этот диалог появляется на экране при попытке открытия файла *.igs.

В нем требуется указать, двухмерное или трехмерное изображение содержится в выбранном файле. Это необходимо для запуска конвертера соответствующего типа.

Для отказа от чтения нажмите кнопку Отмена.


Диалог параметров записи в формат IGES

Диалог появляется на экране при экспорте модели в формат IGES.

Позволяет настроить параметры экспорта.

Описание элементов управления

Элемент

Описание

Объекты

Группа опций позволяет управлять экспортом объектов модели. При включении соответствующих опций экспортируются следующие объекты:

– тела,

– поверхности,

– кривые,

– точки,

– эскизы.

Тела, состоящие из отдельных частей, передаются отдельными телами.

При экспорте эскизов передаются линий двух типов: осевые и основные. Текст, обозначения и вспомогательные прямые эскиза не передаются.

Система координат

Список позволяет выбрать СК, в которой записываются координаты экспортируемой модели. Список недоступен, если в модели существует только абсолютная система координат.

Информация

Группа полей позволяет ввести информацию о документе.

Автор

Поле для ввода сведений об авторе документа.

Организация

Поле для ввода наименования организации.

Комментарий

Поле для ввода дополнительной информации о документе. Текст в поле может состоять из нескольких строк.

После завершения настройки параметров нажмите кнопку ОК. Для выхода из диалога без записи файла нажмите кнопку Отмена.


Диалог параметров чтения файла формата IGES в модель КОМПАС-3D

Диалог появляется при импорте модели из файла формата IGES. Диалог позволяет настроить параметры импорта.

Описание элементов управления

Элемент

Описание

Объекты

Группа опций позволяет управлять импортом объектов модели. При включении соответствующих опций в модель импортируются следующие объекты:

– тела,

– поверхности,

– кривые,

– точки.

Сшивать поверхности

Опция, позволяющая сшивать поверхности.

Если опция включена, то система пытается объединить импортированные поверхности. В результате возможно получение поверхности большей площади или тела (если исходная поверхность замкнута).

Если опция отключена, то сшивка не производится, и результатом импорта являются поверхности, аналогичные исходным.

Обратите внимание на то, что состояние опции Сшивать поверхности влияет только на поверхности и не влияет на тела.

Точность сшивки

Поле для ввода значения максимального расстояния между ребрами сшиваемых поверхностей. Диапазон допустимых значений 0–1000 мм. Поле доступно при включенной опции Сшивать поверхности.

После завершения настройки параметров нажмите кнопку ОК. Для выхода из диалога без чтения файла нажмите кнопку Отмена.


Диалог настройки свойств библиотеки

Этот диалог появляется на экране после вызова команды Добавить описание прикладной библиотеки из контекстного меню вкладки Библиотеки КОМПАС в окне Менеджера библиотек, а также после вызова команды Свойства из контекстного меню библиотеки, выделенной в списке библиотек.

В диалоге можно настроить свойства библиотеки, добавляемой в выбранный раздел Менеджера, или изменить свойства уже имеющейся библиотеки.

Описание элементов управления
Элемент | Описание
Название библиотеки | В этом поле отображается название библиотеки в Менеджере. Вы можете отредактировать название.
Имя файла библиотеки | В этом поле отображается полное имя файла указанной библиотеки. Чтобы выбрать другую библиотеку для добавления в Менеджер библиотек, нажмите кнопку Выбрать.
Режим открытия | В этой группе опций вы можете выбрать режим работы библиотеки (доступно только для прикладных библиотек).

После настройки свойств библиотеки нажмите кнопку ОК диалога для ее добавления (или сохранения сделанных настроек). Чтобы отказаться от добавления библиотеки (или выйти из диалога без сохранения сделанных настроек), нажмите кнопку Отмена.


Диалог выбора кода и наименования документа

Этот диалог появляется на экране после вызова команды Код и наименование....

Позволяет выбрать код и наименование документа для вставки в основную надпись документа или в текстовую часть объекта спецификации.

В диалоге перечислены коды и наименования документов, сгруппированные в разделы. Слева от названия раздела находится значок «+». Чтобы раскрыть раздел, следует щелкнуть по этому значку. Он сменится на «-». В перечне появятся документы раздела.

Код, вставленный в обозначение, может быть отделен пробелом или любым другим символом. Разделителем перед полем Код по умолчанию является пробел. Чтобы изменить разделитель, введите один произвольный символ в соответствующее поле диалога Обозначение. Если требуется создать обозначение без разделителя, нужно удалить пробел из поля.

Нужный символ задается в диалоге ввода обозначения.

Выберите в перечне кодов и наименований нужный код и нажмите кнопку ОК. Можно также дважды щелкнуть в ячейке Код. Диалог закроется. Выбранный код будет вставлен в графу «Обозначение», а соответствующее ему наименование — в графу «Наименование». Порядок вставки зависит от содержимого этих граф и определяется следующими правилами.

– Если графы пусты, в них вставляются код и наименование документа.

– Если в графах содержится произвольный текст, то код документа и его наименование вставляются после этого текста.

– Если последние знаки в графе Обозначение составляют один из стандартных кодов, то эти знаки удаляются. Вместо них вставляется выбранный код.

– Если последние знаки в графе Наименование составляют одно из стандартных наименований документов, то эти знаки удаляются. Вместо них вставляется выбранное наименование документа.

Указанная замена будет выполнена также, если после текста, совпадающего с одним из стандартных кодов или наименований, в графе находилось любое количество знаков «точка» или «пробел». Точки и пробелы при этом будут удалены.

Содержимое диалога Коды и наименования определяется файлом кодов и наименований. При необходимости вы можете самостоятельно отредактировать имеющийся файл или создать новый.

Автоматическая вставка кода и наименования в основной надписи производится в ячейки типа Наименование изделия и Обозначение документа, а в объекте спецификации — в колонки с типом данных «строка», связанные с ячейкой штампа Наименование изделия или Обозначение документа.


Диалог выбора фрагмента

В этом диалоге вы можете выбрать нужный фрагмент из библиотекаря фрагментов КОМПАС.


Не найден или испорчен файл библиотеки

Это сообщение появляется, если система не может обнаружить библиотеку, стиль или тип атрибута из которой присвоен объекту, содержащемуся в открываемом документе. Например, библиотека может быть удалена, перемещена или переименована. Полное имя файла требуемой библиотеки отображается в поле Имя файла.

Как исправить эту ошибку

– Чтобы указать библиотеку, из которой следует взять стиль или тип атрибута, нажмите кнопку Найти файл.

– Чтобы прервать открытие документа, нажмите кнопку Отказ от чтения.

– Если ошибка вызвана отсутствием библиотеки стилей, диалог содержит кнопку Удалить стиль. Нажмите ее, чтобы заменить отсутствующий стиль системным стилем.

– Если ошибка вызвана отсутствием библиотеки типов атрибутов, диалог содержит кнопку Игнорировать. Нажмите ее, чтобы открыть документ, проигнорировав присвоенные объектам атрибуты.


Диалог Допуск (для линейных, диаметральных, радиальных размеров)

Диалог Допуск
(для линейных, диаметральных, радиальных размеров)

Позволяет задать умолчательный допуск для линейных, или диаметральных, или радиальных размеров.

Диалог вызывается нажатием кнопки в диалоге настройки умолчательных параметров допусков.

Описание элементов управления

Элемент

Описание

Квалитет...

Кнопка позволяет задать квалитет с помощью специального диалога Выбор квалитета. В поле, расположенном под кнопкой, отображается квалитет, заданный по умолчанию. Данное поле доступно для ручного ввода.

Отклонения

Поля Верхнее и Нижнее служат для задания значений линейных отклонений размера. Значения отклонений вводятся вручную. При этом поле Квалитет, если в нем было задано значение, очищается.

При вводе отклонений доступна кнопка ±. Она позволяет сделать отклонения равными. Перед значением верхнего отклонения ставится знак «+», а перед значением нижнего — знак «-».

После задания допуска закройте диалог, нажав кнопку ОК. Для выхода из диалога без изменения допуска нажмите кнопку Отмена.


Диалог создания макроэлемента

Этот диалог появляется на экране, если выделенные для объединения в макроэлемент объекты расположены на разных слоях.

Описание элементов управления
Элемент | Описание
Многослойный | Включение этой опции означает, что входящие в макроэлемент объекты останутся на своих исходных слоях.
На текущий слой | Включение этой опции означает, что объекты будут удалены с исходных слоев и перенесены на слой, который в данный момент является текущим.

Выбрав нужную опцию, нажмите кнопку ОК. Для выхода из диалога без создания макроэлемента нажмите кнопку Отмена.


Диалог Менеджер документа(документ-модель)

Диалог Менеджер документа
(документ-модель)

Диалог появляется на экране после вызова следующих команд:

– Менеджер документа...

– Управление слоями

– Управление исполнениями...

– Управление пересчетом...

Диалог предназначен для работы со слоями, исполнениями модели, дополнительными номерами исполнений и пересчетами размеров модели.

В левой части диалога отображается Дерево элементов документа. Оно позволяет указать тип элементов (слои, исполнения, дополнительные номера, пересчеты), с которыми будет выполняться работа в Менеджере.

В правой части диалога отображается список содержащихся в документе элементов выбранного типа и инструментальная панель для вызова команд. Набор кнопок инструментальной панели зависит от выбранного типа элементов.

Управление слоями

Управление исполнениями

Управление дополнительными номерами

Управление пересчетами

Чтобы сохранить произведенные изменения и завершить работу в диалоге, нажмите кнопку ОК. Кнопка Отмена позволяет закрыть диалог, отказавшись от изменений.

Если требуется сохранить изменения, не закрывая диалог, нажмите кнопку Применить.

При работе с исполнениями обратите внимание на следующую особенность. Добавление, перемещение и удаление исполнений сохраняется автоматически и не может быть отменено в Менеджере.

При работе с режимами пересчета подтверждение каждого изменения не требуется, т.к. изменение сохраняется в модели сразу после выполнения и не может быть отменено в Менеджере.


Управление слоями в Менеджере документа

Менеджер документа позволяет выполнять следующие действия со слоями:

– создание и удаление слоев,

– изменение значений свойств слоев,

– выбор текущего слоя.

Для управления слоями в Менеджере документа используются элементы, приведенные в таблице. Для их отображения в Менеджере необходимо, чтобы в дереве Менеджера был выбран элемент Слои.

В правой части диалога находится список слоев, созданных в текущей модели. Текущий слой отмечается красной «галочкой» в поле Статус.

Щелчок мыши по значению свойства в полях Статус, Видимость, Редактирование и Проецирование в чертеж изменяет его на противоположное. Щелчок в поле Имя позволяет изменить значение этого поля. Щелчок в полях Цвет и Оптические свойства позволяет назначить цвет и задать оптические свойства слоя.

Описание элементов управления
Наименование | Описание
Создать слой | Создать новый слой.
Создать группу | Создать группу слоев.
Создать фильтр | Создать фильтр слоев.
Удалить | Удалить выделенные слои. Удаление слоя означает удаление всех расположенных на нем объектов. Поэтому при попытке удалить непустой слой на экране появляется диалог удаления объектов. Вы можете подтвердить удаление слоя вместе со всеми его объектами или отказаться от удаления.
Сделать текущим | Сделать выделенный слой текущим.
Видимый | Сделать выделенные слои видимыми.
Погашенный | Сделать выделенные слои невидимыми.
Цвет | Изменить цвет выделенных слоев. Цвет слоя назначается в стандартном диалоге выбора цвета
Оптические свойства слоя | Изменить оптические свойства выделенных слоев. Оптические свойства назначаются в диалоге Оптические свойства.
Разрешить редактирование | Сделать выделенные слои редактируемыми.
Запретить редактирование | Сделать выделенные слои нередактируемыми.
Проецировать в чертеж | Сделать выделенные слои проецируемыми в ассоциативный чертеж.
Не проецировать в чертеж | Сделать выделенные слои непроецируемыми в ассоциативный чертеж.

Текущий слой нельзя погасить, удалить или сделать нередактируемым.

Поле Область поиска позволяет выполнить поиск слоя по имени или по номеру.

Чтобы начать поиск, следует ввести в поле строку текста. При этом можно использовать маски. В масках знак «*» заменяет любое количество любых символов. Знак «?» заменяет один любой символ. В Списке слоев будут показаны слои, имена или номера которых совпадают с заданной строкой. Содержание области поиска не сохраняется в документе.

Подробнее о работе со слоями в модели...


Управление дополнительными номерами в Менеджере документа

Для управления дополнительными номерами исполнений модели в Менеджере документа используются элементы, приведенные в таблице. Для их отображения в Менеджере необходимо, чтобы в дереве Менеджера был выбран элемент Дополнительные номера.

Описание элементов управления

Наименование

Описание

Таблица дополнительных номеров

Таблица содержит список дополнительных номеров исполнений модели и значения свойств, соответствующие дополнительным номерам.

Список дополнительных номеров содержится в столбце Дополнительный номер. Отображение столбцов, содержащих значения свойств, настраивается (см. ниже). Задание/изменение номеров и их свойств выполняется непосредственно в ячейках таблицы.

Создать дополнительный номер исполнения

Кнопка позволяет создать дополнительный номер исполнения модели. Номер формируется в соответствии с настройкой.

Переместить строку вверх
Переместить строку вниз

Кнопки позволяют переместить строку с выбранным дополнительным номером на одну позицию вверх или вниз в списке дополнительных номеров. Кнопки доступны, если строку можно переместить на указанную позицию.

Удалить строки

Кнопка позволяет удалить выбранный дополнительный номер или несколько дополнительных номеров, выделенных при помощи клавиши <Shift> или <Ctrl>.

Настройка столбцов

Кнопка позволяет настроить список отображаемых свойств и порядок их следования в таблице дополнительных номеров. Значения каждого свойства отображаются в отдельном столбце.

После нажатия кнопки на экране появляется диалог Настройка столбцов.

Удалить столбец

Кнопка позволяет отключить отображение столбца, содержащего значения какого-либо свойства. Для этого предварительно активизируйте одну из ячеек нужного столбца.

Отображение столбца Дополнительный номер отключить нельзя.

Вставить переменную

Кнопка позволяет добавить в таблицу дополнительных номеров столбец, содержащий значения какой-либо внешней переменной. При этом в документе автоматически создается свойство из данной переменной.

После нажатия кнопки на экране появляется диалог Переменные, позволяющий выбрать нужную переменную. Столбец с именем переменной добавляется в таблицу дополнительных номеров и в список отображаемых свойств диалога Настройка столбцов.

В дальнейшем вы можете отключать и включать отображение данного столбца так же, как других столбцов таблицы.

Значение выбранной переменной вводятся непосредственно в ячейки столбца.

Параметры формирования номеров новых исполнений

Кнопка позволяет включить/отключить автоматическое формирование номеров и дополнительных номеров новых исполнений и задать параметры формирования. Вызывает диалог Номера новых исполнений.

Читать из файла

Кнопка позволяет создать в документе список дополнительных номеров, аналогичный сохраненному в файле формата ods или xls. После нажатия кнопки на экране появляется стандартный диалог открытия файла. Выберите нужный файл и нажмите кнопку Открыть. Список дополнительных номеров из файла будет передан в модель.

Сохранить как...

Кнопка позволяет сохранить таблицу дополнительных номеров в виде отдельного документа одного из следующих типов:

– КОМПАС-Чертежи (файл *.cdw),

– КОМПАС-Фрагменты (файл *.frw),

– КОМПАС-Текстовые документы (файл *.kdw),

– КОМПАС-Таблицы (файл *.tbl),

– Текстовые файлы (файл *.txt),

– Электронные таблицы ODF (файл *.ods),

– Электронные таблицы Microsoft Excel (файл *.xls).

После нажатия кнопки на экране появляется стандартный диалог сохранения файлов.

Таблицу дополнительных номеров, сохраненную в файл формата ods или xls, можно использовать для создания аналогичного набора дополнительных номеров в другой модели (см. выше).

Подробно о работе с дополнительными номерами исполнений...


Управление режимом пересчета размеров в Менеджере документа

Менеджер документа позволяет выполнять следующие действия с пересчетами:

– создание, редактирование или удаление пользовательских пересчетов;

– назначение какого-либо пересчета текущим (т.е. выбор пересчета, согласно которому будет производиться расчет размеров).

Подробнее о пересчетах размеров модели...
Подробнее об управлении пересчетом...

Для управления режимом пересчета модели необходимо, чтобы в дереве Менеджера был выбран элемент Пересчет размеров.

При указании пересчета в списке в правой части диалога Менеджер документа на инструментальной панели отображаются кнопки вызова команд, управляющих списком пересчета. Описание команд см. в таблице.

Описание команд управления списком пересчетов

Наименование

Описание

Создать

Команда позволяет создать новый пользовательский пересчет. После нажатия кнопки в списке пересчетов появляется вновь созданный пересчет.

Новый пересчет не содержит переменных или компонентов — правая часть диалога пуста.

По образцу

Команда позволяет создать новый пользовательский пересчет с параметрами системного или созданного ранее пользовательского пересчета — пересчета-образца.

Команда доступна, если в списке пересчетов выделен один из пересчетов.

После нажатия кнопки в списке пересчетов появляется новый пересчет, имеющий параметры пересчета-образца.

Если в качестве образца выбран системный пересчет, то параметрами нового пересчета будут все переменные (и/или компоненты) текущей модели, которые можно перечитать. Способ пересчета значения каждой переменной (или компонента) в данном пересчете будет соответствовать выбранному системному пересчету.

Назначить текущим

Команда позволяет назначить выделенный пересчет текущим. Команда доступна, если в списке выделен один из пересчетов. После нажатия кнопки в списке рядом с выделенным пересчетом появляется «галочка». Это означает, что данный пересчет является текущим.

Удалить

Команда позволяет удалить выделенный пользовательский пересчет. Кнопка доступна при выделении в списке пользовательского пересчета.

Системные пересчеты удалить нельзя.

При указании пользовательского пересчета в списке левой части диалога на инструментальной панели отображаются кнопки вызова команд, управляющих пользовательским пересчетом. Описание команд см. в таблице.

Описание команд управления пользовательским пересчетом

Наименование

Описание

Читать переменные

Команда позволяет добавить в пользовательский пересчет все переменные модели, участвующие в пересчете ее размеров. Команда доступна при выделении в списке пользовательского пересчета.

Обратите внимание на то, что переменные, имеющие статус «информационная», в область параметров не добавляются.

Вставить переменную

Команда позволяет выбрать переменную из списка переменных модели, участвующих в пересчете размеров. Укажите нужную переменную и нажмите кнопку ОК.

Строка, соответствующая выбранной переменной, будет добавлена в таблицу.

Удалить строки

Команда позволяет удалить строки таблицы.

Команда доступна после выделения строки или ячейки.

В середину поля допуска

Группа кнопок позволяет выбрать нужный способ пересчета для переменной или компонента. Выделите нужную строку и нажмите на инструментальной панели кнопку, соответствующую нужному способу пересчета.
Подробнее о способах пересчета....

По верхнему пределу

По нижнему пределу

С коэффициентом

Подробнее о режиме пересчета...


Управление исполнениями в Менеджере документа

Для выполнения различных действий с исполнениями модели в Менеджере документа используются таблица исполнений и кнопки панели управления, приведенные в таблице (см. ниже). Для их отображения необходимо, чтобы в дереве Менеджера был выбран элемент Исполнения.

Таблица исполнений содержит список исполнений модели и значения свойств исполнений.

Список исполнений отображается в столбце Наименование. Его структура повторяет структуру Дерева исполнений модели. Каждому исполнению в списке соответствует наименование и пиктограмма. Пиктограммы всех исполнений, кроме текущего, имеют синий цвет; пиктограмма текущего исполнения желтого цвета.

В списке содержатся все исполнения модели, имеющиеся в документе. Изменения списка, такие как добавление, перемещение и удаление исполнений, автоматически передаются в Дерево исполнений. Отменить эти действия в Менеджере нельзя.

Набор столбцов таблицы, содержащих значения свойств исполнений, настраивается с помощью кнопки Настройка столбцов (см. ниже). Перечень свойств один и тот же для всех исполнений модели. Значения свойств могут быть различными для разных исполнений.

Значения некоторых свойств нельзя изменять. Ячейки со значениями этих свойств серого цвета. Кроме того, серый цвет имеют ячейки, недоступные для ручного ввода.

Значения некоторых свойств (наименование, комментарий и т.п.) можно ввести непосредственно в ячейку. Если для задания значения используется специальный диалог, то после щелчка мышью по ячейке в правой части этой ячейки появляется кнопка с многоточием. Щелчок по этой кнопке вызывает диалог задания значения свойства. Вы также можете вызвать этот диалог двойным щелчком мышью по ячейке.

Значения свойств, заданные в документе, отображаются черным цветом. Значения, полученные по ссылке из источника или записанные операционной системой в файл, имеют синий цвет.

Описание элементов управления

Наименование

Описание

Создать зависимое исполнение

Кнопка позволяет создать зависимое исполнение модели. Исходным для него является исполнение, выбранное в списке исполнений Менеджера. Если исходное исполнение является зеркальным, кнопка недоступна.

После нажатия кнопки новое исполнения появляется в списке исполнений Менеджера и в Дереве исполнений. Оно подчинено исходному.

Создать зеркальное исполнение

Команда вызывается из меню кнопки Создать зависимое исполнение. Позволяет создать зеркальное исполнение модели.

Исходным для него является исполнение, выбранное в списке исполнений Менеджера. Если для исходного исполнения уже создано зеркальное исполнение, или само исходное исполнение является зеркальным, команда недоступна.

После вызова команды новое исполнения появляется в списке исполнений Менеджера и в Дереве исполнений. Оно подчинено исходному, т.е. является зависимым.

Если исходным исполнением является модель с компонентами, то после вызова команды на экране появляется диалог настройки параметров отражения компонентов. Выполните необходимые настройки и завершите создание зеркального исполнения, нажав кнопку ОК в диалоге или кнопку Создать объект на Панели специального управления.

Создать независимое исполнение

Команда вызывается из меню кнопки Создать зависимое исполнение. Позволяет создать независимое исполнение модели. Исходным для него является исполнение, выбранное в списке исполнений Менеджера. Если исходное исполнение является зеркальным, команда недоступна.

После вызова команды новое исполнения появляется в списке исполнений Менеджера и в Дереве исполнений. Оно располагается на первом уровне иерархии и занимает последнюю позицию в списке исполнений.

Переместить строку вверх
Переместить строку вниз

Кнопки позволяют переместить выбранное исполнение на одну позицию вверх или вниз в списке исполнений. Кнопки доступны, если исполнение можно переместить на указанную позицию.

Удалить строки

Кнопка позволяет удалить выбранное исполнение или несколько исполнений, выделенных при помощи клавиши <Shift> или <Ctrl>.

Сделать текущим

Кнопка позволяет сделать текущим исполнение, выбранное в списке исполнений Менеджера.

Настройка столбцов

Кнопка позволяет настроить список отображаемых свойств и порядок их следования в таблице исполнений. Значения каждого свойства отображаются в отдельном столбце.

После нажатия кнопки на экране появляется диалог Настройка столбцов.

Удалить столбец

Кнопка позволяет отключить отображение столбца, содержащего значения какого-либо свойства. Для этого предварительно активизируйте одну из ячеек нужного столбца.

Отображение столбца Наименование отключить нельзя.

Вставить переменную

Кнопка позволяет добавить в таблицу исполнений столбец, содержащий значения какой-либо переменной. При этом в документе автоматически создается свойство из данной переменной.

После нажатия кнопки на экране появляется диалог Переменные, содержащий набор переменных текущего исполнения. При необходимости вы можете выбрать другое исполнение из раскрывающегося списка. В диалоге отобразится набор переменных данного исполнения. После выбора нужной переменной столбец с ее именем добавляется в таблицу исполнений и в список отображаемых свойств диалога Настройка столбцов. Если выбранная переменная соответствует параметру операции/размеру, то в заголовке столбца также отображается название этого параметра/размера.

В дальнейшем вы можете отключать и включать отображение столбца со значениями переменной так же, как других столбцов таблицы.

Подробно об использовании переменных в исполнении...

Отображать индивидуальные допуски

Если в таблицу исполнений добавлены столбцы со значениями переменных управляющих размеров и/или переменных параметров операций, значения которых выражены в линейных или угловых величинах, то вы можете включить отображение индивидуальных допусков этих размеров и/или параметров с помощью кнопки Отображать индивидуальные допуски. Допуски показываются в таблице при нажатой кнопке.

Вы можете не только просматривать допуски, но и изменять их в специальном диалоге.

Подробнее о просмотре и назначении допусков...

Параметры формирования номеров новых исполнений

Кнопка позволяет включить/отключить автоматическое формирование номеров и дополнительных номеров новых исполнений и задать параметры формирования. Вызывает диалог Номера новых исполнений.

Читать из файла

Кнопка позволяет создать в документе набор исполнений, аналогичный сохраненному в файле формата ods или xls. После нажатия кнопки на экране появляется стандартный диалог открытия файла. Выберите нужный файл и нажмите кнопку Открыть. Список исполнений из файла будет передан в модель. Подробнее...

Сохранить как...

Кнопка позволяет сохранить таблицу исполнений в виде отдельных документов следующих типов:

– КОМПАС-Чертежи (файл *.cdw),

– КОМПАС-Фрагменты (файл *.frw),

– КОМПАС-Текстовые документы (файл *.kdw),

– КОМПАС-Таблицы (файл *.tbl),

– Текстовые файлы (файл *.txt),

– Электронные таблицы ODF (файл *.ods),

– Электронные таблицы Microsoft Excel (файл *.xls).

После нажатия кнопки на экране появляется стандартный диалог сохранения файлов.

Таблицу исполнений, сохраненную в файл формата ods или xls, можно использовать для создания аналогичного набора исполнений в другой модели (см. выше).

Смотрите также

Редактирование свойств исполнения

Особенности передачи изменений обозначения и наименования исполнения в другие исполнения


Диалог ввода текста дополнительного обозначения

Позволяет ввести текст дополнительного обозначения прямой координационной оси.

При добавлении элементов Указатель ориентации оси и Марка для вызова диалога требуется щелкнуть мышью в поле Текст.

При добавлении элемента Текст диалог появляется автоматически после того, как указана точка присоединения обозначения.

Введите текст обозначения в поле ввода.

Если длина строки введенного текста окажется больше диаметра окружности марки, произойдет автоматическое сужение надписи.

В меню диалога находятся команды редактирования, вставки и форматирования текста. Некоторые из них можно вызвать из контекстного меню поля ввода диалога.

После завершения ввода текста нажмите кнопку ОК диалога.

Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.

Смотрите также

Создание и редактирование дополнительных обозначений координационной оси


Диалог Ошибка сохранения файла

Этот диалог появляется на экране, если модель компонента, получаемого зеркальным отражением с результатом операции Сохранить зеркальный компонент в файле, невозможно сохранить в папку, выбранную при настройке.

Если сохранение недоступно для нескольких компонентов, то данный диалог появляется по очереди для каждого из них.

В диалоге отображается полное имя файла компонента, который невозможно сохранить.

Выберите нужное действие, нажав одну из кнопок диалога.

– Кнопка Изменить позволяет выбрать другую папку для сохранения файла. После нажатия кнопки на экране появляется стандартный диалог выбора папки.

– Кнопка Пропустить позволяет отказаться от создания новой модели для данного компонента. Создаваемый компонент будет еще одной вставкой исходного компонента, отраженной зеркально.

Чтобы выбранное действие выполнялось для всех последующих компонентов, которые нельзя сохранить при выполнении текущей операции, перед выбором действия включите опцию Применить для всех последующих.

Если в диалоге выбрана другая папка для сохранения (кнопка Изменить), то все последующие компоненты будут сохранены в эту папку.

Если выбрано действие Пропустить, то все последующие компоненты будут зеркальными вставками исходных компонентов (без создания новых моделей).

– Кнопка Прервать позволяет отменить операцию по созданию компонентов зеркальным отражением. При этом зеркальные компоненты в модели не создаются, а заданные для них параметры отражения теряются.


Диалог выбора плотности материала

Данный диалог используется в следующих случаях:

– для выбора плотности материала при расчете массо-центровочных характеристик детали, тела вращения или выдавливания,

– для выбора материала при задании значений свойств Материал, Заменитель материала, Покрытие.

Данные о материалах в диалоге сгруппированы по тематическим разделам.

Чтобы развернуть содержание какого-либо раздела, щелкните левой кнопкой мыши на значке «плюса» рядом с заголовком раздела. Повторный щелчок на этом символе (после разворачивания раздела он отображается как минус) приведет к сворачиванию содержания раздела.

В поле Плотность отображается значение плотности для текущего материала.

Выбрав материал, нажмите кнопку ОК. Для выхода из диалога без выбора значения плотности нажмите кнопку Отмена.


Диалог ввода имени фрагмента

Диалог, появляющийся при сохранении локального фрагмента.

В нем требуется ввести имя, под которым созданный фрагмент будет храниться внутри документа.


Диалог установки значения углового размера

Этот диалог появляется на экране в следующих случаях:

– автоматически после простановки в параметрическом режиме углового размера, если при настройке этого режима были включены опции Размеры и Фиксировать размеры,

– после вызова команды Установить значение размера и указания ассоциативного углового размера,

– после двойного щелчка на размерной надписи ассоциативного углового размера.

Диалог позволяет задать новое значение размера, ввести или отредактировать имя соответствующей ему переменной и комментарий к ней, а также сменить тип размера.

Описание элементов управления

Элемент

Описание

Градусы

Минуты

Секунды

Включите опцию Градусы, если требуется задать значение размера в формате ХХ°ХХ'ХХ". Опция доступна для управляющего размера.

После включения опции становятся доступными поля ввода градусов, минут и секунд. Введите в поля нужные значения. Обратите внимание на то, что ни одно из полей не может быть оставлено пустым. Если требуется задать нулевое значение, введите в поле ноль.

После следующего входа в диалог заданное значение размера отобразится в поле Выражение в формате ХХ,ХХХ°.

Выражение

Включите эту опцию, чтобы задать значение угла в формате ХХ,ХХХ°. Опция доступна для управляющего размера.

После включения опции становится доступным соответствующее поле ввода. В этом поле можно ввести как численное значение, так и константу, а также выражение для расчета значения.

После следующего входа в диалог заданное значение размера отобразится в полях Градусы, Минуты, Секунды в формате ХХ°ХХ'ХХ".

Переменная

Поле для ввода имени переменной, соответствующей размеру.

По умолчанию при простановке размера предлагается имя переменной, сформированное по шаблону «vN», где N — порядковый номер переменной в списке переменных документа.

При необходимости вы можете отредактировать имя переменной.

Если у размера не должно быть переменной, удалите имя переменной из поля.

Комментарий

Поле для ввода комментария к переменной.

Информационный размер

Опция, позволяющая управлять типом размера.

– Включение опции означает, что размер будет информационным. Значение размера вручную задать нельзя.

– Отключение опции означает, что размер будет управляющим. Значение размера задается в диалоге.

Выполнив все необходимые действия, нажмите кнопку OK. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.

Смотрите также

Установка значения размера

Управляющие и информационные размеры. Размеры с переменными


Диалог создания или редактирования стиля линии

Диалог создания или редактирования
стиля линии

Позволяет создать новый или отредактировать существующий пользовательский стиль линии для отрисовки геометрических объектов. Стили можно хранить непосредственно в документе, в наборе или библиотеке стилей.

Этот диалог появляется на экране после нажатия кнопки Создать или Редактировать в диалоге Работа с наборами и библиотеками стилей.

Описание элементов управления

Элемент

Описание

Название

В этом поле необходимо ввести или отредактировать имя стиля.

Тип кривой

Установите переключателями нужный тип линии (сплошная или прерывистая).

Назначить прототип

Чтобы выбрать в качестве шаблона какой-либо из уже существующих стилей, нажмите эту кнопку.

Является границей для штриховки

Включите эту опцию, чтобы линия служила границей области штриховки.

Параметры пера

В этом разделе задаются параметры отрисовки линии на экране и при выводе на печать.

Назначаемые

Если требуется назначить параметры линии вручную, включите эту опцию. Становятся доступны поля для задания толщины линии.

Если же параметры линии должны совпадать с параметрами стандартных линий (основной, тонкой или утолщенной), включите опцию с названием нужного стандартного типа.

Толщина на бумаге

Задает толщину отрисовки линии при выводе на бумагу (в миллиметрах). Поле доступно только в том случае, если выбрана опция Назначаемые.

Толщина на экране

Задает толщину отрисовки линии на экране (в пикселах). Поле доступно только в том случае, если выбрана опция Назначаемые.

Цвет

Для вызова диалога выбора цвета линии нажмите кнопку.

Описание прерывистой кривой

Поля этого раздела доступны только в том случае, если был выбран прерывистый тип кривой.

Штрих-промежуток

В этом поле отображается список заданных сочетаний длин штрихов и промежутков. Линия может состоять из последовательности таких сочетаний.

Длина (мм) штриха

Задает длину штриха линии в миллиметрах.

Длина (мм) промежутка

Задает длину промежутка линии в миллиметрах.

Фрагмент

Позволяет добавить к сочетанию штриха и промежутка произвольный КОМПАС-фрагмент. После нажатия на эту кнопку на экране появляется стандартный диалог выбора файлов, в котором требуется указать включаемый в стиль линии фрагмент.

Поля X и Y

В этих полях задается смещение начала координат фрагмента относительно начала штриха. Поле X соответствует смещению в направлении штрихов (вдоль линии), а поле Y — смещению перпендикулярно направлению штрихов.

В каждое сочетание штриха и промежутка можно включать один фрагмент.

Игнорировать стили линий фрагментов

Если эта опция включена, то для всех линий всех фрагментов используются толщина и цвет, заданные для настраиваемого стиля линии (с помощью кнопки Цвет и группы Параметры пера).

Если опция выключена, то толщина и цвет линий фрагментов зависят от использованных в них стилей линий следующим образом:

– Пользовательские стили линии фрагмента заменяются системным стилем линии Основная с текущими параметрами (т.е. с цветом и толщинами для экрана и для печати, установленными в системе на момент включения фрагмента в стиль линии).

– Системные стили линии фрагмента записываются в стиль линии с текущими параметрами (если во время создания фрагмента параметры системных линий были другими, то эти параметры заменяются текущими)1. Разрывы линий удаляются (т.е. прерывистые линии, такие как Штриховая, Осевая и т.п., заменяются сплошными).

Добавить

Для ввода нового сочетания штриха и промежутка нажмите кнопку.

Удалить

Для удаления сочетания штриха и промежутка выберите его в списке и нажмите кнопку.

Просмотр

В этом поле отображается внешний вид стиля линии, что позволяет немедленно оценить внесенные изменения.

Кривая всегда заканчивается штрихом

Чтобы линия с обеих сторон заканчивалась штрихом, включите соответствующую опцию.

Состояние опции Кривая всегда заканчивается штрихом учитывается при отрисовке линии, только если штрихи имеют ненулевую длину.
  1. Параметры линий фрагмента сохраняются в стиле линии. Их изменение недоступно ни во время, ни после создания стиля.

После завершения ввода или изменения всех параметров стиля линии нажмите кнопку ОК. Для выхода из диалога без сохранения стиля нажмите кнопку Отмена.

Смотрите также

Стиль линии с фрагментами


Диалог установки значения линейного, диаметрального или радиального размера

Этот диалог появляется на экране в следующих случаях:

– автоматически после простановки в параметрическом режиме линейного, диаметрального или радиального размера, если при настройке этого режима были включены опции Размеры и Фиксировать размеры,

– после вызова команды Установить значение размера и указания ассоциативного линейного, диаметрального или радиального размера,

– после двойного щелчка на размерной надписи ассоциативного линейного, диаметрального или радиального размера.

Диалог позволяет задать новое значение размера, ввести или отредактировать имя соответствующей ему переменной и комментарий к ней, а также сменить тип размера.

Описание элементов управления
Элемент | Описание
Выражение | Поле позволяет указать способ получения значения размера: число, константу или выражение для вычисления значения. Поле доступно для управляющего размера.
Значение, мм | Информационное поле, в котором отображается текущее значение размера.
Переменная | Поле для ввода имени переменной, соответствующей размеру. По умолчанию при простановке размера предлагается имя переменной, сформированное по шаблону «vN», где N — порядковый номер переменной в списке переменных документа. При необходимости вы можете отредактировать имя переменной. Если у размера не должно быть переменной, удалите имя переменной из поля.
Комментарий | Поле для ввода комментария к переменной.
Информационный размер | Опция, позволяющая управлять типом размера. – Включение опции означает, что размер будет информационным. Значение размера вручную задать нельзя. – Выключение опции означает, что размер будет управляющим. Значение размера задается в диалоге.

Выполнив все необходимые действия, нажмите кнопку OK. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.

Смотрите также

Установка значения размера

Управляющие и информационные размеры. Размеры с переменными


Диалог создания или редактирования стиля штриховки

Диалог создания или редактирования
стиля штриховки

Позволяет создать новый или отредактировать существующий пользовательский стиль штриховки. Стили можно хранить непосредственно в документе, в наборе или библиотеке стилей.

Диалог появляется на экране в следующих случаях:

– нажатие кнопки Новый диалога выбора стиля штриховки,

– нажатие кнопки Создать или Редактировать диалога Работа с наборами и библиотеками стилей.

Описание элементов управления
Элемент | Описание
Название | Поле позволяет задать имя стиля.
 | Поле просмотра содержит текущий внешний вид редактируемой штриховки. Изменения параметров оперативно отображаются в этом поле.
Номер | Поле позволяет ввести или отредактировать номер стиля. Номер является уникальным.
Группа Линии для штриховки
Список используемых линий | Содержит названия линий, образующих штриховку.
Поле просмотра | Содержит изображение линии, выделенной в списке.
Добавить... | Кнопка позволяет создать новую линию. Новая линия всегда добавляется в конец списка.
Редактировать... | Кнопка позволяет изменить параметры линии, выделенной в списке.
Удалить | Кнопка позволяет удалить линию, выделенную в списке.
Масштаб | Поле позволяет задать умолчательное значение масштаба изображения штриховки.
Не изменять | Опция позволяет управлять возможностью изменения масштаба при использовании штриховки данного стиля.
Угол наклона | Устанавливает угол наклона при изображении штриховки.
Не изменять | Чтобы угол наклона данного стиля штриховки не зависел от угла наклона вида чертежа, включите опцию.
Группа Тип заполнения
Область | Вариант позволяет заполнить штриховкой область внутри границы полностью.
Полоса | Вариант позволяет построить штриховку в виде полосы вдоль границы.
Ширина полосы | Позволяет задать ширину полосы штриховки. Поле доступно, если выбран вариант Полоса. Диапазон допустимых значений составляет 0,01…5000 мм.

После завершения ввода всех параметров стиля штриховки нажмите кнопку ОК. Для выхода из диалога без сохранения стиля нажмите кнопку Отмена.


Диалог установки параметров абзаца

Этот диалог появляется на экране после вызова команды Абзац... из меню Формат или из контекстного меню.

Позволяет назначить различные параметры для выделенных или набираемых заново абзацев текста.

Описание элементов управления
Элемент | Описание
Шаг строк | Устанавливает расстояние между строками текста.
Красная строка | Устанавливает величину отступа или вправо от границы абзаца в его первой строке. Если назначено выравнивание абзаца по правой границе или центрированием, значение отступа красной строки будет проигнорировано при форматировании этого абзаца.
Слева | Устанавливает величину абзацного отступа слева.
Справа | Устанавливает величину абзацного отступа справа.
Перед абзацем | Устанавливает величину интервала перед абзацем.
После абзаца | Устанавливает величину интервала после абзаца.
Выравнивание | Назначьте нужный способ выравнивания абзацев (по левой границе, по правой границе, центрирование, выравнивание по двум границам).
Располагать с новой страницы | Позволяет расположить абзац в начале новой страницы.
Табуляция | Позволяет задать параметры табуляции в абзаце. После нажатия этой кнопки на экране появляется диалог настройки параметров табуляции.

После завершения настройки параметров абзаца нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


Диалог удаления выделенной вставки

В этом диалоге запрашивается подтверждение на удаление выделенной вставки вида или фрагмента.

Для подтверждения удаления вставки нажмите кнопку ОК.

Для отказа от удаления нажмите кнопку Отмена.

Локальные фрагменты и вставки, взятые в документ, удаляются из документа физически (то есть уничтожается их содержимое). В случае вставок внешней ссылкой удаляются только ссылки на файлы-источники вставок, а сами файлы-источники на диске остаются неизменными.

Для быстрой отмены ошибочного удаления вставки нажмите кнопку Отменить на Стандартной панели после выхода из Менеджера вставок видов и фрагментов.


Диалог установки ограничений

Этот диалог появляется на экране после вызова команды Параметризовать объекты.

В нем можно установить типы ограничений, накладываемых на объекты при их автоматической параметризации.

Автоматическая параметризация объектов в ассоциативных видах, сохраняющих связь с моделями, невозможна.

Если среди выделенных есть непараметризуемые объекты, то на них не накладываются связи и ограничения.

Описание элементов управления
Наименование | Описание
Совпадение точек | Если эта опция включена, на точки объектов, расстояние между которыми меньше значения линейного допуска, будет наложено условие совпадения.
Горизонтальность | Если эта опция включена, на объекты, отклонение которых от горизонтали меньше значения углового допуска, будет наложено условие горизонтальности.
Вертикальность | Если эта опция включена, на объекты, отклонение которых от вертикали меньше значения углового допуска, будет наложено условие вертикальности.
Параллельность | Если эта опция включена, на объекты, угол наклона которых совпадает с точностью до значения углового допуска, будет наложено условие параллельности.
Перпендикулярность | Если эта опция включена, на объекты, угол между которыми составляет 90° с точностью до значения углового допуска, будет наложено условие перпендикулярности.
Допуск | Поле для ввода значения линейного допуска на несовпадение точек (в миллиметрах).
Угловой допуск | Поле для ввода значения допуска на угловые отклонения (в градусах).

Одновременное автоматическое наложение условий горизонтальности, вертикальности, параллельности и перпендикулярности невозможно. Таким образом, на горизонтальные и вертикальные объекты можно наложить либо условия горизонтальности и вертикальности, либо параллельности и перпендикулярности.

Завершив установку типов ограничений, нажмите кнопку ОК. Для выхода из диалога без изменения настроек нажмите кнопку Отмена.


Диалог ввода обозначения клеймения

Позволяет полуавтоматически сформировать текстовую надпись при простановке обозначения клеймения.

Описание элементов управления
Наименование | Описание
Содержание | Выберите из списка нужный вариант.
Способ нанесения | Выберите из списка название способа нанесения клеймения.

Закончив выбор, нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


Диалог ввода обозначения маркировки

Позволяет полуавтоматически сформировать текстовую надпись при простановке обозначения маркировки.

Описание элементов управления
Наименование | Описание
Содержание | Выберите из списка нужный вариант.
Способ нанесения | Выберите из списка название способа нанесения клеймения.

Закончив выбор, нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


Диалог ввода текста при изменении свойств объектов

Служит для ввода текста при изменении свойств объектов.

Этот диалог появляется после щелчка в ячейке значения любого свойства из группы Текст в окне Свойства.

В диалоге можно ввести или отредактировать текст, входящий в состав объекта (объектов).

Диалог содержит страницы меню Редактор, Вставить и Формат, команды которых соответствуют командам одноименных страниц Главного меню системы при вводе/редактировании текста и служат для создания и оформления надписей.

Если в редактируемой надписи предусмотрено создание нескольких строк, то в данном диалоге доступно добавление строк текста.

В противном случае возможно только редактирование или удаление имеющейся строки.

Для подтверждения внесенных изменений нажмите кнопку OK. Введенный или отредактированный текст будет передан в объект. Если перед вызовом диалога ввода текста было выделено несколько объектов с разными надписями, то введенный текст заменяет прежнюю надпись в каждом из объектов.

Для выхода из диалога без создания нового или изменения прежнего текста нажмите кнопку Отмена.


Диалог Список значений

Этот диалог появляется на экране после нажатия кнопки Правило для значений в диалоге Параметры свойства, если опция Заполнение из списка в этом диалоге включена.

Диалог позволяет сформировать или изменить список значений типа Целый, Вещественный или Строка текущего свойства.

Описание элементов управления
Наименование | Описание
Поле ввода значения | Поле служит для ввода текста нового значения. Чтобы данное значение было добавлено в список, нажмите кнопку Добавить значение или клавишу <Enter>.
Поле отображения списка | Поле служит для отображения сформированного списка значений.
Добавить значение | Кнопка позволяет добавить значение, заданное в поле ввода, в список значений.
Удалить значение | Кнопка позволяет удалить значение, указанное в списке.
Переместить значение в списке вверх/вниз | Кнопка позволяет переместить значение, выбранное в списке, на одну позицию вверх или вниз.

Для завершения формирования или изменения списка значений нажмите кнопку ОК. Кнопка Отмена позволяет закрыть диалог без сохранения изменений.


Диалог Управление свойствами

Этот диалог появляется на экране в следующих случаях:

– после вызова команды Сервис — Библиотеки стилей, типов, оформлений и основных надписей — Свойства объектов...,

– после нажатия кнопки Управление свойствами на инструментальной панели Отчеты или на Панели свойств при задании свойств объекту, а также при работе в Редакторе свойств.

Диалог позволяет создавать и редактировать библиотеки свойств, вносить изменения в список свойств текущего документа.

Описание элементов управления

Наименование

Описание

Окно просмотра

Окно позволяет отобразить список свойств текущего документа или выбранной библиотеки свойств.

Диалог содержит два окна просмотра. Чтобы выполнять различные действия в окне, активизируйте его щелчком мыши. При этом кнопки, расположенные между окнами, становятся доступными для работы со свойствами активного окна.

Если для отображения в окне выбран документ, окно содержит следующие вкладки:

– вкладку Документ (при работе с деталью),

– вкладки Документ и Компоненты (при работе со сборкой),

– вкладки Документ и Вставки (при работе с графическим документом).

Подробнее...

Документ

Вкладка содержит список свойств текущего документа.

Компоненты/Вставки

Вкладка содержит список свойств составных частей текущего документа.

– Вкладка Компоненты присутствует в диалоге при работе со сборкой. Она содержит список свойств компонентов текущей сборки первого уровня. В список включаются свойства компонентов, отличные от свойств сборки.

– Вкладка Вставки присутствует в диалоге при работе с графическим документом. Она содержит список свойств вставок видов/фрагментов. В список включаются свойства вставок, отличные от свойств текущего документа.

Свойства, перечисленные на данной вкладке, доступны только для просмотра и копирования.

Показать библиотеку

Кнопка позволяет отобразить в активном окне просмотра содержимое библиотеки свойств. Вызывает стандартный диалог Windows открытия файлов.

Показать документ

Кнопка позволяет отобразить в активном окне просмотра список свойств текущего документа. Если открытых документов нет, кнопка недоступна.

Создать раздел

Кнопка позволяет добавить новый раздел в библиотеку свойств. Раздел добавляется в библиотеку, содержимое которой отображается в активном окне просмотра.

Создать свойство

Кнопка позволяет добавить свойство в список свойств документа или библиотеки свойств. Вызывает диалог Параметры свойства.

Свойство добавляется в список свойств, отображаемый в активном окне просмотра.

Просмотреть

Кнопка позволяет просмотреть параметры свойства, указанного в списке. Вызывает диалог Параметры свойства. В режиме просмотра данные, содержащиеся в этом диалоге, недоступны для редактирования.

Редактировать

Кнопка позволяет изменить параметры свойства или раздела библиотеки свойств, указанного в списке. Вызывает диалог редактирования свойства или раздела.

Удалить

Кнопка позволяет удалить указанное свойство или раздел библиотеки свойств.

Копировать

Кнопка позволяет добавить свойство в документ или библиотеку свойств. После нажатия этой кнопки свойство, выделенное в активном окне просмотра, копируется в соседнее окно.

Свойство может быть скопировано

– в текущий документ — из библиотеки свойств или компонента текущей сборки (при работе со сборкой)/ вставок видов и фрагментов (при работе с графическим документом),

– в библиотеку свойств — из другой библиотеки, текущего документа или компонента текущей сборки (при работе со сборкой)/ вставок видов и фрагментов (при работе с графическим документом).

Перенести

Кнопка позволяет производить обмен свойствами между библиотеками свойств и документами. После нажатия этой кнопки выделенное свойство переносится из активного окна просмотра в соседнее окно.

Свойство может быть перенесено в текущий документ только из библиотеки свойств, а в библиотеку — из текущего документа или другой библиотеки.

Для завершения работы в диалоге нажмите кнопку Выход.


Диалог ввода текста марки/позиционного обозначения

Позволяет ввести текст марки/позиционного обозначения.

Диалог появляется на экране после двойного щелчка на тексте марки/позиционного обозначения. Во время создания и редактирования обозначения диалог ввода текста можно вызвать щелчком в поле Текст на Панели свойств или с помощью команды Текст надписи... из контекстного меню.

В окне диалога отображаются поля ввода текста марки/позиционного обозначения.

Описание элементов управления

Наименование

Описание

Текст до

Введите текст, предшествующий обозначению марки/позиционного обозначения.

Марка

Введите текстовое обозначение марки в левое поле, а ее номер — в правое. Если в чертеже уже были созданы марки/позиционные обозначения, марку можно выбрать из списка, раскрывающегося при нажатии кнопки со стрелкой в левом поле. После выбора марки, в том числе и не содержащей символов, становится доступен список номеров данной марки в правом поле. Укажите номер марки из списка или введите новый.

Для обозначения марок рекомендуется использовать символы, ввод которых возможен непосредственно с клавиатуры — цифры и буквы русского и латинского алфавитов и т.п. Если обозначение марки содержит символы, введенные при помощи команд Вставить — Символ... и Вставить — Спецзнак, то это обозначение будет создано, но в раскрывающийся список левого поля попадает только часть обозначения, находящаяся перед первым таким символом.

Если включена Автонумерация марок, то для выбранной марки предлагается следующий по порядку номер.

Текст после

В этом поле вы можете ввести текст, следующий за обозначением марки.

Текст под

В этом поле вводится текст, который отобразится под полкой обозначения.

Комментарий

В это поле можно ввести любую информацию, например, об элементе, для которого создается марка/позиционное обозначение. Комментарий не отображается в чертеже.

В процессе формирования обозначения его текущий внешний вид (за исключением текста под полкой) отображается в специальном поле в нижней части диалога.

Между маркой и номером элемента может находиться разделитель — один или несколько символов. Разделитель вставляется автоматически. Ввод символов разделителя производится в диалоге общих настроек марки/позиционного обозначения.

В меню диалога находятся команды редактирования, вставки и форматирования текста. Некоторые из них можно вызвать из контекстного меню поля ввода диалога.

Текст надписи может служить источником ссылки другого текстового объекта, находящегося в этом документе.

Чтобы введенный текст автоматически предлагался при создании новых марок/позиционных обозначений, включите опцию Сохранять текст на вкладке Знак Панели свойств. Если кнопка Автонумерация на вкладке Знак включена, элементам будут присваиваться свободные номера при неизменном остальном тексте.

После ввода текста марки/позиционного обозначения нажмите кнопку ОК. Для выхода из диалога без изменения текста нажмите кнопку Отмена.


Обнаружена рекурсивная вложенность

Это предупреждение выдается при попытке вставить в графический документ вид или фрагмент, ссылающийся на этот документ, или при попытке открыть документ, который содержит ссылку на себя самого (причем эта ссылка может быть косвенной).

Как исправить эту ошибку

– Нажмите кнопку Заменить, если хотите разместить во вставке на месте «кольцевой» ссылки ссылку на какой-либо другой документ, устранив тем самым рекурсивную вложенность. В появившемся стандартном диалоге открытия файлов выберите документ, который должен заменить вставку, вызывающую конфликт.

– Или нажмите кнопку Удалить вставки, если хотите удалить в документе «кольцевую» ссылку, устранив тем самым рекурсивную вложенность.

– Или нажмите кнопку Отказ от чтения для того, чтобы отказаться от чтения документа.


Диалог Задание имени группы нумерации

Диалог позволяет отредактировать имя пользовательской группы нумерации.

Появляется на экране при работе в диалоге Параметры пользовательских групп нумерации в следующих случаях:

– после нажатия кнопки Создать,

– после выделения имени группы и нажатия клавиши <F2>.

Диалог содержит поле Имя группы:, в котором отображается имя группы нумерации. Произведите необходимые изменения и нажмите кнопку ОК. Кнопка Отмена позволяет закрыть диалог, отказавшись от изменений.

Имя группы должно быть уникальным в пределах документа и содержать не более 256 символов.

Смотрите также

Автоматическая нумерация объектов


Диалог установки параметров замены

Этот диалог появляется на экране после вызова команды Редактор — Заменить....

В нем можно задать параметры для поиска и замены подстроки в тексте.

Описание элементов управления
Наименование | Описание
Найти: | Введите в это поле подстроку, которую необходимо найти. Если поиск уже выполнялся, то можно выбрать одну из подстрок в списке.
Заменить на: | Введите подстроку, которую необходимо вставить вместо найденной. Если замена уже выполнялась, то можно выбрать одну из подстрок в списке.
Различать регистр | Включите эту опцию, если хотите, чтобы система различала строчные и прописные буквы при поиске.
Только полное слово | Включите эту опцию, если заданная подстрока должна искаться только как отдельное слово в тексте.
Запрос на замену | Если эта опция включена, то система будет запрашивать подтверждение на замену каждой найденной подстроки.
Направление | Выберите нужное направление поиска в тексте: Вперед или Назад.
Начало поиска | Установите нужное начало поиска в тексте: От курсора или Граница текста.
Заменить все | Нажмите эту кнопку, если требуется заменить сразу все вхождения заданной подстроки в тексте.

После задания всех параметров нажмите кнопку ОК для начала поиска и замены. Для выхода из диалога без выполнения поиска и замены нажмите кнопку Отмена.

Для продолжения замены с заданными параметрами вызовите команду Редактор — Продолжить или нажмите клавишу <F3>.

Замена текста в таблице производится в пределах текущей ячейки.


Диалог настройки записи в формат предыдущей версии или формат КОМПАС 5.11 R03

Этот диалог появляется на экране при сохранении в файл формата предыдущей версии или формата КОМПАС 5.11 R03 документа, содержащего графические объекты, не поддерживаемые данной версией. В диалоге отображается таблица соответствия объектов.

В столбце Исходный объект перечислены объекты, не поддерживаемые версией КОМПАС, в которую выполняется сохранение; в столбце Результирующий объект — объекты, поддерживаемые этой версией, которые заменят исходные объекты так, чтобы внешний вид документа не изменился или изменился минимально.

Для некоторых исходных объектов возможен выбор варианта заменяющего объекта из списка. Чтобы раскрыть список, активизируйте строку таблицы, содержащую исходный объект, и щелкните мышью по кнопке с треугольником в ячейке столбца Результирующий объект этой строки (кнопка появляется в ячейке после активизации строки).

Чтобы сохранить текущий документ с заменой объектов, нажмите кнопку Да диалога, а чтобы отказаться от сохранения — кнопку Нет.

Настройка записи будет использоваться как умолчательная до конца сеанса работы.

Такие объекты, как рисунки и градиентные заливки, если они не прямоугольны, могут быть заменены не вполне корректно.

Внедренные оформления и стили спецификаций заменяются ссылками на содержащие их библиотеки *.lyt.

В формат КОМПАС 5.11 R03 не передается следующее:

– свойства документа, макроэлементов, вставок фрагментов и видов;

– очистка фона;

– порядок отрисовки объектов;

– спецификации разных стилей на листе чертежа;

– ссылки;

– гиперссылки;

– ограничения, наложенные на стрелки взгляда и линии разреза;

– ограничения, отсутствующие в КОМПАС 5.11 R03;

– характерные точки макроэлементов;

– OLE-объекты, вставленные в виде значка.


Диалог выбора единиц измерения

Этот диалог появляется на экране при чтении файлов в формате SAT.

Позволяет выбрать единицы измерения длины в импортируемой модели, если она была создана в системе SolidWorks ранних версий (в файле такой модели нет информации о единицах измерения длины).

Выберите единицы длины: Миллиметры, Сантиметры или Метры. Если при создании модели использовались другие единицы (например, дюймы), выберите опцию Произвольные и введите величину единицы измерения в миллиметрах (для дюймов эта величина — 25.4).

После выбора единиц измерения нажмите кнопку OK диалога. Модель будет импортирована в КОМПАС-3D, в ней будут использованы указанные единицы измерения.

Для отказа от импорта модели нажмите кнопку Отмена.


Диалог настройки раздела спецификации

Этот диалог появляется на экране после нажатия кнопки Редактировать стиль раздела на вкладке Разделы диалога Настройка спецификации.

Позволяет настроить стиль раздела, имя которого отражается в строке просмотра.

Описание элементов управления

Элемент

Описание

Вкладка Настройка

Опции этой вкладки позволяют настроить стиль раздела спецификации в целом.

Количество резервных строк в разделе

Введите требуемое или задайте счетчиком количество резервных строк для данного раздела.

Проставлять позиции

Включите эту опцию, чтобы в настраиваемом разделе был возможен автоматический расчет номеров позиций.

Подключать геометрию

Включите эту опцию, чтобы объектам настраиваемого раздела можно было поставить в соответствие геометрические объекты графического документа.

Сортировать объекты

Включите эту опцию, чтобы сортировка объектов внутри настраиваемого раздела производилась по предусмотренным стандартом правилам.

Размещать на новом листе

Включите эту опцию, чтобы настраиваемый раздел располагался на новом листе.

Марка

Включите эту опцию, чтобы ввести текст, который будет автоматически вставляться перед номерами позиций базовых объектов настраиваемого раздела.

Например, в стиле спецификации для использования в строительстве может быть раздел Перемычки с маркой ПР.

Текст марки размещается в колонке Позиция. Поэтому, если заполнение колонки Позиция в разделе отключено, то объекты этого раздела будут отображаться без марки, даже если она задана.

Независимая нумерация позиций

Включите эту опцию, чтобы настраиваемый раздел имел собственную — независимую от предыдущего раздела — нумерацию. Первый объект раздела с независимой нумерацией получает номер начальной позиции.

Опция Независимая нумерация позиций доступна, если включена опция Марка.

Показывать код документа

Опция управляет отображением и возможностью редактирования кодов документов в настраиваемом разделе.

Если опция включена, то:

– в таблице отображаются коды, входящие в обозначения документов, которые подключены к объектам раздела,

– при редактировании текстовой части объектов раздела доступна вставка кодов и наименований,

– диалог ввода обозначения, вызванный для объекта раздела, содержит колонку Код.

При отключенной опции ни одна из указанных возможностей не доступна.

Вкладка Подразделы

Опции этой вкладки позволяют настроить стили подразделов выбранного раздела.

Включить деление на подразделы

Включите эту опцию, чтобы сортировка объектов внутри настраиваемого раздела производилась вначале по подразделам (подразделы располагаются в порядке возрастания их номеров).

В окне просмотра перечислены существующие в настраиваемом разделе подразделы и их порядковые номера.

Добавить

Кнопка служит для создания нового подраздела.

Удалить

Кнопка удаляет выделенный цветом в окне просмотра подраздел.

Редактировать

Кнопка служит для редактирования названия выделенного цветом в окне просмотра подраздела или изменения его порядкового номера

Вкладка Блоки вложенных разделов

Опции этой вкладки позволяют настроить блоки вложенных разделов.

Использовать блоки

Опция, управляющая доступностью блоков вложенных разделов в спецификации.

При отключенной опции настройка блоков невозможна. Использование блоков в спецификации тоже будет невозможно — они будут отсутствовать в диалог выбора раздела.

Показывать заголовки блоков

Включите эту опцию, чтобы названия блоков отображались на экране при редактировании спецификации.

Заголовок

Для настройки внешнего вида заголовков раздела (шрифта, выравнивания и т.д.) нажмите эту кнопку и выберите в появившемся меню нужную команду форматирования. Кнопка доступна, если показ заголовков включен.

Список блоков

Перечень блоков вложенных разделов.

Чтобы блок был доступен при редактировании спецификации, включите опцию слева от названия блока.

Редактировать

Позволяет отредактировать блок, выделенный в списке.

Диалог настройки блока вложенных разделов

Завершив настройку стиля раздела, нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


Диалог настройки стиля раздела спецификации

Этот диалог появляется на экране после нажатия кнопки Добавить... или Редактировать... на вкладке Разделы диалога Стиль спецификации.

Позволяет настроить раздел спецификации.

Описание элементов управления

Элемент

Описание

Вкладка Настройки

Опции этой вкладки позволяют настроить раздел спецификации в целом.

Количество резервных строк в разделе

Введите требуемое для данного раздела количество резервных строк.

Позиции в разделе ставить

Включите эту опцию, чтобы в настраиваемом разделе был возможен автоматический расчет номеров позиций.

Геометрию в разделе подключать

Включите эту опцию, чтобы объектам настраиваемого раздела можно было поставить в соответствие геометрические объекты графического документа.

Размещать на новом листе

Включите эту опцию, если хотите, чтобы настраиваемый раздел располагался на новом листе.

Марка

Включите эту опцию, чтобы ввести текст, который будет автоматически вставляться перед номерами позиций базовых объектов настраиваемого раздела.

Так, при разработке стиля спецификации для использования в строительстве можно сформировать разделы, соответствующие элементам здания, и задать в каждом разделе марку — буквенное обозначение элемента. Например, раздел Перемычки должен иметь марку ПР.

Текст марки размещается в колонке Позиция. Поэтому, если заполнение колонки Позиция в разделе отключено, то объекты этого раздела будут отображаться без марки, даже если она задана.

Независимая нумерация позиций

Включите эту опцию, чтобы настраиваемый раздел имел собственную — независимую от предыдущего раздела — нумерацию. Первый объект раздела с независимой нумерацией получает номер начальной позиции.

Опция Независимая нумерация позиций доступна, если включена опция Марка.

Показывать код документа

Опция управляет отображением и возможностью редактирования кодов документов в настраиваемом разделе.

Если опция включена, то:

– в таблице будут видны коды, входящие в обозначения документов, которые подключены к объектам раздела,

– при редактировании текстовой части объектов раздела будет доступна вставка кодов и наименований,

– диалог ввода обозначения, вызванный для объекта раздела, будет содержать колонку Код.

При отключенной опции ни одна из указанных возможностей не будет доступна в настраиваемом разделе.

Заполнение колонок

Установите, как должно производиться заполнение колонок — вручную или смешанным способом — вручную с возможностью чтения информации из основной надписи связанных с объектами спецификации чертежей.

Вкладка Сортировка

На данной вкладке производится настройка сортировки объектов внутри раздела.

Объекты в разделе сортировать

Включите эту опцию, если хотите, чтобы производилась сортировка объектов внутри настраиваемого раздела.

Таблица колонок для сортировки

Позволяет задать список колонок, по которым производится сортировка, и тип сортировки в каждой из них.

В столбце Имя колонки указываются колонки для сортировки, в столбце Тип сортировки задается тип сортировки для каждой колонки.

Чтобы задать колонку для сортировки, щелкните мышью в строке таблицы, разверните список и выберите нужную колонку. Тип сортировки для каждой колонки указывается аналогично.

Сортировка объектов внутри раздела будет выполняться по выбранным колонкам в том порядке, в котором они перечислены в таблице.

Добавить

Кнопка служит для добавления строк в таблицу колонок.

Кнопка не доступна, если в столбце Имя колонки выбраны все имеющиеся в разделе колонки.

Удалить

Кнопка позволяет удалить выделенную строку таблицы колонок.

Кнопка недоступна, если в таблице всего одна строка.

Кнопки со стрелками

Позволяют управлять расположением строк в таблице колонок.

Вкладка Подразделы

Опции этой вкладки позволяют задать стили подразделов внутри настраиваемого раздела.

Деление на подразделы включить

Включите эту опцию, чтобы сортировка объектов внутри настраиваемого раздела производилась вначале по подразделам (подразделы располагаются в порядке возрастания их номеров).

В окне просмотра перечислены существующие в настраиваемом разделе подразделы и их порядковые номера.

Добавить...

Кнопка служит для создания нового подраздела.

Редактировать...

Кнопка служит для редактирования названия выделенного цветом в окне просмотра подраздела или изменения его порядкового номера.

Удалить

Кнопка удаляет выделенный цветом в окне просмотра подраздел.

Вкладка Колонки

Опции этой вкладки позволяют определить правила заполнения колонок внутри выбранного раздела.

В окне просмотра перечислены названия колонок, существующих в спецификации, стиль которой настраивается.

Колонка в разделе заполняется

Включите эту опцию, чтобы в колонку, название которой выделено цветом в окне просмотра, можно было вводить данные. Если опция выключена1, то есть заполнение колонки в настраиваемом разделе запрещено, то напротив названия колонки в окне просмотра отображается пиктограмма [image].

Тип значения в колонке

Необходимо указать, данные какого типа (строка, запись, целое или вещественное число) будут вноситься в колонку в данном разделе.

Минимальное

максимальное

Если тип данных — целое или вещественное число, можно установить минимальное и максимальное допустимое значение. Если тип данных — запись (например, при вводе наименования стандартных изделий), можно указать, в какой библиотеке атрибутов хранится шаблон заполнения этой записи.

Имя ячейки штампа для связи

Выберите название ячейки штампа чертежа детали, данные из которой могут автоматически передаваться в данную колонку спецификации. Например, в колонку Формат можно передавать текст из ячейки Формат штампа чертежа детали.

Вкладка

Дополнительные колонки

Опции этой вкладки позволяют определить правила заполнения дополнительных колонок внутри выбранного раздела.

В окне просмотра перечислены дополнительные параметры, которые можно присвоить объектам спецификации, и указано, заполняются ли дополнительные колонки с этими параметрами на основе данных из штампа подключенного к объекту спецификации чертежа и какого типа данные в них вносятся.

Параметр в разделе заполняется

Включите эту опцию, чтобы внутри настраиваемого раздела производилось заполнение параметра, название которого выделено цветом в окне просмотра.

Тип значения

Необходимо указать, данные какого типа (строка, целое или вещественное число) будут вноситься в дополнительную колонку в данном разделе.

Минимальное

максимальное

Если тип данных — целое или вещественное число, можно установить минимальное и максимальное допустимое значение.

Имя ячейки штампа для связи

Выберите название ячейки штампа чертежа детали, данные из которой могут автоматически передаваться в данную колонку спецификации. Например, в колонку Масса можно передавать текст из ячейки Масса изделия штампа чертежа детали.

Вкладка

Блоки вложенных разделов

Опции этой вкладки позволяют создать блоки вложенных разделов и настроить их.

Практически все параметры блоков вложенных разделов, заданные при настройке стиля спецификации, можно будет изменить при настройке спецификации, использующей данный стиль. Исключение составляют только имя и номер блока. Кроме того, при работе с документом-спецификацией невозможно создавать и удалять блоки.

Использовать блоки

Опция, управляющая доступностью блоков вложенных разделов в спецификации.

При отключенной опции настройка блоков и их использование в спецификации невозможны.

Показывать заголовки блоков

Включите эту опцию, чтобы названия блоков отображались на экране при редактировании спецификации.

Заголовок

Для настройки внешнего вида заголовков раздела (шрифта, выравнивания и т.д.) нажмите эту кнопку и выберите в появившемся меню нужную команду форматирования. Кнопка доступна, если показ заголовков включен.

Список блоков

Перечень блоков вложенных разделов.

Чтобы блок был доступен при редактировании спецификации, включите опцию слева от названия блока.

Добавить

Позволяет добавить в список новый блок. После нажатия этой кнопки на экране появляется диалог настройки блока вложенных разделов.

Редактировать

Позволяет отредактировать блок, выделенный в списке. После нажатия этой кнопки на экране появляется диалог настройки блока вложенных разделов.

Удалить

Позволяет удалить блок, выделенный в списке.
  1. Если в разделе запрещено заполнение колонки с типом ПОЗИЦИЯ, то в состав геометрии объектов спецификации этого раздела нельзя будет включать позиционные линии-выноски или марки/позиционные обозначения. Возможность включения геометрических объектов, составляющих изображение детали или узла, остается.

Завершив настройку раздела, нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


Диалог настройки стиля спецификации

Этот диалог появляется на экране после вызова команды Сервис — Библиотеки стилей, типов, оформлений и основных надписей — Стили спецификации — Редактировать....

Позволяет настроить стиль спецификации в целом. Настройки, произведенные в этом диалоге, будут действовать по умолчанию для всех спецификаций, имеющих данный стиль. Некоторые из этих настроек можно впоследствии изменить для каждой конкретной спецификации.

Описание элементов управления

Элемент

Описание

Вкладка Настройка

Опции этой вкладки позволяют настроить основные правила взаимодействия спецификации со сборочным чертежом.

Связь сборки или чертежа со спецификацией

Эта группа опций служит для определения типа связи модели (или листов сборочного чертежа) с текущей спецификацией. Если опция выключена, информация из подключенного документа не будет передаваться в спецификацию (однако документ будет по-прежнему подключен и связь можно будет включить в любой момент). Включение связи сборки или чертежа со спецификацией сделает доступными опции типа связи.

Только вставка объектов

Выбор варианта означает, что при сохранении подключенного документа, в который внесены изменения, касающиеся спецификации (созданы или отредактированы объекты спецификации), эти изменения будут переданы в спецификацию.

Связь с расчетом позиций

Выбор варианта означает, что после передачи изменений из подключенного документа в спецификацию в ней будет автоматически произведен расчет номеров позиций (в соответствии с последовательностью сортировки объектов) и новые номера позиций будут переданы в чертеж.

Рассчитывать позиции

Включите эту опцию, чтобы после сортировки объектов можно было автоматически проставить номера их позиций с учетом нового порядка объектов. Выключение этой опции делает невозможным связь чертежа и спецификации с расчетом позиций.

Рассчитывать зоны

Включите эту опцию, если хотите, чтобы при автоматической простановке номеров позиций происходило и обновление номеров зон чертежа.

Удалять геометрию при удалении объекта спецификации

Включите эту опцию, чтобы при удалении объекта спецификации из чертежа автоматически удалялись геометрические объекты и линии-выноски, входившие в его состав.

Удалять объекты спецификации при удалении геометрии

Включите эту опцию, чтобы при удалении из чертежа геометрических объектов и линий-выносок, входящих в состав объекта спецификации, этот объект удалялся из спецификации. Если опция включена, то после удаления геометрии объекта спецификации на экране появляется диалог, в котором можно подтвердить удаление этого объекта или отказаться от него.

Копировать объекты спецификации при копировании геометрии

Включите эту опцию, чтобы копия объекта спецификации автоматически создавалась при копировании в чертеже:

– всех геометрических объектов и линий-выносок, входящих в состав этого объекта,

– всех геометрических объектов, входящих в состав этого объекта,

– хотя бы одной линии-выноски, входящей в состав этого объекта.

Способ копирования геометрии — с помощью мыши или команд редактирования — для копирования объекта спецификации не имеет значения1.

Начальная позиция

Введите в это поле номер позиции, который будет иметь первый объект спецификации в первом разделе, для которого включена простановка позиций.

Строить снизу вверх

Включите эту опцию, чтобы разделы спецификации и объекты в них располагались снизу вверх.

Простой

Выберите этот вариант, если в стиле документа одно исполнение.

Групповой

Выберите этот вариант, если количество исполнений в стиле документа больше одного. В справочном поле будет отображаться название варианта его заполнения (согласно ГОСТ 2.113-75) — А или Б.

Количество исполнений

В этом поле нужно указать количество исполнений, для которого создается спецификация.

Если количество исполнений будет меньше, чем количество колонок типа КОЛИЧЕСТВО, сформированных во вкладке Колонки, то данные можно будет ввести только в колонки, соответствующие существующим исполнениям изделия.

Если количество исполнений будет больше, чем количество колонок типа КОЛИЧЕСТВО, то во вкладке Блоки исполнений следует настроить параметры отображения информации для исполнений.

Имя файла для вставки текстовых шаблонов

В этом поле указано имя файла, текстовые шаблоны из которого будут использоваться при заполнении спецификации. Если при настройке текстового редактора была включена запись введенных вручную текстов в файл текстовых шаблонов, то данные, введенные вручную при заполнении спецификации, будут сохраняться в указанном файле.

Обзор...

Чтобы сменить файл текстовых шаблонов, нажмите кнопку. В вызываемом ею стандартном диалоге открытия файлов укажите файл *.tdp.

Вкладка Оформление

Опции этой вкладки позволяют настроить оформление спецификации.

Формат листа

В этом поле указан формат листа бумаги, на котором будет размещаться настраиваемая спецификация.

Изменить

Кнопка вызывает на экран диалог выбора размера и ориентации бумаги.

Оформление первого листа,

Оформление последующих листов

Группы элементов управления, позволяющие выбрать оформления для первого и последующих листов спецификации.

В первом поле группы отображается полное имя текущей библиотеки оформлений *.lyt, а во втором — название оформления из этой библиотеки, присвоенного листу (листам).

Чтобы выбрать другую библиотеку, нажмите кнопку Обзор... и укажите в появившемся диалоге нужный файл *.lyt. После этого на экране появится диалог, в котором нужно указать оформление из выбранной библиотеки. Название указанного оформления появится в соответствующем поле диалога.

Чтобы выбрать другое оформление, нажмите кнопку с многоточием справа от поля.

Следует обратить внимание, что указание оформлений для первого и последующих листов спецификации является обязательным.

Вкладка Колонки

Опции этой вкладки позволяют создать список колонок для данного стиля спецификации и определить правила их заполнения.

В окне просмотра перечислены названия колонок, существующих в спецификации, стиль которой настраивается, и их описания.

Сформировать по умолчанию

Для формирования нового списка колонок после изменения оформления спецификации нажмите эту кнопку.

Редактировать....

Для редактирования описания выделенной колонки нажмите кнопку

Вкладка Разделы

Опции этой вкладки позволяют настроить разделы спецификации.

Разбивать на разделы

Включите эту опцию, чтобы спецификация была разбита на разделы.

Показывать заголовки разделов

Включите эту опцию, чтобы названия разделов отображались на экране при редактировании спецификации.

Заголовок...

Для настройки внешнего вида заголовков раздела (шрифта, выравнивания и т.д.) нажмите эту кнопку и выберите в появившемся меню нужную команду форматирования.

Брать шрифт из оформления

Включите эту опцию, чтобы шрифт объектов спецификации был таким, какой он установлен по умолчанию в таблице спецификации. Выключите опцию, если шрифт должен быть другим.

Шрифт объекта...

Нажмите на эту кнопку и в появившемся диалоге укажите требуемый шрифт объекта спецификации. Кнопка доступна при выключенной опции Брать шрифт из оформления.

В окне просмотра отображаются названия разделов, существующих в спецификации, и настройки стилей каждого из этих разделов. Настройки стилей разделов отображаются в виде последовательности пиктограмм.

— Включено деление на подразделы

— Данные из штампа чертежа передаются в спецификацию

— Включена сортировка объектов внутри раздела

— К объектам раздела можно подключить геометрию

— Включена простановка позиций внутри раздела.

При отсутствии в стиле спецификации пользовательских разделов (т.е. если они еще не созданы или все удалены) список состоит из одного раздела — Системного. Удалить его из стиля вручную невозможно. Он автоматически удаляется при добавлении первого пользовательского раздела.

Сортировать по убыванию

Включите эту опцию, чтобы разделы располагались внутри спецификации в порядке убывания их порядковых номеров.

Добавить...

Эта кнопка служит для внесения в спецификацию нового раздела. Она вызывает на экран диалог, в котором следует настроить стиль вновь создаваемого раздела спецификации.

Редактировать...

Эта кнопка служит для изменения настроек стиля раздела, название которого выделено цветом в окне просмотра. Для быстрого изменения настройки текущего раздела при редактировании спецификации пользуйтесь кнопками-переключателями в Строке параметров объектов.

Удалить

Эта кнопка служит для удаления раздела, выделенного цветом в окне просмотра. После ее нажатия на экране появляется диалог, в котором вы можете подтвердить удаление выделенного раздела или отказаться от удаления.

Кнопки Добавить, Редактировать и Удалить недоступны до тех пор, пока не сформирован список колонок настраиваемого стиля спецификации.

Вкладка Дополнительные колонки

Опции этой вкладки позволяют определить правила заполнения дополнительных колонок внутри выбранного раздела. В окне просмотра перечислены виды дополнительных параметров, которые можно присвоить объектам спецификации, и даны описания этих колонок.

Добавить...

Кнопка служит для создания новой дополнительной колонки.

Редактировать...

Кнопка служит для редактирования описания выделенной в окне просмотра колонки.

Удалить

Кнопка удаляет выделенную в окне просмотра доп. колонку.

Кнопки со стрелками

Позволяют управлять расположением дополнительных колонок.

Вкладка Блоки исполнений

Опции этой вкладки позволяют указать правила заполнения спецификаций на изделие, количество исполнений для которого превышает количество колонок бланка, предназначенных для записи количества на исполнение (например, при создании спецификации для изделия с двадцатью пятью исполнениями на стандартном бланке групповой спецификации). Здесь же можно настроить правила автоматического формирования обозначений исполнений объектов спецификации и исполнений специфицируемого изделия.

Показывать заголовки блоков

Включите эту опцию, чтобы названия блоков исполнений отображались в спецификации.

Заголовок

Для настройки внешнего вида заголовков блоков (шрифта, выравнивания и т.д.) нажмите эту кнопку и выберите в появившемся меню нужную команду форматирования. Кнопка доступна, если показ заголовков включен.

Размещать блок на новом листе

Включение опции означает, что информация о каждой группе исполнений должна начинаться на новой странице (при отображении ее как блоками, так и по объектам). При таком способе отображения строки Обозн. исполн. не возникают в спецификации, а номера каждой группы исполнений размещаются в шапке спецификации.

Показывать исполнения, не содержащие переменных данных

Эта опция доступна для групповой спецификации по варианту А и управляет обработкой исполнений, в которых не применяются переменные данные.

– Включение опции означает, что для исполнений без переменных данных будут создаваться блоки, содержащие строку со словом Отсутствует (отображение заголовков блоков должно быть включено). Если переменных данных не окажется ни в одном исполнении, то блоки созданы не будут, а в конец спецификации добавится строка с текстом Различия исполнений по сборочному чертежу. Данные строки представляют собой отметки об отсутствии переменных данных.
Текст отметок можно отредактировать. Измененный текст сохраняется в документе.

– При выключенной опции не создаются блоки для исполнений, которые не содержат переменных данных, а также отметки об отсутствии переменных данных.

Формирование номеров исполнений изделия

В группе опций можно указать, по каким правилам должны автоматически формироваться номера исполнений специфицируемого изделия в «шапке» спецификации и в строке Обозн. исполн.

Вставлять нули перед числом

Вставлять тире перед числом

Система может вставлять нули и/или тире перед числом (при включении соответствующих опций). Например, если вы включите обе опции, в «шапке» спецификации появятся номера исполнений —, -01, -02, -03 и т.д.

Выдавать информацию

Группа опций доступна при условии, что количество исполнений, указанное во вкладке Настройка, превышает количество колонок типа КОЛИЧЕСТВО, сформированных во вкладке Колонки (то есть исполнений больше, чем предназначенных для них колонок).

По объектам

При выборе варианта информация о количестве объектов на исполнение будет выдаваться для каждого объекта в отдельности. Внутри каждого раздела возникнет такое количество строк для каждого объекта, которое позволит ввести количество для всех исполнений; автоматически будут сформированы строки Обозн. исполн., в которых расположатся номера исполнений специфицируемого изделия.

Блоками

При выборе варианта вся информация о количестве будет выдаваться вначале для первых нескольких исполнений, которые поместятся в колонках бланка (например, для исполнений с базового по девятое), затем — для следующей группы исполнений (например, с десятого по девятнадцатое) и так далее. В результате в спецификации образуется несколько блоков, разделенных автоматически сформированными строками Обозн. исполн., содержащих одинаковые разделы и объекты. Отличаться будут только данные в колонках Количество на исполнение.

Если блок исполнений начинается на новой странице, то строка Обозн. исполн. не отображается, а номера исполнений размещаются в «шапке» спецификации на этой странице.

Формировать обозначения исполнений объектов

Группа опций управляет автоматическим формированием обозначений объектов при вызове команды Добавить исполнения объекта. Объекты, созданные при помощи этой команды, являются копиями одного и того же объекта спецификации; их текстовые части отличаются только суффиксами в обозначении (например, АБВГ.125.567800, АБВГ.125.567800-01, АБВГ.125.567800-02, АБВГ.125.567800-05 и т.д.).

Показывать полностью

Если выбран этот вариант, то обозначения объектов отображаются полностью (как показано в предыдущем примере).

Показывать только номер

Если выбран этот вариант, то полностью показывается только обозначение того объекта, на основе которого созданы остальные объекты. Обозначения автоматически сформированных объектов отображаются в виде номера (например, АБВГ.125.567800, -01, -02, -03).

Позиции возрастают

Если включена опция, то позиции объектов, являющихся исполнениями, отображаются в таблице спецификации; номера позиций возрастают.

Вкладка Блоки дополнительных разделов

Опции этой вкладки позволяют создать блоки дополнительных разделов и настроить их.

Практически все параметры блоков дополнительных разделов, заданные при настройке стиля спецификации, можно будет изменить при настройке спецификации, использующей данный стиль. Исключение составляют только имя и номер блока. Кроме того, при работе с документом-спецификацией невозможно создавать и удалять блоки.

Использовать блоки

Опция, управляющая доступностью блоков дополнительных разделов в спецификации.

При отключенной опции настройка блоков и их использование в спецификации невозможны.

Показывать заголовки блоков

Включите эту опцию, чтобы названия блоков отображались на экране при редактировании спецификации.

Заголовок

Для настройки внешнего вида заголовков разделов (шрифта, выравнивания и т.д.) нажмите эту кнопку и выберите в появившемся меню нужную команду форматирования. Кнопка доступна, если показ заголовков включен.

Список блоков

Перечень блоков дополнительных разделов.

Чтобы блок был доступен при редактировании спецификации, включите опцию слева от названия блока.

Добавить

Позволяет добавить в список новый блок. После нажатия этой кнопки на экране появляется диалог настройки блока дополнительных разделов.

Редактировать

Позволяет отредактировать блок, выделенный в списке. После нажатия этой кнопки на экране появляется диалог настройки блока дополнительных разделов.

Удалить

Позволяет удалить блок, выделенный в списке.
  1. Если геометрия объекта спецификации расположена в разных видах чертежа, то этот объект спецификации копируется также при копировании части геометрии, целиком расположенной в одном виде.

Завершив настройку стиля спецификации, нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


Диалог выбора схемы видов

Этот диалог появляется на экране после вызова команды Схема видов.

В нем можно задать набор стандартных видов, построение которых необходимо для создания чертежа выбранной модели.

В окне просмотра диалога отображается схема, на которой показано стандартное расположение всех видов чертежа. Взаимное расположения видов на схеме зависит от проекционного метода. Выбор проекционного метода выполняется в диалоге настройки параметров вида.

Выберите на схеме виды, которые должны быть построены для получения чертежа модели.

Если вид указан для построения, то в его габаритном прямоугольнике отображается соответствующий вид условной модели.

Если вид не указан для построения, то он отображается в виде пустого габаритного прямоугольника.

Отключить построение главного вида невозможно.

В поле Зазор по горизонтали можно задать расстояние между габаритными прямоугольниками видов по горизонтали (в миллиметрах). Это расстояние будет откладываться, например, между главным видом и видом слева.

В поле Зазор по вертикали можно задать расстояние между габаритными прямоугольниками видов по вертикали (в миллиметрах). Это расстояние будет откладываться, например, между главным видом и видом сверху.

Указанные расстояния измеряются «по бумаге», без учета масштаба видов.

Для сохранения всех изменений и выхода из диалога нажмите кнопку ОК, для выхода без сохранения — кнопку Отмена.


Диалог точного позиционирования спецификации на листе

Позволяет задать положение спецификации на листе, указав координаты любого ее угла в системе координат нулевого (системного) вида.

При помощи соответствующей опции укажите, какой угол является точкой привязки таблицы. Введите координаты, которые должна иметь эта точка.

В справочном поле Номер страницы отображается номер той страницы спецификации, позиционирование которой производится.

Для выхода из диалога и размещения таблицы указанным образом нажмите кнопку OK. Для отказа от изменения положения таблицы спецификации нажмите кнопку Отмена.


Общий диалог настройки параметров

Позволяет изменить внешний вид окна КОМПАС-3D, а также различные параметры системы.

Он появляется на экране после вызова команды Сервис — Параметры.... Если при вызове команды в главном окне системы не было открыто ни одного документа, то диалог настройки содержит две вкладки — Система и Новые документы. Если же открытые документы имелись, то в диалоге есть также вкладки Текущий документ и Текущее окно.

Для изменения какой-либо группы настроек выберите название этой группы из списка в левой части вкладки и установите затем нужные значения параметров в правой части вкладки.

Чтобы развернуть содержание какого-либо раздела, установите курсор на значке <+> рядом с заголовком раздела и щелкните левой кнопкой мыши. Повторный щелчок на этом символе (после разворачивания раздела он отображается как <->) приведет к сворачиванию содержания раздела.

После завершения настроек нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


Диалог выбора оформления листа

Этот диалог появляется на экране после вызова команды настройки оформления листа, например, нажатия кнопки Добавить в диалоге настройки дополнительных листов или вызова команды Оформление контекстного меню листа в Списке листов, видов и слоев диалога Менеджер документа.

Позволяет назначить оформление, которое будет использоваться для листа.

Описание элементов управления

Наименование

Описание

Библиотека

В поле Библиотека отображается полное имя к файлу библиотеки (*.lyt), содержащей оформление, присвоенное листу.

Чтобы выбрать другой файл библиотеки, нажмите кнопку справа от поля и укажите в появившемся диалоге нужный файл *.lyt. На экране появится диалог, в котором нужно указать оформление из выбранной библиотеки. Название указанного оформления появится в соответствующем поле диалога.

Название

В этом поле отображается название оформления, присвоенного листу. Если это оформление отличается от соответствующего ему оформления в библиотеке *.lyt (отличия могут возникнуть, например, после редактирования библиотеки), то перед названием оформления отображается «звездочка» (*).

Чтобы выбрать другое оформление, нажмите кнопку с многоточием справа от поля. На экране появится диалог со списком оформлений, содержащихся в текущей библиотеке оформлений. Выберите нужное оформление и нажмите кнопку ОК диалога.

Перечитать

Позволяет присвоить листу выбранное оформление взамен имеющегося или обновить оформление, если оно отличается от оформления в библиотеке. После нажатия этой кнопки листу будет присвоено оформление из библиотеки, «звездочка» перед названием оформления (если она была) исчезнет.

Кнопка Перечитать присутствует в диалоге, если он вызван для листа, которому уже присвоено какое-либо оформление, например, для уже существующего листа чертежа.

ОК

Позволяет подтвердить выбор оформления для листа.

Кнопка ОК присутствует в диалоге, если он вызван для листа, которому оформление еще не присвоено, например, для нового дополнительного листа в начале или конце спецификации.

Очистить

Чтобы отключить библиотеку стилей, нажмите эту кнопку.

После завершения настройки оформления листа нажмите кнопку ОК или Перечитать. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.

Смотрите также

Хранение в документе информации об используемом оформлении

Настройка обновления оформления


Диалог настройки блока разделов

Этот диалог появляется на экране при добавлении и редактировании блока вложенных или дополнительных разделов (т.е. после нажатия кнопки Добавить или Редактировать на вкладке Блоки вложенных разделов диалога настройки стиля раздела либо на вкладке Блоки дополнительных разделов диалога настройки стиля спецификации).

Описание элементов управления

Элемент

Описание

Имя блока

Поле для ввода заголовка блока. Заголовок блока может содержать специальные синтаксические конструкции:

\n — служит для переноса следующего за ней текста на новую строку,

#XXX# — позволяет связать заголовок блока с КОМПАС-документом; количество и тип символов между «решетками» не имеет значения.

Номер блока

Поле для ввода номера блока разделов.

Номера блоков разделов должны быть уникальны (для блоков вложенных разделов — в пределах раздела).

Разделы спецификации

В списке разделов доступны все разделы, определенные в стиле спецификации. Чтобы отметить те из них, которые должны использоваться в настраиваемом блоке, включите опцию рядом с именем раздела. Настройки разделов, использующихся в блоках, полностью совпадают с настройками соответствующих обычных разделов.

Использовать в работе

Опция, управляющая доступностью настраиваемого блока при редактировании спецификации.

Размещать на новом листе

Опция, управляющая расположением настраиваемого блока. Обычно с новой страницы располагаются блоки дополнительных разделов.

Марка1

Включите эту опцию, чтобы ввести текст, который будет автоматически вставляться перед номерами позиций базовых объектов тех разделов блока, в которых разрешено заполнение колонки Позиция.

Если в разделе спецификации, входящем в блок, задана собственная марка, то она игнорируется и используется марка блока.

Независимая нумерация позиций1

Включите эту опцию, чтобы объекты настраиваемого блока имели собственную — независимую от предыдущих объектов — нумерацию позиций. Первый объект в блоке с независимой нумерацией получает номер начальной позиции.

Если в блоке присутствует раздел с независимой нумерацией, эта настройка сохраняется, т.е. первый объект раздела будет иметь номер начальной позиции.

Опция Независимая нумерация позиций доступна, если включена опция Марка.
  1. Опция присутствует в диалоге при настройке блока дополнительных разделов.


Диалог настройки блока разделов в текущей спецификации

Этот диалог появляется на экране при редактировании блока вложенных или дополнительных разделов (т.е. после нажатия кнопки Добавить или Редактировать на вкладке Блоки вложенных разделов диалога настройки раздела либо на вкладке Блоки дополнительных разделов диалога настройки текущей спецификации).

Описание элементов управления

Элемент

Описание

Имя блока

Номер блока

Справочные поля. Их значения задаются при настройке стиля спецификации.

Разделы спецификации

В списке разделов доступны все разделы, определенные в стиле спецификации. Чтобы отметить те из них, которые должны использоваться в настраиваемом блоке, включите опцию рядом с именем раздела. Настройки разделов, использующихся в блоках, полностью совпадают с настройками соответствующих обычных разделов.

Использовать в работе

Опция, управляющая доступностью настраиваемого блока при редактировании спецификации.

Размещать на новом листе

Опция, управляющая расположением настраиваемого блока. Обычно с новой страницы располагаются блоки дополнительных разделов.

Марка1

Включите эту опцию, чтобы ввести текст, который будет автоматически вставляться перед номерами позиций базовых объектов тех разделов блока, в которых разрешено заполнение колонки Позиция.

Если в разделе спецификации, входящем в блок, задана собственная марка, то она игнорируется и используется марка блока.

Независимая нумерация позиций1

Включите эту опцию, чтобы объекты настраиваемого блока имели собственную — независимую от предыдущих объектов — нумерацию позиций. Первый объект в блоке с независимой нумерацией получает номер начальной позиции.

Если в блоке присутствует раздел с независимой нумерацией, эта настройка сохраняется, т.е. первый объект раздела будет иметь номер начальной позиции.

Опция Независимая нумерация позиций доступна, если включена опция Марка.

Документ

Поле, содержащее полное имя файла КОМПАС-документа для связи с заголовком блока.

Чтобы выбрать или сменить документ для связи, нажмите кнопку Обзор... справа от поля.

  1. Опция присутствует в диалоге при настройке блока дополнительных разделов.

Завершив настройку блока разделов, нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


Диалог выбора сборочного чертежа

Диалог появляется на экране после вызова команды Редактировать состав объекта, если к спецификации подключено более одного чертежа.

Позволяет указать, в каком из подключенных к спецификации чертежей находятся выделенные графические объекты, которые требуется ввести в состав редактируемого объекта спецификации. Если требуется очистить состав объекта спецификации от геометрии, можно указывать любой лист, в котором нет выделенных объектов.

В окне просмотра в уменьшенном масштабе показывается документ, имя которого выделено в списке подключенных документов цветом.

Выбрав документ, геометрию из которого нужно ввести в состав объекта спецификации, нажмите кнопку ОК.

В появившемся на экране диалоге редактирования состава объекта выберите вариант изменения состава (добавить выделенные элементы к уже находящимся в составе объекта спецификации, заменить геометрию в составе объекта спецификации группой выделения или, если группа выделения пуста, очистить объект спецификации от геометрии).


Диалог управления сборкой

Диалог появляется на экране после вызова команды Сервис — Управление сборкой.

Позволяет подключать КОМПАС-документы (листы чертежа — *.сdw и сборки — *a3d) к спецификации и отключать их, запускать редактирование подключенных документов и настраивать передачу данных между спецификацией и подключенными к ней документами.

Количество документов, одновременно подключенных к спецификации, не ограничено.

Описание элементов управления

Наименование

Описание

Список документов

В списке показаны названия КОМПАС-документов, подключенных к текущей спецификации. Документ, имя которого выделено в списке цветом, отображается в окне предварительного просмотра в уменьшенном масштабе. Для отказа от предварительного просмотра активизируйте опцию Выключить просмотр.

Чтобы включить автоматическую передачу обозначения и наименования изделия из текущей спецификации в документ, включите для него опцию в колонке Передавать изменения в документ.

Подключить документ

Кнопка служит для подключения документа к текущей спецификации. В вызываемом ею стандартном диалоге открытия файлов выберите нужный документ (или сразу несколько документов). Документ может быть одновременно подключен только к спецификациям разных стилей (например, к простой, групповой и пользовательской). Поэтому если выбранный документ уже подключен к спецификации такого же типа, как текущая, его невозможно подключить к текущей спецификации.

Отключить документ

Кнопка служит для отключения документа, имя которого выделено цветом, от текущей спецификации. При отключении документа выдается запрос на удаление объектов, содержащихся в отключаемом документе, из спецификации. Нажмите кнопку Да, если объекты должны быть удалены из спецификации, или кнопку Нет, если они должны в ней остаться. Кнопка Отказ позволяет отказаться от отключения листа или сборки.

Редактировать документ

Кнопка позволяет загрузить документ, имя которого выделено цветом в списке. При загрузке документа активным остается окно спецификации, и для редактирования чертежа необходимо активизировать его окно.

Заполнить основную надпись

Кнопка позволяет включить автоматическую передачу обозначения и наименования из первого по списку подключенного документа в основную надпись текущей спецификации.

Переместить вверх/вниз

Кнопки служат для перемещения выделенного имени документа по списку. Порядок расположения подключенных к спецификации документов в списке учитывается при расчете позиций и номеров зон, а также при автоматическом заполнении основной надписи спецификации.

Сформировав нужный список подключенных к спецификации документов, или загрузив их, или настроив передачу обозначения и наименования, нажмите кнопку Выход. Чтобы в этих документах появилась информация о том, что их подключили к спецификации (или отключили от нее), необходимо после выхода из диалога вызвать команду Синхронизировать данные.

Смотрите также

Передача обозначения и наименования изделия между спецификацией и подключенными к ней документами


Диалог выбора шаблона заполнения текстовой части

Этот диалог появляется на экране после нажатия на кнопку Выбрать шаблон в диалоге выбора раздела и типа объекта.

В нем можно выбрать шаблон заполнения текстовой части нового объекта спецификации.

В окне просмотра показан структурированный список доступных в текущем разделе шаблонов. Чтобы развернуть раздел списка, щелкните по знаку «+» рядом с его именем.

Выделите название нужного шаблона и нажмите кнопку Выбрать. Для выхода из диалога без выбора шаблона нажмите кнопку Отмена.


Диалог выбора объекта спецификации

Этот диалог появляется на экране после вызова команды Редактировать объект спецификации из контекстного меню выделенной линии-выноски, входящей в состав нескольких объектов.

В диалоге перечислены объекты спецификации, включающие выделенную линию-выноску. Из представленного списка (в нем перечислены обозначения и наименования объектов) можно выбрать тот объект, который требуется отредактировать.

Установите указатель рядом с обозначением объекта, который требуется отредактировать, и нажмите кнопку OK. Система перейдет в режим редактирования этого объекта спецификации. Для отказа от редактирования объекта нажмите кнопку Отмена.

Если выделенная линия-выноска входит в состав только одного объекта спецификации, то при вызове команды редактирования объекта спецификации, содержащего эту линию-выноску, выбирать объект спецификации не требуется, и система сразу переходит в режим его редактирования.


Диалог настройки колонки спецификации

Этот диалог появляется на экране после нажатия кнопки Редактировать на вкладке Колонки диалога Стиль спецификации.

Позволяет настроить правила заполнения конкретной колонки, имя которой отображается в строке просмотра.

Описание элементов управления
Наименование | Описание
Имя колонки | Если вы настраиваете один из стандартных стилей спецификаций, входящих в комплект поставки КОМПАС-3D, то имя колонки совпадает с названием колонки в заголовке спецификации и изменять его без крайней необходимости не рекомендуется. Если вы настраиваете самостоятельно созданный стиль спецификации, введите любое имя колонки.
Тип колонки | Выберите из предложенного списка тип колонки.
Номер колонки данного типа | Задайте номер колонки, если спецификация содержит более одной колонки данного типа.
Тип данных | Выберите из списка тип данных (строка, запись, целое или вещественное число) для ввода в колонку. Тип данных не должен противоречить типу колонки. Например, не следует в колонку с типом НАИМЕНОВАНИЕ вносить только числа.
Минимальное значение Максимальное значение. | Задайте максимальное и минимальное значения числа в колонке. Поля доступны для данных типа Вещественный или Целый.
Складывать значения в таблице | Включите эту опцию для тех колонок, в которых данные должны быть просуммированы при вызове команды Сложить значения в колонках. Опция доступна для данных типа Вещественный или Целый.
Умножать на количество деталей | Включите эту опцию для тех колонок, данные которых перед сложением при вызове команды Сложить значения в колонках, должны быть умножены на числа в колонке Количество. Опция доступна для данных типа Вещественный или Целый.
Обзор | Нажмите кнопку, чтобы выбрать файл библиотеки атрибутов, содержащий шаблон заполнения этой записи. Кнопка доступна для данных типа Запись.
Ключ 1, Ключ 2, Ключ 3 | Введите значения ключей шаблона заполнения записи. Поля доступны для данных типа Запись.
Имя ячейки штампа для связи | Выберите название ячейки штампа чертежа детали, данные из которой могут автоматически передаваться в данную колонку спецификации. Например, в колонку Формат можно передавать текст из ячейки Формат штампа чертежа детали.
Выравнивать однострочные тексты по нижнему краю | Включите эту опцию, чтобы однострочные тексты в настраиваемой колонке располагались в той строке, в которой кончается текст предыдущей колонки. Чаще всего эту опцию включают при настройке колонки Количество, когда требуется, чтобы количество было записано в той строке, где заканчивается наименование.
Располагать заголовки разделов в данной колонке | Включите эту опцию при настройке той колонки, в которой должны располагаться заголовки разделов спецификации. В стандартных спецификациях заголовки разделов обычно располагаются в колонке Наименование. Включение этой опции для настраиваемой колонки отменяет ее включение для другой колонки (если оно производилось ранее). Данная опция может быть включена только для одной колонки спецификации. Если она не включена ни для одной колонки, заголовки разделов показываться не будут (даже при включении в настройке разделов опции Показывать заголовки разделов).
Использовать в модели | Включите эту опцию, чтобы в настраиваемую колонку можно было вводить данные при формировании объектов спецификации в документе-модели. Если опция Использовать в модели выключена, то заполнение колонки в объектах спецификации модели невозможно. С помощью опции Использовать в модели можно настроить стиль спецификации так, чтобы в документах-моделях формировались частично заполненные объекты спецификации. Это позволяет избежать конфликтов взаимодействия документа-модели со спецификацией и чертежом.

Завершив настройку стиля колонки, нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


Диалог выбора объектов спецификации для удаления

Это диалог появляется на экране после удаления из чертежа геометрии, связанной с объектом (объектами) спецификации или таблицы изменений, если при настройке спецификации включено удаление объектов при удалении геометрии.

Геометрия может удаляться также в результате удаления объекта спецификации (таблицы изменений), с которым она связана, если при настройке спецификации включено удаление геометрии при удалении объектов. Одна и та же геометрия может входить в состав нескольких объектов спецификации (таблицы изменений). Поэтому, если удаление одного объекта спецификации (таблицы изменений) приводит к удалению геометрии, формирующей состав другого объекта (объектов), то на экране также появляется данный диалог.

В окне диалога перечислены обозначение и наименования всех объектов спецификации (таблицы изменений), состав которых полностью удаляется при удалении выбранных геометрических объектов. Чтобы продолжить работу, следует нажать одну из кнопок диалога.

Описание элементов управления
Наименование | Описание
Удалить | Удаляет выделенные объекты спецификации (таблицы изменений). Чтобы выделить один объект, щелкните на нем мышью. Чтобы выделить несколько объектов, воспользуйтесь клавишами <Shift> и (или) <Ctrl>.
Удалить все | Удаляет из спецификации (таблицы изменений) все перечисленные в диалоге объекты спецификации вне зависимости от их выделения.
Не удалять | Оставляет в спецификации (таблице изменений) все перечисленные в диалоге объекты. Такой же результат дает закрытие диалога кнопкой Закрыть в верхнем правом углу.


Диалог управления описаниями спецификаций

Этот диалог появляется на экране после вызова команды Управление описаниями спецификаций....

В нем можно просмотреть и отредактировать описания спецификаций, имеющиеся в текущем чертеже или модели.

Описание элементов управления

Наименование

Описание

Документ

Имя текущего документа.

Описания спецификаций

Окно, содержащее список имеющихся в документе описаний спецификаций.

Этот список представляет собой таблицу из трех колонок:

Текущий — отметка в этой колонке означает, что соответствующее описание является текущим.

На листе — отметка в этой колонке означает, что объекты спецификации данного описания отображаются в таблице спецификации, размещенной на листе текущего чертежа.

Имя — колонка, содержащая имена входящих в описания стилей спецификаций; если спецификация соответствующего стиля подключена к документу, то в данной колонке отображается также имя файла спецификации.

Вариант — колонка для особых отметок; присутствует в диалоге в следующих случаях:

– Документ содержит несколько описаний спецификации и хотя бы для одного из них не найден стиль спецификации (т.е. либо не найдена библиотека, из которой был взят стиль, либо библиотека найдена, но в ней нет стиля с нужным номером). В этом случае колонка содержит отметку Не найден. Чтобы указать другую библиотеку или другой стиль, выделите описание и нажмите кнопку Редактировать описание.

– Документ содержит несколько описаний с аналогичными друг другу стилями спецификации. В этом случае колонка содержит следующие отметки: прочерк — в ячейке описания со стилем-образцом, Вариант или Дубль — в ячейках описаний со стилями-аналогами. Чтобы объединить описания с аналогичными стилями, нажмите в диалоге кнопку Объединить варианты.
Подробнее об объединении вариантов описаний спецификаций...

Для выполнения действий с описанием, его необходимо выделить щелчком мыши. Имя выделенного описания подсвечивается.

Настройка спецификации...

Кнопка вызывает на экран диалог настройки спецификации, описание которой является текущим.

Добавить описание

Кнопка служит для внесения в список описаний спецификации нового описания. Вызывает на экран диалог, в котором требуется задать стиль спецификации (в соответствии с этим стилем будет происходить создание объектов спецификации в чертеже). Если указать в описании имя спецификации, то эта спецификация будет подключена к чертежу.

Все спецификации, подключенные к одному листу чертежа, должны иметь разный стиль.

Редактировать описание

Кнопка служит для редактирования описания текущей спецификации. Вызывает на экран диалог, в котором требуется задать новый стиль или имя текущей спецификации, подключенной к чертежу.

Удалить описание

Кнопка служит для удаления выделенного цветом в окне просмотра описания спецификации. Если выделенное описание появилось в документе в результате наличия в нем фрагмента, содержащего объекты спецификации, то удалить такое описание невозможно (кнопка Удалить описание недоступна). Для удаления этого описания требуется удалить или разрушить вставленный фрагмент.

Будьте внимательны при удалении описаний спецификаций, т.к. удаление описания приводит к удалению из документа объектов спецификации, принадлежащих этому описанию.

При удалении описания спецификации файл этой спецификации отключается от чертежа (если он был подключен), но не уничтожается.

Сделать текущим

Кнопка позволяет сделать выделенное описание спецификации текущим. Текущее описание отмечается «галочкой» в колонке Текущий. Текущим может быть только одно описание. Поэтому при назначении какого-либо описания текущим этот признак снимается с описания, которое было текущим ранее.

Стиль спецификации, который входит в текущее описание спецификации, считается текущим. Этот стиль используется при добавлении объектов спецификации в чертеж и при включении отображения спецификации на листе с помощью команды Спецификация на листе — Показать.

Включить отображение на листе

Кнопка позволяет включить отображение на чертеже объектов спецификации, соответствующих описанию, выделенному в списке.

Кнопка доступна для тех описаний, которые не содержат имени файла спецификации.

Таким образом, для того чтобы включить отображение на чертеже объектов, содержащихся в спецификации, к которой он подключен, сначала необходимо отключить чертеж от этой спецификации.

После нажатия этой кнопки у выделенного описания появляется красная «галочка» в колонке На листе.

Вы можете включить одновременный показ на чертеже объектов спецификации разных стилей.

Кнопка доступна только для чертежей.

Выключить отображение на листе

Кнопка позволяет отключить отображение на чертеже объектов спецификации, соответствующих описанию, выделенному в списке.

После нажатия этой кнопки «галочка» в колонке На листе у выделенного описания исчезает.

Кнопка доступна только для чертежей.

Завершив настройку описаний спецификации, нажмите кнопку Выход.

Кнопка Объединить варианты позволяет объединить описания спецификаций, содержащие аналогичные друг другу стили спецификации (при наличии таких описаний).


Диалог редактирования текущего описания спецификации

Этот диалог появляется на экране после нажатия на кнопку Добавить описание или Редактировать описание в диалоге управления описаниями спецификаций.

В нем можно отредактировать существующее или создать новое описание спецификации.

Описание элементов управления

Наименование

Описание

Библиотека стилей спецификаций

Название подключенной библиотеки, содержащей стили спецификаций. Для подключения другой библиотеки воспользуйтесь кнопкой Выбрать. В вызванном ею стандартном диалоге открытия файлов выберите файл библиотеки *.lyt, в котором находится нужный стиль спецификации. После этого на экране появится диалог, в котором нужно указать стиль из выбранной библиотеки. Название указанного стиля появится в соответствующем поле диалога.

Стиль спецификации

В этом поле отображается название стиля текущей спецификации. Чтобы выбрать спецификацию другого стиля, нажмите на кнопку с многоточием справа от поля.

На экране появится диалог со списком стилей, содержащихся в текущей библиотеке стилей спецификаций. Выберите нужный стиль и нажмите кнопку ОК диалога.

Спецификации, подключенные к одному графическому документу, должны иметь разные стили.

Имя файла спецификации

Имя файла спецификации, подключенного к листу чертежа. Для подключения новой спецификации или замены уже подключенной спецификации воспользуйтесь кнопкой Выбрать. В появившемся диалоге открытия файлов выберите файл спецификации *.spw, который требуется подключить к листу чертежа. Если в стандартном диалоге ввести несуществующее имя файла спецификации, то спецификация с таким именем будет автоматически создана и подключена к чертежу.

Загрузить документ спецификации

Включите эту опцию, если хотите, чтобы при выходе из диалога была автоматически открыта выбранная в нем спецификация.

Отображение массы

Группа элементов управления, позволяющая задать единицы измерения массы и точность отображения ее значения. Эта настройка используется в соответствующих колонках спецификации, например, в колонке Масса плазовой спецификации или в дополнительной колонке Масса.

Если к документу подключен файл спецификации, то ее стиль, а также настройку отображения массы изменить невозможно.

Завершив настройку описания спецификации, нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


Диалог редактирования текущего описания спецификации

Этот диалог появляется на экране после нажатия на кнопку Добавить описание или Редактировать описание в диалоге управления описаниями спецификаций.

В нем можно отредактировать существующее или создать новое описание спецификации.

Описание элементов управления

Наименование

Описание

Библиотека стилей спецификаций

Название подключенной библиотеки, содержащей стили спецификаций. Для подключения другой библиотеки воспользуйтесь кнопкой Выбрать. В вызванном ею стандартном диалоге открытия файлов выберите файл библиотеки *.lyt, в котором находится нужный стиль спецификации. После этого на экране появится диалог, в котором нужно указать стиль из выбранной библиотеки. Название указанного стиля появится в соответствующем поле диалога.

Стиль спецификации

В этом поле отображается название стиля текущей спецификации. Чтобы выбрать спецификацию другого стиля, нажмите на кнопку с многоточием справа от поля.

На экране появится диалог со списком стилей, содержащихся в текущей библиотеке стилей спецификаций. Выберите нужный стиль и нажмите кнопку ОК диалога.

Спецификации, подключенные к одному графическому документу, должны иметь разные стили.

Отображение массы

Группа элементов управления, позволяющая задать единицы измерения массы и точность отображения ее значения. Эта настройка используется в соответствующих колонках спецификации, например, в колонке Масса плазовой спецификации или в дополнительной колонке Масса.

Завершив создание или редактирование описания спецификации, нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


Диалог управления описаниями спецификаций

Этот диалог появляется на экране после вызова команды Управление описаниями спецификаций....

В нем можно просмотреть и отредактировать описания спецификаций, имеющиеся в текущем фрагменте или еще не сохраненном на диск чертеже/модели.

Описание элементов управления

Наименование

Описание

Описание спецификаций

Окно, содержащее список имеющихся в документе описаний спецификаций.

Этот список представляет собой таблицу из следующих колонок:

Текущий — отметка в этой колонке означает, что соответствующее описание является текущим.

На листе — отметка в этой колонке означает, что объекты спецификации данного описания отображаются в таблице спецификации, размещенной на листе текущего чертежа.

Имя — колонка, содержащая имена входящих в описания стилей спецификаций; если спецификация соответствующего стиля подключена к документу, то в данной колонке отображается также имя файла спецификации.

Вариант — колонка для особых отметок; присутствует в диалоге в следующих случаях:

– Документ содержит несколько описаний спецификации и хотя бы для одного из них не найден стиль спецификации (т.е. либо не найдена библиотека, из которой был взят стиль, либо библиотека найдена, но в ней нет стиля с нужным номером). В этом случае колонка содержит отметку Не найден. Чтобы указать другую библиотеку или другой стиль, выделите описание и нажмите кнопку Редактировать описание.

– Документ содержит несколько описаний с аналогичными друг другу стилями спецификации. В этом случае колонка содержит следующие отметки: прочерк — в ячейке описания со стилем-образцом, Вариант или Дубль — в ячейках описаний со стилями-аналогами. Чтобы объединить описания с аналогичными стилями, нажмите в диалоге кнопку Объединить варианты.
Подробнее об объединении вариантов описаний спецификаций...

Для выполнения действий с описанием, его необходимо выделить щелчком мыши. Имя выделенного описания подсвечивается.

Добавить описание

Кнопка служит для внесения в список нового описания спецификации. Вызывает на экран диалог, в котором требуется задать стиль спецификации (в соответствии с этим стилем будет происходить создание объектов спецификации в документе).

Спецификации, подключенные к одному документу, должны иметь разные стили.

Редактировать описание

Кнопка служит для редактирования описания текущей спецификации. Вызывает на экран диалог, в котором требуется задать новый стиль текущей спецификации.

Удалить описание

Кнопка служит для удаления выделенного в окне просмотра описания спецификации. Если выделенное описание появилось в документе в результате наличия в нем вставленного телом или россыпью фрагмента, содержащего объекты спецификации, удалить такое описание невозможно (кнопка Удалить описание недоступна). Для удаления этого описания требуется удалить или разрушить вставленный фрагмент.

Будьте внимательны при удалении описаний спецификаций, т.к. удаление описания приводит к удалению из документа объектов спецификации, принадлежащих этому описанию.

Сделать текущим

Кнопка позволяет сделать выделенное описание спецификации текущим. Текущее описание отмечается «галочкой» в колонке Текущий. Текущим может быть только одно описание. Поэтому при назначении какого-либо описания текущим этот признак снимается с описания, которое было текущим ранее.

Стиль спецификации, который входит в текущее описание спецификации, считается текущим. Этот стиль используется при добавлении во фрагмент объектов спецификации.

Завершив настройку описаний спецификации, нажмите кнопку Выход.

Кнопка Объединить варианты позволяет объединить описания спецификаций, содержащие аналогичные друг другу стили спецификации (при наличии таких описаний).


Диалог выбора раздела

Этот диалог появляется на экране:

– после вызова команды Вставка — Добавить вспомогательный объект — в этом случае в диалоге выбирается раздел, в котором должен находиться новый вспомогательный объект спецификации,

– при смене значения свойства Раздел спецификации у объекта в графическом документе или модели — в этом случае в диалоге выбирается раздел, в который должен быть перенесен базовый объект спецификации, связанный с редактируемым объектом документа.

Описание элементов управления
Наименование | Описание
Список разделов и подразделов | Выберите из предложенного списка раздел спецификации и, при необходимости, подраздел для объекта спецификации.
Создать | Нажмите эту кнопку для подтверждения выбора и выхода из диалога.
Отмена | Нажмите эту кнопку для выхода из диалога без создания или перемещения объекта спецификации.


Диалог выбора раздела

Этот диалог появляется на экране:

– после вызова команды Добавить базовый объект...,

– при задании значения свойства Раздел спецификации объекта.

Позволяет выбрать раздел, в котором будет создаваться новый базовый объект спецификации, и назначить шаблон заполнения текстовой части объекта.

Описание элементов управления

Наименование

Описание

Список разделов и подразделов

Выберите из предложенного списка раздел спецификации и, при необходимости, подраздел для размещения нового объекта.

Текстовая часть в виде строки

Включите эту опцию, чтобы ввести текстовую часть прямо с клавиатуры, не заполняя поля шаблона. После включения этой опции становятся недоступными опции выбора шаблона.

Если была включена эта опция, то введенная текстовая часть автоматически разбивается на поля и сортируется по этим полям. Порядок сортировки можно изменить, отредактировав вручную ключи этих полей.

Синхронизировать наименование с материалом

Опция доступна при создании объекта спецификации, связанного с объектом, который может иметь свойство Материал (примеры объектов: в чертеже — макроэлемент, в модели — компонент). Изменение состояния опции возможно, если выбран раздел Материалы и включена опция Текстовая часть в виде строки.

Включите опцию Синхронизировать наименование с материалом, чтобы текст в ячейке Наименование объекта спецификации синхронизировался со значением имеющегося у объекта свойства Материал.

Если опция отключена, то наименование материала синхронизируется со свойством Наименование объекта.

Шаблон заполнения текстовой части

В этом поле показано наименование шаблона заполнения текстовой части нового базового объекта.

Выбрать шаблон

Нажмите эту кнопку для перехода к диалогу выбора шаблона. Кнопка доступна, если отключена опция Текстовая часть в виде строки и выбран раздел, в котором производится составная сортировка (например, раздел Стандартные изделия или Материалы).

Создать

Нажмите эту кнопку для подтверждения выбора и выхода из диалога.

Отмена

Нажмите эту кнопку для выхода из диалога без создания нового базового объекта (и, соответственно, раздела).


Диалог выбора раздела и типа объекта

Этот диалог появляется на экране:

– после вызова команды Вставка — Раздел,

– при создании объекта спецификации в графическом документе или модели.

Позволяет выбрать раздел, который требуется создать, указать тип нового объекта в нем и назначить, если нужно, шаблон заполнения текстовой части базового объекта. Т.к. в спецификации КОМПАС-3D не допускается наличие пустого раздела, сразу после создания выбранного раздела в нем возникнет объект выбранного типа, текстовую часть которого нужно будет заполнить или отредактировать.

Описание элементов управления

Наименование

Описание

Список разделов и подразделов

Выберите из предложенного списка раздел спецификации и, при необходимости, подраздел для размещения нового объекта.

Тип объекта

Базовый

Вспомогательный

Укажите, тип объекта, который должен быть создан в новом разделе.

Текстовая часть в виде строки

Включите эту опцию, чтобы ввести текстовую часть прямо с клавиатуры, не заполняя поля шаблона. После включения этой опции становятся недоступными опции выбора шаблона.

Если была включена эта опция, то введенная текстовая часть автоматически разбивается на поля и сортируется по этим полям.

Из строки текста автоматически формируется запись.

Правила автоматического формирования записи из строки текста.

Синхронизировать наименование с материалом

Опция доступна при создании объекта спецификации, связанного с объектом, который может иметь свойство Материал (примеры объектов: в чертеже — макроэлемент, в модели — компонент). Изменение состояния опции возможно, если выбран раздел Материалы и включена опция Текстовая часть в виде строки.

Включите опцию Синхронизировать наименование с материалом, чтобы текст в ячейке Наименование объекта спецификации синхронизировался со значением имеющегося у объекта свойства Материал.

Если опция отключена, то наименование материала синхронизируется со свойством Наименование объекта.

Шаблон заполнения текстовой части

В этом поле показано наименование шаблона заполнения текстовой части нового базового объекта.

Выбрать шаблон

Нажмите эту кнопку для перехода к диалогу выбора шаблона.

Кнопка доступна, если отключена опция Текстовая часть в виде строки и выбран раздел, в котором производится составная сортировка (например, раздел Стандартные изделия или Материалы).

Создать

Нажмите эту кнопку для подтверждения выбора и выхода из диалога.

Отмена

Нажмите эту кнопку для выхода из диалога без создания нового объекта (и, соответственно, раздела).


Диалог указания текущего описания спецификации

Это диалог появляется на экране при открытии спецификации, если стиль, используемый в ней, не найден в библиотеке стилей спецификаций (*.lyt), либо если не найдена сама библиотека стилей.

Описание элементов управления

Наименование

Описание

Библиотека стилей спецификаций

В этой строке отображается полное имя библиотеки стилей спецификаций, подключенной к открываемой спецификации.

Если список Стиль доступен, это означает, что библиотека найдена по пути, указанному в строке Библиотека стилей спецификаций, но в ней отсутствует нужный стиль.

Если список недоступен, это означает, что потеряна сама библиотека. В таком случае необходимо сначала указать библиотеку, воспользовавшись кнопкой Обзор..., а затем указать стиль из этой библиотеки.

Обзор...

Позволяет подключить к открываемой спецификации другую библиотеку стилей. После нажатия этой кнопки на экране появляется стандартный диалог открытия файлов. Выберите в нем нужный файл *.lyt.

Стиль

Выберите название из списка стилей спецификаций, имеющихся в подключенной библиотеке стилей.

При выборе стиля для спецификации, подключенной к графическому документу или к сборке, помните, что все спецификации, подключенные к одному документу, должны иметь разный стиль.

Выбрав стиль спецификации, нажмите кнопку ОК. Спецификация откроется. Просмотрите ее и постарайтесь определить, правильно ли выбран стиль взамен утерянного. Если стиль правильный, то сохраните спецификацию. В противном случае закройте спецификацию без сохранения и при последующем открытии выберите нужный стиль.

Чтобы отказаться от открытия спецификации, нажмите кнопку Отмена.


Диалог задания номеров исполнений

Этот диалог появляется на экране после вызова команды Добавить исполнения объекта. В нем требуется указать номера исполнений объекта спецификации, которые должны быть созданы в результате выполнения команды.

Номера должны разделяться запятыми и дефисами.

Нумерация исполнений может быть не сплошной. Например, если в диалоге ввести номера 2-5,8,12, то в спецификации появится 6 новых объектов, а их обозначение будет отличаться от обозначения объекта, для которого создаются исполнения, суффиксами -02, -03, -04, -05, -08, -12.

После ввода номеров исполнений нажмите кнопку OK для подтверждения создания объектов-исполнений.

Для отказа от создания объектов-исполнений нажмите кнопку Отмена.


Диалог работы со стилями спецификаций

Позволяет создать новые или отредактировать уже имеющиеся стили спецификаций, а также выполнять различные операции с библиотеками стилей (они хранятся в файлах с расширением *.lyt).

Этот диалог появляется на экране после вызова команды Сервис — Библиотеки стилей, типов, оформлений и основных надписей — Стили спецификаций....

На панелях в левой и правой частях диалога можно отобразить списки стилей, хранящихся в двух разных библиотеках. Для активизации нужной панели щелкните на ней левой кнопкой мыши. Признаком того, что панель активна, является отображение вокруг нее рамки.

Стили в списках могут быть отсортированы по именам или по номерам. Чтобы изменить сортировку, щелкните мышью по заголовку нужного столбца. В заголовке столбца, по которому сортируются стили, отображается треугольник. Его положение показывает направление сортировки — по возрастанию или по убыванию.

Описание элементов управления
Наименование | Описание
Показать библиотеку | Для подключения другой библиотеки стилей нажмите эту кнопку.
Создать | Для перехода к диалогу создания нового стиля нажмите эту кнопку. Совет...
Редактировать | Для перехода к диалогу редактирования стиля выберите его название из списка и нажмите эту кнопку.
Копировать | Вы можете обмениваться стилями между различными библиотеками. Для этого откройте нужные библиотеки, выберите элемент и нажмите кнопку копирования.
Удалить | Для удаления одного или нескольких стилей из библиотеки выберите их имена в списке и нажмите эту кнопку.

Чтобы закрыть диалог, нажмите кнопку Выход.


Результат суммирования значений в колонках

Этот диалог появляется на экране после вызова команды Сложить значения в колонках.

Он позволяет просмотреть результаты суммирования значений в колонках спецификации и записать их в текстовый файл.

Названия параметров и результаты вычислений для различных исполнений показаны в окне просмотра.

Кнопка Записать вызывает стандартный диалог сохранения файла. По умолчанию расширение файла для сохранения результатов вычислений — *.txt.

Для выхода из диалога нажмите кнопку OK.


Диалог редактирования состава объекта

Диалог появляется на экране после вызова команды Редактировать состав объекта.

Если к спецификации подключено более одного чертежа, то названная команда вызывает диалог выбора чертежа. После указания чертежа на экране появляется диалог редактирования состава объекта.

Этот диалог содержит информацию об объекте спецификации или объекте таблицы изменений, состав которого изменяется.

Описание элементов управления
Наименование | Описание
Добавить | Чтобы добавить выделенные элементы чертежа в состав объекта, нажмите эту кнопку.
Заменить | Чтобы заменить имеющийся состав объекта выделенными элементами чертежа, нажмите эту кнопку.

Для отказа от изменения состава объекта нажмите кнопку Отмена.


Диалог редактирования состава объекта

Диалог появляется на экране после вызова команды Редактировать состав объекта.

Если к спецификации подключено более одного чертежа, то названная команда вызывает диалог выбора чертежа. После указания чертежа на экране появляется диалог редактирования состава объекта.

Этот диалог содержит информацию об объекте спецификации или объекте таблицы изменений, состав которого изменяется.

Описание элементов управления
Наименование | Описание
Добавить | Чтобы добавить выделенные элементы в состав объекта, нажмите эту кнопку. Она присутствует в диалоге, если в чертеже были выделены объекты (группа выделения не пуста).
Очистить | Чтобы очистить объект от геометрии, нажмите эту кнопку. Она присутствует в диалоге, если выделенных объектов нет (группа выделения пуста).

Для отказа от изменения состава объекта нажмите кнопку Отмена.


Диалог выбора документов

В этом диалоге отображается список документов, из которых в спецификацию был передан выбранный объект спецификации, или геометрия из которых подключена к выбранному объекту.

Выберите из списка документы для открытия, включив опции рядом с их названиями.

Чтобы одновременно открыть все документы списка, включите опцию Открыть все.

После завершения выбора документов нажмите кнопку ОК диалога для их открытия. Чтобы отказаться от открытия документов, нажмите кнопку Отмена.


Диалог настройки текущей спецификации

Этот диалог появляется на экране после вызова команды Формат — Настройка спецификации.

Позволяет настроить стиль текущей спецификации в целом и стили разделов текущей спецификации.

Описание элементов управления

Элемент

Описание

Вкладка Настройка

Опции этой вкладки позволяют настроить основные правила взаимодействия спецификации со сборочным чертежом.

Связь сборки или чертежа со спецификацией

Эта группа опций служит для определения типа связи модели (или листов сборочного чертежа) с текущей спецификацией. Если опция выключена, информация из подключенного сборочного документа не будет передаваться в спецификацию (однако документ будет по-прежнему подключен и связь можно будет включить в любой момент). Включение связи сборки или чертежа со спецификацией сделает доступными опции типа связи.

Только вставка объектов

Выбор варианта означает, что при сохранении подключенного документа, в который внесены изменения, касающиеся спецификации (созданы или отредактированы объекты спецификации), эти изменения будут переданы в спецификацию.

Связь с расчетом позиций

Выбор варианта означает, что после передачи изменений из чертежа в спецификацию в ней будет автоматически произведен расчет номеров позиций (в соответствии с последовательностью сортировки объектов) и новые номера позиций будут переданы в чертеж.

Рассчитывать позиции

Включите эту опцию, чтобы после сортировки объектов можно было автоматически проставить номера их позиций с учетом нового порядка объектов. Выключение этой опции делает невозможным связь чертежа и спецификации с расчетом позиций.

Рассчитывать зоны

Включите эту опцию, если хотите, чтобы при автоматической простановке номеров позиций происходило и обновление номеров зон чертежа.

Удалять геометрию при удалении объекта спецификации

Включите эту опцию, чтобы при удалении объекта спецификации из чертежа автоматически удалялись геометрические объекты и линии-выноски, входившие в его состав.

Удалять объекты спецификации при удалении геометрии

Включите эту опцию, чтобы при удалении из чертежа геометрических объектов и линий-выносок, входящих в состав объекта спецификации, этот объект удалялся из спецификации. Если опция включена, то после удаления геометрии объекта спецификации на экране появляется диалог, в котором можно подтвердить удаление этого объекта или отказаться от него.

Копировать объекты спецификации при копировании геометрии

Включите эту опцию, чтобы копия объекта спецификации автоматически создавалась при копировании в чертеже:

– всех геометрических объектов и линий-выносок, входящих в состав этого объекта,

– всех геометрических объектов, входящих в состав этого объекта,

– хотя бы одной линии-выноски, входящей в состав этого объекта.

Способ копирования геометрии — с помощью мыши или команд редактирования — для копирования объекта спецификации не имеет значения1.

Начальная позиция

Введите в это поле номер позиции, который будет иметь первый объект спецификации в первом разделе, для которого включена простановка позиций.

Строить снизу вверх

Включите эту опцию, чтобы разделы спецификации и объекты в них располагались снизу вверх.

Количество исполнений

В этом поле нужно указать количество исполнений, для которого создается спецификация.

Если количество исполнений будет меньше, чем количество колонок типа КОЛИЧЕСТВО, сформированных во вкладке Колонки, то данные можно будет ввести только в колонки, соответствующие существующим исполнениям изделия.

Если количество исполнений будет больше, чем количество колонок типа КОЛИЧЕСТВО, то во вкладке Блоки исполнений следует настроить параметры отображения информации для исполнений.

Имя файла для вставки текстовых шаблонов

В этом поле указано имя файла, текстовые шаблоны из которого будут использоваться при заполнении спецификации. Если при настройке текстового редактора была включена запись введенных вручную текстов в файл текстовых шаблонов, то данные, введенные вручную при заполнении спецификации, будут сохраняться в указанном файле.

Обзор...

Чтобы сменить файл текстовых шаблонов, нажмите эту кнопку. В вызываемом ею стандартном диалоге открытия файлов укажите файл *.tdp.

Вкладка Разделы

Опции этой вкладки позволяют настроить разделы спецификации.

Показывать заголовки разделов

Включите эту опцию, чтобы названия заголовков разделов отображались на экране при редактировании спецификации.

Заголовок...

Для настройки внешнего вида заголовков раздела (шрифта, выравнивания и т.д.) нажмите кнопку и выберите в появившемся меню нужную команду форматирования.

Брать шрифт из оформления

Включите эту опцию, чтобы шрифт объектов спецификации был таким, какой он установлен по умолчанию в таблице спецификации. Выключите опцию, если шрифт должен быть другим.

Шрифт объекта...

Нажмите на кнопку и в появившемся диалоге укажите требуемый шрифт объекта спецификации. Кнопка доступна при выключенной опции Брать шрифт из оформления.

В окне просмотра отображаются названия разделов, существующих в спецификации, и настройки стилей каждого из этих разделов. Настройки стилей разделов отображаются в виде последовательности пиктограмм:

— Включено деление на подразделы

— Данные из штампа чертежа передаются в спецификацию

— Включена сортировка объектов внутри раздела

— К объектам раздела можно подключить геометрию

— Включена простановка позиций внутри раздела.

Редактировать стиль раздела...

Эта кнопка служит для изменения настроек стиля раздела, название которого выделено цветом в окне просмотра. Для быстрого изменения настройки текущего раздела при редактировании спецификации пользуйтесь кнопками-переключателями в Строке параметров объектов.

Кнопки Добавить, Редактировать и Удалить недоступны до тех пор, пока не сформирован список колонок настраиваемого стиля спецификации.

Вкладка Блоки исполнений

Опции этой вкладки позволяют указать правила заполнения спецификаций на изделие, количество исполнений для которого превышает количество колонок бланка, предназначенных для записи количества на исполнение (например, при создании спецификации для изделия с двадцатью пятью исполнениями на стандартном бланке групповой спецификации). Здесь же можно настроить правила автоматического формирования обозначений исполнений объектов спецификации и исполнений специфицируемого изделия.

Показывать заголовки блоков

Включите эту опцию, чтобы названия блоков исполнений отображались в бланке спецификации.

Размещать блок на новом листе

Включение опции означает, что информация о каждой группе исполнений должна начинаться на новой странице (при отображении ее как блоками, так и по объектам). При таком способе отображения строки Обозн. исполн. не возникают в спецификации, а номера каждой группы исполнений размещаются в «шапке» спецификации.

Показывать исполнения, не содержащие переменных данных

Эта опция доступна для групповой спецификации по варианту А и управляет обработкой исполнений, в которых не применяются переменные данные.

– Включение опции означает, что для исполнений без переменных данных будут создаваться блоки, содержащие строку со словом Отсутствует (отображение заголовков блоков должно быть включено). Если переменных данных не окажется ни в одном исполнении, то блоки созданы не будут, а в конец спецификации добавится строка с текстом Различия исполнений по сборочному чертежу. Данные строки представляют собой отметки об отсутствии переменных данных.
Текст отметок можно отредактировать. Измененный текст сохраняется в документе.

– При выключенной опции не создаются блоки для исполнений, которые не содержат переменных данных, а также отметки об отсутствии переменных данных.

Формирование номеров исполнений изделия

В группе опций можно указать, по каким правилам должны автоматически формироваться номера исполнений специфицируемого изделия в «шапке» спецификации и в строке Обозн. исполн.

Вставлять нули перед числом

Вставлять тире перед числом

Система может вставлять нули и/или тире перед числом (при включении соответствующих опций). Так, если вы включите обе опции, в «шапке» спецификации появятся номера исполнений —, -01, -02, -03 и т.д.

Выдавать информацию

Группа опций доступна при условии, что количество исполнений, указанное во вкладке Настройка, превышает количество колонок типа КОЛИЧЕСТВО, сформированных во вкладке Колонки (то есть исполнений больше, чем предназначенных для них колонок).

По объектам

При выборе варианта информация о количестве объектов на исполнение будет выдаваться для каждого объекта в отдельности. Внутри каждого раздела возникнет такое количество строк для каждого объекта, которое позволит ввести количество для всех исполнений; автоматически будут сформированы строки Обозн. исполн., в которых расположатся номера исполнений специфицируемого изделия.

Блоками

При выборе варианта вся информация о количестве будет выдаваться вначале для первых нескольких исполнений, которые поместятся в колонках бланка (например, для исполнений с базового по девятое), затем — для следующей группы исполнений (например, с десятого по девятнадцатое) и так далее. В результате в спецификации образуется несколько блоков, разделенных автоматически сформированными строками Обозн. исполн., содержащих одинаковые разделы и объекты. Отличаться будут только данные в колонках Количество на исполнение.

Если блок исполнений начинается на новой странице, то строка Обозн. исполн. не отображается, а номера исполнений размещаются в «шапке» спецификации на этой странице.

Формировать обозначения исполнений объектов

Группа опций управляет автоматическим формированием обозначений объектов при вызове команды Добавить исполнения объекта. Объекты, созданные при помощи этой команды, являются копиями одного и того же объекта спецификации; их текстовые части отличаются только суффиксами в обозначении (например, АБВГ.125.567800, АБВГ.125.567800-01, АБВГ.125.567800-02, АБВГ.125.567800-05 и т.д.).

Показывать полностью

Если вариант выбран, то обозначения объектов отображаются полностью (как показано в предыдущем примере).

Показывать только номер

Если вариант выбран, то полностью показывается только обозначение того объекта, на основе которого созданы остальные объекты. Обозначения автоматически сформированных объектов отображаются в виде номера (например, АБВГ.125.567800, -01, -02, -03).

Позиции возрастают

Если включена опция, то позиции объектов, являющихся исполнениями, отображаются в таблице спецификации; номера позиций возрастают.

Вкладка Блоки дополнительных разделов

Опции этой вкладки позволяют настроить блоки дополнительных разделов.

Использовать блоки

Опция, управляющая доступностью блоков дополнительных разделов в спецификации.

При отключенной опции настройка блоков невозможна. Невозможным также будет использование блоков в спецификации — они будут отсутствовать в диалоге выбора раздела.

Показывать заголовки блоков

Включите эту опцию, чтобы названия блоков отображались в бланке спецификации.

Заголовок

Для настройки внешнего вида заголовков раздела (шрифта, выравнивания и т.д.) нажмите эту кнопку и выберите в появившемся меню нужную команду форматирования. Кнопка доступна, если показ заголовков включен.

Список блоков

Перечень блоков дополнительных разделов.

Чтобы блок был доступен при редактировании спецификации, включите опцию слева от названия блока.

Редактировать

Позволяет отредактировать блок, выделенный в списке. После нажатия этой кнопки на экране появляется диалог настройки блока дополнительных разделов.
  1. Если геометрия объекта спецификации расположена в разных видах чертежа, то этот объект спецификации копируется также при копировании части геометрии, целиком расположенной в одном виде.

Завершив настройку стиля спецификации, нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


Диалог описания подраздела

Этот диалог появляется на экране после нажатия кнопки Добавить или Редактировать на вкладке Подразделы диалога Стиль раздела спецификации.

Позволяет ввести название и порядковый номер нового подраздела или редактировать название и порядковый номер существующего подраздела.

Описание элементов управления

Наименование

Описание

Имя

Введите в это поле название нового подраздела или отредактируйте название существующего.

Названия подразделов не отображаются в таблице спецификации.

Номер

Введите в это поле порядковый номер нового раздела или отредактируйте порядковый номер существующего раздела.

При сортировке объектов внутри раздела вначале происходит сортировка подразделов по возрастанию их порядкового номера, а затем — сортировка объектов внутри подразделов по установленным правилам. Учитывайте этот принцип сортировки при назначении порядкового номера подраздела.

Нумерация подразделов внутри одного раздела может быть не сплошной.

Номера подразделов внутри одного раздела не должны повторяться.

Максимальный порядковый номер подраздела — 10000.

Завершив ввод или редактирование названия и номера подраздела, нажмите кнопку ОК. Для выхода из диалога без создания нового подраздела или без сохранения изменений нажмите кнопку Отмена.


Диалог Правописание

Диалог появляется на экране после вызова команды Сервис — Правописание.

Элементы управления диалога позволяют выполнить орфографическую и грамматическую проверку всего текста или выделенного фрагмента.

Проверка производится согласно правилам и нормам языка текста. Кроме того, при проверке могут использоваться вспомогательные словари.

Проверка производится в следующем порядке:

– проверяется наличие орфографических ошибок в предложении,

– проверяется наличие грамматических ошибок в предложении (только для русского языка).

Описание элементов управления

Наименование

Описание

Орфографическая ошибка,

Грамматическая ошибка

Поле, содержащее проверяемое предложение. При орфографической проверке слово, предположительно содержащее орфографическую ошибку, выделено красным цветом. При грамматической проверке часть предложения, предположительно содержащая грамматическую ошибку, выделена зеленым цветом.

Ошибка может быть исправлена непосредственно в данном поле. Для внесения исправлений в исходный текст при орфографической проверке нажмите кнопку Заменить, а при грамматической — кнопку Изменить. При смене варианта в поле Язык словаря содержимое поля Орфографическая ошибка изменяется.

Варианты

При орфографической проверке это поле содержит список слов, сходных по написанию с проверяемым, из словарей программы проверки орфографии.

Состав списка определяется только написанием слов, поэтому в него могут быть включены слова, не подходящие по контексту.

Чтобы заменить проверяемое слово вариантом из списка, его следует выделить и нажать кнопку Заменить.

При грамматической проверке это поле содержит краткие описания возможных ошибок. Для внесения исправлений в исходный текст необходимо выбрать вариант и нажать кнопку Изменить.

Замена или исправление выполняется также после двойного щелчка по элементу списка. Если начать редактирование проверяемого слова в поле Орфографическая/Грамматическая ошибка, поле Варианты станет недоступным.

Пропустить

Кнопка, позволяющая пропустить проверяемое слово (при орфографической проверке) или предложение (при грамматической проверке). Оно считается проверенным и не содержащим ошибки. Если начать редактирование проверяемого слова/предложения в поле Орфографическая /Грамматическая ошибка, кнопка Пропустить заменяется кнопкой Отменить правку.

Отменить правку

Кнопка, позволяющая отменить редактирование, выполненное в поле Орфографическая/Грамматическая ошибка. После нажатия кнопки становится доступным поле Варианты.

Пропустить все

Кнопка, позволяющая пропустить проверяемое слово (при орфографической проверке) или предложение (при грамматической проверке). Оно считается проверенным и не содержащим ошибки. Слова такого же написания или предложения с такими же грамматическими ошибками в остальном тексте также полагаются правильными и пропускаются при проверке (даже если выполнялась проверка выделенного фрагмента).

При орфографической проверке кнопка становится недоступна, если производится редактирование в поле Орфографическая ошибка.

Добавить

Кнопка присутствует в диалоге во время орфографической проверки. Она позволяет добавить проверяемое слово во вспомогательный словарь, который назначен умолчательным. При последующих проверках это слово будет предлагаться для замены в списке Варианты. Кнопка недоступна, если производится редактирование в поле Орфографическая ошибка.

Заменить

Кнопка присутствует в диалоге во время орфографической проверки. Она позволяет заменить проверяемое слово в тексте вариантом из списка или словом, отредактированным в поле Орфографическая ошибка. После нажатия кнопки проверка продолжается.

Изменить

Кнопка присутствует в диалоге во время грамматической проверки. Она позволяет отредактировать проверяемое предложение в тексте в соответствии с выбранным вариантом ошибки или заменить исправленным в поле Грамматическая ошибка. После нажатия кнопки проверка продолжается.

Заменить все

Кнопка присутствует в диалоге во время орфографической проверки. Она позволяет заменить проверяемое слово и слова аналогичного написания по всему тексту вариантом из списка или словом, отредактированным в поле Орфографическая ошибка. Уже проверенные слова, например, обработанные командами Пропустить, Заменить, не заменяются. После нажатия кнопки проверка продолжается.

Грамматика

Опция, позволяющая управлять проверкой грамматики. По умолчанию опция включена.

Язык словаря

Элемент управления служит для изменения языка проверяемого слова.

В поле Язык словаря отображается признак языка того слова, которое выделено красным цветом в поле Орфографическая ошибка. В поле Вариант содержится список слов для замены, взятых из основного и вспомогательных словарей.

Если необходимо, выберите из раскрывающегося списка Язык словаря нужный вариант.

– Если выбран другой язык словаря, то набор слов в поле Вариант изменится. Выберите слово для замены.

– Если выбран вариант Без проверки, то данное слово останется без проверки.

После завершения проверки проверяемые слова будут иметь признаки языков, установленных в диалоге. Слова, для которых была отменена проверка, не будут иметь признака языка.

Параметры...

Кнопка, позволяющая настроить параметры проверки правописания. После вызова команды на экране появится диалог Параметры правописания.

Вернуть

Кнопка, позволяющая отменить предыдущее действие по редактированию текста в диалоге Правописание. После отмены последнего редактирования кнопка становится недоступной. Также кнопка недоступна до первой правки текста.

Отмена

Кнопка, позволяющая завершить проверку правописания. После вызова команды диалог Правописание будет закрыт, а внесенные исправления зафиксируются в тексте.


Диалог Вспомогательные словари

Появляется на экране после вызова команды Словари... диалога настройки параметров проверки правописания.

Элементы управления диалога позволяют управлять вспомогательными словарями для проверки правописания.

Описание элементов управления
Наименование | Описание
Список словарей | Содержит имена доступных для использования вспомогательных словарей. Опция слева от имени словаря позволяет управлять его подключением для проверки орфографии.
Изменить... | Кнопка позволяет изменить содержимое выбранного словаря. После нажатия кнопки открывается диалог редактирования вспомогательного словаря.
По умолчанию | Кнопка позволяет использовать выбранный в списке словарь в качестве умолчательного. В этот словарь будут добавляться новые слова. К имени умолчательного словаря добавляется текст «(по умолчанию)».
Создать... | Кнопка позволяет создать новый пользовательский словарь. После нажатия кнопки на экране появится стандартный диалог создания файлов Windows. По умолчанию вспомогательные словари создаются в папке ..\Documents and Settings\user\Application Data\Ascon\Kompas-3D\Х.Х, где Х.Х — номер версии системы.
Добавить... | Кнопка позволяет добавить имя пользовательского словаря в список диалога Вспомогательные словари. После нажатия кнопки на экране появится стандартный диалог открытия файлов Windows. По умолчанию открывается папка ..\Documents and Settings\user\Application Data\Ascon\Kompas-3D\Х.Х, где Х.Х —номер версии системы.
Удалить | Кнопка позволяет удалить имя словаря из списка. Тем самым словарь будет недоступным при проверке правописания. Файл, в котором сохранен словарь, остается без изменений.
Информационное поле | Содержит полное имя файла словаря, выделенного в списке.

Чтобы завершить работу со вспомогательными словарями, нажмите кнопку ОК. Чтобы закрыть диалог, отказавшись от сделанных изменений, нажмите кнопку Отмена.


Диалог редактирования вспомогательного словаря

Диалог появляется на экране после вызова команды Изменить... в диалоге Вспомогательные словари.

Элементы управления диалога позволяют изменять состав словаря.

Описание элементов управления
Наименование | Описание
Слово: | Поле для ввода слова, добавляемого в словарь. По мере ввода строки в словаре проводится поиск слов, совпадающих по написанию.
Словарь: | Поле содержит элементы редактируемого словаря. По мере ввода текста в поле Слово: в поле Словарь: производится поиск слов, совпадающих с введенной строкой.
Добавить | Кнопка позволяет добавить строку, введенную в поле Слово:, в словарь. Кнопка доступна, если в словаре не найдено элемента, совпадающего с введенной строкой.

Чтобы завершить редактирование вспомогательного словаря, нажмите кнопку ОК. Чтобы закрыть диалог, отказавшись от изменений, нажмите кнопку Отмена.


Диалог задания параметров экспорта файла трехмерной модели

В этом диалоге можно настроить некоторые параметры экспорта файла трехмерной модели в формат SAT, STL, IGES, ParaSolid, STEP или VRML.

Название выбранного для экспорта формата показано в заголовке диалога.

В диалоге требуется указать экспортируемый документ. По умолчанию включена опция Текущий и записывается текущий файл. Выключите опцию Текущий, если требуется экспортировать другой файл, и укажите в стандартном диалоге выбора файлов нужный документ (модель КОМПАС-3D). Если требуется указать другой файл для экспорта, нажмите кнопку Выбрать документ... и укажите файл заново.

Укажите итоговый файл. Для этого нажмите кнопку Выбрать файл... и в появившемся диалоге выберите файл, в который будет экспортирована трехмерная модель.

Если необходимо задать параметры экспорта при записи в форматы STL, IGES или STEP, нажмите кнопку Параметры....

Если производится экспорт в формат STL, в диалоге требуется указать формат записи — текстовый или двоичный. Выбор текстового или двоичного формата STL определяется тем, как далее будет использоваться экспортированная модель (например, если она будет передаваться в программу, работающую с двоичным форматом STL, нужно выбрать запись именно в этом формате).

Если производится экспорт в формат IGES, вы можете указать способ записи модели в итоговый файл. Он определяется состоянием опции Включить топологию. Если эта опция выключена, трехмерная модель записывается в виде набора поверхностей. Включенная опция означает, что модель будет записана как твердое тело.

Следует иметь в виду, что модель, записанная в файл формата IGES как твердое тело, может быть прочитана лишь некоторыми целевыми системами. Модель же, записанную в виде набора поверхностей, можно прочитать в большинстве из них.

Перед экспортом файла трехмерной модели в формат IGES заранее выясните, какой способ записи должен использоваться, чтобы этот файл был корректно прочитан целевой системой. Если модель, записанная в файл формата IGES как твердое тело, не читается целевой системой, попробуйте записать модель еще раз — в виде набора поверхностей.

После выбора файлов нажмите кнопку Начать запись диалога. Указанная модель КОМПАС-3D будет записана в выбранном формате.

Скрытые тела и компоненты в формат STL не записываются, в формат STEP записываются или нет в зависимости от настройки, в остальные форматы записываются, причем как видимые, т.е. признак «скрыть» не передается.

Исключенные из расчета тела и компоненты не записываются в целевой формат, т.е. считаются удаленными из модели.

Особенности записи в некоторые форматы:

– ParaSolid ХТ
При экспорте файлов используется стандартный файл-схема (schema file) №10004.

– ParaSolid
В итоговый файл записываются только тела, имеющиеся в модели КОМПАС-3D.

– STEP
В итоговый файл записывается следующая информация:

• обозначения и наименования изделия и его составных частей,

• описание изделия (комментарий, который задается в диалоге информации о документе),

• автор.


Диалог параметров записи в формат STEP AP203/STEP AP214

Диалог появляется на экране при экспорте модели в формат STEP AP203/STEP AP214.

Позволяет настроить параметры экспорта.

Описание элементов управления
Элемент | Описание
Объекты | Группа опций позволяет управлять экспортом объектов модели. При включении соответствующих опций в модель экспортируются следующие объекты: – тела, – поверхности, – кривые, – точки, – размеры (при экспорте в формат STEP AP214), – технические требования (при экспорте в формат STEP AP214).
Система координат | Список позволяет выбрать СК, в которой записываются координаты экспортируемой модели. Список недоступен, если в модели существует только абсолютная система координат.
Только видимые объекты | Опция позволяет управлять экспортом объектов в зависимости от их видимости. Если опция включена, экспортируются только видимые объекты модели, если опция отключена — все объекты модели, как видимые, так и скрытые.
Цвет объектов | Опция позволяет включить/отключить экспорт цветов объектов модели.
Геометрическое представление текста | Опция позволяет управлять видом передаваемого текста. Если опция отключена, тексты передаются в виде букв, символов и спецзнаков. Если опция включена, тексты передаются виде наборов отрезков, объединенных в макроэлементы.
Информация | Группа полей позволяет ввести информацию о документе.
Автор | Поле для ввода сведений об авторе документа.
Организация | Поле для ввода наименования организации.
Комментарий | Поле для ввода дополнительной информации о документе. Текст в поле может состоять из нескольких строк.

После завершения настройки параметров нажмите кнопку ОК. Для выхода из диалога без записи файла нажмите кнопку Отмена.

Особенности экспорта объектов модели


Диалог параметров чтения файлов формата STEP AP203/STEP AP214

Диалог появляется на экране при импорте модели из файла формата STEP AP203/STEP AP214.

Позволяет настроить параметры импорта.

Описание элементов управления

Элемент

Описание

Объекты

Группа опций позволяет управлять импортом объектов модели. При включении соответствующих опций в модель импортируются следующие объекты:

– тела,

– поверхности,

– кривые,

– точки,

– размеры (при импорте из файлов формата STEP AP214),

– технические требования (при импорте из файлов формата STEP AP214).

Сшивать поверхности

Опция, позволяющая сшивать поверхности.

Если опция включена, то система пытается объединить импортированные поверхности. В результате возможно получение поверхности большей площади или тела (если исходная поверхность замкнута).

Если опция выключена, то сшивка не производится, и результатом импорта являются поверхности, аналогичные исходным.

Обратите внимание на то, что состояние опции Сшивать поверхности влияет только на поверхности и не влияет на тела.

Точность сшивки

Поле для ввода значения максимального расстояния между ребрами сшиваемых поверхностей. Диапазон допустимых значений 0–1000 мм. Поле доступно при включенной опции Сшивать поверхности.

Цвет объектов

Опция позволяет включить/отключить импорт цветов объектов модели.

После завершения настройки параметров нажмите кнопку ОК. Для выхода из диалога без чтения файла нажмите кнопку Отмена.

Особенности импорта объектов модели


Диалог параметров записи в формат STL

Диалог появляется на экране при экспорте модели в формат STL. В формат STL существующие в модели поверхности передаются в виде многогранных поверхностей с треугольными гранями. Процесс и результат построения конечного числа не перекрывающих друг друга треугольников, стыкующихся между собой по общим сторонам, называется триангуляцией. Отрезки, соединяющие вершины треугольников, называются ребрами.

В диалоге настраиваются параметры триангуляции.

Описание элементов управления

Элемент

Описание

Объекты

Группа опций позволяет управлять экспортом объектов модели. При включении соответствующих опций экспортируются следующие объекты:

– тела,

– поверхности.

Система координат

Список позволяет выбрать СК, в которой записываются координаты вершин и векторов нормалей треугольных граней. Список недоступен, если в модели существует только абсолютная система координат.

Единицы длины

Список позволяет выбрать единицу длины для записи координат вершин и векторов нормалей треугольных граней.

Точность аппроксимации

Группа опций, позволяющая задать параметры аппроксимации. Хотя бы одна опция из группы должна быть обязательно включена.

Максимальное линейное отклонение

Включение опции позволяет задать максимально допустимое отклонение по нормали треугольной грани передаваемой поверхности от исходной поверхности.

Отклонение можно задать с помощью «ползунка». Для изменения величины отклонения перемещайте «ползунок» по шкале между позициями крайней левой («грубо») и крайней правой («точно»). Диапазон допустимых значений зависит от габаритов модели. Нужное значение можно ввести вручную в поле справа от шкалы.

Максимальное угловое отклонение

Включение опции позволяет задать максимально допустимый угол между нормалями смежных треугольных граней передаваемой поверхности. Отклонение можно задать с помощью «ползунка». Диапазон допустимых значений углового отклонения 45–0.1 (в градусах).

Нужное значение можно ввести вручную в поле справа от шкалы. При этом максимально допустимое значение 90.

Максимальная длина ребра

Включение опции позволяет задать максимальную длину ребра. Диапазон допустимых значений зависит от габаритов модели.

После завершения настройки параметров нажмите кнопку ОК. Для выхода из диалога без записи файла нажмите кнопку Отмена.


Диалог создания и редактирования групп

Этот диалог появляется на экране после вызова команды Группы... из контекстного меню выделенных объектов.

Позволяет создавать в документе новые именованные группы и редактировать уже имеющиеся.

Описание элементов управления
Элемент | Описание
Существующие группы | В этом поле отображается список имен групп, имеющихся в активном документе.
Имя новой группы | В этом поле можно ввести имя вновь создаваемой группы.
Создать новую группу | Эта кнопка позволяет объединить выделенные объекты документа в новую группу с заданным именем.
Разрушить группы | Эта кнопка позволяет разрушить группы, имена которых выделены в списке.
Добавить в группу | Эта кнопка позволяет добавить выделенные объекты документа в группу, имя которой выделено в списке.
Исключить из группы | Эта кнопка позволяет исключить выделенные объекты документа из группы, имя которой выделено в списке.

Для подтверждения сделанных изменений нажмите кнопку ОК диалога. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


Диалог выбора символа

Этот диалог появляется на экране после вызова команды Вставка — Символ...

В нем можно выбрать нужный символ для вставки в текст.

В диалоге отображается таблица символов, содержащихся в текущем шрифте. Выбранный символ отображается в ячейке с черным фоном.

Списки Шрифт и Набор символов служат для указания шрифта и набора символов в нем.

После того как нужный символ выбран, нажмите кнопку ОК для его вставки в текст. Можно также дважды щелкнуть левой кнопкой мыши на изображении символа. Для выхода из диалога без вставки символа нажмите кнопку Отмена.


Диалог настройки параметров табуляции

Этот диалог появляется на экране после нажатия кнопки Табуляция... в диалоге редактирования стиля текста или в диалоге установки параметров абзаца.

Позволяет назначить параметры отступов табуляций.

Описание элементов управления
Элемент | Описание
Позиция | Устанавливает положение отступа табуляции в миллиметрах.
Заполнение | Вы можете выбрать из списка подходящий способ заполнения отступа табуляции.
Выравнивание | С помощью переключателей назначьте нужный способ выравнивания (влево, по центру, вправо, по десятичной точке).
Установить | После того как параметры отступа настроены, нажмите кнопку для добавления в список табуляций.
Удалить | Если нужно удалить табуляцию из списка, выберите ее и нажмите кнопку.
Удалить все | Чтобы очистить сразу весь список, нажмите кнопку.

После завершения настройки параметров табуляций нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


Диалог блокировки размеров таблицы

Этот диалог появляется на экране после вызова команды Таблица — Блокировка.

Позволяет установить ограничения на перестроение таблицы, то есть сделать ее структуру и размеры жесткими.

Описание элементов управления
Наименование | Описание
Зафиксировать габариты ячеек | Включите эту опцию, чтобы размеры ячеек таблицы нельзя было изменить.
Запретить изменять число строк | Включите эту опцию для фиксации текущего количества строк таблицы.
Запретить изменять число столбцов | Включите эту опцию для фиксации текущего количества колонок таблицы.

После завершения настройки атрибутов таблицы нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


Диалог выбора стиля линий границ

Появляется на экране после нажатия кнопки Текущий стиль.

Позволяет установить текущий стиль линии границы.

Диалог содержит опции, соответствующие системным стилям линии, которые могут быть использованы для границ ячеек:

– основная,

– тонкая,

– осевая,

– штриховая,

– утолщенная,

– пунктир 2,

– осевая основная,

– штриховая основная.

Для указания стиля включите нужную опцию и нажмите кнопку ОК. Для выхода из диалога без изменений стиля нажмите кнопку Отмена.


Диалог контроля идентификаторов таблицы

Этот диалог позволяет проконтролировать, в каких ячейках текущей таблицы основной надписи не были введены числовые идентификаторы и какие ячейки имеют одинаковые идентификаторы.

Он появляется на экране после вызова команды Сервис — Проверка идентификаторов.

В нем условно (без соблюдения размеров ячеек и отображения текстов в них) показана текущая таблица основной надписи. В таблице розовым цветом отмечены ячейки, для которых не задан идентификатор, а сиреневым — ячейки с одинаковыми идентификаторами.

Вообще говоря, в корректно сформированной таблице основной надписи не может быть ячеек без идентификаторов (не считая уже заполненных ячеек, в которые пользователю не нужно вводить данные) и ячеек с одинаковыми идентификаторами.

Редактирование ячеек (в том числе изменение их формата) в диалоге контроля невозможно. Для исправления идентификаторов запомните ячейки, которые требуется отредактировать, выйдите из диалога и измените расширенный формат нужных ячеек.


Диалог редактирования стиля текста

Этот диалог появляется на экране после нажатия кнопки Создать или Редактировать в диалоге работы с наборами и библиотеками стилей, а также нажатия кнопки Новый... в диалоге выбора стиля текста.

Позволяет создать или отредактировать стиль текста, который впоследствии можно использовать для быстрого оформления абзацев. Стиль включает параметры шрифта, данные о форматировании абзаца и другие настройки.

Описание элементов управления
Элемент | Описание
Номер | В этом поле требуется указать уникальный номер стиля текста в библиотеке.
Наименование | В этом поле можно ввести или отредактировать имя стиля.
Расширенный стиль текста | Включите эту опцию, чтобы задать параметры расширенного стиля. После включения опции становится доступной кнопка Далее.... Нажмите ее для вызова диалога расширенного стиля текста.
Шаг строк | Устанавливает расстояние между строками текста.
Красная строка | Устанавливает величину отступа вправо от границы абзаца в его первой строке.
Слева | Устанавливает величину абзацного отступа слева.
Справа | Устанавливает величину абзацного отступа справа
Перед абзацем | Устанавливает величину интервала перед абзацем.
После абзаца | Устанавливает величину интервала после абзаца.
Выравнивание | Переключатели, позволяющие назначить нужный способ выравнивания абзацев (по левой границе, по правой границе, центрирование, выравнивание по двум границам).
Шрифт... | Нажмите эту кнопку для вызова диалога настройки параметров шрифта.
Табуляция... | Нажмите эту кнопку для вызова диалога настройки параметров табуляции.
Далее... | Нажмите эту кнопку для настройки расширенного стиля текста.

После завершения редактирования стиля нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


Диалог указания формата текста

Этот диалог позволяет указать формат, в котором хранится вставляемый в документ текст. Благодаря указанию формата при вставке будет использован соответствующий конвертер текста.

В поле Исходный файл указано полное имя файла, содержимое которого вставляется в документ.

В списке перечислены допустимые для вставки в КОМПАС текстовые форматы. Выделите название формата, в котором хранится вставляемый текст.

После выбора формата нажмите кнопку OK для вставки содержимого выбранного файла. Для выхода из диалога без вставки текста нажмите кнопку Отмена.


Диалог Параметры свойства

Этот диалог появляется на экране в следующих случаях:

– после нажатия кнопки Создать свойство, Редактировать или Просмотреть в диалоге Управление свойствами,

– после нажатия кнопки Просмотр в диалоге настройки списка свойств.

Диалог позволяет добавить новое свойство в список свойств документа или библиотеки свойств, изменить или просмотреть параметры существующего свойства. В режиме просмотра изменение параметров недоступно.

Описание элементов управления

Наименование

Описание

Наименование

Поле позволяет ввести или изменить наименование свойства.

Тип данных

Раскрывающийся список позволяет выбрать тип значения свойства — Целый, Вещественный, Строка или Логический. От выбранного типа значения зависит доступность элементов управления диалога.

Тип значения выбирается при создании свойства и не может быть изменен в дальнейшем. При редактировании свойства список типов значений недоступен.

Заполнение из списка

Опция позволяет задать в качестве правила ввода значений свойства выбор из предопределенного списка. Для формирования списка включите эту опцию и нажмите кнопку Правило для значений.

Правило ввода значений задается при создании свойства и не может быть изменено в дальнейшем. Опция доступна в режиме создания свойства для всех типов значения, кроме логического.

Величина

Раскрывающийся список позволяет выбрать измеряемую сущность, с которой будет связано свойство. После выбора измеряемой сущности ее базовая единица измерения становится единицей измерения свойства.

Измеряемая сущность выбирается при создании свойства и не может быть изменена в дальнейшем. Список доступен в режиме создания свойства для значения типа Вещественный или Строка.

Единица измерения

Раскрывающийся список позволяет выбрать единицу измерения свойства. Он содержит единицы измерения текущей измеряемой сущности.

Список доступен для значения свойства типа Вещественный или Строка.

Правило для значений

Значения свойства в документе могут задаваться в рамках конкретного диапазона значений или выбираться из предопределенного списка (при включенной опции Заполнение из списка). Первый вариант доступен для значений типа Целый или Вещественный, второй вариант — для значений типа Целый, Вещественный или Строка.

В зависимости от выбранного варианта после нажатия кнопки на экране появляется диалог задания диапазона значений или формирования списка значений свойства.

Поле значений

Поле служит для отображения правила, заданного для ввода значений свойства. Недоступно для редактирования.

Комментарий

Поле позволяет ввести дополнительные сведения о свойстве. Доступно для значений всех типов.

Идентификатор

Поле служит для отображения идентификатора свойства. Идентификатор назначается автоматически и не может быть изменен пользователем. Поле недоступно для редактирования.

Чтобы завершить создание или изменение свойства, нажмите кнопку ОК. Кнопка Отмена позволяет закрыть диалог без сохранения изменений.


Диалог выбора ориентации вида

Этот диалог появляется на экране после вызова команды Ориентация.

В нем можно изменить текущую ориентацию модели на стандартную или пользовательскую ориентацию из списка, а также сохранить текущую ориентацию в списке.

В столбце таблицы Имя расположен список всех ориентаций, существующих в текущей модели. В столбце таблицы Состояние слоев указано, содержится ли в ориентациях информация о состояниях слоев.

Над таблицей находятся кнопки управления списком ориентаций модели.

Описание элементов управления
Наименование | Описание
Добавить | Если требуется сохранить текущую пользовательскую ориентацию, нажмите эту кнопку. В список добавится новая строка с именем и порядковым номером. Вы можете изменить имя ориентации. Если в модели, кроме системного слоя, существует еще хотя бы один слой, то по умолчанию опция в столбце Состояние слоев включена. При включенной опции вместе с информацией о положении модели в текущей ориентации сохраняется информация о состоянии слоев. Чтобы отменить сохранение данных о состоянии слоев, отключите опцию.
Удалить | Если требуется удалить какую-либо ориентацию из списка, выберите ее имя и нажмите эту кнопку. Удаление возможно только для пользовательских ориентаций. Стандартные ориентации (их названия начинаются с символа «#») удалить нельзя.
Применить | Если требуется установить какую-либо ориентацию из списка в качестве текущей, выберите ее имя и нажмите эту кнопку.

Для закрытия диалога нажмите кнопку Выход.


Диалог работы с наборами и библиотеками стилей

Позволяет создать новые или отредактировать уже имеющиеся стили линий или текстов, а также выполнять различные операции с наборами и библиотеками стилей.

Этот диалог появляется на экране после вызова команды Стили линий... или Стили текстов... из меню Сервис — Библиотеки стилей, типов, оформлений и основных надписей.

На панелях в левой и правой частях диалога можно отобразить списки стилей, хранящихся в разных местах: в библиотеке, наборе или документе. Для активизации нужной панели щелкните на ней левой кнопкой мыши. Признаком того, что панель активна, является отображение вокруг нее рамки.

Стили в списках могут быть отсортированы по именам или по номерам. Чтобы изменить сортировку, щелкните мышью по заголовку нужного столбца. В заголовке столбца, по которому сортируются стили, отображается треугольник. Его положение показывает направление сортировки — по возрастанию или по убыванию.

Описание элементов управления
Наименование | Описание
Внедренные/ Библиотечные | Если на панели показан список стилей документа или набора, то он представлен в виде закладок. При переключении между закладками соответственно отображается либо список стилей, хранящихся внутри документа или набора, либо список стилей, взятых из внешних библиотек в документ или набор.
Показать библиотеку | Для подключения внешней библиотеки стилей нажмите эту кнопку.
Показать набор | Для подключения созданного ранее набора стилей нажмите эту кнопку.
Показать документ | Чтобы просмотреть список стилей, имеющихся в активном документе, нажмите эту кнопку.
Создать | Для перехода к диалогу создания нового стиля нажмите эту кнопку. Совет...
Редактировать | Для перехода к диалогу редактирования стиля выберите его из списка и нажмите эту кнопку.
Копировать | Вы можете обмениваться стилями между различными библиотеками и наборами. Для этого откройте нужные библиотеки или наборы, выберите один или несколько стилей и нажмите кнопку копирования.
Удалить | Для удаления одного или нескольких стилей из набора, документа или библиотеки выберите имена стилей в списке и нажмите эту кнопку.

Для удобства поиска и выбора внешний вид стиля линии отображается в специальном окне просмотра.

Чтобы закрыть диалог, нажмите кнопку Выход.


Диалог работы с наборами и библиотеками стилей штриховок

Позволяет создать новые или отредактировать уже имеющиеся стили штриховок, а также выполнять различные операции с наборами и библиотеками стилей.

Этот диалог появляется на экране после вызова команды Сервис — Библиотеки стилей, типов, оформлений и основных надписей — Стили штриховок....

На панелях в левой и правой частях диалога можно отобразить списки стилей штриховок, хранящихся в разных местах: в библиотеке, наборе или документе. Для активизации нужной панели щелкните на ней левой кнопкой мыши. Признаком того, что панель активна, является отображение вокруг нее рамки.

Стили штриховок в списках могут быть отсортированы по именам или по номерам. Чтобы изменить сортировку, щелкните мышью по заголовку нужного столбца. В заголовке столбца, по которому сортируются стили, отображается треугольник. Его положение показывает направление сортировки — по возрастанию или по убыванию.

Описание элементов управления
Наименование | Описание
Внедренные/Библиотечные | При переключении между закладками соответственно отображается либо список стилей, хранящихся внутри документа или набора, либо список стилей, взятых из внешних библиотек в документ или набор.
Показать библиотеку | Для подключения внешней библиотеки стилей нажмите эту кнопку.
Показать набор | Для подключения созданного ранее набора стилей нажмите эту кнопку.
Показать документ | Чтобы просмотреть список стилей, уже использованных в активном документе, нажмите эту кнопку.
Создать | Для перехода к диалогу создания нового стиля штриховки нажмите эту кнопку. Совет...
Редактировать | Для перехода к диалогу редактирования стиля выберите его из списка и нажмите эту кнопку.
Копировать | Вы можете обмениваться стилями штриховки между различными библиотеками и наборами. Для этого откройте нужные библиотеки или наборы, выберите один или несколько стилей и нажмите кнопку копирования.
Удалить | Для удаления одного или нескольких стилей из набора, документа или библиотеки выберите имена стилей в списке и нажмите эту кнопку.

Для удобства поиска и выбора внешний вид стиля штриховки отображается в специальном окне просмотра.

Чтобы закрыть диалог, нажмите кнопку Выход.


Диалог работы с оформлениями чертежей и спецификаций

Позволяет создать новые или отредактировать уже имеющиеся оформления чертежей и спецификаций, а также выполнять различные операции с библиотеками оформлений (они хранятся в файлах с расширением *.lyt).

Этот диалог появляется на экране после вызова команды Сервис — Библиотеки стилей, типов, оформлений и основных надписей — Оформление чертежей и спецификаций....

На панелях в левой и правой частях диалога можно отобразить списки оформлений, хранящихся в двух разных библиотеках. Для активизации нужной панели щелкните на ней левой кнопкой мыши. Признаком того, что панель активна, является отображение вокруг нее рамки.

Оформления в списках могут быть отсортированы по именам или по номерам. Чтобы изменить сортировку, щелкните мышью по заголовку нужного столбца. В заголовке столбца, по которому сортируются оформления, отображается треугольник. Его положение показывает направление сортировки — по возрастанию или по убыванию.

Описание элементов управления
Наименование | Описание
Показать библиотеку | Для подключения другой библиотеки оформлений нажмите эту кнопку.
Создать | Для перехода к диалогу создания нового оформления нажмите эту кнопку. Совет...
Редактировать | Для перехода к диалогу редактирования оформления выберите его название из списка и нажмите эту кнопку.
Копировать | Вы можете обмениваться оформлениями между различными библиотеками. Для этого откройте нужные библиотеки, выберите элемент и нажмите кнопку копирования.
Удалить | Для удаления одного или нескольких элементов из библиотеки выберите их имена в списке и нажмите эту кнопку.

Чтобы закрыть диалог, нажмите кнопку Выход.


Диалог работы с основными надписями

Этот диалог появляется на экране после вызова команды Сервис — Библиотеки стилей, типов, оформлений и основных надписей — Основные надписи....

В нем можно создать новые или отредактировать уже имеющиеся основные надписи документов, а также выполнять различные операции с библиотеками основных надписей (они хранятся в файлах с расширением *.lyt).

На панелях в левой и правой частях диалога можно отобразить списки основных надписей, хранящихся в двух разных библиотеках. Для активизации нужной панели щелкните на ней левой кнопкой мыши. Признаком того, что панель активна, является отображение вокруг нее рамки.

Основные надписи в списках могут быть отсортированы по именам или по номерам. Чтобы изменить сортировку, щелкните мышью по заголовку нужного столбца. В заголовке столбца, по которому сортируются основные надписи, отображается треугольник. Его положение показывает направление сортировки — по возрастанию или по убыванию.

Описание элементов управления
Наименование | Описание
Показать библиотеку | Для подключения другой библиотеки основных надписей нажмите эту кнопку.
Создать | Для перехода к диалогу создания новой основной надписи нажмите эту кнопку. Совет...
Редактировать | Для перехода к диалогу редактирования основной надписи выберите ее название из списка и нажмите эту кнопку.
Копировать | Вы можете обмениваться основными надписями между различными библиотеками. Для этого откройте нужные библиотеки, выберите элемент и нажмите кнопку копирования.
Удалить | Для удаления одной или нескольких основных надписей из библиотеки выберите их имена в списке и нажмите эту кнопку.

Чтобы завершить диалог, нажмите кнопку Выход.


Диалог работы с оформлениями текстовых документов

Позволяет создать новые или отредактировать уже имеющиеся оформления текстовых документов, а также выполнять различные операции с библиотеками оформлений (они хранятся в файлах с расширением *.lyt).

Этот диалог появляется на экране после вызова команды Сервис — Библиотеки стилей, типов, оформлений и основных надписей — Оформление текстовых документов....

На панелях в левой и правой частях диалога можно отобразить списки оформлений, хранящихся в двух разных библиотеках. Для активизации нужной панели щелкните на ней левой кнопкой мыши. Признаком того, что панель активна, является отображение вокруг нее рамки.

Оформления в списках могут быть отсортированы по именам или по номерам. Чтобы изменить сортировку, щелкните мышью по заголовку нужного столбца. В заголовке столбца, по которому сортируются оформления, отображается треугольник. Его положение показывает направление сортировки — по возрастанию или по убыванию.

Описание элементов управления
Наименование | Описание
Показать библиотеку | Для подключения другой библиотеки оформлений нажмите эту кнопку.
Создать | Для перехода к диалогу создания нового оформления нажмите эту кнопку. Совет...
Редактировать | Для перехода к диалогу редактирования оформления выберите его название из списка и нажмите эту кнопку.
Копировать | Вы можете обмениваться основными надписями между различными библиотеками. Для этого откройте нужные библиотеки, выберите элемент и нажмите кнопку копирования.
Удалить | Для удаления одного или нескольких элементов из библиотеки выберите их имена в списке и нажмите эту кнопку.

Чтобы завершить диалог, нажмите кнопку Выход.


Предупреждение о наличии стиля в библиотеке

Это предупреждение выдается при попытке поместить в библиотеку стиль с уже существующим в ней номером (например, путем создания в ней нового стиля или копировании в нее стиля из другой библиотеки)

В нем указаны названия помещаемого в библиотеку и существующего в ней стиля, имеющих один номер.

Стили линий, штриховок и текстов в библиотеках КОМПАС-3D различаются по номерам. В библиотеке не может существовать двух стилей с одинаковым номером (даже если названия у них разные).

Чтобы поместить стиль в библиотеку, не удаляя из нее существующий стиль, нажмите кнопку Добавить с оставлением старого. В этом случае новому стилю будет присвоен первый из «незанятых» в библиотеке номеров.

Чтобы поместить стиль в библиотеку вместо существующего стиля, нажмите кнопку Добавить вместо старого. В этом случае существующий в библиотеке стиль будет удален (таким образом «освободится» его номер), а новый стиль без изменения номера разместится в библиотеке.

Если не требуется помещать в библиотеку стиль, конфликтующий с существующими в ней стилями по номеру, нажмите кнопку Не добавлять.


Диалог установки размеров прямоугольника разбиения (зоны чертежа)

Диалог установки размеров прямоугольника разбиения
(зоны чертежа)

Позволяет установить размер по горизонтали и вертикали зон, на которые требуется разбить лист чертежа.

Описание элементов управления
Наименование | Описание
Высота, мм Ширина, мм | Введите в полях значения высоты и ширины зон или выберите эти значения из раскрывающихся списков. Введенные вручную значения будут добавляться в список и сохраняться в течение сеанса работы КОМПАС-3D. При разбиении листа на зоны ориентация прямоугольника разбиения игнорируется: длина стороны листа делится на длину той стороны прямоугольника, которая максимальное количество раз укладывается в длину стороны.

После завершения настройки размеров прямоугольника разбиения чертежа на зоны нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


Диалог информации о документе

Этот диалог появляется на экране после вызова команды Файл — Информация о документе.... Кроме того, по умолчанию этот диалог автоматически появляется при первом сохранении КОМПАС-документа.

Позволяет просмотреть и отредактировать справочную информацию, хранящуюся вместе с документом.

Вкладка Общие сведения

Вкладка Внешние ссылки

Вкладка Атрибуты

Чтобы закрыть диалог, нажмите кнопку ОК.

Вы можете ввести умолчательные данные об авторе и организации, а также умолчательный комментарий. Для этого вызовите команду Сервис — Параметры... — Новые документы — Свойства документа. В появившемся диалоге можно ввести необходимые сведения, а также отключить автоматический вызов диалога свойств при первом сохранении документа.


Оформление листа

Оформление листа включает в себя рамки (внешние и внутренние), значения отступов от них, таблицы основной надписи и таблицу изменений. Наличие таблицы изменений не является обязательным. Оформления хранятся в библиотеках оформлений. Файлы этих библиотек имеют расширение lyt.


Изменение положения компонентов исполнения

Чтобы запустить процесс изменения положения компонента исполнения, выделите в Дереве построения нужный компонент и вызовите команду Редактор — Редактировать или команду Разместить компонент контекстного меню.

Команда доступна:

– независимое исполнение — для всех компонентов,

– зависимое исполнение — для компонентов, связь которых с компонентами исходного исполнения отменена,

– зеркальное исполнение — для компонентов, связь которых с компонентами исходного исполнения отменена, а также для компонентов (кроме локальных деталей), сохраняющих связь с компонентами исходного исполнения, если они получены способом Симметричное расположение компонента или Зеркальное отражение компонента с результатом операции Отображать компонент в зеркальном виде.

Если команда вызвана для компонента независимого или зависимого исполнения, то на Панели свойств появляются элементы изменения положения и параметров вставки компонента.

При вызове команды для компонента зеркального исполнения обратите внимание на следующие особенности.

– Если связь компонента с исходным отменена или компонент добавлен в зеркальное исполнение после его создания, на Панели свойств появляются элементы изменения положения и параметров вставки компонента.

– Если связь компонента с исходным сохраняется (рядом с пиктограммой компонента в Дереве построения отображается «замок»), на Панели свойств появляются элементы настройки параметров отражения компонента.


Редактирование грани/эквидистанты грани с помощью команд

Для изменения формы и положения грани, преобразованной в сплайновую поверхность, или ее эквидистанты можно использовать следующие команды инструментальной панели Сплайновая форма:

– Линейное перемещение,

– Перемещение со сглаживанием,

– Вращение,

– Масштабирование,

– Выравнивание.

Чтобы некоторые полюсы были неподвижны в процессе редактирования, зафиксируйте их, используя команду Фиксировать полюсы.

Команды Порядок и Сетка позволяют изменить параметры сплайновой поверхности, в которую преобразована грань, или эквидистантной этой грани сплайновой поверхности.

Смотрите также

Команда Сплайновая форма


EMF

EMF (Enhanced Metafile Format) — 32-битный графический формат, основанный на 16-битном WMF (Windows Metafile Format), но содержащий различные улучшения. Разработан Microsoft и используется для обмена графической информацией между приложениями Microsoft Windows. Поддерживает векторную и растровую графику.


Особенности записи КОМПАС-документов в формат EMF

Формат EMF поддерживает как векторную, так и растровую графику.

Растровое изображение в файлах формата EMF формируется в результате экспорта из КОМПАС-3D следующих документов и объектов:

– сборки (*.a3d),

– детали (*.m3d),

– заливки цветом, растровые и OLE-вставки в графических документах.

В остальных случаях в файлах формата EMF формируется векторное изображение.

При последующем импорте файлов формата EMF в другие графические форматы может наблюдаться некорректное отображение букв кириллицы. В этом случае рекомендуется использовать в исходных КОМПАС-документах шрифты Юникод.


Элемент управления ориентацией

Позволяет изменить ориентацию модели.

Чтобы повернуть модель, щелкните мышью по оси, плоскости или дуге значка.

Приемы работы


Диалог Выделение объектов по свойствам

Этот диалог появляется на экране после вызова команды Выделить по свойствам.

Позволяет производить прямое или обратное выделение объектов, обладающих общими свойствами, такими как геометрические параметры, принадлежность видам и слоям, стили линий, и т.п.

В диалоге находятся инструментальная панель, дерево для выбора объектов и таблица свойств.

Инструментальная панель диалога Выделение объектов по свойствам...

Дерево объектов содержит наименования типов объектов, которые присутствуют в текущем документе. Этот набор формируется автоматически. Опция рядом с наименованием позволяет управлять включением объектов данного типа в группу выделяемых объектов.

После того как тип объекта будет выбран в дереве, в таблице появляется перечень свойств объектов этого типа. В столбце Свойство перечислены признаки, по которым производится выбор среди объектов данного типа. В каждой ячейке столбца Условие находится раскрывающийся список знаков, задающих условия присвоения значений.

= — равно, содержит,

<> — не равно, не содержит,

>= — больше или равно,

<= — меньше или равно

> — больше,

< — меньше.

Ячейки столбца Значение в зависимости от выбранного свойства представляют собой поле ввода или раскрывающийся список параметров. Координата или размер вводятся в ячейку с клавиатуры. Для отделения целой части от дробной используется точка. Остальные параметры выбираются из раскрывающихся списков. Списки содержат только те значения свойств (стили линий, типы ограничений и т.п.), которые используются в данном документе. Раскрывающаяся палитра цветов — стандартная.

При выборе объектов следует учитывать следующие особенности.

1. Включение в дереве опции всего раздела позволяет быстро задать общие свойства для всех его объектов. Выбранные условия и значения параметров отображаются в таблицах свойств объектов всех типов.

Если в столбце Свойство выбран вид и в столбце Значение указан его номер, то при выборе слоя в раскрывающемся списке будут присутствовать только те слои, которые принадлежат данному виду. Если вид не выбран, то для выбора будут доступны все слои.

2. Если опция типа объекта включена, то учитываются указанные свойства, и игнорируются неуказанные.

Если в таблице не указано значение ни одного свойства, то в группу попадают все объекты данного типа.

Если значения свойств заданы, а опция объекта выключена, то объекты в группу не попадают.

3. Если Значения выбраны, а Условия — нет, то принимается знак условия — «равно».

Если Условия выбраны, а Значения — нет, то считается, что свойства не указаны, то есть в группу попадают все объекты данного типа.

Кнопка Применить позволяет выполнить действия по добавлению в группу, исключению из группы, инвертированию выделения без закрытия диалога. Для выполнения действия с закрытием диалога нажмите кнопку ОК. Для выхода из диалога без выполнения действия нажмите кнопку Отмена.

Подробнее о выделении объектов по свойствам...


Инструментальная панель диалога Выделение объектов по свойствам

Инструментальная панель содержит кнопки, позволяющие управлять результатом операции выделения объектов и изменять масштаб отображения документа.

Описание кнопок

Кнопка

Описание

Применить ко всем объектам

Кнопки, позволяющие задать область применения фильтра — все объекты документа или только выделенные объекты. Кнопка Применить к выделенным объектам доступна, если в документе есть выделенные объекты; она нажимается автоматически, если на момент вызова диалога в документе были выделены объекты. Когда эта кнопка нажата, в дереве присутствуют только те типы объектов, которые есть среди выделенных.

Применить к выделенным объектам

Добавлять в группу

Кнопки, позволяющие добавлять в группу и исключать из нее объекты, указанные в дереве. Группу могут составлять как выделяемые объекты, так и объекты, не подлежащие выделению.

– Если нажата кнопка Добавлять в группу, то все указанные объекты будут выделены или добавлены к ранее выделенным.

– Если нажата кнопка Исключить из группы, то указанные объекты исключаются из числа выделенных. Кнопка Исключить из группы доступна, если в документе уже есть выделенные объекты.

Добавление и исключение объектов происходит после нажатия кнопки ОК или Применить.

Исключать из группы

Инвертировать выделение

Кнопка позволяет инвертировать текущее выделение. Инвертирование означает, что с выделенных объектов выделение снимается, но выделяются все остальные. Если в дереве выбора объектов указаны какие-либо объекты, то

– при нажатой кнопке Добавлять в группу указанные объекты добавляются к выделенным; результат инвертируется

– при нажатой кнопке Исключать из группы выделение с указанных объектов снимается; результат инвертируется.

Инвертирование выделения происходит после нажатия кнопки ОК или Применить.

Показать все

Кнопка позволяет изменить масштаб отображения в активном окне таким образом, чтобы в нем был виден полностью весь документ.

Масштаб по выделенным объектам

Кнопка позволяет автоматически изменить масштаб отображения в активном окне таким образом, чтобы в нем полностью помещались все выделенные объекты в максимально возможном масштабе1. Если ни один объект не выделен, команда недоступна.
  1. Выделенные вспомогательные прямые и пустые (не содержащие ни одного объекта) виды при выполнении команды не учитываются. Не учитывается также единственная выделенная точка.


Фантом скругления

После указания исходных кривых на экране появляется фантом скругления — дуга окружности с характерной точкой или цилиндр с характерной точкой и сплайн. Какой именно фантом скругления (дуга окружности или цилиндр и сплайн) появится на экране, зависит от взаимного расположения исходных кривых.

Скругление кривых...


Диалог Фильтр слоев

Этот диалог появляется на экране после нажатия на кнопку Создать фильтр в диалоге Менеджер документа.

Элементы управления диалога позволяют настраивать фильтр.

Описание элементов управления
Наименование | Описание
Название фильтра | Поле позволяет задать имя фильтра. По умолчанию создаваемому фильтру присваивается имя, состоящее из слова «Фильтр», к которому добавляется порядковый номер.
Условия | Таблица содержит набор условий фильтрации. Задание условий
Просмотр | Таблица содержит список слоев, свойства которых удовлетворяют условиям фильтрации. Пока не сформировано ни одного условия, в списке отображаются все слои родительского объекта фильтра. Перечень динамически изменяется при изменении условий фильтрации.

Чтобы завершить формирование фильтра, следует нажать кнопку ОК. Диалог будет закрыт. Значок фильтра появится в Дереве листов, видов и слоев. Чтобы закрыть диалог, отказавшись от сделанных изменений, нажмите кнопку Отмена.


Задание условий фильтрации

Каждая строка таблицы Условия является условием фильтрации слоев. Условия фильтрации следует выбирать из раскрывающихся списков, которые содержатся в полях:

– Статус, Активность, Видимость, Цвет— в графическом документе,

– Статус, Видимость, Цвет, Редактирование и Проецирование в чертеж — в документе-модели.

В полях Номер, Имя, Комментарий условия необходимо вводить с клавиатуры. При этом можно использовать маски. В масках знак «*» заменяет любое количество любых символов. Знак «?» заменяет один любой символ. Чтобы завершить ввод в поле, следует нажать <Enter> или щелкнуть мышью вне этого поля.

При задании условий вы можете использовать команды контекстного меню. Команда Очистить ячейку позволяет удалить значение в текущем поле условия. Команда Удалить строку позволяет удалить условие целиком. Команда Копировать строку позволяет создать копию текущей строки.

Условий фильтрации может быть несколько. После формирования одного условия автоматически создается строка для создания следующего. Если фильтр состоит из нескольких условий, то они складываются. Например, если поле Статус одного условия содержит значение «непустой слой», а другого — «пустой слой», то в фильтре будут показаны и пустые, и содержащие объекты слои.


Габаритный параллелепипед

Габаритный параллелепипед — условный параллелепипед, грани которого параллельны координатным плоскостям и проходят через наиболее удаленные друг от друга точки объектов модели.

Пользователь может выбрать типы объектов, которые будут учитываться при построении габаритного параллелепипеда (см. раздел 9.1.11.13).


Geom_H

Geom_H


Geom_H_Part_2

Geom_H_Part_2


Гладкая цепочка кривых

Гладкая цепочка кривых — цепочка, в которой кривые имеют общую касательную в точке соединения.


Диалог Стили отчетов

Этот диалог появляется на экране

– после вызова команды Сервис — Библиотеки стилей, типов, оформлений и основных надписей — Стили отчетов...,

– после нажатия кнопки Стили отчетов на панели Отчеты.

Позволяет создавать, просматривать, редактировать стили, хранящиеся в библиотеке, а также редактировать структуру библиотек, копировать и перемещать стили из одной библиотеки в другую.

Диалог работы с библиотеками стилей отчетов

Элемент

Описание

Окно просмотра

Служит для отображения списка стилей библиотеки.

Диалог имеет два окна просмотра, в них одновременно могут отображаться списки стилей двух разных библиотек. Активным может быть только одно окно — оно выделено рамкой. Активизация производится щелчком мыши в окне.

Списки стилей имеют структуру дерева — разделы, подразделы и т.д., содержащие стили. Уровень вложенности разделов не ограничен. Все объекты в дереве автоматически сортируются по именам внутри каждого раздела.

Показать
библиотеку

Позволяет отобразить в активном окне список стилей, хранящихся в библиотеке, а также создать новую библиотеку. После нажатия кнопки на экране появляется диалог, в котором необходимо указать имя файла библиотеки стилей.

Подробнее о создании библиотеки...

Новый раздел

Позволяет создать новый подраздел в текущем разделе. После нажатия кнопки на экране появляется диалог, в котором нужно ввести имя нового раздела (подраздела).

Новый

Позволяет создать новый стиль в текущем разделе библиотеки. После нажатия кнопки на экране появляется диалог, в котором необходимо выполнить действия по созданию нового стиля.

Просмотреть

Позволяет просмотреть выделенный стиль. После нажатия кнопки (или двойного щелчка мышью по стилю) на экране появляется диалог настройки параметров стиля в режиме просмотра.

Редактировать

Позволяет отредактировать выделенный объект — наименование раздела (подраздела) или стиль. После нажатия кнопки на экране появляется:

– если был выделен раздел — диалог создания и редактирования его имени;

– если был выделен стиль — диалог создания и редактирования стиля.

Удалить

Позволяет удалить выделенный стиль или раздел. Раздел удаляется вместе со всеми стилями в нем.

Внимание! Восстановление удаленного стиля или раздела библиотеки невозможно.

Копировать1

влево/вправо

Позволяет производить обмен стилями или разделами между библиотеками. После нажатия кнопки выделенный стиль или раздел копируется в соседнее окно в раздел, который является в нем текущим.

Перенести1

влево/вправо

Позволяет переносить стили или разделы из одной библиотеки в другую. После нажатия кнопки выделенный стиль или раздел переносится в текущий раздел соседнего окна.
  1. Кнопки доступны, если в неактивном окне просмотра открыта библиотека.

Для завершения работы в диалоге нажмите кнопку Выход.


Команда О программе

Позволяет вывести на экран информацию о версии установленной на вашем компьютере копии системы КОМПАС-3D и сведения о ключе защиты.


Команда Выход

Позволяет завершить сеанс работы КОМПАС-3D.

Для вызова команды выберите ее название из меню Файл.

В том случае, если какие-либо открытые документы не были сохранены, на экране будут выдаваться запросы на сохранение этих документов. Если документ сохраняется впервые, появится стандартный диалог сохранения файла.


Команда Что это такое?

Позволяет получить справку по командам, кнопкам и другим элементам интерфейса КОМПАС-3D.

Для вызова команды можно также нажать комбинацию клавиш <Shift>+<F1>.

После вызова команды курсор мыши изменит свой внешний вид (превратится в вопросительный знак со стрелкой). Подведите курсор к интересующему вас объекту экрана и щелкните по нему мышью.

Смотрите также

Как получить справку во время работы


Команда Расположить значки режимов

Позволяет расположить значки режимов в различных областях окна документа.

Для вызова команды выберите ее в контекстном меню значка режима.


Диалог Сечения модели

Появляется на экране после вызова команды Управление сечениями... из меню Вид — Сечение модели или меню кнопки Сечение модели на панели Вид.

Диалог позволяет выполнять различные действия с сечениями модели. Он содержит список сечений и инструментальную панель.

Список сечений имеет вид таблицы, состоящей из двух колонок: Имя и Статус.

Вы можете изменить имя сечения, дважды щелкнув мышью в соответствующей ячейке колонки Имя. Ячейка станет доступной для ввода.

Колонка Статус позволяет сделать текущим нужное сечение. Для этого дважды щелкните мышью в соответствующей ячейке этой колонки.

Набор элементов инструментальной панели диалога приведен в таблице.

Элементы управления диалога
Название | Описание
Создать сечение | Кнопка позволяет создать в модели новое сечение. После нажатия кнопки запускается процесс создания сечения, а диалог Сечения модели закрывается.
Текущее сечение | Кнопка позволяет сделать текущим сечение, выбранное в списке. Доступна при выборе сечения, которое не является текущим.
Редактировать сечение | Кнопка позволяет отредактировать сечение, выбранное в списке. После нажатия кнопки запускается процесс редактирования сечения, а диалог Сечения модели закрывается. Редактирование сечения аналогично его созданию.
Удалить сечение | Кнопка позволяет удалить сечение, выбранное в списке. Если удаленное сечение было текущим, то текущим становится сечение, следующее за ним в списке.
Режим сечения модели | Кнопка позволяет включить/отключить режим сечения модели. При этом диалог остается открытым.

После выполнения всех необходимых действий закройте диалог.

Действия, выполненные в диалоге, не могут быть отменены.


Команда Удалить — Выделенные объекты

Позволяет удалить все выделенные объекты активного документа.

Если ни один элемент не выделен, команда будет недоступна.

Для вызова команды выберите ее название из меню Редактор.

Для удаления выделенных объектов можно также нажать клавишу <Delete>.

Для отмены удаления объектов нажмите кнопку Отменить на Стандартной панели или комбинацию клавиш <Ctrl>+<Z>.

Смотрите также

Удаление графических объектов

Удаление трехмерных объектов


Команда Удалить — Все

Позволяет удалить все содержимое активного документа.

После выполнения этой команды нельзя будет воспользоваться командой Отменить.

Для вызова команды выберите ее название из меню Редактор.

После вызова команды на экране появляется диалог с предупреждением о том, что отмена данной операции будет невозможна. Для подтверждения удаления всех объектов документа нажмите кнопку ОК, для отказа от удаления — кнопку Отмена.

Смотрите также

Удаление графических объектов


Команда Копировать

Позволяет копировать выделенные объекты в буфер обмена (Clipboard). Команда доступна только в том случае, если в активном документе имеются выделенные объекты.

Предыдущее содержимое буфера обмена будет удалено.

Для вызова команды выберите ее название из меню Редактор или нажмите кнопку Копировать на Стандартной панели.

Если вы копируете в буфер чертежные объекты из фрагмента или из одного вида чертежа, система будет ожидать указания базовой точки (при этом курсор изменяет свою форму на изображение осей координат). Укажите точку, которая будет базовой для выделенного набора объектов.

Если вы копируете в буфер чертежные объекты из разных видов чертежа и/или виды целиком, указания базовой точки не требуется.

Скопировать выделенные объекты в буфер обмена можно также, нажав комбинацию клавиш <Ctrl>+<C> или <Ctrl>+<Ins>.

Смотрите также

Использование буфера обмена


Команда Вырезать

Позволяет удалять выделенные объекты и помещать их в буфер обмена (Clipboard). Команда доступна только в том случае, если в активном документе имеются выделенные объекты.

Предыдущее содержимое буфера обмена будет удалено.

Для вызова команды выберите ее название из меню Редактор или нажмите кнопку Вырезать на Стандартной панели.

Если вы вырезаете в буфер чертежные объекты из фрагмента или из одного вида чертежа, система будет ожидать указания базовой точки (при этом курсор изменяет свою форму на изображение осей координат). Укажите точку, которая будет базовой для выделенного набора объектов.

Если вы вырезаете в буфер чертежные объекты из разных видов чертежа и/или виды целиком, указания базовой точки не требуется.

Вырезать выделенные объекты в буфер обмена можно также, нажав комбинацию клавиш <Ctrl>+<X> или <Shift>+<Delete>.

Смотрите также

Использование буфера обмена


Команда Найти...

Позволяет найти заданный текст.

Для вызова команды выберите ее название из меню Редактор.

После этого на экране появится диалог, в котором можно задать различные параметры для поиска текста. После задания параметров поиска нажмите кнопку OK для начала поиска.

Для продолжения замены вызовите команду Редактор — Продолжить или нажмите клавишу <F3>.

Поиск текста в таблице производится в пределах текущей ячейки.


Команда Вставить

Позволяет вставлять копию содержимого буфера обмена (Clipboard) в активный документ.

Если буфер обмена пуст, команда будет недоступна.

Для вызова команды выберите ее название из меню Редактор или нажмите кнопку Вставить на Стандартной панели.

Если в буфере находятся объекты, принадлежавшие фрагменту или одному виду чертежа, их фантом появится на экране. Система будет ожидать указания положения точки привязки (новое положение базовой точки объектов).

Вы можете задать координаты точки привязки, а также масштаб и угол поворота вставки из буфера, введя их значения в поля Панели свойств.

На Панели свойств в группе Выносные линии находятся также переключатели, позволяющие указать, требуется ли масштабировать выносные линии размеров.

За один вызов команды можно вставить содержимое буфера обмена произвольное количество раз, задавая различные угол поворота и масштаб вставки.

Если в буфере находятся объекты, принадлежавшие разным видам чертежа и/или виды (вид) целиком, то указания нового положения базовой точки не требуется. Вставленные объекты размещаются в видах с теми же параметрами, что и исходные объекты.

Вставить содержимое буфера обмена в документ можно также, нажав комбинацию клавиш <Ctrl>+<V> или <Shift>+<Ins>.

Копирование атрибутов и свойств

Обратите внимание на то, что при работе с текстом (например, с текстом на чертеже или с текстом технических требований) используется стандартный буфер обмена Windows. Таким образом, возможна вставка текста из документа *.txt, *.rtf, *.doc и т.п. Указание точки привязки при вставке текста не требуется. Имеющийся в буфере текст сразу после вызова команды вставляется в текущую позицию курсора. Вставка иллюстраций невозможна.

Смотрите также

Использование буфера обмена


Команда Повторить

Позволяет повторить отмененное действие пользователя, если это возможно.

Для вызова команды нажмите кнопку Повторить на Стандартной панели или выберите ее название из меню Редактор.

Смотрите также

Отмена и повтор действий


Команда Продолжить

Позволяет найти или заменить следующее вхождение заданного текста в соответствии с параметрами, установленными при предыдущем вызове команд Найти... или Заменить... из меню Редактор.

Для вызова команды выберите ее название из меню Редактор. Можно также нажать клавишу <F3>.


Команда Заменить...

Позволяет найти заданный текст и заменить его на другой заданный текст.

Для вызова команды выберите ее название из меню Редактор.

После этого на экране появится диалог, в котором можно задать различные параметры для поиска и замены текста. После задания параметров нажмите кнопку OK для начала замены.

Для продолжения замены вызовите команду Редактор — Продолжить или нажмите клавишу <F3>.

Замена текста в таблице производится в пределах текущей ячейки.


Команда Выделить все

Позволяет выделить сразу все объекты, которые содержатся в текущем фрагменте или в текущем виде активного чертежа.

Для вызова команды нажмите кнопку Выделить все на инструментальной панели Выделение или выберите ее название из меню Редактор.

Можно также нажать комбинацию клавиш <CTRL>+<A>.

Смотрите также

Выделение объектов и отмена выделения


Команда Специальная вставка...

Позволяет вставить в активный документ содержимое буфера обмена Windows в выбранном формате.

После вызова команды на экране появляется диалог, в котором можно настроить различные параметры вставки.

Если буфер обмена пуст, команда Специальная вставка... будет недоступна.


Команда Отменить

Позволяет отменить предыдущее действие пользователя, если это возможно.

Для вызова команды нажмите кнопку Отменить на Стандартной панели или выберите ее название из меню Редактор.

Смотрите также

Отмена и повтор действий


Команда Закрыть

Позволяет закрыть активный документ.

Для вызова команды выберите ее название из меню Файл.

В том случае, если во время сеанса работы в документ были внесены какие-либо изменения и вы не сохраняли их, на экране появится запрос о сохранении документа. При закрытии документа без сохранения все сделанные изменения будут потеряны.

Если документ был открыт в нескольких окнах, то закрываются все его окна.

Быстро закрыть активный документ можно с помощью двойного нажатия кнопки управляющего меню документа, которая находится в верхнем левом углу его окна.

Для быстрого закрытия всех документов, записи всех несохраненных документов и завершения сеанса работы с КОМПАС-3D вызовите команду Выход из меню Файл.


Команда 1, 2, 3...

В нижней части страницы меню Файл отображается список документов, с которыми велась работа ранее. Фактически это перечень документов в той последовательности, в которой они закрывались.

Чтобы открыть один из документов, выберите его имя из списка.

Количество документов, имена которых хранятся в списке, можно задать в диалоге общей настройки.


Команда Создать

Позволяет создать новый КОМПАС-документ.

Для вызова команды выберите ее название из меню Файл или нажмите кнопку Создать на Стандартной панели.

На экране появится диалог выбора типа нового документа.

На вкладке Шаблоны можно выбрать нужный шаблон для нового документа.

Если использование шаблона не требуется, выберите тип документа на вкладке Новые документы.

Нажмите кнопку ОК для создания документа заданного типа или по заданному шаблону.

Другим способом создания нового документа является выбор его из меню кнопки Создать.

Команды этого меню можно расположить в виде кнопок на отдельной панели и поместить ее в любом удобном месте. Для этого «перетащите» меню кнопки Создать мышью за заголовок в любом направлении. Будет сформирована панель Новый документ.

Обратите внимание на отличие панели Новый документ от остальных инструментальных панелей: состав и порядок кнопок на ней изменить невозможно.


Команда Открыть

Позволяет открыть созданный ранее КОМПАС-документ.

Для вызова команды выберите ее название из меню Файл или нажмите кнопку Открыть на Стандартной панели.

После этого на экране появится диалог выбора файла.

В том случае, если вы недавно редактировали документ, а затем закрыли его, повторное открытие можно выполнить более быстрым способом. В нижней части меню Файл отображается список последних девяти документов, с которыми велась работа. Фактически это перечень документов в той последовательности, в которой они закрывались. Для того чтобы открыть нужный документ, просто выберите его имя в меню.

Если вы попытаетесь открыть уже загруженный для работы документ, КОМПАС-3D не выполнит повторное открытие, а просто активизирует окно этого документа.

При попытке открыть уже загруженный документ, используя альтернативный путь (например, вы пытаетесь открыть по сети файл, который хранится на диске вашего компьютера и уже загружен в текущем сеансе работы), на экране появится сообщение: «Файл уже редактируется».

Смотрите также

Файл-сателлит


Команда Печать

Позволяет настроить параметры печати и вывести на печать текущий документ.

Выполнение команды невозможно для многолистовых документов с различными габаритами листов.

Для вызова команды выберите ее название из меню Файл или нажмите кнопку Печать на Стандартной панели. На экране появится диалог Печать документа, позволяющий настроить параметры печати.

Для ускорения настройки удобно использовать конфигурации устройств печати.

После установки всех необходимых параметров нажмите кнопку ОК для начала печати. Чтобы выйти из диалога без вывода документа на печать, нажмите кнопку Отмена.


Команда Предварительный просмотр

Позволяет перейти в режим предварительного просмотра и печати документов.

Для вызова команды выберите ее название из меню Файл или нажмите кнопку Предварительный просмотр на Стандартной панели.

Меню кнопки Предварительный просмотр содержит команды настройки параметров предварительного просмотра и команду Загрузить задание на печать. Данное меню вызывается щелчком мыши по треугольнику, расположенному рядом с кнопкой.

Если в главном окне системы открыт один документ, то после вызова команды он будет сразу показан в режиме предварительного просмотра.

Если открыто несколько документов, на экране появится диалог выбора документов для печати. Чтобы этот диалог не появлялся на экране, а текущий документ был сразу показан в режиме предварительного просмотра, нажмите кнопку Предварительный просмотр, удерживая клавишу <Shift>.

Для получения информации о том, как подключить принтер или плоттер, обратитесь к документации по Windows и имеющемуся у вас устройству вывода.


Команда Настройка плоттера/принтера

Позволяет настроить параметры плоттера или принтера, на котором будут печататься документы.

Для вызова команды выполните одно из следующих действий:

– в главном окне — выберите название команды из меню Файл — Настройки предварительного просмотра или меню кнопки Предварительный просмотр, расположенной на Стандартной панели,

– в режиме предварительного просмотра — выберите название команды из меню Файл или нажмите кнопку Настройка плоттера/принтера на инструментальной панели.

После вызова команды на экране появляется системный диалог настройки печати.

Описание элементов управления
Наименование | Описание
Имя | Показывает имя устройства, установленного как принтер по умолчанию. Вы можете выбрать из списка другое устройство вывода.
Ориентация | Позволяет выбрать ориентацию листов бумаги: книжная (вертикальная) или альбомная (горизонтальная).
Бумага | Позволяет задать параметры бумаги (размер и способ подачи), из числа поддерживаемых выбранным принтером.
Свойства | Кнопка, позволяющая изменить параметры текущего устройства. После ее нажатия на экране появится системный диалог драйвера принтера, в котором можно настроить различные параметров печати (градации оттенков, интенсивность и т.д.). Набор настраиваемых опций зависит от типа принтера или плоттера.

После завершения настройки печати нажмите кнопку ОК диалога. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.

Смотрите также

Режим предварительного просмотра


Команда Сохранить

Позволяет сохранить активный документ.

Для вызова команды выберите ее название из меню Файл или нажмите кнопку Сохранить на Стандартной панели.

При сохранении документ записывается в файл с именем и расширением, которые были установлены при самом первом сохранении документа. В том случае, если документ сохраняется впервые, на экране появится стандартный диалог сохранения файла.

Вы можете сохранить документ в качестве шаблона. Для этого в поле Тип файла диалога сохранения выберите строку Шаблон.... Обратите внимание на то, что для сохранения шаблона автоматически предлагается папка, содержащая подпапку \Templates. Раскрыв последнюю, вы можете выбрать нужную папку для сохранения шаблона или создать новую.

Если ведется редактирование подчиненной части документа — типового фрагмента или текста технических требований — то функцию команды Сохранить выполняет команда Сохранить — С владельцем в файл или Сохранить — С документом в файл соответственно. После вызова этой команды происходит запись на диск результата редактирования подчиненной части документа и самого документа.

Вы можете настроить систему так, чтобы при первом сохранении имя документа формировалось автоматически из его обозначения и/или наименования.

Смотрите также

Команда Сохранить как...


Команда Сохранить как...

Позволяет сохранить активный документ с изменением имени, типа и расположения файла.

На экране появляется стандартный диалог сохранения файлов.

Укажите папку для размещения файла и введите его имя.

Вы можете сохранить документ в качестве шаблона. Для этого в поле Тип файла диалога сохранения выберите строку Шаблон.... Обратите внимание на то, что для сохранения шаблона по умолчанию предлагается подпапка \Templates главной папки КОМПАС-3D (это определяется переменой среды TEMPLATES). Вы можете выбрать другую папку для сохранения шаблона или создать новую.

Нажмите кнопку Сохранить для сохранения документа. Чтобы выйти из диалога без записи, нажмите кнопку Отмена.

При сохранении сборки в деталь может потребоваться настроить параметры сохранения. Для этого из меню кнопки Сохранить вызовите команду Сохранить с параметрами... и выполните необходимые настройки в появившемся диалоге Параметры сохранения в деталь.


Команда Сохранить копию как...

Позволяет сохранить вставленный КОМПАС-документ на диске под другим именем.


Команда Отправить

Позволяет отправить по электронной почте сообщение вместе с присоединенным к нему активным документом. Команда становится доступной в том случае, если на компьютере установлена какая-либо служба сообщений или почтовая служба, использующая стандартные протоколы Windows (например, Microsoft Exchange).

Для вызова команды выберите ее название из меню Файл.

После этого на экране появляется диалог используемой по умолчанию службы сообщений, в котором следует ввести адреса получателей, а также текст сообщения и его тему.


Команда Обновить изображение

Позволяет передать изменения, сделанные в КОМПАС-документе, в документ-контейнер.


Диалог ввода надписи допуска формы

Этот диалог появляется после вызова команды Текст надписи... из контекстного меню или щелчка в поле Текст на Панели свойств.

В нем можно ввести текст надписи для обозначения допуска формы и расположения поверхностей и сформировать таблицу допуска.

Пока данный диалог находится на экране, на Панели свойств доступны элементы, а в Главном меню — команды, позволяющие работать с текстом. Некоторые из них можно вызвать из контекстного меню поля ввода диалога.

Если длина вводимых строк превысит габариты окна ввода, оно будет автоматически перестроено.

После завершения ввода текста нажмите кнопку OK. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


Команда Контекстная

Позволяет вывести на экран страницу Справочной системы со сведениями о выполняемой в данный момент команде, о параметре, ввода которого ожидает система, или о действующем в данный момент режиме. Для быстрого вызова контекстной справки нажмите клавишу <F1>.

Смотрите также

Как получить справку во время работы


Команда Содержание

Позволяет вывести на экран раздел с содержанием оперативной Справочной системы.

Смотрите также

Как получить справку во время работы


Буфер обмена Менеджера библиотек (Clipboard)

Буфер обмена Менеджера библиотек (Clipboard) — область памяти, в которую временно помещается вырезанная библиотека. Содержимое буфера обмена можно затем вставить в другой раздел Менеджера библиотек.

При новом копировании в буфер его предыдущее содержимое будет потеряно.

Менеджер библиотек использует собственный механизм буфера обмена, отличающийся от стандартного буфера Windows.


Диалог Обозначение(ввод обозначения в основной надписи и объекте спецификации)

Диалог Обозначение
(ввод обозначения в основной надписи и объекте спецификации)

Служит для ввода и редактирования составного обозначения документа в ячейку Обозначение основной надписи или объекта спецификации.

– Если ячейка пуста или содержит простое обозначение, для открытия диалога следует вызвать команду Обозначение документа... из контекстного меню.

– Если ячейка содержит или должна содержать1 составное обозначение, диалог появляется автоматически при попытке ввода или редактирования текста обозначения.

Введите или отредактируйте содержимое полей диалога Обозначение.

Код документа можно вставить из специального диалога. Для его вызова служит команда Вставить код и наименование в меню Вставка или в контекстном меню поля Код.

Если диалог вызван при редактировании текста основной надписи, то наличие поля Код зависит от того, включен или выключен показ кода документа при настройке раздела.

Завершив ввод обозначения, нажмите кнопку ОК. В ячейку основной надписи или объекта спецификации будет внесен текст обозначения.

Чтобы отказаться от ввода или редактирования обозначения, нажмите кнопку Отмена.

Подробнее о вводе обозначения...

  1. Например, ячейка колонки Обозначение в разделе спецификации Документация.


Список окон открытых документов

В этом списке отображаются названия открытых в данный момент документов. Название активного документа отмечено в этом списке «галочкой». Щелчок мышью на названии любого документа в списке делает этот документ активным.


Команда Закладки внизу

Позволяет разместить закладки документов под окном текущего документа.

Для вызова команды выберите ее название из контекстного меню закладки.


Команда Закладки вверху

Позволяет разместить закладки документов над окном текущего документа.

Для вызова команды выберите ее название из контекстного меню закладки.


Список конфигураций устройств печати

Список конфигураций устройств печати отображается в меню Файл — Настройки предварительного просмотра (в главном окне) и в меню Файл — Конфигурация плоттера/принтера (в режиме предварительного просмотра). Фактически это перечень файлов конфигураций, которые сохранялись или загружались в последнее время при печати документов из режима предварительного просмотра.

Чтобы загрузить одну из конфигураций, выберите ее имя из списка.

Количество конфигураций, имена которых хранятся в списке, можно задать в диалоге общих настроек печати. По умолчанию список содержит девять последних сохраненных или загруженных конфигураций.

Смотрите также

Команда Сохранить конфигурацию плоттера/принтера...

Команда Загрузить конфигурацию плоттера/принтера...


Меню настройки столбцов (Окно переменных)

Меню настройки столбцов
(Окно переменных)

Меню настройки столбцов позволяет управлять отображением столбцов таблицы Окна переменных.

Это меню появляется на экране после щелчка правой кнопкой мыши по заголовку любого из столбцов таблицы, отображаемой в Окне переменных.

Меню содержит команды, одноименные столбцам таблицы. Чтобы включить/отключить отображение нужного столбца, вызовите соответствующую ему команду меню. «Галочка» рядом с названием команды означает, что отображение столбца включено.

Команда настройки столбца Пересчитанное значение доступна только при включенном режиме пересчета размеров с учетом допусков.

Если требуется настроить не только отображение столбцов, но и их взаимное расположение, вызовите команду Дополнительно.... На экране появится диалог Настройка столбцов, позволяющий выполнить необходимые настройки.

Смотрите также

Настройка Окна переменных


Группа переключателей Способ вывода

Группа переключателей позволяет выбрать способ печати текущего листа документа.

Активизируйте переключатель Вывести текущий лист полностью, чтобы вывести на печать лист целиком.

Активизируйте переключатель Вывести заданную область текущего листа, чтобы вывести на печать определенную область листа.

Положение и размер печатаемой области листа настраиваются при помощи команды Режим указания выводимых областей листов.


Лист

В окне предварительного просмотра отображаются все листы документов, выбранные для печати. Выберите из раскрывающегося списка лист документа, чтобы сделать его текущим.


Текущий масштаб печати

В этом поле отображается значение масштаба, с которым выделенный лист или несколько выделенных листов будут выведены на печать.

Если выделенные листы имеют разные масштабы, то поле пусто.

Вы можете изменить масштаб выделенных листов, набрав вручную нужное значение. Чтобы поле ввода стало доступным, подведите к нему курсор и щелкните левой кнопкой мыши.

Можно также выбрать значение шага из списка. Чтобы открыть список, щелкните на клавише со стрелкой рядом с полем ввода.


Группа переключателей Способ указания области

Группа переключателей позволяет выбрать способ указания печатаемой области текущего листа.

Доступны следующие способы указания области:

– заданием размеров и положения области,

– заданием отступов границ области от краев листа.

Для выбора нужного способа активизируйте соответствующий ему переключатель.

Ниже переключателей расположены поля управления областью печати листа. Набор полей соответствует выбранному способу указания области.

Обратите внимание на то, что указанная область текущего листа выводится на печать, если в группе переключателей Способ вывода на Панели свойств активен переключатель Вывести заданную область текущего листа. В случае активизации переключателя Вывести текущий лист полностью на печать выводится весь лист целиком.


Координата X

В этом поле отображается значение координаты X базовой точки текущего листа документа (левой нижней точки его габаритного прямоугольника).

Вы можете изменить значение координаты (переместить лист), набрав вручную нужное число. Чтобы поле ввода стало доступным, подведите к нему курсор и щелкните левой кнопкой мыши.


Координата Y

В этом поле отображается значение координаты Y базовой точки текущего листа документа (левой нижней точки его габаритного прямоугольника).

Вы можете изменить значение координаты (переместить лист), набрав вручную нужное число. Чтобы поле ввода стало доступным, подведите к нему курсор и щелкните левой кнопкой мыши.


Диалог Выбор базового компонента

Этот диалог появляется на экране после нажатия кнопки Указать базовый компонент на инструментальной панели диалога Параметры зеркального отражения компонентов.

Позволяет указать компонент, относительно которого будет определяться положение других компонентов модели при их симметричном размещении. Указанный компонент принимается базовым.

Диалог содержит список компонентов, каждый из которых может быть базовым для тех компонентов модели, которые должны быть добавлены как одно целое (эти компоненты выбираются перед вызовом диалога).

По умолчанию базовым является компонент, который находится на верхней строке списка. Рядом с его именем отображается «галочка». Чтобы сделать базовым другой компонент, дважды щелкните по строке списка, содержащей этот компонент, или выделите его в списке и нажмите кнопку Выбор базового компонента.

Для завершения работы в диалоге нажмите кнопку ОК. Диалог закроется. Положение указанных компонентов будет определяться относительно базового.

Кнопка Отмена позволяет закрыть диалог, отказавшись от выбора базового компонента.


Поля управления областью печати листа(указание области печати заданием ее отступов от краев листа)

Поля управления областью печати листа
(указание области печати заданием ее отступов от краев листа)

Группа полей позволяет определить границы области печати листа, задав их положение относительно краев листа. Присутствует на Панели свойств, если в группе Способ указания области активизирован переключатель Указание выводимой области листа заданием ее отступов от края листа.

Для задания отступов области печати от краев листа используются поля Слева, Снизу, Справа и Сверху.

В поля вводятся числа или выражения для их вычисления.

При перемещении мышью области печати или ее границ значения в полях изменяются автоматически.


Поля управления областью печати листа(указание области печати заданием ее размеров и положения)

Поля управления областью печати листа
(указание области печати заданием ее размеров и положения)

Группа полей позволяет определить границы области печати листа, задав ее положение и размеры. Присутствует на Панели свойств, если в группе Способ указания области активизирован переключатель Указание выводимой области листа заданием ее размеров и положения.

Для задания положения области печати используются поля Слева и Снизу, для задания размеров — Ширина и Высота.

В поля вводятся числа или выражения для их вычисления.

При перемещении мышью области печати или ее границ значения в полях изменяются автоматически.


Режим эскиза

При работе в режиме эскиза пользователю доступны команды страниц Главного меню, а также команды ввода и редактирования геометрических объектов, простановки размеров, измерения, наложения параметрических связей и ограничений, кнопки для быстрого вызова которых расположены на Компактной панели.

Смотрите также

Как получить справку во время работы


Блок

Группа переключателей, предназначенная для работы с блоками текста.

Блок текста — фрагмент текста, вставляемый в КОМПАС-документ из внешнего файла (*.txt или *.kdw), либо сохраняемый в файл (*.txt или *.kdw) для последующей вставки.


Команда Разбить ячейки...

Позволяет разбить ячейку или выделенные ячейки таблицы.

Текущая ячейка или несколько выделенных ячеек таблицы могут быть разбиты на несколько ячеек.

Чтобы выполнить разбиение, следует нажать кнопку Разбить ячейки или вызвать команду Таблица — Разбить ячейки...

На экране появится диалог Разбиение ячеек, элементы управления которого позволяют задать параметры разбиения.

Если команда применяется к блоку выделенных ячеек, то ее результат зависит от состояния опции Объединить ячейки перед разбиением этого диалога.

– Если опция включена, то выделенные ячейки объединяются и полученная таким образом ячейка разбивается на заданное количество строк и столбцов.

– Если опция выключена, то на заданное количество строк и столбцов разбивается каждая из выделенных ячеек.

Свойства ячейки и параметры форматирования текста новых ячеек наследуются от исходной ячейки.


Окно просмотра

Окно просмотра текущих параметров шрифта.


Высота символов

Поле, в котором можно ввести или выбрать из списка высоту символов выделенного или набираемого текста.


Модели

Панель, содержащая перечень документов-моделей, ассоциативные виды которых имеются в активном чертеже. Модель, имя которой выделено в списке цветом, отображается в окне просмотра. Для отказа от предварительного просмотра активизируйте опцию Выключить просмотр.

По умолчанию с основной надписью чертежа связывается первая модель, ассоциативное изображение которой было вставлено в этот чертеж. Именно с этой моделью производится синхронизация основной надписи.

Чтобы указать другую модель для синхронизации, выберите ее из списка и нажмите кнопку Связать (можно также произвести двойной щелчок мыши на нужной строке).


Параметры

Группа переключателей, позволяющая перейти к настройкам различных параметров выделенного или вводимого текста.


Строка

Чтобы добавить строку над текущей, нажмите кнопку Вставить строку сверху.

Чтобы добавить строку под текущей, нажмите кнопку Вставить строку снизу.

Чтобы добавить строку внизу таблицы, установите курсор в крайнюю позицию нижней правой ячейки и нажмите клавишу <Tab>.

Чтобы удалить текущую строку таблицы, нажмите кнопку Удалить строку.


Точность представления массы

Поле для ввода или выбора количества знаков после запятой в значении массы.


Единицы измерения массы

Поле для выбора единиц измерения массы.


Режим синхронизации

Автоматическая синхронизация

Если активен этот переключатель, синхронизация данных основной надписи чертежа и модели производится автоматически: при открытии и активизации документа, а также при перестроении изображения в чертеже.

Если обозначение материала в ассоциативном чертеже отредактировано путем добавления пробелов, переноса строк или табуляции, то в результате автоматической синхронизации обозначение материала в чертеже не меняется при условии, что материал модели не менялся. Во всех остальных случаях обозначение материала в чертеже синхронизируется с обозначением материала модели.

Синхронизация по запросу

Если активен этот переключатель, синхронизация данных будет производиться только после вызова команды Синхронизировать данные из контекстного меню основной надписи в режиме ее редактирования.


Синхронизация массы

Активизация этого переключателя означает, что всякий раз при синхронизации значение массы модели будет рассчитано заново и записано в ячейку «Масса».

После активизации переключателя Синхронизация массы становятся доступными поля, позволяющие настроить отображение значения массы модели в ячейке «Масса».

Если переключатель Синхронизация массы не активен, то пересчет массы не производится, и ее значение в основной надписи не изменяется.


Обозначение единиц массы

Поле для ввода сокращенного обозначения единиц измерения массы. Введенный текст добавляется к значению массы в соответствующей графе основной надписи.


Шаг строк

Поле для ввода шага строк в текущем или выделенных абзацах.


Синхронизация данных

Переключатель, управляющий синхронизацией данных основной надписи активного чертежа и модели. Если переключатель Синхронизация данных неактивен, то синхронизация данных не производится.


Формат ячейки

Группа переключателей, предназначенная для настройки формата ячеек таблиц.


Команда Объединить ячейки

Позволяет объединить выделенные ячейки таблицы.

Несколько ячеек таблицы могут быть объединены в одну. Предварительно они должны быть выделены.

Чтобы объединить ячейки, следует нажать кнопку Объединить ячейки или вызвать команду Таблица — Объединить ячейки.

Выделенные ячейки должны образовывать прямоугольный блок.

Подробнее...


Сужение символов

Поле, в котором можно ввести или выбрать из списка сужение символов выделенного или набираемого текста.


Окно редактирования объекта спецификации или таблицы изменений

Это окно появляется на экране после вызова команды создания или редактирования объекта спецификации в графическом документе или модели. В чертеже данное окно появляется также при создании или редактирования объекта таблицы изменений.

Оно оформлено в виде строки спецификации (таблицы изменений), в которую можно ввести текстовую часть объекта.

С помощью элементов Панели свойств можно настроить создаваемый объект.

После ввода текстовой части и настройки объекта нажмите кнопку OK. Созданный объект будет зафиксирован в документе, а окно его редактирования будет закрыто. Для закрытия окна без фиксации объекта спецификации (отказа от создания или редактирования объекта) нажмите кнопку Отмена.

Для открытия окна подчиненного режима, в котором будут видны и доступны для редактирования все объекты спецификации (или таблицы изменений) текущего документа, вызовите команду Спецификация — Редактировать объекты или Спецификация — Редактировать объекты таблицы изменений соответственно.

Окно редактирования объектов таблицы изменений


Диалог ввода надписи обозначения

Диалог используется для ввода текста, входящего в состав обозначений шероховатости, базы, маркировки, клеймения, линий-выносок и других.

Диалог появляется на экране при задании обозначений объектов оформления в процессе их создания или изменения. Для вызова диалога выполните одно из следующих действий:

– щелкните мышью в поле Текст на Панели свойств,

– вызовите команду Текст надписи... из контекстного меню,

– дважды щелкните мышью на тексте обозначения в окне документа (щелчок может производиться в любой точке внутри габаритного прямоугольника текста).

В процессе создания/редактирования базы при включенной опции Автосортировка диалог недоступен.

Пока данный диалог находится на экране, на Панели свойств доступны элементы, а в Главном меню — команды, позволяющие работать с текстом. Некоторые из них можно вызвать из контекстного меню поля ввода диалога.

В окне просмотра диалога отображается иллюстрация, поясняющая расположение отдельных строк текста на объекте.

Если длина вводимых строк превысит габариты окна ввода, оно будет автоматически увеличено.

После завершения ввода текста нажмите кнопку OK. Для выхода из диалога без сохранения введенного текста нажмите кнопку Отмена.

Особенности ввода текста для некоторых обозначений представлены в таблице.

Особенности ввода текста обозначений

Обозначение

Особенности ввода текста

Маркировка

Клеймение

При вводе надписи знаков маркировки и клеймения в диалоге ввода текста присутствует кнопка Ссылка, позволяющая включить в надпись ссылку. Кнопка Ссылка расположена справа от первого поля ввода.

Линия-выноска

Дополнительные полки при простановке позиционной линии-выноски строятся автоматически при вводе каждой новой строки текста. Чтобы создать новую строку, нажмите клавишу <Enter>.

Изменение

Номер изменения может быть задан вручную или автоматически.

Заданный вручную номер является простым текстом и может быть изменен с клавиатуры или с помощью счетчика, расположенного справа от поля ввода текста.

Номер, заданный автоматически, является ссылкой на номер обозначения в группе нумерации. Он недоступен для изменения. Если требуется, вы можете удалить номер-ссылку. При этом обозначение изменения будет удалено из группы нумерации.

Линия разреза/сечения (для машиностроения)

Стрелка взгляда

Выносной элемент

Если на Панели свойств включена опция Автосортировка, то в диалоге ввода текста недоступно первое поле, а если включена опция Лист или Зона, то — второе поле. Если включены опции Автосортировка и Лист (или Зона), то недоступно само поле Текст на Панели свойств и вызов диалога ввода текста невозможен.

Линия разреза (для строительства)

Если на Панели свойств включена опция Лист или Зона, то в диалоге ввода текста второе поле недоступно.


Диалог ввода текста номера узла

Позволяет ввести текст в обозначение номера узла.

Диалог появляется после двойного щелчка на тексте номера узла. Во время создания и редактирования обозначения диалог ввода текста можно вызвать щелчком в поле Текст на Панели свойств или с помощью команды Текст надписи... из контекстного меню.

Введите текст номера узла в поле ввода. Если введен двухстрочный текст, то в обозначении автоматически создается разделитель — горизонтальная черта посередине формы. Первая строка текста будет расположена над разделителем, а вторая — под разделителем. Для формирования новой строки или разбиения одной строки на две нажмите клавишу <Enter>.

Если длина строки введенного текста окажется больше диаметра окружности обозначения, произойдет автоматическое сужение надписи.

Пока диалог ввода текста находится на экране, на Панели свойств доступны элементы, а в Главном меню — команды, позволяющие работать с текстом. Некоторые из них можно вызвать из контекстного меню поля ввода диалога.

Номер узла может входить в надпись вида — если вид был автоматически сформирован после создания обозначения узла или узла в сечении. В этом случае номер узла представляет собой ссылку на соответствующее обозначение узла.


Диалог ввода текста выносной надписи

Позволяет ввести текст выносной надписи.

Диалог появляется на экране после двойного щелчка на тексте выносной надписи. Во время создания и редактирования выносной надписи диалог ввода текста можно вызвать щелчком в поле Текст на Панели свойств или с помощью команды Текст надписи... из контекстного меню.

В окне диалога отображается таблица, состоящая из двух колонок. В левой колонке находятся порядковые номера полок. В правой колонке находится поле ввода текста.

Введите текст в поле ввода. Чтобы перейти к вводу текста следующей полки, нажмите комбинацию клавиш <Shift> + <Enter> или клавишу <Tab>. В окне диалога появится новая строка с номером следующей полки. Чтобы ввести несколько строк на одной полке, пользуйтесь клавишей <Enter> для разделения текста на строки.

Чтобы вставить табуляцию при вводе текста, нажмите комбинацию клавиш <Ctrl> + <Tab>.

При вводе текста выносной надписи можно использовать текстовые шаблоны — готовые или созданные пользователем. Для вызова Библиотекаря текстовых шаблонов дважды щелкните мышью в поле ввода.

Вы можете вставлять в выносную надпись несколько текстовых шаблонов одновременно. При этом в диалоге будет сформировано столько дополнительных строк (и, соответственно, полок в выносной надписи), сколько шаблонов было отмечено в окне Библиотекаря.

Пока диалог ввода текста находится на экране, на Панели свойств доступны элементы, а в Главном меню — команды, позволяющие работать с текстом. Некоторые из них можно вызвать из контекстного меню поля ввода диалога.

Вы можете сделать ссылку на другой текстовый объект, находящийся в этом же документе. Команду вставки ссылки можно вызвать из контекстного меню поля ввода или из меню Вставка.

После завершения ввода текста нажмите кнопку ОК диалога.

Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.

Чтобы введенный текст автоматически предлагался при создании новых выносных надписей, включите опцию Сохранять текст на вкладке Параметры Панели свойств.


Команда Закрыть (Системное меню)

Команда Закрыть
(Системное меню)

Эта команда закрывает окно, из системного меню которого она вызвана.

Закрытие Главного окна системы эквивалентно выходу из нее. Закрыть Главное окно можно также при помощи комбинации клавиш <Alt>+<F4>.

Закрытие единственного окна документа эквивалентно закрытию этого документа. Закрыть активное окно документа можно также при помощи комбинации клавиш <Ctrl>+<F4>.

Для закрытия окна можно нажать системную кнопку Закрыть в его правом верхнем углу.

Если перед выходом из системы или закрытием документа не были сохранены внесенные в него изменения, будет выдан запрос на их сохранение.


Команда Переместить (Системное меню)

Команда Переместить
(Системное меню)

Эта команда доступна в Главном окне системы, если оно занимает часть экрана, и в окне документа, если оно занимает часть Главного окна. Она позволяет изменить положение окна на экране.

После вызова команды курсор превращается в четырехстороннюю стрелку. Подведите его к заголовку окна, нажмите левую кнопку мыши и перемещайте окно, не отпуская кнопку мыши. Когда нужное положение окна будет достигнуто, отпустите кнопку.

Переместить окно можно и без вызова команды. Для этого в любом режиме работы подведите курсор к заголовку окна, зафиксируйте на нем и перемещайте окно, как описано выше.

Такой способ изменения положения окна называется перетаскиванием окна за заголовок.

Для изменения размеров окна пользуйтесь командой Размер из системного меню.


Команда Следующее

Эта команда доступна в системном меню окна документа, если это окно — не единственное в Главном окне системы.

Команда активизирует следующее в списке открытых окон окно документа.

Переключиться на следующее окно (активизировать его) можно также при помощи комбинаций клавиш <Ctrl>+<F6> или <Ctrl>+<Tab>.


Команда Восстановить (Системное меню)

Команда Восстановить
(Системное меню)

Эта команда доступна в Главном окне системы, если оно развернуто на весь экран, и в окне документа, если оно развернуто на все окно системы (то есть если окно максимизировано).

После вызова команды размер окна изменяется: оно занимает часть экрана, а его габариты и положение на экране соответствуют габаритам и положению, которые были установлены перед тем, как окно было развернуто на весь экран (то есть восстанавливается прежний размер окна).

Для восстановления размеров окна можно также нажать системную кнопку Восстановить в правом верхнем углу окна.

После вызова команды на месте кнопки Восстановить возникает кнопка Развернуть, которая вызывает противоположное действие — разворачивание окна на весь экран.

Для изменения размеров окна пользуйтесь командой Размер из системного меню.


Команда Свернуть (Системное меню)

Команда Свернуть
(Системное меню)

Эта команда сворачивает окно до пиктограммы (минимизирует окно). Если она была вызвана в Главном окне системы, то пиктограмма помещается на Панель задач Windows. Пиктограмма свернутого окна документа помещается в нижнюю часть Главного окна системы.

Для сворачивания окна можно также нажать системную кнопку Свернуть в правом верхнем углу окна.

Для восстановления размера окна или его максимизации (разворачивания на весь экран) пользуйтесь командами Восстановить и Развернуть из системного меню.


Команда Размер (Системное меню)

Команда Размер
(Системное меню)

Эта команда доступна в Главном окне системы, если оно занимает часть экрана, и в окне документа, если оно занимает часть Главного окна. Она позволяет изменить размеры окна.

После вызова команды курсор превращается в четырехстороннюю стрелку. Подведите его к границе или углу окна. Курсор превратится в двустороннюю стрелку, указывающую направление, в котором можно переместить границу окна. Нажмите левую кнопку мыши и перемещайте границу или угол окна, не отпуская кнопку мыши. Когда нужный размер окна будет достигнут, отпустите кнопку.

Изменить размер окна можно и без вызова команды. Для этого в любом режиме работы подведите курсор к границе или углу окна, зафиксируйте на нем и изменяйте размер окна, как описано выше.

Такой способ изменения размера окна называется перетаскиванием границ окна.

Для изменения положения окна пользуйтесь командой Переместить из системного меню.


Команда Развернуть (Системное меню)

Команда Развернуть
(Системное меню)

Эта команда доступна в Главном окне системы, если оно не развернуто на весь экран, и в окне документа, если оно не развернуто на все окно системы.

После вызова команды Главное окно системы разворачивается на весь экран, а окно документа разворачивается на все Главное окно системы.

Для разворачивания (максимизации) окна можно также нажать системную кнопку Развернуть в правом верхнем углу окна.

После вызова команды на месте кнопки Развернуть возникает кнопка Восстановить, которая вызывает противоположное действие — команду восстановления прежнего размера и положения окна.

Для изменения размеров окна пользуйтесь командой Размер из системного меню.


Диалог ввода названия таблиц

Этот диалог появляется на экране после вызова в документе команды Название... из контекстного меню таблицы, размещенной в графическом документе.

В диалоге содержится поле ввода названия. Для ассоциативной таблицы, разбитой на части, диалог содержит поля, число которых равно числу таблиц.

Введите в поля диалога название для каждой таблицы по порядку.

Чтобы разбить название на строки, нажмите клавишу <Enter>, а чтобы перейти к названию другой таблицы — клавиши <↑> и <↓>.

Подробнее о вставке названий таблиц...


Диалог ввода названия спецификации на листе

Этот диалог появляется на экране после вызова команды Название... из меню Спецификация — Спецификация на листе или из контекстного меню спецификации на листе, а также после двойного щелчка на названии спецификации.

Введите в первое поле диалога название для первого листа спецификации, а во второе поле — название для последующих листов. В окне просмотра диалога отображается иллюстрация, поясняющая расположение названий.

Следует помнить, что разбиение объектов спецификации в чертеже на листы производится с помощью переключателя Размещать на новом листе. Он доступен на Панели свойств в подчиненном режиме работы с объектами спецификации.

Ширина полей ввода равна ширине таблицы спецификации, для которой задается название. Если длина введенной строки превышает ширину таблицы спецификации, происходит автоматическое сужение символов. Для перехода на новую строку нажмите клавишу <Enter>.

Пока данный диалог находится на экране, на Панели свойств доступны элементы, а в Главном меню — команды, позволяющие работать с текстом. Некоторые из них можно вызвать из контекстного меню поля ввода диалога. Например, вы можете вставить спецзнак, символ, изменить параметры форматирования текста: шрифт, высоту, выравнивание и отступы абзацев, и т.п.

Если в диалоге настройки текстовых шаблонов включена опция Сохранять введенный текст в файле, то введенные вручную названия спецификаций записываются в текущий файл текстовых шаблонов (его имя и расположение указаны в диалоге настройки текстовых шаблонов).

Завершив ввод или редактирование названий спецификации, нажмите кнопку ОК диалога. Диалог закроется, а над таблицами спецификации появятся вновь заданные или измененные названия.

Чтобы отказаться от ввода или редактирования названий, нажмите кнопку Отмена.


Окно переменных

Окно, предназначенное для работы с переменными текущего документа.

Множество переменных документа составляют пользовательские переменные и переменные параметров операций модели и переменные размеров графических документов и эскизов. Переменные могут иметь различные статусы.

Чтобы включить или отключить отображение Окна переменных на экране, вызовите команду Вид — Панели инструментов — Переменные или нажмите кнопку Переменные на панели Стандартная.

Окно переменных содержит Инструментальную панель и список переменных текущего документа.

На первом уровне списка находятся переменные главного раздела, на втором — все остальные переменные документа.

Список переменных представлен в виде таблицы. Таблица может содержать следующие столбцы:

– Имя — имя переменной,

– Выражение — способ получения значения переменной:

• число или константа, являющаяся значением переменной,

• выражение для вычисления значения,

• ссылка на переменную внешнего файла,

– Значение — текущее значение переменной,

– Пересчитанное значение — значение переменной, пересчитанное с учетом допусков размера, которому соответствует эта переменная (отображается только при включенном режиме пересчета размеров с учетом допусков),

– Допуск — допуск на значение параметра или на размер, которому соответствует переменная,

– Параметр — объект, которому соответствует переменная,

– Комментарий — комментарий к переменной.

Отображение и взаимное расположение столбцов в таблице настраивается.

Смотрите также

Порядок работы с переменными

Создание переменных

Справочник формул

Операторы, функции, константы

Вставка элементов выражения

Управление состоянием панелей и окон


Команда Строка сообщений

Позволяет включить или отключить показ Строки сообщений — строки в нижней части главного окна КОМПАС-3D, где выводятся сообщения системы, относящиеся к выполнению текущей команды или к тому элементу рабочего окна, на который указывает курсор.

Для вызова команды выберите ее название в меню Вид.


Команда Упорядочить значки

Позволяет разместить значки свернутых (минимизированных) окон документов в одну или несколько строк в нижней части главного окна КОМПАС-3D.

Для вызова команды выберите ее название из меню Окно.

Команда доступна, если отключен показ закладок документов.


Команда Каскад

Позволяет разместить открытые окна документов таким образом, чтобы они последовательно перекрывали друг друга, а заголовок каждого окна оставался видимым.

Для вызова команды выберите ее название из меню Окно.

Вызов команды Каскад отключает показ закладок документов (если он был включен), так как использование закладок возможно только при развернутых окнах документов.


Команда Новое окно документа

Позволяет открыть дополнительное окно активного графического документа или документа-модели.

Для вызова команды выберите ее название из меню Окно или из контекстного меню закладки документа.

Если для этого документа уже открыто несколько окон и какое-либо из них минимизировано (свернуто до пиктограммы), то новое дополнительное окно также создается в минимизированном виде.

Количество дополнительных окон, которые можно открыть для документа, не ограничено.

При работе с графическими документами команда Новое окно документа доступна, если для отрисовки документов на экране используется GDI. Выбор средства формирования изображения — OpenGL или GDI — осуществляется в диалоге управления изображением.


Команда Мозаика горизонтально

Позволяет горизонтально разместить открытые окна всех документов таким образом, чтобы они прилегали друг к другу и все были видимыми.

Для вызова команды выберите ее название из меню Окно.

Чтобы разместить мозаикой только окна активного документа, используйте команду Мозаика для одного документа.

Вызов команды Мозаика горизонтально отключает показ закладок документов (если он был включен), так как использование закладок возможно только при развернутых окнах документов.


Команда Мозаика вертикально

Позволяет вертикально разместить открытые окна всех документов таким образом, чтобы они прилегали друг к другу и все были видимыми.

Для вызова команды выберите ее название из меню Окно.

Чтобы разместить мозаикой только окна активного документа, используйте команду Мозаика для текущего документа.

Вызов команды Мозаика вертикально отключает показ закладок документов (если он был включен), так как использование закладок возможно только при развернутых окнах документов.


Окно Дерева документа

Окно, в котором отображается Дерево документа. При работе с чертежом окно содержит одну вкладку Построение, на которой отображается Дерево чертежа. При работе с моделью окно содержит три вкладки — Построение, Исполнения и Зоны. На вкладке Построение отображается Дерево построения модели, на вкладке Исполнения — Дерево исполнений модели, а на вкладке Зоны — Дерево зон.

Окно Дерева документа может размещаться только внутри окна документа.

Для включения и выключения этого окна служит команда Вид — Дерево чертежа (для чертежей) или Вид — Дерево модели (для деталей и сборок). Если около названия команды отображается «галочка», то окно Дерева документа находится на экране.

Управление состоянием окна Дерева документа


Окно Технические требования

Окно, предназначенное для работы с техническими требованиями в модели.

Окно Технические требования может размещаться только внутри окна документа.

Для включения и выключения этого окна служит команда Вид — Технические требования. Если около названия команды отображается «галочка», то окно Технические требования находится на экране.

Управление состоянием окна Технические требования...

В окне могут выполняться следующие действия:

– ввод и редактирование текста,

– вставка специальных объектов и форматирование текста — при помощи команд из меню Вставка и Формат,

– сохранение текста в отдельный текстовый файл (*.txt) или текстовый документ КОМПАС-3D (*.kdw) — при помощи команды Файл — Сохранить в документ,

– вывод текста на печать — при помощи команды Файл — Печать.

Для редактирования текста в окне режима работы с техническими требованиями служит команда Редактор — Редактировать в окне из меню окна Технические требования.

Заданные технические требования сохраняются в документе-модели.


Окно Свойства при копировании свойств

Служит для просмотра свойств объекта-источника копируемых свойств, а также для включения и отключения копирования того или иного свойства.

Окно Свойства появляется на экране после нажатия одноименной кнопки на Стандартной панели или вызова команды Редактор — Свойства.

Окно Свойства включает:

– поле с названием объекта-источника свойств,

– инструментальную панель, содержащую элементы управления:

• Группировка — для разбиения перечня свойств на группы,

• Сортировка — для алфавитной сортировки свойств в перечне,

• Указать заново — для смены объекта-источника свойств.

– таблицу свойств, содержащую названия и значения свойств объекта-источника.

Отображение окна Свойства можно включить как до вызова команды Копировать свойства, так и после.

До вызова команды в этом окне можно изменять свойства выделенного объекта.

После вызова команды изменение свойств выделенного объекта в окне Свойства становится недоступно (т.е. возможен только просмотр текущих значений свойств). Слева от названий свойств появляются опции для управления копированием свойств. Включение опции означает, что соответствующее ей свойство будет скопировано из объекта-источника в указанный объект (объекты), а отключение — что свойство скопировано не будет.

Смотрите также

Управление состоянием панелей и окон


Область для работы с уравнениями

Эта область отображается в нижней части Окна переменных, если на инструментальной панели этого окна нажата кнопка Уравнения.

В области уравнений отображается таблица из двух колонок: Уравнения и Комментарий.

Область уравнений служит для просмотра и удаления уравнений:

– в графических документах, которые были созданы в КОМПАС-3D V11 и более ранних версиях,

– в эскизах моделей, которые были созданы в КОМПАС-3D V8 Plus и более ранних версиях.

Редактирование, а также создание новых уравнений в области для работы с уравнениями невозможно.


Окно Группы компонентов

Служит для работы с группами компонентов сборки, которые должны иметь один и тот же номер позиции в спецификации.

Для управления отображением окна на экране служит кнопка Группы компонентов на панели Спецификация.

В верхней части окна Группы компонентов находится поле со списком для выбора текущей группы.

Под полем располагается инструментальная панель, кнопки которой позволяют создавать и удалять группы, включать компоненты в группы и удалять их из групп.

Остальную часть окна Группы компонентов занимает список компонентов, входящих в текущую группу.

Подробнее об окне и приемах работы в нем...


Окно Нумерация

Служит для работы с группами автонумерации и автосортировки объектов.

Окно Нумерация появляется на экране после вызова команды Вид — Нумерация. Оно содержит раскрывающийся список групп нумерации, список объектов текущей группы и инструментальную панель. Элементы окна доступны, если не запущена ни одна команда.

Группы нумерации бывают системные и пользовательские.

Перечень всех имеющихся в документе системных и пользовательских групп содержится в раскрывающемся списке групп нумерации, расположенном в верхней части окна.

Для работы с объектами нужной группы нумерации выберите ее имя из списка групп. Содержимое группы будет отображено в списке объектов.

Для каждого объекта в списке отображается тип и номер. Номер назначается автоматически при добавлении объекта в группу. Формат записи номера задается при настройке параметров нумерации.

В окне Нумерация могут выполняться следующие действия.

– Добавление в группу объектов, выделенных в документе.

– Исключение объектов из группы.

– Изменение номера объекта, при котором в группах могут создаваться свободные номера.

– Изменение масштаба отображения объектов.

– Сортировка объектов.

– Создание, изменение и удаление пользовательских групп, а также настройка параметров нумерации для каждой группы (системной или пользовательской).
Настройка групп нумерации...
 Настройка группы автосортировки...

Изменения, произведенные в окне Нумерация, передаются в окно документа.


Окно Свойства

Служит для просмотра и изменения свойств объектов, выделенных в модели, графическом документе или эскизе.

Окно Свойства появляется на экране после нажатия одноименной кнопки на Стандартной панели или вызова команды Редактор — Свойства.

Объекты для просмотра и изменения свойств можно выделять как до вызова команды, так и после. Кроме того, во время работы со свойствами можно добавлять объекты к уже выделенным или исключать из числа выделенных любым способом.

Окно Свойства содержит:

– список типов выделенных объектов,

– инструментальную панель,

– таблицу свойств объектов.

В таблице свойств отображаются:

– названия и значения всех свойств выделенных объектов одного типа — если в списке типов выбран конкретный тип объектов,

– названия и значения свойств, общих для всех выделенных объектов — если в списке типов выбран вариант «Все».

Свойства в таблице разбиваются на группы — если на инструментальной панели окна Свойства активизирован переключатель Группировка, или сортируются по алфавиту — если активизирован переключатель Сортировка.

В таблице свойств показываются текущие значения свойств объектов. Если значения какого-либо свойства различны для нескольких объектов одного типа, то значение этого свойства не отображается в таблице.

Чтобы изменить значение свойства, выполните следующие действия:

1. Щелкните в ячейке значения свойства, которое требуется изменить.

• Если значение числовое (например, радиус окружности), то ячейка доступна для редактирования.

• Если значение нечисловое (например, стиль линии), то в правой части ячейки появляется кнопка с черным треугольником. Она позволяет раскрыть список значений.

• Если значение текстовое (например, параметр шероховатости), то на экране появляется диалог ввода текста.

Если значение свойства зависит от настроек параметров объекта, например, состояния опций, использованных при его создании, то изменение свойства недоступно. Чтобы отредактировать такое значение, следует изменить значения связанных с ним свойств.

2. Введите новое числовое значение, или выберите нужное значение свойства из списка, или введите текст в диалоге.

3. Чтобы подтвердить ввод числового значения, нажмите клавишу <Enter> или щелкните мышью вне редактируемой ячейки. Диалог ввода текста закройте кнопкой ОК. Для нечисловых значений подтверждение не требуется.

Особенности работы в документах-моделях

Особенности работы в графических документах

Копирование свойств в графическом документе

После ввода значения объекты (объект) перестраиваются в соответствии с новым значением свойства. При этом объекты остаются выделенными и можно продолжать изменять их свойства.

Примеры...

Смотрите также

Управление состоянием панелей и окон


Диалог задания параметров записи в PDF (модель)

Диалог задания параметров записи в PDF
(модель)

Этот диалог появляется на экране после нажатия кнопки Параметры при экспорте файла в PDF.

В диалоге можно настроить параметры записи модели в PDF.

Описание элементов управления
Элемент | Описание
Формат документа | Группа опций позволяет задать формат листа документа.
Стандартный | Опция позволяет задать размеры листа документа в соответствии с одним из стандартных форматов. При включенной опции Стандартный доступны элементы выбора нужного формата и задания его параметров.
Обозначение | Раскрывающийся список позволяет выбрать нужный формат.
Кратность | Поле позволяет ввести или задать с помощью счетчика кратность размеров листа стандартному формату.
Ориентация | Группа опций позволяет выбрать вариант ориентации листа документа — Горизонтальная или Вертикальная.
Пользовательский | Опция позволяет задать произвольные размеры листу документа. При включенной опции доступны поля задания размеров.
Ширина, мм Высота, мм | Поля позволяют ввести произвольные значения размеров листа документа.
Точность вывода моделей | Элемент позволяет изменять точность вывода изображения модели. Для изменения точности вывода перемещайте «ползунок» между позициями Грубо и Точно.
Цвет | Чтобы записать цветные оттенки оттенками серого цвета, включите опцию Оттенки серого.
Сохранить настройки | Опция, позволяющая сохранить заданные настройки записи в формат PDF для дальнейшего использования.

После завершения настройки нажмите кнопку ОК. Для отказа от настройки нажмите кнопку Отмена.


Диалог установки значения размера

Позволяет отредактировать значения следующих размеров:

– ассоциативные размеры эскиза и размеры операции при выполнении операции или в режиме отображения размеров выбранного элемента;

– размеры, проставленные вручную;

– размеры эскиза и операции, представленные в виде элементов оформления (производные размеры).

Размеры эскизов и операций отображаются на экране, если в диалоге настройки отображения размеров и обозначений включена опция Размеры эскизов и операций.

Диалог появляется на экране после:

– двойного щелчка мышью на размерной надписи размера;

– вызова команды Установить значение размера из контекстного меню производного размера, выделенного в Дереве построения или в окне модели.

В этом диалоге вы можете:

– отредактировать имя переменной, присвоенной размеру (только для размера эскиза и размера, проставленного вручную),

– ввести нужное значение размера: число, константу или выражение для вычисления значения размера;

Для размера эскиза ввод значения возможен, если этот размер управляющий. В противном случае поле ввода значения размера недоступно.

– назначить допуск, используя кнопку Назначить допуск:

• на размер эскиза;

• на значение параметра операции,

• на размер, проставленный вручную;

– ввести комментарий к переменной,

– сделать управляющий размер информационным или наоборот, используя кнопку Информационный размер (только для размера эскиза),

– включить автоматическое перестроение модели после завершения задания значения размера (закрытия диалога), используя кнопку Перестроить.

Завершив редактирование размера, в диалоге нажмите кнопку Создать объект.

– Если в диалоге включено автоматическое перестроение модели, то изображение на экране перестроится в соответствии с новым значением размера.

– Если автоматическое перестроение модели отключено, то изображение на экране остается без изменения. Для перестроения модели нажмите кнопку Перестроить на панели Вид или клавишу <F5>. Изображение на экране перестроится в соответствии с новым значением размера.

Обратите внимание на следующую особенность редактирования значения размера эскиза или операции при выполнении операции. После изменения значения размера в диалоге Установить значение размера фантом создаваемого объекта перестраивается независимо от состояния кнопки Перестроить (см. выше).

Смотрите также

Особенности работы с размерами, значение которых задано вручную


Диалог выбора варианта добавления листов документов

Диалог позволяет выбрать вариант загрузки листов документов в предварительный просмотр.

Появляется на экране после вызова команд Файл — Добавить документы... и Файл — Загрузить задание на печать... в режиме предварительного просмотра.

Описание элементов управления

Наименование

Описание

Добавить к имеющимся листам

Нажмите эту кнопку, чтобы добавить листы загружаемых документов к листам документов, открытых для просмотра. При этом листы загружаемых документов будут расположены после листов документов, открытых для просмотра.

В случае выбора этого варианта при загрузке задания на печать игнорируется сохраненный в задании признак печатаемости страниц устройства вывода, установленный при помощи команды Режим выбора страниц для печати.

Заменить имеющиеся листы

Нажмите эту кнопку, чтобы заменить листы документов, открытых для просмотра, листами загружаемых документов.

Отмена

Нажмите эту кнопку, чтобы отказаться от загрузки листов документов.


Диалог смены режима работы библиотеки

Позволяет изменить режим работы с подключенной прикладной библиотекой.

Описание элементов управления
Наименование | Описание
Меню | Устанавливает режим работы с библиотекой как с разворачивающимся меню.
Диалог | Устанавливает режим работы с библиотекой как с диалогом.
Окно | Устанавливает режим работы с библиотекой как со стандартным окном Windows. В этом случае можно изменять размер окна библиотеки, а также сворачивать (минимизировать) его, оставляя на экране только пиктограмму.
Панель | Устанавливает режим работы с библиотекой как с панелью, содержащей несколько окон. Панель работы с библиотекой располагается на вкладке Менеджера библиотек.

После установки нужного режима нажмите кнопку ОК. Для выхода из диалога без изменения режима работы с библиотекой нажмите кнопку Отмена.


Окно Таблица изменяемых переменных

Позволяет создать или отредактировать таблицу изменяемых переменных для экземпляров массива.

Окно Таблица изменяемых переменных появляется на экране:

– после вызова команды Таблица изменяемых переменных (нажатием одноименной кнопки на Панели специального управления или из контекстного меню) при работе с массивами: по сетке, по концентрической сетке, вдоль кривой, по точкам и по таблице,

– после нажатия кнопки Ввод вручную в группе Источник данных (при этом автоматически запускается команда Таблица изменяемых переменных) при работе с массивом по таблице.

В первом случае таблица изменяемых переменных используется для управления переменными экземпляров массива. Во втором случае таблица используется для задания позиций экземпляров массива по таблице.

Работа с окном при управлении переменными экземпляров массива...
Работа с окном при ручном задании позиций экземпляров массива по таблице...

Окно содержит новую или уже созданную таблицу изменяемых переменных и расположенные над ней кнопки для вызова команд.

Описание элементов управления
Элемент | Описание
Читать из файла1 | Кнопка позволяет импортировать в таблицу изменяемых переменных информацию из файла данных.2 После нажатия кнопки на экране появляется диалог открытия файлов. Выберите необходимый файл и нажмите кнопку Открыть. Данные из выбранного файла будут перенесены в таблицу.
Сохранить в файл1 | Кнопка позволяет сохранить таблицу изменяемых переменных в файл данных2. После нажатия кнопки на экране появляется диалог записи файлов. Задайте местоположение и имя файла (по умолчанию файлу присваивается расширение txt) и нажмите кнопку Сохранить.
Читать переменные | Кнопка позволяет перенести переменные копируемого объекта и их значения в таблицу изменяемых переменных2. Обратите внимание на то, что информационные переменные в таблицу не добавляются.
Вставить переменную | Кнопка позволяет добавить нужную переменную копируемого объекта в таблицу изменяемых переменных2. После нажатия кнопки на экране появляется диалог Переменные со списком переменных копируемого объекта. Укажите нужную переменную и нажмите кнопку ОК. Выбранная переменная будет добавлена в таблицу.
Удалить столбец | Кнопка Удалить столбцы доступна после выделения столбца или ячейки переменной экземпляра2.
Добавить строку выше3 | Группа кнопок позволяет изменять количество строк таблицы. Кнопка Удалить строки доступна после выделения строки или ячейки.
Добавить строку ниже3
Удалить строки3
Значения переменных | Кнопка позволяет перейти к способу заполнения таблицы, позволяющему ввести в ячейку таблицы новое значение (способ 1)2. Подробнее...
Шаг значений | Кнопка позволяет перейти к способу заполнения таблицы, позволяющему задать шаг изменения значений (способ 2)2. Подробнее...
Задать координаты базовой точки 3 | Кнопка позволяет включить или отключить в таблице отображение столбцов с координатами экземпляров. Обратите внимание на то, что если отображение координат в таблице отключено, то в отчете, созданном по этому массиву, нельзя будет отобразить значения координат экземпляров.
Отображать индивидуальные допуски | Кнопка позволяет включить или отключить в таблице отображение индивидуальных допусков. Подробнее...
  1. При работе с массивами по сетке, по концентрической сетке, вдоль кривой и по точкам кнопка не доступна в том случае, если таблица изменяемых переменных пустая (не содержит столбцы с переменными экземпляров). При работе с массивом по таблице кнопка доступна всегда.
  2. Одноименная команда находится в контекстном меню окна Таблица изменяемых переменных.
  3. Кнопка присутствует на инструментальной панели окна Таблица изменяемых переменных при работе с массивом по таблице.


Запрос на перестроение модели

Этот запрос появляется, если система обнаруживает, что связи между компонентами модели нарушены. Обычно такая проверка происходит при открытии или закрытии модели, а также при активизации ее окна.

В окне диалога перечислены компоненты, редактирование которых привело к рассогласованию связей между объектами в модели. Эти же компоненты отмечены красными «галочками» в Дереве построения.

Если вы хотите перестроить модель, нажмите кнопку Да диалога. В результате все объекты перестроятся и/или переместятся так, чтобы их форма, параметры и положение соответствовали положению исходных объектов и не противоречили наложенным на них сопряжениям.

Чтобы отказаться от перестроения модели, нажмите кнопку Нет диалога. В этом случае пересчет компонентов и связей не выполняется, «галочки» в Дереве построения остаются.

Вы можете перестроить модель в любой момент работы с ней. Например, это может потребоваться после изменения положения ее компонентов.

Для перестроения модели нажмите кнопку Перестроить на панели Вид или вызовите команду Вид — Перестроить.


Предупреждение о большом количестве блоков в файле DXF/DWG

Предупреждение о большом количестве блоков
в файле DXF/DWG

Это предупреждение появляется в случае, если импортируемый документ формата DXF или DWG содержит большое количество блоков — составных объектов этого формата.

По умолчанию элементы, составляющие блоки, после импорта автоматически объединяются в макроэлементы системы КОМПАС-3D.

Если количество блоков велико, импортирование документа может занять значительное время. Вы можете отказаться от создания макроэлементов, что ускорит чтение. Для этого нажмите кнопку Да. Все элементы, из которых состоят блоки, будут прочитаны, но макроэлементы из этих элементов созданы не будут.

Если объединение элементов, составляющих блоки, в макроэлементы обязательно, нажмите кнопку Нет.


Дополнительное окно Дерева построения

Дополнительное окно Дерева построения — это специальное окно, в котором отображается копия части Дерева построения модели (объект, раздел или отношения) или копия полного Дерева построения одного из исполнений модели.

Чтобы создать дополнительное окно Дерева построения, выполните следующие действия:

– для объекта или раздела — выделите в Дереве построения нужный объект или раздел и нажмите кнопку Дополнительное окно Дерева на инструментальной панели Дерева построения,

– для отношений объекта — выделите в Дереве построения или в окне модели нужный объект и вызовите из его контекстного меню команду Отношения в дополнительном окне,

– для исполнения модели — выделите в Дереве исполнений нужное исполнение модели и вызовите из его контекстного меню команду Исполнение в дополнительном окне.

Заголовок дополнительного окна Дерева содержит название объекта, раздела, или исполнения, для которого создано это окно.

Работа с дополнительным окном Дерева для объекта или раздела (аналогично выполняется работа с дополнительным окном Дерева для исполнения)

Отображение отношений объектов в основном и дополнительном окнах Дерева

Смотрите также

Управление состоянием дополнительного окна Дерева построения


Диалог Разбиение ячеек

Появляется на экране после нажатия кнопки Разбить ячейки или вызова команды Таблица — Разбить ячейки....

Элементы управления диалога позволяют задать параметры разбиения исходной ячейки или блока выделенных ячеек.

Описание элементов управления
Элемент | Описание
Число столбцов | Поле позволяет ввести или задать при помощи счетчика количество столбцов, на которые будет разбита ячейка.
Число строк | Поле позволяет ввести или задать при помощи счетчика количество строк, на которые будет разбита ячейка.
Объединить ячейки перед разбиением | Опция позволяет управлять состоянием выделенных ячеек перед их разбиением.

Чтобы завершить задание параметров, следует нажать кнопку ОК. Кнопка Отмена позволяет закрыть диалог, отказавшись от изменений.


Диалог смены драйвера устройства печати

Этот диалог отображается на экране в том случае, когда при работе в КОМПАС-3D пользователь переключился в другое приложение Windows и удалил драйвер текущего принтера (принтера по умолчанию) либо изменил его имя, а затем вернулся в КОМПАС-3D.

Для выбора другого драйвера устройства печати из списка подключенных к Windows устройств нажмите кнопку Изменить.

Чтобы удалить старые настройки печати КОМПАС-3D, нажмите кнопку Удалить. Если вы работали в режиме предварительного просмотра, будет выполнено его автоматическое закрытие и возврат в режим графического редактора. В последующем при переходе к режиму предварительного просмотра будет использоваться драйвер принтера, установленного как принтер по умолчанию.


Диалог Вставка математического выражения

Этот диалог появляется на экране в следующих случаях:

– после нажатия кнопки Вставить функцию или Вставить константу на инструментальной панели Окна переменных,

– после вызова команды Вставка — Константа или Вставка — Функция из меню этого Окна,

– после нажатия кнопки Вставить функцию на Панели специального управления при построении кривой по закону.

Позволяет использовать элементы выражения из предопределенного списка для присвоения значения переменной или задания функции для координаты точки кривой по закону.

Описание элементов управления

Элемент

Описание

Список групп элементов выражения

Список содержит группы элементов выражения в виде дерева. Содержимое выбранной группы отображается в Таблице элементов выражения.

Таблица элементов выражения

Таблица содержит список доступных для вставки элементов выражения той группы, которая выбрана в списке групп диалога.

Выбранный в таблице элемент отображается в поле Составление выражения.

Вы можете вставить элемент в Окно переменных или в поле задания координаты точки кривой по закону, дважды щелкнув мышью в соответствующей нужному элементу строке таблицы. При этом диалог автоматически закроется. Такой способ вставки удобно использовать, если дополнительное редактирование выбранного элемента не требуется.

Таблица переменных выражения

Таблица присутствует в диалоге, если в Списке групп элементов выражения раскрыта группа, содержащая выражения. При выборе выражения в таблице переменных отображаются переменные, входящие в это выражение.

Колонка Подстановка имени позволяет присваивать переменным произвольные имена. Данные имена используются для обозначения переменных в поле Составление выражения.

Составление выражения

Поле служит для отображения элемента выражения в том виде, в каком он будет передан в Окно переменных или в поле задания координаты точки кривой по закону. Заполняется автоматически при выборе элемента в Таблице элементов выражения.

Чтобы отредактировать содержимое поля, включите соответствующую ему опцию.

При редактировании вы можете вводить символы с клавиатуры, вставлять их с помощью буфера обмена, добавлять выражения и их элементы из таблицы элементов текущего диалога, вставлять переменные, содержащиеся в документе (для вставки переменных используется команда Выбрать переменную контекстного меню, вызывающая диалог Переменные).

Выражение, содержащееся в поле, можно сохранить в файл коллекции математических выражений collection.law, вызвав команду Сохранить выражение контекстного меню.

Все выражения, сохраненные в файл коллекции, добавляются в группу Из файла коллекции диалога Вставка математического выражения. Раскрыв эту группу, вы можете вставить нужное выражение в Окно переменных или в поле задания координаты точки кривой по закону.

Чтобы вставить результирующее выражение в Окно переменных, нажмите кнопку ОК. Кнопка Отмена позволяет отказаться от вставки.

Смотрите также

Вставка элементов выражения


Диалог выбора стилей объектов

Этот диалог появляется на экране после вызова команд выделения или исключения объектов по стилю кривой.

Окно просмотра содержит перечень стилей кривых, использующихся в активном документе.

Выделите нужные строки списка.

Чтобы выделить несколько строк, нажмите клавишу <Ctrl> и, удерживая ее, указывайте нужные строки.

Чтобы выделить несколько строк, расположенных подряд друг за другом, выделите первую (последнюю) из этих строк, нажмите и удерживайте клавишу <Shift>, затем выделите последнюю (первую) строку.

Завершив выбор стилей, нажмите кнопку ОК диалога. Чтобы отказаться от выделения или исключения объектов, нажмите кнопку Отмена.


Диалог выбора объектов

Этот диалог появляется на экране после вызова команд выделения или исключения вида, слоя, группы или по типу.

В соответствии с вызванной командой окно просмотра содержит перечень имеющихся в активном документе видов, слоев, групп или типов объектов.

Выделите нужные строки списка.

Чтобы выделить несколько строк, нажмите клавишу <Ctrl> и, удерживая ее, указывайте нужные строки.

Чтобы выделить несколько строк, расположенных подряд друг за другом, выделите первую (последнюю) из этих строк, нажмите и удерживайте клавишу <Shift>, затем выделите последнюю (первую) строку.

Завершив выбор, нажмите кнопку ОК диалога. Чтобы отказаться от выделения или исключения объектов, нажмите кнопку Отмена.


Диалог выбора слоя для переноса объекта

Диалог появляется после вызова команды Изменить слой... из меню Сервис или из контекстного меню выделенных объектов.

В этом диалоге вы можете указать, на какой слой следует перенести эти объекты.

В списке отображаются номера и названия всех слоев фрагмента или вида, которому принадлежат выделенные объекты (этот вид необязательно должен быть текущим в настоящий момент).

Выделите нужный слой в списке и нажмите кнопку ОК. Чтобы отказаться от переноса объектов, нажмите кнопку Отмена.

При переносе объектов на фоновый слой с них снимается выделение. Для отображения этих объектов используется стиль, заданный для отрисовки фоновых слоев.

Объекты, перенесенные на погашенный слой, перестают отображаться на экране.


Диалог удаления объектов

Этот диалог появляется на экране при удалении различных объектов (стиля из библиотеки стилей и т.п.).

Диалог содержит название удаляемого объекта и кнопки для управления процессом удаления.

Описание элементов управления
Наименование | Описание
Удалить | Удаление объекта, название которого отображается в диалоге. После нажатия этой кнопки происходит переход к следующему объекту (если для удаления было выбрано несколько объектов).
Удалить все | Удаление всех выделенных объектов.
Пропустить | Отмена удаления объекта, название которого отображается в диалоге. После нажатия этой кнопки происходит переход к следующему объекту.
Отмена | Прерывание операции удаления.


Диалог Создать компоновочную геометрию

Позволяет задать имя и тип компоновочной геометрии, создаваемой непосредственно в текущей модели.

Диалог появляется на экране после вызова команды Создать компоновочную геометрию.

Чтобы задать тип компоновочной геометрии, выберите один из следующих вариантов:

– Деталь,

– Сборка,

– Локальная деталь.

Имя компоновочной геометрии вводится в поле Имя компонента.

Для продолжения создания компоновочной геометрии нажмите кнопку ОК. Кнопка Отмена позволяет отказаться от создания.


Диалог создания новых документов

Этот диалог появляется на экране после вызова команды Файл — Создать.

В нем можно указать тип создаваемого документа или выбрать шаблон для нового документа.

Для выбора шаблона перейдите на вкладку Шаблоны. В правом окне просмотра отображается структура папки \Templates, в котором хранятся шаблоны. Содержимое выделенной подпапки показывается в левом окне просмотра.

Инструментальная панель вкладки Шаблоны содержит кнопки, управляющие расположением элементов левого окна, а также кнопку Просмотр для включения и отключения просмотра шаблона, выделенного в левом окне. Если просмотр включен, то выбранный шаблон отображается в уменьшенном виде в правой нижней части вкладки.

Если использование шаблона не требуется, выберите тип документа на вкладке Новые документы.

Нажмите кнопку ОК для создания документа заданного типа или по заданному шаблону.


Диалог настройки профилей пользователя

Этот диалог появляется на экране после вызова команды Сервис — Профили....

Диалог предназначен для работы с профилями.

Описание элементов управления

Элемент

Описание

Профили:

Список имен файлов *.pfl. Чтобы выбрать профиль, разверните список и укажите нужное имя. Если оно отсутствует в списке, выберите строку Другие... и укажите нужный файл *.pfl в появившемся диалоге.

Полное имя выбранного файла появится в нижней части вкладки.

Использовать

Опции, позволяющие выбрать группу настроек, которая будет взята из применяемого профиля или записана в сохраняемый профиль:

– Настройки рабочего окна — информация о расположении, составе и размере панелей и окон, структуре Менеджера библиотек и состоянии библиотек (подключена/отключена).

– Настройки параметров системы — настройки, произведенные на вкладке Система общего диалога настройки параметров.

– Настройки параметров новых документов — настройки, произведенные на вкладке Новые документы общего диалога настройки параметров.

Если ни одна из опций не включена, то применение или сохранение профиля невозможно.

Опция Настройки рабочего окна недоступна, если выбран профиль, созданный в отличной от установленной на данном рабочем месте версии системы.

Сохранить как...

Чтобы сохранить информацию о текущей настройке системы, нажмите эту кнопку. На экране появится диалог, в котором нужно ввести имя файла *.pfl и указать папку для его размещения.

В файл профиля не записываются имена последних открывавшихся документов, а также состояние окон открытых документов.

Удалить

Чтобы удалить профиль, выбранный в списке, нажмите эту кнопку. Указанный профиль будет удален из списка, а соответствующий файл *.pfl — с диска.

Применить

Чтобы применить настройки, записанные в выбранном профиле, нажмите эту кнопку. Диалог работы с профилями при этом остается открытым. Если необходимо, вы можете выбрать и применить другой профиль.

Выход

Чтобы закрыть диалог, нажмите эту кнопку.

В комплект поставки КОМПАС-3D входят несколько готовых файлов профилей. Они расположены в подпапке Profiles главной папки системы.

При использовании готовых файлов профилей следует иметь в виду, что в них нет сведений о библиотеках. Поэтому после применения любого такого профиля текущее содержимое Менеджера библиотек будет удалено, и Менеджер автоматически наполнится в соответствии с файлами *.lms, имеющимися в подпапке Sys главной папки системы.


Диалог настройки удаления истории построения

Этот диалог появляется на экране после вызова команды Редактор — Удалить историю построения.

Диалог позволяет задать параметры преобразования модели при удалении истории построения.

Описание элементов управления

Элемент

Описание

Общие настройки

Группа опций для задания общих параметров преобразования.

Сохранять массу

Включите эту опцию, чтобы преобразованная модель имела ту же массу, что исходная. При отключенной опции масса преобразованной модели рассчитывается заново.

Сохранять центр масс

Включите эту опцию, чтобы центр масс преобразованной модели находился в той же точке, что и центр масс исходной модели. При отключенной опции координаты центра масс преобразованной модели вычисляются заново.

Учитывать скрытые компоненты

Если опция включена, то преобразуются как видимые, так и скрытые компоненты. В результате преобразования в тела они становятся видимыми, а в детали-заготовки — остаются скрытыми. При отключенной опции скрытые компоненты считаются отсутствующими. Исключенные из расчета компоненты всегда считаются отсутствующими.

Преобразования

Группа элементов для выбора нужного способа изменения структуры модели и настройки параметров в рамках выбранного способа. Если требуется сохранить модель без изменений, выберите вариант Специальное преобразование и отключите опции Удалить историю построения и Преобразовать компоненты (см. ниже).

Объединить тела и компоненты в одно тело

Выберите этот вариант, чтобы все тела и компоненты модели были объединены в одно тело.

Полученному телу назначается материал исходной сборки. Тело является сплошным, без внутренних полостей (эти полости заполняются материалом).

Если компоненты сборки не имеют ни одной общей поверхности, то в результате объединения получается тело из частей.

Специальное преобразование

Выберите этот вариант, чтобы настроить параметры преобразования структуры модели.

Удалить историю построения

Включите эту опцию для удаления из файла модели информации о способах создания объектов модели и связях между ними. В результате удаления истории построения:

– тела/поверхности/кривые превращаются в операции/поверхности/кривые без истории;

– массив превращается в набор объектов, расположенных согласно параметрам массива;

– локальные системы координат, контрольные и присоединительные точки заменяются обычными точками,

– эскизы, вспомогательные оси и плоскости, элементы оформления и сопряжения удаляются;

– компоненты фиксируются;

– если компонент был изменен операцией в содержащей его модели, то его тела и поверхности в отредактированном виде переносятся в модель, а сам компонент из нее удаляется.

Обратите внимание на то, что данная опция удаляет историю построения только тех объектов, которые принадлежат непосредственно преобразуемой модели, т.е. история построения компонентов сохраняется.

Преобразовать компоненты

Включите эту опцию, чтобы выполнить преобразование компонентов. При отключенной опции компоненты остаются без изменений.

Если удаление истории построения включено, то компоненты, затронутые операцией в содержащей их модели, преобразуются согласно вышеописанному вне зависимости от состояния опции Преобразовать компоненты.

В тела

Выбор этого варианта означает, что тела и поверхности компонентов всех уровней преобразуются в тела и поверхности без истории. Имена тел и поверхностей совпадают с именами соответствующих компонентов. Другие объекты компонентов в результирующую модель не передаются.

Если модель содержит операции над компонентами (например, массив компонентов), то после преобразования компонентов в тела эти операции удаляются, т.к. теряют источник построения. Удаление выполняется независимо от состояния опции Удалить историю построения.

В детали-заготовки

Выбор этого варианта означает, что компоненты первого уровня преобразуются в детали-заготовки. Если требуется, чтобы заготовки были внедрены в модель (а не вставлены ссылкой на внешние файлы), включите опцию Без истории.

Обратите внимание на то, что компоненты остальных уровней остаются без изменений, т.е. не преобразуются в заготовки и остаются вставленными ссылкой.

Стандартные изделия и библиотечные компоненты не преобразуются в детали-заготовки.

Исключенные из расчета компоненты не учитываются в процессе преобразования. Они считаются отсутствующими.

После завершения настройки параметров нажмите кнопку ОК. Для выхода из диалога без преобразования модели нажмите кнопку Отмена.


Диалог выбора варианта удаления массива

Этот диалог появляется на экране при попытке удаления экземпляра массива.

В нем можно указать вариант удаления массива.

Описание элементов управления
Элемент | Описание
 | В справочном поле диалога показано название удаляемого массива.
Всю операцию | Включите эту опцию, если требуется удалить все экземпляры указанного массива (т.е. саму операцию).
Экземпляры | Включите эту опцию, если требуется удалить отдельные экземпляры массива.

После выбора опции Экземпляры в окне диалога активизируется список номеров удаляемых экземпляров.

– Если сетка параллелограммная, номер экземпляра массива состоит из двух чисел: первое — номер экземпляра вдоль первой оси сетки, второе — номер экземпляра вдоль второй оси (нумерация экземпляров массива начинается с единицы).

– Если сетка концентрическая, номер экземпляра массива состоит из двух чисел: первое — номер экземпляра в радиальном направлении, второе — номер экземпляра в кольцевом направлении (нумерация экземпляров массива начинается с единицы).

– Если копии расположены вдоль кривой, номер экземпляра массива отсчитывается по порядку расположения экземпляров, начиная от исходного.

– Если копии расположены по точкам, номер экземпляра равен номеру точки, задающей его позицию. Точки нумеруются в порядке их указания.

– Если копии расположены по координатам из файла, номер экземпляра равен порядковому номеру строки файла.

После выбора варианта удаления нажмите кнопку OK.

Для выхода из диалога без удаления экземпляров нажмите кнопку Отмена.

Смотрите также

Удаление и восстановление отдельных экземпляров


Диалог настройки параметров слоя AutoCAD для объекта КОМПАС

Позволяет задать имя и цвет слоя AutoCAD, на котором будет расположен объект КОМПАС.

Описание элементов управления
Наименование | Описание
Категория | В этом справочном поле отображается название категории объекта КОМПАС, для которого производится настройка слоя AutoCAD.
Располагать объект на слое-источнике | Включите эту опцию, чтобы для размещения объектов выбранного типа были созданы слои, аналогичные слоям КОМПАС. При этом поля для ввода имени слоя и выбора его цвета становятся недоступными.
Имя слоя | Введите имя слоя AutoCAD, на котором будет располагаться выбранный объект КОМПАС.
Цвет слоя | В этом поле отображается цвет слоя AutoCAD. Чтобы сменить цвет, щелкните в поле мышью и выберите нужный цвет в появившемся диалоге.

Включение опции Располагать на слое-источнике для таких объектов, как неуказанная шероховатость, тех. требования и оформление, означает, что эти объекты будут размещены на системном слое документа AutoCAD (он имеет имя «0»).

Завершив настройку, нажмите кнопку ОК. Чтобы закрыть диалог без изменения параметров слоя AutoCAD для объекта КОМПАС, нажмите кнопку Отмена.


Диалог настройки соответствия стилей линий

Диалог настройки
соответствия стилей линий

Появляется на экране после нажатия кнопки Добавить или Изменить в Диалогах задания параметров чтения DXF и DWG (одного документа или группы).

Позволяет установить соответствие между типами линий AutoCAD и стилями линий КОМПАС для замены линий системы AutoCAD линиями КОМПАС при импорте файлов форматов DWG и DXF.

Описание элементов управления

Элемент

Описание

Параметры линии AutoCAD

В этой группе опций вы можете задать параметры линии в AutoCAD.

Цвет

Установите в этом поле номер цвета линии в AutoCAD. Цвет, имеющий указанный номер, показывается в окне просмотра. Для указания цвета линии можно использовать диалог выбора цвета. Для его вызова щелкните левой кнопкой мыши в окне просмотра цвета.

Тип

Введите в это поле название типа линии в AutoCAD.

Толщина

Если эта опция выключена, то все имеющиеся в импортируемом документе AutoCAD линии указанного цвета и типа вне зависимости от их толщины будут заменены линиями КОМПАС выбранного стиля.

Включите опцию Толщина, если при замене линий AutoCAD должна учитываться их толщина, и введите значение толщины линии в миллиметрах.

В этом случае линиями КОМПАС выбранного стиля будут заменены только те линии AutoCAD указанного цвета и типа, которые имеют заданную толщину. При этом для линий с теми же цветом и типом, но с другой толщиной (если таковые имеются в импортируемом документе) будут созданы соответствующие пользовательские стили линий.

Стиль линии КОМПАС

Выберите из этого списка системный стиль для линий, которыми будут заменены линии документа AutoCAD, имеющие указанные параметры.

Кнопка >>

Нажмите эту кнопку, чтобы выбрать библиотечный стиль для линий, которыми будут заменены линии документа AutoCAD, имеющие указанные параметры.

После нажатия кнопки на экране появится диалог выбора стиля линии. Включенные в список стилей документа библиотечные стили отображаются на вкладке Библиотечные диалога. Если среди них нет нужного стиля, нажмите в диалоге выбора стиля кнопку Менеджер стилей. В появившемся Менеджере стилей линий подключите нужную библиотеку стилей, добавьте стиль из нее в список документа и закройте Менеджер стилей линий кнопкой ОК.

Укажите в диалоге выбора стиля добавленный библиотечный стиль и нажмите кнопку Выбрать. Диалог выбора стиля линии закроется, а в поле Стиль линии КОМПАС диалога настройки соответствия стилей появится выбранный библиотечный стиль.

ОК

После завершения настройки соответствия типа и стиля линии нажмите кнопку.

Отмена

Для выхода из диалога без изменения соответствия нажмите кнопку.


Диалог параметров чтения файлов форматов DXF/DWG в графический документ

Диалог появляется на экране при импорте файлов формата DXF/DWG в графический документ КОМПАС-3D.

Позволяет задать различные параметры импорта.

Описание элементов управления

Элемент

Описание

Вкладка Файлы

Исходный файл

В этом поле отображается имя импортируемого файла.

Читать в файл

Выберите эту группу элементов, чтобы объекты импортируемого файла были записаны в новый файл фрагмента КОМПАС.

Имя файла

По умолчанию предлагается имя файла для записи, образованное из имени исходного файла с добавлением расширения FRW.

Выбрать файл

Для выбора уже существующего файла используйте эту кнопку.

Отображать на экране

Включите эту опцию, чтобы импортируемые объекты отображались на экране во время чтения.

Читать в текущий вид

Выберите эту группу элементов, чтобы объекты импортируемого фрагмента были прочитаны в текущий вид чертежа (или в текущий фрагмент).

На слои-источники

Импортируемые объекты будут помещены на свои слои. При необходимости нужные слои создаются автоматически.

На текущий слой

Все импортируемые объекты будут помещены на текущий слой.

Отображать отчет о результатах чтения

Включите эту опцию, чтобы просмотреть перечень объектов, которые не могут быть импортированы, и причины невозможности импорта. Эти сведения отображаются в Информационном окне.

Вкладка Данные

Читать данные из пространства модели

Выберите этот вариант, если в результирующий документ требуется передать только графическое изображение, существующее в пространстве модели AutoCAD.

Читать данные из пространства листа

Выберите этот вариант, если в документ КОМПАС требуется передать объекты из пространства листа. При выборе данного варианта импорта доступен список компоновок (layout), в котором можно указать, какие именно компоновки следует импортировать.

Список компоновок (layout)

Список позволяет выбрать компоновки для импорта. Включите опции, соответствующие компоновкам, которые должны импортироваться.

Список доступен, если выбран вариант импорта Читать данные из пространства листа.

Все листы

Опция позволяет включить/отключить доступность всех компоновок, содержащихся в списке.

Границы видовых экранов по габаритам

Включите эту опцию для ускорения чтения за счет упрощения формы видовых экранов импортируемого документа до их габаритных прямоугольников. Если видовые экраны не прямоугольны, в КОМПАС-документе могут оказаться «лишние» объекты, не отображавшиеся в исходном документе из-за того, что находились за пределами видовых экранов.

При отключенной опции форма видовых экранов не упрощается и, соответственно, «лишние» объекты не возникают, но обработка документа может занимать большее время.

Вкладка Свойства

Масштаб

Выберите из списка или введите значение коэффициента масштабирования графических объектов. Эта настройка обычно требуется для преодоления ограничения КОМПАС-3D на максимальную длину объектов при импорте изображений крупных объектов, выполненных в натуральную величину.

Единицы измерения

Выберите нужные единицы измерения для импортируемых объектов (миллиметры или дюймы).

Приводить тексты к системным

Включите эту опцию, чтобы тексты из импортируемого файла были записаны с параметрами, установленными в документе КОМПАС по умолчанию для соответствующих надписей (текст на чертеже, текст над/под полкой линии выноски и т.д.). Если тексты приведены к системным, то их параметры (стиль, высоту символов, шаг строк и т.п.) можно будет изменить в диалоге настройки текущего документа КОМПАС.

При выключенной опции для каждого стиля текста, имеющегося в файле DXF/DWG, в документе КОМПАС создается специальный пользовательский стиль текста. Чтобы изменить параметры текстов, которые не были приведены к системным, потребуется изменить соответствующий пользовательский стиль.

Конвертировать текст из OEM в ANSI

Включите эту опцию, если при импорте необходимо выполнить перекодирование текстов из DOS-кодировки в Windows-кодировку. Конвертация обычно требуется, если исходный документ создан в версии AutoCAD для DOS.

При включенной опции Конвертировать текст из OEM в ANSI производится перекодирование всех текстов. Если требуется перекодирование только определенных шрифтов (или отдельных символов), выключите опцию Конвертировать текст из OEM в ANSI и настройте преобразование символов в файлах *.tfn. Подробнее...

Сужение текста

Эта опция позволяет задавать отношение ширины получившихся при импорте текстов к их ширине в исходном документе с целью подгонки ширины надписей к конкретным габаритам. Например, если при импорте документа, содержащего таблицу, тексты «вылезли» за пределы отведенных для них ячеек, произведите импорт вновь, увеличив значение коэффициента сужения.

Коэффициент высоты текстов

Эта опция позволяет задавать отношение высоты получившихся при импорте текстов к их высоте в исходном документе с целью подгонки высоты надписей к конкретным габаритам.

Таблица соответствия объектов

Эта таблица позволяет настроить чтение линий-выносок, штриховок, размеров, блоков и некоторых других объектов, записанных в файле DXF/DWG.

В колонке AutoCAD перечислены объекты, чтение которых можно настроить, в колонке КОМПАС — варианты объектов, которые можно получить в результате чтения, а в колонке Параметры — варианты чтения стрелок размеров и линий-выносок: Преобразовывать пользовательские стрелки в макроэлементы или Приводить пользовательские стрелки к системным.

Чтобы выбрать вариант объектов (или вариант чтения стрелок размеров и линий-выносок), щелкните в ячейке колонки КОМПАС (или Параметры), разверните список и укажите нужную строку.

Зависимость результата чтения от выбранного варианта описана в следующих разделах:

Чтение линий-выносок, штриховок, допусков формы, мультилиний и размеров

Чтение блоков

Чтение растровых объектов

Вкладка Символы

Вы можете интерактивно редактировать соответствие между спецсимволами КОМПАС и последовательностями символов ASCII, которыми они обозначаются в текстовом файле DXF. По умолчанию загружается последовательность символов, которая соответствует поставляемому в составе дистрибутива КОМПАС-3D файлу B_ESKD.SHX.

Выбрать файл

Для подключения ранее сохраненного файла соответствия символов (системный файл КОМПАС с расширением ACS) нажмите эту кнопку.

Записать в файл

Для сохранения сделанной настройки соответствия символов в файле нажмите эту кнопку.

Символы по умолчанию

Для загрузки настройки соответствия символов по умолчанию нажмите эту кнопку.

Вкладка Типы линий

По умолчанию при импорте файлов DXF в документе КОМПАС создаются пользовательские стили линий, имеющие такие же названия и начертания, как и типы линий системы AutoCAD.

Установить соответствие типов линий

Чтобы при импорте происходила замена линий системы AutoCAD системными или библиотечными линиями КОМПАС, необходимо задать соответствия между типами линий в AutoCAD и стилями линий в КОМПАС-3D. Для этого включите данную опцию. После включения опции становятся доступными остальные опции и кнопки вкладки.

В окне просмотра отображаются уже имеющиеся соответствия между типами и стилями линий: в колонке AutoCAD отображаются цвет, название типа линии и ее толщина в AutoCAD, а в колонке КОМПАС — название системного стиля линии в КОМПАС.

Добавить

Чтобы добавить соответствие, нажмите эту кнопку. В появившемся на экране диалоге настройки соответствия введите название типа линии AutoCAD, ее цвет и толщину, введите и установите стиль линии КОМПАС. Закройте диалог, нажав кнопку ОК. В конец списка будет добавлено установленное вами соответствие.

Изменить

Чтобы отредактировать соответствие, выберите его в окне просмотра и нажмите эту кнопку.

Отредактируйте соответствие в появившемся на экране диалоге и нажмите кнопку ОК. Внесенное вами изменение отобразится в списке соответствий.

Удалить

Чтобы удалить соответствие, выберите его в окне просмотра и нажмите эту кнопку.

Прочитать из чертежа AutoCAD

Эта кнопка позволяет отобразить в окне просмотра названия типов линий, используемых в выбранном для чтения чертеже AutoCAD, цвета и толщины этих линий.

Для установки стилей линий КОМПАС, которые должны соответствовать обнаруженным типам линий, используйте кнопку Изменить.

В строках, соответствующих типам линий, которые используются в объектах с толщиной линий «default», значение толщины отсутствует.

Записать в файл

Для сохранения сделанной настройки соответствий в файле нажмите эту кнопку. В появившемся диалоге укажите имя файла для записи. Система сформирует текстовый файл соответствия типов и стилей линий (*.ALS).

Выбрать файл

Для подключения созданного или ранее сохраненного файла соответствия типов и стилей линий нажмите эту кнопку1.

По умолчанию

Для загрузки настройки соответствия типов и стилей линий по умолчанию нажмите эту кнопку.

Вкладка Полилиния

Данная вкладка позволяет настроить импорт полилиний, для сегментов которых заданы индивидуальные толщины линий. Если установлена постоянная толщина линии, то сегмент имеет форму прямоугольника, если переменная — то трапеции.

Вы можете указать, в какие объекты системы КОМПАС-3D нужно преобразовать эти сегменты.

в линию

Сегменты, образующие полилинию, объединяются в контур.

в заливку

Сегмент преобразуется в заливку. Форма контура заливки соответствует форме сегмента в файле формата DXF/DWG. Цвет заливки также соответствует заданному в этом файле.

Контур, ограничивающий заливку, не строится.

в штриховку

Сегмент преобразуется в штриховку. Форма контура и цвет штриховки соответствуют форме и цвету сегмента в файле формата DXF/DWG.

При выборе данного варианта становится доступным раскрывающийся список Шаг штриховки. Вы можете выбрать или ввести с клавиатуры нужное значение шага.

Контур, ограничивающий штриховку, не строится.
  1. Вы можете создать файл соответствия типов и стилей линий в текстовом режиме и подключать его при импорте файлов DXF.

После завершения настройки параметров нажмите кнопку Начать чтение. Для выхода из диалога без чтения файла нажмите кнопку Отмена.

Замечание...

Смотрите также

Особенности чтения размеров и линий-выносок

Преобразование текстов


Диалог параметров чтения группы файлов форматов DXF/DWG в графические документы КОМПАС-3D

Диалог появляется на экране при пакетном (групповом) импорте файлов формата DXF или DWG в графические документы КОМПАС-3D.

Позволяет задать параметры импорта.

Описание элементов управления

Элемент

Описание

Вкладка Данные

Читать данные из пространства модели

Выберите этот вариант, если в результирующий документ требуется передать только графическое изображение, существующее в пространстве модели AutoCAD.

Читать данные из пространства листа

Выберите этот вариант, если в документ КОМПАС требуется передать объекты из пространства листа.

Границы видовых экранов по габаритам

Включите эту опцию для ускорения чтения за счет упрощения формы видовых экранов импортируемого документа до их габаритных прямоугольников. Если видовые экраны не прямоугольны, в КОМПАС-документе могут оказаться «лишние» объекты, не отображавшиеся в исходном документе из-за того, что находились за пределами видовых экранов.

При отключенной опции форма видовых экранов не упрощается и, соответственно, «лишние» объекты не возникают, но обработка документа может занимать большее время.

Вкладка Свойства

Масштаб

Выберите из списка или введите значение коэффициента масштабирования графических объектов. Эта настройка обычно требуется для преодоления ограничения КОМПАС-3D на максимальную длину объектов при импорте изображений крупных объектов, выполненных в натуральную величину.

Единицы измерения

Выберите нужные единицы измерения для импортируемых объектов (миллиметры или дюймы).

Читать данные из пространства модели

Включите эту опцию, если в результирующий документ требуется передать только графическое изображение, существующее в пространстве модели AutoCAD.

Если данная опция выключена, то в документ КОМПАС передаются объекты из пространства листа.

Приводить тексты к системным

Включите эту опцию, чтобы тексты из импортируемого файла были записаны с параметрами, установленными в документе КОМПАС по умолчанию для соответствующих надписей (текст на чертеже, текст над/под полкой линии выноски и т.д.). Если тексты приведены к системным, то их параметры (стиль, высоту символов, шаг строк и т.п.) можно будет изменить в диалоге настройки текущего документа КОМПАС.

При выключенной опции для каждого стиля текста, имеющегося в файле DXF/DWG, в документе КОМПАС создается специальный пользовательский стиль текста. Чтобы изменить параметры текстов, которые не были приведены к системным, потребуется изменить соответствующий пользовательский стиль.

Конвертировать текст из OEM в ANSI

Включите эту опцию, если при импорте необходимо выполнить перекодирование текстов из DOS-кодировки в Windows-кодировку. Конвертация обычно требуется, если исходный документ создан в версии AutoCAD для DOS.

При включенной опции Конвертировать текст из OEM в ANSI производится перекодирование всех текстов. Если требуется перекодирование только определенных шрифтов (или отдельных символов), выключите опцию Конвертировать текст из OEM в ANSI и настройте преобразование символов в файлах *.tfn. Подробнее...

Сужение текста

Эта опция позволяет задавать отношение ширины получившихся при импорте текстов к их ширине в исходном документе с целью подгонки ширины надписей к конкретным габаритам. Например, если при импорте документа, содержащего таблицу, тексты «вылезли» за пределы отведенных для них ячеек, произведите импорт вновь, увеличив значение коэффициента сужения.

Коэффициент высоты текстов

Эта опция позволяет задавать отношение высоты получившихся при импорте текстов к их высоте в исходном документе с целью подгонки высоты надписей к конкретным габаритам.

Таблица соответствия объектов

Эта таблица позволяет настроить чтение линий-выносок, штриховок, размеров, блоков и некоторых других объектов, записанных в файле DXF/DWG.

В колонке AutoCAD перечислены объекты, чтение которых можно настроить, в колонке КОМПАС — варианты объектов, которые можно получить в результате чтения, а в колонке Параметры — варианты чтения стрелок размеров и линий-выносок: Преобразовывать пользовательские стрелки в макроэлементы или Приводить пользовательские стрелки к системным.

Чтобы выбрать вариант объектов (или вариант чтения стрелок размеров и линий-выносок), щелкните в ячейке колонки КОМПАС (или Параметры), разверните список и укажите нужную строку.

Зависимость результата чтения от выбранного варианта описана в следующих разделах:

Чтение линий-выносок, штриховок, допусков формы, мультилиний и размеров

Чтение блоков

Чтение растровых объектов

Вкладка Символы

Вы можете интерактивно редактировать соответствие между спецсимволами КОМПАС и последовательностями символов ASCII, которыми они обозначаются в текстовом файле DXF. По умолчанию загружается последовательность символов, которая соответствует поставляемому в составе дистрибутива КОМПАС-3D файлу B_ESKD.SHX.

Выбрать файл

Для подключения ранее сохраненного файла соответствия символов (системный файл КОМПАС с расширением ACS) нажмите эту кнопку.

Записать в файл

Для сохранения сделанной настройки соответствия символов в файле нажмите эту кнопку.

Символы по умолчанию

Для загрузки настройки соответствия символов по умолчанию нажмите эту кнопку.

Вкладка Типы линий

По умолчанию при импорте файлов DXF в документе КОМПАС создаются пользовательские стили линий, имеющие такие же названия и начертания, как и типы линий системы AutoCAD.

Установить соответствие типов линий

Чтобы при импорте происходила замена линий системы AutoCAD системными или библиотечными линиями КОМПАС, необходимо задать соответствия между типами линий в AutoCAD и стилями линий в КОМПАС-3D. Для этого включите данную опцию. После включения опции становятся доступными остальные опции и кнопки вкладки.

В окне просмотра отображаются уже имеющиеся соответствия между типами и стилями линий: в колонке AutoCAD отображаются цвет, название типа линии и ее толщина в AutoCAD, а в колонке КОМПАС — название системного стиля линии в КОМПАС.

Добавить

Чтобы добавить соответствие, нажмите эту кнопку. В появившемся на экране диалоге настройки соответствия введите название типа линии AutoCAD, ее цвет и толщину, введите и установите стиль линии КОМПАС. Закройте диалог, нажав кнопку ОК. В конец списка будет добавлено установленное вами соответствие.

Изменить

Чтобы отредактировать соответствие, выберите его в окне просмотра и нажмите эту кнопку.

Отредактируйте соответствие в появившемся на экране диалоге и нажмите кнопку ОК. Внесенное вами изменение отобразится в списке соответствий.

Удалить

Чтобы удалить соответствие, выберите его в окне просмотра и нажмите эту кнопку.

Прочитать из чертежа AutoCAD

Эта кнопка позволяет отобразить в окне просмотра названия типов линий, используемых в выбранном для чтения чертеже AutoCAD, цвета и толщины этих линий.

Для установки стилей линий КОМПАС, которые должны соответствовать обнаруженным типам линий, используйте кнопку Изменить.

В строках, соответствующих типам линий, которые используются в объектах с толщиной линий «default», значение толщины отсутствует.

Записать в файл

Для сохранения сделанной настройки соответствий в файле нажмите эту кнопку. В появившемся диалоге укажите имя файла для записи. Система сформирует текстовый файл соответствия типов и стилей линий (*.ALS).

Выбрать файл

Для подключения созданного или ранее сохраненного файла соответствия типов и стилей линий нажмите эту кнопку1.

По умолчанию

Для загрузки настройки соответствия типов и стилей линий по умолчанию нажмите эту кнопку.

Вкладка Полилиния

Данная вкладка позволяет настроить импорт полилиний, для сегментов которых заданы индивидуальные толщины линий. Если установлена постоянная толщина линии, то сегмент имеет форму прямоугольника, если переменная — то трапеции.

Вы можете указать, в какие объекты системы КОМПАС-3D нужно преобразовать эти сегменты.

в линию

Сегменты, образующие полилинию, объединяются в контур.

в заливку

Сегмент преобразуется в заливку. Форма контура заливки соответствует форме сегмента в файле формата DXF/DWG. Цвет заливки также соответствует заданному в этом файле.

Контур, ограничивающий заливку, не строится.

в штриховку

Сегмент преобразуется в штриховку. Форма контура и цвет штриховки соответствуют форме и цвету сегмента в файле формата DXF/DWG.

При выборе данного варианта становится доступным раскрывающийся список Шаг штриховки. Вы можете выбрать или ввести с клавиатуры нужное значение шага.

Контур, ограничивающий штриховку, не строится.
  1. Вы можете создать файл соответствия типов и стилей линий в текстовом режиме и подключать его при импорте файлов DXF.

После завершения настройки параметров нажмите кнопку Начать чтение. Для выхода из диалога без чтения файла нажмите кнопку Отмена.

Замечание...

Смотрите также

Особенности чтения размеров и линий-выносок

Перекодирование текстов


Диалог параметров записи в форматы DXF и DWG

Диалог появляется на экране при экспорте в формат DXF или DWG.

Позволяет задать параметры экспорта.

Описание элементов управления

Элемент

Описание

Вкладка Файлы

(присутствует в диалоге во время пакетного (группового) экспорта документов)

Документ

В этом поле отображается имя файла документа, который будет экспортирован в формат DXF/DWG.

Выбрать документ...

Для указания другого документа (документов) нажмите эту кнопку.

Текущий

Чтобы выбрать для экспорта текущий документ, включите эту опцию.

Записать в файл

В этом поле отображается имя файла, в котором будет сохранен результат экспорта.

Выбрать файл...

Для указания другого файла нажмите эту кнопку.

Вкладка Свойства

Версия формата

Выберите версию формата DXF/DWG для сохранения результатов экспорта.

Учитывать толщину линий

Опция, управляющая записью в результирующий файл сведений о толщине линий, использующихся в документе.

Если она включена, то в результирующий документ передается толщина линий, установленная для печати.

Передача толщин линий имеет следующую особенность. В системе AutoCAD толщина линии геометрического объекта может принимать только некоторые определенные значения в интервале от 0 до 2,11 мм. Поэтому линии КОМПАС-документа с толщиной меньше 2,11 мм преобразуются в линии с допустимой толщиной, наиболее близкой к исходной.

Если опция Учитывать толщину линий выключена, информация о толщине линий КОМПАС не записывается в файл DXF/DWG, и все линии в результирующем документе будут иметь одинаковую толщину, используемую в AutoCAD по умолчанию.

Линии с толщиной больше 2,11 мм преобразовывать в полилинии

Опция, управляющая записью геометрических объектов с установленной для печати толщиной линии больше 2,11 мм.

Если эта опция включена, то указанные объекты записываются как полилинии. Полилинии в системе AutoCAD, в отличие от геометрических объектов, могут иметь толщину больше 2,11 мм. Поэтому толщины полученных полилиний будут такими же, как толщины соответствующих линий в КОМПАС-документе.

Если опция Линии с толщиной больше 2,11 мм преобразовывать в полилинии выключена, то указанные объекты записываются без преобразования — как обычные геометрические объекты. Толщина линий у всех этих объектов будет одинакова и равна максимально допустимой — 2,11 мм.

Данная опция доступна при включенной опции Учитывать толщину линий.

Передавать точки

Группа опций, позволяющая настроить запись точек.

Если требуется, чтобы точки преобразовывались в аналогичные объекты системы AutoCAD, включите опцию Точками. В этом случае информация о стиле и цвете точек теряется, и все точки будут выглядеть в документе формата DXF/DWG одинаково.

Чтобы сохранить исходный вид (Звезда, Конверт и т.п.) и цвета точек, включите опцию Макрообъектами. В этом случае точки будут преобразованы в макроэлементы, повторяющие изображение точек в КОМПАС-документе.

Передавать цвет

Группа опций, позволяющая настроить запись цветов объектов.

Если объекты должны иметь цвета, указанные при их настройке, включите опцию Установленный для объекта. Это означает, что системные линии будут иметь цвета, заданные для них при настройке системы; линии с пользовательскими стилями будут иметь цвета, заданные при настройке соответствующих стилей; тексты и штриховки будут иметь цвета, заданные при их создании и т.д.

Если объекты должны иметь цвета, указанные для слоев, содержащих эти объекты, включите опцию Установленный для слоя. Это означает, что цвет объектов в результирующем документе будет определяться «по слою» (ByLayer).

Количество знаков после запятой

Укажите точность, с которой координаты объектов должны записываться в символьный файл *.dxf. Чем больше количество знаков после запятой, тем выше точность представления графических объектов в экспортированном файле. В то же время повышение точности представления приводит к увеличению размера экспортированного файла.

Вкладка Текст

Сужения текстов

Группа элементов, управляющая габаритами текстовых объектов.

Чтобы подогнать габариты получившихся в результате экспорта текстовых объектов под габариты исходных, включите опцию Автоматическая настройка.

Чтобы установить требуемые коэффициенты сужения для экспортируемых текстовых объектов, включите опцию Пользовательская настройка и введите нужные значения сужения для надписей разных типов.

Чтобы вернуть умолчательные значения сужения, нажмите кнопку По умолчанию.

Записывать тексты шрифтом AutoCAD

Если эта опция отключена, то TrueType-шрифты объектов, содержащих тексты, конвертируются в аналогичные по начертанию TrueType-шрифты. При этом не требуется настройка соответствия между спецсимволами КОМПАС и последовательностями символов ASCII, которыми они обозначаются в текстовом файле DXF/DWG, поэтому все опции вкладки Символы становятся недоступными.

Включение опции позволяет при экспорте в формат DXF/DWG конвертировать шрифты КОМПАС-документа в шрифты собственного формата AutoCAD.

Вкладка Символы

Кнопки этой вкладки доступны, если опция Записывать тексты шрифтом AutoCAD на вкладке Текст включена.

Вы можете интерактивно редактировать соответствие между спецсимволами КОМПАС и последовательностями символов ASCII, которыми они обозначаются в текстовом файле DXF. По умолчанию загружается последовательность символов, которая соответствует поставляемому в составе дистрибутива КОМПАС-3D файлу GOST_AU.shx.

Выбрать файл

Для подключения ранее сохраненного файла соответствия символов (системный файл КОМПАС с расширением ACS) нажмите эту кнопку.

Записать в файл

Для сохранения сделанной настройки соответствия символов в файле нажмите эту кнопку.

Символы по умолчанию

Для загрузки настройки соответствия символов по умолчанию нажмите эту кнопку.

Вкладка Слои

Данная вкладка позволяет настроить запись объектов, расположенных на разных слоях.

Состояния слоев в полученном документе зависят от состояний слоев и содержащих их видов в конвертируемом документе.

Экспортированный документ, открытый в системе AutoCAD, будет находиться в состоянии, максимально приближенном к тому, в котором он был в системе КОМПАС во время конвертации.

Кроме слоев, экспортированных из КОМПАС-3D, в результирующем документе формата DXF/DWG формируется системный слой с именем «0». При записи КОМПАС-чертежа в этом слое автоматически размещаются рамка и основная надпись, знак неуказанной шероховатости, технические требования, спецификация на листе, таблица изменений.

Объединять одноименные слои

Если эта опция, а также опция Распределять объекты КОМПАС по слоям АutoCAD (при экспорте в формат DWG) выключены, то для размещения объектов в результирующем документе создается столько же слоев, что и в экспортируемом. Т.е. все объекты размещаются на «своих» слоях.

Правило именования слоев

Включение опции Объединять одноименные слои означает, что после определения состояний (см. таблицу) слои будут разбиты на группы с совпадающими параметрами (состояниями, названиями, цветами). Слои каждой группы будут объединены в новые — результирующие слои.

Правило именования результирующих слоев

Если состояния и цвета всех Системных слоев в импортируемом КОМПАС-документе одинаковы, то после объединения этих слоев все их объекты помещаются в системный слой AutoCAD (он называется «0»).

Слои, объединение которых невозможно, размещаются в результирующем документе на отдельных слоях. Они именуются по тем же правилам, что и при размещении объектов на «своих» слоях1.

Распределять объекты КОМПАС по слоям АutoCAD

Вы можете сформировать отдельные слои для расположения различных объектов системы КОМПАС (оформление, тексты, штриховки, размеры и т.д.) и кривых с разными стилями линии. Другими словами, можно задать распределение объектов КОМПАС по слоям AutoCAD, отличное от их распределения в исходном файле. Это может потребоваться для приведения экспортируемых чертежей к нормам, установленным на предприятиях.

Чтобы настроить распределение объектов по слоям, включите опцию Распределить объекты КОМПАС по слоям АutoCAD.

В окне просмотра отображается список категорий объектов системы КОМПАС и имена слоев в AutoCAD, на которых по умолчанию будут размещены эти объекты, а также показываются цвета слоев2.

Изменить

Чтобы изменить имя слоя или его цвет, выберите нужную строку в окне просмотра и нажмите эту кнопку. В появившемся на экране диалоге выберите цвет слоя и введите его имя.

Записать в файл

Для сохранения сделанной настройки в файле нажмите эту кнопку. В появившемся диалоге укажите имя файла для записи. Система сформирует двоичный файл, содержащий сведения об именах и цветах слоев в AutoCAD для объектов КОМПАС (*.LAC).

Выбрать файл

Для подключения созданного ранее файла *.LAC нажмите эту кнопку.

По умолчанию

Для загрузки умолчательной настройки имен и цветов слоев нажмите эту кнопку.

Вкладка Компоновка листов спецификации

Вкладка позволяет задавать параметры размещения многостраничных спецификаций в формате DWG/DXF.

Количество листов в ряду

Введите или задайте счетчиком количество листов спецификации, которое должно быть размещено в горизонтальном ряду. Число рядов при этом определяется автоматически, исходя из размещения всех листов спецификации.

Зазор между листами

Введите или задайте счетчиком расстояние (в миллиметрах), которое нужно оставить между внешними рамками листов спецификации.

Записывать каждый лист
спецификации отдельным блоком

По умолчанию эта опция включена, при этом отрезки и тексты, составляющие каждый лист спецификации, в результирующем файле автоматически образуют отдельный блок. Данная настройка действует и для однолистовых спецификаций.
  1. Если предполагается запись с размещением объектов на «своих» слоях, то слоям в КОМПАС-документе рекомендуется присваивать имена, уникальные в пределах документа.
    Если предполагается запись с объединением слоев, то тем слоям, которые будут объединяться, следует присвоить одинаковые имена, а остальным — уникальные в пределах документа.
  2. Категория типа объекта («Точки», «NURBS-кривые», «Штриховки» и т.п.) более приоритетна, чем категория стиля линии («Основные линии», «Тонкие линии» и т.п.). Поэтому, если объект относится сразу к двум категориям (например, NURBS-кривая со стилем линии Основная), то он будет расположен на слое, установленном для категории типа.

После завершения настройки параметров нажмите кнопку ОК. Сделанная настройка запишется в файл dxflib.cfg или dwglib.cfg и будет использоваться для записи последующих файлов. Если потребуется изменение параметров записи, вызовите диалог настройки экспорта и сделайте необходимые изменения.

Если экспорт производится в пакетном режиме, то вместо кнопки ОК в диалоге присутствует кнопка Начать запись. Нажмите ее, чтобы начать экспорт документов. При этом настройка экспорта, сделанная в диалоге, будет записана в файл dxflib.cfg или dwglib.cfg.

Для выхода из диалога без изменения настройки или — в случае пакетного экспорта — без записи файлов нажмите кнопку Отмена.

Смотрите также

Некоторые особенности экспорта в формат DXF/DWG


Диалог параметров записи в формат IGES

Диалог появляется на экране при экспорте в формат IGES.

Позволяет задать параметры экспорта.

Описание элементов управления
Наименование | Описание
Документ | В этом поле отображается имя файла документа, который будет экспортирован в формат IGES.
Выбрать | Для указания другого документа нажмите эту кнопку.
Текущий | Чтобы выбрать для экспорта текущий документ, включите эту опцию.
Записать в файл | В этом поле отображается имя файла, в котором будет сохранен результат экспорта.
Выбрать | Для указания другого файла записи нажмите эту кнопку.
Начать запись | После завершения настройки параметров нажмите эту кнопку.
Отмена | Для выхода из диалога без экспорта документа нажмите эту кнопку.


Исполнение модели

Исполнение модели — один из вариантов модели, информация о которых содержится в одном групповом документе.

В системе предусмотрена возможность создания зависимых и независимых исполнений. Зависимое исполнение имеет связь с исходным исполнением, независимое исполнение не имеет такой связи.

Набор исполнений модели графически представлен в документе в виде Дерева исполнений. Оно отображается на вкладке Исполнения Дерева модели.


Диалог расширенного управления заливкой

Служит для настройки параметров промежуточных цветов и уровней прозрачности градиентной заливки.

Описание элементов управления

Элемент

Описание

Окно отображения цветов и уровней прозрачности

В окне отображается прямоугольник-образец с переходом от начального до конечного цвета и прозрачности, выбранными на Панели свойств. Снизу от прямоугольника располагаются указатели позиций.

– Если в заливке промежуточных цветов или уровней прозрачности нет, то имеются только позиции начального и конечного цветов.

– Если в заливке ранее были заданы промежуточные цвета или уровни прозрачности, то между начальной и конечной позицией располагаются указатели дополнительных позиций.

Чтобы создать новую позицию, щелкните дважды мышью в окне между Цветом 1 и Цветом 2. Перемещать позицию можно или при помощи мыши, или клавиш <→>, <←>, или элемента управления Позиция.

Подробно о настройке параметров...

Позиция

Поле величины, характеризующей положение текущей позиции относительно начального цвета заливки.

Введите или задайте счетчиком величину в процентах от длины прямоугольника-образца — целое число от 1 до 99.

Поле Позиция доступно, если текущим является указатель промежуточной позиции, но не начальной или конечной.

Цвет

Поле цвета текущей позиции.

После щелчка мышью по полю Цвет на экране появляется диалог выбора цвета.

Если необходимо ввести дополнительные цвета без изменения прозрачности, опция Интерполирование группы Прозрачность должна находиться во включенном состоянии.

Прозрачность

Группа элементов управления, позволяющая задать промежуточные уровни прозрачности в заливке.

– При включенной опции Интерполирование создается позиция без изменения прозрачности. По умолчанию при создании позиции опция включена. Величина прозрачности в текущей позиции является величиной, интерполированной между величинами прозрачностей в ближайших позициях — до и после текущей. При включенной опции шкала изменения прозрачности недоступна.

– Если опция Интерполирование выключена, доступна шкала изменения прозрачности. Чтобы изменить прозрачность цвета, следует передвинуть мышью «ползунок» — вправо для увеличения и влево для уменьшения уровня прозрачности.

– Чтобы изменить начальную или конечную прозрачность, следует передвинуть «ползунок» шкалы. Опция Интерполирование недоступна, если выделена позиция начальной или конечной прозрачности.

Изменять прозрачность можно также клавишами <→> и <←>.

Справа от шкалы отображается текущая прозрачность в процентах.

В процессе задания параметров в окне диалога отображаются переходы цвета с изменением прозрачности. Черно-белые клетки вверху прямоугольника служат для визуальной оценки прозрачности при настройке — в заливке они не отображаются.

После задания параметров нажмите кнопку ОК. Для выхода из диалога без внесения промежуточных цветов и уровней прозрачности нажмите кнопку Отмена.


Диалог создания и редактирования гиперссылок на файл или веб-страницу

При нажатой кнопке Файл, веб-страница в диалоге отображаются элементы управления, позволяющие создать гиперссылку данного типа.

Описание элементов управления

Элемент

Описание

Текущая папка

Кнопка, позволяющая выбрать в качестве целевого объекта гиперссылки произвольный файл или папку. Когда она нажата, доступна группа элементов Папка, которая служит для указания пути к файлу или папке.

– Список Папка позволяет выбрать диск или папку для отображения их содержимого в окне просмотра.

– Кнопка Назад позволяет перейти к последней просмотренной папке.

– Кнопка Вверх позволяет перейти к папке, расположенной на один уровень выше текущей.

– Кнопка Открыть позволяет вызвать стандартный диалог выбора файлов. В этом диалоге следует открыть папку, выбрать файл и нажать кнопку Открыть. Выбранная папка становится текущей (ее содержимое отображается в окне просмотра), а путь к файлу помещается в поле Адрес.

Указание целевого объекта — файла или папки — производится щелчком мыши в окне просмотра.

Последние файлы

При нажатой кнопке доступен список недавно использовавшихся файлов.

Просмотренные
страницы

При нажатой кнопке доступен список недавно просмотренных веб-страниц.

Адрес

Поле, в котором отображается путь к файлу или папке либо адрес выбранной веб-страницы. При необходимости поле Адрес можно заполнить или отредактировать вручную.

Нажатие кнопки с треугольником открывает список последних путей и адресов, который можно использовать для быстрого ввода.

Создание гиперссылки на файл или веб-страницу...

Кнопка Удалить ссылку доступна в режиме редактирования гиперссылки и позволяет ее удалить. После нажатия этой кнопки диалог закрывается.

Кнопка ОК доступна, если заполнено поле Адрес.

Для подтверждения ввода параметров или сделанных изменений нажмите кнопку ОК диалога. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


Дерево документа

Дерево документа — структурированный список («дерево») объектов, отражающий последовательность создания документа и его состав.

Отображение значка «+» рядом с объектом означает, что он имеет подчиненные объекты. Чтобы развернуть их список, щелкните мышью на значке.

Контекстные меню объектов Дерева облегчают доступ к командам, которые наиболее часто используются при работе с объектами данного типа.


Дерево исполнений

Дерево исполнений — структурированный список («дерево») исполнений модели, содержащихся в документе.

Содержит зависимые и независимые исполнения. Все независимые исполнения расположены на первом уровне иерархии дерева. Зависимые исполнения иерархически подчинены тому исполнению, которое для них является исходным.

Контекстные меню исполнений в Дереве облегчают доступ к командам, которые используются при работе с исполнениями.


Дерево зон

Дерево зон — структурированный список («дерево») зон, созданных в документе.

Содержит зоны и разбиения зон. Зоны и разбиения находятся на первом уровне иерархии дерева. На втором уровне находятся зоны, получаемые в результате разбиений.

Отображение значка «+» рядом с объектом означает, что он имеет подчиненные объекты. Чтобы развернуть их список, щелкните мышью на значке.

Контекстные меню зон и разбиений в Дереве облегчают доступ к командам, которые используются при работе с зонами.


Диалог настройки оформления документа

Позволяет создать или отредактировать стиль оформления графического документа. В оформление входят внешняя и внутренняя рамки документа, а также основная надпись.

Этот диалог появляется на экране после нажатия кнопки Создать или Редактировать диалога Работа со стилями оформлений чертежей и спецификаций.

Описание элементов управления

Наименование

Описание

Имя

В этом поле вы можете ввести название, под которым будет храниться стиль оформления.

Номер

В этом поле вы можете ввести уникальный номер стиля оформления.

Внешняя рамка

В этом разделе настраиваются параметры внешней рамки. Если отрисовывать ее не нужно, выключите опцию.

Линия

Выберите из списка нужный стиль отрисовки линий внешней рамки.

Внутренняя рамка

В этом разделе настраиваются параметры внутренней рамки. Если отрисовывать ее не нужно, выключите опцию.

Линия

Выберите из списка нужный стиль отрисовки линий внешней рамки.

Отступы от внешней рамки

Задайте величины отступов линий, образующих внутреннюю рамку, от внешней рамки документа.

Основная надпись

В этом разделе выбирается основная надпись для документа.

В поле отображается название текущей основной надписи. Чтобы подключить к оформлению другую основную надпись, нажмите кнопку с многоточием справа от поля.

На экране появится диалог со списком основных надписей, содержащихся в текущей библиотеке оформлений. Выберите нужную основную надпись и нажмите кнопку ОК диалога.

Если основную надпись отрисовывать не нужно, выключите опцию Основная надпись.

Таблица изменений

Активизируйте эту опцию, чтобы включить работу с таблицей изменений.

Работа с таблицей изменений возможна, если включена работа со спецификацией.

Стиль

В этом поле отображается текущий стиль таблицы изменений. Чтобы выбрать другой стиль, нажмите кнопку с многоточием справа от поля.

На экране появится диалог со списком стилей спецификаций, содержащихся в текущей библиотеке оформлений. Выберите стиль, соответствующий таблице изменений, и нажмите кнопку ОК диалога.

В составе системы КОМПАС поставляются два стиля таблицы изменений: Таблица изменений. ГОСТ 2.104-2006 и Таблица изменений с зонами. ГОСТ 2.104-2006.

Сдвиг таблицы относительно главной таблицы основной надписи

В полях этой группы вы можете задать смещение нижнего правого угла таблицы изменений относительно верхнего левого угла таблицы основной надписи.

Количество строк в первом блоке

В этом поле вы можете ввести количество записей об изменениях в первом блоке таблицы. Чтобы таблица изменений не выходила за пределы таблицы основной надписи, например, первого листа конструкторского чертежа, в первом блоке должно быть не более четырех строк.

Количество строк в последующих блоках

В этом поле вы можете ввести количество записей об изменениях в последующих блоках таблицы. Чтобы последующие блоки таблицы изменений по высоте были равны таблице основной надписи, например, первого листа конструкторского чертежа, количество строк в них должно быть равно десяти.

Последующий блок располагать справа от предыдущего

Включите эту опцию, чтобы последующий блок изменений располагался справа от предыдущего. Если опция выключена, то последующие блоки располагаются слева от предыдущих.

После завершения настройки оформления нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


Диалог создания таблицы допуска формы

Этот диалог появляется на экране после вызова команды Создание таблицы... из контекстного меню.

В нем можно полуавтоматически сформировать текстовые надписи в ячейках таблицы допуска формы.

Описание элементов управления
Наименование | Описание
Знак | Выберите из списка нужный вариант знака для обозначения допуска.
Числовое значение | Введите числовое значение допуска. Для вызова пользовательского меню со значениями из стандартного ряда дважды щелкните мышью в поле ввода.
База 1 | Введите букву для обозначения первой базовой поверхности. Для вызова пользовательского меню с заглавными буквами русского алфавита дважды щелкните мышью в поле ввода.
База 2 | Введите букву для обозначения второй базовой поверхности. Для вызова пользовательского меню с заглавными буквами русского алфавита дважды щелкните мышью в поле ввода.

Подробнее о пользовательских меню при вводе текста...

После ввода надписей для всех ячеек нажмите кнопку ОК. Для выхода из диалога без изменений нажмите кнопку Отмена.


Диалог задания параметров записи в PDF (многолистовой чертеж)

Диалог задания параметров записи в PDF
(многолистовой чертеж)

Этот диалог появляется на экране после нажатия кнопки Параметры при экспорте файла в PDF.

В диалоге можно настроить параметры записи многолистового чертежа в PDF.

Описание элементов управления

Элемент

Описание

Группа Диапазон

Количество страниц документа

Общее количество страниц документа.

Все страницы

Вариант позволяет сохранить все листы документа.

Страницы

Вариант позволяет указать номера листов для сохранения. При выборе этого варианта становится доступным поле для ввода номеров листов. Они должны разделяться запятыми.

Все страницы в один файл

Опция, позволяющая сформировать один многостраничный файл, на каждой странице которого будет расположен один лист документа. При выключенной опции для каждого листа создается отдельный файл формата PDF.

Группа Настройка

Цвет

Список, из которого можно выбрать цвет изображения. Доступны следующие варианты:

– Черный,

– Установленный для вида,

– Установленный для слоя,

– Установленный для объекта.

Все линии тонкие

Опция, позволяющая записать все линии с толщиной, установленной для печати тонких линий в диалоге настройки системных линий. По умолчанию это значение (толщина на бумаге) составляет 0,18 мм.

Если эта опция выключена, то линии записываются с индивидуальными толщинами для печати.

Толщина линии на бумаге — параметр стиля линии. Для системных стилей он задается в диалоге настройки системных линий, а для пользовательских стилей — при их настройке.

Стиль линии содержит также параметр «толщина на экране». Его значение не влияет на результат экспорта.

Состояние опции Все линии тонкие не влияет на толщину линий шрифта.

Масштаб

Поле для ввода масштаба изображения.

Группа Параметры

Разрешение, точек на дюйм

Раскрывающийся список позволяет ввести или выбрать разрешение изображения.

Оттенки серого

Опция позволяет записать цветные оттенки оттенками серого цвета.

Встроить шрифты

Опция, позволяющая получить такой же вид текста в PDF-файле, как и в исходном документе.

Фильтр

Кнопка позволяет настроить фильтры вывода на печать. После вызова команды на экране появится диалог Установка фильтров вывода на печать. В созданном файле будут присутствовать только те объекты КОМПАС-документа, печать которых включена.

Сохранить настройки

Опция, позволяющая сохранить заданные настройки записи в формат PDF для дальнейшего использования.

После завершения настройки нажмите кнопку ОК. Для отказа от настройки нажмите кнопку Отмена.


Диалог задания параметров записи в растровый файл (многолистовой чертеж)

Диалог задания параметров записи
в растровый файл
(многолистовой чертеж)

Этот диалог появляется на экране, если при сохранении многолистового чертежа был выбран один из растровых форматов.

В диалоге можно настроить параметры записи в растровый файл.

Описание элементов управления

Элемент

Описание

Группа Диапазон

Количество страниц документа

Общее количество страниц документа.

Весь документ в один файл

Для растровых форматов, исключая TIFF, опция позволяет сохранить все листы чертежа в одном файле. Если опция выключена, каждый лист записывается в отдельный файл. Имена файлов для сохранения листов будут формироваться следующим образом. К заданному при сохранении документа имени будут автоматически добавляться дополнительные элементы, соответствующие номерам листов.

При записи документа в формат TIFF опция позволяет сохранить все листы документа на одной странице файла. Если опция выключена, то результат записи документа будет зависеть от состояния опции Сохранять все страницы в одном файле. Если эта опция включена, то документ будет сохранен в один файл. Листы документа сохраняются на отдельных страницах файла. Если опция Сохранять все страницы в одном файле выключена, то каждый лист записывается в отдельный файл аналогично другим растровым форматам.

Все страницы

Вариант позволяет сохранить все листы документа.

Страницы

Вариант позволяет указать номера листов для сохранения. При выборе этого варианта становится доступным поле для ввода номеров листов. Они должны разделяться запятыми.

Многостраничный TIFF

Опция позволяет при сохранении документа в формате TIFF сохранить каждый лист на отдельной странице файла документа. Опция недоступна в следующих случаях:

– при сохранении в формате TIFF включена опция Весь документ в один рисунок,

– при сохранении в других растровых форматах.

Группа Настройка

Цвет

Список, из которого можно выбрать цвет изображения. Доступны следующие варианты:

– Черный,

– Установленный для объекта.

Все линии тонкие

Опция, позволяющая записать все линии с толщиной, установленной для печати тонких линий в диалоге настройки системных линий. По умолчанию это значение (толщина на бумаге) составляет 0,18 мм.

Если эта опция выключена, то линии записываются с индивидуальными толщинами для печати.

Толщина линии на бумаге — параметр стиля линии. Для системных стилей он задается в диалоге настройки системных линий, а для пользовательских стилей — при их настройке.

Стиль линии содержит также параметр «толщина на экране». Его значение не влияет на результат экспорта.

Состояние опции Все линии тонкие не влияет на толщину линий шрифта.

Масштаб

Поле для ввода масштаба изображения.

Группа Параметры растра

Раскрывающийся список Цветность

Позволяет выбрать количество цветов.

Разрешение, точек на дюйм

Раскрывающийся список позволяет ввести или выбрать разрешение изображения.

Оттенки серого

Опция позволяет записать цветные оттенки оттенками серого цвета.

Количество оттенков серого тем больше, чем большая цветность установлена. Поэтому включение этой опции не равносильно выбору черно-белого способа записи, при котором оттенки серого цвета создаются путем «смешения» черных и белых пикселов.

После завершения настройки нажмите кнопку ОК, чтобы начать запись. Для отказа от записи нажмите кнопку Отмена.

Запись в растровые форматы подчиняется настройке фильтров вывода на печать. Т.е. в созданном файле рисунка будут присутствовать только те объекты КОМПАС-документа, печать которых включена.

Если появилось сообщение о невозможности записи...


Диалог задания параметров записи в файл формата EMF (многолистовой чертеж)

Диалог задания параметров записи
в файл формата EMF
(многолистовой чертеж)

Этот диалог появляется на экране, если при сохранении многолистового чертежа был выбран формат EMF.

В диалоге можно настроить параметры записи в файл выбранного формата.

Описание элементов управления

Элемент

Описание

Группа Диапазон

Количество страниц документа

Общее количество страниц документа.

Весь документ в один файл

Опция, позволяющая сохранить все листы чертежа в одном файле.

Если опция выключена, каждый лист записывается в отдельный файл. Имена файлов для сохранения листов формируются путем добавления порядковых номеров к имени документа.

Все страницы

Вариант, позволяющий сохранить все листы документа.

Страницы

Вариант, позволяющий указать номера листов для сохранения. При выборе этого варианта становится доступным поле для ввода номеров листов. Они должны разделяться запятыми.

Группа Настройка

Цвет

Раскрывающийся список позволяет выбрать цвет изображения. Доступны следующие варианты:

– Черный,

– Установленный для объекта,

– Установленный для вида,

– Установленный для слоя.

Все линии тонкие

Опция, позволяющая записать все линии с толщиной, установленной для печати тонких линий в диалоге настройки системных линий. По умолчанию это значение (толщина на бумаге) составляет 0,18 мм.

Если эта опция выключена, то линии записываются с индивидуальными толщинами для печати.

Толщина линии на бумаге — параметр стиля линии. Для системных стилей он задается в диалоге настройки системных линий, а для пользовательских стилей — при их настройке.

Стиль линии содержит также параметр «толщина на экране». Его значение не влияет на результат экспорта.

Состояние опции Все линии тонкие не влияет на толщину линий шрифта.

Масштаб

Поле для ввода масштаба изображения.

После завершения настройки нажмите кнопку ОК, чтобы начать запись. Для отказа от записи нажмите кнопку Отмена.

Запись в растровые форматы подчиняется настройке фильтров вывода на печать. Т.е. в созданном файле рисунка будут присутствовать только те объекты КОМПАС-документа, печать которых включена.

Поскольку величина файла в формате EMF предварительно оценивается в точках, может появиться сообщение о невозможности записи растрового файла (см. Условия, определяющие возможность записи). Чтобы экспорт был возможен, необходимо уменьшить масштаб изображения.

Смотрите также

Особенности записи КОМПАС-документов в формат EMF


Диалог Удалить группы

Диалог служит для выбора удаляемых групп компонентов с одним и тем же номером позиции.

Появляется на экране после нажатия кнопки Удалить группу.

Элементы управления диалога
Элемент | Описание
Список групп | Список имеющихся в сборке групп компонентов с одним и тем же номером позиции. Сразу после вызова диалога в списке выделена та группа, которая была текущей на момент нажатия кнопки Удалить группу.
Все | Выберите этот вариант, чтобы удалить все группы.
Группы | Выберите этот вариант, чтобы удалить одну или несколько групп. Выделите удаляемые группы в списке групп.

Выбрав удаляемые группы, нажмите кнопку ОК диалога, чтобы подтвердить удаление. Чтобы отказаться от удаления групп, нажмите кнопку Отмена.

Подробнее о компонентах с одним номером позиции...


Диалог Задание имени группы

Служит для ввода имени создаваемой группы компонентов с одним и тем же номером позиции.

Диалог появляется после нажатия кнопки Создать группу на инструментальной панели окна Группы компонентов.

Введите имя в поле Имя группы.

Нажмите кнопку ОК диалога, чтобы подтвердить создание группы. Чтобы отказаться от создания группы, нажмите кнопку Отмена.

Подробнее о компонентах с одним номером позиции...


Диалог параметров чтения формата IGES

Диалог появляется на экране при импорте из формата IGES.

Позволяет задать параметры импорта.

Описание элементов управления
Наименование | Описание
Исходный файл | В этом поле отображается имя импортируемого файла.
Читать в файл | Выберите эту группу параметров, чтобы объекты импортируемого фрагмента были записаны в новый файл.
Имя файла | По умолчанию предлагается имя файла для записи, образованное из имени исходного файла с добавлением расширения *.CDW.
Выбрать | Для выбора уже существующего файла используйте кнопку.
Отображать на экране | Включите эту опцию, чтобы импортируемые объекты отображались на экране во время чтения.
Читать в текущий вид | Выберите эту группу параметров, чтобы объекты импортируемого фрагмента были прочитаны в текущий вид чертежа (или в текущий фрагмент).
На слои-источники | Импортируемые объекты будут помещены на свои слои. При необходимости нужные слои создаются автоматически.
На текущий слой | Все импортируемые объекты будут помещены на текущий слой.
Приводить стили линий к системным | Включите эту опцию, чтобы при импорте все нестандартные стили линий были заменены наиболее близкими к ним системными стилями.
Начать чтение | После завершения настройки параметров нажмите кнопку.
Отмена | Для выхода из диалога без чтения файла нажмите кнопку.


Диалог создания и редактирования гиперссылок

Этот диалог появляется на экране после вызова команды Гиперссылка....

Позволяет создавать в графическом документе или эскизе новые гиперссылки, редактировать или удалять уже имеющиеся.

В левой части диалога расположены кнопки, при помощи которых выбирается тип гиперссылки. После нажатия кнопки диалог меняет вид — в нем появляются элементы управления для создания или редактирования выбранного типа гиперссылки:

– Файл, веб-страница

– Место в документе

– Электронная почта

Чтобы удалить гиперссылку, нажмите кнопку Удалить ссылку. Кнопка доступна в режиме редактирования гиперссылки.


Диалог добавления документа в библиотеку

Этот диалог появляется на экране после вызова команды добавления в библиотеку существующих документов (фрагментов или моделей) и указания файлов этих документов.

Описание элементов управления

Наименование

Описание

Введите имя...

В этом поле ввода вы можете задать имя, под которым фрагмент (модель) будет присутствовать в библиотеке.

Полный путь

Выбор этого вариант означает, что именем фрагмента (модели) будет являться полное имя соответствующего файла.

Относительное имя

Выбор этого варианта означает, что именем фрагмента (модели) будет имя соответствующего файла.

Вы можете ввести произвольное имя длиной не более 259 символов.

ОК

Нажмите эту кнопку, чтобы подтвердить включение текущего документа в библиотеку.

Если для добавления в библиотеку было выбрано несколько документов, система перейдет к следующему. В противном случае диалог закроется.

Да для всех

Нажмите эту кнопку, чтобы добавить в библиотеку сразу все оставшиеся документы (т.е. документы, добавление которых еще не было подтверждено) с одинаковой настройкой умолчательного имени.

Произвольное имя, если оно было задано для текущего документа, сохранится. Имена остальных документов будут сформированы в соответствии с выбранным вариантом именования.

Отмена

Нажмите эту кнопку, чтобы отказаться от включения текущего документа в библиотеку.

Если для добавления в библиотеку было выбрано несколько документов, система перейдет к следующему. В противном случае диалог закроется.

Отменить для всех

Нажмите эту кнопку, чтобы отказаться от добавления в библиотеку оставшихся документов.


Диалог параметров вставки иллюстрации в текст

Позволяет изменить параметры вставки иллюстрации (чертежа, фрагмента или изображения из растрового файла) в текст.

Появляется на экране при создании вставки (после нажатия кнопки Параметры в диалоге открытия файла) или при редактировании уже созданной вставки (после двойного щелчка на ней).

Описание элементов управления

Наименование

Описание

Имя файла

В этом поле отображается имя файла, выбранного для вставки. Поле является справочным и недоступно для редактирования.

Справа от поля находится кнопка для выбора другого файла. Она доступна во время редактирования и только для иллюстраций, вставленных внешней ссылкой.

Взять в документ

Выбор этого способа вставки означает, что содержимое выбранного файла физически скопируется в документ и будет храниться там как единое целое. Связь с источником не сохраняется. Изменения, сделанные в файле-источнике, не отображаются в документе, содержащем вставку. При передаче этого документа на другое рабочее место передача источника вставки не требуется.

Внешняя ссылка

Выбор этого способа вставки означает, что в документе сформируется только ссылка на файл-источник без физической вставки содержимого файла. Изменения, сделанные в файле-источнике, отображаются во всех документах, содержащих вставки. При передаче этих документов на другое рабочее место требуется также передача источника вставки.

Габариты источника

В этих полях отображается высота и ширина изображения, выбранного для вставки.

Поля являются справочными и недоступны для редактирования.

Габариты вставки

В этих полях отображается текущая высота и ширина изображения с учетом масштаба, заданного в поле Масштаб. Для растровых изображений учитывается также разрешение, заданное в поле Разрешение.

Вы можете ввести нужное значение высоты (ширины) вставки с клавиатуры. Соответствующий заданному значению масштаб будет определен автоматически, ширина (высота) вставки будет умножена на полученное значение1.

Масштаб

Поле, позволяющее ввести или выбрать из списка масштаб вставки. В списке доступны также варианты по ширине и по высоте, позволяющие подогнать размеры вставки под ширину или высоту страницы.

После изменения масштаба габариты вставки пересчитываются.

Угол поворота

Список, позволяющий выбрать угол поворота вставки. Доступны углы, кратные 90°.

Разрешение

Только для растровых изображений.

Поле, в котором отображается текущее разрешение изображения. Разрешение доступно для изменения, если в файле-источнике вставки нет информации о разрешении.

После изменения разрешения габариты вставки пересчитываются.

Цветовая палитра

Только для растровых изображений.

Поле, в котором отображается цветовое разрешение графического файла. Является справочным и недоступно для редактирования.
  1. Расчет выполняется с точностью до 0,01. Получившееся значение масштаба округляется в меньшую сторону. В результате этого конечное значение высоты (ширины) может отличаться от изначально введенного.

Опции Взять в документ и Внешняя ссылка не доступны при редактировании параметров вставки, взятой в документ.

После назначения нужных параметров вставки нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


Диалог параметров вставки иллюстрации в ячейку таблицы

Позволяет изменить параметры вставки иллюстрации (фрагмента или изображения из растрового файла) в ячейку таблицы, содержащейся в текстовом или графическом КОМПАС-документе.

Появляется на экране при создании вставки (после нажатия кнопки Параметры в диалоге открытия файла) или при редактировании уже созданной вставки (после двойного щелчка на ней).

Описание элементов управления

Наименование

Описание

Имя файла

В этом поле отображается имя файла, выбранного для вставки. Поле является справочным и недоступно для редактирования.

Справа от поля находится кнопка для выбора другого файла. Она доступна во время редактирования и только для иллюстраций, вставленных внешней ссылкой.

Габариты источника

В этих полях отображается высота и ширина изображения, выбранного для вставки.

Поля являются справочными и недоступны для редактирования.

Габариты вставки

В этих полях отображается текущая высота и ширина изображения с учетом масштаба, заданного в поле Масштаб. Для растровых изображений учитывается также разрешение, заданное в поле Разрешение.

Вы можете ввести нужное значение высоты (ширины) вставки с клавиатуры. Соответствующий заданному значению масштаб будет определен автоматически, ширина (высота) вставки будет умножена на полученное значение1.

Масштаб

Поле, позволяющее ввести или выбрать из списка масштаб вставки. В списке доступны также варианты по ширине и по высоте, позволяющие подогнать размеры вставки под ширину или высоту ячейки.

После изменения масштаба габариты вставки пересчитываются.

Угол поворота

Список, позволяющий выбрать угол поворота вставки. Доступны углы, кратные 90°.

Разрешение

Только для растровых изображений.

Поле, в котором отображается текущее разрешение изображения. Разрешение доступно для изменения, если в файле-источнике вставки нет информации о разрешении.

После изменения разрешения габариты вставки пересчитываются.

Цветовая палитра

Только для растровых изображений.

Поле, в котором отображается цветовое разрешение графического файла. Является справочным и недоступно для редактирования.
  1. Расчет выполняется с точностью до 0,01. Получившееся значение масштаба округляется в меньшую сторону. В результате этого конечное значение высоты (ширины) может отличаться от изначально введенного.

После назначения нужных параметров вставки нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


Диалог задания габаритов вставки

Позволяет задать точные размеры вставки чертежа или фрагмента в текст или ячейку таблицы. В качестве габаритов по умолчанию предлагаются высота и ширина страницы (при вставке в текстовый документ) или ячейки (при вставке в ячейку таблицы).

Введите требуемую высоту и ширину (в миллиметрах) вставки и нажмите кнопку ОК. Для выхода из диалога без изменения габаритов нажмите кнопку Отмена.


Предупреждение о совпадении номеров слоев

Этот диалог появляется на экране при копировании слоев между видами, если в виде, куда копируются слои, уже существуют слои с такими же номерами, как у копируемых.

В диалоге показаны номера, имена и цвета слоев, вызвавших конфликт.

Чтобы продолжить работу, выберите один из вариантов действий, нажав соответствующую кнопку.

Варианты действий при совпадении номеров слоев
Наименование | Описание
Добавить, Добавить — для всех | Копируемому слою (слоям) присваивается другой номер, не совпадающий ни с одним из номеров имеющихся в виде слоев. Слой (слои) добавляется в вид, сохраняя свое имя и цвет, в состоянии активный, видимый.
Заменить, Заменить — для всех | Существующему слою (слоям) присваивается имя и цвет копируемого слоя (слоев). Состояние имеющегося слоя (слоев) не изменяется. Добавление слоев не производится.
Пропустить, Пропустить — для всех | Ни с копируемыми, ни с существующими слоями не выполняется никаких действий. Добавление слоев не производится.

Наличие в виде двух и более системных слоев (слоев с нулевыми номерами) не допускается. Поэтому при копировании системного слоя из одного вида в другой кнопки Добавить и Добавить — для всех недоступны.

Чтобы отказаться от копирования, нажмите кнопку Отмена.

Если копируется группа слоев, то после нажатия кнопки Отмена, Пропустить или Пропустить — для всех в выбранном виде создается пустая группа.


Команда прикладной библиотеки

Справка на команду отсутствует.

Возможная причина: не найден или поврежден файл справки. Проверьте наличие и правильность размещения файла справки на диске и при необходимости переустановите библиотеку.

Справочные системы формата WinHelp32 (т.е. файлы справки с расширением hlp) по умолчанию не поддерживаются операционными системами Microsoft Windows Vista и Microsoft Windows 7. Для работы с такими файлами операционную систему необходимо обновить.

Смотрите также

Общие сведения о библиотеках


Командное окно библиотеки

Окно, содержащее команды управления изображением вставляемого из библиотеки элемента. Эти команды позволяют отредактировать различные параметры элемента до его фиксации. Для вызова любой из них дважды щелкните мышью по ее названию. Эти же команды вы можете выбрать из контекстного меню.

Когда фантом элемента будет соответствовать желаемому изображению, задайте положение его точки привязки.


Меню команд прикладной библиотеки

Позволяет выбрать команду из прикладной библиотеки и выполнить ее. Работа с библиотекой в данном случае ведется как со стандартным иерархическим меню.

Название библиотеки отображается в виде команды в меню Библиотеки. При вызове этой команды раскрывается меню, содержащее функции библиотеки в виде команд (они могут быть сгруппированы по разделам).

Для запуска функции на исполнение выберите из меню Библиотеки команду меню с названием нужной функции.

Смотрите следующие темы об использовании библиотек при работе с КОМПАС-3D:

Общие сведения о библиотеках

Подключение библиотеки

Режимы работы с библиотекой

Изменение режима работы с библиотекой

Выбор функции из библиотеки и ее запуск

Одновременная работа с несколькими библиотеками

Отключение библиотеки


Окно работы с прикладной библиотекой

Позволяет выбрать команду из прикладной библиотеки и выполнить ее. Работа с библиотекой в данном случае ведется как со стандартным окном Windows. Вы можете изменять размер окна библиотеки, а также сворачивать (минимизировать) его, оставляя на экране только пиктограмму.

В левой части окна отображается список команд текущей библиотеки, которые могут быть сгруппированы по разделам. Чтобы развернуть содержание какого-либо раздела, установите курсор на значке плюса рядом с заголовком раздела и щелкните левой кнопкой мыши. Повторный щелчок на этом символе (после разворачивания раздела он отображается как минус) приведет к сворачиванию содержания раздела.

В правой части окна могут отображаться слайды (если это предусмотрено разработчиком библиотеки), облегчающие поиск нужной команды.

Для запуска библиотечной команды на исполнение выберите ее название в списке и нажмите клавишу <Enter>. Можно также дважды щелкнуть левой кнопкой мыши на названии команды.

Для закрытия окна библиотеки нажмите системную кнопку Закрыть в правом верхнем углу окна.

Смотрите следующие темы об использовании библиотек при работе с КОМПАС-3D:

Общие сведения о библиотеках

Подключение библиотеки

Режимы работы с библиотекой

Изменение режима работы с библиотекой

Выбор функции из библиотеки и ее запуск

Одновременная работа с несколькими библиотеками

Отключение библиотеки


Диалог Правило для значений

Этот диалог появляется на экране после нажатия кнопки Правило для значений в диалоге Параметры свойства, если опция Заполнение из списка в этом диалоге отключена.

Диалог позволяет задать или изменить диапазон целых или вещественных значений текущего свойства. Для этого служат поля Минимальное/Максимальное значение.

Умолчательные значения полей определяются системой. Вы можете изменить эти значения вручную или при помощи счетчика.

Для завершения задания или изменения диапазона значений нажмите кнопку ОК. Кнопка Отмена позволяет закрыть диалог без сохранения изменений.


Диалог создания и редактирования гиперссылок на адрес электронной почты

При нажатой кнопке Электронная почта в диалоге отображаются элементы управления, позволяющие создать гиперссылку данного типа.

Описание элементов управления
Элемент | Описание
mailto: | Поле для ввода адреса получателя сообщения. После активизации гиперссылки этот адрес будет автоматически помещен в поле Кому: окна создаваемого сообщения.
Недавно использовавшиеся адреса электронной почты | Поле, в котором отображаются адреса электронной почты, использовавшиеся для гиперссылок в текущем сеансе работы КОМПАС-3D.

Создание гиперссылки на адрес электронной почты...

Кнопка Удалить ссылку доступна в режиме редактирования гиперссылки и позволяет ее удалить. После нажатия этой кнопки диалог закрывается.

Кнопка ОК доступна, если поле mailto: содержит адрес электронной почты.

Для подтверждения ввода параметров или сделанных изменений нажмите кнопку ОК диалога. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


Диалог Параметры зеркального отражения компонентов

Этот диалог появляется на экране при создании зеркальных компонентов или зеркальных исполнений модели.

Диалог появляется в следующих случаях:

– в процессе создания зеркальных компонентов или создания зеркального исполнения модели после нажатия кнопки Продолжить зеркальное отражение, расположенной на Панели специального управления (для исполнения кнопка появляется после включения опции Зеркальное исполнение, если исходное исполнение модели содержит компоненты),

– при работе с исполнениями в Менеджере документа после вызова команды Создать зеркальное исполнение, если исходное исполнение модели содержит компоненты.

Диалог позволяет настроить параметры зеркального отражения и/или симметричной вставки компонентов. Он содержит таблицу исходных компонентов (или компонентов исходного исполнения) и инструментальную панель.

– При работе с компонентами модели в диалоге отображаются все компоненты, выбранные для получения зеркальных и/или симметричных компонентов. Если исходный компонент, в свою очередь, содержит компоненты, то в диалоге отображаются и сам исходный компонент, и все компоненты, входящие в него.

– При работе с исполнениями в диалоге отображаются все компоненты исходного исполнения.

Порядок расположения компонентов в таблице соответствует порядку их отображения в Дереве построения. Ячейки таблицы содержат информацию о заданных настройках и позволяют изменить их.

Настройка параметров выполняется с помощью ячеек таблицы или кнопок инструментальной панели. Кнопки доступны, если в таблице диалога выделен хотя бы один компонент.

Чтобы настроить параметры отражения, выполните следующие действия.

1. Выберите способ отражения компонентов:

– Зеркальное отражение компонента,

– Симметричное расположение компонента.

Подробно о выборе способа отражения

2. В зависимости от выбранного способа отражения компонентов выполните следующие настройки:

– Зеркальное отражение компонента — выберите результат отражения:

• Создать зеркальное исполнение,

• Сохранить зеркальный компонент в файле,

• Отображать компонент в зеркальном виде.

Подробно о выборе результата отражения компонентов

– Симметричное расположение компонента — настройте положение компонента:

• выберите плоскость/центр симметрии исходного компонента автоматически или вручную,

• выберите базовый компонент.

Подробно о настройке положения компонента

В некоторых случаях при настройке параметров отражения компонента все компоненты, входящие в него, перестают отображаться в диалоге. Это означает, что для них недоступно изменение настроек, т.к. они должны иметь те же параметры отражения, что и содержащий их компонент.

3. При необходимости используйте следующие дополнительные возможности:

– фильтр для управления отображением компонентов в таблице,

– команды для управления видимостью фантомов компонентов в окне модели,

– настройку общих параметров отражения.

4. Вы можете изменить набор исходных компонентов, выбранных для отражения. Для этого нажмите кнопку Выбор объектов.... Диалог закроется, на Панели свойств появятся элементы выбора объектов.

Измените набор выбранных компонентов и нажмите кнопку Продолжить зеркальное отражение. Диалог настройки параметров отражения вновь появится на экране.

Если настройка параметров отражения выполняется при создании зеркального исполнения, то кнопки Выбор объектов... в диалоге нет.

5. Для завершения работы в диалоге нажмите кнопку ОК. Диалог закроется, операция добавления компонентов (создания исполнения) будет завершена.

Кнопка Отмена позволяет отказаться от создания компонентов (исполнения).


Диалог Массо-центровочные характеристики

Позволяет задавать значения системных свойств Масса, Материал, Плотность моделей и тел, а также производить пересчет МЦХ модели. В диалоге также могут быть заданы параметры штриховки для отображения модели в ассоциативных чертежах.

Этот диалог вызывается из Редактора свойств или Менеджера документа (при работе с исполнениями). Для вызова диалога выполните одно из следующих действий:

– выделить ячейку и нажать кнопку Параметры МЦХ на инструментальной панели;

– дважды щелкнуть мышью по ячейке;

– нажать на кнопку с многоточием в правой части выделенной ячейки.

Описание элементов управления

Элемент

Описание

Окно параметров

Окно, в котором отображаются наименования свойств и их значения в виде таблицы. Над таблицей находятся элементы управления параметрами.

В зависимости от выбранного способа задания параметров (Расчет по массе, Расчет по плотности, Ручной ввод) те или иные поля таблицы доступны для ввода значений.

Из источника

При активизированном переключателе значения свойств для компонентов берутся из файла-источника, для тела — из текущей модели (корневого объекта в Редакторе свойств).

Расчет по плотности

Активизируйте этот переключатель, чтобы задать материал и его плотность для модели или тела.

Для выбора материала и плотности из справочников используйте переключатели Выбрать материал из списка и Выбрать материал из справочника, для задания значения плотности вручную — переключатель Ручной ввод.

Расчет по массе

Активизируйте этот переключатель, чтобы задать массу модели. Введите значение в поле Масса. Материал и плотность не имеют значения.

Выбрать материал из списка

Нажмите эту кнопку, чтобы выбрать материал из из справочного файла плотностей, который используется системой КОМПАС-3D по умолчанию. На экране появляется диалог выбора плотности материала.

При выборе материала плотность и стиль штриховки задаются автоматически.

Выбрать материал из справочника

Нажмите эту кнопку, чтобы выбрать материал из Справочника Материалы и Сортаменты.

При выборе материала плотность задается автоматически.

Удалить материал

Нажмите эту кнопку, чтобы удалить обозначение материала, отображающееся в поле Материал.

Если обозначение материала модели удалено, то соответствующая графа основной надписи чертежа, содержащего ассоциативные виды этой модели, остается пустой.

Выбор из справочника

Переключатель доступен, если выбран способ Расчет по плотности.

Активизируйте переключатель, чтобы значение плотности материала было взято из справочного файла плотностей или Справочника Материалы и Сортаменты (в зависимости от того, откуда был выбран материал) и отображено в поле Плотность.

Ручной ввод

Переключатель доступен, если выбран способ Расчет по плотности.

Активизируйте переключатель, чтобы задать значение плотности вручную. Введите значение в поле Плотность.

Таблица содержит следующие элементы управления:

Масса

Поле массы модели.

– Если активен переключатель Из источника, то в поле отображается масса модели из файла-источника.

– Если активен переключатель Расчет по массе, то поле доступно для ручного ввода. Введите значение.

– Если активен переключатель Расчет по плотности, то значение вычисляется автоматически. Задайте значение плотности из справочника или вручную, а затем нажмите кнопку Пересчитать МЦХ.

Настройка единиц задания МЦХ...

Обозначение материала

Поле обозначения материала. Заполняется автоматически после выбора материала. Недоступно для ручного ввода.

Обозначение материала передается в основную надпись чертежа при создании в нем ассоциативного вида детали (если этот вид первый в порядке вставки в чертеж).

Удаление обозначение материала производится нажатием кнопки Удалить. В этом случае основная надпись не будет содержать сведений о материале.

Плотность

Поле плотности материала. Заполняется автоматически после выбора материала. Доступно для ручного ввода, если выбран способ Расчет по плотности.

Плотность материала используется при вычислении массо-центровочных характеристик детали при расчете по плотности. При расчете по массе значение является справочным.

Стиль штриховки1

Поле стиля штриховки. Заполняется автоматически после выбора материала. В поле доступен выбор стиля из списка.

Цвет штриховки1

Поле цвета штриховки. По умолчанию отображается цвет, заданный в стиле штриховки (для системных стилей — черный). В поле доступна смена цвета.

Угол штриховки1

Поле угла штриховки. В поле доступен выбор значений из списка или ввод вручную.

Пересчитать МЦХ

Кнопка, позволяющая заново рассчитать массо-центровочные характеристики модели или тела после изменения материала, плотности или массы.

  1. Параметр передается в чертеж при создании в нем ассоциативного разреза/сечения модели.

Подробнее о работе в диалоге...

Для завершения работы в диалоге с сохранением изменений нажмите кнопку ОК.

Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


Диалог задания параметров записи в PDF (текстовый документ, спецификация)

Диалог задания параметров записи в PDF
(текстовый документ, спецификация)

Этот диалог появляется на экране после нажатия кнопки Параметры при экспорте файла в PDF.

В диалоге можно настроить параметры записи текстового документа или спецификации в PDF.

Описание элементов управления

Элемент

Описание

Группа Параметры документа

Размер страницы, мм

Габариты изображения страницы в миллиметрах — размер, который будет иметь изображение, напечатанное без изменения масштаба.

Количество страниц документа

Общее количество страниц документа.

Текущая страница

Порядковый номер страницы, которая была текущей перед вызовом команды сохранения.

Группа Диапазон

Все страницы

Опция, включение которой означает, что будут записаны все страницы документа.

Текущая

Опция, включение которой означает, что будет записана только текущая страница документа.

Страницы

Поле, в котором можно ввести номера и/или диапазоны номеров страниц для записи. Например, «1, 3-5»

Сохранять

Список, позволяющий указать, какие страницы диапазона требуется записать: все, только четные или только нечетные.

Все страницы в один файл

Опция, позволяющая при сохранении документа сформировать один многостраничный файл, на каждой странице которого будет расположен один лист документа.

При выключенной опции для каждого листа создается отдельный файл формата PDF.

Группа Настройка

Цвет

Список, из которого можно выбрать цвет изображения. Доступны следующие варианты:

– Черный,

– Установленный для объекта.

Все линии тонкие

Опция, позволяющая записать все линии с толщиной, установленной для печати тонких линий в диалоге настройки системных линий. По умолчанию это значение (толщина на бумаге) составляет 0,18 мм.

Если эта опция выключена, то линии записываются с индивидуальными толщинами для печати.

Толщина линии на бумаге — параметр стиля линии. Для системных стилей он задается в диалоге настройки системных линий, а для пользовательских стилей — при их настройке.

Стиль линии содержит также параметр «толщина на экране». Его значение не влияет на результат экспорта.

Состояние опции Все линии тонкие не влияет на толщину линий шрифта.

Масштаб

Поле для ввода масштаба изображения.

Группа Параметры

Разрешение, точек на дюйм

Поле, в котором можно ввести или выбрать разрешение изображения.

Оттенки серого

Опция, позволяющая записать цветные оттенки оттенками серого цвета.

Встроить шрифты

Опция, позволяющая получить такой же вид текста в PDF-файле, как и в исходном документе.

Фильтр

Кнопка позволяет настроить фильтры вывода на печать. После вызова команды на экране появится диалог Установка фильтров вывода на печать. В созданном файле будут присутствовать только те объекты КОМПАС-документа, печать которых включена.

Сохранить настройки

Опция, позволяющая сохранить заданные настройки записи в формат PDF для дальнейшего использования.

После завершения настройки нажмите кнопку ОК. Для отказа от настройки нажмите кнопку Отмена.


Диалог задания параметров записи в растровый файл (текстовый документ, спецификация)

Диалог задания параметров записи
в растровый файл
(текстовый документ, спецификация)

Этот диалог появляется на экране, если при сохранении текстового документа или спецификации был выбран один из растровых форматов.

В диалоге можно настроить параметры записи в растровый файл.

При сохранении во все форматы, кроме формата TIFF, для каждого листа документа формируется отдельный растровый файл. Способ сохранения в формат TIFF определяется состоянием опции Многостраничный TIFF.

Описание элементов управления

Элемент

Описание

Группа Параметры документа

Размер страницы, мм

Габариты изображения страницы в миллиметрах — размер, который будет иметь изображение, напечатанное без изменения масштаба.

Количество страниц документа

Общее количество страниц документа.

Текущая страница

Порядковый номер страницы, которая была текущей перед вызовом команды сохранения.

Группа Диапазон

Все страницы

Опция, включение которой означает, что будут записаны все страницы документа.

Текущая

Опция, включение которой означает, что будет записана только текущая страница документа.

Страницы

Поле, в котором можно ввести номера и/или диапазоны номеров страниц для записи. Например, «1, 3-5»

Сохранять

Список, позволяющий указать, какие страницы диапазона требуется записать: все, только четные или только нечетные.

Многостраничный TIFF

Опция, позволяющая при сохранении документа в формате TIFF сформировать один многостраничный файл, на каждой странице которого будет расположен один лист документа.

При выключенной опции для каждого листа создается отдельный файл формата TIFF.

Для других форматов опция недоступна.

Группа Настройка

Цвет

Список, из которого можно выбрать цвет изображения. Доступны следующие варианты:

– Черный,

– Установленный для объекта.

Все линии тонкие

Опция, позволяющая записать все линии с толщиной, установленной для печати тонких линий в диалоге настройки системных линий. По умолчанию это значение (толщина на бумаге) составляет 0,18 мм.

Если эта опция выключена, то линии записываются с индивидуальными толщинами для печати.

Толщина линии на бумаге — параметр стиля линии. Для системных стилей он задается в диалоге настройки системных линий, а для пользовательских стилей — при их настройке.

Стиль линии содержит также параметр «толщина на экране». Его значение не влияет на результат экспорта.

Состояние опции Все линии тонкие не влияет на толщину линий шрифта.

Масштаб

Поле для ввода масштаба изображения.

Группа Параметры растра

Цветность

Список, позволяющий выбрать количество цветов.

Разрешение, точек на дюйм

Поле, в котором можно ввести или выбрать разрешение изображения.

Оттенки серого

Опция, позволяющая записать цветные оттенки оттенками серого цвета.

Количество оттенков серого будет тем больше, чем большая цветность установлена. Поэтому включение этой опции не равносильно выбору черно-белого способа записи, при котором оттенки серого цвета создаются путем «смешения» черных и белых пикселов.

Размер изображения

Габариты изображения страницы в точках. Эта величина зависит от заданного масштаба и разрешения.

После завершения настройки нажмите кнопку ОК, чтобы начать запись. Для отказа от записи нажмите кнопку Отмена.

Запись в растровые форматы подчиняется настройке фильтров вывода на печать. Т.е. в созданном файле рисунка будут присутствовать только те объекты КОМПАС-документа, печать которых включена.

Если появилось сообщение о невозможности записи...


Диалог задания параметров записи в файл формата EMF (текстовый документ, спецификация)

Диалог задания параметров записи
в файл формата EMF
(текстовый документ, спецификация)

Этот диалог появляется на экране, если при сохранении текстового документа или спецификации был выбран формат EMF.

В диалоге можно настроить параметры записи в файл выбранного формата.

Описание элементов управления

Элемент

Описание

Группа Параметры документа

Размер страницы, мм

Габариты изображения страницы в миллиметрах — размер, который будет иметь одна страница документа, напечатанная без изменения масштаба.

Количество страниц документа

Общее количество страниц документа.

Текущая страница

Порядковый номер страницы, которая была текущей перед вызовом команды сохранения.

Группа Диапазон

Все страницы

Опция, включение которой означает, что будут записаны все страницы документа.

Текущую страницу

Опция, включение которой означает, что будет записана только текущая страница документа.

Страницы

Поле, в котором можно ввести номера и/или диапазоны номеров страниц для записи. Например, «1, 3-5».

Сохранять

Список, позволяющий указать, какие страницы диапазона требуется записать: все, только четные или только нечетные.

Группа Настройка

Цвет

Список, из которого можно выбрать цвет изображения. Доступны следующие варианты:

– Черный,

– Установленный для объекта.

Все линии тонкие

Опция, позволяющая записать все линии с толщиной, установленной для печати тонких линий в диалоге настройки системных линий. По умолчанию это значение (толщина на бумаге) составляет 0,18 мм.

Если эта опция выключена, то линии записываются с индивидуальными толщинами для печати.

Толщина линии на бумаге — параметр стиля линии. Для системных стилей он задается в диалоге настройки системных линий, а для пользовательских стилей — при их настройке.

Стиль линии содержит также параметр «толщина на экране». Его значение не влияет на результат экспорта.

Состояние опции Все линии тонкие не влияет на толщину линий шрифта.

Масштаб

Поле для ввода масштаба изображения.

Размер изображения

Габариты изображения в точках. Эта величина зависит от заданного масштаба. При переводе размера изображения в миллиметрах в размер изображения в точках значение разрешения растра принимается равным 96 dpi.

После завершения настройки нажмите кнопку ОК, чтобы начать запись. Для отказа от записи нажмите кнопку Отмена.

Запись в формат EMF подчиняется настройке фильтров вывода на печать. Т.е. в созданном файле будут присутствовать только те объекты КОМПАС-документа, печать которых включена.

Поскольку величина файла в формате EMF предварительно оценивается в точках, может появиться сообщение о невозможности записи растрового файла (см. Условия, определяющие возможность записи). Чтобы экспорт был возможен, необходимо уменьшить масштаб изображения.

Смотрите также

Особенности записи КОМПАС-документов в формат EMF


Диалог Фильтр слоев(для модели)

Диалог Фильтр слоев
(для модели)

Этот диалог появляется на экране после нажатия на кнопку Создать фильтр в диалоге Менеджер документа.

Элементы управления диалога позволяют настраивать фильтр.

Описание элементов управления
Наименование | Описание
Название фильтра | Поле позволяет задать имя фильтра. По умолчанию создаваемому фильтру присваивается имя, состоящее из слова «Фильтр», к которому добавляется порядковый номер.
Условия | Таблица содержит набор условий фильтрации. Задание условий
Просмотр | Таблица содержит список слоев, свойства которых удовлетворяют условиям фильтрации. Пока не сформировано ни одного условия, в списке отображаются все слои объекта фильтра. Перечень динамически изменяется при изменении условий фильтрации.

Чтобы завершить формирование фильтра, следует нажать кнопку ОК. Диалог будет закрыт. Значок фильтра появится в Дереве модели слева. Чтобы закрыть диалог, отказавшись от сделанных изменений, нажмите кнопку Отмена.


Диалог создания и редактирования гиперссылок на место в документе

При нажатой кнопке Место в документе в диалоге отображаются элементы управления, позволяющие создать гиперссылку данного типа.

Окно Выберите место в документе служит для выбора объекта, на который создается гиперссылка.

Создание гиперссылки на место в документе...

Кнопка Удалить ссылку доступна в режиме редактирования гиперссылки и позволяет ее удалить. После нажатия этой кнопки диалог закрывается.

Кнопка ОК доступна, если произведено указание объекта.

Для подтверждения ввода параметров или сделанных изменений нажмите кнопку ОК диалога. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


Окно редактирования объекта спецификации

Это окно появляется на экране после вызова команды создания или редактирования объекта спецификации в графическом документе.

Оно оформлено в виде строки бланка спецификации, в которую можно ввести текстовую часть объекта спецификации.

После ввода текстовой части и настройки параметров объекта нажмите кнопку OK. Созданный объект будет зафиксирован в графическом документе, а окно его редактирования будет закрыто. Для закрытия окна без создания объекта спецификации (отказа от создания объекта) нажмите кнопку Отмена.


Диалог отключения библиотек

Позволяет отключить подключенную прикладную библиотеку или несколько библиотек.

В списке перечислены имена подключенных в данный момент библиотек. Вы можете выбрать из этого списка одну или несколько библиотек для отключения.

После завершения выбора нажмите кнопку ОК для отключения библиотеки. Для выхода из диалога без отключения нажмите кнопку Отмена.


Диалог добавления прикладной библиотеки

Этот диалог появляется на экране после вызова команды Подключить библиотеку.

Описание элементов управления
Наименование | Описание
Вкладка RTW | Предназначена для подключения rtw-библиотек. Чтобы подключить библиотеку, укажите нужный файл на диске, выберите режим работы и нажмите кнопку Открыть.
Вкладка ActiveX | Предназначена для подключения ActiveX-библиотек — библиотек, странслированных в VBasic. Каждая такая библиотека должна быть зарегистрирована в реестре. Для регистрации нажмите кнопку Добавить и в появившемся диалоге укажите нужный файл (файлы). В окне вкладки появится список зарегистрированных библиотек. Для удаления библиотек из реестра служит кнопка Удалить. Чтобы подключить ActiveX-библиотеку, выделите ее в списке зарегистрированных, выберите режим работы и нажмите кнопку Открыть.
Меню | Устанавливает режим работы с библиотекой как с разворачивающимся меню.
Диалог | Устанавливает режим работы с библиотекой как с диалогом.
Окно | Устанавливает режим работы с библиотекой как со стандартным окном Windows. В этом случае можно изменять размер окна библиотеки, а также сворачивать (минимизировать) его, оставляя на экране только пиктограмму.
Панель | Устанавливает режим работы с библиотекой как с панелью, содержащей несколько окон. Панель работы с библиотекой располагается на вкладке Менеджера библиотек.

Режим работы библиотеки, установленный при ее подключении, впоследствии может быть изменен.

К системе КОМПАС-3D одновременно может быть подключено не более 25 библиотек.


Открываемый файл редактируется другим пользователем или доступен только для чтения

Открываемый файл редактируется другим пользователем
или доступен только для чтения

Диалог появляется на экране, если в следующих случаях:

– открываемый файл в данный момент редактируется другим пользователем;

– открываемый файл имеет атрибут «только чтение» или у пользователя, пытающегося открыть файл, разрешения на запись или дозапись данных в него.

Если путь к файлу (в верхней части диалога) не виден полностью, то, чтобы просмотреть его, установите курсор в эту строку и нажмите клавишу <→> нужное число раз.

Элементы управления диалога позволяют выбрать действие.

Описание элементов управления
Элемент | Описание
открыть только для чтения | Вариант позволяет открыть файл только для чтения. Файл, открытый для чтения, можно редактировать, но нельзя сохранять под тем же именем в той же папке (т.е. с помощью команды Файл — Сохранить). При необходимости открытый для чтения файл можно сохранить, вызвав команду Файл — Сохранить как и задав другое имя и/или местоположение файла.
открыть только для чтения и уведомить, когда файл станет доступным | Вариант позволяет открыть файл только для чтения. После того как файл станет доступным, на экране появится диалог с сообщением об этом.
уведомить, когда файл станет доступным | Вариант позволяет отказаться от открытия файла. После того как файл станет доступным, на экране появится диалог с сообщением об этом и предложением открыть файл для редактирования.

Выберите нужный вариант действия и нажмите кнопку ОК диалога.

Нажатие кнопки Отмена или закрытие диалога кнопкой в правом верхнем углу означает отказ как от открытия файла, так и от уведомления.

Появление данного диалога можно отключить в диалоге установки прав доступа к файлам. После этого недоступные на момент открытия файлы будут загружаться для чтения без выдачи каких-либо сообщений.


Диалог подгонки масштаба документа

Предназначен для автоматического пересчета масштаба печати изображения при размещении изображения на фиксированном количестве страниц печати.

Этот диалог появляется на экране после вызова команды Сервис — Подогнать масштаб... или нажатия кнопки Подогнать масштаб... на инструментальной панели.

Описание элементов управления

Наименование

Описание

Листы документов

Справочное поле, содержащее перечень листов, выбранных для подгонки масштаба. Для каждого листа указаны имя файла документа, которому он принадлежит, и его номер в документе.

Количество страниц
по горизонтали,
Количество страниц
по вертикали

Введите, задайте с помощью счетчика или выберите из списка требуемое значение любого из параметров. Второй параметр будет вычислен автоматически.

Масштаб

Поле задания масштаба. Ввод произвольного значения масштаба не допускается — его можно выбирать только из списка. Помимо стандартных значений в нем перечислены те масштабы, которые были установлены ранее в процессе работы с этим диалогом.

При масштабировании одного листа поле доступно для задания масштаба, при масштабировании нескольких листов — недоступно (и пусто, если выбранные листы имеют разные исходные масштабы).

Общее количество страниц

Справочное поле, содержащее количество страниц печати для вывода документов с заданными параметрами.

Для вступления в силу выполненных настроек и закрытия диалога нажмите кнопку ОК. Изображение будет перерисовано в соответствии с новым значением масштаба. При необходимости в поле просмотра автоматически появятся новые страницы или будут удалены страницы, ставшие пустыми.

Для закрытия диалога без изменения масштаба нажмите кнопку Отмена.


Диалог настройки параметров вывода

Позволяет настроить параметры вывода листов документов на печать.

Этот диалог появляется на экране после вызова команды Настройка параметров вывода... одним из следующих способов:

– в главном окне — после выбора названия команды из меню Файл — Настройки предварительного просмотра или меню кнопки Предварительный просмотр, расположенной на Стандартной панели,

– в режиме предварительного просмотра — после выбора названия команды из меню Файл или нажатия кнопки Настройка параметров вывода на инструментальной панели.

Кроме того, в сокращенном виде диалог появляется после нажатия кнопки Параметры вывода... в диалоге печати документов. В этом случае доступна настройка следующих параметров: цвет вывода, вывод тонкими линиями, альтернативный способ вывода заливок и растров, точность вывода моделей.

Описание элементов управления

Наименование

Описание

Количество копий

Поле для ввода количества печатаемых копий документов, включенных в набор предварительного просмотра.

Копии в подбор

Опция, включение которой означает, что при печати нескольких копий изображения, размещенного на нескольких страницах печати, вначале будут последовательно напечатаны все страницы первой копии, затем — все страницы второй копии и так далее.

При отключенной опции вначале будут напечатаны все первые страницы копий, затем — все вторые страницы и так далее.

Вывести в файл

Опция, включение которой означает, что вывод выполняется не на устройство печати (принтер или плоттер), а в файл (с расширением prn). При этом в файл записывается последовательность команд управления устройством вывода, необходимых для печати заданного изображения.

Если при настройке принтера установлена печать в файл (в колонке Порт выбран вариант FILE), то опция Вывести в файл включается автоматически и становится недоступной, т.е. ее отключение невозможно.

Цвет вывода

Список позволяет выбрать вариант использования цветов при выводе документа на печать.

Выбор всех вариантов кроме варианта черный имеет смысл только при выводе цветного изображения на цветное устройство.

черный

При выборе этого варианта все линии и текст печатаются черным цветом, а заливки и растровые изображения — оттенками серого.

установленный для вида

При выборе этого варианта объекты, расположенные в разных видах, печатаются цветами, установленными для этих видов.

установленный для слоя

При выборе этого варианта объекты, расположенные на разных слоях, печатаются цветами, установленными для этих слоев.

установленный для объекта

При выборе этого варианта линии печатаются цветами, установленными для них в диалоге настройки системы, заливки и штриховки — цветами, установленными при их создании.

Изображения трехмерных объектов печатаются цветами, установленными при настройке свойств этих объектов.

Вывод тонкими линиями

Опция, включение которой означает, что все линии будут иметь толщину, установленную для тонких линий в диалоге настройки системы. По умолчанию это значение составляет 0,18 мм.

Состояние данной опции не влияет на толщину линий шрифта.

Альтернативный способ вывода заливок и растров

Если результат вывода на печать заливок, к которым применена прозрачность, и вставленных в документ растровых изображений с прозрачными областями выглядит неудовлетворительно, рекомендуется включить эту опцию. Если качество печати заливок и растров остается неудовлетворительным, рекомендуется вывести документ в растровый формат и печатать получившееся изображение.

Альтернативный способ вывода черно-белых растров

Если результат вывода на печать черно-белых растровых изображений, вставленных в графический документ, выглядит неудовлетворительно, рекомендуется включить эту опцию. Если качество печати растров остается неудовлетворительным, рекомендуется вывести документ в растровый формат и печатать получившееся изображение.

Точность вывода моделей

Элемент позволяет изменять точность вывода изображения модели на принтер.

Для изменения точности вывода перемещайте «ползунок» между позициями Грубо и Точно. При уменьшении точности вывода уменьшается разрешение растрового изображения модели, передаваемого на принтер. Чем выше точность, тем более «гладким» выглядит изображение и тем больше памяти требуется для его обработки.

При печати изображений большого размера могут возникать проблемы, связанные с переполнением памяти компьютера или принтера.

В случаях, когда трудности возникают при печати полутоновых изображений моделей больших размеров или сложной формы, рекомендуется уменьшать точность вывода.

В остальных случаях (проблемы с печатью документов, содержащих растр или имеющих большой формат) рекомендуется изменить настройку драйвера принтера.

Привязка к узлам страниц

Если опция включена, то при перемещении листов выполняется их привязка к узлам страниц устройства вывода.

Если опция отключена, то привязка не выполняется.

Включать и отключать привязку к узлам страниц можно и без вызова диалога настройки параметров вывода — с помощью кнопки Привязка к узлам страниц на инструментальной панели.

Оставлять зазор при привязке к углам листов и их автоматическом размещении

Если опция включена, то привязка углов листов друг к другу, добавление листов в предпросмотр и выполнение команды Сомкуть и выровнять листы производится с зазором, заданным в поле Зазор между листами, мм.

Если опция отключена, то зазор при привязке равен нулю.

Включать и отключать зазор можно и без вызова диалога настройки параметров вывода — с помощью кнопки Оставлять зазор между листами на инструментальной панели.

Радиус зоны чувствительности узла страниц, %

Радиус «зоны чувствительности» узла страниц в процентах от длины короткой стороны страницы.

Лист, угол которого попадает в «зону чувствительности» узла, может быть автоматически совмещен с этим узлом.

Зазор между листами, мм

Величина зазора (в миллиметрах) между сторонами листов.

Масштаб печати документов

По умолчанию

Поле для ввода масштаба, который будет использоваться по умолчанию для всех документов, открытых в режиме просмотра и добавленных в этот режим. В дальнейшем масштаб печати для каждого листа документа можно изменить.

Автоподгонка при переходе в предварительный просмотр

Опция включает автоподгонку масштаба листов документов. Автоподгонка производится при следующем входе в просмотр документов и при добавлении других документов в просмотр.

Порядок вывода страниц на печать

Разновидности порядка вывода страниц. Схема вывода, соответствующая каждому из вариантов, показана на пиктограмме.

Данная настройка позволяет соотнести расположение страниц на поле предварительного просмотра и последовательность их печати. Настройка порядка печати имеет смысл, если поле вывода состоит более чем из одной страницы.

Для вступления в силу выполненных настроек и закрытия диалога нажмите кнопку ОК.

Если был изменен цвет вывода, а также, если была включена или отключена опция Вывод тонкими линиями, изображение перерисовывается. Изменение умолчательного масштаба никак не отражается на уже открытых документах — заданное значение будет применено лишь к вновь добавленным в просмотр документам.

Если была включена печать в файл, то после вызова команды Печать на экране появится диалог, в котором потребуется задать имя файла и указать папку для его размещения.

Для закрытия диалога без применения выполненных настроек нажмите кнопку Отмена.


Диалог позиционирования технических требований

Позволяет точно разместить указанную страницу технических требований на листе чертежа.

Введите в соответствующих полях координаты левой, верхней, правой и нижней границ страницы технических требований. Значения границ вводятся в системе координат листа чертежа.

Для сохранения всех введенных значений и перестроения границ страницы техтребований нажмите кнопку ОК, для выхода из диалога без изменений — кнопку Отмена.


Диалог Оптические свойства

Позволяет задать оптические свойства поверхности объекта или слоя.

Диалог появляется после щелчка мышью по ячейке значения Оптические свойства в окне Свойства или при нажатии кнопки Оптические свойства слоя в Менеджере документа при работе со слоями.

Описание элементов управления
Наименование | Описание
Общий цвет Диффузия Зеркальность Блеск Прозрачность Излучение | Чтобы задать параметры, переместите на нужное расстояние соответствующий «ползунок». Числовое значение параметра будет отображаться в справочном поле.
 | В окне просмотра отображается сфера с заданными свойствами поверхности; это позволяет визуально оценить внесенные изменения.

Подробнее о задании оптических свойств...

Для подтверждения внесенных изменений нажмите кнопку OK. Если перед вызовом диалога было выделено несколько объектов с разными свойствами, то заданные свойства заменяют прежние в каждом из объектов.

Для выхода из диалога без внесения изменений нажмите кнопку Отмена.


Диалог печати документов

Позволяет установить нужные параметры печати текущего документа и вывести его на печать.

Этот диалог появляется на экране после вызова команды Файл — Печать... или нажатия кнопки Печать на Стандартной панели.

Описание элементов управления

Наименование

Описание

Устройство печати

Поле служит для отображения имени устройства, выбранного для печати.

Настройка...

Кнопка позволяет выбрать устройство печати и настроить его параметры. После нажатия кнопки на экране появляется стандартный диалог выбора и настройки устройства печати.

Команды меню кнопки Настройка... позволяют сохранить или загрузить конфигурацию устройства печати. Для вызова меню щелкните мышью по треугольнику, расположенному справа от кнопки.

Вывести в файл

Опция, включение которой означает, что вывод выполняется не на устройство печати (принтер или плоттер), а в файл (с расширением prn). При этом в файл записывается последовательность команд управления устройством вывода, необходимых для печати заданного изображения.

Если при настройке принтера установлена печать в файл (в колонке Порт выбран вариант FILE), то опция Вывести в файл включается автоматически и становится недоступной, т.е. ее отключение невозможно.

Копии

Количество

Поле позволяет ввести вручную или задать с помощью счетчика количество копий документа, которое необходимо напечатать.

Копии в подбор

Опция, включение которой означает, что при печати нескольких копий документа вначале будут напечатаны все листы первой копии, затем — все листы второй копии и так далее.

При отключенной опции вначале будут напечатаны все первые страницы копий, затем — все вторые страницы и так далее.

Диапазон листов

Все листы

Вариант позволяет напечатать все листы документа.

Текущий лист

Вариант позволяет вывести текущий (на момент вызова команды печати) лист многолистового документа. Текущим листом является:

– в текстовом документе — лист, на котором находится курсор,

– в спецификации — лист, на котором выделена строка,

– в чертеже — лист, расположенный так, что захватывает центр окна документа (номер этого листа отображается в списке листов на панели Управление листами).

Если документ не является многолистовым или содержит один лист, то Текущий лист — единственный доступный вариант в группе Диапазон листов.

Номера:

Вариант позволяет напечатать выбранные листы документа. Для выбора листов укажите их номера в поле. Вы можете ввести номера всех печатаемых листов, разделяя их запятыми, и/или задать диапазоны листов, например: 1, 3, 6-13, 17, 22-25.

Выводить

Раскрывающийся список позволяет указать, какие листы диапазона требуется напечатать: все листы диапазона, нечетные листы, четные листы.

Выделение

Вариант позволяет напечатать выделенную часть документа — область, охватывающую выделенные объекты (в графическом документе или модели), или выделенный фрагмент текста (в текстовом документе).

Если перед вызовом диалога в документе ничего не было выделено, а также если печатается спецификация, опция Выделение недоступна.

Подгонка масштаба листа

Список вариантов подгонки масштаба

Раскрывающийся список содержит названия способов автоматического вписывания листов документа в размер страницы печати принтера:

– Вписать в страницу,

– Обрезать по размеру страницы,

– Несколько листов на странице.

Масштаб листов

Поле, в котором отображается значение масштаба листов при печати; доступно для ввода при выборе способа Обрезать по размеру страницы. В остальных случаях в этом поле отображается автоматически рассчитанный масштаб.

Листов на странице

Поле для ввода или выбора из списка количества листов документа на одной странице печати.

Поле присутствует в диалоге, если печатается многолистовой документ и из списка способов подгонки выбран Несколько листов на странице.

Зазор, мм

Поле для ввода или выбора из списка расстояния между листами документа, размещенными на странице печати. Поле присутствует в диалоге, если печатается многолистовой документ и из списка способов подгонки выбран Несколько листов на странице.

Ориентация страницы

Группа опций позволяет задать ориентацию страницы печати — вертикальную или горизонтальную.

Выравнивание листов

Группа полей позволяет выбрать вариант выравнивания листов относительно краев страницы печати в вертикальном и горизонтальном направлениях. Нужный вариант выравнивания для каждого направления выбирается из соответствующего раскрывающегося списка.

Параметры вывода...

Кнопка позволяет вызвать диалог, в котором можно задать цвет вывода, точность вывода моделей, включить или отключить вывод тонкими линиями, включить или отключить альтернативный способ вывода заливок и растров.

Фильтры вывода...

Кнопка позволяет вызвать диалог установки фильтров вывода объектов документа на печать.

Просмотр

Окно служит для просмотра страниц печати — листов бумаги с учетом «мертвых зон» (областей у краев листа, которые принтер не может запечатать в силу своих конструктивных особенностей). Одна страница печати может содержать один или несколько листов документа (в зависимости от настройки). Для перехода между страницами служат кнопки навигации, расположенные в нижней части окна просмотра. Поле между кнопками содержит номер текущей страницы. Для быстрого перехода к нужной странице можно ввести ее номер в это поле.

Информация

Окно содержит справочную информацию о количестве и размерах печатаемых листов документа и страниц печати.

Если перед вызовом диалога печати в чертеже или текстовом документе было что-либо выделено, то автоматически отключается фильтр вывода элементов листа (рамок, основной надписи и т.п.). При необходимости вы можете включить фильтр. В этом случае в текстовом документе будут напечатаны элементы листа целиком, а в чертеже — только те их части, которые попадают в рамку, охватывающую выделенные объекты.

Если многолистовой документ содержит листы одного размера с разной ориентацией, то все они будут иметь ориентацию первого листа. Выбрать нужную ориентацию листов можно с помощью группы опций Ориентация страницы..

После установки всех параметров нажмите кнопку Печать для начала вывода документа. Чтобы закрыть диалог без вывода документа на печать, нажмите кнопку Отмена.


Диалог Редактор свойств

Этот диалог появляется на экране после вызова команды Редактор свойств.

Позволяет просматривать и редактировать свойства объектов в текущем документе, создавать и добавлять новые свойства, сохранять свойства в виде таблиц или выводить на печать.

Диалог Редактора свойств

Элемент

Описание

Окно просмотра

Окно, в котором отображаются объекты и их свойства в виде таблицы. Таблица содержит:

– столбцы со свойствами объекта;

– строки, в которых расположены значения свойств.

В столбце Наименование находится список объектов, имеющий структуру Дерева.

Ячейки, недоступные для редактирования, имеют серый фон.1

Значения свойств, заданные в документе, отображаются черным цветом. Значения, полученные по ссылке из источника или записанные операционной системой в файл, имеют синий цвет.

Группировка2

Позволяет сгруппировать объекты в окне Редактора.

Если кнопка нажата, объекты отображаются в сгруппированном виде, если отжата — в виде полного перечня.

В чертеже после щелчка мыши по треугольнику справа от кнопки появляется меню, в котором доступна команда Группировать по видам. После вызова команды объекты отображаются сгруппированными по своим видам. Подробнее...

Сортировка2

Позволяет отсортировать объекты в окне Редактора.

Если кнопка нажата, объекты каждого типа сортируются по алфавиту; если отжата — в порядке их создания.

Состав Дерева построения2

Позволяет управлять отображением групп объектов в столбце Наименование.

При нажатии кнопки на экране появляется меню, содержащее команды, одноименные группам. Чтобы включить или выключить отображение группы в столбце Наименование, вызовите нужную команду.

Уровень2

Позволяет задать уровень, до которого включительно отображаются объекты, составляющие модель.

Если кнопка нажата, то доступен список Уровень, в котором можно выбрать уровень.

Если кнопка отжата, то отображаются все уровни модели.

Элемент управления находится на панели диалога в сборках и чертежах.

Сохранить как...

Позволяет сохранить таблицу в виде отдельных документов следующих типов:

– КОМПАС-Чертежи (файл *.cdw),

– КОМПАС-Фрагменты (файл *.frw),

– КОМПАС-Текстовые документы (файл *.kdw),

– КОМПАС-Таблицы (файл *.tbl),

– Текстовые файлы (файл *.txt),

– Электронные таблицы ODF (файл *.ods),

– Электронные таблицы Microsoft Excel (файл *.xls).

После нажатия кнопки на экране появляется стандартный диалог сохранения файлов.

Выберите тип файла и введите имя файла. Подробнее...

Печать

Позволяет вывести на печать содержимое окна просмотра. После вызова команды на экране появится диалог, в котором необходимо задать параметры печати.

Параметры МЦХ

Кнопка присутствует в диалоге для документа-модели.

Позволяет задать значения массы, материала, плотности объекта и пересчитать МЦХ содержащей его модели. Кнопка доступна, если выделена ячейка со значением свойства Масса, Материал, Плотность. После нажатия кнопки на экране появляется диалог, в котором можно задать значения свойств объекта и пересчитать МЦХ.

Подробно о задании свойств и пересчете МЦХ...

Выбрать материал из списка

Позволяет выбрать материал из справочного файла плотностей (файл ...\ASCON\KOMPAS-3D V...\Sys\Grарhic.dns; значения плотностей материалов, содержащиеся в нем, могут редактироваться пользователем).

Кнопка доступна, если выделена ячейка со значением свойства Материал или Плотность. После нажатия кнопки на экране появляется диалог выбора плотности материала.

Подробно о задании свойств в графических документах...

Выбрать материал из справочника

Позволяет выбрать материал из внешнего Справочника (Справочник должен быть подключен к системе КОМПАС-3D).

Кнопка доступна, если выделена ячейка со значением свойства Материал или Плотность.

Вставить ссылку

Позволяет вставить ссылку в значении свойства. Кнопка доступна, если выделена одна ячейка. После нажатия кнопки на экране появляется диалог, в котором вы можете задать параметры ссылки.

Подробно о ссылках в значении свойств...

Исходный текст

Позволяет отменить редактирование ячейки таблицы.

Кнопка доступна, если выделена одна ячейка. После нажатия кнопки она приобретает тот вид, который имела после открытия диалога.

Отмена редактирования невозможна, если была разрушена ссылка или значения в ячейках свойств были заданы в диалогах, вызываемых из Редактора, например, Обозначение, Материал, Масса и другие.

Настройка столбцов3

Позволяет настроить список отображаемых свойств и порядок их следования в таблице. После нажатия кнопки на экране появляется диалог Настройка столбцов.

Подробно о настройке столбцов...
  1. Это не распространяется на ячейки Масса, Материал, Плотность в модели, значения которых можно редактировать.
  2. Настройки сохраняются до конца сеанса работы КОМПАС-3D.
  3. Настройка сохраняется до конца сеанса работы с моделью.

Для передачи изменений в документ или обновления ссылок нажмите кнопку Применить. В этом случае отказаться от изменений невозможно.

Для завершения работы в диалоге с сохранением изменений нажмите кнопку ОК.

Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.

Смотрите также

Отображение объектов в Редакторе

Выделение ячеек и строк

Редактирование значений

Особенности задания свойств


Предупреждение о наличии в файле DXF/DWG нечитаемых PROXY-объектов

Предупреждение о наличии в файле DXF/DWG
нечитаемых PROXY-объектов

Документы формата DXF или DWG могут содержать PROXY-объекты. Некоторые элементы, составляющие эти объекты, не могут быть импортированы в КОМПАС-3D.

Данное сообщение появляется в случае, если импортируемый документ содержит PROXY-объект, включающий в себя элемент (элементы), прочитать который невозможно.

Вы можете продолжить чтение документа. Для этого нажмите кнопку Да. Все объекты документа, за исключением PROXY-объекта, содержащего нечитаемые элементы, будут импортированы (в том числе PROXY-объекты, все элементы которых можно прочитать).

Чтобы отказаться от чтения документа, нажмите кнопку Нет.


Диалог запроса пароля на тип загрузки сборки

Диалог запроса пароля на тип загрузки сборки появляется при попытке выполнения следующих действий:

1. открытие защищенной сборки; открытие входящей в нее подсборки с защищенным типом загрузки с помощью команды Редактировать в окне,

2. применение защищенного типа загрузки,

3. удаление или редактирование защищенного типа загрузки, не являющегося примененным,

4. снятие запрета на редактирование компонента, который был наложен в результате применения защищенного типа загрузки (запрет обозначен в Дереве значком «щит» серого цвета).

При вводе неверного пароля выполнение перечисленных действий блокируется.

Пароль системных типов загрузки может использоваться вместо пароля любого пользовательского типа загрузки.

Поля Тип загрузки и Доступ доступны только в случае открытия сборки.

Из списка Тип загрузки можно выбрать другой тип загрузки. Если выбран незащищенный паролем тип загрузки, то поле Пароль становится недоступно.

Из списка Доступ можно выбрать вариант открытия файла: для редактирования или только для чтения.

Установка пароля производится при создании или редактировании типа загрузки.


Диалог подтверждения пароля

Введите пароль еще раз.

При неверном подтверждении пароля на экране появляется сообщение.


Диалог запроса пароля на доступ к детали

Диалог запроса пароля на доступ к детали появляется при попытке выполнения следующих действий с защищенной паролем деталью:

– открытие файла детали;

– вставка детали в другую модель в качестве компонента;

– переход к редактированию детали, являющейся:

• компонентом другой модели;

• заготовкой;

• источником изображения в ассоциативном виде чертежа.

При вводе неверного пароля выполнение перечисленных действий блокируется.

Из списка Доступ можно выбрать вариант открытия файла: для редактирования или только для чтения.

Установка пароля производится при создании или редактировании детали.


Диалог параметров чтения файла формата DXF/DWG в модель КОМПАС-3D

Этот диалог появляется на экране при чтении документа DXF/DWG в модель КОМПАС-3D.

Позволяет задать параметры импорта.

Описание элементов управления

Элемент

Описание

Исходный файл

В этом поле отображается полное имя импортируемого файла.

Результирующий файл

В этом поле отображается полное имя результирующего файла.

По умолчанию результирующий файл размещается в той же папке и имеет то же имя, что и импортируемый. При необходимости вы можете задать другую папку и имя файла. Для этого введите в данное поле нужный путь или укажите путь в диалоге, вызываемом кнопкой Выбрать в правой части поля.

Масштаб

Выберите из списка или введите значение коэффициента масштабирования трехмерных объектов.

Единицы измерения

Выберите нужные единицы измерения для импортируемых объектов: миллиметры или дюймы.

Сшивать поверхности

Опция, позволяющая сшивать поверхности.

– Если опция включена, то система пытается объединить импортированные поверхности. В результате возможно получение поверхности большей площади или тела (если исходная поверхность замкнута).

– Если опция выключена, то сшивка не производится, и результатом импорта являются поверхности, аналогичные исходным.

Обратите внимание на то, что состояние опции Сшивать поверхности влияет только на поверхности и не влияет на тела.

Завершив настройку параметров импорта, нажмите кнопку Начать чтение диалога.

Исходный файл всегда импортируется в файл сборки (*.a3d). Поэтому расширение файла в поле Результирующий файл — a3d.

Если исходный файл не содержит вставки блоков, то он будет прочитан как сборка, включающая тела и поверхности.

Если в исходном файле есть вставки блоков, то он импортируется как сборка, включающая тела, поверхности и компоненты — детали или подсборки, представленные самостоятельными файлами, при этом:

– компонент-деталь соответствует блоку, не содержащему в себе вставок других блоков;

– компонент-подсборка соответствует блоку, содержащему в себе вставки других блоков;

– имена файлов компонентов совпадают с именами блоков в исходном документе AutoCAD.

Объединение поверхностей (при включенной опции Сшивать поверхности) возможно только внутри одной модели. Поэтому сшивка может быть применена, например, к поверхностям, образованным геометрическими объектами с ненулевой трехмерной высотой, или к поверхностям, получившимся при построении таких объектов, как полигональная сеть (polygone mesh) и многогранная сеть (polyface mesh).


Сообщение о наличии в объекте ссылок на внешнюю модель

Сообщение о наличии в объекте ссылок
на внешнюю модель

Этот диалог появляется при попытке отредактировать элемент, который ссылается на объекты, находящиеся в другом файле и недоступные в данный момент.

Пример 1. При построении детали «на месте» (в контексте главной модели) к ней был приклеен элемент, выдавленный до грани соседней детали; в результате элемент выдавливания ссылается на объект из файла главной модели. В дальнейшем при редактировании детали в отдельном окне (вне контекста главной модели) грань, до которой выдавлен приклеенный элемент, оказывается недоступна (т.к. она находится в другом файле). Поэтому, если требуется изменить глубину выдавливания, вы можете указать только доступную в активном окне грань детали (т.е. превратить внешнюю ссылку во внутреннюю) или изменить способ определения глубины выдавливания (вместо выдавливания до грани выбрать выдавливание на расстояние).

Пример 2. При редактировании детали «на месте» в ней была создана ось, проходящая через вершины других деталей. В дальнейшем при редактировании детали в отдельном окне (вне контекста главной модели) вершины, через которые проведена ось, оказываются недоступны (т.к. они находятся в другом файле). Поэтому, если требуется изменить положение оси, то в качестве точечных объектов вы можете указать только доступные в активном окне объекты (т.е. превратить внешние ссылки во внутренние).

Пример 3. Деталь была создана в контексте главной модели путем объединения других — исходных — деталей. В дальнейшем при редактировании детали в отдельном окне (вне контекста главной модели) ее исходные детали оказываются недоступны (т.к. они находятся в другом файле). Поэтому при редактировании детали в отдельном окне вы можете лишь удалить элемент, полученный операцией «Объединение». Изменение формы этого элемента возможно только при редактировании в контексте главной модели.


Диалог смены режима работы прикладных библиотек

Позволяет изменить режим работы с подключенными прикладными библиотеками.

В списке перечислены имена подключенных в данный момент библиотек. Вы можете выбрать из этого списка одну или несколько библиотек для изменения режима работы.

Описание элементов управления
Наименование | Описание
Меню | Устанавливает режим работы с библиотекой как с разворачивающимся меню.
Диалог | Устанавливает режим работы с библиотекой как с диалогом.
Окно | Устанавливает режим работы с библиотекой как со стандартным окном Windows. В этом случае можно изменять размер окна библиотеки, а также сворачивать (минимизировать) его, оставляя на экране только пиктограмму.
Панель | Устанавливает режим работы с библиотекой как с панелью, содержащей несколько окон. Панель работы с библиотекой располагается на вкладке Менеджера библиотек.

После выбора библиотек из списка и установки нужного режима нажмите кнопку ОК. Для выхода из диалога без изменения режима работы с библиотекой нажмите кнопку Отмена.


Диалог иерархии отношений объекта

Позволяет просмотреть операции и объекты, которые являются исходными и производными для выделенного объекта.

Этот диалог появляется на экране после вызова команды Отношения.

В его верхней строке назван объект, для которого показываются отношения. Если перед вызовом команды Отношения была выделена вершина, грань или ребро, то отношения показываются для формообразующего или конструктивного элемента, которому принадлежит выделенный объект. Например, выделена грань фаски — отношения показываются для фаски, выделено ребро бобышки — отношения показываются для соответствующего приклеенного элемента выдавливания.

В первом окне диалога показана последовательность исходных для выбранного объекта операций и объектов. Операции и объекты перечислены в списке в порядке, необходимом для построения выбранного объекта. Список структурирован с учетом взаимосвязей между объектами и операциями. Каждый объект и операция в нем находятся на уровне, следующем за уровнем исходных для этого объекта или операции объектов.

Например, эскиз формообразующего элемента следует за элементом, на грани которого этот эскиз построен. Ось, проведенная через две вершины, следует за элементами, которым принадлежат эти вершины.

Во втором окне диалога показана последовательность производных от выбранного объекта операций и объектов. Операции и объекты перечислены в порядке их взаимосвязи: за каждым объектом или операцией следует построенный на его основе объект или выполненная на его основе операция.

Например, за операцией выдавливания следуют эскизы, построенные на гранях образованного этой операцией элемента.

Если команда была вызвана для компонента модели, во втором окне показываются производные от него объекты (например, плоскость, построенная с использованием одной или нескольких вершин этого компонента), а так же сопряжения, в которых участвует компонент (в порядке их наложения).

После просмотра иерархии объекта нажмите кнопку Выход диалога.

Смотрите также

Иерархическая параметризация модели

Иерархические параметрические связи объектов


Область просмотра иерархии отношений объекта

Эта область отображается в нижней части Дерева построения, если на инструментальной панели Дерева построения нажата кнопка Отношения.

В области просмотра отношений отображается объект, для которого показываются отношения, и два раздела: «Исходные объекты» и «Производные объекты».

– В разделе «Исходные объекты» показана последовательность объектов, исходных для выбранного. Объекты перечислены в списке в порядке, необходимом для построения выбранного объекта. Список структурирован с учетом взаимосвязей между объектами. Каждый объект в списке находится на уровне, следующем за уровнем его исходных объектов.

Например, эскиз формообразующего элемента следует за элементом, на грани которого этот эскиз построен. Ось, проведенная через две вершины, следует за элементами, которым принадлежат эти вершины.

– В разделе «Производные объекты» показана последовательность объектов, производных от выбранного. Объекты перечислены в порядке их взаимосвязи: за каждым объектом следует построенный на его основе объект.

Например, за операцией выдавливания следуют эскизы, построенные на гранях образованного этой операцией элемента.

Если для просмотра отношений выбран компонент, то в разделе «Производные объекты» показываются также сопряжения, в которых участвует компонент (в порядке их наложения).

В области просмотра отношений доступны такие же контекстные меню объектов, как и в Дереве построения. Из этих меню можно быстро вызвать часто используемые команды, например, редактирования или удаления объектов.

При выделении в Дереве построения другого объекта содержимое области просмотра иерархии отношений изменяется — в ней показываются объекты, являющиеся исходными и производными по отношению к вновь выбранному.

Иногда иерархия отношений объекта показывается не полностью. Это свидетельствует о том, что порядок построения модели был изменен вручную.

Пример...

Если в Дереве построения нет выделенных объектов или если выделено несколько объектов, то область просмотра отношений пуста.

По умолчанию область просмотра отношений занимает 30% высоты Дерева построения. При необходимости вы можете изменить размер области просмотра отношений, перемещая мышью ее верхнюю границу.

Смотрите также

Просмотр отношений объектов

Иерархическая параметризация модели

Иерархические параметрические связи объектов


<Файл> теперь доступен для редактирования

Данный диалог уведомляет о том, что документ, занятый на момент открытия (и потому открытый только для чтения), теперь стал доступен для редактирования.

Если путь к файлу (в верхней части диалога) не виден полностью, то, чтобы просмотреть его, установите курсор в эту строку и нажмите клавишу <→> нужное число раз.

Диалог появляется в случае, если в открытом для чтения документе были сделаны изменения.

Элементы управления диалога позволяют выбрать действие.

Описание элементов управления

Элемент

Описание

сохранить изменения под новым именем и открыть файл на редактирование

Вариант позволяет сохранить сделанные изменения, записав документ в файл с другим именем, а затем открыть ставший доступным документ.

После выбора этого варианта и нажатия кнопки ОК на экране появляется диалог для ввода нового имени файла. Задайте имя файла и нажмите кнопку Сохранить. Диалог закроется; автоматически откроется и станет текущим первоначальный файл. Таким образом, в КОМПАС-3D будут одновременно загружены два документа: ставший доступным документ, который вы пытались открыть ранее, и его копия, сохраненная под другим именем и содержащая сделанные вами изменения1.

открыть файл на редактирование без сохранения изменений

Вариант позволяет отказаться от сделанных изменений в открытом для чтения документе и открыть вместо него ставший доступным документ.
  1. Использование термина «копия» в данном контексте условно, так как, если документ был занят другим пользователем, то вполне возможно, что он отредактировал документ.

Выберите нужный вариант действия и нажмите кнопку ОК диалога.

Нажатие кнопки Отмена или закрытие диалога кнопкой в правом верхнем углу означает отказ как каких-либо действий КОМПАС-3D.


Сообщение об изменении совместно используемого файла

Это сообщение появляется на экране, если в диалоге настройки прав доступа включен контроль за изменением совместно используемых файлов и при выполнении контроля обнаружены изменения:

1. КОМПАС-документа, открытого на данном рабочем месте только для чтения,

2. документа-источника внешней ссылки (т.е. источника вставки фрагмента, вида, детали-заготовки или компонента).

Сообщение содержит полное имя файла и запрос на его перечитывание.

В первом случае:

– При нажатии кнопки Да документ будет как бы открыт заново — в том виде, в каком его в последний раз сохранил другой пользователь. При этом на вашем рабочем месте документ останется доступным только для чтения, но все изменения, произведенные в нем до перечитывания, будут потеряны.

– При нажатии кнопки Нет никаких изменений в открытом документе не произойдет.

Таким образом, если вы внесли в открытый для чтения документ изменения, которые требуется сохранить, нажмите кнопку Нет, а затем сохраните документ под новым именем. Если же вы не редактировали документ или сохранение изменений не требуется, нажмите кнопку Да.

Во втором случае:

– При нажатии кнопки Да источник вставки будет немедленно перечитан. Например, другой пользователь отредактировал фрагмент, вставленный в документ, с которым вы в данный момент работаете. В результате перечитывания источника изображение вставки будет перерисовано.

– При нажатии кнопки Нет немедленного перечитывания не произойдет. При последующем открытии документа, содержащего вставку, все изменения, произведенные в источнике вставки, будут безусловно переданы в открываемый документ.

Закрытие диалога кнопкой в правом верхнем углу в обоих случаях равносильно нажатию кнопки Нет.


Диалог Настройка столбцов

Диалог появляется на экране после нажатия кнопки Настройка столбцов в следующих диалогах:

– Редактор свойств,

– Менеджер документа при работе с исполнениями или с дополнительными номерами.

Позволяет сформировать набор и настроить порядок расположения свойств, отображаемых в таблице Редактора свойств/Менеджера документа.

Диалог настройки столбцов

Элемент

Описание

Доступные свойства

Окно, в котором находится список свойств документа, доступных для выбора.

Отображаемые свойства

Окно, в котором находится список свойств, выбранных для отображения в таблице Редактора свойств/Менеджера документа.

Перенести вправо/ Перенести влево

Кнопки позволяют перемещать свойства между окнами Доступные свойства и Отображаемые свойства.

Обратите внимание на то, что одно и то же свойство не может находиться одновременно в обоих окнах. При выделении свойства в одном из окон становится доступной та кнопка, которая позволяет переместить это свойство в другое окно.

Переместить вверх/вниз

Кнопки позволяют переместить выбранное свойство на одну позицию вверх или вниз в списке отображаемых свойств. Кнопки доступны, если свойство можно переместить на указанную позицию.

Порядок свойств в списке определяет их взаимное расположение в таблице Редактора свойств/Менеджера документа.

Управление свойствами

Кнопка позволяет изменить перечень свойств, доступных для выбора. Вызывает диалог Управление свойствами.

В появившемся диалоге вы можете добавить в документ свойство из библиотеки или создать новое свойство.

Подробно о настройке столбцов...

После завершения настройки столбцов нажмите кнопку ОК.


Диалог Создание/редактирование типа загрузки

Позволяет создавать/редактировать типы загрузки сборки.

Диалог Создание типа загрузки появляется на экране после нажатия кнопки Создать над списком Тип загрузки Панели свойств, а диалог Редактирование типа загрузки — кнопки Редактировать.

Описание элементов управления

Элемент

Описание

Наименование

В этом поле отображается наименование типа загрузки сборки.

Поле доступно при создании и редактировании пользовательского типа загрузки. Введите имя.

При редактировании системного типа загрузки поле недоступно.

Комментарий

В этом поле отображается комментарий.

Пароль

Поле для ввода пароля типа загрузки. При создании поле доступно, если пароль задан системным типам загрузки.

По умолчанию при создании поле пусто — пароль отсутствует, при редактировании защищенного типа загрузки в поле находятся символы по умолчанию.

– Чтобы защитить тип загрузки паролем, введите символы в поле.

– Чтобы сделать тип загрузки незащищенным, удалите все символы из поля, например, при помощи клавиши <Delete>.

– Чтобы отредактировать пароль, удалите все символы из поля и введите новый пароль.

Если вводить или редактировать пароль не требуется, то поле Пароль следует оставить без изменения.

Подробнее о защите паролем...

Обновить по текущему состоянию модели

Опция находится в диалоге при редактировании типа загрузки.

При включенной опции тип загрузки сборки формируется по текущему состоянию сборки, при выключенной — по состоянию сборки с примененным типом загрузки.

Состояние сборки определяется загрузкой ее компонентов, а также запретом на их редактирование.

Применить к модели

При включенной опции создаваемый/редактируемый тип загрузки будет применен к модели. Если опция выключена, то примененным типом загрузки остается тот же, что и до создания/редактирования.

После ввода параметров нажмите кнопку ОК. Если был задан новый пароль, введите его еще раз в появившемся диалоге.

Для выхода из диалога Создание/редактирование типа загрузки без изменения параметров нажмите кнопку Отмена.


Диалог Доступ к модели

Позволяет задать пароль на доступ к модели детали, изменить пароль или удалить его.

Диалог появляется на экране после вызова команды Доступ из контекстного меню детали, выделенной в Дереве построения.

Для задания или смены пароля введите нужные символы в поле Пароль и закройте диалог кнопкой ОК. Затем подтвердите пароль в появившемся диалоге, его тоже закройте кнопкой ОК.

Для удаления пароля удалите все символы из поля Пароль.

После задания, смены или удаления пароля сохраните файл модели.

Пароль, если он задан, будет запрашиваться каждый раз при загрузке файла модели.

Подробнее об установке пароля на доступ к модели...


Диалог настройки записи модели в файл детали

Этот диалог появляется на экране после вызова команды Сохранить с параметрами из контекстного меню кнопки Сохранить в диалоге выбора файла для записи. Данное меню становится доступным при сохранении сборки (*.a3d) или технологической сборки (*.t3d) в формат детали (*.m3d).

Диалог позволяет задать параметры преобразования.

Описание элементов управления

Элемент

Описание

Общие настройки

Группа опций для задания общих параметров преобразования.

Сохранять массу

Включите эту опцию, чтобы преобразованная модель имела ту же массу, что исходная. При отключенной опции масса преобразованной модели рассчитывается заново.

Сохранять центр масс

Включите эту опцию, чтобы центр масс преобразованной модели находился в той же точке, что и центр масс исходной модели. При отключенной опции координаты центра масс преобразованной модели вычисляются заново.

Учитывать скрытые компоненты

Если опция включена, то преобразуются как видимые, так и скрытые компоненты. В результате преобразования в тела они становятся видимыми, а в детали-заготовки — остаются скрытыми. При отключенной опции скрытые компоненты считаются отсутствующими.

Преобразования

Группа элементов для выбора нужного способа изменения структуры модели и настройки параметров в рамках выбранного способа. Если требуется сохранить модель без изменений, выберите вариант Специальное преобразование и отключите опции Удалить историю построения и Преобразовать компоненты (см. ниже).

Объединить тела и компоненты в одно тело

Выберите этот вариант, чтобы все тела и компоненты модели были объединены в одно тело.

Полученному телу назначается материал исходной сборки. Тело является сплошным, без внутренних полостей (эти полости заполняются материалом).

Если компоненты сборки не имеют ни одной общей поверхности, то в результате объединения получается тело из частей.

Специальное преобразование

Выберите этот вариант, чтобы настроить параметры преобразования структуры модели.

Удалить историю построения

Включите эту опцию для удаления из файла модели информации о способах создания объектов модели и связях между ними. В результате удаления истории построения:

– тела/поверхности/кривые превращаются в операции/поверхности/кривые без истории;

– массив превращается в набор объектов, расположенных согласно параметрам массива;

– локальные системы координат, контрольные и присоединительные точки заменяются обычными точками,

– эскизы, вспомогательные оси и плоскости, элементы оформления и сопряжения удаляются;

– компоненты фиксируются;

– если компонент был изменен операцией в содержащей его модели, то его тела и поверхности в отредактированном виде переносятся в модель, а сам компонент из нее удаляется.

Обратите внимание на то, что данная опция удаляет историю построения только тех объектов, которые принадлежат непосредственно преобразуемой модели, т.е. история построения компонентов сохраняется.

Преобразовать компоненты

Включите эту опцию, чтобы выполнить преобразование компонентов. При отключенной опции компоненты остаются без изменений.

Если удаление истории построения включено, то компоненты, затронутые операцией в содержащей их модели, преобразуются согласно вышеописанному вне зависимости от состояния опции Преобразовать компоненты.

В тела

Выбор этого варианта означает, что тела и поверхности компонентов всех уровней преобразуются в тела и поверхности без истории. Имена тел и поверхностей совпадают с именами соответствующих компонентов. Другие объекты компонентов в результирующую модель не передаются.

Если модель содержит операции над компонентами (например, массив компонентов), то после преобразования компонентов в тела эти операции удаляются, т.к. теряют источник построения. Удаление выполняется независимо от состояния опции Удалить историю построения.

В детали-заготовки

Выбор этого варианта означает, что компоненты первого уровня преобразуются в детали-заготовки. Если требуется, чтобы заготовки были внедрены в модель (а не вставлены ссылкой на внешние файлы), включите опцию Без истории.

Компоненты остальных уровней остаются без изменений.

Стандартные изделия и библиотечные компоненты не преобразуются в детали-заготовки.

Исключенные из расчета компоненты не учитываются в процессе преобразования. Они считаются отсутствующими.

В процессе преобразования сборки в деталь данные, связанные со спецификацией (описания спецификации, объекты спецификации и т.п.), удаляются. Полученная деталь не имеет связи со спецификацией. Сама спецификация не изменяется.

После завершения настройки параметров нажмите кнопку ОК. Для выхода из диалога без записи файла нажмите кнопку Отмена.


Запрос об изменении ссылки на компонент

При вставке в модель компонента из файла в этой модели создается ссылка на файл-источник компонента.

Если одновременно открыты файл модели и файл-источник компонента этой модели, то при попытке сохранить файл компонента под другим именем система запрашивает пользователя о том, на какой из файлов (прежний или переименованный) должна ссылаться модель.

Если вы хотите, чтобы модель ссылалась на файл с новым именем, нажмите кнопку Изменить ссылки. Это может понадобиться, например, для включения в модель отредактированного компонента и сохранения его первоначального варианта.

Если вы хотите, чтобы модель ссылалась на файл с прежним именем, нажмите кнопку Сохранить ссылки. Это может понадобиться, например, для сохранения отредактированного компонента без передачи его изменения в модель.

Чтобы отказаться от сохранения файла под другим именем, нажмите кнопку Отмена.

Ссылки изменяются лишь в открытых на данный момент моделях; в моделях, имеющих ссылки на этот же файл, но закрытых в момент его сохранения под другим именем, ссылки не изменяются.


Диалог выбора документа

В этом диалоге можно выбрать документ для того, чтобы:

– использовать объекты этого документа в других документах, а именно:

• вставить модель, хранящуюся в этом документе, в текущую модель в качестве компонента,

• вставить локальную деталь, входящую в этот документ, в текущую модель,

• использовать модель в качестве заготовки,

• создать в текущем чертеже один или несколько ассоциативных видов модели,

• использовать в качестве источника при создании ссылки на переменную;

– разместить в нем отчет или таблицу исполнений модели, создаваемую по текущей модели;

– отобразить его в режиме предварительного просмотра перед печатью.

Вы можете выбрать как открытый, так и закрытый в настоящий момент документ.

В диалоге отображается список имен открытых документов. Чтобы выбрать один из них, выполните следующие действия.

Выделите имя нужного документа в списке.

Содержимое выделенного документа показывается в окне просмотра. Вы можете отключить показ содержимого документа с помощью опции Выключить просмотр.

Если выбранный документ содержит исполнения модели и набор дополнительных номеров, то в правой части диалога отображаются раскрывающиеся списки обозначений исполнений и дополнительных номеров. Выберите обозначение нужного исполнения и дополнительный номер.

Для завершения выбора документа нажмите кнопку ОК.

Чтобы выбрать документ, файл которого в настоящее время закрыт, нажмите кнопку Из файла....

В появившемся на экране стандартом диалоге открытия файлов выберите нужный файл и нажмите кнопку Открыть.

Для предварительного просмотра вы можете выбрать один или сразу несколько документов, выделив их в списке или в диалоге открытия файлов. Опция Выделить все документы позволяет выбрать все документы.


Диалог Выберите один или несколько слоев(для модели)

Диалог Выберите один или несколько слоев
(для модели)

Этот диалог появляется на экране после вызова команды Выделить — По слою — Выбором....

В списке перечислены все слои модели и указаны их свойства. Выделите нужные слои в списке и нажмите кнопку ОК. Чтобы отказаться от выделения слоев, нажмите кнопку Отмена.


Диалог Выберите один или несколько слоев

Этот диалог появляется на экране после вызова команды Выделить — Слой — Выбором....

В списке перечислены все слои фрагмента или вида и указаны их свойства. Выделите нужные слои в списке и нажмите кнопку ОК. Чтобы отказаться от выделения слоев, нажмите кнопку Отмена.


Диалог Выберите один или несколько видов

Этот диалог появляется на экране после вызова команды Выделить — Вид — Выбором....

В списке перечислены все виды чертежа и указаны их свойства. Выделите нужные виды в списке и нажмите кнопку ОК. Чтобы отказаться от выделения видов, нажмите кнопку Отмена.


Диалог настройки границ

Этот диалог появляется на экране после вызова команды Таблицы — Границы....

Он позволяет управлять отображением и стилем линии границ текущей ячейки или выделенного диапазона ячеек таблицы.

В списке Стиль линий границ перечислены системные стили линий, которые могут быть использованы для границ ячеек. Текущий стиль выделен.

В поле Образец схематично отображается выделенный диапазон ячеек. Слева от поля и под ним расположены кнопки, соответствующие границам. Если отображение границы включено, то кнопка нажата, а если выключено — отжата. Включенные границы показываются на образце установленным для них стилем линии, а выключенные — серыми линиями. Если граница выделенного диапазона состоит из линий разного стиля, то она показывается на образце в виде толстой серой линии.

Чтобы выключить отображение границ текущей ячейки (или выделенного диапазона ячеек), отожмите кнопки, соответствующие этим границам, в диалоге настройки границ.

Совет...

Чтобы изменить стиль линии границы, выберите нужный стиль в списке. Если граница, стиль которой требуется изменить, выключена, нажмите соответствующую ей кнопку. Если граница, стиль которой требуется изменить, включена, отожмите соответствующую ей кнопку, а затем вновь нажмите ее.

Завершив настройку границ, нажмите кнопку ОК диалога.


Диалог Переменные

Этот диалог появляется на экране в следующих случаях:

– после выбора файла-источника при создании ссылки на переменную в Окне переменных,

– после вызова команды Выбрать переменную контекстного меню при редактировании поля Составление выражения в диалоге Вставка математического выражения,

– после нажатия кнопки Вставить переменную:

• в окне Таблица изменяемых переменных;

• в диалоге Менеджер документа при работе с исполнениями, с дополнительными номерами или с режимом пересчета.

– после нажатия кнопки Вставить имя переменной на Панели специального управления при построении кривой, заданной параметрическими уравнениями.

Поле в верхней части диалога содержит полное имя документа — источника переменных. В качестве документа-источника может использоваться графический документ или модель.

Если диалог вызван при создании ссылки на переменную, в нем доступна кнопка Файл-источник, позволяющая выбрать другой документ в качестве источника переменных. После нажатия кнопки на экране появляется стандартный диалог Windows открытия файлов.

В остальных случаях документом — источником переменных является текущий документ. Выбор другого документа недоступен.

В правой части диалога находится список Исполнение. Если документом-источником является модель с исполнениями, то в этом списке содержатся обозначения всех исполнений данной модели. Вы можете выбрать нужное исполнение из списка. Если документ-источник не содержит исполнений, то список недоступен.

В таблице переменных диалога отображаются переменные, доступные для выбора. Набор переменных соответствует документу-источнику.

Если документом-источником является модель с исполнениями, то в диалоге отображается набор переменных исполнения, обозначение которого выбрано из списка Исполнение.

Если диалог вызван при работе с дополнительными номерами в Менеджере документа, то он содержит только внешние переменные выбранного исполнения.

Чтобы выбрать нужную переменную, выделите любую ячейку в строке этой переменной и нажмите кнопку ОК. Чтобы отказаться от выбора переменной, нажмите кнопку Отмена.


Диалог Настройка столбцов (Окно переменных)

Диалог Настройка столбцов
(Окно переменных)

Этот диалог появляется на экране после вызова команды Сервис — Настроить столбцы из меню Окна переменных или команды Дополнительно... контекстного меню, вызываемого на заголовках столбцов.

Диалог позволяет включить/отключить отображение столбцов таблицы Окна переменных и изменить их взаимное расположение.

В диалоге содержится список всех столбцов таблицы, отображением и расположением которых можно управлять.

Для управления отображением столбца служит опция, находящаяся рядом с его наименованием в списке. Если опция включена, столбец отображается в окне, если опция отключена — не отображается. Вы можете настроить отображение нужных столбцов, включая и отключая опции.

Управление отображением столбца Пересчитанное значение доступно только при включенном режиме пересчета размеров с учетом допусков.

Для настройки взаимного расположения столбцов используются кнопки Вверх и Вниз. Порядок следования столбцов в списке определяет последовательность их расположения в таблице Окна переменных.

Чтобы завершить настройку столбцов, нажмите кнопку ОК.

Кнопка Отмена позволяет закрыть диалог, отказавшись от настройки.

Смотрите также

Настройка Окна переменных


Не найден файл с описанием формы

Это предупреждение появляется на экране при попытке импортировать файл формата DXF или DWG, содержащий формы (shape), если система не может загрузить файл, в котором описаны эти формы.

Файл с описанием формы (*.shx) может быть недоступен по разным причинам: либо он не существует вообще (например, файл с описанием формы удалили или при передаче файла формата DXF или DWG в другую организацию не передали вместе с ним файл с описанием формы), либо он существует под другим именем (например, файл с описанием формы переименовали), либо он находится по другому пути (например, при копировании файлов на другой компьютер изменились пути, по которым размещены файлы с описанием форм), либо файл поврежден.

Описание элементов управления

Наименование

Описание

В справочном поле диалога отображаются сведения о первой форме, описание которой не найдено. Если импортируется файл DXF, то это имя формы, а если DWG — индекс формы и путь к файлу с ее описанием.

Заменить

Если вы хотите указать, какой shx-файл требуется использовать, нажмите эту кнопку. В появившемся диалоге выберите нужный файл.

Игнорировать

Игнорировать все

Если вы хотите импортировать файл формата DXF или DWG, несмотря на отсутствие файла с описанием формы, нажмите кнопку Игнорировать или Игнорировать все.

Выбор кнопки Игнорировать означает, что в графическом документе КОМПАС будет отсутствовать изображение, соответствующее форме, описание которой не найдено.

Выбор кнопки Игнорировать все означает, что в графическом КОМПАС-документе будут отсутствовать изображения, соответствующие всем формам, описания которых не найдены.

Отказ от чтения

Нажмите эту кнопку, чтобы прервать импорт файла.


Диалог работы с прикладной библиотекой

Позволяет выбрать команду из прикладной библиотеки и выполнить ее.

В левой части диалога отображается список команд текущей библиотеки, которые могут быть сгруппированы по разделам. Чтобы развернуть содержание какого-либо раздела, установите курсор на значке плюса рядом с заголовком раздела и щелкните левой кнопкой мыши. Повторный щелчок на этом символе (после разворачивания раздела он отображается как минус) приведет к сворачиванию содержания раздела.

В правой части диалога могут отображаться слайды (если это предусмотрено разработчиком библиотеки), облегчающие поиск нужной команды.

Для запуска библиотечной команды на исполнение выберите ее название в списке и нажмите кнопку ОК. Можно также дважды щелкнуть левой кнопкой мыши на названии команды.

Чтобы изменить режим работы с библиотекой, нажмите кнопку Режим.

Вы можете отключить текущую библиотеку от системы, нажав кнопку Отключить.

Для завершения диалога работы с библиотекой без запуска какой-либо команды нажмите кнопку Отмена.

Смотрите следующие темы об использовании библиотек при работе с КОМПАС-3D:

Общие сведения о библиотеках

Подключение библиотеки

Режимы работы с библиотекой

Изменение режима работы с библиотекой

Выбор функции из библиотеки и ее запуск

Одновременная работа с несколькими библиотеками

Отключение библиотеки


Диалог Использование переменной

Этот диалог появляется на экране:

– после вызова команды Сервис — Использование переменной в Окне переменных,

– при попытке удаления переменной, участвующей в выражениях.

В диалоге отображается перечень объектов текущего документа, в которых используется выделенная в списке переменная.


Диалог задания параметров записи в PDF (чертеж, фрагмент)

Диалог задания параметров записи в PDF
(чертеж, фрагмент)

Этот диалог появляется на экране после нажатия кнопки Параметры при экспорте файла в PDF.

В диалоге можно настроить параметры записи чертежа или фрагмента в PDF.

Описание элементов управления

Элемент

Описание

Группа Параметры документа

Размер, мм

Габариты изображения в миллиметрах — размер, который будет иметь изображение, напечатанное без изменения масштаба.

Группа Настройка

Цвет

Список, из которого можно выбрать цвет изображения. Доступны следующие варианты:

– Черный,

– Установленный для объекта.

– Установленный для вида (при записи чертежей),

– Установленный для слоя.

Все линии тонкие

Опция, позволяющая записать все линии с толщиной, установленной для печати тонких линий в диалоге настройки системных линий. По умолчанию это значение (толщина на бумаге) составляет 0,18 мм.

Если эта опция выключена, то линии записываются с индивидуальными толщинами для печати.

Толщина линии на бумаге — параметр стиля линии. Для системных стилей он задается в диалоге настройки системных линий, а для пользовательских стилей — при их настройке.

Стиль линии содержит также параметр «толщина на экране». Его значение не влияет на результат экспорта.

Состояние опции Все линии тонкие не влияет на толщину линий шрифта.

Масштаб

Поле для ввода масштаба изображения.

Группа Параметры

Разрешение, точек на дюйм

Поле, в котором можно ввести или выбрать разрешение изображения.

Оттенки серого

Опция, позволяющая записать цветные оттенки оттенками серого цвета.

Встроить шрифты

Опция, позволяющая получить такой же вид текста в PDF-файле, как и в исходном документе.

Фильтр

Кнопка позволяет настроить фильтры вывода на печать. После вызова команды на экране появится диалог Установка фильтров вывода на печать. В созданном файле будут присутствовать только те объекты КОМПАС-документа, печать которых включена.

Сохранить настройки

Опция, позволяющая сохранить заданные настройки записи в формат PDF для дальнейшего использования.

После завершения настройки нажмите кнопку ОК. Для отказа от настройки нажмите кнопку Отмена.


Диалог задания параметров записи в растровый файл

Диалог задания параметров записи
в растровый файл

Этот диалог появляется на экране, если при сохранении КОМПАС-документа был выбран один из растровых форматов.

В диалоге можно настроить параметры записи в растровый файл.

Описание элементов управления

Элемент

Описание

Группа Параметры документа

Размер, мм

Габариты изображения в миллиметрах — размер, который будет иметь изображение, напечатанное без изменения масштаба.

Группа Настройка

Цвет

Список, из которого можно выбрать цвет изображения. Доступны следующие варианты:

– Черный,

– Установленный для объекта.

При записи графических документов доступны также варианты:

– Установленный для вида,

– Установленный для слоя.

Все линии тонкие

Опция, позволяющая записать все линии с толщиной, установленной для печати тонких линий в диалоге настройки системных линий. По умолчанию это значение (толщина на бумаге) составляет 0,18 мм.

Если эта опция выключена, то линии записываются с индивидуальными толщинами для печати.

Толщина линии на бумаге — параметр стиля линии. Для системных стилей он задается в диалоге настройки системных линий, а для пользовательских стилей — при их настройке.

Стиль линии содержит также параметр «толщина на экране». Его значение не влияет на результат экспорта.

Состояние опции Все линии тонкие не влияет на толщину линий шрифта.

Масштаб

Поле для ввода масштаба изображения.

Цветность

Список, позволяющий выбрать количество цветов1.

Разрешение, точек на дюйм

Поле, в котором можно ввести или выбрать разрешение изображения2.

Оттенки серого

Опция, позволяющая записать цветные оттенки оттенками серого цвета.

Количество оттенков серого будет тем больше, чем большая цветность установлена. Поэтому включение этой опции не равносильно выбору черно-белого способа записи, при котором оттенки серого цвета создаются путем «смешения» черных и белых пикселов.

Размер изображения

Габариты изображения страницы в точках. Эта величина зависит от заданного масштаба и разрешения.
  1. Так как размер растрового файла пропорционален количеству цветов, высокую цветность рекомендуется использовать только для записи трехмерных моделей — это позволит корректно передать цветовые переходы.
    Записав файл, просмотрите его в соответствующем растровом редакторе. Если цветовые переходы выглядят недостаточно «гладкими», увеличьте цветность и запишите файл снова.
  2. Так как размер растрового файла пропорционален разрешению, большое разрешение рекомендуется использовать для записи документов, содержащих мелкие детали и контуры значительной кривизны — это позволит передать их с минимальными потерями.
    Записав файл, просмотрите его в соответствующем растровом редакторе. Если качество изображения вас не удовлетворит, увеличьте разрешение и запишите файл снова.

После завершения настройки нажмите кнопку ОК, чтобы начать запись. Для отказа от записи нажмите кнопку Отмена.

Запись в растровые форматы подчиняется настройке фильтров вывода на печать. Т.е. в созданном файле рисунка будут присутствовать только те объекты КОМПАС-документа, печать которых включена.

Если появилось сообщение о невозможности записи...


Диалог запроса на изменение объекта

Этот диалог сообщает об отсутствии в спецификации объекта, существующего в сборочном чертеже. В строке просмотра показаны обозначение и наименование этого объекта.

Нажмите кнопку Удалить текстовую часть, если необходимо удалить из чертежа информацию об объекте спецификации, но оставить соответствующие ему геометрические объекты.

Нажмите кнопку Удалить объект из сборки, если необходимо удалить из чертежа информацию об объекте спецификации и соответствующие ему геометрические объекты. Удаление геометрических объектов произойдет только в случае, если при настройке спецификации была включена опция Удалять геометрию при удалении объекта спецификации. Если эта опция была выключена, действие кнопки Удалить объект из сборки будет аналогично действию кнопки Удалить текстовую часть.

Нажмите кнопку Добавить объект в спецификацию, если необходимо перенести существующий в сборочном чертеже объект в спецификацию.

Активизируйте опцию Дальнейшие изменения вносить в спецификацию без запросов, если хотите, чтобы выбранное действие (удаление объекта из сборочного чертежа или его перенос в спецификацию) распространялось на все рассогласованные объекты открываемой спецификации.


Диалог запроса на изменение объекта

Этот диалог сообщает об отсутствии в сборочном чертеже объекта, существующего в спецификации. В строке просмотра показаны обозначение и наименование этого объекта спецификации.

Нажмите кнопку Удалить объект из спецификации, если необходимо привести спецификацию в соответствие со сборочным чертежом, или кнопку Восстановить объект в сборке, если удалять объект из спецификации не нужно (в этом случае объект попадет в чертеж при синхронизации спецификации с чертежом).

Активизируйте опцию Дальнейшие изменения вносить в спецификацию без запросов, если хотите, чтобы выбранное действие (удаление объекта из спецификации или восстановление объекта в сборочном чертеже) распространялось на все рассогласованные объекты открываемой спецификации.


Диалог запроса при сохранении спецификации под другим именем

Так как документ (чертеж или модель сборки) не может быть подключен к нескольким спецификациям одного стиля, при сохранении спецификации под другим именем требуется указать, какая из спецификаций — исходная или скопированная — должна сохранить связь с документом.

Активизация опции Листы сборки и объекты переподключить к новой спецификации означает, что с чертежом или моделью будет связана новая спецификация, а в исходной останутся только объекты спецификации.

Активизация опции Скопировать объекты в новую спецификацию означает, что с чертежом или сборкой будет по-прежнему связана исходная спецификация, а в новую будут скопированы объекты спецификации.

В любом случае в спецификации, не имеющей связи с документом, останутся текстовые части ее объектов и дополнительные параметры. Ее можно будет редактировать в текстовом режиме.

Выбрав вариант сохранения спецификации, нажмите кнопку ОК. Для выхода из диалога без сохранения спецификации нажмите кнопку Отмена.


Диалог запроса на изменение основной надписи

Этот диалог появляется при открытии спецификации, связанной двунаправленной связью с подключенным документом, если обнаруживается рассогласование обозначения и (или) наименования изделия в спецификации и документе (сборочном чертеже или модели сборки). В соответствующих строках просмотра показаны обозначение и наименование, содержащиеся в основной надписи спецификации и в документе (основной надписи чертежа или свойствах модели).

Если обозначение и наименование изделия в спецификации должны быть такими же, как в подключенном документе, нажмите кнопку Взять данные из документа сборки.

Если обозначение и наименование должны остаться такими, какие они есть в спецификации, нажмите кнопку Взять данные из спецификации.


Диалог выбора спецзнака

Этот диалог появляется на экране после вызова команды Вставка — Спецзнак....

В нем можно выбрать нужный специальный знак для вставки в текст.

В левой части диалога отображается каталог доступных спецзнаков (они сгруппированы по тематическим разделам). Для того чтобы развернуть содержание какого-либо раздела, установите курсор на значке плюса рядом с заголовком раздела и щелкните левой кнопкой мыши. Повторный щелчок на этом символе (после разворачивания раздела он отображается как минус) приведет к сворачиванию содержания раздела.

Спецзнак, на котором находится курсор, отображается в окне просмотра в правой части диалога.

Вы можете подключить другой набор спецзнаков. Для этого нажмите кнопку Другой набор и в появившемся диалоге выберите нужный файл. Наборы спецзнаков хранятся в системных файлах *.sss.

После того как нужный спецзнак выбран, нажмите кнопку ОК для его вставки в текст. Можно также дважды щелкнуть левой кнопкой мыши на названии спецзнака. Для выхода из диалога без вставки спецзнака нажмите кнопку Отмена.


Диалог задания параметров записи в файл формата EMF

Диалог задания параметров записи
в файл формата EMF

Этот диалог появляется на экране, если при сохранении КОМПАС-документа был выбран формат EMF.

В диалоге можно настроить параметры записи в файл выбранного формата.

Описание элементов управления

Элемент

Описание

Группа Параметры документа

Размер, мм

Габариты изображения в миллиметрах — размер, который будет иметь изображение, напечатанное без изменения масштаба.

Группа Настройка

Цвет

Список, из которого можно выбрать цвет изображения. Доступны следующие варианты:

– Черный,

– Установленный для объекта.

При записи графических документов доступны также варианты:

– Установленный для вида,

– Установленный для слоя.

Все линии тонкие

Опция, позволяющая записать все линии с толщиной, установленной для печати тонких линий в диалоге настройки системных линий. По умолчанию это значение (толщина на бумаге) составляет 0,18 мм.

Если эта опция выключена, то линии записываются с индивидуальными толщинами для печати.

Толщина линии на бумаге — параметр стиля линии. Для системных стилей он задается в диалоге настройки системных линий, а для пользовательских стилей — при их настройке.

Стиль линии содержит также параметр «толщина на экране». Его значение не влияет на результат экспорта.

Состояние опции Все линии тонкие не влияет на толщину линий шрифта.

Масштаб

Поле для ввода масштаба изображения.

Размер изображения

Габариты изображения в точках. Эта величина зависит от заданного масштаба. При переводе размера изображения в миллиметрах в размер изображения в точках значение разрешения растра принимается равным 96 dpi.

После завершения настройки нажмите кнопку ОК, чтобы начать запись. Для отказа от записи нажмите кнопку Отмена.

Запись в формат EMF подчиняется настройке фильтров вывода на печать. Т.е. в созданном файле будут присутствовать только те объекты КОМПАС-документа, печать которых включена.

Поскольку величина файла в формате EMF предварительно оценивается в точках, может появиться сообщение о невозможности записи растрового файла (см. Условия, определяющие возможность записи). Чтобы экспорт был возможен, необходимо уменьшить масштаб изображения.

Смотрите также

Особенности записи КОМПАС-документов в формат EMF


Диалог создания основной надписи

Этот диалог появляется на экране после нажатия кнопки Редактировать... в диалоге работы с основными надписями.

Позволяет создать новую или отредактировать уже существующую основную надпись (штамп) для оформления документов. Штамп создается как набор обычных таблиц, для которых установлены правила размещения на листе.

Описания основных надписей хранятся в специальных системных библиотеках — файлах с расширением *.lyt.

Описание элементов управления
Наименование | Описание
Наименование | В этом поле можно ввести или отредактировать название основной надписи.
Номер | В этом поле можно ввести или отредактировать номер основной надписи.
Состав основной надписи | В этом поле отображается список названий таблиц, из которых состоит штамп.
Наименование таблицы | В этом поле отображается название текущей таблицы в списке.
Привязка | В этом разделе устанавливаются правила размещения на листе текущей таблицы из списка. В окне просмотра в правой части диалога условно (без соблюдения размеров) показана настраиваемая основная надпись. Текущая (выделенная в списке) таблица подсвечена в окне просмотра. Указанная в диалоге опорная точка на листе также подсвечена. При изменении перечисленных ниже параметров привязки изменяется начертание основной надписи в окне просмотра.
Опорная точка на листе | Список для выбора точки привязки таблицы на листе.
Опорная точка в таблице | Список для выбора точки в таблице, которая будет совмещаться с опорной точкой на листе.
Сдвиг по горизонтали | Поле для ввода смещения по горизонтали опорной точки таблицы относительно опорной точки на листе.
Сдвиг по вертикали | Поле для ввода смещения по вертикали опорной точки таблицы относительно опорной точки на листе.
Поворот таблицы | Выберите из списка угол поворота таблицы против часовой стрелки (кратный 90 градусам) относительно ее опорной точки. Опция Относительно длинной стороны используется в особых случаях.
Редактировать | Нажмите эту кнопку, чтобы внести изменения в выделенную в списке таблицу основной надписи.
Добавить | Нажмите эту кнопку для создания новой таблицы, входящей в штамп.
Удалить | Нажмите эту кнопку, чтобы исключить выделенную в списке таблицу из состава основной надписи.

Завершить работу в диалоге можно нажатием кнопки ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


Диалог Параметры таблицы исполнений

Этот диалог появляется на экране в следующих случаях:

– автоматически после вызова команды создания таблицы исполнений,

– после нажатия кнопки Настроить... на Панели свойств при создании или редактировании выбранной таблицы исполнений модели,

– после нажатия кнопки Настроить... на Панели свойств при создании или редактировании выбранной таблицы дополнительных номеров.

Диалог позволяет настроить параметры таблицы исполнений (дополнительных номеров). Доступны следующие настройки:

– формирование набора отображаемых свойств,

– настройка параметров отображения значений свойств,

– создание или изменение «шапки» таблицы.

Описание элементов управления

Наименование

Описание

Окно настройки

Окно позволяет настроить параметры отображения свойств. Содержит перечень отображаемых свойств, представленный в виде таблицы.

Каждый столбец таблицы соответствует определенному свойству. Эти свойства отображаются в созданной таблице исполнений (дополнительных номеров) в том же порядке, что и в окне настройки.

Строки таблицы содержат элементы управления для настройки отображения свойств. Каждая строка позволяет выполнить определенную настройку. Названия настроек приведены слева от окна, а параметры настройки — в ячейках таблицы.

Вы можете добавлять, изменять расположение и удалять столбцы со свойствами, используя кнопки инструментальной панели диалога (см. ниже).

Каждый новый столбец создается с умолчательными настройками. Настройте параметры отображения свойств для новых столбцов и, при необходимости, для уже имеющихся.

Тип таблицы

Раскрывающийся список позволяет выбрать тип создаваемой таблицы — Таблица исполнений или Таблица дополнительных номеров. Содержимое окна настройки диалога соответствует выбранному типу; элементы и порядок настройки идентичны для таблиц обоих типов.

Добавить столбец
слева/справа

Кнопка позволяет добавить столбец с умолчательными настройками слева/справа от выбранного столбца (для выбора столбца достаточно щелкнуть мышью в любой из его ячеек).

Если ни один из столбцов таблицы не выбран, то новый столбец добавляется в крайнее левое/правое положение в таблице.

Удалить столбец

Кнопка позволяет удалить выбранный столбец. Становится доступной при активизации любого из столбцов.

Переместить столбец
вправо/влево

Кнопка позволяет переместить выбранный столбец влево/вправо на одну позицию. При этом перемещаемый столбец меняется местами с соседним столбцом.

Кнопка доступна, если слева/справа от выбранного столбца имеется хотя бы один столбец.

Высота строк, мм

Поле позволяет задать высоту строк таблицы.

Заголовок...

Кнопка позволяет сформировать «шапку» таблицы. Вызывает диалог Заголовок таблицы.

Для завершения настройки параметров таблицы нажмите кнопку ОК. Кнопка Отмена позволяет закрыть диалог, отказавшись от настройки.


Диалог Оформление

Диалог появляется на экране после нажатия кнопки Оформление в диалоге Параметры стиля отчета.

Позволяет настроить параметры оформления в стиле отчета.

Описание элементов управления

Элемент

Описание

Строить снизу вверх

Опция, позволяющая управлять размещением строк в отчете. Если опция выключена, то заголовок и строки следуют сверху вниз.

Если опция включена, то заголовок помещается на нижней строке и строки следуют снизу вверх.

Отображать заголовок

Группа элементов, позволяющая управлять размещением в отчете заголовков столбцов.

Если опция Отображать заголовок включена, то на каждой странице таблицы помещается строка с заголовками, заданными в поле Имя столбца диалога Параметры стиля отчета. Высота строки отображается в поле Высота строки заголовка таблицы, мм.

Если опция выключена, то строка отсутствует.

Высота строки заголовка таблицы, мм1

Поле для ввода или задания счетчиком высоты строки заголовка.

Высота строки ячейки таблицы, мм

Поле для ввода или задания счетчиком высоты строк.

Нумерация столбцов

Группа элементов, позволяющая управлять нумерацией столбцов. Если опция Нумерация столбцов выключена, то строка с номерами отсутствует.

Если опция включена, то в таблицу автоматически добавляется первая строка с номерами столбцов. Нумерация задается с параметрами, отображенными в полях Формат номера и Начинать с.

Формат номера1

Список, из которого можно выбрать формат номера — буквы или цифры.

Начинать с1

Поле для ввода или задания счетчиком начального номера в нумерации столбцов.

Нумерация строк

Группа элементов, позволяющая управлять нумерацией строк. Если опция Нумерация строк выключена, то столбец с номерами отсутствует.

Если опция включена, то в таблицу автоматически добавляется первый столбец с заголовком «N» и номерами строк.Выполняется одноуровневая или многоуровневая нумерация, в зависимости от выбранного варианта.

Одноуровневая1

Вариант нумерации, при выборе которого все строки в отчете нумеруются подряд в порядке возрастания.

Многоуровневая1

Вариант нумерации, при выборе которого строки нумеруются внутри каждого уровня отдельно. Выполняется для моделей, содержащих компоненты. Например, в сборке компоненты первого уровня будут иметь номера 1, 2, 3, ..., а входящие в них компоненты — номера 1.1, 1.2, 1.3, ..., 2.1, 2.2, 2.3, ..., 3.1, 3.2, 3.3, ... и т.д.

Разбивать на страницы

Группа элементов, позволяющая управлять разбиением таблицы на страницы.

Если опция Разбивать на страницы включена, то таблица автоматически разбивается на несколько страниц с равным количеством строк в каждой. Количество строк отображается в поле Строк на страницу. По умолчанию на последней странице нет пустых строк.

Если опция выключена, то отчет представляет собой одну таблицу.

Строк на страницу1

Поле для ввода или задания счетчиком количества строк таблицы на одной странице.

Оставлять пустые строки1

Опция, позволяющая задавать вид последней станицы. Если опция включена, то на последней странице могут отображаться строки после последнего объекта, оставшиеся пустыми.
  1. Элемент управления доступен, если включена опция в данной группе.

После настройки параметров оформления нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


Диалог Параметры стиля отчета

Позволяет настроить параметры стиля отчета и сохранить его в библиотеку стилей.

Этот диалог появляется на экране:

– после нажатия кнопки Создать стиль в диалоге работы с библиотеками стиля;

– после нажатия кнопки Настроить... на Панели свойств команды Создать отчет, в том числе и в Окне подготовки данных.

Описание элементов управления

Элемент

Описание

Имя стиля

Поле, в котором отображается имя стиля.

Введите имя стиля, под которым его требуется сохранить в библиотеку.

Идентификатор

Справочное поле, содержащее уникальный номер, который система автоматически присваивает создаваемому стилю. Данный номер будет отображаться в диалоге при последующем просмотре или редактировании сформированного стиля.

Окно настройки

Окно, в котором отображаются настройки стиля в виде таблицы. Таблица содержит

– столбцы по количеству свойств объекта — название свойства находится в первой строке таблицы;

– строки, в ячейках которых расположены элементы управления для настройки каждого свойства — название настройки находится слева от окна, а результат настройки отображается в ячейке.

Для стиля По умолчанию в столбцах заданы свойства Обозначение, Наименование, Количество, Масса, для стиля По всем свойствам — все локальные свойства документа.

При создании нового стиля окно пусто. Чтобы заполнить окно, нажмите кнопку Добавить столбец слева/справа нужное количество раз и отредактируйте настройки для каждого столбца.

Добавить столбец
слева/справа

Кнопка, после нажатия которой столбец с умолчательными настройками добавляется слева/справа от текущего. Если окно пусто, то в нем появляется столбец со свойством Обозначение.

Удалить столбец

Кнопка, после нажатия которой текущий столбец удаляется.

Переместить столбец
вправо/влево

Кнопка, после нажатия которой текущий столбец перемещается вправо/влево, меняясь местами с рядом стоящим столбцом. Кнопка доступна, если слева/справа от текущего в таблице имеется хотя бы один столбец.

Заголовок...

Кнопка для вызова диалога, в котором можно настроить «шапку» отчета. Вызывает диалог Заголовок таблицы.

Оформление

Кнопка для вызова диалога, в котором можно настроить параметры оформления отчета.

Сохранить в библиотеку как...

Кнопка для вызова диалога сохранения стиля в библиотеку стилей. В появившемся диалоге укажите файл существующей библиотеки или введите имя новой библиотеки. Стиль будет сохранен под именем, заданным в поле Имя стиля.

Настройки текущего стиля сохраняются до конца сеанса работы КОМПАС-3D.

После настройки параметров нажмите кнопку ОК. Кнопка доступна, если в стиле имеется хотя бы один столбец.

Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.

Если изменение стиля производится во время работы с отчетом в Окне подготовки данных, то для отображения сделанных изменений необходимо вызвать команду перестроения отчета.

Перестроение фактически является повторным созданием отчета, поэтому, если отчет был изменен вручную (редактировался/форматировался текст, добавлялись/удалялись строки и т.п.), то после перестроения эти изменения теряются.


Диалог Сортировка данных в отчете

Диалог появляется на экране после щелчка мыши на поле Сортировка в диалоге Параметры стиля отчета.

Позволяет настроить параметры сортировки данных в отчете.

Элементы управления окна настройки параметров
Элемент | Описание
Уровень 1 Уровень 2 Уровень 3 | Список, из которого можно выбрать свойство, участвующее в сортировке. В списке доступны все свойства стиля. Вариант Нет означает отказ от сортировки.
А-Я Я-А По списку | Опции, позволяющие выбрать вариант расположения объектов внутри группы. А-Я — в алфавитном порядке или по возрастанию чисел, Я-А — в обратном алфавитном порядке или по убыванию чисел, По списку — в порядке, отображенном в списке значений свойства. Опция доступна, если в списке Уровень выбрано свойство, при задании параметров которого в диалоге Параметры свойства установлен список значений.

После настройки сортировки нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


Диалог Параметры таблицы отчета по массиву

Позволяет настроить параметры таблицы отчета по массиву с таблицей изменяемых переменных.

Диалог вызывается при создании или редактировании отчета по массиву:

– автоматически после выбора массива;

– нажатием кнопки Настроить... на вкладке Отчет по массиву Панели свойств.

Подробнее о создании отчета по массиву...

Описание элементов управления

Наименование

Описание

С заголовком

Опция, управляющая заголовком таблицы отчета по массиву. Если опция включена, то таблица отображается с заголовком, если опция отключена — без заголовка.

Окно настройки

Окно, в котором отображаются параметры отображения таблицы. Таблица содержит столбцы, соответствующие столбцам таблицы изменяемых переменных. Каждая строка позволяет выполнить определенную настройку. Названия настроек приведены слева от окна, а параметры настройки — в ячейках таблицы.

Вы можете:

– добавлять, менять местами и удалять столбцы с переменными (см. ниже);

– настраивать параметры отображения переменных для столбцов таблицы.

Высота строк, мм

Поле позволяет задать высоту строк таблицы.

Заголовок...

Кнопка позволяет сформировать «шапку» таблицы. Вызывает диалог Заголовок таблицы.

Добавить столбец
слева/справа

Кнопка позволяет добавить столбец с умолчательными настройками слева/справа от выбранного столбца (для выбора столбца достаточно щелкнуть мышью в любой из его ячеек).

Если ни один из столбцов таблицы не выбран, то новый столбец добавляется в крайнее левое/правое положение в таблице.

Удалить столбец

Кнопка позволяет удалить выбранный столбец. Становится доступной при активизации любого из столбцов.

Переместить столбец
вправо/влево

Кнопка позволяет переместить выбранный столбец влево/вправо на одну позицию. При этом перемещаемый столбец меняется местами с соседним столбцом.

Кнопка доступна, если слева/справа от выбранного столбца имеется хотя бы один столбец.

После настройки свойств таблицы нажмите кнопку ОК. Кнопка доступна, если в стиле имеется хотя бы один столбец. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


Менеджер стилей линий

Служит для управления списком стилей линий документа.

Менеджер стилей линий появляется на экране после:

– нажатия кнопки Изменить список... в диалоге настройки стилей линий,

– нажатия кнопки Менеджер стилей... в диалоге выбора стиля линии.

По умолчанию Менеджер стилей линий открывается в свернутом виде, т.е. отображается только его левая часть. Она содержит список стилей линий. Стили отмечаются значками:

– системный стиль,

– внедренный в документ стиль,

– библиотечный стиль.

Если библиотечный стиль потерял связь с библиотекой, то к его значку добавляется восклицательный знак в красном кружке.

В списке стилей линий текущего документа к значкам может добавляться «галочка», показывающая, что стиль задействован в документе, т.е. является используемым.

Правая часть Менеджера стилей линий появляется после нажатия кнопки Добавить стили. Эта часть служит для выбора библиотеки (или набора) стилей и включения стилей из нее в список стилей документа.

Описание элементов управления

Элемент

Описание

Создать

Кнопка, позволяющая создать стиль. Новый стиль добавляется в список стилей документов как внедренный стиль.

После нажатия этой кнопки на экране появляется диалог создания или редактирования стиля кривой.

Редактировать

Кнопка, позволяющая отредактировать выбранный стиль.

Доступна, если в списке стилей документа выбран внедренный стиль.

После нажатия этой кнопки на экране появляется диалог создания или редактирования стиля кривой.

Удалить

Кнопка, позволяющая удалить выбранный стиль (стили).

Доступна, если в списке стилей документа выбран не используемый стиль (стили) — внедренный или библиотечный.

После нажатия этой кнопки на экране появляется диалог, в котором вы можете подтвердить удаление или отказаться от него.

Фильтр

Список фильтров для списка стилей документа:

– Показать все,

– Системные стили,

– Внедренные стили,

– Библиотечные стили,

– Используемые стили,

– Не используемые стили.

Чтобы применить фильтр, выберите его из списка Фильтр. В списке стилей останутся только те стили, которые соответствуют фильтру.

Добавить стили

Кнопка, позволяющая добавить в список стилей документа стили из библиотеки или набора. После ее нажатия в Менеджере стилей линий появляется дополнительная область с элементами управления.

Для закрытия этой области следует нажать кнопку Добавить стили повторно.

Показать библиотеку

Кнопка для выбора библиотеки стилей линий. После ее нажатия на экране появляется диалог, в котором следует указать файл библиотеки стилей линий (*.lcs) и нажать кнопку Открыть.

Перечень библиотечных стилей линий появится в окне просмотра.

Показать набор

Кнопка для выбора набора стилей линий. После ее нажатия на экране появляется диалог, в котором следует указать имя набора и нажать кнопку Выбрать.

Перечень стилей линий набора появится в окне просмотра.

Добавить библиотечный стиль

Позволяет добавить в список стилей документа один или несколько библиотечных стилей.

Доступна, если в списке библиотечных стилей имеются выделенные стили. После нажатия этой кнопки выбранные стили включаются в список документа как библиотечные.

Библиотечные стили сохраняют связь с файлами библиотек, откуда они были добавлены в документ.

Внедрить стиль в документ

Позволяет внедрить в документ один или несколько библиотечных стилей или стилей из набора.

Доступна, если в списке библиотечных стилей или стилей из набора имеются выделенные стили. После нажатия этой кнопки выбранные стили включаются в список документа как внедренные.

Стили, внедренные в документ из библиотек, не сохраняют связей с файлами этих библиотек.

Завершив настройку списка стилей линий документа, нажмите кнопку ОК. Для выхода из Менеджера стилей линий без сохранения изменений нажмите кнопку Отмена.


Диалог настройки оформления текстового документа

Позволяет создать или отредактировать стиль оформления текстового документа. В оформление входят внешняя и внутренняя рамки документа, а также основная надпись.

Этот диалог появляется на экране после нажатия кнопки Создать или Редактировать диалога Работа со стилями оформлений текстовых документов.

Описание элементов управления

Наименование

Описание

Имя

В этом поле вы можете ввести название, под которым будет храниться стиль оформления.

Номер

В этом поле вы можете ввести уникальный номер стиля оформления.

Внешняя рамка

В этом разделе настраиваются параметры внешней рамки. Если отрисовывать ее не нужно, выключите опцию.

Линия

Выберите из списка нужный стиль отрисовки линий внешней рамки.

Внутренняя рамка

В этом разделе настраиваются параметры внутренней рамки. Если отрисовывать ее не нужно, выключите опцию.

Линия

Выберите из списка нужный стиль отрисовки линий внешней рамки.

Отступы от внешней рамки

Задайте величины отступов линий, образующих внутреннюю рамку, от внешней рамки документа.

Поля текста

В этой группе задаются расстояния между соответствующими сторонами внутренней рамки и границами поля ввода. От границы поля ввода отсчитываются значения отступов и красной строки текста.

Основная надпись

В этом разделе выбирается основная надпись для документа.

В поле отображается название текущей основной надписи. Чтобы подключить к оформлению другую основную надпись, нажмите кнопку с многоточием справа от поля.

На экране появится диалог со списком основных надписей, содержащихся в текущей библиотеке оформлений. Выберите нужное оформление и нажмите кнопку ОК диалога.

Если основную надпись отрисовывать не нужно, выключите опцию.

После завершения настройки оформления нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


Окно Библиотекаря текстовых шаблонов

Это окно появляется на экране после вызова команды Вставка — Текстовый шаблон.

Окно Библиотекаря текстовых шаблонов включает следующие элементы:

– строку меню,

– инструментальную панель,

– вкладки.

Каждая вкладка Библиотекаря соответствует одному файлу шаблонов (*.tdp). Она содержит три области:

– список разделов этого файла шаблонов,

– список пунктов выделенного раздела,

– полный текст выделенного шаблона.

Вы можете изменить размеры областей, перемещая мышью их границы.

Отметьте нужные пункты шаблона, щелкнув мышью на значке рядом с названием пункта. Выбранные пункты будут отмечены красной «галочкой».

Чтобы скопировать выбранные пункты в текст, нажмите кнопку Вставить в документ на инструментальной панели Библиотекаря или вызовите соответствующую команду из меню Библиотекаря Файл.

Использование команд меню


Диалог Выбор параметров стандартной резьбы

Диалог появляется на экране после нажатия кнопки Выбор параметров стандартной резьбы.

Позволяет выбрать параметры стандартной резьбы.

В справочном поле Стандарт в верхней части диалога содержится список стандартных резьб. Список стандартных резьб определяется настройками в диалоге, вызываемом командой Сервис — Параметры... — Система — Общие для документов — Параметры резьбы.

Ниже, в столбцах таблицы, содержатся значения параметров резьбы:

– номинальный диаметр,

– шаг,

– внутренний диаметр,

– обозначение резьбы.

Для некоторых резьб в таблице присутствует столбец с номером ряда.

1. Выберите наименование стандартной резьбы из списка.

2. Выделите строку с нужными значениями параметров.

3. Нажмите кнопку OK.

Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


Диалог Заголовок таблицы

Этот диалог появляется на экране:

– после нажатия кнопки Заголовок... в диалоге Параметры стиля отчета,

– после нажатия кнопки Заголовок... в диалоге Параметры таблицы исполнений,

– после нажатия кнопки Заголовок... в диалоге Параметры таблицы отчета по массиву.

Диалог позволяет сформировать «шапку» следующих таблиц:

– отчетов;

– таблицы исполнений;

– таблицы отчета по массиву.

Описание элементов управления
Наименование | Описание
Поле настройки «шапки» | В поле отображается сформированная «шапка» таблицы. По умолчанию поле содержит только строку заголовков столбцов, заданных при настройке параметров таблицы. Вы можете добавлять строки выше строки с заголовками столбцов и удалять добавленные строки; объединять и разбивать ячейки; вводить и изменять текст в ячейках.
Объединить ячейки | Кнопка позволяет объединить выделенные ячейки.
Разбить ячейки | Кнопка позволяет разбить текущую ячейку или диапазон выделенных ячеек таблицы на несколько ячеек. Вызывает диалог Разбиение ячеек.
Вставить строку сверху/снизу | Кнопка позволяет добавить строку сверху/снизу от текущей. Строки могут быть добавлены только выше строки заголовков столбцов. Поэтому, если текущей является эта строка, кнопка Вставить строку снизу недоступна.
Удалить строку | Кнопка позволяет удалить текущую строку. Удаление доступно только для добавленных строк.

После выполнения всех необходимых действий в диалоге нажмите кнопку ОК. Кнопка Отмена позволяет закрыть диалог, отказавшись от изменений.

Сформированная «шапка» таблицы не отображается в диалоге настройки параметров таблицы. В диалог передаются только изменения текста заголовков столбцов.

Смотрите также

Приемы работы с таблицами


Диалог поиска текста и раздела в файле текстового шаблона

Позволяет указать текст (в том числе часть строки) или название раздела (в том числе часть названия), которые требуется найти в текущем файле текстового шаблона, и задать правила поиска.

Введите в строку диалога текст для поиска. Укажите, в какой части файла нужно производить поиск — с начала файла или от указателя. Укажите, что требуется найти — текст в разделах или раздел. Включите опцию С учетом регистра, если регистр символов в найденном тексте должен совпадать с регистром введенных символов для поиска. Для начала поиска нажмите кнопку OK. После того как найден первый текст, содержащий введенную последовательность символов, можно продолжить поиск, нажав кнопку Искать далее.

Для выхода из диалога нажмите кнопку Отмена.


Диалог Обозначение(ввод обозначения при задании свойств объектов)

Диалог Обозначение
(ввод обозначения при задании свойств объектов)

Служит для ввода и редактирования составного обозначения документа или объекта (в том числе исполнения модели). Заданный текст становится значением системного свойства Обозначение для документа или объекта.

Этот диалог появляется на экране в следующих случаях:

– при создании исполнения или преобразовании объекта в деталь — после щелчка мыши в поле Обозначение на Панели свойств,

– при работе со списком свойств документа или объекта на Панели свойств — двойным щелчком мыши в ячейке свойства Обозначение или командой Редактировать обозначение контекстного меню этой ячейки,

– при работе в Редакторе свойств или в Менеджере документа — двойным щелчком мыши в ячейке свойства Обозначение или нажатием кнопки с многоточием в правой части выделенной ячейки.

Диалог может содержать следующие поля ввода частей обозначения: Базовое обозначение, Номер исполнения, Дополнительный номер исполнения и Код. Набор полей зависит от того, для какого документа или объекта вызывается диалог.

Код, заданный в модели, передается в спецификацию, созданную по данной модели, и не передается в ассоциативный чертеж модели.

Примеры кода модели:

– МД — Электронная модель детали,

– МС — Электронная модель сборочной единицы.

Внесите необходимые изменения в содержимое полей. Базовое обозначение, номер и дополнительный номер исполнения вводятся с клавиатуры. Код документа можно ввести с клавиатуры или выбрать из списка кодов диалога Коды и наименования. Данный диалог вызывается командой Вставить код и наименование... контекстного меню поля Код или двойным щелчком мыши в этом поле.

При изменении базового обозначения и кода для исполнения модели обратите внимание на особенности передачи изменений в другие исполнения.

При изменении номера исполнения имейте в виду, что номер должен быть уникальным в пределах документа. В противном случае завершение работы в диалоге с сохранением изменений невозможно.

Между частями обозначения имеются разделители, заданные по умолчанию (при работе с моделью умолчательные разделители можно указать при настройке). Вы можете ввести вместо умолчательного разделителя один произвольный символ.

Обратите внимание на то, что разделителем перед полем Код по умолчанию является пробел. Чтобы изменить разделитель, введите произвольный символ в соответствующее поле диалога Обозначение. Если требуется создать обозначение без разделителя, удалите пробел.

Разделители, заданные по умолчанию, не включаются в готовое обозначение, если соответствующая часть обозначения не задана.

Если в качестве разделителей введены другие символы, то они безусловно включаются в обозначение.

Обратите внимание на то, что разделитель между базовым обозначением и номером исполнения обязательно должен присутствовать в обозначении. Если разделитель удаляется (поле оставляется пустым), то после закрытия диалога в обозначении восстанавливается удаленный разделитель.

Для завершения работы в диалоге с сохранением изменений нажмите кнопку ОК.

Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.

Составное обозначение «превращается» в простое, если очистить в диалоге поля с номером исполнения, дополнительным номером и кодом (разделители должны быть системными или отсутствовать).


Диалог удаления/разрушения видов

Этот диалог появляется на экране после вызова команды удаления вида (видов) или разрушения ассоциативного вида (видов).

В нем перечислены удаляемые/разрушаемые виды, а также виды, которые затрагивает операция удаления/разрушения (при удалении/разрушении вида чертежа удаляются/разрушаются базирующиеся на нем виды по стрелке, выносные элементы, разрезы и сечения).

Вы можете отказаться от удаления/разрушения или подтвердить его.

Для быстрой отмены ошибочного удаления/разрушения вида нажмите кнопку Отменить на Стандартной панели или комбинацию клавиш <Alt>+<BackSpace> либо <Ctrl>+<Z>. Удаленный/разрушенный вид будет немедленно восстановлен.


Диалог иерархии отношений видов

Позволяет просмотреть виды, которые являются исходными и производными для выделенного вида.

Этот диалог появляется на экране после вызова команды Отношения.

В его верхней строке назван вид, для которого показываются отношения.

В первом окне диалога показана последовательность исходных видов для выбранного вида. Список исходных видов структурирован с учетом взаимосвязей между ними.

Например, вид, содержащий разрез, следует за видом, на котором изображен след секущей плоскости, соответствующий этому разрезу. Проекционный вид следует за своим опорным видом.

Во втором окне диалога показана последовательность видов, производных от выбранного вида. Производные виды перечислены в порядке их взаимосвязи: за каждым из них следует вид, построенный на его основе.

Например, список из трех стандартных видов выглядит так: на первом уровне списка расположен главный вид, на втором уровне — проекционные виды сверху и слева.

Исходные и производные виды могут существовать только у ассоциативных видов. Виды, не являющиеся ассоциативными (системный вид и все пользовательские виды), не связаны между собой отношениями иерархии.

При выделении вида в диалоге иерархии отношений в окне чертежа подсвечивается габаритная рамка этого вида и изображение в нем. Это облегчает просмотр иерархии видов и анализ взаимосвязей между ними.

После просмотра иерархии вида нажмите кнопку Выход диалога.


Диалог Специальная печать документа

Позволяет установить нужные параметры специальной печати текущего документа и вывести его на печать.

Этот диалог появляется на экране после вызова команды Файл — Специальная печать... или нажатия кнопки Специальная печать на Стандартной панели.

Описание элементов управления

Наименование

Описание

Устройство печати

Поле служит для отображения имени устройства, выбранного для печати.

Настройка...

Кнопка позволяет выбрать устройство печати и настроить его параметры. После нажатия кнопки на экране появляется стандартный диалог выбора и настройки устройства печати.

Команды меню кнопки Настройка... позволяют сохранить или загрузить конфигурацию устройства печати. Для вызова меню щелкните мышью по треугольнику, расположенному справа от кнопки.

Диапазон листов

Все листы

Вариант позволяет напечатать все листы документа.

Номера

Вариант позволяет напечатать выбранные листы документа. Для выбора листов укажите их номера в поле. Вы можете ввести номера всех печатаемых листов, разделяя их запятыми, и/или задать диапазоны листов, например: 1, 3, 6-13, 17, 22-25.

Выводить

Раскрывающийся список позволяет указать, какие листы диапазона требуется напечатать: все листы диапазона, нечетные листы, четные листы.

Выделение

Вариант позволяет напечатать выделенную часть документа — область, охватывающую выделенные объекты (в графическом документе или модели), или выделенный фрагмент текста (в текстовом документе).

Если перед вызовом команды специальной печати в документе ничего не было выделено, а также если печатается спецификация, опция Выделение недоступна.

Параметры вывода...

Кнопка позволяет вызвать диалог, в котором можно задать цвет вывода, точность вывода моделей, включить или отключить вывод тонкими линиями, включить или отключить альтернативный способ вывода заливок и растров.

Фильтры вывода...

Кнопка позволяет вызвать диалог установки фильтров вывода объектов документа на печать.

Если перед вызовом диалога специальной печати в чертеже или текстовом документе было что-либо выделено, то автоматически отключается фильтр вывода элементов листа (рамок, основной надписи и т.п.). При необходимости вы можете включить фильтр. В этом случае в текстовом документе будут напечатаны элементы листа целиком, а в чертеже — только те их части, которые попадают в рамку, охватывающую выделенные объекты.

После установки всех параметров нажмите кнопку Печать для начала вывода документа. Чтобы закрыть диалог без вывода документа на печать, нажмите кнопку Отмена.

Подробнее о специальной печати...


Что неверно?

В этом диалоге перечислены ошибки, возникшие при перестроении выбранного объекта или всего документа (модели или чертежа).

Ошибки отображаются в диалоге в виде структурированного списка. Описание каждой ошибки находится на уровне, следующем за названием ошибочного объекта.

Если вы просматриваете все ошибки в модели, то ее ошибочные элементы (формообразующие элементы, вспомогательные оси и плоскости, копии, фаски, оболочки и т.д.) в списке находятся на уровне, следующем за названием модели.

Справочная система содержит рекомендации по возможным путям устранения ошибки.

Чтобы получить разъяснение конкретной ошибки и общие рекомендации по ее устранению, выделите описание ошибки в диалоге и нажмите кнопку Справка.

Для закрытия диалога нажмите кнопку Выход.


Список выделенных объектов

Список выделенных объектов отображается в нижней части вкладки Зоны в Дереве модели.

В списке содержатся все выделенные в модели объекты независимо от способа выделения.

Команды, вызванные из контекстного меню любого объекта списка, применяются ко всему списку.


Команда Автосоздание объекта

Включает или выключает режим автоматического создания объектов.

В этом режиме (при нажатой кнопке) объект создается без дополнительного подтверждения сразу же после того, как вводится минимально необходимый набор его параметров.

Для вызова команды Автосоздание объекта можно также использовать комбинацию клавиш <Ctrl> + <Shift> + <Enter>.

Смотрите также

Автоматическое и ручное создание объектов


Команда Создать объект

Фиксирует создаваемый или редактируемый объект.

Для вызова команды можно выбрать ее название из меню Редактор или из контекстного меню.

Кроме того, можно воспользоваться кнопкой Создать объект на Панели специального управления.

Если для объекта включено автосоздание, то он фиксируется автоматически, и вызов команды Создать объект не требуется.

Если команда Создать объект недоступна, это говорит о том, что либо количество заданных параметров недостаточно для построения объекта, либо при текущем сочетании значений параметров построение невозможно.


Команда Создать из графического фрагмента...

Позволяет создать таблицу из файла, содержащего фрагмент.

После вызова команды на экране появляется диалог, в котором можно выбрать файл *.frw, содержащий изображение таблицы.

Выбрав файл, нажмите кнопку Открыть, после чего начнется автоматическое формирование таблицы из указанного фрагмента.

Для выхода из диалога без создания таблицы нажмите кнопку Отмена.

При автоматической генерации таблицы из графического фрагмента учитываются все существующие в нем тексты, горизонтальные отрезки и вертикальные отрезки. Другие объекты в формировании таблицы не участвуют. Стили текстов и отрезков сохраняются в получившейся таблице (в виде стилей текстов ячеек и стилей обрамления ячеек).


Команда Загрузить из файла таблиц...

Позволяет загрузить таблицу КОМПАС, сохраненную в специальном формате в файле *.tbl.

После вызова команды на экране появляется диалог, в котором можно указать нужный файл *.tbl.

Выбрав файл, нажмите кнопку Открыть, после чего произойдет загрузка указанной таблицы.

Для выхода из диалога без создания таблицы нажмите кнопку Отмена.


Команда Следующий объект

Появляется в том случае, если возможны несколько вариантов построения объекта (например, окружностей, касательных к двум кривым).

Для вызова команды нажмите кнопку Следующий объект на Панели специального управления или выберите ее название из контекстного меню.

После этого текущим становится следующий вариант создаваемого объекта.

Вы можете также выбрать другой вариант и без использования команд. Для этого просто укажите нужный объект курсором.


Команда Предыдущий объект

Появляется в том случае, если возможны несколько вариантов построения объекта (например, окружностей, касательных к двум кривым).

Для вызова команды нажмите кнопку Предыдущий объект на Панели специального управления или выберите ее название из контекстного меню.

После этого текущим становится предыдущий вариант создаваемого объекта.

Вы можете также выбрать другой вариант и без использования команд. Для этого просто укажите нужный объект курсором.


Команда Запомнить состояние

Позволяет запомнить параметры, которые были заданы при вводе объекта, для того чтобы использовать их при создании следующих объектов.

Для вызова команды нажмите кнопку Запомнить состояние на Панели специального управления или нажмите комбинацию клавиш <Ctrl> + <Shift> + <P>.

Например, при вводе окружности было явно задано значение радиуса. Если до фиксации этой окружности нажать кнопку Запомнить состояние, то заданный радиус будет автоматически предлагаться в соответствующем поле Панели свойств при вводе следующей окружности.

Подробнее о запоминании параметров...


Команда Запомнить условия фильтрации

Позволяет сохранить условия фильтрации строк до конца работы с документом.

Для этого до выполнения фильтрации нажмите кнопку Запомнить условия фильтрации на Панели специального управления.

Заданные условия будут автоматически предложены на Панели свойств при следующем вызове команды Применить фильтр в текущем сеансе работы с документом.


Команда Выравнивание по центру

Позволяет задать выравнивание заголовков разделов спецификации по центру колонки, в которой они расположены.


Команда Формировать пустые строки

Позволяет включать и отключать показ пустых строк, обрамляющих название разделов спецификации. Если рядом с названием команды в меню отображается «галочка», показ пустых строк включен.

Для отключения показа пустых строк вызовите команду (при этом «галочка» рядом с ее названием исчезнет).


Команда Шрифт первой строки

Вызывает на экран диалог выбора шрифта для отображения первой строки в названиях разделов спецификации.


Команда Выравнивание влево

Позволяет задать выравнивание заголовков разделов спецификации по левой границе колонки, в которой они расположены.


Команда Шрифт последующих строк

Вызывает на экран диалог выбора шрифта для отображения второй и последующих строк в многострочных названиях разделов спецификации.


Команда Выравнивание вправо

Позволяет задать выравнивание заголовков разделов спецификации по правой границе колонки, в которой они расположены.


Ошибка построения модели

Это предупреждение появляется в том случае, если в виде содержится изображение ошибочной модели.

Как исправить эту ошибку

Если на вашем компьютере установлен КОМПАС-3D, вызовите из контекстного меню на ошибочном компоненте в Дереве построения команду Редактировать в окне (для локальных деталей — команду Открыть документ-владелец).

Система откроет окно, содержащее выбранную модель. Объекты, вызвавшие ошибку, отмечены в Дереве построения восклицательным знаком в красном кружке. Для получения рекомендаций по исправлению ошибки используйте Справочную систему. После редактирования сохраните модель, закройте ее окно или перейдите в окно чертежа.


Единственный экземпляр массива совпадает с исходным объектом

Это сообщение появляется, если в результате редактирования модели в массиве оказался единственный экземпляр.

Как исправить эту ошибку

Войдите в режим редактирования массива и измените его параметры.


Определение параметров поворота экземпляров невозможно

Это сообщение появляется после того, как в результате редактирования модели:

– все точки, задающие позиции экземпляров массива по точкам, перестали лежать на кривой или на поверхности;

– или базовая точка копируемого объекта не проецируется на поверхность или на кривую, которой принадлежат точки.

После этого поворот экземпляров массива становится невозможен, экземпляры не строятся, а операция Массив по точкам отмечается как ошибочная.

Также это сообщение появляется на экране после того, как при создании или редактировании массива по точкам возникают вышеперечисленные ситуации. В этом случае экземпляры массива не поворачиваются и строятся с сохранением ориентации (группа переключателей Ориентация становится недоступна).

Как исправить эту ошибку

– Отредактируйте точки, задающие позиции экземпляров таким образом, чтобы они лежали на кривой или на поверхности.

– Или перестройте копируемый объект так, чтобы его базовая точка стала проецироваться на поверхность или кривую, которой принадлежат точки.

– Или отредактируйте ошибочный массив по точкам.

• Укажите другие точки для задания позиций экземпляров.

• Или задайте такое положение базовой точки базового экземпляра, при котором она проецируется на поверхность или кривую.


Местный разрез не содержит изображение модели

Это предупреждение появляется в том случае, если в местном разрезе не может быть построено изображение модели. Например, контур, указанный для создания местного разреза, расположен так, что в него не попадают геометрические объекты, составляющие разрез, построенный в соответствии с указанным положением секущей плоскости.

Как исправить эту ошибку

Отредактируйте чертеж или модель таким образом, чтобы построение изображения модели в местном разрезе стало возможным.


Создаваемый вид не содержит изображения

Это предупреждение появляется в том случае, если в виде не может быть построено изображение модели. Например, для создания выносного элемента указывается контур, внутри которого нет ни одного геометрического объекта или для создания разреза (сечения) указывается линия разреза, не пересекающая проекцию модели в текущем виде.

Как исправить эту ошибку

Отредактируйте чертеж или модель таким образом, чтобы построение изображения модели в выбранном виде стало возможным.


Конусность базового объекта не соответствует стандарту резьбы

Это сообщение появляется, если в результате редактирования модели угол конуса базового объекта резьбы перестал совпадать с углом стандартной конической резьбы.

Как исправить эту ошибку

Включите опцию Подгонка в контекстном меню условного изображения резьбы в Дереве построения или на Панели свойств при редактировании условного изображения резьбы.


Стандарт резьбы не соответствует типу базового объекта

Это сообщение появляется, если в результате редактирования модели поменялся тип грани, которая использовалась в качестве базового объекта для условного изображения резьбы, т.е. цилиндрическая грань стала конической или наоборот.

Как исправить эту ошибку

– Войдите в режим редактирования условного изображения резьбы и задайте параметры резьбы, соответствующие типу базового объекта.

– Или отредактируйте модель так, чтобы тип базового объекта соответствовал стандарту резьбы.


Коллекция копируемых объектов не найдена

Это сообщение появляется, если коллекция, использованная при копировании геометрических объектов, не найдена. Например, она могла быть удалена из модели.

Как исправить эту ошибку

Войдите в режим редактирования ошибочной операции копирования объектов и укажите для копирования другую — существующую — коллекцию. Или укажите другие копируемые объекты.


Сообщение об отсутствии лицензии

Это сообщение появляется на экране в случае потери лицензии на КОМПАС-3D и/или какое-либо приложение (или несколько приложений).

Для получения более подробной информации об ошибке получения лицензии нажмите в диалоге сообщения кнопку Подробности.

Закройте сообщение кнопкой ОК.


Не задана область применения операции

Это сообщение появляется после того, как в результате редактирования модели исчезают объекты, составлявшие область применения операции. Войдя в режим редактирования ошибочной операции можно увидеть, что Список тел на Панели свойств не содержит ни одного объекта.

Данная ошибка возникает, например, при удалении тел, с которыми был объединен формообразующий элемент.

Эта ошибка появляется также, если при редактировании первого формообразующего элемента был активизирован переключатель Область применения. Это означает, что в результате редактирования отдельное тело должно превратиться в приклеенный элемент. Поскольку первый формообразующий элемент приклеивать не к чему, то выполнение операции становится невозможным.

Как исправить эту ошибку

– Отредактируйте ошибочную операцию: укажите другие объекты для включения в область ее применения или, если это возможно, выберите способ выполнения операции, не требующий задания области применения.

– Или отредактируйте модель, восстановив объекты, составляющие область применения ошибочной операции, а затем — саму операцию, включив в область ее применения вновь созданные объекты.


Неправильно задано оформление первого листа спецификации: не найдены ячейки типа «Для спецификации»

Неправильно задано оформление первого листа спецификации:
не найдены ячейки типа «Для спецификации»

Как исправить эту ошибку

– Если вы получили это сообщение при попытке создать новую спецификацию...

– Если вы получили это сообщение при попытке открыть существующую спецификацию...

– Если вы получили это сообщение при попытке сменить оформление открытой спецификации...

– Если вы получили это сообщение при попытке добавить или отредактировать объект (объекты) спецификации в графическом документе или модели...

– Если вы получили это сообщение при попытке вставить из библиотеки элемент с объектом спецификации...


Не найдено оформление первого листа спецификации

Как исправить эту ошибку

– Если вы получили это сообщение при попытке создать новую спецификацию...

– Если вы получили это сообщение при попытке открыть существующую спецификацию...

– Если вы получили это сообщение при попытке сменить оформление открытой спецификации...

– Если вы получили это сообщение при попытке добавить или отредактировать объект (объекты) спецификации в графическом документе или модели...

– Если вы получили это сообщение при попытке вставить из библиотеки элемент с объектом спецификации...


Неправильно задано оформление первого листа спецификации: не указана таблица, предназначенная для спецификации

Неправильно задано оформление первого листа спецификации:
не указана таблица, предназначенная для спецификации

Как исправить эту ошибку

– Если вы получили это сообщение при попытке создать новую спецификацию...

– Если вы получили это сообщение при попытке открыть существующую спецификацию...

– Если вы получили это сообщение при попытке сменить оформление открытой спецификации...

– Если вы получили это сообщение при попытке добавить или отредактировать объект (объекты) спецификации в графическом документе или модели...

– Если вы получили это сообщение при попытке вставить из библиотеки элемент с объектом спецификации...


Неправильно задано оформление второго и последующих листов спецификации: не найдены ячейки типа «Для спецификации»

Неправильно задано оформление второго и последующих листов спецификации:
не найдены ячейки типа «Для спецификации»

Как исправить эту ошибку

– Если вы получили это сообщение при попытке создать новую спецификацию...

– Если вы получили это сообщение при попытке открыть существующую спецификацию...

– Если вы получили это сообщение при попытке сменить оформление открытой спецификации...

– Если вы получили это сообщение при попытке добавить или отредактировать объект (объекты) спецификации в графическом документе или модели...

– Если вы получили это сообщение при попытке вставить из библиотеки элемент с объектом спецификации...


Не найдено оформление второго и последующих листов спецификации

Как исправить эту ошибку

– Если вы получили это сообщение при попытке создать новую спецификацию...

– Если вы получили это сообщение при попытке открыть существующую спецификацию...

– Если вы получили это сообщение при попытке сменить оформление открытой спецификации...

– Если вы получили это сообщение при попытке добавить или отредактировать объект (объекты) спецификации в графическом документе или модели...

– Если вы получили это сообщение при попытке вставить из библиотеки элемент с объектом спецификации...


Неправильно задано оформление второго и последующих листов спецификации: не указана таблица, предназначенная для спецификации

Неправильно задано оформление второго и последующих листов спецификации:
не указана таблица, предназначенная для спецификации

Как исправить эту ошибку

– Если вы получили это сообщение при попытке создать новую спецификацию...

– Если вы получили это сообщение при попытке открыть существующую спецификацию...

– Если вы получили это сообщение при попытке сменить оформление открытой спецификации...

– Если вы получили это сообщение при попытке добавить или отредактировать объект (объекты) спецификации в графическом документе или модели...

– Если вы получили это сообщение при попытке вставить из библиотеки элемент с объектом спецификации...


Не синхронизированы документы исполнений

Это сообщение появляется для зеркального исполнения компонента, входящего в зеркальное исполнение сборки, если исходное исполнение компонента, входящее в исходное исполнение сборки, преобразовано в локальную модель, т.е. была применена команда Взять в документ.

Как исправить эту ошибку

Доступны следующие способы исправления ошибки.

– Вызовите из контекстного меню компонента в зеркальном исполнении сборки команду Отменить связь. При этом связь между зеркальным и исходным исполнениями компонента будет разорвана.

– Вызовите из контекстного меню компонента в зеркальном исполнении сборки команду Заменить зеркальным исполнением. «Галочка» рядом с названием команды исчезнет, зеркальное исполнение компонента будет заменено его исходным исполнением.


В документе не найдено зеркальное исполнение

Это сообщение появляется в следующих случаях.

– В зеркальное исполнение сборки входит обычное исполнение компонента. Для этого исполнения вызвана команда Заменить зеркальным исполнением, но нужное зеркальное исполнение отсутствует в файле компонента.

Как исправить эту ошибку

Для данного исполнения компонента в файле-источнике создайте зеркальное исполнение или вернитесь к использованию исходного исполнения компонента в зеркальном исполнении сборки, повторно вызвав указанную выше команду.

– В зеркальное исполнение сборки входит зеркальное исполнение компонента. Его исходное исполнение, входящее в исходное исполнение сборки, заменяется другим исполнением этого компонента, для которого зеркальное не создано.

Как исправить эту ошибку

Создайте нужное зеркальное исполнение компонента в его файле-источнике или вернитесь к использованию первоначального исполнения компонента в исходном исполнении сборки.


Ограничения записи в форматы КОМПАС предыдущих версий

В новых версиях КОМПАС появляются новые типы и способы построения объектов, перерабатывается внутренняя структура объектов. Из-за этого сохранение модели в предыдущую версию КОМПАС может оказаться невозможным или имеет ограничения.

В некоторых случаях один или несколько объектов модели сохраняются без истории построения. При этом внешний вид и свойства модели не изменяются, но информация о последовательности ее построения теряется, вместо исходных объектов в Дереве построения отображаются соответствующие объекты (операции, поверхности или кривые) без истории и эскизы.

В эскизе могут присутствовать объекты, не поддерживаемые версией КОМПАС, в которую производится запись модели. Эти объекты при записи заменяются другими, поддерживаемыми, объектами. На экране появляется диалог, в котором перечислены исходные и заменяющие объекты.

Некоторые объекты модели сохраняются в предыдущую версию с потерей связей и/или опорных объектов.

Сохранение модели в версию КОМПАС 5.11 R03 возможно, только если в этой модели не используются объекты или способы их создания, появившиеся в более поздних по сравнению с 5.11 версиях КОМПАС.

Если модель имеет исполнения, то при сохранении ее в формат КОМПАС 5.11 R03 записывается информация только о текущем на момент сохранения исполнении.


Объекты, образующие траекторию, должны последовательно соединяться

Объекты, образующие траекторию,
должны последовательно соединяться

Это предупреждение появляется после того как в процессе редактирования модели объекты, выбранные в качестве траектории для кинематической операции, перестали последовательно соединяться.

Как исправить эту ошибку

– Войдите в режим редактирования операции и укажите другие объекты (объект) в качестве траектории.

– Или отредактируйте объекты, образующие траекторию так, чтобы они соединялись.


Замкнутая траектория должна пересекать плоскость сечения

Замкнутая траектория
должна пересекать плоскость сечения

Это предупреждение появляется после того, как в процессе редактирования модели замкнутая траектория кинематической операции перестает пересекаться с плоскостью сечения.

Как исправить эту ошибку

– Измените траекторию или плоскость сечения так, чтобы они пересекались.

– Или войдите в режим редактирования операции и укажите другой объект — либо в качестве траектории, либо в качестве сечения.


Направление движения сечения параллельно плоскости сечения

Направление движения сечения
параллельно плоскости сечения

Это предупреждение появляется после того, как в процессе редактирования модели траектория кинематической операции изменилась так, что касательная, проведенная к траектории в точке ее пересечения с плоскостью эскиза-сечения, оказалась лежащей в этой же плоскости или параллельна ей.

Как исправить эту ошибку

– Отредактируйте траекторию или плоскость сечения так, чтобы касательная к траектории в точке пересечения с плоскостью сечения перестала принадлежать (или быть параллельной) плоскости сечения.

– Или войдите в режим редактирования операции и укажите другой объект — либо в качестве траектории, либо в качестве сечения.


Сечение должно содержать один контур

Это предупреждение появляется после того, как в результате редактирования эскиза-сечения для кинематической операции он стал содержать более одного контура.

Как исправить эту ошибку

Войдите в режим редактирования эскиза и измените изображение в нем так, чтобы эскиз содержал один контур.


Начало траектории должно лежать в плоскости сечения

Начало траектории
должно лежать в плоскости сечения

Это предупреждение появляется после того как в процессе редактирования модели начальная точка объекта, выбранного в качестве траектории для кинематической операции, перестала находиться в плоскости эскиза-сечения.

Как исправить эту ошибку

– Войдите в режим редактирования операции и укажите другой объект в качестве траектории.

– Или отредактируйте объект-траекторию так, чтобы его начальная точка попала в плоскость сечения.


Указанный объект или его часть уже задействованы

Это предупреждение появляется при выборе одного и того же эскиза (или эскиза и его элемента) в качестве сечения и траектории для кинематической операции.

Как исправить эту ошибку

Укажите в качестве сечения или траектории незадействованный эскиз.


Не удалось продлить поверхность до данной вершины

Это сообщение появляется, если в результате редактирования модели взаимное расположение кромки продлеваемой грани и вершины, ограничивающей удлинение, изменилось так, что продление грани невозможно.

Как исправить эту ошибку

– Укажите другую вершину, ограничивающую удлинение.

– Или войдите в режим редактирования продления грани и выберите другой способ продления грани.


Значение удлинения слишком велико

Это предупреждение появляется, если в результате редактирования модели удлинение грани становится настолько велико, что эквидистанта кромки грани вырождается.

Как исправить эту ошибку

Войдите в режим редактирования продления грани и уменьшите значение удлинения.


Грань содержит полюс. Укажите другую кромку или выберите другой тип продления

Это предупреждение появляется в случае невозможности продления грани за указанную кромку из-за того, что эта кромка примыкает к полюсу грани. Продление грани за такие кромки способом Той же поверхностью не производится.

Как исправить эту ошибку

– Войдите в режим редактирования ошибочной операции продления и выберите другой способ продления или укажите другие ребра, не примыкающие к полюсу.

– Или, если это возможно, усеките поверхность, «срезав» полюс. Так как вместо полюса в поверхности появится ребро, кромка, первоначально выбранная для продления, будет примыкать уже к этому ребру и продление способом Той же поверхностью станет возможным.


Значение удлинения слишком мало

Это предупреждение появляется, если в результате редактирования модели значение удлинения грани принимает значение меньше допустимого предела (0.0001 мм).

Как исправить эту ошибку

Войдите в режим редактирования продления грани и увеличьте значение удлинения.


Точка, определяющая радиус, находится вне ребра

Это предупреждение появляется, если значение расстояния от вершины ребра до точек, определяющих радиус скругления, оказывается отрицательным.

Как исправить эту ошибку

Войдите в режим редактирования ошибочного скругления, найдите в таблице параметров этого скругления точки с отрицательным расстоянием от вершины и исправьте значения расстояний.


Сообщение о достижении предельного количества видов

Это сообщение появляется при попытке создать новый вид в чертеже, уже содержащем предельное количество видов — 254. Поскольку формирование нового вида невозможно, при закрытии данного сообщения работа команды создания вида прерывается.

Чтобы создание нового вида стало возможно, необходимо уменьшить количество видов в чертеже, т.е. удалить какие-либо из существующих видов.

Если среди видов чертежа есть пустые, то удалите их.

Если пустых видов нет, то объедините несколько видов в один (перенесите все изображение из какого-либо вида или видов в другой вид), а затем удалите освободившиеся виды.

Рекомендуется объединять виды с одинаковым масштабом.


Данная операция не применима к телам из частей

Это сообщение проявляется при попытке применить к телу, состоящему из отдельных частей, операцию, которая не предназначена для работы с такими телами.

Например, в листовом теле был сделан вырез, который не приводил к разделению его на части. После этого несколько сгибов листового тела были разогнуты с помощью операции Разогнуть. Затем эскиз выреза был отредактирован так, что вырез стал разделять листовое тело на части. Так как операция Разогнуть не применима к телам, состоящим из частей, она отмечается как ошибочная.

Кроме операции Разогнуть, к телам из отдельных частей не применимы следующие операции:

– Согнуть,

– Сгиб,

– Сгиб по линии,

– Сгиб по эскизу,

– Подсечка,

– Замыкание углов,

– Параметры развертки.

Ни одну из этих команд невозможно выполнить, если листовое тело состоит из отдельных частей.

Как исправить эту ошибку

Переместите Указатель окончания построения вверх — так, чтобы из модели были временно удалены операции, находящиеся ниже ошибочного объекта, и сам этот объект. Затем выполните одно из следующих действий:

– Отредактируйте параметры или эскиз операции, приводящей к разделению листового тела на части, чтобы разделение не происходило.

– Или добавьте операцию, объединяющую части листового тела, например, Пластина.

Верните Указатель окончания построения на прежнее место.


Результатом данной операции не может быть тело из частей

Это сообщение появляется, если после операции, результатом которой может быть только целое тело, в модели появляется (или остается) тело из частей.

Как исправить эту ошибку

– Отредактируйте параметры операции так, чтобы ее результатом было целое тело.

– Или отредактируйте модель так, чтобы операция, отмеченная как ошибочная, выполнялась над целым, а не состоящим из частей телом.


Не было сшито ни одного ребра

Это сообщение появляется, если при построении (перестроении) операции Сшивка поверхностей оказывается, что сшить указанные поверхности невозможно. Например, для сшивки указаны поверхности, расстояние между ближайшими открытыми ребрами которых превышает значение точности, указанное для сшивки.

Как исправить эту ошибку

– Отредактируйте сшиваемые поверхности так, чтобы их сшивка была возможна.

– Или войдите в режим редактирования операции Сшивка поверхностей и увеличьте значение в поле Точность на Панели свойств.


Сообщение о невозможности получения лицензии

Это сообщение появляется на экране в результате неуспешной попытки получения лицензии.

Возникновение данного сообщения говорит о том, что в настоящий момент получить лицензию нельзя: не отвечает Менеджер лицензий или на ключе нет свободных лицензий.

Для получения более подробной информации об ошибке получения лицензии нажмите в диалоге сообщения кнопку Подробности.

Закройте сообщение кнопкой ОК.


Копируемая операция должна быть применена к одному телу

– Это сообщение появляется после того, как в результате редактирования модели оказывается, что копируемая операция Вырезать выдавливанием, глубина которой определяется способом До поверхности или До ближайшей поверхности, применена более чем к одному телу (т.е. ее область применения содержит более одного тела). Копирование таких операций невозможно.

Как исправить эту ошибку

Войдите в режим редактирования копируемой операции и измените один из следующих параметров:

• область применения операции: оставьте в области применения операции только одно тело,

• способ определения глубины выдавливания: выберите любой способ, кроме способа До поверхности или До ближайшей поверхности.

– Это сообщение появляется после того, как в результате редактирования модели оказывается, что операция удаления материала, используемая в качестве копируемого объекта в массиве с таблицей изменяемых переменных, применяется более чем к одному телу. Создание такого массива невозможно.

Как исправить эту ошибку

Удалите таблицу изменяемых переменных из массива.


Грани базовой поверхности не образуют связную совокупность

Это сообщение появляется после того, как в результате редактирования модели грани, составляющие базовую поверхность для эквидистанты, перестали образовывать связную совокупность.

Как исправить эту ошибку

– Отредактируйте объекты, которым принадлежат грани, составляющие базовую поверхность эквидистанты, таким образом, чтобы эти грани образовывали связную совокупность.

– Или отредактируйте эквидистантную поверхность, указав для нее связные грани.

– Или, если это возможно, вместо одной эквидистантной поверхности постройте несколько, а затем соедините и/или обрежьте их, используя операции редактирования поверхностей.


Невозможно создать поверхность, состоящую из нескольких частей

Это сообщение появляется, если для создания эквидистантной поверхности были выбраны такие грани и/или заданы такие параметры, что невозможно построить эквидистантную поверхность, которая являлась бы связной совокупностью граней.

Как исправить эту ошибку

Вместо одной эквидистантной поверхности постройте несколько, а затем соедините и/или обрежьте их, используя операции редактирования поверхностей.


Значение расстояния смещения слишком велико

Это сообщение появляется после того, как в результате редактирования модель изменилась так, что произошло самопересечение или вырождение эквидистантной поверхности.

Как исправить эту ошибку

– Войдите в режим редактирования эквидистантной поверхности и уменьшите расстояние смещения.

– Или отредактируйте модель так, чтобы при текущем значении отступа существование эквидистанты было возможно.


Предупреждение о наличии невекторных объектов

В этом диалоге перечислены документы, в которых обнаружены шрифты True Type, растровые изображения и заливки, а также типы объектов (например, размеры, макроэлементы и т.д.), содержащих эти объекты.

В перечне указаны также документы, в которых используется очистка фона для размеров и обозначений, так как очистка реализуется с помощью заливки.

Диалог выдается при попытке вывести указанные в нем документы (а следовательно, и шрифты True Type, растровые изображения и заливки) на устройство (например, плоттер), драйвер которого не поддерживает такие шрифты и сплошные заливки.

Вы можете указать, выводить или не выводить эти документы, нажав соответствующую кнопку диалога.

Вы можете отказаться от вывода растровых изображений и заливок, включив соответствующую опцию.

При подтверждении вывода перечисленных в диалоге документов следует иметь в виду, что гарантии корректной печати указанных объектов отсутствуют: Вы можете увидеть на бумаге совсем не то, что видели на экране.


Невозможно создать группу. Уточните параметры

Это сообщение означает, что по выбранной кривой группа с заданными параметрами построена быть не может. Например, указанное количество точек с заданным шагом между ними не умещается на кривой.

Как исправить эту ошибку

Измените значения параметров группы точек или исходной кривой таким образом, чтобы построение стало возможным.


Базовая кривая или ребро были изменены. Невозможно создать группу. Уточните параметры

Это сообщение означает, что кривая, которая использована для построения группы точек, была изменена таким образом, что группа с заданными параметрами не может быть построена по ней. Например, указанное количество точек с заданным шагом между ними не умещается на измененной кривой.

Как исправить эту ошибку

Измените значения параметров группы точек или исходной кривой таким образом, чтобы построение стало возможным.


Файл содержит недопустимый для создания объекта вид записи данных. Откорректируйте файл

Это сообщение означает, что значения параметров в файле данных, который был использован для построения объекта (например, массива по таблице), находятся вне допустимого предела изменений. Примером может служить отрицательное значение координаты R при построении объекта в цилиндрических или сферических координатах.

Как исправить эту ошибку

Измените значения параметров, записанных в файле, таким образом, чтобы их значения соответствовали существующим ограничениям.


Файл отсутствует или не соответствует формату

Это сообщение означает, что файл данных, который был использован для построения группы точек, удален, переименован или имеет недопустимый формат.

Как исправить эту ошибку

Попытайтесь восстановить удаленный или переименованный файл координат средствами операционной системы. Приведите формат файла в соответствие существующим требованиям.

Если связь группы точек с файлом не является обязательной, вызовите для этой группы команду Разрушить. Точки останутся в модели в качестве самостоятельных объектов на прежних местах.


Суммарный угол вращения превышает 360 градусов

Суммарный угол вращения
превышает 360 градусов

Это предупреждение появляется после того, как в результате редактирования модели суммарный угол вращения, заданный для тела вращения, превысил 360 градусов (это возможно, если тело получено вращением в двух направлениях).

Как исправить эту ошибку

Войдите в режим редактирования операции и задайте углы вращения, сумма которых не превышает 360.


Сообщение об актуализации значений массы

Актуализация значений массы производится, если на момент вызова команды, требующей наличия в файле модели актуальной информации о ее массе (команда Редактор свойств, Создание отчета и др.), эта информация отсутствует, т.е. после последнего редактирования модели, влияющего на ее массу, не производился пересчет МЦХ.


Ошибка в булевой операции

Это предупреждение появляется, если после редактирования модели один или несколько ее элементов перестраиваются некорректно, в результате чего не может быть рассчитано их положение в модели.


Ошибка при создании поверхности фаски ребра

Это предупреждение появляется после того, как при редактировании модели параметры фаски или модели в целом изменены так, что перестроение фаски невозможно. Например, грани детали стали в несколько раз меньше катетов фаски.

Как исправить эту ошибку

Войдите в режим редактирования фаски и задайте другие параметры для ее построения.


Ошибка при создании фаски ребра

Это предупреждение появляется после того, как при редактировании модели параметры фаски или модели в целом изменены так, что перестроение фаски невозможно. Например, грани детали стали в несколько раз меньше катетов фаски.

Как исправить эту ошибку

Войдите в режим редактирования фаски и задайте другие параметры для ее построения.


Ошибочный контур

Это предупреждение появляется, если в результате редактирования параметры контура в эскизе противоречат параметрам выполняемой на основе этого эскиза операции.

Примеры:

– Ошибочный контур, приводящий к самопересечению элемента:

• эллипс, используемый для операции выдавливания тонкой стенки с уклоном внутрь, настолько мал, что возник «перехлест» стенок,

• отрезок в эскизе, используемый для операции вращения, оказался на одной прямой с проекцией оси вращения на плоскость эскиза.

– Ошибочный контур, приводящий к созданию поверхности из нескольких частей: поверхность, создаваемая на основе эскиза, содержащего вложенные замкнутые контуры, строится с отключенной опцией Замкнутая поверхность.

Как исправить эту ошибку

– Войдите в режим редактирования ошибочного элемента и задайте такие его параметры, которые не приведут к конфликтам при его построении.

– Или войдите в режим редактирования эскиза ошибочного элемента и отредактируйте контур в нем.


Контур невозможно использовать для заданного перемещения

Это предупреждение появляется на экране, когда при движении сечения вокруг выбранной оси или в направлении выдавливания две или более точек сечения имеют совпадающие траектории. Примеры таких ситуаций приведены на рисунках.

Невозможно выполнить вращение

Невозможно выполнить выдавливание

Как исправить эту ошибку

Измените сечение или выберите другую ось вращения/направление выдавливания.


Замкнутый сплайн должен иметь как минимум 3 вершины

Это сообщение появляется, если замкнутый сплайн содержит менее трех вершин.

Как исправить эту ошибку

– Добавьте вершины сплайна.

– Или отключите замыкание сплайна.


Слишком высокий порядок сплайна

Это сообщение появляется после того, как переменной, соответствующей порядку сплайна, присвоено значение, которое не позволяет построить сплайн при данном количестве точек.

Как исправить эту ошибку

Уменьшите значение переменной.


Невозможно построить скругление для кривых в указанной области или с заданным радиусом

Эта ошибка появляется после того, как в результате редактирования модели форма кривых изменилась так, что стало невозможным их скругление заданным радиусом или вблизи точек, в которых они были указаны.

Как исправить эту ошибку

Войдите в режим редактирования скругления и измените значение радиуса или укажите скругляемые кривые повторно — в других точках.


Ошибочная кривая

Это предупреждение появляется, если при выполнении или редактировании операции была указана кривая, не соответствующая требованиям этой операции, или если кривая перестала соответствовать требованиям операции в результате редактирования модели.

Как исправить эту ошибку

Укажите кривую, удовлетворяющую требованиям операции.


Вырожденная кривая

Это сообщение появляется в следующих случаях:

1. Сплайн по полюсам второго порядка имеет больше двух вершин.

Как исправить эту ошибку

– Отредактируйте сплайн, увеличив порядок.

– Любая кривая второго порядка представляет собой ломаную. Поэтому, если нужен не сплайн, а ломаная, удалите сплайн и постройте ломаную с помощью соответствующей команды.

2. Сплайн по полюсам сопряжен с существующим объектом, но для выбранного условия сопряжения сплайн имеет недостаточное количество полюсов, соседних с вершиной сопряжения и/или недостаточный порядок. Подробнее...

Как исправить эту ошибку

– Отредактируйте сплайн, увеличив порядок и/или добавив новые вершины непосредственно после вершины, в которой сплайн сопрягается с объектом.

– Или выберите другое условие сопряжения сплайна с объектом.

– Или, если это допустимо, смените тип сплайна (выберите тип По точкам вместо типа По полюсам).

3. Граничная кривая группы изопараметрических кривых вырождена в точку. Грань, используемая при построении группы изопараметрических кривых с учетом граничных кривых, имеет вырожденное ребро (например, конус).


Ошибка сечения поверхностью

Это предупреждение появляется после того, как в результате редактирования модели ее элементы были перестроены так, что выполнение отсечения с заданными параметрами стало невозможным.


В документе не найдено исполнение

Это сообщение означает, что в файле компонента или модели — источнике изображения в ассоциативном виде отсутствует исполнение, которое было выбрано при вставке компонента в модель, заготовки в модель или при создании ассоциативного вида.

Как исправить эту ошибку

– Для компонента:

• Выберите для вставки другое исполнение компонента. Для этого можно воспользоваться командой Текущее исполнения из контекстного меню компонента, выделенного в Дереве построения.

• Или замените компонент, содержащий ошибку, компонентом из другого файла. Для этого выделите компонент в Дереве модели, вызовите из контекстного меню команду Свойства компонента, перейдите на вкладку Файл-источник Панели свойств, нажмите кнопку Файл-источник и укажите нужный файл в появившемся диалоге. Завершите изменение свойств компонента, нажав кнопку Создать объект на Панели специального управления.
Кроме того, можно просто удалить ошибочный компонент из модели и вставить другой.

– Для ассоциативного вида:

• Если вид — Произвольный, выберите для изображения в виде другое исполнение модели или другую модель. Для этого перейдите в режим редактирования вида и воспользуйтесь списком исполнений или кнопкой Выбрать другую модель на Панели свойств. Отредактированный вид и виды, использующие его в качестве опорного, перестроятся.

• Если вид не Произвольный, а другой, например, Проекционный, найдите его опорный вид (например, с помощью команды Отношения) и отредактируйте, как описано выше.


Пустая деталь

Это предупреждение появляется после того, как в результате редактирования модели были удалены или некорректно перестроены объекты, использовавшиеся при выполнении операции,


Деталь содержит ошибку

Это предупреждение появляется после того, как в результате редактирования модели были удалены или некорректно перестроены объекты, использовавшиеся при выполнении одной или нескольких операций построения модели.


Объекты пересекаются с ошибкой

Это предупреждение появляется, если после редактирования модели один или несколько ее элементов перестраиваются некорректно, в результате чего не может быть рассчитано их пересечение.


Ошибка при создании поверхности скругления ребра

Это предупреждение появляется после того, как при редактировании модели параметры скругления или модели в целом изменены так, что перестроение скругления невозможно. Например, грани детали стали в несколько раз меньше радиуса скругления.

Как исправить эту ошибку

Войдите в режим редактирования скругления и задайте другие параметры для его построения.


Ошибка при скруглении ребра

Это предупреждение появляется после того, как при редактировании модели параметры скругления или модели в целом изменены так, что перестроение скругления невозможно. Например, грани детали стали в несколько раз меньше радиуса скругления.

Как исправить эту ошибку

Войдите в режим редактирования скругления и задайте другие параметры для его построения.


Касательные к сечению в некоторых точках совпадают с касательными к траекториям этих точек

Это сообщение появляется, если при имеющихся оси вращения и сечении некоторые точки сечения должны двигаться по таким траекториям, касательные к которым совпадают с касательными к сечению в этих точках. Например, невозможно выполнение операции вращения с использованием сечения и оси, представленных на рисунке, так как траектория движения (показана штриховой линией) точки 1 имеет касательную, совпадающую с касательной к сечению в этой точке.

Как исправить эту ошибку

Измените сечение или выберите другую ось.


Эскиз с одной точкой может использоваться только для крайнего сечения

Это предупреждение появляется после того как в процессе редактирования модели лини в эскизе, используемом операцией по сечениям, были заменены точкой.

Как исправить эту ошибку

Войдите в режим редактирования эскиза и измените изображение в нем так, чтобы оно соответствовало требованиям операции.

Требования к эскизам сечений...


Тело состоит из отдельных частей

Это предупреждение появляется после того, как в результате редактирования модели одно или несколько ее тел или поверхностей «распалось» на части.


Сообщение о непоследовательном расположении сечений

Это сообщение появляется после того как в результате редактирования модели изменилось расположение эскизов, используемых в операции по сечениям с осевой линией, в результате чего порядок их указания перестал соответствовать порядку их расположения вдоль осевой линии.

Как исправить эту ошибку

– Войдите в режим редактирования операции по сечениям и измените порядок следования эскизов так, чтобы он совпадал с порядком их расположения вдоль направляющей.

– Или укажите другую направляющую, форма и положение которой соответствуют порядку указания сечений.


Проекции лежат в параллельных плоскостях

Это сообщение появляется после того, как в результате редактирования модели эскизы, содержащие проекции кривой, оказались расположенными в параллельных плоскостях. Построение кривой по двум проекциям стало невозможным, поэтому кривая отмечается как ошибочная.

Как исправить эту ошибку

– Измените положение плоскости одного из двух эскизов так, чтобы эти эскизы располагались в непараллельных плоскостях.

– Войдите в режим редактирования ошибочной кривой и укажите другой эскиз или отдельные его линии в качестве первой (второй) проекции. Плоскость выбранного эскиза не должна быть параллельна плоскости другого эскиза.


Ребра не найдены

Это предупреждение появляется после того, как в результате редактирования модели были удалены или некорректно перестроены ребра, использовавшиеся при выполнении операции.

Как исправить эту ошибку

Войдите в режим редактирования элемента, операция построения которого стала ошибочной, и укажите в качестве опорного объекта существующие в модели ребра.

Иногда эта ошибка автоматически устраняется после исправления ошибочного формообразующего элемента, на ребрах которого основывалось построение элемента.


Объекты не пересекаются

Это предупреждение появляется, если после редактирования модели перестали пересекаться объекты, участвующие в операции, условием выполнения которой является пересечение объектов. Например:

– вырезанный или приклеенный формообразующий элемент не пересекается с телом модели,

– поверхности, участвующие в операции Линия пересечения, не пересекаются друг с другом.

Как исправить эту ошибку

– Если ошибка в формообразующем элементе:

• войдите в режим редактирования этого элемента и задайте такие его параметры, чтобы элемент пересекался с моделью,

• или отредактируйте сечение ошибочного элемента так, чтобы элемент с данными параметрами пересекался с моделью,

• если элемент приклеен, его можно «превратить» в самостоятельное тело — для этого в режиме редактирования элемента перейдите на вкладку Результат операции и активизируйте переключатель Новое тело.

– Если ошибка в линии пересечения:

• отредактируйте форму и/или положение поверхностей, участвующих в операции, так, чтобы они пересекались.

Кроме того, данное предупреждение может появляться при попытке создания поверхности из частей, например, на основе эскиза, содержащего несколько контуров. В этом случае нужно отредактировать эскиз так, чтобы создаваемая поверхность была целой.


Не включен ни один контур

Это сообщение появляется в случае, когда отключено создание всех контуров, составляющих кривую.

Например, линия пересечения двух поверхностей состояла из двух контуров, но было включено создание только первого контура. Затем эскиз одной из поверхностей был отредактирован таким образом, что поверхности перестали пересекаться по этому контуру. В результате линия пересечения отмечается в Дереве построения как ошибочная: единственный ее контур не может быть сформирован, так как его создание отключено.

Как исправить эту ошибку

– Отредактируйте форму или расположение исходных объектов кривой таким образом, чтобы кривая состояла из прежних контуров.

– Или отредактируйте саму кривую, включив создание хотя бы одного отключенного контура.


В выбранном направлении отсутствует поверхность

Это предупреждение появляется после того, как в результате редактирования модели была удалена или некорректно перестроена поверхность, использовавшаяся при выполнении операции выдавливания или операции вращения.

Как исправить эту ошибку

– Войдите в режим редактирования операции выдавливания или вращения, а затем укажите в качестве границы выдавливания или поверхности вращения другую поверхность, или укажите другой способ построения операции, или измените направление построения.

– Или удалите элемент выдавливания или вращения.

Данная ошибка может также появляться у экземпляров массива, если копируемый объект получен операцией выдавливания или вращения до поверхности. Экземпляры массива формируются следующим образом: сначала согласно параметрам массива создаются копии сечения (для операций вращения — также копии оси), затем сечения поворачиваются или выдавливаются до поверхности, которая использовалась в исходной операции. Если какие-либо из получающихся объектов не пересекаются с поверхностью, то соответствующие им экземпляры отмечаются как ошибочные.

В этом случае для исправления ошибки можно изменить либо форму/размер поверхности, либо параметры массива, либо параметры копируемой операции.


Файл не найден

Это предупреждение появляется, если на диске не обнаружен файл-источник компонента модели или объектов копии, имеющейся в модели.

Чтобы выбрать в качестве источника другую модель взамен ненайденной, выполните следующие действия.

1. Выделите ошибочный объект в Дереве построения и вызовите из контекстного меню команду Свойства компонента (для компонента) или Редактировать (для копии геометрических объектов).

2. На Панели свойств нажмите кнопку Файл-источник. Данная кнопка расположена на вкладке Файл-источник (для компонента) или на вкладке Параметры (для копии геометрических объектов).

3. В появившемся диалоге укажите нужный файл.

4. Завершите работу команды, нажав кнопку Создать объект на Панели специального управления.


Ошибочный параметр

Это предупреждение появляется, если при редактировании параметров элемента было введено такое значение одного из них, при котором построение элемента невозможно. Ошибочное значение параметра могло быть также введено или вычислено в качестве значения переменной в Окне переменных.

Пример 1. В детали была выполнена операция выдавливания с уклоном внутрь. Затем было введено такое значение угла, при котором возникло самопересечение тела. Чтобы исправить ошибку, следует отредактировать операцию, уменьшив либо угол уклона, либо расстояние выдавливания.

Пример 2. В операции Замыкание углов с включенной опцией Единые параметры один или несколько выбранных углов не могут быть замкнуты с текущими параметрами. Чтобы исправить ошибку, следует отредактировать операцию, выполнив одно из следующих действий:

– изменить параметры замыкания так, чтобы замыкание было возможно для всех углов,

– отключить опцию Единые параметры и изменить параметры замыкания ошибочного угла так, чтобы выполнение операции было возможно,

– удалить ошибочный угол из списка замыкаемых углов.


Ошибка при подготовке операции

Это предупреждение появляется после того, как в результате редактирования модели был некорректно перестроен или удален объект, использовавшийся при выполнении операции.

Пример 1. В детали были выполнена булева операция над двумя телами. Затем в результате редактирования модели одно или оба тела перестроились некорректно (т.е. были отмечены в Дереве построения как ошибочные). Выполнение булевой операции над ошибочными телами невозможно, поэтому и она отмечается как ошибочная.

Булева операция выполняется также при построении массива операций с включенной опцией Геометрический массив. Корректное ее выполнение возможно только при условии, что грани копий не пересекаются друг с другом. В противном случае создание массива невозможно. Для исправления ошибки необходимо либо изменить параметры массива так, чтобы копии не пересекались, либо отключить опцию Геометрический массив.

Пример 2. Из детали был вырезан элемент выдавливания способом «до ближайшей поверхности». Затем модель была отредактирована так, что поверхность, до которой выдавливался элемент, исчезла. Если в выбранном направлении нет другой поверхности, до которой мог бы быть выдавлен данный элемент, то он отмечается как ошибочный.


Ошибка при создании ребра жесткости

Это предупреждение появляется после того, как в результате редактирования модели ее элементы были перестроены так, что построение ребра жесткости с заданными параметрами стало невозможным.


Объект самопересекается

Это предупреждение появляется после того, как в результате редактирования модели совпали некоторые области одного формообразующего элемента.

Как исправить эту ошибку

– Войдите в режим редактирования ошибочного элемента и задайте такие его параметры, которые не приведут к конфликтам при его построении.

– Или войдите в режим редактирования эскиза ошибочного элемента и отредактируйте контур в нем.


Фаски построены не для всех ребер

Это предупреждение появляется после того, как в результате редактирования модели были некорректно перестроены некоторые ребра, использовавшиеся при построении фаски, в результате чего не может быть построена фаска на них.

Как исправить эту ошибку

Войдите в режим редактирования фаски и укажите в качестве опорных объектов существующие в модели ребра.


Скруглены не все ребра

Это предупреждение появляется после того, как в результате редактирования модели были некорректно перестроены некоторые ребра, использовавшиеся при построении скругления, в результате чего не может быть построено скругление на них.

Как исправить эту ошибку

Войдите в режим редактирования скругления и укажите в качестве опорных объектов существующие в модели ребра.


Тело изменено булевой операцией

Это предупреждение появляется, если в качестве исходных объектов для создания массива выбраны объекты, входящие в состав тел, над которыми была произведена булева операция.

Как исправить эту ошибку

Войдите в режим редактирования ошибочного массива и исключите тело, участвующее в булевой операции, из числа исходных объектов массива. Затем переместите Указатель окончания построения в Дереве выше булевой операции, создайте необходимый массив объектов и переместите Указатель обратно.


Ошибочное тело

Это предупреждение появляется, если тело модели не может быть перестроено после ее редактирования.


Один из контуров невозможно использовать для заданного построения

Это предупреждение появляется на экране, если один из контуров, указанных для построения, невозможно использовать для данного построения.

Такая ситуация может возникнуть, например, в следующих случаях:

• один из указанных контуров имеет самопересечение,

• тело, получаемое в результате построения, имеет самопересечение.

Как исправить эту ошибку

Выполните построение для каждого контура отдельно, чтобы определить причину возникновения ошибки:

• если ошибка возникла при выполнении построения для какого-либо контура, отредактируйте этот контур и повторите построение, указав все нужные контуры,

• если при выполнении построения для каждого контура не возникло ни одной ошибки, повторите построение тела одновременно по всем контурам, изменив один или несколько параметров операции. Если ошибка не исчезает, используйте другой набор операций для построения тела.


Ошибочная поверхность

Это предупреждение появляется после того, как в результате редактирования модели была некорректно перестроена поверхность, использовавшаяся при выполнении операции.


Неверно задана толщина тонкостенной оболочки

Это предупреждение появляется после того, как в результате редактирования модели стало невозможным построение оболочки с заданной толщиной. Например, габариты модели стали меньше толщины оболочки


Построение тонкой стенки невозможно, если одно из сечений представляет собой точку

Это предупреждение появляется после того как в процессе редактирования модели линии в эскизе, использующемся в тонкостенном элементе по сечениям, были заменены точкой.

Как исправить эту ошибку

– Войдите в режим редактирования эскиза и измените изображение в нем так, чтобы построение тонкостенного элемента по сечениям было возможно.

– Или войдите в режим редактирования операции и укажите другой эскиз, — содержащий контур.


Ошибка при создании тонкостенного тела

Это предупреждение появляется после того, как в результате редактирования модели ее элементы были перестроены так, что построение тонкой стенки с заданными параметрами стало невозможным.


Слишком большие катеты фаски

Это предупреждение появляется после того, как при редактировании модели параметры фаски или модели в целом изменены так, что перестроение фаски невозможно. Например, грани детали стали в несколько раз меньше катетов фаски.

Как исправить эту ошибку

Войдите в режим редактирования фаски и уменьшите ее катеты.


Слишком большой радиус скругления

Это предупреждение появляется после того, как при редактировании модели параметры скругления (ребер тела/поверхности или вершин ломаной) или модели в целом изменены так, что перестроение скругления невозможно. Например, грани детали стали в несколько раз меньше радиуса скругления.

Как исправить эту ошибку

Войдите в режим редактирования ошибочной операции и уменьшите радиус скругления.


Тело с нарушенной топологией

Нарушением топологии тела детали являются следующие варианты взаимного расположения ее частей:

– одно ребро принадлежит трем и более граням одного и того же тела,

– формообразующие элементы детали касаются только в точке (в точках) или только по линии.

Как исправить эту ошибку

Отредактируйте формообразующие элементы так, чтобы они пересекались или имели совпадающие грани.


Масштабирование с заданным коэффициентом невозможно

Это предупреждение появляется после того как в процессе масштабирования модели было введено недопустимое (слишком маленькое) значение коэффициента масштабирования.

Как исправить эту ошибку

Увеличьте коэффициент масштабирования в поле Коэффициент на Панели свойств.


Боковое ребро касается границы, поэтому не может быть продолжено

Это сообщение появляется, если боковые ребра поверхности соединения строятся как продолжения боковых ребер соединяемых поверхностей, но при этом боковые ребра поверхностей (или хотя бы одно из них) по касательной соединяются с ребрами — границами поверхности соединения.

Как исправить эту ошибку

– Отредактируйте одну или обе соединяемые поверхности (или их исходные объекты) таким образом, чтобы ребра — границы поверхности соединения не были касательны к соседним ребрам.

– Или отредактируйте поверхность соединения, поменяв для одной или обеих границ положение боковых ребер Как продление исходных боковых ребер на положение Перпендикулярно границе.


Кривая нулевой длины

Это сообщение появляется, если длина кривой становится равна нулю. Например, в результате редактирования модели (ее переменных или объектов) совпали вершины отрезка.

Как исправить эту ошибку

Войдите в режим редактирования ошибочного объекта и откорректируйте значения параметров так, чтобы длина кривой отличалась от нуля. Если параметр связан с переменной или объектом, то для изменения значения нужно отменить связь. Если связь должна быть сохранена, то для исправления ошибки следует изменить значение переменной или объект, с которым связана кривая.


Некорректное положение зазора

Это сообщение появляется, если текущее положение зазора в линейчатой обечайке делает ее построение невозможным. Такое происходит в следующих случаях:

– зазор полностью или частично оказывается на сгибе, автоматически сформированном на стыках граней обечайки,

– внутри или на границе зазора оказывается точка контура, в которой сопрягаются два его участка (например, отрезок и дуга); частным случаем такой точки является начальная точка замкнутой гладкой кривой (окружность, эллипс, сплайн), совпадающая с ее же конечной точкой.

Как исправить эту ошибку

– Отредактируйте размещение зазора. Для этого измените значение параметра, управляющего положением зазора: либо путем редактирования ошибочной операции, либо путем редактирования значения соответствующей переменной в Окне переменных.
В некоторых случаях ошибку можно исправить, уменьшив ширину зазора так, чтобы он не захватывал автоматически сформированный сгиб или вершину контура.

– Или измените форму либо положение эскиза (эскизов) оснований.


Точка находится за пределами грани

Это сообщение появляется после того, как в результате редактирования модели точка, положение которой на грани ограничено контуром этой грани (при построении была включена опция Учитывать границы), оказывается за пределами грани.

Как исправить эту ошибку

Войдите в режим редактирования ошибочной точки и измените параметры ее построения:

– измените значение параметров, определяющих положение точки, так, чтобы она оказалась внутри контура грани;

– или отключите опцию Учитывать границы.


Ошибка создания разреза/сечения

Это предупреждение появляется, если при формировании разреза (сечения) по каким-либо причинам оказывается невозможным рассечение трехмерной модели плоскостями, соответствующими обозначению линии разреза.


Некорректная линия разреза/сечения

Это предупреждение появляется в том случае, когда в результате редактирования линии разреза/сечения она приобрела недопустимую конфигурацию (например, возникло ее самопересечение).

Как исправить эту ошибку

Войдите в режим редактирования ошибочной линии разреза/сечения и измените ее конфигурацию так, чтобы построение разреза (сечения) стало возможным.


После сшивки остались несвязанные между собой части

После сшивки остались
несвязанные между собой части

Это сообщение появляется, если при построении (перестроении) операции Сшивка поверхностей оказывается, что некоторые ребра невозможно сшить. Например, среди указанных для сшивки поверхностей есть такие, расстояние между ближайшими открытыми ребрами которых превышает значение точности, указанное для сшивки.

Как исправить эту ошибку

– Отредактируйте сшиваемые поверхности так, чтобы их сшивка была возможна.

– Или войдите в режим редактирования операции Сшивка поверхностей и увеличьте значение в поле Точность на Панели свойств.


Ошибка в операции сшивки

Это предупреждение появляется, если после редактирования модели одна или несколько поверхностей, участвующих в операции сшивки, перестраиваются некорректно, в результате чего не может быть рассчитано их положение.


Пересечение с осью

Это предупреждение появляется после того, как в результате редактирования эскиза элемента вращения контур в нем стал пересекать ось (отрезок, изображенный стилем линии «Осевая», или его продолжение).

Как исправить эту ошибку

Войдите в режим редактирования эскиза и измените изображение в нем так, чтобы оно соответствовало требованиям операции.

Требования к эскизу элемента вращения

Требования к эскизу поверхности вращения


Пустой эскиз

Это предупреждение появляется после того, как в результате редактирования эскиза в нем не осталось элементов, которые можно использовать при выполнении операции.

Как исправить эту ошибку

Войдите в режим редактирования эскиза и измените изображение в нем так, чтобы оно соответствовало требованиям операции.


Невозможно выполнить операцию

Это предупреждение появляется в следующих случаях.

– Если при создании или редактировании элемента выясняется, что сочетание выбранных опорных объектов, заданных свойств и введенных значений параметров таково, что построение этого элемента невозможно. Примеры...

– Если задано недопустимое значение одного или нескольких числовых параметров элемента при его создании (редактировании) либо при редактировании переменных и выражений модели. Примеры...

– Если в результате редактирования модели опорные объекты какой-либо операции были удалены или некорректно перестроены, или изменены так, что использование их в качестве опорных стало невозможно. Система не может выполнить эту операцию (перестроить соответствующий ей элемент) и отмечает ее как ошибочную. Пример...


Невозможно выполнить операцию. Пример 1

Допустим, в качестве линии сгиба в операции Сгиб по линии указано ребро листового тела. Возможность выполнения операции зависит от сочетания выбранной неподвижной стороны и выбранного способа сгиба.

а) | б)

– Если неподвижная сторона — грань детали, примыкающая к указанному ребру (рис. а), то выполнение операции возможно при всех способах сгиба, кроме способа По линии сгиба.

– Если неподвижная сторона — полуплоскость, противоположная грани (рис. б), то выполнение операции возможно, наоборот, только при сгибании По линии сгиба.

Поэтому, если для выбранной неподвижной стороны указан некорректный способ сгиба, то после нажатия кнопки Создать объект появляется сообщение об ошибке «Невозможно выполнить операцию». Причина ее в том, что «гнуть» оказывается нечего.

Следующий пример...


Невозможно выполнить операцию. Пример 2

Возможность выполнения операции Подсечка определяется, главным образом, сочетанием следующих параметров:

– толщина листового тела S,

– угол сгиба a,

– внутренний радиус сгиба R,

– высота H,

– положение линии сгиба.

На рис. 1 показана подсечка с добавлением материала. Из рисунка видно, что подсечка выйдет за свою границу при следующих (более или менее значительных) изменениях параметров:

– уменьшение угла сгиба,

– увеличение радиуса или высоты,

– смещение линии сгиба к границе подсечки.

Любое из этих изменений приведет к невозможности построения.

На рис. 2 показана подсечка без добавления материала.

Любое из вышеперечисленных изменений параметров подсечки приведет к тому, что длины заготовки «перестанет хватать» для создания элемента, и построение окажется невозможным.

Существование подсечки без продолжения второго сгиба, например, как на рисунке 3, недопустимо. Поэтому сочетание параметров, дающее этот вариант подсечки, тоже приводит к невозможности построения.

Предыдущий пример...


Невозможно выполнить операцию. Пример 3

Возможность построения приклеиваемых и вырезаемых тонкостенных элементов, а также оболочек с направлением добавления материала Внутрь ограничивается значением толщины стенки. Если задана толщина, приводящая к самопересечению элемента, выполнение операции становится невозможным.

Следующий пример...


Невозможно выполнить операцию. Пример 4

Возможность построения элемента выдавливания с уклоном внутрь ограничивается углом уклона. Если задано значение угла, приводящее к самопересечению элемента, выполнение операции становится невозможным.

Предыдущий пример...


Невозможно выполнить операцию. Пример 5

Допустим, при построении массива операций по концентрической сетке для определения оси массива была указана цилиндрическая грань, принадлежащая элементу выдавливания.

Впоследствии эскиз элемента был отредактирован: дугу в нем заменили кривой Безье. В результате грань, ось которой использовалась в массиве, перестала быть цилиндрической.

Система не может построить ось такой грани, а, следовательно, и массив, использовавший эту ось. Операция «Массив по концентрической сетке» отмечается ошибкой «Невозможно выполнить операцию».


Не определена ось

Это предупреждение появляется, если во фрагменте, который используется в качестве эскиза профиля для отверстия, отсутствует отрезок со стилем линии Осевая.

Как исправить эту ошибку

Откройте библиотеку, содержащую эскиз профиля ошибочного отверстия, и добавьте в него отрезок с указанным стилем линии.


Пересечение контуров

Это предупреждение появляется после того, как в результате редактирования эскиза он перестал соответствовать общим требованиям, предъявляемым к эскизам.

Как исправить эту ошибку

Войдите в режим редактирования эскиза и измените изображение в нем так, чтобы оно соответствовало общим требованиям.


Фрагмент не найден в библиотеке

Это предупреждение появляется, если система не может обнаружить в подключенной библиотеке отверстий эскиз профиля, использовавшийся при построении отверстия.

Как исправить эту ошибку

Подключите библиотеку отверстий, в которой есть использовавшийся при построении отверстия эскиз.

Для этого вызовите команду Сервис — Параметры — Система — Редактор моделей — Библиотеки конструкторских элементов. Нажмите кнопку с многоточием рядом с полем Имя файла библиотеки отверстий. В стандартном диалоге открытия файлов укажите файл библиотеки фрагментов, который должен использоваться в качестве библиотеки эскизов; нажмите кнопку Открыть. Название выбранного файла и путь к нему появятся в поле Имя файла библиотеки отверстий. Закройте диалог настройки, нажав кнопку OK.


Контур должен быть замкнут

Это предупреждение появляется после того, как в результате редактирования эскиза он перестал соответствовать требованиям операции, которая его использует.

Как исправить эту ошибку

Войдите в режим редактирования эскиза и измените изображение в нем так, чтобы оно соответствовало требованиям операции.


Контур должен быть разомкнут

Это предупреждение появляется после того, как в результате редактирования эскиза он перестал соответствовать требованиям операции, которая его использует.

Как исправить эту ошибку

Войдите в режим редактирования эскиза и измените изображение в нем так, чтобы оно соответствовало требованиям операции.


Контуры должны быть либо все замкнуты, либо все разомкнуты

Это предупреждение появляется после того, как в результате редактирования эскиза он перестал соответствовать требованиям операции, которая его использует. Например, если в эскизе элемента выдавливания есть несколько контуров, то создание элемента возможно, только если все контуры либо разомкнуты, либо замкнуты.

Как исправить эту ошибку

Войдите в режим редактирования эскиза и измените изображение в нем так, чтобы оно соответствовало требованиям операции.


Осевая линия не пересекает сечения

Это предупреждение появляется после того, как в результате редактирования модели эскиз осевой линии перестал соответствовать требованиям к эскизам операции по сечениям.

Как исправить эту ошибку

Войдите в режим редактирования эскиза и измените изображение в нем так, чтобы оно соответствовало требованиям к эскизу осевой линии операции по сечениям.

Требования к осевой линии


Преобразование текста выполнить невозможно

Это предупреждение появляется в случае, если текст в эскизе не может быть преобразован в кривую NURBS (неоднородный рациональный В-сплaйн) или в контур, состоящий из нескольких кривых NURBS, или в несколько кривых NURBS.

Как исправить эту ошибку

Войдите в режим редактирования эскиза и измените шрифт, которым набран текст. Рекомендуется использовать TrueType-шрифты.


Эскиз не замкнут

Это предупреждение появляется после того, как в результате редактирования эскиза он перестал соответствовать требованиям операции, которая его использует.

Как исправить эту ошибку

Войдите в режим редактирования эскиза и измените изображение в нем так, чтобы оно соответствовало требованиям операции.


Эскиз не пересекает деталь

Это предупреждение появляется после того, как в результате редактирования эскиза он перестал соответствовать требованиям операции, которая его использует.

Как исправить эту ошибку

Войдите в режим редактирования эскиза и измените изображение в нем так, чтобы оно соответствовало требованиям операции.


Самопересечение

Это предупреждение появляется после того, как в результате редактирования модели совпали некоторые области одного формообразующего элемента.

Как исправить эту ошибку

Войдите в режим редактирования ошибочного элемента и введите его параметры, не приводящие к возникновению самопересечения.


Самопересечение в продолжении контура

Это предупреждение появляется после того, как в результате редактирования эскиза ребра жесткости появилось самопересечение в продолжении контура эскиза.

Как исправить эту ошибку

Войдите в режим редактирования ошибочного эскиза и измените его так, чтобы самопересечение не возникало.


Контуры в эскизе не должны пересекаться и/или иметь общие точки

Это предупреждение появляется после того, как в результате редактирования эскиза он перестал соответствовать общим требованиям, предъявляемым к эскизам.

Как исправить эту ошибку

Войдите в режим редактирования эскиза и измените изображение в нем так, чтобы оно соответствовало общим требованиям.


Не хватает осей

Это предупреждение появляется после того, как в результате редактирования эскиза элемента вращения в нем не оказалось оси вращения.

Как исправить эту ошибку

– Войдите в режим редактирования эскиза и измените изображение в нем так, чтобы оно соответствовало требованиям операции.

– Или отредактируйте операцию, указав существующий объект в качестве оси вращения.


Слишком много осей

Это предупреждение появляется после того, как в результате редактирования эскиза элемента вращения в нем оказалось более одной оси вращения.

Как исправить эту ошибку

Войдите в режим редактирования эскиза и измените изображение в нем так, чтобы оно соответствовало требованиям операции.


Для данной операции в эскизе должен быть один контур

Это предупреждение появляется после того, как в результате редактирования эскиза он перестал соответствовать требованиям операции, которая его использует. Как правило, это случается после редактирования эскиза сечения кинематического элемента или эскизов элемента по сечениям (в этих эскизах должен быть строго один контур).

Как исправить эту ошибку

Войдите в режим редактирования эскиза и измените изображение в нем так, чтобы оно соответствовало требованиям операции.


Для данной операции в эскизе должна быть только одна точка

Это предупреждение появляется после того как в процессе редактирования модели в начальный или конечный эскиз операции по сечениям были добавлены точки.

Как исправить эту ошибку

Войдите в режим редактирования эскиза и измените изображение в нем так, чтобы эскиз содержал только одну точку.


Дополняющий угол должен быть больше 0 и меньше 360 градусов

Дополняющий угол должен быть
больше 0 и меньше 360 градусов

Это сообщение появляется, если значение дополняющего угла подсечки - введенное на Панели свойств или в окне Переменных либо найденное из системы уравнений детали - оказывается равным 0° или 360°.

При этих значениях угла длина плоского участка подсечки не определена, поэтому построение невозможно.

Как исправить эту ошибку

Если дополняющий угол равен 0°, увеличьте его, а если 360° — уменьшите.


Угол сгиба должен быть меньше 180 градусов

Это сообщение появляется, если значение угла сгиба подсечки — введенное на Панели свойств или в окне Переменных либо найденное из системы уравнений детали — оказывается больше или равно 180°.

В некоторых случаях значение угла сгиба, заданное пользователем, игнорируется. При этом проверка величины не производится, а для построения используется автоматически рассчитанный угол. Подробнее...

Как исправить эту ошибку

Уменьшите угол сгиба подсечки.


Недопустимое значение параметра для определения длины развертки изогнутого участка сгиба

Недопустимое значение параметра
для определения длины развертки изогнутого участка сгиба

Это сообщение означает, что значение длины развертки сгиба, рассчитанное на основе параметра, полученного из таблицы сгибов, оказалось отрицательным или равным нулю.

Например, из таблицы уменьшений сгибов получено значение уменьшения BD, равное 35. В то же время параметр а равняется 15. Длина развертки цилиндрической части сгиба получается отрицательной: 2*15-35= -5, поэтому сгиб не может быть построен.

Как исправить эту ошибку

Укажите корректную таблицу сгибов с помощью команды Операции — Элементы листового тела — Таблица сгибов — Выбрать или в диалоге настройки листового тела для текущей детали. Затем перестройте деталь.

Если вы получили это сообщение при создании листового тела, то для указания таблицы можно воспользоваться кнопкой Выбрать другую таблицу сгибов. Она расположена справа от поля Файл-источник таблицы сгибов.

Наличие в таблице сгибов значений, при которых построение развертки невозможно — это ошибка составления таблицы. Для ее исправления необходимо отредактировать содержимое таблицы (см. тему Формат таблицы сгибов). Чтобы использовать откорректированную таблицу, необходимо указать ее заново, как описано выше. Это объясняется тем, что таблица сгибов, используемая в детали, хранится в файле этой детали.

Если источник таблицы, хранящейся в текущей детали, недоступен, воспользуйтесь командой Операции — Элементы листового тела — Таблица сгибов — Сохранить как...


Неверный формат таблицы сгибов

Это сообщение означает, что использующаяся в текущей детали таблица сгибов имеет формат, отличный от формата таблицы сгибов.

Оно может появляться в следующих случаях:

– при первой попытке использования таблицы сгибов, т. е. при создании в детали первого листового элемента с определяемой по таблице длиной развертки сгиба,

– в результате смены таблицы сгибов в текущей детали.

Как исправить эту ошибку

Укажите корректную таблицу сгибов с помощью команды Операции — Элементы листового тела — Таблица сгибов — Выбрать или в диалоге настройки листового тела для текущей детали. Затем перестройте деталь.

Если вы получили это сообщение при создании листового тела, то для указания таблицы можно воспользоваться кнопкой Выбрать другую таблицу сгибов. Она расположена справа от поля Файл-источник таблицы сгибов.


В таблице сгибов отсутствуют данные по параметрам сгиба

Это сообщение означает, что из таблицы сгибов, использующейся в текущей детали, нельзя получить значение параметра развертки для сгиба. Такая ситуация может возникать в двух случаях:

– толщина листового тела, внутренний радиус или угол сгиба находятся за пределами таблицы (т.е. для определения параметра развертки требуется экстраполяция табличных значений),

– при отключенной интерполяции (см. тему Формат таблицы сгибов) значение толщины листового тела, угла сгиба или внутреннего радиуса, не равно табличному значению.

Как исправить эту ошибку

– Укажите таблицу сгибов, содержащую параметр развертки для заданных толщины, радиуса и угла сгиба. Для этого воспользуйтесь командой Операции — Элементы листового тела — Таблица сгибов — Выбрать или диалогом настройки листового тела для текущей детали. Затем перестройте деталь.

Если вы получили это сообщение при создании листового тела, то для указания таблицы можно воспользоваться кнопкой Выбрать другую таблицу сгибов. Она расположена справа от поля Файл-источник таблицы сгибов.

– Или отредактируйте листовое тело так, чтобы значения ее параметров совпадали с табличными.

– Или отредактируйте таблицу сгибов, включив применение интерполяции. Чтобы использовать исправленную таблицу, необходимо указать ее заново, как описано выше. Это объясняется тем, что таблица сгибов, используемая в детали, хранится в файле этой детали.

Если источник таблицы, хранящейся в текущей детали, недоступен, воспользуйтесь командой Операции — Элементы листового тела — Таблица сгибов — Сохранить как...


Не найдена таблица сгибов

Это сообщение означает, что таблица сгибов, указанная при настройке текущей детали, не найдена по заданному пути.

Предупреждение появляется при первой попытке использования таблицы сгибов, т. е. при создании в детали первого листового элемента, у которого длина развертки сгиба определяется по таблице.

Как исправить эту ошибку

Укажите существующую таблицу сгибов с помощью команды Операции — Элементы листового тела — Таблица сгибов — Выбрать или в диалоге настройки листового тела для текущей детали. Затем перестройте деталь.

Если вы получили это сообщение при создании листового тела, то для указания таблицы можно воспользоваться кнопкой Выбрать другую таблицу сгибов на Панели свойств. Она расположена справа от поля Файл-источник таблицы сгибов.


Полный размер высоты должен быть больше толщины листового материала

Полный размер высоты должен быть больше
толщины листового материала

Это предупреждение появляется, если в результате редактирования листового тела полная высота штамповки стала меньше или равна толщине листового материала.

Как исправить эту ошибку

– Войдите в режим редактирования ошибочной штамповки и задайте значение полной высоты, превышающее толщину листового тела.

– Если ширине сгиба присвоена переменная, то откройте Окно переменных и измените значение соответствующей переменной.

– Или уменьшите толщину листового тела.


Невозможно выполнить операцию.Эскиз не проецируется на базовую грань буртика и пластины

Невозможно выполнить операцию.
Эскиз не проецируется на базовую грань буртика и пластины

Эта ошибка появляется после того, как в результате редактирования модели проекция контура в эскизе буртика или пластины оказалась за пределами грани листового тела, на которой этот эскиз построен.

Как исправить эту ошибку

– отредактируйте листовое тело так, чтобы линии эскиза проецировались на базовую грань,

– или отредактируйте эскиз так, чтобы его линии проецировались на базовую грань.


Угол сгиба должен быть больше нуля

Это предупреждение появляется, если в результате редактирования листового тела угол какого-либо сгиба стал равен 0. Например, переменная, соответствующая величине угла, приняла значение 0.

Поскольку нулевой угол означает отсутствие сгиба, построение становится невозможно, и сгиб отмечается как ошибочный.

Как исправить эту ошибку

Измените значение угла сгиба (или соответствующей переменной) так, чтобы оно было больше нуля.


Дополняющий угол не может быть равен 180 градусам

Это предупреждение появляется, если в результате редактирования листового тела дополняющий угол какого-либо сгиба стал равен 180 градусам. Например, переменная, соответствующая величине угла, приняла значение 180.

Поскольку развернутый дополняющий угол означает отсутствие сгиба, построение становится невозможно, и сгиб отмечается как ошибочный.

Как исправить эту ошибку

Измените значение дополняющего угла (или соответствующей переменной) так, чтобы оно отличалось от 180.


Наружный радиус сгиба должен быть больше толщины листового материала

Наружный радиус сгиба
должен быть больше толщины листового материала

Это предупреждение появляется, если в результате редактирования листового тела наружный радиус сгиба оказывается меньше установленной толщины листового материала. Например, после создания сгиба толщина листового тела была увеличена.

Внутренний и наружный радиусы сгиба связаны соотношением:

Rнаружн.= Rвнутр.+ S,

где S — толщина материала.

Поскольку минимальное значение внутреннего радиуса — 0,0002 мм, минимальное значение наружного радиуса должно равняться сумме (S + 0,0002) мм.

Как исправить эту ошибку

Измените значение наружного радиуса сгиба (или соответствующей переменной) так, чтобы оно удовлетворяло указанному требованию.


Для отступа внутрь его величина должна быть меньше длины выбранного ребра

Для отступа внутрь его величина
должна быть меньше длины выбранного ребра

Это предупреждение появляется, если в результате редактирования листового тела ширина сгиба стала отрицательной или нулевой в результате того, что отступ, направленный внутрь (т.е. модуль отрицательного отступа), превысил длину ребра, на котором располагается сгиб или стал равен ей.

Как исправить эту ошибку

– Войдите в режим редактирования ошибочного сгиба и измените значение отступа так, чтобы ширина сгиба стала положительной.

– Если отступу сгиба присвоена переменная, то откройте Окно переменных и измените значение соответствующей переменной.


Длина сгиба очень мала

Это предупреждение появляется, если в результате редактирования листового тела длина сгиба, определяемая способом По контуру или По касанию, стала меньше минимального значения.

Как исправить эту ошибку

– Войдите в режим редактирования ошибочного сгиба и увеличьте длину.

– Если длине сгиба присвоена переменная, то откройте Окно переменных и увеличьте значение соответствующей переменной.


Невозможно создать сгиб с заданными углом на сгибе и глубиной освобождения

Невозможно создать сгиб
с заданными углом на сгибе и глубиной освобождения

Это предупреждение появляется, если в результате редактирования листового тела освобождения сгиба пересеклись, отделив сгиб от тела. Например, переменные, соответствующие длинам освобождений, приняли слишком большие значения.

Как исправить эту ошибку

– Измените значения длин освобождений сгиба (или соответствующих им переменных) так, чтобы освобождения не пересекались.

– Измените значения углов на сгибе (или соответствующих им переменных) так, чтобы освобождения не пересекались.


Из таблицы сгибов получены недопустимые значения для параметров сгиба

Из таблицы сгибов получены недопустимые значения для
параметров сгиба

Это сообщение означает, что из таблицы сгибов, использующейся в текущей детали, получено такое значение параметра развертки, которое выходит за допустимые пределы. Пределы значений параметров развертки следующие:

– коэффициент положения нейтрального слоя: от 0 до 1 включительно,

– величина сгиба: от 500000 до 0,0002 включительно,

– уменьшение сгиба: от — 500000 до 500000 включительно.

Сообщение может появляться в следующих случаях:

– при первой попытке использования таблицы сгибов, т. е. при создании в детали первого листового элемента с определяемой по таблице длиной развертки сгиба,

– в результате смены таблицы сгибов в текущей детали.

Как исправить эту ошибку

Укажите корректную таблицу сгибов с помощью команды Операции — Элементы листового тела — Таблица сгибов — Выбрать или в диалоге настройки листового тела для текущей детали. Затем перестройте деталь.

Если вы получили это сообщение при создании листового тела, то для указания таблицы можно воспользоваться кнопкой Выбрать другую таблицу сгибов. Она расположена справа от поля Файл-источник таблицы сгибов.

Наличие в таблице сгибов значений, находящихся за пределами допустимого диапазона — это ошибка составления таблицы. Для ее исправления необходимо отредактировать содержимое таблицы (см. тему Формат таблицы сгибов). Чтобы использовать откорректированную таблицу, необходимо указать ее заново, как описано выше. Это объясняется тем, что таблица сгибов, используемая в детали, хранится в файле этой детали.

Если источник таблицы, хранящейся в текущей детали, недоступен, воспользуйтесь командой Операции — Элементы листового тела — Таблица сгибов — Сохранить как...


Для отступов внутрь их суммарная величина должна быть меньше длины выбранного ребра

Для отступов внутрь их суммарная величина
должна быть меньше длины выбранного ребра

Это предупреждение появляется, если в результате редактирования листового тела ширина сгиба стала отрицательной или нулевой в результате того, что сумма отступов, направленных внутрь (т.е. сумма модулей отрицательных отступов), превысила длину ребра, на котором располагается сгиб или стала равна ей.

Как исправить эту ошибку

– Войдите в режим редактирования ошибочного сгиба и измените значения отступов так, чтобы ширина сгиба стала положительной.

– Если отступам сгиба присвоены переменные, то откройте Окно переменных и измените значения соответствующих переменных.


Суммарная величина расширений внутрь должна быть меньше ширины продолжения сгиба

Суммарная величина расширений внутрь
должна быть меньше ширины продолжения сгиба

Это предупреждение появляется, если в результате редактирования листового тела ширина продолжения сгиба стала отрицательной или нулевой в результате того, что суммарная величина расширений, направленных внутрь (т.е. сумма модулей отрицательных расширений), превысила исходную ширину продолжения или стала равна ей.

Как исправить эту ошибку

– Войдите в режим редактирования ошибочного сгиба и измените значения расширений продолжения сгиба так, чтобы ширина продолжения стала положительной.

– Если расширениям сгиба присвоены переменные, то откройте Окно переменных и измените значения соответствующих переменных.


Расширение внутрь должно быть меньше ширины сгиба

Это предупреждение появляется, если в результате редактирования листового тела ширина продолжения сгиба стала отрицательной или нулевой в результате того, что величина расширения, направленного внутрь (т.е. модуль отрицательного расширения), превысила исходную ширину продолжения или стала равна ей.

Как исправить эту ошибку

– Войдите в режим редактирования ошибочного сгиба и измените значение расширения продолжения сгиба так, чтобы ширина продолжения стала положительной.

– Если расширению сгиба присвоена переменная, то откройте Окно переменных и измените значение соответствующей переменной.


Ширина сгиба должна быть больше нуля

Это предупреждение появляется, если в результате редактирования листового тела ширина сгиба стала нулевой или отрицательной.

Как исправить эту ошибку

– Войдите в режим редактирования ошибочного сгиба и задайте для него положительную ширину.

– Если ширине сгиба присвоена переменная, то откройте Окно переменных и измените значение соответствующей переменной.

Если ширина определяется автоматически (равна длине ребра), то причиной ошибки могут являться слишком большие значения углов уклона или углов на сгибе.


Угол потерял общее ребро

Это предупреждение появляется, если замыкание угла стало невозможным из-за того, что сгибы, указанные для замыкания, перестали быть смежными. Например, при редактировании какого-либо из сгибов он был смещен.

Как исправить эту ошибку

Отредактируйте сгиб (сгибы) так, чтобы они стали смежными.


Один или более углов потеряли общее ребро

Это предупреждение появляется, если замыкание угла (углов) стало невозможным из-за того, что сгибы, указанные для замыкания, перестали быть смежными. Например, при редактировании какого-либо из сгибов он был смещен.

Как исправить эту ошибку

Отредактируйте сгиб (сгибы) так, чтобы они стали смежными.


Эскиз должен располагаться только на внешней или внутренней плоской грани листового тела

Эскиз должен располагаться только
на внешней или внутренней плоской грани листового тела

Это предупреждение появляется, если в результате редактирования листового тела эскиз отверстия (выреза), построенного способом По толщине, или пластины оказывается на боковой или торцевой грани листового элемента (или листового тела), или на цилиндрической грани сгиба, или на грани нелистового элемента. Пример...

Как исправить эту ошибку

– Измените плоскость эскиза так, чтобы он располагался на внешней или внутренней грани листового тела.

– Войдите в режим редактирования ошибочного отверстия или выреза и смените тип построения По толщине на другой (На глубину или До грани).


Эскиз не проецируется на базовую грань

Это предупреждение появляется, если в результате редактирования листового тела эскиз отверстия (выреза), построенного способом По толщине, или пластины оказывается за пределами грани, на которой он построен.

Пример...

Как исправить эту ошибку

Измените размещение эскиза так, чтобы его положение соответствовало типу элемента.


Сообщение об изменении спецификации

Данное сообщение говорит о передаче данных из текущего документа в спецификацию, с которой он связан. В сообщении указаны имена файлов спецификации и документа, из которого в нее передается информация.

Сообщение появляется при сохранении документа, если:

– документ подключен к объекту спецификации, файл которой открыт на момент сохранения документа,

– в документе изменены данные, передаваемые в спецификацию: отредактировано обозначение документа, в модели произведены операции, изменившие объем и, следовательно, массу тела, и т.п.


Запрос на подтверждение объединения вариантов или дублей описаний спецификаций

Запрос появляется после нажатия кнопки Объединить варианты в диалоге управления описаниями спецификаций. Объединение описаний означает слияние описаний спецификации, содержащих аналогичные друг другу стили спецификации (дубли и варианты стиля). В результате в документе останется только одно описание с данным стилем. Все объекты спецификации, использующие этот стиль, можно будет увидеть в одной таблице. Изменения производятся не только в текущем документе, но и в документах — источниках объектов спецификации.

Вы можете подтвердить объединение описаний спецификаций или отказаться от него. Если в документе есть описания с ненайденными стилями спецификации, то перед началом объединения выдаются запросы на замену стилей в этих описаниях.

В случае успешного объединения на экране появляется сообщение об этом. Вместо нескольких описаний, содержавших дубли и/или варианты стиля спецификации, в диалоге управления описаниями отображается одно описание.

В случае, если объединение описаний не удалось, на экране появляется сообщение об этом с предложением записать в текстовый документ список файлов, препятствующих объединению. Объединение описаний прерывается. В диалоге управления описаниями остаются описания с аналогичными другу стилями.

Подробнее об объединении вариантов описаний спецификаций...


Сообщение о невозможности объединения вариантов или дублей описаний спецификаций

Данное сообщение появляется при объединении описаний спецификаций, если недоступны файлы — источники объектов спецификации (компоненты или фрагменты) для текущего документа. Например, файлы-источники могут иметь атрибут «Только чтение». В сообщении предлагается сохранить в текстовый документ список файлов, препятствующих объединению описаний спецификаций. Вы можете подтвердить сохранение или отказаться от него.

Описания спецификаций в недоступных файлах остаются без изменений. Процесс объединения описаний спецификации в текущем документе прерывается.

После того, как файлы станут доступны, попытайтесь объединить описания спецификаций снова.

Подробнее об объединении вариантов описаний спецификаций...


Невозможно выставить согласованную ориентацию граней

Невозможно выставить
согласованную ориентацию граней

Это сообщение появляется, если при сшивке поверхностей обнаруживается, что невозможно согласовать ориентацию для какой-либо «цепочки» сшиваемых граней.

Например, невозможно сшить поверхности, образующие ленту Мебиуса.

Как исправить эту ошибку

Исключите из списка сшиваемых объект (поверхность или деталь), входящий в эту «цепочку».


Не удалось установить нормали граней наружу тела

Это сообщение появляется, если при построении операции Сшивка поверхностей с созданием тела оказывается, что, хотя вновь полученная поверхность замкнута, невозможно определить, направлены ли нормали ее граней внутрь или наружу.

Модели, в которых проявляется данная ошибка, присылайте, пожалуйста, в Службу технической поддержки.


Некоторые ребра остались несшитыми

Это сообщение появляется, если при построении (перестроении) операции Сшивка поверхностей с созданием тела оказывается, что некоторые ребра невозможно сшить, и, следовательно, невозможно образовать тело. Например, для сшивки указаны поверхности, расстояние между ближайшими открытыми ребрами которых превышает значение точности, указанное для сшивки.

Как исправить эту ошибку

– Отредактируйте сшиваемые поверхности так, чтобы их сшивка с образованием замкнутой поверхности была возможна.

– Или войдите в режим редактирования операции Сшивка поверхностей и увеличьте значение в поле Точность на Панели свойств.


Невозможно построить поверхность по пласту точек

Это сообщение появляется, если точки, заданные для построения поверхности по пласту точек, расположены так, что по ним невозможно построить корректную поверхность.

Как исправить эту ошибку

– Отредактируйте точки пласта таким образом, чтобы они образовывали регулярную сеть с четырехугольными ячейками. Для этого можно изменить расположение точек, или удалить некоторые точки, или добавить новые. После этого снова попытайтесь построить поверхность по точкам.

– Или используйте для создания поверхности команду Поверхность по сети точек.


Не определен базовый объект резьбы

Это предупреждение появляется, если в результате редактирования модели объект, выбранный в качестве базового для построения резьбы, изменяет свою форму так, что это построение становится невозможным.

Например, резьба была построена на конической или цилиндрической грани, полученной выдавливанием сечения-окружности. Впоследствии эскиз в сечении был отредактирован и превратился в многоугольник.

Или, например, резьба была построена на конической или цилиндрической грани, полученной вращением эскиза-отрезка вокруг оси. Впоследствии эскиз в сечении был отредактирован и превратился в дугу.

И в том, и в другом случае редактирование эскиза приводит к исчезновению поверхности, пригодной для создания резьбы.

Как исправить эту ошибку

Отредактируйте модель так, чтобы в ней присутствовала поверхность для создания данной резьбы.


Недопустимый начальный диаметр резьбы

Это предупреждение появляется, если в результате редактирования модели вырождается начальный диаметр резьбы.

Например, резьба была построена на цилиндрической грани, полученной вращением эскиза-отрезка вокруг оси. Впоследствии эскиз в сечении был отредактирован так, что одна из его вершин оказалась расположенной на оси вращения. В результате поверхность, на которой построена резьба, превратилась в полный (не усеченный) конус, и определение начального радиуса резьбы стало невозможным.

Как исправить эту ошибку

– Отредактируйте модель так, чтобы поверхность, выбранная для построения резьбы, представляла собой усеченный конус.

– Или войдите в режим редактирования ошибочного изображения резьбы, выключите опцию На всю длину и введите значение длины (меньшее, чем высота конуса), при котором построение резьбы возможно.


Недопустимый конечный диаметр резьбы

Это предупреждение появляется, если в результате редактирования модели вырождается конечный диаметр резьбы.

Например, при создании конической резьбы были указаны ее границы — некоторые плоские грани. Впоследствии конечная грань оказалась расположена так далеко от начальной, или диаметр резьбы уменьшился настолько, что коническая поверхность, заданная для построения резьбы, замкнулась или стала двухполостной.

Как исправить эту ошибку

– Отредактируйте модель так, чтобы границы резьбы были расположены на расстоянии, при котором возможно построение резьбы.

– Или войдите в режим редактирования ошибочного изображения резьбы и укажите для его построения другие границы либо увеличьте диаметр резьбы.


Не определена длина резьбы

Это предупреждение появляется, если в результате редактирования модели длина резьбы становится равной нулю. Например, при создании резьбы в качестве начальной и конечной границ были указаны две плоские грани детали. Впоследствии эти грани оказались расположенными в одной плоскости.

Как исправить эту ошибку

– Отредактируйте модель так, чтобы границы резьбы были расположены в разных плоскостях.

– Или войдите в режим редактирования ошибочного изображения резьбы и укажите для его построения другие границы.


Большое количество точек. Уменьшите количество

Это предупреждение появляется после того как в процессе создания или редактирования группы точек по поверхности было задано недопустимое (слишком большое) количество точек сетки.

Как исправить эту ошибку

Увеличьте шаг (шаги) сетки.


Слишком большое количество точек

Это сообщение появляется в случае, если в результате редактирования модели в группе точек по поверхности, построенной способом По линейному отклонению или По угловому отклонению, количество точек в одном из направлений или в каждом направлении оказывается больше 1000.

Как исправить эту ошибку

– Войдите в режим редактирования ошибочной группы точек и увеличьте значение отклонения.

– Или отредактируйте поверхность, по которой построены точки, так, чтобы кривизна поверхности в разных ее точках стала приблизительно одинаковой.


Секущий объект не полностью пересекает поверхность

Это сообщение появляется после того, как в результате редактирования модели секущий объект перестал полностью пересекаться с усекаемой или разбиваемой поверхностью. Например, грань была разбита или усечена по эскизу, содержащему отрезок, который пересекал контур грани в двух точках. Затем отрезок укоротили так, что он стал оканчиваться внутри контура грани. Выполнение операции усечения или разбиения в этом случае невозможно, поэтому она отмечается как ошибочная.

Как исправить эту ошибку

Отредактируйте секущий объект или поверхность так, чтобы они удовлетворяли требованиям операции.

Требования к объектам операции усечения…

Требования к объектам операции разбиения…


Секущий объект не пересекает поверхность или линия пересечения совпадает с границей поверхности

Это сообщение появляется после того, как в результате редактирования модели секущий объект перестал пересекаться с усекаемой или разбиваемой поверхностью либо стал пересекаться с ней по линии, совпадающей с контурами этой поверхности.

Как исправить эту ошибку

Отредактируйте секущий объект или поверхность так, чтобы линия их пересечения существовала и не совпадала с контурами усекаемой поверхности.

Требования к объектам операции усечения…

Требования к объектам операции разбиения…


Ознакомительный режим работы КОМПАС-3D

Ознакомительный режим работы КОМПАС-3D автоматически включается, если при запуске системы не обнаружена необходимая лицензия. В ознакомительном режиме обеспечивается полная функциональность системы и всех ее компонентов. Период работы в ознакомительном режиме — 30 календарных дней с момента первого запуска КОМПАС-3D. Ознакомительный период является однократным для конкретного компьютера.

Приобрести программные продукты АСКОН можно в интернет-магазине АСКОН либо обратившись в офис АСКОН или к партнеру АСКОН.

Смотрите также

Порядок использования защищенного программного обеспечения


Секущий объект не является связной совокупностью кривых или граней

Это сообщение появляется после того, как в результате редактирования модели грани (или кривые), составляющие секущий объект, перестали образовывать связную совокупность граней (или кривых).

Как исправить эту ошибку

– Отредактируйте объекты, которым принадлежат грани или кривые, составляющие секущий объект, таким образом, чтобы эти грани или кривые образовывали связную совокупность.

– Или отредактируйте операцию усечения, указав для нее объекты, образующие связную совокупность.

– Или, если это возможно, вместо одной операции усечения выполните несколько — по количеству секущих объектов.


Группа кривых не содержит ни одной кривой

Это сообщение появляется, если количество изопараметрических кривых в группе по обоим направлениям равно 2, а границы поверхности исключены из состава группы. Так как в данном случае содержимым группы являются именно границы, их отключение приводит к возникновению пустой группы.

Как исправить эту ошибку

Отредактируйте группу изопараметрических кривых, включив в нее границы поверхности или увеличив количество кривых хотя бы по одному из направлений.


Сеть кривых не образует необходимого количества узлов

Это сообщение появляется, если среди кривых, указанных для построения поверхности по сети кривых, имеется:

– хотя бы одна пара кривых разных направлений (U и V), которые не имеют общих точек,

– и/или хотя бы одна пара кривых одного направления (U или V), которые имеют общую точку.

Если в качестве крайней кривой какого-либо направления используется точка, то такое сообщение появляется, если хотя бы одна из кривых противоположного направления не проходит через эту точку.

Как исправить эту ошибку

– Отредактируйте кривые (и/или точки), используемые для построения, так, чтобы выполнялись требования к кривым и точкам сети.

– Или отредактируйте поверхность по сети кривых, указав другие кривые и/или точки, которые удовлетворяют требованиям к кривым и точкам сети.


В сети кривых есть узлы, содержащие взаимное касание кривых разных направлений

Это сообщение появляется, если среди кривых, указанных для построения поверхности по сети кривых, имеется хотя бы одна пара кривых разных направлений (U и V), которые в точке пересечения имеют общую касательную.

Как исправить эту ошибку

– Отредактируйте одну или обе касающиеся кривые так, чтобы, сохраняя пересечение, они перестали касаться.

– Или отредактируйте поверхность по сети кривых, указав другие кривые, которые не касаются в точке пересечения.


Невозможно обеспечить условие сопряжения

Это сообщение появляется после того, как в результате редактирования модели выполнение заданного сопряжения сплайна с объектом модели становится невозможно.
Например, сопрягаемая вершина сплайна перестала принадлежать объекту сопряжения или некорректно перестроен объект сопряжения.

Как исправить эту ошибку

Отредактируйте сплайн или объект сопряжения таким образом, чтобы выполнение сопряжения стало возможным.


Заданное условие сопряжения не может быть выполнено.Добавьте вершины или измените условие сопряжения

Заданное условие сопряжения не может быть выполнено.
Добавьте вершины или измените условие сопряжения

Это сообщение появляется, если сплайн по полюсам сопряжен с существующим объектом, но для выбранного условия сопряжения сплайн имеет недостаточное количество полюсов, соседних с вершиной сопряжения. Подробнее...

Как исправить эту ошибку

– Отредактируйте сплайн, добавив новые вершины непосредственно после вершины, в которой сплайн сопрягается с объектом.

– Или выберите другое условие сопряжения сплайна с объектом.

– Или, если это допустимо, смените тип сплайна (выберите тип По точкам вместо типа По полюсам).


Неверный параметр в таблице переменных

Это сообщение появляется, если переменная экземпляра массива получает такое значение, при котором создание экземпляра невозможно.

Как исправить эту ошибку

Войдите в режим редактирования массива, откройте таблицу изменяемых переменных и отредактируйте значение ошибочного параметра так, чтобы создание экземпляра массива было возможно. Значение параметра также можно изменить в Окне переменных.


Оба диаметра равны нулю

Это предупреждение появляется после того как в процессе редактирования модели начальный и конечный диаметры конической спирали стали равны нулю.

Как исправить эту ошибку

Войдите в режим редактирования спирали и введите ненулевое значение для одного или обоих диаметров.


Невозможно определить положение плоскости обозначения

Это сообщение появляется в случае, если в результате редактирования модели объект фиксации изменился или переместился так, что через него уже невозможно провести плоскость, пригодную для простановки обозначения — параллельную базовой и проходящую через объект, к которому проставляется обозначение.

Как исправить эту ошибку

– Отредактируйте объект фиксации плоскости обозначения так, чтобы через него можно было провести пригодную для простановки обозначения плоскость.

– Или войдите в режим редактирования ошибочного обозначения и отмените фиксацию плоскости или укажите другой объект фиксации.

Сообщение о невозможности определения плоскости обозначения появляется также после смены базовой плоскости размера или обозначения, использовавшегося в качестве объекта для простановки обозначения с несколькими ответвлениями (линии-выноски или допуска формы).

В этом случае для исправления ошибки нужно отредактировать размер, вернув его базовую плоскость или удалить ошибочное обозначение.


Невозможно выполнить копирование в радиальном направлении

Это сообщение появляется, если в результате редактирования модель изменилась так, что базовая точка копируемого объекта (или первого по списку объекта, если их несколько) оказалась на оси этого массива. Направление лучей сетки в данном случае определить невозможно, поэтому количество копий в радиальном направлении может быть равно только 1. При большем количестве копий в радиальном направлении массив отмечается в Дереве построения как ошибочный.

Как исправить эту ошибку

– Если вас устраивает равное 1 количество копий в радиальном направлении, войдите в режим редактирования ошибочного массива и уменьшите это количество до 1.

– Или отредактируйте модель так, чтобы базовая точка копируемого объектам не лежал на оси массива.


Кривая для усечения должна быть не замкнута

Это сообщение появляется после того, как в результате редактирования модели кривая, указанная для усечения, стала замкнута.

Как исправить эту ошибку

Отредактируйте усекаемую кривую, разомкнув ее.


Усечение кривой в ее конечной вершине невозможно

Это сообщение появляется после того, как в результате редактирования модели усекаемая кривая стала пересекаться с усекающим объектом в своей конечной вершине.

Как исправить эту ошибку

– Отредактируйте усекаемую кривую или усекающий объект так, чтобы точка их пересечения не совпадала с конечной вершиной кривой.

– Или войдите в режим редактирования ошибочной операции усечения и укажите в качестве усекающего другой объект.


Невозможно определить точку пересечения

Это сообщение появляется после того, как в результате редактирования модели усеченная кривая перестала пересекаться с усекающим объектом.

Как исправить эту ошибку

– Отредактируйте усекаемую кривую или усекающий объект так, чтобы они пересекались.

– Или войдите в режим редактирования ошибочной операции усечения и укажите в качестве усекающего объект, который пересекается с усекаемой кривой.


Операция потеряла один или все компоненты

Это предупреждение появляется после того как в процессе редактирования модели были удалены один или несколько компонентов, использовавшиеся при выполнении операции.

Как исправить эту ошибку

Войдите в режим редактирования операции, которая стала ошибочной. Укажите в качестве исходных объектов существующие компоненты модели.


Плоскости, образующие ось, параллельны

Это предупреждение появляется после того, как в результате редактирования модели стали параллельными плоскости, использовавшиеся при построении плоскости на пересечении двух плоскостей.


Ось потеряла опорную плоскость

Это предупреждение появляется после того, как в результате редактирования модели была удалена или некорректно перестроена плоскость, использовавшаяся при построении плоскости на пересечении двух плоскостей.


Ось имеет совпадающие опорные вершины

Это предупреждение появляется после того, как в результате редактирования модели совпали вершины, использовавшиеся при построении оси через две вершины, в результате чего невозможно однозначно определить положение оси.

Как исправить эту ошибку

Войдите в режим редактирования оси и укажите в качестве опорных объектов две несовпадающие вершины.


Ось потеряла опорную вершину

Это предупреждение появляется после того, как в результате редактирования модели была удалена вершина, использовавшаяся при построении оси.

Как исправить эту ошибку

Войдите в режим редактирования оси и укажите в качестве опорного объекта существующую в модели вершину.

Иногда эта ошибка автоматически устраняется после исправления ошибочного формообразующего элемента, на вершине которого основывалось построение оси.


Ось потеряла опорное ребро

Это предупреждение появляется после того, как в результате редактирования модели было удалено или некорректно перестроено ребро, использовавшееся при построении оси.

Как исправить эту ошибку

Войдите в режим редактирования оси и укажите в качестве опорного объекта существующее в модели ребро.

Иногда эта ошибка автоматически устраняется после исправления ошибочного формообразующего элемента, на ребре которого основывалось построение оси.


Ось потеряла коническую грань

Это предупреждение появляется после того, как в результате редактирования модели был удален или некорректно перестроен элемент, коническая грань которого использовалась при построении оси.

Как исправить эту ошибку

Войдите в режим редактирования оси и укажите в качестве опорного объекта существующую в модели коническую грань.

Иногда эта ошибка автоматически устраняется после исправления ошибочного формообразующего элемента, грань которого использовалась при построении оси.


Ось потеряла опорную операцию

Это предупреждение появляется после того, как в результате редактирования модели был удален или некорректно перестроен элемент, использовавшийся при построении оси.

Как исправить эту ошибку

Войдите в режим редактирования оси и укажите в качестве опорного объекта существующий в модели элемент.

Иногда эта ошибка автоматически устраняется после исправления ошибочного формообразующего элемента, на котором основывалось построение оси.


Плоскость имеет совпадающие опорные вершины

Это предупреждение появляется после того, как в результате редактирования модели совпали вершины, использовавшиеся при построении плоскости через три вершины, в результате чего невозможно однозначно определить положение плоскости.

Как исправить эту ошибку

Войдите в режим редактирования плоскости и укажите в качестве опорных объектов существующие в модели вершины, не лежащие на одной прямой и не совпадающие.

Иногда эта ошибка автоматически устраняется после исправления ошибочного формообразующего элемента, на вершинах которого основывалось построение плоскости.


Плоскость потеряла одну из опорных вершин

Это предупреждение появляется после того, как в результате редактирования модели была удалена вершина, использовавшаяся при построении плоскости через три вершины.

Как исправить эту ошибку

Войдите в режим редактирования плоскости и укажите в качестве опорной существующую в модели вершину.

Иногда эта ошибка автоматически устраняется после исправления ошибочного формообразующего элемента, на вершине которого основывалось построение плоскости.


Опорные вершины плоскости лежат на одной прямой

Это предупреждение появляется после того, как в результате редактирования модели три вершины, использовавшиеся при построении плоскости, стали принадлежать одной прямой, в результате чего невозможно однозначно определить положение плоскости.

Как исправить эту ошибку

Войдите в режим редактирования плоскости и укажите в качестве опорных объектов существующие в модели вершины, не лежащие на одной прямой и не совпадающие.

Иногда эта ошибка автоматически устраняется после исправления ошибочного формообразующего элемента, на вершинах которого основывалось построение плоскости, или после изменения положения компонентов, на вершинах которых основывалось построение плоскости.


Плоскость потеряла опорное ребро

Это предупреждение появляется после того, как в результате редактирования модели было удалено или некорректно перестроено ребро, использовавшееся при построении плоскости.

Как исправить эту ошибку

Войдите в режим редактирования плоскости и укажите в качестве опорного объекта существующее в модели ребро.

Иногда эта ошибка автоматически устраняется после исправления ошибочного формообразующего элемента, на ребре которого основывалось построение плоскости.


Плоскость потеряла опорную грань

Это предупреждение появляется после того, как в результате редактирования модели была удалена или некорректно перестроена грань, использовавшаяся при построении плоскости.

Как исправить эту ошибку

Войдите в режим редактирования плоскости и укажите в качестве опорного объекта существующую в модели грань.

Иногда эта ошибка автоматически устраняется после исправления ошибочного формообразующего элемента, на грани которого основывалось построение плоскости.


Плоскость потеряла решение

Это предупреждение появляется после того, как в результате редактирования модели были удалены или некорректно перестроены объекты, использовавшиеся при построении плоскости, в результате чего система не может решить уравнение, необходимое для определения положения плоскости.


Плоскость потеряла опорную поверхность

Это предупреждение появляется после того, как в результате редактирования модели была удалена или некорректно перестроена грань или плоскость, использовавшаяся при построении плоскости.

Как исправить эту ошибку

Войдите в режим редактирования плоскости и укажите в качестве опорного объекта существующую в модели поверхность.

Иногда эта ошибка автоматически устраняется после исправления ошибочного формообразующего элемента, на поверхности которого основывалось построение плоскости.


Плоскость потеряла опорную вершину

Это предупреждение появляется после того, как в результате редактирования модели была удалена вершина, использовавшаяся при построении плоскости.

Как исправить эту ошибку

Войдите в режим редактирования плоскости и укажите в качестве опорного объекта существующую в модели вершину.

Иногда эта ошибка автоматически устраняется после исправления ошибочного формообразующего элемента, на вершине которого основывалось построение плоскости.


Опорная поверхность не является цилиндрической или конической

Это предупреждение появляется после того, как в результате редактирования модели грань, нормально или касательно к которой была построена плоскость, перестала быть конической или цилиндрической.

Как исправить эту ошибку

Войдите в режим редактирования плоскости и укажите в качестве опорной поверхности цилиндрическую или коническую грань модели.

Иногда эта ошибка автоматически устраняется после исправления ошибочного формообразующего элемента, на вершинах которого основывалось построение плоскости.


Опорная плоскость не является нормальной к опорной поверхности

Это предупреждение появляется после того, как в результате редактирования модели плоскость, использовавшаяся при построении плоскости, касательной к конической грани, перестала быть нормальной к этой грани.

Как исправить эту ошибку

Войдите в режим редактирования плоскости и укажите в качестве опорного объекта другую коническую грань или укажите в качестве опорного объекта другую плоскость (плоскую грань), нормальную к этой конической грани.


Опорная плоскость не параллельна оси опорной поверхности

Это предупреждение появляется после того, как в результате редактирования модели плоскость, использовавшаяся при выполнении операции, перестала быть параллельной оси конической поверхности, использовавшейся при выполнении той же операции.

Как исправить эту ошибку

Войдите в режим редактирования плоскости и укажите в качестве опорного объекта другую ось, параллельную опорной плоскости или укажите в качестве опорного объекта другую плоскость (плоскую грань), параллельную оси опорной поверхности.


Вырожденное направление. Используйте другой направляющий объект

Это сообщение появляется после того, как в результате редактирования модели точечный направляющий объект, указанный для построения точки, стал совпадать с ее опорной точкой.

Как исправить эту ошибку

Войдите в режим редактирования ошибочной точки и укажите другой направляющий объект или другую опорную точку.


Конструктивная точка потеряла опорный объект

Это предупреждение появляется после того, как в результате редактирования модели были удалены или некорректно перестроены объекты, использовавшиеся при построении конструктивной точки.

Как исправить эту ошибку

– Войдите в режим редактирования ошибочной точки и укажите существующую точку в качестве опорной.

– Или отключите ассоциативную связь конструктивной точки с опорной.

Иногда эта ошибка автоматически устраняется после исправления объектов, которые были использованы при построении конструктивной точки.


Контрольная (присоединительная) точка потеряла опорный объект

Контрольная (присоединительная) точка
потеряла опорный объект

Это предупреждение появляется после того, как в результате редактирования модели был удален или некорректно перестроен объект, использовавшийся при построении опорной или присоединительной точки.

Как исправить эту ошибку

Войдите в режим редактирования ошибочного элемента и укажите в качестве опорных объектов существующие части модели.

Иногда эта ошибка автоматически устраняется после исправления элементов, которые были использованы при выполнении операции.


Функция не определена или не является гладкой на заданном интервале

Это сообщение появляется при создании или редактировании кривой по закону в следующих случаях:

– если выражение функции хотя бы для одной координаты точки кривой содержит деление на ноль или деление на ноль возникает при каком-либо значении интервального параметра;

– если на заданном интервале 1-я или 2-я производная функции хотя бы для одной координаты имеет разрыв (особые точки 1-го и 2-го рода).

Как исправить эту ошибку

– Измените выражение функции для координаты точки кривой (или выражения функций для координат);

– Измените границы интервала изменения параметра функции.


Вырожденный интервал

Это сообщение появляется, если начальное значение интервала параметра функции для координаты точки кривой по закону равно конечному значению.

Как исправить эту ошибку

Измените границы интервала изменения параметра функции.


Закон хотя бы по одной координате не должен быть константой

Это сообщение появляется, если для всех координат точки кривой, заданной параметрическими уравнениями, выбран тип функции Константа.

Как исправить эту ошибку

Измените хотя бы для одной координаты точки кривой тип функции (Линейная, Кубическая или По выражению).


Имя интервального параметра совпадаетс именем статического параметра

Имя интервального параметра совпадает
с именем статического параметра

Это сообщение появляется, если при создании или редактировании кривой по закону либо при редактировании параметров этой кривой в Окне переменных имя интервального параметра выражения функции для одной из координат точки кривой совпадает с именем неинтервального параметра выражения функции для другой координаты (с именем статической переменной модели) или с именем пользовательской переменной модели.

Как исправить эту ошибку

Отредактируйте имя пользовательской переменной или имена параметров выражений функций координат так, чтобы они не совпадали.


N-я точка кривой потеряла опорный объект

Это сообщение появляется в после того, как в результате редактирования модели исчез точечный, плоский или прямолинейный объект, являвшийся опорным для сплайна или ломаной. Например, для построения ломаной использовалась вершина прямоугольного элемента выдавливания. Затем эскиз этого элемента отредактировали, скруглив углы прямоугольника. Так как вершина, использующаяся ломаной, исчезла, ломаная отмечается как ошибочная, а в строке таблицы параметров вершин этой вершины появляется красный восклицательный знак.

Как исправить эту ошибку

– отредактируйте модель так, чтобы в ней вновь появился опорный объект кривой,

– или войдите в режим редактирования ошибочной кривой и укажите другой объект в качестве опорного для вершины.


Кривые должны быть либо все замкнуты, либо все разомкнуты

Это сообщение появляется, если в результате редактирования модели часть кривых линейчатой поверхности или часть кривых одного направления поверхности по сети кривых оказалась замкнута, а другая часть — разомкнута.

Как исправить эту ошибку

– Отредактируйте используемые для построения поверхности кривые так, чтобы все они были либо замкнуты, либо разомкнуты.

– Или отредактируйте поверхность, указав другие кривые.


Задана циклическая зависимость

Это сообщение появляется в случаях, когда для решения одного сопряжения (т.е. размещения участвующего в сопряжении компонента так, чтобы условия сопряжения выполнялись) необходимо решение другого сопряжения, которое, в свою очередь, требует решения первого.

Например, исходный компонент массива «А» сопряжен с экземпляром массива «В», а исходный компонент массива «В» — с экземпляром массива «А». Положение экземпляров массива «А» зависит от положения его исходного компонента. Для определения положения этого компонента необходимо решить сопряжение между ним и экземпляром массива «В». Положение же экземпляров массива «В» зависит от положения его исходного компонента, для определения которого необходимо решить сопряжение между ним и экземпляром массива «А».

Как исправить эту ошибку

– Удалите ошибочное сопряжение.


Вырожденная проекция ребра

Это предупреждение появляется после того, как в результате редактирования модели исчезло ребро, проекция которого использовалась при построении объектов, или эта проекция превратилась в точку (ребро стало перпендикулярно плоскости проекции).


Вырожденная проекция вершины

Это предупреждение появляется после того, как в результате редактирования модели исчезла вершина, проекция которой использовалась при построении объектов.


Кривая не прямолинейна

Это сообщение появляется после того, как в результате редактирования модели прямолинейный объект, к которому проставлен линейный размер от отрезка до точки, перестал быть прямолинейным.

Как исправить эту ошибку

– Отредактируйте модель так, чтобы объект стал прямолинейным.

– Если объект не должны быть прямолинейным, удалите размер.


Размер потерял все опорные объекты

Это предупреждение появляется после того, как в результате редактирования модели были удалены или некорректно перестроены объекты, использовавшиеся при построении размера.

Как исправить эту ошибку

Войдите в режим редактирования ошибочного размера и укажите в качестве опорных существующие объекты модели.

Иногда эта ошибка автоматически устраняется после исправления объектов, которые были использованы при построении размера.


Потеряна базовая плоскость

Это предупреждение появляется после того, как в результате редактирования модели плоский объект, использовавшийся в качестве базовой плоскости размера, был удален или стал неплоским.

Как исправить эту ошибку

Войдите в режим редактирования ошибочного размера и укажите в качестве базовой плоскости существующий в модели плоский объект.


Объекты углового размера не пересекаются

Это сообщение появляется после того, как в результате редактирования модели прямолинейные объекты, к которым проставлен угловой размер, перестали пересекаться.

Как исправить эту ошибку

– Отредактируйте модель так, чтобы указанные для простановки размера прямолинейные объекты пересекались.

– Если объекты не должны пересекаться, удалите размер.


Размер потерял один или несколько опорных объектов

Это предупреждение появляется после того, как в результате редактирования модели были удалены или некорректно перестроены объекты, использовавшиеся при построении размера.

Как исправить эту ошибку

Войдите в режим редактирования ошибочного размера и укажите существующие объекты в качестве опорных.

Иногда эта ошибка автоматически устраняется после исправления объектов, которые были использованы при построении размера.


Вершина находится на выбранном ребре

Это сообщение появляется после того, как в результате редактирования модели точечный и прямолинейный объекты, к которым проставлен линейный размер от отрезка до точки, оказались на одной прямой.

Как исправить эту ошибку

– Отредактируйте модель так, чтобы точечный объект не лежал на прямой, содержащей прямолинейный объект.

– Если объекты должны лежать на одной прямой, удалите размер.


Раннее использование выходной переменной

Эта ошибка возникает, если значение какой-либо выходной переменной требуется использовать раньше, чем оно будет определено путем перестроения объекта, параметр которого соответствует этой переменной.

Например, объект A имеет входной параметр а, соответствующий переменной «а», а следующий за ним объект Б — выходной параметр b, соответствующий переменной «b». Если переменные «а» и «b» связать каким-либо уравнением, то корректное перестроение детали станет невозможным: найти значение переменной «а» и перестроить объект А можно только после перестроения объекта Б, а объект Б можно перестроить только после объекта А — это диктуется порядком расположения объектов в Дереве.

Чтобы исправить ошибку, можно попытаться переместить объект А в Дереве построения так, чтобы он располагался ниже объекта Б. Если это удастся, то при следующем перестроении ошибка исчезнет. В противном случае необходимо редактирование детали или системы уравнений.


Ребро не параллельно плоскости

Это предупреждение появляется после того, как в результате редактирования модели ребро, использовавшееся при построении плоскости под углом к другой плоскости, перестало быть параллельным этой плоскости.

Как исправить эту ошибку

Войдите в режим редактирования плоскости и укажите в качестве опорного объекта другое ребро, параллельное опорной плоскости или укажите в качестве опорного объекта другую плоскость (плоскую грань), параллельную опорному ребру.


Операция потеряла все базовые ребра

Это предупреждение появляется после того, как в результате редактирования модели были удалены или некорректно перестроены ребра, использовавшиеся при выполнении операции.

Как исправить эту ошибку

Войдите в режим редактирования ошибочного элемента и укажите в качестве опорных объектов существующие ребра модели.

Иногда эта ошибка автоматически устраняется после исправления элементов, ребра которых были использованы при выполнении операции.


Операция потеряла некоторые базовые ребра

Это предупреждение появляется после того, как в результате редактирования модели были удалены или некорректно перестроены некоторые ребра, использовавшиеся при выполнении операции.

Как исправить эту ошибку

Войдите в режим редактирования ошибочного элемента и укажите в качестве опорных объектов существующие ребра модели.

Иногда эта ошибка автоматически устраняется после исправления элементов, ребра которых были использованы при выполнении операции.


Уравнение создает циклическую зависимость

Это сообщение выдается в том случае, если в модели обнаружена циклическая зависимость.

Уравнение, которое предположительно является причиной циклической зависимости приводится в описании ошибки в диалоге Что не верно?.

В Окне переменных переменные, вызвавшие конфликт, выделяются красным цветом.

Чтобы исправить эту ошибку, отредактируйте выделенное уравнение так, чтобы разорвать цикл, т.е. удалить его.


Уравнение не решено из-за циклической зависимости

Это сообщение выдается в том случае, если в модели обнаружена циклическая зависимость. Чтобы разорвать цикл, система исключает из него одно уравнение и не решает его. Это уравнение приводится в описании ошибки в диалоге Что не верно?.

В Окне переменных переменные, вызвавшие конфликт, выделяются красным цветом.

Чтобы исправить эту ошибку, отредактируйте любое из уравнений цикла так, чтобы разорвать, т.е. удалить его.


Уравнение не решено

Это сообщение выдается в случае, если какое-либо уравнение в системе уравнений модели невозможно решить по неизвестной причине.


Операция потеряла все опорные объекты

Это предупреждение появляется после того, как в результате редактирования модели были удалены или некорректно перестроены объекты, использовавшиеся при выполнении операции.

Как исправить эту ошибку

– Войдите в режим редактирования ошибочного элемента и укажите в качестве опорных вершин, граней или ребер существующие вершины, грани или ребра модели.

– Или измените тип определения глубины выдавливания вместо опции До вершины включите опцию На расстояние или Через все.

Иногда эта ошибка автоматически устраняется после исправления формообразующих элементов, вершины, грани и ребра которых были использованы при выполнении операции выдавливания.


Операция потеряла опорный объект в прямом направлении

Это предупреждение появляется после того, как в результате редактирования модели был удален или некорректно перестроен объект, положение которого определяло глубину выдавливания формообразующего элемента в прямом направлении.

Как исправить эту ошибку

Войдите в режим редактирования ошибочного элемента выдавливания и укажите в качестве опорного объекта существующую вершину или поверхность. Или измените тип определения глубины выдавливания — вместо варианта До вершины или До поверхности выберите вариант На расстояние или Через все.

Иногда эта ошибка автоматически устраняется после исправления формообразующего элемента, грань или вершина которого была использована при выполнении операции выдавливания.


Операция потеряла опорный объект в обратном направлении

Это предупреждение появляется после того, как в результате редактирования модели был удален или некорректно перестроен объект, положение которого определяло глубину выдавливания формообразующего элемента в обратном направлении.

Как исправить эту ошибку

Войдите в режим редактирования ошибочного элемента выдавливания и укажите в качестве опорного объекта существующую вершину или поверхность. Или измените тип определения глубины выдавливания — вместо опции До вершины или До поверхности включите опцию На расстояние или Через все.

Иногда эта ошибка автоматически устраняется после исправления формообразующего элемента, грань или вершина которого была использована при выполнении операции выдавливания.


Одна или несколько граней не могут быть удалены

Это сообщение появляется после того, как в результате редактирования модели оказывается, что в числе граней, удаляемых для построения оболочки, находятся одна или несколько граней, соединяющихся с другими гранями по касательной. В этом случае создание оболочки невозможно.

Как исправить эту ошибку

– Войдите в режим редактирования ошибочной оболочки и отредактируйте набор удаляемых граней, исключив из него те, которые соединяются с другими по касательной.

– Или отредактируйте модель так, чтобы удаляемые грани не имели общих касательных с соседними гранями в точках разделяющих их ребер.


Потеряна связь с переменной в модели-источнике

Это предупреждение появляется, если при перестроении модели (или при открытии графического документа) со ссылкой на переменную выясняется, что источник ссылки не содержит данную переменную. Источником ссылки может быть другой документ или — для исполнения модели — другое исполнение этой же модели.

Переменная, получающая значение по ссылке, источник которой не найден, выделяется красным цветом в Окне переменных.

Переменная в источнике может исчезнуть, например, в результате переименования или изменения способа построения трехмерного элемента.

Как исправить эту ошибку

– Восстановите в источнике исчезнувшую переменную, а затем вновь перестройте модель или откройте графический документ.

– Или удалите имеющуюся ссылку и создайте новую — на существующую переменную.

Если источником ссылки является другой документ, то для его открытия можно воспользоваться командой Открыть файл-источник из контекстного меню ошибочной переменной в Окне переменных.


Ломаная содержит сегменты нулевой длины

Это сообщение означает, что ломаная содержит две или более следующих друг за другом вершин, координаты которых совпадают.

Как исправить эту ошибку

Войдите в режим редактирования ошибочной ломаной. Совпадающие вершины можно найти в окне модели — их номера отображаются наложенными друг на друга, или в таблице параметров вершин — строки, соответствующие этим вершинам, содержат одинаковые значения координат. При выделении строки в таблице номер соответствующей вершины подсвечивается в окне модели, и наоборот, при выделении в окне модели вершины ломаной соответствующая вершине строка выделяется в таблице.

Чтобы устранить ошибку, вы можете:

– изменить положение совпадающих вершин, т.е. сделать длины сегментов отличными от нуля; для этого отредактируйте значения в соответствующих строках таблицы параметров или «перетащите» вершины ломаной мышью в окне модели;

– удалить «лишние» вершины, т.е. удалить сегменты нулевой длины; для этого удалите из таблицы параметров вершин строки-дубликаты.


Неверная добавочная высота

Это сообщение появляется, если высота спирали вырождается.

Например, оно возникает в случае, когда при определении высоты спирали по объекту расстояние, заданное до объекта, превышает расстояние до этого объекта от первой опорной плоскости спирали.

Как исправить эту ошибку

– Войдите в режим редактирования ошибочной спирали и измените расстояние до объекта.

– Измените положение объекта, определяющего высоту спирали.

– Измените положение первой опорной плоскости спирали.


Неверные параметры размещения

Это сообщение появляется в модели, содержащей компоновочную геометрию, в следующих случаях:

– после удаления в модели локальной системы координат, выбранной для совмещения с системой координат компоновочной геометрии,

– после удаления в файле — источнике компоновочной геометрии локальной системы координат, выбранной для совмещения с системой координат модели.

Как исправить эту ошибку

Войдите в режим изменения положения компоновочной геометрии и выберите другие системы координат для совмещения.


Неверный опорный объект

Это предупреждение появляется после того, как в процессе редактирования модели объект, использовавшийся при построении элемента, был изменен так, что использование его в качестве опорного объекта для элемента стало невозможным.

Как исправить эту ошибку

Войдите в режим редактирования элемента и укажите в качестве опорного другой объект.


Неверный угол наклона образующей

Это предупреждение появляется после того как в процессе редактирования модели было введено недопустимое (слишком большое) значение угла наклона образующей конической спирали.

Как исправить эту ошибку

Войдите в режим редактирования спирали и уменьшите угол наклона образующей.


Ошибка построения компонента

Это сообщение означает, что в модели компонента есть ошибка.

Если компонентом является локальная деталь, то чтобы увидеть, какой именно объект содержит ошибку, следует включить отображение состава локальной детали. Затем, найдя среди объектов ошибочный, можно вызвать из его контекстного меню команду Что неверно? и получить описание ошибки.


Сообщение об ошибке в библиотечном компоненте

Это предупреждение появляется в случае, если в компоненте, вставленном в сборку из библиотеки, нарушены какие-либо связи и ограничения. Это может произойти по нескольким причинам.

1. Введение таких значений внешних переменных, при которых система уравнений и неравенств, связывающих переменные модели, не может быть решена.

2. Присвоение одной или нескольким внешним переменным модели значений, выходящих за пределы допустимого диапазона.

3. Ошибка в модели библиотеки (т.е. модель, вставленная из библиотеки, содержала ошибку еще на этапе создания этой библиотеки).

Если модель содержит внешние переменные (т.е. если ошибка может быть вызвана первой или второй причинами), вызовите диалог задания значений переменных модели и восстановите их значения.

Если после изменения значений переменных ошибка не исчезла (или если в модели нет внешних переменных), эта ошибка вызвана третьей причиной, и для ее исправления необходимо редактирование модели в библиотеке. Чтобы отредактировать модель в библиотеке, подключите эту библиотеку, выделите ошибочную модель и вызовите из контекстного меню команду Редактировать. В КОМПАС-3D откроется окно этой модели. Ее ошибочный объект отмечен в Дереве построения восклицательным знаком в красном кружке. Отредактируйте и сохраните модель, закройте ее окно и вставьте модель в сборку снова.

Как исправить эту ошибку

– Если это возможно, выберите стандартный компонент с другими параметрами.

– Или постройте компонент с нужными параметрами самостоятельно.

Об ошибках в стандартных компонентах сообщайте в Службу технической поддержки.


Экземпляр массива не может быть связан с фиксированнымили полностью определенным компонентом

Экземпляр массива не может быть связан с фиксированным
или полностью определенным компонентом

Это сообщение появляется в следующих случаях:

– после фиксации или полного определения сопряжениями компонента, который связан сопряжением с компонентом-экземпляром массива,

– после создания сопряжения между компонентом-экземпляром массива и фиксированным или полностью определенным компонентом.

Ошибка возникает из-за того, что положение экземпляра массива полностью определяется параметрами массива и не может быть изменено произвольным образом.

Как исправить эту ошибку

– Если компонент, сопряженный с экземпляром массива, зафиксирован, расфиксируйте его.

– Если компонент, сопряженный с экземпляром массива, полностью определен другими наложенными на него сопряжениями, удалите одно из них.

– Или удалите ошибочное сопряжение (сопряжение, в котором участвует экземпляр массива).


Задано сопряжение между экземплярами массива

Это сообщение появляется, если в модели присутствует сопряжение между двумя компонентами, являющимися экземплярами массива (одного и того же или различных).

Положение экземпляров массивов полностью определяется параметрами этих массивов, поэтому для исправления ошибки необходимо удалить вызывающее ее сопряжение.


Контур состоит из двух совпадающих отрезков

Это сообщение появляется в том случае, если эскиз элемента содержит два совпадающих отрезка.

Построение трехмерного элемента на основе такого эскиза означало бы формирование тела нулевой толщины. Существование в модели такого тела — потенциальный источник других ошибок.

Как исправить эту ошибку

Войдите в режим редактирования ошибочного эскиза и удалите из него отрезки, совпадающие с другими.


Потерян один или несколько опорных объектов

Это предупреждение появляется после того как в процессе редактирования модели был удален или некорректно перестроен объект, использовавшийся при построении другого объекта.

Как исправить эту ошибку

– Если это возможно, отредактируйте модель так, чтобы исходные объекты вновь появились в ней или корректно перестроились. В этом случае ошибка в производном от них объекте исправится автоматически.

– Или войдите в режим редактирования ошибочного объекта и укажите в качестве опорного существующий в модели объект.
Если нужного объекта нет, то постройте его, предварительно с помощью Указателя окончания построения условно удалив из модели ошибочный объект (это необходимо для того, чтобы новый объект оказался в Дереве построения выше ошибочного и впоследствии мог стать для него исходным). Затем восстановите ошибочный объект и отредактируйте его.

При работе с некоторыми объектами список их исходных объектов отображается на Панели свойств; потерянные объекты выделяются в этом списке красным цветом. В этом случае для исправления ошибки достаточно удалить потерянный объект из списка. Затем можно указать другой опорный объект.


Операция потеряла опорные объекты

Это предупреждение появляется после того, как в результате редактирования модели были удалены или некорректно перестроены объекты, использовавшиеся при выполнении операции.

Как исправить эту ошибку

Войдите в режим редактирования ошибочной операции и укажите в качестве опорных объектов существующие части модели.

Иногда эта ошибка автоматически устраняется после исправления объектов, которые были использованы при выполнении операции.


Совпадающие оси вращения не поддерживаются для сопряжения Вращение – вращение

Это сообщение появляется после того, как в результате редактирования модели прямолинейные объекты, указанные в качестве осей в сопряжении Вращение – вращение, оказались расположенными на одной прямой. Работа сопряжения в этом случае невозможна, и оно будет отмечено как ошибочное.

Как исправить эту ошибку

– Отредактируйте оси так, чтобы они не лежали на одной прямой.

– Или войдите в режим редактирования ошибочного сопряжения и смените одну ось или обе оси.


Сопряжение дублирует имеющееся

Это предупреждение появляется, если система обнаруживает наличие в модели двух или более абсолютно одинаковых сопряжений, т.е. сопряжений одного и того же типа, наложенных на одни и те же объекты.

Как исправить эту ошибку

Удалите сопряжения, дублирующие имеющиеся.


Позиционирующие сопряжения препятствуют движению толкателя вдоль траектории

Эта ошибка появляется в случае, когда на толкатель наложены такие позиционирующие сопряжения, которые делают невозможным его перемещение вдоль траектории, заданной в сопряжении Кулачок-Толкатель.

Как исправить эту ошибку

– проверьте позиционирующие сопряжения, в которых участвует толкатель и удалите те из них, которые противоречат перемещению толкателя вдоль траектории,

– или отредактируйте сопряжение Кулачок-Толкатель, указав траекторию, вдоль которой толкатель может перемещаться без нарушения наложенных на него сопряжений.


В модели имеются другие сопряжения, перемещающие толкатель при повороте кулачка

Эта ошибка появляется в случае, когда кулачок и толкатель, кроме сопряжения Кулачок-Толкатель, связаны другими сопряжениями так, что поворот кулачка вокруг оси, заданной в сопряжении Кулачок-Толкатель, приводит к перемещению толкателя.

Как исправить эту ошибку

Исключите из расчета ошибочное сопряжение Кулачок-Толкатель, а затем, вращая кулачок вокруг оси, заданной в этом сопряжении, найдите сопряжения, которые приводят к перемещению толкателя, и удалите их.


Задана циклическая зависимость для двух или более сопряжений кулачок-толкатель

Это сообщение появляется в случаях, когда несколько сопряжений Кулачок-толкатель взаимозависимы. Так, если перемещение толкателя первого сопряжения приводит к вращению кулачка второго, а вращение кулачка второго — к перемещению толкателя первого, то одно из сопряжений отмечается как ошибочное.

Эта зависимость может быть опосредованной, т.е. образовавшейся из-за других сопряжений.

Как исправить эту ошибку

Удалите ошибочное сопряжение или какое-либо другое сопряжение, участвующее в «цепочке».


Несовместные объекты для заданного сопряжения

Несовместные объекты
для заданного сопряжения

Это предупреждение появляется в следующих случаях.

– В результате редактирования модели форма сопряженных компонентов была изменена так, что выполнение наложенного на них сопряжения стало невозможным.

Как исправить эту ошибку

Отредактируйте какой-либо из сопряженных объектов так, чтобы он приобрел возможную для сопряжения форму.

– При наложении сопряжения Симметрия были выбраны криволинейные (цилиндрические, конические, сферические, тороидальные) грани, параметры теоретических поверхностей которых не совпадают, или ребра в форме дуг/окружностей, имеющие разные радиусы.

Например, в модели имеются две конические грани, диаметры оснований которых различны. Созданное для этих граней сопряжение Симметрия отмечается в Дереве построения как ошибочное.

Как исправить эту ошибку

Измените отличающиеся параметры одного из сопрягаемых объектов таким образом, чтобы их значения совпали со значениями параметров второго сопрягаемого объекта.


Заданная ориентация переопределяет группу сопряжений

Заданная ориентация
переопределяет группу сопряжений

Это предупреждение появляется после того, как в результате редактирования одного из сопряжений, имеющихся в модели, ориентация какого-либо компонента была изменена так, что выполнение группы других сопряжений стало невозможным.

Как исправить эту ошибку

Отредактируйте ошибочные сопряжения, изменив ориентацию участвующих в них компонентов.


Плоский тип угла применим только для вращательного соединения

Плоский тип угла применим
только для вращательного соединения

Это сообщение зарезервировано для дальнейшего развития системы.


Выбранная ось должна быть перпендикулярна плоскости планарного угла

Это сообщение появляется, если ось, определяющая направление измерения угла сопряжения в плоскости, находится под произвольным, отличным от девяноста градусов, углом к плоскости измерения угла сопряжения. Появление данного сообщения возможно в следующих случаях.

– В процессе построения сопряжения под углом (для плоского угла) после выбора оси.

– После построения сопряжения данного вида, если положение оси относительно плоскости измерения угла сопряжения изменилось. Это возможно, например, при редактировании одного из сопрягаемых компонентов.

Как исправить эту ошибку

– Если ошибка появилась в процессе построения сопряжения, выберите ось, перпендикулярную плоскости измерения угла сопряжения.

– Если ошибка появилась после построения сопряжения, удалите данное сопряжение и создайте новое, выбрав ось, перпендикулярную плоскости измерения угла сопряжения.


Сопряжение не решено

Это предупреждение появляется после того, как в результате редактирования модели она была изменена так, что выполнение сопряжения стало невозможным.

Как исправить эту ошибку

– Удалите ошибочное сопряжение.

– Добавьте другие сопряжения, если они предусмотрены.

– Переместите связанные ошибочным сопряжением компоненты, приблизив их желаемому положению (достижение которого предполагается в результате выполнения сопряжения).


Сопряжение переопределяет модель

Это предупреждение появляется после добавления в модель сопряжения, реализация которого невозможна при условии сохранения всех имеющихся сопряжений и их параметров.

Как исправить эту ошибку

Удалите ошибочное сопряжение или сопряжения, мешающие его реализации.


Сопряжение между фиксированными компонентами

Это предупреждение появляется в следующих случаях:

– после фиксации компонента, положение которого уже полностью определено наложенными сопряжениями,

– после фиксации обоих компонентов, участвующих в сопряжении, или после создания сопряжения между фиксированными объектами,

– после восстановления связи компонента зеркального исполнения с соответствующим компонентом исходного исполнения, если на компонент зеркального исполнения наложены сопряжения.

Как исправить эту ошибку

– Снимите фиксацию с одного из сопряженных компонентов.

– Или удалите сопряжения, связывающие эти компоненты.


Сопряжение невозможно решить

Это предупреждение появляется для сопряжения, выполнение которого невозможно.

Как исправить эту ошибку

Удалите ошибочное сопряжение.


Должно быть два объекта

Это предупреждение появляется, если в результате редактирования модели становится невозможным построение какого-либо объекта, участвующего в операции, для выполнения которой необходимо как минимум два объекта.

Например, в детали были выполнена булева операция над двумя пересекающимися телами. Затем при редактировании второго тела оно было объединено с первым. В результате булева операция потеряла тела, над которыми она была произведена.

Как исправить эту ошибку

– Отредактируйте ошибочную операцию: укажите другие объекты для ее выполнения.

– Или отредактируйте модель, восстановив нужные объекты, а затем — саму операцию, указав для ее выполнения вновь созданные объекты.


Нарушена целостность тела

Это сообщение появляется после того, как в результате редактирования модели нарушается целостность тела.

Как исправить эту ошибку

– С помощью команды Сшивка поверхностей присоедините к телу поверхности так, чтобы его целостность была восстановлена.

– Если грани тел были удалены в результате операции удаления грани или усечения поверхности, войдите в режим редактирования этой операции и исключите грани из числа удаляемых или усекаемых.


Не создано ни одной точки

Это предупреждение появляется после того, как при создании или редактирования группы точек по поверхности параметры группы заданы или изменены так, что не может быть построена ни одна точка группы.

Например, оно возникает в случае, когда группа точек строится по усеченной поверхности с учетом границ этой поверхности (т.е. построение внутри контура поверхности), а параметры группы заданы такие, что точки группы располагаются вне контура поверхности и поэтому не создаются.

Как исправить эту ошибку

– Задайте такие параметры группы, чтобы построение точек группы было возможно.

– Или отредактируйте поверхность, которой должны принадлежать точки, так, чтобы построение точек группы было возможно.


Система не имеет решения

Это предупреждение появляется при попытке произвести такое редактирование графических объектов в эскизе, которое противоречит наложенным на них связям и ограничениям.

Общие рекомендации

Для того чтобы произвести требуемое редактирование объектов в эскизе, снимите с них часть параметрических связей и ограничений или измените эти связи и ограничения (например, отредактируйте аналитические зависимости между параметрами).


Потеряна опорная вершина

Это предупреждение появляется после того, как в результате редактирования модели была удалена вершина, использовавшаяся при выполнении операции.

Как исправить эту ошибку

Войдите в режим редактирования ошибочного элемента и укажите в качестве опорной существующую в модели вершину.


Отсутствует исполнение с дополнительным номером

Это сообщение означает, что в файле компонента отсутствует дополнительный номер, выбранный при вставке компонента в модель.

Как исправить эту ошибку

– Измените дополнительный номер исполнения. Для этого выделите ошибочный компонент в Дереве построения, вызовите команду Редактор — Редактировать элемент, перейдите на вкладку Файл-источник Панели свойств, в списке Дополнительный номер выберите другой дополнительный номер или пустую строку. Выбор пустой строки списка означает, что исполнение не будет иметь дополнительного номера.

– Или замените компонент, содержащий ошибку, компонентом из другого файла. Для этого выделите компонент в Дереве модели, вызовите из контекстного меню команду Свойства компонента, перейдите на вкладку Файл-источник Панели свойств, нажмите кнопку Файл-источники укажите нужный файл в появившемся диалоге. Завершите изменение свойств компонента, нажав кнопку Создать объект на Панели специального управления.
Кроме того, можно просто удалить ошибочный компонент из модели и вставить другой.


Для данной пары поверхностей касание по окружности геометрически не возможно

Это сообщение появляется после того, как в результате редактирования модели сопряжение поверхностей по окружности стало невозможным. Например, если основной диаметр одного из сопряженных по окружности торов уменьшить так, что у них не будет общей окружности, то сопряжение будет отмечено как ошибочное.

Как исправить эту ошибку

Отредактируйте сопрягаемые объекты так, чтобы их сопряжение было возможно.


Не найдены одна или несколько исходных операций

Это предупреждение появляется в результате последовательного выполнения действий:

1. перемещения исходного элемента массива в Дереве построения так, что этот элемент оказался ниже массива,

2. перемещения Указателя окончания построения так, что он оказался между массивом и его исходным элементом.

Признак ошибки — восклицательный знак в красном кружке — исчезнет, если передвинуть Указатель окончания построения так, чтобы массив и его исходный элемент размещались над Указателем. Однако те исходные элементы, которые расположены в Дереве ниже массива, не учитываются при его построении, т.е. копии этих элементов отсутствуют в составе экземпляров массива.

Чтобы в массив входили копии всех исходных элементов, все они должны располагаться в Дереве выше массива. Если необходимо удалить какой-либо элемент из числа исходных, следует сначала разместить все исходные элементы выше массива, а затем отредактировать массив.


Ошибка при создании копии объекта

Это сообщение появляется, если при редактировании параметров экземпляров массива введены некорректные данные. Например, при редактировании массива по сетке, где в качестве копируемого объекта взят отрезок, в таблицу изменяемых переменных внесены одинаковые координаты для двух вершин одного из экземпляров массива. Т.к при этом получается отрезок нулевой длины, создать экземпляр невозможно.

Как исправить эту ошибку

Войдите в режим редактирования массива и проверьте правильность введенных данных.


Операция потеряла базовую плоскость

Это предупреждение появляется после того, как в результате редактирования модели была удалена или некорректно перестроена плоскость, использовавшаяся при выполнении операции.

Как исправить эту ошибку

– Войдите в режим редактирования элемента, операция построения которого стала ошибочной. Укажите в качестве базовой плоскости существующую плоскость или плоскую грань модели.

– Или выделите эскиз, расположенный на «потерянной» плоскости, и вызовите из контекстного меню команду Разместить эскиз. Разместите эскиз на существующей плоскости или плоской грани модели.


Потеряна связь

Это предупреждение появляется после того, как в результате редактирования модели был некорректно перестроен объект, использовавшийся при выполнении операции.

Например, на плоские грани двух деталей было наложено сопряжение Совпадение. После редактирования одной из деталей ее грань, участвующая в сопряжении, стала выпуклой или вогнутой. Такие грани не могут быть сопряжены указанным способом; возникает предупреждение об ошибке.

Или, например, эскиз элемента содержал проекцию ребра детали. В процессе редактирования детали это ребро было скруглено. Так как ребра «не стало», не может быть построена и его проекция, необходимая для правильного формирования эскиза элемента. В этом случае также появляется предупреждение об ошибке.

Как исправить эту ошибку

– Отредактируйте ошибочный объект так, чтобы выполнение операции было возможно.

– Или удалите операцию.


Невозможно определить направление смещения с помощью направляющего объекта

Это сообщение появляется в случае, если в результате редактирования модели направление смещения эквидистантной кривой, задаваемое направляющим объектом, вырождается — вектор смещения эквидистантной кривой в плоскости смещения вырождается в точку. Например, для построения эквидистантной кривой использовались: в качестве базовой кривой — прямолинейное ребро, а в качестве направляющего объекта — вспомогательная ось, проходящая через вершину этого ребра. После редактирования модели вспомогательная ось стала совпадать с ребром. Построение вектора смещения эквидистантной кривой стало невозможным, поэтому эквидистантная кривая отмечается как ошибочная.

Как исправить эту ошибку

– Отредактируйте базовую кривую или направляющий объект так, чтобы построение вектора смещения стало возможным.

– Или укажите другую базовую кривую или другой направляющий объект, при котором построение вектора смещения возможно.


Невозможно построить эквидистанту с данными параметрами

Это сообщение появляется в случае, если в результате редактирования модели параметры эквидистантной кривой или ее базовой кривой изменились так, что эквидистантная кривая не может быть построена. Например, в качестве базовой кривой для построения эквидистантной используется дуга окружности. После редактирования дуги значение ее радиуса стало равно значению расстояния смещения эквидистантной кривой. В этом случае эквидистанта кривой вырождается в точку и отмечается как ошибочная.

Как исправить эту ошибку

– Войдите в режим редактирования эквидистантной кривой и измените ее параметр так, чтобы ее построение стало возможным.

– Или отредактируйте базовую кривую так, чтобы построение эквидистантной кривой стало возможным.

– Или укажите другую базовую кривую для построения эквидистантной кривой.


Попытка переопределить выходные параметры; Система переопределена

Попытка переопределить выходные параметры;
Система переопределена

Эта ошибка возникает, если одна и та же переменная получает значение из нескольких разных источников или несколькими разными способами. Например, в модели имелся элемент выдавливания, выдавленный на расстояние. Для переменной, которая соответствует глубине выдавливания этого элемента, было задано выражение. Затем элемент выдавливания отредактировали, заменив способ определения глубины На расстояние способом До вершины. Переменная, соответствующая расстоянию выдавливания, стала информационной. Значение такой переменной нельзя изменять произвольно, так как оно зависит от других объектов. Однако выражение для вычисления переменной осталось — оно и является причиной конфликта.

Выражение, вызвавшее конфликт, выделяется красным цветом в Окне переменных.

Чтобы исправить ошибку, удалите это выражение.

Для исправления ошибки в вышеприведенном примере можно отредактировать элемент выдавливания, вернув ему способ определения глубины На расстояние.


Значение параметра находится вне допустимого диапазона

Это сообщение появляется после того как переменная, соответствующая параметру объекта, получает значение, выходящее за пределы, установленные для этого параметра.

Допустимый диапазон значений переменных

Как исправить эту ошибку

Отредактируйте значение или выражение для вычисления значения переменной, которая соответствует параметру.


Операция копирования потеряла сведения о своем происхождении

Это предупреждение появляется после удаления элементов, которые были скопированы (исходных экземпляров копии).

Как исправить эту ошибку

– Войдите в режим редактирования операции копирования и укажите другие исходные объекты.

– Или удалите элемент-копию.


Плоскость обозначения не пересекается с опорным объектом

Это сообщение появляется в случае, если в результате редактирования модели плоскость обозначения перестала пересекаться с объектом, к которому проставлено обозначение.

Например, линия-выноска проставлена к грани элемента выдавливания, и использовала в качестве базовой плоскость XY. Затем контур сечения этого элемента был отредактирован — повернут так, что грань, к которой проставлена линия-выноска, стала параллельна плоскости XY. Так как плоскость обозначения — XY — перестала пересекаться с опорным объектом этого обозначения — гранью, — линия-выноска отмечается как ошибочная.

Как исправить эту ошибку

– Отредактируйте модель так, чтобы опорный объект пересекался с плоскостью обозначения.

– Или войдите в режим редактирования обозначения и укажите в качестве базовой плоскость, пересекающую опорный объект.


Опорная вершина плоскости лежит на ребре

Это предупреждение появляется после того, как в результате редактирования модели вершина, использовавшаяся для построения плоскости через ребро и вершину, стала принадлежать ребру, использовавшемуся при построении этой же плоскости.

Как исправить эту ошибку

Войдите в режим редактирования плоскости и укажите в качестве опорных объектов существующие в модели ребро и не принадлежащую ему (или его продолжению) вершину.

Иногда эта ошибка автоматически устраняется после исправления ошибочного формообразующего элемента, на вершине и ребре которого основывалось построение плоскости, или после изменения положения компонентов, на вершине и ребре которых основывалось построение плоскости.


Эскиз не удовлетворяет требованиям операции

Это сообщение появляется после того, как в результате редактирования модели эскиз перестал удовлетворять требованиям использующей его операции.

Как исправить эту ошибку

Найдите в Справочной системе описание требований к эскизу ошибочной операции, а затем отредактируйте эскиз.


Потеряны некоторые выбранные грани

Это предупреждение появляется, если из модели исчезла часть граней, указанных для выполнения операции.

Например, операция разбиения поверхности разделяла грани, принадлежащие двум разным частям тела. После отключения показа второй части тела операция разбиения отмечается как ошибочная из-за потери грани этой части (разбиение грани первой части тела сохраняется).

Как исправить эту ошибку

– Отредактируйте модель так, чтобы грани, участвующие в операции, вновь появились.

– Или отредактируйте ошибочную операцию, указав для нее другие грани.

Если удалена грань, используемая для разбиения, (например, эскиз операции изменен так, что тело стало состоять из одной части) то исправление ошибки невозможно. Вы можете удалить операцию разбиения и создать ее заново или оставить ошибку, так как сохранившиеся грани разбиваются корректно.


Разбиение создано не на всех выбранных гранях

Это сообщение появляется после того, как в результате редактирования модели среди граней, составляющих поверхность разбиения, появились такие, с которыми секущий объект пересекается не полностью.

Как исправить эту ошибку

Отредактируйте секущий объект или поверхность так, чтобы они удовлетворяли требованиям операции.


Невозможно разбить поверхность. Один из объектов имеет самопересечение

Это сообщение появляется, если в качестве секущего объекта в операции разбиения поверхности указана самопересекающаяся кривая или эскиз.

Как исправить эту ошибку

– Отредактируйте секущий объект так, чтобы он не пересекался сам с собой.

– Или укажите в качестве секущего другой объект, не имеющий самопересечений.


Опорный объект не является плоским

Это предупреждение появляется, если в результате редактирования модели плоская грань, использовавшаяся при выполнении операции, стала криволинейной.


Поверхности, образованные проекциями, не пересекаются

Это сообщение появляется, если построение кривой по двум проекциям стало невозможным из-за того, что поверхности, образованные перемещением двух проекций кривой (см. рисунок), перестали пересекаться. Кривая отмечается как ошибочная.

Как исправить эту ошибку

– Измените положение плоскости любого из эскизов, содержащих проекции кривой, так, чтобы поверхности, образованные перемещением проекций, пересекались.

– Войдите в режим редактирования любого из эскизов, содержащих проекции кривой, и измените изображение в нем так, чтобы поверхности, образованные перемещением проекций, пересекались.

– Войдите в режим редактирования ошибочной кривой и укажите другой эскиз или отдельные его линии в качестве первой (второй) проекции.

– Перенесите любой из эскизов на другую плоскость.


Операция без истории потеряла сведения о своем происхождении

Это предупреждение появляется, если система не может обнаружить на диске файл-источник детали-заготовки, использованной в текущей модели.

Как исправить эту ошибку

Любым способом разместите в файле с указанным именем модель детали-заготовки.


Формы элементов не соответствуют выбранному варианту касания

Это сообщение появляется после того, как в результате редактирования модели выбранный вариант касания поверхностей стал невозможен. Например, два цилиндра были сопряжены в точке. Затем один из цилиндров был превращен в конус. Сопряжение конуса и цилиндра в точке недоступно, поэтому сопряжение будет отмечено как ошибочное.

Как исправить эту ошибку

Отредактируйте сопрягаемые объекты так, чтобы выбранный вариант касания был возможен.


Зона нулевого объема

Это сообщение появляется, если в результате редактировании модели противоположные вершины габаритного параллелепипеда зоны (Точка1 и Точка 2) оказываются на прямой, параллельной плоскости системы координат этой зоны. В этом случае объем габаритного параллелепипеда зоны равен нулю, поскольку параллелепипед строится так, чтобы его грани были параллельны плоскостям системы координат зоны.

Как исправить эту ошибку

Войдите в режим редактирования зоны и измените координаты вершины габаритного параллелепипеда зоны.


Главное окно КОМПАС-3D

Главное окно КОМПАС-3D — это главное окно системы. В нем расположены пункты Главного меню, Инструментальные панели и другие элементы управления.

Все окна новых или открываемых документов являются подчиненными по отношению к главному окну.

Для управления главным окном можно использовать стандартные средства Windows — кнопку системного меню в левом верхнем углу экрана и кнопки управления размером окна в правом верхнем углу.


Окно предварительного просмотра для печати

В режиме предварительного просмотра команды меню и изображение в главном окне системы изменяются.

На экране показывается условное поле вывода (одна или несколько страниц печати). На этом поле реалистично отображаются те листы документов, которые выбраны для печати. Вы можете перемещать, поворачивать, масштабировать листы для достижения наилучшего их размещения на поле вывода.

Подробнее о режиме предварительного просмотра и печати документов — см. следующие разделы:

Режим предварительного просмотра

Настройка параметров вывода

Автоподгонка масштаба листов документов

Размещение листов документов на поле вывода

Поиск перекрывающихся листов

Подгонка масштаба листов документа

Печать части изображения

Отмена печати указанных страниц

Масштаб просмотра

Установка фильтров вывода

Выбор нужного принтера (плоттера) и его настройка

Задание на печать


Окно Стартовой страницы

Окно, содержащее Стартовую страницу КОМПАС-3D.

Управление окном Стартовой страницы не отличается от управления окнами документов: вы можете открывать и закрыть его, сворачивать и восстанавливать. Оно так же подчиняется командам меню Окно, как и остальные окна.

Если в диалоге настройки сохранения конфигурации включено сохранение состояния открытых документов, то в файл *.dsk записывается также информация о состоянии окна Стартовой страницы.

Состав Главного меню при работе со Стартовой страницей аналогичен составу меню при отсутствии открытых документов.

Смотрите также

Как получить справку во время работы


Порядок исправления ошибки

1. Внимательно прочитайте сообщение системы. Запомните название оформления, вызвавшего конфликт, название стиля, содержащего это оформление, и полное имя библиотеки, содержащей этот стиль.

2. Если новая спецификация должна иметь другой стиль или стиль из другой библиотеки, укажите нужный стиль в настройке новых спецификаций. Для этого

2.1. вызовите из меню Сервис команду Параметры, раскройте вкладку Новые документы;

2.2. в левой части появившегося диалога раскройте раздел Спецификация и выберите в нем пункт Стиль;

2.3. подключите нужную библиотеку и выберите из нее нужный стиль спецификации (если необходимая библиотека уже подключена, можно ограничиться выбором из нее другого стиля);

2.4. закройте диалог настройки, нажав кнопку OK, и попытайтесь вновь создать спецификацию.

3. Если стиль новой спецификации выбран верно, требуется проверить правильность задания оформления (как известно, оформление спецификации является частью ее стиля). Для этого

3.1. вызовите из меню Сервис команду Стили спецификаций...;

3.2. убедитесь, что в одном из окон просмотра появившегося диалога отображается состав нужной библиотеки стилей (полное имя библиотеки указано в верхней части диалога над окном просмотра ее состава). Если в диалоге показана другая библиотека, подключите ту библиотеку, стиль из которой будет применяться в новой спецификации;

3.3. выберите из списка название стиля, который будет применяться в новой спецификации, и нажмите кнопку Редактировать...;

3.4. активизируйте вкладку Оформление появившегося диалога настройки стиля спецификации;

Если вы получили сообщение об ошибке оформления первого листа спецификации, дальнейшие действия (проверку и настройку) нужно производить с оформлением первого листа, если ошибка в оформлении второго и последующих листов, проверять и настраивать нужно оформление последующих листов.

3.5. проверьте, правильно ли указано полное имя библиотеки, в которой содержится оформление новой спецификации, при необходимости подключите нужную библиотеку оформлений;

3.6. проверьте, правильно ли указано оформление из подключенной библиотеки, при необходимости выберите другое оформление;

3.7. нажав кнопку OK, закройте диалог настройки стиля спецификации, выйдите из диалога работы со стилями спецификаций и попытайтесь вновь создать спецификацию.

4. Если оформление первого листа (или последующих листов) новой спецификации указано верно, требуется проверить правильность задания входящей в состав этого оформления основной надписи. Для этого

4.1. вызовите из меню Сервис команду Оформление чертежей...;

4.2. убедитесь, что в одном из окон просмотра появившегося диалога отображается состав нужной библиотеки оформлений (полное имя библиотеки указано в верхней части диалога над окном просмотра ее состава). Если в диалоге показана другая библиотека, подключите ту библиотеку, оформление из которой будет применяться в новой спецификации;

4.3. выберите из списка название оформления, которое будет применяться в новой спецификации, и нажмите кнопку Редактировать...;

4.4. в появившемся диалоге настройки оформления проверьте, правильно ли указано полное имя библиотеки, в которой содержится основная надпись (бланк) новой спецификации, при необходимости подключите нужную библиотеку основных надписей;

4.5. проверьте, правильно ли указано название основной надписи (бланка) из подключенной библиотеки, при необходимости выберите другую основную надпись. При выборе названия основной надписи учитывайте, оформление какого листа (первого или последующего) вы настраиваете. Обычно в названии бланка есть указание на первый или последующие листы, это поможет вам выбрать нужную основную надпись;

4.6. нажав кнопку OK, закройте диалог настройки оформления листа спецификации, выйдите из диалога работы со стилями оформлений и попытайтесь вновь создать спецификацию.

5. Если основная надпись первого листа (или последующих листов) новой спецификации указана верно, требуется проверить правильность этой основной надписи. Для этого

5.1. вызовите из меню Сервис команду Типы основных надписей...;

5.2. убедитесь, что в одном из окон просмотра появившегося диалога отображается состав нужной библиотеки основных надписей (полное имя библиотеки указано в верхней части диалога над окном просмотра ее состава). Если в диалоге показана другая библиотека, подключите ту библиотеку, основная надпись из которой будет применяться в оформлении новой спецификации;

5.3. выберите из списка название основной надписи, которая будет применяться в оформлении новой спецификации, и нажмите кнопку Редактировать...;

5.4. в появившемся диалоге найдите список, озаглавленный Состав основной надписи, выберите в нем название таблицы, которая предназначена для внесения в нее объектов спецификации (при выделении этого названия включается опция Использовать для спецификации), и нажмите кнопку Редактировать.... На экране появится окно редактирования таблицы бланка;

5.5. хотя бы одна ячейка таблицы для спецификации (за исключением ячеек «шапки») должна иметь расширенный тип Для спецификации. Активизируйте любую ячейку таблицы (щелкните в ней мышью);

5.6. вызовите из меню Таблица команду Формат ячейки...;

5.7. в появившемся диалоге настройки формата ячейки нажмите кнопку Далее...;

5.8. в появившемся диалоге настройки расширенного формата ячейки включите опцию Для таблицы спецификации;

5.9. нажимая кнопки OK, последовательно закройте диалоги настройки расширенного формата ячейки и настройки формата ячейки;

5.10. вызовите из меню Файл команду Закрыть и подтвердите сохранение измененной основной надписи;

5.11. нажав кнопку OK, закройте диалог настройки основной надписи, выйдите из диалога работы с основными надписями и приступайте к созданию спецификации.

Если вы зададите расширенный тип Для спецификации единственной ячейке в таблице спецификации, этого будет достаточно для создания спецификации. Однако объекты спецификации смогут располагаться только в той ячейке, которая имеет тип Для спецификации. Понятно, что создание спецификации, состоящей из одной ячейки, не имеет смысла. Поэтому тип Для спецификации должны иметь все ячейки таблицы спецификации (кроме ячеек «шапки»). Для присвоения этого типа всем ячейкам нужно выполнить пункты с 5.5 по 5.9 включительно для каждой ячейки таблицы спецификации или при настройке расширенного формата каждой первой ячейки в колонке (столбце) включить опцию Сформировать идентификаторы для всех нижележащих ячеек столбца.


Порядок исправления ошибки

1. Внимательно прочитайте сообщение системы. Запомните название оформления, вызвавшего конфликт, название стиля, содержащего это оформление, и полное имя библиотеки, содержащей этот стиль.

2. Вначале требуется проверить правильность задания оформления спецификации (как известно, оформление спецификации является частью ее стиля). Для этого

2.1. вызовите из меню Сервис команду Стили спецификаций...;

2.2. убедитесь, что в одном из окон просмотра появившегося диалога отображается состав нужной библиотеки стилей (полное имя библиотеки указано в верхней части диалога над окном просмотра ее состава). Если в диалоге показана другая библиотека, подключите ту библиотеку, стиль из которой должен применяться в открываемой спецификации;

2.3. выберите из списка название стиля, который должен применяться в открываемой спецификации, и нажмите кнопку Редактировать...;

2.4. активизируйте вкладку Оформление появившегося диалога настройки стиля спецификации;

Если вы получили сообщение об ошибке оформления первого листа спецификации, дальнейшие действия (проверку и настройку) нужно производить с оформлением первого листа, если ошибка в оформлении второго и последующих листов, проверять и настраивать нужно оформление последующих листов.

2.5. проверьте, правильно ли указано полное имя библиотеки, в которой содержится оформление открываемой спецификации, при необходимости подключите нужную библиотеку оформлений;

2.6. проверьте, правильно ли указано оформление из подключенной библиотеки, при необходимости выберите другое оформление;

2.7. нажав кнопку OK, закройте диалог настройки стиля спецификации, выйдите из диалога работы со стилями спецификаций и попытайтесь вновь открыть спецификацию.

3. Если оформление первого листа (или последующих листов) открываемой спецификации указано верно, требуется проверить правильность задания входящей в состав этого оформления основной надписи. Для этого

3.1. вызовите из меню Сервис команду Оформление чертежей...;

3.2. убедитесь, что в одном из окон просмотра появившегося диалога отображается состав нужной библиотеки оформлений (полное имя библиотеки указано в верхней части диалога над окном просмотра ее состава). Если в диалоге показана другая библиотека, подключите ту библиотеку, оформление из которой должно применяться в открываемой спецификации;

3.3. выберите из списка название оформления, которое должно применяться в открываемой спецификации, и нажмите кнопку Редактировать...;

3.4. в появившемся диалоге настройки оформления проверьте, правильно ли указано полное имя библиотеки, в которой содержится основная надпись (бланк) открываемой спецификации, при необходимости подключите нужную библиотеку основных надписей;

3.5. проверьте, правильно ли указано название основной надписи (бланка) из подключенной библиотеки, при необходимости выберите другую основную надпись. При выборе названия основной надписи учитывайте, оформление какого листа (первого или последующего) вы настраиваете. Обычно в названии бланка есть указание на первый или последующие листы, это поможет вам выбрать нужную основную надпись;

3.6. нажав кнопку OK, закройте диалог настройки оформления листа спецификации, выйдите из диалога работы со стилями оформлений и попытайтесь вновь открыть спецификацию.

4. Если основная надпись первого листа (или последующих листов) открываемой спецификации указана верно, требуется проверить правильность этой основной надписи. Для этого

4.1. вызовите из меню Сервис команду Типы основных надписей...;

4.2. убедитесь, что в одном из окон просмотра появившегося диалога отображается состав нужной библиотеки основных надписей (полное имя библиотеки указано в верхней части диалога над окном просмотра ее состава). Если в диалоге показана другая библиотека, подключите ту библиотеку, основная надпись из которой должна применяться в оформлении открываемой спецификации;

4.3. выберите из списка название основной надписи, которая будет применяться в оформлении открываемой спецификации, и нажмите кнопку Редактировать...;

4.4. в появившемся диалоге найдите список, озаглавленный Состав основной надписи, выберите в нем название таблицы, которая предназначена для внесения в нее объектов спецификации (при выделении этого названия включается опция Использовать для спецификации), и нажмите кнопку Редактировать.... На экране появится окно редактирования таблицы бланка;

4.5. хотя бы одна ячейка таблицы для спецификации (за исключением ячеек «шапки») должна иметь расширенный тип Для спецификации. Активизируйте любую ячейку таблицы (щелкните в ней мышью);

4.6. вызовите из меню Таблица команду Формат ячейки...;

4.7. в появившемся диалоге настройки формата ячейки нажмите кнопку Далее...;

4.8. в появившемся диалоге настройки расширенного формата ячейки включите опцию Для таблицы спецификации;

4.9. нажимая кнопки OK, последовательно закройте диалоги настройки расширенного формата ячейки и настройки формата ячейки;

4.10. вызовите из меню Файл команду Закрыть и подтвердите сохранение измененной основной надписи;

4.11. нажав кнопку OK, закройте диалог настройки основной надписи, выйдите из диалога работы с основными надписями и открывайте спецификацию.

Если вы зададите расширенный тип Для спецификации единственной ячейке в таблице спецификации, этого будет достаточно для открытия спецификации. Однако объекты спецификации смогут располагаться только в той ячейке, которая имеет тип Для спецификации. Понятно, что работа со спецификацией, состоящей из одной ячейки, не имеет смысла. Поэтому тип Для спецификации должны иметь все ячейки таблицы спецификации (кроме ячеек «шапки»). Для присвоения этого типа всем ячейкам нужно выполнить пункты с 4.5 по 4.9 включительно для каждой ячейки таблицы спецификации или при настройке расширенного формата каждой первой ячейки в колонке (столбце) включить опцию Сформировать идентификаторы для всех нижележащих ячеек столбца.

При смене стиля, оформления или бланка существующей спецификации никаких изменений данных в ней (например, исчезновения информации из колонок) не происходит. Например, вы сменили стиль с группового на простой; в результате в спецификации будут не видны колонки с количеством объектов для разных исполнений, однако из спецификации данные о количестве не исчезнут, и когда в ней вновь появятся колонки, предназначенные для представления количества (например, вы измените бланк спецификации), данные о количестве займут в них свое место (станут видны). Поэтому вы можете смело менять и перенастраивать стиль, оформление или бланк с целью открыть спецификацию с поврежденным бланком. После того как спецификация будет открыта (в любом виде), вы сможете нужным образом настроить те параметры стиля или оформления, которые вас не устраивают.


Порядок исправления ошибки

1. Внимательно прочитайте сообщение системы. Запомните название оформления, вызвавшего конфликт, название стиля, содержащего это оформление, и полное имя библиотеки, содержащей этот стиль.

2. Проверьте, правильно ли указан стиль, на который вы хотите поменять стиль текущей спецификации (в том числе правильно ли выбрана библиотека стилей).

3. Если новый стиль спецификации выбран верно, требуется проверить правильность задания оформления (как известно, оформление спецификации является частью ее стиля). Для этого

3.1. вызовите из меню Сервис команду Стили спецификаций...;

3.2. убедитесь, что в одном из окон просмотра появившегося диалога отображается состав нужной библиотеки стилей (полное имя библиотеки указано в верхней части диалога над окном просмотра ее состава). Если в диалоге показана другая библиотека, подключите ту библиотеку, стиль из которой должен применяться в спецификации;

3.3. выберите из списка название стиля, который должен применяться в спецификации, и нажмите кнопку Редактировать...;

3.4. активизируйте вкладку Оформление появившегося диалога настройки стиля спецификации;

Если вы получили сообщение об ошибке оформления первого листа спецификации, дальнейшие действия (проверку и настройку) нужно производить с оформлением первого листа, если ошибка в оформлении второго и последующих листов, проверять и настраивать нужно оформление последующих листов.

3.5. проверьте, правильно ли указано полное имя библиотеки, в которой содержится оформление спецификации, при необходимости подключите нужную библиотеку оформлений;

3.6. проверьте, правильно ли указано оформление из подключенной библиотеки, при необходимости выберите другое оформление;

3.7. нажав кнопку OK, закройте диалог настройки стиля спецификации, выйдите из диалога работы со стилями спецификаций и попытайтесь вновь сменить стиль спецификации.

4. Если оформление первого листа (или последующих листов) спецификации указано верно, требуется проверить правильность задания входящей в состав этого оформления основной надписи. Для этого

4.1. вызовите из меню Сервис команду Оформление чертежей...;

4.2. убедитесь, что в одном из окон просмотра появившегося диалога отображается состав нужной библиотеки оформлений (полное имя библиотеки указано в верхней части диалога над окном просмотра ее состава). Если в диалоге показана другая библиотека, подключите ту библиотеку, оформление из которой должно применяться в спецификации;

4.3. выберите из списка название оформления, которое должно применяться в спецификации, и нажмите кнопку Редактировать...;

4.4. в появившемся диалоге настройки оформления проверьте, правильно ли указано полное имя библиотеки, в которой содержится основная надпись (бланк) спецификации, при необходимости подключите нужную библиотеку основных надписей;

4.5. проверьте, правильно ли указано название основной надписи (бланка) из подключенной библиотеки, при необходимости выберите другую основную надпись. При выборе названия основной надписи учитывайте, оформление какого листа (первого или последующего) вы настраиваете. Обычно в названии бланка есть указание на первый или последующие листы, это поможет вам выбрать нужную основную надпись;

4.6. нажав кнопку OK, закройте диалог настройки оформления листа спецификации, выйдите из диалога работы со стилями оформлений и попытайтесь вновь сменить стиль спецификации.

5. Если основная надпись первого листа (или последующих листов) спецификации указана верно, требуется проверить правильность этой основной надписи. Для этого

5.1. вызовите из меню Сервис команду Типы основных надписей...;

5.2. убедитесь, что в одном из окон просмотра появившегося диалога отображается состав нужной библиотеки основных надписей (полное имя библиотеки указано в верхней части диалога над окном просмотра ее состава). Если в диалоге показана другая библиотека, подключите ту библиотеку, основная надпись из которой должна применяться в оформлении спецификации;

5.3. выберите из списка название основной надписи, которая будет применяться в оформлении спецификации, и нажмите кнопку Редактировать...;

5.4. в появившемся диалоге найдите список, озаглавленный Состав основной надписи, выберите в нем название таблицы, которая предназначена для внесения в нее объектов спецификации (при выделении этого названия включается опция Использовать для спецификации), и нажмите кнопку Редактировать.... На экране появится окно редактирования таблицы бланка;

5.5. хотя бы одна ячейка таблицы для спецификации (за исключением ячеек «шапки») должна иметь расширенный тип Для спецификации. Активизируйте любую ячейку таблицы (щелкните в ней мышью);

5.6. вызовите из меню Таблица команду Формат ячейки...;

5.7. в появившемся диалоге настройки формата ячейки нажмите кнопку Далее...;

5.8. в появившемся диалоге настройки расширенного формата ячейки включите опцию Для таблицы спецификации;

5.9. нажимая кнопки OK, последовательно закройте диалоги настройки расширенного формата ячейки и настройки формата ячейки;

5.10. вызовите из меню Файл команду Закрыть и подтвердите сохранение измененной основной надписи;

5.11. нажав кнопку OK, закройте диалог настройки основной надписи, выйдите из диалога работы с основными надписями и измените стиль спецификации.

Если вы зададите расширенный тип Для спецификации единственной ячейке в таблице спецификации, этого будет достаточно для открытия спецификации. Однако объекты спецификации смогут располагаться только в той ячейке, которая имеет тип Для спецификации. Понятно, что работа со спецификацией, состоящей из одной ячейки, не имеет смысла. Поэтому тип Для спецификации должны иметь все ячейки таблицы спецификации (кроме ячеек «шапки»). Для присвоения этого типа всем ячейкам нужно выполнить пункты с 5.5 по 5.9 включительно для каждой ячейки таблицы спецификации или при настройке расширенного формата каждой первой ячейки в колонке (столбце) включить опцию Сформировать идентификаторы для всех нижележащих ячеек столбца.

При смене стиля, оформления или бланка существующей спецификации никаких изменений данных в ней (например, исчезновения информации из колонок) не происходит. Например, вы сменили стиль с группового на простой; в результате в спецификации будут не видны колонки с количеством объектов для разных исполнений, однако из спецификации данные о количестве не исчезнут, и когда в ней вновь появятся колонки, предназначенные для представления количества (например, вы измените бланк спецификации), данные о количестве займут в них свое место (станут видны). Поэтому вы можете смело менять и перенастраивать стиль, оформление или бланк.


Порядок исправления ошибки

1. Внимательно прочитайте сообщение системы. Запомните название оформления, вызвавшего конфликт, название стиля, содержащего это оформление, и полное имя библиотеки, содержащей этот стиль.

Появление сообщения свидетельствует о наличии ошибки в стиле спецификации, который используется для размещения объектов спецификации, принадлежащих текущему графическому документу или модели. Объекты спецификации могут быть вставлены в документ как непосредственно (с помощью команды Спецификация — Добавить объект), так и вместе с другими объектами: фрагментами, деталями, подсборками, библиотечными макроэлементами.

2. Вначале требуется проверить правильность задания оформления спецификации (как известно, оформление спецификации является частью ее стиля). Для этого

2.1. вызовите из меню Сервис команду Стили спецификаций...;

2.2. убедитесь, что в одном из окон просмотра появившегося диалога отображается состав нужной библиотеки стилей (полное имя библиотеки указано в верхней части диалога над окном просмотра ее состава). Если в диалоге показана другая библиотека, подключите ту библиотеку, стиль из которой должен использоваться в текущем документе;

2.3. выберите из списка название стиля, который должен использоваться в документе, и нажмите кнопку Редактировать...;

2.4. активизируйте вкладку Оформление появившегося диалога настройки стиля спецификации;

Если вы получили сообщение об ошибке оформления первого листа спецификации, дальнейшие действия (проверку и настройку) нужно производить с оформлением первого листа, если ошибка в оформлении второго и последующих листов, проверять и настраивать нужно оформление последующих листов.

2.5. проверьте, правильно ли указано полное имя библиотеки, в которой содержится оформление спецификации, при необходимости подключите нужную библиотеку оформлений;

2.6. проверьте, правильно ли указано оформление из подключенной библиотеки, при необходимости выберите другое оформление;

2.7. нажав кнопку OK, закройте диалог настройки стиля спецификации, выйдите из диалога работы со стилями спецификаций и попытайтесь продолжить работу с объектами спецификации в текущем документе.

3. Если оформление первого листа (или последующих листов) спецификации указано верно, требуется проверить правильность задания входящей в состав этого оформления основной надписи. Для этого

3.1. вызовите из меню Сервис команду Оформление чертежей...;

3.2. убедитесь, что в одном из окон просмотра появившегося диалога отображается состав нужной библиотеки оформлений (полное имя библиотеки указано в верхней части диалога над окном просмотра ее состава). Если в диалоге показана другая библиотека, подключите ту библиотеку, оформление из которой должно применяться в спецификации;

3.3. выберите из списка название оформления, которое должно применяться в спецификации, и нажмите кнопку Редактировать...;

3.4. в появившемся диалоге настройки оформления проверьте, правильно ли указано полное имя библиотеки, в которой содержится основная надпись (бланк) спецификации, при необходимости подключите нужную библиотеку основных надписей;

3.5. проверьте, правильно ли указано название основной надписи (бланка) из подключенной библиотеки, при необходимости выберите другую основную надпись. При выборе названия основной надписи учитывайте, оформление какого листа (первого или последующего) вы настраиваете. Обычно в названии бланка есть указание на первый или последующие листы, это поможет вам выбрать нужную основную надпись;

3.6. нажав кнопку OK, закройте диалог настройки оформления листа спецификации, выйдите из диалога работы со стилями оформлений и попытайтесь продолжить работу с объектами спецификации в текущем документе.

4. Если основная надпись первого листа (или последующих листов) спецификации указана верно, требуется проверить правильность этой основной надписи. Для этого

4.1. вызовите из меню Сервис команду Типы основных надписей...;

4.2. убедитесь, что в одном из окон просмотра появившегося диалога отображается состав нужной библиотеки основных надписей (полное имя библиотеки указано в верхней части диалога над окном просмотра ее состава). Если в диалоге показана другая библиотека, подключите ту библиотеку, основная надпись из которой должна применяться в оформлении спецификации;

4.3. выберите из списка название основной надписи, которая будет применяться в оформлении спецификации, и нажмите кнопку Редактировать...;

4.4. в появившемся диалоге найдите список, озаглавленный Состав основной надписи, выберите в нем название таблицы, которая предназначена для внесения в нее объектов спецификации (при выделении этого названия включается опция Использовать для спецификации), и нажмите кнопку Редактировать.... На экране появится окно редактирования таблицы бланка;

4.5. хотя бы одна ячейка таблицы для спецификации (за исключением ячеек «шапки») должна иметь расширенный тип Для спецификации. Активизируйте любую ячейку таблицы (щелкните в ней мышью);

4.6. вызовите из меню Таблица команду Формат ячейки...;

4.7. в появившемся диалоге настройки формата ячейки нажмите кнопку Далее...;

4.8. в появившемся диалоге настройки расширенного формата ячейки включите опцию Для таблицы спецификации;

4.9. нажимая кнопки OK, последовательно закройте диалоги настройки расширенного формата ячейки и настройки формата ячейки;

4.10. вызовите из меню Файл команду Закрыть и подтвердите сохранение измененной основной надписи;

4.11. нажав кнопку OK, закройте диалог настройки основной надписи, выйдите из диалога работы с основными надписями и продолжите работу с объектами спецификации в текущем документе.

Если вы зададите расширенный тип Для спецификации единственной ячейке в таблице спецификации, этого будет достаточно для работы с объектами спецификации. Однако эти объекты смогут располагаться только в той ячейке, которая имеет тип Для спецификации. Понятно, что работа со спецификацией, состоящей из одной ячейки, не имеет смысла. Поэтому тип Для спецификации должны иметь все ячейки таблицы спецификации (кроме ячеек «шапки»). Для присвоения этого типа всем ячейкам нужно выполнить пункты с 4.5 по 4.9 включительно для каждой ячейки таблицы спецификации или при настройке расширенного формата каждой первой ячейки в колонке (столбце) включить опцию Сформировать идентификаторы для всех нижележащих ячеек столбца.


Порядок исправления ошибки

1. Внимательно прочитайте сообщение системы. Запомните название оформления, вызвавшего конфликт, название стиля, содержащего это оформление, и полное имя библиотеки, содержащей этот стиль.

Появление сообщения свидетельствует о наличии ошибки в стиле спецификации, который используется для размещения объектов спецификации, принадлежащих макроэлементам, вставляемым из библиотеки.

2. Вначале требуется проверить правильность задания оформления спецификации (как известно, оформление спецификации является частью ее стиля). Для этого

2.1. вызовите из меню Сервис команду Стили спецификаций...;

2.2. убедитесь, что в одном из окон просмотра появившегося диалога отображается состав нужной библиотеки стилей (полное имя библиотеки указано в верхней части диалога над окном просмотра ее состава). Если в диалоге показана другая библиотека, подключите ту библиотеку, стиль из которой должен использоваться для размещения объектов спецификации;

2.3. выберите из списка название стиля, который должен использоваться для размещения объектов, и нажмите кнопку Редактировать...;

2.4. активизируйте вкладку Оформление появившегося диалога настройки стиля спецификации;

Если вы получили сообщение об ошибке оформления первого листа спецификации, дальнейшие действия (проверку и настройку) нужно производить с оформлением первого листа, если ошибка в оформлении второго и последующих листов, проверять и настраивать нужно оформление последующих листов.

2.5. проверьте, правильно ли указано полное имя библиотеки, в которой содержится оформление спецификации, при необходимости подключите нужную библиотеку оформлений;

2.6. проверьте, правильно ли указано оформление из подключенной библиотеки, при необходимости выберите другое оформление;

2.7. нажав кнопку OK, закройте диалог настройки стиля спецификации, выйдите из диалога работы со стилями спецификаций и попытайтесь вновь вставить библиотечный макроэлемент с объектом спецификации.

3. Если оформление первого листа (или последующих листов) спецификации указано верно, требуется проверить правильность задания входящей в состав этого оформления основной надписи. Для этого

3.1. вызовите из меню Сервис команду Оформление чертежей...;

3.2. убедитесь, что в одном из окон просмотра появившегося диалога отображается состав нужной библиотеки оформлений (полное имя библиотеки указано в верхней части диалога над окном просмотра ее состава). Если в диалоге показана другая библиотека, подключите ту библиотеку, оформление из которой должно применяться в спецификации;

3.3. выберите из списка название оформления, которое должно применяться в спецификации, и нажмите кнопку Редактировать...;

3.4. в появившемся диалоге настройки оформления проверьте, правильно ли указано полное имя библиотеки, в которой содержится основная надпись (бланк) спецификации, при необходимости подключите нужную библиотеку основных надписей;

3.5. проверьте, правильно ли указано название основной надписи (бланка) из подключенной библиотеки, при необходимости выберите другую основную надпись. При выборе названия основной надписи учитывайте, оформление какого листа (первого или последующего) вы настраиваете. Обычно в названии бланка есть указание на первый или последующие листы, это поможет вам выбрать нужную основную надпись;

3.6. нажав кнопку OK, закройте диалог настройки оформления листа спецификации, выйдите из диалога работы со стилями оформлений и попытайтесь вновь вставить библиотечный макроэлемент с объектом спецификации.

4. Если основная надпись первого листа (или последующих листов) спецификации указана верно, требуется проверить правильность этой основной надписи. Для этого

4.1. вызовите из меню Сервис команду Типы основных надписей...;

4.2. убедитесь, что в одном из окон просмотра появившегося диалога отображается состав нужной библиотеки основных надписей (полное имя библиотеки указано в верхней части диалога над окном просмотра ее состава). Если в диалоге показана другая библиотека, подключите ту библиотеку, основная надпись из которой должна применяться в оформлении спецификации;

4.3. выберите из списка название основной надписи, которая будет применяться в оформлении спецификации, и нажмите кнопку Редактировать...;

4.4. в появившемся диалоге найдите список, озаглавленный Состав основной надписи, выберите в нем название таблицы, которая предназначена для внесения в нее объектов спецификации (при выделении этого названия включается опция Использовать для спецификации), и нажмите кнопку Редактировать.... На экране появится окно редактирования таблицы бланка;

4.5. хотя бы одна ячейка таблицы для спецификации (за исключением ячеек «шапки») должна иметь расширенный тип Для спецификации. Активизируйте любую ячейку таблицы (щелкните в ней мышью);

4.6. вызовите из меню Таблица команду Формат ячейки...;

4.7. в появившемся диалоге настройки формата ячейки нажмите кнопку Далее...;

4.8. в появившемся диалоге настройки расширенного формата ячейки включите опцию Для таблицы спецификации;

4.9. нажимая кнопки OK, последовательно закройте диалоги настройки расширенного формата ячейки и настройки формата ячейки;

4.10. вызовите из меню Файл команду Закрыть и подтвердите сохранение измененной основной надписи;

4.11. нажав кнопку OK, закройте диалог настройки основной надписи, выйдите из диалога работы с основными надписями и открывайте спецификацию.

Если вы зададите расширенный тип Для спецификации единственной ячейке в таблице спецификации, этого будет достаточно для вставки в документ объектов спецификации. Однако эти объекты смогут располагаться только в той ячейке, которая имеет тип Для спецификации. Понятно, что работа со спецификацией, состоящей из одной ячейки, не имеет смысла. Поэтому тип Для спецификации должны иметь все ячейки таблицы спецификации (кроме ячеек «шапки»). Для присвоения этого типа всем ячейкам нужно выполнить пункты с 4.5 по 4.9 включительно для каждой ячейки таблицы спецификации или при настройке расширенного формата каждой первой ячейки в колонке (столбце) включить опцию Сформировать идентификаторы для всех нижележащих ячеек столбца.


Порядок исправления ошибки

1. Внимательно прочитайте сообщение системы. Запомните название оформления, вызвавшего конфликт, название стиля, содержащего это оформление, и полное имя библиотеки, содержащей этот стиль.

2. Если новая спецификация должна иметь другой стиль или стиль из другой библиотеки, укажите нужный стиль в настройке новых спецификаций. Для этого

2.1. вызовите из меню Сервис команду Параметры, раскройте вкладку Новые документы;

2.2. в левой части появившегося диалога раскройте раздел Спецификация и выберите в нем пункт Стиль;

2.3. подключите нужную библиотеку и выберите из нее нужный стиль спецификации (если необходимая библиотека уже подключена, можно ограничиться выбором из нее другого стиля);

2.4. закройте диалог настройки, нажав кнопку OK, и попытайтесь вновь создать спецификацию.

3. Если стиль новой спецификации выбран верно, требуется проверить правильность задания оформления (как известно, оформление спецификации является частью ее стиля). Для этого

3.1. вызовите из меню Сервис команду Стили спецификаций...;

3.2. убедитесь, что в одном из окон просмотра появившегося диалога отображается состав нужной библиотеки стилей (полное имя библиотеки указано в верхней части диалога над окном просмотра ее состава). Если в диалоге показана другая библиотека, подключите ту библиотеку, стиль из которой будет применяться в новой спецификации;

3.3. выберите из списка название стиля, который будет применяться в новой спецификации, и нажмите кнопку Редактировать...;

3.4. активизируйте вкладку Оформление появившегося диалога настройки стиля спецификации;

Если вы получили сообщение о ненайденном оформлении первого листа спецификации, дальнейшие действия (проверку и настройку) нужно производить с оформлением первого листа, если не найдено оформление второго и последующих листов, проверять и настраивать нужно оформление последующих листов.

3.5. проверьте, правильно ли указано полное имя библиотеки, в которой содержится оформление новой спецификации, при необходимости подключите нужную библиотеку оформлений;

3.6. проверьте, правильно ли указано оформление из подключенной библиотеки, при необходимости выберите другое оформление;

3.7. нажав кнопку OK, закройте диалог настройки стиля спецификации, выйдите из диалога работы со стилями спецификаций и создайте новую спецификацию.


Порядок исправления ошибки

1. Внимательно прочитайте сообщение системы. Запомните название оформления, вызвавшего конфликт, название стиля, содержащего это оформление, и полное имя библиотеки, содержащей этот стиль.

2. Проверьте правильность задания оформления спецификации (как известно, оформление спецификации является частью ее стиля). Для этого

2.1. вызовите из меню Сервис команду Стили спецификаций...;

2.2. убедитесь, что в одном из окон просмотра появившегося диалога отображается состав нужной библиотеки стилей (полное имя библиотеки указано в верхней части диалога над окном просмотра ее состава). Если в диалоге показана другая библиотека, подключите ту библиотеку, стиль из которой должен применяться в открываемой спецификации;

2.3. выберите из списка название стиля, который должен применяться в открываемой спецификации, и нажмите кнопку Редактировать...;

2.4. активизируйте вкладку Оформление появившегося диалога настройки стиля спецификации;

Если вы получили сообщение о ненайденном оформлении первого листа спецификации, дальнейшие действия (проверку и настройку) нужно производить с оформлением первого листа, если не найдено оформление второго и последующих листов, проверять и настраивать нужно оформление последующих листов.

2.5. проверьте, правильно ли указано полное имя библиотеки, в которой содержится оформление открываемой спецификации, при необходимости подключите нужную библиотеку оформлений;

2.6. проверьте, правильно ли указано оформление из подключенной библиотеки, при необходимости выберите другое оформление;

2.7. нажав кнопку OK, закройте диалог настройки стиля спецификации, выйдите из диалога работы со стилями спецификаций и откройте спецификацию.

При смене оформления существующей спецификации никаких изменений данных в ней (например, исчезновения информации из колонок) не происходит. Например, вы сменили оформление с группового на простое; в результате в спецификации будут не видны колонки с количеством объектов для разных исполнений, однако из спецификации данные о количестве не исчезнут, и когда в ней вновь появятся колонки, предназначенные для представления количества (например, вы измените бланк спецификации, который является частью оформления), данные о количестве займут в них свое место (станут видны). Поэтому вы можете смело менять и перенастраивать оформление с целью открыть спецификацию. После того как спецификация будет открыта (в любом виде), вы сможете нужным образом настроить те параметры стиля или оформления, которые вас не устраивают.


Порядок исправления ошибки

1. Внимательно прочитайте сообщение системы. Запомните название оформления, вызвавшего конфликт, название стиля, содержащего это оформление, и полное имя библиотеки, содержащей этот стиль.

2. Проверьте, правильно ли указан стиль, на который вы хотите поменять стиль текущей спецификации (в том числе правильно ли выбрана библиотека стилей).

3. Если новый стиль спецификации выбран верно, требуется проверить правильность задания оформления (как известно, оформление спецификации является частью ее стиля). Для этого

3.1. вызовите из меню Сервис команду Стили спецификаций...;

3.2. убедитесь, что в одном из окон просмотра появившегося диалога отображается состав нужной библиотеки стилей (полное имя библиотеки указано в верхней части диалога над окном просмотра ее состава). Если в диалоге показана другая библиотека, подключите ту библиотеку, стиль из которой должен применяться в спецификации;

3.3. выберите из списка название стиля, который должен применяться в спецификации, и нажмите кнопку Редактировать...;

3.4. активизируйте вкладку Оформление появившегося диалога настройки стиля спецификации;

Если вы получили сообщение об ошибке оформления первого листа спецификации, дальнейшие действия (проверку и настройку) нужно производить с оформлением первого листа, если ошибка в оформлении второго и последующих листов, проверять и настраивать нужно оформление последующих листов.

3.5. проверьте, правильно ли указано полное имя библиотеки, в которой содержится оформление спецификации, при необходимости подключите нужную библиотеку оформлений;

3.6. проверьте, правильно ли указано оформление из подключенной библиотеки, при необходимости выберите другое оформление;

3.7. нажав кнопку OK, закройте диалог настройки стиля спецификации, выйдите из диалога работы со стилями спецификаций и попытайтесь вновь сменить стиль спецификации.

При смене стиля, оформления или бланка существующей спецификации никаких изменений данных в ней (например, исчезновения информации из колонок) не происходит. Например, вы сменили стиль с группового на простой; в результате в спецификации будут не видны колонки с количеством объектов для разных исполнений, однако из спецификации данные о количестве не исчезнут, и когда в ней вновь появятся колонки, предназначенные для представления количества (например, вы измените бланк спецификации), данные о количестве займут в них свое место (станут видны). Поэтому вы можете смело менять и перенастраивать стиль, оформление или бланк.


Порядок исправления ошибки

1. Внимательно прочитайте сообщение системы. Запомните название оформления, вызвавшего конфликт, название стиля, содержащего это оформление, и полное имя библиотеки, содержащей этот стиль.

Появление сообщения свидетельствует о наличии ошибки в стиле спецификации, который используется для размещения объектов спецификации, принадлежащих текущему графическому документу или модели. Объекты спецификации могут быть вставлены в документ как непосредственно (с помощью команды Спецификация — Добавить объект), так и вместе с другими объектами: фрагментами, деталями, подсборками, библиотечными макроэлементами.

2. Проверьте правильность задания оформления спецификации (как известно, оформление спецификации является частью ее стиля). Для этого

2.1. вызовите из меню Сервис команду Стили спецификаций...;

2.2. убедитесь, что в одном из окон просмотра появившегося диалога отображается состав нужной библиотеки стилей (полное имя библиотеки указано в верхней части диалога над окном просмотра ее состава). Если в диалоге показана другая библиотека, подключите ту библиотеку, стиль из которой должен использоваться в текущем документе;

2.3. выберите из списка название стиля спецификации, который должен использоваться в документе, и нажмите кнопку Редактировать...;

2.4. активизируйте вкладку Оформление появившегося диалога настройки стиля спецификации;

Если вы получили сообщение о ненайденном оформлении первого листа спецификации, дальнейшие действия (проверку и настройку) нужно производить с оформлением первого листа, если не найдено оформление второго и последующих листов, проверять и настраивать нужно оформление последующих листов.

2.5. проверьте, правильно ли указано полное имя библиотеки, в которой содержится оформление спецификации, при необходимости подключите нужную библиотеку оформлений;

2.6. проверьте, правильно ли указано оформление из подключенной библиотеки, при необходимости выберите другое оформление;

2.7. нажав кнопку OK, закройте диалог настройки стиля спецификации, выйдите из диалога работы со стилями спецификаций и продолжите работу с объектами спецификации в текущем документе.


Порядок исправления ошибки

1. Внимательно прочитайте сообщение системы. Запомните название оформления, вызвавшего конфликт, название стиля, содержащего это оформление, и полное имя библиотеки, содержащей этот стиль.

Появление сообщения свидетельствует о наличии ошибки в стиле спецификации, который используется для размещения объектов спецификации, принадлежащих макроэлементам, вставляемым из библиотеки.

2. Проверьте правильность задания оформления спецификации (как известно, оформление спецификации является частью ее стиля). Для этого

2.1. вызовите из меню Сервис команду Стили спецификаций...;

2.2. убедитесь, что в одном из окон просмотра появившегося диалога отображается состав нужной библиотеки стилей (полное имя библиотеки указано в верхней части диалога над окном просмотра ее состава). Если в диалоге показана другая библиотека, подключите ту библиотеку, стиль из которой должен использоваться для размещения объектов спецификации;

2.3. выберите из списка название стиля спецификации, который должен использоваться для размещения объектов, и нажмите кнопку Редактировать...;

2.4. активизируйте вкладку Оформление появившегося диалога настройки стиля спецификации;

Если вы получили сообщение о ненайденном оформлении первого листа спецификации, дальнейшие действия (проверку и настройку) нужно производить с оформлением первого листа, если не найдено оформление второго и последующих листов, проверять и настраивать нужно оформление последующих листов.

2.5. проверьте, правильно ли указано полное имя библиотеки, в которой содержится оформление спецификации, при необходимости подключите нужную библиотеку оформлений;

2.6. проверьте, правильно ли указано оформление из подключенной библиотеки, при необходимости выберите другое оформление;

2.7. нажав кнопку OK, закройте диалог настройки стиля спецификации, выйдите из диалога работы со стилями спецификаций и продолжите вставку макроэлементов из библиотеки.


Порядок исправления ошибки

1. Внимательно прочитайте сообщение системы. Запомните название оформления, вызвавшего конфликт, название стиля, содержащего это оформление, и полное имя библиотеки, содержащей этот стиль.

2. Если новая спецификация должна иметь другой стиль или стиль из другой библиотеки, укажите нужный стиль в настройке новых спецификаций. Для этого

2.1. вызовите из меню Сервис команду Параметры раскройте вкладку Новые документы;

2.2. в левой части появившегося диалога раскройте раздел Спецификация и выберите в нем пункт Стиль;

2.3. подключите нужную библиотеку и выберите из нее нужный стиль спецификации (если необходимая библиотека уже подключена, можно ограничиться выбором из нее другого стиля);

2.4. закройте диалог настройки, нажав кнопку OK, и попытайтесь вновь создать спецификацию.

3. Если стиль новой спецификации выбран верно, требуется проверить правильность задания оформления (как известно, оформление спецификации является частью ее стиля). Для этого

3.1. вызовите из меню Сервис команду Стили спецификаций...;

3.2. убедитесь, что в одном из окон просмотра появившегося диалога отображается состав нужной библиотеки стилей (полное имя библиотеки указано в верхней части диалога над окном просмотра ее состава). Если в диалоге показана другая библиотека, подключите ту библиотеку, стиль из которой будет применяться в новой спецификации;

3.3. выберите из списка название стиля, который будет применяться в новой спецификации, и нажмите кнопку Редактировать...;

3.4. активизируйте вкладку Оформление появившегося диалога настройки стиля спецификации;

Если вы получили сообщение об ошибке оформления первого листа спецификации, дальнейшие действия (проверку и настройку) нужно производить с оформлением первого листа, если ошибка в оформлении второго и последующих листов, проверять и настраивать нужно оформление последующих листов.

3.5. проверьте, правильно ли указано полное имя библиотеки, в которой содержится оформление новой спецификации, при необходимости подключите нужную библиотеку оформлений;

3.6. проверьте, правильно ли указано оформление из подключенной библиотеки, при необходимости выберите другое оформление;

3.7. нажав кнопку OK, закройте диалог настройки стиля спецификации, выйдите из диалога работы со стилями спецификаций и попытайтесь вновь создать спецификацию.

4. Если оформление первого листа (или последующих листов) новой спецификации указано верно, требуется проверить правильность задания входящей в состав этого оформления основной надписи. Для этого

4.1. вызовите из меню Сервис команду Оформление чертежей...;

4.2. убедитесь, что в одном из окон просмотра появившегося диалога отображается состав нужной библиотеки оформлений (полное имя библиотеки указано в верхней части диалога над окном просмотра ее состава). Если в диалоге показана другая библиотека, подключите ту библиотеку, оформление из которой будет применяться в новой спецификации;

4.3. выберите из списка название оформления, которое будет применяться в новой спецификации, и нажмите кнопку Редактировать...;

4.4. в появившемся диалоге настройки оформления проверьте, правильно ли указано полное имя библиотеки, в которой содержится основная надпись (бланк) новой спецификации, при необходимости подключите нужную библиотеку основных надписей;

4.5. проверьте, правильно ли указано название основной надписи (бланка) из подключенной библиотеки, при необходимости выберите другую основную надпись. При выборе названия основной надписи учитывайте, оформление какого листа (первого или последующего) вы настраиваете. Обычно в названии бланка есть указание на первый или последующие листы, это поможет вам выбрать нужную основную надпись;

4.6. нажав кнопку OK, закройте диалог настройки оформления листа спецификации, выйдите из диалога работы со стилями оформлений и попытайтесь вновь создать спецификацию.

5. Если основная надпись первого листа (или последующих листов) новой спецификации указана верно, требуется проверить правильность этой основной надписи. Для этого

5.1. вызовите из меню Сервис команду Типы основных надписей...;

5.2. убедитесь, что в одном из окон просмотра появившегося диалога отображается состав нужной библиотеки основных надписей (полное имя библиотеки указано в верхней части диалога над окном просмотра ее состава). Если в диалоге показана другая библиотека, подключите ту библиотеку, основная надпись из которой будет применяться в оформлении новой спецификации;

5.3. выберите из списка название основной надписи, которая будет применяться в оформлении новой спецификации, и нажмите кнопку Редактировать...;

5.4. в появившемся диалоге найдите список, озаглавленный Состав основной надписи, выберите в нем название таблицы, которая предназначена для внесения в нее объектов спецификации, и включите опцию Использовать для спецификации (таблицы, предназначенные для спецификации и входящие в состав поставляемых вместе с системой основных надписей, называются Таблица спецификации);

5.5. нажав кнопку OK, закройте диалог настройки основной надписи, выйдите из диалога работы с основными надписями и приступайте к созданию спецификации.


Порядок исправления ошибки

1. Внимательно прочитайте сообщение системы. Запомните название оформления, вызвавшего конфликт, название стиля, содержащего это оформление, и полное имя библиотеки, содержащей этот стиль.

2. Вначале требуется проверить правильность задания оформления спецификации (как известно, оформление спецификации является частью ее стиля). Для этого

2.1. вызовите из меню Сервис команду Стили спецификаций...;

2.2. убедитесь, что в одном из окон просмотра появившегося диалога отображается состав нужной библиотеки стилей (полное имя библиотеки указано в верхней части диалога над окном просмотра ее состава). Если в диалоге показана другая библиотека, подключите ту библиотеку, стиль из которой должен применяться в открываемой спецификации;

2.3. выберите из списка название стиля, который должен применяться в открываемой спецификации, и нажмите кнопку Редактировать...;

2.4. активизируйте вкладку Оформление появившегося диалога настройки стиля спецификации;

Если вы получили сообщение об ошибке оформления первого листа спецификации, дальнейшие действия (проверку и настройку) нужно производить с оформлением первого листа, если ошибка в оформлении второго и последующих листов, проверять и настраивать нужно оформление последующих листов.

2.5. проверьте, правильно ли указано полное имя библиотеки, в которой содержится оформление открываемой спецификации, при необходимости подключите нужную библиотеку оформлений;

2.6. проверьте, правильно ли указано оформление из подключенной библиотеки, при необходимости выберите другое оформление;

2.7. нажав кнопку OK, закройте диалог настройки стиля спецификации, выйдите из диалога работы со стилями спецификаций и попытайтесь вновь открыть спецификацию.

3. Если оформление первого листа (или последующих листов) открываемой спецификации указано верно, требуется проверить правильность задания входящей в состав этого оформления основной надписи. Для этого

3.1. вызовите из меню Сервис команду Оформление чертежей...;

3.2. убедитесь, что в одном из окон просмотра появившегося диалога отображается состав нужной библиотеки оформлений (полное имя библиотеки указано в верхней части диалога над окном просмотра ее состава). Если в диалоге показана другая библиотека, подключите ту библиотеку, оформление из которой должно применяться в открываемой спецификации;

3.3. выберите из списка название оформления, которое должно применяться в открываемой спецификации, и нажмите кнопку Редактировать...;

3.4. в появившемся диалоге настройки оформления проверьте, правильно ли указано полное имя библиотеки, в которой содержится основная надпись (бланк) открываемой спецификации, при необходимости подключите нужную библиотеку основных надписей;

3.5. проверьте, правильно ли указано название основной надписи (бланка) из подключенной библиотеки, при необходимости выберите другую основную надпись. При выборе названия основной надписи учитывайте, оформление какого листа (первого или последующего) вы настраиваете. Обычно в названии бланка есть указание на первый или последующие листы, это поможет вам выбрать нужную основную надпись;

3.6. нажав кнопку OK, закройте диалог настройки оформления листа спецификации, выйдите из диалога работы со стилями оформлений и попытайтесь вновь открыть спецификацию.

4. Если основная надпись первого листа (или последующих листов) открываемой спецификации указана верно, требуется проверить правильность этой основной надписи. Для этого

4.1. вызовите из меню Сервис команду Типы основных надписей...;

4.2. убедитесь, что в одном из окон просмотра появившегося диалога отображается состав нужной библиотеки основных надписей (полное имя библиотеки указано в верхней части диалога над окном просмотра ее состава). Если в диалоге показана другая библиотека, подключите ту библиотеку, основная надпись из которой должна применяться в оформлении открываемой спецификации;

4.3. выберите из списка название основной надписи, которая должна применяться в оформлении открываемой спецификации, и нажмите кнопку Редактировать...;

4.4. в появившемся диалоге найдите список, озаглавленный Состав основной надписи, выберите в нем название таблицы, которая предназначена для внесения в нее объектов спецификации, и включите опцию Использовать для спецификации (таблицы, предназначенные для спецификации и входящие в состав поставляемых вместе с системой основных надписей, называются Таблица спецификации);

4.5. нажав кнопку OK, закройте диалог настройки основной надписи, выйдите из диалога работы с основными надписями и откройте спецификацию.

При смене стиля, оформления или бланка существующей спецификации никаких изменений данных в ней (например, исчезновения информации из колонок) не происходит. Например, вы сменили стиль с группового на простой; в результате в спецификации будут не видны колонки с количеством объектов для разных исполнений, однако из спецификации данные о количестве не исчезнут, и когда в ней вновь появятся колонки, предназначенные для представления количества (например, вы измените бланк спецификации), данные о количестве займут в них свое место (станут видны). Поэтому вы можете смело менять и перенастраивать стиль, оформление или бланк с целью открыть спецификацию с поврежденным бланком. После того как спецификация будет открыта (в любом виде), вы сможете нужным образом настроить те параметры стиля или оформления, которые вас не устраивают.


Порядок исправления ошибки

1. Внимательно прочитайте сообщение системы. Запомните название оформления, вызвавшего конфликт, название стиля, содержащего это оформление, и полное имя библиотеки, содержащей этот стиль.

2. Проверьте, правильно ли указан стиль, на который вы хотите поменять стиль текущей спецификации (в том числе правильно ли выбрана библиотека стилей).

3. Если новый стиль спецификации выбран верно, требуется проверить правильность задания оформления (как известно, оформление спецификации является частью ее стиля). Для этого

3.1. вызовите из меню Сервис команду Стили спецификаций...;

3.2. убедитесь, что в одном из окон просмотра появившегося диалога отображается состав нужной библиотеки стилей (полное имя библиотеки указано в верхней части диалога над окном просмотра ее состава). Если в диалоге показана другая библиотека, подключите ту библиотеку, стиль из которой должен применяться в спецификации;

3.3. выберите из списка название стиля, который должен применяться в спецификации, и нажмите кнопку Редактировать...;

3.4. активизируйте вкладку Оформление появившегося диалога настройки стиля спецификации;

Если вы получили сообщение об ошибке оформления первого листа спецификации, дальнейшие действия (проверку и настройку) нужно производить с оформлением первого листа, если ошибка в оформлении второго и последующих листов, проверять и настраивать нужно оформление последующих листов.

3.5. проверьте, правильно ли указано полное имя библиотеки, в которой содержится оформление спецификации, при необходимости подключите нужную библиотеку оформлений;

3.6. проверьте, правильно ли указано оформление из подключенной библиотеки, при необходимости выберите другое оформление;

3.7. нажав кнопку OK, закройте диалог настройки стиля спецификации, выйдите из диалога работы со стилями спецификаций и попытайтесь вновь сменить стиль спецификации.

4. Если оформление первого листа (или последующих листов) спецификации указано верно, требуется проверить правильность задания входящей в состав этого оформления основной надписи. Для этого

4.1. вызовите из меню Сервис команду Оформление чертежей...;

4.2. убедитесь, что в одном из окон просмотра появившегося диалога отображается состав нужной библиотеки оформлений (полное имя библиотеки указано в верхней части диалога над окном просмотра ее состава). Если в диалоге показана другая библиотека, подключите ту библиотеку, оформление из которой должно применяться в спецификации;

4.3. выберите из списка название оформления, которое должно применяться в спецификации, и нажмите кнопку Редактировать...;

4.4. в появившемся диалоге настройки оформления проверьте, правильно ли указано полное имя библиотеки, в которой содержится основная надпись (бланк) спецификации, при необходимости подключите нужную библиотеку основных надписей;

4.5. проверьте, правильно ли указано название основной надписи (бланка) из подключенной библиотеки, при необходимости выберите другую основную надпись. При выборе названия основной надписи учитывайте, оформление какого листа (первого или последующего) вы настраиваете. Обычно в названии бланка есть указание на первый или последующие листы, это поможет вам выбрать нужную основную надпись;

4.6. нажав кнопку OK, закройте диалог настройки оформления листа спецификации, выйдите из диалога работы со стилями оформлений и попытайтесь вновь сменить стиль спецификации.

5. Если основная надпись первого листа (или последующих листов) спецификации указана верно, требуется проверить правильность этой основной надписи. Для этого

5.1. вызовите из меню Сервис команду Типы основных надписей...;

5.2. убедитесь, что в одном из окон просмотра появившегося диалога отображается состав нужной библиотеки основных надписей (полное имя библиотеки указано в верхней части диалога над окном просмотра ее состава). Если в диалоге показана другая библиотека, подключите ту библиотеку, основная надпись из которой будет применяться в оформлении спецификации;

5.3. выберите из списка название основной надписи, которая будет применяться в оформлении спецификации, и нажмите кнопку Редактировать...;

5.4. в появившемся диалоге найдите список, озаглавленный Состав основной надписи, выберите в нем название таблицы, которая предназначена для внесения в нее объектов спецификации, и включите опцию Использовать для спецификации (таблицы, предназначенные для спецификации и входящие в состав поставляемых вместе с системой основных надписей, называются Таблица спецификации);

5.5. нажав кнопку OK, закройте диалог настройки основной надписи, выйдите из диалога работы с основными надписями и смените стиль спецификации.

При смене стиля, оформления или бланка существующей спецификации никаких изменений данных в ней (например, исчезновения информации из колонок) не происходит. Например, вы сменили стиль с группового на простой; в результате в спецификации будут не видны колонки с количеством объектов для разных исполнений, однако из спецификации данные о количестве не исчезнут, и когда в ней вновь появятся колонки, предназначенные для представления количества (например, вы измените бланк спецификации), данные о количестве займут в них свое место (станут видны). Поэтому вы можете смело менять и перенастраивать стиль, оформление или бланк.


Порядок исправления ошибки

1. Внимательно прочитайте сообщение системы. Запомните название оформления, вызвавшего конфликт, название стиля, содержащего это оформление, и полное имя библиотеки, содержащей этот стиль.

Появление сообщения свидетельствует о наличии ошибки в стиле спецификации, который используется для размещения объектов спецификации, принадлежащих текущему графическому документу или модели. Объекты спецификации могут быть вставлены в документ как непосредственно (с помощью команды Спецификация — Добавить объект), так и вместе с другими объектами: фрагментами, деталями, подсборками, библиотечными макроэлементами.

2. Вначале требуется проверить правильность задания оформления спецификации (как известно, оформление спецификации является частью ее стиля). Для этого

2.1. вызовите из меню Сервис команду Стили спецификаций...;

2.2. убедитесь, что в одном из окон просмотра появившегося диалога отображается состав нужной библиотеки стилей (полное имя библиотеки указано в верхней части диалога над окном просмотра ее состава). Если в диалоге показана другая библиотека, подключите ту библиотеку, стиль спецификации из которой должен использоваться в текущем документе;

2.3. выберите из списка название стиля спецификации, который должен использоваться в документе, и нажмите кнопку Редактировать...;

2.4. активизируйте вкладку Оформление появившегося диалога настройки стиля спецификации;

Если вы получили сообщение об ошибке оформления первого листа спецификации, дальнейшие действия (проверку и настройку) нужно производить с оформлением первого листа, если ошибка в оформлении второго и последующих листов, проверять и настраивать нужно оформление последующих листов.

2.5. проверьте, правильно ли указано полное имя библиотеки, в которой содержится оформление спецификации, при необходимости подключите нужную библиотеку оформлений;

2.6. проверьте, правильно ли указано оформление из подключенной библиотеки, при необходимости выберите другое оформление;

2.7. нажав кнопку OK, закройте диалог настройки стиля спецификации, выйдите из диалога работы со стилями спецификаций и попытайтесь вновь открыть спецификацию.

3. Если оформление первого листа (или последующих листов) спецификации указано верно, требуется проверить правильность задания входящей в состав этого оформления основной надписи. Для этого

3.1. вызовите из меню Сервис команду Оформление чертежей...;

3.2. убедитесь, что в одном из окон просмотра появившегося диалога отображается состав нужной библиотеки оформлений (полное имя библиотеки указано в верхней части диалога над окном просмотра ее состава). Если в диалоге показана другая библиотека, подключите ту библиотеку, оформление из которой должно применяться в спецификации;

3.3. выберите из списка название оформления, которое должно применяться в спецификации, и нажмите кнопку Редактировать...;

3.4. в появившемся диалоге настройки оформления проверьте, правильно ли указано полное имя библиотеки, в которой содержится основная надпись (бланк) спецификации, при необходимости подключите нужную библиотеку основных надписей;

3.5. проверьте, правильно ли указано название основной надписи (бланка) из подключенной библиотеки, при необходимости выберите другую основную надпись. При выборе названия основной надписи учитывайте, оформление какого листа (первого или последующего) вы настраиваете. Обычно в названии бланка есть указание на первый или последующие листы, это поможет вам выбрать нужную основную надпись;

3.6. нажав кнопку OK, закройте диалог настройки оформления листа спецификации, выйдите из диалога работы со стилями оформлений и попытайтесь продолжить работу с объектами спецификации в текущем документе.

4. Если основная надпись первого листа (или последующих листов) спецификации указана верно, требуется проверить правильность этой основной надписи. Для этого

4.1. вызовите из меню Сервис команду Типы основных надписей...;

4.2. убедитесь, что в одном из окон просмотра появившегося диалога отображается состав нужной библиотеки основных надписей (полное имя библиотеки указано в верхней части диалога над окном просмотра ее состава). Если в диалоге показана другая библиотека, подключите ту библиотеку, основная надпись из которой должна применяться в оформлении спецификации;

4.3. выберите из списка название основной надписи, которая должна применяться в оформлении спецификации, и нажмите кнопку Редактировать...;

4.4. в появившемся диалоге найдите список, озаглавленный Состав основной надписи, выберите в нем название таблицы, которая предназначена для внесения в нее объектов спецификации, и включите опцию Использовать для спецификации (таблицы, предназначенные для спецификации и входящие в состав поставляемых вместе с системой основных надписей, называются Таблица спецификации);

4.5. нажав кнопку OK, закройте диалог настройки основной надписи, выйдите из диалога работы с основными надписями и продолжите работу с объектами спецификации в текущем документе.


Порядок исправления ошибки

1. Внимательно прочитайте сообщение системы. Запомните название оформления, вызвавшего конфликт, название стиля, содержащего это оформление, и полное имя библиотеки, содержащей этот стиль.

Появление сообщения свидетельствует о наличии ошибки в стиле спецификации, который используется для размещения объектов спецификации, принадлежащих макроэлементам, вставляемым из библиотеки.

2. Вначале требуется проверить правильность задания оформления спецификации (как известно, оформление спецификации является частью ее стиля). Для этого

2.1. вызовите из меню Сервис команду Стили спецификаций...;

2.2. убедитесь, что в одном из окон просмотра появившегося диалога отображается состав нужной библиотеки стилей (полное имя библиотеки указано в верхней части диалога над окном просмотра ее состава). Если в диалоге показана другая библиотека, подключите ту библиотеку, стиль из которой должен использоваться для размещения объектов спецификации;

2.3. выберите из списка название стиля спецификации, который должен использоваться для размещения объектов, и нажмите кнопку Редактировать...;

2.4. активизируйте вкладку Оформление появившегося диалога настройки стиля спецификации;

Если вы получили сообщение об ошибке оформления первого листа спецификации, дальнейшие действия (проверку и настройку) нужно производить с оформлением первого листа, если ошибка в оформлении второго и последующих листов, проверять и настраивать нужно оформление последующих листов.

2.5. проверьте, правильно ли указано полное имя библиотеки, в которой содержится оформление спецификации, при необходимости подключите нужную библиотеку оформлений;

2.6. проверьте, правильно ли указано оформление из подключенной библиотеки, при необходимости выберите другое оформление;

2.7. нажав кнопку OK, закройте диалог настройки стиля спецификации, выйдите из диалога работы со стилями спецификаций и попытайтесь вновь вставить библиотечный макроэлемент с объектом спецификации.

3. Если оформление первого листа (или последующих листов) спецификации указано верно, требуется проверить правильность задания входящей в состав этого оформления основной надписи. Для этого

3.1. вызовите из меню Сервис команду Оформление чертежей...;

3.2. убедитесь, что в одном из окон просмотра появившегося диалога отображается состав нужной библиотеки оформлений (полное имя библиотеки указано в верхней части диалога над окном просмотра ее состава). Если в диалоге показана другая библиотека, подключите ту библиотеку, оформление из которой должно применяться в спецификации;

3.3. выберите из списка название оформления, которое должно применяться в спецификации, и нажмите кнопку Редактировать...;

3.4. в появившемся диалоге настройки оформления проверьте, правильно ли указано полное имя библиотеки, в которой содержится основная надпись (бланк) спецификации, при необходимости подключите нужную библиотеку основных надписей;

3.5. проверьте, правильно ли указано название основной надписи (бланка) из подключенной библиотеки, при необходимости выберите другую основную надпись. При выборе названия основной надписи учитывайте, оформление какого листа (первого или последующего) вы настраиваете. Обычно в названии бланка есть указание на первый или последующие листы, это поможет вам выбрать нужную основную надпись;

3.6. нажав кнопку OK, закройте диалог настройки оформления листа спецификации, выйдите из диалога работы со стилями оформлений и попытайтесь вновь вставить библиотечный макроэлемент с объектом спецификации.

4. Если основная надпись первого листа (или последующих листов) спецификации указана верно, требуется проверить правильность этой основной надписи. Для этого

4.1. вызовите из меню Сервис команду Типы основных надписей...;

4.2. убедитесь, что в одном из окон просмотра появившегося диалога отображается состав нужной библиотеки основных надписей (полное имя библиотеки указано в верхней части диалога над окном просмотра ее состава). Если в диалоге показана другая библиотека, подключите ту библиотеку, основная надпись из которой должна применяться в оформлении спецификации;

4.3. выберите из списка название основной надписи, которая должна применяться в оформлении спецификации, и нажмите кнопку Редактировать...;

4.4. в появившемся диалоге найдите список, озаглавленный Состав основной надписи, выберите в нем название таблицы, которая предназначена для внесения в нее объектов спецификации, и включите опцию Использовать для спецификации (таблицы, предназначенные для спецификации и входящие в состав поставляемых вместе с системой основных надписей, называются Таблица спецификации);

4.5. нажав кнопку OK, закройте диалог настройки основной надписи, выйдите из диалога работы с основными надписями и вставьте в документ библиотечный макроэлемент с объектом спецификации.


Чтение линий с толщиной «default»

В импортируемом документе AutoCAD для некоторых объектов может быть установлена толщина линии «default». Толщина таких линий определяется текущими настройками системы AutoCAD, которые в разных сеансах работы, а также на разных рабочих местах могут отличаться. Таким образом, «default» не задает никакого определенного значения толщины. Поэтому при импорте документов, содержащих объекты с типом линии «default», необходимо учитывать следующее.

– Если настройка соответствия типов и стилей линий производится (опция Установить соответствие типов линий включена), то в диалоге настройки соответствия для того типа линии, который используется в объектах с толщиной линии «default», не следует вводить значение толщины — нужно указать только цвет и тип линии в AutoCAD и системный стиль линии в КОМПАС.

– Если настройка соответствия типов и стилей линий при импорте не производится (опция Установить соответствие типов линий выключена), или если не найдено соответствие, настроенное с учетом предыдущего пункта, то в документе КОМПАС для линии с толщиной «default» будет создан пользовательский стиль линий с толщиной 0,18 мм.


Сообщение об ошибке при импортировании файла

Иногда в процессе чтения возможно возникновение сообщения о наличии в импортируемом файле критической ошибки. Это означает, что в файле отсутствует часть данных, необходимых для корректного чтения.

Сообщение содержит также запрос на восстановление файла.

– Нажмите кнопку Да, чтобы подтвердить восстановление. Система прочтет файл снова, дополняя его данными по умолчанию. В результате файл импортируется корректно, но не исключена вероятность искажения имеющейся в нем информации.

– Нажмите кнопку Нет, чтобы отказаться от чтения файла с ошибкой.


Зависимые и независимые исполнения

В системе предусмотрена возможность создания зависимых и независимых исполнений модели.

Зависимое исполнение имеет связь с исходным исполнением, независимое исполнение не имеет такой связи. Наличие связи определяется при создании исполнения включением/отключением опции Зависимое исполнение. В дальнейшем нельзя сделать зависимое исполнение независимым и наоборот.

Объекты независимого исполнения доступны для самостоятельного редактирования и удаления. На них не влияют изменения соответствующих объектов исходного исполнения.

Объекты зависимого исполнения связаны с соответствующими объектами исходного исполнения. Изменение или удаление объектов исходного исполнения передается в зависимое. Чтобы изменить или удалить объект зависимого исполнения, необходимо отменить его связь с исходным.

Создание объектов в исходном исполнении передается в зависимое в соответствии с настройкой.

Подробнее о создании, изменении и удалении объектов исполнений...

При необходимости объекты исполнения могут быть переданы в другие исполнения, как зависимые, так и независимые. Подробнее...


Менеджер вставок видов и фрагментов

Менеджер вставок видов и фрагментов появляется на экране после нажатия кнопки Менеджер вставок видов и фрагментов на инструментальной панели Вставки и макроэлементы, а также выбора его названия из меню Редактор или контекстного меню на любом свободном месте документа.

Менеджер вставок видов и фрагментов служит для выполнения различных операций над вставками видов и фрагментов: смена способа вставки, переименование вставки, создание и удаление вставок и др.

Окно Менеджера вставок видов и фрагментов содержит инструментальную панель для управления вставками и три списка:

– Список типов вставок,

– Список вставок выбранного типа,

– Список свойств выбранной вставки.

Описание элементов управления Менеджера вставок видов и фрагментов...

Если удаление или разрушение вставки были выполнены по ошибке, то, чтобы отказаться от сделанных изменений, закройте Менеджер вставок видов и фрагментов и нажмите кнопку Отмена на панели Стандартная.

Отменить перечитывание документа-источника невозможно, поэтому, чтобы вернуться к прежнему изображению, необходимо закрыть текущий файл без сохранения.

Смотрите также

Вставки видов в Менеджере документа

Вставки видов и фрагментов в Дереве чертежа


Окно редактирования объектов таблицы изменений

При работе в окне редактирования объектов таблицы изменений пользователю доступны команды, аналогичные командам работы с объектами спецификации. Вы можете создавать и редактировать объекты таблицы изменений, подключать к ним документы, проставлять позиции.

Чтобы выйти из режима, можно щелкнуть мышью по значку режима в окне документа.

Смотрите также

Как получить справку во время работы


Окно графического документа

При работе в окне графического документа пользователю доступны команды страниц Главного меню, а также команды ввода и редактирования геометрических объектов, простановки размеров и технологических обозначений, измерений, наложения параметрических связей и ограничений, кнопки для быстрого вызова которых расположены на Компактной панели.

Смотрите также

Как получить справку во время работы


Окно документа-детали

При работе в окне документа-детали пользователю доступны команды страниц Главного меню, а также команды ввода объемных элементов, вспомогательных элементов, измерений, кнопки для быстрого вызова которых расположены на Компактной панели.

В окне модели находится элемент управления ориентацией, позволяющий изменить положение модели при помощи мыши.

Смотрите также

Как получить справку во время работы


Окно документа-сборки

При работе в окне документа-сборки пользователю доступны команды страниц Главного меню, а также команды вставки, создания и перемещения компонентов сборки, команды ввода объемных элементов, вспомогательных элементов, измерений и наложения сопряжений, кнопки для быстрого вызова которых расположены на Компактной панели.

В окне модели находится элемент управления ориентацией, позволяющий изменить положение модели при помощи мыши.

Смотрите также

Как получить справку во время работы


Режим перебора графических объектов

В этом режиме производится последовательное выделение (перебор) близко расположенных (в том числе наложенных друг на друга) объектов.

Для входа в режим перебора служит команда Перебор объектов, доступная в режиме выделения объектов, если в «ловушку» курсора попадает более одного объекта.

В этом режиме объекты можно перебирать, нажимая клавишу <Пробел> или вызывая команду Следующий объект из контекстного меню.

Для выхода из режима перебора с сохранением выделения на одном из объектов воспользуйтесь командой Закончить перебор объектов из контекстного меню или нажмите клавишу <Пробел>.

Следует отметить, что вызывать команду Закончить перебор необязательно, если для выделенного в результате перебора объекта будет вызываться какая-либо команда редактирования (например, симметрия, ввод атрибутов и т.д.). Команду редактирования можно вызвать сразу, как только нужный объект будет выделен в результате действия команды Следующий объект.

Для выхода из режима перебора объектов и снятия выделения со всех объектов можно щелкнуть мышью на свободном от изображения участке графического документа или нажать клавишу <Esc>.


Окно подготовки данных

Служит для просмотра и редактирования данных, помещенных в отчет, а также дополнительных настроек отчета.

Подробнее...

Отображение отчета в окне возможно в различных режимах.

В Окне подготовки данных в отчете могут выполняться

– Настройка текущих параметров

– Фильтрация строк в таблице

– Выделение строк

– Скрытие строк

– Вставка строк

– Копирование строк

– Удаление строк

– Перемещение строк вверх и вниз

– Перемещение строк в начало страницы

– Редактирование текста в ячейке

– Объединение ячеек

– Поиск текста в отчете

Из Окна подготовки данных отредактированный отчет можно

– Сохранить в отдельный файл

– Вывести на печать

– Разместить в документе, полностью или выборочно

Чтобы перейти к размещению отчета в документе или подтвердить редактирование, нажмите кнопку Создать отчет на Панели специального управления.

Чтобы завершить работу в Окне подготовки данных, нажмите кнопку Прервать команду на Панели специального управления или щелкните мышью на значке режима.


Окно спецификации

При работе в окне документа-спецификации пользователю доступны команды страниц Главного меню, а также команды ввода и редактирования объектов спецификации и их дополнительных параметров, синхронизации данных сборочного чертежа и спецификации и другие сервисные возможности.

Кнопки для быстрого вызова многих из этих команд расположены на Компактной панели.

Смотрите также

Как получить справку во время работы


Окно спецификации в подчиненном режиме

При работе в окне спецификации в подчиненном режиме пользователю доступны те же команды работы со спецификацией и ее объектами, что и в окне документа-спецификации (кроме команд синхронизации данных и подключения документов к спецификации). Вы можете создавать и редактировать объекты спецификации, подключать к ним документы и задавать другие дополнительные параметры объектов (например, массу детали), проставлять позиции, размещать спецификацию на листе чертежа, которому она подчинена.

Чтобы выйти из режима, можно щелкнуть мышью по значку режима в окне документа. Смотрите также

Как получить справку во время работы


Окно редактирования изображения основной надписи (штампа)

Окно редактирования изображения
основной надписи (штампа)

При работе в окне редактирования изображения основной надписи пользователю доступны команды создания и редактирования текстов и таблиц.

Смотрите также

Как получить справку во время работы


Окно текстового документа

При работе в окне текстового документа пользователю доступны команды страниц Главного меню, а также команды ввода и редактирования текстов, кнопки для быстрого вызова которых расположены на Компактной панели.

Смотрите также

Как получить справку во время работы


Окно технических требований

При работе в окне ввода и редактирования технических требований пользователю доступны команды ввода и редактирования текстов, кнопки для быстрого вызова которых расположены на Компактной панели.

Кроме произвольных текстов в технические требования можно вставлять заранее составленные пункты:

– из файла шаблонов — при помощи команды Вставка — Текстовый шаблон,

– из внешнего файла *.txt или текстового документа КОМПАС-3D (*.kdw) — при помощи команды Вставка — Файл....

Смотрите также

Как получить справку во время работы


Серия стандартов ISO 10303 STEP

Серия стандартов ISO 10303 STEP (Standard for the Exchange of Product model data) — стандарты, определяющие технологию представления данных («нейтральный» формат, для всех типов информационных сред) об изделии в виде информационной модели с целью обмена этими данными и их совместного использования. Технология включает методы реализации и протоколы применения. Для обеспечения возможности единообразного описания изделий в различных прикладных областях, информационные модели (в терминах стандарта «прикладные протоколы» — AP) создаются на базе типовых блоков («интегрированных ресурсов»). Прикладной протокол (AP, Application Protocol) — это схема, описывающая некоторую предметную область.

На серии стандартов ISO 10303 STEP базируется концепция и идеология CALS, в настоящее время сформировавшаяся в целое направление в области информационных технологий (CALS-технологии) и оформившаяся в виде серии международных стандартов ISO.


Меню панелей

Меню панелей позволяет управлять отображением на экране Инструментальных панелей, Панели свойств, Менеджера библиотек.

Это меню появляется на экране после вызова команды Вид — Панели инструментов.

Чтобы нужная панель была показана в окне программы, щелкните мышью по ее названию в Меню панелей. Слева от названия панели появится «галочка». Чтобы убрать панель с экрана, щелкните по этой «галочке» или названию панели. Можно также нажать стандартную кнопку Закрыть на панели.


Строка сообщений

В этой строке выводятся сообщения системы, относящиеся к выполнению текущей команды или к тому элементу рабочего окна, на который указывает курсор.


Тип колонки

Тип колонки определяет, какая именно информация будет храниться в этой колонке (независимо от ее названия). Например, в колонке с названием Шифр будет храниться ОБОЗНАЧЕНИЕ.

Тип колонки используется при автоматическом выполнении различных операций. Например, если тип колонки — ПОЗИЦИЯ, то именно в эту колонку будут заноситься номера позиций при их автоматическом перерасчете. Если тип колонки — ЗОНА, то именно в эту колонку будут попадать номера зон. Если тип колонки — ФОРМАТ, то в нее будут переноситься обозначения форматов из штампов чертежей деталей.

Не рекомендуется изменять тип колонок при настройке стандартных стилей спецификации, поставляемых в составе КОМПАС-3D, т.к. это может привести к некорректному выполнению многих сервисных операций.

Если несколько колонок имеют одинаковый тип, то при автоматическом выполнении операций будет использоваться та из них, тип которой имеет номер 1. Например, в спецификации есть колонки с типом ЗОНА[1] и ЗОНА[2]; при автоматическом расчете номера зон будут заноситься в колонку с типом ЗОНА[1].

При перерождении спецификации в спецификацию другого стиля (например, простой спецификации в групповую) колонки превращаются в колонки такого же типа (если он есть в стиле той спецификации, в которую перерождается исходная).


Команды построения массивов объектов

Кнопки вызова команд создания массивов объектов расположены на панели Массивы.

Массив по сетке

Массив по концентрической сетке

Массив вдоль кривой

Массив по точкам

Массив по таблице

Зеркальный массив

Массив по образцу


Диалог Менеджер документа(графический документ, текстовый документ, спецификация)

Диалог Менеджер документа
(графический документ, текстовый документ, спецификация)

Диалог появляется на экране после нажатия кнопки Менеджер документа на панели Стандартная.

Кроме того, при работе с графическим документом диалог может быть вызван командами Управление видами, Управление слоями, Вставка — Слой... или Сервис — Менеджер документа..., а также командой Менеджер документа из контекстного меню на свободном месте документа.

В графическом документе Менеджер документа предназначен для работы с объектами, составляющими структуру документа: листами, видами и слоями.

Основные действия, выполняемые с помощью Менеджера документа:

• изменение свойств листов, видов и слоев, в том числе выбор текущего вида или слоя,

• создание листов и слоев,

• удаление листов, видов и слоев,

• группирование слоев,

• копирование слоев между видами.

В графическом документе Менеджер документа осуществляет также управление слоями видов, вставленных в текущий чертеж из других чертежей. Подробно об этом рассказано в разделе Вставки видов в Менеджере документа.

В текстовом документе Менеджер документа служит для создания разделов, просмотра и смены оформлений листов, используемых в разделах документа.

В спецификации Менеджер документа служит для просмотра и смены стиля спецификации, а также для управления дополнительными листами: добавление, выбор оформления, изменение формата, кратности и ориентации, удаление.

Диалог Менеджер документа содержит области:

– Инструментальную панель,

– Дерево листов, видов и слоев,

– Список листов, видов и слоев,

– Область поиска.

Для сохранения всех сделанных настроек и выхода из диалога нажмите кнопку ОК, для выхода без сохранения — кнопку Отмена. Кнопка Применить позволяет сохранить сделанные изменения без закрытия диалога.

Смотрите также

Использование наборов для задания свойств слоев

Настройка группирования слоев


Правила автоматического формирования записи из строки текста

Правила разбиения строки текста на строковые и числовые поля:

1. Пробел в строке — признак окончания поля.

2. Запятая — признак вещественного числа, то есть два числа, разделенные запятой, воспринимаются как одно вещественное число.

3. Если строка содержит дробь, формируются поля с символами, определяющими дробь в формате КОМПАС 4: «$d» обозначает начало числителя; «;» обозначает конец числителя; «$» обозначает конец знаменателя.

Правила назначения ключей полям:

1. Строковые поля с одним символом (например, дефис) имеют ключ 0 (по этим полям сортировка не производится).

2. Первое поле имеет ключ 1.

3. Третье поле от конца (обычно оно содержит номер ГОСТ) имеет ключ 2.

4. Остальные поля имеют ключ 3.

Порядок сортировки можно изменить, отредактировав вручную ключи полей. Это можно сделать в диалоге редактирования данных в полях записи. Он вызывается двойным щелчком мыши на соответствующем тексте в ячейке спецификации.


Сопряжение механической связи

Сопряжение механической связи — сопряжение, определяющее закон движения одного объекта модели относительно другого при движении любого из них.

Сопряжения механической связи используются, как правило, для моделирования работы механизмов.


Диалог задания параметров для расчета

Диалог появляется на экране после указания очередной фигуры, включаемой в расчет.

В этом диалоге вводятся данные, необходимые для выполнения расчета массо-центровочных характеристик тел вращения или выдавливания.

Выберите, чем является указанная фигура — телом или отверстием.

Плотность материала можно ввести вручную либо выбрать из Справочника материалов (если он установлен на вашем рабочем месте) или из базы данных.

Для вызова Справочника материалов нажмите кнопку Выбрать из Справочника.... В открывшемся Справочнике материалов выберите группу материалов, марку материала, сортамент и типоразмер и вызовите команду Применить. Справочник закроется, а в поле Плотность диалога параметров появится плотность указанного материала.

Для подключения базы данных по материалам нажмите кнопку Плотность. На экране появится диалог выбора плотности материала.

Данные о материалах сгруппированы по тематическим разделам.

Чтобы развернуть содержание какого-либо раздела, щелкните левой кнопкой мыши на значке «плюс» рядом с заголовком раздела. Повторный щелчок на этом символе (после разворачивания раздела он отображается как минус) приведет к сворачиванию содержания раздела.

Укажите нужный материал детали и нажмите кнопку ОК. Диалог выбора материала закроется, а в поле Плотность диалога параметров появится плотность указанного материала.

Для тела вращения задайте угол раствора дуги вращения, а для тела выдавливания — толщину.

После задания всех параметров нажмите кнопку ОК. Для выхода из диалога без включения тела в расчет нажмите кнопку Отмена.


Диалог задания свойств плоского объекта

Диалог отображается на экране после указания очередной фигуры, включаемой в расчет.

В этом диалоге необходимо указать, чем является указанная фигура — телом или отверстием.

Включите опцию, соответствующую нужному варианту и нажмите кнопку ОК. Для выхода из диалога без включения фигуры в расчет нажмите кнопку Отмена.


Направляющие объекты

Направляющими объектами могут служить следующие объекты в модели.

– Точечные объекты.

Направление, задаваемое точечным объектом — проекция прямой, проходящей через этот точечный объект и начальную или конечную вершину базовой кривой, на плоскость смещения.

– Прямолинейные объекты.

Направление, задаваемое прямолинейным объектом — проекция объекта, на плоскость смещения.

– Плоские объекты.

Направление, задаваемое плоским объектом — проекция прямой, перпендикулярной объекту, на плоскость смещения.

Кроме того, направляющим объектом может служить вектор.

Направление и расстояние смещения могут быть заданы:

– вручную — выбором направляющего объекта и вводом значений на Панели свойств,

– указанием точки, проекция которой на плоскость смещения определяет значения параметров.


Направляющие объекты

В качестве направляющих могут использоваться следующие объекты.

– Прямолинейный объект:

• отрезок в эскизе,

• сегмент ломаной,

• координатная или вспомогательная ось,

• прямолинейное ребро.

Направление, задаваемое прямолинейным объектом — прямая, параллельная объекту.

– Плоский объект:

• координатная или вспомогательная плоскость,

• плоская грань,

• плоскость эскиза.

Направление, задаваемое плоским объектом — прямая, перпендикулярная объекту.

– Кривая (если начальная или конечная точка дуги лежит на этой кривой).

Направление, задаваемое кривой — касательный вектор в точке касания. Таким образом можно построить дугу, сопряженную с произвольной кривой — пространственным сплайном или ломаной, ребром и др.


Номер колонки

Иногда однородная (но не одинаковая) информация должна храниться в нескольких колонках и по этой причине они имеют одинаковый тип. Например, несколько колонок групповой спецификации содержат информацию о количестве, но числа в них разные, т.к. они относятся к разным исполнениям. Чтобы отличать типы таких колонок, вместе с названием типа задается еще и номер, отличающий колонку этого типа от других колонок такого же типа. Обратите внимание, что во вкладке Колонки диалога настройки стиля спецификации в скобках рядом с типом колонки показан этот номер (например, КОЛИЧЕСТВО[2]). Если разные колонки имеют одинаковый тип, то номера колонок этого типа должны быть разными.


Диалог Номер страницы

Диалог появляется на экране после вызова команды Спецификация — Добавить объект таблицы изменений, если чертеж содержит более одного листа со стилем оформления С таблицей изменений или С таблицей изменений с зонами.

В этом диалоге следует выбрать из раскрывающегося списка номер листа, в котором будет создана таблица изменений.

Выбрав номер, нажмите кнопку ОК, чтобы закрыть диалог.

Чтобы закрыть диалог без выбора номера, нажмите кнопку Отмена.


Выделение объектов

Чтобы выделить последовательно расположенные объекты, выделите первый из них, нажмите <Shift> и, не отпуская эту клавишу, выделите последний объект. Все объекты между первым и последним будут выделены.

Чтобы выделить произвольно расположенные объекты, нажмите <Ctrl>. Удерживая эту клавишу, щелкайте по названиям объектов. Они будут добавляться в группу выделенных. Чтобы отменить выделение объекта, щелкните по его названию еще раз, не отпуская клавишу <Ctrl>.

Эти способы выделения можно комбинировать.


Опция Разогнуть

Опция Разогнуть управляет состоянием сгибов листового элемента.

Если она включена, то результатом построения будет разогнутый сгиб или сгибы (см. рис. 1).

При выключенной опции сгиб или сгибы будут согнуты (см. рис. 2).

Рис. 1 | Рис. 2

Пиктограмма разогнутого листового элемента отмечается в Дереве построения значком «разогнуто».

Пиктограмма разогнутого листового тела

Пиктограмма разогнутого сгиба

Пиктограмма разогнутого сгиба по линии

Пиктограмма разогнутого сгиба по эскизу

Пиктограмма разогнутой подсечки

Чтобы отключить признак «разогнуто» у листовых элементов (и, соответственно, согнуть все их сгибы), необходимо выделить эти элементы и вызвать из контекстного меню команду Согнуть.

Любой разогнутый сгиб можно согнуть с помощью команды Согнуть, а согнутый — разогнуть с помощью команды Разогнуть.

Различия между способами изменения состояния сгибов


Особенности смены типа координат точек,задающих позиции экземпляров массива по таблице

Особенности смены типа координат точек,
задающих позиции экземпляров массива по таблице

– Если смена типа координат производится при закрытом окне Таблица изменяемых переменных, то значения координат сохраняются — присваиваются координатам выбранного типа. В результате этого положение экземпляров массива меняется.

– Если смена типа координат производится при открытом окне Таблица изменяемых переменных, то на экране появляется диалог, который позволяет:

• Сохранить значения координат — присвоить текущие значения координатам выбранного типа; в этом случае положение экземпляров массива изменится. Для выбора этого варианта нажмите в диалоге кнопку Да.

• Пересчитать значения координат — изменить значения координат согласно выбранному типу координат; в этом случае положение экземпляров массива сохранится. Для выбора этого варианта нажмите в диалоге кнопку Нет.


Инструментальная панель Скрыть

Команды меню кнопок Скрыть все объекты и Скрыть все объекты в компонентах можно расположить в виде наборов кнопок на отдельных панелях и поместить их в любом удобном месте.

Для этого «перетащите» меню кнопки мышью за заголовок в любом направлении.

– Из меню кнопки Скрыть все объекты формируется панель Скрыть.

– Из меню кнопки Скрыть все объекты в компонентах формируется панель Скрыть в компонентах.

Обратите внимание на отличие панелей Скрыть и Скрыть в компонентах от остальных инструментальных панелей: состав и порядок кнопок на них изменить невозможно.


Параметры построения эквидистантной кривойспособом Смещение по направлению от вершины

Параметры построения эквидистантной кривой
способом Смещение по направлению от вершины

Способ Смещение по направлению от вершины позволяет задать положение эквидистантной кривой смещением ее начальной (конечной) вершины относительно соответствующей вершины базовой кривой. Смещение выполняется в плоскости смещения в направлении вектора смещения.

Схема построения эквидистантной кривой способом Смещение по направлению от вершины

Плоскость смещения — это плоскость, перпендикулярная базовой кривой в ее начальной или конечной вершине.

Параметрами построения являются:

– направление вектора смещения эквидистантной кривой, задаваемое с помощью направляющих объектов или вектора (это направление считается умолчательным — начальным);

– угол — поворот вектора смещения относительно начального направления,

– расстояние — величина смещения.

Направление и расстояние смещения могут быть заданы:

– вручную — выбором направляющего объекта и вводом значений на Панели свойств,

– указанием точки, проекция которой на плоскость смещения определяет значения параметров.


Пластина

Пластина — плоский элемент, приклеенный к листовому телу. Пластина формируется путем выдавливания замкнутого эскиза на произвольную глубину или глубину, равную текущей толщине листового тела.

Перед добавлением пластины в детали необходимо создать эскиз, определяющий форму пластины.


Диалог выбора стиля точки

Этот диалог появляется на экране после вызова команды Стиль точки... из контекстного меню при вводе точки.

Выберите нужный стиль точки и нажмите кнопку ОК диалога.

Для выбора текущего стиля точки можно также воспользоваться списком Стиль на Панели свойств.

Смотрите также

Настройка цветов системных стилей точек


Поле Управление исполнениями

В поле отображается обозначение текущего исполнения. Поле присутствует на панели Текущее состояние, если панель расположена горизонтально.

Задайте в поле обозначение нужного исполнения вручную или выберите его из раскрывающегося списка. При указании исполнения соответствующая модель отображается в окне документа, а ее обозначение — в заголовке главного окна КОМПАС-3D.

Смотрите также

Команда Управление исполнениями...


Сопряжение позиционирующее

Сопряжение позиционирующее — сопряжение, определенным образом фиксирующее один объект модели относительно другого.

Позиционирующие сопряжения используются, как правило, в процессе компоновки сборочной модели.

В случае наложения сопряжений механической связи позиционирующие сопряжения служат для ограничения движения при визуализации работы механизма.


Поверхность проецирования(команда Проекционная кривая)

Поверхность проецирования
(команда Проекционная кривая)

В качестве поверхности проецирования может использоваться:

– грань тела или поверхности;

– координатная или вспомогательная плоскость;

– набор граней тел и/или поверхностей.


Поле Шаг Аппроксимации

Поле для ввода значения шага аппроксимации.

Поле доступно, если объект или текст преобразуется в NURBS-кривую по точкам с помощью команды Преобразовать в NURBS.

Чем меньше значение шага, тем точнее кривая повторяет контур исходного объекта.


Список Аппроксимация кривой

Раскрывающийся список, из которого можно выбрать способ аппроксимации — Аппроксимация по стрелке прогиба или Аппроксимация по углу касательной.

Список способов аппроксимации доступен, если объект или текст преобразуется в NURBS-кривую по точкам с помощью команды Преобразовать в NURBS.


Список Тип кривой

Раскрывающийся список, из которого можно выбрать тип кривой, в которую нужно преобразовать объект или текст. В списке доступны следующие типы кривой:

– Сплайн по полюсам

– NURBS-кривая по точкам

При преобразовании объекта в NURBS-кривую по точкам на Панели свойств становятся доступны элементы для задания способа и шага аппроксимации.


Координата А

Поле для ввода или задания счетчиком цилиндрической или сферической координаты точки A.

Если точка связана с точечным объектом (на кнопке Объект при этом отображается «галочка»), то поле координаты недоступно для ввода.

При задании положения точки мышью координата определяется автоматически и заносится в поле.

Подробнее о построении точки по координатам на цилиндре и сфере...


Группа Область применения (способы определения области применения «Компоненты»)

Группа Область применения
(способы определения области применения «Компоненты»)

Группа переключателей, позволяющая указать способ определения области применения «Компоненты». Доступна, если отключен переключатель Автоопределение.

– Активизация переключателя Все компоненты означает, что в область применения операции будут включены все компоненты, с которыми в данный момент пересекается элемент (экземпляры массива). После добавления или перемещения компонентов область применения операции будет определяться заново. При обнаружении новых пересечений соответствующие компоненты будут включаться в область применения операции.

– Активизация переключателя Все компоненты, кроме библиотечных означает аналогичный вышеописанному порядок определения области применения, но с исключением из нее компонентов, которые вставлены из прикладных библиотек (например, крепежных элементов из Библиотеки Стандартные Изделия).

– Активизация переключателя Выбор компонентов позволяет вручную указать компоненты, которые будут участвовать в операции. Для формирования перечня компонентов служит панель Список компонентов. Список компонентов не изменяется при добавлении или перемещении компонентов модели.


Группа Тела (способы определения области применения «Тела»)

Группа Тела
(способы определения области применения «Тела»)

Группа переключателей, позволяющая указать способ определения области применения «Тела». Доступна, если отключен переключатель Автоопределение.

– Активизация переключателя Все тела означает, что в область применения операции будут включены все видимые (не скрытые) тела. При этом формируется перечень всех видимых тел, имеющихся на момент выполнения операции. Этот перечень можно посмотреть и изменить на Панели Список тел, войдя в режим редактирования элемента, созданного с использованием способа определения области применения Все тела.

При работе с массивом перечень тел, составляющих область применения, не формируется. Его нельзя посмотреть и изменить вручную. Если состав модели изменяется, то автоматически изменяется и область применения массива.

– Активизация переключателя Выбор тел позволяет вручную выбрать тела, составляющие область применения. Для формирования перечня тел служит панель Список тел.

Обратите внимание на то, что приклеивание и вырезание формообразующих элементов, построение круглых отверстий возможно только при условии, что создаваемый (редактируемый) элемент пересекается или имеет общую поверхность со всеми телами, входящими в область применения. Если это условие не выполняется хотя бы для одного из тел, составляющих область применения, в модели возникает ошибка. Аналогичная ошибка возникает при задании области применения массива, если хотя бы одно из указанных тел не пересекается со всеми экземплярами массива.

Отсечение части модели поверхностью или по эскизу возможно при условии, что в результате выполнения операции удаляется хотя бы одно тело или его часть. Если в результате отсечения ничего не удаляется, то в модели возникает ошибка.

Если действие операции распространяется только на компоненты (в группе Область применения активен переключатель Область применения «Компоненты»), то элементы управления областью применения «Тела» недоступны.


Группа полей Точка вставки

Группа полей для указания точки вставки компонента в модель.

Координаты точки вставки задаются в текущей системе координат модели.

С точкой вставки совмещается начало абсолютной системы координат вставляемой модели.


Панель Переменные

Панель, содержащая перечень внешних переменных вставляемой модели.

Чтобы изменить значение переменной, дважды щелкните мышью в ячейке, где оно отображается. Задайте новое значение вручную или с помощью счетчика и нажмите клавишу <Enter>.

Если значение переменной изменено, в колонке Изменен напротив ее имени отображается «галочка».

Чтобы вернуть какой-либо переменной значение, хранящееся в файле-источнике, щелкните мышью по этой «галочке».

Изменения значений переменных немедленно отражаются на фантоме модели в окне документа.


Координата Х

Поле координаты Х точки, в которую будет помещено начало координат вставляемой модели.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.


Координата Y

Поле координаты Y точки, в которую будет помещено начало координат вставляемой модели.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.


Координата Z

Поле координаты Z точки, в которую будет помещено начало координат вставляемой модели.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.


Переключатель Направление U

Активизируйте это переключатель, чтобы перейти к указанию кривых или точек сети в направлении U. Укажите нужные объекты в окне модели.

Указанные объекты добавляются в конец Списка кривых направления U.

Если требуется добавить объекты в середину или в начало списка, воспользуйтесь кнопками Вставить перед кривой и Вставить после кривой на панели Список кривых направления U.

Чтобы перейти к указанию объектов направления U, можно также воспользоваться командой контекстного меню Направление U или выделить любой объект в Списке кривых направления U.

Изменение набора объектов сети отображается на фантоме поверхности в окне модели.

Смотрите также

Требования к кривым и точкам сети


Команда Направление U

Позволяет перейти к указанию объектов сети — кривых или точек — в направлении U сети. После вызова команды укажите нужные объекты в окне модели.

Указанные объекты добавляются в конец Списка кривых направления U на вкладке Параметры Панели свойств.

Если требуется добавить объекты в середину или в начало списка, воспользуйтесь кнопками Вставить перед кривой и Вставить после кривой на панели Список кривых направления U.

Изменение набора объектов сети отображается на фантоме поверхности в окне модели.

Смотрите также

Требования к кривым и точкам сети


Переключатель Направление V

Активизируйте это переключатель, чтобы перейти к указанию кривых или точек сети в направлении V. Укажите нужные объекты в окне модели.

Указанные объекты добавляются в конец Списка кривых направления V.

Если требуется добавить объекты в середину или в начало списка, воспользуйтесь кнопками Вставить перед кривой и Вставить после кривой на панели Список кривых направления V.

Переключатель Направление V доступен, если для направления U уже задано два или более объектов.

Чтобы перейти к указанию объектов направления V, можно также воспользоваться командой контекстного меню Направление V или выделить любой объект в Списке кривых направления V.

Изменение набора объектов сети отображается на фантоме поверхности в окне модели.

Смотрите также

Требования к кривым и точкам сети


Команда Направление V

Позволяет перейти к указанию объектов сети — кривых или точек — в направлении V сети. Команда Направление V доступна, если в направлении U уже указано два или более объектов.

После вызова команды укажите нужные объекты в окне модели.

Указанные объекты добавляются в конец Списка кривых направления V на вкладке Параметры Панели свойств.

Если требуется добавить объекты в середину или в начало списка, воспользуйтесь кнопками Вставить перед кривой и Вставить после кривой на панели Список кривых направления V.

Изменение набора объектов сети отображается на фантоме поверхности в окне модели.

Смотрите также

Требования к кривым и точкам сети


Список Дополнительный номер

Список позволяет выбрать дополнительный номер для исполнения модели, которое вставляется (вставлено) в текущую модель.

Список отображается на Панели свойств, если в модели — источнике вставки созданы дополнительные номера.

По умолчанию активной является пустая строка списка, т.е. ни один дополнительный номер не выбран. Вы можете выбрать строку с нужным номером.


Панель Список объектов для булевой операции

Панель Список объектов содержит названия двух тел, над которыми производится булева операция.

Чтобы добавить тело в список, укажите в окне модели любую грань, вершину или ребро этого тела, либо выделите в Дереве построения принадлежащий телу объект любого из следующих типов:

– первый формообразующий элемент,

– приклеенный формообразующий элемент,

– приклеенное листовое тело,

– приклеенная зеркальная копия тела,

– булева операция.

Чтобы удалить тело из списка, укажите его в окне или в Дереве повторно.

Можно также выделить тело в списке и нажать кнопку Удалить в верхней части панели Список тел.

Чтобы удалить оба тела из списка, щелкните мышью на свободном поле окна модели.

В операции могут участвовать только два тела. Поэтому при указании третьего тела второе удаляется из списка автоматически.

Обратите внимание на то, что при выделении тела в списке оно выделяется и в окне модели. Это облегчает контроль правильности выбора тел.

Кнопки Переместить вверх и Переместить вниз служат для изменения порядка следования тел. Этот порядок учитывается при выполнении операции вычитания тел.


Группа Результат операции

Группа переключателей, позволяющая указать тип булевой операции, которая будет произведена над выбранными телами.

Чтобы объединить тела, активизируйте переключатель Объединение.

Чтобы удалить из первого тела объем, занимаемый вторым телом, активизируйте переключатель Вычитание. Первым считается тело, находящееся на первой позиции Списка тел, а вторым — тело, находящееся на второй позиции.

Для изменения порядка следования тел воспользуйтесь кнопками Переместить вниз и Переместить вверх на панели Список тел.

Чтобы удалить весь объем обоих тел, кроме их общего объема, активизируйте переключатель Пересечение.

Объединение тел возможно, если они пересекаются или имеют общую поверхность, а вычитание и пересечение возможны, только если тела пересекаются.


Элемент Направляющий объект

Служит для включения режима, при котором перенос точки будет осуществлен в заданном направлении.

При нажатой кнопке Направляющий объект система ожидает указания в модели направляющего объекта или построения вектора.

Направление переноса: а) задаваемое прямолинейным объектом, б) задаваемое плоским объектом
а) | б)

После указания объекта в поле Направляющий объект отображается его наименование. Если направление задано вектором, то в этом поле отображается слово «Вектор».

После указания направляющего объекта или построения вектора становится доступно поле Расстояние.

Выход из режима производится автоматически после указания объекта.

Чтобы сменить направляющий объект, следует вновь нажать кнопку и произвести указание.

Подробнее о построении переносом...


Поле Углы Эйлера

Поле позволяет задать ориентацию осей текущей системы координат компонента с помощью углов Эйлера. Присутствует на Панели свойств, если для размещения компонента выбран способ По координатам.

Введите в поле углы нутации, прецессии и вращения.

В случае выбора направляющих объектов углы рассчитываются автоматически, их значения появляются в поле. Вы можете изменить значения углов. При этом произведенный ранее выбор направляющих объектов отменяется.

Значения углов в поле изменяются при повороте компонента с помощью элемента базирования.


Опция Выбирать промежуточные элементы

Если эта опция включена, то при выборе копируемых объектов в Дереве построения в их число автоматически включаются объекты, находящиеся между указанными. Т.е. можно указать только первый и последний копируемые объекты, а все промежуточные (точнее, те из них, которые могут быть скопированы) будут включены в список автоматически1.

Опция Выбирать промежуточные элементы присутствует на Панели свойств, если для копирования указываются произвольные объекты (в группе Тип активен переключатель Произвольные).

Обратите внимание на то, что автоматический выбор производится, если опция была включена до указания объектов. Включение опции после указания не изменяет состав копируемых объектов.

Результат автоматического выбора объектов не зависит то того, какой вид Дерева включен — последовательность построения или структура модели. Первый, последний и промежуточные объекты определяются на основе последовательности построения модели.

  1. Если в качестве первого или последнего копируемого объекта выбран объект, который невозможно скопировать, например, массив, то автоматический выбор объектов не производится.


Группа переключателей Ориентация

Позволяет выбрать направление вспомогательной оси: вдоль направляющего объекта или перпендикулярно ему.

Активизируйте нужный переключатель: Параллельно объекту или Перпендикулярно объекту.

Смена ориентации оси отображается на фантоме в окне модели.

Группа присутствует на Панели свойств, если в качестве направляющего объекта выбран прямолинейный объект или поверхность вращения.


Поле Направляющий объект

Содержит наименование объекта, указанного в качестве направляющего для вспомогательной оси. Если направление оси задано вектором, то в этом поле отображается слово «Вектор».

Чтобы сменить направляющий объект, укажите его в окне модели или в Дереве построения.

Выбор объектов в окне модели

Выбор объектов в Дереве построения

Чтобы отредактировать вектор, нажмите кнопку Построение вектора на Панели специального управления или выберите название команды из контекстного меню.


Поле Точка

В этом поле отображается наименование точечного объекта, через который проходит вспомогательная ось.

Чтобы сменить точечный объект, укажите его в окне модели или в Дереве построения или постройте новую точку, используя способы построения точки команды Точка.

Выбор объектов в окне модели

Выбор объектов в Дереве построения


Дополнительные колонки

Список дополнительных параметров объекта спецификации.

В колонке Значение напротив каждого параметра можно ввести или отредактировать его значение.


Документы

Это окно находится на вкладке Документы Панели свойств. В нем можно подключить к объекту КОМПАС-документы (например, спецификацию и сборочный чертеж сборочной единицы, или рабочий чертеж детали, или извещение об изменениях) и настроить связь объекта с этими документами. Если работа со спецификацией не включена, то при настройке дополнительных параметров объектов спецификации это окно недоступно.

В списке показаны названия КОМПАС-документов, подключенных к объекту. Документ, имя которого выделено в списке цветом, отображается в окне предварительного просмотра в уменьшенном масштабе. Для отказа от предварительного просмотра активизируйте опцию Выключить просмотр.

Кнопка Добавить документ служит для подключения КОМПАС-документа к выделенному объекту. В вызываемом ею стандартном диалоге открытия файлов выберите нужный документ (или сразу несколько документов). Один и тот же документ может быть подключен к нескольким объектам (в том числе и из разных спецификаций). С помощью этой кнопки вы можете создавать заготовки документов.

Кнопка Удалить документ служит для отключения документа, имя которого выделено цветом, от объекта.

Кнопка Загрузить документ позволяет загрузить документ, имя которого выделено цветом в списке. При загрузке документа активным остается окно спецификации и для редактирования чертежа необходимо активизировать его окно.

Кнопки со стрелками служат для перемещения выделенного имени документа по списку. Из основной надписи документа, имя которого стоит в списке первым, спецификация (или таблица изменений) будет получать информацию для внесения ее в соответствующие колонки (если перенос информации из основной надписи в спецификацию или таблицу изменений включен пользователем).

Опция в колонке Передавать изменения в документ включает/отключает передачу данных из объекта спецификации в подключенный документ (обозначение, наименование) и обратно (обозначение, наименование, масса, формат листа).

В колонке Комментарий можно ввести комментарий к подключенному документу, имя которого выделено цветом в списке.


Текущий раздел

Справочное поле, в котором отображается название текущего раздела спецификации. Текущим считается раздел, в котором находится курсор.


Тип объекта

Справочное поле, в котором отображается наименование типа объекта спецификации, выделенного или редактируемого в данный момент.

Объекты спецификации бывают базовые и вспомогательные.


С нового листа

При работе с объектами спецификации этот переключатель позволяет разместить текущий объект спецификации или текущий заголовок раздела в начале нового листа спецификации.

При работе с объектами таблицы изменений этот переключатель позволяет разместить текущий объект таблицы изменений в начале нового блока изменений.

Для отмены принудительного изменения размещения объекта или заголовка раздела отожмите переключатель.


Исходный текст

При вставке в графический документ фрагментов телом или внешней ссылкой в этот документ передаются также объекты спецификации, имеющиеся во фрагменте. При вставке в сборку компонентов (деталей и подсборок) в ее внутренние объекты передаются объекты спецификации деталей и внешние объекты спецификации подсборок.

Объекты спецификации, «пришедшие» из вставок, доступны для редактирования как в подчиненном режиме, так и в документе-спецификации, подключенном к документу, содержащему вставки.

Переключатель Исходный текст позволяет привести объект спецификации, принадлежащий фрагменту или компоненту, к исходному виду (хранящемуся во фрагменте или компоненте).

Если между объектом спецификации в текущем документе и объектом спецификации во вставке нет расхождений, переключатель недоступен.


Сброс

Иногда после создания объекта спецификации требуется изменить состояния переключателей группы Настройки автоматически установленные системой, т.е. настроить объект вручную (например, скрыть объект в таблице, или показать возрастающие номера позиций объектов-исполнений).

После ручной настройки становится доступной кнопка Сброс. Если требуется привести состояния переключателей к тем, что были установлены системой при создании объекта, нажмите эту кнопку.


Имя подраздела

Список имен подразделов текущего раздела.

Вы можете выбрать любой подраздел для размещения редактируемого или выделенного объекта спецификации.

Ввод имени подраздела с клавиатуры невозможен. Создание подразделов производится в диалоге настройки спецификации.

Ни имя, ни номер подраздела не отображаются в таблице спецификации и не выводятся на печать.


Номер подраздела

Список чисел от 0 до 10000.

Вы можете ввести или выбрать любой номер подраздела для размещения редактируемого или выделенного объекта спецификации.

Если в стиле текущей спецификации существует подраздел с выбранным номером, его имя появляется в поле Имя подраздела.

В противном случае поле Имя подраздела остается пустым, но объекту спецификации присваивается указанный номер подраздела. Так как объекты в разделах сортируются по возрастанию номеров подразделов, номер подраздела объекта определяет его положение в разделе.

Ни имя, ни номер подраздела не отображаются в таблице спецификации и не выводятся на печать.


Настройки спецификации

Группа переключателей, позволяющая управлять различными характеристиками объекта спецификации.

Активизация переключателя Позиция объекта возрастает означает, что номер позиции настраиваемого объекта должен быть на единицу больше номера позиции предшествующего ему объекта. Если переключатель не активен, то номер позиции совпадает с номером позиции предыдущего объекта. Как правило, эта опция автоматически отключается при создании объекта с текстовой частью, повторяющей текстовую часть другого объекта. Действие этой опции распространяется и на объект, у которого отключен показ номера позиции в таблице. Если эта опция включена у вспомогательного объекта, он может служить резервной строкой.

Активизация переключателя Показывать объект в таблице означает, что настраиваемый объект виден в таблице в любом режиме работы с ней. Неактивный переключатель означает, что показывать объект в таблице не нужно; при этом объект не удаляется (он по-прежнему участвует в расчете номеров позиций, может содержать геометрические объекты и т.д.). Как правило, эта опция автоматически отключается при создании объекта с текстовой частью, полностью повторяющей текстовую часть другого объекта. Чтобы впоследствии просмотреть или отредактировать скрытый объект (его текстовую часть, геометрию, значения в дополнительных колонках), воспользуйтесь командой Показать все объекты.

Активизация переключателя Показывать позицию означает, что в колонке Позиция настраиваемого объекта отображается ее содержимое. Неактивный переключатель означает, что колонка будет показываться пустой.

Переключатель Объект является исполнением автоматически активизируется у объектов, образованных по команде Добавить исполнения. Если создается групповая спецификация с количеством исполнений, большим, чем количество колонок для исполнений, а информация в ней представлена по объектам, то объекты, являющиеся исполнениями, не будут отделяться от своего исходного объекта (исходным они считают первый предыдущий объект, у которого неактивен переключатель Объект является исполнением). Для объектов, у которых активен этот переключатель, команда Добавить исполнения недоступна.

Переключатель Синхронизировать с документом-владельцем автоматически активизируется у объекта, с которым связан компонент сборки. Этот компонент является документом-владельцем объекта спецификации. Пока переключатель активен, между сборкой (или спецификацией, к которой она подключена) и документом-владельцем производится передача изменений, сделанных в объекте спецификации. Неактивный переключатель означает, что передача изменений не происходит. Например, отключение передачи данных может потребоваться для редактирования объекта спецификации, документ-владелец которого недоступен для записи.


Группа Номер точки

Группа переключателей, позволяющая выбрать точку дуги для изменения параметров этой точки при построении и редактировании дуги.

Начальная точка

Конечная точка

При построении дуги последовательная активизация переключателей происходит автоматически.


Элемент Базовая плоскость дуги

Позволяет сменить базовую плоскость — плоскость, которой параллельна плоскость дуги.

Чтобы сменить базовую плоскость, активизируйте переключатель Базовая плоскость и укажите нужный объект в окне модели или в Дереве построения (эскиз следует указывать в Дереве построения).

Название указанного объекта отображается в поле рядом с переключателем.


Способ построения

Список, из которого можно выбрать текущий способ построения дуги окружности.

По 3 точкам

По центру и радиусу

По 2 точкам с направлением

С касанием к кривой


Группа Номер точки

Группа переключателей, позволяющая выбрать точку дуги для изменения параметров этой точки при построении и редактировании дуги.

Начальная точка

Конечная точка

Точка на окружности

При построении дуги последовательная активизация переключателей происходит автоматически.


Точка на дуге

Поля координат точки создаваемой дуги.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Начальный угол дуги

Поле начального угла создаваемой дуги.

При указании начальной точки дуги мышью начальный угол определяется автоматически и заносится в это поле.

Возможен также ввод значения с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Начальная точка дуги

Поля координат начальной точки создаваемой дуги.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Центр дуги

Поля координат центра создаваемой дуги.

Эти поля доступны для редактирования только при построении обычной дуги. Если центр указывается мышью, координаты точки определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Угол раствора дуги

Поле угла раствора создаваемой дуги.

Умолчательное значение раствора дуги — 90 градусов. При необходимости вы можете ввести произвольное значение.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Диаметр дуги

Поле диаметра создаваемой дуги.

При указании точки на дуге мышью, а также при указании объекта, которого должна касаться дуга, величина диаметра определяется автоматически и заносится в это поле.

Кроме того, возможен ввод значения диаметра с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Диаметр дуги

Поле диаметра создаваемой дуги.

При построении дуги по трем точкам и дуги по двум точкам и углу раствора поле является справочным и ввод значений в него невозможен.

При построении других дуг вы можете редактировать значение в поле Диаметр.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Группа Дуга

Группа переключателей, позволяющая выбрать нужный вариант участка дуги или окружность. Активизируйте нужный переключатель: Дуга по умолчанию, Дополняющая дуга или Окружность.

Изменение варианта немедленно отображается на фантоме дуги в окне модели.


Конечный угол дуги

Поле конечного угла создаваемой дуги.

При указании конечной точки дуги мышью конечный угол определяется автоматически и заносится в это поле.

Возможен также ввод значения с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Конечная точка дуги

Поля координат конечной точки создаваемой дуги.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Радиус дуги

Поле радиуса создаваемой дуги.

При указании точки на дуге мышью, а также при указании объекта, которого должна касаться дуга, величина радиуса определяется автоматически и заносится в это поле.

Кроме того, возможен ввод значения радиуса с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Радиус дуги

Поле радиуса создаваемой дуги.

При построении дуги по трем точкам и дуги по двум точкам и углу раствора поле является справочным и ввод значений в него невозможен.

При построении других дуг вы можете редактировать значение в поле Радиус.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Начальный угол оси

Поле начального угла создаваемой дуговой координационной оси.

При указании начальной точки оси мышью начальный угол определяется автоматически и заносится в это поле.

Возможен также ввод значения с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Центр оси

Поля координат центра создаваемой дуговой координационной оси.

При указании центра оси мышью координаты точки определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Диаметр оси

Поле диаметра создаваемой дуговой координационной оси.

При построении оси мышью диаметр определяется автоматически после указания точек тС, т1 или т2 и заносится в это поле.

Возможен также ввод значения с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Конечный угол оси

Поле конечного угла создаваемой дуговой координационной оси.

При указании конечной точки оси мышью конечный угол определяется автоматически и заносится в это поле.

Возможен также ввод значения с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Радиус оси

Поле радиуса создаваемой дуговой координационной оси.

При построении оси мышью радиус определяется автоматически после указания точек тС, т1 или т2 и заносится в это поле.

Возможен также ввод значения с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Группа Номер точки

Группа переключателей, позволяющая выбрать точку дуги для изменения параметров этой точки при построении и редактировании дуги.

Центральная точка

Начальная точка

Конечная точка

Радиус

При построении дуги последовательная активизация переключателей происходит автоматически.


Группа Номер точки

Группа переключателей, позволяющая выбрать точку дуги для изменения параметров этой точки при построении и редактировании дуги.

Центральная точка

Начальная точка

Конечная точка

При построении дуги последовательная активизация переключателей происходит автоматически.


Группа Способ

Группа переключателей для выбора способа размещения экземпляров массива по образцу.

– Активизация переключателя По параметрам массива-образца означает, что экземпляры создаваемого массива размещаются в пространстве согласно параметрам массива-образца.

– Активизация переключателя Сохранять положение относительно экземпляра массива-образца означает, что экземпляры создаваемого массива размещаются относительно соответствующих им экземпляров массива-образца так же, как копируемый компонент размещается относительно соответствующего ему базового экземпляра массива-образца (по умолчанию выбирается экземпляр, ближайший к копируемому компоненту). Возможна смена базового экземпляра массива-образца.

Подробнее о способах размещения экземпляров...


Элемент управления Экземпляр

Позволяет сменить базовый экземпляр массива-образца.

Активизируйте переключатель Экземпляр и укажите нужный экземпляр массива-образца в Дереве построения или в окне модели. Наименование указанного экземпляра отображается в поле рядом с переключателем.

Элемент присутствует на Панели свойств, если в группе Способ активен переключатель Сохранять положение относительно экземпляра массива-образца.


Массив-образец

Переключатель, позволяющий перейти к указанию массива-образца.

После активизации переключателя выберите нужный массив в Дереве построения или в окне модели.

Название указанного массива отображается в поле рядом с переключателем.


Опция Учитывать вложенность

Управляет количеством экземпляров массива по образцу в случае, когда массив-образец имеет вложенность (т.е. его исходным объектом является другой массив).

Если опция включена, то количество экземпляров создаваемого массива будет равно произведению количества экземпляров массива-образца на количество экземпляров вложенного массива, а если отключена — просто равно количеству экземпляров массива-образца.


Опция Учитывать удаленные

Управляет количеством экземпляров массива по образцу в случае, когда в массиве-образце имеются удаленные экземпляры.

Если опция включена, создаваемый массив не будет содержать экземпляры, номера которых равны номерам удаленных экземпляров массива-образца, а если отключена — будет содержать.


Группа Границы

Группа переключателей управляет построением граничных кривых, соответствующих границам теоретической поверхности грани.

– Группа кривых создается с граничными кривыми.

– Группа создается без граничных кривых.

Общие сведения о теоретической поверхности грани и изопараметрических кривых...

Группа изопараметрических кривых на поверхности...


Поле Количество, U

Позволяет задать количество кривых по направлению параметра поверхности U. Это кривые направления V, расположенные с равным шагом по параметру U.

Введите или задайте счетчиком нужное количество кривых направления V.

Обратите внимание на то, что в заданное количество кривых входят две граничные кривые, соответствующие границам теоретической поверхности по направлению U.

Общие сведения о теоретической поверхности грани и изопараметрических кривых...

Группа изопараметрических кривых на поверхности...


Поле Количество, V

Позволяет задать количество кривых по направлению параметра поверхности V. Это кривые направления U, расположенные с равным шагом по параметру V.

Введите или задайте счетчиком нужное количество кривых направления U.

Обратите внимание на то, что в заданное количество кривых входят две граничные кривые, соответствующие границам теоретической поверхности по направлению V.

Общие сведения о теоретической поверхности грани и изопараметрических кривых...

Группа изопараметрических кривых на поверхности...


Поле Поверхность

В этом поле отображается название базовой грани для построения группы изопараметрических кривых.

Выбор объектов в окне модели

Общие сведения о теоретической поверхности грани и изопараметрических кривых...

Группа изопараметрических кривых на поверхности...


Панель Список объектов(редактирование размеров экземпляров массива)

Панель Список объектов
(редактирование размеров экземпляров массива)

Панель, содержащая список объектов, участвовавших в построении базового экземпляра массива. К ним относятся эскизы, операции, вспомогательные плоскости, кривые (кроме сплайнов и ломаных), точки.

Если в списке выделен объект, то в окне модели отображаются размеры. Размеры показываются на том экземпляре массива, который выделен на панели Список экземпляров.

Подробнее о размерах экземпляров массива...


Группа Базовая точка

Позволяет выбрать способ задания базовой точки базового экземпляра массива: ручной или автоматический.

Автоопределенной базовой точкой базового экземпляра является базовая точка копируемого объекта.

Если копируется операция вращения, тело, созданное операцией вращения, или поверхность вращения, то вместо базовой точки копируемого объекта можно использовать ее проекцию на ось вращения копируемого объекта.

Включение/отключение использования проекции базовой точки производится на вкладке Параметры с помощью опции На оси вращения.

– Активизация переключателя Ручное указание позволяет перейти к произвольному заданию базовой точки базового экземпляра. Положение базовой точки задается точечным объектом.

– Активизация переключателя Автоопределение отменяет ручное указание базовой точки. После этого базовой точкой базового экземпляра считается базовая точка копируемого объекта.

Система «запоминает» указанный вручную точечный объект, поэтому вы можете переключаться между способами задания базовой точки без потери данных.

Отменить ручное указание базовой точки можно также с помощью команды контекстного меню Автоопределение базовой точки.

Подробнее о выборе способа задания базовой точки для массива вдоль кривой...

Подробнее о выборе способа задания базовой точки для массивов по концентрической сетке, по точкам и по таблице...

Обратите внимание на следующие особенности при построении массивов по концентрической сетке и вдоль кривой.

– При копировании группы объектов по концентрической сетке имеются особенности, зависящие от того, задана базовая точка вручную или автоопределена.

– При построении массива вдоль кривой, если базовая точка базового экземпляра не выбрана пользователем явно, то в качестве этой точки автоматически выбирается одна из крайних вершин кривой. Можно выбрать другую точку или отменить выбор. В последнем случае базовой точкой базового экземпляра считается базовая точка объекта копирования (автоопределение).

Смотрите также

Базовая точка экземпляра массива


Элемент управления Базовая точка базового экземпляра

Переключатель, позволяющий перейти к ручному указанию базовой точки базового экземпляра.

После активизации переключателя укажите нужный точечный объект в Дереве построения или в окне модели.

Название указанного объекта отображается справочном поле Объект рядом с переключателем.

Переключатель доступен, если в группе Базовая точка выбран способ Ручное указание.

Смотрите также

Выбор способа задания базовой точки базового экземпляра...


Опция На оси вращения

Опция, включение которой позволяет использовать вместо базовой точки копируемого объекта ее проекцию на ось вращения объекта.

Опция присутствует на Панели свойств при копировании следующих объектов:

– операция вращения,

– тело, созданное операцией вращения,

– поверхность вращения.

По умолчанию опция На оси вращения включена.

При выключенной опции для построения массива используется базовая точка копируемого объекта.

Изменение состояния опции отображается на фантоме массива в окне модели.

Возможность включать/отключать использование проекции базовой точки копируемого объекта доступна в массивах, использующих базовую точку базового экземпляра.


Группа переключателей Режим

Группа переключателей, позволяющая выбрать режим работы с экземплярами массива.

Данная группа присутствует на вкладке, если в группе Тип активен переключатель Кривые, точки, вспомогательная геометрия или Операции (при отключенной опции Геометрический массив).

Активизируйте переключатель Удалить/восстановить, чтобы перейти в режим удаления/восстановления экземпляров массива.

Подробнее об удалении и восстановлении экземпляров...

Активизируйте переключатель Редактировать размеры, чтобы перейти в режим редактирования размеров экземпляров массива.

Подробнее о редактировании размеров экземпляров...


Панель Список экземпляров

Панель, содержащая список экземпляров массива.

Номера экземпляров отображаются в списке так же, как в Дереве построения модели. Подробнее...

Для экземпляра, выделенного в списке, в окне модели отображаются размеры эскизов и операций, участвовавших в построении базового экземпляра массива (данные размеры отображаются для всех массивов, кроме зеркального и массива по образцу), а также размеры позиции выбранного экземпляра для массива по таблице.

Подробнее о размерах экземпляров массива...


Переключатель отрисовки линий сгиба

Переключатель, управляющий отрисовкой линий сгиба. Если отрисовка включена, то стиль линий сгиба можно настроить с помощью списка Стиль, расположенного рядом с переключателем. По умолчанию линии сгиба имеют стиль Пунктир 2.

Для вида по стрелке, проекционного и произвольного вида переключатель Линии сгиба доступен, если при настройке параметров этого вида включена отрисовка развертки.

Для разрезов (сечений) и выносного вида переключатель Линии сгиба доступен, если при настройке параметров опорного вида включена отрисовка развертки.


Опция Невидимые линии

Опция, управляющая передачей в вид линий невидимого контура.

Если эта опция выключена, то переключатель отрисовки невидимых линий недоступен. При включении опции система обращается к модели и формирует линии невидимого контура. Переключатель показа невидимых линий становится доступным, и вы можете включить отрисовку невидимых линий.

Если во время настройки параметров вида было изменено состояние опции Невидимые линии, то после завершения настройки этот вид отображается перечеркнутым, т.е. требующим перестроения. В результате перестроения линии невидимого контура добавляются в вид (если опция Невидимые линии была включена) или удаляются из него (если опция была выключена).

Невидимые линии хранятся в виде вне зависимости от того, включена их отрисовка или нет. Если отрисовка этих линий не потребуется, отключите опцию Невидимые линии — это уменьшит размер файла чертежа.

Рекомендуется отключать опцию Невидимые линии при построении ассоциативных видов сборок, содержащих более 1000 компонентов.


Переключатель отрисовки невидимых линий

Переключатель, управляющий отрисовкой линий невидимого контура. Если отрисовка этих линий включена, их стиль можно настроить с помощью списка Стиль, расположенного рядом с переключателем. По умолчанию невидимые линии имеют стиль Штриховая.

Переключатель отрисовки невидимых линий доступен, если включена опция Невидимые линии.


Переключатель отрисовки линий переходов

Переключатель, управляющий отрисовкой линий переходов. Если отрисовка этих линий включена, их стиль можно настроить с помощью списка Стиль, расположенного рядом с переключателем. По умолчанию линии переходов имеют стиль Тонкая.


Элемент Объект

Служит индикатором наличия ассоциативной связи точки на кривой с точечным объектом. Связь формируется при указании точечного объекта.

Если связь есть, то на кнопке Объект отображается «галочка», а в поле Объект — наименование точечного объекта. В этом случае поле ввода параметров смещения точки вдоль кривой недоступно для редактирования.

Если связи нет, то «галочка» на кнопке Объект не отображается, а поле Объект пусто.

При необходимости связь можно отменить, нажав кнопку Объект. «Галочка» на кнопке исчезнет.

Для восстановления ассоциативной связи точки с точечным объектом необходимо указать нужный объект заново.


Элемент Объект(построение группы точек по поверхности)

Элемент Объект
(построение группы точек по поверхности)

Служит индикатором наличия ассоциативной связи центра сетки с точечным объектом.

Если связь есть, то на кнопке Объект отображается «галочка», а в поле рядом с кнопкой — наименование точечного объекта.

Если связи нет, то «галочка» на кнопке Объект не отображается, а поле пусто.

При необходимости связь можно отменить, нажав кнопку Объект. «Галочка» на кнопке исчезнет, поле очистится.

Общие сведения о теоретической поверхности грани...

Подробнее о построении группы точек по поверхности...


Опция Ассоциировать

Служит для включения режима, в котором вершина сплайна или ломаной ассоциативно связывается с указанным точечным объектом.

Благодаря наличию связи вершина кривой будет следовать за объектом при любых его перемещениях.

Если опция отключена, то вершина кривой не связывается с точечным объектом при его указании.

Обратите внимание на то, что с помощью опции Ассоциировать нельзя удалить связь уже созданной вершины кривой с точечным объектом.

Для удаления связи необходимо в таблице параметров вершин выделить нужную строку и щелкнуть мышью по значку связи этой вершины в колонке Связь или вызвать команду Удалить связь из контекстного меню таблицы. Отменить это действие невозможно. Для восстановления связи необходимо отредактировать вершину, заново построив или указав нужную точку.

Смотрите также

Формирование ассоциативной связи вершин с точечными объектами. Особенности связанных вершин


Автоопределение

Опция, позволяющая выбрать способ отрисовки штрихпунктирной линии координационной оси.

Если опция Автоопределение включена, то длина штриха вычисляется автоматически с соблюдением следующих условий:

– длина штриха находится в диапазоне 5...30 мм;

– координационные оси начинаются и заканчиваются штрихами;

– начальная и конечная точки оси (т1 и т2) располагаются на штрихах.

Если нужно, чтобы длина штриха не превышала определенного значения, выключите опцию Автоопределение и задайте максимальную длину штриха в поле Штрих. При построении будет соблюдено условие, что оси начинаются и заканчиваются штрихами, не превышающими заданную длину.

Умолчательное состояние опции Автоопределение задается в диалоге настройки отрисовки координационной оси.


Автоопределение области применения «Компоненты»

Автоопределение
области применения «Компоненты»

Активизируйте этот переключатель, чтобы включить автоматическое определение области применения «Компоненты».

В область применения будут включены все компоненты, с которыми пересекается создаваемый или редактируемый элемент (экземпляры массива).

Особенностью автоопределения является то, что в результате его работы создается перечень компонентов, с которыми обнаружено пересечение во время выполнения операции. Этот перечень можно посмотреть и изменить на Панели Список компонентов, войдя в режим редактирования элемента, созданного с использованием автоопределения области применения.

При работе с массивом список объектов, составляющих область применения, не формируется. Его нельзя посмотреть и изменить вручную. Если состав модели изменяется, то автоматически изменяется и область применения массива.

Если нужно использовать другие способы определения области применения, отключите переключатель Автоопределение и воспользуйтесь группой элементов Область применения.


Автоопределение области применения «Тела»

Автоопределение
области применения «Тела»

Переключатель, позволяющий включить или отключить автоматическое определение области применения «Тела».

По умолчанию переключатель Автоопределение активен. Это означает, что в область применения операции будут включены только те видимые (не скрытые и не исключенные из расчета) тела, с которыми пересекается создаваемый элемент (экземпляры создаваемого массива).

Особенностью автоопределения является то, что в результате его работы создается перечень тел, с которыми обнаружено пересечение во время выполнения операции. Этот перечень можно посмотреть и изменить на Панели Список тел, войдя в режим редактирования элемента, созданного с использованием автоопределения области применения.

При работе с массивом перечень тел, составляющих область применения, не формируется. Его нельзя посмотреть и изменить вручную. Если состав модели изменяется, то автоматически изменяется и область применения массива.

Чтобы задать область применения операции вручную, отключите переключатель Автоопределение. После этого на Панели свойств появится группа переключателей Тела, позволяющая указать нужные тела.

Если действие операции распространяется только на компоненты (в группе Область применения активен переключатель Область применения «Компоненты»), то элементы управления областью применения «Тела» недоступны.


Автоопределение

Согласно ГОСТ осевые линии должны начинаться и заканчиваться штрихами. Чтобы выполнить это требование, при отрисовке линий производится пропорциональное изменение длин штрихов.

Если при расчете длины штриха должно учитываться условие попадания полученного значения в диапазон, заданный стандартом (5...30 мм), включите опцию Автоопределение.

Если нужно, чтобы длина штриха не превышала определенного значения (без учета требований стандарта), выключите опцию Автоопределение и задайте максимальную длину штриха в поле Штрих.


Штрих

Поле для ввода или выбора максимальной длины штрихов осевой линии. Это поле доступно при выключенной опции Автоопределение.


Пунктир

Поле для ввода или выбора длины пунктира.

Напоминаем, что согласно ГОСТ 2.303 общая длина пунктира и двух промежутков должна составлять 3...5 мм.


Промежуток

Поле для ввода или выбора длины промежутков между пунктиром и штрихом.

Напоминаем, что согласно ГОСТ 2.303 общая длина пунктира и двух промежутков должна составлять 3...5 мм.


Выступ

Поле для ввода или выбора величины выступов осевой линии за контур детали.


Элемент Ось 1 (Ось)

Служит для выбора оси, вокруг которой вращается первый объект.

При нажатой кнопке Ось 1 (Ось) система ожидает указания оси.

После указания в поле оси появляется наименование объекта, а на экране появляются круглые стрелки, указывающие направление вращения по умолчанию.

Элемент управления доступен, если указан первый объект.

При указании некоторых объектов выбор оси производится автоматически. Если требуется сменить объект, нажмите кнопку Ось 1 (Ось) и укажите новый объект.


Элемент Ось 2

Служит для выбора оси, вокруг которой происходит вращение второго объекта.

При нажатой кнопке Ось 2 система ожидает указания оси.

После указания в поле оси появляется наименование объекта, а на экране появляются круглые стрелки, указывающие направление вращения по умолчанию.

Элемент управления доступен, если указан второй объект.

При указании некоторых объектов выбор оси производится автоматически. Если требуется сменить объект, нажмите кнопку Ось 2 и укажите новый объект.


Элемент Ось

Служит для выбора оси, вокруг которой происходит вращение кулачка.

При нажатой кнопке Ось система ожидает указания объекта, задающего ось.

После указания в поле оси появляется ее наименование, а на экране — круглые стрелки, указывающие направление вращения.

Объекты, которые могут быть использованы для сопряжения Кулачок – толкатель...


Элемент Траектория

Служит для выбора траектории, вдоль которой происходит перемещение толкателя.

При нажатой кнопке Траектория система ожидает указания прямолинейного объекта.

После указания в поле траектории появляется ее наименование, а на экране — стрелка, указывающая направление перемещения.

Объекты, которые могут быть использованы для сопряжения Кулачок – толкатель...


Группа Направление осей

Группа переключателей, позволяющая указать ось ЛСК или системны координат компонента, направление которой требуется задать. Выбранную ось необходимо связать с направляющим объектом (используются те же прямолинейные и плоские направляющие объекты, что и при построении точки). Ось ЛСК можно также направить по вектору.

Чтобы задать направление оси, активизируйте переключатель, соответствующий этой оси. Данная ось будет выделена в окне модели. На Панели свойств появится поле Направляющий объект оси и кнопка смены направления оси.

При работе с ЛСК ось, направление которой требуется изменить, можно указать мышью в окне модели. Для этого подведите курсор к нужной оси и щелкните левой кнопкой мыши, когда рядом с курсором появится строка «Направляющий объект оси».

Укажите нужный объект в окне модели. Его название появится в поле Направляющий объект оси, а система координат (фантом ЛСК или СК компонента) повернется.

При работе с ЛСК вместо указания объекта можно построить вектор. Для создания вектора нажмите кнопку Построение вектора. Эта кнопка находится на Панели специального управления и становится доступной после выбора оси. Если направление оси задано вектором, то в поле Направляющий объект оси отображается слово «Вектор».

Направление можно задать только для двух осей системы координат. Третья ось автоматически располагается так, чтобы образовывать с двумя другими правую тройку векторов.

Направляющий объект для второй оси может задавать направление, не перпендикулярное первой оси. В этом случае направление второй оси определяется как проекция направления, которое задает объект, на плоскость, перпендикулярную первой оси.

Объект не может использоваться в качестве направляющего для второй оси, если он параллелен первой оси или лежит на одной прямой с ней.

Вектор не может использоваться в качестве направляющего объекта для второй оси ЛСК, если он коллинеарен первой оси. При обнаружении ошибки выдается сообщение об этом.

Когда активен один из переключателей группы Направление осей, на Панели свойств отображается кнопка, позволяющая направить соответствующую ось в обратную сторону:

Перевернуть ось X,

Перевернуть ось Y,

Перевернуть ось Z.

При работе с ЛСК оси можно переворачивать с помощью мыши. Для этого, удерживая нажатой клавишу <Ctrl>, щелкните левой кнопкой мыши по характерной точке на конце нужной оси.

При размещении компонента направлением осей можно управлять с помощью элемента базирования.

Чтобы отменить использование направляющих объектов для всех осей, нажмите кнопку Указать заново на Панели специального управления.


Панель Направление осей

Панель, содержащая таблицу текущих координат единичных векторов, сонаправленных осям ЛСК.

Над таблицей расположены кнопки:

– Исходная ориентация. Позволяет отменить все изменения ориентации ЛСК. После нажатия этой кнопки оси ЛСК становятся сонаправлены соответствующим осям ее собственной СК.

– Читать из файла. Позволяет ориентировать ЛСК по тройке единичных векторов, координаты которых записаны в файле. После нажатия этой кнопки на экране появляется диалог, в котором нужно указать файл, содержащий координаты векторов и нажать кнопку Открыть. Значения в таблице изменятся, а фантом ЛСК в окне модели повернется. Все сделанные ранее настройки ориентации ЛСК (выбор объектов или ввод значений углов) будут отменены.
Связь ЛСК с файлом координат единичных векторов не формируется.

– Сохранить в файл. Позволяет записать текущие координаты единичных векторов в файл. После нажатия этой кнопки на экране появляется диалог, в котором нужно задать папку для размещения файла и его имя.

Файлы координат единичных векторов — текстовые. Вы можете просмотреть, отредактировать или создать такой файл с помощью любого текстового редактора.
Подробнее о файле координат единичных векторов...


Группа Вращение

Группа переключателей, позволяющая указать собственную ось ЛСК, вокруг которой ее требуется повернуть.

Чтобы повернуть ЛСК вокруг оси, активизируйте переключатель, соответствующий этой оси и введите значение угла поворота в поле Угол.

Фантом ЛСК в окне модели повернется.

Вы можете поворачивать ЛСК вокруг собственных осей мышью. Для этого «перетащите» характерную точку фантома, соответствующую плоскости, которая перпендикулярна нужной оси.

Ассоциативные связи осей ЛСК с направляющими объектами, препятствующие повороту, удаляются.


Поле Угол

Поле для ввода значения угла поворота ЛСК вокруг собственной оси.

Поле доступно, если в группе Вращение активен какой-либо переключатель.

Поле Угол обнуляется после каждого ввода, и новый угол поворота ЛСК отсчитывается от ее текущего положения.


Элемент управления Ось

Элемент управления, позволяющий задать ось вращения для элемента вращения или поверхности вращения.

Ось вращения может определяться автоматически. Для этого она должна находиться в том же эскизе, что и сечение и являться отрезком со стилем Осевая или объектом Осевая линия.

Чтобы сменить или задать ось, активизируйте переключатель Ось на Панели свойств или вызовите команду Ось из контекстного меню окна модели. Затем:

– Укажите в Дереве построения или в окне модели:

• прямолинейный объект — осью будет сам этот объект.

• поверхность вращения (кроме сферы) — осью будет ось вращения поверхности.

Название выбранного объекта появляется в поле Ось.

– Или постройте ось. Для запуска команды построения оси нажмите кнопку Ось через вершину по объекту на Панели специального управления.

После того как ось задана, в окне модели стрелкой показывается прямое направление вращения. Вращение может производиться в прямом направлении, в обратном, в двух или от средней плоскости. Для выбора направления используйте список Направление.


Координата B

Поле для ввода или задания счетчиком сферической координаты точки B.

Если точка связана с точечным объектом (на кнопке Объект при этом отображается «галочка»), то поле координаты недоступно для ввода.

При задании положения точки мышью координата определяется автоматически и заносится в поле.

Подробнее о построении точки по координатам на цилиндре и сфере...


Первая ось

Переключатель, позволяющий перейти к заданию параметров сетки по первой оси.

Подробнее о задании параметров сетки по первой оси...


Вторая ось

Переключатель, позволяющий перейти к заданию параметров сетки по второй оси.

Подробнее о задании параметров сетки по второй оси...


Массив для отчета

Переключатель, позволяющий перейти к указанию массива для создания отчета по массиву. Следует указывать такой массив, который содержит таблицу изменяемых переменных.

После активизации переключателя выберите нужный массив в Дереве построения или в окне модели.

Выбор объектов в окне модели
Выбор объектов в Дереве построения модели

Название указанного массива отображается в поле рядом с переключателем.


Поле Базовая зона

В этом поле отображается наименование разбиваемой зоны.Зона может быть указана в Дереве зон или в окне модели.


Положение основания треугольника

Поля координат центра основания треугольника, обозначающего базу.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Положение знака

Поля координат точки привязки рамки обозначения базы.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Объекты

В этом поле содержится название объекта, который выбран в качестве линии сгиба для построения сгиба.


Поле Ребра

В этом поле отображается количество ребер, указанных для построения сгиба по эскизу вдоль последовательности ребер.

Поле присутствует на Панели свойств, если в группе переключателей Способ активен переключатель Последовательность ребер.


Объекты

В этом поле содержится название грани, которая выбрана в качестве базовой для построения сгиба.


Группа переключателей Способ вставки

Позволяет указать способ вставки детали-заготовки в модель. Для выбора нужного способа активизируйте один из следующих переключателей.

– Вставка внешней ссылкой — деталь-заготовка не копируется в модель, а существует в ней в виде ссылки на файл-источник вставки. Изменения, произведенные в файле-источнике, передаются в деталь-заготовку после перестроения модели.

– Вставка без истории — деталь-заготовка копируется в модель и теряет связь с файлом-источником вставки. Редактирование файла-источника не влияет на деталь-заготовку, вставленную данным способом.


Группа Операции

Группа кнопок для выполнения операций над выбранным рядом полюсов сетки. Доступна, если один из рядов сетки является выделенным.

Кнопки Вставить перед выбранным рядом или Вставить после выбранного ряда позволяют добавить ряд полюсов сетки, расположенный в том же направлении, что и выбранный ряд.

Кнопка Удалить выбранный ряд позволяет удалить ряд полюсов сетки.


Команда Граница 1/2

Позволяет выбрать границу создаваемой или редактируемой поверхности соединения для того, чтобы задать ее параметры: указать составляющие ее ребра, поверхность сопряжения, условие сопряжения, натяжение и положение боковых ребер.

После указания ребер, составляющих границу, на Панели свойств появляются элементы управления параметрами соединения вдоль границы.

Попеременно вызывая команды Граница 1 и Граница 2 из контекстного меню, задайте параметры обеих границ поверхности. Все изменения отображаются на фантоме поверхности (он отображается, если указаны ребра, составляющие границы).

Смотрите также

Подробнее о построении поверхности соединения...


Переключатель Сменить направление

Позволяет сменить направление сопряжения вдоль текущей — первой или второй — границы на противоположное. При этом форма поверхности соединения вблизи границы меняется, а условие сопряжения остается прежним.

После активизации переключателя фантом поверхности на экране перестраивается.

Фантом отображается, если обе границы поверхности заданы.

Чтобы сменить направление сопряжения поверхности вблизи другой границы, активизируйте нужный переключатель в группе Выбор границы. Затем активизируйте переключатель Сменить направление.


Список Условие

Поверхность соединения сопрягается с соединяемыми гранями вдоль границ. По умолчанию используется условие По касательной. Значок условия сопряжения отображается на экране рядом с границей.

Чтобы задать другое условие сопряжения вдоль текущей — первой или второй — границы, выберите нужную строку из списка Условие. Фантом поверхности на экране перестраивается так, чтобы выбранное условие выполнялось.

Фантом отображается, если обе границы поверхности заданы.

Чтобы сменить условие сопряжение вдоль другой границы поверхности, активизируйте нужный переключатель в группе Выбор границы, а затем выберите условие из списка Условие.

Подробнее об условиях сопряжения поверхностей...


Поле Кривая границы

Границами поверхности соединения являются ребра соединяемых граней. Граница может представлять собой одно ребро или гладкую цепочку ребер одной грани.

В поле Кривая границы отображается наименование ребра (или количество ребер цепочки), представляющего текущую — первую или вторую — границу поверхности соединения. Граница подсвечивается в окне модели.

Вы можете включить в границу новые ребра или исключить имеющиеся — для этого указывайте нужные ребра в окне модели. Цепочку ребер следует указывать в порядке соединения.

Чтобы задать или отредактировать другую границу соединительной поверхности, активизируйте нужный переключатель в группе Выбор границы, а затем укажите ребра.


Поле Поверхность

Поверхность соединения сопрягается с соединяемыми гранями вдоль границ.

В поле Поверхность отображается название грани, с которой поверхность соединения сопрягается вдоль текущей — первой или второй — границы. Эта грань подсвечена в окне модели.

Если граница принадлежит одновременно двум граням, вы можете выбрать другую грань в качестве поверхности сопряжения. Для этого укажите нужную грань в окне модели.

Чтобы сменить поверхность сопряжения для другой границы соединительной поверхности, активизируйте нужный переключатель в группе Выбор границы, а затем укажите грань.


Группа переключателей Боковые ребра

Позволяет выбрать положение боковых ребер поверхности соединения по отношению к соединяемым граням. Активизируйте нужный переключатель.

Положение боковых ребер | Пример
Как продолжение исходных боковых ребер |
По нормали к границе |

При изменении положения боковых ребер меняется их форма вблизи текущей — первой или второй — границы поверхности, что отображается на фантоме поверхности в окне модели (фантом отображается, если обе границы поверхности заданы).

Если границы поверхности соединения перпендикулярны исходным боковым ребрам, то возможен только один вариант положения боковых ребер поверхности. Их форма в этом случае не зависит от того, какой из переключателей группы Боковые ребра активен.

Чтобы изменить форму боковых ребер поверхности вблизи другой границы, активизируйте нужный переключатель в группе Выбор границы. Затем выберите положение боковых ребер с помощью группы переключателей Боковые ребра.


Поле Натяжение,%

Поле для ввода или задания счетчиком значения натяжения поверхности вблизи текущей — первой или второй — границы.

Натяжение влияет на форму поверхности: чем значение натяжения больше, тем больше кривизна поверхности у границы.

Изменение натяжения отображается на фантоме поверхности в окне модели.

Натяжение можно также изменять с помощью характерной точки фантома.

Фантом отображается, если обе границы поверхности заданы.

Чтобы изменить натяжение поверхности вблизи другой границы, активизируйте нужный переключатель в группе Выбор границы и введите значение в поле Натяжение,%.

Если натяжение поверхности должно быть одинаковым на обеих границах, включите опцию Общее натяжение. После этого изменение натяжения на одной из границ будет автоматически передаваться на другую.


Группа переключателей Выбор границы

Позволяет выбрать границу создаваемой или редактируемой поверхности соединения для того, чтобы задать ее параметры: указать составляющие ее ребра, поверхность сопряжения, условие сопряжения, натяжение и положение боковых ребер.

После указания ребер, составляющих границу, на Панели свойств появляются элементы управления параметрами соединения вдоль границы.

Попеременно активизируя переключатели группы Выбор границы, задайте параметры обеих границ поверхности. Все изменения показываются на фантоме поверхности (он отображается, если указаны ребра, составляющие границы).

Смотрите также

Подробнее о построении поверхности соединения...


Опция Общее натяжение

Опция, включение которой устанавливает одинаковое значение натяжения поверхности соединения вблизи обеих границ.

После этого натяжение, заданное для одной из границ, автоматически применяется ко второй.

Чтобы вновь задавать натяжение порознь, отключите опцию.


Поле Тело или поверхность

Поле, в котором отображается наименование объекта (тела или поверхности), указанного для масштабирования.

Если в модели содержится одно тело (или одна поверхность), наименование этого тела (поверхности) отображается в поле автоматически после вызова команды.


Поле Центр

Поле, в котором отображается наименование системы координат, в которой производится изменение положения тела или поверхности.

Поле становится доступно после того, как выбрано тело или поверхность для изменения положения.

По умолчанию системой координат, в которой производится изменение положения объекта, является текущая система координат.

Чтобы выбрать другую систему координат, укажите ее в Дереве построения.

Если подходящей системы координат в модели нет, вы можете построить ЛСК, не выходя из процесса изменения положения тела или поверхности. Для этого нажмите кнопку Построение ЛСК на Панели специального управления.


Поле Тело или поверхность

Поле, в котором отображается наименование объекта (тела или поверхности), указанного для изменения положения.

Если в модели содержится одно тело (или одна поверхность), наименование этого тела (поверхности) отображается в поле автоматически после вызова команды.

Чтобы выбрать другое тело или поверхность, нажмите кнопку Указать заново на Панели специального управления. Подсветка с выбранного объекта будет снята, и вы сможете указать другой объект.


Группа переключателей Режим

Позволяет указать, следует ли удалить из модели или оставить в ней объект (тело или поверхность), служивший исходным для операции изменения положения.

Активизируйте нужный переключатель:

– Удалять исходные объекты — количество тел (поверхностей) в модели не изменяется, первоначальное тело (поверхность) не отображается в окне модели, а в Дереве построения отображается как подчиненный объект операции Изменение положения;

– Оставлять исходные объекты — количество тел (поверхностей) в модели увеличивается на единицу, первоначальное тело (поверхность) отображается в окне и в Дереве построения на своем прежнем месте.

В результате операции изменения положения в модели создается новый объект — тело или поверхность. Все объекты, производные от первоначального («старого») тела или поверхности остаются связаны с ним.

Если первоначальный объект участвовал в сопряжениях, то в случае его удаления они отмечаются как ошибочные. Для исправления сопряжений их следует отредактировать, повторно указав сопрягаемые объекты. Если же объект не удаляется в результате операции изменения положения, ошибки в сопряжениях не возникают.


Выбор результата операции

Управление результатом операции при добавлении материала к модели (например, при приклеивании формообразующих элементов) производится на вкладке Результат операции Панели свойств.

Чтобы выбрать результат операции, активизируйте в одноименной группе нужный переключатель.

Активизируйте переключатель Автообъединение, чтобы результат операции был определен автоматически. При этом построение выполняется следующим образом:

– если создаваемый элемент не пересекается и не имеет общих поверхностей ни с одним из имеющихся тел, то

• строится новое тело,

• на Панели свойств автоматически активизируется переключатель Новое тело,

– если создаваемый элемент пересекается или имеет общую поверхность с какими-либо имеющимися телами, то

• происходит объединение элемента с этими телами,

• на Панели свойств автоматически активизируется переключатель Объединение, а Список тел наполняется названиями тел, с которыми имеется пересечение или общая поверхность.

Активизируйте переключатель Новое тело, чтобы создаваемый элемент представлял собой отдельное тело вне зависимости от того, пересекается он с другими телами или нет.

Активизируйте переключатель Объединение, чтобы произвольно выбрать тела, с которыми будет объединен создаваемый элемент. Для указания тел служит группа переключателей Область применения.

При построении нового формообразующего элемента результат операции определяется автоматически (т.е. по умолчанию в группе Результат операции активен переключатель Автообъединение).

Смотрите также

Область применения «Тела»


Группа Номер границы

Группа переключателей для выбора границы создаваемой поверхности, вдоль которой эта поверхность будет сопряжена с другой, уже существующей в модели поверхностью.

Среди переключателей группы доступны лишь те, которые соответствуют границам, вдоль которых возможно сопряжение; в окне модели рядом с этими границами отображаются их номера. Чтобы сопряжение вдоль границы было возможно, эта граница должна представлять собой явно указанную кривую (т.е. не быть точкой и не определяться автоматически).

Чтобы выбрать границу, активизируйте переключатель с нужным номером. Граница будет подсвечена в окне модели.

Затем укажите в окне модели поверхность для сопряжения и выберите условие сопряжения.

Изменение условия сопряжения поверхности вдоль какой-либо границы отображается на фантоме поверхности в окне модели.

Подробнее о сопряжении поверхности...


Угол наклона фигурной скобки

Поле для ввода угла наклона фигурной скобки относительно оси ОХ системы координат вида.

Поле доступно для варианта произвольного расположения скобки и не доступно для вариантов вертикального и горизонтального ее расположения.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Первая точка привязки

Поля координат первой точки привязки (т1) фигурной скобки.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Вторая точка привязки

Поля координат второй точки привязки (т2) фигурной скобки.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Длина фигурной скобки

Поле длины создаваемой фигурной скобки.

Длина фигурной скобки равна длине отрезка, соединяющего первую и вторую точки привязки.

При указании точек привязки мышью длина определяется автоматически и заносится в это поле.

Возможен также ввод значения с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.

Минимальная длина фигурной скобки зависит от радиуса закругления.


Точка начала полки линии-выноски

Поля координат точки начала полки линии-выноски (т3).

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Тип ориентации фигурной скобки

Группа переключателей, позволяющая выбрать тип ориентации фигурной скобки.

Доступны следующие типы ориентации:

Произвольно

Горизонтально

Вертикально

По умолчанию строится фигурная скобка произвольной ориентации. При этом расположение скобки в документе определяется указанием первой и второй точек привязки или первой точки привязки, длины и угла наклона скобки.

При выборе горизонтальной или вертикальной ориентации скобка строится параллельно оси ОX или ОY системы координат вида. Расположение скобки в документе определяется указанием первой и второй точек привязки или первой точки привязки и длины скобки. Поле Угол на Панели свойств в этом случае недоступно.


Количество участков кривой

Поле, в котором можно ввести или выбрать из списка количество частей, на которые требуется разбить кривую.


Начальная точка разбиения

Поля координат начальной точки для разбиения замкнутой кривой на несколько частей.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Точка разбиения

Поля координат точки, в которой требуется разбить кривую.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Вторая точка разбиения

Поля координат второй точки, в которой требуется разбить замкнутую кривую.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Угол направления разрыва

Поле для ввода или выбора угла между осью Х вида и направлением сдвига, соответствующим выделенному в списке разрыву.

Обратите внимание на то, что направления сдвига одного и того же вида могут быть только параллельны или перпендикулярны друг другу. Например, в виде создан разрыв, направление сдвига которого расположено под углом 30° к оси Х. Впоследствии в этом виде можно будет создать разрывы, направления сдвига которых располагаются либо под таким же углом, либо под углом 120° к оси Х.


Зазор между линиями разрыва

Поле для ввода или выбора расстояния, на котором будут располагаться друг от друга видимые части изображения после создания разрыва.

Минимальное значение зазора — 1 мм.

Задание параметров разрыва, ограниченного линиями с изломом или волнистыми линиями


Панель Разрывы

Содержит список разрывов в виде. Выделенный в списке разрыв считается текущим. Он доступен для редактирования. Его параметры отображаются на Панели свойств, а в окне чертежа на границах разрыва показываются характерные точки.

Кнопка Добавить позволяет создать в виде новый разрыв. После ее нажатия на экране появляется новая пара границ разрыва, а в списке появляется строка Разрыв N.

Кнопка Удалить позволяет удалить из вида разрыв. После ее нажатия текущий разрыв удаляется.


Амплитуда, max

Поле для ввода или задания счетчиком амплитуды (в миллиметрах) — величины отклонения линии с изломом или волнистой от средней линии.

Для волнистой линии заданное значение определяет максимально допустимую амплитуду.

Задание параметров разрыва, ограниченного линиями с изломом или волнистыми линиями


Амплитуда,%

Поле для ввода или задания счетчиком значения амплитуды волнистой линии (в процентах от длины разрыва).

Задание параметров разрыва, ограниченного линиями с изломом или волнистыми линиями


Тип линии

Список, позволяющий выбрать тип линий, которыми будут ограничены видимые части изображения.


Опция Разбить таблицу

Опция позволяет представить перечень исполнений модели в виде нескольких таблиц. После включения опции становятся доступными элементы настройки формирования и размещения таблиц на листе.

Подробно о таблице исполнений...


Группа элементов Разбить таблицу (для таблицы отчета по массиву)

Группа элементов Разбить таблицу
(для таблицы отчета по массиву)

Группа элементов позволяет представить данные о параметрах экземпляров массива (например, координаты точек, задающих позиции экземпляров, имена переменных), содержащиеся в таблице изменяемых переменных, в виде нескольких таблиц отчета.

Включите опцию Разбить таблицу для получения нескольких таблиц отчета.

После включения опции становится доступным поле Строк в таблице. Это поле позволяет задать максимальное количество строк, входящих в каждую таблицу. Вы можете ввести значение с клавиатуры или задать с помощью счетчика.

Подробнее об отчете по массиву с таблицей изменяемых переменных...


Амплитуда изломов

Поле Амплитуда служит для ввода или задания счетчиком величины амплитуды изломов.

Амплитуда изломов — расстояние между линией и максимально удаленной от нее точкой излома (см. рисунок).

Тип 1 | Тип 2
где A, мм — амплитуда излома, L, мм — ширина излома.

При изменении значения в поле Амплитуда прямо пропорционально изменяется ширина излома; после изменения амплитуды обозначение линии с изломами перестраивается.

Умолчательное значение амплитуды задается в диалоге настройки отрисовки обозначения.

Если умолчательное значение амплитуды было изменено на Панели свойств, то дальнейшие изменения этого значения возможны только с Панели свойств.


Угол наклона линии с изломами

Поле для ввода угла наклона линии с изломами к оси ОХ текущей системы координат.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Количество изломов

Поле для ввода количества изломов линии.

Введите целое число или задайте его счетчиком.

Минимальное количество изломов — 1.

Умолчательное значение количества изломов задается в диалоге настройки отрисовки обозначения.


Конечная точка линии с изломами

Поля координат конечной точки (т2) линии с изломами.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Начальная точка линии с изломами

Поля координат начальной точки (т1) линии с изломами.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Выступ линии с изломами

Выступ
линии с изломами

Поле для ввода величины выступа за начальную точку и конечную точки линии с изломами.

Введите нужное значение или задайте его счетчиком.

Выступ строится одинаковым с обеих сторон линии (см. рисунок).

Ввод нуля означает отсутствие выступа.

Смещение изломов не влияет на величину выступа.

Умолчательная величина выступа задается в диалоге настройки отрисовки обозначения.


Длина линии с изломами

Поле длины создаваемой линии с изломами. Длиной линии является расстояние между начальной (т1) и конечной точками (т2) обозначения.

При указании конечной и начальной точек мышью длина определяется автоматически и заносится в это поле.

Возможен также ввод значения с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Смещение изломов

Поле для ввода величины смещения изломов к начальной или конечной точке линии (см. рисунок).

Смещение равно отношению расстояния, на которое перемещены изломы относительно начального положения (где они расположены симметрично относительно точек т1 и т2), к величине промежутка между изломами. Значение вводится в процентах.

1. Чтобы изломы были расположены симметрично относительно начальной и конечной точек (т1 и т2), введите ноль (рис. а).

а)

2. Чтобы переместить изломы к начальной или конечной точке линии, введите или задайте счетчиком необходимое значение, учитывая следующие особенности.

– Направление смещения определяется знаком, вводимым перед его величиной.

Знак «плюс» или отсутствие знака — смещение в сторону конечной точки (т2) (рис. б, в),

Знак «минус» — смещение в сторону начальной точки (т1).

б)

– При смещении величины промежутков между изломами сохраняются.

где

a, мм — промежуток между изломами;

b, мм — величина, на которую перемещены изломы;

c, % — смещение изломов.

в)

– Максимальное смещение изломов — 100 % (рис. г)

г)

Величина выступов за начальную и конечную точки (т1 и т2) при смещении не изменяется.


Поле Радиус

Поле для ввода или задания счетчиком радиуса скругления ломаной или контура в выбранной вершине.

Радиусы скруглений можно также задать в таблице на Панели свойств или в окне модели с помощью характерных точек.


Тип излома

Группа переключателей Тип излома позволяет выбрать вариант отрисовки излома: с двумя или тремя вершинами.

Тип 1

Тип 2

Чтобы изменить тип, активизируйте переключатель Тип 1 или Тип 2.

При изменении типа величина промежутков между изломами не меняется.

Умолчательный выбор типа излома задается в диалоге настройки отрисовки обозначения.


Панель Список компонентов

Панель, содержащая перечень компонентов для вычитания или объединения.

Чтобы добавить компонент в перечень, укажите его в Дереве построения или в окне модели.

Чтобы удалить компонент из перечня, выделите его и нажмите кнопку Удалить, расположенную на панели Список компонентов.


Поле Коэффициент масштабирования

Поле коэффициента масштабирования полости.

Вы можете ввести нужное значение с клавиатуры или выбрать из списка.

Можно также установить курсор в поле Коэффициент масштабирования и листать список, нажимая клавиши <↓> и <↑>.

Для увеличения размеров полости по сравнению с размерами вычитаемой детали значение коэффициента должно быть положительным, для уменьшения — отрицательным. Если значение нулевое, размер полости будет точно соответствовать размеру детали.

По умолчанию центром масштабирования при создании полости является центр габаритного параллелепипеда вычитаемой детали.


Поле Объект

Поле, содержащее наименование объекта, в центре которого проставляется точка.

Подробнее о способе построения...


Точка вставки обозначения центра

Поля координат точки вставки обозначения центра.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Угол наклона обозначения центра

Поле для ввода угла поворота обозначения центра относительно начала текущей системы координат.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Точка

Поле для ввода длины штрихов, образующих перекрестие в центре объекта. Данная настройка действует при создании обозначения центра в виде «крестика». Во всех остальных случаях длина центральных штрихов определяется системой автоматически.


Способ обозначения центра

Переключатель, позволяющий выбрать способ обозначения центра: две оси, одна (горизонтальная) ось или условное обозначение.


Панель Центр масс

Панель, содержащая таблицу с координатами центра масс модели. Позволяет ввести отличные от расчетных координаты центра масс модели.

Доступна, если включена опция Центр масс.

– Если производится настройка свойств модели, то координаты центра масс сохраняются в файле модели. При вставке модели в качестве компонента в другую модель эти координаты передаются в нее и используются при расчете ее массо-центровочных характеристик.

– Если производится настройка свойств компонента модели, то координаты центра масс компонента сохраняются в файле модели и используются при расчете ее массо-центровочных характеристик. Файл компонента остается без изменений.

Единицы измерения длины можно настроить в диалоге настройки единиц задания МЦХ.


Угол фаски

Поле, в котором можно ввести или выбрать из списка значение угла фаски.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Поле Угол фаски

Поле значения угла фаски.

Вы можете ввести значение вручную или установить с помощью счетчика.

Изменение угла немедленно отображается на фантоме фаски в окне детали.


Переключатель Способ построения фаски

Переключатель, позволяющий выбрать способ построения фаски: по стороне и углу или по двум сторонам.


Длина фаски на первом объекте

Поле, в котором можно ввести или выбрать из списка длину фаски на первом объекте.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Длина фаски на втором объекте

Поле, в котором можно ввести или выбрать из списка длину фаски на втором объекте.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Поле Длина первой стороны

Поле длины первой стороны фаски.

Вы можете ввести значение вручную или установить с помощью счетчика.

Изменение длины немедленно отображается на фантоме фаски в окне детали.


Поле Длина второй стороны

Поле длины второй стороны фаски.

Вы можете ввести значение вручную или установить с помощью счетчика.

Изменение длины немедленно отображается на фантоме фаски в окне детали.


Длина фаски на первом сегменте

Поле, в котором можно ввести или выбрать из списка длину фаски на первом сегменте контура.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Длина фаски на втором сегменте

Поле, в котором можно ввести или выбрать из списка длину фаски на втором сегменте контура.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Тип выноски

Список, позволяющий выбрать тип выноски для обозначения изменения.


Тип

Список, позволяющий выбрать тип знака для обозначения изменения.


Список СК текущего документа

Позволяет при создании или редактировании копии геометрических объектов сделать текущей нужную систему координат текущей модели.

Слева от списка систем координат находится кнопка СК текущего документа. Нажав эту кнопку, вы можете выбрать нужную систему координат в Дереве построения или в окне текущей модели.

Если в копию входят объекты этой же модели (при контекстном копировании), то объекты копии располагаются относительно выбранной системы координат.

Если в копию входят объекты другой модели (при копировании из файла), то объекты копии располагаются таким образом, что система координат модели-источника совмещается с выбранной системой координат текущей модели.

Элементы выбора системы координат текущей модели доступны, если эта модель содержит локальные системы координат.


Опция Новая сетка

Опция позволяет изменить количество полюсов сетки по направлениям U и V и перестроить сетку в соответствии с новыми значениями. После включения опции на Панели свойств появляются дополнительные элементы управления.


Поле Опорная точка

Позволяет задать координаты точки вставки компонента в текущей системе координат модели. Присутствует на Панели свойств, если для размещения компонента выбран способ По координатам.

Для задания положения точки вставки введите нужные координаты в поле Опорная точка. После ввода трех координат положение точки вставки фиксируется. При этом включается опция, расположенная рядом с полем. Включенному состоянию опции (т.е. зафиксированному положению точки вставки) соответствует значок «крестик», а отключенному — значок «галочка».

При отключенной опции вы можете указать положение точки вставки вручную. После ручного указания также выполняется автоматическая фиксация положения точки, т.е. включение опции.

При необходимости вы можете отключить фиксацию или снова включить ее.

Обратите внимание на то, что координаты в поле Опорная точка могут измениться в следующих случаях:

– при ручном перемещении точки вставки в окне модели с помощью элемента базирования,

– при выборе другой системы координат текущей модели,

– при создании точки с помощью кнопки Построение точки на Панели специального управления.


Опция Проверка самопересечений

Позволяет включить или отключить проверку поверхности на предмет наличия самопересечений.

Опция Проверка самопересечений присутствует на Панели свойств при создании или редактировании следующих поверхностей:

– линейчатой,

– по сети точек,

– по пласту точек,

– по сети кривых,

– заплатка,

– поверхность соединения.

Для многогранной поверхности по пласту точек опция Проверка самопересечений недоступна.

Если проверка включена, то она производится при завершении построения или редактирования поверхности (т.е. при нажатии кнопки Создать объект на Панели специального управления). В случае обнаружения самопересечений поверхность отмечается в Дереве построения как ошибочная — восклицательным знаком в красном кружке.


Команда Проверить пересечения

Позволяет проверить пересечения (касания) перечисленных в списке компонентов друг с другом.

После вызова команды в списке Пересечения появится список обнаруженных пересечений (касаний).


Панель Список объектов

Панель, содержащая перечень тел или компонентов, которые требуется проверить на пересечения (касания).

– Если для проверки выбраны компоненты, то будут найдены пересечения между телами, принадлежащими этим компонентам (но не между телами, принадлежащими одному компоненту). Указание компонентов производится в Дереве построения.

– Если для проверки выбраны тела, то будут найдены пересечения между ними. Указание тел возможно как в Дереве построения, так и в окне модели.

Чтобы добавить объект в перечень, укажите его в Дереве построения или в окне модели.

Чтобы удалить объект из перечня, выделите его и нажмите кнопку Удалить, расположенную на панели Список объектов. Можно также повторно указать объект в Дереве построения или в окне модели.

Чтобы изменить порядок следования объектов в списке, используйте кнопки Переместить вниз и Переместить вверх.

Порядок перечисления объектов задает порядок поиска пересечений: сначала будут найдены все пересечения первого объекта, затем — второго и так далее.


Опция Считать касания пересечениями

Опция, включение которой означает, что в списке обнаруженных пересечений будут также перечислены касания тел. При выключенной опции касания игнорируются.


Панель Обнаруженные пересечения

Панель, содержащая порядковые номера пересечений и названия пересекающихся (касающихся) компонентов или тел.

Порядок поиска и отображения пересечений соответствует порядку объектов в списке: сначала названы все пересечения первого объекта, затем — второго и так далее.


Кнопка Пересчитать размеры

Находится на вкладке Файл-источник Панели свойств при вставке или настройке свойств компонента (вне режима пересчета).

Служит для включения и отключения пересчета размеров компонента с учетом назначенных допусков.

Компонент имеет три системных пересчета размеров: в середину поля допуска, по верхнему пределу и по нижнему пределу. Кроме того, компонент может иметь пользовательские пересчеты, созданные при его редактировании. Подробнее...

Управление размерами компонента возможно как при добавлении компонента в модель, так и после:

– пересчет размеров компонента при добавлении в модель;

– пересчет размеров компонента в модели;

– возврат компоненту номинальных размеров.


Список СК источника

Позволяет выбрать систему координат модели — источника объектов, входящих в копию геометрических объектов.

Слева от списка систем координат находится кнопка СК источника. Нажав эту кнопку, вы можете выбрать нужную систему координат в Окне модели-источника (система координат указывается в Дереве построения или в самом окне).

При создании копии копируемые объекты размещаются таким образом, что выбранная система координат модели-источника совмещается с текущей системой координат модели, в которой создается копия.

Элементы выбора системы координат источника отображаются на Панели свойств при способе копирования Из файла. Они доступны, если модель-источник содержит локальные системы координат.


Опция Ссылки в основной надписи

Опция позволяет заменить содержимое ячеек Материал и Масса основной надписи чертежа текстовой строкой, обозначающей ссылку на таблицу исполнений (по умолчанию текстовая строка имеет вид См. табл.). Замена происходит в том случае, если таблица исполнений содержит столбцы со свойствами Материал и Масса соответственно. Если столбец с каким-либо из этих свойств отсутствует в таблице, то содержимое соответствующей ячейки основной надписи не заменяется текстом ссылки.

Опция доступна только при создании или редактировании ассоциативной таблицы.

Смотрите также

Связь основной надписи чертежа с ассоциативной таблицей исполнений


Опция Добавить номер таблицы

Опция позволяет добавить номер таблицы исполнений, размещенной в чертеже, к тексту ссылки, отображаемой в ячейках Материал и Масса основной надписи чертежа.

Номер добавляется в том случае, если в списке Нумерация выбрана группа нумерации.

Подробнее об автоматической нумерации объектов...

Опция доступна только при создании или редактировании ассоциативной таблицы.

Смотрите также

Связь основной надписи чертежа с ассоциативной таблицей исполнений


Ассоциативный отчет

Включите опцию Ассоциативный отчет, чтобы создать в документе ассоциативный отчет.

Если опция выключена, то создается отчет без ассоциативной связи с документом-источником.

Подробнее об ассоциативных отчетах...


Опция Ассоциативный отчет

Включите опцию Ассоциативный отчет, чтобы создать в документе ассоциативный отчет по массиву.

Если опция выключена, то создается отчет без ассоциативной связи с документом-источником (моделью).

Опция Ассоциативный отчет присутствует на Панели свойств во время создания отчета при условии, что документ-источник сохранен в файл на диске. Во время редактирования отчета опция отсутствует на Панели свойств.


Опция Ассоциативная таблица

Опция позволяет определить, будет ли создаваемая таблица исполнений модели ассоциативно связана с документом — источником данных.

При включенной опции таблица связана с источником, при отключенной опции — не связана.

Если таблица исполнений разделена на несколько таблиц, то при включенной опции все полученные таблицы являются единым объектом, ассоциативно связанным с источником, а при отключенной опции каждая таблица — отдельный объект.


Подобрать параметры шрифта

Опция позволяет автоматически подобрать такие параметры шрифта, при которых тексты ссылок на таблицу исполнений в основной надписи чертежа полностью умещаются в содержащих их ячейках (Материал и Масса).

При отключенной опции шрифт в ссылках не меняется, из-за чего они могут выйти за пределы отведенных для них ячеек.

Опция доступна только при создании или редактировании ассоциативной таблицы.

Смотрите также

Связь основной надписи чертежа с ассоциативной таблицей исполнений


Данные в виде ссылок

При включенной опции Данные в виде ссылок содержимое ячеек отчета представлено в виде ссылок на значения свойств объектов, по которым он создается.

Если опция выключена, то значения свойств в ячейках отображаются обычным текстом.

Подробнее о работе с данными в виде ссылок...


Опция Все

Опция, позволяющая оставить в модели все части тела (или тел), образовавшиеся в результате операции.

Чтобы исключить какие-либо части, выключите опцию Все. После этого станет доступна панель Список частей. Она позволяет указать для каждой части тела, требуется ли ее оставить или исключить.

Исключенные части тела остаются в модели, но не учитываются. При необходимости вы можете изменить набор оставленных частей.

Подробнее о процессе изменения набора частей...


Выбор из Справочника

Команда позволяет выбрать из внешнего Справочника (Классификатор ЕСКД) обозначение, наименование и цвет детали. Справочник должен быть подключен к КОМПАС-3D.


Тип объектов

Группа переключателей, позволяющая выбрать тип копируемых объектов при построении массивов.

Переключатель Автоопределение по указанию активен по умолчанию. Это означает, что тип объекта будет определен системой автоматически после указания первого объекта — в группе активизируется переключатель, соответствующий типу указанного объекта. Указанный объект выделяется цветом. На панели Список объектов появляется его название, а на экране — фантом базовой точки копируемого объекта в виде трех ортогональных отрезков с общей вершиной. Повторное указание объекта отменяет его выбор. Далее вы можете указать в качестве копируемых другие объекты данного типа.

Чтобы выбрать для копирования объекты определенного типа, в группе Тип активизируйте переключатель этого типа:

– Операции;

– Тела или поверхности;

– Кривые или точки;

– Произвольные — данный переключатель позволяет создать массив произвольных объектов; он присутствует в группе Тип при создании всех массивов, кроме зеркального и массива по образцу;

– Компоненты.

После активизации переключателя укажите в Дереве построения или в окне модели объекты выбранного типа.

Обратите внимание на то, что смена типа копируемого объекта возможна только при создании массива. При редактировании массива изменить тип копируемого объекта нельзя.

Подробнее о выборе копируемых объектов...


Положение

Опция, позволяющая зафиксировать положение размера относительно произвольного объекта — объекта фиксации.

Опция доступна при выполнении следующих условий:

– автосоздание объекта отключено,

– объект для простановки размера задан и представляет собой грань тела или поверхности.

После включения опции укажите нужный объект в Дереве построения или в окне модели. Размер будет расположен в плоскости, проходящей через выбранный объект.


Элемент управления Поверхность

Кнопка позволяет указать поверхность, на которой будут лежать точки создаваемой группы.

В качестве поверхности могу быть выбраны грани поверхностей и тел.

Наименование указанного объекта появится в поле.

Выбор объектов в окне модели

Выбор объектов в Дереве построения


Первая точка окружности

Поля координат первой точки создаваемой окружности.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Вторая точка окружности

Поля координат второй точки создаваемой окружности.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Третья точка окружности

Поля координат третьей точки создаваемой окружности.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Центр окружности или дуги

Поля координат центра создаваемой окружности или дуги.

При указании центра мышью координаты точки определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Диаметр окружности

Поле диаметра создаваемой окружности.

При построении окружности по трем точкам и окружности, касательной к трем кривым, поле является справочным и ввод значений в него невозможен.

При построении других окружностей вы можете редактировать значение в поле Диаметр.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Точка на окружности

Поля координат произвольной точки создаваемой окружности.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Радиус окружности

Поле радиуса создаваемой окружности.

При построении окружности по трем точкам и окружности, касательной к трем кривым, поле является справочным и ввод значений в него невозможен.

При построении других окружностей вы можете редактировать значение в поле Радиус.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Центр оси

Поля координат центра создаваемой круговой координационной оси.

При указании центра оси мышью координаты точки определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Диаметр оси

Поле диаметра создаваемой круговой координационной оси.

При построении оси мышью диаметр определяется автоматически после указания точек тС и т и заносится в это поле.

Возможен также ввод значения с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Точка размещения марки

Поля координат точки размещения марки круговой координационной оси.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Радиус оси

Поле радиуса создаваемой круговой координационной оси.

При построении оси мышью радиус определяется автоматически после указания точек тС и т и заносится в это поле.

Возможен также ввод значения с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Элемент управления Ось массива(по концентрической сетке)

Элемент управления Ось массива
(по концентрической сетке)

Элемент управления, позволяющий задать ось массива по концентрической сетке. В качестве оси массива можно использовать любой прямолинейный объект или поверхность вращения (кроме сферы).

Чтобы выбрать ось, активизируйте переключатель Ось и укажите нужный объект в окне модели. Конструктивные оси можно также указывать в Дереве построения.

Название указанного объекта появится в поле рядом с переключателем.


Базовый экземпляр

Опция, управляющая положением экземпляров массива относительно базового экземпляра.

По умолчанию номер базового экземпляра — 1,1. Он соответствует копируемому объекту (или группе объектов). Остальные экземпляры массива являются копиями базового экземпляра.

О номерах экземпляров массива...

– Включение опции позволяет изменить положение экземпляров массива относительно базового — на Панели свойств появляются поля Номер 1 и Номер 2. Введите в эти поля нужные номера базового экземпляра в кольцевом и радиальном направлениях или задайте их счетчиком. Фантом массива перестраивается — экземпляры массива располагаются так, чтобы номер базового экземпляра в массиве соответствовал заданному.

– Отключение опции позволяет вернуть базовому экземпляру умолчательный номер — 1,1. Фантом массива перестраивается — экземпляры располагаются так, чтобы номер базового экземпляра стал умолчательным.

Пример...


Настройка размещения экземпляров массивапо концентрической сетке

Настройка размещения экземпляров массива
по концентрической сетке

Переключатели группы Выбор направления обеспечивают настройку размещения экземпляров массива.

Переключатель В кольцевом направлении делает доступными элементы управления, обеспечивающие настройку расположения экземпляров массива в кольцевом направлении.

Переключатель В радиальном направлении делает доступными элементы управления, обеспечивающие настройку расположения экземпляров массива в радиальном направлении.

Подробнее о задании параметров сетки в кольцевом направлении...

Подробнее о задании параметров сетки в радиальном направлении...


Поле Количество в радиальном направлении

Поле значения количества экземпляров массива в радиальном направлении.

Вы можете ввести значение вручную или установить с помощью счетчика.

Изменение количества немедленно отображается на фантоме массива в окне модели.


Поле Количество в кольцевом направлении

Поле значения количества экземпляров массива в кольцевом направлении.

Вы можете ввести значение вручную или установить с помощью счетчика.

Изменение количества немедленно отображается на фантоме массива в окне модели.


Направление копирования вдоль радиальной линии

Группа переключателей, управляющая направлением копирования вдоль радиальной линии.

При выборе Прямого направления добавление экземпляров будет производиться относительно копируемых объектов в направлении от центра сетки, при выборе Обратного направления — к центру.

Массив объектов по концентрической сетке...


Направление копирования вдоль кольцевой линии

Группа переключателей, управляющая направлением копирования вдоль кольцевой линии сетки.

Начальный луч сетки проводится через базовую точку копирования. Затем добавляются остальные лучи.

Подробнее о схеме построения массива...

Если направление добавления лучей, предложенное системой, требуется изменить, активизируйте другой переключатель в группе Направление. Направление, соответствующее активному в данный момент переключателю, показано на экране стрелками.

Результат построения массива не зависит от состояния группы Направление в следующих случаях:

– Значение в поле Шаг 2 равно 360 и активен переключатель Шаг между крайними экземплярами в группе Режим 2.

– Частное от деления 360 на значение поля Шаг 2, — целое число; это число меньше, чем значение поля N2.


Список Схема(массив по концентрической сетке)

Список Схема
(массив по концентрической сетке)

Список вариантов размещения копий внутри концентрической сетки:

Стандартная схема;

Шахматный порядок - сдвиг вдоль кольцевого направления;

Шахматный порядок - сдвиг вдоль радиального направления.

По умолчанию на фантоме отображается расположение экземпляров по стандартной схеме. При выборе другой строки списка в окне модели отображается новое расположение экземпляров.

Подробнее о схемах размещения...


Поле Шаг в радиальном направлении

Поле значения шага экземпляров массива в радиальном направлении.

Вы можете ввести значение вручную или установить с помощью счетчика.

Изменение шага немедленно отображается на фантоме массива в окне модели.


Поле Шаг в кольцевом направлении

Поле значения шага экземпляров массива в кольцевом направлении.

Вы можете ввести значение вручную или установить с помощью счетчика.

Изменение шага немедленно отображается на фантоме массива в окне модели.


Поле Шаг по оси

Используется для сдвига экземпляров вдоль оси массива.

В поле Шаг по оси введите вручную или установите с помощью счетчика положительное или отрицательное значение шага.

При отличном от нуля значении шага сдвиг экземпляров немедленно отображается на фантоме массива в окне модели.

Подробнее о задании шага по оси...


Опция Замкнутая поверхность

Опция, включение которой позволяет добавить к поверхности замыкающие грани.

Эта опция доступна, если сечение поверхности замкнуто. При ее включении к поверхностям добавляются «торцевые» грани. Так, к поверхностям выдавливания, вращения и кинематической добавляются грани, соответствующие начальному и конечному положению сечения, а к поверхности по сечениям — грани, совпадающие по форме с начальным и конечным сечениями. Если эти сечения представляют собой точки, замыкающие грани поверхности по сечениям не создаются.


Угол поворота

Поле, в котором можно ввести угол поворота объектов, вставляемых в активный документ.


Положение базовой точки

Поля координат базовой точки вставляемого или копируемого объекта.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Масштаб

Поле, в котором можно ввести коэффициент масштабирования объектов, вставляемых в активный документ.


Угол (заливки)

Угол
(заливки)

Элемент управления для задания угла поворота заливки относительно начальной точки внутри области.

Введите или выберите значение из списка ранее введенных, а также часто используемых углов.

При изменении угла заливки габаритный прямоугольник также повернется на заданный угол. (см. рис.). Начальная точка, оставаясь на прежнем месте внутри области, может изменить свое положение относительно сторон габаритного прямоугольника. Величина сдвига будет вычислена автоматически и внесена в поля Сдвиг на Панели свойств.

Пример квадратной заливки с углом заливки: а) 0°, б) 40°
а) | б)

Для линейной заливки в поле Угол задается угол изменения направления перехода цвета.

Элемент управления Угол недоступен для радиальной заливки.


Версия оптимизации

Список, из которого можно выбрать вариант оптимизации построения кинематического элемента.

Смена варианта оптимизации может изменить внешний вид кинематического элемента, если траектория имеет сложную форму (например, спираль с переменным шагом).

В случае простой траектории все варианты оптимизации дают одинаковый результат.


Компоненты

Переключатель, позволяющий перейти к указанию компонентов для копирования.

После активизации переключателя выберите нужные компоненты в Дереве построения или в окне модели.

Названия указанных компонентов отображаются в Списке компонентов.


Переключатель Звуковой сигнал при столкновении

Переключатель, управляющий подачей звукового сигнала при столкновении компонентов.


Переключатель Компоненты

Переключатель, позволяющий перейти к указанию компонентов для контроля столкновений.

После активизации переключателя выберите нужные компоненты в Дереве построения или в окне модели.

Названия указанных компонентов отображаются в Списке компонентов.


Переключатель Подсветка граней при столкновении

Переключатель, управляющий подсветкой граней, соприкоснувшихся при столкновении компонентов.


Панель Список компонентов

Панель, содержащая перечень компонентов для контроля столкновений.

Чтобы добавить компонент в перечень, активизируйте соответствующий переключатель и укажите нужный компонент в Дереве построения или в окне модели.

Чтобы удалить компонент из перечня, выделите его и нажмите кнопку Удалить, расположенную на панели Список компонентов.


Переключатель Контролировать столкновения

Переключатель, позволяющий выбрать компоненты для контроля столкновения.

Чтобы контроль столкновений осуществлялся только для перемещаемого компонента, активизируйте переключатель Только передвигаемый компонент в группе Контролировать столкновения. Если активен переключатель Все компоненты, то производится контроль столкновений для любого из одновременно перемещаемых компонентов. Одновременное перемещение компонентов возможно, если они связаны сопряжениями.


Переключатель Останавливать при столкновении

Переключатель, управляющий остановкой перемещаемого компонента при его столкновении с другим.


Список компонентов

Панель, содержащая перечень компонентов для копирования.

Чтобы добавить компонент в перечень, активизируйте соответствующий переключатель и укажите нужный компонент в Дереве построения или в окне модели.

Чтобы удалить компонент из перечня, выделите его и нажмите кнопку Удалить, расположенную на панели Список компонентов.


Выбор компонентов для отражения

Переключатель Компоненты позволяет выбрать компоненты, которые являются исходными при зеркальном отражении или симметричной вставке компонентов.

Компоненты выбираются в Дереве построения или в окне модели указанием самих компонентов или принадлежащих им объектов.

Выбранные компоненты выделяются цветом, их перечень отображается на панели Список объектов. В окне модели появляются фантомы добавляемых компонентов.

Если исходный компонент в свою очередь содержит компоненты, то построение выполняется для всех этих компонентов.


Панель Список объектов

Панель служит для формирования списка компонентов, которые являются исходными при зеркальном отражении или симметричной вставке компонентов.

По умолчанию список пуст. После указания компонентов в Дереве построения или в окне модели они появляются в списке. Подробнее о выборе компонентов...

Компоненты, входящие в состав выбранного компонента, не отображаются в списке, однако построение выполняется для всех этих компонентов.

Если требуется удалить объект из списка, выделите его на панели Список объектов и нажмите кнопку Удалить, расположенную в верхней части панели. Исключение компонента из списка происходит и в том случае, если вы повторно укажете его в Дереве построения или в окне модели.


Выбор плоскости симметрии

Переключатель Плоскость позволяет выбрать плоский объект текущей модели, используемый в качестве плоскости симметрии при зеркальном отражении или симметричной вставке компонентов. Таким объектом может быть плоская грань, координатная или вспомогательная плоскость, эскиз.

Объект выбирается в Дереве построения или в окне модели. Выбранный объект подсвечивается, а его наименование отображается в поле рядом с переключателем.


Группа переключателей Высота(способ определения)

Группа переключателей Высота
(способ определения)

Группа переключателей, позволяющая указать способ определения высоты спирали: по размеру или по объекту.

При выборе способа По размеру в поле Размер следует ввести высоту спирали в миллиметрах.

Выбор способа По объекту означает, что высота спирали определяется автоматически по положению указанного пользователем объекта (грани, плоскости, или точки). При этом необходимо выбрать нужный объект в Дереве построения или в окне модели.

Название объекта, выбранного для определения высоты спирали, отображается в справочном поле рядом с переключателем Объект.

Вы можете построить спираль, высота которой отличается от расстояния между ее опорной плоскостью и указанным объектом на определенную величину. Для этого введите требуемую величину (в миллиметрах) в поле Размер.

Затем с помощью переключателя Тип укажите, должна ли спираль «не доходить» до объекта или «выходить» за объект на заданное расстояние.

Группа переключателей Высота доступна, если в списке Способ построения выбран вариант По числу витков и высоте или По шагу витков и высоте.


Точка условного пересечения объектов

Поля координат точки созданного условного пересечения объектов.

В процессе редактирования условного пересечения в полях отображаются координаты точки пересечения выносных линий.

При изменении положения точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.

Изменение координат доступно, если условное пересечение не имеет ассоциативной связи с объектами.


Угол наклона касательной в начальной точке

Поле величины угла наклона касательной в начальной точке конической кривой.

Угол наклона касательной к конической кривой отсчитывается от оси абсцисс текущей системы координат.

Если задана начальная точка конической кривой, то при указании точки пересечения касательных величина угла определяется автоматически и заносится в это поле.

Возможен также ввод значения с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши или вызовите контекстное меню в окне документа.


Угол наклона касательной в конечной точке

Поле величины угла наклона касательной в конечной точке конической кривой.

Угол наклона касательной к конической кривой отсчитывается от оси абсцисс текущей системы координат.

Если задана конечная точка конической кривой, то при указании точки пересечения касательных величина угла определяется автоматически и заносится в это поле.

Возможен также ввод значения с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши или вызовите контекстное меню в окне документа.


Начальная точка кривой

Поля координат начальной точки конической кривой.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши или вызовите контекстное меню в окне документа.


Конечная точка кривой

Поля координат конечной точки конической кривой

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши или вызовите контекстное меню в окне документа.


Точка пересечения касательных

Поля координат точки пересечения касательных к конической кривой в ее начальной и конечной точках.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Если заданы углы наклонов касательных, то координаты точки их пересечения определяются автоматически.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши или вызовите контекстное меню в окне документа.


Точка на кривой

Поля координат точки, через которую проходит коническая кривая.

Указание точки на кривой возможно, если заданы начальная и конечная точки кривой (т1 и т2) и точка пересечения касательных к ней в этих точках (т3).

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

В зависимости от состояния переключателя коэффициент/высота положение точки определяется по-разному.

– При активном переключателе Коэффициент:

• если точка т4 указана внутри треугольника с вершинами в точках т1, т2, т3, то ее координаты определяются автоматически и коническая кривая проходит непосредственно через указанную точку;

• если точка указана за пределами треугольника, то кривая проходит через точку пересечения медианы с прямой, проведенной через указанную точку параллельно отрезку т1т2.

– При активном переключателе Высота кривая проходит через точку пересечения медианы с прямой, проведенной через указанную точку параллельно отрезку т1т2, независимо от того, где была указана точка.

При вводе значения параметра коэффициент/высота положение точки автоматически определяется на медиане.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши или вызовите контекстное меню в окне документа.


Опция Учитывать границы(построение группы точек по поверхности)

Опция Учитывать границы
(построение группы точек по поверхности)

Опция, позволяющая выбрать вариант построения группы точек по поверхности.

– При включенной опции группа строится в пределах контура указанной грани.

– При отключенной опции группа строится на всей теоретической поверхности грани. При необходимости теоретическая поверхность грани будет продлеваться. Примеры...

Подробнее о построении группы точек по поверхности...


Тип контура

Позволяет выбрать тип контура

– Автоопределение типа,

– Произвольный контур,

– Контур на грани,

– Контур эскиза.

Активизируйте переключатель в группе Тип на Панели свойств или выберите команду в контекстном меню. Затем укажите объекты в зависимости от выбранного варианта.


Тип сегмента

Переключатель, позволяющий выбрать тип сегмента при непрерывном вводе объектов.


Параметры скруглений

Панель, содержащая таблицу параметров скруглений вершин контура: номера точек и значения радиусов скругления в этих точках. В таблицу помещаются точки, значения радиусов в которых отличаются от заданного в поле Радиус на вкладке Параметры.

Чтобы добавить в таблицу точку, укажите ее в окне модели.

Чтобы удалить точку из таблицы, выделите ее и нажмите кнопку Удалить, расположенную над таблицей.

Для изменения значения радиуса сделайте одинарный или двойной щелчок в нужной ячейке. После одинарного щелчка возможен ввод в ячейку значения с клавиатуры, а после двойного — ввод с клавиатуры или выбор с помощью счетчика.

Подробнее о построении контура с переменным радиусом...


Группа переключателей Тип координат

Позволяет выбрать тип координат для задания положения точки на плоскости:

– Прямоугольные координаты,

– Полярные координаты.

Подробнее о построении точки по координатам на плоскости...


Панель Список объектов(объекты коллекции)

Панель Список объектов
(объекты коллекции)

Панель служит для формирования списка объектов, входящих в коллекцию.

Чтобы добавить объект в список, укажите его мышью в Дереве построения или в окне модели.

Тело или поверхность можно указать только в Дереве построения.

Повторное указание объекта удаляет его из списка. Можно также удалить объект, выделив его в списке и нажав кнопку Удалить из списка. Кнопка Указать заново полностью очищает список.


Панель Список объектов(объекты копии)

Панель Список объектов
(объекты копии)

Панель служит для формирования списка объектов, входящих в копию геометрических объектов.

Список отображается на Панели свойств, если в группе Выбор объектов включен переключатель Ручное указание.

Чтобы добавить объект в список, укажите его мышью в Дереве построения или в окне той модели, которая выбрана в качестве источника копирования (в случае контекстного копирования — это текущая модель, в случае копирования из файла — модель, показанная в Окне модели-источника).

Тело или поверхность можно указать только в Дереве построения.

Повторное указание объекта удаляет его из списка. Можно также удалить объект, выделив его в списке и нажав кнопку Удалить из списка. Кнопка Указать заново полностью очищает список.


Результат зеркального копирования тела

– Активизируйте переключатель Автоопределение, чтобы результат операции был определен автоматически. При этом построение выполняется следующим образом:

• если зеркальная копия тела не пересекается и не имеет общих поверхностей с исходным телом, то копия строится как отдельное тело,

• если зеркальная копия тела пересекается или имеет общую поверхность с исходным телом, то происходит объединение тел в одно.

Переключатель работает только при создании зеркального массива. При редактировании массива в первом случае на Панели свойств активен переключатель Новое тело, во втором — переключатель Объединение.

– Активизируйте переключатель Новое тело, чтобы зеркальная копия представляла собой отдельное тело вне зависимости от того, пересекается она с исходным телом или нет.

– Активизируйте переключатель Объединение, чтобы объединить исходное тело и его зеркальную копию.

При построении новой зеркальной копии результат операции определяется автоматически (т.е. по умолчанию в группе Результат операции активен переключатель Автоопределение).

Если был активизирован — вручную или автоматически — переключатель Объединение, то построение зеркальной копии тела возможно только при условии, что она пересекается или имеет общую поверхность с исходным телом. Если условие не выполняется, то операция копирования отмечается как ошибочная.


Поле Количество точек по U

Поле для задания количества полюсов сетки по направлению U. Присутствует на Панели свойств при включенной опции Новая сетка.


Поле Количество точек по V

Поле для задания количества полюсов сетки по направлению V. Присутствует на Панели свойств при включенной опции Новая сетка.


Угол

Поле угла поворота нормальной плоскости вокруг оси поверхности вращения.

Угол отсчитывается от умолчательного положения нормальной плоскости. В умолчательном положении нормальная плоскость создается в режиме автосоздания объектов.

Вы можете ввести значение вручную или выбрать из списка.

Изменение угла поворота немедленно отображается на фантоме плоскости в окне модели.


Расстояние

Поле задания значения расстояния между существующей плоскостью и плоскостью, которую требуется создать.

Вы можете ввести значение вручную или выбрать из списка.

Изменение расстояния немедленно отображается на фантоме плоскости в окне модели.


Поле Ребро или вектор

Содержит наименование кривой, используемой для построения вспомогательной плоскости.

Если для построения плоскости используется вектор, то в этом поле отображается слово «Вектор».

Чтобы сменить кривую, укажите ее в окне модели или в Дереве построения.

Чтобы отредактировать вектор, нажмите кнопку Построение вектора на Панели специального управления или выберите название команды из контекстного меню.


Поле Точечный объект

В этом поле отображается наименование точечного объекта, через который проходит вспомогательная плоскость.

Чтобы сменить точечный объект, укажите его в окне модели или в Дереве построения или постройте новую точку, используя способы построения точки команды Точка.


Группа полей Объекты

Поля, в которых отображаются наименования объектов, указанных для построения вспомогательной плоскости:

– точечный объект, через который должна пройти плоскость,

– кривая, которой плоскость должна быть перпендикулярна.


Поле Грань

В этом поле отображается название грани, касательно к которой проходит вспомогательная плоскость.

Чтобы сменить грань, укажите нужную грань в окне модели.


Элемент Точка

Служит индикатором наличия ассоциативной связи точки, через которую проходит касательная плоскость, с точечным объектом.

Если связь есть, то на кнопке Точка отображается «галочка», а в поле рядом с кнопкой — наименование точечного объекта.

Если связи нет, то «галочка» на кнопке Точка не отображается, а поле пусто.

Формирование связи происходит автоматически во время указания точечного объекта, определяющего положение касательной плоскости.

При необходимости связь можно отменить, нажав кнопку Точка. «Галочка» на кнопке исчезнет, поле очистится.


Направление смещения

Переключатель, позволяющий выбрать направление измерения расстояния смещения создаваемой плоскости.

Изменение направления немедленно отображается на фантоме плоскости в окне модели.


Опция Ассоциировать

Служит для включения режима, при котором создаваемая точка ассоциативно связывается с указанным точечным объектом.

После указания объекта формируется связанная с ним точка (например, вершина отрезка или центр дуги), на кнопке Объект появляется «галочка», а в поле Объект — наименование объекта.

Благодаря наличию связи точка будет следовать за объектом при любых его перемещениях.

Ассоциативную связь точки с точечным объектом можно отключить. Для этого нужно нажать кнопку Объект. Положение точки не изменится, ассоциативная связь будет отключена («галочка» на кнопке Объект исчезнет).

Для восстановления ассоциативной связи точки с точечным объектом необходимо включить опцию Ассоциировать и указать нужный объект заново.


Элемент Объект радиуса

Служит для указания объекта, определяющего радиус цилиндра или сферы при построении точки по цилиндру или по сфере.

Активизируйте переключатель Объект радиуса и укажите нужный объект:

– ребро или линию эскиза в форме окружности или дуги окружности,

– кривую — окружность или дугу,

– цилиндрическую или сферическую грань.

Название выбранного объекта заносится в поле Объект радиуса, а значение его радиуса — в поле координаты R. Между точкой и объектом формируется ассоциативная связь, поэтому поле координаты R становится недоступным.

Если требуется отменить связь (или указать другой объект), снова активизируйте переключатель Объект радиуса и укажите тот же самый (или другой) объект.

Подробнее о построении точки по цилиндру и сфере...


Способ построения

Список, из которого можно выбрать текущий способ построения точки.

По координатам (XYZ)

Перенос

На пересечении

На кривой

На поверхности

В центре

Проекция

По цилиндру (RAZ)

По сфере (RAB)


Группа Тип

Группа переключателей для выбора типа присоединительной точки — с одной осью или с двумя осями.

Первая ось присоединительной точки отображается в окне модели отрезком со стрелкой, вторая ось — отрезком без стрелки.

Для смены текущего типа присоединительной точки можно также использовать команду контекстного меню Сменить тип.


Поле Точка

В этом поле отображается информация об опорной точке текущей присоединительной или контрольной точки. Возможно три варианта содержимого поля Точка:

– название точечного объекта, указанного в качестве опорной точки,

– координаты точки (для точки, построенной по координатам),

– название способа построения (для точки, построенной другими способами) — в этом случае текст в поле Точка отображается серым цветом.

Обратите внимание на то, что в первых двух случаях для смены опорной точки можно указать новый точечный объект в окне модели, а в третьем случае необходимо запустить процесс построения точки, нажав кнопку Построение точки на Панели специального управления.

Поле Точка является справочным и недоступно для редактирования.


Группа Объект 1(построение присоединительной точки способом Ручное задание направления осей)

Группа Объект 1
(построение присоединительной точки способом Ручное задание направления осей)

В поле Объект 1 отображается название направляющего объекта для первой оси присоединитительной точки (первая ось показана на фантоме точки отрезком со стрелкой). Если направление оси задано вектором, то в этом поле отображается слово «Вектор».

Поле является справочным и недоступно для редактирования.

Чтобы сменить направляющий объект для первой оси присоединительной точки, активизируйте переключатель Объект 1, а затем укажите нужный объект или постройте вектор.

Для создания вектора нажмите кнопку Построение вектора на Панели специального управления.

Если точка имеет одну ось, то активизация переключателя не требуется — построенный вектор или указанный прямолинейный или плоский объект автоматически воспринимается как направляющий.


Группа Объект 2(построение присоединительной точки способом Ручное задание направления осей)

Группа Объект 2
(построение присоединительной точки способом Ручное задание направления осей)

В поле Объект 2 отображается название направляющего объекта для второй оси присоединитительной точки (вторая ось показана на фантоме точки отрезком без стрелки). Если направление оси задано вектором, то в этом поле отображается слово «Вектор».

Поле является справочным и недоступно для редактирования.

Направляющий объект для второй оси может задавать направление, не перпендикулярное первой оси. В этом случае направление второй оси определяется как проекция направления, которое задает объект, на плоскость, перпендикулярную первой оси.

Объект не может использоваться в качестве направляющего для второй оси, если он параллелен первой оси или лежит на одной прямой с ней.

Вектор не может использоваться в качестве направляющего объекта для второй оси, если он коллинеарен первой оси. При обнаружении ошибки выдается сообщение об этом.

Чтобы сменить направляющий объект для второй оси присоединительной точки, активизируйте переключатель Объект 2, а затем укажите нужный объект или постройте вектор.

Для создания вектора нажмите кнопку Построение вектора на Панели специального управления.


Опция Учитывать границы(построение точки способом На поверхности)

Опция Учитывать границы
(построение точки способом На поверхности)

Опция, позволяющая выбрать вариант построения точки, лежащей на грани.

– При включенной опции точка строится в пределах контура указанной грани.

– При отключенной опции точка строится на теоретической поверхности грани (как в пределах контура грани, так и за ее пределами). При необходимости теоретическая поверхность грани будет продлеваться.

Если точка строится на вспомогательной или координатной плоскости, то опция Учитывать границы недоступна.


Группа Направление 1(построение присоединительной точки способом Ручное задание направления осей)

Группа Направление 1
(построение присоединительной точки способом Ручное задание направления осей)

Группа переключателей, позволяющая направить первую ось присоединительной точки в противоположную сторону (первая ось отображается на фантоме точки отрезком со стрелкой).

Группа Направление 1 доступна, если задан направляющий объект для первой оси присоединитительной точки.

Сменить направление первой оси можно также с помощью команды контекстного меню Сменить направление оси 1.

В результате смены направления первой оси присоединительной точки происходит автоматическая смена направления второй оси (если она есть). При необходимости вы можете вернуть прежнее направление второй оси, воспользовавшись группой переключателей Направление 2.


Группа Направление 2(построение присоединительной точки способом Ручное задание направления осей)

Группа Направление 2
(построение присоединительной точки способом Ручное задание направления осей)

Группа переключателей, позволяющая направить вторую ось присоединительной точки в противоположную сторону (вторая ось отображается на фантоме точки отрезком без стрелки).

Группа Направление 2 доступна, если задан направляющий объект для второй оси присоединитительной точки.

Сменить направление второй оси можно также с помощью команды контекстного меню Сменить направление оси 2.


Панель Список объектов

Панель, содержащая перечень объектов, размеры которых требуется отобразить в виде элементов оформления (производных размеров).

При выделении объекта в списке он выделяется в окне модели.

Кнопка Удалить, расположенная над панелью, позволяет удалить выделенный объект из списка.


Поле Комментарий

Поле позволяет ввести дополнительные сведения о создаваемом исполнении модели. Текст, введенный в поле, является значением свойства Комментарий данного исполнения и может быть изменен при редактировании свойств исполнения.


Опция Зависимое исполнение

Опция позволяет выбрать вариант создания исполнения модели. Если опция включена, создается зависимое исполнение, если опция отключена — независимое.

Подробнее о зависимых и независимых исполнениях...


Опция Зеркальное исполнение

Опция позволяет создать зеркальное исполнение модели. Доступна при включенной опции Зависимое исполнение.

Опция присутствует на Панели свойств, если исходное исполнение еще не имеет зависимых зеркальных исполнений.

Если исходным исполнением является модель, содержащая компоненты, то после включения опции кнопка Создать объект заменяется кнопкой Продолжить создание исполнения, которая позволяет перейти к настройке параметров отражения компонентов модели.


Имя местного разреза

Поле для ввода имени местного разреза. Это имя отображается в Дереве чертежа.


Номер местного разреза

Поле для ввода номера местного разреза. По умолчанию нумерация местных разрезов в каждом ассоциативном виде начинается заново.


Кнопка Создать измерение

Позволяет создать объект «измерение».

Кнопка доступна, если результат измерения отображается в Информационном окне.

После нажатия кнопки в Дереве построения появляется объект, соответствующий виду измерения. В модели формируется связанная с этим объектом информационная переменная.

Подробнее об объекте «измерение»...


Штриховка сборки

Переключатель, позволяющий выбрать способ штриховки соседних деталей сборки: в одну сторону или с поворотом на 90 градусов.


Тип изображения

Переключатель, позволяющий выбрать тип изображения: разрез или сечение.


Опция Размеры с нулевым значением

Опция, включение которой позволяет создавать производные размеры для размеров операций с нулевым значением.


Точка присоединения линии-выноски

Поля координат точки присоединения линии-выноски.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Поле Зона

Служит для отображения наименования зоны, выбранной для создания сечения.

Поле присутствует на Панели свойств, если для задания параметров шага отсечения выбран способ Зона.


Поле Выражение функции по A

Поле для ввода выражения функции, определяющей координату A.

Это поле присутствует на Панели свойств, если в списке Функция по A выбран тип функции По выражению.

Выражение функции может содержать интервальный параметр и неинтервальные параметры. Например, координата задана выражением: x = a · (1 - t) + b · t.
Параметр t является интервальным, а параметры a и b — неинтервальными.

Для ввода выражения функции могут использоваться следующие приемы:

– ввод выражения вручную,

– вставка в выражение переменной модели;

– вставка элементов выражения из коллекции;

– вставка группового закона из коллекции — вставка выражений функции сразу для всех координат.

Если в выражении функции нет интервального параметра, то значением функции является результат вычисления этого выражения, т.е. константа. Для того чтобы построение кривой было возможно, функция хотя бы по одной координате должна содержать интервальный параметр, т.е. не должна быть константой.

В выражение может быть включено любое количество пробелов. При интерпретации выражения они не учитываются.

После ввода выражения нажмите клавишу <Enter>.

Если выражение содержит русские буквы, или неверное сочетание знаков операций, или символы, не являющиеся обозначениями операций/функций, на экране появляется сообщение о наличии синтаксических ошибок.

После ввода выражения функции неинтервальные параметры заносятся в таблицу Значение параметров на Панели свойств.


Поле Выражение функции по B

Поле для ввода выражения функции, определяющей координату B.

Это поле присутствует на Панели свойств, если в списке Функция по B выбран тип функции По выражению.

Выражение функции может содержать интервальный параметр и неинтервальные параметры. Например, координата задана выражением: x = a · (1 - t) + b · t.
Параметр t является интервальным, а параметры a и b — неинтервальными.

Для ввода выражения функции могут использоваться следующие приемы:

– ввод выражения вручную,

– вставка в выражение переменной модели;

– вставка элементов выражения из коллекции;

– вставка группового закона из коллекции — вставка выражений функции сразу для всех координат.

Если в выражении функции нет интервального параметра, то значением функции является результат вычисления этого выражения, т.е. константа. Для того чтобы построение кривой было возможно, функция хотя бы по одной координате должна содержать интервальный параметр, т.е. не должна быть константой.

В выражение может быть включено любое количество пробелов. При интерпретации выражения они не учитываются.

После ввода выражения нажмите клавишу <Enter>.

Если выражение содержит русские буквы, или неверное сочетание знаков операций, или символы, не являющиеся обозначениями операций/функций, на экране появляется сообщение о наличии синтаксических ошибок.

После ввода выражения функции неинтервальные параметры заносятся в таблицу Значение параметров на Панели свойств.


Поле Выражение функции по R

Поле для ввода выражения функции, определяющей координату R.

Это поле присутствует на Панели свойств, если в списке Функция по R выбран тип функции По выражению.

Выражение функции может содержать интервальный параметр и неинтервальные параметры. Например, координата задана выражением: x = a · (1 - t) + b · t.
Параметр t является интервальным, а параметры a и b — неинтервальными.

Для ввода выражения функции могут использоваться следующие приемы:

– ввод выражения вручную,

– вставка в выражение переменной модели;

– вставка элементов выражения из коллекции;

– вставка группового закона из коллекции — вставка выражений функции сразу для всех координат.

Если в выражении функции нет интервального параметра, то значением функции является результат вычисления этого выражения, т.е. константа. Для того чтобы построение кривой было возможно, функция хотя бы по одной координате должна содержать интервальный параметр, т.е. не должна быть константой.

В выражение может быть включено любое количество пробелов. При интерпретации выражения они не учитываются.

После ввода выражения нажмите клавишу <Enter>.

Если выражение содержит русские буквы, или неверное сочетание знаков операций, или символы, не являющиеся обозначениями операций/функций, на экране появляется сообщение о наличии синтаксических ошибок.

После ввода выражения функции неинтервальные параметры заносятся в таблицу Значение параметров на Панели свойств.


Поле Выражение функции по X

Поле для ввода выражения функции, определяющей координату X.

Это поле присутствует на Панели свойств, если в списке Функция по X выбран тип функции По выражению.

Выражение функции может содержать интервальный параметр и неинтервальные параметры. Например, координата задана выражением: x = a · (1 - t) + b · t.
Параметр t является интервальным, а параметры a и b — неинтервальными.

Для ввода выражения функции могут использоваться следующие приемы:

– ввод выражения вручную,

– вставка в выражение переменной модели;

– вставка элементов выражения из коллекции;

– вставка группового закона из коллекции — вставка выражений функции сразу для всех координат.

Если в выражении функции нет интервального параметра, то значением функции является результат вычисления этого выражения, т.е. константа. Для того чтобы построение кривой было возможно, функция хотя бы по одной координате должна содержать интервальный параметр, т.е. не должна быть константой.

В выражение может быть включено любое количество пробелов. При интерпретации выражения они не учитываются.

После ввода выражения нажмите клавишу <Enter>.

Если выражение содержит символы кириллицы, или неверное сочетание знаков операций, или символы, не являющиеся обозначениями операций/функций, на экране появляется сообщение о наличии синтаксических ошибок.

После ввода выражения функции неинтервальные параметры заносятся в таблицу Значение параметров на Панели свойств.


Поле Выражение функции по Y

Поле для ввода выражения функции, определяющей координату Y.

Это поле присутствует на Панели свойств, если в списке Функция по Y выбран тип функции По выражению.

Выражение функции может содержать интервальный параметр и неинтервальные параметры. Например, координата задана выражением: x = a · (1 - t) + b · t.
Параметр t является интервальным, а параметры a и b — неинтервальными.

Для ввода выражения функции могут использоваться следующие приемы:

– ввод выражения вручную,

– вставка в выражение переменной модели;

– вставка элементов выражения из коллекции;

– вставка группового закона из коллекции — вставка выражений функции сразу для всех координат.

Если в выражении функции нет интервального параметра, то значением функции является результат вычисления этого выражения, т.е. константа. Для того чтобы построение кривой было возможно, функция хотя бы по одной координате должна содержать интервальный параметр, т.е. не должна быть константой.

В выражение может быть включено любое количество пробелов. При интерпретации выражения они не учитываются.

После ввода выражения нажмите клавишу <Enter>.

Если выражение содержит русские буквы, или неверное сочетание знаков операций, или символы, не являющиеся обозначениями операций/функций, на экране появляется сообщение о наличии синтаксических ошибок.

После ввода выражения функции неинтервальные параметры заносятся в таблицу Значение параметров на Панели свойств.


Поле Выражение функции по Z

Поле для ввода выражения функции, определяющей координату Z.

Это поле присутствует на Панели свойств, если в списке Функция по Z выбран тип функции По выражению.

Выражение функции может содержать интервальный параметр и неинтервальные параметры. Например, координата задана выражением: x = a · (1 - t) + b · t.
Параметр t является интервальным, а параметры a и b — неинтервальными.

Для ввода выражения функции могут использоваться следующие приемы:

– ввод выражения вручную,

– вставка в выражение переменной модели;

– вставка элементов выражения из коллекции;

– вставка группового закона из коллекции — вставка выражений функции сразу для всех координат.

Если в выражении функции нет интервального параметра, то значением функции является результат вычисления этого выражения, т.е. константа. Для того чтобы построение кривой было возможно, функция хотя бы по одной координате должна содержать интервальный параметр, т.е. не должна быть константой.

В выражение может быть включено любое количество пробелов. При интерпретации выражения они не учитываются.

После ввода выражения нажмите клавишу <Enter>.

Если выражение содержит русские буквы, или неверное сочетание знаков операций, или символы, не являющиеся обозначениями операций/функций, на экране появляется сообщение о наличии синтаксических ошибок.

После ввода выражения функции неинтервальные параметры заносятся в таблицу Значение параметров на Панели свойств.


Интервальный параметр

Поле для задание интервального параметра функции, которая определяет координату точки кривой.

Параметрическое представлении кривой...

Интервал изменения параметра заключен в квадратные скобки. Значения, ограничивающие интервал, разделяются знаком «;».

Введите в поле имя параметра и интервал его изменения.

Введенные значения будут добавляться в список и сохраняться в течение сеанса работы КОМПАС-3D.

Интервал изменения параметра функции можно задать с помощью имеющейся интервальной переменной. Для этого введите ее имя в квадратных скобках после знака равно в правой части поля Интервальный параметр, а затем нажмите клавишу <Enter>. Значение интервальной переменной (границы интервала изменения) присваивается параметру операции и отображается в поле. Редактирование данного интервала изменения параметра недоступно.

Интервал изменения параметра функции можно задать, создав новую интервальную переменную с нужным значением. Для этого в поле Интервальный параметр выполните следующие действия.

1. В квадратные скобки введите нужный интервал значений (например, [10;-10]).

2. После знака равно в правой части поля введите имя новой интервальной переменной (в квадратных скобках).

3. Нажмите клавишу <Enter>.

Подробнее о задании интервального параметра функции...


Начальное/конечное значение по A

Поля для ввода или задания счетчиком интервала изменения координаты A (начального и конечного значения).

Поля присутствуют на Панели свойств, если в списке Функция по A выбран тип функции Линейная или Кубическая.

Подробнее о задании функции для координаты точки кривой...


Поле Значение по A

Поле для ввода или задания счетчиком постоянного значения координаты A.

Поле присутствует на Панели свойств, если в списке Функция по A выбран тип функции Константа.

Подробнее о задании функции для координаты точки кривой...


Начальное/конечное значение по B

Поля для ввода или задания счетчиком интервала изменения координаты B (начального и конечного значения).

Поля присутствуют на Панели свойств, если в списке Функция по B выбран тип функции Линейная или Кубическая.

Подробнее о задании функции для координаты точки кривой...


Поле Значение по B

Поле для ввода или задания счетчиком постоянного значения координаты B.

Поле присутствует на Панели свойств, если в списке Функция по B выбран тип функции Константа.

Подробнее о задании функции для координаты точки кривой...


Начальное/конечное значение по R

Поля для ввода или задания счетчиком интервала изменения координаты R (начального и конечного значения).

Поля присутствуют на Панели свойств, если в списке Функция по R выбран тип функции Линейная или Кубическая.

Подробнее о задании функции для координаты точки кривой...


Поле Значение по R

Поле для ввода или задания счетчиком постоянного значения координаты R.

Поле присутствует на Панели свойств, если в списке Функция по R выбран тип функции Константа.

Подробнее о задании функции для координаты точки кривой...


Начальное/конечное значение по X

Поля для ввода или задания счетчиком интервала изменения координаты X (начального и конечного значения).

Поля присутствуют на Панели свойств, если в списке Функция по X выбран тип функции Линейная или Кубическая.

Подробнее о задании функции для координаты точки кривой...


Поле Значение по X

Поле для ввода или задания счетчиком постоянного значения координаты X.

Поле присутствует на Панели свойств, если в списке Функция по X выбран тип функции Константа.

Подробнее о задании функции для координаты точки кривой...


Начальное/конечное значение по Y

Поля для ввода или задания счетчиком интервала изменения координаты Y (начального и конечного значения).

Поля присутствуют на Панели свойств, если в списке Функция по Y выбран тип функции Линейная или Кубическая.

Подробнее о задании функции для координаты точки кривой...


Поле Значение по Y

Поле для ввода или задания счетчиком постоянного значения координаты Y.

Поле присутствует на Панели свойств, если в списке Функция по Y выбран тип функции Константа.

Подробнее о задании функции для координаты точки кривой...


Начальное/конечное значение по Z

Поля для ввода или задания счетчиком интервала изменения координаты Z (начального и конечного значения).

Поля присутствуют на Панели свойств, если в списке Функция по Z выбран тип функции Линейная или Кубическая.

Подробнее о задании функции для координаты точки кривой...


Поле Значение по Z

Поле для ввода или задания счетчиком постоянного значения координаты Z.

Поле присутствует на Панели свойств, если в списке Функция по Z выбран тип функции Константа.

Подробнее о задании функции для координаты точки кривой...


Список Функция по A

Список, из которого можно выбрать тип функции для координаты A:

– Константа,

– Линейная,

– Кубическая,

– По выражению.

После выбора типа функции на Панели свойств появляются элементы управления, позволяющие задать параметры функции выбранного типа.

До завершения команды система «запоминает» данные, введенные для каждого типа функции, поэтому вы можете переключаться между типами функции без потери этих данных.

Подробнее о задании функции для координаты точки кривой...


Список Функция по B

Список, из которого можно выбрать тип функции для координаты B:

– Константа,

– Линейная,

– Кубическая,

– По выражению.

После выбора типа функции на Панели свойств появляются элементы управления, позволяющие задать параметры функции выбранного типа.

До завершения команды система «запоминает» данные, введенные для каждого типа функции, поэтому вы можете переключаться между типами функции без потери этих данных.

Подробнее о задании функции для координаты точки кривой...


Список Функция по R

Список, из которого можно выбрать тип функции для координаты R:

– Константа,

– Линейная,

– Кубическая,

– По выражению.

После выбора типа функции на Панели свойств появляются элементы управления, позволяющие задать параметры функции выбранного типа.

До завершения команды система «запоминает» данные, введенные для каждого типа функции, поэтому вы можете переключаться между типами функции без потери этих данных.

Подробнее о задании функции для координаты точки кривой...


Список Функция по X

Список, из которого можно выбрать тип функции для координаты X:

– Константа,

– Линейная,

– Кубическая,

– По выражению.

После выбора типа функции на Панели свойств появляются элементы управления, позволяющие задать параметры функции выбранного типа.

До завершения команды система «запоминает» данные, введенные для каждого типа функции, поэтому вы можете переключаться между типами функции без потери этих данных.

Подробнее о задании функции для координаты точки кривой...


Список Функция по Y

Список, из которого можно выбрать тип функции для координаты Y:

– Константа,

– Линейная,

– Кубическая,

– По выражению.

После выбора типа функции на Панели свойств появляются элементы управления, позволяющие задать параметры функции выбранного типа.

До завершения команды система «запоминает» данные, введенные для каждого типа функции, поэтому вы можете переключаться между типами функции без потери этих данных.

Подробнее о задании функции для координаты точки кривой...


Список Функция по Z

Список, из которого можно выбрать тип функции для координаты Z:

– Константа,

– Линейная,

– Кубическая,

– По выражению.

После выбора типа функции на Панели свойств появляются элементы управления, позволяющие задать параметры функции выбранного типа.

До завершения команды система «запоминает» данные, введенные для каждого типа функции, поэтому вы можете переключаться между типами функции без потери этих данных.

Подробнее о задании функции для координаты точки кривой...


Тип координат

Группа переключателей, позволяющая выбрать тип координат для построения кривой, заданной параметрическими уравнениями:

– Прямоугольные X, Y, Z,

– Цилиндрические R, A, Z,

– Сферические R, A, B.

Параметрическое представление кривой...

Кривая по закону...


Таблица значений параметров выражений

Предназначена для работы с неинтервальными параметрами выражений функций, определяющих координаты точки кривой.

Неинтервальные параметры заносятся в таблицу после ввода выражения функции для текущей координаты. Выражение вводится в поле Выражение функции по <имя координаты>, соответствующее этой координате.

Таблица состоит из трех колонок. В первой колонке показываются имена параметров выражений, во второй — выражения для их вычисления, в третьей — их значения.

Работа с таблицей аналогична работе с таблицей в Окне переменных.

– Если в качестве параметров выражений используются уже существующие пользовательские переменные модели, в том числе функциональные, то данные о переменных (имя и выражение, для функциональной — аргумент) передаются в таблицу из Окна переменных. Изменение этих данных в таблице недоступно.

– Если имя параметра не совпадает ни с одним из имеющихся имен переменных, то параметр заносится в таблицу с умолчательным значением. Активизируйте в столбце Выражение ячейку параметра двойным щелчком мыши и введите нужное значение параметра. Затем нажмите клавишу <Enter>.

Подробнее о вводе выражения функции...


Угол наклона локальной системы координат

Поле угла наклона осей системы координат.

При указании угла наклона мышью его значение определяется автоматически и заносится в это поле.

Возможен также ввод значения угла с клавиатуры.

Для вызова меню геометрического калькулятора щелкните в поле правой кнопкой мыши.


Панель работы с локальными СК

В этом окне содержится список имеющихся в документе локальных систем координат.

Чтобы сделать какую-либо из них текущей, выделите ее имя в списке и нажмите кнопку Текущая локальная СК.

Чтобы создать новую систему координат, нажмите кнопку Новая ЛСК.

Чтобы удалить какую-либо из систем координат, выделите ее имя в списке и нажмите кнопку Удалить.

Если Панель свойств расположена горизонтально, то для открытия и закрытия окна работы с ЛСК требуется нажать кнопку Выбор ЛСК.


Имя локальной системы координат

Поле для ввода имени локальной системы координат.


Начало отсчета локальной системы координат

Поля координат точки начала отсчета локальной системы координат. Обратите внимание на то, что эти координаты измеряются в текущей системе координат.

При указании начала отсчета мышью координаты точки определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните в поле правой кнопкой мыши.


Список СК

Список для выбора системы координат, в которую требуется перенести объекты.

Объект можно перенести только в ту систему координат, которая расположена выше него в Дереве построения.


Опция Все контуры

Опция, включение которой означает, что будут созданы все контуры кривой.

Чтобы исключить какие-либо контуры или, наоборот, добавить, отключите опцию Все контуры. На Панели свойств появится панель Список контуров, содержащая перечень контуров. Слева от названий контуров отображаются опции.

– Включенная опция означает, что контур будет создан.

– Отключенная опция означает, что контур исключен и не будет создан.

Настройте список контуров.

Если нужно оставить или исключить большинство контуров, воспользуйтесь кнопками Включить все и Выключить все, расположенными над списком.


Панель Список контуров

Содержит список контуров кривой.

Слева от названий контуров отображаются опции.

– Включенная опция означает, что контур будет создан.

– Отключенная опция означает, что контур исключен и не будет создан.

Настройте список контуров.

Если нужно оставить или исключить большинство контуров, воспользуйтесь кнопками Включить все и Выключить все, расположенными над списком.

Список присутствует на Панели свойств, если отключена опция Все контуры.


Элемент управления Начальная точка

Позволяет задать начальную точку замкнутой траектории вручную.

По умолчанию начальной точкой замкнутой траектории считается ее первая вершина (для цепочки объектов — вершина, ближайшая к копируемому объекту).

В качестве начальной точки можно указать любую точку на траектории.

Чтобы задать положение начальной точки кривой, активизируйте переключатель Начальная точка и укажите нужную точку в Дереве построения или в окне модели. Название указанного объекта отображается в поле рядом с переключателем. Повторное указание объекта отменяет его выбор.

Переключатель присутствует на Панели свойств, если траектория копирования замкнута.


Поле Количество вдоль кривой

Поле значения количества экземпляров массива.

Вы можете ввести значение вручную или установить с помощью счетчика.

Изменение количества немедленно отображается на фантоме массива в окне модели.


Элемент управления Кривая

Позволяет задать кривую для построения массива.

В качестве этой кривой можно использовать:

– пространственную кривую,

– ребро,

– линию эскиза,

– цепочку вышеперечисленных объектов в любом сочетании.

Чтобы задать траекторию копирования, активизируйте переключатель Кривая и укажите нужный объект или объекты в Дереве построения или в окне модели.

Название указанного объекта или количество указанных объектов отображается в поле рядом с переключателем. Повторное указание объекта отменяет его выбор.


Группа Способ

Переключатель По шагу позволяет разместить элементы вдоль траектории с шагом, заданным в поле Шаг. Группа переключателей Режим позволяет выбрать режим определения шага вдоль кривой.

Переключатель Вдоль всей направляющей позволяет разместить элементы массива так, чтобы первый и последний из них лежали в начальной и конечной точках траектории. При этом поле Шаг и группа Режим не присутствуют на Панели свойств — шаг вычисляется автоматически как частное от деления длины траектории на число, на единицу меньшее, чем количество элементов.


Ориентация экземпляров массива

Если все экземпляры массива должны быть ориентированы в пространстве так же, как ориентирован копируемый объект, активизируйте переключатель Сохранять исходную ориентацию.

Активизация переключателя Доворачивать до нормали означает, что каждая копия будет поворачиваться так, чтобы ориентироваться по отношению к касательному вектору траектории в своей базовой точке так же, как копируемый объект ориентируется по отношению к касательному вектору траектории в его базовой точке.


Поле Шаг вдоль кривой

Поле значения шага экземпляров массива.

Вы можете ввести значение вручную или установить с помощью счетчика.

Изменение шага немедленно отображается на фантоме массива в окне модели.

Поле присутствует на Панели свойств, если в группе Способ активен переключатель По шагу.


Список Тип кривой

Раскрывающийся список, из которого можно выбрать тип кривой при построении сплайна по точкам — NURBS-кривая по точкам или Кривая Безье.

При изменении типа кривой изменяется набор параметров таблицы Координаты вершин — в ней появляются параметры, специфические для выбранного типа кривой.

После выбора типа NURBS-кривая по точкам на Панели свойств появляются элементы управления, позволяющие задать способ формирования параметров точек сплайна.


Панель Кривые

Панель содержит перечень криволинейных участков контура обечайки, являющихся дугами окружностей и/или эллипсов. При выделении строки в списке соответствующий ей участок контура подсвечивается в окне модели.

Панель присутствует на Панели свойств, если отключена опция Единые параметры.

Для настройки сегментации дуги выделите в списке строку с ее номером и задайте требуемые параметры.

Для отмены сегментации дуги отключите опцию рядом с ее номером в списке.


Переключатель Сменить направление

Позволяет направить вектор касательной (или вектор нормали или радиус кривизны) сплайна в текущей вершине в противоположную сторону.

Изменение направления немедленно отображается на фантоме сплайна в окне модели.

Чтобы сменить направление вектора касательной (или вектора нормали или радиуса кривизны), нажмите переключатель Сменить направление.

Смотрите также

Управление формой сплайна...

Базисные векторы в точке кривой...


Список Управление

Раскрывающийся список, из которого можно выбрать вариант управления формой сплайна в текущей вершине.

– Управление касательностью — управление формой сплайна в этой вершине путем задания направления вектора касательной и величины касательности.

– Управление кривизной — управление формой сплайна в текущей вершине путем задания кривизны или радиуса кривизны.

– Управление касательностью и кривизной — управление формой сплайна в текущей вершине путем управления сразу двумя параметрами — величиной касательности и кривизной.

Список присутствует на Панели свойств в режиме управления формой сплайна.

Смотрите также

Базисные векторы в точке кривой...

Кривизна кривой. Соприкасающаяся окружность...


Список Управление

Раскрывающийся список, из которого можно выбрать вариант управления формой сплайна в текущей вершине.

– Нет — отказ от изменения формы сплайна, т.е. использование параметров, рассчитанных системой.

– Управление касательностью — управление формой сплайна в этой вершине путем задания длины и направления вектора касательной.

– Управление касательностью и кривизной — управление формой сплайна в текущей вершине путем задания длины и направления вектора касательной, а также величины кривизны.

Список присутствует на Панели свойств в режиме редактирования характерных точек объекта.

Смотрите также

Базисные векторы в точке кривой

Кривизна кривой. Соприкасающаяся окружность


Поле Проекция 1

В этом поле отображается название объекта или количество объектов, указанных в качестве первой проекции кривой.

Укажите в окне модели первую проекцию кривой — эскиз или отдельные линии в нем.

Эскиз можно указать в Дереве построения или в окне модели. В последнем случае необходимо предварительно включить фильтр эскизов при помощи команды контекстного меню Фильтровать эскизы. Обратите внимание на то, что этот фильтр действует только в процессе создания кривой по двум проекциям.

Линии первой проекции могут быть выделены и перед вызовом команды.

Повторное указание объекта отменяет его выбор.

Выбор объектов в окне модели

Выбор объектов в Дереве построения

Поле является справочным и недоступно для редактирования.

Подробнее о кривой, построенной по двум ее проекциям...

Подробнее о фильтрах объектов...


Поле Проекция 2

В этом поле отображается название объекта или количество объектов, указанных в качестве второй проекции кривой.

Укажите в окне модели вторую проекцию кривой — эскиз или отдельные линии в нем.

Эскиз можно указать в Дереве построения или в окне модели. В последнем случае необходимо предварительно включить фильтр эскизов при помощи команды контекстного меню Фильтровать эскизы. Обратите внимание на то, что этот фильтр действует только в процессе создания кривой по двум проекциям.

Повторное указание объекта отменяет его выбор.

Выбор объектов в окне модели

Выбор объектов в Дереве построения

Поле является справочным и недоступно для редактирования.

Подробнее о кривой, построенной по двум ее проекциям...

Подробнее о фильтрах объектов...


Группа Начальная/конечная вершина 1

Группа переключателей, позволяющая сменить вершину сопряжения первой исходной кривой.

Активизируйте нужный переключатель: Начальная точка или Конечная точка.

Смена вершины немедленно отображается на фантоме соединительной кривой в окне модели.


Группа Начальная/конечная вершина 2

Группа переключателей, позволяющая сменить вершину сопряжения второй исходной кривой.

Активизируйте нужный переключатель: Начальная точка или Конечная точка.

Смена вершины немедленно отображается на фантоме соединительной кривой в окне модели.


Натяжение %

Поле натяжения соединительной кривой.

Величина данного параметра задается в процентах от 0 до 100.

– Чем меньше параметр натяжения, тем меньше кривизна соединительной кривой в точке соединения — кривая более пологая вблизи точек соединения.

– Чем больше параметр натяжения, тем больше кривизна соединительной кривой в точке соединения — кривая более пологая в ее средней части.

Умолчательное значение параметра натяжения кривой равно 50%.

Вы можете ввести или задать счетчиком нужное значение натяжения соединительной кривой в поле Натяжение %.


Список Условие 1

Позволяет выбрать условие сопряжения соединительной и первой исходной кривых. Чтобы задать нужное условие сопряжения, раскройте список и укажите в нем нужную строку.

По умолчанию сопряжение соединительной и исходной кривых выполняется по касательной. Обозначение условия сопряжения отображается около начальной и конечной вершины соединительной кривой.

Изменение условия сопряжения отображается на фантоме соединительной кривой в окне модели.


Список Условие 2

Позволяет выбрать условие сопряжения соединительной и второй исходной кривых. Чтобы задать нужное условие сопряжения, раскройте список и укажите в нем нужную строку.

По умолчанию сопряжение исходной кривой и соединительного сплайна выполняется по касательной. Обозначение условия сопряжения отображается около начальной и конечной вершины соединительной кривой.

Изменение условия сопряжения отображается на фантоме соединительной кривой в окне модели.


Опция Усекать кривую 1

Позволяет включить усечение первой исходной кривой.

– Если опция включена, то для исходной кривой создается копия. Копия кривой усекается в точке касания ее с кривой скругления.

– Если опция отключена, то создается только кривая скругления.

Опция не доступна, если точкой касания первой исходной кривой и кривой скругления является начальная или конечная вершина исходной кривой.

Скругление кривых...


Опция Усекать кривую 2

Позволяет включить усечение второй исходной кривой.

– Если опция включена, то для исходной кривой создается копия. Копия кривой усекается в точке касания ее с кривой скругления.

– Если опция отключена, то создается только кривая скругления.

Опция не доступна, если точкой касания второй исходной кривой и кривой скругления является начальная или конечная вершина исходной кривой.

Скругление кривых...


Опция По поверхности

Включите эту опцию, чтобы разместить скругление ребер одной грани на этой же грани.

Скругление других кривых, лежащих на грани, можно расположить на ней только в том случае, если кривые являются непосредственно производными по отношению к объекту, содержащему грань.

Опция доступна, если исходные кривые являются ребрами одной грани или удовлетворяют выше перечисленным требованиям.

Скругление кривых...


Радиус скругления

Поле радиуса скругления.

Вы можете задать нужный радиус скругления следующими способами:

– ввести значение радиуса в поле Радиус или установить с помощью счетчика;

– «перетащить» мышью характерную точку фантома скругления.

Изменение радиуса отображается на фантоме скругления в окне модели.

При построении контура поле Радиус присутствует на Панели свойств в том случае, если в группе Обход углов выбран способ Обход скруглением.

При построении скругления кривых поле присутствует на Панели свойств всегда. После указания исходных кривых радиус их скругления определяется автоматически и его значение отображается в поле.


Элемент Кривая

Переключатель, позволяющий задать исходную кривую для создания ее усеченной копии.

В качестве исходных кривых могут использоваться:

– пространственные кривые;

– ребра тел и поверхностей;

– контуры в эскизе.

Укажите кривую в окне модели или в Дереве построения.

Название указанной кривой отображается в поле рядом с переключателем.

Чтобы сменить ранее выбранную кривую, активизируйте переключатель Кривая и укажите нужную кривую.


Элемент Кривая 1

Переключатель, позволяющий задать первую исходную кривую для соединения.

В качестве исходных кривых могут использоваться:

– пространственные кривые;

– ребра тел и поверхностей;

– контуры в эскизе.

Чтобы указать кривую, щелкните по ней мышью в окне модели.

Исходную кривую следует указывать в точке, близкой к той вершине, в которой предполагается соединение с другой кривой.

Если в качестве исходной кривой используется пространственная кривая, то ее можно указать в Дереве построения. В этом случае точкой соединения автоматически выбирается начальная вершина кривой.

Название указанной кривой отображается в поле рядом с переключателем.

Чтобы сменить ранее выбранную кривую, активизируйте переключатель Кривая 1 и укажите нужную кривую.


Элемент Кривая 2

Переключатель, позволяющий задать вторую исходную кривую для соединения.

В качестве исходных кривых могут использоваться:

– пространственные кривые;

– ребра тел и поверхностей;

– контуры в эскизе.

Чтобы указать кривую, щелкните по ней мышью в окне модели.

Исходную кривую следует указывать в точке, близкой к той вершине, в которой предполагается соединение с другой кривой.

Если в качестве исходной кривой используется пространственная кривая, то ее можно указать в Дереве построения. В этом случае точкой соединения автоматически выбирается начальная вершина кривой.

Название указанной кривой отображается в поле рядом с переключателем.

Чтобы сменить ранее выбранную кривую, активизируйте переключатель Кривая 2 и укажите нужную кривую.


Панель Список кривых направления U (V)

Содержит список объектов сети — кривых и точек — в направлении U (V). При выделении объекта в списке он выделяется в окне модели.

Над списком находятся кнопки управления объектами списка.

– Чтобы изменить положение объекта в списке, выделите его в списке и нажмите кнопку Переместить вверх или Переместить вниз.

– Чтобы добавить объект перед или после определенного объекта в списке, выделите этот объект в списке, нажмите кнопку Вставить перед кривой или Вставить после кривой, а затем укажите добавляемый объект.

– Чтобы исключить какой-либо объект из списка, выделите ее в списке и нажмите кнопку Удалить.

Если кнопка Вставить перед кривой или Вставить после кривой не была нажата, то указанный объект добавляется в конец списка.

Изменение набора объектов сети отображается на фантоме поверхности в окне модели.

Смотрите также

Требования к кривым и точкам сети


Группа Начальная/конечная вершина

Группа переключателей, позволяющая сменить вершину сплайна для определения параметров сопряжения.

Активизируйте нужный переключатель: Начальная точка или Конечная точка.

Смена вершины немедленно отображается на фантоме сплайна в окне модели.


Поле Объект сопряжения

В этом поле отображается название объекта сопряжения — объекта модели, которому принадлежит текущая — начальная или конечная — вершина сплайна.

В качестве объектов сопряжения могут использоваться:

– пространственная кривая (или отдельный сегмент многосегментной кривой),

– линия эскиза,

– ребро,

– вспомогательные и координатные плоскости,

– грани тел и поверхностей.

Чтобы задать объект сопряжения, укажите его в окне модели.

Подробнее о сопряжении сплайна с объектами модели


Поле Граница

В этом поле отображается название граничного объекта — объекта, относительно которого задается условие сопряжения сплайна с объектом модели.

В качестве граничного объекта может использоваться кривая, которая должна принадлежать плоскости или грани (например, ребро) и содержать начальную и/или конечную вершину сплайна.

Чтобы задать граничный объект, укажите его в окне модели.

Выбор объектов в окне модели

Подробнее о сопряжении сплайна с объектами модели


Группа Направление

Группа переключателей, позволяющая сменить направление сплайна вблизи точки его сопряжения с объектом модели.

Изменение направления немедленно отображается на фантоме сплайна в окне модели.


Список Условие

Позволяет выбрать условие сопряжения сплайна с объектом сопряжения.

Объект сопряжения — это объект модели, которому принадлежит начальная и/или конечная вершина сплайна.

Список доступен, если задан объект сопряжения.


Поле Профиль сечения

Справочное поле, в котором отображается название эскиза, выбранного в качестве профиля сечения.


Поле Поверхность сечения

Справочное поле, в котором отображается название поверхности, по которой будет произведено отсечение.


Начальная точка участка

Поля координат начальной точки участка кривой, который нужно удалить (или оставить, в зависимости от выбранного режима).

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Конечная точка участка

Поля координат конечной точки участка кривой, который нужно удалить (или оставить, в зависимости от выбранного режима).

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Опция Создавать вид

Опция, управляющая формированием нового вида сразу после создания обозначения.

Если опция включена, то после создания обозначения автоматически запускается команда создания нового вида. После выполнения этой команды в чертеже появится вид, надпись которого будет ассоциативно связана с созданным обозначением.


Характерная точка линии разреза

Поля координат характерной точки линии разреза (начальной, конечной или точки перегиба).

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Стрелка линии разреза/сечения

Список, позволяющий выбрать вид стрелки линии разреза /сечения. Перечень стрелок, доступных для выбора, а также порядок следования стрелок в списке определяется настройкой фильтра стрелок, сделанной для текущего документа. При необходимости настраивается отрисовка стрелок.


Стрелка линии разреза

Список, позволяющий выбрать вид стрелки линии разреза. Перечень стрелок, доступных для выбора, а также порядок следования стрелок в списке определяется настройкой фильтра стрелок, сделанной для текущего документа. При необходимости настраивается отрисовка стрелок.


Угол

Поле для ввода угла наклона штрихов обозначения узла в сечении.

При указании точек (т) и (т1) мышью угол определяется автоматически и заносится в это поле.

Возможен также ввод значений угла с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Точка привязки штриха

Поля координат точки привязки штриха обозначения узла в сечении. Точка привязки расположена в середине штриха.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Штрих

Поле для ввода или задания счетчиком длины текущего штриха обозначения узла в сечении.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Полка

Список, позволяющий выбрать направление полки обозначения узла в сечении.


Углы А и В

Поля для ввода или задания счетчиком азимутального a и зенитного b углов сферической системы координат, определяющих направление вектора.

Начало сферической системы координат совпадает с началом системы координат, выбранной для построения вектора. Эта система координат выбирается в списке СК на Панели свойств.

Aзимутальный угол отсчитывается в плоскости XY системы координат вектора от оси X против часовой стрелки (см. рисунок). В плоскости XY проводится луч OC под азимутальным углом к оси X. Зенитный угол отсчитывается в плоскости, проходящей через этот луч и ось Z.

Определение направления вектора по азимутальному и зенитному углам

Диапазон допустимых значений азимутального угла составляет 0°...360°.

Диапазон допустимых значений зенитного угла составляет 0°...180°.


Вершина 1

Элемент управления, позволяющий задать начальную точку вектора.

Поле Вершина 1 заполняется автоматически при выборе точечного объекта в Дереве построения или в окне модели.

Выбор объектов в окне модели

Выбор объектов в Дереве построения

Чтобы сменить начальную точку вектора, активизируйте переключатель Вершина 1 и укажите нужный точечный объект в окне модели или в Дереве построения.


Вершина 2

Элемент управления, позволяющий задать точку, в которую будет направлен вектор.

Поле Вершина 2 заполняется автоматически при выборе точечного объекта в Дереве построения или в окне модели.

Выбор объектов в окне модели

Выбор объектов в Дереве построения

Чтобы сменить точку, определяющую направление вектора, активизируйте переключатель Вершина 2 и укажите нужный точечный объект в окне модели или в Дереве построения.


Поле Угол

Поле для ввода угла наклона вектора. Угол отсчитывается в одной из плоскостей выбранной системы координат от указанной оси.

Система координат для построения вектора выбирается в списке СК.

Ось системы координат выбирается с помощью группы переключателей Ось СК.

Вы можете ввести значение угла вручную или выбрать из списка.

Изменение угла наклона вектора немедленно отображается на фантоме вектора в окне модели.


Группа Ось СК

Группа переключателей, позволяющая указать ось выбранной системы координат для отсчета угла вектора.

Система координат для построения вектора выбирается в списке СК на Панели свойств.

Угол наклона вектора отсчитывается в одной из плоскостей выбранной системы координат от оси, определяющей эту плоскость:

– если указана ось X, то угол вектора отсчитывается в плоскости XY,

– если указана ось Y, то угол вектора отсчитывается в плоскости YZ,

– если указана ось Z, то угол вектора отсчитывается в плоскости ZX.

Чтобы указать нужную ось системы координат для отсчета угла вектора, активизируйте соответствующий ей переключатель.


Список СК

Список, позволяющий выбрать систему координат для построения вектора.

Если модель не содержит ЛСК, то список СК не доступен. В этом случае вектор будет строиться в абсолютной системе координат модели.


Группа Ось СК

Группа переключателей, позволяющая указать ось выбранной системы координат, определяющую направление вектора.

Система координат для построения вектора выбирается в списке СК на Панели свойств.

Чтобы указать ось, определяющую направление вектора, активизируйте соответствующий ей переключатель:

– Ось X,

– Ось Y,

– Ось Z.


Коэффициенты X, Y, Z

Поля для ввода или задания счетчиком коэффициентов разложения вектора по координатным осям X, Y, Z выбранной системы координат. Эта система координат выбирается в списке СК на Панели свойств.


Поле Кривая

Поле, в котором отображается наименование кривой, выбранной для построения вектора.

Чтобы сменить кривую, укажите нужную кривую в окне модели или в Дереве построения.

В качестве кривой может быть выбрана пространственная кривая, ребро, линия эскиза или сегмент ломаной.

Выбор объектов в окне модели

Выбор объектов в Дереве построения


Группа переключателей Вектор

Группа переключателей для выбора одного из трех базисных векторов в точке кривой (в начальной точке вектора, см. рисунок). Выбранный базисный вектор определяет направление вектора в пространстве.

Базисные векторы в точке кривой

Базисные векторы взаимно перпендикулярны.

Касательный вектор и вектор главной нормали лежат в соприкасающейся плоскости, а вектор бинормали ей перпендикулярен.

Соприкасающаяся плоскость — это плоскость, стремящаяся принять положение плоскости, проходящей через три точки кривой М, М1, М2, при условии, что точки M1 и М2 стремятся к точке М (см. рис.).

Соприкасающаяся плоскость

Чтобы выбрать направление вектора, активизируйте нужный переключатель:

Касательный вектор,

Вектор главной нормали,

Вектор бинормали.


Группа Направление

Группа переключателей, позволяющая направить вектор в противоположную сторону.

Изменение направления немедленно отображается на фантоме вектора в окне модели.


Поле Объект

В этом поле отображается название объекта, указанного в качестве направляющего для вектора.

Чтобы сменить направляющий объект, укажите нужный объект в окне модели или в Дереве модели.

Выбор объектов в окне модели

Выбор объектов в Дереве построения

В качестве направляющего объекта может использоваться прямолинейный объект или плоская кривая: линия эскиза, дуга, окружность, ребро в виде дуги, окружности или эллипса.


Поле Объект

В этом поле отображается название объекта, указанного в качестве направляющего для вектора.

Чтобы сменить направляющий объект, укажите нужный объект в окне модели или в Дереве модели.

Выбор объектов в окне модели

Выбор объектов в Дереве построения

В качестве направляющего объекта может использоваться плоский объект или любая поверхность вращения, кроме сферической.


Опция Фиксировать положение

Служит для управления ориентацией вектора в пространстве.

– Если опция включена, то при изменении ориентации модели вектор поворачивается вместе с моделью.

– Если опция выключена, то при любом изменении положения модели вектор располагается в центре экрана и направлен к наблюдателю.


Поле Грань

В этом поле отображается название грани, указанной для построения вектора, перпендикулярного ей в заданной точке.


Способ построения

Список, из которого можно выбрать текущий способ построения вектора.

По двум вершинам

Угол в плоскости СК

По оси СК

По коэффициентам

По двум углам

По прямолинейному ребру, оси или перпендикулярно плоскости кривой

По оси цилиндра или перпендикулярно плоской грани, плоскости

Перпендикулярно грани в указанной точке

По базисному вектору в точке кривой

Перпендикулярно плоскости экрана


Группа переключателей Высота(способ определения)

Группа переключателей Высота
(способ определения)

Группа переключателей, позволяющая указать способ определения высоты спирали: по размеру, по объекту или по линии эскиза.

При выборе способа По размеру в поле Размер следует ввести высоту спирали в миллиметрах.

Выбор способа По объекту означает, что высота спирали определяется автоматически по положению указанного пользователем объекта (грани, плоскости, или точки). При этом необходимо выбрать нужный объект в Дереве построения или в окне модели.

Название объекта, выбранного для определения высоты спирали, отображается в справочном поле рядом с переключателем Объект.

Вы можете построить спираль, высота которой отличается от расстояния между ее опорной плоскостью и указанным объектом на определенную величину. Для этого введите требуемую величину (в миллиметрах) в поле Размер.

Затем с помощью переключателя Тип укажите, должна ли спираль «не доходить» до объекта или «выходить» за объект на заданное расстояние.

Выбор варианта По плоской кривой означает, что высота спирали определяется автоматически по длине указанной линии эскиза (спираль повторяет форму линии, а ось спирали является копией линии, полученной путем параллельного переноса линии эскиза, при котором ее начальная точка совмещается с точкой привязки спирали). Плоскость используемого эскиза должна быть перпендикулярна плоскости опорной грани.

Укажите нужную линию эскиза в окне модели. Название объекта будет показано в справочном поле рядом с переключателем Объект.

Если плоскость эскиза и плоскость оси спирали не параллельны, то спираль автоматически поворачивается так, чтобы эти плоскости стали параллельны.

Группа переключателей Высота доступна, если в списке Способ построения выбран вариант По числу витков и высоте или По шагу витков и высоте.


По умолчанию

Опция, включение которой означает, что все текущие настройки вкладки Параметры Панели свойств будут использоваться при создании следующих обозначений координационных осей этого же типа до конца сеанса работы.

При выключенной опции настройка распространяется только на текущий (создаваемый) объект.


По умолчанию

Опция, включение которой означает, что все текущие настройки вкладки Выступ 1 Панели свойств будут использоваться при создании следующих координационных осей этого же типа до конца сеанса работы. Настройка служит в качестве умолчательной только для параметров выступа за начальную точку (т1).

При выключенной опции настройка распространяется только на текущую (создаваемую) ось.


По умолчанию

Опция, включение которой означает, что все текущие настройки вкладки Выступ 2 Панели свойств будут использоваться при создании следующих координационных осей этого же типа до конца сеанса работы. Настройка служит в качестве умолчательной только для параметров выступа за конечную точку (т2).

При выключенной опции настройка распространяется только на текущую (создаваемую) ось.


Точка привязки

Поля координат точки привязки отверстия в системе координат плоскости.

По умолчанию значения координат равны нулю.

Вы можете ввести в эти поля значения с клавиатуры.

Чтобы задать положение отверстия мышью, расфиксируйте поля координат и укажите нужную точку в окне модели. Координаты выбранной точки будут определены автоматически и занесены в соответствующие поля.


Базовая точка

Поля координат базовой точки для деформации сдвигом.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Сдвиг по оси X

Поле значения сдвига в направлении оси X.

При указании мышью нового положения базовой точки величина сдвига определяются автоматически и заносится в это поле.

Возможен также ввод значения с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Сдвиг по оси Y

Поле значения сдвига в направлении оси Y.

При указании мышью нового положения базовой точки величина сдвига определяются автоматически и заносится в это поле.

Возможен также ввод значения с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Новое положение базовой точки

Поля координат нового положения базовой точки.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Первая вершина рамки

Поля координат первой вершины рамки.

При указании вершины мышью координаты точки определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Вторая вершина рамки

Поля координат второй вершины рамки.

При указании вершины мышью координаты точки определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Угол поворота

Поле угла поворота.

При указании мышью нового положения базовой точки угол определяются автоматически и заносится в это поле.

Возможен также ввод значения с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Базовая точка

Поля координат базовой точки для деформации поворотом.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Центр поворота

Поля координат центра поворота.

При указании центра мышью его координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Центр масштабирования

Поля координат центра деформации масштабированием.

При указании центра мышью его координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Масштаб по оси X

Поле для ввода коэффициента масштабирования в направлении оси X текущей системы координат.


Масштаб по оси Y

Поле для ввода коэффициента масштабирования в направлении оси Y текущей системы координат.

Ввод масштаба по оси Y невозможен, если среди выделенных объектов есть окружности или дуги окружностей или виды целиком. В этом случае выполнение операции производится со значением масштаба по оси Y, равным масштабу по оси X.


Панель просмотра ограничений

Панель, содержащая перечень ограничений, наложенных на выбранный объект.

Объекты документа, участвующие в выделенном ограничении, подсвечиваются в окне документа.

Чтобы удалить выделенное ограничение, нажмите кнопку Удалить.

Чтобы перейти к просмотру ограничений, наложенных на другой параметризованный объект, нажмите кнопку Указать заново на Панели специального управления и укажите нужный объект.


Опция Удалять оригинал

Включите эту опцию, чтобы объекты, сохраняемые в виде отдельной детали, были удалены из модели после завершении операции.

Опция доступна только при работе со сборкой (*.a3d).


Элемент управления Вершина

Переключатель, позволяющий задать точечный объект, расстоянием до которого определяется глубина отверстия. Переключатель доступен, если выбран способ задания глубины отверстия До вершины.

Укажите нужный точечный объект в окне или Дереве построения. Наименование выбранного объекта отображается в поле рядом с переключателем.

Чтобы сменить точечный объект, активизируйте переключатель Вершина, а затем укажите нужный точечный объект заново.

Выбор объектов в окне модели

Выбор объектов в Дереве построения


Элемент управления Поверхность

Переключатель, позволяющий задать поверхность, расстоянием до которой определяется глубина отверстия. Переключатель доступен, если выбран способ задания глубины отверстия До поверхности.

Укажите нужную грань или плоскость в окне модели; плоскость можно также указать в Дереве построения. Наименование выбранного объекта отображается в поле рядом с переключателем.

Чтобы сменить объект, активизируйте переключатель Поверхность, а затем укажите нужный плоский объект заново.

Выбор объектов в окне модели

Выбор объектов в Дереве построения


Элемент управления Положение плоскости обозначения

Позволяет сместить плоскость обозначения параллельно самой себе.

Элемент управления Положение плоскости обозначения доступен, если указано две или более точек обозначения. Например, положение плоскости линии-выноски можно перемещать после того, как задана точка, на которую указывает ответвление, и точка начала полки.

Чтобы начать перемещение положения плоскости обозначения, активизируйте переключатель Положение. Смещение плоскости обозначения можно задать произвольно или зафиксировать ее совпадение с имеющимся в модели объектом.

– Для произвольного задания положения плоскости обозначения переместите мышью характерную точку фантома плоскости. Фантом будет двигаться так, чтобы плоскость обозначения оставалась параллельной базовой, а все начальные точки ответвлений — на обозначаемом объекте (объектах).

Если перемещение плоскости обозначения невозможно, например, когда обозначаемый объект — точка или ребро, параллельное базовой плоскости, фантом остается на месте.

– Для фиксации положения плоскости обозначения укажите курсором объект фиксации — любой точечный, прямолинейный или плоский объект модели, расположенный так, чтобы через него можно было провести плоскость, параллельную базовой плоскости и пересекающую обозначаемый объект. Название выбранного объекта отображается в поле Положение.

Между плоскостью обозначения и объектом фиксации формируется ассоциативная связь. Благодаря этой связи плоскость следует за объектом фиксации при изменении положения последнего.

Повторное указание курсором объекта фиксации отменит фиксацию положения плоскости обозначения.


Панель Список объектов

Содержит перечень объектов модели, указанных для простановки допуска формы, линии-выноски, обозначения маркировки или клеймения.

При выделении объекта в списке соответствующее ему ответвление обозначения подсвечивается в окне модели.

Вы можете удалить выбранное ответвление, нажав кнопку Удалить в верхней части панели.


Группа переключателей Обход

Позволяет выбрать способ обхода углов при скруглении ребер.

Примеры результатов построения приведены в таблице.

Способы обхода углов
Способ | Результат построения
Обход без гладкой стыковки |
Обход с гладкой стыковкой |

Группа Обход доступна, если ребро скругляется способом Дугой окружности.


Размещение стрелок

Переключатель варианта размещения стрелок относительно выносных линий размера.

Если требуется, чтобы стрелки располагались внутри промежутка между выносными линиями, активизируйте переключатель Внутри.

Если требуется, чтобы стрелки располагались снаружи промежутка между выносными линиями, активизируйте переключатель Снаружи.

Если требуется, чтобы вариант размещения стрелок выбирался системой автоматически, активизируйте переключатель Авто.

Умолчательное размещение определяется настройкой стрелок и засечек размеров, сделанной для текущего документа.


Объект 1

Элемент управления, позволяющий задать первый объект для простановки размера.

Поле Объект 1 заполняется автоматически при выборе объекта в Дереве построения или в окне модели.

Чтобы сменить первый объект:

– при простановке радиального или диаметрального размера — укажите нужный объект,

– при простановке остальных размеров — активизируйте переключатель Объект 1 и укажите нужный объект.


Плоскость

Поле, позволяющее задать базовую плоскость размера — плоский объект, параллельно которому будет расположена плоскость простановки размера.

Заполняется автоматически при выборе плоского объекта в Дереве построения или в окне модели.

Чтобы сменить базовую плоскость размера, активизируйте переключатель Плоскость и укажите нужный объект.

Смотрите также

Зависимость значения размера от выбора базовой плоскости


Объект 2

Элемент управления, позволяющий задать второй объект для простановки размера.

Поле Объект 2 заполняется автоматически при выборе объекта в Дереве построения или в окне модели.

Поле доступно после задания первого объекта для простановки размера.

Чтобы сменить второй объект:

– при простановке радиального или диаметрального размера — укажите нужный объект,

– при простановке остальных размеров — активизируйте переключатель Объект 2 и укажите нужный объект.


Длина

Поле, позволяющее задать длину выносных линий размера.

Заполняется автоматически после задания объектов и базовой плоскости для простановки размера. Умолчательное значение длины выносных линий — 50,0 мм.

Чтобы изменить умолчательное значение, введите нужное значение длины с клавиатуры или задайте его при помощи счетчика (значение может быть как положительным, так и отрицательным).

Ввод значения в поле Длина возможен при отключенном автосоздании объекта.

При перемещении мышью одной из характерных точек на концах размерной линии значение длины определяется автоматически и заносится в это поле.


Стрелка

Список, позволяющий выбрать вид стрелки размера. Перечень стрелок, доступных для выбора, а также порядок следования стрелок в списке определяется настройкой фильтра стрелок, сделанной для текущего документа.


Стрелка 1

Список, позволяющий выбрать вид первой стрелки размера. Перечень стрелок, доступных для выбора, а также порядок следования стрелок в списке определяется настройкой фильтра стрелок, сделанной для текущего документа.


Стрелка 2

Список, позволяющий выбрать вид второй стрелки размера. Перечень стрелок, доступных для выбора, а также порядок следования стрелок в списке определяется настройкой фильтра стрелок, сделанной для текущего документа.


Положение надписи

Список, позволяющий выбрать вариант расположения размерной надписи относительно размерной линии. Умолчательное положение определяется настройкой положения надписи, сделанной для текущего документа.


Размещение текста

Список, позволяющий указать нужный способ размещения размерной надписи. Доступны следующие варианты.

Наименование | Описание
Автоматическое | При выборе этого способа по указанному пользователем положению размерной надписи автоматически определяется размещение текста: фиксированное, ручное или на полке.
Фиксированное | При выборе этого способа текст автоматически центрируется относительно размерной линии.
Ручное | При выборе этого способа положение надписи определяется пользователем.
На полке, влево На полке, вправо На полке, вверх На полке, вниз | При выборе одного из этих способов для размещения надписи формируется линия-выноска с полкой указанного направления. Пользователю требуется дополнительно указать точку начала полки.

Смотрите также

Управление размерной линией и надписью


Вершина угла

Поля координат вершины угла.

После указания вершины или двух сторон угла мышью координаты вершины вычисляются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Первая точка привязки размера

Поля координат точки, расположенной на первой стороне угла.

При указании сторон угла мышью координаты точки определяются автоматически и заносятся в эти поля (после того, как определено положение вершины угла).

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните в поле правой кнопкой мыши.


Вторая точка привязки размера

Поля координат точки, расположенной на второй стороне угла.

При указании сторон угла мышью координаты точки определяются автоматически и заносятся в эти поля (после того, как определено положение вершины и первой стороны угла).

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните в поле правой кнопкой мыши.


Точка на оси симметрии угла

Поля координат точки, расположенной на оси симметрии угла.

При указании оси мышью координаты точки определяются автоматически и заносятся в эти поля (после того, как определено положение вершины и первой стороны угла).

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните в поле правой кнопкой мыши.


Базовая точка размера

Поля координат точки для простановки размера от отрезка.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Точка положения размерной линии и начала выноски

Поля координат точки, определяющей положение размерной линии и начала выноски.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Точка положения размерной линии и надписи

Поля координат точки, определяющей положение размерной линии и надписи.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Первая точка привязки размера

Поля координат первой точки привязки размера.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Зазор/длина

Поле для ввода значения длины или зазора выносных линий размера. При нулевом значении выносные линии начинаются в точках привязки размера и могут иметь любую длину.

Подробнее...


Вторая точка привязки размера

Поля координат второй точки привязки размера.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Точка начала полки

Поля координат точки начала полки.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Угол наклона выносных линий

Поле угла наклона выносных линий линейного размера.

При «наклонении» размера мышью угол определяется автоматически и заносится в это поле.

Возможен также ввод значения координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Ориентация линейного размера

Переключатель, позволяющий выбрать ориентацию линейного размера: вертикальный или горизонтальный.


Ориентация линейного размера

По умолчанию создается размер, размерная линия которого параллельна линии, проходящей через точки привязки размера. Возможно также построение размера, размерная линия которого параллельна одной из осей текущей системы координат.

Чтобы выбрать требуемую ориентацию размера, вызовите из контекстного меню нужную команду или нажмите соответствующую кнопку в группе Тип на вкладке Размер Панели свойств.

Линейные размеры различной ориентации

Ориентацию размера можно выбрать до указания точек привязки, во время указания или после. Однако, необходимо иметь в виду следующее:

– Если размер проставляется к одному объекту, который является окружностью или эллипсом, то ориентация размера может быть только Параллельно объекту. Ручная смена ориентации автоматически отменяется.

– Если размер проставляется к двум объектам, из которых хотя бы один является окружностью, эллипсом или дугой окружности/эллипса, то ориентацию можно сменить только после указания объектов. Ориентация, выбранная до или во время указания объектов, автоматически меняется на Параллельно объекту.


Зазор/длина

Группа переключателей позволяет выбрать способ формирования зазора выносных линий.

Если требуется, чтобы заданное число определяло зазор между началом выносной линии и точкой привязки размера, активизируйте переключатель Зазор.

Если же введенное значение должно определять длину выносной линии, активизируйте переключатель Длина.

Подробнее...


Первая точка привязки размера от общей базы

Поля координат первой точки привязки размера от общей базы.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Точка отсчета высот

Поля координат точки, от которой нужно отсчитывать значения высот (точки нулевого уровня).

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Точка образмериваемого уровня

Поля координат точки, определяющую положение образмериваемого уровня.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Тип размера высоты

Список, позволяющий выбрать размер нужного назначения: для вида сверху с линией-выноской, для вида сверху непосредственно на изображении, для вида спереди или разреза.


Положение надписи

Поля координат точки, определяющей положение размерной надписи.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Угол излома

Поле, в которое можно ввести значение угла излома размерной линии (при создании и редактировании радиального размера с изломом).

Умолчательный угол излома задается в диалоге настройки отрисовки размеров.


Точка положения фиктивного центра

Поля координат точки, определяющей положение фиктивного центра дуги или окружности.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Опция По касательной

Служит для автоматического выбора гладко сопряженных граней рабочей поверхности кулачка.

Опция доступна, если указана ось кулачка.

Если опция включена, то при указании одной грани вместе с ней автоматически выбираются грани, которые сопрягаются с указанной и друг с другом по отрезкам прямых, параллельных оси кулачка. Не сопряженные друг с другом грани следует указать каждую отдельно щелчком мыши.

Если опция По касательной выключена, то все грани кулачка следует указывать по одной.


Группа Направление 1

Группа переключателей Направление 1 служит для изменения направления вращения первого объекта.

Направление, соответствующее активному в данный момент переключателю (Прямое направление или Обратное направление), показано на экране стрелкой.

Подробнее о выборе направления...


Группа Направление 2

Группа переключателей Направление 2 служит для изменения направления вращения второго объекта.

Направление, соответствующее активному в данный момент переключателю (Прямое направление или Обратное направление), показано на экране стрелкой.

Подробнее о выборе направления...


Переключатели Тип

Позволяют выбрать тип направления смещения выбранных полюсов сетки при линейном перемещении полюсов. Переключатели находятся на Панели свойств, если в списке Направление выбран вариант Вдоль многоугольника.

Доступны следующие типы направления смещения:

– По U — полюсы смещаются вдоль направления U,

– По V — полюсы смещаются вдоль направления V.

Возможны два варианта смещения по каждому из направлений. Нужный вариант выбирается с помощью группы переключателей Способ.


Переключатели Способ

Позволяют выбрать вариант перемещения полюсов сетки вдоль направления U/V при линейном перемещении полюсов. Переключатели находятся на Панели свойств, если в списке Направление выбран вариант Вдоль многоугольника.

Возможны два варианта перемещения по каждому из направлений:

• К последующему,

• К предыдущему.

При выборе первого варианта полюс перемещается вдоль сегмента сетки, соединяющего этот полюс с полюсом, следующим за ним по направлению U/V, а при выборе второго — против направления U/V.


Угол наклона оси

Поле угла наклона координационной оси.

При указании начальной и конечной точек мышью угол определяется автоматически и заносится в это поле.

Возможен также ввод значения с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Конечная точка оси

Поля координат конечной точки координационной оси.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Начальная точка оси

Поля координат начальной точки координационной оси.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Выступ 1

Поле для ввода величины выступа за начальную точку координационной оси.

Введите нужное значение или задайте его счетчиком.

Ввод нулевого значения означает отсутствие выступа.

а) | б)
Прямая координационная ось при вводе различных величин выступа 1: а) выступ не равен нулю, б) выступ равен нулю

а) | б)
Дуговая координационная ось при вводе различных величин выступа 1: а) выступ не равен нулю, б) выступ равен нулю

Умолчательное значение задается в диалоге настройки отрисовки координационной оси.

Если умолчательное значение было изменено на Панели свойств, то дальнейшие изменения этого значения возможны только с Панели свойств.


Выступ 2

Поле для ввода величины выступа за конечную точку координационной оси.

Введите нужное значение или задайте его счетчиком.

Возможен ввод нулевого значения.

а) | б)
Прямая координационная ось при вводе различных величин выступа 2: а) выступ не равен нулю, б) выступ равен нулю

а) | б)
Дуговая координационная ось при вводе различных величин выступа 2: а) выступ не равен нулю, б) выступ равен нулю

Умолчательное значение задается в диалоге настройки отрисовки координационной оси.

Если умолчательное значение было изменено на Панели свойств, то дальнейшие изменения этого значения возможны только с Панели свойств.


Длина оси

Поле длины оси. Длиной оси является расстояние между начальной (т1) и конечной точками (т2) координационной оси.

При указании характерных точек мышью длина определяется автоматически и заносится в это поле.

Возможен также ввод значения с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Смещение 1

Поле для ввода величины смещения марки от координационной оси.

Введите или задайте счетчиком расстояние, на которое марка 1 отстоит от координационной оси.

Введите ноль, если марка расположена на координационной оси.

а)

б)

Координационная ось при вводе различных величин смещения 1:
а) смещение не равно нулю, б) смещение равно нулю

Поле доступно, если активизирован переключатель Марка.


Смещение 2

Поле для ввода величины смещения марки от координационной оси.

Введите или задайте счетчиком расстояние, на которое марка 2 отстоит от координационной оси.

Введите ноль, если марка расположена на координационной оси.

а)

б)

Координационная ось при вводе различных величин смещения 2:
а) смещение не равно нулю, б) смещение равно нулю

Поле доступно, если активизирован переключатель Марка.


Смещение излома

Поле для ввода величины, характеризующей положение точки излома относительно начальной или конечной точки оси.

Введите или задайте счетчиком отношение расстояния от точки т1 или т2 до точки излома ко всей величине выступа (см. рис.). Отношение задается в процентах.

где

a, мм — расстояния от точки т1 или т2 до точки излома;

b, мм — величина выступа;

c, % — смещение излома.

Поле доступно, если активизирован переключатель Марка.

Умолчательное значение задается в диалоге настройки отрисовки координационной оси.

Если умолчательное значение было изменено на Панели свойств, то дальнейшие изменения этого значения возможны только с Панели свойств.


Группа Направление 2

Группа переключателей Направление 2 служит для изменения направления перемещения второго объекта.

Направление, соответствующее активному в данный момент переключателю (Прямое направление или Обратное направление), показано на экране стрелкой.

Подробнее о выборе направления...


Группа Дуга

Группа переключателей, позволяющая выбрать направление скругления.

Активизируйте нужный переключатель: Прямое направление или Обратное направление.

Изменение направления немедленно отображается на фантоме скругления в окне модели.

Скругление кривых...


Элемент управления Направление

Переключатель, позволяющий задать направление для продления грани — направление перемещения указанных кромок грани.

Переключатель доступен, если выбран тип продления По направлению.

Направление задается направляющим объектом или вектором.

В качестве направляющего объекта может использоваться любой прямолинейный или плоский объект.

Направление, задаваемое прямолинейным объектом — прямая, параллельная объекту.

Направление, задаваемое плоским объектом — прямая, перпендикулярная объекту.

Чтобы задать направление перемещения кромок, укажите в окне или Дереве построения направляющий объект или постройте вектор.

Выбор объектов в окне модели

Выбор объектов в Дереве построения

Построение вектора

Наименование выбранного объекта отображается в поле рядом с переключателем Направление. Если направление задано вектором, то в этом поле отображается слово «Вектор».

Чтобы сменить направляющий объект, активизируйте переключатель Направление, а затем укажите нужный направляющий объект или постройте вектор.

Все изменения немедленно отображаются на фантоме продления в окне модели.


Поле Расстояние 1

Поле для ввода расстояния от первого элемента до создаваемой точки.


Поле Расстояние 2

Поле для ввода расстояния от второго элемента до создаваемой точки.


Поле Расстояние

Служит для ввода или задания счетчиком расстояния от создаваемой точки до опорной точки в направлении, заданном направляющим объектом.

Расстояние при выборе направляющего объекта: а) прямолинейного, б) плоского
а) | б)

При указании точки мышью расстояние вычисляется и заносится в это поле.

Поле доступно, если определен объект в поле Направляющий объект.

Подробнее о построении переносом...


Стиль вершины

Список, из которого можно выбрать текущий стиль отображения точки или стиль отображения вершины пространственной кривой.

Для пространственной кривой этот список доступен, если на Панели свойств активен переключатель Отображение вершин.


Пунктир

Поле для ввода или задания счетчиком длины пунктира.

Умолчательное значение задается в диалоге настройки отрисовки координационной оси.

Если умолчательное значение было изменено на Панели свойств, то дальнейшие изменения этого значения возможны только с Панели свойств.


Поле Угол уклона

Поле угла уклона.

Вы можете ввести значение вручную или установить с помощью счетчика.


Переключатель Основание

Переключатель, позволяющий перейти к указанию основания уклона.

После активизации переключателя выберите нужную грань в окне модели.


Переключатель Грани

Переключатель, позволяющий перейти к указанию уклоняемых граней.

После активизации переключателя выберите нужные грани в окне модели.

Количество указанных граней отображается в справочном поле рядом с переключателем.


Поле Расстояние

Позволяет задать значение смещения плоскости сечения относительно базовой плоскости. Присутствует на Панели свойств, если для задания параметров шага отсечения выбран способ Смещенная плоскость.

Значение можно ввести с клавиатуры или задать с помощью счетчика.

При ручном смещении плоскости сечения значение в поле автоматически изменяется.


Поле Угол

Позволяет задать значение угла поворота плоскости сечения относительно выбранной оси. Присутствует на Панели свойств, если для задания параметров шага отсечения выбран способ Повернутая плоскость.

Значение можно ввести с клавиатуры или задать с помощью счетчика.

При ручном повороте плоскости сечения значение в поле автоматически изменяется.


Поле Ось

Служит для отображения имени объекта, выбранного в качестве оси вращения плоскости сечения. Присутствует на Панели свойств, если для задания параметров шага отсечения выбран способ Повернутая плоскость.

Осью вращения может быть имеющийся в модели линейный объект (ребро или ось). Объект указывается в Дереве построения или в окне модели.


Группа элементов Базовая плоскость

Служит для выбора объекта, используемого в качестве базовой плоскости при размещении плоскости сечения способом Смещенная плоскость или Повернутая плоскость. Присутствует на Панели свойств, если для задания параметров шага отсечения выбран один из этих способов.

Чтобы выбрать вариант задания базовой плоскости, активизируйте один из следующих переключателей:

– Плоскость модели — в качестве базовой плоскости выбирается плоскость или плоская грань, имеющаяся в модели,

– Плоскость сечения предыдущего шага — в качестве базовой плоскости выбирается плоскость сечения, заданная на предыдущем шаге отсечения; вариант доступен, если сечение содержит шаги, которые могут использоваться для задания базовой плоскости.

При активном переключателе Плоскость модели на Панели свойств присутствует поле отображения имени объекта, выбранного в качестве базовой плоскости. Объект указывается в Дереве построения или в окне модели.

Если активизирован переключатель Плоскость сечения предыдущего шага, то на Панели свойств находится раскрывающийся список Выбор шага, содержащий перечень всех предыдущих шагов отсечения, кроме:

– шагов, параметры которых заданы способом Параллелепипед или Зона,

– шагов, в названии которых имеются символы (!).

Выберите из списка нужный шаг.


Панель Список ребер

Панель, содержащая список «поперечных» ребер линейчатой поверхности, поверхности соединения или линейчатой обечайки.

Панель Список ребер присутствует на Панели свойств, если опция Автоопределение выключена.

При выделении строки списка соответствующее ей ребро подсвечивается в окне модели и наоборот.

Над списком находятся кнопки для управления ребрами:

Кнопки Вставить перед текущим ребром или Вставить после текущего ребра позволяют добавить ребро перед выделенным или после выделенного.

Кнопка Удалить ребро позволяет удалить выделенное ребро.

Удаление ребер возможно, если их количество — три или больше.

Подробнее об управлении разбиением поверхности на грани...


Элемент управления Кромки

Переключатель, позволяющий задать кромку грани или набор кромок, за пределы которых должна продлеваться грань.

Укажите в окне модели кромку грани или набор кромок. Если требуется продлить грань за пределы всех кромок, то укажите саму грань.

Повторное указание объекта отменяет его выбор.

Название выбранного объекта или количество выбранных объектов отображается в поле рядом с переключателем Кромки на Панели свойств.

Чтобы сменить объекты продления грани, активизируйте переключатель Кромки и укажите нужные объекты.

Выбор объектов в окне модели


Точка привязки таблицы

Поля координат точки привязки таблицы.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните в поле правой кнопкой мыши.


Угол наклона

Поле, в котором можно ввести или выбрать из списка угол наклона таблицы или строк текста.

Для вызова меню геометрического калькулятора щелкните в поле правой кнопкой мыши.


Точка привязки

Поля координат точки привязки текста.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните в поле правой кнопкой мыши.


Поле ввода текста ссылки

Поле позволяет задать текстовую строку, которая будет отображаться в ячейках Материал и Масса основной надписи чертежа в том случае, если таблица исполнений, размещенная в чертеже, содержит столбцы с соответствующими им свойствами.

Поле доступно только при создании или редактировании ассоциативной таблицы.

Введите текст в поле и нажмите клавишу <Enter>.

Смотрите также

Связь основной надписи чертежа с ассоциативной таблицей исполнений


Элементы дополнительных обозначений

Группа переключателей, позволяющая выбрать вид добавляемого элемента при создании и редактировании дополнительных обозначений координационной оси.

Добавить указатель ориентации оси

Добавить марку

Добавить текст

После активизации переключателя на экране появляется фантом элемента, а в местах возможного присоединения дополнительных обозначений — черные точки (см. рис.).

Элемент Указатель ориентации оси строится по нормали к координационной оси со стрелкой, направленной от основной марки.

Чтобы добавить следующий элемент, следует вновь активизировать переключатель.

– В процессе построения оси переключатели становятся доступны по завершении построения оси при отключенном режиме Автосоздание на Панели специального управления. Если построения ведутся в режиме Автосоздание, его следует отключить до того, как будет указано расположение конечной точки оси (т2).

– В режиме редактирования переключатели доступны всегда.


Первая точка эллипса

Поля координат точки эллипса.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Вторая точка эллипса

Поля координат точки эллипса.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Третья точка касания эллипса

Поля координат точки эллипса.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Длина первой полуоси

Справочное поле, в котором отображается длина первой полуоси создаваемого эллипса.


Длина второй полуоси

Справочное поле, в котором отображается длина второй полуоси создаваемого эллипса.


Начальная точка диагонали прямоугольника

Поля координат начальной точки диагонали прямоугольника, описанного вокруг эллипса.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Конечная точка диагонали прямоугольника

Поля координат конечной точки диагонали прямоугольника, описанного вокруг эллипса.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Длина первой полуоси

Поле длины первой полуоси создаваемого эллипса.

При указании характерных точек эллипса мышью длина первой полуоси определяется автоматически и заносится в это поле.

Возможен также ввод значения с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Угол наклона первой полуоси

Поле угла наклона первой полуоси создаваемого эллипса.

При указании характерных точек эллипса мышью угол наклона определяется автоматически и заносится в это поле.

Возможен также ввод значения с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Длина второй полуоси

Поле длины второй полуоси создаваемого эллипса.

При указании характерных точек эллипса мышью длина второй полуоси определяется автоматически и заносится в это поле.

Возможен также ввод значения с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Центр эллипса

Поля координат центра создаваемого эллипса.

При указании центра мышью координаты точки определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Конечная точка первой полуоси

Поля координат конечной точки первой полуоси создаваемого эллипса.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Конечная точка второй полуоси

Поля координат конечной точки второй полуоси создаваемого эллипса.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Середина стороны описанного параллелограмма

Поля координат середины стороны параллелограмма, описанного вокруг эллипса.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Вершина описанного параллелограмма

Поля координат вершины параллелограмма, описанного вокруг эллипса.

При указании вершины мышью координаты точки определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Первая вершина описанного параллелограмма

Поля координат первой вершины параллелограмма, описанного вокруг эллипса.

При указании вершины мышью координаты точки определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Вторая вершина описанного параллелограмма

Поля координат второй вершины параллелограмма, описанного вокруг эллипса.

При указании вершины мышью координаты точки определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Третья вершина описанного параллелограмма

Поля координат третьей вершины параллелограмма, описанного вокруг эллипса.

При указании вершины мышью координаты точки определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Угол наклона первой полуоси

Справочное поле, в котором отображается угол наклона первой полуоси создаваемого эллипса.


Точка на эллипсе

Поля координат точки эллипса.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Первая точка касания эллипса

Справочные поля, в которых отображаются координаты первой точки касания эллипса.


Вторая точка касания эллипса

Справочные поля, в которых отображаются координаты второй точки касания эллипса.


Список Исполнение

Список позволяет выбрать исполнение модели, которая вставляется (вставлена) в текущую модель, использована для создания ассоциативного вида в чертеже или для подключения к объекту спецификации.

Список отображается на Панели свойств, если в выбранной модели имеются исполнения.

Список содержит полный перечень исполнений данной модели. Обозначения всех исполнений, как зависимых, так и независимых, находятся в списке на одном уровне иерархии.


Радиус эквидистанты слева

Поле, в котором можно ввести или выбрать из списка радиус эквидистанты, расположенной слева от объекта.


Радиус эквидистанты справа

Поле, в котором можно ввести или выбрать из списка радиус эквидистанты, расположенной справа от объекта.


Группа переключателей Сглаживание

Позволяет выбрать способ сглаживания углов при скруглении трех или более ребер, имеющих общую точку.

Примеры результатов построения приведены в таблице.

Способы сглаживания углов
Способ | Результат построения
Сглаживать углы |
Не сглаживать углы |


Траектория

Переключатель, позволяющий перейти к указанию объекта, являющегося траекторией элемента по сечениям.

В качестве траектории может использоваться любая пространственная или плоская кривая, например, ребро, спираль, сплайн, эскиз.

После активизации переключателя выберите нужный объект в Дереве построения или в окне модели.

Название указанного объекта отображается в справочном поле рядом с переключателем.


Сечение

Переключатель, позволяющий перейти к указанию эскиза-сечения.

После активизации переключателя выберите нужный эскиз в Дереве построения или в окне модели.

Название указанного объекта отображается в справочном поле рядом с переключателем.


Поле Длина

Поле для ввода значения удлинения грани за указанные кромки.

Это поле доступно, если выбран способ продления грани На заданную длину.

Величину удлинения грани можно задать также с помощью характерной точки.


Переключатель Сменить направление

Позволяет направить продление грани в противоположную сторону.

Переключатель доступен, если выбран тип продления По направлению.

Чтобы сменить направление продления грани, нажмите переключатель Сменить направление.

После нажатия переключателя продление грани меняет свое направление — это немедленно отображается на фантоме в окне модели.


Группа переключателей Тип продления

Группа переключателей для выбора типа продления грани:

– Той же поверхностью,

– По касательной,

– По направлению.

Кроме того, для выбора нужного типа продления грани можно вызвать соответствующую команду контекстного меню.

Подробнее о типах продления грани...


Элемент управления Направляющий объект

Элемент управления, позволяющий задать направляющий объект для элемента выдавливания или поверхности выдавливания.

Если в качестве сечения используется эскиз или плоская грань, то этот объект автоматически выбирается в качестве направляющего.

Чтобы сменить или задать направляющий объект, активизируйте переключатель Направляющий объект. Затем:

– Укажите в Дереве построения или в окне модели прямолинейный или плоский объект.

• Прямолинейный объект задает направление выдавливания, параллельное себе.

• Плоский объект задает направление выдавливания, перпендикулярное своей плоскости.

Название выбранного объекта появляется в поле Направляющий объект.

– Или постройте вектор. Для запуска команды построения вектора нажмите кнопку Вектор на Панели специального управления. Если направление задано вектором, в поле Направляющий объект отображается слово «Вектор».

После того как направляющий объект задан, в окне модели стрелкой показывается прямое направление выдавливания. Выдавливание может производиться в прямом направлении, в обратном, в двух или от средней плоскости. Для выбора направления используйте список Направление.


Опция Отсекать

Опция, позволяющая отсечь элемент выдавливания или вращения плоскостью:

– для элемента выдавливания — проходящей через указанную вершину перпендикулярно направлению выдавливания,

– для элемента вращения — проходящей через указанную вершину и ось вращения.

В этом случае вне зависимости от формы сечения получается плоский торец элемента.

Опция Отсекать присутствует на Панели свойств, если в списке Способ выбран вариант До вершины.

Подробнее о выдавливании до вершины…

Подробнее о вращении до вершины…


Элемент управления Вершина

Элемент управления, позволяющий задать точечный объект для ограничения глубины выдавливания при построении элемента (либо поверхности) выдавливания. Элемент управления Вершина присутствует на Панели свойств, если в списке Способ выбран вариант До вершины.

Чтобы сменить или задать точечный объект, активизируйте переключатель Вершина и укажите нужный объект в Дереве построения или в окне модели. Название выбранного объекта появляется в поле Вершина.

Автоматически вычисляется такая глубина выдавливания, при котором торец элемента занимает положение, ближайшее к указанной вершине.

Если требуется отсечь элемент плоскостью, проходящей через указанную вершину перпендикулярно направлению выдавливания, включите опцию Отсекать.

Торец элемента может не доходить до указанной вершины или заходить за нее на указанное расстояние. Для ввода расстояния используйте поле Расстояние, а для выбора направления его отсчета — группу переключателей Тип.

Подробнее о выдавливании до вершины...


Элемент управления Грань

Элемент управления, позволяющий задать грань или плоскость для ограничения глубины выдавливания при построении элемента (либо поверхности) выдавливания. Элемент управления Грань присутствует на Панели свойств, если в списке Способ выбран вариант До поверхности.

Чтобы сменить или задать грань, активизируйте переключатель Грань и укажите нужный объект в Дереве построения или в окне модели. Название выбранного объекта появляется в поле Грань.

Элемент выдавливается до указанной поверхности. Торец элемента имеет форму поверхности.

Торец элемента может не доходить до указанной грани или заходить за нее на указанное расстояние. Для ввода расстояния используйте поле Расстояние, а для выбора направления его отсчета — группу переключателей Тип.

Подробнее о выдавливании до поверхности...


Угол уклона

Введите значение угла уклона или задайте его счетчиком.


Элемент Грани кулачка

Служит для выбора граней, составляющих рабочую поверхность кулачка.

При нажатой кнопке Грани кулачка система ожидает указания граней. Если включена опция По касательной, то автоматически выбираются грани, гладко сопрягающиеся с указанной.

После указания в поле рядом с кнопкой появляется их количество.

Объекты, которые могут быть использованы для сопряжения Кулачок – толкатель...


Элемент Грань толкателя

Служит для выбора объекта, являющегося рабочей поверхностью толкателя.

При нажатой кнопке Грань толкателя система ожидает указания рабочей грани или вершины толкателя.

Объекты, которые могут быть использованы для сопряжения Кулачок – толкатель...


Поле Угол вращения

Поле для ввода угла вращения при ориентировании ЛСК способом Система углов Эйлера.


Поле Угол прецессии

Поле для ввода угла прецессии при ориентировании ЛСК способом Система углов Эйлера.

Задание угла прецессии возможно, если угол нутации больше 0°.


Опция Закрашивать сечение

Управляет отображением фантомной грани (или граней) в месте сечения модели созданной плоскостью (набором плоскостей).

При включенной опции фантомная грань (или грани) отображается в модели, при отключенной — не отображается.

Включение/отключение опции выполняется для всего создаваемого сечения, а не для отдельных его шагов, т.е. фантомные грани отображаются (либо не отображаются) для всех шагов отсечения.

Фантомные грани не являются объектами и отображаются только при включенном режиме сечения модели. Эти грани, а также их ребра и вершины не могут использоваться при выполнении каких-либо операций в модели. Они недоступны для указания.

При создании или редактировании сечения вы можете настроить цвет и оптические свойства фантомных граней с помощью группы элементов Назначить цвет вкладки Свойства.


Автоматическое определение способа построения скругления

Автоматическое определение способа
построения скругления

Если поверхность скругления пересекается с соседними гранями, то возможно два варианта выполнения операции: с сохранением кромки или с сохранением поверхности.

Выполнение операции скругления (поверхность скругления выделена цветом):
а) с сохранением кромки; б) с сохранением поверхности.

Автоматический выбор способа построения скругления в случаях его пересечения с соседними гранями заключается в следующем.

Если для выполнения операции указано несколько ребер или если включена опция Продолжать по касательным ребрам, то возможно получение «комбинированного» скругления, одни участки которого построены с сохранением кромки, а другие — с сохранением поверхности.

Если автоопределение отключено, способом построения можно управлять с помощью опции Сохранять кромку.

При включенной опции все скругления будут создаваться с сохранением кромки. Однако, если для каких-либо из указанных ребер это окажется невозможным, невозможным будет и выполнение операции.

При выключенной опции Сохранять кромку все скругления создаются с сохранением поверхности.


Поле Хорда

Поле для ввода значения хорды при построении скругления способом С постоянной хордой.


Поле Коэффициент

Поле для ввода значения коэффициента конической кривой К при построении скругления способом С коэффициентом. Значение коэффициента К может изменяться в пределах от 0 до 1 (0<К<1).


Сохранять кромку

Опция, включение которой позволяет построить скругление с сохранением кромки. При выключенной опции создается скругление с сохранением поверхности.

Смотрите также

Автоопределение способа построения скругления


Способ построения скругления

Группа переключателей, позволяющая выбрать способ построения скругления с постоянным радиусом.

Чтобы выбрать нужный способ, активизируйте соответствующий переключатель:

Дугой окружности

Дугой эллипса

С коэффициентом

С постоянной хордой


Продолжать по касательным ребрам

Если несколько ребер, которые требуется скруглить, гладко соединяются (имеют общую касательную в точке соединения), укажите одно из них и включите опцию Продолжать по касательным ребрам. В этом случае система автоматически определит другие ребра, на которые требуется распространить скругление.


Группа Тип скругления

Группа переключателей, позволяющая выбрать тип скругления: с постоянным или с переменным радиусом.


Радиус скругления

Поле, в котором можно ввести или выбрать из списка значение радиуса скругления.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Поле Полуось 1 (2)

Поле для ввода значения первой (второй) полуоси эллипса при построении скругления способом Дугой эллипса.


Поле Радиус скругления

Поле радиуса скругления.

Вы можете ввести значение с клавиатуры или задать с помощью счетчика.


Опция Остановка

Включение опции позволяет задать параметры остановки скругления.

Опция доступна, если скругляется одно ребро или одна цепочка ребер. При скруглении нескольких ребер или цепочек остановка невозможна.


Опция Усечение по объекту

Включение опции позволяет усечь скругление плоскостью указанного плоского объекта. При отключенной опции усечение производится плоскостью, перпендикулярной скругляемому ребру.

Опция присутствует на Панели свойств, если в списке на панели Точки остановки выделена точка, связанная с плоским объектом.


Точки остановки

Панель, содержащая таблицу с параметрами точек остановки скругления.

В таблице представлены номера точек остановки скругления, расстояния до них от начальной точки скругляемого ребра и информация об ассоциативной связи с объектом.

Чтобы отредактировать точку, выделите соответствующую ей строку в таблице.

– Если точка не связана с объектом, ее можно переместить вдоль ребра, изменив значение в колонке % или Длина. Для этого сделайте одинарный или двойной щелчок в нужной ячейке. После одинарного щелчка возможен ввод в ячейку значения с клавиатуры, а после двойного — ввод с клавиатуры или выбор с помощью счетчика.

Если точка связана с объектом, то ее перемещение невозможно. Для отмены связи следует отключить опцию в колонке Связь с объектом.

– Чтобы задать (или сменить) объект для связи, укажите нужный объект в окне модели:

• точечный объект, лежащий на скругляемом ребре,

• плоский объект, плоскость которого пересекает скругляемое ребро,

• одну из вершин скругляемой цепочки ребер.

– Чтобы удалить точку из таблицы, выделите ее и нажмите кнопку Удалить, расположенную над таблицей.

Подробнее об остановке скругления...


Элемент Объект

Служит индикатором наличия ассоциативной связи точки остановки с точечным или плоским объектом.

Если связь есть, то на переключателе Объект отображается «галочка», а в поле Объект — наименование объекта.

Для отмены связи следует щелкнуть на переключателе.

Для восстановления связи следует указать объект заново.


Элемент управления Условия фильтрации

Элементы управления — поле и кнопки над полем, позволяющие формировать список условий фильтрации.

Поле служит для отображения условий фильтрации. Каждое условие состоит из трех частей: <Свойство (или Имя столбца)> <Условие> <Значение>.

Если поле пусто, то условия не заданы.

Кнопка Добавить условие позволяет добавить условие в список.

После нажатия кнопки в поле появляется часть условия по умолчанию, у которого значение и условие не задано. При этом становятся доступны элементы Свойство (Колонка), Условие, Значение, позволяющие задать эти параметры.

Кнопка Удалить условие позволяет удалить выделенное условие.


Элемент управления Набор поверхностей 1

Переключатель, позволяющий задать первый объект пересечения — грань или плоскость.

Укажите объект пересечения в окне или в Дереве построения.

Выбор объектов в окне модели

Выбор объектов в Дереве построения

Название указанного объекта отображается в поле рядом с переключателем.

Чтобы добавить объекты пересечения в первый набор, активизируйте переключатель Набор поверхностей 1 и укажите нужные грани или плоскости. В поле рядом с переключателем отображается количество объектов набора.

Если в набор поверхностей нужно добавить все грани какого-либо тела или поверхности, укажите это тело или поверхность в Дереве построения.


Элемент управления Набор поверхностей 2

Переключатель, позволяющий задать второй объект пересечения — грань или плоскость — или несколько объектов.

Укажите объект пересечения или несколько объектов в окне или в Дереве построения.

Выбор объектов в окне модели

Выбор объектов в Дереве построения

Название объекта или количество объектов отображается в поле рядом с переключателем.

Если в набор поверхностей нужно добавить все грани какого-либо тела или поверхности, укажите это тело или поверхность в Дереве построения.


Переключатель Выбор полюсов

Позволяет выбрать полюсы, положение которых требуется изменить вращением, перемещением, масштабированием или выравниванием.

Чтобы выбрать полюсы, при нажатом переключателе выполните следующие действия.

Подведите курсор к нужному полюсу. Когда рядом с курсором появится символ вершины, щелкните мышью. Выбранный полюс подсветится. Выберите последовательно все нужные полюсы. Если требуется отменить выбор какого-либо полюса, повторно щелкните по нему мышью.

Вы можете выбирать как отдельные полюсы, так и ряды полюсов. Выбор ряда означает, что все полюсы этого ряда добавляются в набор выбранных полюсов.

Чтобы выбрать ряд полюсов, подведите курсор к сегменту этого ряда. Когда рядом с курсором появится символ пространственной кривой, щелкните мышью. Все полюсы и сегменты выбранного ряда подсветятся. Повторный щелчок мышью по сегменту ряда отменяет выбор полюсов.

Полюсы выбранного ряда могут быть также выбраны по отдельности (до или после выбора ряда). Эти полюсы остаются выбранными после отмены выбора ряда.

Для выбора полюсов можно также использовать следующие команды контекстного меню:

– Выбор полюсов (порядок указания полюсов после вызова команды аналогичен описанному выше),

– Выбрать все полюсы,

– Отменить выбор полюсов,

– Инвертировать выбор полюсов.


Элемент Компонент 1

Служит для выбора вращающегося объекта.

При нажатой кнопке Компонент 1 система ожидает указания объекта.

После указания в поле компонента появляется наименование объекта.


Элемент Компонент 1

Служит для выбора первого объекта — тела или компонента модели.

При нажатой кнопке Компонент 1 система ожидает указания объекта.

После указания в поле компонента появляется наименование объекта.


Элемент Компонент 2

Служит для выбора второго объекта — тела или компонента модели.

При нажатой кнопке Компонент 2 система ожидает указания объекта.

После указания в поле компонента появляется наименование объекта.


Элемент Компонент 2

Служит для выбора перемещающегося объекта.

При нажатой кнопке Компонент 2 система ожидает указания объекта.

После указания в поле компонента появляется наименование объекта.


Поле координаты X

При указании положения вершины курсором мыши поле отображает текущее значение координаты вершины по оси X.

Переключатель рядом с полем показывает состояние фиксированности значения координаты и позволяет управлять им. Значок «галочка» означает, что значение не фиксировано.

Чтобы зафиксировать текущее значение координаты, следует активизировать поле, например клавиатурной комбинацией <Alt>+<x> или используя клавишу табуляции, и нажать <Enter>. Значок «галочки» поменяется на «крестик». Чтобы отменить фиксацию, следует щелкнуть по значку мышью.

Чтобы явно задать значение координаты, следует активизировать поле, ввести число с клавиатуры и нажать <Enter>. Введенное значение автоматически будет зафиксировано.

Смотрите также

Фиксация параметров


Поле координаты Y

При указании положения вершины курсором мыши поле отображает текущее значение координаты вершины по оси Y.

Переключатель рядом с полем показывает состояние фиксированности значения координаты и позволяет управлять им. Значок «галочка» означает, что значение не фиксировано.

Чтобы зафиксировать текущее значение координаты, следует активизировать поле, например клавиатурной комбинацией <Alt>+<y> или используя клавишу табуляции, и нажать <Enter>. Значок «галочки» поменяется на «крестик». Чтобы отменить фиксацию, следует щелкнуть по значку мышью.

Чтобы явно задать значение координаты, следует активизировать поле, ввести число с клавиатуры и нажать <Enter>. Введенное значение автоматически будет зафиксировано.

Смотрите также

Фиксация параметров


Поле координаты Z

При указании положения вершины курсором мыши поле отображает текущее значение координаты вершины по оси Z.

Переключатель рядом с полем показывает состояние фиксированности значения координаты и позволяет управлять им. Значок «галочка» означает, что значение не фиксировано.

Чтобы зафиксировать текущее значение координаты, следует активизировать поле, например клавиатурной комбинацией <Alt>+<z> или используя клавишу табуляции, и нажать <Enter>. Значок «галочки» поменяется на «крестик». Чтобы отменить фиксацию, следует щелкнуть по значку мышью.

Чтобы явно задать значение координаты, следует активизировать поле, ввести число с клавиатуры и нажать <Enter>. Введенное значение автоматически будет зафиксировано.

Смотрите также

Фиксация параметров


Группа переключателей Смещение

Позволяет выбрать способ смещения создаваемой вершины.

– Активизируйте переключатель Смещение от предыдущей вершины, чтобы вершина смещалась от предыдущей на заданное расстояние вдоль линии построения.

– Активизируйте переключатель Смещение от опорной поверхности, чтобы вершина смещалась от опорной грани на заданный отступ.

Подробнее...


Поле Расстояние

Поле для ввода значения расстояния, на которое смещается создаваемая (или редактируемая) вершина кривой от предыдущей вершины.

Знак перед значением расстояния определяет, с какой стороны от предыдущей вершины на линии построения будет располагаться текущая вершина.

Если положение вершины задано указанием точки в окне модели, то в поле отображается текущее значение расстояния от предыдущей вершины до проекции положения курсора на линию построения вершины.

– Если вершина не связана с точечным объектом, то вы можете изменить это расстояние. Для этого введите в поле нужное значение и нажмите клавишу <Enter>.

– Если вершина связана с точечным объектом, то поле недоступно для ввода.

Подробнее об ассоциативной связи вершин с точечными объектами...

Поле Расстояние присутствует на Панели свойств, если в группе Смещение активен переключатель Смещение от предыдущей вершины.


Поле Отступ

Поле для ввода значения отступа создаваемой (или редактируемой) вершины кривой от опорной грани.

Знак перед значением отступа определяет, с какой стороны от опорной грани будет располагаться вершина.

Подробнее об определении положения вершины при ее смещении от опорной грани...

Если положение вершины задано указанием точки в окне модели, то в поле отображается текущее значение отступа проекции положения курсора на линию построения от опорной грани.

– Если вершина не связана с точечным объектом, то вы можете изменить это значение. Для этого введите в поле нужное число и нажмите клавишу <Enter>.

– Если вершина связана с точечным объектом, то поле недоступно для ввода.

Подробнее об ассоциативной связи вершин с точечными объектами...

Поле Отступ присутствует на Панели свойств, если в группе Смещение активен переключатель Смещение от опорной поверхности.


Опция Фиксировать положение

Опция присутствует на Панели свойств, если в группе Способ активен переключатель В плоскости экрана. В этом случае для распознавания сети, образуемой точками пласта, все точки проецируются на плоскость, параллельную плоскости экрана. Затем в этой плоскости разыскиваются четырехугольные ячейки сети.

Подробнее о распознавании сети точек...

– Если опция Фиксировать положение включена, то поверхность фиксируется в той форме, которая соответствует текущему положению модели.

– Если опция Фиксировать положение отключена поверхность перестраивается всякий раз после изменения ориентации модели.


Опция Сохранять положение

Позволяет указать, требуется ли сохранение положения объекта в абсолютной системе координат модели после переноса в другую систему координат.

– Если опция включена, то выполняется пересчет параметров объекта относительно новой системы координат. Благодаря этому положение объекта в модели после замены системы координат сохранится.

– Если опция выключена, то значения параметров объекта сохраняются, и после замены системы координат его положение в модели изменится.

Пересчет параметров ломаной, детали-заготовки, импортированного тела или поверхности не производится. Поэтому в результате замены системы координат эти объекты изменяют свое положение вне зависимости от состояния опции Сохранять положение.

Объект может иметь ассоциативные связи с другими объектами, например, дуга окружности, построенная по трем вершинам. В результате замены системы координат положение такого объекта не изменяется вне зависимости от состояния опции Сохранять положение.


Панель Библиотека

Панель, содержащая название библиотеки фрагментов и список ее разделов.

Выберите нужный раздел, щелкнув по нему мышью. Ниже в окне появится список фрагментов раздела.

Укажите нужный фрагмент в списке. Вставьте фрагмент в документ.


Опция Независимое размещение

Включите эту опцию, чтобы эскиз не был связан с плоскостью, выбранной для его размещения. Опция становится доступной после отключения автосоздания объекта и выбора базовой плоскости эскиза.

При включении опции эскиз сохраняет свое положение в пространстве, но его связь с базовой плоскостью разрывается (подсветка базовой плоскости в окне модели исчезает, а ее имя удаляется из поля Базовая плоскость). Отключение опции восстанавливает связь эскиза с базовой плоскостью.

При включенной опции элементы задания положения эскиза недоступны.


Угол наклона

Поле угла поворота вставляемого объекта.

При указании угла поворота мышью его значение определяется автоматически и заносится в это поле.

Возможен также ввод значения с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Базовая точка

Поля координат точки, необходимой для выполнения команды (например, точки вставки библиотечного объекта т.п.).

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Базовая точка

Поля координат точки, необходимой для выполнения команды (например, базовой точки для выравнивания линий-выносок и т.п.).

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Панель Список частей

Панель, содержащая список частей тела (или тел), получившихся в результате выполнения операции. Эта панель присутствует на Панели свойств, если выключена опция Все.

Список частей имеет вид таблицы, первая колонка которой содержит номер тела и части, а вторая — опцию Оставить. Включенная опция означает, что часть тела будет оставлена в модели, а отключенная — что часть будет исключена.

Отключите или включите нужные опции.

Исключенные части тел как бы отсутствуют в модели: они не отображаются на экране, не могут использоваться при построении других объектов, не учитываются при вычислении МЦХ, не передаются в ассоциативные виды модели и в результирующие файлы при экспорте в другие форматы и т.д.

В то же время информация об исключенных частях тел не удаляется из файла модели, благодаря чему впоследствии набор частей можно изменить.

Части тела отображаются на экране в виде фантомов разных цветов:

– оставленные части — цветом подсветки (по умолчанию — красный),

– исключенные части — серым цветом,

– часть, выделенная в Списке частей — цветом выделения (по умолчанию — зеленый),

– не затронутые операцией части редактируемых тел — голубым цветом.

Части тела можно выбирать не только в списке, но и в окне модели: чтобы исключить оставленную или оставить исключенную часть, щелкните на ней мышью.

Если нужно оставить или исключить большинство частей, воспользуйтесь кнопками Выбрать все части и Отменить выбор для всех частей, расположенными над списком или одноименными командами контекстного меню.


Таблица параметров вершин ломаной

Каждая строка таблицы содержит следующие параметры вершины:

– номер,

– признак ассоциативной связи с точечным объектом — значок связи,

– признак того, что вершина была создана с помощью команды Точка — значок связи и значок вершины,

– пространственные координаты,

– радиус скругления сегментов ломаной в этой вершине.

Элементы управления таблицы позволяют выполнять следующие действия с вершинами ломаной:

– читать из файла значения координат вершин и радиусы скруглений,

– сохранять в файл содержание таблицы параметров для последующего использования,

– создавать новые вершины,

– изменять значения параметров существующих в таблице вершин,

– удалять вершины сплайна,

– удалять связь вершины с опорной точкой.

Подробнее о приемах работы с таблицей параметров вершин...


Параметры скругления с переменным радиусом

Панель, содержащая таблицу параметров скругления с переменным радиусом.

В таблице представлены номера точек указанных для построения скругления, расстояния до них от начальных точек соответствующих ребер и значения радиусов скругления в этих точках.

Чтобы добавить в таблицу новую точку, укажите ее в окне модели.

Чтобы удалить точку из таблицы, выделите ее и нажмите кнопку Удалить, расположенную над таблицей.

Для редактирования таблицы сделайте одинарный или двойной щелчок в нужной ячейке. После одинарного щелчка возможен ввод в ячейку значения с клавиатуры, а после двойного — ввод с клавиатуры или выбор с помощью счетчика.

Подробнее о построении скругления с переменным радиусом...


Таблица параметров вершин сплайна

Каждая строка таблицы содержит следующие параметры вершины:

– номер,

– признак ассоциативной связи с точечным объектом — значок связи,

– признак того, что вершина была создана с помощью команды Точка — значок связи и значок вершины,

– значок связи и значок системного полюса, если координаты вершины изменены системой; значок системного полюса показывает, что координаты полюса изменены системой с целью обеспечения построения сплайна по заданному сопряжению его начальной или конечной вершины с объектом сопряжения,

– пространственные координаты,

– вес вершины.

Элементы управления таблицы позволяют выполнять следующие действия с вершинами:

– читать из файла значения координат вершин и радиусы скруглений,

– сохранять в файл содержание таблицы параметров для последующего использования,

– создавать новые вершины,

– изменять значения параметров существующих в таблице вершин,

– удалять вершины сплайна,

– удалять связь вершины с опорной точкой.

Подробнее о приемах работы с таблицей параметров вершин...


Таблица параметров вершин сплайна

Каждая строка таблицы содержит следующие параметры вершины сплайна:

– номер вершины,

– значения параметров вершины (U,V),

– значок связи, если вершина сплайна ассоциативно связана с точечным объектом,

– вес (при построении сплайна по полюсам);

– значок связи и значок системного полюса (при построении сплайна по полюсам).

Системный полюс сплайна на поверхности аналогичен системному полюсу сплайна, сопряженного По касательной с объектом модели.

Строки таблицы формируются автоматически при построении вершины в окне модели. Вместе с тем, создание или редактирование строки таблицы приводит к созданию новой или изменению параметров существующей вершины кривой. Кроме того, выделение строки существующей вершины позволяет перейти в режим редактирования сплайна. Выделение последней (ненумерованной) строки таблицы позволяет переключиться в режим построения сплайна.

Элементы управления над таблицей и команды контекстного меню таблицы позволяют выполнять следующие действия:

– заменять содержимое всех ячеек выделенного столбца нулевым значением или значением первой ячейки;

– изменять значения параметров существующих в таблице вершин,

– создавать новые вершины,

– удалять вершины кривой,

– удалять связь вершины сплайна с точечным объектом,

– отменять условия касания сплайна с кривой, лежащей на поверхности расположения сплайна.

Приемы работы с таблицей параметров вершин...

Создание новой вершины...

Сплайн на поверхности...


Панель Линии

Содержит список линий мультилинии.

Позволяет добавить в мультилинию новую линию, отредактировать положение и стиль линии мультилинии, а также удалить линию из мультилинии.

Подробнее о списке линий мультилинии...


Панель Объекты

Панель содержит список типов объектов, которые могут быть переданы в ассоциативный вид из модели.

Включите опции рядом с теми типами объектов, проекции которых должны быть созданы в настраиваемом виде.

Чтобы получить изображения не только видимых, но и скрытых объектов, включите также опцию Отображать скрытые объекты. При отключенной опции объекты, показ которых отключен в модели, не отображаются в ассоциативном виде.

Действие опций распространяется на все объекты модели, созданных как в самой модели, так и в ее компонентах.

Присоединительные и контрольные точки не передаются в чертеж.


Панель Элементы оформления

Панель содержит список типов объектов оформления, которые могут быть переданы в ассоциативный вид из модели.

Включите опции рядом с теми типами объектов, которые должны присутствовать в настраиваемом виде.

Смотрите также

Условия формирования проекционных обозначений в видах

Управление отображением проекционных обозначений

Свойства проекционных обозначений

Редактирование проекционных обозначений


Угол наклона штриховки

Поле, в котором можно ввести или выбрать из списка угол наклона штриховки.


Базовая точка штриховки

Поля для ввода координат базовой точки штриховки — условной точки, от которой «начинается» штриховка. При изменении ее координат линии штриховки смещаются по вертикали и/или по горизонтали.

Для вызова меню геометрического калькулятора щелкните в поле правой кнопкой мыши.


Группа Расположение (штриховки)

Группа Расположение
(штриховки)

Переключатели Сторона 1 и Сторона 2 группы позволяют выбрать, с какой стороны от границы будет расположена штриховка.

Переключатели доступны, если создается штриховка типа Полоса.


Шаг или масштаб штриховки

Поле, в котором можно ввести или выбрать из списка шаг или масштаб штриховки.

Если штриховка состоит из сплошных линий (например, штриховка стиля «Металл»), то значение, заданное в этом поле определяет расстояние между линиями.

Если штриховка состоит из прерывистых линий (например, штриховка стиля «Стекло»), то значение, заданное в этом поле, определяет коэффициент масштабирования расстояния между линиями, а также длин штрихов и промежутков, из которых состоят линии.


Группа Тип (штриховки)

Группа Тип
(штриховки)

Переключатели Область и Полоса группы позволяют выбрать способ заполнения границы штриховки.


Ширина полосы штриховки

Поле для ввода ширины полосы штриховки.

Для вызова меню геометрического калькулятора щелкните в поле правой кнопкой мыши.


Опция Скрывать исходные кривые

Если опция включена, то после создания контура кривые, по которым он построен, в модели находятся в скрытом состоянии. Если опция выключена, кривые показываются.

Настройка не распространяется на ребра поверхностей и тел, указанных в качестве кривых.


Поле Угол конуса

Позволяет выбрать из списка или ввести с клавиатуры угол конуса.

Поле доступно для способа задания параметров конического отверстия По углу конуса.


Поле Угол зенковки

Позволяет выбрать из списка или ввести с клавиатуры угол конуса зенковки.

Поле доступно при создании отверстия с зенковкой и цековкой.


Поле Угол зенковки

Позволяет выбрать из списка или ввести с клавиатуры угол конуса зенковки.

Поле доступно при создании отверстия с зенковкой.


Поле Угол поворота

Позволяет задать при помощи счетчика или ввести с клавиатуры угол поворота оси отверстия относительно точки привязки.

Поле доступно при отключенной опции Перпендикулярно поверхности.

Ось отверстия поворачивается, если значение угла наклона оси относительно поверхности размещения больше нуля.


Поле Угол конуса торца

Позволяет выбрать из списка или ввести с клавиатуры угол конуса торца.

Поле доступно для конической формы торца.


Список Форма торца

Список Форма торца предназначен для выбора формы торца.

Форму торца можно также задать, вызвав из контекстного меню команду Торец. Список команд для задания форм торца находится в ее подменю.

Список недоступен для способа задания глубины отверстия Через все и До поверхности.


Команда Торец — Конический

Позволяет создать дно отверстия конической формы.

При вызове команды рядом с ее названием в меню появляется «галочка».

Выберите из списка или введите значение угла конуса торца в поле Угол конуса торца на Панели свойств.

Выбрать форму торца можно также из списка Форма торца на Панели свойств.


Команда Торец — Плоский

Позволяет создать дно отверстия плоской формы.

При вызове команды рядом с ее названием в меню появляется «галочка».

Выбрать форму торца можно также из списка Форма торца на на Панели свойств.


Команда Торец — Сферический

Позволяет создать дно отверстия сферической формы.

При вызове команды рядом с ее названием в меню появляется «галочка».

Выбрать форму торца можно также из списка Форма торца на Панели свойств.


Список Глубина

Список способов задания глубины отверстия:

– На расстояние — глубина отверстия определяется заданным расстоянием;

– Через все — глубина отверстия определяется расстоянием от указанной поверхности до точки пересечения оси отверстия с плоскостью, перпендикулярной оси и проходящей через наиболее удаленную от точки привязки точку габаритного параллелепипеда модели;

– До вершины —глубина отверстия определяется расстоянием от точки привязки отверстия до проекции точечного объекта на ось отверстия;

– До поверхности —Глубина отверстия определяется автоматически по положению указанной пользователем грани или плоскости.

Подробнее...


Поле Глубина выреза

Позволяет задать при помощи счетчика или ввести с клавиатуры глубину отверстия.

Поле доступно для способа задания глубины отверстия На расстояние.


Поле Глубина цековки

Позволяет задать при помощи счетчика или ввести с клавиатуры глубину цековки.

Поле доступно при создании отверстия с цековкой.


Поле Глубина цековки

Позволяет задать при помощи счетчика или ввести с клавиатуры глубину цековки.

Поле доступно при создании отверстия с цековкой и зенковкой.


Поле Глубина зенковки

Позволяет задать при помощи счетчика или ввести с клавиатуры глубину зенковки.

Поле доступно для способов задания параметров зенковки По глубине и углу и По диаметру и глубине.


Поле Диаметр основания

Позволяет задать при помощи счетчика или ввести с клавиатуры диаметр основания конуса.

Поле доступно для способа задания параметров конического отверстия По диаметру верхнего основания конуса.


Поле Диаметр цековки

Позволяет задать при помощи счетчика или ввести с клавиатуры диаметр цековки.

Поле доступно при создании отверстия с цековкой.


Поле Диаметр цековки/зенковки

Позволяет задать при помощи счетчика или ввести с клавиатуры общий диаметр цековки и зенковки.

Поле доступно при создании отверстия с цековкой и зенковкой.


Поле Диаметр зенковки

Позволяет задать при помощи счетчика или ввести с клавиатуры диаметр зенковки.

Поле доступно для способов задания параметров зенковки По диаметру и углу и По диаметру и глубине.


Поле Диаметр

Позволяет задать при помощи счетчика или ввести с клавиатуры диаметр отверстия.


Поле Диаметр резьбы

Позволяет задать при помощи счетчика или ввести с клавиатуры номинальный диаметр резьбы.


Направление построения

Переключатель, позволяющий указать направление построения отверстия.

Изменение направления немедленно отображается на фантоме отверстия в окне модели.


Поле Длина резьбы

Позволяет задать при помощи счетчика или ввести с клавиатуры длину резьбы.

Поле доступно для способа задания длины резьбы На заданную глубину /На заданную длину.


Опция Перпендикулярно поверхности

Опция, управляющая положением оси отверстия относительно поверхности размещения.

При включенной опции ось отверстия направлена перпендикулярно поверхности размещения.

При отключении опции на Панели свойств появляются элементы управления, позволяющие задать угол наклона оси отверстия относительно поверхности размещения, угол поворота оси отверстия относительно точки привязки и направляющий объект.


Элемент управления Направление оси отверстия

Элемент управления, позволяющий задать направляющий объект для оси круглого отверстия

Чтобы сменить или задать направляющий объект, активизируйте переключатель Направление оси. Затем:

– Укажите в Дереве построения или в окне модели прямолинейный или плоский объект.

• Прямолинейный объект задает направление оси отверстия, параллельное себе.

• Плоский объект задает направление оси отверстия, перпендикулярное своей плоскости.

Название выбранного объекта появляется в поле Направление оси отверстия.

– Или постройте вектор. Для запуска команды построения вектора нажмите кнопку Вектор на Панели специального управления. Если направление задано вектором, в поле Направление оси отображается слово «Вектор».


Команда Отверстие по образцу

Позволяет построить отверстие с параметрами ранее созданного отверстия.

Для вызова команды активизируйте вкладку Параметры на Панели свойств. Нажмите кнопку Отверстие по образцу на Панели специального управления или выберите ее название из контекстного меню.

Укажите в модели или в Дереве построения отверстие для копирования параметров. Если положение отверстия еще не определено, задайте его.

Чтобы подтвердить создание отверстия, нажмите кнопку Создать объект.


Поле Угол наклона

Позволяет задать при помощи счетчика или ввести с клавиатуры угол наклона оси отверстия относительно поверхности размещения.

Поле доступно при отключенной опции Перпендикулярно поверхности.


Опция Обрабатывать «навес»

Опция, с помощью которой можно удалить часть тела, в котором находится отверстие, если эта часть располагается над отверстием— образует «навес». Подробнее...


Опция Ось

Опция позволяет создать ось отверстия.

По умолчанию опция отключена.


Поле Шаг резьбы

Позволяет задать шаг резьбы.


Список Способ

Список способов задания параметров конического отверстия:

По углу конуса;

По диаметру верхнего основания конуса.


Список Способ

Список способов задания параметров зенковки.

– По диаметру и углу;

– По глубине и углу;

– По диаметру и глубине.


Команда Резьбовое отверстие

Позволяет создать условное изображение резьбы.

После вызова команды на Панели свойств появляются элементы управления для задания параметров резьбового отверстия.

Подробнее о создании резьбового отверстия...


Список Тип отверстия

Позволяет выбрать тип круглого отверстия.

Раскройте список и выберите из него тип отверстия.

Выбор типа отверстия из списка равносилен вызову команды создания соответствующего круглого отверстия. Тип отверстия при построении можно также выбрать из контекстного меню.


Команда Коническое(отверстие)

Команда Коническое
(отверстие)

Позволяет построить коническое отверстие.

При вызове команды рядом с ее названием в меню появляется «галочка».

Подробнее...


Команда С цековкой(отверстие)

Команда С цековкой
(отверстие)

Позволяет построить отверстие с цековкой.

При вызове команды рядом с ее названием в меню появляется «галочка».

Подробнее...


Команда С зенковкой и цековкой(отверстие)

Команда С зенковкой и цековкой
(отверстие)

Позволяет построить отверстие с зенковкой и цековкой.

При вызове команды рядом с ее названием в меню появляется «галочка».

Подробнее...


Команда С зенковкой(отверстие)

Команда С зенковкой
(отверстие)

Позволяет построить отверстие с зенковкой.

При вызове команды рядом с ее названием в меню появляется «галочка».

Подробнее...


Команда Простое (отверстие)

Команда Простое
(отверстие)

Позволяет построить цилиндрическое отверстие.

При вызове команды рядом с ее названием в меню появляется «галочка».

Подробнее...


Поле Угол

Поле угла наклона прямой, соединяющей точки в исходном и новом положении, в текущей системе координат.

Если курсор расположен в исходной точке, то угол равен нулю. При перемещении курсора угол определяется автоматически и заносится в это поле.

Возможен также ввод значения угла с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Поле Расстояние

Поле величины сдвига точки.

В исходном положении точки сдвиг равен нулю. При перемещении курсора сдвиг определяется автоматически и заносится в это поле.

Возможен также ввод значения сдвига с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Поле По X

Поле величины сдвига точки по оси X в текущей системе координат.

В исходном положении точки сдвиг равен нулю. При перемещении курсора сдвиг по оси X определяется автоматически и заносится в это поле.

Возможен также ввод значения сдвига с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Поле По Y

Поле величины сдвига точки по оси Y в текущей системе координат.

В исходном положении точки сдвиг равен нулю. При перемещении курсора сдвиг по оси Y определяется автоматически и заносится в это поле.

Возможен также ввод значения сдвига с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Свойства сборки

Набор элементов управления, позволяющий настроить свойства сборки или исполнения сборки.

Появляется на Панели свойств в следующих случаях:

– после вызова команды Свойства модели из меню Файл,

– после вызова команды Свойства модели из контекстного меню сборки в окне модели или в Дереве построения,

– после вызова команды Свойства исполнения из контекстного меню исполнения в Дереве исполнений.

Описание элементов управления

Элемент

Описание

Вкладка Свойства

Список свойств

Используйте эту панель для задания значений свойств сборки. Кроме того, элементы управления панели позволяют отредактировать список свойств сборки и настроить отображение свойств в списке.

Цвет

Выберите из раскрывающегося списка цвет для объектов, цвет которых определяется по исходному объекту.

Оптические свойства

Используйте элементы управления панели, чтобы задать оптические свойства для объектов, цвет которых определяется по исходному объекту.

Вкладка Параметры МЦХ

Материал

Используйте элементы управления панели для задания свойств материала1 тел, созданных в сборке (не тел компонентов!). Свойства материала будут использоваться для тех тел, которым не задан собственный материал.

Особенности задания свойств материала в модели...

Способ определения МЦХ

Переключатель, позволяющий указать, какой параметр будет задан для расчета МЦХ сборки: плотность или масса.

Расчет по плотности

Активизируйте этот переключатель, чтобы задать материал и плотность материала тел, созданных в сборке. Данные значения будут использованы для тех тел, которым не заданы собственные материал и плотность.

Для задания материала и плотности служит панель Материал.

После настройки параметров автоматически рассчитываются массы тел (по плотности и объему) и координаты центра масс сборки. Определяется общая масса сборки как сумма масс тел и компонентов2.

Расчет по массе

Активизируйте этот переключатель, чтобы задать массу сборки вручную (общую массу компонентов и тел). Для ввода этого значения служит поле Масса.

При необходимости вы можете вручную задать координаты центра масс сборки. Для этого включите опцию ЦМ и введите значения координат в таблицу на панели Центр масс.

Если опция ЦМ выключена, то центр масс вычисляется по текущим массам компонентов и тел, при этом для тел используются их плотности и объемы.

Пересчитать МЦХ

После нажатия этой кнопки производится расчет массо-центровочных характеристик сборки при текущем значении параметров2. По окончании расчета на экране появляется Информационное окно с результатами расчета.

В Информационном окне отображаются краткие результаты расчета (масса, объем, площадь поверхности, координаты центра масс модели). Чтобы получить инерционные характеристики модели (моменты инерции и направление главных осей инерции), воспользуйтесь командой Вычислить массо-центровочные характеристики модели.
  1. Свойства материала включают в себя обозначение материала, плотность, стиль, цвет и угол штриховки. При выборе материала плотность задается автоматически.
  2. При расчете МЦХ сборки учитываются текущие значения масс и координат центров масс компонентов в сборке — из источника, рассчитанные по плотности или заданные вручную.

Чтобы сделанные изменения вступили в силу, нажмите кнопку Создать объект на Панели специального управления. Изображение сборки будет перерисовано.

Чтобы выйти из режима настроек без фиксации сделанных изменений, нажмите кнопку Прервать команду.

Координаты центра масс и масса сборки (расчетные или заданные пользователем) передаются в другую сборку при вставке в нее данной в качестве подсборки и используются для расчета МЦХ сборки.

Обозначение и наименование сборки, заданные при настройке ее свойств, а также масса — заданная или расчетная — передаются в основную надпись чертежа при создании в нем ассоциативного вида этой сборки.

Единицы измерения длины и массы при задании параметров для расчета МЦХ можно настроить в диалоге настройки единиц задания МЦХ.

Параметры штриховки тел в сборке могут быть переданы в ассоциативный чертеж по модели для отображения на разрезе/сечении.

При изменении значения свойства, созданного из переменной, модель перестраивается.

Смотрите также

Пример задания параметров МЦХ компонента вручную


Свойства тела

Набор элементов управления, позволяющий настроить свойства тела.

Появляется на Панели свойств после вызова команды Свойства тела из контекстного меню тела в Дереве построения.

Пиктограммы и названия тел показываются в Дереве, если в нем включено отображение структуры модели.

Описание элементов управления

Элемент

Описание

Вкладка Свойства

Список свойств

Используйте эту панель для задания значений свойств тела. Элементы управления панели также позволяют отредактировать список свойств текущей модели и настроить отображение свойств в списке.

При настройке свойств тела компонента кроме перечисленных выше действий вы можете просмотреть свойства, хранящиеся в файле компонента.

Назначить цвет

Группа переключателей, позволяющих выбрать способ назначения цвета тела.

Цвет

Выберите цвет тела из палитры в поле Цвет.

Поле появляется на Панели свойств при активизации переключателя Вручную в группе Назначить цвет.

Оптические свойства

Используйте элементы управления панели для задания оптических свойств тела.

Панель доступна при активизации переключателя Вручную в группе Назначить цвет.

Вкладка Параметры МЦХ

Материал

Используйте элементы управления панели для задания материала и плотности материала тела.

Особенности задания свойств материала в модели...

Способ определения МЦХ

Переключатель, позволяющий указать, каким образом будет получено значение плотности тела для расчета МЦХ текущей модели.

Из источника

Активизируйте этот переключатель, чтобы для тела использовалось значение плотности, заданное для модели, в которой это тело построено.

Если переключатель Из источника активен, то остальные элементы управления вкладки недоступны.

Расчет по плотности1

Активизируйте этот переключатель, чтобы задать для тела собственный материал и плотность материала.

Значение плотности следует задать на панели Материал путем выбора из справочника или вручную.

Пересчитать МЦХ

После нажатия этой кнопки производится расчет массо-центровочных характеристик тела при текущем значении плотности. По окончании расчета на экране появляется Информационное окно с результатами расчета.

В Информационном окне отображаются краткие результаты расчета (масса, объем, площадь поверхности, координаты центра масс тела).
  1. Масса тела рассчитывается системой по плотности и объему, который вычисляется автоматически.

Чтобы сделанные изменения вступили в силу, нажмите кнопку Создать объект на Панели специального управления. Изображение модели будет перерисовано.

Чтобы выйти из режима настроек без фиксации сделанных изменений, нажмите кнопку Прервать команду.

Координаты центра масс и масса тела передаются в модель и используются для расчета ее массо-центровочных характеристик.

Единицы измерения длины и массы при задании параметров для расчета МЦХ можно настроить в диалоге настройки единиц задания МЦХ.

Параметры штриховки тел могут быть переданы в ассоциативный чертеж по модели для отображения на разрезе/сечении.


Свойства компонента

Набор элементов управления, позволяющий настроить свойства компонента модели (детали, подсборки, модели из библиотеки, детали-заготовки, локальной детали, компонента компоновочной геометрии), в том числе входящего в состав экземпляра массива.

Появляется на Панели свойств после вызова команды Свойства компонента из контекстного меню компонента в Дереве построения.

Описание элементов управления

Элемент

Описание

Вкладка Свойства

Список свойств

Используйте эту панель для задания значений свойств компонента. Кроме того, элементы управления панели позволяют просмотреть свойства, хранящиеся в файле компонента, отредактировать список свойств текущей модели и настроить отображение свойств в списке.

Назначить цвет

Группа переключателей, позволяющих выбрать способ назначения цвета компонента.

Цвет

Выберите цвет компонента из палитры цветов. Поле Цвет появляется на Панели свойств при активизации переключателя Вручную в группе Назначить цвет.

Оптические свойства

Используйте элементы управления панели для задания свойств объекта. Элементы управления доступны при активизации переключателя Вручную в группе Назначить цвет.

Фиксация

Чтобы зафиксировать компонент или отменить его фиксацию, активизируйте соответствующий переключатель: Фиксировать компонент или Не фиксировать компонент.

Группа Фиксация отображается для всех компонентов, кроме компонентов компоновочной геометрии.

Создавать объекты спецификации

Включите эту опцию, чтобы объект спецификации из компонента был передан во внутренние объекты спецификации сборки.

Опция отображается для всех компонентов, кроме деталей-заготовок и компонентов компоновочной геометрии.

Состояние

Для выбора требуемого состояния объекта активизируйте соответствующий переключатель: Включено в расчет или Исключено из расчета.

Инвертировать ось Z СК

Опция позволяет изменить направление оси Z системы координат компонента на противоположное относительно его модели-источника. При этом правосторонняя система координат компонента становится левосторонней и наоборот. Эти изменения хранятся только в модели, содержащей компонент, и не передаются в модель — источник компонента, т.е. система координат исходной модели компонента не изменяется.

Опция включается автоматически при вставке компонента в модель с левосторонней системой координат.

Вкладка Параметры МЦХ (для всех компонентов, кроме компонентов компоновочной геометрии)

Материал

Используйте элементы управления панели для задания свойств материала компонента.

Свойства материала включают в себя обозначение материала, плотность, стиль, цвет и угол штриховки. При выборе материала плотность задается автоматически.

Особенности задания свойств материала в модели...

Способ определения МЦХ

Группа переключателей, позволяющая указать, каким образом будут получены значения массы и координат центра масс компонента для расчета МЦХ текущей модели.

Из источника

Активизируйте этот переключатель, чтобы значения массы и координат центра масс компонента брались из файла этого компонента.

Расчет по плотности

Активизируйте этот переключатель, чтобы задать материал и плотность материала для тел компонента-детали.

Эта плотность будет использована для тех его тел, которые в файле-детали имеют значение из источника. Для остальных тел учитывается назначенная им собственная плотность.

Для задания материала и плотности служит панель Материал.

После настройки параметров автоматически рассчитываются массы тел (по плотности и объему) и координаты центра масс компонента. Определяется масса компонента как сумма масс его компонентов и тел.

Расчет по массе

Активизируйте этот переключатель, чтобы задать массу компонента вручную.

Для ввода этого значения служит поле Масса.

При необходимости вы можете задать и координаты центра масс компонента. Для этого включите опцию ЦМ и введите значения координат в таблицу на панели Центр масс.

Если опция ЦМ выключена, то центр масс вычисляется по текущим массам компонентов и тел, при этом для тел используются их плотности и объемы.

Пересчитать МЦХ

После нажатия этой кнопки производится расчет массо-центровочных характеристик компонента при текущем значении параметров. По окончании расчета на экране появляется Информационное окно с результатами расчета.

Вкладка Файл-источник

Файл-источник

Поле содержит полное имя файла — источника компонента. Чтобы выбрать другой файл-источник, нажмите кнопку, расположенную справа от поля, и укажите нужный файл в появившемся на экране диалоге открытия файлов.

Если указанная модель содержит исполнения и дополнительные номера, то диалог позволяет выбрать нужное исполнение и дополнительный номер из соответствующих списков. Геометрия и свойства вставленного компонента будут соответствовать выбранному исполнению модели и дополнительному номеру.

Элементы выбора файла отображаются для всех компонентов, кроме деталей-заготовок без истории и локальных деталей.

Исполнение

Раскрывающийся список позволяет выбрать другое исполнение модели, вставленной в качестве компонента. Список отображается на Панели свойств, если в выбранной модели имеются исполнения.

Дополнительный номер

Раскрывающийся список позволяет выбрать другой дополнительный номер исполнения модели, вставленной в качестве компонента. Список отображается на Панели свойств, если в выбранной модели созданы дополнительные номера.

Пересчитать размеры

Кнопка позволяет управлять геометрией компонента с учетом полей допусков, назначенных на его размеры (размеры эскизов и размеры операций). По умолчанию компонент добавляется в модель с номинальными размерами.

После нажатия этой кнопки становится доступным список пересчетов размеров компонента — системных или пользовательских (если они созданы). Выберите из списка нужный пересчет, согласно которому будут пересчитаны размеры компонента.

Чтобы вернуть компоненту номинальные размеры, отожмите эту кнопку — список пересчетов становится недоступным.

Элементы пересчета отображаются для всех компонентов, кроме модели из библиотеки.

Чтобы сделанные изменения вступили в силу, нажмите кнопку Создать объект на Панели специального управления. Изображение модели будет перерисовано и/или модель перестроится в соответствии с новыми свойствами компонента.

Обратите внимание на то, что модель необходимо перестроить, если:

– изменен файл-источник компонента, выбрано другое его исполнение или дополнительный номер,

– изменены размеры компонента с учетом полей допусков.

Пересчитанный компонент в Дереве построения отмечается буквой «п» в круглых скобках.

Чтобы выйти из режима настроек без фиксации сделанных изменений, нажмите кнопку Прервать команду.

Координаты центра масс и масса компонента (расчетные или заданные вручную) сохранятся в модели и будут использоваться при расчета МЦХ этой модели. Файлы компонентов при этом не изменятся.

Единицы измерения длины и массы при задании параметров для расчета МЦХ можно настроить в диалоге настройки единиц задания МЦХ.

Параметры штриховки компонентов-деталей могут быть переданы в ассоциативный чертеж по модели для отображения на разрезе/сечении.

Смотрите также

Пример задания параметров МЦХ компонента вручную


Свойства детали

Набор элементов управления, позволяющий настроить свойства детали или исполнения детали.

Появляется на Панели свойств в следующих случаях:

– после вызова команды Свойства модели из меню Файл,

– после вызова команды Свойства модели из контекстного меню детали в окне модели или в Дереве построения,

– после вызова команды Свойства исполнения из контекстного меню исполнения в Дереве исполнений.

Описание элементов управления

Элемент

Описание

Вкладка Свойства

Список свойств

Используйте эту панель для задания значений свойств детали. Кроме того, элементы управления панели позволяют отредактировать список свойств детали и настроить отображение свойств в списке.

Цвет

Выберите из раскрывающегося списка цвет детали.

Оптические свойства

Используйте элементы управления панели для задания оптических свойств детали.

Вкладка Параметры МЦХ

Материал

Используйте элементы управления панели для задания свойств материала1 детали.

Особенности задания свойств материала в модели...

Способ определения МЦХ

Переключатель, позволяющий указать, какой параметр будет задан для расчета МЦХ детали — плотность или масса.

Расчет по плотности

Активизируйте этот переключатель, чтобы задать материал и плотность материала детали. Данные значения будут использованы для тех тел детали, которым не заданы собственные материал и плотность.

Для задания материала и плотности служит панель Материал.

После настройки параметров автоматически рассчитываются массы тел (по плотности и объему) и координаты центра масс детали. Определяется масса детали как сумма масс тел2.

Расчет по массе

Активизируйте этот переключатель, чтобы задать массу детали вручную.

Для ввода этого значения служит поле Масса.

При необходимости вы можете задать вручную координаты центра масс детали. Для этого включите опцию ЦМ и введите значения координат в таблицу на панели Центр масс.

Если опция ЦМ выключена, то центр масс вычисляется по текущим массам входящих в деталь тел, используя их плотности и объемы.

Пересчитать МЦХ

После нажатия этой кнопки производится расчет массо-центровочных характеристик детали при текущем значении параметров2. По окончании расчета на экране появляется Информационное окно с результатами расчета.

В Информационном окне отображаются краткие результаты расчета (масса, объем, площадь поверхности, координаты центра масс модели). Чтобы получить инерционные характеристики модели (моменты инерции и направление главных осей инерции), воспользуйтесь командой Вычислить массо-центровочные характеристики модели.
  1. Свойства материала включают в себя обозначение материала, плотность, стиль, цвет и угол штриховки. При выборе материала плотность задается автоматически.
  2. При расчете МЦХ детали учитываются текущие значения плотностей тел — из источника или путем задания плотности для каждого тела отдельно.

Чтобы сделанные изменения вступили в силу, нажмите кнопку Создать объект на Панели специального управления. Изображение детали будет перерисовано.

Чтобы выйти из режима настроек без фиксации сделанных изменений, нажмите кнопку Прервать команду.

Координаты центра масс и масса детали (расчетные или заданные пользователем) передаются в сборку при вставке в нее этой детали и используются для расчета МЦХ сборки.

Обозначение, наименование и материал детали, заданные при настройке ее свойств, а также масса — расчетная или заданная вручную — передаются в основную надпись чертежа при создании в нем ассоциативного вида этой детали.

Единицы измерения длины и массы при задании параметров для расчета МЦХ можно настроить в диалоге настройки единиц задания МЦХ.

Параметры штриховки тел детали могут быть переданы в ассоциативный чертеж по модели для отображения на разрезе/сечении.

При изменении значения свойства, созданного из переменной, модель перестраивается.


Свойства грани

Набор элементов управления позволяет настроить свойства грани.

Появляется на экране после вызова команды Свойства грани в контекстном меню.

Описание элементов управления
Элемент | Описание
Наименование | Введите в это поле наименование грани.
Назначить цвет | Группа переключателей, позволяющих выбрать способ назначения цвета грани.
Цвет | Выберите цвет грани из палитры в поле Цвет. Поле присутствует на Панели свойств при активизации переключателя Вручную в группе Назначить цвет.
Оптические свойства | Используйте элементы управления панели для задания свойств объекта. Панель доступна при активизации переключателя Вручную в группе Назначить цвет.

Чтобы сделанные изменения вступили в силу, нажмите кнопку Создать объект на Панели специального управления. Изображение детали будет перерисовано.

Чтобы выйти из режима настроек без фиксации сделанных изменений, нажмите кнопку Прервать команду.


Свойства эскизов, операций (в том числе массивов),пространственных кривых, точек, плоскостей, осей и систем координат

Свойства эскизов, операций (в том числе массивов),
пространственных кривых, точек, плоскостей, осей и систем координат

Набор элементов управления позволяет настроить свойства объектов.

Появляется на экране после вызова команды Свойства из контекстного меню объекта в Дереве модели. Состав элементов управления зависит от настраиваемого объекта.

Описание элементов управления
Элемент | Описание
Наименование1 | Введите в это поле наименование объекта. Оно будет отображаться в Дереве построения.
Назначить цвет | Группа переключателей, позволяющих выбрать способ назначения цвета и оптических свойств объекта. Данная группа отсутствует на Панели свойств при настройке систем координат и массивов компонентов.
Цвет | Выберите цвет объекта из палитры в поле Цвет. Поле появляется на Панели свойств при активизации переключателя Вручную в группе Назначить цвет.
Оптические свойства | Используйте элементы управления панели для задания свойств объекта. Панель присутствует на Панели свойств при настройке свойств операций и доступна при активизации переключателя Вручную в группе Назначить цвет.
Стиль вершин | Список, из которого можно выбрать текущий стиль отображения вершины. Присутствует при настройке свойств точек и пространственных кривых (если нажата кнопка Отображение вершин).
Отображение вершин | Кнопка, управляющая отображением вершин пространственной кривой. Присутствует при настройке свойств пространственных кривых.
Стиль линий | Список, позволяющий выбрать стиль линии. Список присутствует при настройке свойств пространственных кривых. При необходимости можно задать толщину линий.
Включено в расчет1 Исключено из расчета1 | Для выбора требуемого состояния объекта активизируйте соответствующий переключатель.
СК | Поле содержит название системы координат, в которой построен объект.
Инвертировать ось Z1 | Опция присутствует при настройке свойств абсолютной системы координат. Если опция отключена, система координат является правосторонней, если включена — левосторонней. Чтобы преобразовать правостороннюю систему координат в левостороннюю и наоборот, включите/отключите опцию.
  1. Настройка может выполняться как для самой модели, так и для ее компонентов. При работе с компонентами произведенные изменения передаются в модели — источники этих компонентов.

Чтобы сделанные изменения вступили в силу, нажмите кнопку Создать объект на Панели специального управления. Изображение модели будет перерисовано и/или модель перестроится в соответствии с новыми свойствами объекта.

Чтобы выйти из режима настроек без фиксации сделанных изменений, нажмите кнопку Прервать команду.


Угол наклона

Поле угла поворота фрагмента в системе координат эскиза.

По умолчанию значение угла равно нулю.

Вы можете ввести в это поле значение с клавиатуры.

Чтобы задать положение фрагмента мышью, расфиксируйте поле Угол и укажите нужную точку в окне модели. Угол поворота фрагмента будет определен автоматически и занесен в поле Угол.


Точка привязки

Поля координат точки привязки фрагмента в системе координат эскиза.

По умолчанию значения координат равны нулю.

Вы можете ввести в эти поля значения с клавиатуры.

Чтобы задать положение фрагмента мышью, расфиксируйте поля координат и укажите нужную точку в окне модели. Координаты выбранной точки будут определены автоматически и занесены в соответствующие поля.


Поле Файл-источник

Поле, в котором отображается полное имя файла-источника вставки вида или фрагмента.

При создании вставки в это поле можно ввести имя другого файла-источника или, воспользовавшись кнопкой Выбрать другой источник вставки, указать нужный файл.

При редактировании вставки это поле является справочным, а кнопка Выбрать другой источник вставки отсутствует.


Поле Способ вставки

Справочное поле, в котором отображается способ, использовавшийся при создании редактируемой вставки вида или фрагмента.


Поле Имя вставки

Поле для ввода имени вставки. Это имя отображается в Менеджере вставок видов и фрагментов, а при работе с чертежом — также в Менеджере документа и в Дереве чертежа.

По умолчанию в качестве имени предлагается полное имя файла-источника.


Способ вставки

Переключатель, позволяющий выбрать способ вставки:

– Взять в документ,

– Внешней ссылкой,

– Рассыпать.


Переменные

Панель, содержащая перечень внешних переменных вставляемого фрагмента.

Чтобы изменить значение переменной, дважды щелкните мышью в ячейке, где оно отображается. Задайте новое значение и нажмите клавишу <Enter>.

Если значение переменной изменено, в колонке Изменен напротив ее имени отображается «галочка».

Чтобы вернуть какой-либо переменной значение, хранящееся в файле-источнике, щелкните мышью на этой «галочке».

Изменения значений переменных немедленно отражаются на фантоме фрагмента в окне документа.


Список Вид

Позволяет выбрать вид-источник вставки. Содержит перечень видов, имеющихся в чертеже-источнике.

Изображение из текущего вида-источника показывается на экране в виде фантома. При выборе из списка другого вида фантом перерисовывается.


Список СК текущего документа

Список позволяет выбрать систему координат текущей модели, относительно которой определяются координаты расположения точки вставки компонента. Присутствует на Панели свойств, если для размещения компонента выбран способ По координатам.

Список содержит все системы координат, имеющиеся в текущей модели. Выберите нужную систему координат в списке.

Если при выборе системы координат включена опция Сохранять положение, то значения координат точки вставки компонента изменяются, а его положение в модели остается неизменным.

Если эта опция отключена, то координаты точки вставки компонента остаются неизменными, но откладываются в выбранной системе координат. Положение компонента в модели изменяется.

Если текущая модель содержит только абсолютную систему координат, список недоступен.


Список СК компонента

Список позволяет выбрать систему координат компонента, относительно которой определяется его положение в текущей модели. Присутствует на Панели свойств, если для размещения компонента выбран способ По координатам.

Список содержит все системы координат, имеющиеся в компоненте. Выберите нужную систему координат из списка. Она совмещается с точкой вставки компонента. При этом изменяется положение компонента в модели.

Если компонент содержит только абсолютную систему координат, список недоступен.

При необходимости вы можете изменить положение системы координат компонента, используя команду Изменить положение СК компонента. В списке СК компонента появится строка Измененная, соответствующая новому положению системы координат. Данная строка присутствует в списке только в текущем процессе размещения компонента.


Элементы Объект 1 и Объект 2

Позволяют выбрать объекты для построения точки на их пересечении.

При нажатой кнопке Объект 1 система ожидает указания в модели первого объекта пересечения — кривой или поверхности.

При нажатой кнопке Объект 2 система ожидает указания в модели второго объекта пересечения.

– Если первый объект — кривая, то в качестве второго объекта может быть указана кривая или поверхность, пересекающаяся с первой кривой.

– Если первый объект — поверхность, то в качестве второго объекта может быть указана только кривая, пересекающаяся с поверхностью.

Выбранные объекты, если они имеют одну или несколько точек пересечения, подсвечиваются (см. рис.).

Пример построения точки: а) выбор объектов, б) результат построения
а) | б)

После указания в полях Объект 1 (Объект 2) отобразятся наименования объектов.

Чтобы сменить объект, следует нажать кнопку и указать новый объект.

Подробнее о построении на пересечении объектов...


Промежуток

Поле для ввода или задания счетчиком длины промежутков между пунктиром и штрихом.

Умолчательное значение задается в диалоге настройки отрисовки координационной оси.

Если умолчательное значение было изменено на Панели свойств, то дальнейшие изменения этого значения возможны только с Панели свойств.


Опция Инвертировать ось Z

Опция определяет, какой будет система координат — правосторонней (опция отключена) или левосторонней (опция включена). Для преобразования системы координат включите/отключите опцию.

Данная настройка может выполняться как для самой модели, так и для ее компонентов. Изменения, произведенные для компонента, передаются в его файл-источник.


Опция Инвертировать ось Z СК

Опция позволяет изменить направление оси Z системы координат компонента на противоположное относительно его модели-источника. При этом правосторонняя система координат компонента становится левосторонней и наоборот. Эти изменения хранятся только в модели, содержащей компонент, и не передаются в модель — источник компонента, т.е. система координат исходной модели компонента не изменяется.

Обратите внимание на то, что в Дереве модели, содержащей компонент, отображается пиктограмма той системы координат, которая имеется в модели — источнике компонента.

Опция включается автоматически при вставке компонента в модель с левосторонней системой координат.


Группа переключателей Выбор по направлению

Позволяет выбрать одну из двух изопараметрических кривых для построения: кривую направления U или кривую направления V.

Активизируйте нужный переключатель: Кривая направления U или Кривая направления V.

Фантом выбранной кривой становится активным.

Общие сведения о теоретической поверхности грани и изопараметрических кривых...

Изопараметрическая кривая...


Поле Поверхность

В этом поле отображается название выбранной базовой грани для построения изопараметрической кривой.

Выбор объектов в окне модели

Общие сведения о теоретической поверхности грани и изопараметрических кривых...

Изопараметрическая кривая...


Элемент Объект

Служит индикатором наличия ассоциативной связи вершины сплайна или точки, через которую проходит изопараметрическая кривая, с точечным объектом.

Если связь есть, то на кнопке Объект отображается «галочка», а в поле рядом с кнопкой — наименование вершины.

Если связи нет, то «галочка» на кнопке Объект не отображается, а поле пусто.

Формирование связи происходит автоматически во время указания вершины объекта, определяющего положение кривой.

При необходимости связь можно отменить, нажав кнопку Объект. «Галочка» на кнопке исчезнет, поле очистится.

Общие сведения о теоретической поверхности грани и изопараметрических кривых...

Изопараметрическая кривая...

Сплайн на поверхности...


Опция По вершинам

В случае если направляющие имеют одинаковое число вершин, поверхность может быть автоматически построена так, чтобы соответствующие вершины направляющих соединялись ребрами. Для этого следует включить опцию По вершинам. При отключенной опции строится поверхность минимальной кривизны.

Если количество вершин направляющих различно, состояние опции По вершинам не влияет на форму поверхности.


Точка привязки номера узла

Поля координат точки привязки номера узла.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем координат правой кнопкой мыши.


Панель Слой

Панель служит для выбора слоя, на который будут перенесены объекты, перечисленные на панели Список объектов.

По умолчанию на панели отображается список слоев, ранее созданных в документе-модели. Слои, созданные в компонентах модели, не отображаются. Текущий слой документа отмечен «галочкой».

В списке на панели Слой укажите слой, на который требуется поместить объекты.

Чтобы создать новый слой, нажмите кнопку Создать новый слой, расположенную над списком.


Список Способ построения ЛСК

Список, позволяющий выбрать способ построения ЛСК. Доступно два способа построения:

– Относительно СК,

– По объекту.


Точка для редактирования линии-выноски

Поля координат редактируемой точки.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.


Начальная точка ответвления

Поля координат точки, на которую указывает линия-выноска.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Точка начала полки

Поля координат точки начала полки линии-выноски или обозначения узла в сечении.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Положение знака

Поля координат точки привязки знака клеймения, маркировки, изменения.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Стрелка линии-выноски

Список, позволяющий выбрать тип стрелки для линии-выноски, выносной надписи или марки/позиционного обозначения. Перечень стрелок, доступных для выбора, а также порядок следования стрелок в списке определяется настройкой фильтра стрелок, сделанной для текущего документа.


Стрелка

Список, позволяющий выбрать тип стрелки для обозначений маркировки, клеймения или позиционной линии-выноски. Перечень стрелок, доступных для выбора, а также порядок следования стрелок в списке определяется настройкой фильтра стрелок, сделанной для текущего документа.


Направление полки (линии-выноски)

Направление полки
(линии-выноски)

Элемент управления, позволяющий задать направление полки линии-выноски.

Выберите из списка вариант направления полки относительно точки начала полки (т1):

Влево, Вправо, Вверх, Вниз.

Список направлений Полка отображается на Панели свойств при активном переключателе От начала полки или От конца полки группы Ответвления.

Если в группе переключателей Ответвления активен переключатель Параллельные, то вместо списка направлений Полка на Панели свойств отображается группа переключателей Положение полки.


Тип значка

Список, позволяющий выбрать значок для простановки на линии-выноске. Список доступен, если в группе Ответвления активен переключатель От начала полки или От конца полки.


Список Способ

Раскрывающийся список, из которого можно выбрать способ продления грани:

– На заданную длину — грань удлиняется за указанные кромки на заданное расстояние;

– До вершины — грань удлиняется за указанные кромки до выбранного точечного объекта.

Подробнее о способах продления грани...


Стиль

Список, позволяющий выбрать стиль линии разделителя.

Список недоступен, если на стыке сегментов мультилинии нет разделителя.


Угол наклона прямой

Поле угла наклона создаваемой прямой.

Ввод значения в это поле, а также вызов меню геометрического калькулятора возможен только при построении произвольной прямой и касательной прямой через точку объекта.

В остальных случаях поле угла наклона прямой является справочным.


Точка на прямой

Поля координат точки, принадлежащей создаваемой прямой.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Расстояние до параллельной прямой

Поле расстояния от выбранного объекта до параллельной прямой.

При указании точки, через которую должна проходить прямая, мышью, расстояние определяется автоматически и заносится в это поле.

Возможен также ввод значения с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Вторая точка прямой

Поля координат второй точки, принадлежащей создаваемой прямой.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Первая точка прямой

Поля координат первой точки, принадлежащей создаваемой прямой.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Стиль линий

Список, позволяющий выбрать стиль линий для отрисовки пространственных кривых.

При необходимости вы можете задать толщину линий.


Поле Основание 1

Поле, в котором отображается наименование эскиза первого основания линейчатой обечайки.

Укажите эскиз в Дереве построения или в окне модели.

После указания название выбранного эскиза появляется в поле Основание 1.

Повторное указание эскиза отменяет его выбор.

Смотрите также

Требования к эскизам оснований линейчатой обечайки


Поле Основание 2

Поле, в котором отображается наименование эскиза второго основания линейчатой обечайки.

Укажите эскиз в Дереве построения или в окне модели.

После указания название выбранного эскиза появляется в поле Основание 2.

Повторное указание эскиза отменяет его выбор.

Смотрите также

Требования к эскизам оснований линейчатой обечайки


Угол наклона отрезка

Поле угла наклона создаваемого отрезка или осевой линии.

Ввод произвольного значения в это поле, а также вызов меню геометрического калькулятора возможен только при построении осевой линии, простого отрезка или касательного отрезка через точку кривой.

В остальных случаях поле угла наклона отрезка является справочным.


Расстояние до параллельного отрезка

Поле расстояния от выбранного объекта до параллельного отрезка.

При указании точки, через которую должен проходить отрезок, мышью, расстояние определяется автоматически и заносится в это поле.

Возможен также ввод значения с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Конечная точка отрезка

Поля координат конечной точки создаваемого отрезка или осевой линии.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Начальная точка отрезка

Поля координат начальной точки создаваемого отрезка или осевой линии.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Длина отрезка

Поле длины создаваемого отрезка или осевой линии.

При указании характерных точек мышью длина определяется автоматически и заносится в это поле.

Возможен также ввод значения с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Группа Начальная/конечная вершина

Группа переключателей, позволяющая выбрать положение начальной и конечной вершины отрезка при построении и редактировании отрезка.

Активизируйте нужный переключатель: Начальная вершина или
Конечная вершина на Панели свойств или вызовите соответствующую команду из контекстного меню.

Вершину отрезка можно указать следующими способами:

– указать положение мышью в окне модели: координаты точки определяются автоматически и заносятся в поля X, Y, Z;

– связать с уже имеющимся точечным объектом: включить опцию Ассоциировать и указать в модели точечный объект;

– построить, нажав кнопку Построение точки на Панели специального управления;

– задать координаты в пространстве.

Изменение положения вершины немедленно отображается на фантоме отрезка в окне модели.

При построении отрезка последовательная активизация переключателей происходит автоматически.


Способ построения

Список, из которого можно выбрать текущий способ построения отрезка.

По 2 точкам

По точке, длине и углу наклона


Элемент Базовая плоскость отрезка

Позволяет сменить базовую плоскость — плоскость, которой параллельна плоскость отрезка.

Чтобы сменить базовую плоскость, активизируйте переключатель Базовая плоскость или вызовите команду из контекстного меню и укажите нужный объект в окне модели или в Дереве построения (эскиз следует указывать в Дереве построения).

Название указанного объекта отображается в поле рядом с переключателем.


Список Коллекция

Позволяет выбрать коллекцию объектов, которая будет входить в копию геометрических объектов. Содержит перечень всех коллекций, имеющихся в модели, выбранной в качестве источника копирования (в случае контекстного копирования — это текущая модель, в случае копирования из файла — модель, показанная в Окне модели-источника).

Список отображается на Панели свойств при активном переключателе Коллекции группы Выбор объектов, если модель-источник содержит хотя бы одну коллекцию объектов.


Панель Список компонентов

Панель Список компонентов доступна, если в группе Область применения активен переключатель Выбор компонентов.

На панели отображается перечень компонентов модели, составляющих область применения создаваемой или редактируемой операции.

Чтобы добавить компонент в область применения, укажите его в Дереве построения или любой его объект в окне модели.

Выбор объектов в окне модели...

Выбор объектов в Дереве построения...

В верхней части панели Список компонентов находятся кнопки, ускоряющие формирование списка:

– Выбрать все,

– Выбрать все, кроме библиотечных.

Чтобы исключить компонент из области применения операции, укажите его повторно либо выделите в списке и нажмите кнопку Удалить в верхней части панели. Чтобы очистить список, щелкните мышью на свободном поле окна модели.

Подробнее о формировании области применения вручную...


Список Тип загрузки сборки

Список Тип загрузки
сборки

Список типов загрузки сборки. Доступен в команде Типы загрузки, вызываемой для сборки.

Содержит названия системных типов загрузки (Полный, Пустой, Упрощенный, Габарит) и пользовательских типов загрузки, если они созданы в текущей сборке.

Примененный тип загрузки отмечен маркером-«кружком». Звездочка (*) вместо маркера означает, что текущий набор типов загрузки отличается от примененного.

Защищенный паролем тип загрузки обозначен в списке значком «ключ».

Над списком типов загрузки расположены кнопки для создания, редактирования и удаления типов загрузки из текущей сборки.

– Кнопка Создать служит для создания типа загрузки.

– Кнопка Редактировать служит для редактирования типа загрузки. После нажатия кнопки появляется диалог, в котором можно создать или отредактировать параметры выбранного типа загрузки.

Назначение пароля пользовательским типам загрузки возможно только после назначения пароля системным типам, осуществляемого при их редактировании.

– Кнопка Удалить объект служит для удаления выбранного в списке типа загрузки.

Если тип загрузки подчинен другому (исходному) типу загрузки, то его удаление возможно при условии, что текущим является исходный тип загрузки.

Подробнее об иерархии типов загрузки...


Список Тип загрузки компонента-подсборки

Список Тип загрузки
компонента-подсборки

Список типов загрузки компонента-подсборки, созданных в файле-источнике подсборки. Доступен в следующих случаях:

– после вызова из контекстного меню компонента-подсборки команды Тип загрузки — Выбрать...,

– после выделения компонента-подсборки в Дереве построения и нажатия кнопки Примененный тип загрузки на панели Текущее состояние.

Содержит названия системных типов загрузки (Полный, Пустой, Упрощенный, Габарит) и пользовательских типов загрузки, если они созданы в файле-источнике подсборки.

Примененный тип загрузки отмечен маркером-«кружком». Звездочка (*) вместо маркера означает, что текущий набор типов загрузки отличается от примененного.

Защищенный паролем тип загрузки обозначен значком «ключ».

Редактирование списка типов загрузки производится в файле-источнике подсборки.


Панель Исполнения

Панель служит для формирования списка исполнений, в которые будут переданы выбранные объекты текущего исполнения. Панель содержит список исполнений и элементы управления списком.

По умолчанию в списке отображаются все исполнения, имеющиеся в модели. Если требуется, чтобы список содержал только зависимые исполнения текущего исполнения, нажмите кнопку Только зависимые исполнения.

Опция, расположенная слева от обозначения исполнения в списке, управляет передачей объектов в это исполнение. Если опция включена, то объекты передаются в исполнение, если опция отключена — не передаются. Настройте список исполнений, включая и отключая нужные опции.

Если требуется включить опции для всех исполнений, содержащихся в списке, нажмите кнопку Включить все. Кнопка доступна, если хоть одна опция в списке отключена.

Кнопка Выключить все позволяет отключить все опции. Кнопка доступна, если хоть одна опция в списке включена.


Панель Список объектов

Панель служит для формирования списка объектов, которые должны быть перенесены на слой, выбранный на панели Слой.

По умолчанию список пуст. После указания объектов в Дереве построения или в окне модели они появляются в списке. В списке рядом с объектом отображается имя слоя, на котором находится объект.

Если требуется удалить объект из списка, выделите его на панели Список объектов и нажмите кнопку Удалить из списка, расположенную в верхней части панели.


Панель Список объектов

Панель служит для формирования списка объектов текущего исполнения, которые должны быть переданы в другие исполнения.

По умолчанию список пуст. Вы можете добавить нужные объекты в список, указывая их мышью в Дереве построения или в окне модели.

Если требуется удалить объект из списка, выделите его на панели Список объектов и нажмите кнопку Удалить из списка, расположенную в верхней части панели.


Панель Список объектов

Позволяет сформировать список объектов, которые будут преобразованы в деталь.

Чтобы добавить объект в список, укажите его в Дереве построения или в Окне модели. Повторное указание объекта удалит его из списка. Можно также удалить объект, выделив его в списке и нажав кнопку Удалить из списка.


Панель Список тел

Панель Список тел доступна, если в группе Тела активен переключатель Выбор тел.

На панели отображается перечень тел, составляющих область применения создаваемой или редактируемой операции.

Чтобы добавить тело в список, укажите его в Дереве построения или в окне модели.

Чтобы удалить тело из области применения операции, укажите его в окне или в Дереве повторно.

Можно также выделить тело в списке и нажать кнопку Удалить в верхней части панели Список тел.

Чтобы удалить все тела из области применения, щелкните мышью на свободном поле окна модели.

Если в область применения операции входит большинство тел, то формирование списка можно ускорить, воспользовавшись кнопкой Выбрать все в верхней части панели Список тел. После ее нажатия в список заносятся все имеющиеся в модели тела, в том числе скрытые. Те из них, которые не должны входить в область применения, удалите из списка.

Обратите внимание на то, что при выделении названия тела в списке оно выделяется и в окне модели. Это облегчает контроль правильности выбора тел.


Группа Смещение

Группа переключателей, позволяющая указать собственную ось ЛСК, в направлении которой ее требуется переместить.

Переключатели доступны, если ЛСК не имеет ассоциативной связи с точечным объектом.

Чтобы переместить ЛСК вдоль собственной оси, активизируйте переключатель, соответствующий этой оси, а затем введите расстояние смещения в поле Расстояние. Фантом ЛСК в окне модели сдвинется.

Вы можете перемещать ЛСК вдоль собственных осей мышью. Для этого «перетащите» характерную точку фантома, расположенную на конце нужной оси.


Поле Расстояние

Поле для ввода расстояния смещения ЛСК вдоль собственной оси.

Поле доступно, если в группе Смещение активен какой-либо переключатель.

Поле Расстояние обнуляется после каждого ввода, и новое смещение ЛСК отсчитывается от ее текущего положения.


Поле Объект

В этом поле отображается название объекта, указанного для построения ЛСК или присоединительной точки способом По объекту. Чтобы выбрать другой объект, укажите его в Дереве построения или в окне модели.


Переключатель Вектор начального сечения

Переключатель, позволяющий перейти к указанию объекта, задающего направление построения элемента у начального сечения.

После активизации переключателя выберите нужный объект в Дереве построения или в окне модели.

Название указанного объекта отображается справочном поле рядом с переключателем.

Переключатель доступен, если в списке Начальное сечение выбран вариант По объекту.


Переключатель Осевая линия

Переключатель, позволяющий перейти к указанию объекта, являющегося осевой линией элемента по сечениям.

В качестве осевой линии может использоваться любая пространственная или плоская кривая, например, криволинейное ребро, спираль, сплайн, эскиз.

После активизации переключателя выберите нужный объект в Дереве построения или в окне модели.

Название указанного объекта отображается справочном поле рядом с переключателем.


Переключатель Вектор конечного сечения

Переключатель, позволяющий перейти к указанию объекта, задающего направление построения элемента у конечного сечения.

После активизации переключателя выберите нужный объект в Дереве построения или в окне модели.

Название указанного объекта отображается справочном поле рядом с переключателем.

Переключатель доступен, если в списке Конечное сечение выбран вариант По объекту.


Переключатель Сечения

Переключатель, позволяющий перейти к указанию эскизов-сечений.

После активизации переключателя выберите нужные эскизы в Дереве построения или в окне модели.

Названия указанных эскизов отображаются в Списке сечений.


Панель Список сечений

Панель, содержащая перечень эскизов-сечений.

Чтобы добавить эскиз в перечень, активизируйте соответствующий переключатель и укажите нужный эскиз в Дереве построения или в окне модели.

Чтобы удалить эскиз из перечня, выделите его и нажмите кнопку Удалить, расположенную на панели Список сечений.

Чтобы изменить порядок эскизов, воспользуйтесь кнопками Переместить вниз и Переместить вверх.

Порядок эскизов в списке соответствует порядку их соединения при построении элемента.


Опция Сохранять положение

Управляет изменением положения компонента в модели при выборе другой системы координат этой модели (СК выбирается из списка СК текущего документа). Опция присутствует на Панели свойств, если для размещения компонента выбран способ По координатам.

Если опция включена, то при выборе СК положение компонента в модели не изменяется. Изменяются значения координат точки вставки компонента.

Если опция отключена, то при выборе СК координаты точки вставки компонента остаются неизменными, но откладываются в выбранной системе координат. Положение компонента в модели изменяется.


Положение марки/позиционного обозначения на линии

Положение марки/позиционного обозначения
на линии

Поля координат точки положения марки/позиционного обозначения на линии (т).

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры. Если введены координаты точки, не принадлежащей выбранной линии, то положение обозначения будет определяться проекцией указанной точки на линию или ее продолжение. В последнем случае линия автоматически будет продолжена на нужное расстояние линией со стилем тонкая. В поле координат будут отображены координаты спроецированной точки.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Габарит формы

Поле для ввода или задания счетчиком габарита текущей формы марки/позиционного обозначения без линии-выноски.

Габарит формы — размер геометрической фигуры, ограничивающей снаружи форму обозначения. Габаритом формы является сторона квадрата или диаметр окружности — в зависимости от типа формы.

– Для треугольников и шестиугольника — диаметр описанной окружности.

– Для простой окружности и окружности с вертикальным разделителем — диаметр.

– Для двойной окружности — диаметр внутренней окружности.

– Для квадрата — сторона.

– Для равностороннего ромба — сторона описанного квадрата.


Высота формы

Поле для ввода или задания счетчиком высоты габаритного прямоугольника текущей формы марки/позиционного обозначения без линии-выноски.

Высота формы определяет следующие размеры формы.

– Для прямоугольника/скругленного прямоугольника — высоту.

– Для ромба — высоту описанного прямоугольника.


Точка привязки марки/позиционного обозначения без линии-выноски

Точка привязки марки/позиционного обозначения
без линии-выноски

Поля координат точки привязки марки/позиционного обозначения без линии-выноски (т).

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем координат правой кнопкой мыши.


Форма

Список, позволяющий выбрать тип формы для марки/позиционного обозначения без линии-выноски. Перечень форм, доступных для выбора, а также порядок следования форм в списке определяется настройкой фильтра форм, сделанной для текущего документа.

Геометрические размеры форм не зависят от длины строк вводимого текста.


Ширина формы

Поле для ввода или задания счетчиком ширины габаритного прямоугольника текущей формы марки/позиционного обозначения без линии-выноски.

Ширина формы определяет следующие размеры формы.

– Для прямоугольника — ширину.

– Для ромба — ширину описанного прямоугольника.

– Для скругленного прямоугольника — расстояние между центрами полуокружностей.


Поле Масса модели

Поле для ввода значения массы модели. Доступна, если в группе Способ определения МЦХ активен переключатель Расчет по массе.

– Если производится настройка свойств модели, то значение массы сохраняется в файле модели. При вставке модели в качестве компонента в другую модель это значение передается в нее и используется при расчете ее массо-центровочных характеристик.

– Если производится настройка свойств компонента модели, то заданное значение массы компонента сохраняется в файле модели и используется при расчете ее массо-центровочных характеристик. Файл компонента остается без изменений.

Единицы измерения массы можно настроить в диалоге настройки единиц задания МЦХ.


Опция Ближайшее решение

Опция позволяет создать сопряжение, при котором взаимное расположение компонентов максимально приближено к исходному или совпадает с ним.

– Если для наложения сопряжения На расстоянии указаны, например, вершина и плоскость, то положение компонентов не изменяется. Сопряжение создается с использованием того расстояния, которое было между объектами во время их выбора.

Если для наложения сопряжения На расстоянии указаны две плоскости, то одна из них изменяет свое положение так, чтобы стать параллельной другой плоскости. При этом система выбирает наиболее близкую к исходной ориентацию перемещаемого компонента. Формируется сопряжение с использованием того расстояния, на котором будут располагаться плоскости после изменения положения одной из них.

– При создании сопряжения Под углом для угла типа Пространственный положение компонентов не меняется. Для формирования сопряжения используется тот угол, который был между выбранными объектами во время их указания.

Для угла типа Плоский положение компонентов не меняется или минимально меняется положение одного из них. В первом случае для формирования сопряжения используется тот угол, который был между выбранными объектами во время их указания, во втором случае — угол, полученный после изменения положения компонента.


Поле Базовый компонент

Поле для отображения наименования компонента сопряжения, относительно которого фиксируется положение второго (зависимого) компонента сопряжения.

Подробно о сопряжении Зависимое положение...


Поле Базовый компонент-образец

Поле для отображения наименования компонента, который считается базовым в паре компонентов-образцов при создании сопряжения Зависимое положение. Относительно системы координат данного компонента определяется положение зависимого компонента-образца.

Поле присутствует на Панели свойств при включенной опции По образцу.


Опция По образцу

Опция позволяет использовать образец положения для размещения зависимого компонента сопряжения при создании сопряжения Зависимое положение. Положение зависимого компонента изменяется таким образом, чтобы взаимное расположение компонентов сопряжения было таким же, как у двух других компонентов, имеющихся в модели. Последние выбираются в качестве компонентов-образцов.

После включения опции на Панели свойств появляются поля для отображения наименований компонентов, взаимное расположение которых будет образцом для сопрягаемых компонентов.


Поле Зависимый компонент

Поле для отображения наименования компонента сопряжения, положение которого фиксируется относительно второго (базового) компонента сопряжения.

Подробно о сопряжении Зависимое положение...


Поле Зависимый компонент-образец

Поле для отображения наименования компонента, положение которого является образцом для зависимого компонента сопряжения Зависимое положение.

Поле присутствует на Панели свойств при включенной опции По образцу.


Переключатель Направление измерения расстояния

Переключатель, позволяющий выбрать направление измерения расстояния при сопряжении объектов.


Поле Угол

Поле для ввода угла, под которым должны быть расположены сопрягаемые объекты. Значение угла может быть задано вручную или определено системой автоматически.

При включенной опции Ближайшее решение поле становится доступным:

– для угла типа Пространственный — после указания сопрягаемых объектов,

– для угла типа Плоский — после указания сопрягаемых объектов и оси, относительно которой определяется направление измерения угла.

Значение угла определяется и заносится в поле автоматически. Данное значение может быть изменено пользователем.

Если опция Ближайшее решение отключена, поле всегда доступно для ввода.


Группа переключателей Тип угла

Группа переключателей позволяет выбрать тип угла, который будет использоваться при создании сопряжения, — Пространственный (3D) угол или Плоский (2D) угол.

Подробнее...


Ось, определяющая направление измерения плоского угла

Поле для отображения наименования объекта, задающего ось, относительно которой определяется направление измерения угла сопряжения типа Плоский. До выбора объекта поле содержит текст: «Объект не определен».

Выбор объекта возможен в Дереве построения или в окне модели.


Поля сопрягаемых объектов

Поля для отображения наименований сопрягаемых объектов. До выбора объекта каждое из полей содержит текст: «Объект не определен».

Выбор объектов возможен в Дереве построения или в окне модели.

При создании сопряжения Симметрия компоненты и системы координат можно выбрать только в Дереве построения модели.


Поле Расстояние

Поле для ввода расстояния, на котором должны быть расположены сопрягаемые объекты.

При включенной опции Ближайшее решение поле становится доступным после указания сопрягаемых объектов. Значение расстояния определяется и заносится в поле автоматически. Данное значение может быть изменено пользователем.

Если опция Ближайшее решение отключена, поле всегда доступно для ввода.


Группа переключателей Ориентация

Группа переключателей позволяет при создании сопряжения выбрать ориентацию компонента, положение которого изменяется, относительно компонента с неизменным положением.


Панель Сопряжения

Содержит список сопряжений между объектами компонента и текущей модели и элементы управления списком. Присутствует на Панели свойств, если для размещения компонента выбран способ По сопряжениям.

Сопряжения, содержащиеся в списке, можно включать в расчет и исключать из расчета, включая и отключая соответствующие им опции.

Чтобы изменить параметры сопряжения, выделите его в списке и нажмите кнопку Редактировать. Запустится процесс редактирования сопряжения. Внесите необходимые изменения и нажмите кнопку Создать объект на Панели специального управления. Система вернется к выполнению исходной команды.

Чтобы удалить сопряжение, выделите его в списке и нажмите кнопку Удалить.


Поле Объект сборки

Служит для отображения объекта текущей модели, выбранного для сопряжения с объектом компонента. Присутствует на Панели свойств, если для размещения компонента выбран способ По сопряжениям.

Объект указывается в Дереве построения или в окне модели. Повторное указание объекта отменяет его выбор.


Поле Объект компонента

Служит для отображения объекта компонента, выбранного для сопряжения с объектом текущей модели. Присутствует на Панели свойств, если для размещения компонента выбран способ По сопряжениям.

Объект может быть указан в Дереве построения или в окне текущей модели, а также в Окне модели-источника. Повторное указание объекта отменяет его выбор.


Группа переключателей Выбор сопряжения

Позволяет создать сопряжение между объектом компонента и объектом текущей модели. Присутствует на Панели свойств, если для размещения компонента выбран способ По сопряжениям.

Чтобы создать сопряжение нужного типа, активизируйте соответствующий ему переключатель. Запустится процесс создания сопряжения.

Доступно создание сопряжений следующих типов:

– Параллельность,

– Перпендикулярность,

– На расстоянии,

– Под углом,

– Касание,

– Соосность,

– Совпадение объектов.

Сопрягаемые объекты можно указать до активизации переключателя или после, находясь в процессе создания сопряжения. В первом случае доступны переключатели только тех сопряжений, которые можно создать для выбранных объектов.

В процессе создания сопряжения можно перевыбрать сопрягаемые объекты.

После завершения создания сопряжения система вернется к выполнению исходной команды. Созданное сопряжение появится на панели Сопряжения.

Для выбора нужного типа сопряжения можно также использовать соответствующие команды раздела Выбор сопряжения контекстного меню.


Задание направления сопряжения

Элементы задания направления сопряжения Симметрия присутствуют на Панели свойств, если в качестве сопрягаемых объектов выбраны компоненты модели.

По умолчанию создаваемое сопряжение не имеет направления.

Чтобы задать направление сопряжения, активизируйте один из переключателей группы Направление сопряжения:

– Объект 1 ограничивает объект 2,

– Объект 2 ограничивает объект 1.

Если направление задано, один из сопрягаемых компонентов (ведущий компонент) влияет на положение другого (ведомого компонента), ограничивая его степени свободы.

Подробнее о направлении сопряжения...


Поле Плоскость симметрии

Поле для отображения наименования плоского объекта, выбранного в качестве плоскости симметрии при создании сопряжения Симметрия.

Плоскость может быть указана в Дереве построения или в окне модели.


Способ

Группа переключателей, позволяющая выбрать способ измерения расстояния между поверхностями.

По нормали к ‘Поверхности 1‘ — измерение способом По нормали к ‘Поверхности 1‘.

По направляющему объекту — измерение с использованием направляющего объекта.


Направляющий объект

Переключатель, позволяющий перейти к указанию объекта, задающего направление измерения.

После активизации переключателя выберите нужный объект в окне модели.

Если нужного направляющего объекта в модели нет, то вы можете построить вектор, задающий направление измерения. Для этого нажмите кнопку Построение вектора на Панели специального управления.

Название указанного объекта отображается в справочном поле переключателя. Если направление измерения задано вектором, то в этом поле отображается слово «Вектор».


Поверхность 1

Переключатель, позволяющий перейти к указанию первой поверхности.

После активизации переключателя выберите нужный объект в окне модели.

Название указанного объекта отображается в справочном поле переключателя.


Поверхность 2

Переключатель, позволяющий перейти к указанию второй поверхности.

После активизации переключателя выберите нужный объект в окне модели.

Название указанного объекта отображается в справочном поле переключателя.


Кратко (информация об объекте)

Кратко
(информация об объекте)

Опция, управляющая отображением в Информационном окне дополнительных данных об объекте.

Если опция включена, то выдается краткая информация, т.е. только основные сведения об объекте.

Если опция выключена, то в Информационном окне отображаются также дополнительные сведения об объекте.


Кратко (измерение МЦХ)

Кратко
(измерение МЦХ)

Опция, управляющая способом отображения в Информационном окне результатов расчета МЦХ.

Если опция включена, то выдаются сокращенные результаты расчета. Это следующая информация о модели:

– Площадь,

– Объем,

– Материал,

– Плотность,

– Масса,

– Координаты центра масс.

Если опция выключена, то сокращенные результаты в Информационном окне дополняются данными об осевых и центробежных моментах инерции и о направлении главных осей инерции.


Точка (измерение МЦХ)

Точка
(измерение МЦХ)

Опция, позволяющая проставить точку в центре масс модели.

Чтобы создать точку, включите опцию Точка и нажмите кнопку Центр масс на Панели свойств. В окне модели появится точка, а в Дереве построения — ее пиктограмма с именем «Точка в ЦМ».

После построения точки опция Точка автоматически отключается.

При последующем редактировании модели положение ранее созданной Точки в ЦМ не меняется. Чтобы создать новую точку, соответствующую фактическому центру масс, воспользуйтесь командой Вычислить МЦХ модели повторно.


Опция Центр масс

Опция, позволяющая задать произвольные координаты центра масс модели. Доступна, если в группе Способ определения МЦХ активен переключатель Расчет по массе.

Для задания координат введите нужные значения в таблицу на панели Центр масс.

– Если производится настройка свойств модели, то координаты центра масс сохраняются в файле модели. При вставке модели в качестве компонента в другую модель эти координаты передаются в нее и используются при расчете ее массо-центровочных характеристик.

– Если производится настройка свойств компонента модели, то координаты центра масс компонента сохраняются в файле модели и используются при расчете ее массо-центровочных характеристик. Файл компонента остается без изменений.

Единицы измерения длины можно настроить в диалоге настройки единиц задания МЦХ.


Угол

Справочное поле, в котором отображается значение угла между указанными прямолинейными объектами.


Вершина угла

Поля координат вершины угла.

При указании вершины мышью координаты точки определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните в поле правой кнопкой мыши.


Точка на первой стороне угла

Поля координат точки, расположенной на первой стороне угла.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните в поле правой кнопкой мыши.


Точка на второй стороне угла

Поля координат точки, расположенной на второй стороне угла.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните в поле правой кнопкой мыши.


Угол

Справочное поле, в котором отображается значение угла, образованного указанными точками.


Единицы измерения угла

Список единиц измерения углов. Доступны следующие варианты: градусы, радианы.

Чтобы выбрать нужную единицу, разверните список и укажите соответствующую строку.

Можно также установить курсор в поле и листать список, нажимая клавиши <↓> и <↑>.


Максимумов

Поле со счетчиком, позволяющее задать количество результатов измерений вблизи максимального расстояния, отображаемых в информационном окне.


Минимумов

Поле со счетчиком, позволяющее задать количество результатов измерений вблизи минимального расстояния, отображаемых в информационном окне.


Точек по U

Поле со счетчиком, позволяющее задать количество измерений по параметру U.


Точек по V

Поле со счетчиком, позволяющее задать количество измерений по параметру V.


Количество знаков после запятой

Поле для ввода или выбора количества знаков после запятой.

Минимальное количество знаков — 0, максимальное — 10.

Чтобы выбрать нужное значение, разверните список и укажите соответствующую строку.

Можно также установить курсор в поле и листать список, нажимая клавиши <↓> и <↑>.


Количество знаков после запятой

Поле для ввода или выбора количества знаков в десятичной части числа.

Минимальное количество знаков — 1, максимальное — 10.

Чтобы выбрать нужное значение, разверните список и укажите соответствующую строку.

Можно также установить курсор в поле и листать список, нажимая клавиши <↓> и <↑>.


Направление отсчета

При измерении расстояний между поверхностями направление измерений отсчитывается от первой поверхности. Это направление определяется системой автоматически и показывается фантомной стрелкой в окне модели.

Переключатели группы Направление позволяют выбрать направление измерения — прямое или обратное или в обоих направлениях. Выбранное направление должно совпадать с направлением на вторую поверхность, иначе измерение не будет выполнено.

Прямое направление

Обратное направление

Два направления

Выбор варианта направления измерения зависит от формы и взаимного расположения поверхностей. Например, пусть сечение поверхностей плоскостью имеет вид, представленный на рисунке. Измерение выполняется с использованием направляющего объекта. Если ограничиться измерениями только в прямом направлении, то часть расстояний не будет измерена — на рисунке линии этих измерений показаны прерывистыми стрелками. Чтобы измерить все расстояния между поверхностями, следует выбрать вариант Два направления.

Сечение поверхностей

Решение о необходимости измерений в обоих направлениях принимает пользователь.

Если измерение расстояния выполняется в обоих направлениях, то в Информационном окне в начале каждой строки, содержащей результаты измерения первых искомых минимумов и максимумов, отображается стрелка, показывающая направление измерения. Прямое направление отмечается стрелкой влево, обратное направление — стрелкой вправо.


Первая точка

Поля координат начальной точки участка кривой.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните в поле правой кнопкой мыши.


Вторая точка

Поля координат конечной точки участка кривой.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните в поле правой кнопкой мыши.


Расстояние между точками

Справочное поле, в котором отображается значение длины участка кривой, заключенного между указанными точками.


Расстояние между 2 кривыми

Справочное поле, в котором отображается значение расстояния между указанными кривыми.


Расстояние по X

Справочное поле, в котором отображается расстояние по оси Х между указанными объектами.


Расстояние по Y

Справочное поле, в котором отображается расстояние по оси Y между указанными объектами.


Первая точка

Поля координат точки, от которой измеряется расстояние.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните в поле правой кнопкой мыши.


Вторая точка

Поля координат точки, до которой измеряется расстояние.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните в поле правой кнопкой мыши.


Расстояние между точками

Справочное поле, в котором отображается значение расстояния указанными точками.


Точка кривой

Справочные поля, в которых отображаются координаты точки, в которой выбранная кривая пересекается с перпендикуляром, опущенным из указанной точки.


Расстояние от точки до кривой

Справочное поле, в котором отображается значение расстояния между выбранной кривой и указанной точкой.


Единицы измерения длины

Список единиц измерения длины. Доступны следующие варианты: миллиметры, сантиметры, дециметры, метры.

Чтобы выбрать нужную единицу, разверните список и укажите соответствующую строку.

Можно также установить курсор в поле и листать список, нажимая клавиши <↓> и <↑>.


Единицы измерения массы

Список единиц измерения массы. Доступны два варианта: граммы и килограммы.

Чтобы выбрать нужную единицу, разверните список и укажите соответствующую строку.

Можно также установить курсор в поле и листать список, нажимая клавиши <↓> и <↑>.


Центр масс

Кнопка, управляющая отображением рассчитанного центра масс и осей главной центральной системы координат в окне модели в виде фантома. Оси главной центральной системы координат обозначены J1, J2 и J3 в порядке убывания момента инерции относительно оси.

Если перед нажатием кнопки Центр масс была включена опция Точка на Панели свойств, то в центре масс модели будет создана точка. В Дереве построения появится пиктограмма этой точки с именем «Точка в ЦМ».

После построения точки опция Точка автоматически отключается.

При последующем редактировании модели положение ранее созданной Точки в ЦМ не меняется. Чтобы создать новую точку, соответствующую фактическому центру масс, воспользуйтесь командой вычисления МЦХ модели повторно.


Точка вне кривой

Поля координат точки, до которой измеряется расстояние.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните в поле правой кнопкой мыши.


Угол

Справочное поле, в котором отображается угол наклона радиус-вектора текущей точки к оси ОХ текущей системы координат.


Расстояние от начала координат

Поле, в котором отображается длина радиус-вектора текущей точки — расстояние до нее от начала текущей системы координат.


Точка

Поля, в которых отображаются координаты курсора при указании точки, положение которой необходимо определить.

Для вызова меню геометрического калькулятора щелкните в поле правой кнопкой мыши.


Кратко (отклонение поверхностей)

Кратко
(отклонение поверхностей)

Опция, управляющая объемом сведений, отображаемых в Информационном окне.

Если опция включена, будут показаны параметры только первых искомых максимумов и минимумов. Если опция выключена, будут показаны параметры всех результатов измерений.


Группа переключателей Ось массива(по сетке)

Группа переключателей Ось массива
(по сетке)

Группа переключателей, позволяющая задать оси массива по сетке.

Схема образования сетки...

Активизируйте переключатель нужной оси (первой или второй) и задайте ее направление.

Подробнее о задании направления первой оси...

Подробнее о задании направления второй оси...

После активизации переключателя оси на Панели свойств появляются элементы управления, позволяющие задать параметры сетки по этой оси.


Панель Шаг отсечения

Позволяет сформировать набор шагов отсечения текущего сечения. Панель содержит список шагов и элементы управления списком.

Чтобы добавить в список новый шаг, нажмите кнопку Добавить шаг отсечения.

Кнопка Удалить позволяет удалить шаг отсечения.

Задание параметров выполняется для шага отсечения, выбранного в списке. Если заданных параметров недостаточно для создания шага, то справа от его имени отображаются символы (!).


Угол наклона первой оси

Поле значения угла наклона первой оси сетки.

Вы можете ввести значение вручную или установить с помощью счетчика.

Изменение угла наклона немедленно отображается на фантоме массива в окне модели.

Если в качестве первой оси выбран существующий в модели объект или построен вектор, поле Угол наклона недоступно.


Угол раствора сетки

Поле задания значения угла между первой и второй осями сетки.

Вы можете ввести значение вручную или установить с помощью счетчика.

Изменение угла раствора немедленно отображается на фантоме массива в окне модели.

Если в качестве второй оси выбран существующий в модели объект или построен вектор, поле Угол раствора недоступно.


Базовый экземпляр

Опция, управляющая положением экземпляров массива относительно базового экземпляра.

По умолчанию номер базового экземпляра — 1,1. Он соответствует копируемому объекту (или группе объектов). Остальные экземпляры массива являются копиями базового экземпляра.

О номерах экземпляров массива...

– Включение опции позволяет изменить положение экземпляров массива относительно базового — на Панели свойств появляются поля Номер 1 и Номер 2. Введите в эти поля нужные номера базового экземпляра по осям сетки или задайте их счетчиком. Фантом массива перестраивается — экземпляры массива располагаются так, чтобы номер базового экземпляра в массиве соответствовал заданному.

– Отключение опции позволяет вернуть базовому экземпляру умолчательный номер — 1,1. Фантом массива перестраивается — экземпляры располагаются так, чтобы номер базового экземпляра стал умолчательным.

Пример...


Поле Номер 1

Введите в это поле номер базового экземпляра в массиве по первой оси.

Поле присутствует на Панели свойств, если включена опция Базовый экземпляр.


Поле Номер 2

Введите в это поле номер базового экземпляра в массиве по второй оси

Поле присутствует на Панели свойств, если включена опция Базовый экземпляр.


Первая ось

Справочное поле, в котором отображается наименование объекта, задающего направление первой оси сетки.

Если ось задана вектором, то в этом поле отображается слово «Вектор».


Вторая ось

Справочное поле, в котором отображается наименование объекта, задающего направление второй оси сетки.

Если ось задана вектором, то в этом поле отображается слово «Вектор».


Количество экземпляров по первой оси

Поле значения количества экземпляров массива по первой оси сетки.

Вы можете ввести значение вручную или установить с помощью счетчика.

Изменение количества немедленно отображается на фантоме массива в окне модели.


Количество экземпляров по второй оси

Поле задания значения количества экземпляров массива по второй оси сетки.

Вы можете ввести значение вручную или установить с помощью счетчика.

Изменение количества немедленно отображается на фантоме массива в окне модели.


Список Схема(массив по параллелограммной сетке)

Список Схема
(массив по параллелограммной сетке)

Список вариантов размещения копий внутри сетки:

Стандартная схема;

Удалять копии внутри сетки;

Копировать только вдоль осей;

Шахматный порядок - сдвиг вдоль оси 1;

Шахматный порядок - сдвиг вдоль оси 2;

По умолчанию на фантоме отображается расположение экземпляров по стандартной схеме. При выборе другой строки списка в окне модели отображается новое расположение экземпляров.

Подробнее о схемах размещения...


Группа Направление 1

Группа переключателей, управляющая направлением копирования вдоль первой оси сетки.

Изменение направления немедленно отображается на фантоме массива в окне модели.

Группа присутствует на Панели свойств, если первая ось сетки задана указанием существующего в модели объекта или построением вектора.


Группа Направление 2

Группа переключателей, управляющая направлением копирования вдоль второй оси сетки.

Изменение направления немедленно отображается на фантоме массива в окне модели.

Группа присутствует на Панели свойств, если вторая ось сетки задана указанием существующего в модели объекта или построением вектора.


Шаг экземпляров вдоль первой оси

Поле значения шага экземпляров массива по первой оси сетки.

Вы можете ввести значение вручную или установить с помощью счетчика.

Изменение шага немедленно отображается на фантоме массива в окне модели.


Шаг экземпляров вдоль второй оси

Поле задания значения шага экземпляров массива по второй оси сетки.

Вы можете ввести значение вручную или установить с помощью счетчика.

Изменение шага немедленно отображается на фантоме массива в окне модели.


Кнопка Разбить заново

Кнопка позволяет перестроить сетку таким образом, что количество ее полюсов по направлениям U и V становится равным значениям, заданным в полях Количество точек по U и Количество точек по V. Кнопка присутствует на Панели свойств при включенной опции Новая сетка.


Список Тип сетки(построение группы точек по поверхности)

Список Тип сетки
(построение группы точек по поверхности)

Раскрывающийся список, из которого можно выбрать тип сетки, управляющий расположением точек на поверхности: Прямоугольная, Концентрическая и Гексагональная.

Примеры...

Данный список присутствует на Панели свойств, если в списке Способ выбран вариант расположения точек По сетке вокруг заданной точки.

Доступность того или иного типа сетки зависит от типа грани, которой должны принадлежать точки группы.

– Если для построения группы точек используется сферическая грань, то доступны следующие типы сетки: Прямоугольная и Концентрическая.

– Если используется цилиндрическая грань, то доступны следующие типы сетки: Прямоугольная и Гексагональная.

– Если используется коническая, тороидальная или произвольная грань, то доступна только Прямоугольная сетка.

– Если используется плоская грань, то доступны все типы сетки.

Задание центра сетки

Настройка параметров сетки

Подробнее о построении группы точек по поверхности...


Задание параметров шага отсечения способом Повернутая плоскость

Способ Повернутая плоскость позволяет повернуть плоскость вокруг выбранной оси.

Для этого необходимо выполнить следующие действия.

1. Выберите вариант задания базовой плоскости, активизировав в группе элементов Базовая плоскость один из следующих переключателей:

– Плоскость модели,

– Плоскость сечения предыдущего шага (доступен, если сечение содержит шаги, которые могут использоваться для задания базовой плоскости).

2. Укажите объект, который будет использоваться в качестве базовой плоскости. В зависимости от выбранного способа базовой плоскостью может быть плоский объект модели (плоскость, плоская грань) или плоскость сечения, заданная на предыдущем шаге отсечения. Объект модели указывается в Дереве построения или в окне модели, а плоскость сечения предыдущего шага выбирается из списка Выбор шага.

3. Выберите линейный объект модели (ребро, ось), который будет использоваться в качестве оси вращения.

4. Задайте угол поворота. Вы можете ввести нужное значение угла в поле Угол Панели свойств или повернуть плоскость сечения вручную.

Подробнее о повернутой плоскости сечения...

Смотрите также

Процесс задания параметров сечения модели


Задание параметров шага отсечения способом Параллелепипед

Способ Параллелепипед позволяет настроить шаг отсечения таким образом, чтобы модель усекалась шестью плоскостями, соответствующими граням параллелепипеда. Отсекается та часть модели, которая находится за пределами параллелепипеда.

Чтобы задать параметры параллелепипеда, выполните следующие действия.

1. В группе Вариант активизируйте переключатель, соответствующий нужному способу задания параллелепипеда:

– По двум вершинам,

– По центру и вершине.

2. Задайте положение точек параллелепипеда.

Положение первой точки указывается при активном переключателе Точка 1, а положение второй — при активном переключателе Точка 2.

Координаты точки могут быть введены с клавиатуры или определены автоматически при указании положения точки мышью в окне модели или выборе точечного объекта. Для задания координат также можно использовать процесс построения точки.

Подробнее о сечении в виде параллелепипеда...

Смотрите также

Процесс задания параметров сечения модели


Задание параметров шага отсечения способом Свободное размещение

Способ Свободное размещение позволяет определить положение плоскости сечения, задав ее ориентацию и положение опорной точки. Для этого используются элементы управления на Панели свойств или элемент базирования в окне модели.

Элемент базирования представляет собой аналог системы координат. Его можно перемещать и поворачивать в пространстве, что позволяет задать положение опорной точки плоскости и ориентацию плоскости.

Кроме того, для задания положения опорной точки можно использовать один из следующих способов:

– указание точечного объекта в Дереве построения или в окне модели,

– задание смещения плоскости по осям координат,

– построение точки.

Ориентацию плоскости можно задать следующими способами:

– указание объекта (прямолинейного, плоского, поверхности вращения), определяющего направление нормали плоскости сечения (нормаль совпадает с осью Z элемента базирования),

– задание угла поворота плоскости сечения вокруг оси элемента базирования,

– построение вектора.

Подробнее о свободном размещении плоскости сечения...

Смотрите также

Процесс задания параметров сечения модели


Поле Направление нормали

Содержит координаты вектора нормали плоскости сечения или имя объекта, задающего положение нормали. Если нормаль задана построением вектора, то в поле также отображается слово Вектор.

Поле присутствует на Панели свойств, если для задания параметров шага отсечения выбран способ Свободное размещение.

Поле является информационным (недоступно для ввода). При изменении ориентации плоскости сечения содержимое поля автоматически изменяется.


Группа элементов Смещение

Позволяет задать положение опорной точки плоскости сечения смещением по осям координат. Данная группа присутствует на Панели свойств, если для задания параметров шага отсечения выбран способ Свободное размещение.

Чтобы переместить плоскость вдоль нужной оси, в группе Смещение активизируйте переключатель, соответствующий этой оси:

• Смещение по оси Х,

• Смещение по оси Y,

• Смещение по оси Z.

На Панели свойств появится поле Смещение. Введите в это поле расстояние, на которое требуется сместить плоскость. Фантом плоскости сечения и элемент базирования, совпадающий с опорной точкой, сместятся на заданное расстояние. При этом автоматически изменится значение соответствующей координаты в поле Опорная точка.


Поле Опорная точка

Содержит координаты опорной точки плоскости сечения или имя объекта, с которым ассоциативно связана эта точка. Присутствует на Панели свойств, если для задания параметров шага отсечения выбран способ Свободное размещение.

Поле является информационным (недоступно для ввода). При изменении положения опорной точки содержимое поля автоматически изменяется.


Кнопка Сменить направление

Позволяет сменить направление отсечения на противоположное при задании параметров шага отсечения способом Свободное размещение, Смещенная плоскость или Повернутая плоскость. Присутствует на Панели свойств, если для задания параметров шага отсечения выбран один из этих способов.

При свободном размещении плоскости направление отсечения показывает ось Z элемента задания положения, а при смещении или повороте плоскости — синяя стрелка. После нажатия кнопки направление изменяется на противоположное.

Для способов Смещенная плоскость и Повернутая плоскость кнопка становится доступной после выбора базовых объектов.

Для смены направления отсечения можно также вызвать команду Сменить направление из контекстного меню в окне модели.


Группа элементов Вращение

Позволяет повернуть плоскость сечения модели вокруг оси элемента базирования. Данная группа присутствует на Панели свойств, если для задания параметров шага отсечения выбран способ Свободное размещение.

Чтобы повернуть плоскость вокруг нужной оси, в группе Вращение активизируйте соответствующий переключатель:

• Вокруг оси Х,

• Вокруг оси Y,

• Вокруг оси Z.

На Панели свойств появится поле Угол. Введите в это поле нужное значение угла. Фантом плоскости сечения повернется вокруг выбранной оси на заданный угол. При этом автоматически изменится содержимое поля Направление нормали.


Задание параметров шага отсечения способом Смещенная плоскость

Способ Смещенная плоскость позволяет расположить плоскость на определенном расстоянии от выбранного объекта таким образом, что она будет параллельна этому объекту. В данном случае выбранный объект используется в качестве базовой плоскости.

Базовой плоскостью может быть имеющаяся в модели плоскость или плоская грань, а также плоскость сечения, заданная на предыдущем шаге отсечения.

Чтобы выбрать нужный вариант задания базовой плоскости, в группе элементов Базовая плоскость активизируйте один из следующих переключателей:

– Плоскость модели,

– Плоскость сечения предыдущего шага (доступен, если сечение содержит шаги, которые могут использоваться для задания базовой плоскости).

В зависимости от выбранного способа укажите нужный объект модели (объект указывается в Дереве построения или в окне модели) или выберите из появившегося списка нужный шаг отсечения.

Задайте значение смещения. Вы можете ввести нужное значение в поле Расстояние Панели свойств или переместить плоскость сечения вручную.

Подробнее о смещенной плоскости сечения...

Смотрите также

Процесс задания параметров сечения модели


Список Способ

Позволяет выбрать способ задания параметров текущего шага отсечения. Список содержит следующие варианты:

– Свободное размещение,

– Смещенная плоскость,

– Повернутая плоскость,

– Параллелепипед,

– Зона.

При выборе способа набор элементов Панели свойств изменяется.

Для каждого шага отсечения можно выбрать свой способ задания параметров.


Задание параметров шага отсечения способом Зона

Способ Зона можно использовать, если в модели созданы зоны. Он позволяет выбрать одну из зон для настройки шага отсечения. Отсекается та часть модели, которая находится за пределами выбранной зоны.

Нужная зона выбирается на вкладке Зоны Дерева модели. Фантом зоны отображается в окне модели, а ее имя — в поле Зона Панели свойств. Повторное указание зоны отменяет ее выбор.

Смотрите также

Процесс задания параметров сечения модели


Раскрывающийся список Способ

Позволяет выбрать способ расположения точек группы по поверхности.

Наименование варианта | Порядок построения
По количеству точек в направлениях U и V | Точки строятся таким образом, чтобы в направлении U было N точек, а в направлении V — М. Значения переменных N и M задаются пользователем.
По линейному отклонению | Точки строятся таким образом, чтобы отклонения ребер аппроксимирующего многогранника, соединяющих соседние точки в направлениях U и V, от поверхности, не превышали заданного пользователем значения.
По угловому отклонению | Точки строятся таким образом, чтобы углы между касательными к поверхности в точке и ребрами аппроксимирующего многогранника, соединяющими точку с соседними в направлениях U и V, не превышали заданного пользователем значения.
По сетке вокруг заданной точки | Точки располагаются на теоретической поверхности указанной грани так, чтобы образовывать сетку вокруг заданной точки, лежащей на этой же теоретической поверхности. Заданная точка является центром сетки. Сетка может быть прямоугольной, концентрической или гексагональной. Примеры... Задание центра сетки... Настройка параметров сетки...


Команда По угловому отклонению

Позволяет построить группу точек, задав при помощи счетчика или введя с клавиатуры максимальный угол между касательной к поверхности в точке и ребром аппроксимирующего многогранника, соединяющим эту точку с соседними в направлениях U и V.

Команда По угловому отклонению находится в контекстном меню окна модели. Вместо этой команды можно использовать одноименную строку списка Способ на Панели свойств.

Подробнее о построении группы точек по поверхности...


Команда По линейному отклонению

Позволяет построить группу точек, задав при помощи счетчика или введя с клавиатуры отклонение ребер аппроксимирующего многогранника, соединяющих соседние точки в направлениях U и V, от поверхности.

Команда По линейному отклонению находится в контекстном меню окна модели. Вместо этой команды можно использовать одноименную строку списка Способ на Панели свойств.

Подробнее о построении группы точек по поверхности...


Команда По количеству точек в направлениях U и V

Позволяет построить группу точек, задав при помощи счетчика или введя с клавиатуры количество точек в направлениях U и V.

Команда По количеству точек в направлениях U и V находится в контекстном меню окна модели. Вместо этой команды можно использовать одноименную строку списка Способ на Панели свойств.

Подробнее о построении группы точек по поверхности...


Группа переключателей Способ копирования

Позволяет выбрать модель — источник объектов, входящих в копию геометрических объектов. Доступны следующие варианты:

– Контекстное (включен по умолчанию) — объекты копируются из текущей модели,

– Из файла — объекты копируются из другой модели.

После выбора способа копирования Из файла на экране появляется диалог выбора файла. Укажите файл, который будет являться источником для выбора объектов, и нажмите кнопку Открыть.

На Панели свойств появится поле Файл-источник, содержащее полное имя выбранного файла. Кнопка, расположенная справа от этого поля, позволяет перевыбрать файл.

В окне текущей модели появится Окно модели-источника. Оно содержит окно модели из выбранного файла и Дерево построения этой модели. Подробнее...


Группа переключателей Выбор объектов

Позволяет выбрать способ формирования набора объектов, входящих в копию геометрических объектов. Доступны следующие варианты.

– Ручное указание — позволяет сформировать произвольный набор объектов для копирования. Этот набор формируется с помощью панели Список объектов.

– Коллекции — позволяет выбрать одну из имеющихся в модели коллекций объектов. Нужная коллекция выбирается из раскрывающегося списка Коллекция.


Команда По сетке вокруг заданной точки

Позволяет построить группу точек на теоретической поверхности указанной грани в виде сетки вокруг заданной точки, которая лежит на этой же теоретической поверхности. Заданная точка является центром сетки. Сетка может быть прямоугольной, концентрической или гексагональной. Примеры...

Задание центра сетки

Настройка параметров сетки

Команда По сетке вокруг заданной точки находится в контекстном меню окна модели. Вместо этой команды можно использовать одноименную строку списка Способ на Панели свойств.

Подробнее о построении группы точек по поверхности...


Список пересчетов размеров компонента

Раскрывающийся список, из которого можно выбрать пересчет размеров компонента, согласно которому будет производится расчет размеров.

Список доступен, если на Панели свойств нажата кнопка Пересчитать размеры.

Смотрите также

Учет допусков при управлении размерами компонента


Опция Зеркально

Включите эту опцию, чтобы объекты копии были зеркальным отражением исходных объектов. Объекты отражаются относительно плоскости XY системы координат, в которой размещается копия.


Элемент управления Плоскость

Элемент управления, позволяющий задать плоскость симметрии при построении зеркального массива. В качестве плоскости симметрии можно использовать любой плоский объект.

Чтобы задать или сменить плоскость симметрии, активизируйте переключатель Плоскость. Затем укажите в Дереве построения или в окне модели нужный плоский объект.

Название указанного объекта отображается в поле рядом с переключателем.


Группа Способ

Группа присутствует на Панели свойств в процессе изменения положения компонента зеркального исполнения или настройки параметров положения ведомого компонента сопряжения Симметрия.

Позволяет выбрать способ отражения компонента. Доступны следующие варианты.

– Зеркальное отражение

При выборе данного способа настраиваемый компонент является зеркальным отражением исходного компонента (для исполнения) или ведущего компонента (для сопряжения). Дополнительные настройки не требуются.

– Симметричное расположение

При выборе данного способа необходимо настроить параметры симметричного расположения компонента с помощью группы Положение.

Для выбора способа отражения компонента можно использовать соответствующие команды контекстного меню.


Список Плоскость симметрии

Позволяет выбрать плоскость симметрии, которая будет использоваться для изменения положения объектов, преобразуемых в деталь. В полученной детали объекты будут отражены зеркально относительно выбранной плоскости.

Список доступен при включенной опции Зеркально.


Способ определения МЦХ

Группа переключателей, позволяющая указать, каким образом будут заданы параметры тела или модели для вычисления МЦХ.

Из источника — этот переключатель доступен только при настройке свойств тела или компонента модели. Его активизация означает:

– для тела — что будет использовано то значение плотности материала, которое задано для модели, содержащей тело,

– для компонента — что масса и координаты центра масс будут извлечены из файла компонента.

Расчет по плотности — активизируйте этот переключатель, чтобы задать материал и/или плотность материала для расчета массы модели. Для выбора свойств материала используйте панель Материал.

– Если настраивается тело, то заданное значение считается собственным значением плотности этого тела.

– Если настраивается модель (деталь или сборка), то текущее значение плотности применяется только к телам, созданным в этой модели (не к компонентам!), причем к тем из них, которым не задана собственная плотность.

– Если настраивается компонент модели, то задание плотности имеет смысл, только если этот компонент — деталь. Заданное значение плотности применяется к тем ее телам, которым не задана собственная плотность.

Расчет по массе — этот переключатель доступен при настройке модели или компонента модели. Активизируйте его, чтобы задать значение массы, а при необходимости — и координаты центра масс модели.

Значения, заданные на вкладке Параметры МЦХ Панели свойств, используются следующим образом:

– Если производится настройка свойств тела, то заданные параметры используются для вычисления МЦХ модели, содержащей это тело.

– Если производится настройка свойств компонента, то заданные параметры используются для вычисления МЦХ модели, содержащей этот компонент.

– Если производится настройка свойств модели, то заданные параметры используются для вычисления МЦХ самой модели.

Единицы измерения длины и массы при задании параметров для расчета МЦХ можно настроить в диалоге настройки единиц задания МЦХ.


Угол наклона системы координат

Поле для ввода угла наклона системы координат, относительно которой должен производиться расчет МЦХ тела.


Начало системы координат

Поля координат точки начала системы координат, относительно которой должен производиться расчет МЦХ тела.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.


Кнопка Пересчитать МЦХ

Кнопка, позволяющая заново рассчитать массо-центровочные характеристики тела или модели после изменения материала, плотности материала или массы. По окончании расчета на экране появляется Информационное окно с результатами расчета.

В Информационном окне отображаются краткие результаты расчета (масса, объем, площадь поверхности, координаты центра масс тела или модели). Если требуется получить инерционные характеристики модели (моменты инерции и направление главных осей инерции), воспользуйтесь командой Вычислить массо-центровочные характеристики модели.


Группа кнопок Шаблон

Кнопка Сохранить шаблон позволяет сохранить параметры текущей мультилинии в шаблон. Файл шаблона имеет расширение mlt. Шаблон мультилинии содержит параметры мультилинии:

– количество линий и их параметры — стиль и смещение от базовой линии;

– виды ограничителей на концах мультилинии и их параметры — высоту ограничителей и стиль линий.

После нажатия кнопки Сохранить шаблон в окне документа появляется стандартный диалог сохранения файла. Введите имя файла шаблона и нажмите кнопку Сохранить.

Кнопка Загрузить шаблон позволяет использовать шаблон при создании или редактировании мультилинии. После нажатия кнопки в окне документа появляется стандартный диалог открытия файла. Выберите имя нужного файла и нажмите кнопку Открыть.

Мультилиния получит параметры из шаблона. Фантом мультилинии изменится соответственно полученным параметрам.

При необходимости вы можете отредактировать полученные из шаблона параметры мультилинии. Подробнее об этом рассказано в разделах:

– Линии мультилинии

– Ограничители мультилинии

Шаблоны мультилиний хранятся в папке, путь к которой задается переменной MULTILINETEMPLATES среды КОМПАС-3D. По умолчанию это подпапка \Templates главной папки системы. Чтобы задать другую папку для размещения шаблонов мультилиний, отредактируйте файл KOMPAS.ini.

Если при загрузке шаблона на экране появляется сообщение Невозможно открыть файл, это означает, что выбранный файл не является шаблоном или файл шаблона некорректен.


Радиус скругления

Поле радиуса скругления.

Радиус скругления для всех линий мультилинии одинаковый.

По умолчанию радиус скругления равен 10.

Вы можете ввести или задать счетчиком нужный радиус скругления в поле Радиус.

Изменение радиуса отображается на фантоме мультилинии.


Группа переключателей Режимы(перемещение компонента)

Группа переключателей Режимы
(перемещение компонента)

Позволяет выполнить следующие варианты перемещения компонента:

– Простое перемещение — перемещение без дополнительных действий (данный переключатель активен по умолчанию),

– Автосопряжения — перемещение с автоматическим наложением сопряжений,

– Контроль соударений — перемещение с контролем соударений компонентов.


Группа Операция

Группа переключателей, позволяющая изменить конфигурацию базовой линии.

Редактирование вершины

Вставка вершины


Тип сегмента

Группа переключателей, позволяющая выбрать тип сегмента для добавления в базовую линию мультилинии: прямолинейный сегмент, дуговой сегмент или сегмент по объекту.

– Прямолинейные и дуговые сегменты можно добавить в базовую линию, непосредственно построив их при создании или редактировании мультилинии.

– Сегменты произвольной формы можно добавить в базовую линию как сегменты по объекту.

Подробнее о добавлении сегментов в базовую линию рассказано в разделах:

– Прямолинейный и дуговой сегменты

– Сегмент по объекту

– Модификация базовой линии


Угол поворота при копировании

Поле для ввода угла поворота объектов-копий.

Центром поворота является точка, указанная в качестве базовой.


Базовая точка

Поля координат базовой точки.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Центр копирования

Поля координат центра копирования по окружности.

При указании центра мышью его координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Количество копий

Поле, в котором можно ввести или выбрать из списка количество копий.


Угловой шаг

Поле, в котором можно ввести угловой шаг копирования по окружности.

Поле доступно, если выбран режим копирования С заданным шагом.


Начальная точка на кривой

Поля координат начальной точки копирования по кривой.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Количество копий

Поле, в котором можно ввести или выбрать из списка количество копий вдоль кривой.


Шаг по кривой

Поле, в котором можно ввести шаг копий по кривой.

Это расстояние будет измеряться вдоль кривой, по которой производится копирование.


Угол наклона первой оси

Поле, в котором можно ввести угол между первой осью сетки и осью Х текущей системы координат.


Количество копий вдоль первой оси

Поле, в котором можно ввести или выбрать из списка количество копий вдоль первой оси сетки.


Шаг вдоль первой оси

Поле, в котором можно ввести шаг копий вдоль первой оси сетки.


Угол раствора между осями сетки

Угол раствора
между осями сетки

Поле, в котором можно ввести угол между первой и второй осями сетки.


Количество копий вдоль второй оси

Поле, в котором можно ввести или выбрать из списка количество копий вдоль второй оси сетки.


Шаг вдоль второй оси

Поле, в котором можно ввести шаг копий вдоль второй оси сетки.


Точка вставки сетки

Поля координат точки вставки сетки.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Новое положение базовой точки

Поля координат нового положения базовой точки.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значения с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Точка вставки сетки

Поля координат точки вставки концентрической сетки.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Начальный угол

Поле, в котором можно ввести угол между первой осью концентрической сетки и осью Х текущей системы координат.


Количество копий в кольцевом направлении

Поле, в котором можно ввести или выбрать из списка количество копий в кольцевом направлении.


Шаг в кольцевом направлении

Поле, в котором можно ввести шаг копий в кольцевом направлении.


Количество копий в радиальном направлении

Поле, в котором можно ввести или выбрать из списка количество копий в радиальном направлении.


Начальный радиус

Поле, в котором можно радиус первой окружности концентрической сетки.


Шаг в радиальном направлении

Поле, в котором можно ввести шаг копий в радиальном направлении.


Масштаб при копировании

Поле для ввода коэффициента масштабирования объектов-копий.

Центром масштабирования является точка, указанная в качестве базовой.


Смещение базовой точки по оси X

Поле смещения базовой точки копируемого объекта в направлении оси X текущей системы координат.

При указании нового положения точки мышью величина смещения определяется автоматически и заносится в это поле.

Возможен также ввод значения с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Смещение базовой точки по оси Y

Поле смещения базовой точки копируемого объекта в направлении оси Y текущей системы координат.

При указании нового положения точки мышью величина смещения определяется автоматически и заносится в это поле.

Возможен также ввод значения с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Переключатель Объект центра

Позволяет указать произвольный точечный объект, в том числе один из полюсов сетки, в качестве центра вращения, масштабирования или выравнивания полюсов. Переключатель находится на Панели свойств, если для задания центра из раскрывающегося списка Центр выбран вариант Точка.

Чтобы выбрать точечный объект, который будет использоваться в качестве центра, активизируйте переключатель и укажите нужный объект щелчком мыши. Название объекта отображается в поле рядом с переключателем. Центр совпадает с указанным объектом.


Элементы задания направляющего объекта

Позволяют выбрать объект, относительно которого будет определяться направление смещения полюсов сетки при линейном перемещении, перемещении со сглаживанием, перемещении масштабированием, выравнивании полюсов или направление оси вращения при вращении полюсов.

Появляются на Панели свойств в следующих случаях:

– при линейном перемещении, перемещении со сглаживанием, вращении или выравнивании полюсов — после выбора варианта Параллельно объекту или Перпендикулярно объекту в списке Направление,

– при перемещении полюсов масштабированием — после выбора варианта Параллельно объекту, Перпендикулярно объекту или В выбранной плоскости в списке Способ.

В зависимости от варианта смещения полюсов набор элементов может быть различным:

– при линейном перемещении полюсов или перемещении со сглаживанием Панель свойств содержит поле Направляющий объект, которое служит для отображения наименования объекта, указанного в качестве направляющего,

– при смещении полюсов масштабированием, выравниванием или вращением кроме поля Направляющий объект на Панели свойств отображается одноименный переключатель, позволяющий при необходимости сменить направляющий объект.

В качестве направляющего объекта для смещения Параллельно объекту может использоваться прямолинейный объект, цилиндр, конус, тор. При выборе прямолинейного объекта направление смещения полюсов совпадает с ним. При выборе цилиндра, конуса или тора направление совпадает с осью выбранного объекта.

Для смещения Перпендикулярно объекту или В выбранной плоскости в качестве направляющего выбирается плоский объект. В первом случае направление смещения полюсов совпадает с перпендикуляром к этому объекту, во втором случае смещение выполняется в плоскости, параллельной выбранному объекту.

Укажите нужный объект в Дереве построения или в окне модели. Название объекта появится в поле Направляющий объект.


Поле Направляющий объект

Содержит наименование существующего в окне модели объекта, который выбран в качестве направляющего для линии построения вершины пространственного сплайна или ломаной.

Построение по объектам...

Направляющий объект — прямолинейный или плоский объект, которому параллельна или перпендикулярна линия построения вершины сплайна или ломаной.

Если линия построения вершины строится параллельно объекту, то в качестве объекта, определяющего ее направление, можно использовать вектор. Для этого нажмите кнопку Построение вектора на Панели специального управления.


Элемент управления Опорная поверхность

Элемент управления, позволяющий задать опорную грань, от которой смещается вершина пространственного сплайна или ломаной. В качестве опорной грани можно использовать любую грань или плоскость.

Подробнее об определении положения вершины при ее смещении от опорной грани...

Чтобы сменить или задать опорную грань, активизируйте переключатель Опорная поверхность и укажите нужный объект в Дереве построения или в окне модели.

Название выбранного объекта появляется в поле рядом с переключателем.

Повторное указание объекта отменяет его выбор.

Элемент управления Опорная поверхность присутствует на Панели свойств, если в группе Смещение активен переключатель Смещение от опорной поверхности.


Переключатель Плоский объект

Позволяет указать в Дереве построения или в окне модели произвольный плоский объект, который будет использоваться для выравнивания полюсов сетки По плоскому объекту. Переключатель находится на Панели свойств, если из раскрывающегося списка Плоскость выбран вариант Выбранная плоскость.

Чтобы выбрать плоский объект, активизируйте переключатель и укажите нужный объект щелчком мыши. Название объекта отображается в поле рядом с переключателем.


Кнопка Следующий

Кнопка, позволяющая просматривать варианты сопряжения. При нажатии кнопки на экране отображается следующий вариант касания объектов.

Кнопка доступна во время создания сопряжения при отключенном автосоздании объектов, а также во время редактирования ранее созданного сопряжения, если существует более двух вариантов сопряжения Касание.

Если возможны два варианта сопряжения, то вместо кнопки Следующий доступны переключатели группы Ориентация.

Для пар объектов цилиндр – цилиндр и конус – сфера просмотр происходит среди вариантов установленного вида касания, например, в точке. Чтобы отображались варианты другого вида касания, включите нужную опцию, например, для пары цилиндр – цилиндр — по образующей, и возобновите просмотр.


Группа переключателей Способ

Позволяет выбрать способ создания вспомогательной плоскости, нормальной к поверхности вращения (кроме сферы).

Активизируйте нужный переключатель:

– Автопостроение — будет построена нормальная плоскость, проходящая через ось поверхности вращения и точку этой поверхности с нулевыми значениями параметров U и V;

– Параллельно объекту — будет построена нормальная плоскость, проходящая через ось поверхности вращения параллельно указанной координатной плоскости или плоской грани.


Группа Операции

Группа кнопок для выполнения операций над выбранным рядом точек. Появляется на Панели свойств, если в группе Выбор точек активен переключатель Ряд по направлению U или Ряд по направлению V.

Группа Операции содержит кнопки:

Вставить ряд перед выбранным

Вставить ряд после выбранного

Удалить ряд

Выбранный в данный момент ряд точек показан цветом в окне модели. Чтобы выбрать другой ряд этого же направления, щелкните мышью по любой его точке. Если требуется выбрать ряд другого направления, активизируйте нужный переключатель в группе Выбор точек, а затем укажите точку ряда.


Опция Ассоциировать

Служит для включения режима, в котором точка поверхности ассоциативно связывается с указанным точечным объектом.

Благодаря наличию связи точка будет следовать за объектом при любых его перемещениях.

Если опция отключена, то точка поверхности не связывается с точечным объектом при его указании.

Обратите внимание на то, что с помощью опции Ассоциировать нельзя отменить связь уже созданной точки с точечным объектом. Для отмены связи необходимо войти в режим редактирования поверхности, выделить точку и нажать кнопку Объект.

Режим редактирования поверхности по сети точек...

Режим редактирования поверхности по пласту точек...


Поле Количество точек

Справочное поле, в котором отображается общее количество точек, указанных для построения поверхности по пласту точек.


Список СК объекта

Список, из которого можно выбрать систему координат для распознавания сети точек, образуемой точками пласта.

Список становится доступен, если в группе Способ активен переключатель В плоскости системы координат. Список содержит названия всех локальных систем координат, которые имеются в модели на момент создания поверхности, и абсолютную систему координат.

На плоскость XY выбранной системы координат проецируются точки пласта для нахождения четырехугольных ячеек сети.

Подробнее о распознавании сети точек...


Поле Количество точек

Справочное поле, в котором отображаются количества точек сети по направлениям V и U.

Направление U совпадает с направлением добавления точек при создании поверхности по сети точек. Направление V — это направление добавления рядов.

Направления U и V показываются в окне модели стрелками.


Поле Параметры точки

Справочное поле, в котором отображается название, или сп точки, выбранной для редактирования. Параметрами могут быть:

– если точка поверхности ассоциативно связана с точечным объектом: название этого точечного объекта,

– если точка поверхности построена с помощью кнопки Построить точку:

• координаты точки, если использовался способ построения По координатам, По цилиндру или По сфере,

• название способа, если использовался другой способ построения.


Порядок кривой

Поле, в котором можно ввести или выбрать из списка порядок кривой NURBS.


Опорная точка NURBS, вершина ломаной или вершина базовой линии мультилинии

Опорная точка NURBS, вершина ломаной
или вершина базовой линии мультилинии

Поля координат опорной точки NURBS, вершины ломаной или вершины базовой линии мультилинии.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните в поле правой кнопкой мыши.


Поле Номер точки

Справочное поле, в котором отображается номер текущей точки поверхности по сети точек.

Обратите внимание на то, что при создании поверхности, т.е. при добавлении новых точек, текущей считается будущая (еще не существующая) точка, а при редактировании поверхности — точка, выделенная для редактирования.

Номер точки представляет собой два числа, разделенных запятой. Первое число обозначает номер ряда, содержащего точку, а второе — порядковый номер точки от начала ряда.


Список Способ

Раскрывающийся список, который позволяет выбрать способ формирования параметров точек сплайна — Линейный, По длине хорды или Центростремительный.

Список отображается на Панели свойств при построении сплайна по точкам с типом кривой NURBS-кривая по точкам.

При изменении способа формирования параметров точек сплайна форма сплайна меняется.


Точка для редактирования NURBS или ломаной

Поля координат точки, выбранной для редактирования NURBS или ломаной.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните в поле правой кнопкой мыши.


Поле Вес

Поле для ввода веса точки (или точек) поверхности по сети точек.

Поле присутствует на Панели свойств при редактировании поверхности, построенной По полюсам.

Значение, введенное в поле Вес, относится к одной выбранной точке или ко всем точкам ряда — в зависимости то того, какой переключатель активен в группе Выбор точек.


Вес точки сплайна

Поле, в котором можно ввести вес точки сплайна.


Группа Выбор точек

Группа переключателей, позволяющая выбрать объект для редактирования поверхности по сети точек.

– Если активен переключатель По одной точке, то точки выделяются по отдельности. Для выделения точки щелкните по ней мышью в окне модели. Вы можете переместить выделенную точку, построить ее заново или ассоциировать с точечным объектом. При построении поверхности по полюсам можно также изменить вес точки.

– Если активен переключатель Ряд по направлению U или Ряд по направлению V, то точки выделяются рядами. Чтобы выделить ряд, щелкните мышью по любой его точке в окне модели. Вы можете удалить выделенный ряд, вставить ряд после выделенного или перед выделенным. При построении поверхности по полюсам можно также изменить вес точек ряда.

Подробнее о редактировании точек и рядов...


Кнопка Замкнуть по U (V)

Кнопка, управляющая замкнутостью поверхности в направлении U (V).

Замыкание в направлении U (V) возможно, если все кривые этого направления замкнуты.

Включение и отключение замкнутости поверхности отображается на ее фантоме в окне модели.


Группа Тип поверхности

Группа переключателей для выбора типа поверхности при построении или редактировании поверхности по пласту точек.

Поверхность по точкам непосредственно проходит через точки сети.

Поверхность по полюсам проходит на некотором расстоянии от точек сети. Это расстояние определяется системой и не может быть изменено.

Многогранная поверхность непосредственно проходит через точки сети. Каждая грань поверхности имеет форму треугольника.


Поле Порядок

Поле для ввода порядка сплайновой поверхности по пласту точек. Поле Порядок становится доступно, если указано пять или больше точек поверхности.


Группа Способ

Группа переключателей для выбора способа распознавания сети точек, образуемой точками пласта.

– Активизация переключателя Автоматический означает, что ячейки сети сначала разыскиваются в пространстве. Если ячейки в пространстве найдены не будут, то ячейки разыскиваются в проекции на плоскость. Положение плоскости выбирается системой.

– Активизация переключателя В плоскости системы координат означает, что ячейки разыскиваются в проекции на плоскость XY определенной системы координат. Выбор системы координат производится из списка, который становится доступен при активизации данного переключателя.

– Активизация переключателя В плоскости экрана означает, что ячейки будут разыскиваются в плоскости, параллельной экрану, т.е. форма поверхности зависит от того, как расположена модель по отношению к наблюдателю. Опция Фиксировать положение, появляющаяся при активизации данного переключателя, позволяет зафиксировать поверхность в виде, который соответствует текущей ориентации модели.

Подробнее о распознавании сети точек...


Группа Тип поверхности

Группа переключателей для выбора типа поверхности при построении или редактировании поверхности по сети точек.

Поверхность по точкам непосредственно проходит через точки сети.

Поверхность по полюсам проходит на некотором расстоянии от точек сети. Это расстояние можно увеличивать или уменьшать, изменяя вес точек.


Кнопка Замкнуть по U (V)

Кнопка, управляющая замкнутостью поверхности в направлении U (V).

Замыкание в направлении U (V) возможно, если количество точек в этом направлении — три или больше. При меньшем количестве точек кнопка замыкания поверхности не доступна.

Включение и отключение замкнутости поверхности отображается на ее фантоме в окне модели.


Поле Порядок, U (V)

Поле для ввода значения порядка поверхности в направлении U (V). Поле Порядок, U (V) доступно, если в количество точек в этом направлении — три или больше.

Изменение порядка поверхности отображается на ее фантоме в окне модели.


Кнопка Закончить ряд

Служит для завершения ввода точек первого ряда и перехода ко второму ряду при создании поверхности по сети точек. Кнопка доступна, если указано две или более точек.

После нажатия кнопки Закончить ряд она исчезает с Панели свойств, так как завершение второго и последующих рядов не требуется — количества точек в них принимаются равными количеству точек в первом ряду.

Вместо кнопки Закончить ряд можно использовать команду контекстного меню Закончить ряд.


Поле СК

Поле, в котором отображается название системы координат объекта.


Поле Объект

В этом поле отображается наименование объекта, задающего ориентацию экземпляров массива. Подробнее...


Элемент Объект

Служит индикатором наличия ассоциативной связи точки с точечным объектом.

Если связь есть, то на кнопке Объект отображается «галочка», а в поле Объект — наименование точечного объекта.

Если связи нет, то «галочка» на кнопке Объект не отображается, а поле Объект пусто.

Формирование связи происходит во время указания точечного объекта. Положение создаваемой точки определяется проекцией точечного объекта на поверхность. При этом параметры, определяющие положение точки, заносятся в соответствующие поля на Панели свойств. Данные поля недоступны для редактирования.

При необходимости связь можно отменить, нажав кнопку Объект. «Галочка» на кнопке исчезнет. После этого становятся доступными поля для ввода параметров.

Для восстановления ассоциативной связи точки с точечным объектом необходимо указать нужный объект заново.


Стиль

Список, из которого можно выбрать текущий стиль объекта (линии, точки или штриховки).

Перечень линий, доступных для выбора, а также порядок следования линий в списке определяется настройкой фильтра линий, сделанной для текущего документа.

Щелчок на строке Другой стиль позволяет выбрать стиль из внешней библиотеки, или из сформированного пользователем набора, или один из стилей, хранящихся в документе.


Переключатель Объекты

Переключатель, позволяющий перейти к указанию исходных объектов массива.

После активизации переключателя выберите нужные объекты в Дереве построения или в окне модели.

Названия указанных объектов отображаются в Списке объектов.


Панель Список объектов(выбор копируемых объектов массива)

Панель Список объектов
(выбор копируемых объектов массива)

Панель, содержащая перечень копируемых объектов массива.

Кнопка Удалить, расположенная над списком, позволяет удалить выделенный объект из списка.

При создании зеркальной копии тела или поверхности панель отсутствует на Панели свойств.

Подробнее о выборе копируемых объектов...


Поле Угол

Поле угла поворота вектора смещения эквидистантной кривой относительно его начального направления.

Чтобы повернуть вектор смещения (изменить направление смещения), введите нужное значение угла поворота в поле Угол.

Величину угла поворота можно задать также с помощью характерной точки.

При указании точечного объекта (после нажатия кнопки Объект) в поле отображается реальная величина угла, определяющая положение точки на плоскости смещения. Она измеряется относительно направления, отображающегося в поле Направляющий объект на Панели свойств.

Поле недоступно, если установлена ассоциативная связь эквидистанты и точечного объекта.

Подробнее о построении эквидистантной кривой смещением по направлению от вершины...


Поле Расстояние

Поле расстояния от базовой кривой до эквидистантной.

Расстояние можно ввести с клавиатуры или задать с помощью характерной точки.

Поле недоступно, если установлена ассоциативная связь эквидистанты и точечного объекта.

Построение эквидистантной кривой смещением по направлению от вершины...

Построение эквидистантной кривой смещением по поверхности...


Элемент управления Кривая

Переключатель, позволяющий задать базовую кривую для построения эквидистантной кривой.

В качестве базовой кривой может использоваться пространственная кривая, ребро, линия эскиза или цепочка перечисленных объектов в любом сочетании.

Базовую кривую следует указывать в окне модели или в Дереве построения.

Выбор объектов в окне модели

Выбор объектов в Дереве построения

Название выбранного объекта или количество выбранных объектов отображается в поле рядом с переключателем.

Чтобы сменить базовую кривую, активизируйте переключатель Кривая и укажите нужную кривую.


Элемент управления Направление

Переключатель, позволяющий задать направление смещения начальной (конечной) вершины эквидистантной кривой относительно соответствующей вершины базовой кривой.

Смещение выполняется в плоскости смещения в направлении вектора смещения.

Направление вектора смещения задается с помощью направляющих объектов или вектора.

Направляющий объект следует указывать в Дереве построения или в окне модели.

Выбор объектов в окне модели

Выбор объектов в Дереве построения

Построение вектора

Название указанного объекта отображается в поле рядом с переключателем. Если направление задано вектором, то в этом поле отображается слово «Вектор».

Чтобы изменить заданное направление вектора смещения, активизируйте переключатель Направление и укажите нужный направляющий объект или постройте вектор.

Подробнее о построении эквидистантной кривой смещением по направлению от вершины...


Элемент управления Поверхность

Переключатель, позволяющий задать поверхность, на которой будет построена эквидистантная кривая.

Укажите в окне модели нужную поверхность.

Выбор объектов в окне модели

Название указанного объекта, отображается в поле рядом с переключателем.

Чтобы сменить поверхность, активизируйте переключатель Поверхность и укажите нужный объект в окне модели.

Построение эквидистантной кривой смещением по поверхности...


Кнопка Сохранять радиусы

Кнопка управляет построением эквидистанты по участкам базовой кривой, сопряженным дугами окружностей (например, радиусы в вершинах ломаной).

Если кнопка Сохранять радиусы не нажата, то на этих участках строится эквидистанта, радиусы которой будут отличаться от радиусов базовой кривой. Величина их вычисляется автоматически.

Если кнопка нажата, то радиусы эквидистанты будут такими же, как радиусы соответствующих дуговых участков базовой кривой.

Подробнее о построении эквидистантной кривой смещением по направлению от вершины...


Раскрывающийся список Способ

Позволяет выбрать способ построения эквидистантной кривой.

– Смещение по направлению от вершины;

– Смещение вдоль поверхности.


Элемент Объект

Служит для указания точечного объекта при создании эквидистанты.

По проекции точечного объекта на плоскость смещения будут определены параметры эквидистанты — угол и расстояние смещения начальной (конечной) точки.

После нажатия на кнопку Объект система ожидает указания точечного объекта.

– Если опция Ассоциировать включена, то указание точечного объекта приводит к формированию ассоциативной связи эквидистанты с этим объектом.

Признаком наличия связи является отображение «галочки» на кнопке Объект и наименования точечного объекта в поле Объект.

– Если опция выключена, то при указании точечного объекта создается эквидистанта без ассоциативной связи с объектом. В этом случае «галочка» на кнопке Объект не отображается, а поле Объект пусто.

Чтобы отменить связь эквидистанты с объектом, нажмите кнопку Объект. «Галочка» на кнопке исчезнет.

Для восстановления ассоциативной связи точки с точечным объектом необходимо включить опцию Ассоциировать, нажать кнопку Объект и указать нужный объект заново.

Подробнее о построении эквидистантной кривой смещением по направлению от вершины...


Группа Направление

Группа переключателей, позволяющая выбрать, с какой стороны от базовой поверхности будет построена эквидистантная поверхность.

Вместо переключателей группы Направление вы можете использовать команду контекстного меню Изменить направление.


Поле Расстояние

Поле для ввода значения расстояния от базовой поверхности до эквидистантной.

Расстояние можно задать также с помощью характерной точки.


Поле Поверхность

В этом поле отображается название базовой поверхности для построения эквидистантной поверхности.

В качестве базовой поверхности могут использоваться следующие объекты:

– грань тела или поверхности;

– связная совокупность граней одного тела или поверхности.

Если для построения эквидистантной поверхности указана связная совокупность граней, то в этом поле отображается количество выбранных объектов.

Чтобы сменить базовую поверхность, укажите нужный объект или объекты в Дереве построения или в окне модели.

Выбор объектов в окне модели

Выбор объектов в Дереве построения


Базовая точка OLE-объекта

Поля координат базовой точки OLE-объекта.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Поле Угол

Поле для ввода угла радиуса-вектора создаваемой точки.

При указании точки мышью угол определяется автоматически и заносится в это поле.


Поле Расстояние

Поле для ввода расстояния между базовой и создаваемой точками — длины радиуса-вектора точки.

При указании точки мышью расстояние определяется автоматически и заносится в это поле.


Поле По X

Поле для ввода смещения по оси Х точки относительно базовой.

При указании точки мышью ее координата определяется автоматически и заносится в это поле.


Поле По Y

Поле для ввода смещения по оси Y точки относительно базовой.

При указании точки мышью ее координата определяется автоматически и заносится в это поле.


Поле Кривая

Поле, в котором отображается наименование выбранной кривой.


Список Смещение (построение точки/группы точек способом На кривой)

Список Смещение
(построение точки/группы точек способом На кривой)

Список, из которого можно выбрать текущий вариант задания смещения точки вдоль кривой.

В % от длины кривой — по относительной величине смещения от начальной до создаваемой точки.

По длине сегмента — по длине кривой от начальной до создаваемой точки.

По центральному углу дуги — по центральному углу от начальной до создаваемой точки. Вариант доступен, если в качестве кривой выбрана дуга окружности или эллипса.

Подробнее о построении точки на кривой...

Подробнее о построении группы точек по кривой...


Элемент управления Угол

Поле Угол служит для ввода или задания счетчиком углового смещения вдоль дуги окружности или эллипса.

Данный способ задания положения точки используется:

– при построении точки на кривой, если в списке Смещение на Панели свойств выбран вариант По центральному углу дуги.

– при построении группы точек на кривой, если в списке Смещение на Панели свойств выбран вариант По центральному углу дуги.

Смещение задается через величину центрального угла, на который перемещается точка вдоль кривой, в единицах измерения угла. В начальной вершине угол равен 0.

Если задано значение, превышающее центральный угол кривой между начальной и конечной вершинами, то система выдаст сообщение о невозможности выполнения операции.

На рисунке показано, как задается смещение по центральному углу эллипса.

Изменение угла отображается на фантоме создаваемой точки.

При построении точки мышью в поле отображается центральный угол смещения в текущей точке.

Поле доступно, если в списке Смещение выбран вариант По центральному углу дуги.


Элемент управления Длина сегмента

Поле Длина сегмента служит для ввода или задания счетчиком абсолютной величины смещения вдоль кривой.

Данный способ задания положения точки используется:

– при построении точки на кривой, если в списке Смещение на Панели свойств выбран вариант По длине сегмента.

– при построении группы точек на кривой, если в списке Смещение на Панели свойств выбран вариант По длине сегмента.

Смещение точки задается в в единицах измерения длины. В начальной вершине величина смещения равна 0.

Если задано значение, превышающее длину кривой между начальной и конечной вершинами, то система выдаст сообщение о невозможности выполнения операции.

Изменение длины дуги отображается на фантоме создаваемой точки.

При построении точки мышью в поле отображается длина кривой в текущей точке.

Поле доступно, если в списке Смещение выбран вариант По длине сегмента.


Элемент управления % от длины кривой

Поле для задания относительной величины смещения точки вдоль кривой.

Данный способ задания положения точки используется:

– при задании начальной точки базисного вектора кривой,

– при построении точки на кривой, если в списке Смещение на Панели свойств выбран вариант В % от длины кривой.

– при построении группы точек на кривой, если в списке Смещение на Панели свойств выбран вариант В % от длины кривой.

Смещение точки задается в процентах от 0 до 100 от длины кривой. В начальной вершине величина смещения равна 0 (см. рис.).

При изменении смещения точка перемещается по кривой.


Элемент управления Поверхность

Служит для выбора поверхности, на которой будет построена точка.

Поверхностями могут служить грани поверхностей и тел.

При нажатой кнопке Поверхность система ожидает указания в модели грани.

После указания в поле Поверхность отобразится наименование грани.

Чтобы сменить грань, следует при нажатой кнопке сделать новое указание.


Список Смещение

Список, из которого можно выбрать вариант задания смещения точки на поверхности.

– По параметрам U и V — по относительным величинам смещения от начальной точки (U=0, V=0).

– По смещениям от двух объектов — по смещению (линейному или угловому) от двух плоских объектов.

– По координатам на плоскости — по координатам (прямоугольным или полярным).

– По координатам на цилиндре — по цилиндрическим координатам.

– По координатам на сфере — по сферическим координатам.


Элементы управления Объект 1 и Объект 2

Служат для выбора опорных объектов, определяющих положение точки.

В качестве опорных объектов могут использоваться следующие плоские объекты:

– плоские грани,

– вспомогательные и координатные плоскости,

– ребра в форме плоских кривых,

– эскизы (в Дереве построения).

Требования к опорным объектам...

При нажатой кнопке Объект 1 или Объект 2 система ожидает указания в модели первого или второго опорного объекта. Поле Объект 1 или Объект 2 служит для отображения наименований объектов.

Укажите в модели опорные объекты в любой последовательности.

После указания двух опорных объектов становятся доступны:

– группы переключателей Тип параметра 1 и Тип параметра 2 для выбора типа смещения — линейного или углового,

– поля Расстояние 1/Угол 1 и Расстояние 2/Угол 2 для задания смещения от указанных объектов.

Поля Расстояние 1/Угол 1 и Расстояние 2/Угол 2 доступны, если оба опорных объекта определены.

Элементы Объект 1 или Объект 2 доступны, если в поле Поверхность определена поверхность, а в списке Смещение выбран вариант По смещениям от двух объектов.


Поля Угол 1 и Угол 2

Поля для ввода или задания счетчиком угловых смещений от опорных объектов до точки.

Изменение угловых смещений отображается на фантоме. Если заданы смещения, при которых построение невозможно, на экране появится сообщение системы о невозможности выполнения операции при заданном параметре.

При определении положения точки мышью угловые смещения вычисляются и заносятся в эти поля.

Поля Угол 1 и Угол 2 становятся доступны, если определены опорные объекты в полях Объект 1 и Объект 2.


Поля Расстояние 1 и Расстояние 2

Поля для ввода или задания счетчиком расстояний от опорных объектов до точки.

Изменение расстояний отображается на фантоме. Если заданы расстояния, при которых построение невозможно, на экране появится сообщение системы о невозможности выполнения операции при заданном параметре.

При определении положения точки мышью расстояния вычисляются и заносятся в эти поля.

Поля Расстояние 1 и Расстояние 2 становятся доступны, если определены опорные объекты в полях Объект 1 и Объект 2.


Поля Параметр U % и Параметр V %

Поля для задания параметров смещения точки на теоретической поверхности грани.

Введите или задайте счетчиком в поле Параметр U, % значение параметра U, а в поле Параметр V, % — значение параметра V в процентах от полной длины кривой. Положительное направление отсчета параметров показано на фантоме стрелками (см. рис.).

При изменении параметров точка перемещается на теоретической поверхности грани.

В некоторых случаях (например, при построении точки на поверхности или группы точек на поверхности) значения параметров U и V могут быть как положительными, так и отрицательными.


Поле Объект

В этом поле отображается название объекта, указанного для ориентирования ЛСК способом По объекту. Чтобы выбрать другой объект, укажите его в Дереве построения или в окне модели.


Список Способ ориентирования ЛСК

Список, позволяющий выбрать способ ориентирования ЛСК. Доступны следующие варианты:

– Направление осей,

– Система углов Эйлера,

– По объекту.


Элемент Направление

Элемент управления, позволяющий задать направление взгляда при построении линии очерка грани.

Направление взгляда можно задать с помощью направляющего объекта или вектора.

В качестве направляющего объекта может использоваться любой прямолинейный или плоский объект.

Направление, задаваемое прямолинейным объектом — прямая, параллельная объекту.

Направление, задаваемое плоским объектом — прямая, перпендикулярная объекту.

Направляющий объект следует указывать в Дереве построения или в окне модели.

Выбор объектов в окне модели

Выбор объектов в Дереве построения

Построение вектора

Название указанного объекта отображается в поле Направление. Если направление задано вектором, то в этом поле отображается слово «Вектор».

Чтобы сменить направляющий объект, активизируйте переключатель Направление или вызовите из контекстного меню команду Выбор направления взгляда, а затем укажите нужный направляющий объект или постройте вектор.

Все изменения немедленно отображаются на фантоме линии очерка в окне модели.

Подробнее о задании направления взгляда...

Подробнее о линии очерка грани...


Элемент Поверхность

Переключатель, позволяющий задать грань или набор граней для построения линии очерка грани.

Укажите в окне модели нужную грань или набор граней.

Если требуется построить линию очерка для всех граней тела или поверхности, укажите это тело или поверхность в Дереве построения.

Выбор объектов в окне модели

Выбор объектов в Дереве построения

Название выбранного объекта или количество выбранных объектов отображается в поле Поверхность.

Повторное указание грани отменяет ее выбор.

Чтобы добавить грани в набор или исключить из него, активизируйте переключатель Поверхность или вызовите из контекстного меню команду Выбор поверхности, а затем укажите нужные объекты.

Подробнее о линии очерка грани...


Опция Фиксировать положение

Служит для фиксации линии очерка грани в той форме, которая соответствует текущему положению модели.

– Если опция Фиксировать положение включена, то линия очерка фиксируется в той форме, которая соответствует текущему положению модели.

– Если опция Фиксировать положение отключена линия очерка перестраивается всякий раз после изменения ориентации модели.

Подробнее о линии очерка грани...


Угол поворота вида

Поле, в котором можно ввести угол поворота вида.


Базовая точка вида

Переключатель, позволяющий выбрать базовую точку вида: пересечение диагоналей габаритного прямоугольника или начало координат.


Цвет вида в активном состоянии

Список, позволяющий выбрать цвет, который будет использоваться для отображения вида в активном состоянии.


Имя файла модели

Поле, в котором отображается полное имя файла модели, выбранной для изображения в чертеже.

Чтобы указать другую модель, нажмите кнопку Выбрать другую модель и укажите нужный файл в появившемся диалоге. Можно также ввести поле Имя файла модели полное имя файла модели, виды которой требуется получить.


Имя вида

Поле, в котором можно ввести имя вида. Имя, заданное в этом поле, отображается также в Дереве чертежа.


Номер вида

Поле, в котором можно ввести номер вида.


Ориентация модели

Список ориентаций модели для изображения на главном виде.

Этот список содержит ориентации, соответствующие стандартным видам (спереди, сзади, сверху, снизу, слева, справа, изометрия), а также пользовательские ориентации, если они сформированы в модели.


Точка привязки вида

Поля координат точки привязки вида.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните в поле правой кнопкой мыши.


Масштаб вида

Поле, в котором можно ввести произвольный масштаб вида или выбрать из списка стандартный масштаб.


Высота 1, %

Поле высоты первого ограничителя.

Величина данного параметра задается в процентах от 0 до 100 от ширины мультилинии.

Ширина мультилинии — расстояние между крайними линиями мультилинии, причем базовая линия не считается крайней линией. Ширина мультилинии, состоящей из одной линии, равна 0.

Умолчательное значение высоты задается при настройке мультилинии.

Вы можете ввести или задать счетчиком нужное значение высоты в поле Высота 1, %.


Высота 2, %

Поле высоты второго ограничителя.

Величина данного параметра задается в процентах от 0 до 100 от ширины мультилинии.

Ширина мультилинии — расстояние между крайними линиями мультилинии, причем базовая линия не считается крайней линией. Ширина мультилинии, состоящей из одной линии, равна 0.

Умолчательное значение высоты задается при настройке мультилинии.

Вы можете ввести или задать счетчиком нужное значение высоты в поле Высота 2, %.


Группы переключателей Тип параметра 1 и Тип параметра 2

Позволяет выбрать тип параметра смещения точки (линейный или угловой) от первого или второго опорного объекта.

Переключение типа параметра возможно, если точка строится на поверхности вращения и в качестве опорного объекта выбрана плоскость, проходящая через ось вращения. В остальных случаях тип параметра определяется системой автоматически и смена его невозможна.


Элемент управления Файл-источник

Позволяет выбрать файл, содержащий координаты точек, задающих позиции экземпляров массива.

Нажмите кнопку Файл-источник на Панели свойств. В появившемся диалоге открытия файлов Windows укажите имя нужного файла и нажмите кнопку Открыть. Полное имя файла появится в поле рядом с кнопкой.


Группа переключателей Источник данных

Позволяет выбрать способ задания позиций экземпляров массива по таблице.

Доступны два способа задания позиций экземпляров:

– чтение координат точек из ранее созданного файла,

– ручной ввод координат базовых точек экземпляров в таблицу изменяемых переменных.

Подробнее о файле данных...
Подробнее о таблице изменяемых переменных...

– Активизируйте переключатель Файл-источник, чтобы получит координаты точек из файла.

– Активизируйте переключатель Ввод вручную, чтобы ввести координаты точек в таблицу изменяемых переменных.


Список объектов

Панель, содержащая перечень объектов, которые составляют контур поверхности-заплатки.

Для корректной работы команды объекты (ребра и/или контуры в эскизах) должны выбираться в порядке их соединения.

Кнопка Удалить, расположенная над панелью, позволяет удалить выделенный объект из списка.


Панель Список удаленных

Панель, содержащая список номеров удаленных экземпляров массива.

Номера экземпляров отображаются в списке так же, как в Дереве построения модели. Подробнее...

Чтобы восстановить какой-либо экземпляр массива, выделите его номер и нажмите кнопку Восстановить.


Список Резьба

Позволяет выбрать наименование резьбы.

– Если требуется создать стандартную резьбу, выберите строку с ее наименованием из списка. Справа от списка находится кнопка Выбор параметров стандартной резьбы. Она доступна, если выбрана стандартная резьба. При нажатии на эту кнопку на экране появляется диалог, в котором можно выбрать резьбу с нужными параметрами.

– Если требуется создать нестандартную резьбу, выберите из списка строку Нестандартная резьба.

– Если резьба не требуется, выберите строку Нет.


Группа переключателей Базовая плоскость

Позволяет выбрать плоскость расположения производных размеров — исходную или базовую.

Исходной плоскостью называется плоскость, в которой производный размер находится сразу после создания. Эта плоскость определяется системой автоматически.

Базовая плоскость — это плоскость расположения производного размера, заданная пользователем вручную.

В качестве базовой плоскости может использоваться:

– координатная или вспомогательная плоскость;

– плоская грань.

Условия расположения производного размера в базовой плоскости...

– Чтобы разместить размеры набора в их исходных плоскостях, активизируйте переключатель Автоопределение.

– Чтобы разместить размеры набора в новой плоскости, активизируйте переключатель Ручное указание.

После активизации переключателя станет доступен переключатель Базовая плоскость.

Активизируйте переключатель и укажите в окне модели нужную плоскость или плоскую грань. Указанный объект выделяется цветом, а его имя отображается в поле Плоскость на Панели свойств.

Подробнее о размещении производных размеров...


Переключатель Траектория

Позволяет указать траекторию, по которой производные размеры должны переместиться в базовую плоскость.

Обычно указание траектории требуется при размещении размеров эскиза-сечения операции выдавливания, вращения или кинематической (построенной с сохранением угла наклона сечения) в плоскости, соответствующей промежуточному или конечному положению сечения.

После активизации переключателя укажите нужную кривую (ребро, линию в эскизе и т.п.) или несколько кривых. Выбранный объект подсветится, а его имя появится в поле Траектория (если выбрано несколько объектов, то в этом поле отображается их количество).

Удобнее всего в качестве траектории выбирать ребро, образованное в результате операции и совпадающее с направлением движения сечения (для операций вращения или выдавливания), либо собственно траекторию (для кинематической операции).

Подробнее о размещении производных размеров...


Панель Список размеров

Панель содержит список производных размеров, размещение которых требуется изменить. При выделении размера в списке он выделяется в окне модели.

Над списком находятся кнопки управления размерами.

– Чтобы сразу все производные размеры добавить в список, нажмите кнопку Выделить все размеры.

– Чтобы исключить какой-либо размер из списка, выделите его в списке и нажмите кнопку Удалить.


Список Точка привязки

Список, из которого можно выбрать вариант расположения точки привязки таблицы.


Поля Точка вставки

Поля координат точки привязки таблицы.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

После задания точки вставки фантом фиксируется.

Вы можете задавать координаты при отключенном автосоздании объекта.

В этом случае положение таблицы можно изменять, расфиксируя координаты и задавая нужные значения.


Элемент управления Файл-источник

Чтобы указать имя файла-источника данных для построения группы, нажмите кнопку Файл-источник на Панели свойств. Полное имя файла появится в поле.


Группа переключателей Тип координат

Позволяет выбрать вариант интерпретации данных, считанных из файла данных.

Подробнее о типах координат точек...


Опция Рассыпать

Если при создании группы объектов (точек или изопараметрических кривых) опция включена, то после завершения операции создается набор объектов, положение которых определено параметрами операции. Эти объекты не объединены в группу (каждый объект из набора отображаться в Дереве построения по отдельности), а точки группы не связаны с файлом-источником.

Обратите внимание на то, что опция присутствует на Панели свойств только при создании группы. Если уже созданную группу требуется преобразовать в набор отдельных объектов, то вы можете разрушить эту группу, используя команду Разрушить.


Координаты R, A, Z

Поля для ввода или задания счетчиком цилиндрических координат точки:

– R — радиус цилиндра,

– А — угол поворота a,

– Z — координата точки по оси Z.

Построение точки по цилиндрическим координатам;
XYZ — система координат точки

При задании положения точки мышью в полях отображаются координаты текущей точки.

Если координата зафиксирована, то перемещения в этом направлении не происходит.

Если задан объект, определяющий радиус цилиндра (его название отображается в поле Объект радиуса), то поле координаты R недоступно для ввода.

Если точка связана с точечным объектом (на кнопке Объект при этом отображается «галочка»), то все поля координат недоступны для ввода.


Смещение по Х, по Y, по Z

Поля для ввода или задания счетчиком координат точки по осям Х, Y, Z относительно опорной точки. По умолчанию опорной точкой является начало координат.

При задании положения точки мышью в полях отображаются относительные координаты текущей точки.

Если координата зафиксирована, то перемещения в этом направлении не происходит.

Поля недоступны, если определен объект в поле Направляющий объект. Чтобы сделать поля доступными, следует отменить выбор направляющего объекта. Для этого нажмите кнопку Указать заново на Панели специального управления и вновь выберите опорную точку или нажмите кнопку Направляющий объект и повторно укажите тот же направляющий объект.

Подробнее о построении переносом...


Координаты Х, Y, Z

Поля для ввода или задания счетчиком координат точки по осям Х, Y, Z ее системы координат.

При задании положения точки мышью в полях отображаются координаты текущей точки.

Если координата зафиксирована, то перемещения в этом направлении не происходит.

Если точка связана с точечным объектом (на кнопке Объект при этом отображается «галочка»), то поля координат недоступны для ввода.


Координаты R, A, B

Поля для ввода или задания счетчиком сферических координат точки:

– R — радиус сферы,

– А — азимутальный угол a,

– В — зенитный угол b.

Построение точки по сферическим координатам;
XYZ — система координат точки

При задании положения точки мышью в полях отображаются координаты текущей точки.

Если координата зафиксирована, то перемещения в этом направлении не происходит.

Если задан объект, определяющий радиус сферы (его название отображается в поле Объект радиуса), то поле координаты R недоступно для ввода.

Если точка связана с точечным объектом (на кнопке Объект при этом отображается «галочка»), то все поля координат недоступны для ввода.


Количество точек на кривой

Поле, в котором можно ввести или выбрать из списка количество точек для простановки на кривой.


Положение первой точки

Поля задания координат точки на кривой.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Количество точек

Поле, в котором можно ввести или выбрать из списка количество точек для простановки на кривой.


Положение базовой точки

Поля координат базовой точки.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Расстояние между точками

Поле, в котором можно ввести расстояние между точками на кривой.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Поле Точка-центр

Поле, в котором отображается наименование выбранного центра масштабирования.

Поле становится доступно после того, как выбрано тело или поверхность для масштабирования.

По умолчанию центр масштабирования — начало текущей системы координат модели.

Центр масштабирования представляет собой точку пространства, выбираемую за неподвижную. После выполнения команды расстояние от этой точки до центра масс тела изменится пропорционально коэффициенту масштабирования и в направлении отрезка, соединяющего эти точки.

Если требуется, чтобы центр масс тела после масштабирования не изменил расположения, укажите его как центр масштабирования. Для вычисления координат центра масс и простановки точки в центре масс можно воспользоваться командой МЦХ модели.


Группа Ориентация

Позволяет управлять ориентацией экземпляров массива.

– Если все экземпляры должны быть ориентированы в пространстве так же, как копируемый объект, активизируйте переключатель Сохранять исходную ориентацию.

– Активизация переключателя Ориентировать по объекту, связанному с точкой позволяет ориентировать экземпляры относительно объекта (объектов), на котором лежат точки, задающие позиции экземпляров. Подробнее...

– Активизация переключателя Ориентировать по указанному объекту позволяет ориентировать экземпляры по нормали к указанному объекту. В качестве объекта может использоваться:

• ребро, пространственная кривая или линия эскиза (кроме прямолинейных);

• грань (кроме плоской).

После активизации переключателя Ориентировать по указанному объекту на Панели свойств появляется поле Объект. Укажите нужный объект. Указанный объект выделяется цветом, а его наименование отображается в поле Объект. Подробнее...


Положение точки

Поля координат создаваемой точки.

При указании положения точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Группа переключателей Способ

Позволяет выбрать способ построения присоединительной точки.

Доступны два способа построения присоединительной точки:

– По объекту,

– Ручное задание направления осей.


Длина указателя ориентации оси

Поле для ввода длины указателя ориентации оси.

Введите ее или задайте счетчиком.

Параметры стрелки и умолчательная длина указателя определяются значениями, заданными в диалоге настройки указателя ориентации оси.

Поле доступно, если активизирован переключатель Добавить указатель ориентации оси.

– В процессе построения оси элементы управления вкладки Дополнительные обозначения Панели свойств становятся доступны по завершении построения оси при отключенном режиме Автосоздание на Панели специального управления. Если построения ведутся в режиме Автосоздание, его следует отключить до того, как будет указано расположение конечной точки оси (т2).

– В режиме редактирования оси элементы управления вкладки Дополнительные обозначения доступны всегда.

Если умолчательное значение длины было изменено на Панели свойств, то дальнейшие изменения этого значения возможны только с Панели свойств.


Переключатели Граница рабочего участка

Позволяют выбрать крайнюю точку рабочего участка, для которой выполняется настройка отступов. Используя эти переключатели поочередно, можно задать отступы для начальной и конечной точек.


Переключатель Сменить направление

Позволяет выбрать вершину кривой, от которой будет начинаться рабочий участок.


Опция Отступы

Позволяет задать смещения рабочего участка от вершин кривой. Опция включается автоматически, если положение рабочего участка изменить перемещением характерных точек.


Раскрывающийся список Способ

Позволяет выбрать способ расположения точек группы по рабочему участку кривой:

– Равномерно по длине,

– Шаг по кривой,

– Равный шаг по параметру.


Опция По всей кривой

Позволяет создать группу в пределах всего рабочего участка кривой. Количество точек в группе равно результату целочисленного деления длины кривой на указанный шаг.

Опция доступна для способа Шаг по кривой.


Поле Количество точек

Позволяет выбрать при помощи счетчика или ввести с клавиатуры количество создаваемых точек.

При построении способом Шаг по кривой поле доступно, если отключена опция По всей кривой.


Поле Кривая

Содержит наименование кривой, на которой будут лежать точки создаваемой группы.

В качестве кривой может быть выбрана пространственная кривая (или ее сегмент), линия эскиза или ребро.

Выбор объектов в окне модели

Выбор объектов в Дереве построения


Поле Шаг

Позволяет задать при помощи счетчика или ввести с клавиатуры расстояние между точками в группе.


Поле Количество точек, U

Позволяет задать при помощи счетчика или ввести с клавиатуры количество точек в направлении U.


Поле Количество точек, V

Позволяет задать при помощи счетчика или ввести с клавиатуры количество точек в в направлении V.


Поле Угловое отклонение

Позволяет задать при помощи счетчика или ввести с клавиатуры максимальный угол между касательной к поверхности в точке и ребром аппроксимирующего многогранника, соединяющим эту точку с соседними в направлениях U и V.


Поле Линейное отклонение

Позволяет задать при помощи счетчика или ввести с клавиатуры максимальное отклонение ребер аппроксимирующего многогранника, соединяющих соседние точки в направлениях U и V, от поверхности.


Угол наклона многоугольника

Поле угла наклона многоугольника.

Угол наклона многоугольника определяется углом между осью абсцисс текущей системы координат и радиус-вектором, проведенным из центра многоугольника в его первую вершину (при построении по описанной окружности) или в середину первой стороны (при построении по вписанной окружности).

При указании точки, определяющей угол наклона многоугольника, мышью угол определяется автоматически и заносится в это поле.

Возможен также ввод угла с клавиатуры.

Для вызова меню геометрического калькулятора щелкните в поле правой кнопкой мыши.


Центр многоугольника

Поля координат центра создаваемого многоугольника.

При указании центра мышью координаты точки определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните в поле правой кнопкой мыши.


Диаметр базовой окружности

Поле диаметра базовой окружности создаваемого многоугольника.

При указании точки на окружность мышью диаметр определяется автоматически и заносится в это поле.

Возможен также ввод значения с клавиатуры.

Для вызова меню геометрического калькулятора щелкните в поле правой кнопкой мыши.


Число вершин многоугольника

Поле, в котором можно ввести или выбрать из списка число вершин создаваемого многоугольника.


Точка на базовой окружности

Поля координат одной из вершин (при построении по описанной окружности) или середины одной из сторон (при построении по вписанной окружности) создаваемого многоугольника.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните в поле правой кнопкой мыши.


Радиус базовой окружности

Поле радиуса базовой окружности создаваемого многоугольника.

При указании точки на окружность мышью радиус определяется автоматически и заносится в это поле.

Возможен также ввод значения с клавиатуры.

Для вызова меню геометрического калькулятора щелкните в поле правой кнопкой мыши.


Начальная точка ломаной

Поля координат первой вершины ломаной линии.

При указании вершины мышью координаты точки определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Вершина ломаной

Поля координат очередной вершины ломаной линии.

При указании вершины мышью координаты точки определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Панель Список объектов

Содержит перечень компонентов и тел модели, указанных для простановки обозначения позиции.

При выделении объекта в списке соответствующее ему ответвление обозначения, а также компонент (или тело) подсвечиваются в окне модели.

Вы можете удалить выбранное ответвление, нажав кнопку Удалить в верхней части панели.


Тип формы

Список, позволяющий выбрать нужный тип формы для текущего обозначения позиции.

Размер форм типа «Круг», «Шестиугольник» и «Круг с разделителем» задается при настройке формы обозначений позиций для текущего документа.


Точка начала полки

Поля координат точки начала полки марки/позиционного обозначения с линией-выноской.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Элемент Направляющий объект (способ Проекция)

Элемент Направляющий объект
(способ Проекция)

Служит для выбора направления проецирования опорной точки.

При нажатой кнопке Направляющий объект система ожидает указания в модели направляющего объекта или построения вектора.

Пример создания проекции: а) выбор направляющего объекта; б) результат построения
а) | б)

После указания объекта в поле Направляющий объект отобразится его наименование. Если направление задано вектором, то в этом поле отобразится слово «Вектор».

Подробнее о способе построения проекции...


Элемент Опорная точка (способ Проекция)

Элемент Опорная точка
(способ Проекция)

Служит для выбора точки, которая будет спроецирована на поверхность.

При нажатой кнопке Опорная точка система ожидает указания в модели опорной точки.

После указания в поле Опорная точка отобразится наименование объекта.

Подробнее о способе построения проекции...


Элемент Поверхность (способ Проекция)

Элемент Поверхность
(способ Проекция)

Служит для выбора поверхности, на которую будет спроецирована опорная точка.

При нажатой кнопке Поверхность система ожидает указания в модели поверхности.

Пример выбора объектов а) поверхности, на которой строится точка, б) опорной точки
а) | б)

После указания в поле Поверхность отобразится наименование объекта.

В модели отобразится ортогональная проекция точки на выбранную поверхность (см. рис. б).

Подробнее о способе построения проекции...


Элемент Кривая

Переключатель, позволяющий задать базовую кривую для построения ее проекции на заданную поверхность проецирования.

В качестве базовой кривой может использоваться:

– пространственная кривая (в том числе экземпляр массива),

– ребро тела и поверхности,

– линия эскиза,

– набор вышеперечисленных объектов,

– координатная или вспомогательная ось,

– массив кривых,

– группа изопараметрических кривых.

Базовую кривую следует указывать в окне или в Дереве построения.

Выбор объектов в окне модели

Выбор объектов в Дереве построения

Название выбранного объекта или количество выбранных объектов отображается в поле рядом с переключателем.

Обратите внимание на то, что ось, массив кривых и группа изопараметрических кривых не могут входить в набор объектов, составляющих базовую кривую. Поэтому выбор, например, новой оси отменяет выбор всех остальных объектов, входивших в базовую кривую.

Чтобы изменить базовую кривую, активизируйте переключатель Кривая или вызовите из контекстного меню команду Выбор кривой, а затем укажите нужные объекты. Повторное указание объекта отменяет его выбор.

Подробнее о построении проекционной кривой...


Элемент Направление

Элемент управления, позволяющий задать направление проецирования базовой кривой на заданную поверхность проецирования.

Направление проецирования можно задать с помощью направляющего объекта или вектора.

В качестве направляющего объекта может использоваться любой прямолинейный или плоский объект.

Направление, задаваемое прямолинейным объектом — прямая, параллельная объекту.

Направление, задаваемое плоским объектом — прямая, перпендикулярная объекту.

Направляющий объект следует указывать в Дереве построения или в окне модели.

Выбор объектов в окне модели

Выбор объектов в Дереве построения

Построение вектора

Название указанного объекта отображается в поле Направление. Если направление задано вектором, то в этом поле отображается слово «Вектор».

Чтобы сменить направляющий объект, активизируйте переключатель Направление или вызовите из контекстного меню команду Выбор направления, а затем укажите нужный направляющий объект или постройте вектор.

Все изменения немедленно отображаются на фантоме проекционной кривой в окне модели.

Подробнее о построении проекционной кривой...


Элемент Поверхность

Переключатель, позволяющий задать поверхность проецирования базовой кривой.

В качестве поверхности проецирования может использоваться:

– грань тела или поверхности;

– координатная или вспомогательная плоскость;

– набор граней тел и/или поверхностей.

Для задания поверхности проецирования активизируйте переключатель Поверхность или вызовите из контекстного меню команду Выбор поверхности, а затем укажите в окне модели нужную грань или плоскость.

Название выбранного объекта отображается в поле Поверхность на Панели свойств.

Если в набор граней нужно добавить все грани какого-либо тела или поверхности, укажите это тело или поверхность в Дереве построения.

Выбор объектов в окне модели

Выбор объектов в Дереве построения

Повторное указание объекта отменяет его выбор.

Обратите внимание на то, что плоскость не может входить в набор объектов, составляющих поверхность проецирования. Поэтому выбор новой плоскости отменяет выбор всех остальных объектов, входивших в поверхность проецирования.

Подробнее о построении проекционной кривой...


Опция Усечение по границам

Опция, позволяющая выбрать вариант построения проекции.

– При включенной опции проекция базовой кривой строится в пределах контура грани (обрезана по контуру грани). Если в качестве поверхности проецирования используется набор граней, то проекция базовой кривой обрезается по контуру каждой грани набора.

– При отключенной опции строится вся проекция базовой кривой. Базовая кривая проецируется на теоретическую поверхность грани. При необходимости теоретическая поверхность грани продлевается.

Варианты построения проекции базовой кривой...

Обратите внимание на следующие особенности проецирования:

– Проекция базовой кривой на плоскость всегда строится полностью.

– Если в качестве базовой кривой указана ось, то ее проекция всегда строится в пределах контура поверхности проецирования.

В обоих случаях опция Усечение по границам недоступна.


Группа Тип проекции

Группа переключателей, позволяющая выбрать тип проекции базовой кривой на заданную поверхность проецирования.

Если активен переключатель По нормали к поверхности, базовая кривая проецируется по нормали к заданной поверхности проецирования.

Если активен переключатель По направлению, базовая кривая проецируется в направлении, заданном объектом или вектором. Направляющий объект следует указывать в Дереве или в окне модели. Для создания вектора служит команда Построение вектора.

Подробнее о типах проекций базовой кривой...

Подробнее о построении проекционной кривой...


Опция Удалить предыдущие

Позволяет удалить все предыдущие условия фильтрации, заданные при помощи команды Применить фильтр.

Опция находится на Панели свойств, если команда Применить фильтр вызвана повторно.

Если опция включена, то предыдущие условия не учитываются — фильтрация будет произведена исключительно с новыми условиями. Если опция выключена, то новые условия будут применены дополнительно к предыдущим.


Опция Учитывать регистр

Включите опцию Учитывать регистр, чтобы при поиске учитывался регистр — заглавные или строчные буквы. Например, значение «Деталь» и «деталь» будут восприниматься как разные.

При выключенной опции регистр не учитывается.


Группа элементов В колонке (поиск строки в отчете)

Группа элементов В колонке
(поиск строки в отчете)

Группа элементов позволяет производить поиск в одной колонке отчета.

При включенной опции В колонке становится доступен список Колонка, из которого можно выбрать колонку по имени столбца.

Если опция выключена, то поиск производится во всем отчете.


Опция Ячейка целиком (поиск строки в отчете)

Опция Ячейка целиком
(поиск строки в отчете)

Включите опцию, если требуется найти ячейку целиком — ячейку, которая содержит только заданный текст и не содержит других символов.


Группа переключателей Назначить цвет

Группа переключателей позволяет выбрать способ назначения цвета и оптических свойств для объекта.

Настройка оптических свойств возможна для объектов, имеющих поверхность, например, тел. Для объектов без поверхности (точек, кривых, эскизов и т.п.) оптические свойства не задаются.

Результат настройки зависит от типа объекта.

Название переключателя;
для каких объектов доступен

Результат использования переключателя

По исходному объекту
доступен для всех объектов

– Грань получает цвет и оптические свойства, заданные для операции, в результате которой образовалась эта грань.

– Операции (в том числе массивы), тела, поверхности, кривые, оси и другие объекты модели получают цвет, заданный для модели (или исполнения, если оно есть); объекты, имеющие поверхность, получают также оптические свойства модели или исполнения.

По источнику
доступен для операций, в том числе массивов, и компонентов

– Операция получает цвет и оптические свойства, заданные для тела (или поверхности), которое она формирует.

– Массив получает цвет и оптические свойства, заданные для копируемого объекта.

– Компонент отображается в текущей модели так же, как он выглядит в своем файле.

По слою
доступен для объектов, которые могут размещаться на слоях (все объекты, кроме операций и граней)

Позволяет назначить настраиваемому объекту цвет и оптические свойства слоя, на котором находится этот объект.

Вручную
доступен для всех объектов

Позволяет назначить настраиваемому объекту произвольный цвет и оптические свойства.

После активизации этого переключателя на Панели свойств появляется список Цвет для выбора цвета объекта.

Если для объекта возможна настройка оптических свойств, то становится доступна панель Оптические свойства.


Список КолонкаФильтр строк

Список Колонка
Фильтр строк

Раскрывающийся список, из которого можно выбрать столбец для задания ему условия.

В списке доступны имена столбцов текущего стиля.

Элемент управления доступен, если на панели Условия фильтрации задано свойство.


Список СвойствоФильтр объектов

Список Свойство
Фильтр объектов

Раскрывающийся список, из которого можно выбрать свойство для задания ему условия.

В списке доступны свойства, подключенные в документ.

Элемент управления доступен, если на панели Условия фильтрации задано свойство.


Список Условие

Раскрывающийся список, из которого можно выбрать условие для свойства, отображенного в поле Свойство.

Элемент управления доступен, если на панели Условия фильтрации задано свойство.


Поле Текст (поиск строки в отчете)

Поле Текст
(поиск строки в отчете)

Задайте текст, который требуется найти. Его также можно выбрать из списка, в котором находятся ранее использованные фрагменты текста.


Список Значение

Поле, в которое следует ввести значение свойства, отображенного в поле Свойство. Значение можно выбрать из раскрывающегося списка, в котором находятся ранее использованные значения.

Элемент управления доступен, если на панели Условия фильтрации задано свойство.


Группа Направление (поиск строки в отчете)

Группа Направление
(поиск строки в отчете)

Группа переключателей, позволяющая выбрать направление поиска.

– При активном переключателе К концу документа поиск ведется по ходу документа.

– При активном переключателе К началу документа поиск ведется в обратном направлении.

– При активном переключателе Найти все в отчете будут сразу найдены все строки с искомым текстом.


Панель Список свойств

Находится на Панели свойств при настройке свойств текущего документа или входящего в него объекта. Содержит список свойств текущего документа и позволяет управлять этим списком.

Описание элементов управления

Элемент

Описание

Список свойств

Список содержит свойства текущего документа, отображение которых включено. В список входят как системные, так и дополнительные свойства.

Значения свойств задаются пользователем. Ячейки системных свойств могут быть заполнены автоматически. Ячейки свойств, недоступные для редактирования, имеют серый фон.

Подробнее...

Свойства источника

Кнопка находится на Панели свойств при настройке свойств модели. Доступна для компонента и его тел.

Кнопка позволяет просмотреть свойства компонента, хранящиеся в файле этого компонента. После нажатия кнопки на экране появляется информационное окно, содержащее дату просмотра информации, полное имя файла компонента и список его свойств.

Управление свойствами

Кнопка позволяет редактировать список свойств текущего документа, создавать и изменять библиотеки свойств. Вызывает диалог Управление свойствами.

Настройка списка свойств

Кнопка позволяет настроить отображение свойств в списке свойств текущего документа. Вызывает настроечный диалог.

Выбрать обозначение из справочника

Кнопка позволяет выбрать из внешнего Справочника обозначение объекта (Классификатор ЕСКД). Справочник должен быть подключен к системе КОМПАС-3D.

Доступна для всех объектов, за исключением тел, при выделении свойства Обозначение.

Выбрать материал из списка1

Кнопка позволяет выбрать материал из справочного файла плотностей (файл ...\ASCON\KOMPAS-3D V...\Sys\Grарhic.dns; значения плотностей материалов, содержащиеся в нем, могут редактироваться пользователем).

Доступна при выделении свойства Материал.

Выбрать материал из справочника1

Кнопка позволяет выбрать материал из внешнего Справочника (Справочник должен быть подключен к системе КОМПАС-3D).

Доступна при выделении свойства Материал, Заменитель материала или Покрытие.

Вставить ссылку

Кнопка позволяет вставить ссылку в значении свойства на объект в документе. Доступна при выделении свойства, за исключением свойства с типом данных логический.

После вызова команды на экране появится диалог, в котором необходимо задать параметры ссылки.

Подробнее...

Удалить значение

Кнопка позволяет удалить значение свойства текущего документа. Доступна при выделении значения, заданного пользователем на панели Список свойств.

Если значение свойства может быть получено из источника, то после выполнения удаления поле значения свойства автоматически заполняется значением из источника.
  1. В документе-модели кнопка находится на панели Материал вкладки Параметры МЦХ.

В ассоциативном чертеже можно просмотреть свойства модели, по которой этот чертеж создан. Но эти свойства недоступны для редактирования.


Координаты R и A

Поля для ввода или задания счетчиком полярных координат точки R и A.

При задании положения точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Если точка связана с точечным объектом (на кнопке Объект при этом отображается «галочка»), то поля координат недоступны для ввода.

Подробнее о построении точки по координатам на плоскости...


Поле Шаг радиальный(построение группы точек по поверхности)

Поле Шаг радиальный
(построение группы точек по поверхности)

Поле значения шага концентрической сетки в радиальном направлении.

Вы можете ввести значение вручную или установить с помощью счетчика.

Изменение шага немедленно отображается на фантоме группы точек в окне модели.

Поле присутствует на Панели свойств, если в списке Тип сетки выбран тип сетки Концентрическая.

Подробнее о построении группы точек по поверхности...


Поле Коэффициент

Поле коэффициента масштабирования.

Вы можете ввести значение вручную или установить при помощи счетчика.

Шаг изменения значения при задании счетчиком — 0,01.

Поле становится доступно после того, как выбрано тело или поверхность для масштабирования.


Угол поворота растровой вставки

Поле, в котором можно ввести угол поворота растровой вставки.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Базовая точка растровой вставки

Поля координат базовой точки растровой вставки.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Файл-источник

Поле, в котором отображается полное имя файла-источника растровой вставки.

При необходимости в это поле можно ввести имя другого файла источника для вставки.


Информация о растровом объекте

Окно, содержащее следующие сведения о вставленном растровом объекте:

габариты — вертикальный и горизонтальный размеры изображения, которые получатся, если документ будет напечатан без изменения масштаба;

цветовая палитра — цветовое разрешение графического файла;

исходный размер в пикселах — количество пикселов по вертикали и горизонтали;

разрешение — разрешение изображения (количество пикселов в одном дюйме).

При изменении значений в полях Разрешение и Масштаб на Панели свойств значения в строках Ширина, мм и Высота, мм пересчитываются.


Разрешение растра

Поле, в котором можно ввести или выбрать из списка разрешение растрового изображения.

Это поле присутствует на Панели свойств, если в файле-источнике нет сведений о разрешении изображения.


Масштаб растровой вставки

Поле, в котором можно ввести масштаб растровой вставки.

При изменении масштаба пересчитываются значения в строках Высота и Ширина окна информации о растровом объекте.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Поле Количество лучей(построение группы точек по поверхности)

Поле Количество лучей
(построение группы точек по поверхности)

Поле для задания количества радиальных лучей концентрической сетки.

Введите или задайте счетчиком нужное количество радиальных лучей сетки.

Поле присутствует на Панели свойств, если в списке Тип сетки выбран тип сетки Концентрическая.

Подробнее о построении группы точек по поверхности...


Угол(наклона прямоугольника)

Угол
(наклона прямоугольника)

Поле угла наклона создаваемого прямоугольника.

Необходимое значение угла можно ввести с клавиатуры или выбрать из списка значений.

Угол наклона прямоугольника отсчитывается от оси абсцисс текущей системы координат.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Вершина прямоугольника

Поле координат вершины создаваемого прямоугольника.

При указании вершины мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений с клавиатуры.

Точка, заданная указанием или координатами, может не принадлежать прямой, проходящей через т1 (середину стороны прямоугольника) перпендикулярно к отрезку, соединяющему т1 и центр прямоугольника. В таком случае в качестве вершины прямоугольника будет использоваться проекция заданной точки на эту прямую.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Середина стороны прямоугольника

Поле координат середины стороны создаваемого прямоугольника.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Группа Способ

Группа переключателей, позволяющая выбрать способ построения прямоугольника по трем точкам.

По трем точкам. При использовании этого способа следует указать три вершины прямоугольника.

По центру и двум точкам. При использовании этого способа следует указать центр, середину одной и сторон и вершину прямоугольника.

Вместо переключателей можно использовать одноименные им команды контекстного меню.

Для быстрого переключения способа используйте сочетание клавиш <Ctrl>+<Tab>.


Центр прямоугольника

Поля координат центра создаваемого прямоугольника.

При указании центра мышью координаты точки определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Вершина прямоугольника

Поля координат вершины создаваемого прямоугольника.

При указании вершины мышью координаты точки определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Высота прямоугольника

Поле высоты создаваемого прямоугольника.

При указании вершины прямоугольника мышью его высота определяется автоматически и заносится в это поле.

Возможен также ввод значения высоты с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Группа Способ

Группа переключателей, позволяющая выбрать способ построения прямоугольника по двум точкам.

По двум вершинам. При использовании этого способа следует указать две противоположные вершины прямоугольника.

По центру и вершине. При использовании этого способа следует указать центр и одну из вершин прямоугольника.

Вместо переключателей можно использовать одноименные им команды контекстного меню.

Для быстрого переключения способа используйте сочетание клавиш <Ctrl>+<Tab>.


Первая вершина прямоугольника

Поля координат первой вершины создаваемого прямоугольника.

При указании вершины мышью координаты точки определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Вторая вершина прямоугольника

Поля координат второй вершины создаваемого прямоугольника.

При указании вершины мышью координаты точки определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Третья вершина прямоугольника

Поле координат третьей вершины создаваемого прямоугольника.

При указании вершины мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений с клавиатуры.

Точка, заданная указанием или координатами, может не принадлежать прямой, проходящей через т2 (вторую вершину прямоугольника) перпендикулярно к отрезку, соединяющему т2 и т1 (первую вершину прямоугольника). В таком случае в качестве третьей вершины прямоугольника будет использоваться проекция заданной точки на эту прямую.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Ширина прямоугольника

Поле ширины создаваемого прямоугольника.

При указании вершины прямоугольника мышью его ширина определяется автоматически и заносится в это поле.

Возможен также ввод значения ширины с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Элемент Объект

Служит индикатором наличия ассоциативной связи точки с точечным объектом.

Если связь есть, то на кнопке Объект отображается «галочка», а в поле Объект — наименование точечного объекта.

Если связи нет, то «галочка» на кнопке Объект не отображается, а поле Объект пусто.

Связь формируется, если при указании точечного объекта включена опция Ассоциировать.

При необходимости связь можно отменить, нажав кнопку Объект. «Галочка» на кнопке исчезнет.

Для восстановления ассоциативной связи точки с точечным объектом необходимо включить опцию Ассоциировать и указать нужный объект заново.


Элемент Объект

Служит индикатором наличия ассоциативной связи текущей вершины ребра поверхности с точечным объектом, находящимся на ее границе. Выбор текущей вершины производится с помощью группы переключателей Начальная/конечная вершина.

Если связь есть, то на кнопке Объект отображается «галочка», а в поле Объект — наименование точечного объекта.

Если связи нет, то «галочка» на кнопке Объект не отображается, а поле Объект пусто.

При необходимости связь можно отменить, нажав кнопку Объект. «Галочка» на кнопке исчезнет. После отмены связи с точечным объектом вершину ребра можно произвольно перемещать мышью вдоль границы.

Для восстановления ассоциативной вершины с точечным объектом его необходимо указать заново.

Подробнее об управлении разбиением поверхности на грани...


Элемент Объект

Служит индикатором наличия ассоциативной связи начала ЛСК с точечным объектом.

Если связь есть, то на кнопке Объект отображается «галочка», а в поле Объект — наименование точечного объекта.

Если связи нет, то «галочка» на кнопке Объект не отображается, а поле Объект пусто.

При необходимости связь можно отменить, нажав кнопку Объект. «Галочка» на кнопке исчезнет.

Для восстановления ассоциативной связи начала ЛСК с точечным объектом его необходимо указать заново.


Элемент Опорная точка

Служит для выбора опорной точки, необходимой для построения переносом.

При нажатой кнопке Опорная точка система ожидает указания в модели опорной точки.

После указания в поле Опорная точка отобразится наименование объекта.

– Если направляющий объект не определен, то после указания опорной точки становятся доступны поля ввода координат.

– Если в поле Направляющий объект отображено наименование объекта, то после указания опорной точки становится доступно поле Расстояние.

Чтобы сменить опорную точку, следует вновь нажать кнопку и произвести указание.

Подробнее о построении переносом...


Центр

Поля координат центра контура, ограничивающего выносной элемент или обозначение узла.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Диаметр

Поле диаметра окружности, ограничивающей выносной элемент или обозначение узла.

При указании точки контура мышью диаметр определяется автоматически и заносится в это поле.

Возможен также ввод значения диаметра с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Высота

Поле высоты прямоугольника, ограничивающего выносной элемент или обозначение узла.

При указании вершины прямоугольника мышью его высота определяется автоматически и заносится в это поле.

Возможен также ввод значения высоты с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Радиус

Поле радиуса окружности, ограничивающей выносной элемент или обозначение узла.

При указании точки контура мышью радиус определяется автоматически и заносится в это поле.

Возможен также ввод значения радиуса с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Точка начала полки

Поля координат точки начала полки выносного элемента или обозначения узла.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод координат с клавиатуры.

Для вызова щелкните над полем правой кнопкой мыши.


Радиус скругления

Поле для ввода радиуса скругления углов прямоугольника, ограничивающего выносной элемент или обозначение узла.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Полка

Список, позволяющий выбрать направление полки выносного элемента или обозначения узла.


Форма

Список, позволяющий выбрать форму контура выносного элемента или обозначения узла.


Ширина

Поле ширины прямоугольника, ограничивающего выносной элемент или обозначение узла.

При указании вершины прямоугольника мышью его ширина определяется автоматически и заносится в это поле.

Возможен также ввод значения ширины с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Группа переключателей Способ размещения

Позволяет выбрать способ размещения компонента в модели при вставке компонента или изменении его положения командой Разместить компонент.

Для выбора нужного способа активизируйте соответствующий переключатель. Набор элементов управления Панели свойств будет соответствовать выбранному способу.

Доступны следующие варианты:

– По координатам,

– По сопряжениям.

Для выбора нужного способа можно также использовать соответствующие команды контекстного меню


Группа элементов Способ в чертеже

Группа элементов Способ
в чертеже

Позволяет выбрать способ указания объектов в чертеже.

Если активен переключатель По текущему виду, то в отчет включаются все объекты текущего вида.

Если активен переключатель По всем видам, то в отчет автоматически включаются объекты из всех видов чертежа.

Если активен переключатель По указанным объектам, то объекты следует выбирать вручную, щелкая по ним мышью. Укажите объекты.

Опция Уровень чтения моделей служит для ввода или выбора из списка уровня, до которого включительно производится выбор объектов из сборок в ассоциативных видах чертежа. При включенной опции доступен список для выбора уровня.

Выбранные объекты подсвечиваются. Чтобы отменить выбор объекта, щелкните по нему повторно.

Выделение объектов с помощью команд...

Объекты могут быть выделены до вызова команды. В этом случае активен переключатель По указанным объектам, а объекты считаются выбранными вручную.

При выборе объектов вы можете указать тип объектов на вкладке Объекты Панели свойств.

Подробнее о способах указания объектов...


Группа элементов Способ в модели

Группа элементов Способ
в модели

Позволяет выбрать способ указания объектов в модели.

Если активен переключатель По всем объектам до указанного уровня, то в отчет по сборке автоматически включаются компоненты до заданного уровня и тела, полученные операциями в сборке.

По умолчанию выбираются объекты первого уровня.

В поле Уровень задайте номер уровня, до которого включительно производится автовыбор объектов.

Если активен переключатель По всем уровням, то в отчет по сборке автоматически включаются компоненты всех уровней и тела, полученные операциями в сборке.

Если активен переключатель По указанным объектам, то объекты следует выбирать вручную. Укажите объекты. Если требуется, вы можете указать и саму модель. Выбранные объекты подсвечиваются. Чтобы отменить выбор объекта, щелкните по нему повторно.

Чтобы выбрать тела, построенные операциями в сборке или детали, необходимо использовать способ По указанным объектам.

Выбор объектов в окне модели

Выбор объектов в Дереве построения

Объекты могут быть выделены до вызова команды. В этом случае активен переключатель По указанным объектам, а объекты считаются выбранными вручную.

При выборе объектов вы можете

– указать тип объектов на вкладке Объекты Панели свойств,

– фильтровать объекты по свойствам в модели.

Подробнее о способах указания объектов...


Группа элементов Компоновка

Группа элементов служит для задания параметров компоновки на листе следующих таблиц:

– таблиц отчета;

– таблицы исполнений модели (если таблица разбита на несколько таблиц);

– таблицы отчета по массиву (если таблица разбита на несколько таблиц).

Выберите способ в списке Компоновка.

– При выборе способа Вправо, затем вниз таблицы располагаются горизонтальными рядами. В поле Вправо не более задайте максимальное количество таблиц в горизонтальном ряду.

– При выборе способа Вниз, затем вправо таблицы располагаются вертикальными рядами. В поле Вниз не более задайте максимальное количество таблиц в вертикальном ряду.

Задайте в поле Зазор, мм или выберите из списка расстояние между границами таблиц в рядах.

Настройка параметров размещения таблиц сохраняется на Панели свойств до конца сеанса работы с документом.


Элементы управления Уровень чтения моделей

Служит для ввода или выбора из раскрывающегося списка уровня, до которого включительно производится выбор объектов из сборок в ассоциативных видах чертежа.

Например, сборка содержит компоненты и входящие в них детали. Значение 1 означает, что выбор объектов происходит из компонентов, а значение 2 — из компонентов и деталей.

Включите опцию Уровень чтения моделей, затем задайте или выберите из списка номер уровня. Если опция выключена, то выбор осуществляется по всем уровням.


Элемент управления Уровень

Служит для ввода или выбора из раскрывающегося списка уровня, до которого включительно производится выбор объектов.

Например, сборка содержит компоненты и входящие в них детали. Значение 1 означает, что выбор объектов происходит из компонентов, а значение 2 — из компонентов и деталей.

Элемент управления доступен, если активен переключатель По всем объектам до указанного уровня в группе Способ.


Список Новый документ

Список, из которого можно выбрать тип файла нового документа для размещения в нем отчета по модели.


Список Стиль

Позволяет выбрать стиль отчета из списка стилей, подключенных к системе.

В поле Стиль отображается имя текущего стиля отчета.

Следующие стили хранятся в системе КОМПАС-3D и постоянно доступны:

– По умолчанию — пример настройки для отчета по нескольким свойствам;

– По всем свойствам — пример настройки для отчета по всем локальным свойствам текущего документа.

Выберите стиль из раскрывающегося списка Стиль.

Щелчок на строке Другой... позволяет выбрать стиль из внешней библиотеки стилей и подключить его.

Любой стиль можно произвольным образом отредактировать. Для этого следует нажать кнопку Настроить... Чтобы использовать стиль повторно, его следует сохранить в библиотеку и подключить к системе.

Настройка и сохранение стилей...


Опция В новый документ

Включите опцию В новый документ, чтобы разместить отчет в новом документе — текстовом или графическом. Тип файла следует выбрать в списке Новый документ на Панели свойств.

Если опция выключена, то отчет размещается в ранее созданном документе.

Элементы управления размещения в новом документе доступны при создании отчета по модели — на вкладке Отчет и на вкладке Параметры в Окне подготовки данных.


Переключатель Окно подготовки данных

Переключатель служит для выбора варианта продолжения процесса создания отчета.

– При активном переключателе Окно подготовки данных после нажатия кнопки Создать отчет на Панели специального управления происходит переход в Окно подготовки данных (вариант по умолчанию).

Если выбран данный вариант, то перед размещением в документе отчет можно просмотреть на экране, отредактировать содержимое и сделать настройки внешнего вида.

– При неактивном переключателе после нажатия кнопки Создать отчет можно сразу перейти к размещению отчета в документе.

Если выбран данный вариант, то производится размещение отчета с теми настройками, которые заданы на Панели свойств (без просмотра и редактирования).

В этом случае настройте компоновку таблиц на вкладке Компоновка. В документе-модели при необходимости включите опцию В новый документ и выберите тип нового документа на вкладке Отчет.


Кнопка Настроить...

Вызывает диалог настройки параметров стиля отчета. В диалоге можно изменить параметры текущего стиля, а также создать новый стиль и сохранить его в библиотеку стилей.


Кнопка Настроить...

Кнопка позволяет вызвать диалог настройки параметров таблицы отчета по массиву. В этом диалоге можно сформировать набор переменных массива, данные о которых будут содержаться в отчете по этому массиву, настроить параметры отображения этих данных в таблице отчета, создать или изменить заголовок таблицы, расположение т.п.

Кнопка доступна на Панели свойств, если массив для создания отчета по этому массиву выбран.


Кнопка Настроить...

Кнопка позволяет настроить параметры таблицы исполнений модели. Вызывает диалог настройки параметров.


Список Центр

Раскрывающийся список позволяет задать центр вращения, масштабирования или выравнивания полюсов сетки. Описание возможных вариантов задания центра приведено в таблице.

Варианты задания центра вращения

Вариант

Описание

Нет

Вариант доступен для вращения или выравнивания полюсов. Позволяет определить положение оси вращения, прямой (плоскости) выравнивания без задания центра.

При вращении полюсов ось вращения совпадает с направляющим объектом либо с нормалью к этому объекту (для направления Перпендикулярно объекту).

При выравнивании полюсов прямая (плоскость), на которую перемещаются полюсы, совпадает с выбранным прямолинейным (плоским) объектом или нормалью к этому объекту (для варианта Перпендикулярно объекту).

ЛСК

Центр совпадает с началом текущей системы координат.

Центр объекта

Центр совпадает с центром масс редактируемой грани. Координаты центра масс рассчитываются для той формы грани, которую она имеет на момент редактирования.

Центр выбранных

Центр совпадает с центром масс выбранных полюсов. Для расчета центра масс полюсы представляются материальными точками одинакового веса.

Точка

В качестве центра указывается произвольный точечный объект, в том числе один из полюсов сетки. При выборе этого варианта на Панели свойств присутствует переключатель Объект центра.

Для задания центра вместо раскрывающегося списка можно использовать следующие команды контекстного меню:

– Нет,

– ЛСК,

– Центр объекта,

– Центр выбранных,

– Точка.


Поле Угол вращения

Служит для задания угла вращения при перемещении выбранных полюсов сетки вращением.

Значение угла вводится вручную или задается с помощью счетчика. Оно может быть как положительное, так и отрицательное. При положительном значении угла вращение полюсов выполняется в направлении, указанном стрелками, при отрицательном — в противоположном направлении.


Поле Угол прямого направления

Поле значения угла, на который требуется вращать сечение в прямом направлении.

Вы можете ввести значение вручную или установить с помощью счетчика.

Изменение угла вращения немедленно отображается на фантоме элемента в окне модели.


Элемент управления Вершина

Элемент управления, позволяющий задать точечный объект для ограничения угла поворота при построении элемента (либо поверхности) вращения. Элемент управления Вершина присутствует на Панели свойств, если в списке Способ выбран вариант До вершины.

Чтобы сменить или задать точечный объект, активизируйте переключатель Вершина на Панели свойств или вызовите команду Вершина из контекстного меню окна модели.

Затем укажите нужный объект в Дереве построения или в окне модели. Название выбранного объекта появляется в поле Вершина.

Автоматически вычисляется такой угол поворота, при котором торец элемента занимает положение, ближайшее к указанной вершине.

Если требуется отсечь элемент плоскостью, проходящей через указанную вершину и ось вращения, включите опцию Отсекать.

Подробнее о вращении до вершины...


Поле Угол обратного направления

Поле значения угла, на который требуется вращать сечение в обратном направлении.

Вы можете ввести значение вручную или установить с помощью счетчика.

Изменение угла вращения немедленно отображается на фантоме элемента в окне модели.


Выбор направления вращения

Элемент может вращаться как в одну, так и в другую сторону относительно сечения.

Одно из возможных направлений автоматически определяется системой как Прямое и показывается стрелкой на фантоме элемента в окне модели.

При выборе Прямого направления вращение будет производиться по стрелке, при выборе Обратного направления — в противоположную сторону.

Иногда элемент требуется вращать в обоих направлениях относительно сечения. В этом случае выберите вариант Два направления.

Еще один вариант — Средняя плоскость. Его выбор означает, что выдавливание будет производиться в обе стороны симметрично относительно сечения.


Элемент управления Грань

Элемент управления, позволяющий задать грань или плоскость для ограничения угла поворота при построении элемента (либо поверхности) вращения. Элемент управления Грань присутствует на Панели свойств, если в списке Способ выбран вариант До поверхности.

Чтобы сменить или задать грань, активизируйте переключатель Грань на Панели свойств или вызовите команд у Грань из контекстного меню окна модели.

Затем укажите нужный объект в Дереве построения или в окне модели. Название выбранного объекта появляется в поле Грань.

Сечение вращается до указанной поверхности. Торец элемента имеет форму поверхности.

Подробнее о вращении до поверхности...


Переключатель Направление

Переключатель, позволяющий выбрать направление построения ребра жесткости.

Направление показывается фантомной стрелкой в окне модели.


Поле Угол уклона

Поле угла уклона боковых граней ребра жесткости.

Вы можете ввести значение вручную или установить с помощью счетчика.


Угол поворота

Поле угла поворота объектов.

При указании нового положения базовой точки мышью угол поворота определяется автоматически и заносится в это поле.

Возможен также ввод значения с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Новое положение базовой точки

Поля координат нового положения базовой точки.

При указании положения точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Переключатель Центр/ось вращения

Позволяет выполнить вращение компонента вокруг точки (вершины, начала системы координат, точки в эскизе) или вокруг прямолинейного объекта.

Активизируйте переключатель и укажите нужный объект в Дереве построения или в окне модели.


Группа переключателей Режимы(вращение компонента)

Группа переключателей Режимы
(вращение компонента)

Позволяет выполнить следующие варианты вращения компонента:

– Простое вращение — вращение без дополнительных действий (данный переключатель активен по умолчанию),

– Автосопряжения — вращение с автоматическим наложением сопряжений,

– Контроль соударений — вращение с контролем соударений компонентов.


Список Базовая плоскость

Позволяет сменить базовую плоскость обозначения — плоскость, которой параллельна плоскость обозначения. В качестве базовых плоскостей используются координатные плоскости абсолютной системы координат.

Раскройте список и выберите из него название нужной плоскости.

Список доступен:

– при создании и редактировании линии-выноски, обозначения маркировки, клеймения, позиции — пока указано не более двух точек обозначения (например, базовую плоскость линии-выноски можно сменить, если указана точка, на которую указывает ответвление, и точка начала полки);

– при создании и редактировании обозначения допуска — если указано две точки: точка, определяющая положение рамки, и точка начала одного ответвления,

– при создании обозначения шероховатости и базы — если указана одна точка,

– при редактировании обозначения шероховатости и базы — всегда.

Если при задании положения плоскости обозначения указан объект фиксации, то список Базовая плоскость недоступен. В этом случае, чтобы сменить базовую плоскость, необходимо сначала отменить фиксацию плоскости обозначения.


Поле Объект

В этом поле отображается название объекта, выбранного для создания обозначения шероховатости или базы в трехмерной модели.

Чтобы сменить объект для обозначения, нажмите кнопку Указать заново на Панели специального управления и укажите в окне модели новый объект. Кнопка доступна, если для обозначения выбран какой-либо объект.


Точка начала линии-выноски

Поля координат точки начала линии-выноски для простановки обозначения шероховатости.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Положение знака или начала выноски

Поля координат точки привязки обозначения шероховатости или начала линии-выноски (если знак располагается на полке).

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.

Возможен также ввод значений координат с клавиатуры.

Если указанная точка не принадлежит выбранному объекту, за точку привязки принимается проекция указанной точки на этот объект.


Стрелка

Список, позволяющий выбрать вид стрелки при простановке обозначения шероховатости на полке линии-выноски. Перечень стрелок, доступных для выбора, а также порядок следования стрелок в списке определяется настройкой фильтра стрелок, сделанной для текущего документа.


Тип знака

Группа переключателей, позволяющая указать тип знака шероховатости: без указания вида обработки, с удалением слоя материала или без удаления слоя материала.


Полка

Список, позволяющий выбрать направление полки линии-выноски для простановки обозначения шероховатости.

Смотрите также

Управление расположением знака шероховатости


Переключатели Границы вдоль U

Позволяет зафиксировать границы сетки, расположенные вдоль направления U.

По умолчанию ни одна из границ сетки не зафиксирована, поэтому в группе активен переключатель Нет фиксации.

Чтобы зафиксировать полюсы нужных границ, используйте следующие переключатели:

– Обе границы сетки,

– Первая граница сетки,

– Вторая граница сетки.

Для фиксации границ сетки вдоль направления U вместо переключателей Панели свойств можно использовать следующие команды контекстного меню:

– Границы вдоль U — Обе границы,

– Границы вдоль U — Первая граница,

– Границы вдоль U — Вторая граница,

– Границы вдоль U — Не фиксировать.


Переключатели Границы вдоль V

Позволяет зафиксировать границы сетки, расположенные вдоль направления V.

По умолчанию ни одна из границ сетки не зафиксирована, поэтому в группе активен переключатель Нет фиксации.

Чтобы зафиксировать полюсы нужных границ, используйте следующие переключатели:

– Обе границы сетки,

– Первая граница сетки,

– Вторая граница сетки.

Для фиксации границ сетки вдоль направления V вместо переключателей Панели свойств можно использовать следующие команды контекстного меню:

– Границы вдоль V — Обе границы,

– Границы вдоль V — Первая граница,

– Границы вдоль V — Вторая граница,

– Границы вдоль V — Не фиксировать.


Поле Строк в таблице

Для таблицы исполнений модели, представляемой в виде нескольких таблиц, поле позволяет задать максимальное количество строк, входящих в каждую таблицу. Соответственно этому значению общий список исполнений будет разделен на несколько списков, каждый из которых помещается в отдельную таблицу.

Поле доступно при включенной опции Разбить таблицу.


Панель Объекты вида

Список, из которого можно задать тип объектов, помещаемых в отчет.

Включенная опция означает, что в выборе объектов для отчета будут участвовать объекты данного типа. Если опция выключена, то объекты данного типа автоматически исключаются из выбранных.

Если Панель свойств расположена горизонтально, то для открытия и закрытия панели со списком требуется нажать кнопку Объекты вида.


Панель Объекты модели

Список, из которого можно задать тип объектов, помещаемых в отчет:

– в документе-модели — типы самих объектов;

– в ассоциативных чертежах — типы объектов, участвующих в создании вида.

Включенная опция означает, что в выборе объектов для отчета будут участвовать объекты данного типа. Если опция выключена, то объекты данного типа автоматически исключаются из выбранных.

Если Панель свойств расположена горизонтально, то для открытия и закрытия панели со списком требуется нажать кнопку Объекты модели.


Переключатель Обозначение

Переключатель позволяет задать порядок отображения обозначений исполнений модели в таблице исполнений.

Если активным является переключатель Только номера исполнений, то для первого исполнения в таблице отображается полное обозначение, а для остальных исполнений — только номера.

Если активным является переключатель Полные обозначения, то обозначение каждого исполнения отображается полностью.


Элемент Кривая 1 (2)

Элемент управления, позволяющий задать первую (вторую) направляющую линейчатой поверхности.

Направляющей может служить:

– пространственная кривая,

– ребро,

– линия эскиза,

– цепочка вышеперечисленных объектов в любом сочетании.

В качестве одной из направляющих можно использовать точечный объект.

Чтобы перейти к указанию объектов, активизируйте переключатель Кривая 1 (2) на Панели свойств или вызовите команду Кривая 1 (2) из контекстного меню.

Выбор объектов в окне модели

Выбор объектов в Дереве построения

Название выбранного объекта или их количество (в случае указания цепочки) отображается в поле Кривая 1 (2).

Если требуется отменить выбор объекта, активизируйте нужный переключатель и укажите этот объект.

Чтобы указать точку вместо кривой (кривых), необходимо сначала отменить выбор этой кривой (кривых) и наоборот.

Если требуется отменить выбор сразу всех объектов, нажмите кнопку Указать заново на Панели специального управления.


Группа Начальная/конечная вершина

Группа переключателей, позволяющая сделать текущей нужную вершину ребра, выделенного в Списке ребер.

Выбрав вершину, вы можете указать точечный объект на границе поверхности для связи вершины с этим объектом или, если вершина уже была связана с точечным объектом, отменить связь, нажав кнопку Объект.

Одной из направляющих линейчатой поверхности может быть точка. В этом случае группа Начальная/конечная вершина отсутствует на Панели свойств.

Подробнее об управлении разбиением поверхности на грани...


Опция Автоопределение

Опция, включающая и отключающая автоматическое разбиение на грани линейчатой поверхности, поверхности соединения или линейчатой обечайки.

При отключении опции на вкладке Разбиение Панели свойств появляются элементы управления, позволяющие удалять или добавлять ребра, а также отключать ассоциативную связь вершин ребер с границами поверхности для свободного перемещения вершин.

Подробнее об управлении разбиением поверхности на грани...

При включении опции все изменения отменяются и к поверхности применяется автоматическое разбиение на грани.


Опция Компоновочная геометрия

Включите эту опцию, чтобы деталь, полученная преобразованием объектов сборки, была добавлена в эту сборку в виде компоновочной геометрии. При отключенной опции деталь добавляется в сборку в виде компонента.

Опция присутствует на Панели свойств при работе со сборкой.


Группа переключателей Способ

Позволяет указать способ передачи объектов в деталь.

– Активизируйте переключатель Сохранение с историей, чтобы в новую деталь были переданы сами объекты, эскизы, использованные при их построении, и данные об остальных исходных объектах. Тип данных зависит от типа текущей модели:

• если преобразование выполняется в детали, то в новой детали создаются копии геометрии исходных объектов,

• если преобразование выполняется в сборке, то в новой детали формируются ссылки на файл сборки, аналогичные тем, которые формируются в файле компонента во время его редактирования «на месте», если при этом используются объекты других компонентов сборки.

Исходные объекты будут отображаться в Дереве новой детали согласно иерархии; каждый из переданных объектов можно будет отредактировать.

Кроме исходных объектов при сохранении с историей в файл детали передаются также выражения, заданные для вычисления параметров элементов объектов и переменные главного раздела.

– Активизируйте переключатель Сохранение без истории, чтобы в новую деталь были переданы только сами объекты — без исходных объектов, переменных и выражений.

В этом случае Дерево новой детали будет содержать только объекты, выбранные для передачи в деталь — Операции без истории, соответствующие этим объектам. Редактирование таких объектов возможно только путем выполнения новых операций добавления или удаления материала.

При включенной опции Сохранение без истории доступна опция Зеркально.


Опция Зеркально

Позволяет управлять положением объектов, передаваемых в новую деталь. При включенной опции объекты будут расположены симметрично своему исходному положению относительно выбранной плоскости. Данная плоскость выбирается из списка Плоскость симметрии, который становится доступным после включения опции.

Опция Зеркально доступна, если в группе Способ активен переключатель Сохранение без истории.


Поле Соотношение

Поле для ввода соотношения перемещений в механической передаче.

В поле Соотношение вводятся с клавиатуры два действительных числа, обозначающих отношение перемещений в данном сопряжении: первое число обозначает перемещение первого объекта, а второе — перемещение второго объекта, совершаемое одновременно с первым.

По умолчанию соотношение составляет 1:1.

Чтобы изменить соотношение, введите нужные числа вручную.

Значение соотношения можно выбрать из раскрывающегося списка соотношений, ранее использованных в текущем сеансе КОМПАС-3D.

Если при выборе объекта для сопряжения Вращение – вращение указана поверхность вращения, то ее радиус в точке указания передается в одну из частей поля Соотношение. Обратите внимание на то, что радиус первого объекта передается во вторую часть поля, а радиус второго объекта — в первую.

Задание соотношения в зависимости от типа сопряжения...


Центр масштабирования

Поля координат центра масштабирования.

При указании центра мышью его координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Поле коэффициент

Служит для задания коэффициента масштабирования при перемещении выбранных полюсов сетки масштабированием. Значение коэффициента вводится вручную или задается с помощью счетчика.


Список Способ

Раскрывающийся список позволяет выбрать способ масштабирования, который будет использоваться для перемещения полюсов сетки масштабированием. Описание возможных способов масштабирования приведено в таблице.

Способы масштабирования

Вариант

Описание

Равномерное

Масштабирование выполняется вдоль прямой, соединяющей центр масштабирования с выбранным полюсом.

По оси X
По оси Y
По оси Z

Масштабирование выполняется в направлении, параллельном оси Х, Y или Z текущей системы координат.

Параллельно объекту

Масштабирование выполняется в направлении, параллельном указанному прямолинейному объекту или оси цилиндра, конуса, тора.

При выборе этого способа на Панели свойств появляется переключатель Направляющий объект. Укажите нужный объект в Дереве построения или в окне модели.

Перпендикулярно объекту

Масштабирование выполняется в направлении, перпендикулярном указанному плоскому объекту.

При выборе этого способа на Панели свойств появляется переключатель Направляющий объект. Укажите нужный объект в Дереве построения или в окне модели.

В плоскости XY
В плоскости XZ
В плоскости YZ

Масштабирование выполняется в плоскости, параллельной координатной плоскости XY, XZ или YZ текущей системы координат.

В выбранной плоскости

Масштабирование выполняется в плоскости, параллельной указанному плоскому объекту.

При выборе этого способа на Панели свойств появляется переключатель Направляющий объект. Укажите нужный объект в Дереве построения или в окне модели.

Для задания способа масштабирования вместо раскрывающегося списка можно использовать следующие команды контекстного меню:

– Равномерно,

– По оси X,

– По оси Y,

– По оси Z,

– Параллельно объекту,

– Перпендикулярно объекту,

– В плоскости XY,

– В плоскости XZ,

– В плоскости YZ,

– В выбранной плоскости.


Элемент Секущий объект 1

Переключатель, позволяющий задать объект, в точке пересечения с которым должна быть усечена исходная кривая.

В качестве секущего объекта может использоваться:

– любой точечный объект, лежащий на усекаемой кривой (точка начала координат, точка в пространстве, вершины контуров в эскизах, отдельные точки в эскизах, вершины пространственных кривых, вершины ребер и т.п.);

– объект, пересекающийся с исходной кривой:

• координатная и вспомогательная плоскость;

• координатная или вспомогательная ось;

• пространственная кривая;

• ребро тела;

• грань;

• линия эскиза.

Укажите секущий объект в окне модели или в Дереве построения.

Название указанного объекта отображается в поле рядом с переключателем.

Чтобы сменить ранее выбранный секущий объект, активизируйте переключатель Секущий объект 1 и укажите новый объект.


Элемент Секущий объект 2

Переключатель, позволяющий задать второй объект, в точке пересечения с которым должна быть усечена исходная кривая.

В качестве секущего объекта может использоваться:

– любой точечный объект, лежащий на усекаемой кривой (точка начала координат, вершины контуров в эскизах, отдельные точки в эскизе, вершины пространственных кривых, вершины ребер и т.п.);

– объект, пересекающийся с исходной кривой:

• координатная и вспомогательная плоскость;

• координатная или вспомогательная ось;

• пространственная кривая;

• ребро тела;

• грань;

• линия эскиза.

Укажите второй секущий объект в окне модели или в Дереве построения.

Название указанного объекта отображается в поле рядом с переключателем.

Чтобы сменить ранее выбранный секущий объект, активизируйте переключатель Секущий объект 2 и укажите новый объект.

Переключатель присутствует на Панели свойств, если включена опция Два секущих объекта.


Поле Сечение

Справочное поле, в котором отображается наименование эскиза, определяющего форму сечения элемента выдавливания или вращения.


Элемент управления Сечение

Элемент управления, позволяющий задать сечение элемента вращения или поверхности вращения.

Чтобы задать или сменить сечение, активизируйте переключатель Сечение на Панели свойств или вызовите команду Сечение из контекстного меню окна модели. Затем:

– Укажите в Дереве построения или в окне модели один из следующих объектов:

• эскиз,

• грань,

• пространственная кривая,

• ребро.

Название выбранного объекта появится в поле Сечение.

– Или постройте контур. Для запуска команды построения контура нажмите кнопку Контур на Панели специального управления.

Если в качестве сечения используется эскиз, вы можете отредактировать его, не выходя из команды. Для этого нажмите кнопку Редактировать эскиз на Панели специального управления.

Смотрите также

Требования к эскизу элемента вращения

Требования к эскизу поверхности вращения


Поле Основание

Поле, в котором отображается наименование эскиза, являющегося основанием обечайки.

Укажите эскиз в Дереве построения или в окне модели.

После указания название выбранного эскиза появляется в поле Основание.

Повторное указание эскиза отменяет его выбор.

Смотрите также

Требования к эскизу обечайки


Элемент управления Сечение

Элемент управления, позволяющий задать сечение элемента выдавливания или поверхности выдавливания.

Чтобы задать или сменить сечение, активизируйте переключатель Сечение. Затем:

– Укажите в Дереве построения или в окне модели один из следующих объектов:

• эскиз,

• грань,

• пространственная кривая,

• ребро.

Название выбранного объекта появится в поле Сечение.

– Или постройте контур. Для запуска команды построения контура нажмите кнопку Контур на Панели специального управления.

Если в качестве сечения используется эскиз, вы можете отредактировать его, не выходя из команды. Для этого нажмите кнопку Редактировать эскиз на Панели специального управления.

Смотрите также

Требования к эскизу элемента выдавливания

Требования к эскизу поверхности выдавливания


Опция Единые параметры

Позволяет применить выбранный способ сегментации и значение соответствующего параметра ко всем участкам контура обечайки, являющимся дугами окружностей или эллипсов.

Опция Единые параметры присутствует на Панели свойств, если контур обечайки содержит более одной дуги.

По умолчанию опция включена. Если требуется настроить параметры сегментации для какой-либо дуги отдельно, отключите опцию. После этого на Панели свойств появляется панель Кривые, содержащая перечень дуг контура обечайки. При выделении строки в списке соответствующий ей участок контура подсвечивается в окне модели.

Выделите в списке строку с номером нужной дуги и задайте параметры сегментации.

Для отмены сегментации дуги отключите опцию рядом с ее номером.


Способы сегментации

Сегментация представляет собой замену дуг окружностей и эллипсов в контуре обечайки аппроксимирующими ломаными с сегментами равной длины.

Доступно несколько способов сегментации.

Выберите нужный переключатель группы Способ. В зависимости от выбранного варианта на Панели свойств появляется поле ввода значения параметра.

Описание способов сегментации
Наименование | Параметр, определяющий количество сегментов ломаной
По количеству сегментов | В поле ввода Количество сегментов задается количество сегментов аппроксимирующей ломаной.
По длине сегмента | В поле ввода Длина сегмента задается значение максимальной длины сегмента аппроксимирующей ломаной.
По углу сегмента | В поле ввода Угол сегмента задается максимальное значение центрального угла дуги сегмента в единицах измерения угла.
По линейному отклонению сегмента | В поле ввода Линейное отклонение сегмента задается значение максимального расстояния между дугой сегмента и отрезком аппроксимирующей ломаной.

Количество сегментов может принимать целые значения в диапазоне 2 — 1000 (если контуром обечайки является окружность или эллипс, то минимальное количество сегментов — 3). Значение параметра сегментации (независимо от выбранного способа) должно обеспечивать количество сегментов в указанных пределах.

При переключении способов сегментации значение параметра пересчитывается и отображается в единицах измерения, соответствующих выбранному варианту. Обратите внимание на то, что при смене способа сегментации для эллипсов и их дуг количество сегментов может изменяться.


Поле Угол сегмента

Введите или задайте счетчиком значение максимального центрального угла дуги сегмента в это поле.

Поле Угол сегмента присутствует на Панели свойств, если в группе Способ активен переключатель По углу сегмента.


Поле Линейное отклонение сегмента

Введите или задайте счетчиком значение максимального расстояния между дугой сегмента и отрезком аппроксимирующей ломаной в это поле.

Линейное отклонение сегмента задается в миллиметрах.

Поле Линейное отклонение сегмента присутствует на Панели свойств, если в группе Способ активен переключатель По линейному отклонению сегмента.


Поле Длина сегмента

Введите или задайте счетчиком значение максимальной длины сегмента аппроксимирующей ломаной в это поле.

Длина сегмента задается в миллиметрах.

Поле Длина сегмента присутствует на Панели свойств, если в группе Способ активен переключатель По длине сегмента.


Поле Количество сегментов

Введите или задайте счетчиком количество сегментов аппроксимирующей ломаной в это поле.

Поле Количество сегментов присутствует на Панели свойств, если в группе Способ активен переключатель По количеству сегментов.


Ребра

Справочное поле, содержащее сведения о количестве ребер, указанных для создания фаски или скругления.


Грани

Справочное поле, содержащее сведения о количестве граней, указанных для создания фаски или скругления.


Команда Применить

Позволяет применить к модели сделанные настройки разнесения ее компонентов.

После вызова команды модель перестраивается в соответствии с заданными параметрами.


Список компонентов

Панель, содержащая перечень компонентов, участвующих в текущем шаге разнесения (выделенном в списке шагов).

Чтобы добавить компонент в перечень, активизируйте соответствующий переключатель и укажите нужный компонент в Дереве построения или в окне модели.

Чтобы удалить компонент из перечня, выделите его и нажмите кнопку Удалить, расположенную на панели Список компонентов.

После ввода или изменения расстояния нажмите кнопку Применить на Панели специального управления, чтобы это изменение вступило в силу.


Компоненты

Переключатель, позволяющий перейти к указанию компонентов, участвующих в текущем шаге разнесения (выделенном в списке шагов).

После активизации переключателя укажите нужные компоненты в Дереве построения или в окне модели.

Перечень выбранных компонентов отображается на панели рядом с переключателем.

Сформировав перечень компонентов, нажмите кнопку Применить на Панели специального управления, чтобы это изменение вступило в силу.


Объект, задающий направление разнесения

Объект,
задающий направление разнесения

Переключатель, позволяющий перейти к указанию объекта, задающего направление разнесения.

Компоненты могут разноситься в направлении, совпадающем с ребром или в направлении, перпендикулярном грани.

После активизации переключателя выберите нужный объект — ребро или грань — в окне модели.

Название указанного объекта отображается в справочном поле рядом с переключателем.

После ввода или изменения расстояния нажмите кнопку Применить на Панели специального управления, чтобы это изменение вступило в силу.


Выбор направления

Переключатель, изменить выбрать направление перемещения компонентов, перечисленных в Списке компонентов.

После ввода или изменения расстояния нажмите кнопку Применить на Панели специального управления, чтобы это изменение вступило в силу.


Расстояние

Поле для задания расстояния, на которое будут перемещены компоненты, перечисленные в Списке компонентов.

Вы можете ввести значение вручную или установить с помощью счетчика.

Ввод отрицательных значений невозможен. Для изменения направления перемещения служит соответствующий переключатель.

После ввода или изменения расстояния нажмите кнопку Применить на Панели специального управления, чтобы это изменение вступило в силу.


Шаг разнесения

Панель, содержащая перечень шагов разнесения текущей сборки. Выделенный в перечне шаг является текущим. Все сделанные изменения (например, набора компонентов или расстояния) будут относиться к этому шагу.

Чтобы создать новый шаг разнесения, нажмите кнопку Добавить.

Чтобы удалить шаг разнесения, выделите его в перечне и нажмите кнопку Удалить, расположенную на панели Список компонентов.

Завершив настройку шага (шагов) разнесения, нажмите кнопку Применить на Панели специального управления, чтобы это изменение вступило в силу.


Команда Применить поиск (поиск строки в отчете)

Команда Применить поиск
(поиск строки в отчете)

Позволяет начать поиск строк.

Для вызова команды нажмите кнопку Применить поиск на Панели специального управления.

После вызова команды найденная строка становится выделенной.

При активном переключателе К концу документа или К началу документа повторите поиск. При каждом нажатии кнопки выделяется одна строка, найденная в заданном направлении.

При активном переключателе Найти все все найденные строки становятся выделенными.

Команда доступна в Окне подготовки данных в нормальном режиме.


Опция Создавать тело

Опция, позволяющая создать тело, ограниченное сшиваемыми поверхностями.

Если в списке сшиваемых поверхностей есть тело с нарушенной целостностью, опция Создавать тело включается автоматически и ее выключение невозможно.


Поле Точность

Поле для ввода или выбора значения максимального расстояния между ребрами сшиваемых поверхностей.

При выполнении операции будут объединяться только те из указанных поверхностей, расстояние между ближайшими открытыми ребрами которых меньше или равно заданному значению точности.


Панель Список объектов для сшивки

Панель, содержащая перечень сшиваемых объектов. С помощью кнопок, расположенных над панелью, вы можете менять порядок следования объектов и удалять их из списка.


Тип построения тонкой стенки

Список, позволяющий задать направление добавления материала при построении оболочки: наружу или внутрь относительно поверхности детали.


Угол сдвига

Поле для ввода угла между вектором перемещения объекта и осью Х текущей системы координат.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Величина сдвига

Поле для ввода величины сдвига объекта.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Сдвиг по оси X

Поле значения сдвига объекта в направлении оси X.

При указании нового положения базовой точки мышью величина сдвига определяется автоматически и заносится в это поле.

Возможен также ввод значения с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Сдвиг по оси Y

Поле значения сдвига объекта в направлении оси Y.

При указании нового положения базовой точки мышью величина сдвига определяется автоматически и заносится в это поле.

Возможен также ввод значения с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Поле Угол

Введите значение угла сгиба в это поле.

При редактировании параметров сгиба поле Угол является справочным.

Смотрите также

Интерпретация значения угла


Поле Уклон1

Введите значение угла уклона боковой стороны продолжения сгиба в это поле.


Поле Уклон2

Введите значение угла уклона боковой стороны продолжения сгиба в это поле.


Группа Способ

Активизируйте переключатель, соответствующий нужному способу освобождения угла.

При выполнении команды Сгиб переключатели группы Способ доступны после включения освобождения угла — активизации переключателя Освобождение угла.


Поле Угол1

Введите значение угла на сгибе в это поле.


Поле Угол2

Введите значение угла на сгибе в это поле.


Поле Расстояние

Поле для ввода размера подсечки.


Размер подсечки

Доступно три варианта задания размера подсечки. Чтобы выбрать нужный вариант, активизируйте соответствующий переключатель в группе Размер подсечки.

Наружный размер подсечки

Внутренний размер подсечки

Полный размер подсечки


Подсечка с добавлением материала и подсечка без добавления материала

Подсечки с добавлением материала и без добавления материала, построенные с использованием одних и тех же линии сгиба и базовой грани, различаются по следующим признакам:

– положение прямоугольной проекции подсечки на базовую грань,

– форма разогнутой подсечки.

В качестве примера рассмотрим подсечку, исходный элемент которой показан на рисунке:

а) | б)
Исходный элемент подсечки: а) изометрическая проекция, б) проекция исходного элемента на базовую грань

Сравнение результатов построения подсечки с добавлением и без добавления материала представлено в таблице (линия сгиба показана утолщенной линией, проекция исходного элемента — штриховой).

Различающиеся признаки | Способ построения подсечки
 | С добавлением материала | Без добавления материала
проекция подсечки на базовую грань |  |
 | ...совпадает с контуром проекции исходного элемента | ...не совпадает с контуром проекции исходного элемента
форма разогнутой подсечки |  |
 | ...не совпадает с формой исходного элемента | ...совпадает с формой исходного элемента


Опция По 2 сторонам

Опция позволяет задать длины сторон продолжения сгиба по отдельности.

При отключенной опции формируется продолжение, у которого торцевая грань параллельна линии сгиба.

При включенной опции возможно формирование продолжения сгиба с разной длиной сторон.

Варианты формирования продолжения сгиба: а) опция По 2 сторонам отключена; б) опция По 2 сторонам включена
а) | б)


Расширение сгиба слева

Введите в это поле значение расширения сгиба слева.


Расширение сгиба справа

Введите в это поле значение расширения сгиба справа.


Способ сгиба

Укажите способ сгиба, выбрав нужный вариант из раскрывающегося списка.

По линии сгиба

Линия сгиба снаружи

Линия сгиба внутри

По касанию

Способ сгиба | Схема построения
По линии сгиба |
Линия сгиба снаружи |
Линия сгиба внутри |
По касанию |

На схемах показана проекция детали на плоскость, перпендикулярную линии сгиба. Проекция базовой грани обозначена утолщенным отрезком, а проекция линии сгиба — кружком.


По исходному объекту

Включите эту опцию, если параметры сгиба должны быть такими же, как у исходного объекта (листового элемента, содержащего редактируемый сгиб). В этом случае изменение параметров сгиба при редактировании исходного объекта приведет к перестроению сгиба: он получит новые параметры.

Чтобы задать для сгиба собственные параметры, выключите опцию По исходному объекту. После этого станут доступны остальные элементы управления, и вы сможете настроить сгиб. Отредактированный сгиб будет сохранять заданные параметры при изменении настройки исходного объекта.

При редактировании сгибов, принадлежащих листовому телу с разомкнутым эскизом и соответствующих дугам в эскизе этого листового тела, невозможно переключение способа задания радиуса и изменение его значения.


Файл-источник таблицы сгибов

Поле, в котором отображается полное имя текущего файла таблицы сгибов.

Чтобы сменить таблицу сгибов, нажмите на кнопку Выбрать другую таблицу сгибов, расположенную справа от поля.


Файл-источник таблицы сгибов

В этом поле отображается полное имя файла-источника таблицы сгибов. Поле является справочным: оно служит только для просмотра имени файла и пути к нему.

Если необходимо сменить таблицу сгибов в текущей детали, воспользуйтесь одним из следующих способов:

– войдите в режим редактирования листового тела и нажмите на Панели свойств кнопку Выбрать другую таблицу сгибов,

– откройте диалог настройки параметров листового тела для текущей детали и нажмите в нем кнопку Обзор,

– вызовите команду Операции — Элементы листового тела — Таблица сгибов — Выбрать.


Отступ 1

Введите значение отступа слева в это поле.

Поле доступно если выбран вариант размещения сгиба Отступ слева или Два отступа.


Отступ 2

Введите значение отступа справа в это поле.

Поле доступно если выбран вариант размещения сгиба Отступ справа или Два отступа.


Группа Неподвижная сторона сгиба

Чтобы задать неподвижную сторону сгиба, активизируйте нужный переключатель.

Сторона 1

Сторона 2


Выбор сгибов

Чтобы перейти к указанию сгибов, состояние которых требуется изменить, активизируйте этот переключатель.


Переключатель Плоскость

Чтобы выбрать неподвижную грань или плоскость, активизируйте этот переключатель и укажите нужную грань или вспомогательную плоскость в окне модели.

При настройке параметров развертки для указания доступны только грани, принадлежащие листовому телу, которое выбрано в списке Тела, и касательные к этим граням вспомогательные плоскости.


Элемент управления Плоскость вида

Позволяет выбрать грань или плоскость для задания ориентации Развертка.

По умолчанию ориентация Развертка устанавливается таким образом, чтобы направление взгляда было перпендикулярно грани или плоскости, указанной в качестве неподвижной (если тел несколько, то для первого настроенного тела).

При необходимости вы можете указать для ориентации Развертка любую другую грань или плоскость. Грань указывается в окне модели, а плоскость — в окне модели или Дереве модели.

Грань или плоскость будет выделена, а ее наименование появится в поле Плоскость вида.


Опция Включить в ширину сгиба

Включите эту опцию, чтобы значения ширины освобождений были включены в ширину сгиба. При отключенной опции ширины освобождений не включаются в ширину сгиба.


Элемент управления Грань

Элемент управления, позволяющий задать грань или плоскость для ограничения длины продолжения сгиба при создании сгиба вдоль ребра листового тела. Элемент управления Грань присутствует на Панели свойств, если в списке Способ построения выбран вариант До поверхности.

Чтобы сменить или задать грань, активизируйте переключатель Грань и укажите нужный объект в Дереве построения или в графической области. Название выбранного объекта появляется в поле Грань.

Длина продолжения сгиба определяется автоматически по указанной пользователем плоской грани или плоскости

Торец продолжения сгиба может совпадать с указанной поверхностью, «заходить» за поверхность или «не доходить» до нее на заданное расстояние. Для выбора направления отсчета расстояния до поверхности используются переключатели группы Тип, а для ввода значения расстояния — поле Расстояние.

Подробнее о построении продолжения сгиба способом До поверхности...


Элемент управления Вершина

Элемент управления, позволяющий задать точечный объект для ограничения длины продолжения сгиба при создании сгиба вдоль ребра листового тела. Элемент управления Вершина присутствует на Панели свойств, если в списке Способ построения выбран вариант До вершины.

Чтобы сменить или задать точечный объект, активизируйте переключатель Вершина и укажите нужный объект в Дереве построения или в графической области. Название выбранного объекта появляется в поле Вершина.

Автоматически вычисляется такая длина продолжения сгиба, при которой его торцевая грань (или ребро торцевой грани, прилежащее к стороне продолжения, если включена опция По 2 сторонам) совмещается с плоскостью, проходящей через указанную вершину перпендикулярно направлению построения.

Торец продолжения сгиба может совпадать с указанной вершиной, «заходить» за вершину или «не доходить» до нее на указанное расстояние.

Для выбора направления отсчета расстояния до вершины используются переключатели группы Тип, а для ввода значения расстояния — поле Расстояние.


Способы смещения сгиба

Укажите способ смещения сгиба, выбрав нужный вариант из раскрывающегося списка.

Смещение внутрь

Смещение наружу

При смещении сгиба внутрь или наружу расстояние смещения задается пользователем произвольно. Для ввода этого расстояния служит поле Смещение. При нулевом смещении сгиб начинается непосредственно от ребра, а при положительном — сдвигается внутрь или наружу по отношению к листовому телу.

а) | б) | в)
Смещение сгиба: а) нулевое, б) внутрь, в) наружу

При других типах смещения расстояние смещения определяется системой автоматически. Это расстояние зависит от угла сгиба, толщины материала и внутреннего радиуса сгиба.

По внешней линии контура

По внутренней линии контура

По касанию к сгибу


Группа Слева

Укажите способ оформления стороны, активизировав один из переключателей.

Уклон и угол слева

Расширение сгиба слева


Группа Справа

Укажите способ оформления стороны, активизировав один из переключателей.

Уклон и угол справа

Расширение сгиба справа


Уменьшение сгиба

Введите значение уменьшения сгиба в это поле.


Величина сгиба

Введите значение величины сгиба в это поле.


Ширина сгиба

Введите значение ширины сгиба в это поле. По умолчанию поле содержит значение, равное одной третьей части длины линии сгиба.

Поле доступно если выбран вариант размещения сгиба По центру, Слева, Справа, Отступ слева или Отступ справа.


Поле Ширина 1

Поле для ввода ширины сгиба по эскизу.

Поле Ширина 1 присутствует на Панели свойств, если в списке Направление выбран один из вариантов:

– Прямое направление; в этом случае в поле вводится ширина сгиба,

– Два направления; в этом случае в поле вводится ширина сгиба в прямом направлении,

– Средняя плоскость; в этом случае в поле вводится общая ширина сгиба (в каждую сторону будет отложена ее половина).


Поле Ширина 2

Поле для ввода ширины сгиба по эскизу.

Поле Ширина 2 присутствует на Панели свойств, если в списке Направление выбран один из вариантов:

– Обратное направление; в этом случае в поле вводится ширина сгиба,

– Два направления; в этом случае в поле вводится ширина сгиба в обратном направлении.


Группа переключателей Тип

Служит для выбора типа сгиба в местах соединения участков контура при построении обечайки с уклоном.

При активном переключателе С постоянным радиусом сгибы в углах контура имеют форму цилиндра.

При активном переключателе С переменным радиусом сгибы в углах контура имеют форму конуса.

Данный параметр не влияет на сгибы, соответствующие дугам в эскизе. Такие сгибы на обечайке с уклоном всегда имеют форму конуса.


Список Объект толщины

Позволяет указать, будет ли глубина отверстия (выреза) в листовом теле или толщина пластины совпадать с текущей толщиной листового тела или будет равна постоянной величине, заданной пользователем.

При построении отверстия или выреза список Объект толщины присутствует на Панели свойств, если в группе Тип активен переключатель По толщине.

Список содержит названия всех листовых тел, имеющихся в модели и строку Без объекта.

Чтобы глубина отверстия (выреза) или толщина пластины определялась по листовому телу, выберите его название в списке Объект толщины. Толщина выбранного тела отобразится в справочном поле Толщина.

Если требуется задать произвольную толщину, выберите в списке Объект толщины строку Без объекта. Поле Толщина станет доступно для редактирования и вы сможете ввести в него нужное значение.


Поле Толщина

В этом поле отображается значение глубины отверстия (выреза) в листовом теле или толщины пластины.

При построении отверстия или выреза поле Толщина присутствует на Панели свойств, если в группе Тип активен переключатель По толщине.

Если в списке Объект толщины выбрано листовое тело, то поле Толщина является справочным и отображает текущее значение толщины этого листового тела.

Если в списке Объект толщины выбрана строка Без объекта, то поле Толщина доступно для ввода. Введите в него нужное значение глубины отверстия (выреза) или толщины пластины.


Обработка угла

Список, позволяющий указать способ обработки угла при замыкании. Примеры вариантов обработки угла в сочетании с различными способами замыкания приведены в таблице.

При построении сгиба по эскизу способ замыкания Замыкание с перекрытием не используется.

Обработка угла | Способ замыкания |  |
 | Замыкание встык | Замыкание с перекрытием | Плотное замыкание
Без обработки
Круговая
Стык по кромке
Стык по хорде

Обратите внимание на то, что варианты Круговая, Стык по кромке и Стык по хорде доступны, если смежные сгибы имеют одинаковые углы и одинаковые радиусы. При этом стык по хорде возможен при всех способах замыкания, а круговая обработка и стык по кромке — только для замыкания встык и плотного замыкания.

Круговая обработка угла представляет собой обработку угла способом Стык по кромке с добавлением круглого отверстия. Центр отверстия размещается на прямой, проходящей через точку угла и точку пересечения линий сгибов. При выборе этого способа пользователю требуется задать дополнительные параметры. Подробнее...

Если используется Плотное замыкание с обработкой угла Круговая или Стык по кромке, то при нулевом или малом зазоре возможно перекрытие разверток смежных сгибов (см. рисунок). Во избежание этого рекомендуется подбирать такую величину зазора, при которой перекрытие исключено.

Сгибы согнуты | Сгибы разогнуты


Поле Диаметр

Введите значение диаметра отверстия в это поле.


Поле Смещение

Служит для задания расстояния смещения отверстия от точки его размещения вдоль прямой, проходящей через точку угла и точку пересечения линий сгибов.

При положительном значении параметра отверстие смещается к точке угла, при отрицательном — к точке пересечения линий сгибов

Введите или задайте счетчиком значение смещения.


Размещение отверстия

Укажите вариант размещения отверстия, выбрав нужный переключатель группы.

Значение опции Размещение отверстия | Правила размещения отверстия | Результат построения
Отверстие на пересечении сгибов | Центр отверстия находится в точке пересечения линий сгибов. |
Отверстие в точке угла | Центр отверстия находится в точке угла. |
Отверстие через точку угла | Отверстие проходит через точку угла. |


Опция Единые параметры

Позволяет применить одинаковые параметры замыкания ко всем выбранным углам.

По умолчанию опция включена.

При необходимости параметры замыкания можно настроить для каждого угла отдельно. Для этого отключите опцию Единые параметры, выделите угол на панели Углы и задайте требуемые параметры.

Замыкание углов с включенной опцией невозможно, если один или несколько выбранных углов не могут быть замкнуты с текущими параметрами. В списке замыкаемых углов такие углы отмечаются надписью Ошибочный параметр (см. рисунок). Чтобы создать операцию, выполните одно из следующих действий:

– измените параметры замыкания так, чтобы замыкание было возможно для всех углов,

– отключите опцию Единые параметры и измените параметры замыкания ошибочного угла так, чтобы выполнение операции было возможно,

– удалите ошибочный угол из списка замыкаемых углов.


Кнопка Изменить перекрытие

При построении замыкания с перекрытием в окне модели отображается фантомная стрелка. Она располагается на той стороне угла, которая будет перекрывать вторую сторону. Чтобы выбрать другой вариант перекрытия, нажмите эту кнопку. Положение стрелки в окне модели изменится.


Продолжить замыкание

Включите эту опцию, если требуется замкнуть парные сгибы, примыкающие к сторонам замыкаемого угла.

Продолжение замыкания возможно при выполнении следующих требований:

– к смежным сгибам:

• попарно равны радиусы и углы (при замыкании с перекрытием — также длины продолжений),

• боковые стороны, обращенные к замыкаемому углу, не имеют расширений,

– к примыкающим сгибам:

• сгибы не имеют смещения и/или освобождения,

• боковые стороны, обращенные к замыкаемому углу, не имеют расширений,

• размещение сгибов на ребрах таково, что каждый сгиб начинается от той вершины ребра, которая обращена к замыкаемому углу,

• при замыкании с перекрытием: радиусы, углы и длины продолжений попарно равны.

Замыкание сгиба: а) исходное состояние детали, б) замыкание без продолжения, в) замыкание с продолжением
а) | б) | в)

Продолжение замыкания производится до первой пары примыкающих сгибов, не удовлетворяющих требованиям к ним.


Панель Углы

Содержит список углов листового тела, которые будут замкнуты в результате выполнения команды Замыкание углов.

При выделении угла в списке он подсвечивается в окне модели.

При включенной опции Единые параметры все углы списка замыкаются с одинаковыми параметрами.

При необходимости параметры замыкания можно настроить для каждого угла отдельно. Для этого отключите опцию Единые параметры, выделите угол на панели Углы и задайте требуемые параметры. Особенности использования единых параметров замыкания...

Чтобы удалить выделенный угол из списка, нажмите кнопку Удалить.

Чтобы очистить весь список, нажмите кнопку Исключить все.


Коэффициент нейтрального слоя

Введите значение коэффициента нейтрального слоя в это поле.


Список Обработка угладля начальной/конечной кромки сгиба по эскизу

Список Обработка угла
для начальной/конечной кромки сгиба по эскизу

Позволяет задать форму начальной/конечной кромки сгиба по эскизу, обеспечивающую замыкание с предполагаемым смежным сгибом (например, для последующей стыковки с другой деталью).

Выберите одну из строк списка, чтобы кромка сгиба имела вид, необходимый для замыкания.

Варианты обработки угла при замыкании различными способами
 | Замыкание встык | Плотное замыкание
Без обработки |  |
Стык по кромке |  |
Стык по хорде |  |

Список Обработка угла присутствует на Панели свойств, если активен переключатель Замыкание в начале или Замыкание в конце.

Построение сгиба по эскизу невозможно, если для замыкания в начале или в конце задан отрицательный угол и выбран способ обработки Без обработки.


Группа переключателей Способ замыканиясмежных углов сгиба по эскизу

Группа переключателей Способ замыкания
смежных углов сгиба по эскизу

Позволяет выбрать способ замыкания: замыкание встык или плотное замыкание.

Замыкание встык | Плотное замыкание

Группа Способ замыкания присутствует на Панели свойств, если активен переключатель Замыкание смежных углов.


Группа переключателей Способ замыканиядля начальной/конечной кромки сгиба по эскизу

Группа переключателей Способ замыкания
для начальной/конечной кромки сгиба по эскизу

Позволяет задать форму начальной/конечной кромки сгиба по эскизу, обеспечивающую замыкание с предполагаемым смежным сгибом (например, для последующей стыковки с другой деталью).

Активизируйте переключатель Замыкание встык, чтобы кромка сгиба имела вид, необходимый для замыкания встык.

Активизируйте переключатель Плотное замыкание, чтобы кромка сгиба имела вид, необходимый для плотного замыкания.

Замыкание встык | Плотное замыкание

Группа переключателей Способ замыкания присутствует на Панели свойств, если активен переключатель Замыкание в начале или Замыкание в конце.


Группа Способ

Группа переключателей, позволяющая задать способ построения сгиба по эскизу.

Активизируйте переключатель По ребру, если ширина сгиба должна равняться длине ребра, вдоль которого этот сгиб построен. Для построения сгиба укажите ребро.

Активизируйте переключатель На расстояние, если сгиб должен иметь определенную ширину. Для построения сгиба укажите ребро, выберите направление построения из списка Направление и задайте ширину сгиба. В зависимости от того, какое выбрано направление построения, для ввода ширины используется поле Ширина 1, или Ширина 2 или оба поля.

Активизируйте переключатель Последовательность ребер, если сгиб должен быть построен вдоль цепочки ребер. Ребра, образующие цепочку, могут соединяться вершинами или сгибами. Для построения сгиба укажите ребра в порядке расположения.

Для построения сгиба вдоль ребер, соединенных сгибами, необходимо указывать не только прямолинейные ребра, но и сопрягающие их дуговые ребра.

Подробнее о способах построения сгиба по эскизу...


Поле Профиль выреза

Содержит наименование эскиза выреза.


Типы построения выреза

Выберите тип построения выреза, активизировав один из переключателей в группе Тип.

Описание способа

Процесс построения

Результат построения

По толщине

Построенный вырез проходит от указанной грани к противоположной ей в направлении, перпендикулярном этим граням. Если вырез захватывает сгиб или сгиб вместе с примыкающими к нему частями листового тела, то он переходит на этот сгиб и примыкающие части, как «обертка». Другими словами, в листовом теле образуется вырез такой формы, чтобы на развертке его контур точно соответствовал форме выреза в эскизе.

Список Объект толщины на Панели свойств позволяет указать, будет ли глубина выреза совпадать с текущей толщиной листового тела или будет равна постоянной величине, заданной пользователем.

На глубину

Вырез строится вырезанием элемента выдавливания на заданную глубину. Выдавливание производится перпендикулярно грани, выбранной для построения выреза. Направление выдавливания — внутрь по отношению к листовому телу. Чтобы задать расстояние выдавливания, введите его в поле Глубина на вкладке Параметры Панели свойств. Если вырез захватывает сгиб, то в отличие от выреза По толщине направление выдавливания не изменяется.

До грани

Вырез строится вырезанием элемента выдавливания с указанием объекта для автоматического определения расстояния выдавливания. Выдавливание производится перпендикулярно грани, выбранной для построения выреза. Направление выдавливания внутрь по отношению к листовому телу. Чтобы задать объект, ограничивающий расстояние выдавливания, укажите его в окне модели. В качестве этого объекта может использоваться грань, поверхность, проекционная или вспомогательная плоскость. Если вырез захватывает сгиб, то в отличие от выреза По толщине направление выдавливания не изменяется.

Смотрите также

Пример перестроения вырезов при изменении состояния сгиба


Поле Грань

В этом поле отображается название объекта, ограничивающего расстояние выдавливания при построении выреза До грани.

В качестве этого объекта может использоваться грань, поверхность, проекционная или вспомогательная плоскость.

Чтобы задать объект, ограничивающий расстояние выдавливания, укажите его в окне модели.


Направление выдавливания

Выберите нужное направление выдавливания.

При выборе Прямого направления выдавливание будет производиться по стрелке, при выборе Обратного направления — в противоположную сторону.


Группа Направление для толщины

Переключатели группы позволяют выбрать направление добавления материала листового тела. Доступны следующие варианты:

Наружу

Внутрь


Поле Угол 1

Поле для ввода угла, определяющего положение плоскости a, в которой (или параллельно которой) должна располагаться начальная кромка сгиба по эскизу. Плоскость проходит через конечную точку сгиба А; угол отсчитывается плоскости, перпендикулярной ребру, вдоль которого строится сгиб.

Рис. 12.0.1. Сгиб с замыканием в начале и конце: а) точка А и плоскость a, б) вид сверху; отступ и угол
а) | б)

Поле Угол 1 присутствует на Панели свойств, если активен переключатель Замыкание в начале.

Построение сгиба по эскизу невозможно, если для замыкания в начале или в конце задан отрицательный угол и выбран способ обработки Без обработки.


Поле Угол 2

Поле для ввода угла, определяющего положение плоскости a, в которой (или параллельно которой) должна располагаться конечная кромка сгиба по эскизу. Плоскость проходит через конечную точку сгиба А; угол отсчитывается плоскости, перпендикулярной ребру, вдоль которого строится сгиб.

Рис. 12.0.2. Сгиб с замыканием в начале и конце: а) точка А и плоскость a, б) вид сверху; отступ и угол
а) | б)

Поле Угол 2 присутствует на Панели свойств, если активен переключатель Замыкание в конце.

Построение сгиба по эскизу невозможно, если для замыкания в начале или в конце задан отрицательный угол и выбран способ обработки Без обработки.


Переключатель Замыкание смежных углов

Активизируйте этот переключатель, если требуется замыкание смежных углов сгиба по эскизу. После активизации переключателя станут доступны элементы управления обработкой кромки.

Переключатель Замыкание смежных углов присутствует на Панели свойств, если сгиб по эскизу строится вдоль цепочки ребер, соединенных вершинами.

Подробнее о замыкании углов сгиба по эскизу...


Переключатель Замыкание в начале

Активизируйте этот переключатель, если требуется обработка начальной кромки сгиба по эскизу. После активизации переключателя станут доступны элементы управления обработкой кромки.

Переключатель Замыкание в начале присутствует на Панели свойств, если сгиб по эскизу строится вдоль одного ребра или разомкнутой цепочки ребер, соединенных вершинами.

Подробнее о замыкании углов сгиба по эскизу...


Переключатель Замыкание в конце

Активизируйте этот переключатель, если требуется обработка конечной кромки сгиба по эскизу. После активизации переключателя станут доступны элементы управления обработкой кромки.

Переключатель Замыкание в конце присутствует на Панели свойств, если сгиб по эскизу строится вдоль одного ребра или разомкнутой цепочки ребер, соединенных вершинами.

Подробнее о замыкании углов сгиба по эскизу...


Поле Зазор

Поле для ввода величины зазора.

При выполнении замыкания угла зазор определяет расстояние между сторонами замыкаемого угла. Подробнее...

При построении обечайки зазор определяет расстояние между кромками стыка. Подробнее...


Поле Отступ 1

Поле для ввода расстояния, на котором начальная кромка сгиба по эскизу должна располагаться от плоскости a (плоскость a проходит через конечную точку сгиба А; угол ее наклона отсчитывается плоскости, перпендикулярной ребру, вдоль которого строится сгиб).

Рис. 12.0.3. Сгиб с замыканием в начале и конце: а) точка А и плоскость a, б) вид сверху; отступ и угол
а) | б)

Поле Отступ 1 присутствует на Панели свойств, если активен переключатель Замыкание в начале.


Поле Отступ 2

Поле для ввода расстояния, на котором конечная кромка сгиба по эскизу должна располагаться от плоскости a (плоскость a проходит через конечную точку сгиба А; угол ее наклона отсчитывается плоскости, перпендикулярной ребру, вдоль которого строится сгиб).

Рис. 12.0.4. Сгиб с замыканием в начале и конце: а) точка А и плоскость a, б) вид сверху; отступ и угол
а) | б)

Поле Отступ 2 присутствует на Панели свойств, если активен переключатель Замыкание в конце.


Поле Длина

Поле для ввода или задания счетчиком абсолютного смещения зазора обечайки от начальной точки контура в эскизе (для линейчатой обечайки — в эскизе первого основания) до точки в центре зазора. Начальная точка контура определяется системой автоматически.

Смещение зазора задается в миллиметрах. В начальной точке контура величина смещения зазора равна 0.

При перемещении характерной точки мышью величина смещения вычисляется и заносится в это поле.

При изменении параметра зазор перемещается вдоль контура.

Поле Длина присутствует на Панели свойств, если в группе Смещение зазора активен переключатель По длине.

Подробнее о смещении зазора...


Поле Параметр U, %

Поле для ввода или задания счетчиком относительной величины смещения зазора обечайки от начальной точки контура в эскизе (для линейчатой обечайки — в эскизе первого основания) до точки в центре зазора. Начальная точка контура определяется системой автоматически.

Смещение точки задается в процентах от длины контура в эскизе. В начальной точке контура величина смещения равна 0%.

При перемещении характерной точки мышью величина смещения вычисляется и заносится в это поле.

При изменении параметра зазор перемещается вдоль контура.

Поле Параметр U, % присутствует на Панели свойств, если в группе Смещение зазора активен переключатель По параметру U.

Подробнее о смещении зазора...


Поле Точка привязки

Чтобы расположить отверстие в нужном месте грани, введите в это поле значения координат центра отверстия.

Вы можете также указать положение отверстия мышью. Для этого расфиксируйте поле т и укажите нужную точку в окне модели. Координаты выбранной точки будут определены автоматически.


Типы построения отверстия

Выберите тип построения отверстия, активизировав один из переключателей.

Описание способа

Процесс построения

Результат построения

По толщине

Отверстие проходит от указанной грани к противоположной ей в направлении, перпендикулярном этим граням. Если отверстие захватывает сгиб или сгиб вместе с примыкающими к нему частями листового тела, то оно переходит на этот сгиб и примыкающие части, как «обертка». Другими словами, в листовом теле образуется отверстие такой формы, чтобы на развертке получилось круглое отверстие заданного радиуса.

Список Объект толщины на Панели свойств позволяет указать, будет ли глубина отверстия совпадать с текущей толщиной листового тела или будет равна постоянной величине, заданной пользователем.

На глубину

Отверстие строится вырезанием элемента выдавливания на заданную глубину. Выдавливание производится перпендикулярно грани, выбранной для построения отверстия. Направление выдавливания — внутрь по отношению к листовому телу. Чтобы задать расстояние выдавливания, введите его в поле Глубина на вкладке Параметры Панели свойств. Если отверстие захватывает сгиб, то в отличие от отверстия По толщине направление выдавливания не изменяется.

До грани

Отверстие строится вырезанием элемента выдавливания с указанием объекта для автоматического определения расстояния выдавливания. Выдавливание производится перпендикулярно грани, выбранной для построения отверстия. Направление выдавливания — внутрь по отношению к листовому телу. Чтобы задать объект-границу выдавливания, укажите его в окне модели. В качестве этого объекта может использоваться грань, поверхность, проекционная или вспомогательная плоскость. Если отверстие захватывает сгиб, то в отличие от отверстия По толщине направление выдавливания не изменяется.

Смотрите также

Пример перестроения отверстий при изменении состояния сгиба


Поле Грань

В этом поле отображается название объекта, ограничивающего расстояние выдавливания при построении отверстия До грани.

В качестве этого объекта может использоваться грань, поверхность, проекционная или вспомогательная плоскость.

Чтобы задать объект, ограничивающий расстояние выдавливания, укажите его в окне модели.


Форма торца жалюзи

Группа переключателей, позволяющая выбрать форму торца подрезанного жалюзи:

По направлению подрезки,

По нормали к толщине.


Положение жалюзи относительно эскиза

Жалюзи может располагаться справа или слева от отрезка в эскизе.

Правая сторона от отрезка находится следующим образом. Строится вектор, направленный из начальной точки отрезка (т1) в его конечную точку (т2). Правой стороной от отрезка считается часть грани, лежащая справа по направлению этого вектора. Противоположная часть грани — это левая сторона от отрезка.

а) | б) | в)
Расположение жалюзи: а) определение правой и левой сторон от эскиза, б) жалюзи справа от эскиза, в) жалюзи слева от эскиза

Описанным образом определяются правая и левая стороны для каждого отрезка в эскизе жалюзи.

Чтобы указать, с какой стороны от отрезка (отрезков) в эскизе будут расположены жалюзи, активизируйте нужный переключатель:

Справа,

Слева.


Способ создания жалюзи

Список, из которого можно выбрать способ построения жалюзи: вытяжка или подрезка.


Тип размера высоты жалюзи

Группа переключателей, позволяющая выбрать способ задания высоты жалюзи:

Полный,

От грани,

Высота прорези.

Выбрав способ задания высоты, введите нужное значение в поле Высота.

Подробнее...


Ширина жалюзи

Поле для ввода значения ширины жалюзи.

Значение ширины жалюзи В должно удовлетворять следующему условию: 2*S < B, где S — толщина листового материала. Для вытянутого жалюзи значение ширины должно удовлетворять также условию B < L/2, где L — длина отрезка в эскизе жалюзи.


Список способов построения

Выберите из списка способ построения продолжения сгиба.

При включенной опции По 2 сторонам способы определения длин сторон продолжения сгиба следует выбрать из групп Способ построения 1 и Способ построения 2.

Список содержит следующие способы построения.

– На расстояние
При выборе этого способа продолжение сгиба (или его сторона, если включена опция По 2 сторонам) имеет заданную пользователем длину. Укажите способ задания длины продолжения сгиба, выбрав нужный переключатель группы.
Введите значение длины в поле Длина.

– До вершины
При использовании этого способа продолжение сгиба имеет такую длину, при которой его торцевая грань (или ребро торцевой грани, прилежащее к стороне продолжения, если включена опция По 2 сторонам) совмещается с плоскостью, проходящей через указанную вершину перпендикулярно направлению построения.
Чтобы задать вершину, активизируйте переключатель Вершина и укажите нужный точечный объект в Дереве построения или в графической области.

– До поверхности
При выборе этого способа длина продолжения сгиба определяется автоматически по указанной пользователем плоской грани или плоскости.
Подробнее о построении продолжения сгиба способом До поверхности...
Чтобы задать поверхность, активизируйте переключатель Грань и укажите нужную грань, поверхность или плоскость в графической области.

При выборе способа построения До вершины или До поверхности после указания вершины или поверхности требуется задать расстояние до нее.
Торец продолжения сгиба может совпадать с указанным объектом, «заходить» за объект или «не доходить» до него на заданное расстояние.
Чтобы задать направление отсчета расстояния до объекта, активизируйте переключатель До объекта или За объект в группе Тип и введите в поле Расстояние требуемое расстояние между торцем продолжения сгиба и объектом.


Длина

Введите значение длины продолжения сгиба в это поле.


Поле Расстояние до объекта

Введите в это поле расстояние между указанным объектом (вершиной или поверхностью) и торцем продолжения сгиба. Если нужно построить продолжение сгиба точно до объекта, введите нулевое расстояние.

Если расстояние до объекта не нулевое, оно может быть отложено как в направлении продолжения сгиба, так и против него.

Чтобы изменить направление отсчета расстояния до вершины или поверхности, воспользуйтесь переключателем Тип. Изменение направления построения немедленно отражается в фантоме элемента.


Способы построения боковых стенок

Толщина боковых стенок штамповки может откладываться внутрь или наружу по отношению к поверхности, образованной перемещением профиля в направлении построения.

Чтобы изменить направление добавления материала боковых стенок, воспользуйтесь группой переключателей Боковые стенки:

Внутрь,

Наружу.


Угол

Боковые стенки штамповки можно уклонить. Для этого введите значение угла уклона в поле Угол. Нулевое значение в этом поле означает построение штамповки без уклона.

Подробнее...


Высота

Поле для ввода значения высоты штамповки, буртика или жалюзи.

При построении штамповки Полной высоты значение высоты должно быть больше толщины листового материала.

При построении буртика с круглой формой сечения значение высоты должно быть больше радиуса или равно ему.


Сторона от профиля, с которой располагается неподвижная часть грани

Группа переключателей, позволяющая указать неподвижную сторону.

Неподвижная сторона — та часть базовой грани, положение которой при построении штамповки не изменится. Неподвижная часть грани может находиться внутри профиля штамповки или снаружи от него. Именно в этой части грани начинается фантомная стрелка, показывающая направление построения.

Чтобы сменить неподвижную сторону, воспользуйтесь группой переключателей Сторона. При смене неподвижной стороны положение фантомной стрелки в окне модели изменяется.

Зависимость результата построения закрытой штамповки от выбора неподвижной стороны показана на рисунках.

Рис. 1 Неподвижная сторона снаружи от профиля

Рис. 2 Неподвижная сторона внутри профиля (штриховой линией показано исходное положение детали)


Сторона от профиля, с которой располагается неподвижная часть грани

Группа переключателей, позволяющая указать неподвижную сторону.

Неподвижная сторона — та часть базовой грани, положение которой при построении штамповки не изменится. Неподвижная часть грани может находиться внутри профиля штамповки или снаружи от него. Именно в этой части грани начинается фантомная стрелка, показывающая направление построения.

Чтобы сменить неподвижную сторону, воспользуйтесь группой переключателей Сторона. При смене неподвижной стороны положение фантомной стрелки в окне модели изменяется.

Зависимость результата построения открытой штамповки от выбора неподвижной стороны показана на рисунках.

Рис. 1 Неподвижная сторона снаружи от профиля

Рис. 2 Неподвижная сторона внутри профиля (штриховой линией показано исходное положение детали)


Радиус

Поле для ввода радиуса скругления ребер основания штамповки или буртика.

Минимальное значение радиуса — 0.


Радиус

Поле для ввода радиуса скругления ребер дна штамповки.

Минимальное значение радиуса — 0.


Радиус

Поле для ввода радиуса скругления углов профиля штамповки.

Минимальное значение радиуса — 0.


По умолчанию

Опция, включение которой означает, что все текущие настройки создаваемого или редактируемого листового элемента будут использоваться при создании следующих элементов данного типа до конца сеанса работы. При выключенной опции настройка распространяется только на текущий (создаваемый или редактируемый) элемент.


Тип размера высоты штамповки

Группа переключателей, позволяющая выбрать способ задания высоты штамповки:

Полный,

Внутри,

Снаружи.

Выбрав способ задания высоты, введите нужное значение в поле Высота.

При использовании способа Полный заданное значение высоты штамповки должно быть больше толщины листового тела.


Тип размера высоты штамповки

Группа переключателей, позволяющая выбрать способ задания высоты штамповки:

Полный,

Снаружи.

Выбрав способ задания высоты, введите нужное значение в поле Высота.

При использовании способа Полный заданное значение высоты штамповки должно быть больше толщины листового тела.


Скругление ребер основания

Основание штамповочного элемента — часть листового тела, где штамповочный элемент соединяется с прилегающими к нему плоскими участками. Ребра основания — ребра, образующиеся на стыках граней боковых стенок штамповочного элемента и граней прилегающих к нему плоских участков листового тела. При этом ребра, принадлежащие внутренним боковым граням штамповочного элемента, считаются внутренними ребрами основания, а принадлежащие внешним боковым граням — внешними ребрами основания (рис. 1).

Рис. 1. Внутренние и внешние ребра основания

Штамповочные элементы могут создаваться со скруглением ребер основания или без скругления.

Чтобы скруглить ребра основания, включите опцию Скругление основания и введите радиус скругления в поле Радиус скругления основания. Заданное значение радиуса R используется для скругления внешних ребер основания. Радиус скругления внутренних ребер равен сумме (R + S), где S — толщина листового материала. Минимальное значение радиуса скругления ребер основания — 0.

а) | б) | в)
Рис. 2 Поперечный разрез штамповки (буртика): а) без скругления ребер основания, б) с нулевым радиусом скругления, в) с радиусом скругления больше нуля


Скругление ребер дна штамповки

Ребра дна — ребра, образующиеся на стыках граней дна штамповки и граней ее боковых стенок. При этом ребра, принадлежащие внутренним боковым граням штамповки, считаются внутренними ребрами дна, а принадлежащие внешним боковым граням внешними ребрами дна (рис. 1).

Рис. 1. Внутренние и внешние ребра дна штамповки
(штамповка рассечена плоскостью, перпендикулярной базовой грани)

Штамповка может создаваться со скруглением ребер дна или без скругления.

Чтобы скруглить ребра дна, включите опцию Скругление дна и введите радиус скругления в поле Радиус скругления дна. Заданное значение радиуса R используется для скругления внутренних ребер дна. Радиус скругления внешних ребер равен сумме (R + S), где S — толщина листового материала. Минимальное значение радиуса скругления ребер дна — 0.

а) | б) | в)
Рис. 2 Штамповка (поперечный разрез): а) без скругления ребер дна, б) с нулевым радиусом скругления, в) с радиусом скругления больше нуля


Скругление боковых ребер штамповки

Боковые ребра — ребра, образующиеся на стыках граней боковых стенок штамповки.

При этом ребра, принадлежащие внутренним боковым граням штамповки, считаются внутренними боковыми ребрами, а принадлежащие внешним боковым граням — внешними боковыми ребрами (рис. 1).

Рис. 1 Внутренние и внешние боковые ребра штамповки

Штамповка может создаваться со скруглением боковых ребер или без скругления.

Чтобы скруглить боковые ребра, включите опцию Скругление ребер и введите радиус скругления в поле Радиус. Заданное значение радиуса R используется для скругления внутренних боковых ребер. Радиус скругления внешних ребер равен сумме (R + S), где S — толщина листового материала. Минимальное значение радиуса скругления боковых ребер — 0.

Если боковые стенки штамповки уклонены, то R и (R + S) — минимальные радиусы скругления боковых ребер. Эти значения радиусов выдерживаются в области дна штамповки. Например, на рисунке 2 показана открытая штамповка с уклоном боковых стенок и скругленными боковыми ребрами.

Рис. 2 Открытая штамповка с уклоном боковых стенок и скругленными боковыми ребрами:
а) радиус скругления равен нулю, б) радиус скругления больше нуля

Боковые ребра штамповки, образованные гладко сопряженными гранями, не скругляются.


Радиус сгиба

Введите в это поле значение радиуса сгиба.

Минимальное значение внутреннего радиуса — 0,0002 мм. Внутренний и наружный радиусы связаны соотношением:

Rнаружн. = Rвнутр. + S,

где S — толщина материала.

Поэтому минимальное значение наружного радиуса равно сумме (S + 0,0002) мм.

Переключение способа задания радиуса и изменение его значения невозможно при редактировании сгибов, принадлежащих листовому телу с разомкнутым эскизом и соответствующих дугам в эскизе этого листового тела.

В команде Листовое тело с указанием разомкнутого эскиза или в командах Обечайка и Линейчатая обечайка величина, введенная в поле Радиус сгиба, является радиусом скругления на углах контура. При этом необходимо обратить внимание на следующее.

– В команде Листовое тело радиус сгиба является значением внутреннего радиуса.

– В командах Обечайка и Линейчатая обечайка радиус сгиба может быть как наружным, так и внутренним. Это зависит от выбора направления добавления материала по отношению к контуру.

Сгиб в линейчатой обечайке может иметь не цилиндрическую, а линейчатую поверхность. В этом случае радиус сгиба — радиус цилиндрической поверхности, к которой приближена линейчатая поверхность сгиба обечайки.


Смещение

Введите значение смещения сгиба в это поле.


Поле Угол расположения

Поле для ввода или задания счетчиком центрального угла дуги от начальной точки контура в эскизе (для линейчатой обечайки — в эскизе первого основания) до точки в центре зазора. Начальная точка контура определяется системой автоматически.

Смещение зазора задается в единицах измерения угла. В начальной точке контура величина смещения равна 0.

При перемещении характерной точки мышью величина смещения вычисляется и заносится в это поле.

При изменении параметра зазор перемещается вдоль контура.

Поле Угол расположения присутствует на Панели свойств, если в группе Смещение зазора активен переключатель Угол расположения.

Подробнее о смещении зазора...


Угол

Поле для ввода угла наклона боковых стенок буртика.

Минимальное значение угла — 0.


Зазор

Поле для ввода величины зазора вырубки. Это поле появляется на Панели свойств, если выбран Рубленый тип обработки концов буртика.

Минимальное значение зазора — 0,0002 мм.


Панель просмотра образца и параметров сечения буртика

Панель Просмотр содержит изображение буртика. Доступны два варианта изображения:

– поперечный разрез с размерами, соответствующими параметрам сечения,

– образец — наглядное изображение прямолинейного буртика с учетом выбранной формы сечения, типа обработки концов и скругления основания.

Для выбора типа изображения служит опция Образец. Если она включена, на панели просмотра отображается образец буртика, если выключена — разрез.


Радиус

Поле для ввода радиуса круглого или V-образного буртика либо радиуса скругления ребер дна U-образного буртика.

Минимальное значение радиуса — 0,0002 мм.


Способ построения круглого буртика

Список, из которого можно выбрать способ построения буртика. Для буртика с круглой формой сечения доступны следующие способы построения:

По высоте и ширине основания

По высоте и радиусу

По радиусу и ширине основания


Способ построения U-образного буртика

Список, из которого можно выбрать способ построения буртика. Для буртика с U-образной формой сечения доступны следующие способы построения:

По высоте, углу и ширине основания

По ширине основания, высоте и ширине дна

По ширине основания, углу и ширине дна

По углу, высоте и ширине дна


Способ построения V-образного буртика

Список, из которого можно выбрать способ построения буртика. Для буртика с V-образной формой сечения доступны следующие способы построения:

По высоте, углу и ширине основания

По высоте, углу и радиусу

По радиусу, углу и ширине основания

По высоте, радиусу и ширине основания


Группа Формы сечения буртика

Активизируйте переключатель, соответствующий нужной форме сечения буртика.

Круглая

U-образная

V-образная

Смена формы сечения отображается на панели просмотра.


Типы обработки концов буртика

Выберите из списка нужный тип обработки концов буртика.

Конец буртика — часть буртика, соответствующая крайней точке контура в эскизе. Выбранный тип применяется ко всем концам текущего буртика. Доступны следующие варианты:

закрытый | открытый | рубленый

Смена типа обработки концов отображается на панели просмотра.

При выборе типа обработки Рубленый на Панели свойств появляется поле Зазор, в котором необходимо ввести величину зазора вырубки.


Ширина

Поле для ввода ширины дна U-образного буртика.

Минимальное значение ширины — 0,0002 мм.


Ширина основания

Поле для ввода ширины основания буртика.

Минимальное значение ширины — 0,0002 мм.


Элемент управления Эскиз

Элемент управления, позволяющий задать эскиз листового тела.

Эскиз листового тела может быть разомкнутым или замкнутым. Листовое тело с замкнутым и разомкнутым эскизом строится по-разному.

Эскиз следует указывать в Дереве построения.

Название указанного эскиза отображается в поле Эскиз.

Чтобы сменить эскиз листового тела, активизируйте переключатель Эскиз, а затем укажите нужный эскиз в Дереве построения. Обратите внимание на то, что вновь указанный эскиз должен быть того же вида — замкнутый или разомкнутый, — что и прежний.

После смены эскиза фантом листового тела в окне модели перестраивается.

Смотрите также

Требования к эскизу листового тела

Построение листового тела с замкнутым эскизом

Построение листового тела с разомкнутым эскизом


Панель Тела

Содержит список листовых тел, имеющихся в детали.

Выберите листовое тело для задания параметров развертки — указания неподвижной грани или плоскости и выбора сгибов. Выбранное тело подсветится в окне модели.

Завершив настройку одного тела, выберите следующее и так далее.

Строки списка отображаются разными цветами:

– строка тела, для которого еще не заданы параметры развертки — красным,

– строка тела, для которого уже заданы параметры развертки — зеленым.

Не обязательно задавать параметры развертки для всех тел, можно настроить одно или некоторые тела.

Если деталь содержит одно листовое тело, то его указание в списке не требуется. Можно сразу переходить к настройке развертки для этого тела.


Панель Сгибы(команды Согнуть и Разогнуть)

Панель Сгибы
(команды Согнуть и Разогнуть)

Содержит список сгибов листового тела и элементы управления этим списком.

Команда Согнуть или Разогнуть будет применена к тем сгибам, наименования которых содержатся в списке. При выделении сгиба в списке он подсвечивается в окне модели, а при указании в окне модели — выделяется в списке. Это позволяет контролировать правильность выбора сгибов.

Если деталь содержит несколько листовых тел, то для выбора будут доступны только сгибы того тела, которому принадлежит грань или с которым связана вспомогательная плоскость, указанная в качестве неподвижной.

Чтобы ускорить настройку, воспользуйтесь кнопками, расположенными над списком сгибов.

Наименование | Описание
Выбрать все | Позволяет выбрать все сгибы листового тела. При работе с командой разгибания в список включаются все согнутые сгибы, а при работе с командой сгибания — все разогнутые. После нажатия кнопки выбранные сгибы подсвечиваются в окне модели.
Удалить | Позволяет исключить из списка выделенный сгиб. После нажатия кнопки в окне модели снимается выделение с указанного сгиба. Указание выделенного сгиба в окне модели приводит к исключению его из списка.
Исключить все | Позволяет очистить список сгибов. После нажатия кнопки в окне модели снимается выделение со всех сгибов.

Чтобы выделить несколько сгибов в списке, используйте клавиши <Shift> и <Ctrl>.

Чтобы выделить несколько сгибов в окне модели, просто последовательно указывайте их.


Поле Толщина

Введите или выберите из списка значение толщины материала листового тела.


Тип освобождения сгиба

Чтобы выбрать форму освобождения сгиба, активизируйте нужный переключатель в данной группе.


Способ замыкания

Список, позволяющий указать способ замыкания.

Замыкание встык

Замыкание с перекрытием

Плотное замыкание

При выборе варианта Замыкание с перекрытием в окне модели отображается фантомная стрелка. Она располагается на той стороне угла, которая будет перекрывать вторую сторону. Чтобы выбрать другой вариант перекрытия, нажмите кнопку Изменить перекрытие. Положение стрелки в окне модели изменится.

Смотрите также

Принцип построения замыкания встык и плотного замыкания

Принцип построения замыкания с перекрытием


Развертка

Выберите из списка способ определения длины развертки сгиба. В зависимости от указанного способа на Панели свойств появится поле для ввода значения параметра развертки (Коэффициент, или Величина, или Уменьшение) или поле, позволяющее указать файл таблицы сгибов.

По умолчанию используется файл таблицы сгибов, указанный в диалоге настройки листового тела для текущей детали.


Панель Сгибы(команда Параметры развертки)

Панель Сгибы
(команда Параметры развертки)

Панель содержит список всех сгибов, которые имеются в листовом теле, параметры развертки которого настраиваются в данный момент.

Слева от названий сгибов отображаются опции. Сгибы с включенными опциями будут показаны в режиме развертки разогнутыми, а сгибы с отключенными опциями — согнутыми. Чтобы отметить сгиб, включите опцию рядом с его названием. При выделении сгиба в списке он подсвечивается в окне модели, а при указании в окне модели — выделяется в списке. Это позволяет контролировать правильность настройки.

Сгибы, не принадлежащие листовому телу, выбранному в списке Тела, указать невозможно.

Чтобы ускорить настройку, воспользуйтесь кнопками, расположенными над списком сгибов.

 | Наименование | Описание
 | Согнуть все | Позволяет отключить опции сразу у всех ранее отмеченных сгибов.
 | Разогнуть все | Позволяет включить опции сразу у всех сгибов списка.
 | Согнуть выбранные | Позволяет отключить опции у выделенных в списке сгибов.
{ | Разогнуть выбранные | Позволяет включить опции у сгибов, выделенные в списке.

Чтобы выделить несколько сгибов в списке, используйте клавиши <Shift> и <Ctrl>.

Чтобы выделить несколько сгибов в окне модели, просто последовательно указывайте их.


Кратко (расстояние и угол)

Кратко
(расстояние и угол)

Опция, управляющая объемом сведений, отображаемых в Информационном окне.

Если опция Кратко включена, будут показаны расстояние и угол между объектами. Для случаев, когда могут быть показаны расстояния L(min) и L(max), вычисляется только минимальное расстояние L(min).

Если опция Кратко выключена, будут дополнительно показаны:

– максимальное расстояние L(max), если оно имеется;

– расстояния в проекциях на оси абсолютной системы координат X, Y, Z;

– дополняющие углы до 180 и 360 градусов.


Команда Таблица переменных фрагмента

Команда Таблица переменных
фрагмента

Позволяет открыть таблицу переменных вставляемого (вставленного) в графический документ фрагмента и выбрать новые значения внешних переменных фрагмента.

Для вызова команды нажмите кнопку Таблица переменных на вкладке Переменные Панели свойств.

После вызова команды на экране появляется окно Таблица переменных. Укажите в таблице нужную строку и закройте окно кнопкой ОК. Внешние переменные фрагмента получат значения, записанные в ячейках выбранной строки.

Команда Таблица переменных доступна, если таблица переменных, хранящаяся во вставляемом (вставленном) фрагменте, содержит более одной строки.

Смотрите также

Создание, редактирование и удаление таблицы переменных


Группа переключателей Боковые ребра

Группа переключателей, позволяющая выбрать вариант положения боковых ребер продления: продление исходных боковых ребер или продление по нормали к указанным кромкам.

Группа доступна, если выбран тип продления Той же поверхностью или По касательной.

Активизируйте нужный переключатель:

– Как продление исходных боковых ребер;

– По нормали к указанным кромкам.

Подробнее...


Опция Автосортировка

Опция, позволяющая включать и выключать автоматическую сортировку для буквенных обозначений объектов текущего типа. (В документах-моделях возможно создание объектов только одного типа — обозначений базы.)

Если опция Автосортировка включена, то буква для обозначения выбирается системой автоматически в соответствии с настройкой. При работе с графическим документом объект помещается в группу нумерации #Автосортировка, а в обозначение объекта добавляется ссылка на его номер в группе (в данном случае номера представлены буквами).

Ввод обозначений объектов при включенной опции имеет особенности. Подробнее...

Если опция Автосортировка отключена, вы можете ввести любые символы для обозначения текущего объекта. При работе с графическим документом отключение опции исключает из сортировки только текущий объект. При работе с моделью автосортировка отключается для всех объектов того же типа (обозначений баз).

Если опция включается при создании объекта, то все новые объекты того же типа будут автоматически добавляться в группу #Автосортировка (в диалоге настройки включается автосортировка объектов данного типа). Включение опции при редактировании объекта не влияет на вновь создаваемые объекты.

В модели включение/выключение опции Автосортировка или соответствующей опции в диалоге настройки включает/выключает автосортировку всех обозначений баз, имеющихся в модели.

Подробнее об автоматической сортировке буквенных обозначений в графических документах...


Опция Лист (в обозначении объекта оформления)

Опция Лист
(в обозначении объекта оформления)

Опция, управляющая включением в обозначение объекта оформления — линии разреза, стрелки взгляда или выносного элемента — ссылки на номер листа чертежа, где располагается вид, содержащий соответствующее изображение.

Если опция включена, то номер листа добавляется в обозначение. Это происходит после создания вида и формирования связи между ним и объектом оформления. В параметрах надписи вида, который автоматически формируется после создания объекта оформления, также включается опция Лист.

Если опция отключена, то обозначение зоны не добавляется в обозначение объекта оформления. В параметрах надписи вида, который автоматически формируется после создания объекта оформления, опция Лист не включается.

При создании линии разреза/сечения, стрелки взгляда или выносного элемента во фрагменте опция Лист не доступна.


Опция Зона (в обозначении объекта оформления)

Опция Зона
(в обозначении объекта оформления)

Опция, управляющая включением в обозначение объекта оформления — линии разреза, стрелки взгляда или выносного элемента — ссылки на обозначение зоны чертежа, где располагается вид, содержащий соответствующее изображение.

Если опция включена, то обозначение зоны — при условии, что в чертеже включено разбиение на зоны — добавляется в обозначение. Это происходит после создания вида и формирования связи между ним и объектом оформления. В параметрах надписи вида, который автоматически формируется после создания объекта оформления, также включается опция Зона.

Если опция отключена, то обозначение зоны не добавляется в обозначение объекта оформления. В параметрах надписи вида, который автоматически формируется после создания объекта оформления, опция Зона не включается.

При создании линии разреза/сечения, стрелки взгляда или выносного элемента во фрагменте опция Зона не доступна.


Список СК компонента

Содержит перечень систем координат текущего компонента компоновочной геометрии. Список позволяет выбрать систему координат данного компонента для совмещения с системой координат содержащей его модели.

Рядом со списком систем координат находится кнопка СК компонента. Нажав эту кнопку, вы можете выбрать нужную систему координат в Дереве построения или в окне модели.

После выбора системы координат положение компонента в модели изменяется.

Если компонент содержит только абсолютную систему координат, список недоступен.


Список СК текущего документа

Содержит перечень систем координат текущей модели. Список позволяет выбрать систему координат модели для совмещения с системой координат компонента компоновочной геометрии.

Рядом со списком систем координат находится кнопка СК текущего документа. Нажав эту кнопку, вы можете выбрать нужную систему координат в Дереве построения или в окне текущей модели.

После выбора системы координат положение компонента в модели изменяется.

Если модель содержит только абсолютную систему координат, список недоступен.


Опция Проецировать

Позволяет управлять расположением экземпляров массива, позиции которых заданы точками эскиза, относительно плоскости этого эскиза.

Если опция Проецировать включена, то перед размещением экземпляра массива, положение которого задано точкой эскиза, корректируется положение базовой точки C базового экземпляра: за новую базовую точку C' принимается проекция текущей базовой точки на плоскость эскиза. Затем экземпляры размещаются так, чтобы их базовые точки совпадали с точками эскиза (рис. а). Таким образом, если позиции экземпляров заданы точками разных эскизов, то эти экземпляры будут по-разному расположены относительно своих базовых точек.

При отключенной опции копирование производится обычным образом, т.е. для всех экземпляров используется одна и та же — автоопределенная или заданная пользователем — базовая точка базового экземпляра C (рис. б).

На положение экземпляров, позиции которых заданы не точками эскизов, а другими точечными объектами, состояние опции Проецировать не влияет.

Положение экземпляров массива, позиции которых заданы точками эскиза: а) при включенной опции Проецировать; б) при отключенной опции Проецировать
а) | б)

Смотрите также

Команда Массив по точкам


Элемент управления Точки

Позволяет задать позиции экземпляров.

Активизируйте переключатель Точки и укажите нужные точечные объекты в Дереве построения или в окне модели.

Название указанного объекта или количество указанных объектов отображается в поле рядом с переключателем.

Если позиции экземпляров массива задаются точками группы или точками эскиза, то вы можете указать нужные точки в Дереве построения или в окне модели. Для выбора сразу всех точек группы или эскиза укажите эту группу или эскиз в Дереве построения.

Если для задания позиций экземпляров используется эскиз, указанный в Дереве построения, то вы можете управлять плоскостью расположения этих экземпляров.


Поле Базовая плоскость эскиза

Поле, в котором отображается название базовой плоскости эскиза — вспомогательной или координатной плоскости либо плоской грани.

Чтобы указать или сменить базовую плоскость эскиза, укажите нужный объект в Дереве построения или в окне модели.


Угол поворота

Поле угла поворота системы координат эскиза.

Введите в это поле значение с клавиатуры.

Угол поворота системы координат эскиза можно также задать мышью. Для этого расфиксируйте поле Угол и укажите нужную точку в окне модели. Угол поворота будет определен автоматически и занесен в поле Угол.

Поскольку положение изображения во фрагменте относительно его системы координат остается постоянным, поворот системы координат эскиза означает поворот изображения в плоскости эскиза.


Точка привязки

Поля координат точки привязки системы координат эскиза.

Введите в эти поля значения с клавиатуры.

Положение системы координат эскиза можно также задать мышью. Для этого расфиксируйте поля координат и укажите нужную точку в окне модели. Координаты выбранной точки будут определены автоматически и занесены в соответствующие поля.

Поскольку положение изображения во фрагменте относительно его системы координат остается постоянным, перемещение системы координат эскиза означает перемещение изображения в плоскости эскиза.


Кнопка Создать отчет

Служит для фиксации параметров отчета и перехода

– в Окно подготовки данных;

– к размещению отчета в документе;

– обратно в документ, содержащий ассоциативный отчет (после редактирования отчета).

Кнопка Создать отчет расположена на Панели специального управления.

После нажатия кнопки открывается Окно подготовки данных, диалог открытия документа или документ.


Тип сегмента

Группа переключателей, позволяющая выбрать текущий тип сегмента при построении линии: отрезок или дуга.

Отрезки и дуги в составе линии могут строиться различными способами.

При создании первого объекта последовательности доступны дополнительные способы построения, поскольку у этого объекта, в отличие от последующих, не зафиксирована ни одна точка.

Подробнее о доступных способах построения объектов ломаной рассказано в разделах:

Способы построения отрезков

Способы построения дуг

Текущий тип сегмента линии можно менять без обращения к Панели свойств — с помощью комбинации клавиш <Ctrl> + <Tab>.


Поле Степень

Поле позволяет ввести значение степени функции, используемой для расчета расстояния, на которое переместится каждый выбранный полюс сетки при перемещении полюсов со сглаживанием. Находится на панели свойств, если в группе Вид активизирован переключатель Выпуклый или Вогнутый.

Значение вводится вручную или задается с помощью счетчика. Оно может быть натуральным числом от 1 до 10.


Переключатели Вид

Позволяют выбрать вид сглаживания при перемещении полюсов сетки со сглаживанием. Расчет перемещений выбранных полюсов будет выполняться с использованием функции, соответствующей выбранному виду сглаживания.

Доступны следующие варианты:

– Плавный переход,

– Выпуклый,

– Вогнутый.

При выборе варианта Выпуклый или Вогнутый на Панели свойств появляется поле Степень, позволяющее задать значение степени функции, используемой для расчета.


Список Направление

Раскрывающийся список позволяет выбрать направление смещения полюсов при линейном перемещении, перемещении со сглаживанием, выравнивании полюсов сетки или направление оси вращения при вращении полюсов.

При выравнивании полюсов данный список находится на Панели свойств, если из раскрывающегося списка Способ выбран вариант выравнивания По направлению.

При смещении полюсов перемещением или вращением список отображается на Панели свойств вне зависимости от состояния других элементов управления.

Описание возможных вариантов задания направления приведено в таблице.

Варианты задания направления

Вариант

Описание

По оси X
По оси Y
По оси Z

Направление совпадает с осью Х, Y или Z текущей системы координат.

Параллельно объекту

Направление задается указанием произвольного объекта одного из следующих типов: прямолинейный объект, цилиндр, конус, тор.

При выборе прямолинейного объекта направление совпадает с ним.

При выборе цилиндра, конуса или тора направление совпадает с его осью.

Укажите нужный объект в Дереве построения или в окне модели. Название объекта отображается в поле Направляющий объект.

При смещении полюсов вращением, масштабированием или выравниванием на Панели свойств присутствует переключатель Направляющий объект. Он позволяет при необходимости сменить направляющий объект.

Перпендикулярно объекту

Направление задается указанием произвольного плоского объекта и совпадает с перпендикуляром к этому объекту. После выбора этого варианта укажите нужный объект в Дереве построения или в окне модели. Название объекта отображается в поле Направляющий объект.

При смещении полюсов вращением, масштабированием или выравниванием на Панели свойств присутствует переключатель Направляющий объект. Он позволяет при необходимости сменить направляющий объект.

По нормали

Направление совпадает с нормалью к редактируемой грани, проходящей через смещаемый полюс. Вариант доступен для линейного перемещения и перемещения со сглаживанием.

При выборе этого варианта на Панели свойств появляется опция От исходной. По умолчанию опция включена. При этом положение нормали рассчитывается относительно исходной формы редактируемой грани. Исходной формой грани считается та форма, которую имела грань на момент вызова команды Сплайновая форма. Чтобы положение нормали рассчитывалось относительно текущей формы грани, отключите опцию.

Вдоль многоугольника

Полюсы смещаются вдоль направления U или V сетки. Вариант доступен для линейного перемещения.

При выборе этого варианта на Панели свойств появляются переключатели, позволяющие выбрать направление перемещения (U или V) и способ перемещения.

В плоскости экрана

Полюсы смещаются в плоскости экрана.

Вариант доступен для линейного перемещения.

Для задания направления вместо раскрывающегося списка можно использовать следующие команды контекстного меню:

– По оси X,

– По оси Y,

– По оси Z,

– Параллельно объекту,

– Перпендикулярно объекту,

– По нормали,

– Вдоль многоугольника,

– В плоскости экрана.


Список Способ

Раскрывающийся список позволяет выбрать способ выравнивания полюсов сетки. Доступны следующие варианты:

– По направлению,

– По плоскому объекту.

В первом случае выбранные полюсы перемещаются на прямую, проходящую через центр выравнивания в заданном направлении. Перемещение производится перпендикулярно прямой.

Во втором случае выбранные полюсы перемещаются на плоскость, параллельную заданной плоскости и проходящую через центр выравнивания. Перемещение производится перпендикулярно плоскости.

Для выбора способа выравнивания вместо раскрывающегося списка можно использовать следующие команды контекстного меню:

– По направлению,

– По плоскому объекту.


Список Плоскость

Раскрывающийся список позволяет выбрать плоский объект для перемещения полюсов сетки выравниванием. Находится на Панели свойств, если из раскрывающегося списка Способ выбран способ выравнивания По плоскому объекту.

Доступны следующие варианты задания плоского объекта:

• Плоскость ХY,

• Плоскость ZХ,

• Плоскость ZY,

• Выбранная плоскость.

При выборе одного из первых трех вариантов автоматически выбирается соответствующая ему координатная плоскость текущей системы координат.

Вариант Выбранная плоскость позволяет указать произвольный плоский объект в Дереве или в окне модели. При этом на Панели свойств находится переключатель Плоский объект.

Для задания плоского объекта вместо раскрывающегося списка можно использовать следующие команды контекстного меню:

• Плоскость ХY,

• Плоскость ZХ,

• Плоскость ZY,

• Выбранная плоскость.


Опция Повышенная точность отрисовки

Опция позволяет сделать более ровными границы полос «зебры» или участков выбранного изображения, отражаемых в гранях модели.

По умолчанию опция отключена.


Поле Файл-источник

Поле присутствует на Панели свойств, если в списке способов отображения модели выбран способ Отражение среды. Позволяет выбрать файл изображения и просмотреть его полное имя.

Чтобы выбрать нужный файл, нажмите кнопку Файл изображения в правой части поля. На экране появится стандартный диалог выбора файлов. Укажите файл формата BMP, GIF, JPEG, PNG, TIFF или TGA и нажмите кнопку Открыть. Полное имя файла появится в поле.


Раскрывающийся список Способ

Позволяет выбрать один из следующих способов отображения:

– Зебра — в гранях модели отражается сфера с нанесенными на нее полосами,

– Отражение среды — в гранях модели отражается сфера с нанесенным на нее растровым изображением из файла.

Параметры отображения модели для каждого способа могут быть настроены. Элементы управления этими параметрами располагаются на Панели свойств. Набор элементов зависит от выбранного способа отображения модели.


Поле Цвет полос

Поле присутствует на Панели свойств, если в списке способов отображения модели выбран способ Зебра. Показывает текущий цвет полос «зебры» и позволяет изменить его.

Для выбора цвета щелкните мышью по треугольнику в правой части поля и укажите цвет в появившейся на экране палитре цветов.


Опция Добавить знак в скобках

При включении опции к неуказанной шероховатости добавляется знак шероховатости в скобках.


Поле Текст

В этом поле можно ввести с клавиатуры или выбрать из пользовательского меню текст надписи для обозначения неуказанной шероховатости.


Группа переключателей Направление построения

Группа переключателей, позволяющая выбрать направление построения спирали относительно ее опорной плоскости.

Изменение направления немедленно отображается на фантоме спирали.

Если высота спирали определяется по объекту или по линии эскиза, то изменение направления невозможно — группа недоступна.


Способ построения спирали

Список, позволяющий выбрать способ построения спирали: По числу витков и шагу, По числу витков и высоте или По шагу витков и высоте.


Точка привязки спирали

Поля координат точки привязки спирали в системе координат плоскости или плоской грани, на которой создается эта спираль.

По умолчанию значения координат равны нулю.

Вы можете ввести в эти поля значения с клавиатуры.

Чтобы указать положение спирали мышью, расфиксируйте поля координат и укажите нужную точку в окне модели. Координаты выбранной точки будут определены автоматически и занесены в соответствующие поля.


Диаметр спирали

Поле для задания диаметра цилиндрической спирали.

Вы можете ввести значение вручную или установить с помощью счетчика.

Изменение диаметра немедленно отображается на фантоме спирали.

Поле доступно, если диаметр спирали определяется по размеру.


Диаметр начальный

Поле для задания начального диаметра конической спирали.

Вы можете ввести значение вручную или установить с помощью счетчика.

Изменение диаметра немедленно отображается на фантоме спирали.

Поле доступно, если начальный диаметр спирали определяется по размеру.


Диаметр конечный

Поле для задания конечного диаметра конической спирали.

Вы можете ввести значение вручную или установить с помощью счетчика.

Изменение диаметра немедленно отображается на фантоме спирали.

Поле доступно, если конечный диаметр спирали определяется по размеру.


Угол наклона образующей

Поле для задания конечного диаметра конической спирали.

Вы можете ввести значение вручную или установить с помощью счетчика.

Изменение угла наклона образующей немедленно отображается на фантоме спирали.

Поле Угол доступно, если конечный диаметр спирали определяется по наклону образующей.


Наклон образующей спирали

Переключатель, позволяющий задать направление наклона образующей конической спирали.

При выборе варианта Наружу диаметр спирали будет увеличиваться в направлении ее построения.

При выборе варианта Внутрь диаметр спирали будет уменьшаться в направлении ее построения.

Изменение направления наклона образующей немедленно отображается на фантоме спирали.

Переключатель доступен, если конечный диаметр спирали определяется по наклону образующей.


Объект, определяющий диаметр спирали

Переключатель, позволяющий перейти к указанию объекта, определяющего диаметр цилиндрической спирали.

После активизации переключателя выберите нужный объект в Дереве построения или в окне модели.

Название указанного объекта отображается в справочном поле рядом с переключателем.

Переключатель доступен, если диаметр спирали определяется по объекту.


Объект, определяющий начальный диаметр

Переключатель, позволяющий перейти к указанию объекта, определяющего начальный диаметр конической спирали.

После активизации переключателя выберите нужный объект в Дереве построения или в окне модели.

Название указанного объекта отображается в справочном поле рядом с переключателем.

Переключатель доступен, если начальный диаметр спирали определяется по объекту.


Объект, определяющий конечный диаметр

Переключатель, позволяющий перейти к указанию объекта, определяющего конечный диаметр конической спирали.

После активизации переключателя выберите нужный объект в Дереве построения или в окне модели.

Название указанного объекта отображается в справочном поле рядом с переключателем.

Переключатель доступен, если конечный диаметр спирали определяется по объекту.


Диаметр (способ определения)

Диаметр
(способ определения)

Переключатель, позволяющий выбрать способ определения диаметра цилиндрической спирали.


Диаметр начальный (способ определения)

Диаметр начальный
(способ определения)

Переключатель, позволяющий выбрать способ определения начального диаметра конической спирали.


Диаметр конечный (способ определения)

Диаметр конечный
(способ определения)

Переключатель, позволяющий выбрать способ определения конечного диаметра конической спирали.


Начальный угол спирали

Поле для задания начального угла спирали — угла поворота спирали вокруг перпендикуляра к опорной грани.

Вы можете ввести значение вручную или установить с помощью счетчика.

Изменение начального угла немедленно отображается на фантоме спирали.


Размер

Значение, введенное в поле Размер, воспринимается системой по-разному в зависимости от выбранного способа определения высоты спирали.

Если был выбран вариант По размеру, введите в это поле высоту спирали.

Если был выбран вариант По объекту, введите в это поле расстояние между указанным объектом и второй опорной плоскостью спирали. Если нужно построить спираль с высотой, равной расстоянию от ее первой опорной плоскости до объекта, введите нулевое значение.

Если расстояние до объекта не нулевое, оно может быть отложено как в направлении построения (в этом случае спираль будет выше объекта на указанную величину), так и против направления построения (в этом случае спираль будет ниже объекта на указанную величину).

Чтобы изменить направление отсчета расстояния до объекта, воспользуйтесь переключателем Тип. Изменение направления построения немедленно отражается в фантоме спирали.


Группа переключателей Тип

Группа переключателей, позволяющая указать направление отсчета расстояния до объекта.

Изменение типа построения немедленно отражается на фантоме спирали в окне модели.


Объект, определяющий высоту спирали

Переключатель, позволяющий перейти к указанию объекта, определяющего высоту спирали.

После активизации переключателя выберите нужный объект в Дереве построения или в окне модели.

Название указанного объекта отображается в справочном поле рядом с переключателем.

Переключатель доступен, если высота спирали определяется по объекту или по линии эскиза.


Шаг витков спирали

Поле для задания шага витков спирали.

Вы можете ввести значение вручную или установить с помощью счетчика.

Поле Шаг витков доступно, если выбран соответствующий способ построения.


Количество витков спирали

Поле для задания количества витков спирали.

Вы можете ввести значение вручную или установить с помощью счетчика.

Поле Количество витков доступно, если выбран соответствующий способ построения.


Группа переключателей Направление навивки

Группа переключателей, позволяющая выбрать направление навивки спирали.

Изменение направления немедленно отображается на фантоме спирали.


Группа переключателей Управление

Позволяет выбрать способы редактирования сплайна в вершине:

– Положение вершины — изменение положения текущей вершины;

– Касательный вектор в вершине — управление касательным вектором сплайна в текущей вершине.

Для сплайна По полюсам управление касательным вектором возможно только в крайних вершинах.

Сплайн на поверхности...


Поле Кривая

В этом поле отображается название выбранной кривой, проходящей через текущую вершину сплайна. Касательный вектор сплайна в текущей вершине направлен по касательной к этой кривой.

В качестве кривой можно использовать:

– кривую, лежащую на указанной грани, или ребро этой грани;

– изопараметрическую кривую теоретической поверхности указанной грани.

Выбор объектов в окне модели

Управление касательным вектором сплайна в текущей вершине


Переключатель Сменить направление

Позволяет направить касательный вектор сплайна в противоположную сторону.

Переключатель присутствует на Панели свойств при задании условия касания сплайна в текущей вершине с кривой, проходящей через эту вершину.

Чтобы сменить направление касательного вектора, нажмите переключатель Сменить направление.

После нажатия переключателя вектор меняет свое направление — это немедленно отображается на фантоме сплайна в окне модели.

Сплайн на поверхности...


Список Касание

Позволяет выбрать условие касания сплайна в текущей вершине с кривой, проходящей через эту вершину.

Касательный вектор сплайна в текущей вершине будет направлен по касательной к этой кривой.

В качестве кривой можно использовать:

– кривую, лежащую на указанной грани, или ребро этой грани;

– изопараметрическую кривую теоретической поверхности указанной грани.

Чтобы задать условие касания сплайна, раскройте список и укажите в нем нужную строку. Управление касательным вектором описано в таблице. Фантом сплайна в окне модели перестроится согласно выбранному условию касания.

Управление касательным вектором сплайна в текущей вершине
Условие касания | Управление касательным вектором
Не задано | После выбора данного условия форма сплайна в текущей точке принимает умолчательный вид.
По направлению | Позволяет отредактировать параметры вектора в ручную. После выбора данного условия касания на экране появляется касательный вектор в виде пунктирного отрезка с характерной точкой. Вы можете изменить длину и направление вектора, перемещая мышью его характерную точку.
К изопараметрической кривой U; К изопараметрической кривой V | Позволяет задать направление вектора по касательной к изопараметрической кривой U (или V) указанной грани. После выбора данного условия касания вектор располагается по касательной к изопараметрической кривой. На экране появляется вектор заданного направления. Вы можете отредактировать длину вектора, перемещая мышью его характерную точку.
К кривой на поверхности | Позволяет задать направление вектора по касательной к кривой, лежащей на указанной грани. После выбора данного условия касания на экране появляется вектор с умолчательным направлением. Около текущей вершины появляется обозначение касания. Укажите в окне модели кривую или ребро, определяющее направление вектора. Затем измените длину вектора, перемещая мышью его характерную точку.

Общие сведения о теоретической поверхности грани...

Сплайн на поверхности...


Таблица Координаты вершин

Каждая строка таблицы содержит следующие параметры вершины:

– общие для ломаной и сплайна:

• номер,

• координаты вершины.

– специфические для сплайна по точкам с типом NURBS-кривая по точкам:

• длина вектора производной,

• угол наклона вектора производной,

• величина кривизны.

– специфические для сплайна по точкам с типом Кривая Безье:

• длины первого и второго векторов производной,

• углы наклона первого и второго векторов производной.

В таблице можно отредактировать значения координат любой вершины. Для этого дважды щелкните мышью в нужной ячейке и введите необходимое значение.

Кнопки над таблицей позволяют выполнять следующие действия:

– читать из файла значения параметров,

– сохранять в файл содержание таблицы параметров для последующего использования,

– создавать новые вершины,

– удалять вершины сплайна,

Подробнее о приемах работы с таблицей параметров вершин...


Величина кривизны

Поле задания величины кривизны сплайна в выбранной вершине.

При указании величины кривизны мышью она определяются автоматически и заносится в это поле.

Возможен также ввод значения с клавиатуры.


Угол наклона вектора производной

Поле задания угла наклона выбранного вектора производной.

При указании угла наклона мышью он определяются автоматически и заносится в это поле.

Возможен также ввод угла с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Длина вектора производной

Поле задания длины выбранного вектора производной.

При указании длины мышью она определяются автоматически и заносится в это поле.

Возможен также ввод значения с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Начальная точка сплайна

Поля координат начальной точки сплайна (NURBS или кривой Безье).

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните в поле правой кнопкой мыши.


Точка кривой Безье

Поля координат точки кривой Безье.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните в поле правой кнопкой мыши.


Точка на векторе

Поля координат точки на векторе касательной к кривой Безье.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните в поле правой кнопкой мыши.


Следующая точка сплайна

Поля координат очередной точки сплайна (NURBS или кривой Безье).

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните в поле правой кнопкой мыши.


Точка кривой Безье для редактирования

Поля координат точки, выбранной для редактирования кривой Безье.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните в поле правой кнопкой мыши.


Поле Вес

Поле для ввода или задания счетчиком веса в текущей вершине (полюсе) сплайна.

Вес может принимать значения в диапазоне 0,0001 — 999.

Поле Вес доступно только при построении сплайна по полюсам.

Вес полюса можно также задать в колонке Вес таблицы параметров вершин.


Элемент управления Разбиваемая поверхность

Позволяет задать разбиваемую поверхность — грань или набор граней тела или поверхности.

Выбор объектов в Дереве построения...

Выбор объектов в окне модели...

Название разбиваемой поверхности отображается в поле Разбиваемая поверхность. Если для разбиения указан набор граней, то в этом поле отображается их количество.

Чтобы сменить ранее выбранные грани, активизируйте переключатель Поверхность, повторно щелкните мышью по граням, а затем укажите новые грани.

Подробнее об объектах для операции разбиения...


Элемент управления Секущий объект

Позволяет задать секущий объект для разбиения:

– поверхность или плоскость, по линии пересечения с которой будет разбита поверхность;

– кривую на поверхности, по которой она будет разбита,

– эскиз, по проекции которого будет разбита поверхность.

Название секущего объекта отображается в поле Секущий объект. Если указано несколько секущих объектов, то в этом поле отображается их количество.

Выбор объектов в Дереве построения...

Выбор объектов в окне модели...

Чтобы сменить ранее выбранный секущий объект, активизируйте переключатель Секущий объект, повторно щелкните мышью по объекту, а затем укажите новый объект.

Подробнее об объектах для операции разбиения...


Поле Поверхность

В этом поле отображается название выбранной грани, на которой будет располагаться сплайн.

Выбор объектов в окне модели

Сплайн на поверхности...


Способ вставки растрового объекта

Переключатель, позволяющий указать нужный способ вставки растрового объекта: вставить внешней ссылкой или взять в документ.


Поле Шаг(построение группы точек по поверхности)

Поле Шаг
(построение группы точек по поверхности)

Поле значения шага между соседними узлами гексагональной сетки.

Вы можете ввести значение вручную или установить с помощью счетчика.

Изменение шага немедленно отображается на фантоме группы точек в окне модели.

Поле присутствует на Панели свойств, если в списке Тип сетки выбран тип сетки Гексагональная.

Подробнее о построении группы точек по поверхности...


Поле Шаг по оси 1 (построение группы точек по поверхности)

Поле Шаг по оси 1
(построение группы точек по поверхности)

Поле значения шага вдоль первой оси прямоугольной сетки.

Вы можете ввести значение вручную или установить с помощью счетчика.

Изменение шага немедленно отображается на фантоме группы точек в окне модели.

Поле присутствует на Панели свойств, если в списке Тип сетки выбран тип сетки Прямоугольная, а для построения группы точек используется плоская, сферическая или цилиндрическая грань.

Подробнее о построении группы точек по поверхности...


Поле Шаг по оси 2(построение группы точек по поверхности)

Поле Шаг по оси 2
(построение группы точек по поверхности)

Поле значения шага вдоль второй оси прямоугольной сетки.

Вы можете ввести значение вручную или установить с помощью счетчика.

Изменение шага немедленно отображается на фантоме группы точек в окне модели.

Поле присутствует на Панели свойств, если в списке Тип сетки выбран тип сетки Прямоугольная, а для построения группы точек используется плоская, сферическая или цилиндрическая грань.

Подробнее о построении группы точек по поверхности...


Поле Шаг по U, %(построение группы точек по поверхности)

Поле Шаг по U, %
(построение группы точек по поверхности)

Поле значения шага по параметру U прямоугольной сетки.

Подробнее о теоретической поверхности грани...

Вы можете ввести значение вручную или установить с помощью счетчика.

Изменение шага немедленно отображается на фантоме группы точек в окне модели.

Поле присутствует на Панели свойств, если в списке Тип сетки выбран тип сетки Прямоугольная, а для построения группы точек используется коническая, тороидальная или произвольная грань.

Подробнее о построении группы точек по поверхности...


Поле Шаг по V, %(построение группы точек по поверхности)

Поле Шаг по V, %
(построение группы точек по поверхности)

Поле значения шага по параметру V прямоугольной сетки.

Подробнее о теоретической поверхности грани...

Вы можете ввести значение вручную или установить с помощью счетчика.

Изменение шага немедленно отображается на фантоме группы точек в окне модели.

Поле присутствует на Панели свойств, если в списке Тип сетки выбран тип сетки Прямоугольная, а для построения группы точек используется коническая, тороидальная или произвольная грань.

Подробнее о построении группы точек по поверхности...


Штрих

Поле для ввода или задания счетчиком максимальной длины штрихов координационной оси. Поле доступно при выключенной опции Автоопределение.

Умолчательное значение задается в диалоге настройки отрисовки координационной оси.

Если умолчательное значение было изменено на Панели свойств, то дальнейшие изменения этого значения возможны только с Панели свойств.


Стиль1

Список, позволяющий выбрать стиль линии первого ограничителя.

Список недоступен, если первый ограничитель имеет вид Без ограничителя.


Стиль2

Список, позволяющий выбрать стиль линии второго ограничителя.

Список недоступен, если второй ограничитель имеет вид Без ограничителя.


Поле Поверхность сопряжения

Справочное поле, содержащее название поверхности, указанной для сопряжения создаваемой поверхности вдоль текущей границы сопряжения. Текущая граница сопряжения выбирается с помощью группы переключателей Номер границы. Выбранная граница выделена в окне модели.

В качестве поверхности сопряжения можно использовать:

– грани тел и поверхностей,

– вспомогательные и координатные плоскости.

Поверхность сопряжения должна полностью содержать границу сопряжения.

Указав поверхность сопряжения, выберите условие сопряжения из списка Условие.

Чтобы перейти к заданию поверхности и условия сопряжения для другой границы, сделайте эту границу текущей, активизировав нужный переключатель в группе Номер границы.

Подробнее о сопряжении поверхности...


Элемент управления Поверхность размещения

Переключатель, позволяющий задать поверхность размещения отверстия.

Активизируйте переключатель Поверхность,

Укажите поверхность размещения отверстия в окне модели.

Название поверхности размещения отображается в поле рядом с переключателем.


Список объектов

Содержит список объектов контура — кривых, эскизов, контуров, ребер. При выделении объекта в списке он выделяется в окне модели.

Над списком находится кнопка управления объектами в списке. Чтобы удалить объект, выделите его в списке и нажмите кнопку Удалить.

Обратите внимание на то, что при этом удаляются также все следующие за ним объекты в направлении конечной вершины контура. Направление из начальной вершины в конечную показано в окне модели стрелкой на фантоме контура.

Изменение набора объектов списка отображается на фантоме контура в окне модели.


Список Разделитель

Позволяет выбрать вид разделителя сегментов мультилинии.


Список Ограничитель 1

Позволяет выбрать вид первого ограничителя мультилинии.

Смотрите также

Ограничители мультилинии


Список Ограничитель 2

Позволяет выбрать вид второго ограничителя мультилинии.

Смотрите также

Ограничители мультилинии


Панель Список объектов

Содержит список объектов, выбранных для переноса в другую систему координат. После названия объекта в скобках приведено название его системы координат.

Некоторые объекты (ломаные, детали-заготовки и др.) отмечаются в списке значком с изображением замка. Это говорит о невозможности сохранения положения указанных объектов при переносе в другую систему координат.

Чтобы добавить объект в список, укажите его в Дереве построения.

Чтобы исключить какой-либо объект из числа выбранных, выделите его в списке и нажмите кнопку Удалить, расположенную над списком.

ЛСК могут быть выбраны для переноса в другую систему координат, только если при настройке ЛСК отключена опция Создавать ЛСК только в абсолютной СК.


Команда Текст надписи

Вызывает диалог ввода текста дополнительного обозначения, в котором вы можете ввести нужную надпись в обозначения прямых, дуговых и круговых координационных осей.

Текст вводится для следующих элементов дополнительных обозначений:

– указатель ориентации оси,

– марка,

– текст.

Чтобы вызвать этот диалог, щелкните мышью в поле Текст на вкладке Дополнительные обозначения Панели свойств.


Команда Резьба по образцу

Позволяет построить условное изображение резьбы с параметрами ранее созданной резьбы.

Для вызова команды активизируйте вкладку Параметры на Панели свойств. Нажмите кнопку Резьба по образцу на Панели специального управления или выберите ее название из контекстного меню.

Укажите в модели или в Дереве построения резьбу для копирования параметров.

Чтобы подтвердить создание резьбы, нажмите кнопку Создать объект.


Длина резьбы

Поле для ввода значения длины резьбы. Это поле доступно при отключенной опции На всю длину.


Шаг резьбы

Поле для ввода или выбора значения шага резьбы.


Угол наклона оси симметрии

Поле угла между осью симметрии и осью Х текущей системы координат.

При указании точек оси мышью угол наклона определяется автоматически и заносится в это поле.

Возможен также ввод значения с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Первая точка оси симметрии

Поля координат первой точки на оси симметрии.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Вторая точка оси симметрии

Поля координат второй точки на оси симметрии.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Группа Положение

Группа присутствует на Панели свойств в процессе изменения положения компонента зеркального исполнения или настройки параметров положения ведомого компонента сопряжения Симметрия, если компонент размещается способом Симметричное расположение.

Переключатели группы позволяют настроить параметры положения настраиваемого компонента. Доступны следующие варианты.

– Типовое положение

На Панели свойств появляется предопределенный список объектов исходного компонента (для исполнения) или ведущего компонента (для сопряжения), которые могут использоваться для определения положения настраиваемого компонента. Выберите нужную строку списка.

– Положение при ручном указании объекта

В окне модели появляется Окно модели — источника исходного компонента (для исполнения) или ведущего компонента (для сопряжения). Данное окно позволяет вручную указать объект, который будет использоваться для расчета положения настраиваемого компонента.

Вид окна модели-источника и работа в нем

Выберите нужный объект. Его наименование появится в поле Объект внутренней симметрии Панели свойств.

– Положение по базовому компоненту (вариант доступен только при настройке положения компонента зеркального исполнения)

Выберите компонент, определяющий положение настраиваемого компонента, в Дереве построения или в окне модели. Его наименование появится в поле Положение по базовому компоненту.

В качестве базового может быть выбран компонент, который расположен на одном уровне с настраиваемым компонентом и получен способом Симметричное расположение компонента.

Подробнее о настройке параметров отражения компонента...

Для выбора варианта положения компонента можно использовать соответствующие команды контекстного меню.


Синхронизировать со свойствами компонента

Переключатель, управляющий связью объекта спецификации, соответствующего компоненту сборки, со свойствами этого компонента.

– Активный переключатель означает, что изменение обозначения или наименования компонента будут передаваться из объекта спецификации в свойства компонента и наоборот. В результате обозначение (наименование) в свойствах компонента всегда будет совпадать с обозначением (наименованием) в соответствующем объекте спецификации.

– Неактивный переключатель означает, что передача данных не производится. В результате обозначение (наименование) компонента в свойствах и в объекте спецификации могут быть различными.


Группа Ориентация

Позволяет управлять ориентацией экземпляров массива.

– Если все экземпляры должны быть ориентированы в пространстве так же, как ориентирован копируемый объект, активизируйте переключатель Сохранять исходную ориентацию.

– Активизация переключателя Доворачивать по радиальному направлению позволяет ориентировать экземпляры, позиции которых заданы в цилиндрических или сферических координатах, по радиальному направлению. Подробнее...

Переключатель доступен, если позиции экземпляров задаются в цилиндрических или сферических координатах.

– Активизация переключателя Ориентировать по объекту позволяет ориентировать экземпляры по нормали к указанному объекту. В качестве объекта может использоваться:

• ребро, пространственная кривая или линия эскиза (кроме прямолинейных);

• грань (кроме плоской).

После активизации переключателя Ориентировать по указанному объекту на Панели свойств появляется поле Объект. Укажите нужный объект. Указанный объект выделяется цветом, а его наименование отображается в поле Объект. Подробнее...


Команда Изменить положение СК компонента

Позволяет изменить положение системы координат компонента при размещении этого компонента в модели способом По координатам.

Чтобы вызвать команду, нажмите кнопку Изменить положение СК компонента на Панели специального управления. Запустится процесс создания ЛСК. Выполните действия, необходимые для задания параметров ЛСК. После завершения работы команды система вернется в процесс размещения компонента.

В списке СК компонента появится строка Измененная. Обратите внимание на то, что в данном случае процесс создания ЛСК используется только для определения положения СК компонента. Новая ЛСК при этом не создается.

Новое положения СК используется только в текущем процессе размещения компонента. Эти данные не сохраняются в системе.


Команда Построение ЛСК

Позволяет построить локальную систему координат, в которой будет производиться изменение положения тела или поверхности.

Для вызова команды нажмите кнопку Построение ЛСК на Панели специального управления.

После вызова команды запускается операция создания ЛСК. Задайте позицию и ориентацию ЛСК.

Затем нажмите кнопку Создать объект.

Система вернется в процесс операции изменения положения тела или поверхности.

Созданная ЛСК появится в Дереве построения и будет автоматически выбрана в качестве системы координат, задающей исходное положение условной системы координат объекта.


Опции По окружности/По образующей

Опции служат для выбора вида сопряжения Касание.

Включенные (или выключенные) опции означают вид касания объектов.

– По окружности — касание по окружности.

– По образующей — касание по образующей.

– Обе опции выключены — касание в точке.

В паре сфера – тор возможен особый вид касания — в точках внешней и внутренней экваториальных окружностей тора. Этот вид касания считается касанием по окружности.

Можно выбрать вид сопряжения для следующих пар объектов:

– цилиндр – цилиндр (в точке, по образующей);

– конус – сфера (в точке, по окружности).

Для остальных пар объектов вид касания выбрать невозможно — он устанавливается системой автоматически после указания двух объектов (вне зависимости от включенной опции).


Стиль линии границы

Список, из которого можно выбрать текущий стиль линии границы ячейки.


Процесс ввода и редактирования таблиц и текстовых надписей

Процесс ввода и редактирования таблиц
и текстовых надписей

Во время создания текстов и таблиц в графических документах, заполнения текстовой части объектов спецификации и таблицы изменений, ввода надписей для специальных знаков и других подобных процессов работа ведется в специальном окне или диалоге.

Настройка создаваемых объектов (форматирование символов и абзацев, задание параметров объектов спецификации, редактирование конфигурации таблиц) производится с помощью вкладок Панели свойств.


Тип построения тонкой стенки

Список, позволяющий выбрать способ построения тонкой стенки. Доступны следующие варианты:

Описание элементов управления
Элемент | Описание
нет | при выборе этого варианта тонкая стенка не создается
наружу | при выборе этого варианта материал добавляется наружу по отношению к поверхности; допускаются только положительные значения толщины
внутрь | при выборе этого варианта материал добавляется внутрь по отношению к поверхности; допускаются только положительные значения толщины
два направления | при выборе этого варианта материал добавляется внутрь и наружу; толщина задается отдельно для каждого из направлений, значения могут быть либо оба положительными, либо одно положительным, а другое — отрицательным
средняя плоскость | при выборе этого варианта заданное значение толщины считается общим; в каждом направлении откладывается его половина; допускается только положительное значение толщины

В зависимости от конкретной операции (в некоторых операциях — также от типа сечения) некоторые варианты могут быть недоступными или отсутствовать.

Подробнее о построении тонкой стенки...


На всю длину

Опция, управляющая значением длины резьбы. Если эта опция включена, то длина определяется автоматически по размерам и положению объектов, указанных для построения резьбы.

Автоматически рассчитанное значение длины резьбы отображается в поле Длина.

Чтобы задать значение длины резьбы вручную, отключите построение на полную длину. Затем введите в ставшее доступным поле Длина нужное значение.


Автоопределение диаметра резьбы

Опция, управляющая значением номинального диаметра резьбы. Если эта опция включена, то диаметр определяется автоматически по размерам объекта, указанного для построения резьбы.

Автоматически рассчитанное значение диаметра отображается в поле Номинальный диаметр резьбы.

Чтобы задать значение диаметра резьбы вручную, отключите автоопределение диаметра. Затем введите в ставшее доступным поле Номинальный диаметр резьбы нужное значение.


Базовый объект резьбы

Переключатель, позволяющий перейти к указанию базового объекта для построения резьбы. Базовым объектом может являться цилиндрическая или коническая грань, на которой должна быть построена резьба.

После активизации переключателя укажите нужный объект в окне модели.

Указанный объект подсвечивается, его название отображается в справочном поле рядом с переключателем.

Грани, смежные с гранью, указанной для построения резьбы, автоматически определяются как границы резьбы — они подсвечиваются в окне модели, а их названия отображаются в полях Начальная граница и Конечная граница. При необходимости вы можете сменить автоматически выбранные границы.

Если длина резьбы определяется способом На заданную длину, то конечная граница резьбы не требуется для построения и соответствующий переключатель на Панели свойств отсутствует.


Начальная граница резьбы

Переключатель, позволяющий сменить начальную границу резьбы.

После активизации переключателя выберите в окне модели или в Дереве построения поверхность, грань или плоскость, от которой нужно построить резьбу.

Название указанного объекта отображается в справочном поле рядом с переключателем.


Конечная граница резьбы

Переключатель, позволяющий задать конечную границу резьбы. Присутствует на Панели свойств, если в группе Длина резьбы активен переключатель До конечной границы.

После активизации переключателя выберите в окне модели или в Дереве построения поверхность, грань или плоскость, до которой нужно построить резьбу.

Название указанного объекта отображается в справочном поле рядом с переключателем.


Номинальный диаметр резьбы

Поле для ввода значения номинального диаметра резьбы. Это поле доступно при отключенной опции Автоопределение диаметра.


Тип резьбы

Справочное поле, в котором отображается информация о типе создаваемой резьбы — наружная или внутренняя. Этот тип определяется системой автоматически.


Характерная точка допуска формы

Поля координат характерной точки допуска формы и расположения (точки привязки рамки или точки излома ответвления).

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Базовая точка

Список, позволяющий задать расположение таблицы допуска относительно точки, указанной в качестве базовой. Изменение расположения таблицы отображается на фантоме обозначения в окне документа.


Поле Направляющий объект

В этом поле отображается название направляющего объекта для вектора касательной или вектора нормали сплайна в текущей вершине.

В качестве направляющего объекта может использоваться любой точечный, прямолинейный или плоский объект.

Направление, задаваемое точечным объектом — прямая, проходящая через точечный объект и текущую вершину, прямолинейным — прямая, параллельная объекту, плоским — прямая, перпендикулярная объекту.

Направляющий объект следует указывать в Дереве построения или в окне модели.

Направляющим объектом может служить вектор. Для его создания нажмите кнопку Построение вектора на Панели специального управления.

Поле является справочным и недоступно для редактирования.

Смотрите также

Управление формой сплайна...


Группа переключателей Вращение

Группа переключателей, позволяющая выбрать базисный вектор сплайна в текущей вершине для вращения вокруг него управляющего фантома сплайна.

– Активизируйте переключатель Вокруг вектора касательной, чтобы фантом вращался вокруг вектора касательной.

– Активизируйте переключатель Вокруг вектора нормали, чтобы фантом вращался вокруг вектора нормали.

– Активизируйте переключатель Вокруг вектора бинормали, чтобы фантом вращался вокруг вектора бинормали.

– Если используется вариант управления Касательностью, то вращение управляющего фантома возможно только вокруг вектора нормали или вектора бинормали. Поэтому фантом не имеет характерную точку «Вокруг вектора касательной», а в группе Вращение недоступен переключатель Вокруг вектора касательной.

– Если используется вариант управления Кривизной, то вращение управляющего фантома возможно только вокруг вектора касательной или вектора бинормали. Поэтому фантом не имеет характерную точку «Вокруг вектора нормали», а в группе Вращение недоступен переключатель Вокруг вектора нормали.

– Если используется вариант управления Касательностью и кривизной, то вращение управляющего фантома возможно вокруг всех базисных векторов. Поэтому фантом содержит все характерные точки, а в группе Вращение доступны все переключатели.

Смотрите также

Управление формой сплайна...


Поле Угол

Поле для ввода значения угла вращения управляющего фантома сплайна в текущей вершине вокруг одного из базисных векторов (вектора касательной, нормали или бинормали).

Поле доступно, если в группе Вращение активен какой-либо переключатель.


Поле Радиус

Поле для ввода значения радиуса кривизны в текущей вершине сплайна.

Вы можете также задать величину радиуса кривизны с помощью характерной точки управляющего фантома «Радиус».

Смотрите также

Управление формой сплайна...


Поле Кривизна

Поле для ввода значения кривизны в текущей вершине сплайна.

Вы можете также задать величину кривизны с помощью характерной точки управляющего фантома «Кривизна».

Смотрите также

Управление формой сплайна...


Группа переключателей Ориентация

Группа переключателей, позволяющая выбрать направление вектора касательной или вектора нормали сплайна в текущей вершине: вдоль направляющего объекта или перпендикулярно ему.

Активизируйте нужный переключатель: Параллельно объекту или Перпендикулярно объекту.

Группа присутствует на Панели свойств, если в качестве направляющего объекта для вектора выбран прямолинейный объект.

Смотрите также

Управление формой сплайна...

Базисные векторы в точке кривой...


Координаты центра кривизны

Поля для ввода или задания счетчиком координат центра кривизны сплайна в текущей вершине.

Если положение центра кривизны задается мышью, то в этих полях отображаются его текущие координаты.

Если в качестве направляющего объекта для радиуса кривизны используется точечный объект, то поля недоступны. В них отображаются координаты указанного точечного объекта (центр кривизны совмещается с этим объектом).

Смотрите также

Управление формой сплайна...


Команда Удалить параметры управления во всех точках

Позволяет удалить заданные сопряжения сплайна или изменения формы сплайна во всех его вершинах.


Команда Удалить параметры управления в точке

Позволяет удалить:

– заданное сопряжение сплайна в текущей — начальной или конечной — вершине сплайна,

– заданное изменения формы сплайна в текущей вершине.


Группа переключателей Параметр

Группа переключателей, позволяющая выбрать управляющий параметр формой сплайна в текущей вершине — кривизну или радиус кривизны.

– Активизируйте переключатель Кривизна, чтобы задать кривизну в текущей вершине. Подробнее...

– Активизируйте переключатель Радиус кривизны, чтобы задать радиус кривизны. Подробнее...

Смотрите также

Управление формой сплайна...


Поле Касательность

Поле для ввода величины касательности в текущей вершине сплайна.

Величина касательности указывает, насколько форма сплайна близка к соприкасающейся окружности в окрестности его текущей вершины.

Чтобы задать величину касательности сплайна, введите в поле Величина касательности нужное значение и нажмите клавишу <Enter>.

Вы можете также задать величину касательности с помощью характерной точки управляющего фантома «Касательность».

Смотрите также

Управление формой сплайна...


Элемент Траектория

Служит для выбора траектории, вдоль которой происходит перемещение второго объекта.

При нажатой кнопке Траектория система ожидает указания объекта модели, задающего траекторию.

После указания в поле траектории появляется ее наименование, а на экране — стрелка, указывающая направление перемещения по умолчанию.

Элемент управления доступен, если указан второй объект.

При указании некоторых объектов выбор траектории (и отображение ее наименования в поле траектории) производится автоматически. Если требуется сменить объект, следует нажать кнопку Траектория и указать новый объект.


Список Условия

Раскрывающийся список позволяет задать дополнительное условие для линейного перемещения полюсов сетки, при котором будут перемещаться не только выбранные полюсы, но и некоторое количество невыбранных полюсов, расположенных в тех же рядах, что и выбранные. Ряды могут располагаться по направлению U или V сетки, а также по обоим направлениям.

По умолчанию в списке выбран вариант Без условий.

Для задания условия выберите вариант Пропорционально. На Панели свойств появятся дополнительные элементы управления, позволяющие задать направление отсчета и количество перемещаемых полюсов.


Список U/V

Раскрывающийся список позволяет задать направление отсчета полюсов сетки, перемещаемых в соответствии с дополнительным условием, заданным для линейного перемещения полюсов. Отсчет может производиться по направлению U/V сетки или по обоим направлениям.

Доступны следующие варианты направления отсчета полюсов:

– Перед и после — количество перемещаемых полюсов отсчитывается в каждую сторону от выбранного полюса,

– Перед — количество перемещаемых полюсов отсчитывается от выбранного полюса против направления U/V,

– После — количество перемещаемых полюсов отсчитывается от выбранного полюса по направлению U/V,

– Не перемещать — перемещается только выбранный полюс, положение остальных полюсов ряда не изменяется.

При выборе одного из первых трех вариантов на Панели свойств появляются поля для задания количества перемещаемых полюсов.


Список Условие

Список для выбора условия сопряжения создаваемой поверхности с уже существующей в модели поверхностью вдоль их общей границы (границы сопряжения). Граница выбирается с помощью группы переключателей Номер границы, а существующая поверхность указывается мышью в окне модели.

– Если сеть, по которой создается поверхность, не содержит кривых в направлении, противоположном границе сопряжения, то для этой границы возможен выбор любого условия сопряжения.

– Если же кривые противоположного направления есть, то для перпендикулярного сопряжения все они должны быть перпендикулярны поверхности сопряжения, а для сопряжения по касательной — касательны. Если кривые противоположного направления расположены произвольным образом по отношению к поверхности сопряжения, то возможно лишь сопряжение не задано.

В списке Условие доступны только те условия, которые можно применить к текущей границе.

Изменение условия сопряжения отображается на фантоме поверхности в окне модели. Около номера границы появится обозначение условия сопряжения.

Подробнее о сопряжении поверхности...


Группа переключателей Способ

Группа переключателей для выбора способа управления формой сплайна в текущей вершине.

– Активизируйте переключатель Управление ориентацией касательной и величиной касательности, чтобы задать направление вектора касательной сплайна и величину касательности в этой вершине. Подробнее...

– Активизируйте переключатель Управление ориентацией нормали и кривизной, чтобы задать кривизну или радиус кривизны.

• Задание кривизны включает в себя определение направления вектора нормали и задание величины кривизны. Подробнее...

• Задание радиуса кривизны включает в себя определение положения центра кривизны и задание величины радиуса кривизны. Подробнее...

Смотрите также

Управление формой сплайна...

Базисные векторы в точке кривой...

Кривизна кривой. Соприкасающаяся окружность...


Элемент Сменить направление

Переключатель, позволяющий выбрать, какую часть усекаемой поверхности по отношению к линии пересечения следует удалить.

Переключатель становится доступен, если указаны усекаемая поверхность и секущий объект.

На линии пересечения объектов отображается стрелка, которая указывает на ту часть поверхности, которая будет удалена.

Чтобы удалить другую часть усекаемой поверхности, нажмите переключатель Сменить направление.

После нажатия переключателя стрелка на линии усечения меняет направление.


Элемент управления Усекаемая поверхность

Переключатель, позволяющий задать усекаемую поверхность.

Укажите объекты в окне модели или в Дереве построения.

Название указанного объекта отображается в поле рядом с переключателем. Если выбранный объект состоит из нескольких граней, то вместо названия отображается их количество.

Чтобы сменить ранее выбранную поверхность, активизируйте переключатель Поверхность, щелкните по поверхности мышью повторно, а затем укажите новый объект.


Элемент управления Секущий объект

Переключатель, позволяющий задать

– объект, по линии пересечения с которым будет усечена поверхность;

– эскиз, по проекции которого будет усечена поверхность.

Укажите секущий объект в окне модели или в Дереве построения.

Название указанного объекта отображается в поле рядом с переключателем. Если выбранный объект состоит из нескольких граней или сегментов кривых, то вместо названия отображается их количество.

Указанные объекты подсвечиваются в Дереве построения и в окне модели.

Чтобы сменить ранее выбранный секущий объект, активизируйте переключатель Секущий объект, щелкните по объекту мышью повторно, а затем укажите новый объект.


Опция Два секущих объекта

Позволяет включить усечение исходной кривой двумя объектами.

При включении опции на Панели свойств появляется переключатель Секущий объект 2; переключатель Сменить направление исчезает.


Поле Поворот(построение группы точек по поверхности)

Поле Поворот
(построение группы точек по поверхности)

Поле значения угла поворота сетки вокруг нормали грани в центре сетки.

Угол поворота сетки отсчитывается от направления U против часовой стрелки.

Подробнее о теоретической поверхности грани...

Вы можете ввести значение вручную или установить с помощью счетчика.

Значение может быть как положительным — поворот против часовой стрелки, так и отрицательным — поворот по часовой стрелке.

Изменение угла поворота немедленно отображается на фантоме группы точек в окне модели.

Поле доступно, если для построения группы точек выбрана поверхность с постоянной кривизной.

Подробнее о построении группы точек по поверхности...


Тип (заливки)

Тип
(заливки)

Список, из которого можно выбрать текущий тип заливки.


Раскрывающийся список Способ построения

Позволяет выбрать способ построения пространственного сплайна или ломаной:

– По точкам,

– По осям (По оси X, По оси Y, По оси Z),

– По объектам (Параллельно объекту, Перпендикулярно объекту).


Группа переключателей Смещение зазора

Служат для задания параметров размещения зазора на обечайке. Доступны, если указан замкнутый эскиз.

Смещение характеризует положение точки в центре зазора относительно начальной точки контура в эскизе (для линейчатой обечайки — в эскизе первого основания). Начальная точка контура определяется системой автоматически. Чтобы задать смещение, активизируйте нужный переключатель в группе Смещение зазора, затем введите или задайте счетчиком значение параметра.

При активном переключателе По параметру U задайте в поле ввода Параметр U, % относительную величину смещения — в процентах от 0 до 100 от длины контура в эскизе.

При активном переключателе По длине задайте в поле ввода Длина абсолютное смещение — в единицах измерения длины.

При активном переключателе Угол расположения задайте в поле Угол расположения центральный угол дуги — в единицах измерения угла.
При работе с командой Обечайка вариант доступен, если контуром обечайки является окружность.
При работе с командой Линейчатая обечайка вариант доступен, если окружность является контуром первого основания.

Подробнее о смещении зазора...


Опция От исходной

Позволяет определить, относительно какой формы редактируемой грани будет рассчитываться положение нормали при линейном перемещении полюсов сетки вдоль нормали. Опция находится на Панели свойств, если в списке Направление выбран вариант По нормали.

Если опция включена, положение нормали рассчитывается относительно исходной формы редактируемой грани, если опция отключена — относительно текущей формы этой грани. Исходной формой грани считается та форма, которую имела грань на момент вызова команды Сплайновая форма.


Опция Только внешний контур

Опция, позволяющая выбрать вариант расположения центра масс плоской грани. Центр масс грани определяет позицию ЛСК или присоединительной точки.

– При включенной опции расчет центра масс грани производится без учета внутренних контуров грани (учитывается только внешний контур грани).

– При отключенной опции расчет центра масс грани производится с учетом внутренних контуров грани.

Смотрите также

Команда ЛСК...

Команда Присоединительная точка...


Опция Сегментация

Опция, включающая и отключающая сегментацию дуг окружности и эллипсов в контуре обечайки, — замену их аппроксимирующими ломаными с сегментами равной длины.

Опция Сегментация доступна, если контур обечайки содержит дуги окружностей и/или эллипсов или контуром является окружность/эллипс.

После включения опции на вкладке Сегментация Панели свойств появляются элементы для настройки сегментации.

Подробнее о настройке сегментации...


Поле Угол нутации

Поле для ввода угла нутации при ориентировании ЛСК способом Система углов Эйлера.

Угол нутации должен находиться в пределах от 0° до 180°.


Группа элементов Вариант сопряжения

Группа элементов управления для выбора варианта сопряжения Касание:

– кнопка Следующий для просмотра вариантов сопряжения, если их несколько,

– опции По окружности и По образующей для выбора вида сопряжения.

Группа элементов Вариант сопряжения доступна, если указаны объекты, форма которых допускает различные варианты сопряжения: например, два цилиндра могут касаться по образующей или в точке.


Обход угла

Группа переключателей, позволяющая выбрать способ обхода угла в вершине базовой линии — способ соединения линий мультилинии на стыке сегментов.

Возможны три способа обхода угла: обход срезом, обход скруглением, обход скруглением с одинаковым радиусом.

Примеры способов обхода угла...

– При построении мультилинии способ обхода угла задается для начальной вершины добавляемого сегмента. Заданный способ по умолчанию используется для последующих вершин.

– При редактировании мультилинии вы можете задать нужный способ обхода угла для любой ее вершины, кроме конечных.

Активизируйте нужный переключатель: Обход срезом, Обход скруглением, Обход скруглением с одинаковым радиусом.


Элемент управления Вершина

Переключатель, позволяющий задать точечный объект, до которого должна продлеваться грань. Переключатель доступен, если выбран способ продления грани До вершины.

Укажите нужный точечный объект в окне или Дереве построения. Наименование выбранного объекта отображается в поле рядом с переключателем.

Чтобы сменить точечный объект, активизируйте переключатель Вершина, а затем укажите нужный точечный объект заново.

Выбор объектов в окне модели

Выбор объектов в Дереве построения


Точка начала стрелки

Поля координат точки начала (острия) стрелки взгляда.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Положение стрелки

Поля координат точки, определяющей положение стрелки взгляда.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Положение текста

Поля координат точки, определяющей положение обозначения стрелки взгляда.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Стрелка взгляда

Список, позволяющий выбрать вид стрелки взгляда. Перечень стрелок, доступных для выбора, а также порядок следования стрелок в списке определяется настройкой фильтра стрелок, сделанной для текущего документа. При необходимости настраивается отрисовка стрелок.


Амплитуда волн

Поле Амплитуда служит для ввода или задания счетчиком числового значения амплитуды волнистой линии.

Амплитуда волны — расстояние между средней линией и наиболее удаленной от нее точкой волны.

Амплитуда может задаваться в относительных или абсолютных единицах.

Выбор единиц задания амплитуды производится при помощи переключателей единиц значения амплитуды.

При изменении значения в поле Амплитуда волнистая линия перестраивается.

При смене единиц задания амплитуды значение в поле Амплитуда пересчитывается.

Умолчательное значение амплитуды задается в диалоге настройки отрисовки обозначения.

Если умолчательное значение амплитуды было изменено на Панели свойств, то дальнейшие изменения этого значения возможны только с Панели свойств


Угол наклона средней линии волнистой линии

Поле для ввода угла наклона средней линии волнистой линии к оси ОХ текущей системы координат.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Количество полуволн волнистой линии

Количество полуволн
волнистой линии

Переключатель, позволяющий построить волнистую линию с фиксированным количеством полуволн. В процессе построения при изменении координат концов волнистой линии количество полуволн будет постоянным и равным заданному.

Если переключатель активизирован, то поле Количество полуволн доступно для задания параметров. После задания значения изображение волнистой линии перестроится, а в поле Длина волны отобразится автоматически рассчитанное значение текущей длины волны.

Если переключатель находится в неактивном состоянии, то в поле Количество полуволн отображается округленное до целого число полуволн, соответствующее текущему значению длины волны в поле Длина волны.

Переключение между способами построения волнистой линии возможно в любой момент. При этом значение (количества полуволн или длины волны), отображавшееся в поле в момент активизации переключателя, становится текущим.

Умолчательное значение количества полуволн задается в диалоге настройки отрисовки обозначения.


Направление волнистой линии

Группа переключателей, позволяющая выбрать направление отрисовки волнистой линии (см. рис.).

Для смены направления волнистой линии активизируйте переключатель Направление 1 или Направление 2.


Конечная точка волнистой линии

Поля координат конечной точки (т2) волнистой линии.

Конечная точка лежит на средней линии волнистой линии.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Начальная точка волнистой линии

Поля координат начальной точки (т1) волнистой линии.

Начальная точка лежит на средней линии волнистой линии.

При указании точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Возможен также ввод значений координат с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Длина волны (номинальная длина волны волнистой линии)

Длина волны
(номинальная длина волны волнистой линии)

Переключатель, позволяющий построить волнистую линию с заданной длиной волны.

Если переключатель активизирован, то поле Длина волны доступно для ввода значений. Введите в него номинальную длину волны — любое положительное число.

Номинальная длина волны — некоторая ориентировочная величина, используемая при построении волнистой линии. После задания номинальное значение в поле ввода не отображается.

Фактическая длина волны — величина, наиболее близкая к номинальной, вычисляемая исходя из целого количества полуволн на текущем отрезке средней линии.

Фактическая длина волны вычисляется как удвоенное расстояние между начальной и конечной точками средней линии, поделенное на количество полуволн. Поэтому, если в поле Длина волны вводится значение, превышающая удвоенное расстояние между начальной и конечной точками волнистой линии, то фактическая длина волны принимается равной этому удвоенному расстоянию между концами волнистой линии, а количество полуволн принимается равным единице.

После ввода номинальной длины волны в поле Количество полуволн отображается число полуволн, округленное до целого. В процессе построения в поле Длина волны отображается фактическое значение. Изображение волнистой линии на экране соответствует фактическому значению длины волны.

Переключение между способами построения волнистой линии возможно в любой момент. При этом значение (количества полуволн или длины волны), отображавшееся в поле в момент активизации переключателя, становится текущим.


Длина средней линии волнистой линии

Поле длины средней линии создаваемой волнистой линии.

При указании конечной и начальной точек мышью длина определяется автоматически и заносится в это поле.

Возможен также ввод значения с клавиатуры.

Для вызова меню геометрического калькулятора щелкните над полем правой кнопкой мыши.


Переключатель единиц задания амплитуды

Группа переключателей, позволяющая выбрать единицы измерения вводимых значений амплитуды волны волнистой линии.

Если активен переключатель Значения амплитуды в %, то значение, введенное в поле Амплитуда, показывает соотношение между амплитудой и длиной волны. Если в процессе построения или редактирования изменяются координаты концов волнистой линии, амплитуда изменяется пропорционально длине волны.

Если активен переключатель Значения амплитуды в мм то значение, введенное в поле Амплитуда, показывает абсолютное значение расстояния между средней линией и максимально удаленной от нее точкой волны. Если в процессе построения или редактирования изменяются координаты концов волнистой линии, амплитуда не изменяется.

При смене единиц задания амплитуды значение в поле Амплитуда пересчитывается.


Группа Область применения

Группа переключателей, позволяющая указать тип области применения для операции. Эта группа содержится на вкладке Параметры или Результат операции (при работе с массивом).

• Активизация переключателя Область применения «Компоненты и тела» означает, что действие операции будет распространяться на компоненты модели и на построенные в ней тела.

• Активизация переключателя Область применения «Компоненты» означает, что действие операции будет распространяться только на компоненты модели.

• Активизация переключателя Область применения «Тела» означает, что действие операции будет распространяться только на тела, построенные в модели.


Координаты X и Y

Поля для ввода или задания счетчиком прямоугольных координат точки Х и Y.

При задании положения точки мышью ее координаты определяются автоматически и заносятся в эти поля.

Если точка связана с точечным объектом (на кнопке Объект при этом отображается «галочка»), то поля координат недоступны для ввода.

Подробнее о построении точки по координатам на плоскости...


Координата Z

Поле для ввода или задания счетчиком цилиндрической координаты точки Z.

Если точка связана с точечным объектом (на кнопке Объект при этом отображается «галочка»), то поле координаты недоступно для ввода.

При задании положения точки мышью координата определяется автоматически и заносится в поле.

Подробнее о построении точки по координатам на цилиндре и сфере...


Группа переключателей Точка 1/Точка 2

Группа переключателей, позволяющая при построении или редактировании параллелепипеда указать, какая из точек задается: первая или вторая.

Активизируйте нужный переключатель: Точка 1 или
Точка 2 на Панели свойств.

Точку параллелепипеда можно указать следующими способами:

– указать положение мышью в окне модели: координаты точки определяются автоматически и заносятся в поля X, Y, Z;

– задать координаты в пространстве.

– связать с уже имеющимся точечным объектом: включить опцию Ассоциировать и указать в модели точечный объект;

– построить, нажав кнопку Построение точки на Панели специального управления;

Изменение положения вершины немедленно отображается на фантоме параллелепипеда в окне модели.

При построении параллелепипеда последовательная активизация переключателей происходит автоматически.


Группа переключателей Вариант задания параллелепипеда

Позволяет выбрать вариант задания параллелепипеда.

Активизируйте переключатель По 2 вершинам, чтобы построить параллелепипед по двум противоположным вершинам.

Активизируйте переключатель По центру и вершине, чтобы построить параллелепипед по центру и вершине.


Панель Список объектов

Панель служит для формирования списка секущих плоскостей для разбиения зоны.

По умолчанию список пуст. Вы можете добавить нужные объекты в список, указывая их мышью в Дереве построения или в окне модели.

Если требуется удалить объект из списка, выделите его на панели Список объектов и нажмите кнопку Удалить из списка, расположенную в верхней части панели.


Команда Разбить зонуСпособ разбиения По набору плоскостей

Команда Разбить зону
Способ разбиения По набору плоскостей

Данный способ позволяет разбить зону с помощью секущих плоскостей.

Способ можно сделать текущим, выбрав его название из списка Способ на Панели свойств или из контекстного меню команды Разбить зону.

Укажите секущие плоскости.


Команда Разбить зонуСпособ разбиения Равномерно по осям

Команда Разбить зону
Способ разбиения Равномерно по осям

Данный способ позволяет разбить зону равномерно по сетке.

Способ можно сделать текущим, выбрав его название из списка Способ на Панели свойств или из контекстного меню команды Разбить зону.

Укажите количество зон по осям X, Y и Z.


Группа переключателей Способ

Список, из которого можно выбрать способ разбиения зоны:

– Равномерно по осям — разбиение зоны регулярной сеткой.

– По набору плоскостей — разбиение зоны секущими плоскостями.


Команда Создать зонуСпособ создания По координатам

Команда Создать зону
Способ создания По координатам

Данный способ позволяет построить зону по координатам точек параллелепипеда.

Способ можно сделать текущим, выбрав его название из списка Способ на Панели свойств или из контекстного меню команды Создать зону.

1. Укажите вариант задания параллелепипеда:

– По 2 вершинам;

– По центру и вершине.

2. Укажите Точку 1. Переключатель Точка 1 активизирован по умолчанию.

После задания первой точки автоматически активизируется переключатель Точка 2.

3. Укажите Точку 2.

Подробнее...


Поле Количество по X

Поле значения количества зон по оси X.

Вы можете ввести значение вручную или установить с помощью счетчика.

Изменение количества зон сразу отображается на фантоме зоны в окне модели.


Поле Количество по Y

Поле значения количества зон по оси Y.

Вы можете ввести значение вручную или установить с помощью счетчика.

Изменение количества зон сразу отображается на фантоме зоны в окне модели


Поле Количество по Z

Поле значения количества зон по оси Z.

Вы можете ввести значение вручную или установить с помощью счетчика.

Изменение количества зон сразу отображается на фантоме зоны в окне модели


Команда Создать зонуСпособ создания По габаритам объектов

Команда Создать зону
Способ создания По габаритам объектов

Данный способ позволяет построить зону по габаритам указанных объектов.

Способ можно сделать текущим, выбрав его название из списка Способ на Панели свойств или из контекстного меню.

Укажите объекты, определяющие габариты зоны. Созданная зона представляет собой габаритный параллелепипед всех указанных объектов.

Подробнее...


Панель Список объектов

Панель служит для формирования списка объектов, определяющих габариты зоны.

По умолчанию список пуст. Вы можете добавить нужные объекты в список, указывая их мышью в Дереве построения или в окне модели.

Если требуется удалить объект из списка, выделите его на панели Список объектов и нажмите кнопку Удалить из списка, расположенную в верхней части панели.


Список Способ

Список, из которого можно выбрать способ задания габаритов зоны:

– По координатам — параллелепипед, ограничивающий зону, строится по заданным точкам;

– По габаритам объектов — параллелепипед, ограничивающий зону, строится как габаритный параллелепипед указанных объектов.


Построение присоединительной точки способом По объекту

Для построения присоединительной точки по объекту необходимо указать объект, параметры которого позволяют однозначно определить позицию и ориентацию присоединительной точки.

Объекты для создания присоединительной точки
Объект | Параметры присоединительной точки, определяемые объектом
 | Позиция | Ориентация
Эскиз | Начало системы координат эскиза | Первая ось: перпендикулярна плоскости эскиза, Вторая ось: совпадает с осью Y системы координат эскиза
Промежуточная вершина ломаной | Вершина ломаной | Первая ось: параллельна главной нормали к плоскости, проходящей через предыдущий и последующий сегменты ломаной, Вторая ось: параллельна проекции следующего сегмента ломаной на плоскость, перпендикулярную предыдущему сегменту
Точка, созданная способом На кривой 1 | Точка | Первая ось: параллельна бинормали к кривой в точке, Вторая ось: параллельна главной нормали к кривой в точке
Точка, созданная способом На поверхности или Проекция | Точка | Первая ось: параллельна главной нормали поверхности в точке, Вторая ось: параллельна касательной по направлению V2
Дуга окружности или эллипса (кривая, контур в эскизе или ребро) | Центр дуги | Первая ось: перпендикулярна плоскости дуги, Вторая ось: в плоскости дуги перпендикулярна радиусу, проведенному к начальной вершине
Система координат | Начало СК | Первая ось: совпадает с осью Z системы координат, Вторая ось: совпадает с осью Y системы координат
Тело3 | Центр масс | Первая ось: совпадает с осью инерции Oz, Вторая ось: совпадает с осью инерции Oy
Плоская грань | Центр масс грани4 | Первая ось: параллельна главной нормали к грани в центре масс грани, Вторая ось: параллельна оси Y системы координат грани
  1. Для создания присоединительной точки невозможно использовать точку, построенную на линейной кривой.
  2. Направления U и V видны на экране, например, во время построения точки способом На поверхности.
  3. Тела, у которых нет осей инерции (например, шар), не могут использоваться. Если у выбранного тела одна ось инерции (например, цилиндр), то с ней совпадает главная ось присоединительной точки.
  4. Возможен выбор варианта расположения центра масс грани. Для этого служит опция Только внешний контур на Панели свойств (см. ниже).

После указания объекта в окне модели появляется фантом присоединительной точки, расположенный согласно параметрам объекта. Название объекта появляется в поле Объект на Панели свойств. Присоединительная точка ассоциативно связывается с этим объектом.

Опция Только внешний контур управляет положением центра масс плоской грани, который определяет позицию присоединительной точки. Если опция включена, то при расчете центра масс грани учитывается только внешний контур грани. При отлюченной опции расчет центра масс грани производится с учетом внутренних контуров грани.

На рисунке показаны варианты расположения центра масс грани; центр масс отмечен кружком.

Варианты расположения центра масс плоской грани: а) при включенной опции Только внешний контур, б) при отключенной опции Только внешний контур
а) | б)


Построение присоединительной точки способом Ручное задание направления осей

Данный способ позволяет построить присоединительную точку, указав в модели точечный объект, с которым она совпадает, и объекты, определяющие ее ориентацию.

Чтобы построить присоединительную точку, выполните следующие действия.

1. Выберите из списка Способ на Панели свойств строку Ручное задание направления осей.

Фантом точки отображается в окне модели. По умолчанию новая присоединительная точка совмещена с началом текущей локальной системы координат и ориентирована по ее осям X и Y.

Обратите внимание на то, что позиция и ориентация присоединительной точки, заданные способом По объекту, сохраняются при переходе к способу Ручное задание направления осей. Фантом точки располагается согласно параметрам ранее заданного объекта. Вы можете изменить позицию и/или ориентацию присоединительной точки с помощью элементов управления текущего способа (см. ниже).

2. Укажите существующий в модели точечный объект, с которым будет совпадать присоединительная точка. Название точечного объекта появится в поле Точка.

Если в модели нет нужного точечного объекта, вы можете создать его, не выходя из команды. Для этого нажмите кнопку Построение точки на Панели специального управления.

3. Укажите первый направляющий объект — объект, задающий направление первой оси присоединительной точки. Эта ось показана на фантоме отрезком со стрелкой.

Кроме того, направляющим объектом может служить вектор. В этом случае направление оси будет совпадать с направлением вектора. Чтобы создать вектор, нажмите кнопку Построение вектора на Панели специального управления.

Название объекта, выбранного в качестве направляющего, появится в поле Объект 1. Если направление оси задано вектором, то в этом поле отображается слово «Вектор».

Если требуется сменить направление первой оси на противоположное, воспользуйтесь группой переключателей Направление.

4. Аналогичным образом задайте направление второй оси (если присоединительная точка имеет две оси). Вторая ось показана на фантоме отрезком без стрелки.

Направляющий объект для второй оси может задавать направление, не перпендикулярное первой оси. В этом случае направление второй оси определяется как проекция направления, которое задает объект, на плоскость, перпендикулярную первой оси.

Объект не может использоваться в качестве направляющего для второй оси, если он параллелен первой оси или лежит на одной прямой с ней.

Вектор не может использоваться в качестве направляющего объекта для второй оси, если он коллинеарен первой оси. При обнаружении ошибки выдается сообщение об этом.


Производные размеры

Производными размерами называются размеры эскизов и операций, представленные в виде элементов оформления. Подробнее...


Работа с окном Таблица изменяемых переменных при управлении переменными экземпляров массива

Работа с окном Таблица изменяемых переменных
при управлении переменными экземпляров массива

Окно Таблица изменяемых переменных используется при управлении переменными экземпляров массива.

Окно может содержать новую или уже созданную таблицу изменяемых переменных.

– Если таблица новая, то она содержит только столбец с номерами экземпляров массива.

Чтобы создать таблицу, выполните следующие действия.

1. Сформируйте набор переменных, значения которых следует изменить. Для этого укажите в окне модели нужные размеры копируемого объекта.
В таблице появляются столбцы, соответствующие выбранным переменным. Их ячейки, кроме первой (соответствующей базовому экземпляру), пустые. Это означает, что переменные в них имеют значения, совпадающие со значениями соответствующих переменных базового экземпляра.

2. Задайте переменным набора новые значения одним из способов:

• ввод значений (нажата кнопка Значения переменных) —
введите новые значения переменных в нужные ячейки (рис. а);

• задание шага изменения значений (нажата кнопка Шаг значений) —
введите значения шага для нужных переменных (рис. б).

а) | б)

– Если таблица уже создана, то ее вид зависит от способа задания значений переменных для экземпляров (см. рисунки выше).

При необходимости отредактируйте таблицу.
Приемы работы с таблицей изменяемых переменных...

Для закрытия окна и сохранения изменений нажмите кнопку ОК.

Для закрытия окна без сохранения изменений нажмите кнопку Отмена.

Смотрите также

Управление переменными экземпляров


Работа с окном Таблица изменяемых переменных при ручном задании позиций экземпляров массива по таблице

Работа с окном Таблица изменяемых переменных
при ручном задании позиций экземпляров массива по таблице

Окно Таблица изменяемых переменных используется при ручном задании позиций экземпляров массива по таблице.

Окно может содержать новую или уже созданную таблицу изменяемых переменных.

Таблица изменяемых переменных позволяет задать нужное количество экземпляров массива и координаты их базовых точек.

Если таблица изменяемых переменных новая, то она содержит столбцы, соответствующие координатам базовых точек экземпляров. Их ячейки, кроме первой (соответствующей базовому экземпляру), пустые. Это означает, что координаты в них имеют значения, совпадающие со значениями соответствующих координаты базового экземпляра.

Обратите внимание на то, что координаты отображаются в таблице, если на инструментальной панели окна Таблица изменяемых переменных нажата кнопка Задать координаты базовой точки.

Чтобы создать таблицу, выполните следующие действия.

1. Задайте нужное количество экземпляров — строк в таблице (по умолчанию в таблице создается три строки, см. рис.). Для этого нажмите нужную кнопку:

• Добавить строку выше,

• Добавить строку ниже,

• Удалить строки (доступна после выделения строки или ячейки).

2. Задайте экземплярам новые координаты базовых точек одним из способов:

• ввод координат (нажата кнопка Значения переменных) —
введите новые координаты в нужные ячейки (рис. а);

• задание шага изменения координат (нажата кнопка Шаг значений) —
введите значения шага для нужных координат (рис. б).

а) | б)

– Если таблица уже создана, то ее вид зависит от способа задания позиций экземпляров (см. рисунки выше).

При необходимости отредактируйте таблицу.
Приемы работы с таблицей изменяемых переменных...

Для закрытия окна и сохранения изменений нажмите кнопку ОК.

Для закрытия окна без сохранения изменений нажмите кнопку Отмена.

Смотрите также

Массив по таблице

Особенности использования таблицы изменяемых переменных


Прямолинейные объекты

Прямолинейными объектами являются:

– координатная или вспомогательная ось,

– отрезок,

– сегмент ломаной,

– прямолинейное ребро,

– отрезок в эскизе.


Отчет

Отчет — графическая таблица, содержащая данные об объектах.

Объектами, по которым формируется отчет, являются модели и компоненты любого уровня, включая стандартные изделия, компоненты из библиотек моделей, тела, а также графические макроэлементы, вставки видов и фрагментов.

В таблицу автоматически заносятся сведения из документа-модели или графического документа. Например, отчет может включать в себя перечень объектов и их свойства — наименование, обозначение, массу, количество, позицию, изготовителя, цену и т.д. Список объектов и набор свойств, помещаемых в отчет, определяется пользователем.

Свойства в отчете могут быть представлены в виде ссылок. Также может создаваться ассоциативный отчет, связанный с документом, по которому он получен.

Отчет размещается в чертежах, фрагментах, текстовых документах, а также сохраняется в форматы *.cdw, *.frw, *.kdw, *.tbl, *.txt, *.ods, *.xls.


Report_H

Report_H


Линия построения вершины

Линия построения вершины — условная прямая, соединяющая создаваемую (редактируемую) вершину кривой с предыдущей вершиной кривой.


Диалог создания и редактирования ссылки

Этот диалог появляется на экране после вызова команды Вставить ссылку или Редактировать ссылку....

Элементы управления диалога позволяют создавать и редактировать ссылки.

Описание элементов управления

Наименование

Описание

Тип источника

Список, позволяющий выбрать тип объекта — источника ссылки.

Ссылка на

Список, позволяющий указать, что будет являться содержимым ссылки.

Особенности ссылок на некоторые типы объектов...

Список источников

Список, в котором отображаются тексты всех имеющихся в документе источников выбранного типа.

Источники приведены в списке подряд. Источник, содержащий несколько строк текста или несколько полок, на которые возможно сделать ссылки, отображается в списке следующим образом: первая строка — без отступа, подобно источнику с одной строкой, а вторая и последующие строки имеют отступ слева.

Чтобы указать нужный источник, выделите его текст в списке. Выбранный источник выделяется также в окне графического документа.

Пункты технических требований не выделяются в чертеже при выделении их в списке источников.

В скобках

Включите эту опцию, чтобы заключить содержимое ссылки в скобки.

Количество знаков после запятой

Список появляется в диалоге, если источником ссылки является Переменная, и заменяет собой опцию В скобках.

Список становится доступен, если в списке Ссылка на: выбран вариант Значение или Имя = значение.

Список позволяет указать количество знаков после запятой, отображающихся в числовом значении ссылки на переменную.

Значение переменной округляется до указанного знака.

Если выбран 0, то в ссылке отображается округленное целое число.

По умолчанию количество знаков после запятой равно заданному в диалоге настройки представления чисел. Максимальное количество знаков — 6.

Угловые величины в ссылках на переменную представляются в десятичной системе счисления.

Просмотр

В этом поле отображается создаваемая ссылка в том виде, в каком она будет вставлена в текст.

Если формирование ссылки с заданными параметрами невозможно (например, при попытке создать ссылку на текст под полкой линии-выноски, которая содержит только текст над полкой), то поле Просмотр пусто, а кнопка ОК недоступна.

Чтобы завершить создание или изменение ссылки, нажмите кнопку ОК. Для выхода из диалога без изменений нажмите кнопку Отмена.


Листовое тело

Листовое тело — тело, полученное в результате операции Листовое тело или Обечайка. К листовому телу применимы другие листовые операции.


Переменные листового тела


Связная совокупность граней

Связная совокупность граней — множество граней, каждая из которых имеет общее ребро хотя бы еще с одной гранью этого множества, причем одно ребро одновременно принадлежит не более чем двум граням.


Связная совокупность кривых

Связная совокупность кривых (цепочка кривых) — множество кривых, каждая из которых имеет общую вершину хотя бы еще с одной кривой этого множества, причем одна вершина одновременно принадлежит не более чем двум кривым.


Диалог редактирования знака неуказанной шероховатости

Этот диалог появляется на экране после вызова команды Вставка — Неуказанная шероховатость — Ввод....

В нем можно ввести или отредактировать обозначение шероховатости неуказанных поверхностей (знак неуказанной шероховатости) на чертеже.

Описание элементов управления
Элемент | Описание
Тип знака | Группа переключателей, позволяющая выбрать нужный тип знака шероховатости.
Добавить знак в скобках | Включите эту опцию, если требуется отрисовывать знак в скобках.
Текст | В этом поле можно выбрать из меню значений или ввести вручную текст надписи для знака шероховатости.
Расстояние до знака | В этом поле можно ввести значение вертикального расстояния от текста надписи до знака шероховатости. Данное поле присутствует в диалоге, если при настройке обозначений шероховатости было выбрано соответствие предыдущей редакции ГОСТ2.309-73.

Для завершения диалога нажмите кнопку ОК. Если не требуется сохранять сделанные изменения, нажмите кнопку Отмена. Для удаления обозначения неуказанной шероховатости из чертежа нажмите кнопку Удалить.


Способы пересчета размеров модели

Буквами в формулах обозначены:

A — пересчитанное значение размера (эскиза или операции);

N — номинальное значение размера,

ES — верхнее отклонение,

EI — нижнее отклонение.

Способы пересчета размеров модели
Способ пересчета размера | Формула пересчета размера, соответствующая способу пересчета
в середину поля допуска1 | A=N+(ES+EI)*0,5
по верхнему пределу | A=N+ES
по нижнему пределу | A=N+EI
с коэффициентом2 | A=N+EI+(ES-EI)*K, где 0<K<1
  1. В пользовательском пересчете используется по умолчанию.
  2. Используется только для переменных в пользовательских пересчетах (кроме переменных компонента).


Эскиз не может использовать собственную информационную переменную, кроме переменных, присвоенных размерам спроецированных объектов

Эскиз не может использовать собственную информационную переменную,
кроме переменных, присвоенных размерам спроецированных объектов

Это сообщение появляется, если для вычисления значения входной переменной эскиза используется его же информационная переменная.

Уравнение, связывающее переменную эскиза с его же информационной переменной, приведено в диалоге Что не верно? и выделено красным цветом в Окне переменных.

Как исправить эту ошибку

– Отредактируйте выражение для вычисления переменной эскиза так, чтобы оно не содержало его же информационную переменную.

– Или, если возможно, сделайте информационную переменную эскиза обычной. Для этого необходимо зафиксировать размер, которому она присвоена.


Недопустимое значение аргумента для sqrt, tan или tand, ln или log, тригонометрической функции

Недопустимое значение аргумента для
sqrt, tan или tand, ln или log, тригонометрической функции

Это предупреждение появляется, если переменная аргумента функции принимает такое значение, при котором функция не определена. Например, функция sqrt не определена при отрицательных значениях аргумента; функции ln и log не определены при нулевых и отрицательных значениях аргумента.

Уравнение, содержащее функцию с недопустимым значением аргумента, приведено в диалоге Что не верно? и выделено красным цветом в Окне переменных.

Как исправить эту ошибку

– Отредактируйте значение переменной аргумента (или выражение для ее вычисления) так, чтобы функция имела смысл.

– Или отредактируйте выражение, содержащее функцию, изменив переменную, которая определяет аргумент.


Деление на нуль

Это предупреждение появляется, если переменная, определяющая знаменатель дроби, принимает нулевое значение.

Уравнение, содержащее дробь с нулевым знаменателем, приведено в диалоге Что не верно? и выделено красным цветом в Окне переменных.

Как исправить эту ошибку

– Отредактируйте значение переменной (или выражение для его вычисления), определяющей знаменатель дроби так, чтобы эта значение было отличным от нуля.

– Или отредактируйте выражение, содержащее дробь, изменив переменную, которая определяет знаменатель.


Surfaces_h

Surfaces_h


Основание уклона

Основание уклона — плоская грань детали, форма, размеры и угол наклона которой не изменятся после выполнения команды Уклон.

Основание уклона может быть только одно.


Уклоняемые грани

Уклоняемые грани — грани, угол наклона которых по отношению к основанию изменится в результате выполнения команды Уклон.

Уклоняемых граней может быть несколько. Для корректного выполнения команды уклоняемые грани должны быть смежны с основанием; между собой они могут быть не смежны.


Точечный объект для построения кривой(сплайна на поверхности или изопараметрической кривой)

Точечный объект для построения кривой
(сплайна на поверхности или изопараметрической кривой)

Для построения кривой могут использоваться следующие точечные объекты:

– Вершина объекта (или точка в пространстве) при условии, что этот объект (или точка) является непосредственно исходным или непосредственно производным по отношению к объекту, содержащему указанную грань (т.е. в иерархии отношений между объектом, содержащим вершину (или точку), и объектом, содержащим указанную грань, не должно быть других объектов).

– Вершина ребра грани.

Обратите внимание на то, что вершина объекта или точка, используемая для построения кривой, должна лежать на указанной грани и находиться в пределах ее контура.

Подробнее о просмотре отношений объектов...

Общие сведения о теоретической поверхности грани и изопараметрических кривых...

Изопараметрическая кривая...

Сплайн на поверхности...


Указание точки дуги

Точки дуги можно указать следующими способами:

– указать положение мышью в окне модели: координаты точки определяются автоматически и заносятся в поля X, Y, Z;

– связать с уже имеющимся точечным объектом: включить опцию Ассоциировать и указать в модели точечный объект;

– построить, нажав кнопку Построение точки на Панели специального управления;

– задать координаты в пространстве.


Указание точек параллелепипеда

Точку параллелепипеда можно указать следующими способами:

– указать положение мышью в окне модели: координаты вершины определяются автоматически и заносятся в поля X, Y, Z;

– задать координаты в пространстве

– связать с уже имеющимся точечным объектом: включить опцию Ассоциировать и указать в модели точечный объект;

– построить, нажав кнопку Построение точки на Панели специального управления.


Указание вершины отрезка

Вершину отрезка можно указать следующими способами:

– задать координаты в пространстве (координаты задаются относительно системы координат отрезка);

– указать положение мышью в окне модели: координаты точки определяются автоматически и заносятся в поля X, Y, Z;

– связать с уже имеющимся точечным объектом: включить опцию Ассоциировать и указать в модели точечный объект.

– построить, нажав кнопку Построение точки на Панели специального управления.


Пересчет размеров компонента

При редактировании свойств компонента можно пересчитать размеры, используя назначенные допуски. Расчет размеров вставленной модели производится согласно текущему пересчету.

КОМПАС-3D предоставляет три системных пересчета размеров: в середину поля допуска, по верхнему пределу и по нижнему пределу. Вставленная модель также может иметь пользовательские пересчеты, созданные при ее редактировании. Подробнее о пересчетах...

Для пересчета размеров используются элементы управления вкладки Файл-источник.

Чтобы изменить размеры согласно требуемому пересчету, нажмите кнопку Пересчитать размеры. Становится доступен список пересчетов. Выберите из списка нужный пересчет — системный или пользовательский.


Переменная размера

Переменная размера — переменная, созданная пользователем в процессе создания размера в графическом документе или эскизе. Значением переменной является значение соответствующего размера. Если размер, для которого создана переменная, фиксированный, то переменную можно использовать для управления значением размера. Если размер является информационным, то управлять его значением через переменную нельзя.


Переменная параметра операции

Переменная параметра операции — переменная, созданная автоматически в процессе задания числового параметра операции в модели. Значением переменной является значение соответствующего параметра. Переменные данного вида можно использовать для управления значениями параметров операций.


Versions_layers_H

Versions_layers_H

---------------------Viewer-------------------------


Указание группы объектов секущим отрезком

Чтобы указать группу объектов секущим отрезком, выполните следующие действия.

1. Установите курсор в первую точку секущего отрезка.

2. Нажмите левую кнопку мыши и перемещайте курсор ко второй точке отрезка, удерживая кнопку нажатой. При перемещении курсора формируется секущий отрезок. Он отображается пунктиром. Объекты, которые пересекает отрезок, подсвечиваются.

3. Отпустите кнопку, когда отрезок пересечет все нужные объекты.

На рисунке приведен пример указания группы объектов для выравнивания по указанной границе.

Указание группы объектов секущим отрезком для выравнивания по указанной границе: а) исходное изображение, б) указание объектов с помощью секущего отрезка, в) результат выравнивания
а) | б) | в)


Вызов диалога Назначить допуск при работе с моделью

При работе с моделью диалог Назначить допуск появляется на экране после:

– нажатия кнопки Назначить допуск, расположенной на Панели свойств рядом с полем числового параметра операции при выполнении операции;

Кнопка Назначить допуск присутствует на Панели свойств, если в диалоге настройки параметров отображения Панели свойств включена опция Кнопки управления допусками.

– нажатия кнопки Назначить допуск в диалоге установки значения размера при редактировании размеров эскиза и операции.

Смотрите также

Допуски


Вызов диалога Назначить допуск при работе в Окне переменных

При работе в Окне переменных (модели или графического документа) диалог Назначить допуск появляется после:

– двойного щелчка мышью в ячейке столбца Допуск, соответствующей переменной параметра операции или переменной размера (отображение столбца Допуск настраивается);

– вызова команды Назначить допуск контекстного меню имени переменной параметра операции;

– вызова команды Сервис — Назначить допуск меню Окна переменных.

Назначение допусков в Окне переменных...


Окно модели-источника

Окно модели-источника содержит изображение модели, которая является источником компонента или объектов для копирования. Используется для выбора объектов этой модели.

Данное окно содержит саму модель-источник и Дерево ее построения. В Дереве построения отображаются следующие объекты:

– системы координат,

– вспомогательная геометрия,

– элементы оформления (недоступны для копирования),

– кривые и точки,

– эскизы,

– тела, построенные непосредственно в модели-источнике,

– объекты «измерение» (недоступны для копирования).

Указание объектов в данном окне выполняется обычным образом — объекты указываются мышью в Дереве или в самом окне.

Вы можете переместить Окно модели-источника, «перетащив» его мышью за заголовок. Можно также изменить размер окна, «перетаскивая» мышью его границы. Перемещение и изменение размера окна возможны только в пределах окна текущей модели.

Тип отображения объектов в окне (каркасное, полутоновое и т.п.) соответствует выбранному в окне текущей модели.

При необходимости вы можете изменить масштаб отображения объектов в окне с помощью команд Показать все и Текущий масштаб.

Можно также управлять отображением объектов в окне с помощью команды Вид — Скрыть.

Кроме того, вы можете повернуть модель, отображающуюся в окне, при помощи клавиатурных комбинаций и при помощи мыши.

Окно модели-источника используется для выбора объектов при выполнении следующих операций.

– Размещение компонента в модели способом По сопряжениям при добавлении компонента в модель или изменении его положения.

При редактировании детали-заготовки, вставленной без истории, окно модели-источника не отображается.

– Создание копии геометрических объектов модели из файла.

– Создание зеркального отражения компонента способом Симметричное расположение компонента при ручном указании объекта симметрии,

– Изменение положения компонента зеркального исполнения при симметричном размещении компонента и ручном указании объекта симметрии.


Задание на печать

Задание на печать — файл с расширением pjd, в который записываются номера и размеры листов, а также имена файлов документов, выбранных для печати, настройки их размещения на поле вывода, настройки параметров вывода и данные об устройстве вывода.

Файл задания имеет текстовый формат, поэтому он может быть открыт и отредактирован любым текстовым редактором, например, Блокнотом, входящим в состав Windows.


Список заданий на печать

Список заданий на печать отображается:

– в главном окне — в меню Файл — Задание на печать и в меню кнопки Загрузить задание на печать, расположенной на Стандартной панели,

– в режиме предварительного просмотра — в меню Файл.

Фактически это перечень файлов заданий, которые сохранялись или загружались в последнее время.

Чтобы загрузить одно из заданий, выберите его имя из списка.

При загрузке из главного окна программы происходит автоматический переход в режим предварительного просмотра, в котором отображаются листы документов задания.

При загрузке из окна предварительного просмотра на экране появляется диалог выбора варианта добавления листов документов. Для продолжения загрузки выберите один из предлагаемых в диалоге вариантов добавления листов. Для прекращения загрузки нажмите кнопку Отмена.

Количество заданий на печать, имена которых хранятся в списке, можно задать в диалоге общих настроек печати. По умолчанию список содержит девять последних сохраненных или загруженных заданий.

Смотрите также

Команда Сохранить задание на печать...

Команда Загрузить задание на печать...


Некоторые особенности экспорта файлов КОМПАС-3D в формат DXF/DWG

При передаче информации из одной графической системы в другую (конвертировании файлов из одного формата в другой) может возникнуть ситуация, когда целевой формат не поддерживает объекты или параметры объектов, записанные в исходном формате.

Иногда такие объекты можно превратить в похожие объекты целевого формата таким образом, чтобы их изображение сохранилось без изменений. Например, линейный размер КОМПАС превращается в размер формата DXF/DWG; при этом изображение размера не изменяется, но все части размерной надписи («текст до», символ и т.д.) объединяются в единый текст.

Если не удается реализовать такой способ конвертации, объект разбивают на графические объекты (отрезки, дуги, тексты); после преобразования в целевой формат их объединяют в его составной объект (в формате DXF/DWG таким объектом является блок). В результате исходный объект утрачивает информацию о своем типе (а следовательно, уже не может редактироваться характерным для этого типа образом), но его начертание сохраняется. Примером объектов чертежно-графического редактора системы КОМПАС-3D, экспортируемых в DXF/DWG описанным способом, могут служить обозначения шероховатости, базы и допуска, разнообразные линии-выноски, контур, вставка фрагмента, технические требования, таблица, эквидистанта.


Дерево чертежа

Дерево чертежа — структурированный список («дерево»), отражающий виды чертежа и их состав (макроэлементы, вставки видов и фрагментов, для ассоциативных видов — объекты моделей).


Библиотека моделей

Каждая библиотека моделей представляет собой отдельный файл с расширением l3d. Модели библиотеки не являются отдельными файлами на диске, а входят составными частями в единый файл библиотеки. Модели хранятся в виде упорядоченных списков в подразделах и корневом разделе библиотеки. Имена моделей и разделов библиотеки могут состоять из любых символов, количество моделей и разделов не ограничено.

При создании раздела библиотеки или добавлении модели можно ввести комментарий. Комментарий может быть многострочным и иметь произвольную форму. Допускается многократное редактирование комментария.


Внешняя переменная модели

Внешняя переменная модели — переменная в модели, значение которой доступно и может быть изменено в другой модели, содержащей данную в качестве компонента. Основное назначение внешних переменных — управление размерами и топологией модели во время и после вставки ее в другую модель.

Формирование переменных и присвоение им статусов «внешняя» и «информационная» производится при создании модели.

Внешней переменной может быть только пользовательская переменная, т.е. переменная главного раздела.

Признаком внешней переменной является синий или зеленый (если она также является информационной) цвет ячейки с именем переменной в таблице Окна переменных.

Внешняя информационная переменная видна, но не доступна для изменения в модели, содержащей компонент.


Чтение блоков

В документе AutoCAD в блок могут быть объединены объекты, лежащие на разных слоях. В то же время сам блок принадлежит какому-либо из слоев документа. Отображение блока в документе AutoCAD зависит от состояния его слоя.

Если слой блока заморожен, то ни один из входящих в блок объектов не отображается в документе (даже если слои, содержащие объекты, видимы). В остальных случаях (слой блока включен или отключен) в документе отображаются только те из входящих в блок объектов, которые лежат на видимых слоях.

Так как в КОМПАС-3D нет объектов, идентичных блокам AutoCAD, при импорте блоков входящие в них объекты объединяются в макроэлементы.

В зависимости от того, что требуется получить при импорте, выберите один из трех возможных вариантов импорта блока:

– Однослойный макрообъект — все объекты, составляющие блок, переносятся на слой блока (в том числе объекты вложенных блоков, если такие есть) и объединяются в макроэлемент. Состояния слоев корректно распознаются при импорте, поэтому, если слой блока был выключен или заморожен, то все его объекты будут невидимы, а если слой блока был видимый, то все его объекты будут видны. Этот вариант оптимален для документов, содержащих блоки на выключенных или замороженных слоях.

– Многослойный макрообъект — объекты, составляющие блок, объединяются в макроэлемент, оставаясь на своих слоях. Состояние слоя блока не учитывается, и видимость каждого объекта зависит от состояния слоя, содержащего этот объект. Этот вариант оптимален для документов, содержащих блоки на видимых слоях.

– Вставка фрагмента — блок преобразуется в локальный фрагмент. Этот фрагмент содержит столько слоев, сколько в исходном блоке. Состояние слоя блока учитывается, поэтому, если слой блока был выключен или заморожен, то все его объекты будут невидимы, а если слой блока был видимый, то все его объекты будут видны. Если исходный документ содержит несколько вставок одного блока, то в результирующем документе формируется соответствующее количество вставок локального фрагмента. Этот вариант импорта блока оптимален для случаев, когда в исходном документе имеются множественные вставки одного или нескольких блоков. Кроме того, при использовании этого варианта размер получаемого КОМПАС-документа существенно меньше, чем при использовании других вариантов.


Чтение линий-выносок, штриховок, допусков формы, мультилиний и размеров

При настройке чтения линий-выносок, штриховок, допусков формы, мультилиний и размеров доступны следующие варианты:

– Обычный — объект AutoCAD преобразуется в аналогичный объект КОМПАС. Для выбора этого варианта укажите объект КОМПАС, соответствующий объекту AutoCAD. Например, для линии-выноски AutoCAD выберите линию-выноску КОМПАС.

– Макроэлемент — объект AutoCAD преобразуется в макроэлемент КОМПАС, состоящий из графических объектов (отрезков, точек и текстов). При этом теряется информация о типе объекта, т.е. макроэлементы лишь «имитируют» соответствующие объекты оформления.

Размеры хранятся в файле DXF/DWG в двух видах: в виде размерной структуры (координаты линий выносок, размерной линии, текста и т.д.) и в виде блока изображения размера (набор отрезков, заливок, точек и текстов). Поэтому для объекта «размер» доступен еще один вариант чтения — комбинированный объект. При его выборе геометрические объекты, из которых состоят размеры, будут считаны из размерных структур файла DXF/DWG, а тексты — из блоков изображений размеров. Тип объекта — «размер» — сохраняется.

В исходном файле могут находиться ошибочные штриховки и/или размеры. Их чтение возможно только определенным способом:

– если контур штриховки некорректен (например, вырожден), то она импортируется как макроэлемент,

– если габариты размерной структуры и блока изображения размера не совпадают, то размер импортируется как макроэлемент,

– если номинальные значения в размерной структуре и в блоке изображения размера не совпадают, то размер импортируется как комбинированный объект.

Смотрите также

Особенности чтения размеров и линий-выносок


Чтение растровых объектов

Растровые объекты в документах AutoCAD хранятся в виде ссылок на внешние файлы. В графических КОМПАС-документах возможен еще один вариант — хранение изображения непосредственно в файле документа.

При настройке импорта документа формата DXF или DWG можно выбрать вариант чтения имеющихся в нем растровых объектов:

– Взять в документ — растровый объект будет храниться внутри графического КОМПАС-документа. Вставка этого типа отображается в КОМПАС-документе корректно вне зависимости от наличия на диске ее файла-источника.

– Внешней ссылкой — растровый объект будет храниться в КОМПАС-документе в виде ссылки на внешний файл (источник вставки). КОМПАС-документ, содержащий такую ссылку, будет открываться корректно, если файл-источник действительно находится по пути, записанному в ссылке. В противном случае при открытии КОМПАС-документа на экране появится диалог с сообщением о том, что файл-источник не прочитан. Кнопки диалога позволяют указать другой файл в качестве источника, удалить ссылку или отказаться от чтения документа.
При передаче на другое рабочее место КОМПАС-документа, содержащего ссылку на внешний файл, убедитесь, что записанный в ссылке путь к файлу актуален для этого рабочего места. В противном случае передавайте КОМПАС-документ вместе с файлом-источником вставки.


Запрет редактирования объекта

Запрет редактирования объекта — признак объекта, показывающий, наложены ли ограничения на редактирование этого объекта.

Наложение/снятие запрета редактирования объекта осуществляется с помощью команд Редактирование — Запрещено или Редактирование — Разрешено в контекстном меню.

– При работе с объектом, доступным для редактирования, возможно его изменение любым доступным способом. Никаким специальным значком в Дереве построения модели такой объект не отмечается.

– При работе с объектом, имеющим запрет на редактирование, действуют различного рода ограничения, основными из которых являются невозможность редактирования и невозможность удаления из модели. Объекты с запретом редактирования отмечаются в Дереве построения модели значком «щит».

При работе со сборкой информация о запрете редактирования компонентов записывается в тип загрузки сборки и может быть вместе с ним защищена паролем (подробнее см. раздел 2.12.2.3).


Абсолютная система координат

Абсолютная система координат — Система координат, автоматически создаваемая в графических документах и документах-моделях. Абсолютную систему координат документа невозможно отредактировать или удалить.


Активное окно

Активное окно — окно, в котором ведется работа в текущий момент времени. В этом окне отображается активный документ.

Заголовок активного в настоящий момент окна подсвечен.


Связь между заголовком блока разделов и КОМПАС-документом

Документ для связи выбирается при настройке документа-спецификации. Обозначение указанного документа подставляется в заголовок блока вместо конструкции #XXX#, введенной в заголовок блока при его создании.

Обычно конструкция #XXX# используется при создании блока дополнительных разделов с одним из следующих заголовков:

– «Устанавливают по #XXX# МЭ» или

– «Устанавливают по #XXX# ТБ».

В качестве документа для связи с заголовком блока в этом случае выбирается электромонтажный чертеж или таблица соединений соответственно.


Дополнительные разделы спецификации

Дополнительные разделы спецификации располагаются в конце спецификации, после всех ее разделов. Обычно дополнительные разделы размещают, начиная с нового листа.

Группы дополнительных разделов называются блоками дополнительных разделов (подробнее см. раздел 6.1.2.1.1).


Допустимый диапазон значений переменных

Допустимый диапазон значений переменных определяется тем параметром, которому эта переменная соответствует: например, значения переменной, поставленной в соответствие параметру Порядок сплайна, должны лежать в диапазоне от 2 до 10.


Команды Инструментальной панели Окна переменных

Инструментальная панель Окна переменных содержит кнопки вызова следующих команд:

Меню

Удалить

Вставить функцию

Вставить константу

Переместить вверх

Переместить вниз

Вставить ссылку

Использование переменной

Уравнения

Таблица переменных

Удалить таблицу переменных

Большинство команд может быть вызвано также из контекстного меню Окна переменных.


Меню Окна переменных

Меню содержит команды работы с переменными и выражениями в Окне переменных. Для вызова меню используется кнопка Меню на инструментальной панели этого окна.


Инструментальная панель Окна переменных

Эта панель расположена в верхней части Окна Переменных.

Инструментальная панель содержит кнопки быстрого вызова команд работы с переменными.


Прикладная библиотека

Библиотека — это приложение, созданное для расширения стандартных возможностей КОМПАС и работающее в его среде.

Прикладная библиотека может быть создана в одной из стандартных сред программирования для Windows (Borland C++, Microsoft Visual C++, Borland Pascal и т.д.) с использованием функций специального комплекта разработки приложений КОМПАС-МАСТЕР. По своей архитектуре библиотека является стандартным динамически подключаемым модулем (DLL) Windows. По умолчанию файлы библиотек имеют расширения DLL или RTW.

В прикладных библиотеках через языковые средства могут использоваться все возможности КОМПАС, предоставляемые при интерактивной работе (создание и редактирование объектов, работа с моделью документа, открытие и сохранение чертежей и фрагментов и т.д.)


Редактирование условий фильтрации строк

Редактирование условий возможно, если при выполнении команды была нажата кнопка Запомнить условия фильтрации на Панели специального управления.

В этом случае после вызова команды Применить фильтр на Панели свойств отображаются условия, которые были запомнены. Вы можете изменить условия, а затем произвести фильтрацию повторно.

Чтобы изменить условие фильтрации, выделите его на панели Условия фильтрации и выполните необходимые действия — удалите или отредактируйте условие.

Вы можете отменить результат предыдущей фильтрации. Для этого задайте условие и включите опцию Удалить предыдущие на Панели свойств.

Чтобы выполнить фильтрацию, нажмите кнопку Создать объект на Панели специального управления.


Область применения операции

Область применения операции — набор объектов, которые модифицируются в результате операции.

– Если операция добавляет материал, то в область ее применения входят тела и/или компоненты, с которыми объединяется результат операции. Эти тела и/или компоненты вместе с добавленным элементом образуют новое тело.

– Если операция удаляет материал, то в область ее применения входят тела и/или компоненты, объем которых уменьшается в результате операции.


Обход по стрелке

Обход по стрелке — способ задания границы области или осевой линии эквидистанты, при котором граница или ось последовательно набираются из смежных участков пересекающихся кривых.


Команды редактирования сборочных операций

Кнопки вызова команд редактирования сборочных операций расположены на панели Редактирование сборки.

Создать сборку

Создать деталь

Создать локальную деталь

Создать компоновочную геометрию

Добавить компонент из файла

Добавить локальную деталь из файла

Добавить компоновочную геометрию

Переместить компонент

Повернуть компонент


Сборка

Сборка — вид трехмерной модели, предназначенный для представления изделий, изготавливаемых с применением сборочных операций. Создается и хранится в документе «Сборка», расширение файла — a3d.


Выбор направления обхода и перемещение по контуру при помощи клавиш

Клавиатурные комбинации для выбора направления обхода
Клавиша | Описание действия
<Пробел> | Перебор возможных направлений обхода от текущего узла против часовой стрелки.
<Shift>+<Пробел> | Перебор возможных направлений обхода от текущего узла по часовой стрелке.
<Enter> | Подтверждение выбора направления, отмеченного стрелкой.
<Shift>+<Enter> | Возврат на один шаг назад.


Ассоциативный отчет

Ассоциативный отчет — отчет, ассоциативно связанный с документом, по которому он получен. При изменении объектов или их свойств, а также состава документа-источника изменяются и данные во всех связанных с ним отчетах.

Ассоциативный отчет размещается в графическом документе.


Ассоциативный вид

Ассоциативный вид — вид чертежа, ассоциативно связанный с существующей моделью (деталью или сборкой). При изменении формы, размеров и топологии модели изменяется и изображение во всех связанных с ней видах.


Ассоциативность (ассоциативная связь)

Ассоциативность (ассоциативная связь) — однонаправленная зависимость расположения или геометрии одного объекта от расположения или геометрии другого объекта.


Ассоциативная штриховка (заливка)

Ассоциативная штриховка (заливка) — штриховка (заливка), границы которой совпадают с конкретными линейными объектами (или их частями). При изменении положения этих объектов граница штриховки (заливки) автоматически перемещается вместе с ними.


Подключение библиотеки

Прежде чем функции какой-либо прикладной библиотеки можно будет использовать при работе, необходимо подключить эту библиотеку к системе.

Для подключения библиотеки к КОМПАС-3D выполните следующие действия.

1. Вызовите команду Сервис — Менеджер библиотек.

На экране появится окно Менеджера библиотек.

2. В списке библиотек (он находится в правой части первой вкладки) выделите имя нужной библиотеки и вызовите команду Подключить из контекстного меню.

Для быстрого подключения выбранной библиотеки можно щелкнуть мышью в поле рядом с ее названием.

Выбранная библиотека подключается в установленном для нее режиме: меню, окно, диалог или панель. В поле рядом с названием библиотеки появляется красная «галочка» — признак того, что библиотека подключена.

Названия всех подключенных к системе прикладных библиотек отображаются как команды в меню Библиотеки.

К системе КОМПАС-3D одновременно может быть подключено не более 25 библиотек.

Смотрите также

Изменение режима работы с библиотекой


Атрибут

Атрибут — это дополнительная неграфическая информация, связанная с объектом или несколькими объектами документа. Такая информация может быть представлена в виде числа, строки текста, а также таблицы с фиксированным или переменным числом строк.

Типы (описания структуры) атрибутов могут храниться как непосредственно в документе, так и в специальных файлах (библиотеках типов атрибутов). Эти файлы имеют расширение lat.

В дальнейшем значения атрибутов могут обрабатываться различными приложениями (например, Модулем проектирования спецификаций, различными расчетными программами и т.п.). В чертежах и фрагментах возможен также поиск по значениям атрибутов (см. раздел 11.5.3.5).


Автоматическое создание разрыва в ассоциативном виде

В видах, полученных с помощью команд Проекционный вид, Разрез/сечение, Вид по стрелке, могут автоматически создаваться разрывы. Для этого необходимо выполнение следующих условий:

– в опорном виде создан разрыв при помощи команды Разрыв вида,

– направление проецирования перпендикулярно направлению сдвига изображения в опорном виде.

Вид по стрелке, созданный на основе вида с разрывом

Если вышеперечисленные условия не выполняются, то вид создается без разрыва. При необходимости его можно построить вручную.

Параметры разрывов передаются в вид при его создании. Дальнейшая связь между разрывами в опорном и созданном видах не поддерживается.

Чтобы изменить параметры или удалить автоматически созданный разрыв, можно использовать команду Разрыв вида или Параметры разрыва, чтобы показать или скрыть разрыв — команду Показать разрывы.

Особенности работы с разрывами изображений...


Сокращение времени работы команд по созданию/удалению объектов спецификации

Время, требующееся для выполнения команд Создать объекты спецификации... и Удалить объекты спецификации..., может быть значительным, поскольку производится открытие, редактирование и сохранение моделей. В общем случае время выполнения команды зависит от:

– насыщенности сборки и сложности ее компонентов,

– производительности компьютера,

– размещения файлов сборки и компонентов: на диске того же компьютера, где запущен КОМПАС-3D и вызвана команда Создать объекты спецификации... или Удалить объекты спецификации... (в этом случае команда выполняется быстрее всего), или на сетевых дисках.

В целях экономии времени рекомендуется использовать указанные команды не всякий раз после добавления очередного компонента, а на завершающем этапе работы со сборкой — после того, как в нее будут включены все необходимые компоненты.


Опорный вид

Опорный вид — ассоциативный вид чертежа, использующийся при создании другого вида.

Так, для проекционных видов опорным может являться, например, главный вид, для разреза/сечения — вид, в котором располагается обозначение секущей плоскости и т.п.


Уменьшение сгиба

Уменьшение сгиба — параметр BD в формуле определения длины развертки цилиндрической части сгиба:

l = 2•a-BD.

Подробнее об определении длины развертки способом задания уменьшения сгиба см. раздел 2.4.1.4.3.


Таблица сгибов

Таблица сгибов — таблица, содержащая значения параметра развертки сгиба, соответствующие различным толщинам материала, углам и радиусам сгиба.


Определение длины развертки после удаления таблицы сгибов

Например, элемент был построен с использованием таблицы величин сгибов. После удаления таблицы для этого элемента будет выбран способ определения длины развертки Величина сгиба. Значение величины сгиба останется равным выбранному ранее из таблицы.


Параметр развертки сгиба

Параметр развертки сгиба — параметр сгиба, определяющий длину его развертки. В зависимости от выбранного способа определения длины развертки таким параметром является коэффициент нейтрального слоя, или величина сгиба, или уменьшение сгиба.


Величина сгиба

Величина сгиба — явно заданное значение длины развертки цилиндрической части сгиба.

Подробнее об определении длины развертки способом задания величины сгиба см. раздел 2.4.1.4.2.


Кривая Безье

В КОМПАС-3D под кривой Безье понимается кривая, состоящая из гладко состыкованных участков, описанных полиномами четвертого порядка, каждый из которых построен по четырем опорным точкам. Крайние из этих четырех точек задаются пользователем, а средние вычисляются, исходя из условия непрерывности производной кривой, и лежат на векторе производной. Пользователь может отредактировать положение любой опорной точки.


Цвет изображения Черный

Выбор этого варианта означает, что все цветные оттенки будут записаны оттенками серого цвета.


Параметры разрыва, ограниченного линиями с изломом или волнистыми линиями

При задании параметров для отображения разрыва, ограниченного линиями с изломом или волнистыми линиями, необходимо учитывать следующее.

– Для линий с изломом зазор не может быть меньше двух амплитуд. Минимальное значение амплитуды — 2.5 мм.

Задайте значения в поля Амплитуда, max и Зазор в миллиметрах. Если значение зазора недостаточно, то при построении оно будет увеличено автоматически до величины, равной двум амплитудам.

– Для волнистых линий зазор не связан с амплитудой. Минимальное значение зазора — 1 мм. Задайте значение в поле Зазор.

Задайте значения амплитуды:

• в поле Амплитуда,% — амплитуду в процентах от длины разрыва (абсолютное значение амплитуды рассчитывается системой в процессе построения);

• в поле Амплитуда, мах — максимально допустимую амплитуду в миллиметрах.

Для построения используется меньшее из значений амплитуды — рассчитанное как процент от длины разрыва или заданное в поле Амплитуда, мах. Подробнее...

Умолчательные параметры зазора и амплитуды задаются в диалоге настройки параметров линии разрыва.

При установке границ следует учитывать, что расстояние между границами разрыва (см. рисунок) не может быть меньше удвоенного значения амплитуды.

Если это расстояние недостаточно, на экране появляется сообщение об этом. Чтобы построить разрыв, раздвиньте границы или уменьшите амплитуду.


Измерение с использованием направляющего объекта

Чтобы измерение было выполнено указанным способом, следует нажать переключатель По направляющему объекту.

Укажите в окне документа-модели поверхность, от которой будут измеряться расстояния. Наименование объекта появится в поле Поверхность 1.

Укажите вторую поверхность. Наименование объекта появится в поле Поверхность 2.

Координатная или вспомогательная плоскость может быть выбрана только в качестве второй поверхности.

Укажите направляющий объект. В качестве направляющих могут быть указаны следующие объекты:

– Прямолинейные: ось, отрезок, прямое ребро, сегмент ломаной линии. При выборе прямолинейного объекта измерения будут выполняться параллельно ему.

– Плоские: плоская грань, координатная или вспомогательная плоскость. При выборе плоского объекта измерения будут выполняться перпендикулярно ему.

Выбор объектов в окне модели

Если нужного направляющего объекта в модели нет, то вы можете построить вектор, задающий направление измерения. Для этого нажмите кнопку Построение вектора на Панели специального управления.


Настройка формата ячейки. Замечание

При настройке формата ячейки следует иметь в виду следующие особенности.

1. Если в диалоге настройки формата ячейки включена опция Однострочный текст, то варианты Форматирование строк, Перенос нижней границы и Изменение шага строк становятся недоступны.

2. Если в качестве стиля текста по умолчанию выбран стиль, содержащий настройку расширенного стиля, то вариант Форматирование строк становится недоступен. Если он был выбран, то вместо него автоматически выбирается вариант Изменение сужения текста.

3. Если при настройке блокировки таблицы включена опция Зафиксировать габариты ячеек, то варианты Перенос правой границы и Перенос нижней границы становятся недоступны. Кроме того, становятся недоступны поля Ширина столбца, Высота строки и поля ввода отступов.

4. При выборе варианта Перенос правой границы становится недоступно поле Ширина столбца, а при выборе варианта Перенос нижней границы — поле Высота строки.


Осевая линия

Осевая линия — графический объект, предназначенный для простановки осевых линий. Особенностью осевой линии является то, что она не заканчивается в своих характерных точках, а выступает за них на определенное расстояние.


Обозначение центра

Обозначение центра — графический объект, предназначенный для простановки осевых линий осесимметричных объектов: окружностей, дуг окружностей, эллипсов, дуг эллипсов, прямоугольников и многоугольников. Стиль линии обозначения центра — осевая.


Центральная система координат

Центральная система координат — система координат, начало которой совпадает с центром масс модели и оси которой параллельны осям абсолютной системы координат.


Направление первой стороны фаски

Направление первой стороны фаски показывается фантомной стрелкой в окне модели.

Если фаска строится по стороне и углу, то стрелка указывает направление, в котором будет отложена указанная длина стороны фаски; относительно этого же направления будет откладываться указанный угол.

Если фаска строится по двум сторонам, то стрелка указывает направление, в котором будет откладываться сторона фаски с длиной, заданной в поле Длина 1.

Если стороны фаски равны, то результат ее построения не будет зависеть от направления первой стороны.


Выбор формы отверстия и задание его размеров

Для указания нужного отверстия и настройки его параметров служит панель Выбор отверстия на вкладке Параметры Панели свойств.

Панель выбора отверстия разделена на несколько областей. В первой из них содержится структура библиотеки отверстий («дерево» разделов), во второй — перечень элементов выбранного раздела. Команды контекстного меню первой и второй области позволяют управлять представлением их элементов, а также отображением областей комментария и просмотра.

Область комментария к выбранному типу отверстия содержит качественное описание его формы.

В области просмотра показывается эскиз профиля отверстия и размеры, управляющие параметрами профиля.

Таблица параметров занимает нижнюю часть окна.

Выбрав отверстие, введите значения его параметров в соответствующую колонку таблицы.

Не все значения размеров можно менять в произвольном порядке. Например, нельзя сделать диаметр резьбы больше номинального диаметра отверстия. Если требуется увеличить диаметр отверстия, сначала измените номинальный диаметр, а затем — диаметр резьбы.

После ввода нового значения параметра в колонке Изменен напротив его имени появляется «галочка». Щелчок на ней мышью позволяет вернуть исходное значение параметра.

Смотрите также

Пользовательская библиотека отверстий


Панель выбора эскиза из библиотеки

Панель выбора эскиза разделена на несколько областей. В первой из них содержится структура библиотеки эскизов («дерево» разделов), во второй — перечень элементов выбранного раздела. Команды контекстного меню первой и второй области позволяют управлять представлением их элементов, а также отображением областей комментария и просмотра.

В области просмотра показывается содержимое выделенного эскиза.


Выбор стиля линии

Системой предусмотрены несколько стилей линий: основная, тонкая, осевая, штриховая и др.

По умолчанию для линий (за исключением вспомогательных прямых) используется стиль Основная. Для изменения текущего стиля отрисовки линии воспользуйтесь списком Стиль на Панели свойств.

При создании вспомогательных прямых им автоматически присваивается стиль Вспомогательная. Выбор другого стиля невозможен.

Щелчок на строке Другой стиль позволяет выбрать стиль из внешней библиотеки, или из сформированного пользователем набора, или один из стилей, хранящихся в документе. Возможно также создание нового стиля линии и применение его к объектам.

Смотрите также

Настройка цветов системных стилей линий


Требования к границе обрезки рисунка

– граница должна представлять собой окружность, эллипс, прямоугольник, многоугольник, замкнутую ломаную или замкнутый контур (контур не должен содержать кривые Безье или NURBS),

– граница должна пересекаться с рисунком,

– граница, имеющая самопересечения, должна полностью находиться в пределах рисунка,


Порядок выполнения обрезки рисунка

1. Задайте границу обрезки.

Требования к границе обрезки...

– Чтобы указать в качестве границы существующий объект, щелкните по нему мышью (при прохождении курсора над объектом, который может использоваться как граница, он подсвечивается).

Группа переключателей Режим позволяет указать, требуется ли удалять указанный объект после создания границы или нет.

Связь между рисунком и указанным объектом не формируется, т.е. удаление или редактирование объекта не влияет на границу обрезки.

– Чтобы построить ломаную — границу обрезки, нажмите кнопку Ручное рисование границ на Панели специального управления.

Система перейдет в режим ручного рисования границ. Постройте границу обрезки, удовлетворяющую требованиям (см. выше).

Нажмите кнопку Создать объект на Панели специального управления, чтобы вернуться к выполнению команды Обрезать.

2. Если требуется сменить границу, нажмите кнопку Повторный выбор контура на Панели специального управления и выберите другой объект либо нажмите кнопку Ручное рисование границ, и постройте другую границу. При необходимости включите режим полного отображения рисунка с помощью появившейся на Панели свойств группы переключателей Режим.


Команда Убрать форматирование (меню Библиотекаря)

Команда Убрать форматирование
(меню Библиотекаря)

Команда позволяет привести форматирование выделенного текста к виду, установленному в диалоге настройки текстовых шаблонов.


Команда Шрифт... (меню Библиотекаря)

Команда Шрифт...
(меню Библиотекаря)

Команда позволяет назначить или изменить параметры шрифта (высоту, сужение, начертание и т.д.) для выделенного или набираемого заново текста.

После вызова команды на экране появится диалог установки параметров шрифта.


Коллекция

Коллекция — набор объектов модели, необходимых для определенных построений. Коллекции используются для выбора объектов при создании копий геометрических объектов.


Простое и составное обозначение документа

Простое обозначение документа — обозначение, включающее только базовое обозначение.

Составное обозначение документа — обозначение, содержащее базовое обозначение, а также одну или несколько дополнительных частей: номер исполнения, дополнительный номер исполнения, код документа.


Компоновочная геометрия

Компоновочная геометрия — часть модели, которая представляет собой набор объектов, определяющих основные геометрические параметры модели (например, места крепежа, области пространства сборки, ограничивающие ее компоненты и т.п.). Компонентами компоновочной геометрии могут быть детали, сборки и локальные детали.


Компонент

Компонент — объект модели, представленный другой моделью. Компонентами модели могут быть детали, сборки, детали-заготовки и локальные детали, а в сборках также стандартные изделия и библиотечные элементы.

Модель компонента может храниться в отдельном файле или в файле текущей модели.

В отдельных файлах хранятся следующие компоненты:

– детали,

– сборки,

– детали-заготовки с историей,

– стандартные изделия,

– модели из библиотеки.

В данном случае в текущей модели фактически содержатся не сами компоненты, а ссылки на их файлы.

В файле текущей модели хранятся следующие компоненты:

– локальные детали,

– детали-заготовки без истории.

Эти компоненты не имеют самостоятельного файлового представления. Они хранятся непосредственно в содержащей их модели.


Файлы конфигурации

Файлы конфигурации — файлы *.cfg,*.prj и *.dsk.

Они автоматически создаются в результате сохранения параметров конфигурации.

Если эти файлы отсутствуют (например, при первом запуске системы КОМПАС-3D), то используются хранящиеся внутри системы умолчательные параметры конфигурации.


Конфигурация устройства печати

Конфигурация устройства печати — файл с расширением pdc, в который записываются текущие параметры печати (размер и способ подачи бумаги, ориентация страницы) и данные об устройстве печати.

Файл конфигурации имеет текстовый формат, поэтому он может быть открыт и отредактирован любым текстовым редактором, например, Блокнотом, входящим в состав Windows.


Контекстная панель

Контекстная панель — инструментальная панель, появляющаяся на экране рядом с курсором после щелчка мышью (в текстовом документе — также после выделения фрагмента текста), содержащая кнопки вызова наиболее часто используемых команд.


Контекстное меню

Контекстное меню — меню, вызываемое нажатием правой кнопки мыши, содержащее набор команд, которые могут быть применены к объекту либо к документу в целом.


Контур

Контур — составной объект, представляющий собой цепочку кривых и построенный по исходным объектам. В частном случае контур может быть представлен одной кривой.


Линия очерка

Линия очерка — линия, в точках которой нормаль грани перпендикулярна направлению взгляда.


Контрольная точка

Контрольная точка — специальный объект, позволяющий задать пространственное положение элемента трубопровода на его траектории. Свойством контрольной точки является ее положение в модели.

Элемент трубопровода может содержать несколько контрольных точек. Одна из них должна быть расположена в заданной точке траектории.


Вкладка Атрибуты

Для управления копированием атрибутов и свойств служат элементы вкладки Атрибуты.

Переключатели группы Копирование атрибутов позволяют указать, должны ли объекты-копии иметь такие же атрибуты. Подробнее...

Переключатели группы Копирование свойств позволяют указать, требуется ли копировать свойства, назначенные макроэлементам, вставкам видов и фрагментов.

Управление копированием распространяется на свойства, значения которых заданы пользователем. Подробнее...


Группа переключателей Направление

Группа переключателей, управляющая направлением копирования вдоль траектории.

Если требуется, смените направление, предложенное системой, активизируйте нужный переключатель в группе: Прямое направление или Обратное направление.

Смена направления по-разному влияет на массивы с замкнутой и разомкнутой траекториями.

Если траектория замкнута, то Прямое направление копирования означает расположение экземпляров массива вдоль траектории по одну сторону от исходного объекта, а Обратное направление — по другую сторону. На фантоме массива текущее направление копирования показано стрелкой.

Если траектория копирования замкнута и экземпляры располагаются вдоль всей траектории, то результат операции не зависит от направления копирования.

Если траектория разомкнута, то Прямое направление копирования означает, что начало траектории определяется умолчательным образом — начальной точкой считается ближайший к копируемому объекту конец траектории. При выборе Обратного направления началом траектории будет считаться другой ее конец.


Кривая для построения массива

В качестве кривой, используемой для построения массива, может служить один из следующих объектов:

– пространственная кривая,

– линия эскиза,

– ребро,

– цепочка вышеперечисленных объектов в любом сочетании.


Копия геометрических объектов

Копия геометрических объектов — это объект модели, содержащий геометрические объекты без истории, которые являются копиями геометрических объектов этой или другой модели. В копию могут включаться объекты самой модели, ее компонентов и содержащейся в ней компоновочной геометрии.


Ориентация экземпляров массива

Если все экземпляры должны быть ориентированы в пространстве так же, как ориентирован копируемый объект, активизируйте переключатель Сохранять исходную ориентацию.

Активизация переключателя Доворачивать до радиального направления означает, что каждый экземпляр будет поворачиваться в плоскости сетки вокруг своей базовой точки так, чтобы располагаться относительно своего луча так же, как базовый располагается относительно своего.

Если после активизации переключателя положение экземпляров отличается от ожидаемого, измените положение базовой точки базового экземпляра, указав его вручную.


Сопряжение

Сопряжение — связь между компонентом и другим объектом модели, определяющая их взаимное пространственное расположение.


Объекты для сопряжения Кулачок – толкатель

Объекты для сопряжения выбираются таким образом, что один из них служит кулачком, вращающимся вокруг оси, другой — толкателем, перемещающимся вдоль прямолинейной траектории. Рабочие поверхности кулачка и толкателя — поверхности, находящиеся в контакте друг с другом и передающие движение.

Кулачок

Модель кулачка должна быть однотельной деталью.

Рабочая поверхность кулачка может состоять из одной или нескольких граней — плоских, цилиндрических, конических, тороидальных.

Рабочая поверхность кулачка также может представлять собой линейчатую поверхность, эскиз которой состоит из отрезков, дуг, дуг эллипсов, сплайнов.

Для указания оси вращения кулачка могут быть выбраны следующие объекты.

– Прямолинейные (сегменты ломаных, координатные и вспомогательные оси, прямолинейные ребра).

Осью является прямая, совпадающая с объектом.

– Плоские кривые (дуги, ребра в виде окружностей).

Осью является прямая, проходящая через центр указанного объекта по нормали к его плоскости.

– Грани поверхностей вращения (цилиндрические, конические, тороидальные).

Осью является ось вращения.

Толкатель

Рабочая поверхность толкателя — плоская или сферическая грань. В сопряжении участвует поверхность, полученная продолжением указанной грани — плоскость или полная сфера.

Объектом, являющимся рабочей поверхностью, также может служить вершина в детали толкателя.

Если рабочая поверхность толкателя — плоская, то рабочей поверхностью кулачка может служить только цилиндрическая, коническая или линейчатая поверхности. При этом кулачок и толкатель должны быть так ориентированы друг относительно друга, чтобы их касание происходило по прямой линии.

В качестве траектории толкателя могут быть указаны прямолинейные объекты (сегменты ломаных, координатные и вспомогательные оси, прямолинейные ребра). Перемещение толкателя происходит вдоль выбранной траектории.

Выбор объектов в окне модели

Выбор объектов в Дереве построения

Если определяющий траекторию объект, например, ребро, принадлежит подвижному компоненту, то и траектория будет подвижна, т.е. будет перемещаться согласно сопряжениям, наложенным на компонент. Чтобы исключить перемещения траектории, следует наложить на содержащий ее компонент дополнительные позиционирующие сопряжения.


Объекты для механических сопряжений Вращение — вращение и Вращение — перемещение

Объекты для механических сопряжений
Вращение — вращение и Вращение — перемещение

Объектами для механических сопряжений являются компоненты и тела модели.

Для указания осей вращения и траекторий перемещения могут быть выбраны следующие объекты.

– Прямолинейные:

• сегменты ломаных,

• координатные и вспомогательные оси,

• прямолинейные ребра.

Осью или траекторией является прямая, совпадающая с объектом.

– Плоские кривые:

• дуги,

• ребра (окружности).

Осью или траекторией является прямая, проходящая через центр указанного объекта по нормали к его плоскости.

– Грани поверхностей вращения (цилиндрические, конические, тороидальные).

Осью или траекторией является ось вращения.

Выбор объектов в окне модели

Выбор объектов в Дереве построения

При указании некоторых элементов, наряду с объектом, которому они принадлежат, по умолчанию выбирается ось или траектория движения. Ее наименование появляется в соответствующем поле (Ось, Ось 1, Ось 2, Траектория) на Панели свойств.

Например, для указания участвующей в сопряжении детали было выбрано ее ребро. В поле Компонент появляется наименование детали, а в поле Траектория — наименование выбранное ребра.

Если определяющий траекторию объект, например, ребро, принадлежит подвижному компоненту, то и траектория будет подвижна, т.е. будет перемещаться согласно сопряжениям, наложенным на компонент. Чтобы исключить перемещения траектории, следует наложить на содержащий ее компонент дополнительные позиционирующие сопряжения.

Величина перемещения вдоль траектории не ограничивается длиной указанного объекта.


Инструментальная панель окна предварительного просмотра

Инструментальная панель
окна предварительного просмотра

Инструментальная панель содержит кнопки для быстрого вызова наиболее часто используемых команд.


Настройка параметров штриховки на разрезе/сечении

В процессе построения разреза или сечения на вкладке Штриховка Панели свойств доступны следующие элементы управления.

Опция Параметры из модели служит для выбора способа задания параметров штриховки.

– При включенной опции (вариант по умолчанию) штриховка на разрезе/сечении получит параметры, заданные в модели телам и компонентам. Доступна группа переключателей Тип, позволяющая выбрать способ отображения штриховки внутри границ.

Особенности использования штриховки, параметры которой заданы в модели...

– Если опция отключена, то параметры штриховки могут быть заданы вручную. Становятся доступны остальные элементы управления Панели свойств.

Настройка параметров штриховки производится так же, как при работе с командой Штриховка.

Дополнительно при задании параметров штриховки вручную доступна группа переключателей Штриховка сборки. Она позволяет выбрать способ штриховки соседних деталей модели: в одну сторону или с поворотом на 90°.

Стиль, цвет, угол наклона штриховки на разрезе/сечении можно редактировать при помощи команды Изменить стиль или в окне Свойства независимо от способа задания ее параметров.


Текущий лист

Текущий лист — лист, который расположен так, что захватывает центр окна документа. Его номер отображается в списке листов на панели Управление листами.


Текущий стиль спецификации

Текущий стиль спецификации — стиль спецификации, входящий в текущее описание спецификации. Назначение описанию спецификации признака «текущий» производится в диалоге управления описаниями спецификаций.


Шаг курсора

Шаг курсора — расстояние, на которое перемещается курсор при однократном нажатии управляющей клавиши со стрелкой.

Пользователь может устанавливать любой шаг курсора.


Порядок NURBS

Порядок NURBS-кривой — число, на единицу большее максимальной степени полиномов, описывающих участки, из которых состоит кривая NURBS.


Объект, определяющий диаметр спирали

– Если в качестве объекта указана точка (вершина детали, начало координат, конец отрезка или точка в эскизе и т.п.), то диаметр спирали принимается равным расстоянию от цента спирали до проекции указанной точки на опорную плоскость спирали.

– Если в качестве объекта указано ребро детали или линия эскиза в форме окружности (дуги), то диаметр спирали принимается равным диаметру выбранной окружности или дуги.


Удаление графических объектов

Помимо команд ввода и редактирования объектов, КОМПАС-3D предоставляет набор команд удаления.

Удалять можно как отдельные объекты, так и произвольные их сочетания. Будьте внимательны при выделении и последующем удалении макроэлементов, групп, вставленных фрагментов и других сложных объектов. Входящие в них объекты могут быть не видны в текущем режиме отображения (например, часть из них находится на выключенных слоях). Поэтому вы можете случайно удалить лишнее.

Если вы допустили ошибку при удалении, воспользуйтесь командой отмены и восстановите предыдущее состояние документа.

Для этого выберите команду Отменить в меню Редактор либо нажмите комбинацию клавиш <Alt>+<BackSpace> или <Ctrl>+<Z> либо нажмите кнопку Отменить на панели Стандартная.

Команду Отменить можно использовать и для удаления только что созданного объекта — для этого надо вызвать ее сразу после создания объекта.

Подробнее о различных способах удаления объектов и их частей см. следующие разделы:

Усечение кривых

Усечение кривых по указанным точкам

Выравнивание по границе

Удаление фасок и скруглений

Очистка области

Удаление частей объектов оформления и библиотечных макроэлементов

Очистка фона

Удаление вспомогательных объектов

Удаление всех объектов документа

Удаление объектов оформления

Смотрите также

Отмена и повтор действий


Описание спецификации

Описание спецификации — совокупность параметров, характеризующих имеющиеся в документе объекты спецификации: стиль спецификации и настройка отображения значения массы. Если документ (чертеж или сборка) подключен к спецификации, то имя файла этой спецификации входит в описание, содержащее соответствующий стиль. Одно из описаний является текущим — согласно ему в документе создаются новые объекты спецификации.

Для фрагмента описание спецификации включает в себя только имя стиля спецификации и настройку отображения значения массы. Это связано с тем, что фрагмент непосредственно к спецификации не подключается, но в нем можно создавать объекты спецификации.


Типы загрузки компонента

Типы загрузки компонента — способы загрузки компонента, различающиеся объемом данных, помещаемых в память компьютера.

Доступны следующие типы загрузки компонента:

– полный — компонент загружается полностью; виден в Дереве построения и в окне модели,

– упрощенный — компонент загружается так, что он виден в Дереве построения и в окне модели, но в окне отображается без линий каркаса и с пониженной точностью (т.е. менее «гладким»),

– габарит — компонент загружается так, что он виден в Дереве построения и в окне модели, но в окне отображается его габаритный параллелепипед,

– пустой — компонент не загружается; виден только в Дереве построения.

Использование упрощенного, габаритного и пустого типов загрузки позволяет ускорить обработку (перестроение, отрисовку после поворота или сдвига и др.) моделей больших сборок. Так, можно включить полную загрузку лишь той подсборки, с которой ведется работа в данный момент, а все остальные компоненты выгрузить либо — если требуется видеть их расположение в сборке — отобразить габарит или загрузить упрощенно.

Подробнее о типах загрузки компонентов см. раздел 2.12.2.1.


Отключение библиотеки

Если библиотека, подключенная ранее к системе, больше не требуется для работы, можно отключить ее. При отключении библиотеки высвобождаются ресурсы компьютера (в первую очередь оперативная память), выделенные для работы с ней.

1. Вызовите команду Сервис — Менеджер библиотек....

На экране появится окно Менеджера библиотек.

2. В списке библиотек (он находится в правой части первой вкладки Менеджера) выделите имя нужной библиотеки и вызовите команду Подключить из контекстного меню.

Для быстрого отключения выбранной библиотеки можно щелкнуть мышью в поле рядом с ее названием в списке (когда библиотека подключена, в этом поле отображается «галочка»).

Вы можете отключить сразу все библиотеки, подключенные к системе, воспользовавшись командой Отключить все библиотеки из контекстного меню списка библиотек в окне Менеджера библиотек.

Команда Сервис — Выгрузить все библиотеки позволяет одновременно отключить все прикладные библиотеки, подключенные к системе КОМПАС-3D.

Отдельную прикладную библиотеку, работающую в режиме диалога, можно отключить, нажав кнопку Отключить в ее диалоге.

Отдельную прикладную библиотеку, работающую в режиме панели, можно отключить, вызвав команду Закрыть из контекстного меню окна структуры библиотеки или окна просмотра текущего раздела на панели Менеджера библиотек.

Вы можете включить автоматическое отключение библиотек, подключенных в «слепом» режиме. Для этого служит диалог настройки отключения библиотек.


Деталь

Деталь — вид трехмерной модели, предназначенный для представления изделий, изготавливаемых без применения сборочных операций. Создается и хранится в документе «Деталь», расширение файла — m3d.


Работа с прикладной библиотекой в режиме диалога

В левой части диалога отображается список команд текущей библиотеки, которые могут быть сгруппированы по разделам. Чтобы развернуть содержание какого-либо раздела, установите курсор на значке плюса рядом с заголовком раздела и щелкните левой кнопкой мыши. Повторный щелчок на этом символе (после разворачивания раздела он отображается как минус) приведет к сворачиванию содержания раздела.

В правой части диалога отображаются слайды, облегчающие поиск нужной команды.

Для запуска библиотечной команды на исполнение выберите ее название в списке и нажмите кнопку ОК. Можно также дважды щелкнуть левой кнопкой мыши на названии команды.

Чтобы изменить режим работы с библиотекой, нажмите кнопку Режим.

Вы можете отключить текущую библиотеку от системы, нажав кнопку Отключить.

Для завершения диалога работы с библиотекой без запуска какой-либо команды нажмите кнопку Отмена.


Команды создания элементов оформления в документе-модели

Кнопки вызова команд создания элементов оформления в документе-модели находятся на инструментальной панели Элементы оформления.

Условное изображение резьбы

Команды простановки размеров:

Линейный размер

Линейный от отрезка до точки

Угловой размер

Радиальный размер

Диаметральный размер

Команды простановки обозначений:

Шероховатость

База

Линия-выноска

Знак клеймения

Знак маркировки

Обозначение позиций

Допуск формы


Тип ориентации углового размера

Группа переключателей Тип на вкладке Размеры позволяет указать, требуется ли проставить размер на острый угол, тупой угол или угол больше 180°.

По умолчанию ориентация размера определяется системой автоматически.

Если угол острый, становится активным переключатель На острый угол, если тупой — переключатель На тупой угол.

При помощи переключателей вы можете изменить предложенный системой способ простановки размера.

Чтобы включить простановку угла больше 180° (автоматический выбор этого варианта невозможен), активизируйте переключатель На угол более 180 гр.

Подробнее об ориентации углового размера...


Команды простановки размеров в графическом документе или эскизе

Кнопки вызова команд простановки размеров в графическом документе или эскизе находятся на инструментальной панели Размеры.

Авторазмер

Линейный размер

Линейный размер от общей базы

Линейный цепной размер

Линейный размер с общей размерной линией

Линейный размер с обрывом

Линейный размер от отрезка до точки

Диаметральный размер

Радиальный размер

Радиальный размер с изломом

Угловой размер

Угловой размер от общей базы

Угловой цепной размер

Угловой размер с общей размерной линией

Угловой размер с обрывом

Размер дуги окружности

Размер высоты


Настройка параметров размеров

Для настройки параметров размеров служат элементы вкладки Параметры Панели свойств.

Переключатели Выносная линия 1 и Выносная линия 2 позволяют включить или отключить отрисовку первой и второй выносных линий размера.

Для линейных размеров всех типов, кроме размера с обрывом, возможна отрисовка выносных линий на некотором расстоянии от точек привязки размера. Для этого служат элементы группы Зазор/длина, которые доступны, если хотя бы один из переключателей отрисовки выносных линий включен. Подробнее...

Списки Стрелка 1 и Стрелка 2 позволяют выбрать вид первой и второй стрелок. Перечень стрелок, доступных для выбора, а также порядок следования стрелок в списке определяется настройкой фильтра стрелок, сделанной для текущего документа.

Список Положение надписи позволяет выбрать положение надписи относительно размерной линии. Умолчательное положение определяется настройкой положения надписи, сделанной для текущего документа.

Группа переключателей Размещение стрелок служит для выбора размещения стрелок относительно выносных линий: внутри, снаружи или автоматическое определение положения. Умолчательное размещение определяется настройкой стрелок, сделанной для текущего документа.

Группа элементов Параметры выноски становится доступной, если выбрано одно из размещений размерной надписи на полке. В поле Длина отображается длина линии-выноски, а в поле Угол — угол ее наклона к оси абсцисс текущей системы координат. Ввод значений с клавиатуры в эти поля возможен при отключенном автосоздании объектов и только после того, как линия-выноска сформирована (указана точка начала полки), т.е. фактически с помощью этих полей производится редактирование созданной линии-выноски.

Включение опции По умолчанию позволяет сохранить все текущие настройки вкладки Параметры и использовать их при создании следующих размеров данного типа до конца сеанса работы. Если опция выключена, то настройка распространяется только на текущий (создаваемый) размер.


Настройка параметров размеров

Для настройки параметров размеров служат элементы вкладки Параметры Панели свойств.

Переключатель Выносная линия 1 и Выносная линия 2 позволяют включить или отключить отрисовку первой и второй выносных линий размера. Если хотя бы один из этих переключателей включен, доступна группа элементов Зазор/длина. Элементы данной группы позволяют настроить отрисовку выносных линий на некотором расстоянии от точек привязки размера.

Списки Стрелка 1 и Стрелка 2 позволяют выбрать вид первой и второй стрелок. Перечень стрелок, доступных для выбора, а также порядок следования стрелок в списке определяется настройкой фильтра стрелок, сделанной для текущего документа.

Группа переключателей Размещение стрелок служит для выбора размещения стрелок относительно выносных линий: внутри, снаружи или автоматическое определение положения. Умолчательное размещение определяется настройкой стрелок, сделанной для текущего документа.

Включение опции По умолчанию позволяет сохранить все текущие настройки вкладки Параметры и использовать их при создании следующих размеров данного типа до конца сеанса работы. Если опция выключена, то настройка распространяется только на текущий (создаваемый) размер.


Настройка параметров размеров

Для настройки параметров размеров служат элементы вкладки Параметры Панели свойств.

Список Стрелка позволяет выбрать вид стрелки. Перечень стрелок, доступных для выбора, а также порядок следования стрелок в списке определяется настройкой фильтра стрелок, сделанной для текущего документа.

Переключатель Выносная линия позволяет включить или отключить отрисовку выносной линии размера.

Список Положение надписи позволяет выбрать положение надписи относительно размерной линии. Умолчательное положение определяется настройкой положения надписи, сделанной для текущего документа.

Группа переключателей Размещение стрелки служит для выбора размещения стрелки относительно выносной линии: внутри, снаружи или автоматическое определение положения. Умолчательное размещение определяется настройкой стрелок, сделанной для текущего документа.

Группа элементов Параметры выноски становится доступной, если выбрано одно из размещений размерной надписи на полке. В поле Длина отображается длина линии-выноски, а в поле Угол — угол ее наклона к оси абсцисс текущей системы координат. Ввод значений с клавиатуры в эти поля возможен при отключенном автосоздании объектов и только после того, как линия-выноска сформирована (указана точка начала полки), т.е. фактически с помощью этих полей производится редактирование созданной линии-выноски.

Включение опции По умолчанию позволяет сохранить все текущие настройки вкладки Параметры и использовать их при создании следующих размеров данного типа до конца сеанса работы. Если опция выключена, то настройка распространяется только на текущий (создаваемый) размер.


Настройка параметров размеров

Для настройки параметров размеров служат элементы вкладки Параметры Панели свойств.

Переключатель Выносная линия 1 позволяет включить или отключить отрисовку выносной линии радиального размера и радиального размера с изломом.

Для диаметрального размера вкладка Параметры содержит два переключателя отрисовки выносных линий — Выносная линия 1 и Выносная линия 2.

Если хотя бы один из переключателей отрисовки выносных линий включен, доступна группа элементов Зазор/длина. Элементы этой группы позволяют настроить отрисовку выносных линий на некотором расстоянии от точек привязки размера.

Список Стрелка позволяет выбрать вид стрелки. Перечень стрелок, доступных для выбора, а также порядок следования стрелок в списке определяется настройкой фильтра стрелок, сделанной для текущего документа.

Список Положение надписи позволяет выбрать положение надписи относительно размерной линии. Умолчательное положение определяется настройкой положения надписи, сделанной для текущего документа.

Группа переключателей Размещение стрелок служит для выбора размещения стрелок (стрелки) относительно контура окружности или дуги: внутри, снаружи или автоматическое определение положения. Умолчательное размещение определяется настройкой стрелок, сделанной для текущего документа.

Группа элементов Параметры выноски становится доступной, если выбрано одно из размещений размерной надписи на полке. В поле Длина отображается длина линии-выноски, а в поле Угол — угол ее наклона к оси абсцисс текущей системы координат. Ввод значений с клавиатуры в эти поля возможен при отключенном автосоздании объектов и только после того, как линия-выноска сформирована (указана точка начала полки), т.е. фактически с помощью этих полей производится редактирование созданной линии-выноски.

Поле Угол излома служит для ввода угла при построении радиального размера с изломом.

Включение опции По умолчанию позволяет сохранить все текущие настройки вкладки Параметры и использовать их при создании следующих размеров данного типа до конца сеанса работы. Если опция выключена, то настройка распространяется только на текущий (создаваемый) размер.


Создание линейного размера с наклонными выносными линиями

Чтобы проставить линейный размер с наклонными выносными линиями, выполните следующие действия.

– Вызовите команду создания линейного размера.

– Отключите автосоздание объекта на Панели специального управления.

– Укажите точки привязки линейного размера.

– Нажмите кнопку Параллельно объекту на вкладке Размер Панели свойств.

– Расположите размерную линию на нужном расстоянии от объекта.

– Нажмите кнопку Наклонить размер на Панели специального управления.

– Все элементы вкладки Размер заменяются одним полем Угол.

– Введите в него значение угла наклона выносных линий размера. Можно также «наклонить» размер мышью, перетаскивая одну из появившихся экране характерных точек.

– После установки нужного положения выносных линий отожмите кнопку Наклонить размер.

– Чтобы зафиксировать получившийся наклонный размер, нажмите кнопку Создать объект.

Пример простановки размера с наклонными выносными линиями


Направление перемещения

При указании оси или траектории система автоматически задает направление движения объектов в передаче. В окне модели направление вращения обозначается круговыми стрелками, а направление перемещения — прямой.

Направления, заданные автоматически, можно изменить при помощи переключателей, расположенных на Панели свойств.

Группа Направление 1 служит для изменения направления вращения первого объекта. Направление, соответствующее активному в данный момент переключателю (Прямое направление или Обратное направление), показано на экране стрелкой. Чтобы изменить направление на противоположное, следует активизировать другой переключатель группы.

Группа Направление 2 служит для изменения направления движения (вращения или перемещения) второго объекта.

Направление можно изменять для каждого объекта. Но на работу передачи влияет только относительное направление. Для изменения относительного направления достаточно сменить направление движения одного из объектов. Например, чтобы колеса в зубчатой передаче вращались навстречу друг к другу, объектам следует задать противоположные направления (у одного объекта должна быть активен переключатель Прямое направление, у другого — Обратное направление).

Во время работы передачи объект можно перемещать мышью как в прямом, так и в обратном направлении. При этом направления движения объектов или совпадают с заданными при создании, или оба им противоположны.


Элементы документа

Элементы документа — элементы, составляющие содержимое документа. Эти элементы создает пользователь: кривые, точки, штриховки, размеры, обозначения в графическом документе; тела и поверхности в документе-модели.


Шаблон документа

Шаблон КОМПАС-документа — заготовка документа, содержащая оформление, настройки, объекты, слои и др.

Шаблоны документов, поставляемые в составе КОМПАС-3D, хранятся в подпапке \Templates главной папки КОМПАС-3D.

Возможно также создание пользовательских шаблонов документов.


Указание объектов для выполнения команды Уклон

Чтобы выбрать основание, активизируйте соответствующий переключатель и укажите нужную грань в окне модели.

Если основание выбрано неверно, его можно указать повторно, не выходя из команды. Просто щелкните мышью на нужной грани. Выделение с ранее указанной грани будет снято. Вновь указанная грань окажется выбранной в качестве основания уклона.

Чтобы выбрать уклоняемые грани, активизируйте соответствующий переключатель в группе Объекты и укажите нужные грани в окне модели.

Чтобы исключить какую-либо грань из числа выбранных, укажите ее в окне модели повторно. Выделение с этой грани будет снято. Она не будет учитываться при построении.

Результат выполнения команды Уклон (основание — верхняя грань, уклоняемые грани выделены).

Иногда в качестве основания можно указать разные грани. При этом результат выполнения команды будет зависеть от взаимного положения основания и уклоняемой грани.

Положение уклона в зависимости от выбора основания


Вид чертежа

Вид чертежа — составная часть чертежа системы КОМПАС-3D, «контейнер» для объектов чертежа, а также сами объекты, находящиеся в этом «контейнере».

Объекты, содержащиеся в одном виде, могут формировать как одно изображение (вид, разрез, сечение или выносной элемент), так и сразу несколько. В принципе, чертеж может состоять из одного-единственного вида, который будет содержать все необходимые изображения. Однако настоятельно рекомендуется разбивать всю графическую информацию в чертеже на виды, размещая каждое изображение в отдельном виде.

Основными характеристиками вида являются масштаб и положение. Масштаб может быть выбран из стандартного ряда или задан как соотношение произвольных чисел. Положение вида определяется координатами его точки привязки в абсолютной системе координат и углом поворота относительно этой точки.

В каждом виде можно создавать до 2 147 483 647 слоев для удобного размещения и обработки изображения.


DWG

DWG — закрытый двоичный формат, являющийся собственностью компании Autodesk Inc (СШA).


DXF

DXF (Data eXchange Format) — специальный символьный формат обмена информацией, разработанный компaнией Autodesk Inc. (СШA) для своих программных продуктов, в первую очередь AutoCAD.

Этот формат обмена стал стaндapтом де-фaкто для чеpтежно-гpaфических систем и поддерживается практически всеми разработчиками программных продуктов САПР.


Чтение документов формата DXF/DWG

Чтобы импортировать в КОМПАС-3D документ формата DXF или DWG, выполните следующие действия.

1. Вызовите команду Файл — Открыть.

На экране появится диалог открытия файлов.

2. В списке Тип файлов выберите нужную строку: AutoCAD DXF (*.dxf) или AutoCAD DWG (*.dwg).

3. В окне диалога укажите файл для импорта.

4. Выберите нужный вариант чтения: Читать в графический документ или Читать в модель.

5. Запустите процесс импорта одним из следующих способов.

– Если настройка параметров импорта не требуется, нажмите кнопку Открыть диалога.

– Если требуется проверить или изменить параметры импорта, раскройте меню кнопки Открыть и вызовите из него команду Открыть с параметрами. В зависимости от того, в какой документ производится чтение, на экране появится диалог настройки чтения в графический документ или диалог настройки чтения в модель.
Задайте параметры чтения и нажмите кнопку Начать чтение настроечного диалога.


Динамический поиск

Динамический поиск — автоматическое распознавание объектов, которые в данный момент находятся под графическим курсором. Правила автоматического распознавания зависят от фильтров (в моделях) и текущего процесса.


Ребро

Ребро — примитив, представляющий собой ограниченный двумя вершинами и не содержащий внутри себя других вершин участок граничной линии грани.

В общем случае как ребра при указании определяются сегменты кривых и контуров.

Особые случаи ребер:

– замкнутое ребро, у которого вершины отсутствуют (например, окружность и эллипс),

– ребро нулевой длины, вырожденное в вершину (например, вершина конуса).


Команды редактирования

Кнопки вызова команд редактирования геометрических объектов находятся инструментальной панели Редактирование.

Сдвиг

Сдвиг по углу и расстоянию

Поворот

Масштабирование

Симметрия

Копия указанием

Копия по кривой

Копия по окружности

Копия по сетке

Копия по концентрической сетке

Деформация сдвигом

Деформация поворотом

Деформация масштабированием

Усечь кривую

Усечь кривую двумя точками

Удлинить до ближайшего объекта

Выровнять по границе

Разбить кривую

Разбить кривую на N частей

Очистить область

Удалить фаску/скругление

Удалить разрыв линии мультилинии

Удалить все разрывы указанной линии мультилинии

Преобразовать в NURBS


Меню Редактор (меню Библиотекаря)

Меню Редактор
(меню Библиотекаря)

Группа команд позволяет осуществлять операции с буфером обмена, искать текст и названия разделов шаблонов, а также переименовывать их.

Команда Вырезать

Команда Копировать

Команда Вставить

Команда Удалить

Команда Переименовать

Команда Найти


Команда Копировать (меню Библиотекаря)

Команда Копировать
(меню Библиотекаря)

Команда позволяет поместить в буфер обмена выделенный в Окне просмотра фрагмент содержания шаблона. Этот фрагмент останется в шаблоне.


Команда Вырезать (меню Библиотекаря)

Команда Вырезать
(меню Библиотекаря)

Команда позволяет поместить в буфер обмена выделенный в Окне просмотра фрагмент содержания шаблона. Этот фрагмент будет удален из шаблона.


Команда Удалить (меню Библиотекаря)

Команда Удалить
(меню Библиотекаря)

Команда позволяет удалить выделенный в Окне просмотра фрагмент содержания шаблона.


Команда Найти... (меню Библиотекаря)

Команда Найти...
(меню Библиотекаря)

Команда позволяет найти шаблон в текущем файле текстовых шаблонов. Поиск может производиться по строке текста, который содержится в шаблоне или по названию шаблона.


Команда Вставить (меню Библиотекаря)

Команда Вставить
(меню Библиотекаря)

Команда позволяет вставить в Окно просмотра содержимое буфера обмена Windows. Команда доступна, если в буфере обмена находится текст.


Команда Переименовать (меню Библиотекаря)

Команда Переименовать
(меню Библиотекаря)

Команда позволяет изменить название раздела или шаблона.


Элемент модели

Элемент модели — объект, создание которого в модели приводит к добавлению или удалению материала тел. Элементы бывают формообразующие и дополнительные.


Дополнительные обозначения координационной оси

Вкладка Дополнительные обозначения Панели свойств позволяет создать или отредактировать дополнительные обозначения.

– В процессе создания оси элементы вкладки Дополнительные обозначения доступны, если режим автосоздания объектов отключен и указаны точки:

• т1 и т2 — для прямой оси,

• тС, т1 и т2 или тС, угол 1, угол 2 и радиус — для дуговой оси,

• тС и т — для круговой оси.

– В процессе редактирования элементы вкладки Дополнительные обозначения доступны всегда.

Группа переключателей Элементы позволяет выбрать вид добавляемых элементов.

– Чтобы добавить указатель ориентации оси вместе с маркой, активизируйте переключатель Добавить указатель ориентации оси.

– Чтобы добавить марку, активизируйте переключатель Добавить марку.

– Чтобы добавить текстовое обозначение в виде надписи, активизируйте переключатель Добавить текст.

После активизации переключателя группы Элементы на экране появляется фантом элемента, а все места возможного присоединения марок на оси обозначаются черными точками.

Группа переключателей Тип марки служит для выбора варианта отрисовки добавляемой марки: одинарная или двойная окружность. Переключатели Тип марки доступны, если активен переключатель Добавить указатель ориентации оси или Добавить марку.

В поле Длина введите или задайте счетчиком длину указателя ориентации оси. Поле доступно для ввода при активизированном переключателе Добавить указатель ориентации оси.

Для ввода текста дополнительного обозначения вызовите диалог ввода текста, щелкнув мышью в поле Текст на Панели свойств. Поле Текст доступно после активизации любого из переключателей группы Элементы.

Смотрите также

Дополнительные обозначения координационной оси


Растровый объект, взятый в документ

Растровое изображение, хранящееся внутри графического КОМПАС-документа.

Вставка этого типа отображается корректно вне зависимости от наличия на диске ее файла-источника.


Тип перемещения сечения вдоль траектории

Сохранять угол наклона

При выборе этого варианта сечение перемещается так, чтобы в любой точке элемента угол между плоскостью сечения и траекторией был постоянным и равным углу между плоскостью эскиза-сечения и траекторией в начальной точке траектории.

Параллельно самому себе

При выборе этого варианта сечение перемещается так, что в любой точке элемента его плоскость параллельна плоскости эскиза, содержащего сечение.

Ортогонально траектории

При выборе этого варианта сечение перемещается так, чтобы в любой точке элемента плоскость сечения была перпендикулярна траектории.


Расширенная панель команд

Расширенная панель команд — панель, на которой размещен постоянный набор кнопок вызова команд, объединенных каким-либо признаком (команды построения отрезков, команды копирования, команды приклеивания трехмерных элементов и т.д.).

Расширенная панель появляется при удержании курсора мыши с нажатой левой кнопкой на помеченной маленьким черным треугольником кнопке инструментальной панели.

Расширенная панель команд может быть отделена от инструментальной.

Подробнее о расширенной панели команд см. раздел 1.2.2.1.2.


Направление выдавливания

Элемент может выдавливаться как в одну, так и в другую сторону относительно сечения.

Одно из возможных направлений автоматически определяется системой как Прямое и показывается стрелкой на фантоме элемента в окне модели.

При выборе Прямого направления выдавливание будет производиться по стрелке, при выборе Обратного направления — в противоположную сторону.

Иногда элемент требуется выдавливать в обоих направлениях относительно сечения. В этом случае выберите вариант Два направления.

Еще один вариант — Средняя плоскость. Его выбор означает, что выдавливание будет производиться в обе стороны симметрично относительно сечения.


Глубина выдавливания

Значение, введенное в поле Расстояние, воспринимается системой по-разному в зависимости от выбранного способа определения глубины выдавливания.

Если был выбран вариант На расстояние, введите в это поле глубину выдавливания.

Если был выбран вариант До вершины или До поверхности, введите в это поле расстояние между указанным объектом (вершиной или поверхностью) и «торцем» элемента. Если нужно выдавить объект точно до объекта, введите нулевое расстояние.

Если расстояние до объекта не нулевое, оно может быть отложено как в направлении выдавливания, так и против него.

Чтобы изменить направление отсчета расстояния до вершины, воспользуйтесь переключателем Тип. Изменение направления построения немедленно отражается в фантоме элемента.

Если был выбран вариант Через все или До ближайшей поверхности, то поле для ввода глубины отсутствует на Панели свойств.


Направление уклона

Наружу

При выборе этого варианта сечение элемента увеличивается в направлении выдавливания.

Внутрь

При выборе этого варианта сечение элемента уменьшается в направлении выдавливания.


Способы определения глубины выдавливания

– На расстояние

Выбор этого варианта означает, что выдавливание производится точно на заданное расстояние. Введите его в поле Расстояние.

– Через все

Выбор этого варианта означает, что глубина выдавливания определяется автоматически: выдавливание производится до точки тела, наиболее удаленной от сечения в направлении выдавливания.

Этот вариант недоступен, если в модели нет тел.

Подробнее о выдавливании через все...

– До вершины

Выбор этого варианта означает, что вычисляется такая глубина выдавливания, чтобы торец элемента занял положение, ближайшее к заданной вершине.

Чтобы задать вершину, активизируйте переключатель Вершина и укажите нужный точечный объект в Дереве построения или в окне модели.

Можно отсечь элемент плоскостью, проходящей через указанную вершину перпендикулярно направлению выдавливания. Для этого включите опцию Отсекать.

Торец получившегося элемента может проходить через вершину, «заходить» за вершину или «не доходить» до нее на заданное расстояние.

Подробнее о выдавливании до вершины...

– До поверхности

Выбор этого варианта означает, что элемент выдавливается до заданной поверхности. Торец элемента имеет форму поверхности.

Чтобы задать поверхность, активизируйте переключатель Грань и укажите нужную грань или плоскость в окне модели.

Торец элемента может совпадать с указанной поверхностью, «заходить» за поверхность или «не доходить» до нее на заданное расстояние.

Подробнее о выдавливании до поверхности...

– До ближайшей поверхности

Выбор этого варианта означает, что элемент выдавливается до ближайшей в направлении выдавливании грани (или граней) тела.

Этот вариант недоступен, если в модели нет тел.

Подробнее о выдавливании до ближайшей поверхности...

Корректное построение объекта «Поверхность выдавливания» способами До поверхности и До ближайшей поверхности возможно, только если создаваемая поверхность замкнута, т.е. закрыта с торцов. Для этого сечение поверхности должно быть замкнуто, а на Панели свойств при построении поверхности должна быть включена опция Замкнутая поверхность.


Грань

Грань — примитив, представляющий собой ограниченную ребрами часть поверхности, не содержащую внутри себя других ребер.

Особый случай грани — замкнутая грань, у которой границы отсутствуют (например, сферическая и тороидальная).


Полюс грани

Полюс грани — ребро грани, представляющее собой точку.


Меню Файл (меню Библиотекаря)

Меню Файл
(меню Библиотекаря)

Группа команд позволяет осуществлять операции с файлами текстовых шаблонов.

Команда Создать

Команда Открыть

Команда Закрыть

Команда Сохранить

Команда Сохранить как

Команда Сохранить все

Команда Вставить в документ

Команда Выход


Команда Закрыть (меню Библиотекаря)

Команда Закрыть
(меню Библиотекаря)

Команда позволяет закрыть текущий файл текстовых шаблонов. Если открыт один файл текстовых шаблонов, то после выполнения команды будет закрыт диалог Вставка текста.


Команда Создать... (меню Библиотекаря)

Команда Создать...
(меню Библиотекаря)

Команда позволяет создать новый файл текстовых шаблонов системы КОМПАС-3D. После вызова команды на экране появится стандартный диалог создания файла операционной системы Windows.


Команда Выход (меню Библиотекаря)

Команда Выход
(меню Библиотекаря)

Команда позволяет закрыть диалог Вставка текста.


Команда Открыть... (меню Библиотекаря)

Команда Открыть...
(меню Библиотекаря)

Команда позволяет открыть файл текстовых шаблонов.


Команда Вставить в документ (меню Библиотекаря)

Команда Вставить в документ
(меню Библиотекаря)

Команда позволяет вставить в документ отмеченные шаблоны. После выполнения команды диалог Вставка текста будет закрыт.


Команда Сохранить (меню Библиотекаря)

Команда Сохранить
(меню Библиотекаря)

Команда позволяет сохранить сделанные в файле текстовых шаблонов изменения.


Команда Сохранить все (меню Библиотекаря)

Команда Сохранить все
(меню Библиотекаря)

Команда позволяет сохранить сделанные изменения во всех открытых файлах текстовых шаблонов.


Команда Сохранить как... (меню Библиотекаря)

Команда Сохранить как...
(меню Библиотекаря)

Команда позволяет сохранить файл текстовых шаблонов под другим именем или в другой папке.


Цвет изображения Установленный для слоя

Выбор этого варианта означает, что объекты, расположенные на разных слоях, будут иметь цвета, установленные для этих слоев.


Цвет изображения Установленный для объекта

Выбор этого варианта означает, что объекты будут иметь те цвета, которыми они отображаются на экране.


Цвет изображения Установленный для вида

Выбор этого варианта означает, что объекты, расположенные в разных видах, будут иметь цвета, установленные для этих видов.


Характерные ошибки, возникающие в листовом телепри изменении состояния сгибов

Характерные ошибки, возникающие в листовом теле
при изменении состояния сгибов

В результате применения к листовым элементам команд Разогнуть и Согнуть из контекстного меню в листовом теле могут возникать ошибки. Наиболее характерными являются ошибки двух типов.

1. Вызванные изменением положения элементов детали. Пример...

2. Вызванные «превращением» цилиндрических участков в плоские и наоборот (т.е. собственно разгибанием и сгибанием). Пример...


Меню Формат (меню Библиотекаря)

Меню Формат
(меню Библиотекаря)

Группа команд позволяет задать параметры шрифта текстовых шаблонов, вставляемых в текущий документ. Параметры шрифта будут заданы для выделенного в Окне просмотра фрагмента.

Команда Шрифт

Команда Убрать форматирование


Фрагмент

Фрагмент — документ КОМПАС-3D (расширение фaйлa — frw). Он отличается от чертежа отсутствием элементов оформления. Во фрагменте нет рамки, основной надписи, знака неуказанной шероховатости и технических требований. Фрагмент, как и вид чертежа, может содержать до 2 147 483 647 слоев.

Фрагмент обычно используется для хранения изображений, которые не нужно оформлять как лист чертежа (эскизные прорисовки, разработки и т.д.). Кроме того, во фрагментах удобно сохранять созданные типовые решения и конструкции для последующего использования в других документах. Отметим, что КОМПАС-3D предоставляет возможность ссылаться на файл фрагмента без его физического копирования в документ, при этом после редактирования фрагмента автоматически будет откорректирован и документ, содержащий вставку.


GDI

GDI (Graphics Device Interface или Graphical Device Interface) — интерфейс Microsoft Windows для представления графических объектов и передачи их на устройства отображения, такие как мониторы и принтеры. Отвечает за отрисовку линий и кривых, отображение шрифтов и обработку палитры.

GDI обычно используется в простых видеоиграх, которые не требуют быстрой графики.


Геометрический массив

Геометрический массив — такой массив операций, при создании которого копируются только грани и ребра копируемых объектов.


Геометрический калькулятор

Геометрический калькулятор — механизм получения численной информации о параметрах и взаимном расположении объектов с целью использования ее при построении других объектов.


Меню геометрического калькулятора(для графических объектов)

Меню геометрического калькулятора
(для графических объектов)

Это меню выводится на экран при нажатии правой кнопки мыши в то время, когда курсор находится над каким-либо из полей Панели свойств при выполнении различных команд создания и редактирования объектов. С помощью команд меню можно выполнить снятие значений геометрических величин (координат точек, размеров, углов и т.п.) с объектов для их автоматического занесения в поля Панели свойств.

В зависимости от того, над полем ввода какого параметра находился курсор при вызове меню, будет сформирован подходящий набор команд.

– При вводе значений координат точек доступны следующие команды:

• На пересечении продолжений кривых

• На расстоянии от точки

• На расстояниях от двух кривых

• Выровнять по двум точкам

• Точка кривой, ближайшая к другой кривой

• Условное пересечение

– При вводе значений линейных величин доступны следующие команды:

• Длина кривой

• Длина сегмента кривой

• Между 2 точками

• Между 2 точками на кривой

• Между двумя кривыми

• От точки до кривой

• Радиус

• Диаметр

• Полуось эллипса

• Длина строки текста

• Габарит объекта

– При вводе значений угловых величин доступны следующие команды:

• Направление прямой/отрезка

• Наклон касательной

• Наклон нормали

• Раствор дуги

• Между прямыми/отрезками

• Наклон оси эллипса

• По 2 точкам (с осью X)

• По 3 точкам

• Направление строки текста

• По точке на окружности/дуге

– При вводе значения масштаба доступны следующие команды:

• Отношение длин кривых

• Отношение радиусов

Для вызова нужного способа снятия параметров выберите его название из меню.

Смотрите также

Геометрический калькулятор

Меню локальных привязок


Меню геометрического калькулятора(для трехмерных объектов)

Меню геометрического калькулятора
(для трехмерных объектов)

Это меню выводится на экран при нажатии правой кнопки мыши в то время, когда курсор находится над одним из полей Панели свойств после запуска команд Сгиб, Сгиб по эскизу, Сгиб по линии, Подсечка, Отверстие в листовом теле, расположенных на инструментальной панели Элементы листового тела. С помощью команд меню можно выполнить снятие значений геометрических величин (размеров, углов и т.п.) с объектов для их автоматического занесения в поля Панели свойств.

Набор команд геометрического калькулятора зависит от того, над полем какого параметра находился курсор при вызове контекстного меню.

– При вводе значений линейных величин доступны следующие команды:

• Длина ребра

• Расстояние между 2 объектами

• Диаметр

• Радиус

• Копировать свойство

– При вводе значений угловых величин доступны следующие команды:

• Направление объекта

• Раствор дуги

• Между 2 объектами

• Копировать свойство

Для вызова нужного способа снятия значения параметров выберите его название из меню.

Смотрите также

Геометрический калькулятор


Команды создания геометрических объектов

Кнопки вызова команд создания геометрических объектов находятся инструментальной панели Геометрия.

Точка

Точки по кривой

Точки пересечения двух кривых

Все точки пересечения кривой

Точка на заданном расстоянии

Вспомогательная прямая

Горизонтальная прямая

Вертикальная прямая

Параллельная прямая

Перпендикулярная прямая

Касательная прямая через внешнюю точку

Касательная прямая через точку кривой

Прямая, касательная к двум кривым

Биссектриса

Отрезок

Параллельный отрезок

Перпендикулярный отрезок

Касательный отрезок через внешнюю точку

Касательный отрезок через точку кривой

Отрезок, касательный к двум кривым

Окружность

Окружность по трем точкам

Окружность, касательная к кривой

Окружность с центром на объекте

Окружность, касательная к двум кривым

Окружность, касательная к трем кривым

Окружность по двум точкам

Дуга

Дуга по трем точкам

Дуга, касательная к кривой

Дуга по двум точкам

Дуга по двум точкам и углу раствора

Эллипс

Эллипс по диагонали габаритного прямоугольника

Эллипс по центру и вершине габаритного прямоугольника

Эллипс по центру, середине стороны и вершине описанного параллелограмма

Эллипс по трем вершинам описанного параллелограмма

Эллипс по центру и трем точкам

Эллипс, касательный к двум кривым

Непрерывный ввод объектов

Линия

Мультилиния

Сплайн по точкам

Ломаная

Сплайн по полюсам

Коническая кривая

Фаска

Фаска на углах объекта

Скругление

Скругление на углах объекта

Прямоугольник

Прямоугольник по трем точкам

Многоугольник

Собрать контур

Эквидистанта кривой

Эквидистанта по стрелке

Штриховка

Заливка

Спроецировать объект


Как получить справку при работе

При возникновении затруднительных ситуаций во время работы в системе КОМПАС-3D вы можете быстро получить необходимую справочную информацию. Для этого разработана Справочная система, которая содержит сведения о командах меню и панелях кнопок, клавиатурных комбинациях, типовых последовательностях выполнения различных операций и т.д.

Получить справочную информацию можно одним из следующих способов:

– Вызовите подходящую команду из меню Справка.

– Нажмите клавишу <F1> для получения раздела справки о текущем действии, активном элементе интерфейса, или элементе, на который указывает курсор.

– Нажмите кнопку Что это такое? на Стандартной панели для получения справки по произвольно выбранному элементу.

Курсор мыши изменит свой внешний вид (превратится в вопросительный знак со стрелкой). Укажите интересующий вас элемент (например, команду меню или кнопку).

Вы можете также быстро получить краткую информацию о какой-либо кнопке с помощью всплывающих подсказок (см. раздел Использование всплывающих подсказок).


Оформление документов

В чертежно-графическом редакторе системы КОМПАС-3D при работе с документами (графическими и текстовыми) используется понятие оформления.

Оформление листа включает основную надпись, а также внешнюю и внутреннюю рамки. В оформление листа текстового документа, помимо основной надписи и рамок, входит информация об отступах текста от внутренней рамки.

Оформления листов графических и текстовых документов хранятся в специальных системных библиотеках — файлах с расширением lyt.

Пользователь может редактировать имеющиеся и создавать свои собственные оформления.


Главная центральная система координат

Главная центральная система координат — система координат, начало которой совпадает с центром масс модели и в которой центробежные моменты инерции равны нулю.


Главная ось инерции

Главная ось инерции совпадает с соответствующей осью главной центральной системы координат.


Сетка

Сетка — периодически расположенные на экране точки (или линии) и служит для удобства построений.

Сетка является принадлежностью рабочего окна КОМПАС-3D.

Пользователь может в любой момент включить или выключить отображение сетки в окне и настроить ее параметры (цвет, начертание, шаг).

Изображение сетки никогда не выводится на печать.


Группа

Группа — именованный набор объектов графического документа.

Один и тот же объект может входить в разные группы.


Порядок выполнения экспорта в пакетном режиме

Экспорт производится с помощью специальных прикладных библиотек:

– Библиотека экспорта в DWG (dwglib.rtw),

– Библиотека экспорта в DXF (dxflib.rtw),

– Библиотека экспорта в IGES (igeslib.rtw),

Файлы библиотек находятся в подпапке ..\Libs\ImpExp главной папки системы.

Чтобы экспортировать группу файлов, выполните следующие действия.

1. Вызовите Менеджер библиотек.

2. Добавьте нужную прикладную библиотеку.

3. Запустите добавленную библиотеку и вызовите ее единственную команду — команду записи документа в соответствующий формат.

На экране появится диалог настройки экспорта.

4. Нажмите в нем кнопку Выбрать документ...

5. В появившемся диалоге открытия файлов укажите файлы для записи и нажмите кнопку Открыть. Диалог открытия файлов закроется, а имена указанных файлов появятся в поле Документ диалога настройки экспорта.

6. При необходимости настройте остальные параметры записи и нажмите кнопку Начать запись диалога.

Описанный способ можно применить и для экспорта одного файла, но гораздо удобнее в этом случае воспользоваться командой Файл — Сохранить как...


Порядок выполнения импорта в пакетном режиме

Импорт производится с помощью специальной прикладной библиотеки импорта форматов DWG, DXF (dwgdxfImp.rtw),

Файлы библиотек находятся в подпапке ..\Libs\ImpExp главной папки системы.

Чтобы импортировать группу файлов, выполните следующие действия.

1. Вызовите Менеджер библиотек.

2. Добавьте прикладную библиотеку dwgdxfImp.rtw.

3. Запустите добавленную библиотеку и вызовите из нее нужную команду.

4. В появившемся диалоге укажите файлы для чтения и нажмите кнопку Открыть.

На экране появится диалог настройки импорта документов.

5. Задайте параметры импорта в диалоге и нажмите в нем кнопку Начать запись.

Описанный способ можно применить и для импорта одного файла, но гораздо удобнее в этом случае воспользоваться командой Файл — Открыть.

В пакетном режиме целесообразно импортировать файлы, заведомо имеющие одинаковые настройки (например, полученные из одного источника).


Иерархия защищенных типов загрузки

Если на момент создания нового защищенного типа загрузки сборки (или на момент защиты пользовательского типа загрузки паролем) текущим был другой защищенный тип загрузки, то создаваемый (или защищаемый) тип загрузки становится подчиненным по отношению к текущему, а он, в свою очередь, становится исходным по отношению к создаваемому (или защищаемому).

Удаление подчиненного типа загрузки сборки или его пароля доступно только в случае, если текущим типом загрузки является исходный.


Способ построения отверстия

Группа переключателей Способ построения становится доступной после выбора отверстия.

– Если активен переключатель На глубину, то глубина отверстия равна значению, заданному в таблице параметров.

– Если активен переключатель До вершины, то параметр H исчезает из таблицы. В окне модели требуется указать нужную вершину.

– Если активен переключатель Через все, то параметр H исчезает из таблицы, а глубина отверстия определяется автоматически.


Плоский участок подсечки

Плоский участок подсечки — часть листового тела, расположенная между сгибами подсечки.


Характерная точка

Характерная точка — элемент интерфейса, появляющийся в графической области при создании или редактировании объекта, предназначенный для управления его местоположением или геометрией.


Как подключить собственное меню к ячейке основной надписи

Создайте собственное или отредактируйте системное меню в файле пользовательских меню Graphic.pmn.

– Запомните номер меню, которое требуется подключить к ячейке основной надписи.

– Сохраните и закройте файл Graphic.pmn.

– Войдите в режим редактирования таблицы основной надписи, в ячейке которой требуется подключить меню.

– Установите курсор в ячейку, к которой хотите подключить меню.

– Вызовите команду Формат ячейки.

– В появившемся диалоге нажмите кнопку Далее....

– В поле Запрос при вводе текста в ячейку после текста запроса введите «|» (символ вертикальной черты) и номер подключаемого меню.

– Выйдите из диалогов настройки расширенного формата и настройки формата ячейки, нажав кнопку OK.

– Закройте окно редактирования таблицы, выйдите из диалога редактирования состава основной надписи и диалога работы с основными надписями, подтверждая сохранение внесенных изменений.

Аналогичную настройку расширенного формата нужно производить для каждой ячейки, к которой требуется подключить пользовательское меню. Количество пользовательских меню, подключаемых к ячейкам основной надписи, не ограничено.

Если вы отредактировали меню номер 12 (Фамилии должностных лиц), то перенастраивать ячейки системных основных надписей не требуется: ячейки для фамилий в основных надписях, поставляемых в составе КОМПАС, уже настроены для использования меню номер 12.


IGES

IGES (Initial Graphics Exchange Specification) — базовая спецификация обмена графической информацией.

Данный формат предназначен для обмена информацией между системами САПР и другими векторными приложениями. Разработан и сопровождается организацией IGES/PDES, аккредитованной при ANSI.

Этот формат обмена является стaндapтом де-фaкто для систем САПР и поддерживается практически всеми разработчиками таких программных продуктов. Основная область применения данного формата — передача информации о трехмерных геометрических моделях.


Информационное окно

Это окно появляется на экране в следующих случаях:

– при работе с командами измерения после щелчка мышью по объектам измерения;

– при работе с командой Информация об объекте после щелчка мышью по объекту, сведения о котором требуется получить,

– нажатие кнопки Пересчитать МЦХ при настройке параметров МЦХ модели или компонента,

– появление проблем при загрузке файла задания на печать,

– импортируемый документ формата DXF/DWG содержит объекты, которые невозможно импортировать.

В информационном окне отображаются текущая дата, полное имя активного документа и данные, являющиеся результатом работы системы:

– значения измеренных величин,

– или сведения об объекте,

– или массо-центровочные характеристики модели,

– или перечень проблем, обнаруженных при загрузке задания на печать,

– или полное имя импортируемого документа формата DXF/DWG, перечень объектов этого документа, которые не могут быть импортированы, и причины невозможности импорта.

Информационное окно имеет собственное меню, состоящее из двух пунктов: Файл и Редактор.

Команды меню Файл позволяют сохранить содержимое Информационного окна в текстовом файле (*.txt), распечатать его (без создания файла) или закрыть окно.

Команды меню Редактор позволяют редактировать текст в окне. Например, вы можете изменить используемый по умолчанию шрифт, удалить ненужные сведения, вставить текст из буфера Windows и т.п.

Кроме того, в любое место возможен ввод произвольного текста с клавиатуры.

Так как сведения в Информационном окне обновляются после указания очередного объекта измерения, редактирование текста в окне целесообразно только после завершения измерений.

Кнопка Фиксация в заголовке Информационного окна управляет режимом его автоматического сворачивания.

Двойной щелчок мышью по заголовку окна позволяет перевести его из «плавающего» состояния в фиксированное и обратно.

Кнопка Закрыть позволяет закрыть окно.

При работе с командами измерения и получения информации об объекте закрытие Информационного окна завершает работу команды.


Информационная переменная

Информационная переменная — переменная, значение которой зависит от других переменных, размеров, положения объектов документа. Признаком информационной переменной является желтый или зеленый (если она также является внешней) цвет ячейки с именем переменной в таблице Окна переменных.

Информационные переменные можно использовать в выражениях.


Источник вставки

Источник вставки — документ, в котором было создано и хранится изображение, используемое для вставки.


Меню Вставка (меню Библиотекаря)

Меню Вставка
(меню Библиотекаря)

Группа команд позволяет вставлять в текущий файл текстовых шаблонов новые разделы и шаблоны. В текст шаблона могут быть вставлены различные элементы (дроби, индексы и т.п.).

Команда Раздел

Команда Шаблон

Команда Дробь

Команда Индекс

Команда Над/Подстрока

Команда Спецзнак...

Команда Символ...


Команда Раздел (меню Библиотекаря)

Команда Раздел
(меню Библиотекаря)

Команда позволяет вставить новый раздел. Он будет являться подразделом текущего (выделенного) раздела. По умолчанию вставленному разделу присваивается имя «Новый раздел». Последующим вставляемым разделам присваивается такое же имя с добавлением порядкового номера. Вы можете задать имя нового раздела при вставке или переименовать его позднее.


Команда Шаблон (меню Библиотекаря)

Команда Шаблон
(меню Библиотекаря)

Команда позволяет вставить новый шаблон в текущий (выделенный) раздел. По умолчанию вставленному шаблону присваивается имя «Новый шаблон». Последующим вставляемым шаблонам присваивается такое же имя с добавлением порядкового номера. Вы можете задать имя нового шаблона при вставке или переименовать его позднее.


Направляющие объекты для осей присоединительной точки(способ Ручное задание направления осей)

Направляющие объекты для осей присоединительной точки
(способ Ручное задание направления осей)

В качестве направляющих объектов для осей присоединительной точки могут быть указаны следующие объекты.

– Прямолинейные:

• отрезки в эскизах,

• сегменты ломаных,

• координатные и вспомогательные оси,

• прямолинейные ребра.

Направление, задаваемое прямолинейным объектом — прямая, параллельная объекту.

– Плоские:

• координатные и вспомогательные плоскости,

• плоские грани.

Направление, задаваемое плоским объектом — прямая, перпендикулярная объекту.

– Поверхности вращения.
Направление, задаваемое поверхностью вращения — прямая, параллельная оси вращения.

Обратите внимание на то, что сферу можно использовать в качестве направляющего объекта в том случае, если очечный объект принадлежит ей. Направление, задаваемое сферой — перпендикуляр в точке указания.

Выбор объектов в окне модели

Выбор объектов в Дереве построения

Кроме того, направляющим объектом может служить вектор.


Присоединительная точка

Присоединительная точка — специальный объект, позволяющий задать пространственное положение соединяемых (стыкуемых) элементов трубопровода и направление присоединяемого элемента. Свойствами присоединительной точки являются ее положение в модели, ось, которая задает направление присоединения в этой точке, и дополнительная ось.

Элемент трубопровода может содержать несколько присоединительных точек. Чтобы связать два элемента трубопровода, необходимо совместить их присоединительные точки и оси (или задать углы между осями).


Состояния слоев в документе AutoCAD, экспортированном из КОМПАС

Состояние вида и слоя в КОМПАС-3D определяется сочетанием значений свойств активность и видимость.

Свойство активность имеет значения активный и фоновый, а видимость — видимый и погашенный. В AutoCAD состояние слоя определяется признаками разблокированный/заблокированный и включенный/выключенный, которые по своему действию фактически совпадают с вышеперечисленными значениями свойств слоев и видов в КОМПАС-3D.

Если в КОМПАС-документе слой невидим (т.е. погашен или находится в погашенном виде), то, вне зависимости от значения свойства активность, в документе AutoCAD он будет выключенным и разблокированным.

Если в КОМПАС-документе слой видимый, то в документе AutoCAD он будет включенным. При этом активный слой получает признак разблокированный, а фоновый — заблокированный.


Правило именования результирующих слоев

Слои в документе AutoCAD, полученные в результате объединения слоев КОМПАС-документа (результирующие слои), именуются согласно следующему правилу:

– если имя результирующего слоя уникально для документа, то оно не изменяется,

– если получены одноименные результирующие слои (отличающиеся цветом или состоянием), то к их именам добавляются порядковые номера, начиная с 1.


Правило именования слоев

При размещении объектов на «своих» слоях эти слои (в результирующем документе) именуются по следующему правилу:

– если имя слоя уникально для документа, то оно не изменяется,

– если имеется несколько одноименных слоев, то к их именам добавляются порядковые номера, начиная с 1;

– если слой не имеет имени, то ему присваивается имя «LAYER»,

– если имеется несколько безымянных слоев, то им присваивается имя «LAYER» с добавлением порядкового номера, начиная с 1.

Примеры именования слоев по данному правилу:

В документе AutoCAD в именах слоев не допускается использование следующих символов: < > ^ “ “ : ; ? * / , = ‘.

Если наименование слоя в документе КОМПАС содержит какие-либо из этих символов, то в документе AutoCAD эти символы будут заменены символом ~.


Слой

Слой — логическая группа объектов документа. Слои используются для управления видимостью объектов, в графических документах также для управления возможностью редактирования и печати объектов.

Максимальное количество слоев в документе — 2 147 483 647.

Каждый слой может иметь уникальное название для облегчения поиска.

Один слой документа является текущим — на этом слое автоматически размещаются новые объекты. Возможен перенос объектов между слоями.


Фильтр слоев

Фильтр слоев — динамическая группа слоев, свойства которых соответствуют условиям фильтрации (подробнее см. раздел Фильтр слоев).


Группа слоев

Группа слоев — статический набор слоев, объединенных по какому-либо признаку. Предназначена для одновременного изменения свойств слоев одинаковым образом (подробнее см. раздел 3.6.6.9.1).


Группа свойств слоев

Группа свойств слоев — набор настроек для нескольких слоев. Предназначена для одновременного изменения свойств слоев в соответствии с индивидуальными настройками для каждого слоя (подробнее см. раздел 3.6.6.9.1).


Поле Управление слоями

В поле Управление слоями отображается имя (номер) текущего слоя.

Настройка отображения имени слоя для графических документов

Чтобы сделать текущим другой слой, введите или выберите из списка его имя (номер). При выделении слоя в списке объекты, расположенные на нем, выделяются в окне документа. Это позволяет быстро выбрать нужный слой.

Список Управление слоями в графическом документе

В строках списка кроме имен (номеров) слоев отображаются также значки, позволяющие управлять состоянием слоев, т.е. изменять значения свойств:

– активность, видимость, печать — для графических документов,

– редактируемость, видимость, проецируемость в ассоциативный чертеж — для моделей.

Чтобы поменять значение свойства на противоположное, щелкните мышью на значке. Изменение свойств немедленно отображается на экране.

Активность и видимость текущего слоя для графического документа изменить невозможно.

Для текущего слоя невозможно изменить:

– в графическом документе — активность и видимость,

– в модели — редактируемость и видимость.


Лист чертежа

Лист характеризуется следующими параметрами:

– формат — размер сторон листа; представлен либо списком обозначений стандартных форматов листа от А0 до А5, либо фактическими значениями размеров, если для листа задан пользовательский формат,

– кратность — количество коротких сторон указанного формата в листе (кратность), задается списком значений 1...9; если выбран пользовательский формат листа, значение свойства пустое,

– ориентация — расположение листа на экране, может быть вертикальным или горизонтальным; отображается пиктограммой.

Под форматом может обобщенно пониматься совокупность этих параметров.

Каждый лист отображается в чертеже в виде внешней и внутренней рамок формата с основной надписью. Рамки и основная надпись являются элементами оформления листа.

Листы располагаются в чертеже вплотную друг к другу слева направо в порядке создания. В зависимости от масштаба отображения на экране может быть виден один лист, несколько листов или все листы сразу.


Прикладная библиотека

Прикладная библиотека — приложение, созданное для расширения стандартных возможностей КОМПАС-3D и работающее в его среде. Типичным примером приложения является библиотека стандартных машиностроительных элементов, значительно ускоряющая проектирование сборочных чертежей.

Прикладная библиотека может быть создана в одной из стандартных сред программирования для Windows (Borland C++, Microsoft Visual C++, Borland Pascal и т.д.) с использованием функций специального комплекта разработки приложений КОМПАС-МАСТЕР. Библиотека является динамически подключаемым модулем (DLL). По умолчанию файлы библиотек имеют расширения DLL или RTW.

КОМПАС-3D поддерживает одновременную работу с несколькими подключенными библиотеками. Режимы работы с библиотекой могут быть различными (окно, диалог, меню).

После подключения библиотеки к системе пользователь выбирает нужную функцию из ее каталога и запускает на исполнение.


Библиотека фрагментов

Каждая библиотека фрагментов представляет собой отдельный файл с расширением lfr. Фрагменты библиотеки не являются отдельными файлами на диске, а входят составными частями в единый файл библиотеки. Фрагменты хранятся в виде упорядоченных списков в подразделах и корневом разделе библиотеки. Имена фрагментов и разделов библиотеки могут состоять из любых символов, количество фрагментов и разделов не ограничено.

При создании раздела библиотеки или добавлении фрагмента можно ввести произвольный комментарий.


Выбор функции из библиотеки и ее запуск

Способ выбора и запуска на исполнение библиотечной функции зависит от режима, в котором работает библиотека.

Если используется режим меню, выберите команду с названием библиотеки из меню Библиотеки. При этом раскроется вложенное меню, содержащее функции библиотеки в виде команд (они могут быть сгруппированы по разделам). Для запуска функции на исполнение выберите команду меню с названием этой функции.

Если библиотека работает в режиме диалога, то для запуска библиотечной команды на исполнение выберите ее название в списке (при необходимости развернув нужный раздел библиотеки) и нажмите кнопку ОК. Можно также дважды щелкнуть левой кнопкой мыши на названии команды.

При работе в режиме окна или панели необходимо дважды щелкнуть левой кнопкой мыши на названии нужной библиотечной команды для ее выполнения.


Изменение режима работы с библиотекой

При добавлении библиотеки в Менеджер вы можете установить нужный режим, выбрав соответствующую опцию в диалоге свойств добавляемой библиотеки.

Когда библиотека уже добавлена в Менеджер, для изменения режима ее работы можно использовать команды Меню, Диалог, Окно и Панель из контекстного меню названия библиотеки. Вы можете изменить режим работы как подключенной, так и неподключенной библиотеки. При этом не имеет значения, какой режим установлен для библиотеки в настоящий момент.

Изменение режима возможно и в процессе работы с библиотекой (за исключением случая, когда работа ведется в режиме меню).

Изменение режима работы возможно только для прикладных библиотек; библиотеки моделей *.l3d и библиотеки фрагментов *.lfr имеют только один режим — панель.


Режимы работы с библиотекой

КОМПАС-3D обеспечивает четыре различных режима работы с подключенной библиотекой — окно, диалог, меню и панель. В каждом конкретном случае режим работы выбирается пользователем из соображений удобства. Переключение режима работы с библиотекой может быть выполнено в любой момент, даже во время выполнения какой-либо библиотечной функции.

В режиме меню структура библиотеки отображается в виде стандартного иерархического меню.

Если установлен режим диалога, на экране находится диалоговое окно, в левой части которого отображается список команд текущей библиотеки. Команды могут быть сгруппированы по разделам. В правой части диалога отображаются слайды, облегчающие поиск нужной команды.

Чтобы вернуться к обычной работе с системой, необходимо обязательно завершить диалог библиотеки.

В режиме окна структура библиотеки отображается в стандартном окне Windows. Вы можете изменять размер окна библиотеки, а также сворачивать (минимизировать) его, оставляя на экране только пиктограмму. Основное преимущество режима окна состоит в том, что, в отличие от режимов меню и диалога, библиотека и основная система работают одновременно. Можно динамически переходить от основных команд системы к функциям библиотеки и наоборот.

В режиме панели структура библиотеки представлена на отдельной вкладке в окне Менеджера библиотеке. Вы можете изменять размер любой области вкладки. Преимущество режима панели состоит в возможности просмотра слайдов, соответствующих командам библиотеки. Как и в режиме окна, библиотека и основная система работают одновременно.

Смотрите также

Работа с библиотекой в режиме меню

Работа с библиотекой в режиме диалога

Работа с библиотекой в режиме окна

Работа с библиотекой в режиме панели


Общие сведения о библиотеках

Существует огромное количество деталей и узлов, подобных по форме и отличающихся лишь своими параметрами — размерами.

При работе с КОМПАС-3D вы можете сохранять созданные изображения и модели в файлах, а затем вставлять их в новые документы. Однако это не всегда удобно, так как каждый раз после вставки фрагмента или модели приходится редактировать объект для получения необходимых размеров.

Для упрощения и ускорения разработки чертежей и сборок, содержащих типовые и стандартизованные детали (крепеж, пружины, подшипники, резьбовые отверстия, канавки, элементы электросхем, строительные конструкции и т.п.) очень удобно применять готовые параметрические библиотеки.

Библиотека — это приложение, созданное для расширения стандартных возможностей КОМПАС-3D и работающее в его среде. Типичными примерами приложений являются поставляемая вместе с системой библиотека komlib.rtw (она содержит команды построения изображений часто встречающихся геометрических фигур, гладких и резьбовых отверстий и т.д.), а также Библиотека Стандартные Изделия, значительно ускоряющая проектирование сборочных моделей и оформление сборочных чертежей.

Прикладная библиотека может быть создана в одной из стандартных сред программирования для Windows (Borland C++, Microsoft Visual C++, Borland Pascal и т.д.) с использованием функций специального комплекта разработки приложений КОМПАС-МАСТЕР. По своей архитектуре библиотека является стандартным динамически подключаемым модулем (DLL) Windows. По умолчанию файлы библиотек имеют расширения *.DLL или *.RTW.

В прикладных библиотеках через языковые средства могут использоваться все возможности КОМПАС-3D, предоставляемые при интерактивной работе (создание и редактирование объектов, работа с моделью документа, открытие и сохранение чертежей и фрагментов и т.д.)

Следует отметить, что возможности использования библиотек отнюдь не ограничиваются простым вводом в чертеж параметризованных стандартных элементов. Библиотека может представлять из себя сложную, ориентированную на конкретную задачу подсистему автоматизированного проектирования, которая после выполнения проектных расчетов формирует готовые конструкторские документы или их комплекты. Можно сказать, что в виде прикладных библиотек вполне реально разрабатывать целые СAПP объектов определенного класса.

КОМПАС-3D не накладывает никаких ограничений на размер и сложность функций библиотек, а скорость исполнения библиотечных функций зависит в основном от характеристик компьютера (объем оперативной памяти, скорость доступа к жесткому диску и т.д.).

КОМПАС-3D поддерживает одновременную работу с несколькими подключенными библиотеками. Режимы работы с библиотекой могут быть различными (окно, диалог, меню или панель).

После подключения библиотеки к системе пользователь выбирает нужную функцию из ее каталога и запускает на исполнение.


Ссылка на переменную

Ссылка на переменную — способ задания значения переменной документа, при котором она получает значение переменной другого документа (источника). В модели одно исполнение может служить источником ссылки для другого.


Внешние файлы

– библиотеки оформлений,

– библиотеки фрагментов,

– библиотеки стилей,

– библиотеки типов атрибутов,

– документы-спецификации, подключенные к текущей сборке или чертежу,

– сборки или листы сборочного чертежа, подключенные к текущей спецификации,

– документы, подключенные к объектам спецификации в текущем документе,

– документы, к объектам спецификации в которых подключен текущий документ,

– вставленные фрагменты,

– файлы деталей, связанных с ассоциативными видами,

– файлы деталей и сборок, вставленных в модель в качестве компонентов,

– адреса электронной почты и внешние файлы, на которые сделаны гиперссылки.


Окно Менеджера библиотек

Менеджер библиотек предназначен для управления библиотеками.

Для включения и отключения окна Менеджера библиотек служит команда Сервис — Менеджер библиотек.

Управление состоянием окна Менеджера библиотек

Окно Менеджера библиотек содержит несколько вкладок. На первой из них отображается структура (список разделов) Менеджера библиотек.

Если в разделе имеются подключенные библиотеки, то его пиктограмма отображается серым цветом, если нет — голубым.

На остальных вкладках Менеджера отображается содержимое подключенных на данный момент библиотек фрагментов, моделей и прикладных библиотек, работающих в режиме панели.

Подключенные библиотеки отмечены красной «галочкой» на первой вкладке.

Для работы с Менеджером и с библиотеками предназначены команды контекстных меню вкладок. Команды этих меню описаны в следующих разделах:

Управление Менеджером библиотек

Управление библиотеками


Тип загрузки сборки

Тип загрузки сборки — комбинация типов загрузки компонентов сборки.

В любой сборке доступны системные типы загрузки — Полный, Упрощенный, Габарит, Пустой. При применении к сборке какого-либо системного типа загрузки все ее компоненты получают соответствующий тип загрузки.

При необходимости в сборке можно создать пользовательский тип загрузки — комбинацию полного, упрощенного, габаритного и пустого типов загрузки для разных компонентов; кроме того, в пользовательском типе загрузки сохраняется информация о наличии у компонентов запрета на их редактирование.

Тип загрузки сборки можно защитить паролем (см. раздел 2.12.2.3).

Подробнее о типах загрузки сборки см. раздел 2.12.2.2.


Локальный фрагмент

Локальный фрагмент — фрагмент, созданный и хранящийся внутри другого — главного — документа.

Главный документ может содержать произвольное количество вставок локального фрагмента с разными масштабами и углами поворота.

Изменения, внесенные в локальный фрагмент, немедленно отображаются во всех его вставках.

Локальные фрагменты удобно применять, если изображение, хранящееся во фрагменте, требуется использовать только в одном главном документе.


Замыкание элемента по сечениям

Группа переключателей Режим позволяет указать, требуется ли замыкать элемент по сечениям.

По умолчанию активен переключатель Не замыкать траекторию.

Активизируйте переключатель Замкнуть траекторию, если требуется соединить сечения, которые были указаны первым и последним.

Группа переключателей Режим доступна в том случае, если для создания элемента без осевой линии указано более двух сечений.

Если кроме сечений указана осевая линия, то группа Режим недоступна. При этом в ней активен переключатель, соответствующий конфигурации осевой линии.

Если элемент замкнут, то способ его построения около всех сечений — По умолчанию.


Способ построения элемента у граничных сечений

По умолчанию

Выбор этого способа означает, что элемент будет построен обычным образом: вершины сечений будут соединены сплайнами третьего порядка.

По нормали

Выбор этого способа означает, что элемент будет построен так, чтобы плоскость, касательная к поверхности элемента вблизи граничного (начального или конечного) эскиза, была перпендикулярна его плоскости.

По объекту

Выбор этого способа означает, что элемент будет построен так, чтобы плоскость, касательная к поверхности элемента вблизи граничного эскиза, была параллельна указанному прямолинейному объекту (ребру, вспомогательной оси или прямолинейному отрезку в эскизе) или нормали к указанному плоскому объекту (плоской грани детали или вспомогательной плоскости).

Название указанного объекта отображается в поле Вектор начального/конечного сечения.


Порядок соединения сечений

Активизация переключателя Автоматическая генерация траектории означает, что система автоматически определит, какие точки сечений соединять при построении элемента.

Активизация переключателя Генерация траектории по указанным точкам означает, что эскизы будут соединены по точкам, ближайшим к точкам их указания. Если эскизы указываются в Дереве построения, срабатывает алгоритм автоматической генерации пути.

Если сечения не выпуклые, указывайте траекторию вручную.


Макроэлемент

Макроэлемент — составной объект, воспринимаемый системой как единое целое.


Документ-владелец

Документ-владелец — это графический документ, в который выполнена вставка фрагмента или вида внешней ссылкой. При этом содержимое вставки не копируется физически в главный документ. В нем хранится только ссылка на документ-источник вставки.

Любое изменение в источнике повлечет за собой автоматическую модификацию документа-владельца.


Главное меню

Главное меню системы служит для вызова команд. Вызов некоторых из них возможен также с помощью кнопок Инструментальных панелей.

По умолчанию Главное меню располагается в верхней части окна.

При выборе пункта меню раскрывается перечень команд этого пункта.

Некоторые из команд имеют собственные подменю.

Для вызова команды (выполнения соответствующего ей действия) щелкните мышью на ее названии.


Главный раздел списка переменных

Главный раздел списка переменных — группа переменных документа, которые были созданы пользователем. Эти переменные находятся в верхней части Окна переменных, на первом уровне списка.

Переменную главного раздела можно создать в нем непосредственно (см. раздел 7.1.2.1). При вводе выражения (см. раздел 7.1.3.3), содержащего отсутствующие в документе переменные, эти переменные автоматически создаются в главном разделе.


Вспомогательные оси

Чтобы выполнить операции построения вспомогательных конструктивных осей, вы можете вызвать команды из группы Операции — Ось.

Кнопки для вызова этих команд находятся на панели Вспомогательная геометрия.

Ось через две вершины

Ось на пересечении плоскостей

Ось конической поверхности

Ось через ребро

Ось через вершину по объекту

Созданные при помощи этих команд оси отображаются в окне модели в виде отрезков, а в Дереве построения — в виде специальной пиктограммы.

Пиктограмма вспомогательной оси в Дереве построения

Отрезок, изображающий ось, немного выступает за пределы объектов, на которых базировалось построение этой оси. Иногда для понимания расположения оси требуется, чтобы символизирующий ее отрезок был больше (меньше) или был расположен в другом месте оси (прямой линии). Вы можете изменить размер и положение этого отрезка, перетаскивая мышью его характерные точки (они появляются, когда ось выделена).

Смотрите также

Вспомогательные плоскости


Вспомогательные плоскости

Чтобы выполнить операции построения вспомогательных плоскостей, вы можете вызвать команды из группы Операции — Плоскость.

Кнопки для вызова этих команд находятся на панели Вспомогательная геометрия.

Смещенная плоскость

Плоскость через три вершины

Плоскость под углом к другой плоскости

Плоскость через ребро и вершину

Плоскость через плоскую кривую

Плоскость через вершину параллельно другой плоскости

Плоскость через вершину перпендикулярно ребру

Нормальная плоскость

Касательная плоскость

Плоскость, касательная к грани в точке

Плоскость через ребро параллельно/перпендикулярно другому ребру

Плоскость через ребро параллельно/перпендикулярно грани

Средняя плоскость

Созданные при помощи этих команд плоскости отображаются в окне модели в виде прямоугольников, а в Дереве построения — в виде специальной пиктограммы.

Пиктограмма вспомогательной плоскости в Дереве построения

Прямоугольник, изображающий плоскость, немного выступает за пределы объектов, на которых базировалось построение этой плоскости. Иногда для понимания расположения плоскости требуется, чтобы символизирующий ее прямоугольник был больше (меньше) или был расположен в другом месте плоскости. Вы можете изменить размер и положение этого прямоугольника, перетаскивая мышью его характерные точки (они появляются, когда плоскость выделена).

Смотрите также

Вспомогательные оси


Команды простановки обозначений в графическом документе или эскизе

Кнопки вызова команд простановки обозначений в графическом документе или эскизе находятся на инструментальной панели Обозначения.

Ввод текста

Ввод таблицы

Шероховатость

База

Линия-выноска

Знак клеймения

Знак маркировки

Знак изменения

Обозначение позиции

Выровнять позиции по вертикали

Выровнять позиции по горизонтали

Допуск формы

Линия разреза/сечения

Стрелка взгляда

Выносной элемент

Осевая линия по двум точкам

Автоосевая

Обозначение центра

Волнистая линия

Линия с изломами

Условное пересечение

Команды Шероховатость и База доступны, только если в документе уже есть какие-либо графические объекты.


Команды наложения сопряжений

Команды наложения сопряжений расположены в меню Операции.

Кнопки вызова этих команд расположены на панели Сопряжения.

Позиционирующие сопряжения:

Параллельность

Перпендикулярность

На расстоянии

Под углом

Касание

Соосность

Совпадение

Механические сопряжения:

Вращение – вращение

Вращение – перемещение

Кулачок – толкатель


Особенности задания свойств материала в модели

При выборе материала и задании ему свойств необходимо учитывать следующие особенности.

– Если настраивается тело, то выбранный материал считается собственным материалом этого тела.

– Если настраивается модель (деталь или сборка), то выбранный материал применяется только к телам, созданным в этой модели (не к компонентам!), причем к тем из них, которым не задан собственный материал.

– Если настраивается компонент модели, то выбор материала имеет смысл, только если этот компонент — деталь. Заданные свойства материала применяются к тем ее телам, которым не задан собственный материал.

Свойства материала — плотность и параметры штриховки, в том числе и заданные вручную — сохраняются вместе с материалом в модели и применяются к телам моделей и компонентов по приведенным выше правилам.

Параметры штриховки могут быть использованы на разрезах/сечениях в ассоциативных видах чертежей.


Панель Материал

Находится на Панели свойств при настройке свойств объекта.

Позволяет выбрать материал из списка или внешнего Справочника Материалы и Сортаменты (Справочник должен быть подключен к системе КОМПАС-3D), а также задать свойства материала — плотность и параметры штриховки для отображения в ассоциативных чертежах по модели.

В таблице содержатся свойства материала и их значения, которые можно настроить.

При настройке свойств тел элементы управления панели Материал доступны, если в группе Способ определения МЦХ активен переключатель Расчет по плотности.

Описание элементов управления

Наименование

Описание

Выбрать материал из списка

Нажмите эту кнопку, чтобы выбрать материал из справочного файла плотностей, который используется системой КОМПАС-3D по умолчанию. На экране появляется диалог выбора плотности материала.

При выборе материала плотность и стиль штриховки задаются автоматически.

Выбрать материал из справочника

Нажмите эту кнопку, чтобы выбрать материал из Справочника Материалы и Сортаменты. Запускается процесс выбора материала из Справочника.

При выборе материала плотность задается автоматически.

Удалить

Нажмите эту кнопку, чтобы удалить обозначение материала, отображающееся в ячейке Значение.

Если обозначение материала модели удалено, то соответствующая графа основной надписи чертежа, содержащего ассоциативные виды этой модели, остается пустой.

Выбор из справочника

Переключатель доступен, если выбран способ Расчет по плотности и заполнено поле Обозначение материала.

Активизируйте этот переключатель, чтобы значение плотности материала было взято из справочного файла плотностей или Справочника Материалы и Сортаменты (в зависимости от того, откуда был выбран материал) и отображено в поле Плотность.

Ручной ввод

Переключатель доступен, если выбран способ Расчет по плотности и заполнено поле Обозначение материала.

Активизируйте этот переключатель, чтобы задать значение плотности вручную. Поле Плотность становится доступно для ввода числового значения.

Таблица содержит следующие поля:

Обозначение материала

Поле обозначения материала. Заполняется автоматически после выбора материала. Недоступно для ручного ввода.

Удаление обозначение материала производится нажатием кнопки Удалить.

Обозначение материала передается в основную надпись чертежа при создании в нем ассоциативного вида детали (если этот вид первый в порядке вставки в чертеж).

Плотность, г/мм3

Поле плотности материала. Заполняется автоматически после выбора материала. Доступно для ручного ввода, если выбран способ Расчет по плотности и активен переключатель Ручной ввод либо удалено обозначение материала.

Плотность материала используется при вычислении массо-центровочных характеристик детали при расчете по плотности. При расчете по массе значение является справочным.

Стиль штриховки

Поле стиля штриховки. Заполняется автоматически после выбора материала. В поле доступен выбор стиля из списка.

Стиль, цвет и угол штриховки передается в чертеж при создании разреза/сечения в ассоциативном виде чертежа.

Цвет штриховки

Поле цвета штриховки. По умолчанию отображается цвет, заданный в стиле штриховки (для системных стилей — черный). В поле доступна смена цвета.

Цвет штриховки передается в чертеж при создании разреза/сечения в ассоциативном виде чертежа.

Угол штриховки

Поле угла штриховки. В поле доступен выбор значений из списка или ввод вручную.

Угол штриховки передается в чертеж при создании разреза/сечения в ассоциативном виде чертежа.

На панели Материал выполните следующие действия.

1. Выберите материал при помощи кнопки Выбрать материал из списка или Выбрать материал из справочника.

2. Если требуется задать плотность вручную, нажмите кнопку Ручной ввод и введите значение.

3. Чтобы сменить параметры штриховки, щелкните мышью по нужной ячейке и задайте значение.

Особенности задания свойств материала в модели...


Работа с прикладной библиотекой в режиме меню

В этом режиме структура библиотеки отображается в виде стандартного иерархического меню.

Название библиотеки отображается в виде команды в меню Библиотеки. При вызове этой команды раскрывается вложенное меню, содержащее функции библиотеки в виде команд (они могут быть сгруппированы по разделам).

Для запуска функции на исполнение выберите из меню Библиотеки команду меню с названием нужной функции.


Минимальная длина фигурной скобки

Минимальная длина фигурной скобки рассчитывается по формуле

L=4*R/M, где

R — радиус закругления фигурной скобки,

M — масштаб вида, в котором располагается скобка.

Если фигурная скобка создается в виде с масштабом 1:1 или во фрагменте, то L=4*R.


Команды редактирования модели сборки

Кнопки вызова команд редактирования модели сборки расположены на панели Редактирование модели.

Операция вращения

Кинематическая операция

Операция по сечениям

Деталь-заготовка

Добавить компоновочную геометрию

Придать толщину

Вырезать выдавливанием

Вырезать вращением

Вырезать кинематически

Вырезать по сечениям

Фаска

Скругление

Круглое отверстие

Отверстие из библиотеки

Ребро жесткости

Уклон

Оболочка

Сечение поверхностью

Сечение по эскизу

Булева операция

Масштабирование


Направление сдвига

Направление сдвига — линия, вдоль которой сдвигаются друг к другу видимые части изображения при создании разрыва вида.


Многолистовой чертеж

Многолистовой чертеж — конструкторский документ, содержащий несколько листов с единым обозначением, наименованием и сквозной нумерацией.

Многолистовой чертеж обладает следующими свойствами:

– по умолчанию оформление первого листа машиностроительного чертежа — «Чертеж конструкторский. Первый лист», а остальных — «Чертеж конструкторский. Последующие листы»,

– обозначение документа, введенное на одном листе, автоматически передается на остальные листы,

– по умолчанию используется сквозная нумерация листов и пунктов технических требований,

– если включен режим разбиения чертежа на зоны, то чертеж разбивается на зоны,

– вне зависимости от количества листов чертеж может содержать только один знак неуказанной шероховатости и только одни технические требования.

Все листы многолистового чертежа записываются в один файл *.cdw.


Одновременная работа с несколькими библиотеками

КОМПАС-3D позволяет подключить и использовать при работе с документами до двадцати пяти прикладных библиотек одновременно. Однако следует помнить, что каждое подключение библиотеки приводит к уменьшению свободных системных ресурсов.

Список всех подключенных библиотек отображается в виде команд в меню Библиотеки. Чтобы перейти к работе с какой-либо библиотекой, достаточно выбрать команду с ее названием из этого меню.

Наиболее удобно при работе с несколькими библиотеками установить для каждой из них режим окна или панели. Тогда вы сможете видеть окна библиотек одновременно с окном документа и быстро переключаться между ними.

Если некоторые библиотеки не нужны в данный момент, но вы не хотите отключать их от системы, освободите место на экране, минимизируя окна этих библиотек. Когда они вновь понадобятся, вы сможете быстро восстановить нормальное отображение окон и обратиться к библиотечным функциям.


Измерение способом По нормали к ‘Поверхности 1‘

Чтобы измерение было выполнено указанным способом, следует нажать переключатель По нормали к ‘Поверхности 1‘.

Укажите в окне документа-модели поверхность, от которой будут измеряться расстояния. Наименование объекта появится в поле Поверхность 1.

Укажите вторую поверхность. Наименование объекта появится в поле Поверхность 2.

Координатная или вспомогательная плоскость может быть выбрана только в качестве второй поверхности.

Выбор объектов в окне модели


Нормаль грани (плоскости, поверхности)

Нормаль грани — вектор, перпендикулярный плоскости или касательной плоскости в заданной точке грани.

Нормали граней тела всегда направлены наружу по отношению к телу.

Нормаль плоскости и грани поверхности имеет одно из двух возможных направлений, определяемое порядком и способом построения плоскости или поверхности.


Кривая NURBS

Кривая NURBS (Non-Uniform Rational B-Spline) — неоднородный рациональный В-сплайн.

Кривая, состоящая из гладко состыкованных участков, описанных полиномами. Определяется следующими параметрами: набором контрольных точек, называемых полюсами, и порядком NURBS. Конфигурация кривой зависит от положения и веса ее контрольных точек.


Объекты, использующие систему координат

Объектами, параметры которых задаются в определенной системе координат, являются следующие:

– точка,

– ломаная,

– сплайн,

– ЛСК,

– дуга окружности,

– эскиз,

– группа точек по кривой, по поверхности, из файла,

– поверхность по сети точек, по пласту точек.

При построении этих объектов их параметры задаются в текущей на момент построения системе координат. Между объектами и системой координат формируется связь. Кроме перечисленных объектов, с текущей системой координат связываются детали-заготовки, а также импортированные поверхности.

Подробнее о системе координат объекта...


Система координат объекта

Система координат объекта — система координат, относительно которой задано положение или ориентация объекта модели. Первоначально системой координат объекта является та, которая была текущей во время его создания. При необходимости объект можно перенести из его системы координат в другую (см. раздел 2.8.3.4.2).

Объект постоянно сохраняет связь со своей системой координат: перемещается при ее перемещении, исключается из расчета при ее исключении и удаляется при ее удалении.

Подробнее о системе координат объекта см. раздел 2.8.3.4.1.


Указание объектов

Указание объектов требуется во время выполнения некоторых команд. Например, для построения кинематического элемента необходимо указать его траекторию; для построения параллельного отрезка необходимо указать прямолинейный объект, которому должен быть параллелен создаваемый отрезок.

Цвета, используемые для подсвечивания, задаются при настройке редактирования графических и трехмерных объектов.


Таблица свойств объектов

Таблица свойств занимает основную часть окна Свойства. В ней отображаются текущие свойства выделенных объектов. Пользователь может просматривать и изменять значения свойств.

Таблица свойств состоит из двух колонок. В первой показываются названия свойств, а во второй — значения свойств. Если у нескольких выделенных объектов различные значения одного и того же свойства, то в таблице отображается только название этого свойства.

Если на инструментальной панели окна Свойства активизирован переключатель Группировка, то свойства в таблице разбиваются на группы. По умолчанию группы показываются развернутыми, т.е. в таблице видно содержимое групп — входящие в них свойства. Чтобы свернуть группу, оставив в таблице лишь ее название, щелкните мышью на значке минуса слева от названия группы. Повторный щелчок на этом символе (после сворачивания группы он отображается как плюс) приведет к развертыванию группы.

Если на инструментальной панели окна Свойства активизирован переключатель Сортировка, то свойства в таблице сортируются по названиям в алфавитном порядке.

Свойства, являющиеся значениями длин (длина отрезка, радиус окружности и т.п.) и координат точек отображаются с учетом текущих единиц измерения длин.

Особенности работы в документах-моделях

Особенности работы в графических документах

Копирование свойств в графическом документе

Свойства, изменение которых в данный момент не имеет смысла, недоступны. Например, выделена штриховка с типом заполнения Область. Свойства Ширина полосы и Расположение штриховки относительно контура отображаются в таблице свойств, но изменение их значений невозможно. Эти свойства становятся доступны после смены значения свойства Тип заполнения с Область на Полоса.

Кроме того, недоступно изменение свойства Обозначение для стрелок взгляда, выносных элементов, линий разреза/сечения и баз, если при их создании или редактировании была включена автосортировка для букв в обозначении.

Обратите внимание на следующие особенности отображения свойств объектов в чертеже.

– Свойство Слой объекта, а также свойства, являющиеся значениями координат и углов, доступны, если выделенные объекты принадлежат одному виду.

– Значения координат и углов измеряются в системе координат вида, содержащего выделенные объекты, или в его текущей локальной системе координат (если она есть) — даже в случае, если вид, которому принадлежат выделенные объекты, не является текущим в данный момент времени.


Выделение объектов

Выделение объектов часто требуется перед выполнением какой-либо команды. Например, для построения формообразующего трехмерного элемента необходимо выделить его эскиз; для получения копии графического объекта необходимо выделить исходный графический объект.

Цвета, используемые для выделения, задаются при настройке редактирования графических и трехмерных объектов.


Объект спецификации

Объект спецификации — строка или несколько следующих друг за другом строк спецификации, относящихся к одному материальному объекту.

Для базовых объектов предусмотрена возможность автоматического заполнения колонок, сортировки внутри раздела, подключения графического документа (например, рабочего чертежа детали), ввода дополнительных параметров и т.д.

В отличие от базового для вспомогательного объекта не предусмотрены сервисные функции, выполнение которых обеспечивает спецификация. Его используют, например, для ввода произвольных текстов (комментариев) в строку спецификации или для создания пустой строки в середине раздела.


Объект таблицы изменений

Объект таблицы изменений — строка или несколько следующих друг за другом строк таблицы изменений, относящихся к одному изменению.


Внутренний объект спецификации в сборке

Внутренний объект спецификации в сборке — объект, который не передается в другую сборку при вставке в нее данной сборки в качестве подсборки.

При вставке в сборку компонентов (деталей и подсборок) происходит автоматическое формирование ее внутренних объектов спецификации: в сборку передаются объекты спецификации, принадлежащие компонентам.

Пользователь может дополнить набор внутренних объектов спецификации, создавая новые объекты, не связанные с внешними файлами, а также отредактировать внутренние объекты, автоматически сформированные системой.

Внутренние объекты спецификации из сборки передаются в чертеж (при создании ассоциативных видов этой сборки) и в спецификацию (при подключении к ней документа-сборки).


Внешний объект спецификации в сборке

Внешний объект спецификации в сборке — объект спецификации, предназначенный для передачи в те сборки, в которые данная сборка войдет в качестве подсборки.

Внешние объекты спецификации формируются пользователем. Они могут принадлежать любым разделам спецификации: «Сборочные единицы», «Детали», «Стандартные изделия» и др. При вставке сборки в другую сборку ее внешние объекты спецификации попадают в те разделы спецификации главной сборки, в которых они были созданы.


Открытое ребро

Открытое ребро — ребро тела с нарушенной целостностью или поверхности, расположенное на границе грани, а не на стыке граней.


OpenGL

OpenGL (Open Graphics Library — открытая графическая библиотека) — спецификация, определяющая программный интерфейс для написания приложений, использующих двумерную и трехмерную компьютерную графику.

Включает функции для рисования сложных трехмерных сцен из простых объектов. Используется при создании видеоигр, САПР, виртуальной реальности, визуализации в научных исследованиях.


Операция

Операция — способ создания или изменения объекта.


Инструментальная панель Массивы

Панель, на которой расположены кнопки вызова команд создания массивов объектов.

По умолчанию панель Массивы включена в состав компактной инструментальной панели.

Для активизации панели Массивы нажмите одноименную кнопку переключения на компактной панели.

Если указанной кнопки переключения на компактной панели нет, это означает, что панель Массивы была исключена из нее. В этом случае для отображения на экране панели Массивы следует вызвать команду Вид — Панели инструментов — Массивы.


Компактная панель

Компактная панель — панель, на которой расположены кнопки переключения между инструментальными панелями и кнопки самих инструментальных панелей.

По умолчанию окно КОМПАС-3D содержит системную компактную панель. Состав этой панели изменяется в зависимости от типа активного документа.

При необходимости вы можете создать произвольное количество пользовательских компактных панелей. Их состав не изменяется при переходе к другому типу документа.

Подробнее о компактных панелях см. раздел 1.2.2.1.1.


Панель Текущее состояние

Панель, на которой отображаются параметры текущего состояния активного документа.

Набор полей и кнопок панели Текущее состояние зависит от того, какой документ активен.

Для включения отображения ее на экране служит команда Вид — Панели инструментов — Текущее состояние.

Панель Текущее состояние при работе с графическими документами


Инструментальная панель Пространственные кривые

Панель, на которой расположены кнопки вызова команд построения пространственных кривых.

По умолчанию панель Пространственные кривые включена в состав компактной инструментальной панели.

Для активизации панели Пространственные кривые нажмите одноименную кнопку переключения на компактной панели.

Если указанной кнопки переключения на компактной панели нет, это означает, что панель Пространственные кривые была исключена из нее. В этом случае для отображения на экране панели Пространственные кривые следует вызвать команду Вид — Панели инструментов — Пространственные кривые.


Инструментальная панель Размеры

Панель, на которой расположены кнопки вызова команд простановки размеров.

По умолчанию панель Размеры включена в состав компактной инструментальной панели.

Для активизации панели Размеры нажмите одноименную кнопку переключения на компактной панели.

Если указанной кнопки переключения на компактной панели нет, это означает, что панель Размеры была исключена из нее. В этом случае для отображения на экране панели Размеры следует вызвать команду Вид — Панели инструментов — Размеры.

Некоторые кнопки сгруппированы по типам команд, которые они вызывают, например, группа кнопок для построения линейных размеров. На панели отображается только одна кнопка из группы. Чтобы увидеть остальные кнопки группы и выбрать одну из них, нужно нажать на видимую кнопку группы и не отпускать кнопку мыши.

Через секунду рядом с курсором появится панель, содержащая остальные кнопки для вызова команд выбранного типа (расширенная панель команд). По-прежнему не отпуская кнопку мыши, переместите курсор на кнопку вызова нужной команды. Отпустите кнопку мыши. При этом выбранная кнопка появится на Инструментальной панели, а соответствующая ей команда будет активизирована. Кнопки, позволяющие вызвать расширенную панель команд, отмечены маленьким черным треугольником в правом нижнем углу.

Расширенная панель команд может быть преобразована в отдельную панель, имеющую обобщенный заголовок.


Инструментальная панель Редактирование

Панель, на которой расположены кнопки вызова команд редактирования геометрических объектов.

По умолчанию панель Редактирование включена в состав компактной инструментальной панели.

Для активизации панели Редактирование нажмите одноименную кнопку переключения на компактной панели.

Если указанной кнопки переключения на компактной панели нет, это означает, что панель Редактирование была исключена из нее. В этом случае для отображения на экране панели Редактирование следует вызвать команду Вид — Панели инструментов — Редактирование.

Кнопки сгруппированы по типам команд, которые они вызывают, например, группа кнопок для копирования объектов. На панели отображается только одна кнопка из группы. Чтобы увидеть остальные кнопки, нужно нажать на видимую кнопку группы и не отпускать кнопку мыши.

Через секунду рядом с курсором появится панель, содержащая остальные кнопки для вызова команд выбранного типа (расширенная панель команд). По-прежнему не отпуская кнопку мыши, переместите курсор на кнопку вызова нужной команды. Отпустите кнопку мыши. При этом выбранная кнопка появится на Инструментальной панели, а соответствующая ей команда будет активизирована. Кнопки, позволяющие вызвать расширенную панель команд, отмечены маленьким черным треугольником в правом нижнем углу.

Расширенная панель команд может быть преобразована в отдельную панель, имеющую обобщенный заголовок.


Инструментальная панель Редактирование сборки

Панель, на которой расположены кнопки вызова команд выполнения операций в сборке.

По умолчанию панель Редактирование сборки включена в состав компактной инструментальной панели.

Для активизации панели Редактирование сборки нажмите одноименную кнопку переключения на компактной панели.

Если указанной кнопки переключения на компактной панели нет, это означает, что панель Редактирование сборки была исключена из нее. В этом случае для отображения на экране данной панели вызовите команду Вид — Панели инструментов — Редактирование сборки.

При работе с деталью панель Редактирование сборки по умолчанию скрыта. Вы можете включить отображение панели, как описано выше.

Кнопки сгруппированы по типам команд, которые они вызывают, например, группа кнопок для поворота компонента. На панели отображается только одна кнопка из группы. Чтобы увидеть остальные кнопки, нужно нажать на видимую кнопку группы и не отпускать кнопку мыши.

Через секунду рядом с курсором появится панель, содержащая остальные кнопки для вызова команд выбранного типа (расширенная панель команд). По-прежнему не отпуская кнопку мыши, переместите курсор на кнопку вызова нужной команды. Отпустите кнопку мыши. При этом выбранная кнопка появится на Инструментальной панели, а соответствующая ей команда будет активизирована. Кнопки, позволяющие вызвать расширенную панель команд, отмечены маленьким черным треугольником в правом нижнем углу.

Расширенная панель команд может быть преобразована в отдельную панель, имеющую обобщенный заголовок.


Инструментальная панель Редактирование модели

Панель, на которой расположены кнопки вызова команд редактирования моделей сборок.

По умолчанию панель Редактирование модели включена в состав компактной инструментальной панели.

Для активизации панели Редактирование модели нажмите одноименную кнопку переключения на компактной панели.

Если указанной кнопки переключения на компактной панели нет, это означает, что панель Редактирование модели была исключена из нее. В этом случае для отображения на экране панели Редактирование модели следует вызвать команду Вид — Панели инструментов — Редактирование модели.

Кнопки сгруппированы по типам команд, которые они вызывают, например, группа кнопок для построения массивов. На панели отображается только одна кнопка из группы. Чтобы увидеть остальные кнопки, нужно нажать на видимую кнопку группы и не отпускать кнопку мыши.

Через секунду рядом с курсором появится панель, содержащая остальные кнопки для вызова команд выбранного типа (расширенная панель команд). По-прежнему не отпуская кнопку мыши, переместите курсор на кнопку вызова нужной команды. Отпустите кнопку мыши. При этом выбранная кнопка появится на Инструментальной панели, а соответствующая ей команда будет активизирована. Кнопки, позволяющие вызвать расширенную панель команд, отмечены маленьким черным треугольником в правом нижнем углу.

Расширенная панель команд может быть преобразована в отдельную панель, имеющую обобщенный заголовок.


Инструментальная панель Редактирование детали

Панель, на которой расположены кнопки вызова команд редактирования моделей деталей.

По умолчанию панель Редактирование детали включена в состав компактной инструментальной панели.

Для активизации панели Редактирование детали нажмите одноименную кнопку переключения на компактной панели.

Если указанной кнопки переключения на компактной панели нет, это означает, что панель Редактирование детали была исключена из нее. В этом случае для отображения на экране панели Редактирование детали следует вызвать команду Вид — Панели инструментов — Редактирование детали.

Кнопки сгруппированы по типам команд, которые они вызывают, например, группа кнопок для построения массивов. На панели отображается только одна кнопка из группы. Чтобы увидеть остальные кнопки, нужно нажать на видимую кнопку группы и не отпускать кнопку мыши.

Через секунду рядом с курсором появится панель, содержащая остальные кнопки для вызова команд выбранного типа (расширенная панель команд). По-прежнему не отпуская кнопку мыши, переместите курсор на кнопку вызова нужной команды. Отпустите кнопку мыши. При этом выбранная кнопка появится на Инструментальной панели, а соответствующая ей команда будет активизирована. Кнопки, позволяющие вызвать расширенную панель команд, отмечены маленьким черным треугольником в правом нижнем углу.

Расширенная панель команд может быть преобразована в отдельную панель, имеющую обобщенный заголовок.


Инструментальная панель Сплайновая форма

Панель, на которой расположены кнопки вызова команд редактирования грани детали, преобразованной в сплайновую поверхность.

Данная панель не включена в состав компактной инструментальной панели по умолчанию.

Чтобы кнопка активизации панели Сплайновая форма появилась на компактной панели необходимо вызвать команду Сплайновая форма, нажав соответствующую ей кнопку на панели Поверхности. При этом система переходит в специальный режим редактирования грани.


Инструментальная панель Фильтры

Панель, на которой расположены кнопки вызова команд фильтров объектов.

По умолчанию панель Фильтры включена в состав компактной инструментальной панели.

Для активизации панели Фильтры нажмите одноименную кнопку переключения на компактной панели.

Если указанной кнопки переключения на компактной панели нет, это означает, что панель Фильтры была исключена из нее. В этом случае для отображения на экране панели Фильтры следует вызвать команду Вид — Панели инструментов — Фильтры.


Инструментальная панель Форматирование

Панель, на которой расположены кнопки вызова команд форматирования текста.

По умолчанию панель Форматирование включена в состав компактной инструментальной панели.

Для активизации панели Форматирование нажмите одноименную кнопку переключения на компактной панели.

Если указанной кнопки переключения на компактной панели нет, это означает, что панель Форматирование была исключена из нее. В этом случае для отображения на экране панели Форматирование следует вызвать команду Вид — Панели инструментов — Форматирование.


Инструментальная панель Геометрия

Панель, на которой расположены кнопки вызова команд построения геометрических объектов.

По умолчанию панель Геометрия включена в состав компактной инструментальной панели.

Для активизации панели Геометрия нажмите одноименную кнопку переключения на компактной панели.

Если указанной кнопки переключения на компактной панели нет, это означает, что панель Геометрия была исключена из нее. В этом случае для отображения на экране панели Геометрия следует вызвать команду Вид — Панели инструментов — Геометрия.

Кнопки сгруппированы по типам команд, которые они вызывают, например, группа кнопок для построения отрезка. На панели отображается только одна кнопка из группы. Чтобы увидеть остальные кнопки, нужно нажать на видимую кнопку группы и не отпускать кнопку мыши.

Через секунду рядом с курсором появится панель, содержащая остальные кнопки для вызова команд выбранного типа (расширенная панель команд). По-прежнему не отпуская кнопку мыши, переместите курсор на кнопку вызова нужной команды. Отпустите кнопку мыши. При этом выбранная кнопка появится на Инструментальной панели, а соответствующая ей команда будет активизирована. Кнопки, позволяющие вызвать расширенную панель команд, отмечены маленьким черным треугольником в правом нижнем углу.

Расширенная панель команд может быть преобразована в отдельную панель, имеющую обобщенный заголовок.


Инструментальная панель Глобальные привязки

Панель, на которой расположены кнопки управления глобальными привязками в текущем окне.

Для включения отображения ее на экране служит команда Вид — Панели инструментов — Глобальные привязки.


Инструментальная панель Вставка в текст

Панель, на которой расположены кнопки вызова команд вставки в текст различных объектов.

По умолчанию панель Вставка в текст включена в состав компактной инструментальной панели.

Для активизации панели Вставка в текст нажмите одноименную кнопку переключения на компактной панели.

Если указанной кнопки переключения на компактной панели нет, это означает, что панель Вставка в текст была исключена из нее. В этом случае для отображения на экране панели Вставка в текст следует вызвать команду Вид — Панели инструментов — Вставка в текст.


Инструментальная панель Локальные привязки

Панель, на которой расположены кнопки управления локальными привязками при построении текущего графического объекта.

Панель образуется при перемещении мышью меню кнопки Локальные привязки, находящейся на панели Глобальные привязки.

Кнопка Локальные привязки на панели Глобальные привязки доступна после запуска команды создания или редактирования объекта.


Инструментальная панель Элементы оформления

Панель, на которой расположены кнопки вызова команд простановки размеров и создания условных обозначений.

По умолчанию панель Элементы оформления включена в состав компактной инструментальной панели.

Для активизации панели Элементы оформления нажмите одноименную кнопку переключения на компактной панели.

Если указанной кнопки переключения на компактной панели нет, это означает, что панель Элементы оформления была исключена из нее. В этом случае для отображения на экране панели Элементы оформления вызовите команду Вид — Панели инструментов — Элементы оформления.


Инструментальная панель Обозначения

Панель, на которой расположены кнопки вызова команд простановки обозначений.

По умолчанию панель Обозначения включена в состав компактной инструментальной панели.

Для активизации панели Обозначения нажмите одноименную кнопку переключения на компактной панели.

Если указанной кнопки переключения на компактной панели нет, это означает, что панель Обозначения была исключена из нее. В этом случае для отображения на экране панели Обозначения следует вызвать команду Вид — Панели инструментов — Обозначения.

Некоторые кнопки сгруппированы по типам команд, которые они вызывают, например, группа кнопок для построения линий-выносок. На панели отображается только одна кнопка из группы. Чтобы увидеть остальные кнопки группы и выбрать одну из них, нужно нажать на видимую кнопку группы и не отпускать кнопку мыши.

Через секунду рядом с курсором появится панель, содержащая остальные кнопки для вызова команд выбранного типа (расширенная панель команд). По-прежнему не отпуская кнопку мыши, переместите курсор на кнопку вызова нужной команды. Отпустите кнопку мыши. При этом выбранная кнопка появится на Инструментальной панели, а соответствующая ей команда будет активизирована. Кнопки, позволяющие вызвать расширенную панель команд, отмечены маленьким черным треугольником в правом нижнем углу.

Расширенная панель команд может быть преобразована в отдельную панель, имеющую обобщенный заголовок.


Инструментальная панель Обозначения для строительства

Панель, на которой расположены кнопки вызова команд простановки обозначений для строительства.

По умолчанию панель Обозначения для строительства включена в состав компактной инструментальной панели.

Для активизации панели Обозначения для строительства нажмите одноименную кнопку переключения на компактной панели.

Если указанной кнопки переключения на компактной панели нет, это означает, что панель Обозначения для строительства была исключена из нее. В этом случае для отображения на экране панели Обозначения для строительства следует вызвать команду Вид — Панели инструментов — Обозначения для строительства.

Некоторые кнопки сгруппированы по типам команд, которые они вызывают, например, группа кнопок для построения маркировочных обозначений. На панели отображается только одна кнопка из группы. Чтобы увидеть остальные кнопки группы и выбрать одну из них, нужно нажать на видимую кнопку группы и не отпускать кнопку мыши.

Через секунду рядом с курсором появится панель, содержащая остальные кнопки для вызова команд выбранного типа (расширенная панель команд). По-прежнему не отпуская кнопку мыши, переместите курсор на кнопку вызова нужной команды. Отпустите кнопку мыши. При этом выбранная кнопка появится на Инструментальной панели, а соответствующая ей команда будет активизирована.

Кнопки, позволяющие вызвать расширенную панель команд, отмечены маленьким черным треугольником в правом нижнем углу.

Расширенная панель команд может быть преобразована в отдельную панель, имеющую обобщенный заголовок.


Инструментальная панель Сопряжения

Панель, на которой расположены кнопки вызова команд сопряжения компонентов модели.

По умолчанию панель Сопряжения включена в состав компактной инструментальной панели.

Для активизации панели Сопряжения нажмите одноименную кнопку переключения на компактной панели.

Если указанной кнопки переключения на компактной панели нет, это означает, что панель Сопряжения была исключена из нее. В этом случае для отображения на экране данной панели вызовите команду Вид — Панели инструментов — Сопряжения.

При работе с деталью панель Сопряжения по умолчанию скрыта. Вы можете включить отображение панели, как описано выше.

Некоторые кнопки сгруппированы по типам команд, которые они вызывают, например, группа кнопок для параметризации точек. На панели отображается только одна кнопка из группы. Чтобы увидеть остальные кнопки группы и выбрать одну из них, нужно нажать на видимую кнопку группы и не отпускать кнопку мыши.

Через секунду рядом с курсором появится панель, содержащая остальные кнопки для вызова команд выбранного типа (расширенная панель команд). По-прежнему не отпуская кнопку мыши, переместите курсор на кнопку вызова нужной команды. Отпустите кнопку мыши. При этом выбранная кнопка появится на Инструментальной панели, а соответствующая ей команда будет активизирована. Кнопки, позволяющие вызвать расширенную панель команд, отмечены маленьким черным треугольником в правом нижнем углу.

Расширенная панель команд может быть преобразована в отдельную панель, имеющую обобщенный заголовок.


Инструментальная панель Измерения (2D)

Панель, на которой расположены кнопки вызова команд измерений.

По умолчанию панель Измерения 2D включена в состав компактной инструментальной панели.

Для активизации панели Измерения 2D нажмите одноименную кнопку переключения на компактной панели. Если указанной кнопки переключения на компактной панели нет, это означает, что панель Измерения 2D была исключена из нее. В этом случае для отображения на экране панели Измерения 2D следует вызвать команду Вид — Панели инструментов — Измерения 2D.

Кнопки вычисления МЦХ объединены в группу. На панели отображается только одна кнопка из группы. Чтобы увидеть остальные кнопки и выбрать одну из них, нужно нажать на видимую кнопку группы и не отпускать кнопку мыши.

Через секунду рядом с курсором появится панель, содержащая остальные кнопки для вызова команд вычисления МЦХ (расширенная панель команд). По-прежнему не отпуская кнопку мыши, переместите курсор на кнопку вызова нужной команды. Отпустите кнопку мыши. При этом выбранная кнопка появится на Инструментальной панели, а соответствующая ей команда будет активизирована. Кнопки, позволяющие вызвать расширенную панель команд, отмечены маленьким черным треугольником в правом нижнем углу.

Расширенная панель команд может быть преобразована в отдельную панель, имеющую обобщенный заголовок.


Инструментальная панель Измерения и диагностика (3D)

Панель, на которой расположены кнопки вызова команд измерений.

По умолчанию панель Измерения и диагностика (3D) включена в состав компактной инструментальной панели.

Для активизации этой панели на компактной инструментальной панели служит кнопка Измерения и диагностика (3D).


Инструментальная панель Параметризация

Панель, на которой расположены кнопки вызова команд наложения связей и ограничений на геометрические объекты.

По умолчанию панель Параметризация включена в состав компактной инструментальной панели.

Для активизации панели Параметризация нажмите одноименную кнопку переключения на компактной панели.

Если указанной кнопки переключения на компактной панели нет, это означает, что панель Параметризация была исключена из нее. В этом случае для отображения на экране панели Параметризация следует вызвать команду Вид — Панели инструментов — Параметризация.

Некоторые кнопки сгруппированы по типам команд, которые они вызывают, например, группа кнопок для параметризации точек. На панели отображается только одна кнопка из группы. Чтобы увидеть остальные кнопки группы и выбрать одну из них, нужно нажать на видимую кнопку группы и не отпускать кнопку мыши.

Через секунду рядом с курсором появится панель, содержащая остальные кнопки для вызова команд выбранного типа (расширенная панель команд). По-прежнему не отпуская кнопку мыши, переместите курсор на кнопку вызова нужной команды. Отпустите кнопку мыши. При этом выбранная кнопка появится на Инструментальной панели, а соответствующая ей команда будет активизирована. Кнопки, позволяющие вызвать расширенную панель команд, отмечены маленьким черным треугольником в правом нижнем углу.

Расширенная панель команд может быть преобразована в отдельную панель, имеющую обобщенный заголовок.


Панель свойств

Панель свойств служит для управления процессом выполнения команды.

В состав Панели свойств входят:

– Заголовок

– Панель специального управления

– Вкладки

– Область выбора вкладки

Включение и отключение Панели свойств производится командой Вид — Панели инструментов — Панель свойств.

Управление состоянием Панели свойств

Настройка оформления Панели свойств

Смотрите также

Задание параметров объектов на Панели свойств

Активизация параметров

Фиксация параметров

Освобождение параметров


Заголовок Панели свойств

Заголовок Панели свойств содержит название активной команды.

Когда Панель свойств зафиксирована в горизонтальном положении — около нижней или верхней границы окна, роль заголовка играет рельефная вертикальная линия у левого края Панели.


Вкладки Панели свойств

На вкладках Панели свойств расположены элементы управления процессом выполнения команды. Количество вкладок зависит от конкретной команды.

Для активизации нужной вкладки щелкните мышью на ее «корешке» в нижней части Панели.

Если «корешки» всех вкладок не видны одновременно, воспользуйтесь кнопками прокрутки, расположенными слева от «корешков». Кроме того, для выбора нужной вкладки можно вызвать соответствующую команду контекстного меню на свободном месте вкладки.


Область выбора вкладки

Область выбора вкладки предназначена для активизации нужной вкладки Панели свойств. Эта область содержит «корешки» вкладок и кнопки прокрутки «корешков».

Область выбора вкладки

Если включено объемное отображение «корешков», то:

– кроме надписей на них отображаются пиктограммы, символизирующие назначение вкладок,

– ширина «корешков» изменяется в соответствии с шириной Панели свойств, благодаря чему отпадает необходимость в прокрутке «корешков», поэтому кнопки прокрутки не отображаются.


Панель свойств в режиме предварительного просмотра

Панель свойств
в режиме предварительного просмотра

Панель, содержащая элементы управления параметрами выделенного листа документа.


Инструментальная панель Отчеты

Панель, на которой расположены кнопки вызова команд создания отчетов.

По умолчанию панель Отчеты включена в состав компактной инструментальной панели.

Для активизации панели Отчеты нажмите одноименную кнопку переключения на компактной панели.

Если указанной кнопки переключения на компактной панели нет, это означает, что панель Отчеты была исключена из нее. В этом случае для отображения на экране панели Отчеты следует вызвать команду Вид — Панели инструментов — Отчеты.


Инструментальная панель Режимы

Панель, на которой расположены кнопки включения/отключения специальных режимов работы с документами. Набор режимов зависит от типа текущего документа.

Для включения отображения ее на экране служит команда Вид — Панели инструментов — Режимы.


Инструментальная панель Выделение

Панель, на которой расположены кнопки вызова команд выделения объектов и исключения из числа выделенных.

Для включения отображения ее на экране служит команда Вид — Панели инструментов — Выделение.

Для активизации этой панели на компактной инструментальной панели служит кнопка Выделение.

Кнопки панели Выделение доступны, если в документе уже созданы какие-либо объекты.

Кнопки сгруппированы по способам выделения и исключения, например, группа кнопок для выделения/исключения по стилю кривой. На панели отображается только одна кнопка из группы. Чтобы увидеть другую кнопку, нужно нажать на видимую кнопку группы и не отпускать кнопку мыши.

Через секунду рядом с курсором появится панель, содержащая остальные кнопки для вызова команд выбранного типа (расшире нная панель команд). По-прежнему не отпуская кнопку мыши, переместите курсор на кнопку вызова нужной команды. Отпустите кнопку мыши. При этом выбранная кнопка появится на Инструментальной панели, а соответствующая ей команда будет активизирована. Кнопки, позволяющие вызвать расширенную панель команд, отмечены маленьким черным треугольником в правом нижнем углу.

Расширенная панель команд может быть преобразована в отдельную панель, имеющую обобщенный заголовок.


Создание отдельной расширенной панели команд

Чтобы отделить расширенную панель от инструментальной панели, выполните следующие действия.

1. Вызовите на кнопке команды расширенную панель (рис. а) и, не отпуская левую кнопку мыши, подведите курсор к маркеру перемещения — рельефной линии у границы панели. После того как курсор примет вид четырехсторонней стрелки, отпустите кнопку мыши — расширенная панель должна оставаться на экране (рис. б).

а) | б)

2. Нажмите левую кнопку мыши вновь и «перетащите» панель за маркер перемещения в любое место экрана (рис. в, г).

в) | г)


Инструментальная панель Элементы листового тела

Панель, на которой расположены кнопки вызова команд построения листового тела и листовых элементов.

По умолчанию панель Элементы листового тела включена в состав компактной инструментальной панели.

Для активизации панели Элементы листового тела нажмите одноименную кнопку переключения на компактной панели.

Если указанной кнопки переключения на компактной панели нет, это означает, что панель Элементы листового тела была исключена из нее. В этом случае для отображения на экране панели Элементы листового тела следует вызвать команду Вид — Панели инструментов — Элементы листового тела.


Инструментальная панель Спецификация

Панель, на которой расположены кнопки вызова команд работы со спецификацией.

По умолчанию панель Спецификация включена в состав компактной инструментальной панели.

Для активизации панели Спецификация нажмите одноименную кнопку переключения на компактной панели.

Если указанной кнопки переключения на компактной панели нет, это означает, что панель Спецификация была исключена из нее. В этом случае для отображения на экране панели Спецификация следует вызвать команду Вид — Панели инструментов — Спецификация.


Панель специального управления

Эта панель находится в верхней или левой части Панели свойств.

На Панели специального управления расположены кнопки, с помощью которых выполняются специальные действия, такие как ввод объекта, прерывание текущей команды, включение автоматического создания объекта и т.д.

Набор кнопок зависит от выполняемой команды.

Панель специального управления (при вводе линейного размера)


Панель Стандартная

Панель, на которой расположены кнопки вызова команд стандартных операций с файлами и объектами.

Для включения отображения ее на экране служит команда Вид — Панели инструментов — Стандартная.


Инструментальная панель Поверхности

Панель, на которой расположены кнопки вызова команд построения поверхностей.

По умолчанию панель Поверхности включена в состав компактной инструментальной панели.

Для активизации панели Поверхности нажмите одноименную кнопку переключения на компактной панели.

Если указанной кнопки переключения на компактной панели нет, это означает, что панель Поверхности была исключена из нее. В этом случае для отображения на экране панели Поверхности следует вызвать команду Вид — Панели инструментов — Поверхности.


Инструментальная панель Таблица отчета

Панель, на которой расположены кнопки вызова команд создания отчета в Окне подготовки данных.

По умолчанию панель Таблица отчета включена в состав компактной инструментальной панели, появляющейся при открытии Окна подготовки данных.

Для активизации панели Таблица отчета нажмите одноименную кнопку переключения на компактной панели.

Если указанной кнопки переключения на компактной панели нет, это означает, что панель Таблица отчета была исключена из нее. В этом случае для отображения на экране панели Таблица отчета следует вызвать команду Вид — Панели инструментов — Таблица отчета.


Инструментальная панель Таблицы и границы

Панель, на которой расположены кнопки вызова команд оформления таблицы и редактирования ее конфигурации.

По умолчанию панель Таблицы и границы включена в состав компактной инструментальной панели.

Для активизации панели Таблицы и границы нажмите одноименную кнопку переключения на компактной панели.

Если указанной кнопки переключения на компактной панели нет, это означает, что панель Таблицы и границы была исключена из нее. В этом случае для отображения на экране панели Таблицы и границы следует вызвать команду Вид — Панели инструментов — Таблицы и границы.


Инструментальная панель

Инструментальная панель — панель, содержащая кнопки вызова команд.


Панель Вид

Панель, на которой расположены кнопки вызова команд настройки отображения активного документа.

Набор полей и кнопок панели Вид зависит от того, какой документ активен.

Для включения отображения ее на экране служит команда Вид — Панели инструментов — Вид.

Панель Вид при работе с моделями


Инструментальная панель Виды

Панель, на которой расположены кнопки вызова команд создания видов.

По умолчанию панель Виды включена в состав компактной инструментальной панели.

Для активизации панели Виды нажмите одноименную кнопку переключения на компактной панели.

Если указанной кнопки переключения на компактной панели нет, это означает, что панель Виды была исключена из нее. В этом случае для отображения на экране панели Виды следует вызвать команду Вид — Панели инструментов — Виды.


Инструментальная панель Вставки и макроэлементы

Панель, на которой расположены кнопки вызова команд вставок видов и фрагментов, а также команд работы с макроэлементами.

Для включения отображения ее на экране служит команда Вид — Панели инструментов — Вставки и макроэлементы.

Для активизации этой панели на компактной инструментальной панели служит кнопка Вставки и макроэлементы.


Работа с прикладной библиотекой в режиме панели

Панель библиотеки располагается на вкладке Менеджера библиотек.

Команды работы с библиотекой находятся в контекстном меню вкладки.

На панели библиотеки может располагаться несколько окон. В одном из них показана структура (список разделов) библиотеки. В другом —список названий команд и набор слайдов (значков), которые соответствуют пунктам выделенного в списке раздела библиотеки. Третье окно служит для просмотра слайда, выделенного в списке команд. Вы можете изменять размер панели или любого окна на ней.

Для запуска библиотечной команды на исполнение выберите ее название в списке и нажмите клавишу <Enter> или дважды щелкнуть левой кнопкой мыши на названии команды.


Удаление переменной размера

Для удаления переменной размера можно воспользоваться одним из следующих способов.

Способ 1

1. Дважды щелкните левой кнопкой мыши на тексте размерной надписи ассоциативного размера. На экране появится диалог ввода значения размера и имени переменной.

Другим способом вызова этого диалога является использование команды Установить значение размера на панели Параметризация и указание размера, переменную которого требуется удалить.

2. Удалите имя переменной в поле Переменная появившегося диалога и нажмите кнопку OK.

Способ 2

1. Выделите ассоциативный размер и вызовите команду Показать/удалить ограничения из контекстного меню или при помощи кнопки Показать/удалить ограничения на панели Параметризация.

Параметрические связи и ограничения размера будут отображены в списке на Панели свойств.

2. Выделите в нем строку Размер с переменной и нажмите кнопку Удалить.

3. Нажмите кнопку Прервать команду на Панели специального управления.

Способ 3

Удалите размер. Соответствующая ему переменная также будет удалена.


Наложение и снятие ограничений

Различные взаимосвязи и ограничения можно назначить объектам в любой момент, когда это потребуется. Соответствующие команды находятся на панели Параметризация.

Чтобы наложить какое-либо ограничение на объект (или несколько объектов), выполните следующие действия.

1. Перейдите на панель Параметризация, нажав кнопку переключения.

2. Вызовите нужную команду установки ограничения с помощью соответствующей кнопки на панели.

3. Последовательно указывайте объекты, на которые нужно наложить ограничения (естественно, тип объекта должен соответствовать типу ограничения).

Чтобы просмотреть ограничения или снять их с объекта, выполните следующие действия.

1. Укажите объект, ограничения которого вы хотите просмотреть.

2. Нажмите кнопку Показать/удалить ограничения на панели Параметризация.

Ограничения объекта будут отображены в списке на Панели свойств.

Если требуется удалить какое-либо ограничение, выделите его в списке и нажмите кнопку Удалить, расположенную над списком.

Чтобы просмотреть ограничения, наложенные на другой объект, укажите его мышью в окне документа.

Чтобы удалить все ограничения с одного или нескольких объектов, выполните следующие действия.

1. Любым способом выделите объекты, ограничения которых требуется удалить.

2. Нажмите кнопку Удалить все ограничения на панели Параметризация.

Все ограничения выделенных объектов будут сняты. Вместе с ограничениями геометрических объектов удаляются ограничения всех ассоциированных с ними объектов оформления.


Внешняя переменная фрагмента

Внешняя переменная фрагмента — переменная в параметрическом фрагменте, значение которой можно изменять при вставке этого фрагмента в другой фрагмент или чертеж (телом или внешней ссылкой). Основное назначение внешних переменных — управление параметрами вставленного в другой документ параметрического фрагмента без редактирования этого фрагмента «изнутри».

Признаком внешней переменной является синий или зеленый (если она также является информационной) цвет ячейки с именем переменной в таблице Окна переменных.

Если внешняя переменная фрагмента имеет также статус «информационная», то при вставке фрагмента в другой документ она видна, но недоступна для изменения.

Формирование переменных и присвоение им статусов «внешняя» и «информационная» производится при создании фрагмента.

Внешней переменной может быть только пользовательская переменная, т.е. переменная главного раздела.


Команды наложения связей и ограничений

Кнопки вызова команд наложения связей и ограничений на объекты расположены на инструментальной панели Параметризация.

Они доступны, если в документе уже есть какие-либо графические объекты.

Горизонтальность

Вертикальность

Выровнять точки по горизонтали

Выровнять точки по вертикали

Объединить точки

Точка на кривой

Точка на середине кривой

Симметрия двух точек

Параллельность

Перпендикулярность

Биссектриса

Коллинеарность

Касание

Зафиксировать точку

Зафиксировать длину

Зафиксировать угол

Равенство радиусов

Равенство длин

Зафиксировать размер

Установить значение размера

Параметризовать объекты

Остальные команды панели Параметризация служат для управления связями и ограничениями:

Отображать ограничения

Отображать степени свободы

Показать/удалить ограничения

Удалить все ограничения


Параметрический режим

Параметрический режим — режим создания и редактирования геометрических объектов и объектов оформления, в котором параметрические связи и ограничения накладываются автоматически. При этом тип накладываемых связей и ограничений определяется в процессе построения благодаря последовательности выполнения команды построения объекта или осуществлению привязки.

Параметрический режим можно включить или выключить в любой момент работы с чертежом или фрагментом.

При настройке параметрического режима можно выбрать типы связей и ограничений, которые необходимо формировать автоматически, и отказаться от автоматического создания связей и ограничений других типов.

Вы можете включить параметрический режим либо для всех открываемых или создаваемых вновь документов, либо для каждого конкретного документа.


Команды редактирования модели детали

Кнопки вызова команд редактирования модели детали расположены на панели Редактирование детали.

Операция выдавливания

Операция вращения

Кинематическая операция

Операция по сечениям

Деталь-заготовка

Добавить компоновочную геометрию

Придать толщину

Вырезать выдавливанием

Вырезать вращением

Вырезать кинематически

Вырезать по сечениям

Фаска

Скругление

Круглое отверстие

Отверстие из библиотеки

Ребро жесткости

Уклон

Оболочка

Сечение поверхностью

Сечение по эскизу

Булева операция

Вычесть компоненты

Объединить компоненты

Масштабирование

Кнопки Вычесть компоненты и Объединить компоненты доступны только в режиме редактирования компонента на месте.


Требования к контуру

При указании сегментов контура заплатки следует учитывать следующее.

– Контур не должен иметь самопересечений.

– Если сегменты лежат в одной плоскости или на одной существующей поверхности, то их количество может быть любым, в противном случае — не менее двух и не более четырех.


Система PDM

Система PDM (Product Data Management System) — система управления данными об изделии (продукте). В ее состав обязательно входит система управления документами — DMS (Document Management System).

Если при работе с системой КОМПАС-3D используется система PDM, то с ее помощью производятся:

– открытие и сохранение файлов,

– выбор файла модели при создании Стандартных и Произвольных ассоциативных видов,

– выбор файла модели-заготовки,

– выбор файла при импорте поверхности,

– выбор файла компонента.


Фантом

Фантом — изображение, появляющееся на экране при выполнении какой-либо операции и показывающее текущее состояние создаваемых или редактируемых объектов.

Например, если создается отрезок прямой, то во время ожидания ввода его второй точки отображается фантом будущего отрезка. При изменении положения курсора фантом динамически перестраивается, показывая новое состояние вводимого отрезка.

Когда имеется несколько вариантов построения объекта, на экране отображается сразу несколько фантомов. Один из них активный. Он соответствует варианту, который будет зафиксирован при подтверждении создания объекта. Чтобы сделать активным другой фантом, щелкните по нему мышью.

По умолчанию активный фантом отображается сплошной черной линией, а остальные — черным пунктиром. Цвет и стиль отрисовки фантомных изображений можно изменять в диалоге настройки.


Плоские объекты

Плоскими объектами являются:

– координатная или вспомогательная плоскость,

– плоская грань,

– плоскость эскиза (используется для некоторых команд).


Зависимость направления поворота модели от перемещения курсора

Зависимость направления поворота модели от перемещения курсора
Направление перемещения курсора | Направление поворота модели
Вертикально | В вертикальной плоскости, перпендикулярной плоскости экрана.
Горизонтально | В горизонтальной плоскости, перпендикулярной плоскости экрана.
По диагонали | Направление складывается из соответствующих вертикальной и горизонтальной компонент.
Горизонтально при нажатой клавише <Alt> | В плоскости экрана.


Точечные объекты

Точечными объектами являются:

– начало координат,

– характерная точка геометрического объекта в эскизе,

– отдельная точка в эскизе,

– отдельная точка в пространстве,

– вершина пространственной кривой,

– вершина ребра,

– точки группы,

– точки в составе экземпляров массива точек,

– контрольные и присоединительные точки.


Выбор стиля точки

Системой предусмотрены следующие стили точек: вспомогательная точка, крест, звезда, круг, квадрат, треугольник, конверт, плюс тонкий, плюс основной.

По умолчанию создаются точки со стилем Вспомогательная. Для изменения текущего стиля отрисовки точек воспользуйтесь списком Стиль на Панели свойств.

Выбирая стиль точки, помните, что вспомогательные точки можно удалить одной командой, даже не выделяя их. Если вводимые вами точки служат не для вспомогательных построений и не должны удаляться заодно со вспомогательными элементами, используйте любой стиль точки, кроме вспомогательного.

Смотрите также

Настройка цветов системных стилей точек


Вес точки

Вес точки — коэффициент, определяющий влияние характерной точки сплайновой кривой или сплайновой поверхности на конфигурацию этой кривой или поверхности.

Геометрический смысл этого коэффициента следующий: чем больше вес точки, тем ближе к ней расположена кривая или поверхность (точки с большим весом «притягивают» сплайн сильнее, чем точки с маленьким весом).


Команда Окно просмотра (меню Библиотекаря)

Команда Окно просмотра
(меню Библиотекаря)

В окне находится текст, содержащийся в шаблоне. Вы можете добавлять, редактировать, удалять текст или его фрагменты. При работе с текстом в этом окне вы можете использовать буфер обмена Windows.


Примитив

Примитив — элементарная составляющая геометрии объекта. Примитивы: ребро, вершина, грань.


Продолжать по касательным ребрам

Если несколько ребер, на которых строится фаска, гладко соединяются (имеют общую касательную в точке соединения), укажите одно из них и включите опцию Продолжать по касательным ребрам на вкладке Параметры Панели свойств. В этом случае система автоматически определит другие ребра, на которые требуется продолжить фаску.


Проекционное обозначение

Проекционное обозначение — объект, сформированный в ассоциативном виде чертежа в результате передачи в него размера или обозначения из трехмерной модели.


Профиль

Профиль — комплекс сведений о настройке конфигурации системы. Настройка конфигурации включает в себя настройки новых документов, настройки рабочего окна и настройки системы.

С помощью профилей можно быстро изменить текущую настройку системы.

Например, вы можете создать профиль для трехмерного моделирования (т.е. профиль, содержащий настройки, при которых вам наиболее удобно работать с трехмерными моделями), профиль для разработки конструкторской документации и т.д.). Затем, чтобы настроить систему для выполнения той или иной задачи, вам будет достаточно применить соответствующий профиль.


Примеры группового изменения свойств объектов Пример 1

Примеры группового изменения свойств объектов
 Пример 1

В чертеже имеется несколько окружностей радиусом 5 мм. Требуется поменять их диаметр на 6 мм.

Для этого выполните следующие действия.

1. Выделите окружности, подлежащие редактированию.

2. Вызовите команду Свойства.

На экране появится окно Свойства. В таблице свойств будут присутствовать следующие свойства:

– Слой объекта. Если выделенные окружности расположены в одном виде на одном слое, то значение свойства Слой объекта — имя и номер этого слоя. В противном случае значение отсутствует. (Если выделенные окружности принадлежат разным видам, то значение свойства Слой объекта отсутствует и недоступно для ввода.)

– Центр окружности. Поскольку центры выделенных окружностей не совпадают, значение свойства Центр окружности отсутствует. (Если выделенные окружности принадлежат разным видам, то значение свойства Центр окружности отсутствует и недоступно для ввода.)

– Радиус окружности. Поскольку радиусы всех выделенных окружностей равны 5 мм, значение свойства Радиус окружности равно 5.

– Текущий стиль. Если все окружности отрисованы одним стилем линии, то значение свойства Текущий стиль — имя этого стиля. В противном случае значение отсутствует.

3. Щелкните мышью в ячейке значения радиуса.

Ячейка станет доступна для редактирования.

4. Введите значение 6 и нажмите клавишу <Enter>.

Радиус выделенных окружностей увеличится. Остальные свойства окружностей — слой, координаты центра, стиль линии — не изменятся.

Следующий пример


Примеры группового изменения свойств объектов Пример 2

Примеры группового изменения свойств объектов
 Пример 2

Все изображение детали расположено на системном слое первого вида чертежа. В этом виде созданы пустые слои Осевые линии (№ 2) и Размеры (№3). Требуется переместить осевые линии и обозначения центра на слой Осевые линии, а размеры — на слой Размеры.

Для этого выполните следующие действия.

1. Выделите изображение детали.

2. Вызовите команду Свойства.

На экране появится окно Свойства.

3. В списке типов объектов выберите строку Осевые линии.

В таблице свойств отобразятся свойства осевых линий.

4. Щелкните мышью в ячейке значения свойства Слой объекта.

В правой части ячейки появится кнопка с черным треугольником.

5. Нажмите эту кнопку и выберите из развернувшегося списка слой Осевые линии (2).

Осевые линии будут перенесены на выбранный слой. Изображение детали останется выделенным, поэтому вы можете продолжать изменение свойств объектов.

6. Аналогичным образом перенесите обозначения центра на слой Осевые линии, а размеры всех типов — на слой Размеры.

Предыдущий пример

Следующий пример


Примеры группового изменения свойств объектов Пример 3

Примеры группового изменения свойств объектов
 Пример 3

На чертеже детали имеются обозначения шероховатости поверхностей. Те из них, где значение параметра равно 0,63, необходимо отредактировать, поменяв его на 1,25.

Для этого выполните следующие действия.

1. Вызовите команду Свойства.

На экране появится окно Свойства.

2. Выделите все обозначения шероховатости, содержащие текст «0,63».

2.1. Нажмите кнопку Выделить по свойствам на инструментальной панели окна Свойства.

На экране появится диалог Выделение объектов по свойствам.

2.2. Раскройте раздел Обозначения дерева объектов и включите опцию Шероховатость.

2.3. В правой части диалога найдите свойство Текст, выберите для него условие Содержит и введите значение 0,63.

2.4. Нажмите кнопку ОК в диалоге Выделение объектов по свойствам.

Диалог Выделение объектов по свойствам закроется. Все имеющиеся на чертеже обозначения шероховатости со значением 0,63 будут выделены.

В таблице свойств окна Свойства появятся свойства выделенных обозначений.

3. Щелкните мышью в ячейке значения свойства Параметр шероховатости.

На экране появится диалог ввода текста.

4. В этом диалоге удалите текст 0,63, введите 1,25 и нажмите кнопку ОК.

Диалог закроется. Значение параметра в выделенных обозначениях шероховатости поменяется на 1,25.

Предыдущий пример


Свойство документа

Свойство документа — характеристика документа и входящих в него объектов.

Список свойств документа создается в чертеже, фрагменте или документе-модели. Он является единым для документа и входящих в него объектов, а значения свойств объектов могут различаться.

Свойства могут быть заданы:

– в графических документах — чертежу или фрагменту в целом, макроэлементам, вставкам видов и фрагментов;

– в документах-модели — модели в целом, компонентам и телам.

В ассоциативном виде чертежа могут быть учтены свойства модели, по которой чертеж создан.

Свойства сборки автоматически не передаются в файлы ее компонентов, а свойства чертежа — в файлы входящих в него объектов.

Свойства документа делятся на системные и дополнительные.

Системные свойства — свойства, которые всегда находятся в документе и доступны для использования в нем, например, Обозначение, Наименование, Масса и т.д. Значения некоторых системных свойств определяются автоматически, значения остальных свойств задаются пользователем.

Дополнительное свойство — свойство из внешней библиотеки свойств. Дополнительные свойства назначаются документу пользователем. Значения дополнительных свойств также задаются пользователем.


Панель Оптические свойства

Находится на Панели свойств при настройке свойств объекта. Позволяет задать оптические свойства поверхности объекта.

Описание элементов управления
Наименование | Описание
Общий цвет Диффузия Зеркальность Блеск Прозрачность Излучение | Чтобы задать параметры, переместите на нужное расстояние соответствующий «ползунок». Числовое значение параметра будет отображаться в справочном поле.
 | В окне просмотра отображается сфера с заданными свойствами поверхности; это позволяет визуально оценить внесенные изменения.


Инструментальная панель окна Свойства

Инструментальная панель окна Свойства содержит следующие элементы управления.

– Переключатель Группировка служит для разбиения свойств в таблице свойств на группы. Набор групп и наполняемость их свойствами зависит от типа объекта, отображаемого в списке типов.

Возможно формирование следующих групп.

• Группа Параметры в графическом документе включает свойство Слой объекта, а также, как правило, свойства, соответствующие параметрам, которые при создании объекта задаются на первой вкладке Панели свойств и на вкладке Параметры.
В модели группа Параметры присутствует только у элементов оформления, пространственных кривых и точек.

• Группы Текст, Параметры шрифта, Параметры абзаца формируются для объектов, имеющих в составе текст — размеров, обозначений, текста, таблиц, элементов оформления и т.п.

Если выделено несколько объектов, содержащих текст, то редактирование текста возможно при условии, что все объекты принадлежат к одному типу. Исключением являются размеры: вы можете одновременно менять тексты в составе размерных надписей размеров различных типов.

• Группы Свойства, Состояние, Цвет формируются в моделях.

– Переключатель Сортировка служит для сортировки свойств по именам в алфавитном порядке. Разбиение на группы в этом случае не производится.

При активизации переключателя — Группировка или Сортировка — другой выключается автоматически.

– Кнопка Выделить по свойствам служит для вызова команды Выделить по свойствам. Эта команда позволяет выделять объекты по набору свойств, исключать объекты из числа выделенных по набору свойств, а также инвертировать выделение.

Доступна в графическом документе.


Команды простановки обозначений для строительства

Кнопки вызова команд простановки обозначений для строительства находятся на инструментальной панели Обозначения для строительства.

Марка/позиционное обозначение без линии-выноски

Марка/позиционное обозначение с линией-выноской

Марка/позиционное обозначение на линии

Линия разреза

Обозначение узла

Обозначение узла в сечении

Номер узла

Выносная надпись

Фигурная скобка

Прямая координационная ось

Дуговая координационная ось

Круговая координационная ось


Размеры операции

Размеры операции — числовые параметры операции, значение которых выражено в линейных или угловых величинах. Эти параметры могут отображаться на экране в виде соответствующих размеров.

Например, числовыми параметрами операции выдавливания являются: расстояние выдавливания, угол наклона и толщина стенки.

Размеры операции отображаются на экране в следующих случаях:

– при создании операции;

– в специальном режиме отображения размеров выбранного элемента (см. раздел 2.9.2.2.2).

Размеры операции могут быть как управляющими, так и информационными (см. раздел 2.9.2.1).

Размеры операции можно отобразить в виде элементов оформления (производные размеры; см. раздел 2.9.2.8).

Подробнее о размерах операции см. раздел 2.9.2.2.


Запись

Запись — текст в колонке спецификации, состоящий из нескольких полей.


Прямолинейные геометрические объекты

– Вспомогательные прямые,

– отрезки,

– звенья ломаной,

– стороны многоугольника.


Растровый объект, вставленный внешней ссылкой

Ссылка на внешний растровый файл (источник вставки).

КОМПАС-документ, содержащий такую ссылку, должен передаваться на другой компьютер только вместе с файлом-источником вставки.

В противном случае корректное отображение документа будет невозможно.


Показ исходных объектов в Дереве после изменения иерархии вручную. Пример

Например, в модели имелись два элемента выдавливания, причем эскиз второго элемента базировался на грани первого. Таким образом, второй элемент являлся производным по отношению к первому. В списке исходных объектов второго элемента были перечислены: его эскиз, первый элемент, эскиз первого элемента.

Первый элемент перемещается в Дереве так, что оказывается ниже второго (который при этом отмечается в Дереве как ошибочный), а затем возвращается на место (при этом ошибка исчезает). В результате этих действий в числе исходных объектов второго элемента выдавливания останется только эскиз этого элемента.


Указание компонентов для разнесения

Нажмите кнопку Компоненты на Панели свойств и выберите нужные объекты — детали или подсборки — в Дереве или окне модели.

Выбор объектов в Дереве построения

Выбор объектов в окне модели

Указанные компоненты подсвечиваются в окне модели, соответствующие им пиктограммы выделяются цветом в Дереве построения; а их названия появляются в Списке компонентов.

Один и тот же компонент может участвовать в нескольких шагах разнесения.

В одном шаге разнесения могут участвовать несколько компонентов.

Компонент, входящий в подсборку (на любом уровне вложенности), может участвовать в шаге разнесения независимо от других компонентов этой подсборки.

Чтобы исключить компонент из числа участвующих в шаге разнесения, укажите его повторно. Можно также выделить название этого компонента в списке и нажать кнопку Удалить.


Объект, задающий направление разнесения

Компоненты могут разноситься в направлении, совпадающем с ребром или в направлении, перпендикулярном грани.

Нажмите кнопку Объект на Панели свойств и укажите в окне модели нужный объект - ребро или грань.

Указанный элемент подсвечиваются, а его название появляется в справочном поле вкладки Параметры.

Чтобы выбрать другой элемент, задающий направление разнесения, просто укажите курсором. Выделение с ранее указанного элемента будет снято, выбранным для выполнения операции окажется вновь указанное ребро или грань.


Резервная строка

Резервная строка — строка спецификации, предназначенная для внесения последующих изменений в выпущенную спецификацию.

Отличие резервной строки от прочих объектов спецификации состоит в следующем:

– в резервную строку невозможно ввести текст

– резервные строки всегда расположены в конце раздела

– расчет номеров позиций в разделе производится с учетом резервных строк

– возможна настройка количества резервных строк в каждом разделе (в том числе отказ от резервирования строк в разделе)


Способы определения угла вращения

– На угол

Выбор этого варианта означает, что вращение производится точно на заданный угол. Введите его в поле Угол.

– До вершины

Выбор этого варианта означает, что вычисляется такой угол поворота, чтобы торец элемента занял положение, ближайшее к заданной вершине.

Чтобы задать вершину, активизируйте переключатель Вершина и укажите нужный точечный объект в Дереве построения или в окне модели.

Можно отсечь элемент плоскостью, проходящей через указанную вершину и ось вращения выдавливания. Для этого включите опцию Отсекать.

Подробнее о вращении до вершины...

– До поверхности

Выбор этого варианта означает, что элемент вращается до заданной поверхности. Торец элемента имеет форму поверхности.

Чтобы задать поверхность, активизируйте переключатель Грань и укажите нужную грань или плоскость в окне модели.

Подробнее о вращении до поверхности...

Корректное построение объекта «Поверхность вращения» способом До поверхности возможно, только если создаваемая поверхность замкнута, т.е. закрыта с торцов. Для этого сечение поверхности должно быть замкнуто, а на Панели свойств при построении поверхности должна быть включена опция Замкнутая поверхность.


Положение ребра жесткостиотносительно плоскости эскиза

Положение ребра жесткости
относительно плоскости эскиза

Если необходимо построить ребро жесткости, средняя плоскость или одна из боковых граней которого должна располагаться в той же плоскости, что и его эскиз, активизируйте переключатель В плоскости эскиза.

Активизация переключателя Ортогонально плоскости эскиза означает, что ребро будет расположено перпендикулярно плоскости его эскиза.


Сегмент, задающий направление уклона

Если эскиз ребра жесткости состоит из нескольких сегментов (отрезков, кривых), можно выбрать сегмент, задающий направление уклона. Торцевая грань ребра жесткости, соответствующая этому сегменту, будет принята за основание уклона. Боковые грани ребра будут наклонены по отношению к ней на заданный угол.

Сегмент, задающий направление уклона, отмечен фантомной стрелкой в окне модели. Чтобы выбрать другой, сегмент, нажмите кнопку Следующий на вкладке Параметры Панели свойств.

Зависимость формы ребра жесткости от выбора сегмента,
задающего направление уклона (выделен цветом)


Способ построения элемента вращения

Если контур сечения не замкнут, возможны два варианта построения элемента вращения — Тороид и Сфероид.

При построении сфероида концы контура проецируются на ось вращения. Построение элемента производится с учетом этих проекций. В случае поверхности вращения получается поверхность, имеющая грани, перпендикулярные оси вращения. В случае элемента вращения получается сплошной элемент.

При построении тороида вращается только контур сечения. В случае поверхности вращения получается поверхность без граней, перпендикулярных оси вращения. В случае элемента вращения к получившейся поверхности добавляется слой материала. В результате получается тонкостенная оболочка — элемент с отверстием вдоль оси вращения.


Выбор и настройка стиля

Выберите стиль отчета из раскрывающегося списка Стиль, если стиль был создан заранее.

Чтобы изменить текущий стиль, нажмите кнопку Настроить... и настройте его параметры.

Настройка параметров стиля...


Примеры редактирования графических макроэлементов

Пример 1. Если вы ошибочно внесли «лишний» объект в макроэлемент, то его можно исключить из состава макроэлемента (без удаления из документа).

Для этого выполните следующие действия.

1. Перейдите в режим редактирования макроэлемента, содержащего «лишний» объект.

2. Поместите «лишний» объект в буфер обмена командой Вырезать.

3. Перейдите в режим работы с документом и вставьте объект на свое место командой Вставить.

В документе окажется макроэлемент без «лишнего» объекта, а также сам объект.

Пример 2. Вы можете разбить один макроэлемент на два. Для этого выполните следующие действия.

1. Перейдите в режим редактирования макроэлемента, который требуется разбить на части.

2. Выделите мышью объекты для первого макроэлемента и вызовите команду Создать макроэлемент.

3. Поместите созданный макроэлемент в буфер обмена командой Вырезать.

4. Перейдите в режим работы с документом и вставьте макроэлемент командой Вставить.

В документе окажутся два макроэлемента вместо одного.


Соотношение перемещений

Соотношение перемещений — это параметр, задающий отношение перемещений (угловых или линейных) в механической передаче, в зависимости от ее типа. Например, для зубчатой передачи соотношение определяется ее передаточным числом.

В поле Соотношение вводятся с клавиатуры два действительных числа, обозначающих отношение перемещений в данном сопряжении: первое число обозначает перемещение первого объекта, а второе — перемещение второго объекта, совершаемое одновременно с первым.

Значение соотношения можно выбрать из раскрывающегося списка соотношений, ранее использованных в текущем сеансе КОМПАС-3D.

– В сопряжении Вращение – вращение соотношение — это отношение числа оборотов первого объекта к числу оборотов второго объекта.

Соотношение 1:2 означает, что за один оборот первого объекта второй объект совершает 2 оборота.

Если один объект неподвижен, то расчет соотношения производится аналогично. Например, из двух сопряженных колес одно неподвижно. В этом случае подвижное колесо совершает сложное вращательное движение — вращение вокруг своей оси с одновременным вращением вокруг неподвижного колеса. Соотношение равно отношению числа оборотов подвижной оси вокруг неподвижной к числу оборотов подвижного объекта вокруг своей оси.

– В сопряжении Вращение – перемещение соотношение — отношение длины окружности единичного радиуса, равной 2p (мм), к линейному перемещению второго объекта.

Соотношение 1:2 означает, что за один оборот первого объекта второй объект перемещается на 2 · 2p (мм), то есть около 13 мм.

Если один объект неподвижен, то расчет соотношения производится аналогично. Например, рейка неподвижна, а колесо радиуса R (мм) катится по ней без скольжения. За один оборот колеса рейка перемещается относительно центра колеса на 2pR. Соотношение перемещений равно 1:R.

Вы можете рассчитать требуемое соотношение, используя формулу 1:(L/2p).

Здесь L — расстояние в миллиметрах, на которое должен переместиться второй объект за один оборот первого объекта.

После создания механического сопряжения в модели автоматически формируется переменная, соответствующая параметру Соотношение.


Выделение объектов и отмена выделения

Во время работы с КОМПАС-документами пользователь выполняет различные операции над объектами — редактирует их, копирует, перемещает, поворачивает и так далее.

Некоторые команды геометрических построений действуют таким образом, что после их запуска нужно сначала указать объекты, а затем начинается выполнение собственно операции над этими объектами. Например, именно так работают деформации и удаления области.

Большинство команд геометрических построений требуют выделения нужных объектов до своего запуска. Например, операции копирования и поворота затрагивают именно те объекты, которые были выделены перед вызовом команды.

Выполнение команд форматирования текста возможно как с применением выделения (в этом случае будет отформатирован выделенный текст), так и без него (в этом случае форматируется вновь набираемый текст).

КОМПАС-3D предоставляет пользователю самые разнообразные возможности выделения объектов и, соответственно, отмены их выделения — как с помощью мыши, так и с помощью команд меню.

О выделении объектов рассказано в следующих разделах:

Выделение графических объектов с помощью мыши

Выделение графических объектов с помощью команд меню

Для отмены выделения достаточно щелкнуть мышью в любом свободном месте окна или нажать клавишу <Esc>.


Настройка драйвера принтера для печати КОМПАС-документов

В случаях, когда при печати КОМПАС-документов, содержащих растровые изображения или имеющих большой формат, возникают проблемы, рекомендуется настроить драйвер принтера следующим образом.

1. Уменьшить разрешение печати.

2. Если при настройке драйвера имеется возможность выбора между подготовкой изображения к печати на принтере и подготовкой на компьютере, то следует включить подготовку изображения к печати на компьютере.


Настройка свойств поверхности и ввод наименования объекта

Настройка свойств поверхности и ввод наименования объекта производится на вкладке Свойства Панели свойств.

Элементы управления свойствами поверхности
Название | Описание
Наименование | Введите в это поле наименование объекта. Оно будет отображаться в Дереве построения.
Назначить цвет | Группа переключателей, позволяющих выбрать способ назначения цвета и оптических свойств объекта.
Цвет | Выберите из палитры цветов цвет объекта. Поле Цвет присутствует на Панели свойств при активном переключателе Вручную в группе Назначить цвет.
Общий цвет Диффузия Зеркальность Блеск Прозрачность Излучение | Чтобы задать оптические свойства поверхности объекта, переместите на нужное расстояние соответствующий «ползунок». Числовое значение параметра будет отображаться в справочном поле. Настройка оптических свойств доступна при активном переключателе Вручную в группе Назначить цвет.
 | В окне просмотра отображается сфера с заданными свойствами поверхности; это позволяет визуально оценить внесенные изменения.


Чертеж

Чертеж — основной графический документ системы КОМПАС-3D. Чертеж хранится в файле специального двоичного формата (расширение файла — cdw).

Каждый чертеж может состоять из одного или нескольких листов, видов, слоев.

Элементы оформления листа — рамка и основная надпись.

Элементы оформления чертежа — технические требования и обозначение шероховатости неуказанных поверхностей детали (знак неуказанной шероховатости).


Изменение положения элементов детали, вызванные сгибанием/разгибанием сгиба. Пример

Пусть в детали имеется сгиб, созданный в согнутом состоянии. На внешней или внутренней грани продолжения этого сгиба построен эскиз. На основе эскиза построен вырез.

К чему приведет изменение состояния — разгибание — сгиба, сделанное после выполнения указанных операций?

Для выреза, построенного способом «по толщине», возможно появление ошибки «Эскиз не проецируется на базовую грань», а для вырезов, построенных остальными способами — «Объекты не пересекаются».

Причина этих ошибок в следующем. Размещение и ориентация начала системы координат эскиза, построенного на грани, зависит от взаиморасположения этой грани и начала системы координат детали. При разгибании сгиба грань, на которой построен эскиз выреза, принимает положение, отличное от первоначального. Из-за этого размещение и ориентация начала координат эскиза на его плоскости изменяются. В результате эскиз выреза оказывается за пределами грани (возникает ошибка «Эскиз не проецируется на базовую грань»), а сам вырез — за пределами тела детали (возникает ошибка «Объекты не пересекаются»).

Разумеется, не всегда эскиз смещается на столько, что в детали возникает ошибка. Нередко построение остается возможным, но результат его не совпадает с ожидаемым.


Результат сгибания/разгибания сгиба. Примеры

Пример I

Пусть в детали имеется сгиб, созданный в согнутом состоянии. Этот сгиб был разогнут с помощью команды Разогнуть.

К чему приведет изменение состояния — разгибание — сгиба?

У операции «разогнуть» появится ошибка «Невозможно выполнить операцию». Это объясняется тем, что разогнутый сгиб не пригоден для использования в операции «разогнуть».

Пример II

Пусть в детали имеется сгиб, созданный в разогнутом состоянии. На внешней или внутренней плоской грани этого сгиба построен эскиз. На основе эскиза построен вырез способом «по толщине».

К чему приведет изменение состояния — сгибание — сгиба, сделанное после выполнения указанных операций?

У выреза появится ошибка «Эскиз должен располагаться только на внешней или внутренней плоской грани листового тела». Она вызвана тем, что плоская грань, на которой базировался эскиз, стала цилиндрической.


Добавление и удаление ответвлений у линий-выносок и других обозначений

Добавление и удаление ответвлений у ранее созданных объектов оформления, таких как

– линия-выноска (обычная и позиционная),

– выносная надпись к многослойным конструкциям,

– знаки клеймения, маркировки, изменения,

– марка/позиционное обозначение с линией-выноской,

производится в процессе редактирования этих объектов.

Для перехода к редактированию объекта дважды щелкните по нему мышью. Запускается процесс редактирования, аналогичный процессу создания этого объекта.

– По умолчанию включен режим редактирования характерных точек объекта. Признаком этого является нажатая кнопка Редактировать точки на Панели специального управления. В этом режиме можно удалить ответвления. Чтобы удалить ответвление, щелкните мышью по характерной точке начала ответвления и нажмите клавишу <Delete>.

– Чтобы добавить ответвления, следует переключиться в соответствующий режим, нажав кнопку Добавление ответвлений на Панели специального управления. Затем укажите начальные точки новых ответвлений (см. рисунок).

Добавление ответвлений (на примере линии-выноски)

Для такого объекта, как линия-выноска, применяется несколько вариантов добавления ответвлений.

Между режимами редактирования характерных точек и добавления ответвлений можно произвольно переключаться при помощи кнопок Панели специального управления или команд в контекстном меню.

Завершив редактирование, нажмите кнопку Создать объект.


Добавление и удаление ответвлений у допусков формы и расположения

Добавление и удаление ответвлений у ранее созданных допусков формы и расположения производится при редактировании этих объектов.

Для перехода к редактированию дважды щелкните по нему мышью. Запускается процесс редактирования, аналогичный процессу создания этого объекта.

По умолчанию включен режим редактирования характерных точек. Признаком этого является нажатая кнопка Редактировать точки на Панели специального управления. В этом режиме можно удалить ответвления.

Чтобы удалить ответвление, щелкните мышью по характерной точке начала ответвления и нажмите клавишу <Delete>.

Чтобы добавить ответвления, выполните следующие действия.

1. Отожмите кнопку Редактировать точки.

На Панели специального управления становятся доступными кнопки Ответвление со стрелкой и Ответвление с треугольником.

2. Нажмите нужную кнопку Ответвление со стрелкой или Ответвление с треугольником, чтобы войти в режим добавления ответвлений.

3. Добавьте ответвления — так же, как при создании допуска формы и расположения.

Из режима добавления ответвлений можно переключиться в режим редактирования характерных точек — нажатием кнопки Редактировать точки на Панели специального управления. В этом режиме можно перемещать характерные точки, добавлять изломы ответвлений и удалять ответвления.


SHX-шрифт

SHX-шрифт — векторный шрифт собственного формата AutoCAD.


Преобразование текстов

Во время импорта документа формата DXF или DWG возможны следующие преобразования содержащихся в нем текстов:

– корректировка высоты и сужения символов,

– замена символов:

• символами или наборами символов TrueType-шрифта (возможно использование различных TrueType-шрифтов для различных символов),

• спецзнаками КОМПАС-3D.

Преобразование возможно для символов SHX-шрифтов и TrueType-шрифтов, использующихся в исходном документе.

Параметры преобразования задаются в файлах *.tfn. Файл *.tfn должен быть создан для каждого шрифта, который подлежит преобразованию. Файлы *.tfn должны находиться в подпапке TFN папки, содержащей файл библиотеки импорта форматов DWG и DXF (dwgdxfImp.rtw). В комплект поставки включены файлы *.tfn для некоторых SHX- и TrueType-шрифтов. В этих файлах также содержится описание структуры и синтаксиса файлов *.tfn.

Файлы *.tfn — текстовые, поэтому их можно просматривать и редактировать в любом текстовом редакторе, например, в программе Блокнот, входящей в состав ОС Windows.

При импорте учитываются все файлы *.tfn, находящиеся в папке TFN, кроме файлов, чьи имена начинаются со знака ~ (тильда). Благодаря этому можно отменить использование того или иного файла *.tfn, не удаляя его из папки TFN. Собственно имена файлов *.tfn могут быть любыми, но для удобства работы рекомендуется использовать имена, совпадающие с именами (или включающие имена) соответствующих шрифтов.

Имя файла SHX-шрифта или название TrueType-шрифта, параметры преобразования которого содержатся в конкретном файле *.tfn, указывается в тексте этого файла и, таким образом, не связано с именем файла *.tfn.

Файлы *.tfn применяются во время импорта, если в диалоге настройки импорта отключены опции Конвертировать текст из OEM в ANSI и Приводить тексты к системным.


Признак «разогнуто»

Признак «разогнуто» имеют листовые элементы, построенные в разогнутом состоянии, т.е. с включенной опцией Разогнуть. Пиктограммы таких элементов отмечаются в Дереве модели значком «разогнуто»:

Пиктограмма разогнутого листового тела

Пиктограмма разогнутого сгиба

Пиктограмма разогнутого сгиба по линии

Пиктограмма разогнутого сгиба по эскизу

Пиктограмма разогнутой подсечки

Чтобы отменить признак «разогнуто» (и, следовательно, привести сгибы элемента в согнутое состояние), следует отредактировать элемент, отключив опцию Разогнуть.

Кроме того, признаком «разогнуто» можно управлять с помощью команд Разогнуть и Согнуть из контекстного меню элемента в Дереве построения. Команды доступны также для нескольких выделенных листовых элементов.

Любой разогнутый элемент можно согнуть с помощью команды Согнуть, а согнутый — разогнуть с помощью команды Разогнуть из меню Операции — Элементы листового тела.

Различия между способами изменения состояния сгибов


Эскиз

Эскиз — объект модели, созданный на плоскости или плоской грани средствами чертежно-графического редактора.


Подчиненный режим

Подчиненный режим — режим просмотра и редактирования объектов спецификации непосредственно в документе (чертеже, фрагменте или модели).

Для работы с объектами спецификации в документе открывается специальное окно с колонками и разделами, идентичными колонкам и разделам спецификации.

Созданные и отредактированные в подчиненном режиме объекты постоянно хранятся в документе. Их можно в любой момент передать в связанную с этим документом спецификацию.


Способы построения дуг при создании линии

Набор способов, доступных при построении дуг, а также порядок действий при реализации способов зависят от того, каким объектом последовательности является дуга - первым или последующим.

При создании дуги-первого объекта линии доступны следующие способы построения:

– касательно к объекту,

– произвольная.

При создании дуги-последующего объекта линии доступны следующие способы построения:

– касательно к объекту,

– по нормали к предыдущему сегменту,

– произвольная.

При указании конечных точек дуг мышью в поле чертежа можно использовать ортогональное черчение.


Способы построения отрезков при создании линии

Набор способов, доступных при построении отрезка, а также порядок действий при реализации способов зависят от того, каким объектом последовательности является отрезок — первым или последующим.

При создании отрезка-первого объекта линии, если первая точка отрезка еще не зафиксирована, доступны следующие способы построения:

– параллельно или перпендикулярно объекту,

– касательно к объекту,

– касательно к одному объекту и параллельно другому,

– посередине между двумя параллельными прямыми,

– касательно к двум объектам,

– на биссектрисе угла.

Если первая точка отрезка, начинающего линию, уже зафиксирована, то использование описанных способов становится невозможным. В этом случае доступны те же способы, что и при создании отрезка-последующего объекта линии.

При создании отрезка-последующего объекта линии доступны следующие способы построения:

– параллельно или перпендикулярно объекту,

– касательно к объекту,

Как первый, так и последующие отрезки линии можно строить и без указания объектов — способом «по двум точкам». В этом случае работа команды Линия становится практически аналогичной работе команды Ломаная.

При указании конечных точек отрезков мышью в поле чертежа можно использовать привязку и ортогональное черчение.


Привязка

Привязка — механизм, позволяющий точно задать положение курсора, выбрав условие его позиционирования (например, в узлах сетки, или в ближайшей характерной точке, или на пересечении объектов и т.д.).


Тело

Тело — объект модели, имеющий некоторый объем и соотнесенный с каким-либо материалом. Тело, в отличие от компонента, не имеет самостоятельного файлового представления.


Перемещение объектов в групповой спецификации по вар. Б

В групповой спецификации по варианту Б перемещение объектов возможно при условии, что информация о количестве объектов на исполнение выдается блоками. Таким образом, чтобы переместить объекты в спецификации, где информация выдается по объектам, необходимо сначала сменить способ выдачи информации (перейти к отображению блоками), расположить объекты в нужной последовательности, а затем вернуть прежний способ выдачи информации (по объектами). При этом следует иметь в виду, что каждый из вспомогательных объектов, оказавшихся в начале раздела, предваряется строкой Обозн. исполн. Вспомогательные объекты, расположенные внутри раздела, не предваряются строкой Обозн. исполн. — они как бы «прикрепляются» к предшествующему базовому объекту.


Название спецификации

Название спецификации — текст над таблицей спецификации, расположенной на листе. Название спецификации может состоять из нескольких строк. Текст названия вводится пользователем. При этом можно задать различные названия для первого и последующих листов спецификации (см. раздел 6.2.6.12.3).


Системный раздел спецификации

Объекты спецификации не могут существовать вне разделов спецификации. Поэтому при отсутствии пользовательских разделов в стиле спецификации появляется системный раздел.

От пользовательского системный раздел спецификации отличается лишь тем, что его название (и пустые строки, обрамляющие название) никогда не отображается в бланке спецификации. Поэтому кнопка Заголовок... при настройке системного раздела недоступна. Все остальные свойства системного раздела спецификации (параметры заполнения и сортировки, свойства колонок и т.д.) могут быть настроены обычным образом.

Если не добавлять в стиль спецификации пользовательские разделы, то все ее объекты будут принадлежать единственному — системному — разделу и подчиняться его настройкам.

При добавлении в стиль спецификации первого пользовательского раздела системный раздел и его настройки автоматически удаляются.

При смене стиля спецификации с системным разделом на стиль с пользовательскими разделами возможна передача объектов из системного раздела в один из пользовательских. Условие передачи — совпадение номеров разделов.


Спецификация

Модуль проектирования спецификаций КОМПАС-3D позволяет создавать документы-спецификации (стандартное расширение файла spw).


Профиль штамповки

Профиль штамповки — это форма ее дна. Профиль определяется эскизом, на котором базируется штамповка. Тонкостенный элемент, получаемый выдавливанием эскиза в направлении построения, образует боковые стенки штамповки.


Стартовая страница

Стартовая страница — сервисный элемент, предоставляющий пользователю следующие возможности:

– получение справочных сведений о новых возможностях текущей версии системы,

– посещение сайтов компании АСКОН, Службы технической поддержки и Форума пользователей систем КОМПАС,

– связь со Службой технической поддержки по электронной почте,

– создание нового документа.

Стартовая страница автоматически загружается при первом (после установки) запуске системы. После закрытия Стартовой страницы доступ к ней возможен с помощью команды Справка — Стартовая страница.


Интерпретация значения шага

Если активен переключатель Шаг между соседними экземплярами, то это значение воспринимается как расстояние между соответствующими точками соседних экземпляров массива.

Если активен переключатель Шаг между крайними экземплярами, то это значение воспринимается как расстояние между соответствующими точками первого и последнего экземпляров массива, то есть заданное количество экземпляров равномерно размещается на участке, длина которого задана в поле Шаг.


Интерпретация значения шага

Если активен переключатель Шаг между соседними экземплярами, то значение, заданное в поле Шаг 2, воспринимается как угол между соседними осями сетки.

Если активен переключатель Шаг между крайними экземплярами, то это значение воспринимается как угол между первой и последней осями, то есть заданное количество экземпляров равномерно размещается на дуге, центральный угол которой задан в поле Шаг 2.


STEP AP203

STEP AP203 — формат, регламентированный стандартом ISO-10303 (том 21) и прикладным протоколом. Предназначен для передачи данных между различными прикладными системами, совместимыми с ISO-10303 STEP. Обменный файл — символьный, независимый от конкретного программного обеспечения и используемых платформ.

КОМПАС-3D обеспечивает передачу данных в обменный файл в соответствии со STEP AP203. В обменный файл записываются данные о геометрии модели, а также атрибуты изделия: Обозначение, Наименование, Автор, Описание, Структура сборки (дерево). При этом библиотечные элементы записываются, как отдельные файлы. Имя файла такого элемента — его наименование.


Стиль

Стиль — это набор свойств объекта, влияющих на его отображение. Например, стиль точки включает в себя внешний вид символа, которым рисуется точка, а также цвет.

В КОМПАС-3D поддерживаются стили линий, штриховок, точек, а также стили текстов. Помимо использования готовых стилей, поставляемых вместе с системой, можно создавать и применять свои собственные пользовательские стили.

Стили могут храниться как непосредственно в документе, так и в специальных файлах (библиотеках стилей). Файлы библиотек стилей линий имеют расширение lcs, стилей штриховок — lhs, стилей текстов — lts.


Замечание

Важно отметить, что в Окне подготовки данных отображаются настройки параметров текста текущего документа (например, сделанные в диалоге

Сервис — Параметры — Текущая сборка — Параметры таблицы отчета — Ячейка).

Чтобы оценить в Окне подготовки данных расположение текста в таблице, сделайте параметры в текущем документе одинаковыми с параметрами в документе, в который вы размещаете отчет.

Подробнее о настройках текста...


Элементы управления окна настройки параметров

Настройте отображение свойств для каждого столбца таблицы отчета, таблицы исполнений или таблицы отчета по массиву с таблицей изменяемых переменных. Описание общих и специфических настроек для отчетов, исполнений и параметров экземпляров массива приведено в таблицах.

Общие элементы настройки

Элемент

Описание

Свойство

Поле1 имен свойств. Выберите вариант свойства из списка, в котором доступны все локальные свойства документа.

Если нужное свойство в списке отсутствует, щелкните мышью по строке Настроить.... На экране появляется диалог, позволяющий настроить список и выбрать свойство из библиотеки свойств.

Выполните следующие действия.

– Чтобы добавить в список свойство из библиотеки, подключите библиотеку на вкладке Библиотеки свойств. Работа в диалоге аналогична настройке списка свойств для новых документов.

– Чтобы настроить список, включите опции рядом с нужными свойствами на вкладке Свойства. Выделенное в диалоге свойство автоматически становится выбранным вариантом свойства в столбце отчета.

Имя столбца

Строка заголовков столбцов в таблице. Например, свойство Масса может иметь в отчете заголовок Масса, кг.

По умолчанию заголовок столбца совпадает с именем свойством.

Введите нужный заголовок столбца.

Единица измерения

Поле1 единицы измерения свойства. Выберите нужную единицу измерения из списка.

Знаков после запятой

Поле, в котором можно задать количество знаков после запятой для значений свойств с вещественным типом данных. Максимальное количество знаков — 6.

Количество знаков после запятой в значениях предельных отклонений2 определяется автоматически по отклонению с максимальным количеством знаков (определение производится для каждой ячейки таблицы отдельно).

Ширина столбца, мм

Поле ширины столбца в таблице. Введите целое число в миллиметрах.

Выравнивание

Поле1 параметра выравнивания в ячейках столбца, кроме ячейки заголовка.

Выберите способ выравнивания. Параметры способа стилевое задаются в диалоге настройки параметров текста документа, в котором размещается таблица.

Переносить по словам

Опция, позволяющая отображать в одной или нескольких строках содержимое ячейки (обозначения, цифры, текст), длина которого превышает ширину столбца.

Если опция включена, то текст или группа знаков, отделенных пробелом, может быть перенесена на новую строку. Если опция выключена, то содержимое ячейки отображается одной строкой с сужением символов.

  1. Элемент управления позволяет выбрать вариант из раскрывающегося списка. После щелчка мышью по ячейке в ее правом углу появляется кнопка с треугольником. При нажатии на кнопку на экране появляется список, из которого можно выбрать вариант параметра.
  2. Предельные отклонения могут отображаться в таблице исполнений и в таблице отчета по массиву.

Дополнительные элементы настройки таблицы отчета
Элемент | Описание
Отображать | Опция, позволяющая включать/отключать показ столбца в отчете. Если опция включена, то столбец отображается в отчете. Если опция выключена, то столбец не отображается.
Сортировка | Поле, в котором отображаются параметры сортировки. – Если поле пусто, то сортировка по данному свойству не производится. – Если в поле находится текст, то данное свойство участвует в сортировке. Например, текст Приоритет 1 “А-Я” означает, что свойство имеет первый приоритет и его ячейки отсортированы в алфавитном порядке. Щелчком мыши на поле вызывается диалог, в котором можно настроить сортировку данных.
Группировка | Поле1 параметра, по которому производится группировка объектов в отчете. В поле отображается умолчательный способ группирования. Например, способ Совпадение для наименований означает, что все объекты с совпадающими наименованиями представлены одной строкой. Выберите способ группировки.
Оформление | Кнопка для вызова диалога, в котором можно настроить параметры оформления отчета.
  1. Элемент управления позволяет выбрать вариант из раскрывающегося списка. После щелчка мышью по ячейке в ее правом углу появляется кнопка с треугольником. При нажатии на кнопку на экране появляется список, из которого можно выбрать вариант параметра.

Дополнительные элементы настройки таблицы исполнений и таблицы отчета по массиву

Элемент

Описание

Формат значения

Поле1, позволяющее выбрать вариант отображения в таблице значения свойства или параметра экземпляра массива.

Например, в таблице исполнений для свойства Обозначение возможны следующие варианты отображения:

– Полные обозначения,

– Только номера исполнений.

Выбор нужного варианта для данного свойства равнозначен использованию переключателя Обозначение Панели свойств.

Объединять ячейки

Опция, позволяющая объединять соседние ячейки столбца таблицы исполнений в том случае, если содержимое этих ячеек одинаково, т.е. если отображаемое свойство имеет одно и то же значение для соседних исполнений.

Параметр2

Поле1, содержащее имя параметра экземпляров массива (например, координаты точек, задающих позиции экземпляров, имена переменных). Выберите имя параметра из списка. Перечень параметров экземпляров соответствует столбцам таблицы изменяемых переменных в выбранном массиве.
  1. Элемент управления позволяет выбрать вариант из раскрывающегося списка. После щелчка мышью по ячейке в ее правом углу появляется кнопка с треугольником. При нажатии на кнопку на экране появляется список, из которого можно выбрать вариант параметра.
  2. Только для таблицы отчета по массиву.


Создание стиля, оформления или основной надписи на основе прототипа

При добавлении стиля (или оформления, или основной надписи) в библиотеку вы можете использовать любой из уже существующих в ней объектов в качестве прототипа. Для этого выделите объект-прототип перед тем, как нажать кнопку Создать в диалоге работы со стилями (или оформлениями, или основными надписями).

В этом случае настроечный диалог, появляющийся после нажатия кнопки, будет содержать не умолчательные значения, а значения, соответствующие параметрам прототипа.

Стили, оформления и основные надписи, созданные с использованием прототипа, ничем не отличаются от созданных «с нуля».

При создании основной надписи на основе прототипа после нажатия кнопки Создать на экране появляется запрос на использование выбранной основной надписи в качестве прототипа. Вы можете подтвердить применение прототипа или отказаться от него.

В диалоге создания стиля линии есть кнопка Назначить прототип... Она позволяет сменить стиль-прототип в процессе создания нового стиля или выбрать прототип, если он не был указан ранее.


Результаты выполнения команды Отклонение поверхностей

В Информационном окне после выполнения команды Отклонение поверхностей отображаются следующие параметры.

– Количество измерений,

– Минимальное расстояние между поверхностями в точках измерений,

– Максимальное расстояние между поверхностями в точках измерений,

– Среднее арифметическое расстояний в точках измерений,

– Абсолютный минимум расстояния между поверхностями,

– Заданное количество результатов измерения, наиболее близких к минимальному расстоянию (первые искомые минимумы),

– Заданное количество результатов измерения, наиболее близких к максимальному расстоянию (первые искомые максимумы).

Для каждого измерения из групп первых искомых минимумов и максимумов отображается следующий набор данных:

– измеренное расстояние,

– координаты точки измерения на первой и второй поверхностях,

– среднее арифметическое значение расстояния.

Если измерение расстояния выполняется в обоих направлениях, то в начале каждой строки, содержащей результаты измерения, отображается стрелка, показывающая направление измерения. Прямое направление отмечается стрелкой влево, обратное направление — стрелкой вправо.

Если при выполнении команды выбрано отображение полного набора результатов измерений, координаты точек измерений и измеренное расстояние будут показаны для всех измерений.

Если в текущем сеансе выполнения команды будет выполнено повторное измерение, результаты предыдущего измерения в окне Информация будут заменены новыми и не сохранятся. Чтобы не потерять результаты измерений, необходимо сохранить их в файл на диске, используя команды меню окна Информация.


Команды создания поверхностей

Команды создания поверхностей и выполнения операций с поверхностями расположены в меню Операции — Поверхность.

Кнопки вызова этих команд расположены на панели Поверхности.

Импортированная поверхность

Поверхность выдавливания

Поверхность вращения

Кинематическая поверхность

Поверхность по сечениям

Заплатка

Линейчатая поверхность

Поверхность по сети кривых

Поверхность по сети точек

Поверхность по пласту точек

Поверхность соединения

Эквидистанта поверхности

Усечение поверхности

Разбиение поверхности

Продление поверхности

Сшивка поверхностей

Удалить грани


Поверхность

Поверхность — объект модели, представленный связанной совокупностью граней либо одной гранью. Грани поверхности не могут являться гранями каких-либо других объектов (других поверхностей и тел).


Исходные объекты для придания толщины

В качестве исходных объектов для придания толщины могут использоваться:

– грань тела или поверхности;

– связная совокупность граней одного тела или поверхности.

Если нужно добавить слой материала ко всем граням тела или поверхности, то это тело или поверхность следует указать в Дереве построения.


Нарушение топологии тел

Придание толщины производится перпендикулярно исходной поверхности. Нарушение топологии происходит, если задана такая толщина, что добавляемый слой имеет разрывы или участки поверхности, вырожденные в точку или линию, или новая поверхность самопересекается. В этом случае система выдает сообщение об ошибке и построение не выполняется.

Например, при добавлении слоя материала к грани, показанной на рисунке, образуется тело с нарушенной топологией.


Меню выбора символа

Меню, доступное во время создания специального знака. Оно появляется по щелчку правой кнопки мыши в поле Текст на Панели свойств или по двойному щелчку в поле ввода буквы диалога формирования надписи.


Элементы системы

Элементы системы — различные вспомогательные элементы, которые могут присутствовать в окне документа (сетка, фантомы, надписи около курсора и т.п.).

Цвет, установленный для элементов системы, используется также для отображения следующих объектов:

– выделенных и подсвеченных элементов документа,

– увеличенного курсора,

– фоновых видов и слоев,

– рамок выключенных видов,

– рамок, отображающихся на экране при выделении объектов и при увеличении масштаба рамкой,

– обозначений систем координат в графическом документе,

– габаритных рамок растровых и OLE-объектов и др.


Системный вид

Системный вид — вид, автоматически формирующийся в каждом чертеже КОМПАС-3D.

Этот вид имеет номер 0 и масштаб 1:1.

Его система координат совпадает с абсолютной системой координат чертежа.

Масштаб и положение системного вида изменить нельзя.


Номера системных стилей линий КОМПАС

Название | номер
основная | 0
тонкая | 1
осевая | 2
штриховая | 3
утолщенная | 4
штрихпунктирная с 2 точками | 5
осевая основная | 6
штриховая основная | 7
вспомогательная | 8
для линии обрыва | 9
ISO 02 штриховая линия | 10
ISO 03 штриховая линия (дл. пробел) | 11
ISO 04 штрихпунктирная линия (дл. штрих) | 12
ISO 05 штрихпунктирная линия (дл. штрих 2 пунктира) | 13
ISO 06 штрихпунктирная линия (дл. штрих 3 пунктира) | 14
ISO 07 пунктирная линия | 15
ISO 08 штрихпунктирная линия (дл. и кор. штрихи) | 16
ISO 09 штрихпунктирная линия (дл. и 2 кор. штриха) | 17
ISO 10 штрихпунктирная линия | 18
ISO 11 штрихпунктирная линия (2 штриха) | 19
ISO 12 штрихпунктирная линия (2 пунктира) | 20
ISO 13 штрихпунктирная линия (3 пунктира) | 21
ISO 14 штрихпунктирная линия (2 штриха 2 пунктира) | 22
ISO 15 штрихпунктирная линия (2 штриха 3 пунктира) | 23


Системное меню

Системное меню — меню, возникающее при нажатии на пиктограмму в левом верхнем углу окна. Содержит команды управления размерами и положением окна.


Вкладка Атрибуты

Вкладка появляется при просмотре информации о графическом документе, модели или спецификации КОМПАС-3D.

В окне просмотра этой вкладки показан структурированный список типов атрибутов, присвоенных текущему документу в целом. Атрибуты, присвоенные отдельным объектам документа, здесь не отображаются.

Описание элементов управления
Название | Описание
Новый | Для присвоения документу нового атрибута нажмите эту кнопку, выберите тип и введите значение атрибута.
Просмотреть... | Чтобы просмотреть значение существующего атрибута, выделите название его типа в списке и нажмите эту кнопку.
Редактировать... | Чтобы отредактировать значение существующего атрибута, выделите название его типа в списке и нажмите эту кнопку.
Удалить | Чтобы удалить атрибут документа, выделите его тип в списке и нажмите эту кнопку.
Копия в буфер | Чтобы скопировать в буфер обмена атрибуты объектов и документов, нажмите эту кнопку.
Перенос в буфер | Чтобы вырезать в буфер обмена атрибуты объектов и документов, нажмите эту кнопку.
Взять из буфера | Чтобы вставить из буфера обмена атрибуты объектов и документов, нажмите эту кнопку.

Чертежу, содержащему ассоциативные виды трехмерной модели, автоматически присваивается атрибут, в котором содержатся сведения о массе модели.


Вкладка Общие сведения

В окне просмотра этой вкладки показаны общие сведения об активном документе.

Описание элементов управления
Название | Описание
Автор | Поле для ввода сведений об авторе документа.
Организация | Поле для ввода наименования организации.
Комментарий | Поле для ввода комментария к документу. Комментарий может состоять из нескольких строк.
Создан | Поле содержит дату и время создания документа. Это поле заполняется автоматически и не может быть изменено пользователем.
Последнее изменение | Поле содержит дату и время последнего сохранения документа. Это поле заполняется автоматически и не может быть изменено пользователем.


Вкладка Внешние ссылки

В окне просмотра этой вкладки перечислены все внешние файлы, на которые ссылается данный документ, и (или) с которыми он связан.

Описание элементов управления
Название | Описание
Полный путь | Если полный путь и имя файла не помещаются в окне просмотра, происходит сжатие пути. Если нужно получить информацию о полном пути, вы можете включить опцию Полный путь и читать строки в окне просмотра, пользуясь линейкой прокрутки.
Записать в файл | При необходимости представленную в окне информацию о внешних связях документа можно записать в текстовый файл, воспользовавшись этой кнопкой


Отображение границ. Совет

Для удобства редактирования таблицы с выключенными границами вы можете включить их отображение на экране, активизировав переключатель Отображать сетку. Выключенные границы будут показаны в виде тонких серых линий. Эти линии отображаются на экране только в режиме редактирования таблицы и не выводятся на печать.


Таблица изменяемых переменных

Таблица изменяемых переменных — это таблица, хранящаяся в файле и содержащая переменные экземпляров массива. Таблица позволяет задавать новые значения переменных для всех экземпляров массива, кроме базового.

Управление переменными экземпляров доступно во всех массивах, кроме зеркального массива и массива по образцу.

Подробнее об управлении переменными экземпляров см. раздел 2.7.2.


Таблица изменений

Таблица изменений — специальная таблица для внесения информации об изменениях документа, не являющаяся частью основной надписи чертежа.


Вложенные разделы спецификации

Вложенные разделы спецификации располагаются внутри раздела, после всех объектов этого раздела.

Группы вложенных разделов называются блоками вложенных разделов.


Технологическая сборка

Технологическая сборка — сборка, содержащая технологические данные, например, результат пересчета размеров модели с учетом допусков, технологические объекты (центровые отверстия, отверстия для крепления и т.п.), технологические модели (люнеты, центры, инструменты и прочая оснастка).

Файл технологической сборки имеет расширение t3d.

Подробнее о технологической сборке см. раздел 2.16.1.


Шаблон заполнения

Обозначения стандартных изделий (например, винтов, шайб, штуцеров и т.д.) и материалов (например, швеллеров, бумаги, паронита и т.д.) подчиняются правилам, установленным ГОСТ на эти изделия и материалы.

В соответствии с этими стандартными правилами для каждого вида объектов (шайб, швеллеров и т.д.) в КОМПАС-3D сформированы шаблоны заполнения — своеобразные «заготовки» с полями для ввода характеристик объектов. В шаблоне также хранится информация о том, по каким полям и в каком порядке сортировать объекты данного вида.

При внесении стандартных изделий и материалов в спецификацию могут быть заполнены не все поля шаблона (например, винт не имеет покрытия).

В графе спецификации Наименование размещается строка, автоматически сформированная из заполненных полей предписанного стандартом обозначения выбранного объекта.


Стиль отчета

Стиль отчета — набор правил формирования отчета, влияющих на его заполнение и отображение. Стиль отчета хранится в Библиотеке стилей отчетов — файле *.lrt.


Окно подготовки данных

Окно подготовки данных — режим работы команды Создать отчет, который служит для просмотра и редактирования данных, помещенных в отчет, и дополнительных настроек отчета.

Из Окна подготовки данных настроенный отчет может быть размещен в документ, выведен на печать или сохранен в отдельный файл.

Подробнее об Окне подготовки данных см. раздел 5.2.3.4.1.


Использование команд меню

Меню Файл

Меню Редактор

Меню Вид

Меню Вставка

Меню Формат


Текстово-графический документ

Встроенный текстовый процессор КОМПАС-3D позволяет создавать текстово-графические документы (расширение фaйлa kdw). В такой документе помимо собственно текстовой части могут быть вставлены таблицы и графические иллюстрации (чертежи и фрагменты). Текстово-графический документ, как и чертеж, оформляется рамкой и основной надписью.


Ссылка

Ссылка — текст, ассоциативно связанный с каким-либо другим объектом, содержащим текст.

Объект, с которым связана ссылка, называется источником ссылки.

Подробнее о ссылках см. раздел 3.4.1.4.


Текстовые объекты документа

– текст текстового документа,

– текст основной надписи,

– текст технических требований,

– текст надписей в составе линии-выноски и обозначений,

– текст на чертеже,

– текст в таблице.


Текстовые шаблоны

Текстовые шаблоны — фрагменты текстов, хранящиеся во внешних файлах *.tdр.

Они содержат различные типовые тексты и служат для автоматизации ввода часто встречающихся строк или обозначений.

Работа с текстовыми шаблонами ведется в окне Библиотекаря текстовых шаблонов.


Теоретическая поверхность

Теоретическая поверхность — математическое описание формы грани объекта модели в КОМПАС-3D. Теоретические поверхности есть у граней объектов «поверхность» и «тело». Границы грани, т.е. положение ребер грани на теоретической поверхности, определяются другими условиями.

Подробнее о теоретической поверхности см. раздел 2 Приложения IX.


Инструментальная панель Библиотекаря текстовых шаблонов

Инструментальная панель
Библиотекаря текстовых шаблонов

Инструментальная панель содержит кнопки для вызова наиболее часто используемых команд.


Сетчатая прозрачность

Сетчатая прозрачность — способ отображения прозрачного объекта, при котором область, занимаемая этим объектом, заполняется отдельными пикселами. Цвет пикселов соответствует цвету объекта при нулевой прозрачности. Пикселы размещаются на экране, образуя регулярную структуру — сетку. «Ячейки сетки», т.е. участки, где пикселы прозрачного объекта отсутствуют, тем крупнее, чем большее значение параметра «Прозрачность» имеет данный объект.


Дерево построения модели

Дерево построения модели — структурированный список («дерево»), отражающий состав, последовательность построения модели, состояния объектов модели и связи между ними.


Инструментальная панель вкладки Построение окна Дерево модели

Инструментальная панель расположена на вкладке Построение в верхней части окна Дерево модели. Она содержит кнопки, позволяющие настроить вид Дерева построения модели, и кнопку отображения части Дерева построения в дополнительном окне.


Секущие объекты

В качестве секущих могут использоваться следующие объекты.

– Кривые, лежащие на усекаемой поверхности:

• пространственные кривые;

• ребра тел или поверхностей.

Может быть указана одна незамкнутая кривая или ребро. Замкнутых кривых, а также сегментов ломаных, можно указать несколько. Усечение происходит по кривой в пределах усекаемой поверхности.

Совет

– Объекты, пересекающие усекаемую поверхность:

• импортированная или построенная в модели поверхность;

• тело;

• грань или набор смежных граней одной поверхности или тела;

• координатная или вспомогательная плоскость.

Может быть указан один объект или набор граней. Если указано тело, то секущими объектами являются все его грани.

Усечение происходит по линии пересечения усекаемой и секущей поверхностей.

– Контуры в эскизе, произвольно расположенном в пространстве.

Эскиз может содержать или один незамкнутый контур, или несколько замкнутых контуров. Контур не должен иметь самопересечений.

Может быть указан один эскиз в Дереве построения. Если эскиз расположен на усекаемой плоскости, то можно указать элементы контура в окне модели.

Усечение происходит по линии пересечения с поверхность, образованной выдавливанием эскиза перпендикулярно его плоскости (см. рисунок).

Пример усечения поверхности при помощи контура в эскизе: а) усекаемая поверхность и секущий объект, б) объекты после указания, в) результат усечения
а) | б) | в)

Секущие объекты всех типов должны однозначно определять границу отсечения, например, незамкнутая кривая или грань должны полностью пересекать усекаемую поверхность.

Подробнее о выборе объектов...


Совет

Рекомендуется в качестве секущих объектов указывать кривые, которые являются исходными или производными объектами усекаемой поверхности.

Пример использования исходного объекта: усечение поверхности, построенной по сети кривых, по одной из этих кривых.

Пример использования производного объекта: усечение поверхности по эквидистантной кривой, построенной смещением вдоль усекаемой поверхности.


Усекаемые объекты

В качестве усекаемой поверхности могут использоваться следующие объекты:

– импортированная или построенная в модели поверхность;

– поверхность тела;

– грани одной поверхности или тела.


Список типов выделенных объектов

Список типов выделенных объектов находится в верхней части окна Свойства.

Позволяет выбрать тип объектов, чтобы указать, со свойствами каких именно из выделенных объектов будет вестись работа.

– Если выделенных объектов нет, то список типов объектов содержит одну строку — Нет.

– Если выделенные объекты есть, то список содержит строку Все - N, где N — общее количество выделенных объектов, и строки, сформированные по шаблону Имя типа - n, где «Имя типа» — название типа объектов, а n — количество выделенных объектов данного типа.

Например, выделены две концентрические окружности с обозначением центра и радиальными размерами. Список типов выделенных объектов будет содержать следующие строки:

Все - 5
Обозначения центра - 1
Окружности - 2
Радиальные размеры - 2

Если выделены объекты только одного типа, то строка Все отсутствует в списке типов объектов.

При выделении дополнительных объектов или исключении объектов из числа выделенных список типов динамически изменяется.

После выбора из списка строки Все в таблице свойств отображаются общие свойства (если они есть) для всех выделенных объектов.

После выбора из списка конкретного типа объектов в таблице свойств отображаются свойства объектов данного типа. При этом набор выделенных объектов в окне документа не изменяется.


Локальная система координат (ЛСК)

Локальная система координат — система координат, произвольно расположенная и ориентированная относительно абсолютной системы координат.


Пользовательская переменная

Пользовательская переменная — переменная, созданная пользователем произвольно.

Пользовательские переменные образуют главный раздел списка переменных в Окне переменных. Они не имеют прямой связи с параметрами объектов. Используются для получения значений других переменных.


Пользовательские меню при вводе текста

При вводе размеров и технологических обозначений часто требуется вводить повторяющиеся тексты и нормализованные числовые значения. Повторяющиеся тексты требуются также при заполнении основных надписей документов.

Для ускорения ввода таких текстов и чисел разработан механизм пользовательских меню. Схема его работы следующая.

Пользователь в специальном текстовом файле формирует структуру разнообразных меню — указывает, из каких разделов и подразделов состоит меню, какие строки в них расположены и какой текст должен вводиться в документ при выборе из меню каждой строки. При вводе текстовой части размеров и технологических обозначений или заполнении основной надписи в определенных полях и графах можно вызвать соответствующее всплывающее меню. Выбор какой-либо строки из него приводит к появлению соответствующего текста в поле или ячейке.

Вызвать пользовательское меню можно двумя способами.

– Установить курсор на поле ввода текста в Строке параметров объектов и нажать правую кнопку мыши.

– В диалоге ввода текстовой части размера или технологического обозначения дважды щелкнуть мышью в поле ввода. Этот же способ вызова пользовательского меню — двойной щелчок мышью в ячейке — используется при заполнении основной надписи документа.

Смотрите также

Файл пользовательских меню


Использование линеек прокрутки

Если вам нужно работать с объектами документа, которые в данный момент находятся за пределами текущего окна изображения, используйте вертикальную и горизонтальную линейки прокрутки. Они отображаются в окне документа внизу и справа.

Для прокрутки изображения в окне нажимайте кнопки со стрелками, расположенные по краям линеек. Можно также перемещать «ползунок», имеющийся на линейке.

Если вы пользуетесь мышью с колесом, то для прокрутки изображения при работе с текстовыми документами и документами-спецификациями можно вращать колесо мыши. Для постраничной прокрутки следует дополнительно удерживать нажатой клавишу <Shift>.


Использование всплывающих подсказок

Если вы только приступаете к освоению КОМПАС-3D, очень полезной может оказаться возможность быстро узнать о назначении кнопки, поля ввода и т.д. Для этого в системе предусмотрен вызов так называемых всплывающих подсказок.

Чтобы увидеть такую подсказку, подведите курсор к интересующему вас элементу и задержите на некоторое время. Рядом с курсором появится «ярлычок» с кратким описанием назначения этой кнопки.

Если сдвинуть курсор с кнопки, подсказка автоматически исчезнет с экрана.

Пример всплывающей подсказки


Таблица переменных

Таблица переменных — таблица, хранящаяся в файле и содержащая предопределенные значения внешних переменных этого файла. Использование таблицы переменных при вставке файла в другой документ позволяет быстро присваивать внешним переменным этого файла нужный набор значений.

Таблица переменных создается и редактируется пользователем. Возможно чтение таблицы из файла формата Excel и запись таблицы в файл этого формата.

При необходимости таблица переменных может быть удалена из файла.

Подробнее о таблице переменных см. раздел 7.1.5.4.


Вершина

Вершина — примитив, представляющий собой окончание ребра.

В общем случае как вершины при указании определяются начала координат, точки, в том числе в эскизах, контрольные и присоединительные точки.

Особый случай вершины — ребро нулевой длины (например, вершина конуса).


Меню Вид (меню Библиотекаря)

Меню Вид
(меню Библиотекаря)

Группа команд позволяет настраивать внешний вид диалога вставки текста.

Команда Панель инструментов

Команда Окно просмотра


Активный вид (слой)

Активный вид (слой) — вид (слой), объекты которого доступны для выполнения операций редактирования и удаления.

Все объекты, принадлежащие активному виду (слою), изображаются на экране с заданным стилем (например, линии сохраняют свою толщину, а точки — начертание), но одного и того же цвета, установленным для данного вида (слоя) в Менеджере документа.

Активными в данный момент могут быть несколько видов (слоев) документа.

Имеется возможность печати видов и слоев теми цветами, которые установлены для их отображения в активном состоянии.


Фоновый вид (слой)

Фоновый вид (слой) — вид (слой), объекты которого доступны только для выполнения операций привязки к точкам или элементам. Эти виды (слои) нельзя перемещать, а их содержимое недоступно для редактирования.

Все объекты фоновых видов (слоев) изображаются на экране одинаковым стилем линии, который можно настроить. Стили, выбранные для объектов при их создании, не учитываются.

Вид (слой) обычно делается фоновым в том случае, если его формирование завершено, и он нужен лишь в качестве «подложки» для размещения других объектов.

Фоновыми в данный момент могут быть несколько видов (слоев) документа.

Настройка отрисовки фоновых слоев действительна только для текущего вида чертежа. Если вид становится активным, то все его видимые объекты отображаются цветом, выбранным для этого вида. Если вид становится фоновым, то все его видимые объекты отображаются стилем, заданным для фоновых видов.

Стиль линии и цвет, выбранные для отображения фоновых видов и слоев, невозможно использовать при печати.


Погашенный вид (слой)

Погашенный вид (слой) — вид (слой), содержимое которого не отображается на экране вне зависимости от того, активный он или фоновый. Таким образом, погашенный вид (слой) полностью недоступен для любых операций.

Возможность печати всех погашенных видов и слоев зависит от настройки фильтров вывода на печать. В то же время возможностью печати тех или иных погашенных слоев можно управлять с помощью их свойства печать в документе.


Текущий вид (слой)

Текущий вид (слой) — вид (слой), в который помещаются вновь создаваемые объекты. В чертеже новые объекты располагаются на текущем слое текущего вида, а во фрагменте или модели — на текущем слое.

Только один вид чертежа и только один слой вида (фрагмента, модели) может быть текущим в данный момент.

В текущем слое можно выполнять любые операции по вводу, редактированию и удалению объектов.

Текущим можно сделать любой вид (слой). При этом он автоматически становится видимым, а в графическом документе также активным. Пока вид (слой) является текущим, эти параметры изменить нельзя (т.е. текущий вид (слой) невозможно ни погасить, ни сделать фоновым).

После того как статус текущий присваивается другому виду (слою), состояние вида (слоя), который был текущим ранее, восстанавливается. Например, в какой-то момент работы над чертежом Вид 1 был текущим. Вид 2 в это время был фоновым и видимым. Затем Вид 2 сделали текущим, в результате чего он стал активным. После завершения редактирования Вида 2 текущим вновь был сделан Вид 1. Вид 2 при этом снова стал фоновым.


Видимый вид (слой)

Видимый вид (слой) — вид (слой), содержимое которого отображается на экране.

При этом активные виды (слои) показываются выбранными для них цветами, а фоновые — установленным стилем.


Надпись вида

Надпись вида — текстовый объект, входящий в состав вида чертежа. Служит для автоматического формирования и обновления текста, сопровождающего вид.

Надпись вида состоит из следующих элементов:

– буквенное или цифровое обозначение,

– знак «развернуто»,

– масштаб вида,

– знак «повернуто»,

– угол поворота,

– номер листа,

– обозначение зоны.

Надпись вида, в котором изображен узел или узел в сечении, может содержать только цифровое обозначение и номер листа.

Любой из перечисленных элементов пользователь может по своему усмотрению включить в надпись вида или исключить из нее при настройке параметров вида.

Все элементы надписи вида являются ссылками.

Если в чертеже имеются ассоциативные виды исполнений модели, одно из которых является зеркальным, то надписи этих видов содержат, кроме описанных выше элементов, ссылки на обозначения исполнений. Эти ссылки включаются в надписи автоматически.


Вид-владелец

Вид-владелец — вид чертежа-владельца, содержащий вставку вида из другого чертежа.


Команда Панель инструментов (меню Библиотекаря)

Команда Панель инструментов
(меню Библиотекаря)

Команда позволяет управлять отображением инструментальной панели. При вызове команды рядом с ее названием появляется и исчезает «галочка». Наличие «галочки» означает включенный показ инструментальной панели.


Вид-источник

Вид-источник — вид чертежа-источника вставки, изображение из которого вставлено в вид-владелец.


Команда Окно просмотра (меню Библиотекаря)

Команда Окно просмотра
(меню Библиотекаря)

Команда позволяет управлять отображением Окна просмотра. При вызове команды рядом с ее названием появляется и исчезает «галочка». Наличие «галочки» означает включенный показ Окна просмотра.


Команды построения видов

Кнопки вызова команд построения видов находятся на инструментальной панели Виды.

Создать новый вид

Стандартные виды...

Произвольный вид...

Проекционный вид

Вид по стрелке

Местный вид

Выносной элемент

Разрез/Сечение

Местный разрез

Разрыв вида

Параметры текущего вида

Для вызова команд построения видов можно также выбирать их названия в меню Вставка, для вызова команды изменения параметров текущего вида — в меню Сервис.


Поле Управление видами

В поле Управление видами отображается номер или имя и номер (это зависит от настройки, сделанной в диалоге параметров видов) текущего вида. Чтобы сделать текущим другой вид, введите или выберите из списка нужный номер (имя и номер). При выделении вида в списке объекты, расположенные в нем, и его габаритная рамка выделяются в окне документа. Это позволяет быстро выбрать нужный вид.

В строках списка кроме номеров (имен) видов отображаются также значки, позволяющие управлять состоянием видов, т.е. изменять значения свойств активность и видимость видов. Для изменения значения свойства на противоположное щелкните мышью на значке. Изменение состояния вида немедленно отображается на экране.

Состояние текущего вида изменить невозможно.


Работа с прикладной библиотекой в режиме окна

Работа с библиотекой ведется как со стандартным окном Windows. Вы можете изменять размер окна библиотеки, а также сворачивать (минимизировать) его, оставляя на экране только пиктограмму.

В левой части окна отображается список команд текущей библиотеки, которые могут быть сгруппированы по разделам. Чтобы развернуть содержание какого-либо раздела, установите курсор на значке плюса рядом с заголовком раздела и щелкните левой кнопкой мыши. Повторный щелчок на этом символе (после разворачивания раздела он отображается как минус) приведет к сворачиванию содержания раздела.

В правой части окна отображаются слайды, облегчающие поиск нужной команды.

Для запуска библиотечной команды на исполнение выберите ее название в списке и нажмите клавишу <Enter>. Можно также дважды щелкнуть левой кнопкой мыши на названии команды.

Для закрытия окна библиотеки дважды щелкните левой кнопкой мыши на кнопке системного меню в левом верхнем углу окна.


Рабочая область главного окна приложения

Рабочая область главного окна приложения — область, в которой открываются подчиненные окна (окна документов).


Управление масштабом отображения документа в окне

Информацию о различных способах изменения масштаба отображения документа см. в следующих разделах:

Увеличение и уменьшение масштаба изображения

Явное задание масштаба изображения

Увеличение масштаба произвольного участка изображения

Масштаб по выделенным объектам

Плавное изменение масштаба

Отображение эскиза целиком

Отображение документа целиком

Переход к предыдущему или последующему масштабу отображения

Автоматический подбор масштаба

Смотрите также

Использование линеек прокрутки

Обновление изображения


Задание положения точки на грани(для построения изопараметрической кривой)

Задание положения точки на грани
(для построения изопараметрической кривой)

Положение точки на грани можно задать двумя способами:

Способ 1

Введите в полях Параметр U, % и Параметр V, % нужные значения параметров смещения (U и V) точки на теоретической поверхности грани в процентах (от 0 до 100) или задайте их счетчиком. Изменение значений параметров точки отображается на ее фантоме в окне модели. Также положение точки можно изменить, перемещая мышью ее характерную точку.

Способ 2

Укажите в Дереве построения или в окне модели нужный точечный объект.

Выбор объектов в Дереве построения

Выбор объектов в окне модели

На кнопке Объект отображается «галочка», а в поле рядом с кнопкой — название объекта. Это свидетельствует о наличии ассоциативной связи точки с выбранным объектом. Благодаря этой связи построенная кривая будет следовать за объектом при изменении его положения.

При необходимости связь можно отменить, нажав кнопку Объект. «Галочка» на кнопке исчезнет, поле очистится.

Общие сведения о теоретической поверхности грани и изопараметрических кривых...

Изопараметрическая кривая...


Задание положения вершины сплайна на грани

Положение вершины сплайна на указанной грани можно задать двумя способами:

Способ 1

Укажите положение вершины на грани щелчком мыши или введите в поля Параметр U, % и Параметр V, % нужные значения параметров U и V в процентах (от 0 до 100).

Способ 2

Укажите в Дереве построения или в окне модели нужный точечный объект.

Выбор объектов в Дереве построения

Выбор объектов в окне модели

На кнопке Объект отображается «галочка», а в поле рядом с кнопкой — название объекта. Это свидетельствует о наличии ассоциативной связи вершины с выбранным объектом. Благодаря этой связи построенная кривая будет следовать за объектом при изменении его положения. При необходимости связь можно отменить, нажав кнопку Объект. «Галочка» на кнопке исчезнет, поле очистится.

Общие сведения о теоретической поверхности грани и изопараметрических кривых...

Сплайн на поверхности...


Зона

Зона — выделенный в пространстве модели объем. Служит для выбора объектов, находящихся внутри или снаружи от этого объема, либо пересекающихся с ним.