Лекция № 10
Основы работы в системе MAPLE V

1.1 Начальные навыки.


 HYPERLINK "http://detc.ls.urfu.ru/Assets/aMATH0011/mp12.htm" 1.2 Пакеты расширений MAPLE V. 


 HYPERLINK "http://detc.ls.urfu.ru/Assets/aMATH0011/mp12.htm" \l "mp13" 1.3 Работа со справочной системой Maple V.


 HYPERLINK "http://detc.ls.urfu.ru/Assets/aMATH0011/mp12.htm" \l "mp14" 1.4 Алфавит Maple-языка и его синтаксис.


 HYPERLINK "http://detc.ls.urfu.ru/Assets/aMATH0011/mp13.htm" 1.5 Определение функций пользователя.

1.1 Начальные навыки.
	
	Графический интерфейс пользователя. 


Приложение Maple 6 имеет стандартный графический интерфейс пользователя для программ, работающих под управлением операционных систем семейства Windows. При загрузке программы на экране монитораотображается окно, в котором можно выделить несколько основных частей. 

В верхней части, непосредственно под заголовком окна, находится главное меню системы (команды главного меню мы будем рассматривать по ходу изложения материала).
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	Вид основного меню (его команд) меняется в завивсимости от контекста: если на рабочем листе выделен графический объет, то меню содержит команды для работы сграфикой.Всего может быть отображено пять видов основного меню:


· Стандартное меню рабочего листа 

· Меню электронной таблицы 

· Меню двумерной графики 

· Меню трехмерной графики 

· Меню справочной системы 

Ниже главного меню расположена основная панель инструментов с рядом кнопок, дублирующих наиболее часто используемые команды главного меню. Непосредственно под основной панелью инструментов расположена контекстная панель инструментов, вид которой зависит от того, в какой области рабочего листа расположен курсор и что в этой области отображается. Существует пять видов контекстных панелей инструментов: 

· для области ввода 

· для области вывода 

· для выделенного двумерного графика 

· для выделенного трехмерного графика 

· для выделенной анимационной графики 

Большую часть окна интерфейса занимает рабочая область, в которой располагаются рабочие листы, где вводятся команды и отображаются результаты их выполнения. Внижней части окна расположена стока состояния, в которой отображаются некоторые параметры работы системы Maple, а также краткая информация относительно выбранной команды меню или кнопки понели инструментов.

	



	Работа в диалоговом режиме. 


Диалог с системой Maple V происходит на языке задания системе вопросов: пользователь вводит на рабочем листе комады и нажатием клавиши [Enter] передает их на исполнение ядру системы Maple. 

Рабочий лист состоит из области ввода и области вывода. В первой пользователь вводит команды Maple, а в области вывода отображаются результаты выполнения команд и операторов, а также двумерная и трехмерная графика (если задан режим вставки графики в рабочий лист, а не отображения ее в отдельном окне).

Содержимое областей ввода и вывода образуют отдельный блок - Группу вычислений, которая на рабочем листе отмечается слева квадратной скобкой. Основное свойство группы вычислений заключантся в том, что все ее операторы и команды выполняются при однократном нажатии клавиши [Enter].

	Для начала работы нам понадобится знание некоторых одиночных и составных знаков элементов синтаксиса Maple: 

	> 
	Знак приглашения к заданию вопроса. 

	| 
	Мигающая вертикальная черта - маркер ввода. 

	; 
	Знак фиксации конца выражения с выводом результата вычислений на экран. 

	: 
	Знак фиксации конца выражения, предотвращающий вывод результата на экран. 

	:= 
	Оператор присваивания (например, x:=4). 

	= 
	Оператор равенства для задания равенств и логических условий (например, a=b), указания областей изменения переменных (например, i=1..5) и значений параметров - опций в функциях и командах (например, color=black). 


	



	Рабочий лист. Область ввода. 


Область ввода - это область рабочего листа, в которой пользователь вводит информацию. Эта информация может быть двоякого рода: 

· команды и операторы Maple 

· текстовые комментарии. 

По умолчанию при создании нового рабочего листа устанавливается режим ввода команд и операторов.Указанием на это является приглашение ввода на рабочем листе - символ >. Операция Edit ->Entry Mode или клавиша F5 служит для включения/выключения режима ввода текста. Если режим текстового ввода включен, приглашение в виде знака > исчезает, и имеется возможность ввода текстовых комменариев с применением панели форматирования для задания параметров текста. Если режим отменен, то можно вводить математические выражения (Maple-текст). 

Режим ввода команд.Команды можно отображать либо в форме синтаксиса языка Maple, либо в виде привычной математической записи. Переключаться между режимами ввода можно с помощью кнопки [image: image4.png]


на контекстной панели инструментов или используя комады главного меню.
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	Для ввода результата в стандартной математической форме надо до начала набора команд выполнить команду Insert -> Standart Math Input, результатом выполнения которой будет смена курсора в области ввода на вопросительный знак. Также появится контекстная панель инструментов ввода команд Maple с полем ввода.


При этом в поле ввода будет отображаться команда в форме синтаксиса Maple, а в области ввода эта же команда будет отображениа в математической нотации (если команда имеет соответствующую математическую запись) по завершении ввода нажатием кнопки [image: image6.png]


или клавиши [Enter].

Режим ввода текстовых комментариев - это такой режим, при котором любая математическая информация вопринимается как текст (невыполняемый). Для встаки текстового комментария следует выполнить команду Insert -> Text или нажать кнопку [image: image7.png]


на основной панели инструментов.

В текстовый комментарий можно вставлять формулы, причем в зависимости от способа встаки эти формулы могут воспринимаются как текст или как вычисляемые выражения.
Для вставки формул-текста достаточно выполнить команду Insert -> Standart Math или нажать кнопку [image: image8.png]


на основной панели инструментов. Технология ввода формул аналогична вводу команд Maple в математической нотации (см. выше).
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	Для вставки в комментарии выполняемых команд необходимо выполнить команду Insert -> Maple Input (для вставки в форме Maple-команд) или Insert -> Standart Math Input (для вставки в стандартной математической форме). Введенные таким образом формулы можно в любой момент вычислить, выполнив команду Execute контекстного меню для вставленной формулы или нажатием кнопки [image: image10]на контекстной панели инструментов. 


В Maple 7 на контекстрой панели инструментов введена новая кнопка [image: image11.png]


, которая дублирует команду основногоменю Edit -> Execute -> Worksheet (Выполнить всю страницу)
Переключение между исполняемым выражением или неисполняемым (текстом) можно осуществить с помощью кнопки [image: image12.png]


контекстной панели инструментов.

Вернемся к процедуре ввода команд. Если команда достаточно длинная, то Maple автоматически переходит на следующую строку (если команда представлена не как поток символов, а разбита пробелами на слова). Расположенная в нескольких строках команда является одним целым.

В одной строке можно вводить несколько операторов, разделенных точкой с запятой (;) или двоеточием (:). Но иногда удобно задать несколько операторов по одному на строке в области ввода. Перенос команды на новую строку (без выполнения) осуществляется нажатием комбинации клавиш [Shift+Enter]. Все введенные таким способом операторы образуют одну группу и последовательно выполняются однократным нажатием клавиши [Enter].

Для того, чтобы ПОСЛЕ выплнения очередной команды, автоматически появлялась новая ячеейка с приглашением Maple для ввода команд, необходимо выполнить команду Option -> Insert Mode.

Если режим автоматической вставки новой ячейки не включен, вы можете воспользоваться кнопкой [image: image13.png]


стандартной панели инструментов (ячека появится ниже той, в которой находится курсор) или воспользоваться командой меню Insert -> Execution Group: для вставки новой ячеки перед той, в которой находится курсор - Before Cursor ([Ctrl+K]), и, соответственно, After Cursor ([Ctrl+J]) для вставки новой ячейки после курсора.

Пользователь вводит команды Maple в строке ввода, используя клавиатуру. При этом ему приходится запоминать, особенно при первом ознакомлениис системой, достаточно большое их количество. В интерфейс пользователя в версии Maple V R5 были введены палитры - небольшие окна с набором шаблонов для ввода определенных команд и объектов. Всего Maple предлагает чутыре вида палитр:

	[image: image14.png]



	· Палитра для ввода символов (команда View->Palettes->Symbol Palette) - для ввода греческих букв и некоторых символов. 

· Палитра с шаблонами для ввода выражений Maple (команда View->Palettes->Expression Palette) 

· Палитра с шаблонами для ввода матриц размерности не более (4 х 4) (команда View->Palettes->Matrix Palette) 

· Палитра с шаблонами для ввода векторов View->Palettes->Vector Palette(Появилась в Maple 7) 


В Maple 7 в подменю View->Paletts добавлены еще две команды: отобразить все палитры Show All Palettes и скрыть все палитры Hide All Palettes .

Размеры наборных панелей устанавливаются командами подменю Options -> Palette Size, при выборе которых они отображаются малого размера (Small), большого размера (Large) или размеры выбираются приложением Maple в зависимости от размеров экрана монитора компьютерам (Best Choise).

	



	Рабочий лист. Область вывода. 


Результаты выполнения операторов, введенных в область ввода, отображаются в области вывода. Для неграфического вывода Maple позволяет задать три формата:

	>f(x):=sin(x);
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>Int(f(x),x)=int(f(x),x);
Int(sin(x),x) = -cos(x)

> Int(f(x),x)=int(f(x),x);
  /
 |
 |  sin(x) dx = -cos(x)
 |
/

> Int(f(x),x)=int(f(x),x);
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> Int(f(x),x)=int(f(x),x);
· [image: image18.png][ sy dr = —costry




	· в виде строковой записи - аналогично формату ввода Maple-команд 

· в виде символьной записи - имитирует запись формул в математической нотации 

· в стандартном математическом виде, причем в этом случае возможны два варианта вывода: редактируемый (можно выделять отдельные элементы выводящегося выражения, копировать их) и не редактируемый (при выделении области вывода выделяется все выражение целиком). 

Для установки одного из возможных вариантов отображения информации в области вывода необходино выполнить команду Option -> Output Display. В таблице приведены соответствующие подкоманды:

Maple Notation 
Строковый вывод результата 

Character Notation 

Вывод в форме символьной записи 

Typeset Notation 

не редактируемый вывод в математической форме 

Standart Math Nonanion 
Редактируемая математическая нотация (установлена по умолчанию) 




	



	Простейшие графики. 


Графика Maple V реализует все мыслимые (и даже "немыслимые") варианты математических графиков - от построения графиков простых функций в Декартовой и в полярной системах координат до создания реалистических образов сложных пересекающихся в пространстве фигур с их функциональной окраской. Возможны наглядные графические иллюстрации решений самых разнообразных уравнений, включая системы дифференциальных уравнений.

В само ядро Maple V встроено ограниченное число функций графики. Это прежде всего функция для построения двумерных графиков (2D-типа) - plot( ) и функция для построения трехмерных графиков (3D-типа) - plot3d( ). Они позволяют строить графики наиболее распространенных типов. Для построения графиков специального типа (например, в виде векторных полей градиентов, решения дифференциальных уравнений, построения фазовых портретов и т.д.) в пакеты расширения системы Maple V включено большое число различных графических функций. Для их вызова необходимы соответствующие указания.

Для построения двумерных графиков служит функция plot( ). Она задается в виде: 
>plot(f, h, v) 
или
>plot(f, h, v, o) 
где 

f - функция (или функции), чей (чьи) график(и) строятся,
h - переменная с указанием области ее изменения по горизонтали,
v - (не обязательный параметр) заданная опционально переменная с указанием области ее изменения по вертикали,
o - не обязательный параметр) опция или набор опций, задающих стиль построения графика (толщину и цвет кривых, тип кривых, метки на них и т.д.).

Самыми простыми формами задания этой функции служат: 
>plot(f, xmin..xmax) - построение графика функции f, заданной только именем;
>plot(f(x), x=xmin..xmax) - построение графика функции f(x).

Диапазон изменений независимой переменной x задается как xmin..xmax, где xmin и xmax - минимальное и максимальное значение x,
.. (две точки) - составной символ, указывающий на изменение независимой переменной. Разумеется, имя x здесь дано условно - независимая переменная может иметь любое допустимое имя.

С опциями двумерной графики мы познакомимся в Лекции №7.

Для построения графиков трехмерных поверхностей Maple имеет встроенную в ядро функцию plot3d. Простейшие форматы ее представления: 
>plot3d(expr1, x=a..b, y=c..d, p)
>plot3d(f, a..b, c..d, p)

где 

f - функция
expr1 - выражение, отражающее зависимость от х и у,
а и b — числовые константы действительного типа,
c и d — числовые константы или выражения действительного типа
р — параметры-опции.

Вывод графики в Maple можно осуществлять непосредственно в рабочий лист (режим по умолчанию) или в отдельное окно. Задание соответствующих режимов осуществляется командами Options ->Plot Display -> Inline и Options ->Plot Display -> Window. 

Вывод графики в отдельном окне полезен для отображения промежуточных результатов расчетов.

В системе Maple предусмотрено быстрое построение двумерных графиков функций с помощью команды контекстного меню, которое появляется при щелчке ПРАВОЙ кнопкой мыши на выражении в области вывода. (Для этого сначала в области ввода необходимо набрать команду, задающую функцию, и выполнить ее, т.е. нажать клавишу Enter). В контекстном меню следует выбрать команду Plots -> 2-D Plot, после чего Maple с помощью специальной команды smartplot() построит график функции, содержащейся в области вывода.

	[image: image20.png]



	Команда smartplot() использует при построении графика функции значения параметров по умолчанию. Но их можно изменить, теперь уже с помощью контекстного меню полученного графика. Обратите внимание на то, что содержимое строки главного меню и контекстной панели инструментов изменилось.

На график, построенный с помощью функции smartplot() можно добавить графики других функций простым перетаскиванием с помощью мыши их определения из области вывода в область графика. При этом, если необходимо оставить определения функции в области вывода, перетаскивание осуществляется с нажатой клавишей Ctrl. В противном случае перетаскиваемая выделенная часть будет удалена из области вывода.


Аналогичным перетаскиванием можно удалить какую-либо функцию из области графика. Для этого следует подвести указательмыши на линию графика функции и переместитьего за пределы рисунка. При этом в том месте рабочего листа,куда он будет перемещен, появится команда, задающая удаленную функцию.

	



	Основы редактирования. 


Операции редактирования содержатся в позиции главного меню Edit.

	Некоторые операции редактирования: 

	Undo Delete Ctrl+Z 
	Отменить последнюю операцию редактирования. 

	Cut Ctrl+X 
	Поместить выделенное в буфер. 

	Copy Ctrl+C 
	Скопировать выделенное в буфер. 

	Copy As Maple Text 
	Копирование выделения в буфер в формате Maple-текста. 

	Paste Ctrl+V <> 
	Вставить выделенное из буфера в документ. 

	Paste Maple Text 
	Вставить данные из буфера в формате Maple-текста. 

	Delete Paragraph Ctrl+Del 
	Стирание выделенных объектов. 

	Select All Ctrl+A 
	Выделение всех объектов документа. 

	Find... Ctrl+F5 
	Найти заданную текстовую или математическую строку. 

	Input Mode F5 
	Включение/выключение ввода текстов. 

	Split or Join 
	Разделение или объединение объектов. 

	Execute 
	Исполнение выделенных или всех строк. 

	Remove Output 
	Удаление вывода для выделенных или всех строк. 


	



	Сохранение результатов работы. 


Рабочие листы Maple V сохраняются в файлах с расширением msw. Существует возможность сохранить рабочий лист в файлах других форматов, указав в диалоге команде Save As соответствующий формат, либо воспользоваться командами подменю Export As: 

	Команда 
	Расширение 
	Описание формата 

	Plain Text 
	.txt 
	Обычный текстовый файл. 

	Maple Text 
	.txt 
	Текстовый формат Maple. 

	Latex 
	.tex 
	Формат издательской системы LaTeX. 

	HTML 
	.html 
	Формат HTML. 

	Maple Explorer 
	.tex 
	Формат для обозревателя Maple (позволяет просматривать готовые файлы Maple) 

	RTF 
	.RTF 
	Формат RTF (позволяет вставлять рабочие листы в документы MS Word с сохранением цветовой палитры) 


1.2 Пакеты расширений MAPLE V.
Некоторые функции системы MAPLE V помимо ядра могут находиться в стандартной библиотеке и в пакетах расширения, входящих в базовую поставку системы.

Пакеты в Maple используются для удобства организации работы пользователя. Пакет представляет собой набор команд для решения задач, относящихся к определенным разделам математики, или решения определенных задач графического представления информации, например, пакет finance служит для решения задач финансовой математики, в пакете stats собраны команды для статистической обработки результатов и т.д.

Перед использованием функций пакетов их надо загрузить отдельно или целым пакетом. Список пакетов расширения можно получить используя команду 
>?index[package] 

С помощью команды 
>?name_package 
можно получить информацию о любом пакете расширения и найти список входящих в него функций. 

Для обращения к функциям того или иного пакета используется его полная загрузка командой

>with(пакет) 
где в качестве параметра указывается имя соответствующего пакета. Может оказаться, что подключаемый пакет содержит команду с таким же именем, что и в ранее подключенном пакете. В этом случае Maple выдает сообщение о переопределении соответсвующей команды. Подключив пакет, в дальнейшем пользователь может вызывать все его команды, просто набирая их имя и требуемые для выполнения параметры прямо в области ввода.

Если небходимы несколько конкретных функций пакета, то вместо подключения всего пакета целиком можно подключить только эти требуемые функции, используя команду

>with(пакет,f1,f2,...) 
или 
>with(пакет,[f1,f2,...]) 
В дальнейшем загруженные команды также могут быть использованы ссылкой только на их имена, без указания пакета, в котором они находятся.

Если пользователь не желает, чтобы команда постоянно находилась в памяти, ее можно загрузить только на время ее выполнения, после чего она будет выгружена из памяти. Для этого следует указать ее полное имя, состоящее из имени пакета и имени самой команды, в следующем виде: 
>имя пакета[имя команды](...); 
При следующем обращении к команде ее необходимо снова загрузить одним из трех указанных способов.

Если пользователь не желает, чтобы при загрузке всего пакета (первый способ подключения) отображались все команды подключаемого пакета (список команд некоторых пакетов может занимать целую страницу), то команду with() следует завершить двоеточием (:), а не точкой с запятой.

Перечень пакетов расширений и их назначение можно просмотреть здесь
1.3 Работа со справочной системой Maple V.
Система Maple V имеет мощную и подробную справочную базу данных, расчитанную на удовлетворение всех запросов пользователя на справочную информацию.

В реализации Maple V R7 справочная база данных имеет очень удобную древообразную структуру контекстно-зависимого поиска. При этом в ходе поиска информации вначале указываются ее общие признаки, затем более частные - и так до пяти ступеней.

Основные операции по работе со справочной системой Maple V R7 сосредоточены в позиции главного меню Help (Справка).

	Она содержит следующие команды и операции: 

	Contexts 
	Включение раздела справки по контексту. 

	Help on Context Ctrl+F1 
	Оперативная справка по контексту. 

	Topic Search... 
	Предметный поиск по заданному образцу. 

	Full Text Search... 
	Предметный поиск с полным обзором текста справки. 

	History... <> 
	Вывод истории справочного поиска. 

	Save to Database... 
	Формирование базы данных. 

	Remove Topic... 
	Восстановление базы данных предметного поиска. 

	Using Help... 
	Справка по использованию справочной системы. 

	Ballon Help 
	Включение всплывающих "шпаргалок". 

	About Help 
	Вывод окна с информацией о системе. 


Другая система помощи онлайновая (online) позволяет вызвать нужную справку в командном режиме. Для этого достаточно набрать в командной строке слово help или ? с последующим указанием искомого слова, например:

>help sin
или
>? sin

В данном случае после нажатия клавиши Enter будет получена справка по функции sin. Такое обращение применяется для библиотечных функций и зарезервированных слов. Недостатком является то, что нужно знать имя оператора или функции, по которой ожидается получение справки.

При этом на экран дисплея будет выведено подробное сообщение (справка) на английском языке о назначении и правилах записи (синтаксисе) соответствующей функции, оператора или пакета применений.

Достаточно полезным средством является выделение и выбор примеров из справок. Для этого используется клавиша Ins, которой намечают начало и конец выделений. Можно также выделить пример, перемещая мышь с нажатой левой клавишей. Наконец, используя команду Copy Examples в позиции Edit главного меню окна справки, можно скопировать в буфер все примеры.

После этого, закрыв окно справки, можно с помощью команды Edit ->Paste перенести в него имеющиеся в буфере примеры. 

Таким образом, можно легко проверить работу примеров по любой функции системы. Как правило, дается несколько примеров на применение каждой функции так что общее число примеров трудно представить, поскольку число функций достигает двух тысяч восьмисот.

Помимо встроенных в ядро функций в систему входят дополнительные функции и пакеты прикладных программ. Чтобы получить помощь по ним, нужно ввести их имя после вопросительного знака. Например, чтобы получить помощь по функциям пакета расширения системы plots, достаточно ввести в командной строке:

> ?plots 

А чтобы найти полный перечень пакетов расширения, можно ввести команду:

>?index[package] 

Обратите внимание на то, что после этих обращений к справочной системе никакие знаки (двоеточие или точка с запятой) не ставятся. В конце каждой справки приводятся имена связанных с данным объектом слов, а также другие возможные формы получения справок. Используя их, можно более подробно познакомиться с возможностями системы.

Удобно в описываемой версии Maple V решен и вопрос о предоставлении оперативной контекстно-зависимой справки по любой функции. Достаточно указать ее маркером и нажать клавиши Ctrl + F1 (или, что не документировано, просто F1). Тут же будет выведено окно справки по данной функции. Можно также выделить интересующее вас слово и получить справку по нему.

1.4 Алфавит Maple-языка и его синтаксис.
Maple-язык является входным языком общения с системой Maple V и одновременно языком ее программирования.

Входящие в него средства (прежде всего операторы и функции) подобраны настолько полно и удачно, что при peшении подавляющего большинства типовых математических задач от пользователя не требуется знаний даже основ программирования. Достаточно составить aлгоритм решения нужной задачи и подобрать набор нужных для его реализации функций и иных средств Maple-языка.

Maple-язык один из самых мощных языков программирования математических задач, намного превосходящий по своим возможностям такие известные языки программирования, как Fortran, Algol, PL. Basic, Pascal и др. Это связано прежде всего с возможностью использования в его программных модулях почти 2800 операторов, команд и функций, входящих в ядро , основную библиотеку и пакеты расширения системы Maple V.
В тоже время относящаяся к традиционному программированию часть Maple-языка реализована с помощью довольно скромного набора специальных знаков и зарезервированных слов.

Maple-язык является как бы саморасширяющимся и легко адаптируемым к решению конкретных задач любого пользователя. Свыше 90% всех oпределений системы Maple V, в частности все пакеты расширений и огромная SHARE-библиотека пользователей, написаны на этом языке. Поэтому знание этого языка является определяющим в серьезном изучении системы Maple V. Ниже Maple-язык описывается как типичный язык программирования.

Алфавит Maple-языка содержит 26 малых латинских букв от а до z, 26 больших латинских букв (от А до Z), 10 арабских цифр (от 0 до 9) и 32 специальных символа (арифметические операторы +, -, *, /, знак возведения в степень ^) и др. Все они будут рассмотрены в данной главе. Имеется пять пар альтернативных символов:

 ^ и **
     [ и (|
    ] и |)
    { и (*
    } и *)
К специальным одиночным и составным знакам относятся элементы синтаксиса языка:

	; 
	Знак фиксации конца выражения с выводом результата на экран 

	: 
	Знак фиксации конца выражения, предотвращающий вывод результата на экран. 

	:= 
	Оператор присваивания (например, x:=4). 

	= 
	Оператор равенства для задания равенств и логических условий (например, a=b ), указания областей изменения переменных (например, i=1..5 ) и значений параметров - опций в функциях и командах (например, color=black ). 

	;; 
	Пустой оператор 

	:: 
	Указатель типа переменной (например. n::integer или z::complex ). 

	-> 
	Создание функции (пример. f:=(x)->tan(x) или g:=(x,y)->sin(x)+cos(y/2) ). 


Комментарии в программе задаются после символа # . В них допустимо использовать все символы кодовых таблиц, что важно при вводе русскоязычных комментариев, использующих символы кириллицы. Применение последних для идентификаторов (имен) объектов недопустимо.

Зарезервированные слова используются для создания условных выражений, циклов, процедур и управляющих команд. 

	Список зарезервированных слов: 

	! 
	# 
	error 
	catch 
	break 
	by 
	do 
	done 
	elif 
	else 

	end 
	fi 
	for 
	from 
	finally 
	if 
	in 
	next 
	od 
	proc 

	quit 
	read 
	return 
	save 
	stop 
	to 
	then 
	while 
	export
	description

	global 
	local 
	module 
	option 
	options 
	try 
	use 
	
	
	


К зарезервированным относятся также слова, используемые при работе с множествами (intersect, minus, union), логические опраторы (and, not и or) и оператор модуля mod. Зарезервированные слова имеют особый статус. Их нельзя использовать в качестве идентификаторов для переменных, функции, процедур и т.д.

Совокупность правил, по которым записываются определения всех объектов Maple-языка, называются его синтаксисом. Некоторые особенности синтаксиса полезно знать сразу, в начале освоения системы. Например, то, что знак - (минус) имеет двойное значение. Применительно к одному числу, переменной или выражению он меняет их знак. Однако два знака минус подряд (например, в записи --3) задавать нельзя. Другое назначение знака минус — создание операции вычитания, например, 5-2 или а-b.

Соответственно двойное назначение имеет и знак +, причем число без знака считается положительным, так что +5=5. 

При вводе действительных чисел с порядком для ввода порядка используется символ e (например 10е100 или 10е-100). Для изменения общепринятого приоритета вычислений используются круглые скобки, в них же задаются параметры функций и процедур. Более подробно синтаксис Maple-языка рассматривается ниже.

Некоторые операторы представлены двумя символами. Например оператор, присваивания переменным их значения ( : =) содержит двоеточие и знак равенства, а функциональный оператор, представляющий стрелку (- >), содержит знак минус (-) и "больше" (>). В таких операторах между символами недопустим знак пробела. Однако его можно использовать между отдельными частями выражений; так, (а+b)/с эквивалентно (а + b) / с.

1.5 Определение функций пользователя.
1) Один из наиболее простых способов задания функции пользователя - присвоение введенной функции (в виде выражения) некоторой переменной:
Name:=выражение
	[image: image23.png]



	Этот прием фактически означает операцию присваивания.
Заданный таким образом объект все же не является полноценной функцией пользователя. Прежде всего потому, что в нем используются только глобальные переменные (х и у). Их значения приходится определять заведомо, используя операцию присваивания. Подобные "функции" нальзя ввести в библиотеки Maple.


2) Более гибкий способ задания полноценных функций пользователя - использование функционального оператора ->. Его синтаксис:
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	name:=(x,y,...)->Выражение, 

где name -имя функции (без аргументов),
(x,y,...) - список формальных параметров функции,
Выражение - вид функции (некоторое выражение, зависящее от параметров (x,y,...)). 

Вызов функции осуществляется в виде name (x,y,...).Переменные, указанные в списке формальных параметров являются локальными. 


При подстановке на их место фактических параметров они сохраняют их значения только в теле функции Выражение. За пределами этой функции переменные с этими именами оказываются либо неопределенными, либо сохраняют ранее присвоенное значение. 

3) Еще один способ задания функции пользователя базируется на применении команды unapplay. Её синтаксис: 

name:=unapplay(expr, var1,var2,...), 

где name - имя функции (без аргументов),
expr - непосредственно выражение функции через аргументы var1,var2,... 

В качестве expr может быть использовано имя переменной, которой присвоено выражение, зависящее от var1,var2,... (в этом случае команда unapplay преобразует выражение в функцию). 
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	Обращение к функции осуществляется в виде name(var1,var2,...). Переменные , указанные в качестве формальных параметров являются локальными.
Замечание.Для задания сложных выражений можно использовать последовательное определение частей выражения с помощью простого присваивания (1) (при этом переменным не должно быть присвоено никакое значение), а затем, используя (2) или (3), определить сложную функцию, представляющую выражение от ранее определенных (в пункте(1)) выражений. 
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